Introduction

Visual WebGui Documentation
Introduction
Send Feedback

Glossary Item Box

Technical Documentation

Version 1.1
Gizmox LTD©2009. All Rights Reserved.


What is Visual WebGui?
Send Feedback
Introduction > What is Visual WebGui?

Glossary Item Box

What is Visual WebGui?

Visual WebGui is an open source web like desktop application platform incorporated with a RAD development framework over Visual Studio enabling web applications development using desktop like ultra productive( WinForms like) designer which can be accessed through multiple presentation layers (currently available DHTML, Silverlight and a smart client).

Visual WebGui (VWG) introduces a different approach to AJAX / Silverlight front-ends. While the trend is towards empowering the client (browser) with more capabilities, enabling direct consumption of services by client side objects and distributing processing between the client and the server, VWG adopts the On-Server WebModel computing approach where by service consumption and processing is handled on the server and human interaction is handled on the client. This model provides intrinsic benefits for enterprise applications since it provides additional measures of security and control which is not available on browser based solutions. This approach, called "Empty Client", employs de-coupled GUI components which decouple GUI logic from GUI presentation (rendering) and enable remoting of the display/input capture between the client (browser) and the server. It is this approach that provides an even greater benefit by enabling application logic (usually entailing both business and presentation logic) to be handled within one, stateful, object-oriented environment developed in a high level, OOP language such as C#, VB.Net or Java rather than a mix between Javascript and a server based language.

Using a homogeneous platform provides developers with immeasurable productivity benefits and enables developers to make better use of existing assets, knowledge and experience rather than requiring the steep learning curve of AJAX or Silverlight. VWG provides server side controls which behave like existing desktop application controls both in design time and in run-time. These controls manifest themselves as AJAX controls on the browser in run-time and look like their desktop counterparts. The architecture of the system is in no way limited to representing these base controls in their current "Desktop" look and feel since it makes use of de-coupled components. Our initial offering contains the popular Microsoft controls that are a basic part of any Windows based application. These controls provide a huge productivity benefit to web developers who lag behind their desktop behavior, while supporting the most common needs of desktop application developers without letting them down.

In addition the system is extremely extensible. VWG's SDK enables extending the framework by adding additional controls, changing themes/flavors (skins) in Silverlight case enabling Expression Blend capabilities, creating composite controls based on base controls and creating gateway components. Since ultimately VWG is an extension to the app servers context such as IIS/ASP.net, it can interoperate with client side and server side legacy code. This means that Visual WebGui UI can host and interoperate with existing HTML/Javascript client only controls or with embedded DOM objects such as Applets and ActiveX controls. Similarly existing web applications can interoperate with VWG components/forms/windows since they are in essence URLs like any other sharing the same application and session context.

VWG is the only available RAD tool to develop a fully blown, data-centric, enterprise-level Microsoft Silverlight applications. Choosing VWG Over silverlight the developer/designer is provided with over 60 Windows Forms controls and the tools to rapidly create an animated, cross-device, multimedia rich and fully customized Minority Report like Silverlight application.

Visual WebGui is a revolutionary concept. The revolution is making web development as simple as drag and drop, but without locking developers in. Developers can extend, customize, introp, and integrate easily. Visual WebGui revolution is allowing fast and economic porting of existing legacy desktop assets to web utilizing existing skill sets. The revolution is enabling a secured by design web architecture that allows enterprises, first time since the beginning of the web era, to go on web without security concerns.


What is Visual WebGui Over Silverlight?
Send Feedback
Introduction > What is Visual WebGui Over Silverlight?

Glossary Item Box

What is Visual WebGui Over Silverlight?

What is Silverlight

Silverlight is a new Web presentation technology that is created to run on a variety of platforms. It enables the creation of rich, visually stunning and interactive experiences that can run everywhere within browsers and on multiple devices and desktop operating systems. In consistency with WPF (Windows Presentation Foundation), the presentation technology in Microsoft .NET Framework 3.0 (the Windows programming infrastructure), XAML (eXtensible Application Markup Language) is the foundation of the Silverlight presentation capability.
You can read more about it here.

What is Visual WebGui

Visual WebGui (VWG) is an open source ?€?Web like desktop?€ application platform. It incorporates RAD development framework that integrates seamlessly into Visual Studio. VWG enables web applications development using desktop like ultra productive( WinForms like) drag & drop designer. Application built with VWG can be accessed through multiple presentation layers (currently available DHTML, Silverlight and a smart client).

What is Visual WebGui over Silverlight.

Visual WebGui over Silverlight is the only available RAD tool to develop a fully blown, data-centric, enterprise-level Microsoft Silverlight applications. Choosing VWG Over silverlight the developer/designer is provided with over 60 Windows Forms controls and the tools to rapidly create an animated, cross-device, multimedia rich and fully customized Minority Report like Silverlight application.

VWG over Silverlight is based on the VWG ?€?On-Server?€ WebModel concept. This means the entire application flow, UI logic and validations are developed and processed on the server while the browser serves as a ?€?display?€ for the output and a ?€?receptor?€ for user input. Once in run time mode, a VWG application is accessed by automatic downloading a 200K kernel,Nothing but that small kernel runs on client.

VWG over Silverlight uses Ajax uniquely optimized protocol (over standard HTTP / XML). Kernel is downloaded once after which only state and data changes are going back and forth as required. This results in a highly responsive application which utilizes fewer resources enabling servers to handle more concurrent users. An average round trip is made up of less than 1K of Meta data unaffected by application wight and size.

The On-Server WebModel utilizes a client side ?€?rendering?€ engine which communicates with the server over XMLHttp. The client never consumes data or services directly since all of the application logic, UI logic and data access is handled on the server. The client simply connects to the ?€?view?€ on the server and therefore never compromises security. Furthermore, since a proprietary protocol is used to correlate view state between the server and the client, it?€™s a greater challenge to override, eavesdrop or hack. The only data that is delivered to the client is data that can be viewed on the client meaning there is never any sensitive data that may be required for logic or validation beyond what is rendered and seen by the user on the screen.

VWG methodology has a real-world, field-proven track record for simplifying development and saving time and resources in DHTML application development. This is also true to Silverlight, VWG simplifies Silverlight line of business (LOB) development with a proven 90% cut in development time while it empowers it as a GUI for LOB applications.

It is currently the fastest method of choice for a migration path to Silverlight and it does it without losing any of Silverlight's rich capabilities - still allowing you to use Expression Blend for styling. There's no need for retooling, retraining or fighting to stay on the learning curve. Once you've made the simple transition you will be more productive than ever.

Many development shops are still sitting on the fence to see where Silverlight is going. Many say that if they had a default option for users who still haven't installed the Silverlight plug-in they would jump into Silverlight without hesitation. VWG allows for single development and dual deployment to either DHTML or Silverlight. This lets developers cater for all their users whether they have installed Silverlight or not. Both will be able to access the application, with the Silverlight userMany development shops are still sitting on the fence to see where Silverlight is going. Many say that if they had a default option for users who still haven't installed the Silverlight plug-in they would jump into Silverlight without hesitation. VWG allows for single development and dual deployment to either DHTML or Silverlight. This lets developers cater for all their users whether they have installed Silverlight or not. Both will be able to access the application, with the Silverlight users enjoying a richer GUI.

Gizmox, the company behind the Visual WebGui (VWG) open source platform, has been cooperating with Microsoft in the development of VWG server-empowered Silverlight. Visual WebGui over Silverlight is the extension to the Visual WebGui server that allows a VWG developer to use Microsoft Silverlight as there VWG application?€™s presentation layer.


Visual WebGui Server Extension
Send Feedback
Introduction > Visual WebGui Server Extension

Glossary Item Box

Visual WebGui Server Extension

Visual WebGui server extension is an IHTTPHandler (.NET's way of doing ISAPI filters) which provides an alternative HTTP pipe line that is designed to better fit the needs of web application development. Managing all resources and requests, Visual WebGui server extension provides an abstraction layer between the application code that is built upon the Visual WebGui SDK and the presentation layer that is the browser or any other remote presentation layer.

The following figure shows the desktop environment architecture:

The following figure shows how Visual WebGui implements the desktop architecture over HTTP:

Visual WebGui server extension is fully contained with in the web server (HTTPHandler) allowing Visual WebGui to be secured as normal web applications and managed the same way. Hosting WebGui applications does not require installation on the host machine and can be used as an assembly in the bin directory making Visual WebGui application deployment as simple as copying a few assemblies to the bin directory of the web application directory. The Visual WebGui server extension and the Visual WebGui communication mechanism reduces server resource usage and back office supporting servers resource usage making it possible to load more users on a single machine. Rendering very small output responses and parsing very small input requests, Visual WebGui server is extremely efficient on band width consumption.

Every SDK control owns resources that the Visual WebGui server can use to serve the presentation layer. Using a resource inheritance/overriding mechanism the Visual WebGui server can serve multiple devices and support themes for different Visual WebGui applications look and feel. Resources managed by the Visual WebGui server are automatically cached on the web server and the client browser. These resources are optimized to reduce bandwidth and for faster client responses. The Visual WebGui server handles layouting, incremental updating and event queues leaving the SDK control resources with the responsibility of drawing the designated client area and responding to client events (very similar to desktop oriented control tasks).

Visual WebGui server extension is separated by an interface layer from the SDK allowing the application code to be used also as an offline application (This feature is part of the enterprise edition SDK). As Visual WebGui applications are based on WinForms/Swing API they can be used to generate an offline version of the online version allowing offline and online to share code bases at the GUI level rather then only business logic. Using a provider design pattern for the data access layer both online and offline applications can share exactly the same UI.

Visual WebGui server extension can aggregate tracing and performance indicators to help developers identify application snags. Detailing up to the time the control rendered in the client browser all the information is gathered and can be analyzed saving time on debugging and monitoring. As Visual WebGui is basically an event driven environment tracing is done on this level, gathering information on event processing time and event triggered action as rendering.


Visual WebGui SDK
Send Feedback
Introduction > Visual WebGui SDK

Glossary Item Box

Visual WebGui SDK

WebGui SDK is what the developer uses when developing WebGui applications, containing most of WinForm/Swing components the WebGui SDK is a familiar ground for a WinForms / Swing developer. Fully supporting WinForms/Swing design time behavior, developers have the same "user experience" developing WebGui as in those two frameworks. WebGui developer works in an abstraction layer leaving communication and caching optimizations for the WebGui server. The WebGui Server optimizes the communication and cache based upon the SDK usage, meaning the developer does not need to deal with the underlining web plumbing.

WebGui SDK provides a full abstraction layer for developing web applications, developers do not need to work with the underlining web technology unless they need to extend the SDK or write different themes for applying different UI look and feel. When approaching to extend the SDK or write new themes the developer is left with plumbing and designing, as most of the activity is managed by the WebGui Server and the WebGui Client Kernel Services. The WebGui Client Kernel services provide services for cross browser capabilities, services for raising server events and changing client state, services for supporting generic features such as styling, context menus and more. The WebGui Client Kernel Services dramatically reduces the amount of time needed to extend and write WebGui resources.

WebGui SDK contains runtime classes which are used be the developer to build the application, design time classes which are used by the WebGui designer that has the same look and feel as WinForms/Swing design time behavior and a set of client embedded resources which are formatted in a defined way to support client side control behavior and multi device support.

WebGui SDK resources format are designed to enable easy adaptation to browser specific implementations, with special inheritance and overriding mechanism it enables to write common browser code once and to differentiate browser specific code by overriding or adding to inherited common code. Further more WebGui SDK resources can interact with WebGui client browser kernel services reducing the amount of code the developer has to manage when extending the SDK.

WebGui SDK does not reference WebGui Server objects. Instead WebGui SDK interacts with a set of common interfaces defining the relationship between a WebGui hosting provider and the WebGui SDK. This enables WebGui application to be hosted by different hosting providers. This architecture provides support for standalone desktop installations.

WebGui SDK supports a mechanism for themes and multi device support providing a robust mechanism to develop inside the WebGui SDK. By supporting a fall back mechanism very similar to that of the .NET framework resource fallback mechanism it is possible to create new set of resources that inherit there base resource set and overriding as needed. That way if you write a new WebGui theme you do not have to implement all the components but rather override only those components you want to override there design or client behavior. In the same manner when you implement a component resource supporting multiple devices you inherit the common base code and extend or create device specific implementation.


Design Differences Between Visual WebGui And

Visual WebGui Documentation
Design Differences Between Visual WebGui And
Send Feedback
Introduction > Design Differences Between Visual WebGui And

Glossary Item Box

Design Differences Between Visual WebGui And WinForms

The main difference between a WinForms application and a Visual WebGui application is the execution context. Visual WebGui being a platform for building web applications is a multi-threaded environment that needs to serve many users. While a WinForms application serves a single user on a dedicated machine.

A major built in difference between WinForms and Visual WebGui is the ShowModal method of the form object which in WinForms halts the execution of the code until the window is closed. In Visual WebGui the ShowModal method returns immediately and the developer must attach to the closed event to continue execution after the window is closed. This actually means that in Visual WebGui a modal dialog is only modal on the client side.

A side from the ShowModal method, designing a Visual WebGui application is pretty much the same as designing a WinForms application. Never the less Visual WebGui multi-threaded execution context comes with some best practices. Static members should be thread safe as multiple threads can access those members. Resources such as memory and database connections should be released as soon as possible. Server round-trips can be optimized by using Visual WebGui best practices in event handling. Visual WebGui update commands that are sent to the client to reflect changes made on the server can be optimized by using best practices.

Visual WebGui eliminates the request/response nature of web applications by exposing to the developer a fully event driven environment. Web developers usually create resources like connections at the page level knowing that when the request processing is done the resources will be released. As Visual WebGui does not have a concept of pages and requests, developers should treat an event handler method as a page. Meaning that if you have a button that has an event handler that should populate a ListView from the database. A connection should be opened at the beginning of the event handler method and closed at the end. Local method variables will automatically be released at the end of the method execution and this can be a great way of managing resource lifetime.

Another difference between Visual WebGui and WinForms is Gateways. Gateways are actually normal request processors that are processed in the context of the application. If for example you have a list that you like to open as a ready for a print HTML page, you use gateways in order to do so. Controls that need to support gateways implement the IGatewayControl that has one method that returns an IGatewayHandler that is responsible for processing the gateway request. This concept is equivalent to the IHTTPFactory and IHTTPHandler of the ASP.NET pipe line.


Visual WebGui Best Practices
Send Feedback
Introduction > Visual WebGui Best Practices

Glossary Item Box

Visual WebGui Best Practices

Control.Update() Method is used to redraw the control. Calling this method will add the whole control and its underlining object tree to the updating commands. Call this method only if there is an WebGui update bug and remember to remove it when that bug is fixed.

TabControl is an excellent way to enhance incremental updating and to reduce browser processing loads.TabControl can be logical which means that the tabs are not visible and tab switching is done programmatically. This way you can enjoy the TabControl performance without actually seeing the TabControl.

A WebGui application runs in the server session. This means that every user that uses the WebGui created application has a running application in the server session. Unlike desktop programming which is not intend to be executed in this manner you should be aware of which objects you are keeping alive and if they can be unreferenced and recreated when needed.

Static variables are shared between users and should be thread safe.

Using dialog return values should be used through the closed event (Like shown in the WebGui demo movie).

Event handlers should be used carefully. Attaching an event handler to an event causes the WebGui server to force post back on every time this event is fired. Consider using the queued version of this event or removing the need for this event if possible.

Events that do not cause user interface changes are potentially good candidates for rewriting as queued events.

WebGui automatically detects GUI changes and determines the best updating method. Updating the GUI controls should be done with as little changes as possible.

Example:
If you want to update a list view item. You should prefer updating the specific list view item than reloading the entire list. WebGui will detect the change and create an update command suited for updating the client. Updating all the list view items will cause a full redraw of the list.


Installation Prerequisites

Visual WebGui Documentation
Installation Prerequisites
Send Feedback
Installation > Installation Prerequisites

Glossary Item Box

Visual WebGui SDK

.NET Framework | The equivalent .Net framework (.NET 2.0/3.5)
Development Environment | MS Visual Studio 2005/2008, MS Visual Studio Express or Sharp Develop
Web Server | IIS/Mono

Visual WebGui Silverlight SDK

.NET Framework | The equivalent .Net framework (.NET 2.0/3.5)
Development Environment | MS Visual Studio 2005/2008, MS Visual Studio Express or Sharp Develop
Web Server | IIS/Mono
Silverlight | RC0

Visual WebGui Express Studio

.NET Framework | The equivalent .Net framework (.NET 2.0/3.5)
Development Environment | MS Visual Studio Express 2008
Web Server | IIS/Mono

Visual WebGui Professional Studio

.NET Framework | The equivalent .Net framework (.NET 2.0/3.5)
Development Environment | MS Visual Studio 2005/2008
Web Server | IIS/Mono
Silverlight | RC0


Installing The Visual WebGui On Visual Studio 2005

Visual WebGui Documentation
Installing The Visual WebGui On Visual Studio 2005
Send Feedback
Installation > Installing The Visual WebGui On Visual Studio 2005

Glossary Item Box

Visual Studio 2005 has created a new concept for developing web applications that takes the page based architecture one step further by creating a project that does not play well with the Visual WebGui concept of no pages.

You could actually create a Visual WebGui assembly and reference it from the new ASP.NET project but we prefer to do it using the good old web project concept. It is a good thing that Microsoft has created an update to enable developers to work using the previous concept it less good that it takes a while to install it and it requires two different updates. There is a bright side to this issue and it is that you will only have to do it once. Meaning that next time you install Visual WebGui, you want have to install the update and it will take less time. The Visual WebGui installation refers you to the Microsoft update downloading URLs so you do not have to worry about finding those updates.

After installing both updates you will be able to install Visual WebGui. The installation takes a while as for some reason the Visual Studio template adding process takes a minute or two. Now you are ready to start developing with Visual WebGui as the installation has installed both runtime assemblies and design time assemblies needed. If you are planning on using IIS instead of the internal debugging server you will have to register the “.wgx” extension.

Installing the Web Application update (Visual Studio 2005)

Visual WebGui requires Microsoft's Web Application update in for the .NET 2.0 installations. The Web Application update enables Visual Studio 2005 to create Visual Studio 2003 web applications, which are more intuitive when working with desktop concepts. The Visual Studio 2005 web project is built more tightly around the concepts of pages and as such is less suitable. That said you can still create an ASP.NET project based on the new concept and to apply Visual WebGui to it. This can be done by implementing Visual WebGui element with in the project or mapping to an external project which is the recommended scenario as you get the good of both worlds. Installing Visual WebGui for .NET2.0 will check if you have this update installed and direct you to downloading these updates if missing.


Installing The Visual Webgui Wgx Extension

Visual WebGui Documentation
Installing The Visual Webgui Wgx Extension
Send Feedback
Installation > Installing The Visual Webgui Wgx Extension

Glossary Item Box

Visual WebGui by default requires an extension registered in the IIS which is also called a script map. In order to install the “.wgx” extension you need to go to the IIS management console. Right click your working web site as shown in the following image and click the properties menu item.

After receiving this dialog select the home directory tab and click on the configuration button.

After clicking the configuration button you should receive this window which has all the mapped script maps. Double click the “.aspx” extension map.

You should be seeing this dialog.

From the above dialog copy the executable path (For some reason this dialog does not support keyboard commands so you will have to use the right click options to copy the path). Notice that the executable path contains the .NET framework version. You should adjust it to the framework you are planning to use. You can use both but you have to manually set the extension to a different value for different web directories.

Return to the first dialog and click the add button. Paste the executable path in and set the extension to be “.wgx”. Enter the verbs as appear in this dialog or change the radio buttons to the all verbs option. It is very important that you leave the “Check that file exists” unchecked as Visual WebGui does not use actual pages. Click OK on all the opened dialogs and now you have successfully installed the “.wgx” extension.


Version comparison

Visual WebGui Documentation
Version comparison
Send Feedback
Installation > Version comparison

Glossary Item Box

This table displays the difference between Visual WebGui different installation packages.

 | VWG SDK | Express Studio | Professional Studio
DHTML Runtime |  |  |
Silverlight Runtime Ready |  | In the future |
Development Environment | VS 2005/2008 | VS Express 2008 | VS 2005/2008
VWG Designer | - |  |
VS Integration | - | - |
License | LGPL | LGPL | 30-day Evaluation/Commercial


Index (How To)

Visual WebGui Documentation
Index (How To)
Send Feedback

Glossary Item Box

How To Display Dynamic Images Stored In A Database In A Visual Webgui Application

How To Use Visual Webgui Gateways

How To Use Custom Style In A Visual Webgui Control

How To Use Visual Webgui New Asp.net Integrated Rapid Wrapper Capabilities

How To Migrate A Winforms Application To The Web Using Visual Webgui

How To Develop A Visual Webgui Application With Out The Use Of A Designer

Performing Automated Tests With Visual Webgui

Visual Webgui Control Silverlight Extender

How To Embed A Visual Webgui Form In An Asp.net Application

Manually Wrapping Asp.net Controls With Out The Use Of Visual Webgui Designer


How To Display Dynamic Images Stored In A Database In A Visual Webgui Application

Visual WebGui Documentation
How To Display Dynamic Images Stored In A Database In A Visual Webgui Application
Send Feedback
How To > How To Display Dynamic Images Stored In A Database In A Visual Webgui Application

Glossary Item Box

In this “How to” we will learn how to display dynamic images stored in a database in a Visual WebGui application.

You should be familiar by now with What is Visual WebGui and What is Visual WebGui over Silverlight. It’s recommended that you read “How to create a Visual WebGui Silverlight application”.

Prior to version 6.1.3, in case you wanted to display dynamic images stored in a database you had to create your own Gateway that will provide you with a virtual URL to the image. As of version 6.1.3 we can use DatabaseResourceHandle to create a virtual URL to the image.

DatabaseResourceHandle provides a base class that enables you to create a smart database resource handle. The DatabaseResourceHandle implements StaticGatewayResourceHandle, IStaticGateway.

I’ve created a new Database with a table that holds images in it.

Let’s create a new Visual WebGui application.

First thing you need to do is to enable Visual WebGui this action allows you to use the VWG Visual Studio integration that will allow you to run your VWG application as a silverlight application. To do so right click on the project and select the "Enable Visual WebGui". You will be prompt to reload the project and save the WebConfig.

Next, we’ll add three PictuerBox to our form.

Now, we’ll add a new class named DBPictureResourceHandle

DBPictureResourceHandle will inherit from DatabaseResourceHandle

C# Copy Code
public class DBPictureResourceHandle: DatabaseResourceHandle

We will add a constructor to our class.

C# Copy Code

public DBPictureResourceHandle()

{

}

public DBPictureResourceHandle(int intImageId)

: base(intImageId.ToString())

{

}

Next, we’ll override the GetConnection function that will set the connection to our Database.

C# Copy Code

protected override IDbConnection GetConnection()

{

return new SqlConnection(@"Data Source=DEVSRV\SQLEXPRESS;Initial Catalog=ImageTest;Integrated Security=True;");

}

We will also override the GetDataReader function to return a Data reader according to a query that we created.

C# Copy Code

protected override IDataReader GetDataReader(IDbConnection objConnection, string strQualifier)

{

SqlCommand objCommand = new SqlCommand("SELECT Image AS [Content], 'image/jpeg' AS ContentType FROM Images WHERE (Id = @Id)", (SqlConnection)objConnection);

objCommand.Parameters.Add(new SqlParameter("Id", strQualifier));

return objCommand.ExecuteReader();

}

Next, we will override the UseAuthentication property to allow us decide if the Url will require an authentication or not. For the first one we will not use authentication.

C# Copy Code

protected override bool UseAuthentication

{

get

{

return false;

}

}

Let’s open the Form1 in our application and add a button and two picture boxes.

On the button click event we will set the image to the picture box. We’ll add an int member called mPicId that will be the picture id that we want to display and will change every time we click the button.

C# Copy Code

int mPicId = 0;

private void button1_Click_1(object sender, EventArgs e)

{

mPicId++;

pictureBox1.Image = new DBPictureResourceHandle(mPicId);

}

ow we can run our Visual WebGui application but first let set the application entry point. Right click on form on and select "Set as start form" option.

Ok let’s run our application and see the result.

Now, we’ll create another ResourceHandle but this time it will require authentication. Create a new class named

C# Copy Code
DBPictureResourceHandleAuth and copy the

DBPictureResourceHandle to it. Change the UseAuthentication to return true.

protected override bool UseAuthentication

{

get

{

return true;

}

}

Next, we’ll set the second picture box to use the DBPictureResourceHandleAuth.

C# Copy Code

public Form1()

{

InitializeComponent();

pictureBox2.Image = new DBPictureResourceHandleAuth(1);

}

Let’s run the application and see the result.

Now, let’s see how well the authentication works. To get the URL of the image I use the IE Developer Toolbar. Open it and select the first PictureBox without the authentication and copy the image URL from the value column.

Open a new browser and paste the URL there and you will see the image.

Now do the same thing with the other PictureBox with the authentication and past the URL in a new browser. You will get a server error Session authentication failed.

This is happens because when UseAuthentication is set to true we add the session guid to the URL.

You can override the authentication mechanism by doing this:

Adding a constructor that will get a token.

C# Copy Code

public DBPictureResourceHandleAuth(int intEmployeeID, string strToken)

: base(intEmployeeID.ToString(), strToken)

{

}

"FONT-SIZE: 10pt; BACKGROUND: white; COLOR: black; FONT-FAMILY: courier new"> "FONT-SIZE: 10pt; BACKGROUND: white; COLOR: black; FONT-FAMILY: courier new">

Overriding the authentication method

protected override void Authenticate(IDbConnection objConnection, string strToken)

{

if (strToken != "dd")

{

throw new HttpException(401, "The token must be 'dd'...");

}

}

And using the new constructor to create the instance.

C# Copy Code
pictureBox2.Image = new DBPictureResourceHandleAuth(1, "dd");

To summarize:
We have seen how to use Visual WebGui DatabaseResourceHandle and we used it to display dynamic images form a database. We create a DatabaseResourceHandle without authentication and seen how to get the URL and re use it. And we’ve seen how to create an authenticated DatabaseResourceHandle that can not be used unless the right token is given.


How To Use Visual Webgui Gateways

Visual WebGui Documentation
How To Use Visual Webgui Gateways
Send Feedback
How To > How To Use Visual Webgui Gateways

Glossary Item Box

In this article we are going to learn how to use Visual WebGui Gateways. Gateways are Visual WebGui way to declare virtual URLs that are handheld by a control according to declared actions.
This topic assumes that you have some basic knowledge of Visual WebGui.

Up until version 6.2 Visual WebGui Gateways were a hard pill to swallow. What we’ve done was to simplify the implementation of Gateways.

Important: The new implementation of IGatewayComponent conflicts with the previous IGatewayControl interface. By default any control that implements an IGatewayControl will not be able to use the new IGatewayComponent interface for backwards compatibility reasons. The best practice is to gradually convert your IGatewayControl implementations to the new IGatewayComponent interface, which in most cases will mean that you will override the ProcessGatewayRequest method that is implemented by default in the Visual WebGui base classes as a overridable virtual method.

We’ve added a new interface IGatewayComponent that holds one method declaration ProcessRequest.

C# Copy Code

public interface IGatewayComponent

{

/// <summary>

/// Provides a way to custom handle requests.

/// </summary>

/// <param name="objContext">The request context.</param>

/// <param name="strAction">The request action.</param>

void ProcessRequest(IContext objContext, string strAction);

}

RegisteredComponent now inherits from IGatewayComponent and implements the ProcessRequest Method.

C# Copy Code

void IGatewayComponent.ProcessRequest(IContext objContext, string strAction)

{

// Trt to get the gateway handler

IGatewayHandler objGatewayHandler = ProcessGatewayRequest(objContext.HttpContext, strAction);

if (objGatewayHandler != null)

{

objGatewayHandler.ProcessGatewayRequest(objContext, this);

}

}

the ProcessRequest method calls the ProcessGatewayRequest method. This method returns a NotImplementedGateway by default.

C# Copy Code

protected virtual IGatewayHandler ProcessGatewayRequest(HttpContext objHttpContext, string strAction)

{

return new NotImplementedGateway(strAction);

}

This allows you to override the ProcessGatewayRequest method and return your own IGatewayHandler.

Because RegisteredComponent now inherits from IGatewayComponent every control in Visual WebGui out of the box controls and every control that you will create will implement the IGatewayComponent allowing you just to override the ProcessGatewayRequest and having your Gateway much faster then you used to.

Lets see how this works.

Let’s create a new custom control PieControl that will display a dynamic pie chart image.

Our control will inherit from “PictureBox” and will display the pie chart image. We will add two properties.
The first is an array of type int “Values” that will hold the values of our pie chart.
The second is an array of type string “Labels” that will hold the pie chart section labels.

C# Copy Code

public class PieControl : PictureBox

{

private int[] dataValues = new int[]{};

private string[] dataLabels = new string[]{};

public int[] Values

{

get

{

return dataValues;

}

set

{

dataValues = value;

}

}

public string[] Labels

{

get

{

return dataLabels;

}

set

{

dataLabels = value;

}

}

}

Next we will override the ProcessGatewayRequest function. In our control we create an image using the values and the labels and randomly selected colors .

C# Copy Code

protected override IGatewayHandler ProcessGatewayRequest(HttpContext objHttpContext, string strAction)

{

// If is "graph" action print a graph to the response, otherwise let the base class handle the request.

if (strAction == "graph")

{

// find the total of the numeric data

float total = 100;

int width = 300;

string title = "What do we eat and drink?";

int iLoop = 0;

// we need to create fonts for our legend and title

Font fontLegend = new Font("Verdana", 10), fontTitle = new Font("Verdana", 15, FontStyle.Bold);

// We need to create a legend and title, how big do these need to be?

// Also, we need to resize the height for the pie chart, respective to the

// height of the legend and title

const int bufferSpace = 15;

int legendHeight = fontLegend.Height * (dataValues.Length + 1) + bufferSpace;

int titleHeight = fontTitle.Height + bufferSpace;

int height = width + legendHeight + titleHeight + bufferSpace;

int pieHeight = width; // maintain a one-to-one ratio

// Create a rectange for drawing our pie

Rectangle pieRect = new Rectangle(0, titleHeight, width, pieHeight);

// Create our pie chart, start by creating an ArrayList of colors

ArrayList colors = new ArrayList();

Random rnd = new Random();

for (iLoop = 0; iLoop < dataValues.Length; iLoop++)

colors.Add(new SolidBrush(Color.FromArgb(rnd.Next(255), rnd.Next(255), rnd.Next(255))));

float currentDegree = 0.0F;

// Create a Bitmap instance

Bitmap objBitmap = new Bitmap(width, height);

Graphics objGraphics = Graphics.FromImage(objBitmap);

SolidBrush blackBrush = new SolidBrush(Color.Black);

// Put a white backround in

objGraphics.FillRectangle(new SolidBrush(Color.White), 0, 0, width, height);

for (iLoop = 0; iLoop < dataValues.Length; iLoop++)

{

objGraphics.FillPie((SolidBrush)colors[iLoop], pieRect, currentDegree,

dataValues[iLoop] / total * 360);

// increment the currentDegree

currentDegree += Convert.ToSingle(dataValues[iLoop]) / total * 360;

}

// Create the title, centered

StringFormat stringFormat = new StringFormat();

stringFormat.Alignment = StringAlignment.Center;

stringFormat.LineAlignment = StringAlignment.Center;

objGraphics.DrawString(title, fontTitle, blackBrush,

new Rectangle(0, 0, width, titleHeight), stringFormat);

// Create the legend

objGraphics.DrawRectangle(new Pen(Color.Black, 2), 0, height - legendHeight, width, legendHeight);

for (iLoop = 0; iLoop < dataValues.Length; iLoop++)

{

objGraphics.FillRectangle((SolidBrush)colors[iLoop], 5,

height - legendHeight + fontLegend.Height * iLoop + 5, 10, 10);

objGraphics.DrawString(dataLabels[iLoop], fontLegend, blackBrush,

20, height - legendHeight + fontLegend.Height * iLoop + 1);

}

// display the total

objGraphics.DrawString("Total: " + Convert.ToString(total), fontLegend, blackBrush,

5, height - fontLegend.Height - 5);

// Since we are outputting a Jpeg, set the ContentType appropriately

HttpContext.Current.Response.ContentType = "image/jpeg";

// Save the image to a file

objBitmap.Save(HttpContext.Current.Response.OutputStream, ImageFormat.Jpeg);

// clean up...

objGraphics.Dispose();

objBitmap.Dispose();

return null;

}

else

{

return base.ProcessGatewayRequest(objHttpContext, strAction);

}

}

}

To focus you to the most impotent part of the function where we save the result to the out put stream.

C# Copy Code

// Since we are outputting a Jpeg, set the ContentType appropriately

HttpContext.Current.Response.ContentType = "image/jpeg";

// Save the image to a file

objBitmap.Save(HttpContext.Current.Response.OutputStream, ImageFormat.Jpeg);

In the constructor we will set the image value to a new GatewayResourceHandle that will return a resource handel using our ProcessGatewayRequest method.

C# Copy Code

public PieControl()

{

this.Image = new GatewayResourceHandle(new GatewayReference(this, "graph"));

this.SizeMode = PictureBoxSizeMode.Normal;

}

Now that we have our control lets us it in our application. Open Form1 and add the control. Set the values 10,20,30,15,5,20 and labels "Fish","Meat","Milk","Cookies","Wine","Eggs".

Next Let’s run the application and this what we plan to see.

To summarize:
We’ve seen how to use the new Visual WebGui Gateway implementation technic using the IGatewayComponent that simplifies Gateways to just overriding one function and adding your code to it. This will help you create and customize your controls with virtual URLs.


How To Use Custom Style In A Visual Webgui Control

Visual WebGui Documentation
How To Use Custom Style In A Visual Webgui Control
Send Feedback
How To > How To Use Custom Style In A Visual Webgui Control

Glossary Item Box

In this “How to” we are going to learn how to use “Custom Style” in a Visual WebGui Control.
This topic assumes that you have some basic knowledge of Visual WebGui and How to create a Visual WebGui Custom control.

Custom style allows you to inherit from a control and and give it new looks and behaviors while keeping the option to use the original control look and feel. We are going to create Watermark text box from a plain TextBox using the Custom Style. Watermark text box is a text box the until the user enters a text there is a message that appears like like this

Lets Open VS 2008 create new Visual WebGui project.

Add a new folder named “Controls” and add a new Custom control named WatermarkTextBox.

Now we will add to our control a new string property Message

C# Copy Code

private string mstrMessage = "Write text here...";

public string Message

{

get

{

return mstrMessage;

}

set

{

if (mstrMessage != value)

{

mstrMessage = value;

this.Update();

}

}

}

Next we will add to the RenderAttributes the rendering of the Message property.

C# Copy Code

protected override void RenderAttributes(IContext context, IAttributeWriter writer)

{

base.RenderAttributes(context, writer);

writer.WriteAttributeString("Message", this.Message);

}

Lets add two JS functions .WatermarkTextBox_Focus will be raised when the control gets focus and will clear the watermark. WatermarkTextBox_Blur will be raised when the control loses the focus and if text box is empty the Watermark will appear again.

C# Copy Code

function WatermarkTextBox_Focus(strGuid,objInput,objWindow)

{

if(Web_IsAttribute(objInput,"vwgiswatermark","1",true))

{

objInput.value = "";

objInput.setAttribute("vwgiswatermark","0");

}

TextBox_Focus(strGuid,objInput,objWindow);

}

function WatermarkTextBox_Blur(strGuid,objInput,objWindow)

{

if(objInput.value=="")

{

objInput.value = Data_GetAttribute(strGuid,"Message","");

objInput.setAttribute("vwgiswatermark","1");

TextBox_Change(strGuid,"",objWindow);

}

else

{

TextBox_Change(strGuid,objInput.value,objWindow);

}

}

Next we will create the control XSLT that will be used when in Watermark style mode.

XSL Copy Code
<xsl:template match="WC:Tags.TextBox[@Attr.CustomStyle='Watermark']" mode="modContent">

<xsl:attribute name="Class">TextBox-Control</xsl:attribute>

<INPUT type="text"

onkeydown="mobjApp.TextBox_KeyDown('{@Id}','{@ValidatorMask}',window,this,event)"

onblur="mobjApp.WatermarkTextBox_Blur('{@Id}',this,window)"

onfocus="mobjApp.WatermarkTextBox_Focus('{@Id}',this,window)"

dir="{$dir}" tabindex="{@Attr.TabIndex}" class="TextBox-Input Common-FontData" id="TRG_{@Id}" maxlength="{@MaxLength}" value="{@Attr.Value}" vwgiswatermark="0" vwgeditable="1" vwgfocus="1">

<xsl:if test="not(@Value)">

<xsl:attribute name="value">

<xsl:value-of select="@Message"/>

</xsl:attribute>

<xsl:attribute name="vwgiswatermark">1</xsl:attribute>

</xsl:if>

<xsl:call-template name="tplSetDisabled" />

<xsl:call-template name="tplTextBoxStyle" />

<xsl:if test="@Attr.ReadOnly='1'">

<xsl:attribute name="readonly">true</xsl:attribute>

</xsl:if>

<xsl:call-template name="tplAttachTextBoxEvents" />

</INPUT>

</xsl:template>

This line match="WC:Tags.TextBox[@Attr.CustomStyle='Watermark']" checks if the control is in Watermark mode if true the control will be renderd with this template and if not as a regular TextBox.

On the Input element we registered to the onblure an onfocus events with the JS methods that we created before that will show and hide the Watermark.

In the remove this line so the control will use the original TextBox template if no custom style is set.

[MetadataTag("WaterMarkTextBox.Controls.WatermarkTextBox")]

Open Form1 and drag the Watermark control on it, and set the Custom style property to “Watermark”.

To allow the VWG access to the control resources we need to register the control. Open the project property page and select the registration section. In the controls click the add control button and select the WatermarkTextBox.

Next right click on Form1 and select “Set as start form” this will set the start page in the web section of the project property page.

Let’s run our application and see the DHTML control.

Lets start the Silverlight part of the control. Lets add a new project a Visual WebGui Silverlight control library named “WaterMarkTextBox.Controls.Silverlight”.

Add a new class named WaterMarkTextBox and set it to inherit from BindableTextBox.

C# Copy Code
public class WaterMarkTextBox : BindableTextBox

We will add two members bool mblnIsFocused that states if the control is focused or not, and TextBlock mobjMask that will display the Watermark text (I’m not using the TextBox itself because I don’t want to be bothered with the events the will be raised by it).

C# Copy Code

#region Members

private bool mblnIsFocused = false;

private TextBlock mobjMask = null;

#endregion Members

In the constructor we are going to register to TextChanged, GotFocus and LostFocus events and use them to show or hide the Watermark.

public WaterMarkTextBox()

{

this.TextChanged += new TextChangedEventHandler(OnTextChanged);

this.GotFocus += new RoutedEventHandler(OnGotFocus);

this.LostFocus += new RoutedEventHandler(OnLostFocus);

}

Now we will create a method that will show and hide the mobjMask TextBlock according to the user action and control status. When the user set focus to the control the Watermark disappears and the user set’s the focus out side of the control the and no text was entered the Watermark reappears.

C# Copy Code

private void UpdateMask()

{

if (mobjMask != null)

{

if (this.Text == string.Empty && !mblnIsFocused)

{

mobjMask.Visibility = Visibility.Visible;

mobjMask.Text = BindingManager.GetAttribute(this, "Message", "Write text here...");

}

else

{

mobjMask.Visibility = Visibility.Collapsed;

}

}

}

Next in the OnApplyTemplate method we will set the mobjMask to the MaskElement that the TextBox template uses for the password and we will use it to display the Watermark text.

C# Copy Code

public override void OnApplyTemplate()

{

base.OnApplyTemplate();

mobjMask = this.GetTemplateChild("MaskElement") as TextBlock;

if (mobjMask != null)

{

mobjMask.Opacity = 0.6;

UpdateMask();

}

}

Now we will implement the events that we registered to in the constructor. We will set the mblnIsFocused according to the event.

C# Copy Code

private void OnGotFocus(object sender, RoutedEventArgs e)

{

mblnIsFocused = true;

UpdateMask();

}

private void OnLostFocus(object sender, RoutedEventArgs e)

{

mblnIsFocused = false;

UpdateMask();

}

private void OnTextChanged(object sender, TextChangedEventArgs e)

{

UpdateMask();

}

Last but not least we will connect the DHTML control to the silverlight control by adding an attribute to the DHMTL control.

C# Copy Code

[SilverlightControl("WaterMarkTextBox.Controls.Silverlight.WaterMarkTextBox, WaterMarkTextBox.Controls.Silverlight, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", "Watermark")]

public partial class WatermarkTextBox : TextBox

{

Ok let’s run our application but this time as a Silverlight application. Open the project property page and select the deployment section. Enable Silverlight by checking the checkbox.

Add a reference to the VWG Silverlight server.

Run the application and change the extension to swgx to see the Silverlight version.

To summarize:
We have seen how to use Visual WebGui Custom style template. This will enable you to broaden your control library and customize your controls and application.


How To Use Visual Webgui New Asp.net Integrated Rapid Wrapper Capabilities

Visual WebGui Documentation
How To Use Visual Webgui New Asp.net Integrated Rapid Wrapper Capabilities
Send Feedback
How To > How To Use Visual Webgui New Asp.net Integrated Rapid Wrapper Capabilities

Glossary Item Box

In this how to you will learn how to use the new Visual WebGui ASP.Net wrapper capabilities. This ability opens a new way for a Visual WebGui programmer to develop richer and even more customizable applications then before. The wrapper allows you to use third party ASP.Net components or your own ASP.Net components in Visual WebGui as fully integrated controls just like the Visual WebGui out of the box controls.

In our demo we will wrap Dundas charts and use them in a Visual WebGui application.

First let's create a new Visual WebGui application:

Right click the solution and click Enable Visual WebGui:

Add the necessary reference to Dundas assembles:

Right click the project and click "Add ASP.NET Wrapper" control:

From the ASP.NET wrapper wizard select the Dundas Chart control and give it a name "DundasChart":

After clicking the OK button you will get a new wrapper class generated:

Because Dundas chart control renders images it needs a fixed size to relay on, otherwise you will get an error indicating that Dundas chart control does not support non pixel dimensions.
To force the wrapper to pass absolute dimensions you need to override the IsFixedSize property in the DundasChart.cs fileas following:

C# Copy Code

protected override bool IsFixedSize

{

    get

    {

        return true;

    }

}

The current wrapper generator does not work out ambiguous properties well and that still is left to be hand fixed, until the next version release.
After you compile the project you will get a list of warnings regarding ambiguous properties. Fix those warnings by changing the names of the properties / methods or
simply mark out the conflicting code:

After you compile the project and you open the Form1.cs designer, you will get the new wrapper in the toolbox, like this:

Now you can drag the new wrapper control to the form which will put in a place holder like this:

The new wrapper allows you to initialize the control in two ways. The first is by using a reference to an ASCX file.
Add a new WebUserControl1.ascx to the project

And in that ASCX you can add the control code and set it;’s initialization.

In this demo we will paste in the current code which will initialize the Dundas chart so we will be able to just insert data from code (This code is taken from a Dundas sample)

HTML Copy Code

<%@ Control Language="C#"%>

<%@ Register TagPrefix="dcwc" Assembly="DundasWebChart" Namespace="Dundas.Charting.WebControl" %>

<dcwc:chart id="hosted_control_id" runat="server" Height="796px" Width="712px"

    BackColor="#F3DFC1" Palette="GrayScale" backgradienttype="TopBottom"

    borderlinewidth="0" borderlinecolor="181, 64, 1"

    imageurl="~/TempImages/ChartPic_#SEQ(300,3)">

    <legends>

        <dcwc:legend LegendStyle="Row" AutoFitText="False" DockToChartArea="Default" Docking="Bottom" DockInsideChartArea="False" Name="Default" BackColor="Transparent" Font="Trebuchet MS, 8.25pt, style=Bold'></dcwc:legend>

    </legends>

    <chartareas>

        <dcwc:chartarea Name="Default" BorderColor="64, 64, 64, 64" BackGradientEndColor="White" BackColor="OldLace" ShadowColor="Transparent" BackGradientType="TopBottom">

            <area3dstyle yangle="10" perspective="10" xangle="15" rightangleaxes="False" wallwidth="0" clustered="True"></area3dstyle>

            <axisy linecolor="64, 64, 64, 64" labelsautofit="False">

                <labelstyle font="Trebuchet MS, 8.25pt, style=Bold'></labelstyle>

                <majorgrid linecolor="64, 64, 64, 64"></majorgrid>

            </axisy>

            <axisx linecolor="64, 64, 64, 64" labelsautofit="False">

                <labelstyle font="Trebuchet MS, 8.25pt, style=Bold'></labelstyle>

                <majorgrid linecolor="64, 64, 64, 64"></majorgrid>

            </axisx>

        </dcwc:chartarea>

    </chartareas>

</dcwc:chart>

To use an external file insert a path to your code (ASCX file) in the ControlCode property using the following format:  “/[Assembly Resource Name]”

The second way is to past the same code in the ControlCode editor as shown in this picture.

Now we can add a Visual WebGui button to the form and attach its click event to the following code (This code is taken from a Dundas sample)

C# Copy Code

 string[] charts = { "Column", "Spline", "StepLine", "Spline" };

        Random rnd = new Random();

        private void button1_Click(object sender, EventArgs e)

        {

            // Add a series to the chart

            Series series = myChart1.Series.Add("Series " + (myChart1.Series.Count + 1).ToString());

            series.ChartArea = "Default";

            series.ChartType = charts[myChart1.Series.Count - 1];

            series.BorderWidth = 2;

            int j = 0;

            int MaxPoints = 10;

            while (j++ < MaxPoints)

                series.Points.Add(rnd.Next(5, 20));

            myChart1.Update();

        }

Open your web.config and add to it the Dundas http handler as following:
XML Copy Code
<add path="ChartAxd.axd" verb="*" type="Dundas.Charting.WebControl.ChartHttpHandler" validate="false"/>

Set Form1 to be the startup form using the right click as following:

Run the application and you will get the following screen:

After you click the button our code will refresh the chart and display the following view:

As you can see it is very simple to create a wrapper using the new ASP.NET wrapper feature. This is the first version (6.2.1) of Visual WebGui which has this capability and we intend to simplify the procedure even more.

You can read the original how to here

-- Eyal Albert @ Eyal.Albert (at) Gizmox.com


How To Migrate A Winforms Application To The Web Using Visual Webgui

Visual WebGui Documentation
How To Migrate A Winforms Application To The Web Using Visual Webgui
Send Feedback
How To > How To Migrate A Winforms Application To The Web Using Visual Webgui

Glossary Item Box

Visual WebGui introduces a new platform to develop web applications and migrating desktop applications to the web. In this “How To” we are going to learn how to take an existing WinForms application and migrate it to the the web.

First thing we need is a WinForms application. I will use a calculator application written in VB.Net.

Let’s open the project in Visual Studio and run the application to see how it works as a WinForms application.

Add a new Visual WebGui application by right click on the solution and selecting Add->New Project…

Select a new Visual WebGui application.

Delete from the new VWG application the Form1.vb file and drag the Form1.VB from the WinForm project to the VWG project.

Next we will replace the the old references to System.Windows.Forms with the equivalent reference in VWG Gizmox.WebGUI.Forms. Press Ctrl\Shift\H combo to display the Find and Replace form and enter the text that we want to replace and press the replace all. In the end of this process all the references should refer to VWG forms.

Now lets set the VWG project as the starting project by right clicking the project and selecting Set as StartUp Project

Next we will set the starting form of the application. Right click on the project and and open the project property page. In the Web section set the start up action to specific page Form1.wgx.

Now lets run the application and see or WinForms application run as a Web application..

To summarize:
We have seen how to migrate an existing WinForms application to a web application using Visual WebGui.


How To Develop A Visual Webgui Application With Out The Use Of A Designer

Visual WebGui Documentation
How To Develop A Visual Webgui Application With Out The Use Of A Designer
Send Feedback
How To > How To Develop A Visual Webgui Application With Out The Use Of A Designer

Glossary Item Box

In this How to we are going to learn how to develop a Visual WebGui application without the use of a form designer.

Open Visual Studio and create a new Visual WebGui (VWG) application.

in the solution explorer click on the show all files button and expose all the project files. Open the Form.Designer.vb file.

The first thing that we want to do is to add a tool bar to the application.

Add after the InitializeComponent function a declaration to a tool bar.

VB Copy Code
Private WithEvents ToolBar1 As Gizmox.WebGUI.Forms.ToolBar

In the InitializeComponent function will initialize the control and add it to the controls collection of the form.

VB Copy Code

    Private Sub InitializeComponent()

        Me.ToolBar1 = New Gizmox.WebGUI.Forms.ToolBar

        Me.Controls.Add(Me.ToolBar1)

        components = New System.ComponentModel.Container()

        Me.Text = "Form1"

    End Sub

Next will add a few images to our application and set them as the images on the tool bar buttons. To add images to the application add a folder by right clicking on the project and selecting add Add->New folder and name that folder “Resources”. Add another folder named Images and drag the images to it.

Let’s add two tool bar buttons to our form.

VB Copy Code

Private WithEvents ToolBar1 As Gizmox.WebGUI.Forms.ToolBar

Private ToolBarButton1 As Gizmox.WebGUI.Forms.ToolBarButton

Private ToolBarButton2 As Gizmox.WebGUI.Forms.ToolBarButton

Next we will initialize this buttons in the InitializeComponent function, set each one of them with an image by creating an image resource handle and add them to the tool bar.

VB Copy Code
Me.ToolBarButton1 = New Gizmox.WebGUI.Forms.ToolBarButton

Me.ToolBarButton2 = New Gizmox.WebGUI.Forms.ToolBarButton

Dim ImageResourceHandle1 As Gizmox.WebGUI.Common.Resources.ImageResourceHandle = New Gizmox.WebGUI.Common.Resources.ImageResourceHandle

Dim ImageResourceHandle2 As Gizmox.WebGUI.Common.Resources.ImageResourceHandle = New Gizmox.WebGUI.Common.Resources.ImageResourceHandle

ImageResourceHandle1.File = "ContactsView.gif"

ImageResourceHandle2.File = "EmailView.gif"

Me.ToolBarButton1.Image = ImageResourceHandle1

Me.ToolBarButton2.Image = ImageResourceHandle2

Me.ToolBar1.Buttons.AddRange(New Gizmox.WebGUI.Forms.ToolBarButton() {Me.ToolBarButton1})

Me.ToolBar1.Buttons.AddRange(New Gizmox.WebGUI.Forms.ToolBarButton() {Me.ToolBarButton2})

Now let’s add an event to the button click of this buttons. Open the Form1.vb class and add the button click event function and will display the image name when a button is clicked.

Lets run the application and see the result.

Next let’s add a tree view control to our form and add the initialization of it in the InitializeComponent function. Add the control to the form control list and dock it to the left.

VB Copy Code

Private WithEvents TreeView1 As Gizmox.WebGUI.Forms.TreeView

Me.TreeView1 = New Gizmox.WebGUI.Forms.TreeView

Me.TreeView1.Dock = DockStyle.Left

Me.Controls.Add(Me.TreeView1)

Next will add a LinQ to SQL Class. Right click on the project and select Add->New Item. Open the Data section and select a new LinQ to SQL Class.

We will use the Northwind DataBase and drag the category table to the LinQ to SQL Class.

Next will register the on load event of the form and fill the DataClass.

VB Copy Code

Private objDataClasses1DataContext As DataClasses1DataContext

Private Sub Form1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load

objDataClasses1DataContext = New DataClasses1DataContext

End Sub

Now add a new function that will load the categories to tree as nodes and call it on the form load.

VB Copy Code

    Private Sub Form1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load

        objDataClasses1DataContext = New DataClasses1DataContext

        LoadTreeView()

    End Sub

    Private Sub LoadTreeView()

        Dim objMainTreeNote As New Gizmox.WebGUI.Forms.TreeNode("Categories")

        objMainTreeNote.Tag = -1

        TreeView1.Nodes.Add(objMainTreeNote)

        For Each objCategory As Category In objDataClasses1DataContext.Categories

            Dim objCategoryTreeNote As New Gizmox.WebGUI.Forms.TreeNode(objCategory.CategoryName)

            objCategoryTreeNote.Tag = objCategory.CategoryID

            objMainTreeNote.Nodes.Add(objCategoryTreeNote)

        Next

    End Sub

The last thing that we are going to do is to add a grid and to bind it to data on select node event of the tree.

First we will add a grid to the form just like we did with the toolbar and the tree view and dock it to fill.

VB Copy Code

    Private WithEvents Grid1 As Gizmox.WebGUI.Forms.DataGridView

    Me.Grid1 = New Gizmox.WebGUI.Forms.DataGridView

    CType(Me.Grid1, System.ComponentModel.ISupportInitialize).BeginInit()

    Me.Grid1.Dock = DockStyle.Fill

    Me.Controls.Add(Me.Grid1)

    CType(Me.Grid1, System.ComponentModel.ISupportInitialize).EndInit()

Next add another table to the DataClass I’ve added the product table.

Now we will add a BindingSource that will attach the data to the grid and initialize the control in the InitializeComponent function.

VB Copy Code

Private BindingSource1 As Gizmox.WebGUI.Forms.BindingSource

Me.BindingSource1 = New Gizmox.WebGUI.Forms.BindingSource(Me.components)

CType(Me.BindingSource1, System.ComponentModel.ISupportInitialize).BeginInit()

CType(Me.BindingSource1, System.ComponentModel.ISupportInitialize).EndInit()

Next let’s add a select event on a tree node that will fill that data grid.

VB Copy Code

    Private Sub TreeView1_AfterSelect(ByVal sender As System.Object, ByVal e As Gizmox.WebGUI.Forms.TreeViewEventArgs) Handles TreeView1.AfterSelect

        'If this is the first node dont show ros in the grid.

        If e.Node.Tag <> -1 Then

            Dim objProduct As New Product

            BindingSource1.DataSource = objDataClasses1DataContext.ExecuteQuery(objProduct.GetType(), "Select * from Products where CategoryId = {0}", e.Node.Tag)

        End If

    End Sub

Now let’s run our application and see the result.

So what have we seen in this How to

1. How to add controls to a form without the use of a designer.

2. How to register controls events.

3. How to bind data to controls


Performing Automated Tests With Visual Webgui

Visual WebGui Documentation
Performing Automated Tests With Visual Webgui
Send Feedback
How To > Performing Automated Tests With Visual Webgui

Glossary Item Box

Background

Visual WebGui implements AJAX underlying architecture which is used to communicate between the client browser (which is responsible to present the UI) and the server (which actually runs the application).

Using AJAX means that while the application is active, the browser sends HTTPXML requests and receives back responses from the server. Furthermore, an intensive optimization is involved within the client/server communication which is responsible to send a minimal amount of data back and forth.

The most important application automated testing prerequisite is to be able to perform smart recording of activities and replay them as needed, therefore, from revision 6.0.4 up, VWG supports an internal capability which enables recording mechanisms to capture activities and replay them.

In order to understand the request/response mechanism’s systematic behavior, always remember that client requests should always use the latest information from the latest server response especially Ids.

Preparing an application for automated tests

In order to prepare the issued application for automated testing, you should first search for anchor components on which your tests would be based.

For example, in a form with a list-view and a button, on which a user should select a row and press the button, both the list-view (including the list items) and the button are key-components on which you should anchor your test upon. Any other components that might appear on the screen, which should not be tested, are not considered anchors.

Now that you have a list of anchor components, you should set unique identifiers to them by code:

Create a global unique Identifiers extender object:

UniqueIdExtender mobjUniqueIdExtender = new UniqueIdExtender();

Then use it to set Unique-Ids to your anchor components and items:

mobjUniqueIdExtender.SetUniqueId(button1, "B1");

Remember to unique identify all dynamically created list items as well; you can use an applicative identifier which is unique for the task, for example (a list of employees):

DataClasses1DataContext objDataClasses = new DataClasses1DataContext();

foreach (Employee objEmployee in objDataClasses.Employees)

{

   ListViewItem mobjListViewItem = new ListViewItem(new string[]

   {objEmployee.EmployeeID.ToString(), objEmployee.FirstName, objEmployee.LastName,

       objEmployee.Title, objEmployee.Country});

   mobjUniqueIdExtender.SetUniqueId(listView1,

                        string.Format("LI{0}", objEmployee.EmployeeID));

    listView1.Items.Add(mobjListViewItem);

}

Understanding what we have done

Since Visual WebGui optimizes its requests, the automatic test cannot lean on the internal ids of components specified by the server.

By uniquely identifying anchor components, we ensure that those Ids will be sent back from the server at any response so that we would be able to lean on ids in order to create valuable replays.

Understanding Visual WebGui client/server communication flow

The next diagram shows the flow of events which should help you understand Visual WebGui client/server communication flow:

When a client approaches the server for the first time

1. VWG client requests a .wgx resource.

2. IIS ASP.NET ISAPI filter accepts the request and forward it to VWG server router.

3. The router recognizes the request as a new application start, creates the application context within the user’s session (this is called a VWG context).

4. The server sends back the initial information needed to create the first view, along with the VWG small kernel of code (containing js,xsl and css) in case it is not yet cached.

5. The client presents the first view.

From this initial state on, each further client critical event (such as button click) results with the following reaction

1. The client sends all queued events which were accumulated by now on the client (all non-critical and one last critical which caused this current request). This request identifies itself with LR=”<number>” which is the number generated by the server for its last response.

2. The server accepts the events information and runs it chronologically on the application state metadata and sends any update that should be reflected to the client as a response.
This response will circularly contain the next LR value of which the next client event should specify.

Recording automatic test sessions and replaying them

Assuming you have anchored key components; the following process will enable an automated testing of your application:

  1. Capture client requests and server response of your target process by using an HTTP sniffer, an automated tool or VWG build in debugger
  2. Make sure your tool performs the following actions when running the tests:

    1. On every server request be sure to save:

      1. The last rendered LR value.
      2. The VWG internal Ids of your anchored components.

    2. When replaying, the request should contain the last LR value saved by the testing tool and the anchor components which are the only components participating in our test are specified by the latest server update ids.

  3. Run the test.

Request/Response analysis

· Sample server response
The following is a partial XML of what gets back from the server when initially clicking on a ListView sample from the VWG Catalog demo (see painted items explanations bellow):

- <WG:R LR="633468802762518350" AF="53" xmlns:WC="wgcontrols" xmlns:WG="http://www.gizmox.com/webgui">

  - <WG:F Id="53">

    - <WC:TV Id="26" TI="1" F="1" IDD="1" BR="none" SCT="124" D="F" TX="" SL="1">

      - <TN Id="54" TX="Input Controls" IM="Icons.Folders.gif.wgx" HRP="1">

    …More tree nodes here…

  </WC:TV>

    - <WC:P Id="1" TI="3" F="1" BIL="0" TX="Category" MaxSize="400" MinSize="50" TP="Titled" D="F">

      - <WC:UC Id="95" TI="1" F="1" PA="3" D="F">

        - <WC:LV Id="94" TI="1" F="1" BIL="0" IDD="1" D="F" VW="Details" TX="" HS="0" HC="0" SBTN="1" CP="1" TOP="4" TOI="80" HDS="2" MU="1">

          <C Id="109" N="c0" TX="" W="20" TP="Icon" TA="left" CA="left" IM="Icons.Headers.Important.gif.wgx" />

          …More columns here…

          <R Id="116" CUID="84c8215e" c0="Icons.ImportantMail.gif.wgx" c1="Icons.OpenedMail.gif.wgx" c2="Icons.AttachedMail.gif.wgx" s2="background-color:Yellow;" c3="This is a test message." c4="test@visualwebgui.com" s4="background-color:LightGreen;" c5="5/31/2008 1:39:01 PM" c6="412kb" />

          <R Id="117" CUID="a2cb215e" c0="" c1="Icons.OpenedMail.gif.wgx" c2="" s2="background-color:Yellow;" c3="This is a test message." c4="test@visualwebgui.com" c5="4/8/2008 11:37:56 AM" c6="935kb" />

          …More rows here…

        </WC:LV>

      </WC:UC>

    </WC:P>

  </WG:F>

  - <CMDS>

    <IM MM="Bookmarks_SetBookmark" ARG0="1" ARG1="Sample1" />

  </CMDS>

</WG:R>

LR="633468802762518350" – The LR value sent by the server which will be used by the next client request.

WC:TV – WC: WebGui Control – TV: Tree View .

Id="26" – The TreeView’s internal VWG Control Id
*this value is dynamic, therefore, cannot be leaned on when building auto-testing*

WC:P – WC: WebGui Control – P: Panel.

WC:UC – WC: WebGui Control – UC: UserControl.

WC:LV – WC: WebGui Control – LV: ListView.

C – WebGui Component – ListViewColumn.

R Id="116" – WebGui Component – ListViewItem (Row) with its internal VWG Component Id.

CUID="84c8215e" – WebGui Client Unique Id of a ListViewItem (Row)

· Sample client request
The following is the XML which is sent by the client browser to the server after a few accomunlated event and a TreeView Node click which is considered a “critical event” when listened to (as in this sample).

- <ES LR="633468884669035490">

  <E SR="26" TP="ScrollPositionChanged" SCT="108" SCL="0" />

  <E SR="74" TP="SelectionChange" TRG="true" Indexes="8" />

  <E SR="26" TP="LostFocus" />

  <E SR="74" TP="GotFocus" />

  <E SR="74" TP="LostFocus" />

  <E SR="26" TP="GotFocus" />

  <E SR="66" TP="Action" Action="Click" />

</ES>

As shown in the sample above, a few events have happened before the click event did, so that they are sent to the server synchronously.
The SR attribute value indicates the source component id on which the event has occurred.

Flow analysis

It is very possible that your first analysis of what really happens in terms of raised events would be wrong. That is due to the fact that there are a large number of events you might not identify in a single analysis as necessary.
Therefore it is much recommended to identify the anchors before you run the automatic tests and make sure that all of the touched components (on which events are raised) and are crucial for the process to be accurate, will be marked by you as anchors.

This can be done by sniffing/recording the desired session and analyzing what really happens in terms of interaction between the client and the server.

Recommendations

  • It is recommended not to produce production versions with unique ids granting code in, there is no internal need for them except for the sake of test.

(You can add a configurable TEST state on which ids are granted and turn on this capability only when you need it)

  • Try to minimize the number of uniquely identified components (anchors) as possible to prevent enlarging server response sizes.
  • Sniff the HTTP connection during initial test to verify that the test actually does what it should do.


Visual Webgui Control Silverlight Extender

Visual WebGui Documentation
Visual Webgui Control Silverlight Extender
Send Feedback
How To > Visual Webgui Control Silverlight Extender

Glossary Item Box

In this tutorial we are going to learn how to use Visual WebGui silverlight extender component.
Visual WebGui supports multiple presentation layers for the same application. The same design time control can be rendered as a run time DHTML control or a Silverlight control. Microsoft Silverlight is a programmable web browser plug-in that enables features such as animation and vector graphics. These features are not available in DHTML but we found it necessary to add support to this ability to our controls in design time and run time.

For that we created the Silverlight extender. Visual WebGui Silverlight extender adds the necessary support for Silverlight properties to Visual WebGui controls.

To demonstrate the Silverlight extender abilities we will create an application with a few controls on it and an edit area that will allow you to play with the Silverlight properties of the control in run time.

Let’s create a new Visual WebGui application. Open Visual studio and add a new VWG application project.

Next let’s open the form1 in design time and add a panel docked to the right and a splitter and a panel docked to the center (I’ve painted them to see the difference).

Now we will add a few Visual WebGui controls to the panel that is docked to fill (a.k.a the LightCyan panel) like this.

On the other panel (a.k.a 192, 192, 255) we will add a drop down and 6 track bars like this.

Let’s look at one of the controls that we added to the panel and see his design time properties categories before we add the Silverlight extender component. These properties are the control properties and the properties that are inherited form the Control class. All this properties are implemented in the control in any presentation layer that is available in VWG.

Next we will add a Silverlight extender to our form.

Now let’s see the control properties after we added the Silverlight extender. As you can see a new category was added to it “Silverlight”. The properties that are added are basic silverlight controls properties that are available in run time only when running under Visual WebGui Silverlight extension. Our application will use these properties in run time to manipulate the controls.

The first thing that we are going to do is add the on form event and to fill the combo box with a list of the controls that are place on the panel. By selecting a control in the list we will see what control will be edited by the track bars.

private void Form1_Load(object sender, EventArgs e)

{

    objControls.DisplayMember = "Name";

    foreach (Control objControl in panel2.Controls)

    {

        objControls.Items.Add(objControl);

    }

    objControls.SelectedIndex = 0;

}

Next will add an event to the on SelectedIndexChanged od the combo box. Every time an item is select we will set the select control Silverlight property values to the track bars.

private void objControls_SelectedIndexChanged(object sender, EventArgs e)

{

    double dblOpc = this.silverlightExtender1.GetOpacity((Control)objControls.SelectedItem) * 100;

    trackBar1.Value = Convert.ToInt32(dblOpc);

    trackBar2.Value = Convert.ToInt32(this.silverlightExtender1.GetRotation((Control)objControls.SelectedItem)) + 360;

    trackBar3.Value = Convert.ToInt32(this.silverlightExtender1.GetScaleX((Control)objControls.SelectedItem)) + 10;

    trackBar4.Value = Convert.ToInt32(this.silverlightExtender1.GetScaleY((Control)objControls.SelectedItem)) + 10;

    trackBar5.Value = Convert.ToInt32(this.silverlightExtender1.GetSkewX((Control)objControls.SelectedItem))+180;

    trackBar6.Value = Convert.ToInt32(this.silverlightExtender1.GetSkewY((Control)objControls.SelectedItem))+180;

}

Now we will add to the track bars events Value change and update the curently selected control silverlight property with the new value.

private void trackBar1_ValueChanged(object sender, EventArgs e)

{

    double dblOpc = Convert.ToDouble(trackBar1.Value) / 100;

    this.silverlightExtender1.SetOpacity((Control)objControls.SelectedItem, dblOpc);

    this.label1.Text = "Opacity Value: " + dblOpc.ToString();

}

private void trackBar2_ValueChanged(object sender, EventArgs e)

{

    int value = trackBar2.Value - 360;

    this.silverlightExtender1.SetRotation((Control)objControls.SelectedItem, Convert.ToDouble(value));

    this.label2.Text = "Rotate Value: " + value.ToString();

}

private void trackBar3_ValueChanged(object sender, EventArgs e)

{

    double dblOpc = Convert.ToDouble(trackBar3.Value -10) ;

    this.silverlightExtender1.SetScaleX((Control)objControls.SelectedItem, dblOpc);

    this.label3.Text = "ScaleX Value: " + dblOpc.ToString();

}

private void trackBar4_ValueChanged(object sender, EventArgs e)

{

    double dblOpc = Convert.ToDouble(trackBar4.Value -10) ;

    this.silverlightExtender1.SetScaleY((Control)objControls.SelectedItem, dblOpc);

    this.label4.Text = "ScaleY Value: " + dblOpc.ToString();

}

private void trackBar5_ValueChanged(object sender, EventArgs e)

{

    int value = trackBar5.Value - 180;

    this.silverlightExtender1.SetSkewX((Control)objControls.SelectedItem, Convert.ToDouble(value));

    this.label5.Text = "SkewX Value: " + value.ToString();

}

private void trackBar6_ValueChanged(object sender, EventArgs e)

{

    int value = trackBar6.Value - 180;

    this.silverlightExtender1.SetSkewY((Control)objControls.SelectedItem, Convert.ToDouble(value));

    this.label6.Text = "SkewY Value: " + value.ToString();

}

Now before we run the application lets set the start form to form1. Right click on the form an select “Set as StartUp”.

Next let’s add silverlight as a presentation layer of our application. Open the property page Deployment tab and check the check box next to Silverlight.

Because our application is can only work in Silverlight lets set the start page of our application to work with the Silverlight extension. Open the Web tab and set specific page to start as form1.swgx.

Now let’s run the application.

Select the picture box item in the ComboBox and change the picture box by adjusting the values in the track bars.

To summarize:

We have seen how to use the Silverlight extender component and expose the Silverlight properties in design time and run time.


How To Embed A Visual Webgui Form In An Asp.net Application

Visual WebGui Documentation
How To Embed A Visual Webgui Form In An Asp.net Application
Send Feedback
How To > How To Embed A Visual Webgui Form In An Asp.net Application

Glossary Item Box

What we are going to do today is to see how easy it is to embed a Visual WebGui (VWG) form in an ASP.Net application. This ability allows you to do fast development of modules in VWG or port WinForms application to Web using VWG and embed them in your currently working ASP.Net application.

For this I'm going to use a calculator application that I have and embed it in a ASP.Net application.

The Calculator application looks like this

The first thing that we need to do is create an ASP.Net application. Open Visual Studio and add a new Web application project.

Now we will add a reference to VWG assemblies and set the DLL’s to copy local.

We will add another reference to the VWG application just right click on the project and select Add Reference->Browse.

Next let’s open the webform and register the Gizmox.WebGUI.Forms assembly and add a FormBox control. This control is an ASP.Net control that inherits from System.Web.UI.Control and serves as an iFrame for VWG forms.

<%@ Register Assembly="Gizmox.WebGUI.Forms"  Namespace="Gizmox.WebGUI.Forms.Hosts" TagPrefix="VWG"%>

<VWG:FormBox id="FormBox1" runat="server" Stateless="false" Height="300px"

      Width="300px" Form="Form1" >

</VWG:FormBox>

I’ve set the height and width of the control and the form that I want to display which is the Form1 from the VWGCalc.dll.
Next we have to add to the Web.Config file the VWG configuration sections. The First is WebGui section decleration in the <configSections>

<section name="WebGUI" type="Gizmox.WebGUI.Common.Configuration.ConfigHandler, Gizmox.WebGUI.Common, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=263fa4ef694acff6"/>

After the declaration we can add the WebGUI section. This section holds a few configuration that we will not handle at this point.
But lets just focus on the applications section. the way Visual WebGui works is the same as winforms we have to set a start up form like the main form. So I've added Form1 as the start up form and the VWG server will use it as an entry point to the application.

<WebGUI>

  <Applications>

    <Application Code="Form1" Type="VWGCalc.Form1, VWGCalc"/>

  </Applications>

  <Controls>

  </Controls>

  <Themes Selected="Default">

  </Themes>

  <Directories>

    <Directory Code="Icons" Path="Resources\Icons"/>

    <Directory Code="Images" Path="Resources\Images"/>

    <Directory Code="Generated" Path="Resources\Generated"/>

    <Directory Code="UserData" Path="Resources\UserData"/>

  </Directories>

  <StaticResources Mode="Off"/>

  <PrivateVersion Value="1"/>

  <IconsPreloading Mode="Off"/>

</WebGUI>

In the httpHandler section we will add a handler for VWG that will route requests with the .WGX extensions to the VWG server and will run the VWG application in the user’s session.

<httpHandlers>

  <remove verb="*" path="*.asmx"/>

  <add verb="*" path="*.asmx" validate="false" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>

  <add verb="*" path="*_AppService.axd" validate="false" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>

  <add verb="GET,HEAD" path="ScriptResource.axd" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" validate="false"/>

  <!--  WebGUI ROUTER HANDLER

    This http handler routes the requests to Modules/Icons/Images/Css/Xslt/Resoureces.

    Client events are sinked through this router as well.

  -->

  <add verb="*" path="*.wgx" type="Gizmox.WebGUI.Server.Router,Gizmox.WebGUI.Server,Version=3.0.5701.0,Culture=neutral,PublicKeyToken=3de6eb684226c24d"/>

</httpHandlers>

Now we can run our application and see the VWG calculator application in a ASP.Net application. I’ve also added the source of the page.

Next we will add some interaction between the VWG application and the ASP.Net site.

Open Default.Aspx page in design mode and add a TextBox and a Button on it like this.

Select the FormBox1 Control and delete the value from the Form property so when the control loads it will show nothing.

Next we will create an on button click event by clicking the button. when the button is clicked we will check if we set the FormBox1 Form property to a value and if not we will set it and send an argument to to From.

If the Form property has a value we will clear it and read the same argument to textbox.

protected void Button1_Click(object sender, EventArgs e)

{

    if (string.IsNullOrEmpty(FormBox1.Form))

    {

        FormBox1.Form = "Form1";

        FormBox1.Arguments["Value"] = TextBox1.Text;

    }

    else

    {

        FormBox1.Form = string.Empty;

        TextBox1.Text = FormBox1.Results["Value"] as string;

    }

}

Now we can run the application. Enter a number in the text box and press the button to open the calculator. Once you finished your calculation you can send the result back to the textbox and close the calculator by pressing the button.


Manually Wrapping Asp.net Controls With Out The Use Of Visual Webgui Designer

Visual WebGui Documentation
Manually Wrapping Asp.net Controls With Out The Use Of Visual Webgui Designer
Send Feedback
How To > Manually Wrapping Asp.net Controls With Out The Use Of Visual Webgui Designer

Glossary Item Box

In this tutorial we will learn how to wrap an ASP.Net control without the use of a designer or wizard and use that control in a Visual WebGui application. The ability to wrap ASP.Net controls allows you to use third party controls for ASP.Net and your own custom controls and to enrich your arsenal of controls to create rich internet applications.
Visual WebGui extends ASP.NET. It extends an ihttp handler and implements its own pipeline. VWG is actually an ASP.NET site. The diagram bellow illustrates the technological hierarchy which puts VWG at the same level as ASP.NET. Since the application and session are shared integration between ASP.NET and Visual WebGui is possible.

Because Visual WebGui extends ASP.NET you can use third party ASP.NET components or your own ASP.NET custom controls in a Visual WebGui application by wrapping the control.

In this demo we will wrap DevExpress Tree list control. This control can display information as a tree or grid like this.

First we will open Visual studio and create a new VWG application.

Next we will add a reference to DevExpress DLLs:
DevExpress.Data
DevExpress.Web.ASPxEditors
DevExpress.Web.ASPxTreeList
DevExpress.Web
and set these assemblies to copy local.

Next let’s add a new class named MyASPxTreeList. This class will inherit from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase. The AspControlBoxBase provides a base class for creating ASP.NET wrapped controls that can be integrated into VWG as a native control. The class provides services for ASP.NET – VWG communication and using ASP.NET markup code to initialize the ASP.NET control.

public class MyASPxTreeList : Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase

Let’s set the ASP.Net control that will be hosted in our control. We will add a property named HostedASPxTreeList that will return the hosted control casted to a hosted Asp Tree list. This will allow us to expose the hosted control properties and methods.

/// <summary>

/// Get hosted control typed instance

/// </summary>

protected DevExpress.Web.ASPxTreeList.ASPxTreeList HostedASPxTreeList

{

    get

    {

        return (DevExpress.Web.ASPxTreeList.ASPxTreeList)this.HostedControl;

    }

}

We will add to our control an attribute that will allow it to display in the tool box in design time.

[System.ComponentModel.ToolboxItem(true)]

Let’s build our application and open form1 in design time. As you can see our new control is in the tool box.

Let’s add the control to the form and run the application. Open the Project property page and set the starting page of the application to Form1.wgx.

We will see the control without any data.

Let’s open DevExpress demo project and see how the control is used there and copy the behavior to our VWG application. This is the demo it shows the display of a tree list control with data from an access data base and sorting.

All we need to do is use the same code that was used in the demo in our application. For this the AspControlBoxBase expose a property called ControlCode. If you click the ControlCode property in design time an editor is opened. This editor serves as the Aspx designer for markup language.

The code below is copied from the demo project supplied by DevExpress installation for the TreeList control. The code below initializes three columns Department, Location, Budget and a data source AccessDataSource.

<dxwtl:ASPxTreeList ID="treeList" runat="server" AutoGenerateColumns="False"

    ClientInstanceName="treeList" Width="100%"

    DataSourceID="AccessDataSource1"

    KeyFieldName="ID" ParentFieldName="ParentID">

    <Columns>

        <dxwtl:TreeListDataColumn FieldName="Department" VisibleIndex="0" />

        <dxwtl:TreeListDataColumn FieldName="Location" SortIndex="0" SortOrder="Ascending"

        VisibleIndex="1" />

        <dxwtl:TreeListDataColumn FieldName="Budget" SortIndex="1" SortOrder="Descending"

        VisibleIndex="2" DisplayFormat="{0:C}" />

    </Columns>

    <Settings GridLines="Vertical" SuppressOuterGridLines="true" />

    <SettingsBehavior AutoExpandAllNodes="True" ExpandCollapseAction="NodeDblClick" />

    <Border BorderStyle="Solid" />

</dxwtl:ASPxTreeList>

<asp:AccessDataSource ID="AccessDataSource1" runat="server"

DataFile="~/App_Data/DataSources/Departments.mdb"

    SelectCommand="SELECT [ID], [ParentID], [Department], [Location],

    [Budget] FROM [Departments]">

</asp:AccessDataSource>

Take this code and paste it in the ControlCode property.
Because this is a Aspx designer we need to register the control the same way add this registration at the top.

<%@ Page Language="C#"%>

<%@ Register Assembly="DevExpress.Web.ASPxTreeList.v8.2" Namespace="DevExpress.Web.ASPxTreeList" TagPrefix="dxwtl" %>

It will look like this in the end.

Now we need to connect the control that we added in the ControlCode property to the hosted control in the wrapper. Copy the name of the control from the code in our case “treeList” and set it in the ControlID property.

We need to add the DataSource that is referenced in the code section we added. So add a new folder and with the DB from the demo.

Now all we need to do is run the application. Open the project property page Web section and set the specific page to Form1.wgx.

Next run the application and this is the result. You can click on the column header to sort the data.

To summarize:

We have seen how to use third party ASP.Net controls in a Visual WebGui application by manually wrapping the control in a Visual WebGui AspControlBoxBase.


Assembly Overview

Gizmox.WebGUI.Forms
Gizmox.WebGUI.Forms Assembly ()
See Also Send Feedback

Namespaces

Namespace | Description
Gizmox.WebGUI.Forms |
Gizmox.WebGUI.Forms.Authentication |
Gizmox.WebGUI.Forms.Controls |
Gizmox.WebGUI.Forms.Design |
Gizmox.WebGUI.Forms.Dialogs |
Gizmox.WebGUI.Forms.Extenders |
Gizmox.WebGUI.Forms.Hosts |
Gizmox.WebGUI.Forms.Layout |
Gizmox.WebGUI.Forms.PropertyGridInternal |

© 2009 All Rights Reserved.


Gizmox.WebGUI.Forms Namespace (Gizmox.WebGUI.Forms)

Gizmox.WebGUI.Forms Namespace (Gizmox.WebGUI.Forms)
See Also Inheritance Hierarchy Send Feedback

Classes

 | Class | Description
Class | BaseCollection | Provides the base functionality for creating data-related collections in the Gizmox.WebGUI.Forms Namespace namespace.
Class | Binding | Represents the simple binding between the property value of an object and the property value of a control.
Class | BindingCompleteEventArgs | Provides data for the Binding.BindingComplete event.
Class | BindingContext | Manages the collection of BindingManagerBase objects for any object that inherits from the Control class.
Class | BindingManagerBase | Manages all Binding objects that are bound to the same data source and data member. This class is abstract.
Class | BindingManagerDataErrorEventArgs | Provides data for the BindingManagerBase.DataError event.
Class | BindingNavigator | Represents the navigation and manipulation user interface (UI) for controls on a form that are bound to data.
Class | BindingsCollection | Represents a collection of Binding objects for a control.
Class | BindingSource | Encapsulates the data source for a form.
Class | Button | A button control
Class | CheckBox | A checkBox control.
Class | CheckedListBox | Summary description for CheckedListBox.
Class | CheckedListBox.CheckedIndexCollection | Encapsulates the collection of indexes of checked items (including items in an indeterminate state) in a CheckedListBox.
Class | CheckedListBox.CheckedItemCollection | Encapsulates the collection of checked items, including items in an indeterminate state, in a CheckedListBox control.
Class | CheckedListBox.ObjectCollection | The list box object collection
Class | Clipboard | Provides methods to place data on and retrieve data from the system Clipboard. This class cannot be inherited.
Class | ColorComboBox | Represents a Gizmox.WebGUI.Forms combo box control.
Class | ColorComboBox.ObjectCollection | Represents the collection of items in a ComboBox.
Class | ColorDialog | Represents a common dialog box that displays available colors along with controls that enable the user to define custom colors.
Class | ColorListBox | Summary description for ColorListBox.
Class | ColorListBox.ObjectCollection | The list box object collection
Class | ColumnClickEventArgs |
Class | ColumnHeader | Summary description for ColumnHeader.
Class | ColumnHeaderGroupingData |
Class | ColumnHeaderSortingData |
Class | ColumnStyle |
Class | ComboBox | Represents a Gizmox.WebGUI.Forms combo box control.
Class | ComboBox.ObjectCollection | Represents the collection of items in a ComboBox.
Class | CommonDialog | Specifies the base class used for displaying dialog boxes on the screen.
Class | Component | The base class for all GUI elements
Class | ContainerControl | Provides focus management functionality for controls that can function as a container for other controls.
Class | ContextMenu | A button control
Class | Control | The base class for all positioned GUI elements
Class | Control.ControlCollection | Represents a collection of objects.
Class | ControlBindingsCollection | Represents the collection of data bindings for a control.
Class | ControlCollection | Contains a collection of Control objects.
Class | ControlEventArgs | Control event arguments
Class | ConvertEventArgs | Provides data for the Binding.Format and Binding.Parse events.
Class | CurrencyManager | Manages a list of Binding objects.
Class | Cursor | Represents the image used to paint the mouse pointer.
Class | CursorConverter | Provides a type converter to convert Cursor objects to and from various other representations.
Class | Cursors | Provides a collection of Cursor objects for use by a Windows Forms application.
Class | DataFormats | Provides static, predefined Clipboard format names. Use them to identify the format of data that you store in an IDataObject.
Class | DataFormats.Format | Represents a Clipboard format type.
Class | DataGridView | Displays data in a customizable grid.
Class | DataGridView.DisplayedBandsData |
Class | DataGridViewAdvancedBorderStyle | Contains border styles for the cells in a DataGridView control.
Class | DataGridViewAutoSizeColumnModeEventArgs | Provides data for the DataGridView.AutoSizeColumnModeChanged event.
Class | DataGridViewAutoSizeColumnsModeEventArgs | Provides data for the DataGridView.AutoSizeColumnsModeChanged event.
Class | DataGridViewAutoSizeModeEventArgs | Provides data for the DataGridView DataGridView.AutoSizeRowsModeChanged and DataGridView.RowHeadersWidthSizeModeChanged events.
Class | DataGridViewBand | Represents a linear collection of elements in a DataGridView control.
Class | DataGridViewBindingCompleteEventArgs | Provides data for the DataGridView.DataBindingComplete event.
Class | DataGridViewButtonCell | Displays a button-like user interface (UI) for use in a DataGridView control.
Class | DataGridViewButtonColumn | Hosts a collection of DataGridViewButtonCell objects.
Class | DataGridViewCell | Represents an individual cell in a DataGridView control.
Class | DataGridViewCellCancelEventArgs | Provides data for DataGridView.CellBeginEdit and DataGridView.RowValidating events.
Class | DataGridViewCellCollection | Represents a collection of cells in a DataGridViewRow.
Class | DataGridViewCellErrorTextNeededEventArgs | Provides data for the DataGridView.CellErrorTextNeeded event of a DataGridView control.
Class | DataGridViewCellEventArgs | Provides data for DataGridView events related to cell and row operations.
Class | DataGridViewCellFormattingEventArgs | Provides data for the DataGridView.CellFormatting event of a DataGridView.
Class | DataGridViewCellMouseEventArgs | Provides data for mouse events raised by a DataGridView whenever the mouse is moved within a DataGridViewCell.
Class | DataGridViewCellParsingEventArgs | Provides data for the DataGridView.CellParsing event of a DataGridView control.
Class | DataGridViewCellStateChangedEventArgs | Provides data for the DataGridView.CellStateChanged event.
Class | DataGridViewCellStyle | Represents the formatting and style information applied to individual cells within a DataGridView control.
Class | DataGridViewCellStyleContentChangedEventArgs | Provides data for the DataGridView.CellStyleContentChanged event.
Class | DataGridViewCellStyleConverter | Converts DataGridViewCellStyle objects to and from other data types.
Class | DataGridViewCellToolTipTextNeededEventArgs | Provides data for the DataGridView.CellToolTipTextNeeded event.
Class | DataGridViewCellValidatingEventArgs | Provides data for the DataGridView.CellValidating event of a DataGridView control.
Class | DataGridViewCellValueEventArgs | Provides data for the DataGridView.CellValueNeeded and DataGridView.CellValuePushed events of the DataGridView control.
Class | DataGridViewCheckBoxCell | Displays a check box user interface (UI) to use in a DataGridView control.
Class | DataGridViewCheckBoxColumn | Hosts a collection of DataGridViewCheckBoxCell objects.
Class | DataGridViewColumn | Represents a column in a DataGridView control.
Class | DataGridViewColumnCollection | Represents a collection of DataGridViewColumn objects in a DataGridView control.
Class | DataGridViewColumnDesignTimeVisibleAttribute | Specifies whether a column type is visible in the DataGridView designer. This class cannot be inherited.
Class | DataGridViewColumnDividerDoubleClickEventArgs | Provides data for the DataGridView.ColumnDividerDoubleClick event of a DataGridView.
Class | DataGridViewColumnEventArgs | Provides data for column-related events of a DataGridView.
Class | DataGridViewColumnHeaderCell | Represents a column header in a DataGridView control.
Class | DataGridViewColumnStateChangedEventArgs | Provides data for the DataGridView.ColumnStateChanged event.
Class | DataGridViewComboBoxCell | Displays a combo box in a DataGridView control.
Class | DataGridViewComboBoxCell.ObjectCollection | Represents the collection of selection choices in a DataGridViewComboBoxCell.
Class | DataGridViewComboBoxColumn | Represents a column of DataGridViewComboBoxCell objects.
Class | DataGridViewDataErrorEventArgs | Provides data for the DataGridView.DataError event.
Class | DataGridViewEditingControlShowingEventArgs | Provides data for the DataGridView.EditingControlShowing event.
Class | DataGridViewElement | Provides the base class for elements of a DataGridView control.
Class | DataGridViewHeaderCell | Contains functionality common to row header cells and column header cells.
Class | DataGridViewImageCell | Displays a graphic in a DataGridView control.
Class | DataGridViewImageColumn | Hosts a collection of DataGridViewImageCell objects.
Class | DataGridViewLinkCell | Represents a cell that contains a link.
Class | DataGridViewLinkColumn | Represents a column of cells that contain links in a DataGridView control.
Class | DataGridViewRow | Represents a row in a DataGridView control.
Class | DataGridViewRowCancelEventArgs | Provides data for the DataGridView.UserDeletingRow event of a DataGridView.
Class | DataGridViewRowCollection | A collection of DataGridViewRow objects.
Class | DataGridViewRowContextMenuStripNeededEventArgs | Provides data for the DataGridView.RowContextMenuStripNeeded event.
Class | DataGridViewRowDividerDoubleClickEventArgs | Provides data for the DataGridView.RowDividerDoubleClick event of a DataGridView.
Class | DataGridViewRowErrorTextNeededEventArgs | Provides data for the DataGridView.RowErrorTextNeeded event of a DataGridView control.
Class | DataGridViewRowEventArgs | Provides data for row-related DataGridView events.
Class | DataGridViewRowHeaderCell | Represents a row header of a DataGridView control.
Class | DataGridViewRowHeightInfoNeededEventArgs | Provides data for the DataGridView.RowHeightInfoNeeded event of a DataGridView.
Class | DataGridViewRowHeightInfoPushedEventArgs | Provides data for the DataGridView.RowHeightInfoPushed event of a DataGridView.
Class | DataGridViewRowsAddedEventArgs | Provides data for the DataGridView.RowsAdded event.
Class | DataGridViewRowsRemovedEventArgs | Provides data for the DataGridView.RowsRemoved event.
Class | DataGridViewRowStateChangedEventArgs | Provides data for the DataGridView.RowStateChanged event of a DataGridView.
Class | DataGridViewSelectedCellCollection | Represents a collection of cells that are selected in a DataGridView.
Class | DataGridViewSelectedColumnCollection | Represents a collection of DataGridViewColumn objects that are selected in a DataGridView.
Class | DataGridViewSelectedRowCollection | Represents a collection of DataGridViewRow objects that are selected in a DataGridView.
Class | DataGridViewSortCompareEventArgs | Provides data for the DataGridView.SortCompare event.
Class | DataGridViewTextBoxCell | Displays editable text information in a DataGridView control.
Class | DataGridViewTextBoxColumn | Hosts a collection of DataGridViewTextBoxCell cells.
Class | DataGridViewTextBoxEditingControl | Not Implemented. Represents a text box control that can be hosted in a DataGridViewTextBoxCell.
Class | DataGridViewTopLeftHeaderCell | Represents the cell in the top left corner of the DataGridView that sits above the row headers and to the left of the column headers.
Class | DataObject | Implements a basic data transfer mechanism.
Class | DateTimePicker | Represents a Gizmox.WebGUI.Forms control that allows the user to select a date and a time and to display the date and time with a specified format.
Class | DomainUpDown | Represents a Windows spin box (also known as an up-down control) that displays string values.
Class | DomainUpDown.DomainUpDownItemCollection | Encapsulates a collection of objects for use by the DomainUpDown class.
Class | DragDropEventArgs | Contains Drag and drop event arguments.
Class | DragEventArgs | Provides data for the DragDrop, DragEnter, or DragOver event.
Class | DragMapping | Drag mapping between two controls
Class | DragMappings | Summary description for DragMappings.
Class | ErrorProvider | Provides a user interface for indicating that a control on a form has an error associated with it.
Class | FileDialog | Displays a dialog box from which the user can select a file.
Class | FlowLayoutPanel | Represents a panel that dynamically lays out its contents horizontally or vertically.
Class | FolderBrowserDialog | Prompts the user to select a folder. This class can be inherited to provide default data source.
Class | FontDialog | Prompts the user to choose a font from among those installed on the local computer.
Class | Form | Represents a window or dialog box that makes up an application's user interface.
Class | FormReference | References a form
Class | FrameControl | Provides a base class that allows invocation of methods that reside inside controls that have frames
Class | GridItem | Implements one row in a PropertyGrid.
Class | GridItemCollection | Contains a collection of GridItem objects.
Class | GroupBox | Represents a Panel control.
Class | HandledMouseEventArgs | Allows a custom control to prevent the MouseWheel event from being sent to its parent container.
Class | Help | Encapsulates the HTML Help 1.0 engine.
Class | HelpEventArgs | Provides data for the HelpRequested event.
Class | HelpProvider | Provides pop-up or online Help for controls.
Class | HtmlBox | A html control
Class | HtmlBox.HtmlGateway | Html gateway handler
Class | ImageList | Summary description for ImageList.
Class | ImageList.ImageCollection | Encapsulates the collection of Gizmox.WebGUI.Common.Resources.ResourceHandle objects in an ImageList.
Class | ItemChangedEventArgs | Provides data for the CurrencyManager.ItemChanged event.
Class | ItemCheckEventArgs |
Class | KeyEventArgs |
Class | KeyPressEventArgs | Provides data for the KeyPress event.
Class | Label | Represents a standard Gizmox.WebGUI label.
Class | LayoutEngine |
Class | LayoutEventArgs |
Class | LayoutSettings |
Class | Link | The Link class provides services for opening links in a new window
Class | LinkLabel | Represents a Gizmox.WebGUI.Forms label control that can display hyperlinks.
Class | LinkLabel.Link | Represents a link within a LinkLabel control.
Class | LinkLabelLinkClickedEventArgs | Provides data for the LinkLabel.LinkClicked event.
Class | LinkParameters | Holds window parameters for opening links
Class | LinkParameters.LinkArguments | Holds arguments to open links with
Class | ListBindingConverter | Provides a type converter to convert Binding objects to and from various other representations.
Class | ListBindingHelper | Provides functionality to discover a bindable list and the properties of the items contained in the list when they differ from the public properties of the object to which they bind.
Class | ListBox | Implementation of ListBox class.
Class | ListBox.ObjectCollection | The list box object collection
Class | ListBox.SelectedObjectCollection | Represents the collection of selected items in the ListBox.
Class | ListControl | Provides a common implementation of members for the ListBox and ComboBox classes.
Class | ListControlConvertEventArgs | Provides data for the ListControl.Format event.
Class | ListView | A ListView control.
Class | ListView.ColumnHeaderCollection | Represents the collection of column headers in a ListView control.
Class | ListView.ListViewItemCollection | Represents the collection of items in a ListView control.
Class | ListView.SelectedListViewItemCollection |
Class | ListViewItem | Implementation of ListViewItem class.
Class | ListViewItem.ListViewSubItem | Represents a subitem of a ListViewItem .
Class | ListViewItem.ListViewSubItemCollection | Represents a collection of ListViewSubItem objects stored in a ListViewItem .
Class | ListViewItemConverter | Provides a type converter to convert ListViewItem objects to and from various other representations.
Class | ListViewItemEventArgs |
Class | ListViewItemSorter | Gets or sets the sorting comparer for the control.
Class | MainMenu | Summary description for MainMenu.
Class | MaskedTextBox | Uses a mask to distinguish between proper and improper user input.
Class | MdiClient | Represents the container for multiple-document interface (MDI) child forms. This class cannot be inherited.
Class | MdiClient.ControlCollection | Contains a collection of MdiClient controls.
Class | Menu | The base class for all GUI elements
Class | MenuCollection | The base class for all GUI elements
Class | MenuItem | Summary description for Menu Item.
Class | MenuItemCollection |
Class | MenuItemEventArgs | Menu item event arguments
Class | MessageBox | Displays a message box that can contain text, buttons, and symbols that inform and instruct the user.
Class | MessageBoxWindow | Implementation of MessageBoxWindow class.
Class | MonthCalendar | A calendar control.
Class | MonthCalendarEventArgs | A calendar event arguments class
Class | MouseEventArgs |
Class | NodeLabelEditEventArgs |
Class | NumericUpDown | Represents a Windows spin box (also known as an up-down control) that displays numeric values.
Class | OpenFileDialog | Prompts the user to open a file. This class cannot be inherited.
Class | PagingStrip | A panel that has paging controls embeded
Class | PaintEventArgs |
Class | Panel | Represents a Panel control.
Class | PictureBox | A picture box control
Class | ProfessionalColors | Provides Color structures that are colors of a Windows display element. This class cannot be inherited.
Class | ProfessionalColorTable | Provides colors used for Microsoft Office display elements.
Class | ProgressBar | Represents a WebGUI progress bar control.
Class | PropertyGrid | Provides a user interface for browsing the properties of an object.
Class | PropertyGrid.PropertyTabCollection | Contains a collection of PropertyTab objects.
Class | PropertyManager | Maintains a Binding between an object's property and a data-bound control property.
Class | PropertyStore |
Class | PropertyTabChangedEventArgs | Provides data for the PropertyGrid.PropertyTabChanged event of a PropertyGrid.
Class | PropertyValueChangedEventArgs | Provides data for the PropertyGrid.PropertyValueChanged event of a PropertyGrid.
Class | QuestionEventArgs | Provides data for events that need a true or false answer to a question.
Class | RadioButton | Enables the user to select a single option from a group of choices when paired with other RadioButton controls.
Class | RelatedImageListAttribute |
Class | RichTextBox | Represents a Gizmox.WebGUI.Forms rich text box control.
Class | RowStyle |
Class | Screen | Represents a display device or multiple display devices on a single system.
Class | ScrollableControl | Defines a base class for controls that support auto-scrolling behavior.
Class | ScrollableControl.DockPaddingEdges | Determines the border padding for docked controls.
Class | ScrollableControl.DockPaddingEdgesConverter | DockPaddingEdgesConverter class.
Class | SelectedGridItemChangedEventArgs | Provides data for the PropertyGrid.SelectedGridItemChanged event of the PropertyGrid control.
Class | ShortcutsContainer | Contains a collection of mapped shortcuts
Class | SplitContainer | A split container control.
Class | Splitter | Represents a splitter control that enables the user to resize docked controls. Splitter has been replaced by SplitContainer and is provided only for compatibility with previous versions.
Class | SplitterCancelEventArgs |
Class | SplitterEventArgs |
Class | SplitterPanel | Represents a Panel control.
Class | StatusBar | Represents a Gizmox.WebGUI.Forms status bar control. Although ToolStripStatusLabel replaces and adds functionality to the StatusBar control of previous versions, StatusBar is retained for both backward compatibility and future use if you choose.
Class | StatusBar.StatusBarPanelCollection | Represents the collection of panels in a StatusBar control.
Class | StatusBarPanel | Represents a panel in a StatusBar control. Although the StatusStrip control replaces and adds functionality to the StatusBar control of previous versions, StatusBar is retained for both backward compatibility and future use if you choose.
Class | TabControl | Manages a related set of tab pages.
Class | TabControlCancelEventArgs | Provides data for the Selecting and Deselecting events of a TabControl control.
Class | TableLayoutCellPaintEventArgs |
Class | TableLayoutColumnStyleCollection |
Class | TableLayoutControlCollection | Represents a collection of objects.
Class | TableLayoutPanel | A table layout control.
Class | TableLayoutRowStyleCollection |
Class | TableLayoutSettings |
Class | TableLayoutSettingsTypeConverter |
Class | TableLayoutStyle |
Class | TableLayoutStyleCollection |
Class | TabPage | Represents a single tab page in a TabControl.
Class | TabPageCollection | Contains a collection of TabPage objects.
Class | TabPageCollection.TabIndexComparer | Implements IComparer for TabPages sorting by TabIndex
Class | TabPageEventArgs | Provides data for events of a TabControl control.
Class | TextBox | Implementation of TextBox class.
Class | TextBoxBase | Implements the basic functionality required by text controls.
Class | TextBoxChangedEventArgs |
Class | TextBoxValidation |
Class | Timer | Implements a timer that raises an event at user-defined intervals. This timer is optimized for use in Gizmox.WebGUI.Forms applications and must be used in a window.
Class | ToolBar | ToolBar control.
Class | ToolBarButton | Summary description for ToolBarButton.
Class | ToolBarButtonClickEventArgs |
Class | ToolBarCollection | ToolBar collection.
Class | ToolBarItemCollection |
Class | ToolBarItemEventArgs |
Class | ToolTip | Represents a small rectangular pop-up window that displays a brief description of a control's purpose when the user rests the pointer on the control.
Class | TrackBar | Represents a standard Visual WebGui track bar.
Class | TreeNode | Summary description for TreeNode.
Class | TreeNodeCollection | Collection of tree view nodes
Class | TreeNodeMouseClickEventArgs | Provides data for the TreeView.NodeMouseClick and TreeView.NodeMouseDoubleClick events.
Class | TreeView | Summary description for TreeView.
Class | TreeViewCancelEventArgs |
Class | TreeViewEventArgs |
Class | UpDownBase | Implements the basic functionality required by a spin box (also known as an up-down control).
Class | UserControl | Provides an empty control that can be used to create other controls.
Class | WGSite |
Class | XamlBox | A html control
Class | XamlBox.XamlGateway | Xaml gateway handler

Interfaces

 | Interface | Description
Interface | Binding.IDataSourceAttributeProvider | Provides design time attributes for the DataSource property
Interface | IBindableComponent | Enables a non-control component to emulate the data-binding behavior of a Windows Forms control.
Interface | IButtonControl | Summary description for IButton.
Interface | IContainerControl | Provides the functionality for a control to act as a parent for other controls.
Interface | ICurrencyManagerProvider | Provides custom binding management for components.
Interface | IDataGridViewEditingCell | Defines common functionality for a cell that allows the manipulation of its value.
Interface | IDataGridViewEditingControl | Defines common functionality for controls that are hosted within cells of a DataGridView.

Structures

 | Structure | Description
Structure | BindingMemberInfo | Contains information that enables a Binding to resolve a data binding to either the property of an object or the property of the current object in a list of objects.
Structure | Padding | Represents padding or margin information associated with a user interface (UI) element.
Structure | TableLayoutPanelCellPosition |

Delegates

 | Delegate | Description
Delegate | BindingCompleteEventHandler | Represents the method that will handle the Binding.BindingComplete event in data-binding scenarios.
Delegate | BindingManagerDataErrorEventHandler | Represents the method that will handle the BindingManagerBase.DataError event of a BindingManagerBase.
Delegate | ColumnClickEventHandler |
Delegate | ControlEventHandler | Represents the method that will handle the ControlAdded and ControlRemoved events of the Control class.
Delegate | ConvertEventHandler | Represents the method that will handle the Binding.Parse and Binding.Format events of a Binding.
Delegate | DataGridViewAutoSizeColumnModeEventHandler | Represents the method that will handle the DataGridView.AutoSizeColumnModeChanged event of a DataGridView control.
Delegate | DataGridViewAutoSizeColumnsModeEventHandler | Represents the method that will handle the DataGridView.AutoSizeColumnsModeChanged event of a DataGridView control.
Delegate | DataGridViewAutoSizeModeEventHandler | Represents the method that will handle the DataGridView.AutoSizeRowsModeChanged or DataGridView.RowHeadersWidthSizeModeChanged events of a DataGridView.
Delegate | DataGridViewBindingCompleteEventHandler | Represents the method that will handle the DataGridView.DataBindingComplete event of a DataGridView.
Delegate | DataGridViewCellCancelEventHandler | Represents the method that will handle the DataGridView.CellBeginEdit and DataGridView.RowValidating events of a DataGridView.
Delegate | DataGridViewCellErrorTextNeededEventHandler | Represents the method that will handle the DataGridView.CellErrorTextNeeded event of a DataGridView.
Delegate | DataGridViewCellEventHandler | Represents the method that will handle DataGridView events related to cell and row operations.
Delegate | DataGridViewCellFormattingEventHandler | Represents the method that will handle the DataGridView.CellFormatting event of a DataGridView.
Delegate | DataGridViewCellMouseEventHandler | Represents the method that will handle mouse-related events raised by a DataGridView.
Delegate | DataGridViewCellParsingEventHandler | Represents the method that will handle a DataGridView.CellParsing event of a DataGridView.
Delegate | DataGridViewCellStateChangedEventHandler | Represents the method that will handle the DataGridView.CellStateChanged event of a DataGridView.
Delegate | DataGridViewCellStyleContentChangedEventHandler | Represents the method that will handle the DataGridView.CellStyleContentChanged event of a DataGridView.
Delegate | DataGridViewCellToolTipTextNeededEventHandler | Represents the method that will handle the DataGridView.CellToolTipTextNeeded event of a DataGridView.
Delegate | DataGridViewCellValidatingEventHandler | Represents the method that will handle the DataGridView.CellValidating event of a DataGridView control.
Delegate | DataGridViewCellValueEventHandler | Represents the method that will handle the DataGridView.CellValueNeeded event or DataGridView.CellValuePushed event of a DataGridView.
Delegate | DataGridViewColumnDividerDoubleClickEventHandler | Represents the method that will handle the DataGridView.ColumnDividerDoubleClick event of a DataGridView.
Delegate | DataGridViewColumnEventHandler | Represents the method that will handle column-related events of a DataGridView.
Delegate | DataGridViewColumnStateChangedEventHandler | Represents the method that will handle the DataGridView.ColumnStateChanged event of a DataGridView.
Delegate | DataGridViewDataErrorEventHandler | Represents the method that will handle the DataGridView.DataError event of a DataGridView.
Delegate | DataGridViewEditingControlShowingEventHandler | Represents the method that will handle the DataGridView.EditingControlShowing event of a DataGridView.
Delegate | DataGridViewRowCancelEventHandler | Represents the method that will handle the DataGridView.UserDeletingRow event of a DataGridView.
Delegate | DataGridViewRowContextMenuStripNeededEventHandler | Represents the method that will handle the DataGridView.RowContextMenuStripNeeded event of a DataGridView.
Delegate | DataGridViewRowDividerDoubleClickEventHandler | Represents the method that will handle the DataGridView.RowDividerDoubleClick event of a DataGridView.
Delegate | DataGridViewRowErrorTextNeededEventHandler | Represents the method that will handle the DataGridView.RowErrorTextNeeded event of a DataGridView.
Delegate | DataGridViewRowEventHandler | Represents the method that will handle row-related events of a DataGridView.
Delegate | DataGridViewRowHeightInfoNeededEventHandler | Represents the method that will handle an DataGridView.RowHeightInfoNeeded event of a DataGridView control.
Delegate | DataGridViewRowHeightInfoPushedEventHandler | Represents the method that will handle the DataGridView.RowHeightInfoPushed event of a DataGridView.
Delegate | DataGridViewRowsAddedEventHandler | Represents the method that will handle the DataGridView.RowsAdded event of a DataGridView.
Delegate | DataGridViewRowsRemovedEventHandler | Represents the method that will handle the DataGridView.RowsRemoved event of a DataGridView.
Delegate | DataGridViewRowStateChangedEventHandler | Represents the method that will handle the DataGridView.RowStateChanged event of a DataGridView.
Delegate | DataGridViewSortCompareEventHandler | Represents the method that will handle the DataGridView.SortCompare event of a DataGridView control.
Delegate | DragEventHandler | Represents the method that will handle the DragDrop, DragEnter, or DragOver event of a Control.
Delegate | HelpEventHandler | Represents the method that will handle the HelpRequested event of a Control.
Delegate | ItemChangedEventHandler | Represents the method that will handle the CurrencyManager.ItemChanged event of the CurrencyManager class.
Delegate | ItemCheckHandler | The item check delgate
Delegate | KeyEventHandler | Key event hablder
Delegate | KeyPressEventHandler | Represents the method that will handle the KeyPress event of a Control.
Delegate | LinkLabelLinkClickedEventHandler | Represents the method that will handle the LinkLabel.LinkClicked event of a LinkLabel.
Delegate | ListControlConvertEventHandler | Represents the method that will handle converting a ListControl.
Delegate | ListViewItemEventHandler | A list item event handler delegate
Delegate | MenuEventHandler | Handles menu item events
Delegate | MonthCalendarEventHandler | Calendaer event handler delgate
Delegate | MouseEventHandler |
Delegate | NodeLabelEditEventHandler |
Delegate | PropertyTabChangedEventHandler | Represents the method that will handle the PropertyGrid.PropertyTabChanged event of a PropertyGrid.
Delegate | PropertyValueChangedEventHandler | The event handler class that is invoked when a property in the grid is modified by the user.
Delegate | QuestionEventHandler | Represents the method that will handle the DataGridView.CancelRowEdit event or the DataGridView.RowDirtyStateNeeded event of a DataGridView.
Delegate | SelectedGridItemChangedEventHandler | Represents the method that will handle the PropertyGrid.SelectedGridItemChanged event of a PropertyGrid.
Delegate | SplitterCancelEventHandler |
Delegate | SplitterEventHandler |
Delegate | TabControlCancelEventHandler | Represents the method that will handle the Selecting or Deselecting event of a TabControl control.
Delegate | TableLayoutCellPaintEventHandler |
Delegate | TabPageEventHandler | Represents the method that will handle events of a TabControl control.
Delegate | ToolBarButtonClickEventHandler |
Delegate | ToolBarItemHandler |
Delegate | TreeNodeMouseClickEventHandler | Represents the method that will handle the TreeView.NodeMouseClick and TreeView.NodeMouseDoubleClick events of a TreeView.
Delegate | TreeViewCancelEventHandler |
Delegate | TreeViewEventHandler |

Enumerations

 | Enumeration | Description
Enumeration | AnchorStyles | Control anchoring styles
Enumeration | AutoCompleteMode | Specifies the mode for the automatic completion feature used in the ComboBox and TextBox controls.
Enumeration | AutoCompleteSource | Specifies the source for ComboBox and TextBox automatic completion functionality.
Enumeration | AutoSizeMode | Specifies how a control will behave when its Control.AutoSize property is enabled.
Enumeration | BindingCompleteContext | Specifies the direction of the binding operation.
Enumeration | BindingCompleteState | Indicates the result of a completed binding operation.
Enumeration | BorderStyle | Border style types
Enumeration | BoundsSpecified |
Enumeration | ButtonState | Specifies the appearance of a button.
Enumeration | ButtonStyle |
Enumeration | CharacterCasing | Specifies the case of characters in a TextBox control.
Enumeration | CheckBoxVisibility | Defines the node's check box - visiiblity
Enumeration | ColumnHeaderAutoResizeStyle | Specifies how a column contained in a ListView should be resized.
Enumeration | ColumnHeaderStyle | Specifies the styles of the column headers in a ListView control.
Enumeration | ComboBoxStyle | Specifies the ComboBox style.
Enumeration | ControlStyles |
Enumeration | ControlUpdateMode | Determines when changes to a data source value get propagated to the corresponding data-bound control property.
Enumeration | DataGridViewAdvancedCellBorderStyle | Specifies the border styles that can be applied to the cells of a DataGridView control.
Enumeration | DataGridViewAutoSizeColumnMode | Defines values for specifying how the width of a column is adjusted.
Enumeration | DataGridViewAutoSizeColumnsMode | Defines values for specifying how the widths of columns are adjusted.
Enumeration | DataGridViewAutoSizeRowMode | Defines values for specifying how the height of a row is adjusted.
Enumeration | DataGridViewAutoSizeRowsMode | Defines values for specifying how the heights of rows are adjusted.
Enumeration | DataGridViewCellBorderStyle | Specifies the border styles that can be applied to the cells of a DataGridView control.
Enumeration | DataGridViewCellStyleScopes | Specifies the DataGridView entity that owns the cell style that was changed.
Enumeration | DataGridViewClipboardCopyMode | Defines constants that indicate whether content is copied from a DataGridView control to the Clipboard.
Enumeration | DataGridViewColumnHeadersHeightSizeMode | Defines values for specifying how the height of the column headers is adjusted.
Enumeration | DataGridViewColumnSortMode | Defines how a DataGridView column can be sorted by the user.
Enumeration | DataGridViewComboBoxDisplayStyle | Defines constants that indicate how a DataGridViewComboBoxCell is displayed.
Enumeration | DataGridViewContentAlignment | Defines constants that indicate the alignment of content within a DataGridView cell.
Enumeration | DataGridViewDataErrorContexts | Represents the state of a data-bound DataGridView control when a data error occurred.
Enumeration | DataGridViewEditMode | Specifies how a user starts cell editing in the DataGridView control.
Enumeration | DataGridViewElementStates | Specifies the user interface (UI) state of a element within a DataGridView control.
Enumeration | DataGridViewHeaderBorderStyle | Specifies the border style that can be applied to the DataGridView.ColumnHeadersBorderStyle and DataGridView.RowHeadersBorderStyle properties of a DataGridView control.
Enumeration | DataGridViewHitTestType | Specifies a location in a DataGridView control.
Enumeration | DataGridViewImageCellLayout | Specifies the layout for an image contained in a DataGridViewCell.
Enumeration | DataGridViewPaintParts | Defines values for specifying the parts of a DataGridViewCell that are to be painted.
Enumeration | DataGridViewRowHeadersWidthSizeMode | Defines values for specifying how the row header width is adjusted.
Enumeration | DataGridViewSelectionMode | Describes how cells of a DataGridView control can be selected.
Enumeration | DataGridViewTriState | Defines values for specifying one of three possible states.
Enumeration | DataSourceUpdateMode | Specifies when a data source is updated when changes occur in the bound control.
Enumeration | DateTimePickerFormat | Specifies the date and time format the DateTimePicker control displays.
Enumeration | Day | Specifies the day of the week.
Enumeration | DialogAlignment | Reletive aligment of a aligned dialog.
Enumeration | DockStyle | Control docking style
Enumeration | DragDropEffects | Specifies the effects of a drag-and-drop operation.
Enumeration | ErrorBlinkStyle | Specifies constants indicating when the error icon, supplied by an ErrorProvider, should blink to alert the user that an error has occurred.
Enumeration | ErrorIconAlignment | Specifies constants indicating the locations that an error icon can appear in relation to the control with an error.
Enumeration | ExtendedHorizontalAlignment | Specifies how an object or text in a control is horizontally aligned relative to an element of the control and includes inheritance definition.
Enumeration | FixedPanel |
Enumeration | FlatStyle | The component style (WinForms Complaint)
Enumeration | FlowDirection | Defines constants that specify the direction in which consecutive user interface (UI) elements are placed in a linear layout container.
Enumeration | FormBorderStyle |
Enumeration | FormStartPosition |
Enumeration | FormStyle |
Enumeration | FormWindowState |
Enumeration | GridItemType | Specifies the valid grid item types for a PropertyGrid.
Enumeration | HelpNavigator | Specifies constants indicating which elements of the Help file to display.
Enumeration | HorizontalAlignment | Specifies how an object or text in a control is horizontally aligned relative to an element of the control.
Enumeration | HtmlBoxType | The html box content type
Enumeration | ImageLayout | Specifies the position of the image on the control.
Enumeration | ItemActivation |
Enumeration | LeftRightAlignment | Specifies whether an object or text is aligned to the left or right of a reference point.
Enumeration | LinkBehavior | Specifies the behaviors of a link in a LinkLabel.
Enumeration | LinkState | Specifies constants that define the state of the link.
Enumeration | ListViewColumnType |
Enumeration | MaskFormat | Defines how to format the Text property. MaskedTextBox.
Enumeration | MdiLayout | Specifies the layout of multiple document interface (MDI) child windows in an MDI parent window.
Enumeration | MessageBoxButtons | Specifies constants defining which buttons to display on a MessageBox.
Enumeration | MessageBoxDefaultButton | Specifies constants defining the default button on a MessageBox.
Enumeration | MessageBoxIcon | Specifies constants defining which information to display.
Enumeration | MessageBoxOptions | Specifies options on a MessageBox.
Enumeration | Orientation | Specifies the orientation of controls or elements of controls.
Enumeration | PanelType | The panel display tyle
Enumeration | PictureBoxSizeMode | Specifies how an image is positioned within a PictureBox.
Enumeration | ProfessionalColorTable.KnownColors |
Enumeration | PropertySort | Specifies how properties are sorted in the PropertyGrid.
Enumeration | RightToLeft | Specifies a value indicating whether the text appears from right to left, such as when using Hebrew or Arabic fonts.
Enumeration | ScrollBars | Specifies which scroll bars will be visible on a control.
Enumeration | ScrollStyle | Control scrolling style
Enumeration | SelectionMode | Specifies the selection behavior of a list box.
Enumeration | SelectOnRightClickBehvior |
Enumeration | Shortcut |
Enumeration | SizeType |
Enumeration | SortOrder | sort order options enumeration
Enumeration | StatusBarPanelAutoSize | Specifies how a StatusBarPanel on a StatusBar control behaves when the control resizes.
Enumeration | TabAppearance | Specifies the appearance of the tabs in a tab control.
Enumeration | TabControlClientBehavior | Tab control client behavior modes
Enumeration | TableLayoutPanelCellBorderStyle |
Enumeration | TableLayoutPanelGrowStyle |
Enumeration | TextDataFormat | Specifies the formats used with text-related methods of the Clipboard and DataObject classes.
Enumeration | TextFormatFlags | Specifies the display and layout information for text strings.
Enumeration | TextImageRelation | Specifies the position of the text and image relative to each other on a control.
Enumeration | TickStyle | Specifies the location of tick marks in a TrackBar control.
Enumeration | ToolBarAppearance | Toolbar appeatance style
Enumeration | ToolBarButtonStyle | Toolbar button stylr
Enumeration | ToolBarTextAlign | Toolbar buttons text alignment
Enumeration | TreeViewAction |
Enumeration | View | The list display mode
Enumeration | XamlBoxType | The silverlight content type

See Also

Reference

Gizmox.WebGUI.Forms Assembly


BaseCollection Class

[image]
Gizmox.WebGUI.Forms
BaseCollection Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : BaseCollection Class

Provides the base functionality for creating data-related collections in the Gizmox.WebGUI.Forms Namespace namespace.

Syntax

Visual Basic (Declaration)
Public Class BaseCollection
Visual Basic (Usage) Copy Code
Dim instance As BaseCollection
C#
public class BaseCollection
Managed Extensions for C++
public __gc class BaseCollection
C++/CLI
public ref class BaseCollection

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.BaseCollection
Gizmox.WebGUI.Forms.BindingsCollection
Gizmox.WebGUI.Forms.DataGridViewCellCollection
Gizmox.WebGUI.Forms.DataGridViewColumnCollection
Gizmox.WebGUI.Forms.DataGridViewSelectedCellCollection
Gizmox.WebGUI.Forms.DataGridViewSelectedColumnCollection
Gizmox.WebGUI.Forms.DataGridViewSelectedRowCollection
Gizmox.WebGUI.Forms.ScheduleBoxEventCollection
Gizmox.WebGUI.Forms.TreeNodeCollection

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

BaseCollection Members
Gizmox.WebGUI.Forms Namespace


BaseCollection Class Members

[image]
Gizmox.WebGUI.Forms
BaseCollection Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : BaseCollection Class

The following tables list the members exposed by BaseCollection.

Public Constructors

 | Name | Description
Public Constructor | BaseCollection Constructor |
Top

Public Properties

 | Name | Description
Public Property | Count | Gets the total number of elements in the collection.
Public Property | IsReadOnly | Gets a value indicating whether the collection is read-only.
Public Property | IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized.
Public Property | SyncRoot | Gets an object that can be used to synchronize access to the BaseCollection.
Top

Protected Properties

 | Name | Description
Protected Property | List | Gets the list of elements contained in the BaseCollection instance.
Top

Public Methods

 | Name | Description
Public Method | CopyTo | Copies all the elements of the current one-dimensional Array to the specified one-dimensional Array starting at the specified destination Array index.
Public Method | GetEnumerator | Gets the object that enables iterating through the members of the collection.
Top

See Also

Reference

BaseCollection Class
Gizmox.WebGUI.Forms Namespace


BaseCollection Constructor

[image]
Gizmox.WebGUI.Forms
BaseCollection Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BaseCollection Class : BaseCollection Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As BaseCollection()
C#
public BaseCollection()
Managed Extensions for C++
public: BaseCollection();
C++/CLI
public:
BaseCollection();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BaseCollection Class
BaseCollection Members


BaseCollection Class Methods

[image]
Gizmox.WebGUI.Forms
BaseCollection Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : BaseCollection Class

For a list of all members of this type, see BaseCollection members.

Public Methods

 | Name | Description
Public Method | CopyTo | Copies all the elements of the current one-dimensional Array to the specified one-dimensional Array starting at the specified destination Array index.
Public Method | GetEnumerator | Gets the object that enables iterating through the members of the collection.
Top

See Also

Reference

BaseCollection Class
Gizmox.WebGUI.Forms Namespace


CopyTo Method

[image]
Gizmox.WebGUI.Forms
CopyTo Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BaseCollection Class : CopyTo Method

ar
The one-dimensional Array that is the destination of the elements copied from the current Array.
index
The zero-based relative index in ar at which copying begins.
Copies all the elements of the current one-dimensional Array to the specified one-dimensional Array starting at the specified destination Array index.

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal ar As Array, _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As BaseCollection
Dim ar As Array
Dim index As Integer

instance.CopyTo(ar, index)
C#
public void CopyTo(
   Array ar,
   int index
)
Managed Extensions for C++
public: void CopyTo(
   Array* ar,
   int index
)
C++/CLI
public:
void CopyTo(
   Array^ ar,
   int index
)

Parameters

ar
The one-dimensional Array that is the destination of the elements copied from the current Array.
index
The zero-based relative index in ar at which copying begins.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BaseCollection Class
BaseCollection Members


GetEnumerator Method

[image]
Gizmox.WebGUI.Forms
GetEnumerator Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BaseCollection Class : GetEnumerator Method

Gets the object that enables iterating through the members of the collection.

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As BaseCollection
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Return Value

An object that implements the IEnumerator interface.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BaseCollection Class
BaseCollection Members


BaseCollection Class Properties

[image]
Gizmox.WebGUI.Forms
BaseCollection Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : BaseCollection Class

For a list of all members of this type, see BaseCollection members.

Public Properties

 | Name | Description
Public Property | Count | Gets the total number of elements in the collection.
Public Property | IsReadOnly | Gets a value indicating whether the collection is read-only.
Public Property | IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized.
Public Property | SyncRoot | Gets an object that can be used to synchronize access to the BaseCollection.
Top

Protected Properties

 | Name | Description
Protected Property | List | Gets the list of elements contained in the BaseCollection instance.
Top

See Also

Reference

BaseCollection Class
Gizmox.WebGUI.Forms Namespace


Count Property

[image]
Gizmox.WebGUI.Forms
Count Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BaseCollection Class : Count Property

Gets the total number of elements in the collection.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Overridable ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As BaseCollection
Dim value As Integer

value = instance.Count
C#
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public virtual int Count {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: __property virtual int get_Count();
C++/CLI
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
virtual property int Count {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BaseCollection Class
BaseCollection Members


IsReadOnly Property

[image]
Gizmox.WebGUI.Forms
IsReadOnly Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BaseCollection Class : IsReadOnly Property

Gets a value indicating whether the collection is read-only.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public ReadOnly Property IsReadOnly As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BaseCollection
Dim value As Boolean

value = instance.IsReadOnly
C#
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public bool IsReadOnly {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: __property bool get_IsReadOnly();
C++/CLI
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
property bool IsReadOnly {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BaseCollection Class
BaseCollection Members


IsSynchronized Property

[image]
Gizmox.WebGUI.Forms
IsSynchronized Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BaseCollection Class : IsSynchronized Property

Gets a value indicating whether access to the ICollection is synchronized.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public ReadOnly Property IsSynchronized As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BaseCollection
Dim value As Boolean

value = instance.IsSynchronized
C#
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public bool IsSynchronized {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: __property bool get_IsSynchronized();
C++/CLI
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
property bool IsSynchronized {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BaseCollection Class
BaseCollection Members


List Property

[image]
Gizmox.WebGUI.Forms
List Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BaseCollection Class : List Property

Gets the list of elements contained in the BaseCollection instance.

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property List As ArrayList
Visual Basic (Usage) Copy Code
Dim instance As BaseCollection
Dim value As ArrayList

value = instance.List
C#
protected virtual ArrayList List {get;}
Managed Extensions for C++
protected: __property virtual ArrayList* get_List();
C++/CLI
protected:
virtual property ArrayList^ List {
   ArrayList^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BaseCollection Class
BaseCollection Members


SyncRoot Property

[image]
Gizmox.WebGUI.Forms
SyncRoot Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BaseCollection Class : SyncRoot Property

Gets an object that can be used to synchronize access to the BaseCollection.

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<BrowsableAttribute(False)>
Public ReadOnly Property SyncRoot As Object
Visual Basic (Usage) Copy Code
Dim instance As BaseCollection
Dim value As Object

value = instance.SyncRoot
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[BrowsableAttribute(false)]
public object SyncRoot {get;}
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[BrowsableAttribute(false)]
public: __property Object* get_SyncRoot();
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[BrowsableAttribute(false)]
public:
property Object^ SyncRoot {
   Object^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BaseCollection Class
BaseCollection Members


Binding Class

[image]
Gizmox.WebGUI.Forms
Binding Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : Binding Class

Represents the simple binding between the property value of an object and the property value of a control.

Object Model

Syntax

Visual Basic (Declaration)
<TypeConverterAttribute("Gizmox.WebGUI.Forms.ListBindingConverter, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d")>
Public Class Binding
Visual Basic (Usage) Copy Code
Dim instance As Binding
C#
[TypeConverterAttribute("Gizmox.WebGUI.Forms.ListBindingConverter, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d")]
public class Binding
Managed Extensions for C++
[TypeConverterAttribute("Gizmox.WebGUI.Forms.ListBindingConverter, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d")]
public __gc class Binding
C++/CLI
[TypeConverterAttribute("Gizmox.WebGUI.Forms.ListBindingConverter, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d")]
public ref class Binding

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.Binding

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Binding Members
Gizmox.WebGUI.Forms Namespace


Binding Class Members

[image]
Gizmox.WebGUI.Forms
Binding Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : Binding Class

The following tables list the members exposed by Binding.

Public Constructors

 | Name | Description
Public Constructor | Binding Constructor | Overloaded. Initializes a new instance of the Binding class that simple-binds the indicated control property to the specified data member of the data source.
Top

Public Properties

 | Name | Description
Public Property | BindableComponent | Gets the control the Binding is associated with.
Public Property | BindingManagerBase | Gets the BindingManagerBase for this Binding.
Public Property | BindingMemberInfo | Gets an object that contains information about this binding based on the dataMember parameter in the Overload constructor.
Public Property | Control | Gets the control that the binding belongs to.
Public Property | ControlUpdateMode | Gets or sets when changes to the data source are propagated to the bound control property.
Public Property | DataSource | Gets the data source for this binding.
Public Property | DataSourceNullValue | Gets or sets the value to be stored in the data source if the control value is null or empty.
Public Property | DataSourceUpdateMode | Gets or sets when changes to the bound control property are propagated to the data source.
Public Property | FormatInfo | Gets or sets the IFormatProvider that provides custom formatting behavior.
Public Property | FormatString | Gets or sets the format specifier characters that indicate how a value is to be displayed.
Public Property | FormattingEnabled | Gets or sets a value indicating whether formatting is applied to the control property data.
Public Property | IsBinding | Gets a value indicating whether the binding is active.
Public Property | NullValue | Gets or sets the Object to be set as the control property when the data source contains a DBNull value.
Public Property | PropertyName | Gets or sets the name of the control's data-bound property.
Top

Public Methods

 | Name | Description
Public Method | ReadValue | Sets the control property to the value read from the data source.
Public Method | WriteValue | Reads the current value from the control property and writes it to the data source.
Top

Protected Methods

 | Name | Description
Protected Method | OnBindingComplete | Raises the BindingComplete event.
Protected Method | OnFormat | Raises the Format event.
Protected Method | OnParse | Raises the Parse event.
Top

Public Events

 | Name | Description
Public Event | BindingComplete | Occurs when a binding operation is complete, such as when data is pushed to the control property from the data source or vice versa
Public Event | Format | Occurs when the property of a control is bound to a data value.
Public Event | Parse | Occurs when the value of a data-bound control changes.
Top

See Also

Reference

Binding Class
Gizmox.WebGUI.Forms Namespace


Binding Constructor

[image]
Gizmox.WebGUI.Forms
Binding Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Binding Class : Binding Constructor

Initializes a new instance of the Binding class that simple-binds the indicated control property to the specified data member of the data source.

Overload List

Overload | Description
Binding Constructor(String,Object,String) | Initializes a new instance of the Binding class that simple-binds the indicated control property to the specified data member of the data source.
Binding Constructor(String,Object,String,Boolean) | Initializes a new instance of the Binding class that binds the indicated control property to the specified data member of the data source, and optionally enables formatting to be applied.
Binding Constructor(String,Object,String,Boolean,DataSourceUpdateMode) | Initializes a new instance of the Binding class that binds the specified control property to the specified data member of the specified data source. Optionally enables formatting and propagates values to the data source based on the specified update setting.
Binding Constructor(String,Object,String,Boolean,DataSourceUpdateMode,Object) | Initializes a new instance of the Binding class that binds the indicated the specified control property to the specified data member of the specified data source. Optionally enables formatting, propagates values to the data source based on the specified update setting, and sets the property to the specified value when a DBNull is returned from the data source.
Binding Constructor(String,Object,String,Boolean,DataSourceUpdateMode,Object,String) | Initializes a new instance of the Binding class that binds the specified control property to the specified data member of the specified data source. Optionally enables formatting with the specified format string; propagates values to the data source based on the specified update setting; enables formatting with the specified format string; and sets the property to the specified value when a DBNull is returned from the data source and sets the specified format provider.
Binding Constructor(String,Object,String,Boolean,DataSourceUpdateMode,Object,String,IFormatProvider) | Initializes a new instance of the Binding class with the specified control property to the specified data member of the specified data source. Optionally enables formatting with the specified format string; propagates values to the data source based on the specified update setting; enables formatting with the specified format string; sets the property to the specified value when a DBNull is returned from the data source; and sets the specified format provider.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Binding Class
Binding Members


Binding Constructor(String,Object,String)

[image]
Gizmox.WebGUI.Forms
Binding Constructor(String,Object,String)
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Binding Class > Binding Constructor : Binding Constructor(String,Object,String)

propertyName
The name of the control property to bind.
dataSource
An Object that represents the data source.
dataMember
The property or list to bind to.
Initializes a new instance of the Binding class that simple-binds the indicated control property to the specified data member of the data source.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal propertyName As String, _
   ByVal dataSource As Object, _
   ByVal dataMember As String _
)
Visual Basic (Usage) Copy Code
Dim propertyName As String
Dim dataSource As Object
Dim dataMember As String

Dim instance As Binding(propertyName, dataSource, dataMember)
C#
public Binding(
   string propertyName,
   object dataSource,
   string dataMember
)
Managed Extensions for C++
public: Binding(
   string* propertyName,
   Object* dataSource,
   string* dataMember
)
C++/CLI
public:
Binding(
   String^ propertyName,
   Object^ dataSource,
   String^ dataMember
)

Parameters

propertyName
The name of the control property to bind.
dataSource
An Object that represents the data source.
dataMember
The property or list to bind to.

Exceptions

Exception | Description
Exception | propertyName is neither a valid property of a control nor an empty string ("").
ArgumentException | The property given by propertyName does not exist on the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Binding Class
Binding Members
Overload List


Binding Constructor(String,Object,String,Boolean)

[image]
Gizmox.WebGUI.Forms
Binding Constructor(String,Object,String,Boolean)
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Binding Class > Binding Constructor : Binding Constructor(String,Object,String,Boolean)

propertyName
The name of the control property to bind.
dataSource
An Object that represents the data source.
dataMember
The property or list to bind to.
formattingEnabled
true to format the displayed data; otherwise, false.
Initializes a new instance of the Binding class that binds the indicated control property to the specified data member of the data source, and optionally enables formatting to be applied.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal propertyName As String, _
   ByVal dataSource As Object, _
   ByVal dataMember As String, _
   ByVal formattingEnabled As Boolean _
)
Visual Basic (Usage) Copy Code
Dim propertyName As String
Dim dataSource As Object
Dim dataMember As String
Dim formattingEnabled As Boolean

Dim instance As Binding(propertyName, dataSource, dataMember, formattingEnabled)
C#
public Binding(
   string propertyName,
   object dataSource,
   string dataMember,
   bool formattingEnabled
)
Managed Extensions for C++
public: Binding(
   string* propertyName,
   Object* dataSource,
   string* dataMember,
   bool formattingEnabled
)
C++/CLI
public:
Binding(
   String^ propertyName,
   Object^ dataSource,
   String^ dataMember,
   bool formattingEnabled
)

Parameters

propertyName
The name of the control property to bind.
dataSource
An Object that represents the data source.
dataMember
The property or list to bind to.
formattingEnabled
true to format the displayed data; otherwise, false.

Exceptions

Exception | Description
Exception | Formatting is disabled and propertyName is neither a valid property of a control nor an empty string ("").
ArgumentException | The property given by propertyName does not exist on the control.-or-The property given is a read-only property.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Binding Class
Binding Members
Overload List


Binding Constructor(String,Object,String,Boolean,DataSourceUpdateMode)

[image]
Gizmox.WebGUI.Forms
Binding Constructor(String,Object,String,Boolean,DataSourceUpdateMode)
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Binding Class > Binding Constructor : Binding Constructor(String,Object,String,Boolean,DataSourceUpdateMode)

propertyName
The name of the control property to bind.
dataSource
An Object representing the data source.
dataMember
The property or list to bind to.
formattingEnabled
true to format the displayed data; otherwise, false.
dataSourceUpdateMode
One of the DataSourceUpdateMode values.
Initializes a new instance of the Binding class that binds the specified control property to the specified data member of the specified data source. Optionally enables formatting and propagates values to the data source based on the specified update setting.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal propertyName As String, _
   ByVal dataSource As Object, _
   ByVal dataMember As String, _
   ByVal formattingEnabled As Boolean, _
   ByVal dataSourceUpdateMode As DataSourceUpdateMode _
)
Visual Basic (Usage) Copy Code
Dim propertyName As String
Dim dataSource As Object
Dim dataMember As String
Dim formattingEnabled As Boolean
Dim dataSourceUpdateMode As DataSourceUpdateMode

Dim instance As Binding(propertyName, dataSource, dataMember, formattingEnabled, dataSourceUpdateMode)
C#
public Binding(
   string propertyName,
   object dataSource,
   string dataMember,
   bool formattingEnabled,
   DataSourceUpdateMode dataSourceUpdateMode
)
Managed Extensions for C++
public: Binding(
   string* propertyName,
   Object* dataSource,
   string* dataMember,
   bool formattingEnabled,
   DataSourceUpdateMode dataSourceUpdateMode
)
C++/CLI
public:
Binding(
   String^ propertyName,
   Object^ dataSource,
   String^ dataMember,
   bool formattingEnabled,
   DataSourceUpdateMode dataSourceUpdateMode
)

Parameters

propertyName
The name of the control property to bind.
dataSource
An Object representing the data source.
dataMember
The property or list to bind to.
formattingEnabled
true to format the displayed data; otherwise, false.
dataSourceUpdateMode
One of the DataSourceUpdateMode values.

Exceptions

Exception | Description
ArgumentException | The property given by propertyName does not exist on the control.-or-The data source or data member or control property specified are associated with another binding in the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Binding Class
Binding Members
Overload List


Binding Constructor(String,Object,String,Boolean,DataSourceUpdateMode,Object)

[image]
Gizmox.WebGUI.Forms
Binding Constructor(String,Object,String,Boolean,DataSourceUpdateMode,Object)
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Binding Class > Binding Constructor : Binding Constructor(String,Object,String,Boolean,DataSourceUpdateMode,Object)

propertyName
The name of the control property to bind.
dataSource
An Object representing the data source.
dataMember
The property or list to bind to.
formattingEnabled
true to format the displayed data; otherwise, false.
dataSourceUpdateMode
One of the DataSourceUpdateMode values.
nullValue
The Object to be applied to the bound control property if the data source value is DBNull.
Initializes a new instance of the Binding class that binds the indicated the specified control property to the specified data member of the specified data source. Optionally enables formatting, propagates values to the data source based on the specified update setting, and sets the property to the specified value when a DBNull is returned from the data source.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal propertyName As String, _
   ByVal dataSource As Object, _
   ByVal dataMember As String, _
   ByVal formattingEnabled As Boolean, _
   ByVal dataSourceUpdateMode As DataSourceUpdateMode, _
   ByVal nullValue As Object _
)
Visual Basic (Usage) Copy Code
Dim propertyName As String
Dim dataSource As Object
Dim dataMember As String
Dim formattingEnabled As Boolean
Dim dataSourceUpdateMode As DataSourceUpdateMode
Dim nullValue As Object

Dim instance As Binding(propertyName, dataSource, dataMember, formattingEnabled, dataSourceUpdateMode, nullValue)
C#
public Binding(
   string propertyName,
   object dataSource,
   string dataMember,
   bool formattingEnabled,
   DataSourceUpdateMode dataSourceUpdateMode,
   object nullValue
)
Managed Extensions for C++
public: Binding(
   string* propertyName,
   Object* dataSource,
   string* dataMember,
   bool formattingEnabled,
   DataSourceUpdateMode dataSourceUpdateMode,
   Object* nullValue
)
C++/CLI
public:
Binding(
   String^ propertyName,
   Object^ dataSource,
   String^ dataMember,
   bool formattingEnabled,
   DataSourceUpdateMode dataSourceUpdateMode,
   Object^ nullValue
)

Parameters

propertyName
The name of the control property to bind.
dataSource
An Object representing the data source.
dataMember
The property or list to bind to.
formattingEnabled
true to format the displayed data; otherwise, false.
dataSourceUpdateMode
One of the DataSourceUpdateMode values.
nullValue
The Object to be applied to the bound control property if the data source value is DBNull.

Exceptions

Exception | Description
ArgumentException | The property given by propertyName does not exist on the control.-or-The data source or data member or control property specified are associated with another binding in the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Binding Class
Binding Members
Overload List


Binding Constructor(String,Object,String,Boolean,DataSourceUpdateMode,Object,String)

[image]
Gizmox.WebGUI.Forms
Binding Constructor(String,Object,String,Boolean,DataSourceUpdateMode,Object,String)
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Binding Class > Binding Constructor : Binding Constructor(String,Object,String,Boolean,DataSourceUpdateMode,Object,String)

propertyName
The name of the control property to bind.
dataSource
An Object representing the data source.
dataMember
The property or list to bind to.
formattingEnabled
true to format the displayed data; otherwise, false.
dataSourceUpdateMode
One of the DataSourceUpdateMode values.
nullValue
The Object to be applied to the bound control property if the data source value is DBNull.
formatString
One or more format specifier characters that indicate how a value is to be displayed.
Initializes a new instance of the Binding class that binds the specified control property to the specified data member of the specified data source. Optionally enables formatting with the specified format string; propagates values to the data source based on the specified update setting; enables formatting with the specified format string; and sets the property to the specified value when a DBNull is returned from the data source and sets the specified format provider.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal propertyName As String, _
   ByVal dataSource As Object, _
   ByVal dataMember As String, _
   ByVal formattingEnabled As Boolean, _
   ByVal dataSourceUpdateMode As DataSourceUpdateMode, _
   ByVal nullValue As Object, _
   ByVal formatString As String _
)
Visual Basic (Usage) Copy Code
Dim propertyName As String
Dim dataSource As Object
Dim dataMember As String
Dim formattingEnabled As Boolean
Dim dataSourceUpdateMode As DataSourceUpdateMode
Dim nullValue As Object
Dim formatString As String

Dim instance As Binding(propertyName, dataSource, dataMember, formattingEnabled, dataSourceUpdateMode, nullValue, formatString)
C#
public Binding(
   string propertyName,
   object dataSource,
   string dataMember,
   bool formattingEnabled,
   DataSourceUpdateMode dataSourceUpdateMode,
   object nullValue,
   string formatString
)
Managed Extensions for C++
public: Binding(
   string* propertyName,
   Object* dataSource,
   string* dataMember,
   bool formattingEnabled,
   DataSourceUpdateMode dataSourceUpdateMode,
   Object* nullValue,
   string* formatString
)
C++/CLI
public:
Binding(
   String^ propertyName,
   Object^ dataSource,
   String^ dataMember,
   bool formattingEnabled,
   DataSourceUpdateMode dataSourceUpdateMode,
   Object^ nullValue,
   String^ formatString
)

Parameters

propertyName
The name of the control property to bind.
dataSource
An Object representing the data source.
dataMember
The property or list to bind to.
formattingEnabled
true to format the displayed data; otherwise, false.
dataSourceUpdateMode
One of the DataSourceUpdateMode values.
nullValue
The Object to be applied to the bound control property if the data source value is DBNull.
formatString
One or more format specifier characters that indicate how a value is to be displayed.

Exceptions

Exception | Description
ArgumentException | The property given by propertyName does not exist on the control.-or-The data source or data member or control property specified are associated with another binding in the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Binding Class
Binding Members
Overload List


Binding Constructor(String,Object,String,Boolean,DataSourceUpdateMode,Object,String,IFormatProvider)

[image]
Gizmox.WebGUI.Forms
Binding Constructor(String,Object,String,Boolean,DataSourceUpdateMode,Object,String,IFormatProvider)
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Binding Class > Binding Constructor : Binding Constructor(String,Object,String,Boolean,DataSourceUpdateMode,Object,String,IFormatProvider)

propertyName
The name of the control property to bind.
dataSource
An Object representing the data source.
dataMember
The property or list to bind to.
formattingEnabled
true to format the displayed data; otherwise, false.
dataSourceUpdateMode
One of the DataSourceUpdateMode values.
nullValue
The Object to be applied to the bound control property if the data source value is DBNull.
formatString
One or more format specifier characters that indicate how a value is to be displayed.
formatInfo
An implementation of IFormatProvider to override default formatting behavior.
Initializes a new instance of the Binding class with the specified control property to the specified data member of the specified data source. Optionally enables formatting with the specified format string; propagates values to the data source based on the specified update setting; enables formatting with the specified format string; sets the property to the specified value when a DBNull is returned from the data source; and sets the specified format provider.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal propertyName As String, _
   ByVal dataSource As Object, _
   ByVal dataMember As String, _
   ByVal formattingEnabled As Boolean, _
   ByVal dataSourceUpdateMode As DataSourceUpdateMode, _
   ByVal nullValue As Object, _
   ByVal formatString As String, _
   ByVal formatInfo As IFormatProvider _
)
Visual Basic (Usage) Copy Code
Dim propertyName As String
Dim dataSource As Object
Dim dataMember As String
Dim formattingEnabled As Boolean
Dim dataSourceUpdateMode As DataSourceUpdateMode
Dim nullValue As Object
Dim formatString As String
Dim formatInfo As IFormatProvider

Dim instance As Binding(propertyName, dataSource, dataMember, formattingEnabled, dataSourceUpdateMode, nullValue, formatString, formatInfo)
C#
public Binding(
   string propertyName,
   object dataSource,
   string dataMember,
   bool formattingEnabled,
   DataSourceUpdateMode dataSourceUpdateMode,
   object nullValue,
   string formatString,
   IFormatProvider formatInfo
)
Managed Extensions for C++
public: Binding(
   string* propertyName,
   Object* dataSource,
   string* dataMember,
   bool formattingEnabled,
   DataSourceUpdateMode dataSourceUpdateMode,
   Object* nullValue,
   string* formatString,
   IFormatProvider* formatInfo
)
C++/CLI
public:
Binding(
   String^ propertyName,
   Object^ dataSource,
   String^ dataMember,
   bool formattingEnabled,
   DataSourceUpdateMode dataSourceUpdateMode,
   Object^ nullValue,
   String^ formatString,
   IFormatProvider^ formatInfo
)

Parameters

propertyName
The name of the control property to bind.
dataSource
An Object representing the data source.
dataMember
The property or list to bind to.
formattingEnabled
true to format the displayed data; otherwise, false.
dataSourceUpdateMode
One of the DataSourceUpdateMode values.
nullValue
The Object to be applied to the bound control property if the data source value is DBNull.
formatString
One or more format specifier characters that indicate how a value is to be displayed.
formatInfo
An implementation of IFormatProvider to override default formatting behavior.

Exceptions

Exception | Description
ArgumentException | The property given by propertyName does not exist on the control.-or-The data source or data member or control property specified are associated with another binding in the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Binding Class
Binding Members
Overload List


Binding Class Methods

[image]
Gizmox.WebGUI.Forms
Binding Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : Binding Class

For a list of all members of this type, see Binding members.

Public Methods

 | Name | Description
Public Method | ReadValue | Sets the control property to the value read from the data source.
Public Method | WriteValue | Reads the current value from the control property and writes it to the data source.
Top

Protected Methods

 | Name | Description
Protected Method | OnBindingComplete | Raises the BindingComplete event.
Protected Method | OnFormat | Raises the Format event.
Protected Method | OnParse | Raises the Parse event.
Top

See Also

Reference

Binding Class
Gizmox.WebGUI.Forms Namespace


OnBindingComplete Method

[image]
Gizmox.WebGUI.Forms
OnBindingComplete Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Binding Class : OnBindingComplete Method

e
A BindingCompleteEventArgs that contains the event data.
Raises the BindingComplete event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnBindingComplete( _
   ByVal e As BindingCompleteEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As Binding
Dim e As BindingCompleteEventArgs

instance.OnBindingComplete(e)
C#
protected virtual void OnBindingComplete(
   BindingCompleteEventArgs e
)
Managed Extensions for C++
protected: virtual void OnBindingComplete(
   BindingCompleteEventArgs* e
)
C++/CLI
protected:
virtual void OnBindingComplete(
   BindingCompleteEventArgs^ e
)

Parameters

e
A BindingCompleteEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Binding Class
Binding Members


OnFormat Method

[image]
Gizmox.WebGUI.Forms
OnFormat Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Binding Class : OnFormat Method

cevent
A ConvertEventArgs that contains the event data.
Raises the Format event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnFormat( _
   ByVal cevent As ConvertEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As Binding
Dim cevent As ConvertEventArgs

instance.OnFormat(cevent)
C#
protected virtual void OnFormat(
   ConvertEventArgs cevent
)
Managed Extensions for C++
protected: virtual void OnFormat(
   ConvertEventArgs* cevent
)
C++/CLI
protected:
virtual void OnFormat(
   ConvertEventArgs^ cevent
)

Parameters

cevent
A ConvertEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Binding Class
Binding Members


OnParse Method

[image]
Gizmox.WebGUI.Forms
OnParse Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Binding Class : OnParse Method

cevent
A ConvertEventArgs that contains the event data.
Raises the Parse event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnParse( _
   ByVal cevent As ConvertEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As Binding
Dim cevent As ConvertEventArgs

instance.OnParse(cevent)
C#
protected virtual void OnParse(
   ConvertEventArgs cevent
)
Managed Extensions for C++
protected: virtual void OnParse(
   ConvertEventArgs* cevent
)
C++/CLI
protected:
virtual void OnParse(
   ConvertEventArgs^ cevent
)

Parameters

cevent
A ConvertEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Binding Class
Binding Members


ReadValue Method

[image]
Gizmox.WebGUI.Forms
ReadValue Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Binding Class : ReadValue Method

Sets the control property to the value read from the data source.

Syntax

Visual Basic (Declaration)
Public Sub ReadValue()
Visual Basic (Usage) Copy Code
Dim instance As Binding

instance.ReadValue()
C#
public void ReadValue()
Managed Extensions for C++
public: void ReadValue();
C++/CLI
public:
void ReadValue();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Binding Class
Binding Members


WriteValue Method

[image]
Gizmox.WebGUI.Forms
WriteValue Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Binding Class : WriteValue Method

Reads the current value from the control property and writes it to the data source.

Syntax

Visual Basic (Declaration)
Public Sub WriteValue()
Visual Basic (Usage) Copy Code
Dim instance As Binding

instance.WriteValue()
C#
public void WriteValue()
Managed Extensions for C++
public: void WriteValue();
C++/CLI
public:
void WriteValue();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Binding Class
Binding Members


Binding Class Properties

[image]
Gizmox.WebGUI.Forms
Binding Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : Binding Class

For a list of all members of this type, see Binding members.

Public Properties

 | Name | Description
Public Property | BindableComponent | Gets the control the Binding is associated with.
Public Property | BindingManagerBase | Gets the BindingManagerBase for this Binding.
Public Property | BindingMemberInfo | Gets an object that contains information about this binding based on the dataMember parameter in the Overload constructor.
Public Property | Control | Gets the control that the binding belongs to.
Public Property | ControlUpdateMode | Gets or sets when changes to the data source are propagated to the bound control property.
Public Property | DataSource | Gets the data source for this binding.
Public Property | DataSourceNullValue | Gets or sets the value to be stored in the data source if the control value is null or empty.
Public Property | DataSourceUpdateMode | Gets or sets when changes to the bound control property are propagated to the data source.
Public Property | FormatInfo | Gets or sets the IFormatProvider that provides custom formatting behavior.
Public Property | FormatString | Gets or sets the format specifier characters that indicate how a value is to be displayed.
Public Property | FormattingEnabled | Gets or sets a value indicating whether formatting is applied to the control property data.
Public Property | IsBinding | Gets a value indicating whether the binding is active.
Public Property | NullValue | Gets or sets the Object to be set as the control property when the data source contains a DBNull value.
Public Property | PropertyName | Gets or sets the name of the control's data-bound property.
Top

See Also

Reference

Binding Class
Gizmox.WebGUI.Forms Namespace


BindableComponent Property

[image]
Gizmox.WebGUI.Forms
BindableComponent Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Binding Class : BindableComponent Property

Gets the control the Binding is associated with.

Syntax

Visual Basic (Declaration)
<SecurityPermissionAttribute(Assertion=False,
   UnmanagedCode=True,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=False,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Unrestricted=False)>
<DefaultValueAttribute()>
Public ReadOnly Property BindableComponent As IBindableComponent
Visual Basic (Usage) Copy Code
Dim instance As Binding
Dim value As IBindableComponent

value = instance.BindableComponent
C#
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
[DefaultValueAttribute()]
public IBindableComponent BindableComponent {get;}
Managed Extensions for C++
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
[DefaultValueAttribute()]
public: __property IBindableComponent* get_BindableComponent();
C++/CLI
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
[DefaultValueAttribute()]
public:
property IBindableComponent^ BindableComponent {
   IBindableComponent^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Binding Class
Binding Members


BindingManagerBase Property

[image]
Gizmox.WebGUI.Forms
BindingManagerBase Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Binding Class : BindingManagerBase Property

Gets the BindingManagerBase for this Binding.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property BindingManagerBase As BindingManagerBase
Visual Basic (Usage) Copy Code
Dim instance As Binding
Dim value As BindingManagerBase

value = instance.BindingManagerBase
C#
public BindingManagerBase BindingManagerBase {get;}
Managed Extensions for C++
public: __property BindingManagerBase* get_BindingManagerBase();
C++/CLI
public:
property BindingManagerBase^ BindingManagerBase {
   BindingManagerBase^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Binding Class
Binding Members


BindingMemberInfo Property

[image]
Gizmox.WebGUI.Forms
BindingMemberInfo Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Binding Class : BindingMemberInfo Property

Gets an object that contains information about this binding based on the dataMember parameter in the Overload constructor.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property BindingMemberInfo As BindingMemberInfo
Visual Basic (Usage) Copy Code
Dim instance As Binding
Dim value As BindingMemberInfo

value = instance.BindingMemberInfo
C#
public BindingMemberInfo BindingMemberInfo {get;}
Managed Extensions for C++
public: __property BindingMemberInfo get_BindingMemberInfo();
C++/CLI
public:
property BindingMemberInfo BindingMemberInfo {
   BindingMemberInfo get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Binding Class
Binding Members


Control Property

[image]
Gizmox.WebGUI.Forms
Control Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Binding Class : Control Property

Gets the control that the binding belongs to.

Syntax

Visual Basic (Declaration)
<SecurityPermissionAttribute(Assertion=False,
   UnmanagedCode=True,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=False,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Unrestricted=False)>
<DefaultValueAttribute()>
Public ReadOnly Property Control As Control
Visual Basic (Usage) Copy Code
Dim instance As Binding
Dim value As Control

value = instance.Control
C#
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
[DefaultValueAttribute()]
public Control Control {get;}
Managed Extensions for C++
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
[DefaultValueAttribute()]
public: __property Control* get_Control();
C++/CLI
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
[DefaultValueAttribute()]
public:
property Control^ Control {
   Control^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Binding Class
Binding Members


ControlUpdateMode Property

[image]
Gizmox.WebGUI.Forms
ControlUpdateMode Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Binding Class : ControlUpdateMode Property

Gets or sets when changes to the data source are propagated to the bound control property.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property ControlUpdateMode As ControlUpdateMode
Visual Basic (Usage) Copy Code
Dim instance As Binding
Dim value As ControlUpdateMode

instance.ControlUpdateMode = value

value = instance.ControlUpdateMode
C#
[DefaultValueAttribute()]
public ControlUpdateMode ControlUpdateMode {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property ControlUpdateMode get_ControlUpdateMode();
public: __property void set_ControlUpdateMode(
   ControlUpdateMode value
);
C++/CLI
[DefaultValueAttribute()]
public:
property ControlUpdateMode ControlUpdateMode {
   ControlUpdateMode get();
   void set (ControlUpdateModevalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Binding Class
Binding Members


DataSource Property

[image]
Gizmox.WebGUI.Forms
DataSource Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Binding Class : DataSource Property

Gets the data source for this binding.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DataSource As Object
Visual Basic (Usage) Copy Code
Dim instance As Binding
Dim value As Object

value = instance.DataSource
C#
public object DataSource {get;}
Managed Extensions for C++
public: __property Object* get_DataSource();
C++/CLI
public:
property Object^ DataSource {
   Object^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Binding Class
Binding Members


DataSourceNullValue Property

[image]
Gizmox.WebGUI.Forms
DataSourceNullValue Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Binding Class : DataSourceNullValue Property

Gets or sets the value to be stored in the data source if the control value is null or empty.

Syntax

Visual Basic (Declaration)
Public Property DataSourceNullValue As Object
Visual Basic (Usage) Copy Code
Dim instance As Binding
Dim value As Object

instance.DataSourceNullValue = value

value = instance.DataSourceNullValue
C#
public object DataSourceNullValue {get; set;}
Managed Extensions for C++
public: __property Object* get_DataSourceNullValue();
public: __property void set_DataSourceNullValue(
   Object* value
);
C++/CLI
public:
property Object^ DataSourceNullValue {
   Object^ get();
   void set (Object^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Binding Class
Binding Members


DataSourceUpdateMode Property

[image]
Gizmox.WebGUI.Forms
DataSourceUpdateMode Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Binding Class : DataSourceUpdateMode Property

Gets or sets when changes to the bound control property are propagated to the data source.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property DataSourceUpdateMode As DataSourceUpdateMode
Visual Basic (Usage) Copy Code
Dim instance As Binding
Dim value As DataSourceUpdateMode

instance.DataSourceUpdateMode = value

value = instance.DataSourceUpdateMode
C#
[DefaultValueAttribute()]
public DataSourceUpdateMode DataSourceUpdateMode {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property DataSourceUpdateMode get_DataSourceUpdateMode();
public: __property void set_DataSourceUpdateMode(
   DataSourceUpdateMode value
);
C++/CLI
[DefaultValueAttribute()]
public:
property DataSourceUpdateMode DataSourceUpdateMode {
   DataSourceUpdateMode get();
   void set (DataSourceUpdateModevalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Binding Class
Binding Members


FormatInfo Property

[image]
Gizmox.WebGUI.Forms
FormatInfo Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Binding Class : FormatInfo Property

Gets or sets the IFormatProvider that provides custom formatting behavior.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property FormatInfo As IFormatProvider
Visual Basic (Usage) Copy Code
Dim instance As Binding
Dim value As IFormatProvider

instance.FormatInfo = value

value = instance.FormatInfo
C#
[DefaultValueAttribute()]
public IFormatProvider FormatInfo {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property IFormatProvider* get_FormatInfo();
public: __property void set_FormatInfo(
   IFormatProvider* value
);
C++/CLI
[DefaultValueAttribute()]
public:
property IFormatProvider^ FormatInfo {
   IFormatProvider^ get();
   void set (IFormatProvider^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Binding Class
Binding Members


FormatString Property

[image]
Gizmox.WebGUI.Forms
FormatString Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Binding Class : FormatString Property

Gets or sets the format specifier characters that indicate how a value is to be displayed.

Syntax

Visual Basic (Declaration)
Public Property FormatString As String
Visual Basic (Usage) Copy Code
Dim instance As Binding
Dim value As String

instance.FormatString = value

value = instance.FormatString
C#
public string FormatString {get; set;}
Managed Extensions for C++
public: __property string* get_FormatString();
public: __property void set_FormatString(
   string* value
);
C++/CLI
public:
property String^ FormatString {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Binding Class
Binding Members


FormattingEnabled Property

[image]
Gizmox.WebGUI.Forms
FormattingEnabled Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Binding Class : FormattingEnabled Property

Gets or sets a value indicating whether formatting is applied to the control property data.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property FormattingEnabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Binding
Dim value As Boolean

instance.FormattingEnabled = value

value = instance.FormattingEnabled
C#
[DefaultValueAttribute()]
public bool FormattingEnabled {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property bool get_FormattingEnabled();
public: __property void set_FormattingEnabled(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
public:
property bool FormattingEnabled {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Binding Class
Binding Members


IsBinding Property

[image]
Gizmox.WebGUI.Forms
IsBinding Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Binding Class : IsBinding Property

Gets a value indicating whether the binding is active.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsBinding As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Binding
Dim value As Boolean

value = instance.IsBinding
C#
public bool IsBinding {get;}
Managed Extensions for C++
public: __property bool get_IsBinding();
C++/CLI
public:
property bool IsBinding {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Binding Class
Binding Members


NullValue Property

[image]
Gizmox.WebGUI.Forms
NullValue Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Binding Class : NullValue Property

Gets or sets the Object to be set as the control property when the data source contains a DBNull value.

Syntax

Visual Basic (Declaration)
Public Property NullValue As Object
Visual Basic (Usage) Copy Code
Dim instance As Binding
Dim value As Object

instance.NullValue = value

value = instance.NullValue
C#
public object NullValue {get; set;}
Managed Extensions for C++
public: __property Object* get_NullValue();
public: __property void set_NullValue(
   Object* value
);
C++/CLI
public:
property Object^ NullValue {
   Object^ get();
   void set (Object^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Binding Class
Binding Members


PropertyName Property

[image]
Gizmox.WebGUI.Forms
PropertyName Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Binding Class : PropertyName Property

Gets or sets the name of the control's data-bound property.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public ReadOnly Property PropertyName As String
Visual Basic (Usage) Copy Code
Dim instance As Binding
Dim value As String

value = instance.PropertyName
C#
[DefaultValueAttribute()]
public string PropertyName {get;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property string* get_PropertyName();
C++/CLI
[DefaultValueAttribute()]
public:
property String^ PropertyName {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Binding Class
Binding Members


Binding Class Events

[image]
Gizmox.WebGUI.Forms
Binding Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : Binding Class

For a list of all members of this type, see Binding members.

Public Events

 | Name | Description
Public Event | BindingComplete | Occurs when a binding operation is complete, such as when data is pushed to the control property from the data source or vice versa
Public Event | Format | Occurs when the property of a control is bound to a data value.
Public Event | Parse | Occurs when the value of a data-bound control changes.
Top

See Also

Reference

Binding Class
Gizmox.WebGUI.Forms Namespace


BindingComplete Event

[image]
Gizmox.WebGUI.Forms
BindingComplete Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Binding Class : BindingComplete Event

Occurs when a binding operation is complete, such as when data is pushed to the control property from the data source or vice versa

Syntax

Visual Basic (Declaration)
Public Event BindingComplete() As BindingCompleteEventHandler
Visual Basic (Usage) Copy Code
Dim instance As Binding
Dim handler As BindingCompleteEventHandler

AddHandler instance.BindingComplete, handler
C#
public event BindingCompleteEventHandler BindingComplete()
Managed Extensions for C++
public: __event BindingCompleteEventHandler* BindingComplete
C++/CLI
public:
event BindingCompleteEventHandler^ BindingComplete

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Binding Class
Binding Members


Format Event

[image]
Gizmox.WebGUI.Forms
Format Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Binding Class : Format Event

Occurs when the property of a control is bound to a data value.

Syntax

Visual Basic (Declaration)
Public Event Format() As ConvertEventHandler
Visual Basic (Usage) Copy Code
Dim instance As Binding
Dim handler As ConvertEventHandler

AddHandler instance.Format, handler
C#
public event ConvertEventHandler Format()
Managed Extensions for C++
public: __event ConvertEventHandler* Format
C++/CLI
public:
event ConvertEventHandler^ Format

Event Data

The event handler receives an argument of type ConvertEventArgs containing data related to this event. The following ConvertEventArgs properties provide information specific to this event.

Property | Description
DesiredType | Gets the data type of the desired value.
Value | Gets or sets the value of the ConvertEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Binding Class
Binding Members


Parse Event

[image]
Gizmox.WebGUI.Forms
Parse Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Binding Class : Parse Event

Occurs when the value of a data-bound control changes.

Syntax

Visual Basic (Declaration)
Public Event Parse() As ConvertEventHandler
Visual Basic (Usage) Copy Code
Dim instance As Binding
Dim handler As ConvertEventHandler

AddHandler instance.Parse, handler
C#
public event ConvertEventHandler Parse()
Managed Extensions for C++
public: __event ConvertEventHandler* Parse
C++/CLI
public:
event ConvertEventHandler^ Parse

Event Data

The event handler receives an argument of type ConvertEventArgs containing data related to this event. The following ConvertEventArgs properties provide information specific to this event.

Property | Description
DesiredType | Gets the data type of the desired value.
Value | Gets or sets the value of the ConvertEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Binding Class
Binding Members


BindingCompleteEventArgs Class

[image]
Gizmox.WebGUI.Forms
BindingCompleteEventArgs Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : BindingCompleteEventArgs Class

Provides data for the BindingComplete event.

Object Model

Syntax

Visual Basic (Declaration)
Public Class BindingCompleteEventArgs
   Inherits CancelEventArgs
Visual Basic (Usage) Copy Code
Dim instance As BindingCompleteEventArgs
C#
public class BindingCompleteEventArgs : CancelEventArgs
Managed Extensions for C++
public __gc class BindingCompleteEventArgs : public CancelEventArgs
C++/CLI
public ref class BindingCompleteEventArgs : public CancelEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
System.ComponentModel.CancelEventArgs
Gizmox.WebGUI.Forms.BindingCompleteEventArgs

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

BindingCompleteEventArgs Members
Gizmox.WebGUI.Forms Namespace


BindingCompleteEventArgs Class Members

[image]
Gizmox.WebGUI.Forms
BindingCompleteEventArgs Class Members
See Also Properties Send Feedback
Gizmox.WebGUI.Forms Namespace : BindingCompleteEventArgs Class

The following tables list the members exposed by BindingCompleteEventArgs.

Public Constructors

 | Name | Description
Public Constructor | BindingCompleteEventArgs Constructor | Overloaded. Initializes a new instance of the BindingCompleteEventArgs class with the specified binding, error state, and binding context.
Top

Public Properties

 | Name | Description
Public Property | Binding | Gets the binding associated with this occurrence of a BindingComplete event.
Public Property | BindingCompleteContext | Gets the direction of the binding operation.
Public Property | BindingCompleteState | Gets the completion state of the binding operation.
Public Property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from System.ComponentModel.CancelEventArgs)
Public Property | ErrorText | Gets the text description of the error that occurred during the binding operation.
Public Property | Exception | Gets the exception that occurred during the binding operation.
Top

See Also

Reference

BindingCompleteEventArgs Class
Gizmox.WebGUI.Forms Namespace


BindingCompleteEventArgs Constructor

[image]
Gizmox.WebGUI.Forms
BindingCompleteEventArgs Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingCompleteEventArgs Class : BindingCompleteEventArgs Constructor

Initializes a new instance of the BindingCompleteEventArgs class with the specified binding, error state, and binding context.

Overload List

Overload | Description
BindingCompleteEventArgs Constructor(Binding,BindingCompleteState,BindingCompleteContext) | Initializes a new instance of the BindingCompleteEventArgs class with the specified binding, error state, and binding context.
BindingCompleteEventArgs Constructor(Binding,BindingCompleteState,BindingCompleteContext,String) | Initializes a new instance of the BindingCompleteEventArgs class with the specified binding, error state and text, and binding context.
BindingCompleteEventArgs Constructor(Binding,BindingCompleteState,BindingCompleteContext,String,Exception) | Initializes a new instance of the BindingCompleteEventArgs class with the specified binding, error state and text, binding context, and exception.
BindingCompleteEventArgs Constructor(Binding,BindingCompleteState,BindingCompleteContext,String,Exception,Boolean) | Initializes a new instance of the BindingCompleteEventArgs class with the specified binding, error state and text, binding context, exception, and whether the binding should be cancelled.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingCompleteEventArgs Class
BindingCompleteEventArgs Members


BindingCompleteEventArgs Constructor(Binding,BindingCompleteState,BindingCompleteContext)

[image]
Gizmox.WebGUI.Forms
BindingCompleteEventArgs Constructor(Binding,BindingCompleteState,BindingCompleteContext)
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingCompleteEventArgs Class > BindingCompleteEventArgs Constructor : BindingCompleteEventArgs Constructor(Binding,BindingCompleteState,BindingCompleteContext)

binding
The binding associated with this occurrence of a BindingComplete event.
state
One of the BindingCompleteState values.
context
One of the BindingCompleteContext values.
Initializes a new instance of the BindingCompleteEventArgs class with the specified binding, error state, and binding context.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal binding As Binding, _
   ByVal state As BindingCompleteState, _
   ByVal context As BindingCompleteContext _
)
Visual Basic (Usage) Copy Code
Dim binding As Binding
Dim state As BindingCompleteState
Dim context As BindingCompleteContext

Dim instance As BindingCompleteEventArgs(binding, state, context)
C#
public BindingCompleteEventArgs(
   Binding binding,
   BindingCompleteState state,
   BindingCompleteContext context
)
Managed Extensions for C++
public: BindingCompleteEventArgs(
   Binding* binding,
   BindingCompleteState state,
   BindingCompleteContext context
)
C++/CLI
public:
BindingCompleteEventArgs(
   Binding^ binding,
   BindingCompleteState state,
   BindingCompleteContext context
)

Parameters

binding
The binding associated with this occurrence of a BindingComplete event.
state
One of the BindingCompleteState values.
context
One of the BindingCompleteContext values.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingCompleteEventArgs Class
BindingCompleteEventArgs Members
Overload List


BindingCompleteEventArgs Constructor(Binding,BindingCompleteState,BindingCompleteContext,String)

[image]
Gizmox.WebGUI.Forms
BindingCompleteEventArgs Constructor(Binding,BindingCompleteState,BindingCompleteContext,String)
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingCompleteEventArgs Class > BindingCompleteEventArgs Constructor : BindingCompleteEventArgs Constructor(Binding,BindingCompleteState,BindingCompleteContext,String)

binding
The binding associated with this occurrence of a BindingComplete event.
state
One of the BindingCompleteState values.
context
One of the BindingCompleteContext values.
errorText
The error text or exception message for errors that occurred during the binding.
Initializes a new instance of the BindingCompleteEventArgs class with the specified binding, error state and text, and binding context.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal binding As Binding, _
   ByVal state As BindingCompleteState, _
   ByVal context As BindingCompleteContext, _
   ByVal errorText As String _
)
Visual Basic (Usage) Copy Code
Dim binding As Binding
Dim state As BindingCompleteState
Dim context As BindingCompleteContext
Dim errorText As String

Dim instance As BindingCompleteEventArgs(binding, state, context, errorText)
C#
public BindingCompleteEventArgs(
   Binding binding,
   BindingCompleteState state,
   BindingCompleteContext context,
   string errorText
)
Managed Extensions for C++
public: BindingCompleteEventArgs(
   Binding* binding,
   BindingCompleteState state,
   BindingCompleteContext context,
   string* errorText
)
C++/CLI
public:
BindingCompleteEventArgs(
   Binding^ binding,
   BindingCompleteState state,
   BindingCompleteContext context,
   String^ errorText
)

Parameters

binding
The binding associated with this occurrence of a BindingComplete event.
state
One of the BindingCompleteState values.
context
One of the BindingCompleteContext values.
errorText
The error text or exception message for errors that occurred during the binding.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingCompleteEventArgs Class
BindingCompleteEventArgs Members
Overload List


BindingCompleteEventArgs Constructor(Binding,BindingCompleteState,BindingCompleteContext,String,Exception)

[image]
Gizmox.WebGUI.Forms
BindingCompleteEventArgs Constructor(Binding,BindingCompleteState,BindingCompleteContext,String,Exception)
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingCompleteEventArgs Class > BindingCompleteEventArgs Constructor : BindingCompleteEventArgs Constructor(Binding,BindingCompleteState,BindingCompleteContext,String,Exception)

binding
The binding associated with this occurrence of a BindingComplete event.
state
One of the BindingCompleteState values.
context
One of the BindingCompleteContext values.
errorText
The error text or exception message for errors that occurred during the binding.
exception
The Exception that occurred during the binding.
Initializes a new instance of the BindingCompleteEventArgs class with the specified binding, error state and text, binding context, and exception.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal binding As Binding, _
   ByVal state As BindingCompleteState, _
   ByVal context As BindingCompleteContext, _
   ByVal errorText As String, _
   ByVal exception As Exception _
)
Visual Basic (Usage) Copy Code
Dim binding As Binding
Dim state As BindingCompleteState
Dim context As BindingCompleteContext
Dim errorText As String
Dim exception As Exception

Dim instance As BindingCompleteEventArgs(binding, state, context, errorText, exception)
C#
public BindingCompleteEventArgs(
   Binding binding,
   BindingCompleteState state,
   BindingCompleteContext context,
   string errorText,
   Exception exception
)
Managed Extensions for C++
public: BindingCompleteEventArgs(
   Binding* binding,
   BindingCompleteState state,
   BindingCompleteContext context,
   string* errorText,
   Exception* exception
)
C++/CLI
public:
BindingCompleteEventArgs(
   Binding^ binding,
   BindingCompleteState state,
   BindingCompleteContext context,
   String^ errorText,
   Exception^ exception
)

Parameters

binding
The binding associated with this occurrence of a BindingComplete event.
state
One of the BindingCompleteState values.
context
One of the BindingCompleteContext values.
errorText
The error text or exception message for errors that occurred during the binding.
exception
The Exception that occurred during the binding.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingCompleteEventArgs Class
BindingCompleteEventArgs Members
Overload List


BindingCompleteEventArgs Constructor(Binding,BindingCompleteState,BindingCompleteContext,String,Exception,Boolean)

[image]
Gizmox.WebGUI.Forms
BindingCompleteEventArgs Constructor(Binding,BindingCompleteState,BindingCompleteContext,String,Exception,Boolean)
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingCompleteEventArgs Class > BindingCompleteEventArgs Constructor : BindingCompleteEventArgs Constructor(Binding,BindingCompleteState,BindingCompleteContext,String,Exception,Boolean)

binding
The binding associated with this occurrence of a BindingComplete event.
state
One of the BindingCompleteState values.
context
One of the BindingCompleteContext values.
errorText
The error text or exception message for errors that occurred during the binding.
exception
The Exception that occurred during the binding.
cancel
true to cancel the binding and keep focus on the current control; false to allow focus to shift to another control.
Initializes a new instance of the BindingCompleteEventArgs class with the specified binding, error state and text, binding context, exception, and whether the binding should be cancelled.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal binding As Binding, _
   ByVal state As BindingCompleteState, _
   ByVal context As BindingCompleteContext, _
   ByVal errorText As String, _
   ByVal exception As Exception, _
   ByVal cancel As Boolean _
)
Visual Basic (Usage) Copy Code
Dim binding As Binding
Dim state As BindingCompleteState
Dim context As BindingCompleteContext
Dim errorText As String
Dim exception As Exception
Dim cancel As Boolean

Dim instance As BindingCompleteEventArgs(binding, state, context, errorText, exception, cancel)
C#
public BindingCompleteEventArgs(
   Binding binding,
   BindingCompleteState state,
   BindingCompleteContext context,
   string errorText,
   Exception exception,
   bool cancel
)
Managed Extensions for C++
public: BindingCompleteEventArgs(
   Binding* binding,
   BindingCompleteState state,
   BindingCompleteContext context,
   string* errorText,
   Exception* exception,
   bool cancel
)
C++/CLI
public:
BindingCompleteEventArgs(
   Binding^ binding,
   BindingCompleteState state,
   BindingCompleteContext context,
   String^ errorText,
   Exception^ exception,
   bool cancel
)

Parameters

binding
The binding associated with this occurrence of a BindingComplete event.
state
One of the BindingCompleteState values.
context
One of the BindingCompleteContext values.
errorText
The error text or exception message for errors that occurred during the binding.
exception
The Exception that occurred during the binding.
cancel
true to cancel the binding and keep focus on the current control; false to allow focus to shift to another control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingCompleteEventArgs Class
BindingCompleteEventArgs Members
Overload List


BindingCompleteEventArgs Class Properties

[image]
Gizmox.WebGUI.Forms
BindingCompleteEventArgs Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : BindingCompleteEventArgs Class

For a list of all members of this type, see BindingCompleteEventArgs members.

Public Properties

 | Name | Description
Public Property | Binding | Gets the binding associated with this occurrence of a BindingComplete event.
Public Property | BindingCompleteContext | Gets the direction of the binding operation.
Public Property | BindingCompleteState | Gets the completion state of the binding operation.
Public Property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from System.ComponentModel.CancelEventArgs)
Public Property | ErrorText | Gets the text description of the error that occurred during the binding operation.
Public Property | Exception | Gets the exception that occurred during the binding operation.
Top

See Also

Reference

BindingCompleteEventArgs Class
Gizmox.WebGUI.Forms Namespace


Binding Property

[image]
Gizmox.WebGUI.Forms
Binding Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingCompleteEventArgs Class : Binding Property

Gets the binding associated with this occurrence of a BindingComplete event.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Binding As Binding
Visual Basic (Usage) Copy Code
Dim instance As BindingCompleteEventArgs
Dim value As Binding

value = instance.Binding
C#
public Binding Binding {get;}
Managed Extensions for C++
public: __property Binding* get_Binding();
C++/CLI
public:
property Binding^ Binding {
   Binding^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingCompleteEventArgs Class
BindingCompleteEventArgs Members


BindingCompleteContext Property

[image]
Gizmox.WebGUI.Forms
BindingCompleteContext Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingCompleteEventArgs Class : BindingCompleteContext Property

Gets the direction of the binding operation.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property BindingCompleteContext As BindingCompleteContext
Visual Basic (Usage) Copy Code
Dim instance As BindingCompleteEventArgs
Dim value As BindingCompleteContext

value = instance.BindingCompleteContext
C#
public BindingCompleteContext BindingCompleteContext {get;}
Managed Extensions for C++
public: __property BindingCompleteContext get_BindingCompleteContext();
C++/CLI
public:
property BindingCompleteContext BindingCompleteContext {
   BindingCompleteContext get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingCompleteEventArgs Class
BindingCompleteEventArgs Members


BindingCompleteState Property

[image]
Gizmox.WebGUI.Forms
BindingCompleteState Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingCompleteEventArgs Class : BindingCompleteState Property

Gets the completion state of the binding operation.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property BindingCompleteState As BindingCompleteState
Visual Basic (Usage) Copy Code
Dim instance As BindingCompleteEventArgs
Dim value As BindingCompleteState

value = instance.BindingCompleteState
C#
public BindingCompleteState BindingCompleteState {get;}
Managed Extensions for C++
public: __property BindingCompleteState get_BindingCompleteState();
C++/CLI
public:
property BindingCompleteState BindingCompleteState {
   BindingCompleteState get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingCompleteEventArgs Class
BindingCompleteEventArgs Members


ErrorText Property

[image]
Gizmox.WebGUI.Forms
ErrorText Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingCompleteEventArgs Class : ErrorText Property

Gets the text description of the error that occurred during the binding operation.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ErrorText As String
Visual Basic (Usage) Copy Code
Dim instance As BindingCompleteEventArgs
Dim value As String

value = instance.ErrorText
C#
public string ErrorText {get;}
Managed Extensions for C++
public: __property string* get_ErrorText();
C++/CLI
public:
property String^ ErrorText {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingCompleteEventArgs Class
BindingCompleteEventArgs Members


Exception Property

[image]
Gizmox.WebGUI.Forms
Exception Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingCompleteEventArgs Class : Exception Property

Gets the exception that occurred during the binding operation.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Exception As Exception
Visual Basic (Usage) Copy Code
Dim instance As BindingCompleteEventArgs
Dim value As Exception

value = instance.Exception
C#
public Exception Exception {get;}
Managed Extensions for C++
public: __property Exception* get_Exception();
C++/CLI
public:
property Exception^ Exception {
   Exception^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingCompleteEventArgs Class
BindingCompleteEventArgs Members


BindingContext Class

[image]
Gizmox.WebGUI.Forms
BindingContext Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : BindingContext Class

Manages the collection of BindingManagerBase objects for any object that inherits from the Control class.

Object Model

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
<DefaultEventAttribute("CollectionChanged")>
Public Class BindingContext
Visual Basic (Usage) Copy Code
Dim instance As BindingContext
C#
[DefaultMemberAttribute("Item")]
[DefaultEventAttribute("CollectionChanged")]
public class BindingContext
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
[DefaultEventAttribute("CollectionChanged")]
public __gc class BindingContext
C++/CLI
[DefaultMemberAttribute("Item")]
[DefaultEventAttribute("CollectionChanged")]
public ref class BindingContext

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.BindingContext

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

BindingContext Members
Gizmox.WebGUI.Forms Namespace


BindingContext Class Members

[image]
Gizmox.WebGUI.Forms
BindingContext Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : BindingContext Class

The following tables list the members exposed by BindingContext.

Public Constructors

 | Name | Description
Public Constructor | BindingContext Constructor | Initializes a new instance of the BindingContext class.
Top

Public Properties

 | Name | Description
Public Property | IsReadOnly | Gets a value indicating whether the collection is read-only.
Public Property | Item | Overloaded. Gets the BindingManagerBase that is associated with the specified data source.
Top

Public Methods

 | Name | Description
Public Method | Contains | Overloaded. Gets a value indicating whether the BindingContext contains the BindingManagerBase associated with the specified data source.
static (Shared in Visual Basic) | UpdateBinding | Associates a Binding with a new BindingContext.
Top

Protected Methods

 | Name | Description
Protected Method | Add | Adds the BindingManagerBase associated with a specific data source to the collection.
Protected Method | AddCore | Adds the BindingManagerBase associated with a specific data source to the collection.
Protected Method | Clear | Clears the collection of any BindingManagerBase objects.
Protected Method | ClearCore | Clears the collection.
Protected Method | OnCollectionChanged | Raises the CollectionChanged event.
Protected Method | Remove | Deletes the BindingManagerBase associated with the specified data source.
Protected Method | RemoveCore | Removes the BindingManagerBase associated with the specified data source.
Top

See Also

Reference

BindingContext Class
Gizmox.WebGUI.Forms Namespace


BindingContext Constructor

[image]
Gizmox.WebGUI.Forms
BindingContext Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingContext Class : BindingContext Constructor

Initializes a new instance of the BindingContext class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As BindingContext()
C#
public BindingContext()
Managed Extensions for C++
public: BindingContext();
C++/CLI
public:
BindingContext();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingContext Class
BindingContext Members


BindingContext Class Methods

[image]
Gizmox.WebGUI.Forms
BindingContext Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : BindingContext Class

For a list of all members of this type, see BindingContext members.

Public Methods

 | Name | Description
Public Method | Contains | Overloaded. Gets a value indicating whether the BindingContext contains the BindingManagerBase associated with the specified data source.
static (Shared in Visual Basic) | UpdateBinding | Associates a Binding with a new BindingContext.
Top

Protected Methods

 | Name | Description
Protected Method | Add | Adds the BindingManagerBase associated with a specific data source to the collection.
Protected Method | AddCore | Adds the BindingManagerBase associated with a specific data source to the collection.
Protected Method | Clear | Clears the collection of any BindingManagerBase objects.
Protected Method | ClearCore | Clears the collection.
Protected Method | OnCollectionChanged | Raises the CollectionChanged event.
Protected Method | Remove | Deletes the BindingManagerBase associated with the specified data source.
Protected Method | RemoveCore | Removes the BindingManagerBase associated with the specified data source.
Top

See Also

Reference

BindingContext Class
Gizmox.WebGUI.Forms Namespace


Add Method

[image]
Gizmox.WebGUI.Forms
Add Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingContext Class : Add Method

dataSource
The Object associated with the BindingManagerBase.
listManager
The BindingManagerBase to add.
Adds the BindingManagerBase associated with a specific data source to the collection.

Syntax

Visual Basic (Declaration)
Protected Sub Add( _
   ByVal dataSource As Object, _
   ByVal listManager As BindingManagerBase _
)
Visual Basic (Usage) Copy Code
Dim instance As BindingContext
Dim dataSource As Object
Dim listManager As BindingManagerBase

instance.Add(dataSource, listManager)
C#
protected void Add(
   object dataSource,
   BindingManagerBase listManager
)
Managed Extensions for C++
protected: void Add(
   Object* dataSource,
   BindingManagerBase* listManager
)
C++/CLI
protected:
void Add(
   Object^ dataSource,
   BindingManagerBase^ listManager
)

Parameters

dataSource
The Object associated with the BindingManagerBase.
listManager
The BindingManagerBase to add.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingContext Class
BindingContext Members


AddCore Method

[image]
Gizmox.WebGUI.Forms
AddCore Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingContext Class : AddCore Method

dataSource
The object associated with the BindingManagerBase.
listManager
The BindingManagerBase to add.
Adds the BindingManagerBase associated with a specific data source to the collection.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub AddCore( _
   ByVal dataSource As Object, _
   ByVal listManager As BindingManagerBase _
)
Visual Basic (Usage) Copy Code
Dim instance As BindingContext
Dim dataSource As Object
Dim listManager As BindingManagerBase

instance.AddCore(dataSource, listManager)
C#
protected virtual void AddCore(
   object dataSource,
   BindingManagerBase listManager
)
Managed Extensions for C++
protected: virtual void AddCore(
   Object* dataSource,
   BindingManagerBase* listManager
)
C++/CLI
protected:
virtual void AddCore(
   Object^ dataSource,
   BindingManagerBase^ listManager
)

Parameters

dataSource
The object associated with the BindingManagerBase.
listManager
The BindingManagerBase to add.

Exceptions

Exception | Description
ArgumentNullException | dataSource is null.-or-listManager is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingContext Class
BindingContext Members


Clear Method

[image]
Gizmox.WebGUI.Forms
Clear Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingContext Class : Clear Method

Clears the collection of any BindingManagerBase objects.

Syntax

Visual Basic (Declaration)
Protected Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As BindingContext

instance.Clear()
C#
protected void Clear()
Managed Extensions for C++
protected: void Clear();
C++/CLI
protected:
void Clear();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingContext Class
BindingContext Members


ClearCore Method

[image]
Gizmox.WebGUI.Forms
ClearCore Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingContext Class : ClearCore Method

Clears the collection.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ClearCore()
Visual Basic (Usage) Copy Code
Dim instance As BindingContext

instance.ClearCore()
C#
protected virtual void ClearCore()
Managed Extensions for C++
protected: virtual void ClearCore();
C++/CLI
protected:
virtual void ClearCore();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingContext Class
BindingContext Members


Contains Method

[image]
Gizmox.WebGUI.Forms
Contains Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingContext Class : Contains Method

Gets a value indicating whether the BindingContext contains the BindingManagerBase associated with the specified data source.

Overload List

Overload | Description
Contains(Object) | Gets a value indicating whether the BindingContext contains the BindingManagerBase associated with the specified data source.
Contains(Object,String) | Gets a value indicating whether the BindingContext contains the BindingManagerBase associated with the specified data source and data member.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingContext Class
BindingContext Members


Contains(Object) Method

[image]
Gizmox.WebGUI.Forms
Contains(Object) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingContext Class > Contains Method : Contains(Object) Method

dataSource
An Object that represents the data source.
Gets a value indicating whether the BindingContext contains the BindingManagerBase associated with the specified data source.

Syntax

Visual Basic (Declaration)
Public Overloads Function Contains( _
   ByVal dataSource As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BindingContext
Dim dataSource As Object
Dim value As Boolean

value = instance.Contains(dataSource)
C#
public bool Contains(
   object dataSource
)
Managed Extensions for C++
public: bool Contains(
   Object* dataSource
)
C++/CLI
public:
bool Contains(
   Object^ dataSource
)

Parameters

dataSource
An Object that represents the data source.

Return Value

true if the BindingContext contains the specified BindingManagerBase; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingContext Class
BindingContext Members
Overload List


Contains(Object,String) Method

[image]
Gizmox.WebGUI.Forms
Contains(Object,String) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingContext Class > Contains Method : Contains(Object,String) Method

dataSource
An Object that represents the data source.
dataMember
The information needed to resolve to a specific BindingManagerBase.
Gets a value indicating whether the BindingContext contains the BindingManagerBase associated with the specified data source and data member.

Syntax

Visual Basic (Declaration)
Public Overloads Function Contains( _
   ByVal dataSource As Object, _
   ByVal dataMember As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BindingContext
Dim dataSource As Object
Dim dataMember As String
Dim value As Boolean

value = instance.Contains(dataSource, dataMember)
C#
public bool Contains(
   object dataSource,
   string dataMember
)
Managed Extensions for C++
public: bool Contains(
   Object* dataSource,
   string* dataMember
)
C++/CLI
public:
bool Contains(
   Object^ dataSource,
   String^ dataMember
)

Parameters

dataSource
An Object that represents the data source.
dataMember
The information needed to resolve to a specific BindingManagerBase.

Return Value

true if the BindingContext contains the specified BindingManagerBase; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingContext Class
BindingContext Members
Overload List


OnCollectionChanged Method

[image]
Gizmox.WebGUI.Forms
OnCollectionChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingContext Class : OnCollectionChanged Method

ccevent
A CollectionChangeEventArgs that contains the event data.
Raises the CollectionChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnCollectionChanged( _
   ByVal ccevent As CollectionChangeEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As BindingContext
Dim ccevent As CollectionChangeEventArgs

instance.OnCollectionChanged(ccevent)
C#
protected virtual void OnCollectionChanged(
   CollectionChangeEventArgs ccevent
)
Managed Extensions for C++
protected: virtual void OnCollectionChanged(
   CollectionChangeEventArgs* ccevent
)
C++/CLI
protected:
virtual void OnCollectionChanged(
   CollectionChangeEventArgs^ ccevent
)

Parameters

ccevent
A CollectionChangeEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingContext Class
BindingContext Members


Remove Method

[image]
Gizmox.WebGUI.Forms
Remove Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingContext Class : Remove Method

dataSource
The data source associated with the BindingManagerBase to remove.
Deletes the BindingManagerBase associated with the specified data source.

Syntax

Visual Basic (Declaration)
Protected Sub Remove( _
   ByVal dataSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As BindingContext
Dim dataSource As Object

instance.Remove(dataSource)
C#
protected void Remove(
   object dataSource
)
Managed Extensions for C++
protected: void Remove(
   Object* dataSource
)
C++/CLI
protected:
void Remove(
   Object^ dataSource
)

Parameters

dataSource
The data source associated with the BindingManagerBase to remove.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingContext Class
BindingContext Members


RemoveCore Method

[image]
Gizmox.WebGUI.Forms
RemoveCore Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingContext Class : RemoveCore Method

dataSource
The data source associated with the BindingManagerBase to remove.
Removes the BindingManagerBase associated with the specified data source.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub RemoveCore( _
   ByVal dataSource As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As BindingContext
Dim dataSource As Object

instance.RemoveCore(dataSource)
C#
protected virtual void RemoveCore(
   object dataSource
)
Managed Extensions for C++
protected: virtual void RemoveCore(
   Object* dataSource
)
C++/CLI
protected:
virtual void RemoveCore(
   Object^ dataSource
)

Parameters

dataSource
The data source associated with the BindingManagerBase to remove.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingContext Class
BindingContext Members


UpdateBinding Method

[image]
Gizmox.WebGUI.Forms
UpdateBinding Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingContext Class : UpdateBinding Method

newBindingContext
The new BindingContext to associate with the Binding.
binding
The Binding to associate with the new BindingContext.
Associates a Binding with a new BindingContext.

Syntax

Visual Basic (Declaration)
Public Shared Sub UpdateBinding( _
   ByVal newBindingContext As BindingContext, _
   ByVal binding As Binding _
)
Visual Basic (Usage) Copy Code
Dim newBindingContext As BindingContext
Dim binding As Binding

BindingContext.UpdateBinding(newBindingContext, binding)
C#
public static void UpdateBinding(
   BindingContext newBindingContext,
   Binding binding
)
Managed Extensions for C++
public: static void UpdateBinding(
   BindingContext* newBindingContext,
   Binding* binding
)
C++/CLI
public:
static void UpdateBinding(
   BindingContext^ newBindingContext,
   Binding^ binding
)

Parameters

newBindingContext
The new BindingContext to associate with the Binding.
binding
The Binding to associate with the new BindingContext.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingContext Class
BindingContext Members


BindingContext Class Properties

[image]
Gizmox.WebGUI.Forms
BindingContext Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : BindingContext Class

For a list of all members of this type, see BindingContext members.

Public Properties

 | Name | Description
Public Property | IsReadOnly | Gets a value indicating whether the collection is read-only.
Public Property | Item | Overloaded. Gets the BindingManagerBase that is associated with the specified data source.
Top

See Also

Reference

BindingContext Class
Gizmox.WebGUI.Forms Namespace


IsReadOnly Property

[image]
Gizmox.WebGUI.Forms
IsReadOnly Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingContext Class : IsReadOnly Property

Gets a value indicating whether the collection is read-only.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsReadOnly As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BindingContext
Dim value As Boolean

value = instance.IsReadOnly
C#
public bool IsReadOnly {get;}
Managed Extensions for C++
public: __property bool get_IsReadOnly();
C++/CLI
public:
property bool IsReadOnly {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingContext Class
BindingContext Members


Item Property

[image]
Gizmox.WebGUI.Forms
Item Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingContext Class : Item Property

Gets the BindingManagerBase that is associated with the specified data source.

Overload List

Overload | Description
Item(Object) | Gets the BindingManagerBase that is associated with the specified data source.
Item(Object,String) | Gets a BindingManagerBase that is associated with the specified data source and data member.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingContext Class
BindingContext Members


Item(Object) Property

[image]
Gizmox.WebGUI.Forms
Item(Object) Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingContext Class > Item Property : Item(Object) Property

dataSource
The data source associated with a particular BindingManagerBase.
Gets the BindingManagerBase that is associated with the specified data source.

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal dataSource As Object _
) As BindingManagerBase
Visual Basic (Usage) Copy Code
Dim instance As BindingContext
Dim dataSource As Object
Dim value As BindingManagerBase

value = instance.Item(dataSource)
C#
public BindingManagerBase Item(
   object dataSource
) {get;}
Managed Extensions for C++
public: __property BindingManagerBase* get_Item(
   Object* dataSource
);
C++/CLI
public:
property BindingManagerBase^ Item {
   BindingManagerBase^ get(Object^dataSource);
}

Parameters

dataSource
The data source associated with a particular BindingManagerBase.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingContext Class
BindingContext Members
Overload List


Item(Object,String) Property

[image]
Gizmox.WebGUI.Forms
Item(Object,String) Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingContext Class > Item Property : Item(Object,String) Property

dataSource
The data source associated with a particular BindingManagerBase.
dataMember
A navigation path containing the information that resolves to a specific BindingManagerBase.
Gets a BindingManagerBase that is associated with the specified data source and data member.

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal dataSource As Object, _
   ByVal dataMember As String _
) As BindingManagerBase
Visual Basic (Usage) Copy Code
Dim instance As BindingContext
Dim dataSource As Object
Dim dataMember As String
Dim value As BindingManagerBase

value = instance.Item(dataSource, dataMember)
C#
public BindingManagerBase Item(
   object dataSource,
   string dataMember
) {get;}
Managed Extensions for C++
public: __property BindingManagerBase* get_Item(
   Object* dataSource,
   string* dataMember
);
C++/CLI
public:
property BindingManagerBase^ Item {
   BindingManagerBase^ get(Object^dataSource, String^dataMember);
}

Parameters

dataSource
The data source associated with a particular BindingManagerBase.
dataMember
A navigation path containing the information that resolves to a specific BindingManagerBase.

Exceptions

Exception | Description
Exception | The specified dataMember does not exist within the data source.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingContext Class
BindingContext Members
Overload List


BindingManagerBase Class

[image]
Gizmox.WebGUI.Forms
BindingManagerBase Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : BindingManagerBase Class

Manages all Binding objects that are bound to the same data source and data member. This class is abstract.

Object Model

Syntax

Visual Basic (Declaration)
Public MustInherit Class BindingManagerBase
Visual Basic (Usage) Copy Code
Dim instance As BindingManagerBase
C#
public abstract class BindingManagerBase
Managed Extensions for C++
public __gc abstract class BindingManagerBase
C++/CLI
public ref class BindingManagerBase abstract

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.BindingManagerBase
Gizmox.WebGUI.Forms.CurrencyManager
Gizmox.WebGUI.Forms.PropertyManager

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

BindingManagerBase Members
Gizmox.WebGUI.Forms Namespace


BindingManagerBase Class Members

[image]
Gizmox.WebGUI.Forms
BindingManagerBase Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : BindingManagerBase Class

The following tables list the members exposed by BindingManagerBase.

Public Properties

 | Name | Description
Public Property | Bindings | Gets the collection of bindings being managed.
Public Property | Count | When overridden in a derived class, gets the number of rows managed by the BindingManagerBase.
Public Property | Current | When overridden in a derived class, gets the current object.
Public Property | IsBindingSuspended | Gets a value indicating whether binding is suspended.
Public Property | Position | When overridden in a derived class, gets or sets the position in the underlying list that controls bound to this data source point to.
Top

Public Methods

 | Name | Description
Public Method | AddNew | When overridden in a derived class, adds a new item to the underlying list.
Public Method | CancelCurrentEdit | When overridden in a derived class, cancels the current edit.
Public Method | EndCurrentEdit | When overridden in a derived class, ends the current edit.
Public Method | GetItemProperties | Overloaded. When overridden in a derived class, gets the collection of property descriptors for the binding.
Public Method | RemoveAt | When overridden in a derived class, deletes the row at the specified index from the underlying list.
Public Method | ResumeBinding | When overridden in a derived class, resumes data binding.
Public Method | SuspendBinding | When overridden in a derived class, suspends data binding.
Top

Protected Methods

 | Name | Description
Protected Method | FireCurrentChanged |
Protected Method | FireCurrentItemChanged |
Protected Method | FirePositionChanged |
Protected Method | GetListName | When overridden in a derived class, gets the name of the list supplying the data for the binding.
Protected Method | OnBindingComplete | Raises the BindingComplete event.
Protected Method | OnCurrentChanged | Raises the CurrentChanged event.
Protected Method | OnCurrentItemChanged | Raises the CurrentItemChanged event.
Protected Method | OnDataError | Raises the DataError event.
Protected Method | PullData | Pulls data from the data-bound control into the data source, returning no information.
Protected Method | PushData | Pushes data from the data source into the data-bound control, returning no information.
Protected Method | UpdateIsBinding | When overridden in a derived class, updates the binding.
Top

Public Events

 | Name | Description
Public Event | BindingComplete | Occurs at the completion of a data-binding operation.
Public Event | CurrentChanged | Occurs when the currently bound item changes.
Public Event | CurrentItemChanged | Occurs when the state of the currently bound item changes.
Public Event | DataError | Occurs when an Exception is silently handled by the BindingManagerBase.
Public Event | PositionChanged | Occurs after the value of the Position property has changed.
Top

See Also

Reference

BindingManagerBase Class
Gizmox.WebGUI.Forms Namespace


BindingManagerBase Class Methods

[image]
Gizmox.WebGUI.Forms
BindingManagerBase Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : BindingManagerBase Class

For a list of all members of this type, see BindingManagerBase members.

Public Methods

 | Name | Description
Public Method | AddNew | When overridden in a derived class, adds a new item to the underlying list.
Public Method | CancelCurrentEdit | When overridden in a derived class, cancels the current edit.
Public Method | EndCurrentEdit | When overridden in a derived class, ends the current edit.
Public Method | GetItemProperties | Overloaded. When overridden in a derived class, gets the collection of property descriptors for the binding.
Public Method | RemoveAt | When overridden in a derived class, deletes the row at the specified index from the underlying list.
Public Method | ResumeBinding | When overridden in a derived class, resumes data binding.
Public Method | SuspendBinding | When overridden in a derived class, suspends data binding.
Top

Protected Methods

 | Name | Description
Protected Method | FireCurrentChanged |
Protected Method | FireCurrentItemChanged |
Protected Method | FirePositionChanged |
Protected Method | GetListName | When overridden in a derived class, gets the name of the list supplying the data for the binding.
Protected Method | OnBindingComplete | Raises the BindingComplete event.
Protected Method | OnCurrentChanged | Raises the CurrentChanged event.
Protected Method | OnCurrentItemChanged | Raises the CurrentItemChanged event.
Protected Method | OnDataError | Raises the DataError event.
Protected Method | PullData | Pulls data from the data-bound control into the data source, returning no information.
Protected Method | PushData | Pushes data from the data source into the data-bound control, returning no information.
Protected Method | UpdateIsBinding | When overridden in a derived class, updates the binding.
Top

See Also

Reference

BindingManagerBase Class
Gizmox.WebGUI.Forms Namespace


AddNew Method

[image]
Gizmox.WebGUI.Forms
AddNew Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingManagerBase Class : AddNew Method

When overridden in a derived class, adds a new item to the underlying list.

Syntax

Visual Basic (Declaration)
Public MustOverride Sub AddNew()
Visual Basic (Usage) Copy Code
Dim instance As BindingManagerBase

instance.AddNew()
C#
public abstract void AddNew()
Managed Extensions for C++
public: abstract void AddNew();
C++/CLI
public:
abstract void AddNew();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingManagerBase Class
BindingManagerBase Members


CancelCurrentEdit Method

[image]
Gizmox.WebGUI.Forms
CancelCurrentEdit Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingManagerBase Class : CancelCurrentEdit Method

When overridden in a derived class, cancels the current edit.

Syntax

Visual Basic (Declaration)
Public MustOverride Sub CancelCurrentEdit()
Visual Basic (Usage) Copy Code
Dim instance As BindingManagerBase

instance.CancelCurrentEdit()
C#
public abstract void CancelCurrentEdit()
Managed Extensions for C++
public: abstract void CancelCurrentEdit();
C++/CLI
public:
abstract void CancelCurrentEdit();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingManagerBase Class
BindingManagerBase Members


EndCurrentEdit Method

[image]
Gizmox.WebGUI.Forms
EndCurrentEdit Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingManagerBase Class : EndCurrentEdit Method

When overridden in a derived class, ends the current edit.

Syntax

Visual Basic (Declaration)
Public MustOverride Sub EndCurrentEdit()
Visual Basic (Usage) Copy Code
Dim instance As BindingManagerBase

instance.EndCurrentEdit()
C#
public abstract void EndCurrentEdit()
Managed Extensions for C++
public: abstract void EndCurrentEdit();
C++/CLI
public:
abstract void EndCurrentEdit();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingManagerBase Class
BindingManagerBase Members


FireCurrentChanged Method

[image]
Gizmox.WebGUI.Forms
FireCurrentChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingManagerBase Class : FireCurrentChanged Method

objSource
objArgs

Syntax

Visual Basic (Declaration)
Protected Sub FireCurrentChanged( _
   ByVal objSource As Object, _
   ByVal objArgs As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As BindingManagerBase
Dim objSource As Object
Dim objArgs As EventArgs

instance.FireCurrentChanged(objSource, objArgs)
C#
protected void FireCurrentChanged(
   object objSource,
   EventArgs objArgs
)
Managed Extensions for C++
protected: void FireCurrentChanged(
   Object* objSource,
   EventArgs* objArgs
)
C++/CLI
protected:
void FireCurrentChanged(
   Object^ objSource,
   EventArgs^ objArgs
)

Parameters

objSource
objArgs

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingManagerBase Class
BindingManagerBase Members


FireCurrentItemChanged Method

[image]
Gizmox.WebGUI.Forms
FireCurrentItemChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingManagerBase Class : FireCurrentItemChanged Method

objSource
objArgs

Syntax

Visual Basic (Declaration)
Protected Sub FireCurrentItemChanged( _
   ByVal objSource As Object, _
   ByVal objArgs As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As BindingManagerBase
Dim objSource As Object
Dim objArgs As EventArgs

instance.FireCurrentItemChanged(objSource, objArgs)
C#
protected void FireCurrentItemChanged(
   object objSource,
   EventArgs objArgs
)
Managed Extensions for C++
protected: void FireCurrentItemChanged(
   Object* objSource,
   EventArgs* objArgs
)
C++/CLI
protected:
void FireCurrentItemChanged(
   Object^ objSource,
   EventArgs^ objArgs
)

Parameters

objSource
objArgs

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingManagerBase Class
BindingManagerBase Members


FirePositionChanged Method

[image]
Gizmox.WebGUI.Forms
FirePositionChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingManagerBase Class : FirePositionChanged Method

objSource
objArgs

Syntax

Visual Basic (Declaration)
Protected Sub FirePositionChanged( _
   ByVal objSource As Object, _
   ByVal objArgs As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As BindingManagerBase
Dim objSource As Object
Dim objArgs As EventArgs

instance.FirePositionChanged(objSource, objArgs)
C#
protected void FirePositionChanged(
   object objSource,
   EventArgs objArgs
)
Managed Extensions for C++
protected: void FirePositionChanged(
   Object* objSource,
   EventArgs* objArgs
)
C++/CLI
protected:
void FirePositionChanged(
   Object^ objSource,
   EventArgs^ objArgs
)

Parameters

objSource
objArgs

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingManagerBase Class
BindingManagerBase Members


GetItemProperties Method

[image]
Gizmox.WebGUI.Forms
GetItemProperties Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingManagerBase Class : GetItemProperties Method

When overridden in a derived class, gets the collection of property descriptors for the binding.

Overload List

Overload | Description
GetItemProperties() | When overridden in a derived class, gets the collection of property descriptors for the binding.
GetItemProperties(ArrayList,ArrayList) | Gets the collection of property descriptors for the binding using the specified ArrayList.
GetItemProperties(Type,Int32,ArrayList,ArrayList) | Gets the list of properties of the items managed by this BindingManagerBase.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingManagerBase Class
BindingManagerBase Members


GetItemProperties() Method

[image]
Gizmox.WebGUI.Forms
GetItemProperties() Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingManagerBase Class > GetItemProperties Method : GetItemProperties() Method

When overridden in a derived class, gets the collection of property descriptors for the binding.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function GetItemProperties() As PropertyDescriptorCollection
Visual Basic (Usage) Copy Code
Dim instance As BindingManagerBase
Dim value As PropertyDescriptorCollection

value = instance.GetItemProperties()
C#
public virtual PropertyDescriptorCollection GetItemProperties()
Managed Extensions for C++
public: virtual PropertyDescriptorCollection* GetItemProperties();
C++/CLI
public:
virtual PropertyDescriptorCollection^ GetItemProperties();

Return Value

A PropertyDescriptorCollection that represents the property descriptors for the binding.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingManagerBase Class
BindingManagerBase Members
Overload List


GetItemProperties(ArrayList,ArrayList) Method

[image]
Gizmox.WebGUI.Forms
GetItemProperties(ArrayList,ArrayList) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingManagerBase Class > GetItemProperties Method : GetItemProperties(ArrayList,ArrayList) Method

dataSources
An ArrayList containing the data sources.
listAccessors
An ArrayList containing the table's bound properties.
Gets the collection of property descriptors for the binding using the specified ArrayList.

Syntax

Visual Basic (Declaration)
Protected Overloads Overridable Function GetItemProperties( _
   ByVal dataSources As ArrayList, _
   ByVal listAccessors As ArrayList _
) As PropertyDescriptorCollection
Visual Basic (Usage) Copy Code
Dim instance As BindingManagerBase
Dim dataSources As ArrayList
Dim listAccessors As ArrayList
Dim value As PropertyDescriptorCollection

value = instance.GetItemProperties(dataSources, listAccessors)
C#
protected virtual PropertyDescriptorCollection GetItemProperties(
   ArrayList dataSources,
   ArrayList listAccessors
)
Managed Extensions for C++
protected: virtual PropertyDescriptorCollection* GetItemProperties(
   ArrayList* dataSources,
   ArrayList* listAccessors
)
C++/CLI
protected:
virtual PropertyDescriptorCollection^ GetItemProperties(
   ArrayList^ dataSources,
   ArrayList^ listAccessors
)

Parameters

dataSources
An ArrayList containing the data sources.
listAccessors
An ArrayList containing the table's bound properties.

Return Value

A PropertyDescriptorCollection that represents the property descriptors for the binding.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingManagerBase Class
BindingManagerBase Members
Overload List


GetItemProperties(Type,Int32,ArrayList,ArrayList) Method

[image]
Gizmox.WebGUI.Forms
GetItemProperties(Type,Int32,ArrayList,ArrayList) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingManagerBase Class > GetItemProperties Method : GetItemProperties(Type,Int32,ArrayList,ArrayList) Method

listType
The Type of the bound list.
offset
A counter used to recursively call the method.
dataSources
An ArrayList containing the data sources.
listAccessors
An ArrayList containing the table's bound properties.
Gets the list of properties of the items managed by this BindingManagerBase.

Syntax

Visual Basic (Declaration)
Protected Overloads Overridable Function GetItemProperties( _
   ByVal listType As Type, _
   ByVal offset As Integer, _
   ByVal dataSources As ArrayList, _
   ByVal listAccessors As ArrayList _
) As PropertyDescriptorCollection
Visual Basic (Usage) Copy Code
Dim instance As BindingManagerBase
Dim listType As Type
Dim offset As Integer
Dim dataSources As ArrayList
Dim listAccessors As ArrayList
Dim value As PropertyDescriptorCollection

value = instance.GetItemProperties(listType, offset, dataSources, listAccessors)
C#
protected virtual PropertyDescriptorCollection GetItemProperties(
   Type listType,
   int offset,
   ArrayList dataSources,
   ArrayList listAccessors
)
Managed Extensions for C++
protected: virtual PropertyDescriptorCollection* GetItemProperties(
   Type* listType,
   int offset,
   ArrayList* dataSources,
   ArrayList* listAccessors
)
C++/CLI
protected:
virtual PropertyDescriptorCollection^ GetItemProperties(
   Type^ listType,
   int offset,
   ArrayList^ dataSources,
   ArrayList^ listAccessors
)

Parameters

listType
The Type of the bound list.
offset
A counter used to recursively call the method.
dataSources
An ArrayList containing the data sources.
listAccessors
An ArrayList containing the table's bound properties.

Return Value

A PropertyDescriptorCollection that represents the property descriptors for the binding.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingManagerBase Class
BindingManagerBase Members
Overload List


GetListName Method

[image]
Gizmox.WebGUI.Forms
GetListName Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingManagerBase Class : GetListName Method

listAccessors
An ArrayList containing the table's bound properties.
When overridden in a derived class, gets the name of the list supplying the data for the binding.

Syntax

Visual Basic (Declaration)
Protected MustOverride Function GetListName( _
   ByVal listAccessors As ArrayList _
) As String
Visual Basic (Usage) Copy Code
Dim instance As BindingManagerBase
Dim listAccessors As ArrayList
Dim value As String

value = instance.GetListName(listAccessors)
C#
protected abstract string GetListName(
   ArrayList listAccessors
)
Managed Extensions for C++
protected: abstract string* GetListName(
   ArrayList* listAccessors
)
C++/CLI
protected:
abstract String^ GetListName(
   ArrayList^ listAccessors
)

Parameters

listAccessors
An ArrayList containing the table's bound properties.

Return Value

The name of the list supplying the data for the binding.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingManagerBase Class
BindingManagerBase Members


OnBindingComplete Method

[image]
Gizmox.WebGUI.Forms
OnBindingComplete Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingManagerBase Class : OnBindingComplete Method

args
A BindingCompleteEventArgs that contains the event data.
Raises the BindingComplete event.

Syntax

Visual Basic (Declaration)
Protected Sub OnBindingComplete( _
   ByVal args As BindingCompleteEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As BindingManagerBase
Dim args As BindingCompleteEventArgs

instance.OnBindingComplete(args)
C#
protected void OnBindingComplete(
   BindingCompleteEventArgs args
)
Managed Extensions for C++
protected: void OnBindingComplete(
   BindingCompleteEventArgs* args
)
C++/CLI
protected:
void OnBindingComplete(
   BindingCompleteEventArgs^ args
)

Parameters

args
A BindingCompleteEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingManagerBase Class
BindingManagerBase Members


OnCurrentChanged Method

[image]
Gizmox.WebGUI.Forms
OnCurrentChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingManagerBase Class : OnCurrentChanged Method

e
The EventArgs that contains the event data.
Raises the CurrentChanged event.

Syntax

Visual Basic (Declaration)
Protected MustOverride Sub OnCurrentChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As BindingManagerBase
Dim e As EventArgs

instance.OnCurrentChanged(e)
C#
protected abstract void OnCurrentChanged(
   EventArgs e
)
Managed Extensions for C++
protected: abstract void OnCurrentChanged(
   EventArgs* e
)
C++/CLI
protected:
abstract void OnCurrentChanged(
   EventArgs^ e
)

Parameters

e
The EventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingManagerBase Class
BindingManagerBase Members


OnCurrentItemChanged Method

[image]
Gizmox.WebGUI.Forms
OnCurrentItemChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingManagerBase Class : OnCurrentItemChanged Method

e
The EventArgs that contains the event data.
Raises the CurrentItemChanged event.

Syntax

Visual Basic (Declaration)
Protected MustOverride Sub OnCurrentItemChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As BindingManagerBase
Dim e As EventArgs

instance.OnCurrentItemChanged(e)
C#
protected abstract void OnCurrentItemChanged(
   EventArgs e
)
Managed Extensions for C++
protected: abstract void OnCurrentItemChanged(
   EventArgs* e
)
C++/CLI
protected:
abstract void OnCurrentItemChanged(
   EventArgs^ e
)

Parameters

e
The EventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingManagerBase Class
BindingManagerBase Members


OnDataError Method

[image]
Gizmox.WebGUI.Forms
OnDataError Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingManagerBase Class : OnDataError Method

e
An Exception that caused the DataError event to occur.
Raises the DataError event.

Syntax

Visual Basic (Declaration)
Protected Sub OnDataError( _
   ByVal e As Exception _
)
Visual Basic (Usage) Copy Code
Dim instance As BindingManagerBase
Dim e As Exception

instance.OnDataError(e)
C#
protected void OnDataError(
   Exception e
)
Managed Extensions for C++
protected: void OnDataError(
   Exception* e
)
C++/CLI
protected:
void OnDataError(
   Exception^ e
)

Parameters

e
An Exception that caused the DataError event to occur.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingManagerBase Class
BindingManagerBase Members


PullData Method

[image]
Gizmox.WebGUI.Forms
PullData Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingManagerBase Class : PullData Method

Pulls data from the data-bound control into the data source, returning no information.

Syntax

Visual Basic (Declaration)
Protected Sub PullData()
Visual Basic (Usage) Copy Code
Dim instance As BindingManagerBase

instance.PullData()
C#
protected void PullData()
Managed Extensions for C++
protected: void PullData();
C++/CLI
protected:
void PullData();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingManagerBase Class
BindingManagerBase Members


PushData Method

[image]
Gizmox.WebGUI.Forms
PushData Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingManagerBase Class : PushData Method

Pushes data from the data source into the data-bound control, returning no information.

Syntax

Visual Basic (Declaration)
Protected Sub PushData()
Visual Basic (Usage) Copy Code
Dim instance As BindingManagerBase

instance.PushData()
C#
protected void PushData()
Managed Extensions for C++
protected: void PushData();
C++/CLI
protected:
void PushData();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingManagerBase Class
BindingManagerBase Members


RemoveAt Method

[image]
Gizmox.WebGUI.Forms
RemoveAt Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingManagerBase Class : RemoveAt Method

index
The index of the row to delete.
When overridden in a derived class, deletes the row at the specified index from the underlying list.

Syntax

Visual Basic (Declaration)
Public MustOverride Sub RemoveAt( _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As BindingManagerBase
Dim index As Integer

instance.RemoveAt(index)
C#
public abstract void RemoveAt(
   int index
)
Managed Extensions for C++
public: abstract void RemoveAt(
   int index
)
C++/CLI
public:
abstract void RemoveAt(
   int index
)

Parameters

index
The index of the row to delete.

Exceptions

Exception | Description
IndexOutOfRangeException | There is no row at the specified index.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingManagerBase Class
BindingManagerBase Members


ResumeBinding Method

[image]
Gizmox.WebGUI.Forms
ResumeBinding Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingManagerBase Class : ResumeBinding Method

When overridden in a derived class, resumes data binding.

Syntax

Visual Basic (Declaration)
Public MustOverride Sub ResumeBinding()
Visual Basic (Usage) Copy Code
Dim instance As BindingManagerBase

instance.ResumeBinding()
C#
public abstract void ResumeBinding()
Managed Extensions for C++
public: abstract void ResumeBinding();
C++/CLI
public:
abstract void ResumeBinding();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingManagerBase Class
BindingManagerBase Members


SuspendBinding Method

[image]
Gizmox.WebGUI.Forms
SuspendBinding Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingManagerBase Class : SuspendBinding Method

When overridden in a derived class, suspends data binding.

Syntax

Visual Basic (Declaration)
Public MustOverride Sub SuspendBinding()
Visual Basic (Usage) Copy Code
Dim instance As BindingManagerBase

instance.SuspendBinding()
C#
public abstract void SuspendBinding()
Managed Extensions for C++
public: abstract void SuspendBinding();
C++/CLI
public:
abstract void SuspendBinding();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingManagerBase Class
BindingManagerBase Members


UpdateIsBinding Method

[image]
Gizmox.WebGUI.Forms
UpdateIsBinding Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingManagerBase Class : UpdateIsBinding Method

When overridden in a derived class, updates the binding.

Syntax

Visual Basic (Declaration)
Protected MustOverride Sub UpdateIsBinding()
Visual Basic (Usage) Copy Code
Dim instance As BindingManagerBase

instance.UpdateIsBinding()
C#
protected abstract void UpdateIsBinding()
Managed Extensions for C++
protected: abstract void UpdateIsBinding();
C++/CLI
protected:
abstract void UpdateIsBinding();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingManagerBase Class
BindingManagerBase Members


BindingManagerBase Class Properties

[image]
Gizmox.WebGUI.Forms
BindingManagerBase Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : BindingManagerBase Class

For a list of all members of this type, see BindingManagerBase members.

Public Properties

 | Name | Description
Public Property | Bindings | Gets the collection of bindings being managed.
Public Property | Count | When overridden in a derived class, gets the number of rows managed by the BindingManagerBase.
Public Property | Current | When overridden in a derived class, gets the current object.
Public Property | IsBindingSuspended | Gets a value indicating whether binding is suspended.
Public Property | Position | When overridden in a derived class, gets or sets the position in the underlying list that controls bound to this data source point to.
Top

See Also

Reference

BindingManagerBase Class
Gizmox.WebGUI.Forms Namespace


Bindings Property

[image]
Gizmox.WebGUI.Forms
Bindings Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingManagerBase Class : Bindings Property

Gets the collection of bindings being managed.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Bindings As BindingsCollection
Visual Basic (Usage) Copy Code
Dim instance As BindingManagerBase
Dim value As BindingsCollection

value = instance.Bindings
C#
public BindingsCollection Bindings {get;}
Managed Extensions for C++
public: __property BindingsCollection* get_Bindings();
C++/CLI
public:
property BindingsCollection^ Bindings {
   BindingsCollection^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingManagerBase Class
BindingManagerBase Members


Count Property

[image]
Gizmox.WebGUI.Forms
Count Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingManagerBase Class : Count Property

When overridden in a derived class, gets the number of rows managed by the BindingManagerBase.

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As BindingManagerBase
Dim value As Integer

value = instance.Count
C#
public abstract int Count {get;}
Managed Extensions for C++
public: __property abstract int get_Count();
C++/CLI
public:
abstract property int Count {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingManagerBase Class
BindingManagerBase Members


Current Property

[image]
Gizmox.WebGUI.Forms
Current Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingManagerBase Class : Current Property

When overridden in a derived class, gets the current object.

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property Current As Object
Visual Basic (Usage) Copy Code
Dim instance As BindingManagerBase
Dim value As Object

value = instance.Current
C#
public abstract object Current {get;}
Managed Extensions for C++
public: __property abstract Object* get_Current();
C++/CLI
public:
abstract property Object^ Current {
   Object^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingManagerBase Class
BindingManagerBase Members


IsBindingSuspended Property

[image]
Gizmox.WebGUI.Forms
IsBindingSuspended Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingManagerBase Class : IsBindingSuspended Property

Gets a value indicating whether binding is suspended.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsBindingSuspended As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BindingManagerBase
Dim value As Boolean

value = instance.IsBindingSuspended
C#
public bool IsBindingSuspended {get;}
Managed Extensions for C++
public: __property bool get_IsBindingSuspended();
C++/CLI
public:
property bool IsBindingSuspended {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingManagerBase Class
BindingManagerBase Members


Position Property

[image]
Gizmox.WebGUI.Forms
Position Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingManagerBase Class : Position Property

When overridden in a derived class, gets or sets the position in the underlying list that controls bound to this data source point to.

Syntax

Visual Basic (Declaration)
Public MustOverride Property Position As Integer
Visual Basic (Usage) Copy Code
Dim instance As BindingManagerBase
Dim value As Integer

instance.Position = value

value = instance.Position
C#
public abstract int Position {get; set;}
Managed Extensions for C++
public: __property abstract int get_Position();
public: __property abstract void set_Position(
   int value
);
C++/CLI
public:
abstract property int Position {
   int get();
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingManagerBase Class
BindingManagerBase Members


BindingManagerBase Class Events

[image]
Gizmox.WebGUI.Forms
BindingManagerBase Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : BindingManagerBase Class

For a list of all members of this type, see BindingManagerBase members.

Public Events

 | Name | Description
Public Event | BindingComplete | Occurs at the completion of a data-binding operation.
Public Event | CurrentChanged | Occurs when the currently bound item changes.
Public Event | CurrentItemChanged | Occurs when the state of the currently bound item changes.
Public Event | DataError | Occurs when an Exception is silently handled by the BindingManagerBase.
Public Event | PositionChanged | Occurs after the value of the Position property has changed.
Top

See Also

Reference

BindingManagerBase Class
Gizmox.WebGUI.Forms Namespace


BindingComplete Event

[image]
Gizmox.WebGUI.Forms
BindingComplete Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingManagerBase Class : BindingComplete Event

Occurs at the completion of a data-binding operation.

Syntax

Visual Basic (Declaration)
Public Event BindingComplete() As BindingCompleteEventHandler
Visual Basic (Usage) Copy Code
Dim instance As BindingManagerBase
Dim handler As BindingCompleteEventHandler

AddHandler instance.BindingComplete, handler
C#
public event BindingCompleteEventHandler BindingComplete()
Managed Extensions for C++
public: __event BindingCompleteEventHandler* BindingComplete
C++/CLI
public:
event BindingCompleteEventHandler^ BindingComplete

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingManagerBase Class
BindingManagerBase Members


CurrentChanged Event

[image]
Gizmox.WebGUI.Forms
CurrentChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingManagerBase Class : CurrentChanged Event

Occurs when the currently bound item changes.

Syntax

Visual Basic (Declaration)
Public Event CurrentChanged() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As BindingManagerBase
Dim handler As EventHandler

AddHandler instance.CurrentChanged, handler
C#
public event EventHandler CurrentChanged()
Managed Extensions for C++
public: __event EventHandler* CurrentChanged
C++/CLI
public:
event EventHandler^ CurrentChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingManagerBase Class
BindingManagerBase Members


CurrentItemChanged Event

[image]
Gizmox.WebGUI.Forms
CurrentItemChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingManagerBase Class : CurrentItemChanged Event

Occurs when the state of the currently bound item changes.

Syntax

Visual Basic (Declaration)
Public Event CurrentItemChanged() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As BindingManagerBase
Dim handler As EventHandler

AddHandler instance.CurrentItemChanged, handler
C#
public event EventHandler CurrentItemChanged()
Managed Extensions for C++
public: __event EventHandler* CurrentItemChanged
C++/CLI
public:
event EventHandler^ CurrentItemChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingManagerBase Class
BindingManagerBase Members


DataError Event

[image]
Gizmox.WebGUI.Forms
DataError Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingManagerBase Class : DataError Event

Occurs when an Exception is silently handled by the BindingManagerBase.

Syntax

Visual Basic (Declaration)
Public Event DataError() As BindingManagerDataErrorEventHandler
Visual Basic (Usage) Copy Code
Dim instance As BindingManagerBase
Dim handler As BindingManagerDataErrorEventHandler

AddHandler instance.DataError, handler
C#
public event BindingManagerDataErrorEventHandler DataError()
Managed Extensions for C++
public: __event BindingManagerDataErrorEventHandler* DataError
C++/CLI
public:
event BindingManagerDataErrorEventHandler^ DataError

Event Data

The event handler receives an argument of type BindingManagerDataErrorEventArgs containing data related to this event. The following BindingManagerDataErrorEventArgs properties provide information specific to this event.

Property | Description
Exception | Gets the Exception caught in the binding process that caused the DataError event to be raised.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingManagerBase Class
BindingManagerBase Members


PositionChanged Event

[image]
Gizmox.WebGUI.Forms
PositionChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingManagerBase Class : PositionChanged Event

Occurs after the value of the Position property has changed.

Syntax

Visual Basic (Declaration)
Public Event PositionChanged() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As BindingManagerBase
Dim handler As EventHandler

AddHandler instance.PositionChanged, handler
C#
public event EventHandler PositionChanged()
Managed Extensions for C++
public: __event EventHandler* PositionChanged
C++/CLI
public:
event EventHandler^ PositionChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingManagerBase Class
BindingManagerBase Members


BindingManagerDataErrorEventArgs Class

[image]
Gizmox.WebGUI.Forms
BindingManagerDataErrorEventArgs Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : BindingManagerDataErrorEventArgs Class

Provides data for the DataError event.

Syntax

Visual Basic (Declaration)
Public Class BindingManagerDataErrorEventArgs
   Inherits EventArgs
Visual Basic (Usage) Copy Code
Dim instance As BindingManagerDataErrorEventArgs
C#
public class BindingManagerDataErrorEventArgs : EventArgs
Managed Extensions for C++
public __gc class BindingManagerDataErrorEventArgs : public EventArgs
C++/CLI
public ref class BindingManagerDataErrorEventArgs : public EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gizmox.WebGUI.Forms.BindingManagerDataErrorEventArgs

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

BindingManagerDataErrorEventArgs Members
Gizmox.WebGUI.Forms Namespace


BindingManagerDataErrorEventArgs Class Members

[image]
Gizmox.WebGUI.Forms
BindingManagerDataErrorEventArgs Class Members
See Also Properties Send Feedback
Gizmox.WebGUI.Forms Namespace : BindingManagerDataErrorEventArgs Class

The following tables list the members exposed by BindingManagerDataErrorEventArgs.

Public Constructors

 | Name | Description
Public Constructor | BindingManagerDataErrorEventArgs Constructor | Initializes a new instance of the BindingManagerDataErrorEventArgs class.
Top

Public Properties

 | Name | Description
Public Property | Exception | Gets the Exception caught in the binding process that caused the DataError event to be raised.
Top

See Also

Reference

BindingManagerDataErrorEventArgs Class
Gizmox.WebGUI.Forms Namespace


BindingManagerDataErrorEventArgs Constructor

[image]
Gizmox.WebGUI.Forms
BindingManagerDataErrorEventArgs Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingManagerDataErrorEventArgs Class : BindingManagerDataErrorEventArgs Constructor

exception
The Exception that occurred in the binding process that caused the DataError event to be raised.
Initializes a new instance of the BindingManagerDataErrorEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal exception As Exception _
)
Visual Basic (Usage) Copy Code
Dim exception As Exception

Dim instance As BindingManagerDataErrorEventArgs(exception)
C#
public BindingManagerDataErrorEventArgs(
   Exception exception
)
Managed Extensions for C++
public: BindingManagerDataErrorEventArgs(
   Exception* exception
)
C++/CLI
public:
BindingManagerDataErrorEventArgs(
   Exception^ exception
)

Parameters

exception
The Exception that occurred in the binding process that caused the DataError event to be raised.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingManagerDataErrorEventArgs Class
BindingManagerDataErrorEventArgs Members


BindingManagerDataErrorEventArgs Class Properties

[image]
Gizmox.WebGUI.Forms
BindingManagerDataErrorEventArgs Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : BindingManagerDataErrorEventArgs Class

For a list of all members of this type, see BindingManagerDataErrorEventArgs members.

Public Properties

 | Name | Description
Public Property | Exception | Gets the Exception caught in the binding process that caused the DataError event to be raised.
Top

See Also

Reference

BindingManagerDataErrorEventArgs Class
Gizmox.WebGUI.Forms Namespace


Exception Property

[image]
Gizmox.WebGUI.Forms
Exception Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingManagerDataErrorEventArgs Class : Exception Property

Gets the Exception caught in the binding process that caused the DataError event to be raised.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Exception As Exception
Visual Basic (Usage) Copy Code
Dim instance As BindingManagerDataErrorEventArgs
Dim value As Exception

value = instance.Exception
C#
public Exception Exception {get;}
Managed Extensions for C++
public: __property Exception* get_Exception();
C++/CLI
public:
property Exception^ Exception {
   Exception^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingManagerDataErrorEventArgs Class
BindingManagerDataErrorEventArgs Members


BindingNavigator Class

[image]
Gizmox.WebGUI.Forms
BindingNavigator Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : BindingNavigator Class

Represents the navigation and manipulation user interface (UI) for controls on a form that are bound to data.

Object Model

Syntax

Visual Basic (Declaration)
<DesignTimeControllerAttribute()>
<ClientControllerAttribute()>
<ToolboxBitmapAttribute()>
<ToolboxItemCategoryAttribute("Data")>
Public Class BindingNavigator
   Inherits ToolBar
   Implements IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Visual Basic (Usage) Copy Code
Dim instance As BindingNavigator
C#
[DesignTimeControllerAttribute()]
[ClientControllerAttribute()]
[ToolboxBitmapAttribute()]
[ToolboxItemCategoryAttribute("Data")]
public class BindingNavigator : ToolBar, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Managed Extensions for C++
[DesignTimeControllerAttribute()]
[ClientControllerAttribute()]
[ToolboxBitmapAttribute()]
[ToolboxItemCategoryAttribute("Data")]
public __gc class BindingNavigator : public ToolBar, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
C++/CLI
[DesignTimeControllerAttribute()]
[ClientControllerAttribute()]
[ToolboxBitmapAttribute()]
[ToolboxItemCategoryAttribute("Data")]
public ref class BindingNavigator : public ToolBar, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.ToolBar
Gizmox.WebGUI.Forms.BindingNavigator

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

BindingNavigator Members
Gizmox.WebGUI.Forms Namespace


BindingNavigator Class Members

[image]
Gizmox.WebGUI.Forms
BindingNavigator Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : BindingNavigator Class

The following tables list the members exposed by BindingNavigator.

Public Constructors

 | Name | Description
Public Constructor | BindingNavigator Constructor | Overloaded. Initializes a new instance of the BindingNavigator class, indicating whether to display the standard navigation user interface (UI).
Top

Public Properties

 | Name | Description
Public Property | AddNewItem | Gets or sets the ToolBarButton that represents the Add New button.
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | Appearance | Gets or sets the toolbar appearance. (Inherited from ToolBar)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BindingSource | Gets or sets the BindingSource component that is the source of data.
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | Buttons | Gets the toolbar button collecction (Inherited from ToolBar)
Public Property | ButtonSize | Gets or sets the size of the buttons. (Inherited from ToolBar)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | CountItem | Gets or sets the ToolBarButton that displays the total number of items in the associated BindingSource.
Public Property | CountItemFormat | Gets or sets a string used to format the information displayed in the CountItem control.
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | DeleteItem | Gets or sets the ToolBarButton that is associated with the Delete functionality.
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DragHandle | Gets or sets a value indicating whether to display drag handle. (Inherited from ToolBar)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | DropDownArrows | Gets or sets a value indicating whether to display dropdown arrows. (Inherited from ToolBar)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | ImageList | Gets or sets the toolbar image list. (Inherited from ToolBar)
Public Property | ImageSize | Gets the size of the images in the image list assigned to the toolbar. (Inherited from ToolBar)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MenuHandle | Gets or sets a value indicating whether to display menu handle. (Inherited from ToolBar)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MoveFirstItem | Gets or sets the ToolBarButton that is associated with the Move First functionality.
Public Property | MoveLastItem | Gets or sets the ToolBarButton that is associated with the Move Last functionality.
Public Property | MoveNextItem | Gets or sets the ToolBarButton that is associated with the Move Next functionality.
Public Property | MovePreviousItem | Gets or sets the ToolBarButton that is associated with the Move Previous functionality.
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PositionItem | Gets or sets the ToolBarButton that displays the current position within the BindingSource.
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether to invert buttons. (Inherited from ToolBar)
Public Property | ShowToolTips | Gets or sets a value indicating whether to show tooltips. (Inherited from ToolBar)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Control)
Public Property | TextAlign | Gets or sets the buttons text align. (Inherited from ToolBar)
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

Public Methods

 | Name | Description
Public Method | AddStandardItems | Adds the standard set of navigation items to the BindingNavigator control.
Public Method | BeginInit | Disables updates to the ToolBarButton controls of the BindingNavigator during the component's initialization.
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the BindingNavigator and optionally releases the managed resources.
Public Method | EndInit | Enables updates to the ToolBarButton controls of the BindingNavigator after the component's initialization has concluded.
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Public Method | Validate | Causes form validation to occur and returns whether validation was successful.
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Control)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from Control)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnButtonClick | Raises the ButtonClick event. (Inherited from ToolBar)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnRefreshItems | Raises the RefreshItems event.
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from ToolBar)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RefreshItemsCore | Refreshes the state of the standard items to reflect the current state of the data.
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | ToolBar render implementation (Inherited from ToolBar)
Protected Method | RenderAttributes | Renders the controls meta attributes (Inherited from Control)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | (Inherited from ToolBar)
Protected Method | RenderControls | Overloaded. Render buttons (Inherited from ToolBar)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | Do not serialize the size on docked mode (Inherited from ToolBar)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | Do not serialize size on docked mode (Inherited from ToolBar)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | ButtonClick | Occurs when a user clicks on a button (Inherited from ToolBar)
Public Event | Click | Occurs when a user clicks on a button (Inherited from ToolBar)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | RefreshItems | Occurs when the state of the navigational user interface (UI) needs to be refreshed to reflect the current state of the underlying data.
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

BindingNavigator Class
Gizmox.WebGUI.Forms Namespace


BindingNavigator Constructor

[image]
Gizmox.WebGUI.Forms
BindingNavigator Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingNavigator Class : BindingNavigator Constructor

Initializes a new instance of the BindingNavigator class, indicating whether to display the standard navigation user interface (UI).

Overload List

Overload | Description
BindingNavigator Constructor(BindingSource) | Initializes a new instance of the BindingNavigator class with the specified BindingSource as the data source.
BindingNavigator Constructor(Boolean) | Initializes a new instance of the BindingNavigator class, indicating whether to display the standard navigation user interface (UI).

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingNavigator Class
BindingNavigator Members


BindingNavigator Constructor(BindingSource)

[image]
Gizmox.WebGUI.Forms
BindingNavigator Constructor(BindingSource)
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingNavigator Class > BindingNavigator Constructor : BindingNavigator Constructor(BindingSource)

bindingSource
The BindingSource used as a data source.
Initializes a new instance of the BindingNavigator class with the specified BindingSource as the data source.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal bindingSource As BindingSource _
)
Visual Basic (Usage) Copy Code
Dim bindingSource As BindingSource

Dim instance As BindingNavigator(bindingSource)
C#
public BindingNavigator(
   BindingSource bindingSource
)
Managed Extensions for C++
public: BindingNavigator(
   BindingSource* bindingSource
)
C++/CLI
public:
BindingNavigator(
   BindingSource^ bindingSource
)

Parameters

bindingSource
The BindingSource used as a data source.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingNavigator Class
BindingNavigator Members
Overload List


BindingNavigator Constructor(Boolean)

[image]
Gizmox.WebGUI.Forms
BindingNavigator Constructor(Boolean)
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingNavigator Class > BindingNavigator Constructor : BindingNavigator Constructor(Boolean)

addStandardItems
true to show the standard navigational UI; otherwise, false.
Initializes a new instance of the BindingNavigator class, indicating whether to display the standard navigation user interface (UI).

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal addStandardItems As Boolean _
)
Visual Basic (Usage) Copy Code
Dim addStandardItems As Boolean

Dim instance As BindingNavigator(addStandardItems)
C#
public BindingNavigator(
   bool addStandardItems
)
Managed Extensions for C++
public: BindingNavigator(
   bool addStandardItems
)
C++/CLI
public:
BindingNavigator(
   bool addStandardItems
)

Parameters

addStandardItems
true to show the standard navigational UI; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingNavigator Class
BindingNavigator Members
Overload List


BindingNavigator Class Methods

[image]
Gizmox.WebGUI.Forms
BindingNavigator Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : BindingNavigator Class

For a list of all members of this type, see BindingNavigator members.

Public Methods

 | Name | Description
Public Method | AddStandardItems | Adds the standard set of navigation items to the BindingNavigator control.
Public Method | BeginInit | Disables updates to the ToolBarButton controls of the BindingNavigator during the component's initialization.
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the BindingNavigator and optionally releases the managed resources.
Public Method | EndInit | Enables updates to the ToolBarButton controls of the BindingNavigator after the component's initialization has concluded.
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Public Method | Validate | Causes form validation to occur and returns whether validation was successful.
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Control)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from Control)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnButtonClick | Raises the ButtonClick event. (Inherited from ToolBar)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnRefreshItems | Raises the RefreshItems event.
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from ToolBar)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RefreshItemsCore | Refreshes the state of the standard items to reflect the current state of the data.
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | ToolBar render implementation (Inherited from ToolBar)
Protected Method | RenderAttributes | Renders the controls meta attributes (Inherited from Control)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | (Inherited from ToolBar)
Protected Method | RenderControls | Overloaded. Render buttons (Inherited from ToolBar)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | Do not serialize the size on docked mode (Inherited from ToolBar)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | Do not serialize size on docked mode (Inherited from ToolBar)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

See Also

Reference

BindingNavigator Class
Gizmox.WebGUI.Forms Namespace


AddStandardItems Method

[image]
Gizmox.WebGUI.Forms
AddStandardItems Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingNavigator Class : AddStandardItems Method

Adds the standard set of navigation items to the BindingNavigator control.

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddStandardItems()
Visual Basic (Usage) Copy Code
Dim instance As BindingNavigator

instance.AddStandardItems()
C#
public virtual void AddStandardItems()
Managed Extensions for C++
public: virtual void AddStandardItems();
C++/CLI
public:
virtual void AddStandardItems();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingNavigator Class
BindingNavigator Members


BeginInit Method

[image]
Gizmox.WebGUI.Forms
BeginInit Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingNavigator Class : BeginInit Method

Disables updates to the ToolBarButton controls of the BindingNavigator during the component's initialization.

Syntax

Visual Basic (Declaration)
Public Sub BeginInit()
Visual Basic (Usage) Copy Code
Dim instance As BindingNavigator

instance.BeginInit()
C#
public void BeginInit()
Managed Extensions for C++
public: void BeginInit();
C++/CLI
public:
void BeginInit();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingNavigator Class
BindingNavigator Members


Dispose Method

[image]
Gizmox.WebGUI.Forms
Dispose Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingNavigator Class : Dispose Method

Releases the unmanaged resources used by the BindingNavigator and optionally releases the managed resources.

Overload List

Overload | Description
Dispose(Boolean) | Releases the unmanaged resources used by the BindingNavigator and optionally releases the managed resources.
Dispose() | (Inherited from ComponentBase)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingNavigator Class
BindingNavigator Members


Dispose(Boolean) Method

[image]
Gizmox.WebGUI.Forms
Dispose(Boolean) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingNavigator Class > Dispose Method : Dispose(Boolean) Method

disposing
true to release both managed and unmanaged resources; false to release only unmanaged resources.
Releases the unmanaged resources used by the BindingNavigator and optionally releases the managed resources.

Syntax

Visual Basic (Declaration)
Protected Overloads Overridable Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As BindingNavigator
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected virtual void Dispose(
   bool disposing
)
Managed Extensions for C++
protected: virtual void Dispose(
   bool disposing
)
C++/CLI
protected:
virtual void Dispose(
   bool disposing
)

Parameters

disposing
true to release both managed and unmanaged resources; false to release only unmanaged resources.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingNavigator Class
BindingNavigator Members
Overload List


EndInit Method

[image]
Gizmox.WebGUI.Forms
EndInit Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingNavigator Class : EndInit Method

Enables updates to the ToolBarButton controls of the BindingNavigator after the component's initialization has concluded.

Syntax

Visual Basic (Declaration)
Public Sub EndInit()
Visual Basic (Usage) Copy Code
Dim instance As BindingNavigator

instance.EndInit()
C#
public void EndInit()
Managed Extensions for C++
public: void EndInit();
C++/CLI
public:
void EndInit();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingNavigator Class
BindingNavigator Members


OnRefreshItems Method

[image]
Gizmox.WebGUI.Forms
OnRefreshItems Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingNavigator Class : OnRefreshItems Method

Raises the RefreshItems event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnRefreshItems()
Visual Basic (Usage) Copy Code
Dim instance As BindingNavigator

instance.OnRefreshItems()
C#
protected virtual void OnRefreshItems()
Managed Extensions for C++
protected: virtual void OnRefreshItems();
C++/CLI
protected:
virtual void OnRefreshItems();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingNavigator Class
BindingNavigator Members


RefreshItemsCore Method

[image]
Gizmox.WebGUI.Forms
RefreshItemsCore Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingNavigator Class : RefreshItemsCore Method

Refreshes the state of the standard items to reflect the current state of the data.

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub RefreshItemsCore()
Visual Basic (Usage) Copy Code
Dim instance As BindingNavigator

instance.RefreshItemsCore()
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void RefreshItemsCore()
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void RefreshItemsCore();
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void RefreshItemsCore();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingNavigator Class
BindingNavigator Members


Validate Method

[image]
Gizmox.WebGUI.Forms
Validate Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingNavigator Class : Validate Method

Causes form validation to occur and returns whether validation was successful.

Syntax

Visual Basic (Declaration)
Public Function Validate() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BindingNavigator
Dim value As Boolean

value = instance.Validate()
C#
public bool Validate()
Managed Extensions for C++
public: bool Validate();
C++/CLI
public:
bool Validate();

Return Value

true if validation was successful and focus can shift to the BindingNavigator; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingNavigator Class
BindingNavigator Members


BindingNavigator Class Properties

[image]
Gizmox.WebGUI.Forms
BindingNavigator Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : BindingNavigator Class

For a list of all members of this type, see BindingNavigator members.

Public Properties

 | Name | Description
Public Property | AddNewItem | Gets or sets the ToolBarButton that represents the Add New button.
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | Appearance | Gets or sets the toolbar appearance. (Inherited from ToolBar)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BindingSource | Gets or sets the BindingSource component that is the source of data.
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | Buttons | Gets the toolbar button collecction (Inherited from ToolBar)
Public Property | ButtonSize | Gets or sets the size of the buttons. (Inherited from ToolBar)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | CountItem | Gets or sets the ToolBarButton that displays the total number of items in the associated BindingSource.
Public Property | CountItemFormat | Gets or sets a string used to format the information displayed in the CountItem control.
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | DeleteItem | Gets or sets the ToolBarButton that is associated with the Delete functionality.
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DragHandle | Gets or sets a value indicating whether to display drag handle. (Inherited from ToolBar)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | DropDownArrows | Gets or sets a value indicating whether to display dropdown arrows. (Inherited from ToolBar)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | ImageList | Gets or sets the toolbar image list. (Inherited from ToolBar)
Public Property | ImageSize | Gets the size of the images in the image list assigned to the toolbar. (Inherited from ToolBar)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MenuHandle | Gets or sets a value indicating whether to display menu handle. (Inherited from ToolBar)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MoveFirstItem | Gets or sets the ToolBarButton that is associated with the Move First functionality.
Public Property | MoveLastItem | Gets or sets the ToolBarButton that is associated with the Move Last functionality.
Public Property | MoveNextItem | Gets or sets the ToolBarButton that is associated with the Move Next functionality.
Public Property | MovePreviousItem | Gets or sets the ToolBarButton that is associated with the Move Previous functionality.
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PositionItem | Gets or sets the ToolBarButton that displays the current position within the BindingSource.
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether to invert buttons. (Inherited from ToolBar)
Public Property | ShowToolTips | Gets or sets a value indicating whether to show tooltips. (Inherited from ToolBar)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Control)
Public Property | TextAlign | Gets or sets the buttons text align. (Inherited from ToolBar)
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

See Also

Reference

BindingNavigator Class
Gizmox.WebGUI.Forms Namespace


AddNewItem Property

[image]
Gizmox.WebGUI.Forms
AddNewItem Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingNavigator Class : AddNewItem Property

Gets or sets the ToolBarButton that represents the Add New button.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("The ToolStripItem on the BindingNavigator that raises the 'Add new' action.")>
<TypeConverterAttribute("System.ComponentModel.ReferenceConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<SRCategoryAttribute("Items")>
Public Property AddNewItem As ToolBarButton
Visual Basic (Usage) Copy Code
Dim instance As BindingNavigator
Dim value As ToolBarButton

instance.AddNewItem = value

value = instance.AddNewItem
C#
[SRDescriptionAttribute("The ToolStripItem on the BindingNavigator that raises the 'Add new' action.")]
[TypeConverterAttribute("System.ComponentModel.ReferenceConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[SRCategoryAttribute("Items")]
public ToolBarButton AddNewItem {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("The ToolStripItem on the BindingNavigator that raises the 'Add new' action.")]
[TypeConverterAttribute("System.ComponentModel.ReferenceConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[SRCategoryAttribute("Items")]
public: __property ToolBarButton* get_AddNewItem();
public: __property void set_AddNewItem(
   ToolBarButton* value
);
C++/CLI
[SRDescriptionAttribute("The ToolStripItem on the BindingNavigator that raises the 'Add new' action.")]
[TypeConverterAttribute("System.ComponentModel.ReferenceConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[SRCategoryAttribute("Items")]
public:
property ToolBarButton^ AddNewItem {
   ToolBarButton^ get();
   void set (ToolBarButton^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingNavigator Class
BindingNavigator Members


BindingSource Property

[image]
Gizmox.WebGUI.Forms
BindingSource Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingNavigator Class : BindingSource Property

Gets or sets the BindingSource component that is the source of data.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("The BindingSource that the BindingNavigator navigates.")>
<DefaultValueAttribute()>
<SRCategoryAttribute("Data")>
<TypeConverterAttribute("System.ComponentModel.ReferenceConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
Public Property BindingSource As BindingSource
Visual Basic (Usage) Copy Code
Dim instance As BindingNavigator
Dim value As BindingSource

instance.BindingSource = value

value = instance.BindingSource
C#
[SRDescriptionAttribute("The BindingSource that the BindingNavigator navigates.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Data")]
[TypeConverterAttribute("System.ComponentModel.ReferenceConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public BindingSource BindingSource {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("The BindingSource that the BindingNavigator navigates.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Data")]
[TypeConverterAttribute("System.ComponentModel.ReferenceConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public: __property BindingSource* get_BindingSource();
public: __property void set_BindingSource(
   BindingSource* value
);
C++/CLI
[SRDescriptionAttribute("The BindingSource that the BindingNavigator navigates.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Data")]
[TypeConverterAttribute("System.ComponentModel.ReferenceConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public:
property BindingSource^ BindingSource {
   BindingSource^ get();
   void set (BindingSource^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingNavigator Class
BindingNavigator Members


CountItem Property

[image]
Gizmox.WebGUI.Forms
CountItem Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingNavigator Class : CountItem Property

Gets or sets the ToolBarButton that displays the total number of items in the associated BindingSource.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("The ToolStripItem on the BindingNavigator that displays the total number of items.")>
<SRCategoryAttribute("Items")>
<TypeConverterAttribute("System.ComponentModel.ReferenceConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
Public Property CountItem As ToolBarButton
Visual Basic (Usage) Copy Code
Dim instance As BindingNavigator
Dim value As ToolBarButton

instance.CountItem = value

value = instance.CountItem
C#
[SRDescriptionAttribute("The ToolStripItem on the BindingNavigator that displays the total number of items.")]
[SRCategoryAttribute("Items")]
[TypeConverterAttribute("System.ComponentModel.ReferenceConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public ToolBarButton CountItem {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("The ToolStripItem on the BindingNavigator that displays the total number of items.")]
[SRCategoryAttribute("Items")]
[TypeConverterAttribute("System.ComponentModel.ReferenceConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public: __property ToolBarButton* get_CountItem();
public: __property void set_CountItem(
   ToolBarButton* value
);
C++/CLI
[SRDescriptionAttribute("The ToolStripItem on the BindingNavigator that displays the total number of items.")]
[SRCategoryAttribute("Items")]
[TypeConverterAttribute("System.ComponentModel.ReferenceConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public:
property ToolBarButton^ CountItem {
   ToolBarButton^ get();
   void set (ToolBarButton^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingNavigator Class
BindingNavigator Members


CountItemFormat Property

[image]
Gizmox.WebGUI.Forms
CountItemFormat Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingNavigator Class : CountItemFormat Property

Gets or sets a string used to format the information displayed in the CountItem control.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Appearance")>
<SRDescriptionAttribute("Formatting to apply to count displayed in the CountItem ToolStrip item.")>
Public Property CountItemFormat As String
Visual Basic (Usage) Copy Code
Dim instance As BindingNavigator
Dim value As String

instance.CountItemFormat = value

value = instance.CountItemFormat
C#
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Formatting to apply to count displayed in the CountItem ToolStrip item.")]
public string CountItemFormat {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Formatting to apply to count displayed in the CountItem ToolStrip item.")]
public: __property string* get_CountItemFormat();
public: __property void set_CountItemFormat(
   string* value
);
C++/CLI
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Formatting to apply to count displayed in the CountItem ToolStrip item.")]
public:
property String^ CountItemFormat {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingNavigator Class
BindingNavigator Members


DeleteItem Property

[image]
Gizmox.WebGUI.Forms
DeleteItem Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingNavigator Class : DeleteItem Property

Gets or sets the ToolBarButton that is associated with the Delete functionality.

Syntax

Visual Basic (Declaration)
<TypeConverterAttribute("System.ComponentModel.ReferenceConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<SRCategoryAttribute("Items")>
<SRDescriptionAttribute("The ToolStripItem on the BindingNavigator that raises the 'Delete' action.")>
Public Property DeleteItem As ToolBarButton
Visual Basic (Usage) Copy Code
Dim instance As BindingNavigator
Dim value As ToolBarButton

instance.DeleteItem = value

value = instance.DeleteItem
C#
[TypeConverterAttribute("System.ComponentModel.ReferenceConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[SRCategoryAttribute("Items")]
[SRDescriptionAttribute("The ToolStripItem on the BindingNavigator that raises the 'Delete' action.")]
public ToolBarButton DeleteItem {get; set;}
Managed Extensions for C++
[TypeConverterAttribute("System.ComponentModel.ReferenceConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[SRCategoryAttribute("Items")]
[SRDescriptionAttribute("The ToolStripItem on the BindingNavigator that raises the 'Delete' action.")]
public: __property ToolBarButton* get_DeleteItem();
public: __property void set_DeleteItem(
   ToolBarButton* value
);
C++/CLI
[TypeConverterAttribute("System.ComponentModel.ReferenceConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[SRCategoryAttribute("Items")]
[SRDescriptionAttribute("The ToolStripItem on the BindingNavigator that raises the 'Delete' action.")]
public:
property ToolBarButton^ DeleteItem {
   ToolBarButton^ get();
   void set (ToolBarButton^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingNavigator Class
BindingNavigator Members


MoveFirstItem Property

[image]
Gizmox.WebGUI.Forms
MoveFirstItem Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingNavigator Class : MoveFirstItem Property

Gets or sets the ToolBarButton that is associated with the Move First functionality.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Items")>
<TypeConverterAttribute("System.ComponentModel.ReferenceConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<SRDescriptionAttribute("The ToolStripItem on the BindingNavigator that raises the 'Move first' action.")>
Public Property MoveFirstItem As ToolBarButton
Visual Basic (Usage) Copy Code
Dim instance As BindingNavigator
Dim value As ToolBarButton

instance.MoveFirstItem = value

value = instance.MoveFirstItem
C#
[SRCategoryAttribute("Items")]
[TypeConverterAttribute("System.ComponentModel.ReferenceConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[SRDescriptionAttribute("The ToolStripItem on the BindingNavigator that raises the 'Move first' action.")]
public ToolBarButton MoveFirstItem {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Items")]
[TypeConverterAttribute("System.ComponentModel.ReferenceConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[SRDescriptionAttribute("The ToolStripItem on the BindingNavigator that raises the 'Move first' action.")]
public: __property ToolBarButton* get_MoveFirstItem();
public: __property void set_MoveFirstItem(
   ToolBarButton* value
);
C++/CLI
[SRCategoryAttribute("Items")]
[TypeConverterAttribute("System.ComponentModel.ReferenceConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[SRDescriptionAttribute("The ToolStripItem on the BindingNavigator that raises the 'Move first' action.")]
public:
property ToolBarButton^ MoveFirstItem {
   ToolBarButton^ get();
   void set (ToolBarButton^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingNavigator Class
BindingNavigator Members


MoveLastItem Property

[image]
Gizmox.WebGUI.Forms
MoveLastItem Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingNavigator Class : MoveLastItem Property

Gets or sets the ToolBarButton that is associated with the Move Last functionality.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Items")>
<SRDescriptionAttribute("The ToolStripItem on the BindingNavigator that raises the 'Move last' action.")>
<TypeConverterAttribute("System.ComponentModel.ReferenceConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
Public Property MoveLastItem As ToolBarButton
Visual Basic (Usage) Copy Code
Dim instance As BindingNavigator
Dim value As ToolBarButton

instance.MoveLastItem = value

value = instance.MoveLastItem
C#
[SRCategoryAttribute("Items")]
[SRDescriptionAttribute("The ToolStripItem on the BindingNavigator that raises the 'Move last' action.")]
[TypeConverterAttribute("System.ComponentModel.ReferenceConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public ToolBarButton MoveLastItem {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Items")]
[SRDescriptionAttribute("The ToolStripItem on the BindingNavigator that raises the 'Move last' action.")]
[TypeConverterAttribute("System.ComponentModel.ReferenceConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public: __property ToolBarButton* get_MoveLastItem();
public: __property void set_MoveLastItem(
   ToolBarButton* value
);
C++/CLI
[SRCategoryAttribute("Items")]
[SRDescriptionAttribute("The ToolStripItem on the BindingNavigator that raises the 'Move last' action.")]
[TypeConverterAttribute("System.ComponentModel.ReferenceConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public:
property ToolBarButton^ MoveLastItem {
   ToolBarButton^ get();
   void set (ToolBarButton^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingNavigator Class
BindingNavigator Members


MoveNextItem Property

[image]
Gizmox.WebGUI.Forms
MoveNextItem Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingNavigator Class : MoveNextItem Property

Gets or sets the ToolBarButton that is associated with the Move Next functionality.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("The ToolStripItem on the BindingNavigator that raises the 'Move next' action.")>
<SRCategoryAttribute("Items")>
<TypeConverterAttribute("System.ComponentModel.ReferenceConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
Public Property MoveNextItem As ToolBarButton
Visual Basic (Usage) Copy Code
Dim instance As BindingNavigator
Dim value As ToolBarButton

instance.MoveNextItem = value

value = instance.MoveNextItem
C#
[SRDescriptionAttribute("The ToolStripItem on the BindingNavigator that raises the 'Move next' action.")]
[SRCategoryAttribute("Items")]
[TypeConverterAttribute("System.ComponentModel.ReferenceConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public ToolBarButton MoveNextItem {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("The ToolStripItem on the BindingNavigator that raises the 'Move next' action.")]
[SRCategoryAttribute("Items")]
[TypeConverterAttribute("System.ComponentModel.ReferenceConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public: __property ToolBarButton* get_MoveNextItem();
public: __property void set_MoveNextItem(
   ToolBarButton* value
);
C++/CLI
[SRDescriptionAttribute("The ToolStripItem on the BindingNavigator that raises the 'Move next' action.")]
[SRCategoryAttribute("Items")]
[TypeConverterAttribute("System.ComponentModel.ReferenceConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public:
property ToolBarButton^ MoveNextItem {
   ToolBarButton^ get();
   void set (ToolBarButton^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingNavigator Class
BindingNavigator Members


MovePreviousItem Property

[image]
Gizmox.WebGUI.Forms
MovePreviousItem Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingNavigator Class : MovePreviousItem Property

Gets or sets the ToolBarButton that is associated with the Move Previous functionality.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Items")>
<SRDescriptionAttribute("The ToolStripItem on the BindingNavigator that raises the 'Move previous' action.")>
<TypeConverterAttribute("System.ComponentModel.ReferenceConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
Public Property MovePreviousItem As ToolBarButton
Visual Basic (Usage) Copy Code
Dim instance As BindingNavigator
Dim value As ToolBarButton

instance.MovePreviousItem = value

value = instance.MovePreviousItem
C#
[SRCategoryAttribute("Items")]
[SRDescriptionAttribute("The ToolStripItem on the BindingNavigator that raises the 'Move previous' action.")]
[TypeConverterAttribute("System.ComponentModel.ReferenceConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public ToolBarButton MovePreviousItem {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Items")]
[SRDescriptionAttribute("The ToolStripItem on the BindingNavigator that raises the 'Move previous' action.")]
[TypeConverterAttribute("System.ComponentModel.ReferenceConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public: __property ToolBarButton* get_MovePreviousItem();
public: __property void set_MovePreviousItem(
   ToolBarButton* value
);
C++/CLI
[SRCategoryAttribute("Items")]
[SRDescriptionAttribute("The ToolStripItem on the BindingNavigator that raises the 'Move previous' action.")]
[TypeConverterAttribute("System.ComponentModel.ReferenceConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public:
property ToolBarButton^ MovePreviousItem {
   ToolBarButton^ get();
   void set (ToolBarButton^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingNavigator Class
BindingNavigator Members


PositionItem Property

[image]
Gizmox.WebGUI.Forms
PositionItem Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingNavigator Class : PositionItem Property

Gets or sets the ToolBarButton that displays the current position within the BindingSource.

Syntax

Visual Basic (Declaration)
<TypeConverterAttribute("System.ComponentModel.ReferenceConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<SRDescriptionAttribute("The ToolStripItem on the BindingNavigator that displays the current position.")>
<SRCategoryAttribute("Items")>
Public Property PositionItem As ToolBarButton
Visual Basic (Usage) Copy Code
Dim instance As BindingNavigator
Dim value As ToolBarButton

instance.PositionItem = value

value = instance.PositionItem
C#
[TypeConverterAttribute("System.ComponentModel.ReferenceConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[SRDescriptionAttribute("The ToolStripItem on the BindingNavigator that displays the current position.")]
[SRCategoryAttribute("Items")]
public ToolBarButton PositionItem {get; set;}
Managed Extensions for C++
[TypeConverterAttribute("System.ComponentModel.ReferenceConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[SRDescriptionAttribute("The ToolStripItem on the BindingNavigator that displays the current position.")]
[SRCategoryAttribute("Items")]
public: __property ToolBarButton* get_PositionItem();
public: __property void set_PositionItem(
   ToolBarButton* value
);
C++/CLI
[TypeConverterAttribute("System.ComponentModel.ReferenceConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[SRDescriptionAttribute("The ToolStripItem on the BindingNavigator that displays the current position.")]
[SRCategoryAttribute("Items")]
public:
property ToolBarButton^ PositionItem {
   ToolBarButton^ get();
   void set (ToolBarButton^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingNavigator Class
BindingNavigator Members


BindingNavigator Class Events

[image]
Gizmox.WebGUI.Forms
BindingNavigator Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : BindingNavigator Class

For a list of all members of this type, see BindingNavigator members.

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | ButtonClick | Occurs when a user clicks on a button (Inherited from ToolBar)
Public Event | Click | Occurs when a user clicks on a button (Inherited from ToolBar)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | RefreshItems | Occurs when the state of the navigational user interface (UI) needs to be refreshed to reflect the current state of the underlying data.
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

BindingNavigator Class
Gizmox.WebGUI.Forms Namespace


RefreshItems Event

[image]
Gizmox.WebGUI.Forms
RefreshItems Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingNavigator Class : RefreshItems Event

Occurs when the state of the navigational user interface (UI) needs to be refreshed to reflect the current state of the underlying data.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Behavior")>
<SRDescriptionAttribute("Event raised when BindingNavigator ToolStrip items need to be refreshed to reflect current state of data.")>
Public Event RefreshItems() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As BindingNavigator
Dim handler As EventHandler

AddHandler instance.RefreshItems, handler
C#
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Event raised when BindingNavigator ToolStrip items need to be refreshed to reflect current state of data.")]
public event EventHandler RefreshItems()
Managed Extensions for C++
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Event raised when BindingNavigator ToolStrip items need to be refreshed to reflect current state of data.")]
public: __event EventHandler* RefreshItems
C++/CLI
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Event raised when BindingNavigator ToolStrip items need to be refreshed to reflect current state of data.")]
public:
event EventHandler^ RefreshItems

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingNavigator Class
BindingNavigator Members


BindingsCollection Class

[image]
Gizmox.WebGUI.Forms
BindingsCollection Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : BindingsCollection Class

Represents a collection of Binding objects for a control.

Object Model

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
<DefaultEventAttribute("CollectionChanged")>
Public Class BindingsCollection
   Inherits BaseCollection
Visual Basic (Usage) Copy Code
Dim instance As BindingsCollection
C#
[DefaultMemberAttribute("Item")]
[DefaultEventAttribute("CollectionChanged")]
public class BindingsCollection : BaseCollection
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
[DefaultEventAttribute("CollectionChanged")]
public __gc class BindingsCollection : public BaseCollection
C++/CLI
[DefaultMemberAttribute("Item")]
[DefaultEventAttribute("CollectionChanged")]
public ref class BindingsCollection : public BaseCollection

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.BaseCollection
Gizmox.WebGUI.Forms.BindingsCollection
Gizmox.WebGUI.Forms.ControlBindingsCollection

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

BindingsCollection Members
Gizmox.WebGUI.Forms Namespace


BindingsCollection Class Members

[image]
Gizmox.WebGUI.Forms
BindingsCollection Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : BindingsCollection Class

The following tables list the members exposed by BindingsCollection.

Public Properties

 | Name | Description
Public Property | Count | Overridden. Gets the total number of bindings in the collection.
Public Property | IsReadOnly | Gets a value indicating whether the collection is read-only. (Inherited from BaseCollection)
Public Property | IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized. (Inherited from BaseCollection)
Public Property | Item | Gets the Binding at the specified index.
Public Property | SyncRoot | Gets an object that can be used to synchronize access to the BaseCollection. (Inherited from BaseCollection)
Top

Protected Properties

 | Name | Description
Protected Property | List | Overridden. Gets the bindings in the collection as an object.
Top

Public Methods

 | Name | Description
Public Method | CopyTo | Copies all the elements of the current one-dimensional Array to the specified one-dimensional Array starting at the specified destination Array index. (Inherited from BaseCollection)
Public Method | GetEnumerator | Gets the object that enables iterating through the members of the collection. (Inherited from BaseCollection)
Top

Protected Methods

 | Name | Description
Protected Method | Add | Adds the specified binding to the collection.
Protected Method | AddCore | Adds a Binding to the collection.
Protected Method | Clear | Clears the collection of binding objects.
Protected Method | ClearCore | Clears the collection of any members.
Protected Method | OnCollectionChanged | Raises the CollectionChanged event.
Protected Method | OnCollectionChanging | Raises the CollectionChanging event.
Protected Method | Remove | Deletes the specified binding from the collection.
Protected Method | RemoveAt | Deletes the binding from the collection at the specified index.
Protected Method | RemoveCore | Removes the specified Binding from the collection.
Protected Method | ShouldSerializeMyAll | Gets a value that indicates whether the collection should be serialized.
Top

Public Events

 | Name | Description
Public Event | CollectionChanged | Occurs when the collection has changed.
Public Event | CollectionChanging | Occurs when the collection is about to change.
Top

See Also

Reference

BindingsCollection Class
Gizmox.WebGUI.Forms Namespace


BindingsCollection Class Methods

[image]
Gizmox.WebGUI.Forms
BindingsCollection Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : BindingsCollection Class

For a list of all members of this type, see BindingsCollection members.

Public Methods

 | Name | Description
Public Method | CopyTo | Copies all the elements of the current one-dimensional Array to the specified one-dimensional Array starting at the specified destination Array index. (Inherited from BaseCollection)
Public Method | GetEnumerator | Gets the object that enables iterating through the members of the collection. (Inherited from BaseCollection)
Top

Protected Methods

 | Name | Description
Protected Method | Add | Adds the specified binding to the collection.
Protected Method | AddCore | Adds a Binding to the collection.
Protected Method | Clear | Clears the collection of binding objects.
Protected Method | ClearCore | Clears the collection of any members.
Protected Method | OnCollectionChanged | Raises the CollectionChanged event.
Protected Method | OnCollectionChanging | Raises the CollectionChanging event.
Protected Method | Remove | Deletes the specified binding from the collection.
Protected Method | RemoveAt | Deletes the binding from the collection at the specified index.
Protected Method | RemoveCore | Removes the specified Binding from the collection.
Protected Method | ShouldSerializeMyAll | Gets a value that indicates whether the collection should be serialized.
Top

See Also

Reference

BindingsCollection Class
Gizmox.WebGUI.Forms Namespace


Add Method

[image]
Gizmox.WebGUI.Forms
Add Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingsCollection Class : Add Method

binding
The Binding to add to the collection.
Adds the specified binding to the collection.

Syntax

Visual Basic (Declaration)
Protected Sub Add( _
   ByVal binding As Binding _
)
Visual Basic (Usage) Copy Code
Dim instance As BindingsCollection
Dim binding As Binding

instance.Add(binding)
C#
protected void Add(
   Binding binding
)
Managed Extensions for C++
protected: void Add(
   Binding* binding
)
C++/CLI
protected:
void Add(
   Binding^ binding
)

Parameters

binding
The Binding to add to the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingsCollection Class
BindingsCollection Members


AddCore Method

[image]
Gizmox.WebGUI.Forms
AddCore Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingsCollection Class : AddCore Method

dataBinding
The Binding to add to the collection.
Adds a Binding to the collection.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub AddCore( _
   ByVal dataBinding As Binding _
)
Visual Basic (Usage) Copy Code
Dim instance As BindingsCollection
Dim dataBinding As Binding

instance.AddCore(dataBinding)
C#
protected virtual void AddCore(
   Binding dataBinding
)
Managed Extensions for C++
protected: virtual void AddCore(
   Binding* dataBinding
)
C++/CLI
protected:
virtual void AddCore(
   Binding^ dataBinding
)

Parameters

dataBinding
The Binding to add to the collection.

Exceptions

Exception | Description
ArgumentNullException | The dataBinding argument was null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingsCollection Class
BindingsCollection Members


Clear Method

[image]
Gizmox.WebGUI.Forms
Clear Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingsCollection Class : Clear Method

Clears the collection of binding objects.

Syntax

Visual Basic (Declaration)
Protected Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As BindingsCollection

instance.Clear()
C#
protected void Clear()
Managed Extensions for C++
protected: void Clear();
C++/CLI
protected:
void Clear();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingsCollection Class
BindingsCollection Members


ClearCore Method

[image]
Gizmox.WebGUI.Forms
ClearCore Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingsCollection Class : ClearCore Method

Clears the collection of any members.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ClearCore()
Visual Basic (Usage) Copy Code
Dim instance As BindingsCollection

instance.ClearCore()
C#
protected virtual void ClearCore()
Managed Extensions for C++
protected: virtual void ClearCore();
C++/CLI
protected:
virtual void ClearCore();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingsCollection Class
BindingsCollection Members


OnCollectionChanged Method

[image]
Gizmox.WebGUI.Forms
OnCollectionChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingsCollection Class : OnCollectionChanged Method

ccevent
A CollectionChangeEventArgs that contains the event data.
Raises the CollectionChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnCollectionChanged( _
   ByVal ccevent As CollectionChangeEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As BindingsCollection
Dim ccevent As CollectionChangeEventArgs

instance.OnCollectionChanged(ccevent)
C#
protected virtual void OnCollectionChanged(
   CollectionChangeEventArgs ccevent
)
Managed Extensions for C++
protected: virtual void OnCollectionChanged(
   CollectionChangeEventArgs* ccevent
)
C++/CLI
protected:
virtual void OnCollectionChanged(
   CollectionChangeEventArgs^ ccevent
)

Parameters

ccevent
A CollectionChangeEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingsCollection Class
BindingsCollection Members


OnCollectionChanging Method

[image]
Gizmox.WebGUI.Forms
OnCollectionChanging Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingsCollection Class : OnCollectionChanging Method

e
A CollectionChangeEventArgs that contains event data.
Raises the CollectionChanging event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnCollectionChanging( _
   ByVal e As CollectionChangeEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As BindingsCollection
Dim e As CollectionChangeEventArgs

instance.OnCollectionChanging(e)
C#
protected virtual void OnCollectionChanging(
   CollectionChangeEventArgs e
)
Managed Extensions for C++
protected: virtual void OnCollectionChanging(
   CollectionChangeEventArgs* e
)
C++/CLI
protected:
virtual void OnCollectionChanging(
   CollectionChangeEventArgs^ e
)

Parameters

e
A CollectionChangeEventArgs that contains event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingsCollection Class
BindingsCollection Members


Remove Method

[image]
Gizmox.WebGUI.Forms
Remove Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingsCollection Class : Remove Method

binding
The Binding to remove from the collection.
Deletes the specified binding from the collection.

Syntax

Visual Basic (Declaration)
Protected Sub Remove( _
   ByVal binding As Binding _
)
Visual Basic (Usage) Copy Code
Dim instance As BindingsCollection
Dim binding As Binding

instance.Remove(binding)
C#
protected void Remove(
   Binding binding
)
Managed Extensions for C++
protected: void Remove(
   Binding* binding
)
C++/CLI
protected:
void Remove(
   Binding^ binding
)

Parameters

binding
The Binding to remove from the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingsCollection Class
BindingsCollection Members


RemoveAt Method

[image]
Gizmox.WebGUI.Forms
RemoveAt Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingsCollection Class : RemoveAt Method

index
The index of the Binding to remove.
Deletes the binding from the collection at the specified index.

Syntax

Visual Basic (Declaration)
Protected Sub RemoveAt( _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As BindingsCollection
Dim index As Integer

instance.RemoveAt(index)
C#
protected void RemoveAt(
   int index
)
Managed Extensions for C++
protected: void RemoveAt(
   int index
)
C++/CLI
protected:
void RemoveAt(
   int index
)

Parameters

index
The index of the Binding to remove.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingsCollection Class
BindingsCollection Members


RemoveCore Method

[image]
Gizmox.WebGUI.Forms
RemoveCore Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingsCollection Class : RemoveCore Method

dataBinding
The Binding to remove.
Removes the specified Binding from the collection.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub RemoveCore( _
   ByVal dataBinding As Binding _
)
Visual Basic (Usage) Copy Code
Dim instance As BindingsCollection
Dim dataBinding As Binding

instance.RemoveCore(dataBinding)
C#
protected virtual void RemoveCore(
   Binding dataBinding
)
Managed Extensions for C++
protected: virtual void RemoveCore(
   Binding* dataBinding
)
C++/CLI
protected:
virtual void RemoveCore(
   Binding^ dataBinding
)

Parameters

dataBinding
The Binding to remove.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingsCollection Class
BindingsCollection Members


ShouldSerializeMyAll Method

[image]
Gizmox.WebGUI.Forms
ShouldSerializeMyAll Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingsCollection Class : ShouldSerializeMyAll Method

Gets a value that indicates whether the collection should be serialized.

Syntax

Visual Basic (Declaration)
Protected Function ShouldSerializeMyAll() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BindingsCollection
Dim value As Boolean

value = instance.ShouldSerializeMyAll()
C#
protected bool ShouldSerializeMyAll()
Managed Extensions for C++
protected: bool ShouldSerializeMyAll();
C++/CLI
protected:
bool ShouldSerializeMyAll();

Return Value

true if the collection count is greater than zero; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingsCollection Class
BindingsCollection Members


BindingsCollection Class Properties

[image]
Gizmox.WebGUI.Forms
BindingsCollection Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : BindingsCollection Class

For a list of all members of this type, see BindingsCollection members.

Public Properties

 | Name | Description
Public Property | Count | Overridden. Gets the total number of bindings in the collection.
Public Property | IsReadOnly | Gets a value indicating whether the collection is read-only. (Inherited from BaseCollection)
Public Property | IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized. (Inherited from BaseCollection)
Public Property | Item | Gets the Binding at the specified index.
Public Property | SyncRoot | Gets an object that can be used to synchronize access to the BaseCollection. (Inherited from BaseCollection)
Top

Protected Properties

 | Name | Description
Protected Property | List | Overridden. Gets the bindings in the collection as an object.
Top

See Also

Reference

BindingsCollection Class
Gizmox.WebGUI.Forms Namespace


Count Property

[image]
Gizmox.WebGUI.Forms
Count Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingsCollection Class : Count Property

Gets the total number of bindings in the collection.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As BindingsCollection
Dim value As Integer

value = instance.Count
C#
public override int Count {get;}
Managed Extensions for C++
public: __property int get_Count() override;
C++/CLI
public:
property int Count {
   int get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingsCollection Class
BindingsCollection Members


Item Property

[image]
Gizmox.WebGUI.Forms
Item Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingsCollection Class : Item Property

index
The index of the Binding to find.
Gets the Binding at the specified index.

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal index As Integer _
) As Binding
Visual Basic (Usage) Copy Code
Dim instance As BindingsCollection
Dim index As Integer
Dim value As Binding

value = instance.Item(index)
C#
public Binding this[
   int index
]; {get;}
Managed Extensions for C++
public: __property Binding* get_Item(
   int index
);
C++/CLI
public:
property Binding^ default [int] {
   Binding^ get(intindex);
}

Parameters

index
The index of the Binding to find.

Exceptions

Exception | Description
IndexOutOfRangeException | The collection doesn't contain an item at the specified index.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingsCollection Class
BindingsCollection Members


List Property

[image]
Gizmox.WebGUI.Forms
List Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingsCollection Class : List Property

Gets the bindings in the collection as an object.

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property List As ArrayList
Visual Basic (Usage) Copy Code
Dim instance As BindingsCollection
Dim value As ArrayList

value = instance.List
C#
protected override ArrayList List {get;}
Managed Extensions for C++
protected: __property ArrayList* get_List() override;
C++/CLI
protected:
property ArrayList^ List {
   ArrayList^ get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingsCollection Class
BindingsCollection Members


BindingsCollection Class Events

[image]
Gizmox.WebGUI.Forms
BindingsCollection Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : BindingsCollection Class

For a list of all members of this type, see BindingsCollection members.

Public Events

 | Name | Description
Public Event | CollectionChanged | Occurs when the collection has changed.
Public Event | CollectionChanging | Occurs when the collection is about to change.
Top

See Also

Reference

BindingsCollection Class
Gizmox.WebGUI.Forms Namespace


CollectionChanged Event

[image]
Gizmox.WebGUI.Forms
CollectionChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingsCollection Class : CollectionChanged Event

Occurs when the collection has changed.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs whenever this collection's membership changes.")>
Public Event CollectionChanged() As CollectionChangeEventHandler
Visual Basic (Usage) Copy Code
Dim instance As BindingsCollection
Dim handler As CollectionChangeEventHandler

AddHandler instance.CollectionChanged, handler
C#
[SRDescriptionAttribute("Occurs whenever this collection's membership changes.")]
public event CollectionChangeEventHandler CollectionChanged()
Managed Extensions for C++
[SRDescriptionAttribute("Occurs whenever this collection's membership changes.")]
public: __event CollectionChangeEventHandler* CollectionChanged
C++/CLI
[SRDescriptionAttribute("Occurs whenever this collection's membership changes.")]
public:
event CollectionChangeEventHandler^ CollectionChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingsCollection Class
BindingsCollection Members


CollectionChanging Event

[image]
Gizmox.WebGUI.Forms
CollectionChanging Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingsCollection Class : CollectionChanging Event

Occurs when the collection is about to change.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs whenever this collection's membership is about to change.")>
Public Event CollectionChanging() As CollectionChangeEventHandler
Visual Basic (Usage) Copy Code
Dim instance As BindingsCollection
Dim handler As CollectionChangeEventHandler

AddHandler instance.CollectionChanging, handler
C#
[SRDescriptionAttribute("Occurs whenever this collection's membership is about to change.")]
public event CollectionChangeEventHandler CollectionChanging()
Managed Extensions for C++
[SRDescriptionAttribute("Occurs whenever this collection's membership is about to change.")]
public: __event CollectionChangeEventHandler* CollectionChanging
C++/CLI
[SRDescriptionAttribute("Occurs whenever this collection's membership is about to change.")]
public:
event CollectionChangeEventHandler^ CollectionChanging

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingsCollection Class
BindingsCollection Members


BindingSource Class

[image]
Gizmox.WebGUI.Forms
BindingSource Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : BindingSource Class

Encapsulates the data source for a form.

Syntax

Visual Basic (Declaration)
<DefaultPropertyAttribute("DataSource")>
<SRDescriptionAttribute("Encapsulates a data source for a form and provides navigation, filtering, sorting, and updating capabilities.")>
<ToolboxBitmapAttribute()>
<DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="Gizmox.WebGUI.Forms.Design.BindingSourceDesigner, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")>
<ToolboxItemFilterAttribute("Gizmox.WebGUI.Forms")>
<ToolboxItemCategoryAttribute("Data")>
<DefaultMemberAttribute("Item")>
<DefaultEventAttribute("CurrentChanged")>
<ComplexBindingPropertiesAttribute(DataSource="DataSource", DataMember="DataMember")>
Public Class BindingSource
   Inherits ComponentBase
   Implements ICurrencyManagerProvider
Visual Basic (Usage) Copy Code
Dim instance As BindingSource
C#
[DefaultPropertyAttribute("DataSource")]
[SRDescriptionAttribute("Encapsulates a data source for a form and provides navigation, filtering, sorting, and updating capabilities.")]
[ToolboxBitmapAttribute()]
[DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="Gizmox.WebGUI.Forms.Design.BindingSourceDesigner, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[ToolboxItemFilterAttribute("Gizmox.WebGUI.Forms")]
[ToolboxItemCategoryAttribute("Data")]
[DefaultMemberAttribute("Item")]
[DefaultEventAttribute("CurrentChanged")]
[ComplexBindingPropertiesAttribute(DataSource="DataSource", DataMember="DataMember")]
public class BindingSource : ComponentBase, ICurrencyManagerProvider
Managed Extensions for C++
[DefaultPropertyAttribute("DataSource")]
[SRDescriptionAttribute("Encapsulates a data source for a form and provides navigation, filtering, sorting, and updating capabilities.")]
[ToolboxBitmapAttribute()]
[DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="Gizmox.WebGUI.Forms.Design.BindingSourceDesigner, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[ToolboxItemFilterAttribute("Gizmox.WebGUI.Forms")]
[ToolboxItemCategoryAttribute("Data")]
[DefaultMemberAttribute("Item")]
[DefaultEventAttribute("CurrentChanged")]
[ComplexBindingPropertiesAttribute(DataSource="DataSource", DataMember="DataMember")]
public __gc class BindingSource : public ComponentBase, ICurrencyManagerProvider
C++/CLI
[DefaultPropertyAttribute("DataSource")]
[SRDescriptionAttribute("Encapsulates a data source for a form and provides navigation, filtering, sorting, and updating capabilities.")]
[ToolboxBitmapAttribute()]
[DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="Gizmox.WebGUI.Forms.Design.BindingSourceDesigner, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[ToolboxItemFilterAttribute("Gizmox.WebGUI.Forms")]
[ToolboxItemCategoryAttribute("Data")]
[DefaultMemberAttribute("Item")]
[DefaultEventAttribute("CurrentChanged")]
[ComplexBindingPropertiesAttribute(DataSource="DataSource", DataMember="DataMember")]
public ref class BindingSource : public ComponentBase, ICurrencyManagerProvider

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.BindingSource

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

BindingSource Members
Gizmox.WebGUI.Forms Namespace


BindingSource Class Members

[image]
Gizmox.WebGUI.Forms
BindingSource Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : BindingSource Class

The following tables list the members exposed by BindingSource.

Public Constructors

 | Name | Description
Public Constructor | BindingSource Constructor | Overloaded. Initializes a new instance of the BindingSource class to the default property values.
Top

Public Properties

 | Name | Description
Public Property | AllowEdit | Gets a value indicating whether items in the underlying list can be edited.
Public Property | AllowNew | Gets or sets a value indicating whether the AddNew method can be used to add items to the list.
Public Property | AllowRemove | Gets a value indicating whether items can be removed from the underlying list.
Public Property | Container | (Inherited from ComponentBase)
Public Property | Count | Gets the total number of items in the underlying list.
Public Property | CurrencyManager | Gets the currency manager associated with this BindingSource.
Public Property | Current | Gets the current item in the list.
Public Property | DataMember | Gets or sets the specific list in the data source to which the connector currently binds to.
Public Property | DataSource | Gets or sets the data source that the connector binds to.
Public Property | Filter | Gets or sets the expression used to filter which rows are viewed.
Public Property | IsBindingSuspended | Gets a value indicating whether the list binding is suspended.
Public Property | IsFixedSize | Gets a value indicating whether the underlying list has a fixed size.
Public Property | IsReadOnly | Gets a value indicating whether the underlying list is read-only.
Public Property | IsSorted | Gets a value indicating whether the items in the underlying list are sorted.
Public Property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe).
Public Property | Item | Gets or sets the list element at the specified index.
Public Property | List | Gets the list that the connector is bound to.
Public Property | Position | Gets or sets the index of the current item in the underlying list.
Public Property | RaiseListChangedEvents | Gets or sets a value indicating whether ListChanged events should be raised.
Public Property | Site | (Inherited from ComponentBase)
Public Property | Sort | Gets or sets the column names used for sorting, and the sort order for viewing the rows in the data source.
Public Property | SupportsAdvancedSorting | Gets a value indicating whether the data source supports multi-column sorting.
Public Property | SupportsChangeNotification | Gets a value indicating whether the data source supports change notification.
Public Property | SupportsFiltering | Gets a value indicating whether the data source supports filtering.
Public Property | SupportsSearching | Gets a value indicating whether the data source supports searching with the Find method.
Public Property | SupportsSorting | Gets a value indicating whether the data source supports sorting.
Public Property | SyncRoot | Gets an object that can be used to synchronize access to the underlying list.
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Top

Public Methods

 | Name | Description
Public Method | Add | Adds an existing item to the internal list.
Public Method | AddNew | Adds a new item to the underlying list.
Public Method | CancelEdit | Cancels the current edit operation.
Public Method | Clear | Removes all elements from the list.
Public Method | Contains | Determines whether an object is an item in the list.
Public Method | CopyTo | Copies the contents of the List to the specified array, starting at the specified index value.
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the BindingSource and optionally releases the managed resources.
Public Method | EndEdit | Applies pending changes to the underlying data source.
Public Method | Find | Overloaded. Searches for the index of the item that has the given property descriptor.
Public Method | GetEnumerator | Retrieves an enumerator for the List.
Public Method | GetItemProperties | Retrieves an array of PropertyDescriptor objects representing the bindable properties of the data source list type.
Public Method | GetListName | Gets the name of the list supplying data for the binding.
Public Method | GetRelatedCurrencyManager | Gets the related currency manager for the specified data member.
Public Method | IndexOf | Searches for the specified object and returns the index of the first occurrence within the entire list.
Public Method | Insert | Inserts an item into the list at the specified index.
Public Method | MoveFirst | Moves to the first item in the list.
Public Method | MoveLast | Moves to the last item in the list.
Public Method | MoveNext | Moves to the next item in the list.
Public Method | MovePrevious | Moves to the previous item in the list.
Public Method | Remove | Removes the specified item from the list.
Public Method | RemoveAt | Removes the item at the specified index in the list.
Public Method | RemoveCurrent | Removes the current item from the list.
Public Method | RemoveFilter | Removes the filter associated with the BindingSource.
Public Method | RemoveSort | Removes the sort associated with the BindingSource.
Public Method | ResetAllowNew | Reinitializes the AllowNew property.
Public Method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values.
Public Method | ResetCurrentItem | Causes a control bound to the BindingSource to reread the currently selected item and refresh its displayed value.
Public Method | ResetItem | Causes a control bound to the BindingSource to reread the item at the specified index, and refresh its displayed value.
Public Method | ResumeBinding | Resumes data binding.
Public Method | SuspendBinding | Suspends data binding to prevent changes from updating the bound data source.
Public Method | ToString | (Inherited from ComponentBase)
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | OnBindingComplete | Raises the BindingComplete event.
Protected Method | OnCurrentChanged |
Protected Method | OnCurrentItemChanged | Raises the CurrentItemChanged event.
Protected Method | OnDataError | Raises the DataError event.
Protected Method | OnDataMemberChanged | Raises the DataMemberChanged event.
Protected Method | OnDataSourceChanged | Raises the DataSourceChanged event.
Protected Method | OnListChanged | Raises the ListChanged event.
Protected Method | OnPositionChanged | Raises the PositionChanged event.
Top

Public Events

 | Name | Description
Public Event | AddingNew | Occurs before an item is added to the underlying list.
Public Event | BindingComplete | Occurs when all the clients have been bound to this BindingSource.
Public Event | CurrentChanged | Occurs when the currently bound item changes.
Public Event | CurrentItemChanged | Occurs when a property value of the Current property has changed.
Public Event | DataError | Occurs when a currency-related exception is silently handled by the BindingSource.
Public Event | DataMemberChanged | Occurs when the DataMember property value has changed.
Public Event | DataSourceChanged | Occurs when the DataSource property value has changed.
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | ListChanged | Occurs when the underlying list changes or an item in the list changes.
Public Event | PositionChanged | Occurs after the value of the Position property has changed.
Top

See Also

Reference

BindingSource Class
Gizmox.WebGUI.Forms Namespace


BindingSource Constructor

[image]
Gizmox.WebGUI.Forms
BindingSource Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingSource Class : BindingSource Constructor

Initializes a new instance of the BindingSource class to the default property values.

Overload List

Overload | Description
BindingSource Constructor() | Initializes a new instance of the BindingSource class to the default property values.
BindingSource Constructor(IContainer) | Initializes a new instance of the BindingSource class and adds the BindingSource to the specified container.
BindingSource Constructor(Object,String) | Initializes a new instance of the BindingSource class with the specified data source and data member.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingSource Class
BindingSource Members


BindingSource Constructor()

[image]
Gizmox.WebGUI.Forms
BindingSource Constructor()
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingSource Class > BindingSource Constructor : BindingSource Constructor()

Initializes a new instance of the BindingSource class to the default property values.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As BindingSource()
C#
public BindingSource()
Managed Extensions for C++
public: BindingSource();
C++/CLI
public:
BindingSource();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingSource Class
BindingSource Members
Overload List


BindingSource Constructor(IContainer)

[image]
Gizmox.WebGUI.Forms
BindingSource Constructor(IContainer)
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingSource Class > BindingSource Constructor : BindingSource Constructor(IContainer)

container
The IContainer to add the current BindingSource to.
Initializes a new instance of the BindingSource class and adds the BindingSource to the specified container.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal container As IContainer _
)
Visual Basic (Usage) Copy Code
Dim container As IContainer

Dim instance As BindingSource(container)
C#
public BindingSource(
   IContainer container
)
Managed Extensions for C++
public: BindingSource(
   IContainer* container
)
C++/CLI
public:
BindingSource(
   IContainer^ container
)

Parameters

container
The IContainer to add the current BindingSource to.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingSource Class
BindingSource Members
Overload List


BindingSource Constructor(Object,String)

[image]
Gizmox.WebGUI.Forms
BindingSource Constructor(Object,String)
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingSource Class > BindingSource Constructor : BindingSource Constructor(Object,String)

dataSource
The data source for the BindingSource.
dataMember
The specific column or list name within the data source to bind to.
Initializes a new instance of the BindingSource class with the specified data source and data member.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal dataSource As Object, _
   ByVal dataMember As String _
)
Visual Basic (Usage) Copy Code
Dim dataSource As Object
Dim dataMember As String

Dim instance As BindingSource(dataSource, dataMember)
C#
public BindingSource(
   object dataSource,
   string dataMember
)
Managed Extensions for C++
public: BindingSource(
   Object* dataSource,
   string* dataMember
)
C++/CLI
public:
BindingSource(
   Object^ dataSource,
   String^ dataMember
)

Parameters

dataSource
The data source for the BindingSource.
dataMember
The specific column or list name within the data source to bind to.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingSource Class
BindingSource Members
Overload List


BindingSource Class Methods

[image]
Gizmox.WebGUI.Forms
BindingSource Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : BindingSource Class

For a list of all members of this type, see BindingSource members.

Public Methods

 | Name | Description
Public Method | Add | Adds an existing item to the internal list.
Public Method | AddNew | Adds a new item to the underlying list.
Public Method | CancelEdit | Cancels the current edit operation.
Public Method | Clear | Removes all elements from the list.
Public Method | Contains | Determines whether an object is an item in the list.
Public Method | CopyTo | Copies the contents of the List to the specified array, starting at the specified index value.
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the BindingSource and optionally releases the managed resources.
Public Method | EndEdit | Applies pending changes to the underlying data source.
Public Method | Find | Overloaded. Searches for the index of the item that has the given property descriptor.
Public Method | GetEnumerator | Retrieves an enumerator for the List.
Public Method | GetItemProperties | Retrieves an array of PropertyDescriptor objects representing the bindable properties of the data source list type.
Public Method | GetListName | Gets the name of the list supplying data for the binding.
Public Method | GetRelatedCurrencyManager | Gets the related currency manager for the specified data member.
Public Method | IndexOf | Searches for the specified object and returns the index of the first occurrence within the entire list.
Public Method | Insert | Inserts an item into the list at the specified index.
Public Method | MoveFirst | Moves to the first item in the list.
Public Method | MoveLast | Moves to the last item in the list.
Public Method | MoveNext | Moves to the next item in the list.
Public Method | MovePrevious | Moves to the previous item in the list.
Public Method | Remove | Removes the specified item from the list.
Public Method | RemoveAt | Removes the item at the specified index in the list.
Public Method | RemoveCurrent | Removes the current item from the list.
Public Method | RemoveFilter | Removes the filter associated with the BindingSource.
Public Method | RemoveSort | Removes the sort associated with the BindingSource.
Public Method | ResetAllowNew | Reinitializes the AllowNew property.
Public Method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values.
Public Method | ResetCurrentItem | Causes a control bound to the BindingSource to reread the currently selected item and refresh its displayed value.
Public Method | ResetItem | Causes a control bound to the BindingSource to reread the item at the specified index, and refresh its displayed value.
Public Method | ResumeBinding | Resumes data binding.
Public Method | SuspendBinding | Suspends data binding to prevent changes from updating the bound data source.
Public Method | ToString | (Inherited from ComponentBase)
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | OnBindingComplete | Raises the BindingComplete event.
Protected Method | OnCurrentChanged |
Protected Method | OnCurrentItemChanged | Raises the CurrentItemChanged event.
Protected Method | OnDataError | Raises the DataError event.
Protected Method | OnDataMemberChanged | Raises the DataMemberChanged event.
Protected Method | OnDataSourceChanged | Raises the DataSourceChanged event.
Protected Method | OnListChanged | Raises the ListChanged event.
Protected Method | OnPositionChanged | Raises the PositionChanged event.
Top

See Also

Reference

BindingSource Class
Gizmox.WebGUI.Forms Namespace


Add Method

[image]
Gizmox.WebGUI.Forms
Add Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingSource Class : Add Method

value
An Object to be added to the internal list.
Adds an existing item to the internal list.

Syntax

Visual Basic (Declaration)
Public Overridable Function Add( _
   ByVal value As Object _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As BindingSource
Dim value As Object
Dim value As Integer

value = instance.Add(value)
C#
public virtual int Add(
   object value
)
Managed Extensions for C++
public: virtual int Add(
   Object* value
)
C++/CLI
public:
virtual int Add(
   Object^ value
)

Parameters

value
An Object to be added to the internal list.

Return Value

The zero-based index at which value was added to the underlying list represented by the List property.

Exceptions

Exception | Description
InvalidOperationException | value differs in type from the existing items in the underlying list.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingSource Class
BindingSource Members


AddNew Method

[image]
Gizmox.WebGUI.Forms
AddNew Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingSource Class : AddNew Method

Adds a new item to the underlying list.

Syntax

Visual Basic (Declaration)
Public Overridable Function AddNew() As Object
Visual Basic (Usage) Copy Code
Dim instance As BindingSource
Dim value As Object

value = instance.AddNew()
C#
public virtual object AddNew()
Managed Extensions for C++
public: virtual Object* AddNew();
C++/CLI
public:
virtual Object^ AddNew();

Return Value

The Object that was created and added to the list.

Exceptions

Exception | Description
InvalidOperationException | The AllowNew property is set to false. -or-A public default constructor could not be found for the current item type.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingSource Class
BindingSource Members


CancelEdit Method

[image]
Gizmox.WebGUI.Forms
CancelEdit Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingSource Class : CancelEdit Method

Cancels the current edit operation.

Syntax

Visual Basic (Declaration)
Public Sub CancelEdit()
Visual Basic (Usage) Copy Code
Dim instance As BindingSource

instance.CancelEdit()
C#
public void CancelEdit()
Managed Extensions for C++
public: void CancelEdit();
C++/CLI
public:
void CancelEdit();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingSource Class
BindingSource Members


Clear Method

[image]
Gizmox.WebGUI.Forms
Clear Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingSource Class : Clear Method

Removes all elements from the list.

Syntax

Visual Basic (Declaration)
Public Overridable Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As BindingSource

instance.Clear()
C#
public virtual void Clear()
Managed Extensions for C++
public: virtual void Clear();
C++/CLI
public:
virtual void Clear();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingSource Class
BindingSource Members


Contains Method

[image]
Gizmox.WebGUI.Forms
Contains Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingSource Class : Contains Method

value
The Object to locate in the underlying list represented by the List property. The value can be null.
Determines whether an object is an item in the list.

Syntax

Visual Basic (Declaration)
Public Overridable Function Contains( _
   ByVal value As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BindingSource
Dim value As Object
Dim value As Boolean

value = instance.Contains(value)
C#
public virtual bool Contains(
   object value
)
Managed Extensions for C++
public: virtual bool Contains(
   Object* value
)
C++/CLI
public:
virtual bool Contains(
   Object^ value
)

Parameters

value
The Object to locate in the underlying list represented by the List property. The value can be null.

Return Value

true if the value parameter is found in the List; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingSource Class
BindingSource Members


CopyTo Method

[image]
Gizmox.WebGUI.Forms
CopyTo Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingSource Class : CopyTo Method

arr
The destination array.
index
The index in the destination array at which to start the copy operation.
Copies the contents of the List to the specified array, starting at the specified index value.

Syntax

Visual Basic (Declaration)
Public Overridable Sub CopyTo( _
   ByVal arr As Array, _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As BindingSource
Dim arr As Array
Dim index As Integer

instance.CopyTo(arr, index)
C#
public virtual void CopyTo(
   Array arr,
   int index
)
Managed Extensions for C++
public: virtual void CopyTo(
   Array* arr,
   int index
)
C++/CLI
public:
virtual void CopyTo(
   Array^ arr,
   int index
)

Parameters

arr
The destination array.
index
The index in the destination array at which to start the copy operation.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingSource Class
BindingSource Members


Dispose Method

[image]
Gizmox.WebGUI.Forms
Dispose Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingSource Class : Dispose Method

Releases the unmanaged resources used by the BindingSource and optionally releases the managed resources.

Overload List

Overload | Description
Dispose(Boolean) | Releases the unmanaged resources used by the BindingSource and optionally releases the managed resources.
Dispose() | (Inherited from ComponentBase)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingSource Class
BindingSource Members


Dispose(Boolean) Method

[image]
Gizmox.WebGUI.Forms
Dispose(Boolean) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingSource Class > Dispose Method : Dispose(Boolean) Method

disposing
true to release both managed and unmanaged resources; false to release only unmanaged resources.
Releases the unmanaged resources used by the BindingSource and optionally releases the managed resources.

Syntax

Visual Basic (Declaration)
Protected Overloads Overridable Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As BindingSource
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected virtual void Dispose(
   bool disposing
)
Managed Extensions for C++
protected: virtual void Dispose(
   bool disposing
)
C++/CLI
protected:
virtual void Dispose(
   bool disposing
)

Parameters

disposing
true to release both managed and unmanaged resources; false to release only unmanaged resources.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingSource Class
BindingSource Members
Overload List


EndEdit Method

[image]
Gizmox.WebGUI.Forms
EndEdit Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingSource Class : EndEdit Method

Applies pending changes to the underlying data source.

Syntax

Visual Basic (Declaration)
Public Sub EndEdit()
Visual Basic (Usage) Copy Code
Dim instance As BindingSource

instance.EndEdit()
C#
public void EndEdit()
Managed Extensions for C++
public: void EndEdit();
C++/CLI
public:
void EndEdit();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingSource Class
BindingSource Members


Find Method

[image]
Gizmox.WebGUI.Forms
Find Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingSource Class : Find Method

Searches for the index of the item that has the given property descriptor.

Overload List

Overload | Description
Find(PropertyDescriptor,Object) | Searches for the index of the item that has the given property descriptor.
Find(String,Object) | Returns the index of the item in the list with the specified property name and value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingSource Class
BindingSource Members


Find(PropertyDescriptor,Object) Method

[image]
Gizmox.WebGUI.Forms
Find(PropertyDescriptor,Object) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingSource Class > Find Method : Find(PropertyDescriptor,Object) Method

prop
The PropertyDescriptor to search for.
key
The value of prop to match.
Searches for the index of the item that has the given property descriptor.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function Find( _
   ByVal prop As PropertyDescriptor, _
   ByVal key As Object _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As BindingSource
Dim prop As PropertyDescriptor
Dim key As Object
Dim value As Integer

value = instance.Find(prop, key)
C#
public virtual int Find(
   PropertyDescriptor prop,
   object key
)
Managed Extensions for C++
public: virtual int Find(
   PropertyDescriptor* prop,
   Object* key
)
C++/CLI
public:
virtual int Find(
   PropertyDescriptor^ prop,
   Object^ key
)

Parameters

prop
The PropertyDescriptor to search for.
key
The value of prop to match.

Return Value

The zero-based index of the item that has the given value for PropertyDescriptor.

Exceptions

Exception | Description
NotSupportedException | The underlying list is not of type IBindingList.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingSource Class
BindingSource Members
Overload List


Find(String,Object) Method

[image]
Gizmox.WebGUI.Forms
Find(String,Object) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingSource Class > Find Method : Find(String,Object) Method

propertyName
The name of the property to search for.
key
The value of the item with the specified propertyName to find.
Returns the index of the item in the list with the specified property name and value.

Syntax

Visual Basic (Declaration)
Public Overloads Function Find( _
   ByVal propertyName As String, _
   ByVal key As Object _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As BindingSource
Dim propertyName As String
Dim key As Object
Dim value As Integer

value = instance.Find(propertyName, key)
C#
public int Find(
   string propertyName,
   object key
)
Managed Extensions for C++
public: int Find(
   string* propertyName,
   Object* key
)
C++/CLI
public:
int Find(
   String^ propertyName,
   Object^ key
)

Parameters

propertyName
The name of the property to search for.
key
The value of the item with the specified propertyName to find.

Return Value

The zero-based index of the item with the specified property name and value.

Exceptions

Exception | Description
ArgumentException | propertyName does not match a property in the list.
InvalidOperationException | The underlying list is not a IBindingList with searching functionality implemented.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingSource Class
BindingSource Members
Overload List


GetEnumerator Method

[image]
Gizmox.WebGUI.Forms
GetEnumerator Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingSource Class : GetEnumerator Method

Retrieves an enumerator for the List.

Syntax

Visual Basic (Declaration)
Public Overridable Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As BindingSource
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public virtual IEnumerator GetEnumerator()
Managed Extensions for C++
public: virtual IEnumerator* GetEnumerator();
C++/CLI
public:
virtual IEnumerator^ GetEnumerator();

Return Value

An IEnumerator for the List.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingSource Class
BindingSource Members


GetItemProperties Method

[image]
Gizmox.WebGUI.Forms
GetItemProperties Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingSource Class : GetItemProperties Method

listAccessors
An array of PropertyDescriptor objects to find in the list as bindable.
Retrieves an array of PropertyDescriptor objects representing the bindable properties of the data source list type.

Syntax

Visual Basic (Declaration)
Public Overridable Function GetItemProperties( _
   ByVal listAccessors() As PropertyDescriptor _
) As PropertyDescriptorCollection
Visual Basic (Usage) Copy Code
Dim instance As BindingSource
Dim listAccessors() As PropertyDescriptor
Dim value As PropertyDescriptorCollection

value = instance.GetItemProperties(listAccessors)
C#
public virtual PropertyDescriptorCollection GetItemProperties(
   PropertyDescriptor[] listAccessors
)
Managed Extensions for C++
public: virtual PropertyDescriptorCollection* GetItemProperties(
   PropertyDescriptor*[]* listAccessors
)
C++/CLI
public:
virtual PropertyDescriptorCollection^ GetItemProperties(
   array<PropertyDescriptor^>^ listAccessors
)

Parameters

listAccessors
An array of PropertyDescriptor objects to find in the list as bindable.

Return Value

An array of PropertyDescriptor objects that represents the properties on this list type used to bind data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingSource Class
BindingSource Members


GetListName Method

[image]
Gizmox.WebGUI.Forms
GetListName Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingSource Class : GetListName Method

listAccessors
An array of PropertyDescriptor objects to find in the list as bindable.
Gets the name of the list supplying data for the binding.

Syntax

Visual Basic (Declaration)
Public Overridable Function GetListName( _
   ByVal listAccessors() As PropertyDescriptor _
) As String
Visual Basic (Usage) Copy Code
Dim instance As BindingSource
Dim listAccessors() As PropertyDescriptor
Dim value As String

value = instance.GetListName(listAccessors)
C#
public virtual string GetListName(
   PropertyDescriptor[] listAccessors
)
Managed Extensions for C++
public: virtual string* GetListName(
   PropertyDescriptor*[]* listAccessors
)
C++/CLI
public:
virtual String^ GetListName(
   array<PropertyDescriptor^>^ listAccessors
)

Parameters

listAccessors
An array of PropertyDescriptor objects to find in the list as bindable.

Return Value

The name of the list supplying the data for binding.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingSource Class
BindingSource Members


GetRelatedCurrencyManager Method

[image]
Gizmox.WebGUI.Forms
GetRelatedCurrencyManager Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingSource Class : GetRelatedCurrencyManager Method

dataMember
The name of column or list, within the data source to retrieve the currency manager for.
Gets the related currency manager for the specified data member.

Syntax

Visual Basic (Declaration)
Public Overridable Function GetRelatedCurrencyManager( _
   ByVal dataMember As String _
) As CurrencyManager
Visual Basic (Usage) Copy Code
Dim instance As BindingSource
Dim dataMember As String
Dim value As CurrencyManager

value = instance.GetRelatedCurrencyManager(dataMember)
C#
public virtual CurrencyManager GetRelatedCurrencyManager(
   string dataMember
)
Managed Extensions for C++
public: virtual CurrencyManager* GetRelatedCurrencyManager(
   string* dataMember
)
C++/CLI
public:
virtual CurrencyManager^ GetRelatedCurrencyManager(
   String^ dataMember
)

Parameters

dataMember
The name of column or list, within the data source to retrieve the currency manager for.

Return Value

The related CurrencyManager for the specified data member.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingSource Class
BindingSource Members


IndexOf Method

[image]
Gizmox.WebGUI.Forms
IndexOf Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingSource Class : IndexOf Method

value
The Object to locate in the underlying list represented by the List property. The value can be null.
Searches for the specified object and returns the index of the first occurrence within the entire list.

Syntax

Visual Basic (Declaration)
Public Overridable Function IndexOf( _
   ByVal value As Object _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As BindingSource
Dim value As Object
Dim value As Integer

value = instance.IndexOf(value)
C#
public virtual int IndexOf(
   object value
)
Managed Extensions for C++
public: virtual int IndexOf(
   Object* value
)
C++/CLI
public:
virtual int IndexOf(
   Object^ value
)

Parameters

value
The Object to locate in the underlying list represented by the List property. The value can be null.

Return Value

The zero-based index of the first occurrence of the value parameter; otherwise, -1 if value is not in the list.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingSource Class
BindingSource Members


Insert Method

[image]
Gizmox.WebGUI.Forms
Insert Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingSource Class : Insert Method

index
The zero-based index at which value should be inserted.
value
The Object to insert. The value can be null.
Inserts an item into the list at the specified index.

Syntax

Visual Basic (Declaration)
Public Overridable Sub Insert( _
   ByVal index As Integer, _
   ByVal value As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As BindingSource
Dim index As Integer
Dim value As Object

instance.Insert(index, value)
C#
public virtual void Insert(
   int index,
   object value
)
Managed Extensions for C++
public: virtual void Insert(
   int index,
   Object* value
)
C++/CLI
public:
virtual void Insert(
   int index,
   Object^ value
)

Parameters

index
The zero-based index at which value should be inserted.
value
The Object to insert. The value can be null.

Exceptions

Exception | Description
NotSupportedException | The list is read-only or has a fixed size.
ArgumentOutOfRangeException | index is less than zero or greater than Count.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingSource Class
BindingSource Members


MoveFirst Method

[image]
Gizmox.WebGUI.Forms
MoveFirst Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingSource Class : MoveFirst Method

Moves to the first item in the list.

Syntax

Visual Basic (Declaration)
Public Sub MoveFirst()
Visual Basic (Usage) Copy Code
Dim instance As BindingSource

instance.MoveFirst()
C#
public void MoveFirst()
Managed Extensions for C++
public: void MoveFirst();
C++/CLI
public:
void MoveFirst();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingSource Class
BindingSource Members


MoveLast Method

[image]
Gizmox.WebGUI.Forms
MoveLast Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingSource Class : MoveLast Method

Moves to the last item in the list.

Syntax

Visual Basic (Declaration)
Public Sub MoveLast()
Visual Basic (Usage) Copy Code
Dim instance As BindingSource

instance.MoveLast()
C#
public void MoveLast()
Managed Extensions for C++
public: void MoveLast();
C++/CLI
public:
void MoveLast();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingSource Class
BindingSource Members


MoveNext Method

[image]
Gizmox.WebGUI.Forms
MoveNext Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingSource Class : MoveNext Method

Moves to the next item in the list.

Syntax

Visual Basic (Declaration)
Public Sub MoveNext()
Visual Basic (Usage) Copy Code
Dim instance As BindingSource

instance.MoveNext()
C#
public void MoveNext()
Managed Extensions for C++
public: void MoveNext();
C++/CLI
public:
void MoveNext();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingSource Class
BindingSource Members


MovePrevious Method

[image]
Gizmox.WebGUI.Forms
MovePrevious Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingSource Class : MovePrevious Method

Moves to the previous item in the list.

Syntax

Visual Basic (Declaration)
Public Sub MovePrevious()
Visual Basic (Usage) Copy Code
Dim instance As BindingSource

instance.MovePrevious()
C#
public void MovePrevious()
Managed Extensions for C++
public: void MovePrevious();
C++/CLI
public:
void MovePrevious();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingSource Class
BindingSource Members


OnBindingComplete Method

[image]
Gizmox.WebGUI.Forms
OnBindingComplete Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingSource Class : OnBindingComplete Method

e
A BindingCompleteEventArgs that contains the event data.
Raises the BindingComplete event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnBindingComplete( _
   ByVal e As BindingCompleteEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As BindingSource
Dim e As BindingCompleteEventArgs

instance.OnBindingComplete(e)
C#
protected virtual void OnBindingComplete(
   BindingCompleteEventArgs e
)
Managed Extensions for C++
protected: virtual void OnBindingComplete(
   BindingCompleteEventArgs* e
)
C++/CLI
protected:
virtual void OnBindingComplete(
   BindingCompleteEventArgs^ e
)

Parameters

e
A BindingCompleteEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingSource Class
BindingSource Members


OnCurrentChanged Method

[image]
Gizmox.WebGUI.Forms
OnCurrentChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingSource Class : OnCurrentChanged Method

e

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnCurrentChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As BindingSource
Dim e As EventArgs

instance.OnCurrentChanged(e)
C#
protected virtual void OnCurrentChanged(
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnCurrentChanged(
   EventArgs* e
)
C++/CLI
protected:
virtual void OnCurrentChanged(
   EventArgs^ e
)

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingSource Class
BindingSource Members


OnCurrentItemChanged Method

[image]
Gizmox.WebGUI.Forms
OnCurrentItemChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingSource Class : OnCurrentItemChanged Method

e
An EventArgs that contains the event data.
Raises the CurrentItemChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnCurrentItemChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As BindingSource
Dim e As EventArgs

instance.OnCurrentItemChanged(e)
C#
protected virtual void OnCurrentItemChanged(
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnCurrentItemChanged(
   EventArgs* e
)
C++/CLI
protected:
virtual void OnCurrentItemChanged(
   EventArgs^ e
)

Parameters

e
An EventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingSource Class
BindingSource Members


OnDataError Method

[image]
Gizmox.WebGUI.Forms
OnDataError Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingSource Class : OnDataError Method

e
A BindingManagerDataErrorEventArgs that contains the event data.
Raises the DataError event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnDataError( _
   ByVal e As BindingManagerDataErrorEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As BindingSource
Dim e As BindingManagerDataErrorEventArgs

instance.OnDataError(e)
C#
protected virtual void OnDataError(
   BindingManagerDataErrorEventArgs e
)
Managed Extensions for C++
protected: virtual void OnDataError(
   BindingManagerDataErrorEventArgs* e
)
C++/CLI
protected:
virtual void OnDataError(
   BindingManagerDataErrorEventArgs^ e
)

Parameters

e
A BindingManagerDataErrorEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingSource Class
BindingSource Members


OnDataMemberChanged Method

[image]
Gizmox.WebGUI.Forms
OnDataMemberChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingSource Class : OnDataMemberChanged Method

e
An EventArgs that contains the event data.
Raises the DataMemberChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnDataMemberChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As BindingSource
Dim e As EventArgs

instance.OnDataMemberChanged(e)
C#
protected virtual void OnDataMemberChanged(
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnDataMemberChanged(
   EventArgs* e
)
C++/CLI
protected:
virtual void OnDataMemberChanged(
   EventArgs^ e
)

Parameters

e
An EventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingSource Class
BindingSource Members


OnDataSourceChanged Method

[image]
Gizmox.WebGUI.Forms
OnDataSourceChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingSource Class : OnDataSourceChanged Method

e
An EventArgs that contains the event data.
Raises the DataSourceChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnDataSourceChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As BindingSource
Dim e As EventArgs

instance.OnDataSourceChanged(e)
C#
protected virtual void OnDataSourceChanged(
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnDataSourceChanged(
   EventArgs* e
)
C++/CLI
protected:
virtual void OnDataSourceChanged(
   EventArgs^ e
)

Parameters

e
An EventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingSource Class
BindingSource Members


OnListChanged Method

[image]
Gizmox.WebGUI.Forms
OnListChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingSource Class : OnListChanged Method

e
An EventArgs that contains the event data.
Raises the ListChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnListChanged( _
   ByVal e As ListChangedEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As BindingSource
Dim e As ListChangedEventArgs

instance.OnListChanged(e)
C#
protected virtual void OnListChanged(
   ListChangedEventArgs e
)
Managed Extensions for C++
protected: virtual void OnListChanged(
   ListChangedEventArgs* e
)
C++/CLI
protected:
virtual void OnListChanged(
   ListChangedEventArgs^ e
)

Parameters

e
An EventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingSource Class
BindingSource Members


OnPositionChanged Method

[image]
Gizmox.WebGUI.Forms
OnPositionChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingSource Class : OnPositionChanged Method

e
A ListChangedEventArgs that contains the event data.
Raises the PositionChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnPositionChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As BindingSource
Dim e As EventArgs

instance.OnPositionChanged(e)
C#
protected virtual void OnPositionChanged(
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnPositionChanged(
   EventArgs* e
)
C++/CLI
protected:
virtual void OnPositionChanged(
   EventArgs^ e
)

Parameters

e
A ListChangedEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingSource Class
BindingSource Members


Remove Method

[image]
Gizmox.WebGUI.Forms
Remove Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingSource Class : Remove Method

value
The item to remove from the underlying list represented by the List property.
Removes the specified item from the list.

Syntax

Visual Basic (Declaration)
Public Overridable Sub Remove( _
   ByVal value As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As BindingSource
Dim value As Object

instance.Remove(value)
C#
public virtual void Remove(
   object value
)
Managed Extensions for C++
public: virtual void Remove(
   Object* value
)
C++/CLI
public:
virtual void Remove(
   Object^ value
)

Parameters

value
The item to remove from the underlying list represented by the List property.

Exceptions

Exception | Description
NotSupportedException | The underlying list has a fixed size or is read-only.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingSource Class
BindingSource Members


RemoveAt Method

[image]
Gizmox.WebGUI.Forms
RemoveAt Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingSource Class : RemoveAt Method

index
The zero-based index of the item to remove.
Removes the item at the specified index in the list.

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveAt( _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As BindingSource
Dim index As Integer

instance.RemoveAt(index)
C#
public virtual void RemoveAt(
   int index
)
Managed Extensions for C++
public: virtual void RemoveAt(
   int index
)
C++/CLI
public:
virtual void RemoveAt(
   int index
)

Parameters

index
The zero-based index of the item to remove.

Exceptions

Exception | Description
ArgumentOutOfRangeException | index is less than zero or greater than the value of the Count property.
NotSupportedException | The underlying list represented by the List property is read-only or has a fixed size.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingSource Class
BindingSource Members


RemoveCurrent Method

[image]
Gizmox.WebGUI.Forms
RemoveCurrent Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingSource Class : RemoveCurrent Method

Removes the current item from the list.

Syntax

Visual Basic (Declaration)
Public Sub RemoveCurrent()
Visual Basic (Usage) Copy Code
Dim instance As BindingSource

instance.RemoveCurrent()
C#
public void RemoveCurrent()
Managed Extensions for C++
public: void RemoveCurrent();
C++/CLI
public:
void RemoveCurrent();

Exceptions

Exception | Description
InvalidOperationException | The AllowRemove property is false.-or-Position is less than zero or greater than Count.
NotSupportedException | The underlying list represented by the List property is read-only or has a fixed size.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingSource Class
BindingSource Members


RemoveFilter Method

[image]
Gizmox.WebGUI.Forms
RemoveFilter Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingSource Class : RemoveFilter Method

Removes the filter associated with the BindingSource.

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveFilter()
Visual Basic (Usage) Copy Code
Dim instance As BindingSource

instance.RemoveFilter()
C#
public virtual void RemoveFilter()
Managed Extensions for C++
public: virtual void RemoveFilter();
C++/CLI
public:
virtual void RemoveFilter();

Exceptions

Exception | Description
NotSupportedException | The underlying list does not support filtering.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingSource Class
BindingSource Members


RemoveSort Method

[image]
Gizmox.WebGUI.Forms
RemoveSort Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingSource Class : RemoveSort Method

Removes the sort associated with the BindingSource.

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveSort()
Visual Basic (Usage) Copy Code
Dim instance As BindingSource

instance.RemoveSort()
C#
public virtual void RemoveSort()
Managed Extensions for C++
public: virtual void RemoveSort();
C++/CLI
public:
virtual void RemoveSort();

Exceptions

Exception | Description
NotSupportedException | The underlying list does not support sorting.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingSource Class
BindingSource Members


ResetAllowNew Method

[image]
Gizmox.WebGUI.Forms
ResetAllowNew Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingSource Class : ResetAllowNew Method

Reinitializes the AllowNew property.

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Overridable Sub ResetAllowNew()
Visual Basic (Usage) Copy Code
Dim instance As BindingSource

instance.ResetAllowNew()
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public virtual void ResetAllowNew()
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: virtual void ResetAllowNew();
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
virtual void ResetAllowNew();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingSource Class
BindingSource Members


ResetBindings Method

[image]
Gizmox.WebGUI.Forms
ResetBindings Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingSource Class : ResetBindings Method

metadataChanged
true if the data schema has changed; false if only values have changed.
Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values.

Syntax

Visual Basic (Declaration)
Public Sub ResetBindings( _
   ByVal metadataChanged As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As BindingSource
Dim metadataChanged As Boolean

instance.ResetBindings(metadataChanged)
C#
public void ResetBindings(
   bool metadataChanged
)
Managed Extensions for C++
public: void ResetBindings(
   bool metadataChanged
)
C++/CLI
public:
void ResetBindings(
   bool metadataChanged
)

Parameters

metadataChanged
true if the data schema has changed; false if only values have changed.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingSource Class
BindingSource Members


ResetCurrentItem Method

[image]
Gizmox.WebGUI.Forms
ResetCurrentItem Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingSource Class : ResetCurrentItem Method

Causes a control bound to the BindingSource to reread the currently selected item and refresh its displayed value.

Syntax

Visual Basic (Declaration)
Public Sub ResetCurrentItem()
Visual Basic (Usage) Copy Code
Dim instance As BindingSource

instance.ResetCurrentItem()
C#
public void ResetCurrentItem()
Managed Extensions for C++
public: void ResetCurrentItem();
C++/CLI
public:
void ResetCurrentItem();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingSource Class
BindingSource Members


ResetItem Method

[image]
Gizmox.WebGUI.Forms
ResetItem Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingSource Class : ResetItem Method

itemIndex
The zero-based index of the item that has changed.
Causes a control bound to the BindingSource to reread the item at the specified index, and refresh its displayed value.

Syntax

Visual Basic (Declaration)
Public Sub ResetItem( _
   ByVal itemIndex As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As BindingSource
Dim itemIndex As Integer

instance.ResetItem(itemIndex)
C#
public void ResetItem(
   int itemIndex
)
Managed Extensions for C++
public: void ResetItem(
   int itemIndex
)
C++/CLI
public:
void ResetItem(
   int itemIndex
)

Parameters

itemIndex
The zero-based index of the item that has changed.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingSource Class
BindingSource Members


ResumeBinding Method

[image]
Gizmox.WebGUI.Forms
ResumeBinding Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingSource Class : ResumeBinding Method

Resumes data binding.

Syntax

Visual Basic (Declaration)
Public Sub ResumeBinding()
Visual Basic (Usage) Copy Code
Dim instance As BindingSource

instance.ResumeBinding()
C#
public void ResumeBinding()
Managed Extensions for C++
public: void ResumeBinding();
C++/CLI
public:
void ResumeBinding();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingSource Class
BindingSource Members


SuspendBinding Method

[image]
Gizmox.WebGUI.Forms
SuspendBinding Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingSource Class : SuspendBinding Method

Suspends data binding to prevent changes from updating the bound data source.

Syntax

Visual Basic (Declaration)
Public Sub SuspendBinding()
Visual Basic (Usage) Copy Code
Dim instance As BindingSource

instance.SuspendBinding()
C#
public void SuspendBinding()
Managed Extensions for C++
public: void SuspendBinding();
C++/CLI
public:
void SuspendBinding();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingSource Class
BindingSource Members


BindingSource Class Properties

[image]
Gizmox.WebGUI.Forms
BindingSource Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : BindingSource Class

For a list of all members of this type, see BindingSource members.

Public Properties

 | Name | Description
Public Property | AllowEdit | Gets a value indicating whether items in the underlying list can be edited.
Public Property | AllowNew | Gets or sets a value indicating whether the AddNew method can be used to add items to the list.
Public Property | AllowRemove | Gets a value indicating whether items can be removed from the underlying list.
Public Property | Container | (Inherited from ComponentBase)
Public Property | Count | Gets the total number of items in the underlying list.
Public Property | CurrencyManager | Gets the currency manager associated with this BindingSource.
Public Property | Current | Gets the current item in the list.
Public Property | DataMember | Gets or sets the specific list in the data source to which the connector currently binds to.
Public Property | DataSource | Gets or sets the data source that the connector binds to.
Public Property | Filter | Gets or sets the expression used to filter which rows are viewed.
Public Property | IsBindingSuspended | Gets a value indicating whether the list binding is suspended.
Public Property | IsFixedSize | Gets a value indicating whether the underlying list has a fixed size.
Public Property | IsReadOnly | Gets a value indicating whether the underlying list is read-only.
Public Property | IsSorted | Gets a value indicating whether the items in the underlying list are sorted.
Public Property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe).
Public Property | Item | Gets or sets the list element at the specified index.
Public Property | List | Gets the list that the connector is bound to.
Public Property | Position | Gets or sets the index of the current item in the underlying list.
Public Property | RaiseListChangedEvents | Gets or sets a value indicating whether ListChanged events should be raised.
Public Property | Site | (Inherited from ComponentBase)
Public Property | Sort | Gets or sets the column names used for sorting, and the sort order for viewing the rows in the data source.
Public Property | SupportsAdvancedSorting | Gets a value indicating whether the data source supports multi-column sorting.
Public Property | SupportsChangeNotification | Gets a value indicating whether the data source supports change notification.
Public Property | SupportsFiltering | Gets a value indicating whether the data source supports filtering.
Public Property | SupportsSearching | Gets a value indicating whether the data source supports searching with the Find method.
Public Property | SupportsSorting | Gets a value indicating whether the data source supports sorting.
Public Property | SyncRoot | Gets an object that can be used to synchronize access to the underlying list.
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Top

See Also

Reference

BindingSource Class
Gizmox.WebGUI.Forms Namespace


AllowEdit Property

[image]
Gizmox.WebGUI.Forms
AllowEdit Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingSource Class : AllowEdit Property

Gets a value indicating whether items in the underlying list can be edited.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public Overridable ReadOnly Property AllowEdit As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BindingSource
Dim value As Boolean

value = instance.AllowEdit
C#
[BrowsableAttribute(false)]
public virtual bool AllowEdit {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property virtual bool get_AllowEdit();
C++/CLI
[BrowsableAttribute(false)]
public:
virtual property bool AllowEdit {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingSource Class
BindingSource Members


AllowNew Property

[image]
Gizmox.WebGUI.Forms
AllowNew Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingSource Class : AllowNew Property

Gets or sets a value indicating whether the AddNew method can be used to add items to the list.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Behavior")>
<SRDescriptionAttribute("Determines whether the BindingSource allows new items to be added to the list.")>
Public Overridable Property AllowNew As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BindingSource
Dim value As Boolean

instance.AllowNew = value

value = instance.AllowNew
C#
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Determines whether the BindingSource allows new items to be added to the list.")]
public virtual bool AllowNew {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Determines whether the BindingSource allows new items to be added to the list.")]
public: __property virtual bool get_AllowNew();
public: __property virtual void set_AllowNew(
   bool value
);
C++/CLI
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Determines whether the BindingSource allows new items to be added to the list.")]
public:
virtual property bool AllowNew {
   bool get();
   void set (boolvalue);
}

Exceptions

Exception | Description
InvalidOperationException | This property is set to true when the underlying list represented by the List property has a fixed size or is read-only.
MissingMethodException | The property is set to true and the AddingNew event is not handled when the underlying list type does not have a default constructor.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingSource Class
BindingSource Members


AllowRemove Property

[image]
Gizmox.WebGUI.Forms
AllowRemove Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingSource Class : AllowRemove Property

Gets a value indicating whether items can be removed from the underlying list.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public Overridable ReadOnly Property AllowRemove As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BindingSource
Dim value As Boolean

value = instance.AllowRemove
C#
[BrowsableAttribute(false)]
public virtual bool AllowRemove {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property virtual bool get_AllowRemove();
C++/CLI
[BrowsableAttribute(false)]
public:
virtual property bool AllowRemove {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingSource Class
BindingSource Members


Count Property

[image]
Gizmox.WebGUI.Forms
Count Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingSource Class : Count Property

Gets the total number of items in the underlying list.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public Overridable ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As BindingSource
Dim value As Integer

value = instance.Count
C#
[BrowsableAttribute(false)]
public virtual int Count {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property virtual int get_Count();
C++/CLI
[BrowsableAttribute(false)]
public:
virtual property int Count {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingSource Class
BindingSource Members


CurrencyManager Property

[image]
Gizmox.WebGUI.Forms
CurrencyManager Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingSource Class : CurrencyManager Property

Gets the currency manager associated with this BindingSource.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public Overridable ReadOnly Property CurrencyManager As CurrencyManager
Visual Basic (Usage) Copy Code
Dim instance As BindingSource
Dim value As CurrencyManager

value = instance.CurrencyManager
C#
[BrowsableAttribute(false)]
public virtual CurrencyManager CurrencyManager {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property virtual CurrencyManager* get_CurrencyManager();
C++/CLI
[BrowsableAttribute(false)]
public:
virtual property CurrencyManager^ CurrencyManager {
   CurrencyManager^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingSource Class
BindingSource Members


Current Property

[image]
Gizmox.WebGUI.Forms
Current Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingSource Class : Current Property

Gets the current item in the list.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property Current As Object
Visual Basic (Usage) Copy Code
Dim instance As BindingSource
Dim value As Object

value = instance.Current
C#
[BrowsableAttribute(false)]
public object Current {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property Object* get_Current();
C++/CLI
[BrowsableAttribute(false)]
public:
property Object^ Current {
   Object^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingSource Class
BindingSource Members


DataMember Property

[image]
Gizmox.WebGUI.Forms
DataMember Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingSource Class : DataMember Property

Gets or sets the specific list in the data source to which the connector currently binds to.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<SRDescriptionAttribute("Indicates a sub-list of the DataSource that the BindingSource is bound to.")>
<EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.DataMemberListEditor, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<RefreshPropertiesAttribute()>
<SRCategoryAttribute("Data")>
Public Property DataMember As String
Visual Basic (Usage) Copy Code
Dim instance As BindingSource
Dim value As String

instance.DataMember = value

value = instance.DataMember
C#
[DefaultValueAttribute()]
[SRDescriptionAttribute("Indicates a sub-list of the DataSource that the BindingSource is bound to.")]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.DataMemberListEditor, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[RefreshPropertiesAttribute()]
[SRCategoryAttribute("Data")]
public string DataMember {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[SRDescriptionAttribute("Indicates a sub-list of the DataSource that the BindingSource is bound to.")]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.DataMemberListEditor, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[RefreshPropertiesAttribute()]
[SRCategoryAttribute("Data")]
public: __property string* get_DataMember();
public: __property void set_DataMember(
   string* value
);
C++/CLI
[DefaultValueAttribute()]
[SRDescriptionAttribute("Indicates a sub-list of the DataSource that the BindingSource is bound to.")]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.DataMemberListEditor, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[RefreshPropertiesAttribute()]
[SRCategoryAttribute("Data")]
public:
property String^ DataMember {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingSource Class
BindingSource Members


DataSource Property

[image]
Gizmox.WebGUI.Forms
DataSource Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingSource Class : DataSource Property

Gets or sets the data source that the connector binds to.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<AttributeProviderAttribute(TypeName="Gizmox.WebGUI.Forms.Binding+IDataSourceAttributeProvider, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d", PropertyName="")>
<SRCategoryAttribute("Data")>
<SRDescriptionAttribute("Indicates the source of data for the BindingSource.")>
<RefreshPropertiesAttribute()>
Public Property DataSource As Object
Visual Basic (Usage) Copy Code
Dim instance As BindingSource
Dim value As Object

instance.DataSource = value

value = instance.DataSource
C#
[DefaultValueAttribute()]
[AttributeProviderAttribute(TypeName="Gizmox.WebGUI.Forms.Binding+IDataSourceAttributeProvider, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d", PropertyName="")]
[SRCategoryAttribute("Data")]
[SRDescriptionAttribute("Indicates the source of data for the BindingSource.")]
[RefreshPropertiesAttribute()]
public object DataSource {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[AttributeProviderAttribute(TypeName="Gizmox.WebGUI.Forms.Binding+IDataSourceAttributeProvider, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d", PropertyName="")]
[SRCategoryAttribute("Data")]
[SRDescriptionAttribute("Indicates the source of data for the BindingSource.")]
[RefreshPropertiesAttribute()]
public: __property Object* get_DataSource();
public: __property void set_DataSource(
   Object* value
);
C++/CLI
[DefaultValueAttribute()]
[AttributeProviderAttribute(TypeName="Gizmox.WebGUI.Forms.Binding+IDataSourceAttributeProvider, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d", PropertyName="")]
[SRCategoryAttribute("Data")]
[SRDescriptionAttribute("Indicates the source of data for the BindingSource.")]
[RefreshPropertiesAttribute()]
public:
property Object^ DataSource {
   Object^ get();
   void set (Object^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingSource Class
BindingSource Members


Filter Property

[image]
Gizmox.WebGUI.Forms
Filter Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingSource Class : Filter Property

Gets or sets the expression used to filter which rows are viewed.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Data")>
<SRDescriptionAttribute("Indicates a database column expression used to filter the set of rows returned by the data source.")>
<DefaultValueAttribute()>
Public Overridable Property Filter As String
Visual Basic (Usage) Copy Code
Dim instance As BindingSource
Dim value As String

instance.Filter = value

value = instance.Filter
C#
[SRCategoryAttribute("Data")]
[SRDescriptionAttribute("Indicates a database column expression used to filter the set of rows returned by the data source.")]
[DefaultValueAttribute()]
public virtual string Filter {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Data")]
[SRDescriptionAttribute("Indicates a database column expression used to filter the set of rows returned by the data source.")]
[DefaultValueAttribute()]
public: __property virtual string* get_Filter();
public: __property virtual void set_Filter(
   string* value
);
C++/CLI
[SRCategoryAttribute("Data")]
[SRDescriptionAttribute("Indicates a database column expression used to filter the set of rows returned by the data source.")]
[DefaultValueAttribute()]
public:
virtual property String^ Filter {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingSource Class
BindingSource Members


IsBindingSuspended Property

[image]
Gizmox.WebGUI.Forms
IsBindingSuspended Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingSource Class : IsBindingSuspended Property

Gets a value indicating whether the list binding is suspended.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property IsBindingSuspended As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BindingSource
Dim value As Boolean

value = instance.IsBindingSuspended
C#
[BrowsableAttribute(false)]
public bool IsBindingSuspended {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property bool get_IsBindingSuspended();
C++/CLI
[BrowsableAttribute(false)]
public:
property bool IsBindingSuspended {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingSource Class
BindingSource Members


IsFixedSize Property

[image]
Gizmox.WebGUI.Forms
IsFixedSize Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingSource Class : IsFixedSize Property

Gets a value indicating whether the underlying list has a fixed size.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public Overridable ReadOnly Property IsFixedSize As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BindingSource
Dim value As Boolean

value = instance.IsFixedSize
C#
[BrowsableAttribute(false)]
public virtual bool IsFixedSize {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property virtual bool get_IsFixedSize();
C++/CLI
[BrowsableAttribute(false)]
public:
virtual property bool IsFixedSize {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingSource Class
BindingSource Members


IsReadOnly Property

[image]
Gizmox.WebGUI.Forms
IsReadOnly Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingSource Class : IsReadOnly Property

Gets a value indicating whether the underlying list is read-only.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public Overridable ReadOnly Property IsReadOnly As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BindingSource
Dim value As Boolean

value = instance.IsReadOnly
C#
[BrowsableAttribute(false)]
public virtual bool IsReadOnly {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property virtual bool get_IsReadOnly();
C++/CLI
[BrowsableAttribute(false)]
public:
virtual property bool IsReadOnly {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingSource Class
BindingSource Members


IsSorted Property

[image]
Gizmox.WebGUI.Forms
IsSorted Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingSource Class : IsSorted Property

Gets a value indicating whether the items in the underlying list are sorted.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public Overridable ReadOnly Property IsSorted As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BindingSource
Dim value As Boolean

value = instance.IsSorted
C#
[BrowsableAttribute(false)]
public virtual bool IsSorted {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property virtual bool get_IsSorted();
C++/CLI
[BrowsableAttribute(false)]
public:
virtual property bool IsSorted {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingSource Class
BindingSource Members


IsSynchronized Property

[image]
Gizmox.WebGUI.Forms
IsSynchronized Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingSource Class : IsSynchronized Property

Gets a value indicating whether access to the collection is synchronized (thread safe).

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public Overridable ReadOnly Property IsSynchronized As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BindingSource
Dim value As Boolean

value = instance.IsSynchronized
C#
[BrowsableAttribute(false)]
public virtual bool IsSynchronized {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property virtual bool get_IsSynchronized();
C++/CLI
[BrowsableAttribute(false)]
public:
virtual property bool IsSynchronized {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingSource Class
BindingSource Members


Item Property

[image]
Gizmox.WebGUI.Forms
Item Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingSource Class : Item Property

index
The zero-based index of the element to retrieve.
Gets or sets the list element at the specified index.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public Overridable Default Property Item( _
   ByVal index As Integer _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As BindingSource
Dim index As Integer
Dim value As Object

instance.Item(index) = value

value = instance.Item(index)
C#
[BrowsableAttribute(false)]
public virtual object this[
   int index
]; {get; set;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property virtual Object* get_Item(
   int index
);
public: __property virtual void set_Item(
   int index,
   Object* value
);
C++/CLI
[BrowsableAttribute(false)]
public:
virtual property Object^ default [int] {
   Object^ get(intindex);
   void set (intindex, Object^value);
}

Parameters

index
The zero-based index of the element to retrieve.

Exceptions

Exception | Description
ArgumentOutOfRangeException | index is less than zero or is equal to or greater than Count.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingSource Class
BindingSource Members


List Property

[image]
Gizmox.WebGUI.Forms
List Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingSource Class : List Property

Gets the list that the connector is bound to.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property List As IList
Visual Basic (Usage) Copy Code
Dim instance As BindingSource
Dim value As IList

value = instance.List
C#
[BrowsableAttribute(false)]
public IList List {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property IList* get_List();
C++/CLI
[BrowsableAttribute(false)]
public:
property IList^ List {
   IList^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingSource Class
BindingSource Members


Position Property

[image]
Gizmox.WebGUI.Forms
Position Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingSource Class : Position Property

Gets or sets the index of the current item in the underlying list.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<DefaultValueAttribute()>
Public Property Position As Integer
Visual Basic (Usage) Copy Code
Dim instance As BindingSource
Dim value As Integer

instance.Position = value

value = instance.Position
C#
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
public int Position {get; set;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
public: __property int get_Position();
public: __property void set_Position(
   int value
);
C++/CLI
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
public:
property int Position {
   int get();
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingSource Class
BindingSource Members


RaiseListChangedEvents Property

[image]
Gizmox.WebGUI.Forms
RaiseListChangedEvents Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingSource Class : RaiseListChangedEvents Property

Gets or sets a value indicating whether ListChanged events should be raised.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<BrowsableAttribute(False)>
Public Property RaiseListChangedEvents As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BindingSource
Dim value As Boolean

instance.RaiseListChangedEvents = value

value = instance.RaiseListChangedEvents
C#
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
public bool RaiseListChangedEvents {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
public: __property bool get_RaiseListChangedEvents();
public: __property void set_RaiseListChangedEvents(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
public:
property bool RaiseListChangedEvents {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingSource Class
BindingSource Members


Sort Property

[image]
Gizmox.WebGUI.Forms
Sort Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingSource Class : Sort Property

Gets or sets the column names used for sorting, and the sort order for viewing the rows in the data source.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Indicates names of database columns used to sort the set of rows returned by the data source.")>
<DefaultValueAttribute()>
<SRCategoryAttribute("Data")>
Public Property Sort As String
Visual Basic (Usage) Copy Code
Dim instance As BindingSource
Dim value As String

instance.Sort = value

value = instance.Sort
C#
[SRDescriptionAttribute("Indicates names of database columns used to sort the set of rows returned by the data source.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Data")]
public string Sort {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Indicates names of database columns used to sort the set of rows returned by the data source.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Data")]
public: __property string* get_Sort();
public: __property void set_Sort(
   string* value
);
C++/CLI
[SRDescriptionAttribute("Indicates names of database columns used to sort the set of rows returned by the data source.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Data")]
public:
property String^ Sort {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingSource Class
BindingSource Members


SupportsAdvancedSorting Property

[image]
Gizmox.WebGUI.Forms
SupportsAdvancedSorting Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingSource Class : SupportsAdvancedSorting Property

Gets a value indicating whether the data source supports multi-column sorting.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public Overridable ReadOnly Property SupportsAdvancedSorting As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BindingSource
Dim value As Boolean

value = instance.SupportsAdvancedSorting
C#
[BrowsableAttribute(false)]
public virtual bool SupportsAdvancedSorting {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property virtual bool get_SupportsAdvancedSorting();
C++/CLI
[BrowsableAttribute(false)]
public:
virtual property bool SupportsAdvancedSorting {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingSource Class
BindingSource Members


SupportsChangeNotification Property

[image]
Gizmox.WebGUI.Forms
SupportsChangeNotification Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingSource Class : SupportsChangeNotification Property

Gets a value indicating whether the data source supports change notification.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public Overridable ReadOnly Property SupportsChangeNotification As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BindingSource
Dim value As Boolean

value = instance.SupportsChangeNotification
C#
[BrowsableAttribute(false)]
public virtual bool SupportsChangeNotification {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property virtual bool get_SupportsChangeNotification();
C++/CLI
[BrowsableAttribute(false)]
public:
virtual property bool SupportsChangeNotification {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingSource Class
BindingSource Members


SupportsFiltering Property

[image]
Gizmox.WebGUI.Forms
SupportsFiltering Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingSource Class : SupportsFiltering Property

Gets a value indicating whether the data source supports filtering.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public Overridable ReadOnly Property SupportsFiltering As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BindingSource
Dim value As Boolean

value = instance.SupportsFiltering
C#
[BrowsableAttribute(false)]
public virtual bool SupportsFiltering {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property virtual bool get_SupportsFiltering();
C++/CLI
[BrowsableAttribute(false)]
public:
virtual property bool SupportsFiltering {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingSource Class
BindingSource Members


SupportsSearching Property

[image]
Gizmox.WebGUI.Forms
SupportsSearching Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingSource Class : SupportsSearching Property

Gets a value indicating whether the data source supports searching with the Find method.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public Overridable ReadOnly Property SupportsSearching As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BindingSource
Dim value As Boolean

value = instance.SupportsSearching
C#
[BrowsableAttribute(false)]
public virtual bool SupportsSearching {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property virtual bool get_SupportsSearching();
C++/CLI
[BrowsableAttribute(false)]
public:
virtual property bool SupportsSearching {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingSource Class
BindingSource Members


SupportsSorting Property

[image]
Gizmox.WebGUI.Forms
SupportsSorting Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingSource Class : SupportsSorting Property

Gets a value indicating whether the data source supports sorting.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public Overridable ReadOnly Property SupportsSorting As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BindingSource
Dim value As Boolean

value = instance.SupportsSorting
C#
[BrowsableAttribute(false)]
public virtual bool SupportsSorting {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property virtual bool get_SupportsSorting();
C++/CLI
[BrowsableAttribute(false)]
public:
virtual property bool SupportsSorting {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingSource Class
BindingSource Members


SyncRoot Property

[image]
Gizmox.WebGUI.Forms
SyncRoot Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingSource Class : SyncRoot Property

Gets an object that can be used to synchronize access to the underlying list.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public Overridable ReadOnly Property SyncRoot As Object
Visual Basic (Usage) Copy Code
Dim instance As BindingSource
Dim value As Object

value = instance.SyncRoot
C#
[BrowsableAttribute(false)]
public virtual object SyncRoot {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property virtual Object* get_SyncRoot();
C++/CLI
[BrowsableAttribute(false)]
public:
virtual property Object^ SyncRoot {
   Object^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingSource Class
BindingSource Members


BindingSource Class Events

[image]
Gizmox.WebGUI.Forms
BindingSource Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : BindingSource Class

For a list of all members of this type, see BindingSource members.

Public Events

 | Name | Description
Public Event | AddingNew | Occurs before an item is added to the underlying list.
Public Event | BindingComplete | Occurs when all the clients have been bound to this BindingSource.
Public Event | CurrentChanged | Occurs when the currently bound item changes.
Public Event | CurrentItemChanged | Occurs when a property value of the Current property has changed.
Public Event | DataError | Occurs when a currency-related exception is silently handled by the BindingSource.
Public Event | DataMemberChanged | Occurs when the DataMember property value has changed.
Public Event | DataSourceChanged | Occurs when the DataSource property value has changed.
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | ListChanged | Occurs when the underlying list changes or an item in the list changes.
Public Event | PositionChanged | Occurs after the value of the Position property has changed.
Top

See Also

Reference

BindingSource Class
Gizmox.WebGUI.Forms Namespace


AddingNew Event

[image]
Gizmox.WebGUI.Forms
AddingNew Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingSource Class : AddingNew Event

Occurs before an item is added to the underlying list.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Data")>
<SRDescriptionAttribute("Event raised when the user calls AddNew on the BindingSource")>
Public Event AddingNew() As AddingNewEventHandler
Visual Basic (Usage) Copy Code
Dim instance As BindingSource
Dim handler As AddingNewEventHandler

AddHandler instance.AddingNew, handler
C#
[SRCategoryAttribute("Data")]
[SRDescriptionAttribute("Event raised when the user calls AddNew on the BindingSource")]
public event AddingNewEventHandler AddingNew()
Managed Extensions for C++
[SRCategoryAttribute("Data")]
[SRDescriptionAttribute("Event raised when the user calls AddNew on the BindingSource")]
public: __event AddingNewEventHandler* AddingNew
C++/CLI
[SRCategoryAttribute("Data")]
[SRDescriptionAttribute("Event raised when the user calls AddNew on the BindingSource")]
public:
event AddingNewEventHandler^ AddingNew

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingSource Class
BindingSource Members


BindingComplete Event

[image]
Gizmox.WebGUI.Forms
BindingComplete Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingSource Class : BindingComplete Event

Occurs when all the clients have been bound to this BindingSource.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Event raised after data has been exchanged between the data source and a control property bound to that data source.")>
<SRCategoryAttribute("Data")>
Public Event BindingComplete() As BindingCompleteEventHandler
Visual Basic (Usage) Copy Code
Dim instance As BindingSource
Dim handler As BindingCompleteEventHandler

AddHandler instance.BindingComplete, handler
C#
[SRDescriptionAttribute("Event raised after data has been exchanged between the data source and a control property bound to that data source.")]
[SRCategoryAttribute("Data")]
public event BindingCompleteEventHandler BindingComplete()
Managed Extensions for C++
[SRDescriptionAttribute("Event raised after data has been exchanged between the data source and a control property bound to that data source.")]
[SRCategoryAttribute("Data")]
public: __event BindingCompleteEventHandler* BindingComplete
C++/CLI
[SRDescriptionAttribute("Event raised after data has been exchanged between the data source and a control property bound to that data source.")]
[SRCategoryAttribute("Data")]
public:
event BindingCompleteEventHandler^ BindingComplete

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingSource Class
BindingSource Members


CurrentChanged Event

[image]
Gizmox.WebGUI.Forms
CurrentChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingSource Class : CurrentChanged Event

Occurs when the currently bound item changes.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Event raised when the value of Current changes.")>
<SRCategoryAttribute("Data")>
Public Event CurrentChanged() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As BindingSource
Dim handler As EventHandler

AddHandler instance.CurrentChanged, handler
C#
[SRDescriptionAttribute("Event raised when the value of Current changes.")]
[SRCategoryAttribute("Data")]
public event EventHandler CurrentChanged()
Managed Extensions for C++
[SRDescriptionAttribute("Event raised when the value of Current changes.")]
[SRCategoryAttribute("Data")]
public: __event EventHandler* CurrentChanged
C++/CLI
[SRDescriptionAttribute("Event raised when the value of Current changes.")]
[SRCategoryAttribute("Data")]
public:
event EventHandler^ CurrentChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingSource Class
BindingSource Members


CurrentItemChanged Event

[image]
Gizmox.WebGUI.Forms
CurrentItemChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingSource Class : CurrentItemChanged Event

Occurs when a property value of the Current property has changed.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Data")>
<SRDescriptionAttribute("Event raised when the value of Current changes, or a property of the current item changes.")>
Public Event CurrentItemChanged() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As BindingSource
Dim handler As EventHandler

AddHandler instance.CurrentItemChanged, handler
C#
[SRCategoryAttribute("Data")]
[SRDescriptionAttribute("Event raised when the value of Current changes, or a property of the current item changes.")]
public event EventHandler CurrentItemChanged()
Managed Extensions for C++
[SRCategoryAttribute("Data")]
[SRDescriptionAttribute("Event raised when the value of Current changes, or a property of the current item changes.")]
public: __event EventHandler* CurrentItemChanged
C++/CLI
[SRCategoryAttribute("Data")]
[SRDescriptionAttribute("Event raised when the value of Current changes, or a property of the current item changes.")]
public:
event EventHandler^ CurrentItemChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingSource Class
BindingSource Members


DataError Event

[image]
Gizmox.WebGUI.Forms
DataError Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingSource Class : DataError Event

Occurs when a currency-related exception is silently handled by the BindingSource.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Event raised when an exception thrown during data binding is handled internally by the CurrencyManager.")>
<SRCategoryAttribute("Data")>
Public Event DataError() As BindingManagerDataErrorEventHandler
Visual Basic (Usage) Copy Code
Dim instance As BindingSource
Dim handler As BindingManagerDataErrorEventHandler

AddHandler instance.DataError, handler
C#
[SRDescriptionAttribute("Event raised when an exception thrown during data binding is handled internally by the CurrencyManager.")]
[SRCategoryAttribute("Data")]
public event BindingManagerDataErrorEventHandler DataError()
Managed Extensions for C++
[SRDescriptionAttribute("Event raised when an exception thrown during data binding is handled internally by the CurrencyManager.")]
[SRCategoryAttribute("Data")]
public: __event BindingManagerDataErrorEventHandler* DataError
C++/CLI
[SRDescriptionAttribute("Event raised when an exception thrown during data binding is handled internally by the CurrencyManager.")]
[SRCategoryAttribute("Data")]
public:
event BindingManagerDataErrorEventHandler^ DataError

Event Data

The event handler receives an argument of type BindingManagerDataErrorEventArgs containing data related to this event. The following BindingManagerDataErrorEventArgs properties provide information specific to this event.

Property | Description
Exception | Gets the Exception caught in the binding process that caused the DataError event to be raised.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingSource Class
BindingSource Members


DataMemberChanged Event

[image]
Gizmox.WebGUI.Forms
DataMemberChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingSource Class : DataMemberChanged Event

Occurs when the DataMember property value has changed.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Event raised when the DataMember changes.")>
<SRCategoryAttribute("Data")>
Public Event DataMemberChanged() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As BindingSource
Dim handler As EventHandler

AddHandler instance.DataMemberChanged, handler
C#
[SRDescriptionAttribute("Event raised when the DataMember changes.")]
[SRCategoryAttribute("Data")]
public event EventHandler DataMemberChanged()
Managed Extensions for C++
[SRDescriptionAttribute("Event raised when the DataMember changes.")]
[SRCategoryAttribute("Data")]
public: __event EventHandler* DataMemberChanged
C++/CLI
[SRDescriptionAttribute("Event raised when the DataMember changes.")]
[SRCategoryAttribute("Data")]
public:
event EventHandler^ DataMemberChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingSource Class
BindingSource Members


DataSourceChanged Event

[image]
Gizmox.WebGUI.Forms
DataSourceChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingSource Class : DataSourceChanged Event

Occurs when the DataSource property value has changed.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Event raised when the DataSource changes.")>
<SRCategoryAttribute("Data")>
Public Event DataSourceChanged() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As BindingSource
Dim handler As EventHandler

AddHandler instance.DataSourceChanged, handler
C#
[SRDescriptionAttribute("Event raised when the DataSource changes.")]
[SRCategoryAttribute("Data")]
public event EventHandler DataSourceChanged()
Managed Extensions for C++
[SRDescriptionAttribute("Event raised when the DataSource changes.")]
[SRCategoryAttribute("Data")]
public: __event EventHandler* DataSourceChanged
C++/CLI
[SRDescriptionAttribute("Event raised when the DataSource changes.")]
[SRCategoryAttribute("Data")]
public:
event EventHandler^ DataSourceChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingSource Class
BindingSource Members


ListChanged Event

[image]
Gizmox.WebGUI.Forms
ListChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingSource Class : ListChanged Event

Occurs when the underlying list changes or an item in the list changes.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Event raised when a change occurs in the BindingSource's list.")>
<SRCategoryAttribute("Data")>
Public Event ListChanged() As ListChangedEventHandler
Visual Basic (Usage) Copy Code
Dim instance As BindingSource
Dim handler As ListChangedEventHandler

AddHandler instance.ListChanged, handler
C#
[SRDescriptionAttribute("Event raised when a change occurs in the BindingSource's list.")]
[SRCategoryAttribute("Data")]
public event ListChangedEventHandler ListChanged()
Managed Extensions for C++
[SRDescriptionAttribute("Event raised when a change occurs in the BindingSource's list.")]
[SRCategoryAttribute("Data")]
public: __event ListChangedEventHandler* ListChanged
C++/CLI
[SRDescriptionAttribute("Event raised when a change occurs in the BindingSource's list.")]
[SRCategoryAttribute("Data")]
public:
event ListChangedEventHandler^ ListChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingSource Class
BindingSource Members


PositionChanged Event

[image]
Gizmox.WebGUI.Forms
PositionChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingSource Class : PositionChanged Event

Occurs after the value of the Position property has changed.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Event raised when the value of Position changes.")>
<SRCategoryAttribute("Data")>
Public Event PositionChanged() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As BindingSource
Dim handler As EventHandler

AddHandler instance.PositionChanged, handler
C#
[SRDescriptionAttribute("Event raised when the value of Position changes.")]
[SRCategoryAttribute("Data")]
public event EventHandler PositionChanged()
Managed Extensions for C++
[SRDescriptionAttribute("Event raised when the value of Position changes.")]
[SRCategoryAttribute("Data")]
public: __event EventHandler* PositionChanged
C++/CLI
[SRDescriptionAttribute("Event raised when the value of Position changes.")]
[SRCategoryAttribute("Data")]
public:
event EventHandler^ PositionChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingSource Class
BindingSource Members


Button Class

[image]
Gizmox.WebGUI.Forms
Button Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : Button Class

A button control

Object Model

Syntax

Visual Basic (Declaration)
<MetadataTagAttribute("B")>
<ToolboxBitmapAttribute()>
<ClientControllerAttribute()>
<SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableFlatButton, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="F")>
<DesignTimeControllerAttribute()>
<ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<ToolboxItemCategoryAttribute("Common Controls")>
Public Class Button
   Inherits Control
   Implements IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IButtonControl, IArrangedElement
Visual Basic (Usage) Copy Code
Dim instance As Button
C#
[MetadataTagAttribute("B")]
[ToolboxBitmapAttribute()]
[ClientControllerAttribute()]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableFlatButton, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="F")]
[DesignTimeControllerAttribute()]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ToolboxItemCategoryAttribute("Common Controls")]
public class Button : Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IButtonControl, IArrangedElement
Managed Extensions for C++
[MetadataTagAttribute("B")]
[ToolboxBitmapAttribute()]
[ClientControllerAttribute()]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableFlatButton, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="F")]
[DesignTimeControllerAttribute()]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ToolboxItemCategoryAttribute("Common Controls")]
public __gc class Button : public Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IButtonControl, IArrangedElement
C++/CLI
[MetadataTagAttribute("B")]
[ToolboxBitmapAttribute()]
[ClientControllerAttribute()]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableFlatButton, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="F")]
[DesignTimeControllerAttribute()]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ToolboxItemCategoryAttribute("Common Controls")]
public ref class Button : public Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IButtonControl, IArrangedElement

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.Button

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Button Members
Gizmox.WebGUI.Forms Namespace


Button Class Members

[image]
Gizmox.WebGUI.Forms
Button Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : Button Class

The following tables list the members exposed by Button.

Public Constructors

 | Name | Description
Public Constructor | Button Constructor | Creates a new Button instance.
Top

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | ButtonStyle | Gets or sets the button style.
Public Property | CanFocus | Overridden.
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | ClickOnce | Gets or sets the ClickOnce property.
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | DialogResult | Gets or sets a value that is returned to the parent form when the button is clicked.
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | DropDownMenu | Defines a dropdown menu to the button
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | FlatStyle | Gets or sets the flat style.
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | Image | Gets or sets the image that is displayed on a button control.
Public Property | ImageAlign | Gets or sets the alignment of the image on the button control.
Public Property | ImageIndex | Gets or sets the index of the image that is displayed for the item.
Public Property | ImageKey | Gets or sets the key for the image that is displayed for the item.
Public Property | ImageList | Gets or sets the ImageList to use when displaying items as small icons in the control.
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Overridden. Gets or sets the text.
Public Property | TextAlign | Gets or sets the text align.
Public Property | TextImageRelation | Gets or sets the position of text and image relative to each other.
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | Overridden.
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | Overridden.
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | NotifyDefault | Notifies the default.
Public Method | PerformClick | Performs the click.
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | Overridden.
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Overridden. Fires an event.
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from Control)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Control)
Protected Method | RenderAttributes | Overridden.
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeImage | Shoulds the serialize image.
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

Button Class
Gizmox.WebGUI.Forms Namespace


Button Constructor

[image]
Gizmox.WebGUI.Forms
Button Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Button Class : Button Constructor

Creates a new Button instance.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Button()
C#
public Button()
Managed Extensions for C++
public: Button();
C++/CLI
public:
Button();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Button Class
Button Members


Button Class Methods

[image]
Gizmox.WebGUI.Forms
Button Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : Button Class

For a list of all members of this type, see Button members.

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | NotifyDefault | Notifies the default.
Public Method | PerformClick | Performs the click.
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | Overridden.
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Overridden. Fires an event.
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from Control)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Control)
Protected Method | RenderAttributes | Overridden.
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeImage | Shoulds the serialize image.
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

See Also

Reference

Button Class
Gizmox.WebGUI.Forms Namespace


FireEvent Method

[image]
Gizmox.WebGUI.Forms
FireEvent Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Button Class : FireEvent Method

objEvent
event.
Fires an event.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub FireEvent( _
   ByVal objEvent As IEvent _
)
Visual Basic (Usage) Copy Code
Dim instance As Button
Dim objEvent As IEvent

instance.FireEvent(objEvent)
C#
protected override void FireEvent(
   IEvent objEvent
)
Managed Extensions for C++
protected: void FireEvent(
   IEvent* objEvent
) override
C++/CLI
protected:
void FireEvent(
   IEvent^ objEvent
) override

Parameters

objEvent
event.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Button Class
Button Members


NotifyDefault Method

[image]
Gizmox.WebGUI.Forms
NotifyDefault Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Button Class : NotifyDefault Method

value
Value.
Notifies the default.

Syntax

Visual Basic (Declaration)
Public Sub NotifyDefault( _
   ByVal value As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As Button
Dim value As Boolean

instance.NotifyDefault(value)
C#
public void NotifyDefault(
   bool value
)
Managed Extensions for C++
public: void NotifyDefault(
   bool value
)
C++/CLI
public:
void NotifyDefault(
   bool value
)

Parameters

value
Value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Button Class
Button Members


PerformClick Method

[image]
Gizmox.WebGUI.Forms
PerformClick Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Button Class : PerformClick Method

Performs the click.

Syntax

Visual Basic (Declaration)
Public Sub PerformClick()
Visual Basic (Usage) Copy Code
Dim instance As Button

instance.PerformClick()
C#
public void PerformClick()
Managed Extensions for C++
public: void PerformClick();
C++/CLI
public:
void PerformClick();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Button Class
Button Members


RenderAttributes Method

[image]
Gizmox.WebGUI.Forms
RenderAttributes Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Button Class : RenderAttributes Method

objContext
objWriter

Syntax

Visual Basic (Declaration)
Protected Overrides Sub RenderAttributes( _
   ByVal objContext As IContext, _
   ByVal objWriter As IAttributeWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As Button
Dim objContext As IContext
Dim objWriter As IAttributeWriter

instance.RenderAttributes(objContext, objWriter)
C#
protected override void RenderAttributes(
   IContext objContext,
   IAttributeWriter objWriter
)
Managed Extensions for C++
protected: void RenderAttributes(
   IContext* objContext,
   IAttributeWriter* objWriter
) override
C++/CLI
protected:
void RenderAttributes(
   IContext^ objContext,
   IAttributeWriter^ objWriter
) override

Parameters

objContext
objWriter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Button Class
Button Members


ShouldSerializeImage Method

[image]
Gizmox.WebGUI.Forms
ShouldSerializeImage Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Button Class : ShouldSerializeImage Method

Shoulds the serialize image.

Syntax

Visual Basic (Declaration)
Protected Function ShouldSerializeImage() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Button
Dim value As Boolean

value = instance.ShouldSerializeImage()
C#
protected bool ShouldSerializeImage()
Managed Extensions for C++
protected: bool ShouldSerializeImage();
C++/CLI
protected:
bool ShouldSerializeImage();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Button Class
Button Members


ToString Method

[image]
Gizmox.WebGUI.Forms
ToString Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Button Class : ToString Method

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As Button
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Button Class
Button Members


Button Class Properties

[image]
Gizmox.WebGUI.Forms
Button Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : Button Class

For a list of all members of this type, see Button members.

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | ButtonStyle | Gets or sets the button style.
Public Property | CanFocus | Overridden.
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | ClickOnce | Gets or sets the ClickOnce property.
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | DialogResult | Gets or sets a value that is returned to the parent form when the button is clicked.
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | DropDownMenu | Defines a dropdown menu to the button
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | FlatStyle | Gets or sets the flat style.
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | Image | Gets or sets the image that is displayed on a button control.
Public Property | ImageAlign | Gets or sets the alignment of the image on the button control.
Public Property | ImageIndex | Gets or sets the index of the image that is displayed for the item.
Public Property | ImageKey | Gets or sets the key for the image that is displayed for the item.
Public Property | ImageList | Gets or sets the ImageList to use when displaying items as small icons in the control.
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Overridden. Gets or sets the text.
Public Property | TextAlign | Gets or sets the text align.
Public Property | TextImageRelation | Gets or sets the position of text and image relative to each other.
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | Overridden.
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | Overridden.
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

See Also

Reference

Button Class
Gizmox.WebGUI.Forms Namespace


ButtonStyle Property

[image]
Gizmox.WebGUI.Forms
ButtonStyle Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Button Class : ButtonStyle Property

Gets or sets the button style.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property ButtonStyle As ButtonStyle
Visual Basic (Usage) Copy Code
Dim instance As Button
Dim value As ButtonStyle

instance.ButtonStyle = value

value = instance.ButtonStyle
C#
[DefaultValueAttribute()]
public ButtonStyle ButtonStyle {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property ButtonStyle get_ButtonStyle();
public: __property void set_ButtonStyle(
   ButtonStyle value
);
C++/CLI
[DefaultValueAttribute()]
public:
property ButtonStyle ButtonStyle {
   ButtonStyle get();
   void set (ButtonStylevalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Button Class
Button Members


CanFocus Property

[image]
Gizmox.WebGUI.Forms
CanFocus Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Button Class : CanFocus Property

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanFocus As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Button
Dim value As Boolean

value = instance.CanFocus
C#
public override bool CanFocus {get;}
Managed Extensions for C++
public: __property bool get_CanFocus() override;
C++/CLI
public:
property bool CanFocus {
   bool get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Button Class
Button Members


ClickOnce Property

[image]
Gizmox.WebGUI.Forms
ClickOnce Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Button Class : ClickOnce Property

Gets or sets the ClickOnce property.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("ControlClickOnceDescr")>
<SRCategoryAttribute("Behavior")>
<DefaultValueAttribute()>
Public Property ClickOnce As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Button
Dim value As Boolean

instance.ClickOnce = value

value = instance.ClickOnce
C#
[SRDescriptionAttribute("ControlClickOnceDescr")]
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
public bool ClickOnce {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("ControlClickOnceDescr")]
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
public: __property bool get_ClickOnce();
public: __property void set_ClickOnce(
   bool value
);
C++/CLI
[SRDescriptionAttribute("ControlClickOnceDescr")]
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
public:
property bool ClickOnce {
   bool get();
   void set (boolvalue);
}

Return Value

The key down filter.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Button Class
Button Members


DefaultBorderStyle Property

[image]
Gizmox.WebGUI.Forms
DefaultBorderStyle Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Button Class : DefaultBorderStyle Property

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property DefaultBorderStyle As BorderStyle
Visual Basic (Usage) Copy Code
Dim instance As Button
Dim value As BorderStyle

value = instance.DefaultBorderStyle
C#
protected override BorderStyle DefaultBorderStyle {get;}
Managed Extensions for C++
protected: __property BorderStyle get_DefaultBorderStyle() override;
C++/CLI
protected:
property BorderStyle DefaultBorderStyle {
   BorderStyle get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Button Class
Button Members


DefaultSize Property

[image]
Gizmox.WebGUI.Forms
DefaultSize Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Button Class : DefaultSize Property

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property DefaultSize As Size
Visual Basic (Usage) Copy Code
Dim instance As Button
Dim value As Size

value = instance.DefaultSize
C#
protected override Size DefaultSize {get;}
Managed Extensions for C++
protected: __property Size get_DefaultSize() override;
C++/CLI
protected:
property Size DefaultSize {
   Size get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Button Class
Button Members


DialogResult Property

[image]
Gizmox.WebGUI.Forms
DialogResult Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Button Class : DialogResult Property

Gets or sets a value that is returned to the parent form when the button is clicked.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property DialogResult As DialogResult
Visual Basic (Usage) Copy Code
Dim instance As Button
Dim value As DialogResult

instance.DialogResult = value

value = instance.DialogResult
C#
[DefaultValueAttribute()]
public DialogResult DialogResult {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property DialogResult get_DialogResult();
public: __property void set_DialogResult(
   DialogResult value
);
C++/CLI
[DefaultValueAttribute()]
public:
property DialogResult DialogResult {
   DialogResult get();
   void set (DialogResultvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Button Class
Button Members


DropDownMenu Property

[image]
Gizmox.WebGUI.Forms
DropDownMenu Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Button Class : DropDownMenu Property

Defines a dropdown menu to the button

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property DropDownMenu As Menu
Visual Basic (Usage) Copy Code
Dim instance As Button
Dim value As Menu

instance.DropDownMenu = value

value = instance.DropDownMenu
C#
[DefaultValueAttribute()]
public Menu DropDownMenu {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property Menu* get_DropDownMenu();
public: __property void set_DropDownMenu(
   Menu* value
);
C++/CLI
[DefaultValueAttribute()]
public:
property Menu^ DropDownMenu {
   Menu^ get();
   void set (Menu^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Button Class
Button Members


FlatStyle Property

[image]
Gizmox.WebGUI.Forms
FlatStyle Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Button Class : FlatStyle Property

Gets or sets the flat style.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property FlatStyle As FlatStyle
Visual Basic (Usage) Copy Code
Dim instance As Button
Dim value As FlatStyle

instance.FlatStyle = value

value = instance.FlatStyle
C#
[DefaultValueAttribute()]
public FlatStyle FlatStyle {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property FlatStyle get_FlatStyle();
public: __property void set_FlatStyle(
   FlatStyle value
);
C++/CLI
[DefaultValueAttribute()]
public:
property FlatStyle FlatStyle {
   FlatStyle get();
   void set (FlatStylevalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Button Class
Button Members


Image Property

[image]
Gizmox.WebGUI.Forms
Image Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Button Class : Image Property

Gets or sets the image that is displayed on a button control.

Syntax

Visual Basic (Declaration)
Public Property Image As ResourceHandle
Visual Basic (Usage) Copy Code
Dim instance As Button
Dim value As ResourceHandle

instance.Image = value

value = instance.Image
C#
public ResourceHandle Image {get; set;}
Managed Extensions for C++
public: __property ResourceHandle* get_Image();
public: __property void set_Image(
   ResourceHandle* value
);
C++/CLI
public:
property ResourceHandle^ Image {
   ResourceHandle^ get();
   void set (ResourceHandle^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Button Class
Button Members


ImageAlign Property

[image]
Gizmox.WebGUI.Forms
ImageAlign Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Button Class : ImageAlign Property

Gets or sets the alignment of the image on the button control.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property ImageAlign As ContentAlignment
Visual Basic (Usage) Copy Code
Dim instance As Button
Dim value As ContentAlignment

instance.ImageAlign = value

value = instance.ImageAlign
C#
[DefaultValueAttribute()]
public ContentAlignment ImageAlign {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property ContentAlignment get_ImageAlign();
public: __property void set_ImageAlign(
   ContentAlignment value
);
C++/CLI
[DefaultValueAttribute()]
public:
property ContentAlignment ImageAlign {
   ContentAlignment get();
   void set (ContentAlignmentvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Button Class
Button Members


ImageIndex Property

[image]
Gizmox.WebGUI.Forms
ImageIndex Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Button Class : ImageIndex Property

Gets or sets the index of the image that is displayed for the item.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Behavior")>
<TypeConverterAttribute("Gizmox.WebGUI.Forms.Design.NoneExcludedImageIndexConverter, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")>
<DefaultValueAttribute()>
<RefreshPropertiesAttribute()>
<SRDescriptionAttribute("The ImageList index value of the image displayed when the list view item is in the unselected state.")>
<LocalizableAttribute(True)>
<EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.ImageIndexEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")>
Public Property ImageIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As Button
Dim value As Integer

instance.ImageIndex = value

value = instance.ImageIndex
C#
[SRCategoryAttribute("Behavior")]
[TypeConverterAttribute("Gizmox.WebGUI.Forms.Design.NoneExcludedImageIndexConverter, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[DefaultValueAttribute()]
[RefreshPropertiesAttribute()]
[SRDescriptionAttribute("The ImageList index value of the image displayed when the list view item is in the unselected state.")]
[LocalizableAttribute(true)]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.ImageIndexEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
public int ImageIndex {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Behavior")]
[TypeConverterAttribute("Gizmox.WebGUI.Forms.Design.NoneExcludedImageIndexConverter, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[DefaultValueAttribute()]
[RefreshPropertiesAttribute()]
[SRDescriptionAttribute("The ImageList index value of the image displayed when the list view item is in the unselected state.")]
[LocalizableAttribute(true)]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.ImageIndexEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
public: __property int get_ImageIndex();
public: __property void set_ImageIndex(
   int value
);
C++/CLI
[SRCategoryAttribute("Behavior")]
[TypeConverterAttribute("Gizmox.WebGUI.Forms.Design.NoneExcludedImageIndexConverter, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[DefaultValueAttribute()]
[RefreshPropertiesAttribute()]
[SRDescriptionAttribute("The ImageList index value of the image displayed when the list view item is in the unselected state.")]
[LocalizableAttribute(true)]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.ImageIndexEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
public:
property int ImageIndex {
   int get();
   void set (intvalue);
}

Exceptions

Exception | Description
ArgumentException | The value specified is less than -1.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Button Class
Button Members


ImageKey Property

[image]
Gizmox.WebGUI.Forms
ImageKey Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Button Class : ImageKey Property

Gets or sets the key for the image that is displayed for the item.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.ImageIndexEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")>
<TypeConverterAttribute("Gizmox.WebGUI.Forms.Design.ImageKeyConverter, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")>
<SRCategoryAttribute("Behavior")>
<RefreshPropertiesAttribute()>
<LocalizableAttribute(True)>
Public Property ImageKey As String
Visual Basic (Usage) Copy Code
Dim instance As Button
Dim value As String

instance.ImageKey = value

value = instance.ImageKey
C#
[DefaultValueAttribute()]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.ImageIndexEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[TypeConverterAttribute("Gizmox.WebGUI.Forms.Design.ImageKeyConverter, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[SRCategoryAttribute("Behavior")]
[RefreshPropertiesAttribute()]
[LocalizableAttribute(true)]
public string ImageKey {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.ImageIndexEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[TypeConverterAttribute("Gizmox.WebGUI.Forms.Design.ImageKeyConverter, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[SRCategoryAttribute("Behavior")]
[RefreshPropertiesAttribute()]
[LocalizableAttribute(true)]
public: __property string* get_ImageKey();
public: __property void set_ImageKey(
   string* value
);
C++/CLI
[DefaultValueAttribute()]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.ImageIndexEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[TypeConverterAttribute("Gizmox.WebGUI.Forms.Design.ImageKeyConverter, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[SRCategoryAttribute("Behavior")]
[RefreshPropertiesAttribute()]
[LocalizableAttribute(true)]
public:
property String^ ImageKey {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Button Class
Button Members


ImageList Property

[image]
Gizmox.WebGUI.Forms
ImageList Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Button Class : ImageList Property

Gets or sets the ImageList to use when displaying items as small icons in the control.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<SRCategoryAttribute("Behavior")>
<SRDescriptionAttribute("The ImageList control used by the ListView for images in all views except for the large icon view.")>
Public Property ImageList As ImageList
Visual Basic (Usage) Copy Code
Dim instance As Button
Dim value As ImageList

instance.ImageList = value

value = instance.ImageList
C#
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("The ImageList control used by the ListView for images in all views except for the large icon view.")]
public ImageList ImageList {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("The ImageList control used by the ListView for images in all views except for the large icon view.")]
public: __property ImageList* get_ImageList();
public: __property void set_ImageList(
   ImageList* value
);
C++/CLI
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("The ImageList control used by the ListView for images in all views except for the large icon view.")]
public:
property ImageList^ ImageList {
   ImageList^ get();
   void set (ImageList^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Button Class
Button Members


Text Property

[image]
Gizmox.WebGUI.Forms
Text Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Button Class : Text Property

Gets or sets the text.

Syntax

Visual Basic (Declaration)
Public Overrides Property Text As String
Visual Basic (Usage) Copy Code
Dim instance As Button
Dim value As String

instance.Text = value

value = instance.Text
C#
public override string Text {get; set;}
Managed Extensions for C++
public: __property string* get_Text() override;
public: __property void set_Text(
   string* value
) override;
C++/CLI
public:
property String^ Text {
   String^ get() override;
   void set (String^value) override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Button Class
Button Members


TextAlign Property

[image]
Gizmox.WebGUI.Forms
TextAlign Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Button Class : TextAlign Property

Gets or sets the text align.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property TextAlign As ContentAlignment
Visual Basic (Usage) Copy Code
Dim instance As Button
Dim value As ContentAlignment

instance.TextAlign = value

value = instance.TextAlign
C#
[DefaultValueAttribute()]
public ContentAlignment TextAlign {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property ContentAlignment get_TextAlign();
public: __property void set_TextAlign(
   ContentAlignment value
);
C++/CLI
[DefaultValueAttribute()]
public:
property ContentAlignment TextAlign {
   ContentAlignment get();
   void set (ContentAlignmentvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Button Class
Button Members


TextImageRelation Property

[image]
Gizmox.WebGUI.Forms
TextImageRelation Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Button Class : TextImageRelation Property

Gets or sets the position of text and image relative to each other.

Syntax

Visual Basic (Declaration)
<LocalizableAttribute(False)>
<SRDescriptionAttribute("Specifies the relative location of the image to the text on the button.")>
<SRCategoryAttribute("Appearance")>
<DefaultValueAttribute()>
Public Property TextImageRelation As TextImageRelation
Visual Basic (Usage) Copy Code
Dim instance As Button
Dim value As TextImageRelation

instance.TextImageRelation = value

value = instance.TextImageRelation
C#
[LocalizableAttribute(false)]
[SRDescriptionAttribute("Specifies the relative location of the image to the text on the button.")]
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
public TextImageRelation TextImageRelation {get; set;}
Managed Extensions for C++
[LocalizableAttribute(false)]
[SRDescriptionAttribute("Specifies the relative location of the image to the text on the button.")]
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
public: __property TextImageRelation get_TextImageRelation();
public: __property void set_TextImageRelation(
   TextImageRelation value
);
C++/CLI
[LocalizableAttribute(false)]
[SRDescriptionAttribute("Specifies the relative location of the image to the text on the button.")]
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
public:
property TextImageRelation TextImageRelation {
   TextImageRelation get();
   void set (TextImageRelationvalue);
}

Exceptions

Exception | Description
InvalidEnumArgumentException | The value is not one of the TextImageRelation values.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Button Class
Button Members


CheckBox Class

[image]
Gizmox.WebGUI.Forms
CheckBox Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : CheckBox Class

A checkBox control.

Object Model

Syntax

Visual Basic (Declaration)
<ToolboxBitmapAttribute()>
<DesignTimeControllerAttribute()>
<ClientControllerAttribute()>
<MetadataTagAttribute("CH")>
<SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableCheckBox, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")>
<ToolboxItemCategoryAttribute("Common Controls")>
<ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
Public Class CheckBox
   Inherits Control
   Implements IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Visual Basic (Usage) Copy Code
Dim instance As CheckBox
C#
[ToolboxBitmapAttribute()]
[DesignTimeControllerAttribute()]
[ClientControllerAttribute()]
[MetadataTagAttribute("CH")]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableCheckBox, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[ToolboxItemCategoryAttribute("Common Controls")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
public class CheckBox : Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Managed Extensions for C++
[ToolboxBitmapAttribute()]
[DesignTimeControllerAttribute()]
[ClientControllerAttribute()]
[MetadataTagAttribute("CH")]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableCheckBox, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[ToolboxItemCategoryAttribute("Common Controls")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
public __gc class CheckBox : public Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
C++/CLI
[ToolboxBitmapAttribute()]
[DesignTimeControllerAttribute()]
[ClientControllerAttribute()]
[MetadataTagAttribute("CH")]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableCheckBox, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[ToolboxItemCategoryAttribute("Common Controls")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
public ref class CheckBox : public Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.CheckBox

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

CheckBox Members
Gizmox.WebGUI.Forms Namespace


CheckBox Class Members

[image]
Gizmox.WebGUI.Forms
CheckBox Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : CheckBox Class

The following tables list the members exposed by CheckBox.

Public Constructors

 | Name | Description
Public Constructor | CheckBox Constructor | Creates a new CheckBox instance.
Top

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | AutoCheck | Gets or set a value indicating whether the Checked or CheckState values and the CheckBox's appearance are automatically changed when the CheckBox is clicked.
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | CheckAlign | Gets or sets the horizontal and vertical alignment of the check mark on a CheckBox control.
Public Property | Checked | Gets or sets a value indicating whether this CheckBox is checked.
Public Property | CheckState |
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | FlatStyle | Gets or sets the flat style.
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Control)
Public Property | ThreeState | Gets or sets a value indicating whether the check box will allow three check states rather than two.
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | Overridden.
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Overridden. Fires an event.
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Overridden. Gets the critical events.
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from Control)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnCheckedChanged | Raises the CheckedChanged event.
Protected Method | OnCheckedChangedQueued | Raises the CheckedChangedQueued event
Protected Method | OnCheckStateChanged | Raises the CheckStateChanged event.
Protected Method | OnCheckStateChangedQueued | Raises the CheckStateChanged event.
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Control)
Protected Method | RenderAttributes | Overridden.
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | Overridden.
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | CheckedChanged | Occurs when the value of the Checked property changes.
Public Event | CheckedChangedQueued | Occurs when the value of the Checked property changes (Queued).
Public Event | CheckStateChanged | Occurs when the value of the CheckState property changes.
Public Event | CheckStateChangedQueued | Occurs when the value of the CheckState property changes (Queued).
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

CheckBox Class
Gizmox.WebGUI.Forms Namespace


CheckBox Constructor

[image]
Gizmox.WebGUI.Forms
CheckBox Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CheckBox Class : CheckBox Constructor

Creates a new CheckBox instance.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As CheckBox()
C#
public CheckBox()
Managed Extensions for C++
public: CheckBox();
C++/CLI
public:
CheckBox();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CheckBox Class
CheckBox Members


CheckBox Class Methods

[image]
Gizmox.WebGUI.Forms
CheckBox Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : CheckBox Class

For a list of all members of this type, see CheckBox members.

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | Overridden.
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Overridden. Fires an event.
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Overridden. Gets the critical events.
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from Control)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnCheckedChanged | Raises the CheckedChanged event.
Protected Method | OnCheckedChangedQueued | Raises the CheckedChangedQueued event
Protected Method | OnCheckStateChanged | Raises the CheckStateChanged event.
Protected Method | OnCheckStateChangedQueued | Raises the CheckStateChanged event.
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Control)
Protected Method | RenderAttributes | Overridden.
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | Overridden.
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

See Also

Reference

CheckBox Class
Gizmox.WebGUI.Forms Namespace


FireEvent Method

[image]
Gizmox.WebGUI.Forms
FireEvent Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CheckBox Class : FireEvent Method

objEvent
event.
Fires an event.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub FireEvent( _
   ByVal objEvent As IEvent _
)
Visual Basic (Usage) Copy Code
Dim instance As CheckBox
Dim objEvent As IEvent

instance.FireEvent(objEvent)
C#
protected override void FireEvent(
   IEvent objEvent
)
Managed Extensions for C++
protected: void FireEvent(
   IEvent* objEvent
) override
C++/CLI
protected:
void FireEvent(
   IEvent^ objEvent
) override

Parameters

objEvent
event.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CheckBox Class
CheckBox Members


GetCriticalEvents Method

[image]
Gizmox.WebGUI.Forms
GetCriticalEvents Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CheckBox Class : GetCriticalEvents Method

Gets the critical events.

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetCriticalEvents() As EventTypes
Visual Basic (Usage) Copy Code
Dim instance As CheckBox
Dim value As EventTypes

value = instance.GetCriticalEvents()
C#
protected override EventTypes GetCriticalEvents()
Managed Extensions for C++
protected: EventTypes GetCriticalEvents(); override
C++/CLI
protected:
EventTypes GetCriticalEvents(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CheckBox Class
CheckBox Members


OnCheckedChanged Method

[image]
Gizmox.WebGUI.Forms
OnCheckedChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CheckBox Class : OnCheckedChanged Method

eventargs
Raises the CheckedChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnCheckedChanged( _
   ByVal eventargs As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As CheckBox
Dim eventargs As EventArgs

instance.OnCheckedChanged(eventargs)
C#
protected virtual void OnCheckedChanged(
   EventArgs eventargs
)
Managed Extensions for C++
protected: virtual void OnCheckedChanged(
   EventArgs* eventargs
)
C++/CLI
protected:
virtual void OnCheckedChanged(
   EventArgs^ eventargs
)

Parameters

eventargs

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CheckBox Class
CheckBox Members


OnCheckedChangedQueued Method

[image]
Gizmox.WebGUI.Forms
OnCheckedChangedQueued Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CheckBox Class : OnCheckedChangedQueued Method

eventargs
Raises the CheckedChangedQueued event

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnCheckedChangedQueued( _
   ByVal eventargs As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As CheckBox
Dim eventargs As EventArgs

instance.OnCheckedChangedQueued(eventargs)
C#
protected virtual void OnCheckedChangedQueued(
   EventArgs eventargs
)
Managed Extensions for C++
protected: virtual void OnCheckedChangedQueued(
   EventArgs* eventargs
)
C++/CLI
protected:
virtual void OnCheckedChangedQueued(
   EventArgs^ eventargs
)

Parameters

eventargs

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CheckBox Class
CheckBox Members


OnCheckStateChanged Method

[image]
Gizmox.WebGUI.Forms
OnCheckStateChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CheckBox Class : OnCheckStateChanged Method

eventargs
Raises the CheckStateChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnCheckStateChanged( _
   ByVal eventargs As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As CheckBox
Dim eventargs As EventArgs

instance.OnCheckStateChanged(eventargs)
C#
protected virtual void OnCheckStateChanged(
   EventArgs eventargs
)
Managed Extensions for C++
protected: virtual void OnCheckStateChanged(
   EventArgs* eventargs
)
C++/CLI
protected:
virtual void OnCheckStateChanged(
   EventArgs^ eventargs
)

Parameters

eventargs

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CheckBox Class
CheckBox Members


OnCheckStateChangedQueued Method

[image]
Gizmox.WebGUI.Forms
OnCheckStateChangedQueued Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CheckBox Class : OnCheckStateChangedQueued Method

eventargs
Raises the CheckStateChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnCheckStateChangedQueued( _
   ByVal eventargs As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As CheckBox
Dim eventargs As EventArgs

instance.OnCheckStateChangedQueued(eventargs)
C#
protected virtual void OnCheckStateChangedQueued(
   EventArgs eventargs
)
Managed Extensions for C++
protected: virtual void OnCheckStateChangedQueued(
   EventArgs* eventargs
)
C++/CLI
protected:
virtual void OnCheckStateChangedQueued(
   EventArgs^ eventargs
)

Parameters

eventargs

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CheckBox Class
CheckBox Members


RenderAttributes Method

[image]
Gizmox.WebGUI.Forms
RenderAttributes Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CheckBox Class : RenderAttributes Method

objContext
objWriter

Syntax

Visual Basic (Declaration)
Protected Overrides Sub RenderAttributes( _
   ByVal objContext As IContext, _
   ByVal objWriter As IAttributeWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As CheckBox
Dim objContext As IContext
Dim objWriter As IAttributeWriter

instance.RenderAttributes(objContext, objWriter)
C#
protected override void RenderAttributes(
   IContext objContext,
   IAttributeWriter objWriter
)
Managed Extensions for C++
protected: void RenderAttributes(
   IContext* objContext,
   IAttributeWriter* objWriter
) override
C++/CLI
protected:
void RenderAttributes(
   IContext^ objContext,
   IAttributeWriter^ objWriter
) override

Parameters

objContext
objWriter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CheckBox Class
CheckBox Members


RenderUpdatedAttributes Method

[image]
Gizmox.WebGUI.Forms
RenderUpdatedAttributes Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CheckBox Class : RenderUpdatedAttributes Method

objContext
objWriter
lngRequestID

Syntax

Visual Basic (Declaration)
Protected Overrides Sub RenderUpdatedAttributes( _
   ByVal objContext As IContext, _
   ByVal objWriter As IAttributeWriter, _
   ByVal lngRequestID As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As CheckBox
Dim objContext As IContext
Dim objWriter As IAttributeWriter
Dim lngRequestID As Long

instance.RenderUpdatedAttributes(objContext, objWriter, lngRequestID)
C#
protected override void RenderUpdatedAttributes(
   IContext objContext,
   IAttributeWriter objWriter,
   long lngRequestID
)
Managed Extensions for C++
protected: void RenderUpdatedAttributes(
   IContext* objContext,
   IAttributeWriter* objWriter,
   long lngRequestID
) override
C++/CLI
protected:
void RenderUpdatedAttributes(
   IContext^ objContext,
   IAttributeWriter^ objWriter,
   long long lngRequestID
) override

Parameters

objContext
objWriter
lngRequestID

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CheckBox Class
CheckBox Members


ToString Method

[image]
Gizmox.WebGUI.Forms
ToString Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CheckBox Class : ToString Method

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As CheckBox
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CheckBox Class
CheckBox Members


CheckBox Class Properties

[image]
Gizmox.WebGUI.Forms
CheckBox Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : CheckBox Class

For a list of all members of this type, see CheckBox members.

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | AutoCheck | Gets or set a value indicating whether the Checked or CheckState values and the CheckBox's appearance are automatically changed when the CheckBox is clicked.
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | CheckAlign | Gets or sets the horizontal and vertical alignment of the check mark on a CheckBox control.
Public Property | Checked | Gets or sets a value indicating whether this CheckBox is checked.
Public Property | CheckState |
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | FlatStyle | Gets or sets the flat style.
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Control)
Public Property | ThreeState | Gets or sets a value indicating whether the check box will allow three check states rather than two.
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

See Also

Reference

CheckBox Class
Gizmox.WebGUI.Forms Namespace


AutoCheck Property

[image]
Gizmox.WebGUI.Forms
AutoCheck Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CheckBox Class : AutoCheck Property

Gets or set a value indicating whether the Checked or CheckState values and the CheckBox's appearance are automatically changed when the CheckBox is clicked.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Behavior")>
<SRDescriptionAttribute("Causes the check box to automatically change state when clicked.")>
<DefaultValueAttribute()>
Public Property AutoCheck As Boolean
Visual Basic (Usage) Copy Code
Dim instance As CheckBox
Dim value As Boolean

instance.AutoCheck = value

value = instance.AutoCheck
C#
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Causes the check box to automatically change state when clicked.")]
[DefaultValueAttribute()]
public bool AutoCheck {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Causes the check box to automatically change state when clicked.")]
[DefaultValueAttribute()]
public: __property bool get_AutoCheck();
public: __property void set_AutoCheck(
   bool value
);
C++/CLI
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Causes the check box to automatically change state when clicked.")]
[DefaultValueAttribute()]
public:
property bool AutoCheck {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CheckBox Class
CheckBox Members


CheckAlign Property

[image]
Gizmox.WebGUI.Forms
CheckAlign Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CheckBox Class : CheckAlign Property

Gets or sets the horizontal and vertical alignment of the check mark on a CheckBox control.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Appearance")>
<BindableAttribute(True)>
<LocalizableAttribute(True)>
<DefaultValueAttribute()>
<SRDescriptionAttribute("Determines the location of the check box inside the control.")>
Public Property CheckAlign As ContentAlignment
Visual Basic (Usage) Copy Code
Dim instance As CheckBox
Dim value As ContentAlignment

instance.CheckAlign = value

value = instance.CheckAlign
C#
[SRCategoryAttribute("Appearance")]
[BindableAttribute(true)]
[LocalizableAttribute(true)]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Determines the location of the check box inside the control.")]
public ContentAlignment CheckAlign {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Appearance")]
[BindableAttribute(true)]
[LocalizableAttribute(true)]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Determines the location of the check box inside the control.")]
public: __property ContentAlignment get_CheckAlign();
public: __property void set_CheckAlign(
   ContentAlignment value
);
C++/CLI
[SRCategoryAttribute("Appearance")]
[BindableAttribute(true)]
[LocalizableAttribute(true)]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Determines the location of the check box inside the control.")]
public:
property ContentAlignment CheckAlign {
   ContentAlignment get();
   void set (ContentAlignmentvalue);
}

Exceptions

Exception | Description
InvalidEnumArgumentException | The value assigned is not one of the ContentAlignment enumeration values.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CheckBox Class
CheckBox Members


Checked Property

[image]
Gizmox.WebGUI.Forms
Checked Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CheckBox Class : Checked Property

Gets or sets a value indicating whether this CheckBox is checked.

Syntax

Visual Basic (Declaration)
Public Property Checked As Boolean
Visual Basic (Usage) Copy Code
Dim instance As CheckBox
Dim value As Boolean

instance.Checked = value

value = instance.Checked
C#
public bool Checked {get; set;}
Managed Extensions for C++
public: __property bool get_Checked();
public: __property void set_Checked(
   bool value
);
C++/CLI
public:
property bool Checked {
   bool get();
   void set (boolvalue);
}

Return Value

true if checked; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CheckBox Class
CheckBox Members


CheckState Property

[image]
Gizmox.WebGUI.Forms
CheckState Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CheckBox Class : CheckState Property

Syntax

Visual Basic (Declaration)
Public Property CheckState As CheckState
Visual Basic (Usage) Copy Code
Dim instance As CheckBox
Dim value As CheckState

instance.CheckState = value

value = instance.CheckState
C#
public CheckState CheckState {get; set;}
Managed Extensions for C++
public: __property CheckState get_CheckState();
public: __property void set_CheckState(
   CheckState value
);
C++/CLI
public:
property CheckState CheckState {
   CheckState get();
   void set (CheckStatevalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CheckBox Class
CheckBox Members


FlatStyle Property

[image]
Gizmox.WebGUI.Forms
FlatStyle Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CheckBox Class : FlatStyle Property

Gets or sets the flat style.

Syntax

Visual Basic (Declaration)
Public Property FlatStyle As FlatStyle
Visual Basic (Usage) Copy Code
Dim instance As CheckBox
Dim value As FlatStyle

instance.FlatStyle = value

value = instance.FlatStyle
C#
public FlatStyle FlatStyle {get; set;}
Managed Extensions for C++
public: __property FlatStyle get_FlatStyle();
public: __property void set_FlatStyle(
   FlatStyle value
);
C++/CLI
public:
property FlatStyle FlatStyle {
   FlatStyle get();
   void set (FlatStylevalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CheckBox Class
CheckBox Members


ThreeState Property

[image]
Gizmox.WebGUI.Forms
ThreeState Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CheckBox Class : ThreeState Property

Gets or sets a value indicating whether the check box will allow three check states rather than two.

Syntax

Visual Basic (Declaration)
Public Property ThreeState As Boolean
Visual Basic (Usage) Copy Code
Dim instance As CheckBox
Dim value As Boolean

instance.ThreeState = value

value = instance.ThreeState
C#
public bool ThreeState {get; set;}
Managed Extensions for C++
public: __property bool get_ThreeState();
public: __property void set_ThreeState(
   bool value
);
C++/CLI
public:
property bool ThreeState {
   bool get();
   void set (boolvalue);
}

Return Value

true if [three state]; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CheckBox Class
CheckBox Members


CheckBox Class Events

[image]
Gizmox.WebGUI.Forms
CheckBox Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : CheckBox Class

For a list of all members of this type, see CheckBox members.

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | CheckedChanged | Occurs when the value of the Checked property changes.
Public Event | CheckedChangedQueued | Occurs when the value of the Checked property changes (Queued).
Public Event | CheckStateChanged | Occurs when the value of the CheckState property changes.
Public Event | CheckStateChangedQueued | Occurs when the value of the CheckState property changes (Queued).
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

CheckBox Class
Gizmox.WebGUI.Forms Namespace


CheckedChanged Event

[image]
Gizmox.WebGUI.Forms
CheckedChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CheckBox Class : CheckedChanged Event

Occurs when the value of the Checked property changes.

Syntax

Visual Basic (Declaration)
Public Event CheckedChanged() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As CheckBox
Dim handler As EventHandler

AddHandler instance.CheckedChanged, handler
C#
public event EventHandler CheckedChanged()
Managed Extensions for C++
public: __event EventHandler* CheckedChanged
C++/CLI
public:
event EventHandler^ CheckedChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CheckBox Class
CheckBox Members


CheckedChangedQueued Event

[image]
Gizmox.WebGUI.Forms
CheckedChangedQueued Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CheckBox Class : CheckedChangedQueued Event

Occurs when the value of the Checked property changes (Queued).

Syntax

Visual Basic (Declaration)
Public Event CheckedChangedQueued() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As CheckBox
Dim handler As EventHandler

AddHandler instance.CheckedChangedQueued, handler
C#
public event EventHandler CheckedChangedQueued()
Managed Extensions for C++
public: __event EventHandler* CheckedChangedQueued
C++/CLI
public:
event EventHandler^ CheckedChangedQueued

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CheckBox Class
CheckBox Members


CheckStateChanged Event

[image]
Gizmox.WebGUI.Forms
CheckStateChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CheckBox Class : CheckStateChanged Event

Occurs when the value of the CheckState property changes.

Syntax

Visual Basic (Declaration)
Public Event CheckStateChanged() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As CheckBox
Dim handler As EventHandler

AddHandler instance.CheckStateChanged, handler
C#
public event EventHandler CheckStateChanged()
Managed Extensions for C++
public: __event EventHandler* CheckStateChanged
C++/CLI
public:
event EventHandler^ CheckStateChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CheckBox Class
CheckBox Members


CheckStateChangedQueued Event

[image]
Gizmox.WebGUI.Forms
CheckStateChangedQueued Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CheckBox Class : CheckStateChangedQueued Event

Occurs when the value of the CheckState property changes (Queued).

Syntax

Visual Basic (Declaration)
Public Event CheckStateChangedQueued() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As CheckBox
Dim handler As EventHandler

AddHandler instance.CheckStateChangedQueued, handler
C#
public event EventHandler CheckStateChangedQueued()
Managed Extensions for C++
public: __event EventHandler* CheckStateChangedQueued
C++/CLI
public:
event EventHandler^ CheckStateChangedQueued

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CheckBox Class
CheckBox Members


CheckedListBox Class

[image]
Gizmox.WebGUI.Forms
CheckedListBox Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : CheckedListBox Class

Summary description for CheckedListBox.

Object Model

Syntax

Visual Basic (Declaration)
<ClientControllerAttribute()>
<ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableCheckedListBox, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")>
<ToolboxBitmapAttribute()>
<DesignTimeControllerAttribute()>
<ToolboxItemCategoryAttribute("Common Controls")>
<MetadataTagAttribute("CX")>
Public Class CheckedListBox
   Inherits ListBox
   Implements IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Visual Basic (Usage) Copy Code
Dim instance As CheckedListBox
C#
[ClientControllerAttribute()]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableCheckedListBox, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[ToolboxBitmapAttribute()]
[DesignTimeControllerAttribute()]
[ToolboxItemCategoryAttribute("Common Controls")]
[MetadataTagAttribute("CX")]
public class CheckedListBox : ListBox, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Managed Extensions for C++
[ClientControllerAttribute()]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableCheckedListBox, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[ToolboxBitmapAttribute()]
[DesignTimeControllerAttribute()]
[ToolboxItemCategoryAttribute("Common Controls")]
[MetadataTagAttribute("CX")]
public __gc class CheckedListBox : public ListBox, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
C++/CLI
[ClientControllerAttribute()]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableCheckedListBox, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[ToolboxBitmapAttribute()]
[DesignTimeControllerAttribute()]
[ToolboxItemCategoryAttribute("Common Controls")]
[MetadataTagAttribute("CX")]
public ref class CheckedListBox : public ListBox, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.ListControl
Gizmox.WebGUI.Forms.ListBox
Gizmox.WebGUI.Forms.CheckedListBox

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

CheckedListBox Members
Gizmox.WebGUI.Forms Namespace


CheckedListBox Class Members

[image]
Gizmox.WebGUI.Forms
CheckedListBox Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : CheckedListBox Class

The following tables list the members exposed by CheckedListBox.

Public Constructors

 | Name | Description
Public Constructor | CheckedListBox Constructor | Creates a new CheckedListBox instance.
Top

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | CheckBoxes | Gets or sets a value indicating whether [check boxes]. (Inherited from ListBox)
Public Property | CheckedIndices | Collection of checked indexes in this CheckedListBox.
Public Property | CheckedItems | Collection of checked items in this CheckedListBox.
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | DataSource | Gets or sets the data source for this ListControl. (Inherited from ListControl)
Public Property | DisplayMember | Gets or sets the property to display for this ListControl. (Inherited from ListControl)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | FormatInfo | Gets or sets the IFormatProvider that provides custom formatting behavior. (Inherited from ListControl)
Public Property | FormatString | Gets or sets the format-specifier characters that indicate how a value is to be displayed. (Inherited from ListControl)
Public Property | FormattingEnabled | Gets or sets a value indicating whether formatting is applied to the ListControl.DisplayMember property of the ListControl. (Inherited from ListControl)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | Items |
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | RadioBoxes | Gets or sets a value indicating whether [radio boxes]. (Inherited from ListBox)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | SelectedIndex | Gets or sets the zero-based index of the currently selected item in a ListBox. (Inherited from ListBox)
Public Property | SelectedIndices | Gets a collection that contains the zero-based indexes of all currently selected items in the ListBox. (Inherited from ListBox)
Public Property | SelectedItem | Gets or sets the currently selected item in the ListBox. (Inherited from ListBox)
Public Property | SelectedItems | Gets a collection containing the currently selected items in the ListBox. (Inherited from ListBox)
Public Property | SelectedValue | Gets or sets the value of the member property specified by the ListControl.ValueMember property. (Inherited from ListControl)
Public Property | SelectionMode | Gets or sets the method in which items are selected in the ListBox. (Inherited from ListBox)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | Sorted | Gets or sets a value indicating whether the items in the ListBox are sorted alphabetically. (Inherited from ListBox)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Control)
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | ValueMember | Gets or sets the property to use as the actual value for the items in the ListControl. (Inherited from ListControl)
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | AllowSelection | Gets a value indicating whether the list enables selection of list items. (Inherited from ListControl)
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DataManager | Gets the CurrencyManager associated with this control. (Inherited from ListControl)
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | Gets a value indicating whether this instance is delayed drawing. (Inherited from ListBox)
Protected Property | IsPostBackRequired | Indicates if the list control context requires its events to cause callback (Inherited from ListControl)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | ClearSelected | Unselects all items in the ListBox. (Inherited from ListBox)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | FindString | Overloaded. Finds the first item in the ListBox that starts with the specified string. (Inherited from ListBox)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetItemChecked | Gets the item checked value.
Public Method | GetItemText | Returns the text representation of the specified item. (Inherited from ListControl)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetItemChecked | Sets the item checked status.
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | SetSelected | Selects or clears the selection for the specified item in a ListBox. (Inherited from ListBox)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | SwapItems | Overridden. Swaps the items.
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | CreateItemCollection | Overridden.
Protected Method | FilterItemOnProperty | Overloaded. Retrieves the current value of the ListControl item, if it is a property of an object, given the item. (Inherited from ListControl)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Overridden. Fires an event.
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Overridden. Gets the critical events.
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from Control)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from ListControl)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDataSourceChanged | Raises the ListControl.DataSourceChanged event. (Inherited from ListBox)
Protected Method | OnDisplayMemberChanged | (Inherited from ListBox)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnFormat | Raises the ListControl.Format event. (Inherited from ListControl)
Protected Method | OnFormatInfoChanged | Raises the ListControl.FormatInfoChanged event. (Inherited from ListControl)
Protected Method | OnFormatStringChanged | Raises the ListControl.FormatStringChanged event. (Inherited from ListControl)
Protected Method | OnFormattingEnabledChanged | Raises the ListControl.FormattingEnabledChanged event. (Inherited from ListControl)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnItemCheck | Raises the ItemCheck event.
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnSelectedIndexChanged | (Inherited from ListBox)
Protected Method | OnSelectedValueChanged | Raises the ListControl.SelectedValueChanged event. (Inherited from ListControl)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnValueMemberChanged | Raises the ListControl.ValueMemberChanged event. (Inherited from ListControl)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RefreshItem | When overridden in a derived class, resynchronizes the data of the object at the specified index with the contents of the data source. (Inherited from ListBox)
Protected Method | RefreshItems | Refreshes all ListBox items and retrieves new strings for them. (Inherited from ListBox)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | Renders the current control. (Inherited from ListBox)
Protected Method | RenderAttributes | Renders the controls meta attributes (Inherited from Control)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderItemAttributes | Overridden. Renders the item attributes.
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetItemCore | When overridden in a derived class, sets the object with the specified index in the derived class. (Inherited from ListControl)
Protected Method | SetItemsCore | When overridden in a derived class, sets the specified array of objects in a collection in the derived class. (Inherited from ListBox)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSelectionMode | Overridden.
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | Sort | Sorts the items in the ListBox. (Inherited from ListBox)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | DataSourceChanged | Occurs when the ListControl.DataSource changes. (Inherited from ListControl)
Public Event | DisplayMemberChanged | Occurs when the ListControl.DisplayMember property changes. (Inherited from ListControl)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | Format | Occurs when the control is bound to a data value. (Inherited from ListControl)
Public Event | FormatInfoChanged | Occurs when the value of the ListControl.FormatInfo property changes. (Inherited from ListControl)
Public Event | FormatStringChanged | Occurs when value of the ListControl.FormatString property changes (Inherited from ListControl)
Public Event | FormattingEnabledChanged | Occurs when the value of the ListControl.FormattingEnabled property changes. (Inherited from ListControl)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | ItemCheck | Occurs when the checked state of an item changes.
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | SelectedIndexChanged | Occurs when the SelectedIndex property has changed. (Inherited from ListBox)
Public Event | SelectedValueChanged | Occurs when the ListControl.SelectedValue property changes. (Inherited from ListControl)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | ValueMemberChanged | Occurs when the ListControl.ValueMember property changes. (Inherited from ListControl)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

CheckedListBox Class
Gizmox.WebGUI.Forms Namespace


CheckedListBox Constructor

[image]
Gizmox.WebGUI.Forms
CheckedListBox Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CheckedListBox Class : CheckedListBox Constructor

Creates a new CheckedListBox instance.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As CheckedListBox()
C#
public CheckedListBox()
Managed Extensions for C++
public: CheckedListBox();
C++/CLI
public:
CheckedListBox();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CheckedListBox Class
CheckedListBox Members


CheckedListBox Class Methods

[image]
Gizmox.WebGUI.Forms
CheckedListBox Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : CheckedListBox Class

For a list of all members of this type, see CheckedListBox members.

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | ClearSelected | Unselects all items in the ListBox. (Inherited from ListBox)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | FindString | Overloaded. Finds the first item in the ListBox that starts with the specified string. (Inherited from ListBox)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetItemChecked | Gets the item checked value.
Public Method | GetItemText | Returns the text representation of the specified item. (Inherited from ListControl)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetItemChecked | Sets the item checked status.
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | SetSelected | Selects or clears the selection for the specified item in a ListBox. (Inherited from ListBox)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | SwapItems | Overridden. Swaps the items.
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | CreateItemCollection | Overridden.
Protected Method | FilterItemOnProperty | Overloaded. Retrieves the current value of the ListControl item, if it is a property of an object, given the item. (Inherited from ListControl)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Overridden. Fires an event.
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Overridden. Gets the critical events.
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from Control)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from ListControl)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDataSourceChanged | Raises the ListControl.DataSourceChanged event. (Inherited from ListBox)
Protected Method | OnDisplayMemberChanged | (Inherited from ListBox)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnFormat | Raises the ListControl.Format event. (Inherited from ListControl)
Protected Method | OnFormatInfoChanged | Raises the ListControl.FormatInfoChanged event. (Inherited from ListControl)
Protected Method | OnFormatStringChanged | Raises the ListControl.FormatStringChanged event. (Inherited from ListControl)
Protected Method | OnFormattingEnabledChanged | Raises the ListControl.FormattingEnabledChanged event. (Inherited from ListControl)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnItemCheck | Raises the ItemCheck event.
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnSelectedIndexChanged | (Inherited from ListBox)
Protected Method | OnSelectedValueChanged | Raises the ListControl.SelectedValueChanged event. (Inherited from ListControl)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnValueMemberChanged | Raises the ListControl.ValueMemberChanged event. (Inherited from ListControl)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RefreshItem | When overridden in a derived class, resynchronizes the data of the object at the specified index with the contents of the data source. (Inherited from ListBox)
Protected Method | RefreshItems | Refreshes all ListBox items and retrieves new strings for them. (Inherited from ListBox)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | Renders the current control. (Inherited from ListBox)
Protected Method | RenderAttributes | Renders the controls meta attributes (Inherited from Control)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderItemAttributes | Overridden. Renders the item attributes.
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetItemCore | When overridden in a derived class, sets the object with the specified index in the derived class. (Inherited from ListControl)
Protected Method | SetItemsCore | When overridden in a derived class, sets the specified array of objects in a collection in the derived class. (Inherited from ListBox)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSelectionMode | Overridden.
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | Sort | Sorts the items in the ListBox. (Inherited from ListBox)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

See Also

Reference

CheckedListBox Class
Gizmox.WebGUI.Forms Namespace


CreateItemCollection Method

[image]
Gizmox.WebGUI.Forms
CreateItemCollection Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CheckedListBox Class : CreateItemCollection Method

Syntax

Visual Basic (Declaration)
Protected Overrides Function CreateItemCollection() As ListBox.ObjectCollection
Visual Basic (Usage) Copy Code
Dim instance As CheckedListBox
Dim value As ListBox.ObjectCollection

value = instance.CreateItemCollection()
C#
protected override ListBox.ObjectCollection CreateItemCollection()
Managed Extensions for C++
protected: ListBox.ObjectCollection* CreateItemCollection(); override
C++/CLI
protected:
ListBox::ObjectCollection^ CreateItemCollection(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CheckedListBox Class
CheckedListBox Members


FireEvent Method

[image]
Gizmox.WebGUI.Forms
FireEvent Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CheckedListBox Class : FireEvent Method

objEvent
event.
Fires an event.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub FireEvent( _
   ByVal objEvent As IEvent _
)
Visual Basic (Usage) Copy Code
Dim instance As CheckedListBox
Dim objEvent As IEvent

instance.FireEvent(objEvent)
C#
protected override void FireEvent(
   IEvent objEvent
)
Managed Extensions for C++
protected: void FireEvent(
   IEvent* objEvent
) override
C++/CLI
protected:
void FireEvent(
   IEvent^ objEvent
) override

Parameters

objEvent
event.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CheckedListBox Class
CheckedListBox Members


GetCriticalEvents Method

[image]
Gizmox.WebGUI.Forms
GetCriticalEvents Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CheckedListBox Class : GetCriticalEvents Method

Gets the critical events.

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetCriticalEvents() As EventTypes
Visual Basic (Usage) Copy Code
Dim instance As CheckedListBox
Dim value As EventTypes

value = instance.GetCriticalEvents()
C#
protected override EventTypes GetCriticalEvents()
Managed Extensions for C++
protected: EventTypes GetCriticalEvents(); override
C++/CLI
protected:
EventTypes GetCriticalEvents(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CheckedListBox Class
CheckedListBox Members


GetItemChecked Method

[image]
Gizmox.WebGUI.Forms
GetItemChecked Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CheckedListBox Class : GetItemChecked Method

intIndex
Item index.
Gets the item checked value.

Syntax

Visual Basic (Declaration)
Public Function GetItemChecked( _
   ByVal intIndex As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As CheckedListBox
Dim intIndex As Integer
Dim value As Boolean

value = instance.GetItemChecked(intIndex)
C#
public bool GetItemChecked(
   int intIndex
)
Managed Extensions for C++
public: bool GetItemChecked(
   int intIndex
)
C++/CLI
public:
bool GetItemChecked(
   int intIndex
)

Parameters

intIndex
Item index.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CheckedListBox Class
CheckedListBox Members


OnItemCheck Method

[image]
Gizmox.WebGUI.Forms
OnItemCheck Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CheckedListBox Class : OnItemCheck Method

ice
An ItemCheckEventArgs that contains the event data.
Raises the ItemCheck event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnItemCheck( _
   ByVal ice As ItemCheckEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As CheckedListBox
Dim ice As ItemCheckEventArgs

instance.OnItemCheck(ice)
C#
protected virtual void OnItemCheck(
   ItemCheckEventArgs ice
)
Managed Extensions for C++
protected: virtual void OnItemCheck(
   ItemCheckEventArgs* ice
)
C++/CLI
protected:
virtual void OnItemCheck(
   ItemCheckEventArgs^ ice
)

Parameters

ice
An ItemCheckEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CheckedListBox Class
CheckedListBox Members


RenderItemAttributes Method

[image]
Gizmox.WebGUI.Forms
RenderItemAttributes Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CheckedListBox Class : RenderItemAttributes Method

objWriter
Writer.
objItem
Item.
intIndex
Item index.
Renders the item attributes.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub RenderItemAttributes( _
   ByVal objWriter As IResponseWriter, _
   ByVal objItem As Object, _
   ByVal intIndex As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As CheckedListBox
Dim objWriter As IResponseWriter
Dim objItem As Object
Dim intIndex As Integer

instance.RenderItemAttributes(objWriter, objItem, intIndex)
C#
protected override void RenderItemAttributes(
   IResponseWriter objWriter,
   object objItem,
   int intIndex
)
Managed Extensions for C++
protected: void RenderItemAttributes(
   IResponseWriter* objWriter,
   Object* objItem,
   int intIndex
) override
C++/CLI
protected:
void RenderItemAttributes(
   IResponseWriter^ objWriter,
   Object^ objItem,
   int intIndex
) override

Parameters

objWriter
Writer.
objItem
Item.
intIndex
Item index.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CheckedListBox Class
CheckedListBox Members


SetItemChecked Method

[image]
Gizmox.WebGUI.Forms
SetItemChecked Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CheckedListBox Class : SetItemChecked Method

intIndex
Item index.
blnChecked
Is checked.
Sets the item checked status.

Syntax

Visual Basic (Declaration)
Public Sub SetItemChecked( _
   ByVal intIndex As Integer, _
   ByVal blnChecked As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As CheckedListBox
Dim intIndex As Integer
Dim blnChecked As Boolean

instance.SetItemChecked(intIndex, blnChecked)
C#
public void SetItemChecked(
   int intIndex,
   bool blnChecked
)
Managed Extensions for C++
public: void SetItemChecked(
   int intIndex,
   bool blnChecked
)
C++/CLI
public:
void SetItemChecked(
   int intIndex,
   bool blnChecked
)

Parameters

intIndex
Item index.
blnChecked
Is checked.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CheckedListBox Class
CheckedListBox Members


ShouldSerializeSelectionMode Method

[image]
Gizmox.WebGUI.Forms
ShouldSerializeSelectionMode Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CheckedListBox Class : ShouldSerializeSelectionMode Method

Syntax

Visual Basic (Declaration)
Protected Overrides Function ShouldSerializeSelectionMode() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As CheckedListBox
Dim value As Boolean

value = instance.ShouldSerializeSelectionMode()
C#
protected override bool ShouldSerializeSelectionMode()
Managed Extensions for C++
protected: bool ShouldSerializeSelectionMode(); override
C++/CLI
protected:
bool ShouldSerializeSelectionMode(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CheckedListBox Class
CheckedListBox Members


SwapItems Method

[image]
Gizmox.WebGUI.Forms
SwapItems Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CheckedListBox Class : SwapItems Method

intIndexA
index A.
intIndexB
index B.
Swaps the items.

Syntax

Visual Basic (Declaration)
Public Overrides Sub SwapItems( _
   ByVal intIndexA As Integer, _
   ByVal intIndexB As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As CheckedListBox
Dim intIndexA As Integer
Dim intIndexB As Integer

instance.SwapItems(intIndexA, intIndexB)
C#
public override void SwapItems(
   int intIndexA,
   int intIndexB
)
Managed Extensions for C++
public: void SwapItems(
   int intIndexA,
   int intIndexB
) override
C++/CLI
public:
void SwapItems(
   int intIndexA,
   int intIndexB
) override

Parameters

intIndexA
index A.
intIndexB
index B.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CheckedListBox Class
CheckedListBox Members


CheckedListBox Class Properties

[image]
Gizmox.WebGUI.Forms
CheckedListBox Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : CheckedListBox Class

For a list of all members of this type, see CheckedListBox members.

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | CheckBoxes | Gets or sets a value indicating whether [check boxes]. (Inherited from ListBox)
Public Property | CheckedIndices | Collection of checked indexes in this CheckedListBox.
Public Property | CheckedItems | Collection of checked items in this CheckedListBox.
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | DataSource | Gets or sets the data source for this ListControl. (Inherited from ListControl)
Public Property | DisplayMember | Gets or sets the property to display for this ListControl. (Inherited from ListControl)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | FormatInfo | Gets or sets the IFormatProvider that provides custom formatting behavior. (Inherited from ListControl)
Public Property | FormatString | Gets or sets the format-specifier characters that indicate how a value is to be displayed. (Inherited from ListControl)
Public Property | FormattingEnabled | Gets or sets a value indicating whether formatting is applied to the ListControl.DisplayMember property of the ListControl. (Inherited from ListControl)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | Items |
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | RadioBoxes | Gets or sets a value indicating whether [radio boxes]. (Inherited from ListBox)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | SelectedIndex | Gets or sets the zero-based index of the currently selected item in a ListBox. (Inherited from ListBox)
Public Property | SelectedIndices | Gets a collection that contains the zero-based indexes of all currently selected items in the ListBox. (Inherited from ListBox)
Public Property | SelectedItem | Gets or sets the currently selected item in the ListBox. (Inherited from ListBox)
Public Property | SelectedItems | Gets a collection containing the currently selected items in the ListBox. (Inherited from ListBox)
Public Property | SelectedValue | Gets or sets the value of the member property specified by the ListControl.ValueMember property. (Inherited from ListControl)
Public Property | SelectionMode | Gets or sets the method in which items are selected in the ListBox. (Inherited from ListBox)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | Sorted | Gets or sets a value indicating whether the items in the ListBox are sorted alphabetically. (Inherited from ListBox)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Control)
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | ValueMember | Gets or sets the property to use as the actual value for the items in the ListControl. (Inherited from ListControl)
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | AllowSelection | Gets a value indicating whether the list enables selection of list items. (Inherited from ListControl)
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DataManager | Gets the CurrencyManager associated with this control. (Inherited from ListControl)
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | Gets a value indicating whether this instance is delayed drawing. (Inherited from ListBox)
Protected Property | IsPostBackRequired | Indicates if the list control context requires its events to cause callback (Inherited from ListControl)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

See Also

Reference

CheckedListBox Class
Gizmox.WebGUI.Forms Namespace


CheckedIndices Property

[image]
Gizmox.WebGUI.Forms
CheckedIndices Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CheckedListBox Class : CheckedIndices Property

Collection of checked indexes in this CheckedListBox.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public ReadOnly Property CheckedIndices As CheckedListBox.CheckedIndexCollection
Visual Basic (Usage) Copy Code
Dim instance As CheckedListBox
Dim value As CheckedListBox.CheckedIndexCollection

value = instance.CheckedIndices
C#
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public CheckedListBox.CheckedIndexCollection CheckedIndices {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property CheckedListBox.CheckedIndexCollection* get_CheckedIndices();
C++/CLI
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
property CheckedListBox::CheckedIndexCollection^ CheckedIndices {
   CheckedListBox::CheckedIndexCollection^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CheckedListBox Class
CheckedListBox Members


CheckedItems Property

[image]
Gizmox.WebGUI.Forms
CheckedItems Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CheckedListBox Class : CheckedItems Property

Collection of checked items in this CheckedListBox.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public ReadOnly Property CheckedItems As CheckedListBox.CheckedItemCollection
Visual Basic (Usage) Copy Code
Dim instance As CheckedListBox
Dim value As CheckedListBox.CheckedItemCollection

value = instance.CheckedItems
C#
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public CheckedListBox.CheckedItemCollection CheckedItems {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property CheckedListBox.CheckedItemCollection* get_CheckedItems();
C++/CLI
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
property CheckedListBox::CheckedItemCollection^ CheckedItems {
   CheckedListBox::CheckedItemCollection^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CheckedListBox Class
CheckedListBox Members


Items Property

[image]
Gizmox.WebGUI.Forms
Items Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CheckedListBox Class : Items Property

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
<SRCategoryAttribute("Data")>
<EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Common.Design.ListControlStringCollectionEditor, Gizmox.WebGUI.Common.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=ea5dfe57c8eb7edd")>
Public ReadOnly Property Items As CheckedListBox.ObjectCollection
Visual Basic (Usage) Copy Code
Dim instance As CheckedListBox
Dim value As CheckedListBox.ObjectCollection

value = instance.Items
C#
[DesignerSerializationVisibilityAttribute()]
[SRCategoryAttribute("Data")]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Common.Design.ListControlStringCollectionEditor, Gizmox.WebGUI.Common.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=ea5dfe57c8eb7edd")]
public CheckedListBox.ObjectCollection Items {get;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
[SRCategoryAttribute("Data")]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Common.Design.ListControlStringCollectionEditor, Gizmox.WebGUI.Common.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=ea5dfe57c8eb7edd")]
public: __property CheckedListBox.ObjectCollection* get_Items();
C++/CLI
[DesignerSerializationVisibilityAttribute()]
[SRCategoryAttribute("Data")]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Common.Design.ListControlStringCollectionEditor, Gizmox.WebGUI.Common.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=ea5dfe57c8eb7edd")]
public:
property CheckedListBox::ObjectCollection^ Items {
   CheckedListBox::ObjectCollection^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CheckedListBox Class
CheckedListBox Members


CheckedListBox Class Events

[image]
Gizmox.WebGUI.Forms
CheckedListBox Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : CheckedListBox Class

For a list of all members of this type, see CheckedListBox members.

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | DataSourceChanged | Occurs when the ListControl.DataSource changes. (Inherited from ListControl)
Public Event | DisplayMemberChanged | Occurs when the ListControl.DisplayMember property changes. (Inherited from ListControl)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | Format | Occurs when the control is bound to a data value. (Inherited from ListControl)
Public Event | FormatInfoChanged | Occurs when the value of the ListControl.FormatInfo property changes. (Inherited from ListControl)
Public Event | FormatStringChanged | Occurs when value of the ListControl.FormatString property changes (Inherited from ListControl)
Public Event | FormattingEnabledChanged | Occurs when the value of the ListControl.FormattingEnabled property changes. (Inherited from ListControl)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | ItemCheck | Occurs when the checked state of an item changes.
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | SelectedIndexChanged | Occurs when the SelectedIndex property has changed. (Inherited from ListBox)
Public Event | SelectedValueChanged | Occurs when the ListControl.SelectedValue property changes. (Inherited from ListControl)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | ValueMemberChanged | Occurs when the ListControl.ValueMember property changes. (Inherited from ListControl)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

CheckedListBox Class
Gizmox.WebGUI.Forms Namespace


ItemCheck Event

[image]
Gizmox.WebGUI.Forms
ItemCheck Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CheckedListBox Class : ItemCheck Event

Occurs when the checked state of an item changes.

Syntax

Visual Basic (Declaration)
Public Event ItemCheck() As ItemCheckHandler
Visual Basic (Usage) Copy Code
Dim instance As CheckedListBox
Dim handler As ItemCheckHandler

AddHandler instance.ItemCheck, handler
C#
public event ItemCheckHandler ItemCheck()
Managed Extensions for C++
public: __event ItemCheckHandler* ItemCheck
C++/CLI
public:
event ItemCheckHandler^ ItemCheck

Event Data

The event handler receives an argument of type ItemCheckEventArgs containing data related to this event. The following ItemCheckEventArgs properties provide information specific to this event.

Property | Description
CurrentValue | Gets the current value.
Index | Gets the index.
NewValue | Gets or sets the new value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CheckedListBox Class
CheckedListBox Members


CheckedListBox.CheckedIndexCollection Class

[image]
Gizmox.WebGUI.Forms
CheckedListBox.CheckedIndexCollection Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : CheckedListBox.CheckedIndexCollection Class

Encapsulates the collection of indexes of checked items (including items in an indeterminate state) in a CheckedListBox.

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class CheckedListBox.CheckedIndexCollection
Visual Basic (Usage) Copy Code
Dim instance As CheckedListBox.CheckedIndexCollection
C#
[DefaultMemberAttribute("Item")]
public class CheckedListBox.CheckedIndexCollection
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
public __gc class CheckedListBox.CheckedIndexCollection
C++/CLI
[DefaultMemberAttribute("Item")]
public ref class CheckedListBox.CheckedIndexCollection

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.CheckedListBox.CheckedIndexCollection

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

CheckedListBox.CheckedIndexCollection Members
Gizmox.WebGUI.Forms Namespace


CheckedListBox.CheckedIndexCollection Class Members

[image]
Gizmox.WebGUI.Forms
CheckedListBox.CheckedIndexCollection Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : CheckedListBox.CheckedIndexCollection Class

The following tables list the members exposed by CheckedListBox.CheckedIndexCollection.

Public Properties

 | Name | Description
Public Property | Count | Gets the number of checked items.
Public Property | IsReadOnly | Gets a value indicating whether the collection is read-only.
Public Property | Item | Gets the index of a checked item in the CheckedListBox control.
Top

Public Methods

 | Name | Description
Public Method | Contains | Determines whether the specified index is located in the collection.
Public Method | CopyTo | Copies the entire collection into an existing array at a specified location within the array.
Public Method | GetEnumerator | Returns an enumerator that can be used to iterate through the CheckedListBox.CheckedIndices collection.
Public Method | IndexOf | Returns an index into the collection of checked indexes.
Top

See Also

Reference

CheckedListBox.CheckedIndexCollection Class
Gizmox.WebGUI.Forms Namespace


CheckedListBox.CheckedIndexCollection Class Methods

[image]
Gizmox.WebGUI.Forms
CheckedListBox.CheckedIndexCollection Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : CheckedListBox.CheckedIndexCollection Class

For a list of all members of this type, see CheckedListBox.CheckedIndexCollection members.

Public Methods

 | Name | Description
Public Method | Contains | Determines whether the specified index is located in the collection.
Public Method | CopyTo | Copies the entire collection into an existing array at a specified location within the array.
Public Method | GetEnumerator | Returns an enumerator that can be used to iterate through the CheckedListBox.CheckedIndices collection.
Public Method | IndexOf | Returns an index into the collection of checked indexes.
Top

See Also

Reference

CheckedListBox.CheckedIndexCollection Class
Gizmox.WebGUI.Forms Namespace


Contains Method

[image]
Gizmox.WebGUI.Forms
Contains Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CheckedListBox.CheckedIndexCollection Class : Contains Method

index
The index to locate in the collection.
Determines whether the specified index is located in the collection.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal index As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As CheckedListBox.CheckedIndexCollection
Dim index As Integer
Dim value As Boolean

value = instance.Contains(index)
C#
public bool Contains(
   int index
)
Managed Extensions for C++
public: bool Contains(
   int index
)
C++/CLI
public:
bool Contains(
   int index
)

Parameters

index
The index to locate in the collection.

Return Value

true if the specified index from the CheckedListBox.ObjectCollection is an item in this collection; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CheckedListBox.CheckedIndexCollection Class
CheckedListBox.CheckedIndexCollection Members


CopyTo Method

[image]
Gizmox.WebGUI.Forms
CopyTo Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CheckedListBox.CheckedIndexCollection Class : CopyTo Method

dest
The destination array.
index
The zero-based relative index in dest at which copying begins.
Copies the entire collection into an existing array at a specified location within the array.

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal dest As Array, _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As CheckedListBox.CheckedIndexCollection
Dim dest As Array
Dim index As Integer

instance.CopyTo(dest, index)
C#
public void CopyTo(
   Array dest,
   int index
)
Managed Extensions for C++
public: void CopyTo(
   Array* dest,
   int index
)
C++/CLI
public:
void CopyTo(
   Array^ dest,
   int index
)

Parameters

dest
The destination array.
index
The zero-based relative index in dest at which copying begins.

Exceptions

Exception | Description
ArgumentNullException | array is null.
ArgumentOutOfRangeException | index is less than zero.
RankException | array is multidimensional.
ArrayTypeMismatchException | The type of the source Array cannot be cast automatically to the type of the destination Array.
ArgumentException | index is equal to or greater than the length of array.-or- The number of elements in the source Array is greater than the available space from index to the end of the destination Array.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CheckedListBox.CheckedIndexCollection Class
CheckedListBox.CheckedIndexCollection Members


GetEnumerator Method

[image]
Gizmox.WebGUI.Forms
GetEnumerator Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CheckedListBox.CheckedIndexCollection Class : GetEnumerator Method

Returns an enumerator that can be used to iterate through the CheckedListBox.CheckedIndices collection.

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As CheckedListBox.CheckedIndexCollection
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Return Value

An IEnumerator for navigating through the list.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CheckedListBox.CheckedIndexCollection Class
CheckedListBox.CheckedIndexCollection Members


IndexOf Method

[image]
Gizmox.WebGUI.Forms
IndexOf Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CheckedListBox.CheckedIndexCollection Class : IndexOf Method

index
The index of the checked item.
Returns an index into the collection of checked indexes.

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal index As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As CheckedListBox.CheckedIndexCollection
Dim index As Integer
Dim value As Integer

value = instance.IndexOf(index)
C#
public int IndexOf(
   int index
)
Managed Extensions for C++
public: int IndexOf(
   int index
)
C++/CLI
public:
int IndexOf(
   int index
)

Parameters

index
The index of the checked item.

Return Value

The index that specifies the index of the checked item or -1 if the index parameter is not in the checked indexes collection. For more information, see the examples in the CheckedListBox.CheckedIndexCollection class overview.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CheckedListBox.CheckedIndexCollection Class
CheckedListBox.CheckedIndexCollection Members


CheckedListBox.CheckedIndexCollection Class Properties

[image]
Gizmox.WebGUI.Forms
CheckedListBox.CheckedIndexCollection Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : CheckedListBox.CheckedIndexCollection Class

For a list of all members of this type, see CheckedListBox.CheckedIndexCollection members.

Public Properties

 | Name | Description
Public Property | Count | Gets the number of checked items.
Public Property | IsReadOnly | Gets a value indicating whether the collection is read-only.
Public Property | Item | Gets the index of a checked item in the CheckedListBox control.
Top

See Also

Reference

CheckedListBox.CheckedIndexCollection Class
Gizmox.WebGUI.Forms Namespace


Count Property

[image]
Gizmox.WebGUI.Forms
Count Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CheckedListBox.CheckedIndexCollection Class : Count Property

Gets the number of checked items.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As CheckedListBox.CheckedIndexCollection
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CheckedListBox.CheckedIndexCollection Class
CheckedListBox.CheckedIndexCollection Members


IsReadOnly Property

[image]
Gizmox.WebGUI.Forms
IsReadOnly Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CheckedListBox.CheckedIndexCollection Class : IsReadOnly Property

Gets a value indicating whether the collection is read-only.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsReadOnly As Boolean
Visual Basic (Usage) Copy Code
Dim instance As CheckedListBox.CheckedIndexCollection
Dim value As Boolean

value = instance.IsReadOnly
C#
public bool IsReadOnly {get;}
Managed Extensions for C++
public: __property bool get_IsReadOnly();
C++/CLI
public:
property bool IsReadOnly {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CheckedListBox.CheckedIndexCollection Class
CheckedListBox.CheckedIndexCollection Members


Item Property

[image]
Gizmox.WebGUI.Forms
Item Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CheckedListBox.CheckedIndexCollection Class : Item Property

index
An index into the checked indexes collection. This index specifies the index of the checked item you want to retrieve.
Gets the index of a checked item in the CheckedListBox control.

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
Public ReadOnly Default Property Item( _
   ByVal index As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As CheckedListBox.CheckedIndexCollection
Dim index As Integer
Dim value As Integer

value = instance.Item(index)
C#
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public int this[
   int index
]; {get;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public: __property int get_Item(
   int index
);
C++/CLI
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public:
property int default [int] {
   int get(intindex);
}

Parameters

index
An index into the checked indexes collection. This index specifies the index of the checked item you want to retrieve.

Exceptions

Exception | Description
ArgumentException | The index is less than zero.-or- The index is not in the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CheckedListBox.CheckedIndexCollection Class
CheckedListBox.CheckedIndexCollection Members


CheckedListBox.CheckedItemCollection Class

[image]
Gizmox.WebGUI.Forms
CheckedListBox.CheckedItemCollection Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : CheckedListBox.CheckedItemCollection Class

Encapsulates the collection of checked items, including items in an indeterminate state, in a CheckedListBox control.

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class CheckedListBox.CheckedItemCollection
Visual Basic (Usage) Copy Code
Dim instance As CheckedListBox.CheckedItemCollection
C#
[DefaultMemberAttribute("Item")]
public class CheckedListBox.CheckedItemCollection
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
public __gc class CheckedListBox.CheckedItemCollection
C++/CLI
[DefaultMemberAttribute("Item")]
public ref class CheckedListBox.CheckedItemCollection

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.CheckedListBox.CheckedItemCollection

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

CheckedListBox.CheckedItemCollection Members
Gizmox.WebGUI.Forms Namespace


CheckedListBox.CheckedItemCollection Class Members

[image]
Gizmox.WebGUI.Forms
CheckedListBox.CheckedItemCollection Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : CheckedListBox.CheckedItemCollection Class

The following tables list the members exposed by CheckedListBox.CheckedItemCollection.

Public Properties

 | Name | Description
Public Property | Count | Gets the number of items in the collection.
Public Property | IsReadOnly | Gets a value indicating if the collection is read-only.
Public Property | Item | Gets an object in the checked items collection.
Top

Public Methods

 | Name | Description
Public Method | Contains | Determines whether the specified item is located in the collection.
Public Method | CopyTo | Copies the entire collection into an existing array at a specified location within the array.
Public Method | GetEnumerator | Returns an enumerator that can be used to iterate through the CheckedListBox.CheckedItems collection.
Public Method | IndexOf | Returns an index into the collection of checked items.
Top

See Also

Reference

CheckedListBox.CheckedItemCollection Class
Gizmox.WebGUI.Forms Namespace


CheckedListBox.CheckedItemCollection Class Methods

[image]
Gizmox.WebGUI.Forms
CheckedListBox.CheckedItemCollection Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : CheckedListBox.CheckedItemCollection Class

For a list of all members of this type, see CheckedListBox.CheckedItemCollection members.

Public Methods

 | Name | Description
Public Method | Contains | Determines whether the specified item is located in the collection.
Public Method | CopyTo | Copies the entire collection into an existing array at a specified location within the array.
Public Method | GetEnumerator | Returns an enumerator that can be used to iterate through the CheckedListBox.CheckedItems collection.
Public Method | IndexOf | Returns an index into the collection of checked items.
Top

See Also

Reference

CheckedListBox.CheckedItemCollection Class
Gizmox.WebGUI.Forms Namespace


Contains Method

[image]
Gizmox.WebGUI.Forms
Contains Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CheckedListBox.CheckedItemCollection Class : Contains Method

item
An object from the items collection.
Determines whether the specified item is located in the collection.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal item As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As CheckedListBox.CheckedItemCollection
Dim item As Object
Dim value As Boolean

value = instance.Contains(item)
C#
public bool Contains(
   object item
)
Managed Extensions for C++
public: bool Contains(
   Object* item
)
C++/CLI
public:
bool Contains(
   Object^ item
)

Parameters

item
An object from the items collection.

Return Value

true if item is in the collection; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CheckedListBox.CheckedItemCollection Class
CheckedListBox.CheckedItemCollection Members


CopyTo Method

[image]
Gizmox.WebGUI.Forms
CopyTo Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CheckedListBox.CheckedItemCollection Class : CopyTo Method

dest
The destination array.
index
The zero-based relative index in dest at which copying begins.
Copies the entire collection into an existing array at a specified location within the array.

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal dest As Array, _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As CheckedListBox.CheckedItemCollection
Dim dest As Array
Dim index As Integer

instance.CopyTo(dest, index)
C#
public void CopyTo(
   Array dest,
   int index
)
Managed Extensions for C++
public: void CopyTo(
   Array* dest,
   int index
)
C++/CLI
public:
void CopyTo(
   Array^ dest,
   int index
)

Parameters

dest
The destination array.
index
The zero-based relative index in dest at which copying begins.

Exceptions

Exception | Description
ArgumentNullException | array is null.
ArgumentOutOfRangeException | index is less than zero.
RankException | array is multidimensional.
ArrayTypeMismatchException | The type of the source Array cannot be cast automatically to the type of the destination Array.
ArgumentException | index is equal to or greater than the length of array.-or- The number of elements in the source Array is greater than the available space from index to the end of the destination Array.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CheckedListBox.CheckedItemCollection Class
CheckedListBox.CheckedItemCollection Members


GetEnumerator Method

[image]
Gizmox.WebGUI.Forms
GetEnumerator Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CheckedListBox.CheckedItemCollection Class : GetEnumerator Method

Returns an enumerator that can be used to iterate through the CheckedListBox.CheckedItems collection.

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As CheckedListBox.CheckedItemCollection
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Return Value

An IEnumerator for navigating through the list.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CheckedListBox.CheckedItemCollection Class
CheckedListBox.CheckedItemCollection Members


IndexOf Method

[image]
Gizmox.WebGUI.Forms
IndexOf Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CheckedListBox.CheckedItemCollection Class : IndexOf Method

item
The object whose index you want to retrieve. This object must belong to the checked items collection.
Returns an index into the collection of checked items.

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal item As Object _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As CheckedListBox.CheckedItemCollection
Dim item As Object
Dim value As Integer

value = instance.IndexOf(item)
C#
public int IndexOf(
   object item
)
Managed Extensions for C++
public: int IndexOf(
   Object* item
)
C++/CLI
public:
int IndexOf(
   Object^ item
)

Parameters

item
The object whose index you want to retrieve. This object must belong to the checked items collection.

Return Value

The index of the object in the checked item collection or -1 if the object is not in the collection. For more information, see the examples in the CheckedListBox.CheckedItemCollection class overview.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CheckedListBox.CheckedItemCollection Class
CheckedListBox.CheckedItemCollection Members


CheckedListBox.CheckedItemCollection Class Properties

[image]
Gizmox.WebGUI.Forms
CheckedListBox.CheckedItemCollection Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : CheckedListBox.CheckedItemCollection Class

For a list of all members of this type, see CheckedListBox.CheckedItemCollection members.

Public Properties

 | Name | Description
Public Property | Count | Gets the number of items in the collection.
Public Property | IsReadOnly | Gets a value indicating if the collection is read-only.
Public Property | Item | Gets an object in the checked items collection.
Top

See Also

Reference

CheckedListBox.CheckedItemCollection Class
Gizmox.WebGUI.Forms Namespace


Count Property

[image]
Gizmox.WebGUI.Forms
Count Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CheckedListBox.CheckedItemCollection Class : Count Property

Gets the number of items in the collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As CheckedListBox.CheckedItemCollection
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CheckedListBox.CheckedItemCollection Class
CheckedListBox.CheckedItemCollection Members


IsReadOnly Property

[image]
Gizmox.WebGUI.Forms
IsReadOnly Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CheckedListBox.CheckedItemCollection Class : IsReadOnly Property

Gets a value indicating if the collection is read-only.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsReadOnly As Boolean
Visual Basic (Usage) Copy Code
Dim instance As CheckedListBox.CheckedItemCollection
Dim value As Boolean

value = instance.IsReadOnly
C#
public bool IsReadOnly {get;}
Managed Extensions for C++
public: __property bool get_IsReadOnly();
C++/CLI
public:
property bool IsReadOnly {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CheckedListBox.CheckedItemCollection Class
CheckedListBox.CheckedItemCollection Members


Item Property

[image]
Gizmox.WebGUI.Forms
Item Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CheckedListBox.CheckedItemCollection Class : Item Property

index
An index into the collection of checked items. This collection index corresponds to the index of the checked item.
Gets an object in the checked items collection.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public Default Property Item( _
   ByVal index As Integer _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As CheckedListBox.CheckedItemCollection
Dim index As Integer
Dim value As Object

instance.Item(index) = value

value = instance.Item(index)
C#
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public object this[
   int index
]; {get; set;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property Object* get_Item(
   int index
);
public: __property void set_Item(
   int index,
   Object* value
);
C++/CLI
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
property Object^ default [int] {
   Object^ get(intindex);
   void set (intindex, Object^value);
}

Parameters

index
An index into the collection of checked items. This collection index corresponds to the index of the checked item.

Exceptions

Exception | Description
NotSupportedException | The object cannot be set.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CheckedListBox.CheckedItemCollection Class
CheckedListBox.CheckedItemCollection Members


CheckedListBox.ObjectCollection Class

[image]
Gizmox.WebGUI.Forms
CheckedListBox.ObjectCollection Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : CheckedListBox.ObjectCollection Class

The list box object collection

Syntax

Visual Basic (Declaration)
Public Class CheckedListBox.ObjectCollection
   Inherits ListBox.ObjectCollection
Visual Basic (Usage) Copy Code
Dim instance As CheckedListBox.ObjectCollection
C#
public class CheckedListBox.ObjectCollection : ListBox.ObjectCollection
Managed Extensions for C++
public __gc class CheckedListBox.ObjectCollection : public ListBox.ObjectCollection
C++/CLI
public ref class CheckedListBox.ObjectCollection : public ListBox::ObjectCollection

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ListBox.ObjectCollection
Gizmox.WebGUI.Forms.CheckedListBox.ObjectCollection

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

CheckedListBox.ObjectCollection Members
Gizmox.WebGUI.Forms Namespace


CheckedListBox.ObjectCollection Class Members

[image]
Gizmox.WebGUI.Forms
CheckedListBox.ObjectCollection Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : CheckedListBox.ObjectCollection Class

The following tables list the members exposed by CheckedListBox.ObjectCollection.

Public Properties

 | Name | Description
Public Property | Count | Gets the number of items in the collection. (Inherited from ListBox.ObjectCollection)
Public Property | IsFixedSize | Gets a value indicating whether the collection has a fixed size. (Inherited from ListBox.ObjectCollection)
Public Property | IsReadOnly | Gets a value indicating whether the collection is read-only. (Inherited from ListBox.ObjectCollection)
Public Property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe). (Inherited from ListBox.ObjectCollection)
Public Property | Item | Gets or sets the item at the specified index within the collection. (Inherited from ListBox.ObjectCollection)
Public Property | SyncRoot | Gets the sync root. (Inherited from ListBox.ObjectCollection)
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Adds an item to the list of items for a ListBox.
Public Method | AddRange | Overloaded. Adds an array of items to the list of items for a ListBox. (Inherited from ListBox.ObjectCollection)
Public Method | Clear | Overridden.
Public Method | Contains | Determines whether the specified item is located within the collection. (Inherited from ListBox.ObjectCollection)
Public Method | CopyTo | Copies the entire collection into an existing array of objects at a specified location within the array. (Inherited from ListBox.ObjectCollection)
Public Method | GetEnumerator | Returns an enumerator to use to iterate through the item collection. (Inherited from ListBox.ObjectCollection)
Public Method | IndexOf | Returns the index within the collection of the specified item. (Inherited from ListBox.ObjectCollection)
Public Method | Insert | Inserts an item into the list box at the specified index. (Inherited from ListBox.ObjectCollection)
Public Method | Remove | Removes the specified object from the collection. (Inherited from ListBox.ObjectCollection)
Public Method | RemoveAt | Removes the item at the specified index within the collection. (Inherited from ListBox.ObjectCollection)
Top

Protected Methods

 | Name | Description
Protected Method | GetItemInvalidMessage | Gets the item invalid message. (Inherited from ListBox.ObjectCollection)
Protected Method | IsItemValid | Determines whether item is valid. (Inherited from ListBox.ObjectCollection)
Top

See Also

Reference

CheckedListBox.ObjectCollection Class
Gizmox.WebGUI.Forms Namespace


CheckedListBox.ObjectCollection Class Methods

[image]
Gizmox.WebGUI.Forms
CheckedListBox.ObjectCollection Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : CheckedListBox.ObjectCollection Class

For a list of all members of this type, see CheckedListBox.ObjectCollection members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Adds an item to the list of items for a ListBox.
Public Method | AddRange | Overloaded. Adds an array of items to the list of items for a ListBox. (Inherited from ListBox.ObjectCollection)
Public Method | Clear | Overridden.
Public Method | Contains | Determines whether the specified item is located within the collection. (Inherited from ListBox.ObjectCollection)
Public Method | CopyTo | Copies the entire collection into an existing array of objects at a specified location within the array. (Inherited from ListBox.ObjectCollection)
Public Method | GetEnumerator | Returns an enumerator to use to iterate through the item collection. (Inherited from ListBox.ObjectCollection)
Public Method | IndexOf | Returns the index within the collection of the specified item. (Inherited from ListBox.ObjectCollection)
Public Method | Insert | Inserts an item into the list box at the specified index. (Inherited from ListBox.ObjectCollection)
Public Method | Remove | Removes the specified object from the collection. (Inherited from ListBox.ObjectCollection)
Public Method | RemoveAt | Removes the item at the specified index within the collection. (Inherited from ListBox.ObjectCollection)
Top

Protected Methods

 | Name | Description
Protected Method | GetItemInvalidMessage | Gets the item invalid message. (Inherited from ListBox.ObjectCollection)
Protected Method | IsItemValid | Determines whether item is valid. (Inherited from ListBox.ObjectCollection)
Top

See Also

Reference

CheckedListBox.ObjectCollection Class
Gizmox.WebGUI.Forms Namespace


Add Method

[image]
Gizmox.WebGUI.Forms
Add Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CheckedListBox.ObjectCollection Class : Add Method

Adds an item to the list of items for a ListBox.

Overload List

Overload | Description
Add(Object,Boolean) |
Add(Object,CheckState) |
Add(Object) | Adds an item to the list of items for a ListBox. (Inherited from ListBox.ObjectCollection)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CheckedListBox.ObjectCollection Class
CheckedListBox.ObjectCollection Members


Add(Object,Boolean) Method

[image]
Gizmox.WebGUI.Forms
Add(Object,Boolean) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CheckedListBox.ObjectCollection Class > Add Method : Add(Object,Boolean) Method

objItem
blnChecked

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal objItem As Object, _
   ByVal blnChecked As Boolean _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As CheckedListBox.ObjectCollection
Dim objItem As Object
Dim blnChecked As Boolean
Dim value As Integer

value = instance.Add(objItem, blnChecked)
C#
public int Add(
   object objItem,
   bool blnChecked
)
Managed Extensions for C++
public: int Add(
   Object* objItem,
   bool blnChecked
)
C++/CLI
public:
int Add(
   Object^ objItem,
   bool blnChecked
)

Parameters

objItem
blnChecked

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CheckedListBox.ObjectCollection Class
CheckedListBox.ObjectCollection Members
Overload List


Add(Object,CheckState) Method

[image]
Gizmox.WebGUI.Forms
Add(Object,CheckState) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CheckedListBox.ObjectCollection Class > Add Method : Add(Object,CheckState) Method

objItem
enmCheck

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal objItem As Object, _
   ByVal enmCheck As CheckState _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As CheckedListBox.ObjectCollection
Dim objItem As Object
Dim enmCheck As CheckState
Dim value As Integer

value = instance.Add(objItem, enmCheck)
C#
public int Add(
   object objItem,
   CheckState enmCheck
)
Managed Extensions for C++
public: int Add(
   Object* objItem,
   CheckState enmCheck
)
C++/CLI
public:
int Add(
   Object^ objItem,
   CheckState enmCheck
)

Parameters

objItem
enmCheck

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CheckedListBox.ObjectCollection Class
CheckedListBox.ObjectCollection Members
Overload List


Clear Method

[image]
Gizmox.WebGUI.Forms
Clear Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CheckedListBox.ObjectCollection Class : Clear Method

Syntax

Visual Basic (Declaration)
Public Overrides Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As CheckedListBox.ObjectCollection

instance.Clear()
C#
public override void Clear()
Managed Extensions for C++
public: void Clear(); override
C++/CLI
public:
void Clear(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CheckedListBox.ObjectCollection Class
CheckedListBox.ObjectCollection Members


Clipboard Class

[image]
Gizmox.WebGUI.Forms
Clipboard Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : Clipboard Class

Provides methods to place data on and retrieve data from the system Clipboard. This class cannot be inherited.

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Clipboard
Visual Basic (Usage) Copy Code
Dim instance As Clipboard
C#
public sealed class Clipboard
Managed Extensions for C++
public __gc __sealed class Clipboard
C++/CLI
public ref class Clipboard sealed

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.Clipboard

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Clipboard Members
Gizmox.WebGUI.Forms Namespace


Clipboard Class Members

[image]
Gizmox.WebGUI.Forms
Clipboard Class Members
See Also Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : Clipboard Class

The following tables list the members exposed by Clipboard.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Clear | Removes all data from the Clipboard.
static (Shared in Visual Basic) | ContainsAudio | Indicates whether there is data on the Clipboard in the DataFormats.WaveAudio format.
static (Shared in Visual Basic) | ContainsData | Indicates whether there is data on the Clipboard that is in the specified format or can be converted to that format.
static (Shared in Visual Basic) | ContainsFileDropList | Indicates whether there is data on the Clipboard that is in the DataFormats.FileDrop format or can be converted to that format.
static (Shared in Visual Basic) | ContainsImage | Indicates whether there is data on the Clipboard that is in the DataFormats.Bitmap format or can be converted to that format.
static (Shared in Visual Basic) | ContainsText | Overloaded. Indicates whether there is data on the Clipboard in the TextDataFormat.Text or TextDataFormat.UnicodeText format, depending on the operating system.
static (Shared in Visual Basic) | GetAudioStream | Retrieves an audio stream from the Clipboard.
static (Shared in Visual Basic) | GetData | Retrieves data from the Clipboard in the specified format.
static (Shared in Visual Basic) | GetDataObject | Retrieves the data that is currently on the system Clipboard.
static (Shared in Visual Basic) | GetFileDropList | Retrieves a collection of file names from the Clipboard.
static (Shared in Visual Basic) | GetImage | Retrieves an image from the Clipboard.
static (Shared in Visual Basic) | GetText | Overloaded. Retrieves text data from the Clipboard in the TextDataFormat.Text or TextDataFormat.UnicodeText format, depending on the operating system.
static (Shared in Visual Basic) | SetAudio | Overloaded. Adds a Byte array to the Clipboard in the DataFormats.WaveAudio format after converting it to a Stream.
static (Shared in Visual Basic) | SetData | Adds data to the Clipboard in the specified format.
static (Shared in Visual Basic) | SetDataObject | Overloaded. Places nonpersistent data on the system Clipboard.
static (Shared in Visual Basic) | SetFileDropList | Adds a collection of file names to the Clipboard in the DataFormats.FileDrop format.
static (Shared in Visual Basic) | SetImage | Adds an Image to the Clipboard in the DataFormats.Bitmap format.
static (Shared in Visual Basic) | SetText | Overloaded. Adds text data to the Clipboard in the TextDataFormat.Text or TextDataFormat.UnicodeText format, depending on the operating system.
static (Shared in Visual Basic) | Update | Overloaded. Sends the current clipboard data to the client and clears the clip board
Top

See Also

Reference

Clipboard Class
Gizmox.WebGUI.Forms Namespace


Clipboard Class Methods

[image]
Gizmox.WebGUI.Forms
Clipboard Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : Clipboard Class

For a list of all members of this type, see Clipboard members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Clear | Removes all data from the Clipboard.
static (Shared in Visual Basic) | ContainsAudio | Indicates whether there is data on the Clipboard in the DataFormats.WaveAudio format.
static (Shared in Visual Basic) | ContainsData | Indicates whether there is data on the Clipboard that is in the specified format or can be converted to that format.
static (Shared in Visual Basic) | ContainsFileDropList | Indicates whether there is data on the Clipboard that is in the DataFormats.FileDrop format or can be converted to that format.
static (Shared in Visual Basic) | ContainsImage | Indicates whether there is data on the Clipboard that is in the DataFormats.Bitmap format or can be converted to that format.
static (Shared in Visual Basic) | ContainsText | Overloaded. Indicates whether there is data on the Clipboard in the TextDataFormat.Text or TextDataFormat.UnicodeText format, depending on the operating system.
static (Shared in Visual Basic) | GetAudioStream | Retrieves an audio stream from the Clipboard.
static (Shared in Visual Basic) | GetData | Retrieves data from the Clipboard in the specified format.
static (Shared in Visual Basic) | GetDataObject | Retrieves the data that is currently on the system Clipboard.
static (Shared in Visual Basic) | GetFileDropList | Retrieves a collection of file names from the Clipboard.
static (Shared in Visual Basic) | GetImage | Retrieves an image from the Clipboard.
static (Shared in Visual Basic) | GetText | Overloaded. Retrieves text data from the Clipboard in the TextDataFormat.Text or TextDataFormat.UnicodeText format, depending on the operating system.
static (Shared in Visual Basic) | SetAudio | Overloaded. Adds a Byte array to the Clipboard in the DataFormats.WaveAudio format after converting it to a Stream.
static (Shared in Visual Basic) | SetData | Adds data to the Clipboard in the specified format.
static (Shared in Visual Basic) | SetDataObject | Overloaded. Places nonpersistent data on the system Clipboard.
static (Shared in Visual Basic) | SetFileDropList | Adds a collection of file names to the Clipboard in the DataFormats.FileDrop format.
static (Shared in Visual Basic) | SetImage | Adds an Image to the Clipboard in the DataFormats.Bitmap format.
static (Shared in Visual Basic) | SetText | Overloaded. Adds text data to the Clipboard in the TextDataFormat.Text or TextDataFormat.UnicodeText format, depending on the operating system.
static (Shared in Visual Basic) | Update | Overloaded. Sends the current clipboard data to the client and clears the clip board
Top

See Also

Reference

Clipboard Class
Gizmox.WebGUI.Forms Namespace


Clear Method

[image]
Gizmox.WebGUI.Forms
Clear Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Clipboard Class : Clear Method

Removes all data from the Clipboard.

Syntax

Visual Basic (Declaration)
Public Shared Sub Clear()
Visual Basic (Usage) Copy Code
Clipboard.Clear()
C#
public static void Clear()
Managed Extensions for C++
public: static void Clear();
C++/CLI
public:
static void Clear();

Exceptions

Exception | Description
ThreadStateException | The current thread is not in single-threaded apartment (STA) mode. Add the STAThreadAttribute to your application's Main method.
ExternalException | The Clipboard could not be cleared. This typically occurs when the Clipboard is being used by another process.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Clipboard Class
Clipboard Members


ContainsAudio Method

[image]
Gizmox.WebGUI.Forms
ContainsAudio Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Clipboard Class : ContainsAudio Method

Indicates whether there is data on the Clipboard in the DataFormats.WaveAudio format.

Syntax

Visual Basic (Declaration)
Public Shared Function ContainsAudio() As Boolean
Visual Basic (Usage) Copy Code
Dim value As Boolean

value = Clipboard.ContainsAudio()
C#
public static bool ContainsAudio()
Managed Extensions for C++
public: static bool ContainsAudio();
C++/CLI
public:
static bool ContainsAudio();

Return Value

true if there is audio data on the Clipboard; otherwise, false.

Exceptions

Exception | Description
ThreadStateException | The current thread is not in single-threaded apartment (STA) mode. Add the STAThreadAttribute to your application's Main method.
ExternalException | The Clipboard could not be cleared. This typically occurs when the Clipboard is being used by another process.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Clipboard Class
Clipboard Members


ContainsData Method

[image]
Gizmox.WebGUI.Forms
ContainsData Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Clipboard Class : ContainsData Method

format
The format of the data to look for. See DataFormats for predefined formats.
Indicates whether there is data on the Clipboard that is in the specified format or can be converted to that format.

Syntax

Visual Basic (Declaration)
Public Shared Function ContainsData( _
   ByVal format As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim format As String
Dim value As Boolean

value = Clipboard.ContainsData(format)
C#
public static bool ContainsData(
   string format
)
Managed Extensions for C++
public: static bool ContainsData(
   string* format
)
C++/CLI
public:
static bool ContainsData(
   String^ format
)

Parameters

format
The format of the data to look for. See DataFormats for predefined formats.

Return Value

true if there is data on the Clipboard that is in the specified format or can be converted to that format; otherwise, false.

Exceptions

Exception | Description
ThreadStateException | The current thread is not in single-threaded apartment (STA) mode. Add the STAThreadAttribute to your application's Main method.
ExternalException | The Clipboard could not be cleared. This typically occurs when the Clipboard is being used by another process.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Clipboard Class
Clipboard Members


ContainsFileDropList Method

[image]
Gizmox.WebGUI.Forms
ContainsFileDropList Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Clipboard Class : ContainsFileDropList Method

Indicates whether there is data on the Clipboard that is in the DataFormats.FileDrop format or can be converted to that format.

Syntax

Visual Basic (Declaration)
Public Shared Function ContainsFileDropList() As Boolean
Visual Basic (Usage) Copy Code
Dim value As Boolean

value = Clipboard.ContainsFileDropList()
C#
public static bool ContainsFileDropList()
Managed Extensions for C++
public: static bool ContainsFileDropList();
C++/CLI
public:
static bool ContainsFileDropList();

Return Value

true if there is a file drop list on the Clipboard; otherwise, false.

Exceptions

Exception | Description
ThreadStateException | The current thread is not in single-threaded apartment (STA) mode. Add the STAThreadAttribute to your application's Main method.
ExternalException | The Clipboard could not be cleared. This typically occurs when the Clipboard is being used by another process.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Clipboard Class
Clipboard Members


ContainsImage Method

[image]
Gizmox.WebGUI.Forms
ContainsImage Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Clipboard Class : ContainsImage Method

Indicates whether there is data on the Clipboard that is in the DataFormats.Bitmap format or can be converted to that format.

Syntax

Visual Basic (Declaration)
Public Shared Function ContainsImage() As Boolean
Visual Basic (Usage) Copy Code
Dim value As Boolean

value = Clipboard.ContainsImage()
C#
public static bool ContainsImage()
Managed Extensions for C++
public: static bool ContainsImage();
C++/CLI
public:
static bool ContainsImage();

Return Value

true if there is image data on the Clipboard; otherwise, false.

Exceptions

Exception | Description
ThreadStateException | The current thread is not in single-threaded apartment (STA) mode. Add the STAThreadAttribute to your application's Main method.
ExternalException | The Clipboard could not be cleared. This typically occurs when the Clipboard is being used by another process.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Clipboard Class
Clipboard Members


ContainsText Method

[image]
Gizmox.WebGUI.Forms
ContainsText Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Clipboard Class : ContainsText Method

Indicates whether there is data on the Clipboard in the TextDataFormat.Text or TextDataFormat.UnicodeText format, depending on the operating system.

Overload List

Overload | Description
ContainsText() | Indicates whether there is data on the Clipboard in the TextDataFormat.Text or TextDataFormat.UnicodeText format, depending on the operating system.
ContainsText(TextDataFormat) | Indicates whether there is text data on the Clipboard in the format indicated by the specified TextDataFormat value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Clipboard Class
Clipboard Members


ContainsText() Method

[image]
Gizmox.WebGUI.Forms
ContainsText() Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Clipboard Class > ContainsText Method : ContainsText() Method

Indicates whether there is data on the Clipboard in the TextDataFormat.Text or TextDataFormat.UnicodeText format, depending on the operating system.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function ContainsText() As Boolean
Visual Basic (Usage) Copy Code
Dim value As Boolean

value = Clipboard.ContainsText()
C#
public static bool ContainsText()
Managed Extensions for C++
public: static bool ContainsText();
C++/CLI
public:
static bool ContainsText();

Return Value

true if there is text data on the Clipboard; otherwise, false.

Exceptions

Exception | Description
ThreadStateException | The current thread is not in single-threaded apartment (STA) mode. Add the STAThreadAttribute to your application's Main method.
ExternalException | The Clipboard could not be cleared. This typically occurs when the Clipboard is being used by another process.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Clipboard Class
Clipboard Members
Overload List


ContainsText(TextDataFormat) Method

[image]
Gizmox.WebGUI.Forms
ContainsText(TextDataFormat) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Clipboard Class > ContainsText Method : ContainsText(TextDataFormat) Method

format
One of the TextDataFormat values.
Indicates whether there is text data on the Clipboard in the format indicated by the specified TextDataFormat value.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function ContainsText( _
   ByVal format As TextDataFormat _
) As Boolean
Visual Basic (Usage) Copy Code
Dim format As TextDataFormat
Dim value As Boolean

value = Clipboard.ContainsText(format)
C#
public static bool ContainsText(
   TextDataFormat format
)
Managed Extensions for C++
public: static bool ContainsText(
   TextDataFormat format
)
C++/CLI
public:
static bool ContainsText(
   TextDataFormat format
)

Parameters

format
One of the TextDataFormat values.

Return Value

true if there is text data on the Clipboard in the value specified for format; otherwise, false.

Exceptions

Exception | Description
ThreadStateException | The current thread is not in single-threaded apartment (STA) mode. Add the STAThreadAttribute to your application's Main method.
ExternalException | The Clipboard could not be cleared. This typically occurs when the Clipboard is being used by another process.
InvalidEnumArgumentException | format is not a valid TextDataFormat value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Clipboard Class
Clipboard Members
Overload List


GetAudioStream Method

[image]
Gizmox.WebGUI.Forms
GetAudioStream Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Clipboard Class : GetAudioStream Method

Retrieves an audio stream from the Clipboard.

Syntax

Visual Basic (Declaration)
Public Shared Function GetAudioStream() As Stream
Visual Basic (Usage) Copy Code
Dim value As Stream

value = Clipboard.GetAudioStream()
C#
public static Stream GetAudioStream()
Managed Extensions for C++
public: static Stream* GetAudioStream();
C++/CLI
public:
static Stream^ GetAudioStream();

Return Value

A Stream containing audio data or null if the Clipboard does not contain any data in the DataFormats.WaveAudio format.

Exceptions

Exception | Description
ThreadStateException | The current thread is not in single-threaded apartment (STA) mode. Add the STAThreadAttribute to your application's Main method.
ExternalException | The Clipboard could not be cleared. This typically occurs when the Clipboard is being used by another process.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Clipboard Class
Clipboard Members


GetData Method

[image]
Gizmox.WebGUI.Forms
GetData Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Clipboard Class : GetData Method

format
The format of the data to retrieve. See DataFormats for predefined formats.
Retrieves data from the Clipboard in the specified format.

Syntax

Visual Basic (Declaration)
Public Shared Function GetData( _
   ByVal format As String _
) As Object
Visual Basic (Usage) Copy Code
Dim format As String
Dim value As Object

value = Clipboard.GetData(format)
C#
public static object GetData(
   string format
)
Managed Extensions for C++
public: static Object* GetData(
   string* format
)
C++/CLI
public:
static Object^ GetData(
   String^ format
)

Parameters

format
The format of the data to retrieve. See DataFormats for predefined formats.

Return Value

An Object representing the Clipboard data or null if the Clipboard does not contain any data that is in the specified format or can be converted to that format.

Exceptions

Exception | Description
ThreadStateException | The current thread is not in single-threaded apartment (STA) mode. Add the STAThreadAttribute to your application's Main method.
ExternalException | The Clipboard could not be cleared. This typically occurs when the Clipboard is being used by another process.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Clipboard Class
Clipboard Members


GetDataObject Method

[image]
Gizmox.WebGUI.Forms
GetDataObject Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Clipboard Class : GetDataObject Method

Retrieves the data that is currently on the system Clipboard.

Syntax

Visual Basic (Declaration)
Public Shared Function GetDataObject() As IDataObject
Visual Basic (Usage) Copy Code
Dim value As IDataObject

value = Clipboard.GetDataObject()
C#
public static IDataObject GetDataObject()
Managed Extensions for C++
public: static IDataObject* GetDataObject();
C++/CLI
public:
static IDataObject^ GetDataObject();

Return Value

An IDataObject that represents the data currently on the Clipboard, or null if there is no data on the Clipboard.

Exceptions

Exception | Description
ExternalException | Data could not be retrieved from the Clipboard. This typically occurs when the Clipboard is being used by another process.
ThreadStateException | The current thread is not in single-threaded apartment (STA) mode and the Application.MessageLoop property value is true. Add the STAThreadAttribute to your application's Main method.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Clipboard Class
Clipboard Members


GetFileDropList Method

[image]
Gizmox.WebGUI.Forms
GetFileDropList Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Clipboard Class : GetFileDropList Method

Retrieves a collection of file names from the Clipboard.

Syntax

Visual Basic (Declaration)
Public Shared Function GetFileDropList() As StringCollection
Visual Basic (Usage) Copy Code
Dim value As StringCollection

value = Clipboard.GetFileDropList()
C#
public static StringCollection GetFileDropList()
Managed Extensions for C++
public: static StringCollection* GetFileDropList();
C++/CLI
public:
static StringCollection^ GetFileDropList();

Return Value

A StringCollection containing file names or null if the Clipboard does not contain any data that is in the DataFormats.FileDrop format or can be converted to that format.

Exceptions

Exception | Description
ThreadStateException | The current thread is not in single-threaded apartment (STA) mode. Add the STAThreadAttribute to your application's Main method.
ExternalException | The Clipboard could not be cleared. This typically occurs when the Clipboard is being used by another process.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Clipboard Class
Clipboard Members


GetImage Method

[image]
Gizmox.WebGUI.Forms
GetImage Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Clipboard Class : GetImage Method

Retrieves an image from the Clipboard.

Syntax

Visual Basic (Declaration)
Public Shared Function GetImage() As Image
Visual Basic (Usage) Copy Code
Dim value As Image

value = Clipboard.GetImage()
C#
public static Image GetImage()
Managed Extensions for C++
public: static Image* GetImage();
C++/CLI
public:
static Image^ GetImage();

Return Value

An Image representing the Clipboard image data or null if the Clipboard does not contain any data that is in the DataFormats.Bitmap format or can be converted to that format.

Exceptions

Exception | Description
ThreadStateException | The current thread is not in single-threaded apartment (STA) mode. Add the STAThreadAttribute to your application's Main method.
ExternalException | The Clipboard could not be cleared. This typically occurs when the Clipboard is being used by another process.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Clipboard Class
Clipboard Members


GetText Method

[image]
Gizmox.WebGUI.Forms
GetText Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Clipboard Class : GetText Method

Retrieves text data from the Clipboard in the TextDataFormat.Text or TextDataFormat.UnicodeText format, depending on the operating system.

Overload List

Overload | Description
GetText() | Retrieves text data from the Clipboard in the TextDataFormat.Text or TextDataFormat.UnicodeText format, depending on the operating system.
GetText(TextDataFormat) | Retrieves text data from the Clipboard in the format indicated by the specified TextDataFormat value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Clipboard Class
Clipboard Members


GetText() Method

[image]
Gizmox.WebGUI.Forms
GetText() Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Clipboard Class > GetText Method : GetText() Method

Retrieves text data from the Clipboard in the TextDataFormat.Text or TextDataFormat.UnicodeText format, depending on the operating system.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function GetText() As String
Visual Basic (Usage) Copy Code
Dim value As String

value = Clipboard.GetText()
C#
public static string GetText()
Managed Extensions for C++
public: static string* GetText();
C++/CLI
public:
static String^ GetText();

Return Value

The Clipboard text data or Empty if the Clipboard does not contain data in the TextDataFormat.Text or TextDataFormat.UnicodeText format, depending on the operating system.

Exceptions

Exception | Description
ThreadStateException | The current thread is not in single-threaded apartment (STA) mode. Add the STAThreadAttribute to your application's Main method.
ExternalException | The Clipboard could not be cleared. This typically occurs when the Clipboard is being used by another process.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Clipboard Class
Clipboard Members
Overload List


GetText(TextDataFormat) Method

[image]
Gizmox.WebGUI.Forms
GetText(TextDataFormat) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Clipboard Class > GetText Method : GetText(TextDataFormat) Method

format
One of the TextDataFormat values.
Retrieves text data from the Clipboard in the format indicated by the specified TextDataFormat value.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function GetText( _
   ByVal format As TextDataFormat _
) As String
Visual Basic (Usage) Copy Code
Dim format As TextDataFormat
Dim value As String

value = Clipboard.GetText(format)
C#
public static string GetText(
   TextDataFormat format
)
Managed Extensions for C++
public: static string* GetText(
   TextDataFormat format
)
C++/CLI
public:
static String^ GetText(
   TextDataFormat format
)

Parameters

format
One of the TextDataFormat values.

Return Value

The Clipboard text data or Empty if the Clipboard does not contain data in the specified format.

Exceptions

Exception | Description
ThreadStateException | The current thread is not in single-threaded apartment (STA) mode. Add the STAThreadAttribute to your application's Main method.
ExternalException | The Clipboard could not be cleared. This typically occurs when the Clipboard is being used by another process.
InvalidEnumArgumentException | format is not a valid TextDataFormat value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Clipboard Class
Clipboard Members
Overload List


SetAudio Method

[image]
Gizmox.WebGUI.Forms
SetAudio Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Clipboard Class : SetAudio Method

Adds a Byte array to the Clipboard in the DataFormats.WaveAudio format after converting it to a Stream.

Overload List

Overload | Description
SetAudio(Byte[]) | Adds a Byte array to the Clipboard in the DataFormats.WaveAudio format after converting it to a Stream.
SetAudio(Stream) | Adds a Stream to the Clipboard in the DataFormats.WaveAudio format.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Clipboard Class
Clipboard Members


SetAudio(Byte[]) Method

[image]
Gizmox.WebGUI.Forms
SetAudio(Byte[]) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Clipboard Class > SetAudio Method : SetAudio(Byte[]) Method

audioBytes
A Byte array containing the audio data.
Adds a Byte array to the Clipboard in the DataFormats.WaveAudio format after converting it to a Stream.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Sub SetAudio( _
   ByVal audioBytes() As Byte _
)
Visual Basic (Usage) Copy Code
Dim audioBytes() As Byte

Clipboard.SetAudio(audioBytes)
C#
public static void SetAudio(
   byte[] audioBytes
)
Managed Extensions for C++
public: static void SetAudio(
   byte[]* audioBytes
)
C++/CLI
public:
static void SetAudio(
   array<byte>^ audioBytes
)

Parameters

audioBytes
A Byte array containing the audio data.

Exceptions

Exception | Description
ThreadStateException | The current thread is not in single-threaded apartment (STA) mode. Add the STAThreadAttribute to your application's Main method.
ExternalException | The Clipboard could not be cleared. This typically occurs when the Clipboard is being used by another process.
ArgumentNullException | audioBytes is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Clipboard Class
Clipboard Members
Overload List


SetAudio(Stream) Method

[image]
Gizmox.WebGUI.Forms
SetAudio(Stream) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Clipboard Class > SetAudio Method : SetAudio(Stream) Method

audioStream
A Stream containing the audio data.
Adds a Stream to the Clipboard in the DataFormats.WaveAudio format.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Sub SetAudio( _
   ByVal audioStream As Stream _
)
Visual Basic (Usage) Copy Code
Dim audioStream As Stream

Clipboard.SetAudio(audioStream)
C#
public static void SetAudio(
   Stream audioStream
)
Managed Extensions for C++
public: static void SetAudio(
   Stream* audioStream
)
C++/CLI
public:
static void SetAudio(
   Stream^ audioStream
)

Parameters

audioStream
A Stream containing the audio data.

Exceptions

Exception | Description
ThreadStateException | The current thread is not in single-threaded apartment (STA) mode. Add the STAThreadAttribute to your application's Main method.
ExternalException | The Clipboard could not be cleared. This typically occurs when the Clipboard is being used by another process.
ArgumentNullException | audioStream is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Clipboard Class
Clipboard Members
Overload List


SetData Method

[image]
Gizmox.WebGUI.Forms
SetData Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Clipboard Class : SetData Method

format
The format of the data to set. See DataFormats for predefined formats.
data
An Object representing the data to add.
Adds data to the Clipboard in the specified format.

Syntax

Visual Basic (Declaration)
Public Shared Sub SetData( _
   ByVal format As String, _
   ByVal data As Object _
)
Visual Basic (Usage) Copy Code
Dim format As String
Dim data As Object

Clipboard.SetData(format, data)
C#
public static void SetData(
   string format,
   object data
)
Managed Extensions for C++
public: static void SetData(
   string* format,
   Object* data
)
C++/CLI
public:
static void SetData(
   String^ format,
   Object^ data
)

Parameters

format
The format of the data to set. See DataFormats for predefined formats.
data
An Object representing the data to add.

Exceptions

Exception | Description
ThreadStateException | The current thread is not in single-threaded apartment (STA) mode. Add the STAThreadAttribute to your application's Main method.
ArgumentNullException | data is null.
ExternalException | The Clipboard could not be cleared. This typically occurs when the Clipboard is being used by another process.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Clipboard Class
Clipboard Members


SetDataObject Method

[image]
Gizmox.WebGUI.Forms
SetDataObject Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Clipboard Class : SetDataObject Method

Places nonpersistent data on the system Clipboard.

Overload List

Overload | Description
SetDataObject(Object) | Places nonpersistent data on the system Clipboard.
SetDataObject(Object,Boolean) | Places data on the system Clipboard and specifies whether the data should remain on the Clipboard after the application exits.
SetDataObject(Object,Boolean,Int32,Int32) | Attempts to place data on the system Clipboard the specified number of times and with the specified delay between attempts, optionally leaving the data on the Clipboard after the application exits.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Clipboard Class
Clipboard Members


SetDataObject(Object) Method

[image]
Gizmox.WebGUI.Forms
SetDataObject(Object) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Clipboard Class > SetDataObject Method : SetDataObject(Object) Method

data
The data to place on the Clipboard.
Places nonpersistent data on the system Clipboard.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Sub SetDataObject( _
   ByVal data As Object _
)
Visual Basic (Usage) Copy Code
Dim data As Object

Clipboard.SetDataObject(data)
C#
public static void SetDataObject(
   object data
)
Managed Extensions for C++
public: static void SetDataObject(
   Object* data
)
C++/CLI
public:
static void SetDataObject(
   Object^ data
)

Parameters

data
The data to place on the Clipboard.

Exceptions

Exception | Description
ThreadStateException | The current thread is not in single-threaded apartment (STA) mode. Add the STAThreadAttribute to your application's Main method.
ArgumentNullException | The value of data is null.
ExternalException | Data could not be placed on the Clipboard. This typically occurs when the Clipboard is being used by another process.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Clipboard Class
Clipboard Members
Overload List


SetDataObject(Object,Boolean) Method

[image]
Gizmox.WebGUI.Forms
SetDataObject(Object,Boolean) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Clipboard Class > SetDataObject Method : SetDataObject(Object,Boolean) Method

data
The data to place on the Clipboard.
copy
true if you want data to remain on the Clipboard after this application exits; otherwise, false.
Places data on the system Clipboard and specifies whether the data should remain on the Clipboard after the application exits.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Sub SetDataObject( _
   ByVal data As Object, _
   ByVal copy As Boolean _
)
Visual Basic (Usage) Copy Code
Dim data As Object
Dim copy As Boolean

Clipboard.SetDataObject(data, copy)
C#
public static void SetDataObject(
   object data,
   bool copy
)
Managed Extensions for C++
public: static void SetDataObject(
   Object* data,
   bool copy
)
C++/CLI
public:
static void SetDataObject(
   Object^ data,
   bool copy
)

Parameters

data
The data to place on the Clipboard.
copy
true if you want data to remain on the Clipboard after this application exits; otherwise, false.

Exceptions

Exception | Description
ThreadStateException | The current thread is not in single-threaded apartment (STA) mode. Add the STAThreadAttribute to your application's Main method.
ArgumentNullException | The value of data is null.
ExternalException | Data could not be placed on the Clipboard. This typically occurs when the Clipboard is being used by another process.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Clipboard Class
Clipboard Members
Overload List


SetDataObject(Object,Boolean,Int32,Int32) Method

[image]
Gizmox.WebGUI.Forms
SetDataObject(Object,Boolean,Int32,Int32) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Clipboard Class > SetDataObject Method : SetDataObject(Object,Boolean,Int32,Int32) Method

data
The data to place on the Clipboard.
copy
true if you want data to remain on the Clipboard after this application exits; otherwise, false.
retryTimes
The number of times to attempt placing the data on the Clipboard.
retryDelay
The number of milliseconds to pause between attempts.
Attempts to place data on the system Clipboard the specified number of times and with the specified delay between attempts, optionally leaving the data on the Clipboard after the application exits.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Sub SetDataObject( _
   ByVal data As Object, _
   ByVal copy As Boolean, _
   ByVal retryTimes As Integer, _
   ByVal retryDelay As Integer _
)
Visual Basic (Usage) Copy Code
Dim data As Object
Dim copy As Boolean
Dim retryTimes As Integer
Dim retryDelay As Integer

Clipboard.SetDataObject(data, copy, retryTimes, retryDelay)
C#
public static void SetDataObject(
   object data,
   bool copy,
   int retryTimes,
   int retryDelay
)
Managed Extensions for C++
public: static void SetDataObject(
   Object* data,
   bool copy,
   int retryTimes,
   int retryDelay
)
C++/CLI
public:
static void SetDataObject(
   Object^ data,
   bool copy,
   int retryTimes,
   int retryDelay
)

Parameters

data
The data to place on the Clipboard.
copy
true if you want data to remain on the Clipboard after this application exits; otherwise, false.
retryTimes
The number of times to attempt placing the data on the Clipboard.
retryDelay
The number of milliseconds to pause between attempts.

Exceptions

Exception | Description
ArgumentNullException | data is null.
ExternalException | Data could not be placed on the Clipboard. This typically occurs when the Clipboard is being used by another process.
ThreadStateException | The current thread is not in single-threaded apartment (STA) mode. Add the STAThreadAttribute to your application's Main method.
ArgumentOutOfRangeException | retryTimes is less than zero.-or-retryDelay is less than zero.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Clipboard Class
Clipboard Members
Overload List


SetFileDropList Method

[image]
Gizmox.WebGUI.Forms
SetFileDropList Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Clipboard Class : SetFileDropList Method

filePaths
A StringCollection containing the file names.
Adds a collection of file names to the Clipboard in the DataFormats.FileDrop format.

Syntax

Visual Basic (Declaration)
Public Shared Sub SetFileDropList( _
   ByVal filePaths As StringCollection _
)
Visual Basic (Usage) Copy Code
Dim filePaths As StringCollection

Clipboard.SetFileDropList(filePaths)
C#
public static void SetFileDropList(
   StringCollection filePaths
)
Managed Extensions for C++
public: static void SetFileDropList(
   StringCollection* filePaths
)
C++/CLI
public:
static void SetFileDropList(
   StringCollection^ filePaths
)

Parameters

filePaths
A StringCollection containing the file names.

Exceptions

Exception | Description
ThreadStateException | The current thread is not in single-threaded apartment (STA) mode. Add the STAThreadAttribute to your application's Main method.
ArgumentException | filePaths does not contain any strings.-or-At least one of the strings in filePaths is Empty, contains only white space, contains one or more invalid characters as defined by InvalidPathChars, is null, contains a colon (:), or exceeds the system-defined maximum length.See the InnerException property of the ArgumentException for more information.
ArgumentNullException | filePaths is null.
ExternalException | The Clipboard could not be cleared. This typically occurs when the Clipboard is being used by another process.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Clipboard Class
Clipboard Members


SetImage Method

[image]
Gizmox.WebGUI.Forms
SetImage Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Clipboard Class : SetImage Method

image
The Image to add to the Clipboard.
Adds an Image to the Clipboard in the DataFormats.Bitmap format.

Syntax

Visual Basic (Declaration)
Public Shared Sub SetImage( _
   ByVal image As Image _
)
Visual Basic (Usage) Copy Code
Dim image As Image

Clipboard.SetImage(image)
C#
public static void SetImage(
   Image image
)
Managed Extensions for C++
public: static void SetImage(
   Image* image
)
C++/CLI
public:
static void SetImage(
   Image^ image
)

Parameters

image
The Image to add to the Clipboard.

Exceptions

Exception | Description
ThreadStateException | The current thread is not in single-threaded apartment (STA) mode. Add the STAThreadAttribute to your application's Main method.
ArgumentNullException | image is null.
ExternalException | The Clipboard could not be cleared. This typically occurs when the Clipboard is being used by another process.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Clipboard Class
Clipboard Members


SetText Method

[image]
Gizmox.WebGUI.Forms
SetText Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Clipboard Class : SetText Method

Adds text data to the Clipboard in the TextDataFormat.Text or TextDataFormat.UnicodeText format, depending on the operating system.

Overload List

Overload | Description
SetText(String) | Adds text data to the Clipboard in the TextDataFormat.Text or TextDataFormat.UnicodeText format, depending on the operating system.
SetText(String,TextDataFormat) | Adds text data to the Clipboard in the format indicated by the specified TextDataFormat value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Clipboard Class
Clipboard Members


SetText(String) Method

[image]
Gizmox.WebGUI.Forms
SetText(String) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Clipboard Class > SetText Method : SetText(String) Method

text
The text to add to the Clipboard.
Adds text data to the Clipboard in the TextDataFormat.Text or TextDataFormat.UnicodeText format, depending on the operating system.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Sub SetText( _
   ByVal text As String _
)
Visual Basic (Usage) Copy Code
Dim text As String

Clipboard.SetText(text)
C#
public static void SetText(
   string text
)
Managed Extensions for C++
public: static void SetText(
   string* text
)
C++/CLI
public:
static void SetText(
   String^ text
)

Parameters

text
The text to add to the Clipboard.

Exceptions

Exception | Description
ArgumentNullException | text is null or Empty.
ThreadStateException | The current thread is not in single-threaded apartment (STA) mode. Add the STAThreadAttribute to your application's Main method.
ExternalException | The Clipboard could not be cleared. This typically occurs when the Clipboard is being used by another process.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Clipboard Class
Clipboard Members
Overload List


SetText(String,TextDataFormat) Method

[image]
Gizmox.WebGUI.Forms
SetText(String,TextDataFormat) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Clipboard Class > SetText Method : SetText(String,TextDataFormat) Method

text
The text to add to the Clipboard.
format
One of the TextDataFormat values.
Adds text data to the Clipboard in the format indicated by the specified TextDataFormat value.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Sub SetText( _
   ByVal text As String, _
   ByVal format As TextDataFormat _
)
Visual Basic (Usage) Copy Code
Dim text As String
Dim format As TextDataFormat

Clipboard.SetText(text, format)
C#
public static void SetText(
   string text,
   TextDataFormat format
)
Managed Extensions for C++
public: static void SetText(
   string* text,
   TextDataFormat format
)
C++/CLI
public:
static void SetText(
   String^ text,
   TextDataFormat format
)

Parameters

text
The text to add to the Clipboard.
format
One of the TextDataFormat values.

Exceptions

Exception | Description
ArgumentNullException | text is null or Empty.
ThreadStateException | The current thread is not in single-threaded apartment (STA) mode. Add the STAThreadAttribute to your application's Main method.
ExternalException | The Clipboard could not be cleared. This typically occurs when the Clipboard is being used by another process.
InvalidEnumArgumentException | format is not a valid TextDataFormat value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Clipboard Class
Clipboard Members
Overload List


Update Method

[image]
Gizmox.WebGUI.Forms
Update Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Clipboard Class : Update Method

Sends the current clipboard data to the client and clears the clip board

Overload List

Overload | Description
Update(TextDataFormat) | Sends the current clipboard data to the client and clears the clip board
Update(TextDataFormat,Boolean) | Sends the current clipboard data to the client

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Clipboard Class
Clipboard Members


Update(TextDataFormat) Method

[image]
Gizmox.WebGUI.Forms
Update(TextDataFormat) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Clipboard Class > Update Method : Update(TextDataFormat) Method

format
The clip board text format to send to the client
Sends the current clipboard data to the client and clears the clip board

Syntax

Visual Basic (Declaration)
Public Overloads Shared Sub Update( _
   ByVal format As TextDataFormat _
)
Visual Basic (Usage) Copy Code
Dim format As TextDataFormat

Clipboard.Update(format)
C#
public static void Update(
   TextDataFormat format
)
Managed Extensions for C++
public: static void Update(
   TextDataFormat format
)
C++/CLI
public:
static void Update(
   TextDataFormat format
)

Parameters

format
The clip board text format to send to the client

Remarks

This is has no effect in smart client mode.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Clipboard Class
Clipboard Members
Overload List


Update(TextDataFormat,Boolean) Method

[image]
Gizmox.WebGUI.Forms
Update(TextDataFormat,Boolean) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Clipboard Class > Update Method : Update(TextDataFormat,Boolean) Method

format
The clip board text format to send to the client
blnClear
A flag indicating if clipboard should be cleared after sending to client.
Sends the current clipboard data to the client

Syntax

Visual Basic (Declaration)
Public Overloads Shared Sub Update( _
   ByVal format As TextDataFormat, _
   ByVal blnClear As Boolean _
)
Visual Basic (Usage) Copy Code
Dim format As TextDataFormat
Dim blnClear As Boolean

Clipboard.Update(format, blnClear)
C#
public static void Update(
   TextDataFormat format,
   bool blnClear
)
Managed Extensions for C++
public: static void Update(
   TextDataFormat format,
   bool blnClear
)
C++/CLI
public:
static void Update(
   TextDataFormat format,
   bool blnClear
)

Parameters

format
The clip board text format to send to the client
blnClear
A flag indicating if clipboard should be cleared after sending to client.

Remarks

This is has no effect in smart client mode.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Clipboard Class
Clipboard Members
Overload List


ColorComboBox Class

[image]
Gizmox.WebGUI.Forms
ColorComboBox Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ColorComboBox Class

Represents a Gizmox.WebGUI.Forms combo box control.

Object Model

Syntax

Visual Basic (Declaration)
<SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableColorComboBox, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")>
<ToolboxItemCategoryAttribute("Common Controls")>
<ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<ToolboxBitmapAttribute()>
<MetadataTagAttribute("CCB")>
Public Class ColorComboBox
   Inherits ComboBox
   Implements IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Visual Basic (Usage) Copy Code
Dim instance As ColorComboBox
C#
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableColorComboBox, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[ToolboxItemCategoryAttribute("Common Controls")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ToolboxBitmapAttribute()]
[MetadataTagAttribute("CCB")]
public class ColorComboBox : ComboBox, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Managed Extensions for C++
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableColorComboBox, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[ToolboxItemCategoryAttribute("Common Controls")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ToolboxBitmapAttribute()]
[MetadataTagAttribute("CCB")]
public __gc class ColorComboBox : public ComboBox, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
C++/CLI
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableColorComboBox, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[ToolboxItemCategoryAttribute("Common Controls")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ToolboxBitmapAttribute()]
[MetadataTagAttribute("CCB")]
public ref class ColorComboBox : public ComboBox, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.ListControl
Gizmox.WebGUI.Forms.ComboBox
Gizmox.WebGUI.Forms.ColorComboBox

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

ColorComboBox Members
Gizmox.WebGUI.Forms Namespace


ColorComboBox Class Members

[image]
Gizmox.WebGUI.Forms
ColorComboBox Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : ColorComboBox Class

The following tables list the members exposed by ColorComboBox.

Public Constructors

 | Name | Description
Public Constructor | ColorComboBox Constructor | Creates a new ColorComboBox instance.
Top

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | AutoCompleteMode | Gets or sets the auto complete mode. (Inherited from ComboBox)
Public Property | AutoCompleteSource | Gets or sets the auto-completion source. (Inherited from ComboBox)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CodeMember | Gets or sets the code member. (Inherited from ComboBox)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | DataSource | Gets or sets the data source for this ListControl. (Inherited from ListControl)
Public Property | DisplayMember | Gets or sets the property to display for this ListControl. (Inherited from ListControl)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DragTargets | Gets a value indicating whether this instance is dragable. (Inherited from ComboBox)
Public Property | DropDownStyle | Gets or sets the drop down style. (Inherited from ComboBox)
Public Property | DropDownWidth | Gets or sets the width of the of the drop-down portion of a combo box. (Inherited from ComboBox)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | FormatInfo | Gets or sets the IFormatProvider that provides custom formatting behavior. (Inherited from ListControl)
Public Property | FormatString | Gets or sets the format-specifier characters that indicate how a value is to be displayed. (Inherited from ListControl)
Public Property | FormattingEnabled | Gets or sets a value indicating whether formatting is applied to the ListControl.DisplayMember property of the ListControl. (Inherited from ListControl)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | Items | Gets the items.
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaxDropDownItems | Gets or sets the maximum number of items to be shown in the drop-down portion of the ComboBox. (Inherited from ComboBox)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | SelectedIndex | Gets or sets the index specifying the currently selected item. (Inherited from ComboBox)
Public Property | SelectedItem | Gets or sets currently selected item in the ComboBox. (Inherited from ComboBox)
Public Property | SelectedValue | Gets or sets the value of the member property specified by the ListControl.ValueMember property. (Inherited from ListControl)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | Sorted | Gets or sets a value indicating whether the items in the combo box are sorted. (Inherited from ComboBox)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Override the Control Text When the combo control is binded to a BindingSource Text property(a string data member in the DB) we have to set the combo index to match the text. (Inherited from ComboBox)
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | ValueMember | Gets or sets the property to use as the actual value for the items in the ListControl. (Inherited from ListControl)
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | AllowSelection | Gets a value indicating whether the list enables selection of list items. (Inherited from ListControl)
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DataManager | Gets the CurrencyManager associated with this control. (Inherited from ListControl)
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsCustomDropDown | Gets a value indicating whether this instance has a custom drop down. (Inherited from ComboBox)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | IsPostBackRequired | Indicates if the list control context requires its events to cause callback (Inherited from ListControl)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | FindCode | Finds the item in the ListBox that has this code. (Inherited from ComboBox)
Public Method | FindString | Finds the first item in the ListBox that starts with the specified string. (Inherited from ComboBox)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetItemText | Overridden.
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | Returns a string that represents the ComboBox control. (Inherited from ComboBox)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | CreateItemCollection | Overridden.
Protected Method | FilterItemOnProperty | Overloaded. Retrieves the current value of the ListControl item, if it is a property of an object, given the item. (Inherited from ListControl)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from ComboBox)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from ComboBox)
Protected Method | GetCustomDropDown | Gets the custom form to display as drop down (Inherited from ComboBox)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from Control)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from ListControl)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDataSourceChanged | Raises the ListControl.DataSourceChanged event. (Inherited from ComboBox)
Protected Method | OnDisplayMemberChanged | Raises the ListControl.DisplayMemberChanged event. (Inherited from ListControl)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnFormat | Raises the ListControl.Format event. (Inherited from ListControl)
Protected Method | OnFormatInfoChanged | Raises the ListControl.FormatInfoChanged event. (Inherited from ListControl)
Protected Method | OnFormatStringChanged | Raises the ListControl.FormatStringChanged event. (Inherited from ListControl)
Protected Method | OnFormattingEnabledChanged | Raises the ListControl.FormattingEnabledChanged event. (Inherited from ListControl)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnSelectedIndexChanged | (Inherited from ComboBox)
Protected Method | OnSelectedIndexChangedQueued | Raises the OnSelectedIndexChangedQueued event (Inherited from ComboBox)
Protected Method | OnSelectedValueChanged | Raises the ListControl.SelectedValueChanged event. (Inherited from ListControl)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnValueMemberChanged | Raises the ListControl.ValueMemberChanged event. (Inherited from ListControl)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RefreshItem | When overridden in a derived class, resynchronizes the data of the object at the specified index with the contents of the data source. (Inherited from ComboBox)
Protected Method | RefreshItems | Refreshes all ComboBox items. (Inherited from ComboBox)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | Renders the current control. (Inherited from ComboBox)
Protected Method | RenderAttributes | (Inherited from ComboBox)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderItemAttributes | Overridden. Renders the item attributes.
Protected Method | RenderUpdatedAttributes | (Inherited from ComboBox)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SelectAll | Selects all items. (Inherited from ComboBox)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetItemCore | When overridden in a derived class, sets the object with the specified index in the derived class. (Inherited from ListControl)
Protected Method | SetItemsCore | When overridden in a derived class, sets the specified array of objects in a collection in the derived class. (Inherited from ComboBox)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | DataSourceChanged | Occurs when the ListControl.DataSource changes. (Inherited from ListControl)
Public Event | DisplayMemberChanged | Occurs when the ListControl.DisplayMember property changes. (Inherited from ListControl)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | Format | Occurs when the control is bound to a data value. (Inherited from ListControl)
Public Event | FormatInfoChanged | Occurs when the value of the ListControl.FormatInfo property changes. (Inherited from ListControl)
Public Event | FormatStringChanged | Occurs when value of the ListControl.FormatString property changes (Inherited from ListControl)
Public Event | FormattingEnabledChanged | Occurs when the value of the ListControl.FormattingEnabled property changes. (Inherited from ListControl)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | SelectedIndexChanged | Occurs when the ComboBox.SelectedIndex property has changed. (Inherited from ComboBox)
Public Event | SelectedIndexChangedQueued | Occurs when the SelectedIndex property has changed (Queued). (Inherited from ComboBox)
Public Event | SelectedValueChanged | Occurs when the ListControl.SelectedValue property changes. (Inherited from ListControl)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | ValueMemberChanged | Occurs when the ListControl.ValueMember property changes. (Inherited from ListControl)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

ColorComboBox Class
Gizmox.WebGUI.Forms Namespace


ColorComboBox Constructor

[image]
Gizmox.WebGUI.Forms
ColorComboBox Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ColorComboBox Class : ColorComboBox Constructor

Creates a new ColorComboBox instance.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ColorComboBox()
C#
public ColorComboBox()
Managed Extensions for C++
public: ColorComboBox();
C++/CLI
public:
ColorComboBox();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ColorComboBox Class
ColorComboBox Members


ColorComboBox Class Methods

[image]
Gizmox.WebGUI.Forms
ColorComboBox Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ColorComboBox Class

For a list of all members of this type, see ColorComboBox members.

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | FindCode | Finds the item in the ListBox that has this code. (Inherited from ComboBox)
Public Method | FindString | Finds the first item in the ListBox that starts with the specified string. (Inherited from ComboBox)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetItemText | Overridden.
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | Returns a string that represents the ComboBox control. (Inherited from ComboBox)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | CreateItemCollection | Overridden.
Protected Method | FilterItemOnProperty | Overloaded. Retrieves the current value of the ListControl item, if it is a property of an object, given the item. (Inherited from ListControl)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from ComboBox)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from ComboBox)
Protected Method | GetCustomDropDown | Gets the custom form to display as drop down (Inherited from ComboBox)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from Control)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from ListControl)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDataSourceChanged | Raises the ListControl.DataSourceChanged event. (Inherited from ComboBox)
Protected Method | OnDisplayMemberChanged | Raises the ListControl.DisplayMemberChanged event. (Inherited from ListControl)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnFormat | Raises the ListControl.Format event. (Inherited from ListControl)
Protected Method | OnFormatInfoChanged | Raises the ListControl.FormatInfoChanged event. (Inherited from ListControl)
Protected Method | OnFormatStringChanged | Raises the ListControl.FormatStringChanged event. (Inherited from ListControl)
Protected Method | OnFormattingEnabledChanged | Raises the ListControl.FormattingEnabledChanged event. (Inherited from ListControl)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnSelectedIndexChanged | (Inherited from ComboBox)
Protected Method | OnSelectedIndexChangedQueued | Raises the OnSelectedIndexChangedQueued event (Inherited from ComboBox)
Protected Method | OnSelectedValueChanged | Raises the ListControl.SelectedValueChanged event. (Inherited from ListControl)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnValueMemberChanged | Raises the ListControl.ValueMemberChanged event. (Inherited from ListControl)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RefreshItem | When overridden in a derived class, resynchronizes the data of the object at the specified index with the contents of the data source. (Inherited from ComboBox)
Protected Method | RefreshItems | Refreshes all ComboBox items. (Inherited from ComboBox)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | Renders the current control. (Inherited from ComboBox)
Protected Method | RenderAttributes | (Inherited from ComboBox)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderItemAttributes | Overridden. Renders the item attributes.
Protected Method | RenderUpdatedAttributes | (Inherited from ComboBox)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SelectAll | Selects all items. (Inherited from ComboBox)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetItemCore | When overridden in a derived class, sets the object with the specified index in the derived class. (Inherited from ListControl)
Protected Method | SetItemsCore | When overridden in a derived class, sets the specified array of objects in a collection in the derived class. (Inherited from ComboBox)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

See Also

Reference

ColorComboBox Class
Gizmox.WebGUI.Forms Namespace


CreateItemCollection Method

[image]
Gizmox.WebGUI.Forms
CreateItemCollection Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ColorComboBox Class : CreateItemCollection Method

Syntax

Visual Basic (Declaration)
Protected Overrides Function CreateItemCollection() As ComboBox.ObjectCollection
Visual Basic (Usage) Copy Code
Dim instance As ColorComboBox
Dim value As ComboBox.ObjectCollection

value = instance.CreateItemCollection()
C#
protected override ComboBox.ObjectCollection CreateItemCollection()
Managed Extensions for C++
protected: ComboBox.ObjectCollection* CreateItemCollection(); override
C++/CLI
protected:
ComboBox::ObjectCollection^ CreateItemCollection(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ColorComboBox Class
ColorComboBox Members


GetItemText Method

[image]
Gizmox.WebGUI.Forms
GetItemText Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ColorComboBox Class : GetItemText Method

objItem

Syntax

Visual Basic (Declaration)
Public Overrides Function GetItemText( _
   ByVal objItem As Object _
) As String
Visual Basic (Usage) Copy Code
Dim instance As ColorComboBox
Dim objItem As Object
Dim value As String

value = instance.GetItemText(objItem)
C#
public override string GetItemText(
   object objItem
)
Managed Extensions for C++
public: string* GetItemText(
   Object* objItem
) override
C++/CLI
public:
String^ GetItemText(
   Object^ objItem
) override

Parameters

objItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ColorComboBox Class
ColorComboBox Members


RenderItemAttributes Method

[image]
Gizmox.WebGUI.Forms
RenderItemAttributes Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ColorComboBox Class : RenderItemAttributes Method

objWriter
Writer.
objItem
Item.
intIndex
Item index.
Renders the item attributes.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub RenderItemAttributes( _
   ByVal objWriter As IResponseWriter, _
   ByVal objItem As Object, _
   ByVal intIndex As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As ColorComboBox
Dim objWriter As IResponseWriter
Dim objItem As Object
Dim intIndex As Integer

instance.RenderItemAttributes(objWriter, objItem, intIndex)
C#
protected override void RenderItemAttributes(
   IResponseWriter objWriter,
   object objItem,
   int intIndex
)
Managed Extensions for C++
protected: void RenderItemAttributes(
   IResponseWriter* objWriter,
   Object* objItem,
   int intIndex
) override
C++/CLI
protected:
void RenderItemAttributes(
   IResponseWriter^ objWriter,
   Object^ objItem,
   int intIndex
) override

Parameters

objWriter
Writer.
objItem
Item.
intIndex
Item index.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ColorComboBox Class
ColorComboBox Members


ColorComboBox Class Properties

[image]
Gizmox.WebGUI.Forms
ColorComboBox Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ColorComboBox Class

For a list of all members of this type, see ColorComboBox members.

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | AutoCompleteMode | Gets or sets the auto complete mode. (Inherited from ComboBox)
Public Property | AutoCompleteSource | Gets or sets the auto-completion source. (Inherited from ComboBox)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CodeMember | Gets or sets the code member. (Inherited from ComboBox)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | DataSource | Gets or sets the data source for this ListControl. (Inherited from ListControl)
Public Property | DisplayMember | Gets or sets the property to display for this ListControl. (Inherited from ListControl)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DragTargets | Gets a value indicating whether this instance is dragable. (Inherited from ComboBox)
Public Property | DropDownStyle | Gets or sets the drop down style. (Inherited from ComboBox)
Public Property | DropDownWidth | Gets or sets the width of the of the drop-down portion of a combo box. (Inherited from ComboBox)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | FormatInfo | Gets or sets the IFormatProvider that provides custom formatting behavior. (Inherited from ListControl)
Public Property | FormatString | Gets or sets the format-specifier characters that indicate how a value is to be displayed. (Inherited from ListControl)
Public Property | FormattingEnabled | Gets or sets a value indicating whether formatting is applied to the ListControl.DisplayMember property of the ListControl. (Inherited from ListControl)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | Items | Gets the items.
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaxDropDownItems | Gets or sets the maximum number of items to be shown in the drop-down portion of the ComboBox. (Inherited from ComboBox)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | SelectedIndex | Gets or sets the index specifying the currently selected item. (Inherited from ComboBox)
Public Property | SelectedItem | Gets or sets currently selected item in the ComboBox. (Inherited from ComboBox)
Public Property | SelectedValue | Gets or sets the value of the member property specified by the ListControl.ValueMember property. (Inherited from ListControl)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | Sorted | Gets or sets a value indicating whether the items in the combo box are sorted. (Inherited from ComboBox)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Override the Control Text When the combo control is binded to a BindingSource Text property(a string data member in the DB) we have to set the combo index to match the text. (Inherited from ComboBox)
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | ValueMember | Gets or sets the property to use as the actual value for the items in the ListControl. (Inherited from ListControl)
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | AllowSelection | Gets a value indicating whether the list enables selection of list items. (Inherited from ListControl)
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DataManager | Gets the CurrencyManager associated with this control. (Inherited from ListControl)
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsCustomDropDown | Gets a value indicating whether this instance has a custom drop down. (Inherited from ComboBox)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | IsPostBackRequired | Indicates if the list control context requires its events to cause callback (Inherited from ListControl)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

See Also

Reference

ColorComboBox Class
Gizmox.WebGUI.Forms Namespace


Items Property

[image]
Gizmox.WebGUI.Forms
Items Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ColorComboBox Class : Items Property

Gets the items.

Syntax

Visual Basic (Declaration)
<EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.ListControlStringCollectionEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")>
<DesignerSerializationVisibilityAttribute()>
<SRCategoryAttribute("Data")>
Public ReadOnly Property Items As ComboBox.ObjectCollection
Visual Basic (Usage) Copy Code
Dim instance As ColorComboBox
Dim value As ComboBox.ObjectCollection

value = instance.Items
C#
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.ListControlStringCollectionEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[DesignerSerializationVisibilityAttribute()]
[SRCategoryAttribute("Data")]
public ComboBox.ObjectCollection Items {get;}
Managed Extensions for C++
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.ListControlStringCollectionEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[DesignerSerializationVisibilityAttribute()]
[SRCategoryAttribute("Data")]
public: __property ComboBox.ObjectCollection* get_Items();
C++/CLI
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.ListControlStringCollectionEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[DesignerSerializationVisibilityAttribute()]
[SRCategoryAttribute("Data")]
public:
property ComboBox::ObjectCollection^ Items {
   ComboBox::ObjectCollection^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ColorComboBox Class
ColorComboBox Members


ColorComboBox.ObjectCollection Class

[image]
Gizmox.WebGUI.Forms
ColorComboBox.ObjectCollection Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ColorComboBox.ObjectCollection Class

Represents the collection of items in a ComboBox.

Syntax

Visual Basic (Declaration)
Public Class ColorComboBox.ObjectCollection
   Inherits ComboBox.ObjectCollection
Visual Basic (Usage) Copy Code
Dim instance As ColorComboBox.ObjectCollection
C#
public class ColorComboBox.ObjectCollection : ComboBox.ObjectCollection
Managed Extensions for C++
public __gc class ColorComboBox.ObjectCollection : public ComboBox.ObjectCollection
C++/CLI
public ref class ColorComboBox.ObjectCollection : public ComboBox::ObjectCollection

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComboBox.ObjectCollection
Gizmox.WebGUI.Forms.ColorComboBox.ObjectCollection

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

ColorComboBox.ObjectCollection Members
Gizmox.WebGUI.Forms Namespace


ColorComboBox.ObjectCollection Class Members

[image]
Gizmox.WebGUI.Forms
ColorComboBox.ObjectCollection Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : ColorComboBox.ObjectCollection Class

The following tables list the members exposed by ColorComboBox.ObjectCollection.

Public Properties

 | Name | Description
Public Property | Count | Gets the number of items in the collection. (Inherited from ComboBox.ObjectCollection)
Public Property | IsFixedSize | For a description of this member, see IsFixedSize. (Inherited from ComboBox.ObjectCollection)
Public Property | IsReadOnly | Gets a value indicating whether this collection can be modified. (Inherited from ComboBox.ObjectCollection)
Public Property | IsSynchronized | For a description of this member, see IsSynchronized. (Inherited from ComboBox.ObjectCollection)
Public Property | Item | Gets the Object with the specified int index. (Inherited from ComboBox.ObjectCollection)
Public Property | SyncRoot | Gets the sync root. (Inherited from ComboBox.ObjectCollection)
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Adds an item to the list of items for a ComboBox.
Public Method | AddRange | Overloaded. Adds an array of items to the list of items for a ComboBox. (Inherited from ComboBox.ObjectCollection)
Public Method | Clear | Removes all items from the ComboBox. (Inherited from ComboBox.ObjectCollection)
Public Method | Contains | Determines if the specified item is located within the collection. (Inherited from ComboBox.ObjectCollection)
Public Method | CopyTo | For a description of this member, see CopyTo. (Inherited from ComboBox.ObjectCollection)
Public Method | GetEnumerator | Returns an enumerator that can be used to iterate through the item collection. (Inherited from ComboBox.ObjectCollection)
Public Method | IndexOf | Retrieves the index within the collection of the specified item. (Inherited from ComboBox.ObjectCollection)
Public Method | Insert | Inserts an item into the collection at the specified index. (Inherited from ComboBox.ObjectCollection)
Public Method | Remove | Removes the specified item from the ComboBox. (Inherited from ComboBox.ObjectCollection)
Public Method | RemoveAt | Removes an item from the ComboBox at the specified index. (Inherited from ComboBox.ObjectCollection)
Top

See Also

Reference

ColorComboBox.ObjectCollection Class
Gizmox.WebGUI.Forms Namespace


ColorComboBox.ObjectCollection Class Methods

[image]
Gizmox.WebGUI.Forms
ColorComboBox.ObjectCollection Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ColorComboBox.ObjectCollection Class

For a list of all members of this type, see ColorComboBox.ObjectCollection members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Adds an item to the list of items for a ComboBox.
Public Method | AddRange | Overloaded. Adds an array of items to the list of items for a ComboBox. (Inherited from ComboBox.ObjectCollection)
Public Method | Clear | Removes all items from the ComboBox. (Inherited from ComboBox.ObjectCollection)
Public Method | Contains | Determines if the specified item is located within the collection. (Inherited from ComboBox.ObjectCollection)
Public Method | CopyTo | For a description of this member, see CopyTo. (Inherited from ComboBox.ObjectCollection)
Public Method | GetEnumerator | Returns an enumerator that can be used to iterate through the item collection. (Inherited from ComboBox.ObjectCollection)
Public Method | IndexOf | Retrieves the index within the collection of the specified item. (Inherited from ComboBox.ObjectCollection)
Public Method | Insert | Inserts an item into the collection at the specified index. (Inherited from ComboBox.ObjectCollection)
Public Method | Remove | Removes the specified item from the ComboBox. (Inherited from ComboBox.ObjectCollection)
Public Method | RemoveAt | Removes an item from the ComboBox at the specified index. (Inherited from ComboBox.ObjectCollection)
Top

See Also

Reference

ColorComboBox.ObjectCollection Class
Gizmox.WebGUI.Forms Namespace


Add Method

[image]
Gizmox.WebGUI.Forms
Add Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ColorComboBox.ObjectCollection Class : Add Method

Adds an item to the list of items for a ComboBox.

Overload List

Overload | Description
Add(Color) |
Add(Object) | Adds an item to the list of items for a ComboBox. (Inherited from ComboBox.ObjectCollection)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ColorComboBox.ObjectCollection Class
ColorComboBox.ObjectCollection Members


Add(Color) Method

[image]
Gizmox.WebGUI.Forms
Add(Color) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ColorComboBox.ObjectCollection Class > Add Method : Add(Color) Method

objColor

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal objColor As Color _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As ColorComboBox.ObjectCollection
Dim objColor As Color
Dim value As Integer

value = instance.Add(objColor)
C#
public int Add(
   Color objColor
)
Managed Extensions for C++
public: int Add(
   Color objColor
)
C++/CLI
public:
int Add(
   Color objColor
)

Parameters

objColor

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ColorComboBox.ObjectCollection Class
ColorComboBox.ObjectCollection Members
Overload List


ColorDialog Class

[image]
Gizmox.WebGUI.Forms
ColorDialog Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ColorDialog Class

Represents a common dialog box that displays available colors along with controls that enable the user to define custom colors.

Syntax

Visual Basic (Declaration)
<ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<ToolboxBitmapAttribute()>
<DefaultPropertyAttribute("Color")>
<SRDescriptionAttribute("Displays available colors along with controls that enable the user to define custom colors.")>
Public Class ColorDialog
   Inherits CommonDialog
   Implements ICommonDialog
Visual Basic (Usage) Copy Code
Dim instance As ColorDialog
C#
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ToolboxBitmapAttribute()]
[DefaultPropertyAttribute("Color")]
[SRDescriptionAttribute("Displays available colors along with controls that enable the user to define custom colors.")]
public class ColorDialog : CommonDialog, ICommonDialog
Managed Extensions for C++
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ToolboxBitmapAttribute()]
[DefaultPropertyAttribute("Color")]
[SRDescriptionAttribute("Displays available colors along with controls that enable the user to define custom colors.")]
public __gc class ColorDialog : public CommonDialog, ICommonDialog
C++/CLI
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ToolboxBitmapAttribute()]
[DefaultPropertyAttribute("Color")]
[SRDescriptionAttribute("Displays available colors along with controls that enable the user to define custom colors.")]
public ref class ColorDialog : public CommonDialog, ICommonDialog

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.CommonDialog
Gizmox.WebGUI.Forms.ColorDialog

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

ColorDialog Members
Gizmox.WebGUI.Forms Namespace


ColorDialog Class Members

[image]
Gizmox.WebGUI.Forms
ColorDialog Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : ColorDialog Class

The following tables list the members exposed by ColorDialog.

Public Constructors

 | Name | Description
Public Constructor | ColorDialog Constructor | Initializes a new instance of the ColorDialog class.
Top

Public Properties

 | Name | Description
Public Property | AllowFullOpen | Gets or sets a value indicating whether the user can use the dialog box to define custom colors.
Public Property | AnyColor | Gets or sets a value indicating whether the dialog box displays all available colors in the set of basic colors.
Public Property | Color | Gets or sets the color selected by the user.
Public Property | Container | (Inherited from ComponentBase)
Public Property | CustomColors | Gets or sets the set of custom colors shown in the dialog box.
Public Property | DialogResult | Returns the last dialog result (Inherited from CommonDialog)
Public Property | FullOpen | Gets or sets a value indicating whether the controls used to create custom colors are visible when the dialog box is opened
Public Property | ShowHelp | Gets or sets a value indicating whether a Help button appears in the color dialog box.
Public Property | Site | (Inherited from ComponentBase)
Public Property | SolidColorOnly | Gets or sets a value indicating whether the dialog box will restrict users to selecting solid colors only.
Public Property | Tag | Gets or sets an object that contains data about the control. (Inherited from CommonDialog)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | Options | Gets values to initialize the ColorDialog.
Top

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded. (Inherited from ComponentBase)
Public Method | Reset | Overridden. Resets all options to their default values, the last selected color to black, and the custom colors to their default values.
Public Method | ShowDialog | Overloaded. Runs a common dialog box with a default owner. (Inherited from CommonDialog)
Public Method | ToString | Overridden. Returns a string that represents the ColorDialog.
Top

Protected Methods

 | Name | Description
Protected Method | CreateForm | Overridden. Create the color dialog form
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | OnApply | Handles apply event (Inherited from CommonDialog)
Protected Method | OnClosed | Raises the Close event. (Inherited from CommonDialog)
Protected Method | OnHelpRequest | Raises the CommonDialog.HelpRequest event. (Inherited from CommonDialog)
Top

Public Events

 | Name | Description
Public Event | Closed | The form close event (Inherited from CommonDialog)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | HelpRequest | Occurs when the user clicks the Help button on a common dialog box. (Inherited from CommonDialog)
Top

See Also

Reference

ColorDialog Class
Gizmox.WebGUI.Forms Namespace


ColorDialog Constructor

[image]
Gizmox.WebGUI.Forms
ColorDialog Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ColorDialog Class : ColorDialog Constructor

Initializes a new instance of the ColorDialog class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ColorDialog()
C#
public ColorDialog()
Managed Extensions for C++
public: ColorDialog();
C++/CLI
public:
ColorDialog();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ColorDialog Class
ColorDialog Members


ColorDialog Class Methods

[image]
Gizmox.WebGUI.Forms
ColorDialog Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ColorDialog Class

For a list of all members of this type, see ColorDialog members.

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded. (Inherited from ComponentBase)
Public Method | Reset | Overridden. Resets all options to their default values, the last selected color to black, and the custom colors to their default values.
Public Method | ShowDialog | Overloaded. Runs a common dialog box with a default owner. (Inherited from CommonDialog)
Public Method | ToString | Overridden. Returns a string that represents the ColorDialog.
Top

Protected Methods

 | Name | Description
Protected Method | CreateForm | Overridden. Create the color dialog form
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | OnApply | Handles apply event (Inherited from CommonDialog)
Protected Method | OnClosed | Raises the Close event. (Inherited from CommonDialog)
Protected Method | OnHelpRequest | Raises the CommonDialog.HelpRequest event. (Inherited from CommonDialog)
Top

See Also

Reference

ColorDialog Class
Gizmox.WebGUI.Forms Namespace


CreateForm Method

[image]
Gizmox.WebGUI.Forms
CreateForm Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ColorDialog Class : CreateForm Method

Create the color dialog form

Syntax

Visual Basic (Declaration)
Protected Overrides Function CreateForm() As CommonDialog.CommonDialogForm
Visual Basic (Usage) Copy Code
Dim instance As ColorDialog
Dim value As CommonDialog.CommonDialogForm

value = instance.CreateForm()
C#
protected override CommonDialog.CommonDialogForm CreateForm()
Managed Extensions for C++
protected: CommonDialog.CommonDialogForm* CreateForm(); override
C++/CLI
protected:
CommonDialog::CommonDialogForm^ CreateForm(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ColorDialog Class
ColorDialog Members


Reset Method

[image]
Gizmox.WebGUI.Forms
Reset Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ColorDialog Class : Reset Method

Resets all options to their default values, the last selected color to black, and the custom colors to their default values.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As ColorDialog

instance.Reset()
C#
public override void Reset()
Managed Extensions for C++
public: void Reset(); override
C++/CLI
public:
void Reset(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ColorDialog Class
ColorDialog Members


ToString Method

[image]
Gizmox.WebGUI.Forms
ToString Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ColorDialog Class : ToString Method

Returns a string that represents the ColorDialog.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As ColorDialog
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Return Value

A String that represents the current ColorDialog.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ColorDialog Class
ColorDialog Members


ColorDialog Class Properties

[image]
Gizmox.WebGUI.Forms
ColorDialog Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ColorDialog Class

For a list of all members of this type, see ColorDialog members.

Public Properties

 | Name | Description
Public Property | AllowFullOpen | Gets or sets a value indicating whether the user can use the dialog box to define custom colors.
Public Property | AnyColor | Gets or sets a value indicating whether the dialog box displays all available colors in the set of basic colors.
Public Property | Color | Gets or sets the color selected by the user.
Public Property | Container | (Inherited from ComponentBase)
Public Property | CustomColors | Gets or sets the set of custom colors shown in the dialog box.
Public Property | DialogResult | Returns the last dialog result (Inherited from CommonDialog)
Public Property | FullOpen | Gets or sets a value indicating whether the controls used to create custom colors are visible when the dialog box is opened
Public Property | ShowHelp | Gets or sets a value indicating whether a Help button appears in the color dialog box.
Public Property | Site | (Inherited from ComponentBase)
Public Property | SolidColorOnly | Gets or sets a value indicating whether the dialog box will restrict users to selecting solid colors only.
Public Property | Tag | Gets or sets an object that contains data about the control. (Inherited from CommonDialog)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | Options | Gets values to initialize the ColorDialog.
Top

See Also

Reference

ColorDialog Class
Gizmox.WebGUI.Forms Namespace


AllowFullOpen Property

[image]
Gizmox.WebGUI.Forms
AllowFullOpen Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ColorDialog Class : AllowFullOpen Property

Gets or sets a value indicating whether the user can use the dialog box to define custom colors.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<SRCategoryAttribute("Behavior")>
<SRDescriptionAttribute("Enables and disables the Define Custom Colors button.")>
Public Overridable Property AllowFullOpen As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ColorDialog
Dim value As Boolean

instance.AllowFullOpen = value

value = instance.AllowFullOpen
C#
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Enables and disables the Define Custom Colors button.")]
public virtual bool AllowFullOpen {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Enables and disables the Define Custom Colors button.")]
public: __property virtual bool get_AllowFullOpen();
public: __property virtual void set_AllowFullOpen(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Enables and disables the Define Custom Colors button.")]
public:
virtual property bool AllowFullOpen {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ColorDialog Class
ColorDialog Members


AnyColor Property

[image]
Gizmox.WebGUI.Forms
AnyColor Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ColorDialog Class : AnyColor Property

Gets or sets a value indicating whether the dialog box displays all available colors in the set of basic colors.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<SRDescriptionAttribute("Indicates whether the dialog box displays all available colors in the set of basic colors.")>
<SRCategoryAttribute("Behavior")>
Public Overridable Property AnyColor As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ColorDialog
Dim value As Boolean

instance.AnyColor = value

value = instance.AnyColor
C#
[DefaultValueAttribute()]
[SRDescriptionAttribute("Indicates whether the dialog box displays all available colors in the set of basic colors.")]
[SRCategoryAttribute("Behavior")]
public virtual bool AnyColor {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[SRDescriptionAttribute("Indicates whether the dialog box displays all available colors in the set of basic colors.")]
[SRCategoryAttribute("Behavior")]
public: __property virtual bool get_AnyColor();
public: __property virtual void set_AnyColor(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
[SRDescriptionAttribute("Indicates whether the dialog box displays all available colors in the set of basic colors.")]
[SRCategoryAttribute("Behavior")]
public:
virtual property bool AnyColor {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ColorDialog Class
ColorDialog Members


Color Property

[image]
Gizmox.WebGUI.Forms
Color Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ColorDialog Class : Color Property

Gets or sets the color selected by the user.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Data")>
<SRDescriptionAttribute("The color selected in the dialog box.")>
Public Property Color As Color
Visual Basic (Usage) Copy Code
Dim instance As ColorDialog
Dim value As Color

instance.Color = value

value = instance.Color
C#
[SRCategoryAttribute("Data")]
[SRDescriptionAttribute("The color selected in the dialog box.")]
public Color Color {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Data")]
[SRDescriptionAttribute("The color selected in the dialog box.")]
public: __property Color get_Color();
public: __property void set_Color(
   Color value
);
C++/CLI
[SRCategoryAttribute("Data")]
[SRDescriptionAttribute("The color selected in the dialog box.")]
public:
property Color Color {
   Color get();
   void set (Colorvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ColorDialog Class
ColorDialog Members


CustomColors Property

[image]
Gizmox.WebGUI.Forms
CustomColors Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ColorDialog Class : CustomColors Property

Gets or sets the set of custom colors shown in the dialog box.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("The custom set of colors shown in the dialog box.")>
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
Public Property CustomColors As Integer()
Visual Basic (Usage) Copy Code
Dim instance As ColorDialog
Dim value() As Integer

instance.CustomColors = value

value = instance.CustomColors
C#
[SRDescriptionAttribute("The custom set of colors shown in the dialog box.")]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public int[] CustomColors {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("The custom set of colors shown in the dialog box.")]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public: __property int[]* get_CustomColors();
public: __property void set_CustomColors(
   int[]* value
);
C++/CLI
[SRDescriptionAttribute("The custom set of colors shown in the dialog box.")]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public:
property array<int>^ CustomColors {
   array<int>^ get();
   void set (intarray<value>^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ColorDialog Class
ColorDialog Members


FullOpen Property

[image]
Gizmox.WebGUI.Forms
FullOpen Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ColorDialog Class : FullOpen Property

Gets or sets a value indicating whether the controls used to create custom colors are visible when the dialog box is opened

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Controls whether the custom color section of the dialog box is initially displayed.")>
<SRCategoryAttribute("Appearance")>
<DefaultValueAttribute()>
Public Overridable Property FullOpen As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ColorDialog
Dim value As Boolean

instance.FullOpen = value

value = instance.FullOpen
C#
[SRDescriptionAttribute("Controls whether the custom color section of the dialog box is initially displayed.")]
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
public virtual bool FullOpen {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Controls whether the custom color section of the dialog box is initially displayed.")]
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
public: __property virtual bool get_FullOpen();
public: __property virtual void set_FullOpen(
   bool value
);
C++/CLI
[SRDescriptionAttribute("Controls whether the custom color section of the dialog box is initially displayed.")]
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
public:
virtual property bool FullOpen {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ColorDialog Class
ColorDialog Members


Options Property

[image]
Gizmox.WebGUI.Forms
Options Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ColorDialog Class : Options Property

Gets values to initialize the ColorDialog.

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property Options As Integer
Visual Basic (Usage) Copy Code
Dim instance As ColorDialog
Dim value As Integer

value = instance.Options
C#
protected virtual int Options {get;}
Managed Extensions for C++
protected: __property virtual int get_Options();
C++/CLI
protected:
virtual property int Options {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ColorDialog Class
ColorDialog Members


ShowHelp Property

[image]
Gizmox.WebGUI.Forms
ShowHelp Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ColorDialog Class : ShowHelp Property

Gets or sets a value indicating whether a Help button appears in the color dialog box.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Controls whether the Help button is displayed.")>
<SRCategoryAttribute("Behavior")>
<DefaultValueAttribute()>
Public Overridable Property ShowHelp As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ColorDialog
Dim value As Boolean

instance.ShowHelp = value

value = instance.ShowHelp
C#
[SRDescriptionAttribute("Controls whether the Help button is displayed.")]
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
public virtual bool ShowHelp {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Controls whether the Help button is displayed.")]
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
public: __property virtual bool get_ShowHelp();
public: __property virtual void set_ShowHelp(
   bool value
);
C++/CLI
[SRDescriptionAttribute("Controls whether the Help button is displayed.")]
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
public:
virtual property bool ShowHelp {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ColorDialog Class
ColorDialog Members


SolidColorOnly Property

[image]
Gizmox.WebGUI.Forms
SolidColorOnly Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ColorDialog Class : SolidColorOnly Property

Gets or sets a value indicating whether the dialog box will restrict users to selecting solid colors only.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Behavior")>
<SRDescriptionAttribute("Indicates whether the dialog box will restrict users to only selecting solid colors.")>
<DefaultValueAttribute()>
Public Overridable Property SolidColorOnly As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ColorDialog
Dim value As Boolean

instance.SolidColorOnly = value

value = instance.SolidColorOnly
C#
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Indicates whether the dialog box will restrict users to only selecting solid colors.")]
[DefaultValueAttribute()]
public virtual bool SolidColorOnly {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Indicates whether the dialog box will restrict users to only selecting solid colors.")]
[DefaultValueAttribute()]
public: __property virtual bool get_SolidColorOnly();
public: __property virtual void set_SolidColorOnly(
   bool value
);
C++/CLI
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Indicates whether the dialog box will restrict users to only selecting solid colors.")]
[DefaultValueAttribute()]
public:
virtual property bool SolidColorOnly {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ColorDialog Class
ColorDialog Members


ColorListBox Class

[image]
Gizmox.WebGUI.Forms
ColorListBox Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ColorListBox Class

Summary description for ColorListBox.

Object Model

Syntax

Visual Basic (Declaration)
<MetadataTagAttribute("CL")>
<SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableColorListBox, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")>
<ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<DesignTimeControllerAttribute()>
<ClientControllerAttribute()>
<ToolboxBitmapAttribute()>
<ToolboxItemCategoryAttribute("Common Controls")>
Public Class ColorListBox
   Inherits ListBox
   Implements IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Visual Basic (Usage) Copy Code
Dim instance As ColorListBox
C#
[MetadataTagAttribute("CL")]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableColorListBox, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[DesignTimeControllerAttribute()]
[ClientControllerAttribute()]
[ToolboxBitmapAttribute()]
[ToolboxItemCategoryAttribute("Common Controls")]
public class ColorListBox : ListBox, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Managed Extensions for C++
[MetadataTagAttribute("CL")]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableColorListBox, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[DesignTimeControllerAttribute()]
[ClientControllerAttribute()]
[ToolboxBitmapAttribute()]
[ToolboxItemCategoryAttribute("Common Controls")]
public __gc class ColorListBox : public ListBox, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
C++/CLI
[MetadataTagAttribute("CL")]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableColorListBox, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[DesignTimeControllerAttribute()]
[ClientControllerAttribute()]
[ToolboxBitmapAttribute()]
[ToolboxItemCategoryAttribute("Common Controls")]
public ref class ColorListBox : public ListBox, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.ListControl
Gizmox.WebGUI.Forms.ListBox
Gizmox.WebGUI.Forms.ColorListBox

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

ColorListBox Members
Gizmox.WebGUI.Forms Namespace


ColorListBox Class Members

[image]
Gizmox.WebGUI.Forms
ColorListBox Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : ColorListBox Class

The following tables list the members exposed by ColorListBox.

Public Constructors

 | Name | Description
Public Constructor | ColorListBox Constructor | Creates a new ColorListBox instance.
Top

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | CheckBoxes | Gets or sets a value indicating whether [check boxes]. (Inherited from ListBox)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | DataSource | Gets or sets the data source for this ListControl. (Inherited from ListControl)
Public Property | DisplayMember | Gets or sets the property to display for this ListControl. (Inherited from ListControl)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | FormatInfo | Gets or sets the IFormatProvider that provides custom formatting behavior. (Inherited from ListControl)
Public Property | FormatString | Gets or sets the format-specifier characters that indicate how a value is to be displayed. (Inherited from ListControl)
Public Property | FormattingEnabled | Gets or sets a value indicating whether formatting is applied to the ListControl.DisplayMember property of the ListControl. (Inherited from ListControl)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | Items | Gets the items.
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | RadioBoxes | Gets or sets a value indicating whether [radio boxes]. (Inherited from ListBox)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | SelectedIndex | Gets or sets the zero-based index of the currently selected item in a ListBox. (Inherited from ListBox)
Public Property | SelectedIndices | Gets a collection that contains the zero-based indexes of all currently selected items in the ListBox. (Inherited from ListBox)
Public Property | SelectedItem | Gets or sets the currently selected item in the ListBox. (Inherited from ListBox)
Public Property | SelectedItems | Gets a collection containing the currently selected items in the ListBox. (Inherited from ListBox)
Public Property | SelectedValue | Gets or sets the value of the member property specified by the ListControl.ValueMember property. (Inherited from ListControl)
Public Property | SelectionMode | Gets or sets the method in which items are selected in the ListBox. (Inherited from ListBox)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | Sorted | Gets or sets a value indicating whether the items in the ListBox are sorted alphabetically. (Inherited from ListBox)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Control)
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | ValueMember | Gets or sets the property to use as the actual value for the items in the ListControl. (Inherited from ListControl)
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | AllowSelection | Gets a value indicating whether the list enables selection of list items. (Inherited from ListControl)
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DataManager | Gets the CurrencyManager associated with this control. (Inherited from ListControl)
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | Gets a value indicating whether this instance is delayed drawing. (Inherited from ListBox)
Protected Property | IsPostBackRequired | Indicates if the list control context requires its events to cause callback (Inherited from ListControl)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | ClearSelected | Unselects all items in the ListBox. (Inherited from ListBox)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | FindString | Overloaded. Finds the first item in the ListBox that starts with the specified string. (Inherited from ListBox)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetItemText | Overridden.
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | SetSelected | Selects or clears the selection for the specified item in a ListBox. (Inherited from ListBox)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | SwapItems | Swaps the items. (Inherited from ListBox)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | CreateItemCollection | Overridden.
Protected Method | FilterItemOnProperty | Overloaded. Retrieves the current value of the ListControl item, if it is a property of an object, given the item. (Inherited from ListControl)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from ListBox)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from ListBox)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from Control)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from ListControl)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDataSourceChanged | Raises the ListControl.DataSourceChanged event. (Inherited from ListBox)
Protected Method | OnDisplayMemberChanged | (Inherited from ListBox)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnFormat | Raises the ListControl.Format event. (Inherited from ListControl)
Protected Method | OnFormatInfoChanged | Raises the ListControl.FormatInfoChanged event. (Inherited from ListControl)
Protected Method | OnFormatStringChanged | Raises the ListControl.FormatStringChanged event. (Inherited from ListControl)
Protected Method | OnFormattingEnabledChanged | Raises the ListControl.FormattingEnabledChanged event. (Inherited from ListControl)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnSelectedIndexChanged | (Inherited from ListBox)
Protected Method | OnSelectedValueChanged | Raises the ListControl.SelectedValueChanged event. (Inherited from ListControl)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnValueMemberChanged | Raises the ListControl.ValueMemberChanged event. (Inherited from ListControl)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RefreshItem | When overridden in a derived class, resynchronizes the data of the object at the specified index with the contents of the data source. (Inherited from ListBox)
Protected Method | RefreshItems | Refreshes all ListBox items and retrieves new strings for them. (Inherited from ListBox)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | Renders the current control. (Inherited from ListBox)
Protected Method | RenderAttributes | Renders the controls meta attributes (Inherited from Control)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderItemAttributes | Overridden. Renders the item attributes.
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetItemCore | When overridden in a derived class, sets the object with the specified index in the derived class. (Inherited from ListControl)
Protected Method | SetItemsCore | When overridden in a derived class, sets the specified array of objects in a collection in the derived class. (Inherited from ListBox)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSelectionMode | Should serialize selection mode. (Inherited from ListBox)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | Sort | Sorts the items in the ListBox. (Inherited from ListBox)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | DataSourceChanged | Occurs when the ListControl.DataSource changes. (Inherited from ListControl)
Public Event | DisplayMemberChanged | Occurs when the ListControl.DisplayMember property changes. (Inherited from ListControl)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | Format | Occurs when the control is bound to a data value. (Inherited from ListControl)
Public Event | FormatInfoChanged | Occurs when the value of the ListControl.FormatInfo property changes. (Inherited from ListControl)
Public Event | FormatStringChanged | Occurs when value of the ListControl.FormatString property changes (Inherited from ListControl)
Public Event | FormattingEnabledChanged | Occurs when the value of the ListControl.FormattingEnabled property changes. (Inherited from ListControl)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | SelectedIndexChanged | Occurs when the SelectedIndex property has changed. (Inherited from ListBox)
Public Event | SelectedValueChanged | Occurs when the ListControl.SelectedValue property changes. (Inherited from ListControl)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | ValueMemberChanged | Occurs when the ListControl.ValueMember property changes. (Inherited from ListControl)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

ColorListBox Class
Gizmox.WebGUI.Forms Namespace


ColorListBox Constructor

[image]
Gizmox.WebGUI.Forms
ColorListBox Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ColorListBox Class : ColorListBox Constructor

Creates a new ColorListBox instance.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ColorListBox()
C#
public ColorListBox()
Managed Extensions for C++
public: ColorListBox();
C++/CLI
public:
ColorListBox();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ColorListBox Class
ColorListBox Members


ColorListBox Class Methods

[image]
Gizmox.WebGUI.Forms
ColorListBox Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ColorListBox Class

For a list of all members of this type, see ColorListBox members.

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | ClearSelected | Unselects all items in the ListBox. (Inherited from ListBox)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | FindString | Overloaded. Finds the first item in the ListBox that starts with the specified string. (Inherited from ListBox)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetItemText | Overridden.
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | SetSelected | Selects or clears the selection for the specified item in a ListBox. (Inherited from ListBox)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | SwapItems | Swaps the items. (Inherited from ListBox)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | CreateItemCollection | Overridden.
Protected Method | FilterItemOnProperty | Overloaded. Retrieves the current value of the ListControl item, if it is a property of an object, given the item. (Inherited from ListControl)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from ListBox)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from ListBox)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from Control)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from ListControl)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDataSourceChanged | Raises the ListControl.DataSourceChanged event. (Inherited from ListBox)
Protected Method | OnDisplayMemberChanged | (Inherited from ListBox)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnFormat | Raises the ListControl.Format event. (Inherited from ListControl)
Protected Method | OnFormatInfoChanged | Raises the ListControl.FormatInfoChanged event. (Inherited from ListControl)
Protected Method | OnFormatStringChanged | Raises the ListControl.FormatStringChanged event. (Inherited from ListControl)
Protected Method | OnFormattingEnabledChanged | Raises the ListControl.FormattingEnabledChanged event. (Inherited from ListControl)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnSelectedIndexChanged | (Inherited from ListBox)
Protected Method | OnSelectedValueChanged | Raises the ListControl.SelectedValueChanged event. (Inherited from ListControl)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnValueMemberChanged | Raises the ListControl.ValueMemberChanged event. (Inherited from ListControl)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RefreshItem | When overridden in a derived class, resynchronizes the data of the object at the specified index with the contents of the data source. (Inherited from ListBox)
Protected Method | RefreshItems | Refreshes all ListBox items and retrieves new strings for them. (Inherited from ListBox)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | Renders the current control. (Inherited from ListBox)
Protected Method | RenderAttributes | Renders the controls meta attributes (Inherited from Control)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderItemAttributes | Overridden. Renders the item attributes.
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetItemCore | When overridden in a derived class, sets the object with the specified index in the derived class. (Inherited from ListControl)
Protected Method | SetItemsCore | When overridden in a derived class, sets the specified array of objects in a collection in the derived class. (Inherited from ListBox)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSelectionMode | Should serialize selection mode. (Inherited from ListBox)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | Sort | Sorts the items in the ListBox. (Inherited from ListBox)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

See Also

Reference

ColorListBox Class
Gizmox.WebGUI.Forms Namespace


CreateItemCollection Method

[image]
Gizmox.WebGUI.Forms
CreateItemCollection Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ColorListBox Class : CreateItemCollection Method

Syntax

Visual Basic (Declaration)
Protected Overrides Function CreateItemCollection() As ListBox.ObjectCollection
Visual Basic (Usage) Copy Code
Dim instance As ColorListBox
Dim value As ListBox.ObjectCollection

value = instance.CreateItemCollection()
C#
protected override ListBox.ObjectCollection CreateItemCollection()
Managed Extensions for C++
protected: ListBox.ObjectCollection* CreateItemCollection(); override
C++/CLI
protected:
ListBox::ObjectCollection^ CreateItemCollection(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ColorListBox Class
ColorListBox Members


GetItemText Method

[image]
Gizmox.WebGUI.Forms
GetItemText Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ColorListBox Class : GetItemText Method

objItem

Syntax

Visual Basic (Declaration)
Public Overrides Function GetItemText( _
   ByVal objItem As Object _
) As String
Visual Basic (Usage) Copy Code
Dim instance As ColorListBox
Dim objItem As Object
Dim value As String

value = instance.GetItemText(objItem)
C#
public override string GetItemText(
   object objItem
)
Managed Extensions for C++
public: string* GetItemText(
   Object* objItem
) override
C++/CLI
public:
String^ GetItemText(
   Object^ objItem
) override

Parameters

objItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ColorListBox Class
ColorListBox Members


RenderItemAttributes Method

[image]
Gizmox.WebGUI.Forms
RenderItemAttributes Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ColorListBox Class : RenderItemAttributes Method

objWriter
Writer.
objItem
Item.
intIndex
Item index.
Renders the item attributes.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub RenderItemAttributes( _
   ByVal objWriter As IResponseWriter, _
   ByVal objItem As Object, _
   ByVal intIndex As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As ColorListBox
Dim objWriter As IResponseWriter
Dim objItem As Object
Dim intIndex As Integer

instance.RenderItemAttributes(objWriter, objItem, intIndex)
C#
protected override void RenderItemAttributes(
   IResponseWriter objWriter,
   object objItem,
   int intIndex
)
Managed Extensions for C++
protected: void RenderItemAttributes(
   IResponseWriter* objWriter,
   Object* objItem,
   int intIndex
) override
C++/CLI
protected:
void RenderItemAttributes(
   IResponseWriter^ objWriter,
   Object^ objItem,
   int intIndex
) override

Parameters

objWriter
Writer.
objItem
Item.
intIndex
Item index.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ColorListBox Class
ColorListBox Members


ColorListBox Class Properties

[image]
Gizmox.WebGUI.Forms
ColorListBox Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ColorListBox Class

For a list of all members of this type, see ColorListBox members.

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | CheckBoxes | Gets or sets a value indicating whether [check boxes]. (Inherited from ListBox)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | DataSource | Gets or sets the data source for this ListControl. (Inherited from ListControl)
Public Property | DisplayMember | Gets or sets the property to display for this ListControl. (Inherited from ListControl)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | FormatInfo | Gets or sets the IFormatProvider that provides custom formatting behavior. (Inherited from ListControl)
Public Property | FormatString | Gets or sets the format-specifier characters that indicate how a value is to be displayed. (Inherited from ListControl)
Public Property | FormattingEnabled | Gets or sets a value indicating whether formatting is applied to the ListControl.DisplayMember property of the ListControl. (Inherited from ListControl)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | Items | Gets the items.
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | RadioBoxes | Gets or sets a value indicating whether [radio boxes]. (Inherited from ListBox)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | SelectedIndex | Gets or sets the zero-based index of the currently selected item in a ListBox. (Inherited from ListBox)
Public Property | SelectedIndices | Gets a collection that contains the zero-based indexes of all currently selected items in the ListBox. (Inherited from ListBox)
Public Property | SelectedItem | Gets or sets the currently selected item in the ListBox. (Inherited from ListBox)
Public Property | SelectedItems | Gets a collection containing the currently selected items in the ListBox. (Inherited from ListBox)
Public Property | SelectedValue | Gets or sets the value of the member property specified by the ListControl.ValueMember property. (Inherited from ListControl)
Public Property | SelectionMode | Gets or sets the method in which items are selected in the ListBox. (Inherited from ListBox)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | Sorted | Gets or sets a value indicating whether the items in the ListBox are sorted alphabetically. (Inherited from ListBox)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Control)
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | ValueMember | Gets or sets the property to use as the actual value for the items in the ListControl. (Inherited from ListControl)
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | AllowSelection | Gets a value indicating whether the list enables selection of list items. (Inherited from ListControl)
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DataManager | Gets the CurrencyManager associated with this control. (Inherited from ListControl)
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | Gets a value indicating whether this instance is delayed drawing. (Inherited from ListBox)
Protected Property | IsPostBackRequired | Indicates if the list control context requires its events to cause callback (Inherited from ListControl)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

See Also

Reference

ColorListBox Class
Gizmox.WebGUI.Forms Namespace


Items Property

[image]
Gizmox.WebGUI.Forms
Items Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ColorListBox Class : Items Property

Gets the items.

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
<SRCategoryAttribute("Data")>
<EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.ListControlStringCollectionEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")>
Public ReadOnly Property Items As ColorListBox.ObjectCollection
Visual Basic (Usage) Copy Code
Dim instance As ColorListBox
Dim value As ColorListBox.ObjectCollection

value = instance.Items
C#
[DesignerSerializationVisibilityAttribute()]
[SRCategoryAttribute("Data")]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.ListControlStringCollectionEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
public ColorListBox.ObjectCollection Items {get;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
[SRCategoryAttribute("Data")]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.ListControlStringCollectionEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
public: __property ColorListBox.ObjectCollection* get_Items();
C++/CLI
[DesignerSerializationVisibilityAttribute()]
[SRCategoryAttribute("Data")]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.ListControlStringCollectionEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
public:
property ColorListBox::ObjectCollection^ Items {
   ColorListBox::ObjectCollection^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ColorListBox Class
ColorListBox Members


ColorListBox.ObjectCollection Class

[image]
Gizmox.WebGUI.Forms
ColorListBox.ObjectCollection Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ColorListBox.ObjectCollection Class

The list box object collection

Syntax

Visual Basic (Declaration)
Public Class ColorListBox.ObjectCollection
   Inherits ListBox.ObjectCollection
Visual Basic (Usage) Copy Code
Dim instance As ColorListBox.ObjectCollection
C#
public class ColorListBox.ObjectCollection : ListBox.ObjectCollection
Managed Extensions for C++
public __gc class ColorListBox.ObjectCollection : public ListBox.ObjectCollection
C++/CLI
public ref class ColorListBox.ObjectCollection : public ListBox::ObjectCollection

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ListBox.ObjectCollection
Gizmox.WebGUI.Forms.ColorListBox.ObjectCollection

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

ColorListBox.ObjectCollection Members
Gizmox.WebGUI.Forms Namespace


ColorListBox.ObjectCollection Class Members

[image]
Gizmox.WebGUI.Forms
ColorListBox.ObjectCollection Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : ColorListBox.ObjectCollection Class

The following tables list the members exposed by ColorListBox.ObjectCollection.

Public Properties

 | Name | Description
Public Property | Count | Gets the number of items in the collection. (Inherited from ListBox.ObjectCollection)
Public Property | IsFixedSize | Gets a value indicating whether the collection has a fixed size. (Inherited from ListBox.ObjectCollection)
Public Property | IsReadOnly | Gets a value indicating whether the collection is read-only. (Inherited from ListBox.ObjectCollection)
Public Property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe). (Inherited from ListBox.ObjectCollection)
Public Property | Item | Gets or sets the item at the specified index within the collection. (Inherited from ListBox.ObjectCollection)
Public Property | SyncRoot | Gets the sync root. (Inherited from ListBox.ObjectCollection)
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Adds an item to the list of items for a ListBox.
Public Method | AddRange | Overloaded. Adds an array of items to the list of items for a ListBox. (Inherited from ListBox.ObjectCollection)
Public Method | Clear | Overridden.
Public Method | Contains | Determines whether the specified item is located within the collection. (Inherited from ListBox.ObjectCollection)
Public Method | CopyTo | Copies the entire collection into an existing array of objects at a specified location within the array. (Inherited from ListBox.ObjectCollection)
Public Method | GetEnumerator | Returns an enumerator to use to iterate through the item collection. (Inherited from ListBox.ObjectCollection)
Public Method | IndexOf | Returns the index within the collection of the specified item. (Inherited from ListBox.ObjectCollection)
Public Method | Insert | Inserts an item into the list box at the specified index. (Inherited from ListBox.ObjectCollection)
Public Method | Remove | Removes the specified object from the collection. (Inherited from ListBox.ObjectCollection)
Public Method | RemoveAt | Removes the item at the specified index within the collection. (Inherited from ListBox.ObjectCollection)
Top

Protected Methods

 | Name | Description
Protected Method | GetItemInvalidMessage | Overridden.
Protected Method | IsItemValid | Overridden.
Top

See Also

Reference

ColorListBox.ObjectCollection Class
Gizmox.WebGUI.Forms Namespace


ColorListBox.ObjectCollection Class Methods

[image]
Gizmox.WebGUI.Forms
ColorListBox.ObjectCollection Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ColorListBox.ObjectCollection Class

For a list of all members of this type, see ColorListBox.ObjectCollection members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Adds an item to the list of items for a ListBox.
Public Method | AddRange | Overloaded. Adds an array of items to the list of items for a ListBox. (Inherited from ListBox.ObjectCollection)
Public Method | Clear | Overridden.
Public Method | Contains | Determines whether the specified item is located within the collection. (Inherited from ListBox.ObjectCollection)
Public Method | CopyTo | Copies the entire collection into an existing array of objects at a specified location within the array. (Inherited from ListBox.ObjectCollection)
Public Method | GetEnumerator | Returns an enumerator to use to iterate through the item collection. (Inherited from ListBox.ObjectCollection)
Public Method | IndexOf | Returns the index within the collection of the specified item. (Inherited from ListBox.ObjectCollection)
Public Method | Insert | Inserts an item into the list box at the specified index. (Inherited from ListBox.ObjectCollection)
Public Method | Remove | Removes the specified object from the collection. (Inherited from ListBox.ObjectCollection)
Public Method | RemoveAt | Removes the item at the specified index within the collection. (Inherited from ListBox.ObjectCollection)
Top

Protected Methods

 | Name | Description
Protected Method | GetItemInvalidMessage | Overridden.
Protected Method | IsItemValid | Overridden.
Top

See Also

Reference

ColorListBox.ObjectCollection Class
Gizmox.WebGUI.Forms Namespace


Add Method

[image]
Gizmox.WebGUI.Forms
Add Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ColorListBox.ObjectCollection Class : Add Method

Adds an item to the list of items for a ListBox.

Overload List

Overload | Description
Add(Color) |
Add(Object) | Adds an item to the list of items for a ListBox. (Inherited from ListBox.ObjectCollection)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ColorListBox.ObjectCollection Class
ColorListBox.ObjectCollection Members


Add(Color) Method

[image]
Gizmox.WebGUI.Forms
Add(Color) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ColorListBox.ObjectCollection Class > Add Method : Add(Color) Method

objColor

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal objColor As Color _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As ColorListBox.ObjectCollection
Dim objColor As Color
Dim value As Integer

value = instance.Add(objColor)
C#
public int Add(
   Color objColor
)
Managed Extensions for C++
public: int Add(
   Color objColor
)
C++/CLI
public:
int Add(
   Color objColor
)

Parameters

objColor

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ColorListBox.ObjectCollection Class
ColorListBox.ObjectCollection Members
Overload List


Clear Method

[image]
Gizmox.WebGUI.Forms
Clear Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ColorListBox.ObjectCollection Class : Clear Method

Syntax

Visual Basic (Declaration)
Public Overrides Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As ColorListBox.ObjectCollection

instance.Clear()
C#
public override void Clear()
Managed Extensions for C++
public: void Clear(); override
C++/CLI
public:
void Clear(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ColorListBox.ObjectCollection Class
ColorListBox.ObjectCollection Members


GetItemInvalidMessage Method

[image]
Gizmox.WebGUI.Forms
GetItemInvalidMessage Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ColorListBox.ObjectCollection Class : GetItemInvalidMessage Method

objItem

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetItemInvalidMessage( _
   ByVal objItem As Object _
) As String
Visual Basic (Usage) Copy Code
Dim instance As ColorListBox.ObjectCollection
Dim objItem As Object
Dim value As String

value = instance.GetItemInvalidMessage(objItem)
C#
protected override string GetItemInvalidMessage(
   object objItem
)
Managed Extensions for C++
protected: string* GetItemInvalidMessage(
   Object* objItem
) override
C++/CLI
protected:
String^ GetItemInvalidMessage(
   Object^ objItem
) override

Parameters

objItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ColorListBox.ObjectCollection Class
ColorListBox.ObjectCollection Members


IsItemValid Method

[image]
Gizmox.WebGUI.Forms
IsItemValid Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ColorListBox.ObjectCollection Class : IsItemValid Method

objItem

Syntax

Visual Basic (Declaration)
Protected Overrides Function IsItemValid( _
   ByVal objItem As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ColorListBox.ObjectCollection
Dim objItem As Object
Dim value As Boolean

value = instance.IsItemValid(objItem)
C#
protected override bool IsItemValid(
   object objItem
)
Managed Extensions for C++
protected: bool IsItemValid(
   Object* objItem
) override
C++/CLI
protected:
bool IsItemValid(
   Object^ objItem
) override

Parameters

objItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ColorListBox.ObjectCollection Class
ColorListBox.ObjectCollection Members


ColumnClickEventArgs Class

[image]
Gizmox.WebGUI.Forms
ColumnClickEventArgs Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ColumnClickEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class ColumnClickEventArgs
   Inherits EventArgs
Visual Basic (Usage) Copy Code
Dim instance As ColumnClickEventArgs
C#
public class ColumnClickEventArgs : EventArgs
Managed Extensions for C++
public __gc class ColumnClickEventArgs : public EventArgs
C++/CLI
public ref class ColumnClickEventArgs : public EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gizmox.WebGUI.Forms.ColumnClickEventArgs

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

ColumnClickEventArgs Members
Gizmox.WebGUI.Forms Namespace


ColumnClickEventArgs Class Members

[image]
Gizmox.WebGUI.Forms
ColumnClickEventArgs Class Members
See Also Properties Send Feedback
Gizmox.WebGUI.Forms Namespace : ColumnClickEventArgs Class

The following tables list the members exposed by ColumnClickEventArgs.

Public Constructors

 | Name | Description
Public Constructor | ColumnClickEventArgs Constructor |
Top

Public Properties

 | Name | Description
Public Property | Column |
Top

See Also

Reference

ColumnClickEventArgs Class
Gizmox.WebGUI.Forms Namespace


ColumnClickEventArgs Constructor

[image]
Gizmox.WebGUI.Forms
ColumnClickEventArgs Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ColumnClickEventArgs Class : ColumnClickEventArgs Constructor

column

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal column As Integer _
)
Visual Basic (Usage) Copy Code
Dim column As Integer

Dim instance As ColumnClickEventArgs(column)
C#
public ColumnClickEventArgs(
   int column
)
Managed Extensions for C++
public: ColumnClickEventArgs(
   int column
)
C++/CLI
public:
ColumnClickEventArgs(
   int column
)

Parameters

column

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ColumnClickEventArgs Class
ColumnClickEventArgs Members


ColumnClickEventArgs Class Properties

[image]
Gizmox.WebGUI.Forms
ColumnClickEventArgs Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ColumnClickEventArgs Class

For a list of all members of this type, see ColumnClickEventArgs members.

Public Properties

 | Name | Description
Public Property | Column |
Top

See Also

Reference

ColumnClickEventArgs Class
Gizmox.WebGUI.Forms Namespace


Column Property

[image]
Gizmox.WebGUI.Forms
Column Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ColumnClickEventArgs Class : Column Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Column As Integer
Visual Basic (Usage) Copy Code
Dim instance As ColumnClickEventArgs
Dim value As Integer

value = instance.Column
C#
public int Column {get;}
Managed Extensions for C++
public: __property int get_Column();
C++/CLI
public:
property int Column {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ColumnClickEventArgs Class
ColumnClickEventArgs Members


ColumnHeader Class

[image]
Gizmox.WebGUI.Forms
ColumnHeader Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ColumnHeader Class

Summary description for ColumnHeader.

Object Model

Syntax

Visual Basic (Declaration)
<ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")>
<DesignTimeVisibleAttribute()>
<ClientControllerAttribute()>
<DesignTimeControllerAttribute()>
Public Class ColumnHeader
   Inherits Component
   Implements IAttributeExtender, IEventHandler, IGatewayComponent, IObservableItem, IRegisteredComponent
Visual Basic (Usage) Copy Code
Dim instance As ColumnHeader
C#
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
[DesignTimeVisibleAttribute()]
[ClientControllerAttribute()]
[DesignTimeControllerAttribute()]
public class ColumnHeader : Component, IAttributeExtender, IEventHandler, IGatewayComponent, IObservableItem, IRegisteredComponent
Managed Extensions for C++
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
[DesignTimeVisibleAttribute()]
[ClientControllerAttribute()]
[DesignTimeControllerAttribute()]
public __gc class ColumnHeader : public Component, IAttributeExtender, IEventHandler, IGatewayComponent, IObservableItem, IRegisteredComponent
C++/CLI
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
[DesignTimeVisibleAttribute()]
[ClientControllerAttribute()]
[DesignTimeControllerAttribute()]
public ref class ColumnHeader : public Component, IAttributeExtender, IEventHandler, IGatewayComponent, IObservableItem, IRegisteredComponent

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.ColumnHeader

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

ColumnHeader Members
Gizmox.WebGUI.Forms Namespace


ColumnHeader Class Members

[image]
Gizmox.WebGUI.Forms
ColumnHeader Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : ColumnHeader Class

The following tables list the members exposed by ColumnHeader.

Public Constructors

 | Name | Description
Public Constructor | ColumnHeader Constructor | Overloaded. Creates a new ColumnHeader instance.
Top

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContentAlign | Gets or sets the column header alignment.
Public Property | ContextMenu | Gets or sets the context menu code. (Inherited from Component)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | GroupBy | Gets or sets a value indicating whether to group by column.
Public Property | GroupByPosition | Gets or sets the group by position.
Public Property | Image | Gets or sets the image displayed in the ColumnHeader.
Public Property | Index | Gets or sets the index.
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | Label | Gets or sets the label.
Public Property | Loaded | Gets or sets a value indicating whether this ColumnHeader is loaded.
Public Property | Name | Gets or sets the name.
Public Property | Position | Gets or sets the position.
Public Property | Site | (Inherited from ComponentBase)
Public Property | SortOrder | Gets or sets the sort order.
Public Property | SortPosition | Gets or sets the sort position.
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text displayed in the column header.
Public Property | TextAlign | Gets or sets the text alignment.
Public Property | Type | Gets or sets the type.
Public Property | Visible | Gets or sets a value indicating whether this ColumnHeader is visible.
Public Property | Width | Gets or sets the width.
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

Public Methods

 | Name | Description
Public Method | AutoResize | Resizes the width of the column as indicated by the resize style.
Public Method | CompareTo |
Public Method | Dispose | Overloaded. Disposes the specified component. (Inherited from Component)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | ToString | Overridden.
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Overridden. Fires an event.
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCriticalEvents | (Inherited from Component)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnUnregisterComponents | (Inherited from Component)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Top

See Also

Reference

ColumnHeader Class
Gizmox.WebGUI.Forms Namespace


ColumnHeader Constructor

[image]
Gizmox.WebGUI.Forms
ColumnHeader Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ColumnHeader Class : ColumnHeader Constructor

Creates a new ColumnHeader instance.

Overload List

Overload | Description
ColumnHeader Constructor() |
ColumnHeader Constructor(String) |
ColumnHeader Constructor(String,String) |
ColumnHeader Constructor(String,String,Boolean) |
ColumnHeader Constructor(String,String,Int32) | Creates a new ColumnHeader instance.
ColumnHeader Constructor(String,String,Int32,Boolean) | Creates a new ColumnHeader instance.
ColumnHeader Constructor(String,String,Int32,ListViewColumnType) |
ColumnHeader Constructor(String,String,Int32,ListViewColumnType,Boolean) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ColumnHeader Class
ColumnHeader Members


ColumnHeader Constructor()

[image]
Gizmox.WebGUI.Forms
ColumnHeader Constructor()
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ColumnHeader Class > ColumnHeader Constructor : ColumnHeader Constructor()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ColumnHeader()
C#
public ColumnHeader()
Managed Extensions for C++
public: ColumnHeader();
C++/CLI
public:
ColumnHeader();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ColumnHeader Class
ColumnHeader Members
Overload List


ColumnHeader Constructor(String)

[image]
Gizmox.WebGUI.Forms
ColumnHeader Constructor(String)
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ColumnHeader Class > ColumnHeader Constructor : ColumnHeader Constructor(String)

strLabel

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal strLabel As String _
)
Visual Basic (Usage) Copy Code
Dim strLabel As String

Dim instance As ColumnHeader(strLabel)
C#
public ColumnHeader(
   string strLabel
)
Managed Extensions for C++
public: ColumnHeader(
   string* strLabel
)
C++/CLI
public:
ColumnHeader(
   String^ strLabel
)

Parameters

strLabel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ColumnHeader Class
ColumnHeader Members
Overload List


ColumnHeader Constructor(String,String)

[image]
Gizmox.WebGUI.Forms
ColumnHeader Constructor(String,String)
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ColumnHeader Class > ColumnHeader Constructor : ColumnHeader Constructor(String,String)

strName
strLabel

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal strName As String, _
   ByVal strLabel As String _
)
Visual Basic (Usage) Copy Code
Dim strName As String
Dim strLabel As String

Dim instance As ColumnHeader(strName, strLabel)
C#
public ColumnHeader(
   string strName,
   string strLabel
)
Managed Extensions for C++
public: ColumnHeader(
   string* strName,
   string* strLabel
)
C++/CLI
public:
ColumnHeader(
   String^ strName,
   String^ strLabel
)

Parameters

strName
strLabel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ColumnHeader Class
ColumnHeader Members
Overload List


ColumnHeader Constructor(String,String,Boolean)

[image]
Gizmox.WebGUI.Forms
ColumnHeader Constructor(String,String,Boolean)
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ColumnHeader Class > ColumnHeader Constructor : ColumnHeader Constructor(String,String,Boolean)

strName
strLabel
blnLoaded

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal strName As String, _
   ByVal strLabel As String, _
   ByVal blnLoaded As Boolean _
)
Visual Basic (Usage) Copy Code
Dim strName As String
Dim strLabel As String
Dim blnLoaded As Boolean

Dim instance As ColumnHeader(strName, strLabel, blnLoaded)
C#
public ColumnHeader(
   string strName,
   string strLabel,
   bool blnLoaded
)
Managed Extensions for C++
public: ColumnHeader(
   string* strName,
   string* strLabel,
   bool blnLoaded
)
C++/CLI
public:
ColumnHeader(
   String^ strName,
   String^ strLabel,
   bool blnLoaded
)

Parameters

strName
strLabel
blnLoaded

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ColumnHeader Class
ColumnHeader Members
Overload List


ColumnHeader Constructor(String,String,Int32)

[image]
Gizmox.WebGUI.Forms
ColumnHeader Constructor(String,String,Int32)
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ColumnHeader Class > ColumnHeader Constructor : ColumnHeader Constructor(String,String,Int32)

strName
Name.
strLabel
Label.
intWidth
Width.
Creates a new ColumnHeader instance.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal strName As String, _
   ByVal strLabel As String, _
   ByVal intWidth As Integer _
)
Visual Basic (Usage) Copy Code
Dim strName As String
Dim strLabel As String
Dim intWidth As Integer

Dim instance As ColumnHeader(strName, strLabel, intWidth)
C#
public ColumnHeader(
   string strName,
   string strLabel,
   int intWidth
)
Managed Extensions for C++
public: ColumnHeader(
   string* strName,
   string* strLabel,
   int intWidth
)
C++/CLI
public:
ColumnHeader(
   String^ strName,
   String^ strLabel,
   int intWidth
)

Parameters

strName
Name.
strLabel
Label.
intWidth
Width.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ColumnHeader Class
ColumnHeader Members
Overload List


ColumnHeader Constructor(String,String,Int32,Boolean)

[image]
Gizmox.WebGUI.Forms
ColumnHeader Constructor(String,String,Int32,Boolean)
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ColumnHeader Class > ColumnHeader Constructor : ColumnHeader Constructor(String,String,Int32,Boolean)

strName
Name.
strLabel
Label.
intWidth
Width.
mblnLoaded
Creates a new ColumnHeader instance.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal strName As String, _
   ByVal strLabel As String, _
   ByVal intWidth As Integer, _
   ByVal mblnLoaded As Boolean _
)
Visual Basic (Usage) Copy Code
Dim strName As String
Dim strLabel As String
Dim intWidth As Integer
Dim mblnLoaded As Boolean

Dim instance As ColumnHeader(strName, strLabel, intWidth, mblnLoaded)
C#
public ColumnHeader(
   string strName,
   string strLabel,
   int intWidth,
   bool mblnLoaded
)
Managed Extensions for C++
public: ColumnHeader(
   string* strName,
   string* strLabel,
   int intWidth,
   bool mblnLoaded
)
C++/CLI
public:
ColumnHeader(
   String^ strName,
   String^ strLabel,
   int intWidth,
   bool mblnLoaded
)

Parameters

strName
Name.
strLabel
Label.
intWidth
Width.
mblnLoaded

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ColumnHeader Class
ColumnHeader Members
Overload List


ColumnHeader Constructor(String,String,Int32,ListViewColumnType)

[image]
Gizmox.WebGUI.Forms
ColumnHeader Constructor(String,String,Int32,ListViewColumnType)
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ColumnHeader Class > ColumnHeader Constructor : ColumnHeader Constructor(String,String,Int32,ListViewColumnType)

strName
strLabel
intWidth
enmType

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal strName As String, _
   ByVal strLabel As String, _
   ByVal intWidth As Integer, _
   ByVal enmType As ListViewColumnType _
)
Visual Basic (Usage) Copy Code
Dim strName As String
Dim strLabel As String
Dim intWidth As Integer
Dim enmType As ListViewColumnType

Dim instance As ColumnHeader(strName, strLabel, intWidth, enmType)
C#
public ColumnHeader(
   string strName,
   string strLabel,
   int intWidth,
   ListViewColumnType enmType
)
Managed Extensions for C++
public: ColumnHeader(
   string* strName,
   string* strLabel,
   int intWidth,
   ListViewColumnType enmType
)
C++/CLI
public:
ColumnHeader(
   String^ strName,
   String^ strLabel,
   int intWidth,
   ListViewColumnType enmType
)

Parameters

strName
strLabel
intWidth
enmType

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ColumnHeader Class
ColumnHeader Members
Overload List


ColumnHeader Constructor(String,String,Int32,ListViewColumnType,Boolean)

[image]
Gizmox.WebGUI.Forms
ColumnHeader Constructor(String,String,Int32,ListViewColumnType,Boolean)
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ColumnHeader Class > ColumnHeader Constructor : ColumnHeader Constructor(String,String,Int32,ListViewColumnType,Boolean)

strName
strLabel
intWidth
enmType
mblnLoaded

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal strName As String, _
   ByVal strLabel As String, _
   ByVal intWidth As Integer, _
   ByVal enmType As ListViewColumnType, _
   ByVal mblnLoaded As Boolean _
)
Visual Basic (Usage) Copy Code
Dim strName As String
Dim strLabel As String
Dim intWidth As Integer
Dim enmType As ListViewColumnType
Dim mblnLoaded As Boolean

Dim instance As ColumnHeader(strName, strLabel, intWidth, enmType, mblnLoaded)
C#
public ColumnHeader(
   string strName,
   string strLabel,
   int intWidth,
   ListViewColumnType enmType,
   bool mblnLoaded
)
Managed Extensions for C++
public: ColumnHeader(
   string* strName,
   string* strLabel,
   int intWidth,
   ListViewColumnType enmType,
   bool mblnLoaded
)
C++/CLI
public:
ColumnHeader(
   String^ strName,
   String^ strLabel,
   int intWidth,
   ListViewColumnType enmType,
   bool mblnLoaded
)

Parameters

strName
strLabel
intWidth
enmType
mblnLoaded

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ColumnHeader Class
ColumnHeader Members
Overload List


ColumnHeader Class Methods

[image]
Gizmox.WebGUI.Forms
ColumnHeader Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ColumnHeader Class

For a list of all members of this type, see ColumnHeader members.

Public Methods

 | Name | Description
Public Method | AutoResize | Resizes the width of the column as indicated by the resize style.
Public Method | CompareTo |
Public Method | Dispose | Overloaded. Disposes the specified component. (Inherited from Component)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | ToString | Overridden.
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Overridden. Fires an event.
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCriticalEvents | (Inherited from Component)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnUnregisterComponents | (Inherited from Component)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

See Also

Reference

ColumnHeader Class
Gizmox.WebGUI.Forms Namespace


AutoResize Method

[image]
Gizmox.WebGUI.Forms
AutoResize Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ColumnHeader Class : AutoResize Method

headerAutoResize
One of the ColumnHeaderAutoResizeStyle values.
Resizes the width of the column as indicated by the resize style.

Syntax

Visual Basic (Declaration)
Public Sub AutoResize( _
   ByVal headerAutoResize As ColumnHeaderAutoResizeStyle _
)
Visual Basic (Usage) Copy Code
Dim instance As ColumnHeader
Dim headerAutoResize As ColumnHeaderAutoResizeStyle

instance.AutoResize(headerAutoResize)
C#
public void AutoResize(
   ColumnHeaderAutoResizeStyle headerAutoResize
)
Managed Extensions for C++
public: void AutoResize(
   ColumnHeaderAutoResizeStyle headerAutoResize
)
C++/CLI
public:
void AutoResize(
   ColumnHeaderAutoResizeStyle headerAutoResize
)

Parameters

headerAutoResize
One of the ColumnHeaderAutoResizeStyle values.

Exceptions

Exception | Description
InvalidOperationException | A value other than None is passed to the AutoResize method when the View property is a value other than Details.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ColumnHeader Class
ColumnHeader Members


CompareTo Method

[image]
Gizmox.WebGUI.Forms
CompareTo Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ColumnHeader Class : CompareTo Method

objObject

Syntax

Visual Basic (Declaration)
Public Function CompareTo( _
   ByVal objObject As Object _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As ColumnHeader
Dim objObject As Object
Dim value As Integer

value = instance.CompareTo(objObject)
C#
public int CompareTo(
   object objObject
)
Managed Extensions for C++
public: int CompareTo(
   Object* objObject
)
C++/CLI
public:
int CompareTo(
   Object^ objObject
)

Parameters

objObject

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ColumnHeader Class
ColumnHeader Members


FireEvent Method

[image]
Gizmox.WebGUI.Forms
FireEvent Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ColumnHeader Class : FireEvent Method

objEvent
event.
Fires an event.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub FireEvent( _
   ByVal objEvent As IEvent _
)
Visual Basic (Usage) Copy Code
Dim instance As ColumnHeader
Dim objEvent As IEvent

instance.FireEvent(objEvent)
C#
protected override void FireEvent(
   IEvent objEvent
)
Managed Extensions for C++
protected: void FireEvent(
   IEvent* objEvent
) override
C++/CLI
protected:
void FireEvent(
   IEvent^ objEvent
) override

Parameters

objEvent
event.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ColumnHeader Class
ColumnHeader Members


ToString Method

[image]
Gizmox.WebGUI.Forms
ToString Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ColumnHeader Class : ToString Method

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As ColumnHeader
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ColumnHeader Class
ColumnHeader Members


ColumnHeader Class Properties

[image]
Gizmox.WebGUI.Forms
ColumnHeader Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ColumnHeader Class

For a list of all members of this type, see ColumnHeader members.

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContentAlign | Gets or sets the column header alignment.
Public Property | ContextMenu | Gets or sets the context menu code. (Inherited from Component)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | GroupBy | Gets or sets a value indicating whether to group by column.
Public Property | GroupByPosition | Gets or sets the group by position.
Public Property | Image | Gets or sets the image displayed in the ColumnHeader.
Public Property | Index | Gets or sets the index.
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | Label | Gets or sets the label.
Public Property | Loaded | Gets or sets a value indicating whether this ColumnHeader is loaded.
Public Property | Name | Gets or sets the name.
Public Property | Position | Gets or sets the position.
Public Property | Site | (Inherited from ComponentBase)
Public Property | SortOrder | Gets or sets the sort order.
Public Property | SortPosition | Gets or sets the sort position.
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text displayed in the column header.
Public Property | TextAlign | Gets or sets the text alignment.
Public Property | Type | Gets or sets the type.
Public Property | Visible | Gets or sets a value indicating whether this ColumnHeader is visible.
Public Property | Width | Gets or sets the width.
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

See Also

Reference

ColumnHeader Class
Gizmox.WebGUI.Forms Namespace


ContentAlign Property

[image]
Gizmox.WebGUI.Forms
ContentAlign Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ColumnHeader Class : ContentAlign Property

Gets or sets the column header alignment.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(True)>
<DefaultValueAttribute()>
Public Property ContentAlign As ExtendedHorizontalAlignment
Visual Basic (Usage) Copy Code
Dim instance As ColumnHeader
Dim value As ExtendedHorizontalAlignment

instance.ContentAlign = value

value = instance.ContentAlign
C#
[BrowsableAttribute(true)]
[DefaultValueAttribute()]
public ExtendedHorizontalAlignment ContentAlign {get; set;}
Managed Extensions for C++
[BrowsableAttribute(true)]
[DefaultValueAttribute()]
public: __property ExtendedHorizontalAlignment get_ContentAlign();
public: __property void set_ContentAlign(
   ExtendedHorizontalAlignment value
);
C++/CLI
[BrowsableAttribute(true)]
[DefaultValueAttribute()]
public:
property ExtendedHorizontalAlignment ContentAlign {
   ExtendedHorizontalAlignment get();
   void set (ExtendedHorizontalAlignmentvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ColumnHeader Class
ColumnHeader Members


GroupBy Property

[image]
Gizmox.WebGUI.Forms
GroupBy Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ColumnHeader Class : GroupBy Property

Gets or sets a value indicating whether to group by column.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public Property GroupBy As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ColumnHeader
Dim value As Boolean

instance.GroupBy = value

value = instance.GroupBy
C#
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public bool GroupBy {get; set;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property bool get_GroupBy();
public: __property void set_GroupBy(
   bool value
);
C++/CLI
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
property bool GroupBy {
   bool get();
   void set (boolvalue);
}

Return Value

true if group by column; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ColumnHeader Class
ColumnHeader Members


GroupByPosition Property

[image]
Gizmox.WebGUI.Forms
GroupByPosition Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ColumnHeader Class : GroupByPosition Property

Gets or sets the group by position.

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
Public Property GroupByPosition As Integer
Visual Basic (Usage) Copy Code
Dim instance As ColumnHeader
Dim value As Integer

instance.GroupByPosition = value

value = instance.GroupByPosition
C#
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public int GroupByPosition {get; set;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public: __property int get_GroupByPosition();
public: __property void set_GroupByPosition(
   int value
);
C++/CLI
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public:
property int GroupByPosition {
   int get();
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ColumnHeader Class
ColumnHeader Members


Image Property

[image]
Gizmox.WebGUI.Forms
Image Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ColumnHeader Class : Image Property

Gets or sets the image displayed in the ColumnHeader.

Syntax

Visual Basic (Declaration)
Public Property Image As ResourceHandle
Visual Basic (Usage) Copy Code
Dim instance As ColumnHeader
Dim value As ResourceHandle

instance.Image = value

value = instance.Image
C#
public ResourceHandle Image {get; set;}
Managed Extensions for C++
public: __property ResourceHandle* get_Image();
public: __property void set_Image(
   ResourceHandle* value
);
C++/CLI
public:
property ResourceHandle^ Image {
   ResourceHandle^ get();
   void set (ResourceHandle^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ColumnHeader Class
ColumnHeader Members


Index Property

[image]
Gizmox.WebGUI.Forms
Index Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ColumnHeader Class : Index Property

Gets or sets the index.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public ReadOnly Property Index As Integer
Visual Basic (Usage) Copy Code
Dim instance As ColumnHeader
Dim value As Integer

value = instance.Index
C#
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public int Index {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property int get_Index();
C++/CLI
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
property int Index {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ColumnHeader Class
ColumnHeader Members


Label Property

[image]
Gizmox.WebGUI.Forms
Label Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ColumnHeader Class : Label Property

Gets or sets the label.

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
Public Property Label As String
Visual Basic (Usage) Copy Code
Dim instance As ColumnHeader
Dim value As String

instance.Label = value

value = instance.Label
C#
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public string Label {get; set;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public: __property string* get_Label();
public: __property void set_Label(
   string* value
);
C++/CLI
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public:
property String^ Label {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ColumnHeader Class
ColumnHeader Members


Loaded Property

[image]
Gizmox.WebGUI.Forms
Loaded Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ColumnHeader Class : Loaded Property

Gets or sets a value indicating whether this ColumnHeader is loaded.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<BrowsableAttribute(False)>
Public Property Loaded As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ColumnHeader
Dim value As Boolean

instance.Loaded = value

value = instance.Loaded
C#
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
public bool Loaded {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
public: __property bool get_Loaded();
public: __property void set_Loaded(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
public:
property bool Loaded {
   bool get();
   void set (boolvalue);
}

Return Value

true if loaded; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ColumnHeader Class
ColumnHeader Members


Name Property

[image]
Gizmox.WebGUI.Forms
Name Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ColumnHeader Class : Name Property

Gets or sets the name.

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
Public Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As ColumnHeader
Dim value As String

instance.Name = value

value = instance.Name
C#
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public string Name {get; set;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public: __property string* get_Name();
public: __property void set_Name(
   string* value
);
C++/CLI
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public:
property String^ Name {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ColumnHeader Class
ColumnHeader Members


Position Property

[image]
Gizmox.WebGUI.Forms
Position Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ColumnHeader Class : Position Property

Gets or sets the position.

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
Public Property Position As Integer
Visual Basic (Usage) Copy Code
Dim instance As ColumnHeader
Dim value As Integer

instance.Position = value

value = instance.Position
C#
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public int Position {get; set;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public: __property int get_Position();
public: __property void set_Position(
   int value
);
C++/CLI
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public:
property int Position {
   int get();
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ColumnHeader Class
ColumnHeader Members


SortOrder Property

[image]
Gizmox.WebGUI.Forms
SortOrder Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ColumnHeader Class : SortOrder Property

Gets or sets the sort order.

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
Public Property SortOrder As SortOrder
Visual Basic (Usage) Copy Code
Dim instance As ColumnHeader
Dim value As SortOrder

instance.SortOrder = value

value = instance.SortOrder
C#
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public SortOrder SortOrder {get; set;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public: __property SortOrder get_SortOrder();
public: __property void set_SortOrder(
   SortOrder value
);
C++/CLI
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public:
property SortOrder SortOrder {
   SortOrder get();
   void set (SortOrdervalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ColumnHeader Class
ColumnHeader Members


SortPosition Property

[image]
Gizmox.WebGUI.Forms
SortPosition Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ColumnHeader Class : SortPosition Property

Gets or sets the sort position.

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
Public Property SortPosition As Integer
Visual Basic (Usage) Copy Code
Dim instance As ColumnHeader
Dim value As Integer

instance.SortPosition = value

value = instance.SortPosition
C#
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public int SortPosition {get; set;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public: __property int get_SortPosition();
public: __property void set_SortPosition(
   int value
);
C++/CLI
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public:
property int SortPosition {
   int get();
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ColumnHeader Class
ColumnHeader Members


Text Property

[image]
Gizmox.WebGUI.Forms
Text Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ColumnHeader Class : Text Property

Gets or sets the text displayed in the column header.

Syntax

Visual Basic (Declaration)
<LocalizableAttribute(True)>
<SRDescriptionAttribute("The text displayed in the column header.")>
Public Property Text As String
Visual Basic (Usage) Copy Code
Dim instance As ColumnHeader
Dim value As String

instance.Text = value

value = instance.Text
C#
[LocalizableAttribute(true)]
[SRDescriptionAttribute("The text displayed in the column header.")]
public string Text {get; set;}
Managed Extensions for C++
[LocalizableAttribute(true)]
[SRDescriptionAttribute("The text displayed in the column header.")]
public: __property string* get_Text();
public: __property void set_Text(
   string* value
);
C++/CLI
[LocalizableAttribute(true)]
[SRDescriptionAttribute("The text displayed in the column header.")]
public:
property String^ Text {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ColumnHeader Class
ColumnHeader Members


TextAlign Property

[image]
Gizmox.WebGUI.Forms
TextAlign Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ColumnHeader Class : TextAlign Property

Gets or sets the text alignment.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(True)>
<DefaultValueAttribute()>
Public Property TextAlign As HorizontalAlignment
Visual Basic (Usage) Copy Code
Dim instance As ColumnHeader
Dim value As HorizontalAlignment

instance.TextAlign = value

value = instance.TextAlign
C#
[BrowsableAttribute(true)]
[DefaultValueAttribute()]
public HorizontalAlignment TextAlign {get; set;}
Managed Extensions for C++
[BrowsableAttribute(true)]
[DefaultValueAttribute()]
public: __property HorizontalAlignment get_TextAlign();
public: __property void set_TextAlign(
   HorizontalAlignment value
);
C++/CLI
[BrowsableAttribute(true)]
[DefaultValueAttribute()]
public:
property HorizontalAlignment TextAlign {
   HorizontalAlignment get();
   void set (HorizontalAlignmentvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ColumnHeader Class
ColumnHeader Members


Type Property

[image]
Gizmox.WebGUI.Forms
Type Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ColumnHeader Class : Type Property

Gets or sets the type.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(True)>
<DefaultValueAttribute()>
Public Property Type As ListViewColumnType
Visual Basic (Usage) Copy Code
Dim instance As ColumnHeader
Dim value As ListViewColumnType

instance.Type = value

value = instance.Type
C#
[BrowsableAttribute(true)]
[DefaultValueAttribute()]
public ListViewColumnType Type {get; set;}
Managed Extensions for C++
[BrowsableAttribute(true)]
[DefaultValueAttribute()]
public: __property ListViewColumnType get_Type();
public: __property void set_Type(
   ListViewColumnType value
);
C++/CLI
[BrowsableAttribute(true)]
[DefaultValueAttribute()]
public:
property ListViewColumnType Type {
   ListViewColumnType get();
   void set (ListViewColumnTypevalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ColumnHeader Class
ColumnHeader Members


Visible Property

[image]
Gizmox.WebGUI.Forms
Visible Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ColumnHeader Class : Visible Property

Gets or sets a value indicating whether this ColumnHeader is visible.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ColumnHeader
Dim value As Boolean

instance.Visible = value

value = instance.Visible
C#
[DefaultValueAttribute()]
public bool Visible {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property bool get_Visible();
public: __property void set_Visible(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
public:
property bool Visible {
   bool get();
   void set (boolvalue);
}

Return Value

true if visible; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ColumnHeader Class
ColumnHeader Members


Width Property

[image]
Gizmox.WebGUI.Forms
Width Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ColumnHeader Class : Width Property

Gets or sets the width.

Syntax

Visual Basic (Declaration)
Public Property Width As Integer
Visual Basic (Usage) Copy Code
Dim instance As ColumnHeader
Dim value As Integer

instance.Width = value

value = instance.Width
C#
public int Width {get; set;}
Managed Extensions for C++
public: __property int get_Width();
public: __property void set_Width(
   int value
);
C++/CLI
public:
property int Width {
   int get();
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ColumnHeader Class
ColumnHeader Members


ColumnHeaderGroupingData Class

[image]
Gizmox.WebGUI.Forms
ColumnHeaderGroupingData Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ColumnHeaderGroupingData Class

Syntax

Visual Basic (Declaration)
Public Class ColumnHeaderGroupingData
Visual Basic (Usage) Copy Code
Dim instance As ColumnHeaderGroupingData
C#
public class ColumnHeaderGroupingData
Managed Extensions for C++
public __gc class ColumnHeaderGroupingData
C++/CLI
public ref class ColumnHeaderGroupingData

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ColumnHeaderGroupingData

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

ColumnHeaderGroupingData Members
Gizmox.WebGUI.Forms Namespace


ColumnHeaderGroupingData Class Members

[image]
Gizmox.WebGUI.Forms
ColumnHeaderGroupingData Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : ColumnHeaderGroupingData Class

The following tables list the members exposed by ColumnHeaderGroupingData.

Public Constructors

 | Name | Description
Public Constructor | ColumnHeaderGroupingData Constructor | Creates a new ColumnHeaderGroupingData instance.
Top

Public Properties

 | Name | Description
Public Property | GroupingColumns | Gets the sorting participating columns.
Public Property | SortedColumns | Gets the columns in the order there are used in the grouping.
Top

Public Methods

 | Name | Description
Public Method | Compare | Compares the specified column headers
Top

See Also

Reference

ColumnHeaderGroupingData Class
Gizmox.WebGUI.Forms Namespace


ColumnHeaderGroupingData Constructor

[image]
Gizmox.WebGUI.Forms
ColumnHeaderGroupingData Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ColumnHeaderGroupingData Class : ColumnHeaderGroupingData Constructor

objListView
list view.
Creates a new ColumnHeaderGroupingData instance.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal objListView As ListView _
)
Visual Basic (Usage) Copy Code
Dim objListView As ListView

Dim instance As ColumnHeaderGroupingData(objListView)
C#
public ColumnHeaderGroupingData(
   ListView objListView
)
Managed Extensions for C++
public: ColumnHeaderGroupingData(
   ListView* objListView
)
C++/CLI
public:
ColumnHeaderGroupingData(
   ListView^ objListView
)

Parameters

objListView
list view.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ColumnHeaderGroupingData Class
ColumnHeaderGroupingData Members


ColumnHeaderGroupingData Class Methods

[image]
Gizmox.WebGUI.Forms
ColumnHeaderGroupingData Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ColumnHeaderGroupingData Class

For a list of all members of this type, see ColumnHeaderGroupingData members.

Public Methods

 | Name | Description
Public Method | Compare | Compares the specified column headers
Top

See Also

Reference

ColumnHeaderGroupingData Class
Gizmox.WebGUI.Forms Namespace


Compare Method

[image]
Gizmox.WebGUI.Forms
Compare Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ColumnHeaderGroupingData Class : Compare Method

objObjectA
Column A.
objObjectB
Column B.
Compares the specified column headers

Syntax

Visual Basic (Declaration)
Public Function Compare( _
   ByVal objObjectA As Object, _
   ByVal objObjectB As Object _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As ColumnHeaderGroupingData
Dim objObjectA As Object
Dim objObjectB As Object
Dim value As Integer

value = instance.Compare(objObjectA, objObjectB)
C#
public int Compare(
   object objObjectA,
   object objObjectB
)
Managed Extensions for C++
public: int Compare(
   Object* objObjectA,
   Object* objObjectB
)
C++/CLI
public:
int Compare(
   Object^ objObjectA,
   Object^ objObjectB
)

Parameters

objObjectA
Column A.
objObjectB
Column B.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ColumnHeaderGroupingData Class
ColumnHeaderGroupingData Members


ColumnHeaderGroupingData Class Properties

[image]
Gizmox.WebGUI.Forms
ColumnHeaderGroupingData Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ColumnHeaderGroupingData Class

For a list of all members of this type, see ColumnHeaderGroupingData members.

Public Properties

 | Name | Description
Public Property | GroupingColumns | Gets the sorting participating columns.
Public Property | SortedColumns | Gets the columns in the order there are used in the grouping.
Top

See Also

Reference

ColumnHeaderGroupingData Class
Gizmox.WebGUI.Forms Namespace


GroupingColumns Property

[image]
Gizmox.WebGUI.Forms
GroupingColumns Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ColumnHeaderGroupingData Class : GroupingColumns Property

Gets the sorting participating columns.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property GroupingColumns As ICollection
Visual Basic (Usage) Copy Code
Dim instance As ColumnHeaderGroupingData
Dim value As ICollection

value = instance.GroupingColumns
C#
public ICollection GroupingColumns {get;}
Managed Extensions for C++
public: __property ICollection* get_GroupingColumns();
C++/CLI
public:
property ICollection^ GroupingColumns {
   ICollection^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ColumnHeaderGroupingData Class
ColumnHeaderGroupingData Members


SortedColumns Property

[image]
Gizmox.WebGUI.Forms
SortedColumns Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ColumnHeaderGroupingData Class : SortedColumns Property

Gets the columns in the order there are used in the grouping.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SortedColumns As ICollection
Visual Basic (Usage) Copy Code
Dim instance As ColumnHeaderGroupingData
Dim value As ICollection

value = instance.SortedColumns
C#
public ICollection SortedColumns {get;}
Managed Extensions for C++
public: __property ICollection* get_SortedColumns();
C++/CLI
public:
property ICollection^ SortedColumns {
   ICollection^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ColumnHeaderGroupingData Class
ColumnHeaderGroupingData Members


ColumnHeaderSortingData Class

[image]
Gizmox.WebGUI.Forms
ColumnHeaderSortingData Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ColumnHeaderSortingData Class

Syntax

Visual Basic (Declaration)
Public Class ColumnHeaderSortingData
Visual Basic (Usage) Copy Code
Dim instance As ColumnHeaderSortingData
C#
public class ColumnHeaderSortingData
Managed Extensions for C++
public __gc class ColumnHeaderSortingData
C++/CLI
public ref class ColumnHeaderSortingData

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ColumnHeaderSortingData

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

ColumnHeaderSortingData Members
Gizmox.WebGUI.Forms Namespace


ColumnHeaderSortingData Class Members

[image]
Gizmox.WebGUI.Forms
ColumnHeaderSortingData Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : ColumnHeaderSortingData Class

The following tables list the members exposed by ColumnHeaderSortingData.

Public Constructors

 | Name | Description
Public Constructor | ColumnHeaderSortingData Constructor | Creates a new ColumnHeaderSortingData instance.
Top

Public Properties

 | Name | Description
Public Property | SortedColumns | Gets the columns in the order there are used in the sorting.
Public Property | SortingColumns | Gets the sorting participating columns.
Top

Public Methods

 | Name | Description
Public Method | Compare | Compares the specified column headers
Top

See Also

Reference

ColumnHeaderSortingData Class
Gizmox.WebGUI.Forms Namespace


ColumnHeaderSortingData Constructor

[image]
Gizmox.WebGUI.Forms
ColumnHeaderSortingData Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ColumnHeaderSortingData Class : ColumnHeaderSortingData Constructor

objListView
list view.
Creates a new ColumnHeaderSortingData instance.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal objListView As ListView _
)
Visual Basic (Usage) Copy Code
Dim objListView As ListView

Dim instance As ColumnHeaderSortingData(objListView)
C#
public ColumnHeaderSortingData(
   ListView objListView
)
Managed Extensions for C++
public: ColumnHeaderSortingData(
   ListView* objListView
)
C++/CLI
public:
ColumnHeaderSortingData(
   ListView^ objListView
)

Parameters

objListView
list view.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ColumnHeaderSortingData Class
ColumnHeaderSortingData Members


ColumnHeaderSortingData Class Methods

[image]
Gizmox.WebGUI.Forms
ColumnHeaderSortingData Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ColumnHeaderSortingData Class

For a list of all members of this type, see ColumnHeaderSortingData members.

Public Methods

 | Name | Description
Public Method | Compare | Compares the specified column headers
Top

See Also

Reference

ColumnHeaderSortingData Class
Gizmox.WebGUI.Forms Namespace


Compare Method

[image]
Gizmox.WebGUI.Forms
Compare Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ColumnHeaderSortingData Class : Compare Method

objObjectA
Column A.
objObjectB
Column B.
Compares the specified column headers

Syntax

Visual Basic (Declaration)
Public Function Compare( _
   ByVal objObjectA As Object, _
   ByVal objObjectB As Object _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As ColumnHeaderSortingData
Dim objObjectA As Object
Dim objObjectB As Object
Dim value As Integer

value = instance.Compare(objObjectA, objObjectB)
C#
public int Compare(
   object objObjectA,
   object objObjectB
)
Managed Extensions for C++
public: int Compare(
   Object* objObjectA,
   Object* objObjectB
)
C++/CLI
public:
int Compare(
   Object^ objObjectA,
   Object^ objObjectB
)

Parameters

objObjectA
Column A.
objObjectB
Column B.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ColumnHeaderSortingData Class
ColumnHeaderSortingData Members


ColumnHeaderSortingData Class Properties

[image]
Gizmox.WebGUI.Forms
ColumnHeaderSortingData Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ColumnHeaderSortingData Class

For a list of all members of this type, see ColumnHeaderSortingData members.

Public Properties

 | Name | Description
Public Property | SortedColumns | Gets the columns in the order there are used in the sorting.
Public Property | SortingColumns | Gets the sorting participating columns.
Top

See Also

Reference

ColumnHeaderSortingData Class
Gizmox.WebGUI.Forms Namespace


SortedColumns Property

[image]
Gizmox.WebGUI.Forms
SortedColumns Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ColumnHeaderSortingData Class : SortedColumns Property

Gets the columns in the order there are used in the sorting.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SortedColumns As ICollection
Visual Basic (Usage) Copy Code
Dim instance As ColumnHeaderSortingData
Dim value As ICollection

value = instance.SortedColumns
C#
public ICollection SortedColumns {get;}
Managed Extensions for C++
public: __property ICollection* get_SortedColumns();
C++/CLI
public:
property ICollection^ SortedColumns {
   ICollection^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ColumnHeaderSortingData Class
ColumnHeaderSortingData Members


SortingColumns Property

[image]
Gizmox.WebGUI.Forms
SortingColumns Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ColumnHeaderSortingData Class : SortingColumns Property

Gets the sorting participating columns.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SortingColumns As ICollection
Visual Basic (Usage) Copy Code
Dim instance As ColumnHeaderSortingData
Dim value As ICollection

value = instance.SortingColumns
C#
public ICollection SortingColumns {get;}
Managed Extensions for C++
public: __property ICollection* get_SortingColumns();
C++/CLI
public:
property ICollection^ SortingColumns {
   ICollection^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ColumnHeaderSortingData Class
ColumnHeaderSortingData Members


ColumnStyle Class

[image]
Gizmox.WebGUI.Forms
ColumnStyle Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ColumnStyle Class

Syntax

Visual Basic (Declaration)
<DesignTimeControllerAttribute()>
<ClientControllerAttribute()>
Public Class ColumnStyle
   Inherits TableLayoutStyle
   Implements IObservableItem
Visual Basic (Usage) Copy Code
Dim instance As ColumnStyle
C#
[DesignTimeControllerAttribute()]
[ClientControllerAttribute()]
public class ColumnStyle : TableLayoutStyle, IObservableItem
Managed Extensions for C++
[DesignTimeControllerAttribute()]
[ClientControllerAttribute()]
public __gc class ColumnStyle : public TableLayoutStyle, IObservableItem
C++/CLI
[DesignTimeControllerAttribute()]
[ClientControllerAttribute()]
public ref class ColumnStyle : public TableLayoutStyle, IObservableItem

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.TableLayoutStyle
Gizmox.WebGUI.Forms.ColumnStyle

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

ColumnStyle Members
Gizmox.WebGUI.Forms Namespace


ColumnStyle Class Members

[image]
Gizmox.WebGUI.Forms
ColumnStyle Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : ColumnStyle Class

The following tables list the members exposed by ColumnStyle.

Public Constructors

 | Name | Description
Public Constructor | ColumnStyle Constructor | Overloaded. Creates a new ColumnStyle instance.
Top

Public Properties

 | Name | Description
Public Property | SizeType | (Inherited from TableLayoutStyle)
Public Property | Width | Gets or sets the width.
Top

Protected Methods

 | Name | Description
Protected Method | FireObservableItemPropertyChanged | Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from TableLayoutStyle)
Top

See Also

Reference

ColumnStyle Class
Gizmox.WebGUI.Forms Namespace


ColumnStyle Constructor

[image]
Gizmox.WebGUI.Forms
ColumnStyle Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ColumnStyle Class : ColumnStyle Constructor

Creates a new ColumnStyle instance.

Overload List

Overload | Description
ColumnStyle Constructor() |
ColumnStyle Constructor(Int32) | Creates a new ColumnStyle instance.
ColumnStyle Constructor(SizeType) |
ColumnStyle Constructor(SizeType,Single) |
ColumnStyle Constructor(String) | Creates a new ColumnStyle instance.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ColumnStyle Class
ColumnStyle Members


ColumnStyle Constructor()

[image]
Gizmox.WebGUI.Forms
ColumnStyle Constructor()
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ColumnStyle Class > ColumnStyle Constructor : ColumnStyle Constructor()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ColumnStyle()
C#
public ColumnStyle()
Managed Extensions for C++
public: ColumnStyle();
C++/CLI
public:
ColumnStyle();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ColumnStyle Class
ColumnStyle Members
Overload List


ColumnStyle Constructor(Int32)

[image]
Gizmox.WebGUI.Forms
ColumnStyle Constructor(Int32)
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ColumnStyle Class > ColumnStyle Constructor : ColumnStyle Constructor(Int32)

intWidth
Width of the current column.
Creates a new ColumnStyle instance.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal intWidth As Integer _
)
Visual Basic (Usage) Copy Code
Dim intWidth As Integer

Dim instance As ColumnStyle(intWidth)
C#
public ColumnStyle(
   int intWidth
)
Managed Extensions for C++
public: ColumnStyle(
   int intWidth
)
C++/CLI
public:
ColumnStyle(
   int intWidth
)

Parameters

intWidth
Width of the current column.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ColumnStyle Class
ColumnStyle Members
Overload List


ColumnStyle Constructor(SizeType)

[image]
Gizmox.WebGUI.Forms
ColumnStyle Constructor(SizeType)
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ColumnStyle Class > ColumnStyle Constructor : ColumnStyle Constructor(SizeType)

sizeType

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal sizeType As SizeType _
)
Visual Basic (Usage) Copy Code
Dim sizeType As SizeType

Dim instance As ColumnStyle(sizeType)
C#
public ColumnStyle(
   SizeType sizeType
)
Managed Extensions for C++
public: ColumnStyle(
   SizeType sizeType
)
C++/CLI
public:
ColumnStyle(
   SizeType sizeType
)

Parameters

sizeType

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ColumnStyle Class
ColumnStyle Members
Overload List


ColumnStyle Constructor(SizeType,Single)

[image]
Gizmox.WebGUI.Forms
ColumnStyle Constructor(SizeType,Single)
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ColumnStyle Class > ColumnStyle Constructor : ColumnStyle Constructor(SizeType,Single)

sizeType
width

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal sizeType As SizeType, _
   ByVal width As Single _
)
Visual Basic (Usage) Copy Code
Dim sizeType As SizeType
Dim width As Single

Dim instance As ColumnStyle(sizeType, width)
C#
public ColumnStyle(
   SizeType sizeType,
   float width
)
Managed Extensions for C++
public: ColumnStyle(
   SizeType sizeType,
   float width
)
C++/CLI
public:
ColumnStyle(
   SizeType sizeType,
   float width
)

Parameters

sizeType
width

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ColumnStyle Class
ColumnStyle Members
Overload List


ColumnStyle Constructor(String)

[image]
Gizmox.WebGUI.Forms
ColumnStyle Constructor(String)
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ColumnStyle Class > ColumnStyle Constructor : ColumnStyle Constructor(String)

strWidth
Width of the current column.
Creates a new ColumnStyle instance.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal strWidth As String _
)
Visual Basic (Usage) Copy Code
Dim strWidth As String

Dim instance As ColumnStyle(strWidth)
C#
public ColumnStyle(
   string strWidth
)
Managed Extensions for C++
public: ColumnStyle(
   string* strWidth
)
C++/CLI
public:
ColumnStyle(
   String^ strWidth
)

Parameters

strWidth
Width of the current column.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ColumnStyle Class
ColumnStyle Members
Overload List


ColumnStyle Class Properties

[image]
Gizmox.WebGUI.Forms
ColumnStyle Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ColumnStyle Class

For a list of all members of this type, see ColumnStyle members.

Public Properties

 | Name | Description
Public Property | SizeType | (Inherited from TableLayoutStyle)
Public Property | Width | Gets or sets the width.
Top

See Also

Reference

ColumnStyle Class
Gizmox.WebGUI.Forms Namespace


Width Property

[image]
Gizmox.WebGUI.Forms
Width Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ColumnStyle Class : Width Property

Gets or sets the width.

Syntax

Visual Basic (Declaration)
Public Property Width As Single
Visual Basic (Usage) Copy Code
Dim instance As ColumnStyle
Dim value As Single

instance.Width = value

value = instance.Width
C#
public float Width {get; set;}
Managed Extensions for C++
public: __property float get_Width();
public: __property void set_Width(
   float value
);
C++/CLI
public:
property float Width {
   float get();
   void set (floatvalue);
}

Return Value

The width.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ColumnStyle Class
ColumnStyle Members


ComboBox Class

[image]
Gizmox.WebGUI.Forms
ComboBox Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ComboBox Class

Represents a Gizmox.WebGUI.Forms combo box control.

Object Model

Syntax

Visual Basic (Declaration)
<SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableComboBox, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")>
<ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<ToolboxBitmapAttribute()>
<DefaultEventAttribute("SelectedIndexChanged")>
<DesignTimeControllerAttribute()>
<ClientControllerAttribute()>
<SRDescriptionAttribute("Displays an editable text box with a drop-down list of permitted values.")>
<ToolboxItemCategoryAttribute("Common Controls")>
<MetadataTagAttribute("CB")>
Public Class ComboBox
   Inherits ListControl
   Implements IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Visual Basic (Usage) Copy Code
Dim instance As ComboBox
C#
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableComboBox, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ToolboxBitmapAttribute()]
[DefaultEventAttribute("SelectedIndexChanged")]
[DesignTimeControllerAttribute()]
[ClientControllerAttribute()]
[SRDescriptionAttribute("Displays an editable text box with a drop-down list of permitted values.")]
[ToolboxItemCategoryAttribute("Common Controls")]
[MetadataTagAttribute("CB")]
public class ComboBox : ListControl, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Managed Extensions for C++
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableComboBox, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ToolboxBitmapAttribute()]
[DefaultEventAttribute("SelectedIndexChanged")]
[DesignTimeControllerAttribute()]
[ClientControllerAttribute()]
[SRDescriptionAttribute("Displays an editable text box with a drop-down list of permitted values.")]
[ToolboxItemCategoryAttribute("Common Controls")]
[MetadataTagAttribute("CB")]
public __gc class ComboBox : public ListControl, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
C++/CLI
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableComboBox, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ToolboxBitmapAttribute()]
[DefaultEventAttribute("SelectedIndexChanged")]
[DesignTimeControllerAttribute()]
[ClientControllerAttribute()]
[SRDescriptionAttribute("Displays an editable text box with a drop-down list of permitted values.")]
[ToolboxItemCategoryAttribute("Common Controls")]
[MetadataTagAttribute("CB")]
public ref class ComboBox : public ListControl, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.ListControl
Gizmox.WebGUI.Forms.ComboBox
Gizmox.WebGUI.Forms.ColorComboBox

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

ComboBox Members
Gizmox.WebGUI.Forms Namespace


ComboBox Class Members

[image]
Gizmox.WebGUI.Forms
ComboBox Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : ComboBox Class

The following tables list the members exposed by ComboBox.

Public Constructors

 | Name | Description
Public Constructor | ComboBox Constructor | Initializes a new instance of the ComboBox class.
Top

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | AutoCompleteMode | Gets or sets the auto complete mode.
Public Property | AutoCompleteSource | Gets or sets the auto-completion source.
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CodeMember | Gets or sets the code member.
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | DataSource | Gets or sets the data source for this ListControl. (Inherited from ListControl)
Public Property | DisplayMember | Gets or sets the property to display for this ListControl. (Inherited from ListControl)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DragTargets | Overridden. Gets a value indicating whether this instance is dragable.
Public Property | DropDownStyle | Gets or sets the drop down style.
Public Property | DropDownWidth | Gets or sets the width of the of the drop-down portion of a combo box.
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | FormatInfo | Gets or sets the IFormatProvider that provides custom formatting behavior. (Inherited from ListControl)
Public Property | FormatString | Gets or sets the format-specifier characters that indicate how a value is to be displayed. (Inherited from ListControl)
Public Property | FormattingEnabled | Gets or sets a value indicating whether formatting is applied to the ListControl.DisplayMember property of the ListControl. (Inherited from ListControl)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | Items | Gets an object representing the collection of the items contained in this ComboBox.
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaxDropDownItems | Gets or sets the maximum number of items to be shown in the drop-down portion of the ComboBox.
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | SelectedIndex | Overridden. Gets or sets the index specifying the currently selected item.
Public Property | SelectedItem | Gets or sets currently selected item in the ComboBox.
Public Property | SelectedValue | Gets or sets the value of the member property specified by the ListControl.ValueMember property. (Inherited from ListControl)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | Sorted | Gets or sets a value indicating whether the items in the combo box are sorted.
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Overridden. Override the Control Text When the combo control is binded to a BindingSource Text property(a string data member in the DB) we have to set the combo index to match the text.
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | ValueMember | Gets or sets the property to use as the actual value for the items in the ListControl. (Inherited from ListControl)
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | AllowSelection | Gets a value indicating whether the list enables selection of list items. (Inherited from ListControl)
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DataManager | Gets the CurrencyManager associated with this control. (Inherited from ListControl)
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsCustomDropDown | Gets a value indicating whether this instance has a custom drop down.
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | IsPostBackRequired | Indicates if the list control context requires its events to cause callback (Inherited from ListControl)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | FindCode | Finds the item in the ListBox that has this code.
Public Method | FindString | Finds the first item in the ListBox that starts with the specified string.
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetItemText | Returns the text representation of the specified item. (Inherited from ListControl)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | Overridden. Returns a string that represents the ComboBox control.
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | CreateItemCollection | Creates the item collection.
Protected Method | FilterItemOnProperty | Overloaded. Retrieves the current value of the ListControl item, if it is a property of an object, given the item. (Inherited from ListControl)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Overridden. Fires an event.
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Overridden. Gets the critical events.
Protected Method | GetCustomDropDown | Gets the custom form to display as drop down
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from Control)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from ListControl)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDataSourceChanged | Overridden. Raises the ListControl.DataSourceChanged event.
Protected Method | OnDisplayMemberChanged | Raises the ListControl.DisplayMemberChanged event. (Inherited from ListControl)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnFormat | Raises the ListControl.Format event. (Inherited from ListControl)
Protected Method | OnFormatInfoChanged | Raises the ListControl.FormatInfoChanged event. (Inherited from ListControl)
Protected Method | OnFormatStringChanged | Raises the ListControl.FormatStringChanged event. (Inherited from ListControl)
Protected Method | OnFormattingEnabledChanged | Raises the ListControl.FormattingEnabledChanged event. (Inherited from ListControl)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnSelectedIndexChanged | Overridden.
Protected Method | OnSelectedIndexChangedQueued | Raises the OnSelectedIndexChangedQueued event
Protected Method | OnSelectedValueChanged | Raises the ListControl.SelectedValueChanged event. (Inherited from ListControl)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnValueMemberChanged | Raises the ListControl.ValueMemberChanged event. (Inherited from ListControl)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RefreshItem | Overridden. When overridden in a derived class, resynchronizes the data of the object at the specified index with the contents of the data source.
Protected Method | RefreshItems | Overridden. Refreshes all ComboBox items.
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | Overridden. Renders the current control.
Protected Method | RenderAttributes | Overridden.
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderItemAttributes |
Protected Method | RenderUpdatedAttributes | Overridden.
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SelectAll | Selects all items.
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetItemCore | When overridden in a derived class, sets the object with the specified index in the derived class. (Inherited from ListControl)
Protected Method | SetItemsCore | Overridden. When overridden in a derived class, sets the specified array of objects in a collection in the derived class.
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | DataSourceChanged | Occurs when the ListControl.DataSource changes. (Inherited from ListControl)
Public Event | DisplayMemberChanged | Occurs when the ListControl.DisplayMember property changes. (Inherited from ListControl)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | Format | Occurs when the control is bound to a data value. (Inherited from ListControl)
Public Event | FormatInfoChanged | Occurs when the value of the ListControl.FormatInfo property changes. (Inherited from ListControl)
Public Event | FormatStringChanged | Occurs when value of the ListControl.FormatString property changes (Inherited from ListControl)
Public Event | FormattingEnabledChanged | Occurs when the value of the ListControl.FormattingEnabled property changes. (Inherited from ListControl)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | SelectedIndexChanged | Occurs when the ComboBox.SelectedIndex property has changed.
Public Event | SelectedIndexChangedQueued | Occurs when the SelectedIndex property has changed (Queued).
Public Event | SelectedValueChanged | Occurs when the ListControl.SelectedValue property changes. (Inherited from ListControl)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | ValueMemberChanged | Occurs when the ListControl.ValueMember property changes. (Inherited from ListControl)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

ComboBox Class
Gizmox.WebGUI.Forms Namespace


ComboBox Constructor

[image]
Gizmox.WebGUI.Forms
ComboBox Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ComboBox Class : ComboBox Constructor

Initializes a new instance of the ComboBox class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ComboBox()
C#
public ComboBox()
Managed Extensions for C++
public: ComboBox();
C++/CLI
public:
ComboBox();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ComboBox Class
ComboBox Members


ComboBox Class Methods

[image]
Gizmox.WebGUI.Forms
ComboBox Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ComboBox Class

For a list of all members of this type, see ComboBox members.

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | FindCode | Finds the item in the ListBox that has this code.
Public Method | FindString | Finds the first item in the ListBox that starts with the specified string.
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetItemText | Returns the text representation of the specified item. (Inherited from ListControl)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | Overridden. Returns a string that represents the ComboBox control.
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | CreateItemCollection | Creates the item collection.
Protected Method | FilterItemOnProperty | Overloaded. Retrieves the current value of the ListControl item, if it is a property of an object, given the item. (Inherited from ListControl)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Overridden. Fires an event.
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Overridden. Gets the critical events.
Protected Method | GetCustomDropDown | Gets the custom form to display as drop down
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from Control)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from ListControl)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDataSourceChanged | Overridden. Raises the ListControl.DataSourceChanged event.
Protected Method | OnDisplayMemberChanged | Raises the ListControl.DisplayMemberChanged event. (Inherited from ListControl)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnFormat | Raises the ListControl.Format event. (Inherited from ListControl)
Protected Method | OnFormatInfoChanged | Raises the ListControl.FormatInfoChanged event. (Inherited from ListControl)
Protected Method | OnFormatStringChanged | Raises the ListControl.FormatStringChanged event. (Inherited from ListControl)
Protected Method | OnFormattingEnabledChanged | Raises the ListControl.FormattingEnabledChanged event. (Inherited from ListControl)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnSelectedIndexChanged | Overridden.
Protected Method | OnSelectedIndexChangedQueued | Raises the OnSelectedIndexChangedQueued event
Protected Method | OnSelectedValueChanged | Raises the ListControl.SelectedValueChanged event. (Inherited from ListControl)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnValueMemberChanged | Raises the ListControl.ValueMemberChanged event. (Inherited from ListControl)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RefreshItem | Overridden. When overridden in a derived class, resynchronizes the data of the object at the specified index with the contents of the data source.
Protected Method | RefreshItems | Overridden. Refreshes all ComboBox items.
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | Overridden. Renders the current control.
Protected Method | RenderAttributes | Overridden.
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderItemAttributes |
Protected Method | RenderUpdatedAttributes | Overridden.
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SelectAll | Selects all items.
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetItemCore | When overridden in a derived class, sets the object with the specified index in the derived class. (Inherited from ListControl)
Protected Method | SetItemsCore | Overridden. When overridden in a derived class, sets the specified array of objects in a collection in the derived class.
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

See Also

Reference

ComboBox Class
Gizmox.WebGUI.Forms Namespace


CreateItemCollection Method

[image]
Gizmox.WebGUI.Forms
CreateItemCollection Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ComboBox Class : CreateItemCollection Method

Creates the item collection.

Syntax

Visual Basic (Declaration)
Protected Overridable Function CreateItemCollection() As ComboBox.ObjectCollection
Visual Basic (Usage) Copy Code
Dim instance As ComboBox
Dim value As ComboBox.ObjectCollection

value = instance.CreateItemCollection()
C#
protected virtual ComboBox.ObjectCollection CreateItemCollection()
Managed Extensions for C++
protected: virtual ComboBox.ObjectCollection* CreateItemCollection();
C++/CLI
protected:
virtual ComboBox::ObjectCollection^ CreateItemCollection();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ComboBox Class
ComboBox Members


FindCode Method

[image]
Gizmox.WebGUI.Forms
FindCode Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ComboBox Class : FindCode Method

strCode
Finds the item in the ListBox that has this code.

Syntax

Visual Basic (Declaration)
Public Function FindCode( _
   ByVal strCode As String _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As ComboBox
Dim strCode As String
Dim value As Integer

value = instance.FindCode(strCode)
C#
public int FindCode(
   string strCode
)
Managed Extensions for C++
public: int FindCode(
   string* strCode
)
C++/CLI
public:
int FindCode(
   String^ strCode
)

Parameters

strCode

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ComboBox Class
ComboBox Members


FindString Method

[image]
Gizmox.WebGUI.Forms
FindString Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ComboBox Class : FindString Method

strValue
startIndex
Finds the first item in the ListBox that starts with the specified string.

Syntax

Visual Basic (Declaration)
Public Function FindString( _
   ByVal strValue As String, _
   ByVal startIndex As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As ComboBox
Dim strValue As String
Dim startIndex As Integer
Dim value As Integer

value = instance.FindString(strValue, startIndex)
C#
public int FindString(
   string strValue,
   int startIndex
)
Managed Extensions for C++
public: int FindString(
   string* strValue,
   int startIndex
)
C++/CLI
public:
int FindString(
   String^ strValue,
   int startIndex
)

Parameters

strValue
startIndex

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ComboBox Class
ComboBox Members


FireEvent Method

[image]
Gizmox.WebGUI.Forms
FireEvent Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ComboBox Class : FireEvent Method

objEvent
event.
Fires an event.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub FireEvent( _
   ByVal objEvent As IEvent _
)
Visual Basic (Usage) Copy Code
Dim instance As ComboBox
Dim objEvent As IEvent

instance.FireEvent(objEvent)
C#
protected override void FireEvent(
   IEvent objEvent
)
Managed Extensions for C++
protected: void FireEvent(
   IEvent* objEvent
) override
C++/CLI
protected:
void FireEvent(
   IEvent^ objEvent
) override

Parameters

objEvent
event.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ComboBox Class
ComboBox Members


GetCriticalEvents Method

[image]
Gizmox.WebGUI.Forms
GetCriticalEvents Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ComboBox Class : GetCriticalEvents Method

Gets the critical events.

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetCriticalEvents() As EventTypes
Visual Basic (Usage) Copy Code
Dim instance As ComboBox
Dim value As EventTypes

value = instance.GetCriticalEvents()
C#
protected override EventTypes GetCriticalEvents()
Managed Extensions for C++
protected: EventTypes GetCriticalEvents(); override
C++/CLI
protected:
EventTypes GetCriticalEvents(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ComboBox Class
ComboBox Members


GetCustomDropDown Method

[image]
Gizmox.WebGUI.Forms
GetCustomDropDown Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ComboBox Class : GetCustomDropDown Method

Gets the custom form to display as drop down

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetCustomDropDown() As Form
Visual Basic (Usage) Copy Code
Dim instance As ComboBox
Dim value As Form

value = instance.GetCustomDropDown()
C#
protected virtual Form GetCustomDropDown()
Managed Extensions for C++
protected: virtual Form* GetCustomDropDown();
C++/CLI
protected:
virtual Form^ GetCustomDropDown();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ComboBox Class
ComboBox Members


OnDataSourceChanged Method

[image]
Gizmox.WebGUI.Forms
OnDataSourceChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ComboBox Class : OnDataSourceChanged Method

e
An EventArgs that contains the event data.
Raises the ListControl.DataSourceChanged event.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnDataSourceChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ComboBox
Dim e As EventArgs

instance.OnDataSourceChanged(e)
C#
protected override void OnDataSourceChanged(
   EventArgs e
)
Managed Extensions for C++
protected: void OnDataSourceChanged(
   EventArgs* e
) override
C++/CLI
protected:
void OnDataSourceChanged(
   EventArgs^ e
) override

Parameters

e
An EventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ComboBox Class
ComboBox Members


OnSelectedIndexChanged Method

[image]
Gizmox.WebGUI.Forms
OnSelectedIndexChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ComboBox Class : OnSelectedIndexChanged Method

eventargs

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnSelectedIndexChanged( _
   ByVal eventargs As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ComboBox
Dim eventargs As EventArgs

instance.OnSelectedIndexChanged(eventargs)
C#
protected override void OnSelectedIndexChanged(
   EventArgs eventargs
)
Managed Extensions for C++
protected: void OnSelectedIndexChanged(
   EventArgs* eventargs
) override
C++/CLI
protected:
void OnSelectedIndexChanged(
   EventArgs^ eventargs
) override

Parameters

eventargs

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ComboBox Class
ComboBox Members


OnSelectedIndexChangedQueued Method

[image]
Gizmox.WebGUI.Forms
OnSelectedIndexChangedQueued Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ComboBox Class : OnSelectedIndexChangedQueued Method

eventargs
Raises the OnSelectedIndexChangedQueued event

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnSelectedIndexChangedQueued( _
   ByVal eventargs As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ComboBox
Dim eventargs As EventArgs

instance.OnSelectedIndexChangedQueued(eventargs)
C#
protected virtual void OnSelectedIndexChangedQueued(
   EventArgs eventargs
)
Managed Extensions for C++
protected: virtual void OnSelectedIndexChangedQueued(
   EventArgs* eventargs
)
C++/CLI
protected:
virtual void OnSelectedIndexChangedQueued(
   EventArgs^ eventargs
)

Parameters

eventargs

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ComboBox Class
ComboBox Members


RefreshItem Method

[image]
Gizmox.WebGUI.Forms
RefreshItem Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ComboBox Class : RefreshItem Method

index
The zero-based index of the item whose data to refresh.
When overridden in a derived class, resynchronizes the data of the object at the specified index with the contents of the data source.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub RefreshItem( _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As ComboBox
Dim index As Integer

instance.RefreshItem(index)
C#
protected override void RefreshItem(
   int index
)
Managed Extensions for C++
protected: void RefreshItem(
   int index
) override
C++/CLI
protected:
void RefreshItem(
   int index
) override

Parameters

index
The zero-based index of the item whose data to refresh.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ComboBox Class
ComboBox Members


RefreshItems Method

[image]
Gizmox.WebGUI.Forms
RefreshItems Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ComboBox Class : RefreshItems Method

Refreshes all ComboBox items.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub RefreshItems()
Visual Basic (Usage) Copy Code
Dim instance As ComboBox

instance.RefreshItems()
C#
protected override void RefreshItems()
Managed Extensions for C++
protected: void RefreshItems(); override
C++/CLI
protected:
void RefreshItems(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ComboBox Class
ComboBox Members


Render Method

[image]
Gizmox.WebGUI.Forms
Render Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ComboBox Class : Render Method

objContext
Request context.
objWriter
lngRequestID
Renders the current control.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub Render( _
   ByVal objContext As IContext, _
   ByVal objWriter As IResponseWriter, _
   ByVal lngRequestID As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As ComboBox
Dim objContext As IContext
Dim objWriter As IResponseWriter
Dim lngRequestID As Long

instance.Render(objContext, objWriter, lngRequestID)
C#
protected override void Render(
   IContext objContext,
   IResponseWriter objWriter,
   long lngRequestID
)
Managed Extensions for C++
protected: void Render(
   IContext* objContext,
   IResponseWriter* objWriter,
   long lngRequestID
) override
C++/CLI
protected:
void Render(
   IContext^ objContext,
   IResponseWriter^ objWriter,
   long long lngRequestID
) override

Parameters

objContext
Request context.
objWriter
lngRequestID

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ComboBox Class
ComboBox Members


RenderAttributes Method

[image]
Gizmox.WebGUI.Forms
RenderAttributes Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ComboBox Class : RenderAttributes Method

objContext
objWriter

Syntax

Visual Basic (Declaration)
Protected Overrides Sub RenderAttributes( _
   ByVal objContext As IContext, _
   ByVal objWriter As IAttributeWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As ComboBox
Dim objContext As IContext
Dim objWriter As IAttributeWriter

instance.RenderAttributes(objContext, objWriter)
C#
protected override void RenderAttributes(
   IContext objContext,
   IAttributeWriter objWriter
)
Managed Extensions for C++
protected: void RenderAttributes(
   IContext* objContext,
   IAttributeWriter* objWriter
) override
C++/CLI
protected:
void RenderAttributes(
   IContext^ objContext,
   IAttributeWriter^ objWriter
) override

Parameters

objContext
objWriter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ComboBox Class
ComboBox Members


RenderItemAttributes Method

[image]
Gizmox.WebGUI.Forms
RenderItemAttributes Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ComboBox Class : RenderItemAttributes Method

objWriter
objItem
intIndex

Syntax

Visual Basic (Declaration)
Protected Overridable Sub RenderItemAttributes( _
   ByVal objWriter As IResponseWriter, _
   ByVal objItem As Object, _
   ByVal intIndex As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As ComboBox
Dim objWriter As IResponseWriter
Dim objItem As Object
Dim intIndex As Integer

instance.RenderItemAttributes(objWriter, objItem, intIndex)
C#
protected virtual void RenderItemAttributes(
   IResponseWriter objWriter,
   object objItem,
   int intIndex
)
Managed Extensions for C++
protected: virtual void RenderItemAttributes(
   IResponseWriter* objWriter,
   Object* objItem,
   int intIndex
)
C++/CLI
protected:
virtual void RenderItemAttributes(
   IResponseWriter^ objWriter,
   Object^ objItem,
   int intIndex
)

Parameters

objWriter
objItem
intIndex

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ComboBox Class
ComboBox Members


RenderUpdatedAttributes Method

[image]
Gizmox.WebGUI.Forms
RenderUpdatedAttributes Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ComboBox Class : RenderUpdatedAttributes Method

objContext
objWriter
lngRequestID

Syntax

Visual Basic (Declaration)
Protected Overrides Sub RenderUpdatedAttributes( _
   ByVal objContext As IContext, _
   ByVal objWriter As IAttributeWriter, _
   ByVal lngRequestID As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As ComboBox
Dim objContext As IContext
Dim objWriter As IAttributeWriter
Dim lngRequestID As Long

instance.RenderUpdatedAttributes(objContext, objWriter, lngRequestID)
C#
protected override void RenderUpdatedAttributes(
   IContext objContext,
   IAttributeWriter objWriter,
   long lngRequestID
)
Managed Extensions for C++
protected: void RenderUpdatedAttributes(
   IContext* objContext,
   IAttributeWriter* objWriter,
   long lngRequestID
) override
C++/CLI
protected:
void RenderUpdatedAttributes(
   IContext^ objContext,
   IAttributeWriter^ objWriter,
   long long lngRequestID
) override

Parameters

objContext
objWriter
lngRequestID

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ComboBox Class
ComboBox Members


SelectAll Method

[image]
Gizmox.WebGUI.Forms
SelectAll Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ComboBox Class : SelectAll Method

Selects all items.

Syntax

Visual Basic (Declaration)
Protected Sub SelectAll()
Visual Basic (Usage) Copy Code
Dim instance As ComboBox

instance.SelectAll()
C#
protected void SelectAll()
Managed Extensions for C++
protected: void SelectAll();
C++/CLI
protected:
void SelectAll();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ComboBox Class
ComboBox Members


SetItemsCore Method

[image]
Gizmox.WebGUI.Forms
SetItemsCore Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ComboBox Class : SetItemsCore Method

items
An array of items.
When overridden in a derived class, sets the specified array of objects in a collection in the derived class.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub SetItemsCore( _
   ByVal items As IList _
)
Visual Basic (Usage) Copy Code
Dim instance As ComboBox
Dim items As IList

instance.SetItemsCore(items)
C#
protected override void SetItemsCore(
   IList items
)
Managed Extensions for C++
protected: void SetItemsCore(
   IList* items
) override
C++/CLI
protected:
void SetItemsCore(
   IList^ items
) override

Parameters

items
An array of items.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ComboBox Class
ComboBox Members


ToString Method

[image]
Gizmox.WebGUI.Forms
ToString Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ComboBox Class : ToString Method

Returns a string that represents the ComboBox control.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As ComboBox
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Return Value

A String that represents the current ComboBox. The string includes the type and the number of items in the ComboBox control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ComboBox Class
ComboBox Members


ComboBox Class Properties

[image]
Gizmox.WebGUI.Forms
ComboBox Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ComboBox Class

For a list of all members of this type, see ComboBox members.

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | AutoCompleteMode | Gets or sets the auto complete mode.
Public Property | AutoCompleteSource | Gets or sets the auto-completion source.
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CodeMember | Gets or sets the code member.
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | DataSource | Gets or sets the data source for this ListControl. (Inherited from ListControl)
Public Property | DisplayMember | Gets or sets the property to display for this ListControl. (Inherited from ListControl)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DragTargets | Overridden. Gets a value indicating whether this instance is dragable.
Public Property | DropDownStyle | Gets or sets the drop down style.
Public Property | DropDownWidth | Gets or sets the width of the of the drop-down portion of a combo box.
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | FormatInfo | Gets or sets the IFormatProvider that provides custom formatting behavior. (Inherited from ListControl)
Public Property | FormatString | Gets or sets the format-specifier characters that indicate how a value is to be displayed. (Inherited from ListControl)
Public Property | FormattingEnabled | Gets or sets a value indicating whether formatting is applied to the ListControl.DisplayMember property of the ListControl. (Inherited from ListControl)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | Items | Gets an object representing the collection of the items contained in this ComboBox.
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaxDropDownItems | Gets or sets the maximum number of items to be shown in the drop-down portion of the ComboBox.
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | SelectedIndex | Overridden. Gets or sets the index specifying the currently selected item.
Public Property | SelectedItem | Gets or sets currently selected item in the ComboBox.
Public Property | SelectedValue | Gets or sets the value of the member property specified by the ListControl.ValueMember property. (Inherited from ListControl)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | Sorted | Gets or sets a value indicating whether the items in the combo box are sorted.
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Overridden. Override the Control Text When the combo control is binded to a BindingSource Text property(a string data member in the DB) we have to set the combo index to match the text.
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | ValueMember | Gets or sets the property to use as the actual value for the items in the ListControl. (Inherited from ListControl)
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | AllowSelection | Gets a value indicating whether the list enables selection of list items. (Inherited from ListControl)
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DataManager | Gets the CurrencyManager associated with this control. (Inherited from ListControl)
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsCustomDropDown | Gets a value indicating whether this instance has a custom drop down.
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | IsPostBackRequired | Indicates if the list control context requires its events to cause callback (Inherited from ListControl)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

See Also

Reference

ComboBox Class
Gizmox.WebGUI.Forms Namespace


AutoCompleteMode Property

[image]
Gizmox.WebGUI.Forms
AutoCompleteMode Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ComboBox Class : AutoCompleteMode Property

Gets or sets the auto complete mode.

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute()>
<SRDescriptionAttribute("Indicates the text completion behavior of the combo box.")>
<BrowsableAttribute(True)>
<DefaultValueAttribute()>
Public Property AutoCompleteMode As AutoCompleteMode
Visual Basic (Usage) Copy Code
Dim instance As ComboBox
Dim value As AutoCompleteMode

instance.AutoCompleteMode = value

value = instance.AutoCompleteMode
C#
[EditorBrowsableAttribute()]
[SRDescriptionAttribute("Indicates the text completion behavior of the combo box.")]
[BrowsableAttribute(true)]
[DefaultValueAttribute()]
public AutoCompleteMode AutoCompleteMode {get; set;}
Managed Extensions for C++
[EditorBrowsableAttribute()]
[SRDescriptionAttribute("Indicates the text completion behavior of the combo box.")]
[BrowsableAttribute(true)]
[DefaultValueAttribute()]
public: __property AutoCompleteMode get_AutoCompleteMode();
public: __property void set_AutoCompleteMode(
   AutoCompleteMode value
);
C++/CLI
[EditorBrowsableAttribute()]
[SRDescriptionAttribute("Indicates the text completion behavior of the combo box.")]
[BrowsableAttribute(true)]
[DefaultValueAttribute()]
public:
property AutoCompleteMode AutoCompleteMode {
   AutoCompleteMode get();
   void set (AutoCompleteModevalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ComboBox Class
ComboBox Members


AutoCompleteSource Property

[image]
Gizmox.WebGUI.Forms
AutoCompleteSource Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ComboBox Class : AutoCompleteSource Property

Gets or sets the auto-completion source.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<EditorBrowsableAttribute()>
<BrowsableAttribute(True)>
<SRDescriptionAttribute("The source of complete strings used for automatic completion.")>
Public Property AutoCompleteSource As AutoCompleteSource
Visual Basic (Usage) Copy Code
Dim instance As ComboBox
Dim value As AutoCompleteSource

instance.AutoCompleteSource = value

value = instance.AutoCompleteSource
C#
[DefaultValueAttribute()]
[EditorBrowsableAttribute()]
[BrowsableAttribute(true)]
[SRDescriptionAttribute("The source of complete strings used for automatic completion.")]
public AutoCompleteSource AutoCompleteSource {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[EditorBrowsableAttribute()]
[BrowsableAttribute(true)]
[SRDescriptionAttribute("The source of complete strings used for automatic completion.")]
public: __property AutoCompleteSource get_AutoCompleteSource();
public: __property void set_AutoCompleteSource(
   AutoCompleteSource value
);
C++/CLI
[DefaultValueAttribute()]
[EditorBrowsableAttribute()]
[BrowsableAttribute(true)]
[SRDescriptionAttribute("The source of complete strings used for automatic completion.")]
public:
property AutoCompleteSource AutoCompleteSource {
   AutoCompleteSource get();
   void set (AutoCompleteSourcevalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ComboBox Class
ComboBox Members


CodeMember Property

[image]
Gizmox.WebGUI.Forms
CodeMember Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ComboBox Class : CodeMember Property

Gets or sets the code member.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property CodeMember As String
Visual Basic (Usage) Copy Code
Dim instance As ComboBox
Dim value As String

instance.CodeMember = value

value = instance.CodeMember
C#
[DefaultValueAttribute()]
public string CodeMember {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property string* get_CodeMember();
public: __property void set_CodeMember(
   string* value
);
C++/CLI
[DefaultValueAttribute()]
public:
property String^ CodeMember {
   String^ get();
   void set (String^value);
}

Return Value

The code member.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ComboBox Class
ComboBox Members


DragTargets Property

[image]
Gizmox.WebGUI.Forms
DragTargets Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ComboBox Class : DragTargets Property

Gets a value indicating whether this instance is dragable.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property DragTargets As Component()
Visual Basic (Usage) Copy Code
Dim instance As ComboBox
Dim value() As Component

value = instance.DragTargets
C#
public override Component[] DragTargets {get;}
Managed Extensions for C++
public: __property Component*[]* get_DragTargets() override;
C++/CLI
public:
property array<Component^>^ DragTargets {
   array<Component^>^ get() override;
}

Return Value

true if this instance is dragable; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ComboBox Class
ComboBox Members


DropDownStyle Property

[image]
Gizmox.WebGUI.Forms
DropDownStyle Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ComboBox Class : DropDownStyle Property

Gets or sets the drop down style.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property DropDownStyle As ComboBoxStyle
Visual Basic (Usage) Copy Code
Dim instance As ComboBox
Dim value As ComboBoxStyle

instance.DropDownStyle = value

value = instance.DropDownStyle
C#
[DefaultValueAttribute()]
public ComboBoxStyle DropDownStyle {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property ComboBoxStyle get_DropDownStyle();
public: __property void set_DropDownStyle(
   ComboBoxStyle value
);
C++/CLI
[DefaultValueAttribute()]
public:
property ComboBoxStyle DropDownStyle {
   ComboBoxStyle get();
   void set (ComboBoxStylevalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ComboBox Class
ComboBox Members


DropDownWidth Property

[image]
Gizmox.WebGUI.Forms
DropDownWidth Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ComboBox Class : DropDownWidth Property

Gets or sets the width of the of the drop-down portion of a combo box.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Behavior")>
<SRDescriptionAttribute("The width, in pixels, of the drop-down box in a combo box.")>
Public Property DropDownWidth As Integer
Visual Basic (Usage) Copy Code
Dim instance As ComboBox
Dim value As Integer

instance.DropDownWidth = value

value = instance.DropDownWidth
C#
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("The width, in pixels, of the drop-down box in a combo box.")]
public int DropDownWidth {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("The width, in pixels, of the drop-down box in a combo box.")]
public: __property int get_DropDownWidth();
public: __property void set_DropDownWidth(
   int value
);
C++/CLI
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("The width, in pixels, of the drop-down box in a combo box.")]
public:
property int DropDownWidth {
   int get();
   void set (intvalue);
}

Exceptions

Exception | Description
ArgumentException | The specified value is less than one.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ComboBox Class
ComboBox Members


IsCustomDropDown Property

[image]
Gizmox.WebGUI.Forms
IsCustomDropDown Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ComboBox Class : IsCustomDropDown Property

Gets a value indicating whether this instance has a custom drop down.

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property IsCustomDropDown As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ComboBox
Dim value As Boolean

value = instance.IsCustomDropDown
C#
protected virtual bool IsCustomDropDown {get;}
Managed Extensions for C++
protected: __property virtual bool get_IsCustomDropDown();
C++/CLI
protected:
virtual property bool IsCustomDropDown {
   bool get();
}

Return Value

true if this instance has a custom drop down; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ComboBox Class
ComboBox Members


Items Property

[image]
Gizmox.WebGUI.Forms
Items Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ComboBox Class : Items Property

Gets an object representing the collection of the items contained in this ComboBox.

Syntax

Visual Basic (Declaration)
<EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.ListControlStringCollectionEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")>
<DesignerSerializationVisibilityAttribute()>
Public ReadOnly Property Items As ComboBox.ObjectCollection
Visual Basic (Usage) Copy Code
Dim instance As ComboBox
Dim value As ComboBox.ObjectCollection

value = instance.Items
C#
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.ListControlStringCollectionEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[DesignerSerializationVisibilityAttribute()]
public ComboBox.ObjectCollection Items {get;}
Managed Extensions for C++
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.ListControlStringCollectionEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[DesignerSerializationVisibilityAttribute()]
public: __property ComboBox.ObjectCollection* get_Items();
C++/CLI
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.ListControlStringCollectionEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[DesignerSerializationVisibilityAttribute()]
public:
property ComboBox::ObjectCollection^ Items {
   ComboBox::ObjectCollection^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ComboBox Class
ComboBox Members


MaxDropDownItems Property

[image]
Gizmox.WebGUI.Forms
MaxDropDownItems Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ComboBox Class : MaxDropDownItems Property

Gets or sets the maximum number of items to be shown in the drop-down portion of the ComboBox.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<SRCategoryAttribute("Behavior")>
<LocalizableAttribute(True)>
<SRDescriptionAttribute("The maximum number of entries to display in the drop-down list.")>
Public Property MaxDropDownItems As Integer
Visual Basic (Usage) Copy Code
Dim instance As ComboBox
Dim value As Integer

instance.MaxDropDownItems = value

value = instance.MaxDropDownItems
C#
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
[LocalizableAttribute(true)]
[SRDescriptionAttribute("The maximum number of entries to display in the drop-down list.")]
public int MaxDropDownItems {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
[LocalizableAttribute(true)]
[SRDescriptionAttribute("The maximum number of entries to display in the drop-down list.")]
public: __property int get_MaxDropDownItems();
public: __property void set_MaxDropDownItems(
   int value
);
C++/CLI
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
[LocalizableAttribute(true)]
[SRDescriptionAttribute("The maximum number of entries to display in the drop-down list.")]
public:
property int MaxDropDownItems {
   int get();
   void set (intvalue);
}

Exceptions

Exception | Description
ArgumentException | The maximum number is set less than one or greater than 100.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ComboBox Class
ComboBox Members


SelectedIndex Property

[image]
Gizmox.WebGUI.Forms
SelectedIndex Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ComboBox Class : SelectedIndex Property

Gets or sets the index specifying the currently selected item.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<SRDescriptionAttribute("The index of the currently selected item of the combo box.")>
<DesignerSerializationVisibilityAttribute()>
Public Overrides Property SelectedIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As ComboBox
Dim value As Integer

instance.SelectedIndex = value

value = instance.SelectedIndex
C#
[BrowsableAttribute(false)]
[SRDescriptionAttribute("The index of the currently selected item of the combo box.")]
[DesignerSerializationVisibilityAttribute()]
public override int SelectedIndex {get; set;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[SRDescriptionAttribute("The index of the currently selected item of the combo box.")]
[DesignerSerializationVisibilityAttribute()]
public: __property int get_SelectedIndex() override;
public: __property void set_SelectedIndex(
   int value
) override;
C++/CLI
[BrowsableAttribute(false)]
[SRDescriptionAttribute("The index of the currently selected item of the combo box.")]
[DesignerSerializationVisibilityAttribute()]
public:
property int SelectedIndex {
   int get() override;
   void set (intvalue) override;
}

Exceptions

Exception | Description
ArgumentOutOfRangeException | The specified index is less than or equal to -2.-or- The specified index is greater than or equal to the number of items in the combo box.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ComboBox Class
ComboBox Members


SelectedItem Property

[image]
Gizmox.WebGUI.Forms
SelectedItem Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ComboBox Class : SelectedItem Property

Gets or sets currently selected item in the ComboBox.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("The currently selected item in the combo box, or null.")>
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public Property SelectedItem As Object
Visual Basic (Usage) Copy Code
Dim instance As ComboBox
Dim value As Object

instance.SelectedItem = value

value = instance.SelectedItem
C#
[SRDescriptionAttribute("The currently selected item in the combo box, or null.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public object SelectedItem {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("The currently selected item in the combo box, or null.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property Object* get_SelectedItem();
public: __property void set_SelectedItem(
   Object* value
);
C++/CLI
[SRDescriptionAttribute("The currently selected item in the combo box, or null.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
property Object^ SelectedItem {
   Object^ get();
   void set (Object^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ComboBox Class
ComboBox Members


Sorted Property

[image]
Gizmox.WebGUI.Forms
Sorted Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ComboBox Class : Sorted Property

Gets or sets a value indicating whether the items in the combo box are sorted.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Behavior")>
<SRDescriptionAttribute("Specifies whether items in the list portion of the combo box are sorted.")>
<DefaultValueAttribute()>
Public Property Sorted As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ComboBox
Dim value As Boolean

instance.Sorted = value

value = instance.Sorted
C#
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Specifies whether items in the list portion of the combo box are sorted.")]
[DefaultValueAttribute()]
public bool Sorted {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Specifies whether items in the list portion of the combo box are sorted.")]
[DefaultValueAttribute()]
public: __property bool get_Sorted();
public: __property void set_Sorted(
   bool value
);
C++/CLI
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Specifies whether items in the list portion of the combo box are sorted.")]
[DefaultValueAttribute()]
public:
property bool Sorted {
   bool get();
   void set (boolvalue);
}

Exceptions

Exception | Description
ArgumentException | An attempt was made to sort a ComboBox that is attached to a data source.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ComboBox Class
ComboBox Members


Text Property

[image]
Gizmox.WebGUI.Forms
Text Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ComboBox Class : Text Property

Override the Control Text When the combo control is binded to a BindingSource Text property(a string data member in the DB) we have to set the combo index to match the text.

Syntax

Visual Basic (Declaration)
Public Overrides Property Text As String
Visual Basic (Usage) Copy Code
Dim instance As ComboBox
Dim value As String

instance.Text = value

value = instance.Text
C#
public override string Text {get; set;}
Managed Extensions for C++
public: __property string* get_Text() override;
public: __property void set_Text(
   string* value
) override;
C++/CLI
public:
property String^ Text {
   String^ get() override;
   void set (String^value) override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ComboBox Class
ComboBox Members


ComboBox Class Events

[image]
Gizmox.WebGUI.Forms
ComboBox Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ComboBox Class

For a list of all members of this type, see ComboBox members.

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | DataSourceChanged | Occurs when the ListControl.DataSource changes. (Inherited from ListControl)
Public Event | DisplayMemberChanged | Occurs when the ListControl.DisplayMember property changes. (Inherited from ListControl)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | Format | Occurs when the control is bound to a data value. (Inherited from ListControl)
Public Event | FormatInfoChanged | Occurs when the value of the ListControl.FormatInfo property changes. (Inherited from ListControl)
Public Event | FormatStringChanged | Occurs when value of the ListControl.FormatString property changes (Inherited from ListControl)
Public Event | FormattingEnabledChanged | Occurs when the value of the ListControl.FormattingEnabled property changes. (Inherited from ListControl)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | SelectedIndexChanged | Occurs when the ComboBox.SelectedIndex property has changed.
Public Event | SelectedIndexChangedQueued | Occurs when the SelectedIndex property has changed (Queued).
Public Event | SelectedValueChanged | Occurs when the ListControl.SelectedValue property changes. (Inherited from ListControl)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | ValueMemberChanged | Occurs when the ListControl.ValueMember property changes. (Inherited from ListControl)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

ComboBox Class
Gizmox.WebGUI.Forms Namespace


SelectedIndexChanged Event

[image]
Gizmox.WebGUI.Forms
SelectedIndexChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ComboBox Class : SelectedIndexChanged Event

Occurs when the ComboBox.SelectedIndex property has changed.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the value of the SelectedIndex property changes.")>
<SRCategoryAttribute("Behavior")>
Public Event SelectedIndexChanged() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As ComboBox
Dim handler As EventHandler

AddHandler instance.SelectedIndexChanged, handler
C#
[SRDescriptionAttribute("Occurs when the value of the SelectedIndex property changes.")]
[SRCategoryAttribute("Behavior")]
public event EventHandler SelectedIndexChanged()
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the value of the SelectedIndex property changes.")]
[SRCategoryAttribute("Behavior")]
public: __event EventHandler* SelectedIndexChanged
C++/CLI
[SRDescriptionAttribute("Occurs when the value of the SelectedIndex property changes.")]
[SRCategoryAttribute("Behavior")]
public:
event EventHandler^ SelectedIndexChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ComboBox Class
ComboBox Members


SelectedIndexChangedQueued Event

[image]
Gizmox.WebGUI.Forms
SelectedIndexChangedQueued Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ComboBox Class : SelectedIndexChangedQueued Event

Occurs when the SelectedIndex property has changed (Queued).

Syntax

Visual Basic (Declaration)
Public Event SelectedIndexChangedQueued() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As ComboBox
Dim handler As EventHandler

AddHandler instance.SelectedIndexChangedQueued, handler
C#
public event EventHandler SelectedIndexChangedQueued()
Managed Extensions for C++
public: __event EventHandler* SelectedIndexChangedQueued
C++/CLI
public:
event EventHandler^ SelectedIndexChangedQueued

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ComboBox Class
ComboBox Members


ComboBox.ObjectCollection Class

[image]
Gizmox.WebGUI.Forms
ComboBox.ObjectCollection Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ComboBox.ObjectCollection Class

Represents the collection of items in a ComboBox.

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
<ListBindableAttribute(False)>
Public Class ComboBox.ObjectCollection
Visual Basic (Usage) Copy Code
Dim instance As ComboBox.ObjectCollection
C#
[DefaultMemberAttribute("Item")]
[ListBindableAttribute(false)]
public class ComboBox.ObjectCollection
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
[ListBindableAttribute(false)]
public __gc class ComboBox.ObjectCollection
C++/CLI
[DefaultMemberAttribute("Item")]
[ListBindableAttribute(false)]
public ref class ComboBox.ObjectCollection

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComboBox.ObjectCollection
Gizmox.WebGUI.Forms.ColorComboBox.ObjectCollection

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

ComboBox.ObjectCollection Members
Gizmox.WebGUI.Forms Namespace


ComboBox.ObjectCollection Class Members

[image]
Gizmox.WebGUI.Forms
ComboBox.ObjectCollection Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : ComboBox.ObjectCollection Class

The following tables list the members exposed by ComboBox.ObjectCollection.

Public Properties

 | Name | Description
Public Property | Count | Gets the number of items in the collection.
Public Property | IsFixedSize | For a description of this member, see IsFixedSize.
Public Property | IsReadOnly | Gets a value indicating whether this collection can be modified.
Public Property | IsSynchronized | For a description of this member, see IsSynchronized.
Public Property | Item | Gets the Object with the specified int index.
Public Property | SyncRoot | Gets the sync root.
Top

Public Methods

 | Name | Description
Public Method | Add | Adds an item to the list of items for a ComboBox.
Public Method | AddRange | Overloaded. Adds an array of items to the list of items for a ComboBox.
Public Method | Clear | Removes all items from the ComboBox.
Public Method | Contains | Determines if the specified item is located within the collection.
Public Method | CopyTo | For a description of this member, see CopyTo.
Public Method | GetEnumerator | Returns an enumerator that can be used to iterate through the item collection.
Public Method | IndexOf | Retrieves the index within the collection of the specified item.
Public Method | Insert | Inserts an item into the collection at the specified index.
Public Method | Remove | Removes the specified item from the ComboBox.
Public Method | RemoveAt | Removes an item from the ComboBox at the specified index.
Top

See Also

Reference

ComboBox.ObjectCollection Class
Gizmox.WebGUI.Forms Namespace


ComboBox.ObjectCollection Class Methods

[image]
Gizmox.WebGUI.Forms
ComboBox.ObjectCollection Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ComboBox.ObjectCollection Class

For a list of all members of this type, see ComboBox.ObjectCollection members.

Public Methods

 | Name | Description
Public Method | Add | Adds an item to the list of items for a ComboBox.
Public Method | AddRange | Overloaded. Adds an array of items to the list of items for a ComboBox.
Public Method | Clear | Removes all items from the ComboBox.
Public Method | Contains | Determines if the specified item is located within the collection.
Public Method | CopyTo | For a description of this member, see CopyTo.
Public Method | GetEnumerator | Returns an enumerator that can be used to iterate through the item collection.
Public Method | IndexOf | Retrieves the index within the collection of the specified item.
Public Method | Insert | Inserts an item into the collection at the specified index.
Public Method | Remove | Removes the specified item from the ComboBox.
Public Method | RemoveAt | Removes an item from the ComboBox at the specified index.
Top

See Also

Reference

ComboBox.ObjectCollection Class
Gizmox.WebGUI.Forms Namespace


Add Method

[image]
Gizmox.WebGUI.Forms
Add Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ComboBox.ObjectCollection Class : Add Method

item
An object representing the item to add to the collection.
Adds an item to the list of items for a ComboBox.

Syntax

Visual Basic (Declaration)
Public Function Add( _
   ByVal item As Object _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As ComboBox.ObjectCollection
Dim item As Object
Dim value As Integer

value = instance.Add(item)
C#
public int Add(
   object item
)
Managed Extensions for C++
public: int Add(
   Object* item
)
C++/CLI
public:
int Add(
   Object^ item
)

Parameters

item
An object representing the item to add to the collection.

Return Value

The zero-based index of the item in the collection.

Exceptions

Exception | Description
ArgumentNullException | The item parameter was null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ComboBox.ObjectCollection Class
ComboBox.ObjectCollection Members


AddRange Method

[image]
Gizmox.WebGUI.Forms
AddRange Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ComboBox.ObjectCollection Class : AddRange Method

Adds an array of items to the list of items for a ComboBox.

Overload List

Overload | Description
AddRange(Object[]) | Adds an array of items to the list of items for a ComboBox.
AddRange(ICollection) | Adds a range of objects.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ComboBox.ObjectCollection Class
ComboBox.ObjectCollection Members


AddRange(Object[]) Method

[image]
Gizmox.WebGUI.Forms
AddRange(Object[]) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ComboBox.ObjectCollection Class > AddRange Method : AddRange(Object[]) Method

objObjects
An array of objects to add to the list.
Adds an array of items to the list of items for a ComboBox.

Syntax

Visual Basic (Declaration)
Public Overloads Sub AddRange( _
   ByVal objObjects() As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ComboBox.ObjectCollection
Dim objObjects() As Object

instance.AddRange(objObjects)
C#
public void AddRange(
   object[] objObjects
)
Managed Extensions for C++
public: void AddRange(
   Object*[]* objObjects
)
C++/CLI
public:
void AddRange(
   array<Object^>^ objObjects
)

Parameters

objObjects
An array of objects to add to the list.

Exceptions

Exception | Description
ArgumentNullException | An item in the items parameter was null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ComboBox.ObjectCollection Class
ComboBox.ObjectCollection Members
Overload List


AddRange(ICollection) Method

[image]
Gizmox.WebGUI.Forms
AddRange(ICollection) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ComboBox.ObjectCollection Class > AddRange Method : AddRange(ICollection) Method

objObjects
objects.
Adds a range of objects.

Syntax

Visual Basic (Declaration)
Public Overloads Sub AddRange( _
   ByVal objObjects As ICollection _
)
Visual Basic (Usage) Copy Code
Dim instance As ComboBox.ObjectCollection
Dim objObjects As ICollection

instance.AddRange(objObjects)
C#
public void AddRange(
   ICollection objObjects
)
Managed Extensions for C++
public: void AddRange(
   ICollection* objObjects
)
C++/CLI
public:
void AddRange(
   ICollection^ objObjects
)

Parameters

objObjects
objects.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ComboBox.ObjectCollection Class
ComboBox.ObjectCollection Members
Overload List


Clear Method

[image]
Gizmox.WebGUI.Forms
Clear Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ComboBox.ObjectCollection Class : Clear Method

Removes all items from the ComboBox.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As ComboBox.ObjectCollection

instance.Clear()
C#
public void Clear()
Managed Extensions for C++
public: void Clear();
C++/CLI
public:
void Clear();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ComboBox.ObjectCollection Class
ComboBox.ObjectCollection Members


Contains Method

[image]
Gizmox.WebGUI.Forms
Contains Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ComboBox.ObjectCollection Class : Contains Method

value
An object representing the item to locate in the collection.
Determines if the specified item is located within the collection.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal value As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ComboBox.ObjectCollection
Dim value As Object
Dim value As Boolean

value = instance.Contains(value)
C#
public bool Contains(
   object value
)
Managed Extensions for C++
public: bool Contains(
   Object* value
)
C++/CLI
public:
bool Contains(
   Object^ value
)

Parameters

value
An object representing the item to locate in the collection.

Return Value

true if the item is located within the collection; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ComboBox.ObjectCollection Class
ComboBox.ObjectCollection Members


CopyTo Method

[image]
Gizmox.WebGUI.Forms
CopyTo Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ComboBox.ObjectCollection Class : CopyTo Method

destination
The one-dimensional array that is the destination of the elements copied from the collection. The array must have zero-based indexing.
index
The zero-based index in the array at which copying begins.
For a description of this member, see CopyTo.

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal destination As Array, _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As ComboBox.ObjectCollection
Dim destination As Array
Dim index As Integer

instance.CopyTo(destination, index)
C#
public void CopyTo(
   Array destination,
   int index
)
Managed Extensions for C++
public: void CopyTo(
   Array* destination,
   int index
)
C++/CLI
public:
void CopyTo(
   Array^ destination,
   int index
)

Parameters

destination
The one-dimensional array that is the destination of the elements copied from the collection. The array must have zero-based indexing.
index
The zero-based index in the array at which copying begins.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ComboBox.ObjectCollection Class
ComboBox.ObjectCollection Members


GetEnumerator Method

[image]
Gizmox.WebGUI.Forms
GetEnumerator Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ComboBox.ObjectCollection Class : GetEnumerator Method

Returns an enumerator that can be used to iterate through the item collection.

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As ComboBox.ObjectCollection
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Return Value

An IEnumerator that represents the item collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ComboBox.ObjectCollection Class
ComboBox.ObjectCollection Members


IndexOf Method

[image]
Gizmox.WebGUI.Forms
IndexOf Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ComboBox.ObjectCollection Class : IndexOf Method

value
An object representing the item to locate in the collection.
Retrieves the index within the collection of the specified item.

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal value As Object _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As ComboBox.ObjectCollection
Dim value As Object
Dim value As Integer

value = instance.IndexOf(value)
C#
public int IndexOf(
   object value
)
Managed Extensions for C++
public: int IndexOf(
   Object* value
)
C++/CLI
public:
int IndexOf(
   Object^ value
)

Parameters

value
An object representing the item to locate in the collection.

Return Value

The zero-based index where the item is located within the collection; otherwise, -1.

Exceptions

Exception | Description
ArgumentNullException | The value parameter was null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ComboBox.ObjectCollection Class
ComboBox.ObjectCollection Members


Insert Method

[image]
Gizmox.WebGUI.Forms
Insert Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ComboBox.ObjectCollection Class : Insert Method

index
The zero-based index location where the item is inserted.
item
An object representing the item to insert.
Inserts an item into the collection at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal item As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ComboBox.ObjectCollection
Dim index As Integer
Dim item As Object

instance.Insert(index, item)
C#
public void Insert(
   int index,
   object item
)
Managed Extensions for C++
public: void Insert(
   int index,
   Object* item
)
C++/CLI
public:
void Insert(
   int index,
   Object^ item
)

Parameters

index
The zero-based index location where the item is inserted.
item
An object representing the item to insert.

Return Value

The zero-based index of the newly added item.

Exceptions

Exception | Description
ArgumentNullException | The item was null.
ArgumentOutOfRangeException | The index was less than zero.-or- The index was greater than the count of items in the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ComboBox.ObjectCollection Class
ComboBox.ObjectCollection Members


Remove Method

[image]
Gizmox.WebGUI.Forms
Remove Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ComboBox.ObjectCollection Class : Remove Method

value
The Object to remove from the list.
Removes the specified item from the ComboBox.

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal value As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ComboBox.ObjectCollection
Dim value As Object

instance.Remove(value)
C#
public void Remove(
   object value
)
Managed Extensions for C++
public: void Remove(
   Object* value
)
C++/CLI
public:
void Remove(
   Object^ value
)

Parameters

value
The Object to remove from the list.

Exceptions

Exception | Description
ArgumentOutOfRangeException | The value parameter was less than zero.-or- The value parameter was greater than or equal to the count of items in the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ComboBox.ObjectCollection Class
ComboBox.ObjectCollection Members


RemoveAt Method

[image]
Gizmox.WebGUI.Forms
RemoveAt Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ComboBox.ObjectCollection Class : RemoveAt Method

index
The index of the item to remove.
Removes an item from the ComboBox at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As ComboBox.ObjectCollection
Dim index As Integer

instance.RemoveAt(index)
C#
public void RemoveAt(
   int index
)
Managed Extensions for C++
public: void RemoveAt(
   int index
)
C++/CLI
public:
void RemoveAt(
   int index
)

Parameters

index
The index of the item to remove.

Exceptions

Exception | Description
ArgumentOutOfRangeException | The value parameter was less than zero.-or- The value parameter was greater than or equal to the count of items in the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ComboBox.ObjectCollection Class
ComboBox.ObjectCollection Members


ComboBox.ObjectCollection Class Properties

[image]
Gizmox.WebGUI.Forms
ComboBox.ObjectCollection Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ComboBox.ObjectCollection Class

For a list of all members of this type, see ComboBox.ObjectCollection members.

Public Properties

 | Name | Description
Public Property | Count | Gets the number of items in the collection.
Public Property | IsFixedSize | For a description of this member, see IsFixedSize.
Public Property | IsReadOnly | Gets a value indicating whether this collection can be modified.
Public Property | IsSynchronized | For a description of this member, see IsSynchronized.
Public Property | Item | Gets the Object with the specified int index.
Public Property | SyncRoot | Gets the sync root.
Top

See Also

Reference

ComboBox.ObjectCollection Class
Gizmox.WebGUI.Forms Namespace


Count Property

[image]
Gizmox.WebGUI.Forms
Count Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ComboBox.ObjectCollection Class : Count Property

Gets the number of items in the collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As ComboBox.ObjectCollection
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ComboBox.ObjectCollection Class
ComboBox.ObjectCollection Members


IsFixedSize Property

[image]
Gizmox.WebGUI.Forms
IsFixedSize Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ComboBox.ObjectCollection Class : IsFixedSize Property

For a description of this member, see IsFixedSize.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsFixedSize As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ComboBox.ObjectCollection
Dim value As Boolean

value = instance.IsFixedSize
C#
public bool IsFixedSize {get;}
Managed Extensions for C++
public: __property bool get_IsFixedSize();
C++/CLI
public:
property bool IsFixedSize {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ComboBox.ObjectCollection Class
ComboBox.ObjectCollection Members


IsReadOnly Property

[image]
Gizmox.WebGUI.Forms
IsReadOnly Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ComboBox.ObjectCollection Class : IsReadOnly Property

Gets a value indicating whether this collection can be modified.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsReadOnly As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ComboBox.ObjectCollection
Dim value As Boolean

value = instance.IsReadOnly
C#
public bool IsReadOnly {get;}
Managed Extensions for C++
public: __property bool get_IsReadOnly();
C++/CLI
public:
property bool IsReadOnly {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ComboBox.ObjectCollection Class
ComboBox.ObjectCollection Members


IsSynchronized Property

[image]
Gizmox.WebGUI.Forms
IsSynchronized Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ComboBox.ObjectCollection Class : IsSynchronized Property

For a description of this member, see IsSynchronized.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsSynchronized As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ComboBox.ObjectCollection
Dim value As Boolean

value = instance.IsSynchronized
C#
public bool IsSynchronized {get;}
Managed Extensions for C++
public: __property bool get_IsSynchronized();
C++/CLI
public:
property bool IsSynchronized {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ComboBox.ObjectCollection Class
ComboBox.ObjectCollection Members


Item Property

[image]
Gizmox.WebGUI.Forms
Item Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ComboBox.ObjectCollection Class : Item Property

intIndex
Gets the Object with the specified int index.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public Default Property Item( _
   ByVal intIndex As Integer _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As ComboBox.ObjectCollection
Dim intIndex As Integer
Dim value As Object

instance.Item(intIndex) = value

value = instance.Item(intIndex)
C#
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public object this[
   int intIndex
]; {get; set;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property Object* get_Item(
   int intIndex
);
public: __property void set_Item(
   int intIndex,
   Object* value
);
C++/CLI
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
property Object^ default [int] {
   Object^ get(intintIndex);
   void set (intintIndex, Object^value);
}

Parameters

intIndex

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ComboBox.ObjectCollection Class
ComboBox.ObjectCollection Members


SyncRoot Property

[image]
Gizmox.WebGUI.Forms
SyncRoot Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ComboBox.ObjectCollection Class : SyncRoot Property

Gets the sync root.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SyncRoot As Object
Visual Basic (Usage) Copy Code
Dim instance As ComboBox.ObjectCollection
Dim value As Object

value = instance.SyncRoot
C#
public object SyncRoot {get;}
Managed Extensions for C++
public: __property Object* get_SyncRoot();
C++/CLI
public:
property Object^ SyncRoot {
   Object^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ComboBox.ObjectCollection Class
ComboBox.ObjectCollection Members


CommonDialog Class

[image]
Gizmox.WebGUI.Forms
CommonDialog Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : CommonDialog Class

Specifies the base class used for displaying dialog boxes on the screen.

Syntax

Visual Basic (Declaration)
<ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")>
<ToolboxItemCategoryAttribute("Dialogs")>
<ToolboxItemFilterAttribute("Gizmox.WebGUI.Forms")>
Public MustInherit Class CommonDialog
   Inherits ComponentBase
   Implements ICommonDialog
Visual Basic (Usage) Copy Code
Dim instance As CommonDialog
C#
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
[ToolboxItemCategoryAttribute("Dialogs")]
[ToolboxItemFilterAttribute("Gizmox.WebGUI.Forms")]
public abstract class CommonDialog : ComponentBase, ICommonDialog
Managed Extensions for C++
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
[ToolboxItemCategoryAttribute("Dialogs")]
[ToolboxItemFilterAttribute("Gizmox.WebGUI.Forms")]
public __gc abstract class CommonDialog : public ComponentBase, ICommonDialog
C++/CLI
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
[ToolboxItemCategoryAttribute("Dialogs")]
[ToolboxItemFilterAttribute("Gizmox.WebGUI.Forms")]
public ref class CommonDialog abstract : public ComponentBase, ICommonDialog

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.CommonDialog
Gizmox.WebGUI.Forms.ColorDialog
Gizmox.WebGUI.Forms.FileDialog
Gizmox.WebGUI.Forms.FolderBrowserDialog
Gizmox.WebGUI.Forms.FontDialog

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

CommonDialog Members
Gizmox.WebGUI.Forms Namespace


CommonDialog Class Members

[image]
Gizmox.WebGUI.Forms
CommonDialog Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : CommonDialog Class

The following tables list the members exposed by CommonDialog.

Public Properties

 | Name | Description
Public Property | Container | (Inherited from ComponentBase)
Public Property | DialogResult | Returns the last dialog result
Public Property | Site | (Inherited from ComponentBase)
Public Property | Tag | Gets or sets an object that contains data about the control.
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Top

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded. (Inherited from ComponentBase)
Public Method | Reset | When overridden in a derived class, resets the properties of a common dialog box to their default values.
Public Method | ShowDialog | Overloaded. Runs a common dialog box with a default owner.
Public Method | ToString | (Inherited from ComponentBase)
Top

Protected Methods

 | Name | Description
Protected Method | CreateForm | Creates a dialog for instance for the current common dialog
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | OnApply | Handles apply event
Protected Method | OnClosed | Raises the Close event.
Protected Method | OnHelpRequest | Raises the CommonDialog.HelpRequest event.
Top

Public Events

 | Name | Description
Public Event | Closed | The form close event
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | HelpRequest | Occurs when the user clicks the Help button on a common dialog box.
Top

See Also

Reference

CommonDialog Class
Gizmox.WebGUI.Forms Namespace


CommonDialog Class Methods

[image]
Gizmox.WebGUI.Forms
CommonDialog Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : CommonDialog Class

For a list of all members of this type, see CommonDialog members.

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded. (Inherited from ComponentBase)
Public Method | Reset | When overridden in a derived class, resets the properties of a common dialog box to their default values.
Public Method | ShowDialog | Overloaded. Runs a common dialog box with a default owner.
Public Method | ToString | (Inherited from ComponentBase)
Top

Protected Methods

 | Name | Description
Protected Method | CreateForm | Creates a dialog for instance for the current common dialog
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | OnApply | Handles apply event
Protected Method | OnClosed | Raises the Close event.
Protected Method | OnHelpRequest | Raises the CommonDialog.HelpRequest event.
Top

See Also

Reference

CommonDialog Class
Gizmox.WebGUI.Forms Namespace


CreateForm Method

[image]
Gizmox.WebGUI.Forms
CreateForm Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CommonDialog Class : CreateForm Method

Creates a dialog for instance for the current common dialog

Syntax

Visual Basic (Declaration)
Protected MustOverride Function CreateForm() As CommonDialog.CommonDialogForm
Visual Basic (Usage) Copy Code
Dim instance As CommonDialog
Dim value As CommonDialog.CommonDialogForm

value = instance.CreateForm()
C#
protected abstract CommonDialog.CommonDialogForm CreateForm()
Managed Extensions for C++
protected: abstract CommonDialog.CommonDialogForm* CreateForm();
C++/CLI
protected:
abstract CommonDialog::CommonDialogForm^ CreateForm();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CommonDialog Class
CommonDialog Members


OnApply Method

[image]
Gizmox.WebGUI.Forms
OnApply Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CommonDialog Class : OnApply Method

e
Handles apply event

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnApply( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As CommonDialog
Dim e As EventArgs

instance.OnApply(e)
C#
protected virtual void OnApply(
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnApply(
   EventArgs* e
)
C++/CLI
protected:
virtual void OnApply(
   EventArgs^ e
)

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CommonDialog Class
CommonDialog Members


OnClosed Method

[image]
Gizmox.WebGUI.Forms
OnClosed Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CommonDialog Class : OnClosed Method

e
An EventArgs that provides the event data.
Raises the Close event.

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnClosed( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As CommonDialog
Dim e As EventArgs

instance.OnClosed(e)
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnClosed(
   EventArgs e
)
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnClosed(
   EventArgs* e
)
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnClosed(
   EventArgs^ e
)

Parameters

e
An EventArgs that provides the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CommonDialog Class
CommonDialog Members


OnHelpRequest Method

[image]
Gizmox.WebGUI.Forms
OnHelpRequest Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CommonDialog Class : OnHelpRequest Method

e
An HelpEventArgs that provides the event data.
Raises the CommonDialog.HelpRequest event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnHelpRequest( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As CommonDialog
Dim e As EventArgs

instance.OnHelpRequest(e)
C#
protected virtual void OnHelpRequest(
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnHelpRequest(
   EventArgs* e
)
C++/CLI
protected:
virtual void OnHelpRequest(
   EventArgs^ e
)

Parameters

e
An HelpEventArgs that provides the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CommonDialog Class
CommonDialog Members


Reset Method

[image]
Gizmox.WebGUI.Forms
Reset Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CommonDialog Class : Reset Method

When overridden in a derived class, resets the properties of a common dialog box to their default values.

Syntax

Visual Basic (Declaration)
Public MustOverride Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As CommonDialog

instance.Reset()
C#
public abstract void Reset()
Managed Extensions for C++
public: abstract void Reset();
C++/CLI
public:
abstract void Reset();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CommonDialog Class
CommonDialog Members


ShowDialog Method

[image]
Gizmox.WebGUI.Forms
ShowDialog Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CommonDialog Class : ShowDialog Method

Runs a common dialog box with a default owner.

Overload List

Overload | Description
ShowDialog() | Runs a common dialog box with a default owner.
ShowDialog(EventHandler) | Runs a common dialog box with a default owner.
ShowDialog(Form) | Runs a common dialog box with the specified owner.
ShowDialog(Form,EventHandler) | Runs a common dialog box with the specified owner.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CommonDialog Class
CommonDialog Members


ShowDialog() Method

[image]
Gizmox.WebGUI.Forms
ShowDialog() Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CommonDialog Class > ShowDialog Method : ShowDialog() Method

Runs a common dialog box with a default owner.

Syntax

Visual Basic (Declaration)
Public Overloads Function ShowDialog() As DialogResult
Visual Basic (Usage) Copy Code
Dim instance As CommonDialog
Dim value As DialogResult

value = instance.ShowDialog()
C#
public DialogResult ShowDialog()
Managed Extensions for C++
public: DialogResult ShowDialog();
C++/CLI
public:
DialogResult ShowDialog();

Return Value

DialogResult.OK if the user clicks OK in the dialog box; otherwise, DialogResult.Cancel.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CommonDialog Class
CommonDialog Members
Overload List


ShowDialog(EventHandler) Method

[image]
Gizmox.WebGUI.Forms
ShowDialog(EventHandler) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CommonDialog Class > ShowDialog Method : ShowDialog(EventHandler) Method

handler
Event handler for dialog closed event
Runs a common dialog box with a default owner.

Syntax

Visual Basic (Declaration)
Public Overloads Function ShowDialog( _
   ByVal handler As EventHandler _
) As DialogResult
Visual Basic (Usage) Copy Code
Dim instance As CommonDialog
Dim handler As EventHandler
Dim value As DialogResult

value = instance.ShowDialog(handler)
C#
public DialogResult ShowDialog(
   EventHandler handler
)
Managed Extensions for C++
public: DialogResult ShowDialog(
   EventHandler* handler
)
C++/CLI
public:
DialogResult ShowDialog(
   EventHandler^ handler
)

Parameters

handler
Event handler for dialog closed event

Return Value

DialogResult.OK if the user clicks OK in the dialog box; otherwise, DialogResult.Cancel.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CommonDialog Class
CommonDialog Members
Overload List


ShowDialog(Form) Method

[image]
Gizmox.WebGUI.Forms
ShowDialog(Form) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CommonDialog Class > ShowDialog Method : ShowDialog(Form) Method

owner
Any object that implements IWin32Window that represents the top-level window that will own the modal dialog box.
Runs a common dialog box with the specified owner.

Syntax

Visual Basic (Declaration)
Public Overloads Function ShowDialog( _
   ByVal owner As Form _
) As DialogResult
Visual Basic (Usage) Copy Code
Dim instance As CommonDialog
Dim owner As Form
Dim value As DialogResult

value = instance.ShowDialog(owner)
C#
public DialogResult ShowDialog(
   Form owner
)
Managed Extensions for C++
public: DialogResult ShowDialog(
   Form* owner
)
C++/CLI
public:
DialogResult ShowDialog(
   Form^ owner
)

Parameters

owner
Any object that implements IWin32Window that represents the top-level window that will own the modal dialog box.

Return Value

DialogResult.OK if the user clicks OK in the dialog box; otherwise, DialogResult.Cancel.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CommonDialog Class
CommonDialog Members
Overload List


ShowDialog(Form,EventHandler) Method

[image]
Gizmox.WebGUI.Forms
ShowDialog(Form,EventHandler) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CommonDialog Class > ShowDialog Method : ShowDialog(Form,EventHandler) Method

owner
Any object that implements IWin32Window that represents the top-level window that will own the modal dialog box.
handler
Event handler for dialog closed event
Runs a common dialog box with the specified owner.

Syntax

Visual Basic (Declaration)
Public Overloads Function ShowDialog( _
   ByVal owner As Form, _
   ByVal handler As EventHandler _
) As DialogResult
Visual Basic (Usage) Copy Code
Dim instance As CommonDialog
Dim owner As Form
Dim handler As EventHandler
Dim value As DialogResult

value = instance.ShowDialog(owner, handler)
C#
public DialogResult ShowDialog(
   Form owner,
   EventHandler handler
)
Managed Extensions for C++
public: DialogResult ShowDialog(
   Form* owner,
   EventHandler* handler
)
C++/CLI
public:
DialogResult ShowDialog(
   Form^ owner,
   EventHandler^ handler
)

Parameters

owner
Any object that implements IWin32Window that represents the top-level window that will own the modal dialog box.
handler
Event handler for dialog closed event

Return Value

DialogResult.OK if the user clicks OK in the dialog box; otherwise, DialogResult.Cancel.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CommonDialog Class
CommonDialog Members
Overload List


CommonDialog Class Properties

[image]
Gizmox.WebGUI.Forms
CommonDialog Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : CommonDialog Class

For a list of all members of this type, see CommonDialog members.

Public Properties

 | Name | Description
Public Property | Container | (Inherited from ComponentBase)
Public Property | DialogResult | Returns the last dialog result
Public Property | Site | (Inherited from ComponentBase)
Public Property | Tag | Gets or sets an object that contains data about the control.
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Top

See Also

Reference

CommonDialog Class
Gizmox.WebGUI.Forms Namespace


DialogResult Property

[image]
Gizmox.WebGUI.Forms
DialogResult Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CommonDialog Class : DialogResult Property

Returns the last dialog result

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DialogResult As DialogResult
Visual Basic (Usage) Copy Code
Dim instance As CommonDialog
Dim value As DialogResult

value = instance.DialogResult
C#
public DialogResult DialogResult {get;}
Managed Extensions for C++
public: __property DialogResult get_DialogResult();
C++/CLI
public:
property DialogResult DialogResult {
   DialogResult get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CommonDialog Class
CommonDialog Members


Tag Property

[image]
Gizmox.WebGUI.Forms
Tag Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CommonDialog Class : Tag Property

Gets or sets an object that contains data about the control.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Data")>
<SRDescriptionAttribute("User-defined data associated with the object.")>
<DefaultValueAttribute()>
<TypeConverterAttribute("System.ComponentModel.StringConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<BindableAttribute(True)>
<LocalizableAttribute(False)>
Public Property Tag As Object
Visual Basic (Usage) Copy Code
Dim instance As CommonDialog
Dim value As Object

instance.Tag = value

value = instance.Tag
C#
[SRCategoryAttribute("Data")]
[SRDescriptionAttribute("User-defined data associated with the object.")]
[DefaultValueAttribute()]
[TypeConverterAttribute("System.ComponentModel.StringConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[BindableAttribute(true)]
[LocalizableAttribute(false)]
public object Tag {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Data")]
[SRDescriptionAttribute("User-defined data associated with the object.")]
[DefaultValueAttribute()]
[TypeConverterAttribute("System.ComponentModel.StringConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[BindableAttribute(true)]
[LocalizableAttribute(false)]
public: __property Object* get_Tag();
public: __property void set_Tag(
   Object* value
);
C++/CLI
[SRCategoryAttribute("Data")]
[SRDescriptionAttribute("User-defined data associated with the object.")]
[DefaultValueAttribute()]
[TypeConverterAttribute("System.ComponentModel.StringConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[BindableAttribute(true)]
[LocalizableAttribute(false)]
public:
property Object^ Tag {
   Object^ get();
   void set (Object^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CommonDialog Class
CommonDialog Members


CommonDialog Class Events

[image]
Gizmox.WebGUI.Forms
CommonDialog Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : CommonDialog Class

For a list of all members of this type, see CommonDialog members.

Public Events

 | Name | Description
Public Event | Closed | The form close event
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | HelpRequest | Occurs when the user clicks the Help button on a common dialog box.
Top

See Also

Reference

CommonDialog Class
Gizmox.WebGUI.Forms Namespace


Closed Event

[image]
Gizmox.WebGUI.Forms
Closed Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CommonDialog Class : Closed Event

The form close event

Syntax

Visual Basic (Declaration)
Public Event Closed() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As CommonDialog
Dim handler As EventHandler

AddHandler instance.Closed, handler
C#
public event EventHandler Closed()
Managed Extensions for C++
public: __event EventHandler* Closed
C++/CLI
public:
event EventHandler^ Closed

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CommonDialog Class
CommonDialog Members


HelpRequest Event

[image]
Gizmox.WebGUI.Forms
HelpRequest Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CommonDialog Class : HelpRequest Event

Occurs when the user clicks the Help button on a common dialog box.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the user clicks the Help button.")>
Public Event HelpRequest() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As CommonDialog
Dim handler As EventHandler

AddHandler instance.HelpRequest, handler
C#
[SRDescriptionAttribute("Occurs when the user clicks the Help button.")]
public event EventHandler HelpRequest()
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the user clicks the Help button.")]
public: __event EventHandler* HelpRequest
C++/CLI
[SRDescriptionAttribute("Occurs when the user clicks the Help button.")]
public:
event EventHandler^ HelpRequest

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CommonDialog Class
CommonDialog Members


Component Class

[image]
Gizmox.WebGUI.Forms
Component Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : Component Class

The base class for all GUI elements

Object Model

Syntax

Visual Basic (Declaration)
<ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")>
<DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089", DesignerTypeName="Gizmox.WebGUI.Common.Design.ComponentDesigner, Gizmox.WebGUI.Common.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=ea5dfe57c8eb7edd")>
Public Class Component
   Inherits RegisteredComponent
   Implements IAttributeExtender, IEventHandler, IGatewayComponent, IObservableItem, IRegisteredComponent
Visual Basic (Usage) Copy Code
Dim instance As Component
C#
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
[DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089", DesignerTypeName="Gizmox.WebGUI.Common.Design.ComponentDesigner, Gizmox.WebGUI.Common.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=ea5dfe57c8eb7edd")]
public class Component : RegisteredComponent, IAttributeExtender, IEventHandler, IGatewayComponent, IObservableItem, IRegisteredComponent
Managed Extensions for C++
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
[DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089", DesignerTypeName="Gizmox.WebGUI.Common.Design.ComponentDesigner, Gizmox.WebGUI.Common.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=ea5dfe57c8eb7edd")]
public __gc class Component : public RegisteredComponent, IAttributeExtender, IEventHandler, IGatewayComponent, IObservableItem, IRegisteredComponent
C++/CLI
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
[DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089", DesignerTypeName="Gizmox.WebGUI.Common.Design.ComponentDesigner, Gizmox.WebGUI.Common.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=ea5dfe57c8eb7edd")]
public ref class Component : public RegisteredComponent, IAttributeExtender, IEventHandler, IGatewayComponent, IObservableItem, IRegisteredComponent

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.ColumnHeader
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.DragMappings
Gizmox.WebGUI.Forms.ListViewItem
Gizmox.WebGUI.Forms.Menu
Gizmox.WebGUI.Forms.MenuCollection
Gizmox.WebGUI.Forms.ShortcutsContainer
Gizmox.WebGUI.Forms.StatusBarPanel
Gizmox.WebGUI.Forms.ToolBarButton
Gizmox.WebGUI.Forms.TreeNode

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Component Members
Gizmox.WebGUI.Forms Namespace


Component Class Members

[image]
Gizmox.WebGUI.Forms
Component Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : Component Class

The following tables list the members exposed by Component.

Public Constructors

 | Name | Description
Public Constructor | Component Constructor | Creates a new Component instance.
Top

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it
Public Property | ClientAction | Gets or sets the client action.
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContextMenu | Gets or sets the context menu code.
Public Property | CustomTemplate | Gets or sets the custom template.
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control.
Public Property | Form | Gets the owner form.
Public Property | InternalParent | Gets the parent of this component.
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Tag | Gets/Sets User definied tag
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | IsConnected | Overridden.
Protected Property | Session | Overridden. Gets the application object.
Top

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded. Disposes the specified component.
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation.
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter).
Public Method | SetLoadingMessage | Sets the loading message.
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation.
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Overridden. Fires an event.
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface.
Protected Method | GetAncestorByType | Gets the ancestor by type.
Protected Method | GetCriticalEvents | Overridden.
Protected Method | GetEventValue | Gets the event integer attribute value.
Protected Method | GetImage | Gets the image.
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnDragDrop | Raises the DragDrop event.
Protected Method | OnUnregisterComponents | Overridden.
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | Overridden.
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed.
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes.
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes.
Protected Method | SetImage | Sets the image.
Protected Method | ShouldSerializeAllowDrop |
Protected Method | ShouldSerializeCustomTemplate |
Protected Method | ShouldSerializeDragTargets |
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | Overridden.
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed.
Public Event | MenuClick | Invokes when a menu item was clicked
Top

See Also

Reference

Component Class
Gizmox.WebGUI.Forms Namespace


Component Constructor

[image]
Gizmox.WebGUI.Forms
Component Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Component Class : Component Constructor

Creates a new Component instance.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Component()
C#
public Component()
Managed Extensions for C++
public: Component();
C++/CLI
public:
Component();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Component Class
Component Members


Component Class Methods

[image]
Gizmox.WebGUI.Forms
Component Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : Component Class

For a list of all members of this type, see Component members.

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded. Disposes the specified component.
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation.
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter).
Public Method | SetLoadingMessage | Sets the loading message.
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation.
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Overridden. Fires an event.
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface.
Protected Method | GetAncestorByType | Gets the ancestor by type.
Protected Method | GetCriticalEvents | Overridden.
Protected Method | GetEventValue | Gets the event integer attribute value.
Protected Method | GetImage | Gets the image.
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnDragDrop | Raises the DragDrop event.
Protected Method | OnUnregisterComponents | Overridden.
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | Overridden.
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed.
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes.
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes.
Protected Method | SetImage | Sets the image.
Protected Method | ShouldSerializeAllowDrop |
Protected Method | ShouldSerializeCustomTemplate |
Protected Method | ShouldSerializeDragTargets |
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | Overridden.
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

See Also

Reference

Component Class
Gizmox.WebGUI.Forms Namespace


Dispose Method

[image]
Gizmox.WebGUI.Forms
Dispose Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Component Class : Dispose Method

Disposes the specified component.

Overload List

Overload | Description
Dispose(Boolean) | Disposes the specified component.
Dispose() | (Inherited from ComponentBase)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Component Class
Component Members


Dispose(Boolean) Method

[image]
Gizmox.WebGUI.Forms
Dispose(Boolean) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Component Class > Dispose Method : Dispose(Boolean) Method

disposing
Disposes the specified component.

Syntax

Visual Basic (Declaration)
Protected Overloads Overridable Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As Component
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected virtual void Dispose(
   bool disposing
)
Managed Extensions for C++
protected: virtual void Dispose(
   bool disposing
)
C++/CLI
protected:
virtual void Dispose(
   bool disposing
)

Parameters

disposing

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Component Class
Component Members
Overload List


FireEvent Method

[image]
Gizmox.WebGUI.Forms
FireEvent Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Component Class : FireEvent Method

objEvent
event.
Fires an event.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub FireEvent( _
   ByVal objEvent As IEvent _
)
Visual Basic (Usage) Copy Code
Dim instance As Component
Dim objEvent As IEvent

instance.FireEvent(objEvent)
C#
protected override void FireEvent(
   IEvent objEvent
)
Managed Extensions for C++
protected: void FireEvent(
   IEvent* objEvent
) override
C++/CLI
protected:
void FireEvent(
   IEvent^ objEvent
) override

Parameters

objEvent
event.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Component Class
Component Members


FireObservableItemPropertyChanged Method

[image]
Gizmox.WebGUI.Forms
FireObservableItemPropertyChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Component Class : FireObservableItemPropertyChanged Method

Fires the ObservableItemPropertyChanged event of the IObservableItem interface.

Overload List

Overload | Description
FireObservableItemPropertyChanged(String) | Fires the ObservableItemPropertyChanged event of the IObservableItem interface.
FireObservableItemPropertyChanged(String,Object) | Fires the ObservableItemPropertyChanged event of the IObservableItem interface.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Component Class
Component Members


FireObservableItemPropertyChanged(String) Method

[image]
Gizmox.WebGUI.Forms
FireObservableItemPropertyChanged(String) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Component Class > FireObservableItemPropertyChanged Method : FireObservableItemPropertyChanged(String) Method

strProperty
The name of the property that has changed
Fires the ObservableItemPropertyChanged event of the IObservableItem interface.

Syntax

Visual Basic (Declaration)
Protected Overloads Sub FireObservableItemPropertyChanged( _
   ByVal strProperty As String _
)
Visual Basic (Usage) Copy Code
Dim instance As Component
Dim strProperty As String

instance.FireObservableItemPropertyChanged(strProperty)
C#
protected void FireObservableItemPropertyChanged(
   string strProperty
)
Managed Extensions for C++
protected: void FireObservableItemPropertyChanged(
   string* strProperty
)
C++/CLI
protected:
void FireObservableItemPropertyChanged(
   String^ strProperty
)

Parameters

strProperty
The name of the property that has changed

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Component Class
Component Members
Overload List


FireObservableItemPropertyChanged(String,Object) Method

[image]
Gizmox.WebGUI.Forms
FireObservableItemPropertyChanged(String,Object) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Component Class > FireObservableItemPropertyChanged Method : FireObservableItemPropertyChanged(String,Object) Method

strProperty
The name of the property that has changed
objSubject
The subject of the property that has changed
Fires the ObservableItemPropertyChanged event of the IObservableItem interface.

Syntax

Visual Basic (Declaration)
Protected Overloads Sub FireObservableItemPropertyChanged( _
   ByVal strProperty As String, _
   ByVal objSubject As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As Component
Dim strProperty As String
Dim objSubject As Object

instance.FireObservableItemPropertyChanged(strProperty, objSubject)
C#
protected void FireObservableItemPropertyChanged(
   string strProperty,
   object objSubject
)
Managed Extensions for C++
protected: void FireObservableItemPropertyChanged(
   string* strProperty,
   Object* objSubject
)
C++/CLI
protected:
void FireObservableItemPropertyChanged(
   String^ strProperty,
   Object^ objSubject
)

Parameters

strProperty
The name of the property that has changed
objSubject
The subject of the property that has changed

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Component Class
Component Members
Overload List


GetAncestorByType Method

[image]
Gizmox.WebGUI.Forms
GetAncestorByType Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Component Class : GetAncestorByType Method

objType
type.
Gets the ancestor by type.

Syntax

Visual Basic (Declaration)
Protected Function GetAncestorByType( _
   ByVal objType As Type _
) As Component
Visual Basic (Usage) Copy Code
Dim instance As Component
Dim objType As Type
Dim value As Component

value = instance.GetAncestorByType(objType)
C#
protected Component GetAncestorByType(
   Type objType
)
Managed Extensions for C++
protected: Component* GetAncestorByType(
   Type* objType
)
C++/CLI
protected:
Component^ GetAncestorByType(
   Type^ objType
)

Parameters

objType
type.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Component Class
Component Members


GetCriticalEvents Method

[image]
Gizmox.WebGUI.Forms
GetCriticalEvents Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Component Class : GetCriticalEvents Method

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetCriticalEvents() As EventTypes
Visual Basic (Usage) Copy Code
Dim instance As Component
Dim value As EventTypes

value = instance.GetCriticalEvents()
C#
protected override EventTypes GetCriticalEvents()
Managed Extensions for C++
protected: EventTypes GetCriticalEvents(); override
C++/CLI
protected:
EventTypes GetCriticalEvents(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Component Class
Component Members


GetEventValue Method

[image]
Gizmox.WebGUI.Forms
GetEventValue Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Component Class : GetEventValue Method

objEvent
The event.
strAttribute
The attribute name.
intDefault
The default integer value.
Gets the event integer attribute value.

Syntax

Visual Basic (Declaration)
Protected Function GetEventValue( _
   ByVal objEvent As IEvent, _
   ByVal strAttribute As String, _
   ByVal intDefault As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As Component
Dim objEvent As IEvent
Dim strAttribute As String
Dim intDefault As Integer
Dim value As Integer

value = instance.GetEventValue(objEvent, strAttribute, intDefault)
C#
protected int GetEventValue(
   IEvent objEvent,
   string strAttribute,
   int intDefault
)
Managed Extensions for C++
protected: int GetEventValue(
   IEvent* objEvent,
   string* strAttribute,
   int intDefault
)
C++/CLI
protected:
int GetEventValue(
   IEvent^ objEvent,
   String^ strAttribute,
   int intDefault
)

Parameters

objEvent
The event.
strAttribute
The attribute name.
intDefault
The default integer value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Component Class
Component Members


GetImage Method

[image]
Gizmox.WebGUI.Forms
GetImage Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Component Class : GetImage Method

objImage
objImageList
The image list.
intImageIndex
Index of the image.
strImageKey
The image key.
intParentImageIndex
strParentImageKey
Gets the image.

Syntax

Visual Basic (Declaration)
Protected Function GetImage( _
   ByVal objImage As ResourceHandle, _
   ByVal objImageList As ImageList, _
   ByVal intImageIndex As Integer, _
   ByVal strImageKey As String, _
   ByVal intParentImageIndex As Integer, _
   ByVal strParentImageKey As String _
) As ResourceHandle
Visual Basic (Usage) Copy Code
Dim instance As Component
Dim objImage As ResourceHandle
Dim objImageList As ImageList
Dim intImageIndex As Integer
Dim strImageKey As String
Dim intParentImageIndex As Integer
Dim strParentImageKey As String
Dim value As ResourceHandle

value = instance.GetImage(objImage, objImageList, intImageIndex, strImageKey, intParentImageIndex, strParentImageKey)
C#
protected ResourceHandle GetImage(
   ResourceHandle objImage,
   ImageList objImageList,
   int intImageIndex,
   string strImageKey,
   int intParentImageIndex,
   string strParentImageKey
)
Managed Extensions for C++
protected: ResourceHandle* GetImage(
   ResourceHandle* objImage,
   ImageList* objImageList,
   int intImageIndex,
   string* strImageKey,
   int intParentImageIndex,
   string* strParentImageKey
)
C++/CLI
protected:
ResourceHandle^ GetImage(
   ResourceHandle^ objImage,
   ImageList^ objImageList,
   int intImageIndex,
   String^ strImageKey,
   int intParentImageIndex,
   String^ strParentImageKey
)

Parameters

objImage
objImageList
The image list.
intImageIndex
Index of the image.
strImageKey
The image key.
intParentImageIndex
strParentImageKey

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Component Class
Component Members


OnDragDrop Method

[image]
Gizmox.WebGUI.Forms
OnDragDrop Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Component Class : OnDragDrop Method

drgevent
A DragEventArgs that contains the event data.
Raises the DragDrop event.

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnDragDrop( _
   ByVal drgevent As DragEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As Component
Dim drgevent As DragEventArgs

instance.OnDragDrop(drgevent)
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnDragDrop(
   DragEventArgs drgevent
)
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnDragDrop(
   DragEventArgs* drgevent
)
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnDragDrop(
   DragEventArgs^ drgevent
)

Parameters

drgevent
A DragEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Component Class
Component Members


OnUnregisterComponents Method

[image]
Gizmox.WebGUI.Forms
OnUnregisterComponents Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Component Class : OnUnregisterComponents Method

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnUnregisterComponents()
Visual Basic (Usage) Copy Code
Dim instance As Component

instance.OnUnregisterComponents()
C#
protected override void OnUnregisterComponents()
Managed Extensions for C++
protected: void OnUnregisterComponents(); override
C++/CLI
protected:
void OnUnregisterComponents(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Component Class
Component Members


RegisterClientAction Method

[image]
Gizmox.WebGUI.Forms
RegisterClientAction Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Component Class : RegisterClientAction Method

Registers the default client invocation.

Overload List

Overload | Description
RegisterClientAction(String,String[]) | Registers the default client invocation.
RegisterClientAction(Component,String,String[]) | Registers the default client invocation.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Component Class
Component Members


RegisterClientAction(String,String[]) Method

[image]
Gizmox.WebGUI.Forms
RegisterClientAction(String,String[]) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Component Class > RegisterClientAction Method : RegisterClientAction(String,String[]) Method

strMethod
The target method.
strArgs
The invocation args.
Registers the default client invocation.

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Overloads Sub RegisterClientAction( _
   ByVal strMethod As String, _
   ByVal ParamArray strArgs() As String _
)
Visual Basic (Usage) Copy Code
Dim instance As Component
Dim strMethod As String
Dim strArgs() As String

instance.RegisterClientAction(strMethod, strArgs)
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public void RegisterClientAction(
   string strMethod,
   params string[] strArgs
)
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: void RegisterClientAction(
   string* strMethod,
   params string*[]* strArgs
)
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
void RegisterClientAction(
   String^ strMethod,
   ... array<String^>^ strArgs
)

Parameters

strMethod
The target method.
strArgs
The invocation args.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Component Class
Component Members
Overload List


RegisterClientAction(Component,String,String[]) Method

[image]
Gizmox.WebGUI.Forms
RegisterClientAction(Component,String,String[]) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Component Class > RegisterClientAction Method : RegisterClientAction(Component,String,String[]) Method

objTarget
The invocation target.
strMethod
The target method.
strArgs
The invocation args.
Registers the default client invocation.

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Overloads Sub RegisterClientAction( _
   ByVal objTarget As Component, _
   ByVal strMethod As String, _
   ByVal ParamArray strArgs() As String _
)
Visual Basic (Usage) Copy Code
Dim instance As Component
Dim objTarget As Component
Dim strMethod As String
Dim strArgs() As String

instance.RegisterClientAction(objTarget, strMethod, strArgs)
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public void RegisterClientAction(
   Component objTarget,
   string strMethod,
   params string[] strArgs
)
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: void RegisterClientAction(
   Component* objTarget,
   string* strMethod,
   params string*[]* strArgs
)
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
void RegisterClientAction(
   Component^ objTarget,
   String^ strMethod,
   ... array<String^>^ strArgs
)

Parameters

objTarget
The invocation target.
strMethod
The target method.
strArgs
The invocation args.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Component Class
Component Members
Overload List


RegisterClientActionWithId Method

[image]
Gizmox.WebGUI.Forms
RegisterClientActionWithId Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Component Class : RegisterClientActionWithId Method

objTarget
The invocation target.
strMethod
The target method.
strArgs
The invocation args.
Registers the default client invocation (Adds component id as the first parameter).

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Sub RegisterClientActionWithId( _
   ByVal objTarget As Component, _
   ByVal strMethod As String, _
   ByVal ParamArray strArgs() As String _
)
Visual Basic (Usage) Copy Code
Dim instance As Component
Dim objTarget As Component
Dim strMethod As String
Dim strArgs() As String

instance.RegisterClientActionWithId(objTarget, strMethod, strArgs)
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public void RegisterClientActionWithId(
   Component objTarget,
   string strMethod,
   params string[] strArgs
)
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: void RegisterClientActionWithId(
   Component* objTarget,
   string* strMethod,
   params string*[]* strArgs
)
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
void RegisterClientActionWithId(
   Component^ objTarget,
   String^ strMethod,
   ... array<String^>^ strArgs
)

Parameters

objTarget
The invocation target.
strMethod
The target method.
strArgs
The invocation args.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Component Class
Component Members


RegisterContextMenu Method

[image]
Gizmox.WebGUI.Forms
RegisterContextMenu Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Component Class : RegisterContextMenu Method

Syntax

Visual Basic (Declaration)
Protected Overrides Sub RegisterContextMenu()
Visual Basic (Usage) Copy Code
Dim instance As Component

instance.RegisterContextMenu()
C#
protected override void RegisterContextMenu()
Managed Extensions for C++
protected: void RegisterContextMenu(); override
C++/CLI
protected:
void RegisterContextMenu(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Component Class
Component Members


RenderClientInvocation Method

[image]
Gizmox.WebGUI.Forms
RenderClientInvocation Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Component Class : RenderClientInvocation Method

objContext
The context.
objWriter
The writer.
Renders the client invocation mapping if needed.

Syntax

Visual Basic (Declaration)
Protected Sub RenderClientInvocation( _
   ByVal objContext As IContext, _
   ByVal objWriter As IAttributeWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As Component
Dim objContext As IContext
Dim objWriter As IAttributeWriter

instance.RenderClientInvocation(objContext, objWriter)
C#
protected void RenderClientInvocation(
   IContext objContext,
   IAttributeWriter objWriter
)
Managed Extensions for C++
protected: void RenderClientInvocation(
   IContext* objContext,
   IAttributeWriter* objWriter
)
C++/CLI
protected:
void RenderClientInvocation(
   IContext^ objContext,
   IAttributeWriter^ objWriter
)

Parameters

objContext
The context.
objWriter
The writer.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Component Class
Component Members


RenderComponentAttributes Method

[image]
Gizmox.WebGUI.Forms
RenderComponentAttributes Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Component Class : RenderComponentAttributes Method

objContext
objWriter
Renders the controls meta attributes

Syntax

Visual Basic (Declaration)
Protected Sub RenderComponentAttributes( _
   ByVal objContext As IContext, _
   ByVal objWriter As IAttributeWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As Component
Dim objContext As IContext
Dim objWriter As IAttributeWriter

instance.RenderComponentAttributes(objContext, objWriter)
C#
protected void RenderComponentAttributes(
   IContext objContext,
   IAttributeWriter objWriter
)
Managed Extensions for C++
protected: void RenderComponentAttributes(
   IContext* objContext,
   IAttributeWriter* objWriter
)
C++/CLI
protected:
void RenderComponentAttributes(
   IContext^ objContext,
   IAttributeWriter^ objWriter
)

Parameters

objContext
objWriter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Component Class
Component Members


RenderDragAndDropAttributes Method

[image]
Gizmox.WebGUI.Forms
RenderDragAndDropAttributes Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Component Class : RenderDragAndDropAttributes Method

objContext
The obj context.
objWriter
The obj writer.
Renders the drag and drop attributes.

Syntax

Visual Basic (Declaration)
Protected Sub RenderDragAndDropAttributes( _
   ByVal objContext As IContext, _
   ByVal objWriter As IAttributeWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As Component
Dim objContext As IContext
Dim objWriter As IAttributeWriter

instance.RenderDragAndDropAttributes(objContext, objWriter)
C#
protected void RenderDragAndDropAttributes(
   IContext objContext,
   IAttributeWriter objWriter
)
Managed Extensions for C++
protected: void RenderDragAndDropAttributes(
   IContext* objContext,
   IAttributeWriter* objWriter
)
C++/CLI
protected:
void RenderDragAndDropAttributes(
   IContext^ objContext,
   IAttributeWriter^ objWriter
)

Parameters

objContext
The obj context.
objWriter
The obj writer.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Component Class
Component Members


RenderExtendedComponentAttributes Method

[image]
Gizmox.WebGUI.Forms
RenderExtendedComponentAttributes Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Component Class : RenderExtendedComponentAttributes Method

objContext
The context.
objWriter
The writer.
Renders the extended component attributes.

Syntax

Visual Basic (Declaration)
Protected Sub RenderExtendedComponentAttributes( _
   ByVal objContext As IContext, _
   ByVal objWriter As IAttributeWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As Component
Dim objContext As IContext
Dim objWriter As IAttributeWriter

instance.RenderExtendedComponentAttributes(objContext, objWriter)
C#
protected void RenderExtendedComponentAttributes(
   IContext objContext,
   IAttributeWriter objWriter
)
Managed Extensions for C++
protected: void RenderExtendedComponentAttributes(
   IContext* objContext,
   IAttributeWriter* objWriter
)
C++/CLI
protected:
void RenderExtendedComponentAttributes(
   IContext^ objContext,
   IAttributeWriter^ objWriter
)

Parameters

objContext
The context.
objWriter
The writer.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Component Class
Component Members


SetImage Method

[image]
Gizmox.WebGUI.Forms
SetImage Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Component Class : SetImage Method

objHandledImage
The obj handled image.
objNewValue
The obj new value.
objImageList
The obj image list.
Sets the image.

Syntax

Visual Basic (Declaration)
Protected Sub SetImage( _
   ByRef objHandledImage As ResourceHandle, _
   ByVal objNewValue As ResourceHandle, _
   ByVal objImageList As ImageList _
)
Visual Basic (Usage) Copy Code
Dim instance As Component
Dim objHandledImage As ResourceHandle
Dim objNewValue As ResourceHandle
Dim objImageList As ImageList

instance.SetImage(objHandledImage, objNewValue, objImageList)
C#
protected void SetImage(
   ref ResourceHandle objHandledImage,
   ResourceHandle objNewValue,
   ImageList objImageList
)
Managed Extensions for C++
protected: void SetImage(
   ref ResourceHandle* objHandledImage,
   ResourceHandle* objNewValue,
   ImageList* objImageList
)
C++/CLI
protected:
void SetImage(
   ResourceHandle^% objHandledImage,
   ResourceHandle^ objNewValue,
   ImageList^ objImageList
)

Parameters

objHandledImage
The obj handled image.
objNewValue
The obj new value.
objImageList
The obj image list.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Component Class
Component Members


SetLoadingMessage Method

[image]
Gizmox.WebGUI.Forms
SetLoadingMessage Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Component Class : SetLoadingMessage Method

strLoadingMessage
Sets the loading message.

Syntax

Visual Basic (Declaration)
Public Sub SetLoadingMessage( _
   ByVal strLoadingMessage As String _
)
Visual Basic (Usage) Copy Code
Dim instance As Component
Dim strLoadingMessage As String

instance.SetLoadingMessage(strLoadingMessage)
C#
public void SetLoadingMessage(
   string strLoadingMessage
)
Managed Extensions for C++
public: void SetLoadingMessage(
   string* strLoadingMessage
)
C++/CLI
public:
void SetLoadingMessage(
   String^ strLoadingMessage
)

Parameters

strLoadingMessage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Component Class
Component Members


ShouldSerializeAllowDrop Method

[image]
Gizmox.WebGUI.Forms
ShouldSerializeAllowDrop Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Component Class : ShouldSerializeAllowDrop Method

Syntax

Visual Basic (Declaration)
Protected Overridable Function ShouldSerializeAllowDrop() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Component
Dim value As Boolean

value = instance.ShouldSerializeAllowDrop()
C#
protected virtual bool ShouldSerializeAllowDrop()
Managed Extensions for C++
protected: virtual bool ShouldSerializeAllowDrop();
C++/CLI
protected:
virtual bool ShouldSerializeAllowDrop();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Component Class
Component Members


ShouldSerializeCustomTemplate Method

[image]
Gizmox.WebGUI.Forms
ShouldSerializeCustomTemplate Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Component Class : ShouldSerializeCustomTemplate Method

Syntax

Visual Basic (Declaration)
Protected Overridable Function ShouldSerializeCustomTemplate() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Component
Dim value As Boolean

value = instance.ShouldSerializeCustomTemplate()
C#
protected virtual bool ShouldSerializeCustomTemplate()
Managed Extensions for C++
protected: virtual bool ShouldSerializeCustomTemplate();
C++/CLI
protected:
virtual bool ShouldSerializeCustomTemplate();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Component Class
Component Members


ShouldSerializeDragTargets Method

[image]
Gizmox.WebGUI.Forms
ShouldSerializeDragTargets Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Component Class : ShouldSerializeDragTargets Method

Syntax

Visual Basic (Declaration)
Protected Overridable Function ShouldSerializeDragTargets() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Component
Dim value As Boolean

value = instance.ShouldSerializeDragTargets()
C#
protected virtual bool ShouldSerializeDragTargets()
Managed Extensions for C++
protected: virtual bool ShouldSerializeDragTargets();
C++/CLI
protected:
virtual bool ShouldSerializeDragTargets();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Component Class
Component Members


UnregisterClientAction Method

[image]
Gizmox.WebGUI.Forms
UnregisterClientAction Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Component Class : UnregisterClientAction Method

Unregisters the default client invocation.

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Sub UnregisterClientAction()
Visual Basic (Usage) Copy Code
Dim instance As Component

instance.UnregisterClientAction()
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public void UnregisterClientAction()
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: void UnregisterClientAction();
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
void UnregisterClientAction();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Component Class
Component Members


UnregisterContextMenu Method

[image]
Gizmox.WebGUI.Forms
UnregisterContextMenu Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Component Class : UnregisterContextMenu Method

Syntax

Visual Basic (Declaration)
Protected Overrides Sub UnregisterContextMenu()
Visual Basic (Usage) Copy Code
Dim instance As Component

instance.UnregisterContextMenu()
C#
protected override void UnregisterContextMenu()
Managed Extensions for C++
protected: void UnregisterContextMenu(); override
C++/CLI
protected:
void UnregisterContextMenu(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Component Class
Component Members


Component Class Properties

[image]
Gizmox.WebGUI.Forms
Component Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : Component Class

For a list of all members of this type, see Component members.

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it
Public Property | ClientAction | Gets or sets the client action.
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContextMenu | Gets or sets the context menu code.
Public Property | CustomTemplate | Gets or sets the custom template.
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control.
Public Property | Form | Gets the owner form.
Public Property | InternalParent | Gets the parent of this component.
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Tag | Gets/Sets User definied tag
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | IsConnected | Overridden.
Protected Property | Session | Overridden. Gets the application object.
Top

See Also

Reference

Component Class
Gizmox.WebGUI.Forms Namespace


AllowDrop Property

[image]
Gizmox.WebGUI.Forms
AllowDrop Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Component Class : AllowDrop Property

Gets or sets whether this control accepts dropping dragged content to it

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("A flag indicating if this control accepts dropping dragged content to it.")>
<SRCategoryAttribute("Behavior")>
<DefaultValueAttribute()>
Public Property AllowDrop As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Component
Dim value As Boolean

instance.AllowDrop = value

value = instance.AllowDrop
C#
[DescriptionAttribute("A flag indicating if this control accepts dropping dragged content to it.")]
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
public bool AllowDrop {get; set;}
Managed Extensions for C++
[DescriptionAttribute("A flag indicating if this control accepts dropping dragged content to it.")]
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
public: __property bool get_AllowDrop();
public: __property void set_AllowDrop(
   bool value
);
C++/CLI
[DescriptionAttribute("A flag indicating if this control accepts dropping dragged content to it.")]
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
public:
property bool AllowDrop {
   bool get();
   void set (boolvalue);
}

Return Value

A flag indicating if this control accepts dropping dragged content to it.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Component Class
Component Members


ClientAction Property

[image]
Gizmox.WebGUI.Forms
ClientAction Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Component Class : ClientAction Property

Gets or sets the client action.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public Property ClientAction As RegisteredClientAction
Visual Basic (Usage) Copy Code
Dim instance As Component
Dim value As RegisteredClientAction

instance.ClientAction = value

value = instance.ClientAction
C#
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public RegisteredClientAction ClientAction {get; set;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property RegisteredClientAction* get_ClientAction();
public: __property void set_ClientAction(
   RegisteredClientAction* value
);
C++/CLI
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
property RegisteredClientAction^ ClientAction {
   RegisteredClientAction^ get();
   void set (RegisteredClientAction^value);
}

Return Value

The client action.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Component Class
Component Members


ContextMenu Property

[image]
Gizmox.WebGUI.Forms
ContextMenu Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Component Class : ContextMenu Property

Gets or sets the context menu code.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<BrowsableAttribute(True)>
Public Overridable Property ContextMenu As ContextMenu
Visual Basic (Usage) Copy Code
Dim instance As Component
Dim value As ContextMenu

instance.ContextMenu = value

value = instance.ContextMenu
C#
[DefaultValueAttribute()]
[BrowsableAttribute(true)]
public virtual ContextMenu ContextMenu {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[BrowsableAttribute(true)]
public: __property virtual ContextMenu* get_ContextMenu();
public: __property virtual void set_ContextMenu(
   ContextMenu* value
);
C++/CLI
[DefaultValueAttribute()]
[BrowsableAttribute(true)]
public:
virtual property ContextMenu^ ContextMenu {
   ContextMenu^ get();
   void set (ContextMenu^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Component Class
Component Members


CustomTemplate Property

[image]
Gizmox.WebGUI.Forms
CustomTemplate Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Component Class : CustomTemplate Property

Gets or sets the custom template.

Syntax

Visual Basic (Declaration)
Public Property CustomTemplate As String
Visual Basic (Usage) Copy Code
Dim instance As Component
Dim value As String

instance.CustomTemplate = value

value = instance.CustomTemplate
C#
public string CustomTemplate {get; set;}
Managed Extensions for C++
public: __property string* get_CustomTemplate();
public: __property void set_CustomTemplate(
   string* value
);
C++/CLI
public:
property String^ CustomTemplate {
   String^ get();
   void set (String^value);
}

Return Value

The custom template.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Component Class
Component Members


DragTargets Property

[image]
Gizmox.WebGUI.Forms
DragTargets Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Component Class : DragTargets Property

Defines the valid drag and drop targets when drag starts from this control.

Syntax

Visual Basic (Declaration)
<EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.Editors.DragTargetsEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")>
Public Overridable Property DragTargets As Component()
Visual Basic (Usage) Copy Code
Dim instance As Component
Dim value() As Component

instance.DragTargets = value

value = instance.DragTargets
C#
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.Editors.DragTargetsEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
public virtual Component[] DragTargets {get; set;}
Managed Extensions for C++
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.Editors.DragTargetsEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
public: __property virtual Component*[]* get_DragTargets();
public: __property virtual void set_DragTargets(
   Component*[]* value
);
C++/CLI
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.Editors.DragTargetsEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
public:
virtual property array<Component^>^ DragTargets {
   array<Component^>^ get();
   void set (Component^array<value>^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Component Class
Component Members


Form Property

[image]
Gizmox.WebGUI.Forms
Form Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Component Class : Form Property

Gets the owner form.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public Overridable ReadOnly Property Form As Form
Visual Basic (Usage) Copy Code
Dim instance As Component
Dim value As Form

value = instance.Form
C#
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public virtual Form Form {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property virtual Form* get_Form();
C++/CLI
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
virtual property Form^ Form {
   Form^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Component Class
Component Members


InternalParent Property

[image]
Gizmox.WebGUI.Forms
InternalParent Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Component Class : InternalParent Property

Gets the parent of this component.

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
Public Overridable Property InternalParent As Component
Visual Basic (Usage) Copy Code
Dim instance As Component
Dim value As Component

instance.InternalParent = value

value = instance.InternalParent
C#
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public virtual Component InternalParent {get; set;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public: __property virtual Component* get_InternalParent();
public: __property virtual void set_InternalParent(
   Component* value
);
C++/CLI
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public:
virtual property Component^ InternalParent {
   Component^ get();
   void set (Component^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Component Class
Component Members


IsConnected Property

[image]
Gizmox.WebGUI.Forms
IsConnected Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Component Class : IsConnected Property

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property IsConnected As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Component
Dim value As Boolean

value = instance.IsConnected
C#
protected override bool IsConnected {get;}
Managed Extensions for C++
protected: __property bool get_IsConnected() override;
C++/CLI
protected:
property bool IsConnected {
   bool get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Component Class
Component Members


Session Property

[image]
Gizmox.WebGUI.Forms
Session Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Component Class : Session Property

Gets the application object.

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property Session As ISession
Visual Basic (Usage) Copy Code
Dim instance As Component
Dim value As ISession

value = instance.Session
C#
protected override ISession Session {get;}
Managed Extensions for C++
protected: __property ISession* get_Session() override;
C++/CLI
protected:
property ISession^ Session {
   ISession^ get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Component Class
Component Members


Tag Property

[image]
Gizmox.WebGUI.Forms
Tag Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Component Class : Tag Property

Gets/Sets User definied tag

Syntax

Visual Basic (Declaration)
<TypeConverterAttribute("System.ComponentModel.StringConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<BindableAttribute(True)>
<DefaultValueAttribute()>
Public Property Tag As Object
Visual Basic (Usage) Copy Code
Dim instance As Component
Dim value As Object

instance.Tag = value

value = instance.Tag
C#
[TypeConverterAttribute("System.ComponentModel.StringConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[BindableAttribute(true)]
[DefaultValueAttribute()]
public object Tag {get; set;}
Managed Extensions for C++
[TypeConverterAttribute("System.ComponentModel.StringConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[BindableAttribute(true)]
[DefaultValueAttribute()]
public: __property Object* get_Tag();
public: __property void set_Tag(
   Object* value
);
C++/CLI
[TypeConverterAttribute("System.ComponentModel.StringConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[BindableAttribute(true)]
[DefaultValueAttribute()]
public:
property Object^ Tag {
   Object^ get();
   void set (Object^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Component Class
Component Members


Component Class Events

[image]
Gizmox.WebGUI.Forms
Component Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : Component Class

For a list of all members of this type, see Component members.

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed.
Public Event | MenuClick | Invokes when a menu item was clicked
Top

See Also

Reference

Component Class
Gizmox.WebGUI.Forms Namespace


DragDrop Event

[image]
Gizmox.WebGUI.Forms
DragDrop Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Component Class : DragDrop Event

Occurs when a drag-and-drop operation is completed.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Drag Drop")>
<SRDescriptionAttribute("Occurs when a drag-and-drop operation is completed.")>
Public Event DragDrop() As DragEventHandler
Visual Basic (Usage) Copy Code
Dim instance As Component
Dim handler As DragEventHandler

AddHandler instance.DragDrop, handler
C#
[SRCategoryAttribute("Drag Drop")]
[SRDescriptionAttribute("Occurs when a drag-and-drop operation is completed.")]
public event DragEventHandler DragDrop()
Managed Extensions for C++
[SRCategoryAttribute("Drag Drop")]
[SRDescriptionAttribute("Occurs when a drag-and-drop operation is completed.")]
public: __event DragEventHandler* DragDrop
C++/CLI
[SRCategoryAttribute("Drag Drop")]
[SRDescriptionAttribute("Occurs when a drag-and-drop operation is completed.")]
public:
event DragEventHandler^ DragDrop

Event Data

The event handler receives an argument of type DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Component Class
Component Members


MenuClick Event

[image]
Gizmox.WebGUI.Forms
MenuClick Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Component Class : MenuClick Event

Invokes when a menu item was clicked

Syntax

Visual Basic (Declaration)
Public Event MenuClick() As MenuEventHandler
Visual Basic (Usage) Copy Code
Dim instance As Component
Dim handler As MenuEventHandler

AddHandler instance.MenuClick, handler
C#
public event MenuEventHandler MenuClick()
Managed Extensions for C++
public: __event MenuEventHandler* MenuClick
C++/CLI
public:
event MenuEventHandler^ MenuClick

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Component Class
Component Members


ContainerControl Class

[image]
Gizmox.WebGUI.Forms
ContainerControl Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ContainerControl Class

Provides focus management functionality for controls that can function as a container for other controls.

Object Model

Syntax

Visual Basic (Declaration)
<ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")>
Public Class ContainerControl
   Inherits ScrollableControl
   Implements IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IContainerControl, IArrangedElement
Visual Basic (Usage) Copy Code
Dim instance As ContainerControl
C#
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
public class ContainerControl : ScrollableControl, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IContainerControl, IArrangedElement
Managed Extensions for C++
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
public __gc class ContainerControl : public ScrollableControl, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IContainerControl, IArrangedElement
C++/CLI
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
public ref class ContainerControl : public ScrollableControl, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IContainerControl, IArrangedElement

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.ScrollableControl
Gizmox.WebGUI.Forms.ContainerControl
Gizmox.WebGUI.Forms.Form
Gizmox.WebGUI.Forms.PropertyGrid
Gizmox.WebGUI.Forms.SplitContainer
Gizmox.WebGUI.Forms.UpDownBase
Gizmox.WebGUI.Forms.UserControl

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

ContainerControl Members
Gizmox.WebGUI.Forms Namespace


ContainerControl Class Members

[image]
Gizmox.WebGUI.Forms
ContainerControl Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : ContainerControl Class

The following tables list the members exposed by ContainerControl.

Public Constructors

 | Name | Description
Public Constructor | ContainerControl Constructor | Creates a new ContainerControl instance.
Top

Public Properties

 | Name | Description
Public Property | ActiveControl | Gets or sets the active control on the container control.
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | Overridden.
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Components |
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Control)
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Protected Property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl)
Top

Public Methods

 | Name | Description
Public Method | Add |
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources.
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | Remove |
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Control)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from ScrollableControl)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Control)
Protected Method | RenderAttributes | Renders the scrollable attribute (Inherited from ScrollableControl)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

ContainerControl Class
Gizmox.WebGUI.Forms Namespace


ContainerControl Constructor

[image]
Gizmox.WebGUI.Forms
ContainerControl Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ContainerControl Class : ContainerControl Constructor

Creates a new ContainerControl instance.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ContainerControl()
C#
public ContainerControl()
Managed Extensions for C++
public: ContainerControl();
C++/CLI
public:
ContainerControl();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ContainerControl Class
ContainerControl Members


ContainerControl Class Methods

[image]
Gizmox.WebGUI.Forms
ContainerControl Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ContainerControl Class

For a list of all members of this type, see ContainerControl members.

Public Methods

 | Name | Description
Public Method | Add |
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources.
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | Remove |
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Control)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from ScrollableControl)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Control)
Protected Method | RenderAttributes | Renders the scrollable attribute (Inherited from ScrollableControl)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

See Also

Reference

ContainerControl Class
Gizmox.WebGUI.Forms Namespace


Add Method

[image]
Gizmox.WebGUI.Forms
Add Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ContainerControl Class : Add Method

objComponent
strName

Syntax

Visual Basic (Declaration)
Public Sub Add( _
   ByVal objComponent As IComponent, _
   ByVal strName As String _
)
Visual Basic (Usage) Copy Code
Dim instance As ContainerControl
Dim objComponent As IComponent
Dim strName As String

instance.Add(objComponent, strName)
C#
public void Add(
   IComponent objComponent,
   string strName
)
Managed Extensions for C++
public: void Add(
   IComponent* objComponent,
   string* strName
)
C++/CLI
public:
void Add(
   IComponent^ objComponent,
   String^ strName
)

Parameters

objComponent
strName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ContainerControl Class
ContainerControl Members


Dispose Method

[image]
Gizmox.WebGUI.Forms
Dispose Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ContainerControl Class : Dispose Method

Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources.

Overload List

Overload | Description
Dispose() |
Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ContainerControl Class
ContainerControl Members


Dispose() Method

[image]
Gizmox.WebGUI.Forms
Dispose() Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ContainerControl Class > Dispose Method : Dispose() Method

Syntax

Visual Basic (Declaration)
Public Overloads Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As ContainerControl

instance.Dispose()
C#
public void Dispose()
Managed Extensions for C++
public: void Dispose();
C++/CLI
public:
void Dispose();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ContainerControl Class
ContainerControl Members
Overload List


Remove Method

[image]
Gizmox.WebGUI.Forms
Remove Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ContainerControl Class : Remove Method

component

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal component As IComponent _
)
Visual Basic (Usage) Copy Code
Dim instance As ContainerControl
Dim component As IComponent

instance.Remove(component)
C#
public void Remove(
   IComponent component
)
Managed Extensions for C++
public: void Remove(
   IComponent* component
)
C++/CLI
public:
void Remove(
   IComponent^ component
)

Parameters

component

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ContainerControl Class
ContainerControl Members


ContainerControl Class Properties

[image]
Gizmox.WebGUI.Forms
ContainerControl Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ContainerControl Class

For a list of all members of this type, see ContainerControl members.

Public Properties

 | Name | Description
Public Property | ActiveControl | Gets or sets the active control on the container control.
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | Overridden.
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Components |
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Control)
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Protected Property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl)
Top

See Also

Reference

ContainerControl Class
Gizmox.WebGUI.Forms Namespace


ActiveControl Property

[image]
Gizmox.WebGUI.Forms
ActiveControl Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ContainerControl Class : ActiveControl Property

Gets or sets the active control on the container control.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<SRDescriptionAttribute("The currently active control.")>
<DesignerSerializationVisibilityAttribute()>
<SRCategoryAttribute("Behavior")>
Public Property ActiveControl As Control
Visual Basic (Usage) Copy Code
Dim instance As ContainerControl
Dim value As Control

instance.ActiveControl = value

value = instance.ActiveControl
C#
[BrowsableAttribute(false)]
[SRDescriptionAttribute("The currently active control.")]
[DesignerSerializationVisibilityAttribute()]
[SRCategoryAttribute("Behavior")]
public Control ActiveControl {get; set;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[SRDescriptionAttribute("The currently active control.")]
[DesignerSerializationVisibilityAttribute()]
[SRCategoryAttribute("Behavior")]
public: __property Control* get_ActiveControl();
public: __property void set_ActiveControl(
   Control* value
);
C++/CLI
[BrowsableAttribute(false)]
[SRDescriptionAttribute("The currently active control.")]
[DesignerSerializationVisibilityAttribute()]
[SRCategoryAttribute("Behavior")]
public:
property Control^ ActiveControl {
   Control^ get();
   void set (Control^value);
}

Exceptions

Exception | Description
ArgumentException | The Control assigned could not be activated.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ContainerControl Class
ContainerControl Members


BindingContext Property

[image]
Gizmox.WebGUI.Forms
BindingContext Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ContainerControl Class : BindingContext Property

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<SRDescriptionAttribute("The binding manager for the container control.  This manages all bindings of child controls to lists.")>
Public Overrides Property BindingContext As BindingContext
Visual Basic (Usage) Copy Code
Dim instance As ContainerControl
Dim value As BindingContext

instance.BindingContext = value

value = instance.BindingContext
C#
[BrowsableAttribute(false)]
[SRDescriptionAttribute("The binding manager for the container control.  This manages all bindings of child controls to lists.")]
public override BindingContext BindingContext {get; set;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[SRDescriptionAttribute("The binding manager for the container control.  This manages all bindings of child controls to lists.")]
public: __property BindingContext* get_BindingContext() override;
public: __property void set_BindingContext(
   BindingContext* value
) override;
C++/CLI
[BrowsableAttribute(false)]
[SRDescriptionAttribute("The binding manager for the container control.  This manages all bindings of child controls to lists.")]
public:
property BindingContext^ BindingContext {
   BindingContext^ get() override;
   void set (BindingContext^value) override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ContainerControl Class
ContainerControl Members


Components Property

[image]
Gizmox.WebGUI.Forms
Components Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ContainerControl Class : Components Property

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property Components As ComponentCollection
Visual Basic (Usage) Copy Code
Dim instance As ContainerControl
Dim value As ComponentCollection

value = instance.Components
C#
[BrowsableAttribute(false)]
public ComponentCollection Components {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property ComponentCollection* get_Components();
C++/CLI
[BrowsableAttribute(false)]
public:
property ComponentCollection^ Components {
   ComponentCollection^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ContainerControl Class
ContainerControl Members


ContextMenu Class

[image]
Gizmox.WebGUI.Forms
ContextMenu Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ContextMenu Class

A button control

Object Model

Syntax

Visual Basic (Declaration)
<ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<ToolboxItemCategoryAttribute("Menus & Toolbars")>
<ClientControllerAttribute()>
<DesignTimeVisibleAttribute(True)>
<DesignTimeControllerAttribute()>
<ToolboxBitmapAttribute()>
Public Class ContextMenu
   Inherits Menu
   Implements IAttributeExtender, IContextMenu, IEventHandler, IGatewayComponent, IMenu, IObservableItem, IRegisteredComponent, IRegisteredComponentContainer
Visual Basic (Usage) Copy Code
Dim instance As ContextMenu
C#
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ToolboxItemCategoryAttribute("Menus & Toolbars")]
[ClientControllerAttribute()]
[DesignTimeVisibleAttribute(true)]
[DesignTimeControllerAttribute()]
[ToolboxBitmapAttribute()]
public class ContextMenu : Menu, IAttributeExtender, IContextMenu, IEventHandler, IGatewayComponent, IMenu, IObservableItem, IRegisteredComponent, IRegisteredComponentContainer
Managed Extensions for C++
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ToolboxItemCategoryAttribute("Menus & Toolbars")]
[ClientControllerAttribute()]
[DesignTimeVisibleAttribute(true)]
[DesignTimeControllerAttribute()]
[ToolboxBitmapAttribute()]
public __gc class ContextMenu : public Menu, IAttributeExtender, IContextMenu, IEventHandler, IGatewayComponent, IMenu, IObservableItem, IRegisteredComponent, IRegisteredComponentContainer
C++/CLI
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ToolboxItemCategoryAttribute("Menus & Toolbars")]
[ClientControllerAttribute()]
[DesignTimeVisibleAttribute(true)]
[DesignTimeControllerAttribute()]
[ToolboxBitmapAttribute()]
public ref class ContextMenu : public Menu, IAttributeExtender, IContextMenu, IEventHandler, IGatewayComponent, IMenu, IObservableItem, IRegisteredComponent, IRegisteredComponentContainer

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Menu
Gizmox.WebGUI.Forms.ContextMenu

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

ContextMenu Members
Gizmox.WebGUI.Forms Namespace


ContextMenu Class Members

[image]
Gizmox.WebGUI.Forms
ContextMenu Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : ContextMenu Class

The following tables list the members exposed by ContextMenu.

Public Constructors

 | Name | Description
Public Constructor | ContextMenu Constructor | Creates a new ContextMenu instance.
Top

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContextMenu | Gets or sets the context menu code. (Inherited from Menu)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | MenuItems | (Inherited from Menu)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded. Disposes the specified component. (Inherited from Component)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | RegisterMenu | (Inherited from Menu)
Public Method | Render | MainMenu render impementation (Inherited from Menu)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | UnregisterMenu | (Inherited from Menu)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Component)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCriticalEvents | (Inherited from Component)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnPopup | Raises the Popup event
Protected Method | OnUnregisterComponents | (Inherited from Menu)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | Popup | Occurs before the shortcut menu is displayed.
Top

See Also

Reference

ContextMenu Class
Gizmox.WebGUI.Forms Namespace


ContextMenu Constructor

[image]
Gizmox.WebGUI.Forms
ContextMenu Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ContextMenu Class : ContextMenu Constructor

Creates a new ContextMenu instance.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ContextMenu()
C#
public ContextMenu()
Managed Extensions for C++
public: ContextMenu();
C++/CLI
public:
ContextMenu();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ContextMenu Class
ContextMenu Members


ContextMenu Class Methods

[image]
Gizmox.WebGUI.Forms
ContextMenu Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ContextMenu Class

For a list of all members of this type, see ContextMenu members.

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded. Disposes the specified component. (Inherited from Component)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | RegisterMenu | (Inherited from Menu)
Public Method | Render | MainMenu render impementation (Inherited from Menu)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | UnregisterMenu | (Inherited from Menu)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Component)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCriticalEvents | (Inherited from Component)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnPopup | Raises the Popup event
Protected Method | OnUnregisterComponents | (Inherited from Menu)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

See Also

Reference

ContextMenu Class
Gizmox.WebGUI.Forms Namespace


OnPopup Method

[image]
Gizmox.WebGUI.Forms
OnPopup Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ContextMenu Class : OnPopup Method

e
An EventArgs that contains the event data.
Raises the Popup event

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnPopup( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ContextMenu
Dim e As EventArgs

instance.OnPopup(e)
C#
protected virtual void OnPopup(
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnPopup(
   EventArgs* e
)
C++/CLI
protected:
virtual void OnPopup(
   EventArgs^ e
)

Parameters

e
An EventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ContextMenu Class
ContextMenu Members


ContextMenu Class Events

[image]
Gizmox.WebGUI.Forms
ContextMenu Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ContextMenu Class

For a list of all members of this type, see ContextMenu members.

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | Popup | Occurs before the shortcut menu is displayed.
Top

See Also

Reference

ContextMenu Class
Gizmox.WebGUI.Forms Namespace


Popup Event

[image]
Gizmox.WebGUI.Forms
Popup Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ContextMenu Class : Popup Event

Occurs before the shortcut menu is displayed.

Syntax

Visual Basic (Declaration)
Public Event Popup() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As ContextMenu
Dim handler As EventHandler

AddHandler instance.Popup, handler
C#
public event EventHandler Popup()
Managed Extensions for C++
public: __event EventHandler* Popup
C++/CLI
public:
event EventHandler^ Popup

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ContextMenu Class
ContextMenu Members


Control Class

[image]
Gizmox.WebGUI.Forms
Control Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : Control Class

The base class for all positioned GUI elements

Object Model

Syntax

Visual Basic (Declaration)
<DefaultEventAttribute("Click")>
<ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")>
<ToolboxItemFilterAttribute("Gizmox.WebGUI.Forms")>
<DesignerSerializerAttribute(SerializerTypeName="Gizmox.WebGUI.Common.Design.Serialization.ControlCodeDomSerializer, Gizmox.WebGUI.Common.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=ea5dfe57c8eb7edd", SerializerBaseTypeName="System.ComponentModel.Design.Serialization.CodeDomSerializer, System.Design, Version=2.0.5000.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
Public Class Control
   Inherits Component
   Implements IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Visual Basic (Usage) Copy Code
Dim instance As Control
C#
[DefaultEventAttribute("Click")]
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
[ToolboxItemFilterAttribute("Gizmox.WebGUI.Forms")]
[DesignerSerializerAttribute(SerializerTypeName="Gizmox.WebGUI.Common.Design.Serialization.ControlCodeDomSerializer, Gizmox.WebGUI.Common.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=ea5dfe57c8eb7edd", SerializerBaseTypeName="System.ComponentModel.Design.Serialization.CodeDomSerializer, System.Design, Version=2.0.5000.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
public class Control : Component, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Managed Extensions for C++
[DefaultEventAttribute("Click")]
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
[ToolboxItemFilterAttribute("Gizmox.WebGUI.Forms")]
[DesignerSerializerAttribute(SerializerTypeName="Gizmox.WebGUI.Common.Design.Serialization.ControlCodeDomSerializer, Gizmox.WebGUI.Common.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=ea5dfe57c8eb7edd", SerializerBaseTypeName="System.ComponentModel.Design.Serialization.CodeDomSerializer, System.Design, Version=2.0.5000.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
public __gc class Control : public Component, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
C++/CLI
[DefaultEventAttribute("Click")]
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
[ToolboxItemFilterAttribute("Gizmox.WebGUI.Forms")]
[DesignerSerializerAttribute(SerializerTypeName="Gizmox.WebGUI.Common.Design.Serialization.ControlCodeDomSerializer, Gizmox.WebGUI.Common.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=ea5dfe57c8eb7edd", SerializerBaseTypeName="System.ComponentModel.Design.Serialization.CodeDomSerializer, System.Design, Version=2.0.5000.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
public ref class Control : public Component, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.Button
Gizmox.WebGUI.Forms.Charts.Axes
Gizmox.WebGUI.Forms.Charts.Chart
Gizmox.WebGUI.Forms.Charts.TitleBase
Gizmox.WebGUI.Forms.CheckBox
Gizmox.WebGUI.Forms.DataGridView
Gizmox.WebGUI.Forms.DateTimePicker
Gizmox.WebGUI.Forms.Editors.FCKEditor
Gizmox.WebGUI.Forms.FrameControl
Gizmox.WebGUI.Forms.GroupBox
Gizmox.WebGUI.Forms.Hosts.AppletBoxBase
Gizmox.WebGUI.Forms.Hosts.ObjectBox
Gizmox.WebGUI.Forms.Label
Gizmox.WebGUI.Forms.ListControl
Gizmox.WebGUI.Forms.ListView
Gizmox.WebGUI.Forms.MainMenu
Gizmox.WebGUI.Forms.MdiClient
Gizmox.WebGUI.Forms.MonthCalendar
Gizmox.WebGUI.Forms.PagingStrip
Gizmox.WebGUI.Forms.PictureBox
Gizmox.WebGUI.Forms.ProgressBar
Gizmox.WebGUI.Forms.RadioButton
Gizmox.WebGUI.Forms.RichTextEditor
Gizmox.WebGUI.Forms.ScheduleBox
Gizmox.WebGUI.Forms.ScrollableControl
Gizmox.WebGUI.Forms.Splitter
Gizmox.WebGUI.Forms.StatusBar
Gizmox.WebGUI.Forms.TabControl
Gizmox.WebGUI.Forms.TableLayoutPanel
Gizmox.WebGUI.Forms.TextBoxBase
Gizmox.WebGUI.Forms.ToolBar
Gizmox.WebGUI.Forms.TrackBar
Gizmox.WebGUI.Forms.TreeView
Gizmox.WebGUI.Forms.XamlBox

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Control Members
Gizmox.WebGUI.Forms Namespace


Control Class Members

[image]
Gizmox.WebGUI.Forms
Control Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : Control Class

The following tables list the members exposed by Control.

Public Constructors

 | Name | Description
Public Constructor | Control Constructor |
Top

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style.
Public Property | BackColor | Gets or sets the background color.
Public Property | BackgroundImage | Gets or sets the background image displayed in the control.
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration.
Public Property | BindingContext |
Public Property | BorderColor | Gets or sets the border color.
Public Property | BorderStyle | Gets or sets the border style.
Public Property | BorderWidth | Gets or sets the width of the border.
Public Property | Bottom | Gets/Sets the bottom position
Public Property | CanFocus | Gets a value indicating whether this instance can focus.
Public Property | CanSelect | Gets a value indicating whether the control can be selected.
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form.
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control.
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
Public Property | Context | Overridden. Gets the context.
Public Property | ContextMenu | Overridden. Gets or sets the shortcut menu associated with the control.
Public Property | Controls | Gets the collection of controls contained within the control.
Public Property | Created | Gets a value indicating whether the control has been created.
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
Public Property | CustomStyle | Gets or sets the control custom style.
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control.
static (Shared in Visual Basic) | DefaultFont | Gets the default font of the control.
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing.
Public Property | Dock | Gets/Sets the controls docking style
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state.
Public Property | Focused | Gets a value indicating whether the control has input focus.
Public Property | Font | Gets or sets the font of the text displayed by the control.
Public Property | ForeColor | Gets or sets the fore color.
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to.
Public Property | HasChildren | Gets a value indicating whether this control has children.
Public Property | HasControls | Gets a value indicating whether this instance has controls.
Public Property | Height | Gets/Sets the height position
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of.
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it.
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter.
Public Property | Left | Gets/Sets the left position
Public Property | Location | Gets or sets the control location.
Public Property | Margin | Gets or sets the space between controls.
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify.
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify.
Public Property | Name | Gets or sets the name associated with this control.
Public Property | Padding | Gets or sets the control padding.
Public Property | Parent | Gets or sets the parent container of this control.
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit.
Public Property | ProductName | Gets the product name of the assembly containing the control.
Public Property | ProductVersion | Gets the version of the assembly containing the control.
Public Property | Right | Gets/Sets the right position
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size.
Public Property | TabIndex | Gets or sets the tab index.
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled.
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text associated with this control.
Public Property | Top | Gets/Sets the top position
Public Property | Visible | Gets or sets the control visability.
Public Property | Width | Gets/Sets the width position
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor |
Protected Property | DefaultBorderColor |
Protected Property | DefaultBorderStyle |
Protected Property | DefaultForeColor |
Protected Property | DefaultMargin |
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
Protected Property | DefaultPadding |
Protected Property | DefaultSize |
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning.
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing |
Protected Property | MetadataTag | Gets the control tag name.
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering.
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property.
Protected Property | ScrollLeftInternal | Sets the scroll left internal.
Protected Property | ScrollTop | Gets or sets the ScrollTop property.
Protected Property | ScrollTopInternal | Sets the scroll top internal.
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order.
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control.
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls.
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources.
Public Method | Focus | Sets focus to this control
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls.
Public Method | GetPreferredSize |
Public Method | Hide | Conceals the control from the user.
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn.
Public Method | Invoke | Overloaded. Invokes the specified method.
Public Method | PerformLayout | WinForm complaint - No use.
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText |
Public Method | ResumeLayout | Overloaded. Resumes the layout.
Public Method | Select | Overloaded. Activates the control.
Public Method | SendToBack |
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user.
Public Method | SuspendLayout | Suspends the layout.
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance |
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Overridden. Fires an event.
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height.
Protected Method | GetCalculatedLeft | Gets the calculated left.
Protected Method | GetCalculatedTop | Gets the calculated top.
Protected Method | GetCalculatedWidth | Gets the calculated width.
Protected Method | GetCommandText |
Protected Method | GetCriticalEvents | Overridden. Gets the critical events.
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore |
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control.
Protected Method | GetTopLevel | Gets the top level.
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event.
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event.
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event.
Protected Method | OnBindingContextChanged |
Protected Method | OnClick | Raises the Control.Click event.
Protected Method | OnControlAdded |
Protected Method | OnControlRemoved |
Protected Method | OnCreateControl | Raises the Control.CreateControl event.
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event.
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event.
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged |
Protected Method | OnEnter | Raises the Control.Enter event.
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event.
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event.
Protected Method | OnGotFocus |
Protected Method | OnHandleCreated | Raises the HandleCreated event.
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event.
Protected Method | OnHelpRequested | Raises the HelpRequested event.
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead).
Protected Method | OnKeyPress | Raises the Control.KeyPress event.
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead).
Protected Method | OnLeave | Raises the Control.Leave event.
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event.
Protected Method | OnLostFocus |
Protected Method | OnMouseClick | Raises the MouseClick event.
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event.
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead).
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead).
Protected Method | OnPaddingChanged | Raises the PaddingChanged event.
Protected Method | OnParentBindingContextChanged |
Protected Method | OnParentChanged | Raises the ParentChanged event.
Protected Method | OnParentVisibleChanged |
Protected Method | OnResize |
Protected Method | OnTextChanged |
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event
Protected Method | OnUnregisterComponents | Overridden.
Protected Method | OnValidated |
Protected Method | OnValidating |
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event.
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | An abstract control method rendering
Protected Method | RenderAttributes | Renders the controls meta attributes
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/
Protected Method | RenderControls | Overloaded. Renders the controls sub tree
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering
Protected Method | ResetCreatedFlag | Resets the created flag.
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value.
Protected Method | SetTopLevel | Sets the top level.
Protected Method | SetVisibleCore | Sets the control to the specified visible state.
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor |
Protected Method | ShouldSerializeBorderColor |
Protected Method | ShouldSerializeBorderStyle |
Protected Method | ShouldSerializeClientSize |
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | Check if the DragTargets property should be serialized in designtime (Inherited from Component)
Protected Method | ShouldSerializeForeColor |
Protected Method | ShouldSerializeSize |
Protected Method | ShouldSerializeTabIndex |
Protected Method | ShouldSerializeText |
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding.
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes.
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes.
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes.
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes.
Public Event | Click | Occurs on clicking the button.
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection.
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection.
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes.
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked.
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design.
Public Event | FontChanged | Occurs when the FontChanged property changes.
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes.
Public Event | GotFocus | Occurs when the control recives focus.
Public Event | HelpRequested | Occurs when the user requests help for a control.
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead).
Public Event | KeyPress | Occurs on key press.
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead).
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design.
Public Event | LocationChanged | Occurs when the Location property value has changed.
Public Event | LostFocus | Occurs when the control loses focus.
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead).
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead).
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes.
Public Event | ParentChanged | Occurs when the Parent property value changes.
Public Event | Resize | Occurs when the control is resized.
Public Event | TextChanged | Occurs when the Text property value changes.
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued).
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes.
Top

See Also

Reference

Control Class
Gizmox.WebGUI.Forms Namespace


Control Constructor

[image]
Gizmox.WebGUI.Forms
Control Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : Control Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Control()
C#
public Control()
Managed Extensions for C++
public: Control();
C++/CLI
public:
Control();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


Control Class Methods

[image]
Gizmox.WebGUI.Forms
Control Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : Control Class

For a list of all members of this type, see Control members.

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order.
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control.
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls.
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources.
Public Method | Focus | Sets focus to this control
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls.
Public Method | GetPreferredSize |
Public Method | Hide | Conceals the control from the user.
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn.
Public Method | Invoke | Overloaded. Invokes the specified method.
Public Method | PerformLayout | WinForm complaint - No use.
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText |
Public Method | ResumeLayout | Overloaded. Resumes the layout.
Public Method | Select | Overloaded. Activates the control.
Public Method | SendToBack |
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user.
Public Method | SuspendLayout | Suspends the layout.
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance |
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Overridden. Fires an event.
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height.
Protected Method | GetCalculatedLeft | Gets the calculated left.
Protected Method | GetCalculatedTop | Gets the calculated top.
Protected Method | GetCalculatedWidth | Gets the calculated width.
Protected Method | GetCommandText |
Protected Method | GetCriticalEvents | Overridden. Gets the critical events.
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore |
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control.
Protected Method | GetTopLevel | Gets the top level.
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event.
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event.
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event.
Protected Method | OnBindingContextChanged |
Protected Method | OnClick | Raises the Control.Click event.
Protected Method | OnControlAdded |
Protected Method | OnControlRemoved |
Protected Method | OnCreateControl | Raises the Control.CreateControl event.
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event.
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event.
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged |
Protected Method | OnEnter | Raises the Control.Enter event.
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event.
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event.
Protected Method | OnGotFocus |
Protected Method | OnHandleCreated | Raises the HandleCreated event.
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event.
Protected Method | OnHelpRequested | Raises the HelpRequested event.
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead).
Protected Method | OnKeyPress | Raises the Control.KeyPress event.
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead).
Protected Method | OnLeave | Raises the Control.Leave event.
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event.
Protected Method | OnLostFocus |
Protected Method | OnMouseClick | Raises the MouseClick event.
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event.
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead).
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead).
Protected Method | OnPaddingChanged | Raises the PaddingChanged event.
Protected Method | OnParentBindingContextChanged |
Protected Method | OnParentChanged | Raises the ParentChanged event.
Protected Method | OnParentVisibleChanged |
Protected Method | OnResize |
Protected Method | OnTextChanged |
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event
Protected Method | OnUnregisterComponents | Overridden.
Protected Method | OnValidated |
Protected Method | OnValidating |
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event.
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | An abstract control method rendering
Protected Method | RenderAttributes | Renders the controls meta attributes
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/
Protected Method | RenderControls | Overloaded. Renders the controls sub tree
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering
Protected Method | ResetCreatedFlag | Resets the created flag.
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value.
Protected Method | SetTopLevel | Sets the top level.
Protected Method | SetVisibleCore | Sets the control to the specified visible state.
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor |
Protected Method | ShouldSerializeBorderColor |
Protected Method | ShouldSerializeBorderStyle |
Protected Method | ShouldSerializeClientSize |
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | Check if the DragTargets property should be serialized in designtime (Inherited from Component)
Protected Method | ShouldSerializeForeColor |
Protected Method | ShouldSerializeSize |
Protected Method | ShouldSerializeTabIndex |
Protected Method | ShouldSerializeText |
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding.
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

See Also

Reference

Control Class
Gizmox.WebGUI.Forms Namespace


BringToFront Method

[image]
Gizmox.WebGUI.Forms
BringToFront Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : BringToFront Method

Brings the control to the front of the z-order.

Syntax

Visual Basic (Declaration)
Public Sub BringToFront()
Visual Basic (Usage) Copy Code
Dim instance As Control

instance.BringToFront()
C#
public void BringToFront()
Managed Extensions for C++
public: void BringToFront();
C++/CLI
public:
void BringToFront();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


Contains Method

[image]
Gizmox.WebGUI.Forms
Contains Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : Contains Method

control
Retrieves a value indicating whether the specified control is a child of the control.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal control As Control _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim control As Control
Dim value As Boolean

value = instance.Contains(control)
C#
public bool Contains(
   Control control
)
Managed Extensions for C++
public: bool Contains(
   Control* control
)
C++/CLI
public:
bool Contains(
   Control^ control
)

Parameters

control

Return Value

true if the specified control is a child of the control; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


CreateControl Method

[image]
Gizmox.WebGUI.Forms
CreateControl Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : CreateControl Method

Forces the creation of the control, including the creation of the handle and any child controls.

Syntax

Visual Basic (Declaration)
Public Sub CreateControl()
Visual Basic (Usage) Copy Code
Dim instance As Control

instance.CreateControl()
C#
public void CreateControl()
Managed Extensions for C++
public: void CreateControl();
C++/CLI
public:
void CreateControl();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


CreateControlsInstance Method

[image]
Gizmox.WebGUI.Forms
CreateControlsInstance Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : CreateControlsInstance Method

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Function CreateControlsInstance() As Control.ControlCollection
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim value As Control.ControlCollection

value = instance.CreateControlsInstance()
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual Control.ControlCollection CreateControlsInstance()
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual Control.ControlCollection* CreateControlsInstance();
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual Control::ControlCollection^ CreateControlsInstance();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


Dispose Method

[image]
Gizmox.WebGUI.Forms
Dispose Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : Dispose Method

Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources.

Overload List

Overload | Description
Dispose(Boolean) | Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources.
Dispose() | (Inherited from ComponentBase)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


Dispose(Boolean) Method

[image]
Gizmox.WebGUI.Forms
Dispose(Boolean) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class > Dispose Method : Dispose(Boolean) Method

disposing
true to release both managed and unmanaged resources; false to release only unmanaged resources.
Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources.

Syntax

Visual Basic (Declaration)
Protected Overloads Overridable Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected virtual void Dispose(
   bool disposing
)
Managed Extensions for C++
protected: virtual void Dispose(
   bool disposing
)
C++/CLI
protected:
virtual void Dispose(
   bool disposing
)

Parameters

disposing
true to release both managed and unmanaged resources; false to release only unmanaged resources.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members
Overload List


FireEvent Method

[image]
Gizmox.WebGUI.Forms
FireEvent Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : FireEvent Method

objEvent
event.
Fires an event.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub FireEvent( _
   ByVal objEvent As IEvent _
)
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim objEvent As IEvent

instance.FireEvent(objEvent)
C#
protected override void FireEvent(
   IEvent objEvent
)
Managed Extensions for C++
protected: void FireEvent(
   IEvent* objEvent
) override
C++/CLI
protected:
void FireEvent(
   IEvent^ objEvent
) override

Parameters

objEvent
event.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


Focus Method

[image]
Gizmox.WebGUI.Forms
Focus Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : Focus Method

Sets focus to this control

Syntax

Visual Basic (Declaration)
Public Function Focus() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim value As Boolean

value = instance.Focus()
C#
public bool Focus()
Managed Extensions for C++
public: bool Focus();
C++/CLI
public:
bool Focus();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


GetCalculatedHeight Method

[image]
Gizmox.WebGUI.Forms
GetCalculatedHeight Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : GetCalculatedHeight Method

blnUseLayoutValues
Gets the calculated height.

Syntax

Visual Basic (Declaration)
Protected Function GetCalculatedHeight( _
   ByVal blnUseLayoutValues As Boolean _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim blnUseLayoutValues As Boolean
Dim value As Integer

value = instance.GetCalculatedHeight(blnUseLayoutValues)
C#
protected int GetCalculatedHeight(
   bool blnUseLayoutValues
)
Managed Extensions for C++
protected: int GetCalculatedHeight(
   bool blnUseLayoutValues
)
C++/CLI
protected:
int GetCalculatedHeight(
   bool blnUseLayoutValues
)

Parameters

blnUseLayoutValues

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


GetCalculatedLeft Method

[image]
Gizmox.WebGUI.Forms
GetCalculatedLeft Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : GetCalculatedLeft Method

blnUseLayoutValues
if set to true use layout values.
Gets the calculated left.

Syntax

Visual Basic (Declaration)
Protected Function GetCalculatedLeft( _
   ByVal blnUseLayoutValues As Boolean _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim blnUseLayoutValues As Boolean
Dim value As Integer

value = instance.GetCalculatedLeft(blnUseLayoutValues)
C#
protected int GetCalculatedLeft(
   bool blnUseLayoutValues
)
Managed Extensions for C++
protected: int GetCalculatedLeft(
   bool blnUseLayoutValues
)
C++/CLI
protected:
int GetCalculatedLeft(
   bool blnUseLayoutValues
)

Parameters

blnUseLayoutValues
if set to true use layout values.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


GetCalculatedTop Method

[image]
Gizmox.WebGUI.Forms
GetCalculatedTop Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : GetCalculatedTop Method

blnUseLayoutValues
if set to true use layout values.
Gets the calculated top.

Syntax

Visual Basic (Declaration)
Protected Function GetCalculatedTop( _
   ByVal blnUseLayoutValues As Boolean _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim blnUseLayoutValues As Boolean
Dim value As Integer

value = instance.GetCalculatedTop(blnUseLayoutValues)
C#
protected int GetCalculatedTop(
   bool blnUseLayoutValues
)
Managed Extensions for C++
protected: int GetCalculatedTop(
   bool blnUseLayoutValues
)
C++/CLI
protected:
int GetCalculatedTop(
   bool blnUseLayoutValues
)

Parameters

blnUseLayoutValues
if set to true use layout values.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


GetCalculatedWidth Method

[image]
Gizmox.WebGUI.Forms
GetCalculatedWidth Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : GetCalculatedWidth Method

blnUseLayoutValues
Gets the calculated width.

Syntax

Visual Basic (Declaration)
Protected Function GetCalculatedWidth( _
   ByVal blnUseLayoutValues As Boolean _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim blnUseLayoutValues As Boolean
Dim value As Integer

value = instance.GetCalculatedWidth(blnUseLayoutValues)
C#
protected int GetCalculatedWidth(
   bool blnUseLayoutValues
)
Managed Extensions for C++
protected: int GetCalculatedWidth(
   bool blnUseLayoutValues
)
C++/CLI
protected:
int GetCalculatedWidth(
   bool blnUseLayoutValues
)

Parameters

blnUseLayoutValues

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


GetCommandText Method

[image]
Gizmox.WebGUI.Forms
GetCommandText Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : GetCommandText Method

strText

Syntax

Visual Basic (Declaration)
Protected Function GetCommandText( _
   ByVal strText As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim strText As String
Dim value As String

value = instance.GetCommandText(strText)
C#
protected string GetCommandText(
   string strText
)
Managed Extensions for C++
protected: string* GetCommandText(
   string* strText
)
C++/CLI
protected:
String^ GetCommandText(
   String^ strText
)

Parameters

strText

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


GetCriticalEvents Method

[image]
Gizmox.WebGUI.Forms
GetCriticalEvents Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : GetCriticalEvents Method

Gets the critical events.

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetCriticalEvents() As EventTypes
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim value As EventTypes

value = instance.GetCriticalEvents()
C#
protected override EventTypes GetCriticalEvents()
Managed Extensions for C++
protected: EventTypes GetCriticalEvents(); override
C++/CLI
protected:
EventTypes GetCriticalEvents(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


GetNextControl Method

[image]
Gizmox.WebGUI.Forms
GetNextControl Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : GetNextControl Method

ctl
The Control to start the search with.
forward
true to search forward in the tab order; false to search backward.
Retrieves the next control forward or back in the tab order of child controls.

Syntax

Visual Basic (Declaration)
Public Function GetNextControl( _
   ByVal ctl As Control, _
   ByVal forward As Boolean _
) As Control
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim ctl As Control
Dim forward As Boolean
Dim value As Control

value = instance.GetNextControl(ctl, forward)
C#
public Control GetNextControl(
   Control ctl,
   bool forward
)
Managed Extensions for C++
public: Control* GetNextControl(
   Control* ctl,
   bool forward
)
C++/CLI
public:
Control^ GetNextControl(
   Control^ ctl,
   bool forward
)

Parameters

ctl
The Control to start the search with.
forward
true to search forward in the tab order; false to search backward.

Return Value

The next Control in the tab order.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


GetPreferredSize Method

[image]
Gizmox.WebGUI.Forms
GetPreferredSize Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : GetPreferredSize Method

proposedSize

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Overridable Function GetPreferredSize( _
   ByVal proposedSize As Size _
) As Size
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim proposedSize As Size
Dim value As Size

value = instance.GetPreferredSize(proposedSize)
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public virtual Size GetPreferredSize(
   Size proposedSize
)
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: virtual Size GetPreferredSize(
   Size proposedSize
)
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
virtual Size GetPreferredSize(
   Size proposedSize
)

Parameters

proposedSize

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


GetPreferredSizeCore Method

[image]
Gizmox.WebGUI.Forms
GetPreferredSizeCore Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : GetPreferredSizeCore Method

proposedSize

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetPreferredSizeCore( _
   ByVal proposedSize As Size _
) As Size
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim proposedSize As Size
Dim value As Size

value = instance.GetPreferredSizeCore(proposedSize)
C#
protected virtual Size GetPreferredSizeCore(
   Size proposedSize
)
Managed Extensions for C++
protected: virtual Size GetPreferredSizeCore(
   Size proposedSize
)
C++/CLI
protected:
virtual Size GetPreferredSizeCore(
   Size proposedSize
)

Parameters

proposedSize

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


GetStyle Method

[image]
Gizmox.WebGUI.Forms
GetStyle Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : GetStyle Method

flag
The ControlStyles bit to return the value from.
Retrieves the value of the specified control style bit for the control.

Syntax

Visual Basic (Declaration)
Protected Function GetStyle( _
   ByVal flag As ControlStyles _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim flag As ControlStyles
Dim value As Boolean

value = instance.GetStyle(flag)
C#
protected bool GetStyle(
   ControlStyles flag
)
Managed Extensions for C++
protected: bool GetStyle(
   ControlStyles flag
)
C++/CLI
protected:
bool GetStyle(
   ControlStyles flag
)

Parameters

flag
The ControlStyles bit to return the value from.

Return Value

true if the specified control style bit is set to true; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


GetTopLevel Method

[image]
Gizmox.WebGUI.Forms
GetTopLevel Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : GetTopLevel Method

Gets the top level.

Syntax

Visual Basic (Declaration)
Protected Function GetTopLevel() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim value As Boolean

value = instance.GetTopLevel()
C#
protected bool GetTopLevel()
Managed Extensions for C++
protected: bool GetTopLevel();
C++/CLI
protected:
bool GetTopLevel();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


Hide Method

[image]
Gizmox.WebGUI.Forms
Hide Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : Hide Method

Conceals the control from the user.

Syntax

Visual Basic (Declaration)
Public Sub Hide()
Visual Basic (Usage) Copy Code
Dim instance As Control

instance.Hide()
C#
public void Hide()
Managed Extensions for C++
public: void Hide();
C++/CLI
public:
void Hide();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


Invalidate Method

[image]
Gizmox.WebGUI.Forms
Invalidate Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : Invalidate Method

Invalidates the entire surface of the control and causes the control to be redrawn.

Overload List

Overload | Description
Invalidate() | Invalidates the entire surface of the control and causes the control to be redrawn.
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


Invalidate() Method

[image]
Gizmox.WebGUI.Forms
Invalidate() Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class > Invalidate Method : Invalidate() Method

Invalidates the entire surface of the control and causes the control to be redrawn.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Invalidate()
Visual Basic (Usage) Copy Code
Dim instance As Control

instance.Invalidate()
C#
public void Invalidate()
Managed Extensions for C++
public: void Invalidate();
C++/CLI
public:
void Invalidate();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members
Overload List


Invalidate(Boolean) Method

[image]
Gizmox.WebGUI.Forms
Invalidate(Boolean) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class > Invalidate Method : Invalidate(Boolean) Method

invalidateChildren
Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Invalidate( _
   ByVal invalidateChildren As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim invalidateChildren As Boolean

instance.Invalidate(invalidateChildren)
C#
public void Invalidate(
   bool invalidateChildren
)
Managed Extensions for C++
public: void Invalidate(
   bool invalidateChildren
)
C++/CLI
public:
void Invalidate(
   bool invalidateChildren
)

Parameters

invalidateChildren

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members
Overload List


Invoke Method

[image]
Gizmox.WebGUI.Forms
Invoke Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : Invoke Method

Invokes the specified method.

Overload List

Overload | Description
Invoke(Delegate) | Invokes the specified method.
Invoke(Delegate,Object[]) | Invokes the specified method.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


Invoke(Delegate) Method

[image]
Gizmox.WebGUI.Forms
Invoke(Delegate) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class > Invoke Method : Invoke(Delegate) Method

objMethod
method.
Invokes the specified method.

Syntax

Visual Basic (Declaration)
Public Overloads Function Invoke( _
   ByVal objMethod As Delegate _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim objMethod As Delegate
Dim value As Object

value = instance.Invoke(objMethod)
C#
public object Invoke(
   Delegate objMethod
)
Managed Extensions for C++
public: Object* Invoke(
   Delegate* objMethod
)
C++/CLI
public:
Object^ Invoke(
   Delegate^ objMethod
)

Parameters

objMethod
method.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members
Overload List


Invoke(Delegate,Object[]) Method

[image]
Gizmox.WebGUI.Forms
Invoke(Delegate,Object[]) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class > Invoke Method : Invoke(Delegate,Object[]) Method

objMethod
method.
objArgs
Arguments.
Invokes the specified method.

Syntax

Visual Basic (Declaration)
Public Overloads Function Invoke( _
   ByVal objMethod As Delegate, _
   ByVal objArgs() As Object _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim objMethod As Delegate
Dim objArgs() As Object
Dim value As Object

value = instance.Invoke(objMethod, objArgs)
C#
public object Invoke(
   Delegate objMethod,
   object[] objArgs
)
Managed Extensions for C++
public: Object* Invoke(
   Delegate* objMethod,
   Object*[]* objArgs
)
C++/CLI
public:
Object^ Invoke(
   Delegate^ objMethod,
   array<Object^>^ objArgs
)

Parameters

objMethod
method.
objArgs
Arguments.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members
Overload List


OnBackColorChanged Method

[image]
Gizmox.WebGUI.Forms
OnBackColorChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : OnBackColorChanged Method

e
An EventArgs that contains the event data.
Raises the BackColorChanged event.

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnBackColorChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim e As EventArgs

instance.OnBackColorChanged(e)
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnBackColorChanged(
   EventArgs e
)
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnBackColorChanged(
   EventArgs* e
)
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnBackColorChanged(
   EventArgs^ e
)

Parameters

e
An EventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


OnBackgroundImageChanged Method

[image]
Gizmox.WebGUI.Forms
OnBackgroundImageChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : OnBackgroundImageChanged Method

e
An EventArgs that contains the event data.
Raises the BackgroundImageChanged event.

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnBackgroundImageChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim e As EventArgs

instance.OnBackgroundImageChanged(e)
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnBackgroundImageChanged(
   EventArgs e
)
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnBackgroundImageChanged(
   EventArgs* e
)
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnBackgroundImageChanged(
   EventArgs^ e
)

Parameters

e
An EventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


OnBackgroundImageLayoutChanged Method

[image]
Gizmox.WebGUI.Forms
OnBackgroundImageLayoutChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : OnBackgroundImageLayoutChanged Method

e
An EventArgs that contains the event data.
Raises the Control.BackgroundImageLayoutChanged event.

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnBackgroundImageLayoutChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim e As EventArgs

instance.OnBackgroundImageLayoutChanged(e)
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnBackgroundImageLayoutChanged(
   EventArgs e
)
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnBackgroundImageLayoutChanged(
   EventArgs* e
)
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnBackgroundImageLayoutChanged(
   EventArgs^ e
)

Parameters

e
An EventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


OnBindingContextChanged Method

[image]
Gizmox.WebGUI.Forms
OnBindingContextChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : OnBindingContextChanged Method

e

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnBindingContextChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim e As EventArgs

instance.OnBindingContextChanged(e)
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnBindingContextChanged(
   EventArgs e
)
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnBindingContextChanged(
   EventArgs* e
)
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnBindingContextChanged(
   EventArgs^ e
)

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


OnClick Method

[image]
Gizmox.WebGUI.Forms
OnClick Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : OnClick Method

objEventArgs

Raises the Control.Click event.

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnClick( _
   ByVal objEventArgs As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim objEventArgs As EventArgs

instance.OnClick(objEventArgs)
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnClick(
   EventArgs objEventArgs
)
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnClick(
   EventArgs* objEventArgs
)
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnClick(
   EventArgs^ objEventArgs
)

Parameters

objEventArgs

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


OnControlAdded Method

[image]
Gizmox.WebGUI.Forms
OnControlAdded Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : OnControlAdded Method

e

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnControlAdded( _
   ByVal e As ControlEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim e As ControlEventArgs

instance.OnControlAdded(e)
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnControlAdded(
   ControlEventArgs e
)
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnControlAdded(
   ControlEventArgs* e
)
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnControlAdded(
   ControlEventArgs^ e
)

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


OnControlRemoved Method

[image]
Gizmox.WebGUI.Forms
OnControlRemoved Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : OnControlRemoved Method

e

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnControlRemoved( _
   ByVal e As ControlEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim e As ControlEventArgs

instance.OnControlRemoved(e)
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnControlRemoved(
   ControlEventArgs e
)
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnControlRemoved(
   ControlEventArgs* e
)
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnControlRemoved(
   ControlEventArgs^ e
)

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


OnCreateControl Method

[image]
Gizmox.WebGUI.Forms
OnCreateControl Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : OnCreateControl Method

Raises the Control.CreateControl event.

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnCreateControl()
Visual Basic (Usage) Copy Code
Dim instance As Control

instance.OnCreateControl()
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnCreateControl()
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnCreateControl();
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnCreateControl();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


OnCursorChanged Method

[image]
Gizmox.WebGUI.Forms
OnCursorChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : OnCursorChanged Method

e
An EventArgs that contains the event data.
Raises the Control.CursorChanged event.

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnCursorChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim e As EventArgs

instance.OnCursorChanged(e)
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnCursorChanged(
   EventArgs e
)
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnCursorChanged(
   EventArgs* e
)
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnCursorChanged(
   EventArgs^ e
)

Parameters

e
An EventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


OnDoubleClick Method

[image]
Gizmox.WebGUI.Forms
OnDoubleClick Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : OnDoubleClick Method

e
An EventArgs that contains the event data.
Raises the Control.DoubleClick event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnDoubleClick( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim e As EventArgs

instance.OnDoubleClick(e)
C#
protected virtual void OnDoubleClick(
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnDoubleClick(
   EventArgs* e
)
C++/CLI
protected:
virtual void OnDoubleClick(
   EventArgs^ e
)

Parameters

e
An EventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


OnEnabledChanged Method

[image]
Gizmox.WebGUI.Forms
OnEnabledChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : OnEnabledChanged Method

e

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnEnabledChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim e As EventArgs

instance.OnEnabledChanged(e)
C#
protected virtual void OnEnabledChanged(
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnEnabledChanged(
   EventArgs* e
)
C++/CLI
protected:
virtual void OnEnabledChanged(
   EventArgs^ e
)

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


OnEnter Method

[image]
Gizmox.WebGUI.Forms
OnEnter Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : OnEnter Method

e
An EventArgs that contains the event data.
Raises the Control.Enter event.

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnEnter( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim e As EventArgs

instance.OnEnter(e)
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnEnter(
   EventArgs e
)
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnEnter(
   EventArgs* e
)
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnEnter(
   EventArgs^ e
)

Parameters

e
An EventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


OnFontChanged Method

[image]
Gizmox.WebGUI.Forms
OnFontChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : OnFontChanged Method

e
An EventArgs that contains the event data.
Raises the DataGridView.FontChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnFontChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim e As EventArgs

instance.OnFontChanged(e)
C#
protected virtual void OnFontChanged(
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnFontChanged(
   EventArgs* e
)
C++/CLI
protected:
virtual void OnFontChanged(
   EventArgs^ e
)

Parameters

e
An EventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


OnForeColorChanged Method

[image]
Gizmox.WebGUI.Forms
OnForeColorChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : OnForeColorChanged Method

e
An EventArgs that contains the event data.
Raises the Control.ForeColorChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnForeColorChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim e As EventArgs

instance.OnForeColorChanged(e)
C#
protected virtual void OnForeColorChanged(
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnForeColorChanged(
   EventArgs* e
)
C++/CLI
protected:
virtual void OnForeColorChanged(
   EventArgs^ e
)

Parameters

e
An EventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


OnGotFocus Method

[image]
Gizmox.WebGUI.Forms
OnGotFocus Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : OnGotFocus Method

e

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnGotFocus( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim e As EventArgs

instance.OnGotFocus(e)
C#
protected virtual void OnGotFocus(
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnGotFocus(
   EventArgs* e
)
C++/CLI
protected:
virtual void OnGotFocus(
   EventArgs^ e
)

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


OnHandleCreated Method

[image]
Gizmox.WebGUI.Forms
OnHandleCreated Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : OnHandleCreated Method

e
An EventArgs that contains the event data.
Raises the HandleCreated event.

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnHandleCreated( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim e As EventArgs

instance.OnHandleCreated(e)
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnHandleCreated(
   EventArgs e
)
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnHandleCreated(
   EventArgs* e
)
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnHandleCreated(
   EventArgs^ e
)

Parameters

e
An EventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


OnHandleDestroyed Method

[image]
Gizmox.WebGUI.Forms
OnHandleDestroyed Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : OnHandleDestroyed Method

e
An EventArgs that contains the event data.
Raises the HandleDestroyed event.

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnHandleDestroyed( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim e As EventArgs

instance.OnHandleDestroyed(e)
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnHandleDestroyed(
   EventArgs e
)
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnHandleDestroyed(
   EventArgs* e
)
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnHandleDestroyed(
   EventArgs^ e
)

Parameters

e
An EventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


OnHelpRequested Method

[image]
Gizmox.WebGUI.Forms
OnHelpRequested Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : OnHelpRequested Method

hevent
A HelpEventArgs that contains the event data.
Raises the HelpRequested event.

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnHelpRequested( _
   ByVal hevent As HelpEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim hevent As HelpEventArgs

instance.OnHelpRequested(hevent)
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnHelpRequested(
   HelpEventArgs hevent
)
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnHelpRequested(
   HelpEventArgs* hevent
)
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnHelpRequested(
   HelpEventArgs^ hevent
)

Parameters

hevent
A HelpEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


OnKeyDown Method

[image]
Gizmox.WebGUI.Forms
OnKeyDown Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : OnKeyDown Method

e
A KeyEventArgs that contains the event data.
Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead).

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<ObsoleteAttribute("Implemented by design as KeyPress (Use KeyPress instead).")>
Protected Overridable Sub OnKeyDown( _
   ByVal e As KeyEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim e As KeyEventArgs

instance.OnKeyDown(e)
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[ObsoleteAttribute("Implemented by design as KeyPress (Use KeyPress instead).")]
protected virtual void OnKeyDown(
   KeyEventArgs e
)
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[ObsoleteAttribute("Implemented by design as KeyPress (Use KeyPress instead).")]
protected: virtual void OnKeyDown(
   KeyEventArgs* e
)
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[ObsoleteAttribute("Implemented by design as KeyPress (Use KeyPress instead).")]
protected:
virtual void OnKeyDown(
   KeyEventArgs^ e
)

Parameters

e
A KeyEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


OnKeyPress Method

[image]
Gizmox.WebGUI.Forms
OnKeyPress Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : OnKeyPress Method

e
A KeyPressEventArgs that contains the event data.
Raises the Control.KeyPress event.

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnKeyPress( _
   ByVal e As KeyPressEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim e As KeyPressEventArgs

instance.OnKeyPress(e)
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnKeyPress(
   KeyPressEventArgs e
)
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnKeyPress(
   KeyPressEventArgs* e
)
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnKeyPress(
   KeyPressEventArgs^ e
)

Parameters

e
A KeyPressEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


OnKeyUp Method

[image]
Gizmox.WebGUI.Forms
OnKeyUp Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : OnKeyUp Method

e
A KeyEventArgs that contains the event data.
Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead).

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("Implemented by design as KeyPress(Use KeyPress instead).")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnKeyUp( _
   ByVal e As KeyEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim e As KeyEventArgs

instance.OnKeyUp(e)
C#
[ObsoleteAttribute("Implemented by design as KeyPress(Use KeyPress instead).")]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnKeyUp(
   KeyEventArgs e
)
Managed Extensions for C++
[ObsoleteAttribute("Implemented by design as KeyPress(Use KeyPress instead).")]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnKeyUp(
   KeyEventArgs* e
)
C++/CLI
[ObsoleteAttribute("Implemented by design as KeyPress(Use KeyPress instead).")]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnKeyUp(
   KeyEventArgs^ e
)

Parameters

e
A KeyEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


OnLeave Method

[image]
Gizmox.WebGUI.Forms
OnLeave Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : OnLeave Method

e
An EventArgs that contains the event data.
Raises the Control.Leave event.

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnLeave( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim e As EventArgs

instance.OnLeave(e)
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnLeave(
   EventArgs e
)
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnLeave(
   EventArgs* e
)
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnLeave(
   EventArgs^ e
)

Parameters

e
An EventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


OnLocationChanged Method

[image]
Gizmox.WebGUI.Forms
OnLocationChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : OnLocationChanged Method

e
An EventArgs that contains the event data.
Raises the Control.LocationChanged event.

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnLocationChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim e As EventArgs

instance.OnLocationChanged(e)
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnLocationChanged(
   EventArgs e
)
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnLocationChanged(
   EventArgs* e
)
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnLocationChanged(
   EventArgs^ e
)

Parameters

e
An EventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


OnLostFocus Method

[image]
Gizmox.WebGUI.Forms
OnLostFocus Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : OnLostFocus Method

e

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnLostFocus( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim e As EventArgs

instance.OnLostFocus(e)
C#
protected virtual void OnLostFocus(
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnLostFocus(
   EventArgs* e
)
C++/CLI
protected:
virtual void OnLostFocus(
   EventArgs^ e
)

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


OnMouseClick Method

[image]
Gizmox.WebGUI.Forms
OnMouseClick Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : OnMouseClick Method

e
An MouseEventArgs that contains the event data.
Raises the MouseClick event.

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnMouseClick( _
   ByVal e As MouseEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim e As MouseEventArgs

instance.OnMouseClick(e)
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnMouseClick(
   MouseEventArgs e
)
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnMouseClick(
   MouseEventArgs* e
)
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnMouseClick(
   MouseEventArgs^ e
)

Parameters

e
An MouseEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


OnMouseDoubleClick Method

[image]
Gizmox.WebGUI.Forms
OnMouseDoubleClick Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : OnMouseDoubleClick Method

e
An MouseEventArgs that contains the event data.
Raises the MouseDoubleClick event.

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnMouseDoubleClick( _
   ByVal e As MouseEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim e As MouseEventArgs

instance.OnMouseDoubleClick(e)
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnMouseDoubleClick(
   MouseEventArgs e
)
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnMouseDoubleClick(
   MouseEventArgs* e
)
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnMouseDoubleClick(
   MouseEventArgs^ e
)

Parameters

e
An MouseEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


OnMouseDown Method

[image]
Gizmox.WebGUI.Forms
OnMouseDown Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : OnMouseDown Method

e
A MouseEventArgs that contains the event data.
Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead).

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("Implemented by design as Click (Use Click instead).")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnMouseDown( _
   ByVal e As MouseEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim e As MouseEventArgs

instance.OnMouseDown(e)
C#
[ObsoleteAttribute("Implemented by design as Click (Use Click instead).")]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnMouseDown(
   MouseEventArgs e
)
Managed Extensions for C++
[ObsoleteAttribute("Implemented by design as Click (Use Click instead).")]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnMouseDown(
   MouseEventArgs* e
)
C++/CLI
[ObsoleteAttribute("Implemented by design as Click (Use Click instead).")]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnMouseDown(
   MouseEventArgs^ e
)

Parameters

e
A MouseEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


OnMouseUp Method

[image]
Gizmox.WebGUI.Forms
OnMouseUp Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : OnMouseUp Method

e
A MouseEventArgs that contains the event data.
Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead).

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<ObsoleteAttribute("Implemented by design as Click (Use Click instead).")>
Protected Overridable Sub OnMouseUp( _
   ByVal e As MouseEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim e As MouseEventArgs

instance.OnMouseUp(e)
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[ObsoleteAttribute("Implemented by design as Click (Use Click instead).")]
protected virtual void OnMouseUp(
   MouseEventArgs e
)
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[ObsoleteAttribute("Implemented by design as Click (Use Click instead).")]
protected: virtual void OnMouseUp(
   MouseEventArgs* e
)
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[ObsoleteAttribute("Implemented by design as Click (Use Click instead).")]
protected:
virtual void OnMouseUp(
   MouseEventArgs^ e
)

Parameters

e
A MouseEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


OnPaddingChanged Method

[image]
Gizmox.WebGUI.Forms
OnPaddingChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : OnPaddingChanged Method

e
A EventArgs that contains the event data.
Raises the PaddingChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnPaddingChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim e As EventArgs

instance.OnPaddingChanged(e)
C#
protected virtual void OnPaddingChanged(
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnPaddingChanged(
   EventArgs* e
)
C++/CLI
protected:
virtual void OnPaddingChanged(
   EventArgs^ e
)

Parameters

e
A EventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


OnParentBindingContextChanged Method

[image]
Gizmox.WebGUI.Forms
OnParentBindingContextChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : OnParentBindingContextChanged Method

e

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnParentBindingContextChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim e As EventArgs

instance.OnParentBindingContextChanged(e)
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnParentBindingContextChanged(
   EventArgs e
)
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnParentBindingContextChanged(
   EventArgs* e
)
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnParentBindingContextChanged(
   EventArgs^ e
)

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


OnParentChanged Method

[image]
Gizmox.WebGUI.Forms
OnParentChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : OnParentChanged Method

e
An EventArgs that contains the event data.
Raises the ParentChanged event.

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnParentChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim e As EventArgs

instance.OnParentChanged(e)
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnParentChanged(
   EventArgs e
)
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnParentChanged(
   EventArgs* e
)
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnParentChanged(
   EventArgs^ e
)

Parameters

e
An EventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


OnParentVisibleChanged Method

[image]
Gizmox.WebGUI.Forms
OnParentVisibleChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : OnParentVisibleChanged Method

e

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnParentVisibleChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim e As EventArgs

instance.OnParentVisibleChanged(e)
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnParentVisibleChanged(
   EventArgs e
)
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnParentVisibleChanged(
   EventArgs* e
)
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnParentVisibleChanged(
   EventArgs^ e
)

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


OnResize Method

[image]
Gizmox.WebGUI.Forms
OnResize Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : OnResize Method

e

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnResize( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim e As EventArgs

instance.OnResize(e)
C#
protected virtual void OnResize(
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnResize(
   EventArgs* e
)
C++/CLI
protected:
virtual void OnResize(
   EventArgs^ e
)

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


OnTextChanged Method

[image]
Gizmox.WebGUI.Forms
OnTextChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : OnTextChanged Method

e

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnTextChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim e As EventArgs

instance.OnTextChanged(e)
C#
protected virtual void OnTextChanged(
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnTextChanged(
   EventArgs* e
)
C++/CLI
protected:
virtual void OnTextChanged(
   EventArgs^ e
)

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


OnTextChangedQueued Method

[image]
Gizmox.WebGUI.Forms
OnTextChangedQueued Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : OnTextChangedQueued Method

e
Raise TextChangedQueued event

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnTextChangedQueued( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim e As EventArgs

instance.OnTextChangedQueued(e)
C#
protected virtual void OnTextChangedQueued(
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnTextChangedQueued(
   EventArgs* e
)
C++/CLI
protected:
virtual void OnTextChangedQueued(
   EventArgs^ e
)

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


OnUnregisterComponents Method

[image]
Gizmox.WebGUI.Forms
OnUnregisterComponents Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : OnUnregisterComponents Method

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnUnregisterComponents()
Visual Basic (Usage) Copy Code
Dim instance As Control

instance.OnUnregisterComponents()
C#
protected override void OnUnregisterComponents()
Managed Extensions for C++
protected: void OnUnregisterComponents(); override
C++/CLI
protected:
void OnUnregisterComponents(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


OnValidated Method

[image]
Gizmox.WebGUI.Forms
OnValidated Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : OnValidated Method

e

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnValidated( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim e As EventArgs

instance.OnValidated(e)
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnValidated(
   EventArgs e
)
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnValidated(
   EventArgs* e
)
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnValidated(
   EventArgs^ e
)

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


OnValidating Method

[image]
Gizmox.WebGUI.Forms
OnValidating Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : OnValidating Method

e

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnValidating( _
   ByVal e As CancelEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim e As CancelEventArgs

instance.OnValidating(e)
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnValidating(
   CancelEventArgs e
)
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnValidating(
   CancelEventArgs* e
)
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnValidating(
   CancelEventArgs^ e
)

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


OnVisibleChanged Method

[image]
Gizmox.WebGUI.Forms
OnVisibleChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : OnVisibleChanged Method

e
An EventArgs that contains the event data.
Raises the Control.VisibleChanged event.

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnVisibleChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim e As EventArgs

instance.OnVisibleChanged(e)
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnVisibleChanged(
   EventArgs e
)
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnVisibleChanged(
   EventArgs* e
)
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnVisibleChanged(
   EventArgs^ e
)

Parameters

e
An EventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


PerformLayout Method

[image]
Gizmox.WebGUI.Forms
PerformLayout Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : PerformLayout Method

WinForm complaint - No use.

Syntax

Visual Basic (Declaration)
Public Sub PerformLayout()
Visual Basic (Usage) Copy Code
Dim instance As Control

instance.PerformLayout()
C#
public void PerformLayout()
Managed Extensions for C++
public: void PerformLayout();
C++/CLI
public:
void PerformLayout();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


Render Method

[image]
Gizmox.WebGUI.Forms
Render Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : Render Method

objContext
objWriter
lngRequestID
An abstract control method rendering

Syntax

Visual Basic (Declaration)
Protected Overridable Sub Render( _
   ByVal objContext As IContext, _
   ByVal objWriter As IResponseWriter, _
   ByVal lngRequestID As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim objContext As IContext
Dim objWriter As IResponseWriter
Dim lngRequestID As Long

instance.Render(objContext, objWriter, lngRequestID)
C#
protected virtual void Render(
   IContext objContext,
   IResponseWriter objWriter,
   long lngRequestID
)
Managed Extensions for C++
protected: virtual void Render(
   IContext* objContext,
   IResponseWriter* objWriter,
   long lngRequestID
)
C++/CLI
protected:
virtual void Render(
   IContext^ objContext,
   IResponseWriter^ objWriter,
   long long lngRequestID
)

Parameters

objContext
objWriter
lngRequestID

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


RenderAttributes Method

[image]
Gizmox.WebGUI.Forms
RenderAttributes Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : RenderAttributes Method

objContext
objWriter
Renders the controls meta attributes

Syntax

Visual Basic (Declaration)
Protected Overridable Sub RenderAttributes( _
   ByVal objContext As IContext, _
   ByVal objWriter As IAttributeWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim objContext As IContext
Dim objWriter As IAttributeWriter

instance.RenderAttributes(objContext, objWriter)
C#
protected virtual void RenderAttributes(
   IContext objContext,
   IAttributeWriter objWriter
)
Managed Extensions for C++
protected: virtual void RenderAttributes(
   IContext* objContext,
   IAttributeWriter* objWriter
)
C++/CLI
protected:
virtual void RenderAttributes(
   IContext^ objContext,
   IAttributeWriter^ objWriter
)

Parameters

objContext
objWriter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


RenderControl Method

[image]
Gizmox.WebGUI.Forms
RenderControl Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : RenderControl Method

objContext
objWriter
lngRequestID
Checks if the current control needs rendering and continues to process sub trree/

Syntax

Visual Basic (Declaration)
Protected Overridable Sub RenderControl( _
   ByVal objContext As IContext, _
   ByVal objWriter As IResponseWriter, _
   ByVal lngRequestID As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim objContext As IContext
Dim objWriter As IResponseWriter
Dim lngRequestID As Long

instance.RenderControl(objContext, objWriter, lngRequestID)
C#
protected virtual void RenderControl(
   IContext objContext,
   IResponseWriter objWriter,
   long lngRequestID
)
Managed Extensions for C++
protected: virtual void RenderControl(
   IContext* objContext,
   IResponseWriter* objWriter,
   long lngRequestID
)
C++/CLI
protected:
virtual void RenderControl(
   IContext^ objContext,
   IResponseWriter^ objWriter,
   long long lngRequestID
)

Parameters

objContext
objWriter
lngRequestID

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


RenderControls Method

[image]
Gizmox.WebGUI.Forms
RenderControls Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : RenderControls Method

Renders the controls sub tree

Overload List

Overload | Description
RenderControls(IContext,IResponseWriter,Int64,Boolean) | Renders the controls sub tree
RenderControls(IContext,IResponseWriter,Int64) | Renders the controls sub tree

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


RenderControls(IContext,IResponseWriter,Int64,Boolean) Method

[image]
Gizmox.WebGUI.Forms
RenderControls(IContext,IResponseWriter,Int64,Boolean) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class > RenderControls Method : RenderControls(IContext,IResponseWriter,Int64,Boolean) Method

objContext
objWriter
lngRequestID
blnRenderOwner
Renders the controls sub tree

Syntax

Visual Basic (Declaration)
Protected Overloads Overridable Sub RenderControls( _
   ByVal objContext As IContext, _
   ByVal objWriter As IResponseWriter, _
   ByVal lngRequestID As Long, _
   ByVal blnRenderOwner As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim objContext As IContext
Dim objWriter As IResponseWriter
Dim lngRequestID As Long
Dim blnRenderOwner As Boolean

instance.RenderControls(objContext, objWriter, lngRequestID, blnRenderOwner)
C#
protected virtual void RenderControls(
   IContext objContext,
   IResponseWriter objWriter,
   long lngRequestID,
   bool blnRenderOwner
)
Managed Extensions for C++
protected: virtual void RenderControls(
   IContext* objContext,
   IResponseWriter* objWriter,
   long lngRequestID,
   bool blnRenderOwner
)
C++/CLI
protected:
virtual void RenderControls(
   IContext^ objContext,
   IResponseWriter^ objWriter,
   long long lngRequestID,
   bool blnRenderOwner
)

Parameters

objContext
objWriter
lngRequestID
blnRenderOwner

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members
Overload List


RenderControls(IContext,IResponseWriter,Int64) Method

[image]
Gizmox.WebGUI.Forms
RenderControls(IContext,IResponseWriter,Int64) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class > RenderControls Method : RenderControls(IContext,IResponseWriter,Int64) Method

objContext
objWriter
lngRequestID
Renders the controls sub tree

Syntax

Visual Basic (Declaration)
Protected Overloads Overridable Sub RenderControls( _
   ByVal objContext As IContext, _
   ByVal objWriter As IResponseWriter, _
   ByVal lngRequestID As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim objContext As IContext
Dim objWriter As IResponseWriter
Dim lngRequestID As Long

instance.RenderControls(objContext, objWriter, lngRequestID)
C#
protected virtual void RenderControls(
   IContext objContext,
   IResponseWriter objWriter,
   long lngRequestID
)
Managed Extensions for C++
protected: virtual void RenderControls(
   IContext* objContext,
   IResponseWriter* objWriter,
   long lngRequestID
)
C++/CLI
protected:
virtual void RenderControls(
   IContext^ objContext,
   IResponseWriter^ objWriter,
   long long lngRequestID
)

Parameters

objContext
objWriter
lngRequestID

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members
Overload List


RenderUpdatedAttributes Method

[image]
Gizmox.WebGUI.Forms
RenderUpdatedAttributes Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : RenderUpdatedAttributes Method

objContext
objWriter
lngRequestID
An abstract param attribute rendering

Syntax

Visual Basic (Declaration)
Protected Overridable Sub RenderUpdatedAttributes( _
   ByVal objContext As IContext, _
   ByVal objWriter As IAttributeWriter, _
   ByVal lngRequestID As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim objContext As IContext
Dim objWriter As IAttributeWriter
Dim lngRequestID As Long

instance.RenderUpdatedAttributes(objContext, objWriter, lngRequestID)
C#
protected virtual void RenderUpdatedAttributes(
   IContext objContext,
   IAttributeWriter objWriter,
   long lngRequestID
)
Managed Extensions for C++
protected: virtual void RenderUpdatedAttributes(
   IContext* objContext,
   IAttributeWriter* objWriter,
   long lngRequestID
)
C++/CLI
protected:
virtual void RenderUpdatedAttributes(
   IContext^ objContext,
   IAttributeWriter^ objWriter,
   long long lngRequestID
)

Parameters

objContext
objWriter
lngRequestID

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


ResetCreatedFlag Method

[image]
Gizmox.WebGUI.Forms
ResetCreatedFlag Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : ResetCreatedFlag Method

Resets the created flag.

Syntax

Visual Basic (Declaration)
Protected Sub ResetCreatedFlag()
Visual Basic (Usage) Copy Code
Dim instance As Control

instance.ResetCreatedFlag()
C#
protected void ResetCreatedFlag()
Managed Extensions for C++
protected: void ResetCreatedFlag();
C++/CLI
protected:
void ResetCreatedFlag();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


ResetText Method

[image]
Gizmox.WebGUI.Forms
ResetText Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : ResetText Method

Syntax

Visual Basic (Declaration)
Public Overridable Sub ResetText()
Visual Basic (Usage) Copy Code
Dim instance As Control

instance.ResetText()
C#
public virtual void ResetText()
Managed Extensions for C++
public: virtual void ResetText();
C++/CLI
public:
virtual void ResetText();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


ResumeLayout Method

[image]
Gizmox.WebGUI.Forms
ResumeLayout Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : ResumeLayout Method

Resumes the layout.

Overload List

Overload | Description
ResumeLayout() | Resumes the layout.
ResumeLayout(Boolean) | Resumes the layout.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


ResumeLayout() Method

[image]
Gizmox.WebGUI.Forms
ResumeLayout() Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class > ResumeLayout Method : ResumeLayout() Method

Resumes the layout.

Syntax

Visual Basic (Declaration)
Public Overloads Sub ResumeLayout()
Visual Basic (Usage) Copy Code
Dim instance As Control

instance.ResumeLayout()
C#
public void ResumeLayout()
Managed Extensions for C++
public: void ResumeLayout();
C++/CLI
public:
void ResumeLayout();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members
Overload List


ResumeLayout(Boolean) Method

[image]
Gizmox.WebGUI.Forms
ResumeLayout(Boolean) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class > ResumeLayout Method : ResumeLayout(Boolean) Method

performLayout
Perform layout.
Resumes the layout.

Syntax

Visual Basic (Declaration)
Public Overloads Sub ResumeLayout( _
   ByVal performLayout As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim performLayout As Boolean

instance.ResumeLayout(performLayout)
C#
public void ResumeLayout(
   bool performLayout
)
Managed Extensions for C++
public: void ResumeLayout(
   bool performLayout
)
C++/CLI
public:
void ResumeLayout(
   bool performLayout
)

Parameters

performLayout
Perform layout.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members
Overload List


Select Method

[image]
Gizmox.WebGUI.Forms
Select Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : Select Method

Activates the control.

Overload List

Overload | Description
Select() | Activates the control.
Select(Boolean,Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


Select() Method

[image]
Gizmox.WebGUI.Forms
Select() Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class > Select Method : Select() Method

Activates the control.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Select()
Visual Basic (Usage) Copy Code
Dim instance As Control

instance.Select()
C#
public void Select()
Managed Extensions for C++
public: void Select();
C++/CLI
public:
void Select();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members
Overload List


Select(Boolean,Boolean) Method

[image]
Gizmox.WebGUI.Forms
Select(Boolean,Boolean) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class > Select Method : Select(Boolean,Boolean) Method

directed
forward
Activates a child control. Optionally specifies the direction in the tab order to select the control from.

Syntax

Visual Basic (Declaration)
Protected Overloads Overridable Sub Select( _
   ByVal directed As Boolean, _
   ByVal forward As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim directed As Boolean
Dim forward As Boolean

instance.Select(directed, forward)
C#
protected virtual void Select(
   bool directed,
   bool forward
)
Managed Extensions for C++
protected: virtual void Select(
   bool directed,
   bool forward
)
C++/CLI
protected:
virtual void Select(
   bool directed,
   bool forward
)

Parameters

directed
forward

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members
Overload List


SendToBack Method

[image]
Gizmox.WebGUI.Forms
SendToBack Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : SendToBack Method

Syntax

Visual Basic (Declaration)
Public Sub SendToBack()
Visual Basic (Usage) Copy Code
Dim instance As Control

instance.SendToBack()
C#
public void SendToBack()
Managed Extensions for C++
public: void SendToBack();
C++/CLI
public:
void SendToBack();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


SetStyle Method

[image]
Gizmox.WebGUI.Forms
SetStyle Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : SetStyle Method

flag
The ControlStyles bit to set.
value
true to apply the specified style to the control; otherwise, false.
Sets the specified style bit to the specified value.

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Sub SetStyle( _
   ByVal flag As ControlStyles, _
   ByVal value As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim flag As ControlStyles
Dim value As Boolean

instance.SetStyle(flag, value)
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected void SetStyle(
   ControlStyles flag,
   bool value
)
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: void SetStyle(
   ControlStyles flag,
   bool value
)
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
void SetStyle(
   ControlStyles flag,
   bool value
)

Parameters

flag
The ControlStyles bit to set.
value
true to apply the specified style to the control; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


SetTopLevel Method

[image]
Gizmox.WebGUI.Forms
SetTopLevel Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : SetTopLevel Method

value
if set to true [value].
Sets the top level.

Syntax

Visual Basic (Declaration)
Protected Sub SetTopLevel( _
   ByVal value As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim value As Boolean

instance.SetTopLevel(value)
C#
protected void SetTopLevel(
   bool value
)
Managed Extensions for C++
protected: void SetTopLevel(
   bool value
)
C++/CLI
protected:
void SetTopLevel(
   bool value
)

Parameters

value
if set to true [value].

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


SetVisibleCore Method

[image]
Gizmox.WebGUI.Forms
SetVisibleCore Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : SetVisibleCore Method

value
true to make the control visible; otherwise, false.
Sets the control to the specified visible state.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub SetVisibleCore( _
   ByVal value As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim value As Boolean

instance.SetVisibleCore(value)
C#
protected virtual void SetVisibleCore(
   bool value
)
Managed Extensions for C++
protected: virtual void SetVisibleCore(
   bool value
)
C++/CLI
protected:
virtual void SetVisibleCore(
   bool value
)

Parameters

value
true to make the control visible; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


ShouldSerializeBackColor Method

[image]
Gizmox.WebGUI.Forms
ShouldSerializeBackColor Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : ShouldSerializeBackColor Method

Syntax

Visual Basic (Declaration)
Protected Overridable Function ShouldSerializeBackColor() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim value As Boolean

value = instance.ShouldSerializeBackColor()
C#
protected virtual bool ShouldSerializeBackColor()
Managed Extensions for C++
protected: virtual bool ShouldSerializeBackColor();
C++/CLI
protected:
virtual bool ShouldSerializeBackColor();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


ShouldSerializeBorderColor Method

[image]
Gizmox.WebGUI.Forms
ShouldSerializeBorderColor Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : ShouldSerializeBorderColor Method

Syntax

Visual Basic (Declaration)
Protected Overridable Function ShouldSerializeBorderColor() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim value As Boolean

value = instance.ShouldSerializeBorderColor()
C#
protected virtual bool ShouldSerializeBorderColor()
Managed Extensions for C++
protected: virtual bool ShouldSerializeBorderColor();
C++/CLI
protected:
virtual bool ShouldSerializeBorderColor();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


ShouldSerializeBorderStyle Method

[image]
Gizmox.WebGUI.Forms
ShouldSerializeBorderStyle Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : ShouldSerializeBorderStyle Method

Syntax

Visual Basic (Declaration)
Protected Overridable Function ShouldSerializeBorderStyle() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim value As Boolean

value = instance.ShouldSerializeBorderStyle()
C#
protected virtual bool ShouldSerializeBorderStyle()
Managed Extensions for C++
protected: virtual bool ShouldSerializeBorderStyle();
C++/CLI
protected:
virtual bool ShouldSerializeBorderStyle();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


ShouldSerializeClientSize Method

[image]
Gizmox.WebGUI.Forms
ShouldSerializeClientSize Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : ShouldSerializeClientSize Method

Syntax

Visual Basic (Declaration)
Protected Overridable Function ShouldSerializeClientSize() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim value As Boolean

value = instance.ShouldSerializeClientSize()
C#
protected virtual bool ShouldSerializeClientSize()
Managed Extensions for C++
protected: virtual bool ShouldSerializeClientSize();
C++/CLI
protected:
virtual bool ShouldSerializeClientSize();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


ShouldSerializeForeColor Method

[image]
Gizmox.WebGUI.Forms
ShouldSerializeForeColor Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : ShouldSerializeForeColor Method

Syntax

Visual Basic (Declaration)
Protected Overridable Function ShouldSerializeForeColor() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim value As Boolean

value = instance.ShouldSerializeForeColor()
C#
protected virtual bool ShouldSerializeForeColor()
Managed Extensions for C++
protected: virtual bool ShouldSerializeForeColor();
C++/CLI
protected:
virtual bool ShouldSerializeForeColor();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


ShouldSerializeSize Method

[image]
Gizmox.WebGUI.Forms
ShouldSerializeSize Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : ShouldSerializeSize Method

Syntax

Visual Basic (Declaration)
Protected Overridable Function ShouldSerializeSize() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim value As Boolean

value = instance.ShouldSerializeSize()
C#
protected virtual bool ShouldSerializeSize()
Managed Extensions for C++
protected: virtual bool ShouldSerializeSize();
C++/CLI
protected:
virtual bool ShouldSerializeSize();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


ShouldSerializeTabIndex Method

[image]
Gizmox.WebGUI.Forms
ShouldSerializeTabIndex Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : ShouldSerializeTabIndex Method

Syntax

Visual Basic (Declaration)
Protected Overridable Function ShouldSerializeTabIndex() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim value As Boolean

value = instance.ShouldSerializeTabIndex()
C#
protected virtual bool ShouldSerializeTabIndex()
Managed Extensions for C++
protected: virtual bool ShouldSerializeTabIndex();
C++/CLI
protected:
virtual bool ShouldSerializeTabIndex();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


ShouldSerializeText Method

[image]
Gizmox.WebGUI.Forms
ShouldSerializeText Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : ShouldSerializeText Method

Syntax

Visual Basic (Declaration)
Protected Overridable Function ShouldSerializeText() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim value As Boolean

value = instance.ShouldSerializeText()
C#
protected virtual bool ShouldSerializeText()
Managed Extensions for C++
protected: virtual bool ShouldSerializeText();
C++/CLI
protected:
virtual bool ShouldSerializeText();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


Show Method

[image]
Gizmox.WebGUI.Forms
Show Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : Show Method

Displays the control to the user.

Syntax

Visual Basic (Declaration)
Public Overridable Sub Show()
Visual Basic (Usage) Copy Code
Dim instance As Control

instance.Show()
C#
public virtual void Show()
Managed Extensions for C++
public: virtual void Show();
C++/CLI
public:
virtual void Show();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


SuspendLayout Method

[image]
Gizmox.WebGUI.Forms
SuspendLayout Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : SuspendLayout Method

Suspends the layout.

Syntax

Visual Basic (Declaration)
Public Sub SuspendLayout()
Visual Basic (Usage) Copy Code
Dim instance As Control

instance.SuspendLayout()
C#
public void SuspendLayout()
Managed Extensions for C++
public: void SuspendLayout();
C++/CLI
public:
void SuspendLayout();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


UpdateDataBinding Method

[image]
Gizmox.WebGUI.Forms
UpdateDataBinding Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : UpdateDataBinding Method

strPropertyName
Updates the received data binding.

Syntax

Visual Basic (Declaration)
Protected Sub UpdateDataBinding( _
   ByVal strPropertyName As String _
)
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim strPropertyName As String

instance.UpdateDataBinding(strPropertyName)
C#
protected void UpdateDataBinding(
   string strPropertyName
)
Managed Extensions for C++
protected: void UpdateDataBinding(
   string* strPropertyName
)
C++/CLI
protected:
void UpdateDataBinding(
   String^ strPropertyName
)

Parameters

strPropertyName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


Control Class Properties

[image]
Gizmox.WebGUI.Forms
Control Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : Control Class

For a list of all members of this type, see Control members.

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style.
Public Property | BackColor | Gets or sets the background color.
Public Property | BackgroundImage | Gets or sets the background image displayed in the control.
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration.
Public Property | BindingContext |
Public Property | BorderColor | Gets or sets the border color.
Public Property | BorderStyle | Gets or sets the border style.
Public Property | BorderWidth | Gets or sets the width of the border.
Public Property | Bottom | Gets/Sets the bottom position
Public Property | CanFocus | Gets a value indicating whether this instance can focus.
Public Property | CanSelect | Gets a value indicating whether the control can be selected.
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form.
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control.
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
Public Property | Context | Overridden. Gets the context.
Public Property | ContextMenu | Overridden. Gets or sets the shortcut menu associated with the control.
Public Property | Controls | Gets the collection of controls contained within the control.
Public Property | Created | Gets a value indicating whether the control has been created.
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
Public Property | CustomStyle | Gets or sets the control custom style.
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control.
static (Shared in Visual Basic) | DefaultFont | Gets the default font of the control.
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing.
Public Property | Dock | Gets/Sets the controls docking style
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state.
Public Property | Focused | Gets a value indicating whether the control has input focus.
Public Property | Font | Gets or sets the font of the text displayed by the control.
Public Property | ForeColor | Gets or sets the fore color.
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to.
Public Property | HasChildren | Gets a value indicating whether this control has children.
Public Property | HasControls | Gets a value indicating whether this instance has controls.
Public Property | Height | Gets/Sets the height position
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of.
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it.
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter.
Public Property | Left | Gets/Sets the left position
Public Property | Location | Gets or sets the control location.
Public Property | Margin | Gets or sets the space between controls.
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify.
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify.
Public Property | Name | Gets or sets the name associated with this control.
Public Property | Padding | Gets or sets the control padding.
Public Property | Parent | Gets or sets the parent container of this control.
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit.
Public Property | ProductName | Gets the product name of the assembly containing the control.
Public Property | ProductVersion | Gets the version of the assembly containing the control.
Public Property | Right | Gets/Sets the right position
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size.
Public Property | TabIndex | Gets or sets the tab index.
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled.
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text associated with this control.
Public Property | Top | Gets/Sets the top position
Public Property | Visible | Gets or sets the control visability.
Public Property | Width | Gets/Sets the width position
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor |
Protected Property | DefaultBorderColor |
Protected Property | DefaultBorderStyle |
Protected Property | DefaultForeColor |
Protected Property | DefaultMargin |
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
Protected Property | DefaultPadding |
Protected Property | DefaultSize |
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning.
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing |
Protected Property | MetadataTag | Gets the control tag name.
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering.
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property.
Protected Property | ScrollLeftInternal | Sets the scroll left internal.
Protected Property | ScrollTop | Gets or sets the ScrollTop property.
Protected Property | ScrollTopInternal | Sets the scroll top internal.
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

See Also

Reference

Control Class
Gizmox.WebGUI.Forms Namespace


Anchor Property

[image]
Gizmox.WebGUI.Forms
Anchor Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : Anchor Property

Gets or sets the anchoring style.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Layout")>
<SRDescriptionAttribute("Defines the edges of the container to which a certain control is bound. When a control is anchored to an edge, the distance between the control's closest edge and the specified edge will remain constant. ")>
Public Property Anchor As AnchorStyles
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim value As AnchorStyles

instance.Anchor = value

value = instance.Anchor
C#
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Defines the edges of the container to which a certain control is bound. When a control is anchored to an edge, the distance between the control's closest edge and the specified edge will remain constant. ")]
public AnchorStyles Anchor {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Defines the edges of the container to which a certain control is bound. When a control is anchored to an edge, the distance between the control's closest edge and the specified edge will remain constant. ")]
public: __property AnchorStyles get_Anchor();
public: __property void set_Anchor(
   AnchorStyles value
);
C++/CLI
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Defines the edges of the container to which a certain control is bound. When a control is anchored to an edge, the distance between the control's closest edge and the specified edge will remain constant. ")]
public:
property AnchorStyles Anchor {
   AnchorStyles get();
   void set (AnchorStylesvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


BackColor Property

[image]
Gizmox.WebGUI.Forms
BackColor Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : BackColor Property

Gets or sets the background color.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Appearance")>
<SRDescriptionAttribute("The background color of the component. ")>
Public Overridable Property BackColor As Color
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim value As Color

instance.BackColor = value

value = instance.BackColor
C#
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("The background color of the component. ")]
public virtual Color BackColor {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("The background color of the component. ")]
public: __property virtual Color get_BackColor();
public: __property virtual void set_BackColor(
   Color value
);
C++/CLI
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("The background color of the component. ")]
public:
virtual property Color BackColor {
   Color get();
   void set (Colorvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


BackgroundImage Property

[image]
Gizmox.WebGUI.Forms
BackgroundImage Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : BackgroundImage Property

Gets or sets the background image displayed in the control.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Appearance")>
<LocalizableAttribute(True)>
<DefaultValueAttribute()>
<SRDescriptionAttribute("The background image used for the control.")>
Public Overridable Property BackgroundImage As ResourceHandle
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim value As ResourceHandle

instance.BackgroundImage = value

value = instance.BackgroundImage
C#
[SRCategoryAttribute("Appearance")]
[LocalizableAttribute(true)]
[DefaultValueAttribute()]
[SRDescriptionAttribute("The background image used for the control.")]
public virtual ResourceHandle BackgroundImage {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Appearance")]
[LocalizableAttribute(true)]
[DefaultValueAttribute()]
[SRDescriptionAttribute("The background image used for the control.")]
public: __property virtual ResourceHandle* get_BackgroundImage();
public: __property virtual void set_BackgroundImage(
   ResourceHandle* value
);
C++/CLI
[SRCategoryAttribute("Appearance")]
[LocalizableAttribute(true)]
[DefaultValueAttribute()]
[SRDescriptionAttribute("The background image used for the control.")]
public:
virtual property ResourceHandle^ BackgroundImage {
   ResourceHandle^ get();
   void set (ResourceHandle^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


BackgroundImageLayout Property

[image]
Gizmox.WebGUI.Forms
BackgroundImageLayout Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : BackgroundImageLayout Property

Gets or sets the background image layout as defined in the ImageLayout enumeration.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("The background image layout used for the component.")>
<DefaultValueAttribute()>
<LocalizableAttribute(True)>
<SRCategoryAttribute("Appearance")>
Public Overridable Property BackgroundImageLayout As ImageLayout
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim value As ImageLayout

instance.BackgroundImageLayout = value

value = instance.BackgroundImageLayout
C#
[SRDescriptionAttribute("The background image layout used for the component.")]
[DefaultValueAttribute()]
[LocalizableAttribute(true)]
[SRCategoryAttribute("Appearance")]
public virtual ImageLayout BackgroundImageLayout {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("The background image layout used for the component.")]
[DefaultValueAttribute()]
[LocalizableAttribute(true)]
[SRCategoryAttribute("Appearance")]
public: __property virtual ImageLayout get_BackgroundImageLayout();
public: __property virtual void set_BackgroundImageLayout(
   ImageLayout value
);
C++/CLI
[SRDescriptionAttribute("The background image layout used for the component.")]
[DefaultValueAttribute()]
[LocalizableAttribute(true)]
[SRCategoryAttribute("Appearance")]
public:
virtual property ImageLayout BackgroundImageLayout {
   ImageLayout get();
   void set (ImageLayoutvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


BindingContext Property

[image]
Gizmox.WebGUI.Forms
BindingContext Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : BindingContext Property

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<SRDescriptionAttribute("The binding context for the control.")>
<DesignerSerializationVisibilityAttribute()>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Overridable Property BindingContext As BindingContext
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim value As BindingContext

instance.BindingContext = value

value = instance.BindingContext
C#
[BrowsableAttribute(false)]
[SRDescriptionAttribute("The binding context for the control.")]
[DesignerSerializationVisibilityAttribute()]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public virtual BindingContext BindingContext {get; set;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[SRDescriptionAttribute("The binding context for the control.")]
[DesignerSerializationVisibilityAttribute()]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: __property virtual BindingContext* get_BindingContext();
public: __property virtual void set_BindingContext(
   BindingContext* value
);
C++/CLI
[BrowsableAttribute(false)]
[SRDescriptionAttribute("The binding context for the control.")]
[DesignerSerializationVisibilityAttribute()]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
virtual property BindingContext^ BindingContext {
   BindingContext^ get();
   void set (BindingContext^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


BorderColor Property

[image]
Gizmox.WebGUI.Forms
BorderColor Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : BorderColor Property

Gets or sets the border color.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Appearance")>
<SRDescriptionAttribute("ControlBorderColorDescr")>
Public Property BorderColor As Color
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim value As Color

instance.BorderColor = value

value = instance.BorderColor
C#
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("ControlBorderColorDescr")]
public Color BorderColor {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("ControlBorderColorDescr")]
public: __property Color get_BorderColor();
public: __property void set_BorderColor(
   Color value
);
C++/CLI
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("ControlBorderColorDescr")]
public:
property Color BorderColor {
   Color get();
   void set (Colorvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


BorderStyle Property

[image]
Gizmox.WebGUI.Forms
BorderStyle Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : BorderStyle Property

Gets or sets the border style.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("ControlBorderStyleDescr")>
<SRCategoryAttribute("Appearance")>
Public Overridable Property BorderStyle As BorderStyle
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim value As BorderStyle

instance.BorderStyle = value

value = instance.BorderStyle
C#
[SRDescriptionAttribute("ControlBorderStyleDescr")]
[SRCategoryAttribute("Appearance")]
public virtual BorderStyle BorderStyle {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("ControlBorderStyleDescr")]
[SRCategoryAttribute("Appearance")]
public: __property virtual BorderStyle get_BorderStyle();
public: __property virtual void set_BorderStyle(
   BorderStyle value
);
C++/CLI
[SRDescriptionAttribute("ControlBorderStyleDescr")]
[SRCategoryAttribute("Appearance")]
public:
virtual property BorderStyle BorderStyle {
   BorderStyle get();
   void set (BorderStylevalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


BorderWidth Property

[image]
Gizmox.WebGUI.Forms
BorderWidth Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : BorderWidth Property

Gets or sets the width of the border.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Appearance")>
<SRDescriptionAttribute("ControlBorderWidthDescr")>
<DefaultValueAttribute()>
Public Property BorderWidth As Integer
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim value As Integer

instance.BorderWidth = value

value = instance.BorderWidth
C#
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("ControlBorderWidthDescr")]
[DefaultValueAttribute()]
public int BorderWidth {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("ControlBorderWidthDescr")]
[DefaultValueAttribute()]
public: __property int get_BorderWidth();
public: __property void set_BorderWidth(
   int value
);
C++/CLI
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("ControlBorderWidthDescr")]
[DefaultValueAttribute()]
public:
property int BorderWidth {
   int get();
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


Bottom Property

[image]
Gizmox.WebGUI.Forms
Bottom Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : Bottom Property

Gets/Sets the bottom position

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
Public ReadOnly Property Bottom As Integer
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim value As Integer

value = instance.Bottom
C#
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public int Bottom {get;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public: __property int get_Bottom();
C++/CLI
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public:
property int Bottom {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


CanFocus Property

[image]
Gizmox.WebGUI.Forms
CanFocus Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : CanFocus Property

Gets a value indicating whether this instance can focus.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public Overridable ReadOnly Property CanFocus As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim value As Boolean

value = instance.CanFocus
C#
[BrowsableAttribute(false)]
public virtual bool CanFocus {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property virtual bool get_CanFocus();
C++/CLI
[BrowsableAttribute(false)]
public:
virtual property bool CanFocus {
   bool get();
}

Return Value

true if this instance can focus; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


CanSelect Property

[image]
Gizmox.WebGUI.Forms
CanSelect Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : CanSelect Property

Gets a value indicating whether the control can be selected.

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
<SRCategoryAttribute("Focus")>
<SRDescriptionAttribute("Checks if this control can be selected.")>
Public ReadOnly Property CanSelect As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim value As Boolean

value = instance.CanSelect
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
[SRCategoryAttribute("Focus")]
[SRDescriptionAttribute("Checks if this control can be selected.")]
public bool CanSelect {get;}
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
[SRCategoryAttribute("Focus")]
[SRDescriptionAttribute("Checks if this control can be selected.")]
public: __property bool get_CanSelect();
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
[SRCategoryAttribute("Focus")]
[SRDescriptionAttribute("Checks if this control can be selected.")]
public:
property bool CanSelect {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


ClientSize Property

[image]
Gizmox.WebGUI.Forms
ClientSize Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : ClientSize Property

Gets or sets the client size of the form.

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
Public Property ClientSize As Size
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim value As Size

instance.ClientSize = value

value = instance.ClientSize
C#
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public Size ClientSize {get; set;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public: __property Size get_ClientSize();
public: __property void set_ClientSize(
   Size value
);
C++/CLI
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public:
property Size ClientSize {
   Size get();
   void set (Sizevalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


CompanyName Property

[image]
Gizmox.WebGUI.Forms
CompanyName Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : CompanyName Property

Gets the name of the company or creator of the application containing the control.

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
<SRDescriptionAttribute("Retrieves the company name for this control.")>
Public ReadOnly Property CompanyName As String
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim value As String

value = instance.CompanyName
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
[SRDescriptionAttribute("Retrieves the company name for this control.")]
public string CompanyName {get;}
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
[SRDescriptionAttribute("Retrieves the company name for this control.")]
public: __property string* get_CompanyName();
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
[SRDescriptionAttribute("Retrieves the company name for this control.")]
public:
property String^ CompanyName {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


ContainsFocus Property

[image]
Gizmox.WebGUI.Forms
ContainsFocus Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : ContainsFocus Property

Gets a value indicating whether the control, or one of its child controls, currently has the input focus.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Determines if this control or one if its children currently has the focus.")>
<DesignerSerializationVisibilityAttribute()>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<BrowsableAttribute(False)>
Public ReadOnly Property ContainsFocus As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim value As Boolean

value = instance.ContainsFocus
C#
[SRDescriptionAttribute("Determines if this control or one if its children currently has the focus.")]
[DesignerSerializationVisibilityAttribute()]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[BrowsableAttribute(false)]
public bool ContainsFocus {get;}
Managed Extensions for C++
[SRDescriptionAttribute("Determines if this control or one if its children currently has the focus.")]
[DesignerSerializationVisibilityAttribute()]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[BrowsableAttribute(false)]
public: __property bool get_ContainsFocus();
C++/CLI
[SRDescriptionAttribute("Determines if this control or one if its children currently has the focus.")]
[DesignerSerializationVisibilityAttribute()]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[BrowsableAttribute(false)]
public:
property bool ContainsFocus {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


Context Property

[image]
Gizmox.WebGUI.Forms
Context Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : Context Property

Gets the context.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Context As IContext
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim value As IContext

value = instance.Context
C#
public override IContext Context {get;}
Managed Extensions for C++
public: __property IContext* get_Context() override;
C++/CLI
public:
property IContext^ Context {
   IContext^ get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


ContextMenu Property

[image]
Gizmox.WebGUI.Forms
ContextMenu Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : ContextMenu Property

Gets or sets the shortcut menu associated with the control.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Behavior")>
<BrowsableAttribute(True)>
<DefaultValueAttribute()>
<SRDescriptionAttribute("The shortcut menu to display when the user right-clicks the control.")>
Public Overrides Property ContextMenu As ContextMenu
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim value As ContextMenu

instance.ContextMenu = value

value = instance.ContextMenu
C#
[SRCategoryAttribute("Behavior")]
[BrowsableAttribute(true)]
[DefaultValueAttribute()]
[SRDescriptionAttribute("The shortcut menu to display when the user right-clicks the control.")]
public override ContextMenu ContextMenu {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Behavior")]
[BrowsableAttribute(true)]
[DefaultValueAttribute()]
[SRDescriptionAttribute("The shortcut menu to display when the user right-clicks the control.")]
public: __property ContextMenu* get_ContextMenu() override;
public: __property void set_ContextMenu(
   ContextMenu* value
) override;
C++/CLI
[SRCategoryAttribute("Behavior")]
[BrowsableAttribute(true)]
[DefaultValueAttribute()]
[SRDescriptionAttribute("The shortcut menu to display when the user right-clicks the control.")]
public:
property ContextMenu^ ContextMenu {
   ContextMenu^ get() override;
   void set (ContextMenu^value) override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


Controls Property

[image]
Gizmox.WebGUI.Forms
Controls Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : Controls Property

Gets the collection of controls contained within the control.

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
Public ReadOnly Property Controls As Control.ControlCollection
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim value As Control.ControlCollection

value = instance.Controls
C#
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public Control.ControlCollection Controls {get;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public: __property Control.ControlCollection* get_Controls();
C++/CLI
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public:
property Control::ControlCollection^ Controls {
   Control::ControlCollection^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


Created Property

[image]
Gizmox.WebGUI.Forms
Created Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : Created Property

Gets a value indicating whether the control has been created.

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
<SRDescriptionAttribute("Determines if the control has been fully created.")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public ReadOnly Property Created As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim value As Boolean

value = instance.Created
C#
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
[SRDescriptionAttribute("Determines if the control has been fully created.")]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public bool Created {get;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
[SRDescriptionAttribute("Determines if the control has been fully created.")]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: __property bool get_Created();
C++/CLI
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
[SRDescriptionAttribute("Determines if the control has been fully created.")]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
property bool Created {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


Cursor Property

[image]
Gizmox.WebGUI.Forms
Cursor Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : Cursor Property

Gets or sets the cursor that is displayed when the mouse pointer is over the control.

Syntax

Visual Basic (Declaration)
<AmbientValueAttribute()>
<SRCategoryAttribute("Appearance")>
<SRDescriptionAttribute("The cursor that appears when the pointer moves over the control.")>
Public Overridable Property Cursor As Cursor
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim value As Cursor

instance.Cursor = value

value = instance.Cursor
C#
[AmbientValueAttribute()]
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("The cursor that appears when the pointer moves over the control.")]
public virtual Cursor Cursor {get; set;}
Managed Extensions for C++
[AmbientValueAttribute()]
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("The cursor that appears when the pointer moves over the control.")]
public: __property virtual Cursor* get_Cursor();
public: __property virtual void set_Cursor(
   Cursor* value
);
C++/CLI
[AmbientValueAttribute()]
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("The cursor that appears when the pointer moves over the control.")]
public:
virtual property Cursor^ Cursor {
   Cursor^ get();
   void set (Cursor^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


CustomStyle Property

[image]
Gizmox.WebGUI.Forms
CustomStyle Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : CustomStyle Property

Gets or sets the control custom style.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<SRCategoryAttribute("Appearance")>
<SRDescriptionAttribute("ControlCustomStyleDescr")>
Public Property CustomStyle As String
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim value As String

instance.CustomStyle = value

value = instance.CustomStyle
C#
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("ControlCustomStyleDescr")]
public string CustomStyle {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("ControlCustomStyleDescr")]
public: __property string* get_CustomStyle();
public: __property void set_CustomStyle(
   string* value
);
C++/CLI
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("ControlCustomStyleDescr")]
public:
property String^ CustomStyle {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


DataBindings Property

[image]
Gizmox.WebGUI.Forms
DataBindings Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : DataBindings Property

Gets the data bindings for the control.

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
<SRDescriptionAttribute("The data bindings for the control.")>
<SRCategoryAttribute("Data")>
<ParenthesizePropertyNameAttribute(True)>
<RefreshPropertiesAttribute()>
Public ReadOnly Property DataBindings As ControlBindingsCollection
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim value As ControlBindingsCollection

value = instance.DataBindings
C#
[DesignerSerializationVisibilityAttribute()]
[SRDescriptionAttribute("The data bindings for the control.")]
[SRCategoryAttribute("Data")]
[ParenthesizePropertyNameAttribute(true)]
[RefreshPropertiesAttribute()]
public ControlBindingsCollection DataBindings {get;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
[SRDescriptionAttribute("The data bindings for the control.")]
[SRCategoryAttribute("Data")]
[ParenthesizePropertyNameAttribute(true)]
[RefreshPropertiesAttribute()]
public: __property ControlBindingsCollection* get_DataBindings();
C++/CLI
[DesignerSerializationVisibilityAttribute()]
[SRDescriptionAttribute("The data bindings for the control.")]
[SRCategoryAttribute("Data")]
[ParenthesizePropertyNameAttribute(true)]
[RefreshPropertiesAttribute()]
public:
property ControlBindingsCollection^ DataBindings {
   ControlBindingsCollection^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


DefaultBackColor Property

[image]
Gizmox.WebGUI.Forms
DefaultBackColor Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : DefaultBackColor Property

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property DefaultBackColor As Color
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim value As Color

value = instance.DefaultBackColor
C#
protected virtual Color DefaultBackColor {get;}
Managed Extensions for C++
protected: __property virtual Color get_DefaultBackColor();
C++/CLI
protected:
virtual property Color DefaultBackColor {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


DefaultBorderColor Property

[image]
Gizmox.WebGUI.Forms
DefaultBorderColor Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : DefaultBorderColor Property

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property DefaultBorderColor As Color
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim value As Color

value = instance.DefaultBorderColor
C#
protected virtual Color DefaultBorderColor {get;}
Managed Extensions for C++
protected: __property virtual Color get_DefaultBorderColor();
C++/CLI
protected:
virtual property Color DefaultBorderColor {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


DefaultBorderStyle Property

[image]
Gizmox.WebGUI.Forms
DefaultBorderStyle Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : DefaultBorderStyle Property

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property DefaultBorderStyle As BorderStyle
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim value As BorderStyle

value = instance.DefaultBorderStyle
C#
protected virtual BorderStyle DefaultBorderStyle {get;}
Managed Extensions for C++
protected: __property virtual BorderStyle get_DefaultBorderStyle();
C++/CLI
protected:
virtual property BorderStyle DefaultBorderStyle {
   BorderStyle get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


DefaultFont Property

[image]
Gizmox.WebGUI.Forms
DefaultFont Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : DefaultFont Property

Gets the default font of the control.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property DefaultFont As Font
Visual Basic (Usage) Copy Code
Dim value As Font

value = Control.DefaultFont
C#
public static Font DefaultFont {get;}
Managed Extensions for C++
public: __property static Font* get_DefaultFont();
C++/CLI
public:
static property Font^ DefaultFont {
   Font^ get();
}

Exceptions

Exception | Description
ArgumentException | The default font or the regional alternative fonts are not installed on the client computer.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


DefaultForeColor Property

[image]
Gizmox.WebGUI.Forms
DefaultForeColor Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : DefaultForeColor Property

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property DefaultForeColor As Color
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim value As Color

value = instance.DefaultForeColor
C#
protected virtual Color DefaultForeColor {get;}
Managed Extensions for C++
protected: __property virtual Color get_DefaultForeColor();
C++/CLI
protected:
virtual property Color DefaultForeColor {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


DefaultMargin Property

[image]
Gizmox.WebGUI.Forms
DefaultMargin Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : DefaultMargin Property

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property DefaultMargin As Padding
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim value As Padding

value = instance.DefaultMargin
C#
protected virtual Padding DefaultMargin {get;}
Managed Extensions for C++
protected: __property virtual Padding get_DefaultMargin();
C++/CLI
protected:
virtual property Padding DefaultMargin {
   Padding get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


DefaultMaximumSize Property

[image]
Gizmox.WebGUI.Forms
DefaultMaximumSize Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : DefaultMaximumSize Property

Gets the length and height, in pixels, that is specified as the default maximum size of a control.

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property DefaultMaximumSize As Size
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim value As Size

value = instance.DefaultMaximumSize
C#
protected virtual Size DefaultMaximumSize {get;}
Managed Extensions for C++
protected: __property virtual Size get_DefaultMaximumSize();
C++/CLI
protected:
virtual property Size DefaultMaximumSize {
   Size get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


DefaultMinimumSize Property

[image]
Gizmox.WebGUI.Forms
DefaultMinimumSize Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : DefaultMinimumSize Property

Gets the length and height, in pixels, that is specified as the default minimum size of a control.

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property DefaultMinimumSize As Size
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim value As Size

value = instance.DefaultMinimumSize
C#
protected virtual Size DefaultMinimumSize {get;}
Managed Extensions for C++
protected: __property virtual Size get_DefaultMinimumSize();
C++/CLI
protected:
virtual property Size DefaultMinimumSize {
   Size get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


DefaultPadding Property

[image]
Gizmox.WebGUI.Forms
DefaultPadding Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : DefaultPadding Property

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property DefaultPadding As Padding
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim value As Padding

value = instance.DefaultPadding
C#
protected virtual Padding DefaultPadding {get;}
Managed Extensions for C++
protected: __property virtual Padding get_DefaultPadding();
C++/CLI
protected:
virtual property Padding DefaultPadding {
   Padding get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


DefaultSize Property

[image]
Gizmox.WebGUI.Forms
DefaultSize Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : DefaultSize Property

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property DefaultSize As Size
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim value As Size

value = instance.DefaultSize
C#
protected virtual Size DefaultSize {get;}
Managed Extensions for C++
protected: __property virtual Size get_DefaultSize();
C++/CLI
protected:
virtual property Size DefaultSize {
   Size get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


Disposing Property

[image]
Gizmox.WebGUI.Forms
Disposing Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : Disposing Property

Gets a value indicating whether the base Control class is in the process of disposing.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Determines whether this control is in the process of being disposed. ")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
Public ReadOnly Property Disposing As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim value As Boolean

value = instance.Disposing
C#
[SRDescriptionAttribute("Determines whether this control is in the process of being disposed. ")]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public bool Disposing {get;}
Managed Extensions for C++
[SRDescriptionAttribute("Determines whether this control is in the process of being disposed. ")]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public: __property bool get_Disposing();
C++/CLI
[SRDescriptionAttribute("Determines whether this control is in the process of being disposed. ")]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public:
property bool Disposing {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


Dock Property

[image]
Gizmox.WebGUI.Forms
Dock Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : Dock Property

Gets/Sets the controls docking style

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Layout")>
<SRDescriptionAttribute("Defines which borders of the control are bound to the container. ")>
<DefaultValueAttribute()>
Public Overridable Property Dock As DockStyle
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim value As DockStyle

instance.Dock = value

value = instance.Dock
C#
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Defines which borders of the control are bound to the container. ")]
[DefaultValueAttribute()]
public virtual DockStyle Dock {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Defines which borders of the control are bound to the container. ")]
[DefaultValueAttribute()]
public: __property virtual DockStyle get_Dock();
public: __property virtual void set_Dock(
   DockStyle value
);
C++/CLI
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Defines which borders of the control are bound to the container. ")]
[DefaultValueAttribute()]
public:
virtual property DockStyle Dock {
   DockStyle get();
   void set (DockStylevalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


Enabled Property

[image]
Gizmox.WebGUI.Forms
Enabled Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : Enabled Property

Gets or sets the control enabled state.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Behavior")>
<DefaultValueAttribute()>
<SRDescriptionAttribute("Indicates whether the control is enabled.")>
Public Property Enabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim value As Boolean

instance.Enabled = value

value = instance.Enabled
C#
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Indicates whether the control is enabled.")]
public bool Enabled {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Indicates whether the control is enabled.")]
public: __property bool get_Enabled();
public: __property void set_Enabled(
   bool value
);
C++/CLI
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Indicates whether the control is enabled.")]
public:
property bool Enabled {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


Focused Property

[image]
Gizmox.WebGUI.Forms
Focused Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : Focused Property

Gets a value indicating whether the control has input focus.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<SRDescriptionAttribute("Determines if this control has focus.")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<DesignerSerializationVisibilityAttribute()>
Public Overridable ReadOnly Property Focused As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim value As Boolean

value = instance.Focused
C#
[BrowsableAttribute(false)]
[SRDescriptionAttribute("Determines if this control has focus.")]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[DesignerSerializationVisibilityAttribute()]
public virtual bool Focused {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[SRDescriptionAttribute("Determines if this control has focus.")]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[DesignerSerializationVisibilityAttribute()]
public: __property virtual bool get_Focused();
C++/CLI
[BrowsableAttribute(false)]
[SRDescriptionAttribute("Determines if this control has focus.")]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[DesignerSerializationVisibilityAttribute()]
public:
virtual property bool Focused {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


Font Property

[image]
Gizmox.WebGUI.Forms
Font Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : Font Property

Gets or sets the font of the text displayed by the control.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Appearance")>
<SRDescriptionAttribute("The font used to display text in the control.")>
Public Overridable Property Font As Font
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim value As Font

instance.Font = value

value = instance.Font
C#
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("The font used to display text in the control.")]
public virtual Font Font {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("The font used to display text in the control.")]
public: __property virtual Font* get_Font();
public: __property virtual void set_Font(
   Font* value
);
C++/CLI
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("The font used to display text in the control.")]
public:
virtual property Font^ Font {
   Font^ get();
   void set (Font^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


ForeColor Property

[image]
Gizmox.WebGUI.Forms
ForeColor Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : ForeColor Property

Gets or sets the fore color.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Appearance")>
<SRDescriptionAttribute("The foreground color of this component, which is used to display text.")>
Public Overridable Property ForeColor As Color
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim value As Color

instance.ForeColor = value

value = instance.ForeColor
C#
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("The foreground color of this component, which is used to display text.")]
public virtual Color ForeColor {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("The foreground color of this component, which is used to display text.")]
public: __property virtual Color get_ForeColor();
public: __property virtual void set_ForeColor(
   Color value
);
C++/CLI
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("The foreground color of this component, which is used to display text.")]
public:
virtual property Color ForeColor {
   Color get();
   void set (Colorvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


Handle Property

[image]
Gizmox.WebGUI.Forms
Handle Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : Handle Property

Gets the handle that the control is bound to.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<SRDescriptionAttribute("The native handle for this control.")>
<DesignerSerializationVisibilityAttribute()>
Public ReadOnly Property Handle As IntPtr
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim value As IntPtr

value = instance.Handle
C#
[BrowsableAttribute(false)]
[SRDescriptionAttribute("The native handle for this control.")]
[DesignerSerializationVisibilityAttribute()]
public IntPtr Handle {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[SRDescriptionAttribute("The native handle for this control.")]
[DesignerSerializationVisibilityAttribute()]
public: __property IntPtr get_Handle();
C++/CLI
[BrowsableAttribute(false)]
[SRDescriptionAttribute("The native handle for this control.")]
[DesignerSerializationVisibilityAttribute()]
public:
property IntPtr Handle {
   IntPtr get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


HasChildren Property

[image]
Gizmox.WebGUI.Forms
HasChildren Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : HasChildren Property

Gets a value indicating whether this control has children.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property HasChildren As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim value As Boolean

value = instance.HasChildren
C#
[BrowsableAttribute(false)]
public bool HasChildren {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property bool get_HasChildren();
C++/CLI
[BrowsableAttribute(false)]
public:
property bool HasChildren {
   bool get();
}

Return Value

true if this control has children; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


HasControls Property

[image]
Gizmox.WebGUI.Forms
HasControls Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : HasControls Property

Gets a value indicating whether this instance has controls.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public Overridable ReadOnly Property HasControls As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim value As Boolean

value = instance.HasControls
C#
[BrowsableAttribute(false)]
public virtual bool HasControls {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property virtual bool get_HasControls();
C++/CLI
[BrowsableAttribute(false)]
public:
virtual property bool HasControls {
   bool get();
}

Return Value

true if this instance has controls; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


HasPositioning Property

[image]
Gizmox.WebGUI.Forms
HasPositioning Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : HasPositioning Property

Gets or sets a value indicating whether this instance has positioning.

Syntax

Visual Basic (Declaration)
Protected Property HasPositioning As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim value As Boolean

instance.HasPositioning = value

value = instance.HasPositioning
C#
protected bool HasPositioning {get; set;}
Managed Extensions for C++
protected: __property bool get_HasPositioning();
protected: __property void set_HasPositioning(
   bool value
);
C++/CLI
protected:
property bool HasPositioning {
   bool get();
   void set (boolvalue);
}

Return Value

true if this instance has positioning; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


Height Property

[image]
Gizmox.WebGUI.Forms
Height Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : Height Property

Gets/Sets the height position

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public Property Height As Integer
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim value As Integer

instance.Height = value

value = instance.Height
C#
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public int Height {get; set;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property int get_Height();
public: __property void set_Height(
   int value
);
C++/CLI
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
property int Height {
   int get();
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


IsDelayedDrawing Property

[image]
Gizmox.WebGUI.Forms
IsDelayedDrawing Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : IsDelayedDrawing Property

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property IsDelayedDrawing As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim value As Boolean

value = instance.IsDelayedDrawing
C#
protected virtual bool IsDelayedDrawing {get;}
Managed Extensions for C++
protected: __property virtual bool get_IsDelayedDrawing();
C++/CLI
protected:
virtual property bool IsDelayedDrawing {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


IsDisposed Property

[image]
Gizmox.WebGUI.Forms
IsDisposed Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : IsDisposed Property

Gets a value indicating whether the control has been disposed of.

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<BrowsableAttribute(False)>
<SRDescriptionAttribute("Determines if this control has been disposed.")>
Public ReadOnly Property IsDisposed As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim value As Boolean

value = instance.IsDisposed
C#
[DesignerSerializationVisibilityAttribute()]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[BrowsableAttribute(false)]
[SRDescriptionAttribute("Determines if this control has been disposed.")]
public bool IsDisposed {get;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[BrowsableAttribute(false)]
[SRDescriptionAttribute("Determines if this control has been disposed.")]
public: __property bool get_IsDisposed();
C++/CLI
[DesignerSerializationVisibilityAttribute()]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[BrowsableAttribute(false)]
[SRDescriptionAttribute("Determines if this control has been disposed.")]
public:
property bool IsDisposed {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


IsHandleCreated Property

[image]
Gizmox.WebGUI.Forms
IsHandleCreated Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : IsHandleCreated Property

Gets a value indicating whether the control has a handle associated with it.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<SRDescriptionAttribute("Indicates whether the control has a handle associated with it.")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<DesignerSerializationVisibilityAttribute()>
Public ReadOnly Property IsHandleCreated As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim value As Boolean

value = instance.IsHandleCreated
C#
[BrowsableAttribute(false)]
[SRDescriptionAttribute("Indicates whether the control has a handle associated with it.")]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[DesignerSerializationVisibilityAttribute()]
public bool IsHandleCreated {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[SRDescriptionAttribute("Indicates whether the control has a handle associated with it.")]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[DesignerSerializationVisibilityAttribute()]
public: __property bool get_IsHandleCreated();
C++/CLI
[BrowsableAttribute(false)]
[SRDescriptionAttribute("Indicates whether the control has a handle associated with it.")]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[DesignerSerializationVisibilityAttribute()]
public:
property bool IsHandleCreated {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


KeyFilter Property

[image]
Gizmox.WebGUI.Forms
KeyFilter Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : KeyFilter Property

Gets or sets the key down filter.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("The key down filter.")>
<SRCategoryAttribute("Behavior")>
<DefaultValueAttribute()>
Public Property KeyFilter As KeyFilter
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim value As KeyFilter

instance.KeyFilter = value

value = instance.KeyFilter
C#
[DescriptionAttribute("The key down filter.")]
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
public KeyFilter KeyFilter {get; set;}
Managed Extensions for C++
[DescriptionAttribute("The key down filter.")]
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
public: __property KeyFilter get_KeyFilter();
public: __property void set_KeyFilter(
   KeyFilter value
);
C++/CLI
[DescriptionAttribute("The key down filter.")]
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
public:
property KeyFilter KeyFilter {
   KeyFilter get();
   void set (KeyFiltervalue);
}

Return Value

The key down filter.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


Left Property

[image]
Gizmox.WebGUI.Forms
Left Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : Left Property

Gets/Sets the left position

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public Property Left As Integer
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim value As Integer

instance.Left = value

value = instance.Left
C#
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public int Left {get; set;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property int get_Left();
public: __property void set_Left(
   int value
);
C++/CLI
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
property int Left {
   int get();
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


Location Property

[image]
Gizmox.WebGUI.Forms
Location Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : Location Property

Gets or sets the control location.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("The coordinates of the upper-left corner of the control relative to the upper-left corner of its container.")>
<SRCategoryAttribute("Layout")>
Public Property Location As Point
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim value As Point

instance.Location = value

value = instance.Location
C#
[SRDescriptionAttribute("The coordinates of the upper-left corner of the control relative to the upper-left corner of its container.")]
[SRCategoryAttribute("Layout")]
public Point Location {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("The coordinates of the upper-left corner of the control relative to the upper-left corner of its container.")]
[SRCategoryAttribute("Layout")]
public: __property Point get_Location();
public: __property void set_Location(
   Point value
);
C++/CLI
[SRDescriptionAttribute("The coordinates of the upper-left corner of the control relative to the upper-left corner of its container.")]
[SRCategoryAttribute("Layout")]
public:
property Point Location {
   Point get();
   void set (Pointvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


Margin Property

[image]
Gizmox.WebGUI.Forms
Margin Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : Margin Property

Gets or sets the space between controls.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Layout")>
<SRDescriptionAttribute("Specifies space between this control and another control's margin.")>
<LocalizableAttribute(True)>
Public Property Margin As Padding
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim value As Padding

instance.Margin = value

value = instance.Margin
C#
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Specifies space between this control and another control's margin.")]
[LocalizableAttribute(true)]
public Padding Margin {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Specifies space between this control and another control's margin.")]
[LocalizableAttribute(true)]
public: __property Padding get_Margin();
public: __property void set_Margin(
   Padding value
);
C++/CLI
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Specifies space between this control and another control's margin.")]
[LocalizableAttribute(true)]
public:
property Padding Margin {
   Padding get();
   void set (Paddingvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


MaximumSize Property

[image]
Gizmox.WebGUI.Forms
MaximumSize Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : MaximumSize Property

Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify.

Syntax

Visual Basic (Declaration)
<AmbientValueAttribute()>
<SRDescriptionAttribute("Specifies the maximum size of the control.")>
<SRCategoryAttribute("Layout")>
Public Overridable Property MaximumSize As Size
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim value As Size

instance.MaximumSize = value

value = instance.MaximumSize
C#
[AmbientValueAttribute()]
[SRDescriptionAttribute("Specifies the maximum size of the control.")]
[SRCategoryAttribute("Layout")]
public virtual Size MaximumSize {get; set;}
Managed Extensions for C++
[AmbientValueAttribute()]
[SRDescriptionAttribute("Specifies the maximum size of the control.")]
[SRCategoryAttribute("Layout")]
public: __property virtual Size get_MaximumSize();
public: __property virtual void set_MaximumSize(
   Size value
);
C++/CLI
[AmbientValueAttribute()]
[SRDescriptionAttribute("Specifies the maximum size of the control.")]
[SRCategoryAttribute("Layout")]
public:
virtual property Size MaximumSize {
   Size get();
   void set (Sizevalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


MetadataTag Property

[image]
Gizmox.WebGUI.Forms
MetadataTag Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : MetadataTag Property

Gets the control tag name.

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property MetadataTag As String
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim value As String

value = instance.MetadataTag
C#
protected string MetadataTag {get;}
Managed Extensions for C++
protected: __property string* get_MetadataTag();
C++/CLI
protected:
property String^ MetadataTag {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


MinimumSize Property

[image]
Gizmox.WebGUI.Forms
MinimumSize Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : MinimumSize Property

Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Specifies the minimum size of the control.")>
<SRCategoryAttribute("Layout")>
Public Overridable Property MinimumSize As Size
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim value As Size

instance.MinimumSize = value

value = instance.MinimumSize
C#
[SRDescriptionAttribute("Specifies the minimum size of the control.")]
[SRCategoryAttribute("Layout")]
public virtual Size MinimumSize {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Specifies the minimum size of the control.")]
[SRCategoryAttribute("Layout")]
public: __property virtual Size get_MinimumSize();
public: __property virtual void set_MinimumSize(
   Size value
);
C++/CLI
[SRDescriptionAttribute("Specifies the minimum size of the control.")]
[SRCategoryAttribute("Layout")]
public:
virtual property Size MinimumSize {
   Size get();
   void set (Sizevalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


Name Property

[image]
Gizmox.WebGUI.Forms
Name Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : Name Property

Gets or sets the name associated with this control.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<BrowsableAttribute(False)>
Public Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim value As String

instance.Name = value

value = instance.Name
C#
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
public string Name {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
public: __property string* get_Name();
public: __property void set_Name(
   string* value
);
C++/CLI
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
public:
property String^ Name {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


Padding Property

[image]
Gizmox.WebGUI.Forms
Padding Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : Padding Property

Gets or sets the control padding.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
Public Overridable Property Padding As Padding
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim value As Padding

instance.Padding = value

value = instance.Padding
C#
[DefaultValueAttribute()]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public virtual Padding Padding {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public: __property virtual Padding get_Padding();
public: __property virtual void set_Padding(
   Padding value
);
C++/CLI
[DefaultValueAttribute()]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public:
virtual property Padding Padding {
   Padding get();
   void set (Paddingvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


Parent Property

[image]
Gizmox.WebGUI.Forms
Parent Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : Parent Property

Gets or sets the parent container of this control.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public Property Parent As Control
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim value As Control

instance.Parent = value

value = instance.Parent
C#
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public Control Parent {get; set;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property Control* get_Parent();
public: __property void set_Parent(
   Control* value
);
C++/CLI
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
property Control^ Parent {
   Control^ get();
   void set (Control^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


PreferredSize Property

[image]
Gizmox.WebGUI.Forms
PreferredSize Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : PreferredSize Property

Not Implemented Property.

Gets the size of a rectangular area into which the control can fit.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property PreferredSize As Size
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim value As Size

value = instance.PreferredSize
C#
[BrowsableAttribute(false)]
public Size PreferredSize {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property Size get_PreferredSize();
C++/CLI
[BrowsableAttribute(false)]
public:
property Size PreferredSize {
   Size get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


ProductName Property

[image]
Gizmox.WebGUI.Forms
ProductName Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : ProductName Property

Gets the product name of the assembly containing the control.

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<SRDescriptionAttribute("Retrieves the name of the product associated with this component.")>
<BrowsableAttribute(False)>
Public ReadOnly Property ProductName As String
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim value As String

value = instance.ProductName
C#
[DesignerSerializationVisibilityAttribute()]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRDescriptionAttribute("Retrieves the name of the product associated with this component.")]
[BrowsableAttribute(false)]
public string ProductName {get;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRDescriptionAttribute("Retrieves the name of the product associated with this component.")]
[BrowsableAttribute(false)]
public: __property string* get_ProductName();
C++/CLI
[DesignerSerializationVisibilityAttribute()]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRDescriptionAttribute("Retrieves the name of the product associated with this component.")]
[BrowsableAttribute(false)]
public:
property String^ ProductName {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


ProductVersion Property

[image]
Gizmox.WebGUI.Forms
ProductVersion Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : ProductVersion Property

Gets the version of the assembly containing the control.

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
<SRDescriptionAttribute("Retrieves the version of the product associated with this component.")>
Public ReadOnly Property ProductVersion As String
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim value As String

value = instance.ProductVersion
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
[SRDescriptionAttribute("Retrieves the version of the product associated with this component.")]
public string ProductVersion {get;}
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
[SRDescriptionAttribute("Retrieves the version of the product associated with this component.")]
public: __property string* get_ProductVersion();
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
[SRDescriptionAttribute("Retrieves the version of the product associated with this component.")]
public:
property String^ ProductVersion {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


ReverseControls Property

[image]
Gizmox.WebGUI.Forms
ReverseControls Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : ReverseControls Property

Gets a value indicating whether to reverse control rendering.

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property ReverseControls As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim value As Boolean

value = instance.ReverseControls
C#
protected virtual bool ReverseControls {get;}
Managed Extensions for C++
protected: __property virtual bool get_ReverseControls();
C++/CLI
protected:
virtual property bool ReverseControls {
   bool get();
}

Return Value

true if to reverse control rendering; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


Right Property

[image]
Gizmox.WebGUI.Forms
Right Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : Right Property

Gets/Sets the right position

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
Public ReadOnly Property Right As Integer
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim value As Integer

value = instance.Right
C#
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public int Right {get;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public: __property int get_Right();
C++/CLI
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public:
property int Right {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


RightToLeft Property

[image]
Gizmox.WebGUI.Forms
RightToLeft Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : RightToLeft Property

Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Indicates whether the component should draw right-to-left for RTL languages.")>
<LocalizableAttribute(True)>
<DefaultValueAttribute()>
<SRCategoryAttribute("Appearance")>
Public Overridable Property RightToLeft As RightToLeft
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim value As RightToLeft

instance.RightToLeft = value

value = instance.RightToLeft
C#
[SRDescriptionAttribute("Indicates whether the component should draw right-to-left for RTL languages.")]
[LocalizableAttribute(true)]
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
public virtual RightToLeft RightToLeft {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Indicates whether the component should draw right-to-left for RTL languages.")]
[LocalizableAttribute(true)]
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
public: __property virtual RightToLeft get_RightToLeft();
public: __property virtual void set_RightToLeft(
   RightToLeft value
);
C++/CLI
[SRDescriptionAttribute("Indicates whether the component should draw right-to-left for RTL languages.")]
[LocalizableAttribute(true)]
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
public:
virtual property RightToLeft RightToLeft {
   RightToLeft get();
   void set (RightToLeftvalue);
}

Exceptions

Exception | Description
InvalidEnumArgumentException | The assigned value is not one of the RightToLeft values.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


ScrollLeft Property

[image]
Gizmox.WebGUI.Forms
ScrollLeft Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : ScrollLeft Property

Gets or sets the ScrollLeft property.

Syntax

Visual Basic (Declaration)
Protected Property ScrollLeft As Integer
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim value As Integer

instance.ScrollLeft = value

value = instance.ScrollLeft
C#
protected int ScrollLeft {get; set;}
Managed Extensions for C++
protected: __property int get_ScrollLeft();
protected: __property void set_ScrollLeft(
   int value
);
C++/CLI
protected:
property int ScrollLeft {
   int get();
   void set (intvalue);
}

Return Value

The ScrollLeft property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


ScrollLeftInternal Property

[image]
Gizmox.WebGUI.Forms
ScrollLeftInternal Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : ScrollLeftInternal Property

Sets the scroll left internal.

Syntax

Visual Basic (Declaration)
Protected WriteOnly Property ScrollLeftInternal As Integer
Visual Basic (Usage) Copy Code
Dim instance As Control

instance.ScrollLeftInternal = value
C#
protected int ScrollLeftInternal {set;}
Managed Extensions for C++
protected: __property void set_ScrollLeftInternal(
   int value
);
C++/CLI
protected:
property int ScrollLeftInternal {
   void set (intvalue);
}

Return Value

The scroll left internal.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


ScrollTop Property

[image]
Gizmox.WebGUI.Forms
ScrollTop Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : ScrollTop Property

Gets or sets the ScrollTop property.

Syntax

Visual Basic (Declaration)
Protected Property ScrollTop As Integer
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim value As Integer

instance.ScrollTop = value

value = instance.ScrollTop
C#
protected int ScrollTop {get; set;}
Managed Extensions for C++
protected: __property int get_ScrollTop();
protected: __property void set_ScrollTop(
   int value
);
C++/CLI
protected:
property int ScrollTop {
   int get();
   void set (intvalue);
}

Return Value

The ScrollTop property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


ScrollTopInternal Property

[image]
Gizmox.WebGUI.Forms
ScrollTopInternal Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : ScrollTopInternal Property

Sets the scroll top internal.

Syntax

Visual Basic (Declaration)
Protected WriteOnly Property ScrollTopInternal As Integer
Visual Basic (Usage) Copy Code
Dim instance As Control

instance.ScrollTopInternal = value
C#
protected int ScrollTopInternal {set;}
Managed Extensions for C++
protected: __property void set_ScrollTopInternal(
   int value
);
C++/CLI
protected:
property int ScrollTopInternal {
   void set (intvalue);
}

Return Value

The scroll top internal.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


Size Property

[image]
Gizmox.WebGUI.Forms
Size Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : Size Property

Gets or sets the size.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("The size of the control in pixels.")>
<SRCategoryAttribute("Layout")>
Public Property Size As Size
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim value As Size

instance.Size = value

value = instance.Size
C#
[SRDescriptionAttribute("The size of the control in pixels.")]
[SRCategoryAttribute("Layout")]
public Size Size {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("The size of the control in pixels.")]
[SRCategoryAttribute("Layout")]
public: __property Size get_Size();
public: __property void set_Size(
   Size value
);
C++/CLI
[SRDescriptionAttribute("The size of the control in pixels.")]
[SRCategoryAttribute("Layout")]
public:
property Size Size {
   Size get();
   void set (Sizevalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


TabIndex Property

[image]
Gizmox.WebGUI.Forms
TabIndex Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : TabIndex Property

Gets or sets the tab index.

Syntax

Visual Basic (Declaration)
Public Property TabIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim value As Integer

instance.TabIndex = value

value = instance.TabIndex
C#
public int TabIndex {get; set;}
Managed Extensions for C++
public: __property int get_TabIndex();
public: __property void set_TabIndex(
   int value
);
C++/CLI
public:
property int TabIndex {
   int get();
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


TabStop Property

[image]
Gizmox.WebGUI.Forms
TabStop Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : TabStop Property

Gets or sets a value indicating whether tab stop is enabled.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Indicates whether the user can use the TAB key to give focus to the control.")>
<SRCategoryAttribute("Behavior")>
<DefaultValueAttribute()>
Public Overridable Property TabStop As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim value As Boolean

instance.TabStop = value

value = instance.TabStop
C#
[SRDescriptionAttribute("Indicates whether the user can use the TAB key to give focus to the control.")]
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
public virtual bool TabStop {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Indicates whether the user can use the TAB key to give focus to the control.")]
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
public: __property virtual bool get_TabStop();
public: __property virtual void set_TabStop(
   bool value
);
C++/CLI
[SRDescriptionAttribute("Indicates whether the user can use the TAB key to give focus to the control.")]
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
public:
virtual property bool TabStop {
   bool get();
   void set (boolvalue);
}

Return Value

true if tab stop is enabled; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


Text Property

[image]
Gizmox.WebGUI.Forms
Text Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : Text Property

Gets or sets the text associated with this control.

Syntax

Visual Basic (Declaration)
<BindableAttribute(True)>
<SRCategoryAttribute("Appearance")>
<DefaultValueAttribute()>
<SRDescriptionAttribute("The text associated with the control.")>
<LocalizableAttribute(True)>
Public Overridable Property Text As String
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim value As String

instance.Text = value

value = instance.Text
C#
[BindableAttribute(true)]
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("The text associated with the control.")]
[LocalizableAttribute(true)]
public virtual string Text {get; set;}
Managed Extensions for C++
[BindableAttribute(true)]
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("The text associated with the control.")]
[LocalizableAttribute(true)]
public: __property virtual string* get_Text();
public: __property virtual void set_Text(
   string* value
);
C++/CLI
[BindableAttribute(true)]
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("The text associated with the control.")]
[LocalizableAttribute(true)]
public:
virtual property String^ Text {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


Top Property

[image]
Gizmox.WebGUI.Forms
Top Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : Top Property

Gets/Sets the top position

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public Property Top As Integer
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim value As Integer

instance.Top = value

value = instance.Top
C#
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public int Top {get; set;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property int get_Top();
public: __property void set_Top(
   int value
);
C++/CLI
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
property int Top {
   int get();
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


Visible Property

[image]
Gizmox.WebGUI.Forms
Visible Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : Visible Property

Gets or sets the control visability.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<SRDescriptionAttribute("Determines whether the control is visible or hidden.")>
<SRCategoryAttribute("Behavior")>
Public Overridable Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim value As Boolean

instance.Visible = value

value = instance.Visible
C#
[DefaultValueAttribute()]
[SRDescriptionAttribute("Determines whether the control is visible or hidden.")]
[SRCategoryAttribute("Behavior")]
public virtual bool Visible {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[SRDescriptionAttribute("Determines whether the control is visible or hidden.")]
[SRCategoryAttribute("Behavior")]
public: __property virtual bool get_Visible();
public: __property virtual void set_Visible(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
[SRDescriptionAttribute("Determines whether the control is visible or hidden.")]
[SRCategoryAttribute("Behavior")]
public:
virtual property bool Visible {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


Width Property

[image]
Gizmox.WebGUI.Forms
Width Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : Width Property

Gets/Sets the width position

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public Property Width As Integer
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim value As Integer

instance.Width = value

value = instance.Width
C#
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public int Width {get; set;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property int get_Width();
public: __property void set_Width(
   int value
);
C++/CLI
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
property int Width {
   int get();
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


Control Class Events

[image]
Gizmox.WebGUI.Forms
Control Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : Control Class

For a list of all members of this type, see Control members.

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes.
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes.
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes.
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes.
Public Event | Click | Occurs on clicking the button.
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection.
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection.
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes.
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked.
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design.
Public Event | FontChanged | Occurs when the FontChanged property changes.
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes.
Public Event | GotFocus | Occurs when the control recives focus.
Public Event | HelpRequested | Occurs when the user requests help for a control.
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead).
Public Event | KeyPress | Occurs on key press.
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead).
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design.
Public Event | LocationChanged | Occurs when the Location property value has changed.
Public Event | LostFocus | Occurs when the control loses focus.
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead).
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead).
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes.
Public Event | ParentChanged | Occurs when the Parent property value changes.
Public Event | Resize | Occurs when the control is resized.
Public Event | TextChanged | Occurs when the Text property value changes.
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued).
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes.
Top

See Also

Reference

Control Class
Gizmox.WebGUI.Forms Namespace


BackColorChanged Event

[image]
Gizmox.WebGUI.Forms
BackColorChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : BackColorChanged Event

Occurs when the value of the BackColor property changes.

Syntax

Visual Basic (Declaration)
Public Event BackColorChanged() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim handler As EventHandler

AddHandler instance.BackColorChanged, handler
C#
public event EventHandler BackColorChanged()
Managed Extensions for C++
public: __event EventHandler* BackColorChanged
C++/CLI
public:
event EventHandler^ BackColorChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


BackgroundImageChanged Event

[image]
Gizmox.WebGUI.Forms
BackgroundImageChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : BackgroundImageChanged Event

Occurs when the value of the BackgroundImage property changes.

Syntax

Visual Basic (Declaration)
Public Event BackgroundImageChanged() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim handler As EventHandler

AddHandler instance.BackgroundImageChanged, handler
C#
public event EventHandler BackgroundImageChanged()
Managed Extensions for C++
public: __event EventHandler* BackgroundImageChanged
C++/CLI
public:
event EventHandler^ BackgroundImageChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


BackgroundImageLayoutChanged Event

[image]
Gizmox.WebGUI.Forms
BackgroundImageLayoutChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : BackgroundImageLayoutChanged Event

Occurs when the BackgroundImageLayout property changes.

Syntax

Visual Basic (Declaration)
Public Event BackgroundImageLayoutChanged() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim handler As EventHandler

AddHandler instance.BackgroundImageLayoutChanged, handler
C#
public event EventHandler BackgroundImageLayoutChanged()
Managed Extensions for C++
public: __event EventHandler* BackgroundImageLayoutChanged
C++/CLI
public:
event EventHandler^ BackgroundImageLayoutChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


BindingContextChanged Event

[image]
Gizmox.WebGUI.Forms
BindingContextChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : BindingContextChanged Event

Occurs when the value of the BindingContext property changes.

Syntax

Visual Basic (Declaration)
Public Event BindingContextChanged() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim handler As EventHandler

AddHandler instance.BindingContextChanged, handler
C#
public event EventHandler BindingContextChanged()
Managed Extensions for C++
public: __event EventHandler* BindingContextChanged
C++/CLI
public:
event EventHandler^ BindingContextChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


Click Event

[image]
Gizmox.WebGUI.Forms
Click Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : Click Event

Occurs on clicking the button.

Syntax

Visual Basic (Declaration)
Public Event Click() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim handler As EventHandler

AddHandler instance.Click, handler
C#
public event EventHandler Click()
Managed Extensions for C++
public: __event EventHandler* Click
C++/CLI
public:
event EventHandler^ Click

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


ControlAdded Event

[image]
Gizmox.WebGUI.Forms
ControlAdded Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : ControlAdded Event

Occurs when a new control is added to the ControlCollection.

Syntax

Visual Basic (Declaration)
Public Event ControlAdded() As ControlEventHandler
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim handler As ControlEventHandler

AddHandler instance.ControlAdded, handler
C#
public event ControlEventHandler ControlAdded()
Managed Extensions for C++
public: __event ControlEventHandler* ControlAdded
C++/CLI
public:
event ControlEventHandler^ ControlAdded

Event Data

The event handler receives an argument of type ControlEventArgs containing data related to this event. The following ControlEventArgs properties provide information specific to this event.

Property | Description
Control | Gets the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


ControlRemoved Event

[image]
Gizmox.WebGUI.Forms
ControlRemoved Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : ControlRemoved Event

Occurs when a control is removed from the ControlCollection.

Syntax

Visual Basic (Declaration)
Public Event ControlRemoved() As ControlEventHandler
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim handler As ControlEventHandler

AddHandler instance.ControlRemoved, handler
C#
public event ControlEventHandler ControlRemoved()
Managed Extensions for C++
public: __event ControlEventHandler* ControlRemoved
C++/CLI
public:
event ControlEventHandler^ ControlRemoved

Event Data

The event handler receives an argument of type ControlEventArgs containing data related to this event. The following ControlEventArgs properties provide information specific to this event.

Property | Description
Control | Gets the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


CursorChanged Event

[image]
Gizmox.WebGUI.Forms
CursorChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : CursorChanged Event

Occurs when the value of the Control.Cursor property changes.

Syntax

Visual Basic (Declaration)
Public Event CursorChanged() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim handler As EventHandler

AddHandler instance.CursorChanged, handler
C#
public event EventHandler CursorChanged()
Managed Extensions for C++
public: __event EventHandler* CursorChanged
C++/CLI
public:
event EventHandler^ CursorChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


DoubleClick Event

[image]
Gizmox.WebGUI.Forms
DoubleClick Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : DoubleClick Event

Occurs when the control is double clicked.

Syntax

Visual Basic (Declaration)
Public Event DoubleClick() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim handler As EventHandler

AddHandler instance.DoubleClick, handler
C#
public event EventHandler DoubleClick()
Managed Extensions for C++
public: __event EventHandler* DoubleClick
C++/CLI
public:
event EventHandler^ DoubleClick

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


Enter Event

[image]
Gizmox.WebGUI.Forms
Enter Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : Enter Event

Occurs when the control is entered. Not implemented by design.

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("Not implemented by design.")>
Public Event Enter() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim handler As EventHandler

AddHandler instance.Enter, handler
C#
[ObsoleteAttribute("Not implemented by design.")]
public event EventHandler Enter()
Managed Extensions for C++
[ObsoleteAttribute("Not implemented by design.")]
public: __event EventHandler* Enter
C++/CLI
[ObsoleteAttribute("Not implemented by design.")]
public:
event EventHandler^ Enter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


FontChanged Event

[image]
Gizmox.WebGUI.Forms
FontChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : FontChanged Event

Occurs when the FontChanged property changes.

Syntax

Visual Basic (Declaration)
Public Event FontChanged() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim handler As EventHandler

AddHandler instance.FontChanged, handler
C#
public event EventHandler FontChanged()
Managed Extensions for C++
public: __event EventHandler* FontChanged
C++/CLI
public:
event EventHandler^ FontChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


ForeColorChanged Event

[image]
Gizmox.WebGUI.Forms
ForeColorChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : ForeColorChanged Event

Occurs when the ForeColorChanged property changes.

Syntax

Visual Basic (Declaration)
Public Event ForeColorChanged() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim handler As EventHandler

AddHandler instance.ForeColorChanged, handler
C#
public event EventHandler ForeColorChanged()
Managed Extensions for C++
public: __event EventHandler* ForeColorChanged
C++/CLI
public:
event EventHandler^ ForeColorChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


GotFocus Event

[image]
Gizmox.WebGUI.Forms
GotFocus Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : GotFocus Event

Occurs when the control recives focus.

Syntax

Visual Basic (Declaration)
Public Event GotFocus() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim handler As EventHandler

AddHandler instance.GotFocus, handler
C#
public event EventHandler GotFocus()
Managed Extensions for C++
public: __event EventHandler* GotFocus
C++/CLI
public:
event EventHandler^ GotFocus

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


HelpRequested Event

[image]
Gizmox.WebGUI.Forms
HelpRequested Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : HelpRequested Event

Occurs when the user requests help for a control.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Behavior")>
<SRDescriptionAttribute("Occurs when the user invokes Help for the control.")>
Public Event HelpRequested() As HelpEventHandler
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim handler As HelpEventHandler

AddHandler instance.HelpRequested, handler
C#
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when the user invokes Help for the control.")]
public event HelpEventHandler HelpRequested()
Managed Extensions for C++
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when the user invokes Help for the control.")]
public: __event HelpEventHandler* HelpRequested
C++/CLI
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when the user invokes Help for the control.")]
public:
event HelpEventHandler^ HelpRequested

Event Data

The event handler receives an argument of type HelpEventArgs containing data related to this event. The following HelpEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value indicating whether the help event was handled.
MousePos | Gets the screen coordinates of the mouse pointer.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


KeyDown Event

[image]
Gizmox.WebGUI.Forms
KeyDown Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : KeyDown Event

Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead).

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("Implemented by design as KeyPress (Use KeyPress instead).")>
Public Event KeyDown() As KeyEventHandler
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim handler As KeyEventHandler

AddHandler instance.KeyDown, handler
C#
[ObsoleteAttribute("Implemented by design as KeyPress (Use KeyPress instead).")]
public event KeyEventHandler KeyDown()
Managed Extensions for C++
[ObsoleteAttribute("Implemented by design as KeyPress (Use KeyPress instead).")]
public: __event KeyEventHandler* KeyDown
C++/CLI
[ObsoleteAttribute("Implemented by design as KeyPress (Use KeyPress instead).")]
public:
event KeyEventHandler^ KeyDown

Event Data

The event handler receives an argument of type KeyEventArgs containing data related to this event. The following KeyEventArgs properties provide information specific to this event.

Property | Description
Alt |
Control |
Handled | Gets or sets a value indicating whether the event was handled.
KeyCode |
KeyData |
KeyValue |
Modifiers | Gets the modifier flags for a KeyDown or KeyUp event. The flags indicate which combination of CTRL, SHIFT, and ALT keys was pressed.
Shift |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


KeyPress Event

[image]
Gizmox.WebGUI.Forms
KeyPress Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : KeyPress Event

Occurs on key press.

Syntax

Visual Basic (Declaration)
Public Event KeyPress() As KeyPressEventHandler
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim handler As KeyPressEventHandler

AddHandler instance.KeyPress, handler
C#
public event KeyPressEventHandler KeyPress()
Managed Extensions for C++
public: __event KeyPressEventHandler* KeyPress
C++/CLI
public:
event KeyPressEventHandler^ KeyPress

Event Data

The event handler receives an argument of type KeyPressEventArgs containing data related to this event. The following KeyPressEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value indicating whether the KeyPress event was handled.
KeyChar | Gets or sets the character corresponding to the key pressed.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


KeyUp Event

[image]
Gizmox.WebGUI.Forms
KeyUp Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : KeyUp Event

Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead).

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("Implemented by design as KeyPress (Use KeyPress instead).")>
Public Event KeyUp() As KeyEventHandler
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim handler As KeyEventHandler

AddHandler instance.KeyUp, handler
C#
[ObsoleteAttribute("Implemented by design as KeyPress (Use KeyPress instead).")]
public event KeyEventHandler KeyUp()
Managed Extensions for C++
[ObsoleteAttribute("Implemented by design as KeyPress (Use KeyPress instead).")]
public: __event KeyEventHandler* KeyUp
C++/CLI
[ObsoleteAttribute("Implemented by design as KeyPress (Use KeyPress instead).")]
public:
event KeyEventHandler^ KeyUp

Event Data

The event handler receives an argument of type KeyEventArgs containing data related to this event. The following KeyEventArgs properties provide information specific to this event.

Property | Description
Alt |
Control |
Handled | Gets or sets a value indicating whether the event was handled.
KeyCode |
KeyData |
KeyValue |
Modifiers | Gets the modifier flags for a KeyDown or KeyUp event. The flags indicate which combination of CTRL, SHIFT, and ALT keys was pressed.
Shift |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


Leave Event

[image]
Gizmox.WebGUI.Forms
Leave Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : Leave Event

Occurs when the input focus leaves the control. Not implemented by design.

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("Not implemented by design.")>
Public Event Leave() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim handler As EventHandler

AddHandler instance.Leave, handler
C#
[ObsoleteAttribute("Not implemented by design.")]
public event EventHandler Leave()
Managed Extensions for C++
[ObsoleteAttribute("Not implemented by design.")]
public: __event EventHandler* Leave
C++/CLI
[ObsoleteAttribute("Not implemented by design.")]
public:
event EventHandler^ Leave

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


LocationChanged Event

[image]
Gizmox.WebGUI.Forms
LocationChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : LocationChanged Event

Occurs when the Location property value has changed.

Syntax

Visual Basic (Declaration)
Public Event LocationChanged() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim handler As EventHandler

AddHandler instance.LocationChanged, handler
C#
public event EventHandler LocationChanged()
Managed Extensions for C++
public: __event EventHandler* LocationChanged
C++/CLI
public:
event EventHandler^ LocationChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


LostFocus Event

[image]
Gizmox.WebGUI.Forms
LostFocus Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : LostFocus Event

Occurs when the control loses focus.

Syntax

Visual Basic (Declaration)
Public Event LostFocus() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim handler As EventHandler

AddHandler instance.LostFocus, handler
C#
public event EventHandler LostFocus()
Managed Extensions for C++
public: __event EventHandler* LostFocus
C++/CLI
public:
event EventHandler^ LostFocus

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


MouseDown Event

[image]
Gizmox.WebGUI.Forms
MouseDown Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : MouseDown Event

Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead).

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("Implemented by design as Click (Use Click instead).")>
Public Event MouseDown() As MouseEventHandler
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim handler As MouseEventHandler

AddHandler instance.MouseDown, handler
C#
[ObsoleteAttribute("Implemented by design as Click (Use Click instead).")]
public event MouseEventHandler MouseDown()
Managed Extensions for C++
[ObsoleteAttribute("Implemented by design as Click (Use Click instead).")]
public: __event MouseEventHandler* MouseDown
C++/CLI
[ObsoleteAttribute("Implemented by design as Click (Use Click instead).")]
public:
event MouseEventHandler^ MouseDown

Event Data

The event handler receives an argument of type MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button |
Clicks |
Delta |
X |
Y |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


MouseUp Event

[image]
Gizmox.WebGUI.Forms
MouseUp Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : MouseUp Event

Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead).

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("Implemented by design as Click (Use Click instead).")>
Public Event MouseUp() As MouseEventHandler
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim handler As MouseEventHandler

AddHandler instance.MouseUp, handler
C#
[ObsoleteAttribute("Implemented by design as Click (Use Click instead).")]
public event MouseEventHandler MouseUp()
Managed Extensions for C++
[ObsoleteAttribute("Implemented by design as Click (Use Click instead).")]
public: __event MouseEventHandler* MouseUp
C++/CLI
[ObsoleteAttribute("Implemented by design as Click (Use Click instead).")]
public:
event MouseEventHandler^ MouseUp

Event Data

The event handler receives an argument of type MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button |
Clicks |
Delta |
X |
Y |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


PaddingChanged Event

[image]
Gizmox.WebGUI.Forms
PaddingChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : PaddingChanged Event

Occurs when the PaddingChanged property changes.

Syntax

Visual Basic (Declaration)
Public Event PaddingChanged() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim handler As EventHandler

AddHandler instance.PaddingChanged, handler
C#
public event EventHandler PaddingChanged()
Managed Extensions for C++
public: __event EventHandler* PaddingChanged
C++/CLI
public:
event EventHandler^ PaddingChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


ParentChanged Event

[image]
Gizmox.WebGUI.Forms
ParentChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : ParentChanged Event

Occurs when the Parent property value changes.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Property Changed")>
<SRDescriptionAttribute("Event raised when the value of the Parent property is changed on Control.")>
Public Event ParentChanged() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim handler As EventHandler

AddHandler instance.ParentChanged, handler
C#
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the Parent property is changed on Control.")]
public event EventHandler ParentChanged()
Managed Extensions for C++
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the Parent property is changed on Control.")]
public: __event EventHandler* ParentChanged
C++/CLI
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the Parent property is changed on Control.")]
public:
event EventHandler^ ParentChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


Resize Event

[image]
Gizmox.WebGUI.Forms
Resize Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : Resize Event

Occurs when the control is resized.

Syntax

Visual Basic (Declaration)
Public Event Resize() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim handler As EventHandler

AddHandler instance.Resize, handler
C#
public event EventHandler Resize()
Managed Extensions for C++
public: __event EventHandler* Resize
C++/CLI
public:
event EventHandler^ Resize

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


TextChanged Event

[image]
Gizmox.WebGUI.Forms
TextChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : TextChanged Event

Occurs when the Text property value changes.

Syntax

Visual Basic (Declaration)
Public Event TextChanged() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim handler As EventHandler

AddHandler instance.TextChanged, handler
C#
public event EventHandler TextChanged()
Managed Extensions for C++
public: __event EventHandler* TextChanged
C++/CLI
public:
event EventHandler^ TextChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


TextChangedQueued Event

[image]
Gizmox.WebGUI.Forms
TextChangedQueued Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : TextChangedQueued Event

Occurs when the Text property value changes (Queued).

Syntax

Visual Basic (Declaration)
Public Event TextChangedQueued() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim handler As EventHandler

AddHandler instance.TextChangedQueued, handler
C#
public event EventHandler TextChangedQueued()
Managed Extensions for C++
public: __event EventHandler* TextChangedQueued
C++/CLI
public:
event EventHandler^ TextChangedQueued

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


VisibleChanged Event

[image]
Gizmox.WebGUI.Forms
VisibleChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control Class : VisibleChanged Event

Occurs when the Control.Visible property value changes.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the control's visibility changes.")>
<SRCategoryAttribute("Property Changed")>
Public Event VisibleChanged() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As Control
Dim handler As EventHandler

AddHandler instance.VisibleChanged, handler
C#
[SRDescriptionAttribute("Occurs when the control's visibility changes.")]
[SRCategoryAttribute("Property Changed")]
public event EventHandler VisibleChanged()
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the control's visibility changes.")]
[SRCategoryAttribute("Property Changed")]
public: __event EventHandler* VisibleChanged
C++/CLI
[SRDescriptionAttribute("Occurs when the control's visibility changes.")]
[SRCategoryAttribute("Property Changed")]
public:
event EventHandler^ VisibleChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control Class
Control Members


Control.ControlCollection Class

[image]
Gizmox.WebGUI.Forms
Control.ControlCollection Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : Control.ControlCollection Class

Represents a collection of objects.

Object Model

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
<ListBindableAttribute(False)>
<DesignerSerializerAttribute(SerializerTypeName="Gizmox.WebGUI.Common.Design.Serialization.ControlCollectionCodeDomSerializer, Gizmox.WebGUI.Common.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=ea5dfe57c8eb7edd", SerializerBaseTypeName="System.ComponentModel.Design.Serialization.CodeDomSerializer, System.Design, Version=1.0.5000.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
Public Class Control.ControlCollection
   Inherits ArrangedElementCollection
   Implements IObservableList
Visual Basic (Usage) Copy Code
Dim instance As Control.ControlCollection
C#
[DefaultMemberAttribute("Item")]
[ListBindableAttribute(false)]
[DesignerSerializerAttribute(SerializerTypeName="Gizmox.WebGUI.Common.Design.Serialization.ControlCollectionCodeDomSerializer, Gizmox.WebGUI.Common.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=ea5dfe57c8eb7edd", SerializerBaseTypeName="System.ComponentModel.Design.Serialization.CodeDomSerializer, System.Design, Version=1.0.5000.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
public class Control.ControlCollection : ArrangedElementCollection, IObservableList
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
[ListBindableAttribute(false)]
[DesignerSerializerAttribute(SerializerTypeName="Gizmox.WebGUI.Common.Design.Serialization.ControlCollectionCodeDomSerializer, Gizmox.WebGUI.Common.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=ea5dfe57c8eb7edd", SerializerBaseTypeName="System.ComponentModel.Design.Serialization.CodeDomSerializer, System.Design, Version=1.0.5000.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
public __gc class Control.ControlCollection : public ArrangedElementCollection, IObservableList
C++/CLI
[DefaultMemberAttribute("Item")]
[ListBindableAttribute(false)]
[DesignerSerializerAttribute(SerializerTypeName="Gizmox.WebGUI.Common.Design.Serialization.ControlCollectionCodeDomSerializer, Gizmox.WebGUI.Common.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=ea5dfe57c8eb7edd", SerializerBaseTypeName="System.ComponentModel.Design.Serialization.CodeDomSerializer, System.Design, Version=1.0.5000.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
public ref class Control.ControlCollection : public ArrangedElementCollection, IObservableList

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.Layout.ArrangedElementCollection
Gizmox.WebGUI.Forms.Control.ControlCollection
Gizmox.WebGUI.Forms.ControlCollection
Gizmox.WebGUI.Forms.MdiClient.ControlCollection
Gizmox.WebGUI.Forms.TableLayoutControlCollection

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Control.ControlCollection Members
Gizmox.WebGUI.Forms Namespace


Control.ControlCollection Class Members

[image]
Gizmox.WebGUI.Forms
Control.ControlCollection Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : Control.ControlCollection Class

The following tables list the members exposed by Control.ControlCollection.

Public Constructors

 | Name | Description
Public Constructor | Control.ControlCollection Constructor | Overloaded. Initializes a new instance of the Control.ControlCollection class.
Top

Public Properties

 | Name | Description
Public Property | Count |
Public Property | IsFixedSize |
Public Property | IsReadOnly | Overridden.
Public Property | Item | Overloaded. Indicates a Control with the specified key in the collection.
Public Property | Owner | Gets the control that owns this Control.ControlCollection.
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Adds the specified control to the control collection.
Public Method | AddRange | Adds an array of control objects to the collection.
Public Method | Clear | Removes all controls from the collection.
Public Method | Contains | Determines whether the specified control is a member of the collection.
Public Method | ContainsKey | Determines whether the Control.ControlCollection contains an item with the specified key.
Public Method | CopyTo | Copies the entire contents of this collection to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Gizmox.WebGUI.Forms.Layout.ArrangedElementCollection)
Public Method | Equals | Determines whether two ArrangedElementCollection instances are equal. (Inherited from Gizmox.WebGUI.Forms.Layout.ArrangedElementCollection)
Public Method | Find | Searches for controls by their Control.Name property and builds an array of all the controls that match.
Public Method | GetChildIndex | Overloaded. Retrieves the index of the specified child control within the control collection.
Public Method | GetEnumerator | Overridden. Retrieves a reference to an enumerator object that is used to iterate over a Control.ControlCollection.
Public Method | GetHashCode | Returns the hash code for this instance. (Inherited from Gizmox.WebGUI.Forms.Layout.ArrangedElementCollection)
Public Method | IndexOf | Retrieves the index of the specified control in the control collection.
Public Method | IndexOfKey | Retrieves the index of the first occurrence of the specified item within the collection.
Public Method | Insert |
Public Method | Remove | Removes the specified control from the control collection.
Public Method | RemoveAt | Removes a control from the control collection at the specified indexed location.
Public Method | RemoveByKey | Removes the child control with the specified key.
Public Method | SetChildIndex | Sets the index of the specified child control in the collection to the specified index value.
Top

See Also

Reference

Control.ControlCollection Class
Gizmox.WebGUI.Forms Namespace


Control.ControlCollection Constructor

[image]
Gizmox.WebGUI.Forms
Control.ControlCollection Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control.ControlCollection Class : Control.ControlCollection Constructor

Initializes a new instance of the Control.ControlCollection class.

Overload List

Overload | Description
Control.ControlCollection Constructor(Control) |
Control.ControlCollection Constructor(Control,Boolean) | Initializes a new instance of the Control.ControlCollection class.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control.ControlCollection Class
Control.ControlCollection Members


Control.ControlCollection Constructor(Control)

[image]
Gizmox.WebGUI.Forms
Control.ControlCollection Constructor(Control)
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control.ControlCollection Class > Control.ControlCollection Constructor : Control.ControlCollection Constructor(Control)

owner

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal owner As Control _
)
Visual Basic (Usage) Copy Code
Dim owner As Control

Dim instance As Control.ControlCollection(owner)
C#
public Control.ControlCollection(
   Control owner
)
Managed Extensions for C++
public: Control.ControlCollection(
   Control* owner
)
C++/CLI
public:
Control.ControlCollection(
   Control^ owner
)

Parameters

owner

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control.ControlCollection Class
Control.ControlCollection Members
Overload List


Control.ControlCollection Constructor(Control,Boolean)

[image]
Gizmox.WebGUI.Forms
Control.ControlCollection Constructor(Control,Boolean)
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control.ControlCollection Class > Control.ControlCollection Constructor : Control.ControlCollection Constructor(Control,Boolean)

owner
A Control representing the control that owns the control collection.
blnReversed
Initializes a new instance of the Control.ControlCollection class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal owner As Control, _
   ByVal blnReversed As Boolean _
)
Visual Basic (Usage) Copy Code
Dim owner As Control
Dim blnReversed As Boolean

Dim instance As Control.ControlCollection(owner, blnReversed)
C#
public Control.ControlCollection(
   Control owner,
   bool blnReversed
)
Managed Extensions for C++
public: Control.ControlCollection(
   Control* owner,
   bool blnReversed
)
C++/CLI
public:
Control.ControlCollection(
   Control^ owner,
   bool blnReversed
)

Parameters

owner
A Control representing the control that owns the control collection.
blnReversed

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control.ControlCollection Class
Control.ControlCollection Members
Overload List


Control.ControlCollection Class Methods

[image]
Gizmox.WebGUI.Forms
Control.ControlCollection Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : Control.ControlCollection Class

For a list of all members of this type, see Control.ControlCollection members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Adds the specified control to the control collection.
Public Method | AddRange | Adds an array of control objects to the collection.
Public Method | Clear | Removes all controls from the collection.
Public Method | Contains | Determines whether the specified control is a member of the collection.
Public Method | ContainsKey | Determines whether the Control.ControlCollection contains an item with the specified key.
Public Method | CopyTo | Copies the entire contents of this collection to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Gizmox.WebGUI.Forms.Layout.ArrangedElementCollection)
Public Method | Equals | Determines whether two ArrangedElementCollection instances are equal. (Inherited from Gizmox.WebGUI.Forms.Layout.ArrangedElementCollection)
Public Method | Find | Searches for controls by their Control.Name property and builds an array of all the controls that match.
Public Method | GetChildIndex | Overloaded. Retrieves the index of the specified child control within the control collection.
Public Method | GetEnumerator | Overridden. Retrieves a reference to an enumerator object that is used to iterate over a Control.ControlCollection.
Public Method | GetHashCode | Returns the hash code for this instance. (Inherited from Gizmox.WebGUI.Forms.Layout.ArrangedElementCollection)
Public Method | IndexOf | Retrieves the index of the specified control in the control collection.
Public Method | IndexOfKey | Retrieves the index of the first occurrence of the specified item within the collection.
Public Method | Insert |
Public Method | Remove | Removes the specified control from the control collection.
Public Method | RemoveAt | Removes a control from the control collection at the specified indexed location.
Public Method | RemoveByKey | Removes the child control with the specified key.
Public Method | SetChildIndex | Sets the index of the specified child control in the collection to the specified index value.
Top

See Also

Reference

Control.ControlCollection Class
Gizmox.WebGUI.Forms Namespace


Add Method

[image]
Gizmox.WebGUI.Forms
Add Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control.ControlCollection Class : Add Method

Adds the specified control to the control collection.

Overload List

Overload | Description
Add(Control) | Adds the specified control to the control collection.
Add(Control,Boolean) | Adds the specified control to the control collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control.ControlCollection Class
Control.ControlCollection Members


Add(Control) Method

[image]
Gizmox.WebGUI.Forms
Add(Control) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control.ControlCollection Class > Add Method : Add(Control) Method

value
The Control to add to the control collection.
Adds the specified control to the control collection.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub Add( _
   ByVal value As Control _
)
Visual Basic (Usage) Copy Code
Dim instance As Control.ControlCollection
Dim value As Control

instance.Add(value)
C#
public virtual void Add(
   Control value
)
Managed Extensions for C++
public: virtual void Add(
   Control* value
)
C++/CLI
public:
virtual void Add(
   Control^ value
)

Parameters

value
The Control to add to the control collection.

Exceptions

Exception | Description
Exception | The specified control is a top-level control, or a circular control reference would result if this control were added to the control collection.
ArgumentException | The object assigned to the value parameter is not a Control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control.ControlCollection Class
Control.ControlCollection Members
Overload List


Add(Control,Boolean) Method

[image]
Gizmox.WebGUI.Forms
Add(Control,Boolean) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control.ControlCollection Class > Add Method : Add(Control,Boolean) Method

value
The Control to add to the control collection.
blnIsAddRange
Adds the specified control to the control collection.

Syntax

Visual Basic (Declaration)
Protected Overloads Overridable Sub Add( _
   ByVal value As Control, _
   ByVal blnIsAddRange As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As Control.ControlCollection
Dim value As Control
Dim blnIsAddRange As Boolean

instance.Add(value, blnIsAddRange)
C#
protected virtual void Add(
   Control value,
   bool blnIsAddRange
)
Managed Extensions for C++
protected: virtual void Add(
   Control* value,
   bool blnIsAddRange
)
C++/CLI
protected:
virtual void Add(
   Control^ value,
   bool blnIsAddRange
)

Parameters

value
The Control to add to the control collection.
blnIsAddRange

Exceptions

Exception | Description
Exception | The specified control is a top-level control, or a circular control reference would result if this control were added to the control collection.
ArgumentException | The object assigned to the value parameter is not a Control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control.ControlCollection Class
Control.ControlCollection Members
Overload List


AddRange Method

[image]
Gizmox.WebGUI.Forms
AddRange Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control.ControlCollection Class : AddRange Method

controls
An array of Control objects to add to the collection.
Adds an array of control objects to the collection.

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
Public Overridable Sub AddRange( _
   ByVal controls() As Control _
)
Visual Basic (Usage) Copy Code
Dim instance As Control.ControlCollection
Dim controls() As Control

instance.AddRange(controls)
C#
[DesignerSerializationVisibilityAttribute()]
public virtual void AddRange(
   Control[] controls
)
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
public: virtual void AddRange(
   Control*[]* controls
)
C++/CLI
[DesignerSerializationVisibilityAttribute()]
public:
virtual void AddRange(
   array<Control^>^ controls
)

Parameters

controls
An array of Control objects to add to the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control.ControlCollection Class
Control.ControlCollection Members


Clear Method

[image]
Gizmox.WebGUI.Forms
Clear Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control.ControlCollection Class : Clear Method

Removes all controls from the collection.

Syntax

Visual Basic (Declaration)
Public Overridable Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As Control.ControlCollection

instance.Clear()
C#
public virtual void Clear()
Managed Extensions for C++
public: virtual void Clear();
C++/CLI
public:
virtual void Clear();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control.ControlCollection Class
Control.ControlCollection Members


Contains Method

[image]
Gizmox.WebGUI.Forms
Contains Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control.ControlCollection Class : Contains Method

control
The Control to locate in the collection.
Determines whether the specified control is a member of the collection.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal control As Control _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Control.ControlCollection
Dim control As Control
Dim value As Boolean

value = instance.Contains(control)
C#
public bool Contains(
   Control control
)
Managed Extensions for C++
public: bool Contains(
   Control* control
)
C++/CLI
public:
bool Contains(
   Control^ control
)

Parameters

control
The Control to locate in the collection.

Return Value

true if the Control is a member of the collection; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control.ControlCollection Class
Control.ControlCollection Members


ContainsKey Method

[image]
Gizmox.WebGUI.Forms
ContainsKey Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control.ControlCollection Class : ContainsKey Method

key
The key to locate in the Control.ControlCollection.
Determines whether the Control.ControlCollection contains an item with the specified key.

Syntax

Visual Basic (Declaration)
Public Overridable Function ContainsKey( _
   ByVal key As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Control.ControlCollection
Dim key As String
Dim value As Boolean

value = instance.ContainsKey(key)
C#
public virtual bool ContainsKey(
   string key
)
Managed Extensions for C++
public: virtual bool ContainsKey(
   string* key
)
C++/CLI
public:
virtual bool ContainsKey(
   String^ key
)

Parameters

key
The key to locate in the Control.ControlCollection.

Return Value

true if the Control.ControlCollection contains an item with the specified key; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control.ControlCollection Class
Control.ControlCollection Members


Find Method

[image]
Gizmox.WebGUI.Forms
Find Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control.ControlCollection Class : Find Method

key
The key to locate in the Control.ControlCollection.
searchAllChildren
true to search all child controls; otherwise, false.
Searches for controls by their Control.Name property and builds an array of all the controls that match.

Syntax

Visual Basic (Declaration)
Public Function Find( _
   ByVal key As String, _
   ByVal searchAllChildren As Boolean _
) As Control()
Visual Basic (Usage) Copy Code
Dim instance As Control.ControlCollection
Dim key As String
Dim searchAllChildren As Boolean
Dim value() As Control

value = instance.Find(key, searchAllChildren)
C#
public Control[] Find(
   string key,
   bool searchAllChildren
)
Managed Extensions for C++
public: Control*[]* Find(
   string* key,
   bool searchAllChildren
)
C++/CLI
public:
array<Control^>^ Find(
   String^ key,
   bool searchAllChildren
)

Parameters

key
The key to locate in the Control.ControlCollection.
searchAllChildren
true to search all child controls; otherwise, false.

Return Value

An array of type Control containing the matching controls.

Exceptions

Exception | Description
ArgumentException | The key parameter is null or the empty string ("").

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control.ControlCollection Class
Control.ControlCollection Members


GetChildIndex Method

[image]
Gizmox.WebGUI.Forms
GetChildIndex Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control.ControlCollection Class : GetChildIndex Method

Retrieves the index of the specified child control within the control collection.

Overload List

Overload | Description
GetChildIndex(Control) | Retrieves the index of the specified child control within the control collection.
GetChildIndex(Control,Boolean) | Retrieves the index of the specified child control within the control collection, and optionally raises an exception if the specified control is not within the control collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control.ControlCollection Class
Control.ControlCollection Members


GetChildIndex(Control) Method

[image]
Gizmox.WebGUI.Forms
GetChildIndex(Control) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control.ControlCollection Class > GetChildIndex Method : GetChildIndex(Control) Method

child
The Control to search for in the control collection.
Retrieves the index of the specified child control within the control collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetChildIndex( _
   ByVal child As Control _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As Control.ControlCollection
Dim child As Control
Dim value As Integer

value = instance.GetChildIndex(child)
C#
public int GetChildIndex(
   Control child
)
Managed Extensions for C++
public: int GetChildIndex(
   Control* child
)
C++/CLI
public:
int GetChildIndex(
   Control^ child
)

Parameters

child
The Control to search for in the control collection.

Return Value

A zero-based index value that represents the location of the specified child control within the control collection.

Exceptions

Exception | Description
ArgumentException | The childControl is not in the Control.ControlCollection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control.ControlCollection Class
Control.ControlCollection Members
Overload List


GetChildIndex(Control,Boolean) Method

[image]
Gizmox.WebGUI.Forms
GetChildIndex(Control,Boolean) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control.ControlCollection Class > GetChildIndex Method : GetChildIndex(Control,Boolean) Method

child
The Control to search for in the control collection.
throwException
true to throw an exception if the Control specified in the child parameter is not a control in the Control.ControlCollection; otherwise, false.
Retrieves the index of the specified child control within the control collection, and optionally raises an exception if the specified control is not within the control collection.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function GetChildIndex( _
   ByVal child As Control, _
   ByVal throwException As Boolean _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As Control.ControlCollection
Dim child As Control
Dim throwException As Boolean
Dim value As Integer

value = instance.GetChildIndex(child, throwException)
C#
public virtual int GetChildIndex(
   Control child,
   bool throwException
)
Managed Extensions for C++
public: virtual int GetChildIndex(
   Control* child,
   bool throwException
)
C++/CLI
public:
virtual int GetChildIndex(
   Control^ child,
   bool throwException
)

Parameters

child
The Control to search for in the control collection.
throwException
true to throw an exception if the Control specified in the child parameter is not a control in the Control.ControlCollection; otherwise, false.

Return Value

A zero-based index value that represents the location of the specified child control within the control collection; otherwise -1 if the specified Control is not found in the Control.ControlCollection.

Exceptions

Exception | Description
ArgumentException | The childControl is not in the Control.ControlCollection, and the throwException parameter value is true.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control.ControlCollection Class
Control.ControlCollection Members
Overload List


GetEnumerator Method

[image]
Gizmox.WebGUI.Forms
GetEnumerator Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control.ControlCollection Class : GetEnumerator Method

Retrieves a reference to an enumerator object that is used to iterate over a Control.ControlCollection.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As Control.ControlCollection
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public override IEnumerator GetEnumerator()
Managed Extensions for C++
public: IEnumerator* GetEnumerator(); override
C++/CLI
public:
IEnumerator^ GetEnumerator(); override

Return Value

An IEnumerator.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control.ControlCollection Class
Control.ControlCollection Members


IndexOf Method

[image]
Gizmox.WebGUI.Forms
IndexOf Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control.ControlCollection Class : IndexOf Method

control
The Control to locate in the collection.
Retrieves the index of the specified control in the control collection.

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal control As Control _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As Control.ControlCollection
Dim control As Control
Dim value As Integer

value = instance.IndexOf(control)
C#
public int IndexOf(
   Control control
)
Managed Extensions for C++
public: int IndexOf(
   Control* control
)
C++/CLI
public:
int IndexOf(
   Control^ control
)

Parameters

control
The Control to locate in the collection.

Return Value

A zero-based index value that represents the position of the specified Control in the Control.ControlCollection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control.ControlCollection Class
Control.ControlCollection Members


IndexOfKey Method

[image]
Gizmox.WebGUI.Forms
IndexOfKey Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control.ControlCollection Class : IndexOfKey Method

key
The name of the control to search for.
Retrieves the index of the first occurrence of the specified item within the collection.

Syntax

Visual Basic (Declaration)
Public Overridable Function IndexOfKey( _
   ByVal key As String _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As Control.ControlCollection
Dim key As String
Dim value As Integer

value = instance.IndexOfKey(key)
C#
public virtual int IndexOfKey(
   string key
)
Managed Extensions for C++
public: virtual int IndexOfKey(
   string* key
)
C++/CLI
public:
virtual int IndexOfKey(
   String^ key
)

Parameters

key
The name of the control to search for.

Return Value

The zero-based index of the first occurrence of the control with the specified name in the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control.ControlCollection Class
Control.ControlCollection Members


Insert Method

[image]
Gizmox.WebGUI.Forms
Insert Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control.ControlCollection Class : Insert Method

index
value

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal value As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As Control.ControlCollection
Dim index As Integer
Dim value As Object

instance.Insert(index, value)
C#
public void Insert(
   int index,
   object value
)
Managed Extensions for C++
public: void Insert(
   int index,
   Object* value
)
C++/CLI
public:
void Insert(
   int index,
   Object^ value
)

Parameters

index
value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control.ControlCollection Class
Control.ControlCollection Members


Remove Method

[image]
Gizmox.WebGUI.Forms
Remove Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control.ControlCollection Class : Remove Method

value
The Control to remove from the Control.ControlCollection.
Removes the specified control from the control collection.

Syntax

Visual Basic (Declaration)
Public Overridable Sub Remove( _
   ByVal value As Control _
)
Visual Basic (Usage) Copy Code
Dim instance As Control.ControlCollection
Dim value As Control

instance.Remove(value)
C#
public virtual void Remove(
   Control value
)
Managed Extensions for C++
public: virtual void Remove(
   Control* value
)
C++/CLI
public:
virtual void Remove(
   Control^ value
)

Parameters

value
The Control to remove from the Control.ControlCollection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control.ControlCollection Class
Control.ControlCollection Members


RemoveAt Method

[image]
Gizmox.WebGUI.Forms
RemoveAt Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control.ControlCollection Class : RemoveAt Method

index
The index value of the Control to remove.
Removes a control from the control collection at the specified indexed location.

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As Control.ControlCollection
Dim index As Integer

instance.RemoveAt(index)
C#
public void RemoveAt(
   int index
)
Managed Extensions for C++
public: void RemoveAt(
   int index
)
C++/CLI
public:
void RemoveAt(
   int index
)

Parameters

index
The index value of the Control to remove.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control.ControlCollection Class
Control.ControlCollection Members


RemoveByKey Method

[image]
Gizmox.WebGUI.Forms
RemoveByKey Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control.ControlCollection Class : RemoveByKey Method

key
The name of the child control to remove.
Removes the child control with the specified key.

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveByKey( _
   ByVal key As String _
)
Visual Basic (Usage) Copy Code
Dim instance As Control.ControlCollection
Dim key As String

instance.RemoveByKey(key)
C#
public virtual void RemoveByKey(
   string key
)
Managed Extensions for C++
public: virtual void RemoveByKey(
   string* key
)
C++/CLI
public:
virtual void RemoveByKey(
   String^ key
)

Parameters

key
The name of the child control to remove.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control.ControlCollection Class
Control.ControlCollection Members


SetChildIndex Method

[image]
Gizmox.WebGUI.Forms
SetChildIndex Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control.ControlCollection Class : SetChildIndex Method

child
The childControl to search for.
newIndex
The new index value of the control.
Sets the index of the specified child control in the collection to the specified index value.

Syntax

Visual Basic (Declaration)
Public Overridable Sub SetChildIndex( _
   ByVal child As Control, _
   ByVal newIndex As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As Control.ControlCollection
Dim child As Control
Dim newIndex As Integer

instance.SetChildIndex(child, newIndex)
C#
public virtual void SetChildIndex(
   Control child,
   int newIndex
)
Managed Extensions for C++
public: virtual void SetChildIndex(
   Control* child,
   int newIndex
)
C++/CLI
public:
virtual void SetChildIndex(
   Control^ child,
   int newIndex
)

Parameters

child
The childControl to search for.
newIndex
The new index value of the control.

Exceptions

Exception | Description
ArgumentException | The child control is not in the Control.ControlCollection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control.ControlCollection Class
Control.ControlCollection Members


Control.ControlCollection Class Properties

[image]
Gizmox.WebGUI.Forms
Control.ControlCollection Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : Control.ControlCollection Class

For a list of all members of this type, see Control.ControlCollection members.

Public Properties

 | Name | Description
Public Property | Count |
Public Property | IsFixedSize |
Public Property | IsReadOnly | Overridden.
Public Property | Item | Overloaded. Indicates a Control with the specified key in the collection.
Public Property | Owner | Gets the control that owns this Control.ControlCollection.
Top

See Also

Reference

Control.ControlCollection Class
Gizmox.WebGUI.Forms Namespace


Count Property

[image]
Gizmox.WebGUI.Forms
Count Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control.ControlCollection Class : Count Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As Control.ControlCollection
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control.ControlCollection Class
Control.ControlCollection Members


IsFixedSize Property

[image]
Gizmox.WebGUI.Forms
IsFixedSize Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control.ControlCollection Class : IsFixedSize Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsFixedSize As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Control.ControlCollection
Dim value As Boolean

value = instance.IsFixedSize
C#
public bool IsFixedSize {get;}
Managed Extensions for C++
public: __property bool get_IsFixedSize();
C++/CLI
public:
property bool IsFixedSize {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control.ControlCollection Class
Control.ControlCollection Members


IsReadOnly Property

[image]
Gizmox.WebGUI.Forms
IsReadOnly Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control.ControlCollection Class : IsReadOnly Property

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property IsReadOnly As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Control.ControlCollection
Dim value As Boolean

value = instance.IsReadOnly
C#
public override bool IsReadOnly {get;}
Managed Extensions for C++
public: __property bool get_IsReadOnly() override;
C++/CLI
public:
property bool IsReadOnly {
   bool get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control.ControlCollection Class
Control.ControlCollection Members


Item Property

[image]
Gizmox.WebGUI.Forms
Item Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control.ControlCollection Class : Item Property

Indicates a Control with the specified key in the collection.

Overload List

Overload | Description
Item(String) | Indicates a Control with the specified key in the collection.
Item(Int32) | Indicates the Control at the specified indexed location in the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control.ControlCollection Class
Control.ControlCollection Members


Item(String) Property

[image]
Gizmox.WebGUI.Forms
Item(String) Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control.ControlCollection Class > Item Property : Item(String) Property

key
The name of the control to retrieve from the control collection.
Indicates a Control with the specified key in the collection.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable ReadOnly Property Item( _
   ByVal key As String _
) As Control
Visual Basic (Usage) Copy Code
Dim instance As Control.ControlCollection
Dim key As String
Dim value As Control

value = instance.Item(key)
C#
public virtual Control Item(
   string key
) {get;}
Managed Extensions for C++
public: __property virtual Control* get_Item(
   string* key
);
C++/CLI
public:
virtual property Control^ Item {
   Control^ get(String^key);
}

Parameters

key
The name of the control to retrieve from the control collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control.ControlCollection Class
Control.ControlCollection Members
Overload List


Item(Int32) Property

[image]
Gizmox.WebGUI.Forms
Item(Int32) Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control.ControlCollection Class > Item Property : Item(Int32) Property

index
The index of the control to retrieve from the control collection.
Indicates the Control at the specified indexed location in the collection.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable ReadOnly Property Item( _
   ByVal index As Integer _
) As Control
Visual Basic (Usage) Copy Code
Dim instance As Control.ControlCollection
Dim index As Integer
Dim value As Control

value = instance.Item(index)
C#
public virtual Control Item(
   int index
) {get;}
Managed Extensions for C++
public: __property virtual Control* get_Item(
   int index
);
C++/CLI
public:
virtual property Control^ Item {
   Control^ get(intindex);
}

Parameters

index
The index of the control to retrieve from the control collection.

Exceptions

Exception | Description
ArgumentOutOfRangeException | The index value is less than zero or is greater than or equal to the number of controls in the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control.ControlCollection Class
Control.ControlCollection Members
Overload List


Owner Property

[image]
Gizmox.WebGUI.Forms
Owner Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Control.ControlCollection Class : Owner Property

Gets the control that owns this Control.ControlCollection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Owner As Control
Visual Basic (Usage) Copy Code
Dim instance As Control.ControlCollection
Dim value As Control

value = instance.Owner
C#
public Control Owner {get;}
Managed Extensions for C++
public: __property Control* get_Owner();
C++/CLI
public:
property Control^ Owner {
   Control^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Control.ControlCollection Class
Control.ControlCollection Members


ControlBindingsCollection Class

[image]
Gizmox.WebGUI.Forms
ControlBindingsCollection Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ControlBindingsCollection Class

Represents the collection of data bindings for a control.

Object Model

Syntax

Visual Basic (Declaration)
<DefaultEventAttribute("CollectionChanged")>
<EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<DefaultMemberAttribute("Item")>
<TypeConverterAttribute("Gizmox.WebGUI.Forms.Design.ControlBindingsConverter, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")>
Public Class ControlBindingsCollection
   Inherits BindingsCollection
Visual Basic (Usage) Copy Code
Dim instance As ControlBindingsCollection
C#
[DefaultEventAttribute("CollectionChanged")]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[DefaultMemberAttribute("Item")]
[TypeConverterAttribute("Gizmox.WebGUI.Forms.Design.ControlBindingsConverter, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
public class ControlBindingsCollection : BindingsCollection
Managed Extensions for C++
[DefaultEventAttribute("CollectionChanged")]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[DefaultMemberAttribute("Item")]
[TypeConverterAttribute("Gizmox.WebGUI.Forms.Design.ControlBindingsConverter, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
public __gc class ControlBindingsCollection : public BindingsCollection
C++/CLI
[DefaultEventAttribute("CollectionChanged")]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[DefaultMemberAttribute("Item")]
[TypeConverterAttribute("Gizmox.WebGUI.Forms.Design.ControlBindingsConverter, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
public ref class ControlBindingsCollection : public BindingsCollection

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.BaseCollection
Gizmox.WebGUI.Forms.BindingsCollection
Gizmox.WebGUI.Forms.ControlBindingsCollection

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

ControlBindingsCollection Members
Gizmox.WebGUI.Forms Namespace


ControlBindingsCollection Class Members

[image]
Gizmox.WebGUI.Forms
ControlBindingsCollection Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : ControlBindingsCollection Class

The following tables list the members exposed by ControlBindingsCollection.

Public Constructors

 | Name | Description
Public Constructor | ControlBindingsCollection Constructor | Initializes a new instance of the ControlBindingsCollection class with the specified bindable control.
Top

Public Properties

 | Name | Description
Public Property | BindableComponent | Gets the IBindableComponent the binding collection belongs to.
Public Property | Control | Gets the control that the collection belongs to.
Public Property | Count | Gets the total number of bindings in the collection. (Inherited from BindingsCollection)
Public Property | DefaultDataSourceUpdateMode | Gets or sets the default Binding.DataSourceUpdateMode for a Binding in the collection.
Public Property | IsReadOnly | Gets a value indicating whether the collection is read-only. (Inherited from BaseCollection)
Public Property | IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized. (Inherited from BaseCollection)
Public Property | Item | Overloaded. Gets the Binding specified by the control's property name.
Public Property | SyncRoot | Gets an object that can be used to synchronize access to the BaseCollection. (Inherited from BaseCollection)
Top

Protected Properties

 | Name | Description
Protected Property | List | Gets the bindings in the collection as an object. (Inherited from BindingsCollection)
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Adds the specified Binding to the collection.
Public Method | Clear | Clears the collection of any bindings.
Public Method | CopyTo | Copies all the elements of the current one-dimensional Array to the specified one-dimensional Array starting at the specified destination Array index. (Inherited from BaseCollection)
Public Method | GetEnumerator | Gets the object that enables iterating through the members of the collection. (Inherited from BaseCollection)
Public Method | Remove | Deletes the specified Binding from the collection.
Public Method | RemoveAt | Deletes the Binding at the specified index.
Top

Protected Methods

 | Name | Description
Protected Method | AddCore | Overridden. Adds a binding to the collection.
Protected Method | ClearCore | Overridden. Clears the bindings in the collection.
Protected Method | OnCollectionChanged | Raises the CollectionChanged event. (Inherited from BindingsCollection)
Protected Method | OnCollectionChanging | Raises the CollectionChanging event. (Inherited from BindingsCollection)
Protected Method | RemoveCore | Overridden. Removes the specified binding from the collection.
Protected Method | ShouldSerializeMyAll | Gets a value that indicates whether the collection should be serialized. (Inherited from BindingsCollection)
Top

Public Events

 | Name | Description
Public Event | CollectionChanged | Occurs when the collection has changed. (Inherited from BindingsCollection)
Public Event | CollectionChanging | Occurs when the collection is about to change. (Inherited from BindingsCollection)
Top

See Also

Reference

ControlBindingsCollection Class
Gizmox.WebGUI.Forms Namespace


ControlBindingsCollection Constructor

[image]
Gizmox.WebGUI.Forms
ControlBindingsCollection Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ControlBindingsCollection Class : ControlBindingsCollection Constructor

control
The IBindableComponent the binding collection belongs to.
Initializes a new instance of the ControlBindingsCollection class with the specified bindable control.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal control As IBindableComponent _
)
Visual Basic (Usage) Copy Code
Dim control As IBindableComponent

Dim instance As ControlBindingsCollection(control)
C#
public ControlBindingsCollection(
   IBindableComponent control
)
Managed Extensions for C++
public: ControlBindingsCollection(
   IBindableComponent* control
)
C++/CLI
public:
ControlBindingsCollection(
   IBindableComponent^ control
)

Parameters

control
The IBindableComponent the binding collection belongs to.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ControlBindingsCollection Class
ControlBindingsCollection Members


ControlBindingsCollection Class Methods

[image]
Gizmox.WebGUI.Forms
ControlBindingsCollection Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ControlBindingsCollection Class

For a list of all members of this type, see ControlBindingsCollection members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Adds the specified Binding to the collection.
Public Method | Clear | Clears the collection of any bindings.
Public Method | CopyTo | Copies all the elements of the current one-dimensional Array to the specified one-dimensional Array starting at the specified destination Array index. (Inherited from BaseCollection)
Public Method | GetEnumerator | Gets the object that enables iterating through the members of the collection. (Inherited from BaseCollection)
Public Method | Remove | Deletes the specified Binding from the collection.
Public Method | RemoveAt | Deletes the Binding at the specified index.
Top

Protected Methods

 | Name | Description
Protected Method | AddCore | Overridden. Adds a binding to the collection.
Protected Method | ClearCore | Overridden. Clears the bindings in the collection.
Protected Method | OnCollectionChanged | Raises the CollectionChanged event. (Inherited from BindingsCollection)
Protected Method | OnCollectionChanging | Raises the CollectionChanging event. (Inherited from BindingsCollection)
Protected Method | RemoveCore | Overridden. Removes the specified binding from the collection.
Protected Method | ShouldSerializeMyAll | Gets a value that indicates whether the collection should be serialized. (Inherited from BindingsCollection)
Top

See Also

Reference

ControlBindingsCollection Class
Gizmox.WebGUI.Forms Namespace


Add Method

[image]
Gizmox.WebGUI.Forms
Add Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ControlBindingsCollection Class : Add Method

Adds the specified Binding to the collection.

Overload List

Overload | Description
Add(Binding) | Adds the specified Binding to the collection.
Add(String,Object,String) | Creates a Binding using the specified control property name, data source, and data member, and adds it to the collection.
Add(String,Object,String,Boolean) | Creates a binding with the specified control property name, data source, data member, and information about whether formatting is enabled, and adds the binding to the collection.
Add(String,Object,String,Boolean,DataSourceUpdateMode) | Creates a binding that binds the specified control property to the specified data member of the specified data source, optionally enabling formatting, propagating values to the data source based on the specified update setting, and adding the binding to the collection.
Add(String,Object,String,Boolean,DataSourceUpdateMode,Object) | Creates a binding that binds the specified control property to the specified data member of the specified data source, optionally enabling formatting, propagating values to the data source based on the specified update setting, setting the property to the specified value when DBNull is returned from the data source, and adding the binding to the collection.
Add(String,Object,String,Boolean,DataSourceUpdateMode,Object,String) | Creates a binding that binds the specified control property to the specified data member of the specified data source, optionally enabling formatting with the specified format string, propagating values to the data source based on the specified update setting, setting the property to the specified value when DBNull is returned from the data source, and adding the binding to the collection.
Add(String,Object,String,Boolean,DataSourceUpdateMode,Object,String,IFormatProvider) | Creates a binding that binds the specified control property to the specified data member of the specified data source, optionally enabling formatting with the specified format string, propagating values to the data source based on the specified update setting, setting the property to the specified value when DBNull is returned from the data source, setting the specified format provider, and adding the binding to the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ControlBindingsCollection Class
ControlBindingsCollection Members


Add(Binding) Method

[image]
Gizmox.WebGUI.Forms
Add(Binding) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ControlBindingsCollection Class > Add Method : Add(Binding) Method

binding
The Binding to add.
Adds the specified Binding to the collection.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Add( _
   ByVal binding As Binding _
)
Visual Basic (Usage) Copy Code
Dim instance As ControlBindingsCollection
Dim binding As Binding

instance.Add(binding)
C#
public void Add(
   Binding binding
)
Managed Extensions for C++
public: void Add(
   Binding* binding
)
C++/CLI
public:
void Add(
   Binding^ binding
)

Parameters

binding
The Binding to add.

Exceptions

Exception | Description
ArgumentNullException | The binding is null.
ArgumentException | The control property is already data-bound.
ArgumentException | The Binding does not specify a valid column of the Binding.DataSource.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ControlBindingsCollection Class
ControlBindingsCollection Members
Overload List


Add(String,Object,String) Method

[image]
Gizmox.WebGUI.Forms
Add(String,Object,String) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ControlBindingsCollection Class > Add Method : Add(String,Object,String) Method

propertyName
The name of the control property to bind.
dataSource
An Object that represents the data source.
dataMember
The property or list to bind to.
Creates a Binding using the specified control property name, data source, and data member, and adds it to the collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal propertyName As String, _
   ByVal dataSource As Object, _
   ByVal dataMember As String _
) As Binding
Visual Basic (Usage) Copy Code
Dim instance As ControlBindingsCollection
Dim propertyName As String
Dim dataSource As Object
Dim dataMember As String
Dim value As Binding

value = instance.Add(propertyName, dataSource, dataMember)
C#
public Binding Add(
   string propertyName,
   object dataSource,
   string dataMember
)
Managed Extensions for C++
public: Binding* Add(
   string* propertyName,
   Object* dataSource,
   string* dataMember
)
C++/CLI
public:
Binding^ Add(
   String^ propertyName,
   Object^ dataSource,
   String^ dataMember
)

Parameters

propertyName
The name of the control property to bind.
dataSource
An Object that represents the data source.
dataMember
The property or list to bind to.

Return Value

The newly created Binding.

Exceptions

Exception | Description
Exception | The propertyName is already data-bound.
ArgumentNullException | The binding is null.
Exception | The dataMember doesn't specify a valid member of the dataSource.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ControlBindingsCollection Class
ControlBindingsCollection Members
Overload List


Add(String,Object,String,Boolean) Method

[image]
Gizmox.WebGUI.Forms
Add(String,Object,String,Boolean) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ControlBindingsCollection Class > Add Method : Add(String,Object,String,Boolean) Method

propertyName
The name of the control property to bind.
dataSource
An Object representing the data source.
dataMember
The property or list to bind to.
formattingEnabled
true to format the displayed data; otherwise, false
Creates a binding with the specified control property name, data source, data member, and information about whether formatting is enabled, and adds the binding to the collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal propertyName As String, _
   ByVal dataSource As Object, _
   ByVal dataMember As String, _
   ByVal formattingEnabled As Boolean _
) As Binding
Visual Basic (Usage) Copy Code
Dim instance As ControlBindingsCollection
Dim propertyName As String
Dim dataSource As Object
Dim dataMember As String
Dim formattingEnabled As Boolean
Dim value As Binding

value = instance.Add(propertyName, dataSource, dataMember, formattingEnabled)
C#
public Binding Add(
   string propertyName,
   object dataSource,
   string dataMember,
   bool formattingEnabled
)
Managed Extensions for C++
public: Binding* Add(
   string* propertyName,
   Object* dataSource,
   string* dataMember,
   bool formattingEnabled
)
C++/CLI
public:
Binding^ Add(
   String^ propertyName,
   Object^ dataSource,
   String^ dataMember,
   bool formattingEnabled
)

Parameters

propertyName
The name of the control property to bind.
dataSource
An Object representing the data source.
dataMember
The property or list to bind to.
formattingEnabled
true to format the displayed data; otherwise, false

Return Value

The newly created Binding.

Exceptions

Exception | Description
Exception | If formatting is disabled and the propertyName is neither a valid property of a control nor an empty string ("").
ArgumentException | The property given by propertyName does not exist on the control.-or-The property given is a read-only property.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ControlBindingsCollection Class
ControlBindingsCollection Members
Overload List


Add(String,Object,String,Boolean,DataSourceUpdateMode) Method

[image]
Gizmox.WebGUI.Forms
Add(String,Object,String,Boolean,DataSourceUpdateMode) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ControlBindingsCollection Class > Add Method : Add(String,Object,String,Boolean,DataSourceUpdateMode) Method

propertyName
The name of the control property to bind.
dataSource
An Object representing the data source.
dataMember
The property or list to bind to.
formattingEnabled
true to format the displayed data; otherwise, false.
updateMode
One of the DataSourceUpdateMode values.
Creates a binding that binds the specified control property to the specified data member of the specified data source, optionally enabling formatting, propagating values to the data source based on the specified update setting, and adding the binding to the collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal propertyName As String, _
   ByVal dataSource As Object, _
   ByVal dataMember As String, _
   ByVal formattingEnabled As Boolean, _
   ByVal updateMode As DataSourceUpdateMode _
) As Binding
Visual Basic (Usage) Copy Code
Dim instance As ControlBindingsCollection
Dim propertyName As String
Dim dataSource As Object
Dim dataMember As String
Dim formattingEnabled As Boolean
Dim updateMode As DataSourceUpdateMode
Dim value As Binding

value = instance.Add(propertyName, dataSource, dataMember, formattingEnabled, updateMode)
C#
public Binding Add(
   string propertyName,
   object dataSource,
   string dataMember,
   bool formattingEnabled,
   DataSourceUpdateMode updateMode
)
Managed Extensions for C++
public: Binding* Add(
   string* propertyName,
   Object* dataSource,
   string* dataMember,
   bool formattingEnabled,
   DataSourceUpdateMode updateMode
)
C++/CLI
public:
Binding^ Add(
   String^ propertyName,
   Object^ dataSource,
   String^ dataMember,
   bool formattingEnabled,
   DataSourceUpdateMode updateMode
)

Parameters

propertyName
The name of the control property to bind.
dataSource
An Object representing the data source.
dataMember
The property or list to bind to.
formattingEnabled
true to format the displayed data; otherwise, false.
updateMode
One of the DataSourceUpdateMode values.

Return Value

The newly created Binding.

Exceptions

Exception | Description
ArgumentException | The property given by propertyName does not exist on the control or is read-only.-or-The specified data member does not exist on the data source.-or-The data source, data member, or control property specified are associated with another binding in the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ControlBindingsCollection Class
ControlBindingsCollection Members
Overload List


Add(String,Object,String,Boolean,DataSourceUpdateMode,Object) Method

[image]
Gizmox.WebGUI.Forms
Add(String,Object,String,Boolean,DataSourceUpdateMode,Object) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ControlBindingsCollection Class > Add Method : Add(String,Object,String,Boolean,DataSourceUpdateMode,Object) Method

propertyName
The name of the control property to bind.
dataSource
An Object representing the data source.
dataMember
The property or list to bind to.
formattingEnabled
true to format the displayed data; otherwise, false.
updateMode
One of the DataSourceUpdateMode values.
nullValue
The Object to be applied to the bound control property if the data source value is DBNull.
Creates a binding that binds the specified control property to the specified data member of the specified data source, optionally enabling formatting, propagating values to the data source based on the specified update setting, setting the property to the specified value when DBNull is returned from the data source, and adding the binding to the collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal propertyName As String, _
   ByVal dataSource As Object, _
   ByVal dataMember As String, _
   ByVal formattingEnabled As Boolean, _
   ByVal updateMode As DataSourceUpdateMode, _
   ByVal nullValue As Object _
) As Binding
Visual Basic (Usage) Copy Code
Dim instance As ControlBindingsCollection
Dim propertyName As String
Dim dataSource As Object
Dim dataMember As String
Dim formattingEnabled As Boolean
Dim updateMode As DataSourceUpdateMode
Dim nullValue As Object
Dim value As Binding

value = instance.Add(propertyName, dataSource, dataMember, formattingEnabled, updateMode, nullValue)
C#
public Binding Add(
   string propertyName,
   object dataSource,
   string dataMember,
   bool formattingEnabled,
   DataSourceUpdateMode updateMode,
   object nullValue
)
Managed Extensions for C++
public: Binding* Add(
   string* propertyName,
   Object* dataSource,
   string* dataMember,
   bool formattingEnabled,
   DataSourceUpdateMode updateMode,
   Object* nullValue
)
C++/CLI
public:
Binding^ Add(
   String^ propertyName,
   Object^ dataSource,
   String^ dataMember,
   bool formattingEnabled,
   DataSourceUpdateMode updateMode,
   Object^ nullValue
)

Parameters

propertyName
The name of the control property to bind.
dataSource
An Object representing the data source.
dataMember
The property or list to bind to.
formattingEnabled
true to format the displayed data; otherwise, false.
updateMode
One of the DataSourceUpdateMode values.
nullValue
The Object to be applied to the bound control property if the data source value is DBNull.

Return Value

The newly created Binding

Exceptions

Exception | Description
ArgumentException | The property given by propertyName does not exist on the control or is read-only.-or-The specified data member does not exist on the data source.-or-The data source, data member, or control property specified are associated with another binding in the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ControlBindingsCollection Class
ControlBindingsCollection Members
Overload List


Add(String,Object,String,Boolean,DataSourceUpdateMode,Object,String) Method

[image]
Gizmox.WebGUI.Forms
Add(String,Object,String,Boolean,DataSourceUpdateMode,Object,String) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ControlBindingsCollection Class > Add Method : Add(String,Object,String,Boolean,DataSourceUpdateMode,Object,String) Method

propertyName
The name of the control property to bind.
dataSource
An Object representing the data source.
dataMember
The property or list to bind to.
formattingEnabled
true to format the displayed data; otherwise, false.
updateMode
One of the DataSourceUpdateMode values.
nullValue
The Object to be applied to the bound control property if the data source value is DBNull.
formatString
One or more format specifier characters that indicate how a value is to be displayed.
Creates a binding that binds the specified control property to the specified data member of the specified data source, optionally enabling formatting with the specified format string, propagating values to the data source based on the specified update setting, setting the property to the specified value when DBNull is returned from the data source, and adding the binding to the collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal propertyName As String, _
   ByVal dataSource As Object, _
   ByVal dataMember As String, _
   ByVal formattingEnabled As Boolean, _
   ByVal updateMode As DataSourceUpdateMode, _
   ByVal nullValue As Object, _
   ByVal formatString As String _
) As Binding
Visual Basic (Usage) Copy Code
Dim instance As ControlBindingsCollection
Dim propertyName As String
Dim dataSource As Object
Dim dataMember As String
Dim formattingEnabled As Boolean
Dim updateMode As DataSourceUpdateMode
Dim nullValue As Object
Dim formatString As String
Dim value As Binding

value = instance.Add(propertyName, dataSource, dataMember, formattingEnabled, updateMode, nullValue, formatString)
C#
public Binding Add(
   string propertyName,
   object dataSource,
   string dataMember,
   bool formattingEnabled,
   DataSourceUpdateMode updateMode,
   object nullValue,
   string formatString
)
Managed Extensions for C++
public: Binding* Add(
   string* propertyName,
   Object* dataSource,
   string* dataMember,
   bool formattingEnabled,
   DataSourceUpdateMode updateMode,
   Object* nullValue,
   string* formatString
)
C++/CLI
public:
Binding^ Add(
   String^ propertyName,
   Object^ dataSource,
   String^ dataMember,
   bool formattingEnabled,
   DataSourceUpdateMode updateMode,
   Object^ nullValue,
   String^ formatString
)

Parameters

propertyName
The name of the control property to bind.
dataSource
An Object representing the data source.
dataMember
The property or list to bind to.
formattingEnabled
true to format the displayed data; otherwise, false.
updateMode
One of the DataSourceUpdateMode values.
nullValue
The Object to be applied to the bound control property if the data source value is DBNull.
formatString
One or more format specifier characters that indicate how a value is to be displayed.

Return Value

The newly created Binding

Exceptions

Exception | Description
ArgumentException | The property given by propertyName does not exist on the control or is read-only.-or-The specified data member does not exist on the data source.-or-The data source, data member, or control property specified are associated with another binding in the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ControlBindingsCollection Class
ControlBindingsCollection Members
Overload List


Add(String,Object,String,Boolean,DataSourceUpdateMode,Object,String,IFormatProvider) Method

[image]
Gizmox.WebGUI.Forms
Add(String,Object,String,Boolean,DataSourceUpdateMode,Object,String,IFormatProvider) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ControlBindingsCollection Class > Add Method : Add(String,Object,String,Boolean,DataSourceUpdateMode,Object,String,IFormatProvider) Method

propertyName
The name of the control property to bind.
dataSource
An Object representing the data source.
dataMember
The property or list to bind to.
formattingEnabled
true to format the displayed data; otherwise, false.
updateMode
One of the DataSourceUpdateMode values.
nullValue
The Object to be applied to the bound control property if the data source value is DBNull.
formatString
One or more format specifier characters that indicate how a value is to be displayed
formatInfo
An implementation of IFormatProvider to override default formatting behavior.
Creates a binding that binds the specified control property to the specified data member of the specified data source, optionally enabling formatting with the specified format string, propagating values to the data source based on the specified update setting, setting the property to the specified value when DBNull is returned from the data source, setting the specified format provider, and adding the binding to the collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal propertyName As String, _
   ByVal dataSource As Object, _
   ByVal dataMember As String, _
   ByVal formattingEnabled As Boolean, _
   ByVal updateMode As DataSourceUpdateMode, _
   ByVal nullValue As Object, _
   ByVal formatString As String, _
   ByVal formatInfo As IFormatProvider _
) As Binding
Visual Basic (Usage) Copy Code
Dim instance As ControlBindingsCollection
Dim propertyName As String
Dim dataSource As Object
Dim dataMember As String
Dim formattingEnabled As Boolean
Dim updateMode As DataSourceUpdateMode
Dim nullValue As Object
Dim formatString As String
Dim formatInfo As IFormatProvider
Dim value As Binding

value = instance.Add(propertyName, dataSource, dataMember, formattingEnabled, updateMode, nullValue, formatString, formatInfo)
C#
public Binding Add(
   string propertyName,
   object dataSource,
   string dataMember,
   bool formattingEnabled,
   DataSourceUpdateMode updateMode,
   object nullValue,
   string formatString,
   IFormatProvider formatInfo
)
Managed Extensions for C++
public: Binding* Add(
   string* propertyName,
   Object* dataSource,
   string* dataMember,
   bool formattingEnabled,
   DataSourceUpdateMode updateMode,
   Object* nullValue,
   string* formatString,
   IFormatProvider* formatInfo
)
C++/CLI
public:
Binding^ Add(
   String^ propertyName,
   Object^ dataSource,
   String^ dataMember,
   bool formattingEnabled,
   DataSourceUpdateMode updateMode,
   Object^ nullValue,
   String^ formatString,
   IFormatProvider^ formatInfo
)

Parameters

propertyName
The name of the control property to bind.
dataSource
An Object representing the data source.
dataMember
The property or list to bind to.
formattingEnabled
true to format the displayed data; otherwise, false.
updateMode
One of the DataSourceUpdateMode values.
nullValue
The Object to be applied to the bound control property if the data source value is DBNull.
formatString
One or more format specifier characters that indicate how a value is to be displayed
formatInfo
An implementation of IFormatProvider to override default formatting behavior.

Return Value

The newly created Binding.

Exceptions

Exception | Description
ArgumentException | The property given by propertyName does not exist on the control or is read-only.-or-The specified data member does not exist on the data source.-or-The data source, data member, or control property specified are associated with another binding in the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ControlBindingsCollection Class
ControlBindingsCollection Members
Overload List


AddCore Method

[image]
Gizmox.WebGUI.Forms
AddCore Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ControlBindingsCollection Class : AddCore Method

dataBinding
The Binding to add.
Adds a binding to the collection.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub AddCore( _
   ByVal dataBinding As Binding _
)
Visual Basic (Usage) Copy Code
Dim instance As ControlBindingsCollection
Dim dataBinding As Binding

instance.AddCore(dataBinding)
C#
protected override void AddCore(
   Binding dataBinding
)
Managed Extensions for C++
protected: void AddCore(
   Binding* dataBinding
) override
C++/CLI
protected:
void AddCore(
   Binding^ dataBinding
) override

Parameters

dataBinding
The Binding to add.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ControlBindingsCollection Class
ControlBindingsCollection Members


Clear Method

[image]
Gizmox.WebGUI.Forms
Clear Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ControlBindingsCollection Class : Clear Method

Clears the collection of any bindings.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As ControlBindingsCollection

instance.Clear()
C#
public void Clear()
Managed Extensions for C++
public: void Clear();
C++/CLI
public:
void Clear();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ControlBindingsCollection Class
ControlBindingsCollection Members


ClearCore Method

[image]
Gizmox.WebGUI.Forms
ClearCore Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ControlBindingsCollection Class : ClearCore Method

Clears the bindings in the collection.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub ClearCore()
Visual Basic (Usage) Copy Code
Dim instance As ControlBindingsCollection

instance.ClearCore()
C#
protected override void ClearCore()
Managed Extensions for C++
protected: void ClearCore(); override
C++/CLI
protected:
void ClearCore(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ControlBindingsCollection Class
ControlBindingsCollection Members


Remove Method

[image]
Gizmox.WebGUI.Forms
Remove Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ControlBindingsCollection Class : Remove Method

binding
The Binding to remove.
Deletes the specified Binding from the collection.

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal binding As Binding _
)
Visual Basic (Usage) Copy Code
Dim instance As ControlBindingsCollection
Dim binding As Binding

instance.Remove(binding)
C#
public void Remove(
   Binding binding
)
Managed Extensions for C++
public: void Remove(
   Binding* binding
)
C++/CLI
public:
void Remove(
   Binding^ binding
)

Parameters

binding
The Binding to remove.

Exceptions

Exception | Description
NullReferenceException | The binding is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ControlBindingsCollection Class
ControlBindingsCollection Members


RemoveAt Method

[image]
Gizmox.WebGUI.Forms
RemoveAt Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ControlBindingsCollection Class : RemoveAt Method

index
The zero-based index of the item to remove.
Deletes the Binding at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As ControlBindingsCollection
Dim index As Integer

instance.RemoveAt(index)
C#
public void RemoveAt(
   int index
)
Managed Extensions for C++
public: void RemoveAt(
   int index
)
C++/CLI
public:
void RemoveAt(
   int index
)

Parameters

index
The zero-based index of the item to remove.

Exceptions

Exception | Description
ArgumentOutOfRangeException | The index value is less than 0, or it is greater than the number of bindings in the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ControlBindingsCollection Class
ControlBindingsCollection Members


RemoveCore Method

[image]
Gizmox.WebGUI.Forms
RemoveCore Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ControlBindingsCollection Class : RemoveCore Method

dataBinding
The Binding to remove from the collection.
Removes the specified binding from the collection.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub RemoveCore( _
   ByVal dataBinding As Binding _
)
Visual Basic (Usage) Copy Code
Dim instance As ControlBindingsCollection
Dim dataBinding As Binding

instance.RemoveCore(dataBinding)
C#
protected override void RemoveCore(
   Binding dataBinding
)
Managed Extensions for C++
protected: void RemoveCore(
   Binding* dataBinding
) override
C++/CLI
protected:
void RemoveCore(
   Binding^ dataBinding
) override

Parameters

dataBinding
The Binding to remove from the collection.

Exceptions

Exception | Description
ArgumentException | The binding belongs to another ControlBindingsCollection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ControlBindingsCollection Class
ControlBindingsCollection Members


ControlBindingsCollection Class Properties

[image]
Gizmox.WebGUI.Forms
ControlBindingsCollection Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ControlBindingsCollection Class

For a list of all members of this type, see ControlBindingsCollection members.

Public Properties

 | Name | Description
Public Property | BindableComponent | Gets the IBindableComponent the binding collection belongs to.
Public Property | Control | Gets the control that the collection belongs to.
Public Property | Count | Gets the total number of bindings in the collection. (Inherited from BindingsCollection)
Public Property | DefaultDataSourceUpdateMode | Gets or sets the default Binding.DataSourceUpdateMode for a Binding in the collection.
Public Property | IsReadOnly | Gets a value indicating whether the collection is read-only. (Inherited from BaseCollection)
Public Property | IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized. (Inherited from BaseCollection)
Public Property | Item | Overloaded. Gets the Binding specified by the control's property name.
Public Property | SyncRoot | Gets an object that can be used to synchronize access to the BaseCollection. (Inherited from BaseCollection)
Top

Protected Properties

 | Name | Description
Protected Property | List | Gets the bindings in the collection as an object. (Inherited from BindingsCollection)
Top

See Also

Reference

ControlBindingsCollection Class
Gizmox.WebGUI.Forms Namespace


BindableComponent Property

[image]
Gizmox.WebGUI.Forms
BindableComponent Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ControlBindingsCollection Class : BindableComponent Property

Gets the IBindableComponent the binding collection belongs to.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property BindableComponent As IBindableComponent
Visual Basic (Usage) Copy Code
Dim instance As ControlBindingsCollection
Dim value As IBindableComponent

value = instance.BindableComponent
C#
public IBindableComponent BindableComponent {get;}
Managed Extensions for C++
public: __property IBindableComponent* get_BindableComponent();
C++/CLI
public:
property IBindableComponent^ BindableComponent {
   IBindableComponent^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ControlBindingsCollection Class
ControlBindingsCollection Members


Control Property

[image]
Gizmox.WebGUI.Forms
Control Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ControlBindingsCollection Class : Control Property

Gets the control that the collection belongs to.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Control As Control
Visual Basic (Usage) Copy Code
Dim instance As ControlBindingsCollection
Dim value As Control

value = instance.Control
C#
public Control Control {get;}
Managed Extensions for C++
public: __property Control* get_Control();
C++/CLI
public:
property Control^ Control {
   Control^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ControlBindingsCollection Class
ControlBindingsCollection Members


DefaultDataSourceUpdateMode Property

[image]
Gizmox.WebGUI.Forms
DefaultDataSourceUpdateMode Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ControlBindingsCollection Class : DefaultDataSourceUpdateMode Property

Gets or sets the default Binding.DataSourceUpdateMode for a Binding in the collection.

Syntax

Visual Basic (Declaration)
Public Property DefaultDataSourceUpdateMode As DataSourceUpdateMode
Visual Basic (Usage) Copy Code
Dim instance As ControlBindingsCollection
Dim value As DataSourceUpdateMode

instance.DefaultDataSourceUpdateMode = value

value = instance.DefaultDataSourceUpdateMode
C#
public DataSourceUpdateMode DefaultDataSourceUpdateMode {get; set;}
Managed Extensions for C++
public: __property DataSourceUpdateMode get_DefaultDataSourceUpdateMode();
public: __property void set_DefaultDataSourceUpdateMode(
   DataSourceUpdateMode value
);
C++/CLI
public:
property DataSourceUpdateMode DefaultDataSourceUpdateMode {
   DataSourceUpdateMode get();
   void set (DataSourceUpdateModevalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ControlBindingsCollection Class
ControlBindingsCollection Members


Item Property

[image]
Gizmox.WebGUI.Forms
Item Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ControlBindingsCollection Class : Item Property

Gets the Binding specified by the control's property name.

Overload List

Overload | Description
Item(String) | Gets the Binding specified by the control's property name.
Item(Int32) | Gets the Binding at the specified index. (Inherited from BindingsCollection)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ControlBindingsCollection Class
ControlBindingsCollection Members


Item(String) Property

[image]
Gizmox.WebGUI.Forms
Item(String) Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ControlBindingsCollection Class > Item Property : Item(String) Property

propertyName
The name of the property on the data-bound control.
Gets the Binding specified by the control's property name.

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal propertyName As String _
) As Binding
Visual Basic (Usage) Copy Code
Dim instance As ControlBindingsCollection
Dim propertyName As String
Dim value As Binding

value = instance.Item(propertyName)
C#
public Binding Item(
   string propertyName
) {get;}
Managed Extensions for C++
public: __property Binding* get_Item(
   string* propertyName
);
C++/CLI
public:
property Binding^ Item {
   Binding^ get(String^propertyName);
}

Parameters

propertyName
The name of the property on the data-bound control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ControlBindingsCollection Class
ControlBindingsCollection Members
Overload List


ControlCollection Class

[image]
Gizmox.WebGUI.Forms
ControlCollection Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ControlCollection Class

Contains a collection of Control objects.

Object Model

Syntax

Visual Basic (Declaration)
Public Class ControlCollection
   Inherits Control.ControlCollection
   Implements IObservableList
Visual Basic (Usage) Copy Code
Dim instance As ControlCollection
C#
public class ControlCollection : Control.ControlCollection, IObservableList
Managed Extensions for C++
public __gc class ControlCollection : public Control.ControlCollection, IObservableList
C++/CLI
public ref class ControlCollection : public Control::ControlCollection, IObservableList

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.Layout.ArrangedElementCollection
Gizmox.WebGUI.Forms.Control.ControlCollection
Gizmox.WebGUI.Forms.ControlCollection

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

ControlCollection Members
Gizmox.WebGUI.Forms Namespace


ControlCollection Class Members

[image]
Gizmox.WebGUI.Forms
ControlCollection Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : ControlCollection Class

The following tables list the members exposed by ControlCollection.

Public Constructors

 | Name | Description
Public Constructor | ControlCollection Constructor | Initializes a new instance of the ControlCollection class.
Top

Public Properties

 | Name | Description
Public Property | Count | (Inherited from Control.ControlCollection)
Public Property | IsFixedSize | (Inherited from Control.ControlCollection)
Public Property | IsReadOnly | (Inherited from Control.ControlCollection)
Public Property | Item | Overloaded. Indicates a Control with the specified key in the collection. (Inherited from Control.ControlCollection)
Public Property | Owner | Gets the control that owns this Control.ControlCollection. (Inherited from Control.ControlCollection)
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Overridden. Adds a Control to the collection.
Public Method | AddRange | Adds an array of control objects to the collection. (Inherited from Control.ControlCollection)
Public Method | Clear | Removes all controls from the collection. (Inherited from Control.ControlCollection)
Public Method | Contains | Determines whether the specified control is a member of the collection. (Inherited from Control.ControlCollection)
Public Method | ContainsKey | Determines whether the Control.ControlCollection contains an item with the specified key. (Inherited from Control.ControlCollection)
Public Method | CopyTo | Copies the entire contents of this collection to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Gizmox.WebGUI.Forms.Layout.ArrangedElementCollection)
Public Method | Equals | Determines whether two ArrangedElementCollection instances are equal. (Inherited from Gizmox.WebGUI.Forms.Layout.ArrangedElementCollection)
Public Method | Find | Searches for controls by their Control.Name property and builds an array of all the controls that match. (Inherited from Control.ControlCollection)
Public Method | GetChildIndex | Overloaded. Retrieves the index of the specified child control within the control collection. (Inherited from Control.ControlCollection)
Public Method | GetEnumerator | Retrieves a reference to an enumerator object that is used to iterate over a Control.ControlCollection. (Inherited from Control.ControlCollection)
Public Method | GetHashCode | Returns the hash code for this instance. (Inherited from Gizmox.WebGUI.Forms.Layout.ArrangedElementCollection)
Public Method | IndexOf | Retrieves the index of the specified control in the control collection. (Inherited from Control.ControlCollection)
Public Method | IndexOfKey | Retrieves the index of the first occurrence of the specified item within the collection. (Inherited from Control.ControlCollection)
Public Method | Insert | (Inherited from Control.ControlCollection)
Public Method | Remove | Overridden. Removes a Control from the collection.
Public Method | RemoveAt | Removes a control from the control collection at the specified indexed location. (Inherited from Control.ControlCollection)
Public Method | RemoveByKey | Removes the child control with the specified key. (Inherited from Control.ControlCollection)
Public Method | SetChildIndex | Sets the index of the specified child control in the collection to the specified index value. (Inherited from Control.ControlCollection)
Top

See Also

Reference

ControlCollection Class
Gizmox.WebGUI.Forms Namespace


ControlCollection Constructor

[image]
Gizmox.WebGUI.Forms
ControlCollection Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ControlCollection Class : ControlCollection Constructor

owner
The TabControl that this collection belongs to.
Initializes a new instance of the ControlCollection class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal owner As TabControl _
)
Visual Basic (Usage) Copy Code
Dim owner As TabControl

Dim instance As ControlCollection(owner)
C#
public ControlCollection(
   TabControl owner
)
Managed Extensions for C++
public: ControlCollection(
   TabControl* owner
)
C++/CLI
public:
ControlCollection(
   TabControl^ owner
)

Parameters

owner
The TabControl that this collection belongs to.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ControlCollection Class
ControlCollection Members


ControlCollection Class Methods

[image]
Gizmox.WebGUI.Forms
ControlCollection Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ControlCollection Class

For a list of all members of this type, see ControlCollection members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Overridden. Adds a Control to the collection.
Public Method | AddRange | Adds an array of control objects to the collection. (Inherited from Control.ControlCollection)
Public Method | Clear | Removes all controls from the collection. (Inherited from Control.ControlCollection)
Public Method | Contains | Determines whether the specified control is a member of the collection. (Inherited from Control.ControlCollection)
Public Method | ContainsKey | Determines whether the Control.ControlCollection contains an item with the specified key. (Inherited from Control.ControlCollection)
Public Method | CopyTo | Copies the entire contents of this collection to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Gizmox.WebGUI.Forms.Layout.ArrangedElementCollection)
Public Method | Equals | Determines whether two ArrangedElementCollection instances are equal. (Inherited from Gizmox.WebGUI.Forms.Layout.ArrangedElementCollection)
Public Method | Find | Searches for controls by their Control.Name property and builds an array of all the controls that match. (Inherited from Control.ControlCollection)
Public Method | GetChildIndex | Overloaded. Retrieves the index of the specified child control within the control collection. (Inherited from Control.ControlCollection)
Public Method | GetEnumerator | Retrieves a reference to an enumerator object that is used to iterate over a Control.ControlCollection. (Inherited from Control.ControlCollection)
Public Method | GetHashCode | Returns the hash code for this instance. (Inherited from Gizmox.WebGUI.Forms.Layout.ArrangedElementCollection)
Public Method | IndexOf | Retrieves the index of the specified control in the control collection. (Inherited from Control.ControlCollection)
Public Method | IndexOfKey | Retrieves the index of the first occurrence of the specified item within the collection. (Inherited from Control.ControlCollection)
Public Method | Insert | (Inherited from Control.ControlCollection)
Public Method | Remove | Overridden. Removes a Control from the collection.
Public Method | RemoveAt | Removes a control from the control collection at the specified indexed location. (Inherited from Control.ControlCollection)
Public Method | RemoveByKey | Removes the child control with the specified key. (Inherited from Control.ControlCollection)
Public Method | SetChildIndex | Sets the index of the specified child control in the collection to the specified index value. (Inherited from Control.ControlCollection)
Top

See Also

Reference

ControlCollection Class
Gizmox.WebGUI.Forms Namespace


Add Method

[image]
Gizmox.WebGUI.Forms
Add Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ControlCollection Class : Add Method

Adds a Control to the collection.

Overload List

Overload | Description
Add(Control) | Adds a Control to the collection.
Add(Control,Boolean) | Adds the specified control to the control collection. (Inherited from Control.ControlCollection)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ControlCollection Class
ControlCollection Members


Add(Control) Method

[image]
Gizmox.WebGUI.Forms
Add(Control) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ControlCollection Class > Add Method : Add(Control) Method

value
The Control to add.
Adds a Control to the collection.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Sub Add( _
   ByVal value As Control _
)
Visual Basic (Usage) Copy Code
Dim instance As ControlCollection
Dim value As Control

instance.Add(value)
C#
public override void Add(
   Control value
)
Managed Extensions for C++
public: void Add(
   Control* value
) override
C++/CLI
public:
void Add(
   Control^ value
) override

Parameters

value
The Control to add.

Exceptions

Exception | Description
Exception | The specified Control is a TabPage.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ControlCollection Class
ControlCollection Members
Overload List


Remove Method

[image]
Gizmox.WebGUI.Forms
Remove Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ControlCollection Class : Remove Method

value
The Control to remove.
Removes a Control from the collection.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Remove( _
   ByVal value As Control _
)
Visual Basic (Usage) Copy Code
Dim instance As ControlCollection
Dim value As Control

instance.Remove(value)
C#
public override void Remove(
   Control value
)
Managed Extensions for C++
public: void Remove(
   Control* value
) override
C++/CLI
public:
void Remove(
   Control^ value
) override

Parameters

value
The Control to remove.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ControlCollection Class
ControlCollection Members


ControlEventArgs Class

[image]
Gizmox.WebGUI.Forms
ControlEventArgs Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ControlEventArgs Class

Control event arguments

Object Model

Syntax

Visual Basic (Declaration)
Public Class ControlEventArgs
   Inherits EventArgs
Visual Basic (Usage) Copy Code
Dim instance As ControlEventArgs
C#
public class ControlEventArgs : EventArgs
Managed Extensions for C++
public __gc class ControlEventArgs : public EventArgs
C++/CLI
public ref class ControlEventArgs : public EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gizmox.WebGUI.Forms.ControlEventArgs

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

ControlEventArgs Members
Gizmox.WebGUI.Forms Namespace


ControlEventArgs Class Members

[image]
Gizmox.WebGUI.Forms
ControlEventArgs Class Members
See Also Properties Send Feedback
Gizmox.WebGUI.Forms Namespace : ControlEventArgs Class

The following tables list the members exposed by ControlEventArgs.

Public Constructors

 | Name | Description
Public Constructor | ControlEventArgs Constructor | Creates a new ControlEventArgs instance.
Top

Public Properties

 | Name | Description
Public Property | Control | Gets the control.
Top

See Also

Reference

ControlEventArgs Class
Gizmox.WebGUI.Forms Namespace


ControlEventArgs Constructor

[image]
Gizmox.WebGUI.Forms
ControlEventArgs Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ControlEventArgs Class : ControlEventArgs Constructor

objControl
control.
Creates a new ControlEventArgs instance.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal objControl As Control _
)
Visual Basic (Usage) Copy Code
Dim objControl As Control

Dim instance As ControlEventArgs(objControl)
C#
public ControlEventArgs(
   Control objControl
)
Managed Extensions for C++
public: ControlEventArgs(
   Control* objControl
)
C++/CLI
public:
ControlEventArgs(
   Control^ objControl
)

Parameters

objControl
control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ControlEventArgs Class
ControlEventArgs Members


ControlEventArgs Class Properties

[image]
Gizmox.WebGUI.Forms
ControlEventArgs Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ControlEventArgs Class

For a list of all members of this type, see ControlEventArgs members.

Public Properties

 | Name | Description
Public Property | Control | Gets the control.
Top

See Also

Reference

ControlEventArgs Class
Gizmox.WebGUI.Forms Namespace


Control Property

[image]
Gizmox.WebGUI.Forms
Control Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ControlEventArgs Class : Control Property

Gets the control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Control As Control
Visual Basic (Usage) Copy Code
Dim instance As ControlEventArgs
Dim value As Control

value = instance.Control
C#
public Control Control {get;}
Managed Extensions for C++
public: __property Control* get_Control();
C++/CLI
public:
property Control^ Control {
   Control^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ControlEventArgs Class
ControlEventArgs Members


ConvertEventArgs Class

[image]
Gizmox.WebGUI.Forms
ConvertEventArgs Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ConvertEventArgs Class

Provides data for the Format and Parse events.

Syntax

Visual Basic (Declaration)
Public Class ConvertEventArgs
   Inherits EventArgs
Visual Basic (Usage) Copy Code
Dim instance As ConvertEventArgs
C#
public class ConvertEventArgs : EventArgs
Managed Extensions for C++
public __gc class ConvertEventArgs : public EventArgs
C++/CLI
public ref class ConvertEventArgs : public EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gizmox.WebGUI.Forms.ConvertEventArgs
Gizmox.WebGUI.Forms.DataGridViewCellFormattingEventArgs
Gizmox.WebGUI.Forms.DataGridViewCellParsingEventArgs
Gizmox.WebGUI.Forms.ListControlConvertEventArgs

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

ConvertEventArgs Members
Gizmox.WebGUI.Forms Namespace


ConvertEventArgs Class Members

[image]
Gizmox.WebGUI.Forms
ConvertEventArgs Class Members
See Also Properties Send Feedback
Gizmox.WebGUI.Forms Namespace : ConvertEventArgs Class

The following tables list the members exposed by ConvertEventArgs.

Public Constructors

 | Name | Description
Public Constructor | ConvertEventArgs Constructor | Initializes a new instance of the ConvertEventArgs class.
Top

Public Properties

 | Name | Description
Public Property | DesiredType | Gets the data type of the desired value.
Public Property | Value | Gets or sets the value of the ConvertEventArgs.
Top

See Also

Reference

ConvertEventArgs Class
Gizmox.WebGUI.Forms Namespace


ConvertEventArgs Constructor

[image]
Gizmox.WebGUI.Forms
ConvertEventArgs Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ConvertEventArgs Class : ConvertEventArgs Constructor

value
An Object that contains the value of the current property.
desiredType
The Type of the value.
Initializes a new instance of the ConvertEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As Object, _
   ByVal desiredType As Type _
)
Visual Basic (Usage) Copy Code
Dim value As Object
Dim desiredType As Type

Dim instance As ConvertEventArgs(value, desiredType)
C#
public ConvertEventArgs(
   object value,
   Type desiredType
)
Managed Extensions for C++
public: ConvertEventArgs(
   Object* value,
   Type* desiredType
)
C++/CLI
public:
ConvertEventArgs(
   Object^ value,
   Type^ desiredType
)

Parameters

value
An Object that contains the value of the current property.
desiredType
The Type of the value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ConvertEventArgs Class
ConvertEventArgs Members


ConvertEventArgs Class Properties

[image]
Gizmox.WebGUI.Forms
ConvertEventArgs Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ConvertEventArgs Class

For a list of all members of this type, see ConvertEventArgs members.

Public Properties

 | Name | Description
Public Property | DesiredType | Gets the data type of the desired value.
Public Property | Value | Gets or sets the value of the ConvertEventArgs.
Top

See Also

Reference

ConvertEventArgs Class
Gizmox.WebGUI.Forms Namespace


DesiredType Property

[image]
Gizmox.WebGUI.Forms
DesiredType Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ConvertEventArgs Class : DesiredType Property

Gets the data type of the desired value.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DesiredType As Type
Visual Basic (Usage) Copy Code
Dim instance As ConvertEventArgs
Dim value As Type

value = instance.DesiredType
C#
public Type DesiredType {get;}
Managed Extensions for C++
public: __property Type* get_DesiredType();
C++/CLI
public:
property Type^ DesiredType {
   Type^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ConvertEventArgs Class
ConvertEventArgs Members


Value Property

[image]
Gizmox.WebGUI.Forms
Value Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ConvertEventArgs Class : Value Property

Gets or sets the value of the ConvertEventArgs.

Syntax

Visual Basic (Declaration)
Public Property Value As Object
Visual Basic (Usage) Copy Code
Dim instance As ConvertEventArgs
Dim value As Object

instance.Value = value

value = instance.Value
C#
public object Value {get; set;}
Managed Extensions for C++
public: __property Object* get_Value();
public: __property void set_Value(
   Object* value
);
C++/CLI
public:
property Object^ Value {
   Object^ get();
   void set (Object^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ConvertEventArgs Class
ConvertEventArgs Members


CurrencyManager Class

[image]
Gizmox.WebGUI.Forms
CurrencyManager Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : CurrencyManager Class

Manages a list of Binding objects.

Object Model

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class CurrencyManager
   Inherits BindingManagerBase
Visual Basic (Usage) Copy Code
Dim instance As CurrencyManager
C#
[DefaultMemberAttribute("Item")]
public class CurrencyManager : BindingManagerBase
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
public __gc class CurrencyManager : public BindingManagerBase
C++/CLI
[DefaultMemberAttribute("Item")]
public ref class CurrencyManager : public BindingManagerBase

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.BindingManagerBase
Gizmox.WebGUI.Forms.CurrencyManager

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

CurrencyManager Members
Gizmox.WebGUI.Forms Namespace


CurrencyManager Class Members

[image]
Gizmox.WebGUI.Forms
CurrencyManager Class Members
See Also Fields Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : CurrencyManager Class

The following tables list the members exposed by CurrencyManager.

Protected Fields

 | Name | Description
Protected Field | finalType | Specifies the data type of the list.
Protected Field | listposition | Specifies the current position of the CurrencyManager in the list.
Top

Public Properties

 | Name | Description
Public Property | Bindings | Gets the collection of bindings being managed. (Inherited from BindingManagerBase)
Public Property | Count | Overridden. Gets the number of items in the list.
Public Property | Current | Overridden. Gets the current item in the list.
Public Property | IsBindingSuspended | Gets a value indicating whether binding is suspended. (Inherited from BindingManagerBase)
Public Property | List | Gets the list for this CurrencyManager.
Public Property | Position | Overridden. Gets or sets the position you are at within the list.
Top

Public Methods

 | Name | Description
Public Method | AddNew | Overridden. Adds a new item to the underlying list.
Public Method | CancelCurrentEdit | Overridden. Cancels the current edit operation.
Public Method | EndCurrentEdit | Overridden. Ends the current edit operation.
Public Method | GetItemProperties | Overloaded. Overridden. Gets the property descriptor collection for the underlying list.
Public Method | Refresh | Forces a repopulation of the data-bound list.
Public Method | RemoveAt | Overridden. Removes the item at the specified index.
Public Method | ResumeBinding | Overridden. Resumes data binding.
Public Method | SuspendBinding | Overridden. Suspends data binding to prevents changes from updating the bound data source.
Top

Protected Methods

 | Name | Description
Protected Method | CheckEmpty | Throws an exception if there is no list, or the list is empty.
Protected Method | FireCurrentChanged | (Inherited from BindingManagerBase)
Protected Method | FireCurrentItemChanged | (Inherited from BindingManagerBase)
Protected Method | FirePositionChanged | (Inherited from BindingManagerBase)
Protected Method | GetListName | Overridden. Gets the name of the list supplying the data for the binding using the specified set of bound properties.
Protected Method | OnBindingComplete | Raises the BindingComplete event. (Inherited from BindingManagerBase)
Protected Method | OnCurrentChanged | Overridden.
Protected Method | OnCurrentItemChanged | Overridden.
Protected Method | OnDataError | Raises the DataError event. (Inherited from BindingManagerBase)
Protected Method | OnItemChanged | Raises the ItemChanged event.
Protected Method | OnMetaDataChanged | Raises the MetaDataChanged event.
Protected Method | OnPositionChanged | Raises the BindingManagerBase.PositionChanged event.
Protected Method | PullData | Pulls data from the data-bound control into the data source, returning no information. (Inherited from BindingManagerBase)
Protected Method | PushData | Pushes data from the data source into the data-bound control, returning no information. (Inherited from BindingManagerBase)
Protected Method | UpdateIsBinding | Overridden. Updates the status of the binding.
Top

Public Events

 | Name | Description
Public Event | BindingComplete | Occurs at the completion of a data-binding operation. (Inherited from BindingManagerBase)
Public Event | CurrentChanged | Occurs when the currently bound item changes. (Inherited from BindingManagerBase)
Public Event | CurrentItemChanged | Occurs when the state of the currently bound item changes. (Inherited from BindingManagerBase)
Public Event | DataError | Occurs when an Exception is silently handled by the BindingManagerBase. (Inherited from BindingManagerBase)
Public Event | ItemChanged | Occurs when the current item has been altered.
Public Event | ListChanged | Occurs when the list changes or an item in the list changes.
Public Event | MetaDataChanged | Occurs when the metadata of the List has changed.
Public Event | PositionChanged | Occurs after the value of the Position property has changed. (Inherited from BindingManagerBase)
Top

See Also

Reference

CurrencyManager Class
Gizmox.WebGUI.Forms Namespace


CurrencyManager Class Methods

[image]
Gizmox.WebGUI.Forms
CurrencyManager Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : CurrencyManager Class

For a list of all members of this type, see CurrencyManager members.

Public Methods

 | Name | Description
Public Method | AddNew | Overridden. Adds a new item to the underlying list.
Public Method | CancelCurrentEdit | Overridden. Cancels the current edit operation.
Public Method | EndCurrentEdit | Overridden. Ends the current edit operation.
Public Method | GetItemProperties | Overloaded. Overridden. Gets the property descriptor collection for the underlying list.
Public Method | Refresh | Forces a repopulation of the data-bound list.
Public Method | RemoveAt | Overridden. Removes the item at the specified index.
Public Method | ResumeBinding | Overridden. Resumes data binding.
Public Method | SuspendBinding | Overridden. Suspends data binding to prevents changes from updating the bound data source.
Top

Protected Methods

 | Name | Description
Protected Method | CheckEmpty | Throws an exception if there is no list, or the list is empty.
Protected Method | FireCurrentChanged | (Inherited from BindingManagerBase)
Protected Method | FireCurrentItemChanged | (Inherited from BindingManagerBase)
Protected Method | FirePositionChanged | (Inherited from BindingManagerBase)
Protected Method | GetListName | Overridden. Gets the name of the list supplying the data for the binding using the specified set of bound properties.
Protected Method | OnBindingComplete | Raises the BindingComplete event. (Inherited from BindingManagerBase)
Protected Method | OnCurrentChanged | Overridden.
Protected Method | OnCurrentItemChanged | Overridden.
Protected Method | OnDataError | Raises the DataError event. (Inherited from BindingManagerBase)
Protected Method | OnItemChanged | Raises the ItemChanged event.
Protected Method | OnMetaDataChanged | Raises the MetaDataChanged event.
Protected Method | OnPositionChanged | Raises the BindingManagerBase.PositionChanged event.
Protected Method | PullData | Pulls data from the data-bound control into the data source, returning no information. (Inherited from BindingManagerBase)
Protected Method | PushData | Pushes data from the data source into the data-bound control, returning no information. (Inherited from BindingManagerBase)
Protected Method | UpdateIsBinding | Overridden. Updates the status of the binding.
Top

See Also

Reference

CurrencyManager Class
Gizmox.WebGUI.Forms Namespace


AddNew Method

[image]
Gizmox.WebGUI.Forms
AddNew Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CurrencyManager Class : AddNew Method

Adds a new item to the underlying list.

Syntax

Visual Basic (Declaration)
Public Overrides Sub AddNew()
Visual Basic (Usage) Copy Code
Dim instance As CurrencyManager

instance.AddNew()
C#
public override void AddNew()
Managed Extensions for C++
public: void AddNew(); override
C++/CLI
public:
void AddNew(); override

Exceptions

Exception | Description
NotSupportedException | The underlying data source does not implement IBindingList, or the data source has thrown an exception because the user has attempted to add a row to a read-only or fixed-size DataView.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CurrencyManager Class
CurrencyManager Members


CancelCurrentEdit Method

[image]
Gizmox.WebGUI.Forms
CancelCurrentEdit Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CurrencyManager Class : CancelCurrentEdit Method

Cancels the current edit operation.

Syntax

Visual Basic (Declaration)
Public Overrides Sub CancelCurrentEdit()
Visual Basic (Usage) Copy Code
Dim instance As CurrencyManager

instance.CancelCurrentEdit()
C#
public override void CancelCurrentEdit()
Managed Extensions for C++
public: void CancelCurrentEdit(); override
C++/CLI
public:
void CancelCurrentEdit(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CurrencyManager Class
CurrencyManager Members


CheckEmpty Method

[image]
Gizmox.WebGUI.Forms
CheckEmpty Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CurrencyManager Class : CheckEmpty Method

Throws an exception if there is no list, or the list is empty.

Syntax

Visual Basic (Declaration)
Protected Sub CheckEmpty()
Visual Basic (Usage) Copy Code
Dim instance As CurrencyManager

instance.CheckEmpty()
C#
protected void CheckEmpty()
Managed Extensions for C++
protected: void CheckEmpty();
C++/CLI
protected:
void CheckEmpty();

Exceptions

Exception | Description
Exception | There is no list, or the list is empty.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CurrencyManager Class
CurrencyManager Members


EndCurrentEdit Method

[image]
Gizmox.WebGUI.Forms
EndCurrentEdit Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CurrencyManager Class : EndCurrentEdit Method

Ends the current edit operation.

Syntax

Visual Basic (Declaration)
Public Overrides Sub EndCurrentEdit()
Visual Basic (Usage) Copy Code
Dim instance As CurrencyManager

instance.EndCurrentEdit()
C#
public override void EndCurrentEdit()
Managed Extensions for C++
public: void EndCurrentEdit(); override
C++/CLI
public:
void EndCurrentEdit(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CurrencyManager Class
CurrencyManager Members


GetItemProperties Method

[image]
Gizmox.WebGUI.Forms
GetItemProperties Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CurrencyManager Class : GetItemProperties Method

Gets the property descriptor collection for the underlying list.

Overload List

Overload | Description
GetItemProperties() | Gets the property descriptor collection for the underlying list.
GetItemProperties(ArrayList,ArrayList) | Gets the collection of property descriptors for the binding using the specified ArrayList. (Inherited from BindingManagerBase)
GetItemProperties(Type,Int32,ArrayList,ArrayList) | Gets the list of properties of the items managed by this BindingManagerBase. (Inherited from BindingManagerBase)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CurrencyManager Class
CurrencyManager Members


GetItemProperties() Method

[image]
Gizmox.WebGUI.Forms
GetItemProperties() Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CurrencyManager Class > GetItemProperties Method : GetItemProperties() Method

Gets the property descriptor collection for the underlying list.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function GetItemProperties() As PropertyDescriptorCollection
Visual Basic (Usage) Copy Code
Dim instance As CurrencyManager
Dim value As PropertyDescriptorCollection

value = instance.GetItemProperties()
C#
public override PropertyDescriptorCollection GetItemProperties()
Managed Extensions for C++
public: PropertyDescriptorCollection* GetItemProperties(); override
C++/CLI
public:
PropertyDescriptorCollection^ GetItemProperties(); override

Return Value

A PropertyDescriptorCollection for the list.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CurrencyManager Class
CurrencyManager Members
Overload List


GetListName Method

[image]
Gizmox.WebGUI.Forms
GetListName Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CurrencyManager Class : GetListName Method

listAccessors
An ArrayList of properties to be found in the data source.
Gets the name of the list supplying the data for the binding using the specified set of bound properties.

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetListName( _
   ByVal listAccessors As ArrayList _
) As String
Visual Basic (Usage) Copy Code
Dim instance As CurrencyManager
Dim listAccessors As ArrayList
Dim value As String

value = instance.GetListName(listAccessors)
C#
protected override string GetListName(
   ArrayList listAccessors
)
Managed Extensions for C++
protected: string* GetListName(
   ArrayList* listAccessors
) override
C++/CLI
protected:
String^ GetListName(
   ArrayList^ listAccessors
) override

Parameters

listAccessors
An ArrayList of properties to be found in the data source.

Return Value

If successful, a String containing name of the list supplying the data for the binding; otherwise, an Empty string.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CurrencyManager Class
CurrencyManager Members


OnCurrentChanged Method

[image]
Gizmox.WebGUI.Forms
OnCurrentChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CurrencyManager Class : OnCurrentChanged Method

e

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnCurrentChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As CurrencyManager
Dim e As EventArgs

instance.OnCurrentChanged(e)
C#
protected override void OnCurrentChanged(
   EventArgs e
)
Managed Extensions for C++
protected: void OnCurrentChanged(
   EventArgs* e
) override
C++/CLI
protected:
void OnCurrentChanged(
   EventArgs^ e
) override

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CurrencyManager Class
CurrencyManager Members


OnCurrentItemChanged Method

[image]
Gizmox.WebGUI.Forms
OnCurrentItemChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CurrencyManager Class : OnCurrentItemChanged Method

e

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnCurrentItemChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As CurrencyManager
Dim e As EventArgs

instance.OnCurrentItemChanged(e)
C#
protected override void OnCurrentItemChanged(
   EventArgs e
)
Managed Extensions for C++
protected: void OnCurrentItemChanged(
   EventArgs* e
) override
C++/CLI
protected:
void OnCurrentItemChanged(
   EventArgs^ e
) override

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CurrencyManager Class
CurrencyManager Members


OnItemChanged Method

[image]
Gizmox.WebGUI.Forms
OnItemChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CurrencyManager Class : OnItemChanged Method

e
An ItemChangedEventArgs that contains the event data.
Raises the ItemChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnItemChanged( _
   ByVal e As ItemChangedEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As CurrencyManager
Dim e As ItemChangedEventArgs

instance.OnItemChanged(e)
C#
protected virtual void OnItemChanged(
   ItemChangedEventArgs e
)
Managed Extensions for C++
protected: virtual void OnItemChanged(
   ItemChangedEventArgs* e
)
C++/CLI
protected:
virtual void OnItemChanged(
   ItemChangedEventArgs^ e
)

Parameters

e
An ItemChangedEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CurrencyManager Class
CurrencyManager Members


OnMetaDataChanged Method

[image]
Gizmox.WebGUI.Forms
OnMetaDataChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CurrencyManager Class : OnMetaDataChanged Method

e
An EventArgs that contains the event data.
Raises the MetaDataChanged event.

Syntax

Visual Basic (Declaration)
Protected Sub OnMetaDataChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As CurrencyManager
Dim e As EventArgs

instance.OnMetaDataChanged(e)
C#
protected void OnMetaDataChanged(
   EventArgs e
)
Managed Extensions for C++
protected: void OnMetaDataChanged(
   EventArgs* e
)
C++/CLI
protected:
void OnMetaDataChanged(
   EventArgs^ e
)

Parameters

e
An EventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CurrencyManager Class
CurrencyManager Members


OnPositionChanged Method

[image]
Gizmox.WebGUI.Forms
OnPositionChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CurrencyManager Class : OnPositionChanged Method

e
An EventArgs that contains the event data.
Raises the BindingManagerBase.PositionChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnPositionChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As CurrencyManager
Dim e As EventArgs

instance.OnPositionChanged(e)
C#
protected virtual void OnPositionChanged(
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnPositionChanged(
   EventArgs* e
)
C++/CLI
protected:
virtual void OnPositionChanged(
   EventArgs^ e
)

Parameters

e
An EventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CurrencyManager Class
CurrencyManager Members


Refresh Method

[image]
Gizmox.WebGUI.Forms
Refresh Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CurrencyManager Class : Refresh Method

Forces a repopulation of the data-bound list.

Syntax

Visual Basic (Declaration)
Public Sub Refresh()
Visual Basic (Usage) Copy Code
Dim instance As CurrencyManager

instance.Refresh()
C#
public void Refresh()
Managed Extensions for C++
public: void Refresh();
C++/CLI
public:
void Refresh();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CurrencyManager Class
CurrencyManager Members


RemoveAt Method

[image]
Gizmox.WebGUI.Forms
RemoveAt Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CurrencyManager Class : RemoveAt Method

index
The index of the item to remove from the list.
Removes the item at the specified index.

Syntax

Visual Basic (Declaration)
Public Overrides Sub RemoveAt( _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As CurrencyManager
Dim index As Integer

instance.RemoveAt(index)
C#
public override void RemoveAt(
   int index
)
Managed Extensions for C++
public: void RemoveAt(
   int index
) override
C++/CLI
public:
void RemoveAt(
   int index
) override

Parameters

index
The index of the item to remove from the list.

Exceptions

Exception | Description
IndexOutOfRangeException | There is no row at the specified index.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CurrencyManager Class
CurrencyManager Members


ResumeBinding Method

[image]
Gizmox.WebGUI.Forms
ResumeBinding Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CurrencyManager Class : ResumeBinding Method

Resumes data binding.

Syntax

Visual Basic (Declaration)
Public Overrides Sub ResumeBinding()
Visual Basic (Usage) Copy Code
Dim instance As CurrencyManager

instance.ResumeBinding()
C#
public override void ResumeBinding()
Managed Extensions for C++
public: void ResumeBinding(); override
C++/CLI
public:
void ResumeBinding(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CurrencyManager Class
CurrencyManager Members


SuspendBinding Method

[image]
Gizmox.WebGUI.Forms
SuspendBinding Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CurrencyManager Class : SuspendBinding Method

Suspends data binding to prevents changes from updating the bound data source.

Syntax

Visual Basic (Declaration)
Public Overrides Sub SuspendBinding()
Visual Basic (Usage) Copy Code
Dim instance As CurrencyManager

instance.SuspendBinding()
C#
public override void SuspendBinding()
Managed Extensions for C++
public: void SuspendBinding(); override
C++/CLI
public:
void SuspendBinding(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CurrencyManager Class
CurrencyManager Members


UpdateIsBinding Method

[image]
Gizmox.WebGUI.Forms
UpdateIsBinding Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CurrencyManager Class : UpdateIsBinding Method

Updates the status of the binding.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub UpdateIsBinding()
Visual Basic (Usage) Copy Code
Dim instance As CurrencyManager

instance.UpdateIsBinding()
C#
protected override void UpdateIsBinding()
Managed Extensions for C++
protected: void UpdateIsBinding(); override
C++/CLI
protected:
void UpdateIsBinding(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CurrencyManager Class
CurrencyManager Members


CurrencyManager Class Properties

[image]
Gizmox.WebGUI.Forms
CurrencyManager Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : CurrencyManager Class

For a list of all members of this type, see CurrencyManager members.

Public Properties

 | Name | Description
Public Property | Bindings | Gets the collection of bindings being managed. (Inherited from BindingManagerBase)
Public Property | Count | Overridden. Gets the number of items in the list.
Public Property | Current | Overridden. Gets the current item in the list.
Public Property | IsBindingSuspended | Gets a value indicating whether binding is suspended. (Inherited from BindingManagerBase)
Public Property | List | Gets the list for this CurrencyManager.
Public Property | Position | Overridden. Gets or sets the position you are at within the list.
Top

See Also

Reference

CurrencyManager Class
Gizmox.WebGUI.Forms Namespace


Count Property

[image]
Gizmox.WebGUI.Forms
Count Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CurrencyManager Class : Count Property

Gets the number of items in the list.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As CurrencyManager
Dim value As Integer

value = instance.Count
C#
public override int Count {get;}
Managed Extensions for C++
public: __property int get_Count() override;
C++/CLI
public:
property int Count {
   int get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CurrencyManager Class
CurrencyManager Members


Current Property

[image]
Gizmox.WebGUI.Forms
Current Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CurrencyManager Class : Current Property

Gets the current item in the list.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Current As Object
Visual Basic (Usage) Copy Code
Dim instance As CurrencyManager
Dim value As Object

value = instance.Current
C#
public override object Current {get;}
Managed Extensions for C++
public: __property Object* get_Current() override;
C++/CLI
public:
property Object^ Current {
   Object^ get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CurrencyManager Class
CurrencyManager Members


List Property

[image]
Gizmox.WebGUI.Forms
List Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CurrencyManager Class : List Property

Gets the list for this CurrencyManager.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property List As IList
Visual Basic (Usage) Copy Code
Dim instance As CurrencyManager
Dim value As IList

value = instance.List
C#
public IList List {get;}
Managed Extensions for C++
public: __property IList* get_List();
C++/CLI
public:
property IList^ List {
   IList^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CurrencyManager Class
CurrencyManager Members


Position Property

[image]
Gizmox.WebGUI.Forms
Position Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CurrencyManager Class : Position Property

Gets or sets the position you are at within the list.

Syntax

Visual Basic (Declaration)
Public Overrides Property Position As Integer
Visual Basic (Usage) Copy Code
Dim instance As CurrencyManager
Dim value As Integer

instance.Position = value

value = instance.Position
C#
public override int Position {get; set;}
Managed Extensions for C++
public: __property int get_Position() override;
public: __property void set_Position(
   int value
) override;
C++/CLI
public:
property int Position {
   int get() override;
   void set (intvalue) override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CurrencyManager Class
CurrencyManager Members


CurrencyManager Class Fields

[image]
Gizmox.WebGUI.Forms
CurrencyManager Class Fields
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : CurrencyManager Class

For a list of all members of this type, see CurrencyManager members.

Protected Fields

 | Name | Description
Protected Field | finalType | Specifies the data type of the list.
Protected Field | listposition | Specifies the current position of the CurrencyManager in the list.
Top

See Also

Reference

CurrencyManager Class
Gizmox.WebGUI.Forms Namespace


finalType Field

[image]
Gizmox.WebGUI.Forms
finalType Field
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CurrencyManager Class : finalType Field

Specifies the data type of the list.

Syntax

Visual Basic (Declaration)
Protected finalType As Type
Visual Basic (Usage) Copy Code
Dim instance As CurrencyManager
Dim value As Type

value = instance.finalType

instance.finalType = value
C#
protected Type finalType
Managed Extensions for C++
protected: Type* finalType
C++/CLI
protected:
Type^ finalType

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CurrencyManager Class
CurrencyManager Members


listposition Field

[image]
Gizmox.WebGUI.Forms
listposition Field
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CurrencyManager Class : listposition Field

Specifies the current position of the CurrencyManager in the list.

Syntax

Visual Basic (Declaration)
Protected listposition As Integer
Visual Basic (Usage) Copy Code
Dim instance As CurrencyManager
Dim value As Integer

value = instance.listposition

instance.listposition = value
C#
protected int listposition
Managed Extensions for C++
protected: int listposition
C++/CLI
protected:
int listposition

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CurrencyManager Class
CurrencyManager Members


CurrencyManager Class Events

[image]
Gizmox.WebGUI.Forms
CurrencyManager Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : CurrencyManager Class

For a list of all members of this type, see CurrencyManager members.

Public Events

 | Name | Description
Public Event | BindingComplete | Occurs at the completion of a data-binding operation. (Inherited from BindingManagerBase)
Public Event | CurrentChanged | Occurs when the currently bound item changes. (Inherited from BindingManagerBase)
Public Event | CurrentItemChanged | Occurs when the state of the currently bound item changes. (Inherited from BindingManagerBase)
Public Event | DataError | Occurs when an Exception is silently handled by the BindingManagerBase. (Inherited from BindingManagerBase)
Public Event | ItemChanged | Occurs when the current item has been altered.
Public Event | ListChanged | Occurs when the list changes or an item in the list changes.
Public Event | MetaDataChanged | Occurs when the metadata of the List has changed.
Public Event | PositionChanged | Occurs after the value of the Position property has changed. (Inherited from BindingManagerBase)
Top

See Also

Reference

CurrencyManager Class
Gizmox.WebGUI.Forms Namespace


ItemChanged Event

[image]
Gizmox.WebGUI.Forms
ItemChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CurrencyManager Class : ItemChanged Event

Occurs when the current item has been altered.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Data")>
Public Event ItemChanged() As ItemChangedEventHandler
Visual Basic (Usage) Copy Code
Dim instance As CurrencyManager
Dim handler As ItemChangedEventHandler

AddHandler instance.ItemChanged, handler
C#
[SRCategoryAttribute("Data")]
public event ItemChangedEventHandler ItemChanged()
Managed Extensions for C++
[SRCategoryAttribute("Data")]
public: __event ItemChangedEventHandler* ItemChanged
C++/CLI
[SRCategoryAttribute("Data")]
public:
event ItemChangedEventHandler^ ItemChanged

Event Data

The event handler receives an argument of type ItemChangedEventArgs containing data related to this event. The following ItemChangedEventArgs properties provide information specific to this event.

Property | Description
Index | Indicates the position of the item being changed within the list.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CurrencyManager Class
CurrencyManager Members


ListChanged Event

[image]
Gizmox.WebGUI.Forms
ListChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CurrencyManager Class : ListChanged Event

Occurs when the list changes or an item in the list changes.

Syntax

Visual Basic (Declaration)
Public Event ListChanged() As ListChangedEventHandler
Visual Basic (Usage) Copy Code
Dim instance As CurrencyManager
Dim handler As ListChangedEventHandler

AddHandler instance.ListChanged, handler
C#
public event ListChangedEventHandler ListChanged()
Managed Extensions for C++
public: __event ListChangedEventHandler* ListChanged
C++/CLI
public:
event ListChangedEventHandler^ ListChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CurrencyManager Class
CurrencyManager Members


MetaDataChanged Event

[image]
Gizmox.WebGUI.Forms
MetaDataChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CurrencyManager Class : MetaDataChanged Event

Occurs when the metadata of the List has changed.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Data")>
Public Event MetaDataChanged() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As CurrencyManager
Dim handler As EventHandler

AddHandler instance.MetaDataChanged, handler
C#
[SRCategoryAttribute("Data")]
public event EventHandler MetaDataChanged()
Managed Extensions for C++
[SRCategoryAttribute("Data")]
public: __event EventHandler* MetaDataChanged
C++/CLI
[SRCategoryAttribute("Data")]
public:
event EventHandler^ MetaDataChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CurrencyManager Class
CurrencyManager Members


Cursor Class

[image]
Gizmox.WebGUI.Forms
Cursor Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : Cursor Class

Represents the image used to paint the mouse pointer.

Syntax

Visual Basic (Declaration)
<TypeConverterAttribute("Gizmox.WebGUI.Forms.CursorConverter, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d")>
<EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.CursorEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")>
Public NotInheritable Class Cursor
Visual Basic (Usage) Copy Code
Dim instance As Cursor
C#
[TypeConverterAttribute("Gizmox.WebGUI.Forms.CursorConverter, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d")]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.CursorEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
public sealed class Cursor
Managed Extensions for C++
[TypeConverterAttribute("Gizmox.WebGUI.Forms.CursorConverter, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d")]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.CursorEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
public __gc __sealed class Cursor
C++/CLI
[TypeConverterAttribute("Gizmox.WebGUI.Forms.CursorConverter, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d")]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.CursorEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
public ref class Cursor sealed

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.Cursor

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Cursor Members
Gizmox.WebGUI.Forms Namespace


Cursor Class Members

[image]
Gizmox.WebGUI.Forms
Cursor Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : Cursor Class

The following tables list the members exposed by Cursor.

Public Constructors

 | Name | Description
Public Constructor | Cursor Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Type |
Top

Public Methods

 | Name | Description
Public Method | ToString | Overridden. Retrieves a human readable string representing this Cursor.
Top

See Also

Reference

Cursor Class
Gizmox.WebGUI.Forms Namespace


Cursor Constructor

[image]
Gizmox.WebGUI.Forms
Cursor Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Cursor Class : Cursor Constructor

Overload List

Overload | Description
Cursor Constructor(String) |
Cursor Constructor(String,String) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Cursor Class
Cursor Members


Cursor Constructor(String)

[image]
Gizmox.WebGUI.Forms
Cursor Constructor(String)
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Cursor Class > Cursor Constructor : Cursor Constructor(String)

strType

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal strType As String _
)
Visual Basic (Usage) Copy Code
Dim strType As String

Dim instance As Cursor(strType)
C#
public Cursor(
   string strType
)
Managed Extensions for C++
public: Cursor(
   string* strType
)
C++/CLI
public:
Cursor(
   String^ strType
)

Parameters

strType

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Cursor Class
Cursor Members
Overload List


Cursor Constructor(String,String)

[image]
Gizmox.WebGUI.Forms
Cursor Constructor(String,String)
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Cursor Class > Cursor Constructor : Cursor Constructor(String,String)

strType
strStyle

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal strType As String, _
   ByVal strStyle As String _
)
Visual Basic (Usage) Copy Code
Dim strType As String
Dim strStyle As String

Dim instance As Cursor(strType, strStyle)
C#
public Cursor(
   string strType,
   string strStyle
)
Managed Extensions for C++
public: Cursor(
   string* strType,
   string* strStyle
)
C++/CLI
public:
Cursor(
   String^ strType,
   String^ strStyle
)

Parameters

strType
strStyle

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Cursor Class
Cursor Members
Overload List


Cursor Class Methods

[image]
Gizmox.WebGUI.Forms
Cursor Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : Cursor Class

For a list of all members of this type, see Cursor members.

Public Methods

 | Name | Description
Public Method | ToString | Overridden. Retrieves a human readable string representing this Cursor.
Top

See Also

Reference

Cursor Class
Gizmox.WebGUI.Forms Namespace


ToString Method

[image]
Gizmox.WebGUI.Forms
ToString Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Cursor Class : ToString Method

Retrieves a human readable string representing this Cursor.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As Cursor
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Return Value

A String that represents this Cursor.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Cursor Class
Cursor Members


Cursor Class Properties

[image]
Gizmox.WebGUI.Forms
Cursor Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : Cursor Class

For a list of all members of this type, see Cursor members.

Public Properties

 | Name | Description
Public Property | Type |
Top

See Also

Reference

Cursor Class
Gizmox.WebGUI.Forms Namespace


Type Property

[image]
Gizmox.WebGUI.Forms
Type Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Cursor Class : Type Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Type As String
Visual Basic (Usage) Copy Code
Dim instance As Cursor
Dim value As String

value = instance.Type
C#
public string Type {get;}
Managed Extensions for C++
public: __property string* get_Type();
C++/CLI
public:
property String^ Type {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Cursor Class
Cursor Members


CursorConverter Class

[image]
Gizmox.WebGUI.Forms
CursorConverter Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : CursorConverter Class

Provides a type converter to convert Cursor objects to and from various other representations.

Syntax

Visual Basic (Declaration)
Public Class CursorConverter
   Inherits TypeConverter
Visual Basic (Usage) Copy Code
Dim instance As CursorConverter
C#
public class CursorConverter : TypeConverter
Managed Extensions for C++
public __gc class CursorConverter : public TypeConverter
C++/CLI
public ref class CursorConverter : public TypeConverter

Inheritance Hierarchy

System.Object
System.ComponentModel.TypeConverter
Gizmox.WebGUI.Forms.CursorConverter

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

CursorConverter Members
Gizmox.WebGUI.Forms Namespace


CursorConverter Class Members

[image]
Gizmox.WebGUI.Forms
CursorConverter Class Members
See Also Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : CursorConverter Class

The following tables list the members exposed by CursorConverter.

Public Constructors

 | Name | Description
Public Constructor | CursorConverter Constructor |
Top

Public Methods

 | Name | Description
Public Method | CanConvertFrom | Overloaded. Overridden. Determines if this converter can convert an object in the given source type to the native type of the converter.
Public Method | CanConvertTo | Overloaded. Overridden. Gets a value indicating whether this converter can convert an object to the given destination type using the context.
Public Method | ConvertFrom | Overloaded. Overridden. Converts the given value to the type of this converter.
Public Method | ConvertFromInvariantString | Overloaded. Converts the given string to the type of this converter, using the invariant culture. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertFromString | Overloaded. Converts the specified text to an object. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertTo | Overloaded. Overridden. Converts the given value object to the specified type, using the arguments.
Public Method | ConvertToInvariantString | Overloaded. Converts the specified value to a culture-invariant string representation. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertToString | Overloaded. Converts the specified value to a string representation. (Inherited from System.ComponentModel.TypeConverter)
Public Method | CreateInstance | Overloaded. Re-creates an Object given a set of property values for the object. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetCreateInstanceSupported | Overloaded. Returns whether changing a value on this object requires a call to the CreateInstance method to create a new value. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetProperties | Overloaded. Returns a collection of properties for the type of array specified by the value parameter. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetPropertiesSupported | Overloaded. Returns whether this object supports properties. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValues | Overloaded. Overridden. Retrieves a collection containing a set of standard values for the data type this validator is designed for. This will return null if the data type does not support a standard set of values.
Public Method | GetStandardValuesExclusive | Overloaded. Returns whether the collection of standard values returned from GetStandardValues is an exclusive list. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValuesSupported | Overloaded. Overridden. Determines if this object supports a standard set of values that can be picked from a list.
Public Method | IsValid | Overloaded. Returns whether the given value object is valid for this type. (Inherited from System.ComponentModel.TypeConverter)
Top

Protected Methods

 | Name | Description
Protected Method | GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from System.ComponentModel.TypeConverter)
Protected Method | GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from System.ComponentModel.TypeConverter)
Protected Method | SortProperties | (Inherited from System.ComponentModel.TypeConverter)
Top

See Also

Reference

CursorConverter Class
Gizmox.WebGUI.Forms Namespace


CursorConverter Constructor

[image]
Gizmox.WebGUI.Forms
CursorConverter Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CursorConverter Class : CursorConverter Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As CursorConverter()
C#
public CursorConverter()
Managed Extensions for C++
public: CursorConverter();
C++/CLI
public:
CursorConverter();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CursorConverter Class
CursorConverter Members


CursorConverter Class Methods

[image]
Gizmox.WebGUI.Forms
CursorConverter Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : CursorConverter Class

For a list of all members of this type, see CursorConverter members.

Public Methods

 | Name | Description
Public Method | CanConvertFrom | Overloaded. Overridden. Determines if this converter can convert an object in the given source type to the native type of the converter.
Public Method | CanConvertTo | Overloaded. Overridden. Gets a value indicating whether this converter can convert an object to the given destination type using the context.
Public Method | ConvertFrom | Overloaded. Overridden. Converts the given value to the type of this converter.
Public Method | ConvertFromInvariantString | Overloaded. Converts the given string to the type of this converter, using the invariant culture. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertFromString | Overloaded. Converts the specified text to an object. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertTo | Overloaded. Overridden. Converts the given value object to the specified type, using the arguments.
Public Method | ConvertToInvariantString | Overloaded. Converts the specified value to a culture-invariant string representation. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertToString | Overloaded. Converts the specified value to a string representation. (Inherited from System.ComponentModel.TypeConverter)
Public Method | CreateInstance | Overloaded. Re-creates an Object given a set of property values for the object. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetCreateInstanceSupported | Overloaded. Returns whether changing a value on this object requires a call to the CreateInstance method to create a new value. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetProperties | Overloaded. Returns a collection of properties for the type of array specified by the value parameter. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetPropertiesSupported | Overloaded. Returns whether this object supports properties. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValues | Overloaded. Overridden. Retrieves a collection containing a set of standard values for the data type this validator is designed for. This will return null if the data type does not support a standard set of values.
Public Method | GetStandardValuesExclusive | Overloaded. Returns whether the collection of standard values returned from GetStandardValues is an exclusive list. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValuesSupported | Overloaded. Overridden. Determines if this object supports a standard set of values that can be picked from a list.
Public Method | IsValid | Overloaded. Returns whether the given value object is valid for this type. (Inherited from System.ComponentModel.TypeConverter)
Top

Protected Methods

 | Name | Description
Protected Method | GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from System.ComponentModel.TypeConverter)
Protected Method | GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from System.ComponentModel.TypeConverter)
Protected Method | SortProperties | (Inherited from System.ComponentModel.TypeConverter)
Top

See Also

Reference

CursorConverter Class
Gizmox.WebGUI.Forms Namespace


CanConvertFrom Method

[image]
Gizmox.WebGUI.Forms
CanConvertFrom Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CursorConverter Class : CanConvertFrom Method

Determines if this converter can convert an object in the given source type to the native type of the converter.

Overload List

Overload | Description
CanConvertFrom(ITypeDescriptorContext,Type) | Determines if this converter can convert an object in the given source type to the native type of the converter.
CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from System.ComponentModel.TypeConverter)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CursorConverter Class
CursorConverter Members


CanConvertFrom(ITypeDescriptorContext,Type) Method

[image]
Gizmox.WebGUI.Forms
CanConvertFrom(ITypeDescriptorContext,Type) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CursorConverter Class > CanConvertFrom Method : CanConvertFrom(ITypeDescriptorContext,Type) Method

context
A formatter context. This object can be used to extract additional information about the environment this converter is being invoked from. This may be null, so you should always check. Also, properties on the context object may also return null.
sourceType
The type you wish to convert from.
Determines if this converter can convert an object in the given source type to the native type of the converter.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function CanConvertFrom( _
   ByVal context As ITypeDescriptorContext, _
   ByVal sourceType As Type _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As CursorConverter
Dim context As ITypeDescriptorContext
Dim sourceType As Type
Dim value As Boolean

value = instance.CanConvertFrom(context, sourceType)
C#
public override bool CanConvertFrom(
   ITypeDescriptorContext context,
   Type sourceType
)
Managed Extensions for C++
public: bool CanConvertFrom(
   ITypeDescriptorContext* context,
   Type* sourceType
) override
C++/CLI
public:
bool CanConvertFrom(
   ITypeDescriptorContext^ context,
   Type^ sourceType
) override

Parameters

context
A formatter context. This object can be used to extract additional information about the environment this converter is being invoked from. This may be null, so you should always check. Also, properties on the context object may also return null.
sourceType
The type you wish to convert from.

Return Value

true if this object can perform the conversion.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CursorConverter Class
CursorConverter Members
Overload List


CanConvertTo Method

[image]
Gizmox.WebGUI.Forms
CanConvertTo Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CursorConverter Class : CanConvertTo Method

Gets a value indicating whether this converter can convert an object to the given destination type using the context.

Overload List

Overload | Description
CanConvertTo(ITypeDescriptorContext,Type) | Gets a value indicating whether this converter can convert an object to the given destination type using the context.
CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from System.ComponentModel.TypeConverter)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CursorConverter Class
CursorConverter Members


CanConvertTo(ITypeDescriptorContext,Type) Method

[image]
Gizmox.WebGUI.Forms
CanConvertTo(ITypeDescriptorContext,Type) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CursorConverter Class > CanConvertTo Method : CanConvertTo(ITypeDescriptorContext,Type) Method

context
An ITypeDescriptorContext that provides a format context.
destinationType
A Type that represents the type you wish to convert to.
Gets a value indicating whether this converter can convert an object to the given destination type using the context.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function CanConvertTo( _
   ByVal context As ITypeDescriptorContext, _
   ByVal destinationType As Type _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As CursorConverter
Dim context As ITypeDescriptorContext
Dim destinationType As Type
Dim value As Boolean

value = instance.CanConvertTo(context, destinationType)
C#
public override bool CanConvertTo(
   ITypeDescriptorContext context,
   Type destinationType
)
Managed Extensions for C++
public: bool CanConvertTo(
   ITypeDescriptorContext* context,
   Type* destinationType
) override
C++/CLI
public:
bool CanConvertTo(
   ITypeDescriptorContext^ context,
   Type^ destinationType
) override

Parameters

context
An ITypeDescriptorContext that provides a format context.
destinationType
A Type that represents the type you wish to convert to.

Return Value

true if this converter can perform the conversion; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CursorConverter Class
CursorConverter Members
Overload List


ConvertFrom Method

[image]
Gizmox.WebGUI.Forms
ConvertFrom Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CursorConverter Class : ConvertFrom Method

Converts the given value to the type of this converter.

Overload List

Overload | Description
ConvertFrom(ITypeDescriptorContext,CultureInfo,Object) |
ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from System.ComponentModel.TypeConverter)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CursorConverter Class
CursorConverter Members


ConvertFrom(ITypeDescriptorContext,CultureInfo,Object) Method

[image]
Gizmox.WebGUI.Forms
ConvertFrom(ITypeDescriptorContext,CultureInfo,Object) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CursorConverter Class > ConvertFrom Method : ConvertFrom(ITypeDescriptorContext,CultureInfo,Object) Method

context
culture
value

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function ConvertFrom( _
   ByVal context As ITypeDescriptorContext, _
   ByVal culture As CultureInfo, _
   ByVal value As Object _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As CursorConverter
Dim context As ITypeDescriptorContext
Dim culture As CultureInfo
Dim value As Object
Dim value As Object

value = instance.ConvertFrom(context, culture, value)
C#
public override object ConvertFrom(
   ITypeDescriptorContext context,
   CultureInfo culture,
   object value
)
Managed Extensions for C++
public: Object* ConvertFrom(
   ITypeDescriptorContext* context,
   CultureInfo* culture,
   Object* value
) override
C++/CLI
public:
Object^ ConvertFrom(
   ITypeDescriptorContext^ context,
   CultureInfo^ culture,
   Object^ value
) override

Parameters

context
culture
value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CursorConverter Class
CursorConverter Members
Overload List


ConvertTo Method

[image]
Gizmox.WebGUI.Forms
ConvertTo Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CursorConverter Class : ConvertTo Method

Converts the given value object to the specified type, using the arguments.

Overload List

Overload | Description
ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) |
ConvertTo(Object,Type) | Converts the given value object to the specified type, using the arguments. (Inherited from System.ComponentModel.TypeConverter)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CursorConverter Class
CursorConverter Members


ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) Method

[image]
Gizmox.WebGUI.Forms
ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CursorConverter Class > ConvertTo Method : ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) Method

context
culture
value
destinationType

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function ConvertTo( _
   ByVal context As ITypeDescriptorContext, _
   ByVal culture As CultureInfo, _
   ByVal value As Object, _
   ByVal destinationType As Type _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As CursorConverter
Dim context As ITypeDescriptorContext
Dim culture As CultureInfo
Dim value As Object
Dim destinationType As Type
Dim value As Object

value = instance.ConvertTo(context, culture, value, destinationType)
C#
public override object ConvertTo(
   ITypeDescriptorContext context,
   CultureInfo culture,
   object value,
   Type destinationType
)
Managed Extensions for C++
public: Object* ConvertTo(
   ITypeDescriptorContext* context,
   CultureInfo* culture,
   Object* value,
   Type* destinationType
) override
C++/CLI
public:
Object^ ConvertTo(
   ITypeDescriptorContext^ context,
   CultureInfo^ culture,
   Object^ value,
   Type^ destinationType
) override

Parameters

context
culture
value
destinationType

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CursorConverter Class
CursorConverter Members
Overload List


GetStandardValues Method

[image]
Gizmox.WebGUI.Forms
GetStandardValues Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CursorConverter Class : GetStandardValues Method

Retrieves a collection containing a set of standard values for the data type this validator is designed for. This will return null if the data type does not support a standard set of values.

Overload List

Overload | Description
GetStandardValues(ITypeDescriptorContext) | Retrieves a collection containing a set of standard values for the data type this validator is designed for. This will return null if the data type does not support a standard set of values.
GetStandardValues() | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from System.ComponentModel.TypeConverter)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CursorConverter Class
CursorConverter Members


GetStandardValues(ITypeDescriptorContext) Method

[image]
Gizmox.WebGUI.Forms
GetStandardValues(ITypeDescriptorContext) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CursorConverter Class > GetStandardValues Method : GetStandardValues(ITypeDescriptorContext) Method

context
A formatter context. This object can be used to extract additional information about the environment this converter is being invoked from. This may be null, so you should always check. Also, properties on the context object may also return null.
Retrieves a collection containing a set of standard values for the data type this validator is designed for. This will return null if the data type does not support a standard set of values.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function GetStandardValues( _
   ByVal context As ITypeDescriptorContext _
) As TypeConverter.StandardValuesCollection
Visual Basic (Usage) Copy Code
Dim instance As CursorConverter
Dim context As ITypeDescriptorContext
Dim value As TypeConverter.StandardValuesCollection

value = instance.GetStandardValues(context)
C#
public override TypeConverter.StandardValuesCollection GetStandardValues(
   ITypeDescriptorContext context
)
Managed Extensions for C++
public: TypeConverter.StandardValuesCollection* GetStandardValues(
   ITypeDescriptorContext* context
) override
C++/CLI
public:
TypeConverter.StandardValuesCollection^ GetStandardValues(
   ITypeDescriptorContext^ context
) override

Parameters

context
A formatter context. This object can be used to extract additional information about the environment this converter is being invoked from. This may be null, so you should always check. Also, properties on the context object may also return null.

Return Value

A collection containing a standard set of valid values, or null. The default implementation always returns null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CursorConverter Class
CursorConverter Members
Overload List


GetStandardValuesSupported Method

[image]
Gizmox.WebGUI.Forms
GetStandardValuesSupported Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CursorConverter Class : GetStandardValuesSupported Method

Determines if this object supports a standard set of values that can be picked from a list.

Overload List

Overload | Description
GetStandardValuesSupported(ITypeDescriptorContext) | Determines if this object supports a standard set of values that can be picked from a list.
GetStandardValuesSupported() | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from System.ComponentModel.TypeConverter)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CursorConverter Class
CursorConverter Members


GetStandardValuesSupported(ITypeDescriptorContext) Method

[image]
Gizmox.WebGUI.Forms
GetStandardValuesSupported(ITypeDescriptorContext) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > CursorConverter Class > GetStandardValuesSupported Method : GetStandardValuesSupported(ITypeDescriptorContext) Method

context
A type descriptor through which additional context may be provided.
Determines if this object supports a standard set of values that can be picked from a list.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function GetStandardValuesSupported( _
   ByVal context As ITypeDescriptorContext _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As CursorConverter
Dim context As ITypeDescriptorContext
Dim value As Boolean

value = instance.GetStandardValuesSupported(context)
C#
public override bool GetStandardValuesSupported(
   ITypeDescriptorContext context
)
Managed Extensions for C++
public: bool GetStandardValuesSupported(
   ITypeDescriptorContext* context
) override
C++/CLI
public:
bool GetStandardValuesSupported(
   ITypeDescriptorContext^ context
) override

Parameters

context
A type descriptor through which additional context may be provided.

Return Value

Returns true if GetStandardValues should be called to find a common set of values the object supports.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CursorConverter Class
CursorConverter Members
Overload List


Cursors Class

[image]
Gizmox.WebGUI.Forms
Cursors Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : Cursors Class

Provides a collection of Cursor objects for use by a Windows Forms application.

Object Model

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Cursors
Visual Basic (Usage) Copy Code
Dim instance As Cursors
C#
public sealed class Cursors
Managed Extensions for C++
public __gc __sealed class Cursors
C++/CLI
public ref class Cursors sealed

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.Cursors

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Cursors Members
Gizmox.WebGUI.Forms Namespace


Cursors Class Members

[image]
Gizmox.WebGUI.Forms
Cursors Class Members
See Also Properties Send Feedback
Gizmox.WebGUI.Forms Namespace : Cursors Class

The following tables list the members exposed by Cursors.

Public Properties

 | Name | Description
static (Shared in Visual Basic) | AppStarting | Gets the cursor that appears when an application starts.
static (Shared in Visual Basic) | Arrow | Gets the arrow cursor.
static (Shared in Visual Basic) | Cross | Gets the crosshair cursor.
static (Shared in Visual Basic) | Default | Gets the default cursor, which is usually an arrow cursor.
static (Shared in Visual Basic) | Hand | Gets the hand cursor, typically used when hovering over a Web link.
static (Shared in Visual Basic) | Help | Gets the Help cursor, which is a combination of an arrow and a question mark.
static (Shared in Visual Basic) | HSplit | Gets the cursor that appears when the mouse is positioned over a horizontal splitter bar.
static (Shared in Visual Basic) | IBeam | Gets the I-beam cursor, which is used to show where the text cursor appears when the mouse is clicked.
static (Shared in Visual Basic) | No | Gets the cursor that indicates that a particular region is invalid for the current operation.
static (Shared in Visual Basic) | NoMove2D | Gets the cursor that appears during wheel operations when the mouse is not moving, but the window can be scrolled in both a horizontal and vertical direction.
static (Shared in Visual Basic) | NoMoveHoriz | Gets the cursor that appears during wheel operations when the mouse is not moving, but the window can be scrolled in a horizontal direction.
static (Shared in Visual Basic) | NoMoveVert | Gets the cursor that appears during wheel operations when the mouse is not moving, but the window can be scrolled in a vertical direction.
static (Shared in Visual Basic) | PanEast | Gets the cursor that appears during wheel operations when the mouse is moving and the window is scrolling horizontally to the right.
static (Shared in Visual Basic) | PanNE | Gets the cursor that appears during wheel operations when the mouse is moving and the window is scrolling horizontally and vertically upward and to the right.
static (Shared in Visual Basic) | PanNorth | Gets the cursor that appears during wheel operations when the mouse is moving and the window is scrolling vertically in an upward direction.
static (Shared in Visual Basic) | PanNW | Gets the cursor that appears during wheel operations when the mouse is moving and the window is scrolling horizontally and vertically upward and to the left.
static (Shared in Visual Basic) | PanSE | Gets the cursor that appears during wheel operations when the mouse is moving and the window is scrolling horizontally and vertically downward and to the right.
static (Shared in Visual Basic) | PanSouth | Gets the cursor that appears during wheel operations when the mouse is moving and the window is scrolling vertically in a downward direction.
static (Shared in Visual Basic) | PanSW | Gets the cursor that appears during wheel operations when the mouse is moving and the window is scrolling horizontally and vertically downward and to the left.
static (Shared in Visual Basic) | PanWest | Gets the cursor that appears during wheel operations when the mouse is moving and the window is scrolling horizontally to the left.
static (Shared in Visual Basic) | SizeAll | Gets the four-headed sizing cursor, which consists of four joined arrows that point north, south, east, and west.
static (Shared in Visual Basic) | SizeNESW | Gets the two-headed diagonal (northeast/southwest) sizing cursor.
static (Shared in Visual Basic) | SizeNS | Gets the two-headed vertical (north/south) sizing cursor.
static (Shared in Visual Basic) | SizeNWSE | Gets the two-headed diagonal (northwest/southeast) sizing cursor.
static (Shared in Visual Basic) | SizeWE | Gets the two-headed horizontal (west/east) sizing cursor.
static (Shared in Visual Basic) | UpArrow | Gets the up arrow cursor, typically used to identify an insertion point.
static (Shared in Visual Basic) | VSplit | Gets the cursor that appears when the mouse is positioned over a vertical splitter bar.
static (Shared in Visual Basic) | WaitCursor | Gets the wait cursor, typically an hourglass shape.
Top

See Also

Reference

Cursors Class
Gizmox.WebGUI.Forms Namespace


Cursors Class Properties

[image]
Gizmox.WebGUI.Forms
Cursors Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : Cursors Class

For a list of all members of this type, see Cursors members.

Public Properties

 | Name | Description
static (Shared in Visual Basic) | AppStarting | Gets the cursor that appears when an application starts.
static (Shared in Visual Basic) | Arrow | Gets the arrow cursor.
static (Shared in Visual Basic) | Cross | Gets the crosshair cursor.
static (Shared in Visual Basic) | Default | Gets the default cursor, which is usually an arrow cursor.
static (Shared in Visual Basic) | Hand | Gets the hand cursor, typically used when hovering over a Web link.
static (Shared in Visual Basic) | Help | Gets the Help cursor, which is a combination of an arrow and a question mark.
static (Shared in Visual Basic) | HSplit | Gets the cursor that appears when the mouse is positioned over a horizontal splitter bar.
static (Shared in Visual Basic) | IBeam | Gets the I-beam cursor, which is used to show where the text cursor appears when the mouse is clicked.
static (Shared in Visual Basic) | No | Gets the cursor that indicates that a particular region is invalid for the current operation.
static (Shared in Visual Basic) | NoMove2D | Gets the cursor that appears during wheel operations when the mouse is not moving, but the window can be scrolled in both a horizontal and vertical direction.
static (Shared in Visual Basic) | NoMoveHoriz | Gets the cursor that appears during wheel operations when the mouse is not moving, but the window can be scrolled in a horizontal direction.
static (Shared in Visual Basic) | NoMoveVert | Gets the cursor that appears during wheel operations when the mouse is not moving, but the window can be scrolled in a vertical direction.
static (Shared in Visual Basic) | PanEast | Gets the cursor that appears during wheel operations when the mouse is moving and the window is scrolling horizontally to the right.
static (Shared in Visual Basic) | PanNE | Gets the cursor that appears during wheel operations when the mouse is moving and the window is scrolling horizontally and vertically upward and to the right.
static (Shared in Visual Basic) | PanNorth | Gets the cursor that appears during wheel operations when the mouse is moving and the window is scrolling vertically in an upward direction.
static (Shared in Visual Basic) | PanNW | Gets the cursor that appears during wheel operations when the mouse is moving and the window is scrolling horizontally and vertically upward and to the left.
static (Shared in Visual Basic) | PanSE | Gets the cursor that appears during wheel operations when the mouse is moving and the window is scrolling horizontally and vertically downward and to the right.
static (Shared in Visual Basic) | PanSouth | Gets the cursor that appears during wheel operations when the mouse is moving and the window is scrolling vertically in a downward direction.
static (Shared in Visual Basic) | PanSW | Gets the cursor that appears during wheel operations when the mouse is moving and the window is scrolling horizontally and vertically downward and to the left.
static (Shared in Visual Basic) | PanWest | Gets the cursor that appears during wheel operations when the mouse is moving and the window is scrolling horizontally to the left.
static (Shared in Visual Basic) | SizeAll | Gets the four-headed sizing cursor, which consists of four joined arrows that point north, south, east, and west.
static (Shared in Visual Basic) | SizeNESW | Gets the two-headed diagonal (northeast/southwest) sizing cursor.
static (Shared in Visual Basic) | SizeNS | Gets the two-headed vertical (north/south) sizing cursor.
static (Shared in Visual Basic) | SizeNWSE | Gets the two-headed diagonal (northwest/southeast) sizing cursor.
static (Shared in Visual Basic) | SizeWE | Gets the two-headed horizontal (west/east) sizing cursor.
static (Shared in Visual Basic) | UpArrow | Gets the up arrow cursor, typically used to identify an insertion point.
static (Shared in Visual Basic) | VSplit | Gets the cursor that appears when the mouse is positioned over a vertical splitter bar.
static (Shared in Visual Basic) | WaitCursor | Gets the wait cursor, typically an hourglass shape.
Top

See Also

Reference

Cursors Class
Gizmox.WebGUI.Forms Namespace


AppStarting Property

[image]
Gizmox.WebGUI.Forms
AppStarting Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Cursors Class : AppStarting Property

Gets the cursor that appears when an application starts.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property AppStarting As Cursor
Visual Basic (Usage) Copy Code
Dim value As Cursor

value = Cursors.AppStarting
C#
public static Cursor AppStarting {get;}
Managed Extensions for C++
public: __property static Cursor* get_AppStarting();
C++/CLI
public:
static property Cursor^ AppStarting {
   Cursor^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Cursors Class
Cursors Members


Arrow Property

[image]
Gizmox.WebGUI.Forms
Arrow Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Cursors Class : Arrow Property

Gets the arrow cursor.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Arrow As Cursor
Visual Basic (Usage) Copy Code
Dim value As Cursor

value = Cursors.Arrow
C#
public static Cursor Arrow {get;}
Managed Extensions for C++
public: __property static Cursor* get_Arrow();
C++/CLI
public:
static property Cursor^ Arrow {
   Cursor^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Cursors Class
Cursors Members


Cross Property

[image]
Gizmox.WebGUI.Forms
Cross Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Cursors Class : Cross Property

Gets the crosshair cursor.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Cross As Cursor
Visual Basic (Usage) Copy Code
Dim value As Cursor

value = Cursors.Cross
C#
public static Cursor Cross {get;}
Managed Extensions for C++
public: __property static Cursor* get_Cross();
C++/CLI
public:
static property Cursor^ Cross {
   Cursor^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Cursors Class
Cursors Members


Default Property

[image]
Gizmox.WebGUI.Forms
Default Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Cursors Class : Default Property

Gets the default cursor, which is usually an arrow cursor.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Default As Cursor
Visual Basic (Usage) Copy Code
Dim value As Cursor

value = Cursors.Default
C#
public static Cursor Default {get;}
Managed Extensions for C++
public: __property static Cursor* get_Default();
C++/CLI
public:
static property Cursor^ Default {
   Cursor^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Cursors Class
Cursors Members


Hand Property

[image]
Gizmox.WebGUI.Forms
Hand Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Cursors Class : Hand Property

Gets the hand cursor, typically used when hovering over a Web link.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Hand As Cursor
Visual Basic (Usage) Copy Code
Dim value As Cursor

value = Cursors.Hand
C#
public static Cursor Hand {get;}
Managed Extensions for C++
public: __property static Cursor* get_Hand();
C++/CLI
public:
static property Cursor^ Hand {
   Cursor^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Cursors Class
Cursors Members


Help Property

[image]
Gizmox.WebGUI.Forms
Help Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Cursors Class : Help Property

Gets the Help cursor, which is a combination of an arrow and a question mark.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Help As Cursor
Visual Basic (Usage) Copy Code
Dim value As Cursor

value = Cursors.Help
C#
public static Cursor Help {get;}
Managed Extensions for C++
public: __property static Cursor* get_Help();
C++/CLI
public:
static property Cursor^ Help {
   Cursor^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Cursors Class
Cursors Members


HSplit Property

[image]
Gizmox.WebGUI.Forms
HSplit Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Cursors Class : HSplit Property

Gets the cursor that appears when the mouse is positioned over a horizontal splitter bar.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property HSplit As Cursor
Visual Basic (Usage) Copy Code
Dim value As Cursor

value = Cursors.HSplit
C#
public static Cursor HSplit {get;}
Managed Extensions for C++
public: __property static Cursor* get_HSplit();
C++/CLI
public:
static property Cursor^ HSplit {
   Cursor^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Cursors Class
Cursors Members


IBeam Property

[image]
Gizmox.WebGUI.Forms
IBeam Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Cursors Class : IBeam Property

Gets the I-beam cursor, which is used to show where the text cursor appears when the mouse is clicked.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property IBeam As Cursor
Visual Basic (Usage) Copy Code
Dim value As Cursor

value = Cursors.IBeam
C#
public static Cursor IBeam {get;}
Managed Extensions for C++
public: __property static Cursor* get_IBeam();
C++/CLI
public:
static property Cursor^ IBeam {
   Cursor^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Cursors Class
Cursors Members


No Property

[image]
Gizmox.WebGUI.Forms
No Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Cursors Class : No Property

Gets the cursor that indicates that a particular region is invalid for the current operation.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property No As Cursor
Visual Basic (Usage) Copy Code
Dim value As Cursor

value = Cursors.No
C#
public static Cursor No {get;}
Managed Extensions for C++
public: __property static Cursor* get_No();
C++/CLI
public:
static property Cursor^ No {
   Cursor^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Cursors Class
Cursors Members


NoMove2D Property

[image]
Gizmox.WebGUI.Forms
NoMove2D Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Cursors Class : NoMove2D Property

Gets the cursor that appears during wheel operations when the mouse is not moving, but the window can be scrolled in both a horizontal and vertical direction.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property NoMove2D As Cursor
Visual Basic (Usage) Copy Code
Dim value As Cursor

value = Cursors.NoMove2D
C#
public static Cursor NoMove2D {get;}
Managed Extensions for C++
public: __property static Cursor* get_NoMove2D();
C++/CLI
public:
static property Cursor^ NoMove2D {
   Cursor^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Cursors Class
Cursors Members


NoMoveHoriz Property

[image]
Gizmox.WebGUI.Forms
NoMoveHoriz Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Cursors Class : NoMoveHoriz Property

Gets the cursor that appears during wheel operations when the mouse is not moving, but the window can be scrolled in a horizontal direction.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property NoMoveHoriz As Cursor
Visual Basic (Usage) Copy Code
Dim value As Cursor

value = Cursors.NoMoveHoriz
C#
public static Cursor NoMoveHoriz {get;}
Managed Extensions for C++
public: __property static Cursor* get_NoMoveHoriz();
C++/CLI
public:
static property Cursor^ NoMoveHoriz {
   Cursor^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Cursors Class
Cursors Members


NoMoveVert Property

[image]
Gizmox.WebGUI.Forms
NoMoveVert Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Cursors Class : NoMoveVert Property

Gets the cursor that appears during wheel operations when the mouse is not moving, but the window can be scrolled in a vertical direction.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property NoMoveVert As Cursor
Visual Basic (Usage) Copy Code
Dim value As Cursor

value = Cursors.NoMoveVert
C#
public static Cursor NoMoveVert {get;}
Managed Extensions for C++
public: __property static Cursor* get_NoMoveVert();
C++/CLI
public:
static property Cursor^ NoMoveVert {
   Cursor^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Cursors Class
Cursors Members


PanEast Property

[image]
Gizmox.WebGUI.Forms
PanEast Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Cursors Class : PanEast Property

Gets the cursor that appears during wheel operations when the mouse is moving and the window is scrolling horizontally to the right.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PanEast As Cursor
Visual Basic (Usage) Copy Code
Dim value As Cursor

value = Cursors.PanEast
C#
public static Cursor PanEast {get;}
Managed Extensions for C++
public: __property static Cursor* get_PanEast();
C++/CLI
public:
static property Cursor^ PanEast {
   Cursor^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Cursors Class
Cursors Members


PanNE Property

[image]
Gizmox.WebGUI.Forms
PanNE Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Cursors Class : PanNE Property

Gets the cursor that appears during wheel operations when the mouse is moving and the window is scrolling horizontally and vertically upward and to the right.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PanNE As Cursor
Visual Basic (Usage) Copy Code
Dim value As Cursor

value = Cursors.PanNE
C#
public static Cursor PanNE {get;}
Managed Extensions for C++
public: __property static Cursor* get_PanNE();
C++/CLI
public:
static property Cursor^ PanNE {
   Cursor^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Cursors Class
Cursors Members


PanNorth Property

[image]
Gizmox.WebGUI.Forms
PanNorth Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Cursors Class : PanNorth Property

Gets the cursor that appears during wheel operations when the mouse is moving and the window is scrolling vertically in an upward direction.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PanNorth As Cursor
Visual Basic (Usage) Copy Code
Dim value As Cursor

value = Cursors.PanNorth
C#
public static Cursor PanNorth {get;}
Managed Extensions for C++
public: __property static Cursor* get_PanNorth();
C++/CLI
public:
static property Cursor^ PanNorth {
   Cursor^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Cursors Class
Cursors Members


PanNW Property

[image]
Gizmox.WebGUI.Forms
PanNW Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Cursors Class : PanNW Property

Gets the cursor that appears during wheel operations when the mouse is moving and the window is scrolling horizontally and vertically upward and to the left.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PanNW As Cursor
Visual Basic (Usage) Copy Code
Dim value As Cursor

value = Cursors.PanNW
C#
public static Cursor PanNW {get;}
Managed Extensions for C++
public: __property static Cursor* get_PanNW();
C++/CLI
public:
static property Cursor^ PanNW {
   Cursor^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Cursors Class
Cursors Members


PanSE Property

[image]
Gizmox.WebGUI.Forms
PanSE Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Cursors Class : PanSE Property

Gets the cursor that appears during wheel operations when the mouse is moving and the window is scrolling horizontally and vertically downward and to the right.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PanSE As Cursor
Visual Basic (Usage) Copy Code
Dim value As Cursor

value = Cursors.PanSE
C#
public static Cursor PanSE {get;}
Managed Extensions for C++
public: __property static Cursor* get_PanSE();
C++/CLI
public:
static property Cursor^ PanSE {
   Cursor^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Cursors Class
Cursors Members


PanSouth Property

[image]
Gizmox.WebGUI.Forms
PanSouth Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Cursors Class : PanSouth Property

Gets the cursor that appears during wheel operations when the mouse is moving and the window is scrolling vertically in a downward direction.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PanSouth As Cursor
Visual Basic (Usage) Copy Code
Dim value As Cursor

value = Cursors.PanSouth
C#
public static Cursor PanSouth {get;}
Managed Extensions for C++
public: __property static Cursor* get_PanSouth();
C++/CLI
public:
static property Cursor^ PanSouth {
   Cursor^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Cursors Class
Cursors Members


PanSW Property

[image]
Gizmox.WebGUI.Forms
PanSW Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Cursors Class : PanSW Property

Gets the cursor that appears during wheel operations when the mouse is moving and the window is scrolling horizontally and vertically downward and to the left.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PanSW As Cursor
Visual Basic (Usage) Copy Code
Dim value As Cursor

value = Cursors.PanSW
C#
public static Cursor PanSW {get;}
Managed Extensions for C++
public: __property static Cursor* get_PanSW();
C++/CLI
public:
static property Cursor^ PanSW {
   Cursor^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Cursors Class
Cursors Members


PanWest Property

[image]
Gizmox.WebGUI.Forms
PanWest Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Cursors Class : PanWest Property

Gets the cursor that appears during wheel operations when the mouse is moving and the window is scrolling horizontally to the left.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PanWest As Cursor
Visual Basic (Usage) Copy Code
Dim value As Cursor

value = Cursors.PanWest
C#
public static Cursor PanWest {get;}
Managed Extensions for C++
public: __property static Cursor* get_PanWest();
C++/CLI
public:
static property Cursor^ PanWest {
   Cursor^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Cursors Class
Cursors Members


SizeAll Property

[image]
Gizmox.WebGUI.Forms
SizeAll Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Cursors Class : SizeAll Property

Gets the four-headed sizing cursor, which consists of four joined arrows that point north, south, east, and west.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property SizeAll As Cursor
Visual Basic (Usage) Copy Code
Dim value As Cursor

value = Cursors.SizeAll
C#
public static Cursor SizeAll {get;}
Managed Extensions for C++
public: __property static Cursor* get_SizeAll();
C++/CLI
public:
static property Cursor^ SizeAll {
   Cursor^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Cursors Class
Cursors Members


SizeNESW Property

[image]
Gizmox.WebGUI.Forms
SizeNESW Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Cursors Class : SizeNESW Property

Gets the two-headed diagonal (northeast/southwest) sizing cursor.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property SizeNESW As Cursor
Visual Basic (Usage) Copy Code
Dim value As Cursor

value = Cursors.SizeNESW
C#
public static Cursor SizeNESW {get;}
Managed Extensions for C++
public: __property static Cursor* get_SizeNESW();
C++/CLI
public:
static property Cursor^ SizeNESW {
   Cursor^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Cursors Class
Cursors Members


SizeNS Property

[image]
Gizmox.WebGUI.Forms
SizeNS Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Cursors Class : SizeNS Property

Gets the two-headed vertical (north/south) sizing cursor.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property SizeNS As Cursor
Visual Basic (Usage) Copy Code
Dim value As Cursor

value = Cursors.SizeNS
C#
public static Cursor SizeNS {get;}
Managed Extensions for C++
public: __property static Cursor* get_SizeNS();
C++/CLI
public:
static property Cursor^ SizeNS {
   Cursor^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Cursors Class
Cursors Members


SizeNWSE Property

[image]
Gizmox.WebGUI.Forms
SizeNWSE Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Cursors Class : SizeNWSE Property

Gets the two-headed diagonal (northwest/southeast) sizing cursor.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property SizeNWSE As Cursor
Visual Basic (Usage) Copy Code
Dim value As Cursor

value = Cursors.SizeNWSE
C#
public static Cursor SizeNWSE {get;}
Managed Extensions for C++
public: __property static Cursor* get_SizeNWSE();
C++/CLI
public:
static property Cursor^ SizeNWSE {
   Cursor^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Cursors Class
Cursors Members


SizeWE Property

[image]
Gizmox.WebGUI.Forms
SizeWE Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Cursors Class : SizeWE Property

Gets the two-headed horizontal (west/east) sizing cursor.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property SizeWE As Cursor
Visual Basic (Usage) Copy Code
Dim value As Cursor

value = Cursors.SizeWE
C#
public static Cursor SizeWE {get;}
Managed Extensions for C++
public: __property static Cursor* get_SizeWE();
C++/CLI
public:
static property Cursor^ SizeWE {
   Cursor^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Cursors Class
Cursors Members


UpArrow Property

[image]
Gizmox.WebGUI.Forms
UpArrow Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Cursors Class : UpArrow Property

Gets the up arrow cursor, typically used to identify an insertion point.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property UpArrow As Cursor
Visual Basic (Usage) Copy Code
Dim value As Cursor

value = Cursors.UpArrow
C#
public static Cursor UpArrow {get;}
Managed Extensions for C++
public: __property static Cursor* get_UpArrow();
C++/CLI
public:
static property Cursor^ UpArrow {
   Cursor^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Cursors Class
Cursors Members


VSplit Property

[image]
Gizmox.WebGUI.Forms
VSplit Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Cursors Class : VSplit Property

Gets the cursor that appears when the mouse is positioned over a vertical splitter bar.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property VSplit As Cursor
Visual Basic (Usage) Copy Code
Dim value As Cursor

value = Cursors.VSplit
C#
public static Cursor VSplit {get;}
Managed Extensions for C++
public: __property static Cursor* get_VSplit();
C++/CLI
public:
static property Cursor^ VSplit {
   Cursor^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Cursors Class
Cursors Members


WaitCursor Property

[image]
Gizmox.WebGUI.Forms
WaitCursor Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Cursors Class : WaitCursor Property

Gets the wait cursor, typically an hourglass shape.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property WaitCursor As Cursor
Visual Basic (Usage) Copy Code
Dim value As Cursor

value = Cursors.WaitCursor
C#
public static Cursor WaitCursor {get;}
Managed Extensions for C++
public: __property static Cursor* get_WaitCursor();
C++/CLI
public:
static property Cursor^ WaitCursor {
   Cursor^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Cursors Class
Cursors Members


DataFormats Class

[image]
Gizmox.WebGUI.Forms
DataFormats Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataFormats Class

Provides static, predefined Clipboard format names. Use them to identify the format of data that you store in an IDataObject.

Syntax

Visual Basic (Declaration)
Public Class DataFormats
Visual Basic (Usage) Copy Code
Dim instance As DataFormats
C#
public class DataFormats
Managed Extensions for C++
public __gc class DataFormats
C++/CLI
public ref class DataFormats

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.DataFormats

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

DataFormats Members
Gizmox.WebGUI.Forms Namespace


DataFormats Class Members

[image]
Gizmox.WebGUI.Forms
DataFormats Class Members
See Also Fields Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : DataFormats Class

The following tables list the members exposed by DataFormats.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Bitmap | Specifies a Windows bitmap format. This static field is read-only.
static (Shared in Visual Basic) | CommaSeparatedValue | Specifies a comma-separated value (CSV) format, which is a common interchange format used by spreadsheets. This format is not used directly by Windows Forms. This static field is read-only.
static (Shared in Visual Basic) | Dib | Specifies the Windows device-independent bitmap (DIB) format. This static field is read-only.
static (Shared in Visual Basic) | Dif | Specifies the Windows Data Interchange Format (DIF), which Windows Forms does not directly use. This static field is read-only.
static (Shared in Visual Basic) | EnhancedMetafile | Specifies the Windows enhanced metafile format. This static field is read-only.
static (Shared in Visual Basic) | FileDrop | Specifies the Windows file drop format, which Windows Forms does not directly use. This static field is read-only.
static (Shared in Visual Basic) | Html | Specifies text consisting of HTML data. This static field is read-only.
static (Shared in Visual Basic) | Locale | Specifies the Windows culture format, which Windows Forms does not directly use. This static field is read-only.
static (Shared in Visual Basic) | MetafilePict | Specifies the Windows metafile format, which Windows Forms does not directly use. This static field is read-only.
static (Shared in Visual Basic) | OemText | Specifies the standard Windows original equipment manufacturer (OEM) text format. This static field is read-only.
static (Shared in Visual Basic) | Palette | Specifies the Windows palette format. This static field is read-only.
static (Shared in Visual Basic) | PenData | Specifies the Windows pen data format, which consists of pen strokes for handwriting software; Windows Forms does not use this format. This static field is read-only.
static (Shared in Visual Basic) | Riff | Specifies the Resource Interchange File Format (RIFF) audio format, which Windows Forms does not directly use. This static field is read-only.
static (Shared in Visual Basic) | Rtf | Specifies text consisting of Rich Text Format (RTF) data. This static field is read-only.
static (Shared in Visual Basic) | Serializable | Specifies a format that encapsulates any type of Windows Forms object. This static field is read-only.
static (Shared in Visual Basic) | StringFormat | Specifies the Windows Forms string class format, which Windows Forms uses to store string objects. This static field is read-only.
static (Shared in Visual Basic) | SymbolicLink | Specifies the Windows symbolic link format, which Windows Forms does not directly use. This static field is read-only.
static (Shared in Visual Basic) | Text | Specifies the standard ANSI text format. This static field is read-only.
static (Shared in Visual Basic) | Tiff | Specifies the Tagged Image File Format (TIFF), which Windows Forms does not directly use. This static field is read-only.
static (Shared in Visual Basic) | UnicodeText | Specifies the standard Windows Unicode text format. This static field is read-only.
static (Shared in Visual Basic) | WaveAudio | Specifies the wave audio format, which Windows Forms does not directly use. This static field is read-only.
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetFormat | Overloaded. Returns a DataFormats.Format with the Windows Clipboard numeric ID and name for the specified ID.
Top

See Also

Reference

DataFormats Class
Gizmox.WebGUI.Forms Namespace


DataFormats Class Methods

[image]
Gizmox.WebGUI.Forms
DataFormats Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataFormats Class

For a list of all members of this type, see DataFormats members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetFormat | Overloaded. Returns a DataFormats.Format with the Windows Clipboard numeric ID and name for the specified ID.
Top

See Also

Reference

DataFormats Class
Gizmox.WebGUI.Forms Namespace


GetFormat Method

[image]
Gizmox.WebGUI.Forms
GetFormat Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataFormats Class : GetFormat Method

Returns a DataFormats.Format with the Windows Clipboard numeric ID and name for the specified ID.

Overload List

Overload | Description
GetFormat(Int32) | Returns a DataFormats.Format with the Windows Clipboard numeric ID and name for the specified ID.
GetFormat(String) | Returns a DataFormats.Format with the Windows Clipboard numeric ID and name for the specified format.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataFormats Class
DataFormats Members


GetFormat(Int32) Method

[image]
Gizmox.WebGUI.Forms
GetFormat(Int32) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataFormats Class > GetFormat Method : GetFormat(Int32) Method

id
The format ID.
Returns a DataFormats.Format with the Windows Clipboard numeric ID and name for the specified ID.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function GetFormat( _
   ByVal id As Integer _
) As DataFormats.Format
Visual Basic (Usage) Copy Code
Dim id As Integer
Dim value As DataFormats.Format

value = DataFormats.GetFormat(id)
C#
public static DataFormats.Format GetFormat(
   int id
)
Managed Extensions for C++
public: static DataFormats.Format* GetFormat(
   int id
)
C++/CLI
public:
static DataFormats::Format^ GetFormat(
   int id
)

Parameters

id
The format ID.

Return Value

A DataFormats.Format that has the Windows Clipboard numeric ID and the name of the format.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataFormats Class
DataFormats Members
Overload List


GetFormat(String) Method

[image]
Gizmox.WebGUI.Forms
GetFormat(String) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataFormats Class > GetFormat Method : GetFormat(String) Method

format
The format name.
Returns a DataFormats.Format with the Windows Clipboard numeric ID and name for the specified format.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function GetFormat( _
   ByVal format As String _
) As DataFormats.Format
Visual Basic (Usage) Copy Code
Dim format As String
Dim value As DataFormats.Format

value = DataFormats.GetFormat(format)
C#
public static DataFormats.Format GetFormat(
   string format
)
Managed Extensions for C++
public: static DataFormats.Format* GetFormat(
   string* format
)
C++/CLI
public:
static DataFormats::Format^ GetFormat(
   String^ format
)

Parameters

format
The format name.

Return Value

A DataFormats.Format that has the Windows Clipboard numeric ID and the name of the format.

Exceptions

Exception | Description
Win32Exception | Registering a new Clipboard format failed.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataFormats Class
DataFormats Members
Overload List


DataFormats Class Fields

[image]
Gizmox.WebGUI.Forms
DataFormats Class Fields
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataFormats Class

For a list of all members of this type, see DataFormats members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Bitmap | Specifies a Windows bitmap format. This static field is read-only.
static (Shared in Visual Basic) | CommaSeparatedValue | Specifies a comma-separated value (CSV) format, which is a common interchange format used by spreadsheets. This format is not used directly by Windows Forms. This static field is read-only.
static (Shared in Visual Basic) | Dib | Specifies the Windows device-independent bitmap (DIB) format. This static field is read-only.
static (Shared in Visual Basic) | Dif | Specifies the Windows Data Interchange Format (DIF), which Windows Forms does not directly use. This static field is read-only.
static (Shared in Visual Basic) | EnhancedMetafile | Specifies the Windows enhanced metafile format. This static field is read-only.
static (Shared in Visual Basic) | FileDrop | Specifies the Windows file drop format, which Windows Forms does not directly use. This static field is read-only.
static (Shared in Visual Basic) | Html | Specifies text consisting of HTML data. This static field is read-only.
static (Shared in Visual Basic) | Locale | Specifies the Windows culture format, which Windows Forms does not directly use. This static field is read-only.
static (Shared in Visual Basic) | MetafilePict | Specifies the Windows metafile format, which Windows Forms does not directly use. This static field is read-only.
static (Shared in Visual Basic) | OemText | Specifies the standard Windows original equipment manufacturer (OEM) text format. This static field is read-only.
static (Shared in Visual Basic) | Palette | Specifies the Windows palette format. This static field is read-only.
static (Shared in Visual Basic) | PenData | Specifies the Windows pen data format, which consists of pen strokes for handwriting software; Windows Forms does not use this format. This static field is read-only.
static (Shared in Visual Basic) | Riff | Specifies the Resource Interchange File Format (RIFF) audio format, which Windows Forms does not directly use. This static field is read-only.
static (Shared in Visual Basic) | Rtf | Specifies text consisting of Rich Text Format (RTF) data. This static field is read-only.
static (Shared in Visual Basic) | Serializable | Specifies a format that encapsulates any type of Windows Forms object. This static field is read-only.
static (Shared in Visual Basic) | StringFormat | Specifies the Windows Forms string class format, which Windows Forms uses to store string objects. This static field is read-only.
static (Shared in Visual Basic) | SymbolicLink | Specifies the Windows symbolic link format, which Windows Forms does not directly use. This static field is read-only.
static (Shared in Visual Basic) | Text | Specifies the standard ANSI text format. This static field is read-only.
static (Shared in Visual Basic) | Tiff | Specifies the Tagged Image File Format (TIFF), which Windows Forms does not directly use. This static field is read-only.
static (Shared in Visual Basic) | UnicodeText | Specifies the standard Windows Unicode text format. This static field is read-only.
static (Shared in Visual Basic) | WaveAudio | Specifies the wave audio format, which Windows Forms does not directly use. This static field is read-only.
Top

See Also

Reference

DataFormats Class
Gizmox.WebGUI.Forms Namespace


Bitmap Field

[image]
Gizmox.WebGUI.Forms
Bitmap Field
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataFormats Class : Bitmap Field

Specifies a Windows bitmap format. This static field is read-only.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Bitmap As String
Visual Basic (Usage) Copy Code
Dim value As String

value = DataFormats.Bitmap
C#
public static readonly string Bitmap
Managed Extensions for C++
public: static readonly string* Bitmap
C++/CLI
public:
static readonly String^ Bitmap

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataFormats Class
DataFormats Members


CommaSeparatedValue Field

[image]
Gizmox.WebGUI.Forms
CommaSeparatedValue Field
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataFormats Class : CommaSeparatedValue Field

Specifies a comma-separated value (CSV) format, which is a common interchange format used by spreadsheets. This format is not used directly by Windows Forms. This static field is read-only.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly CommaSeparatedValue As String
Visual Basic (Usage) Copy Code
Dim value As String

value = DataFormats.CommaSeparatedValue
C#
public static readonly string CommaSeparatedValue
Managed Extensions for C++
public: static readonly string* CommaSeparatedValue
C++/CLI
public:
static readonly String^ CommaSeparatedValue

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataFormats Class
DataFormats Members


Dib Field

[image]
Gizmox.WebGUI.Forms
Dib Field
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataFormats Class : Dib Field

Specifies the Windows device-independent bitmap (DIB) format. This static field is read-only.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Dib As String
Visual Basic (Usage) Copy Code
Dim value As String

value = DataFormats.Dib
C#
public static readonly string Dib
Managed Extensions for C++
public: static readonly string* Dib
C++/CLI
public:
static readonly String^ Dib

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataFormats Class
DataFormats Members


Dif Field

[image]
Gizmox.WebGUI.Forms
Dif Field
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataFormats Class : Dif Field

Specifies the Windows Data Interchange Format (DIF), which Windows Forms does not directly use. This static field is read-only.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Dif As String
Visual Basic (Usage) Copy Code
Dim value As String

value = DataFormats.Dif
C#
public static readonly string Dif
Managed Extensions for C++
public: static readonly string* Dif
C++/CLI
public:
static readonly String^ Dif

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataFormats Class
DataFormats Members


EnhancedMetafile Field

[image]
Gizmox.WebGUI.Forms
EnhancedMetafile Field
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataFormats Class : EnhancedMetafile Field

Specifies the Windows enhanced metafile format. This static field is read-only.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly EnhancedMetafile As String
Visual Basic (Usage) Copy Code
Dim value As String

value = DataFormats.EnhancedMetafile
C#
public static readonly string EnhancedMetafile
Managed Extensions for C++
public: static readonly string* EnhancedMetafile
C++/CLI
public:
static readonly String^ EnhancedMetafile

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataFormats Class
DataFormats Members


FileDrop Field

[image]
Gizmox.WebGUI.Forms
FileDrop Field
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataFormats Class : FileDrop Field

Specifies the Windows file drop format, which Windows Forms does not directly use. This static field is read-only.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly FileDrop As String
Visual Basic (Usage) Copy Code
Dim value As String

value = DataFormats.FileDrop
C#
public static readonly string FileDrop
Managed Extensions for C++
public: static readonly string* FileDrop
C++/CLI
public:
static readonly String^ FileDrop

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataFormats Class
DataFormats Members


Html Field

[image]
Gizmox.WebGUI.Forms
Html Field
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataFormats Class : Html Field

Specifies text consisting of HTML data. This static field is read-only.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Html As String
Visual Basic (Usage) Copy Code
Dim value As String

value = DataFormats.Html
C#
public static readonly string Html
Managed Extensions for C++
public: static readonly string* Html
C++/CLI
public:
static readonly String^ Html

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataFormats Class
DataFormats Members


Locale Field

[image]
Gizmox.WebGUI.Forms
Locale Field
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataFormats Class : Locale Field

Specifies the Windows culture format, which Windows Forms does not directly use. This static field is read-only.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Locale As String
Visual Basic (Usage) Copy Code
Dim value As String

value = DataFormats.Locale
C#
public static readonly string Locale
Managed Extensions for C++
public: static readonly string* Locale
C++/CLI
public:
static readonly String^ Locale

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataFormats Class
DataFormats Members


MetafilePict Field

[image]
Gizmox.WebGUI.Forms
MetafilePict Field
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataFormats Class : MetafilePict Field

Specifies the Windows metafile format, which Windows Forms does not directly use. This static field is read-only.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MetafilePict As String
Visual Basic (Usage) Copy Code
Dim value As String

value = DataFormats.MetafilePict
C#
public static readonly string MetafilePict
Managed Extensions for C++
public: static readonly string* MetafilePict
C++/CLI
public:
static readonly String^ MetafilePict

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataFormats Class
DataFormats Members


OemText Field

[image]
Gizmox.WebGUI.Forms
OemText Field
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataFormats Class : OemText Field

Specifies the standard Windows original equipment manufacturer (OEM) text format. This static field is read-only.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly OemText As String
Visual Basic (Usage) Copy Code
Dim value As String

value = DataFormats.OemText
C#
public static readonly string OemText
Managed Extensions for C++
public: static readonly string* OemText
C++/CLI
public:
static readonly String^ OemText

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataFormats Class
DataFormats Members


Palette Field

[image]
Gizmox.WebGUI.Forms
Palette Field
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataFormats Class : Palette Field

Specifies the Windows palette format. This static field is read-only.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Palette As String
Visual Basic (Usage) Copy Code
Dim value As String

value = DataFormats.Palette
C#
public static readonly string Palette
Managed Extensions for C++
public: static readonly string* Palette
C++/CLI
public:
static readonly String^ Palette

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataFormats Class
DataFormats Members


PenData Field

[image]
Gizmox.WebGUI.Forms
PenData Field
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataFormats Class : PenData Field

Specifies the Windows pen data format, which consists of pen strokes for handwriting software; Windows Forms does not use this format. This static field is read-only.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly PenData As String
Visual Basic (Usage) Copy Code
Dim value As String

value = DataFormats.PenData
C#
public static readonly string PenData
Managed Extensions for C++
public: static readonly string* PenData
C++/CLI
public:
static readonly String^ PenData

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataFormats Class
DataFormats Members


Riff Field

[image]
Gizmox.WebGUI.Forms
Riff Field
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataFormats Class : Riff Field

Specifies the Resource Interchange File Format (RIFF) audio format, which Windows Forms does not directly use. This static field is read-only.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Riff As String
Visual Basic (Usage) Copy Code
Dim value As String

value = DataFormats.Riff
C#
public static readonly string Riff
Managed Extensions for C++
public: static readonly string* Riff
C++/CLI
public:
static readonly String^ Riff

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataFormats Class
DataFormats Members


Rtf Field

[image]
Gizmox.WebGUI.Forms
Rtf Field
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataFormats Class : Rtf Field

Specifies text consisting of Rich Text Format (RTF) data. This static field is read-only.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Rtf As String
Visual Basic (Usage) Copy Code
Dim value As String

value = DataFormats.Rtf
C#
public static readonly string Rtf
Managed Extensions for C++
public: static readonly string* Rtf
C++/CLI
public:
static readonly String^ Rtf

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataFormats Class
DataFormats Members


Serializable Field

[image]
Gizmox.WebGUI.Forms
Serializable Field
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataFormats Class : Serializable Field

Specifies a format that encapsulates any type of Windows Forms object. This static field is read-only.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Serializable As String
Visual Basic (Usage) Copy Code
Dim value As String

value = DataFormats.Serializable
C#
public static readonly string Serializable
Managed Extensions for C++
public: static readonly string* Serializable
C++/CLI
public:
static readonly String^ Serializable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataFormats Class
DataFormats Members


StringFormat Field

[image]
Gizmox.WebGUI.Forms
StringFormat Field
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataFormats Class : StringFormat Field

Specifies the Windows Forms string class format, which Windows Forms uses to store string objects. This static field is read-only.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly StringFormat As String
Visual Basic (Usage) Copy Code
Dim value As String

value = DataFormats.StringFormat
C#
public static readonly string StringFormat
Managed Extensions for C++
public: static readonly string* StringFormat
C++/CLI
public:
static readonly String^ StringFormat

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataFormats Class
DataFormats Members


SymbolicLink Field

[image]
Gizmox.WebGUI.Forms
SymbolicLink Field
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataFormats Class : SymbolicLink Field

Specifies the Windows symbolic link format, which Windows Forms does not directly use. This static field is read-only.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly SymbolicLink As String
Visual Basic (Usage) Copy Code
Dim value As String

value = DataFormats.SymbolicLink
C#
public static readonly string SymbolicLink
Managed Extensions for C++
public: static readonly string* SymbolicLink
C++/CLI
public:
static readonly String^ SymbolicLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataFormats Class
DataFormats Members


Text Field

[image]
Gizmox.WebGUI.Forms
Text Field
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataFormats Class : Text Field

Specifies the standard ANSI text format. This static field is read-only.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Text As String
Visual Basic (Usage) Copy Code
Dim value As String

value = DataFormats.Text
C#
public static readonly string Text
Managed Extensions for C++
public: static readonly string* Text
C++/CLI
public:
static readonly String^ Text

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataFormats Class
DataFormats Members


Tiff Field

[image]
Gizmox.WebGUI.Forms
Tiff Field
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataFormats Class : Tiff Field

Specifies the Tagged Image File Format (TIFF), which Windows Forms does not directly use. This static field is read-only.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Tiff As String
Visual Basic (Usage) Copy Code
Dim value As String

value = DataFormats.Tiff
C#
public static readonly string Tiff
Managed Extensions for C++
public: static readonly string* Tiff
C++/CLI
public:
static readonly String^ Tiff

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataFormats Class
DataFormats Members


UnicodeText Field

[image]
Gizmox.WebGUI.Forms
UnicodeText Field
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataFormats Class : UnicodeText Field

Specifies the standard Windows Unicode text format. This static field is read-only.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly UnicodeText As String
Visual Basic (Usage) Copy Code
Dim value As String

value = DataFormats.UnicodeText
C#
public static readonly string UnicodeText
Managed Extensions for C++
public: static readonly string* UnicodeText
C++/CLI
public:
static readonly String^ UnicodeText

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataFormats Class
DataFormats Members


WaveAudio Field

[image]
Gizmox.WebGUI.Forms
WaveAudio Field
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataFormats Class : WaveAudio Field

Specifies the wave audio format, which Windows Forms does not directly use. This static field is read-only.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly WaveAudio As String
Visual Basic (Usage) Copy Code
Dim value As String

value = DataFormats.WaveAudio
C#
public static readonly string WaveAudio
Managed Extensions for C++
public: static readonly string* WaveAudio
C++/CLI
public:
static readonly String^ WaveAudio

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataFormats Class
DataFormats Members


DataFormats.Format Class

[image]
Gizmox.WebGUI.Forms
DataFormats.Format Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataFormats.Format Class

Represents a Clipboard format type.

Syntax

Visual Basic (Declaration)
Public Class DataFormats.Format
Visual Basic (Usage) Copy Code
Dim instance As DataFormats.Format
C#
public class DataFormats.Format
Managed Extensions for C++
public __gc class DataFormats.Format
C++/CLI
public ref class DataFormats.Format

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.DataFormats.Format

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

DataFormats.Format Members
Gizmox.WebGUI.Forms Namespace


DataFormats.Format Class Members

[image]
Gizmox.WebGUI.Forms
DataFormats.Format Class Members
See Also Properties Send Feedback
Gizmox.WebGUI.Forms Namespace : DataFormats.Format Class

The following tables list the members exposed by DataFormats.Format.

Public Constructors

 | Name | Description
Public Constructor | DataFormats.Format Constructor | Initializes a new instance of the DataFormats.Format class with a Boolean that indicates whether a Win32 handle is expected.
Top

Public Properties

 | Name | Description
Public Property | Id | Gets the ID number for this format.
Public Property | Name | Gets the name of this format.
Top

See Also

Reference

DataFormats.Format Class
Gizmox.WebGUI.Forms Namespace


DataFormats.Format Constructor

[image]
Gizmox.WebGUI.Forms
DataFormats.Format Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataFormats.Format Class : DataFormats.Format Constructor

name
The name of this format.
id
The ID number for this format.
Initializes a new instance of the DataFormats.Format class with a Boolean that indicates whether a Win32 handle is expected.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String, _
   ByVal id As Integer _
)
Visual Basic (Usage) Copy Code
Dim name As String
Dim id As Integer

Dim instance As DataFormats.Format(name, id)
C#
public DataFormats.Format(
   string name,
   int id
)
Managed Extensions for C++
public: DataFormats.Format(
   string* name,
   int id
)
C++/CLI
public:
DataFormats.Format(
   String^ name,
   int id
)

Parameters

name
The name of this format.
id
The ID number for this format.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataFormats.Format Class
DataFormats.Format Members


DataFormats.Format Class Properties

[image]
Gizmox.WebGUI.Forms
DataFormats.Format Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataFormats.Format Class

For a list of all members of this type, see DataFormats.Format members.

Public Properties

 | Name | Description
Public Property | Id | Gets the ID number for this format.
Public Property | Name | Gets the name of this format.
Top

See Also

Reference

DataFormats.Format Class
Gizmox.WebGUI.Forms Namespace


Id Property

[image]
Gizmox.WebGUI.Forms
Id Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataFormats.Format Class : Id Property

Gets the ID number for this format.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Id As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataFormats.Format
Dim value As Integer

value = instance.Id
C#
public int Id {get;}
Managed Extensions for C++
public: __property int get_Id();
C++/CLI
public:
property int Id {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataFormats.Format Class
DataFormats.Format Members


Name Property

[image]
Gizmox.WebGUI.Forms
Name Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataFormats.Format Class : Name Property

Gets the name of this format.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As DataFormats.Format
Dim value As String

value = instance.Name
C#
public string Name {get;}
Managed Extensions for C++
public: __property string* get_Name();
C++/CLI
public:
property String^ Name {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataFormats.Format Class
DataFormats.Format Members


DataGridView Class

[image]
Gizmox.WebGUI.Forms
DataGridView Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridView Class

Displays data in a customizable grid.

Object Model

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Displays rows and columns of data in a grid you can customize.")>
<DefaultMemberAttribute("Item")>
<ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<ToolboxBitmapAttribute()>
<DesignTimeControllerAttribute()>
<ClientControllerAttribute()>
<ComplexBindingPropertiesAttribute(DataSource="DataSource", DataMember="DataMember")>
<EditorAttribute(EditorBaseTypeName="System.ComponentModel.ComponentEditor, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089", EditorTypeName="Gizmox.WebGUI.Forms.Design.DataGridViewComponentEditor, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<ComVisibleAttribute(True)>
<ClassInterfaceAttribute()>
<ToolboxItemCategoryAttribute("Data")>
<MetadataTagAttribute("DG")>
<SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableDataGrid, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")>
Public Class DataGridView
   Inherits Control
   Implements IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IGatewayControl, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
C#
[SRDescriptionAttribute("Displays rows and columns of data in a grid you can customize.")]
[DefaultMemberAttribute("Item")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ToolboxBitmapAttribute()]
[DesignTimeControllerAttribute()]
[ClientControllerAttribute()]
[ComplexBindingPropertiesAttribute(DataSource="DataSource", DataMember="DataMember")]
[EditorAttribute(EditorBaseTypeName="System.ComponentModel.ComponentEditor, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089", EditorTypeName="Gizmox.WebGUI.Forms.Design.DataGridViewComponentEditor, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ComVisibleAttribute(true)]
[ClassInterfaceAttribute()]
[ToolboxItemCategoryAttribute("Data")]
[MetadataTagAttribute("DG")]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableDataGrid, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
public class DataGridView : Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IGatewayControl, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Managed Extensions for C++
[SRDescriptionAttribute("Displays rows and columns of data in a grid you can customize.")]
[DefaultMemberAttribute("Item")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ToolboxBitmapAttribute()]
[DesignTimeControllerAttribute()]
[ClientControllerAttribute()]
[ComplexBindingPropertiesAttribute(DataSource="DataSource", DataMember="DataMember")]
[EditorAttribute(EditorBaseTypeName="System.ComponentModel.ComponentEditor, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089", EditorTypeName="Gizmox.WebGUI.Forms.Design.DataGridViewComponentEditor, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ComVisibleAttribute(true)]
[ClassInterfaceAttribute()]
[ToolboxItemCategoryAttribute("Data")]
[MetadataTagAttribute("DG")]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableDataGrid, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
public __gc class DataGridView : public Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IGatewayControl, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
C++/CLI
[SRDescriptionAttribute("Displays rows and columns of data in a grid you can customize.")]
[DefaultMemberAttribute("Item")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ToolboxBitmapAttribute()]
[DesignTimeControllerAttribute()]
[ClientControllerAttribute()]
[ComplexBindingPropertiesAttribute(DataSource="DataSource", DataMember="DataMember")]
[EditorAttribute(EditorBaseTypeName="System.ComponentModel.ComponentEditor, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089", EditorTypeName="Gizmox.WebGUI.Forms.Design.DataGridViewComponentEditor, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ComVisibleAttribute(true)]
[ClassInterfaceAttribute()]
[ToolboxItemCategoryAttribute("Data")]
[MetadataTagAttribute("DG")]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableDataGrid, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
public ref class DataGridView : public Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IGatewayControl, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.DataGridView

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

DataGridView Members
Gizmox.WebGUI.Forms Namespace


DataGridView Class Members

[image]
Gizmox.WebGUI.Forms
DataGridView Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridView Class

The following tables list the members exposed by DataGridView.

Public Constructors

 | Name | Description
Public Constructor | DataGridView Constructor | Initializes a new instance of the DataGridView class.
Top

Public Properties

 | Name | Description
Public Property | AdjustedTopLeftHeaderBorderStyle | Gets the border style for the upper-left cell in the DataGridView.
Public Property | AdvancedCellBorderStyle | Gets the border style of the cells in the DataGridView.
Public Property | AdvancedColumnHeadersBorderStyle | Gets the border style of the column header cells in the DataGridView.
Public Property | AdvancedRowHeadersBorderStyle | Gets the border style of the row header cells in the DataGridView.
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | AllowUserToAddRows | Gets or sets a value indicating whether the option to add rows is displayed to the user.
Public Property | AllowUserToDeleteRows | Gets or sets a value indicating whether the user is allowed to delete rows from the DataGridView.
Public Property | AllowUserToOrderColumns | Gets or sets a value indicating whether manual column repositioning is enabled.
Public Property | AllowUserToResizeColumns | Gets or sets a value indicating whether users can resize columns.
Public Property | AllowUserToResizeRows | Gets or sets a value indicating whether users can resize rows.
Public Property | AlternatingRowsDefaultCellStyle | Gets or sets the default cell style applied to odd-numbered rows of the DataGridView.
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | AutoGenerateColumns | Gets or sets a value indicating whether columns are created automatically when the DataSource or DataMember properties are set.
Public Property | AutoSizeColumnsMode | Gets or sets a value indicating how column widths are determined.
Public Property | AutoSizeRowsMode | Gets or sets a value indicating how row heights are determined.
Public Property | BackgroundColor | Gets or sets the background color of the DataGridView.
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Overridden. Gets or sets the border style for the DataGridView.
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | CellBorderStyle | Gets the cell border style for the DataGridView.
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | ClipboardCopyMode | Gets or sets a value that indicates whether users can copy cell text values to the Clipboard and whether row and column header text is included.
Public Property | ColumnCount | Gets or sets the number of columns displayed in the DataGridView.
Public Property | ColumnHeadersBorderStyle | Gets the border style applied to the column headers.
Public Property | ColumnHeadersDefaultCellStyle | Gets or sets the default column header style.
Public Property | ColumnHeadersHeight | Gets or sets the height, in pixels, of the column headers row
Public Property | ColumnHeadersHeightSizeMode | Gets or sets a value indicating whether the height of the column headers is adjustable and whether it can be adjusted by the user or is automatically adjusted to fit the contents of the headers.
Public Property | ColumnHeadersVisible | Gets or sets a value indicating whether the column header row is displayed.
Public Property | Columns | Gets a collection that contains all the columns in the control.
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | CurrentCell | Gets or sets the currently active cell.
Public Property | CurrentCellAddress | Gets the row and column indexes of the currently active cell.
Public Property | CurrentPage | Gets or sets the current page.
Public Property | CurrentRow | Gets the row containing the current cell.
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | DataMember | Gets or sets the name of the list or table in the data source for which the DataGridView is displaying data.
Public Property | DataSource | Gets or sets the data source that the DataGridView is displaying data for.
Public Property | DefaultCellStyle | Gets or sets the default cell style to be applied to the cells in the DataGridView if no other cell style properties are set.
Public Property | DisableNavigation | Gets or sets a value indicating whether [disable navigation].
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DragTargets | Overridden. Gets a value indicating whether this instance is dragable.
Public Property | EditingControl |
Public Property | EditingPanel | Gets the panel that contains the EditingControl.
Public Property | EditMode | Gets or sets a value indicating how to begin editing a cell.
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | EnableHeadersVisualStyles | Gets or sets a value indicating whether row and column headers use the visual styles of the user's current theme if visual styles are enabled for the application.
Public Property | FirstDisplayedCell | Gets or sets the first cell currently displayed in the DataGridView; typically, this cell is in the upper left corner.
Public Property | FirstDisplayedScrollingColumnHiddenWidth | Gets the width of the portion of the column that is currently scrolled out of view..
Public Property | FirstDisplayedScrollingColumnIndex | Gets or sets the index of the column that is the first column displayed on the DataGridView.
Public Property | FirstDisplayedScrollingRowIndex | Gets or sets the index of the row that is the first row displayed on the DataGridView.
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Overridden. Gets or sets the font of the text displayed by the DataGridView.
Public Property | ForeColor | Overridden. Gets or sets the foreground color of the DataGridView.
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | GridColor | Gets or sets the color of the grid lines separating the cells of the DataGridView.
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsCurrentCellDirty | Gets a value indicating whether the current cell has uncommitted changes.
Public Property | IsCurrentCellInEditMode | Gets a value indicating whether the currently active cell is being edited.
Public Property | IsCurrentRowDirty | Gets a value indicating whether the current row has uncommitted changes.
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | Item | Overloaded. Gets or sets the cell located at the intersection of the row with the specified index and the column with the specified name.
Public Property | ItemsPerPage | Gets or sets the current page.
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | LazyMode | Gets or sets a value indicating whether [lazy mode].
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MultiSelect | Gets or sets a value indicating whether the user is allowed to select more than one cell, row, or column of the DataGridView at a time.
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | NewRowIndex | Gets the index of the row for new records.
Public Property | PageFirstIndex | Gets the first item's index in the current page
Public Property | PageLastIndex | Gets the last item's index in the current page
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | ReadOnly | Gets a value indicating whether the user can edit the cells of the DataGridView control.
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | RowCount | Gets or sets the number of rows displayed in the DataGridView.
Public Property | RowHeadersBorderStyle | Gets or sets the border style of the row header cells.
Public Property | RowHeadersDefaultCellStyle | Gets or sets the default style applied to the row header cells.
Public Property | RowHeadersVisible | Gets or sets a value indicating whether the column that contains row headers is displayed.
Public Property | RowHeadersWidth | Gets or sets the width, in pixels, of the column that contains the row headers.
Public Property | RowHeadersWidthSizeMode | Gets or sets a value indicating whether the width of the row headers is adjustable and whether it can be adjusted by the user or is automatically adjusted to fit the contents of the headers.
Public Property | Rows | Gets a collection that contains all the rows in the DataGridView control.
Public Property | RowsDefaultCellStyle | Gets or sets the default style applied to the row cells of the DataGridView.
Public Property | RowTemplate | Gets or sets the row that represents the template for all the rows in the control.
Public Property | ScrollBars | Gets or sets the type of scroll bars to display for the DataGridView control.
Public Property | SelectedCells | Gets the collection of cells selected by the user.
Public Property | SelectedColumns | Gets the collection of columns selected by the user.
Public Property | SelectedRows | Gets the collection of rows selected by the user.
Public Property | SelectionMode | Gets or sets a value indicating how the cells of the DataGridView can be selected.
Public Property | ShowCellErrors | Gets or sets a value indicating whether to show cell errors.
Public Property | ShowCellToolTips | Gets or sets a value indicating whether or not ToolTips will show when the mouse pointer pauses on a cell.
Public Property | ShowEditingIcon | Gets or sets a value indicating whether or not the editing glyph is visible in the row header of the cell being edited.
Public Property | ShowRowErrors | Gets or sets a value indicating whether row headers will display error glyphs for each row that contains a data entry error.
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | SortedColumn | Gets the column by which the DataGridView contents are currently sorted.
Public Property | SortOrder | Gets a value indicating whether the items in the DataGridView control are sorted in ascending or descending order, or are not sorted.
Public Property | StandardTab | Gets or sets a value indicating whether the TAB key moves the focus to the next control in the tab order rather than moving focus to the next cell in the control.
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | TopLeftHeaderCell | Gets or sets the header cell located in the upper left corner of the DataGridView control.
Public Property | TotalItems | Gets or sets the total items.
Public Property | TotalPages | Gets or sets the total pages.
Public Property | UseInternalPaging | Uses internal paging algorithem
Public Property | UserSetCursor | Gets the default or user-specified value of the Control.Cursor property.
Public Property | VerticalScrollingOffset | Gets the number of pixels by which the control is scrolled vertically.
Public Property | VirtualMode | Gets or sets a value indicating whether you have provided your own data-management operations for the DataGridView control.
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | Overridden. Override the default back color
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | Overridden. Gets the default initial size of the control.
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | Overridden.
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

Public Methods

 | Name | Description
Public Method | AdjustColumnHeaderBorderStyle | Adjusts the DataGridViewAdvancedBorderStyle for a column header cell of a DataGridView that is currently being painted.
Public Method | AreAllCellsSelected | Returns a value indicating whether all the DataGridView cells are currently selected.
Public Method | AutoResizeColumn | Overloaded. Adjusts the width of the specified column to fit the contents of all its cells, including the header cell.
Public Method | AutoResizeColumnHeadersHeight | Overloaded. Adjusts the height of the column headers to fit the contents of the largest column header.
Public Method | AutoResizeColumns | Overloaded. Adjusts the width of all columns to fit the contents of all their cells, including the header cells.
Public Method | AutoResizeRow | Overloaded. Adjusts the height of the specified row to fit the contents of all its cells including the header cell.
Public Method | AutoResizeRowHeadersWidth | Overloaded. Adjusts the width of the row headers using the specified size mode.
Public Method | AutoResizeRows | Overloaded. Adjusts the heights of all rows to fit the contents of all their cells, including the header cells.
Public Method | BeginEdit | Puts the current cell in edit mode.
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | CancelEdit | Cancels edit mode for the currently selected cell and discards any changes.
Public Method | ClearSelection | Overloaded. Clears the current selection by unselecting all selected cells.
Public Method | CommitEdit | Commits changes in the current cell to the data cache without ending edit mode.
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | DisplayedColumnCount | Returns the number of columns displayed to the user.
Public Method | DisplayedRowCount | Returns the number of rows displayed to the user.
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | EndEdit | Overloaded. Commits and ends the edit operation on the current cell using the default error context.
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetCellCount | Gets the number of cells that satisfy the provided filter.
Public Method | GetClipboardContent | Overloaded. Retrieves the formatted values that represent the contents of the selected cells for copying to the Clipboard.
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | InvalidateCell | Overloaded. Invalidates the specified cell of the DataGridView, forcing it to be repainted.
Public Method | InvalidateColumn | Invalidates the specified column of the DataGridView, forcing it to be repainted.
Public Method | InvalidateRow | Invalidates the specified row of the DataGridView, forcing it to be repainted.
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | NotifyCurrentCellDirty | Notifies the DataGridView that the current cell has uncommitted changes.
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RefreshEdit | Refreshes the value of the current cell with the underlying cell value when the cell is in edit mode, discarding any previous value.
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SelectAll | Selects all the cells in the DataGridView.
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | Sort | Overloaded. Sorts the contents of the DataGridView control using an implementation of the IComparer interface.
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Public Method | UpdateCellErrorText | Forces the cell at the specified location to update its error text.
Public Method | UpdateCellValue | Forces the control to update its display of the cell at the specified location based on its new value, applying any automatic sizing modes currently in effect.
Public Method | UpdateRowErrorText | Overloaded. Forces the row at the given row index to update its error text.
Public Method | UpdateRowHeightInfo | Forces the specified row or rows to update their height information.
Top

Protected Methods

 | Name | Description
Protected Method | AccessibilityNotifyCurrentCellChanged | Notifies the accessible client applications when a new cell becomes the current cell.
Protected Method | AdjustShrinkingRows |
Protected Method | CreateColumnsInstance | Creates and returns a new DataGridViewColumnCollection.
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | CreateRowsInstance | Creates and returns a new DataGridViewRowCollection.
Protected Method | ExitBulkLayout |
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Overridden.
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Overridden.
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from Control)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnAllowUserToAddRowsChanged | Raises the AllowUserToAddRowsChanged event.
Protected Method | OnAllowUserToDeleteRowsChanged | Raises the AllowUserToDeleteRowsChanged event.
Protected Method | OnAllowUserToOrderColumnsChanged | Raises the AllowUserToOrderColumnsChanged event.
Protected Method | OnAllowUserToResizeColumnsChanged | Raises the AllowUserToResizeColumnsChanged event.
Protected Method | OnAllowUserToResizeRowsChanged | Raises the AllowUserToResizeRowsChanged event.
Protected Method | OnAlternatingRowsDefaultCellStyleChanged | Raises the AlternatingRowsDefaultCellStyleChanged event.
Protected Method | OnAutoGenerateColumnsChanged | Raises the AutoGenerateColumnsChanged event.
Protected Method | OnAutoSizeColumnModeChanged | Raises the AutoSizeColumnModeChanged event.
Protected Method | OnAutoSizeColumnsModeChanged | Raises the AutoSizeColumnsModeChanged event.
Protected Method | OnAutoSizeRowsModeChanged | Raises the AutoSizeRowsModeChanged event.
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundColorChanged | Raises the BackgroundColorChanged event.
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | Overridden. Raises the Control.BindingContextChanged event.
Protected Method | OnBorderStyleChanged | Raises the BorderStyleChanged event.
Protected Method | OnCancelRowEdit | Raises the CancelRowEdit event.
Protected Method | OnCellBorderStyleChanged | Raises the CellBorderStyleChanged event.
Protected Method | OnCellClick | Raises the CellClick event.
Protected Method | OnCellContentClick | Raises the CellContentClick event.
Protected Method | OnCellContentDoubleClick | Raises the CellContentDoubleClick event.
Protected Method | OnCellContextMenuStripChanged | Raises the CellContextMenuStripChanged event.
Protected Method | OnCellDoubleClick | Raises the CellDoubleClick event.
Protected Method | OnCellEnter |
Protected Method | OnCellErrorTextChanged | Raises the CellErrorTextChanged event.
Protected Method | OnCellErrorTextNeeded | Raises the CellErrorTextNeeded event.
Protected Method | OnCellFormatting | Raises the CellFormatting event.
Protected Method | OnCellLeave |
Protected Method | OnCellMouseClick | Raises the CellMouseClick event.
Protected Method | OnCellMouseDoubleClick | Raises the CellMouseDoubleClick event.
Protected Method | OnCellMouseDown | Raises the CellMouseDown event.
Protected Method | OnCellMouseEnter | Raises the CellMouseEnter event.
Protected Method | OnCellMouseLeave | Raises the CellMouseLeave event.
Protected Method | OnCellMouseMove | Raises the CellMouseMove event.
Protected Method | OnCellMouseUp | Raises the CellMouseUp event.
Protected Method | OnCellStateChanged | Raises the CellStateChanged event.
Protected Method | OnCellStyleChanged | Raises the CellStyleChanged event.
Protected Method | OnCellStyleContentChanged | Raises the CellStyleContentChanged event.
Protected Method | OnCellToolTipTextChanged | Raises the CellToolTipTextChanged event.
Protected Method | OnCellToolTipTextNeeded | Raises the CellToolTipTextNeeded event.
Protected Method | OnCellValueChanged | Raises the CellValueChanged event.
Protected Method | OnCellValueNeeded | Raises the CellValueNeeded event.
Protected Method | OnCellValuePushed | Raises the CellValuePushed event.
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnColumnAdded | Raises the ColumnAdded event.
Protected Method | OnColumnContextMenuStripChanged | Raises the ColumnContextMenuStripChanged event.
Protected Method | OnColumnDataPropertyNameChanged | Raises the ColumnDataPropertyNameChanged event.
Protected Method | OnColumnDefaultCellStyleChanged | Raises the ColumnDefaultCellStyleChanged event.
Protected Method | OnColumnDisplayIndexChanged | Raises the ColumnDisplayIndexChanged event.
Protected Method | OnColumnDividerDoubleClick | Raises the ColumnDividerDoubleClick event.
Protected Method | OnColumnDividerWidthChanged | Raises the ColumnDividerWidthChanged event.
Protected Method | OnColumnHeaderCellChanged | Raises the ColumnHeaderCellChanged event.
Protected Method | OnColumnHeaderMouseClick | Raises the ColumnHeaderMouseClick event.
Protected Method | OnColumnHeaderMouseDoubleClick | Raises the ColumnHeaderMouseDoubleClick event.
Protected Method | OnColumnHeadersBorderStyleChanged | Raises the ColumnHeadersBorderStyleChanged event.
Protected Method | OnColumnHeadersDefaultCellStyleChanged | Raises the ColumnHeadersDefaultCellStyleChanged event.
Protected Method | OnColumnHeadersHeightChanged | Raises the ColumnHeadersHeightChanged event.
Protected Method | OnColumnHeadersHeightSizeModeChanged | Raises the ColumnHeadersHeightSizeModeChanged event.
Protected Method | OnColumnMinimumWidthChanged | Raises the ColumnMinimumWidthChanged event.
Protected Method | OnColumnNameChanged | Raises the ColumnNameChanged event.
Protected Method | OnColumnRemoved | Raises the ColumnRemoved event.
Protected Method | OnColumnSortModeChanged | Raises the ColumnSortModeChanged event.
Protected Method | OnColumnStateChanged | Raises the ColumnStateChanged event.
Protected Method | OnColumnToolTipTextChanged | Raises the ColumnToolTipTextChanged event.
Protected Method | OnColumnWidthChanged | Raises the ColumnWidthChanged event.
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCurrentCellChanged | Raises the CurrentCellChanged event.
Protected Method | OnCurrentCellDirtyStateChanged | Raises the CurrentCellDirtyStateChanged event.
Protected Method | OnCursorChanged | Overridden. Raises the Control.CursorChanged event and updates the UserSetCursor property if the cursor was changed in user code.
Protected Method | OnDataBindingComplete | Raises the DataBindingComplete event.
Protected Method | OnDataError | Raises the DataError event.
Protected Method | OnDataMemberChanged | Raises the DataMemberChanged event.
Protected Method | OnDataSourceChanged | Raises the DataSourceChanged event.
Protected Method | OnDefaultCellStyleChanged | Raises the DefaultCellStyleChanged event.
Protected Method | OnDefaultValuesNeeded | Raises the DefaultValuesNeeded event.
Protected Method | OnDoubleClick | Overridden. Raises the Control.DoubleClick event.
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEditingControlShowing | Raises the EditingControlShowing event.
Protected Method | OnEditModeChanged | Raises the EditModeChanged event.
Protected Method | OnEnabledChanged | Overridden.
Protected Method | OnEnter | Overridden.
Protected Method | OnFontChanged | Overridden. Raises the DataGridView.FontChanged event.
Protected Method | OnForeColorChanged | Overridden. Raises the Control.ForeColorChanged event.
Protected Method | OnGotFocus | Overridden.
Protected Method | OnGridColorChanged | Raises the GridColorChanged event.
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Overridden. Raises the Control.KeyDown event.
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Overridden. Raises the Control.KeyUp event.
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | Overridden.
Protected Method | OnMouseClick | Overridden. Raises the MouseClick event.
Protected Method | OnMouseDoubleClick | Overridden.
Protected Method | OnMouseDown | Overridden. Raises the Control.MouseDown event.
Protected Method | OnMouseUp | Overridden. Raises the Control.MouseUp event.
Protected Method | OnMultiSelectChanged | Raises the MultiSelectChanged event.
Protected Method | OnNewRowNeeded | Raises the NewRowNeeded event.
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnReadOnlyChanged | Raises the ReadOnlyChanged event.
Protected Method | OnResize | Overridden. Raises the Control.Resize event.
Protected Method | OnRowContextMenuStripChanged | Raises the RowContextMenuStripChanged event.
Protected Method | OnRowContextMenuStripNeeded | Raises the RowContextMenuStripNeeded event.
Protected Method | OnRowDefaultCellStyleChanged | Raises the RowDefaultCellStyleChanged event.
Protected Method | OnRowDirtyStateNeeded | Raises the RowDirtyStateNeeded event.
Protected Method | OnRowDividerDoubleClick | Raises the RowDividerDoubleClick event.
Protected Method | OnRowDividerHeightChanged | Raises the RowDividerHeightChanged event.
Protected Method | OnRowEnter | Raises the RowEnter event.
Protected Method | OnRowErrorTextChanged | Raises the RowErrorTextChanged event.
Protected Method | OnRowErrorTextNeeded | Raises the RowErrorTextNeeded event.
Protected Method | OnRowHeaderCellChanged | Raises the RowHeaderCellChanged event.
Protected Method | OnRowHeaderMouseClick | Raises the RowHeaderMouseClick event.
Protected Method | OnRowHeaderMouseDoubleClick | Raises the RowHeaderMouseDoubleClick event.
Protected Method | OnRowHeadersBorderStyleChanged | Raises the RowHeadersBorderStyleChanged event.
Protected Method | OnRowHeadersDefaultCellStyleChanged | Raises the RowHeadersDefaultCellStyleChanged event.
Protected Method | OnRowHeadersWidthChanged | Raises the RowHeadersWidthChanged event.
Protected Method | OnRowHeadersWidthSizeModeChanged | Raises the RowHeadersWidthSizeModeChanged event.
Protected Method | OnRowHeightChanged | Raises the RowHeightChanged event.
Protected Method | OnRowHeightInfoNeeded | Raises the RowHeightInfoNeeded event.
Protected Method | OnRowHeightInfoPushed | Raises the RowHeightInfoPushed event.
Protected Method | OnRowLeave | Raises the RowLeave event.
Protected Method | OnRowMinimumHeightChanged | Raises the RowMinimumHeightChanged event.
Protected Method | OnRowsAdded | Raises the RowsAdded event.
Protected Method | OnRowsDefaultCellStyleChanged | Raises the RowsDefaultCellStyleChanged event.
Protected Method | OnRowsRemoved | Raises the RowsRemoved event.
Protected Method | OnRowStateChanged | Raises the RowStateChanged event.
Protected Method | OnRowUnshared | Raises the RowUnshared event.
Protected Method | OnRowValidated | Raises the RowValidated event.
Protected Method | OnRowValidating | Raises the RowValidating event.
Protected Method | OnSelectionChanged | Raises the SelectionChanged event.
Protected Method | OnSortCompare | Raises the SortCompare event.
Protected Method | OnSorted | Raises the Sorted event.
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnUserAddedRow | Raises the UserAddedRow event.
Protected Method | OnUserDeletedRow | Raises the UserDeletedRow event.
Protected Method | OnUserDeletingRow | Raises the UserDeletingRow event.
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | Overridden. Raises the Validating event.
Protected Method | OnVisibleChanged | Overridden.
Protected Method | PaintBackground | Paints the background of the DataGridView.
Protected Method | ProcessAKey | Processes the A key.
Protected Method | ProcessDataGridViewKey | Processes keys used for navigating in the DataGridView.
Protected Method | ProcessDeleteKey | Processes the DELETE key.
Protected Method | ProcessDownKey | Processes the DOWN ARROW key.
Protected Method | ProcessEndKey | Processes the END key.
Protected Method | ProcessEnterKey | Processes the ENTER key.
Protected Method | ProcessEscapeKey | Processes the ESC key.
Protected Method | ProcessF2Key | Processes the F2 key.
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | ProcessHomeKey | Processes the HOME key.
Protected Method | ProcessInsertKey | Processes the INSERT key.
Protected Method | ProcessLeftKey | Processes the LEFT ARROW key.
Protected Method | ProcessNextKey | Processes the PAGE DOWN key.
Protected Method | ProcessPriorKey | Processes the PAGE UP key.
Protected Method | ProcessRightKey | Processes the RIGHT ARROW key.
Protected Method | ProcessSpaceKey | Processes the SPACEBAR.
Protected Method | ProcessTabKey | Processes the TAB key.
Protected Method | ProcessUpKey | Processes the UP ARROW key.
Protected Method | ProcessZeroKey | Processes the 0 key.
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Control)
Protected Method | RenderAttributes | Overridden. Renders the control's meta attributes
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Overridden. Renders the controls sub tree
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | Overridden. Renders only the control's updated meta attributes
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetCurrentCellAddressCore | Sets the currently active cell.
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetSelectedCellCore | Changes the selection state of the cell with the specified row and column indexes.
Protected Method | SetSelectedColumnCore | Changes the selection state of the column with the specified index.
Protected Method | SetSelectedRowCore | Changes the selection state of the row with the specified index.
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

Public Events

 | Name | Description
Public Event | AllowUserToAddRowsChanged | Occurs when the value of the AllowUserToAddRows property changes.
Public Event | AllowUserToDeleteRowsChanged | Occurs when the value of the AllowUserToDeleteRowsChanged property changes.
Public Event | AllowUserToOrderColumnsChanged | Occurs when the value of the AllowUserToOrderColumns property changes.
Public Event | AllowUserToResizeColumnsChanged | Occurs when the value of the AllowUserToResizeColumns property changes.
Public Event | AllowUserToResizeRowsChanged | Occurs when the value of the AllowUserToResizeRows property changes.
Public Event | AlternatingRowsDefaultCellStyleChanged | Occurs when the value of the DataGridView.AlternatingRowsDefaultCellStyle property changes.
Public Event | AutoGenerateColumnsChanged | Occurs when the value of the AutoGenerateColumnsChanged property changes.
Public Event | AutoSizeColumnModeChanged | Occurs when the value of the DataGridViewColumn.AutoSizeMode property of a column changes.
Public Event | AutoSizeColumnsModeChanged | Occurs when the value of the DataGridView.AutoSizeColumnsMode property changes.
Public Event | AutoSizeRowsModeChanged | Occurs when the value of the DataGridViewAutoSizeRowsMode property changes.
Public Event | BackgroundColorChanged | Occurs when the value of the BackgroundColor property changes.
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | BorderStyleChanged | Occurs when the value of the BorderStyle property changes.
Public Event | CancelRowEdit | Occurs when the VirtualMode property of a DataGridView control is true and the cancels edits in a row.
Public Event | CellBeginEdit | Occurs when edit mode starts for the selected cell.
Public Event | CellBorderStyleChanged | Occurs when the border style of a cell changes.
Public Event | CellClick | Occurs when any part of a cell is clicked.
Public Event | CellContentClick | Occurs when the content within a cell is clicked.
Public Event | CellContentDoubleClick | Occurs when the user double-clicks a cell's contents.
Public Event | CellContextMenuStripChanged | Occurs when the ContextMenuStrip property changes.
Public Event | CellDoubleClick | Occurs when the user double-clicks anywhere in a cell.
Public Event | CellEndEdit | Occurs when edit mode stops for the currently selected cell.
Public Event | CellEnter | Occurs when the current cell changes in the DataGridView control or when the control receives input focus.
Public Event | CellErrorTextChanged | Occurs when the value of the DataGridViewCell.ErrorText property of a cell changes.
Public Event | CellErrorTextNeeded | Occurs when a cell's error text is needed.
Public Event | CellFormatting | Occurs when the contents of a cell need to be formatted for display.
Public Event | CellLeave | Occurs when a cell loses input focus and is no longer the current cell.
Public Event | CellMouseClick | Occurs whenever the user clicks anywhere on a cell with the mouse.
Public Event | CellMouseDoubleClick | Occurs when a cell within the DataGridView is double-clicked.
Public Event | CellMouseDown | Occurs when the user presses a mouse button while the mouse pointer is within the boundaries of a cell.
Public Event | CellMouseEnter | Occurs when the mouse pointer enters a cell.
Public Event | CellMouseLeave | Occurs when the mouse pointer leaves a cell.
Public Event | CellMouseMove | Occurs when the mouse pointer moves over the DataGridView control.
Public Event | CellMouseUp | Occurs when the user releases a mouse button while over a cell.
Public Event | CellParsing | Occurs when a cell leaves edit mode if the cell value has been modified.
Public Event | CellStateChanged | Occurs when a cell state changes, such as when the cell loses or gains focus.
Public Event | CellStyleChanged | Occurs when the DataGridViewCell.Style property of a DataGridViewCell changes.
Public Event | CellStyleContentChanged | Occurs when one of the values of a cell style changes.
Public Event | CellToolTipTextChanged | Occurs when the DataGridViewCell.ToolTipText property value changes for a cell in the DataGridView.
Public Event | CellToolTipTextNeeded | Occurs when a cell's ToolTip text is needed.
Public Event | CellValidated | Occurs after the cell has finished validating.
Public Event | CellValidating | Occurs when a cell loses input focus, enabling content validation.
Public Event | CellValueChanged | Occurs when the value of a cell changes.
Public Event | CellValueNeeded | Occurs when the VirtualMode property of the DataGridView control is true and the DataGridView requires a value for a cell in order to format and display the cell.
Public Event | CellValuePushed | Occurs when the VirtualMode property of the DataGridView control is true and a cell value has changed and requires storage in the underlying data source.
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ColumnAdded | Occurs when a column is added to the control.
Public Event | ColumnContextMenuStripChanged | Occurs when the ContextMenuStrip property of a column changes.
Public Event | ColumnDataPropertyNameChanged | Occurs when the value of the DataGridViewColumn.DataPropertyName property for a column changes.
Public Event | ColumnDefaultCellStyleChanged | Occurs when the value of the DataGridViewBand.DefaultCellStyle property for a column changes.
Public Event | ColumnDisplayIndexChanged | Occurs when the value the DataGridViewColumn.DisplayIndex property for a column changes.
Public Event | ColumnDividerDoubleClick | Occurs when the user double-clicks a divider between two columns.
Public Event | ColumnDividerWidthChanged | Occurs when the DataGridViewColumn.DividerWidth property changes.
Public Event | ColumnHeaderCellChanged | Occurs when the contents of a column header cell change.
Public Event | ColumnHeaderMouseClick | Occurs when the user clicks a column header.
Public Event | ColumnHeaderMouseDoubleClick | Occurs when a column header is double-clicked.
Public Event | ColumnHeadersBorderStyleChanged | Occurs when the DataGridView.ColumnHeadersBorderStyle property changes.
Public Event | ColumnHeadersDefaultCellStyleChanged | Occurs when the value of the DataGridView.ColumnHeadersDefaultCellStyle property changes.
Public Event | ColumnHeadersHeightChanged | Occurs when the value of the ColumnHeadersHeight property changes.
Public Event | ColumnHeadersHeightSizeModeChanged | Occurs when the value of the ColumnHeadersHeightSizeMode property changes.
Public Event | ColumnMinimumWidthChanged | Occurs when the value of the DataGridViewColumn.MinimumWidth property for a column changes.
Public Event | ColumnNameChanged | Occurs when the value of the DataGridViewColumn.Name property for a column changes.
Public Event | ColumnRemoved | Occurs when a column is removed from the control.
Public Event | ColumnSortModeChanged | Occurs when the value of the DataGridViewColumn.SortMode property for a column changes.
Public Event | ColumnStateChanged | Occurs when a column changes state, such as gaining or losing focus.
Public Event | ColumnToolTipTextChanged | Occurs when the DataGridViewColumn.ToolTipText property value changes for a column in the DataGridView.
Public Event | ColumnWidthChanged | Occurs when the value of the DataGridViewColumn.Width property for a column changes.
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CurrentCellChanged | Occurs when the CurrentCell property changes.
Public Event | CurrentCellDirtyStateChanged | Occurs when the state of a cell changes in relation to a change in its contents.
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | DataBindingComplete | Occurs after a data-binding operation has finished.
Public Event | DataError | Occurs when an external data-parsing or validation operation throws an exception, or when an attempt to commit data to a data source fails.
Public Event | DataMemberChanged | Occurs when value of the DataMember property changes.
Public Event | DataSourceChanged | Occurs when the value of the DataSource property changes.
Public Event | DefaultCellStyleChanged | Occurs when the value of the DataGridView.DefaultCellStyle property changes.
Public Event | DefaultValuesNeeded | Occurs when the user enters the row for new records so that it can be populated with default values.
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | EditingControlShowing | Occurs when a control for editing a cell is showing.
Public Event | EditModeChanged | Occurs when the value of the EditMode property changes.
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the Font property value changes.
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | GridColorChanged | Occurs when the value of the GridColor property changes.
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MultiSelectChanged | Occurs when the value of the MultiSelect property changes.
Public Event | NewRowNeeded | Occurs when the VirtualMode property of the DataGridView is true and the user navigates to the new row at the bottom of the DataGridView.
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | PagingChanged | Occurs when the paging params have changed.
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | ReadOnlyChanged | Occurs when the ReadOnly property changes.
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | RowContextMenuStripChanged | Occurs when the ContextMenuStrip property changes.
Public Event | RowContextMenuStripNeeded | Occurs when a row's shortcut menu is needed.
Public Event | RowDefaultCellStyleChanged | Occurs when the value of the DataGridViewBand.DefaultCellStyle property for a row changes.
Public Event | RowDirtyStateNeeded | Occurs when the VirtualMode property of the DataGridView control is true and the DataGridView needs to determine whether the current row has uncommitted changes.
Public Event | RowDividerDoubleClick | Occurs when the user double-clicks the divider between two rows.
Public Event | RowDividerHeightChanged | Occurs when the DataGridViewRow.DividerHeight property changes.
Public Event | RowEnter | Occurs when a row receives input focus and becomes the current row.
Public Event | RowErrorTextChanged | Occurs when the DataGridViewRow.ErrorText property of a row changes.
Public Event | RowErrorTextNeeded | Occurs when a row's error text is needed.
Public Event | RowHeaderCellChanged | Occurs when the user changes the contents of a row header cell.
Public Event | RowHeaderMouseClick | Occurs when the user clicks within the boundaries of a row header.
Public Event | RowHeaderMouseDoubleClick | Occurs when a row header is double-clicked.
Public Event | RowHeadersBorderStyleChanged | Occurs when the DataGridView.RowHeadersBorderStyle property changes.
Public Event | RowHeadersDefaultCellStyleChanged | Occurs when the value of the DataGridView.RowHeadersDefaultCellStyle property changes.
Public Event | RowHeadersWidthChanged | Occurs when value of the RowHeadersWidth property changes.
Public Event | RowHeadersWidthSizeModeChanged | Occurs when the value of the RowHeadersWidthSizeMode property changes.
Public Event | RowHeightChanged | Occurs when the value of the DataGridViewRow.Height property for a row changes.
Public Event | RowHeightInfoNeeded | Occurs when information about row height is requested.
Public Event | RowHeightInfoPushed | Occurs when the user changes the height of a row.
Public Event | RowLeave | Occurs when a row loses input focus and is no longer the current row.
Public Event | RowMinimumHeightChanged | Occurs when the value of the DataGridViewRow.MinimumHeight property for a row changes.
Public Event | RowsAdded | Occurs after a new row is added to the DataGridView.
Public Event | RowsDefaultCellStyleChanged | Occurs when the value of the DataGridView.RowsDefaultCellStyle property changes.
Public Event | RowsRemoved | Occurs when a row or rows are deleted from the DataGridView.
Public Event | RowStateChanged | Occurs when a row changes state, such as losing or gaining input focus.
Public Event | RowUnshared | Occurs when a row's state changes from shared to unshared.
Public Event | RowValidated | Occurs after a row has finished validating.
Public Event | RowValidating | Occurs when a row is validating.
Public Event | SelectionChanged | Occurs when the current selection changes.
Public Event | SelectionChangedQueued | Occurs when the current selection changes (queued version).
Public Event | SortCompare | Occurs when the DataGridView compares two cell values to perform a sort operation.
Public Event | Sorted | Occurs when the DataGridView control completes a sorting operation.
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | UserAddedRow | Occurs when the user has finished adding a row to the DataGridView control.
Public Event | UserDeletedRow | Occurs when the user has finished deleting a row from the DataGridView control.
Public Event | UserDeletingRow | Occurs when the user deletes a row from the DataGridView control.
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

DataGridView Class
Gizmox.WebGUI.Forms Namespace


DataGridView Constructor

[image]
Gizmox.WebGUI.Forms
DataGridView Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : DataGridView Constructor

Initializes a new instance of the DataGridView class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As DataGridView()
C#
public DataGridView()
Managed Extensions for C++
public: DataGridView();
C++/CLI
public:
DataGridView();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


DataGridView Class Methods

[image]
Gizmox.WebGUI.Forms
DataGridView Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridView Class

For a list of all members of this type, see DataGridView members.

Public Methods

 | Name | Description
Public Method | AdjustColumnHeaderBorderStyle | Adjusts the DataGridViewAdvancedBorderStyle for a column header cell of a DataGridView that is currently being painted.
Public Method | AreAllCellsSelected | Returns a value indicating whether all the DataGridView cells are currently selected.
Public Method | AutoResizeColumn | Overloaded. Adjusts the width of the specified column to fit the contents of all its cells, including the header cell.
Public Method | AutoResizeColumnHeadersHeight | Overloaded. Adjusts the height of the column headers to fit the contents of the largest column header.
Public Method | AutoResizeColumns | Overloaded. Adjusts the width of all columns to fit the contents of all their cells, including the header cells.
Public Method | AutoResizeRow | Overloaded. Adjusts the height of the specified row to fit the contents of all its cells including the header cell.
Public Method | AutoResizeRowHeadersWidth | Overloaded. Adjusts the width of the row headers using the specified size mode.
Public Method | AutoResizeRows | Overloaded. Adjusts the heights of all rows to fit the contents of all their cells, including the header cells.
Public Method | BeginEdit | Puts the current cell in edit mode.
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | CancelEdit | Cancels edit mode for the currently selected cell and discards any changes.
Public Method | ClearSelection | Overloaded. Clears the current selection by unselecting all selected cells.
Public Method | CommitEdit | Commits changes in the current cell to the data cache without ending edit mode.
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | DisplayedColumnCount | Returns the number of columns displayed to the user.
Public Method | DisplayedRowCount | Returns the number of rows displayed to the user.
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | EndEdit | Overloaded. Commits and ends the edit operation on the current cell using the default error context.
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetCellCount | Gets the number of cells that satisfy the provided filter.
Public Method | GetClipboardContent | Overloaded. Retrieves the formatted values that represent the contents of the selected cells for copying to the Clipboard.
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | InvalidateCell | Overloaded. Invalidates the specified cell of the DataGridView, forcing it to be repainted.
Public Method | InvalidateColumn | Invalidates the specified column of the DataGridView, forcing it to be repainted.
Public Method | InvalidateRow | Invalidates the specified row of the DataGridView, forcing it to be repainted.
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | NotifyCurrentCellDirty | Notifies the DataGridView that the current cell has uncommitted changes.
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RefreshEdit | Refreshes the value of the current cell with the underlying cell value when the cell is in edit mode, discarding any previous value.
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SelectAll | Selects all the cells in the DataGridView.
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | Sort | Overloaded. Sorts the contents of the DataGridView control using an implementation of the IComparer interface.
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Public Method | UpdateCellErrorText | Forces the cell at the specified location to update its error text.
Public Method | UpdateCellValue | Forces the control to update its display of the cell at the specified location based on its new value, applying any automatic sizing modes currently in effect.
Public Method | UpdateRowErrorText | Overloaded. Forces the row at the given row index to update its error text.
Public Method | UpdateRowHeightInfo | Forces the specified row or rows to update their height information.
Top

Protected Methods

 | Name | Description
Protected Method | AccessibilityNotifyCurrentCellChanged | Notifies the accessible client applications when a new cell becomes the current cell.
Protected Method | AdjustShrinkingRows |
Protected Method | CreateColumnsInstance | Creates and returns a new DataGridViewColumnCollection.
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | CreateRowsInstance | Creates and returns a new DataGridViewRowCollection.
Protected Method | ExitBulkLayout |
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Overridden.
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Overridden.
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from Control)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnAllowUserToAddRowsChanged | Raises the AllowUserToAddRowsChanged event.
Protected Method | OnAllowUserToDeleteRowsChanged | Raises the AllowUserToDeleteRowsChanged event.
Protected Method | OnAllowUserToOrderColumnsChanged | Raises the AllowUserToOrderColumnsChanged event.
Protected Method | OnAllowUserToResizeColumnsChanged | Raises the AllowUserToResizeColumnsChanged event.
Protected Method | OnAllowUserToResizeRowsChanged | Raises the AllowUserToResizeRowsChanged event.
Protected Method | OnAlternatingRowsDefaultCellStyleChanged | Raises the AlternatingRowsDefaultCellStyleChanged event.
Protected Method | OnAutoGenerateColumnsChanged | Raises the AutoGenerateColumnsChanged event.
Protected Method | OnAutoSizeColumnModeChanged | Raises the AutoSizeColumnModeChanged event.
Protected Method | OnAutoSizeColumnsModeChanged | Raises the AutoSizeColumnsModeChanged event.
Protected Method | OnAutoSizeRowsModeChanged | Raises the AutoSizeRowsModeChanged event.
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundColorChanged | Raises the BackgroundColorChanged event.
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | Overridden. Raises the Control.BindingContextChanged event.
Protected Method | OnBorderStyleChanged | Raises the BorderStyleChanged event.
Protected Method | OnCancelRowEdit | Raises the CancelRowEdit event.
Protected Method | OnCellBorderStyleChanged | Raises the CellBorderStyleChanged event.
Protected Method | OnCellClick | Raises the CellClick event.
Protected Method | OnCellContentClick | Raises the CellContentClick event.
Protected Method | OnCellContentDoubleClick | Raises the CellContentDoubleClick event.
Protected Method | OnCellContextMenuStripChanged | Raises the CellContextMenuStripChanged event.
Protected Method | OnCellDoubleClick | Raises the CellDoubleClick event.
Protected Method | OnCellEnter |
Protected Method | OnCellErrorTextChanged | Raises the CellErrorTextChanged event.
Protected Method | OnCellErrorTextNeeded | Raises the CellErrorTextNeeded event.
Protected Method | OnCellFormatting | Raises the CellFormatting event.
Protected Method | OnCellLeave |
Protected Method | OnCellMouseClick | Raises the CellMouseClick event.
Protected Method | OnCellMouseDoubleClick | Raises the CellMouseDoubleClick event.
Protected Method | OnCellMouseDown | Raises the CellMouseDown event.
Protected Method | OnCellMouseEnter | Raises the CellMouseEnter event.
Protected Method | OnCellMouseLeave | Raises the CellMouseLeave event.
Protected Method | OnCellMouseMove | Raises the CellMouseMove event.
Protected Method | OnCellMouseUp | Raises the CellMouseUp event.
Protected Method | OnCellStateChanged | Raises the CellStateChanged event.
Protected Method | OnCellStyleChanged | Raises the CellStyleChanged event.
Protected Method | OnCellStyleContentChanged | Raises the CellStyleContentChanged event.
Protected Method | OnCellToolTipTextChanged | Raises the CellToolTipTextChanged event.
Protected Method | OnCellToolTipTextNeeded | Raises the CellToolTipTextNeeded event.
Protected Method | OnCellValueChanged | Raises the CellValueChanged event.
Protected Method | OnCellValueNeeded | Raises the CellValueNeeded event.
Protected Method | OnCellValuePushed | Raises the CellValuePushed event.
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnColumnAdded | Raises the ColumnAdded event.
Protected Method | OnColumnContextMenuStripChanged | Raises the ColumnContextMenuStripChanged event.
Protected Method | OnColumnDataPropertyNameChanged | Raises the ColumnDataPropertyNameChanged event.
Protected Method | OnColumnDefaultCellStyleChanged | Raises the ColumnDefaultCellStyleChanged event.
Protected Method | OnColumnDisplayIndexChanged | Raises the ColumnDisplayIndexChanged event.
Protected Method | OnColumnDividerDoubleClick | Raises the ColumnDividerDoubleClick event.
Protected Method | OnColumnDividerWidthChanged | Raises the ColumnDividerWidthChanged event.
Protected Method | OnColumnHeaderCellChanged | Raises the ColumnHeaderCellChanged event.
Protected Method | OnColumnHeaderMouseClick | Raises the ColumnHeaderMouseClick event.
Protected Method | OnColumnHeaderMouseDoubleClick | Raises the ColumnHeaderMouseDoubleClick event.
Protected Method | OnColumnHeadersBorderStyleChanged | Raises the ColumnHeadersBorderStyleChanged event.
Protected Method | OnColumnHeadersDefaultCellStyleChanged | Raises the ColumnHeadersDefaultCellStyleChanged event.
Protected Method | OnColumnHeadersHeightChanged | Raises the ColumnHeadersHeightChanged event.
Protected Method | OnColumnHeadersHeightSizeModeChanged | Raises the ColumnHeadersHeightSizeModeChanged event.
Protected Method | OnColumnMinimumWidthChanged | Raises the ColumnMinimumWidthChanged event.
Protected Method | OnColumnNameChanged | Raises the ColumnNameChanged event.
Protected Method | OnColumnRemoved | Raises the ColumnRemoved event.
Protected Method | OnColumnSortModeChanged | Raises the ColumnSortModeChanged event.
Protected Method | OnColumnStateChanged | Raises the ColumnStateChanged event.
Protected Method | OnColumnToolTipTextChanged | Raises the ColumnToolTipTextChanged event.
Protected Method | OnColumnWidthChanged | Raises the ColumnWidthChanged event.
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCurrentCellChanged | Raises the CurrentCellChanged event.
Protected Method | OnCurrentCellDirtyStateChanged | Raises the CurrentCellDirtyStateChanged event.
Protected Method | OnCursorChanged | Overridden. Raises the Control.CursorChanged event and updates the UserSetCursor property if the cursor was changed in user code.
Protected Method | OnDataBindingComplete | Raises the DataBindingComplete event.
Protected Method | OnDataError | Raises the DataError event.
Protected Method | OnDataMemberChanged | Raises the DataMemberChanged event.
Protected Method | OnDataSourceChanged | Raises the DataSourceChanged event.
Protected Method | OnDefaultCellStyleChanged | Raises the DefaultCellStyleChanged event.
Protected Method | OnDefaultValuesNeeded | Raises the DefaultValuesNeeded event.
Protected Method | OnDoubleClick | Overridden. Raises the Control.DoubleClick event.
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEditingControlShowing | Raises the EditingControlShowing event.
Protected Method | OnEditModeChanged | Raises the EditModeChanged event.
Protected Method | OnEnabledChanged | Overridden.
Protected Method | OnEnter | Overridden.
Protected Method | OnFontChanged | Overridden. Raises the DataGridView.FontChanged event.
Protected Method | OnForeColorChanged | Overridden. Raises the Control.ForeColorChanged event.
Protected Method | OnGotFocus | Overridden.
Protected Method | OnGridColorChanged | Raises the GridColorChanged event.
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Overridden. Raises the Control.KeyDown event.
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Overridden. Raises the Control.KeyUp event.
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | Overridden.
Protected Method | OnMouseClick | Overridden. Raises the MouseClick event.
Protected Method | OnMouseDoubleClick | Overridden.
Protected Method | OnMouseDown | Overridden. Raises the Control.MouseDown event.
Protected Method | OnMouseUp | Overridden. Raises the Control.MouseUp event.
Protected Method | OnMultiSelectChanged | Raises the MultiSelectChanged event.
Protected Method | OnNewRowNeeded | Raises the NewRowNeeded event.
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnReadOnlyChanged | Raises the ReadOnlyChanged event.
Protected Method | OnResize | Overridden. Raises the Control.Resize event.
Protected Method | OnRowContextMenuStripChanged | Raises the RowContextMenuStripChanged event.
Protected Method | OnRowContextMenuStripNeeded | Raises the RowContextMenuStripNeeded event.
Protected Method | OnRowDefaultCellStyleChanged | Raises the RowDefaultCellStyleChanged event.
Protected Method | OnRowDirtyStateNeeded | Raises the RowDirtyStateNeeded event.
Protected Method | OnRowDividerDoubleClick | Raises the RowDividerDoubleClick event.
Protected Method | OnRowDividerHeightChanged | Raises the RowDividerHeightChanged event.
Protected Method | OnRowEnter | Raises the RowEnter event.
Protected Method | OnRowErrorTextChanged | Raises the RowErrorTextChanged event.
Protected Method | OnRowErrorTextNeeded | Raises the RowErrorTextNeeded event.
Protected Method | OnRowHeaderCellChanged | Raises the RowHeaderCellChanged event.
Protected Method | OnRowHeaderMouseClick | Raises the RowHeaderMouseClick event.
Protected Method | OnRowHeaderMouseDoubleClick | Raises the RowHeaderMouseDoubleClick event.
Protected Method | OnRowHeadersBorderStyleChanged | Raises the RowHeadersBorderStyleChanged event.
Protected Method | OnRowHeadersDefaultCellStyleChanged | Raises the RowHeadersDefaultCellStyleChanged event.
Protected Method | OnRowHeadersWidthChanged | Raises the RowHeadersWidthChanged event.
Protected Method | OnRowHeadersWidthSizeModeChanged | Raises the RowHeadersWidthSizeModeChanged event.
Protected Method | OnRowHeightChanged | Raises the RowHeightChanged event.
Protected Method | OnRowHeightInfoNeeded | Raises the RowHeightInfoNeeded event.
Protected Method | OnRowHeightInfoPushed | Raises the RowHeightInfoPushed event.
Protected Method | OnRowLeave | Raises the RowLeave event.
Protected Method | OnRowMinimumHeightChanged | Raises the RowMinimumHeightChanged event.
Protected Method | OnRowsAdded | Raises the RowsAdded event.
Protected Method | OnRowsDefaultCellStyleChanged | Raises the RowsDefaultCellStyleChanged event.
Protected Method | OnRowsRemoved | Raises the RowsRemoved event.
Protected Method | OnRowStateChanged | Raises the RowStateChanged event.
Protected Method | OnRowUnshared | Raises the RowUnshared event.
Protected Method | OnRowValidated | Raises the RowValidated event.
Protected Method | OnRowValidating | Raises the RowValidating event.
Protected Method | OnSelectionChanged | Raises the SelectionChanged event.
Protected Method | OnSortCompare | Raises the SortCompare event.
Protected Method | OnSorted | Raises the Sorted event.
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnUserAddedRow | Raises the UserAddedRow event.
Protected Method | OnUserDeletedRow | Raises the UserDeletedRow event.
Protected Method | OnUserDeletingRow | Raises the UserDeletingRow event.
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | Overridden. Raises the Validating event.
Protected Method | OnVisibleChanged | Overridden.
Protected Method | PaintBackground | Paints the background of the DataGridView.
Protected Method | ProcessAKey | Processes the A key.
Protected Method | ProcessDataGridViewKey | Processes keys used for navigating in the DataGridView.
Protected Method | ProcessDeleteKey | Processes the DELETE key.
Protected Method | ProcessDownKey | Processes the DOWN ARROW key.
Protected Method | ProcessEndKey | Processes the END key.
Protected Method | ProcessEnterKey | Processes the ENTER key.
Protected Method | ProcessEscapeKey | Processes the ESC key.
Protected Method | ProcessF2Key | Processes the F2 key.
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | ProcessHomeKey | Processes the HOME key.
Protected Method | ProcessInsertKey | Processes the INSERT key.
Protected Method | ProcessLeftKey | Processes the LEFT ARROW key.
Protected Method | ProcessNextKey | Processes the PAGE DOWN key.
Protected Method | ProcessPriorKey | Processes the PAGE UP key.
Protected Method | ProcessRightKey | Processes the RIGHT ARROW key.
Protected Method | ProcessSpaceKey | Processes the SPACEBAR.
Protected Method | ProcessTabKey | Processes the TAB key.
Protected Method | ProcessUpKey | Processes the UP ARROW key.
Protected Method | ProcessZeroKey | Processes the 0 key.
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Control)
Protected Method | RenderAttributes | Overridden. Renders the control's meta attributes
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Overridden. Renders the controls sub tree
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | Overridden. Renders only the control's updated meta attributes
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetCurrentCellAddressCore | Sets the currently active cell.
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetSelectedCellCore | Changes the selection state of the cell with the specified row and column indexes.
Protected Method | SetSelectedColumnCore | Changes the selection state of the column with the specified index.
Protected Method | SetSelectedRowCore | Changes the selection state of the row with the specified index.
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

See Also

Reference

DataGridView Class
Gizmox.WebGUI.Forms Namespace


AccessibilityNotifyCurrentCellChanged Method

[image]
Gizmox.WebGUI.Forms
AccessibilityNotifyCurrentCellChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : AccessibilityNotifyCurrentCellChanged Method

cellAddress
A Point indicating the row and column indexes of the new current cell.
Notifies the accessible client applications when a new cell becomes the current cell.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub AccessibilityNotifyCurrentCellChanged( _
   ByVal cellAddress As Point _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim cellAddress As Point

instance.AccessibilityNotifyCurrentCellChanged(cellAddress)
C#
protected virtual void AccessibilityNotifyCurrentCellChanged(
   Point cellAddress
)
Managed Extensions for C++
protected: virtual void AccessibilityNotifyCurrentCellChanged(
   Point cellAddress
)
C++/CLI
protected:
virtual void AccessibilityNotifyCurrentCellChanged(
   Point cellAddress
)

Parameters

cellAddress
A Point indicating the row and column indexes of the new current cell.

Exceptions

Exception | Description
ArgumentOutOfRangeException | The value of the X property of cellAddress is less than 0 or greater than the number of columns in the control minus 1. -or-The value of the Y property of cellAddress is less than 0 or greater than the number of rows in the control minus 1.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


AdjustColumnHeaderBorderStyle Method

[image]
Gizmox.WebGUI.Forms
AdjustColumnHeaderBorderStyle Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : AdjustColumnHeaderBorderStyle Method

dataGridViewAdvancedBorderStyleInput
A DataGridViewAdvancedBorderStyle that that represents the column header border style to modify.
dataGridViewAdvancedBorderStylePlaceholder
A DataGridViewAdvancedBorderStyle that is used to store intermediate changes to the column header border style.
isFirstDisplayedColumn
true to indicate that the DataGridViewCell that is currently being painted is in the first column displayed on the DataGridView; otherwise, false.
isLastVisibleColumn
true to indicate that the DataGridViewCell that is currently being painted is in the last column in the DataGridView that has the DataGridViewColumn.Visible property set to true; otherwise, false.
Adjusts the DataGridViewAdvancedBorderStyle for a column header cell of a DataGridView that is currently being painted.

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Overridable Function AdjustColumnHeaderBorderStyle( _
   ByVal dataGridViewAdvancedBorderStyleInput As DataGridViewAdvancedBorderStyle, _
   ByVal dataGridViewAdvancedBorderStylePlaceholder As DataGridViewAdvancedBorderStyle, _
   ByVal isFirstDisplayedColumn As Boolean, _
   ByVal isLastVisibleColumn As Boolean _
) As DataGridViewAdvancedBorderStyle
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim dataGridViewAdvancedBorderStyleInput As DataGridViewAdvancedBorderStyle
Dim dataGridViewAdvancedBorderStylePlaceholder As DataGridViewAdvancedBorderStyle
Dim isFirstDisplayedColumn As Boolean
Dim isLastVisibleColumn As Boolean
Dim value As DataGridViewAdvancedBorderStyle

value = instance.AdjustColumnHeaderBorderStyle(dataGridViewAdvancedBorderStyleInput, dataGridViewAdvancedBorderStylePlaceholder, isFirstDisplayedColumn, isLastVisibleColumn)
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public virtual DataGridViewAdvancedBorderStyle AdjustColumnHeaderBorderStyle(
   DataGridViewAdvancedBorderStyle dataGridViewAdvancedBorderStyleInput,
   DataGridViewAdvancedBorderStyle dataGridViewAdvancedBorderStylePlaceholder,
   bool isFirstDisplayedColumn,
   bool isLastVisibleColumn
)
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: virtual DataGridViewAdvancedBorderStyle* AdjustColumnHeaderBorderStyle(
   DataGridViewAdvancedBorderStyle* dataGridViewAdvancedBorderStyleInput,
   DataGridViewAdvancedBorderStyle* dataGridViewAdvancedBorderStylePlaceholder,
   bool isFirstDisplayedColumn,
   bool isLastVisibleColumn
)
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
virtual DataGridViewAdvancedBorderStyle^ AdjustColumnHeaderBorderStyle(
   DataGridViewAdvancedBorderStyle^ dataGridViewAdvancedBorderStyleInput,
   DataGridViewAdvancedBorderStyle^ dataGridViewAdvancedBorderStylePlaceholder,
   bool isFirstDisplayedColumn,
   bool isLastVisibleColumn
)

Parameters

dataGridViewAdvancedBorderStyleInput
A DataGridViewAdvancedBorderStyle that that represents the column header border style to modify.
dataGridViewAdvancedBorderStylePlaceholder
A DataGridViewAdvancedBorderStyle that is used to store intermediate changes to the column header border style.
isFirstDisplayedColumn
true to indicate that the DataGridViewCell that is currently being painted is in the first column displayed on the DataGridView; otherwise, false.
isLastVisibleColumn
true to indicate that the DataGridViewCell that is currently being painted is in the last column in the DataGridView that has the DataGridViewColumn.Visible property set to true; otherwise, false.

Return Value

A DataGridViewAdvancedBorderStyle that represents the border style for the current column header.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


AdjustShrinkingRows Method

[image]
Gizmox.WebGUI.Forms
AdjustShrinkingRows Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : AdjustShrinkingRows Method

autoSizeRowsMode
fixedWidth
internalAutosizing

Syntax

Visual Basic (Declaration)
Protected Sub AdjustShrinkingRows( _
   ByVal autoSizeRowsMode As DataGridViewAutoSizeRowsMode, _
   ByVal fixedWidth As Boolean, _
   ByVal internalAutosizing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim autoSizeRowsMode As DataGridViewAutoSizeRowsMode
Dim fixedWidth As Boolean
Dim internalAutosizing As Boolean

instance.AdjustShrinkingRows(autoSizeRowsMode, fixedWidth, internalAutosizing)
C#
protected void AdjustShrinkingRows(
   DataGridViewAutoSizeRowsMode autoSizeRowsMode,
   bool fixedWidth,
   bool internalAutosizing
)
Managed Extensions for C++
protected: void AdjustShrinkingRows(
   DataGridViewAutoSizeRowsMode autoSizeRowsMode,
   bool fixedWidth,
   bool internalAutosizing
)
C++/CLI
protected:
void AdjustShrinkingRows(
   DataGridViewAutoSizeRowsMode autoSizeRowsMode,
   bool fixedWidth,
   bool internalAutosizing
)

Parameters

autoSizeRowsMode
fixedWidth
internalAutosizing

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


AreAllCellsSelected Method

[image]
Gizmox.WebGUI.Forms
AreAllCellsSelected Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : AreAllCellsSelected Method

includeInvisibleCells
true to include the rows and columns with DataGridViewBand.Visible property values of false; otherwise, false.
Returns a value indicating whether all the DataGridView cells are currently selected.

Syntax

Visual Basic (Declaration)
Public Function AreAllCellsSelected( _
   ByVal includeInvisibleCells As Boolean _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim includeInvisibleCells As Boolean
Dim value As Boolean

value = instance.AreAllCellsSelected(includeInvisibleCells)
C#
public bool AreAllCellsSelected(
   bool includeInvisibleCells
)
Managed Extensions for C++
public: bool AreAllCellsSelected(
   bool includeInvisibleCells
)
C++/CLI
public:
bool AreAllCellsSelected(
   bool includeInvisibleCells
)

Parameters

includeInvisibleCells
true to include the rows and columns with DataGridViewBand.Visible property values of false; otherwise, false.

Return Value

true if all cells (or all visible cells) are selected or if there are no cells (or no visible cells); otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


AutoResizeColumn Method

[image]
Gizmox.WebGUI.Forms
AutoResizeColumn Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : AutoResizeColumn Method

Adjusts the width of the specified column to fit the contents of all its cells, including the header cell.

Overload List

Overload | Description
AutoResizeColumn(Int32) | Adjusts the width of the specified column to fit the contents of all its cells, including the header cell.
AutoResizeColumn(Int32,DataGridViewAutoSizeColumnMode) | Adjusts the width of the specified column using the specified size mode.
AutoResizeColumn(Int32,DataGridViewAutoSizeColumnMode,Boolean) | Adjusts the width of the specified column using the specified size mode, optionally calculating the width with the expectation that row heights will subsequently be adjusted.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


AutoResizeColumn(Int32) Method

[image]
Gizmox.WebGUI.Forms
AutoResizeColumn(Int32) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class > AutoResizeColumn Method : AutoResizeColumn(Int32) Method

columnIndex
The index of the column to resize.
Adjusts the width of the specified column to fit the contents of all its cells, including the header cell.

Syntax

Visual Basic (Declaration)
Public Overloads Sub AutoResizeColumn( _
   ByVal columnIndex As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim columnIndex As Integer

instance.AutoResizeColumn(columnIndex)
C#
public void AutoResizeColumn(
   int columnIndex
)
Managed Extensions for C++
public: void AutoResizeColumn(
   int columnIndex
)
C++/CLI
public:
void AutoResizeColumn(
   int columnIndex
)

Parameters

columnIndex
The index of the column to resize.

Exceptions

Exception | Description
ArgumentOutOfRangeException | columnIndex is not in the valid range of 0 to the number of columns minus 1.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members
Overload List


AutoResizeColumn(Int32,DataGridViewAutoSizeColumnMode) Method

[image]
Gizmox.WebGUI.Forms
AutoResizeColumn(Int32,DataGridViewAutoSizeColumnMode) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class > AutoResizeColumn Method : AutoResizeColumn(Int32,DataGridViewAutoSizeColumnMode) Method

columnIndex
The index of the column to resize.
autoSizeColumnMode
One of the DataGridViewAutoSizeColumnMode values.
Adjusts the width of the specified column using the specified size mode.

Syntax

Visual Basic (Declaration)
Public Overloads Sub AutoResizeColumn( _
   ByVal columnIndex As Integer, _
   ByVal autoSizeColumnMode As DataGridViewAutoSizeColumnMode _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim columnIndex As Integer
Dim autoSizeColumnMode As DataGridViewAutoSizeColumnMode

instance.AutoResizeColumn(columnIndex, autoSizeColumnMode)
C#
public void AutoResizeColumn(
   int columnIndex,
   DataGridViewAutoSizeColumnMode autoSizeColumnMode
)
Managed Extensions for C++
public: void AutoResizeColumn(
   int columnIndex,
   DataGridViewAutoSizeColumnMode autoSizeColumnMode
)
C++/CLI
public:
void AutoResizeColumn(
   int columnIndex,
   DataGridViewAutoSizeColumnMode autoSizeColumnMode
)

Parameters

columnIndex
The index of the column to resize.
autoSizeColumnMode
One of the DataGridViewAutoSizeColumnMode values.

Exceptions

Exception | Description
ArgumentOutOfRangeException | columnIndex is not in the valid range of 0 to the number of columns minus 1.
InvalidOperationException | autoSizeColumnMode has the value DataGridViewAutoSizeColumnMode.ColumnHeader and ColumnHeadersVisible is false.
ArgumentException | autoSizeColumnMode has the value DataGridViewAutoSizeColumnMode.NotSet, DataGridViewAutoSizeColumnMode.None, or DataGridViewAutoSizeColumnMode.Fill.
InvalidEnumArgumentException | autoSizeColumnMode is not a valid DataGridViewAutoSizeColumnMode value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members
Overload List


AutoResizeColumn(Int32,DataGridViewAutoSizeColumnMode,Boolean) Method

[image]
Gizmox.WebGUI.Forms
AutoResizeColumn(Int32,DataGridViewAutoSizeColumnMode,Boolean) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class > AutoResizeColumn Method : AutoResizeColumn(Int32,DataGridViewAutoSizeColumnMode,Boolean) Method

columnIndex
The index of the column to resize.
autoSizeColumnMode
One of the DataGridViewAutoSizeColumnMode values.
fixedHeight
true to calculate the new width based on the current row heights; false to calculate the width with the expectation that the row heights will also be adjusted.
Adjusts the width of the specified column using the specified size mode, optionally calculating the width with the expectation that row heights will subsequently be adjusted.

Syntax

Visual Basic (Declaration)
Protected Overloads Sub AutoResizeColumn( _
   ByVal columnIndex As Integer, _
   ByVal autoSizeColumnMode As DataGridViewAutoSizeColumnMode, _
   ByVal fixedHeight As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim columnIndex As Integer
Dim autoSizeColumnMode As DataGridViewAutoSizeColumnMode
Dim fixedHeight As Boolean

instance.AutoResizeColumn(columnIndex, autoSizeColumnMode, fixedHeight)
C#
protected void AutoResizeColumn(
   int columnIndex,
   DataGridViewAutoSizeColumnMode autoSizeColumnMode,
   bool fixedHeight
)
Managed Extensions for C++
protected: void AutoResizeColumn(
   int columnIndex,
   DataGridViewAutoSizeColumnMode autoSizeColumnMode,
   bool fixedHeight
)
C++/CLI
protected:
void AutoResizeColumn(
   int columnIndex,
   DataGridViewAutoSizeColumnMode autoSizeColumnMode,
   bool fixedHeight
)

Parameters

columnIndex
The index of the column to resize.
autoSizeColumnMode
One of the DataGridViewAutoSizeColumnMode values.
fixedHeight
true to calculate the new width based on the current row heights; false to calculate the width with the expectation that the row heights will also be adjusted.

Exceptions

Exception | Description
ArgumentOutOfRangeException | columnIndex is not in the valid range of 0 to the number of columns minus 1.
InvalidOperationException | autoSizeColumnMode has the value DataGridViewAutoSizeColumnMode.ColumnHeader and ColumnHeadersVisible is false.
ArgumentException | autoSizeColumnMode has the value DataGridViewAutoSizeColumnMode.NotSet, DataGridViewAutoSizeColumnMode.None, or DataGridViewAutoSizeColumnMode.Fill.
InvalidEnumArgumentException | autoSizeColumnMode is not a valid DataGridViewAutoSizeColumnMode value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members
Overload List


AutoResizeColumnHeadersHeight Method

[image]
Gizmox.WebGUI.Forms
AutoResizeColumnHeadersHeight Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : AutoResizeColumnHeadersHeight Method

Adjusts the height of the column headers to fit the contents of the largest column header.

Overload List

Overload | Description
AutoResizeColumnHeadersHeight() | Adjusts the height of the column headers to fit the contents of the largest column header.
AutoResizeColumnHeadersHeight(Int32) | Adjusts the height of the column headers based on changes to the contents of the header in the specified column.
AutoResizeColumnHeadersHeight(Boolean,Boolean) | Adjusts the height of the column headers to fit their contents, optionally calculating the height with the expectation that the column and/or row header widths will subsequently be adjusted.
AutoResizeColumnHeadersHeight(Int32,Boolean,Boolean) | Adjusts the height of the column headers based on changes to the contents of the header in the specified column, optionally calculating the height with the expectation that the column and/or row header widths will subsequently be adjusted.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


AutoResizeColumnHeadersHeight() Method

[image]
Gizmox.WebGUI.Forms
AutoResizeColumnHeadersHeight() Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class > AutoResizeColumnHeadersHeight Method : AutoResizeColumnHeadersHeight() Method

Adjusts the height of the column headers to fit the contents of the largest column header.

Syntax

Visual Basic (Declaration)
Public Overloads Sub AutoResizeColumnHeadersHeight()
Visual Basic (Usage) Copy Code
Dim instance As DataGridView

instance.AutoResizeColumnHeadersHeight()
C#
public void AutoResizeColumnHeadersHeight()
Managed Extensions for C++
public: void AutoResizeColumnHeadersHeight();
C++/CLI
public:
void AutoResizeColumnHeadersHeight();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members
Overload List


AutoResizeColumnHeadersHeight(Int32) Method

[image]
Gizmox.WebGUI.Forms
AutoResizeColumnHeadersHeight(Int32) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class > AutoResizeColumnHeadersHeight Method : AutoResizeColumnHeadersHeight(Int32) Method

columnIndex
The index of the column containing the header with the changed content.
Adjusts the height of the column headers based on changes to the contents of the header in the specified column.

Syntax

Visual Basic (Declaration)
Public Overloads Sub AutoResizeColumnHeadersHeight( _
   ByVal columnIndex As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim columnIndex As Integer

instance.AutoResizeColumnHeadersHeight(columnIndex)
C#
public void AutoResizeColumnHeadersHeight(
   int columnIndex
)
Managed Extensions for C++
public: void AutoResizeColumnHeadersHeight(
   int columnIndex
)
C++/CLI
public:
void AutoResizeColumnHeadersHeight(
   int columnIndex
)

Parameters

columnIndex
The index of the column containing the header with the changed content.

Exceptions

Exception | Description
ArgumentOutOfRangeException | columnIndex is not in the valid range of 0 to the number of columns minus 1.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members
Overload List


AutoResizeColumnHeadersHeight(Boolean,Boolean) Method

[image]
Gizmox.WebGUI.Forms
AutoResizeColumnHeadersHeight(Boolean,Boolean) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class > AutoResizeColumnHeadersHeight Method : AutoResizeColumnHeadersHeight(Boolean,Boolean) Method

fixedRowHeadersWidth
true to calculate the new height based on the current width of the row headers; false to calculate the height with the expectation that the row headers width will also be adjusted.
fixedColumnsWidth
true to calculate the new height based on the current column widths; false to calculate the height with the expectation that the column widths will also be adjusted.
Adjusts the height of the column headers to fit their contents, optionally calculating the height with the expectation that the column and/or row header widths will subsequently be adjusted.

Syntax

Visual Basic (Declaration)
Protected Overloads Sub AutoResizeColumnHeadersHeight( _
   ByVal fixedRowHeadersWidth As Boolean, _
   ByVal fixedColumnsWidth As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim fixedRowHeadersWidth As Boolean
Dim fixedColumnsWidth As Boolean

instance.AutoResizeColumnHeadersHeight(fixedRowHeadersWidth, fixedColumnsWidth)
C#
protected void AutoResizeColumnHeadersHeight(
   bool fixedRowHeadersWidth,
   bool fixedColumnsWidth
)
Managed Extensions for C++
protected: void AutoResizeColumnHeadersHeight(
   bool fixedRowHeadersWidth,
   bool fixedColumnsWidth
)
C++/CLI
protected:
void AutoResizeColumnHeadersHeight(
   bool fixedRowHeadersWidth,
   bool fixedColumnsWidth
)

Parameters

fixedRowHeadersWidth
true to calculate the new height based on the current width of the row headers; false to calculate the height with the expectation that the row headers width will also be adjusted.
fixedColumnsWidth
true to calculate the new height based on the current column widths; false to calculate the height with the expectation that the column widths will also be adjusted.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members
Overload List


AutoResizeColumnHeadersHeight(Int32,Boolean,Boolean) Method

[image]
Gizmox.WebGUI.Forms
AutoResizeColumnHeadersHeight(Int32,Boolean,Boolean) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class > AutoResizeColumnHeadersHeight Method : AutoResizeColumnHeadersHeight(Int32,Boolean,Boolean) Method

columnIndex
The index of the column header whose contents should be used to determine new height.
fixedRowHeadersWidth
true to calculate the new height based on the current width of the row headers; false to calculate the height with the expectation that the row headers width will also be adjusted.
fixedColumnWidth
true to calculate the new height based on the current width of the specified column; false to calculate the height with the expectation that the column width will also be adjusted.
Adjusts the height of the column headers based on changes to the contents of the header in the specified column, optionally calculating the height with the expectation that the column and/or row header widths will subsequently be adjusted.

Syntax

Visual Basic (Declaration)
Protected Overloads Sub AutoResizeColumnHeadersHeight( _
   ByVal columnIndex As Integer, _
   ByVal fixedRowHeadersWidth As Boolean, _
   ByVal fixedColumnWidth As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim columnIndex As Integer
Dim fixedRowHeadersWidth As Boolean
Dim fixedColumnWidth As Boolean

instance.AutoResizeColumnHeadersHeight(columnIndex, fixedRowHeadersWidth, fixedColumnWidth)
C#
protected void AutoResizeColumnHeadersHeight(
   int columnIndex,
   bool fixedRowHeadersWidth,
   bool fixedColumnWidth
)
Managed Extensions for C++
protected: void AutoResizeColumnHeadersHeight(
   int columnIndex,
   bool fixedRowHeadersWidth,
   bool fixedColumnWidth
)
C++/CLI
protected:
void AutoResizeColumnHeadersHeight(
   int columnIndex,
   bool fixedRowHeadersWidth,
   bool fixedColumnWidth
)

Parameters

columnIndex
The index of the column header whose contents should be used to determine new height.
fixedRowHeadersWidth
true to calculate the new height based on the current width of the row headers; false to calculate the height with the expectation that the row headers width will also be adjusted.
fixedColumnWidth
true to calculate the new height based on the current width of the specified column; false to calculate the height with the expectation that the column width will also be adjusted.

Exceptions

Exception | Description
ArgumentOutOfRangeException | columnIndex is not in the valid range of 0 to the number of columns minus 1.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members
Overload List


AutoResizeColumns Method

[image]
Gizmox.WebGUI.Forms
AutoResizeColumns Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : AutoResizeColumns Method

Adjusts the width of all columns to fit the contents of all their cells, including the header cells.

Overload List

Overload | Description
AutoResizeColumns() | Adjusts the width of all columns to fit the contents of all their cells, including the header cells.
AutoResizeColumns(DataGridViewAutoSizeColumnsMode) | Adjusts the width of all columns using the specified size mode.
AutoResizeColumns(DataGridViewAutoSizeColumnsMode,Boolean) | Adjusts the width of all columns using the specified size mode, optionally calculating the widths with the expectation that row heights will subsequently be adjusted.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


AutoResizeColumns() Method

[image]
Gizmox.WebGUI.Forms
AutoResizeColumns() Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class > AutoResizeColumns Method : AutoResizeColumns() Method

Adjusts the width of all columns to fit the contents of all their cells, including the header cells.

Syntax

Visual Basic (Declaration)
Public Overloads Sub AutoResizeColumns()
Visual Basic (Usage) Copy Code
Dim instance As DataGridView

instance.AutoResizeColumns()
C#
public void AutoResizeColumns()
Managed Extensions for C++
public: void AutoResizeColumns();
C++/CLI
public:
void AutoResizeColumns();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members
Overload List


AutoResizeColumns(DataGridViewAutoSizeColumnsMode) Method

[image]
Gizmox.WebGUI.Forms
AutoResizeColumns(DataGridViewAutoSizeColumnsMode) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class > AutoResizeColumns Method : AutoResizeColumns(DataGridViewAutoSizeColumnsMode) Method

autoSizeColumnsMode
One of the DataGridViewAutoSizeColumnsMode values.
Adjusts the width of all columns using the specified size mode.

Syntax

Visual Basic (Declaration)
Public Overloads Sub AutoResizeColumns( _
   ByVal autoSizeColumnsMode As DataGridViewAutoSizeColumnsMode _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim autoSizeColumnsMode As DataGridViewAutoSizeColumnsMode

instance.AutoResizeColumns(autoSizeColumnsMode)
C#
public void AutoResizeColumns(
   DataGridViewAutoSizeColumnsMode autoSizeColumnsMode
)
Managed Extensions for C++
public: void AutoResizeColumns(
   DataGridViewAutoSizeColumnsMode autoSizeColumnsMode
)
C++/CLI
public:
void AutoResizeColumns(
   DataGridViewAutoSizeColumnsMode autoSizeColumnsMode
)

Parameters

autoSizeColumnsMode
One of the DataGridViewAutoSizeColumnsMode values.

Exceptions

Exception | Description
ArgumentException | autoSizeColumnsMode has the value DataGridViewAutoSizeColumnsMode.None or DataGridViewAutoSizeColumnsMode.Fill.
InvalidEnumArgumentException | autoSizeColumnsMode is not a valid DataGridViewAutoSizeColumnsMode value.
InvalidOperationException | autoSizeColumnsMode has the value DataGridViewAutoSizeColumnsMode.ColumnHeader and ColumnHeadersVisible is false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members
Overload List


AutoResizeColumns(DataGridViewAutoSizeColumnsMode,Boolean) Method

[image]
Gizmox.WebGUI.Forms
AutoResizeColumns(DataGridViewAutoSizeColumnsMode,Boolean) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class > AutoResizeColumns Method : AutoResizeColumns(DataGridViewAutoSizeColumnsMode,Boolean) Method

autoSizeColumnsMode
One of the DataGridViewAutoSizeColumnsMode values.
fixedHeight
true to calculate the new widths based on the current row heights; false to calculate the widths with the expectation that the row heights will also be adjusted.
Adjusts the width of all columns using the specified size mode, optionally calculating the widths with the expectation that row heights will subsequently be adjusted.

Syntax

Visual Basic (Declaration)
Protected Overloads Sub AutoResizeColumns( _
   ByVal autoSizeColumnsMode As DataGridViewAutoSizeColumnsMode, _
   ByVal fixedHeight As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim autoSizeColumnsMode As DataGridViewAutoSizeColumnsMode
Dim fixedHeight As Boolean

instance.AutoResizeColumns(autoSizeColumnsMode, fixedHeight)
C#
protected void AutoResizeColumns(
   DataGridViewAutoSizeColumnsMode autoSizeColumnsMode,
   bool fixedHeight
)
Managed Extensions for C++
protected: void AutoResizeColumns(
   DataGridViewAutoSizeColumnsMode autoSizeColumnsMode,
   bool fixedHeight
)
C++/CLI
protected:
void AutoResizeColumns(
   DataGridViewAutoSizeColumnsMode autoSizeColumnsMode,
   bool fixedHeight
)

Parameters

autoSizeColumnsMode
One of the DataGridViewAutoSizeColumnsMode values.
fixedHeight
true to calculate the new widths based on the current row heights; false to calculate the widths with the expectation that the row heights will also be adjusted.

Exceptions

Exception | Description
ArgumentException | autoSizeColumnsMode has the value DataGridViewAutoSizeColumnsMode.None or DataGridViewAutoSizeColumnsMode.Fill.
InvalidEnumArgumentException | autoSizeColumnsMode is not a valid DataGridViewAutoSizeColumnsMode value.
InvalidOperationException | autoSizeColumnsMode has the value DataGridViewAutoSizeColumnsMode.ColumnHeader and ColumnHeadersVisible is false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members
Overload List


AutoResizeRow Method

[image]
Gizmox.WebGUI.Forms
AutoResizeRow Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : AutoResizeRow Method

Adjusts the height of the specified row to fit the contents of all its cells including the header cell.

Overload List

Overload | Description
AutoResizeRow(Int32) | Adjusts the height of the specified row to fit the contents of all its cells including the header cell.
AutoResizeRow(Int32,DataGridViewAutoSizeRowMode) | Adjusts the height of the specified row using the specified size mode.
AutoResizeRow(Int32,DataGridViewAutoSizeRowMode,Boolean) | Adjusts the height of the specified row using the specified size mode, optionally calculating the height with the expectation that column widths will subsequently be adjusted.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


AutoResizeRow(Int32) Method

[image]
Gizmox.WebGUI.Forms
AutoResizeRow(Int32) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class > AutoResizeRow Method : AutoResizeRow(Int32) Method

rowIndex
The index of the row to resize.
Adjusts the height of the specified row to fit the contents of all its cells including the header cell.

Syntax

Visual Basic (Declaration)
Public Overloads Sub AutoResizeRow( _
   ByVal rowIndex As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim rowIndex As Integer

instance.AutoResizeRow(rowIndex)
C#
public void AutoResizeRow(
   int rowIndex
)
Managed Extensions for C++
public: void AutoResizeRow(
   int rowIndex
)
C++/CLI
public:
void AutoResizeRow(
   int rowIndex
)

Parameters

rowIndex
The index of the row to resize.

Exceptions

Exception | Description
ArgumentOutOfRangeException | rowIndex is not in the valid range of 0 to the number of rows minus 1.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members
Overload List


AutoResizeRow(Int32,DataGridViewAutoSizeRowMode) Method

[image]
Gizmox.WebGUI.Forms
AutoResizeRow(Int32,DataGridViewAutoSizeRowMode) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class > AutoResizeRow Method : AutoResizeRow(Int32,DataGridViewAutoSizeRowMode) Method

rowIndex
The index of the row to resize.
autoSizeRowMode
One of the DataGridViewAutoSizeRowMode values.
Adjusts the height of the specified row using the specified size mode.

Syntax

Visual Basic (Declaration)
Public Overloads Sub AutoResizeRow( _
   ByVal rowIndex As Integer, _
   ByVal autoSizeRowMode As DataGridViewAutoSizeRowMode _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim rowIndex As Integer
Dim autoSizeRowMode As DataGridViewAutoSizeRowMode

instance.AutoResizeRow(rowIndex, autoSizeRowMode)
C#
public void AutoResizeRow(
   int rowIndex,
   DataGridViewAutoSizeRowMode autoSizeRowMode
)
Managed Extensions for C++
public: void AutoResizeRow(
   int rowIndex,
   DataGridViewAutoSizeRowMode autoSizeRowMode
)
C++/CLI
public:
void AutoResizeRow(
   int rowIndex,
   DataGridViewAutoSizeRowMode autoSizeRowMode
)

Parameters

rowIndex
The index of the row to resize.
autoSizeRowMode
One of the DataGridViewAutoSizeRowMode values.

Exceptions

Exception | Description
InvalidEnumArgumentException | autoSizeRowMode is not a valid DataGridViewAutoSizeRowMode value.
InvalidOperationException | autoSizeRowMode has the value DataGridViewAutoSizeRowMode.RowHeader and RowHeadersVisible is false.
ArgumentOutOfRangeException | rowIndex is not in the valid range of 0 to the number of rows minus 1.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members
Overload List


AutoResizeRow(Int32,DataGridViewAutoSizeRowMode,Boolean) Method

[image]
Gizmox.WebGUI.Forms
AutoResizeRow(Int32,DataGridViewAutoSizeRowMode,Boolean) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class > AutoResizeRow Method : AutoResizeRow(Int32,DataGridViewAutoSizeRowMode,Boolean) Method

rowIndex
The index of the row to resize.
autoSizeRowMode
One of the DataGridViewAutoSizeRowMode values.
fixedWidth
true to calculate the new height based on the current width of the columns; false to calculate the height with the expectation that the column widths will also be adjusted.
Adjusts the height of the specified row using the specified size mode, optionally calculating the height with the expectation that column widths will subsequently be adjusted.

Syntax

Visual Basic (Declaration)
Protected Overloads Sub AutoResizeRow( _
   ByVal rowIndex As Integer, _
   ByVal autoSizeRowMode As DataGridViewAutoSizeRowMode, _
   ByVal fixedWidth As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim rowIndex As Integer
Dim autoSizeRowMode As DataGridViewAutoSizeRowMode
Dim fixedWidth As Boolean

instance.AutoResizeRow(rowIndex, autoSizeRowMode, fixedWidth)
C#
protected void AutoResizeRow(
   int rowIndex,
   DataGridViewAutoSizeRowMode autoSizeRowMode,
   bool fixedWidth
)
Managed Extensions for C++
protected: void AutoResizeRow(
   int rowIndex,
   DataGridViewAutoSizeRowMode autoSizeRowMode,
   bool fixedWidth
)
C++/CLI
protected:
void AutoResizeRow(
   int rowIndex,
   DataGridViewAutoSizeRowMode autoSizeRowMode,
   bool fixedWidth
)

Parameters

rowIndex
The index of the row to resize.
autoSizeRowMode
One of the DataGridViewAutoSizeRowMode values.
fixedWidth
true to calculate the new height based on the current width of the columns; false to calculate the height with the expectation that the column widths will also be adjusted.

Exceptions

Exception | Description
InvalidEnumArgumentException | autoSizeRowMode is not a valid DataGridViewAutoSizeRowMode value.
InvalidOperationException | autoSizeRowMode has the value DataGridViewAutoSizeRowMode.RowHeader and RowHeadersVisible is false.
ArgumentOutOfRangeException | rowIndex is not in the valid range of 0 to the number of rows minus 1.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members
Overload List


AutoResizeRowHeadersWidth Method

[image]
Gizmox.WebGUI.Forms
AutoResizeRowHeadersWidth Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : AutoResizeRowHeadersWidth Method

Adjusts the width of the row headers using the specified size mode.

Overload List

Overload | Description
AutoResizeRowHeadersWidth(DataGridViewRowHeadersWidthSizeMode) | Adjusts the width of the row headers using the specified size mode.
AutoResizeRowHeadersWidth(Int32,DataGridViewRowHeadersWidthSizeMode) | Adjusts the width of the row headers based on changes to the contents of the header in the specified row and using the specified size mode.
AutoResizeRowHeadersWidth(DataGridViewRowHeadersWidthSizeMode,Boolean,Boolean) | Adjusts the width of the row headers using the specified size mode, optionally calculating the width with the expectation that the row and/or column header widths will subsequently be adjusted.
AutoResizeRowHeadersWidth(Int32,DataGridViewRowHeadersWidthSizeMode,Boolean,Boolean) | Adjusts the width of the row headers based on changes to the contents of the header in the specified row and using the specified size mode, optionally calculating the width with the expectation that the row and/or column header widths will subsequently be adjusted.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


AutoResizeRowHeadersWidth(DataGridViewRowHeadersWidthSizeMode) Method

[image]
Gizmox.WebGUI.Forms
AutoResizeRowHeadersWidth(DataGridViewRowHeadersWidthSizeMode) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class > AutoResizeRowHeadersWidth Method : AutoResizeRowHeadersWidth(DataGridViewRowHeadersWidthSizeMode) Method

rowHeadersWidthSizeMode
One of the DataGridViewRowHeadersWidthSizeMode values.
Adjusts the width of the row headers using the specified size mode.

Syntax

Visual Basic (Declaration)
Public Overloads Sub AutoResizeRowHeadersWidth( _
   ByVal rowHeadersWidthSizeMode As DataGridViewRowHeadersWidthSizeMode _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim rowHeadersWidthSizeMode As DataGridViewRowHeadersWidthSizeMode

instance.AutoResizeRowHeadersWidth(rowHeadersWidthSizeMode)
C#
public void AutoResizeRowHeadersWidth(
   DataGridViewRowHeadersWidthSizeMode rowHeadersWidthSizeMode
)
Managed Extensions for C++
public: void AutoResizeRowHeadersWidth(
   DataGridViewRowHeadersWidthSizeMode rowHeadersWidthSizeMode
)
C++/CLI
public:
void AutoResizeRowHeadersWidth(
   DataGridViewRowHeadersWidthSizeMode rowHeadersWidthSizeMode
)

Parameters

rowHeadersWidthSizeMode
One of the DataGridViewRowHeadersWidthSizeMode values.

Exceptions

Exception | Description
InvalidEnumArgumentException | rowHeadersWidthSizeMode is not a valid DataGridViewRowHeadersWidthSizeMode value.
ArgumentException | rowHeadersWidthSizeMode has the value DataGridViewRowHeadersWidthSizeMode.EnableResizing or DataGridViewRowHeadersWidthSizeMode.DisableResizing.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members
Overload List


AutoResizeRowHeadersWidth(Int32,DataGridViewRowHeadersWidthSizeMode) Method

[image]
Gizmox.WebGUI.Forms
AutoResizeRowHeadersWidth(Int32,DataGridViewRowHeadersWidthSizeMode) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class > AutoResizeRowHeadersWidth Method : AutoResizeRowHeadersWidth(Int32,DataGridViewRowHeadersWidthSizeMode) Method

rowIndex
The index of the row header with the changed content.
rowHeadersWidthSizeMode
One of the DataGridViewRowHeadersWidthSizeMode values.
Adjusts the width of the row headers based on changes to the contents of the header in the specified row and using the specified size mode.

Syntax

Visual Basic (Declaration)
Public Overloads Sub AutoResizeRowHeadersWidth( _
   ByVal rowIndex As Integer, _
   ByVal rowHeadersWidthSizeMode As DataGridViewRowHeadersWidthSizeMode _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim rowIndex As Integer
Dim rowHeadersWidthSizeMode As DataGridViewRowHeadersWidthSizeMode

instance.AutoResizeRowHeadersWidth(rowIndex, rowHeadersWidthSizeMode)
C#
public void AutoResizeRowHeadersWidth(
   int rowIndex,
   DataGridViewRowHeadersWidthSizeMode rowHeadersWidthSizeMode
)
Managed Extensions for C++
public: void AutoResizeRowHeadersWidth(
   int rowIndex,
   DataGridViewRowHeadersWidthSizeMode rowHeadersWidthSizeMode
)
C++/CLI
public:
void AutoResizeRowHeadersWidth(
   int rowIndex,
   DataGridViewRowHeadersWidthSizeMode rowHeadersWidthSizeMode
)

Parameters

rowIndex
The index of the row header with the changed content.
rowHeadersWidthSizeMode
One of the DataGridViewRowHeadersWidthSizeMode values.

Exceptions

Exception | Description
InvalidEnumArgumentException | rowHeadersWidthSizeMode is not a valid DataGridViewRowHeadersWidthSizeMode value.
ArgumentException | rowHeadersWidthSizeMode has the value DataGridViewRowHeadersWidthSizeMode.EnableResizing or DataGridViewRowHeadersWidthSizeMode.DisableResizing
ArgumentOutOfRangeException | rowIndex is not in the valid range of 0 to the number of rows minus 1.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members
Overload List


AutoResizeRowHeadersWidth(DataGridViewRowHeadersWidthSizeMode,Boolean,Boolean) Method

[image]
Gizmox.WebGUI.Forms
AutoResizeRowHeadersWidth(DataGridViewRowHeadersWidthSizeMode,Boolean,Boolean) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class > AutoResizeRowHeadersWidth Method : AutoResizeRowHeadersWidth(DataGridViewRowHeadersWidthSizeMode,Boolean,Boolean) Method

rowHeadersWidthSizeMode
One of the DataGridViewRowHeadersWidthSizeMode values.
fixedColumnHeadersHeight
true to calculate the new width based on the current height of the column headers; false to calculate the width with the expectation that the height of the column headers will also be adjusted.
fixedRowsHeight
true to calculate the new width based on the current row heights; false to calculate the width with the expectation that the row heights will also be adjusted.
Adjusts the width of the row headers using the specified size mode, optionally calculating the width with the expectation that the row and/or column header widths will subsequently be adjusted.

Syntax

Visual Basic (Declaration)
Protected Overloads Sub AutoResizeRowHeadersWidth( _
   ByVal rowHeadersWidthSizeMode As DataGridViewRowHeadersWidthSizeMode, _
   ByVal fixedColumnHeadersHeight As Boolean, _
   ByVal fixedRowsHeight As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim rowHeadersWidthSizeMode As DataGridViewRowHeadersWidthSizeMode
Dim fixedColumnHeadersHeight As Boolean
Dim fixedRowsHeight As Boolean

instance.AutoResizeRowHeadersWidth(rowHeadersWidthSizeMode, fixedColumnHeadersHeight, fixedRowsHeight)
C#
protected void AutoResizeRowHeadersWidth(
   DataGridViewRowHeadersWidthSizeMode rowHeadersWidthSizeMode,
   bool fixedColumnHeadersHeight,
   bool fixedRowsHeight
)
Managed Extensions for C++
protected: void AutoResizeRowHeadersWidth(
   DataGridViewRowHeadersWidthSizeMode rowHeadersWidthSizeMode,
   bool fixedColumnHeadersHeight,
   bool fixedRowsHeight
)
C++/CLI
protected:
void AutoResizeRowHeadersWidth(
   DataGridViewRowHeadersWidthSizeMode rowHeadersWidthSizeMode,
   bool fixedColumnHeadersHeight,
   bool fixedRowsHeight
)

Parameters

rowHeadersWidthSizeMode
One of the DataGridViewRowHeadersWidthSizeMode values.
fixedColumnHeadersHeight
true to calculate the new width based on the current height of the column headers; false to calculate the width with the expectation that the height of the column headers will also be adjusted.
fixedRowsHeight
true to calculate the new width based on the current row heights; false to calculate the width with the expectation that the row heights will also be adjusted.

Exceptions

Exception | Description
InvalidEnumArgumentException | rowHeadersWidthSizeMode is not a valid DataGridViewRowHeadersWidthSizeMode value.
ArgumentException | rowHeadersWidthSizeMode has the value DataGridViewRowHeadersWidthSizeMode.EnableResizing or DataGridViewRowHeadersWidthSizeMode.DisableResizing.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members
Overload List


AutoResizeRowHeadersWidth(Int32,DataGridViewRowHeadersWidthSizeMode,Boolean,Boolean) Method

[image]
Gizmox.WebGUI.Forms
AutoResizeRowHeadersWidth(Int32,DataGridViewRowHeadersWidthSizeMode,Boolean,Boolean) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class > AutoResizeRowHeadersWidth Method : AutoResizeRowHeadersWidth(Int32,DataGridViewRowHeadersWidthSizeMode,Boolean,Boolean) Method

rowIndex
The index of the row containing the header with the changed content.
rowHeadersWidthSizeMode
One of the DataGridViewRowHeadersWidthSizeMode values.
fixedColumnHeadersHeight
true to calculate the new width based on the current height of the column headers; false to calculate the width with the expectation that the height of the column headers will also be adjusted.
fixedRowHeight
true to calculate the new width based on the current height of the specified row; false to calculate the width with the expectation that the row height will also be adjusted.
Adjusts the width of the row headers based on changes to the contents of the header in the specified row and using the specified size mode, optionally calculating the width with the expectation that the row and/or column header widths will subsequently be adjusted.

Syntax

Visual Basic (Declaration)
Protected Overloads Sub AutoResizeRowHeadersWidth( _
   ByVal rowIndex As Integer, _
   ByVal rowHeadersWidthSizeMode As DataGridViewRowHeadersWidthSizeMode, _
   ByVal fixedColumnHeadersHeight As Boolean, _
   ByVal fixedRowHeight As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim rowIndex As Integer
Dim rowHeadersWidthSizeMode As DataGridViewRowHeadersWidthSizeMode
Dim fixedColumnHeadersHeight As Boolean
Dim fixedRowHeight As Boolean

instance.AutoResizeRowHeadersWidth(rowIndex, rowHeadersWidthSizeMode, fixedColumnHeadersHeight, fixedRowHeight)
C#
protected void AutoResizeRowHeadersWidth(
   int rowIndex,
   DataGridViewRowHeadersWidthSizeMode rowHeadersWidthSizeMode,
   bool fixedColumnHeadersHeight,
   bool fixedRowHeight
)
Managed Extensions for C++
protected: void AutoResizeRowHeadersWidth(
   int rowIndex,
   DataGridViewRowHeadersWidthSizeMode rowHeadersWidthSizeMode,
   bool fixedColumnHeadersHeight,
   bool fixedRowHeight
)
C++/CLI
protected:
void AutoResizeRowHeadersWidth(
   int rowIndex,
   DataGridViewRowHeadersWidthSizeMode rowHeadersWidthSizeMode,
   bool fixedColumnHeadersHeight,
   bool fixedRowHeight
)

Parameters

rowIndex
The index of the row containing the header with the changed content.
rowHeadersWidthSizeMode
One of the DataGridViewRowHeadersWidthSizeMode values.
fixedColumnHeadersHeight
true to calculate the new width based on the current height of the column headers; false to calculate the width with the expectation that the height of the column headers will also be adjusted.
fixedRowHeight
true to calculate the new width based on the current height of the specified row; false to calculate the width with the expectation that the row height will also be adjusted.

Exceptions

Exception | Description
InvalidEnumArgumentException | rowHeadersWidthSizeMode is not a valid DataGridViewRowHeadersWidthSizeMode value.
ArgumentException | rowHeadersWidthSizeMode has the value DataGridViewRowHeadersWidthSizeMode.EnableResizing or DataGridViewRowHeadersWidthSizeMode.DisableResizing.
ArgumentOutOfRangeException | rowIndex is not in the valid range of 0 to the number of rows minus 1.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members
Overload List


AutoResizeRows Method

[image]
Gizmox.WebGUI.Forms
AutoResizeRows Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : AutoResizeRows Method

Adjusts the heights of all rows to fit the contents of all their cells, including the header cells.

Overload List

Overload | Description
AutoResizeRows() | Adjusts the heights of all rows to fit the contents of all their cells, including the header cells.
AutoResizeRows(DataGridViewAutoSizeRowsMode) | Adjusts the heights of the rows using the specified size mode value.
AutoResizeRows(DataGridViewAutoSizeRowsMode,Boolean) | Adjusts the heights of all rows using the specified size mode, optionally calculating the heights with the expectation that column widths will subsequently be adjusted.
AutoResizeRows(Int32,Int32,DataGridViewAutoSizeRowMode,Boolean) | Adjusts the heights of the specified rows using the specified size mode, optionally calculating the heights with the expectation that column widths will subsequently be adjusted.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


AutoResizeRows() Method

[image]
Gizmox.WebGUI.Forms
AutoResizeRows() Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class > AutoResizeRows Method : AutoResizeRows() Method

Adjusts the heights of all rows to fit the contents of all their cells, including the header cells.

Syntax

Visual Basic (Declaration)
Public Overloads Sub AutoResizeRows()
Visual Basic (Usage) Copy Code
Dim instance As DataGridView

instance.AutoResizeRows()
C#
public void AutoResizeRows()
Managed Extensions for C++
public: void AutoResizeRows();
C++/CLI
public:
void AutoResizeRows();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members
Overload List


AutoResizeRows(DataGridViewAutoSizeRowsMode) Method

[image]
Gizmox.WebGUI.Forms
AutoResizeRows(DataGridViewAutoSizeRowsMode) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class > AutoResizeRows Method : AutoResizeRows(DataGridViewAutoSizeRowsMode) Method

autoSizeRowsMode
One of the DataGridViewAutoSizeRowsMode values.
Adjusts the heights of the rows using the specified size mode value.

Syntax

Visual Basic (Declaration)
Public Overloads Sub AutoResizeRows( _
   ByVal autoSizeRowsMode As DataGridViewAutoSizeRowsMode _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim autoSizeRowsMode As DataGridViewAutoSizeRowsMode

instance.AutoResizeRows(autoSizeRowsMode)
C#
public void AutoResizeRows(
   DataGridViewAutoSizeRowsMode autoSizeRowsMode
)
Managed Extensions for C++
public: void AutoResizeRows(
   DataGridViewAutoSizeRowsMode autoSizeRowsMode
)
C++/CLI
public:
void AutoResizeRows(
   DataGridViewAutoSizeRowsMode autoSizeRowsMode
)

Parameters

autoSizeRowsMode
One of the DataGridViewAutoSizeRowsMode values.

Exceptions

Exception | Description
ArgumentException | autoSizeRowsMode has the value DataGridViewAutoSizeRowsMode.None.
InvalidOperationException | autoSizeRowsMode has the value DataGridViewAutoSizeRowsMode.AllHeaders or DataGridViewAutoSizeRowsMode.DisplayedHeaders, and RowHeadersVisible is false.
InvalidEnumArgumentException | autoSizeRowsMode is not a valid DataGridViewAutoSizeRowsMode value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members
Overload List


AutoResizeRows(DataGridViewAutoSizeRowsMode,Boolean) Method

[image]
Gizmox.WebGUI.Forms
AutoResizeRows(DataGridViewAutoSizeRowsMode,Boolean) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class > AutoResizeRows Method : AutoResizeRows(DataGridViewAutoSizeRowsMode,Boolean) Method

autoSizeRowsMode
One of the DataGridViewAutoSizeRowsMode values.
fixedWidth
true to calculate the new heights based on the current column widths; false to calculate the heights with the expectation that the column widths will also be adjusted.
Adjusts the heights of all rows using the specified size mode, optionally calculating the heights with the expectation that column widths will subsequently be adjusted.

Syntax

Visual Basic (Declaration)
Protected Overloads Sub AutoResizeRows( _
   ByVal autoSizeRowsMode As DataGridViewAutoSizeRowsMode, _
   ByVal fixedWidth As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim autoSizeRowsMode As DataGridViewAutoSizeRowsMode
Dim fixedWidth As Boolean

instance.AutoResizeRows(autoSizeRowsMode, fixedWidth)
C#
protected void AutoResizeRows(
   DataGridViewAutoSizeRowsMode autoSizeRowsMode,
   bool fixedWidth
)
Managed Extensions for C++
protected: void AutoResizeRows(
   DataGridViewAutoSizeRowsMode autoSizeRowsMode,
   bool fixedWidth
)
C++/CLI
protected:
void AutoResizeRows(
   DataGridViewAutoSizeRowsMode autoSizeRowsMode,
   bool fixedWidth
)

Parameters

autoSizeRowsMode
One of the DataGridViewAutoSizeRowsMode values.
fixedWidth
true to calculate the new heights based on the current column widths; false to calculate the heights with the expectation that the column widths will also be adjusted.

Exceptions

Exception | Description
ArgumentException | autoSizeRowsMode has the value DataGridViewAutoSizeRowsMode.None.
InvalidOperationException | autoSizeRowsMode has the value DataGridViewAutoSizeRowsMode.AllHeaders or DataGridViewAutoSizeRowsMode.DisplayedHeaders, and RowHeadersVisible is false.
InvalidEnumArgumentException | autoSizeRowsMode is not a valid DataGridViewAutoSizeRowsMode value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members
Overload List


AutoResizeRows(Int32,Int32,DataGridViewAutoSizeRowMode,Boolean) Method

[image]
Gizmox.WebGUI.Forms
AutoResizeRows(Int32,Int32,DataGridViewAutoSizeRowMode,Boolean) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class > AutoResizeRows Method : AutoResizeRows(Int32,Int32,DataGridViewAutoSizeRowMode,Boolean) Method

rowIndexStart
The index of the first row to resize.
rowsCount
The number of rows to resize.
autoSizeRowMode
One of the DataGridViewAutoSizeRowMode values.
fixedWidth
true to calculate the new heights based on the current column widths; false to calculate the heights with the expectation that the column widths will also be adjusted.
Adjusts the heights of the specified rows using the specified size mode, optionally calculating the heights with the expectation that column widths will subsequently be adjusted.

Syntax

Visual Basic (Declaration)
Protected Overloads Sub AutoResizeRows( _
   ByVal rowIndexStart As Integer, _
   ByVal rowsCount As Integer, _
   ByVal autoSizeRowMode As DataGridViewAutoSizeRowMode, _
   ByVal fixedWidth As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim rowIndexStart As Integer
Dim rowsCount As Integer
Dim autoSizeRowMode As DataGridViewAutoSizeRowMode
Dim fixedWidth As Boolean

instance.AutoResizeRows(rowIndexStart, rowsCount, autoSizeRowMode, fixedWidth)
C#
protected void AutoResizeRows(
   int rowIndexStart,
   int rowsCount,
   DataGridViewAutoSizeRowMode autoSizeRowMode,
   bool fixedWidth
)
Managed Extensions for C++
protected: void AutoResizeRows(
   int rowIndexStart,
   int rowsCount,
   DataGridViewAutoSizeRowMode autoSizeRowMode,
   bool fixedWidth
)
C++/CLI
protected:
void AutoResizeRows(
   int rowIndexStart,
   int rowsCount,
   DataGridViewAutoSizeRowMode autoSizeRowMode,
   bool fixedWidth
)

Parameters

rowIndexStart
The index of the first row to resize.
rowsCount
The number of rows to resize.
autoSizeRowMode
One of the DataGridViewAutoSizeRowMode values.
fixedWidth
true to calculate the new heights based on the current column widths; false to calculate the heights with the expectation that the column widths will also be adjusted.

Exceptions

Exception | Description
ArgumentException | autoSizeRowsMode has the value DataGridViewAutoSizeRowsMode.None.
InvalidOperationException | autoSizeRowsMode has the value DataGridViewAutoSizeRowsMode.AllHeaders or DataGridViewAutoSizeRowsMode.DisplayedHeaders, and RowHeadersVisible is false.
ArgumentOutOfRangeException | rowIndexStart is less than 0.-or-rowsCount is less than 0.
InvalidEnumArgumentException | autoSizeRowsMode is not a valid DataGridViewAutoSizeRowsMode value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members
Overload List


BeginEdit Method

[image]
Gizmox.WebGUI.Forms
BeginEdit Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : BeginEdit Method

selectAll
true to select all the cell's contents; false to not select any contents.
Puts the current cell in edit mode.

Syntax

Visual Basic (Declaration)
Public Overridable Function BeginEdit( _
   ByVal selectAll As Boolean _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim selectAll As Boolean
Dim value As Boolean

value = instance.BeginEdit(selectAll)
C#
public virtual bool BeginEdit(
   bool selectAll
)
Managed Extensions for C++
public: virtual bool BeginEdit(
   bool selectAll
)
C++/CLI
public:
virtual bool BeginEdit(
   bool selectAll
)

Parameters

selectAll
true to select all the cell's contents; false to not select any contents.

Return Value

true if the current cell is already in edit mode or successfully enters edit mode; otherwise, false.

Exceptions

Exception | Description
Exception | Initialization of the editing cell value failed and either there is no handler for the DataError event or the handler has set the DataGridViewDataErrorEventArgs.ThrowException property to true. The exception object can typically be cast to type FormatException.
InvalidCastException | The type indicated by the cell's DataGridViewCell.EditType property does not derive from the Control type.-or-The type indicated by the cell's DataGridViewCell.EditType property does not implement the IDataGridViewEditingControl interface.
InvalidOperationException | CurrentCell is not set to a valid cell.-or-This method was called in a handler for the CellBeginEdit event.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


CancelEdit Method

[image]
Gizmox.WebGUI.Forms
CancelEdit Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : CancelEdit Method

Cancels edit mode for the currently selected cell and discards any changes.

Syntax

Visual Basic (Declaration)
Public Function CancelEdit() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim value As Boolean

value = instance.CancelEdit()
C#
public bool CancelEdit()
Managed Extensions for C++
public: bool CancelEdit();
C++/CLI
public:
bool CancelEdit();

Return Value

true if the cancel was successful; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


ClearSelection Method

[image]
Gizmox.WebGUI.Forms
ClearSelection Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : ClearSelection Method

Clears the current selection by unselecting all selected cells.

Overload List

Overload | Description
ClearSelection() | Clears the current selection by unselecting all selected cells.
ClearSelection(Int32,Int32,Boolean) | Cancels the selection of all currently selected cells except the one indicated, optionally ensuring that the indicated cell is selected.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


ClearSelection() Method

[image]
Gizmox.WebGUI.Forms
ClearSelection() Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class > ClearSelection Method : ClearSelection() Method

Clears the current selection by unselecting all selected cells.

Syntax

Visual Basic (Declaration)
Public Overloads Sub ClearSelection()
Visual Basic (Usage) Copy Code
Dim instance As DataGridView

instance.ClearSelection()
C#
public void ClearSelection()
Managed Extensions for C++
public: void ClearSelection();
C++/CLI
public:
void ClearSelection();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members
Overload List


ClearSelection(Int32,Int32,Boolean) Method

[image]
Gizmox.WebGUI.Forms
ClearSelection(Int32,Int32,Boolean) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class > ClearSelection Method : ClearSelection(Int32,Int32,Boolean) Method

columnIndexException
The column index to exclude.
rowIndexException
The row index to exclude.
selectExceptionElement
true to select the excluded cell, row, or column; false to retain its original state.
Cancels the selection of all currently selected cells except the one indicated, optionally ensuring that the indicated cell is selected.

Syntax

Visual Basic (Declaration)
Protected Overloads Sub ClearSelection( _
   ByVal columnIndexException As Integer, _
   ByVal rowIndexException As Integer, _
   ByVal selectExceptionElement As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim columnIndexException As Integer
Dim rowIndexException As Integer
Dim selectExceptionElement As Boolean

instance.ClearSelection(columnIndexException, rowIndexException, selectExceptionElement)
C#
protected void ClearSelection(
   int columnIndexException,
   int rowIndexException,
   bool selectExceptionElement
)
Managed Extensions for C++
protected: void ClearSelection(
   int columnIndexException,
   int rowIndexException,
   bool selectExceptionElement
)
C++/CLI
protected:
void ClearSelection(
   int columnIndexException,
   int rowIndexException,
   bool selectExceptionElement
)

Parameters

columnIndexException
The column index to exclude.
rowIndexException
The row index to exclude.
selectExceptionElement
true to select the excluded cell, row, or column; false to retain its original state.

Exceptions

Exception | Description
ArgumentOutOfRangeException | columnIndexException is greater than the highest column index.-or-columnIndexException is less than -1 when SelectionMode is FullRowSelect; otherwise, columnIndexException is less than 0.-or- rowIndexException is greater than the highest row index.-or-rowIndexException is less than -1 when SelectionMode is FullColumnSelect; otherwise, rowIndexException is less than 0.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members
Overload List


CommitEdit Method

[image]
Gizmox.WebGUI.Forms
CommitEdit Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : CommitEdit Method

context
A bitwise combination of DataGridViewDataErrorContexts values that specifies the context in which an error can occur.
Commits changes in the current cell to the data cache without ending edit mode.

Syntax

Visual Basic (Declaration)
Public Function CommitEdit( _
   ByVal context As DataGridViewDataErrorContexts _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim context As DataGridViewDataErrorContexts
Dim value As Boolean

value = instance.CommitEdit(context)
C#
public bool CommitEdit(
   DataGridViewDataErrorContexts context
)
Managed Extensions for C++
public: bool CommitEdit(
   DataGridViewDataErrorContexts context
)
C++/CLI
public:
bool CommitEdit(
   DataGridViewDataErrorContexts context
)

Parameters

context
A bitwise combination of DataGridViewDataErrorContexts values that specifies the context in which an error can occur.

Return Value

true if the changes were committed; otherwise false.

Exceptions

Exception | Description
Exception | The cell value could not be committed and either there is no handler for the DataError event or the handler has set the DataGridViewDataErrorEventArgs.ThrowException property to true.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


CreateColumnsInstance Method

[image]
Gizmox.WebGUI.Forms
CreateColumnsInstance Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : CreateColumnsInstance Method

Creates and returns a new DataGridViewColumnCollection.

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Function CreateColumnsInstance() As DataGridViewColumnCollection
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim value As DataGridViewColumnCollection

value = instance.CreateColumnsInstance()
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual DataGridViewColumnCollection CreateColumnsInstance()
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual DataGridViewColumnCollection* CreateColumnsInstance();
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual DataGridViewColumnCollection^ CreateColumnsInstance();

Return Value

An empty DataGridViewColumnCollection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


CreateRowsInstance Method

[image]
Gizmox.WebGUI.Forms
CreateRowsInstance Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : CreateRowsInstance Method

Creates and returns a new DataGridViewRowCollection.

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Function CreateRowsInstance() As DataGridViewRowCollection
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim value As DataGridViewRowCollection

value = instance.CreateRowsInstance()
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual DataGridViewRowCollection CreateRowsInstance()
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual DataGridViewRowCollection* CreateRowsInstance();
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual DataGridViewRowCollection^ CreateRowsInstance();

Return Value

An empty DataGridViewRowCollection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


DisplayedColumnCount Method

[image]
Gizmox.WebGUI.Forms
DisplayedColumnCount Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : DisplayedColumnCount Method

includePartialColumns
true to include partial columns in the displayed column count; otherwise, false.
Returns the number of columns displayed to the user.

Syntax

Visual Basic (Declaration)
Public Function DisplayedColumnCount( _
   ByVal includePartialColumns As Boolean _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim includePartialColumns As Boolean
Dim value As Integer

value = instance.DisplayedColumnCount(includePartialColumns)
C#
public int DisplayedColumnCount(
   bool includePartialColumns
)
Managed Extensions for C++
public: int DisplayedColumnCount(
   bool includePartialColumns
)
C++/CLI
public:
int DisplayedColumnCount(
   bool includePartialColumns
)

Parameters

includePartialColumns
true to include partial columns in the displayed column count; otherwise, false.

Return Value

The number of columns displayed to the user.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


DisplayedRowCount Method

[image]
Gizmox.WebGUI.Forms
DisplayedRowCount Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : DisplayedRowCount Method

includePartialRow
true to include partial rows in the displayed row count; otherwise, false.
Returns the number of rows displayed to the user.

Syntax

Visual Basic (Declaration)
Public Function DisplayedRowCount( _
   ByVal includePartialRow As Boolean _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim includePartialRow As Boolean
Dim value As Integer

value = instance.DisplayedRowCount(includePartialRow)
C#
public int DisplayedRowCount(
   bool includePartialRow
)
Managed Extensions for C++
public: int DisplayedRowCount(
   bool includePartialRow
)
C++/CLI
public:
int DisplayedRowCount(
   bool includePartialRow
)

Parameters

includePartialRow
true to include partial rows in the displayed row count; otherwise, false.

Return Value

The number of rows displayed to the user.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


EndEdit Method

[image]
Gizmox.WebGUI.Forms
EndEdit Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : EndEdit Method

Commits and ends the edit operation on the current cell using the default error context.

Overload List

Overload | Description
EndEdit() | Commits and ends the edit operation on the current cell using the default error context.
EndEdit(DataGridViewDataErrorContexts) | Commits and ends the edit operation on the current cell using the specified error context.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


EndEdit() Method

[image]
Gizmox.WebGUI.Forms
EndEdit() Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class > EndEdit Method : EndEdit() Method

Commits and ends the edit operation on the current cell using the default error context.

Syntax

Visual Basic (Declaration)
Public Overloads Function EndEdit() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim value As Boolean

value = instance.EndEdit()
C#
public bool EndEdit()
Managed Extensions for C++
public: bool EndEdit();
C++/CLI
public:
bool EndEdit();

Return Value

true if the edit operation is committed and ended; otherwise, false.

Exceptions

Exception | Description
Exception | The cell value could not be committed and either there is no handler for the DataError event or the handler has set the DataGridViewDataErrorEventArgs.ThrowException property to true.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members
Overload List


EndEdit(DataGridViewDataErrorContexts) Method

[image]
Gizmox.WebGUI.Forms
EndEdit(DataGridViewDataErrorContexts) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class > EndEdit Method : EndEdit(DataGridViewDataErrorContexts) Method

context
A bitwise combination of DataGridViewDataErrorContexts values that specifies the context in which an error can occur.
Commits and ends the edit operation on the current cell using the specified error context.

Syntax

Visual Basic (Declaration)
Public Overloads Function EndEdit( _
   ByVal context As DataGridViewDataErrorContexts _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim context As DataGridViewDataErrorContexts
Dim value As Boolean

value = instance.EndEdit(context)
C#
public bool EndEdit(
   DataGridViewDataErrorContexts context
)
Managed Extensions for C++
public: bool EndEdit(
   DataGridViewDataErrorContexts context
)
C++/CLI
public:
bool EndEdit(
   DataGridViewDataErrorContexts context
)

Parameters

context
A bitwise combination of DataGridViewDataErrorContexts values that specifies the context in which an error can occur.

Return Value

true if the edit operation is committed and ended; otherwise, false.

Exceptions

Exception | Description
Exception | The cell value could not be committed and either there is no handler for the DataError event or the handler has set the DataGridViewDataErrorEventArgs.ThrowException property to true.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members
Overload List


ExitBulkLayout Method

[image]
Gizmox.WebGUI.Forms
ExitBulkLayout Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : ExitBulkLayout Method

invalidInAdjustFillingColumns

Syntax

Visual Basic (Declaration)
Protected Sub ExitBulkLayout( _
   ByVal invalidInAdjustFillingColumns As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim invalidInAdjustFillingColumns As Boolean

instance.ExitBulkLayout(invalidInAdjustFillingColumns)
C#
protected void ExitBulkLayout(
   bool invalidInAdjustFillingColumns
)
Managed Extensions for C++
protected: void ExitBulkLayout(
   bool invalidInAdjustFillingColumns
)
C++/CLI
protected:
void ExitBulkLayout(
   bool invalidInAdjustFillingColumns
)

Parameters

invalidInAdjustFillingColumns

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


FireEvent Method

[image]
Gizmox.WebGUI.Forms
FireEvent Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : FireEvent Method

objEvent

Syntax

Visual Basic (Declaration)
Protected Overrides Sub FireEvent( _
   ByVal objEvent As IEvent _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim objEvent As IEvent

instance.FireEvent(objEvent)
C#
protected override void FireEvent(
   IEvent objEvent
)
Managed Extensions for C++
protected: void FireEvent(
   IEvent* objEvent
) override
C++/CLI
protected:
void FireEvent(
   IEvent^ objEvent
) override

Parameters

objEvent

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


GetCellCount Method

[image]
Gizmox.WebGUI.Forms
GetCellCount Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : GetCellCount Method

includeFilter
A bitwise combination of the DataGridViewElementStates values specifying the cells to count.
Gets the number of cells that satisfy the provided filter.

Syntax

Visual Basic (Declaration)
Public Function GetCellCount( _
   ByVal includeFilter As DataGridViewElementStates _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim includeFilter As DataGridViewElementStates
Dim value As Integer

value = instance.GetCellCount(includeFilter)
C#
public int GetCellCount(
   DataGridViewElementStates includeFilter
)
Managed Extensions for C++
public: int GetCellCount(
   DataGridViewElementStates includeFilter
)
C++/CLI
public:
int GetCellCount(
   DataGridViewElementStates includeFilter
)

Parameters

includeFilter
A bitwise combination of the DataGridViewElementStates values specifying the cells to count.

Return Value

The number of cells that match the includeFilter parameter.

Exceptions

Exception | Description
ArgumentException | includeFilter includes the value ResizableSet.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


GetClipboardContent Method

[image]
Gizmox.WebGUI.Forms
GetClipboardContent Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : GetClipboardContent Method

Retrieves the formatted values that represent the contents of the selected cells for copying to the Clipboard.

Overload List

Overload | Description
GetClipboardContent() | Retrieves the formatted values that represent the contents of the selected cells for copying to the Clipboard.
GetClipboardContent(TextDataFormat) | Retrieves the formatted values that represent the contents of the selected cells for copying to the Clipboard.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


GetClipboardContent() Method

[image]
Gizmox.WebGUI.Forms
GetClipboardContent() Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class > GetClipboardContent Method : GetClipboardContent() Method

Retrieves the formatted values that represent the contents of the selected cells for copying to the Clipboard.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function GetClipboardContent() As DataObject
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim value As DataObject

value = instance.GetClipboardContent()
C#
public virtual DataObject GetClipboardContent()
Managed Extensions for C++
public: virtual DataObject* GetClipboardContent();
C++/CLI
public:
virtual DataObject^ GetClipboardContent();

Return Value

A DataObject that represents the contents of the selected cells.

Exceptions

Exception | Description
NotSupportedException | ClipboardCopyMode is set to DataGridViewClipboardCopyMode.Disable.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members
Overload List


GetClipboardContent(TextDataFormat) Method

[image]
Gizmox.WebGUI.Forms
GetClipboardContent(TextDataFormat) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class > GetClipboardContent Method : GetClipboardContent(TextDataFormat) Method

format
The serializing format to be produced.
Retrieves the formatted values that represent the contents of the selected cells for copying to the Clipboard.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function GetClipboardContent( _
   ByVal format As TextDataFormat _
) As DataObject
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim format As TextDataFormat
Dim value As DataObject

value = instance.GetClipboardContent(format)
C#
public virtual DataObject GetClipboardContent(
   TextDataFormat format
)
Managed Extensions for C++
public: virtual DataObject* GetClipboardContent(
   TextDataFormat format
)
C++/CLI
public:
virtual DataObject^ GetClipboardContent(
   TextDataFormat format
)

Parameters

format
The serializing format to be produced.

Return Value

A DataObject that represents the contents of the selected cells.

Exceptions

Exception | Description
NotSupportedException | ClipboardCopyMode is set to DataGridViewClipboardCopyMode.Disable.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members
Overload List


GetCriticalEvents Method

[image]
Gizmox.WebGUI.Forms
GetCriticalEvents Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : GetCriticalEvents Method

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetCriticalEvents() As EventTypes
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim value As EventTypes

value = instance.GetCriticalEvents()
C#
protected override EventTypes GetCriticalEvents()
Managed Extensions for C++
protected: EventTypes GetCriticalEvents(); override
C++/CLI
protected:
EventTypes GetCriticalEvents(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


InvalidateCell Method

[image]
Gizmox.WebGUI.Forms
InvalidateCell Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : InvalidateCell Method

Invalidates the specified cell of the DataGridView, forcing it to be repainted.

Overload List

Overload | Description
InvalidateCell(DataGridViewCell) | Invalidates the specified cell of the DataGridView, forcing it to be repainted.
InvalidateCell(Int32,Int32) | Invalidates the cell with the specified row and column indexes, forcing it to be repainted.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


InvalidateCell(DataGridViewCell) Method

[image]
Gizmox.WebGUI.Forms
InvalidateCell(DataGridViewCell) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class > InvalidateCell Method : InvalidateCell(DataGridViewCell) Method

dataGridViewCell
The DataGridViewCell to invalidate.
Invalidates the specified cell of the DataGridView, forcing it to be repainted.

Syntax

Visual Basic (Declaration)
Public Overloads Sub InvalidateCell( _
   ByVal dataGridViewCell As DataGridViewCell _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim dataGridViewCell As DataGridViewCell

instance.InvalidateCell(dataGridViewCell)
C#
public void InvalidateCell(
   DataGridViewCell dataGridViewCell
)
Managed Extensions for C++
public: void InvalidateCell(
   DataGridViewCell* dataGridViewCell
)
C++/CLI
public:
void InvalidateCell(
   DataGridViewCell^ dataGridViewCell
)

Parameters

dataGridViewCell
The DataGridViewCell to invalidate.

Exceptions

Exception | Description
ArgumentNullException | dataGridViewCell is null.
ArgumentException | dataGridViewCell does not belong to the DataGridView.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members
Overload List


InvalidateCell(Int32,Int32) Method

[image]
Gizmox.WebGUI.Forms
InvalidateCell(Int32,Int32) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class > InvalidateCell Method : InvalidateCell(Int32,Int32) Method

columnIndex
The column index of the cell to invalidate.
rowIndex
The row index of the cell to invalidate.
Invalidates the cell with the specified row and column indexes, forcing it to be repainted.

Syntax

Visual Basic (Declaration)
Public Overloads Sub InvalidateCell( _
   ByVal columnIndex As Integer, _
   ByVal rowIndex As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim columnIndex As Integer
Dim rowIndex As Integer

instance.InvalidateCell(columnIndex, rowIndex)
C#
public void InvalidateCell(
   int columnIndex,
   int rowIndex
)
Managed Extensions for C++
public: void InvalidateCell(
   int columnIndex,
   int rowIndex
)
C++/CLI
public:
void InvalidateCell(
   int columnIndex,
   int rowIndex
)

Parameters

columnIndex
The column index of the cell to invalidate.
rowIndex
The row index of the cell to invalidate.

Exceptions

Exception | Description
ArgumentOutOfRangeException | columnIndex is less than -1 or greater than the number of columns in the control minus 1.-or-rowIndex is less than -1 or greater than the number of rows in the control minus 1.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members
Overload List


InvalidateColumn Method

[image]
Gizmox.WebGUI.Forms
InvalidateColumn Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : InvalidateColumn Method

columnIndex
The index of the column to invalidate.
Invalidates the specified column of the DataGridView, forcing it to be repainted.

Syntax

Visual Basic (Declaration)
Public Sub InvalidateColumn( _
   ByVal columnIndex As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim columnIndex As Integer

instance.InvalidateColumn(columnIndex)
C#
public void InvalidateColumn(
   int columnIndex
)
Managed Extensions for C++
public: void InvalidateColumn(
   int columnIndex
)
C++/CLI
public:
void InvalidateColumn(
   int columnIndex
)

Parameters

columnIndex
The index of the column to invalidate.

Exceptions

Exception | Description
ArgumentOutOfRangeException | columnIndex is not in the valid range of 0 to the number of columns minus 1.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


InvalidateRow Method

[image]
Gizmox.WebGUI.Forms
InvalidateRow Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : InvalidateRow Method

rowIndex
The index of the row to invalidate.
Invalidates the specified row of the DataGridView, forcing it to be repainted.

Syntax

Visual Basic (Declaration)
Public Sub InvalidateRow( _
   ByVal rowIndex As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim rowIndex As Integer

instance.InvalidateRow(rowIndex)
C#
public void InvalidateRow(
   int rowIndex
)
Managed Extensions for C++
public: void InvalidateRow(
   int rowIndex
)
C++/CLI
public:
void InvalidateRow(
   int rowIndex
)

Parameters

rowIndex
The index of the row to invalidate.

Exceptions

Exception | Description
ArgumentOutOfRangeException | rowIndex is not in the valid range of 0 to the number of rows minus 1.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


NotifyCurrentCellDirty Method

[image]
Gizmox.WebGUI.Forms
NotifyCurrentCellDirty Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : NotifyCurrentCellDirty Method

dirty
true to indicate the cell has uncommitted changes; otherwise, false.
Notifies the DataGridView that the current cell has uncommitted changes.

Syntax

Visual Basic (Declaration)
Public Overridable Sub NotifyCurrentCellDirty( _
   ByVal dirty As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim dirty As Boolean

instance.NotifyCurrentCellDirty(dirty)
C#
public virtual void NotifyCurrentCellDirty(
   bool dirty
)
Managed Extensions for C++
public: virtual void NotifyCurrentCellDirty(
   bool dirty
)
C++/CLI
public:
virtual void NotifyCurrentCellDirty(
   bool dirty
)

Parameters

dirty
true to indicate the cell has uncommitted changes; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnAllowUserToAddRowsChanged Method

[image]
Gizmox.WebGUI.Forms
OnAllowUserToAddRowsChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnAllowUserToAddRowsChanged Method

e
An EventArgs that contains the event data.
Raises the AllowUserToAddRowsChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnAllowUserToAddRowsChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As EventArgs

instance.OnAllowUserToAddRowsChanged(e)
C#
protected virtual void OnAllowUserToAddRowsChanged(
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnAllowUserToAddRowsChanged(
   EventArgs* e
)
C++/CLI
protected:
virtual void OnAllowUserToAddRowsChanged(
   EventArgs^ e
)

Parameters

e
An EventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnAllowUserToDeleteRowsChanged Method

[image]
Gizmox.WebGUI.Forms
OnAllowUserToDeleteRowsChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnAllowUserToDeleteRowsChanged Method

e
An EventArgs that contains the event data.
Raises the AllowUserToDeleteRowsChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnAllowUserToDeleteRowsChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As EventArgs

instance.OnAllowUserToDeleteRowsChanged(e)
C#
protected virtual void OnAllowUserToDeleteRowsChanged(
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnAllowUserToDeleteRowsChanged(
   EventArgs* e
)
C++/CLI
protected:
virtual void OnAllowUserToDeleteRowsChanged(
   EventArgs^ e
)

Parameters

e
An EventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnAllowUserToOrderColumnsChanged Method

[image]
Gizmox.WebGUI.Forms
OnAllowUserToOrderColumnsChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnAllowUserToOrderColumnsChanged Method

e
A EventArgs that contains the event data.
Raises the AllowUserToOrderColumnsChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnAllowUserToOrderColumnsChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As EventArgs

instance.OnAllowUserToOrderColumnsChanged(e)
C#
protected virtual void OnAllowUserToOrderColumnsChanged(
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnAllowUserToOrderColumnsChanged(
   EventArgs* e
)
C++/CLI
protected:
virtual void OnAllowUserToOrderColumnsChanged(
   EventArgs^ e
)

Parameters

e
A EventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnAllowUserToResizeColumnsChanged Method

[image]
Gizmox.WebGUI.Forms
OnAllowUserToResizeColumnsChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnAllowUserToResizeColumnsChanged Method

e
An EventArgs that contains the event data.
Raises the AllowUserToResizeColumnsChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnAllowUserToResizeColumnsChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As EventArgs

instance.OnAllowUserToResizeColumnsChanged(e)
C#
protected virtual void OnAllowUserToResizeColumnsChanged(
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnAllowUserToResizeColumnsChanged(
   EventArgs* e
)
C++/CLI
protected:
virtual void OnAllowUserToResizeColumnsChanged(
   EventArgs^ e
)

Parameters

e
An EventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnAllowUserToResizeRowsChanged Method

[image]
Gizmox.WebGUI.Forms
OnAllowUserToResizeRowsChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnAllowUserToResizeRowsChanged Method

e
An EventArgs that contains the event data.
Raises the AllowUserToResizeRowsChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnAllowUserToResizeRowsChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As EventArgs

instance.OnAllowUserToResizeRowsChanged(e)
C#
protected virtual void OnAllowUserToResizeRowsChanged(
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnAllowUserToResizeRowsChanged(
   EventArgs* e
)
C++/CLI
protected:
virtual void OnAllowUserToResizeRowsChanged(
   EventArgs^ e
)

Parameters

e
An EventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnAlternatingRowsDefaultCellStyleChanged Method

[image]
Gizmox.WebGUI.Forms
OnAlternatingRowsDefaultCellStyleChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnAlternatingRowsDefaultCellStyleChanged Method

e
An EventArgs that contains the event data.
Raises the AlternatingRowsDefaultCellStyleChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnAlternatingRowsDefaultCellStyleChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As EventArgs

instance.OnAlternatingRowsDefaultCellStyleChanged(e)
C#
protected virtual void OnAlternatingRowsDefaultCellStyleChanged(
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnAlternatingRowsDefaultCellStyleChanged(
   EventArgs* e
)
C++/CLI
protected:
virtual void OnAlternatingRowsDefaultCellStyleChanged(
   EventArgs^ e
)

Parameters

e
An EventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnAutoGenerateColumnsChanged Method

[image]
Gizmox.WebGUI.Forms
OnAutoGenerateColumnsChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnAutoGenerateColumnsChanged Method

e
An EventArgs that contains the event data.
Raises the AutoGenerateColumnsChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnAutoGenerateColumnsChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As EventArgs

instance.OnAutoGenerateColumnsChanged(e)
C#
protected virtual void OnAutoGenerateColumnsChanged(
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnAutoGenerateColumnsChanged(
   EventArgs* e
)
C++/CLI
protected:
virtual void OnAutoGenerateColumnsChanged(
   EventArgs^ e
)

Parameters

e
An EventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnAutoSizeColumnModeChanged Method

[image]
Gizmox.WebGUI.Forms
OnAutoSizeColumnModeChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnAutoSizeColumnModeChanged Method

e
A DataGridViewAutoSizeColumnModeEventArgs that contains the event data.
Raises the AutoSizeColumnModeChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnAutoSizeColumnModeChanged( _
   ByVal e As DataGridViewAutoSizeColumnModeEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As DataGridViewAutoSizeColumnModeEventArgs

instance.OnAutoSizeColumnModeChanged(e)
C#
protected virtual void OnAutoSizeColumnModeChanged(
   DataGridViewAutoSizeColumnModeEventArgs e
)
Managed Extensions for C++
protected: virtual void OnAutoSizeColumnModeChanged(
   DataGridViewAutoSizeColumnModeEventArgs* e
)
C++/CLI
protected:
virtual void OnAutoSizeColumnModeChanged(
   DataGridViewAutoSizeColumnModeEventArgs^ e
)

Parameters

e
A DataGridViewAutoSizeColumnModeEventArgs that contains the event data.

Exceptions

Exception | Description
InvalidOperationException | The value of the DataGridViewAutoSizeColumnModeEventArgs.Column property of e is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnAutoSizeColumnsModeChanged Method

[image]
Gizmox.WebGUI.Forms
OnAutoSizeColumnsModeChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnAutoSizeColumnsModeChanged Method

e
A DataGridViewAutoSizeColumnsModeEventArgs that contains the event data.
Raises the AutoSizeColumnsModeChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnAutoSizeColumnsModeChanged( _
   ByVal e As DataGridViewAutoSizeColumnsModeEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As DataGridViewAutoSizeColumnsModeEventArgs

instance.OnAutoSizeColumnsModeChanged(e)
C#
protected virtual void OnAutoSizeColumnsModeChanged(
   DataGridViewAutoSizeColumnsModeEventArgs e
)
Managed Extensions for C++
protected: virtual void OnAutoSizeColumnsModeChanged(
   DataGridViewAutoSizeColumnsModeEventArgs* e
)
C++/CLI
protected:
virtual void OnAutoSizeColumnsModeChanged(
   DataGridViewAutoSizeColumnsModeEventArgs^ e
)

Parameters

e
A DataGridViewAutoSizeColumnsModeEventArgs that contains the event data.

Exceptions

Exception | Description
ArgumentException | The number of entries in the array returned by the DataGridViewAutoSizeColumnsModeEventArgs.PreviousModes property of e is not equal to the number of columns in the control.
ArgumentNullException | The value of the DataGridViewAutoSizeColumnsModeEventArgs.PreviousModes property of e is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnAutoSizeRowsModeChanged Method

[image]
Gizmox.WebGUI.Forms
OnAutoSizeRowsModeChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnAutoSizeRowsModeChanged Method

e
A DataGridViewAutoSizeModeEventArgs that contains the event data.
Raises the AutoSizeRowsModeChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnAutoSizeRowsModeChanged( _
   ByVal e As DataGridViewAutoSizeModeEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As DataGridViewAutoSizeModeEventArgs

instance.OnAutoSizeRowsModeChanged(e)
C#
protected virtual void OnAutoSizeRowsModeChanged(
   DataGridViewAutoSizeModeEventArgs e
)
Managed Extensions for C++
protected: virtual void OnAutoSizeRowsModeChanged(
   DataGridViewAutoSizeModeEventArgs* e
)
C++/CLI
protected:
virtual void OnAutoSizeRowsModeChanged(
   DataGridViewAutoSizeModeEventArgs^ e
)

Parameters

e
A DataGridViewAutoSizeModeEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnBackgroundColorChanged Method

[image]
Gizmox.WebGUI.Forms
OnBackgroundColorChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnBackgroundColorChanged Method

e
An EventArgs that contains the event data.
Raises the BackgroundColorChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnBackgroundColorChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As EventArgs

instance.OnBackgroundColorChanged(e)
C#
protected virtual void OnBackgroundColorChanged(
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnBackgroundColorChanged(
   EventArgs* e
)
C++/CLI
protected:
virtual void OnBackgroundColorChanged(
   EventArgs^ e
)

Parameters

e
An EventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnBindingContextChanged Method

[image]
Gizmox.WebGUI.Forms
OnBindingContextChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnBindingContextChanged Method

e
An EventArgs that contains the event data.
Raises the Control.BindingContextChanged event.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnBindingContextChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As EventArgs

instance.OnBindingContextChanged(e)
C#
protected override void OnBindingContextChanged(
   EventArgs e
)
Managed Extensions for C++
protected: void OnBindingContextChanged(
   EventArgs* e
) override
C++/CLI
protected:
void OnBindingContextChanged(
   EventArgs^ e
) override

Parameters

e
An EventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnBorderStyleChanged Method

[image]
Gizmox.WebGUI.Forms
OnBorderStyleChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnBorderStyleChanged Method

e
An EventArgs that contains the event data.
Raises the BorderStyleChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnBorderStyleChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As EventArgs

instance.OnBorderStyleChanged(e)
C#
protected virtual void OnBorderStyleChanged(
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnBorderStyleChanged(
   EventArgs* e
)
C++/CLI
protected:
virtual void OnBorderStyleChanged(
   EventArgs^ e
)

Parameters

e
An EventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnCancelRowEdit Method

[image]
Gizmox.WebGUI.Forms
OnCancelRowEdit Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnCancelRowEdit Method

e
A QuestionEventArgs that contains the event data.
Raises the CancelRowEdit event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnCancelRowEdit( _
   ByVal e As QuestionEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As QuestionEventArgs

instance.OnCancelRowEdit(e)
C#
protected virtual void OnCancelRowEdit(
   QuestionEventArgs e
)
Managed Extensions for C++
protected: virtual void OnCancelRowEdit(
   QuestionEventArgs* e
)
C++/CLI
protected:
virtual void OnCancelRowEdit(
   QuestionEventArgs^ e
)

Parameters

e
A QuestionEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnCellBorderStyleChanged Method

[image]
Gizmox.WebGUI.Forms
OnCellBorderStyleChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnCellBorderStyleChanged Method

e
An EventArgs that contains the event data.
Raises the CellBorderStyleChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnCellBorderStyleChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As EventArgs

instance.OnCellBorderStyleChanged(e)
C#
protected virtual void OnCellBorderStyleChanged(
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnCellBorderStyleChanged(
   EventArgs* e
)
C++/CLI
protected:
virtual void OnCellBorderStyleChanged(
   EventArgs^ e
)

Parameters

e
An EventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnCellClick Method

[image]
Gizmox.WebGUI.Forms
OnCellClick Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnCellClick Method

e
A DataGridViewCellEventArgs that contains the event data.
Raises the CellClick event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnCellClick( _
   ByVal e As DataGridViewCellEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As DataGridViewCellEventArgs

instance.OnCellClick(e)
C#
protected virtual void OnCellClick(
   DataGridViewCellEventArgs e
)
Managed Extensions for C++
protected: virtual void OnCellClick(
   DataGridViewCellEventArgs* e
)
C++/CLI
protected:
virtual void OnCellClick(
   DataGridViewCellEventArgs^ e
)

Parameters

e
A DataGridViewCellEventArgs that contains the event data.

Exceptions

Exception | Description
ArgumentOutOfRangeException | The value of the ColumnIndex property of e is greater than the number of columns in the control minus one.-or-The value of the RowIndex property of e is greater than the number of rows in the control minus one.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnCellContentClick Method

[image]
Gizmox.WebGUI.Forms
OnCellContentClick Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnCellContentClick Method

e
A DataGridViewCellEventArgs that contains information regarding the cell whose content was clicked.
Raises the CellContentClick event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnCellContentClick( _
   ByVal e As DataGridViewCellEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As DataGridViewCellEventArgs

instance.OnCellContentClick(e)
C#
protected virtual void OnCellContentClick(
   DataGridViewCellEventArgs e
)
Managed Extensions for C++
protected: virtual void OnCellContentClick(
   DataGridViewCellEventArgs* e
)
C++/CLI
protected:
virtual void OnCellContentClick(
   DataGridViewCellEventArgs^ e
)

Parameters

e
A DataGridViewCellEventArgs that contains information regarding the cell whose content was clicked.

Exceptions

Exception | Description
ArgumentOutOfRangeException | The value of the ColumnIndex property of e is greater than the number of columns in the control minus one.-or-The value of the RowIndex property of e is greater than the number of rows in the control minus one.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnCellContentDoubleClick Method

[image]
Gizmox.WebGUI.Forms
OnCellContentDoubleClick Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnCellContentDoubleClick Method

e
A DataGridViewCellEventArgs that contains the event data.
Raises the CellContentDoubleClick event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnCellContentDoubleClick( _
   ByVal e As DataGridViewCellEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As DataGridViewCellEventArgs

instance.OnCellContentDoubleClick(e)
C#
protected virtual void OnCellContentDoubleClick(
   DataGridViewCellEventArgs e
)
Managed Extensions for C++
protected: virtual void OnCellContentDoubleClick(
   DataGridViewCellEventArgs* e
)
C++/CLI
protected:
virtual void OnCellContentDoubleClick(
   DataGridViewCellEventArgs^ e
)

Parameters

e
A DataGridViewCellEventArgs that contains the event data.

Exceptions

Exception | Description
ArgumentOutOfRangeException | The value of the ColumnIndex property of e is greater than the number of columns in the control minus one.-or-The value of the RowIndex property of e is greater than the number of rows in the control minus one.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnCellContextMenuStripChanged Method

[image]
Gizmox.WebGUI.Forms
OnCellContextMenuStripChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnCellContextMenuStripChanged Method

e
A DataGridViewCellEventArgs that contains the event data.
Raises the CellContextMenuStripChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnCellContextMenuStripChanged( _
   ByVal e As DataGridViewCellEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As DataGridViewCellEventArgs

instance.OnCellContextMenuStripChanged(e)
C#
protected virtual void OnCellContextMenuStripChanged(
   DataGridViewCellEventArgs e
)
Managed Extensions for C++
protected: virtual void OnCellContextMenuStripChanged(
   DataGridViewCellEventArgs* e
)
C++/CLI
protected:
virtual void OnCellContextMenuStripChanged(
   DataGridViewCellEventArgs^ e
)

Parameters

e
A DataGridViewCellEventArgs that contains the event data.

Exceptions

Exception | Description
ArgumentOutOfRangeException | The value of the ColumnIndex property of e is greater than the number of columns in the control minus one.-or-The value of the RowIndex property of e is greater than the number of rows in the control minus one.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnCellDoubleClick Method

[image]
Gizmox.WebGUI.Forms
OnCellDoubleClick Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnCellDoubleClick Method

e
A DataGridViewCellEventArgs that contains the event data.
Raises the CellDoubleClick event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnCellDoubleClick( _
   ByVal e As DataGridViewCellEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As DataGridViewCellEventArgs

instance.OnCellDoubleClick(e)
C#
protected virtual void OnCellDoubleClick(
   DataGridViewCellEventArgs e
)
Managed Extensions for C++
protected: virtual void OnCellDoubleClick(
   DataGridViewCellEventArgs* e
)
C++/CLI
protected:
virtual void OnCellDoubleClick(
   DataGridViewCellEventArgs^ e
)

Parameters

e
A DataGridViewCellEventArgs that contains the event data.

Exceptions

Exception | Description
ArgumentOutOfRangeException | The value of the ColumnIndex property of e is greater than the number of columns in the control minus one.-or-The value of the RowIndex property of e is greater than the number of rows in the control minus one.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnCellEnter Method

[image]
Gizmox.WebGUI.Forms
OnCellEnter Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnCellEnter Method

e

Syntax

Visual Basic (Declaration)
Protected Sub OnCellEnter( _
   ByVal e As DataGridViewCellEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As DataGridViewCellEventArgs

instance.OnCellEnter(e)
C#
protected void OnCellEnter(
   DataGridViewCellEventArgs e
)
Managed Extensions for C++
protected: void OnCellEnter(
   DataGridViewCellEventArgs* e
)
C++/CLI
protected:
void OnCellEnter(
   DataGridViewCellEventArgs^ e
)

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnCellErrorTextChanged Method

[image]
Gizmox.WebGUI.Forms
OnCellErrorTextChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnCellErrorTextChanged Method

e
A DataGridViewCellEventArgs that contains the event data.
Raises the CellErrorTextChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnCellErrorTextChanged( _
   ByVal e As DataGridViewCellEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As DataGridViewCellEventArgs

instance.OnCellErrorTextChanged(e)
C#
protected virtual void OnCellErrorTextChanged(
   DataGridViewCellEventArgs e
)
Managed Extensions for C++
protected: virtual void OnCellErrorTextChanged(
   DataGridViewCellEventArgs* e
)
C++/CLI
protected:
virtual void OnCellErrorTextChanged(
   DataGridViewCellEventArgs^ e
)

Parameters

e
A DataGridViewCellEventArgs that contains the event data.

Exceptions

Exception | Description
ArgumentOutOfRangeException | The value of the DataGridViewCellEventArgs.ColumnIndex property of e is less than -1 or greater than the number of columns in the control minus one.-or-The value of the DataGridViewCellEventArgs.RowIndex property of e is less than -1 or greater than the number of rows in the control minus one.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnCellErrorTextNeeded Method

[image]
Gizmox.WebGUI.Forms
OnCellErrorTextNeeded Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnCellErrorTextNeeded Method

e
A DataGridViewCellErrorTextNeededEventArgs that contains the event data.
Raises the CellErrorTextNeeded event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnCellErrorTextNeeded( _
   ByVal e As DataGridViewCellErrorTextNeededEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As DataGridViewCellErrorTextNeededEventArgs

instance.OnCellErrorTextNeeded(e)
C#
protected virtual void OnCellErrorTextNeeded(
   DataGridViewCellErrorTextNeededEventArgs e
)
Managed Extensions for C++
protected: virtual void OnCellErrorTextNeeded(
   DataGridViewCellErrorTextNeededEventArgs* e
)
C++/CLI
protected:
virtual void OnCellErrorTextNeeded(
   DataGridViewCellErrorTextNeededEventArgs^ e
)

Parameters

e
A DataGridViewCellErrorTextNeededEventArgs that contains the event data.

Exceptions

Exception | Description
ArgumentOutOfRangeException | The value of the DataGridViewCellEventArgs.ColumnIndex property of e is greater than the number of columns in the control minus one.-or-The value of the DataGridViewCellEventArgs.RowIndex property of e is greater than the number of rows in the control minus one.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnCellFormatting Method

[image]
Gizmox.WebGUI.Forms
OnCellFormatting Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnCellFormatting Method

e
A DataGridViewCellFormattingEventArgs that contains the event data.
Raises the CellFormatting event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnCellFormatting( _
   ByVal e As DataGridViewCellFormattingEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As DataGridViewCellFormattingEventArgs

instance.OnCellFormatting(e)
C#
protected virtual void OnCellFormatting(
   DataGridViewCellFormattingEventArgs e
)
Managed Extensions for C++
protected: virtual void OnCellFormatting(
   DataGridViewCellFormattingEventArgs* e
)
C++/CLI
protected:
virtual void OnCellFormatting(
   DataGridViewCellFormattingEventArgs^ e
)

Parameters

e
A DataGridViewCellFormattingEventArgs that contains the event data.

Exceptions

Exception | Description
ArgumentOutOfRangeException | The value of the DataGridViewCellFormattingEventArgs.ColumnIndex property of e is greater than the number of columns in the control minus one.-or-The value of the DataGridViewCellFormattingEventArgs.RowIndex property of e is greater than the number of rows in the control minus one.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnCellLeave Method

[image]
Gizmox.WebGUI.Forms
OnCellLeave Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnCellLeave Method

e

Syntax

Visual Basic (Declaration)
Protected Sub OnCellLeave( _
   ByVal e As DataGridViewCellEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As DataGridViewCellEventArgs

instance.OnCellLeave(e)
C#
protected void OnCellLeave(
   DataGridViewCellEventArgs e
)
Managed Extensions for C++
protected: void OnCellLeave(
   DataGridViewCellEventArgs* e
)
C++/CLI
protected:
void OnCellLeave(
   DataGridViewCellEventArgs^ e
)

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnCellMouseClick Method

[image]
Gizmox.WebGUI.Forms
OnCellMouseClick Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnCellMouseClick Method

e
A DataGridViewCellMouseEventArgs that contains the event data.
Raises the CellMouseClick event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnCellMouseClick( _
   ByVal e As DataGridViewCellMouseEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As DataGridViewCellMouseEventArgs

instance.OnCellMouseClick(e)
C#
protected virtual void OnCellMouseClick(
   DataGridViewCellMouseEventArgs e
)
Managed Extensions for C++
protected: virtual void OnCellMouseClick(
   DataGridViewCellMouseEventArgs* e
)
C++/CLI
protected:
virtual void OnCellMouseClick(
   DataGridViewCellMouseEventArgs^ e
)

Parameters

e
A DataGridViewCellMouseEventArgs that contains the event data.

Exceptions

Exception | Description
ArgumentOutOfRangeException | The value of the ColumnIndex property of e is greater than the number of columns in the control minus one.-or-The value of the RowIndex property of e is greater than the number of rows in the control minus one.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnCellMouseDoubleClick Method

[image]
Gizmox.WebGUI.Forms
OnCellMouseDoubleClick Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnCellMouseDoubleClick Method

e
A DataGridViewCellMouseEventArgs that contains the event data.
Raises the CellMouseDoubleClick event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnCellMouseDoubleClick( _
   ByVal e As DataGridViewCellMouseEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As DataGridViewCellMouseEventArgs

instance.OnCellMouseDoubleClick(e)
C#
protected virtual void OnCellMouseDoubleClick(
   DataGridViewCellMouseEventArgs e
)
Managed Extensions for C++
protected: virtual void OnCellMouseDoubleClick(
   DataGridViewCellMouseEventArgs* e
)
C++/CLI
protected:
virtual void OnCellMouseDoubleClick(
   DataGridViewCellMouseEventArgs^ e
)

Parameters

e
A DataGridViewCellMouseEventArgs that contains the event data.

Exceptions

Exception | Description
ArgumentOutOfRangeException | The value of the ColumnIndex property of e is greater than the number of columns in the control minus one.-or-The value of the RowIndex property of e is greater than the number of rows in the control minus one.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnCellMouseDown Method

[image]
Gizmox.WebGUI.Forms
OnCellMouseDown Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnCellMouseDown Method

e
A DataGridViewCellMouseEventArgs that contains the event data.
Raises the CellMouseDown event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnCellMouseDown( _
   ByVal e As DataGridViewCellMouseEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As DataGridViewCellMouseEventArgs

instance.OnCellMouseDown(e)
C#
protected virtual void OnCellMouseDown(
   DataGridViewCellMouseEventArgs e
)
Managed Extensions for C++
protected: virtual void OnCellMouseDown(
   DataGridViewCellMouseEventArgs* e
)
C++/CLI
protected:
virtual void OnCellMouseDown(
   DataGridViewCellMouseEventArgs^ e
)

Parameters

e
A DataGridViewCellMouseEventArgs that contains the event data.

Exceptions

Exception | Description
ArgumentOutOfRangeException | The value of the ColumnIndex property of e is greater than the number of columns in the control minus one.-or-The value of the RowIndex property of e is greater than the number of rows in the control minus one.
Exception | This action would commit a cell value or enter edit mode, but an error in the data source prevents the action and either there is no handler for the DataError event or the handler has set the ThrowException property to true.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnCellMouseEnter Method

[image]
Gizmox.WebGUI.Forms
OnCellMouseEnter Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnCellMouseEnter Method

e
A DataGridViewCellEventArgs that contains the event data.
Raises the CellMouseEnter event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnCellMouseEnter( _
   ByVal e As DataGridViewCellEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As DataGridViewCellEventArgs

instance.OnCellMouseEnter(e)
C#
protected virtual void OnCellMouseEnter(
   DataGridViewCellEventArgs e
)
Managed Extensions for C++
protected: virtual void OnCellMouseEnter(
   DataGridViewCellEventArgs* e
)
C++/CLI
protected:
virtual void OnCellMouseEnter(
   DataGridViewCellEventArgs^ e
)

Parameters

e
A DataGridViewCellEventArgs that contains the event data.

Exceptions

Exception | Description
ArgumentOutOfRangeException | The value of the ColumnIndex property of e is greater than the number of columns in the control minus one.-or-The value of the RowIndex property of e is greater than the number of rows in the control minus one.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnCellMouseLeave Method

[image]
Gizmox.WebGUI.Forms
OnCellMouseLeave Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnCellMouseLeave Method

e
A DataGridViewCellEventArgs that contains the event data.
Raises the CellMouseLeave event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnCellMouseLeave( _
   ByVal e As DataGridViewCellEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As DataGridViewCellEventArgs

instance.OnCellMouseLeave(e)
C#
protected virtual void OnCellMouseLeave(
   DataGridViewCellEventArgs e
)
Managed Extensions for C++
protected: virtual void OnCellMouseLeave(
   DataGridViewCellEventArgs* e
)
C++/CLI
protected:
virtual void OnCellMouseLeave(
   DataGridViewCellEventArgs^ e
)

Parameters

e
A DataGridViewCellEventArgs that contains the event data.

Exceptions

Exception | Description
ArgumentOutOfRangeException | The value of the ColumnIndex property of e is greater than the number of columns in the control minus one.-or-The value of the RowIndex property of e is greater than the number of rows in the control minus one.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnCellMouseMove Method

[image]
Gizmox.WebGUI.Forms
OnCellMouseMove Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnCellMouseMove Method

e
A DataGridViewCellMouseEventArgs that contains the event data.
Raises the CellMouseMove event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnCellMouseMove( _
   ByVal e As DataGridViewCellMouseEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As DataGridViewCellMouseEventArgs

instance.OnCellMouseMove(e)
C#
protected virtual void OnCellMouseMove(
   DataGridViewCellMouseEventArgs e
)
Managed Extensions for C++
protected: virtual void OnCellMouseMove(
   DataGridViewCellMouseEventArgs* e
)
C++/CLI
protected:
virtual void OnCellMouseMove(
   DataGridViewCellMouseEventArgs^ e
)

Parameters

e
A DataGridViewCellMouseEventArgs that contains the event data.

Exceptions

Exception | Description
ArgumentOutOfRangeException | The value of the ColumnIndex property of e is greater than the number of columns in the control minus one.-or-The value of the RowIndex property of e is greater than the number of rows in the control minus one.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnCellMouseUp Method

[image]
Gizmox.WebGUI.Forms
OnCellMouseUp Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnCellMouseUp Method

e
A DataGridViewCellMouseEventArgs that contains the event data.
Raises the CellMouseUp event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnCellMouseUp( _
   ByVal e As DataGridViewCellMouseEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As DataGridViewCellMouseEventArgs

instance.OnCellMouseUp(e)
C#
protected virtual void OnCellMouseUp(
   DataGridViewCellMouseEventArgs e
)
Managed Extensions for C++
protected: virtual void OnCellMouseUp(
   DataGridViewCellMouseEventArgs* e
)
C++/CLI
protected:
virtual void OnCellMouseUp(
   DataGridViewCellMouseEventArgs^ e
)

Parameters

e
A DataGridViewCellMouseEventArgs that contains the event data.

Exceptions

Exception | Description
ArgumentOutOfRangeException | The value of the ColumnIndex property of e is greater than the number of columns in the control minus one.-or-The value of the RowIndex property of e is greater than the number of rows in the control minus one.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnCellStateChanged Method

[image]
Gizmox.WebGUI.Forms
OnCellStateChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnCellStateChanged Method

e
A DataGridViewCellStateChangedEventArgs that contains the event data.
Raises the CellStateChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnCellStateChanged( _
   ByVal e As DataGridViewCellStateChangedEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As DataGridViewCellStateChangedEventArgs

instance.OnCellStateChanged(e)
C#
protected virtual void OnCellStateChanged(
   DataGridViewCellStateChangedEventArgs e
)
Managed Extensions for C++
protected: virtual void OnCellStateChanged(
   DataGridViewCellStateChangedEventArgs* e
)
C++/CLI
protected:
virtual void OnCellStateChanged(
   DataGridViewCellStateChangedEventArgs^ e
)

Parameters

e
A DataGridViewCellStateChangedEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnCellStyleChanged Method

[image]
Gizmox.WebGUI.Forms
OnCellStyleChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnCellStyleChanged Method

e
A DataGridViewCellEventArgs that contains the event data.
Raises the CellStyleChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnCellStyleChanged( _
   ByVal e As DataGridViewCellEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As DataGridViewCellEventArgs

instance.OnCellStyleChanged(e)
C#
protected virtual void OnCellStyleChanged(
   DataGridViewCellEventArgs e
)
Managed Extensions for C++
protected: virtual void OnCellStyleChanged(
   DataGridViewCellEventArgs* e
)
C++/CLI
protected:
virtual void OnCellStyleChanged(
   DataGridViewCellEventArgs^ e
)

Parameters

e
A DataGridViewCellEventArgs that contains the event data.

Exceptions

Exception | Description
ArgumentOutOfRangeException | The value of the DataGridViewCellEventArgs.ColumnIndex property of e is greater than the number of columns in the control minus one.-or-The value of the DataGridViewCellEventArgs.RowIndex property of e is greater than the number of rows in the control minus one.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnCellStyleContentChanged Method

[image]
Gizmox.WebGUI.Forms
OnCellStyleContentChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnCellStyleContentChanged Method

e
A DataGridViewCellStyleContentChangedEventArgs that contains the event data.
Raises the CellStyleContentChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnCellStyleContentChanged( _
   ByVal e As DataGridViewCellStyleContentChangedEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As DataGridViewCellStyleContentChangedEventArgs

instance.OnCellStyleContentChanged(e)
C#
protected virtual void OnCellStyleContentChanged(
   DataGridViewCellStyleContentChangedEventArgs e
)
Managed Extensions for C++
protected: virtual void OnCellStyleContentChanged(
   DataGridViewCellStyleContentChangedEventArgs* e
)
C++/CLI
protected:
virtual void OnCellStyleContentChanged(
   DataGridViewCellStyleContentChangedEventArgs^ e
)

Parameters

e
A DataGridViewCellStyleContentChangedEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnCellToolTipTextChanged Method

[image]
Gizmox.WebGUI.Forms
OnCellToolTipTextChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnCellToolTipTextChanged Method

e
An DataGridViewCellEventArgs that contains information about the cell.
Raises the CellToolTipTextChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnCellToolTipTextChanged( _
   ByVal e As DataGridViewCellEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As DataGridViewCellEventArgs

instance.OnCellToolTipTextChanged(e)
C#
protected virtual void OnCellToolTipTextChanged(
   DataGridViewCellEventArgs e
)
Managed Extensions for C++
protected: virtual void OnCellToolTipTextChanged(
   DataGridViewCellEventArgs* e
)
C++/CLI
protected:
virtual void OnCellToolTipTextChanged(
   DataGridViewCellEventArgs^ e
)

Parameters

e
An DataGridViewCellEventArgs that contains information about the cell.

Exceptions

Exception | Description
ArgumentOutOfRangeException | The value of the DataGridViewCellEventArgs.ColumnIndex property of e is greater than the number of columns in the control minus one.-or-The value of the DataGridViewCellEventArgs.RowIndex property of e is greater than the number of rows in the control minus one.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnCellToolTipTextNeeded Method

[image]
Gizmox.WebGUI.Forms
OnCellToolTipTextNeeded Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnCellToolTipTextNeeded Method

e
A DataGridViewCellToolTipTextNeededEventArgs that contains the event data.
Raises the CellToolTipTextNeeded event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnCellToolTipTextNeeded( _
   ByVal e As DataGridViewCellToolTipTextNeededEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As DataGridViewCellToolTipTextNeededEventArgs

instance.OnCellToolTipTextNeeded(e)
C#
protected virtual void OnCellToolTipTextNeeded(
   DataGridViewCellToolTipTextNeededEventArgs e
)
Managed Extensions for C++
protected: virtual void OnCellToolTipTextNeeded(
   DataGridViewCellToolTipTextNeededEventArgs* e
)
C++/CLI
protected:
virtual void OnCellToolTipTextNeeded(
   DataGridViewCellToolTipTextNeededEventArgs^ e
)

Parameters

e
A DataGridViewCellToolTipTextNeededEventArgs that contains the event data.

Exceptions

Exception | Description
ArgumentOutOfRangeException | The value of the DataGridViewCellEventArgs.ColumnIndex property of e is greater than the number of columns in the control minus one.-or-The value of the DataGridViewCellEventArgs.RowIndex property of e is greater than the number of rows in the control minus one.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnCellValueChanged Method

[image]
Gizmox.WebGUI.Forms
OnCellValueChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnCellValueChanged Method

e
A DataGridViewCellEventArgs that contains the event data.
Raises the CellValueChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnCellValueChanged( _
   ByVal e As DataGridViewCellEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As DataGridViewCellEventArgs

instance.OnCellValueChanged(e)
C#
protected virtual void OnCellValueChanged(
   DataGridViewCellEventArgs e
)
Managed Extensions for C++
protected: virtual void OnCellValueChanged(
   DataGridViewCellEventArgs* e
)
C++/CLI
protected:
virtual void OnCellValueChanged(
   DataGridViewCellEventArgs^ e
)

Parameters

e
A DataGridViewCellEventArgs that contains the event data.

Exceptions

Exception | Description
ArgumentOutOfRangeException | The value of the DataGridViewCellEventArgs.ColumnIndex property of e is greater than the number of columns in the control minus one.-or-The value of the DataGridViewCellEventArgs.RowIndex property of e is greater than the number of rows in the control minus one.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnCellValueNeeded Method

[image]
Gizmox.WebGUI.Forms
OnCellValueNeeded Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnCellValueNeeded Method

e
A DataGridViewCellValueEventArgs that contains the event data.
Raises the CellValueNeeded event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnCellValueNeeded( _
   ByVal e As DataGridViewCellValueEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As DataGridViewCellValueEventArgs

instance.OnCellValueNeeded(e)
C#
protected virtual void OnCellValueNeeded(
   DataGridViewCellValueEventArgs e
)
Managed Extensions for C++
protected: virtual void OnCellValueNeeded(
   DataGridViewCellValueEventArgs* e
)
C++/CLI
protected:
virtual void OnCellValueNeeded(
   DataGridViewCellValueEventArgs^ e
)

Parameters

e
A DataGridViewCellValueEventArgs that contains the event data.

Exceptions

Exception | Description
ArgumentOutOfRangeException | The value of the DataGridViewCellValueEventArgs.ColumnIndex property of e is less than zero or greater than the number of columns in the control minus one.-or-The value of the DataGridViewCellValueEventArgs.RowIndex property of e is less than zero or greater than the number of rows in the control minus one.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnCellValuePushed Method

[image]
Gizmox.WebGUI.Forms
OnCellValuePushed Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnCellValuePushed Method

e
A DataGridViewCellValueEventArgs that contains the event data.
Raises the CellValuePushed event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnCellValuePushed( _
   ByVal e As DataGridViewCellValueEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As DataGridViewCellValueEventArgs

instance.OnCellValuePushed(e)
C#
protected virtual void OnCellValuePushed(
   DataGridViewCellValueEventArgs e
)
Managed Extensions for C++
protected: virtual void OnCellValuePushed(
   DataGridViewCellValueEventArgs* e
)
C++/CLI
protected:
virtual void OnCellValuePushed(
   DataGridViewCellValueEventArgs^ e
)

Parameters

e
A DataGridViewCellValueEventArgs that contains the event data.

Exceptions

Exception | Description
ArgumentOutOfRangeException | The value of the DataGridViewCellValueEventArgs.ColumnIndex property of e is less than zero or greater than the number of columns in the control minus one.-or-The value of the DataGridViewCellValueEventArgs.RowIndex property of e is less than zero or greater than the number of rows in the control minus one.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnColumnAdded Method

[image]
Gizmox.WebGUI.Forms
OnColumnAdded Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnColumnAdded Method

e
A DataGridViewColumnEventArgs that contains the event data.
Raises the ColumnAdded event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnColumnAdded( _
   ByVal e As DataGridViewColumnEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As DataGridViewColumnEventArgs

instance.OnColumnAdded(e)
C#
protected virtual void OnColumnAdded(
   DataGridViewColumnEventArgs e
)
Managed Extensions for C++
protected: virtual void OnColumnAdded(
   DataGridViewColumnEventArgs* e
)
C++/CLI
protected:
virtual void OnColumnAdded(
   DataGridViewColumnEventArgs^ e
)

Parameters

e
A DataGridViewColumnEventArgs that contains the event data.

Exceptions

Exception | Description
ArgumentException | The column indicated by the DataGridViewColumnEventArgs.Column property of e does not belong to this DataGridView control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnColumnContextMenuStripChanged Method

[image]
Gizmox.WebGUI.Forms
OnColumnContextMenuStripChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnColumnContextMenuStripChanged Method

e
A DataGridViewColumnEventArgs that contains the event data.
Raises the ColumnContextMenuStripChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnColumnContextMenuStripChanged( _
   ByVal e As DataGridViewColumnEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As DataGridViewColumnEventArgs

instance.OnColumnContextMenuStripChanged(e)
C#
protected virtual void OnColumnContextMenuStripChanged(
   DataGridViewColumnEventArgs e
)
Managed Extensions for C++
protected: virtual void OnColumnContextMenuStripChanged(
   DataGridViewColumnEventArgs* e
)
C++/CLI
protected:
virtual void OnColumnContextMenuStripChanged(
   DataGridViewColumnEventArgs^ e
)

Parameters

e
A DataGridViewColumnEventArgs that contains the event data.

Exceptions

Exception | Description
ArgumentException | The column indicated by the DataGridViewColumnEventArgs.Column property of e does not belong to this DataGridView control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnColumnDataPropertyNameChanged Method

[image]
Gizmox.WebGUI.Forms
OnColumnDataPropertyNameChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnColumnDataPropertyNameChanged Method

e
A DataGridViewColumnEventArgs that contains the event data.
Raises the ColumnDataPropertyNameChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnColumnDataPropertyNameChanged( _
   ByVal e As DataGridViewColumnEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As DataGridViewColumnEventArgs

instance.OnColumnDataPropertyNameChanged(e)
C#
protected virtual void OnColumnDataPropertyNameChanged(
   DataGridViewColumnEventArgs e
)
Managed Extensions for C++
protected: virtual void OnColumnDataPropertyNameChanged(
   DataGridViewColumnEventArgs* e
)
C++/CLI
protected:
virtual void OnColumnDataPropertyNameChanged(
   DataGridViewColumnEventArgs^ e
)

Parameters

e
A DataGridViewColumnEventArgs that contains the event data.

Exceptions

Exception | Description
ArgumentException | The column indicated by the DataGridViewColumnEventArgs.Column property of e does not belong to this DataGridView control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnColumnDefaultCellStyleChanged Method

[image]
Gizmox.WebGUI.Forms
OnColumnDefaultCellStyleChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnColumnDefaultCellStyleChanged Method

e
A DataGridViewColumnEventArgs that contains the event data.
Raises the ColumnDefaultCellStyleChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnColumnDefaultCellStyleChanged( _
   ByVal e As DataGridViewColumnEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As DataGridViewColumnEventArgs

instance.OnColumnDefaultCellStyleChanged(e)
C#
protected virtual void OnColumnDefaultCellStyleChanged(
   DataGridViewColumnEventArgs e
)
Managed Extensions for C++
protected: virtual void OnColumnDefaultCellStyleChanged(
   DataGridViewColumnEventArgs* e
)
C++/CLI
protected:
virtual void OnColumnDefaultCellStyleChanged(
   DataGridViewColumnEventArgs^ e
)

Parameters

e
A DataGridViewColumnEventArgs that contains the event data.

Exceptions

Exception | Description
ArgumentException | The column indicated by the DataGridViewColumnEventArgs.Column property of e does not belong to this DataGridView control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnColumnDisplayIndexChanged Method

[image]
Gizmox.WebGUI.Forms
OnColumnDisplayIndexChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnColumnDisplayIndexChanged Method

e
A DataGridViewColumnEventArgs that contains the event data.
Raises the ColumnDisplayIndexChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnColumnDisplayIndexChanged( _
   ByVal e As DataGridViewColumnEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As DataGridViewColumnEventArgs

instance.OnColumnDisplayIndexChanged(e)
C#
protected virtual void OnColumnDisplayIndexChanged(
   DataGridViewColumnEventArgs e
)
Managed Extensions for C++
protected: virtual void OnColumnDisplayIndexChanged(
   DataGridViewColumnEventArgs* e
)
C++/CLI
protected:
virtual void OnColumnDisplayIndexChanged(
   DataGridViewColumnEventArgs^ e
)

Parameters

e
A DataGridViewColumnEventArgs that contains the event data.

Exceptions

Exception | Description
ArgumentException | The column indicated by the DataGridViewColumnEventArgs.Column property of e does not belong to this DataGridView control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnColumnDividerDoubleClick Method

[image]
Gizmox.WebGUI.Forms
OnColumnDividerDoubleClick Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnColumnDividerDoubleClick Method

e
A DataGridViewColumnDividerDoubleClickEventArgs that contains the event data.
Raises the ColumnDividerDoubleClick event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnColumnDividerDoubleClick( _
   ByVal e As DataGridViewColumnDividerDoubleClickEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As DataGridViewColumnDividerDoubleClickEventArgs

instance.OnColumnDividerDoubleClick(e)
C#
protected virtual void OnColumnDividerDoubleClick(
   DataGridViewColumnDividerDoubleClickEventArgs e
)
Managed Extensions for C++
protected: virtual void OnColumnDividerDoubleClick(
   DataGridViewColumnDividerDoubleClickEventArgs* e
)
C++/CLI
protected:
virtual void OnColumnDividerDoubleClick(
   DataGridViewColumnDividerDoubleClickEventArgs^ e
)

Parameters

e
A DataGridViewColumnDividerDoubleClickEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnColumnDividerWidthChanged Method

[image]
Gizmox.WebGUI.Forms
OnColumnDividerWidthChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnColumnDividerWidthChanged Method

e
A DataGridViewColumnEventArgs that contains the event data.
Raises the ColumnDividerWidthChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnColumnDividerWidthChanged( _
   ByVal e As DataGridViewColumnEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As DataGridViewColumnEventArgs

instance.OnColumnDividerWidthChanged(e)
C#
protected virtual void OnColumnDividerWidthChanged(
   DataGridViewColumnEventArgs e
)
Managed Extensions for C++
protected: virtual void OnColumnDividerWidthChanged(
   DataGridViewColumnEventArgs* e
)
C++/CLI
protected:
virtual void OnColumnDividerWidthChanged(
   DataGridViewColumnEventArgs^ e
)

Parameters

e
A DataGridViewColumnEventArgs that contains the event data.

Exceptions

Exception | Description
ArgumentException | The column indicated by the DataGridViewColumnEventArgs.Column property of e does not belong to this DataGridView control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnColumnHeaderCellChanged Method

[image]
Gizmox.WebGUI.Forms
OnColumnHeaderCellChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnColumnHeaderCellChanged Method

e
A DataGridViewColumnEventArgs that contains the event data.
Raises the ColumnHeaderCellChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnColumnHeaderCellChanged( _
   ByVal e As DataGridViewColumnEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As DataGridViewColumnEventArgs

instance.OnColumnHeaderCellChanged(e)
C#
protected virtual void OnColumnHeaderCellChanged(
   DataGridViewColumnEventArgs e
)
Managed Extensions for C++
protected: virtual void OnColumnHeaderCellChanged(
   DataGridViewColumnEventArgs* e
)
C++/CLI
protected:
virtual void OnColumnHeaderCellChanged(
   DataGridViewColumnEventArgs^ e
)

Parameters

e
A DataGridViewColumnEventArgs that contains the event data.

Exceptions

Exception | Description
ArgumentException | The column indicated by the DataGridViewColumnEventArgs.Column property of e does not belong to this DataGridView control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnColumnHeaderMouseClick Method

[image]
Gizmox.WebGUI.Forms
OnColumnHeaderMouseClick Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnColumnHeaderMouseClick Method

e
A DataGridViewCellMouseEventArgs that contains the event data.
Raises the ColumnHeaderMouseClick event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnColumnHeaderMouseClick( _
   ByVal e As DataGridViewCellMouseEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As DataGridViewCellMouseEventArgs

instance.OnColumnHeaderMouseClick(e)
C#
protected virtual void OnColumnHeaderMouseClick(
   DataGridViewCellMouseEventArgs e
)
Managed Extensions for C++
protected: virtual void OnColumnHeaderMouseClick(
   DataGridViewCellMouseEventArgs* e
)
C++/CLI
protected:
virtual void OnColumnHeaderMouseClick(
   DataGridViewCellMouseEventArgs^ e
)

Parameters

e
A DataGridViewCellMouseEventArgs that contains the event data.

Exceptions

Exception | Description
ArgumentOutOfRangeException | The value of the DataGridViewCellMouseEventArgs.ColumnIndex property of e is less than zero or greater than the number of columns in the control minus one.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnColumnHeaderMouseDoubleClick Method

[image]
Gizmox.WebGUI.Forms
OnColumnHeaderMouseDoubleClick Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnColumnHeaderMouseDoubleClick Method

e
A DataGridViewCellMouseEventArgs that contains information about the cell and the position of the mouse pointer.
Raises the ColumnHeaderMouseDoubleClick event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnColumnHeaderMouseDoubleClick( _
   ByVal e As DataGridViewCellMouseEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As DataGridViewCellMouseEventArgs

instance.OnColumnHeaderMouseDoubleClick(e)
C#
protected virtual void OnColumnHeaderMouseDoubleClick(
   DataGridViewCellMouseEventArgs e
)
Managed Extensions for C++
protected: virtual void OnColumnHeaderMouseDoubleClick(
   DataGridViewCellMouseEventArgs* e
)
C++/CLI
protected:
virtual void OnColumnHeaderMouseDoubleClick(
   DataGridViewCellMouseEventArgs^ e
)

Parameters

e
A DataGridViewCellMouseEventArgs that contains information about the cell and the position of the mouse pointer.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnColumnHeadersBorderStyleChanged Method

[image]
Gizmox.WebGUI.Forms
OnColumnHeadersBorderStyleChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnColumnHeadersBorderStyleChanged Method

e
An EventArgs that contains the event data.
Raises the ColumnHeadersBorderStyleChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnColumnHeadersBorderStyleChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As EventArgs

instance.OnColumnHeadersBorderStyleChanged(e)
C#
protected virtual void OnColumnHeadersBorderStyleChanged(
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnColumnHeadersBorderStyleChanged(
   EventArgs* e
)
C++/CLI
protected:
virtual void OnColumnHeadersBorderStyleChanged(
   EventArgs^ e
)

Parameters

e
An EventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnColumnHeadersDefaultCellStyleChanged Method

[image]
Gizmox.WebGUI.Forms
OnColumnHeadersDefaultCellStyleChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnColumnHeadersDefaultCellStyleChanged Method

e
An EventArgs that contains the event data.
Raises the ColumnHeadersDefaultCellStyleChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnColumnHeadersDefaultCellStyleChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As EventArgs

instance.OnColumnHeadersDefaultCellStyleChanged(e)
C#
protected virtual void OnColumnHeadersDefaultCellStyleChanged(
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnColumnHeadersDefaultCellStyleChanged(
   EventArgs* e
)
C++/CLI
protected:
virtual void OnColumnHeadersDefaultCellStyleChanged(
   EventArgs^ e
)

Parameters

e
An EventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnColumnHeadersHeightChanged Method

[image]
Gizmox.WebGUI.Forms
OnColumnHeadersHeightChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnColumnHeadersHeightChanged Method

e
An EventArgs that contains the event data.
Raises the ColumnHeadersHeightChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnColumnHeadersHeightChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As EventArgs

instance.OnColumnHeadersHeightChanged(e)
C#
protected virtual void OnColumnHeadersHeightChanged(
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnColumnHeadersHeightChanged(
   EventArgs* e
)
C++/CLI
protected:
virtual void OnColumnHeadersHeightChanged(
   EventArgs^ e
)

Parameters

e
An EventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnColumnHeadersHeightSizeModeChanged Method

[image]
Gizmox.WebGUI.Forms
OnColumnHeadersHeightSizeModeChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnColumnHeadersHeightSizeModeChanged Method

e
A DataGridViewAutoSizeModeEventArgs that contains the event data.
Raises the ColumnHeadersHeightSizeModeChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnColumnHeadersHeightSizeModeChanged( _
   ByVal e As DataGridViewAutoSizeModeEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As DataGridViewAutoSizeModeEventArgs

instance.OnColumnHeadersHeightSizeModeChanged(e)
C#
protected virtual void OnColumnHeadersHeightSizeModeChanged(
   DataGridViewAutoSizeModeEventArgs e
)
Managed Extensions for C++
protected: virtual void OnColumnHeadersHeightSizeModeChanged(
   DataGridViewAutoSizeModeEventArgs* e
)
C++/CLI
protected:
virtual void OnColumnHeadersHeightSizeModeChanged(
   DataGridViewAutoSizeModeEventArgs^ e
)

Parameters

e
A DataGridViewAutoSizeModeEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnColumnMinimumWidthChanged Method

[image]
Gizmox.WebGUI.Forms
OnColumnMinimumWidthChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnColumnMinimumWidthChanged Method

e
A DataGridViewColumnEventArgs that contains the event data.
Raises the ColumnMinimumWidthChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnColumnMinimumWidthChanged( _
   ByVal e As DataGridViewColumnEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As DataGridViewColumnEventArgs

instance.OnColumnMinimumWidthChanged(e)
C#
protected virtual void OnColumnMinimumWidthChanged(
   DataGridViewColumnEventArgs e
)
Managed Extensions for C++
protected: virtual void OnColumnMinimumWidthChanged(
   DataGridViewColumnEventArgs* e
)
C++/CLI
protected:
virtual void OnColumnMinimumWidthChanged(
   DataGridViewColumnEventArgs^ e
)

Parameters

e
A DataGridViewColumnEventArgs that contains the event data.

Exceptions

Exception | Description
ArgumentException | The column indicated by the DataGridViewColumnEventArgs.Column property of e does not belong to this DataGridView control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnColumnNameChanged Method

[image]
Gizmox.WebGUI.Forms
OnColumnNameChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnColumnNameChanged Method

e
A DataGridViewColumnEventArgs that contains the event data.
Raises the ColumnNameChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnColumnNameChanged( _
   ByVal e As DataGridViewColumnEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As DataGridViewColumnEventArgs

instance.OnColumnNameChanged(e)
C#
protected virtual void OnColumnNameChanged(
   DataGridViewColumnEventArgs e
)
Managed Extensions for C++
protected: virtual void OnColumnNameChanged(
   DataGridViewColumnEventArgs* e
)
C++/CLI
protected:
virtual void OnColumnNameChanged(
   DataGridViewColumnEventArgs^ e
)

Parameters

e
A DataGridViewColumnEventArgs that contains the event data.

Exceptions

Exception | Description
ArgumentException | The column indicated by the DataGridViewColumnEventArgs.Column property of e does not belong to this DataGridView control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnColumnRemoved Method

[image]
Gizmox.WebGUI.Forms
OnColumnRemoved Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnColumnRemoved Method

e
A DataGridViewColumnEventArgs that contains the event data.
Raises the ColumnRemoved event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnColumnRemoved( _
   ByVal e As DataGridViewColumnEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As DataGridViewColumnEventArgs

instance.OnColumnRemoved(e)
C#
protected virtual void OnColumnRemoved(
   DataGridViewColumnEventArgs e
)
Managed Extensions for C++
protected: virtual void OnColumnRemoved(
   DataGridViewColumnEventArgs* e
)
C++/CLI
protected:
virtual void OnColumnRemoved(
   DataGridViewColumnEventArgs^ e
)

Parameters

e
A DataGridViewColumnEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnColumnSortModeChanged Method

[image]
Gizmox.WebGUI.Forms
OnColumnSortModeChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnColumnSortModeChanged Method

e
A DataGridViewColumnEventArgs that contains the event data.
Raises the ColumnSortModeChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnColumnSortModeChanged( _
   ByVal e As DataGridViewColumnEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As DataGridViewColumnEventArgs

instance.OnColumnSortModeChanged(e)
C#
protected virtual void OnColumnSortModeChanged(
   DataGridViewColumnEventArgs e
)
Managed Extensions for C++
protected: virtual void OnColumnSortModeChanged(
   DataGridViewColumnEventArgs* e
)
C++/CLI
protected:
virtual void OnColumnSortModeChanged(
   DataGridViewColumnEventArgs^ e
)

Parameters

e
A DataGridViewColumnEventArgs that contains the event data.

Exceptions

Exception | Description
ArgumentException | The column indicated by the DataGridViewColumnEventArgs.Column property of e does not belong to this DataGridView control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnColumnStateChanged Method

[image]
Gizmox.WebGUI.Forms
OnColumnStateChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnColumnStateChanged Method

e
A DataGridViewColumnStateChangedEventArgs that contains the event data.
Raises the ColumnStateChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnColumnStateChanged( _
   ByVal e As DataGridViewColumnStateChangedEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As DataGridViewColumnStateChangedEventArgs

instance.OnColumnStateChanged(e)
C#
protected virtual void OnColumnStateChanged(
   DataGridViewColumnStateChangedEventArgs e
)
Managed Extensions for C++
protected: virtual void OnColumnStateChanged(
   DataGridViewColumnStateChangedEventArgs* e
)
C++/CLI
protected:
virtual void OnColumnStateChanged(
   DataGridViewColumnStateChangedEventArgs^ e
)

Parameters

e
A DataGridViewColumnStateChangedEventArgs that contains the event data.

Exceptions

Exception | Description
InvalidCastException | The column changed from read-only to read/write, enabling the current cell to enter edit mode, but the DataGridViewCell.EditType property of the current cell does not indicate a class that derives from Control and implements IDataGridViewEditingControl.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnColumnToolTipTextChanged Method

[image]
Gizmox.WebGUI.Forms
OnColumnToolTipTextChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnColumnToolTipTextChanged Method

e
A DataGridViewColumnEventArgs that contains information about the column.
Raises the ColumnToolTipTextChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnColumnToolTipTextChanged( _
   ByVal e As DataGridViewColumnEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As DataGridViewColumnEventArgs

instance.OnColumnToolTipTextChanged(e)
C#
protected virtual void OnColumnToolTipTextChanged(
   DataGridViewColumnEventArgs e
)
Managed Extensions for C++
protected: virtual void OnColumnToolTipTextChanged(
   DataGridViewColumnEventArgs* e
)
C++/CLI
protected:
virtual void OnColumnToolTipTextChanged(
   DataGridViewColumnEventArgs^ e
)

Parameters

e
A DataGridViewColumnEventArgs that contains information about the column.

Exceptions

Exception | Description
ArgumentException | The column indicated by the DataGridViewColumnEventArgs.Column property of e does not belong to this DataGridView control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnColumnWidthChanged Method

[image]
Gizmox.WebGUI.Forms
OnColumnWidthChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnColumnWidthChanged Method

e
A DataGridViewColumnEventArgs that contains the event data.
Raises the ColumnWidthChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnColumnWidthChanged( _
   ByVal e As DataGridViewColumnEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As DataGridViewColumnEventArgs

instance.OnColumnWidthChanged(e)
C#
protected virtual void OnColumnWidthChanged(
   DataGridViewColumnEventArgs e
)
Managed Extensions for C++
protected: virtual void OnColumnWidthChanged(
   DataGridViewColumnEventArgs* e
)
C++/CLI
protected:
virtual void OnColumnWidthChanged(
   DataGridViewColumnEventArgs^ e
)

Parameters

e
A DataGridViewColumnEventArgs that contains the event data.

Exceptions

Exception | Description
ArgumentException | The column indicated by the DataGridViewColumnEventArgs.Column property of e does not belong to this DataGridView control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnCurrentCellChanged Method

[image]
Gizmox.WebGUI.Forms
OnCurrentCellChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnCurrentCellChanged Method

e
An EventArgs that contains the event data.
Raises the CurrentCellChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnCurrentCellChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As EventArgs

instance.OnCurrentCellChanged(e)
C#
protected virtual void OnCurrentCellChanged(
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnCurrentCellChanged(
   EventArgs* e
)
C++/CLI
protected:
virtual void OnCurrentCellChanged(
   EventArgs^ e
)

Parameters

e
An EventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnCurrentCellDirtyStateChanged Method

[image]
Gizmox.WebGUI.Forms
OnCurrentCellDirtyStateChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnCurrentCellDirtyStateChanged Method

e
An EventArgs that contains the event data.
Raises the CurrentCellDirtyStateChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnCurrentCellDirtyStateChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As EventArgs

instance.OnCurrentCellDirtyStateChanged(e)
C#
protected virtual void OnCurrentCellDirtyStateChanged(
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnCurrentCellDirtyStateChanged(
   EventArgs* e
)
C++/CLI
protected:
virtual void OnCurrentCellDirtyStateChanged(
   EventArgs^ e
)

Parameters

e
An EventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnCursorChanged Method

[image]
Gizmox.WebGUI.Forms
OnCursorChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnCursorChanged Method

e
An EventArgs that contains the event data.
Raises the Control.CursorChanged event and updates the UserSetCursor property if the cursor was changed in user code.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnCursorChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As EventArgs

instance.OnCursorChanged(e)
C#
protected override void OnCursorChanged(
   EventArgs e
)
Managed Extensions for C++
protected: void OnCursorChanged(
   EventArgs* e
) override
C++/CLI
protected:
void OnCursorChanged(
   EventArgs^ e
) override

Parameters

e
An EventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnDataBindingComplete Method

[image]
Gizmox.WebGUI.Forms
OnDataBindingComplete Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnDataBindingComplete Method

e
A DataGridViewBindingCompleteEventArgs that contains the event data.
Raises the DataBindingComplete event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnDataBindingComplete( _
   ByVal e As DataGridViewBindingCompleteEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As DataGridViewBindingCompleteEventArgs

instance.OnDataBindingComplete(e)
C#
protected virtual void OnDataBindingComplete(
   DataGridViewBindingCompleteEventArgs e
)
Managed Extensions for C++
protected: virtual void OnDataBindingComplete(
   DataGridViewBindingCompleteEventArgs* e
)
C++/CLI
protected:
virtual void OnDataBindingComplete(
   DataGridViewBindingCompleteEventArgs^ e
)

Parameters

e
A DataGridViewBindingCompleteEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnDataError Method

[image]
Gizmox.WebGUI.Forms
OnDataError Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnDataError Method

displayErrorDialogIfNoHandler
true to display an error dialog box if there is no handler for the DataError event.
e
A DataGridViewDataErrorEventArgs that contains the event data.
Raises the DataError event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnDataError( _
   ByVal displayErrorDialogIfNoHandler As Boolean, _
   ByVal e As DataGridViewDataErrorEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim displayErrorDialogIfNoHandler As Boolean
Dim e As DataGridViewDataErrorEventArgs

instance.OnDataError(displayErrorDialogIfNoHandler, e)
C#
protected virtual void OnDataError(
   bool displayErrorDialogIfNoHandler,
   DataGridViewDataErrorEventArgs e
)
Managed Extensions for C++
protected: virtual void OnDataError(
   bool displayErrorDialogIfNoHandler,
   DataGridViewDataErrorEventArgs* e
)
C++/CLI
protected:
virtual void OnDataError(
   bool displayErrorDialogIfNoHandler,
   DataGridViewDataErrorEventArgs^ e
)

Parameters

displayErrorDialogIfNoHandler
true to display an error dialog box if there is no handler for the DataError event.
e
A DataGridViewDataErrorEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnDataMemberChanged Method

[image]
Gizmox.WebGUI.Forms
OnDataMemberChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnDataMemberChanged Method

e
An EventArgs that contains the event data.
Raises the DataMemberChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnDataMemberChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As EventArgs

instance.OnDataMemberChanged(e)
C#
protected virtual void OnDataMemberChanged(
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnDataMemberChanged(
   EventArgs* e
)
C++/CLI
protected:
virtual void OnDataMemberChanged(
   EventArgs^ e
)

Parameters

e
An EventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnDataSourceChanged Method

[image]
Gizmox.WebGUI.Forms
OnDataSourceChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnDataSourceChanged Method

e
An EventArgs that contains the event data.
Raises the DataSourceChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnDataSourceChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As EventArgs

instance.OnDataSourceChanged(e)
C#
protected virtual void OnDataSourceChanged(
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnDataSourceChanged(
   EventArgs* e
)
C++/CLI
protected:
virtual void OnDataSourceChanged(
   EventArgs^ e
)

Parameters

e
An EventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnDefaultCellStyleChanged Method

[image]
Gizmox.WebGUI.Forms
OnDefaultCellStyleChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnDefaultCellStyleChanged Method

e
An EventArgs that contains the event data.
Raises the DefaultCellStyleChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnDefaultCellStyleChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As EventArgs

instance.OnDefaultCellStyleChanged(e)
C#
protected virtual void OnDefaultCellStyleChanged(
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnDefaultCellStyleChanged(
   EventArgs* e
)
C++/CLI
protected:
virtual void OnDefaultCellStyleChanged(
   EventArgs^ e
)

Parameters

e
An EventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnDefaultValuesNeeded Method

[image]
Gizmox.WebGUI.Forms
OnDefaultValuesNeeded Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnDefaultValuesNeeded Method

e
A DataGridViewRowEventArgs that contains the event data.
Raises the DefaultValuesNeeded event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnDefaultValuesNeeded( _
   ByVal e As DataGridViewRowEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As DataGridViewRowEventArgs

instance.OnDefaultValuesNeeded(e)
C#
protected virtual void OnDefaultValuesNeeded(
   DataGridViewRowEventArgs e
)
Managed Extensions for C++
protected: virtual void OnDefaultValuesNeeded(
   DataGridViewRowEventArgs* e
)
C++/CLI
protected:
virtual void OnDefaultValuesNeeded(
   DataGridViewRowEventArgs^ e
)

Parameters

e
A DataGridViewRowEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnDoubleClick Method

[image]
Gizmox.WebGUI.Forms
OnDoubleClick Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnDoubleClick Method

e
An EventArgs that contains the event data.
Raises the Control.DoubleClick event.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnDoubleClick( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As EventArgs

instance.OnDoubleClick(e)
C#
protected override void OnDoubleClick(
   EventArgs e
)
Managed Extensions for C++
protected: void OnDoubleClick(
   EventArgs* e
) override
C++/CLI
protected:
void OnDoubleClick(
   EventArgs^ e
) override

Parameters

e
An EventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnEditingControlShowing Method

[image]
Gizmox.WebGUI.Forms
OnEditingControlShowing Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnEditingControlShowing Method

e
A DataGridViewEditingControlShowingEventArgs that contains information about the editing control.
Raises the EditingControlShowing event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnEditingControlShowing( _
   ByVal e As DataGridViewEditingControlShowingEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As DataGridViewEditingControlShowingEventArgs

instance.OnEditingControlShowing(e)
C#
protected virtual void OnEditingControlShowing(
   DataGridViewEditingControlShowingEventArgs e
)
Managed Extensions for C++
protected: virtual void OnEditingControlShowing(
   DataGridViewEditingControlShowingEventArgs* e
)
C++/CLI
protected:
virtual void OnEditingControlShowing(
   DataGridViewEditingControlShowingEventArgs^ e
)

Parameters

e
A DataGridViewEditingControlShowingEventArgs that contains information about the editing control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnEditModeChanged Method

[image]
Gizmox.WebGUI.Forms
OnEditModeChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnEditModeChanged Method

e
An EventArgs that contains the event data.
Raises the EditModeChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnEditModeChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As EventArgs

instance.OnEditModeChanged(e)
C#
protected virtual void OnEditModeChanged(
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnEditModeChanged(
   EventArgs* e
)
C++/CLI
protected:
virtual void OnEditModeChanged(
   EventArgs^ e
)

Parameters

e
An EventArgs that contains the event data.

Exceptions

Exception | Description
InvalidCastException | When entering edit mode, the DataGridViewCell.EditType property of the current cell does not indicate a class that derives from Control and implements IDataGridViewEditingControl.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnEnabledChanged Method

[image]
Gizmox.WebGUI.Forms
OnEnabledChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnEnabledChanged Method

e

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnEnabledChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As EventArgs

instance.OnEnabledChanged(e)
C#
protected override void OnEnabledChanged(
   EventArgs e
)
Managed Extensions for C++
protected: void OnEnabledChanged(
   EventArgs* e
) override
C++/CLI
protected:
void OnEnabledChanged(
   EventArgs^ e
) override

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnEnter Method

[image]
Gizmox.WebGUI.Forms
OnEnter Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnEnter Method

e

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnEnter( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As EventArgs

instance.OnEnter(e)
C#
protected override void OnEnter(
   EventArgs e
)
Managed Extensions for C++
protected: void OnEnter(
   EventArgs* e
) override
C++/CLI
protected:
void OnEnter(
   EventArgs^ e
) override

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnFontChanged Method

[image]
Gizmox.WebGUI.Forms
OnFontChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnFontChanged Method

e
An EventArgs that contains the event data.
Raises the DataGridView.FontChanged event.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnFontChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As EventArgs

instance.OnFontChanged(e)
C#
protected override void OnFontChanged(
   EventArgs e
)
Managed Extensions for C++
protected: void OnFontChanged(
   EventArgs* e
) override
C++/CLI
protected:
void OnFontChanged(
   EventArgs^ e
) override

Parameters

e
An EventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnForeColorChanged Method

[image]
Gizmox.WebGUI.Forms
OnForeColorChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnForeColorChanged Method

e
An EventArgs that contains the event data.
Raises the Control.ForeColorChanged event.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnForeColorChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As EventArgs

instance.OnForeColorChanged(e)
C#
protected override void OnForeColorChanged(
   EventArgs e
)
Managed Extensions for C++
protected: void OnForeColorChanged(
   EventArgs* e
) override
C++/CLI
protected:
void OnForeColorChanged(
   EventArgs^ e
) override

Parameters

e
An EventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnGotFocus Method

[image]
Gizmox.WebGUI.Forms
OnGotFocus Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnGotFocus Method

e

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnGotFocus( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As EventArgs

instance.OnGotFocus(e)
C#
protected override void OnGotFocus(
   EventArgs e
)
Managed Extensions for C++
protected: void OnGotFocus(
   EventArgs* e
) override
C++/CLI
protected:
void OnGotFocus(
   EventArgs^ e
) override

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnGridColorChanged Method

[image]
Gizmox.WebGUI.Forms
OnGridColorChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnGridColorChanged Method

e
An EventArgs that contains the event data.
Raises the GridColorChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnGridColorChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As EventArgs

instance.OnGridColorChanged(e)
C#
protected virtual void OnGridColorChanged(
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnGridColorChanged(
   EventArgs* e
)
C++/CLI
protected:
virtual void OnGridColorChanged(
   EventArgs^ e
)

Parameters

e
An EventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnKeyDown Method

[image]
Gizmox.WebGUI.Forms
OnKeyDown Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnKeyDown Method

e
A KeyEventArgs that contains the event data.
Raises the Control.KeyDown event.

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overrides Sub OnKeyDown( _
   ByVal e As KeyEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As KeyEventArgs

instance.OnKeyDown(e)
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected override void OnKeyDown(
   KeyEventArgs e
)
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: void OnKeyDown(
   KeyEventArgs* e
) override
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
void OnKeyDown(
   KeyEventArgs^ e
) override

Parameters

e
A KeyEventArgs that contains the event data.

Exceptions

Exception | Description
Exception | This action would cause the control to enter edit mode but initialization of the editing cell value failed and either there is no handler for the DataError event or the handler has set the DataGridViewDataErrorEventArgs.ThrowException property to true. The exception object can typically be cast to type FormatException.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnKeyUp Method

[image]
Gizmox.WebGUI.Forms
OnKeyUp Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnKeyUp Method

e
A KeyEventArgs that contains the event data.
Raises the Control.KeyUp event.

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overrides Sub OnKeyUp( _
   ByVal e As KeyEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As KeyEventArgs

instance.OnKeyUp(e)
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected override void OnKeyUp(
   KeyEventArgs e
)
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: void OnKeyUp(
   KeyEventArgs* e
) override
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
void OnKeyUp(
   KeyEventArgs^ e
) override

Parameters

e
A KeyEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnLostFocus Method

[image]
Gizmox.WebGUI.Forms
OnLostFocus Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnLostFocus Method

e

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnLostFocus( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As EventArgs

instance.OnLostFocus(e)
C#
protected override void OnLostFocus(
   EventArgs e
)
Managed Extensions for C++
protected: void OnLostFocus(
   EventArgs* e
) override
C++/CLI
protected:
void OnLostFocus(
   EventArgs^ e
) override

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnMouseClick Method

[image]
Gizmox.WebGUI.Forms
OnMouseClick Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnMouseClick Method

e
A MouseEventArgs that contains the event data.
Raises the MouseClick event.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnMouseClick( _
   ByVal e As MouseEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As MouseEventArgs

instance.OnMouseClick(e)
C#
protected override void OnMouseClick(
   MouseEventArgs e
)
Managed Extensions for C++
protected: void OnMouseClick(
   MouseEventArgs* e
) override
C++/CLI
protected:
void OnMouseClick(
   MouseEventArgs^ e
) override

Parameters

e
A MouseEventArgs that contains the event data.

Exceptions

Exception | Description
Exception | The control is configured to enter edit mode when it receives focus, but initialization of the editing cell value failed and either there is no handler for the DataError event or the handler has set the DataGridViewDataErrorEventArgs.ThrowException property to true. The exception object can typically be cast to type FormatException.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnMouseDoubleClick Method

[image]
Gizmox.WebGUI.Forms
OnMouseDoubleClick Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnMouseDoubleClick Method

e

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnMouseDoubleClick( _
   ByVal e As MouseEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As MouseEventArgs

instance.OnMouseDoubleClick(e)
C#
protected override void OnMouseDoubleClick(
   MouseEventArgs e
)
Managed Extensions for C++
protected: void OnMouseDoubleClick(
   MouseEventArgs* e
) override
C++/CLI
protected:
void OnMouseDoubleClick(
   MouseEventArgs^ e
) override

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnMouseDown Method

[image]
Gizmox.WebGUI.Forms
OnMouseDown Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnMouseDown Method

e
A MouseEventArgs that contains the event data.
Raises the Control.MouseDown event.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnMouseDown( _
   ByVal e As MouseEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As MouseEventArgs

instance.OnMouseDown(e)
C#
protected override void OnMouseDown(
   MouseEventArgs e
)
Managed Extensions for C++
protected: void OnMouseDown(
   MouseEventArgs* e
) override
C++/CLI
protected:
void OnMouseDown(
   MouseEventArgs^ e
) override

Parameters

e
A MouseEventArgs that contains the event data.

Exceptions

Exception | Description
Exception | The control is configured to enter edit mode when it receives focus, but initialization of the editing cell value failed and either there is no handler for the DataError event or the handler has set the DataGridViewDataErrorEventArgs.ThrowException property to true. The exception object can typically be cast to type FormatException.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnMouseUp Method

[image]
Gizmox.WebGUI.Forms
OnMouseUp Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnMouseUp Method

e
A MouseEventArgs that contains the event data.
Raises the Control.MouseUp event.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnMouseUp( _
   ByVal e As MouseEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As MouseEventArgs

instance.OnMouseUp(e)
C#
protected override void OnMouseUp(
   MouseEventArgs e
)
Managed Extensions for C++
protected: void OnMouseUp(
   MouseEventArgs* e
) override
C++/CLI
protected:
void OnMouseUp(
   MouseEventArgs^ e
) override

Parameters

e
A MouseEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnMultiSelectChanged Method

[image]
Gizmox.WebGUI.Forms
OnMultiSelectChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnMultiSelectChanged Method

e
An EventArgs that contains the event data.
Raises the MultiSelectChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnMultiSelectChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As EventArgs

instance.OnMultiSelectChanged(e)
C#
protected virtual void OnMultiSelectChanged(
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnMultiSelectChanged(
   EventArgs* e
)
C++/CLI
protected:
virtual void OnMultiSelectChanged(
   EventArgs^ e
)

Parameters

e
An EventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnNewRowNeeded Method

[image]
Gizmox.WebGUI.Forms
OnNewRowNeeded Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnNewRowNeeded Method

e
A DataGridViewRowEventArgs that contains the event data.
Raises the NewRowNeeded event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnNewRowNeeded( _
   ByVal e As DataGridViewRowEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As DataGridViewRowEventArgs

instance.OnNewRowNeeded(e)
C#
protected virtual void OnNewRowNeeded(
   DataGridViewRowEventArgs e
)
Managed Extensions for C++
protected: virtual void OnNewRowNeeded(
   DataGridViewRowEventArgs* e
)
C++/CLI
protected:
virtual void OnNewRowNeeded(
   DataGridViewRowEventArgs^ e
)

Parameters

e
A DataGridViewRowEventArgs that contains the event data.

Exceptions

Exception | Description
ArgumentException | The row indicated by the DataGridViewRowEventArgs.Row property of e does not belong to this DataGridView control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnReadOnlyChanged Method

[image]
Gizmox.WebGUI.Forms
OnReadOnlyChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnReadOnlyChanged Method

e
An EventArgs that contains the event data.
Raises the ReadOnlyChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnReadOnlyChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As EventArgs

instance.OnReadOnlyChanged(e)
C#
protected virtual void OnReadOnlyChanged(
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnReadOnlyChanged(
   EventArgs* e
)
C++/CLI
protected:
virtual void OnReadOnlyChanged(
   EventArgs^ e
)

Parameters

e
An EventArgs that contains the event data.

Exceptions

Exception | Description
InvalidCastException | The control changed from read-only to read/write, enabling the current cell to enter edit mode, but the DataGridViewCell.EditType property of the current cell does not indicate a class that derives from Control and implements IDataGridViewEditingControl.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnResize Method

[image]
Gizmox.WebGUI.Forms
OnResize Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnResize Method

e
An EventArgs that contains the event data.
Raises the Control.Resize event.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnResize( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As EventArgs

instance.OnResize(e)
C#
protected override void OnResize(
   EventArgs e
)
Managed Extensions for C++
protected: void OnResize(
   EventArgs* e
) override
C++/CLI
protected:
void OnResize(
   EventArgs^ e
) override

Parameters

e
An EventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnRowContextMenuStripChanged Method

[image]
Gizmox.WebGUI.Forms
OnRowContextMenuStripChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnRowContextMenuStripChanged Method

e
A DataGridViewRowEventArgs that contains the event data.
Raises the RowContextMenuStripChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnRowContextMenuStripChanged( _
   ByVal e As DataGridViewRowEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As DataGridViewRowEventArgs

instance.OnRowContextMenuStripChanged(e)
C#
protected virtual void OnRowContextMenuStripChanged(
   DataGridViewRowEventArgs e
)
Managed Extensions for C++
protected: virtual void OnRowContextMenuStripChanged(
   DataGridViewRowEventArgs* e
)
C++/CLI
protected:
virtual void OnRowContextMenuStripChanged(
   DataGridViewRowEventArgs^ e
)

Parameters

e
A DataGridViewRowEventArgs that contains the event data.

Exceptions

Exception | Description
ArgumentException | The row indicated by the DataGridViewRowEventArgs.Row property of e does not belong to this DataGridView control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnRowContextMenuStripNeeded Method

[image]
Gizmox.WebGUI.Forms
OnRowContextMenuStripNeeded Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnRowContextMenuStripNeeded Method

e
A DataGridViewRowContextMenuStripNeededEventArgs that contains the event data.
Raises the RowContextMenuStripNeeded event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnRowContextMenuStripNeeded( _
   ByVal e As DataGridViewRowContextMenuStripNeededEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As DataGridViewRowContextMenuStripNeededEventArgs

instance.OnRowContextMenuStripNeeded(e)
C#
protected virtual void OnRowContextMenuStripNeeded(
   DataGridViewRowContextMenuStripNeededEventArgs e
)
Managed Extensions for C++
protected: virtual void OnRowContextMenuStripNeeded(
   DataGridViewRowContextMenuStripNeededEventArgs* e
)
C++/CLI
protected:
virtual void OnRowContextMenuStripNeeded(
   DataGridViewRowContextMenuStripNeededEventArgs^ e
)

Parameters

e
A DataGridViewRowContextMenuStripNeededEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnRowDefaultCellStyleChanged Method

[image]
Gizmox.WebGUI.Forms
OnRowDefaultCellStyleChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnRowDefaultCellStyleChanged Method

e
A DataGridViewRowEventArgs that contains the event data.
Raises the RowDefaultCellStyleChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnRowDefaultCellStyleChanged( _
   ByVal e As DataGridViewRowEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As DataGridViewRowEventArgs

instance.OnRowDefaultCellStyleChanged(e)
C#
protected virtual void OnRowDefaultCellStyleChanged(
   DataGridViewRowEventArgs e
)
Managed Extensions for C++
protected: virtual void OnRowDefaultCellStyleChanged(
   DataGridViewRowEventArgs* e
)
C++/CLI
protected:
virtual void OnRowDefaultCellStyleChanged(
   DataGridViewRowEventArgs^ e
)

Parameters

e
A DataGridViewRowEventArgs that contains the event data.

Exceptions

Exception | Description
ArgumentException | The row indicated by the DataGridViewRowEventArgs.Row property of e does not belong to this DataGridView control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnRowDirtyStateNeeded Method

[image]
Gizmox.WebGUI.Forms
OnRowDirtyStateNeeded Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnRowDirtyStateNeeded Method

e
A QuestionEventArgs that contains the event data.
Raises the RowDirtyStateNeeded event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnRowDirtyStateNeeded( _
   ByVal e As QuestionEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As QuestionEventArgs

instance.OnRowDirtyStateNeeded(e)
C#
protected virtual void OnRowDirtyStateNeeded(
   QuestionEventArgs e
)
Managed Extensions for C++
protected: virtual void OnRowDirtyStateNeeded(
   QuestionEventArgs* e
)
C++/CLI
protected:
virtual void OnRowDirtyStateNeeded(
   QuestionEventArgs^ e
)

Parameters

e
A QuestionEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnRowDividerDoubleClick Method

[image]
Gizmox.WebGUI.Forms
OnRowDividerDoubleClick Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnRowDividerDoubleClick Method

e
A DataGridViewRowDividerDoubleClickEventArgs that contains the event data.
Raises the RowDividerDoubleClick event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnRowDividerDoubleClick( _
   ByVal e As DataGridViewRowDividerDoubleClickEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As DataGridViewRowDividerDoubleClickEventArgs

instance.OnRowDividerDoubleClick(e)
C#
protected virtual void OnRowDividerDoubleClick(
   DataGridViewRowDividerDoubleClickEventArgs e
)
Managed Extensions for C++
protected: virtual void OnRowDividerDoubleClick(
   DataGridViewRowDividerDoubleClickEventArgs* e
)
C++/CLI
protected:
virtual void OnRowDividerDoubleClick(
   DataGridViewRowDividerDoubleClickEventArgs^ e
)

Parameters

e
A DataGridViewRowDividerDoubleClickEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnRowDividerHeightChanged Method

[image]
Gizmox.WebGUI.Forms
OnRowDividerHeightChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnRowDividerHeightChanged Method

e
A DataGridViewRowEventArgs that contains the event data.
Raises the RowDividerHeightChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnRowDividerHeightChanged( _
   ByVal e As DataGridViewRowEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As DataGridViewRowEventArgs

instance.OnRowDividerHeightChanged(e)
C#
protected virtual void OnRowDividerHeightChanged(
   DataGridViewRowEventArgs e
)
Managed Extensions for C++
protected: virtual void OnRowDividerHeightChanged(
   DataGridViewRowEventArgs* e
)
C++/CLI
protected:
virtual void OnRowDividerHeightChanged(
   DataGridViewRowEventArgs^ e
)

Parameters

e
A DataGridViewRowEventArgs that contains the event data.

Exceptions

Exception | Description
ArgumentException | The row indicated by the DataGridViewRowEventArgs.Row property of e does not belong to this DataGridView control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnRowEnter Method

[image]
Gizmox.WebGUI.Forms
OnRowEnter Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnRowEnter Method

e
A DataGridViewCellEventArgs that contains the event data.
Raises the RowEnter event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnRowEnter( _
   ByVal e As DataGridViewCellEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As DataGridViewCellEventArgs

instance.OnRowEnter(e)
C#
protected virtual void OnRowEnter(
   DataGridViewCellEventArgs e
)
Managed Extensions for C++
protected: virtual void OnRowEnter(
   DataGridViewCellEventArgs* e
)
C++/CLI
protected:
virtual void OnRowEnter(
   DataGridViewCellEventArgs^ e
)

Parameters

e
A DataGridViewCellEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnRowErrorTextChanged Method

[image]
Gizmox.WebGUI.Forms
OnRowErrorTextChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnRowErrorTextChanged Method

e
A DataGridViewRowEventArgs that contains the event data.
Raises the RowErrorTextChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnRowErrorTextChanged( _
   ByVal e As DataGridViewRowEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As DataGridViewRowEventArgs

instance.OnRowErrorTextChanged(e)
C#
protected virtual void OnRowErrorTextChanged(
   DataGridViewRowEventArgs e
)
Managed Extensions for C++
protected: virtual void OnRowErrorTextChanged(
   DataGridViewRowEventArgs* e
)
C++/CLI
protected:
virtual void OnRowErrorTextChanged(
   DataGridViewRowEventArgs^ e
)

Parameters

e
A DataGridViewRowEventArgs that contains the event data.

Exceptions

Exception | Description
ArgumentException | The row indicated by the DataGridViewRowEventArgs.Row property of e does not belong to this DataGridView control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnRowErrorTextNeeded Method

[image]
Gizmox.WebGUI.Forms
OnRowErrorTextNeeded Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnRowErrorTextNeeded Method

e
A DataGridViewRowErrorTextNeededEventArgs that contains the event data.
Raises the RowErrorTextNeeded event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnRowErrorTextNeeded( _
   ByVal e As DataGridViewRowErrorTextNeededEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As DataGridViewRowErrorTextNeededEventArgs

instance.OnRowErrorTextNeeded(e)
C#
protected virtual void OnRowErrorTextNeeded(
   DataGridViewRowErrorTextNeededEventArgs e
)
Managed Extensions for C++
protected: virtual void OnRowErrorTextNeeded(
   DataGridViewRowErrorTextNeededEventArgs* e
)
C++/CLI
protected:
virtual void OnRowErrorTextNeeded(
   DataGridViewRowErrorTextNeededEventArgs^ e
)

Parameters

e
A DataGridViewRowErrorTextNeededEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnRowHeaderCellChanged Method

[image]
Gizmox.WebGUI.Forms
OnRowHeaderCellChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnRowHeaderCellChanged Method

e
A DataGridViewRowEventArgs that contains the event data.
Raises the RowHeaderCellChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnRowHeaderCellChanged( _
   ByVal e As DataGridViewRowEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As DataGridViewRowEventArgs

instance.OnRowHeaderCellChanged(e)
C#
protected virtual void OnRowHeaderCellChanged(
   DataGridViewRowEventArgs e
)
Managed Extensions for C++
protected: virtual void OnRowHeaderCellChanged(
   DataGridViewRowEventArgs* e
)
C++/CLI
protected:
virtual void OnRowHeaderCellChanged(
   DataGridViewRowEventArgs^ e
)

Parameters

e
A DataGridViewRowEventArgs that contains the event data.

Exceptions

Exception | Description
ArgumentException | The row indicated by the DataGridViewRowEventArgs.Row property of e does not belong to this DataGridView control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnRowHeaderMouseClick Method

[image]
Gizmox.WebGUI.Forms
OnRowHeaderMouseClick Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnRowHeaderMouseClick Method

e
A DataGridViewCellMouseEventArgs that contains information about the mouse and the header cell that was clicked.
Raises the RowHeaderMouseClick event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnRowHeaderMouseClick( _
   ByVal e As DataGridViewCellMouseEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As DataGridViewCellMouseEventArgs

instance.OnRowHeaderMouseClick(e)
C#
protected virtual void OnRowHeaderMouseClick(
   DataGridViewCellMouseEventArgs e
)
Managed Extensions for C++
protected: virtual void OnRowHeaderMouseClick(
   DataGridViewCellMouseEventArgs* e
)
C++/CLI
protected:
virtual void OnRowHeaderMouseClick(
   DataGridViewCellMouseEventArgs^ e
)

Parameters

e
A DataGridViewCellMouseEventArgs that contains information about the mouse and the header cell that was clicked.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnRowHeaderMouseDoubleClick Method

[image]
Gizmox.WebGUI.Forms
OnRowHeaderMouseDoubleClick Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnRowHeaderMouseDoubleClick Method

e
A DataGridViewCellMouseEventArgs that contains information about the mouse and the header cell that was double-clicked.
Raises the RowHeaderMouseDoubleClick event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnRowHeaderMouseDoubleClick( _
   ByVal e As DataGridViewCellMouseEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As DataGridViewCellMouseEventArgs

instance.OnRowHeaderMouseDoubleClick(e)
C#
protected virtual void OnRowHeaderMouseDoubleClick(
   DataGridViewCellMouseEventArgs e
)
Managed Extensions for C++
protected: virtual void OnRowHeaderMouseDoubleClick(
   DataGridViewCellMouseEventArgs* e
)
C++/CLI
protected:
virtual void OnRowHeaderMouseDoubleClick(
   DataGridViewCellMouseEventArgs^ e
)

Parameters

e
A DataGridViewCellMouseEventArgs that contains information about the mouse and the header cell that was double-clicked.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnRowHeadersBorderStyleChanged Method

[image]
Gizmox.WebGUI.Forms
OnRowHeadersBorderStyleChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnRowHeadersBorderStyleChanged Method

e
An EventArgs that contains the event data.
Raises the RowHeadersBorderStyleChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnRowHeadersBorderStyleChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As EventArgs

instance.OnRowHeadersBorderStyleChanged(e)
C#
protected virtual void OnRowHeadersBorderStyleChanged(
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnRowHeadersBorderStyleChanged(
   EventArgs* e
)
C++/CLI
protected:
virtual void OnRowHeadersBorderStyleChanged(
   EventArgs^ e
)

Parameters

e
An EventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnRowHeadersDefaultCellStyleChanged Method

[image]
Gizmox.WebGUI.Forms
OnRowHeadersDefaultCellStyleChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnRowHeadersDefaultCellStyleChanged Method

e
An EventArgs that contains the event data.
Raises the RowHeadersDefaultCellStyleChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnRowHeadersDefaultCellStyleChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As EventArgs

instance.OnRowHeadersDefaultCellStyleChanged(e)
C#
protected virtual void OnRowHeadersDefaultCellStyleChanged(
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnRowHeadersDefaultCellStyleChanged(
   EventArgs* e
)
C++/CLI
protected:
virtual void OnRowHeadersDefaultCellStyleChanged(
   EventArgs^ e
)

Parameters

e
An EventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnRowHeadersWidthChanged Method

[image]
Gizmox.WebGUI.Forms
OnRowHeadersWidthChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnRowHeadersWidthChanged Method

e
An EventArgs that contains the event data.
Raises the RowHeadersWidthChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnRowHeadersWidthChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As EventArgs

instance.OnRowHeadersWidthChanged(e)
C#
protected virtual void OnRowHeadersWidthChanged(
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnRowHeadersWidthChanged(
   EventArgs* e
)
C++/CLI
protected:
virtual void OnRowHeadersWidthChanged(
   EventArgs^ e
)

Parameters

e
An EventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnRowHeadersWidthSizeModeChanged Method

[image]
Gizmox.WebGUI.Forms
OnRowHeadersWidthSizeModeChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnRowHeadersWidthSizeModeChanged Method

e
A DataGridViewAutoSizeModeEventArgs that contains the event data.
Raises the RowHeadersWidthSizeModeChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnRowHeadersWidthSizeModeChanged( _
   ByVal e As DataGridViewAutoSizeModeEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As DataGridViewAutoSizeModeEventArgs

instance.OnRowHeadersWidthSizeModeChanged(e)
C#
protected virtual void OnRowHeadersWidthSizeModeChanged(
   DataGridViewAutoSizeModeEventArgs e
)
Managed Extensions for C++
protected: virtual void OnRowHeadersWidthSizeModeChanged(
   DataGridViewAutoSizeModeEventArgs* e
)
C++/CLI
protected:
virtual void OnRowHeadersWidthSizeModeChanged(
   DataGridViewAutoSizeModeEventArgs^ e
)

Parameters

e
A DataGridViewAutoSizeModeEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnRowHeightChanged Method

[image]
Gizmox.WebGUI.Forms
OnRowHeightChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnRowHeightChanged Method

e
A DataGridViewRowEventArgs that contains the event data.
Raises the RowHeightChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnRowHeightChanged( _
   ByVal e As DataGridViewRowEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As DataGridViewRowEventArgs

instance.OnRowHeightChanged(e)
C#
protected virtual void OnRowHeightChanged(
   DataGridViewRowEventArgs e
)
Managed Extensions for C++
protected: virtual void OnRowHeightChanged(
   DataGridViewRowEventArgs* e
)
C++/CLI
protected:
virtual void OnRowHeightChanged(
   DataGridViewRowEventArgs^ e
)

Parameters

e
A DataGridViewRowEventArgs that contains the event data.

Exceptions

Exception | Description
ArgumentException | The row indicated by the DataGridViewRowEventArgs.Row property of e does not belong to this DataGridView control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnRowHeightInfoNeeded Method

[image]
Gizmox.WebGUI.Forms
OnRowHeightInfoNeeded Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnRowHeightInfoNeeded Method

e
A DataGridViewRowHeightInfoNeededEventArgs that contains the event data.
Raises the RowHeightInfoNeeded event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnRowHeightInfoNeeded( _
   ByVal e As DataGridViewRowHeightInfoNeededEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As DataGridViewRowHeightInfoNeededEventArgs

instance.OnRowHeightInfoNeeded(e)
C#
protected virtual void OnRowHeightInfoNeeded(
   DataGridViewRowHeightInfoNeededEventArgs e
)
Managed Extensions for C++
protected: virtual void OnRowHeightInfoNeeded(
   DataGridViewRowHeightInfoNeededEventArgs* e
)
C++/CLI
protected:
virtual void OnRowHeightInfoNeeded(
   DataGridViewRowHeightInfoNeededEventArgs^ e
)

Parameters

e
A DataGridViewRowHeightInfoNeededEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnRowHeightInfoPushed Method

[image]
Gizmox.WebGUI.Forms
OnRowHeightInfoPushed Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnRowHeightInfoPushed Method

e
A DataGridViewRowHeightInfoPushedEventArgs that contains the event data.
Raises the RowHeightInfoPushed event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnRowHeightInfoPushed( _
   ByVal e As DataGridViewRowHeightInfoPushedEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As DataGridViewRowHeightInfoPushedEventArgs

instance.OnRowHeightInfoPushed(e)
C#
protected virtual void OnRowHeightInfoPushed(
   DataGridViewRowHeightInfoPushedEventArgs e
)
Managed Extensions for C++
protected: virtual void OnRowHeightInfoPushed(
   DataGridViewRowHeightInfoPushedEventArgs* e
)
C++/CLI
protected:
virtual void OnRowHeightInfoPushed(
   DataGridViewRowHeightInfoPushedEventArgs^ e
)

Parameters

e
A DataGridViewRowHeightInfoPushedEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnRowLeave Method

[image]
Gizmox.WebGUI.Forms
OnRowLeave Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnRowLeave Method

e
A DataGridViewCellEventArgs that contains the event data.
Raises the RowLeave event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnRowLeave( _
   ByVal e As DataGridViewCellEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As DataGridViewCellEventArgs

instance.OnRowLeave(e)
C#
protected virtual void OnRowLeave(
   DataGridViewCellEventArgs e
)
Managed Extensions for C++
protected: virtual void OnRowLeave(
   DataGridViewCellEventArgs* e
)
C++/CLI
protected:
virtual void OnRowLeave(
   DataGridViewCellEventArgs^ e
)

Parameters

e
A DataGridViewCellEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnRowMinimumHeightChanged Method

[image]
Gizmox.WebGUI.Forms
OnRowMinimumHeightChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnRowMinimumHeightChanged Method

e
A DataGridViewRowEventArgs that contains the event data.
Raises the RowMinimumHeightChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnRowMinimumHeightChanged( _
   ByVal e As DataGridViewRowEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As DataGridViewRowEventArgs

instance.OnRowMinimumHeightChanged(e)
C#
protected virtual void OnRowMinimumHeightChanged(
   DataGridViewRowEventArgs e
)
Managed Extensions for C++
protected: virtual void OnRowMinimumHeightChanged(
   DataGridViewRowEventArgs* e
)
C++/CLI
protected:
virtual void OnRowMinimumHeightChanged(
   DataGridViewRowEventArgs^ e
)

Parameters

e
A DataGridViewRowEventArgs that contains the event data.

Exceptions

Exception | Description
ArgumentException | The row indicated by the DataGridViewRowEventArgs.Row property of e does not belong to this DataGridView control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnRowsAdded Method

[image]
Gizmox.WebGUI.Forms
OnRowsAdded Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnRowsAdded Method

e
A DataGridViewRowsAddedEventArgs that contains information about the added rows.
Raises the RowsAdded event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnRowsAdded( _
   ByVal e As DataGridViewRowsAddedEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As DataGridViewRowsAddedEventArgs

instance.OnRowsAdded(e)
C#
protected virtual void OnRowsAdded(
   DataGridViewRowsAddedEventArgs e
)
Managed Extensions for C++
protected: virtual void OnRowsAdded(
   DataGridViewRowsAddedEventArgs* e
)
C++/CLI
protected:
virtual void OnRowsAdded(
   DataGridViewRowsAddedEventArgs^ e
)

Parameters

e
A DataGridViewRowsAddedEventArgs that contains information about the added rows.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnRowsDefaultCellStyleChanged Method

[image]
Gizmox.WebGUI.Forms
OnRowsDefaultCellStyleChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnRowsDefaultCellStyleChanged Method

e
An EventArgs that contains the event data.
Raises the RowsDefaultCellStyleChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnRowsDefaultCellStyleChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As EventArgs

instance.OnRowsDefaultCellStyleChanged(e)
C#
protected virtual void OnRowsDefaultCellStyleChanged(
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnRowsDefaultCellStyleChanged(
   EventArgs* e
)
C++/CLI
protected:
virtual void OnRowsDefaultCellStyleChanged(
   EventArgs^ e
)

Parameters

e
An EventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnRowsRemoved Method

[image]
Gizmox.WebGUI.Forms
OnRowsRemoved Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnRowsRemoved Method

e
A DataGridViewRowsRemovedEventArgs that contains information about the deleted rows.
Raises the RowsRemoved event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnRowsRemoved( _
   ByVal e As DataGridViewRowsRemovedEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As DataGridViewRowsRemovedEventArgs

instance.OnRowsRemoved(e)
C#
protected virtual void OnRowsRemoved(
   DataGridViewRowsRemovedEventArgs e
)
Managed Extensions for C++
protected: virtual void OnRowsRemoved(
   DataGridViewRowsRemovedEventArgs* e
)
C++/CLI
protected:
virtual void OnRowsRemoved(
   DataGridViewRowsRemovedEventArgs^ e
)

Parameters

e
A DataGridViewRowsRemovedEventArgs that contains information about the deleted rows.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnRowStateChanged Method

[image]
Gizmox.WebGUI.Forms
OnRowStateChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnRowStateChanged Method

rowIndex
The index of the row that is changing state.
e
A DataGridViewRowStateChangedEventArgs that contains the event data.
Raises the RowStateChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnRowStateChanged( _
   ByVal rowIndex As Integer, _
   ByVal e As DataGridViewRowStateChangedEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim rowIndex As Integer
Dim e As DataGridViewRowStateChangedEventArgs

instance.OnRowStateChanged(rowIndex, e)
C#
protected virtual void OnRowStateChanged(
   int rowIndex,
   DataGridViewRowStateChangedEventArgs e
)
Managed Extensions for C++
protected: virtual void OnRowStateChanged(
   int rowIndex,
   DataGridViewRowStateChangedEventArgs* e
)
C++/CLI
protected:
virtual void OnRowStateChanged(
   int rowIndex,
   DataGridViewRowStateChangedEventArgs^ e
)

Parameters

rowIndex
The index of the row that is changing state.
e
A DataGridViewRowStateChangedEventArgs that contains the event data.

Exceptions

Exception | Description
InvalidCastException | The row changed from read-only to read/write, enabling the current cell to enter edit mode, but the DataGridViewCell.EditType property of the current cell does not indicate a class that derives from Control and implements IDataGridViewEditingControl.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnRowUnshared Method

[image]
Gizmox.WebGUI.Forms
OnRowUnshared Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnRowUnshared Method

e
A DataGridViewRowEventArgs that contains the event data.
Raises the RowUnshared event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnRowUnshared( _
   ByVal e As DataGridViewRowEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As DataGridViewRowEventArgs

instance.OnRowUnshared(e)
C#
protected virtual void OnRowUnshared(
   DataGridViewRowEventArgs e
)
Managed Extensions for C++
protected: virtual void OnRowUnshared(
   DataGridViewRowEventArgs* e
)
C++/CLI
protected:
virtual void OnRowUnshared(
   DataGridViewRowEventArgs^ e
)

Parameters

e
A DataGridViewRowEventArgs that contains the event data.

Exceptions

Exception | Description
ArgumentException | The row indicated by the DataGridViewRowEventArgs.Row property of e does not belong to this DataGridView control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnRowValidated Method

[image]
Gizmox.WebGUI.Forms
OnRowValidated Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnRowValidated Method

e
A DataGridViewCellEventArgs that contains the event data.
Raises the RowValidated event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnRowValidated( _
   ByVal e As DataGridViewCellEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As DataGridViewCellEventArgs

instance.OnRowValidated(e)
C#
protected virtual void OnRowValidated(
   DataGridViewCellEventArgs e
)
Managed Extensions for C++
protected: virtual void OnRowValidated(
   DataGridViewCellEventArgs* e
)
C++/CLI
protected:
virtual void OnRowValidated(
   DataGridViewCellEventArgs^ e
)

Parameters

e
A DataGridViewCellEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnRowValidating Method

[image]
Gizmox.WebGUI.Forms
OnRowValidating Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnRowValidating Method

e
A DataGridViewCellCancelEventArgs that contains the event data.
Raises the RowValidating event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnRowValidating( _
   ByVal e As DataGridViewCellCancelEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As DataGridViewCellCancelEventArgs

instance.OnRowValidating(e)
C#
protected virtual void OnRowValidating(
   DataGridViewCellCancelEventArgs e
)
Managed Extensions for C++
protected: virtual void OnRowValidating(
   DataGridViewCellCancelEventArgs* e
)
C++/CLI
protected:
virtual void OnRowValidating(
   DataGridViewCellCancelEventArgs^ e
)

Parameters

e
A DataGridViewCellCancelEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnSelectionChanged Method

[image]
Gizmox.WebGUI.Forms
OnSelectionChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnSelectionChanged Method

e
An EventArgs that contains information about the event.
Raises the SelectionChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnSelectionChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As EventArgs

instance.OnSelectionChanged(e)
C#
protected virtual void OnSelectionChanged(
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnSelectionChanged(
   EventArgs* e
)
C++/CLI
protected:
virtual void OnSelectionChanged(
   EventArgs^ e
)

Parameters

e
An EventArgs that contains information about the event.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnSortCompare Method

[image]
Gizmox.WebGUI.Forms
OnSortCompare Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnSortCompare Method

e
A DataGridViewSortCompareEventArgs that contains the event data.
Raises the SortCompare event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnSortCompare( _
   ByVal e As DataGridViewSortCompareEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As DataGridViewSortCompareEventArgs

instance.OnSortCompare(e)
C#
protected virtual void OnSortCompare(
   DataGridViewSortCompareEventArgs e
)
Managed Extensions for C++
protected: virtual void OnSortCompare(
   DataGridViewSortCompareEventArgs* e
)
C++/CLI
protected:
virtual void OnSortCompare(
   DataGridViewSortCompareEventArgs^ e
)

Parameters

e
A DataGridViewSortCompareEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnSorted Method

[image]
Gizmox.WebGUI.Forms
OnSorted Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnSorted Method

e
An EventArgs that contains the event data.
Raises the Sorted event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnSorted( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As EventArgs

instance.OnSorted(e)
C#
protected virtual void OnSorted(
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnSorted(
   EventArgs* e
)
C++/CLI
protected:
virtual void OnSorted(
   EventArgs^ e
)

Parameters

e
An EventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnUserAddedRow Method

[image]
Gizmox.WebGUI.Forms
OnUserAddedRow Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnUserAddedRow Method

e
A DataGridViewRowEventArgs that contains the event data.
Raises the UserAddedRow event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnUserAddedRow( _
   ByVal e As DataGridViewRowEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As DataGridViewRowEventArgs

instance.OnUserAddedRow(e)
C#
protected virtual void OnUserAddedRow(
   DataGridViewRowEventArgs e
)
Managed Extensions for C++
protected: virtual void OnUserAddedRow(
   DataGridViewRowEventArgs* e
)
C++/CLI
protected:
virtual void OnUserAddedRow(
   DataGridViewRowEventArgs^ e
)

Parameters

e
A DataGridViewRowEventArgs that contains the event data.

Exceptions

Exception | Description
ArgumentException | The row indicated by the DataGridViewRowEventArgs.Row property of e does not belong to this DataGridView control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnUserDeletedRow Method

[image]
Gizmox.WebGUI.Forms
OnUserDeletedRow Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnUserDeletedRow Method

e
A DataGridViewRowEventArgs that contains the event data.
Raises the UserDeletedRow event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnUserDeletedRow( _
   ByVal e As DataGridViewRowEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As DataGridViewRowEventArgs

instance.OnUserDeletedRow(e)
C#
protected virtual void OnUserDeletedRow(
   DataGridViewRowEventArgs e
)
Managed Extensions for C++
protected: virtual void OnUserDeletedRow(
   DataGridViewRowEventArgs* e
)
C++/CLI
protected:
virtual void OnUserDeletedRow(
   DataGridViewRowEventArgs^ e
)

Parameters

e
A DataGridViewRowEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnUserDeletingRow Method

[image]
Gizmox.WebGUI.Forms
OnUserDeletingRow Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnUserDeletingRow Method

e
A DataGridViewRowCancelEventArgs that contains the event data.
Raises the UserDeletingRow event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnUserDeletingRow( _
   ByVal e As DataGridViewRowCancelEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As DataGridViewRowCancelEventArgs

instance.OnUserDeletingRow(e)
C#
protected virtual void OnUserDeletingRow(
   DataGridViewRowCancelEventArgs e
)
Managed Extensions for C++
protected: virtual void OnUserDeletingRow(
   DataGridViewRowCancelEventArgs* e
)
C++/CLI
protected:
virtual void OnUserDeletingRow(
   DataGridViewRowCancelEventArgs^ e
)

Parameters

e
A DataGridViewRowCancelEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnValidating Method

[image]
Gizmox.WebGUI.Forms
OnValidating Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnValidating Method

e
A CancelEventArgs that contains the event data.
Raises the Validating event.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnValidating( _
   ByVal e As CancelEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As CancelEventArgs

instance.OnValidating(e)
C#
protected override void OnValidating(
   CancelEventArgs e
)
Managed Extensions for C++
protected: void OnValidating(
   CancelEventArgs* e
) override
C++/CLI
protected:
void OnValidating(
   CancelEventArgs^ e
) override

Parameters

e
A CancelEventArgs that contains the event data.

Exceptions

Exception | Description
Exception | Validation failed and either there is no handler for the DataError event or the handler has set the DataGridViewDataErrorEventArgs.ThrowException property to true. The exception object can typically be cast to type FormatException.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


OnVisibleChanged Method

[image]
Gizmox.WebGUI.Forms
OnVisibleChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : OnVisibleChanged Method

e

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnVisibleChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As EventArgs

instance.OnVisibleChanged(e)
C#
protected override void OnVisibleChanged(
   EventArgs e
)
Managed Extensions for C++
protected: void OnVisibleChanged(
   EventArgs* e
) override
C++/CLI
protected:
void OnVisibleChanged(
   EventArgs^ e
) override

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


PaintBackground Method

[image]
Gizmox.WebGUI.Forms
PaintBackground Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : PaintBackground Method

graphics
The Graphics used to paint the background.
clipBounds
A Rectangle that represents the area of the DataGridView that needs to be painted.
gridBounds
A Rectangle that represents the area in which cells are drawn.
Paints the background of the DataGridView.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub PaintBackground( _
   ByVal graphics As Graphics, _
   ByVal clipBounds As Rectangle, _
   ByVal gridBounds As Rectangle _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim graphics As Graphics
Dim clipBounds As Rectangle
Dim gridBounds As Rectangle

instance.PaintBackground(graphics, clipBounds, gridBounds)
C#
protected virtual void PaintBackground(
   Graphics graphics,
   Rectangle clipBounds,
   Rectangle gridBounds
)
Managed Extensions for C++
protected: virtual void PaintBackground(
   Graphics* graphics,
   Rectangle clipBounds,
   Rectangle gridBounds
)
C++/CLI
protected:
virtual void PaintBackground(
   Graphics^ graphics,
   Rectangle clipBounds,
   Rectangle gridBounds
)

Parameters

graphics
The Graphics used to paint the background.
clipBounds
A Rectangle that represents the area of the DataGridView that needs to be painted.
gridBounds
A Rectangle that represents the area in which cells are drawn.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


ProcessAKey Method

[image]
Gizmox.WebGUI.Forms
ProcessAKey Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : ProcessAKey Method

keyData
A bitwise combination of Keys values that represents the key or keys to process.
Processes the A key.

Syntax

Visual Basic (Declaration)
<SecurityPermissionAttribute(Assertion=False,
   UnmanagedCode=True,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=False,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Unrestricted=False)>
Protected Function ProcessAKey( _
   ByVal keyData As Keys _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim keyData As Keys
Dim value As Boolean

value = instance.ProcessAKey(keyData)
C#
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
protected bool ProcessAKey(
   Keys keyData
)
Managed Extensions for C++
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
protected: bool ProcessAKey(
   Keys keyData
)
C++/CLI
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
protected:
bool ProcessAKey(
   Keys keyData
)

Parameters

keyData
A bitwise combination of Keys values that represents the key or keys to process.

Return Value

true if the key was processed; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


ProcessDataGridViewKey Method

[image]
Gizmox.WebGUI.Forms
ProcessDataGridViewKey Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : ProcessDataGridViewKey Method

e
Contains information about the key that was pressed.
Processes keys used for navigating in the DataGridView.

Syntax

Visual Basic (Declaration)
<SecurityPermissionAttribute(Assertion=False,
   UnmanagedCode=True,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=False,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Unrestricted=False)>
Protected Overridable Function ProcessDataGridViewKey( _
   ByVal e As KeyEventArgs _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim e As KeyEventArgs
Dim value As Boolean

value = instance.ProcessDataGridViewKey(e)
C#
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
protected virtual bool ProcessDataGridViewKey(
   KeyEventArgs e
)
Managed Extensions for C++
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
protected: virtual bool ProcessDataGridViewKey(
   KeyEventArgs* e
)
C++/CLI
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
protected:
virtual bool ProcessDataGridViewKey(
   KeyEventArgs^ e
)

Parameters

e
Contains information about the key that was pressed.

Return Value

true if the key was processed; otherwise, false.

Exceptions

Exception | Description
InvalidCastException | The key pressed would cause the control to enter edit mode, but the DataGridViewCell.EditType property of the current cell does not indicate a class that derives from Control and implements IDataGridViewEditingControl.
Exception | This action would commit a cell value or enter edit mode, but an error in the data source prevents the action and either there is no handler for the DataError event or the handler has set the DataGridViewDataErrorEventArgs.ThrowException property to true.-or-The DELETE key would delete one or more rows, but an error in the data source prevents the deletion and either there is no handler for the DataError event or the handler has set the DataGridViewDataErrorEventArgs.ThrowException property to true.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


ProcessDeleteKey Method

[image]
Gizmox.WebGUI.Forms
ProcessDeleteKey Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : ProcessDeleteKey Method

keyData
A bitwise combination of Keys values that represents the key or keys to process.
Processes the DELETE key.

Syntax

Visual Basic (Declaration)
<SecurityPermissionAttribute(Assertion=False,
   UnmanagedCode=True,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=False,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Unrestricted=False)>
Protected Function ProcessDeleteKey( _
   ByVal keyData As Keys _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim keyData As Keys
Dim value As Boolean

value = instance.ProcessDeleteKey(keyData)
C#
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
protected bool ProcessDeleteKey(
   Keys keyData
)
Managed Extensions for C++
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
protected: bool ProcessDeleteKey(
   Keys keyData
)
C++/CLI
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
protected:
bool ProcessDeleteKey(
   Keys keyData
)

Parameters

keyData
A bitwise combination of Keys values that represents the key or keys to process.

Return Value

true if the key was processed; otherwise, false.

Exceptions

Exception | Description
Exception | The DELETE key would delete one or more rows, but an error in the data source prevents the deletion and either there is no handler for the DataError event or the handler has set the DataGridViewDataErrorEventArgs.ThrowException property to true.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


ProcessDownKey Method

[image]
Gizmox.WebGUI.Forms
ProcessDownKey Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : ProcessDownKey Method

keyData
A bitwise combination of Keys values that represents the key or keys to process.
Processes the DOWN ARROW key.

Syntax

Visual Basic (Declaration)
<SecurityPermissionAttribute(Assertion=False,
   UnmanagedCode=True,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=False,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Unrestricted=False)>
Protected Function ProcessDownKey( _
   ByVal keyData As Keys _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim keyData As Keys
Dim value As Boolean

value = instance.ProcessDownKey(keyData)
C#
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
protected bool ProcessDownKey(
   Keys keyData
)
Managed Extensions for C++
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
protected: bool ProcessDownKey(
   Keys keyData
)
C++/CLI
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
protected:
bool ProcessDownKey(
   Keys keyData
)

Parameters

keyData
A bitwise combination of Keys values that represents the key or keys to process.

Return Value

true if the key was processed; otherwise, false.

Exceptions

Exception | Description
InvalidCastException | The DOWN ARROW key would cause the control to enter edit mode, but the DataGridViewCell.EditType property of the new current cell does not indicate a class that derives from Control and implements IDataGridViewEditingControl.
Exception | This action would commit a cell value or enter edit mode, but an error in the data source prevents the action and either there is no handler for the DataError event or the handler has set the DataGridViewDataErrorEventArgs.ThrowException property to true.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


ProcessEndKey Method

[image]
Gizmox.WebGUI.Forms
ProcessEndKey Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : ProcessEndKey Method

keyData
A bitwise combination of Keys values that represents the key or keys to process.
Processes the END key.

Syntax

Visual Basic (Declaration)
<SecurityPermissionAttribute(Assertion=False,
   UnmanagedCode=True,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=False,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Unrestricted=False)>
Protected Function ProcessEndKey( _
   ByVal keyData As Keys _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim keyData As Keys
Dim value As Boolean

value = instance.ProcessEndKey(keyData)
C#
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
protected bool ProcessEndKey(
   Keys keyData
)
Managed Extensions for C++
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
protected: bool ProcessEndKey(
   Keys keyData
)
C++/CLI
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
protected:
bool ProcessEndKey(
   Keys keyData
)

Parameters

keyData
A bitwise combination of Keys values that represents the key or keys to process.

Return Value

true if the key was processed; otherwise, false.

Exceptions

Exception | Description
InvalidCastException | The END key would cause the control to enter edit mode, but the DataGridViewCell.EditType property of the new current cell does not indicate a class that derives from Control and implements IDataGridViewEditingControl.
Exception | This action would commit a cell value or enter edit mode, but an error in the data source prevents the action and either there is no handler for the DataError event or the handler has set the DataGridViewDataErrorEventArgs.ThrowException property to true.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


ProcessEnterKey Method

[image]
Gizmox.WebGUI.Forms
ProcessEnterKey Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : ProcessEnterKey Method

keyData
A bitwise combination of Keys values that represents the key or keys to process.
Processes the ENTER key.

Syntax

Visual Basic (Declaration)
<SecurityPermissionAttribute(Assertion=False,
   UnmanagedCode=True,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=False,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Unrestricted=False)>
Protected Function ProcessEnterKey( _
   ByVal keyData As Keys _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim keyData As Keys
Dim value As Boolean

value = instance.ProcessEnterKey(keyData)
C#
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
protected bool ProcessEnterKey(
   Keys keyData
)
Managed Extensions for C++
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
protected: bool ProcessEnterKey(
   Keys keyData
)
C++/CLI
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
protected:
bool ProcessEnterKey(
   Keys keyData
)

Parameters

keyData
A bitwise combination of Keys values that represents the key or keys to process.

Return Value

true if the key was processed; otherwise, false.

Exceptions

Exception | Description
Exception | This action would commit a cell value or enter edit mode, but an error in the data source prevents the action and either there is no handler for the DataError event or the handler has set the DataGridViewDataErrorEventArgs.ThrowException property to true.
InvalidCastException | The ENTER key would cause the control to enter edit mode, but the DataGridViewCell.EditType property of the new current cell does not indicate a class that derives from Control and implements IDataGridViewEditingControl.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


ProcessEscapeKey Method

[image]
Gizmox.WebGUI.Forms
ProcessEscapeKey Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : ProcessEscapeKey Method

keyData
A bitwise combination of Keys values that represents the key or keys to process.
Processes the ESC key.

Syntax

Visual Basic (Declaration)
<SecurityPermissionAttribute(Assertion=False,
   UnmanagedCode=True,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=False,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Unrestricted=False)>
Protected Function ProcessEscapeKey( _
   ByVal keyData As Keys _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim keyData As Keys
Dim value As Boolean

value = instance.ProcessEscapeKey(keyData)
C#
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
protected bool ProcessEscapeKey(
   Keys keyData
)
Managed Extensions for C++
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
protected: bool ProcessEscapeKey(
   Keys keyData
)
C++/CLI
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
protected:
bool ProcessEscapeKey(
   Keys keyData
)

Parameters

keyData
A bitwise combination of Keys values that represents the key or keys to process.

Return Value

true if the key was processed; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


ProcessF2Key Method

[image]
Gizmox.WebGUI.Forms
ProcessF2Key Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : ProcessF2Key Method

keyData
A bitwise combination of Keys values that represents the key or keys to process.
Processes the F2 key.

Syntax

Visual Basic (Declaration)
<SecurityPermissionAttribute(Assertion=False,
   UnmanagedCode=True,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=False,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Unrestricted=False)>
Protected Function ProcessF2Key( _
   ByVal keyData As Keys _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim keyData As Keys
Dim value As Boolean

value = instance.ProcessF2Key(keyData)
C#
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
protected bool ProcessF2Key(
   Keys keyData
)
Managed Extensions for C++
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
protected: bool ProcessF2Key(
   Keys keyData
)
C++/CLI
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
protected:
bool ProcessF2Key(
   Keys keyData
)

Parameters

keyData
A bitwise combination of Keys values that represents the key or keys to process.

Return Value

true if the key was processed; otherwise, false.

Exceptions

Exception | Description
Exception | The F2 key would cause the control to enter edit mode, but an error in the data source prevents the action and either there is no handler for the DataError event or the handler has set the DataGridViewDataErrorEventArgs.ThrowException property to true.
InvalidCastException | The F2 key would cause the control to enter edit mode, but the DataGridViewCell.EditType property of the current cell does not indicate a class that derives from Control and implements IDataGridViewEditingControl.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


ProcessHomeKey Method

[image]
Gizmox.WebGUI.Forms
ProcessHomeKey Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : ProcessHomeKey Method

keyData
The key that was pressed.
Processes the HOME key.

Syntax

Visual Basic (Declaration)
<SecurityPermissionAttribute(Assertion=False,
   UnmanagedCode=True,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=False,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Unrestricted=False)>
Protected Function ProcessHomeKey( _
   ByVal keyData As Keys _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim keyData As Keys
Dim value As Boolean

value = instance.ProcessHomeKey(keyData)
C#
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
protected bool ProcessHomeKey(
   Keys keyData
)
Managed Extensions for C++
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
protected: bool ProcessHomeKey(
   Keys keyData
)
C++/CLI
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
protected:
bool ProcessHomeKey(
   Keys keyData
)

Parameters

keyData
The key that was pressed.

Return Value

true if the key was processed; otherwise, false.

Exceptions

Exception | Description
InvalidCastException | The HOME key would cause the control to enter edit mode, but the DataGridViewCell.EditType property of the new current cell does not indicate a class that derives from Control and implements IDataGridViewEditingControl.
Exception | This action would commit a cell value or enter edit mode, but an error in the data source prevents the action and either there is no handler for the DataError event or the handler has set the DataGridViewDataErrorEventArgs.ThrowException property to true.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


ProcessInsertKey Method

[image]
Gizmox.WebGUI.Forms
ProcessInsertKey Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : ProcessInsertKey Method

keyData
One of the Keys values that represents the key to process.
Processes the INSERT key.

Syntax

Visual Basic (Declaration)
<SecurityPermissionAttribute(Assertion=False,
   UnmanagedCode=True,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=False,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Unrestricted=False)>
Protected Function ProcessInsertKey( _
   ByVal keyData As Keys _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim keyData As Keys
Dim value As Boolean

value = instance.ProcessInsertKey(keyData)
C#
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
protected bool ProcessInsertKey(
   Keys keyData
)
Managed Extensions for C++
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
protected: bool ProcessInsertKey(
   Keys keyData
)
C++/CLI
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
protected:
bool ProcessInsertKey(
   Keys keyData
)

Parameters

keyData
One of the Keys values that represents the key to process.

Return Value

true if the key was processed; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


ProcessLeftKey Method

[image]
Gizmox.WebGUI.Forms
ProcessLeftKey Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : ProcessLeftKey Method

keyData
A bitwise combination of Keys values that represents the key or keys to process.
Processes the LEFT ARROW key.

Syntax

Visual Basic (Declaration)
<SecurityPermissionAttribute(Assertion=False,
   UnmanagedCode=True,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=False,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Unrestricted=False)>
Protected Function ProcessLeftKey( _
   ByVal keyData As Keys _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim keyData As Keys
Dim value As Boolean

value = instance.ProcessLeftKey(keyData)
C#
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
protected bool ProcessLeftKey(
   Keys keyData
)
Managed Extensions for C++
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
protected: bool ProcessLeftKey(
   Keys keyData
)
C++/CLI
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
protected:
bool ProcessLeftKey(
   Keys keyData
)

Parameters

keyData
A bitwise combination of Keys values that represents the key or keys to process.

Return Value

true if the key was processed; otherwise, false.

Exceptions

Exception | Description
InvalidCastException | The LEFT ARROW key would cause the control to enter edit mode, but the DataGridViewCell.EditType property of the new current cell does not indicate a class that derives from Control and implements IDataGridViewEditingControl.
Exception | This action would commit a cell value or enter edit mode, but an error in the data source prevents the action and either there is no handler for the DataError event or the handler has set the DataGridViewDataErrorEventArgs.ThrowException property to true.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


ProcessNextKey Method

[image]
Gizmox.WebGUI.Forms
ProcessNextKey Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : ProcessNextKey Method

keyData
A bitwise combination of Keys values that represents the key or keys to process.
Processes the PAGE DOWN key.

Syntax

Visual Basic (Declaration)
<SecurityPermissionAttribute(Assertion=False,
   UnmanagedCode=True,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=False,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Unrestricted=False)>
Protected Function ProcessNextKey( _
   ByVal keyData As Keys _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim keyData As Keys
Dim value As Boolean

value = instance.ProcessNextKey(keyData)
C#
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
protected bool ProcessNextKey(
   Keys keyData
)
Managed Extensions for C++
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
protected: bool ProcessNextKey(
   Keys keyData
)
C++/CLI
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
protected:
bool ProcessNextKey(
   Keys keyData
)

Parameters

keyData
A bitwise combination of Keys values that represents the key or keys to process.

Return Value

true if the key was processed; otherwise, false.

Exceptions

Exception | Description
InvalidCastException | The PAGE DOWN key would cause the control to enter edit mode, but the DataGridViewCell.EditType property of the new current cell does not indicate a class that derives from Control and implements IDataGridViewEditingControl.
Exception | This action would commit a cell value or enter edit mode, but an error in the data source prevents the action and either there is no handler for the DataError event or the handler has set the DataGridViewDataErrorEventArgs.ThrowException property to true.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


ProcessPriorKey Method

[image]
Gizmox.WebGUI.Forms
ProcessPriorKey Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : ProcessPriorKey Method

keyData
A bitwise combination of Keys values that represents the key or keys to process.
Processes the PAGE UP key.

Syntax

Visual Basic (Declaration)
<SecurityPermissionAttribute(Assertion=False,
   UnmanagedCode=True,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=False,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Unrestricted=False)>
Protected Function ProcessPriorKey( _
   ByVal keyData As Keys _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim keyData As Keys
Dim value As Boolean

value = instance.ProcessPriorKey(keyData)
C#
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
protected bool ProcessPriorKey(
   Keys keyData
)
Managed Extensions for C++
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
protected: bool ProcessPriorKey(
   Keys keyData
)
C++/CLI
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
protected:
bool ProcessPriorKey(
   Keys keyData
)

Parameters

keyData
A bitwise combination of Keys values that represents the key or keys to process.

Return Value

true if the key was processed; otherwise, false.

Exceptions

Exception | Description
InvalidCastException | The PAGE UP key would cause the control to enter edit mode, but the DataGridViewCell.EditType property of the new current cell does not indicate a class that derives from Control and implements IDataGridViewEditingControl.
Exception | This action would commit a cell value or enter edit mode, but an error in the data source prevents the action and either there is no handler for the DataError event or the handler has set the DataGridViewDataErrorEventArgs.ThrowException property to true.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


ProcessRightKey Method

[image]
Gizmox.WebGUI.Forms
ProcessRightKey Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : ProcessRightKey Method

keyData
A bitwise combination of Keys values that represents the key or keys to process.
Processes the RIGHT ARROW key.

Syntax

Visual Basic (Declaration)
<SecurityPermissionAttribute(Assertion=False,
   UnmanagedCode=True,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=False,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Unrestricted=False)>
Protected Function ProcessRightKey( _
   ByVal keyData As Keys _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim keyData As Keys
Dim value As Boolean

value = instance.ProcessRightKey(keyData)
C#
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
protected bool ProcessRightKey(
   Keys keyData
)
Managed Extensions for C++
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
protected: bool ProcessRightKey(
   Keys keyData
)
C++/CLI
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
protected:
bool ProcessRightKey(
   Keys keyData
)

Parameters

keyData
A bitwise combination of Keys values that represents the key or keys to process.

Return Value

true if the key was processed; otherwise, false.

Exceptions

Exception | Description
InvalidCastException | The RIGHT ARROW key would cause the control to enter edit mode, but the DataGridViewCell.EditType property of the new current cell does not indicate a class that derives from Control and implements IDataGridViewEditingControl.
Exception | This action would commit a cell value or enter edit mode, but an error in the data source prevents the action and either there is no handler for the DataError event or the handler has set the DataGridViewDataErrorEventArgs.ThrowException property to true.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


ProcessSpaceKey Method

[image]
Gizmox.WebGUI.Forms
ProcessSpaceKey Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : ProcessSpaceKey Method

keyData
One of the Keys values that represents the key to process.
Processes the SPACEBAR.

Syntax

Visual Basic (Declaration)
<SecurityPermissionAttribute(Assertion=False,
   UnmanagedCode=True,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=False,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Unrestricted=False)>
Protected Function ProcessSpaceKey( _
   ByVal keyData As Keys _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim keyData As Keys
Dim value As Boolean

value = instance.ProcessSpaceKey(keyData)
C#
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
protected bool ProcessSpaceKey(
   Keys keyData
)
Managed Extensions for C++
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
protected: bool ProcessSpaceKey(
   Keys keyData
)
C++/CLI
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
protected:
bool ProcessSpaceKey(
   Keys keyData
)

Parameters

keyData
One of the Keys values that represents the key to process.

Return Value

true if the key was processed; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


ProcessTabKey Method

[image]
Gizmox.WebGUI.Forms
ProcessTabKey Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : ProcessTabKey Method

keyData
A bitwise combination of Keys values that represents the key or keys to process.
Processes the TAB key.

Syntax

Visual Basic (Declaration)
<UIPermissionAttribute(False)>
Protected Function ProcessTabKey( _
   ByVal keyData As Keys _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim keyData As Keys
Dim value As Boolean

value = instance.ProcessTabKey(keyData)
C#
[UIPermissionAttribute(false)]
protected bool ProcessTabKey(
   Keys keyData
)
Managed Extensions for C++
[UIPermissionAttribute(false)]
protected: bool ProcessTabKey(
   Keys keyData
)
C++/CLI
[UIPermissionAttribute(false)]
protected:
bool ProcessTabKey(
   Keys keyData
)

Parameters

keyData
A bitwise combination of Keys values that represents the key or keys to process.

Return Value

true if the key was processed; otherwise, false.

Exceptions

Exception | Description
Exception | This action would commit a cell value or enter edit mode, but an error in the data source prevents the action and either there is no handler for the DataError event or the handler has set the DataGridViewDataErrorEventArgs.ThrowException property to true.
InvalidCastException | The TAB key would cause the control to enter edit mode, but the DataGridViewCell.EditType property of the new current cell does not indicate a class that derives from Control and implements IDataGridViewEditingControl.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


ProcessUpKey Method

[image]
Gizmox.WebGUI.Forms
ProcessUpKey Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : ProcessUpKey Method

keyData
A bitwise combination of Keys values that represents the key or keys to process.
Processes the UP ARROW key.

Syntax

Visual Basic (Declaration)
<SecurityPermissionAttribute(Assertion=False,
   UnmanagedCode=True,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=False,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Unrestricted=False)>
Protected Function ProcessUpKey( _
   ByVal keyData As Keys _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim keyData As Keys
Dim value As Boolean

value = instance.ProcessUpKey(keyData)
C#
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
protected bool ProcessUpKey(
   Keys keyData
)
Managed Extensions for C++
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
protected: bool ProcessUpKey(
   Keys keyData
)
C++/CLI
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
protected:
bool ProcessUpKey(
   Keys keyData
)

Parameters

keyData
A bitwise combination of Keys values that represents the key or keys to process.

Return Value

true if the key was processed; otherwise, false.

Exceptions

Exception | Description
InvalidCastException | The UP ARROW key would cause the control to enter edit mode, but the DataGridViewCell.EditType property of the new current cell does not indicate a class that derives from Control and implements IDataGridViewEditingControl.
Exception | This action would commit a cell value or enter edit mode, but an error in the data source prevents the action and either there is no handler for the DataError event or the handler has set the DataGridViewDataErrorEventArgs.ThrowException property to true.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


ProcessZeroKey Method

[image]
Gizmox.WebGUI.Forms
ProcessZeroKey Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : ProcessZeroKey Method

keyData
A bitwise combination of Keys values that represents the key or keys to process.
Processes the 0 key.

Syntax

Visual Basic (Declaration)
<SecurityPermissionAttribute(Assertion=False,
   UnmanagedCode=True,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=False,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Unrestricted=False)>
Protected Function ProcessZeroKey( _
   ByVal keyData As Keys _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim keyData As Keys
Dim value As Boolean

value = instance.ProcessZeroKey(keyData)
C#
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
protected bool ProcessZeroKey(
   Keys keyData
)
Managed Extensions for C++
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
protected: bool ProcessZeroKey(
   Keys keyData
)
C++/CLI
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
protected:
bool ProcessZeroKey(
   Keys keyData
)

Parameters

keyData
A bitwise combination of Keys values that represents the key or keys to process.

Return Value

true if the key was processed; otherwise, false.

Exceptions

Exception | Description
InvalidCastException | The 0 key would cause the control to enter edit mode, but the DataGridViewCell.EditType property of the current cell does not indicate a class that derives from Control and implements IDataGridViewEditingControl.
Exception | This action would cause the control to enter edit mode, but an error in the data source prevents the action and either there is no handler for the DataError event or the handler has set the DataGridViewDataErrorEventArgs.ThrowException property to true.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


RefreshEdit Method

[image]
Gizmox.WebGUI.Forms
RefreshEdit Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : RefreshEdit Method

Refreshes the value of the current cell with the underlying cell value when the cell is in edit mode, discarding any previous value.

Syntax

Visual Basic (Declaration)
Public Function RefreshEdit() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim value As Boolean

value = instance.RefreshEdit()
C#
public bool RefreshEdit()
Managed Extensions for C++
public: bool RefreshEdit();
C++/CLI
public:
bool RefreshEdit();

Return Value

true if successful; false if a DataError event occurred.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


RenderAttributes Method

[image]
Gizmox.WebGUI.Forms
RenderAttributes Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : RenderAttributes Method

objContext
The current VWG Context
objWriter
The XML stream writer
Renders the control's meta attributes

Syntax

Visual Basic (Declaration)
Protected Overrides Sub RenderAttributes( _
   ByVal objContext As IContext, _
   ByVal objWriter As IAttributeWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim objContext As IContext
Dim objWriter As IAttributeWriter

instance.RenderAttributes(objContext, objWriter)
C#
protected override void RenderAttributes(
   IContext objContext,
   IAttributeWriter objWriter
)
Managed Extensions for C++
protected: void RenderAttributes(
   IContext* objContext,
   IAttributeWriter* objWriter
) override
C++/CLI
protected:
void RenderAttributes(
   IContext^ objContext,
   IAttributeWriter^ objWriter
) override

Parameters

objContext
The current VWG Context
objWriter
The XML stream writer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


RenderControls Method

[image]
Gizmox.WebGUI.Forms
RenderControls Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : RenderControls Method

Renders the controls sub tree

Overload List

Overload | Description
RenderControls(IContext,IResponseWriter,Int64) | Renders the controls sub tree
RenderControls(IContext,IResponseWriter,Int64,Boolean) | Renders the controls sub tree (Inherited from Control)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


RenderControls(IContext,IResponseWriter,Int64) Method

[image]
Gizmox.WebGUI.Forms
RenderControls(IContext,IResponseWriter,Int64) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class > RenderControls Method : RenderControls(IContext,IResponseWriter,Int64) Method

objContext
objWriter
lngRequestID
Renders the controls sub tree

Syntax

Visual Basic (Declaration)
Protected Overloads Overrides Sub RenderControls( _
   ByVal objContext As IContext, _
   ByVal objWriter As IResponseWriter, _
   ByVal lngRequestID As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim objContext As IContext
Dim objWriter As IResponseWriter
Dim lngRequestID As Long

instance.RenderControls(objContext, objWriter, lngRequestID)
C#
protected override void RenderControls(
   IContext objContext,
   IResponseWriter objWriter,
   long lngRequestID
)
Managed Extensions for C++
protected: void RenderControls(
   IContext* objContext,
   IResponseWriter* objWriter,
   long lngRequestID
) override
C++/CLI
protected:
void RenderControls(
   IContext^ objContext,
   IResponseWriter^ objWriter,
   long long lngRequestID
) override

Parameters

objContext
objWriter
lngRequestID

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members
Overload List


RenderUpdatedAttributes Method

[image]
Gizmox.WebGUI.Forms
RenderUpdatedAttributes Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : RenderUpdatedAttributes Method

objContext
The current VWG Context
objWriter
The XML stream writer
lngRequestID
The ID of the request currently being handled
Renders only the control's updated meta attributes

Syntax

Visual Basic (Declaration)
Protected Overrides Sub RenderUpdatedAttributes( _
   ByVal objContext As IContext, _
   ByVal objWriter As IAttributeWriter, _
   ByVal lngRequestID As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim objContext As IContext
Dim objWriter As IAttributeWriter
Dim lngRequestID As Long

instance.RenderUpdatedAttributes(objContext, objWriter, lngRequestID)
C#
protected override void RenderUpdatedAttributes(
   IContext objContext,
   IAttributeWriter objWriter,
   long lngRequestID
)
Managed Extensions for C++
protected: void RenderUpdatedAttributes(
   IContext* objContext,
   IAttributeWriter* objWriter,
   long lngRequestID
) override
C++/CLI
protected:
void RenderUpdatedAttributes(
   IContext^ objContext,
   IAttributeWriter^ objWriter,
   long long lngRequestID
) override

Parameters

objContext
The current VWG Context
objWriter
The XML stream writer
lngRequestID
The ID of the request currently being handled

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


SelectAll Method

[image]
Gizmox.WebGUI.Forms
SelectAll Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : SelectAll Method

Selects all the cells in the DataGridView.

Syntax

Visual Basic (Declaration)
Public Sub SelectAll()
Visual Basic (Usage) Copy Code
Dim instance As DataGridView

instance.SelectAll()
C#
public void SelectAll()
Managed Extensions for C++
public: void SelectAll();
C++/CLI
public:
void SelectAll();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


SetCurrentCellAddressCore Method

[image]
Gizmox.WebGUI.Forms
SetCurrentCellAddressCore Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : SetCurrentCellAddressCore Method

columnIndex
The index of the column containing the cell.
rowIndex
The index of the row containing the cell.
setAnchorCellAddress
true to make the new current cell the anchor cell for a subsequent multicell selection using the SHIFT key; otherwise, false.
validateCurrentCell
true to validate the value in the old current cell and cancel the change if validation fails; otherwise, false.
throughMouseClick
true if the current cell is being set as a result of a mouse click; otherwise, false.
Sets the currently active cell.

Syntax

Visual Basic (Declaration)
Protected Overridable Function SetCurrentCellAddressCore( _
   ByVal columnIndex As Integer, _
   ByVal rowIndex As Integer, _
   ByVal setAnchorCellAddress As Boolean, _
   ByVal validateCurrentCell As Boolean, _
   ByVal throughMouseClick As Boolean _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim columnIndex As Integer
Dim rowIndex As Integer
Dim setAnchorCellAddress As Boolean
Dim validateCurrentCell As Boolean
Dim throughMouseClick As Boolean
Dim value As Boolean

value = instance.SetCurrentCellAddressCore(columnIndex, rowIndex, setAnchorCellAddress, validateCurrentCell, throughMouseClick)
C#
protected virtual bool SetCurrentCellAddressCore(
   int columnIndex,
   int rowIndex,
   bool setAnchorCellAddress,
   bool validateCurrentCell,
   bool throughMouseClick
)
Managed Extensions for C++
protected: virtual bool SetCurrentCellAddressCore(
   int columnIndex,
   int rowIndex,
   bool setAnchorCellAddress,
   bool validateCurrentCell,
   bool throughMouseClick
)
C++/CLI
protected:
virtual bool SetCurrentCellAddressCore(
   int columnIndex,
   int rowIndex,
   bool setAnchorCellAddress,
   bool validateCurrentCell,
   bool throughMouseClick
)

Parameters

columnIndex
The index of the column containing the cell.
rowIndex
The index of the row containing the cell.
setAnchorCellAddress
true to make the new current cell the anchor cell for a subsequent multicell selection using the SHIFT key; otherwise, false.
validateCurrentCell
true to validate the value in the old current cell and cancel the change if validation fails; otherwise, false.
throughMouseClick
true if the current cell is being set as a result of a mouse click; otherwise, false.

Return Value

true if the current cell was successfully set; otherwise, false.

Exceptions

Exception | Description
InvalidCastException | The new current cell tried to enter edit mode, but its DataGridViewCell.EditType property does not indicate a class that derives from Control and implements IDataGridViewEditingControl.
ArgumentOutOfRangeException | columnIndex is less than 0 or greater than the number of columns in the control minus 1, and rowIndex is not -1.-or-rowIndex is less than 0 or greater than the number of rows in the control minus 1, and columnIndex is not -1.
InvalidOperationException | The specified cell has a DataGridViewCell.Visible property value of false.-or-This method was called for a reason other than the underlying data source being reset, and another thread is currently executing this method.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


SetSelectedCellCore Method

[image]
Gizmox.WebGUI.Forms
SetSelectedCellCore Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : SetSelectedCellCore Method

columnIndex
The index of the column containing the cell.
rowIndex
The index of the row containing the cell.
selected
true to select the cell; false to cancel the selection of the cell.
Changes the selection state of the cell with the specified row and column indexes.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub SetSelectedCellCore( _
   ByVal columnIndex As Integer, _
   ByVal rowIndex As Integer, _
   ByVal selected As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim columnIndex As Integer
Dim rowIndex As Integer
Dim selected As Boolean

instance.SetSelectedCellCore(columnIndex, rowIndex, selected)
C#
protected virtual void SetSelectedCellCore(
   int columnIndex,
   int rowIndex,
   bool selected
)
Managed Extensions for C++
protected: virtual void SetSelectedCellCore(
   int columnIndex,
   int rowIndex,
   bool selected
)
C++/CLI
protected:
virtual void SetSelectedCellCore(
   int columnIndex,
   int rowIndex,
   bool selected
)

Parameters

columnIndex
The index of the column containing the cell.
rowIndex
The index of the row containing the cell.
selected
true to select the cell; false to cancel the selection of the cell.

Exceptions

Exception | Description
ArgumentOutOfRangeException | columnIndex is less than 0 or greater than the number of columns in the control minus 1.-or-rowIndex is less than 0 or greater than the number of rows in the control minus 1.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


SetSelectedColumnCore Method

[image]
Gizmox.WebGUI.Forms
SetSelectedColumnCore Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : SetSelectedColumnCore Method

columnIndex
The index of the column.
selected
true to select the column; false to cancel the selection of the column.
Changes the selection state of the column with the specified index.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub SetSelectedColumnCore( _
   ByVal columnIndex As Integer, _
   ByVal selected As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim columnIndex As Integer
Dim selected As Boolean

instance.SetSelectedColumnCore(columnIndex, selected)
C#
protected virtual void SetSelectedColumnCore(
   int columnIndex,
   bool selected
)
Managed Extensions for C++
protected: virtual void SetSelectedColumnCore(
   int columnIndex,
   bool selected
)
C++/CLI
protected:
virtual void SetSelectedColumnCore(
   int columnIndex,
   bool selected
)

Parameters

columnIndex
The index of the column.
selected
true to select the column; false to cancel the selection of the column.

Exceptions

Exception | Description
ArgumentOutOfRangeException | columnIndex is less than 0 or greater than the number of columns in the control minus 1.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


SetSelectedRowCore Method

[image]
Gizmox.WebGUI.Forms
SetSelectedRowCore Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : SetSelectedRowCore Method

rowIndex
The index of the row.
selected
true to select the row; false to cancel the selection of the row.
Changes the selection state of the row with the specified index.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub SetSelectedRowCore( _
   ByVal rowIndex As Integer, _
   ByVal selected As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim rowIndex As Integer
Dim selected As Boolean

instance.SetSelectedRowCore(rowIndex, selected)
C#
protected virtual void SetSelectedRowCore(
   int rowIndex,
   bool selected
)
Managed Extensions for C++
protected: virtual void SetSelectedRowCore(
   int rowIndex,
   bool selected
)
C++/CLI
protected:
virtual void SetSelectedRowCore(
   int rowIndex,
   bool selected
)

Parameters

rowIndex
The index of the row.
selected
true to select the row; false to cancel the selection of the row.

Exceptions

Exception | Description
ArgumentOutOfRangeException | rowIndex is less than 0 or greater than the number of rows in the control minus 1.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


Sort Method

[image]
Gizmox.WebGUI.Forms
Sort Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : Sort Method

Sorts the contents of the DataGridView control using an implementation of the IComparer interface.

Overload List

Overload | Description
Sort(IComparer) | Sorts the contents of the DataGridView control using an implementation of the IComparer interface.
Sort(DataGridViewColumn,ListSortDirection) | Sorts the contents of the DataGridView control in ascending or descending order based on the contents of the specified column.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


Sort(IComparer) Method

[image]
Gizmox.WebGUI.Forms
Sort(IComparer) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class > Sort Method : Sort(IComparer) Method

comparer
An implementation of IComparer that performs the custom sorting operation.
Sorts the contents of the DataGridView control using an implementation of the IComparer interface.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub Sort( _
   ByVal comparer As IComparer _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim comparer As IComparer

instance.Sort(comparer)
C#
public virtual void Sort(
   IComparer comparer
)
Managed Extensions for C++
public: virtual void Sort(
   IComparer* comparer
)
C++/CLI
public:
virtual void Sort(
   IComparer^ comparer
)

Parameters

comparer
An implementation of IComparer that performs the custom sorting operation.

Exceptions

Exception | Description
InvalidOperationException | VirtualMode is set to true.-or- DataSource is not null.
ArgumentNullException | comparer is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members
Overload List


Sort(DataGridViewColumn,ListSortDirection) Method

[image]
Gizmox.WebGUI.Forms
Sort(DataGridViewColumn,ListSortDirection) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class > Sort Method : Sort(DataGridViewColumn,ListSortDirection) Method

dataGridViewColumn
The column by which to sort the contents of the DataGridView.
direction
One of the ListSortDirection values.
Sorts the contents of the DataGridView control in ascending or descending order based on the contents of the specified column.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub Sort( _
   ByVal dataGridViewColumn As DataGridViewColumn, _
   ByVal direction As ListSortDirection _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim dataGridViewColumn As DataGridViewColumn
Dim direction As ListSortDirection

instance.Sort(dataGridViewColumn, direction)
C#
public virtual void Sort(
   DataGridViewColumn dataGridViewColumn,
   ListSortDirection direction
)
Managed Extensions for C++
public: virtual void Sort(
   DataGridViewColumn* dataGridViewColumn,
   ListSortDirection direction
)
C++/CLI
public:
virtual void Sort(
   DataGridViewColumn^ dataGridViewColumn,
   ListSortDirection direction
)

Parameters

dataGridViewColumn
The column by which to sort the contents of the DataGridView.
direction
One of the ListSortDirection values.

Exceptions

Exception | Description
ArgumentException | The specified column is not part of this DataGridView.-or-The DataSource property has been set and the DataGridViewColumn.IsDataBound property of the specified column returns false.
ArgumentNullException | dataGridViewColumn is null.
InvalidOperationException | The VirtualMode property is set to true and the DataGridViewColumn.IsDataBound property of the specified column returns false.-or-The object specified by the DataSource property does not implement the IBindingList interface.-or-The object specified by the DataSource property has a SupportsSorting property value of false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members
Overload List


UpdateCellErrorText Method

[image]
Gizmox.WebGUI.Forms
UpdateCellErrorText Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : UpdateCellErrorText Method

columnIndex
The column index of the cell to update, or -1 to indicate a row header cell.
rowIndex
The row index of the cell to update, or -1 to indicate a column header cell.
Forces the cell at the specified location to update its error text.

Syntax

Visual Basic (Declaration)
Public Sub UpdateCellErrorText( _
   ByVal columnIndex As Integer, _
   ByVal rowIndex As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim columnIndex As Integer
Dim rowIndex As Integer

instance.UpdateCellErrorText(columnIndex, rowIndex)
C#
public void UpdateCellErrorText(
   int columnIndex,
   int rowIndex
)
Managed Extensions for C++
public: void UpdateCellErrorText(
   int columnIndex,
   int rowIndex
)
C++/CLI
public:
void UpdateCellErrorText(
   int columnIndex,
   int rowIndex
)

Parameters

columnIndex
The column index of the cell to update, or -1 to indicate a row header cell.
rowIndex
The row index of the cell to update, or -1 to indicate a column header cell.

Exceptions

Exception | Description
ArgumentOutOfRangeException | columnIndex is less than -1 or greater than the number of columns in the control minus 1.- or -rowIndex is less than -1 or greater than the number of rows in the control minus 1.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


UpdateCellValue Method

[image]
Gizmox.WebGUI.Forms
UpdateCellValue Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : UpdateCellValue Method

columnIndex
The zero-based column index of the cell with the new value.
rowIndex
The zero-based row index of the cell with the new value.
Forces the control to update its display of the cell at the specified location based on its new value, applying any automatic sizing modes currently in effect.

Syntax

Visual Basic (Declaration)
Public Sub UpdateCellValue( _
   ByVal columnIndex As Integer, _
   ByVal rowIndex As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim columnIndex As Integer
Dim rowIndex As Integer

instance.UpdateCellValue(columnIndex, rowIndex)
C#
public void UpdateCellValue(
   int columnIndex,
   int rowIndex
)
Managed Extensions for C++
public: void UpdateCellValue(
   int columnIndex,
   int rowIndex
)
C++/CLI
public:
void UpdateCellValue(
   int columnIndex,
   int rowIndex
)

Parameters

columnIndex
The zero-based column index of the cell with the new value.
rowIndex
The zero-based row index of the cell with the new value.

Exceptions

Exception | Description
ArgumentOutOfRangeException | columnIndex is less than zero or greater than the number of columns in the control minus one.-or-rowIndex is less than zero or greater than the number of rows in the control minus one.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


UpdateRowErrorText Method

[image]
Gizmox.WebGUI.Forms
UpdateRowErrorText Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : UpdateRowErrorText Method

Forces the row at the given row index to update its error text.

Overload List

Overload | Description
UpdateRowErrorText(Int32) | Forces the row at the given row index to update its error text.
UpdateRowErrorText(Int32,Int32) | Forces the rows in the given range to update their error text.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


UpdateRowErrorText(Int32) Method

[image]
Gizmox.WebGUI.Forms
UpdateRowErrorText(Int32) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class > UpdateRowErrorText Method : UpdateRowErrorText(Int32) Method

rowIndex
The zero-based index of the row to update.
Forces the row at the given row index to update its error text.

Syntax

Visual Basic (Declaration)
Public Overloads Sub UpdateRowErrorText( _
   ByVal rowIndex As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim rowIndex As Integer

instance.UpdateRowErrorText(rowIndex)
C#
public void UpdateRowErrorText(
   int rowIndex
)
Managed Extensions for C++
public: void UpdateRowErrorText(
   int rowIndex
)
C++/CLI
public:
void UpdateRowErrorText(
   int rowIndex
)

Parameters

rowIndex
The zero-based index of the row to update.

Exceptions

Exception | Description
ArgumentOutOfRangeException | rowIndex is not in the valid range of 0 to the number of rows in the control minus 1.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members
Overload List


UpdateRowErrorText(Int32,Int32) Method

[image]
Gizmox.WebGUI.Forms
UpdateRowErrorText(Int32,Int32) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class > UpdateRowErrorText Method : UpdateRowErrorText(Int32,Int32) Method

rowIndexStart
The zero-based index of the first row in the set of rows to update.
rowIndexEnd
The zero-based index of the last row in the set of rows to update.
Forces the rows in the given range to update their error text.

Syntax

Visual Basic (Declaration)
Public Overloads Sub UpdateRowErrorText( _
   ByVal rowIndexStart As Integer, _
   ByVal rowIndexEnd As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim rowIndexStart As Integer
Dim rowIndexEnd As Integer

instance.UpdateRowErrorText(rowIndexStart, rowIndexEnd)
C#
public void UpdateRowErrorText(
   int rowIndexStart,
   int rowIndexEnd
)
Managed Extensions for C++
public: void UpdateRowErrorText(
   int rowIndexStart,
   int rowIndexEnd
)
C++/CLI
public:
void UpdateRowErrorText(
   int rowIndexStart,
   int rowIndexEnd
)

Parameters

rowIndexStart
The zero-based index of the first row in the set of rows to update.
rowIndexEnd
The zero-based index of the last row in the set of rows to update.

Exceptions

Exception | Description
ArgumentOutOfRangeException | rowIndexStart is not in the valid range of 0 to the number of rows in the control minus 1.-or-rowIndexEnd is not in the valid range of 0 to the number of rows in the control minus 1.-or-rowIndexEnd is less than rowIndexStart.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members
Overload List


UpdateRowHeightInfo Method

[image]
Gizmox.WebGUI.Forms
UpdateRowHeightInfo Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : UpdateRowHeightInfo Method

rowIndex
The zero-based index of the first row to update.
updateToEnd
true to update the specified row and all subsequent rows.
Forces the specified row or rows to update their height information.

Syntax

Visual Basic (Declaration)
Public Sub UpdateRowHeightInfo( _
   ByVal rowIndex As Integer, _
   ByVal updateToEnd As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim rowIndex As Integer
Dim updateToEnd As Boolean

instance.UpdateRowHeightInfo(rowIndex, updateToEnd)
C#
public void UpdateRowHeightInfo(
   int rowIndex,
   bool updateToEnd
)
Managed Extensions for C++
public: void UpdateRowHeightInfo(
   int rowIndex,
   bool updateToEnd
)
C++/CLI
public:
void UpdateRowHeightInfo(
   int rowIndex,
   bool updateToEnd
)

Parameters

rowIndex
The zero-based index of the first row to update.
updateToEnd
true to update the specified row and all subsequent rows.

Exceptions

Exception | Description
ArgumentOutOfRangeException | rowIndex is less than 0 and updateToEnd is true.- or -rowIndex is less than -1 and updateToEnd is false.- or -rowIndex is greater than the highest row index in the Rows collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


DataGridView Class Properties

[image]
Gizmox.WebGUI.Forms
DataGridView Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridView Class

For a list of all members of this type, see DataGridView members.

Public Properties

 | Name | Description
Public Property | AdjustedTopLeftHeaderBorderStyle | Gets the border style for the upper-left cell in the DataGridView.
Public Property | AdvancedCellBorderStyle | Gets the border style of the cells in the DataGridView.
Public Property | AdvancedColumnHeadersBorderStyle | Gets the border style of the column header cells in the DataGridView.
Public Property | AdvancedRowHeadersBorderStyle | Gets the border style of the row header cells in the DataGridView.
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | AllowUserToAddRows | Gets or sets a value indicating whether the option to add rows is displayed to the user.
Public Property | AllowUserToDeleteRows | Gets or sets a value indicating whether the user is allowed to delete rows from the DataGridView.
Public Property | AllowUserToOrderColumns | Gets or sets a value indicating whether manual column repositioning is enabled.
Public Property | AllowUserToResizeColumns | Gets or sets a value indicating whether users can resize columns.
Public Property | AllowUserToResizeRows | Gets or sets a value indicating whether users can resize rows.
Public Property | AlternatingRowsDefaultCellStyle | Gets or sets the default cell style applied to odd-numbered rows of the DataGridView.
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | AutoGenerateColumns | Gets or sets a value indicating whether columns are created automatically when the DataSource or DataMember properties are set.
Public Property | AutoSizeColumnsMode | Gets or sets a value indicating how column widths are determined.
Public Property | AutoSizeRowsMode | Gets or sets a value indicating how row heights are determined.
Public Property | BackgroundColor | Gets or sets the background color of the DataGridView.
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Overridden. Gets or sets the border style for the DataGridView.
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | CellBorderStyle | Gets the cell border style for the DataGridView.
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | ClipboardCopyMode | Gets or sets a value that indicates whether users can copy cell text values to the Clipboard and whether row and column header text is included.
Public Property | ColumnCount | Gets or sets the number of columns displayed in the DataGridView.
Public Property | ColumnHeadersBorderStyle | Gets the border style applied to the column headers.
Public Property | ColumnHeadersDefaultCellStyle | Gets or sets the default column header style.
Public Property | ColumnHeadersHeight | Gets or sets the height, in pixels, of the column headers row
Public Property | ColumnHeadersHeightSizeMode | Gets or sets a value indicating whether the height of the column headers is adjustable and whether it can be adjusted by the user or is automatically adjusted to fit the contents of the headers.
Public Property | ColumnHeadersVisible | Gets or sets a value indicating whether the column header row is displayed.
Public Property | Columns | Gets a collection that contains all the columns in the control.
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | CurrentCell | Gets or sets the currently active cell.
Public Property | CurrentCellAddress | Gets the row and column indexes of the currently active cell.
Public Property | CurrentPage | Gets or sets the current page.
Public Property | CurrentRow | Gets the row containing the current cell.
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | DataMember | Gets or sets the name of the list or table in the data source for which the DataGridView is displaying data.
Public Property | DataSource | Gets or sets the data source that the DataGridView is displaying data for.
Public Property | DefaultCellStyle | Gets or sets the default cell style to be applied to the cells in the DataGridView if no other cell style properties are set.
Public Property | DisableNavigation | Gets or sets a value indicating whether [disable navigation].
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DragTargets | Overridden. Gets a value indicating whether this instance is dragable.
Public Property | EditingControl |
Public Property | EditingPanel | Gets the panel that contains the EditingControl.
Public Property | EditMode | Gets or sets a value indicating how to begin editing a cell.
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | EnableHeadersVisualStyles | Gets or sets a value indicating whether row and column headers use the visual styles of the user's current theme if visual styles are enabled for the application.
Public Property | FirstDisplayedCell | Gets or sets the first cell currently displayed in the DataGridView; typically, this cell is in the upper left corner.
Public Property | FirstDisplayedScrollingColumnHiddenWidth | Gets the width of the portion of the column that is currently scrolled out of view..
Public Property | FirstDisplayedScrollingColumnIndex | Gets or sets the index of the column that is the first column displayed on the DataGridView.
Public Property | FirstDisplayedScrollingRowIndex | Gets or sets the index of the row that is the first row displayed on the DataGridView.
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Overridden. Gets or sets the font of the text displayed by the DataGridView.
Public Property | ForeColor | Overridden. Gets or sets the foreground color of the DataGridView.
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | GridColor | Gets or sets the color of the grid lines separating the cells of the DataGridView.
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsCurrentCellDirty | Gets a value indicating whether the current cell has uncommitted changes.
Public Property | IsCurrentCellInEditMode | Gets a value indicating whether the currently active cell is being edited.
Public Property | IsCurrentRowDirty | Gets a value indicating whether the current row has uncommitted changes.
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | Item | Overloaded. Gets or sets the cell located at the intersection of the row with the specified index and the column with the specified name.
Public Property | ItemsPerPage | Gets or sets the current page.
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | LazyMode | Gets or sets a value indicating whether [lazy mode].
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MultiSelect | Gets or sets a value indicating whether the user is allowed to select more than one cell, row, or column of the DataGridView at a time.
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | NewRowIndex | Gets the index of the row for new records.
Public Property | PageFirstIndex | Gets the first item's index in the current page
Public Property | PageLastIndex | Gets the last item's index in the current page
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | ReadOnly | Gets a value indicating whether the user can edit the cells of the DataGridView control.
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | RowCount | Gets or sets the number of rows displayed in the DataGridView.
Public Property | RowHeadersBorderStyle | Gets or sets the border style of the row header cells.
Public Property | RowHeadersDefaultCellStyle | Gets or sets the default style applied to the row header cells.
Public Property | RowHeadersVisible | Gets or sets a value indicating whether the column that contains row headers is displayed.
Public Property | RowHeadersWidth | Gets or sets the width, in pixels, of the column that contains the row headers.
Public Property | RowHeadersWidthSizeMode | Gets or sets a value indicating whether the width of the row headers is adjustable and whether it can be adjusted by the user or is automatically adjusted to fit the contents of the headers.
Public Property | Rows | Gets a collection that contains all the rows in the DataGridView control.
Public Property | RowsDefaultCellStyle | Gets or sets the default style applied to the row cells of the DataGridView.
Public Property | RowTemplate | Gets or sets the row that represents the template for all the rows in the control.
Public Property | ScrollBars | Gets or sets the type of scroll bars to display for the DataGridView control.
Public Property | SelectedCells | Gets the collection of cells selected by the user.
Public Property | SelectedColumns | Gets the collection of columns selected by the user.
Public Property | SelectedRows | Gets the collection of rows selected by the user.
Public Property | SelectionMode | Gets or sets a value indicating how the cells of the DataGridView can be selected.
Public Property | ShowCellErrors | Gets or sets a value indicating whether to show cell errors.
Public Property | ShowCellToolTips | Gets or sets a value indicating whether or not ToolTips will show when the mouse pointer pauses on a cell.
Public Property | ShowEditingIcon | Gets or sets a value indicating whether or not the editing glyph is visible in the row header of the cell being edited.
Public Property | ShowRowErrors | Gets or sets a value indicating whether row headers will display error glyphs for each row that contains a data entry error.
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | SortedColumn | Gets the column by which the DataGridView contents are currently sorted.
Public Property | SortOrder | Gets a value indicating whether the items in the DataGridView control are sorted in ascending or descending order, or are not sorted.
Public Property | StandardTab | Gets or sets a value indicating whether the TAB key moves the focus to the next control in the tab order rather than moving focus to the next cell in the control.
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | TopLeftHeaderCell | Gets or sets the header cell located in the upper left corner of the DataGridView control.
Public Property | TotalItems | Gets or sets the total items.
Public Property | TotalPages | Gets or sets the total pages.
Public Property | UseInternalPaging | Uses internal paging algorithem
Public Property | UserSetCursor | Gets the default or user-specified value of the Control.Cursor property.
Public Property | VerticalScrollingOffset | Gets the number of pixels by which the control is scrolled vertically.
Public Property | VirtualMode | Gets or sets a value indicating whether you have provided your own data-management operations for the DataGridView control.
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | Overridden. Override the default back color
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | Overridden. Gets the default initial size of the control.
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | Overridden.
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

See Also

Reference

DataGridView Class
Gizmox.WebGUI.Forms Namespace


AdjustedTopLeftHeaderBorderStyle Property

[image]
Gizmox.WebGUI.Forms
AdjustedTopLeftHeaderBorderStyle Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : AdjustedTopLeftHeaderBorderStyle Property

Gets the border style for the upper-left cell in the DataGridView.

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public Overridable ReadOnly Property AdjustedTopLeftHeaderBorderStyle As DataGridViewAdvancedBorderStyle
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim value As DataGridViewAdvancedBorderStyle

value = instance.AdjustedTopLeftHeaderBorderStyle
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public virtual DataGridViewAdvancedBorderStyle AdjustedTopLeftHeaderBorderStyle {get;}
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property virtual DataGridViewAdvancedBorderStyle* get_AdjustedTopLeftHeaderBorderStyle();
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
virtual property DataGridViewAdvancedBorderStyle^ AdjustedTopLeftHeaderBorderStyle {
   DataGridViewAdvancedBorderStyle^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


AdvancedCellBorderStyle Property

[image]
Gizmox.WebGUI.Forms
AdvancedCellBorderStyle Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : AdvancedCellBorderStyle Property

Gets the border style of the cells in the DataGridView.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public ReadOnly Property AdvancedCellBorderStyle As DataGridViewAdvancedBorderStyle
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim value As DataGridViewAdvancedBorderStyle

value = instance.AdvancedCellBorderStyle
C#
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public DataGridViewAdvancedBorderStyle AdvancedCellBorderStyle {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: __property DataGridViewAdvancedBorderStyle* get_AdvancedCellBorderStyle();
C++/CLI
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
property DataGridViewAdvancedBorderStyle^ AdvancedCellBorderStyle {
   DataGridViewAdvancedBorderStyle^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


AdvancedColumnHeadersBorderStyle Property

[image]
Gizmox.WebGUI.Forms
AdvancedColumnHeadersBorderStyle Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : AdvancedColumnHeadersBorderStyle Property

Gets the border style of the column header cells in the DataGridView.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public ReadOnly Property AdvancedColumnHeadersBorderStyle As DataGridViewAdvancedBorderStyle
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim value As DataGridViewAdvancedBorderStyle

value = instance.AdvancedColumnHeadersBorderStyle
C#
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public DataGridViewAdvancedBorderStyle AdvancedColumnHeadersBorderStyle {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: __property DataGridViewAdvancedBorderStyle* get_AdvancedColumnHeadersBorderStyle();
C++/CLI
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
property DataGridViewAdvancedBorderStyle^ AdvancedColumnHeadersBorderStyle {
   DataGridViewAdvancedBorderStyle^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


AdvancedRowHeadersBorderStyle Property

[image]
Gizmox.WebGUI.Forms
AdvancedRowHeadersBorderStyle Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : AdvancedRowHeadersBorderStyle Property

Gets the border style of the row header cells in the DataGridView.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public ReadOnly Property AdvancedRowHeadersBorderStyle As DataGridViewAdvancedBorderStyle
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim value As DataGridViewAdvancedBorderStyle

value = instance.AdvancedRowHeadersBorderStyle
C#
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public DataGridViewAdvancedBorderStyle AdvancedRowHeadersBorderStyle {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: __property DataGridViewAdvancedBorderStyle* get_AdvancedRowHeadersBorderStyle();
C++/CLI
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
property DataGridViewAdvancedBorderStyle^ AdvancedRowHeadersBorderStyle {
   DataGridViewAdvancedBorderStyle^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


AllowUserToAddRows Property

[image]
Gizmox.WebGUI.Forms
AllowUserToAddRows Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : AllowUserToAddRows Property

Gets or sets a value indicating whether the option to add rows is displayed to the user.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Indicates whether the option to add rows is displayed to the user.")>
<DefaultValueAttribute()>
<SRCategoryAttribute("Behavior")>
Public Property AllowUserToAddRows As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim value As Boolean

instance.AllowUserToAddRows = value

value = instance.AllowUserToAddRows
C#
[SRDescriptionAttribute("Indicates whether the option to add rows is displayed to the user.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
public bool AllowUserToAddRows {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Indicates whether the option to add rows is displayed to the user.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
public: __property bool get_AllowUserToAddRows();
public: __property void set_AllowUserToAddRows(
   bool value
);
C++/CLI
[SRDescriptionAttribute("Indicates whether the option to add rows is displayed to the user.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
public:
property bool AllowUserToAddRows {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


AllowUserToDeleteRows Property

[image]
Gizmox.WebGUI.Forms
AllowUserToDeleteRows Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : AllowUserToDeleteRows Property

Gets or sets a value indicating whether the user is allowed to delete rows from the DataGridView.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Behavior")>
<DefaultValueAttribute()>
<SRDescriptionAttribute("Indicates whether the user is allowed to delete rows from the DataGridView.")>
Public Property AllowUserToDeleteRows As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim value As Boolean

instance.AllowUserToDeleteRows = value

value = instance.AllowUserToDeleteRows
C#
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Indicates whether the user is allowed to delete rows from the DataGridView.")]
public bool AllowUserToDeleteRows {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Indicates whether the user is allowed to delete rows from the DataGridView.")]
public: __property bool get_AllowUserToDeleteRows();
public: __property void set_AllowUserToDeleteRows(
   bool value
);
C++/CLI
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Indicates whether the user is allowed to delete rows from the DataGridView.")]
public:
property bool AllowUserToDeleteRows {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


AllowUserToOrderColumns Property

[image]
Gizmox.WebGUI.Forms
AllowUserToOrderColumns Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : AllowUserToOrderColumns Property

Gets or sets a value indicating whether manual column repositioning is enabled.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Indicates whether manual column repositioning is enabled. ")>
<SRCategoryAttribute("Behavior")>
<DefaultValueAttribute()>
Public Property AllowUserToOrderColumns As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim value As Boolean

instance.AllowUserToOrderColumns = value

value = instance.AllowUserToOrderColumns
C#
[SRDescriptionAttribute("Indicates whether manual column repositioning is enabled. ")]
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
public bool AllowUserToOrderColumns {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Indicates whether manual column repositioning is enabled. ")]
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
public: __property bool get_AllowUserToOrderColumns();
public: __property void set_AllowUserToOrderColumns(
   bool value
);
C++/CLI
[SRDescriptionAttribute("Indicates whether manual column repositioning is enabled. ")]
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
public:
property bool AllowUserToOrderColumns {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


AllowUserToResizeColumns Property

[image]
Gizmox.WebGUI.Forms
AllowUserToResizeColumns Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : AllowUserToResizeColumns Property

Gets or sets a value indicating whether users can resize columns.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Indicates whether users can resize columns.")>
<DefaultValueAttribute()>
<SRCategoryAttribute("Behavior")>
Public Property AllowUserToResizeColumns As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim value As Boolean

instance.AllowUserToResizeColumns = value

value = instance.AllowUserToResizeColumns
C#
[SRDescriptionAttribute("Indicates whether users can resize columns.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
public bool AllowUserToResizeColumns {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Indicates whether users can resize columns.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
public: __property bool get_AllowUserToResizeColumns();
public: __property void set_AllowUserToResizeColumns(
   bool value
);
C++/CLI
[SRDescriptionAttribute("Indicates whether users can resize columns.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
public:
property bool AllowUserToResizeColumns {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


AllowUserToResizeRows Property

[image]
Gizmox.WebGUI.Forms
AllowUserToResizeRows Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : AllowUserToResizeRows Property

Gets or sets a value indicating whether users can resize rows.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Behavior")>
<SRDescriptionAttribute("Indicates whether users can resize rows.")>
<DefaultValueAttribute()>
Public Property AllowUserToResizeRows As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim value As Boolean

instance.AllowUserToResizeRows = value

value = instance.AllowUserToResizeRows
C#
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Indicates whether users can resize rows.")]
[DefaultValueAttribute()]
public bool AllowUserToResizeRows {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Indicates whether users can resize rows.")]
[DefaultValueAttribute()]
public: __property bool get_AllowUserToResizeRows();
public: __property void set_AllowUserToResizeRows(
   bool value
);
C++/CLI
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Indicates whether users can resize rows.")]
[DefaultValueAttribute()]
public:
property bool AllowUserToResizeRows {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


AlternatingRowsDefaultCellStyle Property

[image]
Gizmox.WebGUI.Forms
AlternatingRowsDefaultCellStyle Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : AlternatingRowsDefaultCellStyle Property

Gets or sets the default cell style applied to odd-numbered rows of the DataGridView.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("The default cell style applied to odd-numbered rows. ")>
<SRCategoryAttribute("Appearance")>
Public Property AlternatingRowsDefaultCellStyle As DataGridViewCellStyle
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim value As DataGridViewCellStyle

instance.AlternatingRowsDefaultCellStyle = value

value = instance.AlternatingRowsDefaultCellStyle
C#
[SRDescriptionAttribute("The default cell style applied to odd-numbered rows. ")]
[SRCategoryAttribute("Appearance")]
public DataGridViewCellStyle AlternatingRowsDefaultCellStyle {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("The default cell style applied to odd-numbered rows. ")]
[SRCategoryAttribute("Appearance")]
public: __property DataGridViewCellStyle* get_AlternatingRowsDefaultCellStyle();
public: __property void set_AlternatingRowsDefaultCellStyle(
   DataGridViewCellStyle* value
);
C++/CLI
[SRDescriptionAttribute("The default cell style applied to odd-numbered rows. ")]
[SRCategoryAttribute("Appearance")]
public:
property DataGridViewCellStyle^ AlternatingRowsDefaultCellStyle {
   DataGridViewCellStyle^ get();
   void set (DataGridViewCellStyle^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


AutoGenerateColumns Property

[image]
Gizmox.WebGUI.Forms
AutoGenerateColumns Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : AutoGenerateColumns Property

Gets or sets a value indicating whether columns are created automatically when the DataSource or DataMember properties are set.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<BrowsableAttribute(False)>
Public Property AutoGenerateColumns As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim value As Boolean

instance.AutoGenerateColumns = value

value = instance.AutoGenerateColumns
C#
[DefaultValueAttribute()]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[BrowsableAttribute(false)]
public bool AutoGenerateColumns {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[BrowsableAttribute(false)]
public: __property bool get_AutoGenerateColumns();
public: __property void set_AutoGenerateColumns(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[BrowsableAttribute(false)]
public:
property bool AutoGenerateColumns {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


AutoSizeColumnsMode Property

[image]
Gizmox.WebGUI.Forms
AutoSizeColumnsMode Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : AutoSizeColumnsMode Property

Gets or sets a value indicating how column widths are determined.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Layout")>
<SRDescriptionAttribute("Determines the auto size mode for the visible columns.")>
<DefaultValueAttribute()>
Public Property AutoSizeColumnsMode As DataGridViewAutoSizeColumnsMode
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim value As DataGridViewAutoSizeColumnsMode

instance.AutoSizeColumnsMode = value

value = instance.AutoSizeColumnsMode
C#
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Determines the auto size mode for the visible columns.")]
[DefaultValueAttribute()]
public DataGridViewAutoSizeColumnsMode AutoSizeColumnsMode {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Determines the auto size mode for the visible columns.")]
[DefaultValueAttribute()]
public: __property DataGridViewAutoSizeColumnsMode get_AutoSizeColumnsMode();
public: __property void set_AutoSizeColumnsMode(
   DataGridViewAutoSizeColumnsMode value
);
C++/CLI
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Determines the auto size mode for the visible columns.")]
[DefaultValueAttribute()]
public:
property DataGridViewAutoSizeColumnsMode AutoSizeColumnsMode {
   DataGridViewAutoSizeColumnsMode get();
   void set (DataGridViewAutoSizeColumnsModevalue);
}

Exceptions

Exception | Description
InvalidEnumArgumentException | The specified value when setting this property is not a valid DataGridViewAutoSizeColumnsMode value.
InvalidOperationException | The specified value when setting this property is DataGridViewAutoSizeColumnsMode.ColumnHeader, column headers are hidden, and at least one visible column has an DataGridViewColumn.AutoSizeMode property value of DataGridViewAutoSizeColumnMode.NotSet.-or-The specified value when setting this property is DataGridViewAutoSizeColumnsMode.Fill and at least one visible column with an DataGridViewColumn.AutoSizeMode property value of DataGridViewAutoSizeColumnMode.NotSet is frozen.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


AutoSizeRowsMode Property

[image]
Gizmox.WebGUI.Forms
AutoSizeRowsMode Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : AutoSizeRowsMode Property

Gets or sets a value indicating how row heights are determined.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Layout")>
<SRDescriptionAttribute("Determines the auto size mode for the visible rows.")>
<DefaultValueAttribute()>
Public Property AutoSizeRowsMode As DataGridViewAutoSizeRowsMode
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim value As DataGridViewAutoSizeRowsMode

instance.AutoSizeRowsMode = value

value = instance.AutoSizeRowsMode
C#
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Determines the auto size mode for the visible rows.")]
[DefaultValueAttribute()]
public DataGridViewAutoSizeRowsMode AutoSizeRowsMode {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Determines the auto size mode for the visible rows.")]
[DefaultValueAttribute()]
public: __property DataGridViewAutoSizeRowsMode get_AutoSizeRowsMode();
public: __property void set_AutoSizeRowsMode(
   DataGridViewAutoSizeRowsMode value
);
C++/CLI
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Determines the auto size mode for the visible rows.")]
[DefaultValueAttribute()]
public:
property DataGridViewAutoSizeRowsMode AutoSizeRowsMode {
   DataGridViewAutoSizeRowsMode get();
   void set (DataGridViewAutoSizeRowsModevalue);
}

Exceptions

Exception | Description
InvalidOperationException | The specified value when setting this property is DataGridViewAutoSizeRowsMode.AllHeaders or DataGridViewAutoSizeRowsMode.DisplayedHeaders and row headers are hidden.
InvalidEnumArgumentException | The specified value when setting this property is not a valid DataGridViewAutoSizeRowsMode value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


BackgroundColor Property

[image]
Gizmox.WebGUI.Forms
BackgroundColor Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : BackgroundColor Property

Gets or sets the background color of the DataGridView.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Appearance")>
<SRDescriptionAttribute("The background color of the DataGridView.")>
Public Property BackgroundColor As Color
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim value As Color

instance.BackgroundColor = value

value = instance.BackgroundColor
C#
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("The background color of the DataGridView.")]
public Color BackgroundColor {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("The background color of the DataGridView.")]
public: __property Color get_BackgroundColor();
public: __property void set_BackgroundColor(
   Color value
);
C++/CLI
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("The background color of the DataGridView.")]
public:
property Color BackgroundColor {
   Color get();
   void set (Colorvalue);
}

Exceptions

Exception | Description
ArgumentException | The specified value when setting this property is Empty. -or-The specified value when setting this property has a A property value that is less that 255.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


BorderStyle Property

[image]
Gizmox.WebGUI.Forms
BorderStyle Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : BorderStyle Property

Gets or sets the border style for the DataGridView.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Appearance")>
<SRDescriptionAttribute("The border style for the DataGridView.")>
<DefaultValueAttribute()>
Public Overrides Property BorderStyle As BorderStyle
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim value As BorderStyle

instance.BorderStyle = value

value = instance.BorderStyle
C#
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("The border style for the DataGridView.")]
[DefaultValueAttribute()]
public override BorderStyle BorderStyle {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("The border style for the DataGridView.")]
[DefaultValueAttribute()]
public: __property BorderStyle get_BorderStyle() override;
public: __property void set_BorderStyle(
   BorderStyle value
) override;
C++/CLI
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("The border style for the DataGridView.")]
[DefaultValueAttribute()]
public:
property BorderStyle BorderStyle {
   BorderStyle get() override;
   void set (BorderStylevalue) override;
}

Exceptions

Exception | Description
InvalidEnumArgumentException | The specified value when setting this property is not a valid BorderStyle value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


CellBorderStyle Property

[image]
Gizmox.WebGUI.Forms
CellBorderStyle Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : CellBorderStyle Property

Gets the cell border style for the DataGridView.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Appearance")>
<DefaultValueAttribute()>
<SRDescriptionAttribute("The cell border style for the DataGridView.")>
<BrowsableAttribute(True)>
Public Property CellBorderStyle As DataGridViewCellBorderStyle
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim value As DataGridViewCellBorderStyle

instance.CellBorderStyle = value

value = instance.CellBorderStyle
C#
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("The cell border style for the DataGridView.")]
[BrowsableAttribute(true)]
public DataGridViewCellBorderStyle CellBorderStyle {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("The cell border style for the DataGridView.")]
[BrowsableAttribute(true)]
public: __property DataGridViewCellBorderStyle get_CellBorderStyle();
public: __property void set_CellBorderStyle(
   DataGridViewCellBorderStyle value
);
C++/CLI
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("The cell border style for the DataGridView.")]
[BrowsableAttribute(true)]
public:
property DataGridViewCellBorderStyle CellBorderStyle {
   DataGridViewCellBorderStyle get();
   void set (DataGridViewCellBorderStylevalue);
}

Exceptions

Exception | Description
InvalidEnumArgumentException | The specified value when setting this property is not a valid DataGridViewCellBorderStyle value.
ArgumentException | The specified value when setting this property is DataGridViewCellBorderStyle.Custom.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


ClipboardCopyMode Property

[image]
Gizmox.WebGUI.Forms
ClipboardCopyMode Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : ClipboardCopyMode Property

Gets or sets a value that indicates whether users can copy cell text values to the Clipboard and whether row and column header text is included.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<BrowsableAttribute(True)>
<SRDescriptionAttribute("Indicates whether users can copy cell text values to the Clipboard and whether row and column header text is included.")>
<SRCategoryAttribute("Behavior")>
Public Property ClipboardCopyMode As DataGridViewClipboardCopyMode
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim value As DataGridViewClipboardCopyMode

instance.ClipboardCopyMode = value

value = instance.ClipboardCopyMode
C#
[DefaultValueAttribute()]
[BrowsableAttribute(true)]
[SRDescriptionAttribute("Indicates whether users can copy cell text values to the Clipboard and whether row and column header text is included.")]
[SRCategoryAttribute("Behavior")]
public DataGridViewClipboardCopyMode ClipboardCopyMode {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[BrowsableAttribute(true)]
[SRDescriptionAttribute("Indicates whether users can copy cell text values to the Clipboard and whether row and column header text is included.")]
[SRCategoryAttribute("Behavior")]
public: __property DataGridViewClipboardCopyMode get_ClipboardCopyMode();
public: __property void set_ClipboardCopyMode(
   DataGridViewClipboardCopyMode value
);
C++/CLI
[DefaultValueAttribute()]
[BrowsableAttribute(true)]
[SRDescriptionAttribute("Indicates whether users can copy cell text values to the Clipboard and whether row and column header text is included.")]
[SRCategoryAttribute("Behavior")]
public:
property DataGridViewClipboardCopyMode ClipboardCopyMode {
   DataGridViewClipboardCopyMode get();
   void set (DataGridViewClipboardCopyModevalue);
}

Exceptions

Exception | Description
InvalidEnumArgumentException | The specified value when setting this property is not a valid DataGridViewClipboardCopyMode value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


ColumnCount Property

[image]
Gizmox.WebGUI.Forms
ColumnCount Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : ColumnCount Property

Gets or sets the number of columns displayed in the DataGridView.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Property ColumnCount As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim value As Integer

instance.ColumnCount = value

value = instance.ColumnCount
C#
[DefaultValueAttribute()]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public int ColumnCount {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: __property int get_ColumnCount();
public: __property void set_ColumnCount(
   int value
);
C++/CLI
[DefaultValueAttribute()]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
property int ColumnCount {
   int get();
   void set (intvalue);
}

Exceptions

Exception | Description
InvalidOperationException | When setting this property, the DataSource property has been set.
ArgumentOutOfRangeException | The specified value when setting this property is less than 0.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


ColumnHeadersBorderStyle Property

[image]
Gizmox.WebGUI.Forms
ColumnHeadersBorderStyle Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : ColumnHeadersBorderStyle Property

Gets the border style applied to the column headers.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(True)>
<SRDescriptionAttribute("The border style applied to the column headers.")>
<SRCategoryAttribute("Appearance")>
<DefaultValueAttribute()>
Public Property ColumnHeadersBorderStyle As DataGridViewHeaderBorderStyle
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim value As DataGridViewHeaderBorderStyle

instance.ColumnHeadersBorderStyle = value

value = instance.ColumnHeadersBorderStyle
C#
[BrowsableAttribute(true)]
[SRDescriptionAttribute("The border style applied to the column headers.")]
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
public DataGridViewHeaderBorderStyle ColumnHeadersBorderStyle {get; set;}
Managed Extensions for C++
[BrowsableAttribute(true)]
[SRDescriptionAttribute("The border style applied to the column headers.")]
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
public: __property DataGridViewHeaderBorderStyle get_ColumnHeadersBorderStyle();
public: __property void set_ColumnHeadersBorderStyle(
   DataGridViewHeaderBorderStyle value
);
C++/CLI
[BrowsableAttribute(true)]
[SRDescriptionAttribute("The border style applied to the column headers.")]
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
public:
property DataGridViewHeaderBorderStyle ColumnHeadersBorderStyle {
   DataGridViewHeaderBorderStyle get();
   void set (DataGridViewHeaderBorderStylevalue);
}

Exceptions

Exception | Description
ArgumentException | The specified value when setting this property is DataGridViewHeaderBorderStyle.Custom.
InvalidEnumArgumentException | The specified value when setting this property is not a valid DataGridViewHeaderBorderStyle value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


ColumnHeadersDefaultCellStyle Property

[image]
Gizmox.WebGUI.Forms
ColumnHeadersDefaultCellStyle Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : ColumnHeadersDefaultCellStyle Property

Gets or sets the default column header style.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("The default column header style.")>
<SRCategoryAttribute("Appearance")>
<AmbientValueAttribute()>
Public Property ColumnHeadersDefaultCellStyle As DataGridViewCellStyle
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim value As DataGridViewCellStyle

instance.ColumnHeadersDefaultCellStyle = value

value = instance.ColumnHeadersDefaultCellStyle
C#
[SRDescriptionAttribute("The default column header style.")]
[SRCategoryAttribute("Appearance")]
[AmbientValueAttribute()]
public DataGridViewCellStyle ColumnHeadersDefaultCellStyle {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("The default column header style.")]
[SRCategoryAttribute("Appearance")]
[AmbientValueAttribute()]
public: __property DataGridViewCellStyle* get_ColumnHeadersDefaultCellStyle();
public: __property void set_ColumnHeadersDefaultCellStyle(
   DataGridViewCellStyle* value
);
C++/CLI
[SRDescriptionAttribute("The default column header style.")]
[SRCategoryAttribute("Appearance")]
[AmbientValueAttribute()]
public:
property DataGridViewCellStyle^ ColumnHeadersDefaultCellStyle {
   DataGridViewCellStyle^ get();
   void set (DataGridViewCellStyle^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


ColumnHeadersHeight Property

[image]
Gizmox.WebGUI.Forms
ColumnHeadersHeight Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : ColumnHeadersHeight Property

Gets or sets the height, in pixels, of the column headers row

Syntax

Visual Basic (Declaration)
<LocalizableAttribute(True)>
<SRCategoryAttribute("Appearance")>
<SRDescriptionAttribute("The height, in pixels, of the column headers row. ")>
Public Property ColumnHeadersHeight As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim value As Integer

instance.ColumnHeadersHeight = value

value = instance.ColumnHeadersHeight
C#
[LocalizableAttribute(true)]
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("The height, in pixels, of the column headers row. ")]
public int ColumnHeadersHeight {get; set;}
Managed Extensions for C++
[LocalizableAttribute(true)]
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("The height, in pixels, of the column headers row. ")]
public: __property int get_ColumnHeadersHeight();
public: __property void set_ColumnHeadersHeight(
   int value
);
C++/CLI
[LocalizableAttribute(true)]
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("The height, in pixels, of the column headers row. ")]
public:
property int ColumnHeadersHeight {
   int get();
   void set (intvalue);
}

Exceptions

Exception | Description
ArgumentOutOfRangeException | The specified value when setting this property is less than the minimum height of 4 pixels or is greater than the maximum height of 32768 pixels.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


ColumnHeadersHeightSizeMode Property

[image]
Gizmox.WebGUI.Forms
ColumnHeadersHeightSizeMode Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : ColumnHeadersHeightSizeMode Property

Gets or sets a value indicating whether the height of the column headers is adjustable and whether it can be adjusted by the user or is automatically adjusted to fit the contents of the headers.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Determines the behavior for adjusting the column headers height.")>
<DefaultValueAttribute()>
<RefreshPropertiesAttribute()>
<SRCategoryAttribute("Behavior")>
Public Property ColumnHeadersHeightSizeMode As DataGridViewColumnHeadersHeightSizeMode
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim value As DataGridViewColumnHeadersHeightSizeMode

instance.ColumnHeadersHeightSizeMode = value

value = instance.ColumnHeadersHeightSizeMode
C#
[SRDescriptionAttribute("Determines the behavior for adjusting the column headers height.")]
[DefaultValueAttribute()]
[RefreshPropertiesAttribute()]
[SRCategoryAttribute("Behavior")]
public DataGridViewColumnHeadersHeightSizeMode ColumnHeadersHeightSizeMode {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Determines the behavior for adjusting the column headers height.")]
[DefaultValueAttribute()]
[RefreshPropertiesAttribute()]
[SRCategoryAttribute("Behavior")]
public: __property DataGridViewColumnHeadersHeightSizeMode get_ColumnHeadersHeightSizeMode();
public: __property void set_ColumnHeadersHeightSizeMode(
   DataGridViewColumnHeadersHeightSizeMode value
);
C++/CLI
[SRDescriptionAttribute("Determines the behavior for adjusting the column headers height.")]
[DefaultValueAttribute()]
[RefreshPropertiesAttribute()]
[SRCategoryAttribute("Behavior")]
public:
property DataGridViewColumnHeadersHeightSizeMode ColumnHeadersHeightSizeMode {
   DataGridViewColumnHeadersHeightSizeMode get();
   void set (DataGridViewColumnHeadersHeightSizeModevalue);
}

Exceptions

Exception | Description
InvalidEnumArgumentException | The specified value when setting this property is not a valid DataGridViewColumnHeadersHeightSizeMode value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


ColumnHeadersVisible Property

[image]
Gizmox.WebGUI.Forms
ColumnHeadersVisible Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : ColumnHeadersVisible Property

Gets or sets a value indicating whether the column header row is displayed.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Appearance")>
<SRDescriptionAttribute("Indicates whether the column headers row is displayed.")>
<DefaultValueAttribute()>
Public Property ColumnHeadersVisible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim value As Boolean

instance.ColumnHeadersVisible = value

value = instance.ColumnHeadersVisible
C#
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Indicates whether the column headers row is displayed.")]
[DefaultValueAttribute()]
public bool ColumnHeadersVisible {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Indicates whether the column headers row is displayed.")]
[DefaultValueAttribute()]
public: __property bool get_ColumnHeadersVisible();
public: __property void set_ColumnHeadersVisible(
   bool value
);
C++/CLI
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Indicates whether the column headers row is displayed.")]
[DefaultValueAttribute()]
public:
property bool ColumnHeadersVisible {
   bool get();
   void set (boolvalue);
}

Exceptions

Exception | Description
InvalidOperationException | The specified value when setting this property is false and one or more columns have an DataGridViewColumn.InheritedAutoSizeMode property value of DataGridViewAutoSizeColumnMode.ColumnHeader.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


Columns Property

[image]
Gizmox.WebGUI.Forms
Columns Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : Columns Property

Gets a collection that contains all the columns in the control.

Syntax

Visual Basic (Declaration)
<EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.DataGridViewColumnCollectionEditor, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<MergablePropertyAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public ReadOnly Property Columns As DataGridViewColumnCollection
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim value As DataGridViewColumnCollection

value = instance.Columns
C#
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.DataGridViewColumnCollectionEditor, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[MergablePropertyAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public DataGridViewColumnCollection Columns {get;}
Managed Extensions for C++
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.DataGridViewColumnCollectionEditor, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[MergablePropertyAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property DataGridViewColumnCollection* get_Columns();
C++/CLI
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.DataGridViewColumnCollectionEditor, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[MergablePropertyAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
property DataGridViewColumnCollection^ Columns {
   DataGridViewColumnCollection^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


CurrentCell Property

[image]
Gizmox.WebGUI.Forms
CurrentCell Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : CurrentCell Property

Gets or sets the currently active cell.

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
Public Property CurrentCell As DataGridViewCell
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim value As DataGridViewCell

instance.CurrentCell = value

value = instance.CurrentCell
C#
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public DataGridViewCell CurrentCell {get; set;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public: __property DataGridViewCell* get_CurrentCell();
public: __property void set_CurrentCell(
   DataGridViewCell* value
);
C++/CLI
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public:
property DataGridViewCell^ CurrentCell {
   DataGridViewCell^ get();
   void set (DataGridViewCell^value);
}

Exceptions

Exception | Description
ArgumentException | The specified cell when setting this property is not in the DataGridView.
InvalidOperationException | The value of this property cannot be set because changes to the current cell cannot be committed or canceled.-or-The specified cell when setting this property is in a hidden row or column.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


CurrentCellAddress Property

[image]
Gizmox.WebGUI.Forms
CurrentCellAddress Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : CurrentCellAddress Property

Gets the row and column indexes of the currently active cell.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property CurrentCellAddress As Point
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim value As Point

value = instance.CurrentCellAddress
C#
[BrowsableAttribute(false)]
public Point CurrentCellAddress {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property Point get_CurrentCellAddress();
C++/CLI
[BrowsableAttribute(false)]
public:
property Point CurrentCellAddress {
   Point get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


CurrentPage Property

[image]
Gizmox.WebGUI.Forms
CurrentPage Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : CurrentPage Property

Gets or sets the current page.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property CurrentPage As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim value As Integer

instance.CurrentPage = value

value = instance.CurrentPage
C#
[DefaultValueAttribute()]
public int CurrentPage {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property int get_CurrentPage();
public: __property void set_CurrentPage(
   int value
);
C++/CLI
[DefaultValueAttribute()]
public:
property int CurrentPage {
   int get();
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


CurrentRow Property

[image]
Gizmox.WebGUI.Forms
CurrentRow Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : CurrentRow Property

Gets the row containing the current cell.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property CurrentRow As DataGridViewRow
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim value As DataGridViewRow

value = instance.CurrentRow
C#
[BrowsableAttribute(false)]
public DataGridViewRow CurrentRow {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property DataGridViewRow* get_CurrentRow();
C++/CLI
[BrowsableAttribute(false)]
public:
property DataGridViewRow^ CurrentRow {
   DataGridViewRow^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


DataMember Property

[image]
Gizmox.WebGUI.Forms
DataMember Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : DataMember Property

Gets or sets the name of the list or table in the data source for which the DataGridView is displaying data.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Indicates a sub-list of the DataSource to show in the DataGridView control.")>
<EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.DataMemberListEditor, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<DefaultValueAttribute()>
<SRCategoryAttribute("Data")>
Public Property DataMember As String
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim value As String

instance.DataMember = value

value = instance.DataMember
C#
[SRDescriptionAttribute("Indicates a sub-list of the DataSource to show in the DataGridView control.")]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.DataMemberListEditor, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Data")]
public string DataMember {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Indicates a sub-list of the DataSource to show in the DataGridView control.")]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.DataMemberListEditor, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Data")]
public: __property string* get_DataMember();
public: __property void set_DataMember(
   string* value
);
C++/CLI
[SRDescriptionAttribute("Indicates a sub-list of the DataSource to show in the DataGridView control.")]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.DataMemberListEditor, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Data")]
public:
property String^ DataMember {
   String^ get();
   void set (String^value);
}

Exceptions

Exception | Description
Exception | An error occurred in the data source and either there is no handler for the DataError event or the handler has set the DataGridViewDataErrorEventArgs.ThrowException property to true. The exception object can typically be cast to type FormatException.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


DataSource Property

[image]
Gizmox.WebGUI.Forms
DataSource Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : DataSource Property

Gets or sets the data source that the DataGridView is displaying data for.

Syntax

Visual Basic (Declaration)
<RefreshPropertiesAttribute()>
<SRDescriptionAttribute("Indicates the source of data for the DataGridView control.")>
<DefaultValueAttribute()>
<SRCategoryAttribute("Data")>
<AttributeProviderAttribute(TypeName="Gizmox.WebGUI.Forms.Binding+IDataSourceAttributeProvider, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d", PropertyName="")>
Public Property DataSource As Object
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim value As Object

instance.DataSource = value

value = instance.DataSource
C#
[RefreshPropertiesAttribute()]
[SRDescriptionAttribute("Indicates the source of data for the DataGridView control.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Data")]
[AttributeProviderAttribute(TypeName="Gizmox.WebGUI.Forms.Binding+IDataSourceAttributeProvider, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d", PropertyName="")]
public object DataSource {get; set;}
Managed Extensions for C++
[RefreshPropertiesAttribute()]
[SRDescriptionAttribute("Indicates the source of data for the DataGridView control.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Data")]
[AttributeProviderAttribute(TypeName="Gizmox.WebGUI.Forms.Binding+IDataSourceAttributeProvider, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d", PropertyName="")]
public: __property Object* get_DataSource();
public: __property void set_DataSource(
   Object* value
);
C++/CLI
[RefreshPropertiesAttribute()]
[SRDescriptionAttribute("Indicates the source of data for the DataGridView control.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Data")]
[AttributeProviderAttribute(TypeName="Gizmox.WebGUI.Forms.Binding+IDataSourceAttributeProvider, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d", PropertyName="")]
public:
property Object^ DataSource {
   Object^ get();
   void set (Object^value);
}

Exceptions

Exception | Description
Exception | An error occurred in the data source and either there is no handler for the DataError event or the handler has set the DataGridViewDataErrorEventArgs.ThrowException property to true. The exception object can typically be cast to type FormatException.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


DefaultBackColor Property

[image]
Gizmox.WebGUI.Forms
DefaultBackColor Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : DefaultBackColor Property

Override the default back color

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property DefaultBackColor As Color
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim value As Color

value = instance.DefaultBackColor
C#
protected override Color DefaultBackColor {get;}
Managed Extensions for C++
protected: __property Color get_DefaultBackColor() override;
C++/CLI
protected:
property Color DefaultBackColor {
   Color get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


DefaultCellStyle Property

[image]
Gizmox.WebGUI.Forms
DefaultCellStyle Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : DefaultCellStyle Property

Gets or sets the default cell style to be applied to the cells in the DataGridView if no other cell style properties are set.

Syntax

Visual Basic (Declaration)
<AmbientValueAttribute()>
<SRCategoryAttribute("Appearance")>
<SRDescriptionAttribute("The DataGridViewBand.DefaultCellStyle to be applied to the DataGridView if no other style is set.")>
Public Property DefaultCellStyle As DataGridViewCellStyle
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim value As DataGridViewCellStyle

instance.DefaultCellStyle = value

value = instance.DefaultCellStyle
C#
[AmbientValueAttribute()]
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("The DataGridViewBand.DefaultCellStyle to be applied to the DataGridView if no other style is set.")]
public DataGridViewCellStyle DefaultCellStyle {get; set;}
Managed Extensions for C++
[AmbientValueAttribute()]
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("The DataGridViewBand.DefaultCellStyle to be applied to the DataGridView if no other style is set.")]
public: __property DataGridViewCellStyle* get_DefaultCellStyle();
public: __property void set_DefaultCellStyle(
   DataGridViewCellStyle* value
);
C++/CLI
[AmbientValueAttribute()]
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("The DataGridViewBand.DefaultCellStyle to be applied to the DataGridView if no other style is set.")]
public:
property DataGridViewCellStyle^ DefaultCellStyle {
   DataGridViewCellStyle^ get();
   void set (DataGridViewCellStyle^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


DefaultSize Property

[image]
Gizmox.WebGUI.Forms
DefaultSize Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : DefaultSize Property

Gets the default initial size of the control.

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property DefaultSize As Size
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim value As Size

value = instance.DefaultSize
C#
protected override Size DefaultSize {get;}
Managed Extensions for C++
protected: __property Size get_DefaultSize() override;
C++/CLI
protected:
property Size DefaultSize {
   Size get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


DisableNavigation Property

[image]
Gizmox.WebGUI.Forms
DisableNavigation Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : DisableNavigation Property

Gets or sets a value indicating whether [disable navigation].

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Indicates whether to disable default grid navigation.")>
<SRCategoryAttribute("Behavior")>
<DefaultValueAttribute()>
Public Property DisableNavigation As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim value As Boolean

instance.DisableNavigation = value

value = instance.DisableNavigation
C#
[SRDescriptionAttribute("Indicates whether to disable default grid navigation.")]
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
public bool DisableNavigation {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Indicates whether to disable default grid navigation.")]
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
public: __property bool get_DisableNavigation();
public: __property void set_DisableNavigation(
   bool value
);
C++/CLI
[SRDescriptionAttribute("Indicates whether to disable default grid navigation.")]
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
public:
property bool DisableNavigation {
   bool get();
   void set (boolvalue);
}

Return Value

true if [disable navigation]; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


DragTargets Property

[image]
Gizmox.WebGUI.Forms
DragTargets Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : DragTargets Property

Gets a value indicating whether this instance is dragable.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property DragTargets As Component()
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim value() As Component

value = instance.DragTargets
C#
public override Component[] DragTargets {get;}
Managed Extensions for C++
public: __property Component*[]* get_DragTargets() override;
C++/CLI
public:
property array<Component^>^ DragTargets {
   array<Component^>^ get() override;
}

Return Value

true if this instance is dragable; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


EditingControl Property

[image]
Gizmox.WebGUI.Forms
EditingControl Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : EditingControl Property

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public ReadOnly Property EditingControl As Control
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim value As Control

value = instance.EditingControl
C#
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public Control EditingControl {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: __property Control* get_EditingControl();
C++/CLI
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
property Control^ EditingControl {
   Control^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


EditingPanel Property

[image]
Gizmox.WebGUI.Forms
EditingPanel Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : EditingPanel Property

Gets the panel that contains the EditingControl.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public ReadOnly Property EditingPanel As Panel
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim value As Panel

value = instance.EditingPanel
C#
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public Panel EditingPanel {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: __property Panel* get_EditingPanel();
C++/CLI
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
property Panel^ EditingPanel {
   Panel^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


EditMode Property

[image]
Gizmox.WebGUI.Forms
EditMode Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : EditMode Property

Gets or sets a value indicating how to begin editing a cell.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<SRDescriptionAttribute("Identifies the mode that determines how cell editing is started.")>
<SRCategoryAttribute("Behavior")>
Public Property EditMode As DataGridViewEditMode
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim value As DataGridViewEditMode

instance.EditMode = value

value = instance.EditMode
C#
[DefaultValueAttribute()]
[SRDescriptionAttribute("Identifies the mode that determines how cell editing is started.")]
[SRCategoryAttribute("Behavior")]
public DataGridViewEditMode EditMode {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[SRDescriptionAttribute("Identifies the mode that determines how cell editing is started.")]
[SRCategoryAttribute("Behavior")]
public: __property DataGridViewEditMode get_EditMode();
public: __property void set_EditMode(
   DataGridViewEditMode value
);
C++/CLI
[DefaultValueAttribute()]
[SRDescriptionAttribute("Identifies the mode that determines how cell editing is started.")]
[SRCategoryAttribute("Behavior")]
public:
property DataGridViewEditMode EditMode {
   DataGridViewEditMode get();
   void set (DataGridViewEditModevalue);
}

Exceptions

Exception | Description
InvalidEnumArgumentException | The specified value when setting this property is not a valid DataGridViewEditMode value.
Exception | The specified value when setting this property would cause the control to enter edit mode, but initialization of the editing cell value failed and either there is no handler for the DataError event or the handler has set the DataGridViewDataErrorEventArgs.ThrowException property to true. The exception object can typically be cast to type FormatException.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


EnableHeadersVisualStyles Property

[image]
Gizmox.WebGUI.Forms
EnableHeadersVisualStyles Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : EnableHeadersVisualStyles Property

Gets or sets a value indicating whether row and column headers use the visual styles of the user's current theme if visual styles are enabled for the application.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Indicates whether row and column headers use the visual styles of the user's current theme if visual styles are enabled for the application.")>
<SRCategoryAttribute("Appearance")>
<DefaultValueAttribute()>
Public Property EnableHeadersVisualStyles As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim value As Boolean

instance.EnableHeadersVisualStyles = value

value = instance.EnableHeadersVisualStyles
C#
[SRDescriptionAttribute("Indicates whether row and column headers use the visual styles of the user's current theme if visual styles are enabled for the application.")]
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
public bool EnableHeadersVisualStyles {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Indicates whether row and column headers use the visual styles of the user's current theme if visual styles are enabled for the application.")]
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
public: __property bool get_EnableHeadersVisualStyles();
public: __property void set_EnableHeadersVisualStyles(
   bool value
);
C++/CLI
[SRDescriptionAttribute("Indicates whether row and column headers use the visual styles of the user's current theme if visual styles are enabled for the application.")]
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
public:
property bool EnableHeadersVisualStyles {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


FirstDisplayedCell Property

[image]
Gizmox.WebGUI.Forms
FirstDisplayedCell Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : FirstDisplayedCell Property

Gets or sets the first cell currently displayed in the DataGridView; typically, this cell is in the upper left corner.

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
Public Property FirstDisplayedCell As DataGridViewCell
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim value As DataGridViewCell

instance.FirstDisplayedCell = value

value = instance.FirstDisplayedCell
C#
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public DataGridViewCell FirstDisplayedCell {get; set;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public: __property DataGridViewCell* get_FirstDisplayedCell();
public: __property void set_FirstDisplayedCell(
   DataGridViewCell* value
);
C++/CLI
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public:
property DataGridViewCell^ FirstDisplayedCell {
   DataGridViewCell^ get();
   void set (DataGridViewCell^value);
}

Exceptions

Exception | Description
ArgumentException | The specified cell when setting this property is not is not in the DataGridView.
InvalidOperationException | The specified cell when setting this property has a DataGridViewCell.RowIndex or DataGridViewCell.ColumnIndex property value of -1, indicating that it is a header cell or a shared cell. -or-The specified cell when setting this property has a DataGridViewCell.Visible property value of false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


FirstDisplayedScrollingColumnHiddenWidth Property

[image]
Gizmox.WebGUI.Forms
FirstDisplayedScrollingColumnHiddenWidth Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : FirstDisplayedScrollingColumnHiddenWidth Property

Gets the width of the portion of the column that is currently scrolled out of view..

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public ReadOnly Property FirstDisplayedScrollingColumnHiddenWidth As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim value As Integer

value = instance.FirstDisplayedScrollingColumnHiddenWidth
C#
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public int FirstDisplayedScrollingColumnHiddenWidth {get;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: __property int get_FirstDisplayedScrollingColumnHiddenWidth();
C++/CLI
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
property int FirstDisplayedScrollingColumnHiddenWidth {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


FirstDisplayedScrollingColumnIndex Property

[image]
Gizmox.WebGUI.Forms
FirstDisplayedScrollingColumnIndex Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : FirstDisplayedScrollingColumnIndex Property

Gets or sets the index of the column that is the first column displayed on the DataGridView.

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
Public Property FirstDisplayedScrollingColumnIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim value As Integer

instance.FirstDisplayedScrollingColumnIndex = value

value = instance.FirstDisplayedScrollingColumnIndex
C#
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public int FirstDisplayedScrollingColumnIndex {get; set;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public: __property int get_FirstDisplayedScrollingColumnIndex();
public: __property void set_FirstDisplayedScrollingColumnIndex(
   int value
);
C++/CLI
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public:
property int FirstDisplayedScrollingColumnIndex {
   int get();
   void set (intvalue);
}

Exceptions

Exception | Description
ArgumentOutOfRangeException | The specified value when setting this property is less than 0 or greater than the number of columns in the control minus 1.
InvalidOperationException | The specified value when setting this property indicates a column with a DataGridViewColumn.Visible property value of false.-or-The specified value when setting this property indicates a column with a DataGridViewColumn.Frozen property value of true.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


FirstDisplayedScrollingRowIndex Property

[image]
Gizmox.WebGUI.Forms
FirstDisplayedScrollingRowIndex Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : FirstDisplayedScrollingRowIndex Property

Gets or sets the index of the row that is the first row displayed on the DataGridView.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public Property FirstDisplayedScrollingRowIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim value As Integer

instance.FirstDisplayedScrollingRowIndex = value

value = instance.FirstDisplayedScrollingRowIndex
C#
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public int FirstDisplayedScrollingRowIndex {get; set;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property int get_FirstDisplayedScrollingRowIndex();
public: __property void set_FirstDisplayedScrollingRowIndex(
   int value
);
C++/CLI
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
property int FirstDisplayedScrollingRowIndex {
   int get();
   void set (intvalue);
}

Exceptions

Exception | Description
ArgumentOutOfRangeException | The specified value when setting this property is less than 0 or greater than the number of rows in the control minus 1.
InvalidOperationException | The specified value when setting this property indicates a row with a DataGridViewRow.Visible property value of false.-or-The specified value when setting this property indicates a column with a DataGridViewRow.Frozen property value of true.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


Font Property

[image]
Gizmox.WebGUI.Forms
Font Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : Font Property

Gets or sets the font of the text displayed by the DataGridView.

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<BrowsableAttribute(False)>
Public Overrides Property Font As Font
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim value As Font

instance.Font = value

value = instance.Font
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[BrowsableAttribute(false)]
public override Font Font {get; set;}
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[BrowsableAttribute(false)]
public: __property Font* get_Font() override;
public: __property void set_Font(
   Font* value
) override;
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[BrowsableAttribute(false)]
public:
property Font^ Font {
   Font^ get() override;
   void set (Font^value) override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


ForeColor Property

[image]
Gizmox.WebGUI.Forms
ForeColor Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : ForeColor Property

Gets or sets the foreground color of the DataGridView.

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<BrowsableAttribute(False)>
Public Overrides Property ForeColor As Color
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim value As Color

instance.ForeColor = value

value = instance.ForeColor
C#
[DesignerSerializationVisibilityAttribute()]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[BrowsableAttribute(false)]
public override Color ForeColor {get; set;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[BrowsableAttribute(false)]
public: __property Color get_ForeColor() override;
public: __property void set_ForeColor(
   Color value
) override;
C++/CLI
[DesignerSerializationVisibilityAttribute()]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[BrowsableAttribute(false)]
public:
property Color ForeColor {
   Color get() override;
   void set (Colorvalue) override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


GridColor Property

[image]
Gizmox.WebGUI.Forms
GridColor Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : GridColor Property

Gets or sets the color of the grid lines separating the cells of the DataGridView.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("The color of the grid lines separating the cells of the DataGridView.")>
<SRCategoryAttribute("Appearance")>
Public Property GridColor As Color
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim value As Color

instance.GridColor = value

value = instance.GridColor
C#
[SRDescriptionAttribute("The color of the grid lines separating the cells of the DataGridView.")]
[SRCategoryAttribute("Appearance")]
public Color GridColor {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("The color of the grid lines separating the cells of the DataGridView.")]
[SRCategoryAttribute("Appearance")]
public: __property Color get_GridColor();
public: __property void set_GridColor(
   Color value
);
C++/CLI
[SRDescriptionAttribute("The color of the grid lines separating the cells of the DataGridView.")]
[SRCategoryAttribute("Appearance")]
public:
property Color GridColor {
   Color get();
   void set (Colorvalue);
}

Exceptions

Exception | Description
ArgumentException | The specified value when setting this property is Empty. -or-The specified value when setting this property has a A property value that is less that 255.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


IsCurrentCellDirty Property

[image]
Gizmox.WebGUI.Forms
IsCurrentCellDirty Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : IsCurrentCellDirty Property

Gets a value indicating whether the current cell has uncommitted changes.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property IsCurrentCellDirty As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim value As Boolean

value = instance.IsCurrentCellDirty
C#
[BrowsableAttribute(false)]
public bool IsCurrentCellDirty {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property bool get_IsCurrentCellDirty();
C++/CLI
[BrowsableAttribute(false)]
public:
property bool IsCurrentCellDirty {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


IsCurrentCellInEditMode Property

[image]
Gizmox.WebGUI.Forms
IsCurrentCellInEditMode Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : IsCurrentCellInEditMode Property

Gets a value indicating whether the currently active cell is being edited.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property IsCurrentCellInEditMode As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim value As Boolean

value = instance.IsCurrentCellInEditMode
C#
[BrowsableAttribute(false)]
public bool IsCurrentCellInEditMode {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property bool get_IsCurrentCellInEditMode();
C++/CLI
[BrowsableAttribute(false)]
public:
property bool IsCurrentCellInEditMode {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


IsCurrentRowDirty Property

[image]
Gizmox.WebGUI.Forms
IsCurrentRowDirty Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : IsCurrentRowDirty Property

Gets a value indicating whether the current row has uncommitted changes.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property IsCurrentRowDirty As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim value As Boolean

value = instance.IsCurrentRowDirty
C#
[BrowsableAttribute(false)]
public bool IsCurrentRowDirty {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property bool get_IsCurrentRowDirty();
C++/CLI
[BrowsableAttribute(false)]
public:
property bool IsCurrentRowDirty {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


IsDelayedDrawing Property

[image]
Gizmox.WebGUI.Forms
IsDelayedDrawing Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : IsDelayedDrawing Property

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property IsDelayedDrawing As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim value As Boolean

value = instance.IsDelayedDrawing
C#
protected override bool IsDelayedDrawing {get;}
Managed Extensions for C++
protected: __property bool get_IsDelayedDrawing() override;
C++/CLI
protected:
property bool IsDelayedDrawing {
   bool get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


Item Property

[image]
Gizmox.WebGUI.Forms
Item Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : Item Property

Gets or sets the cell located at the intersection of the row with the specified index and the column with the specified name.

Overload List

Overload | Description
Item(String,Int32) | Gets or sets the cell located at the intersection of the row with the specified index and the column with the specified name.
Item(Int32,Int32) | Gets or sets the cell located at the intersection of the row and column with the specified indexes.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


Item(String,Int32) Property

[image]
Gizmox.WebGUI.Forms
Item(String,Int32) Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class > Item Property : Item(String,Int32) Property

columnName
The name of the column containing the cell.
rowIndex
The index of the row containing the cell.
Gets or sets the cell located at the intersection of the row with the specified index and the column with the specified name.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public Overloads Property Item( _
   ByVal columnName As String, _
   ByVal rowIndex As Integer _
) As DataGridViewCell
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim columnName As String
Dim rowIndex As Integer
Dim value As DataGridViewCell

instance.Item(columnName, rowIndex) = value

value = instance.Item(columnName, rowIndex)
C#
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public DataGridViewCell Item(
   string columnName,
   int rowIndex
) {get; set;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property DataGridViewCell* get_Item(
   string* columnName,
   int rowIndex
);
public: __property void set_Item(
   string* columnName,
   int rowIndex,
   DataGridViewCell* value
);
C++/CLI
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
property DataGridViewCell^ Item {
   DataGridViewCell^ get(String^columnName, introwIndex);
   void set (String^columnName, introwIndex, DataGridViewCell^value);
}

Parameters

columnName
The name of the column containing the cell.
rowIndex
The index of the row containing the cell.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members
Overload List


Item(Int32,Int32) Property

[image]
Gizmox.WebGUI.Forms
Item(Int32,Int32) Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class > Item Property : Item(Int32,Int32) Property

columnIndex
The index of the column containing the cell.
rowIndex
The index of the row containing the cell.
Gets or sets the cell located at the intersection of the row and column with the specified indexes.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public Overloads Property Item( _
   ByVal columnIndex As Integer, _
   ByVal rowIndex As Integer _
) As DataGridViewCell
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim columnIndex As Integer
Dim rowIndex As Integer
Dim value As DataGridViewCell

instance.Item(columnIndex, rowIndex) = value

value = instance.Item(columnIndex, rowIndex)
C#
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public DataGridViewCell Item(
   int columnIndex,
   int rowIndex
) {get; set;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property DataGridViewCell* get_Item(
   int columnIndex,
   int rowIndex
);
public: __property void set_Item(
   int columnIndex,
   int rowIndex,
   DataGridViewCell* value
);
C++/CLI
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
property DataGridViewCell^ Item {
   DataGridViewCell^ get(intcolumnIndex, introwIndex);
   void set (intcolumnIndex, introwIndex, DataGridViewCell^value);
}

Parameters

columnIndex
The index of the column containing the cell.
rowIndex
The index of the row containing the cell.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members
Overload List


ItemsPerPage Property

[image]
Gizmox.WebGUI.Forms
ItemsPerPage Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : ItemsPerPage Property

Gets or sets the current page.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property ItemsPerPage As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim value As Integer

instance.ItemsPerPage = value

value = instance.ItemsPerPage
C#
[DefaultValueAttribute()]
public int ItemsPerPage {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property int get_ItemsPerPage();
public: __property void set_ItemsPerPage(
   int value
);
C++/CLI
[DefaultValueAttribute()]
public:
property int ItemsPerPage {
   int get();
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


LazyMode Property

[image]
Gizmox.WebGUI.Forms
LazyMode Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : LazyMode Property

Gets or sets a value indicating whether [lazy mode].

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<SRDescriptionAttribute("A mode in which the DataGridView is not raising the 'CellValueChange' event for each value changing.")>
<SRCategoryAttribute("Data")>
Public Property LazyMode As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim value As Boolean

instance.LazyMode = value

value = instance.LazyMode
C#
[DefaultValueAttribute()]
[SRDescriptionAttribute("A mode in which the DataGridView is not raising the 'CellValueChange' event for each value changing.")]
[SRCategoryAttribute("Data")]
public bool LazyMode {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[SRDescriptionAttribute("A mode in which the DataGridView is not raising the 'CellValueChange' event for each value changing.")]
[SRCategoryAttribute("Data")]
public: __property bool get_LazyMode();
public: __property void set_LazyMode(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
[SRDescriptionAttribute("A mode in which the DataGridView is not raising the 'CellValueChange' event for each value changing.")]
[SRCategoryAttribute("Data")]
public:
property bool LazyMode {
   bool get();
   void set (boolvalue);
}

Return Value

true if [lazy mode]; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


MultiSelect Property

[image]
Gizmox.WebGUI.Forms
MultiSelect Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : MultiSelect Property

Gets or sets a value indicating whether the user is allowed to select more than one cell, row, or column of the DataGridView at a time.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Behavior")>
<DefaultValueAttribute()>
<SRDescriptionAttribute("Indicates whether the user is allowed to select more than one cell, row, or column of the DataGridView at a time.")>
Public Property MultiSelect As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim value As Boolean

instance.MultiSelect = value

value = instance.MultiSelect
C#
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Indicates whether the user is allowed to select more than one cell, row, or column of the DataGridView at a time.")]
public bool MultiSelect {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Indicates whether the user is allowed to select more than one cell, row, or column of the DataGridView at a time.")]
public: __property bool get_MultiSelect();
public: __property void set_MultiSelect(
   bool value
);
C++/CLI
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Indicates whether the user is allowed to select more than one cell, row, or column of the DataGridView at a time.")]
public:
property bool MultiSelect {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


NewRowIndex Property

[image]
Gizmox.WebGUI.Forms
NewRowIndex Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : NewRowIndex Property

Gets the index of the row for new records.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public ReadOnly Property NewRowIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim value As Integer

value = instance.NewRowIndex
C#
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public int NewRowIndex {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property int get_NewRowIndex();
C++/CLI
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
property int NewRowIndex {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


PageFirstIndex Property

[image]
Gizmox.WebGUI.Forms
PageFirstIndex Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : PageFirstIndex Property

Gets the first item's index in the current page

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PageFirstIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim value As Integer

value = instance.PageFirstIndex
C#
public int PageFirstIndex {get;}
Managed Extensions for C++
public: __property int get_PageFirstIndex();
C++/CLI
public:
property int PageFirstIndex {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


PageLastIndex Property

[image]
Gizmox.WebGUI.Forms
PageLastIndex Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : PageLastIndex Property

Gets the last item's index in the current page

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PageLastIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim value As Integer

value = instance.PageLastIndex
C#
public int PageLastIndex {get;}
Managed Extensions for C++
public: __property int get_PageLastIndex();
C++/CLI
public:
property int PageLastIndex {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


ReadOnly Property

[image]
Gizmox.WebGUI.Forms
ReadOnly Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : ReadOnly Property

Gets a value indicating whether the user can edit the cells of the DataGridView control.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(True)>
<SRDescriptionAttribute("Indicates whether the user can edit the cells of the DataGridView control.")>
<DefaultValueAttribute()>
<SRCategoryAttribute("Behavior")>
Public Property ReadOnly As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim value As Boolean

instance.ReadOnly = value

value = instance.ReadOnly
C#
[BrowsableAttribute(true)]
[SRDescriptionAttribute("Indicates whether the user can edit the cells of the DataGridView control.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
public bool ReadOnly {get; set;}
Managed Extensions for C++
[BrowsableAttribute(true)]
[SRDescriptionAttribute("Indicates whether the user can edit the cells of the DataGridView control.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
public: __property bool get_ReadOnly();
public: __property void set_ReadOnly(
   bool value
);
C++/CLI
[BrowsableAttribute(true)]
[SRDescriptionAttribute("Indicates whether the user can edit the cells of the DataGridView control.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
public:
property bool ReadOnly {
   bool get();
   void set (boolvalue);
}

Exceptions

Exception | Description
InvalidOperationException | The specified value when setting this property is true, the current cell is in edit mode, and the current cell contains changes that cannot be committed.
Exception | The specified value when setting this property would cause the control to enter edit mode, but initialization of the editing cell value failed and either there is no handler for the DataError event or the handler has set the DataGridViewDataErrorEventArgs.ThrowException property to true. The exception object can typically be cast to type FormatException.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


RowCount Property

[image]
Gizmox.WebGUI.Forms
RowCount Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : RowCount Property

Gets or sets the number of rows displayed in the DataGridView.

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<BrowsableAttribute(False)>
<DefaultValueAttribute()>
<DesignerSerializationVisibilityAttribute()>
Public Property RowCount As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim value As Integer

instance.RowCount = value

value = instance.RowCount
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
[DesignerSerializationVisibilityAttribute()]
public int RowCount {get; set;}
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
[DesignerSerializationVisibilityAttribute()]
public: __property int get_RowCount();
public: __property void set_RowCount(
   int value
);
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
[DesignerSerializationVisibilityAttribute()]
public:
property int RowCount {
   int get();
   void set (intvalue);
}

Exceptions

Exception | Description
ArgumentException | The specified value when setting this property is less than 0.-or-The specified value is less than 1 and AllowUserToAddRows is set to true.
InvalidOperationException | When setting this property, the DataSource property is set.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


RowHeadersBorderStyle Property

[image]
Gizmox.WebGUI.Forms
RowHeadersBorderStyle Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : RowHeadersBorderStyle Property

Gets or sets the border style of the row header cells.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("The border style of the row header cells.")>
<SRCategoryAttribute("Appearance")>
<DefaultValueAttribute()>
<BrowsableAttribute(True)>
Public Property RowHeadersBorderStyle As DataGridViewHeaderBorderStyle
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim value As DataGridViewHeaderBorderStyle

instance.RowHeadersBorderStyle = value

value = instance.RowHeadersBorderStyle
C#
[SRDescriptionAttribute("The border style of the row header cells.")]
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
[BrowsableAttribute(true)]
public DataGridViewHeaderBorderStyle RowHeadersBorderStyle {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("The border style of the row header cells.")]
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
[BrowsableAttribute(true)]
public: __property DataGridViewHeaderBorderStyle get_RowHeadersBorderStyle();
public: __property void set_RowHeadersBorderStyle(
   DataGridViewHeaderBorderStyle value
);
C++/CLI
[SRDescriptionAttribute("The border style of the row header cells.")]
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
[BrowsableAttribute(true)]
public:
property DataGridViewHeaderBorderStyle RowHeadersBorderStyle {
   DataGridViewHeaderBorderStyle get();
   void set (DataGridViewHeaderBorderStylevalue);
}

Exceptions

Exception | Description
ArgumentException | The specified value when setting this property is DataGridViewHeaderBorderStyle.Custom.
InvalidEnumArgumentException | The specified value when setting this property is not a valid DataGridViewHeaderBorderStyle value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


RowHeadersDefaultCellStyle Property

[image]
Gizmox.WebGUI.Forms
RowHeadersDefaultCellStyle Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : RowHeadersDefaultCellStyle Property

Gets or sets the default style applied to the row header cells.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Appearance")>
<AmbientValueAttribute()>
<SRDescriptionAttribute("The default style applied to the row header cells.")>
Public Property RowHeadersDefaultCellStyle As DataGridViewCellStyle
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim value As DataGridViewCellStyle

instance.RowHeadersDefaultCellStyle = value

value = instance.RowHeadersDefaultCellStyle
C#
[SRCategoryAttribute("Appearance")]
[AmbientValueAttribute()]
[SRDescriptionAttribute("The default style applied to the row header cells.")]
public DataGridViewCellStyle RowHeadersDefaultCellStyle {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Appearance")]
[AmbientValueAttribute()]
[SRDescriptionAttribute("The default style applied to the row header cells.")]
public: __property DataGridViewCellStyle* get_RowHeadersDefaultCellStyle();
public: __property void set_RowHeadersDefaultCellStyle(
   DataGridViewCellStyle* value
);
C++/CLI
[SRCategoryAttribute("Appearance")]
[AmbientValueAttribute()]
[SRDescriptionAttribute("The default style applied to the row header cells.")]
public:
property DataGridViewCellStyle^ RowHeadersDefaultCellStyle {
   DataGridViewCellStyle^ get();
   void set (DataGridViewCellStyle^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


RowHeadersVisible Property

[image]
Gizmox.WebGUI.Forms
RowHeadersVisible Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : RowHeadersVisible Property

Gets or sets a value indicating whether the column that contains row headers is displayed.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Indicates whether the column that contains row headers is displayed.")>
<DefaultValueAttribute()>
<SRCategoryAttribute("Appearance")>
Public Property RowHeadersVisible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim value As Boolean

instance.RowHeadersVisible = value

value = instance.RowHeadersVisible
C#
[SRDescriptionAttribute("Indicates whether the column that contains row headers is displayed.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
public bool RowHeadersVisible {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Indicates whether the column that contains row headers is displayed.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
public: __property bool get_RowHeadersVisible();
public: __property void set_RowHeadersVisible(
   bool value
);
C++/CLI
[SRDescriptionAttribute("Indicates whether the column that contains row headers is displayed.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
public:
property bool RowHeadersVisible {
   bool get();
   void set (boolvalue);
}

Exceptions

Exception | Description
InvalidOperationException | The specified value when setting this property is false and the AutoSizeRowsMode property is set to DataGridViewAutoSizeRowsMode.AllHeaders or DataGridViewAutoSizeRowsMode.DisplayedHeaders.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


RowHeadersWidth Property

[image]
Gizmox.WebGUI.Forms
RowHeadersWidth Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : RowHeadersWidth Property

Gets or sets the width, in pixels, of the column that contains the row headers.

Syntax

Visual Basic (Declaration)
<LocalizableAttribute(True)>
<SRDescriptionAttribute("The width, in pixels, of the column that contains the row headers.")>
<SRCategoryAttribute("Layout")>
Public Property RowHeadersWidth As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim value As Integer

instance.RowHeadersWidth = value

value = instance.RowHeadersWidth
C#
[LocalizableAttribute(true)]
[SRDescriptionAttribute("The width, in pixels, of the column that contains the row headers.")]
[SRCategoryAttribute("Layout")]
public int RowHeadersWidth {get; set;}
Managed Extensions for C++
[LocalizableAttribute(true)]
[SRDescriptionAttribute("The width, in pixels, of the column that contains the row headers.")]
[SRCategoryAttribute("Layout")]
public: __property int get_RowHeadersWidth();
public: __property void set_RowHeadersWidth(
   int value
);
C++/CLI
[LocalizableAttribute(true)]
[SRDescriptionAttribute("The width, in pixels, of the column that contains the row headers.")]
[SRCategoryAttribute("Layout")]
public:
property int RowHeadersWidth {
   int get();
   void set (intvalue);
}

Exceptions

Exception | Description
ArgumentOutOfRangeException | The specified value when setting this property is less than the minimum width of 4 pixels or is greater than the maximum width of 32768 pixels.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


RowHeadersWidthSizeMode Property

[image]
Gizmox.WebGUI.Forms
RowHeadersWidthSizeMode Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : RowHeadersWidthSizeMode Property

Gets or sets a value indicating whether the width of the row headers is adjustable and whether it can be adjusted by the user or is automatically adjusted to fit the contents of the headers.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<SRCategoryAttribute("Behavior")>
<RefreshPropertiesAttribute()>
<SRDescriptionAttribute("Determines the behavior for adjusting the row headers width.")>
Public Property RowHeadersWidthSizeMode As DataGridViewRowHeadersWidthSizeMode
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim value As DataGridViewRowHeadersWidthSizeMode

instance.RowHeadersWidthSizeMode = value

value = instance.RowHeadersWidthSizeMode
C#
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
[RefreshPropertiesAttribute()]
[SRDescriptionAttribute("Determines the behavior for adjusting the row headers width.")]
public DataGridViewRowHeadersWidthSizeMode RowHeadersWidthSizeMode {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
[RefreshPropertiesAttribute()]
[SRDescriptionAttribute("Determines the behavior for adjusting the row headers width.")]
public: __property DataGridViewRowHeadersWidthSizeMode get_RowHeadersWidthSizeMode();
public: __property void set_RowHeadersWidthSizeMode(
   DataGridViewRowHeadersWidthSizeMode value
);
C++/CLI
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
[RefreshPropertiesAttribute()]
[SRDescriptionAttribute("Determines the behavior for adjusting the row headers width.")]
public:
property DataGridViewRowHeadersWidthSizeMode RowHeadersWidthSizeMode {
   DataGridViewRowHeadersWidthSizeMode get();
   void set (DataGridViewRowHeadersWidthSizeModevalue);
}

Exceptions

Exception | Description
InvalidEnumArgumentException | The specified value when setting this property is not a valid DataGridViewRowHeadersWidthSizeMode value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


Rows Property

[image]
Gizmox.WebGUI.Forms
Rows Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : Rows Property

Gets a collection that contains all the rows in the DataGridView control.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property Rows As DataGridViewRowCollection
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim value As DataGridViewRowCollection

value = instance.Rows
C#
[BrowsableAttribute(false)]
public DataGridViewRowCollection Rows {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property DataGridViewRowCollection* get_Rows();
C++/CLI
[BrowsableAttribute(false)]
public:
property DataGridViewRowCollection^ Rows {
   DataGridViewRowCollection^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


RowsDefaultCellStyle Property

[image]
Gizmox.WebGUI.Forms
RowsDefaultCellStyle Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : RowsDefaultCellStyle Property

Gets or sets the default style applied to the row cells of the DataGridView.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("The default style applied to the row cells of the DataGridView.")>
<SRCategoryAttribute("Appearance")>
Public Property RowsDefaultCellStyle As DataGridViewCellStyle
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim value As DataGridViewCellStyle

instance.RowsDefaultCellStyle = value

value = instance.RowsDefaultCellStyle
C#
[SRDescriptionAttribute("The default style applied to the row cells of the DataGridView.")]
[SRCategoryAttribute("Appearance")]
public DataGridViewCellStyle RowsDefaultCellStyle {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("The default style applied to the row cells of the DataGridView.")]
[SRCategoryAttribute("Appearance")]
public: __property DataGridViewCellStyle* get_RowsDefaultCellStyle();
public: __property void set_RowsDefaultCellStyle(
   DataGridViewCellStyle* value
);
C++/CLI
[SRDescriptionAttribute("The default style applied to the row cells of the DataGridView.")]
[SRCategoryAttribute("Appearance")]
public:
property DataGridViewCellStyle^ RowsDefaultCellStyle {
   DataGridViewCellStyle^ get();
   void set (DataGridViewCellStyle^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


RowTemplate Property

[image]
Gizmox.WebGUI.Forms
RowTemplate Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : RowTemplate Property

Gets or sets the row that represents the template for all the rows in the control.

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
<SRCategoryAttribute("Appearance")>
<SRDescriptionAttribute("Identifies the template row whose characteristics are used as the basis for all new implicitly added rows.")>
<BrowsableAttribute(True)>
Public Property RowTemplate As DataGridViewRow
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim value As DataGridViewRow

instance.RowTemplate = value

value = instance.RowTemplate
C#
[DesignerSerializationVisibilityAttribute()]
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Identifies the template row whose characteristics are used as the basis for all new implicitly added rows.")]
[BrowsableAttribute(true)]
public DataGridViewRow RowTemplate {get; set;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Identifies the template row whose characteristics are used as the basis for all new implicitly added rows.")]
[BrowsableAttribute(true)]
public: __property DataGridViewRow* get_RowTemplate();
public: __property void set_RowTemplate(
   DataGridViewRow* value
);
C++/CLI
[DesignerSerializationVisibilityAttribute()]
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Identifies the template row whose characteristics are used as the basis for all new implicitly added rows.")]
[BrowsableAttribute(true)]
public:
property DataGridViewRow^ RowTemplate {
   DataGridViewRow^ get();
   void set (DataGridViewRow^value);
}

Exceptions

Exception | Description
InvalidOperationException | The specified row when setting this property has its DataGridViewElement.DataGridView property set.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


ScrollBars Property

[image]
Gizmox.WebGUI.Forms
ScrollBars Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : ScrollBars Property

Gets or sets the type of scroll bars to display for the DataGridView control.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("The type of scroll bars to display for the DataGridView control.")>
<DefaultValueAttribute()>
<LocalizableAttribute(True)>
<SRCategoryAttribute("Layout")>
Public Property ScrollBars As ScrollBars
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim value As ScrollBars

instance.ScrollBars = value

value = instance.ScrollBars
C#
[SRDescriptionAttribute("The type of scroll bars to display for the DataGridView control.")]
[DefaultValueAttribute()]
[LocalizableAttribute(true)]
[SRCategoryAttribute("Layout")]
public ScrollBars ScrollBars {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("The type of scroll bars to display for the DataGridView control.")]
[DefaultValueAttribute()]
[LocalizableAttribute(true)]
[SRCategoryAttribute("Layout")]
public: __property ScrollBars get_ScrollBars();
public: __property void set_ScrollBars(
   ScrollBars value
);
C++/CLI
[SRDescriptionAttribute("The type of scroll bars to display for the DataGridView control.")]
[DefaultValueAttribute()]
[LocalizableAttribute(true)]
[SRCategoryAttribute("Layout")]
public:
property ScrollBars ScrollBars {
   ScrollBars get();
   void set (ScrollBarsvalue);
}

Exceptions

Exception | Description
InvalidEnumArgumentException | The specified value when setting this property is not a valid ScrollBars value.
InvalidOperationException | The value of this property cannot be set because the DataGridView is unable to scroll due to a cell change that cannot be committed or canceled.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


SelectedCells Property

[image]
Gizmox.WebGUI.Forms
SelectedCells Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : SelectedCells Property

Gets the collection of cells selected by the user.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property SelectedCells As DataGridViewSelectedCellCollection
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim value As DataGridViewSelectedCellCollection

value = instance.SelectedCells
C#
[BrowsableAttribute(false)]
public DataGridViewSelectedCellCollection SelectedCells {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property DataGridViewSelectedCellCollection* get_SelectedCells();
C++/CLI
[BrowsableAttribute(false)]
public:
property DataGridViewSelectedCellCollection^ SelectedCells {
   DataGridViewSelectedCellCollection^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


SelectedColumns Property

[image]
Gizmox.WebGUI.Forms
SelectedColumns Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : SelectedColumns Property

Gets the collection of columns selected by the user.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property SelectedColumns As DataGridViewSelectedColumnCollection
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim value As DataGridViewSelectedColumnCollection

value = instance.SelectedColumns
C#
[BrowsableAttribute(false)]
public DataGridViewSelectedColumnCollection SelectedColumns {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property DataGridViewSelectedColumnCollection* get_SelectedColumns();
C++/CLI
[BrowsableAttribute(false)]
public:
property DataGridViewSelectedColumnCollection^ SelectedColumns {
   DataGridViewSelectedColumnCollection^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


SelectedRows Property

[image]
Gizmox.WebGUI.Forms
SelectedRows Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : SelectedRows Property

Gets the collection of rows selected by the user.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property SelectedRows As DataGridViewSelectedRowCollection
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim value As DataGridViewSelectedRowCollection

value = instance.SelectedRows
C#
[BrowsableAttribute(false)]
public DataGridViewSelectedRowCollection SelectedRows {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property DataGridViewSelectedRowCollection* get_SelectedRows();
C++/CLI
[BrowsableAttribute(false)]
public:
property DataGridViewSelectedRowCollection^ SelectedRows {
   DataGridViewSelectedRowCollection^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


SelectionMode Property

[image]
Gizmox.WebGUI.Forms
SelectionMode Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : SelectionMode Property

Gets or sets a value indicating how the cells of the DataGridView can be selected.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Indicates how the cells of the DataGridView can be selected.")>
<DefaultValueAttribute()>
<BrowsableAttribute(True)>
<SRCategoryAttribute("Behavior")>
Public Property SelectionMode As DataGridViewSelectionMode
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim value As DataGridViewSelectionMode

instance.SelectionMode = value

value = instance.SelectionMode
C#
[SRDescriptionAttribute("Indicates how the cells of the DataGridView can be selected.")]
[DefaultValueAttribute()]
[BrowsableAttribute(true)]
[SRCategoryAttribute("Behavior")]
public DataGridViewSelectionMode SelectionMode {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Indicates how the cells of the DataGridView can be selected.")]
[DefaultValueAttribute()]
[BrowsableAttribute(true)]
[SRCategoryAttribute("Behavior")]
public: __property DataGridViewSelectionMode get_SelectionMode();
public: __property void set_SelectionMode(
   DataGridViewSelectionMode value
);
C++/CLI
[SRDescriptionAttribute("Indicates how the cells of the DataGridView can be selected.")]
[DefaultValueAttribute()]
[BrowsableAttribute(true)]
[SRCategoryAttribute("Behavior")]
public:
property DataGridViewSelectionMode SelectionMode {
   DataGridViewSelectionMode get();
   void set (DataGridViewSelectionModevalue);
}

Exceptions

Exception | Description
InvalidOperationException | The specified value when setting this property is DataGridViewSelectionMode.FullColumnSelect or DataGridViewSelectionMode.ColumnHeaderSelect and the DataGridViewColumn.SortMode property of one or more columns is set to DataGridViewColumnSortMode.Automatic.
InvalidEnumArgumentException | The specified value when setting this property is not a valid DataGridViewSelectionMode value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


ShowCellErrors Property

[image]
Gizmox.WebGUI.Forms
ShowCellErrors Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : ShowCellErrors Property

Gets or sets a value indicating whether to show cell errors.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Indicates whether to show cell errors.")>
<SRCategoryAttribute("Appearance")>
<DefaultValueAttribute()>
Public Property ShowCellErrors As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim value As Boolean

instance.ShowCellErrors = value

value = instance.ShowCellErrors
C#
[SRDescriptionAttribute("Indicates whether to show cell errors.")]
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
public bool ShowCellErrors {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Indicates whether to show cell errors.")]
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
public: __property bool get_ShowCellErrors();
public: __property void set_ShowCellErrors(
   bool value
);
C++/CLI
[SRDescriptionAttribute("Indicates whether to show cell errors.")]
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
public:
property bool ShowCellErrors {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


ShowCellToolTips Property

[image]
Gizmox.WebGUI.Forms
ShowCellToolTips Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : ShowCellToolTips Property

Gets or sets a value indicating whether or not ToolTips will show when the mouse pointer pauses on a cell.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Appearance")>
<SRDescriptionAttribute("Indicates whether or not ToolTips will show when the mouse pointer pauses on a cell.")>
<DefaultValueAttribute()>
Public Property ShowCellToolTips As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim value As Boolean

instance.ShowCellToolTips = value

value = instance.ShowCellToolTips
C#
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Indicates whether or not ToolTips will show when the mouse pointer pauses on a cell.")]
[DefaultValueAttribute()]
public bool ShowCellToolTips {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Indicates whether or not ToolTips will show when the mouse pointer pauses on a cell.")]
[DefaultValueAttribute()]
public: __property bool get_ShowCellToolTips();
public: __property void set_ShowCellToolTips(
   bool value
);
C++/CLI
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Indicates whether or not ToolTips will show when the mouse pointer pauses on a cell.")]
[DefaultValueAttribute()]
public:
property bool ShowCellToolTips {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


ShowEditingIcon Property

[image]
Gizmox.WebGUI.Forms
ShowEditingIcon Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : ShowEditingIcon Property

Gets or sets a value indicating whether or not the editing glyph is visible in the row header of the cell being edited.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Indicates whether or not the editing glyph is visible in the row header of the cell being edited.")>
<SRCategoryAttribute("Appearance")>
<DefaultValueAttribute()>
Public Property ShowEditingIcon As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim value As Boolean

instance.ShowEditingIcon = value

value = instance.ShowEditingIcon
C#
[SRDescriptionAttribute("Indicates whether or not the editing glyph is visible in the row header of the cell being edited.")]
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
public bool ShowEditingIcon {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Indicates whether or not the editing glyph is visible in the row header of the cell being edited.")]
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
public: __property bool get_ShowEditingIcon();
public: __property void set_ShowEditingIcon(
   bool value
);
C++/CLI
[SRDescriptionAttribute("Indicates whether or not the editing glyph is visible in the row header of the cell being edited.")]
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
public:
property bool ShowEditingIcon {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


ShowRowErrors Property

[image]
Gizmox.WebGUI.Forms
ShowRowErrors Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : ShowRowErrors Property

Gets or sets a value indicating whether row headers will display error glyphs for each row that contains a data entry error.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Indicates whether row headers will display error glyphs for each row that contains a data entry error. ")>
<SRCategoryAttribute("Appearance")>
<DefaultValueAttribute()>
Public Property ShowRowErrors As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim value As Boolean

instance.ShowRowErrors = value

value = instance.ShowRowErrors
C#
[SRDescriptionAttribute("Indicates whether row headers will display error glyphs for each row that contains a data entry error. ")]
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
public bool ShowRowErrors {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Indicates whether row headers will display error glyphs for each row that contains a data entry error. ")]
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
public: __property bool get_ShowRowErrors();
public: __property void set_ShowRowErrors(
   bool value
);
C++/CLI
[SRDescriptionAttribute("Indicates whether row headers will display error glyphs for each row that contains a data entry error. ")]
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
public:
property bool ShowRowErrors {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


SortedColumn Property

[image]
Gizmox.WebGUI.Forms
SortedColumn Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : SortedColumn Property

Gets the column by which the DataGridView contents are currently sorted.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property SortedColumn As DataGridViewColumn
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim value As DataGridViewColumn

value = instance.SortedColumn
C#
[BrowsableAttribute(false)]
public DataGridViewColumn SortedColumn {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property DataGridViewColumn* get_SortedColumn();
C++/CLI
[BrowsableAttribute(false)]
public:
property DataGridViewColumn^ SortedColumn {
   DataGridViewColumn^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


SortOrder Property

[image]
Gizmox.WebGUI.Forms
SortOrder Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : SortOrder Property

Gets a value indicating whether the items in the DataGridView control are sorted in ascending or descending order, or are not sorted.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property SortOrder As SortOrder
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim value As SortOrder

value = instance.SortOrder
C#
[BrowsableAttribute(false)]
public SortOrder SortOrder {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property SortOrder get_SortOrder();
C++/CLI
[BrowsableAttribute(false)]
public:
property SortOrder SortOrder {
   SortOrder get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


StandardTab Property

[image]
Gizmox.WebGUI.Forms
StandardTab Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : StandardTab Property

Gets or sets a value indicating whether the TAB key moves the focus to the next control in the tab order rather than moving focus to the next cell in the control.

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<SRDescriptionAttribute("Indicates whether the TAB key moves the focus to the next control in the tab order rather than moving focus to the next cell in the control.")>
<DefaultValueAttribute()>
<SRCategoryAttribute("Behavior")>
Public Property StandardTab As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim value As Boolean

instance.StandardTab = value

value = instance.StandardTab
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRDescriptionAttribute("Indicates whether the TAB key moves the focus to the next control in the tab order rather than moving focus to the next cell in the control.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
public bool StandardTab {get; set;}
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRDescriptionAttribute("Indicates whether the TAB key moves the focus to the next control in the tab order rather than moving focus to the next cell in the control.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
public: __property bool get_StandardTab();
public: __property void set_StandardTab(
   bool value
);
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRDescriptionAttribute("Indicates whether the TAB key moves the focus to the next control in the tab order rather than moving focus to the next cell in the control.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
public:
property bool StandardTab {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


TopLeftHeaderCell Property

[image]
Gizmox.WebGUI.Forms
TopLeftHeaderCell Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : TopLeftHeaderCell Property

Gets or sets the header cell located in the upper left corner of the DataGridView control.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public Property TopLeftHeaderCell As DataGridViewHeaderCell
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim value As DataGridViewHeaderCell

instance.TopLeftHeaderCell = value

value = instance.TopLeftHeaderCell
C#
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public DataGridViewHeaderCell TopLeftHeaderCell {get; set;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property DataGridViewHeaderCell* get_TopLeftHeaderCell();
public: __property void set_TopLeftHeaderCell(
   DataGridViewHeaderCell* value
);
C++/CLI
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
property DataGridViewHeaderCell^ TopLeftHeaderCell {
   DataGridViewHeaderCell^ get();
   void set (DataGridViewHeaderCell^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


TotalItems Property

[image]
Gizmox.WebGUI.Forms
TotalItems Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : TotalItems Property

Gets or sets the total items.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property TotalItems As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim value As Integer

instance.TotalItems = value

value = instance.TotalItems
C#
[DefaultValueAttribute()]
public int TotalItems {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property int get_TotalItems();
public: __property void set_TotalItems(
   int value
);
C++/CLI
[DefaultValueAttribute()]
public:
property int TotalItems {
   int get();
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


TotalPages Property

[image]
Gizmox.WebGUI.Forms
TotalPages Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : TotalPages Property

Gets or sets the total pages.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property TotalPages As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim value As Integer

instance.TotalPages = value

value = instance.TotalPages
C#
[DefaultValueAttribute()]
public int TotalPages {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property int get_TotalPages();
public: __property void set_TotalPages(
   int value
);
C++/CLI
[DefaultValueAttribute()]
public:
property int TotalPages {
   int get();
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


UseInternalPaging Property

[image]
Gizmox.WebGUI.Forms
UseInternalPaging Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : UseInternalPaging Property

Uses internal paging algorithem

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property UseInternalPaging As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim value As Boolean

instance.UseInternalPaging = value

value = instance.UseInternalPaging
C#
[DefaultValueAttribute()]
public bool UseInternalPaging {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property bool get_UseInternalPaging();
public: __property void set_UseInternalPaging(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
public:
property bool UseInternalPaging {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


UserSetCursor Property

[image]
Gizmox.WebGUI.Forms
UserSetCursor Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : UserSetCursor Property

Gets the default or user-specified value of the Control.Cursor property.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public ReadOnly Property UserSetCursor As Cursor
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim value As Cursor

value = instance.UserSetCursor
C#
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public Cursor UserSetCursor {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: __property Cursor* get_UserSetCursor();
C++/CLI
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
property Cursor^ UserSetCursor {
   Cursor^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


VerticalScrollingOffset Property

[image]
Gizmox.WebGUI.Forms
VerticalScrollingOffset Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : VerticalScrollingOffset Property

Gets the number of pixels by which the control is scrolled vertically.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public ReadOnly Property VerticalScrollingOffset As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim value As Integer

value = instance.VerticalScrollingOffset
C#
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public int VerticalScrollingOffset {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property int get_VerticalScrollingOffset();
C++/CLI
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
property int VerticalScrollingOffset {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


VirtualMode Property

[image]
Gizmox.WebGUI.Forms
VirtualMode Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : VirtualMode Property

Gets or sets a value indicating whether you have provided your own data-management operations for the DataGridView control.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Indicates whether you have provided your own data-management operations for the DataGridView control. ")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<SRCategoryAttribute("Behavior")>
<DefaultValueAttribute()>
Public Property VirtualMode As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim value As Boolean

instance.VirtualMode = value

value = instance.VirtualMode
C#
[SRDescriptionAttribute("Indicates whether you have provided your own data-management operations for the DataGridView control. ")]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
public bool VirtualMode {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Indicates whether you have provided your own data-management operations for the DataGridView control. ")]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
public: __property bool get_VirtualMode();
public: __property void set_VirtualMode(
   bool value
);
C++/CLI
[SRDescriptionAttribute("Indicates whether you have provided your own data-management operations for the DataGridView control. ")]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
public:
property bool VirtualMode {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


DataGridView Class Events

[image]
Gizmox.WebGUI.Forms
DataGridView Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridView Class

For a list of all members of this type, see DataGridView members.

Public Events

 | Name | Description
Public Event | AllowUserToAddRowsChanged | Occurs when the value of the AllowUserToAddRows property changes.
Public Event | AllowUserToDeleteRowsChanged | Occurs when the value of the AllowUserToDeleteRowsChanged property changes.
Public Event | AllowUserToOrderColumnsChanged | Occurs when the value of the AllowUserToOrderColumns property changes.
Public Event | AllowUserToResizeColumnsChanged | Occurs when the value of the AllowUserToResizeColumns property changes.
Public Event | AllowUserToResizeRowsChanged | Occurs when the value of the AllowUserToResizeRows property changes.
Public Event | AlternatingRowsDefaultCellStyleChanged | Occurs when the value of the DataGridView.AlternatingRowsDefaultCellStyle property changes.
Public Event | AutoGenerateColumnsChanged | Occurs when the value of the AutoGenerateColumnsChanged property changes.
Public Event | AutoSizeColumnModeChanged | Occurs when the value of the DataGridViewColumn.AutoSizeMode property of a column changes.
Public Event | AutoSizeColumnsModeChanged | Occurs when the value of the DataGridView.AutoSizeColumnsMode property changes.
Public Event | AutoSizeRowsModeChanged | Occurs when the value of the DataGridViewAutoSizeRowsMode property changes.
Public Event | BackgroundColorChanged | Occurs when the value of the BackgroundColor property changes.
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | BorderStyleChanged | Occurs when the value of the BorderStyle property changes.
Public Event | CancelRowEdit | Occurs when the VirtualMode property of a DataGridView control is true and the cancels edits in a row.
Public Event | CellBeginEdit | Occurs when edit mode starts for the selected cell.
Public Event | CellBorderStyleChanged | Occurs when the border style of a cell changes.
Public Event | CellClick | Occurs when any part of a cell is clicked.
Public Event | CellContentClick | Occurs when the content within a cell is clicked.
Public Event | CellContentDoubleClick | Occurs when the user double-clicks a cell's contents.
Public Event | CellContextMenuStripChanged | Occurs when the ContextMenuStrip property changes.
Public Event | CellDoubleClick | Occurs when the user double-clicks anywhere in a cell.
Public Event | CellEndEdit | Occurs when edit mode stops for the currently selected cell.
Public Event | CellEnter | Occurs when the current cell changes in the DataGridView control or when the control receives input focus.
Public Event | CellErrorTextChanged | Occurs when the value of the DataGridViewCell.ErrorText property of a cell changes.
Public Event | CellErrorTextNeeded | Occurs when a cell's error text is needed.
Public Event | CellFormatting | Occurs when the contents of a cell need to be formatted for display.
Public Event | CellLeave | Occurs when a cell loses input focus and is no longer the current cell.
Public Event | CellMouseClick | Occurs whenever the user clicks anywhere on a cell with the mouse.
Public Event | CellMouseDoubleClick | Occurs when a cell within the DataGridView is double-clicked.
Public Event | CellMouseDown | Occurs when the user presses a mouse button while the mouse pointer is within the boundaries of a cell.
Public Event | CellMouseEnter | Occurs when the mouse pointer enters a cell.
Public Event | CellMouseLeave | Occurs when the mouse pointer leaves a cell.
Public Event | CellMouseMove | Occurs when the mouse pointer moves over the DataGridView control.
Public Event | CellMouseUp | Occurs when the user releases a mouse button while over a cell.
Public Event | CellParsing | Occurs when a cell leaves edit mode if the cell value has been modified.
Public Event | CellStateChanged | Occurs when a cell state changes, such as when the cell loses or gains focus.
Public Event | CellStyleChanged | Occurs when the DataGridViewCell.Style property of a DataGridViewCell changes.
Public Event | CellStyleContentChanged | Occurs when one of the values of a cell style changes.
Public Event | CellToolTipTextChanged | Occurs when the DataGridViewCell.ToolTipText property value changes for a cell in the DataGridView.
Public Event | CellToolTipTextNeeded | Occurs when a cell's ToolTip text is needed.
Public Event | CellValidated | Occurs after the cell has finished validating.
Public Event | CellValidating | Occurs when a cell loses input focus, enabling content validation.
Public Event | CellValueChanged | Occurs when the value of a cell changes.
Public Event | CellValueNeeded | Occurs when the VirtualMode property of the DataGridView control is true and the DataGridView requires a value for a cell in order to format and display the cell.
Public Event | CellValuePushed | Occurs when the VirtualMode property of the DataGridView control is true and a cell value has changed and requires storage in the underlying data source.
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ColumnAdded | Occurs when a column is added to the control.
Public Event | ColumnContextMenuStripChanged | Occurs when the ContextMenuStrip property of a column changes.
Public Event | ColumnDataPropertyNameChanged | Occurs when the value of the DataGridViewColumn.DataPropertyName property for a column changes.
Public Event | ColumnDefaultCellStyleChanged | Occurs when the value of the DataGridViewBand.DefaultCellStyle property for a column changes.
Public Event | ColumnDisplayIndexChanged | Occurs when the value the DataGridViewColumn.DisplayIndex property for a column changes.
Public Event | ColumnDividerDoubleClick | Occurs when the user double-clicks a divider between two columns.
Public Event | ColumnDividerWidthChanged | Occurs when the DataGridViewColumn.DividerWidth property changes.
Public Event | ColumnHeaderCellChanged | Occurs when the contents of a column header cell change.
Public Event | ColumnHeaderMouseClick | Occurs when the user clicks a column header.
Public Event | ColumnHeaderMouseDoubleClick | Occurs when a column header is double-clicked.
Public Event | ColumnHeadersBorderStyleChanged | Occurs when the DataGridView.ColumnHeadersBorderStyle property changes.
Public Event | ColumnHeadersDefaultCellStyleChanged | Occurs when the value of the DataGridView.ColumnHeadersDefaultCellStyle property changes.
Public Event | ColumnHeadersHeightChanged | Occurs when the value of the ColumnHeadersHeight property changes.
Public Event | ColumnHeadersHeightSizeModeChanged | Occurs when the value of the ColumnHeadersHeightSizeMode property changes.
Public Event | ColumnMinimumWidthChanged | Occurs when the value of the DataGridViewColumn.MinimumWidth property for a column changes.
Public Event | ColumnNameChanged | Occurs when the value of the DataGridViewColumn.Name property for a column changes.
Public Event | ColumnRemoved | Occurs when a column is removed from the control.
Public Event | ColumnSortModeChanged | Occurs when the value of the DataGridViewColumn.SortMode property for a column changes.
Public Event | ColumnStateChanged | Occurs when a column changes state, such as gaining or losing focus.
Public Event | ColumnToolTipTextChanged | Occurs when the DataGridViewColumn.ToolTipText property value changes for a column in the DataGridView.
Public Event | ColumnWidthChanged | Occurs when the value of the DataGridViewColumn.Width property for a column changes.
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CurrentCellChanged | Occurs when the CurrentCell property changes.
Public Event | CurrentCellDirtyStateChanged | Occurs when the state of a cell changes in relation to a change in its contents.
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | DataBindingComplete | Occurs after a data-binding operation has finished.
Public Event | DataError | Occurs when an external data-parsing or validation operation throws an exception, or when an attempt to commit data to a data source fails.
Public Event | DataMemberChanged | Occurs when value of the DataMember property changes.
Public Event | DataSourceChanged | Occurs when the value of the DataSource property changes.
Public Event | DefaultCellStyleChanged | Occurs when the value of the DataGridView.DefaultCellStyle property changes.
Public Event | DefaultValuesNeeded | Occurs when the user enters the row for new records so that it can be populated with default values.
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | EditingControlShowing | Occurs when a control for editing a cell is showing.
Public Event | EditModeChanged | Occurs when the value of the EditMode property changes.
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the Font property value changes.
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | GridColorChanged | Occurs when the value of the GridColor property changes.
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MultiSelectChanged | Occurs when the value of the MultiSelect property changes.
Public Event | NewRowNeeded | Occurs when the VirtualMode property of the DataGridView is true and the user navigates to the new row at the bottom of the DataGridView.
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | PagingChanged | Occurs when the paging params have changed.
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | ReadOnlyChanged | Occurs when the ReadOnly property changes.
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | RowContextMenuStripChanged | Occurs when the ContextMenuStrip property changes.
Public Event | RowContextMenuStripNeeded | Occurs when a row's shortcut menu is needed.
Public Event | RowDefaultCellStyleChanged | Occurs when the value of the DataGridViewBand.DefaultCellStyle property for a row changes.
Public Event | RowDirtyStateNeeded | Occurs when the VirtualMode property of the DataGridView control is true and the DataGridView needs to determine whether the current row has uncommitted changes.
Public Event | RowDividerDoubleClick | Occurs when the user double-clicks the divider between two rows.
Public Event | RowDividerHeightChanged | Occurs when the DataGridViewRow.DividerHeight property changes.
Public Event | RowEnter | Occurs when a row receives input focus and becomes the current row.
Public Event | RowErrorTextChanged | Occurs when the DataGridViewRow.ErrorText property of a row changes.
Public Event | RowErrorTextNeeded | Occurs when a row's error text is needed.
Public Event | RowHeaderCellChanged | Occurs when the user changes the contents of a row header cell.
Public Event | RowHeaderMouseClick | Occurs when the user clicks within the boundaries of a row header.
Public Event | RowHeaderMouseDoubleClick | Occurs when a row header is double-clicked.
Public Event | RowHeadersBorderStyleChanged | Occurs when the DataGridView.RowHeadersBorderStyle property changes.
Public Event | RowHeadersDefaultCellStyleChanged | Occurs when the value of the DataGridView.RowHeadersDefaultCellStyle property changes.
Public Event | RowHeadersWidthChanged | Occurs when value of the RowHeadersWidth property changes.
Public Event | RowHeadersWidthSizeModeChanged | Occurs when the value of the RowHeadersWidthSizeMode property changes.
Public Event | RowHeightChanged | Occurs when the value of the DataGridViewRow.Height property for a row changes.
Public Event | RowHeightInfoNeeded | Occurs when information about row height is requested.
Public Event | RowHeightInfoPushed | Occurs when the user changes the height of a row.
Public Event | RowLeave | Occurs when a row loses input focus and is no longer the current row.
Public Event | RowMinimumHeightChanged | Occurs when the value of the DataGridViewRow.MinimumHeight property for a row changes.
Public Event | RowsAdded | Occurs after a new row is added to the DataGridView.
Public Event | RowsDefaultCellStyleChanged | Occurs when the value of the DataGridView.RowsDefaultCellStyle property changes.
Public Event | RowsRemoved | Occurs when a row or rows are deleted from the DataGridView.
Public Event | RowStateChanged | Occurs when a row changes state, such as losing or gaining input focus.
Public Event | RowUnshared | Occurs when a row's state changes from shared to unshared.
Public Event | RowValidated | Occurs after a row has finished validating.
Public Event | RowValidating | Occurs when a row is validating.
Public Event | SelectionChanged | Occurs when the current selection changes.
Public Event | SelectionChangedQueued | Occurs when the current selection changes (queued version).
Public Event | SortCompare | Occurs when the DataGridView compares two cell values to perform a sort operation.
Public Event | Sorted | Occurs when the DataGridView control completes a sorting operation.
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | UserAddedRow | Occurs when the user has finished adding a row to the DataGridView control.
Public Event | UserDeletedRow | Occurs when the user has finished deleting a row from the DataGridView control.
Public Event | UserDeletingRow | Occurs when the user deletes a row from the DataGridView control.
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

DataGridView Class
Gizmox.WebGUI.Forms Namespace


AllowUserToAddRowsChanged Event

[image]
Gizmox.WebGUI.Forms
AllowUserToAddRowsChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : AllowUserToAddRowsChanged Event

Occurs when the value of the AllowUserToAddRows property changes.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the value of the AllowUserToAddRows property changes.")>
<SRCategoryAttribute("Property Changed")>
Public Event AllowUserToAddRowsChanged() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As EventHandler

AddHandler instance.AllowUserToAddRowsChanged, handler
C#
[SRDescriptionAttribute("Occurs when the value of the AllowUserToAddRows property changes.")]
[SRCategoryAttribute("Property Changed")]
public event EventHandler AllowUserToAddRowsChanged()
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the value of the AllowUserToAddRows property changes.")]
[SRCategoryAttribute("Property Changed")]
public: __event EventHandler* AllowUserToAddRowsChanged
C++/CLI
[SRDescriptionAttribute("Occurs when the value of the AllowUserToAddRows property changes.")]
[SRCategoryAttribute("Property Changed")]
public:
event EventHandler^ AllowUserToAddRowsChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


AllowUserToDeleteRowsChanged Event

[image]
Gizmox.WebGUI.Forms
AllowUserToDeleteRowsChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : AllowUserToDeleteRowsChanged Event

Occurs when the value of the AllowUserToDeleteRowsChanged property changes.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the value of the AllowUserToDeleteRows property changes.")>
<SRCategoryAttribute("Property Changed")>
Public Event AllowUserToDeleteRowsChanged() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As EventHandler

AddHandler instance.AllowUserToDeleteRowsChanged, handler
C#
[SRDescriptionAttribute("Occurs when the value of the AllowUserToDeleteRows property changes.")]
[SRCategoryAttribute("Property Changed")]
public event EventHandler AllowUserToDeleteRowsChanged()
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the value of the AllowUserToDeleteRows property changes.")]
[SRCategoryAttribute("Property Changed")]
public: __event EventHandler* AllowUserToDeleteRowsChanged
C++/CLI
[SRDescriptionAttribute("Occurs when the value of the AllowUserToDeleteRows property changes.")]
[SRCategoryAttribute("Property Changed")]
public:
event EventHandler^ AllowUserToDeleteRowsChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


AllowUserToOrderColumnsChanged Event

[image]
Gizmox.WebGUI.Forms
AllowUserToOrderColumnsChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : AllowUserToOrderColumnsChanged Event

Occurs when the value of the AllowUserToOrderColumns property changes.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the value of the AllowUserToOrderColumns property changes.")>
<SRCategoryAttribute("Property Changed")>
Public Event AllowUserToOrderColumnsChanged() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As EventHandler

AddHandler instance.AllowUserToOrderColumnsChanged, handler
C#
[SRDescriptionAttribute("Occurs when the value of the AllowUserToOrderColumns property changes.")]
[SRCategoryAttribute("Property Changed")]
public event EventHandler AllowUserToOrderColumnsChanged()
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the value of the AllowUserToOrderColumns property changes.")]
[SRCategoryAttribute("Property Changed")]
public: __event EventHandler* AllowUserToOrderColumnsChanged
C++/CLI
[SRDescriptionAttribute("Occurs when the value of the AllowUserToOrderColumns property changes.")]
[SRCategoryAttribute("Property Changed")]
public:
event EventHandler^ AllowUserToOrderColumnsChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


AllowUserToResizeColumnsChanged Event

[image]
Gizmox.WebGUI.Forms
AllowUserToResizeColumnsChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : AllowUserToResizeColumnsChanged Event

Occurs when the value of the AllowUserToResizeColumns property changes.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the value of the AllowUserToResizeColumns property changes.")>
<SRCategoryAttribute("Property Changed")>
Public Event AllowUserToResizeColumnsChanged() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As EventHandler

AddHandler instance.AllowUserToResizeColumnsChanged, handler
C#
[SRDescriptionAttribute("Occurs when the value of the AllowUserToResizeColumns property changes.")]
[SRCategoryAttribute("Property Changed")]
public event EventHandler AllowUserToResizeColumnsChanged()
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the value of the AllowUserToResizeColumns property changes.")]
[SRCategoryAttribute("Property Changed")]
public: __event EventHandler* AllowUserToResizeColumnsChanged
C++/CLI
[SRDescriptionAttribute("Occurs when the value of the AllowUserToResizeColumns property changes.")]
[SRCategoryAttribute("Property Changed")]
public:
event EventHandler^ AllowUserToResizeColumnsChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


AllowUserToResizeRowsChanged Event

[image]
Gizmox.WebGUI.Forms
AllowUserToResizeRowsChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : AllowUserToResizeRowsChanged Event

Occurs when the value of the AllowUserToResizeRows property changes.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the value of the AllowUserToResizeRows property changes.")>
<SRCategoryAttribute("Property Changed")>
Public Event AllowUserToResizeRowsChanged() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As EventHandler

AddHandler instance.AllowUserToResizeRowsChanged, handler
C#
[SRDescriptionAttribute("Occurs when the value of the AllowUserToResizeRows property changes.")]
[SRCategoryAttribute("Property Changed")]
public event EventHandler AllowUserToResizeRowsChanged()
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the value of the AllowUserToResizeRows property changes.")]
[SRCategoryAttribute("Property Changed")]
public: __event EventHandler* AllowUserToResizeRowsChanged
C++/CLI
[SRDescriptionAttribute("Occurs when the value of the AllowUserToResizeRows property changes.")]
[SRCategoryAttribute("Property Changed")]
public:
event EventHandler^ AllowUserToResizeRowsChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


AlternatingRowsDefaultCellStyleChanged Event

[image]
Gizmox.WebGUI.Forms
AlternatingRowsDefaultCellStyleChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : AlternatingRowsDefaultCellStyleChanged Event

Occurs when the value of the DataGridView.AlternatingRowsDefaultCellStyle property changes.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Property Changed")>
<SRDescriptionAttribute("Occurs when the value of the AlternatingRowsDefaultCellStyle property changes.")>
Public Event AlternatingRowsDefaultCellStyleChanged() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As EventHandler

AddHandler instance.AlternatingRowsDefaultCellStyleChanged, handler
C#
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when the value of the AlternatingRowsDefaultCellStyle property changes.")]
public event EventHandler AlternatingRowsDefaultCellStyleChanged()
Managed Extensions for C++
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when the value of the AlternatingRowsDefaultCellStyle property changes.")]
public: __event EventHandler* AlternatingRowsDefaultCellStyleChanged
C++/CLI
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when the value of the AlternatingRowsDefaultCellStyle property changes.")]
public:
event EventHandler^ AlternatingRowsDefaultCellStyleChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


AutoGenerateColumnsChanged Event

[image]
Gizmox.WebGUI.Forms
AutoGenerateColumnsChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : AutoGenerateColumnsChanged Event

Occurs when the value of the AutoGenerateColumnsChanged property changes.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Event AutoGenerateColumnsChanged() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As EventHandler

AddHandler instance.AutoGenerateColumnsChanged, handler
C#
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public event EventHandler AutoGenerateColumnsChanged()
Managed Extensions for C++
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: __event EventHandler* AutoGenerateColumnsChanged
C++/CLI
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
event EventHandler^ AutoGenerateColumnsChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


AutoSizeColumnModeChanged Event

[image]
Gizmox.WebGUI.Forms
AutoSizeColumnModeChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : AutoSizeColumnModeChanged Event

Occurs when the value of the DataGridViewColumn.AutoSizeMode property of a column changes.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the value of the AutoSizeMode property of a column changes.")>
<SRCategoryAttribute("Property Changed")>
Public Event AutoSizeColumnModeChanged() As DataGridViewAutoSizeColumnModeEventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As DataGridViewAutoSizeColumnModeEventHandler

AddHandler instance.AutoSizeColumnModeChanged, handler
C#
[SRDescriptionAttribute("Occurs when the value of the AutoSizeMode property of a column changes.")]
[SRCategoryAttribute("Property Changed")]
public event DataGridViewAutoSizeColumnModeEventHandler AutoSizeColumnModeChanged()
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the value of the AutoSizeMode property of a column changes.")]
[SRCategoryAttribute("Property Changed")]
public: __event DataGridViewAutoSizeColumnModeEventHandler* AutoSizeColumnModeChanged
C++/CLI
[SRDescriptionAttribute("Occurs when the value of the AutoSizeMode property of a column changes.")]
[SRCategoryAttribute("Property Changed")]
public:
event DataGridViewAutoSizeColumnModeEventHandler^ AutoSizeColumnModeChanged

Event Data

The event handler receives an argument of type DataGridViewAutoSizeColumnModeEventArgs containing data related to this event. The following DataGridViewAutoSizeColumnModeEventArgs properties provide information specific to this event.

Property | Description
Column | Gets the column with the DataGridViewColumn.AutoSizeMode property that changed.
PreviousMode | Gets the previous value of the DataGridViewColumn.AutoSizeMode property of the column.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


AutoSizeColumnsModeChanged Event

[image]
Gizmox.WebGUI.Forms
AutoSizeColumnsModeChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : AutoSizeColumnsModeChanged Event

Occurs when the value of the DataGridView.AutoSizeColumnsMode property changes.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Property Changed")>
<SRDescriptionAttribute("Occurs when the value of the AutoSizeColumnsMode property changes.")>
Public Event AutoSizeColumnsModeChanged() As DataGridViewAutoSizeColumnsModeEventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As DataGridViewAutoSizeColumnsModeEventHandler

AddHandler instance.AutoSizeColumnsModeChanged, handler
C#
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when the value of the AutoSizeColumnsMode property changes.")]
public event DataGridViewAutoSizeColumnsModeEventHandler AutoSizeColumnsModeChanged()
Managed Extensions for C++
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when the value of the AutoSizeColumnsMode property changes.")]
public: __event DataGridViewAutoSizeColumnsModeEventHandler* AutoSizeColumnsModeChanged
C++/CLI
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when the value of the AutoSizeColumnsMode property changes.")]
public:
event DataGridViewAutoSizeColumnsModeEventHandler^ AutoSizeColumnsModeChanged

Event Data

The event handler receives an argument of type DataGridViewAutoSizeColumnsModeEventArgs containing data related to this event. The following DataGridViewAutoSizeColumnsModeEventArgs properties provide information specific to this event.

Property | Description
PreviousModes | Gets an array of the previous values of the column DataGridViewColumn.AutoSizeMode properties.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


AutoSizeRowsModeChanged Event

[image]
Gizmox.WebGUI.Forms
AutoSizeRowsModeChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : AutoSizeRowsModeChanged Event

Occurs when the value of the DataGridViewAutoSizeRowsMode property changes.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the value of the AutoSizeRowsMode property changes.")>
<SRCategoryAttribute("Property Changed")>
Public Event AutoSizeRowsModeChanged() As DataGridViewAutoSizeModeEventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As DataGridViewAutoSizeModeEventHandler

AddHandler instance.AutoSizeRowsModeChanged, handler
C#
[SRDescriptionAttribute("Occurs when the value of the AutoSizeRowsMode property changes.")]
[SRCategoryAttribute("Property Changed")]
public event DataGridViewAutoSizeModeEventHandler AutoSizeRowsModeChanged()
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the value of the AutoSizeRowsMode property changes.")]
[SRCategoryAttribute("Property Changed")]
public: __event DataGridViewAutoSizeModeEventHandler* AutoSizeRowsModeChanged
C++/CLI
[SRDescriptionAttribute("Occurs when the value of the AutoSizeRowsMode property changes.")]
[SRCategoryAttribute("Property Changed")]
public:
event DataGridViewAutoSizeModeEventHandler^ AutoSizeRowsModeChanged

Event Data

The event handler receives an argument of type DataGridViewAutoSizeModeEventArgs containing data related to this event. The following DataGridViewAutoSizeModeEventArgs properties provide information specific to this event.

Property | Description
PreviousModeAutoSized | Gets a value specifying whether the DataGridView was previously set to automatically resize.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


BackgroundColorChanged Event

[image]
Gizmox.WebGUI.Forms
BackgroundColorChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : BackgroundColorChanged Event

Occurs when the value of the BackgroundColor property changes.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the value of the DataGridView.BackgroundColor property changes.")>
<SRCategoryAttribute("Property Changed")>
Public Event BackgroundColorChanged() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As EventHandler

AddHandler instance.BackgroundColorChanged, handler
C#
[SRDescriptionAttribute("Occurs when the value of the DataGridView.BackgroundColor property changes.")]
[SRCategoryAttribute("Property Changed")]
public event EventHandler BackgroundColorChanged()
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the value of the DataGridView.BackgroundColor property changes.")]
[SRCategoryAttribute("Property Changed")]
public: __event EventHandler* BackgroundColorChanged
C++/CLI
[SRDescriptionAttribute("Occurs when the value of the DataGridView.BackgroundColor property changes.")]
[SRCategoryAttribute("Property Changed")]
public:
event EventHandler^ BackgroundColorChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


BorderStyleChanged Event

[image]
Gizmox.WebGUI.Forms
BorderStyleChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : BorderStyleChanged Event

Occurs when the value of the BorderStyle property changes.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the value of the BorderStyle property changes.")>
<SRCategoryAttribute("Property Changed")>
Public Event BorderStyleChanged() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As EventHandler

AddHandler instance.BorderStyleChanged, handler
C#
[SRDescriptionAttribute("Occurs when the value of the BorderStyle property changes.")]
[SRCategoryAttribute("Property Changed")]
public event EventHandler BorderStyleChanged()
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the value of the BorderStyle property changes.")]
[SRCategoryAttribute("Property Changed")]
public: __event EventHandler* BorderStyleChanged
C++/CLI
[SRDescriptionAttribute("Occurs when the value of the BorderStyle property changes.")]
[SRCategoryAttribute("Property Changed")]
public:
event EventHandler^ BorderStyleChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


CancelRowEdit Event

[image]
Gizmox.WebGUI.Forms
CancelRowEdit Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : CancelRowEdit Event

Occurs when the VirtualMode property of a DataGridView control is true and the cancels edits in a row.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the DataGridView.VirtualMode property of a DataGridView control is true and a row edit should be canceled.")>
<SRCategoryAttribute("Action")>
Public Event CancelRowEdit() As QuestionEventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As QuestionEventHandler

AddHandler instance.CancelRowEdit, handler
C#
[SRDescriptionAttribute("Occurs when the DataGridView.VirtualMode property of a DataGridView control is true and a row edit should be canceled.")]
[SRCategoryAttribute("Action")]
public event QuestionEventHandler CancelRowEdit()
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the DataGridView.VirtualMode property of a DataGridView control is true and a row edit should be canceled.")]
[SRCategoryAttribute("Action")]
public: __event QuestionEventHandler* CancelRowEdit
C++/CLI
[SRDescriptionAttribute("Occurs when the DataGridView.VirtualMode property of a DataGridView control is true and a row edit should be canceled.")]
[SRCategoryAttribute("Action")]
public:
event QuestionEventHandler^ CancelRowEdit

Event Data

The event handler receives an argument of type QuestionEventArgs containing data related to this event. The following QuestionEventArgs properties provide information specific to this event.

Property | Description
Response | Gets or sets a value indicating the response to a question represented by the event.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


CellBeginEdit Event

[image]
Gizmox.WebGUI.Forms
CellBeginEdit Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : CellBeginEdit Event

Occurs when edit mode starts for the selected cell.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Data")>
<SRDescriptionAttribute("Occurs when edit mode starts for the selected cell.")>
Public Event CellBeginEdit() As DataGridViewCellCancelEventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As DataGridViewCellCancelEventHandler

AddHandler instance.CellBeginEdit, handler
C#
[SRCategoryAttribute("Data")]
[SRDescriptionAttribute("Occurs when edit mode starts for the selected cell.")]
public event DataGridViewCellCancelEventHandler CellBeginEdit()
Managed Extensions for C++
[SRCategoryAttribute("Data")]
[SRDescriptionAttribute("Occurs when edit mode starts for the selected cell.")]
public: __event DataGridViewCellCancelEventHandler* CellBeginEdit
C++/CLI
[SRCategoryAttribute("Data")]
[SRDescriptionAttribute("Occurs when edit mode starts for the selected cell.")]
public:
event DataGridViewCellCancelEventHandler^ CellBeginEdit

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


CellBorderStyleChanged Event

[image]
Gizmox.WebGUI.Forms
CellBorderStyleChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : CellBorderStyleChanged Event

Occurs when the border style of a cell changes.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the border style of a cell changes.")>
<SRCategoryAttribute("Property Changed")>
Public Event CellBorderStyleChanged() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As EventHandler

AddHandler instance.CellBorderStyleChanged, handler
C#
[SRDescriptionAttribute("Occurs when the border style of a cell changes.")]
[SRCategoryAttribute("Property Changed")]
public event EventHandler CellBorderStyleChanged()
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the border style of a cell changes.")]
[SRCategoryAttribute("Property Changed")]
public: __event EventHandler* CellBorderStyleChanged
C++/CLI
[SRDescriptionAttribute("Occurs when the border style of a cell changes.")]
[SRCategoryAttribute("Property Changed")]
public:
event EventHandler^ CellBorderStyleChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


CellClick Event

[image]
Gizmox.WebGUI.Forms
CellClick Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : CellClick Event

Occurs when any part of a cell is clicked.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when any part of the cell is clicked.")>
<SRCategoryAttribute("Mouse")>
Public Event CellClick() As DataGridViewCellEventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As DataGridViewCellEventHandler

AddHandler instance.CellClick, handler
C#
[SRDescriptionAttribute("Occurs when any part of the cell is clicked.")]
[SRCategoryAttribute("Mouse")]
public event DataGridViewCellEventHandler CellClick()
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when any part of the cell is clicked.")]
[SRCategoryAttribute("Mouse")]
public: __event DataGridViewCellEventHandler* CellClick
C++/CLI
[SRDescriptionAttribute("Occurs when any part of the cell is clicked.")]
[SRCategoryAttribute("Mouse")]
public:
event DataGridViewCellEventHandler^ CellClick

Event Data

The event handler receives an argument of type DataGridViewCellEventArgs containing data related to this event. The following DataGridViewCellEventArgs properties provide information specific to this event.

Property | Description
ColumnIndex | Gets a value indicating the column index of the cell that the event occurs for.
RowIndex | Gets a value indicating the row index of the cell that the event occurs for.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


CellContentClick Event

[image]
Gizmox.WebGUI.Forms
CellContentClick Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : CellContentClick Event

Occurs when the content within a cell is clicked.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("DataGridView_FireCellContentClick")>
<SRCategoryAttribute("Mouse")>
Public Event CellContentClick() As DataGridViewCellEventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As DataGridViewCellEventHandler

AddHandler instance.CellContentClick, handler
C#
[SRDescriptionAttribute("DataGridView_FireCellContentClick")]
[SRCategoryAttribute("Mouse")]
public event DataGridViewCellEventHandler CellContentClick()
Managed Extensions for C++
[SRDescriptionAttribute("DataGridView_FireCellContentClick")]
[SRCategoryAttribute("Mouse")]
public: __event DataGridViewCellEventHandler* CellContentClick
C++/CLI
[SRDescriptionAttribute("DataGridView_FireCellContentClick")]
[SRCategoryAttribute("Mouse")]
public:
event DataGridViewCellEventHandler^ CellContentClick

Event Data

The event handler receives an argument of type DataGridViewCellEventArgs containing data related to this event. The following DataGridViewCellEventArgs properties provide information specific to this event.

Property | Description
ColumnIndex | Gets a value indicating the column index of the cell that the event occurs for.
RowIndex | Gets a value indicating the row index of the cell that the event occurs for.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


CellContentDoubleClick Event

[image]
Gizmox.WebGUI.Forms
CellContentDoubleClick Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : CellContentDoubleClick Event

Occurs when the user double-clicks a cell's contents.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Mouse")>
<SRDescriptionAttribute("Occurs when a user double-clicks a cell's contents.")>
Public Event CellContentDoubleClick() As DataGridViewCellEventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As DataGridViewCellEventHandler

AddHandler instance.CellContentDoubleClick, handler
C#
[SRCategoryAttribute("Mouse")]
[SRDescriptionAttribute("Occurs when a user double-clicks a cell's contents.")]
public event DataGridViewCellEventHandler CellContentDoubleClick()
Managed Extensions for C++
[SRCategoryAttribute("Mouse")]
[SRDescriptionAttribute("Occurs when a user double-clicks a cell's contents.")]
public: __event DataGridViewCellEventHandler* CellContentDoubleClick
C++/CLI
[SRCategoryAttribute("Mouse")]
[SRDescriptionAttribute("Occurs when a user double-clicks a cell's contents.")]
public:
event DataGridViewCellEventHandler^ CellContentDoubleClick

Event Data

The event handler receives an argument of type DataGridViewCellEventArgs containing data related to this event. The following DataGridViewCellEventArgs properties provide information specific to this event.

Property | Description
ColumnIndex | Gets a value indicating the column index of the cell that the event occurs for.
RowIndex | Gets a value indicating the row index of the cell that the event occurs for.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


CellContextMenuStripChanged Event

[image]
Gizmox.WebGUI.Forms
CellContextMenuStripChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : CellContextMenuStripChanged Event

Occurs when the ContextMenuStrip property changes.

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<SRDescriptionAttribute("Occurs when the DataGridViewCell.ContextMenuStrip property changes. ")>
<SRCategoryAttribute("Action")>
Public Event CellContextMenuStripChanged() As DataGridViewCellEventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As DataGridViewCellEventHandler

AddHandler instance.CellContextMenuStripChanged, handler
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRDescriptionAttribute("Occurs when the DataGridViewCell.ContextMenuStrip property changes. ")]
[SRCategoryAttribute("Action")]
public event DataGridViewCellEventHandler CellContextMenuStripChanged()
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRDescriptionAttribute("Occurs when the DataGridViewCell.ContextMenuStrip property changes. ")]
[SRCategoryAttribute("Action")]
public: __event DataGridViewCellEventHandler* CellContextMenuStripChanged
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRDescriptionAttribute("Occurs when the DataGridViewCell.ContextMenuStrip property changes. ")]
[SRCategoryAttribute("Action")]
public:
event DataGridViewCellEventHandler^ CellContextMenuStripChanged

Event Data

The event handler receives an argument of type DataGridViewCellEventArgs containing data related to this event. The following DataGridViewCellEventArgs properties provide information specific to this event.

Property | Description
ColumnIndex | Gets a value indicating the column index of the cell that the event occurs for.
RowIndex | Gets a value indicating the row index of the cell that the event occurs for.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


CellDoubleClick Event

[image]
Gizmox.WebGUI.Forms
CellDoubleClick Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : CellDoubleClick Event

Occurs when the user double-clicks anywhere in a cell.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Mouse")>
<SRDescriptionAttribute("Occurs when the user double-clicks anywhere in a cell.")>
Public Event CellDoubleClick() As DataGridViewCellEventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As DataGridViewCellEventHandler

AddHandler instance.CellDoubleClick, handler
C#
[SRCategoryAttribute("Mouse")]
[SRDescriptionAttribute("Occurs when the user double-clicks anywhere in a cell.")]
public event DataGridViewCellEventHandler CellDoubleClick()
Managed Extensions for C++
[SRCategoryAttribute("Mouse")]
[SRDescriptionAttribute("Occurs when the user double-clicks anywhere in a cell.")]
public: __event DataGridViewCellEventHandler* CellDoubleClick
C++/CLI
[SRCategoryAttribute("Mouse")]
[SRDescriptionAttribute("Occurs when the user double-clicks anywhere in a cell.")]
public:
event DataGridViewCellEventHandler^ CellDoubleClick

Event Data

The event handler receives an argument of type DataGridViewCellEventArgs containing data related to this event. The following DataGridViewCellEventArgs properties provide information specific to this event.

Property | Description
ColumnIndex | Gets a value indicating the column index of the cell that the event occurs for.
RowIndex | Gets a value indicating the row index of the cell that the event occurs for.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


CellEndEdit Event

[image]
Gizmox.WebGUI.Forms
CellEndEdit Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : CellEndEdit Event

Occurs when edit mode stops for the currently selected cell.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Data")>
<SRDescriptionAttribute("Occurs when edit mode stops for the currently selected cell.")>
Public Event CellEndEdit() As DataGridViewCellEventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As DataGridViewCellEventHandler

AddHandler instance.CellEndEdit, handler
C#
[SRCategoryAttribute("Data")]
[SRDescriptionAttribute("Occurs when edit mode stops for the currently selected cell.")]
public event DataGridViewCellEventHandler CellEndEdit()
Managed Extensions for C++
[SRCategoryAttribute("Data")]
[SRDescriptionAttribute("Occurs when edit mode stops for the currently selected cell.")]
public: __event DataGridViewCellEventHandler* CellEndEdit
C++/CLI
[SRCategoryAttribute("Data")]
[SRDescriptionAttribute("Occurs when edit mode stops for the currently selected cell.")]
public:
event DataGridViewCellEventHandler^ CellEndEdit

Event Data

The event handler receives an argument of type DataGridViewCellEventArgs containing data related to this event. The following DataGridViewCellEventArgs properties provide information specific to this event.

Property | Description
ColumnIndex | Gets a value indicating the column index of the cell that the event occurs for.
RowIndex | Gets a value indicating the row index of the cell that the event occurs for.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


CellEnter Event

[image]
Gizmox.WebGUI.Forms
CellEnter Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : CellEnter Event

Occurs when the current cell changes in the DataGridView control or when the control receives input focus.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the cell receives input focus, becoming the current cell in the DataGridView.")>
<SRCategoryAttribute("Focus")>
Public Event CellEnter() As DataGridViewCellEventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As DataGridViewCellEventHandler

AddHandler instance.CellEnter, handler
C#
[SRDescriptionAttribute("Occurs when the cell receives input focus, becoming the current cell in the DataGridView.")]
[SRCategoryAttribute("Focus")]
public event DataGridViewCellEventHandler CellEnter()
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the cell receives input focus, becoming the current cell in the DataGridView.")]
[SRCategoryAttribute("Focus")]
public: __event DataGridViewCellEventHandler* CellEnter
C++/CLI
[SRDescriptionAttribute("Occurs when the cell receives input focus, becoming the current cell in the DataGridView.")]
[SRCategoryAttribute("Focus")]
public:
event DataGridViewCellEventHandler^ CellEnter

Event Data

The event handler receives an argument of type DataGridViewCellEventArgs containing data related to this event. The following DataGridViewCellEventArgs properties provide information specific to this event.

Property | Description
ColumnIndex | Gets a value indicating the column index of the cell that the event occurs for.
RowIndex | Gets a value indicating the row index of the cell that the event occurs for.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


CellErrorTextChanged Event

[image]
Gizmox.WebGUI.Forms
CellErrorTextChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : CellErrorTextChanged Event

Occurs when the value of the DataGridViewCell.ErrorText property of a cell changes.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the value of the DataGridViewCell.ErrorText property of a cell changes.")>
<SRCategoryAttribute("Property Changed")>
Public Event CellErrorTextChanged() As DataGridViewCellEventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As DataGridViewCellEventHandler

AddHandler instance.CellErrorTextChanged, handler
C#
[SRDescriptionAttribute("Occurs when the value of the DataGridViewCell.ErrorText property of a cell changes.")]
[SRCategoryAttribute("Property Changed")]
public event DataGridViewCellEventHandler CellErrorTextChanged()
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the value of the DataGridViewCell.ErrorText property of a cell changes.")]
[SRCategoryAttribute("Property Changed")]
public: __event DataGridViewCellEventHandler* CellErrorTextChanged
C++/CLI
[SRDescriptionAttribute("Occurs when the value of the DataGridViewCell.ErrorText property of a cell changes.")]
[SRCategoryAttribute("Property Changed")]
public:
event DataGridViewCellEventHandler^ CellErrorTextChanged

Event Data

The event handler receives an argument of type DataGridViewCellEventArgs containing data related to this event. The following DataGridViewCellEventArgs properties provide information specific to this event.

Property | Description
ColumnIndex | Gets a value indicating the column index of the cell that the event occurs for.
RowIndex | Gets a value indicating the row index of the cell that the event occurs for.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


CellErrorTextNeeded Event

[image]
Gizmox.WebGUI.Forms
CellErrorTextNeeded Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : CellErrorTextNeeded Event

Occurs when a cell's error text is needed.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when a cell's error text is needed.")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<SRCategoryAttribute("Data")>
Public Event CellErrorTextNeeded() As DataGridViewCellErrorTextNeededEventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As DataGridViewCellErrorTextNeededEventHandler

AddHandler instance.CellErrorTextNeeded, handler
C#
[SRDescriptionAttribute("Occurs when a cell's error text is needed.")]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRCategoryAttribute("Data")]
public event DataGridViewCellErrorTextNeededEventHandler CellErrorTextNeeded()
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when a cell's error text is needed.")]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRCategoryAttribute("Data")]
public: __event DataGridViewCellErrorTextNeededEventHandler* CellErrorTextNeeded
C++/CLI
[SRDescriptionAttribute("Occurs when a cell's error text is needed.")]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRCategoryAttribute("Data")]
public:
event DataGridViewCellErrorTextNeededEventHandler^ CellErrorTextNeeded

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


CellFormatting Event

[image]
Gizmox.WebGUI.Forms
CellFormatting Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : CellFormatting Event

Occurs when the contents of a cell need to be formatted for display.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the contents of a cell need to be formatted for display.")>
<SRCategoryAttribute("Display")>
Public Event CellFormatting() As DataGridViewCellFormattingEventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As DataGridViewCellFormattingEventHandler

AddHandler instance.CellFormatting, handler
C#
[SRDescriptionAttribute("Occurs when the contents of a cell need to be formatted for display.")]
[SRCategoryAttribute("Display")]
public event DataGridViewCellFormattingEventHandler CellFormatting()
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the contents of a cell need to be formatted for display.")]
[SRCategoryAttribute("Display")]
public: __event DataGridViewCellFormattingEventHandler* CellFormatting
C++/CLI
[SRDescriptionAttribute("Occurs when the contents of a cell need to be formatted for display.")]
[SRCategoryAttribute("Display")]
public:
event DataGridViewCellFormattingEventHandler^ CellFormatting

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


CellLeave Event

[image]
Gizmox.WebGUI.Forms
CellLeave Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : CellLeave Event

Occurs when a cell loses input focus and is no longer the current cell.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when a cell loses input focus and is no longer the current cell.")>
<SRCategoryAttribute("Focus")>
Public Event CellLeave() As DataGridViewCellEventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As DataGridViewCellEventHandler

AddHandler instance.CellLeave, handler
C#
[SRDescriptionAttribute("Occurs when a cell loses input focus and is no longer the current cell.")]
[SRCategoryAttribute("Focus")]
public event DataGridViewCellEventHandler CellLeave()
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when a cell loses input focus and is no longer the current cell.")]
[SRCategoryAttribute("Focus")]
public: __event DataGridViewCellEventHandler* CellLeave
C++/CLI
[SRDescriptionAttribute("Occurs when a cell loses input focus and is no longer the current cell.")]
[SRCategoryAttribute("Focus")]
public:
event DataGridViewCellEventHandler^ CellLeave

Event Data

The event handler receives an argument of type DataGridViewCellEventArgs containing data related to this event. The following DataGridViewCellEventArgs properties provide information specific to this event.

Property | Description
ColumnIndex | Gets a value indicating the column index of the cell that the event occurs for.
RowIndex | Gets a value indicating the row index of the cell that the event occurs for.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


CellMouseClick Event

[image]
Gizmox.WebGUI.Forms
CellMouseClick Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : CellMouseClick Event

Occurs whenever the user clicks anywhere on a cell with the mouse.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Mouse")>
<SRDescriptionAttribute("Occurs whenever a mouse clicks anywhere on a cell.")>
Public Event CellMouseClick() As DataGridViewCellMouseEventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As DataGridViewCellMouseEventHandler

AddHandler instance.CellMouseClick, handler
C#
[SRCategoryAttribute("Mouse")]
[SRDescriptionAttribute("Occurs whenever a mouse clicks anywhere on a cell.")]
public event DataGridViewCellMouseEventHandler CellMouseClick()
Managed Extensions for C++
[SRCategoryAttribute("Mouse")]
[SRDescriptionAttribute("Occurs whenever a mouse clicks anywhere on a cell.")]
public: __event DataGridViewCellMouseEventHandler* CellMouseClick
C++/CLI
[SRCategoryAttribute("Mouse")]
[SRDescriptionAttribute("Occurs whenever a mouse clicks anywhere on a cell.")]
public:
event DataGridViewCellMouseEventHandler^ CellMouseClick

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


CellMouseDoubleClick Event

[image]
Gizmox.WebGUI.Forms
CellMouseDoubleClick Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : CellMouseDoubleClick Event

Occurs when a cell within the DataGridView is double-clicked.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Mouse")>
<SRDescriptionAttribute("Occurs when a cell within the DataGridView is double-clicked.")>
Public Event CellMouseDoubleClick() As DataGridViewCellMouseEventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As DataGridViewCellMouseEventHandler

AddHandler instance.CellMouseDoubleClick, handler
C#
[SRCategoryAttribute("Mouse")]
[SRDescriptionAttribute("Occurs when a cell within the DataGridView is double-clicked.")]
public event DataGridViewCellMouseEventHandler CellMouseDoubleClick()
Managed Extensions for C++
[SRCategoryAttribute("Mouse")]
[SRDescriptionAttribute("Occurs when a cell within the DataGridView is double-clicked.")]
public: __event DataGridViewCellMouseEventHandler* CellMouseDoubleClick
C++/CLI
[SRCategoryAttribute("Mouse")]
[SRDescriptionAttribute("Occurs when a cell within the DataGridView is double-clicked.")]
public:
event DataGridViewCellMouseEventHandler^ CellMouseDoubleClick

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


CellMouseDown Event

[image]
Gizmox.WebGUI.Forms
CellMouseDown Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : CellMouseDown Event

Occurs when the user presses a mouse button while the mouse pointer is within the boundaries of a cell.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Mouse")>
<SRDescriptionAttribute("Occurs when the user presses a mouse button while the mouse pointer is within the boundaries of a cell.")>
Public Event CellMouseDown() As DataGridViewCellMouseEventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As DataGridViewCellMouseEventHandler

AddHandler instance.CellMouseDown, handler
C#
[SRCategoryAttribute("Mouse")]
[SRDescriptionAttribute("Occurs when the user presses a mouse button while the mouse pointer is within the boundaries of a cell.")]
public event DataGridViewCellMouseEventHandler CellMouseDown()
Managed Extensions for C++
[SRCategoryAttribute("Mouse")]
[SRDescriptionAttribute("Occurs when the user presses a mouse button while the mouse pointer is within the boundaries of a cell.")]
public: __event DataGridViewCellMouseEventHandler* CellMouseDown
C++/CLI
[SRCategoryAttribute("Mouse")]
[SRDescriptionAttribute("Occurs when the user presses a mouse button while the mouse pointer is within the boundaries of a cell.")]
public:
event DataGridViewCellMouseEventHandler^ CellMouseDown

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


CellMouseEnter Event

[image]
Gizmox.WebGUI.Forms
CellMouseEnter Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : CellMouseEnter Event

Occurs when the mouse pointer enters a cell.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the mouse pointer enters a cell.")>
<SRCategoryAttribute("Mouse")>
Public Event CellMouseEnter() As DataGridViewCellEventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As DataGridViewCellEventHandler

AddHandler instance.CellMouseEnter, handler
C#
[SRDescriptionAttribute("Occurs when the mouse pointer enters a cell.")]
[SRCategoryAttribute("Mouse")]
public event DataGridViewCellEventHandler CellMouseEnter()
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the mouse pointer enters a cell.")]
[SRCategoryAttribute("Mouse")]
public: __event DataGridViewCellEventHandler* CellMouseEnter
C++/CLI
[SRDescriptionAttribute("Occurs when the mouse pointer enters a cell.")]
[SRCategoryAttribute("Mouse")]
public:
event DataGridViewCellEventHandler^ CellMouseEnter

Event Data

The event handler receives an argument of type DataGridViewCellEventArgs containing data related to this event. The following DataGridViewCellEventArgs properties provide information specific to this event.

Property | Description
ColumnIndex | Gets a value indicating the column index of the cell that the event occurs for.
RowIndex | Gets a value indicating the row index of the cell that the event occurs for.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


CellMouseLeave Event

[image]
Gizmox.WebGUI.Forms
CellMouseLeave Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : CellMouseLeave Event

Occurs when the mouse pointer leaves a cell.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the mouse pointer leaves a cell.")>
<SRCategoryAttribute("Mouse")>
Public Event CellMouseLeave() As DataGridViewCellEventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As DataGridViewCellEventHandler

AddHandler instance.CellMouseLeave, handler
C#
[SRDescriptionAttribute("Occurs when the mouse pointer leaves a cell.")]
[SRCategoryAttribute("Mouse")]
public event DataGridViewCellEventHandler CellMouseLeave()
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the mouse pointer leaves a cell.")]
[SRCategoryAttribute("Mouse")]
public: __event DataGridViewCellEventHandler* CellMouseLeave
C++/CLI
[SRDescriptionAttribute("Occurs when the mouse pointer leaves a cell.")]
[SRCategoryAttribute("Mouse")]
public:
event DataGridViewCellEventHandler^ CellMouseLeave

Event Data

The event handler receives an argument of type DataGridViewCellEventArgs containing data related to this event. The following DataGridViewCellEventArgs properties provide information specific to this event.

Property | Description
ColumnIndex | Gets a value indicating the column index of the cell that the event occurs for.
RowIndex | Gets a value indicating the row index of the cell that the event occurs for.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


CellMouseMove Event

[image]
Gizmox.WebGUI.Forms
CellMouseMove Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : CellMouseMove Event

Occurs when the mouse pointer moves over the DataGridView control.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the mouse pointer moves over the DataGridView control.")>
<SRCategoryAttribute("Mouse")>
Public Event CellMouseMove() As DataGridViewCellMouseEventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As DataGridViewCellMouseEventHandler

AddHandler instance.CellMouseMove, handler
C#
[SRDescriptionAttribute("Occurs when the mouse pointer moves over the DataGridView control.")]
[SRCategoryAttribute("Mouse")]
public event DataGridViewCellMouseEventHandler CellMouseMove()
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the mouse pointer moves over the DataGridView control.")]
[SRCategoryAttribute("Mouse")]
public: __event DataGridViewCellMouseEventHandler* CellMouseMove
C++/CLI
[SRDescriptionAttribute("Occurs when the mouse pointer moves over the DataGridView control.")]
[SRCategoryAttribute("Mouse")]
public:
event DataGridViewCellMouseEventHandler^ CellMouseMove

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


CellMouseUp Event

[image]
Gizmox.WebGUI.Forms
CellMouseUp Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : CellMouseUp Event

Occurs when the user releases a mouse button while over a cell.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Mouse")>
<SRDescriptionAttribute("Occurs when the user releases a mouse button while over a cell.")>
Public Event CellMouseUp() As DataGridViewCellMouseEventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As DataGridViewCellMouseEventHandler

AddHandler instance.CellMouseUp, handler
C#
[SRCategoryAttribute("Mouse")]
[SRDescriptionAttribute("Occurs when the user releases a mouse button while over a cell.")]
public event DataGridViewCellMouseEventHandler CellMouseUp()
Managed Extensions for C++
[SRCategoryAttribute("Mouse")]
[SRDescriptionAttribute("Occurs when the user releases a mouse button while over a cell.")]
public: __event DataGridViewCellMouseEventHandler* CellMouseUp
C++/CLI
[SRCategoryAttribute("Mouse")]
[SRDescriptionAttribute("Occurs when the user releases a mouse button while over a cell.")]
public:
event DataGridViewCellMouseEventHandler^ CellMouseUp

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


CellParsing Event

[image]
Gizmox.WebGUI.Forms
CellParsing Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : CellParsing Event

Occurs when a cell leaves edit mode if the cell value has been modified.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Display")>
<SRDescriptionAttribute("Occurs when the user leaves edit mode, regardless of whether the value of the current cell has been modified.")>
Public Event CellParsing() As DataGridViewCellParsingEventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As DataGridViewCellParsingEventHandler

AddHandler instance.CellParsing, handler
C#
[SRCategoryAttribute("Display")]
[SRDescriptionAttribute("Occurs when the user leaves edit mode, regardless of whether the value of the current cell has been modified.")]
public event DataGridViewCellParsingEventHandler CellParsing()
Managed Extensions for C++
[SRCategoryAttribute("Display")]
[SRDescriptionAttribute("Occurs when the user leaves edit mode, regardless of whether the value of the current cell has been modified.")]
public: __event DataGridViewCellParsingEventHandler* CellParsing
C++/CLI
[SRCategoryAttribute("Display")]
[SRDescriptionAttribute("Occurs when the user leaves edit mode, regardless of whether the value of the current cell has been modified.")]
public:
event DataGridViewCellParsingEventHandler^ CellParsing

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


CellStateChanged Event

[image]
Gizmox.WebGUI.Forms
CellStateChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : CellStateChanged Event

Occurs when a cell state changes, such as when the cell loses or gains focus.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when a cell state changes, such as when the cell loses or gains focus.")>
<SRCategoryAttribute("Behavior")>
Public Event CellStateChanged() As DataGridViewCellStateChangedEventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As DataGridViewCellStateChangedEventHandler

AddHandler instance.CellStateChanged, handler
C#
[SRDescriptionAttribute("Occurs when a cell state changes, such as when the cell loses or gains focus.")]
[SRCategoryAttribute("Behavior")]
public event DataGridViewCellStateChangedEventHandler CellStateChanged()
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when a cell state changes, such as when the cell loses or gains focus.")]
[SRCategoryAttribute("Behavior")]
public: __event DataGridViewCellStateChangedEventHandler* CellStateChanged
C++/CLI
[SRDescriptionAttribute("Occurs when a cell state changes, such as when the cell loses or gains focus.")]
[SRCategoryAttribute("Behavior")]
public:
event DataGridViewCellStateChangedEventHandler^ CellStateChanged

Event Data

The event handler receives an argument of type DataGridViewCellStateChangedEventArgs containing data related to this event. The following DataGridViewCellStateChangedEventArgs properties provide information specific to this event.

Property | Description
Cell | Gets the DataGridViewCell that has a changed state.
StateChanged | Gets the state that has changed on the cell.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


CellStyleChanged Event

[image]
Gizmox.WebGUI.Forms
CellStyleChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : CellStyleChanged Event

Occurs when the DataGridViewCell.Style property of a DataGridViewCell changes.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Property Changed")>
<SRDescriptionAttribute("Occurs when the DataGridViewCell.Style property of a DataGridViewCell changes.")>
Public Event CellStyleChanged() As DataGridViewCellEventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As DataGridViewCellEventHandler

AddHandler instance.CellStyleChanged, handler
C#
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when the DataGridViewCell.Style property of a DataGridViewCell changes.")]
public event DataGridViewCellEventHandler CellStyleChanged()
Managed Extensions for C++
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when the DataGridViewCell.Style property of a DataGridViewCell changes.")]
public: __event DataGridViewCellEventHandler* CellStyleChanged
C++/CLI
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when the DataGridViewCell.Style property of a DataGridViewCell changes.")]
public:
event DataGridViewCellEventHandler^ CellStyleChanged

Event Data

The event handler receives an argument of type DataGridViewCellEventArgs containing data related to this event. The following DataGridViewCellEventArgs properties provide information specific to this event.

Property | Description
ColumnIndex | Gets a value indicating the column index of the cell that the event occurs for.
RowIndex | Gets a value indicating the row index of the cell that the event occurs for.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


CellStyleContentChanged Event

[image]
Gizmox.WebGUI.Forms
CellStyleContentChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : CellStyleContentChanged Event

Occurs when one of the values of a cell style changes.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Property Changed")>
<SRDescriptionAttribute("Occurs when one of the values of a cell style changes.")>
Public Event CellStyleContentChanged() As DataGridViewCellStyleContentChangedEventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As DataGridViewCellStyleContentChangedEventHandler

AddHandler instance.CellStyleContentChanged, handler
C#
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when one of the values of a cell style changes.")]
public event DataGridViewCellStyleContentChangedEventHandler CellStyleContentChanged()
Managed Extensions for C++
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when one of the values of a cell style changes.")]
public: __event DataGridViewCellStyleContentChangedEventHandler* CellStyleContentChanged
C++/CLI
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when one of the values of a cell style changes.")]
public:
event DataGridViewCellStyleContentChangedEventHandler^ CellStyleContentChanged

Event Data

The event handler receives an argument of type DataGridViewCellStyleContentChangedEventArgs containing data related to this event. The following DataGridViewCellStyleContentChangedEventArgs properties provide information specific to this event.

Property | Description
CellStyle | Gets the changed DataGridViewCellStyle.
CellStyleScope | Gets the scope that is affected by the changed cell style.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


CellToolTipTextChanged Event

[image]
Gizmox.WebGUI.Forms
CellToolTipTextChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : CellToolTipTextChanged Event

Occurs when the DataGridViewCell.ToolTipText property value changes for a cell in the DataGridView.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Property Changed")>
<SRDescriptionAttribute("Occurs when the DataGridViewCell.ToolTipText property value changes for a cell in the DataGridView.")>
Public Event CellToolTipTextChanged() As DataGridViewCellEventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As DataGridViewCellEventHandler

AddHandler instance.CellToolTipTextChanged, handler
C#
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when the DataGridViewCell.ToolTipText property value changes for a cell in the DataGridView.")]
public event DataGridViewCellEventHandler CellToolTipTextChanged()
Managed Extensions for C++
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when the DataGridViewCell.ToolTipText property value changes for a cell in the DataGridView.")]
public: __event DataGridViewCellEventHandler* CellToolTipTextChanged
C++/CLI
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when the DataGridViewCell.ToolTipText property value changes for a cell in the DataGridView.")]
public:
event DataGridViewCellEventHandler^ CellToolTipTextChanged

Event Data

The event handler receives an argument of type DataGridViewCellEventArgs containing data related to this event. The following DataGridViewCellEventArgs properties provide information specific to this event.

Property | Description
ColumnIndex | Gets a value indicating the column index of the cell that the event occurs for.
RowIndex | Gets a value indicating the row index of the cell that the event occurs for.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


CellToolTipTextNeeded Event

[image]
Gizmox.WebGUI.Forms
CellToolTipTextNeeded Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : CellToolTipTextNeeded Event

Occurs when a cell's ToolTip text is needed.

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<SRCategoryAttribute("Behavior")>
<SRDescriptionAttribute("Occurs when a cell's ToolTip text is needed.")>
Public Event CellToolTipTextNeeded() As DataGridViewCellToolTipTextNeededEventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As DataGridViewCellToolTipTextNeededEventHandler

AddHandler instance.CellToolTipTextNeeded, handler
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when a cell's ToolTip text is needed.")]
public event DataGridViewCellToolTipTextNeededEventHandler CellToolTipTextNeeded()
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when a cell's ToolTip text is needed.")]
public: __event DataGridViewCellToolTipTextNeededEventHandler* CellToolTipTextNeeded
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when a cell's ToolTip text is needed.")]
public:
event DataGridViewCellToolTipTextNeededEventHandler^ CellToolTipTextNeeded

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


CellValidated Event

[image]
Gizmox.WebGUI.Forms
CellValidated Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : CellValidated Event

Occurs after the cell has finished validating.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs after the cell has finished validating.")>
<SRCategoryAttribute("Focus")>
Public Event CellValidated() As DataGridViewCellEventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As DataGridViewCellEventHandler

AddHandler instance.CellValidated, handler
C#
[SRDescriptionAttribute("Occurs after the cell has finished validating.")]
[SRCategoryAttribute("Focus")]
public event DataGridViewCellEventHandler CellValidated()
Managed Extensions for C++
[SRDescriptionAttribute("Occurs after the cell has finished validating.")]
[SRCategoryAttribute("Focus")]
public: __event DataGridViewCellEventHandler* CellValidated
C++/CLI
[SRDescriptionAttribute("Occurs after the cell has finished validating.")]
[SRCategoryAttribute("Focus")]
public:
event DataGridViewCellEventHandler^ CellValidated

Event Data

The event handler receives an argument of type DataGridViewCellEventArgs containing data related to this event. The following DataGridViewCellEventArgs properties provide information specific to this event.

Property | Description
ColumnIndex | Gets a value indicating the column index of the cell that the event occurs for.
RowIndex | Gets a value indicating the row index of the cell that the event occurs for.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


CellValidating Event

[image]
Gizmox.WebGUI.Forms
CellValidating Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : CellValidating Event

Occurs when a cell loses input focus, enabling content validation.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Focus")>
<SRDescriptionAttribute("Occurs when the cell is validating.")>
Public Event CellValidating() As DataGridViewCellValidatingEventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As DataGridViewCellValidatingEventHandler

AddHandler instance.CellValidating, handler
C#
[SRCategoryAttribute("Focus")]
[SRDescriptionAttribute("Occurs when the cell is validating.")]
public event DataGridViewCellValidatingEventHandler CellValidating()
Managed Extensions for C++
[SRCategoryAttribute("Focus")]
[SRDescriptionAttribute("Occurs when the cell is validating.")]
public: __event DataGridViewCellValidatingEventHandler* CellValidating
C++/CLI
[SRCategoryAttribute("Focus")]
[SRDescriptionAttribute("Occurs when the cell is validating.")]
public:
event DataGridViewCellValidatingEventHandler^ CellValidating

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


CellValueChanged Event

[image]
Gizmox.WebGUI.Forms
CellValueChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : CellValueChanged Event

Occurs when the value of a cell changes.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Action")>
<SRDescriptionAttribute("Occurs when the value of a cell changes.")>
Public Event CellValueChanged() As DataGridViewCellEventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As DataGridViewCellEventHandler

AddHandler instance.CellValueChanged, handler
C#
[SRCategoryAttribute("Action")]
[SRDescriptionAttribute("Occurs when the value of a cell changes.")]
public event DataGridViewCellEventHandler CellValueChanged()
Managed Extensions for C++
[SRCategoryAttribute("Action")]
[SRDescriptionAttribute("Occurs when the value of a cell changes.")]
public: __event DataGridViewCellEventHandler* CellValueChanged
C++/CLI
[SRCategoryAttribute("Action")]
[SRDescriptionAttribute("Occurs when the value of a cell changes.")]
public:
event DataGridViewCellEventHandler^ CellValueChanged

Event Data

The event handler receives an argument of type DataGridViewCellEventArgs containing data related to this event. The following DataGridViewCellEventArgs properties provide information specific to this event.

Property | Description
ColumnIndex | Gets a value indicating the column index of the cell that the event occurs for.
RowIndex | Gets a value indicating the row index of the cell that the event occurs for.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


CellValueNeeded Event

[image]
Gizmox.WebGUI.Forms
CellValueNeeded Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : CellValueNeeded Event

Occurs when the VirtualMode property of the DataGridView control is true and the DataGridView requires a value for a cell in order to format and display the cell.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the DataGridView.VirtualMode property of the DataGridView control is true and the DataGridView requires a value for a cell in order to format and display the cell.")>
<SRCategoryAttribute("Data")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Event CellValueNeeded() As DataGridViewCellValueEventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As DataGridViewCellValueEventHandler

AddHandler instance.CellValueNeeded, handler
C#
[SRDescriptionAttribute("Occurs when the DataGridView.VirtualMode property of the DataGridView control is true and the DataGridView requires a value for a cell in order to format and display the cell.")]
[SRCategoryAttribute("Data")]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public event DataGridViewCellValueEventHandler CellValueNeeded()
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the DataGridView.VirtualMode property of the DataGridView control is true and the DataGridView requires a value for a cell in order to format and display the cell.")]
[SRCategoryAttribute("Data")]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: __event DataGridViewCellValueEventHandler* CellValueNeeded
C++/CLI
[SRDescriptionAttribute("Occurs when the DataGridView.VirtualMode property of the DataGridView control is true and the DataGridView requires a value for a cell in order to format and display the cell.")]
[SRCategoryAttribute("Data")]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
event DataGridViewCellValueEventHandler^ CellValueNeeded

Event Data

The event handler receives an argument of type DataGridViewCellValueEventArgs containing data related to this event. The following DataGridViewCellValueEventArgs properties provide information specific to this event.

Property | Description
ColumnIndex | Gets a value indicating the column index of the cell that the event occurs for.
RowIndex | Gets a value indicating the row index of the cell that the event occurs for.
Value | Gets or sets the value of the cell that the event occurs for.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


CellValuePushed Event

[image]
Gizmox.WebGUI.Forms
CellValuePushed Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : CellValuePushed Event

Occurs when the VirtualMode property of the DataGridView control is true and a cell value has changed and requires storage in the underlying data source.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Data")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<SRDescriptionAttribute("Occurs when the DataGridView.VirtualMode property of the DataGridView control is true, and a cell value has changed and requires storage in the underlying data source.")>
Public Event CellValuePushed() As DataGridViewCellValueEventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As DataGridViewCellValueEventHandler

AddHandler instance.CellValuePushed, handler
C#
[SRCategoryAttribute("Data")]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRDescriptionAttribute("Occurs when the DataGridView.VirtualMode property of the DataGridView control is true, and a cell value has changed and requires storage in the underlying data source.")]
public event DataGridViewCellValueEventHandler CellValuePushed()
Managed Extensions for C++
[SRCategoryAttribute("Data")]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRDescriptionAttribute("Occurs when the DataGridView.VirtualMode property of the DataGridView control is true, and a cell value has changed and requires storage in the underlying data source.")]
public: __event DataGridViewCellValueEventHandler* CellValuePushed
C++/CLI
[SRCategoryAttribute("Data")]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRDescriptionAttribute("Occurs when the DataGridView.VirtualMode property of the DataGridView control is true, and a cell value has changed and requires storage in the underlying data source.")]
public:
event DataGridViewCellValueEventHandler^ CellValuePushed

Event Data

The event handler receives an argument of type DataGridViewCellValueEventArgs containing data related to this event. The following DataGridViewCellValueEventArgs properties provide information specific to this event.

Property | Description
ColumnIndex | Gets a value indicating the column index of the cell that the event occurs for.
RowIndex | Gets a value indicating the row index of the cell that the event occurs for.
Value | Gets or sets the value of the cell that the event occurs for.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


ColumnAdded Event

[image]
Gizmox.WebGUI.Forms
ColumnAdded Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : ColumnAdded Event

Occurs when a column is added to the control.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Action")>
<SRDescriptionAttribute("Occurs when a column is added to the control.")>
Public Event ColumnAdded() As DataGridViewColumnEventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As DataGridViewColumnEventHandler

AddHandler instance.ColumnAdded, handler
C#
[SRCategoryAttribute("Action")]
[SRDescriptionAttribute("Occurs when a column is added to the control.")]
public event DataGridViewColumnEventHandler ColumnAdded()
Managed Extensions for C++
[SRCategoryAttribute("Action")]
[SRDescriptionAttribute("Occurs when a column is added to the control.")]
public: __event DataGridViewColumnEventHandler* ColumnAdded
C++/CLI
[SRCategoryAttribute("Action")]
[SRDescriptionAttribute("Occurs when a column is added to the control.")]
public:
event DataGridViewColumnEventHandler^ ColumnAdded

Event Data

The event handler receives an argument of type DataGridViewColumnEventArgs containing data related to this event. The following DataGridViewColumnEventArgs properties provide information specific to this event.

Property | Description
Column | Gets the column that the event occurs for.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


ColumnContextMenuStripChanged Event

[image]
Gizmox.WebGUI.Forms
ColumnContextMenuStripChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : ColumnContextMenuStripChanged Event

Occurs when the ContextMenuStrip property of a column changes.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Property Changed")>
<SRDescriptionAttribute("Occurs when the DataGridViewColumn.ContextMenuStrip property of a column changes.")>
Public Event ColumnContextMenuStripChanged() As DataGridViewColumnEventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As DataGridViewColumnEventHandler

AddHandler instance.ColumnContextMenuStripChanged, handler
C#
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when the DataGridViewColumn.ContextMenuStrip property of a column changes.")]
public event DataGridViewColumnEventHandler ColumnContextMenuStripChanged()
Managed Extensions for C++
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when the DataGridViewColumn.ContextMenuStrip property of a column changes.")]
public: __event DataGridViewColumnEventHandler* ColumnContextMenuStripChanged
C++/CLI
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when the DataGridViewColumn.ContextMenuStrip property of a column changes.")]
public:
event DataGridViewColumnEventHandler^ ColumnContextMenuStripChanged

Event Data

The event handler receives an argument of type DataGridViewColumnEventArgs containing data related to this event. The following DataGridViewColumnEventArgs properties provide information specific to this event.

Property | Description
Column | Gets the column that the event occurs for.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


ColumnDataPropertyNameChanged Event

[image]
Gizmox.WebGUI.Forms
ColumnDataPropertyNameChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : ColumnDataPropertyNameChanged Event

Occurs when the value of the DataGridViewColumn.DataPropertyName property for a column changes.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Property Changed")>
<SRDescriptionAttribute("Occurs when the value of the DataGridViewColumn.DataPropertyName property for a column changes.")>
Public Event ColumnDataPropertyNameChanged() As DataGridViewColumnEventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As DataGridViewColumnEventHandler

AddHandler instance.ColumnDataPropertyNameChanged, handler
C#
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when the value of the DataGridViewColumn.DataPropertyName property for a column changes.")]
public event DataGridViewColumnEventHandler ColumnDataPropertyNameChanged()
Managed Extensions for C++
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when the value of the DataGridViewColumn.DataPropertyName property for a column changes.")]
public: __event DataGridViewColumnEventHandler* ColumnDataPropertyNameChanged
C++/CLI
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when the value of the DataGridViewColumn.DataPropertyName property for a column changes.")]
public:
event DataGridViewColumnEventHandler^ ColumnDataPropertyNameChanged

Event Data

The event handler receives an argument of type DataGridViewColumnEventArgs containing data related to this event. The following DataGridViewColumnEventArgs properties provide information specific to this event.

Property | Description
Column | Gets the column that the event occurs for.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


ColumnDefaultCellStyleChanged Event

[image]
Gizmox.WebGUI.Forms
ColumnDefaultCellStyleChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : ColumnDefaultCellStyleChanged Event

Occurs when the value of the DataGridViewBand.DefaultCellStyle property for a column changes.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Property Changed")>
<SRDescriptionAttribute("Occurs when the value of the DataGridViewBand.DefaultCellStyle property for a column changes.")>
Public Event ColumnDefaultCellStyleChanged() As DataGridViewColumnEventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As DataGridViewColumnEventHandler

AddHandler instance.ColumnDefaultCellStyleChanged, handler
C#
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when the value of the DataGridViewBand.DefaultCellStyle property for a column changes.")]
public event DataGridViewColumnEventHandler ColumnDefaultCellStyleChanged()
Managed Extensions for C++
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when the value of the DataGridViewBand.DefaultCellStyle property for a column changes.")]
public: __event DataGridViewColumnEventHandler* ColumnDefaultCellStyleChanged
C++/CLI
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when the value of the DataGridViewBand.DefaultCellStyle property for a column changes.")]
public:
event DataGridViewColumnEventHandler^ ColumnDefaultCellStyleChanged

Event Data

The event handler receives an argument of type DataGridViewColumnEventArgs containing data related to this event. The following DataGridViewColumnEventArgs properties provide information specific to this event.

Property | Description
Column | Gets the column that the event occurs for.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


ColumnDisplayIndexChanged Event

[image]
Gizmox.WebGUI.Forms
ColumnDisplayIndexChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : ColumnDisplayIndexChanged Event

Occurs when the value the DataGridViewColumn.DisplayIndex property for a column changes.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the value the DataGridViewColumn.DisplayIndex property for a column changes.")>
<SRCategoryAttribute("Property Changed")>
Public Event ColumnDisplayIndexChanged() As DataGridViewColumnEventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As DataGridViewColumnEventHandler

AddHandler instance.ColumnDisplayIndexChanged, handler
C#
[SRDescriptionAttribute("Occurs when the value the DataGridViewColumn.DisplayIndex property for a column changes.")]
[SRCategoryAttribute("Property Changed")]
public event DataGridViewColumnEventHandler ColumnDisplayIndexChanged()
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the value the DataGridViewColumn.DisplayIndex property for a column changes.")]
[SRCategoryAttribute("Property Changed")]
public: __event DataGridViewColumnEventHandler* ColumnDisplayIndexChanged
C++/CLI
[SRDescriptionAttribute("Occurs when the value the DataGridViewColumn.DisplayIndex property for a column changes.")]
[SRCategoryAttribute("Property Changed")]
public:
event DataGridViewColumnEventHandler^ ColumnDisplayIndexChanged

Event Data

The event handler receives an argument of type DataGridViewColumnEventArgs containing data related to this event. The following DataGridViewColumnEventArgs properties provide information specific to this event.

Property | Description
Column | Gets the column that the event occurs for.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


ColumnDividerDoubleClick Event

[image]
Gizmox.WebGUI.Forms
ColumnDividerDoubleClick Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : ColumnDividerDoubleClick Event

Occurs when the user double-clicks a divider between two columns.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Mouse")>
<SRDescriptionAttribute("Occurs when the user double-clicks a divider between two columns.")>
Public Event ColumnDividerDoubleClick() As DataGridViewColumnDividerDoubleClickEventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As DataGridViewColumnDividerDoubleClickEventHandler

AddHandler instance.ColumnDividerDoubleClick, handler
C#
[SRCategoryAttribute("Mouse")]
[SRDescriptionAttribute("Occurs when the user double-clicks a divider between two columns.")]
public event DataGridViewColumnDividerDoubleClickEventHandler ColumnDividerDoubleClick()
Managed Extensions for C++
[SRCategoryAttribute("Mouse")]
[SRDescriptionAttribute("Occurs when the user double-clicks a divider between two columns.")]
public: __event DataGridViewColumnDividerDoubleClickEventHandler* ColumnDividerDoubleClick
C++/CLI
[SRCategoryAttribute("Mouse")]
[SRDescriptionAttribute("Occurs when the user double-clicks a divider between two columns.")]
public:
event DataGridViewColumnDividerDoubleClickEventHandler^ ColumnDividerDoubleClick

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


ColumnDividerWidthChanged Event

[image]
Gizmox.WebGUI.Forms
ColumnDividerWidthChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : ColumnDividerWidthChanged Event

Occurs when the DataGridViewColumn.DividerWidth property changes.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Property Changed")>
<SRDescriptionAttribute("Occurs when DataGridViewColumn.DividerWidth changes.")>
Public Event ColumnDividerWidthChanged() As DataGridViewColumnEventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As DataGridViewColumnEventHandler

AddHandler instance.ColumnDividerWidthChanged, handler
C#
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when DataGridViewColumn.DividerWidth changes.")]
public event DataGridViewColumnEventHandler ColumnDividerWidthChanged()
Managed Extensions for C++
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when DataGridViewColumn.DividerWidth changes.")]
public: __event DataGridViewColumnEventHandler* ColumnDividerWidthChanged
C++/CLI
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when DataGridViewColumn.DividerWidth changes.")]
public:
event DataGridViewColumnEventHandler^ ColumnDividerWidthChanged

Event Data

The event handler receives an argument of type DataGridViewColumnEventArgs containing data related to this event. The following DataGridViewColumnEventArgs properties provide information specific to this event.

Property | Description
Column | Gets the column that the event occurs for.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


ColumnHeaderCellChanged Event

[image]
Gizmox.WebGUI.Forms
ColumnHeaderCellChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : ColumnHeaderCellChanged Event

Occurs when the contents of a column header cell change.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the contents of a column header cell change.")>
<SRCategoryAttribute("Property Changed")>
Public Event ColumnHeaderCellChanged() As DataGridViewColumnEventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As DataGridViewColumnEventHandler

AddHandler instance.ColumnHeaderCellChanged, handler
C#
[SRDescriptionAttribute("Occurs when the contents of a column header cell change.")]
[SRCategoryAttribute("Property Changed")]
public event DataGridViewColumnEventHandler ColumnHeaderCellChanged()
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the contents of a column header cell change.")]
[SRCategoryAttribute("Property Changed")]
public: __event DataGridViewColumnEventHandler* ColumnHeaderCellChanged
C++/CLI
[SRDescriptionAttribute("Occurs when the contents of a column header cell change.")]
[SRCategoryAttribute("Property Changed")]
public:
event DataGridViewColumnEventHandler^ ColumnHeaderCellChanged

Event Data

The event handler receives an argument of type DataGridViewColumnEventArgs containing data related to this event. The following DataGridViewColumnEventArgs properties provide information specific to this event.

Property | Description
Column | Gets the column that the event occurs for.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


ColumnHeaderMouseClick Event

[image]
Gizmox.WebGUI.Forms
ColumnHeaderMouseClick Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : ColumnHeaderMouseClick Event

Occurs when the user clicks a column header.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the user clicks a column header.")>
<SRCategoryAttribute("Mouse")>
Public Event ColumnHeaderMouseClick() As DataGridViewCellMouseEventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As DataGridViewCellMouseEventHandler

AddHandler instance.ColumnHeaderMouseClick, handler
C#
[SRDescriptionAttribute("Occurs when the user clicks a column header.")]
[SRCategoryAttribute("Mouse")]
public event DataGridViewCellMouseEventHandler ColumnHeaderMouseClick()
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the user clicks a column header.")]
[SRCategoryAttribute("Mouse")]
public: __event DataGridViewCellMouseEventHandler* ColumnHeaderMouseClick
C++/CLI
[SRDescriptionAttribute("Occurs when the user clicks a column header.")]
[SRCategoryAttribute("Mouse")]
public:
event DataGridViewCellMouseEventHandler^ ColumnHeaderMouseClick

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


ColumnHeaderMouseDoubleClick Event

[image]
Gizmox.WebGUI.Forms
ColumnHeaderMouseDoubleClick Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : ColumnHeaderMouseDoubleClick Event

Occurs when a column header is double-clicked.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when a column header is double-clicked.")>
<SRCategoryAttribute("Mouse")>
Public Event ColumnHeaderMouseDoubleClick() As DataGridViewCellMouseEventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As DataGridViewCellMouseEventHandler

AddHandler instance.ColumnHeaderMouseDoubleClick, handler
C#
[SRDescriptionAttribute("Occurs when a column header is double-clicked.")]
[SRCategoryAttribute("Mouse")]
public event DataGridViewCellMouseEventHandler ColumnHeaderMouseDoubleClick()
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when a column header is double-clicked.")]
[SRCategoryAttribute("Mouse")]
public: __event DataGridViewCellMouseEventHandler* ColumnHeaderMouseDoubleClick
C++/CLI
[SRDescriptionAttribute("Occurs when a column header is double-clicked.")]
[SRCategoryAttribute("Mouse")]
public:
event DataGridViewCellMouseEventHandler^ ColumnHeaderMouseDoubleClick

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


ColumnHeadersBorderStyleChanged Event

[image]
Gizmox.WebGUI.Forms
ColumnHeadersBorderStyleChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : ColumnHeadersBorderStyleChanged Event

Occurs when the DataGridView.ColumnHeadersBorderStyle property changes.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Property Changed")>
<SRDescriptionAttribute("Occurs when the DataGridView.ColumnHeadersBorderStyle property changes.")>
Public Event ColumnHeadersBorderStyleChanged() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As EventHandler

AddHandler instance.ColumnHeadersBorderStyleChanged, handler
C#
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when the DataGridView.ColumnHeadersBorderStyle property changes.")]
public event EventHandler ColumnHeadersBorderStyleChanged()
Managed Extensions for C++
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when the DataGridView.ColumnHeadersBorderStyle property changes.")]
public: __event EventHandler* ColumnHeadersBorderStyleChanged
C++/CLI
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when the DataGridView.ColumnHeadersBorderStyle property changes.")]
public:
event EventHandler^ ColumnHeadersBorderStyleChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


ColumnHeadersDefaultCellStyleChanged Event

[image]
Gizmox.WebGUI.Forms
ColumnHeadersDefaultCellStyleChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : ColumnHeadersDefaultCellStyleChanged Event

Occurs when the value of the DataGridView.ColumnHeadersDefaultCellStyle property changes.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the value of the ColumnHeadersDefaultCellStyle property changes.")>
<SRCategoryAttribute("Property Changed")>
Public Event ColumnHeadersDefaultCellStyleChanged() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As EventHandler

AddHandler instance.ColumnHeadersDefaultCellStyleChanged, handler
C#
[SRDescriptionAttribute("Occurs when the value of the ColumnHeadersDefaultCellStyle property changes.")]
[SRCategoryAttribute("Property Changed")]
public event EventHandler ColumnHeadersDefaultCellStyleChanged()
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the value of the ColumnHeadersDefaultCellStyle property changes.")]
[SRCategoryAttribute("Property Changed")]
public: __event EventHandler* ColumnHeadersDefaultCellStyleChanged
C++/CLI
[SRDescriptionAttribute("Occurs when the value of the ColumnHeadersDefaultCellStyle property changes.")]
[SRCategoryAttribute("Property Changed")]
public:
event EventHandler^ ColumnHeadersDefaultCellStyleChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


ColumnHeadersHeightChanged Event

[image]
Gizmox.WebGUI.Forms
ColumnHeadersHeightChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : ColumnHeadersHeightChanged Event

Occurs when the value of the ColumnHeadersHeight property changes.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Property Changed")>
<SRDescriptionAttribute("Occurs when the value of the ColumnHeadersHeight property changes.")>
Public Event ColumnHeadersHeightChanged() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As EventHandler

AddHandler instance.ColumnHeadersHeightChanged, handler
C#
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when the value of the ColumnHeadersHeight property changes.")]
public event EventHandler ColumnHeadersHeightChanged()
Managed Extensions for C++
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when the value of the ColumnHeadersHeight property changes.")]
public: __event EventHandler* ColumnHeadersHeightChanged
C++/CLI
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when the value of the ColumnHeadersHeight property changes.")]
public:
event EventHandler^ ColumnHeadersHeightChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


ColumnHeadersHeightSizeModeChanged Event

[image]
Gizmox.WebGUI.Forms
ColumnHeadersHeightSizeModeChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : ColumnHeadersHeightSizeModeChanged Event

Occurs when the value of the ColumnHeadersHeightSizeMode property changes.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the value of the ColumnHeadersHeightSizeMode property changes.")>
<SRCategoryAttribute("Property Changed")>
Public Event ColumnHeadersHeightSizeModeChanged() As DataGridViewAutoSizeModeEventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As DataGridViewAutoSizeModeEventHandler

AddHandler instance.ColumnHeadersHeightSizeModeChanged, handler
C#
[SRDescriptionAttribute("Occurs when the value of the ColumnHeadersHeightSizeMode property changes.")]
[SRCategoryAttribute("Property Changed")]
public event DataGridViewAutoSizeModeEventHandler ColumnHeadersHeightSizeModeChanged()
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the value of the ColumnHeadersHeightSizeMode property changes.")]
[SRCategoryAttribute("Property Changed")]
public: __event DataGridViewAutoSizeModeEventHandler* ColumnHeadersHeightSizeModeChanged
C++/CLI
[SRDescriptionAttribute("Occurs when the value of the ColumnHeadersHeightSizeMode property changes.")]
[SRCategoryAttribute("Property Changed")]
public:
event DataGridViewAutoSizeModeEventHandler^ ColumnHeadersHeightSizeModeChanged

Event Data

The event handler receives an argument of type DataGridViewAutoSizeModeEventArgs containing data related to this event. The following DataGridViewAutoSizeModeEventArgs properties provide information specific to this event.

Property | Description
PreviousModeAutoSized | Gets a value specifying whether the DataGridView was previously set to automatically resize.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


ColumnMinimumWidthChanged Event

[image]
Gizmox.WebGUI.Forms
ColumnMinimumWidthChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : ColumnMinimumWidthChanged Event

Occurs when the value of the DataGridViewColumn.MinimumWidth property for a column changes.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the value of the DataGridViewColumn.MinimumWidth property for a column changes.")>
<SRCategoryAttribute("Property Changed")>
Public Event ColumnMinimumWidthChanged() As DataGridViewColumnEventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As DataGridViewColumnEventHandler

AddHandler instance.ColumnMinimumWidthChanged, handler
C#
[SRDescriptionAttribute("Occurs when the value of the DataGridViewColumn.MinimumWidth property for a column changes.")]
[SRCategoryAttribute("Property Changed")]
public event DataGridViewColumnEventHandler ColumnMinimumWidthChanged()
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the value of the DataGridViewColumn.MinimumWidth property for a column changes.")]
[SRCategoryAttribute("Property Changed")]
public: __event DataGridViewColumnEventHandler* ColumnMinimumWidthChanged
C++/CLI
[SRDescriptionAttribute("Occurs when the value of the DataGridViewColumn.MinimumWidth property for a column changes.")]
[SRCategoryAttribute("Property Changed")]
public:
event DataGridViewColumnEventHandler^ ColumnMinimumWidthChanged

Event Data

The event handler receives an argument of type DataGridViewColumnEventArgs containing data related to this event. The following DataGridViewColumnEventArgs properties provide information specific to this event.

Property | Description
Column | Gets the column that the event occurs for.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


ColumnNameChanged Event

[image]
Gizmox.WebGUI.Forms
ColumnNameChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : ColumnNameChanged Event

Occurs when the value of the DataGridViewColumn.Name property for a column changes.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the value of the DataGridViewColumn.Name property for a column changes.")>
<SRCategoryAttribute("Property Changed")>
Public Event ColumnNameChanged() As DataGridViewColumnEventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As DataGridViewColumnEventHandler

AddHandler instance.ColumnNameChanged, handler
C#
[SRDescriptionAttribute("Occurs when the value of the DataGridViewColumn.Name property for a column changes.")]
[SRCategoryAttribute("Property Changed")]
public event DataGridViewColumnEventHandler ColumnNameChanged()
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the value of the DataGridViewColumn.Name property for a column changes.")]
[SRCategoryAttribute("Property Changed")]
public: __event DataGridViewColumnEventHandler* ColumnNameChanged
C++/CLI
[SRDescriptionAttribute("Occurs when the value of the DataGridViewColumn.Name property for a column changes.")]
[SRCategoryAttribute("Property Changed")]
public:
event DataGridViewColumnEventHandler^ ColumnNameChanged

Event Data

The event handler receives an argument of type DataGridViewColumnEventArgs containing data related to this event. The following DataGridViewColumnEventArgs properties provide information specific to this event.

Property | Description
Column | Gets the column that the event occurs for.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


ColumnRemoved Event

[image]
Gizmox.WebGUI.Forms
ColumnRemoved Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : ColumnRemoved Event

Occurs when a column is removed from the control.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Action")>
<SRDescriptionAttribute("Occurs when a column is removed from the control.")>
Public Event ColumnRemoved() As DataGridViewColumnEventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As DataGridViewColumnEventHandler

AddHandler instance.ColumnRemoved, handler
C#
[SRCategoryAttribute("Action")]
[SRDescriptionAttribute("Occurs when a column is removed from the control.")]
public event DataGridViewColumnEventHandler ColumnRemoved()
Managed Extensions for C++
[SRCategoryAttribute("Action")]
[SRDescriptionAttribute("Occurs when a column is removed from the control.")]
public: __event DataGridViewColumnEventHandler* ColumnRemoved
C++/CLI
[SRCategoryAttribute("Action")]
[SRDescriptionAttribute("Occurs when a column is removed from the control.")]
public:
event DataGridViewColumnEventHandler^ ColumnRemoved

Event Data

The event handler receives an argument of type DataGridViewColumnEventArgs containing data related to this event. The following DataGridViewColumnEventArgs properties provide information specific to this event.

Property | Description
Column | Gets the column that the event occurs for.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


ColumnSortModeChanged Event

[image]
Gizmox.WebGUI.Forms
ColumnSortModeChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : ColumnSortModeChanged Event

Occurs when the value of the DataGridViewColumn.SortMode property for a column changes.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Behavior")>
<SRDescriptionAttribute("Occurs when the value of the SortMode property for a column changes.")>
Public Event ColumnSortModeChanged() As DataGridViewColumnEventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As DataGridViewColumnEventHandler

AddHandler instance.ColumnSortModeChanged, handler
C#
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when the value of the SortMode property for a column changes.")]
public event DataGridViewColumnEventHandler ColumnSortModeChanged()
Managed Extensions for C++
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when the value of the SortMode property for a column changes.")]
public: __event DataGridViewColumnEventHandler* ColumnSortModeChanged
C++/CLI
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when the value of the SortMode property for a column changes.")]
public:
event DataGridViewColumnEventHandler^ ColumnSortModeChanged

Event Data

The event handler receives an argument of type DataGridViewColumnEventArgs containing data related to this event. The following DataGridViewColumnEventArgs properties provide information specific to this event.

Property | Description
Column | Gets the column that the event occurs for.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


ColumnStateChanged Event

[image]
Gizmox.WebGUI.Forms
ColumnStateChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : ColumnStateChanged Event

Occurs when a column changes state, such as gaining or losing focus.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when a column changes state, such as gaining or losing focus.")>
<SRCategoryAttribute("Behavior")>
Public Event ColumnStateChanged() As DataGridViewColumnStateChangedEventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As DataGridViewColumnStateChangedEventHandler

AddHandler instance.ColumnStateChanged, handler
C#
[SRDescriptionAttribute("Occurs when a column changes state, such as gaining or losing focus.")]
[SRCategoryAttribute("Behavior")]
public event DataGridViewColumnStateChangedEventHandler ColumnStateChanged()
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when a column changes state, such as gaining or losing focus.")]
[SRCategoryAttribute("Behavior")]
public: __event DataGridViewColumnStateChangedEventHandler* ColumnStateChanged
C++/CLI
[SRDescriptionAttribute("Occurs when a column changes state, such as gaining or losing focus.")]
[SRCategoryAttribute("Behavior")]
public:
event DataGridViewColumnStateChangedEventHandler^ ColumnStateChanged

Event Data

The event handler receives an argument of type DataGridViewColumnStateChangedEventArgs containing data related to this event. The following DataGridViewColumnStateChangedEventArgs properties provide information specific to this event.

Property | Description
Column | Gets the column whose state changed.
StateChanged | Gets the new column state.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


ColumnToolTipTextChanged Event

[image]
Gizmox.WebGUI.Forms
ColumnToolTipTextChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : ColumnToolTipTextChanged Event

Occurs when the DataGridViewColumn.ToolTipText property value changes for a column in the DataGridView.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Property Changed")>
<SRDescriptionAttribute("Occurs when the DataGridViewColumn.ToolTipText property value changes for a column in the DataGridView.")>
Public Event ColumnToolTipTextChanged() As DataGridViewColumnEventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As DataGridViewColumnEventHandler

AddHandler instance.ColumnToolTipTextChanged, handler
C#
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when the DataGridViewColumn.ToolTipText property value changes for a column in the DataGridView.")]
public event DataGridViewColumnEventHandler ColumnToolTipTextChanged()
Managed Extensions for C++
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when the DataGridViewColumn.ToolTipText property value changes for a column in the DataGridView.")]
public: __event DataGridViewColumnEventHandler* ColumnToolTipTextChanged
C++/CLI
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when the DataGridViewColumn.ToolTipText property value changes for a column in the DataGridView.")]
public:
event DataGridViewColumnEventHandler^ ColumnToolTipTextChanged

Event Data

The event handler receives an argument of type DataGridViewColumnEventArgs containing data related to this event. The following DataGridViewColumnEventArgs properties provide information specific to this event.

Property | Description
Column | Gets the column that the event occurs for.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


ColumnWidthChanged Event

[image]
Gizmox.WebGUI.Forms
ColumnWidthChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : ColumnWidthChanged Event

Occurs when the value of the DataGridViewColumn.Width property for a column changes.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the value of the DataGridViewColumn.Width property for a column changes.")>
<SRCategoryAttribute("Action")>
Public Event ColumnWidthChanged() As DataGridViewColumnEventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As DataGridViewColumnEventHandler

AddHandler instance.ColumnWidthChanged, handler
C#
[SRDescriptionAttribute("Occurs when the value of the DataGridViewColumn.Width property for a column changes.")]
[SRCategoryAttribute("Action")]
public event DataGridViewColumnEventHandler ColumnWidthChanged()
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the value of the DataGridViewColumn.Width property for a column changes.")]
[SRCategoryAttribute("Action")]
public: __event DataGridViewColumnEventHandler* ColumnWidthChanged
C++/CLI
[SRDescriptionAttribute("Occurs when the value of the DataGridViewColumn.Width property for a column changes.")]
[SRCategoryAttribute("Action")]
public:
event DataGridViewColumnEventHandler^ ColumnWidthChanged

Event Data

The event handler receives an argument of type DataGridViewColumnEventArgs containing data related to this event. The following DataGridViewColumnEventArgs properties provide information specific to this event.

Property | Description
Column | Gets the column that the event occurs for.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


CurrentCellChanged Event

[image]
Gizmox.WebGUI.Forms
CurrentCellChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : CurrentCellChanged Event

Occurs when the CurrentCell property changes.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Action")>
<SRDescriptionAttribute("Occurs when DataGridView.CurrentCell changes.")>
Public Event CurrentCellChanged() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As EventHandler

AddHandler instance.CurrentCellChanged, handler
C#
[SRCategoryAttribute("Action")]
[SRDescriptionAttribute("Occurs when DataGridView.CurrentCell changes.")]
public event EventHandler CurrentCellChanged()
Managed Extensions for C++
[SRCategoryAttribute("Action")]
[SRDescriptionAttribute("Occurs when DataGridView.CurrentCell changes.")]
public: __event EventHandler* CurrentCellChanged
C++/CLI
[SRCategoryAttribute("Action")]
[SRDescriptionAttribute("Occurs when DataGridView.CurrentCell changes.")]
public:
event EventHandler^ CurrentCellChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


CurrentCellDirtyStateChanged Event

[image]
Gizmox.WebGUI.Forms
CurrentCellDirtyStateChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : CurrentCellDirtyStateChanged Event

Occurs when the state of a cell changes in relation to a change in its contents.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the state of a cell changes in relation to a change in its contents.")>
<SRCategoryAttribute("Behavior")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Event CurrentCellDirtyStateChanged() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As EventHandler

AddHandler instance.CurrentCellDirtyStateChanged, handler
C#
[SRDescriptionAttribute("Occurs when the state of a cell changes in relation to a change in its contents.")]
[SRCategoryAttribute("Behavior")]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public event EventHandler CurrentCellDirtyStateChanged()
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the state of a cell changes in relation to a change in its contents.")]
[SRCategoryAttribute("Behavior")]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: __event EventHandler* CurrentCellDirtyStateChanged
C++/CLI
[SRDescriptionAttribute("Occurs when the state of a cell changes in relation to a change in its contents.")]
[SRCategoryAttribute("Behavior")]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
event EventHandler^ CurrentCellDirtyStateChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


DataBindingComplete Event

[image]
Gizmox.WebGUI.Forms
DataBindingComplete Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : DataBindingComplete Event

Occurs after a data-binding operation has finished.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Data")>
<SRDescriptionAttribute("Event raised whenever the data source list changes.")>
Public Event DataBindingComplete() As DataGridViewBindingCompleteEventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As DataGridViewBindingCompleteEventHandler

AddHandler instance.DataBindingComplete, handler
C#
[SRCategoryAttribute("Data")]
[SRDescriptionAttribute("Event raised whenever the data source list changes.")]
public event DataGridViewBindingCompleteEventHandler DataBindingComplete()
Managed Extensions for C++
[SRCategoryAttribute("Data")]
[SRDescriptionAttribute("Event raised whenever the data source list changes.")]
public: __event DataGridViewBindingCompleteEventHandler* DataBindingComplete
C++/CLI
[SRCategoryAttribute("Data")]
[SRDescriptionAttribute("Event raised whenever the data source list changes.")]
public:
event DataGridViewBindingCompleteEventHandler^ DataBindingComplete

Event Data

The event handler receives an argument of type DataGridViewBindingCompleteEventArgs containing data related to this event. The following DataGridViewBindingCompleteEventArgs properties provide information specific to this event.

Property | Description
ListChangedType | Gets a value specifying how the list changed.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


DataError Event

[image]
Gizmox.WebGUI.Forms
DataError Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : DataError Event

Occurs when an external data-parsing or validation operation throws an exception, or when an attempt to commit data to a data source fails.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when an external data-parsing or validation operation throws an exception, or when an attempt to commit data to a data source does not succeed.")>
<SRCategoryAttribute("Behavior")>
Public Event DataError() As DataGridViewDataErrorEventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As DataGridViewDataErrorEventHandler

AddHandler instance.DataError, handler
C#
[SRDescriptionAttribute("Occurs when an external data-parsing or validation operation throws an exception, or when an attempt to commit data to a data source does not succeed.")]
[SRCategoryAttribute("Behavior")]
public event DataGridViewDataErrorEventHandler DataError()
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when an external data-parsing or validation operation throws an exception, or when an attempt to commit data to a data source does not succeed.")]
[SRCategoryAttribute("Behavior")]
public: __event DataGridViewDataErrorEventHandler* DataError
C++/CLI
[SRDescriptionAttribute("Occurs when an external data-parsing or validation operation throws an exception, or when an attempt to commit data to a data source does not succeed.")]
[SRCategoryAttribute("Behavior")]
public:
event DataGridViewDataErrorEventHandler^ DataError

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


DataMemberChanged Event

[image]
Gizmox.WebGUI.Forms
DataMemberChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : DataMemberChanged Event

Occurs when value of the DataMember property changes.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Property Changed")>
<SRDescriptionAttribute("Occurs when the value of the DataMember property changes.")>
Public Event DataMemberChanged() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As EventHandler

AddHandler instance.DataMemberChanged, handler
C#
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when the value of the DataMember property changes.")]
public event EventHandler DataMemberChanged()
Managed Extensions for C++
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when the value of the DataMember property changes.")]
public: __event EventHandler* DataMemberChanged
C++/CLI
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when the value of the DataMember property changes.")]
public:
event EventHandler^ DataMemberChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


DataSourceChanged Event

[image]
Gizmox.WebGUI.Forms
DataSourceChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : DataSourceChanged Event

Occurs when the value of the DataSource property changes.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the value of the DataSource property changes.")>
<SRCategoryAttribute("Property Changed")>
Public Event DataSourceChanged() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As EventHandler

AddHandler instance.DataSourceChanged, handler
C#
[SRDescriptionAttribute("Occurs when the value of the DataSource property changes.")]
[SRCategoryAttribute("Property Changed")]
public event EventHandler DataSourceChanged()
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the value of the DataSource property changes.")]
[SRCategoryAttribute("Property Changed")]
public: __event EventHandler* DataSourceChanged
C++/CLI
[SRDescriptionAttribute("Occurs when the value of the DataSource property changes.")]
[SRCategoryAttribute("Property Changed")]
public:
event EventHandler^ DataSourceChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


DefaultCellStyleChanged Event

[image]
Gizmox.WebGUI.Forms
DefaultCellStyleChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : DefaultCellStyleChanged Event

Occurs when the value of the DataGridView.DefaultCellStyle property changes.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Property Changed")>
<SRDescriptionAttribute("Occurs when the value of the DefaultCellStyle property changes.")>
Public Event DefaultCellStyleChanged() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As EventHandler

AddHandler instance.DefaultCellStyleChanged, handler
C#
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when the value of the DefaultCellStyle property changes.")]
public event EventHandler DefaultCellStyleChanged()
Managed Extensions for C++
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when the value of the DefaultCellStyle property changes.")]
public: __event EventHandler* DefaultCellStyleChanged
C++/CLI
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when the value of the DefaultCellStyle property changes.")]
public:
event EventHandler^ DefaultCellStyleChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


DefaultValuesNeeded Event

[image]
Gizmox.WebGUI.Forms
DefaultValuesNeeded Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : DefaultValuesNeeded Event

Occurs when the user enters the row for new records so that it can be populated with default values.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Data")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<SRDescriptionAttribute("Occurs when the user enters the row for new records so that it can be populated with default values.")>
Public Event DefaultValuesNeeded() As DataGridViewRowEventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As DataGridViewRowEventHandler

AddHandler instance.DefaultValuesNeeded, handler
C#
[SRCategoryAttribute("Data")]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRDescriptionAttribute("Occurs when the user enters the row for new records so that it can be populated with default values.")]
public event DataGridViewRowEventHandler DefaultValuesNeeded()
Managed Extensions for C++
[SRCategoryAttribute("Data")]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRDescriptionAttribute("Occurs when the user enters the row for new records so that it can be populated with default values.")]
public: __event DataGridViewRowEventHandler* DefaultValuesNeeded
C++/CLI
[SRCategoryAttribute("Data")]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRDescriptionAttribute("Occurs when the user enters the row for new records so that it can be populated with default values.")]
public:
event DataGridViewRowEventHandler^ DefaultValuesNeeded

Event Data

The event handler receives an argument of type DataGridViewRowEventArgs containing data related to this event. The following DataGridViewRowEventArgs properties provide information specific to this event.

Property | Description
Row | Gets the DataGridViewRow associated with the event.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


EditingControlShowing Event

[image]
Gizmox.WebGUI.Forms
EditingControlShowing Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : EditingControlShowing Event

Occurs when a control for editing a cell is showing.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Action")>
<SRDescriptionAttribute("Occurs when a control for editing a cell is showing.")>
Public Event EditingControlShowing() As DataGridViewEditingControlShowingEventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As DataGridViewEditingControlShowingEventHandler

AddHandler instance.EditingControlShowing, handler
C#
[SRCategoryAttribute("Action")]
[SRDescriptionAttribute("Occurs when a control for editing a cell is showing.")]
public event DataGridViewEditingControlShowingEventHandler EditingControlShowing()
Managed Extensions for C++
[SRCategoryAttribute("Action")]
[SRDescriptionAttribute("Occurs when a control for editing a cell is showing.")]
public: __event DataGridViewEditingControlShowingEventHandler* EditingControlShowing
C++/CLI
[SRCategoryAttribute("Action")]
[SRDescriptionAttribute("Occurs when a control for editing a cell is showing.")]
public:
event DataGridViewEditingControlShowingEventHandler^ EditingControlShowing

Event Data

The event handler receives an argument of type DataGridViewEditingControlShowingEventArgs containing data related to this event. The following DataGridViewEditingControlShowingEventArgs properties provide information specific to this event.

Property | Description
CellStyle | Gets or sets the cell style of the edited cell.
Control | The control shown to the user for editing the selected cell's value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


EditModeChanged Event

[image]
Gizmox.WebGUI.Forms
EditModeChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : EditModeChanged Event

Occurs when the value of the EditMode property changes.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the value of the DataGridView.EditMode property changes.")>
<SRCategoryAttribute("Property Changed")>
Public Event EditModeChanged() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As EventHandler

AddHandler instance.EditModeChanged, handler
C#
[SRDescriptionAttribute("Occurs when the value of the DataGridView.EditMode property changes.")]
[SRCategoryAttribute("Property Changed")]
public event EventHandler EditModeChanged()
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the value of the DataGridView.EditMode property changes.")]
[SRCategoryAttribute("Property Changed")]
public: __event EventHandler* EditModeChanged
C++/CLI
[SRDescriptionAttribute("Occurs when the value of the DataGridView.EditMode property changes.")]
[SRCategoryAttribute("Property Changed")]
public:
event EventHandler^ EditModeChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


FontChanged Event

[image]
Gizmox.WebGUI.Forms
FontChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : FontChanged Event

Occurs when the Font property value changes.

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<BrowsableAttribute(False)>
Public Event FontChanged() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As EventHandler

AddHandler instance.FontChanged, handler
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[BrowsableAttribute(false)]
public event EventHandler FontChanged()
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[BrowsableAttribute(false)]
public: __event EventHandler* FontChanged
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[BrowsableAttribute(false)]
public:
event EventHandler^ FontChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


GridColorChanged Event

[image]
Gizmox.WebGUI.Forms
GridColorChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : GridColorChanged Event

Occurs when the value of the GridColor property changes.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Property Changed")>
<SRDescriptionAttribute("Occurs when the value of the GridColor property changes.")>
Public Event GridColorChanged() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As EventHandler

AddHandler instance.GridColorChanged, handler
C#
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when the value of the GridColor property changes.")]
public event EventHandler GridColorChanged()
Managed Extensions for C++
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when the value of the GridColor property changes.")]
public: __event EventHandler* GridColorChanged
C++/CLI
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when the value of the GridColor property changes.")]
public:
event EventHandler^ GridColorChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


MultiSelectChanged Event

[image]
Gizmox.WebGUI.Forms
MultiSelectChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : MultiSelectChanged Event

Occurs when the value of the MultiSelect property changes.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Property Changed")>
<SRDescriptionAttribute("Occurs when the value of the MultiSelect property changes.")>
Public Event MultiSelectChanged() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As EventHandler

AddHandler instance.MultiSelectChanged, handler
C#
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when the value of the MultiSelect property changes.")]
public event EventHandler MultiSelectChanged()
Managed Extensions for C++
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when the value of the MultiSelect property changes.")]
public: __event EventHandler* MultiSelectChanged
C++/CLI
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when the value of the MultiSelect property changes.")]
public:
event EventHandler^ MultiSelectChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


NewRowNeeded Event

[image]
Gizmox.WebGUI.Forms
NewRowNeeded Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : NewRowNeeded Event

Occurs when the VirtualMode property of the DataGridView is true and the user navigates to the new row at the bottom of the DataGridView.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Data")>
<SRDescriptionAttribute("Occurs when the DataGridView.VirtualMode property of the DataGridView is true and the user navigates to the new row at the bottom of the DataGridView.")>
Public Event NewRowNeeded() As DataGridViewRowEventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As DataGridViewRowEventHandler

AddHandler instance.NewRowNeeded, handler
C#
[SRCategoryAttribute("Data")]
[SRDescriptionAttribute("Occurs when the DataGridView.VirtualMode property of the DataGridView is true and the user navigates to the new row at the bottom of the DataGridView.")]
public event DataGridViewRowEventHandler NewRowNeeded()
Managed Extensions for C++
[SRCategoryAttribute("Data")]
[SRDescriptionAttribute("Occurs when the DataGridView.VirtualMode property of the DataGridView is true and the user navigates to the new row at the bottom of the DataGridView.")]
public: __event DataGridViewRowEventHandler* NewRowNeeded
C++/CLI
[SRCategoryAttribute("Data")]
[SRDescriptionAttribute("Occurs when the DataGridView.VirtualMode property of the DataGridView is true and the user navigates to the new row at the bottom of the DataGridView.")]
public:
event DataGridViewRowEventHandler^ NewRowNeeded

Event Data

The event handler receives an argument of type DataGridViewRowEventArgs containing data related to this event. The following DataGridViewRowEventArgs properties provide information specific to this event.

Property | Description
Row | Gets the DataGridViewRow associated with the event.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


PagingChanged Event

[image]
Gizmox.WebGUI.Forms
PagingChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : PagingChanged Event

Occurs when the paging params have changed.

Syntax

Visual Basic (Declaration)
Public Event PagingChanged() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As EventHandler

AddHandler instance.PagingChanged, handler
C#
public event EventHandler PagingChanged()
Managed Extensions for C++
public: __event EventHandler* PagingChanged
C++/CLI
public:
event EventHandler^ PagingChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


ReadOnlyChanged Event

[image]
Gizmox.WebGUI.Forms
ReadOnlyChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : ReadOnlyChanged Event

Occurs when the ReadOnly property changes.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Property Changed")>
<SRDescriptionAttribute("Occurs when the value of the ReadOnly property changes.")>
Public Event ReadOnlyChanged() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As EventHandler

AddHandler instance.ReadOnlyChanged, handler
C#
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when the value of the ReadOnly property changes.")]
public event EventHandler ReadOnlyChanged()
Managed Extensions for C++
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when the value of the ReadOnly property changes.")]
public: __event EventHandler* ReadOnlyChanged
C++/CLI
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when the value of the ReadOnly property changes.")]
public:
event EventHandler^ ReadOnlyChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


RowContextMenuStripChanged Event

[image]
Gizmox.WebGUI.Forms
RowContextMenuStripChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : RowContextMenuStripChanged Event

Occurs when the ContextMenuStrip property changes.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Property Changed")>
<SRDescriptionAttribute("Occurs when DataGridViewRow.ContextMenuStrip changes.")>
Public Event RowContextMenuStripChanged() As DataGridViewRowEventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As DataGridViewRowEventHandler

AddHandler instance.RowContextMenuStripChanged, handler
C#
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when DataGridViewRow.ContextMenuStrip changes.")]
public event DataGridViewRowEventHandler RowContextMenuStripChanged()
Managed Extensions for C++
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when DataGridViewRow.ContextMenuStrip changes.")]
public: __event DataGridViewRowEventHandler* RowContextMenuStripChanged
C++/CLI
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when DataGridViewRow.ContextMenuStrip changes.")]
public:
event DataGridViewRowEventHandler^ RowContextMenuStripChanged

Event Data

The event handler receives an argument of type DataGridViewRowEventArgs containing data related to this event. The following DataGridViewRowEventArgs properties provide information specific to this event.

Property | Description
Row | Gets the DataGridViewRow associated with the event.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


RowContextMenuStripNeeded Event

[image]
Gizmox.WebGUI.Forms
RowContextMenuStripNeeded Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : RowContextMenuStripNeeded Event

Occurs when a row's shortcut menu is needed.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Data")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<SRDescriptionAttribute("Occurs when the context menu strip is needed.")>
Public Event RowContextMenuStripNeeded() As DataGridViewRowContextMenuStripNeededEventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As DataGridViewRowContextMenuStripNeededEventHandler

AddHandler instance.RowContextMenuStripNeeded, handler
C#
[SRCategoryAttribute("Data")]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRDescriptionAttribute("Occurs when the context menu strip is needed.")]
public event DataGridViewRowContextMenuStripNeededEventHandler RowContextMenuStripNeeded()
Managed Extensions for C++
[SRCategoryAttribute("Data")]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRDescriptionAttribute("Occurs when the context menu strip is needed.")]
public: __event DataGridViewRowContextMenuStripNeededEventHandler* RowContextMenuStripNeeded
C++/CLI
[SRCategoryAttribute("Data")]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRDescriptionAttribute("Occurs when the context menu strip is needed.")]
public:
event DataGridViewRowContextMenuStripNeededEventHandler^ RowContextMenuStripNeeded

Event Data

The event handler receives an argument of type DataGridViewRowContextMenuStripNeededEventArgs containing data related to this event. The following DataGridViewRowContextMenuStripNeededEventArgs properties provide information specific to this event.

Property | Description
RowIndex | Gets the index of the row that is requesting a shortcut menu.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


RowDefaultCellStyleChanged Event

[image]
Gizmox.WebGUI.Forms
RowDefaultCellStyleChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : RowDefaultCellStyleChanged Event

Occurs when the value of the DataGridViewBand.DefaultCellStyle property for a row changes.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Property Changed")>
<SRDescriptionAttribute("Occurs when the value of the DataGridViewBand.DefaultCellStyle property for a row changes.")>
Public Event RowDefaultCellStyleChanged() As DataGridViewRowEventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As DataGridViewRowEventHandler

AddHandler instance.RowDefaultCellStyleChanged, handler
C#
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when the value of the DataGridViewBand.DefaultCellStyle property for a row changes.")]
public event DataGridViewRowEventHandler RowDefaultCellStyleChanged()
Managed Extensions for C++
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when the value of the DataGridViewBand.DefaultCellStyle property for a row changes.")]
public: __event DataGridViewRowEventHandler* RowDefaultCellStyleChanged
C++/CLI
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when the value of the DataGridViewBand.DefaultCellStyle property for a row changes.")]
public:
event DataGridViewRowEventHandler^ RowDefaultCellStyleChanged

Event Data

The event handler receives an argument of type DataGridViewRowEventArgs containing data related to this event. The following DataGridViewRowEventArgs properties provide information specific to this event.

Property | Description
Row | Gets the DataGridViewRow associated with the event.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


RowDirtyStateNeeded Event

[image]
Gizmox.WebGUI.Forms
RowDirtyStateNeeded Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : RowDirtyStateNeeded Event

Occurs when the VirtualMode property of the DataGridView control is true and the DataGridView needs to determine whether the current row has uncommitted changes.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Data")>
<SRDescriptionAttribute("Occurs when the DataGridView.VirtualMode property of the DataGridView control is true and the DataGridView needs to determine whether the current row has uncommitted changes.")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Event RowDirtyStateNeeded() As QuestionEventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As QuestionEventHandler

AddHandler instance.RowDirtyStateNeeded, handler
C#
[SRCategoryAttribute("Data")]
[SRDescriptionAttribute("Occurs when the DataGridView.VirtualMode property of the DataGridView control is true and the DataGridView needs to determine whether the current row has uncommitted changes.")]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public event QuestionEventHandler RowDirtyStateNeeded()
Managed Extensions for C++
[SRCategoryAttribute("Data")]
[SRDescriptionAttribute("Occurs when the DataGridView.VirtualMode property of the DataGridView control is true and the DataGridView needs to determine whether the current row has uncommitted changes.")]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: __event QuestionEventHandler* RowDirtyStateNeeded
C++/CLI
[SRCategoryAttribute("Data")]
[SRDescriptionAttribute("Occurs when the DataGridView.VirtualMode property of the DataGridView control is true and the DataGridView needs to determine whether the current row has uncommitted changes.")]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
event QuestionEventHandler^ RowDirtyStateNeeded

Event Data

The event handler receives an argument of type QuestionEventArgs containing data related to this event. The following QuestionEventArgs properties provide information specific to this event.

Property | Description
Response | Gets or sets a value indicating the response to a question represented by the event.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


RowDividerDoubleClick Event

[image]
Gizmox.WebGUI.Forms
RowDividerDoubleClick Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : RowDividerDoubleClick Event

Occurs when the user double-clicks the divider between two rows.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the user double-clicks the divider between two rows.")>
<SRCategoryAttribute("Mouse")>
Public Event RowDividerDoubleClick() As DataGridViewRowDividerDoubleClickEventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As DataGridViewRowDividerDoubleClickEventHandler

AddHandler instance.RowDividerDoubleClick, handler
C#
[SRDescriptionAttribute("Occurs when the user double-clicks the divider between two rows.")]
[SRCategoryAttribute("Mouse")]
public event DataGridViewRowDividerDoubleClickEventHandler RowDividerDoubleClick()
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the user double-clicks the divider between two rows.")]
[SRCategoryAttribute("Mouse")]
public: __event DataGridViewRowDividerDoubleClickEventHandler* RowDividerDoubleClick
C++/CLI
[SRDescriptionAttribute("Occurs when the user double-clicks the divider between two rows.")]
[SRCategoryAttribute("Mouse")]
public:
event DataGridViewRowDividerDoubleClickEventHandler^ RowDividerDoubleClick

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


RowDividerHeightChanged Event

[image]
Gizmox.WebGUI.Forms
RowDividerHeightChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : RowDividerHeightChanged Event

Occurs when the DataGridViewRow.DividerHeight property changes.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Appearance")>
<SRDescriptionAttribute("Occurs when the DataGridViewRow.DividerHeight property changes. ")>
Public Event RowDividerHeightChanged() As DataGridViewRowEventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As DataGridViewRowEventHandler

AddHandler instance.RowDividerHeightChanged, handler
C#
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Occurs when the DataGridViewRow.DividerHeight property changes. ")]
public event DataGridViewRowEventHandler RowDividerHeightChanged()
Managed Extensions for C++
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Occurs when the DataGridViewRow.DividerHeight property changes. ")]
public: __event DataGridViewRowEventHandler* RowDividerHeightChanged
C++/CLI
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Occurs when the DataGridViewRow.DividerHeight property changes. ")]
public:
event DataGridViewRowEventHandler^ RowDividerHeightChanged

Event Data

The event handler receives an argument of type DataGridViewRowEventArgs containing data related to this event. The following DataGridViewRowEventArgs properties provide information specific to this event.

Property | Description
Row | Gets the DataGridViewRow associated with the event.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


RowEnter Event

[image]
Gizmox.WebGUI.Forms
RowEnter Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : RowEnter Event

Occurs when a row receives input focus and becomes the current row.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when a row receives input focus and becomes the current row.")>
<SRCategoryAttribute("Focus")>
Public Event RowEnter() As DataGridViewCellEventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As DataGridViewCellEventHandler

AddHandler instance.RowEnter, handler
C#
[SRDescriptionAttribute("Occurs when a row receives input focus and becomes the current row.")]
[SRCategoryAttribute("Focus")]
public event DataGridViewCellEventHandler RowEnter()
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when a row receives input focus and becomes the current row.")]
[SRCategoryAttribute("Focus")]
public: __event DataGridViewCellEventHandler* RowEnter
C++/CLI
[SRDescriptionAttribute("Occurs when a row receives input focus and becomes the current row.")]
[SRCategoryAttribute("Focus")]
public:
event DataGridViewCellEventHandler^ RowEnter

Event Data

The event handler receives an argument of type DataGridViewCellEventArgs containing data related to this event. The following DataGridViewCellEventArgs properties provide information specific to this event.

Property | Description
ColumnIndex | Gets a value indicating the column index of the cell that the event occurs for.
RowIndex | Gets a value indicating the row index of the cell that the event occurs for.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


RowErrorTextChanged Event

[image]
Gizmox.WebGUI.Forms
RowErrorTextChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : RowErrorTextChanged Event

Occurs when the DataGridViewRow.ErrorText property of a row changes.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Property Changed")>
<SRDescriptionAttribute("Occurs when the DataGridViewRow.ErrorText property of a row changes.")>
Public Event RowErrorTextChanged() As DataGridViewRowEventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As DataGridViewRowEventHandler

AddHandler instance.RowErrorTextChanged, handler
C#
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when the DataGridViewRow.ErrorText property of a row changes.")]
public event DataGridViewRowEventHandler RowErrorTextChanged()
Managed Extensions for C++
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when the DataGridViewRow.ErrorText property of a row changes.")]
public: __event DataGridViewRowEventHandler* RowErrorTextChanged
C++/CLI
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when the DataGridViewRow.ErrorText property of a row changes.")]
public:
event DataGridViewRowEventHandler^ RowErrorTextChanged

Event Data

The event handler receives an argument of type DataGridViewRowEventArgs containing data related to this event. The following DataGridViewRowEventArgs properties provide information specific to this event.

Property | Description
Row | Gets the DataGridViewRow associated with the event.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


RowErrorTextNeeded Event

[image]
Gizmox.WebGUI.Forms
RowErrorTextNeeded Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : RowErrorTextNeeded Event

Occurs when a row's error text is needed.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Data")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<SRDescriptionAttribute("Occurs when the DataGridView.VirtualMode property of the DataGridView control is true and the DataGridViewRow.ErrorText property for a row requires a value.")>
Public Event RowErrorTextNeeded() As DataGridViewRowErrorTextNeededEventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As DataGridViewRowErrorTextNeededEventHandler

AddHandler instance.RowErrorTextNeeded, handler
C#
[SRCategoryAttribute("Data")]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRDescriptionAttribute("Occurs when the DataGridView.VirtualMode property of the DataGridView control is true and the DataGridViewRow.ErrorText property for a row requires a value.")]
public event DataGridViewRowErrorTextNeededEventHandler RowErrorTextNeeded()
Managed Extensions for C++
[SRCategoryAttribute("Data")]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRDescriptionAttribute("Occurs when the DataGridView.VirtualMode property of the DataGridView control is true and the DataGridViewRow.ErrorText property for a row requires a value.")]
public: __event DataGridViewRowErrorTextNeededEventHandler* RowErrorTextNeeded
C++/CLI
[SRCategoryAttribute("Data")]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRDescriptionAttribute("Occurs when the DataGridView.VirtualMode property of the DataGridView control is true and the DataGridViewRow.ErrorText property for a row requires a value.")]
public:
event DataGridViewRowErrorTextNeededEventHandler^ RowErrorTextNeeded

Event Data

The event handler receives an argument of type DataGridViewRowErrorTextNeededEventArgs containing data related to this event. The following DataGridViewRowErrorTextNeededEventArgs properties provide information specific to this event.

Property | Description
ErrorText | Gets or sets the error text for the row.
RowIndex | Gets the row that raised the RowErrorTextNeeded event.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


RowHeaderCellChanged Event

[image]
Gizmox.WebGUI.Forms
RowHeaderCellChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : RowHeaderCellChanged Event

Occurs when the user changes the contents of a row header cell.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Property Changed")>
<SRDescriptionAttribute("Occurs when the user changes the contents of a row header cell.")>
Public Event RowHeaderCellChanged() As DataGridViewRowEventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As DataGridViewRowEventHandler

AddHandler instance.RowHeaderCellChanged, handler
C#
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when the user changes the contents of a row header cell.")]
public event DataGridViewRowEventHandler RowHeaderCellChanged()
Managed Extensions for C++
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when the user changes the contents of a row header cell.")]
public: __event DataGridViewRowEventHandler* RowHeaderCellChanged
C++/CLI
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when the user changes the contents of a row header cell.")]
public:
event DataGridViewRowEventHandler^ RowHeaderCellChanged

Event Data

The event handler receives an argument of type DataGridViewRowEventArgs containing data related to this event. The following DataGridViewRowEventArgs properties provide information specific to this event.

Property | Description
Row | Gets the DataGridViewRow associated with the event.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


RowHeaderMouseClick Event

[image]
Gizmox.WebGUI.Forms
RowHeaderMouseClick Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : RowHeaderMouseClick Event

Occurs when the user clicks within the boundaries of a row header.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the user clicks within the boundaries of a row header.")>
<SRCategoryAttribute("Mouse")>
Public Event RowHeaderMouseClick() As DataGridViewCellMouseEventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As DataGridViewCellMouseEventHandler

AddHandler instance.RowHeaderMouseClick, handler
C#
[SRDescriptionAttribute("Occurs when the user clicks within the boundaries of a row header.")]
[SRCategoryAttribute("Mouse")]
public event DataGridViewCellMouseEventHandler RowHeaderMouseClick()
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the user clicks within the boundaries of a row header.")]
[SRCategoryAttribute("Mouse")]
public: __event DataGridViewCellMouseEventHandler* RowHeaderMouseClick
C++/CLI
[SRDescriptionAttribute("Occurs when the user clicks within the boundaries of a row header.")]
[SRCategoryAttribute("Mouse")]
public:
event DataGridViewCellMouseEventHandler^ RowHeaderMouseClick

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


RowHeaderMouseDoubleClick Event

[image]
Gizmox.WebGUI.Forms
RowHeaderMouseDoubleClick Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : RowHeaderMouseDoubleClick Event

Occurs when a row header is double-clicked.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when a row header is double-clicked.")>
<SRCategoryAttribute("Mouse")>
Public Event RowHeaderMouseDoubleClick() As DataGridViewCellMouseEventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As DataGridViewCellMouseEventHandler

AddHandler instance.RowHeaderMouseDoubleClick, handler
C#
[SRDescriptionAttribute("Occurs when a row header is double-clicked.")]
[SRCategoryAttribute("Mouse")]
public event DataGridViewCellMouseEventHandler RowHeaderMouseDoubleClick()
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when a row header is double-clicked.")]
[SRCategoryAttribute("Mouse")]
public: __event DataGridViewCellMouseEventHandler* RowHeaderMouseDoubleClick
C++/CLI
[SRDescriptionAttribute("Occurs when a row header is double-clicked.")]
[SRCategoryAttribute("Mouse")]
public:
event DataGridViewCellMouseEventHandler^ RowHeaderMouseDoubleClick

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


RowHeadersBorderStyleChanged Event

[image]
Gizmox.WebGUI.Forms
RowHeadersBorderStyleChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : RowHeadersBorderStyleChanged Event

Occurs when the DataGridView.RowHeadersBorderStyle property changes.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Property Changed")>
<SRDescriptionAttribute("Occurs when the DataGridView.RowHeadersBorderStyle property changes.")>
Public Event RowHeadersBorderStyleChanged() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As EventHandler

AddHandler instance.RowHeadersBorderStyleChanged, handler
C#
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when the DataGridView.RowHeadersBorderStyle property changes.")]
public event EventHandler RowHeadersBorderStyleChanged()
Managed Extensions for C++
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when the DataGridView.RowHeadersBorderStyle property changes.")]
public: __event EventHandler* RowHeadersBorderStyleChanged
C++/CLI
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when the DataGridView.RowHeadersBorderStyle property changes.")]
public:
event EventHandler^ RowHeadersBorderStyleChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


RowHeadersDefaultCellStyleChanged Event

[image]
Gizmox.WebGUI.Forms
RowHeadersDefaultCellStyleChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : RowHeadersDefaultCellStyleChanged Event

Occurs when the value of the DataGridView.RowHeadersDefaultCellStyle property changes.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Property Changed")>
<SRDescriptionAttribute("Occurs when the value of the RowHeadersDefaultCellStyle property changes.")>
Public Event RowHeadersDefaultCellStyleChanged() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As EventHandler

AddHandler instance.RowHeadersDefaultCellStyleChanged, handler
C#
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when the value of the RowHeadersDefaultCellStyle property changes.")]
public event EventHandler RowHeadersDefaultCellStyleChanged()
Managed Extensions for C++
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when the value of the RowHeadersDefaultCellStyle property changes.")]
public: __event EventHandler* RowHeadersDefaultCellStyleChanged
C++/CLI
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when the value of the RowHeadersDefaultCellStyle property changes.")]
public:
event EventHandler^ RowHeadersDefaultCellStyleChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


RowHeadersWidthChanged Event

[image]
Gizmox.WebGUI.Forms
RowHeadersWidthChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : RowHeadersWidthChanged Event

Occurs when value of the RowHeadersWidth property changes.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the value of the RowHeadersWidth property changes.")>
<SRCategoryAttribute("Property Changed")>
Public Event RowHeadersWidthChanged() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As EventHandler

AddHandler instance.RowHeadersWidthChanged, handler
C#
[SRDescriptionAttribute("Occurs when the value of the RowHeadersWidth property changes.")]
[SRCategoryAttribute("Property Changed")]
public event EventHandler RowHeadersWidthChanged()
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the value of the RowHeadersWidth property changes.")]
[SRCategoryAttribute("Property Changed")]
public: __event EventHandler* RowHeadersWidthChanged
C++/CLI
[SRDescriptionAttribute("Occurs when the value of the RowHeadersWidth property changes.")]
[SRCategoryAttribute("Property Changed")]
public:
event EventHandler^ RowHeadersWidthChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


RowHeadersWidthSizeModeChanged Event

[image]
Gizmox.WebGUI.Forms
RowHeadersWidthSizeModeChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : RowHeadersWidthSizeModeChanged Event

Occurs when the value of the RowHeadersWidthSizeMode property changes.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Property Changed")>
<SRDescriptionAttribute("Occurs when the value of the RowHeadersWidthSizeMode property changes.")>
Public Event RowHeadersWidthSizeModeChanged() As DataGridViewAutoSizeModeEventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As DataGridViewAutoSizeModeEventHandler

AddHandler instance.RowHeadersWidthSizeModeChanged, handler
C#
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when the value of the RowHeadersWidthSizeMode property changes.")]
public event DataGridViewAutoSizeModeEventHandler RowHeadersWidthSizeModeChanged()
Managed Extensions for C++
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when the value of the RowHeadersWidthSizeMode property changes.")]
public: __event DataGridViewAutoSizeModeEventHandler* RowHeadersWidthSizeModeChanged
C++/CLI
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when the value of the RowHeadersWidthSizeMode property changes.")]
public:
event DataGridViewAutoSizeModeEventHandler^ RowHeadersWidthSizeModeChanged

Event Data

The event handler receives an argument of type DataGridViewAutoSizeModeEventArgs containing data related to this event. The following DataGridViewAutoSizeModeEventArgs properties provide information specific to this event.

Property | Description
PreviousModeAutoSized | Gets a value specifying whether the DataGridView was previously set to automatically resize.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


RowHeightChanged Event

[image]
Gizmox.WebGUI.Forms
RowHeightChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : RowHeightChanged Event

Occurs when the value of the DataGridViewRow.Height property for a row changes.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the value of the DataGridViewRow.Height property for a row changes.")>
<SRCategoryAttribute("Property Changed")>
Public Event RowHeightChanged() As DataGridViewRowEventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As DataGridViewRowEventHandler

AddHandler instance.RowHeightChanged, handler
C#
[SRDescriptionAttribute("Occurs when the value of the DataGridViewRow.Height property for a row changes.")]
[SRCategoryAttribute("Property Changed")]
public event DataGridViewRowEventHandler RowHeightChanged()
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the value of the DataGridViewRow.Height property for a row changes.")]
[SRCategoryAttribute("Property Changed")]
public: __event DataGridViewRowEventHandler* RowHeightChanged
C++/CLI
[SRDescriptionAttribute("Occurs when the value of the DataGridViewRow.Height property for a row changes.")]
[SRCategoryAttribute("Property Changed")]
public:
event DataGridViewRowEventHandler^ RowHeightChanged

Event Data

The event handler receives an argument of type DataGridViewRowEventArgs containing data related to this event. The following DataGridViewRowEventArgs properties provide information specific to this event.

Property | Description
Row | Gets the DataGridViewRow associated with the event.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


RowHeightInfoNeeded Event

[image]
Gizmox.WebGUI.Forms
RowHeightInfoNeeded Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : RowHeightInfoNeeded Event

Occurs when information about row height is requested.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Data")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<SRDescriptionAttribute("Occurs when information about row height is requested. ")>
Public Event RowHeightInfoNeeded() As DataGridViewRowHeightInfoNeededEventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As DataGridViewRowHeightInfoNeededEventHandler

AddHandler instance.RowHeightInfoNeeded, handler
C#
[SRCategoryAttribute("Data")]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRDescriptionAttribute("Occurs when information about row height is requested. ")]
public event DataGridViewRowHeightInfoNeededEventHandler RowHeightInfoNeeded()
Managed Extensions for C++
[SRCategoryAttribute("Data")]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRDescriptionAttribute("Occurs when information about row height is requested. ")]
public: __event DataGridViewRowHeightInfoNeededEventHandler* RowHeightInfoNeeded
C++/CLI
[SRCategoryAttribute("Data")]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRDescriptionAttribute("Occurs when information about row height is requested. ")]
public:
event DataGridViewRowHeightInfoNeededEventHandler^ RowHeightInfoNeeded

Event Data

The event handler receives an argument of type DataGridViewRowHeightInfoNeededEventArgs containing data related to this event. The following DataGridViewRowHeightInfoNeededEventArgs properties provide information specific to this event.

Property | Description
Height | Gets or sets the height of the row the event occurred for.
MinimumHeight | Gets or sets the minimum height of the row the event occurred for.
RowIndex | Gets the index of the row associated with this DataGridViewRowHeightInfoNeededEventArgs.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


RowHeightInfoPushed Event

[image]
Gizmox.WebGUI.Forms
RowHeightInfoPushed Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : RowHeightInfoPushed Event

Occurs when the user changes the height of a row.

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<SRCategoryAttribute("Data")>
<SRDescriptionAttribute("Occurs when the user changes the height of a row.")>
Public Event RowHeightInfoPushed() As DataGridViewRowHeightInfoPushedEventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As DataGridViewRowHeightInfoPushedEventHandler

AddHandler instance.RowHeightInfoPushed, handler
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRCategoryAttribute("Data")]
[SRDescriptionAttribute("Occurs when the user changes the height of a row.")]
public event DataGridViewRowHeightInfoPushedEventHandler RowHeightInfoPushed()
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRCategoryAttribute("Data")]
[SRDescriptionAttribute("Occurs when the user changes the height of a row.")]
public: __event DataGridViewRowHeightInfoPushedEventHandler* RowHeightInfoPushed
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRCategoryAttribute("Data")]
[SRDescriptionAttribute("Occurs when the user changes the height of a row.")]
public:
event DataGridViewRowHeightInfoPushedEventHandler^ RowHeightInfoPushed

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


RowLeave Event

[image]
Gizmox.WebGUI.Forms
RowLeave Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : RowLeave Event

Occurs when a row loses input focus and is no longer the current row.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when a row loses input focus and is no longer the current row.")>
<SRCategoryAttribute("Focus")>
Public Event RowLeave() As DataGridViewCellEventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As DataGridViewCellEventHandler

AddHandler instance.RowLeave, handler
C#
[SRDescriptionAttribute("Occurs when a row loses input focus and is no longer the current row.")]
[SRCategoryAttribute("Focus")]
public event DataGridViewCellEventHandler RowLeave()
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when a row loses input focus and is no longer the current row.")]
[SRCategoryAttribute("Focus")]
public: __event DataGridViewCellEventHandler* RowLeave
C++/CLI
[SRDescriptionAttribute("Occurs when a row loses input focus and is no longer the current row.")]
[SRCategoryAttribute("Focus")]
public:
event DataGridViewCellEventHandler^ RowLeave

Event Data

The event handler receives an argument of type DataGridViewCellEventArgs containing data related to this event. The following DataGridViewCellEventArgs properties provide information specific to this event.

Property | Description
ColumnIndex | Gets a value indicating the column index of the cell that the event occurs for.
RowIndex | Gets a value indicating the row index of the cell that the event occurs for.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


RowMinimumHeightChanged Event

[image]
Gizmox.WebGUI.Forms
RowMinimumHeightChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : RowMinimumHeightChanged Event

Occurs when the value of the DataGridViewRow.MinimumHeight property for a row changes.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the value of the DataGridViewRow.MinimumHeight property for a row changes.")>
<SRCategoryAttribute("Property Changed")>
Public Event RowMinimumHeightChanged() As DataGridViewRowEventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As DataGridViewRowEventHandler

AddHandler instance.RowMinimumHeightChanged, handler
C#
[SRDescriptionAttribute("Occurs when the value of the DataGridViewRow.MinimumHeight property for a row changes.")]
[SRCategoryAttribute("Property Changed")]
public event DataGridViewRowEventHandler RowMinimumHeightChanged()
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the value of the DataGridViewRow.MinimumHeight property for a row changes.")]
[SRCategoryAttribute("Property Changed")]
public: __event DataGridViewRowEventHandler* RowMinimumHeightChanged
C++/CLI
[SRDescriptionAttribute("Occurs when the value of the DataGridViewRow.MinimumHeight property for a row changes.")]
[SRCategoryAttribute("Property Changed")]
public:
event DataGridViewRowEventHandler^ RowMinimumHeightChanged

Event Data

The event handler receives an argument of type DataGridViewRowEventArgs containing data related to this event. The following DataGridViewRowEventArgs properties provide information specific to this event.

Property | Description
Row | Gets the DataGridViewRow associated with the event.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


RowsAdded Event

[image]
Gizmox.WebGUI.Forms
RowsAdded Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : RowsAdded Event

Occurs after a new row is added to the DataGridView.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Event raised when one or more rows are added to the rows collection.")>
<SRCategoryAttribute("Action")>
Public Event RowsAdded() As DataGridViewRowsAddedEventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As DataGridViewRowsAddedEventHandler

AddHandler instance.RowsAdded, handler
C#
[SRDescriptionAttribute("Event raised when one or more rows are added to the rows collection.")]
[SRCategoryAttribute("Action")]
public event DataGridViewRowsAddedEventHandler RowsAdded()
Managed Extensions for C++
[SRDescriptionAttribute("Event raised when one or more rows are added to the rows collection.")]
[SRCategoryAttribute("Action")]
public: __event DataGridViewRowsAddedEventHandler* RowsAdded
C++/CLI
[SRDescriptionAttribute("Event raised when one or more rows are added to the rows collection.")]
[SRCategoryAttribute("Action")]
public:
event DataGridViewRowsAddedEventHandler^ RowsAdded

Event Data

The event handler receives an argument of type DataGridViewRowsAddedEventArgs containing data related to this event. The following DataGridViewRowsAddedEventArgs properties provide information specific to this event.

Property | Description
RowCount | Gets the number of rows that have been added.
RowIndex | Gets the index of the first added row.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


RowsDefaultCellStyleChanged Event

[image]
Gizmox.WebGUI.Forms
RowsDefaultCellStyleChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : RowsDefaultCellStyleChanged Event

Occurs when the value of the DataGridView.RowsDefaultCellStyle property changes.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the value of the RowsDefaultCellStyle property changes.")>
<SRCategoryAttribute("Property Changed")>
Public Event RowsDefaultCellStyleChanged() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As EventHandler

AddHandler instance.RowsDefaultCellStyleChanged, handler
C#
[SRDescriptionAttribute("Occurs when the value of the RowsDefaultCellStyle property changes.")]
[SRCategoryAttribute("Property Changed")]
public event EventHandler RowsDefaultCellStyleChanged()
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the value of the RowsDefaultCellStyle property changes.")]
[SRCategoryAttribute("Property Changed")]
public: __event EventHandler* RowsDefaultCellStyleChanged
C++/CLI
[SRDescriptionAttribute("Occurs when the value of the RowsDefaultCellStyle property changes.")]
[SRCategoryAttribute("Property Changed")]
public:
event EventHandler^ RowsDefaultCellStyleChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


RowsRemoved Event

[image]
Gizmox.WebGUI.Forms
RowsRemoved Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : RowsRemoved Event

Occurs when a row or rows are deleted from the DataGridView.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Event raised when one or more rows are removed from the rows collection.")>
<SRCategoryAttribute("Action")>
Public Event RowsRemoved() As DataGridViewRowsRemovedEventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As DataGridViewRowsRemovedEventHandler

AddHandler instance.RowsRemoved, handler
C#
[SRDescriptionAttribute("Event raised when one or more rows are removed from the rows collection.")]
[SRCategoryAttribute("Action")]
public event DataGridViewRowsRemovedEventHandler RowsRemoved()
Managed Extensions for C++
[SRDescriptionAttribute("Event raised when one or more rows are removed from the rows collection.")]
[SRCategoryAttribute("Action")]
public: __event DataGridViewRowsRemovedEventHandler* RowsRemoved
C++/CLI
[SRDescriptionAttribute("Event raised when one or more rows are removed from the rows collection.")]
[SRCategoryAttribute("Action")]
public:
event DataGridViewRowsRemovedEventHandler^ RowsRemoved

Event Data

The event handler receives an argument of type DataGridViewRowsRemovedEventArgs containing data related to this event. The following DataGridViewRowsRemovedEventArgs properties provide information specific to this event.

Property | Description
RowCount | Gets the number of rows that were deleted.
RowIndex | Gets the zero-based index of the row deleted, or the first deleted row if multiple rows were deleted.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


RowStateChanged Event

[image]
Gizmox.WebGUI.Forms
RowStateChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : RowStateChanged Event

Occurs when a row changes state, such as losing or gaining input focus.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Behavior")>
<SRDescriptionAttribute("Occurs when a row changes state, such as losing or gaining input focus.")>
Public Event RowStateChanged() As DataGridViewRowStateChangedEventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As DataGridViewRowStateChangedEventHandler

AddHandler instance.RowStateChanged, handler
C#
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when a row changes state, such as losing or gaining input focus.")]
public event DataGridViewRowStateChangedEventHandler RowStateChanged()
Managed Extensions for C++
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when a row changes state, such as losing or gaining input focus.")]
public: __event DataGridViewRowStateChangedEventHandler* RowStateChanged
C++/CLI
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when a row changes state, such as losing or gaining input focus.")]
public:
event DataGridViewRowStateChangedEventHandler^ RowStateChanged

Event Data

The event handler receives an argument of type DataGridViewRowStateChangedEventArgs containing data related to this event. The following DataGridViewRowStateChangedEventArgs properties provide information specific to this event.

Property | Description
Row | Gets the DataGridViewRow that has a changed state.
StateChanged | Gets the state that has changed on the row.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


RowUnshared Event

[image]
Gizmox.WebGUI.Forms
RowUnshared Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : RowUnshared Event

Occurs when a row's state changes from shared to unshared.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Behavior")>
<SRDescriptionAttribute("Occurs when a row's state changes from shared to unshared.")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Event RowUnshared() As DataGridViewRowEventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As DataGridViewRowEventHandler

AddHandler instance.RowUnshared, handler
C#
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when a row's state changes from shared to unshared.")]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public event DataGridViewRowEventHandler RowUnshared()
Managed Extensions for C++
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when a row's state changes from shared to unshared.")]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: __event DataGridViewRowEventHandler* RowUnshared
C++/CLI
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when a row's state changes from shared to unshared.")]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
event DataGridViewRowEventHandler^ RowUnshared

Event Data

The event handler receives an argument of type DataGridViewRowEventArgs containing data related to this event. The following DataGridViewRowEventArgs properties provide information specific to this event.

Property | Description
Row | Gets the DataGridViewRow associated with the event.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


RowValidated Event

[image]
Gizmox.WebGUI.Forms
RowValidated Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : RowValidated Event

Occurs after a row has finished validating.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs after a row has finished validating.")>
<SRCategoryAttribute("Focus")>
Public Event RowValidated() As DataGridViewCellEventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As DataGridViewCellEventHandler

AddHandler instance.RowValidated, handler
C#
[SRDescriptionAttribute("Occurs after a row has finished validating.")]
[SRCategoryAttribute("Focus")]
public event DataGridViewCellEventHandler RowValidated()
Managed Extensions for C++
[SRDescriptionAttribute("Occurs after a row has finished validating.")]
[SRCategoryAttribute("Focus")]
public: __event DataGridViewCellEventHandler* RowValidated
C++/CLI
[SRDescriptionAttribute("Occurs after a row has finished validating.")]
[SRCategoryAttribute("Focus")]
public:
event DataGridViewCellEventHandler^ RowValidated

Event Data

The event handler receives an argument of type DataGridViewCellEventArgs containing data related to this event. The following DataGridViewCellEventArgs properties provide information specific to this event.

Property | Description
ColumnIndex | Gets a value indicating the column index of the cell that the event occurs for.
RowIndex | Gets a value indicating the row index of the cell that the event occurs for.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


RowValidating Event

[image]
Gizmox.WebGUI.Forms
RowValidating Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : RowValidating Event

Occurs when a row is validating.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when a row is validating.")>
<SRCategoryAttribute("Focus")>
Public Event RowValidating() As DataGridViewCellCancelEventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As DataGridViewCellCancelEventHandler

AddHandler instance.RowValidating, handler
C#
[SRDescriptionAttribute("Occurs when a row is validating.")]
[SRCategoryAttribute("Focus")]
public event DataGridViewCellCancelEventHandler RowValidating()
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when a row is validating.")]
[SRCategoryAttribute("Focus")]
public: __event DataGridViewCellCancelEventHandler* RowValidating
C++/CLI
[SRDescriptionAttribute("Occurs when a row is validating.")]
[SRCategoryAttribute("Focus")]
public:
event DataGridViewCellCancelEventHandler^ RowValidating

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


SelectionChanged Event

[image]
Gizmox.WebGUI.Forms
SelectionChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : SelectionChanged Event

Occurs when the current selection changes.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Action")>
<SRDescriptionAttribute("Occurs when the current selection changes.")>
Public Event SelectionChanged() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As EventHandler

AddHandler instance.SelectionChanged, handler
C#
[SRCategoryAttribute("Action")]
[SRDescriptionAttribute("Occurs when the current selection changes.")]
public event EventHandler SelectionChanged()
Managed Extensions for C++
[SRCategoryAttribute("Action")]
[SRDescriptionAttribute("Occurs when the current selection changes.")]
public: __event EventHandler* SelectionChanged
C++/CLI
[SRCategoryAttribute("Action")]
[SRDescriptionAttribute("Occurs when the current selection changes.")]
public:
event EventHandler^ SelectionChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


SelectionChangedQueued Event

[image]
Gizmox.WebGUI.Forms
SelectionChangedQueued Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : SelectionChangedQueued Event

Occurs when the current selection changes (queued version).

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Action")>
<SRDescriptionAttribute("Occurs when the current selection changes.")>
Public Event SelectionChangedQueued() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As EventHandler

AddHandler instance.SelectionChangedQueued, handler
C#
[SRCategoryAttribute("Action")]
[SRDescriptionAttribute("Occurs when the current selection changes.")]
public event EventHandler SelectionChangedQueued()
Managed Extensions for C++
[SRCategoryAttribute("Action")]
[SRDescriptionAttribute("Occurs when the current selection changes.")]
public: __event EventHandler* SelectionChangedQueued
C++/CLI
[SRCategoryAttribute("Action")]
[SRDescriptionAttribute("Occurs when the current selection changes.")]
public:
event EventHandler^ SelectionChangedQueued

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


SortCompare Event

[image]
Gizmox.WebGUI.Forms
SortCompare Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : SortCompare Event

Occurs when the DataGridView compares two cell values to perform a sort operation.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Data")>
<SRDescriptionAttribute("Occurs when the DataGridView compares two cell values to perform a sort operation.")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Event SortCompare() As DataGridViewSortCompareEventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As DataGridViewSortCompareEventHandler

AddHandler instance.SortCompare, handler
C#
[SRCategoryAttribute("Data")]
[SRDescriptionAttribute("Occurs when the DataGridView compares two cell values to perform a sort operation.")]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public event DataGridViewSortCompareEventHandler SortCompare()
Managed Extensions for C++
[SRCategoryAttribute("Data")]
[SRDescriptionAttribute("Occurs when the DataGridView compares two cell values to perform a sort operation.")]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: __event DataGridViewSortCompareEventHandler* SortCompare
C++/CLI
[SRCategoryAttribute("Data")]
[SRDescriptionAttribute("Occurs when the DataGridView compares two cell values to perform a sort operation.")]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
event DataGridViewSortCompareEventHandler^ SortCompare

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


Sorted Event

[image]
Gizmox.WebGUI.Forms
Sorted Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : Sorted Event

Occurs when the DataGridView control completes a sorting operation.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the DataGridView compares two cell values to perform a sort operation.")>
<SRCategoryAttribute("Data")>
Public Event Sorted() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As EventHandler

AddHandler instance.Sorted, handler
C#
[SRDescriptionAttribute("Occurs when the DataGridView compares two cell values to perform a sort operation.")]
[SRCategoryAttribute("Data")]
public event EventHandler Sorted()
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the DataGridView compares two cell values to perform a sort operation.")]
[SRCategoryAttribute("Data")]
public: __event EventHandler* Sorted
C++/CLI
[SRDescriptionAttribute("Occurs when the DataGridView compares two cell values to perform a sort operation.")]
[SRCategoryAttribute("Data")]
public:
event EventHandler^ Sorted

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


UserAddedRow Event

[image]
Gizmox.WebGUI.Forms
UserAddedRow Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : UserAddedRow Event

Occurs when the user has finished adding a row to the DataGridView control.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Action")>
<SRDescriptionAttribute("Occurs when the user has finished adding a row to the DataGridView control.")>
Public Event UserAddedRow() As DataGridViewRowEventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As DataGridViewRowEventHandler

AddHandler instance.UserAddedRow, handler
C#
[SRCategoryAttribute("Action")]
[SRDescriptionAttribute("Occurs when the user has finished adding a row to the DataGridView control.")]
public event DataGridViewRowEventHandler UserAddedRow()
Managed Extensions for C++
[SRCategoryAttribute("Action")]
[SRDescriptionAttribute("Occurs when the user has finished adding a row to the DataGridView control.")]
public: __event DataGridViewRowEventHandler* UserAddedRow
C++/CLI
[SRCategoryAttribute("Action")]
[SRDescriptionAttribute("Occurs when the user has finished adding a row to the DataGridView control.")]
public:
event DataGridViewRowEventHandler^ UserAddedRow

Event Data

The event handler receives an argument of type DataGridViewRowEventArgs containing data related to this event. The following DataGridViewRowEventArgs properties provide information specific to this event.

Property | Description
Row | Gets the DataGridViewRow associated with the event.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


UserDeletedRow Event

[image]
Gizmox.WebGUI.Forms
UserDeletedRow Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : UserDeletedRow Event

Occurs when the user has finished deleting a row from the DataGridView control.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the user has finished deleting a row from the DataGridView control.")>
<SRCategoryAttribute("Action")>
Public Event UserDeletedRow() As DataGridViewRowEventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As DataGridViewRowEventHandler

AddHandler instance.UserDeletedRow, handler
C#
[SRDescriptionAttribute("Occurs when the user has finished deleting a row from the DataGridView control.")]
[SRCategoryAttribute("Action")]
public event DataGridViewRowEventHandler UserDeletedRow()
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the user has finished deleting a row from the DataGridView control.")]
[SRCategoryAttribute("Action")]
public: __event DataGridViewRowEventHandler* UserDeletedRow
C++/CLI
[SRDescriptionAttribute("Occurs when the user has finished deleting a row from the DataGridView control.")]
[SRCategoryAttribute("Action")]
public:
event DataGridViewRowEventHandler^ UserDeletedRow

Event Data

The event handler receives an argument of type DataGridViewRowEventArgs containing data related to this event. The following DataGridViewRowEventArgs properties provide information specific to this event.

Property | Description
Row | Gets the DataGridViewRow associated with the event.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


UserDeletingRow Event

[image]
Gizmox.WebGUI.Forms
UserDeletingRow Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView Class : UserDeletingRow Event

Occurs when the user deletes a row from the DataGridView control.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Action")>
<SRDescriptionAttribute("Occurs when the user deletes a row from the DataGridView control.")>
Public Event UserDeletingRow() As DataGridViewRowCancelEventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridView
Dim handler As DataGridViewRowCancelEventHandler

AddHandler instance.UserDeletingRow, handler
C#
[SRCategoryAttribute("Action")]
[SRDescriptionAttribute("Occurs when the user deletes a row from the DataGridView control.")]
public event DataGridViewRowCancelEventHandler UserDeletingRow()
Managed Extensions for C++
[SRCategoryAttribute("Action")]
[SRDescriptionAttribute("Occurs when the user deletes a row from the DataGridView control.")]
public: __event DataGridViewRowCancelEventHandler* UserDeletingRow
C++/CLI
[SRCategoryAttribute("Action")]
[SRDescriptionAttribute("Occurs when the user deletes a row from the DataGridView control.")]
public:
event DataGridViewRowCancelEventHandler^ UserDeletingRow

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView Class
DataGridView Members


DataGridView.DisplayedBandsData Class

[image]
Gizmox.WebGUI.Forms
DataGridView.DisplayedBandsData Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridView.DisplayedBandsData Class

Syntax

Visual Basic (Declaration)
Private Class DataGridView.DisplayedBandsData
Visual Basic (Usage) Copy Code
Dim instance As DataGridView.DisplayedBandsData
C#
private class DataGridView.DisplayedBandsData
Managed Extensions for C++
private __gc class DataGridView.DisplayedBandsData
C++/CLI
private ref class DataGridView.DisplayedBandsData

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.DataGridView.DisplayedBandsData

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

DataGridView.DisplayedBandsData Members
Gizmox.WebGUI.Forms Namespace


DataGridView.DisplayedBandsData Class Members

[image]
Gizmox.WebGUI.Forms
DataGridView.DisplayedBandsData Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridView.DisplayedBandsData Class

The following tables list the members exposed by DataGridView.DisplayedBandsData.

Public Constructors

 | Name | Description
Public Constructor | DataGridView.DisplayedBandsData Constructor |
Top

Public Properties

 | Name | Description
Public Property | ColumnInsertionOccurred |
Public Property | Dirty |
Public Property | FirstDisplayedFrozenCol |
Public Property | FirstDisplayedFrozenRow |
Public Property | FirstDisplayedScrollingCol |
Public Property | FirstDisplayedScrollingRow |
Public Property | LastDisplayedFrozenCol |
Public Property | LastDisplayedFrozenRow |
Public Property | LastDisplayedScrollingRow |
Public Property | LastTotallyDisplayedScrollingCol |
Public Property | NumDisplayedFrozenCols |
Public Property | NumDisplayedFrozenRows |
Public Property | NumDisplayedScrollingCols |
Public Property | NumDisplayedScrollingRows |
Public Property | NumTotallyDisplayedFrozenRows |
Public Property | NumTotallyDisplayedScrollingRows |
Public Property | OldFirstDisplayedScrollingCol |
Public Property | OldFirstDisplayedScrollingRow |
Public Property | OldNumDisplayedFrozenRows |
Public Property | OldNumDisplayedScrollingRows |
Public Property | RowInsertionOccurred |
Top

Public Methods

 | Name | Description
Public Method | CorrectColumnIndexAfterInsertion |
Public Method | CorrectRowIndexAfterDeletion |
Public Method | CorrectRowIndexAfterInsertion |
Public Method | EnsureDirtyState |
Top

See Also

Reference

DataGridView.DisplayedBandsData Class
Gizmox.WebGUI.Forms Namespace


DataGridView.DisplayedBandsData Constructor

[image]
Gizmox.WebGUI.Forms
DataGridView.DisplayedBandsData Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView.DisplayedBandsData Class : DataGridView.DisplayedBandsData Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As DataGridView.DisplayedBandsData()
C#
public DataGridView.DisplayedBandsData()
Managed Extensions for C++
public: DataGridView.DisplayedBandsData();
C++/CLI
public:
DataGridView.DisplayedBandsData();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView.DisplayedBandsData Class
DataGridView.DisplayedBandsData Members


DataGridView.DisplayedBandsData Class Methods

[image]
Gizmox.WebGUI.Forms
DataGridView.DisplayedBandsData Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridView.DisplayedBandsData Class

For a list of all members of this type, see DataGridView.DisplayedBandsData members.

Public Methods

 | Name | Description
Public Method | CorrectColumnIndexAfterInsertion |
Public Method | CorrectRowIndexAfterDeletion |
Public Method | CorrectRowIndexAfterInsertion |
Public Method | EnsureDirtyState |
Top

See Also

Reference

DataGridView.DisplayedBandsData Class
Gizmox.WebGUI.Forms Namespace


CorrectColumnIndexAfterInsertion Method

[image]
Gizmox.WebGUI.Forms
CorrectColumnIndexAfterInsertion Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView.DisplayedBandsData Class : CorrectColumnIndexAfterInsertion Method

columnIndex
insertionCount

Syntax

Visual Basic (Declaration)
Public Sub CorrectColumnIndexAfterInsertion( _
   ByVal columnIndex As Integer, _
   ByVal insertionCount As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView.DisplayedBandsData
Dim columnIndex As Integer
Dim insertionCount As Integer

instance.CorrectColumnIndexAfterInsertion(columnIndex, insertionCount)
C#
public void CorrectColumnIndexAfterInsertion(
   int columnIndex,
   int insertionCount
)
Managed Extensions for C++
public: void CorrectColumnIndexAfterInsertion(
   int columnIndex,
   int insertionCount
)
C++/CLI
public:
void CorrectColumnIndexAfterInsertion(
   int columnIndex,
   int insertionCount
)

Parameters

columnIndex
insertionCount

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView.DisplayedBandsData Class
DataGridView.DisplayedBandsData Members


CorrectRowIndexAfterDeletion Method

[image]
Gizmox.WebGUI.Forms
CorrectRowIndexAfterDeletion Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView.DisplayedBandsData Class : CorrectRowIndexAfterDeletion Method

rowIndex

Syntax

Visual Basic (Declaration)
Public Sub CorrectRowIndexAfterDeletion( _
   ByVal rowIndex As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView.DisplayedBandsData
Dim rowIndex As Integer

instance.CorrectRowIndexAfterDeletion(rowIndex)
C#
public void CorrectRowIndexAfterDeletion(
   int rowIndex
)
Managed Extensions for C++
public: void CorrectRowIndexAfterDeletion(
   int rowIndex
)
C++/CLI
public:
void CorrectRowIndexAfterDeletion(
   int rowIndex
)

Parameters

rowIndex

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView.DisplayedBandsData Class
DataGridView.DisplayedBandsData Members


CorrectRowIndexAfterInsertion Method

[image]
Gizmox.WebGUI.Forms
CorrectRowIndexAfterInsertion Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView.DisplayedBandsData Class : CorrectRowIndexAfterInsertion Method

rowIndex
insertionCount

Syntax

Visual Basic (Declaration)
Public Sub CorrectRowIndexAfterInsertion( _
   ByVal rowIndex As Integer, _
   ByVal insertionCount As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridView.DisplayedBandsData
Dim rowIndex As Integer
Dim insertionCount As Integer

instance.CorrectRowIndexAfterInsertion(rowIndex, insertionCount)
C#
public void CorrectRowIndexAfterInsertion(
   int rowIndex,
   int insertionCount
)
Managed Extensions for C++
public: void CorrectRowIndexAfterInsertion(
   int rowIndex,
   int insertionCount
)
C++/CLI
public:
void CorrectRowIndexAfterInsertion(
   int rowIndex,
   int insertionCount
)

Parameters

rowIndex
insertionCount

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView.DisplayedBandsData Class
DataGridView.DisplayedBandsData Members


EnsureDirtyState Method

[image]
Gizmox.WebGUI.Forms
EnsureDirtyState Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView.DisplayedBandsData Class : EnsureDirtyState Method

Syntax

Visual Basic (Declaration)
Public Sub EnsureDirtyState()
Visual Basic (Usage) Copy Code
Dim instance As DataGridView.DisplayedBandsData

instance.EnsureDirtyState()
C#
public void EnsureDirtyState()
Managed Extensions for C++
public: void EnsureDirtyState();
C++/CLI
public:
void EnsureDirtyState();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView.DisplayedBandsData Class
DataGridView.DisplayedBandsData Members


DataGridView.DisplayedBandsData Class Properties

[image]
Gizmox.WebGUI.Forms
DataGridView.DisplayedBandsData Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridView.DisplayedBandsData Class

For a list of all members of this type, see DataGridView.DisplayedBandsData members.

Public Properties

 | Name | Description
Public Property | ColumnInsertionOccurred |
Public Property | Dirty |
Public Property | FirstDisplayedFrozenCol |
Public Property | FirstDisplayedFrozenRow |
Public Property | FirstDisplayedScrollingCol |
Public Property | FirstDisplayedScrollingRow |
Public Property | LastDisplayedFrozenCol |
Public Property | LastDisplayedFrozenRow |
Public Property | LastDisplayedScrollingRow |
Public Property | LastTotallyDisplayedScrollingCol |
Public Property | NumDisplayedFrozenCols |
Public Property | NumDisplayedFrozenRows |
Public Property | NumDisplayedScrollingCols |
Public Property | NumDisplayedScrollingRows |
Public Property | NumTotallyDisplayedFrozenRows |
Public Property | NumTotallyDisplayedScrollingRows |
Public Property | OldFirstDisplayedScrollingCol |
Public Property | OldFirstDisplayedScrollingRow |
Public Property | OldNumDisplayedFrozenRows |
Public Property | OldNumDisplayedScrollingRows |
Public Property | RowInsertionOccurred |
Top

See Also

Reference

DataGridView.DisplayedBandsData Class
Gizmox.WebGUI.Forms Namespace


ColumnInsertionOccurred Property

[image]
Gizmox.WebGUI.Forms
ColumnInsertionOccurred Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView.DisplayedBandsData Class : ColumnInsertionOccurred Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ColumnInsertionOccurred As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridView.DisplayedBandsData
Dim value As Boolean

value = instance.ColumnInsertionOccurred
C#
public bool ColumnInsertionOccurred {get;}
Managed Extensions for C++
public: __property bool get_ColumnInsertionOccurred();
C++/CLI
public:
property bool ColumnInsertionOccurred {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView.DisplayedBandsData Class
DataGridView.DisplayedBandsData Members


Dirty Property

[image]
Gizmox.WebGUI.Forms
Dirty Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView.DisplayedBandsData Class : Dirty Property

Syntax

Visual Basic (Declaration)
Public Property Dirty As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridView.DisplayedBandsData
Dim value As Boolean

instance.Dirty = value

value = instance.Dirty
C#
public bool Dirty {get; set;}
Managed Extensions for C++
public: __property bool get_Dirty();
public: __property void set_Dirty(
   bool value
);
C++/CLI
public:
property bool Dirty {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView.DisplayedBandsData Class
DataGridView.DisplayedBandsData Members


FirstDisplayedFrozenCol Property

[image]
Gizmox.WebGUI.Forms
FirstDisplayedFrozenCol Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView.DisplayedBandsData Class : FirstDisplayedFrozenCol Property

Syntax

Visual Basic (Declaration)
Public WriteOnly Property FirstDisplayedFrozenCol As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridView.DisplayedBandsData

instance.FirstDisplayedFrozenCol = value
C#
public int FirstDisplayedFrozenCol {set;}
Managed Extensions for C++
public: __property void set_FirstDisplayedFrozenCol(
   int value
);
C++/CLI
public:
property int FirstDisplayedFrozenCol {
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView.DisplayedBandsData Class
DataGridView.DisplayedBandsData Members


FirstDisplayedFrozenRow Property

[image]
Gizmox.WebGUI.Forms
FirstDisplayedFrozenRow Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView.DisplayedBandsData Class : FirstDisplayedFrozenRow Property

Syntax

Visual Basic (Declaration)
Public WriteOnly Property FirstDisplayedFrozenRow As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridView.DisplayedBandsData

instance.FirstDisplayedFrozenRow = value
C#
public int FirstDisplayedFrozenRow {set;}
Managed Extensions for C++
public: __property void set_FirstDisplayedFrozenRow(
   int value
);
C++/CLI
public:
property int FirstDisplayedFrozenRow {
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView.DisplayedBandsData Class
DataGridView.DisplayedBandsData Members


FirstDisplayedScrollingCol Property

[image]
Gizmox.WebGUI.Forms
FirstDisplayedScrollingCol Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView.DisplayedBandsData Class : FirstDisplayedScrollingCol Property

Syntax

Visual Basic (Declaration)
Public Property FirstDisplayedScrollingCol As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridView.DisplayedBandsData
Dim value As Integer

instance.FirstDisplayedScrollingCol = value

value = instance.FirstDisplayedScrollingCol
C#
public int FirstDisplayedScrollingCol {get; set;}
Managed Extensions for C++
public: __property int get_FirstDisplayedScrollingCol();
public: __property void set_FirstDisplayedScrollingCol(
   int value
);
C++/CLI
public:
property int FirstDisplayedScrollingCol {
   int get();
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView.DisplayedBandsData Class
DataGridView.DisplayedBandsData Members


FirstDisplayedScrollingRow Property

[image]
Gizmox.WebGUI.Forms
FirstDisplayedScrollingRow Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView.DisplayedBandsData Class : FirstDisplayedScrollingRow Property

Syntax

Visual Basic (Declaration)
Public Property FirstDisplayedScrollingRow As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridView.DisplayedBandsData
Dim value As Integer

instance.FirstDisplayedScrollingRow = value

value = instance.FirstDisplayedScrollingRow
C#
public int FirstDisplayedScrollingRow {get; set;}
Managed Extensions for C++
public: __property int get_FirstDisplayedScrollingRow();
public: __property void set_FirstDisplayedScrollingRow(
   int value
);
C++/CLI
public:
property int FirstDisplayedScrollingRow {
   int get();
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView.DisplayedBandsData Class
DataGridView.DisplayedBandsData Members


LastDisplayedFrozenCol Property

[image]
Gizmox.WebGUI.Forms
LastDisplayedFrozenCol Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView.DisplayedBandsData Class : LastDisplayedFrozenCol Property

Syntax

Visual Basic (Declaration)
Public WriteOnly Property LastDisplayedFrozenCol As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridView.DisplayedBandsData

instance.LastDisplayedFrozenCol = value
C#
public int LastDisplayedFrozenCol {set;}
Managed Extensions for C++
public: __property void set_LastDisplayedFrozenCol(
   int value
);
C++/CLI
public:
property int LastDisplayedFrozenCol {
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView.DisplayedBandsData Class
DataGridView.DisplayedBandsData Members


LastDisplayedFrozenRow Property

[image]
Gizmox.WebGUI.Forms
LastDisplayedFrozenRow Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView.DisplayedBandsData Class : LastDisplayedFrozenRow Property

Syntax

Visual Basic (Declaration)
Public WriteOnly Property LastDisplayedFrozenRow As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridView.DisplayedBandsData

instance.LastDisplayedFrozenRow = value
C#
public int LastDisplayedFrozenRow {set;}
Managed Extensions for C++
public: __property void set_LastDisplayedFrozenRow(
   int value
);
C++/CLI
public:
property int LastDisplayedFrozenRow {
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView.DisplayedBandsData Class
DataGridView.DisplayedBandsData Members


LastDisplayedScrollingRow Property

[image]
Gizmox.WebGUI.Forms
LastDisplayedScrollingRow Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView.DisplayedBandsData Class : LastDisplayedScrollingRow Property

Syntax

Visual Basic (Declaration)
Public WriteOnly Property LastDisplayedScrollingRow As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridView.DisplayedBandsData

instance.LastDisplayedScrollingRow = value
C#
public int LastDisplayedScrollingRow {set;}
Managed Extensions for C++
public: __property void set_LastDisplayedScrollingRow(
   int value
);
C++/CLI
public:
property int LastDisplayedScrollingRow {
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView.DisplayedBandsData Class
DataGridView.DisplayedBandsData Members


LastTotallyDisplayedScrollingCol Property

[image]
Gizmox.WebGUI.Forms
LastTotallyDisplayedScrollingCol Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView.DisplayedBandsData Class : LastTotallyDisplayedScrollingCol Property

Syntax

Visual Basic (Declaration)
Public Property LastTotallyDisplayedScrollingCol As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridView.DisplayedBandsData
Dim value As Integer

instance.LastTotallyDisplayedScrollingCol = value

value = instance.LastTotallyDisplayedScrollingCol
C#
public int LastTotallyDisplayedScrollingCol {get; set;}
Managed Extensions for C++
public: __property int get_LastTotallyDisplayedScrollingCol();
public: __property void set_LastTotallyDisplayedScrollingCol(
   int value
);
C++/CLI
public:
property int LastTotallyDisplayedScrollingCol {
   int get();
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView.DisplayedBandsData Class
DataGridView.DisplayedBandsData Members


NumDisplayedFrozenCols Property

[image]
Gizmox.WebGUI.Forms
NumDisplayedFrozenCols Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView.DisplayedBandsData Class : NumDisplayedFrozenCols Property

Syntax

Visual Basic (Declaration)
Public Property NumDisplayedFrozenCols As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridView.DisplayedBandsData
Dim value As Integer

instance.NumDisplayedFrozenCols = value

value = instance.NumDisplayedFrozenCols
C#
public int NumDisplayedFrozenCols {get; set;}
Managed Extensions for C++
public: __property int get_NumDisplayedFrozenCols();
public: __property void set_NumDisplayedFrozenCols(
   int value
);
C++/CLI
public:
property int NumDisplayedFrozenCols {
   int get();
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView.DisplayedBandsData Class
DataGridView.DisplayedBandsData Members


NumDisplayedFrozenRows Property

[image]
Gizmox.WebGUI.Forms
NumDisplayedFrozenRows Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView.DisplayedBandsData Class : NumDisplayedFrozenRows Property

Syntax

Visual Basic (Declaration)
Public Property NumDisplayedFrozenRows As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridView.DisplayedBandsData
Dim value As Integer

instance.NumDisplayedFrozenRows = value

value = instance.NumDisplayedFrozenRows
C#
public int NumDisplayedFrozenRows {get; set;}
Managed Extensions for C++
public: __property int get_NumDisplayedFrozenRows();
public: __property void set_NumDisplayedFrozenRows(
   int value
);
C++/CLI
public:
property int NumDisplayedFrozenRows {
   int get();
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView.DisplayedBandsData Class
DataGridView.DisplayedBandsData Members


NumDisplayedScrollingCols Property

[image]
Gizmox.WebGUI.Forms
NumDisplayedScrollingCols Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView.DisplayedBandsData Class : NumDisplayedScrollingCols Property

Syntax

Visual Basic (Declaration)
Public Property NumDisplayedScrollingCols As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridView.DisplayedBandsData
Dim value As Integer

instance.NumDisplayedScrollingCols = value

value = instance.NumDisplayedScrollingCols
C#
public int NumDisplayedScrollingCols {get; set;}
Managed Extensions for C++
public: __property int get_NumDisplayedScrollingCols();
public: __property void set_NumDisplayedScrollingCols(
   int value
);
C++/CLI
public:
property int NumDisplayedScrollingCols {
   int get();
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView.DisplayedBandsData Class
DataGridView.DisplayedBandsData Members


NumDisplayedScrollingRows Property

[image]
Gizmox.WebGUI.Forms
NumDisplayedScrollingRows Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView.DisplayedBandsData Class : NumDisplayedScrollingRows Property

Syntax

Visual Basic (Declaration)
Public Property NumDisplayedScrollingRows As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridView.DisplayedBandsData
Dim value As Integer

instance.NumDisplayedScrollingRows = value

value = instance.NumDisplayedScrollingRows
C#
public int NumDisplayedScrollingRows {get; set;}
Managed Extensions for C++
public: __property int get_NumDisplayedScrollingRows();
public: __property void set_NumDisplayedScrollingRows(
   int value
);
C++/CLI
public:
property int NumDisplayedScrollingRows {
   int get();
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView.DisplayedBandsData Class
DataGridView.DisplayedBandsData Members


NumTotallyDisplayedFrozenRows Property

[image]
Gizmox.WebGUI.Forms
NumTotallyDisplayedFrozenRows Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView.DisplayedBandsData Class : NumTotallyDisplayedFrozenRows Property

Syntax

Visual Basic (Declaration)
Public Property NumTotallyDisplayedFrozenRows As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridView.DisplayedBandsData
Dim value As Integer

instance.NumTotallyDisplayedFrozenRows = value

value = instance.NumTotallyDisplayedFrozenRows
C#
public int NumTotallyDisplayedFrozenRows {get; set;}
Managed Extensions for C++
public: __property int get_NumTotallyDisplayedFrozenRows();
public: __property void set_NumTotallyDisplayedFrozenRows(
   int value
);
C++/CLI
public:
property int NumTotallyDisplayedFrozenRows {
   int get();
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView.DisplayedBandsData Class
DataGridView.DisplayedBandsData Members


NumTotallyDisplayedScrollingRows Property

[image]
Gizmox.WebGUI.Forms
NumTotallyDisplayedScrollingRows Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView.DisplayedBandsData Class : NumTotallyDisplayedScrollingRows Property

Syntax

Visual Basic (Declaration)
Public Property NumTotallyDisplayedScrollingRows As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridView.DisplayedBandsData
Dim value As Integer

instance.NumTotallyDisplayedScrollingRows = value

value = instance.NumTotallyDisplayedScrollingRows
C#
public int NumTotallyDisplayedScrollingRows {get; set;}
Managed Extensions for C++
public: __property int get_NumTotallyDisplayedScrollingRows();
public: __property void set_NumTotallyDisplayedScrollingRows(
   int value
);
C++/CLI
public:
property int NumTotallyDisplayedScrollingRows {
   int get();
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView.DisplayedBandsData Class
DataGridView.DisplayedBandsData Members


OldFirstDisplayedScrollingCol Property

[image]
Gizmox.WebGUI.Forms
OldFirstDisplayedScrollingCol Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView.DisplayedBandsData Class : OldFirstDisplayedScrollingCol Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OldFirstDisplayedScrollingCol As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridView.DisplayedBandsData
Dim value As Integer

value = instance.OldFirstDisplayedScrollingCol
C#
public int OldFirstDisplayedScrollingCol {get;}
Managed Extensions for C++
public: __property int get_OldFirstDisplayedScrollingCol();
C++/CLI
public:
property int OldFirstDisplayedScrollingCol {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView.DisplayedBandsData Class
DataGridView.DisplayedBandsData Members


OldFirstDisplayedScrollingRow Property

[image]
Gizmox.WebGUI.Forms
OldFirstDisplayedScrollingRow Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView.DisplayedBandsData Class : OldFirstDisplayedScrollingRow Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OldFirstDisplayedScrollingRow As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridView.DisplayedBandsData
Dim value As Integer

value = instance.OldFirstDisplayedScrollingRow
C#
public int OldFirstDisplayedScrollingRow {get;}
Managed Extensions for C++
public: __property int get_OldFirstDisplayedScrollingRow();
C++/CLI
public:
property int OldFirstDisplayedScrollingRow {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView.DisplayedBandsData Class
DataGridView.DisplayedBandsData Members


OldNumDisplayedFrozenRows Property

[image]
Gizmox.WebGUI.Forms
OldNumDisplayedFrozenRows Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView.DisplayedBandsData Class : OldNumDisplayedFrozenRows Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OldNumDisplayedFrozenRows As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridView.DisplayedBandsData
Dim value As Integer

value = instance.OldNumDisplayedFrozenRows
C#
public int OldNumDisplayedFrozenRows {get;}
Managed Extensions for C++
public: __property int get_OldNumDisplayedFrozenRows();
C++/CLI
public:
property int OldNumDisplayedFrozenRows {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView.DisplayedBandsData Class
DataGridView.DisplayedBandsData Members


OldNumDisplayedScrollingRows Property

[image]
Gizmox.WebGUI.Forms
OldNumDisplayedScrollingRows Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView.DisplayedBandsData Class : OldNumDisplayedScrollingRows Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OldNumDisplayedScrollingRows As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridView.DisplayedBandsData
Dim value As Integer

value = instance.OldNumDisplayedScrollingRows
C#
public int OldNumDisplayedScrollingRows {get;}
Managed Extensions for C++
public: __property int get_OldNumDisplayedScrollingRows();
C++/CLI
public:
property int OldNumDisplayedScrollingRows {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView.DisplayedBandsData Class
DataGridView.DisplayedBandsData Members


RowInsertionOccurred Property

[image]
Gizmox.WebGUI.Forms
RowInsertionOccurred Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridView.DisplayedBandsData Class : RowInsertionOccurred Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RowInsertionOccurred As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridView.DisplayedBandsData
Dim value As Boolean

value = instance.RowInsertionOccurred
C#
public bool RowInsertionOccurred {get;}
Managed Extensions for C++
public: __property bool get_RowInsertionOccurred();
C++/CLI
public:
property bool RowInsertionOccurred {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridView.DisplayedBandsData Class
DataGridView.DisplayedBandsData Members


DataGridViewAdvancedBorderStyle Class

[image]
Gizmox.WebGUI.Forms
DataGridViewAdvancedBorderStyle Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewAdvancedBorderStyle Class

Contains border styles for the cells in a DataGridView control.

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DataGridViewAdvancedBorderStyle
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewAdvancedBorderStyle
C#
public sealed class DataGridViewAdvancedBorderStyle
Managed Extensions for C++
public __gc __sealed class DataGridViewAdvancedBorderStyle
C++/CLI
public ref class DataGridViewAdvancedBorderStyle sealed

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.DataGridViewAdvancedBorderStyle

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

DataGridViewAdvancedBorderStyle Members
Gizmox.WebGUI.Forms Namespace


DataGridViewAdvancedBorderStyle Class Members

[image]
Gizmox.WebGUI.Forms
DataGridViewAdvancedBorderStyle Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewAdvancedBorderStyle Class

The following tables list the members exposed by DataGridViewAdvancedBorderStyle.

Public Constructors

 | Name | Description
Public Constructor | DataGridViewAdvancedBorderStyle Constructor | Initializes a new instance of the DataGridViewAdvancedBorderStyle class.
Top

Public Properties

 | Name | Description
Public Property | All | Gets or sets the border style for all of the borders of a cell.
Public Property | Bottom | Gets or sets the style for the bottom border of a cell.
Public Property | Left | Gets the style for the left border of a cell.
Public Property | Right | Gets the style for the right border of a cell.
Public Property | Top | Gets the style for the top border of a cell.
Top

Public Methods

 | Name | Description
Public Method | Equals | Overridden. Determines whether the specified object is equal to the current DataGridViewAdvancedBorderStyle.
Public Method | GetHashCode | Overridden.
Public Method | ToString | Overridden. Returns a string that represents the DataGridViewAdvancedBorderStyle.
Top

See Also

Reference

DataGridViewAdvancedBorderStyle Class
Gizmox.WebGUI.Forms Namespace


DataGridViewAdvancedBorderStyle Constructor

[image]
Gizmox.WebGUI.Forms
DataGridViewAdvancedBorderStyle Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewAdvancedBorderStyle Class : DataGridViewAdvancedBorderStyle Constructor

Initializes a new instance of the DataGridViewAdvancedBorderStyle class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewAdvancedBorderStyle()
C#
public DataGridViewAdvancedBorderStyle()
Managed Extensions for C++
public: DataGridViewAdvancedBorderStyle();
C++/CLI
public:
DataGridViewAdvancedBorderStyle();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewAdvancedBorderStyle Class
DataGridViewAdvancedBorderStyle Members


DataGridViewAdvancedBorderStyle Class Methods

[image]
Gizmox.WebGUI.Forms
DataGridViewAdvancedBorderStyle Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewAdvancedBorderStyle Class

For a list of all members of this type, see DataGridViewAdvancedBorderStyle members.

Public Methods

 | Name | Description
Public Method | Equals | Overridden. Determines whether the specified object is equal to the current DataGridViewAdvancedBorderStyle.
Public Method | GetHashCode | Overridden.
Public Method | ToString | Overridden. Returns a string that represents the DataGridViewAdvancedBorderStyle.
Top

See Also

Reference

DataGridViewAdvancedBorderStyle Class
Gizmox.WebGUI.Forms Namespace


Equals Method

[image]
Gizmox.WebGUI.Forms
Equals Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewAdvancedBorderStyle Class : Equals Method

other
An Object to be compared.
Determines whether the specified object is equal to the current DataGridViewAdvancedBorderStyle.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function Equals( _
   ByVal other As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewAdvancedBorderStyle
Dim other As Object
Dim value As Boolean

value = instance.Equals(other)
C#
public override bool Equals(
   object other
)
Managed Extensions for C++
public: bool Equals(
   Object* other
) override
C++/CLI
public:
bool Equals(
   Object^ other
) override

Parameters

other
An Object to be compared.

Return Value

true if other is a DataGridViewAdvancedBorderStyle and the values for the Top, Bottom, Left, and Right properties are equal to their counterpart in the current DataGridViewAdvancedBorderStyle; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewAdvancedBorderStyle Class
DataGridViewAdvancedBorderStyle Members


GetHashCode Method

[image]
Gizmox.WebGUI.Forms
GetHashCode Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewAdvancedBorderStyle Class : GetHashCode Method

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewAdvancedBorderStyle
Dim value As Integer

value = instance.GetHashCode()
C#
public override int GetHashCode()
Managed Extensions for C++
public: int GetHashCode(); override
C++/CLI
public:
int GetHashCode(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewAdvancedBorderStyle Class
DataGridViewAdvancedBorderStyle Members


ToString Method

[image]
Gizmox.WebGUI.Forms
ToString Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewAdvancedBorderStyle Class : ToString Method

Returns a string that represents the DataGridViewAdvancedBorderStyle.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewAdvancedBorderStyle
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Return Value

A string that represents the DataGridViewAdvancedBorderStyle.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewAdvancedBorderStyle Class
DataGridViewAdvancedBorderStyle Members


DataGridViewAdvancedBorderStyle Class Properties

[image]
Gizmox.WebGUI.Forms
DataGridViewAdvancedBorderStyle Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewAdvancedBorderStyle Class

For a list of all members of this type, see DataGridViewAdvancedBorderStyle members.

Public Properties

 | Name | Description
Public Property | All | Gets or sets the border style for all of the borders of a cell.
Public Property | Bottom | Gets or sets the style for the bottom border of a cell.
Public Property | Left | Gets the style for the left border of a cell.
Public Property | Right | Gets the style for the right border of a cell.
Public Property | Top | Gets the style for the top border of a cell.
Top

See Also

Reference

DataGridViewAdvancedBorderStyle Class
Gizmox.WebGUI.Forms Namespace


All Property

[image]
Gizmox.WebGUI.Forms
All Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewAdvancedBorderStyle Class : All Property

Gets or sets the border style for all of the borders of a cell.

Syntax

Visual Basic (Declaration)
Public Property All As DataGridViewAdvancedCellBorderStyle
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewAdvancedBorderStyle
Dim value As DataGridViewAdvancedCellBorderStyle

instance.All = value

value = instance.All
C#
public DataGridViewAdvancedCellBorderStyle All {get; set;}
Managed Extensions for C++
public: __property DataGridViewAdvancedCellBorderStyle get_All();
public: __property void set_All(
   DataGridViewAdvancedCellBorderStyle value
);
C++/CLI
public:
property DataGridViewAdvancedCellBorderStyle All {
   DataGridViewAdvancedCellBorderStyle get();
   void set (DataGridViewAdvancedCellBorderStylevalue);
}

Exceptions

Exception | Description
InvalidEnumArgumentException | The specified value when setting this property is not a valid DataGridViewAdvancedCellBorderStyle values.
ArgumentException | The specified value when setting this property is DataGridViewAdvancedCellBorderStyle.NotSet.-or-The specified value when setting this property is DataGridViewAdvancedCellBorderStyle.OutsetDouble, DataGridViewAdvancedCellBorderStyle.OutsetPartial, or DataGridViewAdvancedCellBorderStyle.InsetDouble and this DataGridViewAdvancedBorderStyle instance was retrieved through the DataGridView.AdvancedCellBorderStyle property.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewAdvancedBorderStyle Class
DataGridViewAdvancedBorderStyle Members


Bottom Property

[image]
Gizmox.WebGUI.Forms
Bottom Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewAdvancedBorderStyle Class : Bottom Property

Gets or sets the style for the bottom border of a cell.

Syntax

Visual Basic (Declaration)
Public Property Bottom As DataGridViewAdvancedCellBorderStyle
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewAdvancedBorderStyle
Dim value As DataGridViewAdvancedCellBorderStyle

instance.Bottom = value

value = instance.Bottom
C#
public DataGridViewAdvancedCellBorderStyle Bottom {get; set;}
Managed Extensions for C++
public: __property DataGridViewAdvancedCellBorderStyle get_Bottom();
public: __property void set_Bottom(
   DataGridViewAdvancedCellBorderStyle value
);
C++/CLI
public:
property DataGridViewAdvancedCellBorderStyle Bottom {
   DataGridViewAdvancedCellBorderStyle get();
   void set (DataGridViewAdvancedCellBorderStylevalue);
}

Exceptions

Exception | Description
InvalidEnumArgumentException | The specified value when setting this property is not a valid DataGridViewAdvancedCellBorderStyle values.
ArgumentException | The specified value when setting this property is DataGridViewAdvancedCellBorderStyle.NotSet.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewAdvancedBorderStyle Class
DataGridViewAdvancedBorderStyle Members


Left Property

[image]
Gizmox.WebGUI.Forms
Left Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewAdvancedBorderStyle Class : Left Property

Gets the style for the left border of a cell.

Syntax

Visual Basic (Declaration)
Public Property Left As DataGridViewAdvancedCellBorderStyle
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewAdvancedBorderStyle
Dim value As DataGridViewAdvancedCellBorderStyle

instance.Left = value

value = instance.Left
C#
public DataGridViewAdvancedCellBorderStyle Left {get; set;}
Managed Extensions for C++
public: __property DataGridViewAdvancedCellBorderStyle get_Left();
public: __property void set_Left(
   DataGridViewAdvancedCellBorderStyle value
);
C++/CLI
public:
property DataGridViewAdvancedCellBorderStyle Left {
   DataGridViewAdvancedCellBorderStyle get();
   void set (DataGridViewAdvancedCellBorderStylevalue);
}

Exceptions

Exception | Description
InvalidEnumArgumentException | The specified value when setting this property is not a valid DataGridViewAdvancedCellBorderStyle.
ArgumentException | The specified value when setting this property is DataGridViewAdvancedCellBorderStyle.NotSet.-or-The specified value when setting this property is DataGridViewAdvancedCellBorderStyle.InsetDouble or DataGridViewAdvancedCellBorderStyle.OutsetDouble and this DataGridViewAdvancedBorderStyle instance has an associated DataGridView control with a Control.RightToLeft property value of true.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewAdvancedBorderStyle Class
DataGridViewAdvancedBorderStyle Members


Right Property

[image]
Gizmox.WebGUI.Forms
Right Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewAdvancedBorderStyle Class : Right Property

Gets the style for the right border of a cell.

Syntax

Visual Basic (Declaration)
Public Property Right As DataGridViewAdvancedCellBorderStyle
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewAdvancedBorderStyle
Dim value As DataGridViewAdvancedCellBorderStyle

instance.Right = value

value = instance.Right
C#
public DataGridViewAdvancedCellBorderStyle Right {get; set;}
Managed Extensions for C++
public: __property DataGridViewAdvancedCellBorderStyle get_Right();
public: __property void set_Right(
   DataGridViewAdvancedCellBorderStyle value
);
C++/CLI
public:
property DataGridViewAdvancedCellBorderStyle Right {
   DataGridViewAdvancedCellBorderStyle get();
   void set (DataGridViewAdvancedCellBorderStylevalue);
}

Exceptions

Exception | Description
InvalidEnumArgumentException | The specified value when setting this property is not a valid DataGridViewAdvancedCellBorderStyle.
ArgumentException | The specified value when setting this property is DataGridViewAdvancedCellBorderStyle.NotSet.-or-The specified value when setting this property is DataGridViewAdvancedCellBorderStyle.InsetDouble or DataGridViewAdvancedCellBorderStyle.OutsetDouble and this DataGridViewAdvancedBorderStyle instance has an associated DataGridView control with a Control.RightToLeft property value of false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewAdvancedBorderStyle Class
DataGridViewAdvancedBorderStyle Members


Top Property

[image]
Gizmox.WebGUI.Forms
Top Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewAdvancedBorderStyle Class : Top Property

Gets the style for the top border of a cell.

Syntax

Visual Basic (Declaration)
Public Property Top As DataGridViewAdvancedCellBorderStyle
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewAdvancedBorderStyle
Dim value As DataGridViewAdvancedCellBorderStyle

instance.Top = value

value = instance.Top
C#
public DataGridViewAdvancedCellBorderStyle Top {get; set;}
Managed Extensions for C++
public: __property DataGridViewAdvancedCellBorderStyle get_Top();
public: __property void set_Top(
   DataGridViewAdvancedCellBorderStyle value
);
C++/CLI
public:
property DataGridViewAdvancedCellBorderStyle Top {
   DataGridViewAdvancedCellBorderStyle get();
   void set (DataGridViewAdvancedCellBorderStylevalue);
}

Exceptions

Exception | Description
InvalidEnumArgumentException | The specified value when setting this property is not a valid DataGridViewAdvancedCellBorderStyle.
ArgumentException | The specified value when setting this property is DataGridViewAdvancedCellBorderStyle.NotSet.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewAdvancedBorderStyle Class
DataGridViewAdvancedBorderStyle Members


DataGridViewAutoSizeColumnModeEventArgs Class

[image]
Gizmox.WebGUI.Forms
DataGridViewAutoSizeColumnModeEventArgs Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewAutoSizeColumnModeEventArgs Class

Provides data for the AutoSizeColumnModeChanged event.

Object Model

Syntax

Visual Basic (Declaration)
Public Class DataGridViewAutoSizeColumnModeEventArgs
   Inherits EventArgs
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewAutoSizeColumnModeEventArgs
C#
public class DataGridViewAutoSizeColumnModeEventArgs : EventArgs
Managed Extensions for C++
public __gc class DataGridViewAutoSizeColumnModeEventArgs : public EventArgs
C++/CLI
public ref class DataGridViewAutoSizeColumnModeEventArgs : public EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gizmox.WebGUI.Forms.DataGridViewAutoSizeColumnModeEventArgs

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

DataGridViewAutoSizeColumnModeEventArgs Members
Gizmox.WebGUI.Forms Namespace


DataGridViewAutoSizeColumnModeEventArgs Class Members

[image]
Gizmox.WebGUI.Forms
DataGridViewAutoSizeColumnModeEventArgs Class Members
See Also Properties Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewAutoSizeColumnModeEventArgs Class

The following tables list the members exposed by DataGridViewAutoSizeColumnModeEventArgs.

Public Constructors

 | Name | Description
Public Constructor | DataGridViewAutoSizeColumnModeEventArgs Constructor | Initializes a new instance of the DataGridViewAutoSizeColumnModeEventArgs class.
Top

Public Properties

 | Name | Description
Public Property | Column | Gets the column with the DataGridViewColumn.AutoSizeMode property that changed.
Public Property | PreviousMode | Gets the previous value of the DataGridViewColumn.AutoSizeMode property of the column.
Top

See Also

Reference

DataGridViewAutoSizeColumnModeEventArgs Class
Gizmox.WebGUI.Forms Namespace


DataGridViewAutoSizeColumnModeEventArgs Constructor

[image]
Gizmox.WebGUI.Forms
DataGridViewAutoSizeColumnModeEventArgs Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewAutoSizeColumnModeEventArgs Class : DataGridViewAutoSizeColumnModeEventArgs Constructor

dataGridViewColumn
The column with the DataGridViewColumn.AutoSizeMode property that changed.
previousMode
The previous DataGridViewAutoSizeColumnMode value of the column's DataGridViewColumn.AutoSizeMode property.
Initializes a new instance of the DataGridViewAutoSizeColumnModeEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal dataGridViewColumn As DataGridViewColumn, _
   ByVal previousMode As DataGridViewAutoSizeColumnMode _
)
Visual Basic (Usage) Copy Code
Dim dataGridViewColumn As DataGridViewColumn
Dim previousMode As DataGridViewAutoSizeColumnMode

Dim instance As DataGridViewAutoSizeColumnModeEventArgs(dataGridViewColumn, previousMode)
C#
public DataGridViewAutoSizeColumnModeEventArgs(
   DataGridViewColumn dataGridViewColumn,
   DataGridViewAutoSizeColumnMode previousMode
)
Managed Extensions for C++
public: DataGridViewAutoSizeColumnModeEventArgs(
   DataGridViewColumn* dataGridViewColumn,
   DataGridViewAutoSizeColumnMode previousMode
)
C++/CLI
public:
DataGridViewAutoSizeColumnModeEventArgs(
   DataGridViewColumn^ dataGridViewColumn,
   DataGridViewAutoSizeColumnMode previousMode
)

Parameters

dataGridViewColumn
The column with the DataGridViewColumn.AutoSizeMode property that changed.
previousMode
The previous DataGridViewAutoSizeColumnMode value of the column's DataGridViewColumn.AutoSizeMode property.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewAutoSizeColumnModeEventArgs Class
DataGridViewAutoSizeColumnModeEventArgs Members


DataGridViewAutoSizeColumnModeEventArgs Class Properties

[image]
Gizmox.WebGUI.Forms
DataGridViewAutoSizeColumnModeEventArgs Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewAutoSizeColumnModeEventArgs Class

For a list of all members of this type, see DataGridViewAutoSizeColumnModeEventArgs members.

Public Properties

 | Name | Description
Public Property | Column | Gets the column with the DataGridViewColumn.AutoSizeMode property that changed.
Public Property | PreviousMode | Gets the previous value of the DataGridViewColumn.AutoSizeMode property of the column.
Top

See Also

Reference

DataGridViewAutoSizeColumnModeEventArgs Class
Gizmox.WebGUI.Forms Namespace


Column Property

[image]
Gizmox.WebGUI.Forms
Column Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewAutoSizeColumnModeEventArgs Class : Column Property

Gets the column with the DataGridViewColumn.AutoSizeMode property that changed.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Column As DataGridViewColumn
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewAutoSizeColumnModeEventArgs
Dim value As DataGridViewColumn

value = instance.Column
C#
public DataGridViewColumn Column {get;}
Managed Extensions for C++
public: __property DataGridViewColumn* get_Column();
C++/CLI
public:
property DataGridViewColumn^ Column {
   DataGridViewColumn^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewAutoSizeColumnModeEventArgs Class
DataGridViewAutoSizeColumnModeEventArgs Members


PreviousMode Property

[image]
Gizmox.WebGUI.Forms
PreviousMode Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewAutoSizeColumnModeEventArgs Class : PreviousMode Property

Gets the previous value of the DataGridViewColumn.AutoSizeMode property of the column.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PreviousMode As DataGridViewAutoSizeColumnMode
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewAutoSizeColumnModeEventArgs
Dim value As DataGridViewAutoSizeColumnMode

value = instance.PreviousMode
C#
public DataGridViewAutoSizeColumnMode PreviousMode {get;}
Managed Extensions for C++
public: __property DataGridViewAutoSizeColumnMode get_PreviousMode();
C++/CLI
public:
property DataGridViewAutoSizeColumnMode PreviousMode {
   DataGridViewAutoSizeColumnMode get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewAutoSizeColumnModeEventArgs Class
DataGridViewAutoSizeColumnModeEventArgs Members


DataGridViewAutoSizeColumnsModeEventArgs Class

[image]
Gizmox.WebGUI.Forms
DataGridViewAutoSizeColumnsModeEventArgs Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewAutoSizeColumnsModeEventArgs Class

Provides data for the AutoSizeColumnsModeChanged event.

Syntax

Visual Basic (Declaration)
Public Class DataGridViewAutoSizeColumnsModeEventArgs
   Inherits EventArgs
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewAutoSizeColumnsModeEventArgs
C#
public class DataGridViewAutoSizeColumnsModeEventArgs : EventArgs
Managed Extensions for C++
public __gc class DataGridViewAutoSizeColumnsModeEventArgs : public EventArgs
C++/CLI
public ref class DataGridViewAutoSizeColumnsModeEventArgs : public EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gizmox.WebGUI.Forms.DataGridViewAutoSizeColumnsModeEventArgs

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

DataGridViewAutoSizeColumnsModeEventArgs Members
Gizmox.WebGUI.Forms Namespace


DataGridViewAutoSizeColumnsModeEventArgs Class Members

[image]
Gizmox.WebGUI.Forms
DataGridViewAutoSizeColumnsModeEventArgs Class Members
See Also Properties Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewAutoSizeColumnsModeEventArgs Class

The following tables list the members exposed by DataGridViewAutoSizeColumnsModeEventArgs.

Public Constructors

 | Name | Description
Public Constructor | DataGridViewAutoSizeColumnsModeEventArgs Constructor | Initializes a new instance of the DataGridViewAutoSizeColumnsModeEventArgs class.
Top

Public Properties

 | Name | Description
Public Property | PreviousModes | Gets an array of the previous values of the column DataGridViewColumn.AutoSizeMode properties.
Top

See Also

Reference

DataGridViewAutoSizeColumnsModeEventArgs Class
Gizmox.WebGUI.Forms Namespace


DataGridViewAutoSizeColumnsModeEventArgs Constructor

[image]
Gizmox.WebGUI.Forms
DataGridViewAutoSizeColumnsModeEventArgs Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewAutoSizeColumnsModeEventArgs Class : DataGridViewAutoSizeColumnsModeEventArgs Constructor

previousModes
An array of DataGridViewAutoSizeColumnMode values representing the previous DataGridViewColumn.AutoSizeMode property values of each column.
Initializes a new instance of the DataGridViewAutoSizeColumnsModeEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal previousModes() As DataGridViewAutoSizeColumnMode _
)
Visual Basic (Usage) Copy Code
Dim previousModes() As DataGridViewAutoSizeColumnMode

Dim instance As DataGridViewAutoSizeColumnsModeEventArgs(previousModes)
C#
public DataGridViewAutoSizeColumnsModeEventArgs(
   DataGridViewAutoSizeColumnMode[] previousModes
)
Managed Extensions for C++
public: DataGridViewAutoSizeColumnsModeEventArgs(
   DataGridViewAutoSizeColumnMode[]* previousModes
)
C++/CLI
public:
DataGridViewAutoSizeColumnsModeEventArgs(
   array<DataGridViewAutoSizeColumnMode>^ previousModes
)

Parameters

previousModes
An array of DataGridViewAutoSizeColumnMode values representing the previous DataGridViewColumn.AutoSizeMode property values of each column.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewAutoSizeColumnsModeEventArgs Class
DataGridViewAutoSizeColumnsModeEventArgs Members


DataGridViewAutoSizeColumnsModeEventArgs Class Properties

[image]
Gizmox.WebGUI.Forms
DataGridViewAutoSizeColumnsModeEventArgs Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewAutoSizeColumnsModeEventArgs Class

For a list of all members of this type, see DataGridViewAutoSizeColumnsModeEventArgs members.

Public Properties

 | Name | Description
Public Property | PreviousModes | Gets an array of the previous values of the column DataGridViewColumn.AutoSizeMode properties.
Top

See Also

Reference

DataGridViewAutoSizeColumnsModeEventArgs Class
Gizmox.WebGUI.Forms Namespace


PreviousModes Property

[image]
Gizmox.WebGUI.Forms
PreviousModes Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewAutoSizeColumnsModeEventArgs Class : PreviousModes Property

Gets an array of the previous values of the column DataGridViewColumn.AutoSizeMode properties.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PreviousModes As DataGridViewAutoSizeColumnMode()
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewAutoSizeColumnsModeEventArgs
Dim value() As DataGridViewAutoSizeColumnMode

value = instance.PreviousModes
C#
public DataGridViewAutoSizeColumnMode[] PreviousModes {get;}
Managed Extensions for C++
public: __property DataGridViewAutoSizeColumnMode[]* get_PreviousModes();
C++/CLI
public:
property array<DataGridViewAutoSizeColumnMode>^ PreviousModes {
   array<DataGridViewAutoSizeColumnMode>^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewAutoSizeColumnsModeEventArgs Class
DataGridViewAutoSizeColumnsModeEventArgs Members


DataGridViewAutoSizeModeEventArgs Class

[image]
Gizmox.WebGUI.Forms
DataGridViewAutoSizeModeEventArgs Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewAutoSizeModeEventArgs Class

Provides data for the DataGridView AutoSizeRowsModeChanged and RowHeadersWidthSizeModeChanged events.

Syntax

Visual Basic (Declaration)
Public Class DataGridViewAutoSizeModeEventArgs
   Inherits EventArgs
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewAutoSizeModeEventArgs
C#
public class DataGridViewAutoSizeModeEventArgs : EventArgs
Managed Extensions for C++
public __gc class DataGridViewAutoSizeModeEventArgs : public EventArgs
C++/CLI
public ref class DataGridViewAutoSizeModeEventArgs : public EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gizmox.WebGUI.Forms.DataGridViewAutoSizeModeEventArgs

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

DataGridViewAutoSizeModeEventArgs Members
Gizmox.WebGUI.Forms Namespace


DataGridViewAutoSizeModeEventArgs Class Members

[image]
Gizmox.WebGUI.Forms
DataGridViewAutoSizeModeEventArgs Class Members
See Also Properties Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewAutoSizeModeEventArgs Class

The following tables list the members exposed by DataGridViewAutoSizeModeEventArgs.

Public Constructors

 | Name | Description
Public Constructor | DataGridViewAutoSizeModeEventArgs Constructor | Initializes a new instance of the DataGridViewAutoSizeModeEventArgs class.
Top

Public Properties

 | Name | Description
Public Property | PreviousModeAutoSized | Gets a value specifying whether the DataGridView was previously set to automatically resize.
Top

See Also

Reference

DataGridViewAutoSizeModeEventArgs Class
Gizmox.WebGUI.Forms Namespace


DataGridViewAutoSizeModeEventArgs Constructor

[image]
Gizmox.WebGUI.Forms
DataGridViewAutoSizeModeEventArgs Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewAutoSizeModeEventArgs Class : DataGridViewAutoSizeModeEventArgs Constructor

previousModeAutoSized
true if the AutoSizeRowsMode property was previously set to any DataGridViewAutoSizeRowsMode value other than DataGridViewAutoSizeRowsMode.None or the RowHeadersWidthSizeMode property was previously set to any DataGridViewRowHeadersWidthSizeMode value other than DataGridViewRowHeadersWidthSizeMode.DisableResizing or DataGridViewRowHeadersWidthSizeMode.EnableResizing; otherwise, false.
Initializes a new instance of the DataGridViewAutoSizeModeEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal previousModeAutoSized As Boolean _
)
Visual Basic (Usage) Copy Code
Dim previousModeAutoSized As Boolean

Dim instance As DataGridViewAutoSizeModeEventArgs(previousModeAutoSized)
C#
public DataGridViewAutoSizeModeEventArgs(
   bool previousModeAutoSized
)
Managed Extensions for C++
public: DataGridViewAutoSizeModeEventArgs(
   bool previousModeAutoSized
)
C++/CLI
public:
DataGridViewAutoSizeModeEventArgs(
   bool previousModeAutoSized
)

Parameters

previousModeAutoSized
true if the AutoSizeRowsMode property was previously set to any DataGridViewAutoSizeRowsMode value other than DataGridViewAutoSizeRowsMode.None or the RowHeadersWidthSizeMode property was previously set to any DataGridViewRowHeadersWidthSizeMode value other than DataGridViewRowHeadersWidthSizeMode.DisableResizing or DataGridViewRowHeadersWidthSizeMode.EnableResizing; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewAutoSizeModeEventArgs Class
DataGridViewAutoSizeModeEventArgs Members


DataGridViewAutoSizeModeEventArgs Class Properties

[image]
Gizmox.WebGUI.Forms
DataGridViewAutoSizeModeEventArgs Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewAutoSizeModeEventArgs Class

For a list of all members of this type, see DataGridViewAutoSizeModeEventArgs members.

Public Properties

 | Name | Description
Public Property | PreviousModeAutoSized | Gets a value specifying whether the DataGridView was previously set to automatically resize.
Top

See Also

Reference

DataGridViewAutoSizeModeEventArgs Class
Gizmox.WebGUI.Forms Namespace


PreviousModeAutoSized Property

[image]
Gizmox.WebGUI.Forms
PreviousModeAutoSized Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewAutoSizeModeEventArgs Class : PreviousModeAutoSized Property

Gets a value specifying whether the DataGridView was previously set to automatically resize.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PreviousModeAutoSized As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewAutoSizeModeEventArgs
Dim value As Boolean

value = instance.PreviousModeAutoSized
C#
public bool PreviousModeAutoSized {get;}
Managed Extensions for C++
public: __property bool get_PreviousModeAutoSized();
C++/CLI
public:
property bool PreviousModeAutoSized {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewAutoSizeModeEventArgs Class
DataGridViewAutoSizeModeEventArgs Members


DataGridViewBand Class

[image]
Gizmox.WebGUI.Forms
DataGridViewBand Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewBand Class

Represents a linear collection of elements in a DataGridView control.

Object Model

Syntax

Visual Basic (Declaration)
Public Class DataGridViewBand
   Inherits DataGridViewElement
   Implements IRenderableComponentMember
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewBand
C#
public class DataGridViewBand : DataGridViewElement, IRenderableComponentMember
Managed Extensions for C++
public __gc class DataGridViewBand : public DataGridViewElement, IRenderableComponentMember
C++/CLI
public ref class DataGridViewBand : public DataGridViewElement, IRenderableComponentMember

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.DataGridViewElement
Gizmox.WebGUI.Forms.DataGridViewBand
Gizmox.WebGUI.Forms.DataGridViewColumn
Gizmox.WebGUI.Forms.DataGridViewRow

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

DataGridViewBand Members
Gizmox.WebGUI.Forms Namespace


DataGridViewBand Class Members

[image]
Gizmox.WebGUI.Forms
DataGridViewBand Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewBand Class

The following tables list the members exposed by DataGridViewBand.

Public Properties

 | Name | Description
Public Property | DataGridView | Gets the DataGridView control associated with this element. (Inherited from DataGridViewElement)
Public Property | DefaultCellStyle | Gets or sets the default cell style of the band.
Public Property | DefaultHeaderCellType | Gets or sets the run-time type of the default header cell.
Public Property | Displayed | Gets a value indicating whether the band is currently displayed onscreen.
Public Property | Frozen | Gets or sets a value indicating whether the band will move when a user scrolls through the DataGridView.
Public Property | HasDefaultCellStyle | Gets a value indicating whether the DataGridViewBand.DefaultCellStyle property has been set.
Public Property | Index | Gets the relative position of the band within the DataGridView control.
Public Property | InheritedStyle | Gets the cell style in effect for the current band, taking into account style inheritance.
Public Property | ReadOnly | Gets or sets a value indicating whether the user can edit the band's cells.
Public Property | Resizable | Gets or sets a value indicating whether the band can be resized in the user interface (UI).
Public Property | Selected | Gets or sets a value indicating whether the band is in a selected user interface (UI) state.
Public Property | State | Gets the user interface (UI) state of the element. (Inherited from DataGridViewElement)
Public Property | Tag | Gets or sets the object that contains data to associate with the band.
Public Property | Visible | Gets or sets a value indicating whether the band is visible to the user.
Top

Protected Properties

 | Name | Description
Protected Property | HeaderCellCore | Gets or sets the header cell of the DataGridViewBand.
Protected Property | IsRow | Gets a value indicating whether the band represents a row.
Protected Property | MemberID | (Inherited from DataGridViewElement)
Protected Property | TagName | (Inherited from DataGridViewElement)
Top

Public Methods

 | Name | Description
Public Method | Clone | Creates an exact copy of this band.
Public Method | Dispose | Overloaded. Releases all resources used by the DataGridViewBand.
Public Method | ToString | Overridden. Returns a string that represents the current band.
Public Method | Update | Overloaded. Full updates of this instance. (Inherited from DataGridViewElement)
Top

Protected Methods

 | Name | Description
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from DataGridViewElement)
Protected Method | IsDirty | Determines whether the specified component is dirty. (Inherited from DataGridViewElement)
Protected Method | IsDirtyAttributes | Overloaded. Determines whether the specified component is dirty. (Inherited from DataGridViewElement)
Protected Method | OnDataGridViewChanged | Overridden. Called when the band is associated with a different DataGridView.
Protected Method | RaiseCellClick | Raises the DataGridView.CellClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellContentClick | Raises the DataGridView.CellContentClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellContentDoubleClick | Raises the DataGridView.CellContentDoubleClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellValueChanged | Raises the CellValueChanged event. (Inherited from DataGridViewElement)
Protected Method | RaiseDataError | Raises the DataError event. (Inherited from DataGridViewElement)
Protected Method | RaiseMouseWheel | Raises the MouseWheel event. (Inherited from DataGridViewElement)
Protected Method | RenderAttributes | Overridden. Renders the band attributes
Protected Method | RenderComponent | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from DataGridViewElement)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from DataGridViewElement)
Protected Method | RenderComponents | Renders the controls sub tree (Inherited from DataGridViewElement)
Protected Method | RenderUpdatedAttributes | Renders the updated attributes (Inherited from DataGridViewElement)
Protected Method | UpdateParams | Overloaded. Updates only the parameters of this instance. (Inherited from DataGridViewElement)
Top

See Also

Reference

DataGridViewBand Class
Gizmox.WebGUI.Forms Namespace


DataGridViewBand Class Methods

[image]
Gizmox.WebGUI.Forms
DataGridViewBand Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewBand Class

For a list of all members of this type, see DataGridViewBand members.

Public Methods

 | Name | Description
Public Method | Clone | Creates an exact copy of this band.
Public Method | Dispose | Overloaded. Releases all resources used by the DataGridViewBand.
Public Method | ToString | Overridden. Returns a string that represents the current band.
Public Method | Update | Overloaded. Full updates of this instance. (Inherited from DataGridViewElement)
Top

Protected Methods

 | Name | Description
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from DataGridViewElement)
Protected Method | IsDirty | Determines whether the specified component is dirty. (Inherited from DataGridViewElement)
Protected Method | IsDirtyAttributes | Overloaded. Determines whether the specified component is dirty. (Inherited from DataGridViewElement)
Protected Method | OnDataGridViewChanged | Overridden. Called when the band is associated with a different DataGridView.
Protected Method | RaiseCellClick | Raises the DataGridView.CellClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellContentClick | Raises the DataGridView.CellContentClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellContentDoubleClick | Raises the DataGridView.CellContentDoubleClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellValueChanged | Raises the CellValueChanged event. (Inherited from DataGridViewElement)
Protected Method | RaiseDataError | Raises the DataError event. (Inherited from DataGridViewElement)
Protected Method | RaiseMouseWheel | Raises the MouseWheel event. (Inherited from DataGridViewElement)
Protected Method | RenderAttributes | Overridden. Renders the band attributes
Protected Method | RenderComponent | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from DataGridViewElement)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from DataGridViewElement)
Protected Method | RenderComponents | Renders the controls sub tree (Inherited from DataGridViewElement)
Protected Method | RenderUpdatedAttributes | Renders the updated attributes (Inherited from DataGridViewElement)
Protected Method | UpdateParams | Overloaded. Updates only the parameters of this instance. (Inherited from DataGridViewElement)
Top

See Also

Reference

DataGridViewBand Class
Gizmox.WebGUI.Forms Namespace


Clone Method

[image]
Gizmox.WebGUI.Forms
Clone Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewBand Class : Clone Method

Creates an exact copy of this band.

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewBand
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()
Managed Extensions for C++
public: virtual Object* Clone();
C++/CLI
public:
virtual Object^ Clone();

Return Value

An Object that represents the cloned DataGridViewBand.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewBand Class
DataGridViewBand Members


Dispose Method

[image]
Gizmox.WebGUI.Forms
Dispose Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewBand Class : Dispose Method

Releases all resources used by the DataGridViewBand.

Overload List

Overload | Description
Dispose() | Releases all resources used by the DataGridViewBand.
Dispose(Boolean) | Releases the unmanaged resources used by the DataGridViewBand and optionally releases the managed resources.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewBand Class
DataGridViewBand Members


Dispose() Method

[image]
Gizmox.WebGUI.Forms
Dispose() Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewBand Class > Dispose Method : Dispose() Method

Releases all resources used by the DataGridViewBand.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewBand

instance.Dispose()
C#
public void Dispose()
Managed Extensions for C++
public: void Dispose();
C++/CLI
public:
void Dispose();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewBand Class
DataGridViewBand Members
Overload List


Dispose(Boolean) Method

[image]
Gizmox.WebGUI.Forms
Dispose(Boolean) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewBand Class > Dispose Method : Dispose(Boolean) Method

disposing
true to release both managed and unmanaged resources; false to release only unmanaged resources.
Releases the unmanaged resources used by the DataGridViewBand and optionally releases the managed resources.

Syntax

Visual Basic (Declaration)
Protected Overloads Overridable Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewBand
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected virtual void Dispose(
   bool disposing
)
Managed Extensions for C++
protected: virtual void Dispose(
   bool disposing
)
C++/CLI
protected:
virtual void Dispose(
   bool disposing
)

Parameters

disposing
true to release both managed and unmanaged resources; false to release only unmanaged resources.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewBand Class
DataGridViewBand Members
Overload List


OnDataGridViewChanged Method

[image]
Gizmox.WebGUI.Forms
OnDataGridViewChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewBand Class : OnDataGridViewChanged Method

Called when the band is associated with a different DataGridView.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnDataGridViewChanged()
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewBand

instance.OnDataGridViewChanged()
C#
protected override void OnDataGridViewChanged()
Managed Extensions for C++
protected: void OnDataGridViewChanged(); override
C++/CLI
protected:
void OnDataGridViewChanged(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewBand Class
DataGridViewBand Members


RenderAttributes Method

[image]
Gizmox.WebGUI.Forms
RenderAttributes Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewBand Class : RenderAttributes Method

objContext
objWriter
blnRenderOwner
Renders the band attributes

Syntax

Visual Basic (Declaration)
Protected Overrides Sub RenderAttributes( _
   ByVal objContext As IContext, _
   ByVal objWriter As IAttributeWriter, _
   ByVal blnRenderOwner As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewBand
Dim objContext As IContext
Dim objWriter As IAttributeWriter
Dim blnRenderOwner As Boolean

instance.RenderAttributes(objContext, objWriter, blnRenderOwner)
C#
protected override void RenderAttributes(
   IContext objContext,
   IAttributeWriter objWriter,
   bool blnRenderOwner
)
Managed Extensions for C++
protected: void RenderAttributes(
   IContext* objContext,
   IAttributeWriter* objWriter,
   bool blnRenderOwner
) override
C++/CLI
protected:
void RenderAttributes(
   IContext^ objContext,
   IAttributeWriter^ objWriter,
   bool blnRenderOwner
) override

Parameters

objContext
objWriter
blnRenderOwner

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewBand Class
DataGridViewBand Members


ToString Method

[image]
Gizmox.WebGUI.Forms
ToString Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewBand Class : ToString Method

Returns a string that represents the current band.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewBand
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Return Value

A String that represents the current DataGridViewBand.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewBand Class
DataGridViewBand Members


DataGridViewBand Class Properties

[image]
Gizmox.WebGUI.Forms
DataGridViewBand Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewBand Class

For a list of all members of this type, see DataGridViewBand members.

Public Properties

 | Name | Description
Public Property | DataGridView | Gets the DataGridView control associated with this element. (Inherited from DataGridViewElement)
Public Property | DefaultCellStyle | Gets or sets the default cell style of the band.
Public Property | DefaultHeaderCellType | Gets or sets the run-time type of the default header cell.
Public Property | Displayed | Gets a value indicating whether the band is currently displayed onscreen.
Public Property | Frozen | Gets or sets a value indicating whether the band will move when a user scrolls through the DataGridView.
Public Property | HasDefaultCellStyle | Gets a value indicating whether the DataGridViewBand.DefaultCellStyle property has been set.
Public Property | Index | Gets the relative position of the band within the DataGridView control.
Public Property | InheritedStyle | Gets the cell style in effect for the current band, taking into account style inheritance.
Public Property | ReadOnly | Gets or sets a value indicating whether the user can edit the band's cells.
Public Property | Resizable | Gets or sets a value indicating whether the band can be resized in the user interface (UI).
Public Property | Selected | Gets or sets a value indicating whether the band is in a selected user interface (UI) state.
Public Property | State | Gets the user interface (UI) state of the element. (Inherited from DataGridViewElement)
Public Property | Tag | Gets or sets the object that contains data to associate with the band.
Public Property | Visible | Gets or sets a value indicating whether the band is visible to the user.
Top

Protected Properties

 | Name | Description
Protected Property | HeaderCellCore | Gets or sets the header cell of the DataGridViewBand.
Protected Property | IsRow | Gets a value indicating whether the band represents a row.
Protected Property | MemberID | (Inherited from DataGridViewElement)
Protected Property | TagName | (Inherited from DataGridViewElement)
Top

See Also

Reference

DataGridViewBand Class
Gizmox.WebGUI.Forms Namespace


DefaultCellStyle Property

[image]
Gizmox.WebGUI.Forms
DefaultCellStyle Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewBand Class : DefaultCellStyle Property

Gets or sets the default cell style of the band.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public Overridable Property DefaultCellStyle As DataGridViewCellStyle
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewBand
Dim value As DataGridViewCellStyle

instance.DefaultCellStyle = value

value = instance.DefaultCellStyle
C#
[BrowsableAttribute(false)]
public virtual DataGridViewCellStyle DefaultCellStyle {get; set;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property virtual DataGridViewCellStyle* get_DefaultCellStyle();
public: __property virtual void set_DefaultCellStyle(
   DataGridViewCellStyle* value
);
C++/CLI
[BrowsableAttribute(false)]
public:
virtual property DataGridViewCellStyle^ DefaultCellStyle {
   DataGridViewCellStyle^ get();
   void set (DataGridViewCellStyle^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewBand Class
DataGridViewBand Members


DefaultHeaderCellType Property

[image]
Gizmox.WebGUI.Forms
DefaultHeaderCellType Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewBand Class : DefaultHeaderCellType Property

Gets or sets the run-time type of the default header cell.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<BrowsableAttribute(False)>
Public Property DefaultHeaderCellType As Type
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewBand
Dim value As Type

instance.DefaultHeaderCellType = value

value = instance.DefaultHeaderCellType
C#
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
public Type DefaultHeaderCellType {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
public: __property Type* get_DefaultHeaderCellType();
public: __property void set_DefaultHeaderCellType(
   Type* value
);
C++/CLI
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
public:
property Type^ DefaultHeaderCellType {
   Type^ get();
   void set (Type^value);
}

Exceptions

Exception | Description
ArgumentException | The specified value when setting this property is not a Type representing DataGridViewHeaderCell or a derived type.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewBand Class
DataGridViewBand Members


Displayed Property

[image]
Gizmox.WebGUI.Forms
Displayed Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewBand Class : Displayed Property

Gets a value indicating whether the band is currently displayed onscreen.

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
Public Overridable ReadOnly Property Displayed As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewBand
Dim value As Boolean

value = instance.Displayed
C#
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public virtual bool Displayed {get;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public: __property virtual bool get_Displayed();
C++/CLI
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public:
virtual property bool Displayed {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewBand Class
DataGridViewBand Members


Frozen Property

[image]
Gizmox.WebGUI.Forms
Frozen Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewBand Class : Frozen Property

Gets or sets a value indicating whether the band will move when a user scrolls through the DataGridView.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Overridable Property Frozen As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewBand
Dim value As Boolean

instance.Frozen = value

value = instance.Frozen
C#
[DefaultValueAttribute()]
public virtual bool Frozen {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property virtual bool get_Frozen();
public: __property virtual void set_Frozen(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
public:
virtual property bool Frozen {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewBand Class
DataGridViewBand Members


HasDefaultCellStyle Property

[image]
Gizmox.WebGUI.Forms
HasDefaultCellStyle Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewBand Class : HasDefaultCellStyle Property

Gets a value indicating whether the DataGridViewBand.DefaultCellStyle property has been set.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property HasDefaultCellStyle As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewBand
Dim value As Boolean

value = instance.HasDefaultCellStyle
C#
[BrowsableAttribute(false)]
public bool HasDefaultCellStyle {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property bool get_HasDefaultCellStyle();
C++/CLI
[BrowsableAttribute(false)]
public:
property bool HasDefaultCellStyle {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewBand Class
DataGridViewBand Members


HeaderCellCore Property

[image]
Gizmox.WebGUI.Forms
HeaderCellCore Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewBand Class : HeaderCellCore Property

Gets or sets the header cell of the DataGridViewBand.

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
Protected Property HeaderCellCore As DataGridViewHeaderCell
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewBand
Dim value As DataGridViewHeaderCell

instance.HeaderCellCore = value

value = instance.HeaderCellCore
C#
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
protected DataGridViewHeaderCell HeaderCellCore {get; set;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
protected: __property DataGridViewHeaderCell* get_HeaderCellCore();
protected: __property void set_HeaderCellCore(
   DataGridViewHeaderCell* value
);
C++/CLI
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
protected:
property DataGridViewHeaderCell^ HeaderCellCore {
   DataGridViewHeaderCell^ get();
   void set (DataGridViewHeaderCell^value);
}

Exceptions

Exception | Description
ArgumentException | The specified value when setting this property is not a DataGridViewRowHeaderCell and this DataGridViewBand instance is of type DataGridViewRow.-or-The specified value when setting this property is not a DataGridViewColumnHeaderCell and this DataGridViewBand instance is of type DataGridViewColumn.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewBand Class
DataGridViewBand Members


Index Property

[image]
Gizmox.WebGUI.Forms
Index Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewBand Class : Index Property

Gets the relative position of the band within the DataGridView control.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property Index As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewBand
Dim value As Integer

value = instance.Index
C#
[BrowsableAttribute(false)]
public int Index {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property int get_Index();
C++/CLI
[BrowsableAttribute(false)]
public:
property int Index {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewBand Class
DataGridViewBand Members


InheritedStyle Property

[image]
Gizmox.WebGUI.Forms
InheritedStyle Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewBand Class : InheritedStyle Property

Gets the cell style in effect for the current band, taking into account style inheritance.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public Overridable ReadOnly Property InheritedStyle As DataGridViewCellStyle
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewBand
Dim value As DataGridViewCellStyle

value = instance.InheritedStyle
C#
[BrowsableAttribute(false)]
public virtual DataGridViewCellStyle InheritedStyle {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property virtual DataGridViewCellStyle* get_InheritedStyle();
C++/CLI
[BrowsableAttribute(false)]
public:
virtual property DataGridViewCellStyle^ InheritedStyle {
   DataGridViewCellStyle^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewBand Class
DataGridViewBand Members


IsRow Property

[image]
Gizmox.WebGUI.Forms
IsRow Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewBand Class : IsRow Property

Gets a value indicating whether the band represents a row.

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property IsRow As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewBand
Dim value As Boolean

value = instance.IsRow
C#
protected bool IsRow {get;}
Managed Extensions for C++
protected: __property bool get_IsRow();
C++/CLI
protected:
property bool IsRow {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewBand Class
DataGridViewBand Members


ReadOnly Property

[image]
Gizmox.WebGUI.Forms
ReadOnly Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewBand Class : ReadOnly Property

Gets or sets a value indicating whether the user can edit the band's cells.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Overridable Property ReadOnly As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewBand
Dim value As Boolean

instance.ReadOnly = value

value = instance.ReadOnly
C#
[DefaultValueAttribute()]
public virtual bool ReadOnly {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property virtual bool get_ReadOnly();
public: __property virtual void set_ReadOnly(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
public:
virtual property bool ReadOnly {
   bool get();
   void set (boolvalue);
}

Exceptions

Exception | Description
InvalidOperationException | When setting this property, this DataGridViewBand instance is a shared DataGridViewRow.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewBand Class
DataGridViewBand Members


Resizable Property

[image]
Gizmox.WebGUI.Forms
Resizable Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewBand Class : Resizable Property

Gets or sets a value indicating whether the band can be resized in the user interface (UI).

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(True)>
Public Overridable Property Resizable As DataGridViewTriState
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewBand
Dim value As DataGridViewTriState

instance.Resizable = value

value = instance.Resizable
C#
[BrowsableAttribute(true)]
public virtual DataGridViewTriState Resizable {get; set;}
Managed Extensions for C++
[BrowsableAttribute(true)]
public: __property virtual DataGridViewTriState get_Resizable();
public: __property virtual void set_Resizable(
   DataGridViewTriState value
);
C++/CLI
[BrowsableAttribute(true)]
public:
virtual property DataGridViewTriState Resizable {
   DataGridViewTriState get();
   void set (DataGridViewTriStatevalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewBand Class
DataGridViewBand Members


Selected Property

[image]
Gizmox.WebGUI.Forms
Selected Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewBand Class : Selected Property

Gets or sets a value indicating whether the band is in a selected user interface (UI) state.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public Overridable Property Selected As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewBand
Dim value As Boolean

instance.Selected = value

value = instance.Selected
C#
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public virtual bool Selected {get; set;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property virtual bool get_Selected();
public: __property virtual void set_Selected(
   bool value
);
C++/CLI
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
virtual property bool Selected {
   bool get();
   void set (boolvalue);
}

Exceptions

Exception | Description
InvalidOperationException | The specified value when setting this property is true, but the band has not been added to a DataGridView control. -or-This property is being set on a shared DataGridViewRow.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewBand Class
DataGridViewBand Members


Tag Property

[image]
Gizmox.WebGUI.Forms
Tag Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewBand Class : Tag Property

Gets or sets the object that contains data to associate with the band.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public Property Tag As Object
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewBand
Dim value As Object

instance.Tag = value

value = instance.Tag
C#
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public object Tag {get; set;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property Object* get_Tag();
public: __property void set_Tag(
   Object* value
);
C++/CLI
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
property Object^ Tag {
   Object^ get();
   void set (Object^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewBand Class
DataGridViewBand Members


Visible Property

[image]
Gizmox.WebGUI.Forms
Visible Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewBand Class : Visible Property

Gets or sets a value indicating whether the band is visible to the user.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Overridable Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewBand
Dim value As Boolean

instance.Visible = value

value = instance.Visible
C#
[DefaultValueAttribute()]
public virtual bool Visible {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property virtual bool get_Visible();
public: __property virtual void set_Visible(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
public:
virtual property bool Visible {
   bool get();
   void set (boolvalue);
}

Exceptions

Exception | Description
InvalidOperationException | The specified value when setting this property is false and the band is the row for new records.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewBand Class
DataGridViewBand Members


DataGridViewBindingCompleteEventArgs Class

[image]
Gizmox.WebGUI.Forms
DataGridViewBindingCompleteEventArgs Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewBindingCompleteEventArgs Class

Provides data for the DataBindingComplete event.

Syntax

Visual Basic (Declaration)
Public Class DataGridViewBindingCompleteEventArgs
   Inherits EventArgs
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewBindingCompleteEventArgs
C#
public class DataGridViewBindingCompleteEventArgs : EventArgs
Managed Extensions for C++
public __gc class DataGridViewBindingCompleteEventArgs : public EventArgs
C++/CLI
public ref class DataGridViewBindingCompleteEventArgs : public EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gizmox.WebGUI.Forms.DataGridViewBindingCompleteEventArgs

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

DataGridViewBindingCompleteEventArgs Members
Gizmox.WebGUI.Forms Namespace


DataGridViewBindingCompleteEventArgs Class Members

[image]
Gizmox.WebGUI.Forms
DataGridViewBindingCompleteEventArgs Class Members
See Also Properties Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewBindingCompleteEventArgs Class

The following tables list the members exposed by DataGridViewBindingCompleteEventArgs.

Public Constructors

 | Name | Description
Public Constructor | DataGridViewBindingCompleteEventArgs Constructor | Initializes a new instance of the DataGridViewBindingCompleteEventArgs class.
Top

Public Properties

 | Name | Description
Public Property | ListChangedType | Gets a value specifying how the list changed.
Top

See Also

Reference

DataGridViewBindingCompleteEventArgs Class
Gizmox.WebGUI.Forms Namespace


DataGridViewBindingCompleteEventArgs Constructor

[image]
Gizmox.WebGUI.Forms
DataGridViewBindingCompleteEventArgs Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewBindingCompleteEventArgs Class : DataGridViewBindingCompleteEventArgs Constructor

listChangedType
One of the ListChangedType values.
Initializes a new instance of the DataGridViewBindingCompleteEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal listChangedType As ListChangedType _
)
Visual Basic (Usage) Copy Code
Dim listChangedType As ListChangedType

Dim instance As DataGridViewBindingCompleteEventArgs(listChangedType)
C#
public DataGridViewBindingCompleteEventArgs(
   ListChangedType listChangedType
)
Managed Extensions for C++
public: DataGridViewBindingCompleteEventArgs(
   ListChangedType listChangedType
)
C++/CLI
public:
DataGridViewBindingCompleteEventArgs(
   ListChangedType listChangedType
)

Parameters

listChangedType
One of the ListChangedType values.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewBindingCompleteEventArgs Class
DataGridViewBindingCompleteEventArgs Members


DataGridViewBindingCompleteEventArgs Class Properties

[image]
Gizmox.WebGUI.Forms
DataGridViewBindingCompleteEventArgs Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewBindingCompleteEventArgs Class

For a list of all members of this type, see DataGridViewBindingCompleteEventArgs members.

Public Properties

 | Name | Description
Public Property | ListChangedType | Gets a value specifying how the list changed.
Top

See Also

Reference

DataGridViewBindingCompleteEventArgs Class
Gizmox.WebGUI.Forms Namespace


ListChangedType Property

[image]
Gizmox.WebGUI.Forms
ListChangedType Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewBindingCompleteEventArgs Class : ListChangedType Property

Gets a value specifying how the list changed.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ListChangedType As ListChangedType
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewBindingCompleteEventArgs
Dim value As ListChangedType

value = instance.ListChangedType
C#
public ListChangedType ListChangedType {get;}
Managed Extensions for C++
public: __property ListChangedType get_ListChangedType();
C++/CLI
public:
property ListChangedType ListChangedType {
   ListChangedType get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewBindingCompleteEventArgs Class
DataGridViewBindingCompleteEventArgs Members


DataGridViewButtonCell Class

[image]
Gizmox.WebGUI.Forms
DataGridViewButtonCell Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewButtonCell Class

Displays a button-like user interface (UI) for use in a DataGridView control.

Object Model

Syntax

Visual Basic (Declaration)
Public Class DataGridViewButtonCell
   Inherits DataGridViewCell
   Implements IRenderableComponentMember
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewButtonCell
C#
public class DataGridViewButtonCell : DataGridViewCell, IRenderableComponentMember
Managed Extensions for C++
public __gc class DataGridViewButtonCell : public DataGridViewCell, IRenderableComponentMember
C++/CLI
public ref class DataGridViewButtonCell : public DataGridViewCell, IRenderableComponentMember

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.DataGridViewElement
Gizmox.WebGUI.Forms.DataGridViewCell
Gizmox.WebGUI.Forms.DataGridViewButtonCell

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

DataGridViewButtonCell Members
Gizmox.WebGUI.Forms Namespace


DataGridViewButtonCell Class Members

[image]
Gizmox.WebGUI.Forms
DataGridViewButtonCell Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewButtonCell Class

The following tables list the members exposed by DataGridViewButtonCell.

Public Constructors

 | Name | Description
Public Constructor | DataGridViewButtonCell Constructor |
Top

Public Properties

 | Name | Description
Public Property | ColumnIndex | Gets the column index for this cell. (Inherited from DataGridViewCell)
Public Property | ContentBounds | (Inherited from DataGridViewCell)
Public Property | DataGridView | Gets the DataGridView control associated with this element. (Inherited from DataGridViewElement)
Public Property | DefaultNewRowValue | Gets the default value for a cell in the row for new records. (Inherited from DataGridViewCell)
Public Property | Displayed | Gets a value that indicates whether the cell is currently displayed on-screen. (Inherited from DataGridViewCell)
Public Property | EditedFormattedValue | Gets the current, formatted value of the cell, regardless of whether the cell is in edit mode and the value has not been committed. (Inherited from DataGridViewCell)
Public Property | EditType | Overridden. Gets the type of the cell's hosted editing control.
Public Property | ErrorIconBounds | (Inherited from DataGridViewCell)
Public Property | ErrorText | Gets or sets the text describing an error condition associated with the cell. (Inherited from DataGridViewCell)
Public Property | FlatStyle | Gets or sets the style determining the button's appearance.
Public Property | FormattedValue | Gets the value of the cell as formatted for display. (Inherited from DataGridViewCell)
Public Property | FormattedValueType | Overridden.
Public Property | Frozen | Gets a value indicating whether the cell is frozen. (Inherited from DataGridViewCell)
Public Property | HasStyle | Gets a value indicating whether the DataGridViewCell.Style property has been set. (Inherited from DataGridViewCell)
Public Property | InheritedState | Gets the current state of the cell as inherited from the state of its row and column. (Inherited from DataGridViewCell)
Public Property | InheritedStyle | Gets the style currently applied to the cell. (Inherited from DataGridViewCell)
Public Property | IsInEditMode | Gets a value indicating whether this cell is currently being edited. (Inherited from DataGridViewCell)
Public Property | OwningColumn | Gets the column that contains this cell. (Inherited from DataGridViewCell)
Public Property | OwningRow | Gets the row that contains this cell. (Inherited from DataGridViewCell)
Public Property | PreferredSize | Gets the size, in pixels, of a rectangular area into which the cell can fit. (Inherited from DataGridViewCell)
Public Property | ReadOnly | Gets or sets a value indicating whether the cell's data can be edited. (Inherited from DataGridViewCell)
Public Property | Resizable | Gets a value indicating whether the cell can be resized. (Inherited from DataGridViewCell)
Public Property | RowIndex | Gets the index of the cell's parent row. (Inherited from DataGridViewCell)
Public Property | Selected | Gets or sets a value indicating whether the cell has been selected. (Inherited from DataGridViewCell)
Public Property | Size | Gets the size of the cell. (Inherited from DataGridViewCell)
Public Property | State | Gets the user interface (UI) state of the element. (Inherited from DataGridViewElement)
Public Property | Style | Gets or sets the style for the cell. (Inherited from DataGridViewCell)
Public Property | Tag | Gets or sets the object that contains supplemental data about the cell. (Inherited from DataGridViewCell)
Public Property | ToolTipText | Gets or sets the ToolTip text associated with this cell. (Inherited from DataGridViewCell)
Public Property | UseColumnTextForButtonValue | Gets or sets a value indicating whether the owning column's text will appear on the button displayed by the cell.
Public Property | Value | Gets or sets the value associated with this cell. (Inherited from DataGridViewCell)
Public Property | ValueType | Overridden.
Public Property | Visible | Gets a value indicating whether the cell is in a row or column that has been hidden. (Inherited from DataGridViewCell)
Top

Protected Properties

 | Name | Description
Protected Property | MemberID | (Inherited from DataGridViewCell)
Protected Property | TagName | (Inherited from DataGridViewElement)
Top

Public Methods

 | Name | Description
Public Method | AdjustCellBorderStyle | Modifies the input cell border style according to the specified criteria. (Inherited from DataGridViewCell)
Public Method | Clone | Overridden. Creates an exact copy of this cell.
Public Method | DetachEditingControl | Removes the cell's editing control from the DataGridView. (Inherited from DataGridViewCell)
Public Method | Dispose | Overloaded. Releases all resources used by the DataGridViewCell. (Inherited from DataGridViewCell)
Public Method | GetContentBounds | Overloaded. (Inherited from DataGridViewCell)
Public Method | GetEditedFormattedValue | Returns the current, formatted value of the cell, regardless of whether the cell is in edit mode and the value has not been committed. (Inherited from DataGridViewCell)
Public Method | GetInheritedState | Returns a value indicating the current state of the cell as inherited from the state of its row and column. (Inherited from DataGridViewCell)
Public Method | GetInheritedStyle | Gets the style applied to the cell. (Inherited from DataGridViewCell)
Public Method | InitializeEditingControl | Initializes the control used to edit the cell. (Inherited from DataGridViewCell)
Public Method | KeyEntersEditMode | Determines if edit mode should be started based on the given key. (Inherited from DataGridViewCell)
Public Method | ParseFormattedValue | (Inherited from DataGridViewCell)
Public Method | PositionEditingControl | Sets the location and size of the editing control hosted by a cell in the DataGridView control. (Inherited from DataGridViewCell)
Public Method | PositionEditingPanel | (Inherited from DataGridViewCell)
Public Method | ToString | Overridden. Returns the string representation of the cell.
Public Method | Update | Overloaded. Full updates of this instance. (Inherited from DataGridViewElement)
Top

Protected Methods

 | Name | Description
Protected Method | BorderWidths | (Inherited from DataGridViewCell)
Protected Method | ClickUnsharesRow | Indicates whether the cell's row will be unshared when the cell is clicked. (Inherited from DataGridViewCell)
Protected Method | ContentClickUnsharesRow | Indicates whether the cell's row will be unshared when the cell's content is clicked. (Inherited from DataGridViewCell)
Protected Method | ContentDoubleClickUnsharesRow | Indicates whether the cell's row will be unshared when the cell's content is double-clicked. (Inherited from DataGridViewCell)
Protected Method | DoubleClickUnsharesRow | Indicates whether the cell's row will be unshared when the cell is double-clicked. (Inherited from DataGridViewCell)
Protected Method | EnterUnsharesRow | Indicates whether the parent row will be unshared when the focus moves to the cell. (Inherited from DataGridViewCell)
Protected Method | GetClipboardContent | Retrieves the formatted value of the cell to copy to the Clipboard. (Inherited from DataGridViewCell)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from DataGridViewElement)
Protected Method | GetDefaultHorizontalAlignment | Gets the horizontal alignment. (Inherited from DataGridViewCell)
Protected Method | GetDefaultVerticalAlignment | Gets the vertical alignment. (Inherited from DataGridViewCell)
Protected Method | GetErrorIconBounds | (Inherited from DataGridViewCell)
Protected Method | GetErrorText | Returns a string that represents the error for the cell. (Inherited from DataGridViewCell)
Protected Method | GetFormattedValue | Gets the value of the cell as formatted for display. (Inherited from DataGridViewCell)
Protected Method | GetPreferredSize | Overloaded. Overridden. Calculates the preferred size, in pixels, of the cell.
Protected Method | GetSize | Gets the size of the cell. (Inherited from DataGridViewCell)
Protected Method | GetValue | Overridden. Retrieves the text associated with the button.
Protected Method | IsDirty | Determines whether the specified component is dirty. (Inherited from DataGridViewElement)
Protected Method | IsDirtyAttributes | Overloaded. Determines whether the specified component is dirty. (Inherited from DataGridViewElement)
Protected Method | KeyDownUnsharesRow | Overridden. Indicates whether a row is unshared if a key is pressed while the focus is on a cell in the row.
Protected Method | KeyPressUnsharesRow | Indicates whether a row will be unshared if a key is pressed while a cell in the row has focus. (Inherited from DataGridViewCell)
Protected Method | KeyUpUnsharesRow | Overridden. Indicates whether a row is unshared when a key is released while the focus is on a cell in the row.
Protected Method | LeaveUnsharesRow | Indicates whether a row will be unshared when the focus leaves a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseClickUnsharesRow | Indicates whether a row will be unshared if the user clicks a mouse button while the pointer is on a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseDoubleClickUnsharesRow | Indicates whether a row will be unshared if the user double-clicks a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseDownUnsharesRow | Indicates whether a row will be unshared when the user holds down a mouse button while the pointer is on a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseEnterUnsharesRow | Indicates whether a row will be unshared when the mouse pointer moves over a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseLeaveUnsharesRow | Indicates whether a row will be unshared when the mouse pointer leaves the row. (Inherited from DataGridViewCell)
Protected Method | MouseMoveUnsharesRow | Indicates whether a row will be unshared when the mouse pointer moves over a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseUpUnsharesRow | Indicates whether a row will be unshared when the user releases a mouse button while the pointer is on a cell in the row. (Inherited from DataGridViewCell)
Protected Method | OnClick | Called when the cell is clicked. (Inherited from DataGridViewCell)
Protected Method | OnContentClick | Called when the cell's contents are clicked. (Inherited from DataGridViewCell)
Protected Method | OnContentDoubleClick | Called when the cell's contents are double-clicked. (Inherited from DataGridViewCell)
Protected Method | OnDataGridViewChanged | Called when the DataGridViewElement.DataGridView property of the cell changes. (Inherited from DataGridViewCell)
Protected Method | OnDoubleClick | Called when the cell is double-clicked. (Inherited from DataGridViewCell)
Protected Method | OnEnter | Called when the focus moves to a cell. (Inherited from DataGridViewCell)
Protected Method | OnKeyDown | Called when a character key is pressed while the focus is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnKeyPress | Called when a key is pressed while the focus is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnKeyUp | Called when a character key is released while the focus is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnLeave | Called when the focus moves from a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseClick | Called when the user clicks a mouse button while the pointer is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseDoubleClick | Called when the user double-clicks a mouse button while the pointer is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseDown | Called when the user holds down a mouse button while the pointer is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseEnter | Called when the mouse pointer moves over a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseLeave | Called when the mouse pointer leaves the cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseMove | Called when the mouse pointer moves within a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseUp | Called when the user releases a mouse button while the pointer is on a cell. (Inherited from DataGridViewCell)
Protected Method | Paint | (Inherited from DataGridViewCell)
Protected Method | PaintErrorIcon | (Inherited from DataGridViewCell)
Protected Method | ProcessGatewayRequest | (Inherited from DataGridViewCell)
Protected Method | RaiseCellClick | Raises the DataGridView.CellClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellContentClick | Raises the DataGridView.CellContentClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellContentDoubleClick | Raises the DataGridView.CellContentDoubleClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellValueChanged | Raises the CellValueChanged event. (Inherited from DataGridViewElement)
Protected Method | RaiseDataError | Raises the DataError event. (Inherited from DataGridViewElement)
Protected Method | RaiseMouseWheel | Raises the MouseWheel event. (Inherited from DataGridViewElement)
Protected Method | RenderAttributes | Overridden.
Protected Method | RenderBackColorAttribute | Renders the back color attribute. (Inherited from DataGridViewCell)
Protected Method | RenderComponent | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from DataGridViewElement)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from DataGridViewElement)
Protected Method | RenderComponents | Renders the controls sub tree (Inherited from DataGridViewElement)
Protected Method | RenderForeColorAttribute | Renders the fore color attribute. (Inherited from DataGridViewCell)
Protected Method | RenderReadOnlyAttribute | Renders the read only attribute. (Inherited from DataGridViewCell)
Protected Method | RenderUpdatedAttributes | Renders the updated attributes (Inherited from DataGridViewElement)
Protected Method | RenderWrapModeAttribute | Renders the wrap mode attribute. (Inherited from DataGridViewCell)
Protected Method | SetValue | Sets the value of the cell. (Inherited from DataGridViewCell)
Protected Method | UpdateParams | Overloaded. Updates only the parameters of this instance. (Inherited from DataGridViewElement)
Top

See Also

Reference

DataGridViewButtonCell Class
Gizmox.WebGUI.Forms Namespace


DataGridViewButtonCell Constructor

[image]
Gizmox.WebGUI.Forms
DataGridViewButtonCell Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewButtonCell Class : DataGridViewButtonCell Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewButtonCell()
C#
public DataGridViewButtonCell()
Managed Extensions for C++
public: DataGridViewButtonCell();
C++/CLI
public:
DataGridViewButtonCell();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewButtonCell Class
DataGridViewButtonCell Members


DataGridViewButtonCell Class Methods

[image]
Gizmox.WebGUI.Forms
DataGridViewButtonCell Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewButtonCell Class

For a list of all members of this type, see DataGridViewButtonCell members.

Public Methods

 | Name | Description
Public Method | AdjustCellBorderStyle | Modifies the input cell border style according to the specified criteria. (Inherited from DataGridViewCell)
Public Method | Clone | Overridden. Creates an exact copy of this cell.
Public Method | DetachEditingControl | Removes the cell's editing control from the DataGridView. (Inherited from DataGridViewCell)
Public Method | Dispose | Overloaded. Releases all resources used by the DataGridViewCell. (Inherited from DataGridViewCell)
Public Method | GetContentBounds | Overloaded. (Inherited from DataGridViewCell)
Public Method | GetEditedFormattedValue | Returns the current, formatted value of the cell, regardless of whether the cell is in edit mode and the value has not been committed. (Inherited from DataGridViewCell)
Public Method | GetInheritedState | Returns a value indicating the current state of the cell as inherited from the state of its row and column. (Inherited from DataGridViewCell)
Public Method | GetInheritedStyle | Gets the style applied to the cell. (Inherited from DataGridViewCell)
Public Method | InitializeEditingControl | Initializes the control used to edit the cell. (Inherited from DataGridViewCell)
Public Method | KeyEntersEditMode | Determines if edit mode should be started based on the given key. (Inherited from DataGridViewCell)
Public Method | ParseFormattedValue | (Inherited from DataGridViewCell)
Public Method | PositionEditingControl | Sets the location and size of the editing control hosted by a cell in the DataGridView control. (Inherited from DataGridViewCell)
Public Method | PositionEditingPanel | (Inherited from DataGridViewCell)
Public Method | ToString | Overridden. Returns the string representation of the cell.
Public Method | Update | Overloaded. Full updates of this instance. (Inherited from DataGridViewElement)
Top

Protected Methods

 | Name | Description
Protected Method | BorderWidths | (Inherited from DataGridViewCell)
Protected Method | ClickUnsharesRow | Indicates whether the cell's row will be unshared when the cell is clicked. (Inherited from DataGridViewCell)
Protected Method | ContentClickUnsharesRow | Indicates whether the cell's row will be unshared when the cell's content is clicked. (Inherited from DataGridViewCell)
Protected Method | ContentDoubleClickUnsharesRow | Indicates whether the cell's row will be unshared when the cell's content is double-clicked. (Inherited from DataGridViewCell)
Protected Method | DoubleClickUnsharesRow | Indicates whether the cell's row will be unshared when the cell is double-clicked. (Inherited from DataGridViewCell)
Protected Method | EnterUnsharesRow | Indicates whether the parent row will be unshared when the focus moves to the cell. (Inherited from DataGridViewCell)
Protected Method | GetClipboardContent | Retrieves the formatted value of the cell to copy to the Clipboard. (Inherited from DataGridViewCell)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from DataGridViewElement)
Protected Method | GetDefaultHorizontalAlignment | Gets the horizontal alignment. (Inherited from DataGridViewCell)
Protected Method | GetDefaultVerticalAlignment | Gets the vertical alignment. (Inherited from DataGridViewCell)
Protected Method | GetErrorIconBounds | (Inherited from DataGridViewCell)
Protected Method | GetErrorText | Returns a string that represents the error for the cell. (Inherited from DataGridViewCell)
Protected Method | GetFormattedValue | Gets the value of the cell as formatted for display. (Inherited from DataGridViewCell)
Protected Method | GetPreferredSize | Overloaded. Overridden. Calculates the preferred size, in pixels, of the cell.
Protected Method | GetSize | Gets the size of the cell. (Inherited from DataGridViewCell)
Protected Method | GetValue | Overridden. Retrieves the text associated with the button.
Protected Method | IsDirty | Determines whether the specified component is dirty. (Inherited from DataGridViewElement)
Protected Method | IsDirtyAttributes | Overloaded. Determines whether the specified component is dirty. (Inherited from DataGridViewElement)
Protected Method | KeyDownUnsharesRow | Overridden. Indicates whether a row is unshared if a key is pressed while the focus is on a cell in the row.
Protected Method | KeyPressUnsharesRow | Indicates whether a row will be unshared if a key is pressed while a cell in the row has focus. (Inherited from DataGridViewCell)
Protected Method | KeyUpUnsharesRow | Overridden. Indicates whether a row is unshared when a key is released while the focus is on a cell in the row.
Protected Method | LeaveUnsharesRow | Indicates whether a row will be unshared when the focus leaves a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseClickUnsharesRow | Indicates whether a row will be unshared if the user clicks a mouse button while the pointer is on a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseDoubleClickUnsharesRow | Indicates whether a row will be unshared if the user double-clicks a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseDownUnsharesRow | Indicates whether a row will be unshared when the user holds down a mouse button while the pointer is on a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseEnterUnsharesRow | Indicates whether a row will be unshared when the mouse pointer moves over a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseLeaveUnsharesRow | Indicates whether a row will be unshared when the mouse pointer leaves the row. (Inherited from DataGridViewCell)
Protected Method | MouseMoveUnsharesRow | Indicates whether a row will be unshared when the mouse pointer moves over a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseUpUnsharesRow | Indicates whether a row will be unshared when the user releases a mouse button while the pointer is on a cell in the row. (Inherited from DataGridViewCell)
Protected Method | OnClick | Called when the cell is clicked. (Inherited from DataGridViewCell)
Protected Method | OnContentClick | Called when the cell's contents are clicked. (Inherited from DataGridViewCell)
Protected Method | OnContentDoubleClick | Called when the cell's contents are double-clicked. (Inherited from DataGridViewCell)
Protected Method | OnDataGridViewChanged | Called when the DataGridViewElement.DataGridView property of the cell changes. (Inherited from DataGridViewCell)
Protected Method | OnDoubleClick | Called when the cell is double-clicked. (Inherited from DataGridViewCell)
Protected Method | OnEnter | Called when the focus moves to a cell. (Inherited from DataGridViewCell)
Protected Method | OnKeyDown | Called when a character key is pressed while the focus is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnKeyPress | Called when a key is pressed while the focus is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnKeyUp | Called when a character key is released while the focus is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnLeave | Called when the focus moves from a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseClick | Called when the user clicks a mouse button while the pointer is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseDoubleClick | Called when the user double-clicks a mouse button while the pointer is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseDown | Called when the user holds down a mouse button while the pointer is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseEnter | Called when the mouse pointer moves over a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseLeave | Called when the mouse pointer leaves the cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseMove | Called when the mouse pointer moves within a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseUp | Called when the user releases a mouse button while the pointer is on a cell. (Inherited from DataGridViewCell)
Protected Method | Paint | (Inherited from DataGridViewCell)
Protected Method | PaintErrorIcon | (Inherited from DataGridViewCell)
Protected Method | ProcessGatewayRequest | (Inherited from DataGridViewCell)
Protected Method | RaiseCellClick | Raises the DataGridView.CellClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellContentClick | Raises the DataGridView.CellContentClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellContentDoubleClick | Raises the DataGridView.CellContentDoubleClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellValueChanged | Raises the CellValueChanged event. (Inherited from DataGridViewElement)
Protected Method | RaiseDataError | Raises the DataError event. (Inherited from DataGridViewElement)
Protected Method | RaiseMouseWheel | Raises the MouseWheel event. (Inherited from DataGridViewElement)
Protected Method | RenderAttributes | Overridden.
Protected Method | RenderBackColorAttribute | Renders the back color attribute. (Inherited from DataGridViewCell)
Protected Method | RenderComponent | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from DataGridViewElement)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from DataGridViewElement)
Protected Method | RenderComponents | Renders the controls sub tree (Inherited from DataGridViewElement)
Protected Method | RenderForeColorAttribute | Renders the fore color attribute. (Inherited from DataGridViewCell)
Protected Method | RenderReadOnlyAttribute | Renders the read only attribute. (Inherited from DataGridViewCell)
Protected Method | RenderUpdatedAttributes | Renders the updated attributes (Inherited from DataGridViewElement)
Protected Method | RenderWrapModeAttribute | Renders the wrap mode attribute. (Inherited from DataGridViewCell)
Protected Method | SetValue | Sets the value of the cell. (Inherited from DataGridViewCell)
Protected Method | UpdateParams | Overloaded. Updates only the parameters of this instance. (Inherited from DataGridViewElement)
Top

See Also

Reference

DataGridViewButtonCell Class
Gizmox.WebGUI.Forms Namespace


Clone Method

[image]
Gizmox.WebGUI.Forms
Clone Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewButtonCell Class : Clone Method

Creates an exact copy of this cell.

Syntax

Visual Basic (Declaration)
Public Overrides Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewButtonCell
Dim value As Object

value = instance.Clone()
C#
public override object Clone()
Managed Extensions for C++
public: Object* Clone(); override
C++/CLI
public:
Object^ Clone(); override

Return Value

An Object that represents the cloned DataGridViewButtonCell.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewButtonCell Class
DataGridViewButtonCell Members


GetPreferredSize Method

[image]
Gizmox.WebGUI.Forms
GetPreferredSize Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewButtonCell Class : GetPreferredSize Method

Calculates the preferred size, in pixels, of the cell.

Overload List

Overload | Description
GetPreferredSize(Graphics,DataGridViewCellStyle,Int32,Size) | Calculates the preferred size, in pixels, of the cell.
GetPreferredSize(String,DataGridViewCellStyle) | Calculates the preferred size, in pixels, of the cell. (Inherited from DataGridViewCell)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewButtonCell Class
DataGridViewButtonCell Members


GetPreferredSize(Graphics,DataGridViewCellStyle,Int32,Size) Method

[image]
Gizmox.WebGUI.Forms
GetPreferredSize(Graphics,DataGridViewCellStyle,Int32,Size) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewButtonCell Class > GetPreferredSize Method : GetPreferredSize(Graphics,DataGridViewCellStyle,Int32,Size) Method

graphics
The Graphics used to draw the cell.
cellStyle
A DataGridViewCellStyle that represents the style of the cell.
rowIndex
The zero-based row index of the cell.
constraintSize
The cell's maximum allowable size.
Calculates the preferred size, in pixels, of the cell.

Syntax

Visual Basic (Declaration)
Protected Overloads Overrides Function GetPreferredSize( _
   ByVal graphics As Graphics, _
   ByVal cellStyle As DataGridViewCellStyle, _
   ByVal rowIndex As Integer, _
   ByVal constraintSize As Size _
) As Size
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewButtonCell
Dim graphics As Graphics
Dim cellStyle As DataGridViewCellStyle
Dim rowIndex As Integer
Dim constraintSize As Size
Dim value As Size

value = instance.GetPreferredSize(graphics, cellStyle, rowIndex, constraintSize)
C#
protected override Size GetPreferredSize(
   Graphics graphics,
   DataGridViewCellStyle cellStyle,
   int rowIndex,
   Size constraintSize
)
Managed Extensions for C++
protected: Size GetPreferredSize(
   Graphics* graphics,
   DataGridViewCellStyle* cellStyle,
   int rowIndex,
   Size constraintSize
) override
C++/CLI
protected:
Size GetPreferredSize(
   Graphics^ graphics,
   DataGridViewCellStyle^ cellStyle,
   int rowIndex,
   Size constraintSize
) override

Parameters

graphics
The Graphics used to draw the cell.
cellStyle
A DataGridViewCellStyle that represents the style of the cell.
rowIndex
The zero-based row index of the cell.
constraintSize
The cell's maximum allowable size.

Return Value

A Size that represents the preferred size, in pixels, of the cell.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewButtonCell Class
DataGridViewButtonCell Members
Overload List


GetValue Method

[image]
Gizmox.WebGUI.Forms
GetValue Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewButtonCell Class : GetValue Method

rowIndex
The index of the cell's parent row.
Retrieves the text associated with the button.

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetValue( _
   ByVal rowIndex As Integer _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewButtonCell
Dim rowIndex As Integer
Dim value As Object

value = instance.GetValue(rowIndex)
C#
protected override object GetValue(
   int rowIndex
)
Managed Extensions for C++
protected: Object* GetValue(
   int rowIndex
) override
C++/CLI
protected:
Object^ GetValue(
   int rowIndex
) override

Parameters

rowIndex
The index of the cell's parent row.

Return Value

The value of the DataGridViewButtonCell or the DataGridViewButtonColumn.Text value of the owning column if UseColumnTextForButtonValue is true.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewButtonCell Class
DataGridViewButtonCell Members


KeyDownUnsharesRow Method

[image]
Gizmox.WebGUI.Forms
KeyDownUnsharesRow Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewButtonCell Class : KeyDownUnsharesRow Method

e
A KeyEventArgs that contains the event data.
rowIndex
The index of the cell's parent row.
Indicates whether a row is unshared if a key is pressed while the focus is on a cell in the row.

Syntax

Visual Basic (Declaration)
Protected Overrides Function KeyDownUnsharesRow( _
   ByVal e As KeyEventArgs, _
   ByVal rowIndex As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewButtonCell
Dim e As KeyEventArgs
Dim rowIndex As Integer
Dim value As Boolean

value = instance.KeyDownUnsharesRow(e, rowIndex)
C#
protected override bool KeyDownUnsharesRow(
   KeyEventArgs e,
   int rowIndex
)
Managed Extensions for C++
protected: bool KeyDownUnsharesRow(
   KeyEventArgs* e,
   int rowIndex
) override
C++/CLI
protected:
bool KeyDownUnsharesRow(
   KeyEventArgs^ e,
   int rowIndex
) override

Parameters

e
A KeyEventArgs that contains the event data.
rowIndex
The index of the cell's parent row.

Return Value

true if the user pressed the SPACE key without modifier keys; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewButtonCell Class
DataGridViewButtonCell Members


KeyUpUnsharesRow Method

[image]
Gizmox.WebGUI.Forms
KeyUpUnsharesRow Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewButtonCell Class : KeyUpUnsharesRow Method

e
A KeyEventArgs that contains the event data.
rowIndex
The index of the cell's parent row.
Indicates whether a row is unshared when a key is released while the focus is on a cell in the row.

Syntax

Visual Basic (Declaration)
Protected Overrides Function KeyUpUnsharesRow( _
   ByVal e As KeyEventArgs, _
   ByVal rowIndex As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewButtonCell
Dim e As KeyEventArgs
Dim rowIndex As Integer
Dim value As Boolean

value = instance.KeyUpUnsharesRow(e, rowIndex)
C#
protected override bool KeyUpUnsharesRow(
   KeyEventArgs e,
   int rowIndex
)
Managed Extensions for C++
protected: bool KeyUpUnsharesRow(
   KeyEventArgs* e,
   int rowIndex
) override
C++/CLI
protected:
bool KeyUpUnsharesRow(
   KeyEventArgs^ e,
   int rowIndex
) override

Parameters

e
A KeyEventArgs that contains the event data.
rowIndex
The index of the cell's parent row.

Return Value

true if the user released the SPACE key; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewButtonCell Class
DataGridViewButtonCell Members


RenderAttributes Method

[image]
Gizmox.WebGUI.Forms
RenderAttributes Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewButtonCell Class : RenderAttributes Method

objContext
objWriter
blnRenderOwner

Syntax

Visual Basic (Declaration)
Protected Overrides Sub RenderAttributes( _
   ByVal objContext As IContext, _
   ByVal objWriter As IAttributeWriter, _
   ByVal blnRenderOwner As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewButtonCell
Dim objContext As IContext
Dim objWriter As IAttributeWriter
Dim blnRenderOwner As Boolean

instance.RenderAttributes(objContext, objWriter, blnRenderOwner)
C#
protected override void RenderAttributes(
   IContext objContext,
   IAttributeWriter objWriter,
   bool blnRenderOwner
)
Managed Extensions for C++
protected: void RenderAttributes(
   IContext* objContext,
   IAttributeWriter* objWriter,
   bool blnRenderOwner
) override
C++/CLI
protected:
void RenderAttributes(
   IContext^ objContext,
   IAttributeWriter^ objWriter,
   bool blnRenderOwner
) override

Parameters

objContext
objWriter
blnRenderOwner

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewButtonCell Class
DataGridViewButtonCell Members


ToString Method

[image]
Gizmox.WebGUI.Forms
ToString Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewButtonCell Class : ToString Method

Returns the string representation of the cell.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewButtonCell
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Return Value

A String that represents the current cell.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewButtonCell Class
DataGridViewButtonCell Members


DataGridViewButtonCell Class Properties

[image]
Gizmox.WebGUI.Forms
DataGridViewButtonCell Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewButtonCell Class

For a list of all members of this type, see DataGridViewButtonCell members.

Public Properties

 | Name | Description
Public Property | ColumnIndex | Gets the column index for this cell. (Inherited from DataGridViewCell)
Public Property | ContentBounds | (Inherited from DataGridViewCell)
Public Property | DataGridView | Gets the DataGridView control associated with this element. (Inherited from DataGridViewElement)
Public Property | DefaultNewRowValue | Gets the default value for a cell in the row for new records. (Inherited from DataGridViewCell)
Public Property | Displayed | Gets a value that indicates whether the cell is currently displayed on-screen. (Inherited from DataGridViewCell)
Public Property | EditedFormattedValue | Gets the current, formatted value of the cell, regardless of whether the cell is in edit mode and the value has not been committed. (Inherited from DataGridViewCell)
Public Property | EditType | Overridden. Gets the type of the cell's hosted editing control.
Public Property | ErrorIconBounds | (Inherited from DataGridViewCell)
Public Property | ErrorText | Gets or sets the text describing an error condition associated with the cell. (Inherited from DataGridViewCell)
Public Property | FlatStyle | Gets or sets the style determining the button's appearance.
Public Property | FormattedValue | Gets the value of the cell as formatted for display. (Inherited from DataGridViewCell)
Public Property | FormattedValueType | Overridden.
Public Property | Frozen | Gets a value indicating whether the cell is frozen. (Inherited from DataGridViewCell)
Public Property | HasStyle | Gets a value indicating whether the DataGridViewCell.Style property has been set. (Inherited from DataGridViewCell)
Public Property | InheritedState | Gets the current state of the cell as inherited from the state of its row and column. (Inherited from DataGridViewCell)
Public Property | InheritedStyle | Gets the style currently applied to the cell. (Inherited from DataGridViewCell)
Public Property | IsInEditMode | Gets a value indicating whether this cell is currently being edited. (Inherited from DataGridViewCell)
Public Property | OwningColumn | Gets the column that contains this cell. (Inherited from DataGridViewCell)
Public Property | OwningRow | Gets the row that contains this cell. (Inherited from DataGridViewCell)
Public Property | PreferredSize | Gets the size, in pixels, of a rectangular area into which the cell can fit. (Inherited from DataGridViewCell)
Public Property | ReadOnly | Gets or sets a value indicating whether the cell's data can be edited. (Inherited from DataGridViewCell)
Public Property | Resizable | Gets a value indicating whether the cell can be resized. (Inherited from DataGridViewCell)
Public Property | RowIndex | Gets the index of the cell's parent row. (Inherited from DataGridViewCell)
Public Property | Selected | Gets or sets a value indicating whether the cell has been selected. (Inherited from DataGridViewCell)
Public Property | Size | Gets the size of the cell. (Inherited from DataGridViewCell)
Public Property | State | Gets the user interface (UI) state of the element. (Inherited from DataGridViewElement)
Public Property | Style | Gets or sets the style for the cell. (Inherited from DataGridViewCell)
Public Property | Tag | Gets or sets the object that contains supplemental data about the cell. (Inherited from DataGridViewCell)
Public Property | ToolTipText | Gets or sets the ToolTip text associated with this cell. (Inherited from DataGridViewCell)
Public Property | UseColumnTextForButtonValue | Gets or sets a value indicating whether the owning column's text will appear on the button displayed by the cell.
Public Property | Value | Gets or sets the value associated with this cell. (Inherited from DataGridViewCell)
Public Property | ValueType | Overridden.
Public Property | Visible | Gets a value indicating whether the cell is in a row or column that has been hidden. (Inherited from DataGridViewCell)
Top

Protected Properties

 | Name | Description
Protected Property | MemberID | (Inherited from DataGridViewCell)
Protected Property | TagName | (Inherited from DataGridViewElement)
Top

See Also

Reference

DataGridViewButtonCell Class
Gizmox.WebGUI.Forms Namespace


EditType Property

[image]
Gizmox.WebGUI.Forms
EditType Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewButtonCell Class : EditType Property

Gets the type of the cell's hosted editing control.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property EditType As Type
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewButtonCell
Dim value As Type

value = instance.EditType
C#
public override Type EditType {get;}
Managed Extensions for C++
public: __property Type* get_EditType() override;
C++/CLI
public:
property Type^ EditType {
   Type^ get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewButtonCell Class
DataGridViewButtonCell Members


FlatStyle Property

[image]
Gizmox.WebGUI.Forms
FlatStyle Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewButtonCell Class : FlatStyle Property

Gets or sets the style determining the button's appearance.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property FlatStyle As FlatStyle
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewButtonCell
Dim value As FlatStyle

instance.FlatStyle = value

value = instance.FlatStyle
C#
[DefaultValueAttribute()]
public FlatStyle FlatStyle {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property FlatStyle get_FlatStyle();
public: __property void set_FlatStyle(
   FlatStyle value
);
C++/CLI
[DefaultValueAttribute()]
public:
property FlatStyle FlatStyle {
   FlatStyle get();
   void set (FlatStylevalue);
}

Exceptions

Exception | Description
InvalidEnumArgumentException | The specified value when setting this property is not a valid FlatStyle value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewButtonCell Class
DataGridViewButtonCell Members


FormattedValueType Property

[image]
Gizmox.WebGUI.Forms
FormattedValueType Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewButtonCell Class : FormattedValueType Property

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property FormattedValueType As Type
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewButtonCell
Dim value As Type

value = instance.FormattedValueType
C#
public override Type FormattedValueType {get;}
Managed Extensions for C++
public: __property Type* get_FormattedValueType() override;
C++/CLI
public:
property Type^ FormattedValueType {
   Type^ get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewButtonCell Class
DataGridViewButtonCell Members


UseColumnTextForButtonValue Property

[image]
Gizmox.WebGUI.Forms
UseColumnTextForButtonValue Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewButtonCell Class : UseColumnTextForButtonValue Property

Gets or sets a value indicating whether the owning column's text will appear on the button displayed by the cell.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property UseColumnTextForButtonValue As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewButtonCell
Dim value As Boolean

instance.UseColumnTextForButtonValue = value

value = instance.UseColumnTextForButtonValue
C#
[DefaultValueAttribute()]
public bool UseColumnTextForButtonValue {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property bool get_UseColumnTextForButtonValue();
public: __property void set_UseColumnTextForButtonValue(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
public:
property bool UseColumnTextForButtonValue {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewButtonCell Class
DataGridViewButtonCell Members


ValueType Property

[image]
Gizmox.WebGUI.Forms
ValueType Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewButtonCell Class : ValueType Property

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ValueType As Type
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewButtonCell
Dim value As Type

value = instance.ValueType
C#
public override Type ValueType {get;}
Managed Extensions for C++
public: __property Type* get_ValueType() override;
C++/CLI
public:
property Type^ ValueType {
   Type^ get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewButtonCell Class
DataGridViewButtonCell Members


DataGridViewButtonColumn Class

[image]
Gizmox.WebGUI.Forms
DataGridViewButtonColumn Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewButtonColumn Class

Hosts a collection of DataGridViewButtonCell objects.

Object Model

Syntax

Visual Basic (Declaration)
<ClientControllerAttribute()>
<ToolboxBitmapAttribute()>
<DesignTimeControllerAttribute()>
Public Class DataGridViewButtonColumn
   Inherits DataGridViewColumn
   Implements IRenderableComponentMember
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewButtonColumn
C#
[ClientControllerAttribute()]
[ToolboxBitmapAttribute()]
[DesignTimeControllerAttribute()]
public class DataGridViewButtonColumn : DataGridViewColumn, IRenderableComponentMember
Managed Extensions for C++
[ClientControllerAttribute()]
[ToolboxBitmapAttribute()]
[DesignTimeControllerAttribute()]
public __gc class DataGridViewButtonColumn : public DataGridViewColumn, IRenderableComponentMember
C++/CLI
[ClientControllerAttribute()]
[ToolboxBitmapAttribute()]
[DesignTimeControllerAttribute()]
public ref class DataGridViewButtonColumn : public DataGridViewColumn, IRenderableComponentMember

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.DataGridViewElement
Gizmox.WebGUI.Forms.DataGridViewBand
Gizmox.WebGUI.Forms.DataGridViewColumn
Gizmox.WebGUI.Forms.DataGridViewButtonColumn

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

DataGridViewButtonColumn Members
Gizmox.WebGUI.Forms Namespace


DataGridViewButtonColumn Class Members

[image]
Gizmox.WebGUI.Forms
DataGridViewButtonColumn Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewButtonColumn Class

The following tables list the members exposed by DataGridViewButtonColumn.

Public Constructors

 | Name | Description
Public Constructor | DataGridViewButtonColumn Constructor | Initializes a new instance of the DataGridViewButtonColumn class to the default state.
Top

Public Properties

 | Name | Description
Public Property | AutoSizeMode | Gets or sets the mode by which the column automatically adjusts its width. (Inherited from DataGridViewColumn)
Public Property | CellTemplate | Overridden. Gets or sets the template used to create new cells.
Public Property | CellType | Gets the run-time type of the cell template. (Inherited from DataGridViewColumn)
Public Property | DataGridView | Gets the DataGridView control associated with this element. (Inherited from DataGridViewElement)
Public Property | DataPropertyName | Gets or sets the name of the data source property or database column to which the DataGridViewColumn is bound. (Inherited from DataGridViewColumn)
Public Property | DefaultCellStyle | Overridden. Gets or sets the column's default cell style.
Public Property | DefaultHeaderCellType | Gets or sets the run-time type of the default header cell. (Inherited from DataGridViewBand)
Public Property | Displayed | Gets a value indicating whether the band is currently displayed onscreen. (Inherited from DataGridViewBand)
Public Property | DisplayIndex | Gets or sets the display order of the column relative to the currently displayed columns. (Inherited from DataGridViewColumn)
Public Property | DividerWidth | Gets or sets the width, in pixels, of the column divider. (Inherited from DataGridViewColumn)
Public Property | FillWeight | Gets or sets a value that represents the width of the column when it is in fill mode relative to the widths of other fill-mode columns in the control. (Inherited from DataGridViewColumn)
Public Property | FlatStyle | Gets or sets the flat-style appearance of the button cells in the column.
Public Property | Frozen | Gets or sets a value indicating whether a column will move when a user scrolls the DataGridView control horizontally. (Inherited from DataGridViewColumn)
Public Property | HasDefaultCellStyle | Gets a value indicating whether the DataGridViewBand.DefaultCellStyle property has been set. (Inherited from DataGridViewBand)
Public Property | HeaderCell | Gets or sets the DataGridViewColumnHeaderCell that represents the column header. (Inherited from DataGridViewColumn)
Public Property | HeaderText | Gets or sets the caption text on the column's header cell. (Inherited from DataGridViewColumn)
Public Property | Index | Gets the relative position of the band within the DataGridView control. (Inherited from DataGridViewBand)
Public Property | InheritedAutoSizeMode | Gets the sizing mode in effect for the column. (Inherited from DataGridViewColumn)
Public Property | InheritedStyle | Gets the cell style currently applied to the column. (Inherited from DataGridViewColumn)
Public Property | IsDataBound | Gets a value indicating whether the column is bound to a data source. (Inherited from DataGridViewColumn)
Public Property | MinimumWidth | Gets or sets the minimum width, in pixels, of the column. (Inherited from DataGridViewColumn)
Public Property | Name | Gets or sets the name of the column. (Inherited from DataGridViewColumn)
Public Property | ReadOnly | Gets or sets a value indicating whether the user can edit the column's cells. (Inherited from DataGridViewColumn)
Public Property | Resizable | Gets or sets a value indicating whether the column is resizable. (Inherited from DataGridViewColumn)
Public Property | Selected | Gets or sets a value indicating whether the band is in a selected user interface (UI) state. (Inherited from DataGridViewBand)
Public Property | Site | Gets or sets the site of the column. (Inherited from DataGridViewColumn)
Public Property | SortMode | Gets or sets the sort mode for the column. (Inherited from DataGridViewColumn)
Public Property | State | Gets the user interface (UI) state of the element. (Inherited from DataGridViewElement)
Public Property | Tag | Gets or sets the object that contains data to associate with the band. (Inherited from DataGridViewBand)
Public Property | Text | Gets or sets the default text displayed on the button cell.
Public Property | ToolTipText | Gets or sets the text used for ToolTips. (Inherited from DataGridViewColumn)
Public Property | UseColumnTextForButtonValue | Gets or sets a value indicating whether the Text property value is displayed as the button text for cells in this column.
Public Property | ValueType | Gets or sets the data type of the values in the column's cells. (Inherited from DataGridViewColumn)
Public Property | Visible | Gets or sets a value indicating whether the column is visible. (Inherited from DataGridViewColumn)
Public Property | Width | Gets or sets the current width of the column. (Inherited from DataGridViewColumn)
Top

Protected Properties

 | Name | Description
Protected Property | HeaderCellCore | Gets or sets the header cell of the DataGridViewBand. (Inherited from DataGridViewBand)
Protected Property | IsRow | Gets a value indicating whether the band represents a row. (Inherited from DataGridViewBand)
Protected Property | MemberID | (Inherited from DataGridViewColumn)
Protected Property | TagName | (Inherited from DataGridViewElement)
Protected Property | TypeName | Overridden.
Top

Public Methods

 | Name | Description
Public Method | Clone | Overridden. Creates an exact copy of this column.
Public Method | Dispose | Overloaded. Releases all resources used by the DataGridViewBand. (Inherited from DataGridViewBand)
Public Method | GetPreferredWidth | Calculates the ideal width of the column based on the specified criteria. (Inherited from DataGridViewColumn)
Public Method | ToString | Overridden.
Public Method | Update | Overloaded. Full updates of this instance. (Inherited from DataGridViewElement)
Top

Protected Methods

 | Name | Description
Protected Method | CloneInternal | (Inherited from DataGridViewColumn)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from DataGridViewElement)
Protected Method | IsDirty | Determines whether the specified component is dirty. (Inherited from DataGridViewElement)
Protected Method | IsDirtyAttributes | Overloaded. Determines whether the specified component is dirty. (Inherited from DataGridViewElement)
Protected Method | OnDataGridViewChanged | Called when the band is associated with a different DataGridView. (Inherited from DataGridViewBand)
Protected Method | RaiseCellClick | Raises the DataGridView.CellClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellContentClick | Raises the DataGridView.CellContentClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellContentDoubleClick | Raises the DataGridView.CellContentDoubleClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellValueChanged | Raises the CellValueChanged event. (Inherited from DataGridViewElement)
Protected Method | RaiseDataError | Raises the DataError event. (Inherited from DataGridViewElement)
Protected Method | RaiseMouseWheel | Raises the MouseWheel event. (Inherited from DataGridViewElement)
Protected Method | RenderAttributes | (Inherited from DataGridViewColumn)
Protected Method | RenderComponent | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from DataGridViewElement)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from DataGridViewElement)
Protected Method | RenderComponents | Renders the column's inner components (Inherited from DataGridViewColumn)
Protected Method | RenderUpdatedAttributes | Renders the updated attributes (Inherited from DataGridViewElement)
Protected Method | UpdateParams | Overloaded. Updates only the parameters of this instance. (Inherited from DataGridViewElement)
Top

Public Events

 | Name | Description
Public Event | Disposed | Occurs when the DataGridViewColumn is disposed. (Inherited from DataGridViewColumn)
Top

See Also

Reference

DataGridViewButtonColumn Class
Gizmox.WebGUI.Forms Namespace


DataGridViewButtonColumn Constructor

[image]
Gizmox.WebGUI.Forms
DataGridViewButtonColumn Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewButtonColumn Class : DataGridViewButtonColumn Constructor

Initializes a new instance of the DataGridViewButtonColumn class to the default state.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewButtonColumn()
C#
public DataGridViewButtonColumn()
Managed Extensions for C++
public: DataGridViewButtonColumn();
C++/CLI
public:
DataGridViewButtonColumn();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewButtonColumn Class
DataGridViewButtonColumn Members


DataGridViewButtonColumn Class Methods

[image]
Gizmox.WebGUI.Forms
DataGridViewButtonColumn Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewButtonColumn Class

For a list of all members of this type, see DataGridViewButtonColumn members.

Public Methods

 | Name | Description
Public Method | Clone | Overridden. Creates an exact copy of this column.
Public Method | Dispose | Overloaded. Releases all resources used by the DataGridViewBand. (Inherited from DataGridViewBand)
Public Method | GetPreferredWidth | Calculates the ideal width of the column based on the specified criteria. (Inherited from DataGridViewColumn)
Public Method | ToString | Overridden.
Public Method | Update | Overloaded. Full updates of this instance. (Inherited from DataGridViewElement)
Top

Protected Methods

 | Name | Description
Protected Method | CloneInternal | (Inherited from DataGridViewColumn)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from DataGridViewElement)
Protected Method | IsDirty | Determines whether the specified component is dirty. (Inherited from DataGridViewElement)
Protected Method | IsDirtyAttributes | Overloaded. Determines whether the specified component is dirty. (Inherited from DataGridViewElement)
Protected Method | OnDataGridViewChanged | Called when the band is associated with a different DataGridView. (Inherited from DataGridViewBand)
Protected Method | RaiseCellClick | Raises the DataGridView.CellClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellContentClick | Raises the DataGridView.CellContentClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellContentDoubleClick | Raises the DataGridView.CellContentDoubleClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellValueChanged | Raises the CellValueChanged event. (Inherited from DataGridViewElement)
Protected Method | RaiseDataError | Raises the DataError event. (Inherited from DataGridViewElement)
Protected Method | RaiseMouseWheel | Raises the MouseWheel event. (Inherited from DataGridViewElement)
Protected Method | RenderAttributes | (Inherited from DataGridViewColumn)
Protected Method | RenderComponent | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from DataGridViewElement)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from DataGridViewElement)
Protected Method | RenderComponents | Renders the column's inner components (Inherited from DataGridViewColumn)
Protected Method | RenderUpdatedAttributes | Renders the updated attributes (Inherited from DataGridViewElement)
Protected Method | UpdateParams | Overloaded. Updates only the parameters of this instance. (Inherited from DataGridViewElement)
Top

See Also

Reference

DataGridViewButtonColumn Class
Gizmox.WebGUI.Forms Namespace


Clone Method

[image]
Gizmox.WebGUI.Forms
Clone Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewButtonColumn Class : Clone Method

Creates an exact copy of this column.

Syntax

Visual Basic (Declaration)
Public Overrides Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewButtonColumn
Dim value As Object

value = instance.Clone()
C#
public override object Clone()
Managed Extensions for C++
public: Object* Clone(); override
C++/CLI
public:
Object^ Clone(); override

Return Value

An Object that represents the cloned DataGridViewButtonColumn.

Exceptions

Exception | Description
InvalidOperationException | The value of the CellTemplate property is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewButtonColumn Class
DataGridViewButtonColumn Members


ToString Method

[image]
Gizmox.WebGUI.Forms
ToString Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewButtonColumn Class : ToString Method

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewButtonColumn
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewButtonColumn Class
DataGridViewButtonColumn Members


DataGridViewButtonColumn Class Properties

[image]
Gizmox.WebGUI.Forms
DataGridViewButtonColumn Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewButtonColumn Class

For a list of all members of this type, see DataGridViewButtonColumn members.

Public Properties

 | Name | Description
Public Property | AutoSizeMode | Gets or sets the mode by which the column automatically adjusts its width. (Inherited from DataGridViewColumn)
Public Property | CellTemplate | Overridden. Gets or sets the template used to create new cells.
Public Property | CellType | Gets the run-time type of the cell template. (Inherited from DataGridViewColumn)
Public Property | DataGridView | Gets the DataGridView control associated with this element. (Inherited from DataGridViewElement)
Public Property | DataPropertyName | Gets or sets the name of the data source property or database column to which the DataGridViewColumn is bound. (Inherited from DataGridViewColumn)
Public Property | DefaultCellStyle | Overridden. Gets or sets the column's default cell style.
Public Property | DefaultHeaderCellType | Gets or sets the run-time type of the default header cell. (Inherited from DataGridViewBand)
Public Property | Displayed | Gets a value indicating whether the band is currently displayed onscreen. (Inherited from DataGridViewBand)
Public Property | DisplayIndex | Gets or sets the display order of the column relative to the currently displayed columns. (Inherited from DataGridViewColumn)
Public Property | DividerWidth | Gets or sets the width, in pixels, of the column divider. (Inherited from DataGridViewColumn)
Public Property | FillWeight | Gets or sets a value that represents the width of the column when it is in fill mode relative to the widths of other fill-mode columns in the control. (Inherited from DataGridViewColumn)
Public Property | FlatStyle | Gets or sets the flat-style appearance of the button cells in the column.
Public Property | Frozen | Gets or sets a value indicating whether a column will move when a user scrolls the DataGridView control horizontally. (Inherited from DataGridViewColumn)
Public Property | HasDefaultCellStyle | Gets a value indicating whether the DataGridViewBand.DefaultCellStyle property has been set. (Inherited from DataGridViewBand)
Public Property | HeaderCell | Gets or sets the DataGridViewColumnHeaderCell that represents the column header. (Inherited from DataGridViewColumn)
Public Property | HeaderText | Gets or sets the caption text on the column's header cell. (Inherited from DataGridViewColumn)
Public Property | Index | Gets the relative position of the band within the DataGridView control. (Inherited from DataGridViewBand)
Public Property | InheritedAutoSizeMode | Gets the sizing mode in effect for the column. (Inherited from DataGridViewColumn)
Public Property | InheritedStyle | Gets the cell style currently applied to the column. (Inherited from DataGridViewColumn)
Public Property | IsDataBound | Gets a value indicating whether the column is bound to a data source. (Inherited from DataGridViewColumn)
Public Property | MinimumWidth | Gets or sets the minimum width, in pixels, of the column. (Inherited from DataGridViewColumn)
Public Property | Name | Gets or sets the name of the column. (Inherited from DataGridViewColumn)
Public Property | ReadOnly | Gets or sets a value indicating whether the user can edit the column's cells. (Inherited from DataGridViewColumn)
Public Property | Resizable | Gets or sets a value indicating whether the column is resizable. (Inherited from DataGridViewColumn)
Public Property | Selected | Gets or sets a value indicating whether the band is in a selected user interface (UI) state. (Inherited from DataGridViewBand)
Public Property | Site | Gets or sets the site of the column. (Inherited from DataGridViewColumn)
Public Property | SortMode | Gets or sets the sort mode for the column. (Inherited from DataGridViewColumn)
Public Property | State | Gets the user interface (UI) state of the element. (Inherited from DataGridViewElement)
Public Property | Tag | Gets or sets the object that contains data to associate with the band. (Inherited from DataGridViewBand)
Public Property | Text | Gets or sets the default text displayed on the button cell.
Public Property | ToolTipText | Gets or sets the text used for ToolTips. (Inherited from DataGridViewColumn)
Public Property | UseColumnTextForButtonValue | Gets or sets a value indicating whether the Text property value is displayed as the button text for cells in this column.
Public Property | ValueType | Gets or sets the data type of the values in the column's cells. (Inherited from DataGridViewColumn)
Public Property | Visible | Gets or sets a value indicating whether the column is visible. (Inherited from DataGridViewColumn)
Public Property | Width | Gets or sets the current width of the column. (Inherited from DataGridViewColumn)
Top

Protected Properties

 | Name | Description
Protected Property | HeaderCellCore | Gets or sets the header cell of the DataGridViewBand. (Inherited from DataGridViewBand)
Protected Property | IsRow | Gets a value indicating whether the band represents a row. (Inherited from DataGridViewBand)
Protected Property | MemberID | (Inherited from DataGridViewColumn)
Protected Property | TagName | (Inherited from DataGridViewElement)
Protected Property | TypeName | Overridden.
Top

See Also

Reference

DataGridViewButtonColumn Class
Gizmox.WebGUI.Forms Namespace


CellTemplate Property

[image]
Gizmox.WebGUI.Forms
CellTemplate Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewButtonColumn Class : CellTemplate Property

Gets or sets the template used to create new cells.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public Overrides Property CellTemplate As DataGridViewCell
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewButtonColumn
Dim value As DataGridViewCell

instance.CellTemplate = value

value = instance.CellTemplate
C#
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public override DataGridViewCell CellTemplate {get; set;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property DataGridViewCell* get_CellTemplate() override;
public: __property void set_CellTemplate(
   DataGridViewCell* value
) override;
C++/CLI
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
property DataGridViewCell^ CellTemplate {
   DataGridViewCell^ get() override;
   void set (DataGridViewCell^value) override;
}

Exceptions

Exception | Description
InvalidCastException | The specified value when setting this property could not be cast to a DataGridViewButtonCell.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewButtonColumn Class
DataGridViewButtonColumn Members


DefaultCellStyle Property

[image]
Gizmox.WebGUI.Forms
DefaultCellStyle Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewButtonColumn Class : DefaultCellStyle Property

Gets or sets the column's default cell style.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Appearance")>
<SRDescriptionAttribute("The column's default cell style.")>
<BrowsableAttribute(True)>
Public Overrides Property DefaultCellStyle As DataGridViewCellStyle
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewButtonColumn
Dim value As DataGridViewCellStyle

instance.DefaultCellStyle = value

value = instance.DefaultCellStyle
C#
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("The column's default cell style.")]
[BrowsableAttribute(true)]
public override DataGridViewCellStyle DefaultCellStyle {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("The column's default cell style.")]
[BrowsableAttribute(true)]
public: __property DataGridViewCellStyle* get_DefaultCellStyle() override;
public: __property void set_DefaultCellStyle(
   DataGridViewCellStyle* value
) override;
C++/CLI
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("The column's default cell style.")]
[BrowsableAttribute(true)]
public:
property DataGridViewCellStyle^ DefaultCellStyle {
   DataGridViewCellStyle^ get() override;
   void set (DataGridViewCellStyle^value) override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewButtonColumn Class
DataGridViewButtonColumn Members


FlatStyle Property

[image]
Gizmox.WebGUI.Forms
FlatStyle Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewButtonColumn Class : FlatStyle Property

Gets or sets the flat-style appearance of the button cells in the column.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Appearance")>
<DefaultValueAttribute()>
<SRDescriptionAttribute("The flat style appearance of the button cells in the column.")>
Public Property FlatStyle As FlatStyle
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewButtonColumn
Dim value As FlatStyle

instance.FlatStyle = value

value = instance.FlatStyle
C#
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("The flat style appearance of the button cells in the column.")]
public FlatStyle FlatStyle {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("The flat style appearance of the button cells in the column.")]
public: __property FlatStyle get_FlatStyle();
public: __property void set_FlatStyle(
   FlatStyle value
);
C++/CLI
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("The flat style appearance of the button cells in the column.")]
public:
property FlatStyle FlatStyle {
   FlatStyle get();
   void set (FlatStylevalue);
}

Exceptions

Exception | Description
InvalidOperationException | The value of the CellTemplate property is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewButtonColumn Class
DataGridViewButtonColumn Members


Text Property

[image]
Gizmox.WebGUI.Forms
Text Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewButtonColumn Class : Text Property

Gets or sets the default text displayed on the button cell.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("The default text displayed on the button cell.")>
<DefaultValueAttribute()>
<SRCategoryAttribute("Appearance")>
Public Property Text As String
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewButtonColumn
Dim value As String

instance.Text = value

value = instance.Text
C#
[SRDescriptionAttribute("The default text displayed on the button cell.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
public string Text {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("The default text displayed on the button cell.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
public: __property string* get_Text();
public: __property void set_Text(
   string* value
);
C++/CLI
[SRDescriptionAttribute("The default text displayed on the button cell.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
public:
property String^ Text {
   String^ get();
   void set (String^value);
}

Exceptions

Exception | Description
InvalidOperationException | When setting this property, the value of the CellTemplate property is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewButtonColumn Class
DataGridViewButtonColumn Members


TypeName Property

[image]
Gizmox.WebGUI.Forms
TypeName Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewButtonColumn Class : TypeName Property

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property TypeName As String
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewButtonColumn
Dim value As String

value = instance.TypeName
C#
protected override string TypeName {get;}
Managed Extensions for C++
protected: __property string* get_TypeName() override;
C++/CLI
protected:
property String^ TypeName {
   String^ get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewButtonColumn Class
DataGridViewButtonColumn Members


UseColumnTextForButtonValue Property

[image]
Gizmox.WebGUI.Forms
UseColumnTextForButtonValue Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewButtonColumn Class : UseColumnTextForButtonValue Property

Gets or sets a value indicating whether the Text property value is displayed as the button text for cells in this column.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Appearance")>
<DefaultValueAttribute()>
<SRDescriptionAttribute("Indicates whether the DataGridViewButtonColumn.Text property value is displayed as the button text for cells in this column.")>
Public Property UseColumnTextForButtonValue As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewButtonColumn
Dim value As Boolean

instance.UseColumnTextForButtonValue = value

value = instance.UseColumnTextForButtonValue
C#
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Indicates whether the DataGridViewButtonColumn.Text property value is displayed as the button text for cells in this column.")]
public bool UseColumnTextForButtonValue {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Indicates whether the DataGridViewButtonColumn.Text property value is displayed as the button text for cells in this column.")]
public: __property bool get_UseColumnTextForButtonValue();
public: __property void set_UseColumnTextForButtonValue(
   bool value
);
C++/CLI
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Indicates whether the DataGridViewButtonColumn.Text property value is displayed as the button text for cells in this column.")]
public:
property bool UseColumnTextForButtonValue {
   bool get();
   void set (boolvalue);
}

Exceptions

Exception | Description
InvalidOperationException | The value of the CellTemplate property is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewButtonColumn Class
DataGridViewButtonColumn Members


DataGridViewCell Class

[image]
Gizmox.WebGUI.Forms
DataGridViewCell Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewCell Class

Represents an individual cell in a DataGridView control.

Object Model

Syntax

Visual Basic (Declaration)
<TypeConverterAttribute("Gizmox.WebGUI.Forms.DataGridViewCellConverter, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d")>
Public MustInherit Class DataGridViewCell
   Inherits DataGridViewElement
   Implements IRenderableComponentMember
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
C#
[TypeConverterAttribute("Gizmox.WebGUI.Forms.DataGridViewCellConverter, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d")]
public abstract class DataGridViewCell : DataGridViewElement, IRenderableComponentMember
Managed Extensions for C++
[TypeConverterAttribute("Gizmox.WebGUI.Forms.DataGridViewCellConverter, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d")]
public __gc abstract class DataGridViewCell : public DataGridViewElement, IRenderableComponentMember
C++/CLI
[TypeConverterAttribute("Gizmox.WebGUI.Forms.DataGridViewCellConverter, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d")]
public ref class DataGridViewCell abstract : public DataGridViewElement, IRenderableComponentMember

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.DataGridViewElement
Gizmox.WebGUI.Forms.DataGridViewCell
Gizmox.WebGUI.Forms.DataGridViewButtonCell
Gizmox.WebGUI.Forms.DataGridViewCheckBoxCell
Gizmox.WebGUI.Forms.DataGridViewComboBoxCell
Gizmox.WebGUI.Forms.DataGridViewHeaderCell
Gizmox.WebGUI.Forms.DataGridViewImageCell
Gizmox.WebGUI.Forms.DataGridViewLinkCell
Gizmox.WebGUI.Forms.DataGridViewTextBoxCell

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

DataGridViewCell Members
Gizmox.WebGUI.Forms Namespace


DataGridViewCell Class Members

[image]
Gizmox.WebGUI.Forms
DataGridViewCell Class Members
See Also Fields Properties Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewCell Class

The following tables list the members exposed by DataGridViewCell.

Protected Fields

 | Name | Description
static (Shared in Visual Basic) | DefaultHorizontalPadding |
static (Shared in Visual Basic) | DefaultVerticalPadding |
Top

Public Properties

 | Name | Description
Public Property | ColumnIndex | Gets the column index for this cell.
Public Property | ContentBounds |
Public Property | DataGridView | Gets the DataGridView control associated with this element. (Inherited from DataGridViewElement)
Public Property | DefaultNewRowValue | Gets the default value for a cell in the row for new records.
Public Property | Displayed | Gets a value that indicates whether the cell is currently displayed on-screen.
Public Property | EditedFormattedValue | Gets the current, formatted value of the cell, regardless of whether the cell is in edit mode and the value has not been committed.
Public Property | EditType | Gets the type of the cell's hosted editing control.
Public Property | ErrorIconBounds |
Public Property | ErrorText | Gets or sets the text describing an error condition associated with the cell.
Public Property | FormattedValue | Gets the value of the cell as formatted for display.
Public Property | FormattedValueType | Gets the type of the formatted value associated with the cell.
Public Property | Frozen | Gets a value indicating whether the cell is frozen.
Public Property | HasStyle | Gets a value indicating whether the DataGridViewCell.Style property has been set.
Public Property | InheritedState | Gets the current state of the cell as inherited from the state of its row and column.
Public Property | InheritedStyle | Gets the style currently applied to the cell.
Public Property | IsInEditMode | Gets a value indicating whether this cell is currently being edited.
Public Property | OwningColumn | Gets the column that contains this cell.
Public Property | OwningRow | Gets the row that contains this cell.
Public Property | PreferredSize | Gets the size, in pixels, of a rectangular area into which the cell can fit.
Public Property | ReadOnly | Gets or sets a value indicating whether the cell's data can be edited.
Public Property | Resizable | Gets a value indicating whether the cell can be resized.
Public Property | RowIndex | Gets the index of the cell's parent row.
Public Property | Selected | Gets or sets a value indicating whether the cell has been selected.
Public Property | Size | Gets the size of the cell.
Public Property | State | Gets the user interface (UI) state of the element. (Inherited from DataGridViewElement)
Public Property | Style | Gets or sets the style for the cell.
Public Property | Tag | Gets or sets the object that contains supplemental data about the cell.
Public Property | ToolTipText | Gets or sets the ToolTip text associated with this cell.
Public Property | Value | Gets or sets the value associated with this cell.
Public Property | ValueType | Gets or sets the data type of the values in the cell.
Public Property | Visible | Gets a value indicating whether the cell is in a row or column that has been hidden.
Top

Protected Properties

 | Name | Description
Protected Property | MemberID | Overridden.
Protected Property | TagName | (Inherited from DataGridViewElement)
Top

Public Methods

 | Name | Description
Public Method | AdjustCellBorderStyle | Modifies the input cell border style according to the specified criteria.
Public Method | Clone | Creates an exact copy of this cell.
Public Method | DetachEditingControl | Removes the cell's editing control from the DataGridView.
Public Method | Dispose | Overloaded. Releases all resources used by the DataGridViewCell.
Public Method | GetContentBounds | Overloaded.
Public Method | GetEditedFormattedValue | Returns the current, formatted value of the cell, regardless of whether the cell is in edit mode and the value has not been committed.
Public Method | GetInheritedState | Returns a value indicating the current state of the cell as inherited from the state of its row and column.
Public Method | GetInheritedStyle | Gets the style applied to the cell.
Public Method | InitializeEditingControl | Initializes the control used to edit the cell.
Public Method | KeyEntersEditMode | Determines if edit mode should be started based on the given key.
Public Method | ParseFormattedValue |
Public Method | PositionEditingControl | Sets the location and size of the editing control hosted by a cell in the DataGridView control.
Public Method | PositionEditingPanel |
Public Method | ToString | Overridden. Returns a string that describes the current object.
Public Method | Update | Overloaded. Full updates of this instance. (Inherited from DataGridViewElement)
Top

Protected Methods

 | Name | Description
Protected Method | BorderWidths |
Protected Method | ClickUnsharesRow | Indicates whether the cell's row will be unshared when the cell is clicked.
Protected Method | ContentClickUnsharesRow | Indicates whether the cell's row will be unshared when the cell's content is clicked.
Protected Method | ContentDoubleClickUnsharesRow | Indicates whether the cell's row will be unshared when the cell's content is double-clicked.
Protected Method | DoubleClickUnsharesRow | Indicates whether the cell's row will be unshared when the cell is double-clicked.
Protected Method | EnterUnsharesRow | Indicates whether the parent row will be unshared when the focus moves to the cell.
Protected Method | GetClipboardContent | Retrieves the formatted value of the cell to copy to the Clipboard.
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from DataGridViewElement)
Protected Method | GetDefaultHorizontalAlignment | Gets the horizontal alignment.
Protected Method | GetDefaultVerticalAlignment | Gets the vertical alignment.
Protected Method | GetErrorIconBounds |
Protected Method | GetErrorText | Returns a string that represents the error for the cell.
Protected Method | GetFormattedValue | Gets the value of the cell as formatted for display.
Protected Method | GetPreferredSize | Overloaded. Calculates the preferred size, in pixels, of the cell.
Protected Method | GetSize | Gets the size of the cell.
Protected Method | GetValue | Gets the value of the cell.
Protected Method | IsDirty | Determines whether the specified component is dirty. (Inherited from DataGridViewElement)
Protected Method | IsDirtyAttributes | Overloaded. Determines whether the specified component is dirty. (Inherited from DataGridViewElement)
Protected Method | KeyDownUnsharesRow | Indicates whether the parent row is unshared if the user presses a key while the focus is on the cell.
Protected Method | KeyPressUnsharesRow | Indicates whether a row will be unshared if a key is pressed while a cell in the row has focus.
Protected Method | KeyUpUnsharesRow | Indicates whether the parent row is unshared when the user releases a key while the focus is on the cell.
Protected Method | LeaveUnsharesRow | Indicates whether a row will be unshared when the focus leaves a cell in the row.
Protected Method | MouseClickUnsharesRow | Indicates whether a row will be unshared if the user clicks a mouse button while the pointer is on a cell in the row.
Protected Method | MouseDoubleClickUnsharesRow | Indicates whether a row will be unshared if the user double-clicks a cell in the row.
Protected Method | MouseDownUnsharesRow | Indicates whether a row will be unshared when the user holds down a mouse button while the pointer is on a cell in the row.
Protected Method | MouseEnterUnsharesRow | Indicates whether a row will be unshared when the mouse pointer moves over a cell in the row.
Protected Method | MouseLeaveUnsharesRow | Indicates whether a row will be unshared when the mouse pointer leaves the row.
Protected Method | MouseMoveUnsharesRow | Indicates whether a row will be unshared when the mouse pointer moves over a cell in the row.
Protected Method | MouseUpUnsharesRow | Indicates whether a row will be unshared when the user releases a mouse button while the pointer is on a cell in the row.
Protected Method | OnClick | Called when the cell is clicked.
Protected Method | OnContentClick | Called when the cell's contents are clicked.
Protected Method | OnContentDoubleClick | Called when the cell's contents are double-clicked.
Protected Method | OnDataGridViewChanged | Overridden. Called when the DataGridViewElement.DataGridView property of the cell changes.
Protected Method | OnDoubleClick | Called when the cell is double-clicked.
Protected Method | OnEnter | Called when the focus moves to a cell.
Protected Method | OnKeyDown | Called when a character key is pressed while the focus is on a cell.
Protected Method | OnKeyPress | Called when a key is pressed while the focus is on a cell.
Protected Method | OnKeyUp | Called when a character key is released while the focus is on a cell.
Protected Method | OnLeave | Called when the focus moves from a cell.
Protected Method | OnMouseClick | Called when the user clicks a mouse button while the pointer is on a cell.
Protected Method | OnMouseDoubleClick | Called when the user double-clicks a mouse button while the pointer is on a cell.
Protected Method | OnMouseDown | Called when the user holds down a mouse button while the pointer is on a cell.
Protected Method | OnMouseEnter | Called when the mouse pointer moves over a cell.
Protected Method | OnMouseLeave | Called when the mouse pointer leaves the cell.
Protected Method | OnMouseMove | Called when the mouse pointer moves within a cell.
Protected Method | OnMouseUp | Called when the user releases a mouse button while the pointer is on a cell.
Protected Method | Paint |
Protected Method | PaintErrorIcon |
Protected Method | ProcessGatewayRequest |
Protected Method | RaiseCellClick | Raises the DataGridView.CellClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellContentClick | Raises the DataGridView.CellContentClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellContentDoubleClick | Raises the DataGridView.CellContentDoubleClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellValueChanged | Raises the CellValueChanged event. (Inherited from DataGridViewElement)
Protected Method | RaiseDataError | Raises the DataError event. (Inherited from DataGridViewElement)
Protected Method | RaiseMouseWheel | Raises the MouseWheel event. (Inherited from DataGridViewElement)
Protected Method | RenderAttributes | Overridden.
Protected Method | RenderBackColorAttribute | Renders the back color attribute.
Protected Method | RenderComponent | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from DataGridViewElement)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from DataGridViewElement)
Protected Method | RenderComponents | Renders the controls sub tree (Inherited from DataGridViewElement)
Protected Method | RenderForeColorAttribute | Renders the fore color attribute.
Protected Method | RenderReadOnlyAttribute | Renders the read only attribute.
Protected Method | RenderUpdatedAttributes | Renders the updated attributes (Inherited from DataGridViewElement)
Protected Method | RenderWrapModeAttribute | Renders the wrap mode attribute.
Protected Method | SetValue | Sets the value of the cell.
Protected Method | UpdateParams | Overloaded. Updates only the parameters of this instance. (Inherited from DataGridViewElement)
Top

See Also

Reference

DataGridViewCell Class
Gizmox.WebGUI.Forms Namespace


DataGridViewCell Class Methods

[image]
Gizmox.WebGUI.Forms
DataGridViewCell Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewCell Class

For a list of all members of this type, see DataGridViewCell members.

Public Methods

 | Name | Description
Public Method | AdjustCellBorderStyle | Modifies the input cell border style according to the specified criteria.
Public Method | Clone | Creates an exact copy of this cell.
Public Method | DetachEditingControl | Removes the cell's editing control from the DataGridView.
Public Method | Dispose | Overloaded. Releases all resources used by the DataGridViewCell.
Public Method | GetContentBounds | Overloaded.
Public Method | GetEditedFormattedValue | Returns the current, formatted value of the cell, regardless of whether the cell is in edit mode and the value has not been committed.
Public Method | GetInheritedState | Returns a value indicating the current state of the cell as inherited from the state of its row and column.
Public Method | GetInheritedStyle | Gets the style applied to the cell.
Public Method | InitializeEditingControl | Initializes the control used to edit the cell.
Public Method | KeyEntersEditMode | Determines if edit mode should be started based on the given key.
Public Method | ParseFormattedValue |
Public Method | PositionEditingControl | Sets the location and size of the editing control hosted by a cell in the DataGridView control.
Public Method | PositionEditingPanel |
Public Method | ToString | Overridden. Returns a string that describes the current object.
Public Method | Update | Overloaded. Full updates of this instance. (Inherited from DataGridViewElement)
Top

Protected Methods

 | Name | Description
Protected Method | BorderWidths |
Protected Method | ClickUnsharesRow | Indicates whether the cell's row will be unshared when the cell is clicked.
Protected Method | ContentClickUnsharesRow | Indicates whether the cell's row will be unshared when the cell's content is clicked.
Protected Method | ContentDoubleClickUnsharesRow | Indicates whether the cell's row will be unshared when the cell's content is double-clicked.
Protected Method | DoubleClickUnsharesRow | Indicates whether the cell's row will be unshared when the cell is double-clicked.
Protected Method | EnterUnsharesRow | Indicates whether the parent row will be unshared when the focus moves to the cell.
Protected Method | GetClipboardContent | Retrieves the formatted value of the cell to copy to the Clipboard.
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from DataGridViewElement)
Protected Method | GetDefaultHorizontalAlignment | Gets the horizontal alignment.
Protected Method | GetDefaultVerticalAlignment | Gets the vertical alignment.
Protected Method | GetErrorIconBounds |
Protected Method | GetErrorText | Returns a string that represents the error for the cell.
Protected Method | GetFormattedValue | Gets the value of the cell as formatted for display.
Protected Method | GetPreferredSize | Overloaded. Calculates the preferred size, in pixels, of the cell.
Protected Method | GetSize | Gets the size of the cell.
Protected Method | GetValue | Gets the value of the cell.
Protected Method | IsDirty | Determines whether the specified component is dirty. (Inherited from DataGridViewElement)
Protected Method | IsDirtyAttributes | Overloaded. Determines whether the specified component is dirty. (Inherited from DataGridViewElement)
Protected Method | KeyDownUnsharesRow | Indicates whether the parent row is unshared if the user presses a key while the focus is on the cell.
Protected Method | KeyPressUnsharesRow | Indicates whether a row will be unshared if a key is pressed while a cell in the row has focus.
Protected Method | KeyUpUnsharesRow | Indicates whether the parent row is unshared when the user releases a key while the focus is on the cell.
Protected Method | LeaveUnsharesRow | Indicates whether a row will be unshared when the focus leaves a cell in the row.
Protected Method | MouseClickUnsharesRow | Indicates whether a row will be unshared if the user clicks a mouse button while the pointer is on a cell in the row.
Protected Method | MouseDoubleClickUnsharesRow | Indicates whether a row will be unshared if the user double-clicks a cell in the row.
Protected Method | MouseDownUnsharesRow | Indicates whether a row will be unshared when the user holds down a mouse button while the pointer is on a cell in the row.
Protected Method | MouseEnterUnsharesRow | Indicates whether a row will be unshared when the mouse pointer moves over a cell in the row.
Protected Method | MouseLeaveUnsharesRow | Indicates whether a row will be unshared when the mouse pointer leaves the row.
Protected Method | MouseMoveUnsharesRow | Indicates whether a row will be unshared when the mouse pointer moves over a cell in the row.
Protected Method | MouseUpUnsharesRow | Indicates whether a row will be unshared when the user releases a mouse button while the pointer is on a cell in the row.
Protected Method | OnClick | Called when the cell is clicked.
Protected Method | OnContentClick | Called when the cell's contents are clicked.
Protected Method | OnContentDoubleClick | Called when the cell's contents are double-clicked.
Protected Method | OnDataGridViewChanged | Overridden. Called when the DataGridViewElement.DataGridView property of the cell changes.
Protected Method | OnDoubleClick | Called when the cell is double-clicked.
Protected Method | OnEnter | Called when the focus moves to a cell.
Protected Method | OnKeyDown | Called when a character key is pressed while the focus is on a cell.
Protected Method | OnKeyPress | Called when a key is pressed while the focus is on a cell.
Protected Method | OnKeyUp | Called when a character key is released while the focus is on a cell.
Protected Method | OnLeave | Called when the focus moves from a cell.
Protected Method | OnMouseClick | Called when the user clicks a mouse button while the pointer is on a cell.
Protected Method | OnMouseDoubleClick | Called when the user double-clicks a mouse button while the pointer is on a cell.
Protected Method | OnMouseDown | Called when the user holds down a mouse button while the pointer is on a cell.
Protected Method | OnMouseEnter | Called when the mouse pointer moves over a cell.
Protected Method | OnMouseLeave | Called when the mouse pointer leaves the cell.
Protected Method | OnMouseMove | Called when the mouse pointer moves within a cell.
Protected Method | OnMouseUp | Called when the user releases a mouse button while the pointer is on a cell.
Protected Method | Paint |
Protected Method | PaintErrorIcon |
Protected Method | ProcessGatewayRequest |
Protected Method | RaiseCellClick | Raises the DataGridView.CellClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellContentClick | Raises the DataGridView.CellContentClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellContentDoubleClick | Raises the DataGridView.CellContentDoubleClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellValueChanged | Raises the CellValueChanged event. (Inherited from DataGridViewElement)
Protected Method | RaiseDataError | Raises the DataError event. (Inherited from DataGridViewElement)
Protected Method | RaiseMouseWheel | Raises the MouseWheel event. (Inherited from DataGridViewElement)
Protected Method | RenderAttributes | Overridden.
Protected Method | RenderBackColorAttribute | Renders the back color attribute.
Protected Method | RenderComponent | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from DataGridViewElement)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from DataGridViewElement)
Protected Method | RenderComponents | Renders the controls sub tree (Inherited from DataGridViewElement)
Protected Method | RenderForeColorAttribute | Renders the fore color attribute.
Protected Method | RenderReadOnlyAttribute | Renders the read only attribute.
Protected Method | RenderUpdatedAttributes | Renders the updated attributes (Inherited from DataGridViewElement)
Protected Method | RenderWrapModeAttribute | Renders the wrap mode attribute.
Protected Method | SetValue | Sets the value of the cell.
Protected Method | UpdateParams | Overloaded. Updates only the parameters of this instance. (Inherited from DataGridViewElement)
Top

See Also

Reference

DataGridViewCell Class
Gizmox.WebGUI.Forms Namespace


AdjustCellBorderStyle Method

[image]
Gizmox.WebGUI.Forms
AdjustCellBorderStyle Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : AdjustCellBorderStyle Method

dataGridViewAdvancedBorderStyleInput
A DataGridViewAdvancedBorderStyle that represents the cell border style to modify.
dataGridViewAdvancedBorderStylePlaceholder
A DataGridViewAdvancedBorderStyle that is used to store intermediate changes to the cell border style.
singleVerticalBorderAdded
true to add a vertical border to the cell; otherwise, false.
singleHorizontalBorderAdded
true to add a horizontal border to the cell; otherwise, false.
isFirstDisplayedColumn
true if the hosting cell is in the first visible column; otherwise, false.
isFirstDisplayedRow
true if the hosting cell is in the first visible row; otherwise, false.
Modifies the input cell border style according to the specified criteria.

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Overridable Function AdjustCellBorderStyle( _
   ByVal dataGridViewAdvancedBorderStyleInput As DataGridViewAdvancedBorderStyle, _
   ByVal dataGridViewAdvancedBorderStylePlaceholder As DataGridViewAdvancedBorderStyle, _
   ByVal singleVerticalBorderAdded As Boolean, _
   ByVal singleHorizontalBorderAdded As Boolean, _
   ByVal isFirstDisplayedColumn As Boolean, _
   ByVal isFirstDisplayedRow As Boolean _
) As DataGridViewAdvancedBorderStyle
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim dataGridViewAdvancedBorderStyleInput As DataGridViewAdvancedBorderStyle
Dim dataGridViewAdvancedBorderStylePlaceholder As DataGridViewAdvancedBorderStyle
Dim singleVerticalBorderAdded As Boolean
Dim singleHorizontalBorderAdded As Boolean
Dim isFirstDisplayedColumn As Boolean
Dim isFirstDisplayedRow As Boolean
Dim value As DataGridViewAdvancedBorderStyle

value = instance.AdjustCellBorderStyle(dataGridViewAdvancedBorderStyleInput, dataGridViewAdvancedBorderStylePlaceholder, singleVerticalBorderAdded, singleHorizontalBorderAdded, isFirstDisplayedColumn, isFirstDisplayedRow)
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public virtual DataGridViewAdvancedBorderStyle AdjustCellBorderStyle(
   DataGridViewAdvancedBorderStyle dataGridViewAdvancedBorderStyleInput,
   DataGridViewAdvancedBorderStyle dataGridViewAdvancedBorderStylePlaceholder,
   bool singleVerticalBorderAdded,
   bool singleHorizontalBorderAdded,
   bool isFirstDisplayedColumn,
   bool isFirstDisplayedRow
)
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: virtual DataGridViewAdvancedBorderStyle* AdjustCellBorderStyle(
   DataGridViewAdvancedBorderStyle* dataGridViewAdvancedBorderStyleInput,
   DataGridViewAdvancedBorderStyle* dataGridViewAdvancedBorderStylePlaceholder,
   bool singleVerticalBorderAdded,
   bool singleHorizontalBorderAdded,
   bool isFirstDisplayedColumn,
   bool isFirstDisplayedRow
)
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
virtual DataGridViewAdvancedBorderStyle^ AdjustCellBorderStyle(
   DataGridViewAdvancedBorderStyle^ dataGridViewAdvancedBorderStyleInput,
   DataGridViewAdvancedBorderStyle^ dataGridViewAdvancedBorderStylePlaceholder,
   bool singleVerticalBorderAdded,
   bool singleHorizontalBorderAdded,
   bool isFirstDisplayedColumn,
   bool isFirstDisplayedRow
)

Parameters

dataGridViewAdvancedBorderStyleInput
A DataGridViewAdvancedBorderStyle that represents the cell border style to modify.
dataGridViewAdvancedBorderStylePlaceholder
A DataGridViewAdvancedBorderStyle that is used to store intermediate changes to the cell border style.
singleVerticalBorderAdded
true to add a vertical border to the cell; otherwise, false.
singleHorizontalBorderAdded
true to add a horizontal border to the cell; otherwise, false.
isFirstDisplayedColumn
true if the hosting cell is in the first visible column; otherwise, false.
isFirstDisplayedRow
true if the hosting cell is in the first visible row; otherwise, false.

Return Value

The modified DataGridViewAdvancedBorderStyle.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


BorderWidths Method

[image]
Gizmox.WebGUI.Forms
BorderWidths Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : BorderWidths Method

advancedBorderStyle

Syntax

Visual Basic (Declaration)
Protected Overridable Function BorderWidths( _
   ByVal advancedBorderStyle As DataGridViewAdvancedBorderStyle _
) As Rectangle
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim advancedBorderStyle As DataGridViewAdvancedBorderStyle
Dim value As Rectangle

value = instance.BorderWidths(advancedBorderStyle)
C#
protected virtual Rectangle BorderWidths(
   DataGridViewAdvancedBorderStyle advancedBorderStyle
)
Managed Extensions for C++
protected: virtual Rectangle BorderWidths(
   DataGridViewAdvancedBorderStyle* advancedBorderStyle
)
C++/CLI
protected:
virtual Rectangle BorderWidths(
   DataGridViewAdvancedBorderStyle^ advancedBorderStyle
)

Parameters

advancedBorderStyle

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


ClickUnsharesRow Method

[image]
Gizmox.WebGUI.Forms
ClickUnsharesRow Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : ClickUnsharesRow Method

e
The DataGridViewCellEventArgs containing the data passed to the OnClick method.
Indicates whether the cell's row will be unshared when the cell is clicked.

Syntax

Visual Basic (Declaration)
Protected Overridable Function ClickUnsharesRow( _
   ByVal e As DataGridViewCellEventArgs _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim e As DataGridViewCellEventArgs
Dim value As Boolean

value = instance.ClickUnsharesRow(e)
C#
protected virtual bool ClickUnsharesRow(
   DataGridViewCellEventArgs e
)
Managed Extensions for C++
protected: virtual bool ClickUnsharesRow(
   DataGridViewCellEventArgs* e
)
C++/CLI
protected:
virtual bool ClickUnsharesRow(
   DataGridViewCellEventArgs^ e
)

Parameters

e
The DataGridViewCellEventArgs containing the data passed to the OnClick method.

Return Value

true if the row will be unshared, otherwise, false. The base DataGridViewCell class always returns false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


Clone Method

[image]
Gizmox.WebGUI.Forms
Clone Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : Clone Method

Creates an exact copy of this cell.

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()
Managed Extensions for C++
public: virtual Object* Clone();
C++/CLI
public:
virtual Object^ Clone();

Return Value

An Object that represents the cloned DataGridViewCell.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


ContentClickUnsharesRow Method

[image]
Gizmox.WebGUI.Forms
ContentClickUnsharesRow Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : ContentClickUnsharesRow Method

e
The DataGridViewCellEventArgs containing the data passed to the OnContentClick method.
Indicates whether the cell's row will be unshared when the cell's content is clicked.

Syntax

Visual Basic (Declaration)
Protected Overridable Function ContentClickUnsharesRow( _
   ByVal e As DataGridViewCellEventArgs _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim e As DataGridViewCellEventArgs
Dim value As Boolean

value = instance.ContentClickUnsharesRow(e)
C#
protected virtual bool ContentClickUnsharesRow(
   DataGridViewCellEventArgs e
)
Managed Extensions for C++
protected: virtual bool ContentClickUnsharesRow(
   DataGridViewCellEventArgs* e
)
C++/CLI
protected:
virtual bool ContentClickUnsharesRow(
   DataGridViewCellEventArgs^ e
)

Parameters

e
The DataGridViewCellEventArgs containing the data passed to the OnContentClick method.

Return Value

true if the row will be unshared, otherwise, false. The base DataGridViewCell class always returns false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


ContentDoubleClickUnsharesRow Method

[image]
Gizmox.WebGUI.Forms
ContentDoubleClickUnsharesRow Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : ContentDoubleClickUnsharesRow Method

e
The DataGridViewCellEventArgs containing the data passed to the OnContentDoubleClick method.
Indicates whether the cell's row will be unshared when the cell's content is double-clicked.

Syntax

Visual Basic (Declaration)
Protected Overridable Function ContentDoubleClickUnsharesRow( _
   ByVal e As DataGridViewCellEventArgs _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim e As DataGridViewCellEventArgs
Dim value As Boolean

value = instance.ContentDoubleClickUnsharesRow(e)
C#
protected virtual bool ContentDoubleClickUnsharesRow(
   DataGridViewCellEventArgs e
)
Managed Extensions for C++
protected: virtual bool ContentDoubleClickUnsharesRow(
   DataGridViewCellEventArgs* e
)
C++/CLI
protected:
virtual bool ContentDoubleClickUnsharesRow(
   DataGridViewCellEventArgs^ e
)

Parameters

e
The DataGridViewCellEventArgs containing the data passed to the OnContentDoubleClick method.

Return Value

true if the row will be unshared, otherwise, false. The base DataGridViewCell class always returns false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


DetachEditingControl Method

[image]
Gizmox.WebGUI.Forms
DetachEditingControl Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : DetachEditingControl Method

Removes the cell's editing control from the DataGridView.

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Overridable Sub DetachEditingControl()
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell

instance.DetachEditingControl()
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public virtual void DetachEditingControl()
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: virtual void DetachEditingControl();
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
virtual void DetachEditingControl();

Exceptions

Exception | Description
InvalidOperationException | This cell is not associated with a DataGridView.-or-The EditingControl property of the associated DataGridView has a value of null. This is the case, for example, when the control is not in edit mode.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


Dispose Method

[image]
Gizmox.WebGUI.Forms
Dispose Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : Dispose Method

Releases all resources used by the DataGridViewCell.

Overload List

Overload | Description
Dispose() | Releases all resources used by the DataGridViewCell.
Dispose(Boolean) | Releases the unmanaged resources used by the DataGridViewCell and optionally releases the managed resources.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


Dispose() Method

[image]
Gizmox.WebGUI.Forms
Dispose() Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class > Dispose Method : Dispose() Method

Releases all resources used by the DataGridViewCell.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell

instance.Dispose()
C#
public void Dispose()
Managed Extensions for C++
public: void Dispose();
C++/CLI
public:
void Dispose();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members
Overload List


Dispose(Boolean) Method

[image]
Gizmox.WebGUI.Forms
Dispose(Boolean) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class > Dispose Method : Dispose(Boolean) Method

disposing
true to release both managed and unmanaged resources; false to release only unmanaged resources.
Releases the unmanaged resources used by the DataGridViewCell and optionally releases the managed resources.

Syntax

Visual Basic (Declaration)
Protected Overloads Overridable Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected virtual void Dispose(
   bool disposing
)
Managed Extensions for C++
protected: virtual void Dispose(
   bool disposing
)
C++/CLI
protected:
virtual void Dispose(
   bool disposing
)

Parameters

disposing
true to release both managed and unmanaged resources; false to release only unmanaged resources.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members
Overload List


DoubleClickUnsharesRow Method

[image]
Gizmox.WebGUI.Forms
DoubleClickUnsharesRow Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : DoubleClickUnsharesRow Method

e
The DataGridViewCellEventArgs containing the data passed to the OnDoubleClick method.
Indicates whether the cell's row will be unshared when the cell is double-clicked.

Syntax

Visual Basic (Declaration)
Protected Overridable Function DoubleClickUnsharesRow( _
   ByVal e As DataGridViewCellEventArgs _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim e As DataGridViewCellEventArgs
Dim value As Boolean

value = instance.DoubleClickUnsharesRow(e)
C#
protected virtual bool DoubleClickUnsharesRow(
   DataGridViewCellEventArgs e
)
Managed Extensions for C++
protected: virtual bool DoubleClickUnsharesRow(
   DataGridViewCellEventArgs* e
)
C++/CLI
protected:
virtual bool DoubleClickUnsharesRow(
   DataGridViewCellEventArgs^ e
)

Parameters

e
The DataGridViewCellEventArgs containing the data passed to the OnDoubleClick method.

Return Value

true if the row will be unshared, otherwise, false. The base DataGridViewCell class always returns false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


EnterUnsharesRow Method

[image]
Gizmox.WebGUI.Forms
EnterUnsharesRow Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : EnterUnsharesRow Method

rowIndex
The index of the cell's parent row.
throughMouseClick
true if a user action moved focus to the cell; false if a programmatic operation moved focus to the cell.
Indicates whether the parent row will be unshared when the focus moves to the cell.

Syntax

Visual Basic (Declaration)
Protected Overridable Function EnterUnsharesRow( _
   ByVal rowIndex As Integer, _
   ByVal throughMouseClick As Boolean _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim rowIndex As Integer
Dim throughMouseClick As Boolean
Dim value As Boolean

value = instance.EnterUnsharesRow(rowIndex, throughMouseClick)
C#
protected virtual bool EnterUnsharesRow(
   int rowIndex,
   bool throughMouseClick
)
Managed Extensions for C++
protected: virtual bool EnterUnsharesRow(
   int rowIndex,
   bool throughMouseClick
)
C++/CLI
protected:
virtual bool EnterUnsharesRow(
   int rowIndex,
   bool throughMouseClick
)

Parameters

rowIndex
The index of the cell's parent row.
throughMouseClick
true if a user action moved focus to the cell; false if a programmatic operation moved focus to the cell.

Return Value

true if the row will be unshared; otherwise, false. The base DataGridViewCell class always returns false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


GetClipboardContent Method

[image]
Gizmox.WebGUI.Forms
GetClipboardContent Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : GetClipboardContent Method

rowIndex
The zero-based index of the row containing the cell.
firstCell
true to indicate that the cell is in the first column of the region defined by the selected cells; otherwise, false.
lastCell
true to indicate that the cell is the last column of the region defined by the selected cells; otherwise, false.
inFirstRow
true to indicate that the cell is in the first row of the region defined by the selected cells; otherwise, false.
inLastRow
true to indicate that the cell is in the last row of the region defined by the selected cells; otherwise, false.
format
The current format string of the cell.
Retrieves the formatted value of the cell to copy to the Clipboard.

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetClipboardContent( _
   ByVal rowIndex As Integer, _
   ByVal firstCell As Boolean, _
   ByVal lastCell As Boolean, _
   ByVal inFirstRow As Boolean, _
   ByVal inLastRow As Boolean, _
   ByVal format As String _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim rowIndex As Integer
Dim firstCell As Boolean
Dim lastCell As Boolean
Dim inFirstRow As Boolean
Dim inLastRow As Boolean
Dim format As String
Dim value As Object

value = instance.GetClipboardContent(rowIndex, firstCell, lastCell, inFirstRow, inLastRow, format)
C#
protected virtual object GetClipboardContent(
   int rowIndex,
   bool firstCell,
   bool lastCell,
   bool inFirstRow,
   bool inLastRow,
   string format
)
Managed Extensions for C++
protected: virtual Object* GetClipboardContent(
   int rowIndex,
   bool firstCell,
   bool lastCell,
   bool inFirstRow,
   bool inLastRow,
   string* format
)
C++/CLI
protected:
virtual Object^ GetClipboardContent(
   int rowIndex,
   bool firstCell,
   bool lastCell,
   bool inFirstRow,
   bool inLastRow,
   String^ format
)

Parameters

rowIndex
The zero-based index of the row containing the cell.
firstCell
true to indicate that the cell is in the first column of the region defined by the selected cells; otherwise, false.
lastCell
true to indicate that the cell is the last column of the region defined by the selected cells; otherwise, false.
inFirstRow
true to indicate that the cell is in the first row of the region defined by the selected cells; otherwise, false.
inLastRow
true to indicate that the cell is in the last row of the region defined by the selected cells; otherwise, false.
format
The current format string of the cell.

Return Value

An Object that represents the value of the cell to copy to the Clipboard.

Exceptions

Exception | Description
ArgumentOutOfRangeException | rowIndex is less than 0 or greater than or equal to the number of rows in the control.
Exception | Formatting failed and either there is no handler for the DataError event of the DataGridView control or the handler set the DataGridViewDataErrorEventArgs.ThrowException property to true. The exception object can typically be cast to type FormatException.
InvalidOperationException | The value of the cell's DataGridViewElement.DataGridView property is null.-or-DataGridViewCell.ColumnIndex is less than 0, indicating that the cell is a row header cell.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


GetContentBounds Method

[image]
Gizmox.WebGUI.Forms
GetContentBounds Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : GetContentBounds Method

Overload List

Overload | Description
GetContentBounds(Int32) |
GetContentBounds(Graphics,DataGridViewCellStyle,Int32) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


GetContentBounds(Int32) Method

[image]
Gizmox.WebGUI.Forms
GetContentBounds(Int32) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class > GetContentBounds Method : GetContentBounds(Int32) Method

rowIndex

Syntax

Visual Basic (Declaration)
Public Overloads Function GetContentBounds( _
   ByVal rowIndex As Integer _
) As Rectangle
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim rowIndex As Integer
Dim value As Rectangle

value = instance.GetContentBounds(rowIndex)
C#
public Rectangle GetContentBounds(
   int rowIndex
)
Managed Extensions for C++
public: Rectangle GetContentBounds(
   int rowIndex
)
C++/CLI
public:
Rectangle GetContentBounds(
   int rowIndex
)

Parameters

rowIndex

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members
Overload List


GetContentBounds(Graphics,DataGridViewCellStyle,Int32) Method

[image]
Gizmox.WebGUI.Forms
GetContentBounds(Graphics,DataGridViewCellStyle,Int32) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class > GetContentBounds Method : GetContentBounds(Graphics,DataGridViewCellStyle,Int32) Method

graphics
cellStyle
rowIndex

Syntax

Visual Basic (Declaration)
Protected Overloads Overridable Function GetContentBounds( _
   ByVal graphics As Graphics, _
   ByVal cellStyle As DataGridViewCellStyle, _
   ByVal rowIndex As Integer _
) As Rectangle
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim graphics As Graphics
Dim cellStyle As DataGridViewCellStyle
Dim rowIndex As Integer
Dim value As Rectangle

value = instance.GetContentBounds(graphics, cellStyle, rowIndex)
C#
protected virtual Rectangle GetContentBounds(
   Graphics graphics,
   DataGridViewCellStyle cellStyle,
   int rowIndex
)
Managed Extensions for C++
protected: virtual Rectangle GetContentBounds(
   Graphics* graphics,
   DataGridViewCellStyle* cellStyle,
   int rowIndex
)
C++/CLI
protected:
virtual Rectangle GetContentBounds(
   Graphics^ graphics,
   DataGridViewCellStyle^ cellStyle,
   int rowIndex
)

Parameters

graphics
cellStyle
rowIndex

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members
Overload List


GetDefaultHorizontalAlignment Method

[image]
Gizmox.WebGUI.Forms
GetDefaultHorizontalAlignment Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : GetDefaultHorizontalAlignment Method

Gets the horizontal alignment.

Syntax

Visual Basic (Declaration)
Protected Function GetDefaultHorizontalAlignment() As String
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim value As String

value = instance.GetDefaultHorizontalAlignment()
C#
protected string GetDefaultHorizontalAlignment()
Managed Extensions for C++
protected: string* GetDefaultHorizontalAlignment();
C++/CLI
protected:
String^ GetDefaultHorizontalAlignment();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


GetDefaultVerticalAlignment Method

[image]
Gizmox.WebGUI.Forms
GetDefaultVerticalAlignment Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : GetDefaultVerticalAlignment Method

Gets the vertical alignment.

Syntax

Visual Basic (Declaration)
Protected Function GetDefaultVerticalAlignment() As String
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim value As String

value = instance.GetDefaultVerticalAlignment()
C#
protected string GetDefaultVerticalAlignment()
Managed Extensions for C++
protected: string* GetDefaultVerticalAlignment();
C++/CLI
protected:
String^ GetDefaultVerticalAlignment();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


GetEditedFormattedValue Method

[image]
Gizmox.WebGUI.Forms
GetEditedFormattedValue Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : GetEditedFormattedValue Method

rowIndex
The row index of the cell.
context
A bitwise combination of DataGridViewDataErrorContexts values that specifies the data error context.
Returns the current, formatted value of the cell, regardless of whether the cell is in edit mode and the value has not been committed.

Syntax

Visual Basic (Declaration)
Public Function GetEditedFormattedValue( _
   ByVal rowIndex As Integer, _
   ByVal context As DataGridViewDataErrorContexts _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim rowIndex As Integer
Dim context As DataGridViewDataErrorContexts
Dim value As Object

value = instance.GetEditedFormattedValue(rowIndex, context)
C#
public object GetEditedFormattedValue(
   int rowIndex,
   DataGridViewDataErrorContexts context
)
Managed Extensions for C++
public: Object* GetEditedFormattedValue(
   int rowIndex,
   DataGridViewDataErrorContexts context
)
C++/CLI
public:
Object^ GetEditedFormattedValue(
   int rowIndex,
   DataGridViewDataErrorContexts context
)

Parameters

rowIndex
The row index of the cell.
context
A bitwise combination of DataGridViewDataErrorContexts values that specifies the data error context.

Return Value

The current, formatted value of the DataGridViewCell.

Exceptions

Exception | Description
Exception | Formatting failed and either there is no handler for the DataError event of the DataGridView control or the handler set the DataGridViewDataErrorEventArgs.ThrowException property to true. The exception object can typically be cast to type FormatException.
ArgumentOutOfRangeException | The specified rowIndex is less than 0 or greater than the number of rows in the control minus 1.
InvalidOperationException | DataGridViewCell.ColumnIndex is less than 0, indicating that the cell is a row header cell.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


GetErrorIconBounds Method

[image]
Gizmox.WebGUI.Forms
GetErrorIconBounds Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : GetErrorIconBounds Method

graphics
cellStyle
rowIndex

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetErrorIconBounds( _
   ByVal graphics As Graphics, _
   ByVal cellStyle As DataGridViewCellStyle, _
   ByVal rowIndex As Integer _
) As Rectangle
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim graphics As Graphics
Dim cellStyle As DataGridViewCellStyle
Dim rowIndex As Integer
Dim value As Rectangle

value = instance.GetErrorIconBounds(graphics, cellStyle, rowIndex)
C#
protected virtual Rectangle GetErrorIconBounds(
   Graphics graphics,
   DataGridViewCellStyle cellStyle,
   int rowIndex
)
Managed Extensions for C++
protected: virtual Rectangle GetErrorIconBounds(
   Graphics* graphics,
   DataGridViewCellStyle* cellStyle,
   int rowIndex
)
C++/CLI
protected:
virtual Rectangle GetErrorIconBounds(
   Graphics^ graphics,
   DataGridViewCellStyle^ cellStyle,
   int rowIndex
)

Parameters

graphics
cellStyle
rowIndex

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


GetErrorText Method

[image]
Gizmox.WebGUI.Forms
GetErrorText Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : GetErrorText Method

rowIndex
The row index of the cell.
Returns a string that represents the error for the cell.

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetErrorText( _
   ByVal rowIndex As Integer _
) As String
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim rowIndex As Integer
Dim value As String

value = instance.GetErrorText(rowIndex)
C#
protected virtual string GetErrorText(
   int rowIndex
)
Managed Extensions for C++
protected: virtual string* GetErrorText(
   int rowIndex
)
C++/CLI
protected:
virtual String^ GetErrorText(
   int rowIndex
)

Parameters

rowIndex
The row index of the cell.

Return Value

A string that describes the error for the current DataGridViewCell.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


GetFormattedValue Method

[image]
Gizmox.WebGUI.Forms
GetFormattedValue Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : GetFormattedValue Method

value
The value to be formatted.
rowIndex
The index of the cell's parent row.
cellStyle
The DataGridViewCellStyle in effect for the cell.
valueTypeConverter
A TypeConverter associated with the value type that provides custom conversion to the formatted value type, or null if no such custom conversion is needed.
formattedValueTypeConverter
A TypeConverter associated with the formatted value type that provides custom conversion from the value type, or null if no such custom conversion is needed.
context
A bitwise combination of DataGridViewDataErrorContexts values describing the context in which the formatted value is needed.
Gets the value of the cell as formatted for display.

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetFormattedValue( _
   ByVal value As Object, _
   ByVal rowIndex As Integer, _
   ByRef cellStyle As DataGridViewCellStyle, _
   ByVal valueTypeConverter As TypeConverter, _
   ByVal formattedValueTypeConverter As TypeConverter, _
   ByVal context As DataGridViewDataErrorContexts _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim value As Object
Dim rowIndex As Integer
Dim cellStyle As DataGridViewCellStyle
Dim valueTypeConverter As TypeConverter
Dim formattedValueTypeConverter As TypeConverter
Dim context As DataGridViewDataErrorContexts
Dim value As Object

value = instance.GetFormattedValue(value, rowIndex, cellStyle, valueTypeConverter, formattedValueTypeConverter, context)
C#
protected virtual object GetFormattedValue(
   object value,
   int rowIndex,
   ref DataGridViewCellStyle cellStyle,
   TypeConverter valueTypeConverter,
   TypeConverter formattedValueTypeConverter,
   DataGridViewDataErrorContexts context
)
Managed Extensions for C++
protected: virtual Object* GetFormattedValue(
   Object* value,
   int rowIndex,
   ref DataGridViewCellStyle* cellStyle,
   TypeConverter* valueTypeConverter,
   TypeConverter* formattedValueTypeConverter,
   DataGridViewDataErrorContexts context
)
C++/CLI
protected:
virtual Object^ GetFormattedValue(
   Object^ value,
   int rowIndex,
   DataGridViewCellStyle^% cellStyle,
   TypeConverter^ valueTypeConverter,
   TypeConverter^ formattedValueTypeConverter,
   DataGridViewDataErrorContexts context
)

Parameters

value
The value to be formatted.
rowIndex
The index of the cell's parent row.
cellStyle
The DataGridViewCellStyle in effect for the cell.
valueTypeConverter
A TypeConverter associated with the value type that provides custom conversion to the formatted value type, or null if no such custom conversion is needed.
formattedValueTypeConverter
A TypeConverter associated with the formatted value type that provides custom conversion from the value type, or null if no such custom conversion is needed.
context
A bitwise combination of DataGridViewDataErrorContexts values describing the context in which the formatted value is needed.

Return Value

The formatted value of the cell or null if the cell does not belong to a DataGridView control.

Exceptions

Exception | Description
Exception | Formatting failed and either there is no handler for the DataError event of the DataGridView control or the handler set the DataGridViewDataErrorEventArgs.ThrowException property to true. The exception object can typically be cast to type FormatException.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


GetInheritedState Method

[image]
Gizmox.WebGUI.Forms
GetInheritedState Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : GetInheritedState Method

rowIndex
The index of the row containing the cell.
Returns a value indicating the current state of the cell as inherited from the state of its row and column.

Syntax

Visual Basic (Declaration)
Public Overridable Function GetInheritedState( _
   ByVal rowIndex As Integer _
) As DataGridViewElementStates
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim rowIndex As Integer
Dim value As DataGridViewElementStates

value = instance.GetInheritedState(rowIndex)
C#
public virtual DataGridViewElementStates GetInheritedState(
   int rowIndex
)
Managed Extensions for C++
public: virtual DataGridViewElementStates GetInheritedState(
   int rowIndex
)
C++/CLI
public:
virtual DataGridViewElementStates GetInheritedState(
   int rowIndex
)

Parameters

rowIndex
The index of the row containing the cell.

Return Value

A bitwise combination of DataGridViewElementStates values representing the current state of the cell.

Exceptions

Exception | Description
ArgumentOutOfRangeException | The cell is contained within a DataGridView control and rowIndex is outside the valid range of 0 to the number of rows in the control minus 1.
ArgumentException | The cell is not contained within a DataGridView control and rowIndex is not -1.-or-rowIndex is not the index of the row containing this cell.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


GetInheritedStyle Method

[image]
Gizmox.WebGUI.Forms
GetInheritedStyle Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : GetInheritedStyle Method

inheritedCellStyle
A DataGridViewCellStyle to be populated with the inherited cell style.
rowIndex
The index of the cell's parent row.
includeColors
true to include inherited colors in the returned cell style; otherwise, false.
Gets the style applied to the cell.

Syntax

Visual Basic (Declaration)
Public Overridable Function GetInheritedStyle( _
   ByVal inheritedCellStyle As DataGridViewCellStyle, _
   ByVal rowIndex As Integer, _
   ByVal includeColors As Boolean _
) As DataGridViewCellStyle
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim inheritedCellStyle As DataGridViewCellStyle
Dim rowIndex As Integer
Dim includeColors As Boolean
Dim value As DataGridViewCellStyle

value = instance.GetInheritedStyle(inheritedCellStyle, rowIndex, includeColors)
C#
public virtual DataGridViewCellStyle GetInheritedStyle(
   DataGridViewCellStyle inheritedCellStyle,
   int rowIndex,
   bool includeColors
)
Managed Extensions for C++
public: virtual DataGridViewCellStyle* GetInheritedStyle(
   DataGridViewCellStyle* inheritedCellStyle,
   int rowIndex,
   bool includeColors
)
C++/CLI
public:
virtual DataGridViewCellStyle^ GetInheritedStyle(
   DataGridViewCellStyle^ inheritedCellStyle,
   int rowIndex,
   bool includeColors
)

Parameters

inheritedCellStyle
A DataGridViewCellStyle to be populated with the inherited cell style.
rowIndex
The index of the cell's parent row.
includeColors
true to include inherited colors in the returned cell style; otherwise, false.

Return Value

A DataGridViewCellStyle that includes the style settings of the cell inherited from the cell's parent row, column, and DataGridView.

Exceptions

Exception | Description
ArgumentOutOfRangeException | rowIndex is less than 0, or greater than or equal to the number of rows in the parent DataGridView.
InvalidOperationException | The cell has no associated DataGridView.-or-DataGridViewCell.ColumnIndex is less than 0, indicating that the cell is a row header cell.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


GetPreferredSize Method

[image]
Gizmox.WebGUI.Forms
GetPreferredSize Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : GetPreferredSize Method

Calculates the preferred size, in pixels, of the cell.

Overload List

Overload | Description
GetPreferredSize(String,DataGridViewCellStyle) | Calculates the preferred size, in pixels, of the cell.
GetPreferredSize(Graphics,DataGridViewCellStyle,Int32,Size) | Calculates the preferred size, in pixels, of the cell.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


GetPreferredSize(String,DataGridViewCellStyle) Method

[image]
Gizmox.WebGUI.Forms
GetPreferredSize(String,DataGridViewCellStyle) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class > GetPreferredSize Method : GetPreferredSize(String,DataGridViewCellStyle) Method

strText
The text to be measured.
cellStyle
A DataGridViewCellStyle that represents the style of the cell.
Calculates the preferred size, in pixels, of the cell.

Syntax

Visual Basic (Declaration)
Protected Overloads Overridable Function GetPreferredSize( _
   ByVal strText As String, _
   ByVal cellStyle As DataGridViewCellStyle _
) As Size
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim strText As String
Dim cellStyle As DataGridViewCellStyle
Dim value As Size

value = instance.GetPreferredSize(strText, cellStyle)
C#
protected virtual Size GetPreferredSize(
   string strText,
   DataGridViewCellStyle cellStyle
)
Managed Extensions for C++
protected: virtual Size GetPreferredSize(
   string* strText,
   DataGridViewCellStyle* cellStyle
)
C++/CLI
protected:
virtual Size GetPreferredSize(
   String^ strText,
   DataGridViewCellStyle^ cellStyle
)

Parameters

strText
The text to be measured.
cellStyle
A DataGridViewCellStyle that represents the style of the cell.

Return Value

A Size that represents the preferred size, in pixels, of the cell.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members
Overload List


GetPreferredSize(Graphics,DataGridViewCellStyle,Int32,Size) Method

[image]
Gizmox.WebGUI.Forms
GetPreferredSize(Graphics,DataGridViewCellStyle,Int32,Size) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class > GetPreferredSize Method : GetPreferredSize(Graphics,DataGridViewCellStyle,Int32,Size) Method

graphics
The Graphics used to draw the cell.
cellStyle
A DataGridViewCellStyle that represents the style of the cell.
rowIndex
The zero-based row index of the cell.
constraintSize
The cell's maximum allowable size.
Calculates the preferred size, in pixels, of the cell.

Syntax

Visual Basic (Declaration)
Protected Overloads Overridable Function GetPreferredSize( _
   ByVal graphics As Graphics, _
   ByVal cellStyle As DataGridViewCellStyle, _
   ByVal rowIndex As Integer, _
   ByVal constraintSize As Size _
) As Size
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim graphics As Graphics
Dim cellStyle As DataGridViewCellStyle
Dim rowIndex As Integer
Dim constraintSize As Size
Dim value As Size

value = instance.GetPreferredSize(graphics, cellStyle, rowIndex, constraintSize)
C#
protected virtual Size GetPreferredSize(
   Graphics graphics,
   DataGridViewCellStyle cellStyle,
   int rowIndex,
   Size constraintSize
)
Managed Extensions for C++
protected: virtual Size GetPreferredSize(
   Graphics* graphics,
   DataGridViewCellStyle* cellStyle,
   int rowIndex,
   Size constraintSize
)
C++/CLI
protected:
virtual Size GetPreferredSize(
   Graphics^ graphics,
   DataGridViewCellStyle^ cellStyle,
   int rowIndex,
   Size constraintSize
)

Parameters

graphics
The Graphics used to draw the cell.
cellStyle
A DataGridViewCellStyle that represents the style of the cell.
rowIndex
The zero-based row index of the cell.
constraintSize
The cell's maximum allowable size.

Return Value

A Size that represents the preferred size, in pixels, of the cell.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members
Overload List


GetSize Method

[image]
Gizmox.WebGUI.Forms
GetSize Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : GetSize Method

rowIndex
The index of the cell's parent row.
Gets the size of the cell.

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetSize( _
   ByVal rowIndex As Integer _
) As Size
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim rowIndex As Integer
Dim value As Size

value = instance.GetSize(rowIndex)
C#
protected virtual Size GetSize(
   int rowIndex
)
Managed Extensions for C++
protected: virtual Size GetSize(
   int rowIndex
)
C++/CLI
protected:
virtual Size GetSize(
   int rowIndex
)

Parameters

rowIndex
The index of the cell's parent row.

Return Value

A Size representing the cell's dimensions.

Exceptions

Exception | Description
InvalidOperationException | rowIndex is -1

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


GetValue Method

[image]
Gizmox.WebGUI.Forms
GetValue Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : GetValue Method

rowIndex
The index of the cell's parent row.
Gets the value of the cell.

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetValue( _
   ByVal rowIndex As Integer _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim rowIndex As Integer
Dim value As Object

value = instance.GetValue(rowIndex)
C#
protected virtual object GetValue(
   int rowIndex
)
Managed Extensions for C++
protected: virtual Object* GetValue(
   int rowIndex
)
C++/CLI
protected:
virtual Object^ GetValue(
   int rowIndex
)

Parameters

rowIndex
The index of the cell's parent row.

Return Value

The value contained in the DataGridViewCell.

Exceptions

Exception | Description
ArgumentOutOfRangeException | The value of the DataGridViewElement.DataGridView property of the cell is not null and rowIndex is less than 0 or greater than or equal to the number of rows in the parent DataGridView.
InvalidOperationException | The value of the DataGridViewElement.DataGridView property of the cell is not null and the value of the DataGridViewCell.ColumnIndex property is less than 0, indicating that the cell is a row header cell.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


InitializeEditingControl Method

[image]
Gizmox.WebGUI.Forms
InitializeEditingControl Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : InitializeEditingControl Method

rowIndex
The zero-based row index of the cell's location.
initialFormattedValue
An Object that represents the value displayed by the cell when editing is started.
dataGridViewCellStyle
A DataGridViewCellStyle that represents the style of the cell.
Initializes the control used to edit the cell.

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Overridable Sub InitializeEditingControl( _
   ByVal rowIndex As Integer, _
   ByVal initialFormattedValue As Object, _
   ByVal dataGridViewCellStyle As DataGridViewCellStyle _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim rowIndex As Integer
Dim initialFormattedValue As Object
Dim dataGridViewCellStyle As DataGridViewCellStyle

instance.InitializeEditingControl(rowIndex, initialFormattedValue, dataGridViewCellStyle)
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public virtual void InitializeEditingControl(
   int rowIndex,
   object initialFormattedValue,
   DataGridViewCellStyle dataGridViewCellStyle
)
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: virtual void InitializeEditingControl(
   int rowIndex,
   Object* initialFormattedValue,
   DataGridViewCellStyle* dataGridViewCellStyle
)
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
virtual void InitializeEditingControl(
   int rowIndex,
   Object^ initialFormattedValue,
   DataGridViewCellStyle^ dataGridViewCellStyle
)

Parameters

rowIndex
The zero-based row index of the cell's location.
initialFormattedValue
An Object that represents the value displayed by the cell when editing is started.
dataGridViewCellStyle
A DataGridViewCellStyle that represents the style of the cell.

Exceptions

Exception | Description
InvalidOperationException | There is no associated DataGridView or if one is present, it does not have an associated editing control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


KeyDownUnsharesRow Method

[image]
Gizmox.WebGUI.Forms
KeyDownUnsharesRow Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : KeyDownUnsharesRow Method

e
A KeyEventArgs that contains the event data.
rowIndex
The index of the cell's parent row.
Indicates whether the parent row is unshared if the user presses a key while the focus is on the cell.

Syntax

Visual Basic (Declaration)
Protected Overridable Function KeyDownUnsharesRow( _
   ByVal e As KeyEventArgs, _
   ByVal rowIndex As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim e As KeyEventArgs
Dim rowIndex As Integer
Dim value As Boolean

value = instance.KeyDownUnsharesRow(e, rowIndex)
C#
protected virtual bool KeyDownUnsharesRow(
   KeyEventArgs e,
   int rowIndex
)
Managed Extensions for C++
protected: virtual bool KeyDownUnsharesRow(
   KeyEventArgs* e,
   int rowIndex
)
C++/CLI
protected:
virtual bool KeyDownUnsharesRow(
   KeyEventArgs^ e,
   int rowIndex
)

Parameters

e
A KeyEventArgs that contains the event data.
rowIndex
The index of the cell's parent row.

Return Value

true if the row will be unshared, otherwise, false. The base DataGridViewCell class always returns false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


KeyEntersEditMode Method

[image]
Gizmox.WebGUI.Forms
KeyEntersEditMode Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : KeyEntersEditMode Method

e
A KeyEventArgs that represents the key that was pressed.
Determines if edit mode should be started based on the given key.

Syntax

Visual Basic (Declaration)
Public Overridable Function KeyEntersEditMode( _
   ByVal e As KeyEventArgs _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim e As KeyEventArgs
Dim value As Boolean

value = instance.KeyEntersEditMode(e)
C#
public virtual bool KeyEntersEditMode(
   KeyEventArgs e
)
Managed Extensions for C++
public: virtual bool KeyEntersEditMode(
   KeyEventArgs* e
)
C++/CLI
public:
virtual bool KeyEntersEditMode(
   KeyEventArgs^ e
)

Parameters

e
A KeyEventArgs that represents the key that was pressed.

Return Value

true if edit mode should be started; otherwise, false. The default is false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


KeyPressUnsharesRow Method

[image]
Gizmox.WebGUI.Forms
KeyPressUnsharesRow Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : KeyPressUnsharesRow Method

e
A KeyPressEventArgs that contains the event data.
rowIndex
The index of the cell's parent row.
Indicates whether a row will be unshared if a key is pressed while a cell in the row has focus.

Syntax

Visual Basic (Declaration)
Protected Overridable Function KeyPressUnsharesRow( _
   ByVal e As KeyPressEventArgs, _
   ByVal rowIndex As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim e As KeyPressEventArgs
Dim rowIndex As Integer
Dim value As Boolean

value = instance.KeyPressUnsharesRow(e, rowIndex)
C#
protected virtual bool KeyPressUnsharesRow(
   KeyPressEventArgs e,
   int rowIndex
)
Managed Extensions for C++
protected: virtual bool KeyPressUnsharesRow(
   KeyPressEventArgs* e,
   int rowIndex
)
C++/CLI
protected:
virtual bool KeyPressUnsharesRow(
   KeyPressEventArgs^ e,
   int rowIndex
)

Parameters

e
A KeyPressEventArgs that contains the event data.
rowIndex
The index of the cell's parent row.

Return Value

true if the row will be unshared, otherwise, false. The base DataGridViewCell class always returns false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


KeyUpUnsharesRow Method

[image]
Gizmox.WebGUI.Forms
KeyUpUnsharesRow Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : KeyUpUnsharesRow Method

e
A KeyEventArgs that contains the event data.
rowIndex
The index of the cell's parent row.
Indicates whether the parent row is unshared when the user releases a key while the focus is on the cell.

Syntax

Visual Basic (Declaration)
Protected Overridable Function KeyUpUnsharesRow( _
   ByVal e As KeyEventArgs, _
   ByVal rowIndex As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim e As KeyEventArgs
Dim rowIndex As Integer
Dim value As Boolean

value = instance.KeyUpUnsharesRow(e, rowIndex)
C#
protected virtual bool KeyUpUnsharesRow(
   KeyEventArgs e,
   int rowIndex
)
Managed Extensions for C++
protected: virtual bool KeyUpUnsharesRow(
   KeyEventArgs* e,
   int rowIndex
)
C++/CLI
protected:
virtual bool KeyUpUnsharesRow(
   KeyEventArgs^ e,
   int rowIndex
)

Parameters

e
A KeyEventArgs that contains the event data.
rowIndex
The index of the cell's parent row.

Return Value

true if the row will be unshared, otherwise, false. The base DataGridViewCell class always returns false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


LeaveUnsharesRow Method

[image]
Gizmox.WebGUI.Forms
LeaveUnsharesRow Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : LeaveUnsharesRow Method

rowIndex
The index of the cell's parent row.
throughMouseClick
true if a user action moved focus to the cell; false if a programmatic operation moved focus to the cell.
Indicates whether a row will be unshared when the focus leaves a cell in the row.

Syntax

Visual Basic (Declaration)
Protected Overridable Function LeaveUnsharesRow( _
   ByVal rowIndex As Integer, _
   ByVal throughMouseClick As Boolean _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim rowIndex As Integer
Dim throughMouseClick As Boolean
Dim value As Boolean

value = instance.LeaveUnsharesRow(rowIndex, throughMouseClick)
C#
protected virtual bool LeaveUnsharesRow(
   int rowIndex,
   bool throughMouseClick
)
Managed Extensions for C++
protected: virtual bool LeaveUnsharesRow(
   int rowIndex,
   bool throughMouseClick
)
C++/CLI
protected:
virtual bool LeaveUnsharesRow(
   int rowIndex,
   bool throughMouseClick
)

Parameters

rowIndex
The index of the cell's parent row.
throughMouseClick
true if a user action moved focus to the cell; false if a programmatic operation moved focus to the cell.

Return Value

true if the row will be unshared, otherwise, false. The base DataGridViewCell class always returns false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


MouseClickUnsharesRow Method

[image]
Gizmox.WebGUI.Forms
MouseClickUnsharesRow Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : MouseClickUnsharesRow Method

e
A DataGridViewCellMouseEventArgs that contains the event data.
Indicates whether a row will be unshared if the user clicks a mouse button while the pointer is on a cell in the row.

Syntax

Visual Basic (Declaration)
Protected Overridable Function MouseClickUnsharesRow( _
   ByVal e As DataGridViewCellMouseEventArgs _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim e As DataGridViewCellMouseEventArgs
Dim value As Boolean

value = instance.MouseClickUnsharesRow(e)
C#
protected virtual bool MouseClickUnsharesRow(
   DataGridViewCellMouseEventArgs e
)
Managed Extensions for C++
protected: virtual bool MouseClickUnsharesRow(
   DataGridViewCellMouseEventArgs* e
)
C++/CLI
protected:
virtual bool MouseClickUnsharesRow(
   DataGridViewCellMouseEventArgs^ e
)

Parameters

e
A DataGridViewCellMouseEventArgs that contains the event data.

Return Value

true if the row will be unshared, otherwise, false. The base DataGridViewCell class always returns false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


MouseDoubleClickUnsharesRow Method

[image]
Gizmox.WebGUI.Forms
MouseDoubleClickUnsharesRow Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : MouseDoubleClickUnsharesRow Method

e
A DataGridViewCellMouseEventArgs that contains the event data.
Indicates whether a row will be unshared if the user double-clicks a cell in the row.

Syntax

Visual Basic (Declaration)
Protected Overridable Function MouseDoubleClickUnsharesRow( _
   ByVal e As DataGridViewCellMouseEventArgs _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim e As DataGridViewCellMouseEventArgs
Dim value As Boolean

value = instance.MouseDoubleClickUnsharesRow(e)
C#
protected virtual bool MouseDoubleClickUnsharesRow(
   DataGridViewCellMouseEventArgs e
)
Managed Extensions for C++
protected: virtual bool MouseDoubleClickUnsharesRow(
   DataGridViewCellMouseEventArgs* e
)
C++/CLI
protected:
virtual bool MouseDoubleClickUnsharesRow(
   DataGridViewCellMouseEventArgs^ e
)

Parameters

e
A DataGridViewCellMouseEventArgs that contains the event data.

Return Value

true if the row will be unshared, otherwise, false. The base DataGridViewCell class always returns false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


MouseDownUnsharesRow Method

[image]
Gizmox.WebGUI.Forms
MouseDownUnsharesRow Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : MouseDownUnsharesRow Method

e
A DataGridViewCellMouseEventArgs that contains the event data.
Indicates whether a row will be unshared when the user holds down a mouse button while the pointer is on a cell in the row.

Syntax

Visual Basic (Declaration)
Protected Overridable Function MouseDownUnsharesRow( _
   ByVal e As DataGridViewCellMouseEventArgs _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim e As DataGridViewCellMouseEventArgs
Dim value As Boolean

value = instance.MouseDownUnsharesRow(e)
C#
protected virtual bool MouseDownUnsharesRow(
   DataGridViewCellMouseEventArgs e
)
Managed Extensions for C++
protected: virtual bool MouseDownUnsharesRow(
   DataGridViewCellMouseEventArgs* e
)
C++/CLI
protected:
virtual bool MouseDownUnsharesRow(
   DataGridViewCellMouseEventArgs^ e
)

Parameters

e
A DataGridViewCellMouseEventArgs that contains the event data.

Return Value

true if the row will be unshared, otherwise, false. The base DataGridViewCell class always returns false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


MouseEnterUnsharesRow Method

[image]
Gizmox.WebGUI.Forms
MouseEnterUnsharesRow Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : MouseEnterUnsharesRow Method

rowIndex
The index of the cell's parent row.
Indicates whether a row will be unshared when the mouse pointer moves over a cell in the row.

Syntax

Visual Basic (Declaration)
Protected Overridable Function MouseEnterUnsharesRow( _
   ByVal rowIndex As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim rowIndex As Integer
Dim value As Boolean

value = instance.MouseEnterUnsharesRow(rowIndex)
C#
protected virtual bool MouseEnterUnsharesRow(
   int rowIndex
)
Managed Extensions for C++
protected: virtual bool MouseEnterUnsharesRow(
   int rowIndex
)
C++/CLI
protected:
virtual bool MouseEnterUnsharesRow(
   int rowIndex
)

Parameters

rowIndex
The index of the cell's parent row.

Return Value

true if the row will be unshared, otherwise, false. The base DataGridViewCell class always returns false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


MouseLeaveUnsharesRow Method

[image]
Gizmox.WebGUI.Forms
MouseLeaveUnsharesRow Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : MouseLeaveUnsharesRow Method

rowIndex
The index of the cell's parent row.
Indicates whether a row will be unshared when the mouse pointer leaves the row.

Syntax

Visual Basic (Declaration)
Protected Overridable Function MouseLeaveUnsharesRow( _
   ByVal rowIndex As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim rowIndex As Integer
Dim value As Boolean

value = instance.MouseLeaveUnsharesRow(rowIndex)
C#
protected virtual bool MouseLeaveUnsharesRow(
   int rowIndex
)
Managed Extensions for C++
protected: virtual bool MouseLeaveUnsharesRow(
   int rowIndex
)
C++/CLI
protected:
virtual bool MouseLeaveUnsharesRow(
   int rowIndex
)

Parameters

rowIndex
The index of the cell's parent row.

Return Value

true if the row will be unshared, otherwise, false. The base DataGridViewCell class always returns false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


MouseMoveUnsharesRow Method

[image]
Gizmox.WebGUI.Forms
MouseMoveUnsharesRow Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : MouseMoveUnsharesRow Method

e
A DataGridViewCellMouseEventArgs that contains the event data.
Indicates whether a row will be unshared when the mouse pointer moves over a cell in the row.

Syntax

Visual Basic (Declaration)
Protected Overridable Function MouseMoveUnsharesRow( _
   ByVal e As DataGridViewCellMouseEventArgs _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim e As DataGridViewCellMouseEventArgs
Dim value As Boolean

value = instance.MouseMoveUnsharesRow(e)
C#
protected virtual bool MouseMoveUnsharesRow(
   DataGridViewCellMouseEventArgs e
)
Managed Extensions for C++
protected: virtual bool MouseMoveUnsharesRow(
   DataGridViewCellMouseEventArgs* e
)
C++/CLI
protected:
virtual bool MouseMoveUnsharesRow(
   DataGridViewCellMouseEventArgs^ e
)

Parameters

e
A DataGridViewCellMouseEventArgs that contains the event data.

Return Value

true if the row will be unshared, otherwise, false. The base DataGridViewCell class always returns false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


MouseUpUnsharesRow Method

[image]
Gizmox.WebGUI.Forms
MouseUpUnsharesRow Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : MouseUpUnsharesRow Method

e
A DataGridViewCellMouseEventArgs that contains the event data.
Indicates whether a row will be unshared when the user releases a mouse button while the pointer is on a cell in the row.

Syntax

Visual Basic (Declaration)
Protected Overridable Function MouseUpUnsharesRow( _
   ByVal e As DataGridViewCellMouseEventArgs _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim e As DataGridViewCellMouseEventArgs
Dim value As Boolean

value = instance.MouseUpUnsharesRow(e)
C#
protected virtual bool MouseUpUnsharesRow(
   DataGridViewCellMouseEventArgs e
)
Managed Extensions for C++
protected: virtual bool MouseUpUnsharesRow(
   DataGridViewCellMouseEventArgs* e
)
C++/CLI
protected:
virtual bool MouseUpUnsharesRow(
   DataGridViewCellMouseEventArgs^ e
)

Parameters

e
A DataGridViewCellMouseEventArgs that contains the event data.

Return Value

true if the row will be unshared, otherwise, false. The base DataGridViewCell class always returns false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


OnClick Method

[image]
Gizmox.WebGUI.Forms
OnClick Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : OnClick Method

e
A DataGridViewCellEventArgs that contains the event data.
Called when the cell is clicked.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnClick( _
   ByVal e As DataGridViewCellEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim e As DataGridViewCellEventArgs

instance.OnClick(e)
C#
protected virtual void OnClick(
   DataGridViewCellEventArgs e
)
Managed Extensions for C++
protected: virtual void OnClick(
   DataGridViewCellEventArgs* e
)
C++/CLI
protected:
virtual void OnClick(
   DataGridViewCellEventArgs^ e
)

Parameters

e
A DataGridViewCellEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


OnContentClick Method

[image]
Gizmox.WebGUI.Forms
OnContentClick Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : OnContentClick Method

e
A DataGridViewCellEventArgs that contains the event data.
Called when the cell's contents are clicked.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnContentClick( _
   ByVal e As DataGridViewCellEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim e As DataGridViewCellEventArgs

instance.OnContentClick(e)
C#
protected virtual void OnContentClick(
   DataGridViewCellEventArgs e
)
Managed Extensions for C++
protected: virtual void OnContentClick(
   DataGridViewCellEventArgs* e
)
C++/CLI
protected:
virtual void OnContentClick(
   DataGridViewCellEventArgs^ e
)

Parameters

e
A DataGridViewCellEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


OnContentDoubleClick Method

[image]
Gizmox.WebGUI.Forms
OnContentDoubleClick Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : OnContentDoubleClick Method

e
A DataGridViewCellEventArgs that contains the event data.
Called when the cell's contents are double-clicked.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnContentDoubleClick( _
   ByVal e As DataGridViewCellEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim e As DataGridViewCellEventArgs

instance.OnContentDoubleClick(e)
C#
protected virtual void OnContentDoubleClick(
   DataGridViewCellEventArgs e
)
Managed Extensions for C++
protected: virtual void OnContentDoubleClick(
   DataGridViewCellEventArgs* e
)
C++/CLI
protected:
virtual void OnContentDoubleClick(
   DataGridViewCellEventArgs^ e
)

Parameters

e
A DataGridViewCellEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


OnDataGridViewChanged Method

[image]
Gizmox.WebGUI.Forms
OnDataGridViewChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : OnDataGridViewChanged Method

Called when the DataGridViewElement.DataGridView property of the cell changes.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnDataGridViewChanged()
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell

instance.OnDataGridViewChanged()
C#
protected override void OnDataGridViewChanged()
Managed Extensions for C++
protected: void OnDataGridViewChanged(); override
C++/CLI
protected:
void OnDataGridViewChanged(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


OnDoubleClick Method

[image]
Gizmox.WebGUI.Forms
OnDoubleClick Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : OnDoubleClick Method

e
A DataGridViewCellEventArgs that contains the event data.
Called when the cell is double-clicked.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnDoubleClick( _
   ByVal e As DataGridViewCellEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim e As DataGridViewCellEventArgs

instance.OnDoubleClick(e)
C#
protected virtual void OnDoubleClick(
   DataGridViewCellEventArgs e
)
Managed Extensions for C++
protected: virtual void OnDoubleClick(
   DataGridViewCellEventArgs* e
)
C++/CLI
protected:
virtual void OnDoubleClick(
   DataGridViewCellEventArgs^ e
)

Parameters

e
A DataGridViewCellEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


OnEnter Method

[image]
Gizmox.WebGUI.Forms
OnEnter Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : OnEnter Method

rowIndex
The index of the cell's parent row.
throughMouseClick
true if a user action moved focus to the cell; false if a programmatic operation moved focus to the cell.
Called when the focus moves to a cell.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnEnter( _
   ByVal rowIndex As Integer, _
   ByVal throughMouseClick As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim rowIndex As Integer
Dim throughMouseClick As Boolean

instance.OnEnter(rowIndex, throughMouseClick)
C#
protected virtual void OnEnter(
   int rowIndex,
   bool throughMouseClick
)
Managed Extensions for C++
protected: virtual void OnEnter(
   int rowIndex,
   bool throughMouseClick
)
C++/CLI
protected:
virtual void OnEnter(
   int rowIndex,
   bool throughMouseClick
)

Parameters

rowIndex
The index of the cell's parent row.
throughMouseClick
true if a user action moved focus to the cell; false if a programmatic operation moved focus to the cell.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


OnKeyDown Method

[image]
Gizmox.WebGUI.Forms
OnKeyDown Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : OnKeyDown Method

e
A KeyEventArgs that contains the event data.
rowIndex
The index of the cell's parent row.
Called when a character key is pressed while the focus is on a cell.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnKeyDown( _
   ByVal e As KeyEventArgs, _
   ByVal rowIndex As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim e As KeyEventArgs
Dim rowIndex As Integer

instance.OnKeyDown(e, rowIndex)
C#
protected virtual void OnKeyDown(
   KeyEventArgs e,
   int rowIndex
)
Managed Extensions for C++
protected: virtual void OnKeyDown(
   KeyEventArgs* e,
   int rowIndex
)
C++/CLI
protected:
virtual void OnKeyDown(
   KeyEventArgs^ e,
   int rowIndex
)

Parameters

e
A KeyEventArgs that contains the event data.
rowIndex
The index of the cell's parent row.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


OnKeyPress Method

[image]
Gizmox.WebGUI.Forms
OnKeyPress Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : OnKeyPress Method

e
A KeyPressEventArgs that contains the event data.
rowIndex
The index of the cell's parent row.
Called when a key is pressed while the focus is on a cell.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnKeyPress( _
   ByVal e As KeyPressEventArgs, _
   ByVal rowIndex As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim e As KeyPressEventArgs
Dim rowIndex As Integer

instance.OnKeyPress(e, rowIndex)
C#
protected virtual void OnKeyPress(
   KeyPressEventArgs e,
   int rowIndex
)
Managed Extensions for C++
protected: virtual void OnKeyPress(
   KeyPressEventArgs* e,
   int rowIndex
)
C++/CLI
protected:
virtual void OnKeyPress(
   KeyPressEventArgs^ e,
   int rowIndex
)

Parameters

e
A KeyPressEventArgs that contains the event data.
rowIndex
The index of the cell's parent row.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


OnKeyUp Method

[image]
Gizmox.WebGUI.Forms
OnKeyUp Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : OnKeyUp Method

e
A KeyEventArgs that contains the event data.
rowIndex
The index of the cell's parent row.
Called when a character key is released while the focus is on a cell.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnKeyUp( _
   ByVal e As KeyEventArgs, _
   ByVal rowIndex As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim e As KeyEventArgs
Dim rowIndex As Integer

instance.OnKeyUp(e, rowIndex)
C#
protected virtual void OnKeyUp(
   KeyEventArgs e,
   int rowIndex
)
Managed Extensions for C++
protected: virtual void OnKeyUp(
   KeyEventArgs* e,
   int rowIndex
)
C++/CLI
protected:
virtual void OnKeyUp(
   KeyEventArgs^ e,
   int rowIndex
)

Parameters

e
A KeyEventArgs that contains the event data.
rowIndex
The index of the cell's parent row.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


OnLeave Method

[image]
Gizmox.WebGUI.Forms
OnLeave Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : OnLeave Method

rowIndex
The index of the cell's parent row.
throughMouseClick
true if a user action moved focus from the cell; false if a programmatic operation moved focus from the cell.
Called when the focus moves from a cell.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnLeave( _
   ByVal rowIndex As Integer, _
   ByVal throughMouseClick As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim rowIndex As Integer
Dim throughMouseClick As Boolean

instance.OnLeave(rowIndex, throughMouseClick)
C#
protected virtual void OnLeave(
   int rowIndex,
   bool throughMouseClick
)
Managed Extensions for C++
protected: virtual void OnLeave(
   int rowIndex,
   bool throughMouseClick
)
C++/CLI
protected:
virtual void OnLeave(
   int rowIndex,
   bool throughMouseClick
)

Parameters

rowIndex
The index of the cell's parent row.
throughMouseClick
true if a user action moved focus from the cell; false if a programmatic operation moved focus from the cell.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


OnMouseClick Method

[image]
Gizmox.WebGUI.Forms
OnMouseClick Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : OnMouseClick Method

e
A DataGridViewCellMouseEventArgs that contains the event data.
Called when the user clicks a mouse button while the pointer is on a cell.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnMouseClick( _
   ByVal e As DataGridViewCellMouseEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim e As DataGridViewCellMouseEventArgs

instance.OnMouseClick(e)
C#
protected virtual void OnMouseClick(
   DataGridViewCellMouseEventArgs e
)
Managed Extensions for C++
protected: virtual void OnMouseClick(
   DataGridViewCellMouseEventArgs* e
)
C++/CLI
protected:
virtual void OnMouseClick(
   DataGridViewCellMouseEventArgs^ e
)

Parameters

e
A DataGridViewCellMouseEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


OnMouseDoubleClick Method

[image]
Gizmox.WebGUI.Forms
OnMouseDoubleClick Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : OnMouseDoubleClick Method

e
A DataGridViewCellMouseEventArgs that contains the event data.
Called when the user double-clicks a mouse button while the pointer is on a cell.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnMouseDoubleClick( _
   ByVal e As DataGridViewCellMouseEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim e As DataGridViewCellMouseEventArgs

instance.OnMouseDoubleClick(e)
C#
protected virtual void OnMouseDoubleClick(
   DataGridViewCellMouseEventArgs e
)
Managed Extensions for C++
protected: virtual void OnMouseDoubleClick(
   DataGridViewCellMouseEventArgs* e
)
C++/CLI
protected:
virtual void OnMouseDoubleClick(
   DataGridViewCellMouseEventArgs^ e
)

Parameters

e
A DataGridViewCellMouseEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


OnMouseDown Method

[image]
Gizmox.WebGUI.Forms
OnMouseDown Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : OnMouseDown Method

e
A DataGridViewCellMouseEventArgs that contains the event data.
Called when the user holds down a mouse button while the pointer is on a cell.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnMouseDown( _
   ByVal e As DataGridViewCellMouseEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim e As DataGridViewCellMouseEventArgs

instance.OnMouseDown(e)
C#
protected virtual void OnMouseDown(
   DataGridViewCellMouseEventArgs e
)
Managed Extensions for C++
protected: virtual void OnMouseDown(
   DataGridViewCellMouseEventArgs* e
)
C++/CLI
protected:
virtual void OnMouseDown(
   DataGridViewCellMouseEventArgs^ e
)

Parameters

e
A DataGridViewCellMouseEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


OnMouseEnter Method

[image]
Gizmox.WebGUI.Forms
OnMouseEnter Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : OnMouseEnter Method

rowIndex
The index of the cell's parent row.
Called when the mouse pointer moves over a cell.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnMouseEnter( _
   ByVal rowIndex As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim rowIndex As Integer

instance.OnMouseEnter(rowIndex)
C#
protected virtual void OnMouseEnter(
   int rowIndex
)
Managed Extensions for C++
protected: virtual void OnMouseEnter(
   int rowIndex
)
C++/CLI
protected:
virtual void OnMouseEnter(
   int rowIndex
)

Parameters

rowIndex
The index of the cell's parent row.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


OnMouseLeave Method

[image]
Gizmox.WebGUI.Forms
OnMouseLeave Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : OnMouseLeave Method

rowIndex
The index of the cell's parent row.
Called when the mouse pointer leaves the cell.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnMouseLeave( _
   ByVal rowIndex As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim rowIndex As Integer

instance.OnMouseLeave(rowIndex)
C#
protected virtual void OnMouseLeave(
   int rowIndex
)
Managed Extensions for C++
protected: virtual void OnMouseLeave(
   int rowIndex
)
C++/CLI
protected:
virtual void OnMouseLeave(
   int rowIndex
)

Parameters

rowIndex
The index of the cell's parent row.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


OnMouseMove Method

[image]
Gizmox.WebGUI.Forms
OnMouseMove Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : OnMouseMove Method

e
A DataGridViewCellMouseEventArgs that contains the event data.
Called when the mouse pointer moves within a cell.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnMouseMove( _
   ByVal e As DataGridViewCellMouseEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim e As DataGridViewCellMouseEventArgs

instance.OnMouseMove(e)
C#
protected virtual void OnMouseMove(
   DataGridViewCellMouseEventArgs e
)
Managed Extensions for C++
protected: virtual void OnMouseMove(
   DataGridViewCellMouseEventArgs* e
)
C++/CLI
protected:
virtual void OnMouseMove(
   DataGridViewCellMouseEventArgs^ e
)

Parameters

e
A DataGridViewCellMouseEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


OnMouseUp Method

[image]
Gizmox.WebGUI.Forms
OnMouseUp Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : OnMouseUp Method

e
A DataGridViewCellMouseEventArgs that contains the event data.
Called when the user releases a mouse button while the pointer is on a cell.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnMouseUp( _
   ByVal e As DataGridViewCellMouseEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim e As DataGridViewCellMouseEventArgs

instance.OnMouseUp(e)
C#
protected virtual void OnMouseUp(
   DataGridViewCellMouseEventArgs e
)
Managed Extensions for C++
protected: virtual void OnMouseUp(
   DataGridViewCellMouseEventArgs* e
)
C++/CLI
protected:
virtual void OnMouseUp(
   DataGridViewCellMouseEventArgs^ e
)

Parameters

e
A DataGridViewCellMouseEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


Paint Method

[image]
Gizmox.WebGUI.Forms
Paint Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : Paint Method

graphics
clipBounds
cellBounds
rowIndex
cellState
value
formattedValue
errorText
cellStyle
advancedBorderStyle
paintParts

Syntax

Visual Basic (Declaration)
Protected Overridable Sub Paint( _
   ByVal graphics As Graphics, _
   ByVal clipBounds As Rectangle, _
   ByVal cellBounds As Rectangle, _
   ByVal rowIndex As Integer, _
   ByVal cellState As DataGridViewElementStates, _
   ByVal value As Object, _
   ByVal formattedValue As Object, _
   ByVal errorText As String, _
   ByVal cellStyle As DataGridViewCellStyle, _
   ByVal advancedBorderStyle As DataGridViewAdvancedBorderStyle, _
   ByVal paintParts As DataGridViewPaintParts _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim graphics As Graphics
Dim clipBounds As Rectangle
Dim cellBounds As Rectangle
Dim rowIndex As Integer
Dim cellState As DataGridViewElementStates
Dim value As Object
Dim formattedValue As Object
Dim errorText As String
Dim cellStyle As DataGridViewCellStyle
Dim advancedBorderStyle As DataGridViewAdvancedBorderStyle
Dim paintParts As DataGridViewPaintParts

instance.Paint(graphics, clipBounds, cellBounds, rowIndex, cellState, value, formattedValue, errorText, cellStyle, advancedBorderStyle, paintParts)
C#
protected virtual void Paint(
   Graphics graphics,
   Rectangle clipBounds,
   Rectangle cellBounds,
   int rowIndex,
   DataGridViewElementStates cellState,
   object value,
   object formattedValue,
   string errorText,
   DataGridViewCellStyle cellStyle,
   DataGridViewAdvancedBorderStyle advancedBorderStyle,
   DataGridViewPaintParts paintParts
)
Managed Extensions for C++
protected: virtual void Paint(
   Graphics* graphics,
   Rectangle clipBounds,
   Rectangle cellBounds,
   int rowIndex,
   DataGridViewElementStates cellState,
   Object* value,
   Object* formattedValue,
   string* errorText,
   DataGridViewCellStyle* cellStyle,
   DataGridViewAdvancedBorderStyle* advancedBorderStyle,
   DataGridViewPaintParts paintParts
)
C++/CLI
protected:
virtual void Paint(
   Graphics^ graphics,
   Rectangle clipBounds,
   Rectangle cellBounds,
   int rowIndex,
   DataGridViewElementStates cellState,
   Object^ value,
   Object^ formattedValue,
   String^ errorText,
   DataGridViewCellStyle^ cellStyle,
   DataGridViewAdvancedBorderStyle^ advancedBorderStyle,
   DataGridViewPaintParts paintParts
)

Parameters

graphics
clipBounds
cellBounds
rowIndex
cellState
value
formattedValue
errorText
cellStyle
advancedBorderStyle
paintParts

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


PaintErrorIcon Method

[image]
Gizmox.WebGUI.Forms
PaintErrorIcon Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : PaintErrorIcon Method

graphics
clipBounds
cellValueBounds
errorText

Syntax

Visual Basic (Declaration)
Protected Overridable Sub PaintErrorIcon( _
   ByVal graphics As Graphics, _
   ByVal clipBounds As Rectangle, _
   ByVal cellValueBounds As Rectangle, _
   ByVal errorText As String _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim graphics As Graphics
Dim clipBounds As Rectangle
Dim cellValueBounds As Rectangle
Dim errorText As String

instance.PaintErrorIcon(graphics, clipBounds, cellValueBounds, errorText)
C#
protected virtual void PaintErrorIcon(
   Graphics graphics,
   Rectangle clipBounds,
   Rectangle cellValueBounds,
   string errorText
)
Managed Extensions for C++
protected: virtual void PaintErrorIcon(
   Graphics* graphics,
   Rectangle clipBounds,
   Rectangle cellValueBounds,
   string* errorText
)
C++/CLI
protected:
virtual void PaintErrorIcon(
   Graphics^ graphics,
   Rectangle clipBounds,
   Rectangle cellValueBounds,
   String^ errorText
)

Parameters

graphics
clipBounds
cellValueBounds
errorText

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


ParseFormattedValue Method

[image]
Gizmox.WebGUI.Forms
ParseFormattedValue Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : ParseFormattedValue Method

formattedValue
cellStyle
formattedValueTypeConverter
valueTypeConverter

Syntax

Visual Basic (Declaration)
Public Overridable Function ParseFormattedValue( _
   ByVal formattedValue As Object, _
   ByVal cellStyle As DataGridViewCellStyle, _
   ByVal formattedValueTypeConverter As TypeConverter, _
   ByVal valueTypeConverter As TypeConverter _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim formattedValue As Object
Dim cellStyle As DataGridViewCellStyle
Dim formattedValueTypeConverter As TypeConverter
Dim valueTypeConverter As TypeConverter
Dim value As Object

value = instance.ParseFormattedValue(formattedValue, cellStyle, formattedValueTypeConverter, valueTypeConverter)
C#
public virtual object ParseFormattedValue(
   object formattedValue,
   DataGridViewCellStyle cellStyle,
   TypeConverter formattedValueTypeConverter,
   TypeConverter valueTypeConverter
)
Managed Extensions for C++
public: virtual Object* ParseFormattedValue(
   Object* formattedValue,
   DataGridViewCellStyle* cellStyle,
   TypeConverter* formattedValueTypeConverter,
   TypeConverter* valueTypeConverter
)
C++/CLI
public:
virtual Object^ ParseFormattedValue(
   Object^ formattedValue,
   DataGridViewCellStyle^ cellStyle,
   TypeConverter^ formattedValueTypeConverter,
   TypeConverter^ valueTypeConverter
)

Parameters

formattedValue
cellStyle
formattedValueTypeConverter
valueTypeConverter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


PositionEditingControl Method

[image]
Gizmox.WebGUI.Forms
PositionEditingControl Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : PositionEditingControl Method

setLocation
true to have the control placed as specified by the other arguments; false to allow the control to place itself.
setSize
true to specify the size; false to allow the control to size itself.
cellBounds
A Rectangle that defines the cell bounds.
cellClip
The area that will be used to paint the editing control.
cellStyle
A DataGridViewCellStyle that represents the style of the cell being edited.
singleVerticalBorderAdded
true to add a vertical border to the cell; otherwise, false.
singleHorizontalBorderAdded
true to add a horizontal border to the cell; otherwise, false.
isFirstDisplayedColumn
true if the hosting cell is in the first visible column; otherwise, false.
isFirstDisplayedRow
true if the hosting cell is in the first visible row; otherwise, false.
Sets the location and size of the editing control hosted by a cell in the DataGridView control.

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Overridable Sub PositionEditingControl( _
   ByVal setLocation As Boolean, _
   ByVal setSize As Boolean, _
   ByVal cellBounds As Rectangle, _
   ByVal cellClip As Rectangle, _
   ByVal cellStyle As DataGridViewCellStyle, _
   ByVal singleVerticalBorderAdded As Boolean, _
   ByVal singleHorizontalBorderAdded As Boolean, _
   ByVal isFirstDisplayedColumn As Boolean, _
   ByVal isFirstDisplayedRow As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim setLocation As Boolean
Dim setSize As Boolean
Dim cellBounds As Rectangle
Dim cellClip As Rectangle
Dim cellStyle As DataGridViewCellStyle
Dim singleVerticalBorderAdded As Boolean
Dim singleHorizontalBorderAdded As Boolean
Dim isFirstDisplayedColumn As Boolean
Dim isFirstDisplayedRow As Boolean

instance.PositionEditingControl(setLocation, setSize, cellBounds, cellClip, cellStyle, singleVerticalBorderAdded, singleHorizontalBorderAdded, isFirstDisplayedColumn, isFirstDisplayedRow)
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public virtual void PositionEditingControl(
   bool setLocation,
   bool setSize,
   Rectangle cellBounds,
   Rectangle cellClip,
   DataGridViewCellStyle cellStyle,
   bool singleVerticalBorderAdded,
   bool singleHorizontalBorderAdded,
   bool isFirstDisplayedColumn,
   bool isFirstDisplayedRow
)
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: virtual void PositionEditingControl(
   bool setLocation,
   bool setSize,
   Rectangle cellBounds,
   Rectangle cellClip,
   DataGridViewCellStyle* cellStyle,
   bool singleVerticalBorderAdded,
   bool singleHorizontalBorderAdded,
   bool isFirstDisplayedColumn,
   bool isFirstDisplayedRow
)
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
virtual void PositionEditingControl(
   bool setLocation,
   bool setSize,
   Rectangle cellBounds,
   Rectangle cellClip,
   DataGridViewCellStyle^ cellStyle,
   bool singleVerticalBorderAdded,
   bool singleHorizontalBorderAdded,
   bool isFirstDisplayedColumn,
   bool isFirstDisplayedRow
)

Parameters

setLocation
true to have the control placed as specified by the other arguments; false to allow the control to place itself.
setSize
true to specify the size; false to allow the control to size itself.
cellBounds
A Rectangle that defines the cell bounds.
cellClip
The area that will be used to paint the editing control.
cellStyle
A DataGridViewCellStyle that represents the style of the cell being edited.
singleVerticalBorderAdded
true to add a vertical border to the cell; otherwise, false.
singleHorizontalBorderAdded
true to add a horizontal border to the cell; otherwise, false.
isFirstDisplayedColumn
true if the hosting cell is in the first visible column; otherwise, false.
isFirstDisplayedRow
true if the hosting cell is in the first visible row; otherwise, false.

Exceptions

Exception | Description
InvalidOperationException | The cell is not contained within a DataGridView control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


PositionEditingPanel Method

[image]
Gizmox.WebGUI.Forms
PositionEditingPanel Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : PositionEditingPanel Method

cellBounds
cellClip
cellStyle
singleVerticalBorderAdded
singleHorizontalBorderAdded
isFirstDisplayedColumn
isFirstDisplayedRow

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Overridable Function PositionEditingPanel( _
   ByVal cellBounds As Rectangle, _
   ByVal cellClip As Rectangle, _
   ByVal cellStyle As DataGridViewCellStyle, _
   ByVal singleVerticalBorderAdded As Boolean, _
   ByVal singleHorizontalBorderAdded As Boolean, _
   ByVal isFirstDisplayedColumn As Boolean, _
   ByVal isFirstDisplayedRow As Boolean _
) As Rectangle
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim cellBounds As Rectangle
Dim cellClip As Rectangle
Dim cellStyle As DataGridViewCellStyle
Dim singleVerticalBorderAdded As Boolean
Dim singleHorizontalBorderAdded As Boolean
Dim isFirstDisplayedColumn As Boolean
Dim isFirstDisplayedRow As Boolean
Dim value As Rectangle

value = instance.PositionEditingPanel(cellBounds, cellClip, cellStyle, singleVerticalBorderAdded, singleHorizontalBorderAdded, isFirstDisplayedColumn, isFirstDisplayedRow)
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public virtual Rectangle PositionEditingPanel(
   Rectangle cellBounds,
   Rectangle cellClip,
   DataGridViewCellStyle cellStyle,
   bool singleVerticalBorderAdded,
   bool singleHorizontalBorderAdded,
   bool isFirstDisplayedColumn,
   bool isFirstDisplayedRow
)
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: virtual Rectangle PositionEditingPanel(
   Rectangle cellBounds,
   Rectangle cellClip,
   DataGridViewCellStyle* cellStyle,
   bool singleVerticalBorderAdded,
   bool singleHorizontalBorderAdded,
   bool isFirstDisplayedColumn,
   bool isFirstDisplayedRow
)
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
virtual Rectangle PositionEditingPanel(
   Rectangle cellBounds,
   Rectangle cellClip,
   DataGridViewCellStyle^ cellStyle,
   bool singleVerticalBorderAdded,
   bool singleHorizontalBorderAdded,
   bool isFirstDisplayedColumn,
   bool isFirstDisplayedRow
)

Parameters

cellBounds
cellClip
cellStyle
singleVerticalBorderAdded
singleHorizontalBorderAdded
isFirstDisplayedColumn
isFirstDisplayedRow

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


ProcessGatewayRequest Method

[image]
Gizmox.WebGUI.Forms
ProcessGatewayRequest Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : ProcessGatewayRequest Method

objContext
strCellAction

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ProcessGatewayRequest( _
   ByVal objContext As IContext, _
   ByVal strCellAction As String _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim objContext As IContext
Dim strCellAction As String

instance.ProcessGatewayRequest(objContext, strCellAction)
C#
protected virtual void ProcessGatewayRequest(
   IContext objContext,
   string strCellAction
)
Managed Extensions for C++
protected: virtual void ProcessGatewayRequest(
   IContext* objContext,
   string* strCellAction
)
C++/CLI
protected:
virtual void ProcessGatewayRequest(
   IContext^ objContext,
   String^ strCellAction
)

Parameters

objContext
strCellAction

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


RenderAttributes Method

[image]
Gizmox.WebGUI.Forms
RenderAttributes Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : RenderAttributes Method

objContext
objWriter
blnRenderOwner

Syntax

Visual Basic (Declaration)
Protected Overrides Sub RenderAttributes( _
   ByVal objContext As IContext, _
   ByVal objWriter As IAttributeWriter, _
   ByVal blnRenderOwner As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim objContext As IContext
Dim objWriter As IAttributeWriter
Dim blnRenderOwner As Boolean

instance.RenderAttributes(objContext, objWriter, blnRenderOwner)
C#
protected override void RenderAttributes(
   IContext objContext,
   IAttributeWriter objWriter,
   bool blnRenderOwner
)
Managed Extensions for C++
protected: void RenderAttributes(
   IContext* objContext,
   IAttributeWriter* objWriter,
   bool blnRenderOwner
) override
C++/CLI
protected:
void RenderAttributes(
   IContext^ objContext,
   IAttributeWriter^ objWriter,
   bool blnRenderOwner
) override

Parameters

objContext
objWriter
blnRenderOwner

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


RenderBackColorAttribute Method

[image]
Gizmox.WebGUI.Forms
RenderBackColorAttribute Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : RenderBackColorAttribute Method

objWriter
The obj writer.
objInheritedCellStyle
The obj inherited cell style.
Renders the back color attribute.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub RenderBackColorAttribute( _
   ByVal objWriter As IAttributeWriter, _
   ByVal objInheritedCellStyle As DataGridViewCellStyle _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim objWriter As IAttributeWriter
Dim objInheritedCellStyle As DataGridViewCellStyle

instance.RenderBackColorAttribute(objWriter, objInheritedCellStyle)
C#
protected virtual void RenderBackColorAttribute(
   IAttributeWriter objWriter,
   DataGridViewCellStyle objInheritedCellStyle
)
Managed Extensions for C++
protected: virtual void RenderBackColorAttribute(
   IAttributeWriter* objWriter,
   DataGridViewCellStyle* objInheritedCellStyle
)
C++/CLI
protected:
virtual void RenderBackColorAttribute(
   IAttributeWriter^ objWriter,
   DataGridViewCellStyle^ objInheritedCellStyle
)

Parameters

objWriter
The obj writer.
objInheritedCellStyle
The obj inherited cell style.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


RenderForeColorAttribute Method

[image]
Gizmox.WebGUI.Forms
RenderForeColorAttribute Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : RenderForeColorAttribute Method

objWriter
The obj writer.
objInheritedCellStyle
The obj inherited cell style.
Renders the fore color attribute.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub RenderForeColorAttribute( _
   ByVal objWriter As IAttributeWriter, _
   ByVal objInheritedCellStyle As DataGridViewCellStyle _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim objWriter As IAttributeWriter
Dim objInheritedCellStyle As DataGridViewCellStyle

instance.RenderForeColorAttribute(objWriter, objInheritedCellStyle)
C#
protected virtual void RenderForeColorAttribute(
   IAttributeWriter objWriter,
   DataGridViewCellStyle objInheritedCellStyle
)
Managed Extensions for C++
protected: virtual void RenderForeColorAttribute(
   IAttributeWriter* objWriter,
   DataGridViewCellStyle* objInheritedCellStyle
)
C++/CLI
protected:
virtual void RenderForeColorAttribute(
   IAttributeWriter^ objWriter,
   DataGridViewCellStyle^ objInheritedCellStyle
)

Parameters

objWriter
The obj writer.
objInheritedCellStyle
The obj inherited cell style.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


RenderReadOnlyAttribute Method

[image]
Gizmox.WebGUI.Forms
RenderReadOnlyAttribute Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : RenderReadOnlyAttribute Method

objWriter
The obj writer.
Renders the read only attribute.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub RenderReadOnlyAttribute( _
   ByVal objWriter As IAttributeWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim objWriter As IAttributeWriter

instance.RenderReadOnlyAttribute(objWriter)
C#
protected virtual void RenderReadOnlyAttribute(
   IAttributeWriter objWriter
)
Managed Extensions for C++
protected: virtual void RenderReadOnlyAttribute(
   IAttributeWriter* objWriter
)
C++/CLI
protected:
virtual void RenderReadOnlyAttribute(
   IAttributeWriter^ objWriter
)

Parameters

objWriter
The obj writer.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


RenderWrapModeAttribute Method

[image]
Gizmox.WebGUI.Forms
RenderWrapModeAttribute Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : RenderWrapModeAttribute Method

objWriter
The obj writer.
objInheritedCellStyle
The obj inherited cell style.
Renders the wrap mode attribute.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub RenderWrapModeAttribute( _
   ByVal objWriter As IAttributeWriter, _
   ByVal objInheritedCellStyle As DataGridViewCellStyle _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim objWriter As IAttributeWriter
Dim objInheritedCellStyle As DataGridViewCellStyle

instance.RenderWrapModeAttribute(objWriter, objInheritedCellStyle)
C#
protected virtual void RenderWrapModeAttribute(
   IAttributeWriter objWriter,
   DataGridViewCellStyle objInheritedCellStyle
)
Managed Extensions for C++
protected: virtual void RenderWrapModeAttribute(
   IAttributeWriter* objWriter,
   DataGridViewCellStyle* objInheritedCellStyle
)
C++/CLI
protected:
virtual void RenderWrapModeAttribute(
   IAttributeWriter^ objWriter,
   DataGridViewCellStyle^ objInheritedCellStyle
)

Parameters

objWriter
The obj writer.
objInheritedCellStyle
The obj inherited cell style.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


SetValue Method

[image]
Gizmox.WebGUI.Forms
SetValue Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : SetValue Method

rowIndex
The index of the cell's parent row.
value
The cell value to set.
Sets the value of the cell.

Syntax

Visual Basic (Declaration)
Protected Overridable Function SetValue( _
   ByVal rowIndex As Integer, _
   ByVal value As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim rowIndex As Integer
Dim value As Object
Dim value As Boolean

value = instance.SetValue(rowIndex, value)
C#
protected virtual bool SetValue(
   int rowIndex,
   object value
)
Managed Extensions for C++
protected: virtual bool SetValue(
   int rowIndex,
   Object* value
)
C++/CLI
protected:
virtual bool SetValue(
   int rowIndex,
   Object^ value
)

Parameters

rowIndex
The index of the cell's parent row.
value
The cell value to set.

Return Value

true if the value has been set; otherwise, false.

Exceptions

Exception | Description
InvalidOperationException | DataGridViewCell.ColumnIndex is less than 0.
ArgumentOutOfRangeException | rowIndex is less than 0 or greater than or equal to the number of rows in the parent DataGridView.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


ToString Method

[image]
Gizmox.WebGUI.Forms
ToString Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : ToString Method

Returns a string that describes the current object.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Return Value

A string that represents the current object.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


DataGridViewCell Class Properties

[image]
Gizmox.WebGUI.Forms
DataGridViewCell Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewCell Class

For a list of all members of this type, see DataGridViewCell members.

Public Properties

 | Name | Description
Public Property | ColumnIndex | Gets the column index for this cell.
Public Property | ContentBounds |
Public Property | DataGridView | Gets the DataGridView control associated with this element. (Inherited from DataGridViewElement)
Public Property | DefaultNewRowValue | Gets the default value for a cell in the row for new records.
Public Property | Displayed | Gets a value that indicates whether the cell is currently displayed on-screen.
Public Property | EditedFormattedValue | Gets the current, formatted value of the cell, regardless of whether the cell is in edit mode and the value has not been committed.
Public Property | EditType | Gets the type of the cell's hosted editing control.
Public Property | ErrorIconBounds |
Public Property | ErrorText | Gets or sets the text describing an error condition associated with the cell.
Public Property | FormattedValue | Gets the value of the cell as formatted for display.
Public Property | FormattedValueType | Gets the type of the formatted value associated with the cell.
Public Property | Frozen | Gets a value indicating whether the cell is frozen.
Public Property | HasStyle | Gets a value indicating whether the DataGridViewCell.Style property has been set.
Public Property | InheritedState | Gets the current state of the cell as inherited from the state of its row and column.
Public Property | InheritedStyle | Gets the style currently applied to the cell.
Public Property | IsInEditMode | Gets a value indicating whether this cell is currently being edited.
Public Property | OwningColumn | Gets the column that contains this cell.
Public Property | OwningRow | Gets the row that contains this cell.
Public Property | PreferredSize | Gets the size, in pixels, of a rectangular area into which the cell can fit.
Public Property | ReadOnly | Gets or sets a value indicating whether the cell's data can be edited.
Public Property | Resizable | Gets a value indicating whether the cell can be resized.
Public Property | RowIndex | Gets the index of the cell's parent row.
Public Property | Selected | Gets or sets a value indicating whether the cell has been selected.
Public Property | Size | Gets the size of the cell.
Public Property | State | Gets the user interface (UI) state of the element. (Inherited from DataGridViewElement)
Public Property | Style | Gets or sets the style for the cell.
Public Property | Tag | Gets or sets the object that contains supplemental data about the cell.
Public Property | ToolTipText | Gets or sets the ToolTip text associated with this cell.
Public Property | Value | Gets or sets the value associated with this cell.
Public Property | ValueType | Gets or sets the data type of the values in the cell.
Public Property | Visible | Gets a value indicating whether the cell is in a row or column that has been hidden.
Top

Protected Properties

 | Name | Description
Protected Property | MemberID | Overridden.
Protected Property | TagName | (Inherited from DataGridViewElement)
Top

See Also

Reference

DataGridViewCell Class
Gizmox.WebGUI.Forms Namespace


ColumnIndex Property

[image]
Gizmox.WebGUI.Forms
ColumnIndex Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : ColumnIndex Property

Gets the column index for this cell.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ColumnIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim value As Integer

value = instance.ColumnIndex
C#
public int ColumnIndex {get;}
Managed Extensions for C++
public: __property int get_ColumnIndex();
C++/CLI
public:
property int ColumnIndex {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


ContentBounds Property

[image]
Gizmox.WebGUI.Forms
ContentBounds Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : ContentBounds Property

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property ContentBounds As Rectangle
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim value As Rectangle

value = instance.ContentBounds
C#
[BrowsableAttribute(false)]
public Rectangle ContentBounds {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property Rectangle get_ContentBounds();
C++/CLI
[BrowsableAttribute(false)]
public:
property Rectangle ContentBounds {
   Rectangle get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


DefaultNewRowValue Property

[image]
Gizmox.WebGUI.Forms
DefaultNewRowValue Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : DefaultNewRowValue Property

Gets the default value for a cell in the row for new records.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public Overridable ReadOnly Property DefaultNewRowValue As Object
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim value As Object

value = instance.DefaultNewRowValue
C#
[BrowsableAttribute(false)]
public virtual object DefaultNewRowValue {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property virtual Object* get_DefaultNewRowValue();
C++/CLI
[BrowsableAttribute(false)]
public:
virtual property Object^ DefaultNewRowValue {
   Object^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


Displayed Property

[image]
Gizmox.WebGUI.Forms
Displayed Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : Displayed Property

Gets a value that indicates whether the cell is currently displayed on-screen.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public Overridable ReadOnly Property Displayed As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim value As Boolean

value = instance.Displayed
C#
[BrowsableAttribute(false)]
public virtual bool Displayed {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property virtual bool get_Displayed();
C++/CLI
[BrowsableAttribute(false)]
public:
virtual property bool Displayed {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


EditedFormattedValue Property

[image]
Gizmox.WebGUI.Forms
EditedFormattedValue Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : EditedFormattedValue Property

Gets the current, formatted value of the cell, regardless of whether the cell is in edit mode and the value has not been committed.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public ReadOnly Property EditedFormattedValue As Object
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim value As Object

value = instance.EditedFormattedValue
C#
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public object EditedFormattedValue {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: __property Object* get_EditedFormattedValue();
C++/CLI
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
property Object^ EditedFormattedValue {
   Object^ get();
}

Exceptions

Exception | Description
ArgumentOutOfRangeException | The row containing the cell is a shared row.-or-The cell is a column header cell.
Exception | Formatting failed and either there is no handler for the DataError event of the DataGridView control or the handler set the DataGridViewDataErrorEventArgs.ThrowException property to true. The exception object can typically be cast to type FormatException.
InvalidOperationException | DataGridViewCell.ColumnIndex is less than 0, indicating that the cell is a row header cell.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


EditType Property

[image]
Gizmox.WebGUI.Forms
EditType Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : EditType Property

Gets the type of the cell's hosted editing control.

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<BrowsableAttribute(False)>
Public Overridable ReadOnly Property EditType As Type
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim value As Type

value = instance.EditType
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[BrowsableAttribute(false)]
public virtual Type EditType {get;}
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[BrowsableAttribute(false)]
public: __property virtual Type* get_EditType();
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[BrowsableAttribute(false)]
public:
virtual property Type^ EditType {
   Type^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


ErrorIconBounds Property

[image]
Gizmox.WebGUI.Forms
ErrorIconBounds Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : ErrorIconBounds Property

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public ReadOnly Property ErrorIconBounds As Rectangle
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim value As Rectangle

value = instance.ErrorIconBounds
C#
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public Rectangle ErrorIconBounds {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: __property Rectangle get_ErrorIconBounds();
C++/CLI
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
property Rectangle ErrorIconBounds {
   Rectangle get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


ErrorText Property

[image]
Gizmox.WebGUI.Forms
ErrorText Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : ErrorText Property

Gets or sets the text describing an error condition associated with the cell.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public Property ErrorText As String
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim value As String

instance.ErrorText = value

value = instance.ErrorText
C#
[BrowsableAttribute(false)]
public string ErrorText {get; set;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property string* get_ErrorText();
public: __property void set_ErrorText(
   string* value
);
C++/CLI
[BrowsableAttribute(false)]
public:
property String^ ErrorText {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


FormattedValue Property

[image]
Gizmox.WebGUI.Forms
FormattedValue Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : FormattedValue Property

Gets the value of the cell as formatted for display.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property FormattedValue As Object
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim value As Object

value = instance.FormattedValue
C#
[BrowsableAttribute(false)]
public object FormattedValue {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property Object* get_FormattedValue();
C++/CLI
[BrowsableAttribute(false)]
public:
property Object^ FormattedValue {
   Object^ get();
}

Exceptions

Exception | Description
ArgumentOutOfRangeException | The row containing the cell is a shared row.-or-The cell is a column header cell.
Exception | Formatting failed and either there is no handler for the DataError event of the DataGridView control or the handler set the DataGridViewDataErrorEventArgs.ThrowException property to true. The exception object can typically be cast to type FormatException.
InvalidOperationException | DataGridViewCell.ColumnIndex is less than 0, indicating that the cell is a row header cell.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


FormattedValueType Property

[image]
Gizmox.WebGUI.Forms
FormattedValueType Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : FormattedValueType Property

Gets the type of the formatted value associated with the cell.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public Overridable ReadOnly Property FormattedValueType As Type
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim value As Type

value = instance.FormattedValueType
C#
[BrowsableAttribute(false)]
public virtual Type FormattedValueType {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property virtual Type* get_FormattedValueType();
C++/CLI
[BrowsableAttribute(false)]
public:
virtual property Type^ FormattedValueType {
   Type^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


Frozen Property

[image]
Gizmox.WebGUI.Forms
Frozen Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : Frozen Property

Gets a value indicating whether the cell is frozen.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public Overridable ReadOnly Property Frozen As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim value As Boolean

value = instance.Frozen
C#
[BrowsableAttribute(false)]
public virtual bool Frozen {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property virtual bool get_Frozen();
C++/CLI
[BrowsableAttribute(false)]
public:
virtual property bool Frozen {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


HasStyle Property

[image]
Gizmox.WebGUI.Forms
HasStyle Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : HasStyle Property

Gets a value indicating whether the DataGridViewCell.Style property has been set.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property HasStyle As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim value As Boolean

value = instance.HasStyle
C#
[BrowsableAttribute(false)]
public bool HasStyle {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property bool get_HasStyle();
C++/CLI
[BrowsableAttribute(false)]
public:
property bool HasStyle {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


InheritedState Property

[image]
Gizmox.WebGUI.Forms
InheritedState Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : InheritedState Property

Gets the current state of the cell as inherited from the state of its row and column.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property InheritedState As DataGridViewElementStates
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim value As DataGridViewElementStates

value = instance.InheritedState
C#
[BrowsableAttribute(false)]
public DataGridViewElementStates InheritedState {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property DataGridViewElementStates get_InheritedState();
C++/CLI
[BrowsableAttribute(false)]
public:
property DataGridViewElementStates InheritedState {
   DataGridViewElementStates get();
}

Exceptions

Exception | Description
ArgumentOutOfRangeException | The cell is contained within a DataGridView control and the value of its DataGridViewCell.RowIndex property is -1.
ArgumentException | The cell is not contained within a DataGridView control and the value of its DataGridViewCell.RowIndex property is not -1.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


InheritedStyle Property

[image]
Gizmox.WebGUI.Forms
InheritedStyle Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : InheritedStyle Property

Gets the style currently applied to the cell.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property InheritedStyle As DataGridViewCellStyle
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim value As DataGridViewCellStyle

value = instance.InheritedStyle
C#
[BrowsableAttribute(false)]
public DataGridViewCellStyle InheritedStyle {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property DataGridViewCellStyle* get_InheritedStyle();
C++/CLI
[BrowsableAttribute(false)]
public:
property DataGridViewCellStyle^ InheritedStyle {
   DataGridViewCellStyle^ get();
}

Exceptions

Exception | Description
ArgumentOutOfRangeException | The row containing the cell is a shared row.-or-The cell is a column header cell.
InvalidOperationException | The cell does not belong to a DataGridView control.-or- DataGridViewCell.ColumnIndex is less than 0, indicating that the cell is a row header cell.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


IsInEditMode Property

[image]
Gizmox.WebGUI.Forms
IsInEditMode Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : IsInEditMode Property

Gets a value indicating whether this cell is currently being edited.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property IsInEditMode As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim value As Boolean

value = instance.IsInEditMode
C#
[BrowsableAttribute(false)]
public bool IsInEditMode {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property bool get_IsInEditMode();
C++/CLI
[BrowsableAttribute(false)]
public:
property bool IsInEditMode {
   bool get();
}

Exceptions

Exception | Description
InvalidOperationException | The row containing the cell is a shared row.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


MemberID Property

[image]
Gizmox.WebGUI.Forms
MemberID Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : MemberID Property

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property MemberID As String
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim value As String

value = instance.MemberID
C#
protected override string MemberID {get;}
Managed Extensions for C++
protected: __property string* get_MemberID() override;
C++/CLI
protected:
property String^ MemberID {
   String^ get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


OwningColumn Property

[image]
Gizmox.WebGUI.Forms
OwningColumn Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : OwningColumn Property

Gets the column that contains this cell.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public ReadOnly Property OwningColumn As DataGridViewColumn
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim value As DataGridViewColumn

value = instance.OwningColumn
C#
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public DataGridViewColumn OwningColumn {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: __property DataGridViewColumn* get_OwningColumn();
C++/CLI
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
property DataGridViewColumn^ OwningColumn {
   DataGridViewColumn^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


OwningRow Property

[image]
Gizmox.WebGUI.Forms
OwningRow Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : OwningRow Property

Gets the row that contains this cell.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public ReadOnly Property OwningRow As DataGridViewRow
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim value As DataGridViewRow

value = instance.OwningRow
C#
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public DataGridViewRow OwningRow {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: __property DataGridViewRow* get_OwningRow();
C++/CLI
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
property DataGridViewRow^ OwningRow {
   DataGridViewRow^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


PreferredSize Property

[image]
Gizmox.WebGUI.Forms
PreferredSize Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : PreferredSize Property

Gets the size, in pixels, of a rectangular area into which the cell can fit.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property PreferredSize As Size
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim value As Size

value = instance.PreferredSize
C#
[BrowsableAttribute(false)]
public Size PreferredSize {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property Size get_PreferredSize();
C++/CLI
[BrowsableAttribute(false)]
public:
property Size PreferredSize {
   Size get();
}

Exceptions

Exception | Description
ArgumentOutOfRangeException | The row containing the cell is a shared row.-or-The cell is a column header cell.
InvalidOperationException | DataGridViewCell.ColumnIndex is less than 0, indicating that the cell is a row header cell.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


ReadOnly Property

[image]
Gizmox.WebGUI.Forms
ReadOnly Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : ReadOnly Property

Gets or sets a value indicating whether the cell's data can be edited.

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
Public Overridable Property ReadOnly As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim value As Boolean

instance.ReadOnly = value

value = instance.ReadOnly
C#
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public virtual bool ReadOnly {get; set;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public: __property virtual bool get_ReadOnly();
public: __property virtual void set_ReadOnly(
   bool value
);
C++/CLI
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public:
virtual property bool ReadOnly {
   bool get();
   void set (boolvalue);
}

Exceptions

Exception | Description
InvalidOperationException | There is no owning row when setting this property. -or-The owning row is shared when setting this property.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


Resizable Property

[image]
Gizmox.WebGUI.Forms
Resizable Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : Resizable Property

Gets a value indicating whether the cell can be resized.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public Overridable ReadOnly Property Resizable As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim value As Boolean

value = instance.Resizable
C#
[BrowsableAttribute(false)]
public virtual bool Resizable {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property virtual bool get_Resizable();
C++/CLI
[BrowsableAttribute(false)]
public:
virtual property bool Resizable {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


RowIndex Property

[image]
Gizmox.WebGUI.Forms
RowIndex Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : RowIndex Property

Gets the index of the cell's parent row.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property RowIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim value As Integer

value = instance.RowIndex
C#
[BrowsableAttribute(false)]
public int RowIndex {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property int get_RowIndex();
C++/CLI
[BrowsableAttribute(false)]
public:
property int RowIndex {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


Selected Property

[image]
Gizmox.WebGUI.Forms
Selected Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : Selected Property

Gets or sets a value indicating whether the cell has been selected.

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
Public Overridable Property Selected As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim value As Boolean

instance.Selected = value

value = instance.Selected
C#
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public virtual bool Selected {get; set;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public: __property virtual bool get_Selected();
public: __property virtual void set_Selected(
   bool value
);
C++/CLI
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public:
virtual property bool Selected {
   bool get();
   void set (boolvalue);
}

Exceptions

Exception | Description
InvalidOperationException | There is no associated DataGridView when setting this property. -or-The owning row is shared when setting this property.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


Size Property

[image]
Gizmox.WebGUI.Forms
Size Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : Size Property

Gets the size of the cell.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property Size As Size
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim value As Size

value = instance.Size
C#
[BrowsableAttribute(false)]
public Size Size {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property Size get_Size();
C++/CLI
[BrowsableAttribute(false)]
public:
property Size Size {
   Size get();
}

Exceptions

Exception | Description
InvalidOperationException | The row containing the cell is a shared row.-or-The cell is a column header cell.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


Style Property

[image]
Gizmox.WebGUI.Forms
Style Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : Style Property

Gets or sets the style for the cell.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(True)>
Public Property Style As DataGridViewCellStyle
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim value As DataGridViewCellStyle

instance.Style = value

value = instance.Style
C#
[BrowsableAttribute(true)]
public DataGridViewCellStyle Style {get; set;}
Managed Extensions for C++
[BrowsableAttribute(true)]
public: __property DataGridViewCellStyle* get_Style();
public: __property void set_Style(
   DataGridViewCellStyle* value
);
C++/CLI
[BrowsableAttribute(true)]
public:
property DataGridViewCellStyle^ Style {
   DataGridViewCellStyle^ get();
   void set (DataGridViewCellStyle^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


Tag Property

[image]
Gizmox.WebGUI.Forms
Tag Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : Tag Property

Gets or sets the object that contains supplemental data about the cell.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<SRDescriptionAttribute("User-defined data associated with the object.")>
<TypeConverterAttribute("System.ComponentModel.StringConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<SRCategoryAttribute("Data")>
<LocalizableAttribute(False)>
<BindableAttribute(True)>
Public Property Tag As Object
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim value As Object

instance.Tag = value

value = instance.Tag
C#
[DefaultValueAttribute()]
[SRDescriptionAttribute("User-defined data associated with the object.")]
[TypeConverterAttribute("System.ComponentModel.StringConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[SRCategoryAttribute("Data")]
[LocalizableAttribute(false)]
[BindableAttribute(true)]
public object Tag {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[SRDescriptionAttribute("User-defined data associated with the object.")]
[TypeConverterAttribute("System.ComponentModel.StringConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[SRCategoryAttribute("Data")]
[LocalizableAttribute(false)]
[BindableAttribute(true)]
public: __property Object* get_Tag();
public: __property void set_Tag(
   Object* value
);
C++/CLI
[DefaultValueAttribute()]
[SRDescriptionAttribute("User-defined data associated with the object.")]
[TypeConverterAttribute("System.ComponentModel.StringConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[SRCategoryAttribute("Data")]
[LocalizableAttribute(false)]
[BindableAttribute(true)]
public:
property Object^ Tag {
   Object^ get();
   void set (Object^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


ToolTipText Property

[image]
Gizmox.WebGUI.Forms
ToolTipText Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : ToolTipText Property

Gets or sets the ToolTip text associated with this cell.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public Property ToolTipText As String
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim value As String

instance.ToolTipText = value

value = instance.ToolTipText
C#
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public string ToolTipText {get; set;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property string* get_ToolTipText();
public: __property void set_ToolTipText(
   string* value
);
C++/CLI
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
property String^ ToolTipText {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


Value Property

[image]
Gizmox.WebGUI.Forms
Value Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : Value Property

Gets or sets the value associated with this cell.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public Property Value As Object
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim value As Object

instance.Value = value

value = instance.Value
C#
[BrowsableAttribute(false)]
public object Value {get; set;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property Object* get_Value();
public: __property void set_Value(
   Object* value
);
C++/CLI
[BrowsableAttribute(false)]
public:
property Object^ Value {
   Object^ get();
   void set (Object^value);
}

Exceptions

Exception | Description
InvalidOperationException | DataGridViewCell.ColumnIndex is less than 0, indicating that the cell is a row header cell.
ArgumentOutOfRangeException | DataGridViewCell.RowIndex is outside the valid range of 0 to the number of rows in the control minus 1.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


ValueType Property

[image]
Gizmox.WebGUI.Forms
ValueType Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : ValueType Property

Gets or sets the data type of the values in the cell.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public Overridable Property ValueType As Type
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim value As Type

instance.ValueType = value

value = instance.ValueType
C#
[BrowsableAttribute(false)]
public virtual Type ValueType {get; set;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property virtual Type* get_ValueType();
public: __property virtual void set_ValueType(
   Type* value
);
C++/CLI
[BrowsableAttribute(false)]
public:
virtual property Type^ ValueType {
   Type^ get();
   void set (Type^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


Visible Property

[image]
Gizmox.WebGUI.Forms
Visible Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : Visible Property

Gets a value indicating whether the cell is in a row or column that has been hidden.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public Overridable ReadOnly Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCell
Dim value As Boolean

value = instance.Visible
C#
[BrowsableAttribute(false)]
public virtual bool Visible {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property virtual bool get_Visible();
C++/CLI
[BrowsableAttribute(false)]
public:
virtual property bool Visible {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


DataGridViewCell Class Fields

[image]
Gizmox.WebGUI.Forms
DataGridViewCell Class Fields
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewCell Class

For a list of all members of this type, see DataGridViewCell members.

Protected Fields

 | Name | Description
static (Shared in Visual Basic) | DefaultHorizontalPadding |
static (Shared in Visual Basic) | DefaultVerticalPadding |
Top

See Also

Reference

DataGridViewCell Class
Gizmox.WebGUI.Forms Namespace


DefaultHorizontalPadding Field

[image]
Gizmox.WebGUI.Forms
DefaultHorizontalPadding Field
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : DefaultHorizontalPadding Field

Syntax

Visual Basic (Declaration)
Protected Shared DefaultHorizontalPadding As Integer
Visual Basic (Usage) Copy Code
Dim value As Integer

value = DataGridViewCell.DefaultHorizontalPadding

DataGridViewCell.DefaultHorizontalPadding = value
C#
protected static int DefaultHorizontalPadding
Managed Extensions for C++
protected: static int DefaultHorizontalPadding
C++/CLI
protected:
static int DefaultHorizontalPadding

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


DefaultVerticalPadding Field

[image]
Gizmox.WebGUI.Forms
DefaultVerticalPadding Field
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCell Class : DefaultVerticalPadding Field

Syntax

Visual Basic (Declaration)
Protected Shared DefaultVerticalPadding As Integer
Visual Basic (Usage) Copy Code
Dim value As Integer

value = DataGridViewCell.DefaultVerticalPadding

DataGridViewCell.DefaultVerticalPadding = value
C#
protected static int DefaultVerticalPadding
Managed Extensions for C++
protected: static int DefaultVerticalPadding
C++/CLI
protected:
static int DefaultVerticalPadding

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCell Class
DataGridViewCell Members


DataGridViewCellCancelEventArgs Class

[image]
Gizmox.WebGUI.Forms
DataGridViewCellCancelEventArgs Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewCellCancelEventArgs Class

Provides data for CellBeginEdit and RowValidating events.

Syntax

Visual Basic (Declaration)
Public Class DataGridViewCellCancelEventArgs
   Inherits CancelEventArgs
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCellCancelEventArgs
C#
public class DataGridViewCellCancelEventArgs : CancelEventArgs
Managed Extensions for C++
public __gc class DataGridViewCellCancelEventArgs : public CancelEventArgs
C++/CLI
public ref class DataGridViewCellCancelEventArgs : public CancelEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
System.ComponentModel.CancelEventArgs
Gizmox.WebGUI.Forms.DataGridViewCellCancelEventArgs
Gizmox.WebGUI.Forms.DataGridViewDataErrorEventArgs

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

DataGridViewCellCancelEventArgs Members
Gizmox.WebGUI.Forms Namespace


DataGridViewCellCancelEventArgs Class Members

[image]
Gizmox.WebGUI.Forms
DataGridViewCellCancelEventArgs Class Members
See Also Properties Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewCellCancelEventArgs Class

The following tables list the members exposed by DataGridViewCellCancelEventArgs.

Public Constructors

 | Name | Description
Public Constructor | DataGridViewCellCancelEventArgs Constructor | Initializes a new instance of the DataGridViewCellCancelEventArgs class.
Top

Public Properties

 | Name | Description
Public Property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from System.ComponentModel.CancelEventArgs)
Public Property | ColumnIndex | Gets the column index of the cell that the event occurs for.
Public Property | RowIndex | Gets the row index of the cell that the event occurs for.
Top

See Also

Reference

DataGridViewCellCancelEventArgs Class
Gizmox.WebGUI.Forms Namespace


DataGridViewCellCancelEventArgs Constructor

[image]
Gizmox.WebGUI.Forms
DataGridViewCellCancelEventArgs Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCellCancelEventArgs Class : DataGridViewCellCancelEventArgs Constructor

columnIndex
The index of the column containing the cell that the event occurs for.
rowIndex
The index of the row containing the cell that the event occurs for.
Initializes a new instance of the DataGridViewCellCancelEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal columnIndex As Integer, _
   ByVal rowIndex As Integer _
)
Visual Basic (Usage) Copy Code
Dim columnIndex As Integer
Dim rowIndex As Integer

Dim instance As DataGridViewCellCancelEventArgs(columnIndex, rowIndex)
C#
public DataGridViewCellCancelEventArgs(
   int columnIndex,
   int rowIndex
)
Managed Extensions for C++
public: DataGridViewCellCancelEventArgs(
   int columnIndex,
   int rowIndex
)
C++/CLI
public:
DataGridViewCellCancelEventArgs(
   int columnIndex,
   int rowIndex
)

Parameters

columnIndex
The index of the column containing the cell that the event occurs for.
rowIndex
The index of the row containing the cell that the event occurs for.

Exceptions

Exception | Description
ArgumentOutOfRangeException | columnIndex is less than -1.-or-rowIndex is less than -1.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCellCancelEventArgs Class
DataGridViewCellCancelEventArgs Members


DataGridViewCellCancelEventArgs Class Properties

[image]
Gizmox.WebGUI.Forms
DataGridViewCellCancelEventArgs Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewCellCancelEventArgs Class

For a list of all members of this type, see DataGridViewCellCancelEventArgs members.

Public Properties

 | Name | Description
Public Property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from System.ComponentModel.CancelEventArgs)
Public Property | ColumnIndex | Gets the column index of the cell that the event occurs for.
Public Property | RowIndex | Gets the row index of the cell that the event occurs for.
Top

See Also

Reference

DataGridViewCellCancelEventArgs Class
Gizmox.WebGUI.Forms Namespace


ColumnIndex Property

[image]
Gizmox.WebGUI.Forms
ColumnIndex Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCellCancelEventArgs Class : ColumnIndex Property

Gets the column index of the cell that the event occurs for.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ColumnIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCellCancelEventArgs
Dim value As Integer

value = instance.ColumnIndex
C#
public int ColumnIndex {get;}
Managed Extensions for C++
public: __property int get_ColumnIndex();
C++/CLI
public:
property int ColumnIndex {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCellCancelEventArgs Class
DataGridViewCellCancelEventArgs Members


RowIndex Property

[image]
Gizmox.WebGUI.Forms
RowIndex Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCellCancelEventArgs Class : RowIndex Property

Gets the row index of the cell that the event occurs for.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RowIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCellCancelEventArgs
Dim value As Integer

value = instance.RowIndex
C#
public int RowIndex {get;}
Managed Extensions for C++
public: __property int get_RowIndex();
C++/CLI
public:
property int RowIndex {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCellCancelEventArgs Class
DataGridViewCellCancelEventArgs Members


DataGridViewCellCollection Class

[image]
Gizmox.WebGUI.Forms
DataGridViewCellCollection Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewCellCollection Class

Represents a collection of cells in a DataGridViewRow.

Object Model

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
<ListBindableAttribute(False)>
Public Class DataGridViewCellCollection
   Inherits BaseCollection
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCellCollection
C#
[DefaultMemberAttribute("Item")]
[ListBindableAttribute(false)]
public class DataGridViewCellCollection : BaseCollection
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
[ListBindableAttribute(false)]
public __gc class DataGridViewCellCollection : public BaseCollection
C++/CLI
[DefaultMemberAttribute("Item")]
[ListBindableAttribute(false)]
public ref class DataGridViewCellCollection : public BaseCollection

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.BaseCollection
Gizmox.WebGUI.Forms.DataGridViewCellCollection

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

DataGridViewCellCollection Members
Gizmox.WebGUI.Forms Namespace


DataGridViewCellCollection Class Members

[image]
Gizmox.WebGUI.Forms
DataGridViewCellCollection Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewCellCollection Class

The following tables list the members exposed by DataGridViewCellCollection.

Public Constructors

 | Name | Description
Public Constructor | DataGridViewCellCollection Constructor | Initializes a new instance of the DataGridViewCellCollection class.
Top

Public Properties

 | Name | Description
Public Property | Count | Gets the total number of elements in the collection. (Inherited from BaseCollection)
Public Property | IsReadOnly | Gets a value indicating whether the collection is read-only. (Inherited from BaseCollection)
Public Property | IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized. (Inherited from BaseCollection)
Public Property | Item | Overloaded. Gets or sets the cell at the provided index location. In C#, this property is the indexer for the DataGridViewCellCollection class.
Public Property | SyncRoot | Gets an object that can be used to synchronize access to the BaseCollection. (Inherited from BaseCollection)
Top

Protected Properties

 | Name | Description
Protected Property | List | Overridden. Gets an ArrayList containing DataGridViewCellCollection objects.
Top

Public Methods

 | Name | Description
Public Method | Add | Adds a cell to the collection.
Public Method | AddRange | Adds an array of cells to the collection.
Public Method | Clear | Clears all cells from the collection.
Public Method | Contains | Determines whether the specified cell is contained in the collection.
Public Method | CopyTo | Overloaded. Copies the entire collection of cells into an array at a specified location within the array.
Public Method | GetEnumerator | Gets the object that enables iterating through the members of the collection. (Inherited from BaseCollection)
Public Method | IndexOf | Returns the index of the specified cell.
Public Method | Insert | Inserts a cell into the collection at the specified index.
Public Method | Remove | Removes the specified cell from the collection.
Public Method | RemoveAt | Removes the cell at the specified index.
Top

Protected Methods

 | Name | Description
Protected Method | OnCollectionChanged | Raises the CollectionChanged event.
Top

Public Events

 | Name | Description
Public Event | CollectionChanged | Occurs when the collection is changed.
Top

See Also

Reference

DataGridViewCellCollection Class
Gizmox.WebGUI.Forms Namespace


DataGridViewCellCollection Constructor

[image]
Gizmox.WebGUI.Forms
DataGridViewCellCollection Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCellCollection Class : DataGridViewCellCollection Constructor

dataGridViewRow
The DataGridViewRow that owns the collection.
Initializes a new instance of the DataGridViewCellCollection class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal dataGridViewRow As DataGridViewRow _
)
Visual Basic (Usage) Copy Code
Dim dataGridViewRow As DataGridViewRow

Dim instance As DataGridViewCellCollection(dataGridViewRow)
C#
public DataGridViewCellCollection(
   DataGridViewRow dataGridViewRow
)
Managed Extensions for C++
public: DataGridViewCellCollection(
   DataGridViewRow* dataGridViewRow
)
C++/CLI
public:
DataGridViewCellCollection(
   DataGridViewRow^ dataGridViewRow
)

Parameters

dataGridViewRow
The DataGridViewRow that owns the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCellCollection Class
DataGridViewCellCollection Members


DataGridViewCellCollection Class Methods

[image]
Gizmox.WebGUI.Forms
DataGridViewCellCollection Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewCellCollection Class

For a list of all members of this type, see DataGridViewCellCollection members.

Public Methods

 | Name | Description
Public Method | Add | Adds a cell to the collection.
Public Method | AddRange | Adds an array of cells to the collection.
Public Method | Clear | Clears all cells from the collection.
Public Method | Contains | Determines whether the specified cell is contained in the collection.
Public Method | CopyTo | Overloaded. Copies the entire collection of cells into an array at a specified location within the array.
Public Method | GetEnumerator | Gets the object that enables iterating through the members of the collection. (Inherited from BaseCollection)
Public Method | IndexOf | Returns the index of the specified cell.
Public Method | Insert | Inserts a cell into the collection at the specified index.
Public Method | Remove | Removes the specified cell from the collection.
Public Method | RemoveAt | Removes the cell at the specified index.
Top

Protected Methods

 | Name | Description
Protected Method | OnCollectionChanged | Raises the CollectionChanged event.
Top

See Also

Reference

DataGridViewCellCollection Class
Gizmox.WebGUI.Forms Namespace


Add Method

[image]
Gizmox.WebGUI.Forms
Add Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCellCollection Class : Add Method

dataGridViewCell
A DataGridViewCell to add to the collection.
Adds a cell to the collection.

Syntax

Visual Basic (Declaration)
Public Overridable Function Add( _
   ByVal dataGridViewCell As DataGridViewCell _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCellCollection
Dim dataGridViewCell As DataGridViewCell
Dim value As Integer

value = instance.Add(dataGridViewCell)
C#
public virtual int Add(
   DataGridViewCell dataGridViewCell
)
Managed Extensions for C++
public: virtual int Add(
   DataGridViewCell* dataGridViewCell
)
C++/CLI
public:
virtual int Add(
   DataGridViewCell^ dataGridViewCell
)

Parameters

dataGridViewCell
A DataGridViewCell to add to the collection.

Return Value

The position in which to insert the new element.

Exceptions

Exception | Description
InvalidOperationException | The row that owns this DataGridViewCellCollection already belongs to a DataGridView control.-or-dataGridViewCell already belongs to a DataGridViewRow.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCellCollection Class
DataGridViewCellCollection Members


AddRange Method

[image]
Gizmox.WebGUI.Forms
AddRange Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCellCollection Class : AddRange Method

dataGridViewCells
The array of DataGridViewCell objects to add to the collection.
Adds an array of cells to the collection.

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
Public Overridable Sub AddRange( _
   ByVal ParamArray dataGridViewCells() As DataGridViewCell _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCellCollection
Dim dataGridViewCells() As DataGridViewCell

instance.AddRange(dataGridViewCells)
C#
[DesignerSerializationVisibilityAttribute()]
public virtual void AddRange(
   params DataGridViewCell[] dataGridViewCells
)
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
public: virtual void AddRange(
   params DataGridViewCell*[]* dataGridViewCells
)
C++/CLI
[DesignerSerializationVisibilityAttribute()]
public:
virtual void AddRange(
   ... array<DataGridViewCell^>^ dataGridViewCells
)

Parameters

dataGridViewCells
The array of DataGridViewCell objects to add to the collection.

Exceptions

Exception | Description
ArgumentNullException | dataGridViewCells is null.
InvalidOperationException | The row that owns this DataGridViewCellCollection already belongs to a DataGridView control.-or-At least one value in dataGridViewCells is null.-or-At least one cell in dataGridViewCells already belongs to a DataGridViewRow.-or-At least two values in dataGridViewCells are references to the same DataGridViewCell.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCellCollection Class
DataGridViewCellCollection Members


Clear Method

[image]
Gizmox.WebGUI.Forms
Clear Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCellCollection Class : Clear Method

Clears all cells from the collection.

Syntax

Visual Basic (Declaration)
Public Overridable Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCellCollection

instance.Clear()
C#
public virtual void Clear()
Managed Extensions for C++
public: virtual void Clear();
C++/CLI
public:
virtual void Clear();

Exceptions

Exception | Description
InvalidOperationException | The row that owns this DataGridViewCellCollection already belongs to a DataGridView control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCellCollection Class
DataGridViewCellCollection Members


Contains Method

[image]
Gizmox.WebGUI.Forms
Contains Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCellCollection Class : Contains Method

dataGridViewCell
A DataGridViewCell to locate in the collection.
Determines whether the specified cell is contained in the collection.

Syntax

Visual Basic (Declaration)
Public Overridable Function Contains( _
   ByVal dataGridViewCell As DataGridViewCell _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCellCollection
Dim dataGridViewCell As DataGridViewCell
Dim value As Boolean

value = instance.Contains(dataGridViewCell)
C#
public virtual bool Contains(
   DataGridViewCell dataGridViewCell
)
Managed Extensions for C++
public: virtual bool Contains(
   DataGridViewCell* dataGridViewCell
)
C++/CLI
public:
virtual bool Contains(
   DataGridViewCell^ dataGridViewCell
)

Parameters

dataGridViewCell
A DataGridViewCell to locate in the collection.

Return Value

true if dataGridViewCell is in the collection; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCellCollection Class
DataGridViewCellCollection Members


CopyTo Method

[image]
Gizmox.WebGUI.Forms
CopyTo Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCellCollection Class : CopyTo Method

Copies the entire collection of cells into an array at a specified location within the array.

Overload List

Overload | Description
CopyTo(DataGridViewCell[],Int32) | Copies the entire collection of cells into an array at a specified location within the array.
CopyTo(Array,Int32) | Copies all the elements of the current one-dimensional Array to the specified one-dimensional Array starting at the specified destination Array index. (Inherited from BaseCollection)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCellCollection Class
DataGridViewCellCollection Members


CopyTo(DataGridViewCell[],Int32) Method

[image]
Gizmox.WebGUI.Forms
CopyTo(DataGridViewCell[],Int32) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCellCollection Class > CopyTo Method : CopyTo(DataGridViewCell[],Int32) Method

array
The destination array to which the contents will be copied.
index
The index of the element in array at which to start copying.
Copies the entire collection of cells into an array at a specified location within the array.

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal array() As DataGridViewCell, _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCellCollection
Dim array() As DataGridViewCell
Dim index As Integer

instance.CopyTo(array, index)
C#
public void CopyTo(
   DataGridViewCell[] array,
   int index
)
Managed Extensions for C++
public: void CopyTo(
   DataGridViewCell*[]* array,
   int index
)
C++/CLI
public:
void CopyTo(
   array<DataGridViewCell^>^ array,
   int index
)

Parameters

array
The destination array to which the contents will be copied.
index
The index of the element in array at which to start copying.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCellCollection Class
DataGridViewCellCollection Members
Overload List


IndexOf Method

[image]
Gizmox.WebGUI.Forms
IndexOf Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCellCollection Class : IndexOf Method

dataGridViewCell
The cell to locate in the collection.
Returns the index of the specified cell.

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal dataGridViewCell As DataGridViewCell _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCellCollection
Dim dataGridViewCell As DataGridViewCell
Dim value As Integer

value = instance.IndexOf(dataGridViewCell)
C#
public int IndexOf(
   DataGridViewCell dataGridViewCell
)
Managed Extensions for C++
public: int IndexOf(
   DataGridViewCell* dataGridViewCell
)
C++/CLI
public:
int IndexOf(
   DataGridViewCell^ dataGridViewCell
)

Parameters

dataGridViewCell
The cell to locate in the collection.

Return Value

The zero-based index of the value of dataGridViewCell parameter, if it is found in the collection; otherwise, -1.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCellCollection Class
DataGridViewCellCollection Members


Insert Method

[image]
Gizmox.WebGUI.Forms
Insert Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCellCollection Class : Insert Method

index
The zero-based index at which to place dataGridViewCell.
dataGridViewCell
The DataGridViewCell to insert.
Inserts a cell into the collection at the specified index.

Syntax

Visual Basic (Declaration)
Public Overridable Sub Insert( _
   ByVal index As Integer, _
   ByVal dataGridViewCell As DataGridViewCell _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCellCollection
Dim index As Integer
Dim dataGridViewCell As DataGridViewCell

instance.Insert(index, dataGridViewCell)
C#
public virtual void Insert(
   int index,
   DataGridViewCell dataGridViewCell
)
Managed Extensions for C++
public: virtual void Insert(
   int index,
   DataGridViewCell* dataGridViewCell
)
C++/CLI
public:
virtual void Insert(
   int index,
   DataGridViewCell^ dataGridViewCell
)

Parameters

index
The zero-based index at which to place dataGridViewCell.
dataGridViewCell
The DataGridViewCell to insert.

Exceptions

Exception | Description
InvalidOperationException | The row that owns this DataGridViewCellCollection already belongs to a DataGridView control.-or-dataGridViewCell already belongs to a DataGridViewRow.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCellCollection Class
DataGridViewCellCollection Members


OnCollectionChanged Method

[image]
Gizmox.WebGUI.Forms
OnCollectionChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCellCollection Class : OnCollectionChanged Method

e
A CollectionChangeEventArgs that contains the event data.
Raises the CollectionChanged event.

Syntax

Visual Basic (Declaration)
Protected Sub OnCollectionChanged( _
   ByVal e As CollectionChangeEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCellCollection
Dim e As CollectionChangeEventArgs

instance.OnCollectionChanged(e)
C#
protected void OnCollectionChanged(
   CollectionChangeEventArgs e
)
Managed Extensions for C++
protected: void OnCollectionChanged(
   CollectionChangeEventArgs* e
)
C++/CLI
protected:
void OnCollectionChanged(
   CollectionChangeEventArgs^ e
)

Parameters

e
A CollectionChangeEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCellCollection Class
DataGridViewCellCollection Members


Remove Method

[image]
Gizmox.WebGUI.Forms
Remove Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCellCollection Class : Remove Method

cell
The DataGridViewCell to remove from the collection.
Removes the specified cell from the collection.

Syntax

Visual Basic (Declaration)
Public Overridable Sub Remove( _
   ByVal cell As DataGridViewCell _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCellCollection
Dim cell As DataGridViewCell

instance.Remove(cell)
C#
public virtual void Remove(
   DataGridViewCell cell
)
Managed Extensions for C++
public: virtual void Remove(
   DataGridViewCell* cell
)
C++/CLI
public:
virtual void Remove(
   DataGridViewCell^ cell
)

Parameters

cell
The DataGridViewCell to remove from the collection.

Exceptions

Exception | Description
ArgumentException | cell could not be found in the collection.
InvalidOperationException | The row that owns this DataGridViewCellCollection already belongs to a DataGridView control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCellCollection Class
DataGridViewCellCollection Members


RemoveAt Method

[image]
Gizmox.WebGUI.Forms
RemoveAt Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCellCollection Class : RemoveAt Method

index
The zero-based index of the DataGridViewCell to be removed.
Removes the cell at the specified index.

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveAt( _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCellCollection
Dim index As Integer

instance.RemoveAt(index)
C#
public virtual void RemoveAt(
   int index
)
Managed Extensions for C++
public: virtual void RemoveAt(
   int index
)
C++/CLI
public:
virtual void RemoveAt(
   int index
)

Parameters

index
The zero-based index of the DataGridViewCell to be removed.

Exceptions

Exception | Description
InvalidOperationException | The row that owns this DataGridViewCellCollection already belongs to a DataGridView control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCellCollection Class
DataGridViewCellCollection Members


DataGridViewCellCollection Class Properties

[image]
Gizmox.WebGUI.Forms
DataGridViewCellCollection Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewCellCollection Class

For a list of all members of this type, see DataGridViewCellCollection members.

Public Properties

 | Name | Description
Public Property | Count | Gets the total number of elements in the collection. (Inherited from BaseCollection)
Public Property | IsReadOnly | Gets a value indicating whether the collection is read-only. (Inherited from BaseCollection)
Public Property | IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized. (Inherited from BaseCollection)
Public Property | Item | Overloaded. Gets or sets the cell at the provided index location. In C#, this property is the indexer for the DataGridViewCellCollection class.
Public Property | SyncRoot | Gets an object that can be used to synchronize access to the BaseCollection. (Inherited from BaseCollection)
Top

Protected Properties

 | Name | Description
Protected Property | List | Overridden. Gets an ArrayList containing DataGridViewCellCollection objects.
Top

See Also

Reference

DataGridViewCellCollection Class
Gizmox.WebGUI.Forms Namespace


Item Property

[image]
Gizmox.WebGUI.Forms
Item Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCellCollection Class : Item Property

Gets or sets the cell at the provided index location. In C#, this property is the indexer for the DataGridViewCellCollection class.

Overload List

Overload | Description
Item(Int32) | Gets or sets the cell at the provided index location. In C#, this property is the indexer for the DataGridViewCellCollection class.
Item(String) | Gets or sets the cell in the column with the provided name. In C#, this property is the indexer for the DataGridViewCellCollection class.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCellCollection Class
DataGridViewCellCollection Members


Item(Int32) Property

[image]
Gizmox.WebGUI.Forms
Item(Int32) Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCellCollection Class > Item Property : Item(Int32) Property

index
The zero-based index of the cell to get or set.
Gets or sets the cell at the provided index location. In C#, this property is the indexer for the DataGridViewCellCollection class.

Syntax

Visual Basic (Declaration)
Public Overloads Property Item( _
   ByVal index As Integer _
) As DataGridViewCell
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCellCollection
Dim index As Integer
Dim value As DataGridViewCell

instance.Item(index) = value

value = instance.Item(index)
C#
public DataGridViewCell Item(
   int index
) {get; set;}
Managed Extensions for C++
public: __property DataGridViewCell* get_Item(
   int index
);
public: __property void set_Item(
   int index,
   DataGridViewCell* value
);
C++/CLI
public:
property DataGridViewCell^ Item {
   DataGridViewCell^ get(intindex);
   void set (intindex, DataGridViewCell^value);
}

Parameters

index
The zero-based index of the cell to get or set.

Exceptions

Exception | Description
InvalidOperationException | The specified cell when setting this property already belongs to a DataGridView control.-or-The specified cell when setting this property already belongs to a DataGridViewRow.
ArgumentNullException | The specified value when setting this property is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCellCollection Class
DataGridViewCellCollection Members
Overload List


Item(String) Property

[image]
Gizmox.WebGUI.Forms
Item(String) Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCellCollection Class > Item Property : Item(String) Property

columnName
The name of the column in which to get or set the cell.
Gets or sets the cell in the column with the provided name. In C#, this property is the indexer for the DataGridViewCellCollection class.

Syntax

Visual Basic (Declaration)
Public Overloads Property Item( _
   ByVal columnName As String _
) As DataGridViewCell
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCellCollection
Dim columnName As String
Dim value As DataGridViewCell

instance.Item(columnName) = value

value = instance.Item(columnName)
C#
public DataGridViewCell Item(
   string columnName
) {get; set;}
Managed Extensions for C++
public: __property DataGridViewCell* get_Item(
   string* columnName
);
public: __property void set_Item(
   string* columnName,
   DataGridViewCell* value
);
C++/CLI
public:
property DataGridViewCell^ Item {
   DataGridViewCell^ get(String^columnName);
   void set (String^columnName, DataGridViewCell^value);
}

Parameters

columnName
The name of the column in which to get or set the cell.

Exceptions

Exception | Description
InvalidOperationException | The specified cell when setting this property already belongs to a DataGridView control.-or-The specified cell when setting this property already belongs to a DataGridViewRow.
ArgumentException | columnName does not match the name of any columns in the control.
ArgumentNullException | The specified value when setting this property is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCellCollection Class
DataGridViewCellCollection Members
Overload List


List Property

[image]
Gizmox.WebGUI.Forms
List Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCellCollection Class : List Property

Gets an ArrayList containing DataGridViewCellCollection objects.

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property List As ArrayList
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCellCollection
Dim value As ArrayList

value = instance.List
C#
protected override ArrayList List {get;}
Managed Extensions for C++
protected: __property ArrayList* get_List() override;
C++/CLI
protected:
property ArrayList^ List {
   ArrayList^ get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCellCollection Class
DataGridViewCellCollection Members


DataGridViewCellCollection Class Events

[image]
Gizmox.WebGUI.Forms
DataGridViewCellCollection Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewCellCollection Class

For a list of all members of this type, see DataGridViewCellCollection members.

Public Events

 | Name | Description
Public Event | CollectionChanged | Occurs when the collection is changed.
Top

See Also

Reference

DataGridViewCellCollection Class
Gizmox.WebGUI.Forms Namespace


CollectionChanged Event

[image]
Gizmox.WebGUI.Forms
CollectionChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCellCollection Class : CollectionChanged Event

Occurs when the collection is changed.

Syntax

Visual Basic (Declaration)
Public Event CollectionChanged() As CollectionChangeEventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCellCollection
Dim handler As CollectionChangeEventHandler

AddHandler instance.CollectionChanged, handler
C#
public event CollectionChangeEventHandler CollectionChanged()
Managed Extensions for C++
public: __event CollectionChangeEventHandler* CollectionChanged
C++/CLI
public:
event CollectionChangeEventHandler^ CollectionChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCellCollection Class
DataGridViewCellCollection Members


DataGridViewCellErrorTextNeededEventArgs Class

[image]
Gizmox.WebGUI.Forms
DataGridViewCellErrorTextNeededEventArgs Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewCellErrorTextNeededEventArgs Class

Provides data for the CellErrorTextNeeded event of a DataGridView control.

Syntax

Visual Basic (Declaration)
Public Class DataGridViewCellErrorTextNeededEventArgs
   Inherits DataGridViewCellEventArgs
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCellErrorTextNeededEventArgs
C#
public class DataGridViewCellErrorTextNeededEventArgs : DataGridViewCellEventArgs
Managed Extensions for C++
public __gc class DataGridViewCellErrorTextNeededEventArgs : public DataGridViewCellEventArgs
C++/CLI
public ref class DataGridViewCellErrorTextNeededEventArgs : public DataGridViewCellEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gizmox.WebGUI.Forms.DataGridViewCellEventArgs
Gizmox.WebGUI.Forms.DataGridViewCellErrorTextNeededEventArgs

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

DataGridViewCellErrorTextNeededEventArgs Members
Gizmox.WebGUI.Forms Namespace


DataGridViewCellErrorTextNeededEventArgs Class Members

[image]
Gizmox.WebGUI.Forms
DataGridViewCellErrorTextNeededEventArgs Class Members
See Also Properties Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewCellErrorTextNeededEventArgs Class

The following tables list the members exposed by DataGridViewCellErrorTextNeededEventArgs.

Public Properties

 | Name | Description
Public Property | ColumnIndex | Gets a value indicating the column index of the cell that the event occurs for. (Inherited from DataGridViewCellEventArgs)
Public Property | ErrorText | Gets or sets the message that is displayed when the cell is selected.
Public Property | RowIndex | Gets a value indicating the row index of the cell that the event occurs for. (Inherited from DataGridViewCellEventArgs)
Top

See Also

Reference

DataGridViewCellErrorTextNeededEventArgs Class
Gizmox.WebGUI.Forms Namespace


DataGridViewCellErrorTextNeededEventArgs Class Properties

[image]
Gizmox.WebGUI.Forms
DataGridViewCellErrorTextNeededEventArgs Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewCellErrorTextNeededEventArgs Class

For a list of all members of this type, see DataGridViewCellErrorTextNeededEventArgs members.

Public Properties

 | Name | Description
Public Property | ColumnIndex | Gets a value indicating the column index of the cell that the event occurs for. (Inherited from DataGridViewCellEventArgs)
Public Property | ErrorText | Gets or sets the message that is displayed when the cell is selected.
Public Property | RowIndex | Gets a value indicating the row index of the cell that the event occurs for. (Inherited from DataGridViewCellEventArgs)
Top

See Also

Reference

DataGridViewCellErrorTextNeededEventArgs Class
Gizmox.WebGUI.Forms Namespace


ErrorText Property

[image]
Gizmox.WebGUI.Forms
ErrorText Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCellErrorTextNeededEventArgs Class : ErrorText Property

Gets or sets the message that is displayed when the cell is selected.

Syntax

Visual Basic (Declaration)
Public Property ErrorText As String
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCellErrorTextNeededEventArgs
Dim value As String

instance.ErrorText = value

value = instance.ErrorText
C#
public string ErrorText {get; set;}
Managed Extensions for C++
public: __property string* get_ErrorText();
public: __property void set_ErrorText(
   string* value
);
C++/CLI
public:
property String^ ErrorText {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCellErrorTextNeededEventArgs Class
DataGridViewCellErrorTextNeededEventArgs Members


DataGridViewCellEventArgs Class

[image]
Gizmox.WebGUI.Forms
DataGridViewCellEventArgs Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewCellEventArgs Class

Provides data for DataGridView events related to cell and row operations.

Syntax

Visual Basic (Declaration)
Public Class DataGridViewCellEventArgs
   Inherits EventArgs
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCellEventArgs
C#
public class DataGridViewCellEventArgs : EventArgs
Managed Extensions for C++
public __gc class DataGridViewCellEventArgs : public EventArgs
C++/CLI
public ref class DataGridViewCellEventArgs : public EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gizmox.WebGUI.Forms.DataGridViewCellEventArgs
Gizmox.WebGUI.Forms.DataGridViewCellErrorTextNeededEventArgs
Gizmox.WebGUI.Forms.DataGridViewCellToolTipTextNeededEventArgs

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

DataGridViewCellEventArgs Members
Gizmox.WebGUI.Forms Namespace


DataGridViewCellEventArgs Class Members

[image]
Gizmox.WebGUI.Forms
DataGridViewCellEventArgs Class Members
See Also Properties Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewCellEventArgs Class

The following tables list the members exposed by DataGridViewCellEventArgs.

Public Constructors

 | Name | Description
Public Constructor | DataGridViewCellEventArgs Constructor | Initializes a new instance of the DataGridViewCellEventArgs class.
Top

Public Properties

 | Name | Description
Public Property | ColumnIndex | Gets a value indicating the column index of the cell that the event occurs for.
Public Property | RowIndex | Gets a value indicating the row index of the cell that the event occurs for.
Top

See Also

Reference

DataGridViewCellEventArgs Class
Gizmox.WebGUI.Forms Namespace


DataGridViewCellEventArgs Constructor

[image]
Gizmox.WebGUI.Forms
DataGridViewCellEventArgs Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCellEventArgs Class : DataGridViewCellEventArgs Constructor

columnIndex
The index of the column containing the cell that the event occurs for.
rowIndex
The index of the row containing the cell that the event occurs for.
Initializes a new instance of the DataGridViewCellEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal columnIndex As Integer, _
   ByVal rowIndex As Integer _
)
Visual Basic (Usage) Copy Code
Dim columnIndex As Integer
Dim rowIndex As Integer

Dim instance As DataGridViewCellEventArgs(columnIndex, rowIndex)
C#
public DataGridViewCellEventArgs(
   int columnIndex,
   int rowIndex
)
Managed Extensions for C++
public: DataGridViewCellEventArgs(
   int columnIndex,
   int rowIndex
)
C++/CLI
public:
DataGridViewCellEventArgs(
   int columnIndex,
   int rowIndex
)

Parameters

columnIndex
The index of the column containing the cell that the event occurs for.
rowIndex
The index of the row containing the cell that the event occurs for.

Exceptions

Exception | Description
ArgumentOutOfRangeException | columnIndex is less than -1.-or-rowIndex is less than -1.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCellEventArgs Class
DataGridViewCellEventArgs Members


DataGridViewCellEventArgs Class Properties

[image]
Gizmox.WebGUI.Forms
DataGridViewCellEventArgs Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewCellEventArgs Class

For a list of all members of this type, see DataGridViewCellEventArgs members.

Public Properties

 | Name | Description
Public Property | ColumnIndex | Gets a value indicating the column index of the cell that the event occurs for.
Public Property | RowIndex | Gets a value indicating the row index of the cell that the event occurs for.
Top

See Also

Reference

DataGridViewCellEventArgs Class
Gizmox.WebGUI.Forms Namespace


ColumnIndex Property

[image]
Gizmox.WebGUI.Forms
ColumnIndex Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCellEventArgs Class : ColumnIndex Property

Gets a value indicating the column index of the cell that the event occurs for.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ColumnIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCellEventArgs
Dim value As Integer

value = instance.ColumnIndex
C#
public int ColumnIndex {get;}
Managed Extensions for C++
public: __property int get_ColumnIndex();
C++/CLI
public:
property int ColumnIndex {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCellEventArgs Class
DataGridViewCellEventArgs Members


RowIndex Property

[image]
Gizmox.WebGUI.Forms
RowIndex Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCellEventArgs Class : RowIndex Property

Gets a value indicating the row index of the cell that the event occurs for.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RowIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCellEventArgs
Dim value As Integer

value = instance.RowIndex
C#
public int RowIndex {get;}
Managed Extensions for C++
public: __property int get_RowIndex();
C++/CLI
public:
property int RowIndex {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCellEventArgs Class
DataGridViewCellEventArgs Members


DataGridViewCellFormattingEventArgs Class

[image]
Gizmox.WebGUI.Forms
DataGridViewCellFormattingEventArgs Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewCellFormattingEventArgs Class

Provides data for the CellFormatting event of a DataGridView.

Object Model

Syntax

Visual Basic (Declaration)
Public Class DataGridViewCellFormattingEventArgs
   Inherits ConvertEventArgs
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCellFormattingEventArgs
C#
public class DataGridViewCellFormattingEventArgs : ConvertEventArgs
Managed Extensions for C++
public __gc class DataGridViewCellFormattingEventArgs : public ConvertEventArgs
C++/CLI
public ref class DataGridViewCellFormattingEventArgs : public ConvertEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gizmox.WebGUI.Forms.ConvertEventArgs
Gizmox.WebGUI.Forms.DataGridViewCellFormattingEventArgs

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

DataGridViewCellFormattingEventArgs Members
Gizmox.WebGUI.Forms Namespace


DataGridViewCellFormattingEventArgs Class Members

[image]
Gizmox.WebGUI.Forms
DataGridViewCellFormattingEventArgs Class Members
See Also Properties Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewCellFormattingEventArgs Class

The following tables list the members exposed by DataGridViewCellFormattingEventArgs.

Public Constructors

 | Name | Description
Public Constructor | DataGridViewCellFormattingEventArgs Constructor | Initializes a new instance of the DataGridViewCellFormattingEventArgs class.
Top

Public Properties

 | Name | Description
Public Property | CellStyle | Gets or sets the style of the cell that is being formatted.
Public Property | ColumnIndex | Gets the column index of the cell that is being formatted.
Public Property | DesiredType | Gets the data type of the desired value. (Inherited from ConvertEventArgs)
Public Property | FormattingApplied | Gets or sets a value indicating whether the cell value has been successfully formatted.
Public Property | RowIndex | Gets the row index of the cell that is being formatted.
Public Property | Value | Gets or sets the value of the ConvertEventArgs. (Inherited from ConvertEventArgs)
Top

See Also

Reference

DataGridViewCellFormattingEventArgs Class
Gizmox.WebGUI.Forms Namespace


DataGridViewCellFormattingEventArgs Constructor

[image]
Gizmox.WebGUI.Forms
DataGridViewCellFormattingEventArgs Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCellFormattingEventArgs Class : DataGridViewCellFormattingEventArgs Constructor

columnIndex
The column index of the cell that caused the event.
rowIndex
The row index of the cell that caused the event.
value
The cell's contents.
desiredType
The type to convert value to.
cellStyle
The style of the cell that caused the event.
Initializes a new instance of the DataGridViewCellFormattingEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal columnIndex As Integer, _
   ByVal rowIndex As Integer, _
   ByVal value As Object, _
   ByVal desiredType As Type, _
   ByVal cellStyle As DataGridViewCellStyle _
)
Visual Basic (Usage) Copy Code
Dim columnIndex As Integer
Dim rowIndex As Integer
Dim value As Object
Dim desiredType As Type
Dim cellStyle As DataGridViewCellStyle

Dim instance As DataGridViewCellFormattingEventArgs(columnIndex, rowIndex, value, desiredType, cellStyle)
C#
public DataGridViewCellFormattingEventArgs(
   int columnIndex,
   int rowIndex,
   object value,
   Type desiredType,
   DataGridViewCellStyle cellStyle
)
Managed Extensions for C++
public: DataGridViewCellFormattingEventArgs(
   int columnIndex,
   int rowIndex,
   Object* value,
   Type* desiredType,
   DataGridViewCellStyle* cellStyle
)
C++/CLI
public:
DataGridViewCellFormattingEventArgs(
   int columnIndex,
   int rowIndex,
   Object^ value,
   Type^ desiredType,
   DataGridViewCellStyle^ cellStyle
)

Parameters

columnIndex
The column index of the cell that caused the event.
rowIndex
The row index of the cell that caused the event.
value
The cell's contents.
desiredType
The type to convert value to.
cellStyle
The style of the cell that caused the event.

Exceptions

Exception | Description
ArgumentOutOfRangeException | columnIndex is less than -1-or-rowIndex is less than -1.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCellFormattingEventArgs Class
DataGridViewCellFormattingEventArgs Members


DataGridViewCellFormattingEventArgs Class Properties

[image]
Gizmox.WebGUI.Forms
DataGridViewCellFormattingEventArgs Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewCellFormattingEventArgs Class

For a list of all members of this type, see DataGridViewCellFormattingEventArgs members.

Public Properties

 | Name | Description
Public Property | CellStyle | Gets or sets the style of the cell that is being formatted.
Public Property | ColumnIndex | Gets the column index of the cell that is being formatted.
Public Property | DesiredType | Gets the data type of the desired value. (Inherited from ConvertEventArgs)
Public Property | FormattingApplied | Gets or sets a value indicating whether the cell value has been successfully formatted.
Public Property | RowIndex | Gets the row index of the cell that is being formatted.
Public Property | Value | Gets or sets the value of the ConvertEventArgs. (Inherited from ConvertEventArgs)
Top

See Also

Reference

DataGridViewCellFormattingEventArgs Class
Gizmox.WebGUI.Forms Namespace


CellStyle Property

[image]
Gizmox.WebGUI.Forms
CellStyle Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCellFormattingEventArgs Class : CellStyle Property

Gets or sets the style of the cell that is being formatted.

Syntax

Visual Basic (Declaration)
Public Property CellStyle As DataGridViewCellStyle
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCellFormattingEventArgs
Dim value As DataGridViewCellStyle

instance.CellStyle = value

value = instance.CellStyle
C#
public DataGridViewCellStyle CellStyle {get; set;}
Managed Extensions for C++
public: __property DataGridViewCellStyle* get_CellStyle();
public: __property void set_CellStyle(
   DataGridViewCellStyle* value
);
C++/CLI
public:
property DataGridViewCellStyle^ CellStyle {
   DataGridViewCellStyle^ get();
   void set (DataGridViewCellStyle^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCellFormattingEventArgs Class
DataGridViewCellFormattingEventArgs Members


ColumnIndex Property

[image]
Gizmox.WebGUI.Forms
ColumnIndex Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCellFormattingEventArgs Class : ColumnIndex Property

Gets the column index of the cell that is being formatted.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ColumnIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCellFormattingEventArgs
Dim value As Integer

value = instance.ColumnIndex
C#
public int ColumnIndex {get;}
Managed Extensions for C++
public: __property int get_ColumnIndex();
C++/CLI
public:
property int ColumnIndex {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCellFormattingEventArgs Class
DataGridViewCellFormattingEventArgs Members


FormattingApplied Property

[image]
Gizmox.WebGUI.Forms
FormattingApplied Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCellFormattingEventArgs Class : FormattingApplied Property

Gets or sets a value indicating whether the cell value has been successfully formatted.

Syntax

Visual Basic (Declaration)
Public Property FormattingApplied As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCellFormattingEventArgs
Dim value As Boolean

instance.FormattingApplied = value

value = instance.FormattingApplied
C#
public bool FormattingApplied {get; set;}
Managed Extensions for C++
public: __property bool get_FormattingApplied();
public: __property void set_FormattingApplied(
   bool value
);
C++/CLI
public:
property bool FormattingApplied {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCellFormattingEventArgs Class
DataGridViewCellFormattingEventArgs Members


RowIndex Property

[image]
Gizmox.WebGUI.Forms
RowIndex Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCellFormattingEventArgs Class : RowIndex Property

Gets the row index of the cell that is being formatted.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RowIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCellFormattingEventArgs
Dim value As Integer

value = instance.RowIndex
C#
public int RowIndex {get;}
Managed Extensions for C++
public: __property int get_RowIndex();
C++/CLI
public:
property int RowIndex {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCellFormattingEventArgs Class
DataGridViewCellFormattingEventArgs Members


DataGridViewCellMouseEventArgs Class

[image]
Gizmox.WebGUI.Forms
DataGridViewCellMouseEventArgs Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewCellMouseEventArgs Class

Provides data for mouse events raised by a DataGridView whenever the mouse is moved within a DataGridViewCell.

Syntax

Visual Basic (Declaration)
Public Class DataGridViewCellMouseEventArgs
   Inherits MouseEventArgs
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCellMouseEventArgs
C#
public class DataGridViewCellMouseEventArgs : MouseEventArgs
Managed Extensions for C++
public __gc class DataGridViewCellMouseEventArgs : public MouseEventArgs
C++/CLI
public ref class DataGridViewCellMouseEventArgs : public MouseEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gizmox.WebGUI.Forms.MouseEventArgs
Gizmox.WebGUI.Forms.DataGridViewCellMouseEventArgs

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

DataGridViewCellMouseEventArgs Members
Gizmox.WebGUI.Forms Namespace


DataGridViewCellMouseEventArgs Class Members

[image]
Gizmox.WebGUI.Forms
DataGridViewCellMouseEventArgs Class Members
See Also Properties Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewCellMouseEventArgs Class

The following tables list the members exposed by DataGridViewCellMouseEventArgs.

Public Constructors

 | Name | Description
Public Constructor | DataGridViewCellMouseEventArgs Constructor | Initializes a new instance of the DataGridViewCellMouseEventArgs class.
Top

Public Properties

 | Name | Description
Public Property | Button | (Inherited from MouseEventArgs)
Public Property | Clicks | (Inherited from MouseEventArgs)
Public Property | ColumnIndex | Gets the zero-based column index of the cell.
Public Property | Delta | (Inherited from MouseEventArgs)
Public Property | RowIndex | Gets the zero-based row index of the cell.
Public Property | X | (Inherited from MouseEventArgs)
Public Property | Y | (Inherited from MouseEventArgs)
Top

See Also

Reference

DataGridViewCellMouseEventArgs Class
Gizmox.WebGUI.Forms Namespace


DataGridViewCellMouseEventArgs Constructor

[image]
Gizmox.WebGUI.Forms
DataGridViewCellMouseEventArgs Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCellMouseEventArgs Class : DataGridViewCellMouseEventArgs Constructor

columnIndex
The cell's zero-based column index.
rowIndex
The cell's zero-based row index.
localX
The x-coordinate of the mouse, in pixels.
localY
The y-coordinate of the mouse, in pixels.
e
The originating MouseEventArgs.
Initializes a new instance of the DataGridViewCellMouseEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal columnIndex As Integer, _
   ByVal rowIndex As Integer, _
   ByVal localX As Integer, _
   ByVal localY As Integer, _
   ByVal e As MouseEventArgs _
)
Visual Basic (Usage) Copy Code
Dim columnIndex As Integer
Dim rowIndex As Integer
Dim localX As Integer
Dim localY As Integer
Dim e As MouseEventArgs

Dim instance As DataGridViewCellMouseEventArgs(columnIndex, rowIndex, localX, localY, e)
C#
public DataGridViewCellMouseEventArgs(
   int columnIndex,
   int rowIndex,
   int localX,
   int localY,
   MouseEventArgs e
)
Managed Extensions for C++
public: DataGridViewCellMouseEventArgs(
   int columnIndex,
   int rowIndex,
   int localX,
   int localY,
   MouseEventArgs* e
)
C++/CLI
public:
DataGridViewCellMouseEventArgs(
   int columnIndex,
   int rowIndex,
   int localX,
   int localY,
   MouseEventArgs^ e
)

Parameters

columnIndex
The cell's zero-based column index.
rowIndex
The cell's zero-based row index.
localX
The x-coordinate of the mouse, in pixels.
localY
The y-coordinate of the mouse, in pixels.
e
The originating MouseEventArgs.

Exceptions

Exception | Description
ArgumentOutOfRangeException | columnIndex is less than -1.-or-rowIndex is less than -1.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCellMouseEventArgs Class
DataGridViewCellMouseEventArgs Members


DataGridViewCellMouseEventArgs Class Properties

[image]
Gizmox.WebGUI.Forms
DataGridViewCellMouseEventArgs Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewCellMouseEventArgs Class

For a list of all members of this type, see DataGridViewCellMouseEventArgs members.

Public Properties

 | Name | Description
Public Property | Button | (Inherited from MouseEventArgs)
Public Property | Clicks | (Inherited from MouseEventArgs)
Public Property | ColumnIndex | Gets the zero-based column index of the cell.
Public Property | Delta | (Inherited from MouseEventArgs)
Public Property | RowIndex | Gets the zero-based row index of the cell.
Public Property | X | (Inherited from MouseEventArgs)
Public Property | Y | (Inherited from MouseEventArgs)
Top

See Also

Reference

DataGridViewCellMouseEventArgs Class
Gizmox.WebGUI.Forms Namespace


ColumnIndex Property

[image]
Gizmox.WebGUI.Forms
ColumnIndex Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCellMouseEventArgs Class : ColumnIndex Property

Gets the zero-based column index of the cell.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ColumnIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCellMouseEventArgs
Dim value As Integer

value = instance.ColumnIndex
C#
public int ColumnIndex {get;}
Managed Extensions for C++
public: __property int get_ColumnIndex();
C++/CLI
public:
property int ColumnIndex {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCellMouseEventArgs Class
DataGridViewCellMouseEventArgs Members


RowIndex Property

[image]
Gizmox.WebGUI.Forms
RowIndex Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCellMouseEventArgs Class : RowIndex Property

Gets the zero-based row index of the cell.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RowIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCellMouseEventArgs
Dim value As Integer

value = instance.RowIndex
C#
public int RowIndex {get;}
Managed Extensions for C++
public: __property int get_RowIndex();
C++/CLI
public:
property int RowIndex {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCellMouseEventArgs Class
DataGridViewCellMouseEventArgs Members


DataGridViewCellParsingEventArgs Class

[image]
Gizmox.WebGUI.Forms
DataGridViewCellParsingEventArgs Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewCellParsingEventArgs Class

Provides data for the DataGridView.CellParsing event of a DataGridView control.

Object Model

Syntax

Visual Basic (Declaration)
Public Class DataGridViewCellParsingEventArgs
   Inherits ConvertEventArgs
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCellParsingEventArgs
C#
public class DataGridViewCellParsingEventArgs : ConvertEventArgs
Managed Extensions for C++
public __gc class DataGridViewCellParsingEventArgs : public ConvertEventArgs
C++/CLI
public ref class DataGridViewCellParsingEventArgs : public ConvertEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gizmox.WebGUI.Forms.ConvertEventArgs
Gizmox.WebGUI.Forms.DataGridViewCellParsingEventArgs

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

DataGridViewCellParsingEventArgs Members
Gizmox.WebGUI.Forms Namespace


DataGridViewCellParsingEventArgs Class Members

[image]
Gizmox.WebGUI.Forms
DataGridViewCellParsingEventArgs Class Members
See Also Properties Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewCellParsingEventArgs Class

The following tables list the members exposed by DataGridViewCellParsingEventArgs.

Public Constructors

 | Name | Description
Public Constructor | DataGridViewCellParsingEventArgs Constructor | Initializes a new instance of the DataGridViewCellParsingEventArgs class.
Top

Public Properties

 | Name | Description
Public Property | ColumnIndex | Gets the column index of the cell data that requires parsing.
Public Property | DesiredType | Gets the data type of the desired value. (Inherited from ConvertEventArgs)
Public Property | InheritedCellStyle | Gets or sets the style applied to the edited cell.
Public Property | ParsingApplied | Gets or sets a value indicating whether a cell's value has been successfully parsed.
Public Property | RowIndex | Gets the row index of the cell that requires parsing.
Public Property | Value | Gets or sets the value of the ConvertEventArgs. (Inherited from ConvertEventArgs)
Top

See Also

Reference

DataGridViewCellParsingEventArgs Class
Gizmox.WebGUI.Forms Namespace


DataGridViewCellParsingEventArgs Constructor

[image]
Gizmox.WebGUI.Forms
DataGridViewCellParsingEventArgs Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCellParsingEventArgs Class : DataGridViewCellParsingEventArgs Constructor

rowIndex
The row index of the cell that was changed.
columnIndex
The column index of the cell that was changed.
value
The new value.
desiredType
The type of the new value.
inheritedCellStyle
The style applied to the cell that was changed.
Initializes a new instance of the DataGridViewCellParsingEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal rowIndex As Integer, _
   ByVal columnIndex As Integer, _
   ByVal value As Object, _
   ByVal desiredType As Type, _
   ByVal inheritedCellStyle As DataGridViewCellStyle _
)
Visual Basic (Usage) Copy Code
Dim rowIndex As Integer
Dim columnIndex As Integer
Dim value As Object
Dim desiredType As Type
Dim inheritedCellStyle As DataGridViewCellStyle

Dim instance As DataGridViewCellParsingEventArgs(rowIndex, columnIndex, value, desiredType, inheritedCellStyle)
C#
public DataGridViewCellParsingEventArgs(
   int rowIndex,
   int columnIndex,
   object value,
   Type desiredType,
   DataGridViewCellStyle inheritedCellStyle
)
Managed Extensions for C++
public: DataGridViewCellParsingEventArgs(
   int rowIndex,
   int columnIndex,
   Object* value,
   Type* desiredType,
   DataGridViewCellStyle* inheritedCellStyle
)
C++/CLI
public:
DataGridViewCellParsingEventArgs(
   int rowIndex,
   int columnIndex,
   Object^ value,
   Type^ desiredType,
   DataGridViewCellStyle^ inheritedCellStyle
)

Parameters

rowIndex
The row index of the cell that was changed.
columnIndex
The column index of the cell that was changed.
value
The new value.
desiredType
The type of the new value.
inheritedCellStyle
The style applied to the cell that was changed.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCellParsingEventArgs Class
DataGridViewCellParsingEventArgs Members


DataGridViewCellParsingEventArgs Class Properties

[image]
Gizmox.WebGUI.Forms
DataGridViewCellParsingEventArgs Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewCellParsingEventArgs Class

For a list of all members of this type, see DataGridViewCellParsingEventArgs members.

Public Properties

 | Name | Description
Public Property | ColumnIndex | Gets the column index of the cell data that requires parsing.
Public Property | DesiredType | Gets the data type of the desired value. (Inherited from ConvertEventArgs)
Public Property | InheritedCellStyle | Gets or sets the style applied to the edited cell.
Public Property | ParsingApplied | Gets or sets a value indicating whether a cell's value has been successfully parsed.
Public Property | RowIndex | Gets the row index of the cell that requires parsing.
Public Property | Value | Gets or sets the value of the ConvertEventArgs. (Inherited from ConvertEventArgs)
Top

See Also

Reference

DataGridViewCellParsingEventArgs Class
Gizmox.WebGUI.Forms Namespace


ColumnIndex Property

[image]
Gizmox.WebGUI.Forms
ColumnIndex Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCellParsingEventArgs Class : ColumnIndex Property

Gets the column index of the cell data that requires parsing.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ColumnIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCellParsingEventArgs
Dim value As Integer

value = instance.ColumnIndex
C#
public int ColumnIndex {get;}
Managed Extensions for C++
public: __property int get_ColumnIndex();
C++/CLI
public:
property int ColumnIndex {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCellParsingEventArgs Class
DataGridViewCellParsingEventArgs Members


InheritedCellStyle Property

[image]
Gizmox.WebGUI.Forms
InheritedCellStyle Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCellParsingEventArgs Class : InheritedCellStyle Property

Gets or sets the style applied to the edited cell.

Syntax

Visual Basic (Declaration)
Public Property InheritedCellStyle As DataGridViewCellStyle
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCellParsingEventArgs
Dim value As DataGridViewCellStyle

instance.InheritedCellStyle = value

value = instance.InheritedCellStyle
C#
public DataGridViewCellStyle InheritedCellStyle {get; set;}
Managed Extensions for C++
public: __property DataGridViewCellStyle* get_InheritedCellStyle();
public: __property void set_InheritedCellStyle(
   DataGridViewCellStyle* value
);
C++/CLI
public:
property DataGridViewCellStyle^ InheritedCellStyle {
   DataGridViewCellStyle^ get();
   void set (DataGridViewCellStyle^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCellParsingEventArgs Class
DataGridViewCellParsingEventArgs Members


ParsingApplied Property

[image]
Gizmox.WebGUI.Forms
ParsingApplied Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCellParsingEventArgs Class : ParsingApplied Property

Gets or sets a value indicating whether a cell's value has been successfully parsed.

Syntax

Visual Basic (Declaration)
Public Property ParsingApplied As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCellParsingEventArgs
Dim value As Boolean

instance.ParsingApplied = value

value = instance.ParsingApplied
C#
public bool ParsingApplied {get; set;}
Managed Extensions for C++
public: __property bool get_ParsingApplied();
public: __property void set_ParsingApplied(
   bool value
);
C++/CLI
public:
property bool ParsingApplied {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCellParsingEventArgs Class
DataGridViewCellParsingEventArgs Members


RowIndex Property

[image]
Gizmox.WebGUI.Forms
RowIndex Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCellParsingEventArgs Class : RowIndex Property

Gets the row index of the cell that requires parsing.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RowIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCellParsingEventArgs
Dim value As Integer

value = instance.RowIndex
C#
public int RowIndex {get;}
Managed Extensions for C++
public: __property int get_RowIndex();
C++/CLI
public:
property int RowIndex {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCellParsingEventArgs Class
DataGridViewCellParsingEventArgs Members


DataGridViewCellStateChangedEventArgs Class

[image]
Gizmox.WebGUI.Forms
DataGridViewCellStateChangedEventArgs Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewCellStateChangedEventArgs Class

Provides data for the CellStateChanged event.

Object Model

Syntax

Visual Basic (Declaration)
Public Class DataGridViewCellStateChangedEventArgs
   Inherits EventArgs
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCellStateChangedEventArgs
C#
public class DataGridViewCellStateChangedEventArgs : EventArgs
Managed Extensions for C++
public __gc class DataGridViewCellStateChangedEventArgs : public EventArgs
C++/CLI
public ref class DataGridViewCellStateChangedEventArgs : public EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gizmox.WebGUI.Forms.DataGridViewCellStateChangedEventArgs

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

DataGridViewCellStateChangedEventArgs Members
Gizmox.WebGUI.Forms Namespace


DataGridViewCellStateChangedEventArgs Class Members

[image]
Gizmox.WebGUI.Forms
DataGridViewCellStateChangedEventArgs Class Members
See Also Properties Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewCellStateChangedEventArgs Class

The following tables list the members exposed by DataGridViewCellStateChangedEventArgs.

Public Constructors

 | Name | Description
Public Constructor | DataGridViewCellStateChangedEventArgs Constructor | Initializes a new instance of the DataGridViewCellStateChangedEventArgs class.
Top

Public Properties

 | Name | Description
Public Property | Cell | Gets the DataGridViewCell that has a changed state.
Public Property | StateChanged | Gets the state that has changed on the cell.
Top

See Also

Reference

DataGridViewCellStateChangedEventArgs Class
Gizmox.WebGUI.Forms Namespace


DataGridViewCellStateChangedEventArgs Constructor

[image]
Gizmox.WebGUI.Forms
DataGridViewCellStateChangedEventArgs Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCellStateChangedEventArgs Class : DataGridViewCellStateChangedEventArgs Constructor

dataGridViewCell
The DataGridViewCell that has a changed state.
stateChanged
One of the DataGridViewElementStates values indicating the state that has changed on the cell.
Initializes a new instance of the DataGridViewCellStateChangedEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal dataGridViewCell As DataGridViewCell, _
   ByVal stateChanged As DataGridViewElementStates _
)
Visual Basic (Usage) Copy Code
Dim dataGridViewCell As DataGridViewCell
Dim stateChanged As DataGridViewElementStates

Dim instance As DataGridViewCellStateChangedEventArgs(dataGridViewCell, stateChanged)
C#
public DataGridViewCellStateChangedEventArgs(
   DataGridViewCell dataGridViewCell,
   DataGridViewElementStates stateChanged
)
Managed Extensions for C++
public: DataGridViewCellStateChangedEventArgs(
   DataGridViewCell* dataGridViewCell,
   DataGridViewElementStates stateChanged
)
C++/CLI
public:
DataGridViewCellStateChangedEventArgs(
   DataGridViewCell^ dataGridViewCell,
   DataGridViewElementStates stateChanged
)

Parameters

dataGridViewCell
The DataGridViewCell that has a changed state.
stateChanged
One of the DataGridViewElementStates values indicating the state that has changed on the cell.

Exceptions

Exception | Description
ArgumentNullException | dataGridViewCell is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCellStateChangedEventArgs Class
DataGridViewCellStateChangedEventArgs Members


DataGridViewCellStateChangedEventArgs Class Properties

[image]
Gizmox.WebGUI.Forms
DataGridViewCellStateChangedEventArgs Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewCellStateChangedEventArgs Class

For a list of all members of this type, see DataGridViewCellStateChangedEventArgs members.

Public Properties

 | Name | Description
Public Property | Cell | Gets the DataGridViewCell that has a changed state.
Public Property | StateChanged | Gets the state that has changed on the cell.
Top

See Also

Reference

DataGridViewCellStateChangedEventArgs Class
Gizmox.WebGUI.Forms Namespace


Cell Property

[image]
Gizmox.WebGUI.Forms
Cell Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCellStateChangedEventArgs Class : Cell Property

Gets the DataGridViewCell that has a changed state.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Cell As DataGridViewCell
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCellStateChangedEventArgs
Dim value As DataGridViewCell

value = instance.Cell
C#
public DataGridViewCell Cell {get;}
Managed Extensions for C++
public: __property DataGridViewCell* get_Cell();
C++/CLI
public:
property DataGridViewCell^ Cell {
   DataGridViewCell^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCellStateChangedEventArgs Class
DataGridViewCellStateChangedEventArgs Members


StateChanged Property

[image]
Gizmox.WebGUI.Forms
StateChanged Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCellStateChangedEventArgs Class : StateChanged Property

Gets the state that has changed on the cell.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property StateChanged As DataGridViewElementStates
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCellStateChangedEventArgs
Dim value As DataGridViewElementStates

value = instance.StateChanged
C#
public DataGridViewElementStates StateChanged {get;}
Managed Extensions for C++
public: __property DataGridViewElementStates get_StateChanged();
C++/CLI
public:
property DataGridViewElementStates StateChanged {
   DataGridViewElementStates get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCellStateChangedEventArgs Class
DataGridViewCellStateChangedEventArgs Members


DataGridViewCellStyle Class

[image]
Gizmox.WebGUI.Forms
DataGridViewCellStyle Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewCellStyle Class

Represents the formatting and style information applied to individual cells within a DataGridView control.

Object Model

Syntax

Visual Basic (Declaration)
<EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.DataGridViewCellStyleEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")>
<TypeConverterAttribute("Gizmox.WebGUI.Forms.DataGridViewCellStyleConverter, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d")>
Public Class DataGridViewCellStyle
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCellStyle
C#
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.DataGridViewCellStyleEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[TypeConverterAttribute("Gizmox.WebGUI.Forms.DataGridViewCellStyleConverter, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d")]
public class DataGridViewCellStyle
Managed Extensions for C++
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.DataGridViewCellStyleEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[TypeConverterAttribute("Gizmox.WebGUI.Forms.DataGridViewCellStyleConverter, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d")]
public __gc class DataGridViewCellStyle
C++/CLI
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.DataGridViewCellStyleEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[TypeConverterAttribute("Gizmox.WebGUI.Forms.DataGridViewCellStyleConverter, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d")]
public ref class DataGridViewCellStyle

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.DataGridViewCellStyle

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

DataGridViewCellStyle Members
Gizmox.WebGUI.Forms Namespace


DataGridViewCellStyle Class Members

[image]
Gizmox.WebGUI.Forms
DataGridViewCellStyle Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewCellStyle Class

The following tables list the members exposed by DataGridViewCellStyle.

Public Constructors

 | Name | Description
Public Constructor | DataGridViewCellStyle Constructor | Overloaded. Initializes a new instance of the DataGridViewCellStyle class using the property values of the specified DataGridViewCellStyle.
Top

Public Properties

 | Name | Description
Public Property | Alignment | Gets or sets a value indicating the position of the cell content within a DataGridView cell.
Public Property | BackColor | Gets or sets the background color of a DataGridView cell.
Public Property | DataSourceNullValue | Gets or sets the value saved to the data source when the user enters a null value into a cell.
Public Property | Font | Gets or sets the font applied to the textual content of a DataGridView cell.
Public Property | ForeColor | Gets or sets the foreground color of a DataGridView cell.
Public Property | Format | Gets or sets the format string applied to the textual content of a DataGridView cell.
Public Property | FormatProvider | Gets or sets the object used to provide culture-specific formatting of DataGridView cell values.
Public Property | IsDataSourceNullValueDefault | Gets a value indicating whether the DataSourceNullValue property has been set.
Public Property | IsFormatProviderDefault | Gets a value that indicates whether the FormatProvider property has been set.
Public Property | IsNullValueDefault | Gets a value indicating whether the NullValue property has been set.
Public Property | NullValue | Gets or sets the DataGridView cell display value corresponding to a cell value of Value or null.
Public Property | Padding | Gets or sets the space between the edge of a DataGridViewCell and its content.
Public Property | SelectionBackColor | Gets or sets the background color used by a DataGridView cell when it is selected.
Public Property | SelectionForeColor | Gets or sets the foreground color used by a DataGridView cell when it is selected.
Public Property | Tag | Gets or sets an object that contains additional data related to the DataGridViewCellStyle.
Public Property | WrapMode | Gets or sets a value indicating whether textual content in a DataGridView cell is wrapped to subsequent lines or truncated when it is too long to fit on a single line.
Top

Public Methods

 | Name | Description
Public Method | ApplyStyle | Applies the specified DataGridViewCellStyle to the current DataGridViewCellStyle.
Public Method | Clone | Creates an exact copy of this DataGridViewCellStyle.
Public Method | Equals | Overridden. Returns a value indicating whether this instance is equivalent to the specified object.
Public Method | GetHashCode | Overridden.
Public Method | ToString | Overridden. Returns a string indicating the current property settings of the DataGridViewCellStyle.
Top

See Also

Reference

DataGridViewCellStyle Class
Gizmox.WebGUI.Forms Namespace


DataGridViewCellStyle Constructor

[image]
Gizmox.WebGUI.Forms
DataGridViewCellStyle Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCellStyle Class : DataGridViewCellStyle Constructor

Initializes a new instance of the DataGridViewCellStyle class using the property values of the specified DataGridViewCellStyle.

Overload List

Overload | Description
DataGridViewCellStyle Constructor() |
DataGridViewCellStyle Constructor(DataGridViewCellStyle) | Initializes a new instance of the DataGridViewCellStyle class using the property values of the specified DataGridViewCellStyle.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCellStyle Class
DataGridViewCellStyle Members


DataGridViewCellStyle Constructor()

[image]
Gizmox.WebGUI.Forms
DataGridViewCellStyle Constructor()
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCellStyle Class > DataGridViewCellStyle Constructor : DataGridViewCellStyle Constructor()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCellStyle()
C#
public DataGridViewCellStyle()
Managed Extensions for C++
public: DataGridViewCellStyle();
C++/CLI
public:
DataGridViewCellStyle();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCellStyle Class
DataGridViewCellStyle Members
Overload List


DataGridViewCellStyle Constructor(DataGridViewCellStyle)

[image]
Gizmox.WebGUI.Forms
DataGridViewCellStyle Constructor(DataGridViewCellStyle)
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCellStyle Class > DataGridViewCellStyle Constructor : DataGridViewCellStyle Constructor(DataGridViewCellStyle)

dataGridViewCellStyle
The DataGridViewCellStyle used as a template to provide initial property values.
Initializes a new instance of the DataGridViewCellStyle class using the property values of the specified DataGridViewCellStyle.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal dataGridViewCellStyle As DataGridViewCellStyle _
)
Visual Basic (Usage) Copy Code
Dim dataGridViewCellStyle As DataGridViewCellStyle

Dim instance As DataGridViewCellStyle(dataGridViewCellStyle)
C#
public DataGridViewCellStyle(
   DataGridViewCellStyle dataGridViewCellStyle
)
Managed Extensions for C++
public: DataGridViewCellStyle(
   DataGridViewCellStyle* dataGridViewCellStyle
)
C++/CLI
public:
DataGridViewCellStyle(
   DataGridViewCellStyle^ dataGridViewCellStyle
)

Parameters

dataGridViewCellStyle
The DataGridViewCellStyle used as a template to provide initial property values.

Exceptions

Exception | Description
ArgumentNullException | dataGridViewCellStyle is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCellStyle Class
DataGridViewCellStyle Members
Overload List


DataGridViewCellStyle Class Methods

[image]
Gizmox.WebGUI.Forms
DataGridViewCellStyle Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewCellStyle Class

For a list of all members of this type, see DataGridViewCellStyle members.

Public Methods

 | Name | Description
Public Method | ApplyStyle | Applies the specified DataGridViewCellStyle to the current DataGridViewCellStyle.
Public Method | Clone | Creates an exact copy of this DataGridViewCellStyle.
Public Method | Equals | Overridden. Returns a value indicating whether this instance is equivalent to the specified object.
Public Method | GetHashCode | Overridden.
Public Method | ToString | Overridden. Returns a string indicating the current property settings of the DataGridViewCellStyle.
Top

See Also

Reference

DataGridViewCellStyle Class
Gizmox.WebGUI.Forms Namespace


ApplyStyle Method

[image]
Gizmox.WebGUI.Forms
ApplyStyle Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCellStyle Class : ApplyStyle Method

dataGridViewCellStyle
The DataGridViewCellStyle to apply to the current DataGridViewCellStyle.
Applies the specified DataGridViewCellStyle to the current DataGridViewCellStyle.

Syntax

Visual Basic (Declaration)
Public Overridable Sub ApplyStyle( _
   ByVal dataGridViewCellStyle As DataGridViewCellStyle _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCellStyle
Dim dataGridViewCellStyle As DataGridViewCellStyle

instance.ApplyStyle(dataGridViewCellStyle)
C#
public virtual void ApplyStyle(
   DataGridViewCellStyle dataGridViewCellStyle
)
Managed Extensions for C++
public: virtual void ApplyStyle(
   DataGridViewCellStyle* dataGridViewCellStyle
)
C++/CLI
public:
virtual void ApplyStyle(
   DataGridViewCellStyle^ dataGridViewCellStyle
)

Parameters

dataGridViewCellStyle
The DataGridViewCellStyle to apply to the current DataGridViewCellStyle.

Exceptions

Exception | Description
ArgumentNullException | dataGridViewCellStyle is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCellStyle Class
DataGridViewCellStyle Members


Clone Method

[image]
Gizmox.WebGUI.Forms
Clone Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCellStyle Class : Clone Method

Creates an exact copy of this DataGridViewCellStyle.

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As DataGridViewCellStyle
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCellStyle
Dim value As DataGridViewCellStyle

value = instance.Clone()
C#
public virtual DataGridViewCellStyle Clone()
Managed Extensions for C++
public: virtual DataGridViewCellStyle* Clone();
C++/CLI
public:
virtual DataGridViewCellStyle^ Clone();

Return Value

A DataGridViewCellStyle that represents an exact copy of this cell style.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCellStyle Class
DataGridViewCellStyle Members


Equals Method

[image]
Gizmox.WebGUI.Forms
Equals Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCellStyle Class : Equals Method

o
An object to compare with this instance, or null.
Returns a value indicating whether this instance is equivalent to the specified object.

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
   ByVal o As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCellStyle
Dim o As Object
Dim value As Boolean

value = instance.Equals(o)
C#
public override bool Equals(
   object o
)
Managed Extensions for C++
public: bool Equals(
   Object* o
) override
C++/CLI
public:
bool Equals(
   Object^ o
) override

Parameters

o
An object to compare with this instance, or null.

Return Value

true if o is a DataGridViewCellStyle and has the same property values as this instance; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCellStyle Class
DataGridViewCellStyle Members


GetHashCode Method

[image]
Gizmox.WebGUI.Forms
GetHashCode Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCellStyle Class : GetHashCode Method

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCellStyle
Dim value As Integer

value = instance.GetHashCode()
C#
public override int GetHashCode()
Managed Extensions for C++
public: int GetHashCode(); override
C++/CLI
public:
int GetHashCode(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCellStyle Class
DataGridViewCellStyle Members


ToString Method

[image]
Gizmox.WebGUI.Forms
ToString Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCellStyle Class : ToString Method

Returns a string indicating the current property settings of the DataGridViewCellStyle.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCellStyle
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Return Value

A string indicating the current property settings of the DataGridViewCellStyle.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCellStyle Class
DataGridViewCellStyle Members


DataGridViewCellStyle Class Properties

[image]
Gizmox.WebGUI.Forms
DataGridViewCellStyle Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewCellStyle Class

For a list of all members of this type, see DataGridViewCellStyle members.

Public Properties

 | Name | Description
Public Property | Alignment | Gets or sets a value indicating the position of the cell content within a DataGridView cell.
Public Property | BackColor | Gets or sets the background color of a DataGridView cell.
Public Property | DataSourceNullValue | Gets or sets the value saved to the data source when the user enters a null value into a cell.
Public Property | Font | Gets or sets the font applied to the textual content of a DataGridView cell.
Public Property | ForeColor | Gets or sets the foreground color of a DataGridView cell.
Public Property | Format | Gets or sets the format string applied to the textual content of a DataGridView cell.
Public Property | FormatProvider | Gets or sets the object used to provide culture-specific formatting of DataGridView cell values.
Public Property | IsDataSourceNullValueDefault | Gets a value indicating whether the DataSourceNullValue property has been set.
Public Property | IsFormatProviderDefault | Gets a value that indicates whether the FormatProvider property has been set.
Public Property | IsNullValueDefault | Gets a value indicating whether the NullValue property has been set.
Public Property | NullValue | Gets or sets the DataGridView cell display value corresponding to a cell value of Value or null.
Public Property | Padding | Gets or sets the space between the edge of a DataGridViewCell and its content.
Public Property | SelectionBackColor | Gets or sets the background color used by a DataGridView cell when it is selected.
Public Property | SelectionForeColor | Gets or sets the foreground color used by a DataGridView cell when it is selected.
Public Property | Tag | Gets or sets an object that contains additional data related to the DataGridViewCellStyle.
Public Property | WrapMode | Gets or sets a value indicating whether textual content in a DataGridView cell is wrapped to subsequent lines or truncated when it is too long to fit on a single line.
Top

See Also

Reference

DataGridViewCellStyle Class
Gizmox.WebGUI.Forms Namespace


Alignment Property

[image]
Gizmox.WebGUI.Forms
Alignment Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCellStyle Class : Alignment Property

Gets or sets a value indicating the position of the cell content within a DataGridView cell.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Indicates the position of the content within a cell.")>
<DefaultValueAttribute()>
<SRCategoryAttribute("Layout")>
Public Property Alignment As DataGridViewContentAlignment
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCellStyle
Dim value As DataGridViewContentAlignment

instance.Alignment = value

value = instance.Alignment
C#
[SRDescriptionAttribute("Indicates the position of the content within a cell.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Layout")]
public DataGridViewContentAlignment Alignment {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Indicates the position of the content within a cell.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Layout")]
public: __property DataGridViewContentAlignment get_Alignment();
public: __property void set_Alignment(
   DataGridViewContentAlignment value
);
C++/CLI
[SRDescriptionAttribute("Indicates the position of the content within a cell.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Layout")]
public:
property DataGridViewContentAlignment Alignment {
   DataGridViewContentAlignment get();
   void set (DataGridViewContentAlignmentvalue);
}

Exceptions

Exception | Description
InvalidEnumArgumentException | The property value is not a valid DataGridViewContentAlignment value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCellStyle Class
DataGridViewCellStyle Members


BackColor Property

[image]
Gizmox.WebGUI.Forms
BackColor Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCellStyle Class : BackColor Property

Gets or sets the background color of a DataGridView cell.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Appearance")>
Public Property BackColor As Color
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCellStyle
Dim value As Color

instance.BackColor = value

value = instance.BackColor
C#
[SRCategoryAttribute("Appearance")]
public Color BackColor {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Appearance")]
public: __property Color get_BackColor();
public: __property void set_BackColor(
   Color value
);
C++/CLI
[SRCategoryAttribute("Appearance")]
public:
property Color BackColor {
   Color get();
   void set (Colorvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCellStyle Class
DataGridViewCellStyle Members


DataSourceNullValue Property

[image]
Gizmox.WebGUI.Forms
DataSourceNullValue Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCellStyle Class : DataSourceNullValue Property

Gets or sets the value saved to the data source when the user enters a null value into a cell.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<DesignerSerializationVisibilityAttribute()>
Public Property DataSourceNullValue As Object
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCellStyle
Dim value As Object

instance.DataSourceNullValue = value

value = instance.DataSourceNullValue
C#
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[DesignerSerializationVisibilityAttribute()]
public object DataSourceNullValue {get; set;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[DesignerSerializationVisibilityAttribute()]
public: __property Object* get_DataSourceNullValue();
public: __property void set_DataSourceNullValue(
   Object* value
);
C++/CLI
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[DesignerSerializationVisibilityAttribute()]
public:
property Object^ DataSourceNullValue {
   Object^ get();
   void set (Object^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCellStyle Class
DataGridViewCellStyle Members


Font Property

[image]
Gizmox.WebGUI.Forms
Font Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCellStyle Class : Font Property

Gets or sets the font applied to the textual content of a DataGridView cell.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Appearance")>
Public Property Font As Font
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCellStyle
Dim value As Font

instance.Font = value

value = instance.Font
C#
[SRCategoryAttribute("Appearance")]
public Font Font {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Appearance")]
public: __property Font* get_Font();
public: __property void set_Font(
   Font* value
);
C++/CLI
[SRCategoryAttribute("Appearance")]
public:
property Font^ Font {
   Font^ get();
   void set (Font^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCellStyle Class
DataGridViewCellStyle Members


ForeColor Property

[image]
Gizmox.WebGUI.Forms
ForeColor Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCellStyle Class : ForeColor Property

Gets or sets the foreground color of a DataGridView cell.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Appearance")>
Public Property ForeColor As Color
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCellStyle
Dim value As Color

instance.ForeColor = value

value = instance.ForeColor
C#
[SRCategoryAttribute("Appearance")]
public Color ForeColor {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Appearance")]
public: __property Color get_ForeColor();
public: __property void set_ForeColor(
   Color value
);
C++/CLI
[SRCategoryAttribute("Appearance")]
public:
property Color ForeColor {
   Color get();
   void set (Colorvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCellStyle Class
DataGridViewCellStyle Members


Format Property

[image]
Gizmox.WebGUI.Forms
Format Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCellStyle Class : Format Property

Gets or sets the format string applied to the textual content of a DataGridView cell.

Syntax

Visual Basic (Declaration)
<EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.FormatStringEditor, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<DefaultValueAttribute()>
<SRCategoryAttribute("Behavior")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Property Format As String
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCellStyle
Dim value As String

instance.Format = value

value = instance.Format
C#
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.FormatStringEditor, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public string Format {get; set;}
Managed Extensions for C++
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.FormatStringEditor, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: __property string* get_Format();
public: __property void set_Format(
   string* value
);
C++/CLI
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.FormatStringEditor, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
property String^ Format {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCellStyle Class
DataGridViewCellStyle Members


FormatProvider Property

[image]
Gizmox.WebGUI.Forms
FormatProvider Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCellStyle Class : FormatProvider Property

Gets or sets the object used to provide culture-specific formatting of DataGridView cell values.

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<BrowsableAttribute(False)>
Public Property FormatProvider As IFormatProvider
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCellStyle
Dim value As IFormatProvider

instance.FormatProvider = value

value = instance.FormatProvider
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[BrowsableAttribute(false)]
public IFormatProvider FormatProvider {get; set;}
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[BrowsableAttribute(false)]
public: __property IFormatProvider* get_FormatProvider();
public: __property void set_FormatProvider(
   IFormatProvider* value
);
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[BrowsableAttribute(false)]
public:
property IFormatProvider^ FormatProvider {
   IFormatProvider^ get();
   void set (IFormatProvider^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCellStyle Class
DataGridViewCellStyle Members


IsDataSourceNullValueDefault Property

[image]
Gizmox.WebGUI.Forms
IsDataSourceNullValueDefault Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCellStyle Class : IsDataSourceNullValueDefault Property

Gets a value indicating whether the DataSourceNullValue property has been set.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public ReadOnly Property IsDataSourceNullValueDefault As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCellStyle
Dim value As Boolean

value = instance.IsDataSourceNullValueDefault
C#
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public bool IsDataSourceNullValueDefault {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: __property bool get_IsDataSourceNullValueDefault();
C++/CLI
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
property bool IsDataSourceNullValueDefault {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCellStyle Class
DataGridViewCellStyle Members


IsFormatProviderDefault Property

[image]
Gizmox.WebGUI.Forms
IsFormatProviderDefault Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCellStyle Class : IsFormatProviderDefault Property

Gets a value that indicates whether the FormatProvider property has been set.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public ReadOnly Property IsFormatProviderDefault As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCellStyle
Dim value As Boolean

value = instance.IsFormatProviderDefault
C#
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public bool IsFormatProviderDefault {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: __property bool get_IsFormatProviderDefault();
C++/CLI
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
property bool IsFormatProviderDefault {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCellStyle Class
DataGridViewCellStyle Members


IsNullValueDefault Property

[image]
Gizmox.WebGUI.Forms
IsNullValueDefault Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCellStyle Class : IsNullValueDefault Property

Gets a value indicating whether the NullValue property has been set.

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<BrowsableAttribute(False)>
Public ReadOnly Property IsNullValueDefault As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCellStyle
Dim value As Boolean

value = instance.IsNullValueDefault
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[BrowsableAttribute(false)]
public bool IsNullValueDefault {get;}
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[BrowsableAttribute(false)]
public: __property bool get_IsNullValueDefault();
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[BrowsableAttribute(false)]
public:
property bool IsNullValueDefault {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCellStyle Class
DataGridViewCellStyle Members


NullValue Property

[image]
Gizmox.WebGUI.Forms
NullValue Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCellStyle Class : NullValue Property

Gets or sets the DataGridView cell display value corresponding to a cell value of Value or null.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<SRCategoryAttribute("Data")>
<TypeConverterAttribute("System.ComponentModel.StringConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
Public Property NullValue As Object
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCellStyle
Dim value As Object

instance.NullValue = value

value = instance.NullValue
C#
[DefaultValueAttribute()]
[SRCategoryAttribute("Data")]
[TypeConverterAttribute("System.ComponentModel.StringConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public object NullValue {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[SRCategoryAttribute("Data")]
[TypeConverterAttribute("System.ComponentModel.StringConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public: __property Object* get_NullValue();
public: __property void set_NullValue(
   Object* value
);
C++/CLI
[DefaultValueAttribute()]
[SRCategoryAttribute("Data")]
[TypeConverterAttribute("System.ComponentModel.StringConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public:
property Object^ NullValue {
   Object^ get();
   void set (Object^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCellStyle Class
DataGridViewCellStyle Members


Padding Property

[image]
Gizmox.WebGUI.Forms
Padding Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCellStyle Class : Padding Property

Gets or sets the space between the edge of a DataGridViewCell and its content.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Layout")>
Public Property Padding As Padding
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCellStyle
Dim value As Padding

instance.Padding = value

value = instance.Padding
C#
[SRCategoryAttribute("Layout")]
public Padding Padding {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Layout")]
public: __property Padding get_Padding();
public: __property void set_Padding(
   Padding value
);
C++/CLI
[SRCategoryAttribute("Layout")]
public:
property Padding Padding {
   Padding get();
   void set (Paddingvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCellStyle Class
DataGridViewCellStyle Members


SelectionBackColor Property

[image]
Gizmox.WebGUI.Forms
SelectionBackColor Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCellStyle Class : SelectionBackColor Property

Gets or sets the background color used by a DataGridView cell when it is selected.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Appearance")>
Public Property SelectionBackColor As Color
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCellStyle
Dim value As Color

instance.SelectionBackColor = value

value = instance.SelectionBackColor
C#
[SRCategoryAttribute("Appearance")]
public Color SelectionBackColor {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Appearance")]
public: __property Color get_SelectionBackColor();
public: __property void set_SelectionBackColor(
   Color value
);
C++/CLI
[SRCategoryAttribute("Appearance")]
public:
property Color SelectionBackColor {
   Color get();
   void set (Colorvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCellStyle Class
DataGridViewCellStyle Members


SelectionForeColor Property

[image]
Gizmox.WebGUI.Forms
SelectionForeColor Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCellStyle Class : SelectionForeColor Property

Gets or sets the foreground color used by a DataGridView cell when it is selected.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Appearance")>
Public Property SelectionForeColor As Color
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCellStyle
Dim value As Color

instance.SelectionForeColor = value

value = instance.SelectionForeColor
C#
[SRCategoryAttribute("Appearance")]
public Color SelectionForeColor {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Appearance")]
public: __property Color get_SelectionForeColor();
public: __property void set_SelectionForeColor(
   Color value
);
C++/CLI
[SRCategoryAttribute("Appearance")]
public:
property Color SelectionForeColor {
   Color get();
   void set (Colorvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCellStyle Class
DataGridViewCellStyle Members


Tag Property

[image]
Gizmox.WebGUI.Forms
Tag Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCellStyle Class : Tag Property

Gets or sets an object that contains additional data related to the DataGridViewCellStyle.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public Property Tag As Object
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCellStyle
Dim value As Object

instance.Tag = value

value = instance.Tag
C#
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public object Tag {get; set;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property Object* get_Tag();
public: __property void set_Tag(
   Object* value
);
C++/CLI
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
property Object^ Tag {
   Object^ get();
   void set (Object^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCellStyle Class
DataGridViewCellStyle Members


WrapMode Property

[image]
Gizmox.WebGUI.Forms
WrapMode Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCellStyle Class : WrapMode Property

Gets or sets a value indicating whether textual content in a DataGridView cell is wrapped to subsequent lines or truncated when it is too long to fit on a single line.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<SRCategoryAttribute("Layout")>
Public Property WrapMode As DataGridViewTriState
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCellStyle
Dim value As DataGridViewTriState

instance.WrapMode = value

value = instance.WrapMode
C#
[DefaultValueAttribute()]
[SRCategoryAttribute("Layout")]
public DataGridViewTriState WrapMode {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[SRCategoryAttribute("Layout")]
public: __property DataGridViewTriState get_WrapMode();
public: __property void set_WrapMode(
   DataGridViewTriState value
);
C++/CLI
[DefaultValueAttribute()]
[SRCategoryAttribute("Layout")]
public:
property DataGridViewTriState WrapMode {
   DataGridViewTriState get();
   void set (DataGridViewTriStatevalue);
}

Exceptions

Exception | Description
InvalidEnumArgumentException | The property value is not a valid DataGridViewTriState value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCellStyle Class
DataGridViewCellStyle Members


DataGridViewCellStyleContentChangedEventArgs Class

[image]
Gizmox.WebGUI.Forms
DataGridViewCellStyleContentChangedEventArgs Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewCellStyleContentChangedEventArgs Class

Provides data for the CellStyleContentChanged event.

Object Model

Syntax

Visual Basic (Declaration)
Public Class DataGridViewCellStyleContentChangedEventArgs
   Inherits EventArgs
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCellStyleContentChangedEventArgs
C#
public class DataGridViewCellStyleContentChangedEventArgs : EventArgs
Managed Extensions for C++
public __gc class DataGridViewCellStyleContentChangedEventArgs : public EventArgs
C++/CLI
public ref class DataGridViewCellStyleContentChangedEventArgs : public EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gizmox.WebGUI.Forms.DataGridViewCellStyleContentChangedEventArgs

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

DataGridViewCellStyleContentChangedEventArgs Members
Gizmox.WebGUI.Forms Namespace


DataGridViewCellStyleContentChangedEventArgs Class Members

[image]
Gizmox.WebGUI.Forms
DataGridViewCellStyleContentChangedEventArgs Class Members
See Also Properties Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewCellStyleContentChangedEventArgs Class

The following tables list the members exposed by DataGridViewCellStyleContentChangedEventArgs.

Public Properties

 | Name | Description
Public Property | CellStyle | Gets the changed DataGridViewCellStyle.
Public Property | CellStyleScope | Gets the scope that is affected by the changed cell style.
Top

See Also

Reference

DataGridViewCellStyleContentChangedEventArgs Class
Gizmox.WebGUI.Forms Namespace


DataGridViewCellStyleContentChangedEventArgs Class Properties

[image]
Gizmox.WebGUI.Forms
DataGridViewCellStyleContentChangedEventArgs Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewCellStyleContentChangedEventArgs Class

For a list of all members of this type, see DataGridViewCellStyleContentChangedEventArgs members.

Public Properties

 | Name | Description
Public Property | CellStyle | Gets the changed DataGridViewCellStyle.
Public Property | CellStyleScope | Gets the scope that is affected by the changed cell style.
Top

See Also

Reference

DataGridViewCellStyleContentChangedEventArgs Class
Gizmox.WebGUI.Forms Namespace


CellStyle Property

[image]
Gizmox.WebGUI.Forms
CellStyle Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCellStyleContentChangedEventArgs Class : CellStyle Property

Gets the changed DataGridViewCellStyle.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CellStyle As DataGridViewCellStyle
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCellStyleContentChangedEventArgs
Dim value As DataGridViewCellStyle

value = instance.CellStyle
C#
public DataGridViewCellStyle CellStyle {get;}
Managed Extensions for C++
public: __property DataGridViewCellStyle* get_CellStyle();
C++/CLI
public:
property DataGridViewCellStyle^ CellStyle {
   DataGridViewCellStyle^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCellStyleContentChangedEventArgs Class
DataGridViewCellStyleContentChangedEventArgs Members


CellStyleScope Property

[image]
Gizmox.WebGUI.Forms
CellStyleScope Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCellStyleContentChangedEventArgs Class : CellStyleScope Property

Gets the scope that is affected by the changed cell style.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CellStyleScope As DataGridViewCellStyleScopes
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCellStyleContentChangedEventArgs
Dim value As DataGridViewCellStyleScopes

value = instance.CellStyleScope
C#
public DataGridViewCellStyleScopes CellStyleScope {get;}
Managed Extensions for C++
public: __property DataGridViewCellStyleScopes get_CellStyleScope();
C++/CLI
public:
property DataGridViewCellStyleScopes CellStyleScope {
   DataGridViewCellStyleScopes get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCellStyleContentChangedEventArgs Class
DataGridViewCellStyleContentChangedEventArgs Members


DataGridViewCellStyleConverter Class

[image]
Gizmox.WebGUI.Forms
DataGridViewCellStyleConverter Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewCellStyleConverter Class

Converts DataGridViewCellStyle objects to and from other data types.

Syntax

Visual Basic (Declaration)
Public Class DataGridViewCellStyleConverter
   Inherits TypeConverter
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCellStyleConverter
C#
public class DataGridViewCellStyleConverter : TypeConverter
Managed Extensions for C++
public __gc class DataGridViewCellStyleConverter : public TypeConverter
C++/CLI
public ref class DataGridViewCellStyleConverter : public TypeConverter

Inheritance Hierarchy

System.Object
System.ComponentModel.TypeConverter
Gizmox.WebGUI.Forms.DataGridViewCellStyleConverter

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

DataGridViewCellStyleConverter Members
Gizmox.WebGUI.Forms Namespace


DataGridViewCellStyleConverter Class Members

[image]
Gizmox.WebGUI.Forms
DataGridViewCellStyleConverter Class Members
See Also Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewCellStyleConverter Class

The following tables list the members exposed by DataGridViewCellStyleConverter.

Public Constructors

 | Name | Description
Public Constructor | DataGridViewCellStyleConverter Constructor |
Top

Public Methods

 | Name | Description
Public Method | CanConvertFrom | Overloaded. Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from System.ComponentModel.TypeConverter)
Public Method | CanConvertTo | Overloaded. Overridden. Returns whether this converter can convert the object to the specified type.
Public Method | ConvertFrom | Overloaded. Converts the given value to the type of this converter. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertFromInvariantString | Overloaded. Converts the given string to the type of this converter, using the invariant culture. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertFromString | Overloaded. Converts the specified text to an object. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertTo | Overloaded. Overridden. Converts the given value object to the specified type, using the arguments.
Public Method | ConvertToInvariantString | Overloaded. Converts the specified value to a culture-invariant string representation. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertToString | Overloaded. Converts the specified value to a string representation. (Inherited from System.ComponentModel.TypeConverter)
Public Method | CreateInstance | Overloaded. Re-creates an Object given a set of property values for the object. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetCreateInstanceSupported | Overloaded. Returns whether changing a value on this object requires a call to the CreateInstance method to create a new value. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetProperties | Overloaded. Returns a collection of properties for the type of array specified by the value parameter. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetPropertiesSupported | Overloaded. Returns whether this object supports properties. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValues | Overloaded. Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValuesExclusive | Overloaded. Returns whether the collection of standard values returned from GetStandardValues is an exclusive list. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValuesSupported | Overloaded. Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from System.ComponentModel.TypeConverter)
Public Method | IsValid | Overloaded. Returns whether the given value object is valid for this type. (Inherited from System.ComponentModel.TypeConverter)
Top

Protected Methods

 | Name | Description
Protected Method | GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from System.ComponentModel.TypeConverter)
Protected Method | GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from System.ComponentModel.TypeConverter)
Protected Method | SortProperties | (Inherited from System.ComponentModel.TypeConverter)
Top

See Also

Reference

DataGridViewCellStyleConverter Class
Gizmox.WebGUI.Forms Namespace


DataGridViewCellStyleConverter Constructor

[image]
Gizmox.WebGUI.Forms
DataGridViewCellStyleConverter Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCellStyleConverter Class : DataGridViewCellStyleConverter Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCellStyleConverter()
C#
public DataGridViewCellStyleConverter()
Managed Extensions for C++
public: DataGridViewCellStyleConverter();
C++/CLI
public:
DataGridViewCellStyleConverter();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCellStyleConverter Class
DataGridViewCellStyleConverter Members


DataGridViewCellStyleConverter Class Methods

[image]
Gizmox.WebGUI.Forms
DataGridViewCellStyleConverter Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewCellStyleConverter Class

For a list of all members of this type, see DataGridViewCellStyleConverter members.

Public Methods

 | Name | Description
Public Method | CanConvertFrom | Overloaded. Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from System.ComponentModel.TypeConverter)
Public Method | CanConvertTo | Overloaded. Overridden. Returns whether this converter can convert the object to the specified type.
Public Method | ConvertFrom | Overloaded. Converts the given value to the type of this converter. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertFromInvariantString | Overloaded. Converts the given string to the type of this converter, using the invariant culture. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertFromString | Overloaded. Converts the specified text to an object. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertTo | Overloaded. Overridden. Converts the given value object to the specified type, using the arguments.
Public Method | ConvertToInvariantString | Overloaded. Converts the specified value to a culture-invariant string representation. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertToString | Overloaded. Converts the specified value to a string representation. (Inherited from System.ComponentModel.TypeConverter)
Public Method | CreateInstance | Overloaded. Re-creates an Object given a set of property values for the object. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetCreateInstanceSupported | Overloaded. Returns whether changing a value on this object requires a call to the CreateInstance method to create a new value. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetProperties | Overloaded. Returns a collection of properties for the type of array specified by the value parameter. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetPropertiesSupported | Overloaded. Returns whether this object supports properties. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValues | Overloaded. Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValuesExclusive | Overloaded. Returns whether the collection of standard values returned from GetStandardValues is an exclusive list. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValuesSupported | Overloaded. Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from System.ComponentModel.TypeConverter)
Public Method | IsValid | Overloaded. Returns whether the given value object is valid for this type. (Inherited from System.ComponentModel.TypeConverter)
Top

Protected Methods

 | Name | Description
Protected Method | GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from System.ComponentModel.TypeConverter)
Protected Method | GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from System.ComponentModel.TypeConverter)
Protected Method | SortProperties | (Inherited from System.ComponentModel.TypeConverter)
Top

See Also

Reference

DataGridViewCellStyleConverter Class
Gizmox.WebGUI.Forms Namespace


CanConvertTo Method

[image]
Gizmox.WebGUI.Forms
CanConvertTo Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCellStyleConverter Class : CanConvertTo Method

Returns whether this converter can convert the object to the specified type.

Overload List

Overload | Description
CanConvertTo(ITypeDescriptorContext,Type) |
CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from System.ComponentModel.TypeConverter)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCellStyleConverter Class
DataGridViewCellStyleConverter Members


CanConvertTo(ITypeDescriptorContext,Type) Method

[image]
Gizmox.WebGUI.Forms
CanConvertTo(ITypeDescriptorContext,Type) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCellStyleConverter Class > CanConvertTo Method : CanConvertTo(ITypeDescriptorContext,Type) Method

context
destinationType

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function CanConvertTo( _
   ByVal context As ITypeDescriptorContext, _
   ByVal destinationType As Type _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCellStyleConverter
Dim context As ITypeDescriptorContext
Dim destinationType As Type
Dim value As Boolean

value = instance.CanConvertTo(context, destinationType)
C#
public override bool CanConvertTo(
   ITypeDescriptorContext context,
   Type destinationType
)
Managed Extensions for C++
public: bool CanConvertTo(
   ITypeDescriptorContext* context,
   Type* destinationType
) override
C++/CLI
public:
bool CanConvertTo(
   ITypeDescriptorContext^ context,
   Type^ destinationType
) override

Parameters

context
destinationType

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCellStyleConverter Class
DataGridViewCellStyleConverter Members
Overload List


ConvertTo Method

[image]
Gizmox.WebGUI.Forms
ConvertTo Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCellStyleConverter Class : ConvertTo Method

Converts the given value object to the specified type, using the arguments.

Overload List

Overload | Description
ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) |
ConvertTo(Object,Type) | Converts the given value object to the specified type, using the arguments. (Inherited from System.ComponentModel.TypeConverter)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCellStyleConverter Class
DataGridViewCellStyleConverter Members


ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) Method

[image]
Gizmox.WebGUI.Forms
ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCellStyleConverter Class > ConvertTo Method : ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) Method

context
culture
value
destinationType

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function ConvertTo( _
   ByVal context As ITypeDescriptorContext, _
   ByVal culture As CultureInfo, _
   ByVal value As Object, _
   ByVal destinationType As Type _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCellStyleConverter
Dim context As ITypeDescriptorContext
Dim culture As CultureInfo
Dim value As Object
Dim destinationType As Type
Dim value As Object

value = instance.ConvertTo(context, culture, value, destinationType)
C#
public override object ConvertTo(
   ITypeDescriptorContext context,
   CultureInfo culture,
   object value,
   Type destinationType
)
Managed Extensions for C++
public: Object* ConvertTo(
   ITypeDescriptorContext* context,
   CultureInfo* culture,
   Object* value,
   Type* destinationType
) override
C++/CLI
public:
Object^ ConvertTo(
   ITypeDescriptorContext^ context,
   CultureInfo^ culture,
   Object^ value,
   Type^ destinationType
) override

Parameters

context
culture
value
destinationType

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCellStyleConverter Class
DataGridViewCellStyleConverter Members
Overload List


DataGridViewCellToolTipTextNeededEventArgs Class

[image]
Gizmox.WebGUI.Forms
DataGridViewCellToolTipTextNeededEventArgs Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewCellToolTipTextNeededEventArgs Class

Provides data for the CellToolTipTextNeeded event.

Syntax

Visual Basic (Declaration)
Public Class DataGridViewCellToolTipTextNeededEventArgs
   Inherits DataGridViewCellEventArgs
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCellToolTipTextNeededEventArgs
C#
public class DataGridViewCellToolTipTextNeededEventArgs : DataGridViewCellEventArgs
Managed Extensions for C++
public __gc class DataGridViewCellToolTipTextNeededEventArgs : public DataGridViewCellEventArgs
C++/CLI
public ref class DataGridViewCellToolTipTextNeededEventArgs : public DataGridViewCellEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gizmox.WebGUI.Forms.DataGridViewCellEventArgs
Gizmox.WebGUI.Forms.DataGridViewCellToolTipTextNeededEventArgs

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

DataGridViewCellToolTipTextNeededEventArgs Members
Gizmox.WebGUI.Forms Namespace


DataGridViewCellToolTipTextNeededEventArgs Class Members

[image]
Gizmox.WebGUI.Forms
DataGridViewCellToolTipTextNeededEventArgs Class Members
See Also Properties Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewCellToolTipTextNeededEventArgs Class

The following tables list the members exposed by DataGridViewCellToolTipTextNeededEventArgs.

Public Properties

 | Name | Description
Public Property | ColumnIndex | Gets a value indicating the column index of the cell that the event occurs for. (Inherited from DataGridViewCellEventArgs)
Public Property | RowIndex | Gets a value indicating the row index of the cell that the event occurs for. (Inherited from DataGridViewCellEventArgs)
Public Property | ToolTipText | Gets or sets the ToolTip text.
Top

See Also

Reference

DataGridViewCellToolTipTextNeededEventArgs Class
Gizmox.WebGUI.Forms Namespace


DataGridViewCellToolTipTextNeededEventArgs Class Properties

[image]
Gizmox.WebGUI.Forms
DataGridViewCellToolTipTextNeededEventArgs Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewCellToolTipTextNeededEventArgs Class

For a list of all members of this type, see DataGridViewCellToolTipTextNeededEventArgs members.

Public Properties

 | Name | Description
Public Property | ColumnIndex | Gets a value indicating the column index of the cell that the event occurs for. (Inherited from DataGridViewCellEventArgs)
Public Property | RowIndex | Gets a value indicating the row index of the cell that the event occurs for. (Inherited from DataGridViewCellEventArgs)
Public Property | ToolTipText | Gets or sets the ToolTip text.
Top

See Also

Reference

DataGridViewCellToolTipTextNeededEventArgs Class
Gizmox.WebGUI.Forms Namespace


ToolTipText Property

[image]
Gizmox.WebGUI.Forms
ToolTipText Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCellToolTipTextNeededEventArgs Class : ToolTipText Property

Gets or sets the ToolTip text.

Syntax

Visual Basic (Declaration)
Public Property ToolTipText As String
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCellToolTipTextNeededEventArgs
Dim value As String

instance.ToolTipText = value

value = instance.ToolTipText
C#
public string ToolTipText {get; set;}
Managed Extensions for C++
public: __property string* get_ToolTipText();
public: __property void set_ToolTipText(
   string* value
);
C++/CLI
public:
property String^ ToolTipText {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCellToolTipTextNeededEventArgs Class
DataGridViewCellToolTipTextNeededEventArgs Members


DataGridViewCellValidatingEventArgs Class

[image]
Gizmox.WebGUI.Forms
DataGridViewCellValidatingEventArgs Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewCellValidatingEventArgs Class

Provides data for the DataGridView.CellValidating event of a DataGridView control.

Syntax

Visual Basic (Declaration)
Public Class DataGridViewCellValidatingEventArgs
   Inherits CancelEventArgs
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCellValidatingEventArgs
C#
public class DataGridViewCellValidatingEventArgs : CancelEventArgs
Managed Extensions for C++
public __gc class DataGridViewCellValidatingEventArgs : public CancelEventArgs
C++/CLI
public ref class DataGridViewCellValidatingEventArgs : public CancelEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
System.ComponentModel.CancelEventArgs
Gizmox.WebGUI.Forms.DataGridViewCellValidatingEventArgs

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

DataGridViewCellValidatingEventArgs Members
Gizmox.WebGUI.Forms Namespace


DataGridViewCellValidatingEventArgs Class Members

[image]
Gizmox.WebGUI.Forms
DataGridViewCellValidatingEventArgs Class Members
See Also Properties Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewCellValidatingEventArgs Class

The following tables list the members exposed by DataGridViewCellValidatingEventArgs.

Public Properties

 | Name | Description
Public Property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from System.ComponentModel.CancelEventArgs)
Public Property | ColumnIndex | Gets the column index of the cell that needs to be validated.
Public Property | FormattedValue | Gets the formatted contents of the cell that needs to be validated.
Public Property | RowIndex | Gets the row index of the cell that needs to be validated.
Top

See Also

Reference

DataGridViewCellValidatingEventArgs Class
Gizmox.WebGUI.Forms Namespace


DataGridViewCellValidatingEventArgs Class Properties

[image]
Gizmox.WebGUI.Forms
DataGridViewCellValidatingEventArgs Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewCellValidatingEventArgs Class

For a list of all members of this type, see DataGridViewCellValidatingEventArgs members.

Public Properties

 | Name | Description
Public Property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from System.ComponentModel.CancelEventArgs)
Public Property | ColumnIndex | Gets the column index of the cell that needs to be validated.
Public Property | FormattedValue | Gets the formatted contents of the cell that needs to be validated.
Public Property | RowIndex | Gets the row index of the cell that needs to be validated.
Top

See Also

Reference

DataGridViewCellValidatingEventArgs Class
Gizmox.WebGUI.Forms Namespace


ColumnIndex Property

[image]
Gizmox.WebGUI.Forms
ColumnIndex Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCellValidatingEventArgs Class : ColumnIndex Property

Gets the column index of the cell that needs to be validated.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ColumnIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCellValidatingEventArgs
Dim value As Integer

value = instance.ColumnIndex
C#
public int ColumnIndex {get;}
Managed Extensions for C++
public: __property int get_ColumnIndex();
C++/CLI
public:
property int ColumnIndex {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCellValidatingEventArgs Class
DataGridViewCellValidatingEventArgs Members


FormattedValue Property

[image]
Gizmox.WebGUI.Forms
FormattedValue Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCellValidatingEventArgs Class : FormattedValue Property

Gets the formatted contents of the cell that needs to be validated.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FormattedValue As Object
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCellValidatingEventArgs
Dim value As Object

value = instance.FormattedValue
C#
public object FormattedValue {get;}
Managed Extensions for C++
public: __property Object* get_FormattedValue();
C++/CLI
public:
property Object^ FormattedValue {
   Object^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCellValidatingEventArgs Class
DataGridViewCellValidatingEventArgs Members


RowIndex Property

[image]
Gizmox.WebGUI.Forms
RowIndex Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCellValidatingEventArgs Class : RowIndex Property

Gets the row index of the cell that needs to be validated.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RowIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCellValidatingEventArgs
Dim value As Integer

value = instance.RowIndex
C#
public int RowIndex {get;}
Managed Extensions for C++
public: __property int get_RowIndex();
C++/CLI
public:
property int RowIndex {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCellValidatingEventArgs Class
DataGridViewCellValidatingEventArgs Members


DataGridViewCellValueEventArgs Class

[image]
Gizmox.WebGUI.Forms
DataGridViewCellValueEventArgs Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewCellValueEventArgs Class

Provides data for the CellValueNeeded and CellValuePushed events of the DataGridView control.

Syntax

Visual Basic (Declaration)
Public Class DataGridViewCellValueEventArgs
   Inherits EventArgs
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCellValueEventArgs
C#
public class DataGridViewCellValueEventArgs : EventArgs
Managed Extensions for C++
public __gc class DataGridViewCellValueEventArgs : public EventArgs
C++/CLI
public ref class DataGridViewCellValueEventArgs : public EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gizmox.WebGUI.Forms.DataGridViewCellValueEventArgs

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

DataGridViewCellValueEventArgs Members
Gizmox.WebGUI.Forms Namespace


DataGridViewCellValueEventArgs Class Members

[image]
Gizmox.WebGUI.Forms
DataGridViewCellValueEventArgs Class Members
See Also Properties Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewCellValueEventArgs Class

The following tables list the members exposed by DataGridViewCellValueEventArgs.

Public Constructors

 | Name | Description
Public Constructor | DataGridViewCellValueEventArgs Constructor | Initializes a new instance of the DataGridViewCellValueEventArgs class.
Top

Public Properties

 | Name | Description
Public Property | ColumnIndex | Gets a value indicating the column index of the cell that the event occurs for.
Public Property | RowIndex | Gets a value indicating the row index of the cell that the event occurs for.
Public Property | Value | Gets or sets the value of the cell that the event occurs for.
Top

See Also

Reference

DataGridViewCellValueEventArgs Class
Gizmox.WebGUI.Forms Namespace


DataGridViewCellValueEventArgs Constructor

[image]
Gizmox.WebGUI.Forms
DataGridViewCellValueEventArgs Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCellValueEventArgs Class : DataGridViewCellValueEventArgs Constructor

columnIndex
The index of the column containing the cell that the event occurs for.
rowIndex
The index of the row containing the cell that the event occurs for.
Initializes a new instance of the DataGridViewCellValueEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal columnIndex As Integer, _
   ByVal rowIndex As Integer _
)
Visual Basic (Usage) Copy Code
Dim columnIndex As Integer
Dim rowIndex As Integer

Dim instance As DataGridViewCellValueEventArgs(columnIndex, rowIndex)
C#
public DataGridViewCellValueEventArgs(
   int columnIndex,
   int rowIndex
)
Managed Extensions for C++
public: DataGridViewCellValueEventArgs(
   int columnIndex,
   int rowIndex
)
C++/CLI
public:
DataGridViewCellValueEventArgs(
   int columnIndex,
   int rowIndex
)

Parameters

columnIndex
The index of the column containing the cell that the event occurs for.
rowIndex
The index of the row containing the cell that the event occurs for.

Exceptions

Exception | Description
ArgumentOutOfRangeException | columnIndex is less than 0.-or-rowIndex is less than 0.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCellValueEventArgs Class
DataGridViewCellValueEventArgs Members


DataGridViewCellValueEventArgs Class Properties

[image]
Gizmox.WebGUI.Forms
DataGridViewCellValueEventArgs Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewCellValueEventArgs Class

For a list of all members of this type, see DataGridViewCellValueEventArgs members.

Public Properties

 | Name | Description
Public Property | ColumnIndex | Gets a value indicating the column index of the cell that the event occurs for.
Public Property | RowIndex | Gets a value indicating the row index of the cell that the event occurs for.
Public Property | Value | Gets or sets the value of the cell that the event occurs for.
Top

See Also

Reference

DataGridViewCellValueEventArgs Class
Gizmox.WebGUI.Forms Namespace


ColumnIndex Property

[image]
Gizmox.WebGUI.Forms
ColumnIndex Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCellValueEventArgs Class : ColumnIndex Property

Gets a value indicating the column index of the cell that the event occurs for.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ColumnIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCellValueEventArgs
Dim value As Integer

value = instance.ColumnIndex
C#
public int ColumnIndex {get;}
Managed Extensions for C++
public: __property int get_ColumnIndex();
C++/CLI
public:
property int ColumnIndex {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCellValueEventArgs Class
DataGridViewCellValueEventArgs Members


RowIndex Property

[image]
Gizmox.WebGUI.Forms
RowIndex Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCellValueEventArgs Class : RowIndex Property

Gets a value indicating the row index of the cell that the event occurs for.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RowIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCellValueEventArgs
Dim value As Integer

value = instance.RowIndex
C#
public int RowIndex {get;}
Managed Extensions for C++
public: __property int get_RowIndex();
C++/CLI
public:
property int RowIndex {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCellValueEventArgs Class
DataGridViewCellValueEventArgs Members


Value Property

[image]
Gizmox.WebGUI.Forms
Value Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCellValueEventArgs Class : Value Property

Gets or sets the value of the cell that the event occurs for.

Syntax

Visual Basic (Declaration)
Public Property Value As Object
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCellValueEventArgs
Dim value As Object

instance.Value = value

value = instance.Value
C#
public object Value {get; set;}
Managed Extensions for C++
public: __property Object* get_Value();
public: __property void set_Value(
   Object* value
);
C++/CLI
public:
property Object^ Value {
   Object^ get();
   void set (Object^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCellValueEventArgs Class
DataGridViewCellValueEventArgs Members


DataGridViewCheckBoxCell Class

[image]
Gizmox.WebGUI.Forms
DataGridViewCheckBoxCell Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewCheckBoxCell Class

Displays a check box user interface (UI) to use in a DataGridView control.

Object Model

Syntax

Visual Basic (Declaration)
Public Class DataGridViewCheckBoxCell
   Inherits DataGridViewCell
   Implements IRenderableComponentMember, IDataGridViewEditingCell
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCheckBoxCell
C#
public class DataGridViewCheckBoxCell : DataGridViewCell, IRenderableComponentMember, IDataGridViewEditingCell
Managed Extensions for C++
public __gc class DataGridViewCheckBoxCell : public DataGridViewCell, IRenderableComponentMember, IDataGridViewEditingCell
C++/CLI
public ref class DataGridViewCheckBoxCell : public DataGridViewCell, IRenderableComponentMember, IDataGridViewEditingCell

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.DataGridViewElement
Gizmox.WebGUI.Forms.DataGridViewCell
Gizmox.WebGUI.Forms.DataGridViewCheckBoxCell

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

DataGridViewCheckBoxCell Members
Gizmox.WebGUI.Forms Namespace


DataGridViewCheckBoxCell Class Members

[image]
Gizmox.WebGUI.Forms
DataGridViewCheckBoxCell Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewCheckBoxCell Class

The following tables list the members exposed by DataGridViewCheckBoxCell.

Public Constructors

 | Name | Description
Public Constructor | DataGridViewCheckBoxCell Constructor | Overloaded. Initializes a new instance of the DataGridViewCheckBoxCell class to its default state.
Top

Public Properties

 | Name | Description
Public Property | ColumnIndex | Gets the column index for this cell. (Inherited from DataGridViewCell)
Public Property | ContentBounds | (Inherited from DataGridViewCell)
Public Property | DataGridView | Gets the DataGridView control associated with this element. (Inherited from DataGridViewElement)
Public Property | DefaultNewRowValue | Gets the default value for a cell in the row for new records. (Inherited from DataGridViewCell)
Public Property | Displayed | Gets a value that indicates whether the cell is currently displayed on-screen. (Inherited from DataGridViewCell)
Public Property | EditedFormattedValue | Gets the current, formatted value of the cell, regardless of whether the cell is in edit mode and the value has not been committed. (Inherited from DataGridViewCell)
Public Property | EditingCellFormattedValue | Gets or sets the formatted value of the control hosted by the cell when it is in edit mode.
Public Property | EditingCellValueChanged | Gets or sets a flag indicating that the value has been changed for this cell.
Public Property | EditType | Overridden. Gets the type of the cell's hosted editing control.
Public Property | ErrorIconBounds | (Inherited from DataGridViewCell)
Public Property | ErrorText | Gets or sets the text describing an error condition associated with the cell. (Inherited from DataGridViewCell)
Public Property | FalseValue | Gets or sets the underlying value corresponding to a cell value of false.
Public Property | FlatStyle | Gets or sets the flat style appearance of the check box user interface (UI).
Public Property | FormattedValue | Gets the value of the cell as formatted for display. (Inherited from DataGridViewCell)
Public Property | FormattedValueType | Overridden. Gets the type of the cell display value.
Public Property | Frozen | Gets a value indicating whether the cell is frozen. (Inherited from DataGridViewCell)
Public Property | HasStyle | Gets a value indicating whether the DataGridViewCell.Style property has been set. (Inherited from DataGridViewCell)
Public Property | IndeterminateValue | Gets or sets the underlying value corresponding to an indeterminate or null cell value.
Public Property | InheritedState | Gets the current state of the cell as inherited from the state of its row and column. (Inherited from DataGridViewCell)
Public Property | InheritedStyle | Gets the style currently applied to the cell. (Inherited from DataGridViewCell)
Public Property | IsInEditMode | Gets a value indicating whether this cell is currently being edited. (Inherited from DataGridViewCell)
Public Property | OwningColumn | Gets the column that contains this cell. (Inherited from DataGridViewCell)
Public Property | OwningRow | Gets the row that contains this cell. (Inherited from DataGridViewCell)
Public Property | PreferredSize | Gets the size, in pixels, of a rectangular area into which the cell can fit. (Inherited from DataGridViewCell)
Public Property | ReadOnly | Gets or sets a value indicating whether the cell's data can be edited. (Inherited from DataGridViewCell)
Public Property | Resizable | Gets a value indicating whether the cell can be resized. (Inherited from DataGridViewCell)
Public Property | RowIndex | Gets the index of the cell's parent row. (Inherited from DataGridViewCell)
Public Property | Selected | Gets or sets a value indicating whether the cell has been selected. (Inherited from DataGridViewCell)
Public Property | Size | Gets the size of the cell. (Inherited from DataGridViewCell)
Public Property | State | Gets the user interface (UI) state of the element. (Inherited from DataGridViewElement)
Public Property | Style | Gets or sets the style for the cell. (Inherited from DataGridViewCell)
Public Property | Tag | Gets or sets the object that contains supplemental data about the cell. (Inherited from DataGridViewCell)
Public Property | ThreeState | Gets or sets a value indicating whether ternary mode has been enabled for the hosted check box control.
Public Property | ToolTipText | Gets or sets the ToolTip text associated with this cell. (Inherited from DataGridViewCell)
Public Property | TrueValue | Gets or sets the underlying value corresponding to a cell value of true.
Public Property | Value | Gets or sets the value associated with this cell. (Inherited from DataGridViewCell)
Public Property | ValueType | Overridden. Gets the data type of the values in the cell.
Public Property | Visible | Gets a value indicating whether the cell is in a row or column that has been hidden. (Inherited from DataGridViewCell)
Top

Protected Properties

 | Name | Description
Protected Property | MemberID | (Inherited from DataGridViewCell)
Protected Property | TagName | (Inherited from DataGridViewElement)
Top

Public Methods

 | Name | Description
Public Method | AdjustCellBorderStyle | Modifies the input cell border style according to the specified criteria. (Inherited from DataGridViewCell)
Public Method | Clone | Overridden. Creates an exact copy of this cell.
Public Method | DetachEditingControl | Removes the cell's editing control from the DataGridView. (Inherited from DataGridViewCell)
Public Method | Dispose | Overloaded. Releases all resources used by the DataGridViewCell. (Inherited from DataGridViewCell)
Public Method | GetContentBounds | Overloaded. (Inherited from DataGridViewCell)
Public Method | GetEditedFormattedValue | Returns the current, formatted value of the cell, regardless of whether the cell is in edit mode and the value has not been committed. (Inherited from DataGridViewCell)
Public Method | GetEditingCellFormattedValue | Gets the formatted value of the cell while it is in edit mode.
Public Method | GetInheritedState | Returns a value indicating the current state of the cell as inherited from the state of its row and column. (Inherited from DataGridViewCell)
Public Method | GetInheritedStyle | Gets the style applied to the cell. (Inherited from DataGridViewCell)
Public Method | InitializeEditingControl | Initializes the control used to edit the cell. (Inherited from DataGridViewCell)
Public Method | KeyEntersEditMode | Determines if edit mode should be started based on the given key. (Inherited from DataGridViewCell)
Public Method | ParseFormattedValue | Overridden. Converts a value formatted for display to an actual cell value.
Public Method | PositionEditingControl | Sets the location and size of the editing control hosted by a cell in the DataGridView control. (Inherited from DataGridViewCell)
Public Method | PositionEditingPanel | (Inherited from DataGridViewCell)
Public Method | PrepareEditingCellForEdit | This method is not meaningful for this type.
Public Method | ToString | Overridden. Returns the string representation of the cell.
Public Method | Update | Overloaded. Full updates of this instance. (Inherited from DataGridViewElement)
Top

Protected Methods

 | Name | Description
Protected Method | BorderWidths | (Inherited from DataGridViewCell)
Protected Method | ClickUnsharesRow | Indicates whether the cell's row will be unshared when the cell is clicked. (Inherited from DataGridViewCell)
Protected Method | ContentClickUnsharesRow | Overridden. Indicates whether the row containing the cell will be unshared when the cell content is clicked.
Protected Method | ContentDoubleClickUnsharesRow | Overridden. Indicates whether the row containing the cell will be unshared when the cell content is double-clicked.
Protected Method | DoubleClickUnsharesRow | Indicates whether the cell's row will be unshared when the cell is double-clicked. (Inherited from DataGridViewCell)
Protected Method | EnterUnsharesRow | Indicates whether the parent row will be unshared when the focus moves to the cell. (Inherited from DataGridViewCell)
Protected Method | GetClipboardContent | Retrieves the formatted value of the cell to copy to the Clipboard. (Inherited from DataGridViewCell)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from DataGridViewElement)
Protected Method | GetDefaultHorizontalAlignment | Gets the horizontal alignment. (Inherited from DataGridViewCell)
Protected Method | GetDefaultVerticalAlignment | Gets the vertical alignment. (Inherited from DataGridViewCell)
Protected Method | GetErrorIconBounds | (Inherited from DataGridViewCell)
Protected Method | GetErrorText | Returns a string that represents the error for the cell. (Inherited from DataGridViewCell)
Protected Method | GetFormattedValue | Overridden. Gets the formatted value of the cell's data.
Protected Method | GetPreferredSize | Overloaded. Overridden. Calculates the preferred size, in pixels, of the cell.
Protected Method | GetSize | Gets the size of the cell. (Inherited from DataGridViewCell)
Protected Method | GetValue | Gets the value of the cell. (Inherited from DataGridViewCell)
Protected Method | IsDirty | Determines whether the specified component is dirty. (Inherited from DataGridViewElement)
Protected Method | IsDirtyAttributes | Overloaded. Determines whether the specified component is dirty. (Inherited from DataGridViewElement)
Protected Method | KeyDownUnsharesRow | Indicates whether the parent row is unshared if the user presses a key while the focus is on the cell. (Inherited from DataGridViewCell)
Protected Method | KeyPressUnsharesRow | Indicates whether a row will be unshared if a key is pressed while a cell in the row has focus. (Inherited from DataGridViewCell)
Protected Method | KeyUpUnsharesRow | Indicates whether the parent row is unshared when the user releases a key while the focus is on the cell. (Inherited from DataGridViewCell)
Protected Method | LeaveUnsharesRow | Indicates whether a row will be unshared when the focus leaves a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseClickUnsharesRow | Indicates whether a row will be unshared if the user clicks a mouse button while the pointer is on a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseDoubleClickUnsharesRow | Indicates whether a row will be unshared if the user double-clicks a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseDownUnsharesRow | Indicates whether a row will be unshared when the user holds down a mouse button while the pointer is on a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseEnterUnsharesRow | Indicates whether a row will be unshared when the mouse pointer moves over a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseLeaveUnsharesRow | Indicates whether a row will be unshared when the mouse pointer leaves the row. (Inherited from DataGridViewCell)
Protected Method | MouseMoveUnsharesRow | Indicates whether a row will be unshared when the mouse pointer moves over a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseUpUnsharesRow | Indicates whether a row will be unshared when the user releases a mouse button while the pointer is on a cell in the row. (Inherited from DataGridViewCell)
Protected Method | OnClick | Called when the cell is clicked. (Inherited from DataGridViewCell)
Protected Method | OnContentClick | Overridden.
Protected Method | OnContentDoubleClick | Overridden.
Protected Method | OnDataGridViewChanged | Called when the DataGridViewElement.DataGridView property of the cell changes. (Inherited from DataGridViewCell)
Protected Method | OnDoubleClick | Called when the cell is double-clicked. (Inherited from DataGridViewCell)
Protected Method | OnEnter | Called when the focus moves to a cell. (Inherited from DataGridViewCell)
Protected Method | OnKeyDown | Called when a character key is pressed while the focus is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnKeyPress | Called when a key is pressed while the focus is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnKeyUp | Called when a character key is released while the focus is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnLeave | Called when the focus moves from a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseClick | Called when the user clicks a mouse button while the pointer is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseDoubleClick | Called when the user double-clicks a mouse button while the pointer is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseDown | Called when the user holds down a mouse button while the pointer is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseEnter | Called when the mouse pointer moves over a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseLeave | Called when the mouse pointer leaves the cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseMove | Called when the mouse pointer moves within a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseUp | Called when the user releases a mouse button while the pointer is on a cell. (Inherited from DataGridViewCell)
Protected Method | Paint | (Inherited from DataGridViewCell)
Protected Method | PaintErrorIcon | (Inherited from DataGridViewCell)
Protected Method | ProcessGatewayRequest | (Inherited from DataGridViewCell)
Protected Method | RaiseCellClick | Raises the DataGridView.CellClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellContentClick | Raises the DataGridView.CellContentClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellContentDoubleClick | Raises the DataGridView.CellContentDoubleClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellValueChanged | Raises the CellValueChanged event. (Inherited from DataGridViewElement)
Protected Method | RaiseDataError | Raises the DataError event. (Inherited from DataGridViewElement)
Protected Method | RaiseMouseWheel | Raises the MouseWheel event. (Inherited from DataGridViewElement)
Protected Method | RenderAttributes | Overridden.
Protected Method | RenderBackColorAttribute | Renders the back color attribute. (Inherited from DataGridViewCell)
Protected Method | RenderComponent | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from DataGridViewElement)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from DataGridViewElement)
Protected Method | RenderComponents | Renders the controls sub tree (Inherited from DataGridViewElement)
Protected Method | RenderForeColorAttribute | Renders the fore color attribute. (Inherited from DataGridViewCell)
Protected Method | RenderReadOnlyAttribute | Renders the read only attribute. (Inherited from DataGridViewCell)
Protected Method | RenderUpdatedAttributes | Overridden.
Protected Method | RenderWrapModeAttribute | Renders the wrap mode attribute. (Inherited from DataGridViewCell)
Protected Method | SetValue | Sets the value of the cell. (Inherited from DataGridViewCell)
Protected Method | UpdateParams | Overloaded. Updates only the parameters of this instance. (Inherited from DataGridViewElement)
Top

See Also

Reference

DataGridViewCheckBoxCell Class
Gizmox.WebGUI.Forms Namespace


DataGridViewCheckBoxCell Constructor

[image]
Gizmox.WebGUI.Forms
DataGridViewCheckBoxCell Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCheckBoxCell Class : DataGridViewCheckBoxCell Constructor

Initializes a new instance of the DataGridViewCheckBoxCell class to its default state.

Overload List

Overload | Description
DataGridViewCheckBoxCell Constructor() | Initializes a new instance of the DataGridViewCheckBoxCell class to its default state.
DataGridViewCheckBoxCell Constructor(Boolean) | Initializes a new instance of the DataGridViewCheckBoxCell class, enabling binary or ternary state.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCheckBoxCell Class
DataGridViewCheckBoxCell Members


DataGridViewCheckBoxCell Constructor()

[image]
Gizmox.WebGUI.Forms
DataGridViewCheckBoxCell Constructor()
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCheckBoxCell Class > DataGridViewCheckBoxCell Constructor : DataGridViewCheckBoxCell Constructor()

Initializes a new instance of the DataGridViewCheckBoxCell class to its default state.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCheckBoxCell()
C#
public DataGridViewCheckBoxCell()
Managed Extensions for C++
public: DataGridViewCheckBoxCell();
C++/CLI
public:
DataGridViewCheckBoxCell();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCheckBoxCell Class
DataGridViewCheckBoxCell Members
Overload List


DataGridViewCheckBoxCell Constructor(Boolean)

[image]
Gizmox.WebGUI.Forms
DataGridViewCheckBoxCell Constructor(Boolean)
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCheckBoxCell Class > DataGridViewCheckBoxCell Constructor : DataGridViewCheckBoxCell Constructor(Boolean)

threeState
true to enable ternary state; false to enable binary state.
Initializes a new instance of the DataGridViewCheckBoxCell class, enabling binary or ternary state.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal threeState As Boolean _
)
Visual Basic (Usage) Copy Code
Dim threeState As Boolean

Dim instance As DataGridViewCheckBoxCell(threeState)
C#
public DataGridViewCheckBoxCell(
   bool threeState
)
Managed Extensions for C++
public: DataGridViewCheckBoxCell(
   bool threeState
)
C++/CLI
public:
DataGridViewCheckBoxCell(
   bool threeState
)

Parameters

threeState
true to enable ternary state; false to enable binary state.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCheckBoxCell Class
DataGridViewCheckBoxCell Members
Overload List


DataGridViewCheckBoxCell Class Methods

[image]
Gizmox.WebGUI.Forms
DataGridViewCheckBoxCell Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewCheckBoxCell Class

For a list of all members of this type, see DataGridViewCheckBoxCell members.

Public Methods

 | Name | Description
Public Method | AdjustCellBorderStyle | Modifies the input cell border style according to the specified criteria. (Inherited from DataGridViewCell)
Public Method | Clone | Overridden. Creates an exact copy of this cell.
Public Method | DetachEditingControl | Removes the cell's editing control from the DataGridView. (Inherited from DataGridViewCell)
Public Method | Dispose | Overloaded. Releases all resources used by the DataGridViewCell. (Inherited from DataGridViewCell)
Public Method | GetContentBounds | Overloaded. (Inherited from DataGridViewCell)
Public Method | GetEditedFormattedValue | Returns the current, formatted value of the cell, regardless of whether the cell is in edit mode and the value has not been committed. (Inherited from DataGridViewCell)
Public Method | GetEditingCellFormattedValue | Gets the formatted value of the cell while it is in edit mode.
Public Method | GetInheritedState | Returns a value indicating the current state of the cell as inherited from the state of its row and column. (Inherited from DataGridViewCell)
Public Method | GetInheritedStyle | Gets the style applied to the cell. (Inherited from DataGridViewCell)
Public Method | InitializeEditingControl | Initializes the control used to edit the cell. (Inherited from DataGridViewCell)
Public Method | KeyEntersEditMode | Determines if edit mode should be started based on the given key. (Inherited from DataGridViewCell)
Public Method | ParseFormattedValue | Overridden. Converts a value formatted for display to an actual cell value.
Public Method | PositionEditingControl | Sets the location and size of the editing control hosted by a cell in the DataGridView control. (Inherited from DataGridViewCell)
Public Method | PositionEditingPanel | (Inherited from DataGridViewCell)
Public Method | PrepareEditingCellForEdit | This method is not meaningful for this type.
Public Method | ToString | Overridden. Returns the string representation of the cell.
Public Method | Update | Overloaded. Full updates of this instance. (Inherited from DataGridViewElement)
Top

Protected Methods

 | Name | Description
Protected Method | BorderWidths | (Inherited from DataGridViewCell)
Protected Method | ClickUnsharesRow | Indicates whether the cell's row will be unshared when the cell is clicked. (Inherited from DataGridViewCell)
Protected Method | ContentClickUnsharesRow | Overridden. Indicates whether the row containing the cell will be unshared when the cell content is clicked.
Protected Method | ContentDoubleClickUnsharesRow | Overridden. Indicates whether the row containing the cell will be unshared when the cell content is double-clicked.
Protected Method | DoubleClickUnsharesRow | Indicates whether the cell's row will be unshared when the cell is double-clicked. (Inherited from DataGridViewCell)
Protected Method | EnterUnsharesRow | Indicates whether the parent row will be unshared when the focus moves to the cell. (Inherited from DataGridViewCell)
Protected Method | GetClipboardContent | Retrieves the formatted value of the cell to copy to the Clipboard. (Inherited from DataGridViewCell)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from DataGridViewElement)
Protected Method | GetDefaultHorizontalAlignment | Gets the horizontal alignment. (Inherited from DataGridViewCell)
Protected Method | GetDefaultVerticalAlignment | Gets the vertical alignment. (Inherited from DataGridViewCell)
Protected Method | GetErrorIconBounds | (Inherited from DataGridViewCell)
Protected Method | GetErrorText | Returns a string that represents the error for the cell. (Inherited from DataGridViewCell)
Protected Method | GetFormattedValue | Overridden. Gets the formatted value of the cell's data.
Protected Method | GetPreferredSize | Overloaded. Overridden. Calculates the preferred size, in pixels, of the cell.
Protected Method | GetSize | Gets the size of the cell. (Inherited from DataGridViewCell)
Protected Method | GetValue | Gets the value of the cell. (Inherited from DataGridViewCell)
Protected Method | IsDirty | Determines whether the specified component is dirty. (Inherited from DataGridViewElement)
Protected Method | IsDirtyAttributes | Overloaded. Determines whether the specified component is dirty. (Inherited from DataGridViewElement)
Protected Method | KeyDownUnsharesRow | Indicates whether the parent row is unshared if the user presses a key while the focus is on the cell. (Inherited from DataGridViewCell)
Protected Method | KeyPressUnsharesRow | Indicates whether a row will be unshared if a key is pressed while a cell in the row has focus. (Inherited from DataGridViewCell)
Protected Method | KeyUpUnsharesRow | Indicates whether the parent row is unshared when the user releases a key while the focus is on the cell. (Inherited from DataGridViewCell)
Protected Method | LeaveUnsharesRow | Indicates whether a row will be unshared when the focus leaves a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseClickUnsharesRow | Indicates whether a row will be unshared if the user clicks a mouse button while the pointer is on a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseDoubleClickUnsharesRow | Indicates whether a row will be unshared if the user double-clicks a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseDownUnsharesRow | Indicates whether a row will be unshared when the user holds down a mouse button while the pointer is on a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseEnterUnsharesRow | Indicates whether a row will be unshared when the mouse pointer moves over a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseLeaveUnsharesRow | Indicates whether a row will be unshared when the mouse pointer leaves the row. (Inherited from DataGridViewCell)
Protected Method | MouseMoveUnsharesRow | Indicates whether a row will be unshared when the mouse pointer moves over a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseUpUnsharesRow | Indicates whether a row will be unshared when the user releases a mouse button while the pointer is on a cell in the row. (Inherited from DataGridViewCell)
Protected Method | OnClick | Called when the cell is clicked. (Inherited from DataGridViewCell)
Protected Method | OnContentClick | Overridden.
Protected Method | OnContentDoubleClick | Overridden.
Protected Method | OnDataGridViewChanged | Called when the DataGridViewElement.DataGridView property of the cell changes. (Inherited from DataGridViewCell)
Protected Method | OnDoubleClick | Called when the cell is double-clicked. (Inherited from DataGridViewCell)
Protected Method | OnEnter | Called when the focus moves to a cell. (Inherited from DataGridViewCell)
Protected Method | OnKeyDown | Called when a character key is pressed while the focus is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnKeyPress | Called when a key is pressed while the focus is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnKeyUp | Called when a character key is released while the focus is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnLeave | Called when the focus moves from a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseClick | Called when the user clicks a mouse button while the pointer is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseDoubleClick | Called when the user double-clicks a mouse button while the pointer is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseDown | Called when the user holds down a mouse button while the pointer is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseEnter | Called when the mouse pointer moves over a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseLeave | Called when the mouse pointer leaves the cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseMove | Called when the mouse pointer moves within a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseUp | Called when the user releases a mouse button while the pointer is on a cell. (Inherited from DataGridViewCell)
Protected Method | Paint | (Inherited from DataGridViewCell)
Protected Method | PaintErrorIcon | (Inherited from DataGridViewCell)
Protected Method | ProcessGatewayRequest | (Inherited from DataGridViewCell)
Protected Method | RaiseCellClick | Raises the DataGridView.CellClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellContentClick | Raises the DataGridView.CellContentClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellContentDoubleClick | Raises the DataGridView.CellContentDoubleClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellValueChanged | Raises the CellValueChanged event. (Inherited from DataGridViewElement)
Protected Method | RaiseDataError | Raises the DataError event. (Inherited from DataGridViewElement)
Protected Method | RaiseMouseWheel | Raises the MouseWheel event. (Inherited from DataGridViewElement)
Protected Method | RenderAttributes | Overridden.
Protected Method | RenderBackColorAttribute | Renders the back color attribute. (Inherited from DataGridViewCell)
Protected Method | RenderComponent | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from DataGridViewElement)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from DataGridViewElement)
Protected Method | RenderComponents | Renders the controls sub tree (Inherited from DataGridViewElement)
Protected Method | RenderForeColorAttribute | Renders the fore color attribute. (Inherited from DataGridViewCell)
Protected Method | RenderReadOnlyAttribute | Renders the read only attribute. (Inherited from DataGridViewCell)
Protected Method | RenderUpdatedAttributes | Overridden.
Protected Method | RenderWrapModeAttribute | Renders the wrap mode attribute. (Inherited from DataGridViewCell)
Protected Method | SetValue | Sets the value of the cell. (Inherited from DataGridViewCell)
Protected Method | UpdateParams | Overloaded. Updates only the parameters of this instance. (Inherited from DataGridViewElement)
Top

See Also

Reference

DataGridViewCheckBoxCell Class
Gizmox.WebGUI.Forms Namespace


Clone Method

[image]
Gizmox.WebGUI.Forms
Clone Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCheckBoxCell Class : Clone Method

Creates an exact copy of this cell.

Syntax

Visual Basic (Declaration)
Public Overrides Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCheckBoxCell
Dim value As Object

value = instance.Clone()
C#
public override object Clone()
Managed Extensions for C++
public: Object* Clone(); override
C++/CLI
public:
Object^ Clone(); override

Return Value

An Object that represents the cloned DataGridViewCheckBoxCell.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCheckBoxCell Class
DataGridViewCheckBoxCell Members


ContentClickUnsharesRow Method

[image]
Gizmox.WebGUI.Forms
ContentClickUnsharesRow Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCheckBoxCell Class : ContentClickUnsharesRow Method

e
A DataGridViewCellEventArgs that contains data about the mouse click.
Indicates whether the row containing the cell will be unshared when the cell content is clicked.

Syntax

Visual Basic (Declaration)
Protected Overrides Function ContentClickUnsharesRow( _
   ByVal e As DataGridViewCellEventArgs _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCheckBoxCell
Dim e As DataGridViewCellEventArgs
Dim value As Boolean

value = instance.ContentClickUnsharesRow(e)
C#
protected override bool ContentClickUnsharesRow(
   DataGridViewCellEventArgs e
)
Managed Extensions for C++
protected: bool ContentClickUnsharesRow(
   DataGridViewCellEventArgs* e
) override
C++/CLI
protected:
bool ContentClickUnsharesRow(
   DataGridViewCellEventArgs^ e
) override

Parameters

e
A DataGridViewCellEventArgs that contains data about the mouse click.

Return Value

true if the cell is in edit mode; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCheckBoxCell Class
DataGridViewCheckBoxCell Members


ContentDoubleClickUnsharesRow Method

[image]
Gizmox.WebGUI.Forms
ContentDoubleClickUnsharesRow Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCheckBoxCell Class : ContentDoubleClickUnsharesRow Method

e
A DataGridViewCellEventArgs that contains data about the double-click.
Indicates whether the row containing the cell will be unshared when the cell content is double-clicked.

Syntax

Visual Basic (Declaration)
Protected Overrides Function ContentDoubleClickUnsharesRow( _
   ByVal e As DataGridViewCellEventArgs _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCheckBoxCell
Dim e As DataGridViewCellEventArgs
Dim value As Boolean

value = instance.ContentDoubleClickUnsharesRow(e)
C#
protected override bool ContentDoubleClickUnsharesRow(
   DataGridViewCellEventArgs e
)
Managed Extensions for C++
protected: bool ContentDoubleClickUnsharesRow(
   DataGridViewCellEventArgs* e
) override
C++/CLI
protected:
bool ContentDoubleClickUnsharesRow(
   DataGridViewCellEventArgs^ e
) override

Parameters

e
A DataGridViewCellEventArgs that contains data about the double-click.

Return Value

true if the cell is in edit mode; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCheckBoxCell Class
DataGridViewCheckBoxCell Members


GetEditingCellFormattedValue Method

[image]
Gizmox.WebGUI.Forms
GetEditingCellFormattedValue Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCheckBoxCell Class : GetEditingCellFormattedValue Method

context
A bitwise combination of DataGridViewDataErrorContexts values that describes the context in which any formatting error occurs.
Gets the formatted value of the cell while it is in edit mode.

Syntax

Visual Basic (Declaration)
Public Overridable Function GetEditingCellFormattedValue( _
   ByVal context As DataGridViewDataErrorContexts _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCheckBoxCell
Dim context As DataGridViewDataErrorContexts
Dim value As Object

value = instance.GetEditingCellFormattedValue(context)
C#
public virtual object GetEditingCellFormattedValue(
   DataGridViewDataErrorContexts context
)
Managed Extensions for C++
public: virtual Object* GetEditingCellFormattedValue(
   DataGridViewDataErrorContexts context
)
C++/CLI
public:
virtual Object^ GetEditingCellFormattedValue(
   DataGridViewDataErrorContexts context
)

Parameters

context
A bitwise combination of DataGridViewDataErrorContexts values that describes the context in which any formatting error occurs.

Return Value

An Object representing the formatted value of the editing cell.

Exceptions

Exception | Description
InvalidOperationException | The FormattedValueType property value is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCheckBoxCell Class
DataGridViewCheckBoxCell Members


GetFormattedValue Method

[image]
Gizmox.WebGUI.Forms
GetFormattedValue Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCheckBoxCell Class : GetFormattedValue Method

value
The value to be formatted.
rowIndex
The index of the cell's parent row.
cellStyle
The DataGridViewCellStyle in effect for the cell.
valueTypeConverter
A TypeConverter associated with the value type that provides custom conversion to the formatted value type, or null if no such custom conversion is needed.
formattedValueTypeConverter
A TypeConverter associated with the formatted value type that provides custom conversion from the value type, or null if no such custom conversion is needed.
context
A bitwise combination of DataGridViewDataErrorContexts values describing the context in which the formatted value is needed.
Gets the formatted value of the cell's data.

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetFormattedValue( _
   ByVal value As Object, _
   ByVal rowIndex As Integer, _
   ByRef cellStyle As DataGridViewCellStyle, _
   ByVal valueTypeConverter As TypeConverter, _
   ByVal formattedValueTypeConverter As TypeConverter, _
   ByVal context As DataGridViewDataErrorContexts _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCheckBoxCell
Dim value As Object
Dim rowIndex As Integer
Dim cellStyle As DataGridViewCellStyle
Dim valueTypeConverter As TypeConverter
Dim formattedValueTypeConverter As TypeConverter
Dim context As DataGridViewDataErrorContexts
Dim value As Object

value = instance.GetFormattedValue(value, rowIndex, cellStyle, valueTypeConverter, formattedValueTypeConverter, context)
C#
protected override object GetFormattedValue(
   object value,
   int rowIndex,
   ref DataGridViewCellStyle cellStyle,
   TypeConverter valueTypeConverter,
   TypeConverter formattedValueTypeConverter,
   DataGridViewDataErrorContexts context
)
Managed Extensions for C++
protected: Object* GetFormattedValue(
   Object* value,
   int rowIndex,
   ref DataGridViewCellStyle* cellStyle,
   TypeConverter* valueTypeConverter,
   TypeConverter* formattedValueTypeConverter,
   DataGridViewDataErrorContexts context
) override
C++/CLI
protected:
Object^ GetFormattedValue(
   Object^ value,
   int rowIndex,
   DataGridViewCellStyle^% cellStyle,
   TypeConverter^ valueTypeConverter,
   TypeConverter^ formattedValueTypeConverter,
   DataGridViewDataErrorContexts context
) override

Parameters

value
The value to be formatted.
rowIndex
The index of the cell's parent row.
cellStyle
The DataGridViewCellStyle in effect for the cell.
valueTypeConverter
A TypeConverter associated with the value type that provides custom conversion to the formatted value type, or null if no such custom conversion is needed.
formattedValueTypeConverter
A TypeConverter associated with the formatted value type that provides custom conversion from the value type, or null if no such custom conversion is needed.
context
A bitwise combination of DataGridViewDataErrorContexts values describing the context in which the formatted value is needed.

Return Value

The value of the cell's data after formatting has been applied or null if the cell is not part of a DataGridView control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCheckBoxCell Class
DataGridViewCheckBoxCell Members


GetPreferredSize Method

[image]
Gizmox.WebGUI.Forms
GetPreferredSize Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCheckBoxCell Class : GetPreferredSize Method

Calculates the preferred size, in pixels, of the cell.

Overload List

Overload | Description
GetPreferredSize(Graphics,DataGridViewCellStyle,Int32,Size) | Calculates the preferred size, in pixels, of the cell.
GetPreferredSize(String,DataGridViewCellStyle) | Calculates the preferred size, in pixels, of the cell. (Inherited from DataGridViewCell)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCheckBoxCell Class
DataGridViewCheckBoxCell Members


GetPreferredSize(Graphics,DataGridViewCellStyle,Int32,Size) Method

[image]
Gizmox.WebGUI.Forms
GetPreferredSize(Graphics,DataGridViewCellStyle,Int32,Size) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCheckBoxCell Class > GetPreferredSize Method : GetPreferredSize(Graphics,DataGridViewCellStyle,Int32,Size) Method

graphics
The Graphics used to draw the cell.
cellStyle
A DataGridViewCellStyle that represents the style of the cell.
rowIndex
The zero-based row index of the cell.
constraintSize
The cell's maximum allowable size.
Calculates the preferred size, in pixels, of the cell.

Syntax

Visual Basic (Declaration)
Protected Overloads Overrides Function GetPreferredSize( _
   ByVal graphics As Graphics, _
   ByVal cellStyle As DataGridViewCellStyle, _
   ByVal rowIndex As Integer, _
   ByVal constraintSize As Size _
) As Size
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCheckBoxCell
Dim graphics As Graphics
Dim cellStyle As DataGridViewCellStyle
Dim rowIndex As Integer
Dim constraintSize As Size
Dim value As Size

value = instance.GetPreferredSize(graphics, cellStyle, rowIndex, constraintSize)
C#
protected override Size GetPreferredSize(
   Graphics graphics,
   DataGridViewCellStyle cellStyle,
   int rowIndex,
   Size constraintSize
)
Managed Extensions for C++
protected: Size GetPreferredSize(
   Graphics* graphics,
   DataGridViewCellStyle* cellStyle,
   int rowIndex,
   Size constraintSize
) override
C++/CLI
protected:
Size GetPreferredSize(
   Graphics^ graphics,
   DataGridViewCellStyle^ cellStyle,
   int rowIndex,
   Size constraintSize
) override

Parameters

graphics
The Graphics used to draw the cell.
cellStyle
A DataGridViewCellStyle that represents the style of the cell.
rowIndex
The zero-based row index of the cell.
constraintSize
The cell's maximum allowable size.

Return Value

A Size that represents the preferred size, in pixels, of the cell.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCheckBoxCell Class
DataGridViewCheckBoxCell Members
Overload List


OnContentClick Method

[image]
Gizmox.WebGUI.Forms
OnContentClick Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCheckBoxCell Class : OnContentClick Method

e

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnContentClick( _
   ByVal e As DataGridViewCellEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCheckBoxCell
Dim e As DataGridViewCellEventArgs

instance.OnContentClick(e)
C#
protected override void OnContentClick(
   DataGridViewCellEventArgs e
)
Managed Extensions for C++
protected: void OnContentClick(
   DataGridViewCellEventArgs* e
) override
C++/CLI
protected:
void OnContentClick(
   DataGridViewCellEventArgs^ e
) override

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCheckBoxCell Class
DataGridViewCheckBoxCell Members


OnContentDoubleClick Method

[image]
Gizmox.WebGUI.Forms
OnContentDoubleClick Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCheckBoxCell Class : OnContentDoubleClick Method

e

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnContentDoubleClick( _
   ByVal e As DataGridViewCellEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCheckBoxCell
Dim e As DataGridViewCellEventArgs

instance.OnContentDoubleClick(e)
C#
protected override void OnContentDoubleClick(
   DataGridViewCellEventArgs e
)
Managed Extensions for C++
protected: void OnContentDoubleClick(
   DataGridViewCellEventArgs* e
) override
C++/CLI
protected:
void OnContentDoubleClick(
   DataGridViewCellEventArgs^ e
) override

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCheckBoxCell Class
DataGridViewCheckBoxCell Members


ParseFormattedValue Method

[image]
Gizmox.WebGUI.Forms
ParseFormattedValue Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCheckBoxCell Class : ParseFormattedValue Method

formattedValue
The display value of the cell.
cellStyle
The DataGridViewCellStyle in effect for the cell.
formattedValueTypeConverter
A TypeConverter for the display value type, or null to use the default converter.
valueTypeConverter
A TypeConverter for the cell value type, or null to use the default converter.
Converts a value formatted for display to an actual cell value.

Syntax

Visual Basic (Declaration)
Public Overrides Function ParseFormattedValue( _
   ByVal formattedValue As Object, _
   ByVal cellStyle As DataGridViewCellStyle, _
   ByVal formattedValueTypeConverter As TypeConverter, _
   ByVal valueTypeConverter As TypeConverter _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCheckBoxCell
Dim formattedValue As Object
Dim cellStyle As DataGridViewCellStyle
Dim formattedValueTypeConverter As TypeConverter
Dim valueTypeConverter As TypeConverter
Dim value As Object

value = instance.ParseFormattedValue(formattedValue, cellStyle, formattedValueTypeConverter, valueTypeConverter)
C#
public override object ParseFormattedValue(
   object formattedValue,
   DataGridViewCellStyle cellStyle,
   TypeConverter formattedValueTypeConverter,
   TypeConverter valueTypeConverter
)
Managed Extensions for C++
public: Object* ParseFormattedValue(
   Object* formattedValue,
   DataGridViewCellStyle* cellStyle,
   TypeConverter* formattedValueTypeConverter,
   TypeConverter* valueTypeConverter
) override
C++/CLI
public:
Object^ ParseFormattedValue(
   Object^ formattedValue,
   DataGridViewCellStyle^ cellStyle,
   TypeConverter^ formattedValueTypeConverter,
   TypeConverter^ valueTypeConverter
) override

Parameters

formattedValue
The display value of the cell.
cellStyle
The DataGridViewCellStyle in effect for the cell.
formattedValueTypeConverter
A TypeConverter for the display value type, or null to use the default converter.
valueTypeConverter
A TypeConverter for the cell value type, or null to use the default converter.

Return Value

The cell value.

Exceptions

Exception | Description
FormatException | The DataGridViewCell.FormattedValueType property value is null.
ArgumentNullException | cellStyle is null.
ArgumentException | formattedValue is null.- or -The type of formattedValue does not match the type indicated by the DataGridViewCell.FormattedValueType property.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCheckBoxCell Class
DataGridViewCheckBoxCell Members


PrepareEditingCellForEdit Method

[image]
Gizmox.WebGUI.Forms
PrepareEditingCellForEdit Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCheckBoxCell Class : PrepareEditingCellForEdit Method

selectAll
This parameter is ignored.
This method is not meaningful for this type.

Syntax

Visual Basic (Declaration)
Public Overridable Sub PrepareEditingCellForEdit( _
   ByVal selectAll As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCheckBoxCell
Dim selectAll As Boolean

instance.PrepareEditingCellForEdit(selectAll)
C#
public virtual void PrepareEditingCellForEdit(
   bool selectAll
)
Managed Extensions for C++
public: virtual void PrepareEditingCellForEdit(
   bool selectAll
)
C++/CLI
public:
virtual void PrepareEditingCellForEdit(
   bool selectAll
)

Parameters

selectAll
This parameter is ignored.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCheckBoxCell Class
DataGridViewCheckBoxCell Members


RenderAttributes Method

[image]
Gizmox.WebGUI.Forms
RenderAttributes Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCheckBoxCell Class : RenderAttributes Method

objContext
objWriter
blnRenderOwner

Syntax

Visual Basic (Declaration)
Protected Overrides Sub RenderAttributes( _
   ByVal objContext As IContext, _
   ByVal objWriter As IAttributeWriter, _
   ByVal blnRenderOwner As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCheckBoxCell
Dim objContext As IContext
Dim objWriter As IAttributeWriter
Dim blnRenderOwner As Boolean

instance.RenderAttributes(objContext, objWriter, blnRenderOwner)
C#
protected override void RenderAttributes(
   IContext objContext,
   IAttributeWriter objWriter,
   bool blnRenderOwner
)
Managed Extensions for C++
protected: void RenderAttributes(
   IContext* objContext,
   IAttributeWriter* objWriter,
   bool blnRenderOwner
) override
C++/CLI
protected:
void RenderAttributes(
   IContext^ objContext,
   IAttributeWriter^ objWriter,
   bool blnRenderOwner
) override

Parameters

objContext
objWriter
blnRenderOwner

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCheckBoxCell Class
DataGridViewCheckBoxCell Members


RenderUpdatedAttributes Method

[image]
Gizmox.WebGUI.Forms
RenderUpdatedAttributes Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCheckBoxCell Class : RenderUpdatedAttributes Method

objContext
objWriter
lngRequestID
blnRenderOwner

Syntax

Visual Basic (Declaration)
Protected Overrides Sub RenderUpdatedAttributes( _
   ByVal objContext As IContext, _
   ByVal objWriter As IAttributeWriter, _
   ByVal lngRequestID As Long, _
   ByVal blnRenderOwner As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCheckBoxCell
Dim objContext As IContext
Dim objWriter As IAttributeWriter
Dim lngRequestID As Long
Dim blnRenderOwner As Boolean

instance.RenderUpdatedAttributes(objContext, objWriter, lngRequestID, blnRenderOwner)
C#
protected override void RenderUpdatedAttributes(
   IContext objContext,
   IAttributeWriter objWriter,
   long lngRequestID,
   bool blnRenderOwner
)
Managed Extensions for C++
protected: void RenderUpdatedAttributes(
   IContext* objContext,
   IAttributeWriter* objWriter,
   long lngRequestID,
   bool blnRenderOwner
) override
C++/CLI
protected:
void RenderUpdatedAttributes(
   IContext^ objContext,
   IAttributeWriter^ objWriter,
   long long lngRequestID,
   bool blnRenderOwner
) override

Parameters

objContext
objWriter
lngRequestID
blnRenderOwner

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCheckBoxCell Class
DataGridViewCheckBoxCell Members


ToString Method

[image]
Gizmox.WebGUI.Forms
ToString Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCheckBoxCell Class : ToString Method

Returns the string representation of the cell.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCheckBoxCell
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Return Value

A String that represents the current cell.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCheckBoxCell Class
DataGridViewCheckBoxCell Members


DataGridViewCheckBoxCell Class Properties

[image]
Gizmox.WebGUI.Forms
DataGridViewCheckBoxCell Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewCheckBoxCell Class

For a list of all members of this type, see DataGridViewCheckBoxCell members.

Public Properties

 | Name | Description
Public Property | ColumnIndex | Gets the column index for this cell. (Inherited from DataGridViewCell)
Public Property | ContentBounds | (Inherited from DataGridViewCell)
Public Property | DataGridView | Gets the DataGridView control associated with this element. (Inherited from DataGridViewElement)
Public Property | DefaultNewRowValue | Gets the default value for a cell in the row for new records. (Inherited from DataGridViewCell)
Public Property | Displayed | Gets a value that indicates whether the cell is currently displayed on-screen. (Inherited from DataGridViewCell)
Public Property | EditedFormattedValue | Gets the current, formatted value of the cell, regardless of whether the cell is in edit mode and the value has not been committed. (Inherited from DataGridViewCell)
Public Property | EditingCellFormattedValue | Gets or sets the formatted value of the control hosted by the cell when it is in edit mode.
Public Property | EditingCellValueChanged | Gets or sets a flag indicating that the value has been changed for this cell.
Public Property | EditType | Overridden. Gets the type of the cell's hosted editing control.
Public Property | ErrorIconBounds | (Inherited from DataGridViewCell)
Public Property | ErrorText | Gets or sets the text describing an error condition associated with the cell. (Inherited from DataGridViewCell)
Public Property | FalseValue | Gets or sets the underlying value corresponding to a cell value of false.
Public Property | FlatStyle | Gets or sets the flat style appearance of the check box user interface (UI).
Public Property | FormattedValue | Gets the value of the cell as formatted for display. (Inherited from DataGridViewCell)
Public Property | FormattedValueType | Overridden. Gets the type of the cell display value.
Public Property | Frozen | Gets a value indicating whether the cell is frozen. (Inherited from DataGridViewCell)
Public Property | HasStyle | Gets a value indicating whether the DataGridViewCell.Style property has been set. (Inherited from DataGridViewCell)
Public Property | IndeterminateValue | Gets or sets the underlying value corresponding to an indeterminate or null cell value.
Public Property | InheritedState | Gets the current state of the cell as inherited from the state of its row and column. (Inherited from DataGridViewCell)
Public Property | InheritedStyle | Gets the style currently applied to the cell. (Inherited from DataGridViewCell)
Public Property | IsInEditMode | Gets a value indicating whether this cell is currently being edited. (Inherited from DataGridViewCell)
Public Property | OwningColumn | Gets the column that contains this cell. (Inherited from DataGridViewCell)
Public Property | OwningRow | Gets the row that contains this cell. (Inherited from DataGridViewCell)
Public Property | PreferredSize | Gets the size, in pixels, of a rectangular area into which the cell can fit. (Inherited from DataGridViewCell)
Public Property | ReadOnly | Gets or sets a value indicating whether the cell's data can be edited. (Inherited from DataGridViewCell)
Public Property | Resizable | Gets a value indicating whether the cell can be resized. (Inherited from DataGridViewCell)
Public Property | RowIndex | Gets the index of the cell's parent row. (Inherited from DataGridViewCell)
Public Property | Selected | Gets or sets a value indicating whether the cell has been selected. (Inherited from DataGridViewCell)
Public Property | Size | Gets the size of the cell. (Inherited from DataGridViewCell)
Public Property | State | Gets the user interface (UI) state of the element. (Inherited from DataGridViewElement)
Public Property | Style | Gets or sets the style for the cell. (Inherited from DataGridViewCell)
Public Property | Tag | Gets or sets the object that contains supplemental data about the cell. (Inherited from DataGridViewCell)
Public Property | ThreeState | Gets or sets a value indicating whether ternary mode has been enabled for the hosted check box control.
Public Property | ToolTipText | Gets or sets the ToolTip text associated with this cell. (Inherited from DataGridViewCell)
Public Property | TrueValue | Gets or sets the underlying value corresponding to a cell value of true.
Public Property | Value | Gets or sets the value associated with this cell. (Inherited from DataGridViewCell)
Public Property | ValueType | Overridden. Gets the data type of the values in the cell.
Public Property | Visible | Gets a value indicating whether the cell is in a row or column that has been hidden. (Inherited from DataGridViewCell)
Top

Protected Properties

 | Name | Description
Protected Property | MemberID | (Inherited from DataGridViewCell)
Protected Property | TagName | (Inherited from DataGridViewElement)
Top

See Also

Reference

DataGridViewCheckBoxCell Class
Gizmox.WebGUI.Forms Namespace


EditingCellFormattedValue Property

[image]
Gizmox.WebGUI.Forms
EditingCellFormattedValue Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCheckBoxCell Class : EditingCellFormattedValue Property

Gets or sets the formatted value of the control hosted by the cell when it is in edit mode.

Syntax

Visual Basic (Declaration)
Public Overridable Property EditingCellFormattedValue As Object
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCheckBoxCell
Dim value As Object

instance.EditingCellFormattedValue = value

value = instance.EditingCellFormattedValue
C#
public virtual object EditingCellFormattedValue {get; set;}
Managed Extensions for C++
public: __property virtual Object* get_EditingCellFormattedValue();
public: __property virtual void set_EditingCellFormattedValue(
   Object* value
);
C++/CLI
public:
virtual property Object^ EditingCellFormattedValue {
   Object^ get();
   void set (Object^value);
}

Exceptions

Exception | Description
InvalidOperationException | The FormattedValueType property value is null.
ArgumentException | The FormattedValueType property value is null.-or-The assigned value is null or is not of the type indicated by the FormattedValueType property.-or- The assigned value is not of type Boolean nor of type CheckState.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCheckBoxCell Class
DataGridViewCheckBoxCell Members


EditingCellValueChanged Property

[image]
Gizmox.WebGUI.Forms
EditingCellValueChanged Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCheckBoxCell Class : EditingCellValueChanged Property

Gets or sets a flag indicating that the value has been changed for this cell.

Syntax

Visual Basic (Declaration)
Public Overridable Property EditingCellValueChanged As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCheckBoxCell
Dim value As Boolean

instance.EditingCellValueChanged = value

value = instance.EditingCellValueChanged
C#
public virtual bool EditingCellValueChanged {get; set;}
Managed Extensions for C++
public: __property virtual bool get_EditingCellValueChanged();
public: __property virtual void set_EditingCellValueChanged(
   bool value
);
C++/CLI
public:
virtual property bool EditingCellValueChanged {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCheckBoxCell Class
DataGridViewCheckBoxCell Members


EditType Property

[image]
Gizmox.WebGUI.Forms
EditType Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCheckBoxCell Class : EditType Property

Gets the type of the cell's hosted editing control.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property EditType As Type
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCheckBoxCell
Dim value As Type

value = instance.EditType
C#
public override Type EditType {get;}
Managed Extensions for C++
public: __property Type* get_EditType() override;
C++/CLI
public:
property Type^ EditType {
   Type^ get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCheckBoxCell Class
DataGridViewCheckBoxCell Members


FalseValue Property

[image]
Gizmox.WebGUI.Forms
FalseValue Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCheckBoxCell Class : FalseValue Property

Gets or sets the underlying value corresponding to a cell value of false.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property FalseValue As Object
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCheckBoxCell
Dim value As Object

instance.FalseValue = value

value = instance.FalseValue
C#
[DefaultValueAttribute()]
public object FalseValue {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property Object* get_FalseValue();
public: __property void set_FalseValue(
   Object* value
);
C++/CLI
[DefaultValueAttribute()]
public:
property Object^ FalseValue {
   Object^ get();
   void set (Object^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCheckBoxCell Class
DataGridViewCheckBoxCell Members


FlatStyle Property

[image]
Gizmox.WebGUI.Forms
FlatStyle Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCheckBoxCell Class : FlatStyle Property

Gets or sets the flat style appearance of the check box user interface (UI).

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property FlatStyle As FlatStyle
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCheckBoxCell
Dim value As FlatStyle

instance.FlatStyle = value

value = instance.FlatStyle
C#
[DefaultValueAttribute()]
public FlatStyle FlatStyle {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property FlatStyle get_FlatStyle();
public: __property void set_FlatStyle(
   FlatStyle value
);
C++/CLI
[DefaultValueAttribute()]
public:
property FlatStyle FlatStyle {
   FlatStyle get();
   void set (FlatStylevalue);
}

Exceptions

Exception | Description
InvalidEnumArgumentException | The specified value when setting this property is not a valid FlatStyle value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCheckBoxCell Class
DataGridViewCheckBoxCell Members


FormattedValueType Property

[image]
Gizmox.WebGUI.Forms
FormattedValueType Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCheckBoxCell Class : FormattedValueType Property

Gets the type of the cell display value.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property FormattedValueType As Type
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCheckBoxCell
Dim value As Type

value = instance.FormattedValueType
C#
public override Type FormattedValueType {get;}
Managed Extensions for C++
public: __property Type* get_FormattedValueType() override;
C++/CLI
public:
property Type^ FormattedValueType {
   Type^ get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCheckBoxCell Class
DataGridViewCheckBoxCell Members


IndeterminateValue Property

[image]
Gizmox.WebGUI.Forms
IndeterminateValue Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCheckBoxCell Class : IndeterminateValue Property

Gets or sets the underlying value corresponding to an indeterminate or null cell value.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property IndeterminateValue As Object
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCheckBoxCell
Dim value As Object

instance.IndeterminateValue = value

value = instance.IndeterminateValue
C#
[DefaultValueAttribute()]
public object IndeterminateValue {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property Object* get_IndeterminateValue();
public: __property void set_IndeterminateValue(
   Object* value
);
C++/CLI
[DefaultValueAttribute()]
public:
property Object^ IndeterminateValue {
   Object^ get();
   void set (Object^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCheckBoxCell Class
DataGridViewCheckBoxCell Members


ThreeState Property

[image]
Gizmox.WebGUI.Forms
ThreeState Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCheckBoxCell Class : ThreeState Property

Gets or sets a value indicating whether ternary mode has been enabled for the hosted check box control.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property ThreeState As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCheckBoxCell
Dim value As Boolean

instance.ThreeState = value

value = instance.ThreeState
C#
[DefaultValueAttribute()]
public bool ThreeState {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property bool get_ThreeState();
public: __property void set_ThreeState(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
public:
property bool ThreeState {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCheckBoxCell Class
DataGridViewCheckBoxCell Members


TrueValue Property

[image]
Gizmox.WebGUI.Forms
TrueValue Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCheckBoxCell Class : TrueValue Property

Gets or sets the underlying value corresponding to a cell value of true.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property TrueValue As Object
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCheckBoxCell
Dim value As Object

instance.TrueValue = value

value = instance.TrueValue
C#
[DefaultValueAttribute()]
public object TrueValue {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property Object* get_TrueValue();
public: __property void set_TrueValue(
   Object* value
);
C++/CLI
[DefaultValueAttribute()]
public:
property Object^ TrueValue {
   Object^ get();
   void set (Object^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCheckBoxCell Class
DataGridViewCheckBoxCell Members


ValueType Property

[image]
Gizmox.WebGUI.Forms
ValueType Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCheckBoxCell Class : ValueType Property

Gets the data type of the values in the cell.

Syntax

Visual Basic (Declaration)
Public Overrides Property ValueType As Type
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCheckBoxCell
Dim value As Type

instance.ValueType = value

value = instance.ValueType
C#
public override Type ValueType {get; set;}
Managed Extensions for C++
public: __property Type* get_ValueType() override;
public: __property void set_ValueType(
   Type* value
) override;
C++/CLI
public:
property Type^ ValueType {
   Type^ get() override;
   void set (Type^value) override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCheckBoxCell Class
DataGridViewCheckBoxCell Members


DataGridViewCheckBoxColumn Class

[image]
Gizmox.WebGUI.Forms
DataGridViewCheckBoxColumn Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewCheckBoxColumn Class

Hosts a collection of DataGridViewCheckBoxCell objects.

Object Model

Syntax

Visual Basic (Declaration)
<ToolboxBitmapAttribute()>
<DesignTimeControllerAttribute()>
<ClientControllerAttribute()>
Public Class DataGridViewCheckBoxColumn
   Inherits DataGridViewColumn
   Implements IRenderableComponentMember
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCheckBoxColumn
C#
[ToolboxBitmapAttribute()]
[DesignTimeControllerAttribute()]
[ClientControllerAttribute()]
public class DataGridViewCheckBoxColumn : DataGridViewColumn, IRenderableComponentMember
Managed Extensions for C++
[ToolboxBitmapAttribute()]
[DesignTimeControllerAttribute()]
[ClientControllerAttribute()]
public __gc class DataGridViewCheckBoxColumn : public DataGridViewColumn, IRenderableComponentMember
C++/CLI
[ToolboxBitmapAttribute()]
[DesignTimeControllerAttribute()]
[ClientControllerAttribute()]
public ref class DataGridViewCheckBoxColumn : public DataGridViewColumn, IRenderableComponentMember

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.DataGridViewElement
Gizmox.WebGUI.Forms.DataGridViewBand
Gizmox.WebGUI.Forms.DataGridViewColumn
Gizmox.WebGUI.Forms.DataGridViewCheckBoxColumn

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

DataGridViewCheckBoxColumn Members
Gizmox.WebGUI.Forms Namespace


DataGridViewCheckBoxColumn Class Members

[image]
Gizmox.WebGUI.Forms
DataGridViewCheckBoxColumn Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewCheckBoxColumn Class

The following tables list the members exposed by DataGridViewCheckBoxColumn.

Public Constructors

 | Name | Description
Public Constructor | DataGridViewCheckBoxColumn Constructor | Overloaded. Initializes a new instance of the DataGridViewCheckBoxColumn class to the default state.
Top

Public Properties

 | Name | Description
Public Property | AutoSizeMode | Gets or sets the mode by which the column automatically adjusts its width. (Inherited from DataGridViewColumn)
Public Property | CellTemplate | Overridden. Gets or sets the template used to create new cells.
Public Property | CellType | Gets the run-time type of the cell template. (Inherited from DataGridViewColumn)
Public Property | DataGridView | Gets the DataGridView control associated with this element. (Inherited from DataGridViewElement)
Public Property | DataPropertyName | Gets or sets the name of the data source property or database column to which the DataGridViewColumn is bound. (Inherited from DataGridViewColumn)
Public Property | DefaultCellStyle | Overridden. Gets or sets the column's default cell style.
Public Property | DefaultHeaderCellType | Gets or sets the run-time type of the default header cell. (Inherited from DataGridViewBand)
Public Property | Displayed | Gets a value indicating whether the band is currently displayed onscreen. (Inherited from DataGridViewBand)
Public Property | DisplayIndex | Gets or sets the display order of the column relative to the currently displayed columns. (Inherited from DataGridViewColumn)
Public Property | DividerWidth | Gets or sets the width, in pixels, of the column divider. (Inherited from DataGridViewColumn)
Public Property | FalseValue | Gets or sets the underlying value corresponding to a cell value of false, which appears as an unchecked box.
Public Property | FillWeight | Gets or sets a value that represents the width of the column when it is in fill mode relative to the widths of other fill-mode columns in the control. (Inherited from DataGridViewColumn)
Public Property | FlatStyle | Gets or sets the flat style appearance of the check box cells.
Public Property | Frozen | Gets or sets a value indicating whether a column will move when a user scrolls the DataGridView control horizontally. (Inherited from DataGridViewColumn)
Public Property | HasDefaultCellStyle | Gets a value indicating whether the DataGridViewBand.DefaultCellStyle property has been set. (Inherited from DataGridViewBand)
Public Property | HeaderCell | Gets or sets the DataGridViewColumnHeaderCell that represents the column header. (Inherited from DataGridViewColumn)
Public Property | HeaderText | Gets or sets the caption text on the column's header cell. (Inherited from DataGridViewColumn)
Public Property | IndeterminateValue | Gets or sets the underlying value corresponding to an indeterminate or null cell value, which appears as a disabled checkbox.
Public Property | Index | Gets the relative position of the band within the DataGridView control. (Inherited from DataGridViewBand)
Public Property | InheritedAutoSizeMode | Gets the sizing mode in effect for the column. (Inherited from DataGridViewColumn)
Public Property | InheritedStyle | Gets the cell style currently applied to the column. (Inherited from DataGridViewColumn)
Public Property | IsDataBound | Gets a value indicating whether the column is bound to a data source. (Inherited from DataGridViewColumn)
Public Property | MinimumWidth | Gets or sets the minimum width, in pixels, of the column. (Inherited from DataGridViewColumn)
Public Property | Name | Gets or sets the name of the column. (Inherited from DataGridViewColumn)
Public Property | ReadOnly | Gets or sets a value indicating whether the user can edit the column's cells. (Inherited from DataGridViewColumn)
Public Property | Resizable | Gets or sets a value indicating whether the column is resizable. (Inherited from DataGridViewColumn)
Public Property | Selected | Gets or sets a value indicating whether the band is in a selected user interface (UI) state. (Inherited from DataGridViewBand)
Public Property | Site | Gets or sets the site of the column. (Inherited from DataGridViewColumn)
Public Property | SortMode | Gets or sets the sort mode for the column. (Inherited from DataGridViewColumn)
Public Property | State | Gets the user interface (UI) state of the element. (Inherited from DataGridViewElement)
Public Property | Tag | Gets or sets the object that contains data to associate with the band. (Inherited from DataGridViewBand)
Public Property | ThreeState | Gets or sets a value indicating whether the hosted check box cells will allow three check states rather than two.
Public Property | ToolTipText | Gets or sets the text used for ToolTips. (Inherited from DataGridViewColumn)
Public Property | TrueValue | Gets or sets the underlying value corresponding to a cell value of true, which appears as a checked box.
Public Property | ValueType | Gets or sets the data type of the values in the column's cells. (Inherited from DataGridViewColumn)
Public Property | Visible | Gets or sets a value indicating whether the column is visible. (Inherited from DataGridViewColumn)
Public Property | Width | Gets or sets the current width of the column. (Inherited from DataGridViewColumn)
Top

Protected Properties

 | Name | Description
Protected Property | HeaderCellCore | Gets or sets the header cell of the DataGridViewBand. (Inherited from DataGridViewBand)
Protected Property | IsRow | Gets a value indicating whether the band represents a row. (Inherited from DataGridViewBand)
Protected Property | MemberID | (Inherited from DataGridViewColumn)
Protected Property | TagName | (Inherited from DataGridViewElement)
Protected Property | TypeName | Overridden.
Top

Public Methods

 | Name | Description
Public Method | Clone | Creates an exact copy of this band. (Inherited from DataGridViewBand)
Public Method | Dispose | Overloaded. Releases all resources used by the DataGridViewBand. (Inherited from DataGridViewBand)
Public Method | GetPreferredWidth | Calculates the ideal width of the column based on the specified criteria. (Inherited from DataGridViewColumn)
Public Method | ToString | Overridden.
Public Method | Update | Overloaded. Full updates of this instance. (Inherited from DataGridViewElement)
Top

Protected Methods

 | Name | Description
Protected Method | CloneInternal | (Inherited from DataGridViewColumn)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from DataGridViewElement)
Protected Method | IsDirty | Determines whether the specified component is dirty. (Inherited from DataGridViewElement)
Protected Method | IsDirtyAttributes | Overloaded. Determines whether the specified component is dirty. (Inherited from DataGridViewElement)
Protected Method | OnDataGridViewChanged | Called when the band is associated with a different DataGridView. (Inherited from DataGridViewBand)
Protected Method | RaiseCellClick | Raises the DataGridView.CellClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellContentClick | Raises the DataGridView.CellContentClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellContentDoubleClick | Raises the DataGridView.CellContentDoubleClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellValueChanged | Raises the CellValueChanged event. (Inherited from DataGridViewElement)
Protected Method | RaiseDataError | Raises the DataError event. (Inherited from DataGridViewElement)
Protected Method | RaiseMouseWheel | Raises the MouseWheel event. (Inherited from DataGridViewElement)
Protected Method | RenderAttributes | (Inherited from DataGridViewColumn)
Protected Method | RenderComponent | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from DataGridViewElement)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from DataGridViewElement)
Protected Method | RenderComponents | Renders the column's inner components (Inherited from DataGridViewColumn)
Protected Method | RenderUpdatedAttributes | Renders the updated attributes (Inherited from DataGridViewElement)
Protected Method | UpdateParams | Overloaded. Updates only the parameters of this instance. (Inherited from DataGridViewElement)
Top

Public Events

 | Name | Description
Public Event | Disposed | Occurs when the DataGridViewColumn is disposed. (Inherited from DataGridViewColumn)
Top

See Also

Reference

DataGridViewCheckBoxColumn Class
Gizmox.WebGUI.Forms Namespace


DataGridViewCheckBoxColumn Constructor

[image]
Gizmox.WebGUI.Forms
DataGridViewCheckBoxColumn Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCheckBoxColumn Class : DataGridViewCheckBoxColumn Constructor

Initializes a new instance of the DataGridViewCheckBoxColumn class to the default state.

Overload List

Overload | Description
DataGridViewCheckBoxColumn Constructor() | Initializes a new instance of the DataGridViewCheckBoxColumn class to the default state.
DataGridViewCheckBoxColumn Constructor(Boolean) | Initializes a new instance of the DataGridViewCheckBoxColumn and configures it to display check boxes with two or three states.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCheckBoxColumn Class
DataGridViewCheckBoxColumn Members


DataGridViewCheckBoxColumn Constructor()

[image]
Gizmox.WebGUI.Forms
DataGridViewCheckBoxColumn Constructor()
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCheckBoxColumn Class > DataGridViewCheckBoxColumn Constructor : DataGridViewCheckBoxColumn Constructor()

Initializes a new instance of the DataGridViewCheckBoxColumn class to the default state.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCheckBoxColumn()
C#
public DataGridViewCheckBoxColumn()
Managed Extensions for C++
public: DataGridViewCheckBoxColumn();
C++/CLI
public:
DataGridViewCheckBoxColumn();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCheckBoxColumn Class
DataGridViewCheckBoxColumn Members
Overload List


DataGridViewCheckBoxColumn Constructor(Boolean)

[image]
Gizmox.WebGUI.Forms
DataGridViewCheckBoxColumn Constructor(Boolean)
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCheckBoxColumn Class > DataGridViewCheckBoxColumn Constructor : DataGridViewCheckBoxColumn Constructor(Boolean)

threeState
true to display check boxes with three states; false to display check boxes with two states.
Initializes a new instance of the DataGridViewCheckBoxColumn and configures it to display check boxes with two or three states.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal threeState As Boolean _
)
Visual Basic (Usage) Copy Code
Dim threeState As Boolean

Dim instance As DataGridViewCheckBoxColumn(threeState)
C#
public DataGridViewCheckBoxColumn(
   bool threeState
)
Managed Extensions for C++
public: DataGridViewCheckBoxColumn(
   bool threeState
)
C++/CLI
public:
DataGridViewCheckBoxColumn(
   bool threeState
)

Parameters

threeState
true to display check boxes with three states; false to display check boxes with two states.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCheckBoxColumn Class
DataGridViewCheckBoxColumn Members
Overload List


DataGridViewCheckBoxColumn Class Methods

[image]
Gizmox.WebGUI.Forms
DataGridViewCheckBoxColumn Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewCheckBoxColumn Class

For a list of all members of this type, see DataGridViewCheckBoxColumn members.

Public Methods

 | Name | Description
Public Method | Clone | Creates an exact copy of this band. (Inherited from DataGridViewBand)
Public Method | Dispose | Overloaded. Releases all resources used by the DataGridViewBand. (Inherited from DataGridViewBand)
Public Method | GetPreferredWidth | Calculates the ideal width of the column based on the specified criteria. (Inherited from DataGridViewColumn)
Public Method | ToString | Overridden.
Public Method | Update | Overloaded. Full updates of this instance. (Inherited from DataGridViewElement)
Top

Protected Methods

 | Name | Description
Protected Method | CloneInternal | (Inherited from DataGridViewColumn)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from DataGridViewElement)
Protected Method | IsDirty | Determines whether the specified component is dirty. (Inherited from DataGridViewElement)
Protected Method | IsDirtyAttributes | Overloaded. Determines whether the specified component is dirty. (Inherited from DataGridViewElement)
Protected Method | OnDataGridViewChanged | Called when the band is associated with a different DataGridView. (Inherited from DataGridViewBand)
Protected Method | RaiseCellClick | Raises the DataGridView.CellClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellContentClick | Raises the DataGridView.CellContentClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellContentDoubleClick | Raises the DataGridView.CellContentDoubleClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellValueChanged | Raises the CellValueChanged event. (Inherited from DataGridViewElement)
Protected Method | RaiseDataError | Raises the DataError event. (Inherited from DataGridViewElement)
Protected Method | RaiseMouseWheel | Raises the MouseWheel event. (Inherited from DataGridViewElement)
Protected Method | RenderAttributes | (Inherited from DataGridViewColumn)
Protected Method | RenderComponent | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from DataGridViewElement)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from DataGridViewElement)
Protected Method | RenderComponents | Renders the column's inner components (Inherited from DataGridViewColumn)
Protected Method | RenderUpdatedAttributes | Renders the updated attributes (Inherited from DataGridViewElement)
Protected Method | UpdateParams | Overloaded. Updates only the parameters of this instance. (Inherited from DataGridViewElement)
Top

See Also

Reference

DataGridViewCheckBoxColumn Class
Gizmox.WebGUI.Forms Namespace


ToString Method

[image]
Gizmox.WebGUI.Forms
ToString Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCheckBoxColumn Class : ToString Method

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCheckBoxColumn
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCheckBoxColumn Class
DataGridViewCheckBoxColumn Members


DataGridViewCheckBoxColumn Class Properties

[image]
Gizmox.WebGUI.Forms
DataGridViewCheckBoxColumn Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewCheckBoxColumn Class

For a list of all members of this type, see DataGridViewCheckBoxColumn members.

Public Properties

 | Name | Description
Public Property | AutoSizeMode | Gets or sets the mode by which the column automatically adjusts its width. (Inherited from DataGridViewColumn)
Public Property | CellTemplate | Overridden. Gets or sets the template used to create new cells.
Public Property | CellType | Gets the run-time type of the cell template. (Inherited from DataGridViewColumn)
Public Property | DataGridView | Gets the DataGridView control associated with this element. (Inherited from DataGridViewElement)
Public Property | DataPropertyName | Gets or sets the name of the data source property or database column to which the DataGridViewColumn is bound. (Inherited from DataGridViewColumn)
Public Property | DefaultCellStyle | Overridden. Gets or sets the column's default cell style.
Public Property | DefaultHeaderCellType | Gets or sets the run-time type of the default header cell. (Inherited from DataGridViewBand)
Public Property | Displayed | Gets a value indicating whether the band is currently displayed onscreen. (Inherited from DataGridViewBand)
Public Property | DisplayIndex | Gets or sets the display order of the column relative to the currently displayed columns. (Inherited from DataGridViewColumn)
Public Property | DividerWidth | Gets or sets the width, in pixels, of the column divider. (Inherited from DataGridViewColumn)
Public Property | FalseValue | Gets or sets the underlying value corresponding to a cell value of false, which appears as an unchecked box.
Public Property | FillWeight | Gets or sets a value that represents the width of the column when it is in fill mode relative to the widths of other fill-mode columns in the control. (Inherited from DataGridViewColumn)
Public Property | FlatStyle | Gets or sets the flat style appearance of the check box cells.
Public Property | Frozen | Gets or sets a value indicating whether a column will move when a user scrolls the DataGridView control horizontally. (Inherited from DataGridViewColumn)
Public Property | HasDefaultCellStyle | Gets a value indicating whether the DataGridViewBand.DefaultCellStyle property has been set. (Inherited from DataGridViewBand)
Public Property | HeaderCell | Gets or sets the DataGridViewColumnHeaderCell that represents the column header. (Inherited from DataGridViewColumn)
Public Property | HeaderText | Gets or sets the caption text on the column's header cell. (Inherited from DataGridViewColumn)
Public Property | IndeterminateValue | Gets or sets the underlying value corresponding to an indeterminate or null cell value, which appears as a disabled checkbox.
Public Property | Index | Gets the relative position of the band within the DataGridView control. (Inherited from DataGridViewBand)
Public Property | InheritedAutoSizeMode | Gets the sizing mode in effect for the column. (Inherited from DataGridViewColumn)
Public Property | InheritedStyle | Gets the cell style currently applied to the column. (Inherited from DataGridViewColumn)
Public Property | IsDataBound | Gets a value indicating whether the column is bound to a data source. (Inherited from DataGridViewColumn)
Public Property | MinimumWidth | Gets or sets the minimum width, in pixels, of the column. (Inherited from DataGridViewColumn)
Public Property | Name | Gets or sets the name of the column. (Inherited from DataGridViewColumn)
Public Property | ReadOnly | Gets or sets a value indicating whether the user can edit the column's cells. (Inherited from DataGridViewColumn)
Public Property | Resizable | Gets or sets a value indicating whether the column is resizable. (Inherited from DataGridViewColumn)
Public Property | Selected | Gets or sets a value indicating whether the band is in a selected user interface (UI) state. (Inherited from DataGridViewBand)
Public Property | Site | Gets or sets the site of the column. (Inherited from DataGridViewColumn)
Public Property | SortMode | Gets or sets the sort mode for the column. (Inherited from DataGridViewColumn)
Public Property | State | Gets the user interface (UI) state of the element. (Inherited from DataGridViewElement)
Public Property | Tag | Gets or sets the object that contains data to associate with the band. (Inherited from DataGridViewBand)
Public Property | ThreeState | Gets or sets a value indicating whether the hosted check box cells will allow three check states rather than two.
Public Property | ToolTipText | Gets or sets the text used for ToolTips. (Inherited from DataGridViewColumn)
Public Property | TrueValue | Gets or sets the underlying value corresponding to a cell value of true, which appears as a checked box.
Public Property | ValueType | Gets or sets the data type of the values in the column's cells. (Inherited from DataGridViewColumn)
Public Property | Visible | Gets or sets a value indicating whether the column is visible. (Inherited from DataGridViewColumn)
Public Property | Width | Gets or sets the current width of the column. (Inherited from DataGridViewColumn)
Top

Protected Properties

 | Name | Description
Protected Property | HeaderCellCore | Gets or sets the header cell of the DataGridViewBand. (Inherited from DataGridViewBand)
Protected Property | IsRow | Gets a value indicating whether the band represents a row. (Inherited from DataGridViewBand)
Protected Property | MemberID | (Inherited from DataGridViewColumn)
Protected Property | TagName | (Inherited from DataGridViewElement)
Protected Property | TypeName | Overridden.
Top

See Also

Reference

DataGridViewCheckBoxColumn Class
Gizmox.WebGUI.Forms Namespace


CellTemplate Property

[image]
Gizmox.WebGUI.Forms
CellTemplate Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCheckBoxColumn Class : CellTemplate Property

Gets or sets the template used to create new cells.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public Overrides Property CellTemplate As DataGridViewCell
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCheckBoxColumn
Dim value As DataGridViewCell

instance.CellTemplate = value

value = instance.CellTemplate
C#
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public override DataGridViewCell CellTemplate {get; set;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property DataGridViewCell* get_CellTemplate() override;
public: __property void set_CellTemplate(
   DataGridViewCell* value
) override;
C++/CLI
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
property DataGridViewCell^ CellTemplate {
   DataGridViewCell^ get() override;
   void set (DataGridViewCell^value) override;
}

Exceptions

Exception | Description
InvalidCastException | The property is set to a value that is not of type DataGridViewCheckBoxCell.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCheckBoxColumn Class
DataGridViewCheckBoxColumn Members


DefaultCellStyle Property

[image]
Gizmox.WebGUI.Forms
DefaultCellStyle Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCheckBoxColumn Class : DefaultCellStyle Property

Gets or sets the column's default cell style.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("The column's default cell style.")>
<BrowsableAttribute(True)>
<SRCategoryAttribute("Appearance")>
Public Overrides Property DefaultCellStyle As DataGridViewCellStyle
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCheckBoxColumn
Dim value As DataGridViewCellStyle

instance.DefaultCellStyle = value

value = instance.DefaultCellStyle
C#
[SRDescriptionAttribute("The column's default cell style.")]
[BrowsableAttribute(true)]
[SRCategoryAttribute("Appearance")]
public override DataGridViewCellStyle DefaultCellStyle {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("The column's default cell style.")]
[BrowsableAttribute(true)]
[SRCategoryAttribute("Appearance")]
public: __property DataGridViewCellStyle* get_DefaultCellStyle() override;
public: __property void set_DefaultCellStyle(
   DataGridViewCellStyle* value
) override;
C++/CLI
[SRDescriptionAttribute("The column's default cell style.")]
[BrowsableAttribute(true)]
[SRCategoryAttribute("Appearance")]
public:
property DataGridViewCellStyle^ DefaultCellStyle {
   DataGridViewCellStyle^ get() override;
   void set (DataGridViewCellStyle^value) override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCheckBoxColumn Class
DataGridViewCheckBoxColumn Members


FalseValue Property

[image]
Gizmox.WebGUI.Forms
FalseValue Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCheckBoxColumn Class : FalseValue Property

Gets or sets the underlying value corresponding to a cell value of false, which appears as an unchecked box.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Data")>
<TypeConverterAttribute("System.ComponentModel.StringConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<SRDescriptionAttribute("The underlying value corresponding to a cell value of false, which appears as an unchecked box.")>
<DefaultValueAttribute()>
Public Property FalseValue As Object
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCheckBoxColumn
Dim value As Object

instance.FalseValue = value

value = instance.FalseValue
C#
[SRCategoryAttribute("Data")]
[TypeConverterAttribute("System.ComponentModel.StringConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[SRDescriptionAttribute("The underlying value corresponding to a cell value of false, which appears as an unchecked box.")]
[DefaultValueAttribute()]
public object FalseValue {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Data")]
[TypeConverterAttribute("System.ComponentModel.StringConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[SRDescriptionAttribute("The underlying value corresponding to a cell value of false, which appears as an unchecked box.")]
[DefaultValueAttribute()]
public: __property Object* get_FalseValue();
public: __property void set_FalseValue(
   Object* value
);
C++/CLI
[SRCategoryAttribute("Data")]
[TypeConverterAttribute("System.ComponentModel.StringConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[SRDescriptionAttribute("The underlying value corresponding to a cell value of false, which appears as an unchecked box.")]
[DefaultValueAttribute()]
public:
property Object^ FalseValue {
   Object^ get();
   void set (Object^value);
}

Exceptions

Exception | Description
InvalidOperationException | The value of the CellTemplate property is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCheckBoxColumn Class
DataGridViewCheckBoxColumn Members


FlatStyle Property

[image]
Gizmox.WebGUI.Forms
FlatStyle Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCheckBoxColumn Class : FlatStyle Property

Gets or sets the flat style appearance of the check box cells.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("The flat style appearance of the check box cells.")>
<DefaultValueAttribute()>
<SRCategoryAttribute("Appearance")>
Public Property FlatStyle As FlatStyle
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCheckBoxColumn
Dim value As FlatStyle

instance.FlatStyle = value

value = instance.FlatStyle
C#
[SRDescriptionAttribute("The flat style appearance of the check box cells.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
public FlatStyle FlatStyle {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("The flat style appearance of the check box cells.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
public: __property FlatStyle get_FlatStyle();
public: __property void set_FlatStyle(
   FlatStyle value
);
C++/CLI
[SRDescriptionAttribute("The flat style appearance of the check box cells.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
public:
property FlatStyle FlatStyle {
   FlatStyle get();
   void set (FlatStylevalue);
}

Exceptions

Exception | Description
InvalidOperationException | The value of the CellTemplate property is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCheckBoxColumn Class
DataGridViewCheckBoxColumn Members


IndeterminateValue Property

[image]
Gizmox.WebGUI.Forms
IndeterminateValue Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCheckBoxColumn Class : IndeterminateValue Property

Gets or sets the underlying value corresponding to an indeterminate or null cell value, which appears as a disabled checkbox.

Syntax

Visual Basic (Declaration)
<TypeConverterAttribute("System.ComponentModel.StringConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<DefaultValueAttribute()>
<SRCategoryAttribute("Data")>
<SRDescriptionAttribute("The underlying value corresponding to an indeterminate or null cell value, which appears as a disabled checkbox.")>
Public Property IndeterminateValue As Object
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCheckBoxColumn
Dim value As Object

instance.IndeterminateValue = value

value = instance.IndeterminateValue
C#
[TypeConverterAttribute("System.ComponentModel.StringConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Data")]
[SRDescriptionAttribute("The underlying value corresponding to an indeterminate or null cell value, which appears as a disabled checkbox.")]
public object IndeterminateValue {get; set;}
Managed Extensions for C++
[TypeConverterAttribute("System.ComponentModel.StringConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Data")]
[SRDescriptionAttribute("The underlying value corresponding to an indeterminate or null cell value, which appears as a disabled checkbox.")]
public: __property Object* get_IndeterminateValue();
public: __property void set_IndeterminateValue(
   Object* value
);
C++/CLI
[TypeConverterAttribute("System.ComponentModel.StringConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Data")]
[SRDescriptionAttribute("The underlying value corresponding to an indeterminate or null cell value, which appears as a disabled checkbox.")]
public:
property Object^ IndeterminateValue {
   Object^ get();
   void set (Object^value);
}

Exceptions

Exception | Description
InvalidOperationException | The value of the CellTemplate property is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCheckBoxColumn Class
DataGridViewCheckBoxColumn Members


ThreeState Property

[image]
Gizmox.WebGUI.Forms
ThreeState Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCheckBoxColumn Class : ThreeState Property

Gets or sets a value indicating whether the hosted check box cells will allow three check states rather than two.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Indicates whether the hosted check box cells will allow three check states rather than two.")>
<DefaultValueAttribute()>
<SRCategoryAttribute("Behavior")>
Public Property ThreeState As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCheckBoxColumn
Dim value As Boolean

instance.ThreeState = value

value = instance.ThreeState
C#
[SRDescriptionAttribute("Indicates whether the hosted check box cells will allow three check states rather than two.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
public bool ThreeState {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Indicates whether the hosted check box cells will allow three check states rather than two.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
public: __property bool get_ThreeState();
public: __property void set_ThreeState(
   bool value
);
C++/CLI
[SRDescriptionAttribute("Indicates whether the hosted check box cells will allow three check states rather than two.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
public:
property bool ThreeState {
   bool get();
   void set (boolvalue);
}

Exceptions

Exception | Description
InvalidOperationException | The value of the CellTemplate property is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCheckBoxColumn Class
DataGridViewCheckBoxColumn Members


TrueValue Property

[image]
Gizmox.WebGUI.Forms
TrueValue Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCheckBoxColumn Class : TrueValue Property

Gets or sets the underlying value corresponding to a cell value of true, which appears as a checked box.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<SRCategoryAttribute("Data")>
<SRDescriptionAttribute("The underlying value corresponding to a cell value of true, which appears as a checked box.")>
<TypeConverterAttribute("System.ComponentModel.StringConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
Public Property TrueValue As Object
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCheckBoxColumn
Dim value As Object

instance.TrueValue = value

value = instance.TrueValue
C#
[DefaultValueAttribute()]
[SRCategoryAttribute("Data")]
[SRDescriptionAttribute("The underlying value corresponding to a cell value of true, which appears as a checked box.")]
[TypeConverterAttribute("System.ComponentModel.StringConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public object TrueValue {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[SRCategoryAttribute("Data")]
[SRDescriptionAttribute("The underlying value corresponding to a cell value of true, which appears as a checked box.")]
[TypeConverterAttribute("System.ComponentModel.StringConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public: __property Object* get_TrueValue();
public: __property void set_TrueValue(
   Object* value
);
C++/CLI
[DefaultValueAttribute()]
[SRCategoryAttribute("Data")]
[SRDescriptionAttribute("The underlying value corresponding to a cell value of true, which appears as a checked box.")]
[TypeConverterAttribute("System.ComponentModel.StringConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public:
property Object^ TrueValue {
   Object^ get();
   void set (Object^value);
}

Exceptions

Exception | Description
InvalidOperationException | The value of the CellTemplate property is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCheckBoxColumn Class
DataGridViewCheckBoxColumn Members


TypeName Property

[image]
Gizmox.WebGUI.Forms
TypeName Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewCheckBoxColumn Class : TypeName Property

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property TypeName As String
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCheckBoxColumn
Dim value As String

value = instance.TypeName
C#
protected override string TypeName {get;}
Managed Extensions for C++
protected: __property string* get_TypeName() override;
C++/CLI
protected:
property String^ TypeName {
   String^ get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewCheckBoxColumn Class
DataGridViewCheckBoxColumn Members


DataGridViewColumn Class

[image]
Gizmox.WebGUI.Forms
DataGridViewColumn Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewColumn Class

Represents a column in a DataGridView control.

Object Model

Syntax

Visual Basic (Declaration)
<TypeConverterAttribute("Gizmox.WebGUI.Forms.DataGridViewColumnConverter, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d")>
<DesignTimeControllerAttribute()>
<ClientControllerAttribute()>
<ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")>
<DesignTimeVisibleAttribute()>
Public Class DataGridViewColumn
   Inherits DataGridViewBand
   Implements IRenderableComponentMember
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewColumn
C#
[TypeConverterAttribute("Gizmox.WebGUI.Forms.DataGridViewColumnConverter, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d")]
[DesignTimeControllerAttribute()]
[ClientControllerAttribute()]
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
[DesignTimeVisibleAttribute()]
public class DataGridViewColumn : DataGridViewBand, IRenderableComponentMember
Managed Extensions for C++
[TypeConverterAttribute("Gizmox.WebGUI.Forms.DataGridViewColumnConverter, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d")]
[DesignTimeControllerAttribute()]
[ClientControllerAttribute()]
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
[DesignTimeVisibleAttribute()]
public __gc class DataGridViewColumn : public DataGridViewBand, IRenderableComponentMember
C++/CLI
[TypeConverterAttribute("Gizmox.WebGUI.Forms.DataGridViewColumnConverter, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d")]
[DesignTimeControllerAttribute()]
[ClientControllerAttribute()]
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
[DesignTimeVisibleAttribute()]
public ref class DataGridViewColumn : public DataGridViewBand, IRenderableComponentMember

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.DataGridViewElement
Gizmox.WebGUI.Forms.DataGridViewBand
Gizmox.WebGUI.Forms.DataGridViewColumn
Gizmox.WebGUI.Forms.DataGridViewButtonColumn
Gizmox.WebGUI.Forms.DataGridViewCheckBoxColumn
Gizmox.WebGUI.Forms.DataGridViewComboBoxColumn
Gizmox.WebGUI.Forms.DataGridViewImageColumn
Gizmox.WebGUI.Forms.DataGridViewLinkColumn
Gizmox.WebGUI.Forms.DataGridViewTextBoxColumn

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

DataGridViewColumn Members
Gizmox.WebGUI.Forms Namespace


DataGridViewColumn Class Members

[image]
Gizmox.WebGUI.Forms
DataGridViewColumn Class Members
See Also Fields Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewColumn Class

The following tables list the members exposed by DataGridViewColumn.

Public Constructors

 | Name | Description
Public Constructor | DataGridViewColumn Constructor | Overloaded. Initializes a new instance of the DataGridViewColumn class to the default state.
Top

Protected Fields

 | Name | Description
static (Shared in Visual Basic) | ButtonTypeName |
static (Shared in Visual Basic) | CheckBoxTypeName |
static (Shared in Visual Basic) | ComboBoxTypeName |
static (Shared in Visual Basic) | ImageTypeName |
static (Shared in Visual Basic) | LinkTypeName |
static (Shared in Visual Basic) | TextTypeName |
Top

Public Properties

 | Name | Description
Public Property | AutoSizeMode | Gets or sets the mode by which the column automatically adjusts its width.
Public Property | CellTemplate | Gets or sets the template used to create new cells.
Public Property | CellType | Gets the run-time type of the cell template.
Public Property | DataGridView | Gets the DataGridView control associated with this element. (Inherited from DataGridViewElement)
Public Property | DataPropertyName | Gets or sets the name of the data source property or database column to which the DataGridViewColumn is bound.
Public Property | DefaultCellStyle | Overridden. Gets or sets the column's default cell style.
Public Property | DefaultHeaderCellType | Gets or sets the run-time type of the default header cell. (Inherited from DataGridViewBand)
Public Property | Displayed | Gets a value indicating whether the band is currently displayed onscreen. (Inherited from DataGridViewBand)
Public Property | DisplayIndex | Gets or sets the display order of the column relative to the currently displayed columns.
Public Property | DividerWidth | Gets or sets the width, in pixels, of the column divider.
Public Property | FillWeight | Gets or sets a value that represents the width of the column when it is in fill mode relative to the widths of other fill-mode columns in the control.
Public Property | Frozen | Overridden. Gets or sets a value indicating whether a column will move when a user scrolls the DataGridView control horizontally.
Public Property | HasDefaultCellStyle | Gets a value indicating whether the DataGridViewBand.DefaultCellStyle property has been set. (Inherited from DataGridViewBand)
Public Property | HeaderCell | Gets or sets the DataGridViewColumnHeaderCell that represents the column header.
Public Property | HeaderText | Gets or sets the caption text on the column's header cell.
Public Property | Index | Gets the relative position of the band within the DataGridView control. (Inherited from DataGridViewBand)
Public Property | InheritedAutoSizeMode | Gets the sizing mode in effect for the column.
Public Property | InheritedStyle | Overridden. Gets the cell style currently applied to the column.
Public Property | IsDataBound | Gets a value indicating whether the column is bound to a data source.
Public Property | MinimumWidth | Gets or sets the minimum width, in pixels, of the column.
Public Property | Name | Gets or sets the name of the column.
Public Property | ReadOnly | Overridden. Gets or sets a value indicating whether the user can edit the column's cells.
Public Property | Resizable | Overridden. Gets or sets a value indicating whether the column is resizable.
Public Property | Selected | Gets or sets a value indicating whether the band is in a selected user interface (UI) state. (Inherited from DataGridViewBand)
Public Property | Site | Gets or sets the site of the column.
Public Property | SortMode | Gets or sets the sort mode for the column.
Public Property | State | Gets the user interface (UI) state of the element. (Inherited from DataGridViewElement)
Public Property | Tag | Gets or sets the object that contains data to associate with the band. (Inherited from DataGridViewBand)
Public Property | ToolTipText | Gets or sets the text used for ToolTips.
Public Property | ValueType | Gets or sets the data type of the values in the column's cells.
Public Property | Visible | Overridden. Gets or sets a value indicating whether the column is visible.
Public Property | Width | Gets or sets the current width of the column.
Top

Protected Properties

 | Name | Description
Protected Property | HeaderCellCore | Gets or sets the header cell of the DataGridViewBand. (Inherited from DataGridViewBand)
Protected Property | IsRow | Gets a value indicating whether the band represents a row. (Inherited from DataGridViewBand)
Protected Property | MemberID | Overridden.
Protected Property | TagName | (Inherited from DataGridViewElement)
Protected Property | TypeName |
Top

Public Methods

 | Name | Description
Public Method | Clone | Creates an exact copy of this band. (Inherited from DataGridViewBand)
Public Method | Dispose | Overloaded. Releases all resources used by the DataGridViewBand. (Inherited from DataGridViewBand)
Public Method | GetPreferredWidth | Calculates the ideal width of the column based on the specified criteria.
Public Method | ToString | Overridden. Gets a string that describes the column.
Public Method | Update | Overloaded. Full updates of this instance. (Inherited from DataGridViewElement)
Top

Protected Methods

 | Name | Description
Protected Method | CloneInternal |
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from DataGridViewElement)
Protected Method | IsDirty | Determines whether the specified component is dirty. (Inherited from DataGridViewElement)
Protected Method | IsDirtyAttributes | Overloaded. Determines whether the specified component is dirty. (Inherited from DataGridViewElement)
Protected Method | OnDataGridViewChanged | Called when the band is associated with a different DataGridView. (Inherited from DataGridViewBand)
Protected Method | RaiseCellClick | Raises the DataGridView.CellClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellContentClick | Raises the DataGridView.CellContentClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellContentDoubleClick | Raises the DataGridView.CellContentDoubleClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellValueChanged | Raises the CellValueChanged event. (Inherited from DataGridViewElement)
Protected Method | RaiseDataError | Raises the DataError event. (Inherited from DataGridViewElement)
Protected Method | RaiseMouseWheel | Raises the MouseWheel event. (Inherited from DataGridViewElement)
Protected Method | RenderAttributes | Overridden.
Protected Method | RenderComponent | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from DataGridViewElement)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from DataGridViewElement)
Protected Method | RenderComponents | Overridden. Renders the column's inner components
Protected Method | RenderUpdatedAttributes | Renders the updated attributes (Inherited from DataGridViewElement)
Protected Method | UpdateParams | Overloaded. Updates only the parameters of this instance. (Inherited from DataGridViewElement)
Top

Public Events

 | Name | Description
Public Event | Disposed | Occurs when the DataGridViewColumn is disposed.
Top

See Also

Reference

DataGridViewColumn Class
Gizmox.WebGUI.Forms Namespace


DataGridViewColumn Constructor

[image]
Gizmox.WebGUI.Forms
DataGridViewColumn Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumn Class : DataGridViewColumn Constructor

Initializes a new instance of the DataGridViewColumn class to the default state.

Overload List

Overload | Description
DataGridViewColumn Constructor() | Initializes a new instance of the DataGridViewColumn class to the default state.
DataGridViewColumn Constructor(DataGridViewCell) | Initializes a new instance of the DataGridViewColumn class using an existing DataGridViewCell as a template.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumn Class
DataGridViewColumn Members


DataGridViewColumn Constructor()

[image]
Gizmox.WebGUI.Forms
DataGridViewColumn Constructor()
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumn Class > DataGridViewColumn Constructor : DataGridViewColumn Constructor()

Initializes a new instance of the DataGridViewColumn class to the default state.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewColumn()
C#
public DataGridViewColumn()
Managed Extensions for C++
public: DataGridViewColumn();
C++/CLI
public:
DataGridViewColumn();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumn Class
DataGridViewColumn Members
Overload List


DataGridViewColumn Constructor(DataGridViewCell)

[image]
Gizmox.WebGUI.Forms
DataGridViewColumn Constructor(DataGridViewCell)
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumn Class > DataGridViewColumn Constructor : DataGridViewColumn Constructor(DataGridViewCell)

cellTemplate
An existing DataGridViewCell to use as a template.
Initializes a new instance of the DataGridViewColumn class using an existing DataGridViewCell as a template.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal cellTemplate As DataGridViewCell _
)
Visual Basic (Usage) Copy Code
Dim cellTemplate As DataGridViewCell

Dim instance As DataGridViewColumn(cellTemplate)
C#
public DataGridViewColumn(
   DataGridViewCell cellTemplate
)
Managed Extensions for C++
public: DataGridViewColumn(
   DataGridViewCell* cellTemplate
)
C++/CLI
public:
DataGridViewColumn(
   DataGridViewCell^ cellTemplate
)

Parameters

cellTemplate
An existing DataGridViewCell to use as a template.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumn Class
DataGridViewColumn Members
Overload List


DataGridViewColumn Class Methods

[image]
Gizmox.WebGUI.Forms
DataGridViewColumn Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewColumn Class

For a list of all members of this type, see DataGridViewColumn members.

Public Methods

 | Name | Description
Public Method | Clone | Creates an exact copy of this band. (Inherited from DataGridViewBand)
Public Method | Dispose | Overloaded. Releases all resources used by the DataGridViewBand. (Inherited from DataGridViewBand)
Public Method | GetPreferredWidth | Calculates the ideal width of the column based on the specified criteria.
Public Method | ToString | Overridden. Gets a string that describes the column.
Public Method | Update | Overloaded. Full updates of this instance. (Inherited from DataGridViewElement)
Top

Protected Methods

 | Name | Description
Protected Method | CloneInternal |
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from DataGridViewElement)
Protected Method | IsDirty | Determines whether the specified component is dirty. (Inherited from DataGridViewElement)
Protected Method | IsDirtyAttributes | Overloaded. Determines whether the specified component is dirty. (Inherited from DataGridViewElement)
Protected Method | OnDataGridViewChanged | Called when the band is associated with a different DataGridView. (Inherited from DataGridViewBand)
Protected Method | RaiseCellClick | Raises the DataGridView.CellClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellContentClick | Raises the DataGridView.CellContentClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellContentDoubleClick | Raises the DataGridView.CellContentDoubleClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellValueChanged | Raises the CellValueChanged event. (Inherited from DataGridViewElement)
Protected Method | RaiseDataError | Raises the DataError event. (Inherited from DataGridViewElement)
Protected Method | RaiseMouseWheel | Raises the MouseWheel event. (Inherited from DataGridViewElement)
Protected Method | RenderAttributes | Overridden.
Protected Method | RenderComponent | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from DataGridViewElement)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from DataGridViewElement)
Protected Method | RenderComponents | Overridden. Renders the column's inner components
Protected Method | RenderUpdatedAttributes | Renders the updated attributes (Inherited from DataGridViewElement)
Protected Method | UpdateParams | Overloaded. Updates only the parameters of this instance. (Inherited from DataGridViewElement)
Top

See Also

Reference

DataGridViewColumn Class
Gizmox.WebGUI.Forms Namespace


CloneInternal Method

[image]
Gizmox.WebGUI.Forms
CloneInternal Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumn Class : CloneInternal Method

dataGridViewColumn

Syntax

Visual Basic (Declaration)
Protected Sub CloneInternal( _
   ByVal dataGridViewColumn As DataGridViewComboBoxColumn _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewColumn
Dim dataGridViewColumn As DataGridViewComboBoxColumn

instance.CloneInternal(dataGridViewColumn)
C#
protected void CloneInternal(
   DataGridViewComboBoxColumn dataGridViewColumn
)
Managed Extensions for C++
protected: void CloneInternal(
   DataGridViewComboBoxColumn* dataGridViewColumn
)
C++/CLI
protected:
void CloneInternal(
   DataGridViewComboBoxColumn^ dataGridViewColumn
)

Parameters

dataGridViewColumn

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumn Class
DataGridViewColumn Members


GetPreferredWidth Method

[image]
Gizmox.WebGUI.Forms
GetPreferredWidth Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumn Class : GetPreferredWidth Method

autoSizeColumnMode
A DataGridViewAutoSizeColumnMode value that specifies an automatic sizing mode.
fixedHeight
true to calculate the width of the column based on the current row heights; false to calculate the width with the expectation that the row heights will be adjusted.
Calculates the ideal width of the column based on the specified criteria.

Syntax

Visual Basic (Declaration)
Public Overridable Function GetPreferredWidth( _
   ByVal autoSizeColumnMode As DataGridViewAutoSizeColumnMode, _
   ByVal fixedHeight As Boolean _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewColumn
Dim autoSizeColumnMode As DataGridViewAutoSizeColumnMode
Dim fixedHeight As Boolean
Dim value As Integer

value = instance.GetPreferredWidth(autoSizeColumnMode, fixedHeight)
C#
public virtual int GetPreferredWidth(
   DataGridViewAutoSizeColumnMode autoSizeColumnMode,
   bool fixedHeight
)
Managed Extensions for C++
public: virtual int GetPreferredWidth(
   DataGridViewAutoSizeColumnMode autoSizeColumnMode,
   bool fixedHeight
)
C++/CLI
public:
virtual int GetPreferredWidth(
   DataGridViewAutoSizeColumnMode autoSizeColumnMode,
   bool fixedHeight
)

Parameters

autoSizeColumnMode
A DataGridViewAutoSizeColumnMode value that specifies an automatic sizing mode.
fixedHeight
true to calculate the width of the column based on the current row heights; false to calculate the width with the expectation that the row heights will be adjusted.

Return Value

The ideal width, in pixels, of the column.

Exceptions

Exception | Description
InvalidEnumArgumentException | autoSizeColumnMode is not a valid DataGridViewAutoSizeColumnMode value.
ArgumentException | autoSizeColumnMode is DataGridViewAutoSizeColumnMode.NotSet, DataGridViewAutoSizeColumnMode.None, or DataGridViewAutoSizeColumnMode.Fill.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumn Class
DataGridViewColumn Members


RenderAttributes Method

[image]
Gizmox.WebGUI.Forms
RenderAttributes Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumn Class : RenderAttributes Method

objContext
objWriter
blnRenderOwner

Syntax

Visual Basic (Declaration)
Protected Overrides Sub RenderAttributes( _
   ByVal objContext As IContext, _
   ByVal objWriter As IAttributeWriter, _
   ByVal blnRenderOwner As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewColumn
Dim objContext As IContext
Dim objWriter As IAttributeWriter
Dim blnRenderOwner As Boolean

instance.RenderAttributes(objContext, objWriter, blnRenderOwner)
C#
protected override void RenderAttributes(
   IContext objContext,
   IAttributeWriter objWriter,
   bool blnRenderOwner
)
Managed Extensions for C++
protected: void RenderAttributes(
   IContext* objContext,
   IAttributeWriter* objWriter,
   bool blnRenderOwner
) override
C++/CLI
protected:
void RenderAttributes(
   IContext^ objContext,
   IAttributeWriter^ objWriter,
   bool blnRenderOwner
) override

Parameters

objContext
objWriter
blnRenderOwner

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumn Class
DataGridViewColumn Members


RenderComponents Method

[image]
Gizmox.WebGUI.Forms
RenderComponents Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumn Class : RenderComponents Method

objContext
objWriter
lngRequestID
blnRenderOwner
Renders the column's inner components

Syntax

Visual Basic (Declaration)
Protected Overrides Sub RenderComponents( _
   ByVal objContext As IContext, _
   ByVal objWriter As IResponseWriter, _
   ByVal lngRequestID As Long, _
   ByVal blnRenderOwner As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewColumn
Dim objContext As IContext
Dim objWriter As IResponseWriter
Dim lngRequestID As Long
Dim blnRenderOwner As Boolean

instance.RenderComponents(objContext, objWriter, lngRequestID, blnRenderOwner)
C#
protected override void RenderComponents(
   IContext objContext,
   IResponseWriter objWriter,
   long lngRequestID,
   bool blnRenderOwner
)
Managed Extensions for C++
protected: void RenderComponents(
   IContext* objContext,
   IResponseWriter* objWriter,
   long lngRequestID,
   bool blnRenderOwner
) override
C++/CLI
protected:
void RenderComponents(
   IContext^ objContext,
   IResponseWriter^ objWriter,
   long long lngRequestID,
   bool blnRenderOwner
) override

Parameters

objContext
objWriter
lngRequestID
blnRenderOwner

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumn Class
DataGridViewColumn Members


ToString Method

[image]
Gizmox.WebGUI.Forms
ToString Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumn Class : ToString Method

Gets a string that describes the column.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewColumn
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Return Value

A String that describes the column.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumn Class
DataGridViewColumn Members


DataGridViewColumn Class Properties

[image]
Gizmox.WebGUI.Forms
DataGridViewColumn Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewColumn Class

For a list of all members of this type, see DataGridViewColumn members.

Public Properties

 | Name | Description
Public Property | AutoSizeMode | Gets or sets the mode by which the column automatically adjusts its width.
Public Property | CellTemplate | Gets or sets the template used to create new cells.
Public Property | CellType | Gets the run-time type of the cell template.
Public Property | DataGridView | Gets the DataGridView control associated with this element. (Inherited from DataGridViewElement)
Public Property | DataPropertyName | Gets or sets the name of the data source property or database column to which the DataGridViewColumn is bound.
Public Property | DefaultCellStyle | Overridden. Gets or sets the column's default cell style.
Public Property | DefaultHeaderCellType | Gets or sets the run-time type of the default header cell. (Inherited from DataGridViewBand)
Public Property | Displayed | Gets a value indicating whether the band is currently displayed onscreen. (Inherited from DataGridViewBand)
Public Property | DisplayIndex | Gets or sets the display order of the column relative to the currently displayed columns.
Public Property | DividerWidth | Gets or sets the width, in pixels, of the column divider.
Public Property | FillWeight | Gets or sets a value that represents the width of the column when it is in fill mode relative to the widths of other fill-mode columns in the control.
Public Property | Frozen | Overridden. Gets or sets a value indicating whether a column will move when a user scrolls the DataGridView control horizontally.
Public Property | HasDefaultCellStyle | Gets a value indicating whether the DataGridViewBand.DefaultCellStyle property has been set. (Inherited from DataGridViewBand)
Public Property | HeaderCell | Gets or sets the DataGridViewColumnHeaderCell that represents the column header.
Public Property | HeaderText | Gets or sets the caption text on the column's header cell.
Public Property | Index | Gets the relative position of the band within the DataGridView control. (Inherited from DataGridViewBand)
Public Property | InheritedAutoSizeMode | Gets the sizing mode in effect for the column.
Public Property | InheritedStyle | Overridden. Gets the cell style currently applied to the column.
Public Property | IsDataBound | Gets a value indicating whether the column is bound to a data source.
Public Property | MinimumWidth | Gets or sets the minimum width, in pixels, of the column.
Public Property | Name | Gets or sets the name of the column.
Public Property | ReadOnly | Overridden. Gets or sets a value indicating whether the user can edit the column's cells.
Public Property | Resizable | Overridden. Gets or sets a value indicating whether the column is resizable.
Public Property | Selected | Gets or sets a value indicating whether the band is in a selected user interface (UI) state. (Inherited from DataGridViewBand)
Public Property | Site | Gets or sets the site of the column.
Public Property | SortMode | Gets or sets the sort mode for the column.
Public Property | State | Gets the user interface (UI) state of the element. (Inherited from DataGridViewElement)
Public Property | Tag | Gets or sets the object that contains data to associate with the band. (Inherited from DataGridViewBand)
Public Property | ToolTipText | Gets or sets the text used for ToolTips.
Public Property | ValueType | Gets or sets the data type of the values in the column's cells.
Public Property | Visible | Overridden. Gets or sets a value indicating whether the column is visible.
Public Property | Width | Gets or sets the current width of the column.
Top

Protected Properties

 | Name | Description
Protected Property | HeaderCellCore | Gets or sets the header cell of the DataGridViewBand. (Inherited from DataGridViewBand)
Protected Property | IsRow | Gets a value indicating whether the band represents a row. (Inherited from DataGridViewBand)
Protected Property | MemberID | Overridden.
Protected Property | TagName | (Inherited from DataGridViewElement)
Protected Property | TypeName |
Top

See Also

Reference

DataGridViewColumn Class
Gizmox.WebGUI.Forms Namespace


AutoSizeMode Property

[image]
Gizmox.WebGUI.Forms
AutoSizeMode Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumn Class : AutoSizeMode Property

Gets or sets the mode by which the column automatically adjusts its width.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<RefreshPropertiesAttribute()>
<SRDescriptionAttribute("Determines the auto size mode for this column.")>
<SRCategoryAttribute("Layout")>
Public Property AutoSizeMode As DataGridViewAutoSizeColumnMode
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewColumn
Dim value As DataGridViewAutoSizeColumnMode

instance.AutoSizeMode = value

value = instance.AutoSizeMode
C#
[DefaultValueAttribute()]
[RefreshPropertiesAttribute()]
[SRDescriptionAttribute("Determines the auto size mode for this column.")]
[SRCategoryAttribute("Layout")]
public DataGridViewAutoSizeColumnMode AutoSizeMode {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[RefreshPropertiesAttribute()]
[SRDescriptionAttribute("Determines the auto size mode for this column.")]
[SRCategoryAttribute("Layout")]
public: __property DataGridViewAutoSizeColumnMode get_AutoSizeMode();
public: __property void set_AutoSizeMode(
   DataGridViewAutoSizeColumnMode value
);
C++/CLI
[DefaultValueAttribute()]
[RefreshPropertiesAttribute()]
[SRDescriptionAttribute("Determines the auto size mode for this column.")]
[SRCategoryAttribute("Layout")]
public:
property DataGridViewAutoSizeColumnMode AutoSizeMode {
   DataGridViewAutoSizeColumnMode get();
   void set (DataGridViewAutoSizeColumnModevalue);
}

Exceptions

Exception | Description
InvalidOperationException | The specified value when setting this property results in an InheritedAutoSizeMode value of ColumnHeader for a visible column when column headers are hidden.-or-The specified value when setting this property results in an InheritedAutoSizeMode value of Fill for a visible column that is frozen.
InvalidEnumArgumentException | The specified value when setting this property is a DataGridViewAutoSizeColumnMode that is not valid.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumn Class
DataGridViewColumn Members


CellTemplate Property

[image]
Gizmox.WebGUI.Forms
CellTemplate Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumn Class : CellTemplate Property

Gets or sets the template used to create new cells.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<DesignerSerializationVisibilityAttribute()>
Public Overridable Property CellTemplate As DataGridViewCell
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewColumn
Dim value As DataGridViewCell

instance.CellTemplate = value

value = instance.CellTemplate
C#
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[DesignerSerializationVisibilityAttribute()]
public virtual DataGridViewCell CellTemplate {get; set;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[DesignerSerializationVisibilityAttribute()]
public: __property virtual DataGridViewCell* get_CellTemplate();
public: __property virtual void set_CellTemplate(
   DataGridViewCell* value
);
C++/CLI
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[DesignerSerializationVisibilityAttribute()]
public:
virtual property DataGridViewCell^ CellTemplate {
   DataGridViewCell^ get();
   void set (DataGridViewCell^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumn Class
DataGridViewColumn Members


CellType Property

[image]
Gizmox.WebGUI.Forms
CellType Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumn Class : CellType Property

Gets the run-time type of the cell template.

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<BrowsableAttribute(False)>
Public ReadOnly Property CellType As Type
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewColumn
Dim value As Type

value = instance.CellType
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[BrowsableAttribute(false)]
public Type CellType {get;}
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[BrowsableAttribute(false)]
public: __property Type* get_CellType();
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[BrowsableAttribute(false)]
public:
property Type^ CellType {
   Type^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumn Class
DataGridViewColumn Members


DataPropertyName Property

[image]
Gizmox.WebGUI.Forms
DataPropertyName Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumn Class : DataPropertyName Property

Gets or sets the name of the data source property or database column to which the DataGridViewColumn is bound.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Data")>
<EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.DataGridViewColumnDataPropertyNameEditor, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<SRDescriptionAttribute("The name of the data source property or database column to which the DataGridViewColumn is bound.")>
<TypeConverterAttribute("System.Windows.Forms.Design.DataMemberFieldConverter, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<BrowsableAttribute(True)>
<DefaultValueAttribute()>
Public Property DataPropertyName As String
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewColumn
Dim value As String

instance.DataPropertyName = value

value = instance.DataPropertyName
C#
[SRCategoryAttribute("Data")]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.DataGridViewColumnDataPropertyNameEditor, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[SRDescriptionAttribute("The name of the data source property or database column to which the DataGridViewColumn is bound.")]
[TypeConverterAttribute("System.Windows.Forms.Design.DataMemberFieldConverter, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[BrowsableAttribute(true)]
[DefaultValueAttribute()]
public string DataPropertyName {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Data")]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.DataGridViewColumnDataPropertyNameEditor, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[SRDescriptionAttribute("The name of the data source property or database column to which the DataGridViewColumn is bound.")]
[TypeConverterAttribute("System.Windows.Forms.Design.DataMemberFieldConverter, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[BrowsableAttribute(true)]
[DefaultValueAttribute()]
public: __property string* get_DataPropertyName();
public: __property void set_DataPropertyName(
   string* value
);
C++/CLI
[SRCategoryAttribute("Data")]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.DataGridViewColumnDataPropertyNameEditor, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[SRDescriptionAttribute("The name of the data source property or database column to which the DataGridViewColumn is bound.")]
[TypeConverterAttribute("System.Windows.Forms.Design.DataMemberFieldConverter, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[BrowsableAttribute(true)]
[DefaultValueAttribute()]
public:
property String^ DataPropertyName {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumn Class
DataGridViewColumn Members


DefaultCellStyle Property

[image]
Gizmox.WebGUI.Forms
DefaultCellStyle Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumn Class : DefaultCellStyle Property

Gets or sets the column's default cell style.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("The column's default cell style.")>
<BrowsableAttribute(True)>
<SRCategoryAttribute("Appearance")>
Public Overrides Property DefaultCellStyle As DataGridViewCellStyle
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewColumn
Dim value As DataGridViewCellStyle

instance.DefaultCellStyle = value

value = instance.DefaultCellStyle
C#
[SRDescriptionAttribute("The column's default cell style.")]
[BrowsableAttribute(true)]
[SRCategoryAttribute("Appearance")]
public override DataGridViewCellStyle DefaultCellStyle {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("The column's default cell style.")]
[BrowsableAttribute(true)]
[SRCategoryAttribute("Appearance")]
public: __property DataGridViewCellStyle* get_DefaultCellStyle() override;
public: __property void set_DefaultCellStyle(
   DataGridViewCellStyle* value
) override;
C++/CLI
[SRDescriptionAttribute("The column's default cell style.")]
[BrowsableAttribute(true)]
[SRCategoryAttribute("Appearance")]
public:
property DataGridViewCellStyle^ DefaultCellStyle {
   DataGridViewCellStyle^ get() override;
   void set (DataGridViewCellStyle^value) override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumn Class
DataGridViewColumn Members


DisplayIndex Property

[image]
Gizmox.WebGUI.Forms
DisplayIndex Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumn Class : DisplayIndex Property

Gets or sets the display order of the column relative to the currently displayed columns.

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
Public Property DisplayIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewColumn
Dim value As Integer

instance.DisplayIndex = value

value = instance.DisplayIndex
C#
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public int DisplayIndex {get; set;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public: __property int get_DisplayIndex();
public: __property void set_DisplayIndex(
   int value
);
C++/CLI
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public:
property int DisplayIndex {
   int get();
   void set (intvalue);
}

Exceptions

Exception | Description
ArgumentOutOfRangeException | DataGridViewElement.DataGridView is not null and the specified value when setting this property is less than 0 or greater than or equal to the number of columns in the control.-or-DataGridViewElement.DataGridView is null and the specified value when setting this property is less than -1.-or-The specified value when setting this property is equal to MaxValue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumn Class
DataGridViewColumn Members


DividerWidth Property

[image]
Gizmox.WebGUI.Forms
DividerWidth Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumn Class : DividerWidth Property

Gets or sets the width, in pixels, of the column divider.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("The width of the column divider in pixels.")>
<SRCategoryAttribute("Layout")>
<DefaultValueAttribute()>
Public Property DividerWidth As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewColumn
Dim value As Integer

instance.DividerWidth = value

value = instance.DividerWidth
C#
[SRDescriptionAttribute("The width of the column divider in pixels.")]
[SRCategoryAttribute("Layout")]
[DefaultValueAttribute()]
public int DividerWidth {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("The width of the column divider in pixels.")]
[SRCategoryAttribute("Layout")]
[DefaultValueAttribute()]
public: __property int get_DividerWidth();
public: __property void set_DividerWidth(
   int value
);
C++/CLI
[SRDescriptionAttribute("The width of the column divider in pixels.")]
[SRCategoryAttribute("Layout")]
[DefaultValueAttribute()]
public:
property int DividerWidth {
   int get();
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumn Class
DataGridViewColumn Members


FillWeight Property

[image]
Gizmox.WebGUI.Forms
FillWeight Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumn Class : FillWeight Property

Gets or sets a value that represents the width of the column when it is in fill mode relative to the widths of other fill-mode columns in the control.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("The weight that is used when sizing this column in the Fill auto size mode.")>
<DefaultValueAttribute()>
<SRCategoryAttribute("Layout")>
Public Property FillWeight As Single
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewColumn
Dim value As Single

instance.FillWeight = value

value = instance.FillWeight
C#
[SRDescriptionAttribute("The weight that is used when sizing this column in the Fill auto size mode.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Layout")]
public float FillWeight {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("The weight that is used when sizing this column in the Fill auto size mode.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Layout")]
public: __property float get_FillWeight();
public: __property void set_FillWeight(
   float value
);
C++/CLI
[SRDescriptionAttribute("The weight that is used when sizing this column in the Fill auto size mode.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Layout")]
public:
property float FillWeight {
   float get();
   void set (floatvalue);
}

Exceptions

Exception | Description
ArgumentOutOfRangeException | The specified value when setting this property is less than or equal to 0.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumn Class
DataGridViewColumn Members


Frozen Property

[image]
Gizmox.WebGUI.Forms
Frozen Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumn Class : Frozen Property

Gets or sets a value indicating whether a column will move when a user scrolls the DataGridView control horizontally.

Syntax

Visual Basic (Declaration)
<RefreshPropertiesAttribute()>
<DefaultValueAttribute()>
<SRCategoryAttribute("Layout")>
<SRDescriptionAttribute("Indicates whether a column will move when a user scrolls the DataGridView control horizontally.")>
Public Overrides Property Frozen As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewColumn
Dim value As Boolean

instance.Frozen = value

value = instance.Frozen
C#
[RefreshPropertiesAttribute()]
[DefaultValueAttribute()]
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Indicates whether a column will move when a user scrolls the DataGridView control horizontally.")]
public override bool Frozen {get; set;}
Managed Extensions for C++
[RefreshPropertiesAttribute()]
[DefaultValueAttribute()]
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Indicates whether a column will move when a user scrolls the DataGridView control horizontally.")]
public: __property bool get_Frozen() override;
public: __property void set_Frozen(
   bool value
) override;
C++/CLI
[RefreshPropertiesAttribute()]
[DefaultValueAttribute()]
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Indicates whether a column will move when a user scrolls the DataGridView control horizontally.")]
public:
property bool Frozen {
   bool get() override;
   void set (boolvalue) override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumn Class
DataGridViewColumn Members


HeaderCell Property

[image]
Gizmox.WebGUI.Forms
HeaderCell Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumn Class : HeaderCell Property

Gets or sets the DataGridViewColumnHeaderCell that represents the column header.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public Property HeaderCell As DataGridViewColumnHeaderCell
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewColumn
Dim value As DataGridViewColumnHeaderCell

instance.HeaderCell = value

value = instance.HeaderCell
C#
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public DataGridViewColumnHeaderCell HeaderCell {get; set;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property DataGridViewColumnHeaderCell* get_HeaderCell();
public: __property void set_HeaderCell(
   DataGridViewColumnHeaderCell* value
);
C++/CLI
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
property DataGridViewColumnHeaderCell^ HeaderCell {
   DataGridViewColumnHeaderCell^ get();
   void set (DataGridViewColumnHeaderCell^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumn Class
DataGridViewColumn Members


HeaderText Property

[image]
Gizmox.WebGUI.Forms
HeaderText Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumn Class : HeaderText Property

Gets or sets the caption text on the column's header cell.

Syntax

Visual Basic (Declaration)
<LocalizableAttribute(True)>
<SRDescriptionAttribute("The caption text on the column's header cell.")>
<RefreshPropertiesAttribute()>
<SRCategoryAttribute("Appearance")>
Public Property HeaderText As String
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewColumn
Dim value As String

instance.HeaderText = value

value = instance.HeaderText
C#
[LocalizableAttribute(true)]
[SRDescriptionAttribute("The caption text on the column's header cell.")]
[RefreshPropertiesAttribute()]
[SRCategoryAttribute("Appearance")]
public string HeaderText {get; set;}
Managed Extensions for C++
[LocalizableAttribute(true)]
[SRDescriptionAttribute("The caption text on the column's header cell.")]
[RefreshPropertiesAttribute()]
[SRCategoryAttribute("Appearance")]
public: __property string* get_HeaderText();
public: __property void set_HeaderText(
   string* value
);
C++/CLI
[LocalizableAttribute(true)]
[SRDescriptionAttribute("The caption text on the column's header cell.")]
[RefreshPropertiesAttribute()]
[SRCategoryAttribute("Appearance")]
public:
property String^ HeaderText {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumn Class
DataGridViewColumn Members


InheritedAutoSizeMode Property

[image]
Gizmox.WebGUI.Forms
InheritedAutoSizeMode Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumn Class : InheritedAutoSizeMode Property

Gets the sizing mode in effect for the column.

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public ReadOnly Property InheritedAutoSizeMode As DataGridViewAutoSizeColumnMode
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewColumn
Dim value As DataGridViewAutoSizeColumnMode

value = instance.InheritedAutoSizeMode
C#
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public DataGridViewAutoSizeColumnMode InheritedAutoSizeMode {get;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: __property DataGridViewAutoSizeColumnMode get_InheritedAutoSizeMode();
C++/CLI
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
property DataGridViewAutoSizeColumnMode InheritedAutoSizeMode {
   DataGridViewAutoSizeColumnMode get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumn Class
DataGridViewColumn Members


InheritedStyle Property

[image]
Gizmox.WebGUI.Forms
InheritedStyle Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumn Class : InheritedStyle Property

Gets the cell style currently applied to the column.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public Overrides ReadOnly Property InheritedStyle As DataGridViewCellStyle
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewColumn
Dim value As DataGridViewCellStyle

value = instance.InheritedStyle
C#
[BrowsableAttribute(false)]
public override DataGridViewCellStyle InheritedStyle {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property DataGridViewCellStyle* get_InheritedStyle() override;
C++/CLI
[BrowsableAttribute(false)]
public:
property DataGridViewCellStyle^ InheritedStyle {
   DataGridViewCellStyle^ get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumn Class
DataGridViewColumn Members


IsDataBound Property

[image]
Gizmox.WebGUI.Forms
IsDataBound Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumn Class : IsDataBound Property

Gets a value indicating whether the column is bound to a data source.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public ReadOnly Property IsDataBound As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewColumn
Dim value As Boolean

value = instance.IsDataBound
C#
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public bool IsDataBound {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property bool get_IsDataBound();
C++/CLI
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
property bool IsDataBound {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumn Class
DataGridViewColumn Members


MemberID Property

[image]
Gizmox.WebGUI.Forms
MemberID Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumn Class : MemberID Property

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property MemberID As String
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewColumn
Dim value As String

value = instance.MemberID
C#
protected override string MemberID {get;}
Managed Extensions for C++
protected: __property string* get_MemberID() override;
C++/CLI
protected:
property String^ MemberID {
   String^ get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumn Class
DataGridViewColumn Members


MinimumWidth Property

[image]
Gizmox.WebGUI.Forms
MinimumWidth Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumn Class : MinimumWidth Property

Gets or sets the minimum width, in pixels, of the column.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<RefreshPropertiesAttribute()>
<LocalizableAttribute(True)>
<SRDescriptionAttribute("The minimum width of the column in pixels.")>
<SRCategoryAttribute("Layout")>
Public Property MinimumWidth As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewColumn
Dim value As Integer

instance.MinimumWidth = value

value = instance.MinimumWidth
C#
[DefaultValueAttribute()]
[RefreshPropertiesAttribute()]
[LocalizableAttribute(true)]
[SRDescriptionAttribute("The minimum width of the column in pixels.")]
[SRCategoryAttribute("Layout")]
public int MinimumWidth {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[RefreshPropertiesAttribute()]
[LocalizableAttribute(true)]
[SRDescriptionAttribute("The minimum width of the column in pixels.")]
[SRCategoryAttribute("Layout")]
public: __property int get_MinimumWidth();
public: __property void set_MinimumWidth(
   int value
);
C++/CLI
[DefaultValueAttribute()]
[RefreshPropertiesAttribute()]
[LocalizableAttribute(true)]
[SRDescriptionAttribute("The minimum width of the column in pixels.")]
[SRCategoryAttribute("Layout")]
public:
property int MinimumWidth {
   int get();
   void set (intvalue);
}

Exceptions

Exception | Description
ArgumentOutOfRangeException | The value is less than 2 or greater than MaxValue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumn Class
DataGridViewColumn Members


Name Property

[image]
Gizmox.WebGUI.Forms
Name Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumn Class : Name Property

Gets or sets the name of the column.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewColumn
Dim value As String

instance.Name = value

value = instance.Name
C#
[BrowsableAttribute(false)]
public string Name {get; set;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property string* get_Name();
public: __property void set_Name(
   string* value
);
C++/CLI
[BrowsableAttribute(false)]
public:
property String^ Name {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumn Class
DataGridViewColumn Members


ReadOnly Property

[image]
Gizmox.WebGUI.Forms
ReadOnly Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumn Class : ReadOnly Property

Gets or sets a value indicating whether the user can edit the column's cells.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Behavior")>
<SRDescriptionAttribute("Indicates whether the user can edit the column's cells.")>
Public Overrides Property ReadOnly As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewColumn
Dim value As Boolean

instance.ReadOnly = value

value = instance.ReadOnly
C#
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Indicates whether the user can edit the column's cells.")]
public override bool ReadOnly {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Indicates whether the user can edit the column's cells.")]
public: __property bool get_ReadOnly() override;
public: __property void set_ReadOnly(
   bool value
) override;
C++/CLI
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Indicates whether the user can edit the column's cells.")]
public:
property bool ReadOnly {
   bool get() override;
   void set (boolvalue) override;
}

Exceptions

Exception | Description
InvalidOperationException | This property is set to false for a column that is bound to a read-only data source.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumn Class
DataGridViewColumn Members


Resizable Property

[image]
Gizmox.WebGUI.Forms
Resizable Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumn Class : Resizable Property

Gets or sets a value indicating whether the column is resizable.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Behavior")>
<SRDescriptionAttribute("Indicates whether the column is resizable.")>
Public Overrides Property Resizable As DataGridViewTriState
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewColumn
Dim value As DataGridViewTriState

instance.Resizable = value

value = instance.Resizable
C#
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Indicates whether the column is resizable.")]
public override DataGridViewTriState Resizable {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Indicates whether the column is resizable.")]
public: __property DataGridViewTriState get_Resizable() override;
public: __property void set_Resizable(
   DataGridViewTriState value
) override;
C++/CLI
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Indicates whether the column is resizable.")]
public:
property DataGridViewTriState Resizable {
   DataGridViewTriState get() override;
   void set (DataGridViewTriStatevalue) override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumn Class
DataGridViewColumn Members


Site Property

[image]
Gizmox.WebGUI.Forms
Site Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumn Class : Site Property

Gets or sets the site of the column.

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
Public Property Site As ISite
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewColumn
Dim value As ISite

instance.Site = value

value = instance.Site
C#
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public ISite Site {get; set;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public: __property ISite* get_Site();
public: __property void set_Site(
   ISite* value
);
C++/CLI
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public:
property ISite^ Site {
   ISite^ get();
   void set (ISite^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumn Class
DataGridViewColumn Members


SortMode Property

[image]
Gizmox.WebGUI.Forms
SortMode Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumn Class : SortMode Property

Gets or sets the sort mode for the column.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<SRCategoryAttribute("Behavior")>
<SRDescriptionAttribute("The sort mode for the column. ")>
Public Property SortMode As DataGridViewColumnSortMode
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewColumn
Dim value As DataGridViewColumnSortMode

instance.SortMode = value

value = instance.SortMode
C#
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("The sort mode for the column. ")]
public DataGridViewColumnSortMode SortMode {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("The sort mode for the column. ")]
public: __property DataGridViewColumnSortMode get_SortMode();
public: __property void set_SortMode(
   DataGridViewColumnSortMode value
);
C++/CLI
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("The sort mode for the column. ")]
public:
property DataGridViewColumnSortMode SortMode {
   DataGridViewColumnSortMode get();
   void set (DataGridViewColumnSortModevalue);
}

Exceptions

Exception | Description
InvalidOperationException | The value assigned to the property conflicts with DataGridView.SelectionMode.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumn Class
DataGridViewColumn Members


ToolTipText Property

[image]
Gizmox.WebGUI.Forms
ToolTipText Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumn Class : ToolTipText Property

Gets or sets the text used for ToolTips.

Syntax

Visual Basic (Declaration)
<LocalizableAttribute(True)>
<DefaultValueAttribute()>
<SRDescriptionAttribute("The text used for ToolTips.")>
<SRCategoryAttribute("Appearance")>
Public Property ToolTipText As String
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewColumn
Dim value As String

instance.ToolTipText = value

value = instance.ToolTipText
C#
[LocalizableAttribute(true)]
[DefaultValueAttribute()]
[SRDescriptionAttribute("The text used for ToolTips.")]
[SRCategoryAttribute("Appearance")]
public string ToolTipText {get; set;}
Managed Extensions for C++
[LocalizableAttribute(true)]
[DefaultValueAttribute()]
[SRDescriptionAttribute("The text used for ToolTips.")]
[SRCategoryAttribute("Appearance")]
public: __property string* get_ToolTipText();
public: __property void set_ToolTipText(
   string* value
);
C++/CLI
[LocalizableAttribute(true)]
[DefaultValueAttribute()]
[SRDescriptionAttribute("The text used for ToolTips.")]
[SRCategoryAttribute("Appearance")]
public:
property String^ ToolTipText {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumn Class
DataGridViewColumn Members


TypeName Property

[image]
Gizmox.WebGUI.Forms
TypeName Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumn Class : TypeName Property

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property TypeName As String
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewColumn
Dim value As String

value = instance.TypeName
C#
protected virtual string TypeName {get;}
Managed Extensions for C++
protected: __property virtual string* get_TypeName();
C++/CLI
protected:
virtual property String^ TypeName {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumn Class
DataGridViewColumn Members


ValueType Property

[image]
Gizmox.WebGUI.Forms
ValueType Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumn Class : ValueType Property

Gets or sets the data type of the values in the column's cells.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public Property ValueType As Type
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewColumn
Dim value As Type

instance.ValueType = value

value = instance.ValueType
C#
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public Type ValueType {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property Type* get_ValueType();
public: __property void set_ValueType(
   Type* value
);
C++/CLI
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
property Type^ ValueType {
   Type^ get();
   void set (Type^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumn Class
DataGridViewColumn Members


Visible Property

[image]
Gizmox.WebGUI.Forms
Visible Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumn Class : Visible Property

Gets or sets a value indicating whether the column is visible.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<SRCategoryAttribute("Appearance")>
<LocalizableAttribute(True)>
<SRDescriptionAttribute("Indicates whether the column is visible.")>
Public Overrides Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewColumn
Dim value As Boolean

instance.Visible = value

value = instance.Visible
C#
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
[LocalizableAttribute(true)]
[SRDescriptionAttribute("Indicates whether the column is visible.")]
public override bool Visible {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
[LocalizableAttribute(true)]
[SRDescriptionAttribute("Indicates whether the column is visible.")]
public: __property bool get_Visible() override;
public: __property void set_Visible(
   bool value
) override;
C++/CLI
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
[LocalizableAttribute(true)]
[SRDescriptionAttribute("Indicates whether the column is visible.")]
public:
property bool Visible {
   bool get() override;
   void set (boolvalue) override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumn Class
DataGridViewColumn Members


Width Property

[image]
Gizmox.WebGUI.Forms
Width Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumn Class : Width Property

Gets or sets the current width of the column.

Syntax

Visual Basic (Declaration)
<LocalizableAttribute(True)>
<RefreshPropertiesAttribute()>
<SRDescriptionAttribute("The current width of the column.")>
<SRCategoryAttribute("Layout")>
Public Property Width As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewColumn
Dim value As Integer

instance.Width = value

value = instance.Width
C#
[LocalizableAttribute(true)]
[RefreshPropertiesAttribute()]
[SRDescriptionAttribute("The current width of the column.")]
[SRCategoryAttribute("Layout")]
public int Width {get; set;}
Managed Extensions for C++
[LocalizableAttribute(true)]
[RefreshPropertiesAttribute()]
[SRDescriptionAttribute("The current width of the column.")]
[SRCategoryAttribute("Layout")]
public: __property int get_Width();
public: __property void set_Width(
   int value
);
C++/CLI
[LocalizableAttribute(true)]
[RefreshPropertiesAttribute()]
[SRDescriptionAttribute("The current width of the column.")]
[SRCategoryAttribute("Layout")]
public:
property int Width {
   int get();
   void set (intvalue);
}

Exceptions

Exception | Description
ArgumentOutOfRangeException | The specified value when setting this property is greater than 65536.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumn Class
DataGridViewColumn Members


DataGridViewColumn Class Fields

[image]
Gizmox.WebGUI.Forms
DataGridViewColumn Class Fields
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewColumn Class

For a list of all members of this type, see DataGridViewColumn members.

Protected Fields

 | Name | Description
static (Shared in Visual Basic) | ButtonTypeName |
static (Shared in Visual Basic) | CheckBoxTypeName |
static (Shared in Visual Basic) | ComboBoxTypeName |
static (Shared in Visual Basic) | ImageTypeName |
static (Shared in Visual Basic) | LinkTypeName |
static (Shared in Visual Basic) | TextTypeName |
Top

See Also

Reference

DataGridViewColumn Class
Gizmox.WebGUI.Forms Namespace


ButtonTypeName Field

[image]
Gizmox.WebGUI.Forms
ButtonTypeName Field
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumn Class : ButtonTypeName Field

Syntax

Visual Basic (Declaration)
Protected Shared ButtonTypeName As String
Visual Basic (Usage) Copy Code
Dim value As String

value = DataGridViewColumn.ButtonTypeName

DataGridViewColumn.ButtonTypeName = value
C#
protected static string ButtonTypeName
Managed Extensions for C++
protected: static string* ButtonTypeName
C++/CLI
protected:
static String^ ButtonTypeName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumn Class
DataGridViewColumn Members


CheckBoxTypeName Field

[image]
Gizmox.WebGUI.Forms
CheckBoxTypeName Field
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumn Class : CheckBoxTypeName Field

Syntax

Visual Basic (Declaration)
Protected Shared CheckBoxTypeName As String
Visual Basic (Usage) Copy Code
Dim value As String

value = DataGridViewColumn.CheckBoxTypeName

DataGridViewColumn.CheckBoxTypeName = value
C#
protected static string CheckBoxTypeName
Managed Extensions for C++
protected: static string* CheckBoxTypeName
C++/CLI
protected:
static String^ CheckBoxTypeName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumn Class
DataGridViewColumn Members


ComboBoxTypeName Field

[image]
Gizmox.WebGUI.Forms
ComboBoxTypeName Field
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumn Class : ComboBoxTypeName Field

Syntax

Visual Basic (Declaration)
Protected Shared ComboBoxTypeName As String
Visual Basic (Usage) Copy Code
Dim value As String

value = DataGridViewColumn.ComboBoxTypeName

DataGridViewColumn.ComboBoxTypeName = value
C#
protected static string ComboBoxTypeName
Managed Extensions for C++
protected: static string* ComboBoxTypeName
C++/CLI
protected:
static String^ ComboBoxTypeName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumn Class
DataGridViewColumn Members


ImageTypeName Field

[image]
Gizmox.WebGUI.Forms
ImageTypeName Field
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumn Class : ImageTypeName Field

Syntax

Visual Basic (Declaration)
Protected Shared ImageTypeName As String
Visual Basic (Usage) Copy Code
Dim value As String

value = DataGridViewColumn.ImageTypeName

DataGridViewColumn.ImageTypeName = value
C#
protected static string ImageTypeName
Managed Extensions for C++
protected: static string* ImageTypeName
C++/CLI
protected:
static String^ ImageTypeName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumn Class
DataGridViewColumn Members


LinkTypeName Field

[image]
Gizmox.WebGUI.Forms
LinkTypeName Field
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumn Class : LinkTypeName Field

Syntax

Visual Basic (Declaration)
Protected Shared LinkTypeName As String
Visual Basic (Usage) Copy Code
Dim value As String

value = DataGridViewColumn.LinkTypeName

DataGridViewColumn.LinkTypeName = value
C#
protected static string LinkTypeName
Managed Extensions for C++
protected: static string* LinkTypeName
C++/CLI
protected:
static String^ LinkTypeName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumn Class
DataGridViewColumn Members


TextTypeName Field

[image]
Gizmox.WebGUI.Forms
TextTypeName Field
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumn Class : TextTypeName Field

Syntax

Visual Basic (Declaration)
Protected Shared TextTypeName As String
Visual Basic (Usage) Copy Code
Dim value As String

value = DataGridViewColumn.TextTypeName

DataGridViewColumn.TextTypeName = value
C#
protected static string TextTypeName
Managed Extensions for C++
protected: static string* TextTypeName
C++/CLI
protected:
static String^ TextTypeName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumn Class
DataGridViewColumn Members


DataGridViewColumn Class Events

[image]
Gizmox.WebGUI.Forms
DataGridViewColumn Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewColumn Class

For a list of all members of this type, see DataGridViewColumn members.

Public Events

 | Name | Description
Public Event | Disposed | Occurs when the DataGridViewColumn is disposed.
Top

See Also

Reference

DataGridViewColumn Class
Gizmox.WebGUI.Forms Namespace


Disposed Event

[image]
Gizmox.WebGUI.Forms
Disposed Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumn Class : Disposed Event

Occurs when the DataGridViewColumn is disposed.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Event Disposed() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewColumn
Dim handler As EventHandler

AddHandler instance.Disposed, handler
C#
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public event EventHandler Disposed()
Managed Extensions for C++
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: __event EventHandler* Disposed
C++/CLI
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
event EventHandler^ Disposed

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumn Class
DataGridViewColumn Members


DataGridViewColumnCollection Class

[image]
Gizmox.WebGUI.Forms
DataGridViewColumnCollection Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewColumnCollection Class

Represents a collection of DataGridViewColumn objects in a DataGridView control.

Object Model

Syntax

Visual Basic (Declaration)
<ListBindableAttribute(False)>
<DefaultMemberAttribute("Item")>
<EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.DataGridViewColumnCollectionEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")>
<DesignTimeControllerAttribute()>
<ClientControllerAttribute()>
Public Class DataGridViewColumnCollection
   Inherits BaseCollection
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewColumnCollection
C#
[ListBindableAttribute(false)]
[DefaultMemberAttribute("Item")]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.DataGridViewColumnCollectionEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[DesignTimeControllerAttribute()]
[ClientControllerAttribute()]
public class DataGridViewColumnCollection : BaseCollection
Managed Extensions for C++
[ListBindableAttribute(false)]
[DefaultMemberAttribute("Item")]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.DataGridViewColumnCollectionEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[DesignTimeControllerAttribute()]
[ClientControllerAttribute()]
public __gc class DataGridViewColumnCollection : public BaseCollection
C++/CLI
[ListBindableAttribute(false)]
[DefaultMemberAttribute("Item")]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.DataGridViewColumnCollectionEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[DesignTimeControllerAttribute()]
[ClientControllerAttribute()]
public ref class DataGridViewColumnCollection : public BaseCollection

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.BaseCollection
Gizmox.WebGUI.Forms.DataGridViewColumnCollection

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

DataGridViewColumnCollection Members
Gizmox.WebGUI.Forms Namespace


DataGridViewColumnCollection Class Members

[image]
Gizmox.WebGUI.Forms
DataGridViewColumnCollection Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewColumnCollection Class

The following tables list the members exposed by DataGridViewColumnCollection.

Public Constructors

 | Name | Description
Public Constructor | DataGridViewColumnCollection Constructor | Initializes a new instance of the DataGridViewColumnCollection class for the given DataGridView.
Top

Public Properties

 | Name | Description
Public Property | Count | Gets the total number of elements in the collection. (Inherited from BaseCollection)
Public Property | IsReadOnly | Gets a value indicating whether the collection is read-only. (Inherited from BaseCollection)
Public Property | IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized. (Inherited from BaseCollection)
Public Property | Item | Overloaded. Gets or sets the column of the given name in the collection.
Public Property | SyncRoot | Gets an object that can be used to synchronize access to the BaseCollection. (Inherited from BaseCollection)
Top

Protected Properties

 | Name | Description
Protected Property | DataGridView | Gets the DataGridView upon which the collection performs column-related operations.
Protected Property | List | Overridden.
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Adds the given column to the collection.
Public Method | AddRange | Adds a range of columns to the collection.
Public Method | Clear | Clears the collection.
Public Method | Contains | Overloaded. Determines whether the collection contains the column referred to by the given name.
Public Method | CopyTo | Overloaded. Copies the items from the collection to the given array.
Public Method | GetColumnCount | Returns the number of columns that meet the given filter requirements.
Public Method | GetColumnsWidth | Returns the width, in pixels, required to display all of the columns that meet the given filter requirements.
Public Method | GetEnumerator | Gets the object that enables iterating through the members of the collection. (Inherited from BaseCollection)
Public Method | GetFirstColumn | Overloaded. Returns the first column in display order that meets the given inclusion-filter requirements.
Public Method | GetLastColumn | Returns the last column in display order that meets the given filter requirements.
Public Method | GetNextColumn | Gets the first column after the given column in display order that meets the given filter requirements.
Public Method | GetPreviousColumn | Gets the last column prior to the given column in display order that meets the given filter requirements.
Public Method | IndexOf | Gets the index of the given DataGridViewColumn in the collection.
Public Method | Insert | Inserts a column at the given index in the collection.
Public Method | Remove | Overloaded. Removes the column with the specified name from the collection.
Public Method | RemoveAt | Removes the column at the given index in the collection.
Top

Protected Methods

 | Name | Description
Protected Method | OnCollectionChanged | Raises the CollectionChanged event.
Top

Public Events

 | Name | Description
Public Event | CollectionChanged | Occurs when the collection changes.
Top

See Also

Reference

DataGridViewColumnCollection Class
Gizmox.WebGUI.Forms Namespace


DataGridViewColumnCollection Constructor

[image]
Gizmox.WebGUI.Forms
DataGridViewColumnCollection Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumnCollection Class : DataGridViewColumnCollection Constructor

dataGridView
The DataGridView that created this collection.
Initializes a new instance of the DataGridViewColumnCollection class for the given DataGridView.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal dataGridView As DataGridView _
)
Visual Basic (Usage) Copy Code
Dim dataGridView As DataGridView

Dim instance As DataGridViewColumnCollection(dataGridView)
C#
public DataGridViewColumnCollection(
   DataGridView dataGridView
)
Managed Extensions for C++
public: DataGridViewColumnCollection(
   DataGridView* dataGridView
)
C++/CLI
public:
DataGridViewColumnCollection(
   DataGridView^ dataGridView
)

Parameters

dataGridView
The DataGridView that created this collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumnCollection Class
DataGridViewColumnCollection Members


DataGridViewColumnCollection Class Methods

[image]
Gizmox.WebGUI.Forms
DataGridViewColumnCollection Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewColumnCollection Class

For a list of all members of this type, see DataGridViewColumnCollection members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Adds the given column to the collection.
Public Method | AddRange | Adds a range of columns to the collection.
Public Method | Clear | Clears the collection.
Public Method | Contains | Overloaded. Determines whether the collection contains the column referred to by the given name.
Public Method | CopyTo | Overloaded. Copies the items from the collection to the given array.
Public Method | GetColumnCount | Returns the number of columns that meet the given filter requirements.
Public Method | GetColumnsWidth | Returns the width, in pixels, required to display all of the columns that meet the given filter requirements.
Public Method | GetEnumerator | Gets the object that enables iterating through the members of the collection. (Inherited from BaseCollection)
Public Method | GetFirstColumn | Overloaded. Returns the first column in display order that meets the given inclusion-filter requirements.
Public Method | GetLastColumn | Returns the last column in display order that meets the given filter requirements.
Public Method | GetNextColumn | Gets the first column after the given column in display order that meets the given filter requirements.
Public Method | GetPreviousColumn | Gets the last column prior to the given column in display order that meets the given filter requirements.
Public Method | IndexOf | Gets the index of the given DataGridViewColumn in the collection.
Public Method | Insert | Inserts a column at the given index in the collection.
Public Method | Remove | Overloaded. Removes the column with the specified name from the collection.
Public Method | RemoveAt | Removes the column at the given index in the collection.
Top

Protected Methods

 | Name | Description
Protected Method | OnCollectionChanged | Raises the CollectionChanged event.
Top

See Also

Reference

DataGridViewColumnCollection Class
Gizmox.WebGUI.Forms Namespace


Add Method

[image]
Gizmox.WebGUI.Forms
Add Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumnCollection Class : Add Method

Adds the given column to the collection.

Overload List

Overload | Description
Add(DataGridViewColumn) | Adds the given column to the collection.
Add(String,String) | Adds a DataGridViewTextBoxColumn with the given column name and column header text to the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumnCollection Class
DataGridViewColumnCollection Members


Add(DataGridViewColumn) Method

[image]
Gizmox.WebGUI.Forms
Add(DataGridViewColumn) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumnCollection Class > Add Method : Add(DataGridViewColumn) Method

dataGridViewColumn
The DataGridViewColumn to add.
Adds the given column to the collection.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function Add( _
   ByVal dataGridViewColumn As DataGridViewColumn _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewColumnCollection
Dim dataGridViewColumn As DataGridViewColumn
Dim value As Integer

value = instance.Add(dataGridViewColumn)
C#
public virtual int Add(
   DataGridViewColumn dataGridViewColumn
)
Managed Extensions for C++
public: virtual int Add(
   DataGridViewColumn* dataGridViewColumn
)
C++/CLI
public:
virtual int Add(
   DataGridViewColumn^ dataGridViewColumn
)

Parameters

dataGridViewColumn
The DataGridViewColumn to add.

Return Value

The index of the column.

Exceptions

Exception | Description
ArgumentNullException | dataGridViewColumn is null.
InvalidOperationException | The associated DataGridView control is performing one of the following actions that temporarily prevents new columns from being added:Selecting all cells in the control.Clearing the selection.Updating column DataGridViewColumn.DisplayIndex property values. -or-This method is being called from a handler for one of the following DataGridView events:RowValidated RowValidating-or-dataGridViewColumn already belongs to a DataGridView control.-or-The dataGridViewColumnDataGridViewColumn.SortMode property value is DataGridViewColumnSortMode.Automatic and the DataGridView.SelectionMode property value is DataGridViewSelectionMode.FullColumnSelect or DataGridViewSelectionMode.ColumnHeaderSelect. Use the control BeginInit and EndInit methods to temporarily set conflicting property values. -or-The dataGridViewColumnDataGridViewColumn.InheritedAutoSizeMode property value is DataGridViewAutoSizeColumnMode.ColumnHeader and the ColumnHeadersVisible property value is false.-or-dataGridViewColumn has an DataGridViewColumn.InheritedAutoSizeMode property value of DataGridViewAutoSizeColumnMode.Fill and a DataGridViewColumn.Frozen property value of true.-or-dataGridViewColumn has a DataGridViewColumn.FillWeight property value that would cause the combined DataGridViewColumn.FillWeight values of all columns in the control to exceed 65535.-or-dataGridViewColumn has DataGridViewColumn.DisplayIndex and DataGridViewColumn.Frozen property values that would display it among a set of adjacent columns with the opposite DataGridViewColumn.Frozen property value.-or-The DataGridView control contains at least one row and dataGridViewColumn has a DataGridViewColumn.CellType property value of null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumnCollection Class
DataGridViewColumnCollection Members
Overload List


Add(String,String) Method

[image]
Gizmox.WebGUI.Forms
Add(String,String) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumnCollection Class > Add Method : Add(String,String) Method

columnName
The name by which the column will be referred.
headerText
The text for the column's header.
Adds a DataGridViewTextBoxColumn with the given column name and column header text to the collection.

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
Public Overloads Overridable Function Add( _
   ByVal columnName As String, _
   ByVal headerText As String _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewColumnCollection
Dim columnName As String
Dim headerText As String
Dim value As Integer

value = instance.Add(columnName, headerText)
C#
[DesignerSerializationVisibilityAttribute()]
public virtual int Add(
   string columnName,
   string headerText
)
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
public: virtual int Add(
   string* columnName,
   string* headerText
)
C++/CLI
[DesignerSerializationVisibilityAttribute()]
public:
virtual int Add(
   String^ columnName,
   String^ headerText
)

Parameters

columnName
The name by which the column will be referred.
headerText
The text for the column's header.

Return Value

The index of the column.

Exceptions

Exception | Description
InvalidOperationException | The associated DataGridView control is performing one of the following actions that temporarily prevents new columns from being added:Selecting all cells in the control.Clearing the selection.Updating column DataGridViewColumn.DisplayIndex property values. -or-This method is being called from a handler for one of the following DataGridView events:RowValidated RowValidating-or-The DataGridView.SelectionMode property value is DataGridViewSelectionMode.FullColumnSelect or DataGridViewSelectionMode.ColumnHeaderSelect, which conflicts with the default column DataGridViewColumn.SortMode property value of DataGridViewColumnSortMode.Automatic.-or-The default column DataGridViewColumn.FillWeight property value of 100 would cause the combined DataGridViewColumn.FillWeight values of all columns in the control to exceed 65535.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumnCollection Class
DataGridViewColumnCollection Members
Overload List


AddRange Method

[image]
Gizmox.WebGUI.Forms
AddRange Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumnCollection Class : AddRange Method

dataGridViewColumns
An array of DataGridViewColumn objects to add.
Adds a range of columns to the collection.

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddRange( _
   ByVal ParamArray dataGridViewColumns() As DataGridViewColumn _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewColumnCollection
Dim dataGridViewColumns() As DataGridViewColumn

instance.AddRange(dataGridViewColumns)
C#
public virtual void AddRange(
   params DataGridViewColumn[] dataGridViewColumns
)
Managed Extensions for C++
public: virtual void AddRange(
   params DataGridViewColumn*[]* dataGridViewColumns
)
C++/CLI
public:
virtual void AddRange(
   ... array<DataGridViewColumn^>^ dataGridViewColumns
)

Parameters

dataGridViewColumns
An array of DataGridViewColumn objects to add.

Exceptions

Exception | Description
ArgumentNullException | dataGridViewColumns is null.
InvalidOperationException | The associated DataGridView control is performing one of the following actions that temporarily prevents new columns from being added:Selecting all cells in the control.Clearing the selection.Updating column DataGridViewColumn.DisplayIndex property values. -or-This method is being called from a handler for one of the following DataGridView events:RowValidated RowValidating-or-At least one of the values in dataGridViewColumns is null.-or-At least one of the columns in dataGridViewColumns already belongs to a DataGridView control.-or-At least one of the columns in dataGridViewColumns has a DataGridViewColumn.CellType property value of null and the DataGridView control contains at least one row.-or-At least one of the columns in dataGridViewColumns has a DataGridViewColumn.SortMode property value of DataGridViewColumnSortMode.Automatic and the DataGridView.SelectionMode property value is DataGridViewSelectionMode.FullColumnSelect or DataGridViewSelectionMode.ColumnHeaderSelect. Use the control BeginInit and EndInit methods to temporarily set conflicting property values. -or-At least one of the columns in dataGridViewColumns has an DataGridViewColumn.InheritedAutoSizeMode property value of DataGridViewAutoSizeColumnMode.ColumnHeader and the ColumnHeadersVisible property value is false.-or-At least one of the columns in dataGridViewColumns has an DataGridViewColumn.InheritedAutoSizeMode property value of DataGridViewAutoSizeColumnMode.Fill and a DataGridViewColumn.Frozen property value of true.-or-The columns in dataGridViewColumns have DataGridViewColumn.FillWeight property values that would cause the combined DataGridViewColumn.FillWeight values of all columns in the control to exceed 65535.-or-At least two of the values in dataGridViewColumns are references to the same DataGridViewColumn.-or-At least one of the columns in dataGridViewColumns has DataGridViewColumn.DisplayIndex and DataGridViewColumn.Frozen property values that would display it among a set of adjacent columns with the opposite DataGridViewColumn.Frozen property value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumnCollection Class
DataGridViewColumnCollection Members


Clear Method

[image]
Gizmox.WebGUI.Forms
Clear Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumnCollection Class : Clear Method

Clears the collection.

Syntax

Visual Basic (Declaration)
Public Overridable Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewColumnCollection

instance.Clear()
C#
public virtual void Clear()
Managed Extensions for C++
public: virtual void Clear();
C++/CLI
public:
virtual void Clear();

Exceptions

Exception | Description
InvalidOperationException | The associated DataGridView control is performing one of the following actions that temporarily prevents new columns from being added:Selecting all cells in the control.Clearing the selection.Updating column DataGridViewColumn.DisplayIndex property values. -or-This method is being called from a handler for one of the following DataGridView events:RowValidated RowValidating

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumnCollection Class
DataGridViewColumnCollection Members


Contains Method

[image]
Gizmox.WebGUI.Forms
Contains Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumnCollection Class : Contains Method

Determines whether the collection contains the column referred to by the given name.

Overload List

Overload | Description
Contains(String) | Determines whether the collection contains the column referred to by the given name.
Contains(DataGridViewColumn) | Determines whether the collection contains the given column.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumnCollection Class
DataGridViewColumnCollection Members


Contains(String) Method

[image]
Gizmox.WebGUI.Forms
Contains(String) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumnCollection Class > Contains Method : Contains(String) Method

columnName
The name of the column to look for.
Determines whether the collection contains the column referred to by the given name.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function Contains( _
   ByVal columnName As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewColumnCollection
Dim columnName As String
Dim value As Boolean

value = instance.Contains(columnName)
C#
public virtual bool Contains(
   string columnName
)
Managed Extensions for C++
public: virtual bool Contains(
   string* columnName
)
C++/CLI
public:
virtual bool Contains(
   String^ columnName
)

Parameters

columnName
The name of the column to look for.

Return Value

true if the column is contained in the collection; otherwise, false.

Exceptions

Exception | Description
ArgumentNullException | columnName is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumnCollection Class
DataGridViewColumnCollection Members
Overload List


Contains(DataGridViewColumn) Method

[image]
Gizmox.WebGUI.Forms
Contains(DataGridViewColumn) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumnCollection Class > Contains Method : Contains(DataGridViewColumn) Method

dataGridViewColumn
The DataGridViewColumn to look for.
Determines whether the collection contains the given column.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function Contains( _
   ByVal dataGridViewColumn As DataGridViewColumn _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewColumnCollection
Dim dataGridViewColumn As DataGridViewColumn
Dim value As Boolean

value = instance.Contains(dataGridViewColumn)
C#
public virtual bool Contains(
   DataGridViewColumn dataGridViewColumn
)
Managed Extensions for C++
public: virtual bool Contains(
   DataGridViewColumn* dataGridViewColumn
)
C++/CLI
public:
virtual bool Contains(
   DataGridViewColumn^ dataGridViewColumn
)

Parameters

dataGridViewColumn
The DataGridViewColumn to look for.

Return Value

true if the given column is in the collection; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumnCollection Class
DataGridViewColumnCollection Members
Overload List


CopyTo Method

[image]
Gizmox.WebGUI.Forms
CopyTo Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumnCollection Class : CopyTo Method

Copies the items from the collection to the given array.

Overload List

Overload | Description
CopyTo(DataGridViewColumn[],Int32) | Copies the items from the collection to the given array.
CopyTo(Array,Int32) | Copies all the elements of the current one-dimensional Array to the specified one-dimensional Array starting at the specified destination Array index. (Inherited from BaseCollection)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumnCollection Class
DataGridViewColumnCollection Members


CopyTo(DataGridViewColumn[],Int32) Method

[image]
Gizmox.WebGUI.Forms
CopyTo(DataGridViewColumn[],Int32) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumnCollection Class > CopyTo Method : CopyTo(DataGridViewColumn[],Int32) Method

array
The destination DataGridViewColumn array.
index
The index of the destination array at which to start copying.
Copies the items from the collection to the given array.

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal array() As DataGridViewColumn, _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewColumnCollection
Dim array() As DataGridViewColumn
Dim index As Integer

instance.CopyTo(array, index)
C#
public void CopyTo(
   DataGridViewColumn[] array,
   int index
)
Managed Extensions for C++
public: void CopyTo(
   DataGridViewColumn*[]* array,
   int index
)
C++/CLI
public:
void CopyTo(
   array<DataGridViewColumn^>^ array,
   int index
)

Parameters

array
The destination DataGridViewColumn array.
index
The index of the destination array at which to start copying.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumnCollection Class
DataGridViewColumnCollection Members
Overload List


GetColumnCount Method

[image]
Gizmox.WebGUI.Forms
GetColumnCount Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumnCollection Class : GetColumnCount Method

includeFilter
A bitwise combination of the DataGridViewElementStates values that represent the filter for inclusion.
Returns the number of columns that meet the given filter requirements.

Syntax

Visual Basic (Declaration)
Public Function GetColumnCount( _
   ByVal includeFilter As DataGridViewElementStates _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewColumnCollection
Dim includeFilter As DataGridViewElementStates
Dim value As Integer

value = instance.GetColumnCount(includeFilter)
C#
public int GetColumnCount(
   DataGridViewElementStates includeFilter
)
Managed Extensions for C++
public: int GetColumnCount(
   DataGridViewElementStates includeFilter
)
C++/CLI
public:
int GetColumnCount(
   DataGridViewElementStates includeFilter
)

Parameters

includeFilter
A bitwise combination of the DataGridViewElementStates values that represent the filter for inclusion.

Return Value

The number of columns that meet the filter requirements.

Exceptions

Exception | Description
ArgumentException | includeFilter is not a valid bitwise combination of DataGridViewElementStates values.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumnCollection Class
DataGridViewColumnCollection Members


GetColumnsWidth Method

[image]
Gizmox.WebGUI.Forms
GetColumnsWidth Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumnCollection Class : GetColumnsWidth Method

includeFilter
A bitwise combination of the DataGridViewElementStates values that represent the filter for inclusion.
Returns the width, in pixels, required to display all of the columns that meet the given filter requirements.

Syntax

Visual Basic (Declaration)
Public Function GetColumnsWidth( _
   ByVal includeFilter As DataGridViewElementStates _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewColumnCollection
Dim includeFilter As DataGridViewElementStates
Dim value As Integer

value = instance.GetColumnsWidth(includeFilter)
C#
public int GetColumnsWidth(
   DataGridViewElementStates includeFilter
)
Managed Extensions for C++
public: int GetColumnsWidth(
   DataGridViewElementStates includeFilter
)
C++/CLI
public:
int GetColumnsWidth(
   DataGridViewElementStates includeFilter
)

Parameters

includeFilter
A bitwise combination of the DataGridViewElementStates values that represent the filter for inclusion.

Return Value

The width, in pixels, that is necessary to display all of the columns that meet the filter requirements.

Exceptions

Exception | Description
ArgumentException | includeFilter is not a valid bitwise combination of DataGridViewElementStates values.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumnCollection Class
DataGridViewColumnCollection Members


GetFirstColumn Method

[image]
Gizmox.WebGUI.Forms
GetFirstColumn Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumnCollection Class : GetFirstColumn Method

Returns the first column in display order that meets the given inclusion-filter requirements.

Overload List

Overload | Description
GetFirstColumn(DataGridViewElementStates) | Returns the first column in display order that meets the given inclusion-filter requirements.
GetFirstColumn(DataGridViewElementStates,DataGridViewElementStates) | Returns the first column in display order that meets the given inclusion-filter and exclusion-filter requirements.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumnCollection Class
DataGridViewColumnCollection Members


GetFirstColumn(DataGridViewElementStates) Method

[image]
Gizmox.WebGUI.Forms
GetFirstColumn(DataGridViewElementStates) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumnCollection Class > GetFirstColumn Method : GetFirstColumn(DataGridViewElementStates) Method

includeFilter
A bitwise combination of the DataGridViewElementStates values that represents the filter for inclusion.
Returns the first column in display order that meets the given inclusion-filter requirements.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetFirstColumn( _
   ByVal includeFilter As DataGridViewElementStates _
) As DataGridViewColumn
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewColumnCollection
Dim includeFilter As DataGridViewElementStates
Dim value As DataGridViewColumn

value = instance.GetFirstColumn(includeFilter)
C#
public DataGridViewColumn GetFirstColumn(
   DataGridViewElementStates includeFilter
)
Managed Extensions for C++
public: DataGridViewColumn* GetFirstColumn(
   DataGridViewElementStates includeFilter
)
C++/CLI
public:
DataGridViewColumn^ GetFirstColumn(
   DataGridViewElementStates includeFilter
)

Parameters

includeFilter
A bitwise combination of the DataGridViewElementStates values that represents the filter for inclusion.

Return Value

The first column in display order that meets the given filter requirements, or null if no column is found.

Exceptions

Exception | Description
ArgumentException | includeFilter is not a valid bitwise combination of DataGridViewElementStates values.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumnCollection Class
DataGridViewColumnCollection Members
Overload List


GetFirstColumn(DataGridViewElementStates,DataGridViewElementStates) Method

[image]
Gizmox.WebGUI.Forms
GetFirstColumn(DataGridViewElementStates,DataGridViewElementStates) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumnCollection Class > GetFirstColumn Method : GetFirstColumn(DataGridViewElementStates,DataGridViewElementStates) Method

includeFilter
A bitwise combination of the DataGridViewElementStates values that represent the filter to apply for inclusion.
excludeFilter
A bitwise combination of the DataGridViewElementStates values that represent the filter to apply for exclusion.
Returns the first column in display order that meets the given inclusion-filter and exclusion-filter requirements.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetFirstColumn( _
   ByVal includeFilter As DataGridViewElementStates, _
   ByVal excludeFilter As DataGridViewElementStates _
) As DataGridViewColumn
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewColumnCollection
Dim includeFilter As DataGridViewElementStates
Dim excludeFilter As DataGridViewElementStates
Dim value As DataGridViewColumn

value = instance.GetFirstColumn(includeFilter, excludeFilter)
C#
public DataGridViewColumn GetFirstColumn(
   DataGridViewElementStates includeFilter,
   DataGridViewElementStates excludeFilter
)
Managed Extensions for C++
public: DataGridViewColumn* GetFirstColumn(
   DataGridViewElementStates includeFilter,
   DataGridViewElementStates excludeFilter
)
C++/CLI
public:
DataGridViewColumn^ GetFirstColumn(
   DataGridViewElementStates includeFilter,
   DataGridViewElementStates excludeFilter
)

Parameters

includeFilter
A bitwise combination of the DataGridViewElementStates values that represent the filter to apply for inclusion.
excludeFilter
A bitwise combination of the DataGridViewElementStates values that represent the filter to apply for exclusion.

Return Value

The first column in display order that meets the given filter requirements, or null if no column is found.

Exceptions

Exception | Description
ArgumentException | At least one of the filter values is not a valid bitwise combination of DataGridViewElementStates values.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumnCollection Class
DataGridViewColumnCollection Members
Overload List


GetLastColumn Method

[image]
Gizmox.WebGUI.Forms
GetLastColumn Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumnCollection Class : GetLastColumn Method

includeFilter
A bitwise combination of the DataGridViewElementStates values that represent the filter to apply for inclusion.
excludeFilter
A bitwise combination of the DataGridViewElementStates values that represent the filter to apply for exclusion.
Returns the last column in display order that meets the given filter requirements.

Syntax

Visual Basic (Declaration)
Public Function GetLastColumn( _
   ByVal includeFilter As DataGridViewElementStates, _
   ByVal excludeFilter As DataGridViewElementStates _
) As DataGridViewColumn
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewColumnCollection
Dim includeFilter As DataGridViewElementStates
Dim excludeFilter As DataGridViewElementStates
Dim value As DataGridViewColumn

value = instance.GetLastColumn(includeFilter, excludeFilter)
C#
public DataGridViewColumn GetLastColumn(
   DataGridViewElementStates includeFilter,
   DataGridViewElementStates excludeFilter
)
Managed Extensions for C++
public: DataGridViewColumn* GetLastColumn(
   DataGridViewElementStates includeFilter,
   DataGridViewElementStates excludeFilter
)
C++/CLI
public:
DataGridViewColumn^ GetLastColumn(
   DataGridViewElementStates includeFilter,
   DataGridViewElementStates excludeFilter
)

Parameters

includeFilter
A bitwise combination of the DataGridViewElementStates values that represent the filter to apply for inclusion.
excludeFilter
A bitwise combination of the DataGridViewElementStates values that represent the filter to apply for exclusion.

Return Value

The last displayed column in display order that meets the given filter requirements, or null if no column is found.

Exceptions

Exception | Description
ArgumentException | At least one of the filter values is not a valid bitwise combination of DataGridViewElementStates values.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumnCollection Class
DataGridViewColumnCollection Members


GetNextColumn Method

[image]
Gizmox.WebGUI.Forms
GetNextColumn Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumnCollection Class : GetNextColumn Method

dataGridViewColumnStart
The column from which to start searching for the next column.
includeFilter
A bitwise combination of the DataGridViewElementStates values that represent the filter to apply for inclusion.
excludeFilter
A bitwise combination of the DataGridViewElementStates values that represent the filter to apply for exclusion.
Gets the first column after the given column in display order that meets the given filter requirements.

Syntax

Visual Basic (Declaration)
Public Function GetNextColumn( _
   ByVal dataGridViewColumnStart As DataGridViewColumn, _
   ByVal includeFilter As DataGridViewElementStates, _
   ByVal excludeFilter As DataGridViewElementStates _
) As DataGridViewColumn
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewColumnCollection
Dim dataGridViewColumnStart As DataGridViewColumn
Dim includeFilter As DataGridViewElementStates
Dim excludeFilter As DataGridViewElementStates
Dim value As DataGridViewColumn

value = instance.GetNextColumn(dataGridViewColumnStart, includeFilter, excludeFilter)
C#
public DataGridViewColumn GetNextColumn(
   DataGridViewColumn dataGridViewColumnStart,
   DataGridViewElementStates includeFilter,
   DataGridViewElementStates excludeFilter
)
Managed Extensions for C++
public: DataGridViewColumn* GetNextColumn(
   DataGridViewColumn* dataGridViewColumnStart,
   DataGridViewElementStates includeFilter,
   DataGridViewElementStates excludeFilter
)
C++/CLI
public:
DataGridViewColumn^ GetNextColumn(
   DataGridViewColumn^ dataGridViewColumnStart,
   DataGridViewElementStates includeFilter,
   DataGridViewElementStates excludeFilter
)

Parameters

dataGridViewColumnStart
The column from which to start searching for the next column.
includeFilter
A bitwise combination of the DataGridViewElementStates values that represent the filter to apply for inclusion.
excludeFilter
A bitwise combination of the DataGridViewElementStates values that represent the filter to apply for exclusion.

Return Value

The next column that meets the given filter requirements, or null if no column is found.

Exceptions

Exception | Description
ArgumentException | At least one of the filter values is not a valid bitwise combination of DataGridViewElementStates values.
ArgumentNullException | dataGridViewColumnStart is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumnCollection Class
DataGridViewColumnCollection Members


GetPreviousColumn Method

[image]
Gizmox.WebGUI.Forms
GetPreviousColumn Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumnCollection Class : GetPreviousColumn Method

dataGridViewColumnStart
The column from which to start searching for the previous column.
includeFilter
A bitwise combination of the DataGridViewElementStates values that represent the filter to apply for inclusion.
excludeFilter
A bitwise combination of the DataGridViewElementStates values that represent the filter to apply for exclusion.
Gets the last column prior to the given column in display order that meets the given filter requirements.

Syntax

Visual Basic (Declaration)
Public Function GetPreviousColumn( _
   ByVal dataGridViewColumnStart As DataGridViewColumn, _
   ByVal includeFilter As DataGridViewElementStates, _
   ByVal excludeFilter As DataGridViewElementStates _
) As DataGridViewColumn
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewColumnCollection
Dim dataGridViewColumnStart As DataGridViewColumn
Dim includeFilter As DataGridViewElementStates
Dim excludeFilter As DataGridViewElementStates
Dim value As DataGridViewColumn

value = instance.GetPreviousColumn(dataGridViewColumnStart, includeFilter, excludeFilter)
C#
public DataGridViewColumn GetPreviousColumn(
   DataGridViewColumn dataGridViewColumnStart,
   DataGridViewElementStates includeFilter,
   DataGridViewElementStates excludeFilter
)
Managed Extensions for C++
public: DataGridViewColumn* GetPreviousColumn(
   DataGridViewColumn* dataGridViewColumnStart,
   DataGridViewElementStates includeFilter,
   DataGridViewElementStates excludeFilter
)
C++/CLI
public:
DataGridViewColumn^ GetPreviousColumn(
   DataGridViewColumn^ dataGridViewColumnStart,
   DataGridViewElementStates includeFilter,
   DataGridViewElementStates excludeFilter
)

Parameters

dataGridViewColumnStart
The column from which to start searching for the previous column.
includeFilter
A bitwise combination of the DataGridViewElementStates values that represent the filter to apply for inclusion.
excludeFilter
A bitwise combination of the DataGridViewElementStates values that represent the filter to apply for exclusion.

Return Value

The previous column that meets the given filter requirements, or null if no column is found.

Exceptions

Exception | Description
ArgumentException | At least one of the filter values is not a valid bitwise combination of DataGridViewElementStates values.
ArgumentNullException | dataGridViewColumnStart is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumnCollection Class
DataGridViewColumnCollection Members


IndexOf Method

[image]
Gizmox.WebGUI.Forms
IndexOf Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumnCollection Class : IndexOf Method

dataGridViewColumn
The DataGridViewColumn to return the index of.
Gets the index of the given DataGridViewColumn in the collection.

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal dataGridViewColumn As DataGridViewColumn _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewColumnCollection
Dim dataGridViewColumn As DataGridViewColumn
Dim value As Integer

value = instance.IndexOf(dataGridViewColumn)
C#
public int IndexOf(
   DataGridViewColumn dataGridViewColumn
)
Managed Extensions for C++
public: int IndexOf(
   DataGridViewColumn* dataGridViewColumn
)
C++/CLI
public:
int IndexOf(
   DataGridViewColumn^ dataGridViewColumn
)

Parameters

dataGridViewColumn
The DataGridViewColumn to return the index of.

Return Value

The index of the given DataGridViewColumn.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumnCollection Class
DataGridViewColumnCollection Members


Insert Method

[image]
Gizmox.WebGUI.Forms
Insert Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumnCollection Class : Insert Method

columnIndex
The zero-based index at which to insert the given column.
dataGridViewColumn
The DataGridViewColumn to insert.
Inserts a column at the given index in the collection.

Syntax

Visual Basic (Declaration)
Public Overridable Sub Insert( _
   ByVal columnIndex As Integer, _
   ByVal dataGridViewColumn As DataGridViewColumn _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewColumnCollection
Dim columnIndex As Integer
Dim dataGridViewColumn As DataGridViewColumn

instance.Insert(columnIndex, dataGridViewColumn)
C#
public virtual void Insert(
   int columnIndex,
   DataGridViewColumn dataGridViewColumn
)
Managed Extensions for C++
public: virtual void Insert(
   int columnIndex,
   DataGridViewColumn* dataGridViewColumn
)
C++/CLI
public:
virtual void Insert(
   int columnIndex,
   DataGridViewColumn^ dataGridViewColumn
)

Parameters

columnIndex
The zero-based index at which to insert the given column.
dataGridViewColumn
The DataGridViewColumn to insert.

Exceptions

Exception | Description
ArgumentNullException | dataGridViewColumn is null.
InvalidOperationException | The associated DataGridView control is performing one of the following actions that temporarily prevents new columns from being added:Selecting all cells in the control.Clearing the selection.Updating column DataGridViewColumn.DisplayIndex property values. -or-This method is being called from a handler for one of the following DataGridView events:RowValidated RowValidating-or-dataGridViewColumn already belongs to a DataGridView control.-or-The dataGridViewColumnDataGridViewColumn.SortMode property value is DataGridViewColumnSortMode.Automatic and the DataGridView.SelectionMode property value is DataGridViewSelectionMode.FullColumnSelect or DataGridViewSelectionMode.ColumnHeaderSelect. Use the control BeginInit and EndInit methods to temporarily set conflicting property values. -or-The dataGridViewColumnDataGridViewColumn.InheritedAutoSizeMode property value is DataGridViewAutoSizeColumnMode.ColumnHeader and the ColumnHeadersVisible property value is false.-or-dataGridViewColumn has an DataGridViewColumn.InheritedAutoSizeMode property value of DataGridViewAutoSizeColumnMode.Fill and a DataGridViewColumn.Frozen property value of true.-or-dataGridViewColumn has DataGridViewColumn.DisplayIndex and DataGridViewColumn.Frozen property values that would display it among a set of adjacent columns with the opposite DataGridViewColumn.Frozen property value.-or-The DataGridView control contains at least one row and dataGridViewColumn has a DataGridViewColumn.CellType property value of null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumnCollection Class
DataGridViewColumnCollection Members


OnCollectionChanged Method

[image]
Gizmox.WebGUI.Forms
OnCollectionChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumnCollection Class : OnCollectionChanged Method

e
A CollectionChangeEventArgs that contains the event data.
Raises the CollectionChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnCollectionChanged( _
   ByVal e As CollectionChangeEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewColumnCollection
Dim e As CollectionChangeEventArgs

instance.OnCollectionChanged(e)
C#
protected virtual void OnCollectionChanged(
   CollectionChangeEventArgs e
)
Managed Extensions for C++
protected: virtual void OnCollectionChanged(
   CollectionChangeEventArgs* e
)
C++/CLI
protected:
virtual void OnCollectionChanged(
   CollectionChangeEventArgs^ e
)

Parameters

e
A CollectionChangeEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumnCollection Class
DataGridViewColumnCollection Members


Remove Method

[image]
Gizmox.WebGUI.Forms
Remove Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumnCollection Class : Remove Method

Removes the column with the specified name from the collection.

Overload List

Overload | Description
Remove(String) | Removes the column with the specified name from the collection.
Remove(DataGridViewColumn) | Removes the specified column from the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumnCollection Class
DataGridViewColumnCollection Members


Remove(String) Method

[image]
Gizmox.WebGUI.Forms
Remove(String) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumnCollection Class > Remove Method : Remove(String) Method

columnName
The name of the column to delete.
Removes the column with the specified name from the collection.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub Remove( _
   ByVal columnName As String _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewColumnCollection
Dim columnName As String

instance.Remove(columnName)
C#
public virtual void Remove(
   string columnName
)
Managed Extensions for C++
public: virtual void Remove(
   string* columnName
)
C++/CLI
public:
virtual void Remove(
   String^ columnName
)

Parameters

columnName
The name of the column to delete.

Exceptions

Exception | Description
InvalidOperationException | The associated DataGridView control is performing one of the following actions that temporarily prevents new columns from being added:Selecting all cells in the control.Clearing the selection.Updating column DataGridViewColumn.DisplayIndex property values. -or-This method is being called from a handler for one of the following DataGridView events:RowValidated RowValidating
ArgumentException | columnName does not match the name of any column in the collection.
ArgumentNullException | columnName is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumnCollection Class
DataGridViewColumnCollection Members
Overload List


Remove(DataGridViewColumn) Method

[image]
Gizmox.WebGUI.Forms
Remove(DataGridViewColumn) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumnCollection Class > Remove Method : Remove(DataGridViewColumn) Method

dataGridViewColumn
The column to delete.
Removes the specified column from the collection.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub Remove( _
   ByVal dataGridViewColumn As DataGridViewColumn _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewColumnCollection
Dim dataGridViewColumn As DataGridViewColumn

instance.Remove(dataGridViewColumn)
C#
public virtual void Remove(
   DataGridViewColumn dataGridViewColumn
)
Managed Extensions for C++
public: virtual void Remove(
   DataGridViewColumn* dataGridViewColumn
)
C++/CLI
public:
virtual void Remove(
   DataGridViewColumn^ dataGridViewColumn
)

Parameters

dataGridViewColumn
The column to delete.

Exceptions

Exception | Description
InvalidOperationException | The associated DataGridView control is performing one of the following actions that temporarily prevents new columns from being added:Selecting all cells in the control.Clearing the selection.Updating column DataGridViewColumn.DisplayIndex property values. -or-This method is being called from a handler for one of the following DataGridView events:RowValidated RowValidating
ArgumentNullException | dataGridViewColumn is null.
ArgumentException | dataGridViewColumn is not in the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumnCollection Class
DataGridViewColumnCollection Members
Overload List


RemoveAt Method

[image]
Gizmox.WebGUI.Forms
RemoveAt Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumnCollection Class : RemoveAt Method

index
The index of the column to delete.
Removes the column at the given index in the collection.

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveAt( _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewColumnCollection
Dim index As Integer

instance.RemoveAt(index)
C#
public virtual void RemoveAt(
   int index
)
Managed Extensions for C++
public: virtual void RemoveAt(
   int index
)
C++/CLI
public:
virtual void RemoveAt(
   int index
)

Parameters

index
The index of the column to delete.

Exceptions

Exception | Description
InvalidOperationException | The associated DataGridView control is performing one of the following actions that temporarily prevents new columns from being added:Selecting all cells in the control.Clearing the selection.Updating column DataGridViewColumn.DisplayIndex property values. -or-This method is being called from a handler for one of the following DataGridView events:RowValidated RowValidating
ArgumentOutOfRangeException | index is less than zero or greater than the number of columns in the control minus one.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumnCollection Class
DataGridViewColumnCollection Members


DataGridViewColumnCollection Class Properties

[image]
Gizmox.WebGUI.Forms
DataGridViewColumnCollection Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewColumnCollection Class

For a list of all members of this type, see DataGridViewColumnCollection members.

Public Properties

 | Name | Description
Public Property | Count | Gets the total number of elements in the collection. (Inherited from BaseCollection)
Public Property | IsReadOnly | Gets a value indicating whether the collection is read-only. (Inherited from BaseCollection)
Public Property | IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized. (Inherited from BaseCollection)
Public Property | Item | Overloaded. Gets or sets the column of the given name in the collection.
Public Property | SyncRoot | Gets an object that can be used to synchronize access to the BaseCollection. (Inherited from BaseCollection)
Top

Protected Properties

 | Name | Description
Protected Property | DataGridView | Gets the DataGridView upon which the collection performs column-related operations.
Protected Property | List | Overridden.
Top

See Also

Reference

DataGridViewColumnCollection Class
Gizmox.WebGUI.Forms Namespace


DataGridView Property

[image]
Gizmox.WebGUI.Forms
DataGridView Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumnCollection Class : DataGridView Property

Gets the DataGridView upon which the collection performs column-related operations.

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property DataGridView As DataGridView
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewColumnCollection
Dim value As DataGridView

value = instance.DataGridView
C#
protected DataGridView DataGridView {get;}
Managed Extensions for C++
protected: __property DataGridView* get_DataGridView();
C++/CLI
protected:
property DataGridView^ DataGridView {
   DataGridView^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumnCollection Class
DataGridViewColumnCollection Members


Item Property

[image]
Gizmox.WebGUI.Forms
Item Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumnCollection Class : Item Property

Gets or sets the column of the given name in the collection.

Overload List

Overload | Description
Item(String) | Gets or sets the column of the given name in the collection.
Item(Int32) | Gets or sets the column at the given index in the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumnCollection Class
DataGridViewColumnCollection Members


Item(String) Property

[image]
Gizmox.WebGUI.Forms
Item(String) Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumnCollection Class > Item Property : Item(String) Property

columnName
The name of the column to get or set.
Gets or sets the column of the given name in the collection.

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal columnName As String _
) As DataGridViewColumn
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewColumnCollection
Dim columnName As String
Dim value As DataGridViewColumn

value = instance.Item(columnName)
C#
public DataGridViewColumn Item(
   string columnName
) {get;}
Managed Extensions for C++
public: __property DataGridViewColumn* get_Item(
   string* columnName
);
C++/CLI
public:
property DataGridViewColumn^ Item {
   DataGridViewColumn^ get(String^columnName);
}

Parameters

columnName
The name of the column to get or set.

Exceptions

Exception | Description
ArgumentNullException | columnName is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumnCollection Class
DataGridViewColumnCollection Members
Overload List


Item(Int32) Property

[image]
Gizmox.WebGUI.Forms
Item(Int32) Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumnCollection Class > Item Property : Item(Int32) Property

index
The zero-based index of the column to get or set.
Gets or sets the column at the given index in the collection.

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal index As Integer _
) As DataGridViewColumn
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewColumnCollection
Dim index As Integer
Dim value As DataGridViewColumn

value = instance.Item(index)
C#
public DataGridViewColumn Item(
   int index
) {get;}
Managed Extensions for C++
public: __property DataGridViewColumn* get_Item(
   int index
);
C++/CLI
public:
property DataGridViewColumn^ Item {
   DataGridViewColumn^ get(intindex);
}

Parameters

index
The zero-based index of the column to get or set.

Exceptions

Exception | Description
ArgumentOutOfRangeException | index is less than zero or greater than the number of columns in the collection minus one.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumnCollection Class
DataGridViewColumnCollection Members
Overload List


List Property

[image]
Gizmox.WebGUI.Forms
List Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumnCollection Class : List Property

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property List As ArrayList
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewColumnCollection
Dim value As ArrayList

value = instance.List
C#
protected override ArrayList List {get;}
Managed Extensions for C++
protected: __property ArrayList* get_List() override;
C++/CLI
protected:
property ArrayList^ List {
   ArrayList^ get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumnCollection Class
DataGridViewColumnCollection Members


DataGridViewColumnCollection Class Events

[image]
Gizmox.WebGUI.Forms
DataGridViewColumnCollection Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewColumnCollection Class

For a list of all members of this type, see DataGridViewColumnCollection members.

Public Events

 | Name | Description
Public Event | CollectionChanged | Occurs when the collection changes.
Top

See Also

Reference

DataGridViewColumnCollection Class
Gizmox.WebGUI.Forms Namespace


CollectionChanged Event

[image]
Gizmox.WebGUI.Forms
CollectionChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumnCollection Class : CollectionChanged Event

Occurs when the collection changes.

Syntax

Visual Basic (Declaration)
Public Event CollectionChanged() As CollectionChangeEventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewColumnCollection
Dim handler As CollectionChangeEventHandler

AddHandler instance.CollectionChanged, handler
C#
public event CollectionChangeEventHandler CollectionChanged()
Managed Extensions for C++
public: __event CollectionChangeEventHandler* CollectionChanged
C++/CLI
public:
event CollectionChangeEventHandler^ CollectionChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumnCollection Class
DataGridViewColumnCollection Members


DataGridViewColumnDesignTimeVisibleAttribute Class

[image]
Gizmox.WebGUI.Forms
DataGridViewColumnDesignTimeVisibleAttribute Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewColumnDesignTimeVisibleAttribute Class

Specifies whether a column type is visible in the DataGridView designer. This class cannot be inherited.

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AllowMultiple=False, Inherited=True)>
Public NotInheritable Class DataGridViewColumnDesignTimeVisibleAttribute
   Inherits Attribute
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewColumnDesignTimeVisibleAttribute
C#
[AttributeUsageAttribute(AllowMultiple=false, Inherited=true)]
public sealed class DataGridViewColumnDesignTimeVisibleAttribute : Attribute
Managed Extensions for C++
[AttributeUsageAttribute(AllowMultiple=false, Inherited=true)]
public __gc __sealed class DataGridViewColumnDesignTimeVisibleAttribute : public Attribute
C++/CLI
[AttributeUsageAttribute(AllowMultiple=false, Inherited=true)]
public ref class DataGridViewColumnDesignTimeVisibleAttribute sealed : public Attribute

Inheritance Hierarchy

System.Object
System.Attribute
Gizmox.WebGUI.Forms.DataGridViewColumnDesignTimeVisibleAttribute

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

DataGridViewColumnDesignTimeVisibleAttribute Members
Gizmox.WebGUI.Forms Namespace


DataGridViewColumnDesignTimeVisibleAttribute Class Members

[image]
Gizmox.WebGUI.Forms
DataGridViewColumnDesignTimeVisibleAttribute Class Members
See Also Fields Properties Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewColumnDesignTimeVisibleAttribute Class

The following tables list the members exposed by DataGridViewColumnDesignTimeVisibleAttribute.

Public Constructors

 | Name | Description
Public Constructor | DataGridViewColumnDesignTimeVisibleAttribute Constructor | Overloaded. Initializes a new instance of the DataGridViewColumnDesignTimeVisibleAttribute class using the default Visible property value of true.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Default | The default DataGridViewColumnDesignTimeVisibleAttribute value, which is Yes, indicating that the column is visible in the DataGridView designer.
static (Shared in Visual Basic) | No | A DataGridViewColumnDesignTimeVisibleAttribute value indicating that the column is not visible in the DataGridView designer.
static (Shared in Visual Basic) | Yes | A DataGridViewColumnDesignTimeVisibleAttribute value indicating that the column is visible in the DataGridView designer.
Top

Public Properties

 | Name | Description
Public Property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from System.Attribute)
Public Property | Visible | Gets a value indicating whether the column type is visible in the DataGridView designer.
Top

Public Methods

 | Name | Description
Public Method | Equals | Overridden. Gets a value indicating whether this object is equivalent to the specified object.
Public Method | GetHashCode | Overridden.
Public Method | IsDefaultAttribute | Overridden. Gets a value indicating whether this attribute instance is equal to the Default attribute value.
Public Method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from System.Attribute)
Top

See Also

Reference

DataGridViewColumnDesignTimeVisibleAttribute Class
Gizmox.WebGUI.Forms Namespace


DataGridViewColumnDesignTimeVisibleAttribute Constructor

[image]
Gizmox.WebGUI.Forms
DataGridViewColumnDesignTimeVisibleAttribute Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumnDesignTimeVisibleAttribute Class : DataGridViewColumnDesignTimeVisibleAttribute Constructor

Initializes a new instance of the DataGridViewColumnDesignTimeVisibleAttribute class using the default Visible property value of true.

Overload List

Overload | Description
DataGridViewColumnDesignTimeVisibleAttribute Constructor() | Initializes a new instance of the DataGridViewColumnDesignTimeVisibleAttribute class using the default Visible property value of true.
DataGridViewColumnDesignTimeVisibleAttribute Constructor(Boolean) | Initializes a new instance of the DataGridViewColumnDesignTimeVisibleAttribute class using the specified value to initialize the Visible property.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumnDesignTimeVisibleAttribute Class
DataGridViewColumnDesignTimeVisibleAttribute Members


DataGridViewColumnDesignTimeVisibleAttribute Constructor()

[image]
Gizmox.WebGUI.Forms
DataGridViewColumnDesignTimeVisibleAttribute Constructor()
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumnDesignTimeVisibleAttribute Class > DataGridViewColumnDesignTimeVisibleAttribute Constructor : DataGridViewColumnDesignTimeVisibleAttribute Constructor()

Initializes a new instance of the DataGridViewColumnDesignTimeVisibleAttribute class using the default Visible property value of true.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewColumnDesignTimeVisibleAttribute()
C#
public DataGridViewColumnDesignTimeVisibleAttribute()
Managed Extensions for C++
public: DataGridViewColumnDesignTimeVisibleAttribute();
C++/CLI
public:
DataGridViewColumnDesignTimeVisibleAttribute();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumnDesignTimeVisibleAttribute Class
DataGridViewColumnDesignTimeVisibleAttribute Members
Overload List


DataGridViewColumnDesignTimeVisibleAttribute Constructor(Boolean)

[image]
Gizmox.WebGUI.Forms
DataGridViewColumnDesignTimeVisibleAttribute Constructor(Boolean)
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumnDesignTimeVisibleAttribute Class > DataGridViewColumnDesignTimeVisibleAttribute Constructor : DataGridViewColumnDesignTimeVisibleAttribute Constructor(Boolean)

visible
The value of the Visible property.
Initializes a new instance of the DataGridViewColumnDesignTimeVisibleAttribute class using the specified value to initialize the Visible property.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal visible As Boolean _
)
Visual Basic (Usage) Copy Code
Dim visible As Boolean

Dim instance As DataGridViewColumnDesignTimeVisibleAttribute(visible)
C#
public DataGridViewColumnDesignTimeVisibleAttribute(
   bool visible
)
Managed Extensions for C++
public: DataGridViewColumnDesignTimeVisibleAttribute(
   bool visible
)
C++/CLI
public:
DataGridViewColumnDesignTimeVisibleAttribute(
   bool visible
)

Parameters

visible
The value of the Visible property.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumnDesignTimeVisibleAttribute Class
DataGridViewColumnDesignTimeVisibleAttribute Members
Overload List


DataGridViewColumnDesignTimeVisibleAttribute Class Methods

[image]
Gizmox.WebGUI.Forms
DataGridViewColumnDesignTimeVisibleAttribute Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewColumnDesignTimeVisibleAttribute Class

For a list of all members of this type, see DataGridViewColumnDesignTimeVisibleAttribute members.

Public Methods

 | Name | Description
Public Method | Equals | Overridden. Gets a value indicating whether this object is equivalent to the specified object.
Public Method | GetHashCode | Overridden.
Public Method | IsDefaultAttribute | Overridden. Gets a value indicating whether this attribute instance is equal to the Default attribute value.
Public Method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from System.Attribute)
Top

See Also

Reference

DataGridViewColumnDesignTimeVisibleAttribute Class
Gizmox.WebGUI.Forms Namespace


Equals Method

[image]
Gizmox.WebGUI.Forms
Equals Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumnDesignTimeVisibleAttribute Class : Equals Method

obj
The Object to compare with the current Object.
Gets a value indicating whether this object is equivalent to the specified object.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function Equals( _
   ByVal obj As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewColumnDesignTimeVisibleAttribute
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
C#
public override bool Equals(
   object obj
)
Managed Extensions for C++
public: bool Equals(
   Object* obj
) override
C++/CLI
public:
bool Equals(
   Object^ obj
) override

Parameters

obj
The Object to compare with the current Object.

Return Value

true to indicate that the specified object is a DataGridViewColumnDesignTimeVisibleAttribute instance with the same Visible property value as this instance; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumnDesignTimeVisibleAttribute Class
DataGridViewColumnDesignTimeVisibleAttribute Members


GetHashCode Method

[image]
Gizmox.WebGUI.Forms
GetHashCode Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumnDesignTimeVisibleAttribute Class : GetHashCode Method

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewColumnDesignTimeVisibleAttribute
Dim value As Integer

value = instance.GetHashCode()
C#
public override int GetHashCode()
Managed Extensions for C++
public: int GetHashCode(); override
C++/CLI
public:
int GetHashCode(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumnDesignTimeVisibleAttribute Class
DataGridViewColumnDesignTimeVisibleAttribute Members


IsDefaultAttribute Method

[image]
Gizmox.WebGUI.Forms
IsDefaultAttribute Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumnDesignTimeVisibleAttribute Class : IsDefaultAttribute Method

Gets a value indicating whether this attribute instance is equal to the Default attribute value.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function IsDefaultAttribute() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewColumnDesignTimeVisibleAttribute
Dim value As Boolean

value = instance.IsDefaultAttribute()
C#
public override bool IsDefaultAttribute()
Managed Extensions for C++
public: bool IsDefaultAttribute(); override
C++/CLI
public:
bool IsDefaultAttribute(); override

Return Value

true to indicate that this instance is equal to the Default instance; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumnDesignTimeVisibleAttribute Class
DataGridViewColumnDesignTimeVisibleAttribute Members


DataGridViewColumnDesignTimeVisibleAttribute Class Properties

[image]
Gizmox.WebGUI.Forms
DataGridViewColumnDesignTimeVisibleAttribute Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewColumnDesignTimeVisibleAttribute Class

For a list of all members of this type, see DataGridViewColumnDesignTimeVisibleAttribute members.

Public Properties

 | Name | Description
Public Property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from System.Attribute)
Public Property | Visible | Gets a value indicating whether the column type is visible in the DataGridView designer.
Top

See Also

Reference

DataGridViewColumnDesignTimeVisibleAttribute Class
Gizmox.WebGUI.Forms Namespace


Visible Property

[image]
Gizmox.WebGUI.Forms
Visible Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumnDesignTimeVisibleAttribute Class : Visible Property

Gets a value indicating whether the column type is visible in the DataGridView designer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewColumnDesignTimeVisibleAttribute
Dim value As Boolean

value = instance.Visible
C#
public bool Visible {get;}
Managed Extensions for C++
public: __property bool get_Visible();
C++/CLI
public:
property bool Visible {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumnDesignTimeVisibleAttribute Class
DataGridViewColumnDesignTimeVisibleAttribute Members


DataGridViewColumnDesignTimeVisibleAttribute Class Fields

[image]
Gizmox.WebGUI.Forms
DataGridViewColumnDesignTimeVisibleAttribute Class Fields
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewColumnDesignTimeVisibleAttribute Class

For a list of all members of this type, see DataGridViewColumnDesignTimeVisibleAttribute members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Default | The default DataGridViewColumnDesignTimeVisibleAttribute value, which is Yes, indicating that the column is visible in the DataGridView designer.
static (Shared in Visual Basic) | No | A DataGridViewColumnDesignTimeVisibleAttribute value indicating that the column is not visible in the DataGridView designer.
static (Shared in Visual Basic) | Yes | A DataGridViewColumnDesignTimeVisibleAttribute value indicating that the column is visible in the DataGridView designer.
Top

See Also

Reference

DataGridViewColumnDesignTimeVisibleAttribute Class
Gizmox.WebGUI.Forms Namespace


Default Field

[image]
Gizmox.WebGUI.Forms
Default Field
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumnDesignTimeVisibleAttribute Class : Default Field

The default DataGridViewColumnDesignTimeVisibleAttribute value, which is Yes, indicating that the column is visible in the DataGridView designer.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Default As DataGridViewColumnDesignTimeVisibleAttribute
Visual Basic (Usage) Copy Code
Dim value As DataGridViewColumnDesignTimeVisibleAttribute

value = DataGridViewColumnDesignTimeVisibleAttribute.Default
C#
public static readonly DataGridViewColumnDesignTimeVisibleAttribute Default
Managed Extensions for C++
public: static readonly DataGridViewColumnDesignTimeVisibleAttribute* Default
C++/CLI
public:
static readonly DataGridViewColumnDesignTimeVisibleAttribute^ Default

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumnDesignTimeVisibleAttribute Class
DataGridViewColumnDesignTimeVisibleAttribute Members


No Field

[image]
Gizmox.WebGUI.Forms
No Field
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumnDesignTimeVisibleAttribute Class : No Field

A DataGridViewColumnDesignTimeVisibleAttribute value indicating that the column is not visible in the DataGridView designer.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly No As DataGridViewColumnDesignTimeVisibleAttribute
Visual Basic (Usage) Copy Code
Dim value As DataGridViewColumnDesignTimeVisibleAttribute

value = DataGridViewColumnDesignTimeVisibleAttribute.No
C#
public static readonly DataGridViewColumnDesignTimeVisibleAttribute No
Managed Extensions for C++
public: static readonly DataGridViewColumnDesignTimeVisibleAttribute* No
C++/CLI
public:
static readonly DataGridViewColumnDesignTimeVisibleAttribute^ No

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumnDesignTimeVisibleAttribute Class
DataGridViewColumnDesignTimeVisibleAttribute Members


Yes Field

[image]
Gizmox.WebGUI.Forms
Yes Field
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumnDesignTimeVisibleAttribute Class : Yes Field

A DataGridViewColumnDesignTimeVisibleAttribute value indicating that the column is visible in the DataGridView designer.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Yes As DataGridViewColumnDesignTimeVisibleAttribute
Visual Basic (Usage) Copy Code
Dim value As DataGridViewColumnDesignTimeVisibleAttribute

value = DataGridViewColumnDesignTimeVisibleAttribute.Yes
C#
public static readonly DataGridViewColumnDesignTimeVisibleAttribute Yes
Managed Extensions for C++
public: static readonly DataGridViewColumnDesignTimeVisibleAttribute* Yes
C++/CLI
public:
static readonly DataGridViewColumnDesignTimeVisibleAttribute^ Yes

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumnDesignTimeVisibleAttribute Class
DataGridViewColumnDesignTimeVisibleAttribute Members


DataGridViewColumnDividerDoubleClickEventArgs Class

[image]
Gizmox.WebGUI.Forms
DataGridViewColumnDividerDoubleClickEventArgs Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewColumnDividerDoubleClickEventArgs Class

Provides data for the ColumnDividerDoubleClick event of a DataGridView.

Syntax

Visual Basic (Declaration)
Public Class DataGridViewColumnDividerDoubleClickEventArgs
   Inherits HandledMouseEventArgs
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewColumnDividerDoubleClickEventArgs
C#
public class DataGridViewColumnDividerDoubleClickEventArgs : HandledMouseEventArgs
Managed Extensions for C++
public __gc class DataGridViewColumnDividerDoubleClickEventArgs : public HandledMouseEventArgs
C++/CLI
public ref class DataGridViewColumnDividerDoubleClickEventArgs : public HandledMouseEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gizmox.WebGUI.Forms.MouseEventArgs
Gizmox.WebGUI.Forms.HandledMouseEventArgs
Gizmox.WebGUI.Forms.DataGridViewColumnDividerDoubleClickEventArgs

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

DataGridViewColumnDividerDoubleClickEventArgs Members
Gizmox.WebGUI.Forms Namespace


DataGridViewColumnDividerDoubleClickEventArgs Class Members

[image]
Gizmox.WebGUI.Forms
DataGridViewColumnDividerDoubleClickEventArgs Class Members
See Also Properties Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewColumnDividerDoubleClickEventArgs Class

The following tables list the members exposed by DataGridViewColumnDividerDoubleClickEventArgs.

Public Constructors

 | Name | Description
Public Constructor | DataGridViewColumnDividerDoubleClickEventArgs Constructor | Initializes a new instance of the DataGridViewColumnDividerDoubleClickEventArgs class.
Top

Public Properties

 | Name | Description
Public Property | Button | (Inherited from MouseEventArgs)
Public Property | Clicks | (Inherited from MouseEventArgs)
Public Property | ColumnIndex | The index of the column next to the column divider that was double-clicked.
Public Property | Delta | (Inherited from MouseEventArgs)
Public Property | Handled | Gets or sets whether this event should be forwarded to the control's parent container. (Inherited from HandledMouseEventArgs)
Public Property | X | (Inherited from MouseEventArgs)
Public Property | Y | (Inherited from MouseEventArgs)
Top

See Also

Reference

DataGridViewColumnDividerDoubleClickEventArgs Class
Gizmox.WebGUI.Forms Namespace


DataGridViewColumnDividerDoubleClickEventArgs Constructor

[image]
Gizmox.WebGUI.Forms
DataGridViewColumnDividerDoubleClickEventArgs Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumnDividerDoubleClickEventArgs Class : DataGridViewColumnDividerDoubleClickEventArgs Constructor

columnIndex
The index of the column next to the column divider that was double-clicked.
e
A new HandledMouseEventArgs containing the inherited event data.
Initializes a new instance of the DataGridViewColumnDividerDoubleClickEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal columnIndex As Integer, _
   ByVal e As HandledMouseEventArgs _
)
Visual Basic (Usage) Copy Code
Dim columnIndex As Integer
Dim e As HandledMouseEventArgs

Dim instance As DataGridViewColumnDividerDoubleClickEventArgs(columnIndex, e)
C#
public DataGridViewColumnDividerDoubleClickEventArgs(
   int columnIndex,
   HandledMouseEventArgs e
)
Managed Extensions for C++
public: DataGridViewColumnDividerDoubleClickEventArgs(
   int columnIndex,
   HandledMouseEventArgs* e
)
C++/CLI
public:
DataGridViewColumnDividerDoubleClickEventArgs(
   int columnIndex,
   HandledMouseEventArgs^ e
)

Parameters

columnIndex
The index of the column next to the column divider that was double-clicked.
e
A new HandledMouseEventArgs containing the inherited event data.

Exceptions

Exception | Description
ArgumentOutOfRangeException | columnIndex is less than -1.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumnDividerDoubleClickEventArgs Class
DataGridViewColumnDividerDoubleClickEventArgs Members


DataGridViewColumnDividerDoubleClickEventArgs Class Properties

[image]
Gizmox.WebGUI.Forms
DataGridViewColumnDividerDoubleClickEventArgs Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewColumnDividerDoubleClickEventArgs Class

For a list of all members of this type, see DataGridViewColumnDividerDoubleClickEventArgs members.

Public Properties

 | Name | Description
Public Property | Button | (Inherited from MouseEventArgs)
Public Property | Clicks | (Inherited from MouseEventArgs)
Public Property | ColumnIndex | The index of the column next to the column divider that was double-clicked.
Public Property | Delta | (Inherited from MouseEventArgs)
Public Property | Handled | Gets or sets whether this event should be forwarded to the control's parent container. (Inherited from HandledMouseEventArgs)
Public Property | X | (Inherited from MouseEventArgs)
Public Property | Y | (Inherited from MouseEventArgs)
Top

See Also

Reference

DataGridViewColumnDividerDoubleClickEventArgs Class
Gizmox.WebGUI.Forms Namespace


ColumnIndex Property

[image]
Gizmox.WebGUI.Forms
ColumnIndex Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumnDividerDoubleClickEventArgs Class : ColumnIndex Property

The index of the column next to the column divider that was double-clicked.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ColumnIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewColumnDividerDoubleClickEventArgs
Dim value As Integer

value = instance.ColumnIndex
C#
public int ColumnIndex {get;}
Managed Extensions for C++
public: __property int get_ColumnIndex();
C++/CLI
public:
property int ColumnIndex {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumnDividerDoubleClickEventArgs Class
DataGridViewColumnDividerDoubleClickEventArgs Members


DataGridViewColumnEventArgs Class

[image]
Gizmox.WebGUI.Forms
DataGridViewColumnEventArgs Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewColumnEventArgs Class

Provides data for column-related events of a DataGridView.

Object Model

Syntax

Visual Basic (Declaration)
Public Class DataGridViewColumnEventArgs
   Inherits EventArgs
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewColumnEventArgs
C#
public class DataGridViewColumnEventArgs : EventArgs
Managed Extensions for C++
public __gc class DataGridViewColumnEventArgs : public EventArgs
C++/CLI
public ref class DataGridViewColumnEventArgs : public EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gizmox.WebGUI.Forms.DataGridViewColumnEventArgs

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

DataGridViewColumnEventArgs Members
Gizmox.WebGUI.Forms Namespace


DataGridViewColumnEventArgs Class Members

[image]
Gizmox.WebGUI.Forms
DataGridViewColumnEventArgs Class Members
See Also Properties Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewColumnEventArgs Class

The following tables list the members exposed by DataGridViewColumnEventArgs.

Public Constructors

 | Name | Description
Public Constructor | DataGridViewColumnEventArgs Constructor | Initializes a new instance of the DataGridViewColumnEventArgs class.
Top

Public Properties

 | Name | Description
Public Property | Column | Gets the column that the event occurs for.
Top

See Also

Reference

DataGridViewColumnEventArgs Class
Gizmox.WebGUI.Forms Namespace


DataGridViewColumnEventArgs Constructor

[image]
Gizmox.WebGUI.Forms
DataGridViewColumnEventArgs Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumnEventArgs Class : DataGridViewColumnEventArgs Constructor

dataGridViewColumn
The column that the event occurs for.
Initializes a new instance of the DataGridViewColumnEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal dataGridViewColumn As DataGridViewColumn _
)
Visual Basic (Usage) Copy Code
Dim dataGridViewColumn As DataGridViewColumn

Dim instance As DataGridViewColumnEventArgs(dataGridViewColumn)
C#
public DataGridViewColumnEventArgs(
   DataGridViewColumn dataGridViewColumn
)
Managed Extensions for C++
public: DataGridViewColumnEventArgs(
   DataGridViewColumn* dataGridViewColumn
)
C++/CLI
public:
DataGridViewColumnEventArgs(
   DataGridViewColumn^ dataGridViewColumn
)

Parameters

dataGridViewColumn
The column that the event occurs for.

Exceptions

Exception | Description
ArgumentNullException | dataGridViewColumn is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumnEventArgs Class
DataGridViewColumnEventArgs Members


DataGridViewColumnEventArgs Class Properties

[image]
Gizmox.WebGUI.Forms
DataGridViewColumnEventArgs Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewColumnEventArgs Class

For a list of all members of this type, see DataGridViewColumnEventArgs members.

Public Properties

 | Name | Description
Public Property | Column | Gets the column that the event occurs for.
Top

See Also

Reference

DataGridViewColumnEventArgs Class
Gizmox.WebGUI.Forms Namespace


Column Property

[image]
Gizmox.WebGUI.Forms
Column Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumnEventArgs Class : Column Property

Gets the column that the event occurs for.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Column As DataGridViewColumn
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewColumnEventArgs
Dim value As DataGridViewColumn

value = instance.Column
C#
public DataGridViewColumn Column {get;}
Managed Extensions for C++
public: __property DataGridViewColumn* get_Column();
C++/CLI
public:
property DataGridViewColumn^ Column {
   DataGridViewColumn^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumnEventArgs Class
DataGridViewColumnEventArgs Members


DataGridViewColumnHeaderCell Class

[image]
Gizmox.WebGUI.Forms
DataGridViewColumnHeaderCell Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewColumnHeaderCell Class

Represents a column header in a DataGridView control.

Object Model

Syntax

Visual Basic (Declaration)
Public Class DataGridViewColumnHeaderCell
   Inherits DataGridViewHeaderCell
   Implements IRenderableComponentMember
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewColumnHeaderCell
C#
public class DataGridViewColumnHeaderCell : DataGridViewHeaderCell, IRenderableComponentMember
Managed Extensions for C++
public __gc class DataGridViewColumnHeaderCell : public DataGridViewHeaderCell, IRenderableComponentMember
C++/CLI
public ref class DataGridViewColumnHeaderCell : public DataGridViewHeaderCell, IRenderableComponentMember

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.DataGridViewElement
Gizmox.WebGUI.Forms.DataGridViewCell
Gizmox.WebGUI.Forms.DataGridViewHeaderCell
Gizmox.WebGUI.Forms.DataGridViewColumnHeaderCell
Gizmox.WebGUI.Forms.DataGridViewTopLeftHeaderCell

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

DataGridViewColumnHeaderCell Members
Gizmox.WebGUI.Forms Namespace


DataGridViewColumnHeaderCell Class Members

[image]
Gizmox.WebGUI.Forms
DataGridViewColumnHeaderCell Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewColumnHeaderCell Class

The following tables list the members exposed by DataGridViewColumnHeaderCell.

Public Constructors

 | Name | Description
Public Constructor | DataGridViewColumnHeaderCell Constructor | Initializes a new instance of the DataGridViewColumnHeaderCell class.
Top

Public Properties

 | Name | Description
Public Property | ColumnIndex | Gets the column index for this cell. (Inherited from DataGridViewCell)
Public Property | ContentBounds | (Inherited from DataGridViewCell)
Public Property | DataGridView | Gets the DataGridView control associated with this element. (Inherited from DataGridViewElement)
Public Property | DefaultNewRowValue | Gets the default value for a cell in the row for new records. (Inherited from DataGridViewCell)
Public Property | Displayed | (Inherited from DataGridViewHeaderCell)
Public Property | EditedFormattedValue | Gets the current, formatted value of the cell, regardless of whether the cell is in edit mode and the value has not been committed. (Inherited from DataGridViewCell)
Public Property | EditType | Gets the type of the cell's hosted editing control. (Inherited from DataGridViewCell)
Public Property | ErrorIconBounds | (Inherited from DataGridViewCell)
Public Property | ErrorText | Gets or sets the text describing an error condition associated with the cell. (Inherited from DataGridViewCell)
Public Property | FormattedValue | Gets the value of the cell as formatted for display. (Inherited from DataGridViewCell)
Public Property | FormattedValueType | Gets the type of the formatted value of the cell. (Inherited from DataGridViewHeaderCell)
Public Property | Frozen | Gets a value indicating whether the cell is frozen. (Inherited from DataGridViewHeaderCell)
Public Property | HasStyle | Gets a value indicating whether the DataGridViewCell.Style property has been set. (Inherited from DataGridViewCell)
Public Property | InheritedState | Gets the current state of the cell as inherited from the state of its row and column. (Inherited from DataGridViewCell)
Public Property | InheritedStyle | Gets the style currently applied to the cell. (Inherited from DataGridViewCell)
Public Property | IsInEditMode | Gets a value indicating whether this cell is currently being edited. (Inherited from DataGridViewCell)
Public Property | OwningColumn | Gets the column that contains this cell. (Inherited from DataGridViewCell)
Public Property | OwningRow | Gets the row that contains this cell. (Inherited from DataGridViewCell)
Public Property | PreferredSize | Gets the size, in pixels, of a rectangular area into which the cell can fit. (Inherited from DataGridViewCell)
Public Property | ReadOnly | Gets a value indicating whether the header cell is read-only. (Inherited from DataGridViewHeaderCell)
Public Property | Resizable | Gets a value indicating whether the cell is resizable. (Inherited from DataGridViewHeaderCell)
Public Property | RowIndex | Gets the index of the cell's parent row. (Inherited from DataGridViewCell)
Public Property | Selected | Gets or sets a value indicating whether the cell is selected. (Inherited from DataGridViewHeaderCell)
Public Property | Size | Gets the size of the cell. (Inherited from DataGridViewCell)
Public Property | SortGlyphDirection | Gets or sets a value indicating which sort glyph is displayed.
Public Property | State | Gets the user interface (UI) state of the element. (Inherited from DataGridViewElement)
Public Property | Style | Gets or sets the style for the cell. (Inherited from DataGridViewCell)
Public Property | Tag | Gets or sets the object that contains supplemental data about the cell. (Inherited from DataGridViewCell)
Public Property | ToolTipText | Gets or sets the ToolTip text associated with this cell. (Inherited from DataGridViewCell)
Public Property | Value | Gets or sets the value associated with this cell. (Inherited from DataGridViewCell)
Public Property | ValueType | Gets the type of the value stored in the cell. (Inherited from DataGridViewHeaderCell)
Public Property | Visible | Gets a value indicating whether or not the cell is visible. (Inherited from DataGridViewHeaderCell)
Top

Protected Properties

 | Name | Description
Protected Property | ButtonState | Gets the buttonlike visual state of the header cell. (Inherited from DataGridViewHeaderCell)
Protected Property | MemberID | (Inherited from DataGridViewCell)
Protected Property | TagName | (Inherited from DataGridViewElement)
Top

Public Methods

 | Name | Description
Public Method | AdjustCellBorderStyle | Modifies the input cell border style according to the specified criteria. (Inherited from DataGridViewCell)
Public Method | Clone | Overridden.
Public Method | DetachEditingControl | Removes the cell's editing control from the DataGridView. (Inherited from DataGridViewCell)
Public Method | Dispose | Overloaded. Releases all resources used by the DataGridViewCell. (Inherited from DataGridViewCell)
Public Method | GetContentBounds | Overloaded. (Inherited from DataGridViewCell)
Public Method | GetEditedFormattedValue | Returns the current, formatted value of the cell, regardless of whether the cell is in edit mode and the value has not been committed. (Inherited from DataGridViewCell)
Public Method | GetInheritedState | Returns a value indicating the current state of the cell as inherited from the state of its row or column. (Inherited from DataGridViewHeaderCell)
Public Method | GetInheritedStyle | Overridden. Gets the style applied to the cell.
Public Method | InitializeEditingControl | Initializes the control used to edit the cell. (Inherited from DataGridViewCell)
Public Method | KeyEntersEditMode | Determines if edit mode should be started based on the given key. (Inherited from DataGridViewCell)
Public Method | ParseFormattedValue | (Inherited from DataGridViewCell)
Public Method | PositionEditingControl | Sets the location and size of the editing control hosted by a cell in the DataGridView control. (Inherited from DataGridViewCell)
Public Method | PositionEditingPanel | (Inherited from DataGridViewCell)
Public Method | ToString | Overridden.
Public Method | Update | Overloaded. Full updates of this instance. (Inherited from DataGridViewElement)
Top

Protected Methods

 | Name | Description
Protected Method | BorderWidths | (Inherited from DataGridViewCell)
Protected Method | ClickUnsharesRow | Indicates whether the cell's row will be unshared when the cell is clicked. (Inherited from DataGridViewCell)
Protected Method | ContentClickUnsharesRow | Indicates whether the cell's row will be unshared when the cell's content is clicked. (Inherited from DataGridViewCell)
Protected Method | ContentDoubleClickUnsharesRow | Indicates whether the cell's row will be unshared when the cell's content is double-clicked. (Inherited from DataGridViewCell)
Protected Method | DoubleClickUnsharesRow | Indicates whether the cell's row will be unshared when the cell is double-clicked. (Inherited from DataGridViewCell)
Protected Method | EnterUnsharesRow | Indicates whether the parent row will be unshared when the focus moves to the cell. (Inherited from DataGridViewCell)
Protected Method | GetClipboardContent | Overridden. Retrieves the formatted value of the cell to copy to the Clipboard.
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from DataGridViewElement)
Protected Method | GetDefaultHorizontalAlignment | Gets the horizontal alignment. (Inherited from DataGridViewCell)
Protected Method | GetDefaultVerticalAlignment | Gets the vertical alignment. (Inherited from DataGridViewCell)
Protected Method | GetErrorIconBounds | (Inherited from DataGridViewCell)
Protected Method | GetErrorText | Returns a string that represents the error for the cell. (Inherited from DataGridViewCell)
Protected Method | GetFormattedValue | Gets the value of the cell as formatted for display. (Inherited from DataGridViewCell)
Protected Method | GetPreferredSize | Overloaded. Calculates the preferred size, in pixels, of the cell. (Inherited from DataGridViewCell)
Protected Method | GetSize | Gets the size of the cell. (Inherited from DataGridViewHeaderCell)
Protected Method | GetValue | Overridden. Gets the value of the cell.
Protected Method | IsDirty | Determines whether the specified component is dirty. (Inherited from DataGridViewElement)
Protected Method | IsDirtyAttributes | Overloaded. Determines whether the specified component is dirty. (Inherited from DataGridViewElement)
Protected Method | KeyDownUnsharesRow | Indicates whether the parent row is unshared if the user presses a key while the focus is on the cell. (Inherited from DataGridViewCell)
Protected Method | KeyPressUnsharesRow | Indicates whether a row will be unshared if a key is pressed while a cell in the row has focus. (Inherited from DataGridViewCell)
Protected Method | KeyUpUnsharesRow | Indicates whether the parent row is unshared when the user releases a key while the focus is on the cell. (Inherited from DataGridViewCell)
Protected Method | LeaveUnsharesRow | Indicates whether a row will be unshared when the focus leaves a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseClickUnsharesRow | Indicates whether a row will be unshared if the user clicks a mouse button while the pointer is on a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseDoubleClickUnsharesRow | Indicates whether a row will be unshared if the user double-clicks a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseDownUnsharesRow | Indicates whether a row will be unshared when the user holds down a mouse button while the pointer is on a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseEnterUnsharesRow | Indicates whether a row will be unshared when the mouse pointer moves over a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseLeaveUnsharesRow | Indicates whether a row will be unshared when the mouse pointer leaves the row. (Inherited from DataGridViewCell)
Protected Method | MouseMoveUnsharesRow | Indicates whether a row will be unshared when the mouse pointer moves over a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseUpUnsharesRow | Indicates whether a row will be unshared when the user releases a mouse button while the pointer is on a cell in the row. (Inherited from DataGridViewCell)
Protected Method | OnClick | Called when the cell is clicked. (Inherited from DataGridViewCell)
Protected Method | OnContentClick | Called when the cell's contents are clicked. (Inherited from DataGridViewCell)
Protected Method | OnContentDoubleClick | Called when the cell's contents are double-clicked. (Inherited from DataGridViewCell)
Protected Method | OnDataGridViewChanged | Called when the DataGridViewElement.DataGridView property of the cell changes. (Inherited from DataGridViewCell)
Protected Method | OnDoubleClick | Called when the cell is double-clicked. (Inherited from DataGridViewCell)
Protected Method | OnEnter | Called when the focus moves to a cell. (Inherited from DataGridViewCell)
Protected Method | OnKeyDown | Called when a character key is pressed while the focus is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnKeyPress | Called when a key is pressed while the focus is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnKeyUp | Called when a character key is released while the focus is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnLeave | Called when the focus moves from a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseClick | Called when the user clicks a mouse button while the pointer is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseDoubleClick | Called when the user double-clicks a mouse button while the pointer is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseDown | Called when the user holds down a mouse button while the pointer is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseEnter | Called when the mouse pointer moves over a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseLeave | Called when the mouse pointer leaves the cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseMove | Called when the mouse pointer moves within a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseUp | Called when the user releases a mouse button while the pointer is on a cell. (Inherited from DataGridViewCell)
Protected Method | Paint | (Inherited from DataGridViewCell)
Protected Method | PaintErrorIcon | (Inherited from DataGridViewCell)
Protected Method | ProcessGatewayRequest | (Inherited from DataGridViewCell)
Protected Method | RaiseCellClick | Raises the DataGridView.CellClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellContentClick | Raises the DataGridView.CellContentClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellContentDoubleClick | Raises the DataGridView.CellContentDoubleClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellValueChanged | Raises the CellValueChanged event. (Inherited from DataGridViewElement)
Protected Method | RaiseDataError | Raises the DataError event. (Inherited from DataGridViewElement)
Protected Method | RaiseMouseWheel | Raises the MouseWheel event. (Inherited from DataGridViewElement)
Protected Method | RenderAttributes | Renders a header- cell's attributes (Inherited from DataGridViewHeaderCell)
Protected Method | RenderBackColorAttribute | Renders the back-color attribute. (Inherited from DataGridViewHeaderCell)
Protected Method | RenderComponent | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from DataGridViewElement)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from DataGridViewElement)
Protected Method | RenderComponents | Renders the controls sub tree (Inherited from DataGridViewElement)
Protected Method | RenderForeColorAttribute | Renders the fore color attribute. (Inherited from DataGridViewHeaderCell)
Protected Method | RenderReadOnlyAttribute | Renders the read only attribute. (Inherited from DataGridViewHeaderCell)
Protected Method | RenderUpdatedAttributes | Renders the updated attributes (Inherited from DataGridViewElement)
Protected Method | RenderWrapModeAttribute | Renders the wrap mode attribute. (Inherited from DataGridViewHeaderCell)
Protected Method | SetValue | Overridden. Sets the value of the cell.
Protected Method | UpdateParams | Overloaded. Updates only the parameters of this instance. (Inherited from DataGridViewElement)
Top

See Also

Reference

DataGridViewColumnHeaderCell Class
Gizmox.WebGUI.Forms Namespace


DataGridViewColumnHeaderCell Constructor

[image]
Gizmox.WebGUI.Forms
DataGridViewColumnHeaderCell Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumnHeaderCell Class : DataGridViewColumnHeaderCell Constructor

Initializes a new instance of the DataGridViewColumnHeaderCell class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewColumnHeaderCell()
C#
public DataGridViewColumnHeaderCell()
Managed Extensions for C++
public: DataGridViewColumnHeaderCell();
C++/CLI
public:
DataGridViewColumnHeaderCell();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumnHeaderCell Class
DataGridViewColumnHeaderCell Members


DataGridViewColumnHeaderCell Class Methods

[image]
Gizmox.WebGUI.Forms
DataGridViewColumnHeaderCell Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewColumnHeaderCell Class

For a list of all members of this type, see DataGridViewColumnHeaderCell members.

Public Methods

 | Name | Description
Public Method | AdjustCellBorderStyle | Modifies the input cell border style according to the specified criteria. (Inherited from DataGridViewCell)
Public Method | Clone | Overridden.
Public Method | DetachEditingControl | Removes the cell's editing control from the DataGridView. (Inherited from DataGridViewCell)
Public Method | Dispose | Overloaded. Releases all resources used by the DataGridViewCell. (Inherited from DataGridViewCell)
Public Method | GetContentBounds | Overloaded. (Inherited from DataGridViewCell)
Public Method | GetEditedFormattedValue | Returns the current, formatted value of the cell, regardless of whether the cell is in edit mode and the value has not been committed. (Inherited from DataGridViewCell)
Public Method | GetInheritedState | Returns a value indicating the current state of the cell as inherited from the state of its row or column. (Inherited from DataGridViewHeaderCell)
Public Method | GetInheritedStyle | Overridden. Gets the style applied to the cell.
Public Method | InitializeEditingControl | Initializes the control used to edit the cell. (Inherited from DataGridViewCell)
Public Method | KeyEntersEditMode | Determines if edit mode should be started based on the given key. (Inherited from DataGridViewCell)
Public Method | ParseFormattedValue | (Inherited from DataGridViewCell)
Public Method | PositionEditingControl | Sets the location and size of the editing control hosted by a cell in the DataGridView control. (Inherited from DataGridViewCell)
Public Method | PositionEditingPanel | (Inherited from DataGridViewCell)
Public Method | ToString | Overridden.
Public Method | Update | Overloaded. Full updates of this instance. (Inherited from DataGridViewElement)
Top

Protected Methods

 | Name | Description
Protected Method | BorderWidths | (Inherited from DataGridViewCell)
Protected Method | ClickUnsharesRow | Indicates whether the cell's row will be unshared when the cell is clicked. (Inherited from DataGridViewCell)
Protected Method | ContentClickUnsharesRow | Indicates whether the cell's row will be unshared when the cell's content is clicked. (Inherited from DataGridViewCell)
Protected Method | ContentDoubleClickUnsharesRow | Indicates whether the cell's row will be unshared when the cell's content is double-clicked. (Inherited from DataGridViewCell)
Protected Method | DoubleClickUnsharesRow | Indicates whether the cell's row will be unshared when the cell is double-clicked. (Inherited from DataGridViewCell)
Protected Method | EnterUnsharesRow | Indicates whether the parent row will be unshared when the focus moves to the cell. (Inherited from DataGridViewCell)
Protected Method | GetClipboardContent | Overridden. Retrieves the formatted value of the cell to copy to the Clipboard.
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from DataGridViewElement)
Protected Method | GetDefaultHorizontalAlignment | Gets the horizontal alignment. (Inherited from DataGridViewCell)
Protected Method | GetDefaultVerticalAlignment | Gets the vertical alignment. (Inherited from DataGridViewCell)
Protected Method | GetErrorIconBounds | (Inherited from DataGridViewCell)
Protected Method | GetErrorText | Returns a string that represents the error for the cell. (Inherited from DataGridViewCell)
Protected Method | GetFormattedValue | Gets the value of the cell as formatted for display. (Inherited from DataGridViewCell)
Protected Method | GetPreferredSize | Overloaded. Calculates the preferred size, in pixels, of the cell. (Inherited from DataGridViewCell)
Protected Method | GetSize | Gets the size of the cell. (Inherited from DataGridViewHeaderCell)
Protected Method | GetValue | Overridden. Gets the value of the cell.
Protected Method | IsDirty | Determines whether the specified component is dirty. (Inherited from DataGridViewElement)
Protected Method | IsDirtyAttributes | Overloaded. Determines whether the specified component is dirty. (Inherited from DataGridViewElement)
Protected Method | KeyDownUnsharesRow | Indicates whether the parent row is unshared if the user presses a key while the focus is on the cell. (Inherited from DataGridViewCell)
Protected Method | KeyPressUnsharesRow | Indicates whether a row will be unshared if a key is pressed while a cell in the row has focus. (Inherited from DataGridViewCell)
Protected Method | KeyUpUnsharesRow | Indicates whether the parent row is unshared when the user releases a key while the focus is on the cell. (Inherited from DataGridViewCell)
Protected Method | LeaveUnsharesRow | Indicates whether a row will be unshared when the focus leaves a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseClickUnsharesRow | Indicates whether a row will be unshared if the user clicks a mouse button while the pointer is on a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseDoubleClickUnsharesRow | Indicates whether a row will be unshared if the user double-clicks a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseDownUnsharesRow | Indicates whether a row will be unshared when the user holds down a mouse button while the pointer is on a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseEnterUnsharesRow | Indicates whether a row will be unshared when the mouse pointer moves over a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseLeaveUnsharesRow | Indicates whether a row will be unshared when the mouse pointer leaves the row. (Inherited from DataGridViewCell)
Protected Method | MouseMoveUnsharesRow | Indicates whether a row will be unshared when the mouse pointer moves over a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseUpUnsharesRow | Indicates whether a row will be unshared when the user releases a mouse button while the pointer is on a cell in the row. (Inherited from DataGridViewCell)
Protected Method | OnClick | Called when the cell is clicked. (Inherited from DataGridViewCell)
Protected Method | OnContentClick | Called when the cell's contents are clicked. (Inherited from DataGridViewCell)
Protected Method | OnContentDoubleClick | Called when the cell's contents are double-clicked. (Inherited from DataGridViewCell)
Protected Method | OnDataGridViewChanged | Called when the DataGridViewElement.DataGridView property of the cell changes. (Inherited from DataGridViewCell)
Protected Method | OnDoubleClick | Called when the cell is double-clicked. (Inherited from DataGridViewCell)
Protected Method | OnEnter | Called when the focus moves to a cell. (Inherited from DataGridViewCell)
Protected Method | OnKeyDown | Called when a character key is pressed while the focus is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnKeyPress | Called when a key is pressed while the focus is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnKeyUp | Called when a character key is released while the focus is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnLeave | Called when the focus moves from a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseClick | Called when the user clicks a mouse button while the pointer is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseDoubleClick | Called when the user double-clicks a mouse button while the pointer is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseDown | Called when the user holds down a mouse button while the pointer is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseEnter | Called when the mouse pointer moves over a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseLeave | Called when the mouse pointer leaves the cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseMove | Called when the mouse pointer moves within a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseUp | Called when the user releases a mouse button while the pointer is on a cell. (Inherited from DataGridViewCell)
Protected Method | Paint | (Inherited from DataGridViewCell)
Protected Method | PaintErrorIcon | (Inherited from DataGridViewCell)
Protected Method | ProcessGatewayRequest | (Inherited from DataGridViewCell)
Protected Method | RaiseCellClick | Raises the DataGridView.CellClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellContentClick | Raises the DataGridView.CellContentClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellContentDoubleClick | Raises the DataGridView.CellContentDoubleClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellValueChanged | Raises the CellValueChanged event. (Inherited from DataGridViewElement)
Protected Method | RaiseDataError | Raises the DataError event. (Inherited from DataGridViewElement)
Protected Method | RaiseMouseWheel | Raises the MouseWheel event. (Inherited from DataGridViewElement)
Protected Method | RenderAttributes | Renders a header- cell's attributes (Inherited from DataGridViewHeaderCell)
Protected Method | RenderBackColorAttribute | Renders the back-color attribute. (Inherited from DataGridViewHeaderCell)
Protected Method | RenderComponent | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from DataGridViewElement)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from DataGridViewElement)
Protected Method | RenderComponents | Renders the controls sub tree (Inherited from DataGridViewElement)
Protected Method | RenderForeColorAttribute | Renders the fore color attribute. (Inherited from DataGridViewHeaderCell)
Protected Method | RenderReadOnlyAttribute | Renders the read only attribute. (Inherited from DataGridViewHeaderCell)
Protected Method | RenderUpdatedAttributes | Renders the updated attributes (Inherited from DataGridViewElement)
Protected Method | RenderWrapModeAttribute | Renders the wrap mode attribute. (Inherited from DataGridViewHeaderCell)
Protected Method | SetValue | Overridden. Sets the value of the cell.
Protected Method | UpdateParams | Overloaded. Updates only the parameters of this instance. (Inherited from DataGridViewElement)
Top

See Also

Reference

DataGridViewColumnHeaderCell Class
Gizmox.WebGUI.Forms Namespace


Clone Method

[image]
Gizmox.WebGUI.Forms
Clone Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumnHeaderCell Class : Clone Method

Syntax

Visual Basic (Declaration)
Public Overrides Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewColumnHeaderCell
Dim value As Object

value = instance.Clone()
C#
public override object Clone()
Managed Extensions for C++
public: Object* Clone(); override
C++/CLI
public:
Object^ Clone(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumnHeaderCell Class
DataGridViewColumnHeaderCell Members


GetClipboardContent Method

[image]
Gizmox.WebGUI.Forms
GetClipboardContent Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumnHeaderCell Class : GetClipboardContent Method

rowIndex
The zero-based index of the row containing the cell.
firstCell
true to indicate that the cell is in the first column of the region defined by the selected cells; otherwise, false.
lastCell
true to indicate that the cell is the last column of the region defined by the selected cells; otherwise, false.
inFirstRow
true to indicate that the cell is in the first row of the region defined by the selected cells; otherwise, false.
inLastRow
true to indicate that the cell is in the last row of the region defined by the selected cells; otherwise, false.
format
The current format string of the cell.
Retrieves the formatted value of the cell to copy to the Clipboard.

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetClipboardContent( _
   ByVal rowIndex As Integer, _
   ByVal firstCell As Boolean, _
   ByVal lastCell As Boolean, _
   ByVal inFirstRow As Boolean, _
   ByVal inLastRow As Boolean, _
   ByVal format As String _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewColumnHeaderCell
Dim rowIndex As Integer
Dim firstCell As Boolean
Dim lastCell As Boolean
Dim inFirstRow As Boolean
Dim inLastRow As Boolean
Dim format As String
Dim value As Object

value = instance.GetClipboardContent(rowIndex, firstCell, lastCell, inFirstRow, inLastRow, format)
C#
protected override object GetClipboardContent(
   int rowIndex,
   bool firstCell,
   bool lastCell,
   bool inFirstRow,
   bool inLastRow,
   string format
)
Managed Extensions for C++
protected: Object* GetClipboardContent(
   int rowIndex,
   bool firstCell,
   bool lastCell,
   bool inFirstRow,
   bool inLastRow,
   string* format
) override
C++/CLI
protected:
Object^ GetClipboardContent(
   int rowIndex,
   bool firstCell,
   bool lastCell,
   bool inFirstRow,
   bool inLastRow,
   String^ format
) override

Parameters

rowIndex
The zero-based index of the row containing the cell.
firstCell
true to indicate that the cell is in the first column of the region defined by the selected cells; otherwise, false.
lastCell
true to indicate that the cell is the last column of the region defined by the selected cells; otherwise, false.
inFirstRow
true to indicate that the cell is in the first row of the region defined by the selected cells; otherwise, false.
inLastRow
true to indicate that the cell is in the last row of the region defined by the selected cells; otherwise, false.
format
The current format string of the cell.

Return Value

A Object that represents the value of the cell to copy to the Clipboard.

Exceptions

Exception | Description
ArgumentOutOfRangeException | rowIndex is not -1.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumnHeaderCell Class
DataGridViewColumnHeaderCell Members


GetInheritedStyle Method

[image]
Gizmox.WebGUI.Forms
GetInheritedStyle Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumnHeaderCell Class : GetInheritedStyle Method

inheritedCellStyle
A DataGridViewCellStyle to be populated with the inherited cell style.
rowIndex
The index of the cell's parent row.
includeColors
true to include inherited colors in the returned cell style; otherwise, false.
Gets the style applied to the cell.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetInheritedStyle( _
   ByVal inheritedCellStyle As DataGridViewCellStyle, _
   ByVal rowIndex As Integer, _
   ByVal includeColors As Boolean _
) As DataGridViewCellStyle
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewColumnHeaderCell
Dim inheritedCellStyle As DataGridViewCellStyle
Dim rowIndex As Integer
Dim includeColors As Boolean
Dim value As DataGridViewCellStyle

value = instance.GetInheritedStyle(inheritedCellStyle, rowIndex, includeColors)
C#
public override DataGridViewCellStyle GetInheritedStyle(
   DataGridViewCellStyle inheritedCellStyle,
   int rowIndex,
   bool includeColors
)
Managed Extensions for C++
public: DataGridViewCellStyle* GetInheritedStyle(
   DataGridViewCellStyle* inheritedCellStyle,
   int rowIndex,
   bool includeColors
) override
C++/CLI
public:
DataGridViewCellStyle^ GetInheritedStyle(
   DataGridViewCellStyle^ inheritedCellStyle,
   int rowIndex,
   bool includeColors
) override

Parameters

inheritedCellStyle
A DataGridViewCellStyle to be populated with the inherited cell style.
rowIndex
The index of the cell's parent row.
includeColors
true to include inherited colors in the returned cell style; otherwise, false.

Return Value

A DataGridViewCellStyle that includes the style settings of the cell inherited from the cell's parent row, column, and DataGridView.

Exceptions

Exception | Description
ArgumentOutOfRangeException | rowIndex is not -1.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumnHeaderCell Class
DataGridViewColumnHeaderCell Members


GetValue Method

[image]
Gizmox.WebGUI.Forms
GetValue Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumnHeaderCell Class : GetValue Method

rowIndex
The index of the cell's parent row.
Gets the value of the cell.

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetValue( _
   ByVal rowIndex As Integer _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewColumnHeaderCell
Dim rowIndex As Integer
Dim value As Object

value = instance.GetValue(rowIndex)
C#
protected override object GetValue(
   int rowIndex
)
Managed Extensions for C++
protected: Object* GetValue(
   int rowIndex
) override
C++/CLI
protected:
Object^ GetValue(
   int rowIndex
) override

Parameters

rowIndex
The index of the cell's parent row.

Return Value

The value contained in the DataGridViewColumnHeaderCell.

Exceptions

Exception | Description
ArgumentOutOfRangeException | rowIndex is not -1.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumnHeaderCell Class
DataGridViewColumnHeaderCell Members


SetValue Method

[image]
Gizmox.WebGUI.Forms
SetValue Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumnHeaderCell Class : SetValue Method

rowIndex
The index of the cell's parent row.
value
The cell value to set.
Sets the value of the cell.

Syntax

Visual Basic (Declaration)
Protected Overrides Function SetValue( _
   ByVal rowIndex As Integer, _
   ByVal value As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewColumnHeaderCell
Dim rowIndex As Integer
Dim value As Object
Dim value As Boolean

value = instance.SetValue(rowIndex, value)
C#
protected override bool SetValue(
   int rowIndex,
   object value
)
Managed Extensions for C++
protected: bool SetValue(
   int rowIndex,
   Object* value
) override
C++/CLI
protected:
bool SetValue(
   int rowIndex,
   Object^ value
) override

Parameters

rowIndex
The index of the cell's parent row.
value
The cell value to set.

Return Value

true if the value has been set; otherwise false.

Exceptions

Exception | Description
ArgumentOutOfRangeException | rowIndex is not -1.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumnHeaderCell Class
DataGridViewColumnHeaderCell Members


ToString Method

[image]
Gizmox.WebGUI.Forms
ToString Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumnHeaderCell Class : ToString Method

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewColumnHeaderCell
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumnHeaderCell Class
DataGridViewColumnHeaderCell Members


DataGridViewColumnHeaderCell Class Properties

[image]
Gizmox.WebGUI.Forms
DataGridViewColumnHeaderCell Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewColumnHeaderCell Class

For a list of all members of this type, see DataGridViewColumnHeaderCell members.

Public Properties

 | Name | Description
Public Property | ColumnIndex | Gets the column index for this cell. (Inherited from DataGridViewCell)
Public Property | ContentBounds | (Inherited from DataGridViewCell)
Public Property | DataGridView | Gets the DataGridView control associated with this element. (Inherited from DataGridViewElement)
Public Property | DefaultNewRowValue | Gets the default value for a cell in the row for new records. (Inherited from DataGridViewCell)
Public Property | Displayed | (Inherited from DataGridViewHeaderCell)
Public Property | EditedFormattedValue | Gets the current, formatted value of the cell, regardless of whether the cell is in edit mode and the value has not been committed. (Inherited from DataGridViewCell)
Public Property | EditType | Gets the type of the cell's hosted editing control. (Inherited from DataGridViewCell)
Public Property | ErrorIconBounds | (Inherited from DataGridViewCell)
Public Property | ErrorText | Gets or sets the text describing an error condition associated with the cell. (Inherited from DataGridViewCell)
Public Property | FormattedValue | Gets the value of the cell as formatted for display. (Inherited from DataGridViewCell)
Public Property | FormattedValueType | Gets the type of the formatted value of the cell. (Inherited from DataGridViewHeaderCell)
Public Property | Frozen | Gets a value indicating whether the cell is frozen. (Inherited from DataGridViewHeaderCell)
Public Property | HasStyle | Gets a value indicating whether the DataGridViewCell.Style property has been set. (Inherited from DataGridViewCell)
Public Property | InheritedState | Gets the current state of the cell as inherited from the state of its row and column. (Inherited from DataGridViewCell)
Public Property | InheritedStyle | Gets the style currently applied to the cell. (Inherited from DataGridViewCell)
Public Property | IsInEditMode | Gets a value indicating whether this cell is currently being edited. (Inherited from DataGridViewCell)
Public Property | OwningColumn | Gets the column that contains this cell. (Inherited from DataGridViewCell)
Public Property | OwningRow | Gets the row that contains this cell. (Inherited from DataGridViewCell)
Public Property | PreferredSize | Gets the size, in pixels, of a rectangular area into which the cell can fit. (Inherited from DataGridViewCell)
Public Property | ReadOnly | Gets a value indicating whether the header cell is read-only. (Inherited from DataGridViewHeaderCell)
Public Property | Resizable | Gets a value indicating whether the cell is resizable. (Inherited from DataGridViewHeaderCell)
Public Property | RowIndex | Gets the index of the cell's parent row. (Inherited from DataGridViewCell)
Public Property | Selected | Gets or sets a value indicating whether the cell is selected. (Inherited from DataGridViewHeaderCell)
Public Property | Size | Gets the size of the cell. (Inherited from DataGridViewCell)
Public Property | SortGlyphDirection | Gets or sets a value indicating which sort glyph is displayed.
Public Property | State | Gets the user interface (UI) state of the element. (Inherited from DataGridViewElement)
Public Property | Style | Gets or sets the style for the cell. (Inherited from DataGridViewCell)
Public Property | Tag | Gets or sets the object that contains supplemental data about the cell. (Inherited from DataGridViewCell)
Public Property | ToolTipText | Gets or sets the ToolTip text associated with this cell. (Inherited from DataGridViewCell)
Public Property | Value | Gets or sets the value associated with this cell. (Inherited from DataGridViewCell)
Public Property | ValueType | Gets the type of the value stored in the cell. (Inherited from DataGridViewHeaderCell)
Public Property | Visible | Gets a value indicating whether or not the cell is visible. (Inherited from DataGridViewHeaderCell)
Top

Protected Properties

 | Name | Description
Protected Property | ButtonState | Gets the buttonlike visual state of the header cell. (Inherited from DataGridViewHeaderCell)
Protected Property | MemberID | (Inherited from DataGridViewCell)
Protected Property | TagName | (Inherited from DataGridViewElement)
Top

See Also

Reference

DataGridViewColumnHeaderCell Class
Gizmox.WebGUI.Forms Namespace


SortGlyphDirection Property

[image]
Gizmox.WebGUI.Forms
SortGlyphDirection Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumnHeaderCell Class : SortGlyphDirection Property

Gets or sets a value indicating which sort glyph is displayed.

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
Public Property SortGlyphDirection As SortOrder
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewColumnHeaderCell
Dim value As SortOrder

instance.SortGlyphDirection = value

value = instance.SortGlyphDirection
C#
[DesignerSerializationVisibilityAttribute()]
public SortOrder SortGlyphDirection {get; set;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
public: __property SortOrder get_SortGlyphDirection();
public: __property void set_SortGlyphDirection(
   SortOrder value
);
C++/CLI
[DesignerSerializationVisibilityAttribute()]
public:
property SortOrder SortGlyphDirection {
   SortOrder get();
   void set (SortOrdervalue);
}

Exceptions

Exception | Description
InvalidEnumArgumentException | The specified value when setting this property is not a valid SortOrder value.
InvalidOperationException | When setting this property, the value of either the DataGridViewCell.OwningColumn property or the DataGridViewElement.DataGridView property of the cell is null.-or-When changing the value of this property, the specified value is not SortOrder.None and the value of the DataGridViewColumn.SortMode property of the owning column is DataGridViewColumnSortMode.NotSortable.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumnHeaderCell Class
DataGridViewColumnHeaderCell Members


DataGridViewColumnStateChangedEventArgs Class

[image]
Gizmox.WebGUI.Forms
DataGridViewColumnStateChangedEventArgs Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewColumnStateChangedEventArgs Class

Provides data for the ColumnStateChanged event.

Object Model

Syntax

Visual Basic (Declaration)
Public Class DataGridViewColumnStateChangedEventArgs
   Inherits EventArgs
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewColumnStateChangedEventArgs
C#
public class DataGridViewColumnStateChangedEventArgs : EventArgs
Managed Extensions for C++
public __gc class DataGridViewColumnStateChangedEventArgs : public EventArgs
C++/CLI
public ref class DataGridViewColumnStateChangedEventArgs : public EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gizmox.WebGUI.Forms.DataGridViewColumnStateChangedEventArgs

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

DataGridViewColumnStateChangedEventArgs Members
Gizmox.WebGUI.Forms Namespace


DataGridViewColumnStateChangedEventArgs Class Members

[image]
Gizmox.WebGUI.Forms
DataGridViewColumnStateChangedEventArgs Class Members
See Also Properties Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewColumnStateChangedEventArgs Class

The following tables list the members exposed by DataGridViewColumnStateChangedEventArgs.

Public Constructors

 | Name | Description
Public Constructor | DataGridViewColumnStateChangedEventArgs Constructor | Initializes a new instance of the DataGridViewColumnStateChangedEventArgs class.
Top

Public Properties

 | Name | Description
Public Property | Column | Gets the column whose state changed.
Public Property | StateChanged | Gets the new column state.
Top

See Also

Reference

DataGridViewColumnStateChangedEventArgs Class
Gizmox.WebGUI.Forms Namespace


DataGridViewColumnStateChangedEventArgs Constructor

[image]
Gizmox.WebGUI.Forms
DataGridViewColumnStateChangedEventArgs Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumnStateChangedEventArgs Class : DataGridViewColumnStateChangedEventArgs Constructor

dataGridViewColumn
The DataGridViewColumn whose state has changed.
stateChanged
One of the DataGridViewElementStates values.
Initializes a new instance of the DataGridViewColumnStateChangedEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal dataGridViewColumn As DataGridViewColumn, _
   ByVal stateChanged As DataGridViewElementStates _
)
Visual Basic (Usage) Copy Code
Dim dataGridViewColumn As DataGridViewColumn
Dim stateChanged As DataGridViewElementStates

Dim instance As DataGridViewColumnStateChangedEventArgs(dataGridViewColumn, stateChanged)
C#
public DataGridViewColumnStateChangedEventArgs(
   DataGridViewColumn dataGridViewColumn,
   DataGridViewElementStates stateChanged
)
Managed Extensions for C++
public: DataGridViewColumnStateChangedEventArgs(
   DataGridViewColumn* dataGridViewColumn,
   DataGridViewElementStates stateChanged
)
C++/CLI
public:
DataGridViewColumnStateChangedEventArgs(
   DataGridViewColumn^ dataGridViewColumn,
   DataGridViewElementStates stateChanged
)

Parameters

dataGridViewColumn
The DataGridViewColumn whose state has changed.
stateChanged
One of the DataGridViewElementStates values.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumnStateChangedEventArgs Class
DataGridViewColumnStateChangedEventArgs Members


DataGridViewColumnStateChangedEventArgs Class Properties

[image]
Gizmox.WebGUI.Forms
DataGridViewColumnStateChangedEventArgs Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewColumnStateChangedEventArgs Class

For a list of all members of this type, see DataGridViewColumnStateChangedEventArgs members.

Public Properties

 | Name | Description
Public Property | Column | Gets the column whose state changed.
Public Property | StateChanged | Gets the new column state.
Top

See Also

Reference

DataGridViewColumnStateChangedEventArgs Class
Gizmox.WebGUI.Forms Namespace


Column Property

[image]
Gizmox.WebGUI.Forms
Column Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumnStateChangedEventArgs Class : Column Property

Gets the column whose state changed.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Column As DataGridViewColumn
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewColumnStateChangedEventArgs
Dim value As DataGridViewColumn

value = instance.Column
C#
public DataGridViewColumn Column {get;}
Managed Extensions for C++
public: __property DataGridViewColumn* get_Column();
C++/CLI
public:
property DataGridViewColumn^ Column {
   DataGridViewColumn^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumnStateChangedEventArgs Class
DataGridViewColumnStateChangedEventArgs Members


StateChanged Property

[image]
Gizmox.WebGUI.Forms
StateChanged Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewColumnStateChangedEventArgs Class : StateChanged Property

Gets the new column state.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property StateChanged As DataGridViewElementStates
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewColumnStateChangedEventArgs
Dim value As DataGridViewElementStates

value = instance.StateChanged
C#
public DataGridViewElementStates StateChanged {get;}
Managed Extensions for C++
public: __property DataGridViewElementStates get_StateChanged();
C++/CLI
public:
property DataGridViewElementStates StateChanged {
   DataGridViewElementStates get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewColumnStateChangedEventArgs Class
DataGridViewColumnStateChangedEventArgs Members


DataGridViewComboBoxCell Class

[image]
Gizmox.WebGUI.Forms
DataGridViewComboBoxCell Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewComboBoxCell Class

Displays a combo box in a DataGridView control.

Object Model

Syntax

Visual Basic (Declaration)
Public Class DataGridViewComboBoxCell
   Inherits DataGridViewCell
   Implements IRenderableComponentMember
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewComboBoxCell
C#
public class DataGridViewComboBoxCell : DataGridViewCell, IRenderableComponentMember
Managed Extensions for C++
public __gc class DataGridViewComboBoxCell : public DataGridViewCell, IRenderableComponentMember
C++/CLI
public ref class DataGridViewComboBoxCell : public DataGridViewCell, IRenderableComponentMember

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.DataGridViewElement
Gizmox.WebGUI.Forms.DataGridViewCell
Gizmox.WebGUI.Forms.DataGridViewComboBoxCell

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

DataGridViewComboBoxCell Members
Gizmox.WebGUI.Forms Namespace


DataGridViewComboBoxCell Class Members

[image]
Gizmox.WebGUI.Forms
DataGridViewComboBoxCell Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewComboBoxCell Class

The following tables list the members exposed by DataGridViewComboBoxCell.

Public Constructors

 | Name | Description
Public Constructor | DataGridViewComboBoxCell Constructor | Initializes a new instance of the DataGridViewComboBoxCell class.
Top

Public Properties

 | Name | Description
Public Property | AutoComplete | Gets or sets a value indicating whether the cell will match the characters being entered in the cell with a selection from the drop-down list.
Public Property | ColumnIndex | Gets the column index for this cell. (Inherited from DataGridViewCell)
Public Property | ContentBounds | (Inherited from DataGridViewCell)
Public Property | DataGridView | Gets the DataGridView control associated with this element. (Inherited from DataGridViewElement)
Public Property | DataSource | Gets or sets the data source whose data contains the possible selections shown in the drop-down list.
Public Property | DefaultNewRowValue | Gets the default value for a cell in the row for new records. (Inherited from DataGridViewCell)
Public Property | Displayed | Gets a value that indicates whether the cell is currently displayed on-screen. (Inherited from DataGridViewCell)
Public Property | DisplayMember | Gets or sets a string that specifies where to gather selections to display in the drop-down list.
Public Property | DisplayStyle | Gets or sets a value that determines how the combo box is displayed when it is not in edit mode.
Public Property | DisplayStyleForCurrentCellOnly | Gets or sets a value that determines if the display style only applies to the current cell.
Public Property | DropDownWidth | Gets or sets the width of the of the drop-down list portion of a combo box.
Public Property | EditedFormattedValue | Gets the current, formatted value of the cell, regardless of whether the cell is in edit mode and the value has not been committed. (Inherited from DataGridViewCell)
Public Property | EditType | Overridden. Gets the type of the cell's hosted editing control.
Public Property | ErrorIconBounds | (Inherited from DataGridViewCell)
Public Property | ErrorText | Gets or sets the text describing an error condition associated with the cell. (Inherited from DataGridViewCell)
Public Property | FlatStyle | Gets or sets the flat style appearance of the cell.
Public Property | FormattedValue | Gets the value of the cell as formatted for display. (Inherited from DataGridViewCell)
Public Property | FormattedValueType | Overridden. Gets the class type of the formatted value associated with the cell.
Public Property | Frozen | Gets a value indicating whether the cell is frozen. (Inherited from DataGridViewCell)
Public Property | HasStyle | Gets a value indicating whether the DataGridViewCell.Style property has been set. (Inherited from DataGridViewCell)
Public Property | InheritedState | Gets the current state of the cell as inherited from the state of its row and column. (Inherited from DataGridViewCell)
Public Property | InheritedStyle | Gets the style currently applied to the cell. (Inherited from DataGridViewCell)
Public Property | IsInEditMode | Gets a value indicating whether this cell is currently being edited. (Inherited from DataGridViewCell)
Public Property | Items | Gets the objects that represent the selection displayed in the drop-down list.
Public Property | MaxDropDownItems | Gets or sets the maximum number of items shown in the drop-down list.
Public Property | OwningColumn | Gets the column that contains this cell. (Inherited from DataGridViewCell)
Public Property | OwningRow | Gets the row that contains this cell. (Inherited from DataGridViewCell)
Public Property | PreferredSize | Gets the size, in pixels, of a rectangular area into which the cell can fit. (Inherited from DataGridViewCell)
Public Property | ReadOnly | Gets or sets a value indicating whether the cell's data can be edited. (Inherited from DataGridViewCell)
Public Property | Resizable | Gets a value indicating whether the cell can be resized. (Inherited from DataGridViewCell)
Public Property | RowIndex | Gets the index of the cell's parent row. (Inherited from DataGridViewCell)
Public Property | Selected | Gets or sets a value indicating whether the cell has been selected. (Inherited from DataGridViewCell)
Public Property | Size | Gets the size of the cell. (Inherited from DataGridViewCell)
Public Property | Sorted | Gets or sets a value indicating whether the items in the combo box are automatically sorted.
Public Property | State | Gets the user interface (UI) state of the element. (Inherited from DataGridViewElement)
Public Property | Style | Gets or sets the style for the cell. (Inherited from DataGridViewCell)
Public Property | Tag | Gets or sets the object that contains supplemental data about the cell. (Inherited from DataGridViewCell)
Public Property | ToolTipText | Gets or sets the ToolTip text associated with this cell. (Inherited from DataGridViewCell)
Public Property | Value | Gets or sets the value associated with this cell. (Inherited from DataGridViewCell)
Public Property | ValueMember | Gets or sets a string that specifies where to gather the underlying values used in the drop-down list.
Public Property | ValueType | Overridden.
Public Property | Visible | Gets a value indicating whether the cell is in a row or column that has been hidden. (Inherited from DataGridViewCell)
Top

Protected Properties

 | Name | Description
Protected Property | MemberID | (Inherited from DataGridViewCell)
Protected Property | TagName | (Inherited from DataGridViewElement)
Top

Public Methods

 | Name | Description
Public Method | AdjustCellBorderStyle | Modifies the input cell border style according to the specified criteria. (Inherited from DataGridViewCell)
Public Method | Clone | Overridden. Creates an exact copy of this cell.
Public Method | DetachEditingControl | Overridden.
Public Method | Dispose | Overloaded. Releases all resources used by the DataGridViewCell. (Inherited from DataGridViewCell)
Public Method | GetContentBounds | Overloaded. (Inherited from DataGridViewCell)
Public Method | GetEditedFormattedValue | Returns the current, formatted value of the cell, regardless of whether the cell is in edit mode and the value has not been committed. (Inherited from DataGridViewCell)
Public Method | GetInheritedState | Returns a value indicating the current state of the cell as inherited from the state of its row and column. (Inherited from DataGridViewCell)
Public Method | GetInheritedStyle | Gets the style applied to the cell. (Inherited from DataGridViewCell)
Public Method | InitializeEditingControl | Overridden. Attaches and initializes the hosted editing control.
Public Method | KeyEntersEditMode | Overridden. Determines if edit mode should be started based on the given key.
Public Method | ParseFormattedValue | Overridden.
Public Method | PositionEditingControl | Sets the location and size of the editing control hosted by a cell in the DataGridView control. (Inherited from DataGridViewCell)
Public Method | PositionEditingPanel | (Inherited from DataGridViewCell)
Public Method | RenderComboboxItems | Renders the combobox items.
Public Method | ToString | Overridden.
Public Method | Update | Overloaded. Full updates of this instance. (Inherited from DataGridViewElement)
Top

Protected Methods

 | Name | Description
Protected Method | BorderWidths | (Inherited from DataGridViewCell)
Protected Method | ClickUnsharesRow | Indicates whether the cell's row will be unshared when the cell is clicked. (Inherited from DataGridViewCell)
Protected Method | CollectionsEquals | Determines whether [is collections equals] [the specified obj collection1].
Protected Method | ContentClickUnsharesRow | Indicates whether the cell's row will be unshared when the cell's content is clicked. (Inherited from DataGridViewCell)
Protected Method | ContentDoubleClickUnsharesRow | Indicates whether the cell's row will be unshared when the cell's content is double-clicked. (Inherited from DataGridViewCell)
Protected Method | DoubleClickUnsharesRow | Indicates whether the cell's row will be unshared when the cell is double-clicked. (Inherited from DataGridViewCell)
Protected Method | EnterUnsharesRow | Indicates whether the parent row will be unshared when the focus moves to the cell. (Inherited from DataGridViewCell)
Protected Method | GetClipboardContent | Retrieves the formatted value of the cell to copy to the Clipboard. (Inherited from DataGridViewCell)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from DataGridViewElement)
Protected Method | GetDefaultHorizontalAlignment | Gets the horizontal alignment. (Inherited from DataGridViewCell)
Protected Method | GetDefaultVerticalAlignment | Gets the vertical alignment. (Inherited from DataGridViewCell)
Protected Method | GetErrorIconBounds | (Inherited from DataGridViewCell)
Protected Method | GetErrorText | Returns a string that represents the error for the cell. (Inherited from DataGridViewCell)
Protected Method | GetFormattedValue | Overridden. Gets the formatted value of the cell's data.
Protected Method | GetPreferredSize | Overloaded. Overridden. Calculates the preferred size, in pixels, of the cell.
Protected Method | GetSize | Gets the size of the cell. (Inherited from DataGridViewCell)
Protected Method | GetValue | Gets the value of the cell. (Inherited from DataGridViewCell)
Protected Method | IsDirty | Determines whether the specified component is dirty. (Inherited from DataGridViewElement)
Protected Method | IsDirtyAttributes | Overloaded. Determines whether the specified component is dirty. (Inherited from DataGridViewElement)
Protected Method | KeyDownUnsharesRow | Indicates whether the parent row is unshared if the user presses a key while the focus is on the cell. (Inherited from DataGridViewCell)
Protected Method | KeyPressUnsharesRow | Indicates whether a row will be unshared if a key is pressed while a cell in the row has focus. (Inherited from DataGridViewCell)
Protected Method | KeyUpUnsharesRow | Indicates whether the parent row is unshared when the user releases a key while the focus is on the cell. (Inherited from DataGridViewCell)
Protected Method | LeaveUnsharesRow | Indicates whether a row will be unshared when the focus leaves a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseClickUnsharesRow | Indicates whether a row will be unshared if the user clicks a mouse button while the pointer is on a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseDoubleClickUnsharesRow | Indicates whether a row will be unshared if the user double-clicks a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseDownUnsharesRow | Indicates whether a row will be unshared when the user holds down a mouse button while the pointer is on a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseEnterUnsharesRow | Indicates whether a row will be unshared when the mouse pointer moves over a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseLeaveUnsharesRow | Indicates whether a row will be unshared when the mouse pointer leaves the row. (Inherited from DataGridViewCell)
Protected Method | MouseMoveUnsharesRow | Indicates whether a row will be unshared when the mouse pointer moves over a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseUpUnsharesRow | Indicates whether a row will be unshared when the user releases a mouse button while the pointer is on a cell in the row. (Inherited from DataGridViewCell)
Protected Method | OnClick | Called when the cell is clicked. (Inherited from DataGridViewCell)
Protected Method | OnContentClick | Called when the cell's contents are clicked. (Inherited from DataGridViewCell)
Protected Method | OnContentDoubleClick | Called when the cell's contents are double-clicked. (Inherited from DataGridViewCell)
Protected Method | OnDataGridViewChanged | Overridden. Called when the DataGridView property of the cell changes.
Protected Method | OnDoubleClick | Called when the cell is double-clicked. (Inherited from DataGridViewCell)
Protected Method | OnEnter | Overridden.
Protected Method | OnKeyDown | Called when a character key is pressed while the focus is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnKeyPress | Called when a key is pressed while the focus is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnKeyUp | Called when a character key is released while the focus is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnLeave | Overridden.
Protected Method | OnMouseClick | Overridden.
Protected Method | OnMouseDoubleClick | Called when the user double-clicks a mouse button while the pointer is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseDown | Called when the user holds down a mouse button while the pointer is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseEnter | Overridden.
Protected Method | OnMouseLeave | Overridden.
Protected Method | OnMouseMove | Overridden.
Protected Method | OnMouseUp | Called when the user releases a mouse button while the pointer is on a cell. (Inherited from DataGridViewCell)
Protected Method | Paint | (Inherited from DataGridViewCell)
Protected Method | PaintErrorIcon | (Inherited from DataGridViewCell)
Protected Method | ProcessGatewayRequest | (Inherited from DataGridViewCell)
Protected Method | RaiseCellClick | Raises the DataGridView.CellClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellContentClick | Raises the DataGridView.CellContentClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellContentDoubleClick | Raises the DataGridView.CellContentDoubleClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellValueChanged | Raises the CellValueChanged event. (Inherited from DataGridViewElement)
Protected Method | RaiseDataError | Raises the DataError event. (Inherited from DataGridViewElement)
Protected Method | RaiseMouseWheel | Raises the MouseWheel event. (Inherited from DataGridViewElement)
Protected Method | RenderAttributes | Overridden.
Protected Method | RenderBackColorAttribute | Renders the back color attribute. (Inherited from DataGridViewCell)
Protected Method | RenderComponent | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from DataGridViewElement)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from DataGridViewElement)
Protected Method | RenderComponents | Overridden.
Protected Method | RenderForeColorAttribute | Renders the fore color attribute. (Inherited from DataGridViewCell)
Protected Method | RenderReadOnlyAttribute | Renders the read only attribute. (Inherited from DataGridViewCell)
Protected Method | RenderUpdatedAttributes | Renders the updated attributes (Inherited from DataGridViewElement)
Protected Method | RenderWrapModeAttribute | Renders the wrap mode attribute. (Inherited from DataGridViewCell)
Protected Method | SetValue | Sets the value of the cell. (Inherited from DataGridViewCell)
Protected Method | UpdateParams | Overloaded. Updates only the parameters of this instance. (Inherited from DataGridViewElement)
Top

See Also

Reference

DataGridViewComboBoxCell Class
Gizmox.WebGUI.Forms Namespace


DataGridViewComboBoxCell Constructor

[image]
Gizmox.WebGUI.Forms
DataGridViewComboBoxCell Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewComboBoxCell Class : DataGridViewComboBoxCell Constructor

Initializes a new instance of the DataGridViewComboBoxCell class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewComboBoxCell()
C#
public DataGridViewComboBoxCell()
Managed Extensions for C++
public: DataGridViewComboBoxCell();
C++/CLI
public:
DataGridViewComboBoxCell();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewComboBoxCell Class
DataGridViewComboBoxCell Members


DataGridViewComboBoxCell Class Methods

[image]
Gizmox.WebGUI.Forms
DataGridViewComboBoxCell Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewComboBoxCell Class

For a list of all members of this type, see DataGridViewComboBoxCell members.

Public Methods

 | Name | Description
Public Method | AdjustCellBorderStyle | Modifies the input cell border style according to the specified criteria. (Inherited from DataGridViewCell)
Public Method | Clone | Overridden. Creates an exact copy of this cell.
Public Method | DetachEditingControl | Overridden.
Public Method | Dispose | Overloaded. Releases all resources used by the DataGridViewCell. (Inherited from DataGridViewCell)
Public Method | GetContentBounds | Overloaded. (Inherited from DataGridViewCell)
Public Method | GetEditedFormattedValue | Returns the current, formatted value of the cell, regardless of whether the cell is in edit mode and the value has not been committed. (Inherited from DataGridViewCell)
Public Method | GetInheritedState | Returns a value indicating the current state of the cell as inherited from the state of its row and column. (Inherited from DataGridViewCell)
Public Method | GetInheritedStyle | Gets the style applied to the cell. (Inherited from DataGridViewCell)
Public Method | InitializeEditingControl | Overridden. Attaches and initializes the hosted editing control.
Public Method | KeyEntersEditMode | Overridden. Determines if edit mode should be started based on the given key.
Public Method | ParseFormattedValue | Overridden.
Public Method | PositionEditingControl | Sets the location and size of the editing control hosted by a cell in the DataGridView control. (Inherited from DataGridViewCell)
Public Method | PositionEditingPanel | (Inherited from DataGridViewCell)
Public Method | RenderComboboxItems | Renders the combobox items.
Public Method | ToString | Overridden.
Public Method | Update | Overloaded. Full updates of this instance. (Inherited from DataGridViewElement)
Top

Protected Methods

 | Name | Description
Protected Method | BorderWidths | (Inherited from DataGridViewCell)
Protected Method | ClickUnsharesRow | Indicates whether the cell's row will be unshared when the cell is clicked. (Inherited from DataGridViewCell)
Protected Method | CollectionsEquals | Determines whether [is collections equals] [the specified obj collection1].
Protected Method | ContentClickUnsharesRow | Indicates whether the cell's row will be unshared when the cell's content is clicked. (Inherited from DataGridViewCell)
Protected Method | ContentDoubleClickUnsharesRow | Indicates whether the cell's row will be unshared when the cell's content is double-clicked. (Inherited from DataGridViewCell)
Protected Method | DoubleClickUnsharesRow | Indicates whether the cell's row will be unshared when the cell is double-clicked. (Inherited from DataGridViewCell)
Protected Method | EnterUnsharesRow | Indicates whether the parent row will be unshared when the focus moves to the cell. (Inherited from DataGridViewCell)
Protected Method | GetClipboardContent | Retrieves the formatted value of the cell to copy to the Clipboard. (Inherited from DataGridViewCell)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from DataGridViewElement)
Protected Method | GetDefaultHorizontalAlignment | Gets the horizontal alignment. (Inherited from DataGridViewCell)
Protected Method | GetDefaultVerticalAlignment | Gets the vertical alignment. (Inherited from DataGridViewCell)
Protected Method | GetErrorIconBounds | (Inherited from DataGridViewCell)
Protected Method | GetErrorText | Returns a string that represents the error for the cell. (Inherited from DataGridViewCell)
Protected Method | GetFormattedValue | Overridden. Gets the formatted value of the cell's data.
Protected Method | GetPreferredSize | Overloaded. Overridden. Calculates the preferred size, in pixels, of the cell.
Protected Method | GetSize | Gets the size of the cell. (Inherited from DataGridViewCell)
Protected Method | GetValue | Gets the value of the cell. (Inherited from DataGridViewCell)
Protected Method | IsDirty | Determines whether the specified component is dirty. (Inherited from DataGridViewElement)
Protected Method | IsDirtyAttributes | Overloaded. Determines whether the specified component is dirty. (Inherited from DataGridViewElement)
Protected Method | KeyDownUnsharesRow | Indicates whether the parent row is unshared if the user presses a key while the focus is on the cell. (Inherited from DataGridViewCell)
Protected Method | KeyPressUnsharesRow | Indicates whether a row will be unshared if a key is pressed while a cell in the row has focus. (Inherited from DataGridViewCell)
Protected Method | KeyUpUnsharesRow | Indicates whether the parent row is unshared when the user releases a key while the focus is on the cell. (Inherited from DataGridViewCell)
Protected Method | LeaveUnsharesRow | Indicates whether a row will be unshared when the focus leaves a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseClickUnsharesRow | Indicates whether a row will be unshared if the user clicks a mouse button while the pointer is on a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseDoubleClickUnsharesRow | Indicates whether a row will be unshared if the user double-clicks a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseDownUnsharesRow | Indicates whether a row will be unshared when the user holds down a mouse button while the pointer is on a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseEnterUnsharesRow | Indicates whether a row will be unshared when the mouse pointer moves over a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseLeaveUnsharesRow | Indicates whether a row will be unshared when the mouse pointer leaves the row. (Inherited from DataGridViewCell)
Protected Method | MouseMoveUnsharesRow | Indicates whether a row will be unshared when the mouse pointer moves over a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseUpUnsharesRow | Indicates whether a row will be unshared when the user releases a mouse button while the pointer is on a cell in the row. (Inherited from DataGridViewCell)
Protected Method | OnClick | Called when the cell is clicked. (Inherited from DataGridViewCell)
Protected Method | OnContentClick | Called when the cell's contents are clicked. (Inherited from DataGridViewCell)
Protected Method | OnContentDoubleClick | Called when the cell's contents are double-clicked. (Inherited from DataGridViewCell)
Protected Method | OnDataGridViewChanged | Overridden. Called when the DataGridView property of the cell changes.
Protected Method | OnDoubleClick | Called when the cell is double-clicked. (Inherited from DataGridViewCell)
Protected Method | OnEnter | Overridden.
Protected Method | OnKeyDown | Called when a character key is pressed while the focus is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnKeyPress | Called when a key is pressed while the focus is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnKeyUp | Called when a character key is released while the focus is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnLeave | Overridden.
Protected Method | OnMouseClick | Overridden.
Protected Method | OnMouseDoubleClick | Called when the user double-clicks a mouse button while the pointer is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseDown | Called when the user holds down a mouse button while the pointer is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseEnter | Overridden.
Protected Method | OnMouseLeave | Overridden.
Protected Method | OnMouseMove | Overridden.
Protected Method | OnMouseUp | Called when the user releases a mouse button while the pointer is on a cell. (Inherited from DataGridViewCell)
Protected Method | Paint | (Inherited from DataGridViewCell)
Protected Method | PaintErrorIcon | (Inherited from DataGridViewCell)
Protected Method | ProcessGatewayRequest | (Inherited from DataGridViewCell)
Protected Method | RaiseCellClick | Raises the DataGridView.CellClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellContentClick | Raises the DataGridView.CellContentClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellContentDoubleClick | Raises the DataGridView.CellContentDoubleClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellValueChanged | Raises the CellValueChanged event. (Inherited from DataGridViewElement)
Protected Method | RaiseDataError | Raises the DataError event. (Inherited from DataGridViewElement)
Protected Method | RaiseMouseWheel | Raises the MouseWheel event. (Inherited from DataGridViewElement)
Protected Method | RenderAttributes | Overridden.
Protected Method | RenderBackColorAttribute | Renders the back color attribute. (Inherited from DataGridViewCell)
Protected Method | RenderComponent | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from DataGridViewElement)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from DataGridViewElement)
Protected Method | RenderComponents | Overridden.
Protected Method | RenderForeColorAttribute | Renders the fore color attribute. (Inherited from DataGridViewCell)
Protected Method | RenderReadOnlyAttribute | Renders the read only attribute. (Inherited from DataGridViewCell)
Protected Method | RenderUpdatedAttributes | Renders the updated attributes (Inherited from DataGridViewElement)
Protected Method | RenderWrapModeAttribute | Renders the wrap mode attribute. (Inherited from DataGridViewCell)
Protected Method | SetValue | Sets the value of the cell. (Inherited from DataGridViewCell)
Protected Method | UpdateParams | Overloaded. Updates only the parameters of this instance. (Inherited from DataGridViewElement)
Top

See Also

Reference

DataGridViewComboBoxCell Class
Gizmox.WebGUI.Forms Namespace


Clone Method

[image]
Gizmox.WebGUI.Forms
Clone Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewComboBoxCell Class : Clone Method

Creates an exact copy of this cell.

Syntax

Visual Basic (Declaration)
Public Overrides Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewComboBoxCell
Dim value As Object

value = instance.Clone()
C#
public override object Clone()
Managed Extensions for C++
public: Object* Clone(); override
C++/CLI
public:
Object^ Clone(); override

Return Value

An Object that represents the cloned DataGridViewComboBoxCell.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewComboBoxCell Class
DataGridViewComboBoxCell Members


CollectionsEquals Method

[image]
Gizmox.WebGUI.Forms
CollectionsEquals Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewComboBoxCell Class : CollectionsEquals Method

objCollection1
The obj collection1.
objCollection2
The obj collection2.
Determines whether [is collections equals] [the specified obj collection1].

Syntax

Visual Basic (Declaration)
Protected Function CollectionsEquals( _
   ByVal objCollection1 As DataGridViewComboBoxCell.ObjectCollection, _
   ByVal objCollection2 As DataGridViewComboBoxCell.ObjectCollection _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewComboBoxCell
Dim objCollection1 As DataGridViewComboBoxCell.ObjectCollection
Dim objCollection2 As DataGridViewComboBoxCell.ObjectCollection
Dim value As Boolean

value = instance.CollectionsEquals(objCollection1, objCollection2)
C#
protected bool CollectionsEquals(
   DataGridViewComboBoxCell.ObjectCollection objCollection1,
   DataGridViewComboBoxCell.ObjectCollection objCollection2
)
Managed Extensions for C++
protected: bool CollectionsEquals(
   DataGridViewComboBoxCell.ObjectCollection* objCollection1,
   DataGridViewComboBoxCell.ObjectCollection* objCollection2
)
C++/CLI
protected:
bool CollectionsEquals(
   DataGridViewComboBoxCell::ObjectCollection^ objCollection1,
   DataGridViewComboBoxCell::ObjectCollection^ objCollection2
)

Parameters

objCollection1
The obj collection1.
objCollection2
The obj collection2.

Return Value

true if [is collections equals] [the specified obj collection1]; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewComboBoxCell Class
DataGridViewComboBoxCell Members


DetachEditingControl Method

[image]
Gizmox.WebGUI.Forms
DetachEditingControl Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewComboBoxCell Class : DetachEditingControl Method

Syntax

Visual Basic (Declaration)
Public Overrides Sub DetachEditingControl()
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewComboBoxCell

instance.DetachEditingControl()
C#
public override void DetachEditingControl()
Managed Extensions for C++
public: void DetachEditingControl(); override
C++/CLI
public:
void DetachEditingControl(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewComboBoxCell Class
DataGridViewComboBoxCell Members


GetFormattedValue Method

[image]
Gizmox.WebGUI.Forms
GetFormattedValue Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewComboBoxCell Class : GetFormattedValue Method

value
The value to be formatted.
rowIndex
The index of the cell's parent row.
cellStyle
The DataGridViewCellStyle in effect for the cell.
valueTypeConverter
A TypeConverter associated with the value type that provides custom conversion to the formatted value type, or null if no such custom conversion is needed.
formattedValueTypeConverter
A TypeConverter associated with the formatted value type that provides custom conversion from the value type, or null if no such custom conversion is needed.
context
A bitwise combination of DataGridViewDataErrorContexts values describing the context in which the formatted value is needed.
Gets the formatted value of the cell's data.

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetFormattedValue( _
   ByVal value As Object, _
   ByVal rowIndex As Integer, _
   ByRef cellStyle As DataGridViewCellStyle, _
   ByVal valueTypeConverter As TypeConverter, _
   ByVal formattedValueTypeConverter As TypeConverter, _
   ByVal context As DataGridViewDataErrorContexts _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewComboBoxCell
Dim value As Object
Dim rowIndex As Integer
Dim cellStyle As DataGridViewCellStyle
Dim valueTypeConverter As TypeConverter
Dim formattedValueTypeConverter As TypeConverter
Dim context As DataGridViewDataErrorContexts
Dim value As Object

value = instance.GetFormattedValue(value, rowIndex, cellStyle, valueTypeConverter, formattedValueTypeConverter, context)
C#
protected override object GetFormattedValue(
   object value,
   int rowIndex,
   ref DataGridViewCellStyle cellStyle,
   TypeConverter valueTypeConverter,
   TypeConverter formattedValueTypeConverter,
   DataGridViewDataErrorContexts context
)
Managed Extensions for C++
protected: Object* GetFormattedValue(
   Object* value,
   int rowIndex,
   ref DataGridViewCellStyle* cellStyle,
   TypeConverter* valueTypeConverter,
   TypeConverter* formattedValueTypeConverter,
   DataGridViewDataErrorContexts context
) override
C++/CLI
protected:
Object^ GetFormattedValue(
   Object^ value,
   int rowIndex,
   DataGridViewCellStyle^% cellStyle,
   TypeConverter^ valueTypeConverter,
   TypeConverter^ formattedValueTypeConverter,
   DataGridViewDataErrorContexts context
) override

Parameters

value
The value to be formatted.
rowIndex
The index of the cell's parent row.
cellStyle
The DataGridViewCellStyle in effect for the cell.
valueTypeConverter
A TypeConverter associated with the value type that provides custom conversion to the formatted value type, or null if no such custom conversion is needed.
formattedValueTypeConverter
A TypeConverter associated with the formatted value type that provides custom conversion from the value type, or null if no such custom conversion is needed.
context
A bitwise combination of DataGridViewDataErrorContexts values describing the context in which the formatted value is needed.

Return Value

The value of the cell's data after formatting has been applied or null if the cell is not part of a DataGridView control.

Exceptions

Exception | Description
Exception | Formatting failed and either there is no handler for the DataError event of the DataGridView control or the handler set the DataGridViewDataErrorEventArgs.ThrowException property to true. The exception object can typically be cast to type FormatException for type conversion errors or to type ArgumentException if value cannot be found in the DataSource or the Items collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewComboBoxCell Class
DataGridViewComboBoxCell Members


GetPreferredSize Method

[image]
Gizmox.WebGUI.Forms
GetPreferredSize Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewComboBoxCell Class : GetPreferredSize Method

Calculates the preferred size, in pixels, of the cell.

Overload List

Overload | Description
GetPreferredSize(Graphics,DataGridViewCellStyle,Int32,Size) | Calculates the preferred size, in pixels, of the cell.
GetPreferredSize(String,DataGridViewCellStyle) | Calculates the preferred size, in pixels, of the cell. (Inherited from DataGridViewCell)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewComboBoxCell Class
DataGridViewComboBoxCell Members


GetPreferredSize(Graphics,DataGridViewCellStyle,Int32,Size) Method

[image]
Gizmox.WebGUI.Forms
GetPreferredSize(Graphics,DataGridViewCellStyle,Int32,Size) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewComboBoxCell Class > GetPreferredSize Method : GetPreferredSize(Graphics,DataGridViewCellStyle,Int32,Size) Method

graphics
The Graphics used to draw the cell.
cellStyle
A DataGridViewCellStyle that represents the style of the cell.
rowIndex
The zero-based row index of the cell.
constraintSize
The cell's maximum allowable size.
Calculates the preferred size, in pixels, of the cell.

Syntax

Visual Basic (Declaration)
Protected Overloads Overrides Function GetPreferredSize( _
   ByVal graphics As Graphics, _
   ByVal cellStyle As DataGridViewCellStyle, _
   ByVal rowIndex As Integer, _
   ByVal constraintSize As Size _
) As Size
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewComboBoxCell
Dim graphics As Graphics
Dim cellStyle As DataGridViewCellStyle
Dim rowIndex As Integer
Dim constraintSize As Size
Dim value As Size

value = instance.GetPreferredSize(graphics, cellStyle, rowIndex, constraintSize)
C#
protected override Size GetPreferredSize(
   Graphics graphics,
   DataGridViewCellStyle cellStyle,
   int rowIndex,
   Size constraintSize
)
Managed Extensions for C++
protected: Size GetPreferredSize(
   Graphics* graphics,
   DataGridViewCellStyle* cellStyle,
   int rowIndex,
   Size constraintSize
) override
C++/CLI
protected:
Size GetPreferredSize(
   Graphics^ graphics,
   DataGridViewCellStyle^ cellStyle,
   int rowIndex,
   Size constraintSize
) override

Parameters

graphics
The Graphics used to draw the cell.
cellStyle
A DataGridViewCellStyle that represents the style of the cell.
rowIndex
The zero-based row index of the cell.
constraintSize
The cell's maximum allowable size.

Return Value

A Size that represents the preferred size, in pixels, of the cell.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewComboBoxCell Class
DataGridViewComboBoxCell Members
Overload List


InitializeEditingControl Method

[image]
Gizmox.WebGUI.Forms
InitializeEditingControl Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewComboBoxCell Class : InitializeEditingControl Method

rowIndex
The index of the cell's parent row.
initialFormattedValue
The initial value to be displayed in the control.
dataGridViewCellStyle
A DataGridViewCellStyle that determines the appearance of the hosted control.
Attaches and initializes the hosted editing control.

Syntax

Visual Basic (Declaration)
Public Overrides Sub InitializeEditingControl( _
   ByVal rowIndex As Integer, _
   ByVal initialFormattedValue As Object, _
   ByVal dataGridViewCellStyle As DataGridViewCellStyle _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewComboBoxCell
Dim rowIndex As Integer
Dim initialFormattedValue As Object
Dim dataGridViewCellStyle As DataGridViewCellStyle

instance.InitializeEditingControl(rowIndex, initialFormattedValue, dataGridViewCellStyle)
C#
public override void InitializeEditingControl(
   int rowIndex,
   object initialFormattedValue,
   DataGridViewCellStyle dataGridViewCellStyle
)
Managed Extensions for C++
public: void InitializeEditingControl(
   int rowIndex,
   Object* initialFormattedValue,
   DataGridViewCellStyle* dataGridViewCellStyle
) override
C++/CLI
public:
void InitializeEditingControl(
   int rowIndex,
   Object^ initialFormattedValue,
   DataGridViewCellStyle^ dataGridViewCellStyle
) override

Parameters

rowIndex
The index of the cell's parent row.
initialFormattedValue
The initial value to be displayed in the control.
dataGridViewCellStyle
A DataGridViewCellStyle that determines the appearance of the hosted control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewComboBoxCell Class
DataGridViewComboBoxCell Members


KeyEntersEditMode Method

[image]
Gizmox.WebGUI.Forms
KeyEntersEditMode Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewComboBoxCell Class : KeyEntersEditMode Method

e
A KeyEventArgs that represents the key that was pressed.
Determines if edit mode should be started based on the given key.

Syntax

Visual Basic (Declaration)
Public Overrides Function KeyEntersEditMode( _
   ByVal e As KeyEventArgs _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewComboBoxCell
Dim e As KeyEventArgs
Dim value As Boolean

value = instance.KeyEntersEditMode(e)
C#
public override bool KeyEntersEditMode(
   KeyEventArgs e
)
Managed Extensions for C++
public: bool KeyEntersEditMode(
   KeyEventArgs* e
) override
C++/CLI
public:
bool KeyEntersEditMode(
   KeyEventArgs^ e
) override

Parameters

e
A KeyEventArgs that represents the key that was pressed.

Return Value

true if edit mode should be started; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewComboBoxCell Class
DataGridViewComboBoxCell Members


OnDataGridViewChanged Method

[image]
Gizmox.WebGUI.Forms
OnDataGridViewChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewComboBoxCell Class : OnDataGridViewChanged Method

Called when the DataGridView property of the cell changes.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnDataGridViewChanged()
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewComboBoxCell

instance.OnDataGridViewChanged()
C#
protected override void OnDataGridViewChanged()
Managed Extensions for C++
protected: void OnDataGridViewChanged(); override
C++/CLI
protected:
void OnDataGridViewChanged(); override

Exceptions

Exception | Description
ArgumentException | The DataSource property is not null and the value of either the DisplayMember property or the ValueMember property is not null or Empty and does not name a valid property or column in the data source.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewComboBoxCell Class
DataGridViewComboBoxCell Members


OnEnter Method

[image]
Gizmox.WebGUI.Forms
OnEnter Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewComboBoxCell Class : OnEnter Method

rowIndex
throughMouseClick

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnEnter( _
   ByVal rowIndex As Integer, _
   ByVal throughMouseClick As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewComboBoxCell
Dim rowIndex As Integer
Dim throughMouseClick As Boolean

instance.OnEnter(rowIndex, throughMouseClick)
C#
protected override void OnEnter(
   int rowIndex,
   bool throughMouseClick
)
Managed Extensions for C++
protected: void OnEnter(
   int rowIndex,
   bool throughMouseClick
) override
C++/CLI
protected:
void OnEnter(
   int rowIndex,
   bool throughMouseClick
) override

Parameters

rowIndex
throughMouseClick

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewComboBoxCell Class
DataGridViewComboBoxCell Members


OnLeave Method

[image]
Gizmox.WebGUI.Forms
OnLeave Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewComboBoxCell Class : OnLeave Method

rowIndex
throughMouseClick

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnLeave( _
   ByVal rowIndex As Integer, _
   ByVal throughMouseClick As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewComboBoxCell
Dim rowIndex As Integer
Dim throughMouseClick As Boolean

instance.OnLeave(rowIndex, throughMouseClick)
C#
protected override void OnLeave(
   int rowIndex,
   bool throughMouseClick
)
Managed Extensions for C++
protected: void OnLeave(
   int rowIndex,
   bool throughMouseClick
) override
C++/CLI
protected:
void OnLeave(
   int rowIndex,
   bool throughMouseClick
) override

Parameters

rowIndex
throughMouseClick

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewComboBoxCell Class
DataGridViewComboBoxCell Members


OnMouseClick Method

[image]
Gizmox.WebGUI.Forms
OnMouseClick Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewComboBoxCell Class : OnMouseClick Method

e

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnMouseClick( _
   ByVal e As DataGridViewCellMouseEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewComboBoxCell
Dim e As DataGridViewCellMouseEventArgs

instance.OnMouseClick(e)
C#
protected override void OnMouseClick(
   DataGridViewCellMouseEventArgs e
)
Managed Extensions for C++
protected: void OnMouseClick(
   DataGridViewCellMouseEventArgs* e
) override
C++/CLI
protected:
void OnMouseClick(
   DataGridViewCellMouseEventArgs^ e
) override

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewComboBoxCell Class
DataGridViewComboBoxCell Members


OnMouseEnter Method

[image]
Gizmox.WebGUI.Forms
OnMouseEnter Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewComboBoxCell Class : OnMouseEnter Method

rowIndex

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnMouseEnter( _
   ByVal rowIndex As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewComboBoxCell
Dim rowIndex As Integer

instance.OnMouseEnter(rowIndex)
C#
protected override void OnMouseEnter(
   int rowIndex
)
Managed Extensions for C++
protected: void OnMouseEnter(
   int rowIndex
) override
C++/CLI
protected:
void OnMouseEnter(
   int rowIndex
) override

Parameters

rowIndex

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewComboBoxCell Class
DataGridViewComboBoxCell Members


OnMouseLeave Method

[image]
Gizmox.WebGUI.Forms
OnMouseLeave Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewComboBoxCell Class : OnMouseLeave Method

rowIndex

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnMouseLeave( _
   ByVal rowIndex As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewComboBoxCell
Dim rowIndex As Integer

instance.OnMouseLeave(rowIndex)
C#
protected override void OnMouseLeave(
   int rowIndex
)
Managed Extensions for C++
protected: void OnMouseLeave(
   int rowIndex
) override
C++/CLI
protected:
void OnMouseLeave(
   int rowIndex
) override

Parameters

rowIndex

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewComboBoxCell Class
DataGridViewComboBoxCell Members


OnMouseMove Method

[image]
Gizmox.WebGUI.Forms
OnMouseMove Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewComboBoxCell Class : OnMouseMove Method

e

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnMouseMove( _
   ByVal e As DataGridViewCellMouseEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewComboBoxCell
Dim e As DataGridViewCellMouseEventArgs

instance.OnMouseMove(e)
C#
protected override void OnMouseMove(
   DataGridViewCellMouseEventArgs e
)
Managed Extensions for C++
protected: void OnMouseMove(
   DataGridViewCellMouseEventArgs* e
) override
C++/CLI
protected:
void OnMouseMove(
   DataGridViewCellMouseEventArgs^ e
) override

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewComboBoxCell Class
DataGridViewComboBoxCell Members


ParseFormattedValue Method

[image]
Gizmox.WebGUI.Forms
ParseFormattedValue Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewComboBoxCell Class : ParseFormattedValue Method

formattedValue
cellStyle
formattedValueTypeConverter
valueTypeConverter

Syntax

Visual Basic (Declaration)
Public Overrides Function ParseFormattedValue( _
   ByVal formattedValue As Object, _
   ByVal cellStyle As DataGridViewCellStyle, _
   ByVal formattedValueTypeConverter As TypeConverter, _
   ByVal valueTypeConverter As TypeConverter _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewComboBoxCell
Dim formattedValue As Object
Dim cellStyle As DataGridViewCellStyle
Dim formattedValueTypeConverter As TypeConverter
Dim valueTypeConverter As TypeConverter
Dim value As Object

value = instance.ParseFormattedValue(formattedValue, cellStyle, formattedValueTypeConverter, valueTypeConverter)
C#
public override object ParseFormattedValue(
   object formattedValue,
   DataGridViewCellStyle cellStyle,
   TypeConverter formattedValueTypeConverter,
   TypeConverter valueTypeConverter
)
Managed Extensions for C++
public: Object* ParseFormattedValue(
   Object* formattedValue,
   DataGridViewCellStyle* cellStyle,
   TypeConverter* formattedValueTypeConverter,
   TypeConverter* valueTypeConverter
) override
C++/CLI
public:
Object^ ParseFormattedValue(
   Object^ formattedValue,
   DataGridViewCellStyle^ cellStyle,
   TypeConverter^ formattedValueTypeConverter,
   TypeConverter^ valueTypeConverter
) override

Parameters

formattedValue
cellStyle
formattedValueTypeConverter
valueTypeConverter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewComboBoxCell Class
DataGridViewComboBoxCell Members


RenderAttributes Method

[image]
Gizmox.WebGUI.Forms
RenderAttributes Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewComboBoxCell Class : RenderAttributes Method

objContext
objWriter
blnRenderOwner

Syntax

Visual Basic (Declaration)
Protected Overrides Sub RenderAttributes( _
   ByVal objContext As IContext, _
   ByVal objWriter As IAttributeWriter, _
   ByVal blnRenderOwner As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewComboBoxCell
Dim objContext As IContext
Dim objWriter As IAttributeWriter
Dim blnRenderOwner As Boolean

instance.RenderAttributes(objContext, objWriter, blnRenderOwner)
C#
protected override void RenderAttributes(
   IContext objContext,
   IAttributeWriter objWriter,
   bool blnRenderOwner
)
Managed Extensions for C++
protected: void RenderAttributes(
   IContext* objContext,
   IAttributeWriter* objWriter,
   bool blnRenderOwner
) override
C++/CLI
protected:
void RenderAttributes(
   IContext^ objContext,
   IAttributeWriter^ objWriter,
   bool blnRenderOwner
) override

Parameters

objContext
objWriter
blnRenderOwner

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewComboBoxCell Class
DataGridViewComboBoxCell Members


RenderComboboxItems Method

[image]
Gizmox.WebGUI.Forms
RenderComboboxItems Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewComboBoxCell Class : RenderComboboxItems Method

objContext
The obj context.
objWriter
The obj writer.
lngRequestID
The LNG request ID.
blnRenderOwner
if set to true [BLN render owner].
Renders the combobox items.

Syntax

Visual Basic (Declaration)
Public Sub RenderComboboxItems( _
   ByVal objContext As IContext, _
   ByVal objWriter As IResponseWriter, _
   ByVal lngRequestID As Long, _
   ByVal blnRenderOwner As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewComboBoxCell
Dim objContext As IContext
Dim objWriter As IResponseWriter
Dim lngRequestID As Long
Dim blnRenderOwner As Boolean

instance.RenderComboboxItems(objContext, objWriter, lngRequestID, blnRenderOwner)
C#
public void RenderComboboxItems(
   IContext objContext,
   IResponseWriter objWriter,
   long lngRequestID,
   bool blnRenderOwner
)
Managed Extensions for C++
public: void RenderComboboxItems(
   IContext* objContext,
   IResponseWriter* objWriter,
   long lngRequestID,
   bool blnRenderOwner
)
C++/CLI
public:
void RenderComboboxItems(
   IContext^ objContext,
   IResponseWriter^ objWriter,
   long long lngRequestID,
   bool blnRenderOwner
)

Parameters

objContext
The obj context.
objWriter
The obj writer.
lngRequestID
The LNG request ID.
blnRenderOwner
if set to true [BLN render owner].

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewComboBoxCell Class
DataGridViewComboBoxCell Members


RenderComponents Method

[image]
Gizmox.WebGUI.Forms
RenderComponents Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewComboBoxCell Class : RenderComponents Method

objContext
objWriter
lngRequestID
blnRenderOwner

Syntax

Visual Basic (Declaration)
Protected Overrides Sub RenderComponents( _
   ByVal objContext As IContext, _
   ByVal objWriter As IResponseWriter, _
   ByVal lngRequestID As Long, _
   ByVal blnRenderOwner As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewComboBoxCell
Dim objContext As IContext
Dim objWriter As IResponseWriter
Dim lngRequestID As Long
Dim blnRenderOwner As Boolean

instance.RenderComponents(objContext, objWriter, lngRequestID, blnRenderOwner)
C#
protected override void RenderComponents(
   IContext objContext,
   IResponseWriter objWriter,
   long lngRequestID,
   bool blnRenderOwner
)
Managed Extensions for C++
protected: void RenderComponents(
   IContext* objContext,
   IResponseWriter* objWriter,
   long lngRequestID,
   bool blnRenderOwner
) override
C++/CLI
protected:
void RenderComponents(
   IContext^ objContext,
   IResponseWriter^ objWriter,
   long long lngRequestID,
   bool blnRenderOwner
) override

Parameters

objContext
objWriter
lngRequestID
blnRenderOwner

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewComboBoxCell Class
DataGridViewComboBoxCell Members


ToString Method

[image]
Gizmox.WebGUI.Forms
ToString Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewComboBoxCell Class : ToString Method

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewComboBoxCell
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewComboBoxCell Class
DataGridViewComboBoxCell Members


DataGridViewComboBoxCell Class Properties

[image]
Gizmox.WebGUI.Forms
DataGridViewComboBoxCell Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewComboBoxCell Class

For a list of all members of this type, see DataGridViewComboBoxCell members.

Public Properties

 | Name | Description
Public Property | AutoComplete | Gets or sets a value indicating whether the cell will match the characters being entered in the cell with a selection from the drop-down list.
Public Property | ColumnIndex | Gets the column index for this cell. (Inherited from DataGridViewCell)
Public Property | ContentBounds | (Inherited from DataGridViewCell)
Public Property | DataGridView | Gets the DataGridView control associated with this element. (Inherited from DataGridViewElement)
Public Property | DataSource | Gets or sets the data source whose data contains the possible selections shown in the drop-down list.
Public Property | DefaultNewRowValue | Gets the default value for a cell in the row for new records. (Inherited from DataGridViewCell)
Public Property | Displayed | Gets a value that indicates whether the cell is currently displayed on-screen. (Inherited from DataGridViewCell)
Public Property | DisplayMember | Gets or sets a string that specifies where to gather selections to display in the drop-down list.
Public Property | DisplayStyle | Gets or sets a value that determines how the combo box is displayed when it is not in edit mode.
Public Property | DisplayStyleForCurrentCellOnly | Gets or sets a value that determines if the display style only applies to the current cell.
Public Property | DropDownWidth | Gets or sets the width of the of the drop-down list portion of a combo box.
Public Property | EditedFormattedValue | Gets the current, formatted value of the cell, regardless of whether the cell is in edit mode and the value has not been committed. (Inherited from DataGridViewCell)
Public Property | EditType | Overridden. Gets the type of the cell's hosted editing control.
Public Property | ErrorIconBounds | (Inherited from DataGridViewCell)
Public Property | ErrorText | Gets or sets the text describing an error condition associated with the cell. (Inherited from DataGridViewCell)
Public Property | FlatStyle | Gets or sets the flat style appearance of the cell.
Public Property | FormattedValue | Gets the value of the cell as formatted for display. (Inherited from DataGridViewCell)
Public Property | FormattedValueType | Overridden. Gets the class type of the formatted value associated with the cell.
Public Property | Frozen | Gets a value indicating whether the cell is frozen. (Inherited from DataGridViewCell)
Public Property | HasStyle | Gets a value indicating whether the DataGridViewCell.Style property has been set. (Inherited from DataGridViewCell)
Public Property | InheritedState | Gets the current state of the cell as inherited from the state of its row and column. (Inherited from DataGridViewCell)
Public Property | InheritedStyle | Gets the style currently applied to the cell. (Inherited from DataGridViewCell)
Public Property | IsInEditMode | Gets a value indicating whether this cell is currently being edited. (Inherited from DataGridViewCell)
Public Property | Items | Gets the objects that represent the selection displayed in the drop-down list.
Public Property | MaxDropDownItems | Gets or sets the maximum number of items shown in the drop-down list.
Public Property | OwningColumn | Gets the column that contains this cell. (Inherited from DataGridViewCell)
Public Property | OwningRow | Gets the row that contains this cell. (Inherited from DataGridViewCell)
Public Property | PreferredSize | Gets the size, in pixels, of a rectangular area into which the cell can fit. (Inherited from DataGridViewCell)
Public Property | ReadOnly | Gets or sets a value indicating whether the cell's data can be edited. (Inherited from DataGridViewCell)
Public Property | Resizable | Gets a value indicating whether the cell can be resized. (Inherited from DataGridViewCell)
Public Property | RowIndex | Gets the index of the cell's parent row. (Inherited from DataGridViewCell)
Public Property | Selected | Gets or sets a value indicating whether the cell has been selected. (Inherited from DataGridViewCell)
Public Property | Size | Gets the size of the cell. (Inherited from DataGridViewCell)
Public Property | Sorted | Gets or sets a value indicating whether the items in the combo box are automatically sorted.
Public Property | State | Gets the user interface (UI) state of the element. (Inherited from DataGridViewElement)
Public Property | Style | Gets or sets the style for the cell. (Inherited from DataGridViewCell)
Public Property | Tag | Gets or sets the object that contains supplemental data about the cell. (Inherited from DataGridViewCell)
Public Property | ToolTipText | Gets or sets the ToolTip text associated with this cell. (Inherited from DataGridViewCell)
Public Property | Value | Gets or sets the value associated with this cell. (Inherited from DataGridViewCell)
Public Property | ValueMember | Gets or sets a string that specifies where to gather the underlying values used in the drop-down list.
Public Property | ValueType | Overridden.
Public Property | Visible | Gets a value indicating whether the cell is in a row or column that has been hidden. (Inherited from DataGridViewCell)
Top

Protected Properties

 | Name | Description
Protected Property | MemberID | (Inherited from DataGridViewCell)
Protected Property | TagName | (Inherited from DataGridViewElement)
Top

See Also

Reference

DataGridViewComboBoxCell Class
Gizmox.WebGUI.Forms Namespace


AutoComplete Property

[image]
Gizmox.WebGUI.Forms
AutoComplete Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewComboBoxCell Class : AutoComplete Property

Gets or sets a value indicating whether the cell will match the characters being entered in the cell with a selection from the drop-down list.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Overridable Property AutoComplete As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewComboBoxCell
Dim value As Boolean

instance.AutoComplete = value

value = instance.AutoComplete
C#
[DefaultValueAttribute()]
public virtual bool AutoComplete {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property virtual bool get_AutoComplete();
public: __property virtual void set_AutoComplete(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
public:
virtual property bool AutoComplete {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewComboBoxCell Class
DataGridViewComboBoxCell Members


DataSource Property

[image]
Gizmox.WebGUI.Forms
DataSource Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewComboBoxCell Class : DataSource Property

Gets or sets the data source whose data contains the possible selections shown in the drop-down list.

Syntax

Visual Basic (Declaration)
Public Overridable Property DataSource As Object
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewComboBoxCell
Dim value As Object

instance.DataSource = value

value = instance.DataSource
C#
public virtual object DataSource {get; set;}
Managed Extensions for C++
public: __property virtual Object* get_DataSource();
public: __property virtual void set_DataSource(
   Object* value
);
C++/CLI
public:
virtual property Object^ DataSource {
   Object^ get();
   void set (Object^value);
}

Exceptions

Exception | Description
ArgumentException | The specified value when setting this property is not null and is not of type IList nor IListSource.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewComboBoxCell Class
DataGridViewComboBoxCell Members


DisplayMember Property

[image]
Gizmox.WebGUI.Forms
DisplayMember Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewComboBoxCell Class : DisplayMember Property

Gets or sets a string that specifies where to gather selections to display in the drop-down list.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Overridable Property DisplayMember As String
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewComboBoxCell
Dim value As String

instance.DisplayMember = value

value = instance.DisplayMember
C#
[DefaultValueAttribute()]
public virtual string DisplayMember {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property virtual string* get_DisplayMember();
public: __property virtual void set_DisplayMember(
   string* value
);
C++/CLI
[DefaultValueAttribute()]
public:
virtual property String^ DisplayMember {
   String^ get();
   void set (String^value);
}

Exceptions

Exception | Description
ArgumentException | The DataSource property is not null and the specified value when setting this property is not null or Empty and does not name a valid property or column in the data source.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewComboBoxCell Class
DataGridViewComboBoxCell Members


DisplayStyle Property

[image]
Gizmox.WebGUI.Forms
DisplayStyle Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewComboBoxCell Class : DisplayStyle Property

Gets or sets a value that determines how the combo box is displayed when it is not in edit mode.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property DisplayStyle As DataGridViewComboBoxDisplayStyle
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewComboBoxCell
Dim value As DataGridViewComboBoxDisplayStyle

instance.DisplayStyle = value

value = instance.DisplayStyle
C#
[DefaultValueAttribute()]
public DataGridViewComboBoxDisplayStyle DisplayStyle {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property DataGridViewComboBoxDisplayStyle get_DisplayStyle();
public: __property void set_DisplayStyle(
   DataGridViewComboBoxDisplayStyle value
);
C++/CLI
[DefaultValueAttribute()]
public:
property DataGridViewComboBoxDisplayStyle DisplayStyle {
   DataGridViewComboBoxDisplayStyle get();
   void set (DataGridViewComboBoxDisplayStylevalue);
}

Exceptions

Exception | Description
InvalidEnumArgumentException | The specified value when setting this property is not a valid DataGridViewComboBoxDisplayStyle value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewComboBoxCell Class
DataGridViewComboBoxCell Members


DisplayStyleForCurrentCellOnly Property

[image]
Gizmox.WebGUI.Forms
DisplayStyleForCurrentCellOnly Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewComboBoxCell Class : DisplayStyleForCurrentCellOnly Property

Gets or sets a value that determines if the display style only applies to the current cell.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property DisplayStyleForCurrentCellOnly As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewComboBoxCell
Dim value As Boolean

instance.DisplayStyleForCurrentCellOnly = value

value = instance.DisplayStyleForCurrentCellOnly
C#
[DefaultValueAttribute()]
public bool DisplayStyleForCurrentCellOnly {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property bool get_DisplayStyleForCurrentCellOnly();
public: __property void set_DisplayStyleForCurrentCellOnly(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
public:
property bool DisplayStyleForCurrentCellOnly {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewComboBoxCell Class
DataGridViewComboBoxCell Members


DropDownWidth Property

[image]
Gizmox.WebGUI.Forms
DropDownWidth Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewComboBoxCell Class : DropDownWidth Property

Gets or sets the width of the of the drop-down list portion of a combo box.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Overridable Property DropDownWidth As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewComboBoxCell
Dim value As Integer

instance.DropDownWidth = value

value = instance.DropDownWidth
C#
[DefaultValueAttribute()]
public virtual int DropDownWidth {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property virtual int get_DropDownWidth();
public: __property virtual void set_DropDownWidth(
   int value
);
C++/CLI
[DefaultValueAttribute()]
public:
virtual property int DropDownWidth {
   int get();
   void set (intvalue);
}

Exceptions

Exception | Description
ArgumentOutOfRangeException | The specified value is less than one.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewComboBoxCell Class
DataGridViewComboBoxCell Members


EditType Property

[image]
Gizmox.WebGUI.Forms
EditType Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewComboBoxCell Class : EditType Property

Gets the type of the cell's hosted editing control.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property EditType As Type
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewComboBoxCell
Dim value As Type

value = instance.EditType
C#
public override Type EditType {get;}
Managed Extensions for C++
public: __property Type* get_EditType() override;
C++/CLI
public:
property Type^ EditType {
   Type^ get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewComboBoxCell Class
DataGridViewComboBoxCell Members


FlatStyle Property

[image]
Gizmox.WebGUI.Forms
FlatStyle Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewComboBoxCell Class : FlatStyle Property

Gets or sets the flat style appearance of the cell.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property FlatStyle As FlatStyle
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewComboBoxCell
Dim value As FlatStyle

instance.FlatStyle = value

value = instance.FlatStyle
C#
[DefaultValueAttribute()]
public FlatStyle FlatStyle {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property FlatStyle get_FlatStyle();
public: __property void set_FlatStyle(
   FlatStyle value
);
C++/CLI
[DefaultValueAttribute()]
public:
property FlatStyle FlatStyle {
   FlatStyle get();
   void set (FlatStylevalue);
}

Exceptions

Exception | Description
InvalidEnumArgumentException | The specified value is not a valid FlatStyle value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewComboBoxCell Class
DataGridViewComboBoxCell Members


FormattedValueType Property

[image]
Gizmox.WebGUI.Forms
FormattedValueType Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewComboBoxCell Class : FormattedValueType Property

Gets the class type of the formatted value associated with the cell.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property FormattedValueType As Type
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewComboBoxCell
Dim value As Type

value = instance.FormattedValueType
C#
public override Type FormattedValueType {get;}
Managed Extensions for C++
public: __property Type* get_FormattedValueType() override;
C++/CLI
public:
property Type^ FormattedValueType {
   Type^ get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewComboBoxCell Class
DataGridViewComboBoxCell Members


Items Property

[image]
Gizmox.WebGUI.Forms
Items Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewComboBoxCell Class : Items Property

Gets the objects that represent the selection displayed in the drop-down list.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public Overridable ReadOnly Property Items As DataGridViewComboBoxCell.ObjectCollection
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewComboBoxCell
Dim value As DataGridViewComboBoxCell.ObjectCollection

value = instance.Items
C#
[BrowsableAttribute(false)]
public virtual DataGridViewComboBoxCell.ObjectCollection Items {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property virtual DataGridViewComboBoxCell.ObjectCollection* get_Items();
C++/CLI
[BrowsableAttribute(false)]
public:
virtual property DataGridViewComboBoxCell::ObjectCollection^ Items {
   DataGridViewComboBoxCell::ObjectCollection^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewComboBoxCell Class
DataGridViewComboBoxCell Members


MaxDropDownItems Property

[image]
Gizmox.WebGUI.Forms
MaxDropDownItems Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewComboBoxCell Class : MaxDropDownItems Property

Gets or sets the maximum number of items shown in the drop-down list.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Overridable Property MaxDropDownItems As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewComboBoxCell
Dim value As Integer

instance.MaxDropDownItems = value

value = instance.MaxDropDownItems
C#
[DefaultValueAttribute()]
public virtual int MaxDropDownItems {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property virtual int get_MaxDropDownItems();
public: __property virtual void set_MaxDropDownItems(
   int value
);
C++/CLI
[DefaultValueAttribute()]
public:
virtual property int MaxDropDownItems {
   int get();
   void set (intvalue);
}

Exceptions

Exception | Description
ArgumentOutOfRangeException | The value is less than 1 or greater than 100 when setting this property.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewComboBoxCell Class
DataGridViewComboBoxCell Members


Sorted Property

[image]
Gizmox.WebGUI.Forms
Sorted Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewComboBoxCell Class : Sorted Property

Gets or sets a value indicating whether the items in the combo box are automatically sorted.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Overridable Property Sorted As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewComboBoxCell
Dim value As Boolean

instance.Sorted = value

value = instance.Sorted
C#
[DefaultValueAttribute()]
public virtual bool Sorted {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property virtual bool get_Sorted();
public: __property virtual void set_Sorted(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
public:
virtual property bool Sorted {
   bool get();
   void set (boolvalue);
}

Exceptions

Exception | Description
ArgumentException | An attempt was made to sort a cell that is attached to a data source.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewComboBoxCell Class
DataGridViewComboBoxCell Members


ValueMember Property

[image]
Gizmox.WebGUI.Forms
ValueMember Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewComboBoxCell Class : ValueMember Property

Gets or sets a string that specifies where to gather the underlying values used in the drop-down list.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Overridable Property ValueMember As String
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewComboBoxCell
Dim value As String

instance.ValueMember = value

value = instance.ValueMember
C#
[DefaultValueAttribute()]
public virtual string ValueMember {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property virtual string* get_ValueMember();
public: __property virtual void set_ValueMember(
   string* value
);
C++/CLI
[DefaultValueAttribute()]
public:
virtual property String^ ValueMember {
   String^ get();
   void set (String^value);
}

Exceptions

Exception | Description
ArgumentException | The DataSource property is not null and the specified value when setting this property is not null or Empty and does not name a valid property or column in the data source.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewComboBoxCell Class
DataGridViewComboBoxCell Members


ValueType Property

[image]
Gizmox.WebGUI.Forms
ValueType Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewComboBoxCell Class : ValueType Property

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ValueType As Type
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewComboBoxCell
Dim value As Type

value = instance.ValueType
C#
public override Type ValueType {get;}
Managed Extensions for C++
public: __property Type* get_ValueType() override;
C++/CLI
public:
property Type^ ValueType {
   Type^ get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewComboBoxCell Class
DataGridViewComboBoxCell Members


DataGridViewComboBoxCell.ObjectCollection Class

[image]
Gizmox.WebGUI.Forms
DataGridViewComboBoxCell.ObjectCollection Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewComboBoxCell.ObjectCollection Class

Represents the collection of selection choices in a DataGridViewComboBoxCell.

Syntax

Visual Basic (Declaration)
<ListBindableAttribute(False)>
<DefaultMemberAttribute("Item")>
Public Class DataGridViewComboBoxCell.ObjectCollection
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewComboBoxCell.ObjectCollection
C#
[ListBindableAttribute(false)]
[DefaultMemberAttribute("Item")]
public class DataGridViewComboBoxCell.ObjectCollection
Managed Extensions for C++
[ListBindableAttribute(false)]
[DefaultMemberAttribute("Item")]
public __gc class DataGridViewComboBoxCell.ObjectCollection
C++/CLI
[ListBindableAttribute(false)]
[DefaultMemberAttribute("Item")]
public ref class DataGridViewComboBoxCell.ObjectCollection

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.DataGridViewComboBoxCell.ObjectCollection

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

DataGridViewComboBoxCell.ObjectCollection Members
Gizmox.WebGUI.Forms Namespace


DataGridViewComboBoxCell.ObjectCollection Class Members

[image]
Gizmox.WebGUI.Forms
DataGridViewComboBoxCell.ObjectCollection Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewComboBoxCell.ObjectCollection Class

The following tables list the members exposed by DataGridViewComboBoxCell.ObjectCollection.

Public Constructors

 | Name | Description
Public Constructor | DataGridViewComboBoxCell.ObjectCollection Constructor | Initializes a new instance of the DataGridViewComboBoxCell.ObjectCollection class.
Top

Public Properties

 | Name | Description
Public Property | Count | Gets the number of items in the collection.
Public Property | IsReadOnly | Gets a value indicating whether the collection is read-only.
Public Property | Item | Gets or sets the item at the current index location. In C#, this property is the indexer for the DataGridViewComboBoxCell.ObjectCollection class.
Top

Public Methods

 | Name | Description
Public Method | Add | Adds an item to the list of items for a DataGridViewComboBoxCell.
Public Method | AddRange | Overloaded. Adds one or more items to the list of items for a DataGridViewComboBoxCell.
Public Method | Clear | Clears all items from the collection.
Public Method | Contains | Determines whether the specified item is contained in the collection.
Public Method | CopyTo | Copies the entire collection into an existing array of objects at a specified location within the array.
Public Method | GetEnumerator | Returns an enumerator that can iterate through a DataGridViewComboBoxCell.ObjectCollection.
Public Method | IndexOf | Returns the index of the specified item in the collection.
Public Method | Insert | Inserts an item into the collection at the specified index.
Public Method | Remove | Removes the specified object from the collection.
Public Method | RemoveAt | Removes the object at the specified index.
Top

See Also

Reference

DataGridViewComboBoxCell.ObjectCollection Class
Gizmox.WebGUI.Forms Namespace


DataGridViewComboBoxCell.ObjectCollection Constructor

[image]
Gizmox.WebGUI.Forms
DataGridViewComboBoxCell.ObjectCollection Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewComboBoxCell.ObjectCollection Class : DataGridViewComboBoxCell.ObjectCollection Constructor

owner
The DataGridViewComboBoxCell that owns the collection.
Initializes a new instance of the DataGridViewComboBoxCell.ObjectCollection class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal owner As DataGridViewComboBoxCell _
)
Visual Basic (Usage) Copy Code
Dim owner As DataGridViewComboBoxCell

Dim instance As DataGridViewComboBoxCell.ObjectCollection(owner)
C#
public DataGridViewComboBoxCell.ObjectCollection(
   DataGridViewComboBoxCell owner
)
Managed Extensions for C++
public: DataGridViewComboBoxCell.ObjectCollection(
   DataGridViewComboBoxCell* owner
)
C++/CLI
public:
DataGridViewComboBoxCell.ObjectCollection(
   DataGridViewComboBoxCell^ owner
)

Parameters

owner
The DataGridViewComboBoxCell that owns the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewComboBoxCell.ObjectCollection Class
DataGridViewComboBoxCell.ObjectCollection Members


DataGridViewComboBoxCell.ObjectCollection Class Methods

[image]
Gizmox.WebGUI.Forms
DataGridViewComboBoxCell.ObjectCollection Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewComboBoxCell.ObjectCollection Class

For a list of all members of this type, see DataGridViewComboBoxCell.ObjectCollection members.

Public Methods

 | Name | Description
Public Method | Add | Adds an item to the list of items for a DataGridViewComboBoxCell.
Public Method | AddRange | Overloaded. Adds one or more items to the list of items for a DataGridViewComboBoxCell.
Public Method | Clear | Clears all items from the collection.
Public Method | Contains | Determines whether the specified item is contained in the collection.
Public Method | CopyTo | Copies the entire collection into an existing array of objects at a specified location within the array.
Public Method | GetEnumerator | Returns an enumerator that can iterate through a DataGridViewComboBoxCell.ObjectCollection.
Public Method | IndexOf | Returns the index of the specified item in the collection.
Public Method | Insert | Inserts an item into the collection at the specified index.
Public Method | Remove | Removes the specified object from the collection.
Public Method | RemoveAt | Removes the object at the specified index.
Top

See Also

Reference

DataGridViewComboBoxCell.ObjectCollection Class
Gizmox.WebGUI.Forms Namespace


Add Method

[image]
Gizmox.WebGUI.Forms
Add Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewComboBoxCell.ObjectCollection Class : Add Method

item
An object representing the item to add to the collection.
Adds an item to the list of items for a DataGridViewComboBoxCell.

Syntax

Visual Basic (Declaration)
Public Function Add( _
   ByVal item As Object _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewComboBoxCell.ObjectCollection
Dim item As Object
Dim value As Integer

value = instance.Add(item)
C#
public int Add(
   object item
)
Managed Extensions for C++
public: int Add(
   Object* item
)
C++/CLI
public:
int Add(
   Object^ item
)

Parameters

item
An object representing the item to add to the collection.

Return Value

The position into which the new element was inserted.

Exceptions

Exception | Description
ArgumentNullException | item is null.
ArgumentException | The cell's DataSource property value is not null.
InvalidOperationException | The cell is in a shared row.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewComboBoxCell.ObjectCollection Class
DataGridViewComboBoxCell.ObjectCollection Members


AddRange Method

[image]
Gizmox.WebGUI.Forms
AddRange Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewComboBoxCell.ObjectCollection Class : AddRange Method

Adds one or more items to the list of items for a DataGridViewComboBoxCell.

Overload List

Overload | Description
AddRange(Object[]) | Adds one or more items to the list of items for a DataGridViewComboBoxCell.
AddRange(ObjectCollection) | Adds the items of an existing DataGridViewComboBoxCell.ObjectCollection to the list of items in a DataGridViewComboBoxCell.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewComboBoxCell.ObjectCollection Class
DataGridViewComboBoxCell.ObjectCollection Members


AddRange(Object[]) Method

[image]
Gizmox.WebGUI.Forms
AddRange(Object[]) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewComboBoxCell.ObjectCollection Class > AddRange Method : AddRange(Object[]) Method

items
One or more objects that represent items for the drop-down list.-or-An Array of Object values.
Adds one or more items to the list of items for a DataGridViewComboBoxCell.

Syntax

Visual Basic (Declaration)
Public Overloads Sub AddRange( _
   ByVal ParamArray items() As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewComboBoxCell.ObjectCollection
Dim items() As Object

instance.AddRange(items)
C#
public void AddRange(
   params object[] items
)
Managed Extensions for C++
public: void AddRange(
   params Object*[]* items
)
C++/CLI
public:
void AddRange(
   ... array<Object^>^ items
)

Parameters

items
One or more objects that represent items for the drop-down list.-or-An Array of Object values.

Exceptions

Exception | Description
InvalidOperationException | One or more of the items in the items array is null.
ArgumentException | The cell's DataSource property value is not null.
InvalidOperationException | The cell is in a shared row.
ArgumentNullException | items is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewComboBoxCell.ObjectCollection Class
DataGridViewComboBoxCell.ObjectCollection Members
Overload List


AddRange(ObjectCollection) Method

[image]
Gizmox.WebGUI.Forms
AddRange(ObjectCollection) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewComboBoxCell.ObjectCollection Class > AddRange Method : AddRange(ObjectCollection) Method

value
The DataGridViewComboBoxCell.ObjectCollection to load into this collection.
Adds the items of an existing DataGridViewComboBoxCell.ObjectCollection to the list of items in a DataGridViewComboBoxCell.

Syntax

Visual Basic (Declaration)
Public Overloads Sub AddRange( _
   ByVal value As DataGridViewComboBoxCell.ObjectCollection _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewComboBoxCell.ObjectCollection
Dim value As DataGridViewComboBoxCell.ObjectCollection

instance.AddRange(value)
C#
public void AddRange(
   DataGridViewComboBoxCell.ObjectCollection value
)
Managed Extensions for C++
public: void AddRange(
   DataGridViewComboBoxCell.ObjectCollection* value
)
C++/CLI
public:
void AddRange(
   DataGridViewComboBoxCell::ObjectCollection^ value
)

Parameters

value
The DataGridViewComboBoxCell.ObjectCollection to load into this collection.

Exceptions

Exception | Description
ArgumentException | The cell's DataSource property value is not null.
InvalidOperationException | One or more of the items in the value collection is null.
InvalidOperationException | The cell is in a shared row.
ArgumentNullException | value is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewComboBoxCell.ObjectCollection Class
DataGridViewComboBoxCell.ObjectCollection Members
Overload List


Clear Method

[image]
Gizmox.WebGUI.Forms
Clear Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewComboBoxCell.ObjectCollection Class : Clear Method

Clears all items from the collection.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewComboBoxCell.ObjectCollection

instance.Clear()
C#
public void Clear()
Managed Extensions for C++
public: void Clear();
C++/CLI
public:
void Clear();

Exceptions

Exception | Description
InvalidOperationException | The collection contains at least one item and the cell is in a shared row.
ArgumentException | The collection contains at least one item and the cell's DataSource property value is not null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewComboBoxCell.ObjectCollection Class
DataGridViewComboBoxCell.ObjectCollection Members


Contains Method

[image]
Gizmox.WebGUI.Forms
Contains Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewComboBoxCell.ObjectCollection Class : Contains Method

value
An object representing the item to locate in the collection.
Determines whether the specified item is contained in the collection.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal value As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewComboBoxCell.ObjectCollection
Dim value As Object
Dim value As Boolean

value = instance.Contains(value)
C#
public bool Contains(
   object value
)
Managed Extensions for C++
public: bool Contains(
   Object* value
)
C++/CLI
public:
bool Contains(
   Object^ value
)

Parameters

value
An object representing the item to locate in the collection.

Return Value

true if the item is in the collection; otherwise, false.

Exceptions

Exception | Description
ArgumentNullException | value is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewComboBoxCell.ObjectCollection Class
DataGridViewComboBoxCell.ObjectCollection Members


CopyTo Method

[image]
Gizmox.WebGUI.Forms
CopyTo Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewComboBoxCell.ObjectCollection Class : CopyTo Method

destination
The destination array to which the contents will be copied.
arrayIndex
The index of the element in dest at which to start copying.
Copies the entire collection into an existing array of objects at a specified location within the array.

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal destination() As Object, _
   ByVal arrayIndex As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewComboBoxCell.ObjectCollection
Dim destination() As Object
Dim arrayIndex As Integer

instance.CopyTo(destination, arrayIndex)
C#
public void CopyTo(
   object[] destination,
   int arrayIndex
)
Managed Extensions for C++
public: void CopyTo(
   Object*[]* destination,
   int arrayIndex
)
C++/CLI
public:
void CopyTo(
   array<Object^>^ destination,
   int arrayIndex
)

Parameters

destination
The destination array to which the contents will be copied.
arrayIndex
The index of the element in dest at which to start copying.

Exceptions

Exception | Description
ArgumentNullException | destination is null.
ArgumentOutOfRangeException | arrayIndex is less than 0 or equal to or greater than the length of destination.-or-The number of elements in the DataGridViewComboBoxCell.ObjectCollection is greater than the available space from arrayIndex to the end of destination.
ArgumentException | destination is multidimensional.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewComboBoxCell.ObjectCollection Class
DataGridViewComboBoxCell.ObjectCollection Members


GetEnumerator Method

[image]
Gizmox.WebGUI.Forms
GetEnumerator Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewComboBoxCell.ObjectCollection Class : GetEnumerator Method

Returns an enumerator that can iterate through a DataGridViewComboBoxCell.ObjectCollection.

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewComboBoxCell.ObjectCollection
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Return Value

An enumerator of type IEnumerator.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewComboBoxCell.ObjectCollection Class
DataGridViewComboBoxCell.ObjectCollection Members


IndexOf Method

[image]
Gizmox.WebGUI.Forms
IndexOf Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewComboBoxCell.ObjectCollection Class : IndexOf Method

value
An object representing the item to locate in the collection.
Returns the index of the specified item in the collection.

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal value As Object _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewComboBoxCell.ObjectCollection
Dim value As Object
Dim value As Integer

value = instance.IndexOf(value)
C#
public int IndexOf(
   object value
)
Managed Extensions for C++
public: int IndexOf(
   Object* value
)
C++/CLI
public:
int IndexOf(
   Object^ value
)

Parameters

value
An object representing the item to locate in the collection.

Return Value

The zero-based index of the value parameter if it is found in the collection; otherwise, -1.

Exceptions

Exception | Description
ArgumentNullException | value is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewComboBoxCell.ObjectCollection Class
DataGridViewComboBoxCell.ObjectCollection Members


Insert Method

[image]
Gizmox.WebGUI.Forms
Insert Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewComboBoxCell.ObjectCollection Class : Insert Method

index
The zero-based index at which to place item within an unsorted DataGridViewComboBoxCell.
item
An object representing the item to insert.
Inserts an item into the collection at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal item As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewComboBoxCell.ObjectCollection
Dim index As Integer
Dim item As Object

instance.Insert(index, item)
C#
public void Insert(
   int index,
   object item
)
Managed Extensions for C++
public: void Insert(
   int index,
   Object* item
)
C++/CLI
public:
void Insert(
   int index,
   Object^ item
)

Parameters

index
The zero-based index at which to place item within an unsorted DataGridViewComboBoxCell.
item
An object representing the item to insert.

Exceptions

Exception | Description
ArgumentNullException | item is null.
ArgumentException | The cell's DataSource property value is not null.
ArgumentOutOfRangeException | index is less than 0 or greater than the number of items in the collection.
InvalidOperationException | The cell is in a shared row.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewComboBoxCell.ObjectCollection Class
DataGridViewComboBoxCell.ObjectCollection Members


Remove Method

[image]
Gizmox.WebGUI.Forms
Remove Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewComboBoxCell.ObjectCollection Class : Remove Method

value
An object representing the item to remove from the collection.
Removes the specified object from the collection.

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal value As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewComboBoxCell.ObjectCollection
Dim value As Object

instance.Remove(value)
C#
public void Remove(
   object value
)
Managed Extensions for C++
public: void Remove(
   Object* value
)
C++/CLI
public:
void Remove(
   Object^ value
)

Parameters

value
An object representing the item to remove from the collection.

Exceptions

Exception | Description
ArgumentException | The cell's DataSource property value is not null.
InvalidOperationException | The cell is in a shared row.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewComboBoxCell.ObjectCollection Class
DataGridViewComboBoxCell.ObjectCollection Members


RemoveAt Method

[image]
Gizmox.WebGUI.Forms
RemoveAt Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewComboBoxCell.ObjectCollection Class : RemoveAt Method

index
The zero-based index of the object to be removed.
Removes the object at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewComboBoxCell.ObjectCollection
Dim index As Integer

instance.RemoveAt(index)
C#
public void RemoveAt(
   int index
)
Managed Extensions for C++
public: void RemoveAt(
   int index
)
C++/CLI
public:
void RemoveAt(
   int index
)

Parameters

index
The zero-based index of the object to be removed.

Exceptions

Exception | Description
ArgumentException | The cell's DataSource property value is not null.
InvalidOperationException | The cell is in a shared row.
ArgumentOutOfRangeException | index is less than 0 or greater than the number of items in the collection minus one.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewComboBoxCell.ObjectCollection Class
DataGridViewComboBoxCell.ObjectCollection Members


DataGridViewComboBoxCell.ObjectCollection Class Properties

[image]
Gizmox.WebGUI.Forms
DataGridViewComboBoxCell.ObjectCollection Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewComboBoxCell.ObjectCollection Class

For a list of all members of this type, see DataGridViewComboBoxCell.ObjectCollection members.

Public Properties

 | Name | Description
Public Property | Count | Gets the number of items in the collection.
Public Property | IsReadOnly | Gets a value indicating whether the collection is read-only.
Public Property | Item | Gets or sets the item at the current index location. In C#, this property is the indexer for the DataGridViewComboBoxCell.ObjectCollection class.
Top

See Also

Reference

DataGridViewComboBoxCell.ObjectCollection Class
Gizmox.WebGUI.Forms Namespace


Count Property

[image]
Gizmox.WebGUI.Forms
Count Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewComboBoxCell.ObjectCollection Class : Count Property

Gets the number of items in the collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewComboBoxCell.ObjectCollection
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewComboBoxCell.ObjectCollection Class
DataGridViewComboBoxCell.ObjectCollection Members


IsReadOnly Property

[image]
Gizmox.WebGUI.Forms
IsReadOnly Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewComboBoxCell.ObjectCollection Class : IsReadOnly Property

Gets a value indicating whether the collection is read-only.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsReadOnly As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewComboBoxCell.ObjectCollection
Dim value As Boolean

value = instance.IsReadOnly
C#
public bool IsReadOnly {get;}
Managed Extensions for C++
public: __property bool get_IsReadOnly();
C++/CLI
public:
property bool IsReadOnly {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewComboBoxCell.ObjectCollection Class
DataGridViewComboBoxCell.ObjectCollection Members


Item Property

[image]
Gizmox.WebGUI.Forms
Item Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewComboBoxCell.ObjectCollection Class : Item Property

index
The zero-based index of the element to get or set.
Gets or sets the item at the current index location. In C#, this property is the indexer for the DataGridViewComboBoxCell.ObjectCollection class.

Syntax

Visual Basic (Declaration)
Public Overridable Default Property Item( _
   ByVal index As Integer _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewComboBoxCell.ObjectCollection
Dim index As Integer
Dim value As Object

instance.Item(index) = value

value = instance.Item(index)
C#
public virtual object this[
   int index
]; {get; set;}
Managed Extensions for C++
public: __property virtual Object* get_Item(
   int index
);
public: __property virtual void set_Item(
   int index,
   Object* value
);
C++/CLI
public:
virtual property Object^ default [int] {
   Object^ get(intindex);
   void set (intindex, Object^value);
}

Parameters

index
The zero-based index of the element to get or set.

Exceptions

Exception | Description
ArgumentException | When setting this property, the cell's DataSource property value is not null.
ArgumentNullException | The specified value when setting this property is null.
ArgumentOutOfRangeException | index is less than 0 or greater than the number of items in the collection minus one.
InvalidOperationException | When setting this property, the cell is in a shared row.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewComboBoxCell.ObjectCollection Class
DataGridViewComboBoxCell.ObjectCollection Members


DataGridViewComboBoxColumn Class

[image]
Gizmox.WebGUI.Forms
DataGridViewComboBoxColumn Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewComboBoxColumn Class

Represents a column of DataGridViewComboBoxCell objects.

Object Model

Syntax

Visual Basic (Declaration)
<DesignTimeControllerAttribute()>
<ClientControllerAttribute()>
<ToolboxBitmapAttribute()>
Public Class DataGridViewComboBoxColumn
   Inherits DataGridViewColumn
   Implements IRenderableComponentMember
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewComboBoxColumn
C#
[DesignTimeControllerAttribute()]
[ClientControllerAttribute()]
[ToolboxBitmapAttribute()]
public class DataGridViewComboBoxColumn : DataGridViewColumn, IRenderableComponentMember
Managed Extensions for C++
[DesignTimeControllerAttribute()]
[ClientControllerAttribute()]
[ToolboxBitmapAttribute()]
public __gc class DataGridViewComboBoxColumn : public DataGridViewColumn, IRenderableComponentMember
C++/CLI
[DesignTimeControllerAttribute()]
[ClientControllerAttribute()]
[ToolboxBitmapAttribute()]
public ref class DataGridViewComboBoxColumn : public DataGridViewColumn, IRenderableComponentMember

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.DataGridViewElement
Gizmox.WebGUI.Forms.DataGridViewBand
Gizmox.WebGUI.Forms.DataGridViewColumn
Gizmox.WebGUI.Forms.DataGridViewComboBoxColumn

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

DataGridViewComboBoxColumn Members
Gizmox.WebGUI.Forms Namespace


DataGridViewComboBoxColumn Class Members

[image]
Gizmox.WebGUI.Forms
DataGridViewComboBoxColumn Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewComboBoxColumn Class

The following tables list the members exposed by DataGridViewComboBoxColumn.

Public Constructors

 | Name | Description
Public Constructor | DataGridViewComboBoxColumn Constructor | Initializes a new instance of the DataGridViewTextBoxColumn class to the default state.
Top

Public Properties

 | Name | Description
Public Property | AutoComplete | Gets or sets a value indicating whether cells in the column will match the characters being entered in the cell with one from the possible selections.
Public Property | AutoSizeMode | Gets or sets the mode by which the column automatically adjusts its width. (Inherited from DataGridViewColumn)
Public Property | CellTemplate | Overridden. Gets or sets the template used to create cells.
Public Property | CellType | Gets the run-time type of the cell template. (Inherited from DataGridViewColumn)
Public Property | DataGridView | Gets the DataGridView control associated with this element. (Inherited from DataGridViewElement)
Public Property | DataPropertyName | Gets or sets the name of the data source property or database column to which the DataGridViewColumn is bound. (Inherited from DataGridViewColumn)
Public Property | DataSource | Gets or sets the data source that populates the selections for the combo boxes.
Public Property | DefaultCellStyle | Gets or sets the column's default cell style. (Inherited from DataGridViewColumn)
Public Property | DefaultHeaderCellType | Gets or sets the run-time type of the default header cell. (Inherited from DataGridViewBand)
Public Property | Displayed | Gets a value indicating whether the band is currently displayed onscreen. (Inherited from DataGridViewBand)
Public Property | DisplayIndex | Gets or sets the display order of the column relative to the currently displayed columns. (Inherited from DataGridViewColumn)
Public Property | DisplayMember | Gets or sets a string that specifies the property or column from which to retrieve strings for display in the combo boxes.
Public Property | DisplayStyle | Gets or sets a value that determines how the combo box is displayed when not editing.
Public Property | DisplayStyleForCurrentCellOnly | Gets or sets a value that determines if the display style only applies to the current cell.
Public Property | DividerWidth | Gets or sets the width, in pixels, of the column divider. (Inherited from DataGridViewColumn)
Public Property | DropDownWidth | Gets or sets the width of the drop-down lists of the combo boxes.
Public Property | FillWeight | Gets or sets a value that represents the width of the column when it is in fill mode relative to the widths of other fill-mode columns in the control. (Inherited from DataGridViewColumn)
Public Property | FlatStyle | Gets or sets the flat style appearance of the column's cells.
Public Property | Frozen | Gets or sets a value indicating whether a column will move when a user scrolls the DataGridView control horizontally. (Inherited from DataGridViewColumn)
Public Property | HasDefaultCellStyle | Gets a value indicating whether the DataGridViewBand.DefaultCellStyle property has been set. (Inherited from DataGridViewBand)
Public Property | HeaderCell | Gets or sets the DataGridViewColumnHeaderCell that represents the column header. (Inherited from DataGridViewColumn)
Public Property | HeaderText | Gets or sets the caption text on the column's header cell. (Inherited from DataGridViewColumn)
Public Property | Index | Gets the relative position of the band within the DataGridView control. (Inherited from DataGridViewBand)
Public Property | InheritedAutoSizeMode | Gets the sizing mode in effect for the column. (Inherited from DataGridViewColumn)
Public Property | InheritedStyle | Gets the cell style currently applied to the column. (Inherited from DataGridViewColumn)
Public Property | IsDataBound | Gets a value indicating whether the column is bound to a data source. (Inherited from DataGridViewColumn)
Public Property | Items | Gets the collection of objects used as selections in the combo boxes.
Public Property | MaxDropDownItems | Gets or sets the maximum number of items in the drop-down list of the cells in the column.
Public Property | MinimumWidth | Gets or sets the minimum width, in pixels, of the column. (Inherited from DataGridViewColumn)
Public Property | Name | Gets or sets the name of the column. (Inherited from DataGridViewColumn)
Public Property | ReadOnly | Gets or sets a value indicating whether the user can edit the column's cells. (Inherited from DataGridViewColumn)
Public Property | Resizable | Gets or sets a value indicating whether the column is resizable. (Inherited from DataGridViewColumn)
Public Property | Selected | Gets or sets a value indicating whether the band is in a selected user interface (UI) state. (Inherited from DataGridViewBand)
Public Property | Site | Gets or sets the site of the column. (Inherited from DataGridViewColumn)
Public Property | Sorted | Gets or sets a value indicating whether the items in the combo box are sorted.
Public Property | SortMode | Gets or sets the sort mode for the column. (Inherited from DataGridViewColumn)
Public Property | State | Gets the user interface (UI) state of the element. (Inherited from DataGridViewElement)
Public Property | Tag | Gets or sets the object that contains data to associate with the band. (Inherited from DataGridViewBand)
Public Property | ToolTipText | Gets or sets the text used for ToolTips. (Inherited from DataGridViewColumn)
Public Property | ValueMember | Gets or sets a string that specifies the property or column from which to get values that correspond to the selections in the drop-down list.
Public Property | ValueType | Gets or sets the data type of the values in the column's cells. (Inherited from DataGridViewColumn)
Public Property | Visible | Gets or sets a value indicating whether the column is visible. (Inherited from DataGridViewColumn)
Public Property | Width | Gets or sets the current width of the column. (Inherited from DataGridViewColumn)
Top

Protected Properties

 | Name | Description
Protected Property | HeaderCellCore | Gets or sets the header cell of the DataGridViewBand. (Inherited from DataGridViewBand)
Protected Property | IsRow | Gets a value indicating whether the band represents a row. (Inherited from DataGridViewBand)
Protected Property | MemberID | (Inherited from DataGridViewColumn)
Protected Property | TagName | (Inherited from DataGridViewElement)
Protected Property | TypeName | Overridden.
Top

Public Methods

 | Name | Description
Public Method | Clone | Overridden.
Public Method | Dispose | Overloaded. Releases all resources used by the DataGridViewBand. (Inherited from DataGridViewBand)
Public Method | GetPreferredWidth | Calculates the ideal width of the column based on the specified criteria. (Inherited from DataGridViewColumn)
Public Method | ToString | Overridden.
Public Method | Update | Overloaded. Full updates of this instance. (Inherited from DataGridViewElement)
Top

Protected Methods

 | Name | Description
Protected Method | CloneInternal | (Inherited from DataGridViewColumn)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from DataGridViewElement)
Protected Method | IsDirty | Determines whether the specified component is dirty. (Inherited from DataGridViewElement)
Protected Method | IsDirtyAttributes | Overloaded. Determines whether the specified component is dirty. (Inherited from DataGridViewElement)
Protected Method | OnDataGridViewChanged | Called when the band is associated with a different DataGridView. (Inherited from DataGridViewBand)
Protected Method | RaiseCellClick | Raises the DataGridView.CellClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellContentClick | Raises the DataGridView.CellContentClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellContentDoubleClick | Raises the DataGridView.CellContentDoubleClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellValueChanged | Raises the CellValueChanged event. (Inherited from DataGridViewElement)
Protected Method | RaiseDataError | Raises the DataError event. (Inherited from DataGridViewElement)
Protected Method | RaiseMouseWheel | Raises the MouseWheel event. (Inherited from DataGridViewElement)
Protected Method | RenderAttributes | (Inherited from DataGridViewColumn)
Protected Method | RenderComponent | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from DataGridViewElement)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from DataGridViewElement)
Protected Method | RenderComponents | Overridden.
Protected Method | RenderUpdatedAttributes | Renders the updated attributes (Inherited from DataGridViewElement)
Protected Method | UpdateParams | Overloaded. Updates only the parameters of this instance. (Inherited from DataGridViewElement)
Top

Public Events

 | Name | Description
Public Event | Disposed | Occurs when the DataGridViewColumn is disposed. (Inherited from DataGridViewColumn)
Top

See Also

Reference

DataGridViewComboBoxColumn Class
Gizmox.WebGUI.Forms Namespace


DataGridViewComboBoxColumn Constructor

[image]
Gizmox.WebGUI.Forms
DataGridViewComboBoxColumn Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewComboBoxColumn Class : DataGridViewComboBoxColumn Constructor

Initializes a new instance of the DataGridViewTextBoxColumn class to the default state.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewComboBoxColumn()
C#
public DataGridViewComboBoxColumn()
Managed Extensions for C++
public: DataGridViewComboBoxColumn();
C++/CLI
public:
DataGridViewComboBoxColumn();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewComboBoxColumn Class
DataGridViewComboBoxColumn Members


DataGridViewComboBoxColumn Class Methods

[image]
Gizmox.WebGUI.Forms
DataGridViewComboBoxColumn Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewComboBoxColumn Class

For a list of all members of this type, see DataGridViewComboBoxColumn members.

Public Methods

 | Name | Description
Public Method | Clone | Overridden.
Public Method | Dispose | Overloaded. Releases all resources used by the DataGridViewBand. (Inherited from DataGridViewBand)
Public Method | GetPreferredWidth | Calculates the ideal width of the column based on the specified criteria. (Inherited from DataGridViewColumn)
Public Method | ToString | Overridden.
Public Method | Update | Overloaded. Full updates of this instance. (Inherited from DataGridViewElement)
Top

Protected Methods

 | Name | Description
Protected Method | CloneInternal | (Inherited from DataGridViewColumn)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from DataGridViewElement)
Protected Method | IsDirty | Determines whether the specified component is dirty. (Inherited from DataGridViewElement)
Protected Method | IsDirtyAttributes | Overloaded. Determines whether the specified component is dirty. (Inherited from DataGridViewElement)
Protected Method | OnDataGridViewChanged | Called when the band is associated with a different DataGridView. (Inherited from DataGridViewBand)
Protected Method | RaiseCellClick | Raises the DataGridView.CellClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellContentClick | Raises the DataGridView.CellContentClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellContentDoubleClick | Raises the DataGridView.CellContentDoubleClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellValueChanged | Raises the CellValueChanged event. (Inherited from DataGridViewElement)
Protected Method | RaiseDataError | Raises the DataError event. (Inherited from DataGridViewElement)
Protected Method | RaiseMouseWheel | Raises the MouseWheel event. (Inherited from DataGridViewElement)
Protected Method | RenderAttributes | (Inherited from DataGridViewColumn)
Protected Method | RenderComponent | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from DataGridViewElement)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from DataGridViewElement)
Protected Method | RenderComponents | Overridden.
Protected Method | RenderUpdatedAttributes | Renders the updated attributes (Inherited from DataGridViewElement)
Protected Method | UpdateParams | Overloaded. Updates only the parameters of this instance. (Inherited from DataGridViewElement)
Top

See Also

Reference

DataGridViewComboBoxColumn Class
Gizmox.WebGUI.Forms Namespace


Clone Method

[image]
Gizmox.WebGUI.Forms
Clone Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewComboBoxColumn Class : Clone Method

Syntax

Visual Basic (Declaration)
Public Overrides Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewComboBoxColumn
Dim value As Object

value = instance.Clone()
C#
public override object Clone()
Managed Extensions for C++
public: Object* Clone(); override
C++/CLI
public:
Object^ Clone(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewComboBoxColumn Class
DataGridViewComboBoxColumn Members


RenderComponents Method

[image]
Gizmox.WebGUI.Forms
RenderComponents Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewComboBoxColumn Class : RenderComponents Method

objContext
objWriter
lngRequestID
blnRenderOwner

Syntax

Visual Basic (Declaration)
Protected Overrides Sub RenderComponents( _
   ByVal objContext As IContext, _
   ByVal objWriter As IResponseWriter, _
   ByVal lngRequestID As Long, _
   ByVal blnRenderOwner As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewComboBoxColumn
Dim objContext As IContext
Dim objWriter As IResponseWriter
Dim lngRequestID As Long
Dim blnRenderOwner As Boolean

instance.RenderComponents(objContext, objWriter, lngRequestID, blnRenderOwner)
C#
protected override void RenderComponents(
   IContext objContext,
   IResponseWriter objWriter,
   long lngRequestID,
   bool blnRenderOwner
)
Managed Extensions for C++
protected: void RenderComponents(
   IContext* objContext,
   IResponseWriter* objWriter,
   long lngRequestID,
   bool blnRenderOwner
) override
C++/CLI
protected:
void RenderComponents(
   IContext^ objContext,
   IResponseWriter^ objWriter,
   long long lngRequestID,
   bool blnRenderOwner
) override

Parameters

objContext
objWriter
lngRequestID
blnRenderOwner

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewComboBoxColumn Class
DataGridViewComboBoxColumn Members


ToString Method

[image]
Gizmox.WebGUI.Forms
ToString Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewComboBoxColumn Class : ToString Method

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewComboBoxColumn
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewComboBoxColumn Class
DataGridViewComboBoxColumn Members


DataGridViewComboBoxColumn Class Properties

[image]
Gizmox.WebGUI.Forms
DataGridViewComboBoxColumn Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewComboBoxColumn Class

For a list of all members of this type, see DataGridViewComboBoxColumn members.

Public Properties

 | Name | Description
Public Property | AutoComplete | Gets or sets a value indicating whether cells in the column will match the characters being entered in the cell with one from the possible selections.
Public Property | AutoSizeMode | Gets or sets the mode by which the column automatically adjusts its width. (Inherited from DataGridViewColumn)
Public Property | CellTemplate | Overridden. Gets or sets the template used to create cells.
Public Property | CellType | Gets the run-time type of the cell template. (Inherited from DataGridViewColumn)
Public Property | DataGridView | Gets the DataGridView control associated with this element. (Inherited from DataGridViewElement)
Public Property | DataPropertyName | Gets or sets the name of the data source property or database column to which the DataGridViewColumn is bound. (Inherited from DataGridViewColumn)
Public Property | DataSource | Gets or sets the data source that populates the selections for the combo boxes.
Public Property | DefaultCellStyle | Gets or sets the column's default cell style. (Inherited from DataGridViewColumn)
Public Property | DefaultHeaderCellType | Gets or sets the run-time type of the default header cell. (Inherited from DataGridViewBand)
Public Property | Displayed | Gets a value indicating whether the band is currently displayed onscreen. (Inherited from DataGridViewBand)
Public Property | DisplayIndex | Gets or sets the display order of the column relative to the currently displayed columns. (Inherited from DataGridViewColumn)
Public Property | DisplayMember | Gets or sets a string that specifies the property or column from which to retrieve strings for display in the combo boxes.
Public Property | DisplayStyle | Gets or sets a value that determines how the combo box is displayed when not editing.
Public Property | DisplayStyleForCurrentCellOnly | Gets or sets a value that determines if the display style only applies to the current cell.
Public Property | DividerWidth | Gets or sets the width, in pixels, of the column divider. (Inherited from DataGridViewColumn)
Public Property | DropDownWidth | Gets or sets the width of the drop-down lists of the combo boxes.
Public Property | FillWeight | Gets or sets a value that represents the width of the column when it is in fill mode relative to the widths of other fill-mode columns in the control. (Inherited from DataGridViewColumn)
Public Property | FlatStyle | Gets or sets the flat style appearance of the column's cells.
Public Property | Frozen | Gets or sets a value indicating whether a column will move when a user scrolls the DataGridView control horizontally. (Inherited from DataGridViewColumn)
Public Property | HasDefaultCellStyle | Gets a value indicating whether the DataGridViewBand.DefaultCellStyle property has been set. (Inherited from DataGridViewBand)
Public Property | HeaderCell | Gets or sets the DataGridViewColumnHeaderCell that represents the column header. (Inherited from DataGridViewColumn)
Public Property | HeaderText | Gets or sets the caption text on the column's header cell. (Inherited from DataGridViewColumn)
Public Property | Index | Gets the relative position of the band within the DataGridView control. (Inherited from DataGridViewBand)
Public Property | InheritedAutoSizeMode | Gets the sizing mode in effect for the column. (Inherited from DataGridViewColumn)
Public Property | InheritedStyle | Gets the cell style currently applied to the column. (Inherited from DataGridViewColumn)
Public Property | IsDataBound | Gets a value indicating whether the column is bound to a data source. (Inherited from DataGridViewColumn)
Public Property | Items | Gets the collection of objects used as selections in the combo boxes.
Public Property | MaxDropDownItems | Gets or sets the maximum number of items in the drop-down list of the cells in the column.
Public Property | MinimumWidth | Gets or sets the minimum width, in pixels, of the column. (Inherited from DataGridViewColumn)
Public Property | Name | Gets or sets the name of the column. (Inherited from DataGridViewColumn)
Public Property | ReadOnly | Gets or sets a value indicating whether the user can edit the column's cells. (Inherited from DataGridViewColumn)
Public Property | Resizable | Gets or sets a value indicating whether the column is resizable. (Inherited from DataGridViewColumn)
Public Property | Selected | Gets or sets a value indicating whether the band is in a selected user interface (UI) state. (Inherited from DataGridViewBand)
Public Property | Site | Gets or sets the site of the column. (Inherited from DataGridViewColumn)
Public Property | Sorted | Gets or sets a value indicating whether the items in the combo box are sorted.
Public Property | SortMode | Gets or sets the sort mode for the column. (Inherited from DataGridViewColumn)
Public Property | State | Gets the user interface (UI) state of the element. (Inherited from DataGridViewElement)
Public Property | Tag | Gets or sets the object that contains data to associate with the band. (Inherited from DataGridViewBand)
Public Property | ToolTipText | Gets or sets the text used for ToolTips. (Inherited from DataGridViewColumn)
Public Property | ValueMember | Gets or sets a string that specifies the property or column from which to get values that correspond to the selections in the drop-down list.
Public Property | ValueType | Gets or sets the data type of the values in the column's cells. (Inherited from DataGridViewColumn)
Public Property | Visible | Gets or sets a value indicating whether the column is visible. (Inherited from DataGridViewColumn)
Public Property | Width | Gets or sets the current width of the column. (Inherited from DataGridViewColumn)
Top

Protected Properties

 | Name | Description
Protected Property | HeaderCellCore | Gets or sets the header cell of the DataGridViewBand. (Inherited from DataGridViewBand)
Protected Property | IsRow | Gets a value indicating whether the band represents a row. (Inherited from DataGridViewBand)
Protected Property | MemberID | (Inherited from DataGridViewColumn)
Protected Property | TagName | (Inherited from DataGridViewElement)
Protected Property | TypeName | Overridden.
Top

See Also

Reference

DataGridViewComboBoxColumn Class
Gizmox.WebGUI.Forms Namespace


AutoComplete Property

[image]
Gizmox.WebGUI.Forms
AutoComplete Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewComboBoxColumn Class : AutoComplete Property

Gets or sets a value indicating whether cells in the column will match the characters being entered in the cell with one from the possible selections.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(True)>
<SRDescriptionAttribute("Indicates whether cells in the column will match the characters being entered in the cell with one from the possible selections. ")>
<DefaultValueAttribute()>
<SRCategoryAttribute("Behavior")>
Public Property AutoComplete As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewComboBoxColumn
Dim value As Boolean

instance.AutoComplete = value

value = instance.AutoComplete
C#
[BrowsableAttribute(true)]
[SRDescriptionAttribute("Indicates whether cells in the column will match the characters being entered in the cell with one from the possible selections. ")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
public bool AutoComplete {get; set;}
Managed Extensions for C++
[BrowsableAttribute(true)]
[SRDescriptionAttribute("Indicates whether cells in the column will match the characters being entered in the cell with one from the possible selections. ")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
public: __property bool get_AutoComplete();
public: __property void set_AutoComplete(
   bool value
);
C++/CLI
[BrowsableAttribute(true)]
[SRDescriptionAttribute("Indicates whether cells in the column will match the characters being entered in the cell with one from the possible selections. ")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
public:
property bool AutoComplete {
   bool get();
   void set (boolvalue);
}

Exceptions

Exception | Description
InvalidOperationException | The value of the CellTemplate property is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewComboBoxColumn Class
DataGridViewComboBoxColumn Members


CellTemplate Property

[image]
Gizmox.WebGUI.Forms
CellTemplate Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewComboBoxColumn Class : CellTemplate Property

Gets or sets the template used to create cells.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public Overrides Property CellTemplate As DataGridViewCell
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewComboBoxColumn
Dim value As DataGridViewCell

instance.CellTemplate = value

value = instance.CellTemplate
C#
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public override DataGridViewCell CellTemplate {get; set;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property DataGridViewCell* get_CellTemplate() override;
public: __property void set_CellTemplate(
   DataGridViewCell* value
) override;
C++/CLI
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
property DataGridViewCell^ CellTemplate {
   DataGridViewCell^ get() override;
   void set (DataGridViewCell^value) override;
}

Exceptions

Exception | Description
InvalidCastException | When setting this property to a value that is not of type DataGridViewComboBoxCell.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewComboBoxColumn Class
DataGridViewComboBoxColumn Members


DataSource Property

[image]
Gizmox.WebGUI.Forms
DataSource Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewComboBoxColumn Class : DataSource Property

Gets or sets the data source that populates the selections for the combo boxes.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<RefreshPropertiesAttribute()>
<AttributeProviderAttribute(TypeName="Gizmox.WebGUI.Forms.Binding+IDataSourceAttributeProvider, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d", PropertyName="")>
<SRDescriptionAttribute("Indicates the source of data for the DataGridView control.")>
<SRCategoryAttribute("Data")>
Public Property DataSource As Object
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewComboBoxColumn
Dim value As Object

instance.DataSource = value

value = instance.DataSource
C#
[DefaultValueAttribute()]
[RefreshPropertiesAttribute()]
[AttributeProviderAttribute(TypeName="Gizmox.WebGUI.Forms.Binding+IDataSourceAttributeProvider, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d", PropertyName="")]
[SRDescriptionAttribute("Indicates the source of data for the DataGridView control.")]
[SRCategoryAttribute("Data")]
public object DataSource {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[RefreshPropertiesAttribute()]
[AttributeProviderAttribute(TypeName="Gizmox.WebGUI.Forms.Binding+IDataSourceAttributeProvider, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d", PropertyName="")]
[SRDescriptionAttribute("Indicates the source of data for the DataGridView control.")]
[SRCategoryAttribute("Data")]
public: __property Object* get_DataSource();
public: __property void set_DataSource(
   Object* value
);
C++/CLI
[DefaultValueAttribute()]
[RefreshPropertiesAttribute()]
[AttributeProviderAttribute(TypeName="Gizmox.WebGUI.Forms.Binding+IDataSourceAttributeProvider, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d", PropertyName="")]
[SRDescriptionAttribute("Indicates the source of data for the DataGridView control.")]
[SRCategoryAttribute("Data")]
public:
property Object^ DataSource {
   Object^ get();
   void set (Object^value);
}

Exceptions

Exception | Description
InvalidOperationException | The value of the CellTemplate property is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewComboBoxColumn Class
DataGridViewComboBoxColumn Members


DisplayMember Property

[image]
Gizmox.WebGUI.Forms
DisplayMember Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewComboBoxColumn Class : DisplayMember Property

Gets or sets a string that specifies the property or column from which to retrieve strings for display in the combo boxes.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.DataMemberFieldEditor, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<SRDescriptionAttribute("A string that specifies the property or column from which to retrieve strings for display in the combo boxes.")>
<TypeConverterAttribute("System.Windows.Forms.Design.DataMemberFieldConverter, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<SRCategoryAttribute("Data")>
Public Property DisplayMember As String
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewComboBoxColumn
Dim value As String

instance.DisplayMember = value

value = instance.DisplayMember
C#
[DefaultValueAttribute()]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.DataMemberFieldEditor, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[SRDescriptionAttribute("A string that specifies the property or column from which to retrieve strings for display in the combo boxes.")]
[TypeConverterAttribute("System.Windows.Forms.Design.DataMemberFieldConverter, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[SRCategoryAttribute("Data")]
public string DisplayMember {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.DataMemberFieldEditor, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[SRDescriptionAttribute("A string that specifies the property or column from which to retrieve strings for display in the combo boxes.")]
[TypeConverterAttribute("System.Windows.Forms.Design.DataMemberFieldConverter, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[SRCategoryAttribute("Data")]
public: __property string* get_DisplayMember();
public: __property void set_DisplayMember(
   string* value
);
C++/CLI
[DefaultValueAttribute()]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.DataMemberFieldEditor, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[SRDescriptionAttribute("A string that specifies the property or column from which to retrieve strings for display in the combo boxes.")]
[TypeConverterAttribute("System.Windows.Forms.Design.DataMemberFieldConverter, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[SRCategoryAttribute("Data")]
public:
property String^ DisplayMember {
   String^ get();
   void set (String^value);
}

Exceptions

Exception | Description
InvalidOperationException | The value of the CellTemplate property is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewComboBoxColumn Class
DataGridViewComboBoxColumn Members


DisplayStyle Property

[image]
Gizmox.WebGUI.Forms
DisplayStyle Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewComboBoxColumn Class : DisplayStyle Property

Gets or sets a value that determines how the combo box is displayed when not editing.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<SRDescriptionAttribute("Determines how the combo box is displayed when not editing.")>
<SRCategoryAttribute("Appearance")>
Public Property DisplayStyle As DataGridViewComboBoxDisplayStyle
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewComboBoxColumn
Dim value As DataGridViewComboBoxDisplayStyle

instance.DisplayStyle = value

value = instance.DisplayStyle
C#
[DefaultValueAttribute()]
[SRDescriptionAttribute("Determines how the combo box is displayed when not editing.")]
[SRCategoryAttribute("Appearance")]
public DataGridViewComboBoxDisplayStyle DisplayStyle {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[SRDescriptionAttribute("Determines how the combo box is displayed when not editing.")]
[SRCategoryAttribute("Appearance")]
public: __property DataGridViewComboBoxDisplayStyle get_DisplayStyle();
public: __property void set_DisplayStyle(
   DataGridViewComboBoxDisplayStyle value
);
C++/CLI
[DefaultValueAttribute()]
[SRDescriptionAttribute("Determines how the combo box is displayed when not editing.")]
[SRCategoryAttribute("Appearance")]
public:
property DataGridViewComboBoxDisplayStyle DisplayStyle {
   DataGridViewComboBoxDisplayStyle get();
   void set (DataGridViewComboBoxDisplayStylevalue);
}

Exceptions

Exception | Description
InvalidOperationException | The value of the CellTemplate property is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewComboBoxColumn Class
DataGridViewComboBoxColumn Members


DisplayStyleForCurrentCellOnly Property

[image]
Gizmox.WebGUI.Forms
DisplayStyleForCurrentCellOnly Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewComboBoxColumn Class : DisplayStyleForCurrentCellOnly Property

Gets or sets a value that determines if the display style only applies to the current cell.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Indicates if the display style only applies to the current cell.")>
<DefaultValueAttribute()>
<SRCategoryAttribute("Appearance")>
Public Property DisplayStyleForCurrentCellOnly As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewComboBoxColumn
Dim value As Boolean

instance.DisplayStyleForCurrentCellOnly = value

value = instance.DisplayStyleForCurrentCellOnly
C#
[SRDescriptionAttribute("Indicates if the display style only applies to the current cell.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
public bool DisplayStyleForCurrentCellOnly {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Indicates if the display style only applies to the current cell.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
public: __property bool get_DisplayStyleForCurrentCellOnly();
public: __property void set_DisplayStyleForCurrentCellOnly(
   bool value
);
C++/CLI
[SRDescriptionAttribute("Indicates if the display style only applies to the current cell.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
public:
property bool DisplayStyleForCurrentCellOnly {
   bool get();
   void set (boolvalue);
}

Exceptions

Exception | Description
InvalidOperationException | The value of the CellTemplate property is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewComboBoxColumn Class
DataGridViewComboBoxColumn Members


DropDownWidth Property

[image]
Gizmox.WebGUI.Forms
DropDownWidth Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewComboBoxColumn Class : DropDownWidth Property

Gets or sets the width of the drop-down lists of the combo boxes.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("The width of the drop-down lists of the combo boxes.")>
<SRCategoryAttribute("Behavior")>
<DefaultValueAttribute()>
Public Property DropDownWidth As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewComboBoxColumn
Dim value As Integer

instance.DropDownWidth = value

value = instance.DropDownWidth
C#
[SRDescriptionAttribute("The width of the drop-down lists of the combo boxes.")]
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
public int DropDownWidth {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("The width of the drop-down lists of the combo boxes.")]
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
public: __property int get_DropDownWidth();
public: __property void set_DropDownWidth(
   int value
);
C++/CLI
[SRDescriptionAttribute("The width of the drop-down lists of the combo boxes.")]
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
public:
property int DropDownWidth {
   int get();
   void set (intvalue);
}

Exceptions

Exception | Description
InvalidOperationException | The value of the CellTemplate property is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewComboBoxColumn Class
DataGridViewComboBoxColumn Members


FlatStyle Property

[image]
Gizmox.WebGUI.Forms
FlatStyle Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewComboBoxColumn Class : FlatStyle Property

Gets or sets the flat style appearance of the column's cells.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<SRDescriptionAttribute("The flat style appearance of the column's cells.")>
<SRCategoryAttribute("Appearance")>
Public Property FlatStyle As FlatStyle
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewComboBoxColumn
Dim value As FlatStyle

instance.FlatStyle = value

value = instance.FlatStyle
C#
[DefaultValueAttribute()]
[SRDescriptionAttribute("The flat style appearance of the column's cells.")]
[SRCategoryAttribute("Appearance")]
public FlatStyle FlatStyle {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[SRDescriptionAttribute("The flat style appearance of the column's cells.")]
[SRCategoryAttribute("Appearance")]
public: __property FlatStyle get_FlatStyle();
public: __property void set_FlatStyle(
   FlatStyle value
);
C++/CLI
[DefaultValueAttribute()]
[SRDescriptionAttribute("The flat style appearance of the column's cells.")]
[SRCategoryAttribute("Appearance")]
public:
property FlatStyle FlatStyle {
   FlatStyle get();
   void set (FlatStylevalue);
}

Exceptions

Exception | Description
InvalidOperationException | The value of the CellTemplate property is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewComboBoxColumn Class
DataGridViewComboBoxColumn Members


Items Property

[image]
Gizmox.WebGUI.Forms
Items Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewComboBoxColumn Class : Items Property

Gets the collection of objects used as selections in the combo boxes.

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
<SRDescriptionAttribute("The collection of objects used as selections in the combo boxes.")>
<EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.StringCollectionEditor, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<SRCategoryAttribute("Data")>
Public ReadOnly Property Items As DataGridViewComboBoxCell.ObjectCollection
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewComboBoxColumn
Dim value As DataGridViewComboBoxCell.ObjectCollection

value = instance.Items
C#
[DesignerSerializationVisibilityAttribute()]
[SRDescriptionAttribute("The collection of objects used as selections in the combo boxes.")]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.StringCollectionEditor, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[SRCategoryAttribute("Data")]
public DataGridViewComboBoxCell.ObjectCollection Items {get;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
[SRDescriptionAttribute("The collection of objects used as selections in the combo boxes.")]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.StringCollectionEditor, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[SRCategoryAttribute("Data")]
public: __property DataGridViewComboBoxCell.ObjectCollection* get_Items();
C++/CLI
[DesignerSerializationVisibilityAttribute()]
[SRDescriptionAttribute("The collection of objects used as selections in the combo boxes.")]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.StringCollectionEditor, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[SRCategoryAttribute("Data")]
public:
property DataGridViewComboBoxCell::ObjectCollection^ Items {
   DataGridViewComboBoxCell::ObjectCollection^ get();
}

Exceptions

Exception | Description
InvalidOperationException | The value of the CellTemplate property is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewComboBoxColumn Class
DataGridViewComboBoxColumn Members


MaxDropDownItems Property

[image]
Gizmox.WebGUI.Forms
MaxDropDownItems Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewComboBoxColumn Class : MaxDropDownItems Property

Gets or sets the maximum number of items in the drop-down list of the cells in the column.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<SRCategoryAttribute("Behavior")>
<SRDescriptionAttribute("The maximum number of items in the drop-down list of the cells in the column.")>
Public Property MaxDropDownItems As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewComboBoxColumn
Dim value As Integer

instance.MaxDropDownItems = value

value = instance.MaxDropDownItems
C#
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("The maximum number of items in the drop-down list of the cells in the column.")]
public int MaxDropDownItems {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("The maximum number of items in the drop-down list of the cells in the column.")]
public: __property int get_MaxDropDownItems();
public: __property void set_MaxDropDownItems(
   int value
);
C++/CLI
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("The maximum number of items in the drop-down list of the cells in the column.")]
public:
property int MaxDropDownItems {
   int get();
   void set (intvalue);
}

Exceptions

Exception | Description
InvalidOperationException | The value of the CellTemplate property is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewComboBoxColumn Class
DataGridViewComboBoxColumn Members


Sorted Property

[image]
Gizmox.WebGUI.Forms
Sorted Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewComboBoxColumn Class : Sorted Property

Gets or sets a value indicating whether the items in the combo box are sorted.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Indicates whether the items in the combo box are sorted.")>
<DefaultValueAttribute()>
<SRCategoryAttribute("Behavior")>
Public Property Sorted As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewComboBoxColumn
Dim value As Boolean

instance.Sorted = value

value = instance.Sorted
C#
[SRDescriptionAttribute("Indicates whether the items in the combo box are sorted.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
public bool Sorted {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Indicates whether the items in the combo box are sorted.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
public: __property bool get_Sorted();
public: __property void set_Sorted(
   bool value
);
C++/CLI
[SRDescriptionAttribute("Indicates whether the items in the combo box are sorted.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
public:
property bool Sorted {
   bool get();
   void set (boolvalue);
}

Exceptions

Exception | Description
InvalidOperationException | The value of the CellTemplate property is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewComboBoxColumn Class
DataGridViewComboBoxColumn Members


TypeName Property

[image]
Gizmox.WebGUI.Forms
TypeName Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewComboBoxColumn Class : TypeName Property

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property TypeName As String
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewComboBoxColumn
Dim value As String

value = instance.TypeName
C#
protected override string TypeName {get;}
Managed Extensions for C++
protected: __property string* get_TypeName() override;
C++/CLI
protected:
property String^ TypeName {
   String^ get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewComboBoxColumn Class
DataGridViewComboBoxColumn Members


ValueMember Property

[image]
Gizmox.WebGUI.Forms
ValueMember Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewComboBoxColumn Class : ValueMember Property

Gets or sets a string that specifies the property or column from which to get values that correspond to the selections in the drop-down list.

Syntax

Visual Basic (Declaration)
<EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.DataMemberFieldEditor, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<DefaultValueAttribute()>
<SRCategoryAttribute("Data")>
<TypeConverterAttribute("System.Windows.Forms.Design.DataMemberFieldConverter, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<SRDescriptionAttribute("A string that specifies the property or column from which to get values that correspond to the selections in the drop-down list.")>
Public Property ValueMember As String
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewComboBoxColumn
Dim value As String

instance.ValueMember = value

value = instance.ValueMember
C#
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.DataMemberFieldEditor, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Data")]
[TypeConverterAttribute("System.Windows.Forms.Design.DataMemberFieldConverter, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[SRDescriptionAttribute("A string that specifies the property or column from which to get values that correspond to the selections in the drop-down list.")]
public string ValueMember {get; set;}
Managed Extensions for C++
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.DataMemberFieldEditor, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Data")]
[TypeConverterAttribute("System.Windows.Forms.Design.DataMemberFieldConverter, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[SRDescriptionAttribute("A string that specifies the property or column from which to get values that correspond to the selections in the drop-down list.")]
public: __property string* get_ValueMember();
public: __property void set_ValueMember(
   string* value
);
C++/CLI
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.DataMemberFieldEditor, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Data")]
[TypeConverterAttribute("System.Windows.Forms.Design.DataMemberFieldConverter, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[SRDescriptionAttribute("A string that specifies the property or column from which to get values that correspond to the selections in the drop-down list.")]
public:
property String^ ValueMember {
   String^ get();
   void set (String^value);
}

Exceptions

Exception | Description
InvalidOperationException | The value of the CellTemplate property is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewComboBoxColumn Class
DataGridViewComboBoxColumn Members


DataGridViewDataErrorEventArgs Class

[image]
Gizmox.WebGUI.Forms
DataGridViewDataErrorEventArgs Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewDataErrorEventArgs Class

Provides data for the DataError event.

Syntax

Visual Basic (Declaration)
Public Class DataGridViewDataErrorEventArgs
   Inherits DataGridViewCellCancelEventArgs
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewDataErrorEventArgs
C#
public class DataGridViewDataErrorEventArgs : DataGridViewCellCancelEventArgs
Managed Extensions for C++
public __gc class DataGridViewDataErrorEventArgs : public DataGridViewCellCancelEventArgs
C++/CLI
public ref class DataGridViewDataErrorEventArgs : public DataGridViewCellCancelEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
System.ComponentModel.CancelEventArgs
Gizmox.WebGUI.Forms.DataGridViewCellCancelEventArgs
Gizmox.WebGUI.Forms.DataGridViewDataErrorEventArgs

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

DataGridViewDataErrorEventArgs Members
Gizmox.WebGUI.Forms Namespace


DataGridViewDataErrorEventArgs Class Members

[image]
Gizmox.WebGUI.Forms
DataGridViewDataErrorEventArgs Class Members
See Also Properties Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewDataErrorEventArgs Class

The following tables list the members exposed by DataGridViewDataErrorEventArgs.

Public Constructors

 | Name | Description
Public Constructor | DataGridViewDataErrorEventArgs Constructor | Initializes a new instance of the DataGridViewDataErrorEventArgs class.
Top

Public Properties

 | Name | Description
Public Property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from System.ComponentModel.CancelEventArgs)
Public Property | ColumnIndex | Gets the column index of the cell that the event occurs for. (Inherited from DataGridViewCellCancelEventArgs)
Public Property | Context | Gets details about the state of the DataGridView when the error occurred.
Public Property | Exception | Gets the exception that represents the error.
Public Property | RowIndex | Gets the row index of the cell that the event occurs for. (Inherited from DataGridViewCellCancelEventArgs)
Public Property | ThrowException | Gets or sets a value indicating whether to throw the exception after the __Delegates.DataGridViewDataErrorEventHandler delegate is finished with it.
Top

See Also

Reference

DataGridViewDataErrorEventArgs Class
Gizmox.WebGUI.Forms Namespace


DataGridViewDataErrorEventArgs Constructor

[image]
Gizmox.WebGUI.Forms
DataGridViewDataErrorEventArgs Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewDataErrorEventArgs Class : DataGridViewDataErrorEventArgs Constructor

exception
The exception that occurred.
columnIndex
The column index of the cell that raised the DataError.
rowIndex
The row index of the cell that raised the DataError.
context
A bitwise combination of DataGridViewDataErrorContexts values indicating the context in which the error occurred.
Initializes a new instance of the DataGridViewDataErrorEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal exception As Exception, _
   ByVal columnIndex As Integer, _
   ByVal rowIndex As Integer, _
   ByVal context As DataGridViewDataErrorContexts _
)
Visual Basic (Usage) Copy Code
Dim exception As Exception
Dim columnIndex As Integer
Dim rowIndex As Integer
Dim context As DataGridViewDataErrorContexts

Dim instance As DataGridViewDataErrorEventArgs(exception, columnIndex, rowIndex, context)
C#
public DataGridViewDataErrorEventArgs(
   Exception exception,
   int columnIndex,
   int rowIndex,
   DataGridViewDataErrorContexts context
)
Managed Extensions for C++
public: DataGridViewDataErrorEventArgs(
   Exception* exception,
   int columnIndex,
   int rowIndex,
   DataGridViewDataErrorContexts context
)
C++/CLI
public:
DataGridViewDataErrorEventArgs(
   Exception^ exception,
   int columnIndex,
   int rowIndex,
   DataGridViewDataErrorContexts context
)

Parameters

exception
The exception that occurred.
columnIndex
The column index of the cell that raised the DataError.
rowIndex
The row index of the cell that raised the DataError.
context
A bitwise combination of DataGridViewDataErrorContexts values indicating the context in which the error occurred.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewDataErrorEventArgs Class
DataGridViewDataErrorEventArgs Members


DataGridViewDataErrorEventArgs Class Properties

[image]
Gizmox.WebGUI.Forms
DataGridViewDataErrorEventArgs Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewDataErrorEventArgs Class

For a list of all members of this type, see DataGridViewDataErrorEventArgs members.

Public Properties

 | Name | Description
Public Property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from System.ComponentModel.CancelEventArgs)
Public Property | ColumnIndex | Gets the column index of the cell that the event occurs for. (Inherited from DataGridViewCellCancelEventArgs)
Public Property | Context | Gets details about the state of the DataGridView when the error occurred.
Public Property | Exception | Gets the exception that represents the error.
Public Property | RowIndex | Gets the row index of the cell that the event occurs for. (Inherited from DataGridViewCellCancelEventArgs)
Public Property | ThrowException | Gets or sets a value indicating whether to throw the exception after the __Delegates.DataGridViewDataErrorEventHandler delegate is finished with it.
Top

See Also

Reference

DataGridViewDataErrorEventArgs Class
Gizmox.WebGUI.Forms Namespace


Context Property

[image]
Gizmox.WebGUI.Forms
Context Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewDataErrorEventArgs Class : Context Property

Gets details about the state of the DataGridView when the error occurred.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Context As DataGridViewDataErrorContexts
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewDataErrorEventArgs
Dim value As DataGridViewDataErrorContexts

value = instance.Context
C#
public DataGridViewDataErrorContexts Context {get;}
Managed Extensions for C++
public: __property DataGridViewDataErrorContexts get_Context();
C++/CLI
public:
property DataGridViewDataErrorContexts Context {
   DataGridViewDataErrorContexts get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewDataErrorEventArgs Class
DataGridViewDataErrorEventArgs Members


Exception Property

[image]
Gizmox.WebGUI.Forms
Exception Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewDataErrorEventArgs Class : Exception Property

Gets the exception that represents the error.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Exception As Exception
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewDataErrorEventArgs
Dim value As Exception

value = instance.Exception
C#
public Exception Exception {get;}
Managed Extensions for C++
public: __property Exception* get_Exception();
C++/CLI
public:
property Exception^ Exception {
   Exception^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewDataErrorEventArgs Class
DataGridViewDataErrorEventArgs Members


ThrowException Property

[image]
Gizmox.WebGUI.Forms
ThrowException Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewDataErrorEventArgs Class : ThrowException Property

Gets or sets a value indicating whether to throw the exception after the __Delegates.DataGridViewDataErrorEventHandler delegate is finished with it.

Syntax

Visual Basic (Declaration)
Public Property ThrowException As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewDataErrorEventArgs
Dim value As Boolean

instance.ThrowException = value

value = instance.ThrowException
C#
public bool ThrowException {get; set;}
Managed Extensions for C++
public: __property bool get_ThrowException();
public: __property void set_ThrowException(
   bool value
);
C++/CLI
public:
property bool ThrowException {
   bool get();
   void set (boolvalue);
}

Exceptions

Exception | Description
ArgumentException | When setting this property to true, the Exception property value is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewDataErrorEventArgs Class
DataGridViewDataErrorEventArgs Members


DataGridViewEditingControlShowingEventArgs Class

[image]
Gizmox.WebGUI.Forms
DataGridViewEditingControlShowingEventArgs Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewEditingControlShowingEventArgs Class

Provides data for the EditingControlShowing event.

Object Model

Syntax

Visual Basic (Declaration)
Public Class DataGridViewEditingControlShowingEventArgs
   Inherits EventArgs
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewEditingControlShowingEventArgs
C#
public class DataGridViewEditingControlShowingEventArgs : EventArgs
Managed Extensions for C++
public __gc class DataGridViewEditingControlShowingEventArgs : public EventArgs
C++/CLI
public ref class DataGridViewEditingControlShowingEventArgs : public EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gizmox.WebGUI.Forms.DataGridViewEditingControlShowingEventArgs

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

DataGridViewEditingControlShowingEventArgs Members
Gizmox.WebGUI.Forms Namespace


DataGridViewEditingControlShowingEventArgs Class Members

[image]
Gizmox.WebGUI.Forms
DataGridViewEditingControlShowingEventArgs Class Members
See Also Properties Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewEditingControlShowingEventArgs Class

The following tables list the members exposed by DataGridViewEditingControlShowingEventArgs.

Public Constructors

 | Name | Description
Public Constructor | DataGridViewEditingControlShowingEventArgs Constructor | Initializes a new instance of the DataGridViewEditingControlShowingEventArgs class.
Top

Public Properties

 | Name | Description
Public Property | CellStyle | Gets or sets the cell style of the edited cell.
Public Property | Control | The control shown to the user for editing the selected cell's value.
Top

See Also

Reference

DataGridViewEditingControlShowingEventArgs Class
Gizmox.WebGUI.Forms Namespace


DataGridViewEditingControlShowingEventArgs Constructor

[image]
Gizmox.WebGUI.Forms
DataGridViewEditingControlShowingEventArgs Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewEditingControlShowingEventArgs Class : DataGridViewEditingControlShowingEventArgs Constructor

control
A Control in which the user will edit the selected cell's contents.
cellStyle
A DataGridViewCellStyle representing the style of the cell being edited.
Initializes a new instance of the DataGridViewEditingControlShowingEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal control As Control, _
   ByVal cellStyle As DataGridViewCellStyle _
)
Visual Basic (Usage) Copy Code
Dim control As Control
Dim cellStyle As DataGridViewCellStyle

Dim instance As DataGridViewEditingControlShowingEventArgs(control, cellStyle)
C#
public DataGridViewEditingControlShowingEventArgs(
   Control control,
   DataGridViewCellStyle cellStyle
)
Managed Extensions for C++
public: DataGridViewEditingControlShowingEventArgs(
   Control* control,
   DataGridViewCellStyle* cellStyle
)
C++/CLI
public:
DataGridViewEditingControlShowingEventArgs(
   Control^ control,
   DataGridViewCellStyle^ cellStyle
)

Parameters

control
A Control in which the user will edit the selected cell's contents.
cellStyle
A DataGridViewCellStyle representing the style of the cell being edited.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewEditingControlShowingEventArgs Class
DataGridViewEditingControlShowingEventArgs Members


DataGridViewEditingControlShowingEventArgs Class Properties

[image]
Gizmox.WebGUI.Forms
DataGridViewEditingControlShowingEventArgs Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewEditingControlShowingEventArgs Class

For a list of all members of this type, see DataGridViewEditingControlShowingEventArgs members.

Public Properties

 | Name | Description
Public Property | CellStyle | Gets or sets the cell style of the edited cell.
Public Property | Control | The control shown to the user for editing the selected cell's value.
Top

See Also

Reference

DataGridViewEditingControlShowingEventArgs Class
Gizmox.WebGUI.Forms Namespace


CellStyle Property

[image]
Gizmox.WebGUI.Forms
CellStyle Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewEditingControlShowingEventArgs Class : CellStyle Property

Gets or sets the cell style of the edited cell.

Syntax

Visual Basic (Declaration)
Public Property CellStyle As DataGridViewCellStyle
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewEditingControlShowingEventArgs
Dim value As DataGridViewCellStyle

instance.CellStyle = value

value = instance.CellStyle
C#
public DataGridViewCellStyle CellStyle {get; set;}
Managed Extensions for C++
public: __property DataGridViewCellStyle* get_CellStyle();
public: __property void set_CellStyle(
   DataGridViewCellStyle* value
);
C++/CLI
public:
property DataGridViewCellStyle^ CellStyle {
   DataGridViewCellStyle^ get();
   void set (DataGridViewCellStyle^value);
}

Exceptions

Exception | Description
ArgumentNullException | The specified value when setting this property is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewEditingControlShowingEventArgs Class
DataGridViewEditingControlShowingEventArgs Members


Control Property

[image]
Gizmox.WebGUI.Forms
Control Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewEditingControlShowingEventArgs Class : Control Property

The control shown to the user for editing the selected cell's value.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Control As Control
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewEditingControlShowingEventArgs
Dim value As Control

value = instance.Control
C#
public Control Control {get;}
Managed Extensions for C++
public: __property Control* get_Control();
C++/CLI
public:
property Control^ Control {
   Control^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewEditingControlShowingEventArgs Class
DataGridViewEditingControlShowingEventArgs Members


DataGridViewElement Class

[image]
Gizmox.WebGUI.Forms
DataGridViewElement Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewElement Class

Provides the base class for elements of a DataGridView control.

Object Model

Syntax

Visual Basic (Declaration)
Public Class DataGridViewElement
   Implements IRenderableComponentMember
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewElement
C#
public class DataGridViewElement : IRenderableComponentMember
Managed Extensions for C++
public __gc class DataGridViewElement : public IRenderableComponentMember
C++/CLI
public ref class DataGridViewElement : public IRenderableComponentMember

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.DataGridViewElement
Gizmox.WebGUI.Forms.DataGridViewBand
Gizmox.WebGUI.Forms.DataGridViewCell

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

DataGridViewElement Members
Gizmox.WebGUI.Forms Namespace


DataGridViewElement Class Members

[image]
Gizmox.WebGUI.Forms
DataGridViewElement Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewElement Class

The following tables list the members exposed by DataGridViewElement.

Public Constructors

 | Name | Description
Public Constructor | DataGridViewElement Constructor | Initializes a new instance of the DataGridViewElement class.
Top

Public Properties

 | Name | Description
Public Property | DataGridView | Gets the DataGridView control associated with this element.
Public Property | State | Gets the user interface (UI) state of the element.
Top

Protected Properties

 | Name | Description
Protected Property | MemberID |
Protected Property | TagName |
Top

Public Methods

 | Name | Description
Public Method | Update | Overloaded. Full updates of this instance.
Top

Protected Methods

 | Name | Description
Protected Method | GetCriticalEvents | Gets the critical events.
Protected Method | IsDirty | Determines whether the specified component is dirty.
Protected Method | IsDirtyAttributes | Overloaded. Determines whether the specified component is dirty.
Protected Method | OnDataGridViewChanged | Called when the element is associated with a different DataGridView.
Protected Method | RaiseCellClick | Raises the DataGridView.CellClick event.
Protected Method | RaiseCellContentClick | Raises the DataGridView.CellContentClick event.
Protected Method | RaiseCellContentDoubleClick | Raises the DataGridView.CellContentDoubleClick event.
Protected Method | RaiseCellValueChanged | Raises the CellValueChanged event.
Protected Method | RaiseDataError | Raises the DataError event.
Protected Method | RaiseMouseWheel | Raises the MouseWheel event.
Protected Method | RenderAttributes | Renders the controls meta attributes
Protected Method | RenderComponent | Checks if the current control needs rendering and continues to process sub trree/
Protected Method | RenderComponentAttributes | Renders the controls meta attributes
Protected Method | RenderComponents | Renders the controls sub tree
Protected Method | RenderUpdatedAttributes | Renders the updated attributes
Protected Method | UpdateParams | Overloaded. Updates only the parameters of this instance.
Top

See Also

Reference

DataGridViewElement Class
Gizmox.WebGUI.Forms Namespace


DataGridViewElement Constructor

[image]
Gizmox.WebGUI.Forms
DataGridViewElement Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewElement Class : DataGridViewElement Constructor

Initializes a new instance of the DataGridViewElement class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewElement()
C#
public DataGridViewElement()
Managed Extensions for C++
public: DataGridViewElement();
C++/CLI
public:
DataGridViewElement();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewElement Class
DataGridViewElement Members


DataGridViewElement Class Methods

[image]
Gizmox.WebGUI.Forms
DataGridViewElement Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewElement Class

For a list of all members of this type, see DataGridViewElement members.

Public Methods

 | Name | Description
Public Method | Update | Overloaded. Full updates of this instance.
Top

Protected Methods

 | Name | Description
Protected Method | GetCriticalEvents | Gets the critical events.
Protected Method | IsDirty | Determines whether the specified component is dirty.
Protected Method | IsDirtyAttributes | Overloaded. Determines whether the specified component is dirty.
Protected Method | OnDataGridViewChanged | Called when the element is associated with a different DataGridView.
Protected Method | RaiseCellClick | Raises the DataGridView.CellClick event.
Protected Method | RaiseCellContentClick | Raises the DataGridView.CellContentClick event.
Protected Method | RaiseCellContentDoubleClick | Raises the DataGridView.CellContentDoubleClick event.
Protected Method | RaiseCellValueChanged | Raises the CellValueChanged event.
Protected Method | RaiseDataError | Raises the DataError event.
Protected Method | RaiseMouseWheel | Raises the MouseWheel event.
Protected Method | RenderAttributes | Renders the controls meta attributes
Protected Method | RenderComponent | Checks if the current control needs rendering and continues to process sub trree/
Protected Method | RenderComponentAttributes | Renders the controls meta attributes
Protected Method | RenderComponents | Renders the controls sub tree
Protected Method | RenderUpdatedAttributes | Renders the updated attributes
Protected Method | UpdateParams | Overloaded. Updates only the parameters of this instance.
Top

See Also

Reference

DataGridViewElement Class
Gizmox.WebGUI.Forms Namespace


GetCriticalEvents Method

[image]
Gizmox.WebGUI.Forms
GetCriticalEvents Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewElement Class : GetCriticalEvents Method

Gets the critical events.

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetCriticalEvents() As EventTypes
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewElement
Dim value As EventTypes

value = instance.GetCriticalEvents()
C#
protected virtual EventTypes GetCriticalEvents()
Managed Extensions for C++
protected: virtual EventTypes GetCriticalEvents();
C++/CLI
protected:
virtual EventTypes GetCriticalEvents();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewElement Class
DataGridViewElement Members


IsDirty Method

[image]
Gizmox.WebGUI.Forms
IsDirty Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewElement Class : IsDirty Method

lngRequestID
Request ID.
Determines whether the specified component is dirty.

Syntax

Visual Basic (Declaration)
Protected Function IsDirty( _
   ByVal lngRequestID As Long _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewElement
Dim lngRequestID As Long
Dim value As Boolean

value = instance.IsDirty(lngRequestID)
C#
protected bool IsDirty(
   long lngRequestID
)
Managed Extensions for C++
protected: bool IsDirty(
   long lngRequestID
)
C++/CLI
protected:
bool IsDirty(
   long long lngRequestID
)

Parameters

lngRequestID
Request ID.

Return Value

true if the specified component is dirty; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewElement Class
DataGridViewElement Members


IsDirtyAttributes Method

[image]
Gizmox.WebGUI.Forms
IsDirtyAttributes Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewElement Class : IsDirtyAttributes Method

Determines whether the specified component is dirty.

Overload List

Overload | Description
IsDirtyAttributes(Int64) | Determines whether the specified component is dirty.
IsDirtyAttributes(Int64,AttributeType) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewElement Class
DataGridViewElement Members


IsDirtyAttributes(Int64) Method

[image]
Gizmox.WebGUI.Forms
IsDirtyAttributes(Int64) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewElement Class > IsDirtyAttributes Method : IsDirtyAttributes(Int64) Method

lngRequestID
Request ID.
Determines whether the specified component is dirty.

Syntax

Visual Basic (Declaration)
Protected Overloads Function IsDirtyAttributes( _
   ByVal lngRequestID As Long _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewElement
Dim lngRequestID As Long
Dim value As Boolean

value = instance.IsDirtyAttributes(lngRequestID)
C#
protected bool IsDirtyAttributes(
   long lngRequestID
)
Managed Extensions for C++
protected: bool IsDirtyAttributes(
   long lngRequestID
)
C++/CLI
protected:
bool IsDirtyAttributes(
   long long lngRequestID
)

Parameters

lngRequestID
Request ID.

Return Value

true if the specified component is dirty; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewElement Class
DataGridViewElement Members
Overload List


IsDirtyAttributes(Int64,AttributeType) Method

[image]
Gizmox.WebGUI.Forms
IsDirtyAttributes(Int64,AttributeType) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewElement Class > IsDirtyAttributes Method : IsDirtyAttributes(Int64,AttributeType) Method

lngRequestID
enmParams

Syntax

Visual Basic (Declaration)
Protected Overloads Function IsDirtyAttributes( _
   ByVal lngRequestID As Long, _
   ByVal enmParams As AttributeType _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewElement
Dim lngRequestID As Long
Dim enmParams As AttributeType
Dim value As Boolean

value = instance.IsDirtyAttributes(lngRequestID, enmParams)
C#
protected bool IsDirtyAttributes(
   long lngRequestID,
   AttributeType enmParams
)
Managed Extensions for C++
protected: bool IsDirtyAttributes(
   long lngRequestID,
   AttributeType enmParams
)
C++/CLI
protected:
bool IsDirtyAttributes(
   long long lngRequestID,
   AttributeType enmParams
)

Parameters

lngRequestID
enmParams

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewElement Class
DataGridViewElement Members
Overload List


OnDataGridViewChanged Method

[image]
Gizmox.WebGUI.Forms
OnDataGridViewChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewElement Class : OnDataGridViewChanged Method

Called when the element is associated with a different DataGridView.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnDataGridViewChanged()
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewElement

instance.OnDataGridViewChanged()
C#
protected virtual void OnDataGridViewChanged()
Managed Extensions for C++
protected: virtual void OnDataGridViewChanged();
C++/CLI
protected:
virtual void OnDataGridViewChanged();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewElement Class
DataGridViewElement Members


RaiseCellClick Method

[image]
Gizmox.WebGUI.Forms
RaiseCellClick Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewElement Class : RaiseCellClick Method

e
A DataGridViewCellEventArgs that contains the event data.
Raises the DataGridView.CellClick event.

Syntax

Visual Basic (Declaration)
Protected Sub RaiseCellClick( _
   ByVal e As DataGridViewCellEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewElement
Dim e As DataGridViewCellEventArgs

instance.RaiseCellClick(e)
C#
protected void RaiseCellClick(
   DataGridViewCellEventArgs e
)
Managed Extensions for C++
protected: void RaiseCellClick(
   DataGridViewCellEventArgs* e
)
C++/CLI
protected:
void RaiseCellClick(
   DataGridViewCellEventArgs^ e
)

Parameters

e
A DataGridViewCellEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewElement Class
DataGridViewElement Members


RaiseCellContentClick Method

[image]
Gizmox.WebGUI.Forms
RaiseCellContentClick Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewElement Class : RaiseCellContentClick Method

e
A DataGridViewCellEventArgs that contains the event data.
Raises the DataGridView.CellContentClick event.

Syntax

Visual Basic (Declaration)
Protected Sub RaiseCellContentClick( _
   ByVal e As DataGridViewCellEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewElement
Dim e As DataGridViewCellEventArgs

instance.RaiseCellContentClick(e)
C#
protected void RaiseCellContentClick(
   DataGridViewCellEventArgs e
)
Managed Extensions for C++
protected: void RaiseCellContentClick(
   DataGridViewCellEventArgs* e
)
C++/CLI
protected:
void RaiseCellContentClick(
   DataGridViewCellEventArgs^ e
)

Parameters

e
A DataGridViewCellEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewElement Class
DataGridViewElement Members


RaiseCellContentDoubleClick Method

[image]
Gizmox.WebGUI.Forms
RaiseCellContentDoubleClick Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewElement Class : RaiseCellContentDoubleClick Method

e
A DataGridViewCellEventArgs that contains the event data.
Raises the DataGridView.CellContentDoubleClick event.

Syntax

Visual Basic (Declaration)
Protected Sub RaiseCellContentDoubleClick( _
   ByVal e As DataGridViewCellEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewElement
Dim e As DataGridViewCellEventArgs

instance.RaiseCellContentDoubleClick(e)
C#
protected void RaiseCellContentDoubleClick(
   DataGridViewCellEventArgs e
)
Managed Extensions for C++
protected: void RaiseCellContentDoubleClick(
   DataGridViewCellEventArgs* e
)
C++/CLI
protected:
void RaiseCellContentDoubleClick(
   DataGridViewCellEventArgs^ e
)

Parameters

e
A DataGridViewCellEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewElement Class
DataGridViewElement Members


RaiseCellValueChanged Method

[image]
Gizmox.WebGUI.Forms
RaiseCellValueChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewElement Class : RaiseCellValueChanged Method

e
A DataGridViewCellEventArgs that contains the event data.
Raises the CellValueChanged event.

Syntax

Visual Basic (Declaration)
Protected Sub RaiseCellValueChanged( _
   ByVal e As DataGridViewCellEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewElement
Dim e As DataGridViewCellEventArgs

instance.RaiseCellValueChanged(e)
C#
protected void RaiseCellValueChanged(
   DataGridViewCellEventArgs e
)
Managed Extensions for C++
protected: void RaiseCellValueChanged(
   DataGridViewCellEventArgs* e
)
C++/CLI
protected:
void RaiseCellValueChanged(
   DataGridViewCellEventArgs^ e
)

Parameters

e
A DataGridViewCellEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewElement Class
DataGridViewElement Members


RaiseDataError Method

[image]
Gizmox.WebGUI.Forms
RaiseDataError Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewElement Class : RaiseDataError Method

e
A DataGridViewDataErrorEventArgs that contains the event data.
Raises the DataError event.

Syntax

Visual Basic (Declaration)
Protected Sub RaiseDataError( _
   ByVal e As DataGridViewDataErrorEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewElement
Dim e As DataGridViewDataErrorEventArgs

instance.RaiseDataError(e)
C#
protected void RaiseDataError(
   DataGridViewDataErrorEventArgs e
)
Managed Extensions for C++
protected: void RaiseDataError(
   DataGridViewDataErrorEventArgs* e
)
C++/CLI
protected:
void RaiseDataError(
   DataGridViewDataErrorEventArgs^ e
)

Parameters

e
A DataGridViewDataErrorEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewElement Class
DataGridViewElement Members


RaiseMouseWheel Method

[image]
Gizmox.WebGUI.Forms
RaiseMouseWheel Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewElement Class : RaiseMouseWheel Method

e
A MouseEventArgs that contains the event data.
Raises the MouseWheel event.

Syntax

Visual Basic (Declaration)
Protected Sub RaiseMouseWheel( _
   ByVal e As MouseEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewElement
Dim e As MouseEventArgs

instance.RaiseMouseWheel(e)
C#
protected void RaiseMouseWheel(
   MouseEventArgs e
)
Managed Extensions for C++
protected: void RaiseMouseWheel(
   MouseEventArgs* e
)
C++/CLI
protected:
void RaiseMouseWheel(
   MouseEventArgs^ e
)

Parameters

e
A MouseEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewElement Class
DataGridViewElement Members


RenderAttributes Method

[image]
Gizmox.WebGUI.Forms
RenderAttributes Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewElement Class : RenderAttributes Method

objContext
objWriter
blnRenderOwner
Renders the controls meta attributes

Syntax

Visual Basic (Declaration)
Protected Overridable Sub RenderAttributes( _
   ByVal objContext As IContext, _
   ByVal objWriter As IAttributeWriter, _
   ByVal blnRenderOwner As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewElement
Dim objContext As IContext
Dim objWriter As IAttributeWriter
Dim blnRenderOwner As Boolean

instance.RenderAttributes(objContext, objWriter, blnRenderOwner)
C#
protected virtual void RenderAttributes(
   IContext objContext,
   IAttributeWriter objWriter,
   bool blnRenderOwner
)
Managed Extensions for C++
protected: virtual void RenderAttributes(
   IContext* objContext,
   IAttributeWriter* objWriter,
   bool blnRenderOwner
)
C++/CLI
protected:
virtual void RenderAttributes(
   IContext^ objContext,
   IAttributeWriter^ objWriter,
   bool blnRenderOwner
)

Parameters

objContext
objWriter
blnRenderOwner

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewElement Class
DataGridViewElement Members


RenderComponent Method

[image]
Gizmox.WebGUI.Forms
RenderComponent Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewElement Class : RenderComponent Method

objContext
objWriter
lngRequestID
blnRenderOwner
Checks if the current control needs rendering and continues to process sub trree/

Syntax

Visual Basic (Declaration)
Protected Overridable Sub RenderComponent( _
   ByVal objContext As IContext, _
   ByVal objWriter As IResponseWriter, _
   ByVal lngRequestID As Long, _
   ByVal blnRenderOwner As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewElement
Dim objContext As IContext
Dim objWriter As IResponseWriter
Dim lngRequestID As Long
Dim blnRenderOwner As Boolean

instance.RenderComponent(objContext, objWriter, lngRequestID, blnRenderOwner)
C#
protected virtual void RenderComponent(
   IContext objContext,
   IResponseWriter objWriter,
   long lngRequestID,
   bool blnRenderOwner
)
Managed Extensions for C++
protected: virtual void RenderComponent(
   IContext* objContext,
   IResponseWriter* objWriter,
   long lngRequestID,
   bool blnRenderOwner
)
C++/CLI
protected:
virtual void RenderComponent(
   IContext^ objContext,
   IResponseWriter^ objWriter,
   long long lngRequestID,
   bool blnRenderOwner
)

Parameters

objContext
objWriter
lngRequestID
blnRenderOwner

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewElement Class
DataGridViewElement Members


RenderComponentAttributes Method

[image]
Gizmox.WebGUI.Forms
RenderComponentAttributes Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewElement Class : RenderComponentAttributes Method

objContext
objWriter
blnRenderOwner
Renders the controls meta attributes

Syntax

Visual Basic (Declaration)
Protected Overridable Sub RenderComponentAttributes( _
   ByVal objContext As IContext, _
   ByVal objWriter As IAttributeWriter, _
   ByVal blnRenderOwner As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewElement
Dim objContext As IContext
Dim objWriter As IAttributeWriter
Dim blnRenderOwner As Boolean

instance.RenderComponentAttributes(objContext, objWriter, blnRenderOwner)
C#
protected virtual void RenderComponentAttributes(
   IContext objContext,
   IAttributeWriter objWriter,
   bool blnRenderOwner
)
Managed Extensions for C++
protected: virtual void RenderComponentAttributes(
   IContext* objContext,
   IAttributeWriter* objWriter,
   bool blnRenderOwner
)
C++/CLI
protected:
virtual void RenderComponentAttributes(
   IContext^ objContext,
   IAttributeWriter^ objWriter,
   bool blnRenderOwner
)

Parameters

objContext
objWriter
blnRenderOwner

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewElement Class
DataGridViewElement Members


RenderComponents Method

[image]
Gizmox.WebGUI.Forms
RenderComponents Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewElement Class : RenderComponents Method

objContext
objWriter
lngRequestID
blnRenderOwner
Renders the controls sub tree

Syntax

Visual Basic (Declaration)
Protected Overridable Sub RenderComponents( _
   ByVal objContext As IContext, _
   ByVal objWriter As IResponseWriter, _
   ByVal lngRequestID As Long, _
   ByVal blnRenderOwner As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewElement
Dim objContext As IContext
Dim objWriter As IResponseWriter
Dim lngRequestID As Long
Dim blnRenderOwner As Boolean

instance.RenderComponents(objContext, objWriter, lngRequestID, blnRenderOwner)
C#
protected virtual void RenderComponents(
   IContext objContext,
   IResponseWriter objWriter,
   long lngRequestID,
   bool blnRenderOwner
)
Managed Extensions for C++
protected: virtual void RenderComponents(
   IContext* objContext,
   IResponseWriter* objWriter,
   long lngRequestID,
   bool blnRenderOwner
)
C++/CLI
protected:
virtual void RenderComponents(
   IContext^ objContext,
   IResponseWriter^ objWriter,
   long long lngRequestID,
   bool blnRenderOwner
)

Parameters

objContext
objWriter
lngRequestID
blnRenderOwner

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewElement Class
DataGridViewElement Members


RenderUpdatedAttributes Method

[image]
Gizmox.WebGUI.Forms
RenderUpdatedAttributes Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewElement Class : RenderUpdatedAttributes Method

objContext
objWriter
lngRequestID
blnRenderOwner
Renders the updated attributes

Syntax

Visual Basic (Declaration)
Protected Overridable Sub RenderUpdatedAttributes( _
   ByVal objContext As IContext, _
   ByVal objWriter As IAttributeWriter, _
   ByVal lngRequestID As Long, _
   ByVal blnRenderOwner As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewElement
Dim objContext As IContext
Dim objWriter As IAttributeWriter
Dim lngRequestID As Long
Dim blnRenderOwner As Boolean

instance.RenderUpdatedAttributes(objContext, objWriter, lngRequestID, blnRenderOwner)
C#
protected virtual void RenderUpdatedAttributes(
   IContext objContext,
   IAttributeWriter objWriter,
   long lngRequestID,
   bool blnRenderOwner
)
Managed Extensions for C++
protected: virtual void RenderUpdatedAttributes(
   IContext* objContext,
   IAttributeWriter* objWriter,
   long lngRequestID,
   bool blnRenderOwner
)
C++/CLI
protected:
virtual void RenderUpdatedAttributes(
   IContext^ objContext,
   IAttributeWriter^ objWriter,
   long long lngRequestID,
   bool blnRenderOwner
)

Parameters

objContext
objWriter
lngRequestID
blnRenderOwner

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewElement Class
DataGridViewElement Members


Update Method

[image]
Gizmox.WebGUI.Forms
Update Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewElement Class : Update Method

Full updates of this instance.

Overload List

Overload | Description
Update() | Full updates of this instance.
Update(Boolean) | Redraw only

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewElement Class
DataGridViewElement Members


Update() Method

[image]
Gizmox.WebGUI.Forms
Update() Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewElement Class > Update Method : Update() Method

Full updates of this instance.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub Update()
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewElement

instance.Update()
C#
public virtual void Update()
Managed Extensions for C++
public: virtual void Update();
C++/CLI
public:
virtual void Update();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewElement Class
DataGridViewElement Members
Overload List


Update(Boolean) Method

[image]
Gizmox.WebGUI.Forms
Update(Boolean) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewElement Class > Update Method : Update(Boolean) Method

blnRedrawOnly
Redraw only

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub Update( _
   ByVal blnRedrawOnly As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewElement
Dim blnRedrawOnly As Boolean

instance.Update(blnRedrawOnly)
C#
public virtual void Update(
   bool blnRedrawOnly
)
Managed Extensions for C++
public: virtual void Update(
   bool blnRedrawOnly
)
C++/CLI
public:
virtual void Update(
   bool blnRedrawOnly
)

Parameters

blnRedrawOnly

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewElement Class
DataGridViewElement Members
Overload List


UpdateParams Method

[image]
Gizmox.WebGUI.Forms
UpdateParams Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewElement Class : UpdateParams Method

Updates only the parameters of this instance.

Overload List

Overload | Description
UpdateParams() | Updates only the parameters of this instance.
UpdateParams(AttributeType) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewElement Class
DataGridViewElement Members


UpdateParams() Method

[image]
Gizmox.WebGUI.Forms
UpdateParams() Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewElement Class > UpdateParams Method : UpdateParams() Method

Updates only the parameters of this instance.

Syntax

Visual Basic (Declaration)
Protected Overloads Sub UpdateParams()
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewElement

instance.UpdateParams()
C#
protected void UpdateParams()
Managed Extensions for C++
protected: void UpdateParams();
C++/CLI
protected:
void UpdateParams();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewElement Class
DataGridViewElement Members
Overload List


UpdateParams(AttributeType) Method

[image]
Gizmox.WebGUI.Forms
UpdateParams(AttributeType) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewElement Class > UpdateParams Method : UpdateParams(AttributeType) Method

enmParams

Syntax

Visual Basic (Declaration)
Protected Overloads Sub UpdateParams( _
   ByVal enmParams As AttributeType _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewElement
Dim enmParams As AttributeType

instance.UpdateParams(enmParams)
C#
protected void UpdateParams(
   AttributeType enmParams
)
Managed Extensions for C++
protected: void UpdateParams(
   AttributeType enmParams
)
C++/CLI
protected:
void UpdateParams(
   AttributeType enmParams
)

Parameters

enmParams

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewElement Class
DataGridViewElement Members
Overload List


DataGridViewElement Class Properties

[image]
Gizmox.WebGUI.Forms
DataGridViewElement Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewElement Class

For a list of all members of this type, see DataGridViewElement members.

Public Properties

 | Name | Description
Public Property | DataGridView | Gets the DataGridView control associated with this element.
Public Property | State | Gets the user interface (UI) state of the element.
Top

Protected Properties

 | Name | Description
Protected Property | MemberID |
Protected Property | TagName |
Top

See Also

Reference

DataGridViewElement Class
Gizmox.WebGUI.Forms Namespace


DataGridView Property

[image]
Gizmox.WebGUI.Forms
DataGridView Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewElement Class : DataGridView Property

Gets the DataGridView control associated with this element.

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
Public ReadOnly Property DataGridView As DataGridView
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewElement
Dim value As DataGridView

value = instance.DataGridView
C#
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public DataGridView DataGridView {get;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public: __property DataGridView* get_DataGridView();
C++/CLI
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public:
property DataGridView^ DataGridView {
   DataGridView^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewElement Class
DataGridViewElement Members


MemberID Property

[image]
Gizmox.WebGUI.Forms
MemberID Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewElement Class : MemberID Property

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property MemberID As String
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewElement
Dim value As String

value = instance.MemberID
C#
protected virtual string MemberID {get;}
Managed Extensions for C++
protected: __property virtual string* get_MemberID();
C++/CLI
protected:
virtual property String^ MemberID {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewElement Class
DataGridViewElement Members


State Property

[image]
Gizmox.WebGUI.Forms
State Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewElement Class : State Property

Gets the user interface (UI) state of the element.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Overridable ReadOnly Property State As DataGridViewElementStates
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewElement
Dim value As DataGridViewElementStates

value = instance.State
C#
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public virtual DataGridViewElementStates State {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: __property virtual DataGridViewElementStates get_State();
C++/CLI
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
virtual property DataGridViewElementStates State {
   DataGridViewElementStates get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewElement Class
DataGridViewElement Members


TagName Property

[image]
Gizmox.WebGUI.Forms
TagName Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewElement Class : TagName Property

Syntax

Visual Basic (Declaration)
Protected Property TagName As String
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewElement
Dim value As String

instance.TagName = value

value = instance.TagName
C#
protected string TagName {get; set;}
Managed Extensions for C++
protected: __property string* get_TagName();
protected: __property void set_TagName(
   string* value
);
C++/CLI
protected:
property String^ TagName {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewElement Class
DataGridViewElement Members


DataGridViewHeaderCell Class

[image]
Gizmox.WebGUI.Forms
DataGridViewHeaderCell Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewHeaderCell Class

Contains functionality common to row header cells and column header cells.

Object Model

Syntax

Visual Basic (Declaration)
Public Class DataGridViewHeaderCell
   Inherits DataGridViewCell
   Implements IRenderableComponentMember
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewHeaderCell
C#
public class DataGridViewHeaderCell : DataGridViewCell, IRenderableComponentMember
Managed Extensions for C++
public __gc class DataGridViewHeaderCell : public DataGridViewCell, IRenderableComponentMember
C++/CLI
public ref class DataGridViewHeaderCell : public DataGridViewCell, IRenderableComponentMember

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.DataGridViewElement
Gizmox.WebGUI.Forms.DataGridViewCell
Gizmox.WebGUI.Forms.DataGridViewHeaderCell
Gizmox.WebGUI.Forms.DataGridViewColumnHeaderCell
Gizmox.WebGUI.Forms.DataGridViewRowHeaderCell

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

DataGridViewHeaderCell Members
Gizmox.WebGUI.Forms Namespace


DataGridViewHeaderCell Class Members

[image]
Gizmox.WebGUI.Forms
DataGridViewHeaderCell Class Members
See Also Fields Properties Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewHeaderCell Class

The following tables list the members exposed by DataGridViewHeaderCell.

Public Constructors

 | Name | Description
Public Constructor | DataGridViewHeaderCell Constructor |
Top

Protected Fields

 | Name | Description
static (Shared in Visual Basic) | cellType |
static (Shared in Visual Basic) | DATAGRIDVIEWHEADERCELL_themeMargin |
static (Shared in Visual Basic) | defaultFormattedValueType |
static (Shared in Visual Basic) | defaultValueType |
static (Shared in Visual Basic) | HeaderTypeName |
static (Shared in Visual Basic) | PropButtonState |
static (Shared in Visual Basic) | PropFlipXPThemesBitmap |
static (Shared in Visual Basic) | PropValueType |
static (Shared in Visual Basic) | rectThemeMargins |
Top

Public Properties

 | Name | Description
Public Property | ColumnIndex | Gets the column index for this cell. (Inherited from DataGridViewCell)
Public Property | ContentBounds | (Inherited from DataGridViewCell)
Public Property | DataGridView | Gets the DataGridView control associated with this element. (Inherited from DataGridViewElement)
Public Property | DefaultNewRowValue | Gets the default value for a cell in the row for new records. (Inherited from DataGridViewCell)
Public Property | Displayed | Overridden.
Public Property | EditedFormattedValue | Gets the current, formatted value of the cell, regardless of whether the cell is in edit mode and the value has not been committed. (Inherited from DataGridViewCell)
Public Property | EditType | Gets the type of the cell's hosted editing control. (Inherited from DataGridViewCell)
Public Property | ErrorIconBounds | (Inherited from DataGridViewCell)
Public Property | ErrorText | Gets or sets the text describing an error condition associated with the cell. (Inherited from DataGridViewCell)
Public Property | FormattedValue | Gets the value of the cell as formatted for display. (Inherited from DataGridViewCell)
Public Property | FormattedValueType | Overridden. Gets the type of the formatted value of the cell.
Public Property | Frozen | Overridden. Gets a value indicating whether the cell is frozen.
Public Property | HasStyle | Gets a value indicating whether the DataGridViewCell.Style property has been set. (Inherited from DataGridViewCell)
Public Property | InheritedState | Gets the current state of the cell as inherited from the state of its row and column. (Inherited from DataGridViewCell)
Public Property | InheritedStyle | Gets the style currently applied to the cell. (Inherited from DataGridViewCell)
Public Property | IsInEditMode | Gets a value indicating whether this cell is currently being edited. (Inherited from DataGridViewCell)
Public Property | OwningColumn | Gets the column that contains this cell. (Inherited from DataGridViewCell)
Public Property | OwningRow | Gets the row that contains this cell. (Inherited from DataGridViewCell)
Public Property | PreferredSize | Gets the size, in pixels, of a rectangular area into which the cell can fit. (Inherited from DataGridViewCell)
Public Property | ReadOnly | Overridden. Gets a value indicating whether the header cell is read-only.
Public Property | Resizable | Overridden. Gets a value indicating whether the cell is resizable.
Public Property | RowIndex | Gets the index of the cell's parent row. (Inherited from DataGridViewCell)
Public Property | Selected | Overridden. Gets or sets a value indicating whether the cell is selected.
Public Property | Size | Gets the size of the cell. (Inherited from DataGridViewCell)
Public Property | State | Gets the user interface (UI) state of the element. (Inherited from DataGridViewElement)
Public Property | Style | Gets or sets the style for the cell. (Inherited from DataGridViewCell)
Public Property | Tag | Gets or sets the object that contains supplemental data about the cell. (Inherited from DataGridViewCell)
Public Property | ToolTipText | Gets or sets the ToolTip text associated with this cell. (Inherited from DataGridViewCell)
Public Property | Value | Gets or sets the value associated with this cell. (Inherited from DataGridViewCell)
Public Property | ValueType | Overridden. Gets the type of the value stored in the cell.
Public Property | Visible | Overridden. Gets a value indicating whether or not the cell is visible.
Top

Protected Properties

 | Name | Description
Protected Property | ButtonState | Gets the buttonlike visual state of the header cell.
Protected Property | MemberID | (Inherited from DataGridViewCell)
Protected Property | TagName | (Inherited from DataGridViewElement)
Top

Public Methods

 | Name | Description
Public Method | AdjustCellBorderStyle | Modifies the input cell border style according to the specified criteria. (Inherited from DataGridViewCell)
Public Method | Clone | Overridden. Creates an exact copy of this cell.
Public Method | DetachEditingControl | Removes the cell's editing control from the DataGridView. (Inherited from DataGridViewCell)
Public Method | Dispose | Overloaded. Releases all resources used by the DataGridViewCell. (Inherited from DataGridViewCell)
Public Method | GetContentBounds | Overloaded. (Inherited from DataGridViewCell)
Public Method | GetEditedFormattedValue | Returns the current, formatted value of the cell, regardless of whether the cell is in edit mode and the value has not been committed. (Inherited from DataGridViewCell)
Public Method | GetInheritedState | Overridden. Returns a value indicating the current state of the cell as inherited from the state of its row or column.
Public Method | GetInheritedStyle | Gets the style applied to the cell. (Inherited from DataGridViewCell)
Public Method | InitializeEditingControl | Initializes the control used to edit the cell. (Inherited from DataGridViewCell)
Public Method | KeyEntersEditMode | Determines if edit mode should be started based on the given key. (Inherited from DataGridViewCell)
Public Method | ParseFormattedValue | (Inherited from DataGridViewCell)
Public Method | PositionEditingControl | Sets the location and size of the editing control hosted by a cell in the DataGridView control. (Inherited from DataGridViewCell)
Public Method | PositionEditingPanel | (Inherited from DataGridViewCell)
Public Method | ToString | Overridden.
Public Method | Update | Overloaded. Full updates of this instance. (Inherited from DataGridViewElement)
Top

Protected Methods

 | Name | Description
Protected Method | BorderWidths | (Inherited from DataGridViewCell)
Protected Method | ClickUnsharesRow | Indicates whether the cell's row will be unshared when the cell is clicked. (Inherited from DataGridViewCell)
Protected Method | ContentClickUnsharesRow | Indicates whether the cell's row will be unshared when the cell's content is clicked. (Inherited from DataGridViewCell)
Protected Method | ContentDoubleClickUnsharesRow | Indicates whether the cell's row will be unshared when the cell's content is double-clicked. (Inherited from DataGridViewCell)
Protected Method | DoubleClickUnsharesRow | Indicates whether the cell's row will be unshared when the cell is double-clicked. (Inherited from DataGridViewCell)
Protected Method | EnterUnsharesRow | Indicates whether the parent row will be unshared when the focus moves to the cell. (Inherited from DataGridViewCell)
Protected Method | GetClipboardContent | Retrieves the formatted value of the cell to copy to the Clipboard. (Inherited from DataGridViewCell)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from DataGridViewElement)
Protected Method | GetDefaultHorizontalAlignment | Gets the horizontal alignment. (Inherited from DataGridViewCell)
Protected Method | GetDefaultVerticalAlignment | Gets the vertical alignment. (Inherited from DataGridViewCell)
Protected Method | GetErrorIconBounds | (Inherited from DataGridViewCell)
Protected Method | GetErrorText | Returns a string that represents the error for the cell. (Inherited from DataGridViewCell)
Protected Method | GetFormattedValue | Gets the value of the cell as formatted for display. (Inherited from DataGridViewCell)
Protected Method | GetPreferredSize | Overloaded. Calculates the preferred size, in pixels, of the cell. (Inherited from DataGridViewCell)
Protected Method | GetSize | Overridden. Gets the size of the cell.
Protected Method | GetValue | Overridden. Gets the value of the cell.
Protected Method | IsDirty | Determines whether the specified component is dirty. (Inherited from DataGridViewElement)
Protected Method | IsDirtyAttributes | Overloaded. Determines whether the specified component is dirty. (Inherited from DataGridViewElement)
Protected Method | KeyDownUnsharesRow | Indicates whether the parent row is unshared if the user presses a key while the focus is on the cell. (Inherited from DataGridViewCell)
Protected Method | KeyPressUnsharesRow | Indicates whether a row will be unshared if a key is pressed while a cell in the row has focus. (Inherited from DataGridViewCell)
Protected Method | KeyUpUnsharesRow | Indicates whether the parent row is unshared when the user releases a key while the focus is on the cell. (Inherited from DataGridViewCell)
Protected Method | LeaveUnsharesRow | Indicates whether a row will be unshared when the focus leaves a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseClickUnsharesRow | Indicates whether a row will be unshared if the user clicks a mouse button while the pointer is on a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseDoubleClickUnsharesRow | Indicates whether a row will be unshared if the user double-clicks a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseDownUnsharesRow | Indicates whether a row will be unshared when the user holds down a mouse button while the pointer is on a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseEnterUnsharesRow | Indicates whether a row will be unshared when the mouse pointer moves over a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseLeaveUnsharesRow | Indicates whether a row will be unshared when the mouse pointer leaves the row. (Inherited from DataGridViewCell)
Protected Method | MouseMoveUnsharesRow | Indicates whether a row will be unshared when the mouse pointer moves over a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseUpUnsharesRow | Indicates whether a row will be unshared when the user releases a mouse button while the pointer is on a cell in the row. (Inherited from DataGridViewCell)
Protected Method | OnClick | Called when the cell is clicked. (Inherited from DataGridViewCell)
Protected Method | OnContentClick | Called when the cell's contents are clicked. (Inherited from DataGridViewCell)
Protected Method | OnContentDoubleClick | Called when the cell's contents are double-clicked. (Inherited from DataGridViewCell)
Protected Method | OnDataGridViewChanged | Called when the DataGridViewElement.DataGridView property of the cell changes. (Inherited from DataGridViewCell)
Protected Method | OnDoubleClick | Called when the cell is double-clicked. (Inherited from DataGridViewCell)
Protected Method | OnEnter | Called when the focus moves to a cell. (Inherited from DataGridViewCell)
Protected Method | OnKeyDown | Called when a character key is pressed while the focus is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnKeyPress | Called when a key is pressed while the focus is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnKeyUp | Called when a character key is released while the focus is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnLeave | Called when the focus moves from a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseClick | Called when the user clicks a mouse button while the pointer is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseDoubleClick | Called when the user double-clicks a mouse button while the pointer is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseDown | Called when the user holds down a mouse button while the pointer is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseEnter | Called when the mouse pointer moves over a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseLeave | Called when the mouse pointer leaves the cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseMove | Called when the mouse pointer moves within a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseUp | Called when the user releases a mouse button while the pointer is on a cell. (Inherited from DataGridViewCell)
Protected Method | Paint | (Inherited from DataGridViewCell)
Protected Method | PaintErrorIcon | (Inherited from DataGridViewCell)
Protected Method | ProcessGatewayRequest | (Inherited from DataGridViewCell)
Protected Method | RaiseCellClick | Raises the DataGridView.CellClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellContentClick | Raises the DataGridView.CellContentClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellContentDoubleClick | Raises the DataGridView.CellContentDoubleClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellValueChanged | Raises the CellValueChanged event. (Inherited from DataGridViewElement)
Protected Method | RaiseDataError | Raises the DataError event. (Inherited from DataGridViewElement)
Protected Method | RaiseMouseWheel | Raises the MouseWheel event. (Inherited from DataGridViewElement)
Protected Method | RenderAttributes | Overridden. Renders a header- cell's attributes
Protected Method | RenderBackColorAttribute | Overridden. Renders the back-color attribute.
Protected Method | RenderComponent | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from DataGridViewElement)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from DataGridViewElement)
Protected Method | RenderComponents | Renders the controls sub tree (Inherited from DataGridViewElement)
Protected Method | RenderForeColorAttribute | Overridden. Renders the fore color attribute.
Protected Method | RenderReadOnlyAttribute | Overridden. Renders the read only attribute.
Protected Method | RenderUpdatedAttributes | Renders the updated attributes (Inherited from DataGridViewElement)
Protected Method | RenderWrapModeAttribute | Overridden. Renders the wrap mode attribute.
Protected Method | SetValue | Sets the value of the cell. (Inherited from DataGridViewCell)
Protected Method | UpdateParams | Overloaded. Updates only the parameters of this instance. (Inherited from DataGridViewElement)
Top

See Also

Reference

DataGridViewHeaderCell Class
Gizmox.WebGUI.Forms Namespace


DataGridViewHeaderCell Constructor

[image]
Gizmox.WebGUI.Forms
DataGridViewHeaderCell Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewHeaderCell Class : DataGridViewHeaderCell Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewHeaderCell()
C#
public DataGridViewHeaderCell()
Managed Extensions for C++
public: DataGridViewHeaderCell();
C++/CLI
public:
DataGridViewHeaderCell();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewHeaderCell Class
DataGridViewHeaderCell Members


DataGridViewHeaderCell Class Methods

[image]
Gizmox.WebGUI.Forms
DataGridViewHeaderCell Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewHeaderCell Class

For a list of all members of this type, see DataGridViewHeaderCell members.

Public Methods

 | Name | Description
Public Method | AdjustCellBorderStyle | Modifies the input cell border style according to the specified criteria. (Inherited from DataGridViewCell)
Public Method | Clone | Overridden. Creates an exact copy of this cell.
Public Method | DetachEditingControl | Removes the cell's editing control from the DataGridView. (Inherited from DataGridViewCell)
Public Method | Dispose | Overloaded. Releases all resources used by the DataGridViewCell. (Inherited from DataGridViewCell)
Public Method | GetContentBounds | Overloaded. (Inherited from DataGridViewCell)
Public Method | GetEditedFormattedValue | Returns the current, formatted value of the cell, regardless of whether the cell is in edit mode and the value has not been committed. (Inherited from DataGridViewCell)
Public Method | GetInheritedState | Overridden. Returns a value indicating the current state of the cell as inherited from the state of its row or column.
Public Method | GetInheritedStyle | Gets the style applied to the cell. (Inherited from DataGridViewCell)
Public Method | InitializeEditingControl | Initializes the control used to edit the cell. (Inherited from DataGridViewCell)
Public Method | KeyEntersEditMode | Determines if edit mode should be started based on the given key. (Inherited from DataGridViewCell)
Public Method | ParseFormattedValue | (Inherited from DataGridViewCell)
Public Method | PositionEditingControl | Sets the location and size of the editing control hosted by a cell in the DataGridView control. (Inherited from DataGridViewCell)
Public Method | PositionEditingPanel | (Inherited from DataGridViewCell)
Public Method | ToString | Overridden.
Public Method | Update | Overloaded. Full updates of this instance. (Inherited from DataGridViewElement)
Top

Protected Methods

 | Name | Description
Protected Method | BorderWidths | (Inherited from DataGridViewCell)
Protected Method | ClickUnsharesRow | Indicates whether the cell's row will be unshared when the cell is clicked. (Inherited from DataGridViewCell)
Protected Method | ContentClickUnsharesRow | Indicates whether the cell's row will be unshared when the cell's content is clicked. (Inherited from DataGridViewCell)
Protected Method | ContentDoubleClickUnsharesRow | Indicates whether the cell's row will be unshared when the cell's content is double-clicked. (Inherited from DataGridViewCell)
Protected Method | DoubleClickUnsharesRow | Indicates whether the cell's row will be unshared when the cell is double-clicked. (Inherited from DataGridViewCell)
Protected Method | EnterUnsharesRow | Indicates whether the parent row will be unshared when the focus moves to the cell. (Inherited from DataGridViewCell)
Protected Method | GetClipboardContent | Retrieves the formatted value of the cell to copy to the Clipboard. (Inherited from DataGridViewCell)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from DataGridViewElement)
Protected Method | GetDefaultHorizontalAlignment | Gets the horizontal alignment. (Inherited from DataGridViewCell)
Protected Method | GetDefaultVerticalAlignment | Gets the vertical alignment. (Inherited from DataGridViewCell)
Protected Method | GetErrorIconBounds | (Inherited from DataGridViewCell)
Protected Method | GetErrorText | Returns a string that represents the error for the cell. (Inherited from DataGridViewCell)
Protected Method | GetFormattedValue | Gets the value of the cell as formatted for display. (Inherited from DataGridViewCell)
Protected Method | GetPreferredSize | Overloaded. Calculates the preferred size, in pixels, of the cell. (Inherited from DataGridViewCell)
Protected Method | GetSize | Overridden. Gets the size of the cell.
Protected Method | GetValue | Overridden. Gets the value of the cell.
Protected Method | IsDirty | Determines whether the specified component is dirty. (Inherited from DataGridViewElement)
Protected Method | IsDirtyAttributes | Overloaded. Determines whether the specified component is dirty. (Inherited from DataGridViewElement)
Protected Method | KeyDownUnsharesRow | Indicates whether the parent row is unshared if the user presses a key while the focus is on the cell. (Inherited from DataGridViewCell)
Protected Method | KeyPressUnsharesRow | Indicates whether a row will be unshared if a key is pressed while a cell in the row has focus. (Inherited from DataGridViewCell)
Protected Method | KeyUpUnsharesRow | Indicates whether the parent row is unshared when the user releases a key while the focus is on the cell. (Inherited from DataGridViewCell)
Protected Method | LeaveUnsharesRow | Indicates whether a row will be unshared when the focus leaves a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseClickUnsharesRow | Indicates whether a row will be unshared if the user clicks a mouse button while the pointer is on a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseDoubleClickUnsharesRow | Indicates whether a row will be unshared if the user double-clicks a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseDownUnsharesRow | Indicates whether a row will be unshared when the user holds down a mouse button while the pointer is on a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseEnterUnsharesRow | Indicates whether a row will be unshared when the mouse pointer moves over a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseLeaveUnsharesRow | Indicates whether a row will be unshared when the mouse pointer leaves the row. (Inherited from DataGridViewCell)
Protected Method | MouseMoveUnsharesRow | Indicates whether a row will be unshared when the mouse pointer moves over a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseUpUnsharesRow | Indicates whether a row will be unshared when the user releases a mouse button while the pointer is on a cell in the row. (Inherited from DataGridViewCell)
Protected Method | OnClick | Called when the cell is clicked. (Inherited from DataGridViewCell)
Protected Method | OnContentClick | Called when the cell's contents are clicked. (Inherited from DataGridViewCell)
Protected Method | OnContentDoubleClick | Called when the cell's contents are double-clicked. (Inherited from DataGridViewCell)
Protected Method | OnDataGridViewChanged | Called when the DataGridViewElement.DataGridView property of the cell changes. (Inherited from DataGridViewCell)
Protected Method | OnDoubleClick | Called when the cell is double-clicked. (Inherited from DataGridViewCell)
Protected Method | OnEnter | Called when the focus moves to a cell. (Inherited from DataGridViewCell)
Protected Method | OnKeyDown | Called when a character key is pressed while the focus is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnKeyPress | Called when a key is pressed while the focus is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnKeyUp | Called when a character key is released while the focus is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnLeave | Called when the focus moves from a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseClick | Called when the user clicks a mouse button while the pointer is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseDoubleClick | Called when the user double-clicks a mouse button while the pointer is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseDown | Called when the user holds down a mouse button while the pointer is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseEnter | Called when the mouse pointer moves over a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseLeave | Called when the mouse pointer leaves the cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseMove | Called when the mouse pointer moves within a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseUp | Called when the user releases a mouse button while the pointer is on a cell. (Inherited from DataGridViewCell)
Protected Method | Paint | (Inherited from DataGridViewCell)
Protected Method | PaintErrorIcon | (Inherited from DataGridViewCell)
Protected Method | ProcessGatewayRequest | (Inherited from DataGridViewCell)
Protected Method | RaiseCellClick | Raises the DataGridView.CellClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellContentClick | Raises the DataGridView.CellContentClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellContentDoubleClick | Raises the DataGridView.CellContentDoubleClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellValueChanged | Raises the CellValueChanged event. (Inherited from DataGridViewElement)
Protected Method | RaiseDataError | Raises the DataError event. (Inherited from DataGridViewElement)
Protected Method | RaiseMouseWheel | Raises the MouseWheel event. (Inherited from DataGridViewElement)
Protected Method | RenderAttributes | Overridden. Renders a header- cell's attributes
Protected Method | RenderBackColorAttribute | Overridden. Renders the back-color attribute.
Protected Method | RenderComponent | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from DataGridViewElement)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from DataGridViewElement)
Protected Method | RenderComponents | Renders the controls sub tree (Inherited from DataGridViewElement)
Protected Method | RenderForeColorAttribute | Overridden. Renders the fore color attribute.
Protected Method | RenderReadOnlyAttribute | Overridden. Renders the read only attribute.
Protected Method | RenderUpdatedAttributes | Renders the updated attributes (Inherited from DataGridViewElement)
Protected Method | RenderWrapModeAttribute | Overridden. Renders the wrap mode attribute.
Protected Method | SetValue | Sets the value of the cell. (Inherited from DataGridViewCell)
Protected Method | UpdateParams | Overloaded. Updates only the parameters of this instance. (Inherited from DataGridViewElement)
Top

See Also

Reference

DataGridViewHeaderCell Class
Gizmox.WebGUI.Forms Namespace


Clone Method

[image]
Gizmox.WebGUI.Forms
Clone Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewHeaderCell Class : Clone Method

Creates an exact copy of this cell.

Syntax

Visual Basic (Declaration)
Public Overrides Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewHeaderCell
Dim value As Object

value = instance.Clone()
C#
public override object Clone()
Managed Extensions for C++
public: Object* Clone(); override
C++/CLI
public:
Object^ Clone(); override

Return Value

An Object that represents the cloned DataGridViewHeaderCell.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewHeaderCell Class
DataGridViewHeaderCell Members


GetInheritedState Method

[image]
Gizmox.WebGUI.Forms
GetInheritedState Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewHeaderCell Class : GetInheritedState Method

rowIndex
The index of the row containing the cell or -1 if the cell is not a row header cell or is not contained within a DataGridView control.
Returns a value indicating the current state of the cell as inherited from the state of its row or column.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetInheritedState( _
   ByVal rowIndex As Integer _
) As DataGridViewElementStates
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewHeaderCell
Dim rowIndex As Integer
Dim value As DataGridViewElementStates

value = instance.GetInheritedState(rowIndex)
C#
public override DataGridViewElementStates GetInheritedState(
   int rowIndex
)
Managed Extensions for C++
public: DataGridViewElementStates GetInheritedState(
   int rowIndex
) override
C++/CLI
public:
DataGridViewElementStates GetInheritedState(
   int rowIndex
) override

Parameters

rowIndex
The index of the row containing the cell or -1 if the cell is not a row header cell or is not contained within a DataGridView control.

Return Value

A bitwise combination of DataGridViewElementStates values representing the current state of the cell.

Exceptions

Exception | Description
ArgumentException | The cell is a row header cell, the cell is not contained within a DataGridView control, and rowIndex is not -1.- or -The cell is a row header cell, the cell is contained within a DataGridView control, and rowIndex is outside the valid range of 0 to the number of rows in the control minus 1.- or -The cell is a row header cell and rowIndex is not the index of the row containing this cell.
ArgumentOutOfRangeException | The cell is a column header cell or the control's DataGridView.TopLeftHeaderCell and rowIndex is not -1.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewHeaderCell Class
DataGridViewHeaderCell Members


GetSize Method

[image]
Gizmox.WebGUI.Forms
GetSize Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewHeaderCell Class : GetSize Method

rowIndex
The row index of the header cell.
Gets the size of the cell.

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetSize( _
   ByVal rowIndex As Integer _
) As Size
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewHeaderCell
Dim rowIndex As Integer
Dim value As Size

value = instance.GetSize(rowIndex)
C#
protected override Size GetSize(
   int rowIndex
)
Managed Extensions for C++
protected: Size GetSize(
   int rowIndex
) override
C++/CLI
protected:
Size GetSize(
   int rowIndex
) override

Parameters

rowIndex
The row index of the header cell.

Return Value

A Size that represents the size of the header cell.

Exceptions

Exception | Description
ArgumentOutOfRangeException | The value of the DataGridViewElement.DataGridView property for this cell is null and rowIndex does not equal -1. -or-The value of the DataGridViewCell.OwningColumn property for this cell is not null and rowIndex does not equal -1. -or-The value of the DataGridViewCell.OwningRow property for this cell is not null and rowIndex is less than zero or greater than or equal to the number of rows in the control.-or-The values of the DataGridViewCell.OwningColumn and DataGridViewCell.OwningRow properties of this cell are both null and rowIndex does not equal -1.
ArgumentException | The value of the DataGridViewCell.OwningRow property for this cell is not null and rowIndex indicates a row other than the DataGridViewCell.OwningRow.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewHeaderCell Class
DataGridViewHeaderCell Members


GetValue Method

[image]
Gizmox.WebGUI.Forms
GetValue Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewHeaderCell Class : GetValue Method

rowIndex
The index of the cell's parent row.
Gets the value of the cell.

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetValue( _
   ByVal rowIndex As Integer _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewHeaderCell
Dim rowIndex As Integer
Dim value As Object

value = instance.GetValue(rowIndex)
C#
protected override object GetValue(
   int rowIndex
)
Managed Extensions for C++
protected: Object* GetValue(
   int rowIndex
) override
C++/CLI
protected:
Object^ GetValue(
   int rowIndex
) override

Parameters

rowIndex
The index of the cell's parent row.

Return Value

The value of the current DataGridViewCell.

Exceptions

Exception | Description
ArgumentOutOfRangeException | rowIndex is not -1.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewHeaderCell Class
DataGridViewHeaderCell Members


RenderAttributes Method

[image]
Gizmox.WebGUI.Forms
RenderAttributes Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewHeaderCell Class : RenderAttributes Method

objContext
objWriter
blnRenderOwner
Renders a header- cell's attributes

Syntax

Visual Basic (Declaration)
Protected Overrides Sub RenderAttributes( _
   ByVal objContext As IContext, _
   ByVal objWriter As IAttributeWriter, _
   ByVal blnRenderOwner As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewHeaderCell
Dim objContext As IContext
Dim objWriter As IAttributeWriter
Dim blnRenderOwner As Boolean

instance.RenderAttributes(objContext, objWriter, blnRenderOwner)
C#
protected override void RenderAttributes(
   IContext objContext,
   IAttributeWriter objWriter,
   bool blnRenderOwner
)
Managed Extensions for C++
protected: void RenderAttributes(
   IContext* objContext,
   IAttributeWriter* objWriter,
   bool blnRenderOwner
) override
C++/CLI
protected:
void RenderAttributes(
   IContext^ objContext,
   IAttributeWriter^ objWriter,
   bool blnRenderOwner
) override

Parameters

objContext
objWriter
blnRenderOwner

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewHeaderCell Class
DataGridViewHeaderCell Members


RenderBackColorAttribute Method

[image]
Gizmox.WebGUI.Forms
RenderBackColorAttribute Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewHeaderCell Class : RenderBackColorAttribute Method

objWriter
The obj writer.
objInheritedCellStyle
The obj inherited cell style.
Renders the back-color attribute.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub RenderBackColorAttribute( _
   ByVal objWriter As IAttributeWriter, _
   ByVal objInheritedCellStyle As DataGridViewCellStyle _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewHeaderCell
Dim objWriter As IAttributeWriter
Dim objInheritedCellStyle As DataGridViewCellStyle

instance.RenderBackColorAttribute(objWriter, objInheritedCellStyle)
C#
protected override void RenderBackColorAttribute(
   IAttributeWriter objWriter,
   DataGridViewCellStyle objInheritedCellStyle
)
Managed Extensions for C++
protected: void RenderBackColorAttribute(
   IAttributeWriter* objWriter,
   DataGridViewCellStyle* objInheritedCellStyle
) override
C++/CLI
protected:
void RenderBackColorAttribute(
   IAttributeWriter^ objWriter,
   DataGridViewCellStyle^ objInheritedCellStyle
) override

Parameters

objWriter
The obj writer.
objInheritedCellStyle
The obj inherited cell style.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewHeaderCell Class
DataGridViewHeaderCell Members


RenderForeColorAttribute Method

[image]
Gizmox.WebGUI.Forms
RenderForeColorAttribute Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewHeaderCell Class : RenderForeColorAttribute Method

objWriter
The obj writer.
objInheritedCellStyle
The obj inherited cell style.
Renders the fore color attribute.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub RenderForeColorAttribute( _
   ByVal objWriter As IAttributeWriter, _
   ByVal objInheritedCellStyle As DataGridViewCellStyle _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewHeaderCell
Dim objWriter As IAttributeWriter
Dim objInheritedCellStyle As DataGridViewCellStyle

instance.RenderForeColorAttribute(objWriter, objInheritedCellStyle)
C#
protected override void RenderForeColorAttribute(
   IAttributeWriter objWriter,
   DataGridViewCellStyle objInheritedCellStyle
)
Managed Extensions for C++
protected: void RenderForeColorAttribute(
   IAttributeWriter* objWriter,
   DataGridViewCellStyle* objInheritedCellStyle
) override
C++/CLI
protected:
void RenderForeColorAttribute(
   IAttributeWriter^ objWriter,
   DataGridViewCellStyle^ objInheritedCellStyle
) override

Parameters

objWriter
The obj writer.
objInheritedCellStyle
The obj inherited cell style.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewHeaderCell Class
DataGridViewHeaderCell Members


RenderReadOnlyAttribute Method

[image]
Gizmox.WebGUI.Forms
RenderReadOnlyAttribute Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewHeaderCell Class : RenderReadOnlyAttribute Method

objWriter
The obj writer.
Renders the read only attribute.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub RenderReadOnlyAttribute( _
   ByVal objWriter As IAttributeWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewHeaderCell
Dim objWriter As IAttributeWriter

instance.RenderReadOnlyAttribute(objWriter)
C#
protected override void RenderReadOnlyAttribute(
   IAttributeWriter objWriter
)
Managed Extensions for C++
protected: void RenderReadOnlyAttribute(
   IAttributeWriter* objWriter
) override
C++/CLI
protected:
void RenderReadOnlyAttribute(
   IAttributeWriter^ objWriter
) override

Parameters

objWriter
The obj writer.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewHeaderCell Class
DataGridViewHeaderCell Members


RenderWrapModeAttribute Method

[image]
Gizmox.WebGUI.Forms
RenderWrapModeAttribute Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewHeaderCell Class : RenderWrapModeAttribute Method

objWriter
The obj writer.
objInheritedCellStyle
The obj inherited cell style.
Renders the wrap mode attribute.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub RenderWrapModeAttribute( _
   ByVal objWriter As IAttributeWriter, _
   ByVal objInheritedCellStyle As DataGridViewCellStyle _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewHeaderCell
Dim objWriter As IAttributeWriter
Dim objInheritedCellStyle As DataGridViewCellStyle

instance.RenderWrapModeAttribute(objWriter, objInheritedCellStyle)
C#
protected override void RenderWrapModeAttribute(
   IAttributeWriter objWriter,
   DataGridViewCellStyle objInheritedCellStyle
)
Managed Extensions for C++
protected: void RenderWrapModeAttribute(
   IAttributeWriter* objWriter,
   DataGridViewCellStyle* objInheritedCellStyle
) override
C++/CLI
protected:
void RenderWrapModeAttribute(
   IAttributeWriter^ objWriter,
   DataGridViewCellStyle^ objInheritedCellStyle
) override

Parameters

objWriter
The obj writer.
objInheritedCellStyle
The obj inherited cell style.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewHeaderCell Class
DataGridViewHeaderCell Members


ToString Method

[image]
Gizmox.WebGUI.Forms
ToString Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewHeaderCell Class : ToString Method

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewHeaderCell
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewHeaderCell Class
DataGridViewHeaderCell Members


DataGridViewHeaderCell Class Properties

[image]
Gizmox.WebGUI.Forms
DataGridViewHeaderCell Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewHeaderCell Class

For a list of all members of this type, see DataGridViewHeaderCell members.

Public Properties

 | Name | Description
Public Property | ColumnIndex | Gets the column index for this cell. (Inherited from DataGridViewCell)
Public Property | ContentBounds | (Inherited from DataGridViewCell)
Public Property | DataGridView | Gets the DataGridView control associated with this element. (Inherited from DataGridViewElement)
Public Property | DefaultNewRowValue | Gets the default value for a cell in the row for new records. (Inherited from DataGridViewCell)
Public Property | Displayed | Overridden.
Public Property | EditedFormattedValue | Gets the current, formatted value of the cell, regardless of whether the cell is in edit mode and the value has not been committed. (Inherited from DataGridViewCell)
Public Property | EditType | Gets the type of the cell's hosted editing control. (Inherited from DataGridViewCell)
Public Property | ErrorIconBounds | (Inherited from DataGridViewCell)
Public Property | ErrorText | Gets or sets the text describing an error condition associated with the cell. (Inherited from DataGridViewCell)
Public Property | FormattedValue | Gets the value of the cell as formatted for display. (Inherited from DataGridViewCell)
Public Property | FormattedValueType | Overridden. Gets the type of the formatted value of the cell.
Public Property | Frozen | Overridden. Gets a value indicating whether the cell is frozen.
Public Property | HasStyle | Gets a value indicating whether the DataGridViewCell.Style property has been set. (Inherited from DataGridViewCell)
Public Property | InheritedState | Gets the current state of the cell as inherited from the state of its row and column. (Inherited from DataGridViewCell)
Public Property | InheritedStyle | Gets the style currently applied to the cell. (Inherited from DataGridViewCell)
Public Property | IsInEditMode | Gets a value indicating whether this cell is currently being edited. (Inherited from DataGridViewCell)
Public Property | OwningColumn | Gets the column that contains this cell. (Inherited from DataGridViewCell)
Public Property | OwningRow | Gets the row that contains this cell. (Inherited from DataGridViewCell)
Public Property | PreferredSize | Gets the size, in pixels, of a rectangular area into which the cell can fit. (Inherited from DataGridViewCell)
Public Property | ReadOnly | Overridden. Gets a value indicating whether the header cell is read-only.
Public Property | Resizable | Overridden. Gets a value indicating whether the cell is resizable.
Public Property | RowIndex | Gets the index of the cell's parent row. (Inherited from DataGridViewCell)
Public Property | Selected | Overridden. Gets or sets a value indicating whether the cell is selected.
Public Property | Size | Gets the size of the cell. (Inherited from DataGridViewCell)
Public Property | State | Gets the user interface (UI) state of the element. (Inherited from DataGridViewElement)
Public Property | Style | Gets or sets the style for the cell. (Inherited from DataGridViewCell)
Public Property | Tag | Gets or sets the object that contains supplemental data about the cell. (Inherited from DataGridViewCell)
Public Property | ToolTipText | Gets or sets the ToolTip text associated with this cell. (Inherited from DataGridViewCell)
Public Property | Value | Gets or sets the value associated with this cell. (Inherited from DataGridViewCell)
Public Property | ValueType | Overridden. Gets the type of the value stored in the cell.
Public Property | Visible | Overridden. Gets a value indicating whether or not the cell is visible.
Top

Protected Properties

 | Name | Description
Protected Property | ButtonState | Gets the buttonlike visual state of the header cell.
Protected Property | MemberID | (Inherited from DataGridViewCell)
Protected Property | TagName | (Inherited from DataGridViewElement)
Top

See Also

Reference

DataGridViewHeaderCell Class
Gizmox.WebGUI.Forms Namespace


ButtonState Property

[image]
Gizmox.WebGUI.Forms
ButtonState Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewHeaderCell Class : ButtonState Property

Gets the buttonlike visual state of the header cell.

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property ButtonState As ButtonState
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewHeaderCell
Dim value As ButtonState

value = instance.ButtonState
C#
protected ButtonState ButtonState {get;}
Managed Extensions for C++
protected: __property ButtonState get_ButtonState();
C++/CLI
protected:
property ButtonState ButtonState {
   ButtonState get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewHeaderCell Class
DataGridViewHeaderCell Members


Displayed Property

[image]
Gizmox.WebGUI.Forms
Displayed Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewHeaderCell Class : Displayed Property

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public Overrides ReadOnly Property Displayed As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewHeaderCell
Dim value As Boolean

value = instance.Displayed
C#
[BrowsableAttribute(false)]
public override bool Displayed {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property bool get_Displayed() override;
C++/CLI
[BrowsableAttribute(false)]
public:
property bool Displayed {
   bool get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewHeaderCell Class
DataGridViewHeaderCell Members


FormattedValueType Property

[image]
Gizmox.WebGUI.Forms
FormattedValueType Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewHeaderCell Class : FormattedValueType Property

Gets the type of the formatted value of the cell.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property FormattedValueType As Type
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewHeaderCell
Dim value As Type

value = instance.FormattedValueType
C#
public override Type FormattedValueType {get;}
Managed Extensions for C++
public: __property Type* get_FormattedValueType() override;
C++/CLI
public:
property Type^ FormattedValueType {
   Type^ get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewHeaderCell Class
DataGridViewHeaderCell Members


Frozen Property

[image]
Gizmox.WebGUI.Forms
Frozen Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewHeaderCell Class : Frozen Property

Gets a value indicating whether the cell is frozen.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public Overrides ReadOnly Property Frozen As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewHeaderCell
Dim value As Boolean

value = instance.Frozen
C#
[BrowsableAttribute(false)]
public override bool Frozen {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property bool get_Frozen() override;
C++/CLI
[BrowsableAttribute(false)]
public:
property bool Frozen {
   bool get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewHeaderCell Class
DataGridViewHeaderCell Members


ReadOnly Property

[image]
Gizmox.WebGUI.Forms
ReadOnly Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewHeaderCell Class : ReadOnly Property

Gets a value indicating whether the header cell is read-only.

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
Public Overrides Property ReadOnly As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewHeaderCell
Dim value As Boolean

instance.ReadOnly = value

value = instance.ReadOnly
C#
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public override bool ReadOnly {get; set;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public: __property bool get_ReadOnly() override;
public: __property void set_ReadOnly(
   bool value
) override;
C++/CLI
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public:
property bool ReadOnly {
   bool get() override;
   void set (boolvalue) override;
}

Exceptions

Exception | Description
InvalidOperationException | An operation tries to set this property.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewHeaderCell Class
DataGridViewHeaderCell Members


Resizable Property

[image]
Gizmox.WebGUI.Forms
Resizable Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewHeaderCell Class : Resizable Property

Gets a value indicating whether the cell is resizable.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public Overrides ReadOnly Property Resizable As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewHeaderCell
Dim value As Boolean

value = instance.Resizable
C#
[BrowsableAttribute(false)]
public override bool Resizable {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property bool get_Resizable() override;
C++/CLI
[BrowsableAttribute(false)]
public:
property bool Resizable {
   bool get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewHeaderCell Class
DataGridViewHeaderCell Members


Selected Property

[image]
Gizmox.WebGUI.Forms
Selected Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewHeaderCell Class : Selected Property

Gets or sets a value indicating whether the cell is selected.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public Overrides Property Selected As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewHeaderCell
Dim value As Boolean

instance.Selected = value

value = instance.Selected
C#
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public override bool Selected {get; set;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property bool get_Selected() override;
public: __property void set_Selected(
   bool value
) override;
C++/CLI
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
property bool Selected {
   bool get() override;
   void set (boolvalue) override;
}

Exceptions

Exception | Description
InvalidOperationException | This property is being set.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewHeaderCell Class
DataGridViewHeaderCell Members


ValueType Property

[image]
Gizmox.WebGUI.Forms
ValueType Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewHeaderCell Class : ValueType Property

Gets the type of the value stored in the cell.

Syntax

Visual Basic (Declaration)
Public Overrides Property ValueType As Type
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewHeaderCell
Dim value As Type

instance.ValueType = value

value = instance.ValueType
C#
public override Type ValueType {get; set;}
Managed Extensions for C++
public: __property Type* get_ValueType() override;
public: __property void set_ValueType(
   Type* value
) override;
C++/CLI
public:
property Type^ ValueType {
   Type^ get() override;
   void set (Type^value) override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewHeaderCell Class
DataGridViewHeaderCell Members


Visible Property

[image]
Gizmox.WebGUI.Forms
Visible Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewHeaderCell Class : Visible Property

Gets a value indicating whether or not the cell is visible.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public Overrides ReadOnly Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewHeaderCell
Dim value As Boolean

value = instance.Visible
C#
[BrowsableAttribute(false)]
public override bool Visible {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property bool get_Visible() override;
C++/CLI
[BrowsableAttribute(false)]
public:
property bool Visible {
   bool get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewHeaderCell Class
DataGridViewHeaderCell Members


DataGridViewHeaderCell Class Fields

[image]
Gizmox.WebGUI.Forms
DataGridViewHeaderCell Class Fields
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewHeaderCell Class

For a list of all members of this type, see DataGridViewHeaderCell members.

Protected Fields

 | Name | Description
static (Shared in Visual Basic) | cellType |
static (Shared in Visual Basic) | DATAGRIDVIEWHEADERCELL_themeMargin |
static (Shared in Visual Basic) | defaultFormattedValueType |
static (Shared in Visual Basic) | defaultValueType |
static (Shared in Visual Basic) | HeaderTypeName |
static (Shared in Visual Basic) | PropButtonState |
static (Shared in Visual Basic) | PropFlipXPThemesBitmap |
static (Shared in Visual Basic) | PropValueType |
static (Shared in Visual Basic) | rectThemeMargins |
Top

See Also

Reference

DataGridViewHeaderCell Class
Gizmox.WebGUI.Forms Namespace


cellType Field

[image]
Gizmox.WebGUI.Forms
cellType Field
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewHeaderCell Class : cellType Field

Syntax

Visual Basic (Declaration)
Protected Shared cellType As Type
Visual Basic (Usage) Copy Code
Dim value As Type

value = DataGridViewHeaderCell.cellType

DataGridViewHeaderCell.cellType = value
C#
protected static Type cellType
Managed Extensions for C++
protected: static Type* cellType
C++/CLI
protected:
static Type^ cellType

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewHeaderCell Class
DataGridViewHeaderCell Members


DATAGRIDVIEWHEADERCELL_themeMargin Field

[image]
Gizmox.WebGUI.Forms
DATAGRIDVIEWHEADERCELL_themeMargin Field
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewHeaderCell Class : DATAGRIDVIEWHEADERCELL_themeMargin Field

Syntax

Visual Basic (Declaration)
Protected Shared DATAGRIDVIEWHEADERCELL_themeMargin As Byte
Visual Basic (Usage) Copy Code
Dim value As Byte

value = DataGridViewHeaderCell.DATAGRIDVIEWHEADERCELL_themeMargin

DataGridViewHeaderCell.DATAGRIDVIEWHEADERCELL_themeMargin = value
C#
protected static byte DATAGRIDVIEWHEADERCELL_themeMargin
Managed Extensions for C++
protected: static byte DATAGRIDVIEWHEADERCELL_themeMargin
C++/CLI
protected:
static byte DATAGRIDVIEWHEADERCELL_themeMargin

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewHeaderCell Class
DataGridViewHeaderCell Members


defaultFormattedValueType Field

[image]
Gizmox.WebGUI.Forms
defaultFormattedValueType Field
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewHeaderCell Class : defaultFormattedValueType Field

Syntax

Visual Basic (Declaration)
Protected Shared defaultFormattedValueType As Type
Visual Basic (Usage) Copy Code
Dim value As Type

value = DataGridViewHeaderCell.defaultFormattedValueType

DataGridViewHeaderCell.defaultFormattedValueType = value
C#
protected static Type defaultFormattedValueType
Managed Extensions for C++
protected: static Type* defaultFormattedValueType
C++/CLI
protected:
static Type^ defaultFormattedValueType

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewHeaderCell Class
DataGridViewHeaderCell Members


defaultValueType Field

[image]
Gizmox.WebGUI.Forms
defaultValueType Field
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewHeaderCell Class : defaultValueType Field

Syntax

Visual Basic (Declaration)
Protected Shared defaultValueType As Type
Visual Basic (Usage) Copy Code
Dim value As Type

value = DataGridViewHeaderCell.defaultValueType

DataGridViewHeaderCell.defaultValueType = value
C#
protected static Type defaultValueType
Managed Extensions for C++
protected: static Type* defaultValueType
C++/CLI
protected:
static Type^ defaultValueType

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewHeaderCell Class
DataGridViewHeaderCell Members


HeaderTypeName Field

[image]
Gizmox.WebGUI.Forms
HeaderTypeName Field
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewHeaderCell Class : HeaderTypeName Field

Syntax

Visual Basic (Declaration)
Protected Shared HeaderTypeName As String
Visual Basic (Usage) Copy Code
Dim value As String

value = DataGridViewHeaderCell.HeaderTypeName

DataGridViewHeaderCell.HeaderTypeName = value
C#
protected static string HeaderTypeName
Managed Extensions for C++
protected: static string* HeaderTypeName
C++/CLI
protected:
static String^ HeaderTypeName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewHeaderCell Class
DataGridViewHeaderCell Members


PropButtonState Field

[image]
Gizmox.WebGUI.Forms
PropButtonState Field
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewHeaderCell Class : PropButtonState Field

Syntax

Visual Basic (Declaration)
Protected Shared ReadOnly PropButtonState As Integer
Visual Basic (Usage) Copy Code
Dim value As Integer

value = DataGridViewHeaderCell.PropButtonState
C#
protected static readonly int PropButtonState
Managed Extensions for C++
protected: static readonly int PropButtonState
C++/CLI
protected:
static readonly int PropButtonState

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewHeaderCell Class
DataGridViewHeaderCell Members


PropFlipXPThemesBitmap Field

[image]
Gizmox.WebGUI.Forms
PropFlipXPThemesBitmap Field
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewHeaderCell Class : PropFlipXPThemesBitmap Field

Syntax

Visual Basic (Declaration)
Protected Shared ReadOnly PropFlipXPThemesBitmap As Integer
Visual Basic (Usage) Copy Code
Dim value As Integer

value = DataGridViewHeaderCell.PropFlipXPThemesBitmap
C#
protected static readonly int PropFlipXPThemesBitmap
Managed Extensions for C++
protected: static readonly int PropFlipXPThemesBitmap
C++/CLI
protected:
static readonly int PropFlipXPThemesBitmap

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewHeaderCell Class
DataGridViewHeaderCell Members


PropValueType Field

[image]
Gizmox.WebGUI.Forms
PropValueType Field
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewHeaderCell Class : PropValueType Field

Syntax

Visual Basic (Declaration)
Protected Shared ReadOnly PropValueType As Integer
Visual Basic (Usage) Copy Code
Dim value As Integer

value = DataGridViewHeaderCell.PropValueType
C#
protected static readonly int PropValueType
Managed Extensions for C++
protected: static readonly int PropValueType
C++/CLI
protected:
static readonly int PropValueType

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewHeaderCell Class
DataGridViewHeaderCell Members


rectThemeMargins Field

[image]
Gizmox.WebGUI.Forms
rectThemeMargins Field
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewHeaderCell Class : rectThemeMargins Field

Syntax

Visual Basic (Declaration)
Protected Shared rectThemeMargins As Rectangle
Visual Basic (Usage) Copy Code
Dim value As Rectangle

value = DataGridViewHeaderCell.rectThemeMargins

DataGridViewHeaderCell.rectThemeMargins = value
C#
protected static Rectangle rectThemeMargins
Managed Extensions for C++
protected: static Rectangle rectThemeMargins
C++/CLI
protected:
static Rectangle rectThemeMargins

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewHeaderCell Class
DataGridViewHeaderCell Members


DataGridViewImageCell Class

[image]
Gizmox.WebGUI.Forms
DataGridViewImageCell Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewImageCell Class

Displays a graphic in a DataGridView control.

Object Model

Syntax

Visual Basic (Declaration)
Public Class DataGridViewImageCell
   Inherits DataGridViewCell
   Implements IRenderableComponentMember
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewImageCell
C#
public class DataGridViewImageCell : DataGridViewCell, IRenderableComponentMember
Managed Extensions for C++
public __gc class DataGridViewImageCell : public DataGridViewCell, IRenderableComponentMember
C++/CLI
public ref class DataGridViewImageCell : public DataGridViewCell, IRenderableComponentMember

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.DataGridViewElement
Gizmox.WebGUI.Forms.DataGridViewCell
Gizmox.WebGUI.Forms.DataGridViewImageCell

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

DataGridViewImageCell Members
Gizmox.WebGUI.Forms Namespace


DataGridViewImageCell Class Members

[image]
Gizmox.WebGUI.Forms
DataGridViewImageCell Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewImageCell Class

The following tables list the members exposed by DataGridViewImageCell.

Public Constructors

 | Name | Description
Public Constructor | DataGridViewImageCell Constructor | Overloaded. Initializes a new instance of the DataGridViewImageCell class, configuring it for use with cell values other than Icon objects.
Top

Public Properties

 | Name | Description
Public Property | ColumnIndex | Gets the column index for this cell. (Inherited from DataGridViewCell)
Public Property | ContentBounds | (Inherited from DataGridViewCell)
Public Property | DataGridView | Gets the DataGridView control associated with this element. (Inherited from DataGridViewElement)
Public Property | DefaultNewRowValue | Overridden. Gets the default value that is used when creating a new row.
Public Property | Description | Gets or sets the text associated with the image.
Public Property | Displayed | Gets a value that indicates whether the cell is currently displayed on-screen. (Inherited from DataGridViewCell)
Public Property | EditedFormattedValue | Gets the current, formatted value of the cell, regardless of whether the cell is in edit mode and the value has not been committed. (Inherited from DataGridViewCell)
Public Property | EditType | Overridden. Gets the type of the cell's hosted editing control.
Public Property | ErrorIconBounds | (Inherited from DataGridViewCell)
Public Property | ErrorText | Gets or sets the text describing an error condition associated with the cell. (Inherited from DataGridViewCell)
Public Property | FormattedValue | Gets the value of the cell as formatted for display. (Inherited from DataGridViewCell)
Public Property | FormattedValueType | Overridden. Gets the type of the formatted value associated with the cell.
Public Property | Frozen | Gets a value indicating whether the cell is frozen. (Inherited from DataGridViewCell)
Public Property | HasStyle | Gets a value indicating whether the DataGridViewCell.Style property has been set. (Inherited from DataGridViewCell)
Public Property | ImageLayout | Gets or sets the graphics layout for the cell.
Public Property | InheritedState | Gets the current state of the cell as inherited from the state of its row and column. (Inherited from DataGridViewCell)
Public Property | InheritedStyle | Gets the style currently applied to the cell. (Inherited from DataGridViewCell)
Public Property | IsInEditMode | Gets a value indicating whether this cell is currently being edited. (Inherited from DataGridViewCell)
Public Property | OwningColumn | Gets the column that contains this cell. (Inherited from DataGridViewCell)
Public Property | OwningRow | Gets the row that contains this cell. (Inherited from DataGridViewCell)
Public Property | PreferredSize | Gets the size, in pixels, of a rectangular area into which the cell can fit. (Inherited from DataGridViewCell)
Public Property | ReadOnly | Gets or sets a value indicating whether the cell's data can be edited. (Inherited from DataGridViewCell)
Public Property | Resizable | Gets a value indicating whether the cell can be resized. (Inherited from DataGridViewCell)
Public Property | RowIndex | Gets the index of the cell's parent row. (Inherited from DataGridViewCell)
Public Property | Selected | Gets or sets a value indicating whether the cell has been selected. (Inherited from DataGridViewCell)
Public Property | Size | Gets the size of the cell. (Inherited from DataGridViewCell)
Public Property | State | Gets the user interface (UI) state of the element. (Inherited from DataGridViewElement)
Public Property | Style | Gets or sets the style for the cell. (Inherited from DataGridViewCell)
Public Property | Tag | Gets or sets the object that contains supplemental data about the cell. (Inherited from DataGridViewCell)
Public Property | ToolTipText | Gets or sets the ToolTip text associated with this cell. (Inherited from DataGridViewCell)
Public Property | Value | Gets or sets the value associated with this cell. (Inherited from DataGridViewCell)
Public Property | ValueIsIcon | Gets or sets a value indicating whether this cell displays an Icon value.
Public Property | ValueType | Overridden. Gets or sets the data type of the values in the cell.
Public Property | Visible | Gets a value indicating whether the cell is in a row or column that has been hidden. (Inherited from DataGridViewCell)
Top

Protected Properties

 | Name | Description
Protected Property | MemberID | (Inherited from DataGridViewCell)
Protected Property | TagName | (Inherited from DataGridViewElement)
Top

Public Methods

 | Name | Description
Public Method | AdjustCellBorderStyle | Modifies the input cell border style according to the specified criteria. (Inherited from DataGridViewCell)
Public Method | Clone | Overridden. Creates an exact copy of this cell.
Public Method | DetachEditingControl | Removes the cell's editing control from the DataGridView. (Inherited from DataGridViewCell)
Public Method | Dispose | Overloaded. Releases all resources used by the DataGridViewCell. (Inherited from DataGridViewCell)
Public Method | GetContentBounds | Overloaded. (Inherited from DataGridViewCell)
Public Method | GetEditedFormattedValue | Returns the current, formatted value of the cell, regardless of whether the cell is in edit mode and the value has not been committed. (Inherited from DataGridViewCell)
Public Method | GetInheritedState | Returns a value indicating the current state of the cell as inherited from the state of its row and column. (Inherited from DataGridViewCell)
Public Method | GetInheritedStyle | Gets the style applied to the cell. (Inherited from DataGridViewCell)
Public Method | InitializeEditingControl | Initializes the control used to edit the cell. (Inherited from DataGridViewCell)
Public Method | KeyEntersEditMode | Determines if edit mode should be started based on the given key. (Inherited from DataGridViewCell)
Public Method | ParseFormattedValue | (Inherited from DataGridViewCell)
Public Method | PositionEditingControl | Sets the location and size of the editing control hosted by a cell in the DataGridView control. (Inherited from DataGridViewCell)
Public Method | PositionEditingPanel | (Inherited from DataGridViewCell)
Public Method | ToString | Overridden.
Public Method | Update | Overloaded. Full updates of this instance. (Inherited from DataGridViewElement)
Top

Protected Methods

 | Name | Description
Protected Method | BorderWidths | (Inherited from DataGridViewCell)
Protected Method | ClickUnsharesRow | Indicates whether the cell's row will be unshared when the cell is clicked. (Inherited from DataGridViewCell)
Protected Method | ContentClickUnsharesRow | Indicates whether the cell's row will be unshared when the cell's content is clicked. (Inherited from DataGridViewCell)
Protected Method | ContentDoubleClickUnsharesRow | Indicates whether the cell's row will be unshared when the cell's content is double-clicked. (Inherited from DataGridViewCell)
Protected Method | DoubleClickUnsharesRow | Indicates whether the cell's row will be unshared when the cell is double-clicked. (Inherited from DataGridViewCell)
Protected Method | EnterUnsharesRow | Indicates whether the parent row will be unshared when the focus moves to the cell. (Inherited from DataGridViewCell)
Protected Method | GetClipboardContent | Retrieves the formatted value of the cell to copy to the Clipboard. (Inherited from DataGridViewCell)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from DataGridViewElement)
Protected Method | GetDefaultHorizontalAlignment | Gets the horizontal alignment. (Inherited from DataGridViewCell)
Protected Method | GetDefaultVerticalAlignment | Gets the vertical alignment. (Inherited from DataGridViewCell)
Protected Method | GetErrorIconBounds | (Inherited from DataGridViewCell)
Protected Method | GetErrorText | Returns a string that represents the error for the cell. (Inherited from DataGridViewCell)
Protected Method | GetFormattedValue | Overridden. Returns a graphic as it would be displayed in the cell.
Protected Method | GetPreferredSize | Overloaded. Overridden. Calculates the preferred size, in pixels, of the cell.
Protected Method | GetSize | Gets the size of the cell. (Inherited from DataGridViewCell)
Protected Method | GetValue | Overridden.
Protected Method | IsDirty | Determines whether the specified component is dirty. (Inherited from DataGridViewElement)
Protected Method | IsDirtyAttributes | Overloaded. Determines whether the specified component is dirty. (Inherited from DataGridViewElement)
Protected Method | KeyDownUnsharesRow | Indicates whether the parent row is unshared if the user presses a key while the focus is on the cell. (Inherited from DataGridViewCell)
Protected Method | KeyPressUnsharesRow | Indicates whether a row will be unshared if a key is pressed while a cell in the row has focus. (Inherited from DataGridViewCell)
Protected Method | KeyUpUnsharesRow | Indicates whether the parent row is unshared when the user releases a key while the focus is on the cell. (Inherited from DataGridViewCell)
Protected Method | LeaveUnsharesRow | Indicates whether a row will be unshared when the focus leaves a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseClickUnsharesRow | Indicates whether a row will be unshared if the user clicks a mouse button while the pointer is on a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseDoubleClickUnsharesRow | Indicates whether a row will be unshared if the user double-clicks a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseDownUnsharesRow | Indicates whether a row will be unshared when the user holds down a mouse button while the pointer is on a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseEnterUnsharesRow | Indicates whether a row will be unshared when the mouse pointer moves over a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseLeaveUnsharesRow | Indicates whether a row will be unshared when the mouse pointer leaves the row. (Inherited from DataGridViewCell)
Protected Method | MouseMoveUnsharesRow | Indicates whether a row will be unshared when the mouse pointer moves over a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseUpUnsharesRow | Indicates whether a row will be unshared when the user releases a mouse button while the pointer is on a cell in the row. (Inherited from DataGridViewCell)
Protected Method | OnClick | Called when the cell is clicked. (Inherited from DataGridViewCell)
Protected Method | OnContentClick | Called when the cell's contents are clicked. (Inherited from DataGridViewCell)
Protected Method | OnContentDoubleClick | Called when the cell's contents are double-clicked. (Inherited from DataGridViewCell)
Protected Method | OnDataGridViewChanged | Called when the DataGridViewElement.DataGridView property of the cell changes. (Inherited from DataGridViewCell)
Protected Method | OnDoubleClick | Called when the cell is double-clicked. (Inherited from DataGridViewCell)
Protected Method | OnEnter | Called when the focus moves to a cell. (Inherited from DataGridViewCell)
Protected Method | OnKeyDown | Called when a character key is pressed while the focus is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnKeyPress | Called when a key is pressed while the focus is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnKeyUp | Called when a character key is released while the focus is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnLeave | Called when the focus moves from a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseClick | Called when the user clicks a mouse button while the pointer is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseDoubleClick | Called when the user double-clicks a mouse button while the pointer is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseDown | Called when the user holds down a mouse button while the pointer is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseEnter | Called when the mouse pointer moves over a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseLeave | Called when the mouse pointer leaves the cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseMove | Called when the mouse pointer moves within a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseUp | Called when the user releases a mouse button while the pointer is on a cell. (Inherited from DataGridViewCell)
Protected Method | Paint | (Inherited from DataGridViewCell)
Protected Method | PaintErrorIcon | (Inherited from DataGridViewCell)
Protected Method | ProcessGatewayRequest | Overridden.
Protected Method | RaiseCellClick | Raises the DataGridView.CellClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellContentClick | Raises the DataGridView.CellContentClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellContentDoubleClick | Raises the DataGridView.CellContentDoubleClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellValueChanged | Raises the CellValueChanged event. (Inherited from DataGridViewElement)
Protected Method | RaiseDataError | Raises the DataError event. (Inherited from DataGridViewElement)
Protected Method | RaiseMouseWheel | Raises the MouseWheel event. (Inherited from DataGridViewElement)
Protected Method | RenderAttributes | Overridden.
Protected Method | RenderBackColorAttribute | Renders the back color attribute. (Inherited from DataGridViewCell)
Protected Method | RenderComponent | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from DataGridViewElement)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from DataGridViewElement)
Protected Method | RenderComponents | Renders the controls sub tree (Inherited from DataGridViewElement)
Protected Method | RenderForeColorAttribute | Renders the fore color attribute. (Inherited from DataGridViewCell)
Protected Method | RenderReadOnlyAttribute | Renders the read only attribute. (Inherited from DataGridViewCell)
Protected Method | RenderUpdatedAttributes | Renders the updated attributes (Inherited from DataGridViewElement)
Protected Method | RenderWrapModeAttribute | Renders the wrap mode attribute. (Inherited from DataGridViewCell)
Protected Method | SetValue | Sets the value of the cell. (Inherited from DataGridViewCell)
Protected Method | UpdateParams | Overloaded. Updates only the parameters of this instance. (Inherited from DataGridViewElement)
Top

See Also

Reference

DataGridViewImageCell Class
Gizmox.WebGUI.Forms Namespace


DataGridViewImageCell Constructor

[image]
Gizmox.WebGUI.Forms
DataGridViewImageCell Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewImageCell Class : DataGridViewImageCell Constructor

Initializes a new instance of the DataGridViewImageCell class, configuring it for use with cell values other than Icon objects.

Overload List

Overload | Description
DataGridViewImageCell Constructor() | Initializes a new instance of the DataGridViewImageCell class, configuring it for use with cell values other than Icon objects.
DataGridViewImageCell Constructor(Boolean) | Initializes a new instance of the DataGridViewImageCell class, optionally configuring it for use with Icon cell values.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewImageCell Class
DataGridViewImageCell Members


DataGridViewImageCell Constructor()

[image]
Gizmox.WebGUI.Forms
DataGridViewImageCell Constructor()
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewImageCell Class > DataGridViewImageCell Constructor : DataGridViewImageCell Constructor()

Initializes a new instance of the DataGridViewImageCell class, configuring it for use with cell values other than Icon objects.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewImageCell()
C#
public DataGridViewImageCell()
Managed Extensions for C++
public: DataGridViewImageCell();
C++/CLI
public:
DataGridViewImageCell();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewImageCell Class
DataGridViewImageCell Members
Overload List


DataGridViewImageCell Constructor(Boolean)

[image]
Gizmox.WebGUI.Forms
DataGridViewImageCell Constructor(Boolean)
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewImageCell Class > DataGridViewImageCell Constructor : DataGridViewImageCell Constructor(Boolean)

valueIsIcon
The cell will display an Icon value.
Initializes a new instance of the DataGridViewImageCell class, optionally configuring it for use with Icon cell values.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal valueIsIcon As Boolean _
)
Visual Basic (Usage) Copy Code
Dim valueIsIcon As Boolean

Dim instance As DataGridViewImageCell(valueIsIcon)
C#
public DataGridViewImageCell(
   bool valueIsIcon
)
Managed Extensions for C++
public: DataGridViewImageCell(
   bool valueIsIcon
)
C++/CLI
public:
DataGridViewImageCell(
   bool valueIsIcon
)

Parameters

valueIsIcon
The cell will display an Icon value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewImageCell Class
DataGridViewImageCell Members
Overload List


DataGridViewImageCell Class Methods

[image]
Gizmox.WebGUI.Forms
DataGridViewImageCell Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewImageCell Class

For a list of all members of this type, see DataGridViewImageCell members.

Public Methods

 | Name | Description
Public Method | AdjustCellBorderStyle | Modifies the input cell border style according to the specified criteria. (Inherited from DataGridViewCell)
Public Method | Clone | Overridden. Creates an exact copy of this cell.
Public Method | DetachEditingControl | Removes the cell's editing control from the DataGridView. (Inherited from DataGridViewCell)
Public Method | Dispose | Overloaded. Releases all resources used by the DataGridViewCell. (Inherited from DataGridViewCell)
Public Method | GetContentBounds | Overloaded. (Inherited from DataGridViewCell)
Public Method | GetEditedFormattedValue | Returns the current, formatted value of the cell, regardless of whether the cell is in edit mode and the value has not been committed. (Inherited from DataGridViewCell)
Public Method | GetInheritedState | Returns a value indicating the current state of the cell as inherited from the state of its row and column. (Inherited from DataGridViewCell)
Public Method | GetInheritedStyle | Gets the style applied to the cell. (Inherited from DataGridViewCell)
Public Method | InitializeEditingControl | Initializes the control used to edit the cell. (Inherited from DataGridViewCell)
Public Method | KeyEntersEditMode | Determines if edit mode should be started based on the given key. (Inherited from DataGridViewCell)
Public Method | ParseFormattedValue | (Inherited from DataGridViewCell)
Public Method | PositionEditingControl | Sets the location and size of the editing control hosted by a cell in the DataGridView control. (Inherited from DataGridViewCell)
Public Method | PositionEditingPanel | (Inherited from DataGridViewCell)
Public Method | ToString | Overridden.
Public Method | Update | Overloaded. Full updates of this instance. (Inherited from DataGridViewElement)
Top

Protected Methods

 | Name | Description
Protected Method | BorderWidths | (Inherited from DataGridViewCell)
Protected Method | ClickUnsharesRow | Indicates whether the cell's row will be unshared when the cell is clicked. (Inherited from DataGridViewCell)
Protected Method | ContentClickUnsharesRow | Indicates whether the cell's row will be unshared when the cell's content is clicked. (Inherited from DataGridViewCell)
Protected Method | ContentDoubleClickUnsharesRow | Indicates whether the cell's row will be unshared when the cell's content is double-clicked. (Inherited from DataGridViewCell)
Protected Method | DoubleClickUnsharesRow | Indicates whether the cell's row will be unshared when the cell is double-clicked. (Inherited from DataGridViewCell)
Protected Method | EnterUnsharesRow | Indicates whether the parent row will be unshared when the focus moves to the cell. (Inherited from DataGridViewCell)
Protected Method | GetClipboardContent | Retrieves the formatted value of the cell to copy to the Clipboard. (Inherited from DataGridViewCell)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from DataGridViewElement)
Protected Method | GetDefaultHorizontalAlignment | Gets the horizontal alignment. (Inherited from DataGridViewCell)
Protected Method | GetDefaultVerticalAlignment | Gets the vertical alignment. (Inherited from DataGridViewCell)
Protected Method | GetErrorIconBounds | (Inherited from DataGridViewCell)
Protected Method | GetErrorText | Returns a string that represents the error for the cell. (Inherited from DataGridViewCell)
Protected Method | GetFormattedValue | Overridden. Returns a graphic as it would be displayed in the cell.
Protected Method | GetPreferredSize | Overloaded. Overridden. Calculates the preferred size, in pixels, of the cell.
Protected Method | GetSize | Gets the size of the cell. (Inherited from DataGridViewCell)
Protected Method | GetValue | Overridden.
Protected Method | IsDirty | Determines whether the specified component is dirty. (Inherited from DataGridViewElement)
Protected Method | IsDirtyAttributes | Overloaded. Determines whether the specified component is dirty. (Inherited from DataGridViewElement)
Protected Method | KeyDownUnsharesRow | Indicates whether the parent row is unshared if the user presses a key while the focus is on the cell. (Inherited from DataGridViewCell)
Protected Method | KeyPressUnsharesRow | Indicates whether a row will be unshared if a key is pressed while a cell in the row has focus. (Inherited from DataGridViewCell)
Protected Method | KeyUpUnsharesRow | Indicates whether the parent row is unshared when the user releases a key while the focus is on the cell. (Inherited from DataGridViewCell)
Protected Method | LeaveUnsharesRow | Indicates whether a row will be unshared when the focus leaves a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseClickUnsharesRow | Indicates whether a row will be unshared if the user clicks a mouse button while the pointer is on a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseDoubleClickUnsharesRow | Indicates whether a row will be unshared if the user double-clicks a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseDownUnsharesRow | Indicates whether a row will be unshared when the user holds down a mouse button while the pointer is on a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseEnterUnsharesRow | Indicates whether a row will be unshared when the mouse pointer moves over a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseLeaveUnsharesRow | Indicates whether a row will be unshared when the mouse pointer leaves the row. (Inherited from DataGridViewCell)
Protected Method | MouseMoveUnsharesRow | Indicates whether a row will be unshared when the mouse pointer moves over a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseUpUnsharesRow | Indicates whether a row will be unshared when the user releases a mouse button while the pointer is on a cell in the row. (Inherited from DataGridViewCell)
Protected Method | OnClick | Called when the cell is clicked. (Inherited from DataGridViewCell)
Protected Method | OnContentClick | Called when the cell's contents are clicked. (Inherited from DataGridViewCell)
Protected Method | OnContentDoubleClick | Called when the cell's contents are double-clicked. (Inherited from DataGridViewCell)
Protected Method | OnDataGridViewChanged | Called when the DataGridViewElement.DataGridView property of the cell changes. (Inherited from DataGridViewCell)
Protected Method | OnDoubleClick | Called when the cell is double-clicked. (Inherited from DataGridViewCell)
Protected Method | OnEnter | Called when the focus moves to a cell. (Inherited from DataGridViewCell)
Protected Method | OnKeyDown | Called when a character key is pressed while the focus is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnKeyPress | Called when a key is pressed while the focus is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnKeyUp | Called when a character key is released while the focus is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnLeave | Called when the focus moves from a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseClick | Called when the user clicks a mouse button while the pointer is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseDoubleClick | Called when the user double-clicks a mouse button while the pointer is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseDown | Called when the user holds down a mouse button while the pointer is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseEnter | Called when the mouse pointer moves over a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseLeave | Called when the mouse pointer leaves the cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseMove | Called when the mouse pointer moves within a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseUp | Called when the user releases a mouse button while the pointer is on a cell. (Inherited from DataGridViewCell)
Protected Method | Paint | (Inherited from DataGridViewCell)
Protected Method | PaintErrorIcon | (Inherited from DataGridViewCell)
Protected Method | ProcessGatewayRequest | Overridden.
Protected Method | RaiseCellClick | Raises the DataGridView.CellClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellContentClick | Raises the DataGridView.CellContentClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellContentDoubleClick | Raises the DataGridView.CellContentDoubleClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellValueChanged | Raises the CellValueChanged event. (Inherited from DataGridViewElement)
Protected Method | RaiseDataError | Raises the DataError event. (Inherited from DataGridViewElement)
Protected Method | RaiseMouseWheel | Raises the MouseWheel event. (Inherited from DataGridViewElement)
Protected Method | RenderAttributes | Overridden.
Protected Method | RenderBackColorAttribute | Renders the back color attribute. (Inherited from DataGridViewCell)
Protected Method | RenderComponent | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from DataGridViewElement)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from DataGridViewElement)
Protected Method | RenderComponents | Renders the controls sub tree (Inherited from DataGridViewElement)
Protected Method | RenderForeColorAttribute | Renders the fore color attribute. (Inherited from DataGridViewCell)
Protected Method | RenderReadOnlyAttribute | Renders the read only attribute. (Inherited from DataGridViewCell)
Protected Method | RenderUpdatedAttributes | Renders the updated attributes (Inherited from DataGridViewElement)
Protected Method | RenderWrapModeAttribute | Renders the wrap mode attribute. (Inherited from DataGridViewCell)
Protected Method | SetValue | Sets the value of the cell. (Inherited from DataGridViewCell)
Protected Method | UpdateParams | Overloaded. Updates only the parameters of this instance. (Inherited from DataGridViewElement)
Top

See Also

Reference

DataGridViewImageCell Class
Gizmox.WebGUI.Forms Namespace


Clone Method

[image]
Gizmox.WebGUI.Forms
Clone Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewImageCell Class : Clone Method

Creates an exact copy of this cell.

Syntax

Visual Basic (Declaration)
Public Overrides Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewImageCell
Dim value As Object

value = instance.Clone()
C#
public override object Clone()
Managed Extensions for C++
public: Object* Clone(); override
C++/CLI
public:
Object^ Clone(); override

Return Value

An Object that represents the cloned DataGridViewImageCell.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewImageCell Class
DataGridViewImageCell Members


GetFormattedValue Method

[image]
Gizmox.WebGUI.Forms
GetFormattedValue Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewImageCell Class : GetFormattedValue Method

value
The value to be formatted.
rowIndex
The index of the cell's parent row.
cellStyle
The DataGridViewCellStyle in effect for the cell.
valueTypeConverter
A TypeConverter associated with the value type that provides custom conversion to the formatted value type, or null if no such custom conversion is needed.
formattedValueTypeConverter
A TypeConverter associated with the formatted value type that provides custom conversion from the value type, or null if no such custom conversion is needed.
context
A bitwise combination of DataGridViewDataErrorContexts values describing the context in which the formatted value is needed.
Returns a graphic as it would be displayed in the cell.

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetFormattedValue( _
   ByVal value As Object, _
   ByVal rowIndex As Integer, _
   ByRef cellStyle As DataGridViewCellStyle, _
   ByVal valueTypeConverter As TypeConverter, _
   ByVal formattedValueTypeConverter As TypeConverter, _
   ByVal context As DataGridViewDataErrorContexts _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewImageCell
Dim value As Object
Dim rowIndex As Integer
Dim cellStyle As DataGridViewCellStyle
Dim valueTypeConverter As TypeConverter
Dim formattedValueTypeConverter As TypeConverter
Dim context As DataGridViewDataErrorContexts
Dim value As Object

value = instance.GetFormattedValue(value, rowIndex, cellStyle, valueTypeConverter, formattedValueTypeConverter, context)
C#
protected override object GetFormattedValue(
   object value,
   int rowIndex,
   ref DataGridViewCellStyle cellStyle,
   TypeConverter valueTypeConverter,
   TypeConverter formattedValueTypeConverter,
   DataGridViewDataErrorContexts context
)
Managed Extensions for C++
protected: Object* GetFormattedValue(
   Object* value,
   int rowIndex,
   ref DataGridViewCellStyle* cellStyle,
   TypeConverter* valueTypeConverter,
   TypeConverter* formattedValueTypeConverter,
   DataGridViewDataErrorContexts context
) override
C++/CLI
protected:
Object^ GetFormattedValue(
   Object^ value,
   int rowIndex,
   DataGridViewCellStyle^% cellStyle,
   TypeConverter^ valueTypeConverter,
   TypeConverter^ formattedValueTypeConverter,
   DataGridViewDataErrorContexts context
) override

Parameters

value
The value to be formatted.
rowIndex
The index of the cell's parent row.
cellStyle
The DataGridViewCellStyle in effect for the cell.
valueTypeConverter
A TypeConverter associated with the value type that provides custom conversion to the formatted value type, or null if no such custom conversion is needed.
formattedValueTypeConverter
A TypeConverter associated with the formatted value type that provides custom conversion from the value type, or null if no such custom conversion is needed.
context
A bitwise combination of DataGridViewDataErrorContexts values describing the context in which the formatted value is needed.

Return Value

An object that represents the formatted image.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewImageCell Class
DataGridViewImageCell Members


GetPreferredSize Method

[image]
Gizmox.WebGUI.Forms
GetPreferredSize Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewImageCell Class : GetPreferredSize Method

Calculates the preferred size, in pixels, of the cell.

Overload List

Overload | Description
GetPreferredSize(Graphics,DataGridViewCellStyle,Int32,Size) | Calculates the preferred size, in pixels, of the cell.
GetPreferredSize(String,DataGridViewCellStyle) | Calculates the preferred size, in pixels, of the cell. (Inherited from DataGridViewCell)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewImageCell Class
DataGridViewImageCell Members


GetPreferredSize(Graphics,DataGridViewCellStyle,Int32,Size) Method

[image]
Gizmox.WebGUI.Forms
GetPreferredSize(Graphics,DataGridViewCellStyle,Int32,Size) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewImageCell Class > GetPreferredSize Method : GetPreferredSize(Graphics,DataGridViewCellStyle,Int32,Size) Method

graphics
The Graphics used to draw the cell.
cellStyle
A DataGridViewCellStyle that represents the style of the cell.
rowIndex
The zero-based row index of the cell.
constraintSize
The cell's maximum allowable size.
Calculates the preferred size, in pixels, of the cell.

Syntax

Visual Basic (Declaration)
Protected Overloads Overrides Function GetPreferredSize( _
   ByVal graphics As Graphics, _
   ByVal cellStyle As DataGridViewCellStyle, _
   ByVal rowIndex As Integer, _
   ByVal constraintSize As Size _
) As Size
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewImageCell
Dim graphics As Graphics
Dim cellStyle As DataGridViewCellStyle
Dim rowIndex As Integer
Dim constraintSize As Size
Dim value As Size

value = instance.GetPreferredSize(graphics, cellStyle, rowIndex, constraintSize)
C#
protected override Size GetPreferredSize(
   Graphics graphics,
   DataGridViewCellStyle cellStyle,
   int rowIndex,
   Size constraintSize
)
Managed Extensions for C++
protected: Size GetPreferredSize(
   Graphics* graphics,
   DataGridViewCellStyle* cellStyle,
   int rowIndex,
   Size constraintSize
) override
C++/CLI
protected:
Size GetPreferredSize(
   Graphics^ graphics,
   DataGridViewCellStyle^ cellStyle,
   int rowIndex,
   Size constraintSize
) override

Parameters

graphics
The Graphics used to draw the cell.
cellStyle
A DataGridViewCellStyle that represents the style of the cell.
rowIndex
The zero-based row index of the cell.
constraintSize
The cell's maximum allowable size.

Return Value

A Size that represents the preferred size, in pixels, of the cell.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewImageCell Class
DataGridViewImageCell Members
Overload List


GetValue Method

[image]
Gizmox.WebGUI.Forms
GetValue Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewImageCell Class : GetValue Method

rowIndex

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetValue( _
   ByVal rowIndex As Integer _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewImageCell
Dim rowIndex As Integer
Dim value As Object

value = instance.GetValue(rowIndex)
C#
protected override object GetValue(
   int rowIndex
)
Managed Extensions for C++
protected: Object* GetValue(
   int rowIndex
) override
C++/CLI
protected:
Object^ GetValue(
   int rowIndex
) override

Parameters

rowIndex

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewImageCell Class
DataGridViewImageCell Members


ProcessGatewayRequest Method

[image]
Gizmox.WebGUI.Forms
ProcessGatewayRequest Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewImageCell Class : ProcessGatewayRequest Method

objContext
strCellAction

Syntax

Visual Basic (Declaration)
Protected Overrides Sub ProcessGatewayRequest( _
   ByVal objContext As IContext, _
   ByVal strCellAction As String _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewImageCell
Dim objContext As IContext
Dim strCellAction As String

instance.ProcessGatewayRequest(objContext, strCellAction)
C#
protected override void ProcessGatewayRequest(
   IContext objContext,
   string strCellAction
)
Managed Extensions for C++
protected: void ProcessGatewayRequest(
   IContext* objContext,
   string* strCellAction
) override
C++/CLI
protected:
void ProcessGatewayRequest(
   IContext^ objContext,
   String^ strCellAction
) override

Parameters

objContext
strCellAction

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewImageCell Class
DataGridViewImageCell Members


RenderAttributes Method

[image]
Gizmox.WebGUI.Forms
RenderAttributes Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewImageCell Class : RenderAttributes Method

objContext
objWriter
blnRenderOwner

Syntax

Visual Basic (Declaration)
Protected Overrides Sub RenderAttributes( _
   ByVal objContext As IContext, _
   ByVal objWriter As IAttributeWriter, _
   ByVal blnRenderOwner As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewImageCell
Dim objContext As IContext
Dim objWriter As IAttributeWriter
Dim blnRenderOwner As Boolean

instance.RenderAttributes(objContext, objWriter, blnRenderOwner)
C#
protected override void RenderAttributes(
   IContext objContext,
   IAttributeWriter objWriter,
   bool blnRenderOwner
)
Managed Extensions for C++
protected: void RenderAttributes(
   IContext* objContext,
   IAttributeWriter* objWriter,
   bool blnRenderOwner
) override
C++/CLI
protected:
void RenderAttributes(
   IContext^ objContext,
   IAttributeWriter^ objWriter,
   bool blnRenderOwner
) override

Parameters

objContext
objWriter
blnRenderOwner

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewImageCell Class
DataGridViewImageCell Members


ToString Method

[image]
Gizmox.WebGUI.Forms
ToString Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewImageCell Class : ToString Method

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewImageCell
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewImageCell Class
DataGridViewImageCell Members


DataGridViewImageCell Class Properties

[image]
Gizmox.WebGUI.Forms
DataGridViewImageCell Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewImageCell Class

For a list of all members of this type, see DataGridViewImageCell members.

Public Properties

 | Name | Description
Public Property | ColumnIndex | Gets the column index for this cell. (Inherited from DataGridViewCell)
Public Property | ContentBounds | (Inherited from DataGridViewCell)
Public Property | DataGridView | Gets the DataGridView control associated with this element. (Inherited from DataGridViewElement)
Public Property | DefaultNewRowValue | Overridden. Gets the default value that is used when creating a new row.
Public Property | Description | Gets or sets the text associated with the image.
Public Property | Displayed | Gets a value that indicates whether the cell is currently displayed on-screen. (Inherited from DataGridViewCell)
Public Property | EditedFormattedValue | Gets the current, formatted value of the cell, regardless of whether the cell is in edit mode and the value has not been committed. (Inherited from DataGridViewCell)
Public Property | EditType | Overridden. Gets the type of the cell's hosted editing control.
Public Property | ErrorIconBounds | (Inherited from DataGridViewCell)
Public Property | ErrorText | Gets or sets the text describing an error condition associated with the cell. (Inherited from DataGridViewCell)
Public Property | FormattedValue | Gets the value of the cell as formatted for display. (Inherited from DataGridViewCell)
Public Property | FormattedValueType | Overridden. Gets the type of the formatted value associated with the cell.
Public Property | Frozen | Gets a value indicating whether the cell is frozen. (Inherited from DataGridViewCell)
Public Property | HasStyle | Gets a value indicating whether the DataGridViewCell.Style property has been set. (Inherited from DataGridViewCell)
Public Property | ImageLayout | Gets or sets the graphics layout for the cell.
Public Property | InheritedState | Gets the current state of the cell as inherited from the state of its row and column. (Inherited from DataGridViewCell)
Public Property | InheritedStyle | Gets the style currently applied to the cell. (Inherited from DataGridViewCell)
Public Property | IsInEditMode | Gets a value indicating whether this cell is currently being edited. (Inherited from DataGridViewCell)
Public Property | OwningColumn | Gets the column that contains this cell. (Inherited from DataGridViewCell)
Public Property | OwningRow | Gets the row that contains this cell. (Inherited from DataGridViewCell)
Public Property | PreferredSize | Gets the size, in pixels, of a rectangular area into which the cell can fit. (Inherited from DataGridViewCell)
Public Property | ReadOnly | Gets or sets a value indicating whether the cell's data can be edited. (Inherited from DataGridViewCell)
Public Property | Resizable | Gets a value indicating whether the cell can be resized. (Inherited from DataGridViewCell)
Public Property | RowIndex | Gets the index of the cell's parent row. (Inherited from DataGridViewCell)
Public Property | Selected | Gets or sets a value indicating whether the cell has been selected. (Inherited from DataGridViewCell)
Public Property | Size | Gets the size of the cell. (Inherited from DataGridViewCell)
Public Property | State | Gets the user interface (UI) state of the element. (Inherited from DataGridViewElement)
Public Property | Style | Gets or sets the style for the cell. (Inherited from DataGridViewCell)
Public Property | Tag | Gets or sets the object that contains supplemental data about the cell. (Inherited from DataGridViewCell)
Public Property | ToolTipText | Gets or sets the ToolTip text associated with this cell. (Inherited from DataGridViewCell)
Public Property | Value | Gets or sets the value associated with this cell. (Inherited from DataGridViewCell)
Public Property | ValueIsIcon | Gets or sets a value indicating whether this cell displays an Icon value.
Public Property | ValueType | Overridden. Gets or sets the data type of the values in the cell.
Public Property | Visible | Gets a value indicating whether the cell is in a row or column that has been hidden. (Inherited from DataGridViewCell)
Top

Protected Properties

 | Name | Description
Protected Property | MemberID | (Inherited from DataGridViewCell)
Protected Property | TagName | (Inherited from DataGridViewElement)
Top

See Also

Reference

DataGridViewImageCell Class
Gizmox.WebGUI.Forms Namespace


DefaultNewRowValue Property

[image]
Gizmox.WebGUI.Forms
DefaultNewRowValue Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewImageCell Class : DefaultNewRowValue Property

Gets the default value that is used when creating a new row.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property DefaultNewRowValue As Object
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewImageCell
Dim value As Object

value = instance.DefaultNewRowValue
C#
public override object DefaultNewRowValue {get;}
Managed Extensions for C++
public: __property Object* get_DefaultNewRowValue() override;
C++/CLI
public:
property Object^ DefaultNewRowValue {
   Object^ get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewImageCell Class
DataGridViewImageCell Members


Description Property

[image]
Gizmox.WebGUI.Forms
Description Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewImageCell Class : Description Property

Gets or sets the text associated with the image.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property Description As String
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewImageCell
Dim value As String

instance.Description = value

value = instance.Description
C#
[DefaultValueAttribute()]
public string Description {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property string* get_Description();
public: __property void set_Description(
   string* value
);
C++/CLI
[DefaultValueAttribute()]
public:
property String^ Description {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewImageCell Class
DataGridViewImageCell Members


EditType Property

[image]
Gizmox.WebGUI.Forms
EditType Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewImageCell Class : EditType Property

Gets the type of the cell's hosted editing control.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property EditType As Type
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewImageCell
Dim value As Type

value = instance.EditType
C#
public override Type EditType {get;}
Managed Extensions for C++
public: __property Type* get_EditType() override;
C++/CLI
public:
property Type^ EditType {
   Type^ get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewImageCell Class
DataGridViewImageCell Members


FormattedValueType Property

[image]
Gizmox.WebGUI.Forms
FormattedValueType Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewImageCell Class : FormattedValueType Property

Gets the type of the formatted value associated with the cell.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property FormattedValueType As Type
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewImageCell
Dim value As Type

value = instance.FormattedValueType
C#
public override Type FormattedValueType {get;}
Managed Extensions for C++
public: __property Type* get_FormattedValueType() override;
C++/CLI
public:
property Type^ FormattedValueType {
   Type^ get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewImageCell Class
DataGridViewImageCell Members


ImageLayout Property

[image]
Gizmox.WebGUI.Forms
ImageLayout Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewImageCell Class : ImageLayout Property

Gets or sets the graphics layout for the cell.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property ImageLayout As DataGridViewImageCellLayout
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewImageCell
Dim value As DataGridViewImageCellLayout

instance.ImageLayout = value

value = instance.ImageLayout
C#
[DefaultValueAttribute()]
public DataGridViewImageCellLayout ImageLayout {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property DataGridViewImageCellLayout get_ImageLayout();
public: __property void set_ImageLayout(
   DataGridViewImageCellLayout value
);
C++/CLI
[DefaultValueAttribute()]
public:
property DataGridViewImageCellLayout ImageLayout {
   DataGridViewImageCellLayout get();
   void set (DataGridViewImageCellLayoutvalue);
}

Exceptions

Exception | Description
InvalidEnumArgumentException | The supplied DataGridViewImageCellLayout value is invalid.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewImageCell Class
DataGridViewImageCell Members


ValueIsIcon Property

[image]
Gizmox.WebGUI.Forms
ValueIsIcon Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewImageCell Class : ValueIsIcon Property

Gets or sets a value indicating whether this cell displays an Icon value.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property ValueIsIcon As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewImageCell
Dim value As Boolean

instance.ValueIsIcon = value

value = instance.ValueIsIcon
C#
[DefaultValueAttribute()]
public bool ValueIsIcon {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property bool get_ValueIsIcon();
public: __property void set_ValueIsIcon(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
public:
property bool ValueIsIcon {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewImageCell Class
DataGridViewImageCell Members


ValueType Property

[image]
Gizmox.WebGUI.Forms
ValueType Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewImageCell Class : ValueType Property

Gets or sets the data type of the values in the cell.

Syntax

Visual Basic (Declaration)
Public Overrides Property ValueType As Type
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewImageCell
Dim value As Type

instance.ValueType = value

value = instance.ValueType
C#
public override Type ValueType {get; set;}
Managed Extensions for C++
public: __property Type* get_ValueType() override;
public: __property void set_ValueType(
   Type* value
) override;
C++/CLI
public:
property Type^ ValueType {
   Type^ get() override;
   void set (Type^value) override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewImageCell Class
DataGridViewImageCell Members


DataGridViewImageColumn Class

[image]
Gizmox.WebGUI.Forms
DataGridViewImageColumn Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewImageColumn Class

Hosts a collection of DataGridViewImageCell objects.

Object Model

Syntax

Visual Basic (Declaration)
<DesignTimeControllerAttribute()>
<ToolboxBitmapAttribute()>
<ClientControllerAttribute()>
Public Class DataGridViewImageColumn
   Inherits DataGridViewColumn
   Implements IRenderableComponentMember
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewImageColumn
C#
[DesignTimeControllerAttribute()]
[ToolboxBitmapAttribute()]
[ClientControllerAttribute()]
public class DataGridViewImageColumn : DataGridViewColumn, IRenderableComponentMember
Managed Extensions for C++
[DesignTimeControllerAttribute()]
[ToolboxBitmapAttribute()]
[ClientControllerAttribute()]
public __gc class DataGridViewImageColumn : public DataGridViewColumn, IRenderableComponentMember
C++/CLI
[DesignTimeControllerAttribute()]
[ToolboxBitmapAttribute()]
[ClientControllerAttribute()]
public ref class DataGridViewImageColumn : public DataGridViewColumn, IRenderableComponentMember

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.DataGridViewElement
Gizmox.WebGUI.Forms.DataGridViewBand
Gizmox.WebGUI.Forms.DataGridViewColumn
Gizmox.WebGUI.Forms.DataGridViewImageColumn

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

DataGridViewImageColumn Members
Gizmox.WebGUI.Forms Namespace


DataGridViewImageColumn Class Members

[image]
Gizmox.WebGUI.Forms
DataGridViewImageColumn Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewImageColumn Class

The following tables list the members exposed by DataGridViewImageColumn.

Public Constructors

 | Name | Description
Public Constructor | DataGridViewImageColumn Constructor | Overloaded. Initializes a new instance of the DataGridViewImageColumn class, configuring it for use with cell values of type Image.
Top

Public Properties

 | Name | Description
Public Property | AutoSizeMode | Gets or sets the mode by which the column automatically adjusts its width. (Inherited from DataGridViewColumn)
Public Property | CellTemplate | Overridden. Gets or sets the template used to create new cells.
Public Property | CellType | Gets the run-time type of the cell template. (Inherited from DataGridViewColumn)
Public Property | DataGridView | Gets the DataGridView control associated with this element. (Inherited from DataGridViewElement)
Public Property | DataPropertyName | Gets or sets the name of the data source property or database column to which the DataGridViewColumn is bound. (Inherited from DataGridViewColumn)
Public Property | DefaultCellStyle | Overridden. Gets or sets the column's default cell style.
Public Property | DefaultHeaderCellType | Gets or sets the run-time type of the default header cell. (Inherited from DataGridViewBand)
Public Property | Description | Gets or sets a string that describes the column's image.
Public Property | Displayed | Gets a value indicating whether the band is currently displayed onscreen. (Inherited from DataGridViewBand)
Public Property | DisplayIndex | Gets or sets the display order of the column relative to the currently displayed columns. (Inherited from DataGridViewColumn)
Public Property | DividerWidth | Gets or sets the width, in pixels, of the column divider. (Inherited from DataGridViewColumn)
Public Property | FillWeight | Gets or sets a value that represents the width of the column when it is in fill mode relative to the widths of other fill-mode columns in the control. (Inherited from DataGridViewColumn)
Public Property | Frozen | Gets or sets a value indicating whether a column will move when a user scrolls the DataGridView control horizontally. (Inherited from DataGridViewColumn)
Public Property | HasDefaultCellStyle | Gets a value indicating whether the DataGridViewBand.DefaultCellStyle property has been set. (Inherited from DataGridViewBand)
Public Property | HeaderCell | Gets or sets the DataGridViewColumnHeaderCell that represents the column header. (Inherited from DataGridViewColumn)
Public Property | HeaderText | Gets or sets the caption text on the column's header cell. (Inherited from DataGridViewColumn)
Public Property | Icon | Gets or sets the icon displayed in the cells of this column when the cell's DataGridViewCell.Value property is not set and the cell's DataGridViewImageCell.ValueIsIcon property is set to true.
Public Property | Image | Gets or sets the image displayed in the cells of this column when the cell's DataGridViewCell.Value property is not set and the cell's DataGridViewImageCell.ValueIsIcon property is set to false.
Public Property | ImageLayout | Gets or sets the image layout in the cells for this column.
Public Property | Index | Gets the relative position of the band within the DataGridView control. (Inherited from DataGridViewBand)
Public Property | InheritedAutoSizeMode | Gets the sizing mode in effect for the column. (Inherited from DataGridViewColumn)
Public Property | InheritedStyle | Gets the cell style currently applied to the column. (Inherited from DataGridViewColumn)
Public Property | IsDataBound | Gets a value indicating whether the column is bound to a data source. (Inherited from DataGridViewColumn)
Public Property | MinimumWidth | Gets or sets the minimum width, in pixels, of the column. (Inherited from DataGridViewColumn)
Public Property | Name | Gets or sets the name of the column. (Inherited from DataGridViewColumn)
Public Property | ReadOnly | Gets or sets a value indicating whether the user can edit the column's cells. (Inherited from DataGridViewColumn)
Public Property | Resizable | Gets or sets a value indicating whether the column is resizable. (Inherited from DataGridViewColumn)
Public Property | Selected | Gets or sets a value indicating whether the band is in a selected user interface (UI) state. (Inherited from DataGridViewBand)
Public Property | Site | Gets or sets the site of the column. (Inherited from DataGridViewColumn)
Public Property | SortMode | Gets or sets the sort mode for the column. (Inherited from DataGridViewColumn)
Public Property | State | Gets the user interface (UI) state of the element. (Inherited from DataGridViewElement)
Public Property | Tag | Gets or sets the object that contains data to associate with the band. (Inherited from DataGridViewBand)
Public Property | ToolTipText | Gets or sets the text used for ToolTips. (Inherited from DataGridViewColumn)
Public Property | ValuesAreIcons | Gets or sets a value indicating whether cells in this column display Icon values.
Public Property | ValueType | Gets or sets the data type of the values in the column's cells. (Inherited from DataGridViewColumn)
Public Property | Visible | Gets or sets a value indicating whether the column is visible. (Inherited from DataGridViewColumn)
Public Property | Width | Gets or sets the current width of the column. (Inherited from DataGridViewColumn)
Top

Protected Properties

 | Name | Description
Protected Property | HeaderCellCore | Gets or sets the header cell of the DataGridViewBand. (Inherited from DataGridViewBand)
Protected Property | IsRow | Gets a value indicating whether the band represents a row. (Inherited from DataGridViewBand)
Protected Property | MemberID | (Inherited from DataGridViewColumn)
Protected Property | TagName | (Inherited from DataGridViewElement)
Protected Property | TypeName | Overridden.
Top

Public Methods

 | Name | Description
Public Method | Clone | Overridden.
Public Method | Dispose | Overloaded. Releases all resources used by the DataGridViewBand. (Inherited from DataGridViewBand)
Public Method | GetPreferredWidth | Calculates the ideal width of the column based on the specified criteria. (Inherited from DataGridViewColumn)
Public Method | ToString | Overridden.
Public Method | Update | Overloaded. Full updates of this instance. (Inherited from DataGridViewElement)
Top

Protected Methods

 | Name | Description
Protected Method | CloneInternal | (Inherited from DataGridViewColumn)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from DataGridViewElement)
Protected Method | IsDirty | Determines whether the specified component is dirty. (Inherited from DataGridViewElement)
Protected Method | IsDirtyAttributes | Overloaded. Determines whether the specified component is dirty. (Inherited from DataGridViewElement)
Protected Method | OnDataGridViewChanged | Called when the band is associated with a different DataGridView. (Inherited from DataGridViewBand)
Protected Method | RaiseCellClick | Raises the DataGridView.CellClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellContentClick | Raises the DataGridView.CellContentClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellContentDoubleClick | Raises the DataGridView.CellContentDoubleClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellValueChanged | Raises the CellValueChanged event. (Inherited from DataGridViewElement)
Protected Method | RaiseDataError | Raises the DataError event. (Inherited from DataGridViewElement)
Protected Method | RaiseMouseWheel | Raises the MouseWheel event. (Inherited from DataGridViewElement)
Protected Method | RenderAttributes | (Inherited from DataGridViewColumn)
Protected Method | RenderComponent | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from DataGridViewElement)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from DataGridViewElement)
Protected Method | RenderComponents | Renders the column's inner components (Inherited from DataGridViewColumn)
Protected Method | RenderUpdatedAttributes | Renders the updated attributes (Inherited from DataGridViewElement)
Protected Method | UpdateParams | Overloaded. Updates only the parameters of this instance. (Inherited from DataGridViewElement)
Top

Public Events

 | Name | Description
Public Event | Disposed | Occurs when the DataGridViewColumn is disposed. (Inherited from DataGridViewColumn)
Top

See Also

Reference

DataGridViewImageColumn Class
Gizmox.WebGUI.Forms Namespace


DataGridViewImageColumn Constructor

[image]
Gizmox.WebGUI.Forms
DataGridViewImageColumn Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewImageColumn Class : DataGridViewImageColumn Constructor

Initializes a new instance of the DataGridViewImageColumn class, configuring it for use with cell values of type Image.

Overload List

Overload | Description
DataGridViewImageColumn Constructor() | Initializes a new instance of the DataGridViewImageColumn class, configuring it for use with cell values of type Image.
DataGridViewImageColumn Constructor(Boolean) | Initializes a new instance of the DataGridViewImageColumn class, optionally configuring it for use with Icon cell values.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewImageColumn Class
DataGridViewImageColumn Members


DataGridViewImageColumn Constructor()

[image]
Gizmox.WebGUI.Forms
DataGridViewImageColumn Constructor()
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewImageColumn Class > DataGridViewImageColumn Constructor : DataGridViewImageColumn Constructor()

Initializes a new instance of the DataGridViewImageColumn class, configuring it for use with cell values of type Image.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewImageColumn()
C#
public DataGridViewImageColumn()
Managed Extensions for C++
public: DataGridViewImageColumn();
C++/CLI
public:
DataGridViewImageColumn();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewImageColumn Class
DataGridViewImageColumn Members
Overload List


DataGridViewImageColumn Constructor(Boolean)

[image]
Gizmox.WebGUI.Forms
DataGridViewImageColumn Constructor(Boolean)
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewImageColumn Class > DataGridViewImageColumn Constructor : DataGridViewImageColumn Constructor(Boolean)

valuesAreIcons
true to indicate that the DataGridViewCell.Value property of cells in this column will be set to values of type Icon; false to indicate that they will be set to values of type Image.
Initializes a new instance of the DataGridViewImageColumn class, optionally configuring it for use with Icon cell values.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal valuesAreIcons As Boolean _
)
Visual Basic (Usage) Copy Code
Dim valuesAreIcons As Boolean

Dim instance As DataGridViewImageColumn(valuesAreIcons)
C#
public DataGridViewImageColumn(
   bool valuesAreIcons
)
Managed Extensions for C++
public: DataGridViewImageColumn(
   bool valuesAreIcons
)
C++/CLI
public:
DataGridViewImageColumn(
   bool valuesAreIcons
)

Parameters

valuesAreIcons
true to indicate that the DataGridViewCell.Value property of cells in this column will be set to values of type Icon; false to indicate that they will be set to values of type Image.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewImageColumn Class
DataGridViewImageColumn Members
Overload List


DataGridViewImageColumn Class Methods

[image]
Gizmox.WebGUI.Forms
DataGridViewImageColumn Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewImageColumn Class

For a list of all members of this type, see DataGridViewImageColumn members.

Public Methods

 | Name | Description
Public Method | Clone | Overridden.
Public Method | Dispose | Overloaded. Releases all resources used by the DataGridViewBand. (Inherited from DataGridViewBand)
Public Method | GetPreferredWidth | Calculates the ideal width of the column based on the specified criteria. (Inherited from DataGridViewColumn)
Public Method | ToString | Overridden.
Public Method | Update | Overloaded. Full updates of this instance. (Inherited from DataGridViewElement)
Top

Protected Methods

 | Name | Description
Protected Method | CloneInternal | (Inherited from DataGridViewColumn)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from DataGridViewElement)
Protected Method | IsDirty | Determines whether the specified component is dirty. (Inherited from DataGridViewElement)
Protected Method | IsDirtyAttributes | Overloaded. Determines whether the specified component is dirty. (Inherited from DataGridViewElement)
Protected Method | OnDataGridViewChanged | Called when the band is associated with a different DataGridView. (Inherited from DataGridViewBand)
Protected Method | RaiseCellClick | Raises the DataGridView.CellClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellContentClick | Raises the DataGridView.CellContentClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellContentDoubleClick | Raises the DataGridView.CellContentDoubleClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellValueChanged | Raises the CellValueChanged event. (Inherited from DataGridViewElement)
Protected Method | RaiseDataError | Raises the DataError event. (Inherited from DataGridViewElement)
Protected Method | RaiseMouseWheel | Raises the MouseWheel event. (Inherited from DataGridViewElement)
Protected Method | RenderAttributes | (Inherited from DataGridViewColumn)
Protected Method | RenderComponent | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from DataGridViewElement)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from DataGridViewElement)
Protected Method | RenderComponents | Renders the column's inner components (Inherited from DataGridViewColumn)
Protected Method | RenderUpdatedAttributes | Renders the updated attributes (Inherited from DataGridViewElement)
Protected Method | UpdateParams | Overloaded. Updates only the parameters of this instance. (Inherited from DataGridViewElement)
Top

See Also

Reference

DataGridViewImageColumn Class
Gizmox.WebGUI.Forms Namespace


Clone Method

[image]
Gizmox.WebGUI.Forms
Clone Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewImageColumn Class : Clone Method

Syntax

Visual Basic (Declaration)
Public Overrides Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewImageColumn
Dim value As Object

value = instance.Clone()
C#
public override object Clone()
Managed Extensions for C++
public: Object* Clone(); override
C++/CLI
public:
Object^ Clone(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewImageColumn Class
DataGridViewImageColumn Members


ToString Method

[image]
Gizmox.WebGUI.Forms
ToString Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewImageColumn Class : ToString Method

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewImageColumn
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewImageColumn Class
DataGridViewImageColumn Members


DataGridViewImageColumn Class Properties

[image]
Gizmox.WebGUI.Forms
DataGridViewImageColumn Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewImageColumn Class

For a list of all members of this type, see DataGridViewImageColumn members.

Public Properties

 | Name | Description
Public Property | AutoSizeMode | Gets or sets the mode by which the column automatically adjusts its width. (Inherited from DataGridViewColumn)
Public Property | CellTemplate | Overridden. Gets or sets the template used to create new cells.
Public Property | CellType | Gets the run-time type of the cell template. (Inherited from DataGridViewColumn)
Public Property | DataGridView | Gets the DataGridView control associated with this element. (Inherited from DataGridViewElement)
Public Property | DataPropertyName | Gets or sets the name of the data source property or database column to which the DataGridViewColumn is bound. (Inherited from DataGridViewColumn)
Public Property | DefaultCellStyle | Overridden. Gets or sets the column's default cell style.
Public Property | DefaultHeaderCellType | Gets or sets the run-time type of the default header cell. (Inherited from DataGridViewBand)
Public Property | Description | Gets or sets a string that describes the column's image.
Public Property | Displayed | Gets a value indicating whether the band is currently displayed onscreen. (Inherited from DataGridViewBand)
Public Property | DisplayIndex | Gets or sets the display order of the column relative to the currently displayed columns. (Inherited from DataGridViewColumn)
Public Property | DividerWidth | Gets or sets the width, in pixels, of the column divider. (Inherited from DataGridViewColumn)
Public Property | FillWeight | Gets or sets a value that represents the width of the column when it is in fill mode relative to the widths of other fill-mode columns in the control. (Inherited from DataGridViewColumn)
Public Property | Frozen | Gets or sets a value indicating whether a column will move when a user scrolls the DataGridView control horizontally. (Inherited from DataGridViewColumn)
Public Property | HasDefaultCellStyle | Gets a value indicating whether the DataGridViewBand.DefaultCellStyle property has been set. (Inherited from DataGridViewBand)
Public Property | HeaderCell | Gets or sets the DataGridViewColumnHeaderCell that represents the column header. (Inherited from DataGridViewColumn)
Public Property | HeaderText | Gets or sets the caption text on the column's header cell. (Inherited from DataGridViewColumn)
Public Property | Icon | Gets or sets the icon displayed in the cells of this column when the cell's DataGridViewCell.Value property is not set and the cell's DataGridViewImageCell.ValueIsIcon property is set to true.
Public Property | Image | Gets or sets the image displayed in the cells of this column when the cell's DataGridViewCell.Value property is not set and the cell's DataGridViewImageCell.ValueIsIcon property is set to false.
Public Property | ImageLayout | Gets or sets the image layout in the cells for this column.
Public Property | Index | Gets the relative position of the band within the DataGridView control. (Inherited from DataGridViewBand)
Public Property | InheritedAutoSizeMode | Gets the sizing mode in effect for the column. (Inherited from DataGridViewColumn)
Public Property | InheritedStyle | Gets the cell style currently applied to the column. (Inherited from DataGridViewColumn)
Public Property | IsDataBound | Gets a value indicating whether the column is bound to a data source. (Inherited from DataGridViewColumn)
Public Property | MinimumWidth | Gets or sets the minimum width, in pixels, of the column. (Inherited from DataGridViewColumn)
Public Property | Name | Gets or sets the name of the column. (Inherited from DataGridViewColumn)
Public Property | ReadOnly | Gets or sets a value indicating whether the user can edit the column's cells. (Inherited from DataGridViewColumn)
Public Property | Resizable | Gets or sets a value indicating whether the column is resizable. (Inherited from DataGridViewColumn)
Public Property | Selected | Gets or sets a value indicating whether the band is in a selected user interface (UI) state. (Inherited from DataGridViewBand)
Public Property | Site | Gets or sets the site of the column. (Inherited from DataGridViewColumn)
Public Property | SortMode | Gets or sets the sort mode for the column. (Inherited from DataGridViewColumn)
Public Property | State | Gets the user interface (UI) state of the element. (Inherited from DataGridViewElement)
Public Property | Tag | Gets or sets the object that contains data to associate with the band. (Inherited from DataGridViewBand)
Public Property | ToolTipText | Gets or sets the text used for ToolTips. (Inherited from DataGridViewColumn)
Public Property | ValuesAreIcons | Gets or sets a value indicating whether cells in this column display Icon values.
Public Property | ValueType | Gets or sets the data type of the values in the column's cells. (Inherited from DataGridViewColumn)
Public Property | Visible | Gets or sets a value indicating whether the column is visible. (Inherited from DataGridViewColumn)
Public Property | Width | Gets or sets the current width of the column. (Inherited from DataGridViewColumn)
Top

Protected Properties

 | Name | Description
Protected Property | HeaderCellCore | Gets or sets the header cell of the DataGridViewBand. (Inherited from DataGridViewBand)
Protected Property | IsRow | Gets a value indicating whether the band represents a row. (Inherited from DataGridViewBand)
Protected Property | MemberID | (Inherited from DataGridViewColumn)
Protected Property | TagName | (Inherited from DataGridViewElement)
Protected Property | TypeName | Overridden.
Top

See Also

Reference

DataGridViewImageColumn Class
Gizmox.WebGUI.Forms Namespace


CellTemplate Property

[image]
Gizmox.WebGUI.Forms
CellTemplate Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewImageColumn Class : CellTemplate Property

Gets or sets the template used to create new cells.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public Overrides Property CellTemplate As DataGridViewCell
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewImageColumn
Dim value As DataGridViewCell

instance.CellTemplate = value

value = instance.CellTemplate
C#
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public override DataGridViewCell CellTemplate {get; set;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property DataGridViewCell* get_CellTemplate() override;
public: __property void set_CellTemplate(
   DataGridViewCell* value
) override;
C++/CLI
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
property DataGridViewCell^ CellTemplate {
   DataGridViewCell^ get() override;
   void set (DataGridViewCell^value) override;
}

Exceptions

Exception | Description
InvalidCastException | The set type is not compatible with type DataGridViewImageCell.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewImageColumn Class
DataGridViewImageColumn Members


DefaultCellStyle Property

[image]
Gizmox.WebGUI.Forms
DefaultCellStyle Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewImageColumn Class : DefaultCellStyle Property

Gets or sets the column's default cell style.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Appearance")>
<BrowsableAttribute(True)>
<SRDescriptionAttribute("The column's default cell style.")>
Public Overrides Property DefaultCellStyle As DataGridViewCellStyle
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewImageColumn
Dim value As DataGridViewCellStyle

instance.DefaultCellStyle = value

value = instance.DefaultCellStyle
C#
[SRCategoryAttribute("Appearance")]
[BrowsableAttribute(true)]
[SRDescriptionAttribute("The column's default cell style.")]
public override DataGridViewCellStyle DefaultCellStyle {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Appearance")]
[BrowsableAttribute(true)]
[SRDescriptionAttribute("The column's default cell style.")]
public: __property DataGridViewCellStyle* get_DefaultCellStyle() override;
public: __property void set_DefaultCellStyle(
   DataGridViewCellStyle* value
) override;
C++/CLI
[SRCategoryAttribute("Appearance")]
[BrowsableAttribute(true)]
[SRDescriptionAttribute("The column's default cell style.")]
public:
property DataGridViewCellStyle^ DefaultCellStyle {
   DataGridViewCellStyle^ get() override;
   void set (DataGridViewCellStyle^value) override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewImageColumn Class
DataGridViewImageColumn Members


Description Property

[image]
Gizmox.WebGUI.Forms
Description Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewImageColumn Class : Description Property

Gets or sets a string that describes the column's image.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(True)>
<DefaultValueAttribute()>
<SRCategoryAttribute("Appearance")>
<SRDescriptionAttribute("User-defined text associated with the image.")>
Public Property Description As String
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewImageColumn
Dim value As String

instance.Description = value

value = instance.Description
C#
[BrowsableAttribute(true)]
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("User-defined text associated with the image.")]
public string Description {get; set;}
Managed Extensions for C++
[BrowsableAttribute(true)]
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("User-defined text associated with the image.")]
public: __property string* get_Description();
public: __property void set_Description(
   string* value
);
C++/CLI
[BrowsableAttribute(true)]
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("User-defined text associated with the image.")]
public:
property String^ Description {
   String^ get();
   void set (String^value);
}

Exceptions

Exception | Description
InvalidOperationException | The value of the CellTemplate property is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewImageColumn Class
DataGridViewImageColumn Members


Icon Property

[image]
Gizmox.WebGUI.Forms
Icon Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewImageColumn Class : Icon Property

Gets or sets the icon displayed in the cells of this column when the cell's DataGridViewCell.Value property is not set and the cell's DataGridViewImageCell.ValueIsIcon property is set to true.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public Property Icon As Icon
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewImageColumn
Dim value As Icon

instance.Icon = value

value = instance.Icon
C#
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public Icon Icon {get; set;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property Icon* get_Icon();
public: __property void set_Icon(
   Icon* value
);
C++/CLI
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
property Icon^ Icon {
   Icon^ get();
   void set (Icon^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewImageColumn Class
DataGridViewImageColumn Members


Image Property

[image]
Gizmox.WebGUI.Forms
Image Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewImageColumn Class : Image Property

Gets or sets the image displayed in the cells of this column when the cell's DataGridViewCell.Value property is not set and the cell's DataGridViewImageCell.ValueIsIcon property is set to false.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Appearance")>
<SRDescriptionAttribute("The image displayed in the cells of this column when the cell's DataGridViewCell.Value property is not set and the cell's DataGridViewImageCell.ValueIsIcon property is set to false.")>
<DefaultValueAttribute()>
Public Property Image As Image
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewImageColumn
Dim value As Image

instance.Image = value

value = instance.Image
C#
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("The image displayed in the cells of this column when the cell's DataGridViewCell.Value property is not set and the cell's DataGridViewImageCell.ValueIsIcon property is set to false.")]
[DefaultValueAttribute()]
public Image Image {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("The image displayed in the cells of this column when the cell's DataGridViewCell.Value property is not set and the cell's DataGridViewImageCell.ValueIsIcon property is set to false.")]
[DefaultValueAttribute()]
public: __property Image* get_Image();
public: __property void set_Image(
   Image* value
);
C++/CLI
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("The image displayed in the cells of this column when the cell's DataGridViewCell.Value property is not set and the cell's DataGridViewImageCell.ValueIsIcon property is set to false.")]
[DefaultValueAttribute()]
public:
property Image^ Image {
   Image^ get();
   void set (Image^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewImageColumn Class
DataGridViewImageColumn Members


ImageLayout Property

[image]
Gizmox.WebGUI.Forms
ImageLayout Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewImageColumn Class : ImageLayout Property

Gets or sets the image layout in the cells for this column.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<SRCategoryAttribute("Appearance")>
<SRDescriptionAttribute("The image layout in the cells for this column.")>
Public Property ImageLayout As DataGridViewImageCellLayout
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewImageColumn
Dim value As DataGridViewImageCellLayout

instance.ImageLayout = value

value = instance.ImageLayout
C#
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("The image layout in the cells for this column.")]
public DataGridViewImageCellLayout ImageLayout {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("The image layout in the cells for this column.")]
public: __property DataGridViewImageCellLayout get_ImageLayout();
public: __property void set_ImageLayout(
   DataGridViewImageCellLayout value
);
C++/CLI
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("The image layout in the cells for this column.")]
public:
property DataGridViewImageCellLayout ImageLayout {
   DataGridViewImageCellLayout get();
   void set (DataGridViewImageCellLayoutvalue);
}

Exceptions

Exception | Description
InvalidOperationException | The value of the CellTemplate property is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewImageColumn Class
DataGridViewImageColumn Members


TypeName Property

[image]
Gizmox.WebGUI.Forms
TypeName Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewImageColumn Class : TypeName Property

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property TypeName As String
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewImageColumn
Dim value As String

value = instance.TypeName
C#
protected override string TypeName {get;}
Managed Extensions for C++
protected: __property string* get_TypeName() override;
C++/CLI
protected:
property String^ TypeName {
   String^ get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewImageColumn Class
DataGridViewImageColumn Members


ValuesAreIcons Property

[image]
Gizmox.WebGUI.Forms
ValuesAreIcons Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewImageColumn Class : ValuesAreIcons Property

Gets or sets a value indicating whether cells in this column display Icon values.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public Property ValuesAreIcons As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewImageColumn
Dim value As Boolean

instance.ValuesAreIcons = value

value = instance.ValuesAreIcons
C#
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public bool ValuesAreIcons {get; set;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property bool get_ValuesAreIcons();
public: __property void set_ValuesAreIcons(
   bool value
);
C++/CLI
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
property bool ValuesAreIcons {
   bool get();
   void set (boolvalue);
}

Exceptions

Exception | Description
InvalidOperationException | The value of the CellTemplate property is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewImageColumn Class
DataGridViewImageColumn Members


DataGridViewLinkCell Class

[image]
Gizmox.WebGUI.Forms
DataGridViewLinkCell Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewLinkCell Class

Represents a cell that contains a link.

Object Model

Syntax

Visual Basic (Declaration)
Public Class DataGridViewLinkCell
   Inherits DataGridViewCell
   Implements IRenderableComponentMember
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewLinkCell
C#
public class DataGridViewLinkCell : DataGridViewCell, IRenderableComponentMember
Managed Extensions for C++
public __gc class DataGridViewLinkCell : public DataGridViewCell, IRenderableComponentMember
C++/CLI
public ref class DataGridViewLinkCell : public DataGridViewCell, IRenderableComponentMember

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.DataGridViewElement
Gizmox.WebGUI.Forms.DataGridViewCell
Gizmox.WebGUI.Forms.DataGridViewLinkCell

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

DataGridViewLinkCell Members
Gizmox.WebGUI.Forms Namespace


DataGridViewLinkCell Class Members

[image]
Gizmox.WebGUI.Forms
DataGridViewLinkCell Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewLinkCell Class

The following tables list the members exposed by DataGridViewLinkCell.

Public Constructors

 | Name | Description
Public Constructor | DataGridViewLinkCell Constructor | Initializes a new instance of the DataGridViewLinkCell class.
Top

Public Properties

 | Name | Description
Public Property | ActiveLinkColor | Gets or sets the color used to display an active link.
Public Property | ColumnIndex | Gets the column index for this cell. (Inherited from DataGridViewCell)
Public Property | ContentBounds | (Inherited from DataGridViewCell)
Public Property | DataGridView | Gets the DataGridView control associated with this element. (Inherited from DataGridViewElement)
Public Property | DefaultNewRowValue | Gets the default value for a cell in the row for new records. (Inherited from DataGridViewCell)
Public Property | Displayed | Gets a value that indicates whether the cell is currently displayed on-screen. (Inherited from DataGridViewCell)
Public Property | EditedFormattedValue | Gets the current, formatted value of the cell, regardless of whether the cell is in edit mode and the value has not been committed. (Inherited from DataGridViewCell)
Public Property | EditType | Overridden. Gets the type of the cell's hosted editing control.
Public Property | ErrorIconBounds | (Inherited from DataGridViewCell)
Public Property | ErrorText | Gets or sets the text describing an error condition associated with the cell. (Inherited from DataGridViewCell)
Public Property | FormattedValue | Gets the value of the cell as formatted for display. (Inherited from DataGridViewCell)
Public Property | FormattedValueType | Overridden. Gets the display Type of the cell value.
Public Property | Frozen | Gets a value indicating whether the cell is frozen. (Inherited from DataGridViewCell)
Public Property | HasStyle | Gets a value indicating whether the DataGridViewCell.Style property has been set. (Inherited from DataGridViewCell)
Public Property | InheritedState | Gets the current state of the cell as inherited from the state of its row and column. (Inherited from DataGridViewCell)
Public Property | InheritedStyle | Gets the style currently applied to the cell. (Inherited from DataGridViewCell)
Public Property | IsInEditMode | Gets a value indicating whether this cell is currently being edited. (Inherited from DataGridViewCell)
Public Property | LinkBehavior | Gets or sets a value that represents the behavior of a link.
Public Property | LinkColor | Gets or sets the color used to display an inactive and unvisited link.
Public Property | LinkVisited | Gets or sets a value indicating whether the link was visited.
Public Property | OwningColumn | Gets the column that contains this cell. (Inherited from DataGridViewCell)
Public Property | OwningRow | Gets the row that contains this cell. (Inherited from DataGridViewCell)
Public Property | PreferredSize | Gets the size, in pixels, of a rectangular area into which the cell can fit. (Inherited from DataGridViewCell)
Public Property | ReadOnly | Gets or sets a value indicating whether the cell's data can be edited. (Inherited from DataGridViewCell)
Public Property | Resizable | Gets a value indicating whether the cell can be resized. (Inherited from DataGridViewCell)
Public Property | RowIndex | Gets the index of the cell's parent row. (Inherited from DataGridViewCell)
Public Property | Selected | Gets or sets a value indicating whether the cell has been selected. (Inherited from DataGridViewCell)
Public Property | Size | Gets the size of the cell. (Inherited from DataGridViewCell)
Public Property | State | Gets the user interface (UI) state of the element. (Inherited from DataGridViewElement)
Public Property | Style | Gets or sets the style for the cell. (Inherited from DataGridViewCell)
Public Property | Tag | Gets or sets the object that contains supplemental data about the cell. (Inherited from DataGridViewCell)
Public Property | ToolTipText | Gets or sets the ToolTip text associated with this cell. (Inherited from DataGridViewCell)
Public Property | TrackVisitedState | Gets or sets a value indicating whether the link changes color when it is visited.
Public Property | UseColumnTextForLinkValue | Gets or sets a value indicating whether the column Text property value is displayed as the link text.
Public Property | Value | Gets or sets the value associated with this cell. (Inherited from DataGridViewCell)
Public Property | ValueType | Overridden.
Public Property | Visible | Gets a value indicating whether the cell is in a row or column that has been hidden. (Inherited from DataGridViewCell)
Public Property | VisitedLinkColor | Gets or sets the color used to display a link that has been previously visited.
Top

Protected Properties

 | Name | Description
Protected Property | MemberID | (Inherited from DataGridViewCell)
Protected Property | TagName | (Inherited from DataGridViewElement)
Top

Public Methods

 | Name | Description
Public Method | AdjustCellBorderStyle | Modifies the input cell border style according to the specified criteria. (Inherited from DataGridViewCell)
Public Method | Clone | Overridden. Creates an exact copy of this cell.
Public Method | DetachEditingControl | Removes the cell's editing control from the DataGridView. (Inherited from DataGridViewCell)
Public Method | Dispose | Overloaded. Releases all resources used by the DataGridViewCell. (Inherited from DataGridViewCell)
Public Method | GetContentBounds | Overloaded. (Inherited from DataGridViewCell)
Public Method | GetEditedFormattedValue | Returns the current, formatted value of the cell, regardless of whether the cell is in edit mode and the value has not been committed. (Inherited from DataGridViewCell)
Public Method | GetInheritedState | Returns a value indicating the current state of the cell as inherited from the state of its row and column. (Inherited from DataGridViewCell)
Public Method | GetInheritedStyle | Gets the style applied to the cell. (Inherited from DataGridViewCell)
Public Method | InitializeEditingControl | Initializes the control used to edit the cell. (Inherited from DataGridViewCell)
Public Method | KeyEntersEditMode | Determines if edit mode should be started based on the given key. (Inherited from DataGridViewCell)
Public Method | ParseFormattedValue | (Inherited from DataGridViewCell)
Public Method | PositionEditingControl | Sets the location and size of the editing control hosted by a cell in the DataGridView control. (Inherited from DataGridViewCell)
Public Method | PositionEditingPanel | (Inherited from DataGridViewCell)
Public Method | ToString | Overridden.
Public Method | Update | Overloaded. Full updates of this instance. (Inherited from DataGridViewElement)
Top

Protected Methods

 | Name | Description
Protected Method | BorderWidths | (Inherited from DataGridViewCell)
Protected Method | ClickUnsharesRow | Indicates whether the cell's row will be unshared when the cell is clicked. (Inherited from DataGridViewCell)
Protected Method | ContentClickUnsharesRow | Indicates whether the cell's row will be unshared when the cell's content is clicked. (Inherited from DataGridViewCell)
Protected Method | ContentDoubleClickUnsharesRow | Indicates whether the cell's row will be unshared when the cell's content is double-clicked. (Inherited from DataGridViewCell)
Protected Method | DoubleClickUnsharesRow | Indicates whether the cell's row will be unshared when the cell is double-clicked. (Inherited from DataGridViewCell)
Protected Method | EnterUnsharesRow | Indicates whether the parent row will be unshared when the focus moves to the cell. (Inherited from DataGridViewCell)
Protected Method | GetClipboardContent | Retrieves the formatted value of the cell to copy to the Clipboard. (Inherited from DataGridViewCell)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from DataGridViewElement)
Protected Method | GetDefaultHorizontalAlignment | Gets the horizontal alignment. (Inherited from DataGridViewCell)
Protected Method | GetDefaultVerticalAlignment | Gets the vertical alignment. (Inherited from DataGridViewCell)
Protected Method | GetErrorIconBounds | (Inherited from DataGridViewCell)
Protected Method | GetErrorText | Returns a string that represents the error for the cell. (Inherited from DataGridViewCell)
Protected Method | GetFormattedValue | Gets the value of the cell as formatted for display. (Inherited from DataGridViewCell)
Protected Method | GetPreferredSize | Overloaded. Calculates the preferred size, in pixels, of the cell. (Inherited from DataGridViewCell)
Protected Method | GetSize | Gets the size of the cell. (Inherited from DataGridViewCell)
Protected Method | GetValue | Overridden.
Protected Method | IsDirty | Determines whether the specified component is dirty. (Inherited from DataGridViewElement)
Protected Method | IsDirtyAttributes | Overloaded. Determines whether the specified component is dirty. (Inherited from DataGridViewElement)
Protected Method | KeyDownUnsharesRow | Indicates whether the parent row is unshared if the user presses a key while the focus is on the cell. (Inherited from DataGridViewCell)
Protected Method | KeyPressUnsharesRow | Indicates whether a row will be unshared if a key is pressed while a cell in the row has focus. (Inherited from DataGridViewCell)
Protected Method | KeyUpUnsharesRow | Overridden. Indicates whether the row containing the cell will be unshared when a key is released and the cell has focus.
Protected Method | LeaveUnsharesRow | Indicates whether a row will be unshared when the focus leaves a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseClickUnsharesRow | Indicates whether a row will be unshared if the user clicks a mouse button while the pointer is on a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseDoubleClickUnsharesRow | Indicates whether a row will be unshared if the user double-clicks a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseDownUnsharesRow | Overridden. Indicates whether the row containing the cell will be unshared when the mouse button is pressed while the pointer is over the cell.
Protected Method | MouseEnterUnsharesRow | Indicates whether a row will be unshared when the mouse pointer moves over a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseLeaveUnsharesRow | Overridden. Indicates whether the row containing the cell will be unshared when the mouse pointer leaves the cell.
Protected Method | MouseMoveUnsharesRow | Overridden. Indicates whether the row containing the cell will be unshared when the mouse pointer moves over the cell.
Protected Method | MouseUpUnsharesRow | Overridden. Indicates whether the row containing the cell will be unshared when the mouse button is released while the pointer is over the cell.
Protected Method | OnClick | Called when the cell is clicked. (Inherited from DataGridViewCell)
Protected Method | OnContentClick | Called when the cell's contents are clicked. (Inherited from DataGridViewCell)
Protected Method | OnContentDoubleClick | Called when the cell's contents are double-clicked. (Inherited from DataGridViewCell)
Protected Method | OnDataGridViewChanged | Called when the DataGridViewElement.DataGridView property of the cell changes. (Inherited from DataGridViewCell)
Protected Method | OnDoubleClick | Called when the cell is double-clicked. (Inherited from DataGridViewCell)
Protected Method | OnEnter | Called when the focus moves to a cell. (Inherited from DataGridViewCell)
Protected Method | OnKeyDown | Called when a character key is pressed while the focus is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnKeyPress | Called when a key is pressed while the focus is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnKeyUp | Called when a character key is released while the focus is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnLeave | Called when the focus moves from a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseClick | Called when the user clicks a mouse button while the pointer is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseDoubleClick | Called when the user double-clicks a mouse button while the pointer is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseDown | Called when the user holds down a mouse button while the pointer is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseEnter | Called when the mouse pointer moves over a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseLeave | Called when the mouse pointer leaves the cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseMove | Called when the mouse pointer moves within a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseUp | Called when the user releases a mouse button while the pointer is on a cell. (Inherited from DataGridViewCell)
Protected Method | Paint | (Inherited from DataGridViewCell)
Protected Method | PaintErrorIcon | (Inherited from DataGridViewCell)
Protected Method | ProcessGatewayRequest | (Inherited from DataGridViewCell)
Protected Method | RaiseCellClick | Raises the DataGridView.CellClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellContentClick | Raises the DataGridView.CellContentClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellContentDoubleClick | Raises the DataGridView.CellContentDoubleClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellValueChanged | Raises the CellValueChanged event. (Inherited from DataGridViewElement)
Protected Method | RaiseDataError | Raises the DataError event. (Inherited from DataGridViewElement)
Protected Method | RaiseMouseWheel | Raises the MouseWheel event. (Inherited from DataGridViewElement)
Protected Method | RenderAttributes | Overridden.
Protected Method | RenderBackColorAttribute | Renders the back color attribute. (Inherited from DataGridViewCell)
Protected Method | RenderComponent | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from DataGridViewElement)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from DataGridViewElement)
Protected Method | RenderComponents | Renders the controls sub tree (Inherited from DataGridViewElement)
Protected Method | RenderForeColorAttribute | Renders the fore color attribute. (Inherited from DataGridViewCell)
Protected Method | RenderReadOnlyAttribute | Renders the read only attribute. (Inherited from DataGridViewCell)
Protected Method | RenderUpdatedAttributes | Renders the updated attributes (Inherited from DataGridViewElement)
Protected Method | RenderWrapModeAttribute | Renders the wrap mode attribute. (Inherited from DataGridViewCell)
Protected Method | SetValue | Sets the value of the cell. (Inherited from DataGridViewCell)
Protected Method | UpdateParams | Overloaded. Updates only the parameters of this instance. (Inherited from DataGridViewElement)
Top

See Also

Reference

DataGridViewLinkCell Class
Gizmox.WebGUI.Forms Namespace


DataGridViewLinkCell Constructor

[image]
Gizmox.WebGUI.Forms
DataGridViewLinkCell Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewLinkCell Class : DataGridViewLinkCell Constructor

Initializes a new instance of the DataGridViewLinkCell class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewLinkCell()
C#
public DataGridViewLinkCell()
Managed Extensions for C++
public: DataGridViewLinkCell();
C++/CLI
public:
DataGridViewLinkCell();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewLinkCell Class
DataGridViewLinkCell Members


DataGridViewLinkCell Class Methods

[image]
Gizmox.WebGUI.Forms
DataGridViewLinkCell Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewLinkCell Class

For a list of all members of this type, see DataGridViewLinkCell members.

Public Methods

 | Name | Description
Public Method | AdjustCellBorderStyle | Modifies the input cell border style according to the specified criteria. (Inherited from DataGridViewCell)
Public Method | Clone | Overridden. Creates an exact copy of this cell.
Public Method | DetachEditingControl | Removes the cell's editing control from the DataGridView. (Inherited from DataGridViewCell)
Public Method | Dispose | Overloaded. Releases all resources used by the DataGridViewCell. (Inherited from DataGridViewCell)
Public Method | GetContentBounds | Overloaded. (Inherited from DataGridViewCell)
Public Method | GetEditedFormattedValue | Returns the current, formatted value of the cell, regardless of whether the cell is in edit mode and the value has not been committed. (Inherited from DataGridViewCell)
Public Method | GetInheritedState | Returns a value indicating the current state of the cell as inherited from the state of its row and column. (Inherited from DataGridViewCell)
Public Method | GetInheritedStyle | Gets the style applied to the cell. (Inherited from DataGridViewCell)
Public Method | InitializeEditingControl | Initializes the control used to edit the cell. (Inherited from DataGridViewCell)
Public Method | KeyEntersEditMode | Determines if edit mode should be started based on the given key. (Inherited from DataGridViewCell)
Public Method | ParseFormattedValue | (Inherited from DataGridViewCell)
Public Method | PositionEditingControl | Sets the location and size of the editing control hosted by a cell in the DataGridView control. (Inherited from DataGridViewCell)
Public Method | PositionEditingPanel | (Inherited from DataGridViewCell)
Public Method | ToString | Overridden.
Public Method | Update | Overloaded. Full updates of this instance. (Inherited from DataGridViewElement)
Top

Protected Methods

 | Name | Description
Protected Method | BorderWidths | (Inherited from DataGridViewCell)
Protected Method | ClickUnsharesRow | Indicates whether the cell's row will be unshared when the cell is clicked. (Inherited from DataGridViewCell)
Protected Method | ContentClickUnsharesRow | Indicates whether the cell's row will be unshared when the cell's content is clicked. (Inherited from DataGridViewCell)
Protected Method | ContentDoubleClickUnsharesRow | Indicates whether the cell's row will be unshared when the cell's content is double-clicked. (Inherited from DataGridViewCell)
Protected Method | DoubleClickUnsharesRow | Indicates whether the cell's row will be unshared when the cell is double-clicked. (Inherited from DataGridViewCell)
Protected Method | EnterUnsharesRow | Indicates whether the parent row will be unshared when the focus moves to the cell. (Inherited from DataGridViewCell)
Protected Method | GetClipboardContent | Retrieves the formatted value of the cell to copy to the Clipboard. (Inherited from DataGridViewCell)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from DataGridViewElement)
Protected Method | GetDefaultHorizontalAlignment | Gets the horizontal alignment. (Inherited from DataGridViewCell)
Protected Method | GetDefaultVerticalAlignment | Gets the vertical alignment. (Inherited from DataGridViewCell)
Protected Method | GetErrorIconBounds | (Inherited from DataGridViewCell)
Protected Method | GetErrorText | Returns a string that represents the error for the cell. (Inherited from DataGridViewCell)
Protected Method | GetFormattedValue | Gets the value of the cell as formatted for display. (Inherited from DataGridViewCell)
Protected Method | GetPreferredSize | Overloaded. Calculates the preferred size, in pixels, of the cell. (Inherited from DataGridViewCell)
Protected Method | GetSize | Gets the size of the cell. (Inherited from DataGridViewCell)
Protected Method | GetValue | Overridden.
Protected Method | IsDirty | Determines whether the specified component is dirty. (Inherited from DataGridViewElement)
Protected Method | IsDirtyAttributes | Overloaded. Determines whether the specified component is dirty. (Inherited from DataGridViewElement)
Protected Method | KeyDownUnsharesRow | Indicates whether the parent row is unshared if the user presses a key while the focus is on the cell. (Inherited from DataGridViewCell)
Protected Method | KeyPressUnsharesRow | Indicates whether a row will be unshared if a key is pressed while a cell in the row has focus. (Inherited from DataGridViewCell)
Protected Method | KeyUpUnsharesRow | Overridden. Indicates whether the row containing the cell will be unshared when a key is released and the cell has focus.
Protected Method | LeaveUnsharesRow | Indicates whether a row will be unshared when the focus leaves a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseClickUnsharesRow | Indicates whether a row will be unshared if the user clicks a mouse button while the pointer is on a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseDoubleClickUnsharesRow | Indicates whether a row will be unshared if the user double-clicks a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseDownUnsharesRow | Overridden. Indicates whether the row containing the cell will be unshared when the mouse button is pressed while the pointer is over the cell.
Protected Method | MouseEnterUnsharesRow | Indicates whether a row will be unshared when the mouse pointer moves over a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseLeaveUnsharesRow | Overridden. Indicates whether the row containing the cell will be unshared when the mouse pointer leaves the cell.
Protected Method | MouseMoveUnsharesRow | Overridden. Indicates whether the row containing the cell will be unshared when the mouse pointer moves over the cell.
Protected Method | MouseUpUnsharesRow | Overridden. Indicates whether the row containing the cell will be unshared when the mouse button is released while the pointer is over the cell.
Protected Method | OnClick | Called when the cell is clicked. (Inherited from DataGridViewCell)
Protected Method | OnContentClick | Called when the cell's contents are clicked. (Inherited from DataGridViewCell)
Protected Method | OnContentDoubleClick | Called when the cell's contents are double-clicked. (Inherited from DataGridViewCell)
Protected Method | OnDataGridViewChanged | Called when the DataGridViewElement.DataGridView property of the cell changes. (Inherited from DataGridViewCell)
Protected Method | OnDoubleClick | Called when the cell is double-clicked. (Inherited from DataGridViewCell)
Protected Method | OnEnter | Called when the focus moves to a cell. (Inherited from DataGridViewCell)
Protected Method | OnKeyDown | Called when a character key is pressed while the focus is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnKeyPress | Called when a key is pressed while the focus is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnKeyUp | Called when a character key is released while the focus is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnLeave | Called when the focus moves from a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseClick | Called when the user clicks a mouse button while the pointer is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseDoubleClick | Called when the user double-clicks a mouse button while the pointer is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseDown | Called when the user holds down a mouse button while the pointer is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseEnter | Called when the mouse pointer moves over a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseLeave | Called when the mouse pointer leaves the cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseMove | Called when the mouse pointer moves within a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseUp | Called when the user releases a mouse button while the pointer is on a cell. (Inherited from DataGridViewCell)
Protected Method | Paint | (Inherited from DataGridViewCell)
Protected Method | PaintErrorIcon | (Inherited from DataGridViewCell)
Protected Method | ProcessGatewayRequest | (Inherited from DataGridViewCell)
Protected Method | RaiseCellClick | Raises the DataGridView.CellClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellContentClick | Raises the DataGridView.CellContentClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellContentDoubleClick | Raises the DataGridView.CellContentDoubleClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellValueChanged | Raises the CellValueChanged event. (Inherited from DataGridViewElement)
Protected Method | RaiseDataError | Raises the DataError event. (Inherited from DataGridViewElement)
Protected Method | RaiseMouseWheel | Raises the MouseWheel event. (Inherited from DataGridViewElement)
Protected Method | RenderAttributes | Overridden.
Protected Method | RenderBackColorAttribute | Renders the back color attribute. (Inherited from DataGridViewCell)
Protected Method | RenderComponent | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from DataGridViewElement)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from DataGridViewElement)
Protected Method | RenderComponents | Renders the controls sub tree (Inherited from DataGridViewElement)
Protected Method | RenderForeColorAttribute | Renders the fore color attribute. (Inherited from DataGridViewCell)
Protected Method | RenderReadOnlyAttribute | Renders the read only attribute. (Inherited from DataGridViewCell)
Protected Method | RenderUpdatedAttributes | Renders the updated attributes (Inherited from DataGridViewElement)
Protected Method | RenderWrapModeAttribute | Renders the wrap mode attribute. (Inherited from DataGridViewCell)
Protected Method | SetValue | Sets the value of the cell. (Inherited from DataGridViewCell)
Protected Method | UpdateParams | Overloaded. Updates only the parameters of this instance. (Inherited from DataGridViewElement)
Top

See Also

Reference

DataGridViewLinkCell Class
Gizmox.WebGUI.Forms Namespace


Clone Method

[image]
Gizmox.WebGUI.Forms
Clone Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewLinkCell Class : Clone Method

Creates an exact copy of this cell.

Syntax

Visual Basic (Declaration)
Public Overrides Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewLinkCell
Dim value As Object

value = instance.Clone()
C#
public override object Clone()
Managed Extensions for C++
public: Object* Clone(); override
C++/CLI
public:
Object^ Clone(); override

Return Value

An Object that represents the cloned DataGridViewLinkCell.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewLinkCell Class
DataGridViewLinkCell Members


GetValue Method

[image]
Gizmox.WebGUI.Forms
GetValue Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewLinkCell Class : GetValue Method

rowIndex

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetValue( _
   ByVal rowIndex As Integer _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewLinkCell
Dim rowIndex As Integer
Dim value As Object

value = instance.GetValue(rowIndex)
C#
protected override object GetValue(
   int rowIndex
)
Managed Extensions for C++
protected: Object* GetValue(
   int rowIndex
) override
C++/CLI
protected:
Object^ GetValue(
   int rowIndex
) override

Parameters

rowIndex

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewLinkCell Class
DataGridViewLinkCell Members


KeyUpUnsharesRow Method

[image]
Gizmox.WebGUI.Forms
KeyUpUnsharesRow Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewLinkCell Class : KeyUpUnsharesRow Method

e
A KeyEventArgs that contains data about the key press.
rowIndex
The index of the row containing the cell.
Indicates whether the row containing the cell will be unshared when a key is released and the cell has focus.

Syntax

Visual Basic (Declaration)
Protected Overrides Function KeyUpUnsharesRow( _
   ByVal e As KeyEventArgs, _
   ByVal rowIndex As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewLinkCell
Dim e As KeyEventArgs
Dim rowIndex As Integer
Dim value As Boolean

value = instance.KeyUpUnsharesRow(e, rowIndex)
C#
protected override bool KeyUpUnsharesRow(
   KeyEventArgs e,
   int rowIndex
)
Managed Extensions for C++
protected: bool KeyUpUnsharesRow(
   KeyEventArgs* e,
   int rowIndex
) override
C++/CLI
protected:
bool KeyUpUnsharesRow(
   KeyEventArgs^ e,
   int rowIndex
) override

Parameters

e
A KeyEventArgs that contains data about the key press.
rowIndex
The index of the row containing the cell.

Return Value

true if the SPACE key was released, the TrackVisitedState property is true, the LinkVisited property is false, and the CTRL, ALT, and SHIFT keys are not pressed; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewLinkCell Class
DataGridViewLinkCell Members


MouseDownUnsharesRow Method

[image]
Gizmox.WebGUI.Forms
MouseDownUnsharesRow Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewLinkCell Class : MouseDownUnsharesRow Method

e
A DataGridViewCellMouseEventArgs that contains data about the mouse click.
Indicates whether the row containing the cell will be unshared when the mouse button is pressed while the pointer is over the cell.

Syntax

Visual Basic (Declaration)
Protected Overrides Function MouseDownUnsharesRow( _
   ByVal e As DataGridViewCellMouseEventArgs _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewLinkCell
Dim e As DataGridViewCellMouseEventArgs
Dim value As Boolean

value = instance.MouseDownUnsharesRow(e)
C#
protected override bool MouseDownUnsharesRow(
   DataGridViewCellMouseEventArgs e
)
Managed Extensions for C++
protected: bool MouseDownUnsharesRow(
   DataGridViewCellMouseEventArgs* e
) override
C++/CLI
protected:
bool MouseDownUnsharesRow(
   DataGridViewCellMouseEventArgs^ e
) override

Parameters

e
A DataGridViewCellMouseEventArgs that contains data about the mouse click.

Return Value

true if the mouse pointer is over the link; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewLinkCell Class
DataGridViewLinkCell Members


MouseLeaveUnsharesRow Method

[image]
Gizmox.WebGUI.Forms
MouseLeaveUnsharesRow Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewLinkCell Class : MouseLeaveUnsharesRow Method

rowIndex
The index of the row containing the cell.
Indicates whether the row containing the cell will be unshared when the mouse pointer leaves the cell.

Syntax

Visual Basic (Declaration)
Protected Overrides Function MouseLeaveUnsharesRow( _
   ByVal rowIndex As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewLinkCell
Dim rowIndex As Integer
Dim value As Boolean

value = instance.MouseLeaveUnsharesRow(rowIndex)
C#
protected override bool MouseLeaveUnsharesRow(
   int rowIndex
)
Managed Extensions for C++
protected: bool MouseLeaveUnsharesRow(
   int rowIndex
) override
C++/CLI
protected:
bool MouseLeaveUnsharesRow(
   int rowIndex
) override

Parameters

rowIndex
The index of the row containing the cell.

Return Value

true if the link displayed by the cell is not in the normal state; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewLinkCell Class
DataGridViewLinkCell Members


MouseMoveUnsharesRow Method

[image]
Gizmox.WebGUI.Forms
MouseMoveUnsharesRow Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewLinkCell Class : MouseMoveUnsharesRow Method

e
A DataGridViewCellMouseEventArgs that contains data about the mouse click.
Indicates whether the row containing the cell will be unshared when the mouse pointer moves over the cell.

Syntax

Visual Basic (Declaration)
Protected Overrides Function MouseMoveUnsharesRow( _
   ByVal e As DataGridViewCellMouseEventArgs _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewLinkCell
Dim e As DataGridViewCellMouseEventArgs
Dim value As Boolean

value = instance.MouseMoveUnsharesRow(e)
C#
protected override bool MouseMoveUnsharesRow(
   DataGridViewCellMouseEventArgs e
)
Managed Extensions for C++
protected: bool MouseMoveUnsharesRow(
   DataGridViewCellMouseEventArgs* e
) override
C++/CLI
protected:
bool MouseMoveUnsharesRow(
   DataGridViewCellMouseEventArgs^ e
) override

Parameters

e
A DataGridViewCellMouseEventArgs that contains data about the mouse click.

Return Value

true if the mouse pointer is over the link and the link is has not yet changed color to reflect the hover state; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewLinkCell Class
DataGridViewLinkCell Members


MouseUpUnsharesRow Method

[image]
Gizmox.WebGUI.Forms
MouseUpUnsharesRow Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewLinkCell Class : MouseUpUnsharesRow Method

e
A DataGridViewCellMouseEventArgs that contains data about the mouse click.
Indicates whether the row containing the cell will be unshared when the mouse button is released while the pointer is over the cell.

Syntax

Visual Basic (Declaration)
Protected Overrides Function MouseUpUnsharesRow( _
   ByVal e As DataGridViewCellMouseEventArgs _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewLinkCell
Dim e As DataGridViewCellMouseEventArgs
Dim value As Boolean

value = instance.MouseUpUnsharesRow(e)
C#
protected override bool MouseUpUnsharesRow(
   DataGridViewCellMouseEventArgs e
)
Managed Extensions for C++
protected: bool MouseUpUnsharesRow(
   DataGridViewCellMouseEventArgs* e
) override
C++/CLI
protected:
bool MouseUpUnsharesRow(
   DataGridViewCellMouseEventArgs^ e
) override

Parameters

e
A DataGridViewCellMouseEventArgs that contains data about the mouse click.

Return Value

true if the mouse pointer is over the link; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewLinkCell Class
DataGridViewLinkCell Members


RenderAttributes Method

[image]
Gizmox.WebGUI.Forms
RenderAttributes Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewLinkCell Class : RenderAttributes Method

objContext
objWriter
blnRenderOwner

Syntax

Visual Basic (Declaration)
Protected Overrides Sub RenderAttributes( _
   ByVal objContext As IContext, _
   ByVal objWriter As IAttributeWriter, _
   ByVal blnRenderOwner As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewLinkCell
Dim objContext As IContext
Dim objWriter As IAttributeWriter
Dim blnRenderOwner As Boolean

instance.RenderAttributes(objContext, objWriter, blnRenderOwner)
C#
protected override void RenderAttributes(
   IContext objContext,
   IAttributeWriter objWriter,
   bool blnRenderOwner
)
Managed Extensions for C++
protected: void RenderAttributes(
   IContext* objContext,
   IAttributeWriter* objWriter,
   bool blnRenderOwner
) override
C++/CLI
protected:
void RenderAttributes(
   IContext^ objContext,
   IAttributeWriter^ objWriter,
   bool blnRenderOwner
) override

Parameters

objContext
objWriter
blnRenderOwner

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewLinkCell Class
DataGridViewLinkCell Members


ToString Method

[image]
Gizmox.WebGUI.Forms
ToString Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewLinkCell Class : ToString Method

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewLinkCell
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewLinkCell Class
DataGridViewLinkCell Members


DataGridViewLinkCell Class Properties

[image]
Gizmox.WebGUI.Forms
DataGridViewLinkCell Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewLinkCell Class

For a list of all members of this type, see DataGridViewLinkCell members.

Public Properties

 | Name | Description
Public Property | ActiveLinkColor | Gets or sets the color used to display an active link.
Public Property | ColumnIndex | Gets the column index for this cell. (Inherited from DataGridViewCell)
Public Property | ContentBounds | (Inherited from DataGridViewCell)
Public Property | DataGridView | Gets the DataGridView control associated with this element. (Inherited from DataGridViewElement)
Public Property | DefaultNewRowValue | Gets the default value for a cell in the row for new records. (Inherited from DataGridViewCell)
Public Property | Displayed | Gets a value that indicates whether the cell is currently displayed on-screen. (Inherited from DataGridViewCell)
Public Property | EditedFormattedValue | Gets the current, formatted value of the cell, regardless of whether the cell is in edit mode and the value has not been committed. (Inherited from DataGridViewCell)
Public Property | EditType | Overridden. Gets the type of the cell's hosted editing control.
Public Property | ErrorIconBounds | (Inherited from DataGridViewCell)
Public Property | ErrorText | Gets or sets the text describing an error condition associated with the cell. (Inherited from DataGridViewCell)
Public Property | FormattedValue | Gets the value of the cell as formatted for display. (Inherited from DataGridViewCell)
Public Property | FormattedValueType | Overridden. Gets the display Type of the cell value.
Public Property | Frozen | Gets a value indicating whether the cell is frozen. (Inherited from DataGridViewCell)
Public Property | HasStyle | Gets a value indicating whether the DataGridViewCell.Style property has been set. (Inherited from DataGridViewCell)
Public Property | InheritedState | Gets the current state of the cell as inherited from the state of its row and column. (Inherited from DataGridViewCell)
Public Property | InheritedStyle | Gets the style currently applied to the cell. (Inherited from DataGridViewCell)
Public Property | IsInEditMode | Gets a value indicating whether this cell is currently being edited. (Inherited from DataGridViewCell)
Public Property | LinkBehavior | Gets or sets a value that represents the behavior of a link.
Public Property | LinkColor | Gets or sets the color used to display an inactive and unvisited link.
Public Property | LinkVisited | Gets or sets a value indicating whether the link was visited.
Public Property | OwningColumn | Gets the column that contains this cell. (Inherited from DataGridViewCell)
Public Property | OwningRow | Gets the row that contains this cell. (Inherited from DataGridViewCell)
Public Property | PreferredSize | Gets the size, in pixels, of a rectangular area into which the cell can fit. (Inherited from DataGridViewCell)
Public Property | ReadOnly | Gets or sets a value indicating whether the cell's data can be edited. (Inherited from DataGridViewCell)
Public Property | Resizable | Gets a value indicating whether the cell can be resized. (Inherited from DataGridViewCell)
Public Property | RowIndex | Gets the index of the cell's parent row. (Inherited from DataGridViewCell)
Public Property | Selected | Gets or sets a value indicating whether the cell has been selected. (Inherited from DataGridViewCell)
Public Property | Size | Gets the size of the cell. (Inherited from DataGridViewCell)
Public Property | State | Gets the user interface (UI) state of the element. (Inherited from DataGridViewElement)
Public Property | Style | Gets or sets the style for the cell. (Inherited from DataGridViewCell)
Public Property | Tag | Gets or sets the object that contains supplemental data about the cell. (Inherited from DataGridViewCell)
Public Property | ToolTipText | Gets or sets the ToolTip text associated with this cell. (Inherited from DataGridViewCell)
Public Property | TrackVisitedState | Gets or sets a value indicating whether the link changes color when it is visited.
Public Property | UseColumnTextForLinkValue | Gets or sets a value indicating whether the column Text property value is displayed as the link text.
Public Property | Value | Gets or sets the value associated with this cell. (Inherited from DataGridViewCell)
Public Property | ValueType | Overridden.
Public Property | Visible | Gets a value indicating whether the cell is in a row or column that has been hidden. (Inherited from DataGridViewCell)
Public Property | VisitedLinkColor | Gets or sets the color used to display a link that has been previously visited.
Top

Protected Properties

 | Name | Description
Protected Property | MemberID | (Inherited from DataGridViewCell)
Protected Property | TagName | (Inherited from DataGridViewElement)
Top

See Also

Reference

DataGridViewLinkCell Class
Gizmox.WebGUI.Forms Namespace


ActiveLinkColor Property

[image]
Gizmox.WebGUI.Forms
ActiveLinkColor Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewLinkCell Class : ActiveLinkColor Property

Gets or sets the color used to display an active link.

Syntax

Visual Basic (Declaration)
Public Property ActiveLinkColor As Color
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewLinkCell
Dim value As Color

instance.ActiveLinkColor = value

value = instance.ActiveLinkColor
C#
public Color ActiveLinkColor {get; set;}
Managed Extensions for C++
public: __property Color get_ActiveLinkColor();
public: __property void set_ActiveLinkColor(
   Color value
);
C++/CLI
public:
property Color ActiveLinkColor {
   Color get();
   void set (Colorvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewLinkCell Class
DataGridViewLinkCell Members


EditType Property

[image]
Gizmox.WebGUI.Forms
EditType Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewLinkCell Class : EditType Property

Gets the type of the cell's hosted editing control.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property EditType As Type
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewLinkCell
Dim value As Type

value = instance.EditType
C#
public override Type EditType {get;}
Managed Extensions for C++
public: __property Type* get_EditType() override;
C++/CLI
public:
property Type^ EditType {
   Type^ get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewLinkCell Class
DataGridViewLinkCell Members


FormattedValueType Property

[image]
Gizmox.WebGUI.Forms
FormattedValueType Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewLinkCell Class : FormattedValueType Property

Gets the display Type of the cell value.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property FormattedValueType As Type
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewLinkCell
Dim value As Type

value = instance.FormattedValueType
C#
public override Type FormattedValueType {get;}
Managed Extensions for C++
public: __property Type* get_FormattedValueType() override;
C++/CLI
public:
property Type^ FormattedValueType {
   Type^ get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewLinkCell Class
DataGridViewLinkCell Members


LinkBehavior Property

[image]
Gizmox.WebGUI.Forms
LinkBehavior Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewLinkCell Class : LinkBehavior Property

Gets or sets a value that represents the behavior of a link.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property LinkBehavior As LinkBehavior
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewLinkCell
Dim value As LinkBehavior

instance.LinkBehavior = value

value = instance.LinkBehavior
C#
[DefaultValueAttribute()]
public LinkBehavior LinkBehavior {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property LinkBehavior get_LinkBehavior();
public: __property void set_LinkBehavior(
   LinkBehavior value
);
C++/CLI
[DefaultValueAttribute()]
public:
property LinkBehavior LinkBehavior {
   LinkBehavior get();
   void set (LinkBehaviorvalue);
}

Exceptions

Exception | Description
InvalidEnumArgumentException | The specified value when setting this property is not a valid LinkBehavior value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewLinkCell Class
DataGridViewLinkCell Members


LinkColor Property

[image]
Gizmox.WebGUI.Forms
LinkColor Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewLinkCell Class : LinkColor Property

Gets or sets the color used to display an inactive and unvisited link.

Syntax

Visual Basic (Declaration)
Public Property LinkColor As Color
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewLinkCell
Dim value As Color

instance.LinkColor = value

value = instance.LinkColor
C#
public Color LinkColor {get; set;}
Managed Extensions for C++
public: __property Color get_LinkColor();
public: __property void set_LinkColor(
   Color value
);
C++/CLI
public:
property Color LinkColor {
   Color get();
   void set (Colorvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewLinkCell Class
DataGridViewLinkCell Members


LinkVisited Property

[image]
Gizmox.WebGUI.Forms
LinkVisited Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewLinkCell Class : LinkVisited Property

Gets or sets a value indicating whether the link was visited.

Syntax

Visual Basic (Declaration)
Public Property LinkVisited As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewLinkCell
Dim value As Boolean

instance.LinkVisited = value

value = instance.LinkVisited
C#
public bool LinkVisited {get; set;}
Managed Extensions for C++
public: __property bool get_LinkVisited();
public: __property void set_LinkVisited(
   bool value
);
C++/CLI
public:
property bool LinkVisited {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewLinkCell Class
DataGridViewLinkCell Members


TrackVisitedState Property

[image]
Gizmox.WebGUI.Forms
TrackVisitedState Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewLinkCell Class : TrackVisitedState Property

Gets or sets a value indicating whether the link changes color when it is visited.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property TrackVisitedState As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewLinkCell
Dim value As Boolean

instance.TrackVisitedState = value

value = instance.TrackVisitedState
C#
[DefaultValueAttribute()]
public bool TrackVisitedState {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property bool get_TrackVisitedState();
public: __property void set_TrackVisitedState(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
public:
property bool TrackVisitedState {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewLinkCell Class
DataGridViewLinkCell Members


UseColumnTextForLinkValue Property

[image]
Gizmox.WebGUI.Forms
UseColumnTextForLinkValue Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewLinkCell Class : UseColumnTextForLinkValue Property

Gets or sets a value indicating whether the column Text property value is displayed as the link text.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property UseColumnTextForLinkValue As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewLinkCell
Dim value As Boolean

instance.UseColumnTextForLinkValue = value

value = instance.UseColumnTextForLinkValue
C#
[DefaultValueAttribute()]
public bool UseColumnTextForLinkValue {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property bool get_UseColumnTextForLinkValue();
public: __property void set_UseColumnTextForLinkValue(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
public:
property bool UseColumnTextForLinkValue {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewLinkCell Class
DataGridViewLinkCell Members


ValueType Property

[image]
Gizmox.WebGUI.Forms
ValueType Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewLinkCell Class : ValueType Property

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ValueType As Type
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewLinkCell
Dim value As Type

value = instance.ValueType
C#
public override Type ValueType {get;}
Managed Extensions for C++
public: __property Type* get_ValueType() override;
C++/CLI
public:
property Type^ ValueType {
   Type^ get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewLinkCell Class
DataGridViewLinkCell Members


VisitedLinkColor Property

[image]
Gizmox.WebGUI.Forms
VisitedLinkColor Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewLinkCell Class : VisitedLinkColor Property

Gets or sets the color used to display a link that has been previously visited.

Syntax

Visual Basic (Declaration)
Public Property VisitedLinkColor As Color
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewLinkCell
Dim value As Color

instance.VisitedLinkColor = value

value = instance.VisitedLinkColor
C#
public Color VisitedLinkColor {get; set;}
Managed Extensions for C++
public: __property Color get_VisitedLinkColor();
public: __property void set_VisitedLinkColor(
   Color value
);
C++/CLI
public:
property Color VisitedLinkColor {
   Color get();
   void set (Colorvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewLinkCell Class
DataGridViewLinkCell Members


DataGridViewLinkColumn Class

[image]
Gizmox.WebGUI.Forms
DataGridViewLinkColumn Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewLinkColumn Class

Represents a column of cells that contain links in a DataGridView control.

Object Model

Syntax

Visual Basic (Declaration)
<ToolboxBitmapAttribute()>
<ClientControllerAttribute()>
<DesignTimeControllerAttribute()>
Public Class DataGridViewLinkColumn
   Inherits DataGridViewColumn
   Implements IRenderableComponentMember
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewLinkColumn
C#
[ToolboxBitmapAttribute()]
[ClientControllerAttribute()]
[DesignTimeControllerAttribute()]
public class DataGridViewLinkColumn : DataGridViewColumn, IRenderableComponentMember
Managed Extensions for C++
[ToolboxBitmapAttribute()]
[ClientControllerAttribute()]
[DesignTimeControllerAttribute()]
public __gc class DataGridViewLinkColumn : public DataGridViewColumn, IRenderableComponentMember
C++/CLI
[ToolboxBitmapAttribute()]
[ClientControllerAttribute()]
[DesignTimeControllerAttribute()]
public ref class DataGridViewLinkColumn : public DataGridViewColumn, IRenderableComponentMember

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.DataGridViewElement
Gizmox.WebGUI.Forms.DataGridViewBand
Gizmox.WebGUI.Forms.DataGridViewColumn
Gizmox.WebGUI.Forms.DataGridViewLinkColumn

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

DataGridViewLinkColumn Members
Gizmox.WebGUI.Forms Namespace


DataGridViewLinkColumn Class Members

[image]
Gizmox.WebGUI.Forms
DataGridViewLinkColumn Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewLinkColumn Class

The following tables list the members exposed by DataGridViewLinkColumn.

Public Constructors

 | Name | Description
Public Constructor | DataGridViewLinkColumn Constructor | Initializes a new instance of the DataGridViewLinkColumn class.
Top

Public Properties

 | Name | Description
Public Property | ActiveLinkColor | Gets or sets the color used to display an active link within cells in the column.
Public Property | AutoSizeMode | Gets or sets the mode by which the column automatically adjusts its width. (Inherited from DataGridViewColumn)
Public Property | CellTemplate | Overridden. Gets or sets the template used to create new cells.
Public Property | CellType | Gets the run-time type of the cell template. (Inherited from DataGridViewColumn)
Public Property | DataGridView | Gets the DataGridView control associated with this element. (Inherited from DataGridViewElement)
Public Property | DataPropertyName | Gets or sets the name of the data source property or database column to which the DataGridViewColumn is bound. (Inherited from DataGridViewColumn)
Public Property | DefaultCellStyle | Gets or sets the column's default cell style. (Inherited from DataGridViewColumn)
Public Property | DefaultHeaderCellType | Gets or sets the run-time type of the default header cell. (Inherited from DataGridViewBand)
Public Property | Displayed | Gets a value indicating whether the band is currently displayed onscreen. (Inherited from DataGridViewBand)
Public Property | DisplayIndex | Gets or sets the display order of the column relative to the currently displayed columns. (Inherited from DataGridViewColumn)
Public Property | DividerWidth | Gets or sets the width, in pixels, of the column divider. (Inherited from DataGridViewColumn)
Public Property | FillWeight | Gets or sets a value that represents the width of the column when it is in fill mode relative to the widths of other fill-mode columns in the control. (Inherited from DataGridViewColumn)
Public Property | Frozen | Gets or sets a value indicating whether a column will move when a user scrolls the DataGridView control horizontally. (Inherited from DataGridViewColumn)
Public Property | HasDefaultCellStyle | Gets a value indicating whether the DataGridViewBand.DefaultCellStyle property has been set. (Inherited from DataGridViewBand)
Public Property | HeaderCell | Gets or sets the DataGridViewColumnHeaderCell that represents the column header. (Inherited from DataGridViewColumn)
Public Property | HeaderText | Gets or sets the caption text on the column's header cell. (Inherited from DataGridViewColumn)
Public Property | Index | Gets the relative position of the band within the DataGridView control. (Inherited from DataGridViewBand)
Public Property | InheritedAutoSizeMode | Gets the sizing mode in effect for the column. (Inherited from DataGridViewColumn)
Public Property | InheritedStyle | Gets the cell style currently applied to the column. (Inherited from DataGridViewColumn)
Public Property | IsDataBound | Gets a value indicating whether the column is bound to a data source. (Inherited from DataGridViewColumn)
Public Property | LinkBehavior | Gets or sets a value that represents the behavior of links within cells in the column.
Public Property | LinkColor | Gets or sets the color used to display an unselected link within cells in the column.
Public Property | MinimumWidth | Gets or sets the minimum width, in pixels, of the column. (Inherited from DataGridViewColumn)
Public Property | Name | Gets or sets the name of the column. (Inherited from DataGridViewColumn)
Public Property | ReadOnly | Gets or sets a value indicating whether the user can edit the column's cells. (Inherited from DataGridViewColumn)
Public Property | Resizable | Gets or sets a value indicating whether the column is resizable. (Inherited from DataGridViewColumn)
Public Property | Selected | Gets or sets a value indicating whether the band is in a selected user interface (UI) state. (Inherited from DataGridViewBand)
Public Property | Site | Gets or sets the site of the column. (Inherited from DataGridViewColumn)
Public Property | SortMode | Gets or sets the sort mode for the column. (Inherited from DataGridViewColumn)
Public Property | State | Gets the user interface (UI) state of the element. (Inherited from DataGridViewElement)
Public Property | Tag | Gets or sets the object that contains data to associate with the band. (Inherited from DataGridViewBand)
Public Property | Text | Gets or sets the link text displayed in a column's cells if UseColumnTextForLinkValue is true.
Public Property | ToolTipText | Gets or sets the text used for ToolTips. (Inherited from DataGridViewColumn)
Public Property | TrackVisitedState | Gets or sets a value indicating whether the link changes color if it has been visited.
Public Property | UseColumnTextForLinkValue | Gets or sets a value indicating whether the Text property value is displayed as the link text.
Public Property | ValueType | Gets or sets the data type of the values in the column's cells. (Inherited from DataGridViewColumn)
Public Property | Visible | Gets or sets a value indicating whether the column is visible. (Inherited from DataGridViewColumn)
Public Property | VisitedLinkColor | Gets or sets the color used to display a link that has been previously visited.
Public Property | Width | Gets or sets the current width of the column. (Inherited from DataGridViewColumn)
Top

Protected Properties

 | Name | Description
Protected Property | HeaderCellCore | Gets or sets the header cell of the DataGridViewBand. (Inherited from DataGridViewBand)
Protected Property | IsRow | Gets a value indicating whether the band represents a row. (Inherited from DataGridViewBand)
Protected Property | MemberID | (Inherited from DataGridViewColumn)
Protected Property | TagName | (Inherited from DataGridViewElement)
Protected Property | TypeName | Overridden.
Top

Public Methods

 | Name | Description
Public Method | Clone | Overridden. Creates an exact copy of this column.
Public Method | Dispose | Overloaded. Releases all resources used by the DataGridViewBand. (Inherited from DataGridViewBand)
Public Method | GetPreferredWidth | Calculates the ideal width of the column based on the specified criteria. (Inherited from DataGridViewColumn)
Public Method | ToString | Overridden.
Public Method | Update | Overloaded. Full updates of this instance. (Inherited from DataGridViewElement)
Top

Protected Methods

 | Name | Description
Protected Method | CloneInternal | (Inherited from DataGridViewColumn)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from DataGridViewElement)
Protected Method | IsDirty | Determines whether the specified component is dirty. (Inherited from DataGridViewElement)
Protected Method | IsDirtyAttributes | Overloaded. Determines whether the specified component is dirty. (Inherited from DataGridViewElement)
Protected Method | OnDataGridViewChanged | Called when the band is associated with a different DataGridView. (Inherited from DataGridViewBand)
Protected Method | RaiseCellClick | Raises the DataGridView.CellClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellContentClick | Raises the DataGridView.CellContentClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellContentDoubleClick | Raises the DataGridView.CellContentDoubleClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellValueChanged | Raises the CellValueChanged event. (Inherited from DataGridViewElement)
Protected Method | RaiseDataError | Raises the DataError event. (Inherited from DataGridViewElement)
Protected Method | RaiseMouseWheel | Raises the MouseWheel event. (Inherited from DataGridViewElement)
Protected Method | RenderAttributes | (Inherited from DataGridViewColumn)
Protected Method | RenderComponent | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from DataGridViewElement)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from DataGridViewElement)
Protected Method | RenderComponents | Renders the column's inner components (Inherited from DataGridViewColumn)
Protected Method | RenderUpdatedAttributes | Renders the updated attributes (Inherited from DataGridViewElement)
Protected Method | UpdateParams | Overloaded. Updates only the parameters of this instance. (Inherited from DataGridViewElement)
Top

Public Events

 | Name | Description
Public Event | Disposed | Occurs when the DataGridViewColumn is disposed. (Inherited from DataGridViewColumn)
Top

See Also

Reference

DataGridViewLinkColumn Class
Gizmox.WebGUI.Forms Namespace


DataGridViewLinkColumn Constructor

[image]
Gizmox.WebGUI.Forms
DataGridViewLinkColumn Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewLinkColumn Class : DataGridViewLinkColumn Constructor

Initializes a new instance of the DataGridViewLinkColumn class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewLinkColumn()
C#
public DataGridViewLinkColumn()
Managed Extensions for C++
public: DataGridViewLinkColumn();
C++/CLI
public:
DataGridViewLinkColumn();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewLinkColumn Class
DataGridViewLinkColumn Members


DataGridViewLinkColumn Class Methods

[image]
Gizmox.WebGUI.Forms
DataGridViewLinkColumn Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewLinkColumn Class

For a list of all members of this type, see DataGridViewLinkColumn members.

Public Methods

 | Name | Description
Public Method | Clone | Overridden. Creates an exact copy of this column.
Public Method | Dispose | Overloaded. Releases all resources used by the DataGridViewBand. (Inherited from DataGridViewBand)
Public Method | GetPreferredWidth | Calculates the ideal width of the column based on the specified criteria. (Inherited from DataGridViewColumn)
Public Method | ToString | Overridden.
Public Method | Update | Overloaded. Full updates of this instance. (Inherited from DataGridViewElement)
Top

Protected Methods

 | Name | Description
Protected Method | CloneInternal | (Inherited from DataGridViewColumn)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from DataGridViewElement)
Protected Method | IsDirty | Determines whether the specified component is dirty. (Inherited from DataGridViewElement)
Protected Method | IsDirtyAttributes | Overloaded. Determines whether the specified component is dirty. (Inherited from DataGridViewElement)
Protected Method | OnDataGridViewChanged | Called when the band is associated with a different DataGridView. (Inherited from DataGridViewBand)
Protected Method | RaiseCellClick | Raises the DataGridView.CellClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellContentClick | Raises the DataGridView.CellContentClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellContentDoubleClick | Raises the DataGridView.CellContentDoubleClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellValueChanged | Raises the CellValueChanged event. (Inherited from DataGridViewElement)
Protected Method | RaiseDataError | Raises the DataError event. (Inherited from DataGridViewElement)
Protected Method | RaiseMouseWheel | Raises the MouseWheel event. (Inherited from DataGridViewElement)
Protected Method | RenderAttributes | (Inherited from DataGridViewColumn)
Protected Method | RenderComponent | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from DataGridViewElement)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from DataGridViewElement)
Protected Method | RenderComponents | Renders the column's inner components (Inherited from DataGridViewColumn)
Protected Method | RenderUpdatedAttributes | Renders the updated attributes (Inherited from DataGridViewElement)
Protected Method | UpdateParams | Overloaded. Updates only the parameters of this instance. (Inherited from DataGridViewElement)
Top

See Also

Reference

DataGridViewLinkColumn Class
Gizmox.WebGUI.Forms Namespace


Clone Method

[image]
Gizmox.WebGUI.Forms
Clone Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewLinkColumn Class : Clone Method

Creates an exact copy of this column.

Syntax

Visual Basic (Declaration)
Public Overrides Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewLinkColumn
Dim value As Object

value = instance.Clone()
C#
public override object Clone()
Managed Extensions for C++
public: Object* Clone(); override
C++/CLI
public:
Object^ Clone(); override

Return Value

An Object that represents the cloned DataGridViewLinkColumn.

Exceptions

Exception | Description
InvalidOperationException | The value of the CellTemplate property is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewLinkColumn Class
DataGridViewLinkColumn Members


ToString Method

[image]
Gizmox.WebGUI.Forms
ToString Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewLinkColumn Class : ToString Method

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewLinkColumn
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewLinkColumn Class
DataGridViewLinkColumn Members


DataGridViewLinkColumn Class Properties

[image]
Gizmox.WebGUI.Forms
DataGridViewLinkColumn Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewLinkColumn Class

For a list of all members of this type, see DataGridViewLinkColumn members.

Public Properties

 | Name | Description
Public Property | ActiveLinkColor | Gets or sets the color used to display an active link within cells in the column.
Public Property | AutoSizeMode | Gets or sets the mode by which the column automatically adjusts its width. (Inherited from DataGridViewColumn)
Public Property | CellTemplate | Overridden. Gets or sets the template used to create new cells.
Public Property | CellType | Gets the run-time type of the cell template. (Inherited from DataGridViewColumn)
Public Property | DataGridView | Gets the DataGridView control associated with this element. (Inherited from DataGridViewElement)
Public Property | DataPropertyName | Gets or sets the name of the data source property or database column to which the DataGridViewColumn is bound. (Inherited from DataGridViewColumn)
Public Property | DefaultCellStyle | Gets or sets the column's default cell style. (Inherited from DataGridViewColumn)
Public Property | DefaultHeaderCellType | Gets or sets the run-time type of the default header cell. (Inherited from DataGridViewBand)
Public Property | Displayed | Gets a value indicating whether the band is currently displayed onscreen. (Inherited from DataGridViewBand)
Public Property | DisplayIndex | Gets or sets the display order of the column relative to the currently displayed columns. (Inherited from DataGridViewColumn)
Public Property | DividerWidth | Gets or sets the width, in pixels, of the column divider. (Inherited from DataGridViewColumn)
Public Property | FillWeight | Gets or sets a value that represents the width of the column when it is in fill mode relative to the widths of other fill-mode columns in the control. (Inherited from DataGridViewColumn)
Public Property | Frozen | Gets or sets a value indicating whether a column will move when a user scrolls the DataGridView control horizontally. (Inherited from DataGridViewColumn)
Public Property | HasDefaultCellStyle | Gets a value indicating whether the DataGridViewBand.DefaultCellStyle property has been set. (Inherited from DataGridViewBand)
Public Property | HeaderCell | Gets or sets the DataGridViewColumnHeaderCell that represents the column header. (Inherited from DataGridViewColumn)
Public Property | HeaderText | Gets or sets the caption text on the column's header cell. (Inherited from DataGridViewColumn)
Public Property | Index | Gets the relative position of the band within the DataGridView control. (Inherited from DataGridViewBand)
Public Property | InheritedAutoSizeMode | Gets the sizing mode in effect for the column. (Inherited from DataGridViewColumn)
Public Property | InheritedStyle | Gets the cell style currently applied to the column. (Inherited from DataGridViewColumn)
Public Property | IsDataBound | Gets a value indicating whether the column is bound to a data source. (Inherited from DataGridViewColumn)
Public Property | LinkBehavior | Gets or sets a value that represents the behavior of links within cells in the column.
Public Property | LinkColor | Gets or sets the color used to display an unselected link within cells in the column.
Public Property | MinimumWidth | Gets or sets the minimum width, in pixels, of the column. (Inherited from DataGridViewColumn)
Public Property | Name | Gets or sets the name of the column. (Inherited from DataGridViewColumn)
Public Property | ReadOnly | Gets or sets a value indicating whether the user can edit the column's cells. (Inherited from DataGridViewColumn)
Public Property | Resizable | Gets or sets a value indicating whether the column is resizable. (Inherited from DataGridViewColumn)
Public Property | Selected | Gets or sets a value indicating whether the band is in a selected user interface (UI) state. (Inherited from DataGridViewBand)
Public Property | Site | Gets or sets the site of the column. (Inherited from DataGridViewColumn)
Public Property | SortMode | Gets or sets the sort mode for the column. (Inherited from DataGridViewColumn)
Public Property | State | Gets the user interface (UI) state of the element. (Inherited from DataGridViewElement)
Public Property | Tag | Gets or sets the object that contains data to associate with the band. (Inherited from DataGridViewBand)
Public Property | Text | Gets or sets the link text displayed in a column's cells if UseColumnTextForLinkValue is true.
Public Property | ToolTipText | Gets or sets the text used for ToolTips. (Inherited from DataGridViewColumn)
Public Property | TrackVisitedState | Gets or sets a value indicating whether the link changes color if it has been visited.
Public Property | UseColumnTextForLinkValue | Gets or sets a value indicating whether the Text property value is displayed as the link text.
Public Property | ValueType | Gets or sets the data type of the values in the column's cells. (Inherited from DataGridViewColumn)
Public Property | Visible | Gets or sets a value indicating whether the column is visible. (Inherited from DataGridViewColumn)
Public Property | VisitedLinkColor | Gets or sets the color used to display a link that has been previously visited.
Public Property | Width | Gets or sets the current width of the column. (Inherited from DataGridViewColumn)
Top

Protected Properties

 | Name | Description
Protected Property | HeaderCellCore | Gets or sets the header cell of the DataGridViewBand. (Inherited from DataGridViewBand)
Protected Property | IsRow | Gets a value indicating whether the band represents a row. (Inherited from DataGridViewBand)
Protected Property | MemberID | (Inherited from DataGridViewColumn)
Protected Property | TagName | (Inherited from DataGridViewElement)
Protected Property | TypeName | Overridden.
Top

See Also

Reference

DataGridViewLinkColumn Class
Gizmox.WebGUI.Forms Namespace


ActiveLinkColor Property

[image]
Gizmox.WebGUI.Forms
ActiveLinkColor Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewLinkColumn Class : ActiveLinkColor Property

Gets or sets the color used to display an active link within cells in the column.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Appearance")>
<SRDescriptionAttribute("The color used to display an active link within cells in the column. ")>
Public Property ActiveLinkColor As Color
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewLinkColumn
Dim value As Color

instance.ActiveLinkColor = value

value = instance.ActiveLinkColor
C#
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("The color used to display an active link within cells in the column. ")]
public Color ActiveLinkColor {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("The color used to display an active link within cells in the column. ")]
public: __property Color get_ActiveLinkColor();
public: __property void set_ActiveLinkColor(
   Color value
);
C++/CLI
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("The color used to display an active link within cells in the column. ")]
public:
property Color ActiveLinkColor {
   Color get();
   void set (Colorvalue);
}

Exceptions

Exception | Description
InvalidOperationException | The value of the CellTemplate property is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewLinkColumn Class
DataGridViewLinkColumn Members


CellTemplate Property

[image]
Gizmox.WebGUI.Forms
CellTemplate Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewLinkColumn Class : CellTemplate Property

Gets or sets the template used to create new cells.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public Overrides Property CellTemplate As DataGridViewCell
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewLinkColumn
Dim value As DataGridViewCell

instance.CellTemplate = value

value = instance.CellTemplate
C#
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public override DataGridViewCell CellTemplate {get; set;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property DataGridViewCell* get_CellTemplate() override;
public: __property void set_CellTemplate(
   DataGridViewCell* value
) override;
C++/CLI
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
property DataGridViewCell^ CellTemplate {
   DataGridViewCell^ get() override;
   void set (DataGridViewCell^value) override;
}

Exceptions

Exception | Description
InvalidCastException | When setting this property to a value that is not of type DataGridViewLinkCell.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewLinkColumn Class
DataGridViewLinkColumn Members


LinkBehavior Property

[image]
Gizmox.WebGUI.Forms
LinkBehavior Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewLinkColumn Class : LinkBehavior Property

Gets or sets a value that represents the behavior of links within cells in the column.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Behavior")>
<DefaultValueAttribute()>
<SRDescriptionAttribute("A value that represents the behavior of links within cells in the column.")>
Public Property LinkBehavior As LinkBehavior
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewLinkColumn
Dim value As LinkBehavior

instance.LinkBehavior = value

value = instance.LinkBehavior
C#
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("A value that represents the behavior of links within cells in the column.")]
public LinkBehavior LinkBehavior {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("A value that represents the behavior of links within cells in the column.")]
public: __property LinkBehavior get_LinkBehavior();
public: __property void set_LinkBehavior(
   LinkBehavior value
);
C++/CLI
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("A value that represents the behavior of links within cells in the column.")]
public:
property LinkBehavior LinkBehavior {
   LinkBehavior get();
   void set (LinkBehaviorvalue);
}

Exceptions

Exception | Description
InvalidOperationException | The value of the CellTemplate property is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewLinkColumn Class
DataGridViewLinkColumn Members


LinkColor Property

[image]
Gizmox.WebGUI.Forms
LinkColor Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewLinkColumn Class : LinkColor Property

Gets or sets the color used to display an unselected link within cells in the column.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Appearance")>
<SRDescriptionAttribute("The color used to display an unselected link within cells in the column.")>
Public Property LinkColor As Color
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewLinkColumn
Dim value As Color

instance.LinkColor = value

value = instance.LinkColor
C#
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("The color used to display an unselected link within cells in the column.")]
public Color LinkColor {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("The color used to display an unselected link within cells in the column.")]
public: __property Color get_LinkColor();
public: __property void set_LinkColor(
   Color value
);
C++/CLI
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("The color used to display an unselected link within cells in the column.")]
public:
property Color LinkColor {
   Color get();
   void set (Colorvalue);
}

Exceptions

Exception | Description
InvalidOperationException | The value of the CellTemplate property is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewLinkColumn Class
DataGridViewLinkColumn Members


Text Property

[image]
Gizmox.WebGUI.Forms
Text Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewLinkColumn Class : Text Property

Gets or sets the link text displayed in a column's cells if UseColumnTextForLinkValue is true.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<SRDescriptionAttribute("The link text displayed in all of the column's cells.")>
<SRCategoryAttribute("Appearance")>
Public Property Text As String
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewLinkColumn
Dim value As String

instance.Text = value

value = instance.Text
C#
[DefaultValueAttribute()]
[SRDescriptionAttribute("The link text displayed in all of the column's cells.")]
[SRCategoryAttribute("Appearance")]
public string Text {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[SRDescriptionAttribute("The link text displayed in all of the column's cells.")]
[SRCategoryAttribute("Appearance")]
public: __property string* get_Text();
public: __property void set_Text(
   string* value
);
C++/CLI
[DefaultValueAttribute()]
[SRDescriptionAttribute("The link text displayed in all of the column's cells.")]
[SRCategoryAttribute("Appearance")]
public:
property String^ Text {
   String^ get();
   void set (String^value);
}

Exceptions

Exception | Description
InvalidOperationException | When setting this property, the value of the CellTemplate property is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewLinkColumn Class
DataGridViewLinkColumn Members


TrackVisitedState Property

[image]
Gizmox.WebGUI.Forms
TrackVisitedState Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewLinkColumn Class : TrackVisitedState Property

Gets or sets a value indicating whether the link changes color if it has been visited.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<SRDescriptionAttribute("Indicates whether the link changes color if it has been visited.")>
<SRCategoryAttribute("Behavior")>
Public Property TrackVisitedState As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewLinkColumn
Dim value As Boolean

instance.TrackVisitedState = value

value = instance.TrackVisitedState
C#
[DefaultValueAttribute()]
[SRDescriptionAttribute("Indicates whether the link changes color if it has been visited.")]
[SRCategoryAttribute("Behavior")]
public bool TrackVisitedState {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[SRDescriptionAttribute("Indicates whether the link changes color if it has been visited.")]
[SRCategoryAttribute("Behavior")]
public: __property bool get_TrackVisitedState();
public: __property void set_TrackVisitedState(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
[SRDescriptionAttribute("Indicates whether the link changes color if it has been visited.")]
[SRCategoryAttribute("Behavior")]
public:
property bool TrackVisitedState {
   bool get();
   void set (boolvalue);
}

Exceptions

Exception | Description
InvalidOperationException | The value of the CellTemplate property is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewLinkColumn Class
DataGridViewLinkColumn Members


TypeName Property

[image]
Gizmox.WebGUI.Forms
TypeName Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewLinkColumn Class : TypeName Property

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property TypeName As String
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewLinkColumn
Dim value As String

value = instance.TypeName
C#
protected override string TypeName {get;}
Managed Extensions for C++
protected: __property string* get_TypeName() override;
C++/CLI
protected:
property String^ TypeName {
   String^ get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewLinkColumn Class
DataGridViewLinkColumn Members


UseColumnTextForLinkValue Property

[image]
Gizmox.WebGUI.Forms
UseColumnTextForLinkValue Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewLinkColumn Class : UseColumnTextForLinkValue Property

Gets or sets a value indicating whether the Text property value is displayed as the link text.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Indicates whether the DataGridViewLinkColumn.Text property value is displayed as the link text.")>
<DefaultValueAttribute()>
<SRCategoryAttribute("Appearance")>
Public Property UseColumnTextForLinkValue As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewLinkColumn
Dim value As Boolean

instance.UseColumnTextForLinkValue = value

value = instance.UseColumnTextForLinkValue
C#
[SRDescriptionAttribute("Indicates whether the DataGridViewLinkColumn.Text property value is displayed as the link text.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
public bool UseColumnTextForLinkValue {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Indicates whether the DataGridViewLinkColumn.Text property value is displayed as the link text.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
public: __property bool get_UseColumnTextForLinkValue();
public: __property void set_UseColumnTextForLinkValue(
   bool value
);
C++/CLI
[SRDescriptionAttribute("Indicates whether the DataGridViewLinkColumn.Text property value is displayed as the link text.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
public:
property bool UseColumnTextForLinkValue {
   bool get();
   void set (boolvalue);
}

Exceptions

Exception | Description
InvalidOperationException | The value of the CellTemplate property is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewLinkColumn Class
DataGridViewLinkColumn Members


VisitedLinkColor Property

[image]
Gizmox.WebGUI.Forms
VisitedLinkColor Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewLinkColumn Class : VisitedLinkColor Property

Gets or sets the color used to display a link that has been previously visited.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Appearance")>
<SRDescriptionAttribute("The color used to display a link that has been previously visited.")>
Public Property VisitedLinkColor As Color
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewLinkColumn
Dim value As Color

instance.VisitedLinkColor = value

value = instance.VisitedLinkColor
C#
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("The color used to display a link that has been previously visited.")]
public Color VisitedLinkColor {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("The color used to display a link that has been previously visited.")]
public: __property Color get_VisitedLinkColor();
public: __property void set_VisitedLinkColor(
   Color value
);
C++/CLI
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("The color used to display a link that has been previously visited.")]
public:
property Color VisitedLinkColor {
   Color get();
   void set (Colorvalue);
}

Exceptions

Exception | Description
InvalidOperationException | The value of the CellTemplate property is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewLinkColumn Class
DataGridViewLinkColumn Members


DataGridViewRow Class

[image]
Gizmox.WebGUI.Forms
DataGridViewRow Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewRow Class

Represents a row in a DataGridView control.

Object Model

Syntax

Visual Basic (Declaration)
<TypeConverterAttribute("Gizmox.WebGUI.Forms.DataGridViewRowConverter, Gizmox.WebGUI.Forms")>
Public Class DataGridViewRow
   Inherits DataGridViewBand
   Implements IRenderableComponentMember
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRow
C#
[TypeConverterAttribute("Gizmox.WebGUI.Forms.DataGridViewRowConverter, Gizmox.WebGUI.Forms")]
public class DataGridViewRow : DataGridViewBand, IRenderableComponentMember
Managed Extensions for C++
[TypeConverterAttribute("Gizmox.WebGUI.Forms.DataGridViewRowConverter, Gizmox.WebGUI.Forms")]
public __gc class DataGridViewRow : public DataGridViewBand, IRenderableComponentMember
C++/CLI
[TypeConverterAttribute("Gizmox.WebGUI.Forms.DataGridViewRowConverter, Gizmox.WebGUI.Forms")]
public ref class DataGridViewRow : public DataGridViewBand, IRenderableComponentMember

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.DataGridViewElement
Gizmox.WebGUI.Forms.DataGridViewBand
Gizmox.WebGUI.Forms.DataGridViewRow

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

DataGridViewRow Members
Gizmox.WebGUI.Forms Namespace


DataGridViewRow Class Members

[image]
Gizmox.WebGUI.Forms
DataGridViewRow Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewRow Class

The following tables list the members exposed by DataGridViewRow.

Public Constructors

 | Name | Description
Public Constructor | DataGridViewRow Constructor | Initializes a new instance of the DataGridViewRow class without using a template.
Top

Public Properties

 | Name | Description
Public Property | Cells | Gets the collection of cells that populate the row.
Public Property | DataBoundItem | Gets the data-bound object that populated the row.
Public Property | DataGridView | Gets the DataGridView control associated with this element. (Inherited from DataGridViewElement)
Public Property | DefaultCellStyle | Overridden. Gets or sets the default styles for the row, which are used to render cells in the row unless the styles are overridden.
Public Property | DefaultHeaderCellType | Gets or sets the run-time type of the default header cell. (Inherited from DataGridViewBand)
Public Property | Displayed | Overridden. Gets a value indicating whether this row is displayed on the screen.
Public Property | DividerHeight | Gets or sets the height, in pixels, of the row divider.
Public Property | ErrorText | Gets or sets the error message text for row-level errors.
Public Property | Frozen | Overridden. Gets or sets a value indicating whether the row is frozen.
Public Property | HasDefaultCellStyle | Gets a value indicating whether the DataGridViewBand.DefaultCellStyle property has been set. (Inherited from DataGridViewBand)
Public Property | HeaderCell | Gets or sets the row's header cell.
Public Property | Height | Gets or sets the current height of the row.
Public Property | Index | Gets the relative position of the band within the DataGridView control. (Inherited from DataGridViewBand)
Public Property | InheritedStyle | Overridden. Gets the cell style in effect for the row.
Public Property | IsNewRow | Gets a value indicating whether the row is the row for new records.
Public Property | MinimumHeight | Gets or sets the minimum height of the row.
Public Property | ReadOnly | Overridden. Gets or sets a value indicating whether the row is read-only.
Public Property | Resizable | Overridden. Gets or sets a value indicating whether users can resize the row or indicating that the behavior is inherited from the AllowUserToResizeRows property.
Public Property | Selected | Overridden. Gets or sets a value indicating whether the row is selected.
Public Property | State | Overridden. Gets the current state of the row.
Public Property | Tag | Gets or sets the object that contains data to associate with the band. (Inherited from DataGridViewBand)
Public Property | Visible | Overridden. Gets or sets a value indicating whether the row is visible.
Top

Protected Properties

 | Name | Description
Protected Property | HeaderCellCore | Gets or sets the header cell of the DataGridViewBand. (Inherited from DataGridViewBand)
Protected Property | IsRow | Gets a value indicating whether the band represents a row. (Inherited from DataGridViewBand)
Protected Property | MemberID | Overridden.
Protected Property | TagName | (Inherited from DataGridViewElement)
Top

Public Methods

 | Name | Description
Public Method | AdjustRowHeaderBorderStyle | Modifies an input row header border style according to the specified criteria.
Public Method | Clone | Overridden. Creates an exact copy of this row.
Public Method | CreateCells | Overloaded. Clears the existing cells and sets their template according to the supplied DataGridView template.
Public Method | Dispose | Overloaded. Releases all resources used by the DataGridViewBand. (Inherited from DataGridViewBand)
Public Method | GetErrorText | Gets the error text for the row at the specified index.
Public Method | GetPreferredHeight | Calculates the ideal height of the specified row based on the specified criteria.
Public Method | GetState | Returns a value indicating the current state of the row.
Public Method | SetValues | Sets the values of the row's cells.
Public Method | ToString | Overridden. Gets a human-readable string that describes the row.
Public Method | Update | Overloaded. Full updates of this instance. (Inherited from DataGridViewElement)
Top

Protected Methods

 | Name | Description
Protected Method | CreateCellsInstance | Constructs a new collection of cells based on this row.
Protected Method | DrawFocus | Draws a focus rectangle around the specified bounds.
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from DataGridViewElement)
Protected Method | IsDirty | Determines whether the specified component is dirty. (Inherited from DataGridViewElement)
Protected Method | IsDirtyAttributes | Overloaded. Determines whether the specified component is dirty. (Inherited from DataGridViewElement)
Protected Method | OnDataGridViewChanged | Called when the band is associated with a different DataGridView. (Inherited from DataGridViewBand)
Protected Method | RaiseCellClick | Raises the DataGridView.CellClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellContentClick | Raises the DataGridView.CellContentClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellContentDoubleClick | Raises the DataGridView.CellContentDoubleClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellValueChanged | Raises the CellValueChanged event. (Inherited from DataGridViewElement)
Protected Method | RaiseDataError | Raises the DataError event. (Inherited from DataGridViewElement)
Protected Method | RaiseMouseWheel | Raises the MouseWheel event. (Inherited from DataGridViewElement)
Protected Method | RenderAttributes | Overridden.
Protected Method | RenderComponent | Overridden.
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from DataGridViewElement)
Protected Method | RenderComponents | Overridden. Renders the controls sub tree
Protected Method | RenderUpdatedAttributes | Renders the updated attributes (Inherited from DataGridViewElement)
Protected Method | UpdateParams | Overloaded. Updates only the parameters of this instance. (Inherited from DataGridViewElement)
Top

See Also

Reference

DataGridViewRow Class
Gizmox.WebGUI.Forms Namespace


DataGridViewRow Constructor

[image]
Gizmox.WebGUI.Forms
DataGridViewRow Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRow Class : DataGridViewRow Constructor

Initializes a new instance of the DataGridViewRow class without using a template.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRow()
C#
public DataGridViewRow()
Managed Extensions for C++
public: DataGridViewRow();
C++/CLI
public:
DataGridViewRow();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRow Class
DataGridViewRow Members


DataGridViewRow Class Methods

[image]
Gizmox.WebGUI.Forms
DataGridViewRow Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewRow Class

For a list of all members of this type, see DataGridViewRow members.

Public Methods

 | Name | Description
Public Method | AdjustRowHeaderBorderStyle | Modifies an input row header border style according to the specified criteria.
Public Method | Clone | Overridden. Creates an exact copy of this row.
Public Method | CreateCells | Overloaded. Clears the existing cells and sets their template according to the supplied DataGridView template.
Public Method | Dispose | Overloaded. Releases all resources used by the DataGridViewBand. (Inherited from DataGridViewBand)
Public Method | GetErrorText | Gets the error text for the row at the specified index.
Public Method | GetPreferredHeight | Calculates the ideal height of the specified row based on the specified criteria.
Public Method | GetState | Returns a value indicating the current state of the row.
Public Method | SetValues | Sets the values of the row's cells.
Public Method | ToString | Overridden. Gets a human-readable string that describes the row.
Public Method | Update | Overloaded. Full updates of this instance. (Inherited from DataGridViewElement)
Top

Protected Methods

 | Name | Description
Protected Method | CreateCellsInstance | Constructs a new collection of cells based on this row.
Protected Method | DrawFocus | Draws a focus rectangle around the specified bounds.
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from DataGridViewElement)
Protected Method | IsDirty | Determines whether the specified component is dirty. (Inherited from DataGridViewElement)
Protected Method | IsDirtyAttributes | Overloaded. Determines whether the specified component is dirty. (Inherited from DataGridViewElement)
Protected Method | OnDataGridViewChanged | Called when the band is associated with a different DataGridView. (Inherited from DataGridViewBand)
Protected Method | RaiseCellClick | Raises the DataGridView.CellClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellContentClick | Raises the DataGridView.CellContentClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellContentDoubleClick | Raises the DataGridView.CellContentDoubleClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellValueChanged | Raises the CellValueChanged event. (Inherited from DataGridViewElement)
Protected Method | RaiseDataError | Raises the DataError event. (Inherited from DataGridViewElement)
Protected Method | RaiseMouseWheel | Raises the MouseWheel event. (Inherited from DataGridViewElement)
Protected Method | RenderAttributes | Overridden.
Protected Method | RenderComponent | Overridden.
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from DataGridViewElement)
Protected Method | RenderComponents | Overridden. Renders the controls sub tree
Protected Method | RenderUpdatedAttributes | Renders the updated attributes (Inherited from DataGridViewElement)
Protected Method | UpdateParams | Overloaded. Updates only the parameters of this instance. (Inherited from DataGridViewElement)
Top

See Also

Reference

DataGridViewRow Class
Gizmox.WebGUI.Forms Namespace


AdjustRowHeaderBorderStyle Method

[image]
Gizmox.WebGUI.Forms
AdjustRowHeaderBorderStyle Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRow Class : AdjustRowHeaderBorderStyle Method

dataGridViewAdvancedBorderStyleInput
A DataGridViewAdvancedBorderStyle that represents the row header border style to modify.
dataGridViewAdvancedBorderStylePlaceholder
A DataGridViewAdvancedBorderStyle that is used to store intermediate changes to the row header border style.
singleVerticalBorderAdded
true to add a single vertical border to the result; otherwise, false.
singleHorizontalBorderAdded
true to add a single horizontal border to the result; otherwise, false.
isFirstDisplayedRow
true if the row is the first row displayed in the DataGridView; otherwise, false.
isLastVisibleRow
true if the row is the last row in the DataGridView that has its DataGridViewRow.Visible property set to true; otherwise, false.
Modifies an input row header border style according to the specified criteria.

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Overridable Function AdjustRowHeaderBorderStyle( _
   ByVal dataGridViewAdvancedBorderStyleInput As DataGridViewAdvancedBorderStyle, _
   ByVal dataGridViewAdvancedBorderStylePlaceholder As DataGridViewAdvancedBorderStyle, _
   ByVal singleVerticalBorderAdded As Boolean, _
   ByVal singleHorizontalBorderAdded As Boolean, _
   ByVal isFirstDisplayedRow As Boolean, _
   ByVal isLastVisibleRow As Boolean _
) As DataGridViewAdvancedBorderStyle
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRow
Dim dataGridViewAdvancedBorderStyleInput As DataGridViewAdvancedBorderStyle
Dim dataGridViewAdvancedBorderStylePlaceholder As DataGridViewAdvancedBorderStyle
Dim singleVerticalBorderAdded As Boolean
Dim singleHorizontalBorderAdded As Boolean
Dim isFirstDisplayedRow As Boolean
Dim isLastVisibleRow As Boolean
Dim value As DataGridViewAdvancedBorderStyle

value = instance.AdjustRowHeaderBorderStyle(dataGridViewAdvancedBorderStyleInput, dataGridViewAdvancedBorderStylePlaceholder, singleVerticalBorderAdded, singleHorizontalBorderAdded, isFirstDisplayedRow, isLastVisibleRow)
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public virtual DataGridViewAdvancedBorderStyle AdjustRowHeaderBorderStyle(
   DataGridViewAdvancedBorderStyle dataGridViewAdvancedBorderStyleInput,
   DataGridViewAdvancedBorderStyle dataGridViewAdvancedBorderStylePlaceholder,
   bool singleVerticalBorderAdded,
   bool singleHorizontalBorderAdded,
   bool isFirstDisplayedRow,
   bool isLastVisibleRow
)
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: virtual DataGridViewAdvancedBorderStyle* AdjustRowHeaderBorderStyle(
   DataGridViewAdvancedBorderStyle* dataGridViewAdvancedBorderStyleInput,
   DataGridViewAdvancedBorderStyle* dataGridViewAdvancedBorderStylePlaceholder,
   bool singleVerticalBorderAdded,
   bool singleHorizontalBorderAdded,
   bool isFirstDisplayedRow,
   bool isLastVisibleRow
)
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
virtual DataGridViewAdvancedBorderStyle^ AdjustRowHeaderBorderStyle(
   DataGridViewAdvancedBorderStyle^ dataGridViewAdvancedBorderStyleInput,
   DataGridViewAdvancedBorderStyle^ dataGridViewAdvancedBorderStylePlaceholder,
   bool singleVerticalBorderAdded,
   bool singleHorizontalBorderAdded,
   bool isFirstDisplayedRow,
   bool isLastVisibleRow
)

Parameters

dataGridViewAdvancedBorderStyleInput
A DataGridViewAdvancedBorderStyle that represents the row header border style to modify.
dataGridViewAdvancedBorderStylePlaceholder
A DataGridViewAdvancedBorderStyle that is used to store intermediate changes to the row header border style.
singleVerticalBorderAdded
true to add a single vertical border to the result; otherwise, false.
singleHorizontalBorderAdded
true to add a single horizontal border to the result; otherwise, false.
isFirstDisplayedRow
true if the row is the first row displayed in the DataGridView; otherwise, false.
isLastVisibleRow
true if the row is the last row in the DataGridView that has its DataGridViewRow.Visible property set to true; otherwise, false.

Return Value

A DataGridViewAdvancedBorderStyle that represents the new border style used.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRow Class
DataGridViewRow Members


Clone Method

[image]
Gizmox.WebGUI.Forms
Clone Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRow Class : Clone Method

Creates an exact copy of this row.

Syntax

Visual Basic (Declaration)
Public Overrides Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRow
Dim value As Object

value = instance.Clone()
C#
public override object Clone()
Managed Extensions for C++
public: Object* Clone(); override
C++/CLI
public:
Object^ Clone(); override

Return Value

An Object that represents the cloned DataGridViewRow.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRow Class
DataGridViewRow Members


CreateCells Method

[image]
Gizmox.WebGUI.Forms
CreateCells Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRow Class : CreateCells Method

Clears the existing cells and sets their template according to the supplied DataGridView template.

Overload List

Overload | Description
CreateCells(DataGridView) | Clears the existing cells and sets their template according to the supplied DataGridView template.
CreateCells(DataGridView,Object[]) | Clears the existing cells and sets their template and values.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRow Class
DataGridViewRow Members


CreateCells(DataGridView) Method

[image]
Gizmox.WebGUI.Forms
CreateCells(DataGridView) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRow Class > CreateCells Method : CreateCells(DataGridView) Method

dataGridView
A DataGridView that acts as a template for cell styles.
Clears the existing cells and sets their template according to the supplied DataGridView template.

Syntax

Visual Basic (Declaration)
Public Overloads Sub CreateCells( _
   ByVal dataGridView As DataGridView _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRow
Dim dataGridView As DataGridView

instance.CreateCells(dataGridView)
C#
public void CreateCells(
   DataGridView dataGridView
)
Managed Extensions for C++
public: void CreateCells(
   DataGridView* dataGridView
)
C++/CLI
public:
void CreateCells(
   DataGridView^ dataGridView
)

Parameters

dataGridView
A DataGridView that acts as a template for cell styles.

Exceptions

Exception | Description
InvalidOperationException | A row that already belongs to the DataGridView was added. -or-A column that has no cell template was added.
ArgumentNullException | dataGridView is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRow Class
DataGridViewRow Members
Overload List


CreateCells(DataGridView,Object[]) Method

[image]
Gizmox.WebGUI.Forms
CreateCells(DataGridView,Object[]) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRow Class > CreateCells Method : CreateCells(DataGridView,Object[]) Method

dataGridView
A DataGridView that acts as a template for cell styles.
values
An array of objects that initialize the reset cells.
Clears the existing cells and sets their template and values.

Syntax

Visual Basic (Declaration)
Public Overloads Sub CreateCells( _
   ByVal dataGridView As DataGridView, _
   ByVal ParamArray values() As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRow
Dim dataGridView As DataGridView
Dim values() As Object

instance.CreateCells(dataGridView, values)
C#
public void CreateCells(
   DataGridView dataGridView,
   params object[] values
)
Managed Extensions for C++
public: void CreateCells(
   DataGridView* dataGridView,
   params Object*[]* values
)
C++/CLI
public:
void CreateCells(
   DataGridView^ dataGridView,
   ... array<Object^>^ values
)

Parameters

dataGridView
A DataGridView that acts as a template for cell styles.
values
An array of objects that initialize the reset cells.

Exceptions

Exception | Description
ArgumentNullException | Either of the parameters is null.
InvalidOperationException | A row that already belongs to the DataGridView was added. -or-A column that has no cell template was added.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRow Class
DataGridViewRow Members
Overload List


CreateCellsInstance Method

[image]
Gizmox.WebGUI.Forms
CreateCellsInstance Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRow Class : CreateCellsInstance Method

Constructs a new collection of cells based on this row.

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Function CreateCellsInstance() As DataGridViewCellCollection
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRow
Dim value As DataGridViewCellCollection

value = instance.CreateCellsInstance()
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual DataGridViewCellCollection CreateCellsInstance()
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual DataGridViewCellCollection* CreateCellsInstance();
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual DataGridViewCellCollection^ CreateCellsInstance();

Return Value

The newly created DataGridViewCellCollection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRow Class
DataGridViewRow Members


DrawFocus Method

[image]
Gizmox.WebGUI.Forms
DrawFocus Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRow Class : DrawFocus Method

graphics
The Graphics used to paint the DataGridViewRow.
clipBounds
A Rectangle that represents the area of the DataGridView that needs to be painted.
bounds
A Rectangle that contains the bounds of the DataGridViewRow that is being painted.
rowIndex
The row index of the cell that is being painted.
rowState
A bitwise combination of DataGridViewElementStates values that specifies the state of the row.
cellStyle
The DataGridViewCellStyle used to paint the focus rectangle.
cellsPaintSelectionBackground
true to use the DataGridViewCellStyle.SelectionBackColor property of cellStyle as the color of the focus rectangle; false to use the DataGridViewCellStyle.BackColor property of cellStyle as the color of the focus rectangle.
Draws a focus rectangle around the specified bounds.

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub DrawFocus( _
   ByVal graphics As Graphics, _
   ByVal clipBounds As Rectangle, _
   ByVal bounds As Rectangle, _
   ByVal rowIndex As Integer, _
   ByVal rowState As DataGridViewElementStates, _
   ByVal cellStyle As DataGridViewCellStyle, _
   ByVal cellsPaintSelectionBackground As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRow
Dim graphics As Graphics
Dim clipBounds As Rectangle
Dim bounds As Rectangle
Dim rowIndex As Integer
Dim rowState As DataGridViewElementStates
Dim cellStyle As DataGridViewCellStyle
Dim cellsPaintSelectionBackground As Boolean

instance.DrawFocus(graphics, clipBounds, bounds, rowIndex, rowState, cellStyle, cellsPaintSelectionBackground)
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void DrawFocus(
   Graphics graphics,
   Rectangle clipBounds,
   Rectangle bounds,
   int rowIndex,
   DataGridViewElementStates rowState,
   DataGridViewCellStyle cellStyle,
   bool cellsPaintSelectionBackground
)
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void DrawFocus(
   Graphics* graphics,
   Rectangle clipBounds,
   Rectangle bounds,
   int rowIndex,
   DataGridViewElementStates rowState,
   DataGridViewCellStyle* cellStyle,
   bool cellsPaintSelectionBackground
)
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void DrawFocus(
   Graphics^ graphics,
   Rectangle clipBounds,
   Rectangle bounds,
   int rowIndex,
   DataGridViewElementStates rowState,
   DataGridViewCellStyle^ cellStyle,
   bool cellsPaintSelectionBackground
)

Parameters

graphics
The Graphics used to paint the DataGridViewRow.
clipBounds
A Rectangle that represents the area of the DataGridView that needs to be painted.
bounds
A Rectangle that contains the bounds of the DataGridViewRow that is being painted.
rowIndex
The row index of the cell that is being painted.
rowState
A bitwise combination of DataGridViewElementStates values that specifies the state of the row.
cellStyle
The DataGridViewCellStyle used to paint the focus rectangle.
cellsPaintSelectionBackground
true to use the DataGridViewCellStyle.SelectionBackColor property of cellStyle as the color of the focus rectangle; false to use the DataGridViewCellStyle.BackColor property of cellStyle as the color of the focus rectangle.

Exceptions

Exception | Description
InvalidOperationException | The row has not been added to a DataGridView control.
ArgumentNullException | graphics is null.-or-cellStyle is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRow Class
DataGridViewRow Members


GetErrorText Method

[image]
Gizmox.WebGUI.Forms
GetErrorText Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRow Class : GetErrorText Method

rowIndex
The index of the row that contains the error.
Gets the error text for the row at the specified index.

Syntax

Visual Basic (Declaration)
Public Function GetErrorText( _
   ByVal rowIndex As Integer _
) As String
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRow
Dim rowIndex As Integer
Dim value As String

value = instance.GetErrorText(rowIndex)
C#
public string GetErrorText(
   int rowIndex
)
Managed Extensions for C++
public: string* GetErrorText(
   int rowIndex
)
C++/CLI
public:
String^ GetErrorText(
   int rowIndex
)

Parameters

rowIndex
The index of the row that contains the error.

Return Value

A string that describes the error of the row at the specified index.

Exceptions

Exception | Description
InvalidOperationException | The row belongs to a DataGridView control and is a shared row.
ArgumentOutOfRangeException | The row belongs to a DataGridView control and rowIndex is less than zero or greater than the number of rows in the control minus one.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRow Class
DataGridViewRow Members


GetPreferredHeight Method

[image]
Gizmox.WebGUI.Forms
GetPreferredHeight Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRow Class : GetPreferredHeight Method

rowIndex
The index of the row whose preferred height is calculated.
autoSizeRowMode
A DataGridViewAutoSizeRowMode that specifies an automatic sizing mode.
fixedWidth
true to calculate the preferred height for a fixed cell width; otherwise, false.
Calculates the ideal height of the specified row based on the specified criteria.

Syntax

Visual Basic (Declaration)
Public Overridable Function GetPreferredHeight( _
   ByVal rowIndex As Integer, _
   ByVal autoSizeRowMode As DataGridViewAutoSizeRowMode, _
   ByVal fixedWidth As Boolean _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRow
Dim rowIndex As Integer
Dim autoSizeRowMode As DataGridViewAutoSizeRowMode
Dim fixedWidth As Boolean
Dim value As Integer

value = instance.GetPreferredHeight(rowIndex, autoSizeRowMode, fixedWidth)
C#
public virtual int GetPreferredHeight(
   int rowIndex,
   DataGridViewAutoSizeRowMode autoSizeRowMode,
   bool fixedWidth
)
Managed Extensions for C++
public: virtual int GetPreferredHeight(
   int rowIndex,
   DataGridViewAutoSizeRowMode autoSizeRowMode,
   bool fixedWidth
)
C++/CLI
public:
virtual int GetPreferredHeight(
   int rowIndex,
   DataGridViewAutoSizeRowMode autoSizeRowMode,
   bool fixedWidth
)

Parameters

rowIndex
The index of the row whose preferred height is calculated.
autoSizeRowMode
A DataGridViewAutoSizeRowMode that specifies an automatic sizing mode.
fixedWidth
true to calculate the preferred height for a fixed cell width; otherwise, false.

Return Value

The ideal height of the row, in pixels.

Exceptions

Exception | Description
ArgumentOutOfRangeException | The rowIndex is not in the valid range of 0 to the number of rows in the control minus 1.
InvalidEnumArgumentException | autoSizeRowMode is not a valid DataGridViewAutoSizeRowMode value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRow Class
DataGridViewRow Members


GetState Method

[image]
Gizmox.WebGUI.Forms
GetState Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRow Class : GetState Method

rowIndex
The index of the row.
Returns a value indicating the current state of the row.

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Overridable Function GetState( _
   ByVal rowIndex As Integer _
) As DataGridViewElementStates
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRow
Dim rowIndex As Integer
Dim value As DataGridViewElementStates

value = instance.GetState(rowIndex)
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public virtual DataGridViewElementStates GetState(
   int rowIndex
)
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: virtual DataGridViewElementStates GetState(
   int rowIndex
)
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
virtual DataGridViewElementStates GetState(
   int rowIndex
)

Parameters

rowIndex
The index of the row.

Return Value

A bitwise combination of DataGridViewElementStates values indicating the row state.

Exceptions

Exception | Description
ArgumentOutOfRangeException | The row has been added to a DataGridView control, but the rowIndex value is not in the valid range of 0 to the number of rows in the control minus 1.
ArgumentException | The row is not a shared row, but the rowIndex value does not match the row's DataGridViewBand.Index property value.-or-The row has not been added to a DataGridView control, but the rowIndex value does not match the row's DataGridViewBand.Index property value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRow Class
DataGridViewRow Members


RenderAttributes Method

[image]
Gizmox.WebGUI.Forms
RenderAttributes Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRow Class : RenderAttributes Method

objContext
objWriter
blnRenderOwner

Syntax

Visual Basic (Declaration)
Protected Overrides Sub RenderAttributes( _
   ByVal objContext As IContext, _
   ByVal objWriter As IAttributeWriter, _
   ByVal blnRenderOwner As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRow
Dim objContext As IContext
Dim objWriter As IAttributeWriter
Dim blnRenderOwner As Boolean

instance.RenderAttributes(objContext, objWriter, blnRenderOwner)
C#
protected override void RenderAttributes(
   IContext objContext,
   IAttributeWriter objWriter,
   bool blnRenderOwner
)
Managed Extensions for C++
protected: void RenderAttributes(
   IContext* objContext,
   IAttributeWriter* objWriter,
   bool blnRenderOwner
) override
C++/CLI
protected:
void RenderAttributes(
   IContext^ objContext,
   IAttributeWriter^ objWriter,
   bool blnRenderOwner
) override

Parameters

objContext
objWriter
blnRenderOwner

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRow Class
DataGridViewRow Members


RenderComponent Method

[image]
Gizmox.WebGUI.Forms
RenderComponent Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRow Class : RenderComponent Method

objContext
objWriter
lngRequestID
blnRenderOwner

Syntax

Visual Basic (Declaration)
Protected Overrides Sub RenderComponent( _
   ByVal objContext As IContext, _
   ByVal objWriter As IResponseWriter, _
   ByVal lngRequestID As Long, _
   ByVal blnRenderOwner As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRow
Dim objContext As IContext
Dim objWriter As IResponseWriter
Dim lngRequestID As Long
Dim blnRenderOwner As Boolean

instance.RenderComponent(objContext, objWriter, lngRequestID, blnRenderOwner)
C#
protected override void RenderComponent(
   IContext objContext,
   IResponseWriter objWriter,
   long lngRequestID,
   bool blnRenderOwner
)
Managed Extensions for C++
protected: void RenderComponent(
   IContext* objContext,
   IResponseWriter* objWriter,
   long lngRequestID,
   bool blnRenderOwner
) override
C++/CLI
protected:
void RenderComponent(
   IContext^ objContext,
   IResponseWriter^ objWriter,
   long long lngRequestID,
   bool blnRenderOwner
) override

Parameters

objContext
objWriter
lngRequestID
blnRenderOwner

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRow Class
DataGridViewRow Members


RenderComponents Method

[image]
Gizmox.WebGUI.Forms
RenderComponents Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRow Class : RenderComponents Method

objContext
objWriter
lngRequestID
blnRenderOwner
Renders the controls sub tree

Syntax

Visual Basic (Declaration)
Protected Overrides Sub RenderComponents( _
   ByVal objContext As IContext, _
   ByVal objWriter As IResponseWriter, _
   ByVal lngRequestID As Long, _
   ByVal blnRenderOwner As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRow
Dim objContext As IContext
Dim objWriter As IResponseWriter
Dim lngRequestID As Long
Dim blnRenderOwner As Boolean

instance.RenderComponents(objContext, objWriter, lngRequestID, blnRenderOwner)
C#
protected override void RenderComponents(
   IContext objContext,
   IResponseWriter objWriter,
   long lngRequestID,
   bool blnRenderOwner
)
Managed Extensions for C++
protected: void RenderComponents(
   IContext* objContext,
   IResponseWriter* objWriter,
   long lngRequestID,
   bool blnRenderOwner
) override
C++/CLI
protected:
void RenderComponents(
   IContext^ objContext,
   IResponseWriter^ objWriter,
   long long lngRequestID,
   bool blnRenderOwner
) override

Parameters

objContext
objWriter
lngRequestID
blnRenderOwner

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRow Class
DataGridViewRow Members


SetValues Method

[image]
Gizmox.WebGUI.Forms
SetValues Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRow Class : SetValues Method

values
One or more objects that represent the cell values in the row.-or-An Array of Object values.
Sets the values of the row's cells.

Syntax

Visual Basic (Declaration)
Public Function SetValues( _
   ByVal ParamArray values() As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRow
Dim values() As Object
Dim value As Boolean

value = instance.SetValues(values)
C#
public bool SetValues(
   params object[] values
)
Managed Extensions for C++
public: bool SetValues(
   params Object*[]* values
)
C++/CLI
public:
bool SetValues(
   ... array<Object^>^ values
)

Parameters

values
One or more objects that represent the cell values in the row.-or-An Array of Object values.

Return Value

true if all values have been set; otherwise, false.

Exceptions

Exception | Description
ArgumentNullException | values is null.
InvalidOperationException | This method is called when the associated DataGridView is operating in virtual mode. -or-This row is a shared row.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRow Class
DataGridViewRow Members


ToString Method

[image]
Gizmox.WebGUI.Forms
ToString Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRow Class : ToString Method

Gets a human-readable string that describes the row.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRow
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Return Value

A String that describes this row.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRow Class
DataGridViewRow Members


DataGridViewRow Class Properties

[image]
Gizmox.WebGUI.Forms
DataGridViewRow Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewRow Class

For a list of all members of this type, see DataGridViewRow members.

Public Properties

 | Name | Description
Public Property | Cells | Gets the collection of cells that populate the row.
Public Property | DataBoundItem | Gets the data-bound object that populated the row.
Public Property | DataGridView | Gets the DataGridView control associated with this element. (Inherited from DataGridViewElement)
Public Property | DefaultCellStyle | Overridden. Gets or sets the default styles for the row, which are used to render cells in the row unless the styles are overridden.
Public Property | DefaultHeaderCellType | Gets or sets the run-time type of the default header cell. (Inherited from DataGridViewBand)
Public Property | Displayed | Overridden. Gets a value indicating whether this row is displayed on the screen.
Public Property | DividerHeight | Gets or sets the height, in pixels, of the row divider.
Public Property | ErrorText | Gets or sets the error message text for row-level errors.
Public Property | Frozen | Overridden. Gets or sets a value indicating whether the row is frozen.
Public Property | HasDefaultCellStyle | Gets a value indicating whether the DataGridViewBand.DefaultCellStyle property has been set. (Inherited from DataGridViewBand)
Public Property | HeaderCell | Gets or sets the row's header cell.
Public Property | Height | Gets or sets the current height of the row.
Public Property | Index | Gets the relative position of the band within the DataGridView control. (Inherited from DataGridViewBand)
Public Property | InheritedStyle | Overridden. Gets the cell style in effect for the row.
Public Property | IsNewRow | Gets a value indicating whether the row is the row for new records.
Public Property | MinimumHeight | Gets or sets the minimum height of the row.
Public Property | ReadOnly | Overridden. Gets or sets a value indicating whether the row is read-only.
Public Property | Resizable | Overridden. Gets or sets a value indicating whether users can resize the row or indicating that the behavior is inherited from the AllowUserToResizeRows property.
Public Property | Selected | Overridden. Gets or sets a value indicating whether the row is selected.
Public Property | State | Overridden. Gets the current state of the row.
Public Property | Tag | Gets or sets the object that contains data to associate with the band. (Inherited from DataGridViewBand)
Public Property | Visible | Overridden. Gets or sets a value indicating whether the row is visible.
Top

Protected Properties

 | Name | Description
Protected Property | HeaderCellCore | Gets or sets the header cell of the DataGridViewBand. (Inherited from DataGridViewBand)
Protected Property | IsRow | Gets a value indicating whether the band represents a row. (Inherited from DataGridViewBand)
Protected Property | MemberID | Overridden.
Protected Property | TagName | (Inherited from DataGridViewElement)
Top

See Also

Reference

DataGridViewRow Class
Gizmox.WebGUI.Forms Namespace


Cells Property

[image]
Gizmox.WebGUI.Forms
Cells Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRow Class : Cells Property

Gets the collection of cells that populate the row.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public ReadOnly Property Cells As DataGridViewCellCollection
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRow
Dim value As DataGridViewCellCollection

value = instance.Cells
C#
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public DataGridViewCellCollection Cells {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property DataGridViewCellCollection* get_Cells();
C++/CLI
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
property DataGridViewCellCollection^ Cells {
   DataGridViewCellCollection^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRow Class
DataGridViewRow Members


DataBoundItem Property

[image]
Gizmox.WebGUI.Forms
DataBoundItem Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRow Class : DataBoundItem Property

Gets the data-bound object that populated the row.

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<BrowsableAttribute(False)>
Public ReadOnly Property DataBoundItem As Object
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRow
Dim value As Object

value = instance.DataBoundItem
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[BrowsableAttribute(false)]
public object DataBoundItem {get;}
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[BrowsableAttribute(false)]
public: __property Object* get_DataBoundItem();
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[BrowsableAttribute(false)]
public:
property Object^ DataBoundItem {
   Object^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRow Class
DataGridViewRow Members


DefaultCellStyle Property

[image]
Gizmox.WebGUI.Forms
DefaultCellStyle Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRow Class : DefaultCellStyle Property

Gets or sets the default styles for the row, which are used to render cells in the row unless the styles are overridden.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Appearance")>
<SRDescriptionAttribute("The default cell style to be applied to the DataGridViewRow if no other style is set.")>
<NotifyParentPropertyAttribute(True)>
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(True)>
Public Overrides Property DefaultCellStyle As DataGridViewCellStyle
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRow
Dim value As DataGridViewCellStyle

instance.DefaultCellStyle = value

value = instance.DefaultCellStyle
C#
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("The default cell style to be applied to the DataGridViewRow if no other style is set.")]
[NotifyParentPropertyAttribute(true)]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(true)]
public override DataGridViewCellStyle DefaultCellStyle {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("The default cell style to be applied to the DataGridViewRow if no other style is set.")]
[NotifyParentPropertyAttribute(true)]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(true)]
public: __property DataGridViewCellStyle* get_DefaultCellStyle() override;
public: __property void set_DefaultCellStyle(
   DataGridViewCellStyle* value
) override;
C++/CLI
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("The default cell style to be applied to the DataGridViewRow if no other style is set.")]
[NotifyParentPropertyAttribute(true)]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(true)]
public:
property DataGridViewCellStyle^ DefaultCellStyle {
   DataGridViewCellStyle^ get() override;
   void set (DataGridViewCellStyle^value) override;
}

Exceptions

Exception | Description
InvalidOperationException | When setting this property, the row is in a DataGridView control and is a shared row.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRow Class
DataGridViewRow Members


Displayed Property

[image]
Gizmox.WebGUI.Forms
Displayed Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRow Class : Displayed Property

Gets a value indicating whether this row is displayed on the screen.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public Overrides ReadOnly Property Displayed As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRow
Dim value As Boolean

value = instance.Displayed
C#
[BrowsableAttribute(false)]
public override bool Displayed {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property bool get_Displayed() override;
C++/CLI
[BrowsableAttribute(false)]
public:
property bool Displayed {
   bool get() override;
}

Exceptions

Exception | Description
InvalidOperationException | The row is in a DataGridView control and is a shared row.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRow Class
DataGridViewRow Members


DividerHeight Property

[image]
Gizmox.WebGUI.Forms
DividerHeight Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRow Class : DividerHeight Property

Gets or sets the height, in pixels, of the row divider.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("The height of the row divider in pixels.")>
<SRCategoryAttribute("Appearance")>
<NotifyParentPropertyAttribute(True)>
<DefaultValueAttribute()>
Public Property DividerHeight As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRow
Dim value As Integer

instance.DividerHeight = value

value = instance.DividerHeight
C#
[SRDescriptionAttribute("The height of the row divider in pixels.")]
[SRCategoryAttribute("Appearance")]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
public int DividerHeight {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("The height of the row divider in pixels.")]
[SRCategoryAttribute("Appearance")]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
public: __property int get_DividerHeight();
public: __property void set_DividerHeight(
   int value
);
C++/CLI
[SRDescriptionAttribute("The height of the row divider in pixels.")]
[SRCategoryAttribute("Appearance")]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
public:
property int DividerHeight {
   int get();
   void set (intvalue);
}

Exceptions

Exception | Description
InvalidOperationException | When setting this property, the row is in a DataGridView control and is a shared row.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRow Class
DataGridViewRow Members


ErrorText Property

[image]
Gizmox.WebGUI.Forms
ErrorText Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRow Class : ErrorText Property

Gets or sets the error message text for row-level errors.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Appearance")>
<NotifyParentPropertyAttribute(True)>
<DefaultValueAttribute()>
<SRDescriptionAttribute("The error message text for row-level errors.")>
Public Property ErrorText As String
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRow
Dim value As String

instance.ErrorText = value

value = instance.ErrorText
C#
[SRCategoryAttribute("Appearance")]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
[SRDescriptionAttribute("The error message text for row-level errors.")]
public string ErrorText {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Appearance")]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
[SRDescriptionAttribute("The error message text for row-level errors.")]
public: __property string* get_ErrorText();
public: __property void set_ErrorText(
   string* value
);
C++/CLI
[SRCategoryAttribute("Appearance")]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
[SRDescriptionAttribute("The error message text for row-level errors.")]
public:
property String^ ErrorText {
   String^ get();
   void set (String^value);
}

Exceptions

Exception | Description
InvalidOperationException | When getting the value of this property, the row is a shared row in a DataGridView control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRow Class
DataGridViewRow Members


Frozen Property

[image]
Gizmox.WebGUI.Forms
Frozen Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRow Class : Frozen Property

Gets or sets a value indicating whether the row is frozen.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public Overrides Property Frozen As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRow
Dim value As Boolean

instance.Frozen = value

value = instance.Frozen
C#
[BrowsableAttribute(false)]
public override bool Frozen {get; set;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property bool get_Frozen() override;
public: __property void set_Frozen(
   bool value
) override;
C++/CLI
[BrowsableAttribute(false)]
public:
property bool Frozen {
   bool get() override;
   void set (boolvalue) override;
}

Exceptions

Exception | Description
InvalidOperationException | The row is in a DataGridView control and is a shared row.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRow Class
DataGridViewRow Members


HeaderCell Property

[image]
Gizmox.WebGUI.Forms
HeaderCell Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRow Class : HeaderCell Property

Gets or sets the row's header cell.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public Property HeaderCell As DataGridViewRowHeaderCell
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRow
Dim value As DataGridViewRowHeaderCell

instance.HeaderCell = value

value = instance.HeaderCell
C#
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public DataGridViewRowHeaderCell HeaderCell {get; set;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property DataGridViewRowHeaderCell* get_HeaderCell();
public: __property void set_HeaderCell(
   DataGridViewRowHeaderCell* value
);
C++/CLI
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
property DataGridViewRowHeaderCell^ HeaderCell {
   DataGridViewRowHeaderCell^ get();
   void set (DataGridViewRowHeaderCell^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRow Class
DataGridViewRow Members


Height Property

[image]
Gizmox.WebGUI.Forms
Height Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRow Class : Height Property

Gets or sets the current height of the row.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<NotifyParentPropertyAttribute(True)>
<SRDescriptionAttribute("The current height of the row.")>
<SRCategoryAttribute("Appearance")>
Public Property Height As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRow
Dim value As Integer

instance.Height = value

value = instance.Height
C#
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
[SRDescriptionAttribute("The current height of the row.")]
[SRCategoryAttribute("Appearance")]
public int Height {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
[SRDescriptionAttribute("The current height of the row.")]
[SRCategoryAttribute("Appearance")]
public: __property int get_Height();
public: __property void set_Height(
   int value
);
C++/CLI
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
[SRDescriptionAttribute("The current height of the row.")]
[SRCategoryAttribute("Appearance")]
public:
property int Height {
   int get();
   void set (intvalue);
}

Exceptions

Exception | Description
InvalidOperationException | When setting this property, the row is in a DataGridView control and is a shared row.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRow Class
DataGridViewRow Members


InheritedStyle Property

[image]
Gizmox.WebGUI.Forms
InheritedStyle Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRow Class : InheritedStyle Property

Gets the cell style in effect for the row.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property InheritedStyle As DataGridViewCellStyle
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRow
Dim value As DataGridViewCellStyle

value = instance.InheritedStyle
C#
public override DataGridViewCellStyle InheritedStyle {get;}
Managed Extensions for C++
public: __property DataGridViewCellStyle* get_InheritedStyle() override;
C++/CLI
public:
property DataGridViewCellStyle^ InheritedStyle {
   DataGridViewCellStyle^ get() override;
}

Exceptions

Exception | Description
InvalidOperationException | The row is in a DataGridView control and is a shared row.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRow Class
DataGridViewRow Members


IsNewRow Property

[image]
Gizmox.WebGUI.Forms
IsNewRow Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRow Class : IsNewRow Property

Gets a value indicating whether the row is the row for new records.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public ReadOnly Property IsNewRow As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRow
Dim value As Boolean

value = instance.IsNewRow
C#
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public bool IsNewRow {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property bool get_IsNewRow();
C++/CLI
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
property bool IsNewRow {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRow Class
DataGridViewRow Members


MemberID Property

[image]
Gizmox.WebGUI.Forms
MemberID Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRow Class : MemberID Property

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property MemberID As String
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRow
Dim value As String

value = instance.MemberID
C#
protected override string MemberID {get;}
Managed Extensions for C++
protected: __property string* get_MemberID() override;
C++/CLI
protected:
property String^ MemberID {
   String^ get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRow Class
DataGridViewRow Members


MinimumHeight Property

[image]
Gizmox.WebGUI.Forms
MinimumHeight Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRow Class : MinimumHeight Property

Gets or sets the minimum height of the row.

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
Public Property MinimumHeight As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRow
Dim value As Integer

instance.MinimumHeight = value

value = instance.MinimumHeight
C#
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public int MinimumHeight {get; set;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public: __property int get_MinimumHeight();
public: __property void set_MinimumHeight(
   int value
);
C++/CLI
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public:
property int MinimumHeight {
   int get();
   void set (intvalue);
}

Exceptions

Exception | Description
InvalidOperationException | When setting this property, the row is in a DataGridView control and is a shared row.
ArgumentOutOfRangeException | The specified value when setting this property is less than 2.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRow Class
DataGridViewRow Members


ReadOnly Property

[image]
Gizmox.WebGUI.Forms
ReadOnly Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRow Class : ReadOnly Property

Gets or sets a value indicating whether the row is read-only.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Indicates whether the row is read-only.")>
<NotifyParentPropertyAttribute(True)>
<DefaultValueAttribute()>
<BrowsableAttribute(True)>
<SRCategoryAttribute("Behavior")>
Public Overrides Property ReadOnly As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRow
Dim value As Boolean

instance.ReadOnly = value

value = instance.ReadOnly
C#
[SRDescriptionAttribute("Indicates whether the row is read-only.")]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
[BrowsableAttribute(true)]
[SRCategoryAttribute("Behavior")]
public override bool ReadOnly {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Indicates whether the row is read-only.")]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
[BrowsableAttribute(true)]
[SRCategoryAttribute("Behavior")]
public: __property bool get_ReadOnly() override;
public: __property void set_ReadOnly(
   bool value
) override;
C++/CLI
[SRDescriptionAttribute("Indicates whether the row is read-only.")]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
[BrowsableAttribute(true)]
[SRCategoryAttribute("Behavior")]
public:
property bool ReadOnly {
   bool get() override;
   void set (boolvalue) override;
}

Exceptions

Exception | Description
InvalidOperationException | The row is in a DataGridView control and is a shared row.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRow Class
DataGridViewRow Members


Resizable Property

[image]
Gizmox.WebGUI.Forms
Resizable Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRow Class : Resizable Property

Gets or sets a value indicating whether users can resize the row or indicating that the behavior is inherited from the AllowUserToResizeRows property.

Syntax

Visual Basic (Declaration)
<NotifyParentPropertyAttribute(True)>
<SRCategoryAttribute("Behavior")>
<SRDescriptionAttribute("Indicates whether users can resize the row or indicates that the behavior is inherited from the DataGridView.AllowUserToResizeRows property.")>
<DefaultValueAttribute()>
Public Overrides Property Resizable As DataGridViewTriState
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRow
Dim value As DataGridViewTriState

instance.Resizable = value

value = instance.Resizable
C#
[NotifyParentPropertyAttribute(true)]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Indicates whether users can resize the row or indicates that the behavior is inherited from the DataGridView.AllowUserToResizeRows property.")]
[DefaultValueAttribute()]
public override DataGridViewTriState Resizable {get; set;}
Managed Extensions for C++
[NotifyParentPropertyAttribute(true)]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Indicates whether users can resize the row or indicates that the behavior is inherited from the DataGridView.AllowUserToResizeRows property.")]
[DefaultValueAttribute()]
public: __property DataGridViewTriState get_Resizable() override;
public: __property void set_Resizable(
   DataGridViewTriState value
) override;
C++/CLI
[NotifyParentPropertyAttribute(true)]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Indicates whether users can resize the row or indicates that the behavior is inherited from the DataGridView.AllowUserToResizeRows property.")]
[DefaultValueAttribute()]
public:
property DataGridViewTriState Resizable {
   DataGridViewTriState get() override;
   void set (DataGridViewTriStatevalue) override;
}

Exceptions

Exception | Description
InvalidOperationException | The row is in a DataGridView control and is a shared row.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRow Class
DataGridViewRow Members


Selected Property

[image]
Gizmox.WebGUI.Forms
Selected Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRow Class : Selected Property

Gets or sets a value indicating whether the row is selected.

Syntax

Visual Basic (Declaration)
Public Overrides Property Selected As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRow
Dim value As Boolean

instance.Selected = value

value = instance.Selected
C#
public override bool Selected {get; set;}
Managed Extensions for C++
public: __property bool get_Selected() override;
public: __property void set_Selected(
   bool value
) override;
C++/CLI
public:
property bool Selected {
   bool get() override;
   void set (boolvalue) override;
}

Exceptions

Exception | Description
InvalidOperationException | The row is in a DataGridView control and is a shared row.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRow Class
DataGridViewRow Members


State Property

[image]
Gizmox.WebGUI.Forms
State Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRow Class : State Property

Gets the current state of the row.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property State As DataGridViewElementStates
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRow
Dim value As DataGridViewElementStates

value = instance.State
C#
public override DataGridViewElementStates State {get;}
Managed Extensions for C++
public: __property DataGridViewElementStates get_State() override;
C++/CLI
public:
property DataGridViewElementStates State {
   DataGridViewElementStates get() override;
}

Exceptions

Exception | Description
InvalidOperationException | The row is in a DataGridView control and is a shared row.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRow Class
DataGridViewRow Members


Visible Property

[image]
Gizmox.WebGUI.Forms
Visible Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRow Class : Visible Property

Gets or sets a value indicating whether the row is visible.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public Overrides Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRow
Dim value As Boolean

instance.Visible = value

value = instance.Visible
C#
[BrowsableAttribute(false)]
public override bool Visible {get; set;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property bool get_Visible() override;
public: __property void set_Visible(
   bool value
) override;
C++/CLI
[BrowsableAttribute(false)]
public:
property bool Visible {
   bool get() override;
   void set (boolvalue) override;
}

Exceptions

Exception | Description
InvalidOperationException | The row is in a DataGridView control and is a shared row.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRow Class
DataGridViewRow Members


DataGridViewRowCancelEventArgs Class

[image]
Gizmox.WebGUI.Forms
DataGridViewRowCancelEventArgs Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewRowCancelEventArgs Class

Provides data for the UserDeletingRow event of a DataGridView.

Object Model

Syntax

Visual Basic (Declaration)
Public Class DataGridViewRowCancelEventArgs
   Inherits CancelEventArgs
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRowCancelEventArgs
C#
public class DataGridViewRowCancelEventArgs : CancelEventArgs
Managed Extensions for C++
public __gc class DataGridViewRowCancelEventArgs : public CancelEventArgs
C++/CLI
public ref class DataGridViewRowCancelEventArgs : public CancelEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
System.ComponentModel.CancelEventArgs
Gizmox.WebGUI.Forms.DataGridViewRowCancelEventArgs

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

DataGridViewRowCancelEventArgs Members
Gizmox.WebGUI.Forms Namespace


DataGridViewRowCancelEventArgs Class Members

[image]
Gizmox.WebGUI.Forms
DataGridViewRowCancelEventArgs Class Members
See Also Properties Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewRowCancelEventArgs Class

The following tables list the members exposed by DataGridViewRowCancelEventArgs.

Public Constructors

 | Name | Description
Public Constructor | DataGridViewRowCancelEventArgs Constructor | Initializes a new instance of the DataGridViewRowCancelEventArgs class.
Top

Public Properties

 | Name | Description
Public Property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from System.ComponentModel.CancelEventArgs)
Public Property | Row | Gets the row that the user is deleting.
Top

See Also

Reference

DataGridViewRowCancelEventArgs Class
Gizmox.WebGUI.Forms Namespace


DataGridViewRowCancelEventArgs Constructor

[image]
Gizmox.WebGUI.Forms
DataGridViewRowCancelEventArgs Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRowCancelEventArgs Class : DataGridViewRowCancelEventArgs Constructor

dataGridViewRow
The row the user is deleting.
Initializes a new instance of the DataGridViewRowCancelEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal dataGridViewRow As DataGridViewRow _
)
Visual Basic (Usage) Copy Code
Dim dataGridViewRow As DataGridViewRow

Dim instance As DataGridViewRowCancelEventArgs(dataGridViewRow)
C#
public DataGridViewRowCancelEventArgs(
   DataGridViewRow dataGridViewRow
)
Managed Extensions for C++
public: DataGridViewRowCancelEventArgs(
   DataGridViewRow* dataGridViewRow
)
C++/CLI
public:
DataGridViewRowCancelEventArgs(
   DataGridViewRow^ dataGridViewRow
)

Parameters

dataGridViewRow
The row the user is deleting.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRowCancelEventArgs Class
DataGridViewRowCancelEventArgs Members


DataGridViewRowCancelEventArgs Class Properties

[image]
Gizmox.WebGUI.Forms
DataGridViewRowCancelEventArgs Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewRowCancelEventArgs Class

For a list of all members of this type, see DataGridViewRowCancelEventArgs members.

Public Properties

 | Name | Description
Public Property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from System.ComponentModel.CancelEventArgs)
Public Property | Row | Gets the row that the user is deleting.
Top

See Also

Reference

DataGridViewRowCancelEventArgs Class
Gizmox.WebGUI.Forms Namespace


Row Property

[image]
Gizmox.WebGUI.Forms
Row Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRowCancelEventArgs Class : Row Property

Gets the row that the user is deleting.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Row As DataGridViewRow
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRowCancelEventArgs
Dim value As DataGridViewRow

value = instance.Row
C#
public DataGridViewRow Row {get;}
Managed Extensions for C++
public: __property DataGridViewRow* get_Row();
C++/CLI
public:
property DataGridViewRow^ Row {
   DataGridViewRow^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRowCancelEventArgs Class
DataGridViewRowCancelEventArgs Members


DataGridViewRowCollection Class

[image]
Gizmox.WebGUI.Forms
DataGridViewRowCollection Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewRowCollection Class

A collection of DataGridViewRow objects.

Object Model

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
<DesignerSerializerAttribute(SerializerTypeName="Gizmox.WebGUI.Forms.Design.DataGridViewRowCollectionCodeDomSerializer, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", SerializerBaseTypeName="System.ComponentModel.Design.Serialization.CodeDomSerializer, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<ListBindableAttribute(False)>
Public Class DataGridViewRowCollection
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRowCollection
C#
[DefaultMemberAttribute("Item")]
[DesignerSerializerAttribute(SerializerTypeName="Gizmox.WebGUI.Forms.Design.DataGridViewRowCollectionCodeDomSerializer, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", SerializerBaseTypeName="System.ComponentModel.Design.Serialization.CodeDomSerializer, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ListBindableAttribute(false)]
public class DataGridViewRowCollection
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
[DesignerSerializerAttribute(SerializerTypeName="Gizmox.WebGUI.Forms.Design.DataGridViewRowCollectionCodeDomSerializer, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", SerializerBaseTypeName="System.ComponentModel.Design.Serialization.CodeDomSerializer, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ListBindableAttribute(false)]
public __gc class DataGridViewRowCollection
C++/CLI
[DefaultMemberAttribute("Item")]
[DesignerSerializerAttribute(SerializerTypeName="Gizmox.WebGUI.Forms.Design.DataGridViewRowCollectionCodeDomSerializer, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", SerializerBaseTypeName="System.ComponentModel.Design.Serialization.CodeDomSerializer, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ListBindableAttribute(false)]
public ref class DataGridViewRowCollection

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.DataGridViewRowCollection

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

DataGridViewRowCollection Members
Gizmox.WebGUI.Forms Namespace


DataGridViewRowCollection Class Members

[image]
Gizmox.WebGUI.Forms
DataGridViewRowCollection Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewRowCollection Class

The following tables list the members exposed by DataGridViewRowCollection.

Public Constructors

 | Name | Description
Public Constructor | DataGridViewRowCollection Constructor | Initializes a new instance of the DataGridViewRowCollection class.
Top

Public Properties

 | Name | Description
Public Property | Count | Gets the number of rows in the collection.
Public Property | Item | Gets the DataGridViewRow at the specified index.
Top

Protected Properties

 | Name | Description
Protected Property | DataGridView | Gets the DataGridView that owns the collection.
Protected Property | List | Gets an array of DataGridViewRow objects.
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Adds a new row to the collection.
Public Method | AddCopies | Adds the specified number of rows to the collection based on the row at the specified index.
Public Method | AddCopy | Adds a new row based on the row at the specified index.
Public Method | AddRange | Adds the specified DataGridViewRow objects to the collection.
Public Method | Clear | Clears the collection.
Public Method | Contains | Determines whether the specified DataGridViewRow is in the collection.
Public Method | CopyTo | Copies the items from the collection into the specified DataGridViewRow array, starting at the specified index.
Public Method | GetFirstRow | Overloaded. Returns the index of the first DataGridViewRow that meets the specified criteria.
Public Method | GetLastRow | Returns the index of the last DataGridViewRow that meets the specified criteria.
Public Method | GetNextRow | Overloaded. Returns the index of the next DataGridViewRow that meets the specified criteria.
Public Method | GetPreviousRow | Overloaded. Returns the index of the previous DataGridViewRow that meets the specified criteria.
Public Method | GetRowCount | Returns the number of DataGridViewRow objects in the collection that meet the specified criteria.
Public Method | GetRowsHeight | Returns the cumulative height of the DataGridViewRow objects that meet the specified criteria.
Public Method | GetRowState | Gets the state of the row with the specified index.
Public Method | IndexOf | Returns the index of a specified item in the collection.
Public Method | Insert | Overloaded. Inserts the specified number of rows into the collection at the specified location.
Public Method | InsertCopies | Inserts rows into the collection at the specified position.
Public Method | InsertCopy | Inserts a row into the collection at the specified position, based on the row at specified position.
Public Method | InsertRange | Inserts the DataGridViewRow objects into the collection at the specified position.
Public Method | Remove | Removes the row from the collection.
Public Method | RemoveAt | Removes the row at the specified position from the collection.
Public Method | SharedRow | Returns the DataGridViewRow at the specified index.
Top

Protected Methods

 | Name | Description
Protected Method | OnCollectionChanged | Raises the CollectionChanged event.
Top

Public Events

 | Name | Description
Public Event | CollectionChanged | Occurs when the contents of the collection change.
Top

See Also

Reference

DataGridViewRowCollection Class
Gizmox.WebGUI.Forms Namespace


DataGridViewRowCollection Constructor

[image]
Gizmox.WebGUI.Forms
DataGridViewRowCollection Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRowCollection Class : DataGridViewRowCollection Constructor

dataGridView
The DataGridView that owns the DataGridViewRowCollection.
Initializes a new instance of the DataGridViewRowCollection class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal dataGridView As DataGridView _
)
Visual Basic (Usage) Copy Code
Dim dataGridView As DataGridView

Dim instance As DataGridViewRowCollection(dataGridView)
C#
public DataGridViewRowCollection(
   DataGridView dataGridView
)
Managed Extensions for C++
public: DataGridViewRowCollection(
   DataGridView* dataGridView
)
C++/CLI
public:
DataGridViewRowCollection(
   DataGridView^ dataGridView
)

Parameters

dataGridView
The DataGridView that owns the DataGridViewRowCollection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRowCollection Class
DataGridViewRowCollection Members


DataGridViewRowCollection Class Methods

[image]
Gizmox.WebGUI.Forms
DataGridViewRowCollection Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewRowCollection Class

For a list of all members of this type, see DataGridViewRowCollection members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Adds a new row to the collection.
Public Method | AddCopies | Adds the specified number of rows to the collection based on the row at the specified index.
Public Method | AddCopy | Adds a new row based on the row at the specified index.
Public Method | AddRange | Adds the specified DataGridViewRow objects to the collection.
Public Method | Clear | Clears the collection.
Public Method | Contains | Determines whether the specified DataGridViewRow is in the collection.
Public Method | CopyTo | Copies the items from the collection into the specified DataGridViewRow array, starting at the specified index.
Public Method | GetFirstRow | Overloaded. Returns the index of the first DataGridViewRow that meets the specified criteria.
Public Method | GetLastRow | Returns the index of the last DataGridViewRow that meets the specified criteria.
Public Method | GetNextRow | Overloaded. Returns the index of the next DataGridViewRow that meets the specified criteria.
Public Method | GetPreviousRow | Overloaded. Returns the index of the previous DataGridViewRow that meets the specified criteria.
Public Method | GetRowCount | Returns the number of DataGridViewRow objects in the collection that meet the specified criteria.
Public Method | GetRowsHeight | Returns the cumulative height of the DataGridViewRow objects that meet the specified criteria.
Public Method | GetRowState | Gets the state of the row with the specified index.
Public Method | IndexOf | Returns the index of a specified item in the collection.
Public Method | Insert | Overloaded. Inserts the specified number of rows into the collection at the specified location.
Public Method | InsertCopies | Inserts rows into the collection at the specified position.
Public Method | InsertCopy | Inserts a row into the collection at the specified position, based on the row at specified position.
Public Method | InsertRange | Inserts the DataGridViewRow objects into the collection at the specified position.
Public Method | Remove | Removes the row from the collection.
Public Method | RemoveAt | Removes the row at the specified position from the collection.
Public Method | SharedRow | Returns the DataGridViewRow at the specified index.
Top

Protected Methods

 | Name | Description
Protected Method | OnCollectionChanged | Raises the CollectionChanged event.
Top

See Also

Reference

DataGridViewRowCollection Class
Gizmox.WebGUI.Forms Namespace


Add Method

[image]
Gizmox.WebGUI.Forms
Add Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRowCollection Class : Add Method

Adds a new row to the collection.

Overload List

Overload | Description
Add() | Adds a new row to the collection.
Add(Int32) | Adds the specified number of new rows to the collection.
Add(Object[]) | Adds a new row to the collection, and populates the cells with the specified objects.
Add(DataGridViewRow) | Adds the specified DataGridViewRow to the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRowCollection Class
DataGridViewRowCollection Members


Add() Method

[image]
Gizmox.WebGUI.Forms
Add() Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRowCollection Class > Add Method : Add() Method

Adds a new row to the collection.

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
Public Overloads Overridable Function Add() As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRowCollection
Dim value As Integer

value = instance.Add()
C#
[DesignerSerializationVisibilityAttribute()]
public virtual int Add()
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
public: virtual int Add();
C++/CLI
[DesignerSerializationVisibilityAttribute()]
public:
virtual int Add();

Return Value

The index of the new row.

Exceptions

Exception | Description
ArgumentException | The row returned by the DataGridView.RowTemplate property has more cells than there are columns in the control.
InvalidOperationException | The associated DataGridView control is performing one of the following actions that temporarily prevents new rows from being added:Selecting all cells in the control.Clearing the selection.-or-This method is being called from a handler for one of the following DataGridView events:RowValidated RowValidating-or-The DataSource property of the DataGridView is not null.-or-The DataGridView has no columns.-or-This operation would add a frozen row after unfrozen rows.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRowCollection Class
DataGridViewRowCollection Members
Overload List


Add(Int32) Method

[image]
Gizmox.WebGUI.Forms
Add(Int32) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRowCollection Class > Add Method : Add(Int32) Method

count
The number of rows to add to the DataGridViewRowCollection.
Adds the specified number of new rows to the collection.

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
Public Overloads Overridable Function Add( _
   ByVal count As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRowCollection
Dim count As Integer
Dim value As Integer

value = instance.Add(count)
C#
[DesignerSerializationVisibilityAttribute()]
public virtual int Add(
   int count
)
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
public: virtual int Add(
   int count
)
C++/CLI
[DesignerSerializationVisibilityAttribute()]
public:
virtual int Add(
   int count
)

Parameters

count
The number of rows to add to the DataGridViewRowCollection.

Return Value

The index of the last row that was added.

Exceptions

Exception | Description
ArgumentOutOfRangeException | count is less than 1.
InvalidOperationException | The associated DataGridView control is performing one of the following actions that temporarily prevents new rows from being added:Selecting all cells in the control.Clearing the selection.-or-This method is being called from a handler for one of the following DataGridView events:RowValidated RowValidating-or-The DataSource property of the DataGridView is not null.-or-The DataGridView has no columns.-or-The row returned by the DataGridView.RowTemplate property has more cells than there are columns in the control. -or-This operation would add frozen rows after unfrozen rows.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRowCollection Class
DataGridViewRowCollection Members
Overload List


Add(Object[]) Method

[image]
Gizmox.WebGUI.Forms
Add(Object[]) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRowCollection Class > Add Method : Add(Object[]) Method

values
A variable number of objects that populate the cells of the new DataGridViewRow.
Adds a new row to the collection, and populates the cells with the specified objects.

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
Public Overloads Overridable Function Add( _
   ByVal ParamArray values() As Object _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRowCollection
Dim values() As Object
Dim value As Integer

value = instance.Add(values)
C#
[DesignerSerializationVisibilityAttribute()]
public virtual int Add(
   params object[] values
)
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
public: virtual int Add(
   params Object*[]* values
)
C++/CLI
[DesignerSerializationVisibilityAttribute()]
public:
virtual int Add(
   ... array<Object^>^ values
)

Parameters

values
A variable number of objects that populate the cells of the new DataGridViewRow.

Return Value

The index of the new row.

Exceptions

Exception | Description
InvalidOperationException | The associated DataGridView control is performing one of the following actions that temporarily prevents new rows from being added:Selecting all cells in the control.Clearing the selection.-or-This method is being called from a handler for one of the following DataGridView events:RowValidated RowValidating-or-The VirtualMode property of the DataGridView is set to true.- or -The DataSource property of the DataGridView is not null.-or-The DataGridView has no columns. -or-The row returned by the DataGridView.RowTemplate property has more cells than there are columns in the control.-or-This operation would add a frozen row after unfrozen rows.
ArgumentNullException | values is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRowCollection Class
DataGridViewRowCollection Members
Overload List


Add(DataGridViewRow) Method

[image]
Gizmox.WebGUI.Forms
Add(DataGridViewRow) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRowCollection Class > Add Method : Add(DataGridViewRow) Method

dataGridViewRow
The DataGridViewRow to add to the DataGridViewRowCollection.
Adds the specified DataGridViewRow to the collection.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function Add( _
   ByVal dataGridViewRow As DataGridViewRow _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRowCollection
Dim dataGridViewRow As DataGridViewRow
Dim value As Integer

value = instance.Add(dataGridViewRow)
C#
public virtual int Add(
   DataGridViewRow dataGridViewRow
)
Managed Extensions for C++
public: virtual int Add(
   DataGridViewRow* dataGridViewRow
)
C++/CLI
public:
virtual int Add(
   DataGridViewRow^ dataGridViewRow
)

Parameters

dataGridViewRow
The DataGridViewRow to add to the DataGridViewRowCollection.

Return Value

The index of the new DataGridViewRow.

Exceptions

Exception | Description
ArgumentException | dataGridViewRow has more cells than there are columns in the control.
InvalidOperationException | The associated DataGridView control is performing one of the following actions that temporarily prevents new rows from being added:Selecting all cells in the control.Clearing the selection.-or-This method is being called from a handler for one of the following DataGridView events:RowValidated RowValidating-or-The DataSource property of the DataGridView is not null.-or-The DataGridView has no columns.-or-The DataGridViewElement.DataGridView property of the dataGridViewRow is not null.-or-dataGridViewRow has a DataGridViewRow.Selected property value of true. -or-This operation would add a frozen row after unfrozen rows.
ArgumentNullException | dataGridViewRow is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRowCollection Class
DataGridViewRowCollection Members
Overload List


AddCopies Method

[image]
Gizmox.WebGUI.Forms
AddCopies Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRowCollection Class : AddCopies Method

indexSource
The index of the row on which to base the new rows.
count
The number of rows to add to the DataGridViewRowCollection.
Adds the specified number of rows to the collection based on the row at the specified index.

Syntax

Visual Basic (Declaration)
Public Overridable Function AddCopies( _
   ByVal indexSource As Integer, _
   ByVal count As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRowCollection
Dim indexSource As Integer
Dim count As Integer
Dim value As Integer

value = instance.AddCopies(indexSource, count)
C#
public virtual int AddCopies(
   int indexSource,
   int count
)
Managed Extensions for C++
public: virtual int AddCopies(
   int indexSource,
   int count
)
C++/CLI
public:
virtual int AddCopies(
   int indexSource,
   int count
)

Parameters

indexSource
The index of the row on which to base the new rows.
count
The number of rows to add to the DataGridViewRowCollection.

Return Value

The index of the last row that was added.

Exceptions

Exception | Description
ArgumentOutOfRangeException | indexSource is less than zero or greater than or equal to the number of rows in the control.-or-count is less than zero.
InvalidOperationException | The associated DataGridView control is performing one of the following actions that temporarily prevents new rows from being added:Selecting all cells in the control.Clearing the selection.-or-This method is being called from a handler for one of the following DataGridView events:RowValidated RowValidating-or-The DataSource property of the DataGridView is not null.-or-This operation would add a frozen row after unfrozen rows.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRowCollection Class
DataGridViewRowCollection Members


AddCopy Method

[image]
Gizmox.WebGUI.Forms
AddCopy Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRowCollection Class : AddCopy Method

indexSource
The index of the row on which to base the new row.
Adds a new row based on the row at the specified index.

Syntax

Visual Basic (Declaration)
Public Overridable Function AddCopy( _
   ByVal indexSource As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRowCollection
Dim indexSource As Integer
Dim value As Integer

value = instance.AddCopy(indexSource)
C#
public virtual int AddCopy(
   int indexSource
)
Managed Extensions for C++
public: virtual int AddCopy(
   int indexSource
)
C++/CLI
public:
virtual int AddCopy(
   int indexSource
)

Parameters

indexSource
The index of the row on which to base the new row.

Return Value

The index of the new row.

Exceptions

Exception | Description
ArgumentOutOfRangeException | indexSource is less than zero or greater than or equal to the number of rows in the collection.
InvalidOperationException | The associated DataGridView control is performing one of the following actions that temporarily prevents new rows from being added:Selecting all cells in the control.Clearing the selection.-or-This method is being called from a handler for one of the following DataGridView events:RowValidated RowValidating-or-The DataSource property of the DataGridView is not null.-or-This operation would add a frozen row after unfrozen rows.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRowCollection Class
DataGridViewRowCollection Members


AddRange Method

[image]
Gizmox.WebGUI.Forms
AddRange Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRowCollection Class : AddRange Method

dataGridViewRows
An array of DataGridViewRow objects to be added to the DataGridViewRowCollection.
Adds the specified DataGridViewRow objects to the collection.

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
Public Overridable Sub AddRange( _
   ByVal ParamArray dataGridViewRows() As DataGridViewRow _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRowCollection
Dim dataGridViewRows() As DataGridViewRow

instance.AddRange(dataGridViewRows)
C#
[DesignerSerializationVisibilityAttribute()]
public virtual void AddRange(
   params DataGridViewRow[] dataGridViewRows
)
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
public: virtual void AddRange(
   params DataGridViewRow*[]* dataGridViewRows
)
C++/CLI
[DesignerSerializationVisibilityAttribute()]
public:
virtual void AddRange(
   ... array<DataGridViewRow^>^ dataGridViewRows
)

Parameters

dataGridViewRows
An array of DataGridViewRow objects to be added to the DataGridViewRowCollection.

Exceptions

Exception | Description
InvalidOperationException | The associated DataGridView control is performing one of the following actions that temporarily prevents new rows from being added:Selecting all cells in the control.Clearing the selection.-or-This method is being called from a handler for one of the following DataGridView events:RowValidated RowValidating-or-The DataSource property of the DataGridView is not null.-or-At least one entry in the dataGridViewRows array is null.-or-The DataGridView has no columns.-or-At least one row in the dataGridViewRows array has a DataGridViewElement.DataGridView property value that is not null.-or-At least one row in the dataGridViewRows array has a DataGridViewRow.Selected property value of true.-or-Two or more rows in the dataGridViewRows array are identical.-or-At least one row in the dataGridViewRows array contains one or more cells of a type that is incompatible with the type of the corresponding column in the control.-or-At least one row in the dataGridViewRows array contains more cells than there are columns in the control.-or-This operation would add frozen rows after unfrozen rows.
ArgumentException | dataGridViewRows contains only one row, and the row it contains has more cells than there are columns in the control.
ArgumentNullException | dataGridViewRows is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRowCollection Class
DataGridViewRowCollection Members


Clear Method

[image]
Gizmox.WebGUI.Forms
Clear Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRowCollection Class : Clear Method

Clears the collection.

Syntax

Visual Basic (Declaration)
Public Overridable Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRowCollection

instance.Clear()
C#
public virtual void Clear()
Managed Extensions for C++
public: virtual void Clear();
C++/CLI
public:
virtual void Clear();

Exceptions

Exception | Description
InvalidOperationException | The collection is data bound and the underlying data source does not support clearing the row data.-or-The associated DataGridView control is performing one of the following actions that temporarily prevents new rows from being added:Selecting all cells in the control.Clearing the selection.-or-This method is being called from a handler for one of the following DataGridView events:RowValidated RowValidating

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRowCollection Class
DataGridViewRowCollection Members


Contains Method

[image]
Gizmox.WebGUI.Forms
Contains Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRowCollection Class : Contains Method

dataGridViewRow
The DataGridViewRow to locate in the DataGridViewRowCollection.
Determines whether the specified DataGridViewRow is in the collection.

Syntax

Visual Basic (Declaration)
Public Overridable Function Contains( _
   ByVal dataGridViewRow As DataGridViewRow _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRowCollection
Dim dataGridViewRow As DataGridViewRow
Dim value As Boolean

value = instance.Contains(dataGridViewRow)
C#
public virtual bool Contains(
   DataGridViewRow dataGridViewRow
)
Managed Extensions for C++
public: virtual bool Contains(
   DataGridViewRow* dataGridViewRow
)
C++/CLI
public:
virtual bool Contains(
   DataGridViewRow^ dataGridViewRow
)

Parameters

dataGridViewRow
The DataGridViewRow to locate in the DataGridViewRowCollection.

Return Value

true if the DataGridViewRow is in the DataGridViewRowCollection; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRowCollection Class
DataGridViewRowCollection Members


CopyTo Method

[image]
Gizmox.WebGUI.Forms
CopyTo Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRowCollection Class : CopyTo Method

array
A DataGridViewRow array that is the destination of the items copied from the DataGridViewRowCollection.
index
The zero-based index in array at which copying begins.
Copies the items from the collection into the specified DataGridViewRow array, starting at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array() As DataGridViewRow, _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRowCollection
Dim array() As DataGridViewRow
Dim index As Integer

instance.CopyTo(array, index)
C#
public void CopyTo(
   DataGridViewRow[] array,
   int index
)
Managed Extensions for C++
public: void CopyTo(
   DataGridViewRow*[]* array,
   int index
)
C++/CLI
public:
void CopyTo(
   array<DataGridViewRow^>^ array,
   int index
)

Parameters

array
A DataGridViewRow array that is the destination of the items copied from the DataGridViewRowCollection.
index
The zero-based index in array at which copying begins.

Exceptions

Exception | Description
ArgumentException | array is multidimensional.-or- index is equal to or greater than the length of array.-or- The number of elements in the DataGridViewRowCollection is greater than the available space from index to the end of array.
ArgumentNullException | array is null.
ArgumentOutOfRangeException | index is less than zero.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRowCollection Class
DataGridViewRowCollection Members


GetFirstRow Method

[image]
Gizmox.WebGUI.Forms
GetFirstRow Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRowCollection Class : GetFirstRow Method

Returns the index of the first DataGridViewRow that meets the specified criteria.

Overload List

Overload | Description
GetFirstRow(DataGridViewElementStates) | Returns the index of the first DataGridViewRow that meets the specified criteria.
GetFirstRow(DataGridViewElementStates,DataGridViewElementStates) | Returns the index of the first DataGridViewRow that meets the specified inclusion and exclusion criteria.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRowCollection Class
DataGridViewRowCollection Members


GetFirstRow(DataGridViewElementStates) Method

[image]
Gizmox.WebGUI.Forms
GetFirstRow(DataGridViewElementStates) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRowCollection Class > GetFirstRow Method : GetFirstRow(DataGridViewElementStates) Method

includeFilter
A bitwise combination of DataGridViewElementStates values.
Returns the index of the first DataGridViewRow that meets the specified criteria.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetFirstRow( _
   ByVal includeFilter As DataGridViewElementStates _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRowCollection
Dim includeFilter As DataGridViewElementStates
Dim value As Integer

value = instance.GetFirstRow(includeFilter)
C#
public int GetFirstRow(
   DataGridViewElementStates includeFilter
)
Managed Extensions for C++
public: int GetFirstRow(
   DataGridViewElementStates includeFilter
)
C++/CLI
public:
int GetFirstRow(
   DataGridViewElementStates includeFilter
)

Parameters

includeFilter
A bitwise combination of DataGridViewElementStates values.

Return Value

The index of the first DataGridViewRow that has the attributes specified by includeFilter; -1 if no row is found.

Exceptions

Exception | Description
ArgumentException | includeFilter is not a valid bitwise combination of DataGridViewElementStates values.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRowCollection Class
DataGridViewRowCollection Members
Overload List


GetFirstRow(DataGridViewElementStates,DataGridViewElementStates) Method

[image]
Gizmox.WebGUI.Forms
GetFirstRow(DataGridViewElementStates,DataGridViewElementStates) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRowCollection Class > GetFirstRow Method : GetFirstRow(DataGridViewElementStates,DataGridViewElementStates) Method

includeFilter
A bitwise combination of DataGridViewElementStates values.
excludeFilter
A bitwise combination of DataGridViewElementStates values.
Returns the index of the first DataGridViewRow that meets the specified inclusion and exclusion criteria.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetFirstRow( _
   ByVal includeFilter As DataGridViewElementStates, _
   ByVal excludeFilter As DataGridViewElementStates _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRowCollection
Dim includeFilter As DataGridViewElementStates
Dim excludeFilter As DataGridViewElementStates
Dim value As Integer

value = instance.GetFirstRow(includeFilter, excludeFilter)
C#
public int GetFirstRow(
   DataGridViewElementStates includeFilter,
   DataGridViewElementStates excludeFilter
)
Managed Extensions for C++
public: int GetFirstRow(
   DataGridViewElementStates includeFilter,
   DataGridViewElementStates excludeFilter
)
C++/CLI
public:
int GetFirstRow(
   DataGridViewElementStates includeFilter,
   DataGridViewElementStates excludeFilter
)

Parameters

includeFilter
A bitwise combination of DataGridViewElementStates values.
excludeFilter
A bitwise combination of DataGridViewElementStates values.

Return Value

The index of the first DataGridViewRow that has the attributes specified by includeFilter, and does not have the attributes specified by excludeFilter; -1 if no row is found.

Exceptions

Exception | Description
ArgumentException | One or both of the specified filter values is not a valid bitwise combination of DataGridViewElementStates values.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRowCollection Class
DataGridViewRowCollection Members
Overload List


GetLastRow Method

[image]
Gizmox.WebGUI.Forms
GetLastRow Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRowCollection Class : GetLastRow Method

includeFilter
A bitwise combination of DataGridViewElementStates values.
Returns the index of the last DataGridViewRow that meets the specified criteria.

Syntax

Visual Basic (Declaration)
Public Function GetLastRow( _
   ByVal includeFilter As DataGridViewElementStates _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRowCollection
Dim includeFilter As DataGridViewElementStates
Dim value As Integer

value = instance.GetLastRow(includeFilter)
C#
public int GetLastRow(
   DataGridViewElementStates includeFilter
)
Managed Extensions for C++
public: int GetLastRow(
   DataGridViewElementStates includeFilter
)
C++/CLI
public:
int GetLastRow(
   DataGridViewElementStates includeFilter
)

Parameters

includeFilter
A bitwise combination of DataGridViewElementStates values.

Return Value

The index of the last DataGridViewRow that has the attributes specified by includeFilter; -1 if no row is found.

Exceptions

Exception | Description
ArgumentException | includeFilter is not a valid bitwise combination of DataGridViewElementStates values.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRowCollection Class
DataGridViewRowCollection Members


GetNextRow Method

[image]
Gizmox.WebGUI.Forms
GetNextRow Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRowCollection Class : GetNextRow Method

Returns the index of the next DataGridViewRow that meets the specified criteria.

Overload List

Overload | Description
GetNextRow(Int32,DataGridViewElementStates) | Returns the index of the next DataGridViewRow that meets the specified criteria.
GetNextRow(Int32,DataGridViewElementStates,DataGridViewElementStates) | Returns the index of the next DataGridViewRow that meets the specified inclusion and exclusion criteria.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRowCollection Class
DataGridViewRowCollection Members


GetNextRow(Int32,DataGridViewElementStates) Method

[image]
Gizmox.WebGUI.Forms
GetNextRow(Int32,DataGridViewElementStates) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRowCollection Class > GetNextRow Method : GetNextRow(Int32,DataGridViewElementStates) Method

indexStart
The index of the row where the method should begin to look for the next DataGridViewRow.
includeFilter
A bitwise combination of DataGridViewElementStates values.
Returns the index of the next DataGridViewRow that meets the specified criteria.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetNextRow( _
   ByVal indexStart As Integer, _
   ByVal includeFilter As DataGridViewElementStates _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRowCollection
Dim indexStart As Integer
Dim includeFilter As DataGridViewElementStates
Dim value As Integer

value = instance.GetNextRow(indexStart, includeFilter)
C#
public int GetNextRow(
   int indexStart,
   DataGridViewElementStates includeFilter
)
Managed Extensions for C++
public: int GetNextRow(
   int indexStart,
   DataGridViewElementStates includeFilter
)
C++/CLI
public:
int GetNextRow(
   int indexStart,
   DataGridViewElementStates includeFilter
)

Parameters

indexStart
The index of the row where the method should begin to look for the next DataGridViewRow.
includeFilter
A bitwise combination of DataGridViewElementStates values.

Return Value

The index of the first DataGridViewRow after indexStart that has the attributes specified by includeFilter, or -1 if no row is found.

Exceptions

Exception | Description
ArgumentException | includeFilter is not a valid bitwise combination of DataGridViewElementStates values.
ArgumentOutOfRangeException | indexStart is less than -1.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRowCollection Class
DataGridViewRowCollection Members
Overload List


GetNextRow(Int32,DataGridViewElementStates,DataGridViewElementStates) Method

[image]
Gizmox.WebGUI.Forms
GetNextRow(Int32,DataGridViewElementStates,DataGridViewElementStates) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRowCollection Class > GetNextRow Method : GetNextRow(Int32,DataGridViewElementStates,DataGridViewElementStates) Method

indexStart
The index of the row where the method should begin to look for the next DataGridViewRow.
includeFilter
A bitwise combination of DataGridViewElementStates values.
excludeFilter
A bitwise combination of DataGridViewElementStates values.
Returns the index of the next DataGridViewRow that meets the specified inclusion and exclusion criteria.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetNextRow( _
   ByVal indexStart As Integer, _
   ByVal includeFilter As DataGridViewElementStates, _
   ByVal excludeFilter As DataGridViewElementStates _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRowCollection
Dim indexStart As Integer
Dim includeFilter As DataGridViewElementStates
Dim excludeFilter As DataGridViewElementStates
Dim value As Integer

value = instance.GetNextRow(indexStart, includeFilter, excludeFilter)
C#
public int GetNextRow(
   int indexStart,
   DataGridViewElementStates includeFilter,
   DataGridViewElementStates excludeFilter
)
Managed Extensions for C++
public: int GetNextRow(
   int indexStart,
   DataGridViewElementStates includeFilter,
   DataGridViewElementStates excludeFilter
)
C++/CLI
public:
int GetNextRow(
   int indexStart,
   DataGridViewElementStates includeFilter,
   DataGridViewElementStates excludeFilter
)

Parameters

indexStart
The index of the row where the method should begin to look for the next DataGridViewRow.
includeFilter
A bitwise combination of DataGridViewElementStates values.
excludeFilter
A bitwise combination of DataGridViewElementStates values.

Return Value

The index of the next DataGridViewRow that has the attributes specified by includeFilter, and does not have the attributes specified by excludeFilter; -1 if no row is found.

Exceptions

Exception | Description
ArgumentException | One or both of the specified filter values is not a valid bitwise combination of DataGridViewElementStates values.
ArgumentOutOfRangeException | indexStart is less than -1.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRowCollection Class
DataGridViewRowCollection Members
Overload List


GetPreviousRow Method

[image]
Gizmox.WebGUI.Forms
GetPreviousRow Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRowCollection Class : GetPreviousRow Method

Returns the index of the previous DataGridViewRow that meets the specified criteria.

Overload List

Overload | Description
GetPreviousRow(Int32,DataGridViewElementStates) | Returns the index of the previous DataGridViewRow that meets the specified criteria.
GetPreviousRow(Int32,DataGridViewElementStates,DataGridViewElementStates) | Returns the index of the previous DataGridViewRow that meets the specified inclusion and exclusion criteria.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRowCollection Class
DataGridViewRowCollection Members


GetPreviousRow(Int32,DataGridViewElementStates) Method

[image]
Gizmox.WebGUI.Forms
GetPreviousRow(Int32,DataGridViewElementStates) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRowCollection Class > GetPreviousRow Method : GetPreviousRow(Int32,DataGridViewElementStates) Method

indexStart
The index of the row where the method should begin to look for the previous DataGridViewRow.
includeFilter
A bitwise combination of DataGridViewElementStates values.
Returns the index of the previous DataGridViewRow that meets the specified criteria.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetPreviousRow( _
   ByVal indexStart As Integer, _
   ByVal includeFilter As DataGridViewElementStates _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRowCollection
Dim indexStart As Integer
Dim includeFilter As DataGridViewElementStates
Dim value As Integer

value = instance.GetPreviousRow(indexStart, includeFilter)
C#
public int GetPreviousRow(
   int indexStart,
   DataGridViewElementStates includeFilter
)
Managed Extensions for C++
public: int GetPreviousRow(
   int indexStart,
   DataGridViewElementStates includeFilter
)
C++/CLI
public:
int GetPreviousRow(
   int indexStart,
   DataGridViewElementStates includeFilter
)

Parameters

indexStart
The index of the row where the method should begin to look for the previous DataGridViewRow.
includeFilter
A bitwise combination of DataGridViewElementStates values.

Return Value

The index of the previous DataGridViewRow that has the attributes specified by includeFilter; -1 if no row is found.

Exceptions

Exception | Description
ArgumentException | includeFilter is not a valid bitwise combination of DataGridViewElementStates values.
ArgumentOutOfRangeException | indexStart is greater than the number of rows in the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRowCollection Class
DataGridViewRowCollection Members
Overload List


GetPreviousRow(Int32,DataGridViewElementStates,DataGridViewElementStates) Method

[image]
Gizmox.WebGUI.Forms
GetPreviousRow(Int32,DataGridViewElementStates,DataGridViewElementStates) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRowCollection Class > GetPreviousRow Method : GetPreviousRow(Int32,DataGridViewElementStates,DataGridViewElementStates) Method

indexStart
The index of the row where the method should begin to look for the previous DataGridViewRow.
includeFilter
A bitwise combination of DataGridViewElementStates values.
excludeFilter
A bitwise combination of DataGridViewElementStates values.
Returns the index of the previous DataGridViewRow that meets the specified inclusion and exclusion criteria.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetPreviousRow( _
   ByVal indexStart As Integer, _
   ByVal includeFilter As DataGridViewElementStates, _
   ByVal excludeFilter As DataGridViewElementStates _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRowCollection
Dim indexStart As Integer
Dim includeFilter As DataGridViewElementStates
Dim excludeFilter As DataGridViewElementStates
Dim value As Integer

value = instance.GetPreviousRow(indexStart, includeFilter, excludeFilter)
C#
public int GetPreviousRow(
   int indexStart,
   DataGridViewElementStates includeFilter,
   DataGridViewElementStates excludeFilter
)
Managed Extensions for C++
public: int GetPreviousRow(
   int indexStart,
   DataGridViewElementStates includeFilter,
   DataGridViewElementStates excludeFilter
)
C++/CLI
public:
int GetPreviousRow(
   int indexStart,
   DataGridViewElementStates includeFilter,
   DataGridViewElementStates excludeFilter
)

Parameters

indexStart
The index of the row where the method should begin to look for the previous DataGridViewRow.
includeFilter
A bitwise combination of DataGridViewElementStates values.
excludeFilter
A bitwise combination of DataGridViewElementStates values.

Return Value

The index of the previous DataGridViewRow that has the attributes specified by includeFilter, and does not have the attributes specified by excludeFilter; -1 if no row is found.

Exceptions

Exception | Description
ArgumentException | One or both of the specified filter values is not a valid bitwise combination of DataGridViewElementStates values.
ArgumentOutOfRangeException | indexStart is greater than the number of rows in the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRowCollection Class
DataGridViewRowCollection Members
Overload List


GetRowCount Method

[image]
Gizmox.WebGUI.Forms
GetRowCount Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRowCollection Class : GetRowCount Method

includeFilter
A bitwise combination of DataGridViewElementStates values.
Returns the number of DataGridViewRow objects in the collection that meet the specified criteria.

Syntax

Visual Basic (Declaration)
Public Function GetRowCount( _
   ByVal includeFilter As DataGridViewElementStates _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRowCollection
Dim includeFilter As DataGridViewElementStates
Dim value As Integer

value = instance.GetRowCount(includeFilter)
C#
public int GetRowCount(
   DataGridViewElementStates includeFilter
)
Managed Extensions for C++
public: int GetRowCount(
   DataGridViewElementStates includeFilter
)
C++/CLI
public:
int GetRowCount(
   DataGridViewElementStates includeFilter
)

Parameters

includeFilter
A bitwise combination of DataGridViewElementStates values.

Return Value

The number of DataGridViewRow objects in the DataGridViewRowCollection that have the attributes specified by includeFilter.

Exceptions

Exception | Description
ArgumentException | includeFilter is not a valid bitwise combination of DataGridViewElementStates values.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRowCollection Class
DataGridViewRowCollection Members


GetRowsHeight Method

[image]
Gizmox.WebGUI.Forms
GetRowsHeight Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRowCollection Class : GetRowsHeight Method

includeFilter
A bitwise combination of DataGridViewElementStates values.
Returns the cumulative height of the DataGridViewRow objects that meet the specified criteria.

Syntax

Visual Basic (Declaration)
Public Function GetRowsHeight( _
   ByVal includeFilter As DataGridViewElementStates _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRowCollection
Dim includeFilter As DataGridViewElementStates
Dim value As Integer

value = instance.GetRowsHeight(includeFilter)
C#
public int GetRowsHeight(
   DataGridViewElementStates includeFilter
)
Managed Extensions for C++
public: int GetRowsHeight(
   DataGridViewElementStates includeFilter
)
C++/CLI
public:
int GetRowsHeight(
   DataGridViewElementStates includeFilter
)

Parameters

includeFilter
A bitwise combination of DataGridViewElementStates values.

Return Value

The cumulative height of DataGridViewRow objects in the DataGridViewRowCollection that have the attributes specified by includeFilter.

Exceptions

Exception | Description
ArgumentException | includeFilter is not a valid bitwise combination of DataGridViewElementStates values.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRowCollection Class
DataGridViewRowCollection Members


GetRowState Method

[image]
Gizmox.WebGUI.Forms
GetRowState Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRowCollection Class : GetRowState Method

rowIndex
The index of the row.
Gets the state of the row with the specified index.

Syntax

Visual Basic (Declaration)
Public Overridable Function GetRowState( _
   ByVal rowIndex As Integer _
) As DataGridViewElementStates
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRowCollection
Dim rowIndex As Integer
Dim value As DataGridViewElementStates

value = instance.GetRowState(rowIndex)
C#
public virtual DataGridViewElementStates GetRowState(
   int rowIndex
)
Managed Extensions for C++
public: virtual DataGridViewElementStates GetRowState(
   int rowIndex
)
C++/CLI
public:
virtual DataGridViewElementStates GetRowState(
   int rowIndex
)

Parameters

rowIndex
The index of the row.

Return Value

A bitwise combination of DataGridViewElementStates values indicating the state of the specified row.

Exceptions

Exception | Description
ArgumentOutOfRangeException | rowIndex is less than zero and greater than the number of rows in the collection minus one.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRowCollection Class
DataGridViewRowCollection Members


IndexOf Method

[image]
Gizmox.WebGUI.Forms
IndexOf Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRowCollection Class : IndexOf Method

dataGridViewRow
The DataGridViewRow to locate in the DataGridViewRowCollection.
Returns the index of a specified item in the collection.

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal dataGridViewRow As DataGridViewRow _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRowCollection
Dim dataGridViewRow As DataGridViewRow
Dim value As Integer

value = instance.IndexOf(dataGridViewRow)
C#
public int IndexOf(
   DataGridViewRow dataGridViewRow
)
Managed Extensions for C++
public: int IndexOf(
   DataGridViewRow* dataGridViewRow
)
C++/CLI
public:
int IndexOf(
   DataGridViewRow^ dataGridViewRow
)

Parameters

dataGridViewRow
The DataGridViewRow to locate in the DataGridViewRowCollection.

Return Value

The index of value if it is a DataGridViewRow found in the DataGridViewRowCollection; otherwise, -1.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRowCollection Class
DataGridViewRowCollection Members


Insert Method

[image]
Gizmox.WebGUI.Forms
Insert Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRowCollection Class : Insert Method

Inserts the specified number of rows into the collection at the specified location.

Overload List

Overload | Description
Insert(Int32,Int32) | Inserts the specified number of rows into the collection at the specified location.
Insert(Int32,DataGridViewRow) | Inserts the specified DataGridViewRow into the collection.
Insert(Int32,Object[]) | Inserts a row into the collection at the specified position, and populates the cells with the specified objects.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRowCollection Class
DataGridViewRowCollection Members


Insert(Int32,Int32) Method

[image]
Gizmox.WebGUI.Forms
Insert(Int32,Int32) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRowCollection Class > Insert Method : Insert(Int32,Int32) Method

rowIndex
The position at which to insert the rows.
count
The number of rows to insert into the DataGridViewRowCollection.
Inserts the specified number of rows into the collection at the specified location.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub Insert( _
   ByVal rowIndex As Integer, _
   ByVal count As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRowCollection
Dim rowIndex As Integer
Dim count As Integer

instance.Insert(rowIndex, count)
C#
public virtual void Insert(
   int rowIndex,
   int count
)
Managed Extensions for C++
public: virtual void Insert(
   int rowIndex,
   int count
)
C++/CLI
public:
virtual void Insert(
   int rowIndex,
   int count
)

Parameters

rowIndex
The position at which to insert the rows.
count
The number of rows to insert into the DataGridViewRowCollection.

Exceptions

Exception | Description
InvalidOperationException | The associated DataGridView control is performing one of the following actions that temporarily prevents new rows from being added:Selecting all cells in the control.Clearing the selection.-or-This method is being called from a handler for one of the following DataGridView events:RowValidated RowValidating-or-The DataSource property of the DataGridView is not null.-or-The DataGridView has no columns.-or-rowIndex is equal to the number of rows in the collection and the AllowUserToAddRows property of the DataGridView is set to true.-or-The row returned by the DataGridView.RowTemplate property has more cells than there are columns in the control. -or-This operation would insert a frozen row after unfrozen rows or an unfrozen row before frozen rows.
ArgumentOutOfRangeException | rowIndex is less than zero or greater than the number of rows in the collection. -or-count is less than 1.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRowCollection Class
DataGridViewRowCollection Members
Overload List


Insert(Int32,DataGridViewRow) Method

[image]
Gizmox.WebGUI.Forms
Insert(Int32,DataGridViewRow) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRowCollection Class > Insert Method : Insert(Int32,DataGridViewRow) Method

rowIndex
The position at which to insert the row.
dataGridViewRow
The DataGridViewRow to insert into the DataGridViewRowCollection.
Inserts the specified DataGridViewRow into the collection.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub Insert( _
   ByVal rowIndex As Integer, _
   ByVal dataGridViewRow As DataGridViewRow _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRowCollection
Dim rowIndex As Integer
Dim dataGridViewRow As DataGridViewRow

instance.Insert(rowIndex, dataGridViewRow)
C#
public virtual void Insert(
   int rowIndex,
   DataGridViewRow dataGridViewRow
)
Managed Extensions for C++
public: virtual void Insert(
   int rowIndex,
   DataGridViewRow* dataGridViewRow
)
C++/CLI
public:
virtual void Insert(
   int rowIndex,
   DataGridViewRow^ dataGridViewRow
)

Parameters

rowIndex
The position at which to insert the row.
dataGridViewRow
The DataGridViewRow to insert into the DataGridViewRowCollection.

Exceptions

Exception | Description
ArgumentOutOfRangeException | rowIndex is less than zero or greater than the number of rows in the collection.
ArgumentException | dataGridViewRow has more cells than there are columns in the control.
InvalidOperationException | The associated DataGridView control is performing one of the following actions that temporarily prevents new rows from being added:Selecting all cells in the control.Clearing the selection.-or-This method is being called from a handler for one of the following DataGridView events:RowValidated RowValidating-or-The DataSource property of the DataGridView is not null.-or-rowIndex is equal to the number of rows in the collection and the AllowUserToAddRows property of the DataGridView is set to true.-or-The DataGridView has no columns.-or-The DataGridViewElement.DataGridView property of dataGridViewRow is not null.-or-dataGridViewRow has a DataGridViewRow.Selected property value of true. -or-This operation would insert a frozen row after unfrozen rows or an unfrozen row before frozen rows.
ArgumentNullException | dataGridViewRow is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRowCollection Class
DataGridViewRowCollection Members
Overload List


Insert(Int32,Object[]) Method

[image]
Gizmox.WebGUI.Forms
Insert(Int32,Object[]) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRowCollection Class > Insert Method : Insert(Int32,Object[]) Method

rowIndex
The position at which to insert the row.
values
A variable number of objects that populate the cells of the new row.
Inserts a row into the collection at the specified position, and populates the cells with the specified objects.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub Insert( _
   ByVal rowIndex As Integer, _
   ByVal ParamArray values() As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRowCollection
Dim rowIndex As Integer
Dim values() As Object

instance.Insert(rowIndex, values)
C#
public virtual void Insert(
   int rowIndex,
   params object[] values
)
Managed Extensions for C++
public: virtual void Insert(
   int rowIndex,
   params Object*[]* values
)
C++/CLI
public:
virtual void Insert(
   int rowIndex,
   ... array<Object^>^ values
)

Parameters

rowIndex
The position at which to insert the row.
values
A variable number of objects that populate the cells of the new row.

Exceptions

Exception | Description
ArgumentOutOfRangeException | rowIndex is less than zero or greater than the number of rows in the collection.
ArgumentException | The row returned by the control's DataGridView.RowTemplate property has more cells than there are columns in the control.
InvalidOperationException | The associated DataGridView control is performing one of the following actions that temporarily prevents new rows from being added:Selecting all cells in the control.Clearing the selection.-or-This method is being called from a handler for one of the following DataGridView events:RowValidated RowValidating-or-The VirtualMode property of the DataGridView is set to true.-or-The DataSource property of the DataGridView is not null.-or-The DataGridView has no columns.-or-rowIndex is equal to the number of rows in the collection and the AllowUserToAddRows property of the DataGridView is set to true.-or-The DataGridViewElement.DataGridView property of the row returned by the control's DataGridView.RowTemplate property is not null. -or-This operation would insert a frozen row after unfrozen rows or an unfrozen row before frozen rows.
ArgumentNullException | values is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRowCollection Class
DataGridViewRowCollection Members
Overload List


InsertCopies Method

[image]
Gizmox.WebGUI.Forms
InsertCopies Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRowCollection Class : InsertCopies Method

indexSource
The index of the DataGridViewRow on which to base the new rows.
indexDestination
The position at which to insert the rows.
count
The number of DataGridViewRow objects to add to the DataGridViewRowCollection.
Inserts rows into the collection at the specified position.

Syntax

Visual Basic (Declaration)
Public Overridable Sub InsertCopies( _
   ByVal indexSource As Integer, _
   ByVal indexDestination As Integer, _
   ByVal count As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRowCollection
Dim indexSource As Integer
Dim indexDestination As Integer
Dim count As Integer

instance.InsertCopies(indexSource, indexDestination, count)
C#
public virtual void InsertCopies(
   int indexSource,
   int indexDestination,
   int count
)
Managed Extensions for C++
public: virtual void InsertCopies(
   int indexSource,
   int indexDestination,
   int count
)
C++/CLI
public:
virtual void InsertCopies(
   int indexSource,
   int indexDestination,
   int count
)

Parameters

indexSource
The index of the DataGridViewRow on which to base the new rows.
indexDestination
The position at which to insert the rows.
count
The number of DataGridViewRow objects to add to the DataGridViewRowCollection.

Exceptions

Exception | Description
ArgumentOutOfRangeException | indexSource is less than zero or greater than the number of rows in the collection minus one.-or-indexDestination is less than zero or greater than the number of rows in the collection.-or-count is less than 1.
InvalidOperationException | The associated DataGridView control is performing one of the following actions that temporarily prevents new rows from being added:Selecting all cells in the control.Clearing the selection.-or-This method is being called from a handler for one of the following DataGridView events:RowValidated RowValidating-or-indexDestination is equal to the number of rows in the collection and AllowUserToAddRows is true.-or-This operation would insert frozen rows after unfrozen rows or unfrozen rows before frozen rows.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRowCollection Class
DataGridViewRowCollection Members


InsertCopy Method

[image]
Gizmox.WebGUI.Forms
InsertCopy Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRowCollection Class : InsertCopy Method

indexSource
The index of the row on which to base the new row.
indexDestination
The position at which to insert the row.
Inserts a row into the collection at the specified position, based on the row at specified position.

Syntax

Visual Basic (Declaration)
Public Overridable Sub InsertCopy( _
   ByVal indexSource As Integer, _
   ByVal indexDestination As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRowCollection
Dim indexSource As Integer
Dim indexDestination As Integer

instance.InsertCopy(indexSource, indexDestination)
C#
public virtual void InsertCopy(
   int indexSource,
   int indexDestination
)
Managed Extensions for C++
public: virtual void InsertCopy(
   int indexSource,
   int indexDestination
)
C++/CLI
public:
virtual void InsertCopy(
   int indexSource,
   int indexDestination
)

Parameters

indexSource
The index of the row on which to base the new row.
indexDestination
The position at which to insert the row.

Exceptions

Exception | Description
ArgumentOutOfRangeException | indexSource is less than zero or greater than the number of rows in the collection minus one.-or-indexDestination is less than zero or greater than the number of rows in the collection.
InvalidOperationException | The associated DataGridView control is performing one of the following actions that temporarily prevents new rows from being added:Selecting all cells in the control.Clearing the selection.-or-This method is being called from a handler for one of the following DataGridView events:RowValidated RowValidating-or-indexDestination is equal to the number of rows in the collection and AllowUserToAddRows is true. -or-This operation would insert a frozen row after unfrozen rows or an unfrozen row before frozen rows.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRowCollection Class
DataGridViewRowCollection Members


InsertRange Method

[image]
Gizmox.WebGUI.Forms
InsertRange Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRowCollection Class : InsertRange Method

rowIndex
The position at which to insert the rows.
dataGridViewRows
An array of DataGridViewRow objects to add to the DataGridViewRowCollection.
Inserts the DataGridViewRow objects into the collection at the specified position.

Syntax

Visual Basic (Declaration)
Public Overridable Sub InsertRange( _
   ByVal rowIndex As Integer, _
   ByVal ParamArray dataGridViewRows() As DataGridViewRow _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRowCollection
Dim rowIndex As Integer
Dim dataGridViewRows() As DataGridViewRow

instance.InsertRange(rowIndex, dataGridViewRows)
C#
public virtual void InsertRange(
   int rowIndex,
   params DataGridViewRow[] dataGridViewRows
)
Managed Extensions for C++
public: virtual void InsertRange(
   int rowIndex,
   params DataGridViewRow*[]* dataGridViewRows
)
C++/CLI
public:
virtual void InsertRange(
   int rowIndex,
   ... array<DataGridViewRow^>^ dataGridViewRows
)

Parameters

rowIndex
The position at which to insert the rows.
dataGridViewRows
An array of DataGridViewRow objects to add to the DataGridViewRowCollection.

Exceptions

Exception | Description
InvalidOperationException | The associated DataGridView control is performing one of the following actions that temporarily prevents new rows from being added:Selecting all cells in the control.Clearing the selection.-or-This method is being called from a handler for one of the following DataGridView events:RowValidated RowValidating-or-rowIndex is equal to the number of rows in the collection and AllowUserToAddRows is true.-or-The DataSource property of the DataGridView is not null.-or-At least one entry in the dataGridViewRows array is null.-or-The DataGridView has no columns.-or-At least one row in the dataGridViewRows array has a DataGridViewElement.DataGridView property value that is not null.-or-At least one row in the dataGridViewRows array has a DataGridViewRow.Selected property value of true.-or-Two or more rows in the dataGridViewRows array are identical.-or-At least one row in the dataGridViewRows array contains one or more cells of a type that is incompatible with the type of the corresponding column in the control.-or-At least one row in the dataGridViewRows array contains more cells than there are columns in the control. -or-This operation would insert frozen rows after unfrozen rows or unfrozen rows before frozen rows.
ArgumentOutOfRangeException | rowIndex is less than zero or greater than the number of rows in the collection.
ArgumentException | dataGridViewRows contains only one row, and the row it contains has more cells than there are columns in the control.
ArgumentNullException | dataGridViewRows is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRowCollection Class
DataGridViewRowCollection Members


OnCollectionChanged Method

[image]
Gizmox.WebGUI.Forms
OnCollectionChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRowCollection Class : OnCollectionChanged Method

e
A CollectionChangeEventArgs that contains the event data.
Raises the CollectionChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnCollectionChanged( _
   ByVal e As CollectionChangeEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRowCollection
Dim e As CollectionChangeEventArgs

instance.OnCollectionChanged(e)
C#
protected virtual void OnCollectionChanged(
   CollectionChangeEventArgs e
)
Managed Extensions for C++
protected: virtual void OnCollectionChanged(
   CollectionChangeEventArgs* e
)
C++/CLI
protected:
virtual void OnCollectionChanged(
   CollectionChangeEventArgs^ e
)

Parameters

e
A CollectionChangeEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRowCollection Class
DataGridViewRowCollection Members


Remove Method

[image]
Gizmox.WebGUI.Forms
Remove Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRowCollection Class : Remove Method

dataGridViewRow
The row to remove from the DataGridViewRowCollection.
Removes the row from the collection.

Syntax

Visual Basic (Declaration)
Public Overridable Sub Remove( _
   ByVal dataGridViewRow As DataGridViewRow _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRowCollection
Dim dataGridViewRow As DataGridViewRow

instance.Remove(dataGridViewRow)
C#
public virtual void Remove(
   DataGridViewRow dataGridViewRow
)
Managed Extensions for C++
public: virtual void Remove(
   DataGridViewRow* dataGridViewRow
)
C++/CLI
public:
virtual void Remove(
   DataGridViewRow^ dataGridViewRow
)

Parameters

dataGridViewRow
The row to remove from the DataGridViewRowCollection.

Exceptions

Exception | Description
InvalidOperationException | The associated DataGridView control is performing one of the following actions that temporarily prevents new rows from being added:Selecting all cells in the control.Clearing the selection.-or-This method is being called from a handler for one of the following DataGridView events:RowValidated RowValidating-or-dataGridViewRow is the row for new records.-or-The associated DataGridView control is bound to an IBindingList implementation with AllowRemove and SupportsChangeNotification property values that are not both true.
ArgumentException | dataGridViewRow is not contained in this collection.-or-dataGridViewRow is a shared row.
ArgumentNullException | dataGridViewRow is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRowCollection Class
DataGridViewRowCollection Members


RemoveAt Method

[image]
Gizmox.WebGUI.Forms
RemoveAt Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRowCollection Class : RemoveAt Method

index
The position of the row to remove.
Removes the row at the specified position from the collection.

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveAt( _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRowCollection
Dim index As Integer

instance.RemoveAt(index)
C#
public virtual void RemoveAt(
   int index
)
Managed Extensions for C++
public: virtual void RemoveAt(
   int index
)
C++/CLI
public:
virtual void RemoveAt(
   int index
)

Parameters

index
The position of the row to remove.

Exceptions

Exception | Description
ArgumentOutOfRangeException | index is less than zero and greater than the number of rows in the collection minus one.
InvalidOperationException | The associated DataGridView control is performing one of the following actions that temporarily prevents new rows from being added:Selecting all cells in the control.Clearing the selection.-or-This method is being called from a handler for one of the following DataGridView events:RowValidated RowValidating-or-index is equal to the number of rows in the collection and the AllowUserToAddRows property of the DataGridView is set to true.-or-The associated DataGridView control is bound to an IBindingList implementation with AllowRemove and SupportsChangeNotification property values that are not both true.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRowCollection Class
DataGridViewRowCollection Members


SharedRow Method

[image]
Gizmox.WebGUI.Forms
SharedRow Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRowCollection Class : SharedRow Method

rowIndex
The index of the DataGridViewRow to get.
Returns the DataGridViewRow at the specified index.

Syntax

Visual Basic (Declaration)
Public Function SharedRow( _
   ByVal rowIndex As Integer _
) As DataGridViewRow
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRowCollection
Dim rowIndex As Integer
Dim value As DataGridViewRow

value = instance.SharedRow(rowIndex)
C#
public DataGridViewRow SharedRow(
   int rowIndex
)
Managed Extensions for C++
public: DataGridViewRow* SharedRow(
   int rowIndex
)
C++/CLI
public:
DataGridViewRow^ SharedRow(
   int rowIndex
)

Parameters

rowIndex
The index of the DataGridViewRow to get.

Return Value

The DataGridViewRow positioned at the specified index.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRowCollection Class
DataGridViewRowCollection Members


DataGridViewRowCollection Class Properties

[image]
Gizmox.WebGUI.Forms
DataGridViewRowCollection Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewRowCollection Class

For a list of all members of this type, see DataGridViewRowCollection members.

Public Properties

 | Name | Description
Public Property | Count | Gets the number of rows in the collection.
Public Property | Item | Gets the DataGridViewRow at the specified index.
Top

Protected Properties

 | Name | Description
Protected Property | DataGridView | Gets the DataGridView that owns the collection.
Protected Property | List | Gets an array of DataGridViewRow objects.
Top

See Also

Reference

DataGridViewRowCollection Class
Gizmox.WebGUI.Forms Namespace


Count Property

[image]
Gizmox.WebGUI.Forms
Count Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRowCollection Class : Count Property

Gets the number of rows in the collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRowCollection
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRowCollection Class
DataGridViewRowCollection Members


DataGridView Property

[image]
Gizmox.WebGUI.Forms
DataGridView Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRowCollection Class : DataGridView Property

Gets the DataGridView that owns the collection.

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property DataGridView As DataGridView
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRowCollection
Dim value As DataGridView

value = instance.DataGridView
C#
protected DataGridView DataGridView {get;}
Managed Extensions for C++
protected: __property DataGridView* get_DataGridView();
C++/CLI
protected:
property DataGridView^ DataGridView {
   DataGridView^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRowCollection Class
DataGridViewRowCollection Members


Item Property

[image]
Gizmox.WebGUI.Forms
Item Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRowCollection Class : Item Property

index
The zero-based index of the DataGridViewRow to get.
Gets the DataGridViewRow at the specified index.

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal index As Integer _
) As DataGridViewRow
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRowCollection
Dim index As Integer
Dim value As DataGridViewRow

value = instance.Item(index)
C#
public DataGridViewRow this[
   int index
]; {get;}
Managed Extensions for C++
public: __property DataGridViewRow* get_Item(
   int index
);
C++/CLI
public:
property DataGridViewRow^ default [int] {
   DataGridViewRow^ get(intindex);
}

Parameters

index
The zero-based index of the DataGridViewRow to get.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRowCollection Class
DataGridViewRowCollection Members


List Property

[image]
Gizmox.WebGUI.Forms
List Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRowCollection Class : List Property

Gets an array of DataGridViewRow objects.

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property List As ArrayList
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRowCollection
Dim value As ArrayList

value = instance.List
C#
protected ArrayList List {get;}
Managed Extensions for C++
protected: __property ArrayList* get_List();
C++/CLI
protected:
property ArrayList^ List {
   ArrayList^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRowCollection Class
DataGridViewRowCollection Members


DataGridViewRowCollection Class Events

[image]
Gizmox.WebGUI.Forms
DataGridViewRowCollection Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewRowCollection Class

For a list of all members of this type, see DataGridViewRowCollection members.

Public Events

 | Name | Description
Public Event | CollectionChanged | Occurs when the contents of the collection change.
Top

See Also

Reference

DataGridViewRowCollection Class
Gizmox.WebGUI.Forms Namespace


CollectionChanged Event

[image]
Gizmox.WebGUI.Forms
CollectionChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRowCollection Class : CollectionChanged Event

Occurs when the contents of the collection change.

Syntax

Visual Basic (Declaration)
Public Event CollectionChanged() As CollectionChangeEventHandler
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRowCollection
Dim handler As CollectionChangeEventHandler

AddHandler instance.CollectionChanged, handler
C#
public event CollectionChangeEventHandler CollectionChanged()
Managed Extensions for C++
public: __event CollectionChangeEventHandler* CollectionChanged
C++/CLI
public:
event CollectionChangeEventHandler^ CollectionChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRowCollection Class
DataGridViewRowCollection Members


DataGridViewRowContextMenuStripNeededEventArgs Class

[image]
Gizmox.WebGUI.Forms
DataGridViewRowContextMenuStripNeededEventArgs Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewRowContextMenuStripNeededEventArgs Class

Provides data for the RowContextMenuStripNeeded event.

Syntax

Visual Basic (Declaration)
Public Class DataGridViewRowContextMenuStripNeededEventArgs
   Inherits EventArgs
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRowContextMenuStripNeededEventArgs
C#
public class DataGridViewRowContextMenuStripNeededEventArgs : EventArgs
Managed Extensions for C++
public __gc class DataGridViewRowContextMenuStripNeededEventArgs : public EventArgs
C++/CLI
public ref class DataGridViewRowContextMenuStripNeededEventArgs : public EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gizmox.WebGUI.Forms.DataGridViewRowContextMenuStripNeededEventArgs

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

DataGridViewRowContextMenuStripNeededEventArgs Members
Gizmox.WebGUI.Forms Namespace


DataGridViewRowContextMenuStripNeededEventArgs Class Members

[image]
Gizmox.WebGUI.Forms
DataGridViewRowContextMenuStripNeededEventArgs Class Members
See Also Properties Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewRowContextMenuStripNeededEventArgs Class

The following tables list the members exposed by DataGridViewRowContextMenuStripNeededEventArgs.

Public Constructors

 | Name | Description
Public Constructor | DataGridViewRowContextMenuStripNeededEventArgs Constructor | Initializes a new instance of the DataGridViewRowContextMenuStripNeededEventArgs class.
Top

Public Properties

 | Name | Description
Public Property | RowIndex | Gets the index of the row that is requesting a shortcut menu.
Top

See Also

Reference

DataGridViewRowContextMenuStripNeededEventArgs Class
Gizmox.WebGUI.Forms Namespace


DataGridViewRowContextMenuStripNeededEventArgs Constructor

[image]
Gizmox.WebGUI.Forms
DataGridViewRowContextMenuStripNeededEventArgs Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRowContextMenuStripNeededEventArgs Class : DataGridViewRowContextMenuStripNeededEventArgs Constructor

rowIndex
The index of the row.
Initializes a new instance of the DataGridViewRowContextMenuStripNeededEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal rowIndex As Integer _
)
Visual Basic (Usage) Copy Code
Dim rowIndex As Integer

Dim instance As DataGridViewRowContextMenuStripNeededEventArgs(rowIndex)
C#
public DataGridViewRowContextMenuStripNeededEventArgs(
   int rowIndex
)
Managed Extensions for C++
public: DataGridViewRowContextMenuStripNeededEventArgs(
   int rowIndex
)
C++/CLI
public:
DataGridViewRowContextMenuStripNeededEventArgs(
   int rowIndex
)

Parameters

rowIndex
The index of the row.

Exceptions

Exception | Description
ArgumentOutOfRangeException | rowIndex is less than -1.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRowContextMenuStripNeededEventArgs Class
DataGridViewRowContextMenuStripNeededEventArgs Members


DataGridViewRowContextMenuStripNeededEventArgs Class Properties

[image]
Gizmox.WebGUI.Forms
DataGridViewRowContextMenuStripNeededEventArgs Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewRowContextMenuStripNeededEventArgs Class

For a list of all members of this type, see DataGridViewRowContextMenuStripNeededEventArgs members.

Public Properties

 | Name | Description
Public Property | RowIndex | Gets the index of the row that is requesting a shortcut menu.
Top

See Also

Reference

DataGridViewRowContextMenuStripNeededEventArgs Class
Gizmox.WebGUI.Forms Namespace


RowIndex Property

[image]
Gizmox.WebGUI.Forms
RowIndex Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRowContextMenuStripNeededEventArgs Class : RowIndex Property

Gets the index of the row that is requesting a shortcut menu.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RowIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRowContextMenuStripNeededEventArgs
Dim value As Integer

value = instance.RowIndex
C#
public int RowIndex {get;}
Managed Extensions for C++
public: __property int get_RowIndex();
C++/CLI
public:
property int RowIndex {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRowContextMenuStripNeededEventArgs Class
DataGridViewRowContextMenuStripNeededEventArgs Members


DataGridViewRowDividerDoubleClickEventArgs Class

[image]
Gizmox.WebGUI.Forms
DataGridViewRowDividerDoubleClickEventArgs Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewRowDividerDoubleClickEventArgs Class

Provides data for the RowDividerDoubleClick event of a DataGridView.

Syntax

Visual Basic (Declaration)
Public Class DataGridViewRowDividerDoubleClickEventArgs
   Inherits HandledMouseEventArgs
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRowDividerDoubleClickEventArgs
C#
public class DataGridViewRowDividerDoubleClickEventArgs : HandledMouseEventArgs
Managed Extensions for C++
public __gc class DataGridViewRowDividerDoubleClickEventArgs : public HandledMouseEventArgs
C++/CLI
public ref class DataGridViewRowDividerDoubleClickEventArgs : public HandledMouseEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gizmox.WebGUI.Forms.MouseEventArgs
Gizmox.WebGUI.Forms.HandledMouseEventArgs
Gizmox.WebGUI.Forms.DataGridViewRowDividerDoubleClickEventArgs

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

DataGridViewRowDividerDoubleClickEventArgs Members
Gizmox.WebGUI.Forms Namespace


DataGridViewRowDividerDoubleClickEventArgs Class Members

[image]
Gizmox.WebGUI.Forms
DataGridViewRowDividerDoubleClickEventArgs Class Members
See Also Properties Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewRowDividerDoubleClickEventArgs Class

The following tables list the members exposed by DataGridViewRowDividerDoubleClickEventArgs.

Public Constructors

 | Name | Description
Public Constructor | DataGridViewRowDividerDoubleClickEventArgs Constructor | Initializes a new instance of the DataGridViewRowDividerDoubleClickEventArgs class.
Top

Public Properties

 | Name | Description
Public Property | Button | (Inherited from MouseEventArgs)
Public Property | Clicks | (Inherited from MouseEventArgs)
Public Property | Delta | (Inherited from MouseEventArgs)
Public Property | Handled | Gets or sets whether this event should be forwarded to the control's parent container. (Inherited from HandledMouseEventArgs)
Public Property | RowIndex | The index of the row above the row divider that was double-clicked.
Public Property | X | (Inherited from MouseEventArgs)
Public Property | Y | (Inherited from MouseEventArgs)
Top

See Also

Reference

DataGridViewRowDividerDoubleClickEventArgs Class
Gizmox.WebGUI.Forms Namespace


DataGridViewRowDividerDoubleClickEventArgs Constructor

[image]
Gizmox.WebGUI.Forms
DataGridViewRowDividerDoubleClickEventArgs Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRowDividerDoubleClickEventArgs Class : DataGridViewRowDividerDoubleClickEventArgs Constructor

rowIndex
The index of the row above the row divider that was double-clicked.
e
A new HandledMouseEventArgs containing the inherited event data.
Initializes a new instance of the DataGridViewRowDividerDoubleClickEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal rowIndex As Integer, _
   ByVal e As HandledMouseEventArgs _
)
Visual Basic (Usage) Copy Code
Dim rowIndex As Integer
Dim e As HandledMouseEventArgs

Dim instance As DataGridViewRowDividerDoubleClickEventArgs(rowIndex, e)
C#
public DataGridViewRowDividerDoubleClickEventArgs(
   int rowIndex,
   HandledMouseEventArgs e
)
Managed Extensions for C++
public: DataGridViewRowDividerDoubleClickEventArgs(
   int rowIndex,
   HandledMouseEventArgs* e
)
C++/CLI
public:
DataGridViewRowDividerDoubleClickEventArgs(
   int rowIndex,
   HandledMouseEventArgs^ e
)

Parameters

rowIndex
The index of the row above the row divider that was double-clicked.
e
A new HandledMouseEventArgs containing the inherited event data.

Exceptions

Exception | Description
ArgumentOutOfRangeException | rowIndex is less than -1.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRowDividerDoubleClickEventArgs Class
DataGridViewRowDividerDoubleClickEventArgs Members


DataGridViewRowDividerDoubleClickEventArgs Class Properties

[image]
Gizmox.WebGUI.Forms
DataGridViewRowDividerDoubleClickEventArgs Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewRowDividerDoubleClickEventArgs Class

For a list of all members of this type, see DataGridViewRowDividerDoubleClickEventArgs members.

Public Properties

 | Name | Description
Public Property | Button | (Inherited from MouseEventArgs)
Public Property | Clicks | (Inherited from MouseEventArgs)
Public Property | Delta | (Inherited from MouseEventArgs)
Public Property | Handled | Gets or sets whether this event should be forwarded to the control's parent container. (Inherited from HandledMouseEventArgs)
Public Property | RowIndex | The index of the row above the row divider that was double-clicked.
Public Property | X | (Inherited from MouseEventArgs)
Public Property | Y | (Inherited from MouseEventArgs)
Top

See Also

Reference

DataGridViewRowDividerDoubleClickEventArgs Class
Gizmox.WebGUI.Forms Namespace


RowIndex Property

[image]
Gizmox.WebGUI.Forms
RowIndex Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRowDividerDoubleClickEventArgs Class : RowIndex Property

The index of the row above the row divider that was double-clicked.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RowIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRowDividerDoubleClickEventArgs
Dim value As Integer

value = instance.RowIndex
C#
public int RowIndex {get;}
Managed Extensions for C++
public: __property int get_RowIndex();
C++/CLI
public:
property int RowIndex {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRowDividerDoubleClickEventArgs Class
DataGridViewRowDividerDoubleClickEventArgs Members


DataGridViewRowErrorTextNeededEventArgs Class

[image]
Gizmox.WebGUI.Forms
DataGridViewRowErrorTextNeededEventArgs Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewRowErrorTextNeededEventArgs Class

Provides data for the RowErrorTextNeeded event of a DataGridView control.

Syntax

Visual Basic (Declaration)
Public Class DataGridViewRowErrorTextNeededEventArgs
   Inherits EventArgs
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRowErrorTextNeededEventArgs
C#
public class DataGridViewRowErrorTextNeededEventArgs : EventArgs
Managed Extensions for C++
public __gc class DataGridViewRowErrorTextNeededEventArgs : public EventArgs
C++/CLI
public ref class DataGridViewRowErrorTextNeededEventArgs : public EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gizmox.WebGUI.Forms.DataGridViewRowErrorTextNeededEventArgs

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

DataGridViewRowErrorTextNeededEventArgs Members
Gizmox.WebGUI.Forms Namespace


DataGridViewRowErrorTextNeededEventArgs Class Members

[image]
Gizmox.WebGUI.Forms
DataGridViewRowErrorTextNeededEventArgs Class Members
See Also Properties Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewRowErrorTextNeededEventArgs Class

The following tables list the members exposed by DataGridViewRowErrorTextNeededEventArgs.

Public Properties

 | Name | Description
Public Property | ErrorText | Gets or sets the error text for the row.
Public Property | RowIndex | Gets the row that raised the RowErrorTextNeeded event.
Top

See Also

Reference

DataGridViewRowErrorTextNeededEventArgs Class
Gizmox.WebGUI.Forms Namespace


DataGridViewRowErrorTextNeededEventArgs Class Properties

[image]
Gizmox.WebGUI.Forms
DataGridViewRowErrorTextNeededEventArgs Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewRowErrorTextNeededEventArgs Class

For a list of all members of this type, see DataGridViewRowErrorTextNeededEventArgs members.

Public Properties

 | Name | Description
Public Property | ErrorText | Gets or sets the error text for the row.
Public Property | RowIndex | Gets the row that raised the RowErrorTextNeeded event.
Top

See Also

Reference

DataGridViewRowErrorTextNeededEventArgs Class
Gizmox.WebGUI.Forms Namespace


ErrorText Property

[image]
Gizmox.WebGUI.Forms
ErrorText Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRowErrorTextNeededEventArgs Class : ErrorText Property

Gets or sets the error text for the row.

Syntax

Visual Basic (Declaration)
Public Property ErrorText As String
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRowErrorTextNeededEventArgs
Dim value As String

instance.ErrorText = value

value = instance.ErrorText
C#
public string ErrorText {get; set;}
Managed Extensions for C++
public: __property string* get_ErrorText();
public: __property void set_ErrorText(
   string* value
);
C++/CLI
public:
property String^ ErrorText {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRowErrorTextNeededEventArgs Class
DataGridViewRowErrorTextNeededEventArgs Members


RowIndex Property

[image]
Gizmox.WebGUI.Forms
RowIndex Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRowErrorTextNeededEventArgs Class : RowIndex Property

Gets the row that raised the RowErrorTextNeeded event.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RowIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRowErrorTextNeededEventArgs
Dim value As Integer

value = instance.RowIndex
C#
public int RowIndex {get;}
Managed Extensions for C++
public: __property int get_RowIndex();
C++/CLI
public:
property int RowIndex {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRowErrorTextNeededEventArgs Class
DataGridViewRowErrorTextNeededEventArgs Members


DataGridViewRowEventArgs Class

[image]
Gizmox.WebGUI.Forms
DataGridViewRowEventArgs Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewRowEventArgs Class

Provides data for row-related DataGridView events.

Object Model

Syntax

Visual Basic (Declaration)
Public Class DataGridViewRowEventArgs
   Inherits EventArgs
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRowEventArgs
C#
public class DataGridViewRowEventArgs : EventArgs
Managed Extensions for C++
public __gc class DataGridViewRowEventArgs : public EventArgs
C++/CLI
public ref class DataGridViewRowEventArgs : public EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gizmox.WebGUI.Forms.DataGridViewRowEventArgs

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

DataGridViewRowEventArgs Members
Gizmox.WebGUI.Forms Namespace


DataGridViewRowEventArgs Class Members

[image]
Gizmox.WebGUI.Forms
DataGridViewRowEventArgs Class Members
See Also Properties Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewRowEventArgs Class

The following tables list the members exposed by DataGridViewRowEventArgs.

Public Constructors

 | Name | Description
Public Constructor | DataGridViewRowEventArgs Constructor | Initializes a new instance of the DataGridViewRowEventArgs class.
Top

Public Properties

 | Name | Description
Public Property | Row | Gets the DataGridViewRow associated with the event.
Top

See Also

Reference

DataGridViewRowEventArgs Class
Gizmox.WebGUI.Forms Namespace


DataGridViewRowEventArgs Constructor

[image]
Gizmox.WebGUI.Forms
DataGridViewRowEventArgs Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRowEventArgs Class : DataGridViewRowEventArgs Constructor

dataGridViewRow
The DataGridViewRow that the event occurred for.
Initializes a new instance of the DataGridViewRowEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal dataGridViewRow As DataGridViewRow _
)
Visual Basic (Usage) Copy Code
Dim dataGridViewRow As DataGridViewRow

Dim instance As DataGridViewRowEventArgs(dataGridViewRow)
C#
public DataGridViewRowEventArgs(
   DataGridViewRow dataGridViewRow
)
Managed Extensions for C++
public: DataGridViewRowEventArgs(
   DataGridViewRow* dataGridViewRow
)
C++/CLI
public:
DataGridViewRowEventArgs(
   DataGridViewRow^ dataGridViewRow
)

Parameters

dataGridViewRow
The DataGridViewRow that the event occurred for.

Exceptions

Exception | Description
ArgumentNullException | dataGridViewRow is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRowEventArgs Class
DataGridViewRowEventArgs Members


DataGridViewRowEventArgs Class Properties

[image]
Gizmox.WebGUI.Forms
DataGridViewRowEventArgs Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewRowEventArgs Class

For a list of all members of this type, see DataGridViewRowEventArgs members.

Public Properties

 | Name | Description
Public Property | Row | Gets the DataGridViewRow associated with the event.
Top

See Also

Reference

DataGridViewRowEventArgs Class
Gizmox.WebGUI.Forms Namespace


Row Property

[image]
Gizmox.WebGUI.Forms
Row Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRowEventArgs Class : Row Property

Gets the DataGridViewRow associated with the event.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Row As DataGridViewRow
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRowEventArgs
Dim value As DataGridViewRow

value = instance.Row
C#
public DataGridViewRow Row {get;}
Managed Extensions for C++
public: __property DataGridViewRow* get_Row();
C++/CLI
public:
property DataGridViewRow^ Row {
   DataGridViewRow^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRowEventArgs Class
DataGridViewRowEventArgs Members


DataGridViewRowHeaderCell Class

[image]
Gizmox.WebGUI.Forms
DataGridViewRowHeaderCell Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewRowHeaderCell Class

Represents a row header of a DataGridView control.

Object Model

Syntax

Visual Basic (Declaration)
Public Class DataGridViewRowHeaderCell
   Inherits DataGridViewHeaderCell
   Implements IRenderableComponentMember
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRowHeaderCell
C#
public class DataGridViewRowHeaderCell : DataGridViewHeaderCell, IRenderableComponentMember
Managed Extensions for C++
public __gc class DataGridViewRowHeaderCell : public DataGridViewHeaderCell, IRenderableComponentMember
C++/CLI
public ref class DataGridViewRowHeaderCell : public DataGridViewHeaderCell, IRenderableComponentMember

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.DataGridViewElement
Gizmox.WebGUI.Forms.DataGridViewCell
Gizmox.WebGUI.Forms.DataGridViewHeaderCell
Gizmox.WebGUI.Forms.DataGridViewRowHeaderCell

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

DataGridViewRowHeaderCell Members
Gizmox.WebGUI.Forms Namespace


DataGridViewRowHeaderCell Class Members

[image]
Gizmox.WebGUI.Forms
DataGridViewRowHeaderCell Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewRowHeaderCell Class

The following tables list the members exposed by DataGridViewRowHeaderCell.

Public Constructors

 | Name | Description
Public Constructor | DataGridViewRowHeaderCell Constructor | Initializes a new instance of the DataGridViewRowHeaderCell class.
Top

Public Properties

 | Name | Description
Public Property | ColumnIndex | Gets the column index for this cell. (Inherited from DataGridViewCell)
Public Property | ContentBounds | (Inherited from DataGridViewCell)
Public Property | DataGridView | Gets the DataGridView control associated with this element. (Inherited from DataGridViewElement)
Public Property | DefaultNewRowValue | Gets the default value for a cell in the row for new records. (Inherited from DataGridViewCell)
Public Property | Displayed | (Inherited from DataGridViewHeaderCell)
Public Property | EditedFormattedValue | Gets the current, formatted value of the cell, regardless of whether the cell is in edit mode and the value has not been committed. (Inherited from DataGridViewCell)
Public Property | EditType | Gets the type of the cell's hosted editing control. (Inherited from DataGridViewCell)
Public Property | ErrorIconBounds | (Inherited from DataGridViewCell)
Public Property | ErrorText | Gets or sets the text describing an error condition associated with the cell. (Inherited from DataGridViewCell)
Public Property | FormattedValue | Gets the value of the cell as formatted for display. (Inherited from DataGridViewCell)
Public Property | FormattedValueType | Gets the type of the formatted value of the cell. (Inherited from DataGridViewHeaderCell)
Public Property | Frozen | Gets a value indicating whether the cell is frozen. (Inherited from DataGridViewHeaderCell)
Public Property | HasStyle | Gets a value indicating whether the DataGridViewCell.Style property has been set. (Inherited from DataGridViewCell)
Public Property | InheritedState | Gets the current state of the cell as inherited from the state of its row and column. (Inherited from DataGridViewCell)
Public Property | InheritedStyle | Gets the style currently applied to the cell. (Inherited from DataGridViewCell)
Public Property | IsInEditMode | Gets a value indicating whether this cell is currently being edited. (Inherited from DataGridViewCell)
Public Property | OwningColumn | Gets the column that contains this cell. (Inherited from DataGridViewCell)
Public Property | OwningRow | Gets the row that contains this cell. (Inherited from DataGridViewCell)
Public Property | PreferredSize | Gets the size, in pixels, of a rectangular area into which the cell can fit. (Inherited from DataGridViewCell)
Public Property | ReadOnly | Gets a value indicating whether the header cell is read-only. (Inherited from DataGridViewHeaderCell)
Public Property | Resizable | Gets a value indicating whether the cell is resizable. (Inherited from DataGridViewHeaderCell)
Public Property | RowIndex | Gets the index of the cell's parent row. (Inherited from DataGridViewCell)
Public Property | Selected | Gets or sets a value indicating whether the cell is selected. (Inherited from DataGridViewHeaderCell)
Public Property | Size | Gets the size of the cell. (Inherited from DataGridViewCell)
Public Property | State | Gets the user interface (UI) state of the element. (Inherited from DataGridViewElement)
Public Property | Style | Gets or sets the style for the cell. (Inherited from DataGridViewCell)
Public Property | Tag | Gets or sets the object that contains supplemental data about the cell. (Inherited from DataGridViewCell)
Public Property | ToolTipText | Gets or sets the ToolTip text associated with this cell. (Inherited from DataGridViewCell)
Public Property | Value | Gets or sets the value associated with this cell. (Inherited from DataGridViewCell)
Public Property | ValueType | Gets the type of the value stored in the cell. (Inherited from DataGridViewHeaderCell)
Public Property | Visible | Gets a value indicating whether or not the cell is visible. (Inherited from DataGridViewHeaderCell)
Top

Protected Properties

 | Name | Description
Protected Property | ButtonState | Gets the buttonlike visual state of the header cell. (Inherited from DataGridViewHeaderCell)
Protected Property | MemberID | (Inherited from DataGridViewCell)
Protected Property | TagName | (Inherited from DataGridViewElement)
Top

Public Methods

 | Name | Description
Public Method | AdjustCellBorderStyle | Modifies the input cell border style according to the specified criteria. (Inherited from DataGridViewCell)
Public Method | Clone | Overridden.
Public Method | DetachEditingControl | Removes the cell's editing control from the DataGridView. (Inherited from DataGridViewCell)
Public Method | Dispose | Overloaded. Releases all resources used by the DataGridViewCell. (Inherited from DataGridViewCell)
Public Method | GetContentBounds | Overloaded. (Inherited from DataGridViewCell)
Public Method | GetEditedFormattedValue | Returns the current, formatted value of the cell, regardless of whether the cell is in edit mode and the value has not been committed. (Inherited from DataGridViewCell)
Public Method | GetInheritedState | Returns a value indicating the current state of the cell as inherited from the state of its row or column. (Inherited from DataGridViewHeaderCell)
Public Method | GetInheritedStyle | Overridden.
Public Method | InitializeEditingControl | Initializes the control used to edit the cell. (Inherited from DataGridViewCell)
Public Method | KeyEntersEditMode | Determines if edit mode should be started based on the given key. (Inherited from DataGridViewCell)
Public Method | ParseFormattedValue | (Inherited from DataGridViewCell)
Public Method | PositionEditingControl | Sets the location and size of the editing control hosted by a cell in the DataGridView control. (Inherited from DataGridViewCell)
Public Method | PositionEditingPanel | (Inherited from DataGridViewCell)
Public Method | ToString | Overridden.
Public Method | Update | Overloaded. Full updates of this instance. (Inherited from DataGridViewElement)
Top

Protected Methods

 | Name | Description
Protected Method | BorderWidths | (Inherited from DataGridViewCell)
Protected Method | ClickUnsharesRow | Indicates whether the cell's row will be unshared when the cell is clicked. (Inherited from DataGridViewCell)
Protected Method | ContentClickUnsharesRow | Indicates whether the cell's row will be unshared when the cell's content is clicked. (Inherited from DataGridViewCell)
Protected Method | ContentDoubleClickUnsharesRow | Indicates whether the cell's row will be unshared when the cell's content is double-clicked. (Inherited from DataGridViewCell)
Protected Method | DoubleClickUnsharesRow | Indicates whether the cell's row will be unshared when the cell is double-clicked. (Inherited from DataGridViewCell)
Protected Method | EnterUnsharesRow | Indicates whether the parent row will be unshared when the focus moves to the cell. (Inherited from DataGridViewCell)
Protected Method | GetClipboardContent | Overridden. Retrieves the formatted value of the cell to copy to the Clipboard.
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from DataGridViewElement)
Protected Method | GetDefaultHorizontalAlignment | Gets the horizontal alignment. (Inherited from DataGridViewCell)
Protected Method | GetDefaultVerticalAlignment | Gets the vertical alignment. (Inherited from DataGridViewCell)
Protected Method | GetErrorIconBounds | (Inherited from DataGridViewCell)
Protected Method | GetErrorText | Returns a string that represents the error for the cell. (Inherited from DataGridViewCell)
Protected Method | GetFormattedValue | Gets the value of the cell as formatted for display. (Inherited from DataGridViewCell)
Protected Method | GetPreferredSize | Overloaded. Calculates the preferred size, in pixels, of the cell. (Inherited from DataGridViewCell)
Protected Method | GetSize | Gets the size of the cell. (Inherited from DataGridViewHeaderCell)
Protected Method | GetValue | Overridden. Gets the value of the cell.
Protected Method | IsDirty | Determines whether the specified component is dirty. (Inherited from DataGridViewElement)
Protected Method | IsDirtyAttributes | Overloaded. Determines whether the specified component is dirty. (Inherited from DataGridViewElement)
Protected Method | KeyDownUnsharesRow | Indicates whether the parent row is unshared if the user presses a key while the focus is on the cell. (Inherited from DataGridViewCell)
Protected Method | KeyPressUnsharesRow | Indicates whether a row will be unshared if a key is pressed while a cell in the row has focus. (Inherited from DataGridViewCell)
Protected Method | KeyUpUnsharesRow | Indicates whether the parent row is unshared when the user releases a key while the focus is on the cell. (Inherited from DataGridViewCell)
Protected Method | LeaveUnsharesRow | Indicates whether a row will be unshared when the focus leaves a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseClickUnsharesRow | Indicates whether a row will be unshared if the user clicks a mouse button while the pointer is on a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseDoubleClickUnsharesRow | Indicates whether a row will be unshared if the user double-clicks a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseDownUnsharesRow | Indicates whether a row will be unshared when the user holds down a mouse button while the pointer is on a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseEnterUnsharesRow | Indicates whether a row will be unshared when the mouse pointer moves over a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseLeaveUnsharesRow | Indicates whether a row will be unshared when the mouse pointer leaves the row. (Inherited from DataGridViewCell)
Protected Method | MouseMoveUnsharesRow | Indicates whether a row will be unshared when the mouse pointer moves over a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseUpUnsharesRow | Indicates whether a row will be unshared when the user releases a mouse button while the pointer is on a cell in the row. (Inherited from DataGridViewCell)
Protected Method | OnClick | Called when the cell is clicked. (Inherited from DataGridViewCell)
Protected Method | OnContentClick | Called when the cell's contents are clicked. (Inherited from DataGridViewCell)
Protected Method | OnContentDoubleClick | Called when the cell's contents are double-clicked. (Inherited from DataGridViewCell)
Protected Method | OnDataGridViewChanged | Called when the DataGridViewElement.DataGridView property of the cell changes. (Inherited from DataGridViewCell)
Protected Method | OnDoubleClick | Called when the cell is double-clicked. (Inherited from DataGridViewCell)
Protected Method | OnEnter | Called when the focus moves to a cell. (Inherited from DataGridViewCell)
Protected Method | OnKeyDown | Called when a character key is pressed while the focus is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnKeyPress | Called when a key is pressed while the focus is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnKeyUp | Called when a character key is released while the focus is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnLeave | Called when the focus moves from a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseClick | Called when the user clicks a mouse button while the pointer is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseDoubleClick | Called when the user double-clicks a mouse button while the pointer is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseDown | Called when the user holds down a mouse button while the pointer is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseEnter | Called when the mouse pointer moves over a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseLeave | Called when the mouse pointer leaves the cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseMove | Called when the mouse pointer moves within a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseUp | Called when the user releases a mouse button while the pointer is on a cell. (Inherited from DataGridViewCell)
Protected Method | Paint | (Inherited from DataGridViewCell)
Protected Method | PaintErrorIcon | (Inherited from DataGridViewCell)
Protected Method | ProcessGatewayRequest | (Inherited from DataGridViewCell)
Protected Method | RaiseCellClick | Raises the DataGridView.CellClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellContentClick | Raises the DataGridView.CellContentClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellContentDoubleClick | Raises the DataGridView.CellContentDoubleClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellValueChanged | Raises the CellValueChanged event. (Inherited from DataGridViewElement)
Protected Method | RaiseDataError | Raises the DataError event. (Inherited from DataGridViewElement)
Protected Method | RaiseMouseWheel | Raises the MouseWheel event. (Inherited from DataGridViewElement)
Protected Method | RenderAttributes | Renders a header- cell's attributes (Inherited from DataGridViewHeaderCell)
Protected Method | RenderBackColorAttribute | Renders the back-color attribute. (Inherited from DataGridViewHeaderCell)
Protected Method | RenderComponent | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from DataGridViewElement)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from DataGridViewElement)
Protected Method | RenderComponents | Renders the controls sub tree (Inherited from DataGridViewElement)
Protected Method | RenderForeColorAttribute | Renders the fore color attribute. (Inherited from DataGridViewHeaderCell)
Protected Method | RenderReadOnlyAttribute | Renders the read only attribute. (Inherited from DataGridViewHeaderCell)
Protected Method | RenderUpdatedAttributes | Renders the updated attributes (Inherited from DataGridViewElement)
Protected Method | RenderWrapModeAttribute | Renders the wrap mode attribute. (Inherited from DataGridViewHeaderCell)
Protected Method | SetValue | Overridden.
Protected Method | UpdateParams | Overloaded. Updates only the parameters of this instance. (Inherited from DataGridViewElement)
Top

See Also

Reference

DataGridViewRowHeaderCell Class
Gizmox.WebGUI.Forms Namespace


DataGridViewRowHeaderCell Constructor

[image]
Gizmox.WebGUI.Forms
DataGridViewRowHeaderCell Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRowHeaderCell Class : DataGridViewRowHeaderCell Constructor

Initializes a new instance of the DataGridViewRowHeaderCell class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRowHeaderCell()
C#
public DataGridViewRowHeaderCell()
Managed Extensions for C++
public: DataGridViewRowHeaderCell();
C++/CLI
public:
DataGridViewRowHeaderCell();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRowHeaderCell Class
DataGridViewRowHeaderCell Members


DataGridViewRowHeaderCell Class Methods

[image]
Gizmox.WebGUI.Forms
DataGridViewRowHeaderCell Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewRowHeaderCell Class

For a list of all members of this type, see DataGridViewRowHeaderCell members.

Public Methods

 | Name | Description
Public Method | AdjustCellBorderStyle | Modifies the input cell border style according to the specified criteria. (Inherited from DataGridViewCell)
Public Method | Clone | Overridden.
Public Method | DetachEditingControl | Removes the cell's editing control from the DataGridView. (Inherited from DataGridViewCell)
Public Method | Dispose | Overloaded. Releases all resources used by the DataGridViewCell. (Inherited from DataGridViewCell)
Public Method | GetContentBounds | Overloaded. (Inherited from DataGridViewCell)
Public Method | GetEditedFormattedValue | Returns the current, formatted value of the cell, regardless of whether the cell is in edit mode and the value has not been committed. (Inherited from DataGridViewCell)
Public Method | GetInheritedState | Returns a value indicating the current state of the cell as inherited from the state of its row or column. (Inherited from DataGridViewHeaderCell)
Public Method | GetInheritedStyle | Overridden.
Public Method | InitializeEditingControl | Initializes the control used to edit the cell. (Inherited from DataGridViewCell)
Public Method | KeyEntersEditMode | Determines if edit mode should be started based on the given key. (Inherited from DataGridViewCell)
Public Method | ParseFormattedValue | (Inherited from DataGridViewCell)
Public Method | PositionEditingControl | Sets the location and size of the editing control hosted by a cell in the DataGridView control. (Inherited from DataGridViewCell)
Public Method | PositionEditingPanel | (Inherited from DataGridViewCell)
Public Method | ToString | Overridden.
Public Method | Update | Overloaded. Full updates of this instance. (Inherited from DataGridViewElement)
Top

Protected Methods

 | Name | Description
Protected Method | BorderWidths | (Inherited from DataGridViewCell)
Protected Method | ClickUnsharesRow | Indicates whether the cell's row will be unshared when the cell is clicked. (Inherited from DataGridViewCell)
Protected Method | ContentClickUnsharesRow | Indicates whether the cell's row will be unshared when the cell's content is clicked. (Inherited from DataGridViewCell)
Protected Method | ContentDoubleClickUnsharesRow | Indicates whether the cell's row will be unshared when the cell's content is double-clicked. (Inherited from DataGridViewCell)
Protected Method | DoubleClickUnsharesRow | Indicates whether the cell's row will be unshared when the cell is double-clicked. (Inherited from DataGridViewCell)
Protected Method | EnterUnsharesRow | Indicates whether the parent row will be unshared when the focus moves to the cell. (Inherited from DataGridViewCell)
Protected Method | GetClipboardContent | Overridden. Retrieves the formatted value of the cell to copy to the Clipboard.
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from DataGridViewElement)
Protected Method | GetDefaultHorizontalAlignment | Gets the horizontal alignment. (Inherited from DataGridViewCell)
Protected Method | GetDefaultVerticalAlignment | Gets the vertical alignment. (Inherited from DataGridViewCell)
Protected Method | GetErrorIconBounds | (Inherited from DataGridViewCell)
Protected Method | GetErrorText | Returns a string that represents the error for the cell. (Inherited from DataGridViewCell)
Protected Method | GetFormattedValue | Gets the value of the cell as formatted for display. (Inherited from DataGridViewCell)
Protected Method | GetPreferredSize | Overloaded. Calculates the preferred size, in pixels, of the cell. (Inherited from DataGridViewCell)
Protected Method | GetSize | Gets the size of the cell. (Inherited from DataGridViewHeaderCell)
Protected Method | GetValue | Overridden. Gets the value of the cell.
Protected Method | IsDirty | Determines whether the specified component is dirty. (Inherited from DataGridViewElement)
Protected Method | IsDirtyAttributes | Overloaded. Determines whether the specified component is dirty. (Inherited from DataGridViewElement)
Protected Method | KeyDownUnsharesRow | Indicates whether the parent row is unshared if the user presses a key while the focus is on the cell. (Inherited from DataGridViewCell)
Protected Method | KeyPressUnsharesRow | Indicates whether a row will be unshared if a key is pressed while a cell in the row has focus. (Inherited from DataGridViewCell)
Protected Method | KeyUpUnsharesRow | Indicates whether the parent row is unshared when the user releases a key while the focus is on the cell. (Inherited from DataGridViewCell)
Protected Method | LeaveUnsharesRow | Indicates whether a row will be unshared when the focus leaves a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseClickUnsharesRow | Indicates whether a row will be unshared if the user clicks a mouse button while the pointer is on a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseDoubleClickUnsharesRow | Indicates whether a row will be unshared if the user double-clicks a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseDownUnsharesRow | Indicates whether a row will be unshared when the user holds down a mouse button while the pointer is on a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseEnterUnsharesRow | Indicates whether a row will be unshared when the mouse pointer moves over a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseLeaveUnsharesRow | Indicates whether a row will be unshared when the mouse pointer leaves the row. (Inherited from DataGridViewCell)
Protected Method | MouseMoveUnsharesRow | Indicates whether a row will be unshared when the mouse pointer moves over a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseUpUnsharesRow | Indicates whether a row will be unshared when the user releases a mouse button while the pointer is on a cell in the row. (Inherited from DataGridViewCell)
Protected Method | OnClick | Called when the cell is clicked. (Inherited from DataGridViewCell)
Protected Method | OnContentClick | Called when the cell's contents are clicked. (Inherited from DataGridViewCell)
Protected Method | OnContentDoubleClick | Called when the cell's contents are double-clicked. (Inherited from DataGridViewCell)
Protected Method | OnDataGridViewChanged | Called when the DataGridViewElement.DataGridView property of the cell changes. (Inherited from DataGridViewCell)
Protected Method | OnDoubleClick | Called when the cell is double-clicked. (Inherited from DataGridViewCell)
Protected Method | OnEnter | Called when the focus moves to a cell. (Inherited from DataGridViewCell)
Protected Method | OnKeyDown | Called when a character key is pressed while the focus is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnKeyPress | Called when a key is pressed while the focus is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnKeyUp | Called when a character key is released while the focus is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnLeave | Called when the focus moves from a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseClick | Called when the user clicks a mouse button while the pointer is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseDoubleClick | Called when the user double-clicks a mouse button while the pointer is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseDown | Called when the user holds down a mouse button while the pointer is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseEnter | Called when the mouse pointer moves over a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseLeave | Called when the mouse pointer leaves the cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseMove | Called when the mouse pointer moves within a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseUp | Called when the user releases a mouse button while the pointer is on a cell. (Inherited from DataGridViewCell)
Protected Method | Paint | (Inherited from DataGridViewCell)
Protected Method | PaintErrorIcon | (Inherited from DataGridViewCell)
Protected Method | ProcessGatewayRequest | (Inherited from DataGridViewCell)
Protected Method | RaiseCellClick | Raises the DataGridView.CellClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellContentClick | Raises the DataGridView.CellContentClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellContentDoubleClick | Raises the DataGridView.CellContentDoubleClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellValueChanged | Raises the CellValueChanged event. (Inherited from DataGridViewElement)
Protected Method | RaiseDataError | Raises the DataError event. (Inherited from DataGridViewElement)
Protected Method | RaiseMouseWheel | Raises the MouseWheel event. (Inherited from DataGridViewElement)
Protected Method | RenderAttributes | Renders a header- cell's attributes (Inherited from DataGridViewHeaderCell)
Protected Method | RenderBackColorAttribute | Renders the back-color attribute. (Inherited from DataGridViewHeaderCell)
Protected Method | RenderComponent | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from DataGridViewElement)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from DataGridViewElement)
Protected Method | RenderComponents | Renders the controls sub tree (Inherited from DataGridViewElement)
Protected Method | RenderForeColorAttribute | Renders the fore color attribute. (Inherited from DataGridViewHeaderCell)
Protected Method | RenderReadOnlyAttribute | Renders the read only attribute. (Inherited from DataGridViewHeaderCell)
Protected Method | RenderUpdatedAttributes | Renders the updated attributes (Inherited from DataGridViewElement)
Protected Method | RenderWrapModeAttribute | Renders the wrap mode attribute. (Inherited from DataGridViewHeaderCell)
Protected Method | SetValue | Overridden.
Protected Method | UpdateParams | Overloaded. Updates only the parameters of this instance. (Inherited from DataGridViewElement)
Top

See Also

Reference

DataGridViewRowHeaderCell Class
Gizmox.WebGUI.Forms Namespace


Clone Method

[image]
Gizmox.WebGUI.Forms
Clone Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRowHeaderCell Class : Clone Method

Syntax

Visual Basic (Declaration)
Public Overrides Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRowHeaderCell
Dim value As Object

value = instance.Clone()
C#
public override object Clone()
Managed Extensions for C++
public: Object* Clone(); override
C++/CLI
public:
Object^ Clone(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRowHeaderCell Class
DataGridViewRowHeaderCell Members


GetClipboardContent Method

[image]
Gizmox.WebGUI.Forms
GetClipboardContent Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRowHeaderCell Class : GetClipboardContent Method

rowIndex
The zero-based index of the row containing the cell.
firstCell
true to indicate that the cell is in the first column of the region defined by the selected cells; otherwise, false.
lastCell
true to indicate that the cell is the last column of the region defined by the selected cells; otherwise, false.
inFirstRow
true to indicate that the cell is in the first row of the region defined by the selected cells; otherwise, false.
inLastRow
true to indicate that the cell is in the last row of the region defined by the selected cells; otherwise, false.
format
The current format string of the cell.
Retrieves the formatted value of the cell to copy to the Clipboard.

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetClipboardContent( _
   ByVal rowIndex As Integer, _
   ByVal firstCell As Boolean, _
   ByVal lastCell As Boolean, _
   ByVal inFirstRow As Boolean, _
   ByVal inLastRow As Boolean, _
   ByVal format As String _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRowHeaderCell
Dim rowIndex As Integer
Dim firstCell As Boolean
Dim lastCell As Boolean
Dim inFirstRow As Boolean
Dim inLastRow As Boolean
Dim format As String
Dim value As Object

value = instance.GetClipboardContent(rowIndex, firstCell, lastCell, inFirstRow, inLastRow, format)
C#
protected override object GetClipboardContent(
   int rowIndex,
   bool firstCell,
   bool lastCell,
   bool inFirstRow,
   bool inLastRow,
   string format
)
Managed Extensions for C++
protected: Object* GetClipboardContent(
   int rowIndex,
   bool firstCell,
   bool lastCell,
   bool inFirstRow,
   bool inLastRow,
   string* format
) override
C++/CLI
protected:
Object^ GetClipboardContent(
   int rowIndex,
   bool firstCell,
   bool lastCell,
   bool inFirstRow,
   bool inLastRow,
   String^ format
) override

Parameters

rowIndex
The zero-based index of the row containing the cell.
firstCell
true to indicate that the cell is in the first column of the region defined by the selected cells; otherwise, false.
lastCell
true to indicate that the cell is the last column of the region defined by the selected cells; otherwise, false.
inFirstRow
true to indicate that the cell is in the first row of the region defined by the selected cells; otherwise, false.
inLastRow
true to indicate that the cell is in the last row of the region defined by the selected cells; otherwise, false.
format
The current format string of the cell.

Return Value

A Object that represents the value of the cell to copy to the Clipboard.

Exceptions

Exception | Description
ArgumentOutOfRangeException | rowIndex is less than zero or greater than or equal to the number of rows in the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRowHeaderCell Class
DataGridViewRowHeaderCell Members


GetInheritedStyle Method

[image]
Gizmox.WebGUI.Forms
GetInheritedStyle Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRowHeaderCell Class : GetInheritedStyle Method

inheritedCellStyle
rowIndex
includeColors

Syntax

Visual Basic (Declaration)
Public Overrides Function GetInheritedStyle( _
   ByVal inheritedCellStyle As DataGridViewCellStyle, _
   ByVal rowIndex As Integer, _
   ByVal includeColors As Boolean _
) As DataGridViewCellStyle
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRowHeaderCell
Dim inheritedCellStyle As DataGridViewCellStyle
Dim rowIndex As Integer
Dim includeColors As Boolean
Dim value As DataGridViewCellStyle

value = instance.GetInheritedStyle(inheritedCellStyle, rowIndex, includeColors)
C#
public override DataGridViewCellStyle GetInheritedStyle(
   DataGridViewCellStyle inheritedCellStyle,
   int rowIndex,
   bool includeColors
)
Managed Extensions for C++
public: DataGridViewCellStyle* GetInheritedStyle(
   DataGridViewCellStyle* inheritedCellStyle,
   int rowIndex,
   bool includeColors
) override
C++/CLI
public:
DataGridViewCellStyle^ GetInheritedStyle(
   DataGridViewCellStyle^ inheritedCellStyle,
   int rowIndex,
   bool includeColors
) override

Parameters

inheritedCellStyle
rowIndex
includeColors

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRowHeaderCell Class
DataGridViewRowHeaderCell Members


GetValue Method

[image]
Gizmox.WebGUI.Forms
GetValue Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRowHeaderCell Class : GetValue Method

rowIndex
The index of the cell's parent row.
Gets the value of the cell.

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetValue( _
   ByVal rowIndex As Integer _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRowHeaderCell
Dim rowIndex As Integer
Dim value As Object

value = instance.GetValue(rowIndex)
C#
protected override object GetValue(
   int rowIndex
)
Managed Extensions for C++
protected: Object* GetValue(
   int rowIndex
) override
C++/CLI
protected:
Object^ GetValue(
   int rowIndex
) override

Parameters

rowIndex
The index of the cell's parent row.

Return Value

The value contained in the DataGridViewRowHeaderCell.

Exceptions

Exception | Description
ArgumentOutOfRangeException | The value of the DataGridViewElement.DataGridView property of the cell is not null and rowIndex is less than -1 or greater than or equal to the number of rows in the parent DataGridView.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRowHeaderCell Class
DataGridViewRowHeaderCell Members


SetValue Method

[image]
Gizmox.WebGUI.Forms
SetValue Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRowHeaderCell Class : SetValue Method

rowIndex
value

Syntax

Visual Basic (Declaration)
Protected Overrides Function SetValue( _
   ByVal rowIndex As Integer, _
   ByVal value As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRowHeaderCell
Dim rowIndex As Integer
Dim value As Object
Dim value As Boolean

value = instance.SetValue(rowIndex, value)
C#
protected override bool SetValue(
   int rowIndex,
   object value
)
Managed Extensions for C++
protected: bool SetValue(
   int rowIndex,
   Object* value
) override
C++/CLI
protected:
bool SetValue(
   int rowIndex,
   Object^ value
) override

Parameters

rowIndex
value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRowHeaderCell Class
DataGridViewRowHeaderCell Members


ToString Method

[image]
Gizmox.WebGUI.Forms
ToString Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRowHeaderCell Class : ToString Method

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRowHeaderCell
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRowHeaderCell Class
DataGridViewRowHeaderCell Members


DataGridViewRowHeightInfoNeededEventArgs Class

[image]
Gizmox.WebGUI.Forms
DataGridViewRowHeightInfoNeededEventArgs Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewRowHeightInfoNeededEventArgs Class

Provides data for the RowHeightInfoNeeded event of a DataGridView.

Syntax

Visual Basic (Declaration)
Public Class DataGridViewRowHeightInfoNeededEventArgs
   Inherits EventArgs
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRowHeightInfoNeededEventArgs
C#
public class DataGridViewRowHeightInfoNeededEventArgs : EventArgs
Managed Extensions for C++
public __gc class DataGridViewRowHeightInfoNeededEventArgs : public EventArgs
C++/CLI
public ref class DataGridViewRowHeightInfoNeededEventArgs : public EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gizmox.WebGUI.Forms.DataGridViewRowHeightInfoNeededEventArgs

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

DataGridViewRowHeightInfoNeededEventArgs Members
Gizmox.WebGUI.Forms Namespace


DataGridViewRowHeightInfoNeededEventArgs Class Members

[image]
Gizmox.WebGUI.Forms
DataGridViewRowHeightInfoNeededEventArgs Class Members
See Also Properties Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewRowHeightInfoNeededEventArgs Class

The following tables list the members exposed by DataGridViewRowHeightInfoNeededEventArgs.

Public Properties

 | Name | Description
Public Property | Height | Gets or sets the height of the row the event occurred for.
Public Property | MinimumHeight | Gets or sets the minimum height of the row the event occurred for.
Public Property | RowIndex | Gets the index of the row associated with this DataGridViewRowHeightInfoNeededEventArgs.
Top

See Also

Reference

DataGridViewRowHeightInfoNeededEventArgs Class
Gizmox.WebGUI.Forms Namespace


DataGridViewRowHeightInfoNeededEventArgs Class Properties

[image]
Gizmox.WebGUI.Forms
DataGridViewRowHeightInfoNeededEventArgs Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewRowHeightInfoNeededEventArgs Class

For a list of all members of this type, see DataGridViewRowHeightInfoNeededEventArgs members.

Public Properties

 | Name | Description
Public Property | Height | Gets or sets the height of the row the event occurred for.
Public Property | MinimumHeight | Gets or sets the minimum height of the row the event occurred for.
Public Property | RowIndex | Gets the index of the row associated with this DataGridViewRowHeightInfoNeededEventArgs.
Top

See Also

Reference

DataGridViewRowHeightInfoNeededEventArgs Class
Gizmox.WebGUI.Forms Namespace


Height Property

[image]
Gizmox.WebGUI.Forms
Height Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRowHeightInfoNeededEventArgs Class : Height Property

Gets or sets the height of the row the event occurred for.

Syntax

Visual Basic (Declaration)
Public Property Height As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRowHeightInfoNeededEventArgs
Dim value As Integer

instance.Height = value

value = instance.Height
C#
public int Height {get; set;}
Managed Extensions for C++
public: __property int get_Height();
public: __property void set_Height(
   int value
);
C++/CLI
public:
property int Height {
   int get();
   void set (intvalue);
}

Exceptions

Exception | Description
ArgumentOutOfRangeException | The specified value when setting this property is greater than 65,536.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRowHeightInfoNeededEventArgs Class
DataGridViewRowHeightInfoNeededEventArgs Members


MinimumHeight Property

[image]
Gizmox.WebGUI.Forms
MinimumHeight Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRowHeightInfoNeededEventArgs Class : MinimumHeight Property

Gets or sets the minimum height of the row the event occurred for.

Syntax

Visual Basic (Declaration)
Public Property MinimumHeight As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRowHeightInfoNeededEventArgs
Dim value As Integer

instance.MinimumHeight = value

value = instance.MinimumHeight
C#
public int MinimumHeight {get; set;}
Managed Extensions for C++
public: __property int get_MinimumHeight();
public: __property void set_MinimumHeight(
   int value
);
C++/CLI
public:
property int MinimumHeight {
   int get();
   void set (intvalue);
}

Exceptions

Exception | Description
ArgumentOutOfRangeException | The specified value when setting this property is less than 2.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRowHeightInfoNeededEventArgs Class
DataGridViewRowHeightInfoNeededEventArgs Members


RowIndex Property

[image]
Gizmox.WebGUI.Forms
RowIndex Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRowHeightInfoNeededEventArgs Class : RowIndex Property

Gets the index of the row associated with this DataGridViewRowHeightInfoNeededEventArgs.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RowIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRowHeightInfoNeededEventArgs
Dim value As Integer

value = instance.RowIndex
C#
public int RowIndex {get;}
Managed Extensions for C++
public: __property int get_RowIndex();
C++/CLI
public:
property int RowIndex {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRowHeightInfoNeededEventArgs Class
DataGridViewRowHeightInfoNeededEventArgs Members


DataGridViewRowHeightInfoPushedEventArgs Class

[image]
Gizmox.WebGUI.Forms
DataGridViewRowHeightInfoPushedEventArgs Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewRowHeightInfoPushedEventArgs Class

Provides data for the RowHeightInfoPushed event of a DataGridView.

Syntax

Visual Basic (Declaration)
Public Class DataGridViewRowHeightInfoPushedEventArgs
   Inherits HandledEventArgs
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRowHeightInfoPushedEventArgs
C#
public class DataGridViewRowHeightInfoPushedEventArgs : HandledEventArgs
Managed Extensions for C++
public __gc class DataGridViewRowHeightInfoPushedEventArgs : public HandledEventArgs
C++/CLI
public ref class DataGridViewRowHeightInfoPushedEventArgs : public HandledEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
System.ComponentModel.HandledEventArgs
Gizmox.WebGUI.Forms.DataGridViewRowHeightInfoPushedEventArgs

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

DataGridViewRowHeightInfoPushedEventArgs Members
Gizmox.WebGUI.Forms Namespace


DataGridViewRowHeightInfoPushedEventArgs Class Members

[image]
Gizmox.WebGUI.Forms
DataGridViewRowHeightInfoPushedEventArgs Class Members
See Also Properties Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewRowHeightInfoPushedEventArgs Class

The following tables list the members exposed by DataGridViewRowHeightInfoPushedEventArgs.

Public Properties

 | Name | Description
Public Property | Handled | Gets or sets a value that indicates whether the event handler has completely handled the event or whether the system should continue its own processing. (Inherited from System.ComponentModel.HandledEventArgs)
Public Property | Height | Gets the height of the row the event occurred for.
Public Property | MinimumHeight | Gets the minimum height of the row the event occurred for.
Public Property | RowIndex | Gets the index of the row the event occurred for.
Top

See Also

Reference

DataGridViewRowHeightInfoPushedEventArgs Class
Gizmox.WebGUI.Forms Namespace


DataGridViewRowHeightInfoPushedEventArgs Class Properties

[image]
Gizmox.WebGUI.Forms
DataGridViewRowHeightInfoPushedEventArgs Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewRowHeightInfoPushedEventArgs Class

For a list of all members of this type, see DataGridViewRowHeightInfoPushedEventArgs members.

Public Properties

 | Name | Description
Public Property | Handled | Gets or sets a value that indicates whether the event handler has completely handled the event or whether the system should continue its own processing. (Inherited from System.ComponentModel.HandledEventArgs)
Public Property | Height | Gets the height of the row the event occurred for.
Public Property | MinimumHeight | Gets the minimum height of the row the event occurred for.
Public Property | RowIndex | Gets the index of the row the event occurred for.
Top

See Also

Reference

DataGridViewRowHeightInfoPushedEventArgs Class
Gizmox.WebGUI.Forms Namespace


Height Property

[image]
Gizmox.WebGUI.Forms
Height Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRowHeightInfoPushedEventArgs Class : Height Property

Gets the height of the row the event occurred for.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Height As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRowHeightInfoPushedEventArgs
Dim value As Integer

value = instance.Height
C#
public int Height {get;}
Managed Extensions for C++
public: __property int get_Height();
C++/CLI
public:
property int Height {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRowHeightInfoPushedEventArgs Class
DataGridViewRowHeightInfoPushedEventArgs Members


MinimumHeight Property

[image]
Gizmox.WebGUI.Forms
MinimumHeight Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRowHeightInfoPushedEventArgs Class : MinimumHeight Property

Gets the minimum height of the row the event occurred for.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MinimumHeight As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRowHeightInfoPushedEventArgs
Dim value As Integer

value = instance.MinimumHeight
C#
public int MinimumHeight {get;}
Managed Extensions for C++
public: __property int get_MinimumHeight();
C++/CLI
public:
property int MinimumHeight {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRowHeightInfoPushedEventArgs Class
DataGridViewRowHeightInfoPushedEventArgs Members


RowIndex Property

[image]
Gizmox.WebGUI.Forms
RowIndex Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRowHeightInfoPushedEventArgs Class : RowIndex Property

Gets the index of the row the event occurred for.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RowIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRowHeightInfoPushedEventArgs
Dim value As Integer

value = instance.RowIndex
C#
public int RowIndex {get;}
Managed Extensions for C++
public: __property int get_RowIndex();
C++/CLI
public:
property int RowIndex {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRowHeightInfoPushedEventArgs Class
DataGridViewRowHeightInfoPushedEventArgs Members


DataGridViewRowsAddedEventArgs Class

[image]
Gizmox.WebGUI.Forms
DataGridViewRowsAddedEventArgs Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewRowsAddedEventArgs Class

Provides data for the RowsAdded event.

Syntax

Visual Basic (Declaration)
Public Class DataGridViewRowsAddedEventArgs
   Inherits EventArgs
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRowsAddedEventArgs
C#
public class DataGridViewRowsAddedEventArgs : EventArgs
Managed Extensions for C++
public __gc class DataGridViewRowsAddedEventArgs : public EventArgs
C++/CLI
public ref class DataGridViewRowsAddedEventArgs : public EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gizmox.WebGUI.Forms.DataGridViewRowsAddedEventArgs

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

DataGridViewRowsAddedEventArgs Members
Gizmox.WebGUI.Forms Namespace


DataGridViewRowsAddedEventArgs Class Members

[image]
Gizmox.WebGUI.Forms
DataGridViewRowsAddedEventArgs Class Members
See Also Properties Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewRowsAddedEventArgs Class

The following tables list the members exposed by DataGridViewRowsAddedEventArgs.

Public Constructors

 | Name | Description
Public Constructor | DataGridViewRowsAddedEventArgs Constructor | Initializes a new instance of the DataGridViewRowsAddedEventArgs class.
Top

Public Properties

 | Name | Description
Public Property | RowCount | Gets the number of rows that have been added.
Public Property | RowIndex | Gets the index of the first added row.
Top

See Also

Reference

DataGridViewRowsAddedEventArgs Class
Gizmox.WebGUI.Forms Namespace


DataGridViewRowsAddedEventArgs Constructor

[image]
Gizmox.WebGUI.Forms
DataGridViewRowsAddedEventArgs Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRowsAddedEventArgs Class : DataGridViewRowsAddedEventArgs Constructor

rowIndex
The index of the first added row.
rowCount
The number of rows that have been added.
Initializes a new instance of the DataGridViewRowsAddedEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal rowIndex As Integer, _
   ByVal rowCount As Integer _
)
Visual Basic (Usage) Copy Code
Dim rowIndex As Integer
Dim rowCount As Integer

Dim instance As DataGridViewRowsAddedEventArgs(rowIndex, rowCount)
C#
public DataGridViewRowsAddedEventArgs(
   int rowIndex,
   int rowCount
)
Managed Extensions for C++
public: DataGridViewRowsAddedEventArgs(
   int rowIndex,
   int rowCount
)
C++/CLI
public:
DataGridViewRowsAddedEventArgs(
   int rowIndex,
   int rowCount
)

Parameters

rowIndex
The index of the first added row.
rowCount
The number of rows that have been added.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRowsAddedEventArgs Class
DataGridViewRowsAddedEventArgs Members


DataGridViewRowsAddedEventArgs Class Properties

[image]
Gizmox.WebGUI.Forms
DataGridViewRowsAddedEventArgs Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewRowsAddedEventArgs Class

For a list of all members of this type, see DataGridViewRowsAddedEventArgs members.

Public Properties

 | Name | Description
Public Property | RowCount | Gets the number of rows that have been added.
Public Property | RowIndex | Gets the index of the first added row.
Top

See Also

Reference

DataGridViewRowsAddedEventArgs Class
Gizmox.WebGUI.Forms Namespace


RowCount Property

[image]
Gizmox.WebGUI.Forms
RowCount Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRowsAddedEventArgs Class : RowCount Property

Gets the number of rows that have been added.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RowCount As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRowsAddedEventArgs
Dim value As Integer

value = instance.RowCount
C#
public int RowCount {get;}
Managed Extensions for C++
public: __property int get_RowCount();
C++/CLI
public:
property int RowCount {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRowsAddedEventArgs Class
DataGridViewRowsAddedEventArgs Members


RowIndex Property

[image]
Gizmox.WebGUI.Forms
RowIndex Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRowsAddedEventArgs Class : RowIndex Property

Gets the index of the first added row.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RowIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRowsAddedEventArgs
Dim value As Integer

value = instance.RowIndex
C#
public int RowIndex {get;}
Managed Extensions for C++
public: __property int get_RowIndex();
C++/CLI
public:
property int RowIndex {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRowsAddedEventArgs Class
DataGridViewRowsAddedEventArgs Members


DataGridViewRowsRemovedEventArgs Class

[image]
Gizmox.WebGUI.Forms
DataGridViewRowsRemovedEventArgs Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewRowsRemovedEventArgs Class

Provides data for the RowsRemoved event.

Syntax

Visual Basic (Declaration)
Public Class DataGridViewRowsRemovedEventArgs
   Inherits EventArgs
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRowsRemovedEventArgs
C#
public class DataGridViewRowsRemovedEventArgs : EventArgs
Managed Extensions for C++
public __gc class DataGridViewRowsRemovedEventArgs : public EventArgs
C++/CLI
public ref class DataGridViewRowsRemovedEventArgs : public EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gizmox.WebGUI.Forms.DataGridViewRowsRemovedEventArgs

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

DataGridViewRowsRemovedEventArgs Members
Gizmox.WebGUI.Forms Namespace


DataGridViewRowsRemovedEventArgs Class Members

[image]
Gizmox.WebGUI.Forms
DataGridViewRowsRemovedEventArgs Class Members
See Also Properties Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewRowsRemovedEventArgs Class

The following tables list the members exposed by DataGridViewRowsRemovedEventArgs.

Public Constructors

 | Name | Description
Public Constructor | DataGridViewRowsRemovedEventArgs Constructor | Initializes a new instance of the DataGridViewRowsRemovedEventArgs class.
Top

Public Properties

 | Name | Description
Public Property | RowCount | Gets the number of rows that were deleted.
Public Property | RowIndex | Gets the zero-based index of the row deleted, or the first deleted row if multiple rows were deleted.
Top

See Also

Reference

DataGridViewRowsRemovedEventArgs Class
Gizmox.WebGUI.Forms Namespace


DataGridViewRowsRemovedEventArgs Constructor

[image]
Gizmox.WebGUI.Forms
DataGridViewRowsRemovedEventArgs Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRowsRemovedEventArgs Class : DataGridViewRowsRemovedEventArgs Constructor

rowIndex
The zero-based index of the row that was deleted, or the first deleted row if multiple rows were deleted.
rowCount
The number of rows that were deleted.
Initializes a new instance of the DataGridViewRowsRemovedEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal rowIndex As Integer, _
   ByVal rowCount As Integer _
)
Visual Basic (Usage) Copy Code
Dim rowIndex As Integer
Dim rowCount As Integer

Dim instance As DataGridViewRowsRemovedEventArgs(rowIndex, rowCount)
C#
public DataGridViewRowsRemovedEventArgs(
   int rowIndex,
   int rowCount
)
Managed Extensions for C++
public: DataGridViewRowsRemovedEventArgs(
   int rowIndex,
   int rowCount
)
C++/CLI
public:
DataGridViewRowsRemovedEventArgs(
   int rowIndex,
   int rowCount
)

Parameters

rowIndex
The zero-based index of the row that was deleted, or the first deleted row if multiple rows were deleted.
rowCount
The number of rows that were deleted.

Exceptions

Exception | Description
ArgumentOutOfRangeException | rowIndex is less than 0.-or-rowCount is less than 1.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRowsRemovedEventArgs Class
DataGridViewRowsRemovedEventArgs Members


DataGridViewRowsRemovedEventArgs Class Properties

[image]
Gizmox.WebGUI.Forms
DataGridViewRowsRemovedEventArgs Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewRowsRemovedEventArgs Class

For a list of all members of this type, see DataGridViewRowsRemovedEventArgs members.

Public Properties

 | Name | Description
Public Property | RowCount | Gets the number of rows that were deleted.
Public Property | RowIndex | Gets the zero-based index of the row deleted, or the first deleted row if multiple rows were deleted.
Top

See Also

Reference

DataGridViewRowsRemovedEventArgs Class
Gizmox.WebGUI.Forms Namespace


RowCount Property

[image]
Gizmox.WebGUI.Forms
RowCount Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRowsRemovedEventArgs Class : RowCount Property

Gets the number of rows that were deleted.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RowCount As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRowsRemovedEventArgs
Dim value As Integer

value = instance.RowCount
C#
public int RowCount {get;}
Managed Extensions for C++
public: __property int get_RowCount();
C++/CLI
public:
property int RowCount {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRowsRemovedEventArgs Class
DataGridViewRowsRemovedEventArgs Members


RowIndex Property

[image]
Gizmox.WebGUI.Forms
RowIndex Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRowsRemovedEventArgs Class : RowIndex Property

Gets the zero-based index of the row deleted, or the first deleted row if multiple rows were deleted.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RowIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRowsRemovedEventArgs
Dim value As Integer

value = instance.RowIndex
C#
public int RowIndex {get;}
Managed Extensions for C++
public: __property int get_RowIndex();
C++/CLI
public:
property int RowIndex {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRowsRemovedEventArgs Class
DataGridViewRowsRemovedEventArgs Members


DataGridViewRowStateChangedEventArgs Class

[image]
Gizmox.WebGUI.Forms
DataGridViewRowStateChangedEventArgs Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewRowStateChangedEventArgs Class

Provides data for the RowStateChanged event of a DataGridView.

Object Model

Syntax

Visual Basic (Declaration)
Public Class DataGridViewRowStateChangedEventArgs
   Inherits EventArgs
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRowStateChangedEventArgs
C#
public class DataGridViewRowStateChangedEventArgs : EventArgs
Managed Extensions for C++
public __gc class DataGridViewRowStateChangedEventArgs : public EventArgs
C++/CLI
public ref class DataGridViewRowStateChangedEventArgs : public EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gizmox.WebGUI.Forms.DataGridViewRowStateChangedEventArgs

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

DataGridViewRowStateChangedEventArgs Members
Gizmox.WebGUI.Forms Namespace


DataGridViewRowStateChangedEventArgs Class Members

[image]
Gizmox.WebGUI.Forms
DataGridViewRowStateChangedEventArgs Class Members
See Also Properties Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewRowStateChangedEventArgs Class

The following tables list the members exposed by DataGridViewRowStateChangedEventArgs.

Public Constructors

 | Name | Description
Public Constructor | DataGridViewRowStateChangedEventArgs Constructor | Initializes a new instance of the DataGridViewRowStateChangedEventArgs class.
Top

Public Properties

 | Name | Description
Public Property | Row | Gets the DataGridViewRow that has a changed state.
Public Property | StateChanged | Gets the state that has changed on the row.
Top

See Also

Reference

DataGridViewRowStateChangedEventArgs Class
Gizmox.WebGUI.Forms Namespace


DataGridViewRowStateChangedEventArgs Constructor

[image]
Gizmox.WebGUI.Forms
DataGridViewRowStateChangedEventArgs Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRowStateChangedEventArgs Class : DataGridViewRowStateChangedEventArgs Constructor

dataGridViewRow
The DataGridViewRow that has a changed state.
stateChanged
One of the DataGridViewElementStates values indicating the state that has changed on the row.
Initializes a new instance of the DataGridViewRowStateChangedEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal dataGridViewRow As DataGridViewRow, _
   ByVal stateChanged As DataGridViewElementStates _
)
Visual Basic (Usage) Copy Code
Dim dataGridViewRow As DataGridViewRow
Dim stateChanged As DataGridViewElementStates

Dim instance As DataGridViewRowStateChangedEventArgs(dataGridViewRow, stateChanged)
C#
public DataGridViewRowStateChangedEventArgs(
   DataGridViewRow dataGridViewRow,
   DataGridViewElementStates stateChanged
)
Managed Extensions for C++
public: DataGridViewRowStateChangedEventArgs(
   DataGridViewRow* dataGridViewRow,
   DataGridViewElementStates stateChanged
)
C++/CLI
public:
DataGridViewRowStateChangedEventArgs(
   DataGridViewRow^ dataGridViewRow,
   DataGridViewElementStates stateChanged
)

Parameters

dataGridViewRow
The DataGridViewRow that has a changed state.
stateChanged
One of the DataGridViewElementStates values indicating the state that has changed on the row.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRowStateChangedEventArgs Class
DataGridViewRowStateChangedEventArgs Members


DataGridViewRowStateChangedEventArgs Class Properties

[image]
Gizmox.WebGUI.Forms
DataGridViewRowStateChangedEventArgs Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewRowStateChangedEventArgs Class

For a list of all members of this type, see DataGridViewRowStateChangedEventArgs members.

Public Properties

 | Name | Description
Public Property | Row | Gets the DataGridViewRow that has a changed state.
Public Property | StateChanged | Gets the state that has changed on the row.
Top

See Also

Reference

DataGridViewRowStateChangedEventArgs Class
Gizmox.WebGUI.Forms Namespace


Row Property

[image]
Gizmox.WebGUI.Forms
Row Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRowStateChangedEventArgs Class : Row Property

Gets the DataGridViewRow that has a changed state.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Row As DataGridViewRow
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRowStateChangedEventArgs
Dim value As DataGridViewRow

value = instance.Row
C#
public DataGridViewRow Row {get;}
Managed Extensions for C++
public: __property DataGridViewRow* get_Row();
C++/CLI
public:
property DataGridViewRow^ Row {
   DataGridViewRow^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRowStateChangedEventArgs Class
DataGridViewRowStateChangedEventArgs Members


StateChanged Property

[image]
Gizmox.WebGUI.Forms
StateChanged Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewRowStateChangedEventArgs Class : StateChanged Property

Gets the state that has changed on the row.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property StateChanged As DataGridViewElementStates
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRowStateChangedEventArgs
Dim value As DataGridViewElementStates

value = instance.StateChanged
C#
public DataGridViewElementStates StateChanged {get;}
Managed Extensions for C++
public: __property DataGridViewElementStates get_StateChanged();
C++/CLI
public:
property DataGridViewElementStates StateChanged {
   DataGridViewElementStates get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewRowStateChangedEventArgs Class
DataGridViewRowStateChangedEventArgs Members


DataGridViewSelectedCellCollection Class

[image]
Gizmox.WebGUI.Forms
DataGridViewSelectedCellCollection Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewSelectedCellCollection Class

Represents a collection of cells that are selected in a DataGridView.

Object Model

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
<ListBindableAttribute(False)>
Public Class DataGridViewSelectedCellCollection
   Inherits BaseCollection
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewSelectedCellCollection
C#
[DefaultMemberAttribute("Item")]
[ListBindableAttribute(false)]
public class DataGridViewSelectedCellCollection : BaseCollection
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
[ListBindableAttribute(false)]
public __gc class DataGridViewSelectedCellCollection : public BaseCollection
C++/CLI
[DefaultMemberAttribute("Item")]
[ListBindableAttribute(false)]
public ref class DataGridViewSelectedCellCollection : public BaseCollection

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.BaseCollection
Gizmox.WebGUI.Forms.DataGridViewSelectedCellCollection

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

DataGridViewSelectedCellCollection Members
Gizmox.WebGUI.Forms Namespace


DataGridViewSelectedCellCollection Class Members

[image]
Gizmox.WebGUI.Forms
DataGridViewSelectedCellCollection Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewSelectedCellCollection Class

The following tables list the members exposed by DataGridViewSelectedCellCollection.

Public Properties

 | Name | Description
Public Property | Count | Gets the total number of elements in the collection. (Inherited from BaseCollection)
Public Property | IsReadOnly | Gets a value indicating whether the collection is read-only. (Inherited from BaseCollection)
Public Property | IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized. (Inherited from BaseCollection)
Public Property | Item | Gets the cell at the specified index.
Public Property | SyncRoot | Gets an object that can be used to synchronize access to the BaseCollection. (Inherited from BaseCollection)
Top

Protected Properties

 | Name | Description
Protected Property | List | Overridden. Gets a list of elements in the collection.
Top

Public Methods

 | Name | Description
Public Method | Contains | Determines whether the specified cell is contained in the collection.
Public Method | CopyTo | Overloaded. Copies the elements of the collection to the specified DataGridViewCell array, starting at the specified index.
Public Method | GetEnumerator | Gets the object that enables iterating through the members of the collection. (Inherited from BaseCollection)
Top

See Also

Reference

DataGridViewSelectedCellCollection Class
Gizmox.WebGUI.Forms Namespace


DataGridViewSelectedCellCollection Class Methods

[image]
Gizmox.WebGUI.Forms
DataGridViewSelectedCellCollection Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewSelectedCellCollection Class

For a list of all members of this type, see DataGridViewSelectedCellCollection members.

Public Methods

 | Name | Description
Public Method | Contains | Determines whether the specified cell is contained in the collection.
Public Method | CopyTo | Overloaded. Copies the elements of the collection to the specified DataGridViewCell array, starting at the specified index.
Public Method | GetEnumerator | Gets the object that enables iterating through the members of the collection. (Inherited from BaseCollection)
Top

See Also

Reference

DataGridViewSelectedCellCollection Class
Gizmox.WebGUI.Forms Namespace


Contains Method

[image]
Gizmox.WebGUI.Forms
Contains Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewSelectedCellCollection Class : Contains Method

dataGridViewCell
The DataGridViewCell to locate in the DataGridViewSelectedCellCollection.
Determines whether the specified cell is contained in the collection.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal dataGridViewCell As DataGridViewCell _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewSelectedCellCollection
Dim dataGridViewCell As DataGridViewCell
Dim value As Boolean

value = instance.Contains(dataGridViewCell)
C#
public bool Contains(
   DataGridViewCell dataGridViewCell
)
Managed Extensions for C++
public: bool Contains(
   DataGridViewCell* dataGridViewCell
)
C++/CLI
public:
bool Contains(
   DataGridViewCell^ dataGridViewCell
)

Parameters

dataGridViewCell
The DataGridViewCell to locate in the DataGridViewSelectedCellCollection.

Return Value

true if dataGridViewCell is in the DataGridViewSelectedCellCollection; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewSelectedCellCollection Class
DataGridViewSelectedCellCollection Members


CopyTo Method

[image]
Gizmox.WebGUI.Forms
CopyTo Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewSelectedCellCollection Class : CopyTo Method

Copies the elements of the collection to the specified DataGridViewCell array, starting at the specified index.

Overload List

Overload | Description
CopyTo(DataGridViewCell[],Int32) | Copies the elements of the collection to the specified DataGridViewCell array, starting at the specified index.
CopyTo(Array,Int32) | Copies all the elements of the current one-dimensional Array to the specified one-dimensional Array starting at the specified destination Array index. (Inherited from BaseCollection)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewSelectedCellCollection Class
DataGridViewSelectedCellCollection Members


CopyTo(DataGridViewCell[],Int32) Method

[image]
Gizmox.WebGUI.Forms
CopyTo(DataGridViewCell[],Int32) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewSelectedCellCollection Class > CopyTo Method : CopyTo(DataGridViewCell[],Int32) Method

array
The one-dimensional array of type DataGridViewCell that is the destination of the elements copied from the collection. The array must have zero-based indexing.
index
The zero-based index in array at which copying begins.
Copies the elements of the collection to the specified DataGridViewCell array, starting at the specified index.

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal array() As DataGridViewCell, _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewSelectedCellCollection
Dim array() As DataGridViewCell
Dim index As Integer

instance.CopyTo(array, index)
C#
public void CopyTo(
   DataGridViewCell[] array,
   int index
)
Managed Extensions for C++
public: void CopyTo(
   DataGridViewCell*[]* array,
   int index
)
C++/CLI
public:
void CopyTo(
   array<DataGridViewCell^>^ array,
   int index
)

Parameters

array
The one-dimensional array of type DataGridViewCell that is the destination of the elements copied from the collection. The array must have zero-based indexing.
index
The zero-based index in array at which copying begins.

Exceptions

Exception | Description
ArgumentOutOfRangeException | index is less than zero.
ArgumentException | array is multidimensional.-or-index is equal to or greater than the length of array.-or-The number of elements in the DataGridViewCellCollection is greater than the available space from index to the end of array.
InvalidCastException | The DataGridViewCellCollection cannot be cast automatically to the type of array.
ArgumentNullException | array is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewSelectedCellCollection Class
DataGridViewSelectedCellCollection Members
Overload List


DataGridViewSelectedCellCollection Class Properties

[image]
Gizmox.WebGUI.Forms
DataGridViewSelectedCellCollection Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewSelectedCellCollection Class

For a list of all members of this type, see DataGridViewSelectedCellCollection members.

Public Properties

 | Name | Description
Public Property | Count | Gets the total number of elements in the collection. (Inherited from BaseCollection)
Public Property | IsReadOnly | Gets a value indicating whether the collection is read-only. (Inherited from BaseCollection)
Public Property | IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized. (Inherited from BaseCollection)
Public Property | Item | Gets the cell at the specified index.
Public Property | SyncRoot | Gets an object that can be used to synchronize access to the BaseCollection. (Inherited from BaseCollection)
Top

Protected Properties

 | Name | Description
Protected Property | List | Overridden. Gets a list of elements in the collection.
Top

See Also

Reference

DataGridViewSelectedCellCollection Class
Gizmox.WebGUI.Forms Namespace


Item Property

[image]
Gizmox.WebGUI.Forms
Item Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewSelectedCellCollection Class : Item Property

index
The index of the DataGridViewCell to get from the DataGridViewSelectedCellCollection.
Gets the cell at the specified index.

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal index As Integer _
) As DataGridViewCell
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewSelectedCellCollection
Dim index As Integer
Dim value As DataGridViewCell

value = instance.Item(index)
C#
public DataGridViewCell this[
   int index
]; {get;}
Managed Extensions for C++
public: __property DataGridViewCell* get_Item(
   int index
);
C++/CLI
public:
property DataGridViewCell^ default [int] {
   DataGridViewCell^ get(intindex);
}

Parameters

index
The index of the DataGridViewCell to get from the DataGridViewSelectedCellCollection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewSelectedCellCollection Class
DataGridViewSelectedCellCollection Members


List Property

[image]
Gizmox.WebGUI.Forms
List Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewSelectedCellCollection Class : List Property

Gets a list of elements in the collection.

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property List As ArrayList
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewSelectedCellCollection
Dim value As ArrayList

value = instance.List
C#
protected override ArrayList List {get;}
Managed Extensions for C++
protected: __property ArrayList* get_List() override;
C++/CLI
protected:
property ArrayList^ List {
   ArrayList^ get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewSelectedCellCollection Class
DataGridViewSelectedCellCollection Members


DataGridViewSelectedColumnCollection Class

[image]
Gizmox.WebGUI.Forms
DataGridViewSelectedColumnCollection Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewSelectedColumnCollection Class

Represents a collection of DataGridViewColumn objects that are selected in a DataGridView.

Object Model

Syntax

Visual Basic (Declaration)
<ListBindableAttribute(False)>
<DefaultMemberAttribute("Item")>
Public Class DataGridViewSelectedColumnCollection
   Inherits BaseCollection
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewSelectedColumnCollection
C#
[ListBindableAttribute(false)]
[DefaultMemberAttribute("Item")]
public class DataGridViewSelectedColumnCollection : BaseCollection
Managed Extensions for C++
[ListBindableAttribute(false)]
[DefaultMemberAttribute("Item")]
public __gc class DataGridViewSelectedColumnCollection : public BaseCollection
C++/CLI
[ListBindableAttribute(false)]
[DefaultMemberAttribute("Item")]
public ref class DataGridViewSelectedColumnCollection : public BaseCollection

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.BaseCollection
Gizmox.WebGUI.Forms.DataGridViewSelectedColumnCollection

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

DataGridViewSelectedColumnCollection Members
Gizmox.WebGUI.Forms Namespace


DataGridViewSelectedColumnCollection Class Members

[image]
Gizmox.WebGUI.Forms
DataGridViewSelectedColumnCollection Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewSelectedColumnCollection Class

The following tables list the members exposed by DataGridViewSelectedColumnCollection.

Public Properties

 | Name | Description
Public Property | Count | Gets the total number of elements in the collection. (Inherited from BaseCollection)
Public Property | IsReadOnly | Gets a value indicating whether the collection is read-only. (Inherited from BaseCollection)
Public Property | IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized. (Inherited from BaseCollection)
Public Property | Item | Gets the column at the specified index.
Public Property | SyncRoot | Gets an object that can be used to synchronize access to the BaseCollection. (Inherited from BaseCollection)
Top

Protected Properties

 | Name | Description
Protected Property | List | Overridden.
Top

Public Methods

 | Name | Description
Public Method | Contains | Determines whether the specified column is contained in the collection.
Public Method | CopyTo | Overloaded. Copies the elements of the collection to the specified array, starting at the specified index.
Public Method | GetEnumerator | Gets the object that enables iterating through the members of the collection. (Inherited from BaseCollection)
Top

See Also

Reference

DataGridViewSelectedColumnCollection Class
Gizmox.WebGUI.Forms Namespace


DataGridViewSelectedColumnCollection Class Methods

[image]
Gizmox.WebGUI.Forms
DataGridViewSelectedColumnCollection Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewSelectedColumnCollection Class

For a list of all members of this type, see DataGridViewSelectedColumnCollection members.

Public Methods

 | Name | Description
Public Method | Contains | Determines whether the specified column is contained in the collection.
Public Method | CopyTo | Overloaded. Copies the elements of the collection to the specified array, starting at the specified index.
Public Method | GetEnumerator | Gets the object that enables iterating through the members of the collection. (Inherited from BaseCollection)
Top

See Also

Reference

DataGridViewSelectedColumnCollection Class
Gizmox.WebGUI.Forms Namespace


Contains Method

[image]
Gizmox.WebGUI.Forms
Contains Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewSelectedColumnCollection Class : Contains Method

dataGridViewColumn
A DataGridViewColumn to locate in the DataGridViewSelectedColumnCollection.
Determines whether the specified column is contained in the collection.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal dataGridViewColumn As DataGridViewColumn _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewSelectedColumnCollection
Dim dataGridViewColumn As DataGridViewColumn
Dim value As Boolean

value = instance.Contains(dataGridViewColumn)
C#
public bool Contains(
   DataGridViewColumn dataGridViewColumn
)
Managed Extensions for C++
public: bool Contains(
   DataGridViewColumn* dataGridViewColumn
)
C++/CLI
public:
bool Contains(
   DataGridViewColumn^ dataGridViewColumn
)

Parameters

dataGridViewColumn
A DataGridViewColumn to locate in the DataGridViewSelectedColumnCollection.

Return Value

true if the dataGridViewColumn parameter is in the collection; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewSelectedColumnCollection Class
DataGridViewSelectedColumnCollection Members


CopyTo Method

[image]
Gizmox.WebGUI.Forms
CopyTo Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewSelectedColumnCollection Class : CopyTo Method

Copies the elements of the collection to the specified array, starting at the specified index.

Overload List

Overload | Description
CopyTo(DataGridViewColumn[],Int32) | Copies the elements of the collection to the specified array, starting at the specified index.
CopyTo(Array,Int32) | Copies all the elements of the current one-dimensional Array to the specified one-dimensional Array starting at the specified destination Array index. (Inherited from BaseCollection)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewSelectedColumnCollection Class
DataGridViewSelectedColumnCollection Members


CopyTo(DataGridViewColumn[],Int32) Method

[image]
Gizmox.WebGUI.Forms
CopyTo(DataGridViewColumn[],Int32) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewSelectedColumnCollection Class > CopyTo Method : CopyTo(DataGridViewColumn[],Int32) Method

array
The one-dimensional array that is the destination of the elements copied from the collection. The array must have zero-based indexing.
index
The zero-based index in the array at which copying begins.
Copies the elements of the collection to the specified array, starting at the specified index.

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal array() As DataGridViewColumn, _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewSelectedColumnCollection
Dim array() As DataGridViewColumn
Dim index As Integer

instance.CopyTo(array, index)
C#
public void CopyTo(
   DataGridViewColumn[] array,
   int index
)
Managed Extensions for C++
public: void CopyTo(
   DataGridViewColumn*[]* array,
   int index
)
C++/CLI
public:
void CopyTo(
   array<DataGridViewColumn^>^ array,
   int index
)

Parameters

array
The one-dimensional array that is the destination of the elements copied from the collection. The array must have zero-based indexing.
index
The zero-based index in the array at which copying begins.

Exceptions

Exception | Description
InvalidCastException | The DataGridViewColumnCollection cannot be cast automatically to the type of array.
ArgumentOutOfRangeException | index is less than zero.
ArgumentException | array is multidimensional.-or-index is equal to or greater than the length of array.-or-The number of elements in the DataGridViewCellCollection is greater than the available space from index to the end of array.
ArgumentNullException | array is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewSelectedColumnCollection Class
DataGridViewSelectedColumnCollection Members
Overload List


DataGridViewSelectedColumnCollection Class Properties

[image]
Gizmox.WebGUI.Forms
DataGridViewSelectedColumnCollection Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewSelectedColumnCollection Class

For a list of all members of this type, see DataGridViewSelectedColumnCollection members.

Public Properties

 | Name | Description
Public Property | Count | Gets the total number of elements in the collection. (Inherited from BaseCollection)
Public Property | IsReadOnly | Gets a value indicating whether the collection is read-only. (Inherited from BaseCollection)
Public Property | IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized. (Inherited from BaseCollection)
Public Property | Item | Gets the column at the specified index.
Public Property | SyncRoot | Gets an object that can be used to synchronize access to the BaseCollection. (Inherited from BaseCollection)
Top

Protected Properties

 | Name | Description
Protected Property | List | Overridden.
Top

See Also

Reference

DataGridViewSelectedColumnCollection Class
Gizmox.WebGUI.Forms Namespace


Item Property

[image]
Gizmox.WebGUI.Forms
Item Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewSelectedColumnCollection Class : Item Property

index
The index of the DataGridViewColumn to get from the DataGridViewSelectedColumnCollection.
Gets the column at the specified index.

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal index As Integer _
) As DataGridViewColumn
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewSelectedColumnCollection
Dim index As Integer
Dim value As DataGridViewColumn

value = instance.Item(index)
C#
public DataGridViewColumn this[
   int index
]; {get;}
Managed Extensions for C++
public: __property DataGridViewColumn* get_Item(
   int index
);
C++/CLI
public:
property DataGridViewColumn^ default [int] {
   DataGridViewColumn^ get(intindex);
}

Parameters

index
The index of the DataGridViewColumn to get from the DataGridViewSelectedColumnCollection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewSelectedColumnCollection Class
DataGridViewSelectedColumnCollection Members


List Property

[image]
Gizmox.WebGUI.Forms
List Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewSelectedColumnCollection Class : List Property

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property List As ArrayList
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewSelectedColumnCollection
Dim value As ArrayList

value = instance.List
C#
protected override ArrayList List {get;}
Managed Extensions for C++
protected: __property ArrayList* get_List() override;
C++/CLI
protected:
property ArrayList^ List {
   ArrayList^ get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewSelectedColumnCollection Class
DataGridViewSelectedColumnCollection Members


DataGridViewSelectedRowCollection Class

[image]
Gizmox.WebGUI.Forms
DataGridViewSelectedRowCollection Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewSelectedRowCollection Class

Represents a collection of DataGridViewRow objects that are selected in a DataGridView.

Object Model

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
<ListBindableAttribute(False)>
Public Class DataGridViewSelectedRowCollection
   Inherits BaseCollection
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewSelectedRowCollection
C#
[DefaultMemberAttribute("Item")]
[ListBindableAttribute(false)]
public class DataGridViewSelectedRowCollection : BaseCollection
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
[ListBindableAttribute(false)]
public __gc class DataGridViewSelectedRowCollection : public BaseCollection
C++/CLI
[DefaultMemberAttribute("Item")]
[ListBindableAttribute(false)]
public ref class DataGridViewSelectedRowCollection : public BaseCollection

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.BaseCollection
Gizmox.WebGUI.Forms.DataGridViewSelectedRowCollection

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

DataGridViewSelectedRowCollection Members
Gizmox.WebGUI.Forms Namespace


DataGridViewSelectedRowCollection Class Members

[image]
Gizmox.WebGUI.Forms
DataGridViewSelectedRowCollection Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewSelectedRowCollection Class

The following tables list the members exposed by DataGridViewSelectedRowCollection.

Public Properties

 | Name | Description
Public Property | Count | Gets the total number of elements in the collection. (Inherited from BaseCollection)
Public Property | IsReadOnly | Gets a value indicating whether the collection is read-only. (Inherited from BaseCollection)
Public Property | IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized. (Inherited from BaseCollection)
Public Property | Item | Gets the row at the specified index.
Public Property | SyncRoot | Gets an object that can be used to synchronize access to the BaseCollection. (Inherited from BaseCollection)
Top

Protected Properties

 | Name | Description
Protected Property | List | Overridden.
Top

Public Methods

 | Name | Description
Public Method | Contains | Determines whether the specified row is contained in the collection.
Public Method | CopyTo | Overloaded. Copies the elements of the collection to the specified array, starting at the specified index.
Public Method | GetEnumerator | Gets the object that enables iterating through the members of the collection. (Inherited from BaseCollection)
Top

See Also

Reference

DataGridViewSelectedRowCollection Class
Gizmox.WebGUI.Forms Namespace


DataGridViewSelectedRowCollection Class Methods

[image]
Gizmox.WebGUI.Forms
DataGridViewSelectedRowCollection Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewSelectedRowCollection Class

For a list of all members of this type, see DataGridViewSelectedRowCollection members.

Public Methods

 | Name | Description
Public Method | Contains | Determines whether the specified row is contained in the collection.
Public Method | CopyTo | Overloaded. Copies the elements of the collection to the specified array, starting at the specified index.
Public Method | GetEnumerator | Gets the object that enables iterating through the members of the collection. (Inherited from BaseCollection)
Top

See Also

Reference

DataGridViewSelectedRowCollection Class
Gizmox.WebGUI.Forms Namespace


Contains Method

[image]
Gizmox.WebGUI.Forms
Contains Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewSelectedRowCollection Class : Contains Method

dataGridViewRow
The DataGridViewRow to locate in the DataGridViewSelectedRowCollection.
Determines whether the specified row is contained in the collection.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal dataGridViewRow As DataGridViewRow _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewSelectedRowCollection
Dim dataGridViewRow As DataGridViewRow
Dim value As Boolean

value = instance.Contains(dataGridViewRow)
C#
public bool Contains(
   DataGridViewRow dataGridViewRow
)
Managed Extensions for C++
public: bool Contains(
   DataGridViewRow* dataGridViewRow
)
C++/CLI
public:
bool Contains(
   DataGridViewRow^ dataGridViewRow
)

Parameters

dataGridViewRow
The DataGridViewRow to locate in the DataGridViewSelectedRowCollection.

Return Value

true if dataGridViewRow is in the collection; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewSelectedRowCollection Class
DataGridViewSelectedRowCollection Members


CopyTo Method

[image]
Gizmox.WebGUI.Forms
CopyTo Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewSelectedRowCollection Class : CopyTo Method

Copies the elements of the collection to the specified array, starting at the specified index.

Overload List

Overload | Description
CopyTo(DataGridViewRow[],Int32) | Copies the elements of the collection to the specified array, starting at the specified index.
CopyTo(Array,Int32) | Copies all the elements of the current one-dimensional Array to the specified one-dimensional Array starting at the specified destination Array index. (Inherited from BaseCollection)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewSelectedRowCollection Class
DataGridViewSelectedRowCollection Members


CopyTo(DataGridViewRow[],Int32) Method

[image]
Gizmox.WebGUI.Forms
CopyTo(DataGridViewRow[],Int32) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewSelectedRowCollection Class > CopyTo Method : CopyTo(DataGridViewRow[],Int32) Method

array
The one-dimensional array that is the destination of the elements copied from the collection. The array must have zero-based indexing.
index
The zero-based index in the array at which copying begins.
Copies the elements of the collection to the specified array, starting at the specified index.

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal array() As DataGridViewRow, _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewSelectedRowCollection
Dim array() As DataGridViewRow
Dim index As Integer

instance.CopyTo(array, index)
C#
public void CopyTo(
   DataGridViewRow[] array,
   int index
)
Managed Extensions for C++
public: void CopyTo(
   DataGridViewRow*[]* array,
   int index
)
C++/CLI
public:
void CopyTo(
   array<DataGridViewRow^>^ array,
   int index
)

Parameters

array
The one-dimensional array that is the destination of the elements copied from the collection. The array must have zero-based indexing.
index
The zero-based index in the array at which copying begins.

Exceptions

Exception | Description
ArgumentOutOfRangeException | index is less than zero.
ArgumentException | array is multidimensional.-or-index is equal to or greater than the length of array.-or-The number of elements in the DataGridViewCellCollection is greater than the available space from index to the end of array.
InvalidCastException | The DataGridViewCellCollection cannot be cast automatically to the type of array.
ArgumentNullException | array is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewSelectedRowCollection Class
DataGridViewSelectedRowCollection Members
Overload List


DataGridViewSelectedRowCollection Class Properties

[image]
Gizmox.WebGUI.Forms
DataGridViewSelectedRowCollection Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewSelectedRowCollection Class

For a list of all members of this type, see DataGridViewSelectedRowCollection members.

Public Properties

 | Name | Description
Public Property | Count | Gets the total number of elements in the collection. (Inherited from BaseCollection)
Public Property | IsReadOnly | Gets a value indicating whether the collection is read-only. (Inherited from BaseCollection)
Public Property | IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized. (Inherited from BaseCollection)
Public Property | Item | Gets the row at the specified index.
Public Property | SyncRoot | Gets an object that can be used to synchronize access to the BaseCollection. (Inherited from BaseCollection)
Top

Protected Properties

 | Name | Description
Protected Property | List | Overridden.
Top

See Also

Reference

DataGridViewSelectedRowCollection Class
Gizmox.WebGUI.Forms Namespace


Item Property

[image]
Gizmox.WebGUI.Forms
Item Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewSelectedRowCollection Class : Item Property

index
The index of the DataGridViewRow in the DataGridViewSelectedRowCollection.
Gets the row at the specified index.

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal index As Integer _
) As DataGridViewRow
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewSelectedRowCollection
Dim index As Integer
Dim value As DataGridViewRow

value = instance.Item(index)
C#
public DataGridViewRow this[
   int index
]; {get;}
Managed Extensions for C++
public: __property DataGridViewRow* get_Item(
   int index
);
C++/CLI
public:
property DataGridViewRow^ default [int] {
   DataGridViewRow^ get(intindex);
}

Parameters

index
The index of the DataGridViewRow in the DataGridViewSelectedRowCollection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewSelectedRowCollection Class
DataGridViewSelectedRowCollection Members


List Property

[image]
Gizmox.WebGUI.Forms
List Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewSelectedRowCollection Class : List Property

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property List As ArrayList
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewSelectedRowCollection
Dim value As ArrayList

value = instance.List
C#
protected override ArrayList List {get;}
Managed Extensions for C++
protected: __property ArrayList* get_List() override;
C++/CLI
protected:
property ArrayList^ List {
   ArrayList^ get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewSelectedRowCollection Class
DataGridViewSelectedRowCollection Members


DataGridViewSortCompareEventArgs Class

[image]
Gizmox.WebGUI.Forms
DataGridViewSortCompareEventArgs Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewSortCompareEventArgs Class

Provides data for the SortCompare event.

Object Model

Syntax

Visual Basic (Declaration)
Public Class DataGridViewSortCompareEventArgs
   Inherits HandledEventArgs
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewSortCompareEventArgs
C#
public class DataGridViewSortCompareEventArgs : HandledEventArgs
Managed Extensions for C++
public __gc class DataGridViewSortCompareEventArgs : public HandledEventArgs
C++/CLI
public ref class DataGridViewSortCompareEventArgs : public HandledEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
System.ComponentModel.HandledEventArgs
Gizmox.WebGUI.Forms.DataGridViewSortCompareEventArgs

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

DataGridViewSortCompareEventArgs Members
Gizmox.WebGUI.Forms Namespace


DataGridViewSortCompareEventArgs Class Members

[image]
Gizmox.WebGUI.Forms
DataGridViewSortCompareEventArgs Class Members
See Also Properties Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewSortCompareEventArgs Class

The following tables list the members exposed by DataGridViewSortCompareEventArgs.

Public Constructors

 | Name | Description
Public Constructor | DataGridViewSortCompareEventArgs Constructor | Initializes a new instance of the DataGridViewSortCompareEventArgs class.
Top

Public Properties

 | Name | Description
Public Property | CellValue1 | Gets the value of the first cell to compare.
Public Property | CellValue2 | Gets the value of the second cell to compare.
Public Property | Column | Gets the column being sorted.
Public Property | Handled | Gets or sets a value that indicates whether the event handler has completely handled the event or whether the system should continue its own processing. (Inherited from System.ComponentModel.HandledEventArgs)
Public Property | RowIndex1 | Gets the index of the row containing the first cell to compare.
Public Property | RowIndex2 | Gets the index of the row containing the second cell to compare.
Public Property | SortResult | Gets or sets a value indicating the order in which the compared cells will be sorted.
Top

See Also

Reference

DataGridViewSortCompareEventArgs Class
Gizmox.WebGUI.Forms Namespace


DataGridViewSortCompareEventArgs Constructor

[image]
Gizmox.WebGUI.Forms
DataGridViewSortCompareEventArgs Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewSortCompareEventArgs Class : DataGridViewSortCompareEventArgs Constructor

dataGridViewColumn
The column to sort.
cellValue1
The value of the first cell to compare.
cellValue2
The value of the second cell to compare.
rowIndex1
The index of the row containing the first cell.
rowIndex2
The index of the row containing the second cell.
Initializes a new instance of the DataGridViewSortCompareEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal dataGridViewColumn As DataGridViewColumn, _
   ByVal cellValue1 As Object, _
   ByVal cellValue2 As Object, _
   ByVal rowIndex1 As Integer, _
   ByVal rowIndex2 As Integer _
)
Visual Basic (Usage) Copy Code
Dim dataGridViewColumn As DataGridViewColumn
Dim cellValue1 As Object
Dim cellValue2 As Object
Dim rowIndex1 As Integer
Dim rowIndex2 As Integer

Dim instance As DataGridViewSortCompareEventArgs(dataGridViewColumn, cellValue1, cellValue2, rowIndex1, rowIndex2)
C#
public DataGridViewSortCompareEventArgs(
   DataGridViewColumn dataGridViewColumn,
   object cellValue1,
   object cellValue2,
   int rowIndex1,
   int rowIndex2
)
Managed Extensions for C++
public: DataGridViewSortCompareEventArgs(
   DataGridViewColumn* dataGridViewColumn,
   Object* cellValue1,
   Object* cellValue2,
   int rowIndex1,
   int rowIndex2
)
C++/CLI
public:
DataGridViewSortCompareEventArgs(
   DataGridViewColumn^ dataGridViewColumn,
   Object^ cellValue1,
   Object^ cellValue2,
   int rowIndex1,
   int rowIndex2
)

Parameters

dataGridViewColumn
The column to sort.
cellValue1
The value of the first cell to compare.
cellValue2
The value of the second cell to compare.
rowIndex1
The index of the row containing the first cell.
rowIndex2
The index of the row containing the second cell.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewSortCompareEventArgs Class
DataGridViewSortCompareEventArgs Members


DataGridViewSortCompareEventArgs Class Properties

[image]
Gizmox.WebGUI.Forms
DataGridViewSortCompareEventArgs Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewSortCompareEventArgs Class

For a list of all members of this type, see DataGridViewSortCompareEventArgs members.

Public Properties

 | Name | Description
Public Property | CellValue1 | Gets the value of the first cell to compare.
Public Property | CellValue2 | Gets the value of the second cell to compare.
Public Property | Column | Gets the column being sorted.
Public Property | Handled | Gets or sets a value that indicates whether the event handler has completely handled the event or whether the system should continue its own processing. (Inherited from System.ComponentModel.HandledEventArgs)
Public Property | RowIndex1 | Gets the index of the row containing the first cell to compare.
Public Property | RowIndex2 | Gets the index of the row containing the second cell to compare.
Public Property | SortResult | Gets or sets a value indicating the order in which the compared cells will be sorted.
Top

See Also

Reference

DataGridViewSortCompareEventArgs Class
Gizmox.WebGUI.Forms Namespace


CellValue1 Property

[image]
Gizmox.WebGUI.Forms
CellValue1 Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewSortCompareEventArgs Class : CellValue1 Property

Gets the value of the first cell to compare.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CellValue1 As Object
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewSortCompareEventArgs
Dim value As Object

value = instance.CellValue1
C#
public object CellValue1 {get;}
Managed Extensions for C++
public: __property Object* get_CellValue1();
C++/CLI
public:
property Object^ CellValue1 {
   Object^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewSortCompareEventArgs Class
DataGridViewSortCompareEventArgs Members


CellValue2 Property

[image]
Gizmox.WebGUI.Forms
CellValue2 Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewSortCompareEventArgs Class : CellValue2 Property

Gets the value of the second cell to compare.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CellValue2 As Object
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewSortCompareEventArgs
Dim value As Object

value = instance.CellValue2
C#
public object CellValue2 {get;}
Managed Extensions for C++
public: __property Object* get_CellValue2();
C++/CLI
public:
property Object^ CellValue2 {
   Object^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewSortCompareEventArgs Class
DataGridViewSortCompareEventArgs Members


Column Property

[image]
Gizmox.WebGUI.Forms
Column Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewSortCompareEventArgs Class : Column Property

Gets the column being sorted.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Column As DataGridViewColumn
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewSortCompareEventArgs
Dim value As DataGridViewColumn

value = instance.Column
C#
public DataGridViewColumn Column {get;}
Managed Extensions for C++
public: __property DataGridViewColumn* get_Column();
C++/CLI
public:
property DataGridViewColumn^ Column {
   DataGridViewColumn^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewSortCompareEventArgs Class
DataGridViewSortCompareEventArgs Members


RowIndex1 Property

[image]
Gizmox.WebGUI.Forms
RowIndex1 Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewSortCompareEventArgs Class : RowIndex1 Property

Gets the index of the row containing the first cell to compare.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RowIndex1 As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewSortCompareEventArgs
Dim value As Integer

value = instance.RowIndex1
C#
public int RowIndex1 {get;}
Managed Extensions for C++
public: __property int get_RowIndex1();
C++/CLI
public:
property int RowIndex1 {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewSortCompareEventArgs Class
DataGridViewSortCompareEventArgs Members


RowIndex2 Property

[image]
Gizmox.WebGUI.Forms
RowIndex2 Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewSortCompareEventArgs Class : RowIndex2 Property

Gets the index of the row containing the second cell to compare.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RowIndex2 As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewSortCompareEventArgs
Dim value As Integer

value = instance.RowIndex2
C#
public int RowIndex2 {get;}
Managed Extensions for C++
public: __property int get_RowIndex2();
C++/CLI
public:
property int RowIndex2 {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewSortCompareEventArgs Class
DataGridViewSortCompareEventArgs Members


SortResult Property

[image]
Gizmox.WebGUI.Forms
SortResult Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewSortCompareEventArgs Class : SortResult Property

Gets or sets a value indicating the order in which the compared cells will be sorted.

Syntax

Visual Basic (Declaration)
Public Property SortResult As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewSortCompareEventArgs
Dim value As Integer

instance.SortResult = value

value = instance.SortResult
C#
public int SortResult {get; set;}
Managed Extensions for C++
public: __property int get_SortResult();
public: __property void set_SortResult(
   int value
);
C++/CLI
public:
property int SortResult {
   int get();
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewSortCompareEventArgs Class
DataGridViewSortCompareEventArgs Members


DataGridViewTextBoxCell Class

[image]
Gizmox.WebGUI.Forms
DataGridViewTextBoxCell Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewTextBoxCell Class

Displays editable text information in a DataGridView control.

Object Model

Syntax

Visual Basic (Declaration)
Public Class DataGridViewTextBoxCell
   Inherits DataGridViewCell
   Implements IRenderableComponentMember
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewTextBoxCell
C#
public class DataGridViewTextBoxCell : DataGridViewCell, IRenderableComponentMember
Managed Extensions for C++
public __gc class DataGridViewTextBoxCell : public DataGridViewCell, IRenderableComponentMember
C++/CLI
public ref class DataGridViewTextBoxCell : public DataGridViewCell, IRenderableComponentMember

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.DataGridViewElement
Gizmox.WebGUI.Forms.DataGridViewCell
Gizmox.WebGUI.Forms.DataGridViewTextBoxCell

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

DataGridViewTextBoxCell Members
Gizmox.WebGUI.Forms Namespace


DataGridViewTextBoxCell Class Members

[image]
Gizmox.WebGUI.Forms
DataGridViewTextBoxCell Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewTextBoxCell Class

The following tables list the members exposed by DataGridViewTextBoxCell.

Public Constructors

 | Name | Description
Public Constructor | DataGridViewTextBoxCell Constructor | Initializes a new instance of the DataGridViewTextBoxCell class.
Top

Public Properties

 | Name | Description
Public Property | ColumnIndex | Gets the column index for this cell. (Inherited from DataGridViewCell)
Public Property | ContentBounds | (Inherited from DataGridViewCell)
Public Property | DataGridView | Gets the DataGridView control associated with this element. (Inherited from DataGridViewElement)
Public Property | DefaultNewRowValue | Gets the default value for a cell in the row for new records. (Inherited from DataGridViewCell)
Public Property | Displayed | Gets a value that indicates whether the cell is currently displayed on-screen. (Inherited from DataGridViewCell)
Public Property | EditedFormattedValue | Gets the current, formatted value of the cell, regardless of whether the cell is in edit mode and the value has not been committed. (Inherited from DataGridViewCell)
Public Property | EditType | Gets the type of the cell's hosted editing control. (Inherited from DataGridViewCell)
Public Property | ErrorIconBounds | (Inherited from DataGridViewCell)
Public Property | ErrorText | Gets or sets the text describing an error condition associated with the cell. (Inherited from DataGridViewCell)
Public Property | FormattedValue | Gets the value of the cell as formatted for display. (Inherited from DataGridViewCell)
Public Property | FormattedValueType | Overridden. Gets the type of the formatted value associated with the cell.
Public Property | Frozen | Gets a value indicating whether the cell is frozen. (Inherited from DataGridViewCell)
Public Property | HasStyle | Gets a value indicating whether the DataGridViewCell.Style property has been set. (Inherited from DataGridViewCell)
Public Property | InheritedState | Gets the current state of the cell as inherited from the state of its row and column. (Inherited from DataGridViewCell)
Public Property | InheritedStyle | Gets the style currently applied to the cell. (Inherited from DataGridViewCell)
Public Property | IsInEditMode | Gets a value indicating whether this cell is currently being edited. (Inherited from DataGridViewCell)
Public Property | MaxInputLength | Gets or sets the maximum number of characters that can be entered into the text box.
Public Property | OwningColumn | Gets the column that contains this cell. (Inherited from DataGridViewCell)
Public Property | OwningRow | Gets the row that contains this cell. (Inherited from DataGridViewCell)
Public Property | PreferredSize | Gets the size, in pixels, of a rectangular area into which the cell can fit. (Inherited from DataGridViewCell)
Public Property | ReadOnly | Gets or sets a value indicating whether the cell's data can be edited. (Inherited from DataGridViewCell)
Public Property | Resizable | Gets a value indicating whether the cell can be resized. (Inherited from DataGridViewCell)
Public Property | RowIndex | Gets the index of the cell's parent row. (Inherited from DataGridViewCell)
Public Property | Selected | Gets or sets a value indicating whether the cell has been selected. (Inherited from DataGridViewCell)
Public Property | Size | Gets the size of the cell. (Inherited from DataGridViewCell)
Public Property | State | Gets the user interface (UI) state of the element. (Inherited from DataGridViewElement)
Public Property | Style | Gets or sets the style for the cell. (Inherited from DataGridViewCell)
Public Property | Tag | Gets or sets the object that contains supplemental data about the cell. (Inherited from DataGridViewCell)
Public Property | ToolTipText | Gets or sets the ToolTip text associated with this cell. (Inherited from DataGridViewCell)
Public Property | Value | Gets or sets the value associated with this cell. (Inherited from DataGridViewCell)
Public Property | ValueType | Overridden.
Public Property | Visible | Gets a value indicating whether the cell is in a row or column that has been hidden. (Inherited from DataGridViewCell)
Top

Protected Properties

 | Name | Description
Protected Property | MemberID | (Inherited from DataGridViewCell)
Protected Property | TagName | (Inherited from DataGridViewElement)
Top

Public Methods

 | Name | Description
Public Method | AdjustCellBorderStyle | Modifies the input cell border style according to the specified criteria. (Inherited from DataGridViewCell)
Public Method | Clone | Overridden. Creates an exact copy of this cell.
Public Method | DetachEditingControl | Overridden.
Public Method | Dispose | Overloaded. Releases all resources used by the DataGridViewCell. (Inherited from DataGridViewCell)
Public Method | GetContentBounds | Overloaded. (Inherited from DataGridViewCell)
Public Method | GetEditedFormattedValue | Returns the current, formatted value of the cell, regardless of whether the cell is in edit mode and the value has not been committed. (Inherited from DataGridViewCell)
Public Method | GetInheritedState | Returns a value indicating the current state of the cell as inherited from the state of its row and column. (Inherited from DataGridViewCell)
Public Method | GetInheritedStyle | Gets the style applied to the cell. (Inherited from DataGridViewCell)
Public Method | InitializeEditingControl | Overridden. Attaches and initializes the hosted editing control.
Public Method | KeyEntersEditMode | Overridden. Determines if edit mode should be started based on the given key.
Public Method | ParseFormattedValue | (Inherited from DataGridViewCell)
Public Method | PositionEditingControl | Overridden.
Public Method | PositionEditingPanel | (Inherited from DataGridViewCell)
Public Method | ToString | Overridden.
Public Method | Update | Overloaded. Full updates of this instance. (Inherited from DataGridViewElement)
Top

Protected Methods

 | Name | Description
Protected Method | BorderWidths | (Inherited from DataGridViewCell)
Protected Method | ClickUnsharesRow | Indicates whether the cell's row will be unshared when the cell is clicked. (Inherited from DataGridViewCell)
Protected Method | ContentClickUnsharesRow | Indicates whether the cell's row will be unshared when the cell's content is clicked. (Inherited from DataGridViewCell)
Protected Method | ContentDoubleClickUnsharesRow | Indicates whether the cell's row will be unshared when the cell's content is double-clicked. (Inherited from DataGridViewCell)
Protected Method | DoubleClickUnsharesRow | Indicates whether the cell's row will be unshared when the cell is double-clicked. (Inherited from DataGridViewCell)
Protected Method | EnterUnsharesRow | Indicates whether the parent row will be unshared when the focus moves to the cell. (Inherited from DataGridViewCell)
Protected Method | GetClipboardContent | Retrieves the formatted value of the cell to copy to the Clipboard. (Inherited from DataGridViewCell)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from DataGridViewElement)
Protected Method | GetDefaultHorizontalAlignment | Gets the horizontal alignment. (Inherited from DataGridViewCell)
Protected Method | GetDefaultVerticalAlignment | Gets the vertical alignment. (Inherited from DataGridViewCell)
Protected Method | GetErrorIconBounds | (Inherited from DataGridViewCell)
Protected Method | GetErrorText | Returns a string that represents the error for the cell. (Inherited from DataGridViewCell)
Protected Method | GetFormattedValue | Gets the value of the cell as formatted for display. (Inherited from DataGridViewCell)
Protected Method | GetPreferredSize | Overloaded. Calculates the preferred size, in pixels, of the cell. (Inherited from DataGridViewCell)
Protected Method | GetSize | Gets the size of the cell. (Inherited from DataGridViewCell)
Protected Method | GetValue | Gets the value of the cell. (Inherited from DataGridViewCell)
Protected Method | IsDirty | Determines whether the specified component is dirty. (Inherited from DataGridViewElement)
Protected Method | IsDirtyAttributes | Overloaded. Determines whether the specified component is dirty. (Inherited from DataGridViewElement)
Protected Method | KeyDownUnsharesRow | Indicates whether the parent row is unshared if the user presses a key while the focus is on the cell. (Inherited from DataGridViewCell)
Protected Method | KeyPressUnsharesRow | Indicates whether a row will be unshared if a key is pressed while a cell in the row has focus. (Inherited from DataGridViewCell)
Protected Method | KeyUpUnsharesRow | Indicates whether the parent row is unshared when the user releases a key while the focus is on the cell. (Inherited from DataGridViewCell)
Protected Method | LeaveUnsharesRow | Indicates whether a row will be unshared when the focus leaves a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseClickUnsharesRow | Indicates whether a row will be unshared if the user clicks a mouse button while the pointer is on a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseDoubleClickUnsharesRow | Indicates whether a row will be unshared if the user double-clicks a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseDownUnsharesRow | Indicates whether a row will be unshared when the user holds down a mouse button while the pointer is on a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseEnterUnsharesRow | Indicates whether a row will be unshared when the mouse pointer moves over a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseLeaveUnsharesRow | Indicates whether a row will be unshared when the mouse pointer leaves the row. (Inherited from DataGridViewCell)
Protected Method | MouseMoveUnsharesRow | Indicates whether a row will be unshared when the mouse pointer moves over a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseUpUnsharesRow | Indicates whether a row will be unshared when the user releases a mouse button while the pointer is on a cell in the row. (Inherited from DataGridViewCell)
Protected Method | OnClick | Called when the cell is clicked. (Inherited from DataGridViewCell)
Protected Method | OnContentClick | Called when the cell's contents are clicked. (Inherited from DataGridViewCell)
Protected Method | OnContentDoubleClick | Called when the cell's contents are double-clicked. (Inherited from DataGridViewCell)
Protected Method | OnDataGridViewChanged | Called when the DataGridViewElement.DataGridView property of the cell changes. (Inherited from DataGridViewCell)
Protected Method | OnDoubleClick | Called when the cell is double-clicked. (Inherited from DataGridViewCell)
Protected Method | OnEnter | Overridden. Called by DataGridView when the selection cursor moves onto a cell.
Protected Method | OnKeyDown | Called when a character key is pressed while the focus is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnKeyPress | Called when a key is pressed while the focus is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnKeyUp | Called when a character key is released while the focus is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnLeave | Overridden. Called by the DataGridView when the mouse leaves a cell.
Protected Method | OnMouseClick | Overridden. Called by DataGridView when the mouse leaves a cell.
Protected Method | OnMouseDoubleClick | Called when the user double-clicks a mouse button while the pointer is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseDown | Called when the user holds down a mouse button while the pointer is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseEnter | Called when the mouse pointer moves over a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseLeave | Called when the mouse pointer leaves the cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseMove | Called when the mouse pointer moves within a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseUp | Called when the user releases a mouse button while the pointer is on a cell. (Inherited from DataGridViewCell)
Protected Method | Paint | (Inherited from DataGridViewCell)
Protected Method | PaintErrorIcon | (Inherited from DataGridViewCell)
Protected Method | ProcessGatewayRequest | (Inherited from DataGridViewCell)
Protected Method | RaiseCellClick | Raises the DataGridView.CellClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellContentClick | Raises the DataGridView.CellContentClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellContentDoubleClick | Raises the DataGridView.CellContentDoubleClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellValueChanged | Raises the CellValueChanged event. (Inherited from DataGridViewElement)
Protected Method | RaiseDataError | Raises the DataError event. (Inherited from DataGridViewElement)
Protected Method | RaiseMouseWheel | Raises the MouseWheel event. (Inherited from DataGridViewElement)
Protected Method | RenderAttributes | Overridden.
Protected Method | RenderBackColorAttribute | Renders the back color attribute. (Inherited from DataGridViewCell)
Protected Method | RenderComponent | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from DataGridViewElement)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from DataGridViewElement)
Protected Method | RenderComponents | Renders the controls sub tree (Inherited from DataGridViewElement)
Protected Method | RenderForeColorAttribute | Renders the fore color attribute. (Inherited from DataGridViewCell)
Protected Method | RenderReadOnlyAttribute | Renders the read only attribute. (Inherited from DataGridViewCell)
Protected Method | RenderUpdatedAttributes | Renders the updated attributes (Inherited from DataGridViewElement)
Protected Method | RenderWrapModeAttribute | Renders the wrap mode attribute. (Inherited from DataGridViewCell)
Protected Method | SetValue | Sets the value of the cell. (Inherited from DataGridViewCell)
Protected Method | UpdateParams | Overloaded. Updates only the parameters of this instance. (Inherited from DataGridViewElement)
Top

See Also

Reference

DataGridViewTextBoxCell Class
Gizmox.WebGUI.Forms Namespace


DataGridViewTextBoxCell Constructor

[image]
Gizmox.WebGUI.Forms
DataGridViewTextBoxCell Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewTextBoxCell Class : DataGridViewTextBoxCell Constructor

Initializes a new instance of the DataGridViewTextBoxCell class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewTextBoxCell()
C#
public DataGridViewTextBoxCell()
Managed Extensions for C++
public: DataGridViewTextBoxCell();
C++/CLI
public:
DataGridViewTextBoxCell();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewTextBoxCell Class
DataGridViewTextBoxCell Members


DataGridViewTextBoxCell Class Methods

[image]
Gizmox.WebGUI.Forms
DataGridViewTextBoxCell Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewTextBoxCell Class

For a list of all members of this type, see DataGridViewTextBoxCell members.

Public Methods

 | Name | Description
Public Method | AdjustCellBorderStyle | Modifies the input cell border style according to the specified criteria. (Inherited from DataGridViewCell)
Public Method | Clone | Overridden. Creates an exact copy of this cell.
Public Method | DetachEditingControl | Overridden.
Public Method | Dispose | Overloaded. Releases all resources used by the DataGridViewCell. (Inherited from DataGridViewCell)
Public Method | GetContentBounds | Overloaded. (Inherited from DataGridViewCell)
Public Method | GetEditedFormattedValue | Returns the current, formatted value of the cell, regardless of whether the cell is in edit mode and the value has not been committed. (Inherited from DataGridViewCell)
Public Method | GetInheritedState | Returns a value indicating the current state of the cell as inherited from the state of its row and column. (Inherited from DataGridViewCell)
Public Method | GetInheritedStyle | Gets the style applied to the cell. (Inherited from DataGridViewCell)
Public Method | InitializeEditingControl | Overridden. Attaches and initializes the hosted editing control.
Public Method | KeyEntersEditMode | Overridden. Determines if edit mode should be started based on the given key.
Public Method | ParseFormattedValue | (Inherited from DataGridViewCell)
Public Method | PositionEditingControl | Overridden.
Public Method | PositionEditingPanel | (Inherited from DataGridViewCell)
Public Method | ToString | Overridden.
Public Method | Update | Overloaded. Full updates of this instance. (Inherited from DataGridViewElement)
Top

Protected Methods

 | Name | Description
Protected Method | BorderWidths | (Inherited from DataGridViewCell)
Protected Method | ClickUnsharesRow | Indicates whether the cell's row will be unshared when the cell is clicked. (Inherited from DataGridViewCell)
Protected Method | ContentClickUnsharesRow | Indicates whether the cell's row will be unshared when the cell's content is clicked. (Inherited from DataGridViewCell)
Protected Method | ContentDoubleClickUnsharesRow | Indicates whether the cell's row will be unshared when the cell's content is double-clicked. (Inherited from DataGridViewCell)
Protected Method | DoubleClickUnsharesRow | Indicates whether the cell's row will be unshared when the cell is double-clicked. (Inherited from DataGridViewCell)
Protected Method | EnterUnsharesRow | Indicates whether the parent row will be unshared when the focus moves to the cell. (Inherited from DataGridViewCell)
Protected Method | GetClipboardContent | Retrieves the formatted value of the cell to copy to the Clipboard. (Inherited from DataGridViewCell)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from DataGridViewElement)
Protected Method | GetDefaultHorizontalAlignment | Gets the horizontal alignment. (Inherited from DataGridViewCell)
Protected Method | GetDefaultVerticalAlignment | Gets the vertical alignment. (Inherited from DataGridViewCell)
Protected Method | GetErrorIconBounds | (Inherited from DataGridViewCell)
Protected Method | GetErrorText | Returns a string that represents the error for the cell. (Inherited from DataGridViewCell)
Protected Method | GetFormattedValue | Gets the value of the cell as formatted for display. (Inherited from DataGridViewCell)
Protected Method | GetPreferredSize | Overloaded. Calculates the preferred size, in pixels, of the cell. (Inherited from DataGridViewCell)
Protected Method | GetSize | Gets the size of the cell. (Inherited from DataGridViewCell)
Protected Method | GetValue | Gets the value of the cell. (Inherited from DataGridViewCell)
Protected Method | IsDirty | Determines whether the specified component is dirty. (Inherited from DataGridViewElement)
Protected Method | IsDirtyAttributes | Overloaded. Determines whether the specified component is dirty. (Inherited from DataGridViewElement)
Protected Method | KeyDownUnsharesRow | Indicates whether the parent row is unshared if the user presses a key while the focus is on the cell. (Inherited from DataGridViewCell)
Protected Method | KeyPressUnsharesRow | Indicates whether a row will be unshared if a key is pressed while a cell in the row has focus. (Inherited from DataGridViewCell)
Protected Method | KeyUpUnsharesRow | Indicates whether the parent row is unshared when the user releases a key while the focus is on the cell. (Inherited from DataGridViewCell)
Protected Method | LeaveUnsharesRow | Indicates whether a row will be unshared when the focus leaves a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseClickUnsharesRow | Indicates whether a row will be unshared if the user clicks a mouse button while the pointer is on a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseDoubleClickUnsharesRow | Indicates whether a row will be unshared if the user double-clicks a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseDownUnsharesRow | Indicates whether a row will be unshared when the user holds down a mouse button while the pointer is on a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseEnterUnsharesRow | Indicates whether a row will be unshared when the mouse pointer moves over a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseLeaveUnsharesRow | Indicates whether a row will be unshared when the mouse pointer leaves the row. (Inherited from DataGridViewCell)
Protected Method | MouseMoveUnsharesRow | Indicates whether a row will be unshared when the mouse pointer moves over a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseUpUnsharesRow | Indicates whether a row will be unshared when the user releases a mouse button while the pointer is on a cell in the row. (Inherited from DataGridViewCell)
Protected Method | OnClick | Called when the cell is clicked. (Inherited from DataGridViewCell)
Protected Method | OnContentClick | Called when the cell's contents are clicked. (Inherited from DataGridViewCell)
Protected Method | OnContentDoubleClick | Called when the cell's contents are double-clicked. (Inherited from DataGridViewCell)
Protected Method | OnDataGridViewChanged | Called when the DataGridViewElement.DataGridView property of the cell changes. (Inherited from DataGridViewCell)
Protected Method | OnDoubleClick | Called when the cell is double-clicked. (Inherited from DataGridViewCell)
Protected Method | OnEnter | Overridden. Called by DataGridView when the selection cursor moves onto a cell.
Protected Method | OnKeyDown | Called when a character key is pressed while the focus is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnKeyPress | Called when a key is pressed while the focus is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnKeyUp | Called when a character key is released while the focus is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnLeave | Overridden. Called by the DataGridView when the mouse leaves a cell.
Protected Method | OnMouseClick | Overridden. Called by DataGridView when the mouse leaves a cell.
Protected Method | OnMouseDoubleClick | Called when the user double-clicks a mouse button while the pointer is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseDown | Called when the user holds down a mouse button while the pointer is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseEnter | Called when the mouse pointer moves over a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseLeave | Called when the mouse pointer leaves the cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseMove | Called when the mouse pointer moves within a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseUp | Called when the user releases a mouse button while the pointer is on a cell. (Inherited from DataGridViewCell)
Protected Method | Paint | (Inherited from DataGridViewCell)
Protected Method | PaintErrorIcon | (Inherited from DataGridViewCell)
Protected Method | ProcessGatewayRequest | (Inherited from DataGridViewCell)
Protected Method | RaiseCellClick | Raises the DataGridView.CellClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellContentClick | Raises the DataGridView.CellContentClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellContentDoubleClick | Raises the DataGridView.CellContentDoubleClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellValueChanged | Raises the CellValueChanged event. (Inherited from DataGridViewElement)
Protected Method | RaiseDataError | Raises the DataError event. (Inherited from DataGridViewElement)
Protected Method | RaiseMouseWheel | Raises the MouseWheel event. (Inherited from DataGridViewElement)
Protected Method | RenderAttributes | Overridden.
Protected Method | RenderBackColorAttribute | Renders the back color attribute. (Inherited from DataGridViewCell)
Protected Method | RenderComponent | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from DataGridViewElement)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from DataGridViewElement)
Protected Method | RenderComponents | Renders the controls sub tree (Inherited from DataGridViewElement)
Protected Method | RenderForeColorAttribute | Renders the fore color attribute. (Inherited from DataGridViewCell)
Protected Method | RenderReadOnlyAttribute | Renders the read only attribute. (Inherited from DataGridViewCell)
Protected Method | RenderUpdatedAttributes | Renders the updated attributes (Inherited from DataGridViewElement)
Protected Method | RenderWrapModeAttribute | Renders the wrap mode attribute. (Inherited from DataGridViewCell)
Protected Method | SetValue | Sets the value of the cell. (Inherited from DataGridViewCell)
Protected Method | UpdateParams | Overloaded. Updates only the parameters of this instance. (Inherited from DataGridViewElement)
Top

See Also

Reference

DataGridViewTextBoxCell Class
Gizmox.WebGUI.Forms Namespace


Clone Method

[image]
Gizmox.WebGUI.Forms
Clone Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewTextBoxCell Class : Clone Method

Creates an exact copy of this cell.

Syntax

Visual Basic (Declaration)
Public Overrides Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewTextBoxCell
Dim value As Object

value = instance.Clone()
C#
public override object Clone()
Managed Extensions for C++
public: Object* Clone(); override
C++/CLI
public:
Object^ Clone(); override

Return Value

An Object that represents the cloned DataGridViewTextBoxCell.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewTextBoxCell Class
DataGridViewTextBoxCell Members


DetachEditingControl Method

[image]
Gizmox.WebGUI.Forms
DetachEditingControl Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewTextBoxCell Class : DetachEditingControl Method

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Overrides Sub DetachEditingControl()
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewTextBoxCell

instance.DetachEditingControl()
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public override void DetachEditingControl()
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: void DetachEditingControl(); override
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
void DetachEditingControl(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewTextBoxCell Class
DataGridViewTextBoxCell Members


InitializeEditingControl Method

[image]
Gizmox.WebGUI.Forms
InitializeEditingControl Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewTextBoxCell Class : InitializeEditingControl Method

rowIndex
The index of the row being edited.
initialFormattedValue
The initial value to be displayed in the control.
dataGridViewCellStyle
A cell style that is used to determine the appearance of the hosted control.
Attaches and initializes the hosted editing control.

Syntax

Visual Basic (Declaration)
Public Overrides Sub InitializeEditingControl( _
   ByVal rowIndex As Integer, _
   ByVal initialFormattedValue As Object, _
   ByVal dataGridViewCellStyle As DataGridViewCellStyle _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewTextBoxCell
Dim rowIndex As Integer
Dim initialFormattedValue As Object
Dim dataGridViewCellStyle As DataGridViewCellStyle

instance.InitializeEditingControl(rowIndex, initialFormattedValue, dataGridViewCellStyle)
C#
public override void InitializeEditingControl(
   int rowIndex,
   object initialFormattedValue,
   DataGridViewCellStyle dataGridViewCellStyle
)
Managed Extensions for C++
public: void InitializeEditingControl(
   int rowIndex,
   Object* initialFormattedValue,
   DataGridViewCellStyle* dataGridViewCellStyle
) override
C++/CLI
public:
void InitializeEditingControl(
   int rowIndex,
   Object^ initialFormattedValue,
   DataGridViewCellStyle^ dataGridViewCellStyle
) override

Parameters

rowIndex
The index of the row being edited.
initialFormattedValue
The initial value to be displayed in the control.
dataGridViewCellStyle
A cell style that is used to determine the appearance of the hosted control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewTextBoxCell Class
DataGridViewTextBoxCell Members


KeyEntersEditMode Method

[image]
Gizmox.WebGUI.Forms
KeyEntersEditMode Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewTextBoxCell Class : KeyEntersEditMode Method

e
A KeyEventArgs that represents the key that was pressed.
Determines if edit mode should be started based on the given key.

Syntax

Visual Basic (Declaration)
Public Overrides Function KeyEntersEditMode( _
   ByVal e As KeyEventArgs _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewTextBoxCell
Dim e As KeyEventArgs
Dim value As Boolean

value = instance.KeyEntersEditMode(e)
C#
public override bool KeyEntersEditMode(
   KeyEventArgs e
)
Managed Extensions for C++
public: bool KeyEntersEditMode(
   KeyEventArgs* e
) override
C++/CLI
public:
bool KeyEntersEditMode(
   KeyEventArgs^ e
) override

Parameters

e
A KeyEventArgs that represents the key that was pressed.

Return Value

true if edit mode should be started; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewTextBoxCell Class
DataGridViewTextBoxCell Members


OnEnter Method

[image]
Gizmox.WebGUI.Forms
OnEnter Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewTextBoxCell Class : OnEnter Method

rowIndex
The index of the row entered by the mouse.
throughMouseClick
true if the cell was entered as a result of a mouse click; otherwise, false.
Called by DataGridView when the selection cursor moves onto a cell.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnEnter( _
   ByVal rowIndex As Integer, _
   ByVal throughMouseClick As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewTextBoxCell
Dim rowIndex As Integer
Dim throughMouseClick As Boolean

instance.OnEnter(rowIndex, throughMouseClick)
C#
protected override void OnEnter(
   int rowIndex,
   bool throughMouseClick
)
Managed Extensions for C++
protected: void OnEnter(
   int rowIndex,
   bool throughMouseClick
) override
C++/CLI
protected:
void OnEnter(
   int rowIndex,
   bool throughMouseClick
) override

Parameters

rowIndex
The index of the row entered by the mouse.
throughMouseClick
true if the cell was entered as a result of a mouse click; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewTextBoxCell Class
DataGridViewTextBoxCell Members


OnLeave Method

[image]
Gizmox.WebGUI.Forms
OnLeave Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewTextBoxCell Class : OnLeave Method

rowIndex
The index of the row the mouse has left.
throughMouseClick
true if the cell was left as a result of a mouse click; otherwise, false.
Called by the DataGridView when the mouse leaves a cell.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnLeave( _
   ByVal rowIndex As Integer, _
   ByVal throughMouseClick As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewTextBoxCell
Dim rowIndex As Integer
Dim throughMouseClick As Boolean

instance.OnLeave(rowIndex, throughMouseClick)
C#
protected override void OnLeave(
   int rowIndex,
   bool throughMouseClick
)
Managed Extensions for C++
protected: void OnLeave(
   int rowIndex,
   bool throughMouseClick
) override
C++/CLI
protected:
void OnLeave(
   int rowIndex,
   bool throughMouseClick
) override

Parameters

rowIndex
The index of the row the mouse has left.
throughMouseClick
true if the cell was left as a result of a mouse click; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewTextBoxCell Class
DataGridViewTextBoxCell Members


OnMouseClick Method

[image]
Gizmox.WebGUI.Forms
OnMouseClick Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewTextBoxCell Class : OnMouseClick Method

e
An DataGridViewCellMouseEventArgs that contains the event data.
Called by DataGridView when the mouse leaves a cell.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnMouseClick( _
   ByVal e As DataGridViewCellMouseEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewTextBoxCell
Dim e As DataGridViewCellMouseEventArgs

instance.OnMouseClick(e)
C#
protected override void OnMouseClick(
   DataGridViewCellMouseEventArgs e
)
Managed Extensions for C++
protected: void OnMouseClick(
   DataGridViewCellMouseEventArgs* e
) override
C++/CLI
protected:
void OnMouseClick(
   DataGridViewCellMouseEventArgs^ e
) override

Parameters

e
An DataGridViewCellMouseEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewTextBoxCell Class
DataGridViewTextBoxCell Members


PositionEditingControl Method

[image]
Gizmox.WebGUI.Forms
PositionEditingControl Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewTextBoxCell Class : PositionEditingControl Method

setLocation
setSize
cellBounds
cellClip
cellStyle
singleVerticalBorderAdded
singleHorizontalBorderAdded
isFirstDisplayedColumn
isFirstDisplayedRow

Syntax

Visual Basic (Declaration)
Public Overrides Sub PositionEditingControl( _
   ByVal setLocation As Boolean, _
   ByVal setSize As Boolean, _
   ByVal cellBounds As Rectangle, _
   ByVal cellClip As Rectangle, _
   ByVal cellStyle As DataGridViewCellStyle, _
   ByVal singleVerticalBorderAdded As Boolean, _
   ByVal singleHorizontalBorderAdded As Boolean, _
   ByVal isFirstDisplayedColumn As Boolean, _
   ByVal isFirstDisplayedRow As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewTextBoxCell
Dim setLocation As Boolean
Dim setSize As Boolean
Dim cellBounds As Rectangle
Dim cellClip As Rectangle
Dim cellStyle As DataGridViewCellStyle
Dim singleVerticalBorderAdded As Boolean
Dim singleHorizontalBorderAdded As Boolean
Dim isFirstDisplayedColumn As Boolean
Dim isFirstDisplayedRow As Boolean

instance.PositionEditingControl(setLocation, setSize, cellBounds, cellClip, cellStyle, singleVerticalBorderAdded, singleHorizontalBorderAdded, isFirstDisplayedColumn, isFirstDisplayedRow)
C#
public override void PositionEditingControl(
   bool setLocation,
   bool setSize,
   Rectangle cellBounds,
   Rectangle cellClip,
   DataGridViewCellStyle cellStyle,
   bool singleVerticalBorderAdded,
   bool singleHorizontalBorderAdded,
   bool isFirstDisplayedColumn,
   bool isFirstDisplayedRow
)
Managed Extensions for C++
public: void PositionEditingControl(
   bool setLocation,
   bool setSize,
   Rectangle cellBounds,
   Rectangle cellClip,
   DataGridViewCellStyle* cellStyle,
   bool singleVerticalBorderAdded,
   bool singleHorizontalBorderAdded,
   bool isFirstDisplayedColumn,
   bool isFirstDisplayedRow
) override
C++/CLI
public:
void PositionEditingControl(
   bool setLocation,
   bool setSize,
   Rectangle cellBounds,
   Rectangle cellClip,
   DataGridViewCellStyle^ cellStyle,
   bool singleVerticalBorderAdded,
   bool singleHorizontalBorderAdded,
   bool isFirstDisplayedColumn,
   bool isFirstDisplayedRow
) override

Parameters

setLocation
setSize
cellBounds
cellClip
cellStyle
singleVerticalBorderAdded
singleHorizontalBorderAdded
isFirstDisplayedColumn
isFirstDisplayedRow

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewTextBoxCell Class
DataGridViewTextBoxCell Members


RenderAttributes Method

[image]
Gizmox.WebGUI.Forms
RenderAttributes Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewTextBoxCell Class : RenderAttributes Method

objContext
objWriter
blnRenderOwner

Syntax

Visual Basic (Declaration)
Protected Overrides Sub RenderAttributes( _
   ByVal objContext As IContext, _
   ByVal objWriter As IAttributeWriter, _
   ByVal blnRenderOwner As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewTextBoxCell
Dim objContext As IContext
Dim objWriter As IAttributeWriter
Dim blnRenderOwner As Boolean

instance.RenderAttributes(objContext, objWriter, blnRenderOwner)
C#
protected override void RenderAttributes(
   IContext objContext,
   IAttributeWriter objWriter,
   bool blnRenderOwner
)
Managed Extensions for C++
protected: void RenderAttributes(
   IContext* objContext,
   IAttributeWriter* objWriter,
   bool blnRenderOwner
) override
C++/CLI
protected:
void RenderAttributes(
   IContext^ objContext,
   IAttributeWriter^ objWriter,
   bool blnRenderOwner
) override

Parameters

objContext
objWriter
blnRenderOwner

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewTextBoxCell Class
DataGridViewTextBoxCell Members


ToString Method

[image]
Gizmox.WebGUI.Forms
ToString Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewTextBoxCell Class : ToString Method

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewTextBoxCell
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewTextBoxCell Class
DataGridViewTextBoxCell Members


DataGridViewTextBoxCell Class Properties

[image]
Gizmox.WebGUI.Forms
DataGridViewTextBoxCell Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewTextBoxCell Class

For a list of all members of this type, see DataGridViewTextBoxCell members.

Public Properties

 | Name | Description
Public Property | ColumnIndex | Gets the column index for this cell. (Inherited from DataGridViewCell)
Public Property | ContentBounds | (Inherited from DataGridViewCell)
Public Property | DataGridView | Gets the DataGridView control associated with this element. (Inherited from DataGridViewElement)
Public Property | DefaultNewRowValue | Gets the default value for a cell in the row for new records. (Inherited from DataGridViewCell)
Public Property | Displayed | Gets a value that indicates whether the cell is currently displayed on-screen. (Inherited from DataGridViewCell)
Public Property | EditedFormattedValue | Gets the current, formatted value of the cell, regardless of whether the cell is in edit mode and the value has not been committed. (Inherited from DataGridViewCell)
Public Property | EditType | Gets the type of the cell's hosted editing control. (Inherited from DataGridViewCell)
Public Property | ErrorIconBounds | (Inherited from DataGridViewCell)
Public Property | ErrorText | Gets or sets the text describing an error condition associated with the cell. (Inherited from DataGridViewCell)
Public Property | FormattedValue | Gets the value of the cell as formatted for display. (Inherited from DataGridViewCell)
Public Property | FormattedValueType | Overridden. Gets the type of the formatted value associated with the cell.
Public Property | Frozen | Gets a value indicating whether the cell is frozen. (Inherited from DataGridViewCell)
Public Property | HasStyle | Gets a value indicating whether the DataGridViewCell.Style property has been set. (Inherited from DataGridViewCell)
Public Property | InheritedState | Gets the current state of the cell as inherited from the state of its row and column. (Inherited from DataGridViewCell)
Public Property | InheritedStyle | Gets the style currently applied to the cell. (Inherited from DataGridViewCell)
Public Property | IsInEditMode | Gets a value indicating whether this cell is currently being edited. (Inherited from DataGridViewCell)
Public Property | MaxInputLength | Gets or sets the maximum number of characters that can be entered into the text box.
Public Property | OwningColumn | Gets the column that contains this cell. (Inherited from DataGridViewCell)
Public Property | OwningRow | Gets the row that contains this cell. (Inherited from DataGridViewCell)
Public Property | PreferredSize | Gets the size, in pixels, of a rectangular area into which the cell can fit. (Inherited from DataGridViewCell)
Public Property | ReadOnly | Gets or sets a value indicating whether the cell's data can be edited. (Inherited from DataGridViewCell)
Public Property | Resizable | Gets a value indicating whether the cell can be resized. (Inherited from DataGridViewCell)
Public Property | RowIndex | Gets the index of the cell's parent row. (Inherited from DataGridViewCell)
Public Property | Selected | Gets or sets a value indicating whether the cell has been selected. (Inherited from DataGridViewCell)
Public Property | Size | Gets the size of the cell. (Inherited from DataGridViewCell)
Public Property | State | Gets the user interface (UI) state of the element. (Inherited from DataGridViewElement)
Public Property | Style | Gets or sets the style for the cell. (Inherited from DataGridViewCell)
Public Property | Tag | Gets or sets the object that contains supplemental data about the cell. (Inherited from DataGridViewCell)
Public Property | ToolTipText | Gets or sets the ToolTip text associated with this cell. (Inherited from DataGridViewCell)
Public Property | Value | Gets or sets the value associated with this cell. (Inherited from DataGridViewCell)
Public Property | ValueType | Overridden.
Public Property | Visible | Gets a value indicating whether the cell is in a row or column that has been hidden. (Inherited from DataGridViewCell)
Top

Protected Properties

 | Name | Description
Protected Property | MemberID | (Inherited from DataGridViewCell)
Protected Property | TagName | (Inherited from DataGridViewElement)
Top

See Also

Reference

DataGridViewTextBoxCell Class
Gizmox.WebGUI.Forms Namespace


FormattedValueType Property

[image]
Gizmox.WebGUI.Forms
FormattedValueType Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewTextBoxCell Class : FormattedValueType Property

Gets the type of the formatted value associated with the cell.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property FormattedValueType As Type
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewTextBoxCell
Dim value As Type

value = instance.FormattedValueType
C#
public override Type FormattedValueType {get;}
Managed Extensions for C++
public: __property Type* get_FormattedValueType() override;
C++/CLI
public:
property Type^ FormattedValueType {
   Type^ get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewTextBoxCell Class
DataGridViewTextBoxCell Members


MaxInputLength Property

[image]
Gizmox.WebGUI.Forms
MaxInputLength Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewTextBoxCell Class : MaxInputLength Property

Gets or sets the maximum number of characters that can be entered into the text box.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Overridable Property MaxInputLength As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewTextBoxCell
Dim value As Integer

instance.MaxInputLength = value

value = instance.MaxInputLength
C#
[DefaultValueAttribute()]
public virtual int MaxInputLength {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property virtual int get_MaxInputLength();
public: __property virtual void set_MaxInputLength(
   int value
);
C++/CLI
[DefaultValueAttribute()]
public:
virtual property int MaxInputLength {
   int get();
   void set (intvalue);
}

Exceptions

Exception | Description
ArgumentOutOfRangeException | The value is less than 0.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewTextBoxCell Class
DataGridViewTextBoxCell Members


ValueType Property

[image]
Gizmox.WebGUI.Forms
ValueType Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewTextBoxCell Class : ValueType Property

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ValueType As Type
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewTextBoxCell
Dim value As Type

value = instance.ValueType
C#
public override Type ValueType {get;}
Managed Extensions for C++
public: __property Type* get_ValueType() override;
C++/CLI
public:
property Type^ ValueType {
   Type^ get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewTextBoxCell Class
DataGridViewTextBoxCell Members


DataGridViewTextBoxColumn Class

[image]
Gizmox.WebGUI.Forms
DataGridViewTextBoxColumn Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewTextBoxColumn Class

Hosts a collection of DataGridViewTextBoxCell cells.

Object Model

Syntax

Visual Basic (Declaration)
<DesignTimeControllerAttribute()>
<ClientControllerAttribute()>
<ToolboxBitmapAttribute()>
Public Class DataGridViewTextBoxColumn
   Inherits DataGridViewColumn
   Implements IRenderableComponentMember
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewTextBoxColumn
C#
[DesignTimeControllerAttribute()]
[ClientControllerAttribute()]
[ToolboxBitmapAttribute()]
public class DataGridViewTextBoxColumn : DataGridViewColumn, IRenderableComponentMember
Managed Extensions for C++
[DesignTimeControllerAttribute()]
[ClientControllerAttribute()]
[ToolboxBitmapAttribute()]
public __gc class DataGridViewTextBoxColumn : public DataGridViewColumn, IRenderableComponentMember
C++/CLI
[DesignTimeControllerAttribute()]
[ClientControllerAttribute()]
[ToolboxBitmapAttribute()]
public ref class DataGridViewTextBoxColumn : public DataGridViewColumn, IRenderableComponentMember

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.DataGridViewElement
Gizmox.WebGUI.Forms.DataGridViewBand
Gizmox.WebGUI.Forms.DataGridViewColumn
Gizmox.WebGUI.Forms.DataGridViewTextBoxColumn

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

DataGridViewTextBoxColumn Members
Gizmox.WebGUI.Forms Namespace


DataGridViewTextBoxColumn Class Members

[image]
Gizmox.WebGUI.Forms
DataGridViewTextBoxColumn Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewTextBoxColumn Class

The following tables list the members exposed by DataGridViewTextBoxColumn.

Public Constructors

 | Name | Description
Public Constructor | DataGridViewTextBoxColumn Constructor | Initializes a new instance of the DataGridViewTextBoxColumn class to the default state.
Top

Public Properties

 | Name | Description
Public Property | AutoSizeMode | Gets or sets the mode by which the column automatically adjusts its width. (Inherited from DataGridViewColumn)
Public Property | CellTemplate | Overridden. Gets or sets the template used to model cell appearance.
Public Property | CellType | Gets the run-time type of the cell template. (Inherited from DataGridViewColumn)
Public Property | DataGridView | Gets the DataGridView control associated with this element. (Inherited from DataGridViewElement)
Public Property | DataPropertyName | Gets or sets the name of the data source property or database column to which the DataGridViewColumn is bound. (Inherited from DataGridViewColumn)
Public Property | DefaultCellStyle | Gets or sets the column's default cell style. (Inherited from DataGridViewColumn)
Public Property | DefaultHeaderCellType | Gets or sets the run-time type of the default header cell. (Inherited from DataGridViewBand)
Public Property | Displayed | Gets a value indicating whether the band is currently displayed onscreen. (Inherited from DataGridViewBand)
Public Property | DisplayIndex | Gets or sets the display order of the column relative to the currently displayed columns. (Inherited from DataGridViewColumn)
Public Property | DividerWidth | Gets or sets the width, in pixels, of the column divider. (Inherited from DataGridViewColumn)
Public Property | FillWeight | Gets or sets a value that represents the width of the column when it is in fill mode relative to the widths of other fill-mode columns in the control. (Inherited from DataGridViewColumn)
Public Property | Frozen | Gets or sets a value indicating whether a column will move when a user scrolls the DataGridView control horizontally. (Inherited from DataGridViewColumn)
Public Property | HasDefaultCellStyle | Gets a value indicating whether the DataGridViewBand.DefaultCellStyle property has been set. (Inherited from DataGridViewBand)
Public Property | HeaderCell | Gets or sets the DataGridViewColumnHeaderCell that represents the column header. (Inherited from DataGridViewColumn)
Public Property | HeaderText | Gets or sets the caption text on the column's header cell. (Inherited from DataGridViewColumn)
Public Property | Index | Gets the relative position of the band within the DataGridView control. (Inherited from DataGridViewBand)
Public Property | InheritedAutoSizeMode | Gets the sizing mode in effect for the column. (Inherited from DataGridViewColumn)
Public Property | InheritedStyle | Gets the cell style currently applied to the column. (Inherited from DataGridViewColumn)
Public Property | IsDataBound | Gets a value indicating whether the column is bound to a data source. (Inherited from DataGridViewColumn)
Public Property | MaxInputLength | Gets or sets the maximum number of characters that can be entered into the text box.
Public Property | MinimumWidth | Gets or sets the minimum width, in pixels, of the column. (Inherited from DataGridViewColumn)
Public Property | Name | Gets or sets the name of the column. (Inherited from DataGridViewColumn)
Public Property | ReadOnly | Gets or sets a value indicating whether the user can edit the column's cells. (Inherited from DataGridViewColumn)
Public Property | Resizable | Gets or sets a value indicating whether the column is resizable. (Inherited from DataGridViewColumn)
Public Property | Selected | Gets or sets a value indicating whether the band is in a selected user interface (UI) state. (Inherited from DataGridViewBand)
Public Property | Site | Gets or sets the site of the column. (Inherited from DataGridViewColumn)
Public Property | SortMode | Gets or sets the sort mode for the column.
Public Property | State | Gets the user interface (UI) state of the element. (Inherited from DataGridViewElement)
Public Property | Tag | Gets or sets the object that contains data to associate with the band. (Inherited from DataGridViewBand)
Public Property | ToolTipText | Gets or sets the text used for ToolTips. (Inherited from DataGridViewColumn)
Public Property | ValueType | Gets or sets the data type of the values in the column's cells. (Inherited from DataGridViewColumn)
Public Property | Visible | Gets or sets a value indicating whether the column is visible. (Inherited from DataGridViewColumn)
Public Property | Width | Gets or sets the current width of the column. (Inherited from DataGridViewColumn)
Top

Protected Properties

 | Name | Description
Protected Property | HeaderCellCore | Gets or sets the header cell of the DataGridViewBand. (Inherited from DataGridViewBand)
Protected Property | IsRow | Gets a value indicating whether the band represents a row. (Inherited from DataGridViewBand)
Protected Property | MemberID | (Inherited from DataGridViewColumn)
Protected Property | TagName | (Inherited from DataGridViewElement)
Protected Property | TypeName | Overridden.
Top

Public Methods

 | Name | Description
Public Method | Clone | Creates an exact copy of this band. (Inherited from DataGridViewBand)
Public Method | Dispose | Overloaded. Releases all resources used by the DataGridViewBand. (Inherited from DataGridViewBand)
Public Method | GetPreferredWidth | Calculates the ideal width of the column based on the specified criteria. (Inherited from DataGridViewColumn)
Public Method | ToString | Overridden.
Public Method | Update | Overloaded. Full updates of this instance. (Inherited from DataGridViewElement)
Top

Protected Methods

 | Name | Description
Protected Method | CloneInternal | (Inherited from DataGridViewColumn)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from DataGridViewElement)
Protected Method | IsDirty | Determines whether the specified component is dirty. (Inherited from DataGridViewElement)
Protected Method | IsDirtyAttributes | Overloaded. Determines whether the specified component is dirty. (Inherited from DataGridViewElement)
Protected Method | OnDataGridViewChanged | Called when the band is associated with a different DataGridView. (Inherited from DataGridViewBand)
Protected Method | RaiseCellClick | Raises the DataGridView.CellClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellContentClick | Raises the DataGridView.CellContentClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellContentDoubleClick | Raises the DataGridView.CellContentDoubleClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellValueChanged | Raises the CellValueChanged event. (Inherited from DataGridViewElement)
Protected Method | RaiseDataError | Raises the DataError event. (Inherited from DataGridViewElement)
Protected Method | RaiseMouseWheel | Raises the MouseWheel event. (Inherited from DataGridViewElement)
Protected Method | RenderAttributes | (Inherited from DataGridViewColumn)
Protected Method | RenderComponent | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from DataGridViewElement)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from DataGridViewElement)
Protected Method | RenderComponents | Renders the column's inner components (Inherited from DataGridViewColumn)
Protected Method | RenderUpdatedAttributes | Renders the updated attributes (Inherited from DataGridViewElement)
Protected Method | UpdateParams | Overloaded. Updates only the parameters of this instance. (Inherited from DataGridViewElement)
Top

Public Events

 | Name | Description
Public Event | Disposed | Occurs when the DataGridViewColumn is disposed. (Inherited from DataGridViewColumn)
Top

See Also

Reference

DataGridViewTextBoxColumn Class
Gizmox.WebGUI.Forms Namespace


DataGridViewTextBoxColumn Constructor

[image]
Gizmox.WebGUI.Forms
DataGridViewTextBoxColumn Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewTextBoxColumn Class : DataGridViewTextBoxColumn Constructor

Initializes a new instance of the DataGridViewTextBoxColumn class to the default state.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewTextBoxColumn()
C#
public DataGridViewTextBoxColumn()
Managed Extensions for C++
public: DataGridViewTextBoxColumn();
C++/CLI
public:
DataGridViewTextBoxColumn();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewTextBoxColumn Class
DataGridViewTextBoxColumn Members


DataGridViewTextBoxColumn Class Methods

[image]
Gizmox.WebGUI.Forms
DataGridViewTextBoxColumn Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewTextBoxColumn Class

For a list of all members of this type, see DataGridViewTextBoxColumn members.

Public Methods

 | Name | Description
Public Method | Clone | Creates an exact copy of this band. (Inherited from DataGridViewBand)
Public Method | Dispose | Overloaded. Releases all resources used by the DataGridViewBand. (Inherited from DataGridViewBand)
Public Method | GetPreferredWidth | Calculates the ideal width of the column based on the specified criteria. (Inherited from DataGridViewColumn)
Public Method | ToString | Overridden.
Public Method | Update | Overloaded. Full updates of this instance. (Inherited from DataGridViewElement)
Top

Protected Methods

 | Name | Description
Protected Method | CloneInternal | (Inherited from DataGridViewColumn)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from DataGridViewElement)
Protected Method | IsDirty | Determines whether the specified component is dirty. (Inherited from DataGridViewElement)
Protected Method | IsDirtyAttributes | Overloaded. Determines whether the specified component is dirty. (Inherited from DataGridViewElement)
Protected Method | OnDataGridViewChanged | Called when the band is associated with a different DataGridView. (Inherited from DataGridViewBand)
Protected Method | RaiseCellClick | Raises the DataGridView.CellClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellContentClick | Raises the DataGridView.CellContentClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellContentDoubleClick | Raises the DataGridView.CellContentDoubleClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellValueChanged | Raises the CellValueChanged event. (Inherited from DataGridViewElement)
Protected Method | RaiseDataError | Raises the DataError event. (Inherited from DataGridViewElement)
Protected Method | RaiseMouseWheel | Raises the MouseWheel event. (Inherited from DataGridViewElement)
Protected Method | RenderAttributes | (Inherited from DataGridViewColumn)
Protected Method | RenderComponent | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from DataGridViewElement)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from DataGridViewElement)
Protected Method | RenderComponents | Renders the column's inner components (Inherited from DataGridViewColumn)
Protected Method | RenderUpdatedAttributes | Renders the updated attributes (Inherited from DataGridViewElement)
Protected Method | UpdateParams | Overloaded. Updates only the parameters of this instance. (Inherited from DataGridViewElement)
Top

See Also

Reference

DataGridViewTextBoxColumn Class
Gizmox.WebGUI.Forms Namespace


ToString Method

[image]
Gizmox.WebGUI.Forms
ToString Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewTextBoxColumn Class : ToString Method

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewTextBoxColumn
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewTextBoxColumn Class
DataGridViewTextBoxColumn Members


DataGridViewTextBoxColumn Class Properties

[image]
Gizmox.WebGUI.Forms
DataGridViewTextBoxColumn Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewTextBoxColumn Class

For a list of all members of this type, see DataGridViewTextBoxColumn members.

Public Properties

 | Name | Description
Public Property | AutoSizeMode | Gets or sets the mode by which the column automatically adjusts its width. (Inherited from DataGridViewColumn)
Public Property | CellTemplate | Overridden. Gets or sets the template used to model cell appearance.
Public Property | CellType | Gets the run-time type of the cell template. (Inherited from DataGridViewColumn)
Public Property | DataGridView | Gets the DataGridView control associated with this element. (Inherited from DataGridViewElement)
Public Property | DataPropertyName | Gets or sets the name of the data source property or database column to which the DataGridViewColumn is bound. (Inherited from DataGridViewColumn)
Public Property | DefaultCellStyle | Gets or sets the column's default cell style. (Inherited from DataGridViewColumn)
Public Property | DefaultHeaderCellType | Gets or sets the run-time type of the default header cell. (Inherited from DataGridViewBand)
Public Property | Displayed | Gets a value indicating whether the band is currently displayed onscreen. (Inherited from DataGridViewBand)
Public Property | DisplayIndex | Gets or sets the display order of the column relative to the currently displayed columns. (Inherited from DataGridViewColumn)
Public Property | DividerWidth | Gets or sets the width, in pixels, of the column divider. (Inherited from DataGridViewColumn)
Public Property | FillWeight | Gets or sets a value that represents the width of the column when it is in fill mode relative to the widths of other fill-mode columns in the control. (Inherited from DataGridViewColumn)
Public Property | Frozen | Gets or sets a value indicating whether a column will move when a user scrolls the DataGridView control horizontally. (Inherited from DataGridViewColumn)
Public Property | HasDefaultCellStyle | Gets a value indicating whether the DataGridViewBand.DefaultCellStyle property has been set. (Inherited from DataGridViewBand)
Public Property | HeaderCell | Gets or sets the DataGridViewColumnHeaderCell that represents the column header. (Inherited from DataGridViewColumn)
Public Property | HeaderText | Gets or sets the caption text on the column's header cell. (Inherited from DataGridViewColumn)
Public Property | Index | Gets the relative position of the band within the DataGridView control. (Inherited from DataGridViewBand)
Public Property | InheritedAutoSizeMode | Gets the sizing mode in effect for the column. (Inherited from DataGridViewColumn)
Public Property | InheritedStyle | Gets the cell style currently applied to the column. (Inherited from DataGridViewColumn)
Public Property | IsDataBound | Gets a value indicating whether the column is bound to a data source. (Inherited from DataGridViewColumn)
Public Property | MaxInputLength | Gets or sets the maximum number of characters that can be entered into the text box.
Public Property | MinimumWidth | Gets or sets the minimum width, in pixels, of the column. (Inherited from DataGridViewColumn)
Public Property | Name | Gets or sets the name of the column. (Inherited from DataGridViewColumn)
Public Property | ReadOnly | Gets or sets a value indicating whether the user can edit the column's cells. (Inherited from DataGridViewColumn)
Public Property | Resizable | Gets or sets a value indicating whether the column is resizable. (Inherited from DataGridViewColumn)
Public Property | Selected | Gets or sets a value indicating whether the band is in a selected user interface (UI) state. (Inherited from DataGridViewBand)
Public Property | Site | Gets or sets the site of the column. (Inherited from DataGridViewColumn)
Public Property | SortMode | Gets or sets the sort mode for the column.
Public Property | State | Gets the user interface (UI) state of the element. (Inherited from DataGridViewElement)
Public Property | Tag | Gets or sets the object that contains data to associate with the band. (Inherited from DataGridViewBand)
Public Property | ToolTipText | Gets or sets the text used for ToolTips. (Inherited from DataGridViewColumn)
Public Property | ValueType | Gets or sets the data type of the values in the column's cells. (Inherited from DataGridViewColumn)
Public Property | Visible | Gets or sets a value indicating whether the column is visible. (Inherited from DataGridViewColumn)
Public Property | Width | Gets or sets the current width of the column. (Inherited from DataGridViewColumn)
Top

Protected Properties

 | Name | Description
Protected Property | HeaderCellCore | Gets or sets the header cell of the DataGridViewBand. (Inherited from DataGridViewBand)
Protected Property | IsRow | Gets a value indicating whether the band represents a row. (Inherited from DataGridViewBand)
Protected Property | MemberID | (Inherited from DataGridViewColumn)
Protected Property | TagName | (Inherited from DataGridViewElement)
Protected Property | TypeName | Overridden.
Top

See Also

Reference

DataGridViewTextBoxColumn Class
Gizmox.WebGUI.Forms Namespace


CellTemplate Property

[image]
Gizmox.WebGUI.Forms
CellTemplate Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewTextBoxColumn Class : CellTemplate Property

Gets or sets the template used to model cell appearance.

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
Public Overrides Property CellTemplate As DataGridViewCell
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewTextBoxColumn
Dim value As DataGridViewCell

instance.CellTemplate = value

value = instance.CellTemplate
C#
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public override DataGridViewCell CellTemplate {get; set;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public: __property DataGridViewCell* get_CellTemplate() override;
public: __property void set_CellTemplate(
   DataGridViewCell* value
) override;
C++/CLI
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public:
property DataGridViewCell^ CellTemplate {
   DataGridViewCell^ get() override;
   void set (DataGridViewCell^value) override;
}

Exceptions

Exception | Description
InvalidCastException | The set type is not compatible with type DataGridViewTextBoxCell.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewTextBoxColumn Class
DataGridViewTextBoxColumn Members


MaxInputLength Property

[image]
Gizmox.WebGUI.Forms
MaxInputLength Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewTextBoxColumn Class : MaxInputLength Property

Gets or sets the maximum number of characters that can be entered into the text box.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Specifies the maximum number of characters that can be entered into the text box.")>
<DefaultValueAttribute()>
<SRCategoryAttribute("Behavior")>
Public Property MaxInputLength As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewTextBoxColumn
Dim value As Integer

instance.MaxInputLength = value

value = instance.MaxInputLength
C#
[SRDescriptionAttribute("Specifies the maximum number of characters that can be entered into the text box.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
public int MaxInputLength {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Specifies the maximum number of characters that can be entered into the text box.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
public: __property int get_MaxInputLength();
public: __property void set_MaxInputLength(
   int value
);
C++/CLI
[SRDescriptionAttribute("Specifies the maximum number of characters that can be entered into the text box.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
public:
property int MaxInputLength {
   int get();
   void set (intvalue);
}

Exceptions

Exception | Description
InvalidOperationException | The value of the CellTemplate property is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewTextBoxColumn Class
DataGridViewTextBoxColumn Members


SortMode Property

[image]
Gizmox.WebGUI.Forms
SortMode Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewTextBoxColumn Class : SortMode Property

Gets or sets the sort mode for the column.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property SortMode As DataGridViewColumnSortMode
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewTextBoxColumn
Dim value As DataGridViewColumnSortMode

instance.SortMode = value

value = instance.SortMode
C#
[DefaultValueAttribute()]
public DataGridViewColumnSortMode SortMode {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property DataGridViewColumnSortMode get_SortMode();
public: __property void set_SortMode(
   DataGridViewColumnSortMode value
);
C++/CLI
[DefaultValueAttribute()]
public:
property DataGridViewColumnSortMode SortMode {
   DataGridViewColumnSortMode get();
   void set (DataGridViewColumnSortModevalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewTextBoxColumn Class
DataGridViewTextBoxColumn Members


TypeName Property

[image]
Gizmox.WebGUI.Forms
TypeName Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewTextBoxColumn Class : TypeName Property

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property TypeName As String
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewTextBoxColumn
Dim value As String

value = instance.TypeName
C#
protected override string TypeName {get;}
Managed Extensions for C++
protected: __property string* get_TypeName() override;
C++/CLI
protected:
property String^ TypeName {
   String^ get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewTextBoxColumn Class
DataGridViewTextBoxColumn Members


DataGridViewTextBoxEditingControl Class

[image]
Gizmox.WebGUI.Forms
DataGridViewTextBoxEditingControl Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewTextBoxEditingControl Class

Not Implemented. Represents a text box control that can be hosted in a DataGridViewTextBoxCell.

Object Model

Syntax

Visual Basic (Declaration)
<ComVisibleAttribute(True)>
<ClassInterfaceAttribute()>
<ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")>
Public Class DataGridViewTextBoxEditingControl
   Inherits TextBox
   Implements IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IDataGridViewEditingControl, IArrangedElement
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewTextBoxEditingControl
C#
[ComVisibleAttribute(true)]
[ClassInterfaceAttribute()]
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
public class DataGridViewTextBoxEditingControl : TextBox, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IDataGridViewEditingControl, IArrangedElement
Managed Extensions for C++
[ComVisibleAttribute(true)]
[ClassInterfaceAttribute()]
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
public __gc class DataGridViewTextBoxEditingControl : public TextBox, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IDataGridViewEditingControl, IArrangedElement
C++/CLI
[ComVisibleAttribute(true)]
[ClassInterfaceAttribute()]
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
public ref class DataGridViewTextBoxEditingControl : public TextBox, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IDataGridViewEditingControl, IArrangedElement

Remarks

The DataGridViewTextBoxEditingControl class is a specialized type of TextBox control that implements the IDataGridViewEditingControl interface, allowing it to be hosted in a DataGridViewTextBoxCell when the cell is in edit mode.

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.TextBoxBase
Gizmox.WebGUI.Forms.TextBox
Gizmox.WebGUI.Forms.DataGridViewTextBoxEditingControl

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

DataGridViewTextBoxEditingControl Members
Gizmox.WebGUI.Forms Namespace


DataGridViewTextBoxEditingControl Class Members

[image]
Gizmox.WebGUI.Forms
DataGridViewTextBoxEditingControl Class Members
See Also Fields Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewTextBoxEditingControl Class

The following tables list the members exposed by DataGridViewTextBoxEditingControl.

Public Constructors

 | Name | Description
Public Constructor | DataGridViewTextBoxEditingControl Constructor |
Top

Protected Fields

 | Name | Description
Protected Field | menmScrollBars | Member which holds the scrollbars mode. (Inherited from TextBox)
Top

Public Properties

 | Name | Description
Public Property | AcceptsReturn | Gets or sets a value indicating whether pressing ENTER in a multiline TextBox control creates a new line of text in the control or activates the default button for the form. (Inherited from TextBox)
Public Property | AcceptsTab | (Inherited from TextBoxBase)
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | (Inherited from TextBox)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | CanUndo | Gets a value indicating whether the user can undo the previous operation in a text box control. (Inherited from TextBox)
Public Property | CharacterCasing | Indicates if all characters should be left alone or converted to uppercase or lowercase (Inherited from TextBox)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DragTargets | Gets a value indicating whether this instance is dragable. (Inherited from TextBox)
Public Property | EditingControlDataGridView |
Public Property | EditingControlFormattedValue |
Public Property | EditingControlRowIndex |
Public Property | EditingControlValueChanged |
Public Property | EditingPanelCursor |
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Lines | (Inherited from TextBoxBase)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MaxLength | (Inherited from TextBoxBase)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Multiline | Gets or sets a value indicating whether text box is multi line. (Inherited from TextBoxBase)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PasswordChar | Gets or sets the password charecter. (Inherited from TextBox)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | ReadOnly | Gets or sets a value indicating whether [read only]. (Inherited from TextBoxBase)
Public Property | RepositionEditingControlOnValueChange |
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | ScrollBars | Gets or sets which scroll bars should appear in a multiline TextBox control. (Inherited from TextBox)
Public Property | SelectedText | Gets or sets a value indicating the currently selected text in the control. (Inherited from TextBoxBase)
Public Property | SelectionLength | Gets or sets the number of characters selected in the text box. (Inherited from TextBoxBase)
Public Property | SelectionStart | Gets or sets the starting point of text selected in the text box. (Inherited from TextBoxBase)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Control)
Public Property | TextAlign | Gets or sets how text is aligned in a TextBox control. (Inherited from TextBox)
Public Property | TextLength | Gets the length of text in the control. (Inherited from TextBoxBase)
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | Validator | Gets or sets the text box validator. (Inherited from TextBox)
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Public Property | WordWrap | (Inherited from TextBoxBase)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from TextBox)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from TextBox)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

Public Methods

 | Name | Description
Public Method | AppendText | Appends text to the current text of a text box. (Inherited from TextBoxBase)
Public Method | ApplyCellStyleToEditingControl |
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Clear | Clears all text from the text box control. (Inherited from TextBoxBase)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | Copy | Copies the current selection in the text box to the Clipboard. (Inherited from TextBoxBase)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Cut | Moves the current selection in the text box to the Clipboard. (Inherited from TextBoxBase)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | EditingControlWantsInputKey |
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetEditingControlFormattedValue |
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | Paste | Replaces the current selection in the text box with the contents of the Clipboard. (Inherited from TextBoxBase)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | PrepareEditingControlForEdit |
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | ScrollToCaret | Scrolls the contents of the control to the current caret position. (Inherited from TextBoxBase)
Public Method | Select | Overloaded. Selects a range of text in the text box. (Inherited from TextBoxBase)
Public Method | SelectAll | Selects all text in the text box. (Inherited from TextBoxBase)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | Undo | Undoes the last edit operation in the text box. (Inherited from TextBox)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from TextBox)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetClipboardContent | Get content to be added to the clip board (Inherited from TextBox)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from TextBox)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from Control)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | InvokeSelection | Implements the actual client side selection (Inherited from TextBox)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnTextChanged | Overridden.
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Control)
Protected Method | RenderAttributes | Renders the current control attributes. (Inherited from TextBox)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | Render control params (Inherited from TextBoxBase)
Protected Method | RenderValue | (Inherited from TextBox)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetClipboardContent | Set the value from the clip board (Inherited from TextBox)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | EnterKeyDown | Occurs on enter key down only on single line. (Inherited from TextBox)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

DataGridViewTextBoxEditingControl Class
Gizmox.WebGUI.Forms Namespace


DataGridViewTextBoxEditingControl Constructor

[image]
Gizmox.WebGUI.Forms
DataGridViewTextBoxEditingControl Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewTextBoxEditingControl Class : DataGridViewTextBoxEditingControl Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewTextBoxEditingControl()
C#
public DataGridViewTextBoxEditingControl()
Managed Extensions for C++
public: DataGridViewTextBoxEditingControl();
C++/CLI
public:
DataGridViewTextBoxEditingControl();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewTextBoxEditingControl Class
DataGridViewTextBoxEditingControl Members


DataGridViewTextBoxEditingControl Class Methods

[image]
Gizmox.WebGUI.Forms
DataGridViewTextBoxEditingControl Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewTextBoxEditingControl Class

For a list of all members of this type, see DataGridViewTextBoxEditingControl members.

Public Methods

 | Name | Description
Public Method | AppendText | Appends text to the current text of a text box. (Inherited from TextBoxBase)
Public Method | ApplyCellStyleToEditingControl |
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Clear | Clears all text from the text box control. (Inherited from TextBoxBase)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | Copy | Copies the current selection in the text box to the Clipboard. (Inherited from TextBoxBase)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Cut | Moves the current selection in the text box to the Clipboard. (Inherited from TextBoxBase)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | EditingControlWantsInputKey |
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetEditingControlFormattedValue |
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | Paste | Replaces the current selection in the text box with the contents of the Clipboard. (Inherited from TextBoxBase)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | PrepareEditingControlForEdit |
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | ScrollToCaret | Scrolls the contents of the control to the current caret position. (Inherited from TextBoxBase)
Public Method | Select | Overloaded. Selects a range of text in the text box. (Inherited from TextBoxBase)
Public Method | SelectAll | Selects all text in the text box. (Inherited from TextBoxBase)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | Undo | Undoes the last edit operation in the text box. (Inherited from TextBox)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from TextBox)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetClipboardContent | Get content to be added to the clip board (Inherited from TextBox)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from TextBox)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from Control)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | InvokeSelection | Implements the actual client side selection (Inherited from TextBox)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnTextChanged | Overridden.
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Control)
Protected Method | RenderAttributes | Renders the current control attributes. (Inherited from TextBox)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | Render control params (Inherited from TextBoxBase)
Protected Method | RenderValue | (Inherited from TextBox)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetClipboardContent | Set the value from the clip board (Inherited from TextBox)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

See Also

Reference

DataGridViewTextBoxEditingControl Class
Gizmox.WebGUI.Forms Namespace


ApplyCellStyleToEditingControl Method

[image]
Gizmox.WebGUI.Forms
ApplyCellStyleToEditingControl Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewTextBoxEditingControl Class : ApplyCellStyleToEditingControl Method

dataGridViewCellStyle

Syntax

Visual Basic (Declaration)
Public Overridable Sub ApplyCellStyleToEditingControl( _
   ByVal dataGridViewCellStyle As DataGridViewCellStyle _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewTextBoxEditingControl
Dim dataGridViewCellStyle As DataGridViewCellStyle

instance.ApplyCellStyleToEditingControl(dataGridViewCellStyle)
C#
public virtual void ApplyCellStyleToEditingControl(
   DataGridViewCellStyle dataGridViewCellStyle
)
Managed Extensions for C++
public: virtual void ApplyCellStyleToEditingControl(
   DataGridViewCellStyle* dataGridViewCellStyle
)
C++/CLI
public:
virtual void ApplyCellStyleToEditingControl(
   DataGridViewCellStyle^ dataGridViewCellStyle
)

Parameters

dataGridViewCellStyle

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewTextBoxEditingControl Class
DataGridViewTextBoxEditingControl Members


EditingControlWantsInputKey Method

[image]
Gizmox.WebGUI.Forms
EditingControlWantsInputKey Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewTextBoxEditingControl Class : EditingControlWantsInputKey Method

keyData
dataGridViewWantsInputKey

Syntax

Visual Basic (Declaration)
Public Overridable Function EditingControlWantsInputKey( _
   ByVal keyData As Keys, _
   ByVal dataGridViewWantsInputKey As Boolean _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewTextBoxEditingControl
Dim keyData As Keys
Dim dataGridViewWantsInputKey As Boolean
Dim value As Boolean

value = instance.EditingControlWantsInputKey(keyData, dataGridViewWantsInputKey)
C#
public virtual bool EditingControlWantsInputKey(
   Keys keyData,
   bool dataGridViewWantsInputKey
)
Managed Extensions for C++
public: virtual bool EditingControlWantsInputKey(
   Keys keyData,
   bool dataGridViewWantsInputKey
)
C++/CLI
public:
virtual bool EditingControlWantsInputKey(
   Keys keyData,
   bool dataGridViewWantsInputKey
)

Parameters

keyData
dataGridViewWantsInputKey

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewTextBoxEditingControl Class
DataGridViewTextBoxEditingControl Members


GetEditingControlFormattedValue Method

[image]
Gizmox.WebGUI.Forms
GetEditingControlFormattedValue Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewTextBoxEditingControl Class : GetEditingControlFormattedValue Method

context

Syntax

Visual Basic (Declaration)
Public Overridable Function GetEditingControlFormattedValue( _
   ByVal context As DataGridViewDataErrorContexts _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewTextBoxEditingControl
Dim context As DataGridViewDataErrorContexts
Dim value As Object

value = instance.GetEditingControlFormattedValue(context)
C#
public virtual object GetEditingControlFormattedValue(
   DataGridViewDataErrorContexts context
)
Managed Extensions for C++
public: virtual Object* GetEditingControlFormattedValue(
   DataGridViewDataErrorContexts context
)
C++/CLI
public:
virtual Object^ GetEditingControlFormattedValue(
   DataGridViewDataErrorContexts context
)

Parameters

context

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewTextBoxEditingControl Class
DataGridViewTextBoxEditingControl Members


OnTextChanged Method

[image]
Gizmox.WebGUI.Forms
OnTextChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewTextBoxEditingControl Class : OnTextChanged Method

e

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnTextChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewTextBoxEditingControl
Dim e As EventArgs

instance.OnTextChanged(e)
C#
protected override void OnTextChanged(
   EventArgs e
)
Managed Extensions for C++
protected: void OnTextChanged(
   EventArgs* e
) override
C++/CLI
protected:
void OnTextChanged(
   EventArgs^ e
) override

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewTextBoxEditingControl Class
DataGridViewTextBoxEditingControl Members


PrepareEditingControlForEdit Method

[image]
Gizmox.WebGUI.Forms
PrepareEditingControlForEdit Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewTextBoxEditingControl Class : PrepareEditingControlForEdit Method

selectAll

Syntax

Visual Basic (Declaration)
Public Overridable Sub PrepareEditingControlForEdit( _
   ByVal selectAll As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewTextBoxEditingControl
Dim selectAll As Boolean

instance.PrepareEditingControlForEdit(selectAll)
C#
public virtual void PrepareEditingControlForEdit(
   bool selectAll
)
Managed Extensions for C++
public: virtual void PrepareEditingControlForEdit(
   bool selectAll
)
C++/CLI
public:
virtual void PrepareEditingControlForEdit(
   bool selectAll
)

Parameters

selectAll

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewTextBoxEditingControl Class
DataGridViewTextBoxEditingControl Members


DataGridViewTextBoxEditingControl Class Properties

[image]
Gizmox.WebGUI.Forms
DataGridViewTextBoxEditingControl Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewTextBoxEditingControl Class

For a list of all members of this type, see DataGridViewTextBoxEditingControl members.

Public Properties

 | Name | Description
Public Property | AcceptsReturn | Gets or sets a value indicating whether pressing ENTER in a multiline TextBox control creates a new line of text in the control or activates the default button for the form. (Inherited from TextBox)
Public Property | AcceptsTab | (Inherited from TextBoxBase)
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | (Inherited from TextBox)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | CanUndo | Gets a value indicating whether the user can undo the previous operation in a text box control. (Inherited from TextBox)
Public Property | CharacterCasing | Indicates if all characters should be left alone or converted to uppercase or lowercase (Inherited from TextBox)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DragTargets | Gets a value indicating whether this instance is dragable. (Inherited from TextBox)
Public Property | EditingControlDataGridView |
Public Property | EditingControlFormattedValue |
Public Property | EditingControlRowIndex |
Public Property | EditingControlValueChanged |
Public Property | EditingPanelCursor |
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Lines | (Inherited from TextBoxBase)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MaxLength | (Inherited from TextBoxBase)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Multiline | Gets or sets a value indicating whether text box is multi line. (Inherited from TextBoxBase)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PasswordChar | Gets or sets the password charecter. (Inherited from TextBox)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | ReadOnly | Gets or sets a value indicating whether [read only]. (Inherited from TextBoxBase)
Public Property | RepositionEditingControlOnValueChange |
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | ScrollBars | Gets or sets which scroll bars should appear in a multiline TextBox control. (Inherited from TextBox)
Public Property | SelectedText | Gets or sets a value indicating the currently selected text in the control. (Inherited from TextBoxBase)
Public Property | SelectionLength | Gets or sets the number of characters selected in the text box. (Inherited from TextBoxBase)
Public Property | SelectionStart | Gets or sets the starting point of text selected in the text box. (Inherited from TextBoxBase)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Control)
Public Property | TextAlign | Gets or sets how text is aligned in a TextBox control. (Inherited from TextBox)
Public Property | TextLength | Gets the length of text in the control. (Inherited from TextBoxBase)
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | Validator | Gets or sets the text box validator. (Inherited from TextBox)
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Public Property | WordWrap | (Inherited from TextBoxBase)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from TextBox)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from TextBox)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

See Also

Reference

DataGridViewTextBoxEditingControl Class
Gizmox.WebGUI.Forms Namespace


EditingControlDataGridView Property

[image]
Gizmox.WebGUI.Forms
EditingControlDataGridView Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewTextBoxEditingControl Class : EditingControlDataGridView Property

Syntax

Visual Basic (Declaration)
Public Overridable Property EditingControlDataGridView As DataGridView
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewTextBoxEditingControl
Dim value As DataGridView

instance.EditingControlDataGridView = value

value = instance.EditingControlDataGridView
C#
public virtual DataGridView EditingControlDataGridView {get; set;}
Managed Extensions for C++
public: __property virtual DataGridView* get_EditingControlDataGridView();
public: __property virtual void set_EditingControlDataGridView(
   DataGridView* value
);
C++/CLI
public:
virtual property DataGridView^ EditingControlDataGridView {
   DataGridView^ get();
   void set (DataGridView^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewTextBoxEditingControl Class
DataGridViewTextBoxEditingControl Members


EditingControlFormattedValue Property

[image]
Gizmox.WebGUI.Forms
EditingControlFormattedValue Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewTextBoxEditingControl Class : EditingControlFormattedValue Property

Syntax

Visual Basic (Declaration)
Public Overridable Property EditingControlFormattedValue As Object
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewTextBoxEditingControl
Dim value As Object

instance.EditingControlFormattedValue = value

value = instance.EditingControlFormattedValue
C#
public virtual object EditingControlFormattedValue {get; set;}
Managed Extensions for C++
public: __property virtual Object* get_EditingControlFormattedValue();
public: __property virtual void set_EditingControlFormattedValue(
   Object* value
);
C++/CLI
public:
virtual property Object^ EditingControlFormattedValue {
   Object^ get();
   void set (Object^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewTextBoxEditingControl Class
DataGridViewTextBoxEditingControl Members


EditingControlRowIndex Property

[image]
Gizmox.WebGUI.Forms
EditingControlRowIndex Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewTextBoxEditingControl Class : EditingControlRowIndex Property

Syntax

Visual Basic (Declaration)
Public Overridable Property EditingControlRowIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewTextBoxEditingControl
Dim value As Integer

instance.EditingControlRowIndex = value

value = instance.EditingControlRowIndex
C#
public virtual int EditingControlRowIndex {get; set;}
Managed Extensions for C++
public: __property virtual int get_EditingControlRowIndex();
public: __property virtual void set_EditingControlRowIndex(
   int value
);
C++/CLI
public:
virtual property int EditingControlRowIndex {
   int get();
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewTextBoxEditingControl Class
DataGridViewTextBoxEditingControl Members


EditingControlValueChanged Property

[image]
Gizmox.WebGUI.Forms
EditingControlValueChanged Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewTextBoxEditingControl Class : EditingControlValueChanged Property

Syntax

Visual Basic (Declaration)
Public Overridable Property EditingControlValueChanged As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewTextBoxEditingControl
Dim value As Boolean

instance.EditingControlValueChanged = value

value = instance.EditingControlValueChanged
C#
public virtual bool EditingControlValueChanged {get; set;}
Managed Extensions for C++
public: __property virtual bool get_EditingControlValueChanged();
public: __property virtual void set_EditingControlValueChanged(
   bool value
);
C++/CLI
public:
virtual property bool EditingControlValueChanged {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewTextBoxEditingControl Class
DataGridViewTextBoxEditingControl Members


EditingPanelCursor Property

[image]
Gizmox.WebGUI.Forms
EditingPanelCursor Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewTextBoxEditingControl Class : EditingPanelCursor Property

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property EditingPanelCursor As Cursor
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewTextBoxEditingControl
Dim value As Cursor

value = instance.EditingPanelCursor
C#
public virtual Cursor EditingPanelCursor {get;}
Managed Extensions for C++
public: __property virtual Cursor* get_EditingPanelCursor();
C++/CLI
public:
virtual property Cursor^ EditingPanelCursor {
   Cursor^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewTextBoxEditingControl Class
DataGridViewTextBoxEditingControl Members


RepositionEditingControlOnValueChange Property

[image]
Gizmox.WebGUI.Forms
RepositionEditingControlOnValueChange Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewTextBoxEditingControl Class : RepositionEditingControlOnValueChange Property

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property RepositionEditingControlOnValueChange As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewTextBoxEditingControl
Dim value As Boolean

value = instance.RepositionEditingControlOnValueChange
C#
public virtual bool RepositionEditingControlOnValueChange {get;}
Managed Extensions for C++
public: __property virtual bool get_RepositionEditingControlOnValueChange();
C++/CLI
public:
virtual property bool RepositionEditingControlOnValueChange {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewTextBoxEditingControl Class
DataGridViewTextBoxEditingControl Members


DataGridViewTopLeftHeaderCell Class

[image]
Gizmox.WebGUI.Forms
DataGridViewTopLeftHeaderCell Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewTopLeftHeaderCell Class

Represents the cell in the top left corner of the DataGridView that sits above the row headers and to the left of the column headers.

Object Model

Syntax

Visual Basic (Declaration)
Public Class DataGridViewTopLeftHeaderCell
   Inherits DataGridViewColumnHeaderCell
   Implements IRenderableComponentMember
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewTopLeftHeaderCell
C#
public class DataGridViewTopLeftHeaderCell : DataGridViewColumnHeaderCell, IRenderableComponentMember
Managed Extensions for C++
public __gc class DataGridViewTopLeftHeaderCell : public DataGridViewColumnHeaderCell, IRenderableComponentMember
C++/CLI
public ref class DataGridViewTopLeftHeaderCell : public DataGridViewColumnHeaderCell, IRenderableComponentMember

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.DataGridViewElement
Gizmox.WebGUI.Forms.DataGridViewCell
Gizmox.WebGUI.Forms.DataGridViewHeaderCell
Gizmox.WebGUI.Forms.DataGridViewColumnHeaderCell
Gizmox.WebGUI.Forms.DataGridViewTopLeftHeaderCell

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

DataGridViewTopLeftHeaderCell Members
Gizmox.WebGUI.Forms Namespace


DataGridViewTopLeftHeaderCell Class Members

[image]
Gizmox.WebGUI.Forms
DataGridViewTopLeftHeaderCell Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewTopLeftHeaderCell Class

The following tables list the members exposed by DataGridViewTopLeftHeaderCell.

Public Constructors

 | Name | Description
Public Constructor | DataGridViewTopLeftHeaderCell Constructor |
Top

Public Properties

 | Name | Description
Public Property | ColumnIndex | Gets the column index for this cell. (Inherited from DataGridViewCell)
Public Property | ContentBounds | (Inherited from DataGridViewCell)
Public Property | DataGridView | Gets the DataGridView control associated with this element. (Inherited from DataGridViewElement)
Public Property | DefaultNewRowValue | Gets the default value for a cell in the row for new records. (Inherited from DataGridViewCell)
Public Property | Displayed | (Inherited from DataGridViewHeaderCell)
Public Property | EditedFormattedValue | Gets the current, formatted value of the cell, regardless of whether the cell is in edit mode and the value has not been committed. (Inherited from DataGridViewCell)
Public Property | EditType | Gets the type of the cell's hosted editing control. (Inherited from DataGridViewCell)
Public Property | ErrorIconBounds | (Inherited from DataGridViewCell)
Public Property | ErrorText | Gets or sets the text describing an error condition associated with the cell. (Inherited from DataGridViewCell)
Public Property | FormattedValue | Gets the value of the cell as formatted for display. (Inherited from DataGridViewCell)
Public Property | FormattedValueType | Gets the type of the formatted value of the cell. (Inherited from DataGridViewHeaderCell)
Public Property | Frozen | Gets a value indicating whether the cell is frozen. (Inherited from DataGridViewHeaderCell)
Public Property | HasStyle | Gets a value indicating whether the DataGridViewCell.Style property has been set. (Inherited from DataGridViewCell)
Public Property | InheritedState | Gets the current state of the cell as inherited from the state of its row and column. (Inherited from DataGridViewCell)
Public Property | InheritedStyle | Gets the style currently applied to the cell. (Inherited from DataGridViewCell)
Public Property | IsInEditMode | Gets a value indicating whether this cell is currently being edited. (Inherited from DataGridViewCell)
Public Property | OwningColumn | Gets the column that contains this cell. (Inherited from DataGridViewCell)
Public Property | OwningRow | Gets the row that contains this cell. (Inherited from DataGridViewCell)
Public Property | PreferredSize | Gets the size, in pixels, of a rectangular area into which the cell can fit. (Inherited from DataGridViewCell)
Public Property | ReadOnly | Gets a value indicating whether the header cell is read-only. (Inherited from DataGridViewHeaderCell)
Public Property | Resizable | Gets a value indicating whether the cell is resizable. (Inherited from DataGridViewHeaderCell)
Public Property | RowIndex | Gets the index of the cell's parent row. (Inherited from DataGridViewCell)
Public Property | Selected | Gets or sets a value indicating whether the cell is selected. (Inherited from DataGridViewHeaderCell)
Public Property | Size | Gets the size of the cell. (Inherited from DataGridViewCell)
Public Property | SortGlyphDirection | Gets or sets a value indicating which sort glyph is displayed. (Inherited from DataGridViewColumnHeaderCell)
Public Property | State | Gets the user interface (UI) state of the element. (Inherited from DataGridViewElement)
Public Property | Style | Gets or sets the style for the cell. (Inherited from DataGridViewCell)
Public Property | Tag | Gets or sets the object that contains supplemental data about the cell. (Inherited from DataGridViewCell)
Public Property | ToolTipText | Gets or sets the ToolTip text associated with this cell. (Inherited from DataGridViewCell)
Public Property | Value | Gets or sets the value associated with this cell. (Inherited from DataGridViewCell)
Public Property | ValueType | Gets the type of the value stored in the cell. (Inherited from DataGridViewHeaderCell)
Public Property | Visible | Gets a value indicating whether or not the cell is visible. (Inherited from DataGridViewHeaderCell)
Top

Protected Properties

 | Name | Description
Protected Property | ButtonState | Gets the buttonlike visual state of the header cell. (Inherited from DataGridViewHeaderCell)
Protected Property | MemberID | (Inherited from DataGridViewCell)
Protected Property | TagName | (Inherited from DataGridViewElement)
Top

Public Methods

 | Name | Description
Public Method | AdjustCellBorderStyle | Modifies the input cell border style according to the specified criteria. (Inherited from DataGridViewCell)
Public Method | Clone | (Inherited from DataGridViewColumnHeaderCell)
Public Method | DetachEditingControl | Removes the cell's editing control from the DataGridView. (Inherited from DataGridViewCell)
Public Method | Dispose | Overloaded. Releases all resources used by the DataGridViewCell. (Inherited from DataGridViewCell)
Public Method | GetContentBounds | Overloaded. (Inherited from DataGridViewCell)
Public Method | GetEditedFormattedValue | Returns the current, formatted value of the cell, regardless of whether the cell is in edit mode and the value has not been committed. (Inherited from DataGridViewCell)
Public Method | GetInheritedState | Returns a value indicating the current state of the cell as inherited from the state of its row or column. (Inherited from DataGridViewHeaderCell)
Public Method | GetInheritedStyle | Gets the style applied to the cell. (Inherited from DataGridViewColumnHeaderCell)
Public Method | InitializeEditingControl | Initializes the control used to edit the cell. (Inherited from DataGridViewCell)
Public Method | KeyEntersEditMode | Determines if edit mode should be started based on the given key. (Inherited from DataGridViewCell)
Public Method | ParseFormattedValue | (Inherited from DataGridViewCell)
Public Method | PositionEditingControl | Sets the location and size of the editing control hosted by a cell in the DataGridView control. (Inherited from DataGridViewCell)
Public Method | PositionEditingPanel | (Inherited from DataGridViewCell)
Public Method | ToString | Overridden.
Public Method | Update | Overloaded. Full updates of this instance. (Inherited from DataGridViewElement)
Top

Protected Methods

 | Name | Description
Protected Method | BorderWidths | (Inherited from DataGridViewCell)
Protected Method | ClickUnsharesRow | Indicates whether the cell's row will be unshared when the cell is clicked. (Inherited from DataGridViewCell)
Protected Method | ContentClickUnsharesRow | Indicates whether the cell's row will be unshared when the cell's content is clicked. (Inherited from DataGridViewCell)
Protected Method | ContentDoubleClickUnsharesRow | Indicates whether the cell's row will be unshared when the cell's content is double-clicked. (Inherited from DataGridViewCell)
Protected Method | DoubleClickUnsharesRow | Indicates whether the cell's row will be unshared when the cell is double-clicked. (Inherited from DataGridViewCell)
Protected Method | EnterUnsharesRow | Indicates whether the parent row will be unshared when the focus moves to the cell. (Inherited from DataGridViewCell)
Protected Method | GetClipboardContent | Retrieves the formatted value of the cell to copy to the Clipboard. (Inherited from DataGridViewColumnHeaderCell)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from DataGridViewElement)
Protected Method | GetDefaultHorizontalAlignment | Gets the horizontal alignment. (Inherited from DataGridViewCell)
Protected Method | GetDefaultVerticalAlignment | Gets the vertical alignment. (Inherited from DataGridViewCell)
Protected Method | GetErrorIconBounds | (Inherited from DataGridViewCell)
Protected Method | GetErrorText | Returns a string that represents the error for the cell. (Inherited from DataGridViewCell)
Protected Method | GetFormattedValue | Gets the value of the cell as formatted for display. (Inherited from DataGridViewCell)
Protected Method | GetPreferredSize | Overloaded. Calculates the preferred size, in pixels, of the cell. (Inherited from DataGridViewCell)
Protected Method | GetSize | Gets the size of the cell. (Inherited from DataGridViewHeaderCell)
Protected Method | GetValue | Gets the value of the cell. (Inherited from DataGridViewColumnHeaderCell)
Protected Method | IsDirty | Determines whether the specified component is dirty. (Inherited from DataGridViewElement)
Protected Method | IsDirtyAttributes | Overloaded. Determines whether the specified component is dirty. (Inherited from DataGridViewElement)
Protected Method | KeyDownUnsharesRow | Indicates whether the parent row is unshared if the user presses a key while the focus is on the cell. (Inherited from DataGridViewCell)
Protected Method | KeyPressUnsharesRow | Indicates whether a row will be unshared if a key is pressed while a cell in the row has focus. (Inherited from DataGridViewCell)
Protected Method | KeyUpUnsharesRow | Indicates whether the parent row is unshared when the user releases a key while the focus is on the cell. (Inherited from DataGridViewCell)
Protected Method | LeaveUnsharesRow | Indicates whether a row will be unshared when the focus leaves a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseClickUnsharesRow | Indicates whether a row will be unshared if the user clicks a mouse button while the pointer is on a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseDoubleClickUnsharesRow | Indicates whether a row will be unshared if the user double-clicks a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseDownUnsharesRow | Indicates whether a row will be unshared when the user holds down a mouse button while the pointer is on a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseEnterUnsharesRow | Indicates whether a row will be unshared when the mouse pointer moves over a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseLeaveUnsharesRow | Indicates whether a row will be unshared when the mouse pointer leaves the row. (Inherited from DataGridViewCell)
Protected Method | MouseMoveUnsharesRow | Indicates whether a row will be unshared when the mouse pointer moves over a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseUpUnsharesRow | Indicates whether a row will be unshared when the user releases a mouse button while the pointer is on a cell in the row. (Inherited from DataGridViewCell)
Protected Method | OnClick | Called when the cell is clicked. (Inherited from DataGridViewCell)
Protected Method | OnContentClick | Called when the cell's contents are clicked. (Inherited from DataGridViewCell)
Protected Method | OnContentDoubleClick | Called when the cell's contents are double-clicked. (Inherited from DataGridViewCell)
Protected Method | OnDataGridViewChanged | Called when the DataGridViewElement.DataGridView property of the cell changes. (Inherited from DataGridViewCell)
Protected Method | OnDoubleClick | Called when the cell is double-clicked. (Inherited from DataGridViewCell)
Protected Method | OnEnter | Called when the focus moves to a cell. (Inherited from DataGridViewCell)
Protected Method | OnKeyDown | Called when a character key is pressed while the focus is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnKeyPress | Called when a key is pressed while the focus is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnKeyUp | Called when a character key is released while the focus is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnLeave | Called when the focus moves from a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseClick | Called when the user clicks a mouse button while the pointer is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseDoubleClick | Called when the user double-clicks a mouse button while the pointer is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseDown | Called when the user holds down a mouse button while the pointer is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseEnter | Called when the mouse pointer moves over a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseLeave | Called when the mouse pointer leaves the cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseMove | Called when the mouse pointer moves within a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseUp | Called when the user releases a mouse button while the pointer is on a cell. (Inherited from DataGridViewCell)
Protected Method | Paint | (Inherited from DataGridViewCell)
Protected Method | PaintErrorIcon | (Inherited from DataGridViewCell)
Protected Method | ProcessGatewayRequest | (Inherited from DataGridViewCell)
Protected Method | RaiseCellClick | Raises the DataGridView.CellClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellContentClick | Raises the DataGridView.CellContentClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellContentDoubleClick | Raises the DataGridView.CellContentDoubleClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellValueChanged | Raises the CellValueChanged event. (Inherited from DataGridViewElement)
Protected Method | RaiseDataError | Raises the DataError event. (Inherited from DataGridViewElement)
Protected Method | RaiseMouseWheel | Raises the MouseWheel event. (Inherited from DataGridViewElement)
Protected Method | RenderAttributes | Renders a header- cell's attributes (Inherited from DataGridViewHeaderCell)
Protected Method | RenderBackColorAttribute | Renders the back-color attribute. (Inherited from DataGridViewHeaderCell)
Protected Method | RenderComponent | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from DataGridViewElement)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from DataGridViewElement)
Protected Method | RenderComponents | Renders the controls sub tree (Inherited from DataGridViewElement)
Protected Method | RenderForeColorAttribute | Renders the fore color attribute. (Inherited from DataGridViewHeaderCell)
Protected Method | RenderReadOnlyAttribute | Renders the read only attribute. (Inherited from DataGridViewHeaderCell)
Protected Method | RenderUpdatedAttributes | Renders the updated attributes (Inherited from DataGridViewElement)
Protected Method | RenderWrapModeAttribute | Renders the wrap mode attribute. (Inherited from DataGridViewHeaderCell)
Protected Method | SetValue | Sets the value of the cell. (Inherited from DataGridViewColumnHeaderCell)
Protected Method | UpdateParams | Overloaded. Updates only the parameters of this instance. (Inherited from DataGridViewElement)
Top

See Also

Reference

DataGridViewTopLeftHeaderCell Class
Gizmox.WebGUI.Forms Namespace


DataGridViewTopLeftHeaderCell Constructor

[image]
Gizmox.WebGUI.Forms
DataGridViewTopLeftHeaderCell Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewTopLeftHeaderCell Class : DataGridViewTopLeftHeaderCell Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewTopLeftHeaderCell()
C#
public DataGridViewTopLeftHeaderCell()
Managed Extensions for C++
public: DataGridViewTopLeftHeaderCell();
C++/CLI
public:
DataGridViewTopLeftHeaderCell();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewTopLeftHeaderCell Class
DataGridViewTopLeftHeaderCell Members


DataGridViewTopLeftHeaderCell Class Methods

[image]
Gizmox.WebGUI.Forms
DataGridViewTopLeftHeaderCell Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewTopLeftHeaderCell Class

For a list of all members of this type, see DataGridViewTopLeftHeaderCell members.

Public Methods

 | Name | Description
Public Method | AdjustCellBorderStyle | Modifies the input cell border style according to the specified criteria. (Inherited from DataGridViewCell)
Public Method | Clone | (Inherited from DataGridViewColumnHeaderCell)
Public Method | DetachEditingControl | Removes the cell's editing control from the DataGridView. (Inherited from DataGridViewCell)
Public Method | Dispose | Overloaded. Releases all resources used by the DataGridViewCell. (Inherited from DataGridViewCell)
Public Method | GetContentBounds | Overloaded. (Inherited from DataGridViewCell)
Public Method | GetEditedFormattedValue | Returns the current, formatted value of the cell, regardless of whether the cell is in edit mode and the value has not been committed. (Inherited from DataGridViewCell)
Public Method | GetInheritedState | Returns a value indicating the current state of the cell as inherited from the state of its row or column. (Inherited from DataGridViewHeaderCell)
Public Method | GetInheritedStyle | Gets the style applied to the cell. (Inherited from DataGridViewColumnHeaderCell)
Public Method | InitializeEditingControl | Initializes the control used to edit the cell. (Inherited from DataGridViewCell)
Public Method | KeyEntersEditMode | Determines if edit mode should be started based on the given key. (Inherited from DataGridViewCell)
Public Method | ParseFormattedValue | (Inherited from DataGridViewCell)
Public Method | PositionEditingControl | Sets the location and size of the editing control hosted by a cell in the DataGridView control. (Inherited from DataGridViewCell)
Public Method | PositionEditingPanel | (Inherited from DataGridViewCell)
Public Method | ToString | Overridden.
Public Method | Update | Overloaded. Full updates of this instance. (Inherited from DataGridViewElement)
Top

Protected Methods

 | Name | Description
Protected Method | BorderWidths | (Inherited from DataGridViewCell)
Protected Method | ClickUnsharesRow | Indicates whether the cell's row will be unshared when the cell is clicked. (Inherited from DataGridViewCell)
Protected Method | ContentClickUnsharesRow | Indicates whether the cell's row will be unshared when the cell's content is clicked. (Inherited from DataGridViewCell)
Protected Method | ContentDoubleClickUnsharesRow | Indicates whether the cell's row will be unshared when the cell's content is double-clicked. (Inherited from DataGridViewCell)
Protected Method | DoubleClickUnsharesRow | Indicates whether the cell's row will be unshared when the cell is double-clicked. (Inherited from DataGridViewCell)
Protected Method | EnterUnsharesRow | Indicates whether the parent row will be unshared when the focus moves to the cell. (Inherited from DataGridViewCell)
Protected Method | GetClipboardContent | Retrieves the formatted value of the cell to copy to the Clipboard. (Inherited from DataGridViewColumnHeaderCell)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from DataGridViewElement)
Protected Method | GetDefaultHorizontalAlignment | Gets the horizontal alignment. (Inherited from DataGridViewCell)
Protected Method | GetDefaultVerticalAlignment | Gets the vertical alignment. (Inherited from DataGridViewCell)
Protected Method | GetErrorIconBounds | (Inherited from DataGridViewCell)
Protected Method | GetErrorText | Returns a string that represents the error for the cell. (Inherited from DataGridViewCell)
Protected Method | GetFormattedValue | Gets the value of the cell as formatted for display. (Inherited from DataGridViewCell)
Protected Method | GetPreferredSize | Overloaded. Calculates the preferred size, in pixels, of the cell. (Inherited from DataGridViewCell)
Protected Method | GetSize | Gets the size of the cell. (Inherited from DataGridViewHeaderCell)
Protected Method | GetValue | Gets the value of the cell. (Inherited from DataGridViewColumnHeaderCell)
Protected Method | IsDirty | Determines whether the specified component is dirty. (Inherited from DataGridViewElement)
Protected Method | IsDirtyAttributes | Overloaded. Determines whether the specified component is dirty. (Inherited from DataGridViewElement)
Protected Method | KeyDownUnsharesRow | Indicates whether the parent row is unshared if the user presses a key while the focus is on the cell. (Inherited from DataGridViewCell)
Protected Method | KeyPressUnsharesRow | Indicates whether a row will be unshared if a key is pressed while a cell in the row has focus. (Inherited from DataGridViewCell)
Protected Method | KeyUpUnsharesRow | Indicates whether the parent row is unshared when the user releases a key while the focus is on the cell. (Inherited from DataGridViewCell)
Protected Method | LeaveUnsharesRow | Indicates whether a row will be unshared when the focus leaves a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseClickUnsharesRow | Indicates whether a row will be unshared if the user clicks a mouse button while the pointer is on a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseDoubleClickUnsharesRow | Indicates whether a row will be unshared if the user double-clicks a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseDownUnsharesRow | Indicates whether a row will be unshared when the user holds down a mouse button while the pointer is on a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseEnterUnsharesRow | Indicates whether a row will be unshared when the mouse pointer moves over a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseLeaveUnsharesRow | Indicates whether a row will be unshared when the mouse pointer leaves the row. (Inherited from DataGridViewCell)
Protected Method | MouseMoveUnsharesRow | Indicates whether a row will be unshared when the mouse pointer moves over a cell in the row. (Inherited from DataGridViewCell)
Protected Method | MouseUpUnsharesRow | Indicates whether a row will be unshared when the user releases a mouse button while the pointer is on a cell in the row. (Inherited from DataGridViewCell)
Protected Method | OnClick | Called when the cell is clicked. (Inherited from DataGridViewCell)
Protected Method | OnContentClick | Called when the cell's contents are clicked. (Inherited from DataGridViewCell)
Protected Method | OnContentDoubleClick | Called when the cell's contents are double-clicked. (Inherited from DataGridViewCell)
Protected Method | OnDataGridViewChanged | Called when the DataGridViewElement.DataGridView property of the cell changes. (Inherited from DataGridViewCell)
Protected Method | OnDoubleClick | Called when the cell is double-clicked. (Inherited from DataGridViewCell)
Protected Method | OnEnter | Called when the focus moves to a cell. (Inherited from DataGridViewCell)
Protected Method | OnKeyDown | Called when a character key is pressed while the focus is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnKeyPress | Called when a key is pressed while the focus is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnKeyUp | Called when a character key is released while the focus is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnLeave | Called when the focus moves from a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseClick | Called when the user clicks a mouse button while the pointer is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseDoubleClick | Called when the user double-clicks a mouse button while the pointer is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseDown | Called when the user holds down a mouse button while the pointer is on a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseEnter | Called when the mouse pointer moves over a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseLeave | Called when the mouse pointer leaves the cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseMove | Called when the mouse pointer moves within a cell. (Inherited from DataGridViewCell)
Protected Method | OnMouseUp | Called when the user releases a mouse button while the pointer is on a cell. (Inherited from DataGridViewCell)
Protected Method | Paint | (Inherited from DataGridViewCell)
Protected Method | PaintErrorIcon | (Inherited from DataGridViewCell)
Protected Method | ProcessGatewayRequest | (Inherited from DataGridViewCell)
Protected Method | RaiseCellClick | Raises the DataGridView.CellClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellContentClick | Raises the DataGridView.CellContentClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellContentDoubleClick | Raises the DataGridView.CellContentDoubleClick event. (Inherited from DataGridViewElement)
Protected Method | RaiseCellValueChanged | Raises the CellValueChanged event. (Inherited from DataGridViewElement)
Protected Method | RaiseDataError | Raises the DataError event. (Inherited from DataGridViewElement)
Protected Method | RaiseMouseWheel | Raises the MouseWheel event. (Inherited from DataGridViewElement)
Protected Method | RenderAttributes | Renders a header- cell's attributes (Inherited from DataGridViewHeaderCell)
Protected Method | RenderBackColorAttribute | Renders the back-color attribute. (Inherited from DataGridViewHeaderCell)
Protected Method | RenderComponent | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from DataGridViewElement)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from DataGridViewElement)
Protected Method | RenderComponents | Renders the controls sub tree (Inherited from DataGridViewElement)
Protected Method | RenderForeColorAttribute | Renders the fore color attribute. (Inherited from DataGridViewHeaderCell)
Protected Method | RenderReadOnlyAttribute | Renders the read only attribute. (Inherited from DataGridViewHeaderCell)
Protected Method | RenderUpdatedAttributes | Renders the updated attributes (Inherited from DataGridViewElement)
Protected Method | RenderWrapModeAttribute | Renders the wrap mode attribute. (Inherited from DataGridViewHeaderCell)
Protected Method | SetValue | Sets the value of the cell. (Inherited from DataGridViewColumnHeaderCell)
Protected Method | UpdateParams | Overloaded. Updates only the parameters of this instance. (Inherited from DataGridViewElement)
Top

See Also

Reference

DataGridViewTopLeftHeaderCell Class
Gizmox.WebGUI.Forms Namespace


ToString Method

[image]
Gizmox.WebGUI.Forms
ToString Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataGridViewTopLeftHeaderCell Class : ToString Method

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewTopLeftHeaderCell
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataGridViewTopLeftHeaderCell Class
DataGridViewTopLeftHeaderCell Members


DataObject Class

[image]
Gizmox.WebGUI.Forms
DataObject Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataObject Class

Implements a basic data transfer mechanism.

Syntax

Visual Basic (Declaration)
<ClassInterfaceAttribute()>
Public Class DataObject
   Implements IDataObject
Visual Basic (Usage) Copy Code
Dim instance As DataObject
C#
[ClassInterfaceAttribute()]
public class DataObject : IDataObject
Managed Extensions for C++
[ClassInterfaceAttribute()]
public __gc class DataObject : public IDataObject
C++/CLI
[ClassInterfaceAttribute()]
public ref class DataObject : public IDataObject

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.DataObject

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

DataObject Members
Gizmox.WebGUI.Forms Namespace


DataObject Class Members

[image]
Gizmox.WebGUI.Forms
DataObject Class Members
See Also Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : DataObject Class

The following tables list the members exposed by DataObject.

Public Constructors

 | Name | Description
Public Constructor | DataObject Constructor | Overloaded. Initializes a new instance of the DataObject class.
Top

Public Methods

 | Name | Description
Public Method | ContainsAudio | Indicates whether the data object contains data in the DataFormats.WaveAudio format.
Public Method | ContainsFileDropList | Indicates whether the data object contains data that is in the DataFormats.FileDrop format or can be converted to that format.
Public Method | ContainsImage | Indicates whether the data object contains data that is in the DataFormats.Bitmap format or can be converted to that format.
Public Method | ContainsText | Overloaded. Indicates whether the data object contains data in the TextDataFormat.UnicodeText format.
Public Method | GetAudioStream | Retrieves an audio stream from the data object.
Public Method | GetData | Overloaded. Returns the data associated with the specified data format.
Public Method | GetDataPresent | Overloaded. Determines whether data stored in this DataObject is associated with, or can be converted to, the specified format.
Public Method | GetFileDropList | Retrieves a collection of file names from the data object.
Public Method | GetFormats | Overloaded. Returns a list of all formats that data stored in this DataObject is associated with or can be converted to.
Public Method | GetImage | Retrieves an image from the data object.
Public Method | GetText | Overloaded. Retrieves text data from the data object in the TextDataFormat.UnicodeText format.
Public Method | SetAudio | Overloaded. Adds a Stream to the data object in the DataFormats.WaveAudio format.
Public Method | SetData | Overloaded. Adds the specified object to the DataObject using the object type as the data format.
Public Method | SetFileDropList | Adds a collection of file names to the data object in the DataFormats.FileDrop format.
Public Method | SetImage | Adds an Image to the data object in the DataFormats.Bitmap format.
Public Method | SetText | Overloaded. Adds text data to the data object in the TextDataFormat.UnicodeText format.
Top

See Also

Reference

DataObject Class
Gizmox.WebGUI.Forms Namespace


DataObject Constructor

[image]
Gizmox.WebGUI.Forms
DataObject Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataObject Class : DataObject Constructor

Initializes a new instance of the DataObject class.

Overload List

Overload | Description
DataObject Constructor() | Initializes a new instance of the DataObject class.
DataObject Constructor(Object) | Initializes a new instance of the DataObject class and adds the specified object to it.
DataObject Constructor(String,Object) | Initializes a new instance of the DataObject class and adds the specified object in the specified format.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataObject Class
DataObject Members


DataObject Constructor()

[image]
Gizmox.WebGUI.Forms
DataObject Constructor()
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataObject Class > DataObject Constructor : DataObject Constructor()

Initializes a new instance of the DataObject class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As DataObject()
C#
public DataObject()
Managed Extensions for C++
public: DataObject();
C++/CLI
public:
DataObject();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataObject Class
DataObject Members
Overload List


DataObject Constructor(Object)

[image]
Gizmox.WebGUI.Forms
DataObject Constructor(Object)
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataObject Class > DataObject Constructor : DataObject Constructor(Object)

data
The data to store.
Initializes a new instance of the DataObject class and adds the specified object to it.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As Object _
)
Visual Basic (Usage) Copy Code
Dim data As Object

Dim instance As DataObject(data)
C#
public DataObject(
   object data
)
Managed Extensions for C++
public: DataObject(
   Object* data
)
C++/CLI
public:
DataObject(
   Object^ data
)

Parameters

data
The data to store.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataObject Class
DataObject Members
Overload List


DataObject Constructor(String,Object)

[image]
Gizmox.WebGUI.Forms
DataObject Constructor(String,Object)
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataObject Class > DataObject Constructor : DataObject Constructor(String,Object)

format
The format of the specified data. See DataFormats for predefined formats.
data
The data to store.
Initializes a new instance of the DataObject class and adds the specified object in the specified format.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal format As String, _
   ByVal data As Object _
)
Visual Basic (Usage) Copy Code
Dim format As String
Dim data As Object

Dim instance As DataObject(format, data)
C#
public DataObject(
   string format,
   object data
)
Managed Extensions for C++
public: DataObject(
   string* format,
   Object* data
)
C++/CLI
public:
DataObject(
   String^ format,
   Object^ data
)

Parameters

format
The format of the specified data. See DataFormats for predefined formats.
data
The data to store.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataObject Class
DataObject Members
Overload List


DataObject Class Methods

[image]
Gizmox.WebGUI.Forms
DataObject Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataObject Class

For a list of all members of this type, see DataObject members.

Public Methods

 | Name | Description
Public Method | ContainsAudio | Indicates whether the data object contains data in the DataFormats.WaveAudio format.
Public Method | ContainsFileDropList | Indicates whether the data object contains data that is in the DataFormats.FileDrop format or can be converted to that format.
Public Method | ContainsImage | Indicates whether the data object contains data that is in the DataFormats.Bitmap format or can be converted to that format.
Public Method | ContainsText | Overloaded. Indicates whether the data object contains data in the TextDataFormat.UnicodeText format.
Public Method | GetAudioStream | Retrieves an audio stream from the data object.
Public Method | GetData | Overloaded. Returns the data associated with the specified data format.
Public Method | GetDataPresent | Overloaded. Determines whether data stored in this DataObject is associated with, or can be converted to, the specified format.
Public Method | GetFileDropList | Retrieves a collection of file names from the data object.
Public Method | GetFormats | Overloaded. Returns a list of all formats that data stored in this DataObject is associated with or can be converted to.
Public Method | GetImage | Retrieves an image from the data object.
Public Method | GetText | Overloaded. Retrieves text data from the data object in the TextDataFormat.UnicodeText format.
Public Method | SetAudio | Overloaded. Adds a Stream to the data object in the DataFormats.WaveAudio format.
Public Method | SetData | Overloaded. Adds the specified object to the DataObject using the object type as the data format.
Public Method | SetFileDropList | Adds a collection of file names to the data object in the DataFormats.FileDrop format.
Public Method | SetImage | Adds an Image to the data object in the DataFormats.Bitmap format.
Public Method | SetText | Overloaded. Adds text data to the data object in the TextDataFormat.UnicodeText format.
Top

See Also

Reference

DataObject Class
Gizmox.WebGUI.Forms Namespace


ContainsAudio Method

[image]
Gizmox.WebGUI.Forms
ContainsAudio Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataObject Class : ContainsAudio Method

Indicates whether the data object contains data in the DataFormats.WaveAudio format.

Syntax

Visual Basic (Declaration)
Public Overridable Function ContainsAudio() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataObject
Dim value As Boolean

value = instance.ContainsAudio()
C#
public virtual bool ContainsAudio()
Managed Extensions for C++
public: virtual bool ContainsAudio();
C++/CLI
public:
virtual bool ContainsAudio();

Return Value

true if the data object contains audio data; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataObject Class
DataObject Members


ContainsFileDropList Method

[image]
Gizmox.WebGUI.Forms
ContainsFileDropList Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataObject Class : ContainsFileDropList Method

Indicates whether the data object contains data that is in the DataFormats.FileDrop format or can be converted to that format.

Syntax

Visual Basic (Declaration)
Public Overridable Function ContainsFileDropList() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataObject
Dim value As Boolean

value = instance.ContainsFileDropList()
C#
public virtual bool ContainsFileDropList()
Managed Extensions for C++
public: virtual bool ContainsFileDropList();
C++/CLI
public:
virtual bool ContainsFileDropList();

Return Value

true if the data object contains a file drop list; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataObject Class
DataObject Members


ContainsImage Method

[image]
Gizmox.WebGUI.Forms
ContainsImage Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataObject Class : ContainsImage Method

Indicates whether the data object contains data that is in the DataFormats.Bitmap format or can be converted to that format.

Syntax

Visual Basic (Declaration)
Public Overridable Function ContainsImage() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataObject
Dim value As Boolean

value = instance.ContainsImage()
C#
public virtual bool ContainsImage()
Managed Extensions for C++
public: virtual bool ContainsImage();
C++/CLI
public:
virtual bool ContainsImage();

Return Value

true if the data object contains image data; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataObject Class
DataObject Members


ContainsText Method

[image]
Gizmox.WebGUI.Forms
ContainsText Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataObject Class : ContainsText Method

Indicates whether the data object contains data in the TextDataFormat.UnicodeText format.

Overload List

Overload | Description
ContainsText() | Indicates whether the data object contains data in the TextDataFormat.UnicodeText format.
ContainsText(TextDataFormat) | Indicates whether the data object contains text data in the format indicated by the specified TextDataFormat value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataObject Class
DataObject Members


ContainsText() Method

[image]
Gizmox.WebGUI.Forms
ContainsText() Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataObject Class > ContainsText Method : ContainsText() Method

Indicates whether the data object contains data in the TextDataFormat.UnicodeText format.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function ContainsText() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataObject
Dim value As Boolean

value = instance.ContainsText()
C#
public virtual bool ContainsText()
Managed Extensions for C++
public: virtual bool ContainsText();
C++/CLI
public:
virtual bool ContainsText();

Return Value

true if the data object contains text data; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataObject Class
DataObject Members
Overload List


ContainsText(TextDataFormat) Method

[image]
Gizmox.WebGUI.Forms
ContainsText(TextDataFormat) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataObject Class > ContainsText Method : ContainsText(TextDataFormat) Method

format
One of the TextDataFormat values.
Indicates whether the data object contains text data in the format indicated by the specified TextDataFormat value.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function ContainsText( _
   ByVal format As TextDataFormat _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataObject
Dim format As TextDataFormat
Dim value As Boolean

value = instance.ContainsText(format)
C#
public virtual bool ContainsText(
   TextDataFormat format
)
Managed Extensions for C++
public: virtual bool ContainsText(
   TextDataFormat format
)
C++/CLI
public:
virtual bool ContainsText(
   TextDataFormat format
)

Parameters

format
One of the TextDataFormat values.

Return Value

true if the data object contains text data in the specified format; otherwise, false.

Exceptions

Exception | Description
InvalidEnumArgumentException | format is not a valid TextDataFormat value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataObject Class
DataObject Members
Overload List


GetAudioStream Method

[image]
Gizmox.WebGUI.Forms
GetAudioStream Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataObject Class : GetAudioStream Method

Retrieves an audio stream from the data object.

Syntax

Visual Basic (Declaration)
Public Overridable Function GetAudioStream() As Stream
Visual Basic (Usage) Copy Code
Dim instance As DataObject
Dim value As Stream

value = instance.GetAudioStream()
C#
public virtual Stream GetAudioStream()
Managed Extensions for C++
public: virtual Stream* GetAudioStream();
C++/CLI
public:
virtual Stream^ GetAudioStream();

Return Value

A Stream containing audio data or null if the data object does not contain any data in the DataFormats.WaveAudio format.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataObject Class
DataObject Members


GetData Method

[image]
Gizmox.WebGUI.Forms
GetData Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataObject Class : GetData Method

Returns the data associated with the specified data format.

Overload List

Overload | Description
GetData(String) | Returns the data associated with the specified data format.
GetData(Type) | Returns the data associated with the specified class type format.
GetData(String,Boolean) | Returns the data associated with the specified data format, using an automated conversion parameter to determine whether to convert the data to the format.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataObject Class
DataObject Members


GetData(String) Method

[image]
Gizmox.WebGUI.Forms
GetData(String) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataObject Class > GetData Method : GetData(String) Method

format
The format of the data to retrieve. See DataFormats for predefined formats.
Returns the data associated with the specified data format.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function GetData( _
   ByVal format As String _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As DataObject
Dim format As String
Dim value As Object

value = instance.GetData(format)
C#
public virtual object GetData(
   string format
)
Managed Extensions for C++
public: virtual Object* GetData(
   string* format
)
C++/CLI
public:
virtual Object^ GetData(
   String^ format
)

Parameters

format
The format of the data to retrieve. See DataFormats for predefined formats.

Return Value

The data associated with the specified format, or null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataObject Class
DataObject Members
Overload List


GetData(Type) Method

[image]
Gizmox.WebGUI.Forms
GetData(Type) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataObject Class > GetData Method : GetData(Type) Method

format
A Type representing the format of the data to retrieve.
Returns the data associated with the specified class type format.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function GetData( _
   ByVal format As Type _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As DataObject
Dim format As Type
Dim value As Object

value = instance.GetData(format)
C#
public virtual object GetData(
   Type format
)
Managed Extensions for C++
public: virtual Object* GetData(
   Type* format
)
C++/CLI
public:
virtual Object^ GetData(
   Type^ format
)

Parameters

format
A Type representing the format of the data to retrieve.

Return Value

The data associated with the specified format, or null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataObject Class
DataObject Members
Overload List


GetData(String,Boolean) Method

[image]
Gizmox.WebGUI.Forms
GetData(String,Boolean) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataObject Class > GetData Method : GetData(String,Boolean) Method

format
The format of the data to retrieve. See DataFormats for predefined formats.
autoConvert
true to the convert data to the specified format; otherwise, false.
Returns the data associated with the specified data format, using an automated conversion parameter to determine whether to convert the data to the format.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function GetData( _
   ByVal format As String, _
   ByVal autoConvert As Boolean _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As DataObject
Dim format As String
Dim autoConvert As Boolean
Dim value As Object

value = instance.GetData(format, autoConvert)
C#
public virtual object GetData(
   string format,
   bool autoConvert
)
Managed Extensions for C++
public: virtual Object* GetData(
   string* format,
   bool autoConvert
)
C++/CLI
public:
virtual Object^ GetData(
   String^ format,
   bool autoConvert
)

Parameters

format
The format of the data to retrieve. See DataFormats for predefined formats.
autoConvert
true to the convert data to the specified format; otherwise, false.

Return Value

The data associated with the specified format, or null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataObject Class
DataObject Members
Overload List


GetDataPresent Method

[image]
Gizmox.WebGUI.Forms
GetDataPresent Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataObject Class : GetDataPresent Method

Determines whether data stored in this DataObject is associated with, or can be converted to, the specified format.

Overload List

Overload | Description
GetDataPresent(String) | Determines whether data stored in this DataObject is associated with, or can be converted to, the specified format.
GetDataPresent(Type) | Determines whether data stored in this DataObject is associated with, or can be converted to, the specified format.
GetDataPresent(String,Boolean) | Determines whether this DataObject contains data in the specified format or, optionally, contains data that can be converted to the specified format.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataObject Class
DataObject Members


GetDataPresent(String) Method

[image]
Gizmox.WebGUI.Forms
GetDataPresent(String) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataObject Class > GetDataPresent Method : GetDataPresent(String) Method

format
The format to check for. See DataFormats for predefined formats.
Determines whether data stored in this DataObject is associated with, or can be converted to, the specified format.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function GetDataPresent( _
   ByVal format As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataObject
Dim format As String
Dim value As Boolean

value = instance.GetDataPresent(format)
C#
public virtual bool GetDataPresent(
   string format
)
Managed Extensions for C++
public: virtual bool GetDataPresent(
   string* format
)
C++/CLI
public:
virtual bool GetDataPresent(
   String^ format
)

Parameters

format
The format to check for. See DataFormats for predefined formats.

Return Value

true if data stored in this DataObject is associated with, or can be converted to, the specified format; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataObject Class
DataObject Members
Overload List


GetDataPresent(Type) Method

[image]
Gizmox.WebGUI.Forms
GetDataPresent(Type) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataObject Class > GetDataPresent Method : GetDataPresent(Type) Method

format
A Type representing the format to check for.
Determines whether data stored in this DataObject is associated with, or can be converted to, the specified format.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function GetDataPresent( _
   ByVal format As Type _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataObject
Dim format As Type
Dim value As Boolean

value = instance.GetDataPresent(format)
C#
public virtual bool GetDataPresent(
   Type format
)
Managed Extensions for C++
public: virtual bool GetDataPresent(
   Type* format
)
C++/CLI
public:
virtual bool GetDataPresent(
   Type^ format
)

Parameters

format
A Type representing the format to check for.

Return Value

true if data stored in this DataObject is associated with, or can be converted to, the specified format; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataObject Class
DataObject Members
Overload List


GetDataPresent(String,Boolean) Method

[image]
Gizmox.WebGUI.Forms
GetDataPresent(String,Boolean) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataObject Class > GetDataPresent Method : GetDataPresent(String,Boolean) Method

format
The format to check for. See DataFormats for predefined formats.
autoConvert
true to determine whether data stored in this DataObject can be converted to the specified format; false to check whether the data is in the specified format.
Determines whether this DataObject contains data in the specified format or, optionally, contains data that can be converted to the specified format.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function GetDataPresent( _
   ByVal format As String, _
   ByVal autoConvert As Boolean _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataObject
Dim format As String
Dim autoConvert As Boolean
Dim value As Boolean

value = instance.GetDataPresent(format, autoConvert)
C#
public virtual bool GetDataPresent(
   string format,
   bool autoConvert
)
Managed Extensions for C++
public: virtual bool GetDataPresent(
   string* format,
   bool autoConvert
)
C++/CLI
public:
virtual bool GetDataPresent(
   String^ format,
   bool autoConvert
)

Parameters

format
The format to check for. See DataFormats for predefined formats.
autoConvert
true to determine whether data stored in this DataObject can be converted to the specified format; false to check whether the data is in the specified format.

Return Value

true if the data is in, or can be converted to, the specified format; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataObject Class
DataObject Members
Overload List


GetFileDropList Method

[image]
Gizmox.WebGUI.Forms
GetFileDropList Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataObject Class : GetFileDropList Method

Retrieves a collection of file names from the data object.

Syntax

Visual Basic (Declaration)
Public Overridable Function GetFileDropList() As StringCollection
Visual Basic (Usage) Copy Code
Dim instance As DataObject
Dim value As StringCollection

value = instance.GetFileDropList()
C#
public virtual StringCollection GetFileDropList()
Managed Extensions for C++
public: virtual StringCollection* GetFileDropList();
C++/CLI
public:
virtual StringCollection^ GetFileDropList();

Return Value

A StringCollection containing file names or null if the data object does not contain any data that is in the DataFormats.FileDrop format or can be converted to that format.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataObject Class
DataObject Members


GetFormats Method

[image]
Gizmox.WebGUI.Forms
GetFormats Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataObject Class : GetFormats Method

Returns a list of all formats that data stored in this DataObject is associated with or can be converted to.

Overload List

Overload | Description
GetFormats() | Returns a list of all formats that data stored in this DataObject is associated with or can be converted to.
GetFormats(Boolean) | Returns a list of all formats that data stored in this DataObject is associated with or can be converted to, using an automatic conversion parameter to determine whether to retrieve only native data formats or all formats that the data can be converted to.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataObject Class
DataObject Members


GetFormats() Method

[image]
Gizmox.WebGUI.Forms
GetFormats() Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataObject Class > GetFormats Method : GetFormats() Method

Returns a list of all formats that data stored in this DataObject is associated with or can be converted to.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function GetFormats() As String()
Visual Basic (Usage) Copy Code
Dim instance As DataObject
Dim value() As String

value = instance.GetFormats()
C#
public virtual string[] GetFormats()
Managed Extensions for C++
public: virtual string*[]* GetFormats();
C++/CLI
public:
virtual array<String^>^ GetFormats();

Return Value

An array of type String, containing a list of all formats that are supported by the data stored in this object.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataObject Class
DataObject Members
Overload List


GetFormats(Boolean) Method

[image]
Gizmox.WebGUI.Forms
GetFormats(Boolean) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataObject Class > GetFormats Method : GetFormats(Boolean) Method

autoConvert
true to retrieve all formats that data stored in this DataObject is associated with, or can be converted to; false to retrieve only native data formats.
Returns a list of all formats that data stored in this DataObject is associated with or can be converted to, using an automatic conversion parameter to determine whether to retrieve only native data formats or all formats that the data can be converted to.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function GetFormats( _
   ByVal autoConvert As Boolean _
) As String()
Visual Basic (Usage) Copy Code
Dim instance As DataObject
Dim autoConvert As Boolean
Dim value() As String

value = instance.GetFormats(autoConvert)
C#
public virtual string[] GetFormats(
   bool autoConvert
)
Managed Extensions for C++
public: virtual string*[]* GetFormats(
   bool autoConvert
)
C++/CLI
public:
virtual array<String^>^ GetFormats(
   bool autoConvert
)

Parameters

autoConvert
true to retrieve all formats that data stored in this DataObject is associated with, or can be converted to; false to retrieve only native data formats.

Return Value

An array of type String, containing a list of all formats that are supported by the data stored in this object.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataObject Class
DataObject Members
Overload List


GetImage Method

[image]
Gizmox.WebGUI.Forms
GetImage Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataObject Class : GetImage Method

Retrieves an image from the data object.

Syntax

Visual Basic (Declaration)
Public Overridable Function GetImage() As Image
Visual Basic (Usage) Copy Code
Dim instance As DataObject
Dim value As Image

value = instance.GetImage()
C#
public virtual Image GetImage()
Managed Extensions for C++
public: virtual Image* GetImage();
C++/CLI
public:
virtual Image^ GetImage();

Return Value

An Image representing the image data in the data object or null if the data object does not contain any data that is in the DataFormats.Bitmap format or can be converted to that format.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataObject Class
DataObject Members


GetText Method

[image]
Gizmox.WebGUI.Forms
GetText Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataObject Class : GetText Method

Retrieves text data from the data object in the TextDataFormat.UnicodeText format.

Overload List

Overload | Description
GetText() | Retrieves text data from the data object in the TextDataFormat.UnicodeText format.
GetText(TextDataFormat) | Retrieves text data from the data object in the format indicated by the specified TextDataFormat value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataObject Class
DataObject Members


GetText() Method

[image]
Gizmox.WebGUI.Forms
GetText() Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataObject Class > GetText Method : GetText() Method

Retrieves text data from the data object in the TextDataFormat.UnicodeText format.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function GetText() As String
Visual Basic (Usage) Copy Code
Dim instance As DataObject
Dim value As String

value = instance.GetText()
C#
public virtual string GetText()
Managed Extensions for C++
public: virtual string* GetText();
C++/CLI
public:
virtual String^ GetText();

Return Value

The text data in the data object or Empty if the data object does not contain data in the TextDataFormat.UnicodeText format.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataObject Class
DataObject Members
Overload List


GetText(TextDataFormat) Method

[image]
Gizmox.WebGUI.Forms
GetText(TextDataFormat) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataObject Class > GetText Method : GetText(TextDataFormat) Method

format
One of the TextDataFormat values.
Retrieves text data from the data object in the format indicated by the specified TextDataFormat value.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function GetText( _
   ByVal format As TextDataFormat _
) As String
Visual Basic (Usage) Copy Code
Dim instance As DataObject
Dim format As TextDataFormat
Dim value As String

value = instance.GetText(format)
C#
public virtual string GetText(
   TextDataFormat format
)
Managed Extensions for C++
public: virtual string* GetText(
   TextDataFormat format
)
C++/CLI
public:
virtual String^ GetText(
   TextDataFormat format
)

Parameters

format
One of the TextDataFormat values.

Return Value

The text data in the data object or Empty if the data object does not contain data in the specified format.

Exceptions

Exception | Description
InvalidEnumArgumentException | format is not a valid TextDataFormat value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataObject Class
DataObject Members
Overload List


SetAudio Method

[image]
Gizmox.WebGUI.Forms
SetAudio Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataObject Class : SetAudio Method

Adds a Stream to the data object in the DataFormats.WaveAudio format.

Overload List

Overload | Description
SetAudio(Stream) | Adds a Stream to the data object in the DataFormats.WaveAudio format.
SetAudio(Byte[]) | Adds a Byte array to the data object in the DataFormats.WaveAudio format after converting it to a Stream.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataObject Class
DataObject Members


SetAudio(Stream) Method

[image]
Gizmox.WebGUI.Forms
SetAudio(Stream) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataObject Class > SetAudio Method : SetAudio(Stream) Method

audioStream
A Stream containing the audio data.
Adds a Stream to the data object in the DataFormats.WaveAudio format.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub SetAudio( _
   ByVal audioStream As Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As DataObject
Dim audioStream As Stream

instance.SetAudio(audioStream)
C#
public virtual void SetAudio(
   Stream audioStream
)
Managed Extensions for C++
public: virtual void SetAudio(
   Stream* audioStream
)
C++/CLI
public:
virtual void SetAudio(
   Stream^ audioStream
)

Parameters

audioStream
A Stream containing the audio data.

Exceptions

Exception | Description
ArgumentNullException | audioStream is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataObject Class
DataObject Members
Overload List


SetAudio(Byte[]) Method

[image]
Gizmox.WebGUI.Forms
SetAudio(Byte[]) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataObject Class > SetAudio Method : SetAudio(Byte[]) Method

audioBytes
A Byte array containing the audio data.
Adds a Byte array to the data object in the DataFormats.WaveAudio format after converting it to a Stream.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub SetAudio( _
   ByVal audioBytes() As Byte _
)
Visual Basic (Usage) Copy Code
Dim instance As DataObject
Dim audioBytes() As Byte

instance.SetAudio(audioBytes)
C#
public virtual void SetAudio(
   byte[] audioBytes
)
Managed Extensions for C++
public: virtual void SetAudio(
   byte[]* audioBytes
)
C++/CLI
public:
virtual void SetAudio(
   array<byte>^ audioBytes
)

Parameters

audioBytes
A Byte array containing the audio data.

Exceptions

Exception | Description
ArgumentNullException | audioBytes is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataObject Class
DataObject Members
Overload List


SetData Method

[image]
Gizmox.WebGUI.Forms
SetData Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataObject Class : SetData Method

Adds the specified object to the DataObject using the object type as the data format.

Overload List

Overload | Description
SetData(Object) | Adds the specified object to the DataObject using the object type as the data format.
SetData(String,Object) | Adds the specified object to the DataObject using the specified format.
SetData(Type,Object) | Adds the specified object to the DataObject using the specified type as the format.
SetData(String,Boolean,Object) | Adds the specified object to the DataObject using the specified format and indicating whether the data can be converted to another format.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataObject Class
DataObject Members


SetData(Object) Method

[image]
Gizmox.WebGUI.Forms
SetData(Object) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataObject Class > SetData Method : SetData(Object) Method

data
The data to store.
Adds the specified object to the DataObject using the object type as the data format.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub SetData( _
   ByVal data As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As DataObject
Dim data As Object

instance.SetData(data)
C#
public virtual void SetData(
   object data
)
Managed Extensions for C++
public: virtual void SetData(
   Object* data
)
C++/CLI
public:
virtual void SetData(
   Object^ data
)

Parameters

data
The data to store.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataObject Class
DataObject Members
Overload List


SetData(String,Object) Method

[image]
Gizmox.WebGUI.Forms
SetData(String,Object) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataObject Class > SetData Method : SetData(String,Object) Method

format
The format associated with the data. See DataFormats for predefined formats.
data
The data to store.
Adds the specified object to the DataObject using the specified format.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub SetData( _
   ByVal format As String, _
   ByVal data As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As DataObject
Dim format As String
Dim data As Object

instance.SetData(format, data)
C#
public virtual void SetData(
   string format,
   object data
)
Managed Extensions for C++
public: virtual void SetData(
   string* format,
   Object* data
)
C++/CLI
public:
virtual void SetData(
   String^ format,
   Object^ data
)

Parameters

format
The format associated with the data. See DataFormats for predefined formats.
data
The data to store.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataObject Class
DataObject Members
Overload List


SetData(Type,Object) Method

[image]
Gizmox.WebGUI.Forms
SetData(Type,Object) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataObject Class > SetData Method : SetData(Type,Object) Method

format
A Type representing the format associated with the data.
data
The data to store.
Adds the specified object to the DataObject using the specified type as the format.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub SetData( _
   ByVal format As Type, _
   ByVal data As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As DataObject
Dim format As Type
Dim data As Object

instance.SetData(format, data)
C#
public virtual void SetData(
   Type format,
   object data
)
Managed Extensions for C++
public: virtual void SetData(
   Type* format,
   Object* data
)
C++/CLI
public:
virtual void SetData(
   Type^ format,
   Object^ data
)

Parameters

format
A Type representing the format associated with the data.
data
The data to store.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataObject Class
DataObject Members
Overload List


SetData(String,Boolean,Object) Method

[image]
Gizmox.WebGUI.Forms
SetData(String,Boolean,Object) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataObject Class > SetData Method : SetData(String,Boolean,Object) Method

format
The format associated with the data. See DataFormats for predefined formats.
autoConvert
true to allow the data to be converted to another format; otherwise, false.
data
The data to store.
Adds the specified object to the DataObject using the specified format and indicating whether the data can be converted to another format.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub SetData( _
   ByVal format As String, _
   ByVal autoConvert As Boolean, _
   ByVal data As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As DataObject
Dim format As String
Dim autoConvert As Boolean
Dim data As Object

instance.SetData(format, autoConvert, data)
C#
public virtual void SetData(
   string format,
   bool autoConvert,
   object data
)
Managed Extensions for C++
public: virtual void SetData(
   string* format,
   bool autoConvert,
   Object* data
)
C++/CLI
public:
virtual void SetData(
   String^ format,
   bool autoConvert,
   Object^ data
)

Parameters

format
The format associated with the data. See DataFormats for predefined formats.
autoConvert
true to allow the data to be converted to another format; otherwise, false.
data
The data to store.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataObject Class
DataObject Members
Overload List


SetFileDropList Method

[image]
Gizmox.WebGUI.Forms
SetFileDropList Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataObject Class : SetFileDropList Method

filePaths
A StringCollection containing the file names.
Adds a collection of file names to the data object in the DataFormats.FileDrop format.

Syntax

Visual Basic (Declaration)
Public Overridable Sub SetFileDropList( _
   ByVal filePaths As StringCollection _
)
Visual Basic (Usage) Copy Code
Dim instance As DataObject
Dim filePaths As StringCollection

instance.SetFileDropList(filePaths)
C#
public virtual void SetFileDropList(
   StringCollection filePaths
)
Managed Extensions for C++
public: virtual void SetFileDropList(
   StringCollection* filePaths
)
C++/CLI
public:
virtual void SetFileDropList(
   StringCollection^ filePaths
)

Parameters

filePaths
A StringCollection containing the file names.

Exceptions

Exception | Description
ArgumentNullException | filePaths is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataObject Class
DataObject Members


SetImage Method

[image]
Gizmox.WebGUI.Forms
SetImage Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataObject Class : SetImage Method

image
The Image to add to the data object.
Adds an Image to the data object in the DataFormats.Bitmap format.

Syntax

Visual Basic (Declaration)
Public Overridable Sub SetImage( _
   ByVal image As Image _
)
Visual Basic (Usage) Copy Code
Dim instance As DataObject
Dim image As Image

instance.SetImage(image)
C#
public virtual void SetImage(
   Image image
)
Managed Extensions for C++
public: virtual void SetImage(
   Image* image
)
C++/CLI
public:
virtual void SetImage(
   Image^ image
)

Parameters

image
The Image to add to the data object.

Exceptions

Exception | Description
ArgumentNullException | image is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataObject Class
DataObject Members


SetText Method

[image]
Gizmox.WebGUI.Forms
SetText Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataObject Class : SetText Method

Adds text data to the data object in the TextDataFormat.UnicodeText format.

Overload List

Overload | Description
SetText(String) | Adds text data to the data object in the TextDataFormat.UnicodeText format.
SetText(String,TextDataFormat) | Adds text data to the data object in the format indicated by the specified TextDataFormat value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataObject Class
DataObject Members


SetText(String) Method

[image]
Gizmox.WebGUI.Forms
SetText(String) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataObject Class > SetText Method : SetText(String) Method

textData
The text to add to the data object.
Adds text data to the data object in the TextDataFormat.UnicodeText format.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub SetText( _
   ByVal textData As String _
)
Visual Basic (Usage) Copy Code
Dim instance As DataObject
Dim textData As String

instance.SetText(textData)
C#
public virtual void SetText(
   string textData
)
Managed Extensions for C++
public: virtual void SetText(
   string* textData
)
C++/CLI
public:
virtual void SetText(
   String^ textData
)

Parameters

textData
The text to add to the data object.

Exceptions

Exception | Description
ArgumentNullException | textData is null or Empty.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataObject Class
DataObject Members
Overload List


SetText(String,TextDataFormat) Method

[image]
Gizmox.WebGUI.Forms
SetText(String,TextDataFormat) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DataObject Class > SetText Method : SetText(String,TextDataFormat) Method

textData
The text to add to the data object.
format
One of the TextDataFormat values.
Adds text data to the data object in the format indicated by the specified TextDataFormat value.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub SetText( _
   ByVal textData As String, _
   ByVal format As TextDataFormat _
)
Visual Basic (Usage) Copy Code
Dim instance As DataObject
Dim textData As String
Dim format As TextDataFormat

instance.SetText(textData, format)
C#
public virtual void SetText(
   string textData,
   TextDataFormat format
)
Managed Extensions for C++
public: virtual void SetText(
   string* textData,
   TextDataFormat format
)
C++/CLI
public:
virtual void SetText(
   String^ textData,
   TextDataFormat format
)

Parameters

textData
The text to add to the data object.
format
One of the TextDataFormat values.

Exceptions

Exception | Description
InvalidEnumArgumentException | format is not a valid TextDataFormat value.
ArgumentNullException | textData is null or Empty.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataObject Class
DataObject Members
Overload List


DateTimePicker Class

[image]
Gizmox.WebGUI.Forms
DateTimePicker Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DateTimePicker Class

Represents a Gizmox.WebGUI.Forms control that allows the user to select a date and a time and to display the date and time with a specified format.

Object Model

Syntax

Visual Basic (Declaration)
<ToolboxItemCategoryAttribute("Common Controls")>
<ClientControllerAttribute()>
<SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableDatePicker, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")>
<ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<DesignTimeControllerAttribute()>
<ToolboxBitmapAttribute()>
<MetadataTagAttribute("DP")>
Public Class DateTimePicker
   Inherits Control
   Implements IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Visual Basic (Usage) Copy Code
Dim instance As DateTimePicker
C#
[ToolboxItemCategoryAttribute("Common Controls")]
[ClientControllerAttribute()]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableDatePicker, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[DesignTimeControllerAttribute()]
[ToolboxBitmapAttribute()]
[MetadataTagAttribute("DP")]
public class DateTimePicker : Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Managed Extensions for C++
[ToolboxItemCategoryAttribute("Common Controls")]
[ClientControllerAttribute()]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableDatePicker, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[DesignTimeControllerAttribute()]
[ToolboxBitmapAttribute()]
[MetadataTagAttribute("DP")]
public __gc class DateTimePicker : public Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
C++/CLI
[ToolboxItemCategoryAttribute("Common Controls")]
[ClientControllerAttribute()]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableDatePicker, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[DesignTimeControllerAttribute()]
[ToolboxBitmapAttribute()]
[MetadataTagAttribute("DP")]
public ref class DateTimePicker : public Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.DateTimePicker

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

DateTimePicker Members
Gizmox.WebGUI.Forms Namespace


DateTimePicker Class Members

[image]
Gizmox.WebGUI.Forms
DateTimePicker Class Members
See Also Fields Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : DateTimePicker Class

The following tables list the members exposed by DateTimePicker.

Public Constructors

 | Name | Description
Public Constructor | DateTimePicker Constructor | Initializes a new instance of the DateTimePicker class.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | MaxDateTime | Specifies the maximum date value of the DateTimePicker control. This field is read-only.
static (Shared in Visual Basic) | MinDateTime | Gets the minimum date value of the DateTimePicker control.
Top

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CalendarFirstDayOfWeek | Gets or sets the first day of the week as displayed in the month calendar.
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | Checked | Gets or sets a value indicating whether this DateTimePicker is checked.
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomFormat | Gets or sets the custom date/time format string.
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Format | Gets or sets the format of the date and time displayed in the control.
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaxDate | Gets or sets the maximum date and time that can be selected in the control.
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MinDate | Gets or sets the minimum date and time that can be selected in the control.
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | ShowCheckBox | Gets or sets a value indicating whether a check box is displayed to the left of the selected date.
Public Property | ShowUpDown | Gets or sets a value indicating whether a spin button control (also known as an up-down control) is used to adjust the date/time value.
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Overridden. Gets or sets the text associated with this control.
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | Value | Gets or sets the date/time value assigned to the control.
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | Overridden. Gets the default back color.
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | Overridden. Gets the default border style.
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | Overridden. Returns a string that represents the current DateTimePicker control.
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Overridden. Fires an event.
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Overridden. Gets the critical events.
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from Control)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnValueChanged | Raises the ValueChanged event.
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | Overridden. Render the datetimepicker formating
Protected Method | RenderAttributes | Overridden. Renders the controls meta attributes
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | Overridden.
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | ValueChanged | Occurs when the Value property changes.
Public Event | ValueChangedQueued | Occurs when the ValueChanged property changes (queued).
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

DateTimePicker Class
Gizmox.WebGUI.Forms Namespace


DateTimePicker Constructor

[image]
Gizmox.WebGUI.Forms
DateTimePicker Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DateTimePicker Class : DateTimePicker Constructor

Initializes a new instance of the DateTimePicker class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As DateTimePicker()
C#
public DateTimePicker()
Managed Extensions for C++
public: DateTimePicker();
C++/CLI
public:
DateTimePicker();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DateTimePicker Class
DateTimePicker Members


DateTimePicker Class Methods

[image]
Gizmox.WebGUI.Forms
DateTimePicker Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DateTimePicker Class

For a list of all members of this type, see DateTimePicker members.

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | Overridden. Returns a string that represents the current DateTimePicker control.
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Overridden. Fires an event.
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Overridden. Gets the critical events.
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from Control)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnValueChanged | Raises the ValueChanged event.
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | Overridden. Render the datetimepicker formating
Protected Method | RenderAttributes | Overridden. Renders the controls meta attributes
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | Overridden.
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

See Also

Reference

DateTimePicker Class
Gizmox.WebGUI.Forms Namespace


FireEvent Method

[image]
Gizmox.WebGUI.Forms
FireEvent Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DateTimePicker Class : FireEvent Method

objEvent
event.
Fires an event.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub FireEvent( _
   ByVal objEvent As IEvent _
)
Visual Basic (Usage) Copy Code
Dim instance As DateTimePicker
Dim objEvent As IEvent

instance.FireEvent(objEvent)
C#
protected override void FireEvent(
   IEvent objEvent
)
Managed Extensions for C++
protected: void FireEvent(
   IEvent* objEvent
) override
C++/CLI
protected:
void FireEvent(
   IEvent^ objEvent
) override

Parameters

objEvent
event.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DateTimePicker Class
DateTimePicker Members


GetCriticalEvents Method

[image]
Gizmox.WebGUI.Forms
GetCriticalEvents Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DateTimePicker Class : GetCriticalEvents Method

Gets the critical events.

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetCriticalEvents() As EventTypes
Visual Basic (Usage) Copy Code
Dim instance As DateTimePicker
Dim value As EventTypes

value = instance.GetCriticalEvents()
C#
protected override EventTypes GetCriticalEvents()
Managed Extensions for C++
protected: EventTypes GetCriticalEvents(); override
C++/CLI
protected:
EventTypes GetCriticalEvents(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DateTimePicker Class
DateTimePicker Members


OnValueChanged Method

[image]
Gizmox.WebGUI.Forms
OnValueChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DateTimePicker Class : OnValueChanged Method

eventargs
An EventArgs that contains the event data.
Raises the ValueChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnValueChanged( _
   ByVal eventargs As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DateTimePicker
Dim eventargs As EventArgs

instance.OnValueChanged(eventargs)
C#
protected virtual void OnValueChanged(
   EventArgs eventargs
)
Managed Extensions for C++
protected: virtual void OnValueChanged(
   EventArgs* eventargs
)
C++/CLI
protected:
virtual void OnValueChanged(
   EventArgs^ eventargs
)

Parameters

eventargs
An EventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DateTimePicker Class
DateTimePicker Members


Render Method

[image]
Gizmox.WebGUI.Forms
Render Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DateTimePicker Class : Render Method

objContext
objWriter
lngRequestID
Render the datetimepicker formating

Syntax

Visual Basic (Declaration)
Protected Overrides Sub Render( _
   ByVal objContext As IContext, _
   ByVal objWriter As IResponseWriter, _
   ByVal lngRequestID As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As DateTimePicker
Dim objContext As IContext
Dim objWriter As IResponseWriter
Dim lngRequestID As Long

instance.Render(objContext, objWriter, lngRequestID)
C#
protected override void Render(
   IContext objContext,
   IResponseWriter objWriter,
   long lngRequestID
)
Managed Extensions for C++
protected: void Render(
   IContext* objContext,
   IResponseWriter* objWriter,
   long lngRequestID
) override
C++/CLI
protected:
void Render(
   IContext^ objContext,
   IResponseWriter^ objWriter,
   long long lngRequestID
) override

Parameters

objContext
objWriter
lngRequestID

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DateTimePicker Class
DateTimePicker Members


RenderAttributes Method

[image]
Gizmox.WebGUI.Forms
RenderAttributes Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DateTimePicker Class : RenderAttributes Method

objContext
objWriter
Renders the controls meta attributes

Syntax

Visual Basic (Declaration)
Protected Overrides Sub RenderAttributes( _
   ByVal objContext As IContext, _
   ByVal objWriter As IAttributeWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As DateTimePicker
Dim objContext As IContext
Dim objWriter As IAttributeWriter

instance.RenderAttributes(objContext, objWriter)
C#
protected override void RenderAttributes(
   IContext objContext,
   IAttributeWriter objWriter
)
Managed Extensions for C++
protected: void RenderAttributes(
   IContext* objContext,
   IAttributeWriter* objWriter
) override
C++/CLI
protected:
void RenderAttributes(
   IContext^ objContext,
   IAttributeWriter^ objWriter
) override

Parameters

objContext
objWriter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DateTimePicker Class
DateTimePicker Members


RenderUpdatedAttributes Method

[image]
Gizmox.WebGUI.Forms
RenderUpdatedAttributes Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DateTimePicker Class : RenderUpdatedAttributes Method

objContext
Request context.
objWriter
lngRequestID

Syntax

Visual Basic (Declaration)
Protected Overrides Sub RenderUpdatedAttributes( _
   ByVal objContext As IContext, _
   ByVal objWriter As IAttributeWriter, _
   ByVal lngRequestID As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As DateTimePicker
Dim objContext As IContext
Dim objWriter As IAttributeWriter
Dim lngRequestID As Long

instance.RenderUpdatedAttributes(objContext, objWriter, lngRequestID)
C#
protected override void RenderUpdatedAttributes(
   IContext objContext,
   IAttributeWriter objWriter,
   long lngRequestID
)
Managed Extensions for C++
protected: void RenderUpdatedAttributes(
   IContext* objContext,
   IAttributeWriter* objWriter,
   long lngRequestID
) override
C++/CLI
protected:
void RenderUpdatedAttributes(
   IContext^ objContext,
   IAttributeWriter^ objWriter,
   long long lngRequestID
) override

Parameters

objContext
Request context.
objWriter
lngRequestID

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DateTimePicker Class
DateTimePicker Members


ToString Method

[image]
Gizmox.WebGUI.Forms
ToString Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DateTimePicker Class : ToString Method

Returns a string that represents the current DateTimePicker control.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As DateTimePicker
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Return Value

A string that represents the current DateTimePicker. The string includes the type and the Value property of the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DateTimePicker Class
DateTimePicker Members


DateTimePicker Class Properties

[image]
Gizmox.WebGUI.Forms
DateTimePicker Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DateTimePicker Class

For a list of all members of this type, see DateTimePicker members.

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CalendarFirstDayOfWeek | Gets or sets the first day of the week as displayed in the month calendar.
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | Checked | Gets or sets a value indicating whether this DateTimePicker is checked.
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomFormat | Gets or sets the custom date/time format string.
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Format | Gets or sets the format of the date and time displayed in the control.
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaxDate | Gets or sets the maximum date and time that can be selected in the control.
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MinDate | Gets or sets the minimum date and time that can be selected in the control.
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | ShowCheckBox | Gets or sets a value indicating whether a check box is displayed to the left of the selected date.
Public Property | ShowUpDown | Gets or sets a value indicating whether a spin button control (also known as an up-down control) is used to adjust the date/time value.
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Overridden. Gets or sets the text associated with this control.
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | Value | Gets or sets the date/time value assigned to the control.
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | Overridden. Gets the default back color.
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | Overridden. Gets the default border style.
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

See Also

Reference

DateTimePicker Class
Gizmox.WebGUI.Forms Namespace


CalendarFirstDayOfWeek Property

[image]
Gizmox.WebGUI.Forms
CalendarFirstDayOfWeek Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DateTimePicker Class : CalendarFirstDayOfWeek Property

Gets or sets the first day of the week as displayed in the month calendar.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Behavior")>
<DefaultValueAttribute()>
<LocalizableAttribute(True)>
<SRDescriptionAttribute("The first day of the week.")>
Public Property CalendarFirstDayOfWeek As Day
Visual Basic (Usage) Copy Code
Dim instance As DateTimePicker
Dim value As Day

instance.CalendarFirstDayOfWeek = value

value = instance.CalendarFirstDayOfWeek
C#
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[LocalizableAttribute(true)]
[SRDescriptionAttribute("The first day of the week.")]
public Day CalendarFirstDayOfWeek {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[LocalizableAttribute(true)]
[SRDescriptionAttribute("The first day of the week.")]
public: __property Day get_CalendarFirstDayOfWeek();
public: __property void set_CalendarFirstDayOfWeek(
   Day value
);
C++/CLI
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[LocalizableAttribute(true)]
[SRDescriptionAttribute("The first day of the week.")]
public:
property Day CalendarFirstDayOfWeek {
   Day get();
   void set (Dayvalue);
}

Exceptions

Exception | Description
InvalidEnumArgumentException | The assigned value is not one of the Day enumeration members.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DateTimePicker Class
DateTimePicker Members


Checked Property

[image]
Gizmox.WebGUI.Forms
Checked Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DateTimePicker Class : Checked Property

Gets or sets a value indicating whether this DateTimePicker is checked.

Syntax

Visual Basic (Declaration)
<BindableAttribute(True)>
<SRCategoryAttribute("Behavior")>
<SRDescriptionAttribute("When ShowSelectBox is true, determines if the check box is checked, indicating that the user has selected a value.")>
<DefaultValueAttribute()>
Public Property Checked As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DateTimePicker
Dim value As Boolean

instance.Checked = value

value = instance.Checked
C#
[BindableAttribute(true)]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("When ShowSelectBox is true, determines if the check box is checked, indicating that the user has selected a value.")]
[DefaultValueAttribute()]
public bool Checked {get; set;}
Managed Extensions for C++
[BindableAttribute(true)]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("When ShowSelectBox is true, determines if the check box is checked, indicating that the user has selected a value.")]
[DefaultValueAttribute()]
public: __property bool get_Checked();
public: __property void set_Checked(
   bool value
);
C++/CLI
[BindableAttribute(true)]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("When ShowSelectBox is true, determines if the check box is checked, indicating that the user has selected a value.")]
[DefaultValueAttribute()]
public:
property bool Checked {
   bool get();
   void set (boolvalue);
}

Return Value

true if checked; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DateTimePicker Class
DateTimePicker Members


CustomFormat Property

[image]
Gizmox.WebGUI.Forms
CustomFormat Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DateTimePicker Class : CustomFormat Property

Gets or sets the custom date/time format string.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("The custom format string used to format the date and/or time displayed in the control.")>
<RefreshPropertiesAttribute()>
<DefaultValueAttribute()>
<LocalizableAttribute(True)>
<SRCategoryAttribute("Behavior")>
Public Property CustomFormat As String
Visual Basic (Usage) Copy Code
Dim instance As DateTimePicker
Dim value As String

instance.CustomFormat = value

value = instance.CustomFormat
C#
[SRDescriptionAttribute("The custom format string used to format the date and/or time displayed in the control.")]
[RefreshPropertiesAttribute()]
[DefaultValueAttribute()]
[LocalizableAttribute(true)]
[SRCategoryAttribute("Behavior")]
public string CustomFormat {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("The custom format string used to format the date and/or time displayed in the control.")]
[RefreshPropertiesAttribute()]
[DefaultValueAttribute()]
[LocalizableAttribute(true)]
[SRCategoryAttribute("Behavior")]
public: __property string* get_CustomFormat();
public: __property void set_CustomFormat(
   string* value
);
C++/CLI
[SRDescriptionAttribute("The custom format string used to format the date and/or time displayed in the control.")]
[RefreshPropertiesAttribute()]
[DefaultValueAttribute()]
[LocalizableAttribute(true)]
[SRCategoryAttribute("Behavior")]
public:
property String^ CustomFormat {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DateTimePicker Class
DateTimePicker Members


DefaultBackColor Property

[image]
Gizmox.WebGUI.Forms
DefaultBackColor Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DateTimePicker Class : DefaultBackColor Property

Gets the default back color.

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property DefaultBackColor As Color
Visual Basic (Usage) Copy Code
Dim instance As DateTimePicker
Dim value As Color

value = instance.DefaultBackColor
C#
protected override Color DefaultBackColor {get;}
Managed Extensions for C++
protected: __property Color get_DefaultBackColor() override;
C++/CLI
protected:
property Color DefaultBackColor {
   Color get() override;
}

Return Value

The default back color.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DateTimePicker Class
DateTimePicker Members


DefaultBorderStyle Property

[image]
Gizmox.WebGUI.Forms
DefaultBorderStyle Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DateTimePicker Class : DefaultBorderStyle Property

Gets the default border style.

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property DefaultBorderStyle As BorderStyle
Visual Basic (Usage) Copy Code
Dim instance As DateTimePicker
Dim value As BorderStyle

value = instance.DefaultBorderStyle
C#
protected override BorderStyle DefaultBorderStyle {get;}
Managed Extensions for C++
protected: __property BorderStyle get_DefaultBorderStyle() override;
C++/CLI
protected:
property BorderStyle DefaultBorderStyle {
   BorderStyle get() override;
}

Return Value

The default border style.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DateTimePicker Class
DateTimePicker Members


Format Property

[image]
Gizmox.WebGUI.Forms
Format Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DateTimePicker Class : Format Property

Gets or sets the format of the date and time displayed in the control.

Syntax

Visual Basic (Declaration)
Public Property Format As DateTimePickerFormat
Visual Basic (Usage) Copy Code
Dim instance As DateTimePicker
Dim value As DateTimePickerFormat

instance.Format = value

value = instance.Format
C#
public DateTimePickerFormat Format {get; set;}
Managed Extensions for C++
public: __property DateTimePickerFormat get_Format();
public: __property void set_Format(
   DateTimePickerFormat value
);
C++/CLI
public:
property DateTimePickerFormat Format {
   DateTimePickerFormat get();
   void set (DateTimePickerFormatvalue);
}

Exceptions

Exception | Description
InvalidEnumArgumentException | The value assigned is not one of the DateTimePickerFormat values.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DateTimePicker Class
DateTimePicker Members


MaxDate Property

[image]
Gizmox.WebGUI.Forms
MaxDate Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DateTimePicker Class : MaxDate Property

Gets or sets the maximum date and time that can be selected in the control.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("The maximum date that can be selected.")>
<SRCategoryAttribute("Behavior")>
Public Property MaxDate As Date
Visual Basic (Usage) Copy Code
Dim instance As DateTimePicker
Dim value As Date

instance.MaxDate = value

value = instance.MaxDate
C#
[SRDescriptionAttribute("The maximum date that can be selected.")]
[SRCategoryAttribute("Behavior")]
public DateTime MaxDate {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("The maximum date that can be selected.")]
[SRCategoryAttribute("Behavior")]
public: __property DateTime get_MaxDate();
public: __property void set_MaxDate(
   DateTime value
);
C++/CLI
[SRDescriptionAttribute("The maximum date that can be selected.")]
[SRCategoryAttribute("Behavior")]
public:
property DateTime MaxDate {
   DateTime get();
   void set (DateTimevalue);
}

Exceptions

Exception | Description
ArgumentException | The value assigned is less than the MinDate value.
SystemException | The value assigned is greater than the MaxDateTime value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DateTimePicker Class
DateTimePicker Members


MinDate Property

[image]
Gizmox.WebGUI.Forms
MinDate Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DateTimePicker Class : MinDate Property

Gets or sets the minimum date and time that can be selected in the control.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("The minimum date that can be selected.")>
<SRCategoryAttribute("Behavior")>
Public Property MinDate As Date
Visual Basic (Usage) Copy Code
Dim instance As DateTimePicker
Dim value As Date

instance.MinDate = value

value = instance.MinDate
C#
[SRDescriptionAttribute("The minimum date that can be selected.")]
[SRCategoryAttribute("Behavior")]
public DateTime MinDate {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("The minimum date that can be selected.")]
[SRCategoryAttribute("Behavior")]
public: __property DateTime get_MinDate();
public: __property void set_MinDate(
   DateTime value
);
C++/CLI
[SRDescriptionAttribute("The minimum date that can be selected.")]
[SRCategoryAttribute("Behavior")]
public:
property DateTime MinDate {
   DateTime get();
   void set (DateTimevalue);
}

Exceptions

Exception | Description
SystemException | The value assigned is less than the MinDateTime value.
ArgumentException | The value assigned is not less than the MaxDate value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DateTimePicker Class
DateTimePicker Members


ShowCheckBox Property

[image]
Gizmox.WebGUI.Forms
ShowCheckBox Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DateTimePicker Class : ShowCheckBox Property

Gets or sets a value indicating whether a check box is displayed to the left of the selected date.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Appearance")>
<DefaultValueAttribute()>
<SRDescriptionAttribute("Determines whether a check box is displayed in the control. When the box is unchecked, no value is selected.")>
Public Property ShowCheckBox As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DateTimePicker
Dim value As Boolean

instance.ShowCheckBox = value

value = instance.ShowCheckBox
C#
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Determines whether a check box is displayed in the control. When the box is unchecked, no value is selected.")]
public bool ShowCheckBox {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Determines whether a check box is displayed in the control. When the box is unchecked, no value is selected.")]
public: __property bool get_ShowCheckBox();
public: __property void set_ShowCheckBox(
   bool value
);
C++/CLI
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Determines whether a check box is displayed in the control. When the box is unchecked, no value is selected.")]
public:
property bool ShowCheckBox {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DateTimePicker Class
DateTimePicker Members


ShowUpDown Property

[image]
Gizmox.WebGUI.Forms
ShowUpDown Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DateTimePicker Class : ShowUpDown Property

Gets or sets a value indicating whether a spin button control (also known as an up-down control) is used to adjust the date/time value.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Appearance")>
<SRDescriptionAttribute("Indicates whether a spin box rather than a drop-down calendar is displayed for modifying the control value.")>
<DefaultValueAttribute()>
Public Property ShowUpDown As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DateTimePicker
Dim value As Boolean

instance.ShowUpDown = value

value = instance.ShowUpDown
C#
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Indicates whether a spin box rather than a drop-down calendar is displayed for modifying the control value.")]
[DefaultValueAttribute()]
public bool ShowUpDown {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Indicates whether a spin box rather than a drop-down calendar is displayed for modifying the control value.")]
[DefaultValueAttribute()]
public: __property bool get_ShowUpDown();
public: __property void set_ShowUpDown(
   bool value
);
C++/CLI
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Indicates whether a spin box rather than a drop-down calendar is displayed for modifying the control value.")]
[DefaultValueAttribute()]
public:
property bool ShowUpDown {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DateTimePicker Class
DateTimePicker Members


Text Property

[image]
Gizmox.WebGUI.Forms
Text Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DateTimePicker Class : Text Property

Gets or sets the text associated with this control.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<DesignerSerializationVisibilityAttribute()>
Public Overrides Property Text As String
Visual Basic (Usage) Copy Code
Dim instance As DateTimePicker
Dim value As String

instance.Text = value

value = instance.Text
C#
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[DesignerSerializationVisibilityAttribute()]
public override string Text {get; set;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[DesignerSerializationVisibilityAttribute()]
public: __property string* get_Text() override;
public: __property void set_Text(
   string* value
) override;
C++/CLI
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[DesignerSerializationVisibilityAttribute()]
public:
property String^ Text {
   String^ get() override;
   void set (String^value) override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DateTimePicker Class
DateTimePicker Members


Value Property

[image]
Gizmox.WebGUI.Forms
Value Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DateTimePicker Class : Value Property

Gets or sets the date/time value assigned to the control.

Syntax

Visual Basic (Declaration)
<BindableAttribute(True)>
<SRDescriptionAttribute("The current date/time value for this control.")>
<SRCategoryAttribute("Behavior")>
<RefreshPropertiesAttribute()>
Public Property Value As Date
Visual Basic (Usage) Copy Code
Dim instance As DateTimePicker
Dim value As Date

instance.Value = value

value = instance.Value
C#
[BindableAttribute(true)]
[SRDescriptionAttribute("The current date/time value for this control.")]
[SRCategoryAttribute("Behavior")]
[RefreshPropertiesAttribute()]
public DateTime Value {get; set;}
Managed Extensions for C++
[BindableAttribute(true)]
[SRDescriptionAttribute("The current date/time value for this control.")]
[SRCategoryAttribute("Behavior")]
[RefreshPropertiesAttribute()]
public: __property DateTime get_Value();
public: __property void set_Value(
   DateTime value
);
C++/CLI
[BindableAttribute(true)]
[SRDescriptionAttribute("The current date/time value for this control.")]
[SRCategoryAttribute("Behavior")]
[RefreshPropertiesAttribute()]
public:
property DateTime Value {
   DateTime get();
   void set (DateTimevalue);
}

Exceptions

Exception | Description
ArgumentOutOfRangeException | The set value is less than MinDate or more than MaxDate.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DateTimePicker Class
DateTimePicker Members


DateTimePicker Class Fields

[image]
Gizmox.WebGUI.Forms
DateTimePicker Class Fields
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DateTimePicker Class

For a list of all members of this type, see DateTimePicker members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | MaxDateTime | Specifies the maximum date value of the DateTimePicker control. This field is read-only.
static (Shared in Visual Basic) | MinDateTime | Gets the minimum date value of the DateTimePicker control.
Top

See Also

Reference

DateTimePicker Class
Gizmox.WebGUI.Forms Namespace


MaxDateTime Field

[image]
Gizmox.WebGUI.Forms
MaxDateTime Field
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DateTimePicker Class : MaxDateTime Field

Specifies the maximum date value of the DateTimePicker control. This field is read-only.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MaxDateTime As Date
Visual Basic (Usage) Copy Code
Dim value As Date

value = DateTimePicker.MaxDateTime
C#
public static readonly DateTime MaxDateTime
Managed Extensions for C++
public: static readonly DateTime MaxDateTime
C++/CLI
public:
static readonly DateTime MaxDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DateTimePicker Class
DateTimePicker Members


MinDateTime Field

[image]
Gizmox.WebGUI.Forms
MinDateTime Field
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DateTimePicker Class : MinDateTime Field

Gets the minimum date value of the DateTimePicker control.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly MinDateTime As Date
Visual Basic (Usage) Copy Code
Dim value As Date

value = DateTimePicker.MinDateTime
C#
public static readonly DateTime MinDateTime
Managed Extensions for C++
public: static readonly DateTime MinDateTime
C++/CLI
public:
static readonly DateTime MinDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DateTimePicker Class
DateTimePicker Members


DateTimePicker Class Events

[image]
Gizmox.WebGUI.Forms
DateTimePicker Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DateTimePicker Class

For a list of all members of this type, see DateTimePicker members.

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | ValueChanged | Occurs when the Value property changes.
Public Event | ValueChangedQueued | Occurs when the ValueChanged property changes (queued).
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

DateTimePicker Class
Gizmox.WebGUI.Forms Namespace


ValueChanged Event

[image]
Gizmox.WebGUI.Forms
ValueChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DateTimePicker Class : ValueChanged Event

Occurs when the Value property changes.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Action")>
<SRDescriptionAttribute("Occurs when the value of the control changes.")>
Public Event ValueChanged() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As DateTimePicker
Dim handler As EventHandler

AddHandler instance.ValueChanged, handler
C#
[SRCategoryAttribute("Action")]
[SRDescriptionAttribute("Occurs when the value of the control changes.")]
public event EventHandler ValueChanged()
Managed Extensions for C++
[SRCategoryAttribute("Action")]
[SRDescriptionAttribute("Occurs when the value of the control changes.")]
public: __event EventHandler* ValueChanged
C++/CLI
[SRCategoryAttribute("Action")]
[SRDescriptionAttribute("Occurs when the value of the control changes.")]
public:
event EventHandler^ ValueChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DateTimePicker Class
DateTimePicker Members


ValueChangedQueued Event

[image]
Gizmox.WebGUI.Forms
ValueChangedQueued Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DateTimePicker Class : ValueChangedQueued Event

Occurs when the ValueChanged property changes (queued).

Syntax

Visual Basic (Declaration)
Public Event ValueChangedQueued() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As DateTimePicker
Dim handler As EventHandler

AddHandler instance.ValueChangedQueued, handler
C#
public event EventHandler ValueChangedQueued()
Managed Extensions for C++
public: __event EventHandler* ValueChangedQueued
C++/CLI
public:
event EventHandler^ ValueChangedQueued

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DateTimePicker Class
DateTimePicker Members


DomainUpDown Class

[image]
Gizmox.WebGUI.Forms
DomainUpDown Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DomainUpDown Class

Represents a Windows spin box (also known as an up-down control) that displays string values.

Object Model

Syntax

Visual Basic (Declaration)
<ToolboxBitmapAttribute()>
<ClientControllerAttribute()>
<MetadataTagAttribute("DUD")>
<ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<DesignTimeControllerAttribute()>
<SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableDomainUpDown, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")>
<DefaultPropertyAttribute("Items")>
<DefaultEventAttribute("SelectedItemChanged")>
<SRDescriptionAttribute("Displays a single string value that the user selected from a list of items by clicking up and down buttons in the control.")>
Public Class DomainUpDown
   Inherits UpDownBase
   Implements IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IContainerControl, IArrangedElement
Visual Basic (Usage) Copy Code
Dim instance As DomainUpDown
C#
[ToolboxBitmapAttribute()]
[ClientControllerAttribute()]
[MetadataTagAttribute("DUD")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[DesignTimeControllerAttribute()]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableDomainUpDown, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[DefaultPropertyAttribute("Items")]
[DefaultEventAttribute("SelectedItemChanged")]
[SRDescriptionAttribute("Displays a single string value that the user selected from a list of items by clicking up and down buttons in the control.")]
public class DomainUpDown : UpDownBase, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IContainerControl, IArrangedElement
Managed Extensions for C++
[ToolboxBitmapAttribute()]
[ClientControllerAttribute()]
[MetadataTagAttribute("DUD")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[DesignTimeControllerAttribute()]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableDomainUpDown, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[DefaultPropertyAttribute("Items")]
[DefaultEventAttribute("SelectedItemChanged")]
[SRDescriptionAttribute("Displays a single string value that the user selected from a list of items by clicking up and down buttons in the control.")]
public __gc class DomainUpDown : public UpDownBase, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IContainerControl, IArrangedElement
C++/CLI
[ToolboxBitmapAttribute()]
[ClientControllerAttribute()]
[MetadataTagAttribute("DUD")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[DesignTimeControllerAttribute()]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableDomainUpDown, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[DefaultPropertyAttribute("Items")]
[DefaultEventAttribute("SelectedItemChanged")]
[SRDescriptionAttribute("Displays a single string value that the user selected from a list of items by clicking up and down buttons in the control.")]
public ref class DomainUpDown : public UpDownBase, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IContainerControl, IArrangedElement

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.ScrollableControl
Gizmox.WebGUI.Forms.ContainerControl
Gizmox.WebGUI.Forms.UpDownBase
Gizmox.WebGUI.Forms.DomainUpDown

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

DomainUpDown Members
Gizmox.WebGUI.Forms Namespace


DomainUpDown Class Members

[image]
Gizmox.WebGUI.Forms
DomainUpDown Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : DomainUpDown Class

The following tables list the members exposed by DomainUpDown.

Public Constructors

 | Name | Description
Public Constructor | DomainUpDown Constructor | Initializes a new instance of the DomainUpDown class.
Top

Public Properties

 | Name | Description
Public Property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl)
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from ContainerControl)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Components | (Inherited from ContainerControl)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | HideButtons | Gets or sets a value indicating whether the buttons are hidden or not. (Inherited from UpDownBase)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | Items | A collection of objects assigned to the spin box (also known as an up-down control).
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | ReadOnly | Gets or sets a value indicating whether the text can be changed by the use of the up or down buttons only. (Inherited from UpDownBase)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | SelectedIndex | Gets or sets the index value of the selected item.
Public Property | SelectedItem | Gets or sets the selected item based on the index value of the selected item in the collection.
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | Sorted | Gets or sets a value indicating whether the item collection is sorted.
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Control)
Public Property | TextAlign | Gets or sets the alignment of the text in the spin box (also known as an up-down control). (Inherited from UpDownBase)
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | UpDownAlign | Gets or sets the alignment of the up and down buttons on the spin box (also known as an up-down control). (Inherited from UpDownBase)
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Public Property | Wrap | Gets or sets a value indicating whether the collection of items continues to the first or last item if the user continues past the end of the list.
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Protected Property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl)
Top

Public Methods

 | Name | Description
Public Method | Add | (Inherited from ContainerControl)
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from ContainerControl)
Public Method | DownButton | Overridden. Displays the next item in the object collection.
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | Remove | (Inherited from ContainerControl)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl)
Public Method | Select | Overloaded. Selects a range of text in the spin box (also known as an up-down control) specifying the starting position and number of characters to select. (Inherited from UpDownBase)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | Overridden. Returns a string that represents the DomainUpDown control.
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | UpButton | Overridden. Displays the previous item in the collection.
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from UpDownBase)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from ScrollableControl)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnSelectedItemChanged | Raises the SelectedItemChanged event.
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Control)
Protected Method | RenderAttributes | Renders the scrollable attribute (Inherited from UpDownBase)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetValue | Sets the value. (Inherited from UpDownBase)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateEditText | Overridden. Updates the text in the spin box (also known as an up-down control) to display the selected item.
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Protected Method | ValidateEditText | When overridden in a derived class, validates the text displayed in the spin box (also known as an up-down control). (Inherited from UpDownBase)
Top

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | SelectedItemChanged | Occurs when the SelectedItem property has been changed.
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

DomainUpDown Class
Gizmox.WebGUI.Forms Namespace


DomainUpDown Constructor

[image]
Gizmox.WebGUI.Forms
DomainUpDown Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DomainUpDown Class : DomainUpDown Constructor

Initializes a new instance of the DomainUpDown class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As DomainUpDown()
C#
public DomainUpDown()
Managed Extensions for C++
public: DomainUpDown();
C++/CLI
public:
DomainUpDown();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DomainUpDown Class
DomainUpDown Members


DomainUpDown Class Methods

[image]
Gizmox.WebGUI.Forms
DomainUpDown Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DomainUpDown Class

For a list of all members of this type, see DomainUpDown members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from ContainerControl)
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from ContainerControl)
Public Method | DownButton | Overridden. Displays the next item in the object collection.
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | Remove | (Inherited from ContainerControl)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl)
Public Method | Select | Overloaded. Selects a range of text in the spin box (also known as an up-down control) specifying the starting position and number of characters to select. (Inherited from UpDownBase)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | Overridden. Returns a string that represents the DomainUpDown control.
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | UpButton | Overridden. Displays the previous item in the collection.
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from UpDownBase)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from ScrollableControl)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnSelectedItemChanged | Raises the SelectedItemChanged event.
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Control)
Protected Method | RenderAttributes | Renders the scrollable attribute (Inherited from UpDownBase)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetValue | Sets the value. (Inherited from UpDownBase)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateEditText | Overridden. Updates the text in the spin box (also known as an up-down control) to display the selected item.
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Protected Method | ValidateEditText | When overridden in a derived class, validates the text displayed in the spin box (also known as an up-down control). (Inherited from UpDownBase)
Top

See Also

Reference

DomainUpDown Class
Gizmox.WebGUI.Forms Namespace


DownButton Method

[image]
Gizmox.WebGUI.Forms
DownButton Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DomainUpDown Class : DownButton Method

Displays the next item in the object collection.

Syntax

Visual Basic (Declaration)
Public Overrides Sub DownButton()
Visual Basic (Usage) Copy Code
Dim instance As DomainUpDown

instance.DownButton()
C#
public override void DownButton()
Managed Extensions for C++
public: void DownButton(); override
C++/CLI
public:
void DownButton(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DomainUpDown Class
DomainUpDown Members


OnSelectedItemChanged Method

[image]
Gizmox.WebGUI.Forms
OnSelectedItemChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DomainUpDown Class : OnSelectedItemChanged Method

source
The source of the event.
e
An EventArgs that contains the event data.
Raises the SelectedItemChanged event.

Syntax

Visual Basic (Declaration)
Protected Sub OnSelectedItemChanged( _
   ByVal source As Object, _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As DomainUpDown
Dim source As Object
Dim e As EventArgs

instance.OnSelectedItemChanged(source, e)
C#
protected void OnSelectedItemChanged(
   object source,
   EventArgs e
)
Managed Extensions for C++
protected: void OnSelectedItemChanged(
   Object* source,
   EventArgs* e
)
C++/CLI
protected:
void OnSelectedItemChanged(
   Object^ source,
   EventArgs^ e
)

Parameters

source
The source of the event.
e
An EventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DomainUpDown Class
DomainUpDown Members


ToString Method

[image]
Gizmox.WebGUI.Forms
ToString Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DomainUpDown Class : ToString Method

Returns a string that represents the DomainUpDown control.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As DomainUpDown
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Return Value

A string that represents the current DomainUpDown.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DomainUpDown Class
DomainUpDown Members


UpButton Method

[image]
Gizmox.WebGUI.Forms
UpButton Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DomainUpDown Class : UpButton Method

Displays the previous item in the collection.

Syntax

Visual Basic (Declaration)
Public Overrides Sub UpButton()
Visual Basic (Usage) Copy Code
Dim instance As DomainUpDown

instance.UpButton()
C#
public override void UpButton()
Managed Extensions for C++
public: void UpButton(); override
C++/CLI
public:
void UpButton(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DomainUpDown Class
DomainUpDown Members


UpdateEditText Method

[image]
Gizmox.WebGUI.Forms
UpdateEditText Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DomainUpDown Class : UpdateEditText Method

Updates the text in the spin box (also known as an up-down control) to display the selected item.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub UpdateEditText()
Visual Basic (Usage) Copy Code
Dim instance As DomainUpDown

instance.UpdateEditText()
C#
protected override void UpdateEditText()
Managed Extensions for C++
protected: void UpdateEditText(); override
C++/CLI
protected:
void UpdateEditText(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DomainUpDown Class
DomainUpDown Members


DomainUpDown Class Properties

[image]
Gizmox.WebGUI.Forms
DomainUpDown Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DomainUpDown Class

For a list of all members of this type, see DomainUpDown members.

Public Properties

 | Name | Description
Public Property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl)
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from ContainerControl)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Components | (Inherited from ContainerControl)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | HideButtons | Gets or sets a value indicating whether the buttons are hidden or not. (Inherited from UpDownBase)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | Items | A collection of objects assigned to the spin box (also known as an up-down control).
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | ReadOnly | Gets or sets a value indicating whether the text can be changed by the use of the up or down buttons only. (Inherited from UpDownBase)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | SelectedIndex | Gets or sets the index value of the selected item.
Public Property | SelectedItem | Gets or sets the selected item based on the index value of the selected item in the collection.
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | Sorted | Gets or sets a value indicating whether the item collection is sorted.
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Control)
Public Property | TextAlign | Gets or sets the alignment of the text in the spin box (also known as an up-down control). (Inherited from UpDownBase)
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | UpDownAlign | Gets or sets the alignment of the up and down buttons on the spin box (also known as an up-down control). (Inherited from UpDownBase)
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Public Property | Wrap | Gets or sets a value indicating whether the collection of items continues to the first or last item if the user continues past the end of the list.
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Protected Property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl)
Top

See Also

Reference

DomainUpDown Class
Gizmox.WebGUI.Forms Namespace


Items Property

[image]
Gizmox.WebGUI.Forms
Items Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DomainUpDown Class : Items Property

A collection of objects assigned to the spin box (also known as an up-down control).

Syntax

Visual Basic (Declaration)
<LocalizableAttribute(True)>
<SRDescriptionAttribute("The allowable values of the DomainUpDown.")>
<SRCategoryAttribute("Data")>
<DesignerSerializationVisibilityAttribute()>
Public ReadOnly Property Items As DomainUpDown.DomainUpDownItemCollection
Visual Basic (Usage) Copy Code
Dim instance As DomainUpDown
Dim value As DomainUpDown.DomainUpDownItemCollection

value = instance.Items
C#
[LocalizableAttribute(true)]
[SRDescriptionAttribute("The allowable values of the DomainUpDown.")]
[SRCategoryAttribute("Data")]
[DesignerSerializationVisibilityAttribute()]
public DomainUpDown.DomainUpDownItemCollection Items {get;}
Managed Extensions for C++
[LocalizableAttribute(true)]
[SRDescriptionAttribute("The allowable values of the DomainUpDown.")]
[SRCategoryAttribute("Data")]
[DesignerSerializationVisibilityAttribute()]
public: __property DomainUpDown.DomainUpDownItemCollection* get_Items();
C++/CLI
[LocalizableAttribute(true)]
[SRDescriptionAttribute("The allowable values of the DomainUpDown.")]
[SRCategoryAttribute("Data")]
[DesignerSerializationVisibilityAttribute()]
public:
property DomainUpDown::DomainUpDownItemCollection^ Items {
   DomainUpDown::DomainUpDownItemCollection^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DomainUpDown Class
DomainUpDown Members


SelectedIndex Property

[image]
Gizmox.WebGUI.Forms
SelectedIndex Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DomainUpDown Class : SelectedIndex Property

Gets or sets the index value of the selected item.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<SRCategoryAttribute("Appearance")>
<DefaultValueAttribute()>
<SRDescriptionAttribute("The index of the selected domain value.")>
Public Property SelectedIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As DomainUpDown
Dim value As Integer

instance.SelectedIndex = value

value = instance.SelectedIndex
C#
[BrowsableAttribute(false)]
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("The index of the selected domain value.")]
public int SelectedIndex {get; set;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("The index of the selected domain value.")]
public: __property int get_SelectedIndex();
public: __property void set_SelectedIndex(
   int value
);
C++/CLI
[BrowsableAttribute(false)]
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("The index of the selected domain value.")]
public:
property int SelectedIndex {
   int get();
   void set (intvalue);
}

Exceptions

Exception | Description
ArgumentOutOfRangeException | The assigned value is less than the default, -1.-or- The assigned value is greater than the Items count.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DomainUpDown Class
DomainUpDown Members


SelectedItem Property

[image]
Gizmox.WebGUI.Forms
SelectedItem Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DomainUpDown Class : SelectedItem Property

Gets or sets the selected item based on the index value of the selected item in the collection.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("The currently selected domain value.")>
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
Public Property SelectedItem As Object
Visual Basic (Usage) Copy Code
Dim instance As DomainUpDown
Dim value As Object

instance.SelectedItem = value

value = instance.SelectedItem
C#
[SRDescriptionAttribute("The currently selected domain value.")]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public object SelectedItem {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("The currently selected domain value.")]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public: __property Object* get_SelectedItem();
public: __property void set_SelectedItem(
   Object* value
);
C++/CLI
[SRDescriptionAttribute("The currently selected domain value.")]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public:
property Object^ SelectedItem {
   Object^ get();
   void set (Object^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DomainUpDown Class
DomainUpDown Members


Sorted Property

[image]
Gizmox.WebGUI.Forms
Sorted Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DomainUpDown Class : Sorted Property

Gets or sets a value indicating whether the item collection is sorted.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Controls whether items in the domain list are sorted.")>
<DefaultValueAttribute()>
<SRCategoryAttribute("Behavior")>
Public Property Sorted As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DomainUpDown
Dim value As Boolean

instance.Sorted = value

value = instance.Sorted
C#
[SRDescriptionAttribute("Controls whether items in the domain list are sorted.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
public bool Sorted {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Controls whether items in the domain list are sorted.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
public: __property bool get_Sorted();
public: __property void set_Sorted(
   bool value
);
C++/CLI
[SRDescriptionAttribute("Controls whether items in the domain list are sorted.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
public:
property bool Sorted {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DomainUpDown Class
DomainUpDown Members


Wrap Property

[image]
Gizmox.WebGUI.Forms
Wrap Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DomainUpDown Class : Wrap Property

Gets or sets a value indicating whether the collection of items continues to the first or last item if the user continues past the end of the list.

Syntax

Visual Basic (Declaration)
<LocalizableAttribute(True)>
<SRDescriptionAttribute("Indicates whether values wrap around at either end of the item list.")>
<DefaultValueAttribute()>
<SRCategoryAttribute("Behavior")>
Public Property Wrap As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DomainUpDown
Dim value As Boolean

instance.Wrap = value

value = instance.Wrap
C#
[LocalizableAttribute(true)]
[SRDescriptionAttribute("Indicates whether values wrap around at either end of the item list.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
public bool Wrap {get; set;}
Managed Extensions for C++
[LocalizableAttribute(true)]
[SRDescriptionAttribute("Indicates whether values wrap around at either end of the item list.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
public: __property bool get_Wrap();
public: __property void set_Wrap(
   bool value
);
C++/CLI
[LocalizableAttribute(true)]
[SRDescriptionAttribute("Indicates whether values wrap around at either end of the item list.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
public:
property bool Wrap {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DomainUpDown Class
DomainUpDown Members


DomainUpDown Class Events

[image]
Gizmox.WebGUI.Forms
DomainUpDown Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DomainUpDown Class

For a list of all members of this type, see DomainUpDown members.

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | SelectedItemChanged | Occurs when the SelectedItem property has been changed.
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

DomainUpDown Class
Gizmox.WebGUI.Forms Namespace


SelectedItemChanged Event

[image]
Gizmox.WebGUI.Forms
SelectedItemChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DomainUpDown Class : SelectedItemChanged Event

Occurs when the SelectedItem property has been changed.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the selected item in the control changes.")>
<SRCategoryAttribute("Behavior")>
Public Event SelectedItemChanged() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As DomainUpDown
Dim handler As EventHandler

AddHandler instance.SelectedItemChanged, handler
C#
[SRDescriptionAttribute("Occurs when the selected item in the control changes.")]
[SRCategoryAttribute("Behavior")]
public event EventHandler SelectedItemChanged()
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the selected item in the control changes.")]
[SRCategoryAttribute("Behavior")]
public: __event EventHandler* SelectedItemChanged
C++/CLI
[SRDescriptionAttribute("Occurs when the selected item in the control changes.")]
[SRCategoryAttribute("Behavior")]
public:
event EventHandler^ SelectedItemChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DomainUpDown Class
DomainUpDown Members


DomainUpDown.DomainUpDownItemCollection Class

[image]
Gizmox.WebGUI.Forms
DomainUpDown.DomainUpDownItemCollection Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DomainUpDown.DomainUpDownItemCollection Class

Encapsulates a collection of objects for use by the DomainUpDown class.

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class DomainUpDown.DomainUpDownItemCollection
   Inherits ArrayList
Visual Basic (Usage) Copy Code
Dim instance As DomainUpDown.DomainUpDownItemCollection
C#
[DefaultMemberAttribute("Item")]
public class DomainUpDown.DomainUpDownItemCollection : ArrayList
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
public __gc class DomainUpDown.DomainUpDownItemCollection : public ArrayList
C++/CLI
[DefaultMemberAttribute("Item")]
public ref class DomainUpDown.DomainUpDownItemCollection : public ArrayList

Inheritance Hierarchy

System.Object
System.Collections.ArrayList
Gizmox.WebGUI.Forms.DomainUpDown.DomainUpDownItemCollection

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

DomainUpDown.DomainUpDownItemCollection Members
Gizmox.WebGUI.Forms Namespace


DomainUpDown.DomainUpDownItemCollection Class Members

[image]
Gizmox.WebGUI.Forms
DomainUpDown.DomainUpDownItemCollection Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : DomainUpDown.DomainUpDownItemCollection Class

The following tables list the members exposed by DomainUpDown.DomainUpDownItemCollection.

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the ArrayList can contain. (Inherited from System.Collections.ArrayList)
Public Property | Count | Gets the number of elements actually contained in the ArrayList. (Inherited from System.Collections.ArrayList)
Public Property | IsFixedSize | Gets a value indicating whether the ArrayList has a fixed size. (Inherited from System.Collections.ArrayList)
Public Property | IsReadOnly | Gets a value indicating whether the ArrayList is read-only. (Inherited from System.Collections.ArrayList)
Public Property | IsSynchronized | Gets a value indicating whether access to the ArrayList is synchronized (thread safe). (Inherited from System.Collections.ArrayList)
Public Property | Item | Overridden. Gets or sets the item at the specified indexed location in the collection.
Public Property | SyncRoot | Gets an object that can be used to synchronize access to the ArrayList. (Inherited from System.Collections.ArrayList)
Top

Public Methods

 | Name | Description
Public Method | Add | Overridden. Adds the specified object to the end of the collection.
Public Method | AddRange | Adds the elements of an ICollection to the end of the ArrayList. (Inherited from System.Collections.ArrayList)
Public Method | BinarySearch | Overloaded. Searches a range of elements in the sorted ArrayList for an element using the specified comparer and returns the zero-based index of the element. (Inherited from System.Collections.ArrayList)
Public Method | Clear | Removes all elements from the ArrayList. (Inherited from System.Collections.ArrayList)
Public Method | Clone | Creates a shallow copy of the ArrayList. (Inherited from System.Collections.ArrayList)
Public Method | Contains | Determines whether an element is in the ArrayList. (Inherited from System.Collections.ArrayList)
Public Method | CopyTo | Overloaded. Copies the entire ArrayList to a compatible one-dimensional Array, starting at the beginning of the target array. (Inherited from System.Collections.ArrayList)
Public Method | GetEnumerator | Overloaded. Returns an enumerator for the entire ArrayList. (Inherited from System.Collections.ArrayList)
Public Method | GetRange | Returns an ArrayList which represents a subset of the elements in the source ArrayList. (Inherited from System.Collections.ArrayList)
Public Method | IndexOf | Overloaded. Searches for the specified Object and returns the zero-based index of the first occurrence within the entire ArrayList. (Inherited from System.Collections.ArrayList)
Public Method | Insert | Overridden. Inserts the specified object into the collection at the specified location.
Public Method | InsertRange | Inserts the elements of a collection into the ArrayList at the specified index. (Inherited from System.Collections.ArrayList)
Public Method | LastIndexOf | Overloaded. Searches for the specified Object and returns the zero-based index of the last occurrence within the entire ArrayList. (Inherited from System.Collections.ArrayList)
Public Method | Remove | Overridden. Removes the specified item from the collection.
Public Method | RemoveAt | Overridden. Removes the item from the specified location in the collection.
Public Method | RemoveRange | Removes a range of elements from the ArrayList. (Inherited from System.Collections.ArrayList)
Public Method | Reverse | Overloaded. Reverses the order of the elements in the entire ArrayList. (Inherited from System.Collections.ArrayList)
Public Method | SetRange | Copies the elements of a collection over a range of elements in the ArrayList. (Inherited from System.Collections.ArrayList)
Public Method | Sort | Overloaded. Sorts the elements in the entire ArrayList using the IComparable implementation of each element. (Inherited from System.Collections.ArrayList)
Public Method | ToArray | Overloaded. Copies the elements of the ArrayList to a new Object array. (Inherited from System.Collections.ArrayList)
Public Method | TrimToSize | Sets the capacity to the actual number of elements in the ArrayList. (Inherited from System.Collections.ArrayList)
Top

See Also

Reference

DomainUpDown.DomainUpDownItemCollection Class
Gizmox.WebGUI.Forms Namespace


DomainUpDown.DomainUpDownItemCollection Class Methods

[image]
Gizmox.WebGUI.Forms
DomainUpDown.DomainUpDownItemCollection Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DomainUpDown.DomainUpDownItemCollection Class

For a list of all members of this type, see DomainUpDown.DomainUpDownItemCollection members.

Public Methods

 | Name | Description
Public Method | Add | Overridden. Adds the specified object to the end of the collection.
Public Method | AddRange | Adds the elements of an ICollection to the end of the ArrayList. (Inherited from System.Collections.ArrayList)
Public Method | BinarySearch | Overloaded. Searches a range of elements in the sorted ArrayList for an element using the specified comparer and returns the zero-based index of the element. (Inherited from System.Collections.ArrayList)
Public Method | Clear | Removes all elements from the ArrayList. (Inherited from System.Collections.ArrayList)
Public Method | Clone | Creates a shallow copy of the ArrayList. (Inherited from System.Collections.ArrayList)
Public Method | Contains | Determines whether an element is in the ArrayList. (Inherited from System.Collections.ArrayList)
Public Method | CopyTo | Overloaded. Copies the entire ArrayList to a compatible one-dimensional Array, starting at the beginning of the target array. (Inherited from System.Collections.ArrayList)
Public Method | GetEnumerator | Overloaded. Returns an enumerator for the entire ArrayList. (Inherited from System.Collections.ArrayList)
Public Method | GetRange | Returns an ArrayList which represents a subset of the elements in the source ArrayList. (Inherited from System.Collections.ArrayList)
Public Method | IndexOf | Overloaded. Searches for the specified Object and returns the zero-based index of the first occurrence within the entire ArrayList. (Inherited from System.Collections.ArrayList)
Public Method | Insert | Overridden. Inserts the specified object into the collection at the specified location.
Public Method | InsertRange | Inserts the elements of a collection into the ArrayList at the specified index. (Inherited from System.Collections.ArrayList)
Public Method | LastIndexOf | Overloaded. Searches for the specified Object and returns the zero-based index of the last occurrence within the entire ArrayList. (Inherited from System.Collections.ArrayList)
Public Method | Remove | Overridden. Removes the specified item from the collection.
Public Method | RemoveAt | Overridden. Removes the item from the specified location in the collection.
Public Method | RemoveRange | Removes a range of elements from the ArrayList. (Inherited from System.Collections.ArrayList)
Public Method | Reverse | Overloaded. Reverses the order of the elements in the entire ArrayList. (Inherited from System.Collections.ArrayList)
Public Method | SetRange | Copies the elements of a collection over a range of elements in the ArrayList. (Inherited from System.Collections.ArrayList)
Public Method | Sort | Overloaded. Sorts the elements in the entire ArrayList using the IComparable implementation of each element. (Inherited from System.Collections.ArrayList)
Public Method | ToArray | Overloaded. Copies the elements of the ArrayList to a new Object array. (Inherited from System.Collections.ArrayList)
Public Method | TrimToSize | Sets the capacity to the actual number of elements in the ArrayList. (Inherited from System.Collections.ArrayList)
Top

See Also

Reference

DomainUpDown.DomainUpDownItemCollection Class
Gizmox.WebGUI.Forms Namespace


Add Method

[image]
Gizmox.WebGUI.Forms
Add Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DomainUpDown.DomainUpDownItemCollection Class : Add Method

item
The Object to be added to the end of the collection.
Adds the specified object to the end of the collection.

Syntax

Visual Basic (Declaration)
Public Overrides Function Add( _
   ByVal item As Object _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As DomainUpDown.DomainUpDownItemCollection
Dim item As Object
Dim value As Integer

value = instance.Add(item)
C#
public override int Add(
   object item
)
Managed Extensions for C++
public: int Add(
   Object* item
) override
C++/CLI
public:
int Add(
   Object^ item
) override

Parameters

item
The Object to be added to the end of the collection.

Return Value

The zero-based index value of the Object added to the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DomainUpDown.DomainUpDownItemCollection Class
DomainUpDown.DomainUpDownItemCollection Members


Insert Method

[image]
Gizmox.WebGUI.Forms
Insert Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DomainUpDown.DomainUpDownItemCollection Class : Insert Method

index
The indexed location within the collection to insert the Object.
item
The Object to insert.
Inserts the specified object into the collection at the specified location.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Insert( _
   ByVal index As Integer, _
   ByVal item As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As DomainUpDown.DomainUpDownItemCollection
Dim index As Integer
Dim item As Object

instance.Insert(index, item)
C#
public override void Insert(
   int index,
   object item
)
Managed Extensions for C++
public: void Insert(
   int index,
   Object* item
) override
C++/CLI
public:
void Insert(
   int index,
   Object^ item
) override

Parameters

index
The indexed location within the collection to insert the Object.
item
The Object to insert.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DomainUpDown.DomainUpDownItemCollection Class
DomainUpDown.DomainUpDownItemCollection Members


Remove Method

[image]
Gizmox.WebGUI.Forms
Remove Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DomainUpDown.DomainUpDownItemCollection Class : Remove Method

item
The Object to remove from the collection.
Removes the specified item from the collection.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Remove( _
   ByVal item As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As DomainUpDown.DomainUpDownItemCollection
Dim item As Object

instance.Remove(item)
C#
public override void Remove(
   object item
)
Managed Extensions for C++
public: void Remove(
   Object* item
) override
C++/CLI
public:
void Remove(
   Object^ item
) override

Parameters

item
The Object to remove from the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DomainUpDown.DomainUpDownItemCollection Class
DomainUpDown.DomainUpDownItemCollection Members


RemoveAt Method

[image]
Gizmox.WebGUI.Forms
RemoveAt Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DomainUpDown.DomainUpDownItemCollection Class : RemoveAt Method

item
The indexed location of the Object in the collection.
Removes the item from the specified location in the collection.

Syntax

Visual Basic (Declaration)
Public Overrides Sub RemoveAt( _
   ByVal item As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As DomainUpDown.DomainUpDownItemCollection
Dim item As Integer

instance.RemoveAt(item)
C#
public override void RemoveAt(
   int item
)
Managed Extensions for C++
public: void RemoveAt(
   int item
) override
C++/CLI
public:
void RemoveAt(
   int item
) override

Parameters

item
The indexed location of the Object in the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DomainUpDown.DomainUpDownItemCollection Class
DomainUpDown.DomainUpDownItemCollection Members


DomainUpDown.DomainUpDownItemCollection Class Properties

[image]
Gizmox.WebGUI.Forms
DomainUpDown.DomainUpDownItemCollection Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DomainUpDown.DomainUpDownItemCollection Class

For a list of all members of this type, see DomainUpDown.DomainUpDownItemCollection members.

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the ArrayList can contain. (Inherited from System.Collections.ArrayList)
Public Property | Count | Gets the number of elements actually contained in the ArrayList. (Inherited from System.Collections.ArrayList)
Public Property | IsFixedSize | Gets a value indicating whether the ArrayList has a fixed size. (Inherited from System.Collections.ArrayList)
Public Property | IsReadOnly | Gets a value indicating whether the ArrayList is read-only. (Inherited from System.Collections.ArrayList)
Public Property | IsSynchronized | Gets a value indicating whether access to the ArrayList is synchronized (thread safe). (Inherited from System.Collections.ArrayList)
Public Property | Item | Overridden. Gets or sets the item at the specified indexed location in the collection.
Public Property | SyncRoot | Gets an object that can be used to synchronize access to the ArrayList. (Inherited from System.Collections.ArrayList)
Top

See Also

Reference

DomainUpDown.DomainUpDownItemCollection Class
Gizmox.WebGUI.Forms Namespace


Item Property

[image]
Gizmox.WebGUI.Forms
Item Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DomainUpDown.DomainUpDownItemCollection Class : Item Property

index
The indexed location of the item in the collection.
Gets or sets the item at the specified indexed location in the collection.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public Overrides Default Property Item( _
   ByVal index As Integer _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As DomainUpDown.DomainUpDownItemCollection
Dim index As Integer
Dim value As Object

instance.Item(index) = value

value = instance.Item(index)
C#
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public override object this[
   int index
]; {get; set;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property Object* get_Item(
   int index
) override;
public: __property void set_Item(
   int index,
   Object* value
) override;
C++/CLI
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
property Object^ default [int] override {
   Object^ get(intindex) override;
   void set (intindex, Object^value) override;
}

Parameters

index
The indexed location of the item in the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DomainUpDown.DomainUpDownItemCollection Class
DomainUpDown.DomainUpDownItemCollection Members


DragDropEventArgs Class

[image]
Gizmox.WebGUI.Forms
DragDropEventArgs Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DragDropEventArgs Class

Contains Drag and drop event arguments.

Object Model

Syntax

Visual Basic (Declaration)
<ComVisibleAttribute(True)>
Public Class DragDropEventArgs
   Inherits DragEventArgs
Visual Basic (Usage) Copy Code
Dim instance As DragDropEventArgs
C#
[ComVisibleAttribute(true)]
public class DragDropEventArgs : DragEventArgs
Managed Extensions for C++
[ComVisibleAttribute(true)]
public __gc class DragDropEventArgs : public DragEventArgs
C++/CLI
[ComVisibleAttribute(true)]
public ref class DragDropEventArgs : public DragEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gizmox.WebGUI.Forms.DragEventArgs
Gizmox.WebGUI.Forms.DragDropEventArgs

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

DragDropEventArgs Members
Gizmox.WebGUI.Forms Namespace


DragDropEventArgs Class Members

[image]
Gizmox.WebGUI.Forms
DragDropEventArgs Class Members
See Also Properties Send Feedback
Gizmox.WebGUI.Forms Namespace : DragDropEventArgs Class

The following tables list the members exposed by DragDropEventArgs.

Public Constructors

 | Name | Description
Public Constructor | DragDropEventArgs Constructor | Overloaded. Initializes a new instance of the DragDropEventArgs class.
Top

Public Properties

 | Name | Description
Public Property | AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event. (Inherited from DragEventArgs)
Public Property | Data | Gets the IDataObject that contains the data associated with this event. (Inherited from DragEventArgs)
Public Property | Effect | Gets or sets the target drop effect in a drag-and-drop operation. (Inherited from DragEventArgs)
Public Property | KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons. (Inherited from DragEventArgs)
Public Property | Source | Gets the source component.
Public Property | SourceMember | Gets the source component member.
Public Property | Target | Gets the target component.
Public Property | TargetMember | Gets the target component member.
Public Property | X | Gets the x-coordinate of the mouse pointer, in screen coordinates. (Inherited from DragEventArgs)
Public Property | Y | Gets the y-coordinate of the mouse pointer, in screen coordinates. (Inherited from DragEventArgs)
Top

See Also

Reference

DragDropEventArgs Class
Gizmox.WebGUI.Forms Namespace


DragDropEventArgs Constructor

[image]
Gizmox.WebGUI.Forms
DragDropEventArgs Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DragDropEventArgs Class : DragDropEventArgs Constructor

Initializes a new instance of the DragDropEventArgs class.

Overload List

Overload | Description
DragDropEventArgs Constructor(Component,Component,Component,Component,Int32,Int32,Int32,DragDropEffects,DragDropEffects) | Initializes a new instance of the DragDropEventArgs class.
DragDropEventArgs Constructor(IDataObject,Int32,Int32,Int32,DragDropEffects,DragDropEffects) | Initializes a new instance of the DragDropEventArgs class.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DragDropEventArgs Class
DragDropEventArgs Members


DragDropEventArgs Constructor(Component,Component,Component,Component,Int32,Int32,Int32,DragDropEffects,DragDropEffects)

[image]
Gizmox.WebGUI.Forms
DragDropEventArgs Constructor(Component,Component,Component,Component,Int32,Int32,Int32,DragDropEffects,DragDropEffects)
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DragDropEventArgs Class > DragDropEventArgs Constructor : DragDropEventArgs Constructor(Component,Component,Component,Component,Int32,Int32,Int32,DragDropEffects,DragDropEffects)

objSource
The source.
objSourceMember
The source member.
objTarget
The target.
objTargetMember
The target member.
keyState
State of the key.
x
The x.
y
The y.
allowedEffect
The allowed effect.
effect
The effect.
Initializes a new instance of the DragDropEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal objSource As Component, _
   ByVal objSourceMember As Component, _
   ByVal objTarget As Component, _
   ByVal objTargetMember As Component, _
   ByVal keyState As Integer, _
   ByVal x As Integer, _
   ByVal y As Integer, _
   ByVal allowedEffect As DragDropEffects, _
   ByVal effect As DragDropEffects _
)
Visual Basic (Usage) Copy Code
Dim objSource As Component
Dim objSourceMember As Component
Dim objTarget As Component
Dim objTargetMember As Component
Dim keyState As Integer
Dim x As Integer
Dim y As Integer
Dim allowedEffect As DragDropEffects
Dim effect As DragDropEffects

Dim instance As DragDropEventArgs(objSource, objSourceMember, objTarget, objTargetMember, keyState, x, y, allowedEffect, effect)
C#
public DragDropEventArgs(
   Component objSource,
   Component objSourceMember,
   Component objTarget,
   Component objTargetMember,
   int keyState,
   int x,
   int y,
   DragDropEffects allowedEffect,
   DragDropEffects effect
)
Managed Extensions for C++
public: DragDropEventArgs(
   Component* objSource,
   Component* objSourceMember,
   Component* objTarget,
   Component* objTargetMember,
   int keyState,
   int x,
   int y,
   DragDropEffects allowedEffect,
   DragDropEffects effect
)
C++/CLI
public:
DragDropEventArgs(
   Component^ objSource,
   Component^ objSourceMember,
   Component^ objTarget,
   Component^ objTargetMember,
   int keyState,
   int x,
   int y,
   DragDropEffects allowedEffect,
   DragDropEffects effect
)

Parameters

objSource
The source.
objSourceMember
The source member.
objTarget
The target.
objTargetMember
The target member.
keyState
State of the key.
x
The x.
y
The y.
allowedEffect
The allowed effect.
effect
The effect.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DragDropEventArgs Class
DragDropEventArgs Members
Overload List


DragDropEventArgs Constructor(IDataObject,Int32,Int32,Int32,DragDropEffects,DragDropEffects)

[image]
Gizmox.WebGUI.Forms
DragDropEventArgs Constructor(IDataObject,Int32,Int32,Int32,DragDropEffects,DragDropEffects)
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DragDropEventArgs Class > DragDropEventArgs Constructor : DragDropEventArgs Constructor(IDataObject,Int32,Int32,Int32,DragDropEffects,DragDropEffects)

data
The data associated with this event.
keyState
The current state of the SHIFT, CTRL, and ALT keys.
x
The x-coordinate of the mouse cursor in pixels.
y
The y-coordinate of the mouse cursor in pixels.
allowedEffect
One of the DragDropEffects values.
effect
One of the DragDropEffects values.
Initializes a new instance of the DragDropEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As IDataObject, _
   ByVal keyState As Integer, _
   ByVal x As Integer, _
   ByVal y As Integer, _
   ByVal allowedEffect As DragDropEffects, _
   ByVal effect As DragDropEffects _
)
Visual Basic (Usage) Copy Code
Dim data As IDataObject
Dim keyState As Integer
Dim x As Integer
Dim y As Integer
Dim allowedEffect As DragDropEffects
Dim effect As DragDropEffects

Dim instance As DragDropEventArgs(data, keyState, x, y, allowedEffect, effect)
C#
public DragDropEventArgs(
   IDataObject data,
   int keyState,
   int x,
   int y,
   DragDropEffects allowedEffect,
   DragDropEffects effect
)
Managed Extensions for C++
public: DragDropEventArgs(
   IDataObject* data,
   int keyState,
   int x,
   int y,
   DragDropEffects allowedEffect,
   DragDropEffects effect
)
C++/CLI
public:
DragDropEventArgs(
   IDataObject^ data,
   int keyState,
   int x,
   int y,
   DragDropEffects allowedEffect,
   DragDropEffects effect
)

Parameters

data
The data associated with this event.
keyState
The current state of the SHIFT, CTRL, and ALT keys.
x
The x-coordinate of the mouse cursor in pixels.
y
The y-coordinate of the mouse cursor in pixels.
allowedEffect
One of the DragDropEffects values.
effect
One of the DragDropEffects values.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DragDropEventArgs Class
DragDropEventArgs Members
Overload List


DragDropEventArgs Class Properties

[image]
Gizmox.WebGUI.Forms
DragDropEventArgs Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DragDropEventArgs Class

For a list of all members of this type, see DragDropEventArgs members.

Public Properties

 | Name | Description
Public Property | AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event. (Inherited from DragEventArgs)
Public Property | Data | Gets the IDataObject that contains the data associated with this event. (Inherited from DragEventArgs)
Public Property | Effect | Gets or sets the target drop effect in a drag-and-drop operation. (Inherited from DragEventArgs)
Public Property | KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons. (Inherited from DragEventArgs)
Public Property | Source | Gets the source component.
Public Property | SourceMember | Gets the source component member.
Public Property | Target | Gets the target component.
Public Property | TargetMember | Gets the target component member.
Public Property | X | Gets the x-coordinate of the mouse pointer, in screen coordinates. (Inherited from DragEventArgs)
Public Property | Y | Gets the y-coordinate of the mouse pointer, in screen coordinates. (Inherited from DragEventArgs)
Top

See Also

Reference

DragDropEventArgs Class
Gizmox.WebGUI.Forms Namespace


Source Property

[image]
Gizmox.WebGUI.Forms
Source Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DragDropEventArgs Class : Source Property

Gets the source component.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Source As Component
Visual Basic (Usage) Copy Code
Dim instance As DragDropEventArgs
Dim value As Component

value = instance.Source
C#
public Component Source {get;}
Managed Extensions for C++
public: __property Component* get_Source();
C++/CLI
public:
property Component^ Source {
   Component^ get();
}

Return Value

The source component.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DragDropEventArgs Class
DragDropEventArgs Members


SourceMember Property

[image]
Gizmox.WebGUI.Forms
SourceMember Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DragDropEventArgs Class : SourceMember Property

Gets the source component member.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SourceMember As Component
Visual Basic (Usage) Copy Code
Dim instance As DragDropEventArgs
Dim value As Component

value = instance.SourceMember
C#
public Component SourceMember {get;}
Managed Extensions for C++
public: __property Component* get_SourceMember();
C++/CLI
public:
property Component^ SourceMember {
   Component^ get();
}

Return Value

The source component member.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DragDropEventArgs Class
DragDropEventArgs Members


Target Property

[image]
Gizmox.WebGUI.Forms
Target Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DragDropEventArgs Class : Target Property

Gets the target component.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Target As Component
Visual Basic (Usage) Copy Code
Dim instance As DragDropEventArgs
Dim value As Component

value = instance.Target
C#
public Component Target {get;}
Managed Extensions for C++
public: __property Component* get_Target();
C++/CLI
public:
property Component^ Target {
   Component^ get();
}

Return Value

The target component.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DragDropEventArgs Class
DragDropEventArgs Members


TargetMember Property

[image]
Gizmox.WebGUI.Forms
TargetMember Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DragDropEventArgs Class : TargetMember Property

Gets the target component member.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TargetMember As Component
Visual Basic (Usage) Copy Code
Dim instance As DragDropEventArgs
Dim value As Component

value = instance.TargetMember
C#
public Component TargetMember {get;}
Managed Extensions for C++
public: __property Component* get_TargetMember();
C++/CLI
public:
property Component^ TargetMember {
   Component^ get();
}

Return Value

The target component member.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DragDropEventArgs Class
DragDropEventArgs Members


DragEventArgs Class

[image]
Gizmox.WebGUI.Forms
DragEventArgs Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DragEventArgs Class

Provides data for the DragDrop, DragEnter, or DragOver event.

Object Model

Syntax

Visual Basic (Declaration)
<ComVisibleAttribute(True)>
Public Class DragEventArgs
   Inherits EventArgs
Visual Basic (Usage) Copy Code
Dim instance As DragEventArgs
C#
[ComVisibleAttribute(true)]
public class DragEventArgs : EventArgs
Managed Extensions for C++
[ComVisibleAttribute(true)]
public __gc class DragEventArgs : public EventArgs
C++/CLI
[ComVisibleAttribute(true)]
public ref class DragEventArgs : public EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gizmox.WebGUI.Forms.DragEventArgs
Gizmox.WebGUI.Forms.DragDropEventArgs

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

DragEventArgs Members
Gizmox.WebGUI.Forms Namespace


DragEventArgs Class Members

[image]
Gizmox.WebGUI.Forms
DragEventArgs Class Members
See Also Properties Send Feedback
Gizmox.WebGUI.Forms Namespace : DragEventArgs Class

The following tables list the members exposed by DragEventArgs.

Public Constructors

 | Name | Description
Public Constructor | DragEventArgs Constructor | Initializes a new instance of the DragEventArgs class.
Top

Public Properties

 | Name | Description
Public Property | AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Public Property | Data | Gets the IDataObject that contains the data associated with this event.
Public Property | Effect | Gets or sets the target drop effect in a drag-and-drop operation.
Public Property | KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
Public Property | X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Public Property | Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.
Top

See Also

Reference

DragEventArgs Class
Gizmox.WebGUI.Forms Namespace


DragEventArgs Constructor

[image]
Gizmox.WebGUI.Forms
DragEventArgs Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DragEventArgs Class : DragEventArgs Constructor

data
The data associated with this event.
keyState
The current state of the SHIFT, CTRL, and ALT keys.
x
The x-coordinate of the mouse cursor in pixels.
y
The y-coordinate of the mouse cursor in pixels.
allowedEffect
One of the DragDropEffects values.
effect
One of the DragDropEffects values.
Initializes a new instance of the DragEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data As IDataObject, _
   ByVal keyState As Integer, _
   ByVal x As Integer, _
   ByVal y As Integer, _
   ByVal allowedEffect As DragDropEffects, _
   ByVal effect As DragDropEffects _
)
Visual Basic (Usage) Copy Code
Dim data As IDataObject
Dim keyState As Integer
Dim x As Integer
Dim y As Integer
Dim allowedEffect As DragDropEffects
Dim effect As DragDropEffects

Dim instance As DragEventArgs(data, keyState, x, y, allowedEffect, effect)
C#
public DragEventArgs(
   IDataObject data,
   int keyState,
   int x,
   int y,
   DragDropEffects allowedEffect,
   DragDropEffects effect
)
Managed Extensions for C++
public: DragEventArgs(
   IDataObject* data,
   int keyState,
   int x,
   int y,
   DragDropEffects allowedEffect,
   DragDropEffects effect
)
C++/CLI
public:
DragEventArgs(
   IDataObject^ data,
   int keyState,
   int x,
   int y,
   DragDropEffects allowedEffect,
   DragDropEffects effect
)

Parameters

data
The data associated with this event.
keyState
The current state of the SHIFT, CTRL, and ALT keys.
x
The x-coordinate of the mouse cursor in pixels.
y
The y-coordinate of the mouse cursor in pixels.
allowedEffect
One of the DragDropEffects values.
effect
One of the DragDropEffects values.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DragEventArgs Class
DragEventArgs Members


DragEventArgs Class Properties

[image]
Gizmox.WebGUI.Forms
DragEventArgs Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DragEventArgs Class

For a list of all members of this type, see DragEventArgs members.

Public Properties

 | Name | Description
Public Property | AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Public Property | Data | Gets the IDataObject that contains the data associated with this event.
Public Property | Effect | Gets or sets the target drop effect in a drag-and-drop operation.
Public Property | KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
Public Property | X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Public Property | Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.
Top

See Also

Reference

DragEventArgs Class
Gizmox.WebGUI.Forms Namespace


AllowedEffect Property

[image]
Gizmox.WebGUI.Forms
AllowedEffect Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DragEventArgs Class : AllowedEffect Property

Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AllowedEffect As DragDropEffects
Visual Basic (Usage) Copy Code
Dim instance As DragEventArgs
Dim value As DragDropEffects

value = instance.AllowedEffect
C#
public DragDropEffects AllowedEffect {get;}
Managed Extensions for C++
public: __property DragDropEffects get_AllowedEffect();
C++/CLI
public:
property DragDropEffects AllowedEffect {
   DragDropEffects get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DragEventArgs Class
DragEventArgs Members


Data Property

[image]
Gizmox.WebGUI.Forms
Data Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DragEventArgs Class : Data Property

Gets the IDataObject that contains the data associated with this event.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Data As IDataObject
Visual Basic (Usage) Copy Code
Dim instance As DragEventArgs
Dim value As IDataObject

value = instance.Data
C#
public IDataObject Data {get;}
Managed Extensions for C++
public: __property IDataObject* get_Data();
C++/CLI
public:
property IDataObject^ Data {
   IDataObject^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DragEventArgs Class
DragEventArgs Members


Effect Property

[image]
Gizmox.WebGUI.Forms
Effect Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DragEventArgs Class : Effect Property

Gets or sets the target drop effect in a drag-and-drop operation.

Syntax

Visual Basic (Declaration)
Public Property Effect As DragDropEffects
Visual Basic (Usage) Copy Code
Dim instance As DragEventArgs
Dim value As DragDropEffects

instance.Effect = value

value = instance.Effect
C#
public DragDropEffects Effect {get; set;}
Managed Extensions for C++
public: __property DragDropEffects get_Effect();
public: __property void set_Effect(
   DragDropEffects value
);
C++/CLI
public:
property DragDropEffects Effect {
   DragDropEffects get();
   void set (DragDropEffectsvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DragEventArgs Class
DragEventArgs Members


KeyState Property

[image]
Gizmox.WebGUI.Forms
KeyState Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DragEventArgs Class : KeyState Property

Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property KeyState As Integer
Visual Basic (Usage) Copy Code
Dim instance As DragEventArgs
Dim value As Integer

value = instance.KeyState
C#
public int KeyState {get;}
Managed Extensions for C++
public: __property int get_KeyState();
C++/CLI
public:
property int KeyState {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DragEventArgs Class
DragEventArgs Members


X Property

[image]
Gizmox.WebGUI.Forms
X Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DragEventArgs Class : X Property

Gets the x-coordinate of the mouse pointer, in screen coordinates.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property X As Integer
Visual Basic (Usage) Copy Code
Dim instance As DragEventArgs
Dim value As Integer

value = instance.X
C#
public int X {get;}
Managed Extensions for C++
public: __property int get_X();
C++/CLI
public:
property int X {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DragEventArgs Class
DragEventArgs Members


Y Property

[image]
Gizmox.WebGUI.Forms
Y Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DragEventArgs Class : Y Property

Gets the y-coordinate of the mouse pointer, in screen coordinates.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Y As Integer
Visual Basic (Usage) Copy Code
Dim instance As DragEventArgs
Dim value As Integer

value = instance.Y
C#
public int Y {get;}
Managed Extensions for C++
public: __property int get_Y();
C++/CLI
public:
property int Y {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DragEventArgs Class
DragEventArgs Members


DragMapping Class

[image]
Gizmox.WebGUI.Forms
DragMapping Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DragMapping Class

Drag mapping between two controls

Object Model

Syntax

Visual Basic (Declaration)
Public Class DragMapping
Visual Basic (Usage) Copy Code
Dim instance As DragMapping
C#
public class DragMapping
Managed Extensions for C++
public __gc class DragMapping
C++/CLI
public ref class DragMapping

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.DragMapping

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

DragMapping Members
Gizmox.WebGUI.Forms Namespace


DragMapping Class Members

[image]
Gizmox.WebGUI.Forms
DragMapping Class Members
See Also Properties Send Feedback
Gizmox.WebGUI.Forms Namespace : DragMapping Class

The following tables list the members exposed by DragMapping.

Public Properties

 | Name | Description
Public Property | Source | Gets the drag mapping source.
Public Property | Target | Gets the drag mapping target.
Top

See Also

Reference

DragMapping Class
Gizmox.WebGUI.Forms Namespace


DragMapping Class Properties

[image]
Gizmox.WebGUI.Forms
DragMapping Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DragMapping Class

For a list of all members of this type, see DragMapping members.

Public Properties

 | Name | Description
Public Property | Source | Gets the drag mapping source.
Public Property | Target | Gets the drag mapping target.
Top

See Also

Reference

DragMapping Class
Gizmox.WebGUI.Forms Namespace


Source Property

[image]
Gizmox.WebGUI.Forms
Source Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DragMapping Class : Source Property

Gets the drag mapping source.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Source As Control
Visual Basic (Usage) Copy Code
Dim instance As DragMapping
Dim value As Control

value = instance.Source
C#
public Control Source {get;}
Managed Extensions for C++
public: __property Control* get_Source();
C++/CLI
public:
property Control^ Source {
   Control^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DragMapping Class
DragMapping Members


Target Property

[image]
Gizmox.WebGUI.Forms
Target Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DragMapping Class : Target Property

Gets the drag mapping target.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Target As Control
Visual Basic (Usage) Copy Code
Dim instance As DragMapping
Dim value As Control

value = instance.Target
C#
public Control Target {get;}
Managed Extensions for C++
public: __property Control* get_Target();
C++/CLI
public:
property Control^ Target {
   Control^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DragMapping Class
DragMapping Members


DragMappings Class

[image]
Gizmox.WebGUI.Forms
DragMappings Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DragMappings Class

Summary description for DragMappings.

Object Model

Syntax

Visual Basic (Declaration)
<ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")>
Public Class DragMappings
   Inherits Component
   Implements IAttributeExtender, IEventHandler, IGatewayComponent, IObservableItem, IRegisteredComponent
Visual Basic (Usage) Copy Code
Dim instance As DragMappings
C#
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
public class DragMappings : Component, IAttributeExtender, IEventHandler, IGatewayComponent, IObservableItem, IRegisteredComponent
Managed Extensions for C++
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
public __gc class DragMappings : public Component, IAttributeExtender, IEventHandler, IGatewayComponent, IObservableItem, IRegisteredComponent
C++/CLI
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
public ref class DragMappings : public Component, IAttributeExtender, IEventHandler, IGatewayComponent, IObservableItem, IRegisteredComponent

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.DragMappings

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

DragMappings Members
Gizmox.WebGUI.Forms Namespace


DragMappings Class Members

[image]
Gizmox.WebGUI.Forms
DragMappings Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : DragMappings Class

The following tables list the members exposed by DragMappings.

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContextMenu | Gets or sets the context menu code. (Inherited from Component)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

Public Methods

 | Name | Description
Public Method | Add | Adds a drag mapping.
Public Method | Dispose | Overloaded. Disposes the specified component. (Inherited from Component)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | Remove | Removes a drag mapping.
Public Method | Render | Renders the render.
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Component)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCriticalEvents | (Inherited from Component)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnUnregisterComponents | (Inherited from Component)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Top

See Also

Reference

DragMappings Class
Gizmox.WebGUI.Forms Namespace


DragMappings Class Methods

[image]
Gizmox.WebGUI.Forms
DragMappings Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DragMappings Class

For a list of all members of this type, see DragMappings members.

Public Methods

 | Name | Description
Public Method | Add | Adds a drag mapping.
Public Method | Dispose | Overloaded. Disposes the specified component. (Inherited from Component)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | Remove | Removes a drag mapping.
Public Method | Render | Renders the render.
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Component)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCriticalEvents | (Inherited from Component)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnUnregisterComponents | (Inherited from Component)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

See Also

Reference

DragMappings Class
Gizmox.WebGUI.Forms Namespace


Add Method

[image]
Gizmox.WebGUI.Forms
Add Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DragMappings Class : Add Method

objSource
Source control.
objTarget
Target control.
Adds a drag mapping.

Syntax

Visual Basic (Declaration)
Public Function Add( _
   ByVal objSource As Control, _
   ByVal objTarget As Control _
) As DragMapping
Visual Basic (Usage) Copy Code
Dim instance As DragMappings
Dim objSource As Control
Dim objTarget As Control
Dim value As DragMapping

value = instance.Add(objSource, objTarget)
C#
public DragMapping Add(
   Control objSource,
   Control objTarget
)
Managed Extensions for C++
public: DragMapping* Add(
   Control* objSource,
   Control* objTarget
)
C++/CLI
public:
DragMapping^ Add(
   Control^ objSource,
   Control^ objTarget
)

Parameters

objSource
Source control.
objTarget
Target control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DragMappings Class
DragMappings Members


Remove Method

[image]
Gizmox.WebGUI.Forms
Remove Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DragMappings Class : Remove Method

objSource
Source control.
objTarget
Target control.
Removes a drag mapping.

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal objSource As Control, _
   ByVal objTarget As Control _
)
Visual Basic (Usage) Copy Code
Dim instance As DragMappings
Dim objSource As Control
Dim objTarget As Control

instance.Remove(objSource, objTarget)
C#
public void Remove(
   Control objSource,
   Control objTarget
)
Managed Extensions for C++
public: void Remove(
   Control* objSource,
   Control* objTarget
)
C++/CLI
public:
void Remove(
   Control^ objSource,
   Control^ objTarget
)

Parameters

objSource
Source control.
objTarget
Target control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DragMappings Class
DragMappings Members


Render Method

[image]
Gizmox.WebGUI.Forms
Render Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > DragMappings Class : Render Method

objContext
Obj context.
objWriter
Obj writer.
lngRequestID
LNG last updated.
Renders the render.

Syntax

Visual Basic (Declaration)
Public Sub Render( _
   ByVal objContext As IContext, _
   ByVal objWriter As IResponseWriter, _
   ByVal lngRequestID As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As DragMappings
Dim objContext As IContext
Dim objWriter As IResponseWriter
Dim lngRequestID As Long

instance.Render(objContext, objWriter, lngRequestID)
C#
public void Render(
   IContext objContext,
   IResponseWriter objWriter,
   long lngRequestID
)
Managed Extensions for C++
public: void Render(
   IContext* objContext,
   IResponseWriter* objWriter,
   long lngRequestID
)
C++/CLI
public:
void Render(
   IContext^ objContext,
   IResponseWriter^ objWriter,
   long long lngRequestID
)

Parameters

objContext
Obj context.
objWriter
Obj writer.
lngRequestID
LNG last updated.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DragMappings Class
DragMappings Members


ErrorProvider Class

[image]
Gizmox.WebGUI.Forms
ErrorProvider Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ErrorProvider Class

Provides a user interface for indicating that a control on a form has an error associated with it.

Object Model

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Provides a user interface to indicate to the user that a control on a form has an error associated with it.")>
<ProvidePropertyAttribute(PropertyName="Error", ReceiverTypeName="Gizmox.WebGUI.Forms.Control, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d")>
<ToolboxBitmapAttribute()>
<ToolboxItemFilterAttribute("Gizmox.WebGUI.Forms")>
<ToolboxItemCategoryAttribute("Components")>
<ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<ComplexBindingPropertiesAttribute(DataSource="DataSource", DataMember="DataMember")>
Public Class ErrorProvider
   Inherits ComponentBase
Visual Basic (Usage) Copy Code
Dim instance As ErrorProvider
C#
[SRDescriptionAttribute("Provides a user interface to indicate to the user that a control on a form has an error associated with it.")]
[ProvidePropertyAttribute(PropertyName="Error", ReceiverTypeName="Gizmox.WebGUI.Forms.Control, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d")]
[ToolboxBitmapAttribute()]
[ToolboxItemFilterAttribute("Gizmox.WebGUI.Forms")]
[ToolboxItemCategoryAttribute("Components")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ComplexBindingPropertiesAttribute(DataSource="DataSource", DataMember="DataMember")]
public class ErrorProvider : ComponentBase
Managed Extensions for C++
[SRDescriptionAttribute("Provides a user interface to indicate to the user that a control on a form has an error associated with it.")]
[ProvidePropertyAttribute(PropertyName="Error", ReceiverTypeName="Gizmox.WebGUI.Forms.Control, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d")]
[ToolboxBitmapAttribute()]
[ToolboxItemFilterAttribute("Gizmox.WebGUI.Forms")]
[ToolboxItemCategoryAttribute("Components")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ComplexBindingPropertiesAttribute(DataSource="DataSource", DataMember="DataMember")]
public __gc class ErrorProvider : public ComponentBase
C++/CLI
[SRDescriptionAttribute("Provides a user interface to indicate to the user that a control on a form has an error associated with it.")]
[ProvidePropertyAttribute(PropertyName="Error", ReceiverTypeName="Gizmox.WebGUI.Forms.Control, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d")]
[ToolboxBitmapAttribute()]
[ToolboxItemFilterAttribute("Gizmox.WebGUI.Forms")]
[ToolboxItemCategoryAttribute("Components")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ComplexBindingPropertiesAttribute(DataSource="DataSource", DataMember="DataMember")]
public ref class ErrorProvider : public ComponentBase

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.ErrorProvider

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

ErrorProvider Members
Gizmox.WebGUI.Forms Namespace


ErrorProvider Class Members

[image]
Gizmox.WebGUI.Forms
ErrorProvider Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : ErrorProvider Class

The following tables list the members exposed by ErrorProvider.

Public Constructors

 | Name | Description
Public Constructor | ErrorProvider Constructor | Overloaded. Initializes a new instance of the ErrorProvider class and initializes the default settings for BlinkRate, BlinkStyle, and the Icon.
Top

Public Properties

 | Name | Description
Public Property | BlinkRate | Gets or sets the rate at which the error icon flashes.
Public Property | BlinkStyle | Gets or sets a value indicating when the error icon flashes.
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainerControl | Gets or sets a value indicating the parent control for this ErrorProvider.
Public Property | DataMember | Gets or sets the list within a data source to monitor.
Public Property | DataSource | Gets or sets the data source that the ErrorProvider monitors.
Public Property | Icon | Gets or sets the Icon that is displayed next to a control when an error description string has been set for the control.
Public Property | Site | (Inherited from ComponentBase)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Top

Public Methods

 | Name | Description
Public Method | CanExtend | Gets a value indicating whether a control can be extended.
Public Method | Dispose | Overloaded. (Inherited from ComponentBase)
Public Method | GetError | Returns the current error description string for the specified control.
Public Method | GetIconAlignment | Gets a value indicating where the error icon should be placed in relation to the control.
Public Method | GetIconPadding | Returns the amount of extra space to leave next to the error icon.
Public Method | SetError | Sets the error description string for the specified control.
Public Method | SetIconAlignment | Sets the location where the error icon should be placed in relation to the control.
Public Method | SetIconPadding | Sets the amount of extra space to leave between the specified control and the error icon.
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UpdateBinding | Provides a method to update the bindings of the DataSource, DataMember, and the error text.
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | GetService | (Inherited from ComponentBase)
Top

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from ComponentBase)
Top

See Also

Reference

ErrorProvider Class
Gizmox.WebGUI.Forms Namespace


ErrorProvider Constructor

[image]
Gizmox.WebGUI.Forms
ErrorProvider Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ErrorProvider Class : ErrorProvider Constructor

Initializes a new instance of the ErrorProvider class and initializes the default settings for BlinkRate, BlinkStyle, and the Icon.

Overload List

Overload | Description
ErrorProvider Constructor() | Initializes a new instance of the ErrorProvider class and initializes the default settings for BlinkRate, BlinkStyle, and the Icon.
ErrorProvider Constructor(ContainerControl) | Initializes a new instance of the ErrorProvider class attached to a container.
ErrorProvider Constructor(IContainer) | Initializes a new instance of the ErrorProvider class attached to an IContainer implementation.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ErrorProvider Class
ErrorProvider Members


ErrorProvider Constructor()

[image]
Gizmox.WebGUI.Forms
ErrorProvider Constructor()
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ErrorProvider Class > ErrorProvider Constructor : ErrorProvider Constructor()

Initializes a new instance of the ErrorProvider class and initializes the default settings for BlinkRate, BlinkStyle, and the Icon.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ErrorProvider()
C#
public ErrorProvider()
Managed Extensions for C++
public: ErrorProvider();
C++/CLI
public:
ErrorProvider();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ErrorProvider Class
ErrorProvider Members
Overload List


ErrorProvider Constructor(ContainerControl)

[image]
Gizmox.WebGUI.Forms
ErrorProvider Constructor(ContainerControl)
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ErrorProvider Class > ErrorProvider Constructor : ErrorProvider Constructor(ContainerControl)

parentControl
The container of the control to monitor for errors.
Initializes a new instance of the ErrorProvider class attached to a container.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parentControl As ContainerControl _
)
Visual Basic (Usage) Copy Code
Dim parentControl As ContainerControl

Dim instance As ErrorProvider(parentControl)
C#
public ErrorProvider(
   ContainerControl parentControl
)
Managed Extensions for C++
public: ErrorProvider(
   ContainerControl* parentControl
)
C++/CLI
public:
ErrorProvider(
   ContainerControl^ parentControl
)

Parameters

parentControl
The container of the control to monitor for errors.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ErrorProvider Class
ErrorProvider Members
Overload List


ErrorProvider Constructor(IContainer)

[image]
Gizmox.WebGUI.Forms
ErrorProvider Constructor(IContainer)
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ErrorProvider Class > ErrorProvider Constructor : ErrorProvider Constructor(IContainer)

container
The IContainer to monitor for errors.
Initializes a new instance of the ErrorProvider class attached to an IContainer implementation.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal container As IContainer _
)
Visual Basic (Usage) Copy Code
Dim container As IContainer

Dim instance As ErrorProvider(container)
C#
public ErrorProvider(
   IContainer container
)
Managed Extensions for C++
public: ErrorProvider(
   IContainer* container
)
C++/CLI
public:
ErrorProvider(
   IContainer^ container
)

Parameters

container
The IContainer to monitor for errors.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ErrorProvider Class
ErrorProvider Members
Overload List


ErrorProvider Class Methods

[image]
Gizmox.WebGUI.Forms
ErrorProvider Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ErrorProvider Class

For a list of all members of this type, see ErrorProvider members.

Public Methods

 | Name | Description
Public Method | CanExtend | Gets a value indicating whether a control can be extended.
Public Method | Dispose | Overloaded. (Inherited from ComponentBase)
Public Method | GetError | Returns the current error description string for the specified control.
Public Method | GetIconAlignment | Gets a value indicating where the error icon should be placed in relation to the control.
Public Method | GetIconPadding | Returns the amount of extra space to leave next to the error icon.
Public Method | SetError | Sets the error description string for the specified control.
Public Method | SetIconAlignment | Sets the location where the error icon should be placed in relation to the control.
Public Method | SetIconPadding | Sets the amount of extra space to leave between the specified control and the error icon.
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UpdateBinding | Provides a method to update the bindings of the DataSource, DataMember, and the error text.
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | GetService | (Inherited from ComponentBase)
Top

See Also

Reference

ErrorProvider Class
Gizmox.WebGUI.Forms Namespace


CanExtend Method

[image]
Gizmox.WebGUI.Forms
CanExtend Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ErrorProvider Class : CanExtend Method

objExtendee
The control to be extended.
Gets a value indicating whether a control can be extended.

Syntax

Visual Basic (Declaration)
Public Function CanExtend( _
   ByVal objExtendee As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ErrorProvider
Dim objExtendee As Object
Dim value As Boolean

value = instance.CanExtend(objExtendee)
C#
public bool CanExtend(
   object objExtendee
)
Managed Extensions for C++
public: bool CanExtend(
   Object* objExtendee
)
C++/CLI
public:
bool CanExtend(
   Object^ objExtendee
)

Parameters

objExtendee
The control to be extended.

Return Value

true if the control can be extended; otherwise, false.This property will be true if the object is a Control and is not a Form or ToolBar.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ErrorProvider Class
ErrorProvider Members


GetError Method

[image]
Gizmox.WebGUI.Forms
GetError Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ErrorProvider Class : GetError Method

objControl
The item to get the error description string for.
Returns the current error description string for the specified control.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("The error description for a control.")>
<DefaultValueAttribute()>
<SRCategoryAttribute("Appearance")>
<LocalizableAttribute(True)>
Public Function GetError( _
   ByVal objControl As Control _
) As String
Visual Basic (Usage) Copy Code
Dim instance As ErrorProvider
Dim objControl As Control
Dim value As String

value = instance.GetError(objControl)
C#
[SRDescriptionAttribute("The error description for a control.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
[LocalizableAttribute(true)]
public string GetError(
   Control objControl
)
Managed Extensions for C++
[SRDescriptionAttribute("The error description for a control.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
[LocalizableAttribute(true)]
public: string* GetError(
   Control* objControl
)
C++/CLI
[SRDescriptionAttribute("The error description for a control.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
[LocalizableAttribute(true)]
public:
String^ GetError(
   Control^ objControl
)

Parameters

objControl
The item to get the error description string for.

Return Value

The error description string for the specified control.

Exceptions

Exception | Description
ArgumentNullException | control is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ErrorProvider Class
ErrorProvider Members


GetIconAlignment Method

[image]
Gizmox.WebGUI.Forms
GetIconAlignment Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ErrorProvider Class : GetIconAlignment Method

objControl
The control to get the icon location for.
Gets a value indicating where the error icon should be placed in relation to the control.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<SRCategoryAttribute("Appearance")>
<SRDescriptionAttribute("The location of the error icon relative to the control.")>
<LocalizableAttribute(True)>
Public Function GetIconAlignment( _
   ByVal objControl As Control _
) As ErrorIconAlignment
Visual Basic (Usage) Copy Code
Dim instance As ErrorProvider
Dim objControl As Control
Dim value As ErrorIconAlignment

value = instance.GetIconAlignment(objControl)
C#
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("The location of the error icon relative to the control.")]
[LocalizableAttribute(true)]
public ErrorIconAlignment GetIconAlignment(
   Control objControl
)
Managed Extensions for C++
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("The location of the error icon relative to the control.")]
[LocalizableAttribute(true)]
public: ErrorIconAlignment GetIconAlignment(
   Control* objControl
)
C++/CLI
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("The location of the error icon relative to the control.")]
[LocalizableAttribute(true)]
public:
ErrorIconAlignment GetIconAlignment(
   Control^ objControl
)

Parameters

objControl
The control to get the icon location for.

Return Value

One of the ErrorIconAlignment values. The default icon alignment is MiddleRight.

Exceptions

Exception | Description
ArgumentNullException | control is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ErrorProvider Class
ErrorProvider Members


GetIconPadding Method

[image]
Gizmox.WebGUI.Forms
GetIconPadding Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ErrorProvider Class : GetIconPadding Method

objControl
The control to get the padding for.
Returns the amount of extra space to leave next to the error icon.

Syntax

Visual Basic (Declaration)
<LocalizableAttribute(True)>
<SRCategoryAttribute("Appearance")>
<SRDescriptionAttribute("The number of pixels to leave between the error icon and the control.")>
<DefaultValueAttribute()>
Public Function GetIconPadding( _
   ByVal objControl As Control _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As ErrorProvider
Dim objControl As Control
Dim value As Integer

value = instance.GetIconPadding(objControl)
C#
[LocalizableAttribute(true)]
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("The number of pixels to leave between the error icon and the control.")]
[DefaultValueAttribute()]
public int GetIconPadding(
   Control objControl
)
Managed Extensions for C++
[LocalizableAttribute(true)]
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("The number of pixels to leave between the error icon and the control.")]
[DefaultValueAttribute()]
public: int GetIconPadding(
   Control* objControl
)
C++/CLI
[LocalizableAttribute(true)]
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("The number of pixels to leave between the error icon and the control.")]
[DefaultValueAttribute()]
public:
int GetIconPadding(
   Control^ objControl
)

Parameters

objControl
The control to get the padding for.

Return Value

The number of pixels to leave between the icon and the control.

Exceptions

Exception | Description
ArgumentNullException | control is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ErrorProvider Class
ErrorProvider Members


SetError Method

[image]
Gizmox.WebGUI.Forms
SetError Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ErrorProvider Class : SetError Method

objControl
The control to set the error description string for.
strValue
The error description string.
Sets the error description string for the specified control.

Syntax

Visual Basic (Declaration)
Public Sub SetError( _
   ByVal objControl As Control, _
   ByVal strValue As String _
)
Visual Basic (Usage) Copy Code
Dim instance As ErrorProvider
Dim objControl As Control
Dim strValue As String

instance.SetError(objControl, strValue)
C#
public void SetError(
   Control objControl,
   string strValue
)
Managed Extensions for C++
public: void SetError(
   Control* objControl,
   string* strValue
)
C++/CLI
public:
void SetError(
   Control^ objControl,
   String^ strValue
)

Parameters

objControl
The control to set the error description string for.
strValue
The error description string.

Exceptions

Exception | Description
ArgumentNullException | control is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ErrorProvider Class
ErrorProvider Members


SetIconAlignment Method

[image]
Gizmox.WebGUI.Forms
SetIconAlignment Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ErrorProvider Class : SetIconAlignment Method

objControl
The control to set the icon location for.
enmValue
One of the ErrorIconAlignment values.
Sets the location where the error icon should be placed in relation to the control.

Syntax

Visual Basic (Declaration)
Public Sub SetIconAlignment( _
   ByVal objControl As Control, _
   ByVal enmValue As ErrorIconAlignment _
)
Visual Basic (Usage) Copy Code
Dim instance As ErrorProvider
Dim objControl As Control
Dim enmValue As ErrorIconAlignment

instance.SetIconAlignment(objControl, enmValue)
C#
public void SetIconAlignment(
   Control objControl,
   ErrorIconAlignment enmValue
)
Managed Extensions for C++
public: void SetIconAlignment(
   Control* objControl,
   ErrorIconAlignment enmValue
)
C++/CLI
public:
void SetIconAlignment(
   Control^ objControl,
   ErrorIconAlignment enmValue
)

Parameters

objControl
The control to set the icon location for.
enmValue
One of the ErrorIconAlignment values.

Exceptions

Exception | Description
ArgumentNullException | control is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ErrorProvider Class
ErrorProvider Members


SetIconPadding Method

[image]
Gizmox.WebGUI.Forms
SetIconPadding Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ErrorProvider Class : SetIconPadding Method

objControl
The control to set the padding for.
intPadding
The number of pixels to add between the icon and the control.
Sets the amount of extra space to leave between the specified control and the error icon.

Syntax

Visual Basic (Declaration)
Public Sub SetIconPadding( _
   ByVal objControl As Control, _
   ByVal intPadding As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As ErrorProvider
Dim objControl As Control
Dim intPadding As Integer

instance.SetIconPadding(objControl, intPadding)
C#
public void SetIconPadding(
   Control objControl,
   int intPadding
)
Managed Extensions for C++
public: void SetIconPadding(
   Control* objControl,
   int intPadding
)
C++/CLI
public:
void SetIconPadding(
   Control^ objControl,
   int intPadding
)

Parameters

objControl
The control to set the padding for.
intPadding
The number of pixels to add between the icon and the control.

Exceptions

Exception | Description
ArgumentNullException | control is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ErrorProvider Class
ErrorProvider Members


UpdateBinding Method

[image]
Gizmox.WebGUI.Forms
UpdateBinding Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ErrorProvider Class : UpdateBinding Method

Provides a method to update the bindings of the DataSource, DataMember, and the error text.

Syntax

Visual Basic (Declaration)
Public Sub UpdateBinding()
Visual Basic (Usage) Copy Code
Dim instance As ErrorProvider

instance.UpdateBinding()
C#
public void UpdateBinding()
Managed Extensions for C++
public: void UpdateBinding();
C++/CLI
public:
void UpdateBinding();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ErrorProvider Class
ErrorProvider Members


ErrorProvider Class Properties

[image]
Gizmox.WebGUI.Forms
ErrorProvider Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ErrorProvider Class

For a list of all members of this type, see ErrorProvider members.

Public Properties

 | Name | Description
Public Property | BlinkRate | Gets or sets the rate at which the error icon flashes.
Public Property | BlinkStyle | Gets or sets a value indicating when the error icon flashes.
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainerControl | Gets or sets a value indicating the parent control for this ErrorProvider.
Public Property | DataMember | Gets or sets the list within a data source to monitor.
Public Property | DataSource | Gets or sets the data source that the ErrorProvider monitors.
Public Property | Icon | Gets or sets the Icon that is displayed next to a control when an error description string has been set for the control.
Public Property | Site | (Inherited from ComponentBase)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Top

See Also

Reference

ErrorProvider Class
Gizmox.WebGUI.Forms Namespace


BlinkRate Property

[image]
Gizmox.WebGUI.Forms
BlinkRate Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ErrorProvider Class : BlinkRate Property

Gets or sets the rate at which the error icon flashes.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<RefreshPropertiesAttribute()>
<SRCategoryAttribute("Behavior")>
<SRDescriptionAttribute("The rate in milliseconds at which the error icon blinks.")>
Public Property BlinkRate As Integer
Visual Basic (Usage) Copy Code
Dim instance As ErrorProvider
Dim value As Integer

instance.BlinkRate = value

value = instance.BlinkRate
C#
[DefaultValueAttribute()]
[RefreshPropertiesAttribute()]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("The rate in milliseconds at which the error icon blinks.")]
public int BlinkRate {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[RefreshPropertiesAttribute()]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("The rate in milliseconds at which the error icon blinks.")]
public: __property int get_BlinkRate();
public: __property void set_BlinkRate(
   int value
);
C++/CLI
[DefaultValueAttribute()]
[RefreshPropertiesAttribute()]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("The rate in milliseconds at which the error icon blinks.")]
public:
property int BlinkRate {
   int get();
   void set (intvalue);
}

Exceptions

Exception | Description
ArgumentOutOfRangeException | The value is less than zero.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ErrorProvider Class
ErrorProvider Members


BlinkStyle Property

[image]
Gizmox.WebGUI.Forms
BlinkStyle Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ErrorProvider Class : BlinkStyle Property

Gets or sets a value indicating when the error icon flashes.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Controls whether the error icon blinks when an error is set.")>
<SRCategoryAttribute("Behavior")>
<DefaultValueAttribute()>
Public Property BlinkStyle As ErrorBlinkStyle
Visual Basic (Usage) Copy Code
Dim instance As ErrorProvider
Dim value As ErrorBlinkStyle

instance.BlinkStyle = value

value = instance.BlinkStyle
C#
[SRDescriptionAttribute("Controls whether the error icon blinks when an error is set.")]
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
public ErrorBlinkStyle BlinkStyle {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Controls whether the error icon blinks when an error is set.")]
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
public: __property ErrorBlinkStyle get_BlinkStyle();
public: __property void set_BlinkStyle(
   ErrorBlinkStyle value
);
C++/CLI
[SRDescriptionAttribute("Controls whether the error icon blinks when an error is set.")]
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
public:
property ErrorBlinkStyle BlinkStyle {
   ErrorBlinkStyle get();
   void set (ErrorBlinkStylevalue);
}

Exceptions

Exception | Description
InvalidEnumArgumentException | The assigned value is not one of the ErrorBlinkStyle values.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ErrorProvider Class
ErrorProvider Members


ContainerControl Property

[image]
Gizmox.WebGUI.Forms
ContainerControl Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ErrorProvider Class : ContainerControl Property

Gets or sets a value indicating the parent control for this ErrorProvider.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<SRCategoryAttribute("Data")>
<SRDescriptionAttribute("The parent control, usually the form, that contains the data-bound controls on which the ErrorProvider can display error icons.")>
Public Property ContainerControl As ContainerControl
Visual Basic (Usage) Copy Code
Dim instance As ErrorProvider
Dim value As ContainerControl

instance.ContainerControl = value

value = instance.ContainerControl
C#
[DefaultValueAttribute()]
[SRCategoryAttribute("Data")]
[SRDescriptionAttribute("The parent control, usually the form, that contains the data-bound controls on which the ErrorProvider can display error icons.")]
public ContainerControl ContainerControl {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[SRCategoryAttribute("Data")]
[SRDescriptionAttribute("The parent control, usually the form, that contains the data-bound controls on which the ErrorProvider can display error icons.")]
public: __property ContainerControl* get_ContainerControl();
public: __property void set_ContainerControl(
   ContainerControl* value
);
C++/CLI
[DefaultValueAttribute()]
[SRCategoryAttribute("Data")]
[SRDescriptionAttribute("The parent control, usually the form, that contains the data-bound controls on which the ErrorProvider can display error icons.")]
public:
property ContainerControl^ ContainerControl {
   ContainerControl^ get();
   void set (ContainerControl^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ErrorProvider Class
ErrorProvider Members


DataMember Property

[image]
Gizmox.WebGUI.Forms
DataMember Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ErrorProvider Class : DataMember Property

Gets or sets the list within a data source to monitor.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="System.Windows.Forms.Design.DataMemberListEditor, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<SRCategoryAttribute("Data")>
<SRDescriptionAttribute("Indicates the sub-list of data from the DataSource to bind errors against.")>
Public Property DataMember As String
Visual Basic (Usage) Copy Code
Dim instance As ErrorProvider
Dim value As String

instance.DataMember = value

value = instance.DataMember
C#
[DefaultValueAttribute()]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="System.Windows.Forms.Design.DataMemberListEditor, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[SRCategoryAttribute("Data")]
[SRDescriptionAttribute("Indicates the sub-list of data from the DataSource to bind errors against.")]
public string DataMember {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="System.Windows.Forms.Design.DataMemberListEditor, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[SRCategoryAttribute("Data")]
[SRDescriptionAttribute("Indicates the sub-list of data from the DataSource to bind errors against.")]
public: __property string* get_DataMember();
public: __property void set_DataMember(
   string* value
);
C++/CLI
[DefaultValueAttribute()]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="System.Windows.Forms.Design.DataMemberListEditor, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[SRCategoryAttribute("Data")]
[SRDescriptionAttribute("Indicates the sub-list of data from the DataSource to bind errors against.")]
public:
property String^ DataMember {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ErrorProvider Class
ErrorProvider Members


DataSource Property

[image]
Gizmox.WebGUI.Forms
DataSource Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ErrorProvider Class : DataSource Property

Gets or sets the data source that the ErrorProvider monitors.

Syntax

Visual Basic (Declaration)
<AttributeProviderAttribute(TypeName="System.ComponentModel.IListSource, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089", PropertyName="")>
<DefaultValueAttribute()>
<SRCategoryAttribute("Data")>
<SRDescriptionAttribute("Indicates the source of data to bind errors against.")>
Public Property DataSource As Object
Visual Basic (Usage) Copy Code
Dim instance As ErrorProvider
Dim value As Object

instance.DataSource = value

value = instance.DataSource
C#
[AttributeProviderAttribute(TypeName="System.ComponentModel.IListSource, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089", PropertyName="")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Data")]
[SRDescriptionAttribute("Indicates the source of data to bind errors against.")]
public object DataSource {get; set;}
Managed Extensions for C++
[AttributeProviderAttribute(TypeName="System.ComponentModel.IListSource, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089", PropertyName="")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Data")]
[SRDescriptionAttribute("Indicates the source of data to bind errors against.")]
public: __property Object* get_DataSource();
public: __property void set_DataSource(
   Object* value
);
C++/CLI
[AttributeProviderAttribute(TypeName="System.ComponentModel.IListSource, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089", PropertyName="")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Data")]
[SRDescriptionAttribute("Indicates the source of data to bind errors against.")]
public:
property Object^ DataSource {
   Object^ get();
   void set (Object^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ErrorProvider Class
ErrorProvider Members


Icon Property

[image]
Gizmox.WebGUI.Forms
Icon Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ErrorProvider Class : Icon Property

Gets or sets the Icon that is displayed next to a control when an error description string has been set for the control.

Syntax

Visual Basic (Declaration)
<LocalizableAttribute(True)>
<SRDescriptionAttribute("The icon used to indicate an error.")>
<SRCategoryAttribute("Appearance")>
Public Property Icon As ResourceHandle
Visual Basic (Usage) Copy Code
Dim instance As ErrorProvider
Dim value As ResourceHandle

instance.Icon = value

value = instance.Icon
C#
[LocalizableAttribute(true)]
[SRDescriptionAttribute("The icon used to indicate an error.")]
[SRCategoryAttribute("Appearance")]
public ResourceHandle Icon {get; set;}
Managed Extensions for C++
[LocalizableAttribute(true)]
[SRDescriptionAttribute("The icon used to indicate an error.")]
[SRCategoryAttribute("Appearance")]
public: __property ResourceHandle* get_Icon();
public: __property void set_Icon(
   ResourceHandle* value
);
C++/CLI
[LocalizableAttribute(true)]
[SRDescriptionAttribute("The icon used to indicate an error.")]
[SRCategoryAttribute("Appearance")]
public:
property ResourceHandle^ Icon {
   ResourceHandle^ get();
   void set (ResourceHandle^value);
}

Exceptions

Exception | Description
ArgumentNullException | The assigned value of the Icon is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ErrorProvider Class
ErrorProvider Members


FileDialog Class

[image]
Gizmox.WebGUI.Forms
FileDialog Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : FileDialog Class

Displays a dialog box from which the user can select a file.

Object Model

Syntax

Visual Basic (Declaration)
<DefaultPropertyAttribute("FileName")>
<DefaultEventAttribute("FileOk")>
Public MustInherit Class FileDialog
   Inherits CommonDialog
   Implements ICommonDialog
Visual Basic (Usage) Copy Code
Dim instance As FileDialog
C#
[DefaultPropertyAttribute("FileName")]
[DefaultEventAttribute("FileOk")]
public abstract class FileDialog : CommonDialog, ICommonDialog
Managed Extensions for C++
[DefaultPropertyAttribute("FileName")]
[DefaultEventAttribute("FileOk")]
public __gc abstract class FileDialog : public CommonDialog, ICommonDialog
C++/CLI
[DefaultPropertyAttribute("FileName")]
[DefaultEventAttribute("FileOk")]
public ref class FileDialog abstract : public CommonDialog, ICommonDialog

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.CommonDialog
Gizmox.WebGUI.Forms.FileDialog
Gizmox.WebGUI.Forms.OpenFileDialog

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

FileDialog Members
Gizmox.WebGUI.Forms Namespace


FileDialog Class Members

[image]
Gizmox.WebGUI.Forms
FileDialog Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : FileDialog Class

The following tables list the members exposed by FileDialog.

Public Properties

 | Name | Description
Public Property | AddExtension | Gets or sets a value indicating whether the dialog box automatically adds an extension to a file name if the user omits the extension.
Public Property | CheckFileExists | Gets or sets a value indicating whether the dialog box displays a warning if the user specifies a file name that does not exist.
Public Property | CheckPathExists | Gets or sets a value indicating whether the dialog box displays a warning if the user specifies a path that does not exist.
Public Property | Container | (Inherited from ComponentBase)
Public Property | DefaultExt | Gets or sets the default file name extension.
Public Property | DereferenceLinks | Gets or sets a value indicating whether the dialog box returns the location of the file referenced by the shortcut or whether it returns the location of the shortcut (.lnk).
Public Property | DialogResult | Returns the last dialog result (Inherited from CommonDialog)
Public Property | File | Gets the current selected file
Public Property | FileName | Gets or sets a string containing the file name selected in the file dialog box.
Public Property | FileNames | Gets the file names of all selected files in the dialog box.
Public Property | Files | Gets the current selected files
Public Property | Filter | Gets or sets the current file name filter string, which determines the choices that appear in the "Save as file type" or "Files of type" box in the dialog box.
Public Property | FilterIndex | Gets or sets the index of the filter currently selected in the file dialog box.
Public Property | InitialDirectory | Gets or sets the initial directory displayed by the file dialog box.
Public Property | MaxFileSize | Gets of sets the Maximum file size allowed in kilobytes.
Public Property | RestoreDirectory | Gets or sets a value indicating whether the dialog box restores the current directory before closing.
Public Property | ShowHelp | Gets or sets a value indicating whether the Help button is displayed in the file dialog box.
Public Property | Site | (Inherited from ComponentBase)
Public Property | SupportMultiDottedExtensions |
Public Property | Tag | Gets or sets an object that contains data about the control. (Inherited from CommonDialog)
Public Property | Title | Gets or sets the file dialog box title.
Public Property | ValidateNames | Gets or sets a value indicating whether the dialog box accepts only valid Win32 file names.
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | Options | Gets values to initialize the FileDialog.
Top

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded. (Inherited from ComponentBase)
Public Method | Reset | Overridden. Resets all properties to their default values.
Public Method | ShowDialog | Overloaded. Runs a common dialog box with a default owner. (Inherited from CommonDialog)
Public Method | ToString | Overridden. Provides a string version of this object.
Top

Protected Methods

 | Name | Description
Protected Method | CreateForm | Creates a dialog for instance for the current common dialog (Inherited from CommonDialog)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | OnApply | Handles apply event (Inherited from CommonDialog)
Protected Method | OnClosed | Overridden. Handler the dialog closing event
Protected Method | OnFileOk | Raises the FileOk event.
Protected Method | OnHelpRequest | Raises the CommonDialog.HelpRequest event. (Inherited from CommonDialog)
Top

Public Events

 | Name | Description
Public Event | Closed | The form close event (Inherited from CommonDialog)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | FileOk | Occurs when the user clicks on the Open or Save button on a file dialog box.
Public Event | HelpRequest | Occurs when the user clicks the Help button on a common dialog box. (Inherited from CommonDialog)
Top

See Also

Reference

FileDialog Class
Gizmox.WebGUI.Forms Namespace


FileDialog Class Methods

[image]
Gizmox.WebGUI.Forms
FileDialog Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : FileDialog Class

For a list of all members of this type, see FileDialog members.

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded. (Inherited from ComponentBase)
Public Method | Reset | Overridden. Resets all properties to their default values.
Public Method | ShowDialog | Overloaded. Runs a common dialog box with a default owner. (Inherited from CommonDialog)
Public Method | ToString | Overridden. Provides a string version of this object.
Top

Protected Methods

 | Name | Description
Protected Method | CreateForm | Creates a dialog for instance for the current common dialog (Inherited from CommonDialog)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | OnApply | Handles apply event (Inherited from CommonDialog)
Protected Method | OnClosed | Overridden. Handler the dialog closing event
Protected Method | OnFileOk | Raises the FileOk event.
Protected Method | OnHelpRequest | Raises the CommonDialog.HelpRequest event. (Inherited from CommonDialog)
Top

See Also

Reference

FileDialog Class
Gizmox.WebGUI.Forms Namespace


OnClosed Method

[image]
Gizmox.WebGUI.Forms
OnClosed Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > FileDialog Class : OnClosed Method

e
Handler the dialog closing event

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnClosed( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As FileDialog
Dim e As EventArgs

instance.OnClosed(e)
C#
protected override void OnClosed(
   EventArgs e
)
Managed Extensions for C++
protected: void OnClosed(
   EventArgs* e
) override
C++/CLI
protected:
void OnClosed(
   EventArgs^ e
) override

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FileDialog Class
FileDialog Members


OnFileOk Method

[image]
Gizmox.WebGUI.Forms
OnFileOk Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > FileDialog Class : OnFileOk Method

e
A CancelEventArgs that contains the event data.
Raises the FileOk event.

Syntax

Visual Basic (Declaration)
Protected Sub OnFileOk( _
   ByVal e As CancelEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As FileDialog
Dim e As CancelEventArgs

instance.OnFileOk(e)
C#
protected void OnFileOk(
   CancelEventArgs e
)
Managed Extensions for C++
protected: void OnFileOk(
   CancelEventArgs* e
)
C++/CLI
protected:
void OnFileOk(
   CancelEventArgs^ e
)

Parameters

e
A CancelEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FileDialog Class
FileDialog Members


Reset Method

[image]
Gizmox.WebGUI.Forms
Reset Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > FileDialog Class : Reset Method

Resets all properties to their default values.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As FileDialog

instance.Reset()
C#
public override void Reset()
Managed Extensions for C++
public: void Reset(); override
C++/CLI
public:
void Reset(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FileDialog Class
FileDialog Members


ToString Method

[image]
Gizmox.WebGUI.Forms
ToString Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > FileDialog Class : ToString Method

Provides a string version of this object.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As FileDialog
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Return Value

A string version of this object.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FileDialog Class
FileDialog Members


FileDialog Class Properties

[image]
Gizmox.WebGUI.Forms
FileDialog Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : FileDialog Class

For a list of all members of this type, see FileDialog members.

Public Properties

 | Name | Description
Public Property | AddExtension | Gets or sets a value indicating whether the dialog box automatically adds an extension to a file name if the user omits the extension.
Public Property | CheckFileExists | Gets or sets a value indicating whether the dialog box displays a warning if the user specifies a file name that does not exist.
Public Property | CheckPathExists | Gets or sets a value indicating whether the dialog box displays a warning if the user specifies a path that does not exist.
Public Property | Container | (Inherited from ComponentBase)
Public Property | DefaultExt | Gets or sets the default file name extension.
Public Property | DereferenceLinks | Gets or sets a value indicating whether the dialog box returns the location of the file referenced by the shortcut or whether it returns the location of the shortcut (.lnk).
Public Property | DialogResult | Returns the last dialog result (Inherited from CommonDialog)
Public Property | File | Gets the current selected file
Public Property | FileName | Gets or sets a string containing the file name selected in the file dialog box.
Public Property | FileNames | Gets the file names of all selected files in the dialog box.
Public Property | Files | Gets the current selected files
Public Property | Filter | Gets or sets the current file name filter string, which determines the choices that appear in the "Save as file type" or "Files of type" box in the dialog box.
Public Property | FilterIndex | Gets or sets the index of the filter currently selected in the file dialog box.
Public Property | InitialDirectory | Gets or sets the initial directory displayed by the file dialog box.
Public Property | MaxFileSize | Gets of sets the Maximum file size allowed in kilobytes.
Public Property | RestoreDirectory | Gets or sets a value indicating whether the dialog box restores the current directory before closing.
Public Property | ShowHelp | Gets or sets a value indicating whether the Help button is displayed in the file dialog box.
Public Property | Site | (Inherited from ComponentBase)
Public Property | SupportMultiDottedExtensions |
Public Property | Tag | Gets or sets an object that contains data about the control. (Inherited from CommonDialog)
Public Property | Title | Gets or sets the file dialog box title.
Public Property | ValidateNames | Gets or sets a value indicating whether the dialog box accepts only valid Win32 file names.
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | Options | Gets values to initialize the FileDialog.
Top

See Also

Reference

FileDialog Class
Gizmox.WebGUI.Forms Namespace


AddExtension Property

[image]
Gizmox.WebGUI.Forms
AddExtension Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > FileDialog Class : AddExtension Property

Gets or sets a value indicating whether the dialog box automatically adds an extension to a file name if the user omits the extension.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Controls whether extensions are automatically added to file names.")>
<DefaultValueAttribute()>
<SRCategoryAttribute("Behavior")>
Public Property AddExtension As Boolean
Visual Basic (Usage) Copy Code
Dim instance As FileDialog
Dim value As Boolean

instance.AddExtension = value

value = instance.AddExtension
C#
[SRDescriptionAttribute("Controls whether extensions are automatically added to file names.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
public bool AddExtension {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Controls whether extensions are automatically added to file names.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
public: __property bool get_AddExtension();
public: __property void set_AddExtension(
   bool value
);
C++/CLI
[SRDescriptionAttribute("Controls whether extensions are automatically added to file names.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
public:
property bool AddExtension {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FileDialog Class
FileDialog Members


CheckFileExists Property

[image]
Gizmox.WebGUI.Forms
CheckFileExists Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > FileDialog Class : CheckFileExists Property

Gets or sets a value indicating whether the dialog box displays a warning if the user specifies a file name that does not exist.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Checks that the specified file exists before returning from the dialog.")>
<SRCategoryAttribute("Behavior")>
<DefaultValueAttribute()>
Public Overridable Property CheckFileExists As Boolean
Visual Basic (Usage) Copy Code
Dim instance As FileDialog
Dim value As Boolean

instance.CheckFileExists = value

value = instance.CheckFileExists
C#
[SRDescriptionAttribute("Checks that the specified file exists before returning from the dialog.")]
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
public virtual bool CheckFileExists {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Checks that the specified file exists before returning from the dialog.")]
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
public: __property virtual bool get_CheckFileExists();
public: __property virtual void set_CheckFileExists(
   bool value
);
C++/CLI
[SRDescriptionAttribute("Checks that the specified file exists before returning from the dialog.")]
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
public:
virtual property bool CheckFileExists {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FileDialog Class
FileDialog Members


CheckPathExists Property

[image]
Gizmox.WebGUI.Forms
CheckPathExists Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > FileDialog Class : CheckPathExists Property

Gets or sets a value indicating whether the dialog box displays a warning if the user specifies a path that does not exist.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Behavior")>
<SRDescriptionAttribute("Checks that the specified path exists before returning from the dialog.")>
<DefaultValueAttribute()>
Public Property CheckPathExists As Boolean
Visual Basic (Usage) Copy Code
Dim instance As FileDialog
Dim value As Boolean

instance.CheckPathExists = value

value = instance.CheckPathExists
C#
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Checks that the specified path exists before returning from the dialog.")]
[DefaultValueAttribute()]
public bool CheckPathExists {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Checks that the specified path exists before returning from the dialog.")]
[DefaultValueAttribute()]
public: __property bool get_CheckPathExists();
public: __property void set_CheckPathExists(
   bool value
);
C++/CLI
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Checks that the specified path exists before returning from the dialog.")]
[DefaultValueAttribute()]
public:
property bool CheckPathExists {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FileDialog Class
FileDialog Members


DefaultExt Property

[image]
Gizmox.WebGUI.Forms
DefaultExt Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > FileDialog Class : DefaultExt Property

Gets or sets the default file name extension.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("The default file name extension. If the user types a file name, this extension is added at the end of the file name if one is not specified.")>
<DefaultValueAttribute()>
<SRCategoryAttribute("Behavior")>
Public Property DefaultExt As String
Visual Basic (Usage) Copy Code
Dim instance As FileDialog
Dim value As String

instance.DefaultExt = value

value = instance.DefaultExt
C#
[SRDescriptionAttribute("The default file name extension. If the user types a file name, this extension is added at the end of the file name if one is not specified.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
public string DefaultExt {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("The default file name extension. If the user types a file name, this extension is added at the end of the file name if one is not specified.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
public: __property string* get_DefaultExt();
public: __property void set_DefaultExt(
   string* value
);
C++/CLI
[SRDescriptionAttribute("The default file name extension. If the user types a file name, this extension is added at the end of the file name if one is not specified.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
public:
property String^ DefaultExt {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FileDialog Class
FileDialog Members


DereferenceLinks Property

[image]
Gizmox.WebGUI.Forms
DereferenceLinks Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > FileDialog Class : DereferenceLinks Property

Gets or sets a value indicating whether the dialog box returns the location of the file referenced by the shortcut or whether it returns the location of the shortcut (.lnk).

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<SRCategoryAttribute("Behavior")>
<SRDescriptionAttribute("Controls whether shortcuts are dereferenced before returning from the dialog.")>
Public Property DereferenceLinks As Boolean
Visual Basic (Usage) Copy Code
Dim instance As FileDialog
Dim value As Boolean

instance.DereferenceLinks = value

value = instance.DereferenceLinks
C#
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Controls whether shortcuts are dereferenced before returning from the dialog.")]
public bool DereferenceLinks {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Controls whether shortcuts are dereferenced before returning from the dialog.")]
public: __property bool get_DereferenceLinks();
public: __property void set_DereferenceLinks(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Controls whether shortcuts are dereferenced before returning from the dialog.")]
public:
property bool DereferenceLinks {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FileDialog Class
FileDialog Members


File Property

[image]
Gizmox.WebGUI.Forms
File Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > FileDialog Class : File Property

Gets the current selected file

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property File As FileHandle
Visual Basic (Usage) Copy Code
Dim instance As FileDialog
Dim value As FileHandle

value = instance.File
C#
[BrowsableAttribute(false)]
public FileHandle File {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property FileHandle* get_File();
C++/CLI
[BrowsableAttribute(false)]
public:
property FileHandle^ File {
   FileHandle^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FileDialog Class
FileDialog Members


FileName Property

[image]
Gizmox.WebGUI.Forms
FileName Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > FileDialog Class : FileName Property

Gets or sets a string containing the file name selected in the file dialog box.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Data")>
<SRDescriptionAttribute("The file first shown in the dialog box, or the last one selected by the user.")>
<DefaultValueAttribute()>
Public Property FileName As String
Visual Basic (Usage) Copy Code
Dim instance As FileDialog
Dim value As String

instance.FileName = value

value = instance.FileName
C#
[SRCategoryAttribute("Data")]
[SRDescriptionAttribute("The file first shown in the dialog box, or the last one selected by the user.")]
[DefaultValueAttribute()]
public string FileName {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Data")]
[SRDescriptionAttribute("The file first shown in the dialog box, or the last one selected by the user.")]
[DefaultValueAttribute()]
public: __property string* get_FileName();
public: __property void set_FileName(
   string* value
);
C++/CLI
[SRCategoryAttribute("Data")]
[SRDescriptionAttribute("The file first shown in the dialog box, or the last one selected by the user.")]
[DefaultValueAttribute()]
public:
property String^ FileName {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FileDialog Class
FileDialog Members


FileNames Property

[image]
Gizmox.WebGUI.Forms
FileNames Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > FileDialog Class : FileNames Property

Gets the file names of all selected files in the dialog box.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<SRDescriptionAttribute("Retrieves the file names of all selected files in the dialog box.")>
<DesignerSerializationVisibilityAttribute()>
Public ReadOnly Property FileNames As String()
Visual Basic (Usage) Copy Code
Dim instance As FileDialog
Dim value() As String

value = instance.FileNames
C#
[BrowsableAttribute(false)]
[SRDescriptionAttribute("Retrieves the file names of all selected files in the dialog box.")]
[DesignerSerializationVisibilityAttribute()]
public string[] FileNames {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[SRDescriptionAttribute("Retrieves the file names of all selected files in the dialog box.")]
[DesignerSerializationVisibilityAttribute()]
public: __property string*[]* get_FileNames();
C++/CLI
[BrowsableAttribute(false)]
[SRDescriptionAttribute("Retrieves the file names of all selected files in the dialog box.")]
[DesignerSerializationVisibilityAttribute()]
public:
property array<String^>^ FileNames {
   array<String^>^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FileDialog Class
FileDialog Members


Files Property

[image]
Gizmox.WebGUI.Forms
Files Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > FileDialog Class : Files Property

Gets the current selected files

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property Files As FileHandleCollection
Visual Basic (Usage) Copy Code
Dim instance As FileDialog
Dim value As FileHandleCollection

value = instance.Files
C#
[BrowsableAttribute(false)]
public FileHandleCollection Files {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property FileHandleCollection* get_Files();
C++/CLI
[BrowsableAttribute(false)]
public:
property FileHandleCollection^ Files {
   FileHandleCollection^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FileDialog Class
FileDialog Members


Filter Property

[image]
Gizmox.WebGUI.Forms
Filter Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > FileDialog Class : Filter Property

Gets or sets the current file name filter string, which determines the choices that appear in the "Save as file type" or "Files of type" box in the dialog box.

Syntax

Visual Basic (Declaration)
<LocalizableAttribute(True)>
<SRDescriptionAttribute("The file filters to display in the dialog box, for example, "C# files|*.cs|All files|*.*".")>
<SRCategoryAttribute("Behavior")>
<DefaultValueAttribute()>
Public Property Filter As String
Visual Basic (Usage) Copy Code
Dim instance As FileDialog
Dim value As String

instance.Filter = value

value = instance.Filter
C#
[LocalizableAttribute(true)]
[SRDescriptionAttribute("The file filters to display in the dialog box, for example, "C# files|*.cs|All files|*.*".")]
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
public string Filter {get; set;}
Managed Extensions for C++
[LocalizableAttribute(true)]
[SRDescriptionAttribute("The file filters to display in the dialog box, for example, "C# files|*.cs|All files|*.*".")]
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
public: __property string* get_Filter();
public: __property void set_Filter(
   string* value
);
C++/CLI
[LocalizableAttribute(true)]
[SRDescriptionAttribute("The file filters to display in the dialog box, for example, "C# files|*.cs|All files|*.*".")]
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
public:
property String^ Filter {
   String^ get();
   void set (String^value);
}

Exceptions

Exception | Description
ArgumentException | Filter format is invalid.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FileDialog Class
FileDialog Members


FilterIndex Property

[image]
Gizmox.WebGUI.Forms
FilterIndex Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > FileDialog Class : FilterIndex Property

Gets or sets the index of the filter currently selected in the file dialog box.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("The index of the file filter selected in the dialog box. The first item has an index of 1.")>
<DefaultValueAttribute()>
<SRCategoryAttribute("Behavior")>
Public Property FilterIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As FileDialog
Dim value As Integer

instance.FilterIndex = value

value = instance.FilterIndex
C#
[SRDescriptionAttribute("The index of the file filter selected in the dialog box. The first item has an index of 1.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
public int FilterIndex {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("The index of the file filter selected in the dialog box. The first item has an index of 1.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
public: __property int get_FilterIndex();
public: __property void set_FilterIndex(
   int value
);
C++/CLI
[SRDescriptionAttribute("The index of the file filter selected in the dialog box. The first item has an index of 1.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
public:
property int FilterIndex {
   int get();
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FileDialog Class
FileDialog Members


InitialDirectory Property

[image]
Gizmox.WebGUI.Forms
InitialDirectory Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > FileDialog Class : InitialDirectory Property

Gets or sets the initial directory displayed by the file dialog box.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Data")>
<DefaultValueAttribute()>
<SRDescriptionAttribute("The initial directory for the dialog box.")>
Public Property InitialDirectory As String
Visual Basic (Usage) Copy Code
Dim instance As FileDialog
Dim value As String

instance.InitialDirectory = value

value = instance.InitialDirectory
C#
[SRCategoryAttribute("Data")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("The initial directory for the dialog box.")]
public string InitialDirectory {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Data")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("The initial directory for the dialog box.")]
public: __property string* get_InitialDirectory();
public: __property void set_InitialDirectory(
   string* value
);
C++/CLI
[SRCategoryAttribute("Data")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("The initial directory for the dialog box.")]
public:
property String^ InitialDirectory {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FileDialog Class
FileDialog Members


MaxFileSize Property

[image]
Gizmox.WebGUI.Forms
MaxFileSize Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > FileDialog Class : MaxFileSize Property

Gets of sets the Maximum file size allowed in kilobytes.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property MaxFileSize As Integer
Visual Basic (Usage) Copy Code
Dim instance As FileDialog
Dim value As Integer

instance.MaxFileSize = value

value = instance.MaxFileSize
C#
[DefaultValueAttribute()]
public int MaxFileSize {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property int get_MaxFileSize();
public: __property void set_MaxFileSize(
   int value
);
C++/CLI
[DefaultValueAttribute()]
public:
property int MaxFileSize {
   int get();
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FileDialog Class
FileDialog Members


Options Property

[image]
Gizmox.WebGUI.Forms
Options Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > FileDialog Class : Options Property

Gets values to initialize the FileDialog.

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property Options As Integer
Visual Basic (Usage) Copy Code
Dim instance As FileDialog
Dim value As Integer

value = instance.Options
C#
protected int Options {get;}
Managed Extensions for C++
protected: __property int get_Options();
C++/CLI
protected:
property int Options {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FileDialog Class
FileDialog Members


RestoreDirectory Property

[image]
Gizmox.WebGUI.Forms
RestoreDirectory Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > FileDialog Class : RestoreDirectory Property

Gets or sets a value indicating whether the dialog box restores the current directory before closing.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<SRCategoryAttribute("Behavior")>
<SRDescriptionAttribute("Controls whether the dialog box restores the current directory before closing.")>
Public Property RestoreDirectory As Boolean
Visual Basic (Usage) Copy Code
Dim instance As FileDialog
Dim value As Boolean

instance.RestoreDirectory = value

value = instance.RestoreDirectory
C#
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Controls whether the dialog box restores the current directory before closing.")]
public bool RestoreDirectory {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Controls whether the dialog box restores the current directory before closing.")]
public: __property bool get_RestoreDirectory();
public: __property void set_RestoreDirectory(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Controls whether the dialog box restores the current directory before closing.")]
public:
property bool RestoreDirectory {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FileDialog Class
FileDialog Members


ShowHelp Property

[image]
Gizmox.WebGUI.Forms
ShowHelp Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > FileDialog Class : ShowHelp Property

Gets or sets a value indicating whether the Help button is displayed in the file dialog box.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Enables the Help button.")>
<SRCategoryAttribute("Behavior")>
<DefaultValueAttribute()>
Public Property ShowHelp As Boolean
Visual Basic (Usage) Copy Code
Dim instance As FileDialog
Dim value As Boolean

instance.ShowHelp = value

value = instance.ShowHelp
C#
[SRDescriptionAttribute("Enables the Help button.")]
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
public bool ShowHelp {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Enables the Help button.")]
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
public: __property bool get_ShowHelp();
public: __property void set_ShowHelp(
   bool value
);
C++/CLI
[SRDescriptionAttribute("Enables the Help button.")]
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
public:
property bool ShowHelp {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FileDialog Class
FileDialog Members


SupportMultiDottedExtensions Property

[image]
Gizmox.WebGUI.Forms
SupportMultiDottedExtensions Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > FileDialog Class : SupportMultiDottedExtensions Property

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Controls whether multi-dotted extensions are supported.")>
<SRCategoryAttribute("Behavior")>
<DefaultValueAttribute()>
Public Property SupportMultiDottedExtensions As Boolean
Visual Basic (Usage) Copy Code
Dim instance As FileDialog
Dim value As Boolean

instance.SupportMultiDottedExtensions = value

value = instance.SupportMultiDottedExtensions
C#
[SRDescriptionAttribute("Controls whether multi-dotted extensions are supported.")]
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
public bool SupportMultiDottedExtensions {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Controls whether multi-dotted extensions are supported.")]
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
public: __property bool get_SupportMultiDottedExtensions();
public: __property void set_SupportMultiDottedExtensions(
   bool value
);
C++/CLI
[SRDescriptionAttribute("Controls whether multi-dotted extensions are supported.")]
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
public:
property bool SupportMultiDottedExtensions {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FileDialog Class
FileDialog Members


Title Property

[image]
Gizmox.WebGUI.Forms
Title Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > FileDialog Class : Title Property

Gets or sets the file dialog box title.

Syntax

Visual Basic (Declaration)
<LocalizableAttribute(True)>
<SRCategoryAttribute("Appearance")>
<SRDescriptionAttribute("The string to display in the title bar of the dialog box.")>
<DefaultValueAttribute()>
Public Property Title As String
Visual Basic (Usage) Copy Code
Dim instance As FileDialog
Dim value As String

instance.Title = value

value = instance.Title
C#
[LocalizableAttribute(true)]
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("The string to display in the title bar of the dialog box.")]
[DefaultValueAttribute()]
public string Title {get; set;}
Managed Extensions for C++
[LocalizableAttribute(true)]
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("The string to display in the title bar of the dialog box.")]
[DefaultValueAttribute()]
public: __property string* get_Title();
public: __property void set_Title(
   string* value
);
C++/CLI
[LocalizableAttribute(true)]
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("The string to display in the title bar of the dialog box.")]
[DefaultValueAttribute()]
public:
property String^ Title {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FileDialog Class
FileDialog Members


ValidateNames Property

[image]
Gizmox.WebGUI.Forms
ValidateNames Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > FileDialog Class : ValidateNames Property

Gets or sets a value indicating whether the dialog box accepts only valid Win32 file names.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<SRCategoryAttribute("Behavior")>
<SRDescriptionAttribute("Controls whether the dialog box ensures that file names do not contain invalid characters or sequences.")>
Public Property ValidateNames As Boolean
Visual Basic (Usage) Copy Code
Dim instance As FileDialog
Dim value As Boolean

instance.ValidateNames = value

value = instance.ValidateNames
C#
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Controls whether the dialog box ensures that file names do not contain invalid characters or sequences.")]
public bool ValidateNames {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Controls whether the dialog box ensures that file names do not contain invalid characters or sequences.")]
public: __property bool get_ValidateNames();
public: __property void set_ValidateNames(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Controls whether the dialog box ensures that file names do not contain invalid characters or sequences.")]
public:
property bool ValidateNames {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FileDialog Class
FileDialog Members


FileDialog Class Events

[image]
Gizmox.WebGUI.Forms
FileDialog Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : FileDialog Class

For a list of all members of this type, see FileDialog members.

Public Events

 | Name | Description
Public Event | Closed | The form close event (Inherited from CommonDialog)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | FileOk | Occurs when the user clicks on the Open or Save button on a file dialog box.
Public Event | HelpRequest | Occurs when the user clicks the Help button on a common dialog box. (Inherited from CommonDialog)
Top

See Also

Reference

FileDialog Class
Gizmox.WebGUI.Forms Namespace


FileOk Event

[image]
Gizmox.WebGUI.Forms
FileOk Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > FileDialog Class : FileOk Event

Occurs when the user clicks on the Open or Save button on a file dialog box.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the user clicks the Open or Save button in the dialog box.")>
Public Event FileOk() As CancelEventHandler
Visual Basic (Usage) Copy Code
Dim instance As FileDialog
Dim handler As CancelEventHandler

AddHandler instance.FileOk, handler
C#
[SRDescriptionAttribute("Occurs when the user clicks the Open or Save button in the dialog box.")]
public event CancelEventHandler FileOk()
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the user clicks the Open or Save button in the dialog box.")]
public: __event CancelEventHandler* FileOk
C++/CLI
[SRDescriptionAttribute("Occurs when the user clicks the Open or Save button in the dialog box.")]
public:
event CancelEventHandler^ FileOk

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FileDialog Class
FileDialog Members


FlowLayoutPanel Class

[image]
Gizmox.WebGUI.Forms
FlowLayoutPanel Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : FlowLayoutPanel Class

Represents a panel that dynamically lays out its contents horizontally or vertically.

Object Model

Syntax

Visual Basic (Declaration)
<ToolboxBitmapAttribute()>
<MetadataTagAttribute("FL")>
<SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableFlowPanel, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")>
<DesignTimeControllerAttribute()>
<ClientControllerAttribute()>
<ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<ToolboxItemCategoryAttribute("Containers")>
Public Class FlowLayoutPanel
   Inherits Panel
   Implements IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Visual Basic (Usage) Copy Code
Dim instance As FlowLayoutPanel
C#
[ToolboxBitmapAttribute()]
[MetadataTagAttribute("FL")]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableFlowPanel, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[DesignTimeControllerAttribute()]
[ClientControllerAttribute()]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ToolboxItemCategoryAttribute("Containers")]
public class FlowLayoutPanel : Panel, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Managed Extensions for C++
[ToolboxBitmapAttribute()]
[MetadataTagAttribute("FL")]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableFlowPanel, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[DesignTimeControllerAttribute()]
[ClientControllerAttribute()]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ToolboxItemCategoryAttribute("Containers")]
public __gc class FlowLayoutPanel : public Panel, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
C++/CLI
[ToolboxBitmapAttribute()]
[MetadataTagAttribute("FL")]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableFlowPanel, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[DesignTimeControllerAttribute()]
[ClientControllerAttribute()]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ToolboxItemCategoryAttribute("Containers")]
public ref class FlowLayoutPanel : public Panel, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.ScrollableControl
Gizmox.WebGUI.Forms.Panel
Gizmox.WebGUI.Forms.FlowLayoutPanel

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

FlowLayoutPanel Members
Gizmox.WebGUI.Forms Namespace


FlowLayoutPanel Class Members

[image]
Gizmox.WebGUI.Forms
FlowLayoutPanel Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : FlowLayoutPanel Class

The following tables list the members exposed by FlowLayoutPanel.

Public Constructors

 | Name | Description
Public Constructor | FlowLayoutPanel Constructor | Initializes a new instance of the FlowLayoutPanel class.
Top

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl)
Public Property | AutoSize | (Inherited from Panel)
Public Property | AutoSizeMode | Indicates the automatic sizing behavior of the control. (Inherited from Panel)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Gets a value indicating whether this control can recive focus. (Inherited from Panel)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | FlowDirection | Gets or sets a value indicating the flow direction of the FlowLayoutPanel control.
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text. (Inherited from Panel)
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Public Property | WrapContents | Gets or sets a value indicating whether the FlowLayoutPanel control should wrap its contents or let the contents be clipped.
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Overridden. Gets a value indicating whether to reverse control rendering.
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Protected Property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl)
Top

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Control)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from ScrollableControl)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Control)
Protected Method | RenderAttributes | Overridden. Renders the attributes.
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | Overridden.
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializePanelType | (Inherited from Panel)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

FlowLayoutPanel Class
Gizmox.WebGUI.Forms Namespace


FlowLayoutPanel Constructor

[image]
Gizmox.WebGUI.Forms
FlowLayoutPanel Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > FlowLayoutPanel Class : FlowLayoutPanel Constructor

Initializes a new instance of the FlowLayoutPanel class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As FlowLayoutPanel()
C#
public FlowLayoutPanel()
Managed Extensions for C++
public: FlowLayoutPanel();
C++/CLI
public:
FlowLayoutPanel();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FlowLayoutPanel Class
FlowLayoutPanel Members


FlowLayoutPanel Class Methods

[image]
Gizmox.WebGUI.Forms
FlowLayoutPanel Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : FlowLayoutPanel Class

For a list of all members of this type, see FlowLayoutPanel members.

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Control)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from ScrollableControl)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Control)
Protected Method | RenderAttributes | Overridden. Renders the attributes.
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | Overridden.
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializePanelType | (Inherited from Panel)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

See Also

Reference

FlowLayoutPanel Class
Gizmox.WebGUI.Forms Namespace


RenderAttributes Method

[image]
Gizmox.WebGUI.Forms
RenderAttributes Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > FlowLayoutPanel Class : RenderAttributes Method

objContext
The obj context.
objWriter
The obj writer.
Renders the attributes.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub RenderAttributes( _
   ByVal objContext As IContext, _
   ByVal objWriter As IAttributeWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As FlowLayoutPanel
Dim objContext As IContext
Dim objWriter As IAttributeWriter

instance.RenderAttributes(objContext, objWriter)
C#
protected override void RenderAttributes(
   IContext objContext,
   IAttributeWriter objWriter
)
Managed Extensions for C++
protected: void RenderAttributes(
   IContext* objContext,
   IAttributeWriter* objWriter
) override
C++/CLI
protected:
void RenderAttributes(
   IContext^ objContext,
   IAttributeWriter^ objWriter
) override

Parameters

objContext
The obj context.
objWriter
The obj writer.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FlowLayoutPanel Class
FlowLayoutPanel Members


RenderUpdatedAttributes Method

[image]
Gizmox.WebGUI.Forms
RenderUpdatedAttributes Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > FlowLayoutPanel Class : RenderUpdatedAttributes Method

objContext
objWriter
lngRequestID

Syntax

Visual Basic (Declaration)
Protected Overrides Sub RenderUpdatedAttributes( _
   ByVal objContext As IContext, _
   ByVal objWriter As IAttributeWriter, _
   ByVal lngRequestID As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As FlowLayoutPanel
Dim objContext As IContext
Dim objWriter As IAttributeWriter
Dim lngRequestID As Long

instance.RenderUpdatedAttributes(objContext, objWriter, lngRequestID)
C#
protected override void RenderUpdatedAttributes(
   IContext objContext,
   IAttributeWriter objWriter,
   long lngRequestID
)
Managed Extensions for C++
protected: void RenderUpdatedAttributes(
   IContext* objContext,
   IAttributeWriter* objWriter,
   long lngRequestID
) override
C++/CLI
protected:
void RenderUpdatedAttributes(
   IContext^ objContext,
   IAttributeWriter^ objWriter,
   long long lngRequestID
) override

Parameters

objContext
objWriter
lngRequestID

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FlowLayoutPanel Class
FlowLayoutPanel Members


FlowLayoutPanel Class Properties

[image]
Gizmox.WebGUI.Forms
FlowLayoutPanel Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : FlowLayoutPanel Class

For a list of all members of this type, see FlowLayoutPanel members.

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl)
Public Property | AutoSize | (Inherited from Panel)
Public Property | AutoSizeMode | Indicates the automatic sizing behavior of the control. (Inherited from Panel)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Gets a value indicating whether this control can recive focus. (Inherited from Panel)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | FlowDirection | Gets or sets a value indicating the flow direction of the FlowLayoutPanel control.
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text. (Inherited from Panel)
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Public Property | WrapContents | Gets or sets a value indicating whether the FlowLayoutPanel control should wrap its contents or let the contents be clipped.
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Overridden. Gets a value indicating whether to reverse control rendering.
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Protected Property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl)
Top

See Also

Reference

FlowLayoutPanel Class
Gizmox.WebGUI.Forms Namespace


FlowDirection Property

[image]
Gizmox.WebGUI.Forms
FlowDirection Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > FlowLayoutPanel Class : FlowDirection Property

Gets or sets a value indicating the flow direction of the FlowLayoutPanel control.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Layout")>
<DefaultValueAttribute()>
<LocalizableAttribute(True)>
<SRDescriptionAttribute("Specifies the direction in which controls are laid out.")>
Public Property FlowDirection As FlowDirection
Visual Basic (Usage) Copy Code
Dim instance As FlowLayoutPanel
Dim value As FlowDirection

instance.FlowDirection = value

value = instance.FlowDirection
C#
[SRCategoryAttribute("Layout")]
[DefaultValueAttribute()]
[LocalizableAttribute(true)]
[SRDescriptionAttribute("Specifies the direction in which controls are laid out.")]
public FlowDirection FlowDirection {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Layout")]
[DefaultValueAttribute()]
[LocalizableAttribute(true)]
[SRDescriptionAttribute("Specifies the direction in which controls are laid out.")]
public: __property FlowDirection get_FlowDirection();
public: __property void set_FlowDirection(
   FlowDirection value
);
C++/CLI
[SRCategoryAttribute("Layout")]
[DefaultValueAttribute()]
[LocalizableAttribute(true)]
[SRDescriptionAttribute("Specifies the direction in which controls are laid out.")]
public:
property FlowDirection FlowDirection {
   FlowDirection get();
   void set (FlowDirectionvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FlowLayoutPanel Class
FlowLayoutPanel Members


ReverseControls Property

[image]
Gizmox.WebGUI.Forms
ReverseControls Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > FlowLayoutPanel Class : ReverseControls Property

Gets a value indicating whether to reverse control rendering.

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property ReverseControls As Boolean
Visual Basic (Usage) Copy Code
Dim instance As FlowLayoutPanel
Dim value As Boolean

value = instance.ReverseControls
C#
protected override bool ReverseControls {get;}
Managed Extensions for C++
protected: __property bool get_ReverseControls() override;
C++/CLI
protected:
property bool ReverseControls {
   bool get() override;
}

Return Value

true if to reverse control rendering; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FlowLayoutPanel Class
FlowLayoutPanel Members


WrapContents Property

[image]
Gizmox.WebGUI.Forms
WrapContents Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > FlowLayoutPanel Class : WrapContents Property

Gets or sets a value indicating whether the FlowLayoutPanel control should wrap its contents or let the contents be clipped.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Indicates whether contents are wrapped or clipped at the control boundary.")>
<DefaultValueAttribute()>
<SRCategoryAttribute("Layout")>
<LocalizableAttribute(True)>
Public Property WrapContents As Boolean
Visual Basic (Usage) Copy Code
Dim instance As FlowLayoutPanel
Dim value As Boolean

instance.WrapContents = value

value = instance.WrapContents
C#
[SRDescriptionAttribute("Indicates whether contents are wrapped or clipped at the control boundary.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Layout")]
[LocalizableAttribute(true)]
public bool WrapContents {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Indicates whether contents are wrapped or clipped at the control boundary.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Layout")]
[LocalizableAttribute(true)]
public: __property bool get_WrapContents();
public: __property void set_WrapContents(
   bool value
);
C++/CLI
[SRDescriptionAttribute("Indicates whether contents are wrapped or clipped at the control boundary.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Layout")]
[LocalizableAttribute(true)]
public:
property bool WrapContents {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FlowLayoutPanel Class
FlowLayoutPanel Members


FolderBrowserDialog Class

[image]
Gizmox.WebGUI.Forms
FolderBrowserDialog Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : FolderBrowserDialog Class

Prompts the user to select a folder. This class can be inherited to provide default data source.

Syntax

Visual Basic (Declaration)
<ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<SRDescriptionAttribute("Displays a dialog box that prompts the user to select a folder.")>
<DefaultPropertyAttribute("SelectedPath")>
<ToolboxBitmapAttribute()>
<DefaultEventAttribute("HelpRequest")>
Public Class FolderBrowserDialog
   Inherits CommonDialog
   Implements ICommonDialog
Visual Basic (Usage) Copy Code
Dim instance As FolderBrowserDialog
C#
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[SRDescriptionAttribute("Displays a dialog box that prompts the user to select a folder.")]
[DefaultPropertyAttribute("SelectedPath")]
[ToolboxBitmapAttribute()]
[DefaultEventAttribute("HelpRequest")]
public class FolderBrowserDialog : CommonDialog, ICommonDialog
Managed Extensions for C++
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[SRDescriptionAttribute("Displays a dialog box that prompts the user to select a folder.")]
[DefaultPropertyAttribute("SelectedPath")]
[ToolboxBitmapAttribute()]
[DefaultEventAttribute("HelpRequest")]
public __gc class FolderBrowserDialog : public CommonDialog, ICommonDialog
C++/CLI
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[SRDescriptionAttribute("Displays a dialog box that prompts the user to select a folder.")]
[DefaultPropertyAttribute("SelectedPath")]
[ToolboxBitmapAttribute()]
[DefaultEventAttribute("HelpRequest")]
public ref class FolderBrowserDialog : public CommonDialog, ICommonDialog

Remarks

By default this dialog works on server side folders.

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.CommonDialog
Gizmox.WebGUI.Forms.FolderBrowserDialog

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

FolderBrowserDialog Members
Gizmox.WebGUI.Forms Namespace


FolderBrowserDialog Class Members

[image]
Gizmox.WebGUI.Forms
FolderBrowserDialog Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : FolderBrowserDialog Class

The following tables list the members exposed by FolderBrowserDialog.

Public Constructors

 | Name | Description
Public Constructor | FolderBrowserDialog Constructor | Initializes a new instance of the FolderBrowserDialog class.
Top

Public Properties

 | Name | Description
Public Property | Container | (Inherited from ComponentBase)
Public Property | Description | Gets or sets the descriptive text displayed above the tree view control in the dialog box.
Public Property | DialogResult | Returns the last dialog result (Inherited from CommonDialog)
Public Property | RootFolder | Gets or sets the root folder where the browsing starts from.
Public Property | SelectedPath | Gets or sets the path selected by the user.
Public Property | ShowNewFolderButton | Gets or sets a value indicating whether the New Folder button appears in the folder browser dialog box.
Public Property | Site | (Inherited from ComponentBase)
Public Property | Tag | Gets or sets an object that contains data about the control. (Inherited from CommonDialog)
Public Property | Title | Gets or sets the file dialog box title.
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Top

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded. (Inherited from ComponentBase)
Public Method | Reset | Overridden. Resets properties to their default values.
Public Method | ShowDialog | Overloaded. Runs a common dialog box with a default owner. (Inherited from CommonDialog)
Public Method | ToString | (Inherited from ComponentBase)
Top

Protected Methods

 | Name | Description
Protected Method | CreateForm | Overridden. Create the folder browser dialog form
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | GetFolderIcon | Gets the folder icon.
Protected Method | GetFolderLabel | Gets the folder label.
Protected Method | GetFolderPath | Gets the folder path.
Protected Method | GetRootFolder | Gets the root folder.
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetSubFolders | Gets the sub folders of the current folder.
Protected Method | HasSubFolders | Determines whether the specified folder has sub folders.
Protected Method | OnApply | Handles apply event (Inherited from CommonDialog)
Protected Method | OnClosed | Raises the Close event. (Inherited from CommonDialog)
Protected Method | OnHelpRequest | Raises the CommonDialog.HelpRequest event. (Inherited from CommonDialog)
Top

Public Events

 | Name | Description
Public Event | Closed | The form close event (Inherited from CommonDialog)
Public Event | Disposed | (Inherited from ComponentBase)
Top

See Also

Reference

FolderBrowserDialog Class
Gizmox.WebGUI.Forms Namespace


FolderBrowserDialog Constructor

[image]
Gizmox.WebGUI.Forms
FolderBrowserDialog Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > FolderBrowserDialog Class : FolderBrowserDialog Constructor

Initializes a new instance of the FolderBrowserDialog class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As FolderBrowserDialog()
C#
public FolderBrowserDialog()
Managed Extensions for C++
public: FolderBrowserDialog();
C++/CLI
public:
FolderBrowserDialog();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FolderBrowserDialog Class
FolderBrowserDialog Members


FolderBrowserDialog Class Methods

[image]
Gizmox.WebGUI.Forms
FolderBrowserDialog Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : FolderBrowserDialog Class

For a list of all members of this type, see FolderBrowserDialog members.

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded. (Inherited from ComponentBase)
Public Method | Reset | Overridden. Resets properties to their default values.
Public Method | ShowDialog | Overloaded. Runs a common dialog box with a default owner. (Inherited from CommonDialog)
Public Method | ToString | (Inherited from ComponentBase)
Top

Protected Methods

 | Name | Description
Protected Method | CreateForm | Overridden. Create the folder browser dialog form
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | GetFolderIcon | Gets the folder icon.
Protected Method | GetFolderLabel | Gets the folder label.
Protected Method | GetFolderPath | Gets the folder path.
Protected Method | GetRootFolder | Gets the root folder.
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetSubFolders | Gets the sub folders of the current folder.
Protected Method | HasSubFolders | Determines whether the specified folder has sub folders.
Protected Method | OnApply | Handles apply event (Inherited from CommonDialog)
Protected Method | OnClosed | Raises the Close event. (Inherited from CommonDialog)
Protected Method | OnHelpRequest | Raises the CommonDialog.HelpRequest event. (Inherited from CommonDialog)
Top

See Also

Reference

FolderBrowserDialog Class
Gizmox.WebGUI.Forms Namespace


CreateForm Method

[image]
Gizmox.WebGUI.Forms
CreateForm Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > FolderBrowserDialog Class : CreateForm Method

Create the folder browser dialog form

Syntax

Visual Basic (Declaration)
Protected Overrides Function CreateForm() As CommonDialog.CommonDialogForm
Visual Basic (Usage) Copy Code
Dim instance As FolderBrowserDialog
Dim value As CommonDialog.CommonDialogForm

value = instance.CreateForm()
C#
protected override CommonDialog.CommonDialogForm CreateForm()
Managed Extensions for C++
protected: CommonDialog.CommonDialogForm* CreateForm(); override
C++/CLI
protected:
CommonDialog::CommonDialogForm^ CreateForm(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FolderBrowserDialog Class
FolderBrowserDialog Members


GetFolderIcon Method

[image]
Gizmox.WebGUI.Forms
GetFolderIcon Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > FolderBrowserDialog Class : GetFolderIcon Method

objFolder
The folder object.
Gets the folder icon.

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetFolderIcon( _
   ByVal objFolder As Object _
) As ResourceHandle
Visual Basic (Usage) Copy Code
Dim instance As FolderBrowserDialog
Dim objFolder As Object
Dim value As ResourceHandle

value = instance.GetFolderIcon(objFolder)
C#
protected virtual ResourceHandle GetFolderIcon(
   object objFolder
)
Managed Extensions for C++
protected: virtual ResourceHandle* GetFolderIcon(
   Object* objFolder
)
C++/CLI
protected:
virtual ResourceHandle^ GetFolderIcon(
   Object^ objFolder
)

Parameters

objFolder
The folder object.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FolderBrowserDialog Class
FolderBrowserDialog Members


GetFolderLabel Method

[image]
Gizmox.WebGUI.Forms
GetFolderLabel Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > FolderBrowserDialog Class : GetFolderLabel Method

objFolder
The folder object.
Gets the folder label.

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetFolderLabel( _
   ByVal objFolder As Object _
) As String
Visual Basic (Usage) Copy Code
Dim instance As FolderBrowserDialog
Dim objFolder As Object
Dim value As String

value = instance.GetFolderLabel(objFolder)
C#
protected virtual string GetFolderLabel(
   object objFolder
)
Managed Extensions for C++
protected: virtual string* GetFolderLabel(
   Object* objFolder
)
C++/CLI
protected:
virtual String^ GetFolderLabel(
   Object^ objFolder
)

Parameters

objFolder
The folder object.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FolderBrowserDialog Class
FolderBrowserDialog Members


GetFolderPath Method

[image]
Gizmox.WebGUI.Forms
GetFolderPath Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > FolderBrowserDialog Class : GetFolderPath Method

objFolder
The folder to get its path.
Gets the folder path.

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetFolderPath( _
   ByVal objFolder As Object _
) As String
Visual Basic (Usage) Copy Code
Dim instance As FolderBrowserDialog
Dim objFolder As Object
Dim value As String

value = instance.GetFolderPath(objFolder)
C#
protected virtual string GetFolderPath(
   object objFolder
)
Managed Extensions for C++
protected: virtual string* GetFolderPath(
   Object* objFolder
)
C++/CLI
protected:
virtual String^ GetFolderPath(
   Object^ objFolder
)

Parameters

objFolder
The folder to get its path.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FolderBrowserDialog Class
FolderBrowserDialog Members


GetRootFolder Method

[image]
Gizmox.WebGUI.Forms
GetRootFolder Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > FolderBrowserDialog Class : GetRootFolder Method

Gets the root folder.

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetRootFolder() As Object
Visual Basic (Usage) Copy Code
Dim instance As FolderBrowserDialog
Dim value As Object

value = instance.GetRootFolder()
C#
protected virtual object GetRootFolder()
Managed Extensions for C++
protected: virtual Object* GetRootFolder();
C++/CLI
protected:
virtual Object^ GetRootFolder();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FolderBrowserDialog Class
FolderBrowserDialog Members


GetSubFolders Method

[image]
Gizmox.WebGUI.Forms
GetSubFolders Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > FolderBrowserDialog Class : GetSubFolders Method

objFolder
The current folder.
Gets the sub folders of the current folder.

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetSubFolders( _
   ByVal objFolder As Object _
) As ICollection
Visual Basic (Usage) Copy Code
Dim instance As FolderBrowserDialog
Dim objFolder As Object
Dim value As ICollection

value = instance.GetSubFolders(objFolder)
C#
protected virtual ICollection GetSubFolders(
   object objFolder
)
Managed Extensions for C++
protected: virtual ICollection* GetSubFolders(
   Object* objFolder
)
C++/CLI
protected:
virtual ICollection^ GetSubFolders(
   Object^ objFolder
)

Parameters

objFolder
The current folder.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FolderBrowserDialog Class
FolderBrowserDialog Members


HasSubFolders Method

[image]
Gizmox.WebGUI.Forms
HasSubFolders Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > FolderBrowserDialog Class : HasSubFolders Method

objFolder
The obj folder.
Determines whether the specified folder has sub folders.

Syntax

Visual Basic (Declaration)
Protected Overridable Function HasSubFolders( _
   ByVal objFolder As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As FolderBrowserDialog
Dim objFolder As Object
Dim value As Boolean

value = instance.HasSubFolders(objFolder)
C#
protected virtual bool HasSubFolders(
   object objFolder
)
Managed Extensions for C++
protected: virtual bool HasSubFolders(
   Object* objFolder
)
C++/CLI
protected:
virtual bool HasSubFolders(
   Object^ objFolder
)

Parameters

objFolder
The obj folder.

Return Value

true if specified folder has sub folders; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FolderBrowserDialog Class
FolderBrowserDialog Members


Reset Method

[image]
Gizmox.WebGUI.Forms
Reset Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > FolderBrowserDialog Class : Reset Method

Resets properties to their default values.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As FolderBrowserDialog

instance.Reset()
C#
public override void Reset()
Managed Extensions for C++
public: void Reset(); override
C++/CLI
public:
void Reset(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FolderBrowserDialog Class
FolderBrowserDialog Members


FolderBrowserDialog Class Properties

[image]
Gizmox.WebGUI.Forms
FolderBrowserDialog Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : FolderBrowserDialog Class

For a list of all members of this type, see FolderBrowserDialog members.

Public Properties

 | Name | Description
Public Property | Container | (Inherited from ComponentBase)
Public Property | Description | Gets or sets the descriptive text displayed above the tree view control in the dialog box.
Public Property | DialogResult | Returns the last dialog result (Inherited from CommonDialog)
Public Property | RootFolder | Gets or sets the root folder where the browsing starts from.
Public Property | SelectedPath | Gets or sets the path selected by the user.
Public Property | ShowNewFolderButton | Gets or sets a value indicating whether the New Folder button appears in the folder browser dialog box.
Public Property | Site | (Inherited from ComponentBase)
Public Property | Tag | Gets or sets an object that contains data about the control. (Inherited from CommonDialog)
Public Property | Title | Gets or sets the file dialog box title.
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Top

See Also

Reference

FolderBrowserDialog Class
Gizmox.WebGUI.Forms Namespace


Description Property

[image]
Gizmox.WebGUI.Forms
Description Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > FolderBrowserDialog Class : Description Property

Gets or sets the descriptive text displayed above the tree view control in the dialog box.

Syntax

Visual Basic (Declaration)
<LocalizableAttribute(True)>
<DefaultValueAttribute()>
<SRCategoryAttribute("Folder Browsing")>
<BrowsableAttribute(True)>
<SRDescriptionAttribute("The string that is displayed above the tree view control in the dialog box. This string can be used to specify instructions to the user.")>
Public Property Description As String
Visual Basic (Usage) Copy Code
Dim instance As FolderBrowserDialog
Dim value As String

instance.Description = value

value = instance.Description
C#
[LocalizableAttribute(true)]
[DefaultValueAttribute()]
[SRCategoryAttribute("Folder Browsing")]
[BrowsableAttribute(true)]
[SRDescriptionAttribute("The string that is displayed above the tree view control in the dialog box. This string can be used to specify instructions to the user.")]
public string Description {get; set;}
Managed Extensions for C++
[LocalizableAttribute(true)]
[DefaultValueAttribute()]
[SRCategoryAttribute("Folder Browsing")]
[BrowsableAttribute(true)]
[SRDescriptionAttribute("The string that is displayed above the tree view control in the dialog box. This string can be used to specify instructions to the user.")]
public: __property string* get_Description();
public: __property void set_Description(
   string* value
);
C++/CLI
[LocalizableAttribute(true)]
[DefaultValueAttribute()]
[SRCategoryAttribute("Folder Browsing")]
[BrowsableAttribute(true)]
[SRDescriptionAttribute("The string that is displayed above the tree view control in the dialog box. This string can be used to specify instructions to the user.")]
public:
property String^ Description {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FolderBrowserDialog Class
FolderBrowserDialog Members


RootFolder Property

[image]
Gizmox.WebGUI.Forms
RootFolder Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > FolderBrowserDialog Class : RootFolder Property

Gets or sets the root folder where the browsing starts from.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(True)>
<SRDescriptionAttribute("The location of the root folder from which to start browsing. Only the specified folder and any subfolders that are beneath it will appear in the dialog box.")>
<SRCategoryAttribute("Folder Browsing")>
<DefaultValueAttribute()>
<LocalizableAttribute(False)>
Public Property RootFolder As Environment.SpecialFolder
Visual Basic (Usage) Copy Code
Dim instance As FolderBrowserDialog
Dim value As Environment.SpecialFolder

instance.RootFolder = value

value = instance.RootFolder
C#
[BrowsableAttribute(true)]
[SRDescriptionAttribute("The location of the root folder from which to start browsing. Only the specified folder and any subfolders that are beneath it will appear in the dialog box.")]
[SRCategoryAttribute("Folder Browsing")]
[DefaultValueAttribute()]
[LocalizableAttribute(false)]
public Environment.SpecialFolder RootFolder {get; set;}
Managed Extensions for C++
[BrowsableAttribute(true)]
[SRDescriptionAttribute("The location of the root folder from which to start browsing. Only the specified folder and any subfolders that are beneath it will appear in the dialog box.")]
[SRCategoryAttribute("Folder Browsing")]
[DefaultValueAttribute()]
[LocalizableAttribute(false)]
public: __property Environment.SpecialFolder get_RootFolder();
public: __property void set_RootFolder(
   Environment.SpecialFolder value
);
C++/CLI
[BrowsableAttribute(true)]
[SRDescriptionAttribute("The location of the root folder from which to start browsing. Only the specified folder and any subfolders that are beneath it will appear in the dialog box.")]
[SRCategoryAttribute("Folder Browsing")]
[DefaultValueAttribute()]
[LocalizableAttribute(false)]
public:
property Environment.SpecialFolder RootFolder {
   Environment.SpecialFolder get();
   void set (Environment.SpecialFoldervalue);
}

Exceptions

Exception | Description
InvalidEnumArgumentException | The value assigned is not one of the SpecialFolder values.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FolderBrowserDialog Class
FolderBrowserDialog Members


SelectedPath Property

[image]
Gizmox.WebGUI.Forms
SelectedPath Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > FolderBrowserDialog Class : SelectedPath Property

Gets or sets the path selected by the user.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<LocalizableAttribute(True)>
<BrowsableAttribute(True)>
<SRCategoryAttribute("Folder Browsing")>
<SRDescriptionAttribute("The path of the folder first selected in the dialog or the last one selected by the user.")>
Public Property SelectedPath As String
Visual Basic (Usage) Copy Code
Dim instance As FolderBrowserDialog
Dim value As String

instance.SelectedPath = value

value = instance.SelectedPath
C#
[DefaultValueAttribute()]
[LocalizableAttribute(true)]
[BrowsableAttribute(true)]
[SRCategoryAttribute("Folder Browsing")]
[SRDescriptionAttribute("The path of the folder first selected in the dialog or the last one selected by the user.")]
public string SelectedPath {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[LocalizableAttribute(true)]
[BrowsableAttribute(true)]
[SRCategoryAttribute("Folder Browsing")]
[SRDescriptionAttribute("The path of the folder first selected in the dialog or the last one selected by the user.")]
public: __property string* get_SelectedPath();
public: __property void set_SelectedPath(
   string* value
);
C++/CLI
[DefaultValueAttribute()]
[LocalizableAttribute(true)]
[BrowsableAttribute(true)]
[SRCategoryAttribute("Folder Browsing")]
[SRDescriptionAttribute("The path of the folder first selected in the dialog or the last one selected by the user.")]
public:
property String^ SelectedPath {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FolderBrowserDialog Class
FolderBrowserDialog Members


ShowNewFolderButton Property

[image]
Gizmox.WebGUI.Forms
ShowNewFolderButton Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > FolderBrowserDialog Class : ShowNewFolderButton Property

Gets or sets a value indicating whether the New Folder button appears in the folder browser dialog box.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Folder Browsing")>
<LocalizableAttribute(False)>
<BrowsableAttribute(True)>
<DefaultValueAttribute()>
<SRDescriptionAttribute("Include the New Folder button in the dialog box.")>
Public Property ShowNewFolderButton As Boolean
Visual Basic (Usage) Copy Code
Dim instance As FolderBrowserDialog
Dim value As Boolean

instance.ShowNewFolderButton = value

value = instance.ShowNewFolderButton
C#
[SRCategoryAttribute("Folder Browsing")]
[LocalizableAttribute(false)]
[BrowsableAttribute(true)]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Include the New Folder button in the dialog box.")]
public bool ShowNewFolderButton {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Folder Browsing")]
[LocalizableAttribute(false)]
[BrowsableAttribute(true)]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Include the New Folder button in the dialog box.")]
public: __property bool get_ShowNewFolderButton();
public: __property void set_ShowNewFolderButton(
   bool value
);
C++/CLI
[SRCategoryAttribute("Folder Browsing")]
[LocalizableAttribute(false)]
[BrowsableAttribute(true)]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Include the New Folder button in the dialog box.")]
public:
property bool ShowNewFolderButton {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FolderBrowserDialog Class
FolderBrowserDialog Members


Title Property

[image]
Gizmox.WebGUI.Forms
Title Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > FolderBrowserDialog Class : Title Property

Gets or sets the file dialog box title.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<LocalizableAttribute(True)>
<SRDescriptionAttribute("The string to display in the title bar of the dialog box.")>
<SRCategoryAttribute("Appearance")>
Public Property Title As String
Visual Basic (Usage) Copy Code
Dim instance As FolderBrowserDialog
Dim value As String

instance.Title = value

value = instance.Title
C#
[DefaultValueAttribute()]
[LocalizableAttribute(true)]
[SRDescriptionAttribute("The string to display in the title bar of the dialog box.")]
[SRCategoryAttribute("Appearance")]
public string Title {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[LocalizableAttribute(true)]
[SRDescriptionAttribute("The string to display in the title bar of the dialog box.")]
[SRCategoryAttribute("Appearance")]
public: __property string* get_Title();
public: __property void set_Title(
   string* value
);
C++/CLI
[DefaultValueAttribute()]
[LocalizableAttribute(true)]
[SRDescriptionAttribute("The string to display in the title bar of the dialog box.")]
[SRCategoryAttribute("Appearance")]
public:
property String^ Title {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FolderBrowserDialog Class
FolderBrowserDialog Members


FontDialog Class

[image]
Gizmox.WebGUI.Forms
FontDialog Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : FontDialog Class

Prompts the user to choose a font from among those installed on the local computer.

Syntax

Visual Basic (Declaration)
<ToolboxBitmapAttribute()>
<DefaultEventAttribute("Apply")>
<SRDescriptionAttribute("Displays a dialog box that prompts the user to choose a font from those installed on the local computer.")>
<DefaultPropertyAttribute("Font")>
<ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
Public Class FontDialog
   Inherits CommonDialog
   Implements ICommonDialog
Visual Basic (Usage) Copy Code
Dim instance As FontDialog
C#
[ToolboxBitmapAttribute()]
[DefaultEventAttribute("Apply")]
[SRDescriptionAttribute("Displays a dialog box that prompts the user to choose a font from those installed on the local computer.")]
[DefaultPropertyAttribute("Font")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
public class FontDialog : CommonDialog, ICommonDialog
Managed Extensions for C++
[ToolboxBitmapAttribute()]
[DefaultEventAttribute("Apply")]
[SRDescriptionAttribute("Displays a dialog box that prompts the user to choose a font from those installed on the local computer.")]
[DefaultPropertyAttribute("Font")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
public __gc class FontDialog : public CommonDialog, ICommonDialog
C++/CLI
[ToolboxBitmapAttribute()]
[DefaultEventAttribute("Apply")]
[SRDescriptionAttribute("Displays a dialog box that prompts the user to choose a font from those installed on the local computer.")]
[DefaultPropertyAttribute("Font")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
public ref class FontDialog : public CommonDialog, ICommonDialog

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.CommonDialog
Gizmox.WebGUI.Forms.FontDialog

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

FontDialog Members
Gizmox.WebGUI.Forms Namespace


FontDialog Class Members

[image]
Gizmox.WebGUI.Forms
FontDialog Class Members
See Also Fields Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : FontDialog Class

The following tables list the members exposed by FontDialog.

Public Constructors

 | Name | Description
Public Constructor | FontDialog Constructor | Initializes a new instance of the FontDialog class.
Top

Protected Fields

 | Name | Description
static (Shared in Visual Basic) | EventApply |
Top

Public Properties

 | Name | Description
Public Property | AllowScriptChange | Gets or sets a value indicating whether the user can change the character set specified in the Script combo box to display a character set other than the one currently displayed.
Public Property | AllowSimulations | Gets or sets a value indicating whether the dialog box allows graphics device interface (GDI) font simulations.
Public Property | AllowVectorFonts | Gets or sets a value indicating whether the dialog box allows vector font selections.
Public Property | AllowVerticalFonts | Gets or sets a value indicating whether the dialog box displays both vertical and horizontal fonts or only horizontal fonts.
Public Property | Color | Gets or sets the selected font color.
Public Property | Container | (Inherited from ComponentBase)
Public Property | DialogResult | Returns the last dialog result (Inherited from CommonDialog)
Public Property | FixedPitchOnly | Gets or sets a value indicating whether the dialog box allows only the selection of fixed-pitch fonts.
Public Property | Font | Gets or sets the selected font.
Public Property | FontMustExist | Gets or sets a value indicating whether the dialog box specifies an error condition if the user attempts to select a font or style that does not exist.
Public Property | MaxSize | Gets or sets the maximum point size a user can select.
Public Property | MinSize | Gets or sets the minimum point size a user can select.
Public Property | ScriptsOnly | Gets or sets a value indicating whether the dialog box allows selection of fonts for all non-OEM and Symbol character sets, as well as the ANSI character set.
Public Property | ShowApply | Gets or sets a value indicating whether the dialog box contains an Apply button.
Public Property | ShowColor | Gets or sets a value indicating whether the dialog box displays the color choice.
Public Property | ShowEffects | Gets or sets a value indicating whether the dialog box contains controls that allow the user to specify strikethrough, underline, and text color options.
Public Property | ShowHelp | Gets or sets a value indicating whether the dialog box displays a Help button.
Public Property | Site | (Inherited from ComponentBase)
Public Property | Tag | Gets or sets an object that contains data about the control. (Inherited from CommonDialog)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | Options | Gets values to initialize the FontDialog.
Top

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded. (Inherited from ComponentBase)
Public Method | Reset | Overridden. Resets all dialog box options to their default values.
Public Method | ShowDialog | Overloaded. Runs a common dialog box with a default owner. (Inherited from CommonDialog)
Public Method | ToString | Overridden. Retrieves a string that includes the name of the current font selected in the dialog box.
Top

Protected Methods

 | Name | Description
Protected Method | CreateForm | Overridden. Create the color dialog form
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | OnApply | Overridden. Raises the Apply event.
Protected Method | OnClosed | Raises the Close event. (Inherited from CommonDialog)
Protected Method | OnHelpRequest | Raises the CommonDialog.HelpRequest event. (Inherited from CommonDialog)
Top

Public Events

 | Name | Description
Public Event | Apply |
Public Event | Closed | The form close event (Inherited from CommonDialog)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | HelpRequest | Occurs when the user clicks the Help button on a common dialog box. (Inherited from CommonDialog)
Top

See Also

Reference

FontDialog Class
Gizmox.WebGUI.Forms Namespace


FontDialog Constructor

[image]
Gizmox.WebGUI.Forms
FontDialog Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > FontDialog Class : FontDialog Constructor

Initializes a new instance of the FontDialog class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As FontDialog()
C#
public FontDialog()
Managed Extensions for C++
public: FontDialog();
C++/CLI
public:
FontDialog();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FontDialog Class
FontDialog Members


FontDialog Class Methods

[image]
Gizmox.WebGUI.Forms
FontDialog Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : FontDialog Class

For a list of all members of this type, see FontDialog members.

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded. (Inherited from ComponentBase)
Public Method | Reset | Overridden. Resets all dialog box options to their default values.
Public Method | ShowDialog | Overloaded. Runs a common dialog box with a default owner. (Inherited from CommonDialog)
Public Method | ToString | Overridden. Retrieves a string that includes the name of the current font selected in the dialog box.
Top

Protected Methods

 | Name | Description
Protected Method | CreateForm | Overridden. Create the color dialog form
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | OnApply | Overridden. Raises the Apply event.
Protected Method | OnClosed | Raises the Close event. (Inherited from CommonDialog)
Protected Method | OnHelpRequest | Raises the CommonDialog.HelpRequest event. (Inherited from CommonDialog)
Top

See Also

Reference

FontDialog Class
Gizmox.WebGUI.Forms Namespace


CreateForm Method

[image]
Gizmox.WebGUI.Forms
CreateForm Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > FontDialog Class : CreateForm Method

Create the color dialog form

Syntax

Visual Basic (Declaration)
Protected Overrides Function CreateForm() As CommonDialog.CommonDialogForm
Visual Basic (Usage) Copy Code
Dim instance As FontDialog
Dim value As CommonDialog.CommonDialogForm

value = instance.CreateForm()
C#
protected override CommonDialog.CommonDialogForm CreateForm()
Managed Extensions for C++
protected: CommonDialog.CommonDialogForm* CreateForm(); override
C++/CLI
protected:
CommonDialog::CommonDialogForm^ CreateForm(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FontDialog Class
FontDialog Members


OnApply Method

[image]
Gizmox.WebGUI.Forms
OnApply Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > FontDialog Class : OnApply Method

e
An EventArgs that contains the data.
Raises the Apply event.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnApply( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As FontDialog
Dim e As EventArgs

instance.OnApply(e)
C#
protected override void OnApply(
   EventArgs e
)
Managed Extensions for C++
protected: void OnApply(
   EventArgs* e
) override
C++/CLI
protected:
void OnApply(
   EventArgs^ e
) override

Parameters

e
An EventArgs that contains the data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FontDialog Class
FontDialog Members


Reset Method

[image]
Gizmox.WebGUI.Forms
Reset Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > FontDialog Class : Reset Method

Resets all dialog box options to their default values.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As FontDialog

instance.Reset()
C#
public override void Reset()
Managed Extensions for C++
public: void Reset(); override
C++/CLI
public:
void Reset(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FontDialog Class
FontDialog Members


ToString Method

[image]
Gizmox.WebGUI.Forms
ToString Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > FontDialog Class : ToString Method

Retrieves a string that includes the name of the current font selected in the dialog box.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As FontDialog
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Return Value

A string that includes the name of the currently selected font.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FontDialog Class
FontDialog Members


FontDialog Class Properties

[image]
Gizmox.WebGUI.Forms
FontDialog Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : FontDialog Class

For a list of all members of this type, see FontDialog members.

Public Properties

 | Name | Description
Public Property | AllowScriptChange | Gets or sets a value indicating whether the user can change the character set specified in the Script combo box to display a character set other than the one currently displayed.
Public Property | AllowSimulations | Gets or sets a value indicating whether the dialog box allows graphics device interface (GDI) font simulations.
Public Property | AllowVectorFonts | Gets or sets a value indicating whether the dialog box allows vector font selections.
Public Property | AllowVerticalFonts | Gets or sets a value indicating whether the dialog box displays both vertical and horizontal fonts or only horizontal fonts.
Public Property | Color | Gets or sets the selected font color.
Public Property | Container | (Inherited from ComponentBase)
Public Property | DialogResult | Returns the last dialog result (Inherited from CommonDialog)
Public Property | FixedPitchOnly | Gets or sets a value indicating whether the dialog box allows only the selection of fixed-pitch fonts.
Public Property | Font | Gets or sets the selected font.
Public Property | FontMustExist | Gets or sets a value indicating whether the dialog box specifies an error condition if the user attempts to select a font or style that does not exist.
Public Property | MaxSize | Gets or sets the maximum point size a user can select.
Public Property | MinSize | Gets or sets the minimum point size a user can select.
Public Property | ScriptsOnly | Gets or sets a value indicating whether the dialog box allows selection of fonts for all non-OEM and Symbol character sets, as well as the ANSI character set.
Public Property | ShowApply | Gets or sets a value indicating whether the dialog box contains an Apply button.
Public Property | ShowColor | Gets or sets a value indicating whether the dialog box displays the color choice.
Public Property | ShowEffects | Gets or sets a value indicating whether the dialog box contains controls that allow the user to specify strikethrough, underline, and text color options.
Public Property | ShowHelp | Gets or sets a value indicating whether the dialog box displays a Help button.
Public Property | Site | (Inherited from ComponentBase)
Public Property | Tag | Gets or sets an object that contains data about the control. (Inherited from CommonDialog)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | Options | Gets values to initialize the FontDialog.
Top

See Also

Reference

FontDialog Class
Gizmox.WebGUI.Forms Namespace


AllowScriptChange Property

[image]
Gizmox.WebGUI.Forms
AllowScriptChange Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > FontDialog Class : AllowScriptChange Property

Gets or sets a value indicating whether the user can change the character set specified in the Script combo box to display a character set other than the one currently displayed.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Controls whether the character set of the font can be changed.")>
<SRCategoryAttribute("Behavior")>
<DefaultValueAttribute()>
Public Property AllowScriptChange As Boolean
Visual Basic (Usage) Copy Code
Dim instance As FontDialog
Dim value As Boolean

instance.AllowScriptChange = value

value = instance.AllowScriptChange
C#
[SRDescriptionAttribute("Controls whether the character set of the font can be changed.")]
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
public bool AllowScriptChange {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Controls whether the character set of the font can be changed.")]
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
public: __property bool get_AllowScriptChange();
public: __property void set_AllowScriptChange(
   bool value
);
C++/CLI
[SRDescriptionAttribute("Controls whether the character set of the font can be changed.")]
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
public:
property bool AllowScriptChange {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FontDialog Class
FontDialog Members


AllowSimulations Property

[image]
Gizmox.WebGUI.Forms
AllowSimulations Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > FontDialog Class : AllowSimulations Property

Gets or sets a value indicating whether the dialog box allows graphics device interface (GDI) font simulations.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Controls whether GDI font simulations are allowed.")>
<DefaultValueAttribute()>
<SRCategoryAttribute("Behavior")>
Public Property AllowSimulations As Boolean
Visual Basic (Usage) Copy Code
Dim instance As FontDialog
Dim value As Boolean

instance.AllowSimulations = value

value = instance.AllowSimulations
C#
[SRDescriptionAttribute("Controls whether GDI font simulations are allowed.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
public bool AllowSimulations {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Controls whether GDI font simulations are allowed.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
public: __property bool get_AllowSimulations();
public: __property void set_AllowSimulations(
   bool value
);
C++/CLI
[SRDescriptionAttribute("Controls whether GDI font simulations are allowed.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
public:
property bool AllowSimulations {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FontDialog Class
FontDialog Members


AllowVectorFonts Property

[image]
Gizmox.WebGUI.Forms
AllowVectorFonts Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > FontDialog Class : AllowVectorFonts Property

Gets or sets a value indicating whether the dialog box allows vector font selections.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Behavior")>
<DefaultValueAttribute()>
<SRDescriptionAttribute("Controls whether vector fonts can be selected.")>
Public Property AllowVectorFonts As Boolean
Visual Basic (Usage) Copy Code
Dim instance As FontDialog
Dim value As Boolean

instance.AllowVectorFonts = value

value = instance.AllowVectorFonts
C#
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Controls whether vector fonts can be selected.")]
public bool AllowVectorFonts {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Controls whether vector fonts can be selected.")]
public: __property bool get_AllowVectorFonts();
public: __property void set_AllowVectorFonts(
   bool value
);
C++/CLI
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Controls whether vector fonts can be selected.")]
public:
property bool AllowVectorFonts {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FontDialog Class
FontDialog Members


AllowVerticalFonts Property

[image]
Gizmox.WebGUI.Forms
AllowVerticalFonts Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > FontDialog Class : AllowVerticalFonts Property

Gets or sets a value indicating whether the dialog box displays both vertical and horizontal fonts or only horizontal fonts.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Controls whether vertical fonts can be selected.")>
<SRCategoryAttribute("Behavior")>
<DefaultValueAttribute()>
Public Property AllowVerticalFonts As Boolean
Visual Basic (Usage) Copy Code
Dim instance As FontDialog
Dim value As Boolean

instance.AllowVerticalFonts = value

value = instance.AllowVerticalFonts
C#
[SRDescriptionAttribute("Controls whether vertical fonts can be selected.")]
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
public bool AllowVerticalFonts {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Controls whether vertical fonts can be selected.")]
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
public: __property bool get_AllowVerticalFonts();
public: __property void set_AllowVerticalFonts(
   bool value
);
C++/CLI
[SRDescriptionAttribute("Controls whether vertical fonts can be selected.")]
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
public:
property bool AllowVerticalFonts {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FontDialog Class
FontDialog Members


Color Property

[image]
Gizmox.WebGUI.Forms
Color Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > FontDialog Class : Color Property

Gets or sets the selected font color.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<SRCategoryAttribute("Data")>
<SRDescriptionAttribute("The color selected in the dialog box.")>
Public Property Color As Color
Visual Basic (Usage) Copy Code
Dim instance As FontDialog
Dim value As Color

instance.Color = value

value = instance.Color
C#
[DefaultValueAttribute()]
[SRCategoryAttribute("Data")]
[SRDescriptionAttribute("The color selected in the dialog box.")]
public Color Color {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[SRCategoryAttribute("Data")]
[SRDescriptionAttribute("The color selected in the dialog box.")]
public: __property Color get_Color();
public: __property void set_Color(
   Color value
);
C++/CLI
[DefaultValueAttribute()]
[SRCategoryAttribute("Data")]
[SRDescriptionAttribute("The color selected in the dialog box.")]
public:
property Color Color {
   Color get();
   void set (Colorvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FontDialog Class
FontDialog Members


FixedPitchOnly Property

[image]
Gizmox.WebGUI.Forms
FixedPitchOnly Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > FontDialog Class : FixedPitchOnly Property

Gets or sets a value indicating whether the dialog box allows only the selection of fixed-pitch fonts.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Behavior")>
<SRDescriptionAttribute("Controls whether only fixed pitch fonts can be selected.")>
<DefaultValueAttribute()>
Public Property FixedPitchOnly As Boolean
Visual Basic (Usage) Copy Code
Dim instance As FontDialog
Dim value As Boolean

instance.FixedPitchOnly = value

value = instance.FixedPitchOnly
C#
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Controls whether only fixed pitch fonts can be selected.")]
[DefaultValueAttribute()]
public bool FixedPitchOnly {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Controls whether only fixed pitch fonts can be selected.")]
[DefaultValueAttribute()]
public: __property bool get_FixedPitchOnly();
public: __property void set_FixedPitchOnly(
   bool value
);
C++/CLI
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Controls whether only fixed pitch fonts can be selected.")]
[DefaultValueAttribute()]
public:
property bool FixedPitchOnly {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FontDialog Class
FontDialog Members


Font Property

[image]
Gizmox.WebGUI.Forms
Font Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > FontDialog Class : Font Property

Gets or sets the selected font.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Data")>
<SRDescriptionAttribute("The font selected in the dialog box.")>
Public Property Font As Font
Visual Basic (Usage) Copy Code
Dim instance As FontDialog
Dim value As Font

instance.Font = value

value = instance.Font
C#
[SRCategoryAttribute("Data")]
[SRDescriptionAttribute("The font selected in the dialog box.")]
public Font Font {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Data")]
[SRDescriptionAttribute("The font selected in the dialog box.")]
public: __property Font* get_Font();
public: __property void set_Font(
   Font* value
);
C++/CLI
[SRCategoryAttribute("Data")]
[SRDescriptionAttribute("The font selected in the dialog box.")]
public:
property Font^ Font {
   Font^ get();
   void set (Font^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FontDialog Class
FontDialog Members


FontMustExist Property

[image]
Gizmox.WebGUI.Forms
FontMustExist Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > FontDialog Class : FontMustExist Property

Gets or sets a value indicating whether the dialog box specifies an error condition if the user attempts to select a font or style that does not exist.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Controls whether to report an error if the selected font does not exist.")>
<DefaultValueAttribute()>
<SRCategoryAttribute("Behavior")>
Public Property FontMustExist As Boolean
Visual Basic (Usage) Copy Code
Dim instance As FontDialog
Dim value As Boolean

instance.FontMustExist = value

value = instance.FontMustExist
C#
[SRDescriptionAttribute("Controls whether to report an error if the selected font does not exist.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
public bool FontMustExist {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Controls whether to report an error if the selected font does not exist.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
public: __property bool get_FontMustExist();
public: __property void set_FontMustExist(
   bool value
);
C++/CLI
[SRDescriptionAttribute("Controls whether to report an error if the selected font does not exist.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
public:
property bool FontMustExist {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FontDialog Class
FontDialog Members


MaxSize Property

[image]
Gizmox.WebGUI.Forms
MaxSize Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > FontDialog Class : MaxSize Property

Gets or sets the maximum point size a user can select.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Data")>
<DefaultValueAttribute()>
<SRDescriptionAttribute("The maximum point size that can be Selected (or zero to disable).")>
Public Property MaxSize As Integer
Visual Basic (Usage) Copy Code
Dim instance As FontDialog
Dim value As Integer

instance.MaxSize = value

value = instance.MaxSize
C#
[SRCategoryAttribute("Data")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("The maximum point size that can be Selected (or zero to disable).")]
public int MaxSize {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Data")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("The maximum point size that can be Selected (or zero to disable).")]
public: __property int get_MaxSize();
public: __property void set_MaxSize(
   int value
);
C++/CLI
[SRCategoryAttribute("Data")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("The maximum point size that can be Selected (or zero to disable).")]
public:
property int MaxSize {
   int get();
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FontDialog Class
FontDialog Members


MinSize Property

[image]
Gizmox.WebGUI.Forms
MinSize Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > FontDialog Class : MinSize Property

Gets or sets the minimum point size a user can select.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("The minimum point size that can be Selected (or zero to disable).")>
<DefaultValueAttribute()>
<SRCategoryAttribute("Data")>
Public Property MinSize As Integer
Visual Basic (Usage) Copy Code
Dim instance As FontDialog
Dim value As Integer

instance.MinSize = value

value = instance.MinSize
C#
[SRDescriptionAttribute("The minimum point size that can be Selected (or zero to disable).")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Data")]
public int MinSize {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("The minimum point size that can be Selected (or zero to disable).")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Data")]
public: __property int get_MinSize();
public: __property void set_MinSize(
   int value
);
C++/CLI
[SRDescriptionAttribute("The minimum point size that can be Selected (or zero to disable).")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Data")]
public:
property int MinSize {
   int get();
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FontDialog Class
FontDialog Members


Options Property

[image]
Gizmox.WebGUI.Forms
Options Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > FontDialog Class : Options Property

Gets values to initialize the FontDialog.

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property Options As Integer
Visual Basic (Usage) Copy Code
Dim instance As FontDialog
Dim value As Integer

value = instance.Options
C#
protected int Options {get;}
Managed Extensions for C++
protected: __property int get_Options();
C++/CLI
protected:
property int Options {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FontDialog Class
FontDialog Members


ScriptsOnly Property

[image]
Gizmox.WebGUI.Forms
ScriptsOnly Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > FontDialog Class : ScriptsOnly Property

Gets or sets a value indicating whether the dialog box allows selection of fonts for all non-OEM and Symbol character sets, as well as the ANSI character set.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<SRCategoryAttribute("Behavior")>
<SRDescriptionAttribute("Controls whether to exclude OEM and Symbol character sets.")>
Public Property ScriptsOnly As Boolean
Visual Basic (Usage) Copy Code
Dim instance As FontDialog
Dim value As Boolean

instance.ScriptsOnly = value

value = instance.ScriptsOnly
C#
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Controls whether to exclude OEM and Symbol character sets.")]
public bool ScriptsOnly {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Controls whether to exclude OEM and Symbol character sets.")]
public: __property bool get_ScriptsOnly();
public: __property void set_ScriptsOnly(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Controls whether to exclude OEM and Symbol character sets.")]
public:
property bool ScriptsOnly {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FontDialog Class
FontDialog Members


ShowApply Property

[image]
Gizmox.WebGUI.Forms
ShowApply Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > FontDialog Class : ShowApply Property

Gets or sets a value indicating whether the dialog box contains an Apply button.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Behavior")>
<SRDescriptionAttribute("Controls whether to show the Apply button.")>
<DefaultValueAttribute()>
Public Property ShowApply As Boolean
Visual Basic (Usage) Copy Code
Dim instance As FontDialog
Dim value As Boolean

instance.ShowApply = value

value = instance.ShowApply
C#
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Controls whether to show the Apply button.")]
[DefaultValueAttribute()]
public bool ShowApply {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Controls whether to show the Apply button.")]
[DefaultValueAttribute()]
public: __property bool get_ShowApply();
public: __property void set_ShowApply(
   bool value
);
C++/CLI
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Controls whether to show the Apply button.")]
[DefaultValueAttribute()]
public:
property bool ShowApply {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FontDialog Class
FontDialog Members


ShowColor Property

[image]
Gizmox.WebGUI.Forms
ShowColor Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > FontDialog Class : ShowColor Property

Gets or sets a value indicating whether the dialog box displays the color choice.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<SRDescriptionAttribute("Controls whether to show a color choice.")>
<SRCategoryAttribute("Behavior")>
Public Property ShowColor As Boolean
Visual Basic (Usage) Copy Code
Dim instance As FontDialog
Dim value As Boolean

instance.ShowColor = value

value = instance.ShowColor
C#
[DefaultValueAttribute()]
[SRDescriptionAttribute("Controls whether to show a color choice.")]
[SRCategoryAttribute("Behavior")]
public bool ShowColor {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[SRDescriptionAttribute("Controls whether to show a color choice.")]
[SRCategoryAttribute("Behavior")]
public: __property bool get_ShowColor();
public: __property void set_ShowColor(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
[SRDescriptionAttribute("Controls whether to show a color choice.")]
[SRCategoryAttribute("Behavior")]
public:
property bool ShowColor {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FontDialog Class
FontDialog Members


ShowEffects Property

[image]
Gizmox.WebGUI.Forms
ShowEffects Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > FontDialog Class : ShowEffects Property

Gets or sets a value indicating whether the dialog box contains controls that allow the user to specify strikethrough, underline, and text color options.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Behavior")>
<DefaultValueAttribute()>
<SRDescriptionAttribute("Controls whether to show the underline, strikeout, and font color selections.")>
Public Property ShowEffects As Boolean
Visual Basic (Usage) Copy Code
Dim instance As FontDialog
Dim value As Boolean

instance.ShowEffects = value

value = instance.ShowEffects
C#
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Controls whether to show the underline, strikeout, and font color selections.")]
public bool ShowEffects {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Controls whether to show the underline, strikeout, and font color selections.")]
public: __property bool get_ShowEffects();
public: __property void set_ShowEffects(
   bool value
);
C++/CLI
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Controls whether to show the underline, strikeout, and font color selections.")]
public:
property bool ShowEffects {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FontDialog Class
FontDialog Members


ShowHelp Property

[image]
Gizmox.WebGUI.Forms
ShowHelp Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > FontDialog Class : ShowHelp Property

Gets or sets a value indicating whether the dialog box displays a Help button.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Controls whether to show the Help button.")>
<DefaultValueAttribute()>
<SRCategoryAttribute("Behavior")>
Public Property ShowHelp As Boolean
Visual Basic (Usage) Copy Code
Dim instance As FontDialog
Dim value As Boolean

instance.ShowHelp = value

value = instance.ShowHelp
C#
[SRDescriptionAttribute("Controls whether to show the Help button.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
public bool ShowHelp {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Controls whether to show the Help button.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
public: __property bool get_ShowHelp();
public: __property void set_ShowHelp(
   bool value
);
C++/CLI
[SRDescriptionAttribute("Controls whether to show the Help button.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
public:
property bool ShowHelp {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FontDialog Class
FontDialog Members


FontDialog Class Fields

[image]
Gizmox.WebGUI.Forms
FontDialog Class Fields
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : FontDialog Class

For a list of all members of this type, see FontDialog members.

Protected Fields

 | Name | Description
static (Shared in Visual Basic) | EventApply |
Top

See Also

Reference

FontDialog Class
Gizmox.WebGUI.Forms Namespace


EventApply Field

[image]
Gizmox.WebGUI.Forms
EventApply Field
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > FontDialog Class : EventApply Field

Syntax

Visual Basic (Declaration)
Protected Shared ReadOnly EventApply As Object
Visual Basic (Usage) Copy Code
Dim value As Object

value = FontDialog.EventApply
C#
protected static readonly object EventApply
Managed Extensions for C++
protected: static readonly Object* EventApply
C++/CLI
protected:
static readonly Object^ EventApply

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FontDialog Class
FontDialog Members


FontDialog Class Events

[image]
Gizmox.WebGUI.Forms
FontDialog Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : FontDialog Class

For a list of all members of this type, see FontDialog members.

Public Events

 | Name | Description
Public Event | Apply |
Public Event | Closed | The form close event (Inherited from CommonDialog)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | HelpRequest | Occurs when the user clicks the Help button on a common dialog box. (Inherited from CommonDialog)
Top

See Also

Reference

FontDialog Class
Gizmox.WebGUI.Forms Namespace


Apply Event

[image]
Gizmox.WebGUI.Forms
Apply Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > FontDialog Class : Apply Event

Syntax

Visual Basic (Declaration)
Public Event Apply() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As FontDialog
Dim handler As EventHandler

AddHandler instance.Apply, handler
C#
public event EventHandler Apply()
Managed Extensions for C++
public: __event EventHandler* Apply
C++/CLI
public:
event EventHandler^ Apply

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FontDialog Class
FontDialog Members


Form Class

[image]
Gizmox.WebGUI.Forms
Form Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : Form Class

Represents a window or dialog box that makes up an application's user interface.

Object Model

Syntax

Visual Basic (Declaration)
<DesignTimeVisibleAttribute()>
<DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IRootDesigner, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089", DesignerTypeName="Gizmox.WebGUI.Common.Design.FormDocumentDesigner, Gizmox.WebGUI.Common.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=ea5dfe57c8eb7edd")>
<InitializationEventAttribute("Load")>
<DesignerCategoryAttribute("Form")>
<MetadataTagAttribute("F")>
<DefaultEventAttribute("Load")>
<ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")>
Public Class Form
   Inherits ContainerControl
   Implements IAttributeExtender, IControl, IEventHandler, IForm, IGatewayComponent, IObservableItem, IObservableLayoutItem, IObservableList, IRegisteredComponent, IRenderableComponent, IBindableComponent, IContainerControl, IArrangedElement
Visual Basic (Usage) Copy Code
Dim instance As Form
C#
[DesignTimeVisibleAttribute()]
[DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IRootDesigner, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089", DesignerTypeName="Gizmox.WebGUI.Common.Design.FormDocumentDesigner, Gizmox.WebGUI.Common.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=ea5dfe57c8eb7edd")]
[InitializationEventAttribute("Load")]
[DesignerCategoryAttribute("Form")]
[MetadataTagAttribute("F")]
[DefaultEventAttribute("Load")]
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
public class Form : ContainerControl, IAttributeExtender, IControl, IEventHandler, IForm, IGatewayComponent, IObservableItem, IObservableLayoutItem, IObservableList, IRegisteredComponent, IRenderableComponent, IBindableComponent, IContainerControl, IArrangedElement
Managed Extensions for C++
[DesignTimeVisibleAttribute()]
[DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IRootDesigner, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089", DesignerTypeName="Gizmox.WebGUI.Common.Design.FormDocumentDesigner, Gizmox.WebGUI.Common.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=ea5dfe57c8eb7edd")]
[InitializationEventAttribute("Load")]
[DesignerCategoryAttribute("Form")]
[MetadataTagAttribute("F")]
[DefaultEventAttribute("Load")]
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
public __gc class Form : public ContainerControl, IAttributeExtender, IControl, IEventHandler, IForm, IGatewayComponent, IObservableItem, IObservableLayoutItem, IObservableList, IRegisteredComponent, IRenderableComponent, IBindableComponent, IContainerControl, IArrangedElement
C++/CLI
[DesignTimeVisibleAttribute()]
[DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IRootDesigner, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089", DesignerTypeName="Gizmox.WebGUI.Common.Design.FormDocumentDesigner, Gizmox.WebGUI.Common.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=ea5dfe57c8eb7edd")]
[InitializationEventAttribute("Load")]
[DesignerCategoryAttribute("Form")]
[MetadataTagAttribute("F")]
[DefaultEventAttribute("Load")]
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
public ref class Form : public ContainerControl, IAttributeExtender, IControl, IEventHandler, IForm, IGatewayComponent, IObservableItem, IObservableLayoutItem, IObservableList, IRegisteredComponent, IRenderableComponent, IBindableComponent, IContainerControl, IArrangedElement

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.ScrollableControl
Gizmox.WebGUI.Forms.ContainerControl
Gizmox.WebGUI.Forms.Form
Gizmox.WebGUI.Forms.Authentication.LogonForm
Gizmox.WebGUI.Forms.Authentication.LogonListenerForm
Gizmox.WebGUI.Forms.Authentication.LogonOpenerForm
Gizmox.WebGUI.Forms.Dialogs.ListViewColumnOptions
Gizmox.WebGUI.Forms.Dialogs.ListViewGroupingOptions
Gizmox.WebGUI.Forms.Dialogs.ListViewSortingOptions
Gizmox.WebGUI.Forms.Dialogs.TraceViewer
Gizmox.WebGUI.Forms.MessageBoxWindow

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Form Members
Gizmox.WebGUI.Forms Namespace


Form Class Members

[image]
Gizmox.WebGUI.Forms
Form Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : Form Class

The following tables list the members exposed by Form.

Public Constructors

 | Name | Description
Public Constructor | Form Constructor | Overloaded. Creates a new Form instance.
Top

Public Properties

 | Name | Description
Public Property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
Public Property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl)
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | AutoScaleBaseSize | Gets or sets the size of the auto scale base. Not implemented.
Public Property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BeforeUnloadMessage | Gets or sets the before unload message.
Public Property | BindingContext | (Inherited from ContainerControl)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CancelButton | Gets or sets the button on the form that is clicked when the user presses the ESC key.
Public Property | CanFocus | Overridden. Gets a value indicating whether this instance can focus.
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Components | (Inherited from ContainerControl)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Overridden. Gets the context.
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | DialogResult | Gets or sets the dialog result.
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl)
Public Property | DragMappings | Gets the form drag mappings.
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | FormBorderStyle | Gets or sets the form border style.
Public Property | FormStyle | Gets or sets the form style.
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Overridden. Gets a value indicating whether this control has controls.
Public Property | Header | Gets or sets the form header control.
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | Icon | Gets or sets the form icon
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
Public Property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximizeBox | Gets or sets a value indicating whether [maximize box].
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form.
Public Property | Menu | Gets or sets the MainMenu that is displayed in the form.
Public Property | MinimizeBox | Gets or sets a value indicating whether [minimize box].
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Modal | Gets or sets a value indicating whether this window is modal.
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | OwnedForms | Gets the child forms.
Public Property | Owner | Gets the parent window.
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | ShowInTaskbar | Gets or sets a value indicating whether [show in taskbar]. Not implemented by design
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | StartPosition | Gets or sets the form start position.
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Control)
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window.
Public Property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. Not implemented by design.
Public Property | Visible | Overridden. Get/Sets the form visibility
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Public Property | WindowState | Gets or sets the state of the window.
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | IsWindowSized | Calculate size invluding borders
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Overridden. Gets or sets the main form.
Protected Property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl)
Top

Public Methods

 | Name | Description
Public Method | Add | (Inherited from ContainerControl)
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Close | Closes this window.
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from ContainerControl)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | Remove | (Inherited from ContainerControl)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Overridden.
Public Method | ShowDialog | Overloaded. Shows a the form as a dialog. The ShowDialog in Visual WebGui works differently than WinForms. Code lines after this call is executed immediately and won’t wait for the dialog to close. If you need to run code only after the dialog is closed or only if a specific result is returned register to the close event of the dialog. See documentation for code example.
Public Method | ShowPopup | Overloaded. Displays the form as a popup window.
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Overridden. Fires an event.
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from ScrollableControl)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnActivated | Raises the Activated event.
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnClosed |
Protected Method | OnClosing |
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Overridden. Occurs when control is created
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLoad | Raises the Load event.
Protected Method | OnLocationChanged | Overridden.
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | Overridden.
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | Overridden. Render the form content
Protected Method | RenderAttributes | Overridden. Renders the forms attribute
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Overridden. Checks if the current control needs rendering and continues to process sub trree/
Protected Method | RenderControls | Overloaded. Overridden. Renders the controls sub tree
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | Overridden.
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

Public Events

 | Name | Description
Public Event | Activated | Occurs when the form is activated in code or by the user.
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | Closed |
Public Event | Closing | The form closing event. This event is not raised on the main form.
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | Load | The form load event
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

Form Class
Gizmox.WebGUI.Forms Namespace


Form Constructor

[image]
Gizmox.WebGUI.Forms
Form Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Form Class : Form Constructor

Creates a new Form instance.

Overload List

Overload | Description
Form Constructor() | Creates a new Form instance.
Form Constructor(IContext) | Creates a new Form instance.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Form Class
Form Members


Form Constructor()

[image]
Gizmox.WebGUI.Forms
Form Constructor()
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Form Class > Form Constructor : Form Constructor()

Creates a new Form instance.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Form()
C#
public Form()
Managed Extensions for C++
public: Form();
C++/CLI
public:
Form();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Form Class
Form Members
Overload List


Form Constructor(IContext)

[image]
Gizmox.WebGUI.Forms
Form Constructor(IContext)
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Form Class > Form Constructor : Form Constructor(IContext)

objContext
Creates a new Form instance.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal objContext As IContext _
)
Visual Basic (Usage) Copy Code
Dim objContext As IContext

Dim instance As Form(objContext)
C#
public Form(
   IContext objContext
)
Managed Extensions for C++
public: Form(
   IContext* objContext
)
C++/CLI
public:
Form(
   IContext^ objContext
)

Parameters

objContext

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Form Class
Form Members
Overload List


Form Class Methods

[image]
Gizmox.WebGUI.Forms
Form Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : Form Class

For a list of all members of this type, see Form members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from ContainerControl)
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Close | Closes this window.
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from ContainerControl)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | Remove | (Inherited from ContainerControl)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Overridden.
Public Method | ShowDialog | Overloaded. Shows a the form as a dialog. The ShowDialog in Visual WebGui works differently than WinForms. Code lines after this call is executed immediately and won’t wait for the dialog to close. If you need to run code only after the dialog is closed or only if a specific result is returned register to the close event of the dialog. See documentation for code example.
Public Method | ShowPopup | Overloaded. Displays the form as a popup window.
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Overridden. Fires an event.
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from ScrollableControl)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnActivated | Raises the Activated event.
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnClosed |
Protected Method | OnClosing |
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Overridden. Occurs when control is created
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLoad | Raises the Load event.
Protected Method | OnLocationChanged | Overridden.
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | Overridden.
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | Overridden. Render the form content
Protected Method | RenderAttributes | Overridden. Renders the forms attribute
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Overridden. Checks if the current control needs rendering and continues to process sub trree/
Protected Method | RenderControls | Overloaded. Overridden. Renders the controls sub tree
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | Overridden.
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

See Also

Reference

Form Class
Gizmox.WebGUI.Forms Namespace


Close Method

[image]
Gizmox.WebGUI.Forms
Close Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Form Class : Close Method

Closes this window.

Syntax

Visual Basic (Declaration)
Public Sub Close()
Visual Basic (Usage) Copy Code
Dim instance As Form

instance.Close()
C#
public void Close()
Managed Extensions for C++
public: void Close();
C++/CLI
public:
void Close();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Form Class
Form Members


FireEvent Method

[image]
Gizmox.WebGUI.Forms
FireEvent Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Form Class : FireEvent Method

objEvent
event.
Fires an event.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub FireEvent( _
   ByVal objEvent As IEvent _
)
Visual Basic (Usage) Copy Code
Dim instance As Form
Dim objEvent As IEvent

instance.FireEvent(objEvent)
C#
protected override void FireEvent(
   IEvent objEvent
)
Managed Extensions for C++
protected: void FireEvent(
   IEvent* objEvent
) override
C++/CLI
protected:
void FireEvent(
   IEvent^ objEvent
) override

Parameters

objEvent
event.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Form Class
Form Members


OnActivated Method

[image]
Gizmox.WebGUI.Forms
OnActivated Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Form Class : OnActivated Method

e
An EventArgs that contains the event data.
Raises the Activated event.

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnActivated( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As Form
Dim e As EventArgs

instance.OnActivated(e)
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnActivated(
   EventArgs e
)
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnActivated(
   EventArgs* e
)
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnActivated(
   EventArgs^ e
)

Parameters

e
An EventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Form Class
Form Members


OnClosed Method

[image]
Gizmox.WebGUI.Forms
OnClosed Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Form Class : OnClosed Method

e

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnClosed( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As Form
Dim e As EventArgs

instance.OnClosed(e)
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnClosed(
   EventArgs e
)
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnClosed(
   EventArgs* e
)
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnClosed(
   EventArgs^ e
)

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Form Class
Form Members


OnClosing Method

[image]
Gizmox.WebGUI.Forms
OnClosing Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Form Class : OnClosing Method

e

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnClosing( _
   ByVal e As CancelEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As Form
Dim e As CancelEventArgs

instance.OnClosing(e)
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnClosing(
   CancelEventArgs e
)
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnClosing(
   CancelEventArgs* e
)
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnClosing(
   CancelEventArgs^ e
)

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Form Class
Form Members


OnCreateControl Method

[image]
Gizmox.WebGUI.Forms
OnCreateControl Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Form Class : OnCreateControl Method

Occurs when control is created

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnCreateControl()
Visual Basic (Usage) Copy Code
Dim instance As Form

instance.OnCreateControl()
C#
protected override void OnCreateControl()
Managed Extensions for C++
protected: void OnCreateControl(); override
C++/CLI
protected:
void OnCreateControl(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Form Class
Form Members


OnLoad Method

[image]
Gizmox.WebGUI.Forms
OnLoad Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Form Class : OnLoad Method

e
An EventArgs that contains the event data.
Raises the Load event.

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnLoad( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As Form
Dim e As EventArgs

instance.OnLoad(e)
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnLoad(
   EventArgs e
)
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnLoad(
   EventArgs* e
)
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnLoad(
   EventArgs^ e
)

Parameters

e
An EventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Form Class
Form Members


OnLocationChanged Method

[image]
Gizmox.WebGUI.Forms
OnLocationChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Form Class : OnLocationChanged Method

e

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnLocationChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As Form
Dim e As EventArgs

instance.OnLocationChanged(e)
C#
protected override void OnLocationChanged(
   EventArgs e
)
Managed Extensions for C++
protected: void OnLocationChanged(
   EventArgs* e
) override
C++/CLI
protected:
void OnLocationChanged(
   EventArgs^ e
) override

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Form Class
Form Members


OnUnregisterComponents Method

[image]
Gizmox.WebGUI.Forms
OnUnregisterComponents Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Form Class : OnUnregisterComponents Method

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnUnregisterComponents()
Visual Basic (Usage) Copy Code
Dim instance As Form

instance.OnUnregisterComponents()
C#
protected override void OnUnregisterComponents()
Managed Extensions for C++
protected: void OnUnregisterComponents(); override
C++/CLI
protected:
void OnUnregisterComponents(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Form Class
Form Members


Render Method

[image]
Gizmox.WebGUI.Forms
Render Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Form Class : Render Method

objContext
objWriter
lngRequestID
Render the form content

Syntax

Visual Basic (Declaration)
Protected Overrides Sub Render( _
   ByVal objContext As IContext, _
   ByVal objWriter As IResponseWriter, _
   ByVal lngRequestID As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As Form
Dim objContext As IContext
Dim objWriter As IResponseWriter
Dim lngRequestID As Long

instance.Render(objContext, objWriter, lngRequestID)
C#
protected override void Render(
   IContext objContext,
   IResponseWriter objWriter,
   long lngRequestID
)
Managed Extensions for C++
protected: void Render(
   IContext* objContext,
   IResponseWriter* objWriter,
   long lngRequestID
) override
C++/CLI
protected:
void Render(
   IContext^ objContext,
   IResponseWriter^ objWriter,
   long long lngRequestID
) override

Parameters

objContext
objWriter
lngRequestID

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Form Class
Form Members


RenderAttributes Method

[image]
Gizmox.WebGUI.Forms
RenderAttributes Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Form Class : RenderAttributes Method

objContext
objWriter
Renders the forms attribute

Syntax

Visual Basic (Declaration)
Protected Overrides Sub RenderAttributes( _
   ByVal objContext As IContext, _
   ByVal objWriter As IAttributeWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As Form
Dim objContext As IContext
Dim objWriter As IAttributeWriter

instance.RenderAttributes(objContext, objWriter)
C#
protected override void RenderAttributes(
   IContext objContext,
   IAttributeWriter objWriter
)
Managed Extensions for C++
protected: void RenderAttributes(
   IContext* objContext,
   IAttributeWriter* objWriter
) override
C++/CLI
protected:
void RenderAttributes(
   IContext^ objContext,
   IAttributeWriter^ objWriter
) override

Parameters

objContext
objWriter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Form Class
Form Members


RenderControl Method

[image]
Gizmox.WebGUI.Forms
RenderControl Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Form Class : RenderControl Method

objContext
objWriter
lngRequestID
Checks if the current control needs rendering and continues to process sub trree/

Syntax

Visual Basic (Declaration)
Protected Overrides Sub RenderControl( _
   ByVal objContext As IContext, _
   ByVal objWriter As IResponseWriter, _
   ByVal lngRequestID As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As Form
Dim objContext As IContext
Dim objWriter As IResponseWriter
Dim lngRequestID As Long

instance.RenderControl(objContext, objWriter, lngRequestID)
C#
protected override void RenderControl(
   IContext objContext,
   IResponseWriter objWriter,
   long lngRequestID
)
Managed Extensions for C++
protected: void RenderControl(
   IContext* objContext,
   IResponseWriter* objWriter,
   long lngRequestID
) override
C++/CLI
protected:
void RenderControl(
   IContext^ objContext,
   IResponseWriter^ objWriter,
   long long lngRequestID
) override

Parameters

objContext
objWriter
lngRequestID

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Form Class
Form Members


RenderControls Method

[image]
Gizmox.WebGUI.Forms
RenderControls Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Form Class : RenderControls Method

Renders the controls sub tree

Overload List

Overload | Description
RenderControls(IContext,IResponseWriter,Int64) | Renders the controls sub tree
RenderControls(IContext,IResponseWriter,Int64,Boolean) | Renders the controls sub tree (Inherited from Control)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Form Class
Form Members


RenderControls(IContext,IResponseWriter,Int64) Method

[image]
Gizmox.WebGUI.Forms
RenderControls(IContext,IResponseWriter,Int64) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Form Class > RenderControls Method : RenderControls(IContext,IResponseWriter,Int64) Method

objContext
objWriter
lngRequestID
Renders the controls sub tree

Syntax

Visual Basic (Declaration)
Protected Overloads Overrides Sub RenderControls( _
   ByVal objContext As IContext, _
   ByVal objWriter As IResponseWriter, _
   ByVal lngRequestID As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As Form
Dim objContext As IContext
Dim objWriter As IResponseWriter
Dim lngRequestID As Long

instance.RenderControls(objContext, objWriter, lngRequestID)
C#
protected override void RenderControls(
   IContext objContext,
   IResponseWriter objWriter,
   long lngRequestID
)
Managed Extensions for C++
protected: void RenderControls(
   IContext* objContext,
   IResponseWriter* objWriter,
   long lngRequestID
) override
C++/CLI
protected:
void RenderControls(
   IContext^ objContext,
   IResponseWriter^ objWriter,
   long long lngRequestID
) override

Parameters

objContext
objWriter
lngRequestID

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Form Class
Form Members
Overload List


RenderUpdatedAttributes Method

[image]
Gizmox.WebGUI.Forms
RenderUpdatedAttributes Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Form Class : RenderUpdatedAttributes Method

objContext
objWriter
lngRequestID

Syntax

Visual Basic (Declaration)
Protected Overrides Sub RenderUpdatedAttributes( _
   ByVal objContext As IContext, _
   ByVal objWriter As IAttributeWriter, _
   ByVal lngRequestID As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As Form
Dim objContext As IContext
Dim objWriter As IAttributeWriter
Dim lngRequestID As Long

instance.RenderUpdatedAttributes(objContext, objWriter, lngRequestID)
C#
protected override void RenderUpdatedAttributes(
   IContext objContext,
   IAttributeWriter objWriter,
   long lngRequestID
)
Managed Extensions for C++
protected: void RenderUpdatedAttributes(
   IContext* objContext,
   IAttributeWriter* objWriter,
   long lngRequestID
) override
C++/CLI
protected:
void RenderUpdatedAttributes(
   IContext^ objContext,
   IAttributeWriter^ objWriter,
   long long lngRequestID
) override

Parameters

objContext
objWriter
lngRequestID

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Form Class
Form Members


Show Method

[image]
Gizmox.WebGUI.Forms
Show Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Form Class : Show Method

Syntax

Visual Basic (Declaration)
Public Overrides Sub Show()
Visual Basic (Usage) Copy Code
Dim instance As Form

instance.Show()
C#
public override void Show()
Managed Extensions for C++
public: void Show(); override
C++/CLI
public:
void Show(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Form Class
Form Members


ShowDialog Method

[image]
Gizmox.WebGUI.Forms
ShowDialog Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Form Class : ShowDialog Method

Shows a the form as a dialog.

The ShowDialog in Visual WebGui works differently than WinForms. Code lines after this call is executed immediately and won’t wait for the dialog to close. If you need to run code only after the dialog is closed or only if a specific result is returned register to the close event of the dialog.

See documentation for code example.

Overload List

Overload | Description
ShowDialog(Form) | Shows a the form as a dialog. The ShowDialog in Visual WebGui works differently than WinForms. Code lines after this call is executed immediately and won’t wait for the dialog to close. If you need to run code only after the dialog is closed or only if a specific result is returned register to the close event of the dialog. See documentation for code example.
ShowDialog() | Shows a form as a dialog. The ShowDialog in Visual WebGui works differently than WinForms. Code lines after this call is executed immediately and won’t wait for the dialog to close. If you need to run code only after the dialog is closed or only if a specific result is returned register to the close event of the dialog. See code example.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Form Class
Form Members


ShowDialog(Form) Method

[image]
Gizmox.WebGUI.Forms
ShowDialog(Form) Method
See Also Example Send Feedback
Gizmox.WebGUI.Forms Namespace > Form Class > ShowDialog Method : ShowDialog(Form) Method

objForm
Obj window.

Shows a the form as a dialog.

The ShowDialog in Visual WebGui works differently than WinForms. Code lines after this call is executed immediately and won’t wait for the dialog to close. If you need to run code only after the dialog is closed or only if a specific result is returned register to the close event of the dialog.

See documentation for code example.

Syntax

Visual Basic (Declaration)
Public Overloads Function ShowDialog( _
   ByVal objForm As Form _
) As DialogResult
Visual Basic (Usage) Copy Code
Dim instance As Form
Dim objForm As Form
Dim value As DialogResult

value = instance.ShowDialog(objForm)
C#
public DialogResult ShowDialog(
   Form objForm
)
Managed Extensions for C++
public: DialogResult ShowDialog(
   Form* objForm
)
C++/CLI
public:
DialogResult ShowDialog(
   Form^ objForm
)

Parameters

objForm
Obj window.

Example

The following code example displays a form as a modal dialog box and evaluates the return value of the dialog box before determining whether to show a message box or not.

C# Copy Code
private void button1_Click(object sender, EventArgs e)
{
Form1 objForm1 = new Form1();
objForm1.Closed += objForm1_Closed;
objForm1.ShowDialog(this);
}
 private void objForm1_Closed(object sender, EventArgs e)
{
 if (((Form1)sender).DialogResult == DialogResult.OK) {
MessageBox.Show("Dialog result OK");
}
}
Visual Basic Copy Code
Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
Dim objForm1 As New Form1()
AddHandler objForm1.Closed, AddressOf objForm1_Closed
objForm1.ShowDialog(Me)
End Sub
Private Sub objForm1_Closed(ByVal sender As Object, ByVal e As EventArgs)
If DirectCast(sender, Form1).DialogResult = DialogResult.OK Then
MessageBox.Show("Dialog result OK")
End If
End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Form Class
Form Members
Overload List


ShowDialog() Method

[image]
Gizmox.WebGUI.Forms
ShowDialog() Method
See Also Example Send Feedback
Gizmox.WebGUI.Forms Namespace > Form Class > ShowDialog Method : ShowDialog() Method

Shows a form as a dialog.

The ShowDialog in Visual WebGui works differently than WinForms. Code lines after this call is executed immediately and won’t wait for the dialog to close. If you need to run code only after the dialog is closed or only if a specific result is returned register to the close event of the dialog.

See code example.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function ShowDialog() As DialogResult
Visual Basic (Usage) Copy Code
Dim instance As Form
Dim value As DialogResult

value = instance.ShowDialog()
C#
public virtual DialogResult ShowDialog()
Managed Extensions for C++
public: virtual DialogResult ShowDialog();
C++/CLI
public:
virtual DialogResult ShowDialog();

Example

The following code example displays a form as a modal dialog box and evaluates the return value of the dialog box before determining whether to show a message box or not.

C# Copy Code
private void button1_Click(object sender, EventArgs e)
{
Form1 objForm1 = new Form1();
objForm1.Closed += objForm1_Closed;
objForm1.ShowDialog();
}
 private void objForm1_Closed(object sender, EventArgs e)
{
 if (((Form1)sender).DialogResult == DialogResult.OK) {
MessageBox.Show("Dialog result OK");
}
}
Visual Basic Copy Code
Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
Dim objForm1 As New Form1()
AddHandler objForm1.Closed, AddressOf objForm1_Closed
objForm1.ShowDialog()
End Sub
Private Sub objForm1_Closed(ByVal sender As Object, ByVal e As EventArgs)
If DirectCast(sender, Form1).DialogResult = DialogResult.OK Then
MessageBox.Show("Dialog result OK")
End If
End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Form Class
Form Members
Overload List


ShowPopup Method

[image]
Gizmox.WebGUI.Forms
ShowPopup Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Form Class : ShowPopup Method

Displays the form as a popup window.

Overload List

Overload | Description
ShowPopup() | Displays the form as a popup window.
ShowPopup(Form) | Displays the form as a popup window.
ShowPopup(Component) | Displays the form as a popup window.
ShowPopup(Component,DialogAlignment) |
ShowPopup(Form,IRegisteredComponent,DialogAlignment) | Used by combobox
ShowPopup(Form,IRegisteredComponentMember,DialogAlignment) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Form Class
Form Members


ShowPopup() Method

[image]
Gizmox.WebGUI.Forms
ShowPopup() Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Form Class > ShowPopup Method : ShowPopup() Method

Displays the form as a popup window.

Syntax

Visual Basic (Declaration)
Public Overloads Function ShowPopup() As DialogResult
Visual Basic (Usage) Copy Code
Dim instance As Form
Dim value As DialogResult

value = instance.ShowPopup()
C#
public DialogResult ShowPopup()
Managed Extensions for C++
public: DialogResult ShowPopup();
C++/CLI
public:
DialogResult ShowPopup();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Form Class
Form Members
Overload List


ShowPopup(Form) Method

[image]
Gizmox.WebGUI.Forms
ShowPopup(Form) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Form Class > ShowPopup Method : ShowPopup(Form) Method

objForm
Displays the form as a popup window.

Syntax

Visual Basic (Declaration)
Public Overloads Function ShowPopup( _
   ByVal objForm As Form _
) As DialogResult
Visual Basic (Usage) Copy Code
Dim instance As Form
Dim objForm As Form
Dim value As DialogResult

value = instance.ShowPopup(objForm)
C#
public DialogResult ShowPopup(
   Form objForm
)
Managed Extensions for C++
public: DialogResult ShowPopup(
   Form* objForm
)
C++/CLI
public:
DialogResult ShowPopup(
   Form^ objForm
)

Parameters

objForm

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Form Class
Form Members
Overload List


ShowPopup(Component) Method

[image]
Gizmox.WebGUI.Forms
ShowPopup(Component) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Form Class > ShowPopup Method : ShowPopup(Component) Method

objComponent
Displays the form as a popup window.

Syntax

Visual Basic (Declaration)
Public Overloads Function ShowPopup( _
   ByVal objComponent As Component _
) As DialogResult
Visual Basic (Usage) Copy Code
Dim instance As Form
Dim objComponent As Component
Dim value As DialogResult

value = instance.ShowPopup(objComponent)
C#
public DialogResult ShowPopup(
   Component objComponent
)
Managed Extensions for C++
public: DialogResult ShowPopup(
   Component* objComponent
)
C++/CLI
public:
DialogResult ShowPopup(
   Component^ objComponent
)

Parameters

objComponent

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Form Class
Form Members
Overload List


ShowPopup(Component,DialogAlignment) Method

[image]
Gizmox.WebGUI.Forms
ShowPopup(Component,DialogAlignment) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Form Class > ShowPopup Method : ShowPopup(Component,DialogAlignment) Method

objComponent
enmAlignment

Syntax

Visual Basic (Declaration)
Public Overloads Function ShowPopup( _
   ByVal objComponent As Component, _
   ByVal enmAlignment As DialogAlignment _
) As DialogResult
Visual Basic (Usage) Copy Code
Dim instance As Form
Dim objComponent As Component
Dim enmAlignment As DialogAlignment
Dim value As DialogResult

value = instance.ShowPopup(objComponent, enmAlignment)
C#
public DialogResult ShowPopup(
   Component objComponent,
   DialogAlignment enmAlignment
)
Managed Extensions for C++
public: DialogResult ShowPopup(
   Component* objComponent,
   DialogAlignment enmAlignment
)
C++/CLI
public:
DialogResult ShowPopup(
   Component^ objComponent,
   DialogAlignment enmAlignment
)

Parameters

objComponent
enmAlignment

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Form Class
Form Members
Overload List


ShowPopup(Form,IRegisteredComponent,DialogAlignment) Method

[image]
Gizmox.WebGUI.Forms
ShowPopup(Form,IRegisteredComponent,DialogAlignment) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Form Class > ShowPopup Method : ShowPopup(Form,IRegisteredComponent,DialogAlignment) Method

objForm
objComponent
IRegisteredComponent
enmAlignment
DialogAlignment
Used by combobox

Syntax

Visual Basic (Declaration)
Public Overloads Function ShowPopup( _
   ByVal objForm As Form, _
   ByVal objComponent As IRegisteredComponent, _
   ByVal enmAlignment As DialogAlignment _
) As DialogResult
Visual Basic (Usage) Copy Code
Dim instance As Form
Dim objForm As Form
Dim objComponent As IRegisteredComponent
Dim enmAlignment As DialogAlignment
Dim value As DialogResult

value = instance.ShowPopup(objForm, objComponent, enmAlignment)
C#
public DialogResult ShowPopup(
   Form objForm,
   IRegisteredComponent objComponent,
   DialogAlignment enmAlignment
)
Managed Extensions for C++
public: DialogResult ShowPopup(
   Form* objForm,
   IRegisteredComponent* objComponent,
   DialogAlignment enmAlignment
)
C++/CLI
public:
DialogResult ShowPopup(
   Form^ objForm,
   IRegisteredComponent^ objComponent,
   DialogAlignment enmAlignment
)

Parameters

objForm
objComponent
IRegisteredComponent
enmAlignment
DialogAlignment

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Form Class
Form Members
Overload List


ShowPopup(Form,IRegisteredComponentMember,DialogAlignment) Method

[image]
Gizmox.WebGUI.Forms
ShowPopup(Form,IRegisteredComponentMember,DialogAlignment) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Form Class > ShowPopup Method : ShowPopup(Form,IRegisteredComponentMember,DialogAlignment) Method

objForm
objComponent
IRegisteredComponentMember
enmAlignment
DialogAlignment

Syntax

Visual Basic (Declaration)
Public Overloads Function ShowPopup( _
   ByVal objForm As Form, _
   ByVal objComponent As IRegisteredComponentMember, _
   ByVal enmAlignment As DialogAlignment _
) As DialogResult
Visual Basic (Usage) Copy Code
Dim instance As Form
Dim objForm As Form
Dim objComponent As IRegisteredComponentMember
Dim enmAlignment As DialogAlignment
Dim value As DialogResult

value = instance.ShowPopup(objForm, objComponent, enmAlignment)
C#
public DialogResult ShowPopup(
   Form objForm,
   IRegisteredComponentMember objComponent,
   DialogAlignment enmAlignment
)
Managed Extensions for C++
public: DialogResult ShowPopup(
   Form* objForm,
   IRegisteredComponentMember* objComponent,
   DialogAlignment enmAlignment
)
C++/CLI
public:
DialogResult ShowPopup(
   Form^ objForm,
   IRegisteredComponentMember^ objComponent,
   DialogAlignment enmAlignment
)

Parameters

objForm
objComponent
IRegisteredComponentMember
enmAlignment
DialogAlignment

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Form Class
Form Members
Overload List


Form Class Properties

[image]
Gizmox.WebGUI.Forms
Form Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : Form Class

For a list of all members of this type, see Form members.

Public Properties

 | Name | Description
Public Property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
Public Property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl)
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | AutoScaleBaseSize | Gets or sets the size of the auto scale base. Not implemented.
Public Property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BeforeUnloadMessage | Gets or sets the before unload message.
Public Property | BindingContext | (Inherited from ContainerControl)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CancelButton | Gets or sets the button on the form that is clicked when the user presses the ESC key.
Public Property | CanFocus | Overridden. Gets a value indicating whether this instance can focus.
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Components | (Inherited from ContainerControl)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Overridden. Gets the context.
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | DialogResult | Gets or sets the dialog result.
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl)
Public Property | DragMappings | Gets the form drag mappings.
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | FormBorderStyle | Gets or sets the form border style.
Public Property | FormStyle | Gets or sets the form style.
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Overridden. Gets a value indicating whether this control has controls.
Public Property | Header | Gets or sets the form header control.
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | Icon | Gets or sets the form icon
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
Public Property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximizeBox | Gets or sets a value indicating whether [maximize box].
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form.
Public Property | Menu | Gets or sets the MainMenu that is displayed in the form.
Public Property | MinimizeBox | Gets or sets a value indicating whether [minimize box].
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Modal | Gets or sets a value indicating whether this window is modal.
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | OwnedForms | Gets the child forms.
Public Property | Owner | Gets the parent window.
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | ShowInTaskbar | Gets or sets a value indicating whether [show in taskbar]. Not implemented by design
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | StartPosition | Gets or sets the form start position.
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Control)
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window.
Public Property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. Not implemented by design.
Public Property | Visible | Overridden. Get/Sets the form visibility
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Public Property | WindowState | Gets or sets the state of the window.
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | IsWindowSized | Calculate size invluding borders
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Overridden. Gets or sets the main form.
Protected Property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl)
Top

See Also

Reference

Form Class
Gizmox.WebGUI.Forms Namespace


AcceptButton Property

[image]
Gizmox.WebGUI.Forms
AcceptButton Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Form Class : AcceptButton Property

Gets or sets the button on the form that is clicked when the user presses the ENTER key.

Syntax

Visual Basic (Declaration)
Public Property AcceptButton As IButtonControl
Visual Basic (Usage) Copy Code
Dim instance As Form
Dim value As IButtonControl

instance.AcceptButton = value

value = instance.AcceptButton
C#
public IButtonControl AcceptButton {get; set;}
Managed Extensions for C++
public: __property IButtonControl* get_AcceptButton();
public: __property void set_AcceptButton(
   IButtonControl* value
);
C++/CLI
public:
property IButtonControl^ AcceptButton {
   IButtonControl^ get();
   void set (IButtonControl^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Form Class
Form Members


AutoScaleBaseSize Property

[image]
Gizmox.WebGUI.Forms
AutoScaleBaseSize Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Form Class : AutoScaleBaseSize Property

Gets or sets the size of the auto scale base. Not implemented.

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("Not implemented.")>
Public Property AutoScaleBaseSize As Size
Visual Basic (Usage) Copy Code
Dim instance As Form
Dim value As Size

instance.AutoScaleBaseSize = value

value = instance.AutoScaleBaseSize
C#
[ObsoleteAttribute("Not implemented.")]
public Size AutoScaleBaseSize {get; set;}
Managed Extensions for C++
[ObsoleteAttribute("Not implemented.")]
public: __property Size get_AutoScaleBaseSize();
public: __property void set_AutoScaleBaseSize(
   Size value
);
C++/CLI
[ObsoleteAttribute("Not implemented.")]
public:
property Size AutoScaleBaseSize {
   Size get();
   void set (Sizevalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Form Class
Form Members


BeforeUnloadMessage Property

[image]
Gizmox.WebGUI.Forms
BeforeUnloadMessage Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Form Class : BeforeUnloadMessage Property

Gets or sets the before unload message.

Syntax

Visual Basic (Declaration)
<LocalizableAttribute(True)>
Public Property BeforeUnloadMessage As String
Visual Basic (Usage) Copy Code
Dim instance As Form
Dim value As String

instance.BeforeUnloadMessage = value

value = instance.BeforeUnloadMessage
C#
[LocalizableAttribute(true)]
public string BeforeUnloadMessage {get; set;}
Managed Extensions for C++
[LocalizableAttribute(true)]
public: __property string* get_BeforeUnloadMessage();
public: __property void set_BeforeUnloadMessage(
   string* value
);
C++/CLI
[LocalizableAttribute(true)]
public:
property String^ BeforeUnloadMessage {
   String^ get();
   void set (String^value);
}

Return Value

The before unload message.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Form Class
Form Members


CancelButton Property

[image]
Gizmox.WebGUI.Forms
CancelButton Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Form Class : CancelButton Property

Gets or sets the button on the form that is clicked when the user presses the ESC key.

Syntax

Visual Basic (Declaration)
Public Property CancelButton As IButtonControl
Visual Basic (Usage) Copy Code
Dim instance As Form
Dim value As IButtonControl

instance.CancelButton = value

value = instance.CancelButton
C#
public IButtonControl CancelButton {get; set;}
Managed Extensions for C++
public: __property IButtonControl* get_CancelButton();
public: __property void set_CancelButton(
   IButtonControl* value
);
C++/CLI
public:
property IButtonControl^ CancelButton {
   IButtonControl^ get();
   void set (IButtonControl^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Form Class
Form Members


CanFocus Property

[image]
Gizmox.WebGUI.Forms
CanFocus Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Form Class : CanFocus Property

Gets a value indicating whether this instance can focus.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanFocus As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Form
Dim value As Boolean

value = instance.CanFocus
C#
public override bool CanFocus {get;}
Managed Extensions for C++
public: __property bool get_CanFocus() override;
C++/CLI
public:
property bool CanFocus {
   bool get() override;
}

Return Value

true if this instance can focus; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Form Class
Form Members


Context Property

[image]
Gizmox.WebGUI.Forms
Context Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Form Class : Context Property

Gets the context.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Context As IContext
Visual Basic (Usage) Copy Code
Dim instance As Form
Dim value As IContext

value = instance.Context
C#
public override IContext Context {get;}
Managed Extensions for C++
public: __property IContext* get_Context() override;
C++/CLI
public:
property IContext^ Context {
   IContext^ get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Form Class
Form Members


DialogResult Property

[image]
Gizmox.WebGUI.Forms
DialogResult Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Form Class : DialogResult Property

Gets or sets the dialog result.

Syntax

Visual Basic (Declaration)
Public Property DialogResult As DialogResult
Visual Basic (Usage) Copy Code
Dim instance As Form
Dim value As DialogResult

instance.DialogResult = value

value = instance.DialogResult
C#
public DialogResult DialogResult {get; set;}
Managed Extensions for C++
public: __property DialogResult get_DialogResult();
public: __property void set_DialogResult(
   DialogResult value
);
C++/CLI
public:
property DialogResult DialogResult {
   DialogResult get();
   void set (DialogResultvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Form Class
Form Members


DragMappings Property

[image]
Gizmox.WebGUI.Forms
DragMappings Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Form Class : DragMappings Property

Gets the form drag mappings.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DragMappings As DragMappings
Visual Basic (Usage) Copy Code
Dim instance As Form
Dim value As DragMappings

value = instance.DragMappings
C#
public DragMappings DragMappings {get;}
Managed Extensions for C++
public: __property DragMappings* get_DragMappings();
C++/CLI
public:
property DragMappings^ DragMappings {
   DragMappings^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Form Class
Form Members


FormBorderStyle Property

[image]
Gizmox.WebGUI.Forms
FormBorderStyle Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Form Class : FormBorderStyle Property

Gets or sets the form border style.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Appearance")>
<SRDescriptionAttribute("Indicates the appearance and behavior of the border and title bar of the form.")>
<DefaultValueAttribute()>
Public Property FormBorderStyle As FormBorderStyle
Visual Basic (Usage) Copy Code
Dim instance As Form
Dim value As FormBorderStyle

instance.FormBorderStyle = value

value = instance.FormBorderStyle
C#
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Indicates the appearance and behavior of the border and title bar of the form.")]
[DefaultValueAttribute()]
public FormBorderStyle FormBorderStyle {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Indicates the appearance and behavior of the border and title bar of the form.")]
[DefaultValueAttribute()]
public: __property FormBorderStyle get_FormBorderStyle();
public: __property void set_FormBorderStyle(
   FormBorderStyle value
);
C++/CLI
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Indicates the appearance and behavior of the border and title bar of the form.")]
[DefaultValueAttribute()]
public:
property FormBorderStyle FormBorderStyle {
   FormBorderStyle get();
   void set (FormBorderStylevalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Form Class
Form Members


FormStyle Property

[image]
Gizmox.WebGUI.Forms
FormStyle Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Form Class : FormStyle Property

Gets or sets the form style.

Syntax

Visual Basic (Declaration)
Public Property FormStyle As FormStyle
Visual Basic (Usage) Copy Code
Dim instance As Form
Dim value As FormStyle

instance.FormStyle = value

value = instance.FormStyle
C#
public FormStyle FormStyle {get; set;}
Managed Extensions for C++
public: __property FormStyle get_FormStyle();
public: __property void set_FormStyle(
   FormStyle value
);
C++/CLI
public:
property FormStyle FormStyle {
   FormStyle get();
   void set (FormStylevalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Form Class
Form Members


HasControls Property

[image]
Gizmox.WebGUI.Forms
HasControls Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Form Class : HasControls Property

Gets a value indicating whether this control has controls.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property HasControls As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Form
Dim value As Boolean

value = instance.HasControls
C#
public override bool HasControls {get;}
Managed Extensions for C++
public: __property bool get_HasControls() override;
C++/CLI
public:
property bool HasControls {
   bool get() override;
}

Return Value

true if this control has controls; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Form Class
Form Members


Header Property

[image]
Gizmox.WebGUI.Forms
Header Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Form Class : Header Property

Gets or sets the form header control.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public Property Header As Control
Visual Basic (Usage) Copy Code
Dim instance As Form
Dim value As Control

instance.Header = value

value = instance.Header
C#
[BrowsableAttribute(false)]
public Control Header {get; set;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property Control* get_Header();
public: __property void set_Header(
   Control* value
);
C++/CLI
[BrowsableAttribute(false)]
public:
property Control^ Header {
   Control^ get();
   void set (Control^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Form Class
Form Members


Icon Property

[image]
Gizmox.WebGUI.Forms
Icon Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Form Class : Icon Property

Gets or sets the form icon

Syntax

Visual Basic (Declaration)
Public Property Icon As ResourceHandle
Visual Basic (Usage) Copy Code
Dim instance As Form
Dim value As ResourceHandle

instance.Icon = value

value = instance.Icon
C#
public ResourceHandle Icon {get; set;}
Managed Extensions for C++
public: __property ResourceHandle* get_Icon();
public: __property void set_Icon(
   ResourceHandle* value
);
C++/CLI
public:
property ResourceHandle^ Icon {
   ResourceHandle^ get();
   void set (ResourceHandle^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Form Class
Form Members


IsMdiChild Property

[image]
Gizmox.WebGUI.Forms
IsMdiChild Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Form Class : IsMdiChild Property

Gets a value indicating whether the form is a multiple document interface (MDI) child form.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Window Style")>
<BrowsableAttribute(False)>
<SRDescriptionAttribute("Determines whether the form is a child of a MDI container.")>
<DesignerSerializationVisibilityAttribute()>
Public ReadOnly Property IsMdiChild As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Form
Dim value As Boolean

value = instance.IsMdiChild
C#
[SRCategoryAttribute("Window Style")]
[BrowsableAttribute(false)]
[SRDescriptionAttribute("Determines whether the form is a child of a MDI container.")]
[DesignerSerializationVisibilityAttribute()]
public bool IsMdiChild {get;}
Managed Extensions for C++
[SRCategoryAttribute("Window Style")]
[BrowsableAttribute(false)]
[SRDescriptionAttribute("Determines whether the form is a child of a MDI container.")]
[DesignerSerializationVisibilityAttribute()]
public: __property bool get_IsMdiChild();
C++/CLI
[SRCategoryAttribute("Window Style")]
[BrowsableAttribute(false)]
[SRDescriptionAttribute("Determines whether the form is a child of a MDI container.")]
[DesignerSerializationVisibilityAttribute()]
public:
property bool IsMdiChild {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Form Class
Form Members


IsMdiContainer Property

[image]
Gizmox.WebGUI.Forms
IsMdiContainer Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Form Class : IsMdiContainer Property

Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<SRDescriptionAttribute("Determines whether the form is an MDI container.")>
<SRCategoryAttribute("Window Style")>
Public Property IsMdiContainer As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Form
Dim value As Boolean

instance.IsMdiContainer = value

value = instance.IsMdiContainer
C#
[DefaultValueAttribute()]
[SRDescriptionAttribute("Determines whether the form is an MDI container.")]
[SRCategoryAttribute("Window Style")]
public bool IsMdiContainer {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[SRDescriptionAttribute("Determines whether the form is an MDI container.")]
[SRCategoryAttribute("Window Style")]
public: __property bool get_IsMdiContainer();
public: __property void set_IsMdiContainer(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
[SRDescriptionAttribute("Determines whether the form is an MDI container.")]
[SRCategoryAttribute("Window Style")]
public:
property bool IsMdiContainer {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Form Class
Form Members


IsWindowSized Property

[image]
Gizmox.WebGUI.Forms
IsWindowSized Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Form Class : IsWindowSized Property

Calculate size invluding borders

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Protected Overridable ReadOnly Property IsWindowSized As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Form
Dim value As Boolean

value = instance.IsWindowSized
C#
[BrowsableAttribute(false)]
protected virtual bool IsWindowSized {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
protected: __property virtual bool get_IsWindowSized();
C++/CLI
[BrowsableAttribute(false)]
protected:
virtual property bool IsWindowSized {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Form Class
Form Members


MaximizeBox Property

[image]
Gizmox.WebGUI.Forms
MaximizeBox Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Form Class : MaximizeBox Property

Gets or sets a value indicating whether [maximize box].

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Determines whether a form has a maximize box in the upper-right corner of its caption bar.")>
<DefaultValueAttribute()>
<SRCategoryAttribute("Window Style")>
Public Property MaximizeBox As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Form
Dim value As Boolean

instance.MaximizeBox = value

value = instance.MaximizeBox
C#
[SRDescriptionAttribute("Determines whether a form has a maximize box in the upper-right corner of its caption bar.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Window Style")]
public bool MaximizeBox {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Determines whether a form has a maximize box in the upper-right corner of its caption bar.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Window Style")]
public: __property bool get_MaximizeBox();
public: __property void set_MaximizeBox(
   bool value
);
C++/CLI
[SRDescriptionAttribute("Determines whether a form has a maximize box in the upper-right corner of its caption bar.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Window Style")]
public:
property bool MaximizeBox {
   bool get();
   void set (boolvalue);
}

Return Value

true if [maximize box]; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Form Class
Form Members


MdiParent Property

[image]
Gizmox.WebGUI.Forms
MdiParent Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Form Class : MdiParent Property

Gets or sets the current multiple document interface (MDI) parent form of this form.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Retrieves the MDI parent of this form.")>
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
<SRCategoryAttribute("Window Style")>
Public Property MdiParent As Form
Visual Basic (Usage) Copy Code
Dim instance As Form
Dim value As Form

instance.MdiParent = value

value = instance.MdiParent
C#
[SRDescriptionAttribute("Retrieves the MDI parent of this form.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
[SRCategoryAttribute("Window Style")]
public Form MdiParent {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Retrieves the MDI parent of this form.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
[SRCategoryAttribute("Window Style")]
public: __property Form* get_MdiParent();
public: __property void set_MdiParent(
   Form* value
);
C++/CLI
[SRDescriptionAttribute("Retrieves the MDI parent of this form.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
[SRCategoryAttribute("Window Style")]
public:
property Form^ MdiParent {
   Form^ get();
   void set (Form^value);
}

Exceptions

Exception | Description
Exception | The Form assigned to this property is not marked as an MDI container.-or- The Form assigned to this property is both a child and an MDI container form.-or- The Form assigned to this property is located on a different thread.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Form Class
Form Members


Menu Property

[image]
Gizmox.WebGUI.Forms
Menu Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Form Class : Menu Property

Gets or sets the MainMenu that is displayed in the form.

Syntax

Visual Basic (Declaration)
Public Property Menu As MainMenu
Visual Basic (Usage) Copy Code
Dim instance As Form
Dim value As MainMenu

instance.Menu = value

value = instance.Menu
C#
public MainMenu Menu {get; set;}
Managed Extensions for C++
public: __property MainMenu* get_Menu();
public: __property void set_Menu(
   MainMenu* value
);
C++/CLI
public:
property MainMenu^ Menu {
   MainMenu^ get();
   void set (MainMenu^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Form Class
Form Members


MinimizeBox Property

[image]
Gizmox.WebGUI.Forms
MinimizeBox Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Form Class : MinimizeBox Property

Gets or sets a value indicating whether [minimize box].

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Window Style")>
<DefaultValueAttribute()>
<SRDescriptionAttribute("Determines whether a form has a minimize box in the upper-right corner of its caption bar.")>
Public Property MinimizeBox As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Form
Dim value As Boolean

instance.MinimizeBox = value

value = instance.MinimizeBox
C#
[SRCategoryAttribute("Window Style")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Determines whether a form has a minimize box in the upper-right corner of its caption bar.")]
public bool MinimizeBox {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Window Style")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Determines whether a form has a minimize box in the upper-right corner of its caption bar.")]
public: __property bool get_MinimizeBox();
public: __property void set_MinimizeBox(
   bool value
);
C++/CLI
[SRCategoryAttribute("Window Style")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Determines whether a form has a minimize box in the upper-right corner of its caption bar.")]
public:
property bool MinimizeBox {
   bool get();
   void set (boolvalue);
}

Return Value

true if [minimize box]; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Form Class
Form Members


Modal Property

[image]
Gizmox.WebGUI.Forms
Modal Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Form Class : Modal Property

Gets or sets a value indicating whether this window is modal.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Modal As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Form
Dim value As Boolean

value = instance.Modal
C#
public bool Modal {get;}
Managed Extensions for C++
public: __property bool get_Modal();
C++/CLI
public:
property bool Modal {
   bool get();
}

Return Value

true if this instance is modal; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Form Class
Form Members


OwnedForms Property

[image]
Gizmox.WebGUI.Forms
OwnedForms Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Form Class : OwnedForms Property

Gets the child forms.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OwnedForms As Form()
Visual Basic (Usage) Copy Code
Dim instance As Form
Dim value() As Form

value = instance.OwnedForms
C#
public Form[] OwnedForms {get;}
Managed Extensions for C++
public: __property Form*[]* get_OwnedForms();
C++/CLI
public:
property array<Form^>^ OwnedForms {
   array<Form^>^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Form Class
Form Members


Owner Property

[image]
Gizmox.WebGUI.Forms
Owner Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Form Class : Owner Property

Gets the parent window.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Owner As Form
Visual Basic (Usage) Copy Code
Dim instance As Form
Dim value As Form

value = instance.Owner
C#
public Form Owner {get;}
Managed Extensions for C++
public: __property Form* get_Owner();
C++/CLI
public:
property Form^ Owner {
   Form^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Form Class
Form Members


Session Property

[image]
Gizmox.WebGUI.Forms
Session Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Form Class : Session Property

Gets or sets the main form.

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property Session As ISession
Visual Basic (Usage) Copy Code
Dim instance As Form
Dim value As ISession

value = instance.Session
C#
protected override ISession Session {get;}
Managed Extensions for C++
protected: __property ISession* get_Session() override;
C++/CLI
protected:
property ISession^ Session {
   ISession^ get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Form Class
Form Members


ShowInTaskbar Property

[image]
Gizmox.WebGUI.Forms
ShowInTaskbar Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Form Class : ShowInTaskbar Property

Gets or sets a value indicating whether [show in taskbar]. Not implemented by design

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Window Style")>
<DefaultValueAttribute()>
<ObsoleteAttribute("Not implemented by design")>
<SRDescriptionAttribute("Determines whether the form appears in the Windows Taskbar.")>
Public Property ShowInTaskbar As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Form
Dim value As Boolean

instance.ShowInTaskbar = value

value = instance.ShowInTaskbar
C#
[SRCategoryAttribute("Window Style")]
[DefaultValueAttribute()]
[ObsoleteAttribute("Not implemented by design")]
[SRDescriptionAttribute("Determines whether the form appears in the Windows Taskbar.")]
public bool ShowInTaskbar {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Window Style")]
[DefaultValueAttribute()]
[ObsoleteAttribute("Not implemented by design")]
[SRDescriptionAttribute("Determines whether the form appears in the Windows Taskbar.")]
public: __property bool get_ShowInTaskbar();
public: __property void set_ShowInTaskbar(
   bool value
);
C++/CLI
[SRCategoryAttribute("Window Style")]
[DefaultValueAttribute()]
[ObsoleteAttribute("Not implemented by design")]
[SRDescriptionAttribute("Determines whether the form appears in the Windows Taskbar.")]
public:
property bool ShowInTaskbar {
   bool get();
   void set (boolvalue);
}

Return Value

true if [show in taskbar]; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Form Class
Form Members


StartPosition Property

[image]
Gizmox.WebGUI.Forms
StartPosition Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Form Class : StartPosition Property

Gets or sets the form start position.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Determines the position of a form when it first appears.")>
<LocalizableAttribute(True)>
<SRCategoryAttribute("Layout")>
<DefaultValueAttribute()>
Public Property StartPosition As FormStartPosition
Visual Basic (Usage) Copy Code
Dim instance As Form
Dim value As FormStartPosition

instance.StartPosition = value

value = instance.StartPosition
C#
[SRDescriptionAttribute("Determines the position of a form when it first appears.")]
[LocalizableAttribute(true)]
[SRCategoryAttribute("Layout")]
[DefaultValueAttribute()]
public FormStartPosition StartPosition {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Determines the position of a form when it first appears.")]
[LocalizableAttribute(true)]
[SRCategoryAttribute("Layout")]
[DefaultValueAttribute()]
public: __property FormStartPosition get_StartPosition();
public: __property void set_StartPosition(
   FormStartPosition value
);
C++/CLI
[SRDescriptionAttribute("Determines the position of a form when it first appears.")]
[LocalizableAttribute(true)]
[SRCategoryAttribute("Layout")]
[DefaultValueAttribute()]
public:
property FormStartPosition StartPosition {
   FormStartPosition get();
   void set (FormStartPositionvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Form Class
Form Members


TopLevel Property

[image]
Gizmox.WebGUI.Forms
TopLevel Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Form Class : TopLevel Property

Gets or sets a value indicating whether to display the form as a top-level window.

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public Property TopLevel As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Form
Dim value As Boolean

instance.TopLevel = value

value = instance.TopLevel
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public bool TopLevel {get; set;}
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property bool get_TopLevel();
public: __property void set_TopLevel(
   bool value
);
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
property bool TopLevel {
   bool get();
   void set (boolvalue);
}

Return Value

true if [top level]; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Form Class
Form Members


TransparencyKey Property

[image]
Gizmox.WebGUI.Forms
TransparencyKey Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Form Class : TransparencyKey Property

Gets or sets the color that will represent transparent areas of the form. Not implemented by design.

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("Not implemented by design")>
Public Property TransparencyKey As Color
Visual Basic (Usage) Copy Code
Dim instance As Form
Dim value As Color

instance.TransparencyKey = value

value = instance.TransparencyKey
C#
[ObsoleteAttribute("Not implemented by design")]
public Color TransparencyKey {get; set;}
Managed Extensions for C++
[ObsoleteAttribute("Not implemented by design")]
public: __property Color get_TransparencyKey();
public: __property void set_TransparencyKey(
   Color value
);
C++/CLI
[ObsoleteAttribute("Not implemented by design")]
public:
property Color TransparencyKey {
   Color get();
   void set (Colorvalue);
}

Return Value

The transparency key.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Form Class
Form Members


Visible Property

[image]
Gizmox.WebGUI.Forms
Visible Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Form Class : Visible Property

Get/Sets the form visibility

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
Public Overrides Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Form
Dim value As Boolean

instance.Visible = value

value = instance.Visible
C#
[DesignerSerializationVisibilityAttribute()]
public override bool Visible {get; set;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
public: __property bool get_Visible() override;
public: __property void set_Visible(
   bool value
) override;
C++/CLI
[DesignerSerializationVisibilityAttribute()]
public:
property bool Visible {
   bool get() override;
   void set (boolvalue) override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Form Class
Form Members


WindowState Property

[image]
Gizmox.WebGUI.Forms
WindowState Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Form Class : WindowState Property

Gets or sets the state of the window.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Layout")>
<SRDescriptionAttribute("Determines the initial visual state of the form.")>
<DefaultValueAttribute()>
Public Property WindowState As FormWindowState
Visual Basic (Usage) Copy Code
Dim instance As Form
Dim value As FormWindowState

instance.WindowState = value

value = instance.WindowState
C#
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Determines the initial visual state of the form.")]
[DefaultValueAttribute()]
public FormWindowState WindowState {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Determines the initial visual state of the form.")]
[DefaultValueAttribute()]
public: __property FormWindowState get_WindowState();
public: __property void set_WindowState(
   FormWindowState value
);
C++/CLI
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Determines the initial visual state of the form.")]
[DefaultValueAttribute()]
public:
property FormWindowState WindowState {
   FormWindowState get();
   void set (FormWindowStatevalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Form Class
Form Members


Form Class Events

[image]
Gizmox.WebGUI.Forms
Form Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : Form Class

For a list of all members of this type, see Form members.

Public Events

 | Name | Description
Public Event | Activated | Occurs when the form is activated in code or by the user.
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | Closed |
Public Event | Closing | The form closing event. This event is not raised on the main form.
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | Load | The form load event
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

Form Class
Gizmox.WebGUI.Forms Namespace


Activated Event

[image]
Gizmox.WebGUI.Forms
Activated Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Form Class : Activated Event

Occurs when the form is activated in code or by the user.

Syntax

Visual Basic (Declaration)
Public Event Activated() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As Form
Dim handler As EventHandler

AddHandler instance.Activated, handler
C#
public event EventHandler Activated()
Managed Extensions for C++
public: __event EventHandler* Activated
C++/CLI
public:
event EventHandler^ Activated

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Form Class
Form Members


Closed Event

[image]
Gizmox.WebGUI.Forms
Closed Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Form Class : Closed Event

Syntax

Visual Basic (Declaration)
Public Event Closed() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As Form
Dim handler As EventHandler

AddHandler instance.Closed, handler
C#
public event EventHandler Closed()
Managed Extensions for C++
public: __event EventHandler* Closed
C++/CLI
public:
event EventHandler^ Closed

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Form Class
Form Members


Closing Event

[image]
Gizmox.WebGUI.Forms
Closing Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Form Class : Closing Event

The form closing event. This event is not raised on the main form.

Syntax

Visual Basic (Declaration)
Public Event Closing() As CancelEventHandler
Visual Basic (Usage) Copy Code
Dim instance As Form
Dim handler As CancelEventHandler

AddHandler instance.Closing, handler
C#
public event CancelEventHandler Closing()
Managed Extensions for C++
public: __event CancelEventHandler* Closing
C++/CLI
public:
event CancelEventHandler^ Closing

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Form Class
Form Members


Load Event

[image]
Gizmox.WebGUI.Forms
Load Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Form Class : Load Event

The form load event

Syntax

Visual Basic (Declaration)
Public Event Load() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As Form
Dim handler As EventHandler

AddHandler instance.Load, handler
C#
public event EventHandler Load()
Managed Extensions for C++
public: __event EventHandler* Load
C++/CLI
public:
event EventHandler^ Load

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Form Class
Form Members


FormReference Class

[image]
Gizmox.WebGUI.Forms
FormReference Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : FormReference Class

References a form

Syntax

Visual Basic (Declaration)
Public Class FormReference
   Implements IFormLink, ILink
Visual Basic (Usage) Copy Code
Dim instance As FormReference
C#
public class FormReference : IFormLink, ILink
Managed Extensions for C++
public __gc class FormReference : public IFormLink, ILink
C++/CLI
public ref class FormReference : public IFormLink, ILink

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.FormReference

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

FormReference Members
Gizmox.WebGUI.Forms Namespace


FormReference Class Members

[image]
Gizmox.WebGUI.Forms
FormReference Class Members
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : FormReference Class

The following tables list the members exposed by FormReference.

Public Constructors

 | Name | Description
Public Constructor | FormReference Constructor | Initialize form reference by application code
Top

See Also

Reference

FormReference Class
Gizmox.WebGUI.Forms Namespace


FormReference Constructor

[image]
Gizmox.WebGUI.Forms
FormReference Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > FormReference Class : FormReference Constructor

application
The application code as defined in the web config
Initialize form reference by application code

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal application As String _
)
Visual Basic (Usage) Copy Code
Dim application As String

Dim instance As FormReference(application)
C#
public FormReference(
   string application
)
Managed Extensions for C++
public: FormReference(
   string* application
)
C++/CLI
public:
FormReference(
   String^ application
)

Parameters

application
The application code as defined in the web config

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FormReference Class
FormReference Members


FrameControl Class

[image]
Gizmox.WebGUI.Forms
FrameControl Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : FrameControl Class

Provides a base class that allows invocation of methods that reside inside controls that have frames

Object Model

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Class FrameControl
   Inherits Control
   Implements IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Visual Basic (Usage) Copy Code
Dim instance As FrameControl
C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public class FrameControl : Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public __gc class FrameControl : public Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public ref class FrameControl : public Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.FrameControl
Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase
Gizmox.WebGUI.Forms.Hosts.AspPageBox
Gizmox.WebGUI.Forms.HtmlBox

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

FrameControl Members
Gizmox.WebGUI.Forms Namespace


FrameControl Class Members

[image]
Gizmox.WebGUI.Forms
FrameControl Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : FrameControl Class

The following tables list the members exposed by FrameControl.

Public Constructors

 | Name | Description
Public Constructor | FrameControl Constructor |
Top

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Control)
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | InvokeClientMethod | Invokes a client side method on the hosted control frame.
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Control)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from Control)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Control)
Protected Method | RenderAttributes | Renders the controls meta attributes (Inherited from Control)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

FrameControl Class
Gizmox.WebGUI.Forms Namespace


FrameControl Constructor

[image]
Gizmox.WebGUI.Forms
FrameControl Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > FrameControl Class : FrameControl Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As FrameControl()
C#
public FrameControl()
Managed Extensions for C++
public: FrameControl();
C++/CLI
public:
FrameControl();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FrameControl Class
FrameControl Members


FrameControl Class Methods

[image]
Gizmox.WebGUI.Forms
FrameControl Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : FrameControl Class

For a list of all members of this type, see FrameControl members.

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | InvokeClientMethod | Invokes a client side method on the hosted control frame.
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Control)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from Control)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Control)
Protected Method | RenderAttributes | Renders the controls meta attributes (Inherited from Control)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

See Also

Reference

FrameControl Class
Gizmox.WebGUI.Forms Namespace


InvokeClientMethod Method

[image]
Gizmox.WebGUI.Forms
InvokeClientMethod Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > FrameControl Class : InvokeClientMethod Method

strMember
The client side method name.
arrArgs
The arugments to be passed to the method
Invokes a client side method on the hosted control frame.

Syntax

Visual Basic (Declaration)
Public Sub InvokeClientMethod( _
   ByVal strMember As String, _
   ByVal ParamArray arrArgs() As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As FrameControl
Dim strMember As String
Dim arrArgs() As Object

instance.InvokeClientMethod(strMember, arrArgs)
C#
public void InvokeClientMethod(
   string strMember,
   params object[] arrArgs
)
Managed Extensions for C++
public: void InvokeClientMethod(
   string* strMember,
   params Object*[]* arrArgs
)
C++/CLI
public:
void InvokeClientMethod(
   String^ strMember,
   ... array<Object^>^ arrArgs
)

Parameters

strMember
The client side method name.
arrArgs
The arugments to be passed to the method

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FrameControl Class
FrameControl Members


GridItem Class

[image]
Gizmox.WebGUI.Forms
GridItem Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : GridItem Class

Implements one row in a PropertyGrid.

Object Model

Syntax

Visual Basic (Declaration)
Public MustInherit Class GridItem
Visual Basic (Usage) Copy Code
Dim instance As GridItem
C#
public abstract class GridItem
Managed Extensions for C++
public __gc abstract class GridItem
C++/CLI
public ref class GridItem abstract

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.GridItem

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

GridItem Members
Gizmox.WebGUI.Forms Namespace


GridItem Class Members

[image]
Gizmox.WebGUI.Forms
GridItem Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : GridItem Class

The following tables list the members exposed by GridItem.

Public Properties

 | Name | Description
Public Property | Expandable | When overridden in a derived class, gets a value indicating whether the specified property is expandable to show nested properties.
Public Property | Expanded | When overridden in a derived class, gets or sets a value indicating whether the GridItem is in an expanded state.
Public Property | GridItems | When overridden in a derived class, gets the collection of GridItem objects, if any, associated as a child of this GridItem.
Public Property | GridItemType | When overridden in a derived class, gets the type of this GridItem.
Public Property | Label | When overridden in a derived class, gets the text of this GridItem.
Public Property | Parent | When overridden in a derived class, gets the parent GridItem of this GridItem, if any.
Public Property | PropertyDescriptor | When overridden in a derived class, gets the PropertyDescriptor that is associated with this GridItem.
Public Property | Tag | Gets or sets user-defined data about the GridItem.
Public Property | Value | When overridden in a derived class, gets the current value of this GridItem.
Top

Public Methods

 | Name | Description
Public Method | Select | When overridden in a derived class, selects this GridItem in the PropertyGrid.
Top

See Also

Reference

GridItem Class
Gizmox.WebGUI.Forms Namespace


GridItem Class Methods

[image]
Gizmox.WebGUI.Forms
GridItem Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : GridItem Class

For a list of all members of this type, see GridItem members.

Public Methods

 | Name | Description
Public Method | Select | When overridden in a derived class, selects this GridItem in the PropertyGrid.
Top

See Also

Reference

GridItem Class
Gizmox.WebGUI.Forms Namespace


Select Method

[image]
Gizmox.WebGUI.Forms
Select Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > GridItem Class : Select Method

When overridden in a derived class, selects this GridItem in the PropertyGrid.

Syntax

Visual Basic (Declaration)
Public MustOverride Function Select() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GridItem
Dim value As Boolean

value = instance.Select()
C#
public abstract bool Select()
Managed Extensions for C++
public: abstract bool Select();
C++/CLI
public:
abstract bool Select();

Return Value

true if the selection is successful; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

GridItem Class
GridItem Members


GridItem Class Properties

[image]
Gizmox.WebGUI.Forms
GridItem Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : GridItem Class

For a list of all members of this type, see GridItem members.

Public Properties

 | Name | Description
Public Property | Expandable | When overridden in a derived class, gets a value indicating whether the specified property is expandable to show nested properties.
Public Property | Expanded | When overridden in a derived class, gets or sets a value indicating whether the GridItem is in an expanded state.
Public Property | GridItems | When overridden in a derived class, gets the collection of GridItem objects, if any, associated as a child of this GridItem.
Public Property | GridItemType | When overridden in a derived class, gets the type of this GridItem.
Public Property | Label | When overridden in a derived class, gets the text of this GridItem.
Public Property | Parent | When overridden in a derived class, gets the parent GridItem of this GridItem, if any.
Public Property | PropertyDescriptor | When overridden in a derived class, gets the PropertyDescriptor that is associated with this GridItem.
Public Property | Tag | Gets or sets user-defined data about the GridItem.
Public Property | Value | When overridden in a derived class, gets the current value of this GridItem.
Top

See Also

Reference

GridItem Class
Gizmox.WebGUI.Forms Namespace


Expandable Property

[image]
Gizmox.WebGUI.Forms
Expandable Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > GridItem Class : Expandable Property

When overridden in a derived class, gets a value indicating whether the specified property is expandable to show nested properties.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Expandable As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GridItem
Dim value As Boolean

value = instance.Expandable
C#
public virtual bool Expandable {get;}
Managed Extensions for C++
public: __property virtual bool get_Expandable();
C++/CLI
public:
virtual property bool Expandable {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

GridItem Class
GridItem Members


Expanded Property

[image]
Gizmox.WebGUI.Forms
Expanded Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > GridItem Class : Expanded Property

When overridden in a derived class, gets or sets a value indicating whether the GridItem is in an expanded state.

Syntax

Visual Basic (Declaration)
Public Overridable Property Expanded As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GridItem
Dim value As Boolean

instance.Expanded = value

value = instance.Expanded
C#
public virtual bool Expanded {get; set;}
Managed Extensions for C++
public: __property virtual bool get_Expanded();
public: __property virtual void set_Expanded(
   bool value
);
C++/CLI
public:
virtual property bool Expanded {
   bool get();
   void set (boolvalue);
}

Exceptions

Exception | Description
NotSupportedException | The Expanded property was set to true, but a GridItem is not expandable.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

GridItem Class
GridItem Members


GridItems Property

[image]
Gizmox.WebGUI.Forms
GridItems Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > GridItem Class : GridItems Property

When overridden in a derived class, gets the collection of GridItem objects, if any, associated as a child of this GridItem.

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property GridItems As GridItemCollection
Visual Basic (Usage) Copy Code
Dim instance As GridItem
Dim value As GridItemCollection

value = instance.GridItems
C#
public abstract GridItemCollection GridItems {get;}
Managed Extensions for C++
public: __property abstract GridItemCollection* get_GridItems();
C++/CLI
public:
abstract property GridItemCollection^ GridItems {
   GridItemCollection^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

GridItem Class
GridItem Members


GridItemType Property

[image]
Gizmox.WebGUI.Forms
GridItemType Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > GridItem Class : GridItemType Property

When overridden in a derived class, gets the type of this GridItem.

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property GridItemType As GridItemType
Visual Basic (Usage) Copy Code
Dim instance As GridItem
Dim value As GridItemType

value = instance.GridItemType
C#
public abstract GridItemType GridItemType {get;}
Managed Extensions for C++
public: __property abstract GridItemType get_GridItemType();
C++/CLI
public:
abstract property GridItemType GridItemType {
   GridItemType get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

GridItem Class
GridItem Members


Label Property

[image]
Gizmox.WebGUI.Forms
Label Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > GridItem Class : Label Property

When overridden in a derived class, gets the text of this GridItem.

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property Label As String
Visual Basic (Usage) Copy Code
Dim instance As GridItem
Dim value As String

value = instance.Label
C#
public abstract string Label {get;}
Managed Extensions for C++
public: __property abstract string* get_Label();
C++/CLI
public:
abstract property String^ Label {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

GridItem Class
GridItem Members


Parent Property

[image]
Gizmox.WebGUI.Forms
Parent Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > GridItem Class : Parent Property

When overridden in a derived class, gets the parent GridItem of this GridItem, if any.

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property Parent As GridItem
Visual Basic (Usage) Copy Code
Dim instance As GridItem
Dim value As GridItem

value = instance.Parent
C#
public abstract GridItem Parent {get;}
Managed Extensions for C++
public: __property abstract GridItem* get_Parent();
C++/CLI
public:
abstract property GridItem^ Parent {
   GridItem^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

GridItem Class
GridItem Members


PropertyDescriptor Property

[image]
Gizmox.WebGUI.Forms
PropertyDescriptor Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > GridItem Class : PropertyDescriptor Property

When overridden in a derived class, gets the PropertyDescriptor that is associated with this GridItem.

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property PropertyDescriptor As PropertyDescriptor
Visual Basic (Usage) Copy Code
Dim instance As GridItem
Dim value As PropertyDescriptor

value = instance.PropertyDescriptor
C#
public abstract PropertyDescriptor PropertyDescriptor {get;}
Managed Extensions for C++
public: __property abstract PropertyDescriptor* get_PropertyDescriptor();
C++/CLI
public:
abstract property PropertyDescriptor^ PropertyDescriptor {
   PropertyDescriptor^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

GridItem Class
GridItem Members


Tag Property

[image]
Gizmox.WebGUI.Forms
Tag Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > GridItem Class : Tag Property

Gets or sets user-defined data about the GridItem.

Syntax

Visual Basic (Declaration)
<LocalizableAttribute(False)>
<SRCategoryAttribute("Data")>
<BindableAttribute(True)>
<TypeConverterAttribute("System.ComponentModel.StringConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<SRDescriptionAttribute("User-defined data associated with the object.")>
<DefaultValueAttribute()>
Public Property Tag As Object
Visual Basic (Usage) Copy Code
Dim instance As GridItem
Dim value As Object

instance.Tag = value

value = instance.Tag
C#
[LocalizableAttribute(false)]
[SRCategoryAttribute("Data")]
[BindableAttribute(true)]
[TypeConverterAttribute("System.ComponentModel.StringConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[SRDescriptionAttribute("User-defined data associated with the object.")]
[DefaultValueAttribute()]
public object Tag {get; set;}
Managed Extensions for C++
[LocalizableAttribute(false)]
[SRCategoryAttribute("Data")]
[BindableAttribute(true)]
[TypeConverterAttribute("System.ComponentModel.StringConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[SRDescriptionAttribute("User-defined data associated with the object.")]
[DefaultValueAttribute()]
public: __property Object* get_Tag();
public: __property void set_Tag(
   Object* value
);
C++/CLI
[LocalizableAttribute(false)]
[SRCategoryAttribute("Data")]
[BindableAttribute(true)]
[TypeConverterAttribute("System.ComponentModel.StringConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[SRDescriptionAttribute("User-defined data associated with the object.")]
[DefaultValueAttribute()]
public:
property Object^ Tag {
   Object^ get();
   void set (Object^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

GridItem Class
GridItem Members


Value Property

[image]
Gizmox.WebGUI.Forms
Value Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > GridItem Class : Value Property

When overridden in a derived class, gets the current value of this GridItem.

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property Value As Object
Visual Basic (Usage) Copy Code
Dim instance As GridItem
Dim value As Object

value = instance.Value
C#
public abstract object Value {get;}
Managed Extensions for C++
public: __property abstract Object* get_Value();
C++/CLI
public:
abstract property Object^ Value {
   Object^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

GridItem Class
GridItem Members


GridItemCollection Class

[image]
Gizmox.WebGUI.Forms
GridItemCollection Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : GridItemCollection Class

Contains a collection of GridItem objects.

Object Model

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class GridItemCollection
Visual Basic (Usage) Copy Code
Dim instance As GridItemCollection
C#
[DefaultMemberAttribute("Item")]
public class GridItemCollection
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
public __gc class GridItemCollection
C++/CLI
[DefaultMemberAttribute("Item")]
public ref class GridItemCollection

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.GridItemCollection

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

GridItemCollection Members
Gizmox.WebGUI.Forms Namespace


GridItemCollection Class Members

[image]
Gizmox.WebGUI.Forms
GridItemCollection Class Members
See Also Fields Properties Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : GridItemCollection Class

The following tables list the members exposed by GridItemCollection.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Empty | Specifies that the GridItemCollection has no entries.
Top

Public Properties

 | Name | Description
Public Property | Count | Gets the number of grid items in the collection.
Public Property | Item | Overloaded. Gets the GridItem at the specified index.
Top

Public Methods

 | Name | Description
Public Method | GetEnumerator | Returns an enumeration of all the grid items in the collection.
Top

See Also

Reference

GridItemCollection Class
Gizmox.WebGUI.Forms Namespace


GridItemCollection Class Methods

[image]
Gizmox.WebGUI.Forms
GridItemCollection Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : GridItemCollection Class

For a list of all members of this type, see GridItemCollection members.

Public Methods

 | Name | Description
Public Method | GetEnumerator | Returns an enumeration of all the grid items in the collection.
Top

See Also

Reference

GridItemCollection Class
Gizmox.WebGUI.Forms Namespace


GetEnumerator Method

[image]
Gizmox.WebGUI.Forms
GetEnumerator Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > GridItemCollection Class : GetEnumerator Method

Returns an enumeration of all the grid items in the collection.

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As GridItemCollection
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Return Value

An IEnumerator for the GridItemCollection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

GridItemCollection Class
GridItemCollection Members


GridItemCollection Class Properties

[image]
Gizmox.WebGUI.Forms
GridItemCollection Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : GridItemCollection Class

For a list of all members of this type, see GridItemCollection members.

Public Properties

 | Name | Description
Public Property | Count | Gets the number of grid items in the collection.
Public Property | Item | Overloaded. Gets the GridItem at the specified index.
Top

See Also

Reference

GridItemCollection Class
Gizmox.WebGUI.Forms Namespace


Count Property

[image]
Gizmox.WebGUI.Forms
Count Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > GridItemCollection Class : Count Property

Gets the number of grid items in the collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As GridItemCollection
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

GridItemCollection Class
GridItemCollection Members


Item Property

[image]
Gizmox.WebGUI.Forms
Item Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > GridItemCollection Class : Item Property

Gets the GridItem at the specified index.

Overload List

Overload | Description
Item(Int32) | Gets the GridItem at the specified index.
Item(String) | Gets the GridItem with the matching label.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

GridItemCollection Class
GridItemCollection Members


Item(Int32) Property

[image]
Gizmox.WebGUI.Forms
Item(Int32) Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > GridItemCollection Class > Item Property : Item(Int32) Property

index
The index of the grid item to return.
Gets the GridItem at the specified index.

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal index As Integer _
) As GridItem
Visual Basic (Usage) Copy Code
Dim instance As GridItemCollection
Dim index As Integer
Dim value As GridItem

value = instance.Item(index)
C#
public GridItem Item(
   int index
) {get;}
Managed Extensions for C++
public: __property GridItem* get_Item(
   int index
);
C++/CLI
public:
property GridItem^ Item {
   GridItem^ get(intindex);
}

Parameters

index
The index of the grid item to return.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

GridItemCollection Class
GridItemCollection Members
Overload List


Item(String) Property

[image]
Gizmox.WebGUI.Forms
Item(String) Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > GridItemCollection Class > Item Property : Item(String) Property

label
A string value to match to a grid item label
Gets the GridItem with the matching label.

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal label As String _
) As GridItem
Visual Basic (Usage) Copy Code
Dim instance As GridItemCollection
Dim label As String
Dim value As GridItem

value = instance.Item(label)
C#
public GridItem Item(
   string label
) {get;}
Managed Extensions for C++
public: __property GridItem* get_Item(
   string* label
);
C++/CLI
public:
property GridItem^ Item {
   GridItem^ get(String^label);
}

Parameters

label
A string value to match to a grid item label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

GridItemCollection Class
GridItemCollection Members
Overload List


GridItemCollection Class Fields

[image]
Gizmox.WebGUI.Forms
GridItemCollection Class Fields
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : GridItemCollection Class

For a list of all members of this type, see GridItemCollection members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Empty | Specifies that the GridItemCollection has no entries.
Top

See Also

Reference

GridItemCollection Class
Gizmox.WebGUI.Forms Namespace


Empty Field

[image]
Gizmox.WebGUI.Forms
Empty Field
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > GridItemCollection Class : Empty Field

Specifies that the GridItemCollection has no entries.

Syntax

Visual Basic (Declaration)
Public Shared Empty As GridItemCollection
Visual Basic (Usage) Copy Code
Dim value As GridItemCollection

value = GridItemCollection.Empty

GridItemCollection.Empty = value
C#
public static GridItemCollection Empty
Managed Extensions for C++
public: static GridItemCollection* Empty
C++/CLI
public:
static GridItemCollection^ Empty

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

GridItemCollection Class
GridItemCollection Members


GroupBox Class

[image]
Gizmox.WebGUI.Forms
GroupBox Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : GroupBox Class

Represents a Panel control.

Object Model

Syntax

Visual Basic (Declaration)
<ClientControllerAttribute()>
<ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<MetadataTagAttribute("GB")>
<SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableGroupBox, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")>
<ToolboxBitmapAttribute()>
<DesignTimeControllerAttribute()>
<ToolboxItemCategoryAttribute("Common Controls")>
Public Class GroupBox
   Inherits Control
   Implements IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Visual Basic (Usage) Copy Code
Dim instance As GroupBox
C#
[ClientControllerAttribute()]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[MetadataTagAttribute("GB")]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableGroupBox, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[ToolboxBitmapAttribute()]
[DesignTimeControllerAttribute()]
[ToolboxItemCategoryAttribute("Common Controls")]
public class GroupBox : Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Managed Extensions for C++
[ClientControllerAttribute()]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[MetadataTagAttribute("GB")]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableGroupBox, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[ToolboxBitmapAttribute()]
[DesignTimeControllerAttribute()]
[ToolboxItemCategoryAttribute("Common Controls")]
public __gc class GroupBox : public Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
C++/CLI
[ClientControllerAttribute()]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[MetadataTagAttribute("GB")]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableGroupBox, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[ToolboxBitmapAttribute()]
[DesignTimeControllerAttribute()]
[ToolboxItemCategoryAttribute("Common Controls")]
public ref class GroupBox : public Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.GroupBox

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

GroupBox Members
Gizmox.WebGUI.Forms Namespace


GroupBox Class Members

[image]
Gizmox.WebGUI.Forms
GroupBox Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : GroupBox Class

The following tables list the members exposed by GroupBox.

Public Constructors

 | Name | Description
Public Constructor | GroupBox Constructor | Creates a new Panel instance.
Top

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | FlatStyle |
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Overridden. Gets or sets the text.
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | Overridden.
Protected Property | DefaultSize | Overridden.
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Control)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from Control)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Control)
Protected Method | RenderAttributes | Overridden.
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | Overridden.
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

GroupBox Class
Gizmox.WebGUI.Forms Namespace


GroupBox Constructor

[image]
Gizmox.WebGUI.Forms
GroupBox Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > GroupBox Class : GroupBox Constructor

Creates a new Panel instance.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As GroupBox()
C#
public GroupBox()
Managed Extensions for C++
public: GroupBox();
C++/CLI
public:
GroupBox();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

GroupBox Class
GroupBox Members


GroupBox Class Methods

[image]
Gizmox.WebGUI.Forms
GroupBox Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : GroupBox Class

For a list of all members of this type, see GroupBox members.

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Control)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from Control)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Control)
Protected Method | RenderAttributes | Overridden.
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | Overridden.
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

See Also

Reference

GroupBox Class
Gizmox.WebGUI.Forms Namespace


RenderAttributes Method

[image]
Gizmox.WebGUI.Forms
RenderAttributes Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > GroupBox Class : RenderAttributes Method

objContext
objWriter

Syntax

Visual Basic (Declaration)
Protected Overrides Sub RenderAttributes( _
   ByVal objContext As IContext, _
   ByVal objWriter As IAttributeWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As GroupBox
Dim objContext As IContext
Dim objWriter As IAttributeWriter

instance.RenderAttributes(objContext, objWriter)
C#
protected override void RenderAttributes(
   IContext objContext,
   IAttributeWriter objWriter
)
Managed Extensions for C++
protected: void RenderAttributes(
   IContext* objContext,
   IAttributeWriter* objWriter
) override
C++/CLI
protected:
void RenderAttributes(
   IContext^ objContext,
   IAttributeWriter^ objWriter
) override

Parameters

objContext
objWriter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

GroupBox Class
GroupBox Members


RenderUpdatedAttributes Method

[image]
Gizmox.WebGUI.Forms
RenderUpdatedAttributes Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > GroupBox Class : RenderUpdatedAttributes Method

objContext
Request context.
objWriter
lngRequestID

Syntax

Visual Basic (Declaration)
Protected Overrides Sub RenderUpdatedAttributes( _
   ByVal objContext As IContext, _
   ByVal objWriter As IAttributeWriter, _
   ByVal lngRequestID As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As GroupBox
Dim objContext As IContext
Dim objWriter As IAttributeWriter
Dim lngRequestID As Long

instance.RenderUpdatedAttributes(objContext, objWriter, lngRequestID)
C#
protected override void RenderUpdatedAttributes(
   IContext objContext,
   IAttributeWriter objWriter,
   long lngRequestID
)
Managed Extensions for C++
protected: void RenderUpdatedAttributes(
   IContext* objContext,
   IAttributeWriter* objWriter,
   long lngRequestID
) override
C++/CLI
protected:
void RenderUpdatedAttributes(
   IContext^ objContext,
   IAttributeWriter^ objWriter,
   long long lngRequestID
) override

Parameters

objContext
Request context.
objWriter
lngRequestID

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

GroupBox Class
GroupBox Members


GroupBox Class Properties

[image]
Gizmox.WebGUI.Forms
GroupBox Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : GroupBox Class

For a list of all members of this type, see GroupBox members.

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | FlatStyle |
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Overridden. Gets or sets the text.
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | Overridden.
Protected Property | DefaultSize | Overridden.
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

See Also

Reference

GroupBox Class
Gizmox.WebGUI.Forms Namespace


DefaultPadding Property

[image]
Gizmox.WebGUI.Forms
DefaultPadding Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > GroupBox Class : DefaultPadding Property

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property DefaultPadding As Padding
Visual Basic (Usage) Copy Code
Dim instance As GroupBox
Dim value As Padding

value = instance.DefaultPadding
C#
protected override Padding DefaultPadding {get;}
Managed Extensions for C++
protected: __property Padding get_DefaultPadding() override;
C++/CLI
protected:
property Padding DefaultPadding {
   Padding get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

GroupBox Class
GroupBox Members


DefaultSize Property

[image]
Gizmox.WebGUI.Forms
DefaultSize Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > GroupBox Class : DefaultSize Property

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property DefaultSize As Size
Visual Basic (Usage) Copy Code
Dim instance As GroupBox
Dim value As Size

value = instance.DefaultSize
C#
protected override Size DefaultSize {get;}
Managed Extensions for C++
protected: __property Size get_DefaultSize() override;
C++/CLI
protected:
property Size DefaultSize {
   Size get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

GroupBox Class
GroupBox Members


FlatStyle Property

[image]
Gizmox.WebGUI.Forms
FlatStyle Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > GroupBox Class : FlatStyle Property

Syntax

Visual Basic (Declaration)
Public Property FlatStyle As FlatStyle
Visual Basic (Usage) Copy Code
Dim instance As GroupBox
Dim value As FlatStyle

instance.FlatStyle = value

value = instance.FlatStyle
C#
public FlatStyle FlatStyle {get; set;}
Managed Extensions for C++
public: __property FlatStyle get_FlatStyle();
public: __property void set_FlatStyle(
   FlatStyle value
);
C++/CLI
public:
property FlatStyle FlatStyle {
   FlatStyle get();
   void set (FlatStylevalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

GroupBox Class
GroupBox Members


Text Property

[image]
Gizmox.WebGUI.Forms
Text Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > GroupBox Class : Text Property

Gets or sets the text.

Syntax

Visual Basic (Declaration)
Public Overrides Property Text As String
Visual Basic (Usage) Copy Code
Dim instance As GroupBox
Dim value As String

instance.Text = value

value = instance.Text
C#
public override string Text {get; set;}
Managed Extensions for C++
public: __property string* get_Text() override;
public: __property void set_Text(
   string* value
) override;
C++/CLI
public:
property String^ Text {
   String^ get() override;
   void set (String^value) override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

GroupBox Class
GroupBox Members


HandledMouseEventArgs Class

[image]
Gizmox.WebGUI.Forms
HandledMouseEventArgs Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : HandledMouseEventArgs Class

Allows a custom control to prevent the MouseWheel event from being sent to its parent container.

Syntax

Visual Basic (Declaration)
Public Class HandledMouseEventArgs
   Inherits MouseEventArgs
Visual Basic (Usage) Copy Code
Dim instance As HandledMouseEventArgs
C#
public class HandledMouseEventArgs : MouseEventArgs
Managed Extensions for C++
public __gc class HandledMouseEventArgs : public MouseEventArgs
C++/CLI
public ref class HandledMouseEventArgs : public MouseEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gizmox.WebGUI.Forms.MouseEventArgs
Gizmox.WebGUI.Forms.HandledMouseEventArgs
Gizmox.WebGUI.Forms.DataGridViewColumnDividerDoubleClickEventArgs
Gizmox.WebGUI.Forms.DataGridViewRowDividerDoubleClickEventArgs

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

HandledMouseEventArgs Members
Gizmox.WebGUI.Forms Namespace


HandledMouseEventArgs Class Members

[image]
Gizmox.WebGUI.Forms
HandledMouseEventArgs Class Members
See Also Properties Send Feedback
Gizmox.WebGUI.Forms Namespace : HandledMouseEventArgs Class

The following tables list the members exposed by HandledMouseEventArgs.

Public Constructors

 | Name | Description
Public Constructor | HandledMouseEventArgs Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Button | (Inherited from MouseEventArgs)
Public Property | Clicks | (Inherited from MouseEventArgs)
Public Property | Delta | (Inherited from MouseEventArgs)
Public Property | Handled | Gets or sets whether this event should be forwarded to the control's parent container.
Public Property | X | (Inherited from MouseEventArgs)
Public Property | Y | (Inherited from MouseEventArgs)
Top

See Also

Reference

HandledMouseEventArgs Class
Gizmox.WebGUI.Forms Namespace


HandledMouseEventArgs Constructor

[image]
Gizmox.WebGUI.Forms
HandledMouseEventArgs Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > HandledMouseEventArgs Class : HandledMouseEventArgs Constructor

Overload List

Overload | Description
HandledMouseEventArgs Constructor(MouseButtons,Int32,Int32,Int32,Int32) |
HandledMouseEventArgs Constructor(MouseButtons,Int32,Int32,Int32,Int32,Boolean) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HandledMouseEventArgs Class
HandledMouseEventArgs Members


HandledMouseEventArgs Constructor(MouseButtons,Int32,Int32,Int32,Int32)

[image]
Gizmox.WebGUI.Forms
HandledMouseEventArgs Constructor(MouseButtons,Int32,Int32,Int32,Int32)
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > HandledMouseEventArgs Class > HandledMouseEventArgs Constructor : HandledMouseEventArgs Constructor(MouseButtons,Int32,Int32,Int32,Int32)

button
clicks
x
y
delta

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal button As MouseButtons, _
   ByVal clicks As Integer, _
   ByVal x As Integer, _
   ByVal y As Integer, _
   ByVal delta As Integer _
)
Visual Basic (Usage) Copy Code
Dim button As MouseButtons
Dim clicks As Integer
Dim x As Integer
Dim y As Integer
Dim delta As Integer

Dim instance As HandledMouseEventArgs(button, clicks, x, y, delta)
C#
public HandledMouseEventArgs(
   MouseButtons button,
   int clicks,
   int x,
   int y,
   int delta
)
Managed Extensions for C++
public: HandledMouseEventArgs(
   MouseButtons button,
   int clicks,
   int x,
   int y,
   int delta
)
C++/CLI
public:
HandledMouseEventArgs(
   MouseButtons button,
   int clicks,
   int x,
   int y,
   int delta
)

Parameters

button
clicks
x
y
delta

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HandledMouseEventArgs Class
HandledMouseEventArgs Members
Overload List


HandledMouseEventArgs Constructor(MouseButtons,Int32,Int32,Int32,Int32,Boolean)

[image]
Gizmox.WebGUI.Forms
HandledMouseEventArgs Constructor(MouseButtons,Int32,Int32,Int32,Int32,Boolean)
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > HandledMouseEventArgs Class > HandledMouseEventArgs Constructor : HandledMouseEventArgs Constructor(MouseButtons,Int32,Int32,Int32,Int32,Boolean)

button
clicks
x
y
delta
defaultHandledValue

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal button As MouseButtons, _
   ByVal clicks As Integer, _
   ByVal x As Integer, _
   ByVal y As Integer, _
   ByVal delta As Integer, _
   ByVal defaultHandledValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim button As MouseButtons
Dim clicks As Integer
Dim x As Integer
Dim y As Integer
Dim delta As Integer
Dim defaultHandledValue As Boolean

Dim instance As HandledMouseEventArgs(button, clicks, x, y, delta, defaultHandledValue)
C#
public HandledMouseEventArgs(
   MouseButtons button,
   int clicks,
   int x,
   int y,
   int delta,
   bool defaultHandledValue
)
Managed Extensions for C++
public: HandledMouseEventArgs(
   MouseButtons button,
   int clicks,
   int x,
   int y,
   int delta,
   bool defaultHandledValue
)
C++/CLI
public:
HandledMouseEventArgs(
   MouseButtons button,
   int clicks,
   int x,
   int y,
   int delta,
   bool defaultHandledValue
)

Parameters

button
clicks
x
y
delta
defaultHandledValue

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HandledMouseEventArgs Class
HandledMouseEventArgs Members
Overload List


HandledMouseEventArgs Class Properties

[image]
Gizmox.WebGUI.Forms
HandledMouseEventArgs Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : HandledMouseEventArgs Class

For a list of all members of this type, see HandledMouseEventArgs members.

Public Properties

 | Name | Description
Public Property | Button | (Inherited from MouseEventArgs)
Public Property | Clicks | (Inherited from MouseEventArgs)
Public Property | Delta | (Inherited from MouseEventArgs)
Public Property | Handled | Gets or sets whether this event should be forwarded to the control's parent container.
Public Property | X | (Inherited from MouseEventArgs)
Public Property | Y | (Inherited from MouseEventArgs)
Top

See Also

Reference

HandledMouseEventArgs Class
Gizmox.WebGUI.Forms Namespace


Handled Property

[image]
Gizmox.WebGUI.Forms
Handled Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > HandledMouseEventArgs Class : Handled Property

Gets or sets whether this event should be forwarded to the control's parent container.

Syntax

Visual Basic (Declaration)
Public Property Handled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As HandledMouseEventArgs
Dim value As Boolean

instance.Handled = value

value = instance.Handled
C#
public bool Handled {get; set;}
Managed Extensions for C++
public: __property bool get_Handled();
public: __property void set_Handled(
   bool value
);
C++/CLI
public:
property bool Handled {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HandledMouseEventArgs Class
HandledMouseEventArgs Members


Help Class

[image]
Gizmox.WebGUI.Forms
Help Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : Help Class

Encapsulates the HTML Help 1.0 engine.

Syntax

Visual Basic (Declaration)
Public Class Help
Visual Basic (Usage) Copy Code
Dim instance As Help
C#
public class Help
Managed Extensions for C++
public __gc class Help
C++/CLI
public ref class Help

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.Help

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Help Members
Gizmox.WebGUI.Forms Namespace


Help Class Members

[image]
Gizmox.WebGUI.Forms
Help Class Members
See Also Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : Help Class

The following tables list the members exposed by Help.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | ShowHelp | Overloaded. Displays the contents of the Help file at the specified URL.
static (Shared in Visual Basic) | ShowHelpIndex | Displays the index of the specified Help file.
static (Shared in Visual Basic) | ShowPopup | Displays a Help pop-up window.
Top

See Also

Reference

Help Class
Gizmox.WebGUI.Forms Namespace


Help Class Methods

[image]
Gizmox.WebGUI.Forms
Help Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : Help Class

For a list of all members of this type, see Help members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | ShowHelp | Overloaded. Displays the contents of the Help file at the specified URL.
static (Shared in Visual Basic) | ShowHelpIndex | Displays the index of the specified Help file.
static (Shared in Visual Basic) | ShowPopup | Displays a Help pop-up window.
Top

See Also

Reference

Help Class
Gizmox.WebGUI.Forms Namespace


ShowHelp Method

[image]
Gizmox.WebGUI.Forms
ShowHelp Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Help Class : ShowHelp Method

Displays the contents of the Help file at the specified URL.

Overload List

Overload | Description
ShowHelp(Control,String) | Displays the contents of the Help file at the specified URL.
ShowHelp(Control,String,String) | Displays the contents of the Help file found at the specified URL for a specific keyword.
ShowHelp(Control,String,HelpNavigator) | Displays the contents of the Help file found at the specified URL for a specific topic.
ShowHelp(Control,String,HelpNavigator,Object) | Displays the contents of the Help file located at the URL supplied by the user.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Help Class
Help Members


ShowHelp(Control,String) Method

[image]
Gizmox.WebGUI.Forms
ShowHelp(Control,String) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Help Class > ShowHelp Method : ShowHelp(Control,String) Method

parent
A Control that identifies the parent of the Help dialog box.
url
The path and name of the Help file.
Displays the contents of the Help file at the specified URL.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Sub ShowHelp( _
   ByVal parent As Control, _
   ByVal url As String _
)
Visual Basic (Usage) Copy Code
Dim parent As Control
Dim url As String

Help.ShowHelp(parent, url)
C#
public static void ShowHelp(
   Control parent,
   string url
)
Managed Extensions for C++
public: static void ShowHelp(
   Control* parent,
   string* url
)
C++/CLI
public:
static void ShowHelp(
   Control^ parent,
   String^ url
)

Parameters

parent
A Control that identifies the parent of the Help dialog box.
url
The path and name of the Help file.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Help Class
Help Members
Overload List


ShowHelp(Control,String,String) Method

[image]
Gizmox.WebGUI.Forms
ShowHelp(Control,String,String) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Help Class > ShowHelp Method : ShowHelp(Control,String,String) Method

parent
A Control that identifies the parent of the Help dialog box.
url
The path and name of the Help file.
keyword
The keyword to display Help for.
Displays the contents of the Help file found at the specified URL for a specific keyword.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Sub ShowHelp( _
   ByVal parent As Control, _
   ByVal url As String, _
   ByVal keyword As String _
)
Visual Basic (Usage) Copy Code
Dim parent As Control
Dim url As String
Dim keyword As String

Help.ShowHelp(parent, url, keyword)
C#
public static void ShowHelp(
   Control parent,
   string url,
   string keyword
)
Managed Extensions for C++
public: static void ShowHelp(
   Control* parent,
   string* url,
   string* keyword
)
C++/CLI
public:
static void ShowHelp(
   Control^ parent,
   String^ url,
   String^ keyword
)

Parameters

parent
A Control that identifies the parent of the Help dialog box.
url
The path and name of the Help file.
keyword
The keyword to display Help for.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Help Class
Help Members
Overload List


ShowHelp(Control,String,HelpNavigator) Method

[image]
Gizmox.WebGUI.Forms
ShowHelp(Control,String,HelpNavigator) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Help Class > ShowHelp Method : ShowHelp(Control,String,HelpNavigator) Method

parent
A Control that identifies the parent of the Help dialog box.
url
The path and name of the Help file.
navigator
One of the HelpNavigator values.
Displays the contents of the Help file found at the specified URL for a specific topic.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Sub ShowHelp( _
   ByVal parent As Control, _
   ByVal url As String, _
   ByVal navigator As HelpNavigator _
)
Visual Basic (Usage) Copy Code
Dim parent As Control
Dim url As String
Dim navigator As HelpNavigator

Help.ShowHelp(parent, url, navigator)
C#
public static void ShowHelp(
   Control parent,
   string url,
   HelpNavigator navigator
)
Managed Extensions for C++
public: static void ShowHelp(
   Control* parent,
   string* url,
   HelpNavigator navigator
)
C++/CLI
public:
static void ShowHelp(
   Control^ parent,
   String^ url,
   HelpNavigator navigator
)

Parameters

parent
A Control that identifies the parent of the Help dialog box.
url
The path and name of the Help file.
navigator
One of the HelpNavigator values.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Help Class
Help Members
Overload List


ShowHelp(Control,String,HelpNavigator,Object) Method

[image]
Gizmox.WebGUI.Forms
ShowHelp(Control,String,HelpNavigator,Object) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Help Class > ShowHelp Method : ShowHelp(Control,String,HelpNavigator,Object) Method

parent
A Control that identifies the parent of the Help dialog box.
url
The path and name of the Help file.
command
One of the HelpNavigator values.
parameter
Displays the contents of the Help file located at the URL supplied by the user.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Sub ShowHelp( _
   ByVal parent As Control, _
   ByVal url As String, _
   ByVal command As HelpNavigator, _
   ByVal parameter As Object _
)
Visual Basic (Usage) Copy Code
Dim parent As Control
Dim url As String
Dim command As HelpNavigator
Dim parameter As Object

Help.ShowHelp(parent, url, command, parameter)
C#
public static void ShowHelp(
   Control parent,
   string url,
   HelpNavigator command,
   object parameter
)
Managed Extensions for C++
public: static void ShowHelp(
   Control* parent,
   string* url,
   HelpNavigator command,
   Object* parameter
)
C++/CLI
public:
static void ShowHelp(
   Control^ parent,
   String^ url,
   HelpNavigator command,
   Object^ parameter
)

Parameters

parent
A Control that identifies the parent of the Help dialog box.
url
The path and name of the Help file.
command
One of the HelpNavigator values.
parameter

Exceptions

Exception | Description
ArgumentException | param is an integer.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Help Class
Help Members
Overload List


ShowHelpIndex Method

[image]
Gizmox.WebGUI.Forms
ShowHelpIndex Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Help Class : ShowHelpIndex Method

parent
A Control that identifies the parent of the Help dialog box.
url
The path and name of the Help file.
Displays the index of the specified Help file.

Syntax

Visual Basic (Declaration)
Public Shared Sub ShowHelpIndex( _
   ByVal parent As Control, _
   ByVal url As String _
)
Visual Basic (Usage) Copy Code
Dim parent As Control
Dim url As String

Help.ShowHelpIndex(parent, url)
C#
public static void ShowHelpIndex(
   Control parent,
   string url
)
Managed Extensions for C++
public: static void ShowHelpIndex(
   Control* parent,
   string* url
)
C++/CLI
public:
static void ShowHelpIndex(
   Control^ parent,
   String^ url
)

Parameters

parent
A Control that identifies the parent of the Help dialog box.
url
The path and name of the Help file.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Help Class
Help Members


ShowPopup Method

[image]
Gizmox.WebGUI.Forms
ShowPopup Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Help Class : ShowPopup Method

parent
A Control that identifies the parent of the Help dialog box.
caption
The message to display in the pop-up window.
location
A value specifying the horizontal and vertical coordinates at which to display the pop-up window.
Displays a Help pop-up window.

Syntax

Visual Basic (Declaration)
Public Shared Sub ShowPopup( _
   ByVal parent As Control, _
   ByVal caption As String, _
   ByVal location As Point _
)
Visual Basic (Usage) Copy Code
Dim parent As Control
Dim caption As String
Dim location As Point

Help.ShowPopup(parent, caption, location)
C#
public static void ShowPopup(
   Control parent,
   string caption,
   Point location
)
Managed Extensions for C++
public: static void ShowPopup(
   Control* parent,
   string* caption,
   Point location
)
C++/CLI
public:
static void ShowPopup(
   Control^ parent,
   String^ caption,
   Point location
)

Parameters

parent
A Control that identifies the parent of the Help dialog box.
caption
The message to display in the pop-up window.
location
A value specifying the horizontal and vertical coordinates at which to display the pop-up window.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Help Class
Help Members


HelpEventArgs Class

[image]
Gizmox.WebGUI.Forms
HelpEventArgs Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : HelpEventArgs Class

Provides data for the HelpRequested event.

Syntax

Visual Basic (Declaration)
Public Class HelpEventArgs
   Inherits EventArgs
Visual Basic (Usage) Copy Code
Dim instance As HelpEventArgs
C#
public class HelpEventArgs : EventArgs
Managed Extensions for C++
public __gc class HelpEventArgs : public EventArgs
C++/CLI
public ref class HelpEventArgs : public EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gizmox.WebGUI.Forms.HelpEventArgs

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

HelpEventArgs Members
Gizmox.WebGUI.Forms Namespace


HelpEventArgs Class Members

[image]
Gizmox.WebGUI.Forms
HelpEventArgs Class Members
See Also Properties Send Feedback
Gizmox.WebGUI.Forms Namespace : HelpEventArgs Class

The following tables list the members exposed by HelpEventArgs.

Public Constructors

 | Name | Description
Public Constructor | HelpEventArgs Constructor | Initializes a new instance of the HelpEventArgs class.
Top

Public Properties

 | Name | Description
Public Property | Handled | Gets or sets a value indicating whether the help event was handled.
Public Property | MousePos | Gets the screen coordinates of the mouse pointer.
Top

See Also

Reference

HelpEventArgs Class
Gizmox.WebGUI.Forms Namespace


HelpEventArgs Constructor

[image]
Gizmox.WebGUI.Forms
HelpEventArgs Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > HelpEventArgs Class : HelpEventArgs Constructor

mousePos
The coordinates of the mouse pointer.
Initializes a new instance of the HelpEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal mousePos As Point _
)
Visual Basic (Usage) Copy Code
Dim mousePos As Point

Dim instance As HelpEventArgs(mousePos)
C#
public HelpEventArgs(
   Point mousePos
)
Managed Extensions for C++
public: HelpEventArgs(
   Point mousePos
)
C++/CLI
public:
HelpEventArgs(
   Point mousePos
)

Parameters

mousePos
The coordinates of the mouse pointer.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HelpEventArgs Class
HelpEventArgs Members


HelpEventArgs Class Properties

[image]
Gizmox.WebGUI.Forms
HelpEventArgs Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : HelpEventArgs Class

For a list of all members of this type, see HelpEventArgs members.

Public Properties

 | Name | Description
Public Property | Handled | Gets or sets a value indicating whether the help event was handled.
Public Property | MousePos | Gets the screen coordinates of the mouse pointer.
Top

See Also

Reference

HelpEventArgs Class
Gizmox.WebGUI.Forms Namespace


Handled Property

[image]
Gizmox.WebGUI.Forms
Handled Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > HelpEventArgs Class : Handled Property

Gets or sets a value indicating whether the help event was handled.

Syntax

Visual Basic (Declaration)
Public Property Handled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As HelpEventArgs
Dim value As Boolean

instance.Handled = value

value = instance.Handled
C#
public bool Handled {get; set;}
Managed Extensions for C++
public: __property bool get_Handled();
public: __property void set_Handled(
   bool value
);
C++/CLI
public:
property bool Handled {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HelpEventArgs Class
HelpEventArgs Members


MousePos Property

[image]
Gizmox.WebGUI.Forms
MousePos Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > HelpEventArgs Class : MousePos Property

Gets the screen coordinates of the mouse pointer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MousePos As Point
Visual Basic (Usage) Copy Code
Dim instance As HelpEventArgs
Dim value As Point

value = instance.MousePos
C#
public Point MousePos {get;}
Managed Extensions for C++
public: __property Point get_MousePos();
C++/CLI
public:
property Point MousePos {
   Point get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HelpEventArgs Class
HelpEventArgs Members


HelpProvider Class

[image]
Gizmox.WebGUI.Forms
HelpProvider Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : HelpProvider Class

Provides pop-up or online Help for controls.

Syntax

Visual Basic (Declaration)
<ToolboxItemFilterAttribute("Gizmox.WebGUI.Forms")>
<ProvidePropertyAttribute(PropertyName="HelpString", ReceiverTypeName="Gizmox.WebGUI.Forms.Control, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d")>
<SRDescriptionAttribute("Provides pop-up or online Help for controls.")>
<ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<ToolboxItemCategoryAttribute("Components")>
<ToolboxBitmapAttribute()>
Public Class HelpProvider
   Inherits ComponentBase
Visual Basic (Usage) Copy Code
Dim instance As HelpProvider
C#
[ToolboxItemFilterAttribute("Gizmox.WebGUI.Forms")]
[ProvidePropertyAttribute(PropertyName="HelpString", ReceiverTypeName="Gizmox.WebGUI.Forms.Control, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d")]
[SRDescriptionAttribute("Provides pop-up or online Help for controls.")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ToolboxItemCategoryAttribute("Components")]
[ToolboxBitmapAttribute()]
public class HelpProvider : ComponentBase
Managed Extensions for C++
[ToolboxItemFilterAttribute("Gizmox.WebGUI.Forms")]
[ProvidePropertyAttribute(PropertyName="HelpString", ReceiverTypeName="Gizmox.WebGUI.Forms.Control, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d")]
[SRDescriptionAttribute("Provides pop-up or online Help for controls.")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ToolboxItemCategoryAttribute("Components")]
[ToolboxBitmapAttribute()]
public __gc class HelpProvider : public ComponentBase
C++/CLI
[ToolboxItemFilterAttribute("Gizmox.WebGUI.Forms")]
[ProvidePropertyAttribute(PropertyName="HelpString", ReceiverTypeName="Gizmox.WebGUI.Forms.Control, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d")]
[SRDescriptionAttribute("Provides pop-up or online Help for controls.")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ToolboxItemCategoryAttribute("Components")]
[ToolboxBitmapAttribute()]
public ref class HelpProvider : public ComponentBase

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.HelpProvider

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

HelpProvider Members
Gizmox.WebGUI.Forms Namespace


HelpProvider Class Members

[image]
Gizmox.WebGUI.Forms
HelpProvider Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : HelpProvider Class

The following tables list the members exposed by HelpProvider.

Public Constructors

 | Name | Description
Public Constructor | HelpProvider Constructor |
Top

Public Properties

 | Name | Description
Public Property | Container | (Inherited from ComponentBase)
Public Property | HelpNamespace | Gets or sets a value specifying the name of the Help file associated with this HelpProvider object.
Public Property | Site | (Inherited from ComponentBase)
Public Property | Tag | Gets or sets the object that contains supplemental data about the HelpProvider.
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Top

Public Methods

 | Name | Description
Public Method | CanExtend | Specifies whether this object can provide its extender properties to the specified object.
Public Method | Dispose | Overloaded. (Inherited from ComponentBase)
Public Method | GetHelpKeyword | Returns the Help keyword for the specified control.
Public Method | GetHelpNavigator | Returns the current HelpNavigator setting for the specified control.
Public Method | GetHelpString | Returns the contents of the pop-up Help window for the specified control.
Public Method | GetShowHelp | Returns a value indicating whether the specified control's Help should be displayed.
Public Method | ResetShowHelp | Removes the Help associated with the specified control.
Public Method | SetHelpKeyword | Specifies the keyword used to retrieve Help when the user invokes Help for the specified control.
Public Method | SetHelpNavigator | Specifies the Help command to use when retrieving Help from the Help file for the specified control.
Public Method | SetHelpString | Specifies the Help string associated with the specified control.
Public Method | SetShowHelp | Specifies whether Help is displayed for the specified control.
Public Method | ToString | Overridden. Returns a string that represents the current HelpProvider.
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | GetService | (Inherited from ComponentBase)
Top

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from ComponentBase)
Top

See Also

Reference

HelpProvider Class
Gizmox.WebGUI.Forms Namespace


HelpProvider Constructor

[image]
Gizmox.WebGUI.Forms
HelpProvider Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > HelpProvider Class : HelpProvider Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As HelpProvider()
C#
public HelpProvider()
Managed Extensions for C++
public: HelpProvider();
C++/CLI
public:
HelpProvider();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HelpProvider Class
HelpProvider Members


HelpProvider Class Methods

[image]
Gizmox.WebGUI.Forms
HelpProvider Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : HelpProvider Class

For a list of all members of this type, see HelpProvider members.

Public Methods

 | Name | Description
Public Method | CanExtend | Specifies whether this object can provide its extender properties to the specified object.
Public Method | Dispose | Overloaded. (Inherited from ComponentBase)
Public Method | GetHelpKeyword | Returns the Help keyword for the specified control.
Public Method | GetHelpNavigator | Returns the current HelpNavigator setting for the specified control.
Public Method | GetHelpString | Returns the contents of the pop-up Help window for the specified control.
Public Method | GetShowHelp | Returns a value indicating whether the specified control's Help should be displayed.
Public Method | ResetShowHelp | Removes the Help associated with the specified control.
Public Method | SetHelpKeyword | Specifies the keyword used to retrieve Help when the user invokes Help for the specified control.
Public Method | SetHelpNavigator | Specifies the Help command to use when retrieving Help from the Help file for the specified control.
Public Method | SetHelpString | Specifies the Help string associated with the specified control.
Public Method | SetShowHelp | Specifies whether Help is displayed for the specified control.
Public Method | ToString | Overridden. Returns a string that represents the current HelpProvider.
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | GetService | (Inherited from ComponentBase)
Top

See Also

Reference

HelpProvider Class
Gizmox.WebGUI.Forms Namespace


CanExtend Method

[image]
Gizmox.WebGUI.Forms
CanExtend Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > HelpProvider Class : CanExtend Method

target
The object
Specifies whether this object can provide its extender properties to the specified object.

Syntax

Visual Basic (Declaration)
Public Overridable Function CanExtend( _
   ByVal target As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As HelpProvider
Dim target As Object
Dim value As Boolean

value = instance.CanExtend(target)
C#
public virtual bool CanExtend(
   object target
)
Managed Extensions for C++
public: virtual bool CanExtend(
   Object* target
)
C++/CLI
public:
virtual bool CanExtend(
   Object^ target
)

Parameters

target
The object

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HelpProvider Class
HelpProvider Members


GetHelpKeyword Method

[image]
Gizmox.WebGUI.Forms
GetHelpKeyword Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > HelpProvider Class : GetHelpKeyword Method

ctl
A Control from which to retrieve the Help topic.
Returns the Help keyword for the specified control.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<SRDescriptionAttribute("Determines the Help keyword associated with this control.")>
<LocalizableAttribute(True)>
Public Overridable Function GetHelpKeyword( _
   ByVal ctl As Control _
) As String
Visual Basic (Usage) Copy Code
Dim instance As HelpProvider
Dim ctl As Control
Dim value As String

value = instance.GetHelpKeyword(ctl)
C#
[DefaultValueAttribute()]
[SRDescriptionAttribute("Determines the Help keyword associated with this control.")]
[LocalizableAttribute(true)]
public virtual string GetHelpKeyword(
   Control ctl
)
Managed Extensions for C++
[DefaultValueAttribute()]
[SRDescriptionAttribute("Determines the Help keyword associated with this control.")]
[LocalizableAttribute(true)]
public: virtual string* GetHelpKeyword(
   Control* ctl
)
C++/CLI
[DefaultValueAttribute()]
[SRDescriptionAttribute("Determines the Help keyword associated with this control.")]
[LocalizableAttribute(true)]
public:
virtual String^ GetHelpKeyword(
   Control^ ctl
)

Parameters

ctl
A Control from which to retrieve the Help topic.

Return Value

The Help keyword associated with this control, or null if the HelpProvider is currently configured to display the entire Help file or is configured to provide a Help string.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HelpProvider Class
HelpProvider Members


GetHelpNavigator Method

[image]
Gizmox.WebGUI.Forms
GetHelpNavigator Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > HelpProvider Class : GetHelpNavigator Method

ctl
A Control from which to retrieve the Help navigator.
Returns the current HelpNavigator setting for the specified control.

Syntax

Visual Basic (Declaration)
<LocalizableAttribute(True)>
<SRDescriptionAttribute("Determines the kind of Help associated with this control.")>
<DefaultValueAttribute()>
Public Overridable Function GetHelpNavigator( _
   ByVal ctl As Control _
) As HelpNavigator
Visual Basic (Usage) Copy Code
Dim instance As HelpProvider
Dim ctl As Control
Dim value As HelpNavigator

value = instance.GetHelpNavigator(ctl)
C#
[LocalizableAttribute(true)]
[SRDescriptionAttribute("Determines the kind of Help associated with this control.")]
[DefaultValueAttribute()]
public virtual HelpNavigator GetHelpNavigator(
   Control ctl
)
Managed Extensions for C++
[LocalizableAttribute(true)]
[SRDescriptionAttribute("Determines the kind of Help associated with this control.")]
[DefaultValueAttribute()]
public: virtual HelpNavigator GetHelpNavigator(
   Control* ctl
)
C++/CLI
[LocalizableAttribute(true)]
[SRDescriptionAttribute("Determines the kind of Help associated with this control.")]
[DefaultValueAttribute()]
public:
virtual HelpNavigator GetHelpNavigator(
   Control^ ctl
)

Parameters

ctl
A Control from which to retrieve the Help navigator.

Return Value

The HelpNavigator setting for the specified control. The default is AssociateIndex.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HelpProvider Class
HelpProvider Members


GetHelpString Method

[image]
Gizmox.WebGUI.Forms
GetHelpString Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > HelpProvider Class : GetHelpString Method

ctl
A Control from which to retrieve the Help string.
Returns the contents of the pop-up Help window for the specified control.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Determines the Help string associated with this control.")>
<DefaultValueAttribute()>
<LocalizableAttribute(True)>
Public Overridable Function GetHelpString( _
   ByVal ctl As Control _
) As String
Visual Basic (Usage) Copy Code
Dim instance As HelpProvider
Dim ctl As Control
Dim value As String

value = instance.GetHelpString(ctl)
C#
[SRDescriptionAttribute("Determines the Help string associated with this control.")]
[DefaultValueAttribute()]
[LocalizableAttribute(true)]
public virtual string GetHelpString(
   Control ctl
)
Managed Extensions for C++
[SRDescriptionAttribute("Determines the Help string associated with this control.")]
[DefaultValueAttribute()]
[LocalizableAttribute(true)]
public: virtual string* GetHelpString(
   Control* ctl
)
C++/CLI
[SRDescriptionAttribute("Determines the Help string associated with this control.")]
[DefaultValueAttribute()]
[LocalizableAttribute(true)]
public:
virtual String^ GetHelpString(
   Control^ ctl
)

Parameters

ctl
A Control from which to retrieve the Help string.

Return Value

The Help string associated with this control. The default is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HelpProvider Class
HelpProvider Members


GetShowHelp Method

[image]
Gizmox.WebGUI.Forms
GetShowHelp Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > HelpProvider Class : GetShowHelp Method

ctl
A Control for which Help will be displayed.
Returns a value indicating whether the specified control's Help should be displayed.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Determines if Help should be displayed for this control.")>
<LocalizableAttribute(True)>
Public Overridable Function GetShowHelp( _
   ByVal ctl As Control _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As HelpProvider
Dim ctl As Control
Dim value As Boolean

value = instance.GetShowHelp(ctl)
C#
[SRDescriptionAttribute("Determines if Help should be displayed for this control.")]
[LocalizableAttribute(true)]
public virtual bool GetShowHelp(
   Control ctl
)
Managed Extensions for C++
[SRDescriptionAttribute("Determines if Help should be displayed for this control.")]
[LocalizableAttribute(true)]
public: virtual bool GetShowHelp(
   Control* ctl
)
C++/CLI
[SRDescriptionAttribute("Determines if Help should be displayed for this control.")]
[LocalizableAttribute(true)]
public:
virtual bool GetShowHelp(
   Control^ ctl
)

Parameters

ctl
A Control for which Help will be displayed.

Return Value

true if Help will be displayed for the control; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HelpProvider Class
HelpProvider Members


ResetShowHelp Method

[image]
Gizmox.WebGUI.Forms
ResetShowHelp Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > HelpProvider Class : ResetShowHelp Method

ctl
The control to remove Help from.
Removes the Help associated with the specified control.

Syntax

Visual Basic (Declaration)
Public Overridable Sub ResetShowHelp( _
   ByVal ctl As Control _
)
Visual Basic (Usage) Copy Code
Dim instance As HelpProvider
Dim ctl As Control

instance.ResetShowHelp(ctl)
C#
public virtual void ResetShowHelp(
   Control ctl
)
Managed Extensions for C++
public: virtual void ResetShowHelp(
   Control* ctl
)
C++/CLI
public:
virtual void ResetShowHelp(
   Control^ ctl
)

Parameters

ctl
The control to remove Help from.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HelpProvider Class
HelpProvider Members


SetHelpKeyword Method

[image]
Gizmox.WebGUI.Forms
SetHelpKeyword Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > HelpProvider Class : SetHelpKeyword Method

ctl
A Control that specifies the control for which to set the Help topic.
keyword
The Help keyword to associate with the control.
Specifies the keyword used to retrieve Help when the user invokes Help for the specified control.

Syntax

Visual Basic (Declaration)
Public Overridable Sub SetHelpKeyword( _
   ByVal ctl As Control, _
   ByVal keyword As String _
)
Visual Basic (Usage) Copy Code
Dim instance As HelpProvider
Dim ctl As Control
Dim keyword As String

instance.SetHelpKeyword(ctl, keyword)
C#
public virtual void SetHelpKeyword(
   Control ctl,
   string keyword
)
Managed Extensions for C++
public: virtual void SetHelpKeyword(
   Control* ctl,
   string* keyword
)
C++/CLI
public:
virtual void SetHelpKeyword(
   Control^ ctl,
   String^ keyword
)

Parameters

ctl
A Control that specifies the control for which to set the Help topic.
keyword
The Help keyword to associate with the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HelpProvider Class
HelpProvider Members


SetHelpNavigator Method

[image]
Gizmox.WebGUI.Forms
SetHelpNavigator Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > HelpProvider Class : SetHelpNavigator Method

ctl
A Control for which to set the Help keyword.
navigator
One of the HelpNavigator values.
Specifies the Help command to use when retrieving Help from the Help file for the specified control.

Syntax

Visual Basic (Declaration)
Public Overridable Sub SetHelpNavigator( _
   ByVal ctl As Control, _
   ByVal navigator As HelpNavigator _
)
Visual Basic (Usage) Copy Code
Dim instance As HelpProvider
Dim ctl As Control
Dim navigator As HelpNavigator

instance.SetHelpNavigator(ctl, navigator)
C#
public virtual void SetHelpNavigator(
   Control ctl,
   HelpNavigator navigator
)
Managed Extensions for C++
public: virtual void SetHelpNavigator(
   Control* ctl,
   HelpNavigator navigator
)
C++/CLI
public:
virtual void SetHelpNavigator(
   Control^ ctl,
   HelpNavigator navigator
)

Parameters

ctl
A Control for which to set the Help keyword.
navigator
One of the HelpNavigator values.

Exceptions

Exception | Description
InvalidEnumArgumentException | The value of navigator is not one of the HelpNavigator values.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HelpProvider Class
HelpProvider Members


SetHelpString Method

[image]
Gizmox.WebGUI.Forms
SetHelpString Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > HelpProvider Class : SetHelpString Method

ctl
A Control with which to associate the Help string.
helpString
The Help string associated with the control.
Specifies the Help string associated with the specified control.

Syntax

Visual Basic (Declaration)
Public Overridable Sub SetHelpString( _
   ByVal ctl As Control, _
   ByVal helpString As String _
)
Visual Basic (Usage) Copy Code
Dim instance As HelpProvider
Dim ctl As Control
Dim helpString As String

instance.SetHelpString(ctl, helpString)
C#
public virtual void SetHelpString(
   Control ctl,
   string helpString
)
Managed Extensions for C++
public: virtual void SetHelpString(
   Control* ctl,
   string* helpString
)
C++/CLI
public:
virtual void SetHelpString(
   Control^ ctl,
   String^ helpString
)

Parameters

ctl
A Control with which to associate the Help string.
helpString
The Help string associated with the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HelpProvider Class
HelpProvider Members


SetShowHelp Method

[image]
Gizmox.WebGUI.Forms
SetShowHelp Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > HelpProvider Class : SetShowHelp Method

ctl
A Control for which Help is turned on or off.
value
true if Help displays for the control; otherwise, false.
Specifies whether Help is displayed for the specified control.

Syntax

Visual Basic (Declaration)
Public Overridable Sub SetShowHelp( _
   ByVal ctl As Control, _
   ByVal value As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As HelpProvider
Dim ctl As Control
Dim value As Boolean

instance.SetShowHelp(ctl, value)
C#
public virtual void SetShowHelp(
   Control ctl,
   bool value
)
Managed Extensions for C++
public: virtual void SetShowHelp(
   Control* ctl,
   bool value
)
C++/CLI
public:
virtual void SetShowHelp(
   Control^ ctl,
   bool value
)

Parameters

ctl
A Control for which Help is turned on or off.
value
true if Help displays for the control; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HelpProvider Class
HelpProvider Members


ToString Method

[image]
Gizmox.WebGUI.Forms
ToString Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > HelpProvider Class : ToString Method

Returns a string that represents the current HelpProvider.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As HelpProvider
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Return Value

A string that represents the current HelpProvider.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HelpProvider Class
HelpProvider Members


HelpProvider Class Properties

[image]
Gizmox.WebGUI.Forms
HelpProvider Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : HelpProvider Class

For a list of all members of this type, see HelpProvider members.

Public Properties

 | Name | Description
Public Property | Container | (Inherited from ComponentBase)
Public Property | HelpNamespace | Gets or sets a value specifying the name of the Help file associated with this HelpProvider object.
Public Property | Site | (Inherited from ComponentBase)
Public Property | Tag | Gets or sets the object that contains supplemental data about the HelpProvider.
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Top

See Also

Reference

HelpProvider Class
Gizmox.WebGUI.Forms Namespace


HelpNamespace Property

[image]
Gizmox.WebGUI.Forms
HelpNamespace Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > HelpProvider Class : HelpNamespace Property

Gets or sets a value specifying the name of the Help file associated with this HelpProvider object.

Syntax

Visual Basic (Declaration)
Public Overridable Property HelpNamespace As String
Visual Basic (Usage) Copy Code
Dim instance As HelpProvider
Dim value As String

instance.HelpNamespace = value

value = instance.HelpNamespace
C#
public virtual string HelpNamespace {get; set;}
Managed Extensions for C++
public: __property virtual string* get_HelpNamespace();
public: __property virtual void set_HelpNamespace(
   string* value
);
C++/CLI
public:
virtual property String^ HelpNamespace {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HelpProvider Class
HelpProvider Members


Tag Property

[image]
Gizmox.WebGUI.Forms
Tag Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > HelpProvider Class : Tag Property

Gets or sets the object that contains supplemental data about the HelpProvider.

Syntax

Visual Basic (Declaration)
<BindableAttribute(True)>
<LocalizableAttribute(False)>
<SRDescriptionAttribute("User-defined data associated with the object.")>
<TypeConverterAttribute("System.ComponentModel.StringConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<DefaultValueAttribute()>
<SRCategoryAttribute("Data")>
Public Property Tag As Object
Visual Basic (Usage) Copy Code
Dim instance As HelpProvider
Dim value As Object

instance.Tag = value

value = instance.Tag
C#
[BindableAttribute(true)]
[LocalizableAttribute(false)]
[SRDescriptionAttribute("User-defined data associated with the object.")]
[TypeConverterAttribute("System.ComponentModel.StringConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Data")]
public object Tag {get; set;}
Managed Extensions for C++
[BindableAttribute(true)]
[LocalizableAttribute(false)]
[SRDescriptionAttribute("User-defined data associated with the object.")]
[TypeConverterAttribute("System.ComponentModel.StringConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Data")]
public: __property Object* get_Tag();
public: __property void set_Tag(
   Object* value
);
C++/CLI
[BindableAttribute(true)]
[LocalizableAttribute(false)]
[SRDescriptionAttribute("User-defined data associated with the object.")]
[TypeConverterAttribute("System.ComponentModel.StringConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Data")]
public:
property Object^ Tag {
   Object^ get();
   void set (Object^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HelpProvider Class
HelpProvider Members


HtmlBox Class

[image]
Gizmox.WebGUI.Forms
HtmlBox Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : HtmlBox Class

A html control

Object Model

Syntax

Visual Basic (Declaration)
<ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<ClientControllerAttribute()>
<ToolboxBitmapAttribute()>
<MetadataTagAttribute("H")>
<SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableHtmlBox, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")>
<DesignTimeControllerAttribute()>
<ToolboxItemCategoryAttribute("Common Controls")>
Public Class HtmlBox
   Inherits FrameControl
   Implements IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Visual Basic (Usage) Copy Code
Dim instance As HtmlBox
C#
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ClientControllerAttribute()]
[ToolboxBitmapAttribute()]
[MetadataTagAttribute("H")]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableHtmlBox, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[DesignTimeControllerAttribute()]
[ToolboxItemCategoryAttribute("Common Controls")]
public class HtmlBox : FrameControl, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Managed Extensions for C++
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ClientControllerAttribute()]
[ToolboxBitmapAttribute()]
[MetadataTagAttribute("H")]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableHtmlBox, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[DesignTimeControllerAttribute()]
[ToolboxItemCategoryAttribute("Common Controls")]
public __gc class HtmlBox : public FrameControl, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
C++/CLI
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ClientControllerAttribute()]
[ToolboxBitmapAttribute()]
[MetadataTagAttribute("H")]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableHtmlBox, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[DesignTimeControllerAttribute()]
[ToolboxItemCategoryAttribute("Common Controls")]
public ref class HtmlBox : public FrameControl, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.FrameControl
Gizmox.WebGUI.Forms.HtmlBox

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

HtmlBox Members
Gizmox.WebGUI.Forms Namespace


HtmlBox Class Members

[image]
Gizmox.WebGUI.Forms
HtmlBox Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : HtmlBox Class

The following tables list the members exposed by HtmlBox.

Public Constructors

 | Name | Description
Public Constructor | HtmlBox Constructor | Creates a new HtmlBox instance.
Top

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | ContentType | Gets or sets the content type.
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Expires | Gets or sets the expire time in secodns.
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | Html | Gets or sets the HTML code of the control.
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | Path | Gets or sets the path.
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | Resource | Gets or sets the resource.
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Control)
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | Type | Gets the html box type.
Public Property | Url | Gets or sets the URL.
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | Overridden.
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | Overridden.
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | InvokeClientMethod | Invokes a client side method on the hosted control frame. (Inherited from FrameControl)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | Print |
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. Overridden.
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Control)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from Control)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | Overridden. Provides a way to handle gateway requests.
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Control)
Protected Method | RenderAttributes | Overridden.
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

HtmlBox Class
Gizmox.WebGUI.Forms Namespace


HtmlBox Constructor

[image]
Gizmox.WebGUI.Forms
HtmlBox Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > HtmlBox Class : HtmlBox Constructor

Creates a new HtmlBox instance.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As HtmlBox()
C#
public HtmlBox()
Managed Extensions for C++
public: HtmlBox();
C++/CLI
public:
HtmlBox();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HtmlBox Class
HtmlBox Members


HtmlBox Class Methods

[image]
Gizmox.WebGUI.Forms
HtmlBox Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : HtmlBox Class

For a list of all members of this type, see HtmlBox members.

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | InvokeClientMethod | Invokes a client side method on the hosted control frame. (Inherited from FrameControl)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | Print |
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. Overridden.
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Control)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from Control)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | Overridden. Provides a way to handle gateway requests.
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Control)
Protected Method | RenderAttributes | Overridden.
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

See Also

Reference

HtmlBox Class
Gizmox.WebGUI.Forms Namespace


Print Method

[image]
Gizmox.WebGUI.Forms
Print Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > HtmlBox Class : Print Method

Syntax

Visual Basic (Declaration)
Public Sub Print()
Visual Basic (Usage) Copy Code
Dim instance As HtmlBox

instance.Print()
C#
public void Print()
Managed Extensions for C++
public: void Print();
C++/CLI
public:
void Print();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HtmlBox Class
HtmlBox Members


ProcessGatewayRequest Method

[image]
Gizmox.WebGUI.Forms
ProcessGatewayRequest Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > HtmlBox Class : ProcessGatewayRequest Method

objHttpContext
The gateway request HTTP context.
strAction
The gateway request action.
Provides a way to handle gateway requests.

Syntax

Visual Basic (Declaration)
Protected Overrides Function ProcessGatewayRequest( _
   ByVal objHttpContext As HttpContext, _
   ByVal strAction As String _
) As IGatewayHandler
Visual Basic (Usage) Copy Code
Dim instance As HtmlBox
Dim objHttpContext As HttpContext
Dim strAction As String
Dim value As IGatewayHandler

value = instance.ProcessGatewayRequest(objHttpContext, strAction)
C#
protected override IGatewayHandler ProcessGatewayRequest(
   HttpContext objHttpContext,
   string strAction
)
Managed Extensions for C++
protected: IGatewayHandler* ProcessGatewayRequest(
   HttpContext* objHttpContext,
   string* strAction
) override
C++/CLI
protected:
IGatewayHandler^ ProcessGatewayRequest(
   HttpContext^ objHttpContext,
   String^ strAction
) override

Parameters

objHttpContext
The gateway request HTTP context.
strAction
The gateway request action.

Return Value

By default this method returns a instance of a class which implements the IGatewayHandler and throws a non implemented HttpException.

Remarks

This method is called from the implementation of IGatewayComponent which replaces the IGatewayControl interface. The IGatewayCompoenent is implemented by default in the RegisteredComponent class which is the base class of most of the Visual WebGui components. Referencing a RegisterComponent that overrides this method is done the same way that a control implementing IGatewayControl, which is by using the GatewayReference class.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HtmlBox Class
HtmlBox Members


RenderAttributes Method

[image]
Gizmox.WebGUI.Forms
RenderAttributes Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > HtmlBox Class : RenderAttributes Method

objContext
objWriter

Syntax

Visual Basic (Declaration)
Protected Overrides Sub RenderAttributes( _
   ByVal objContext As IContext, _
   ByVal objWriter As IAttributeWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As HtmlBox
Dim objContext As IContext
Dim objWriter As IAttributeWriter

instance.RenderAttributes(objContext, objWriter)
C#
protected override void RenderAttributes(
   IContext objContext,
   IAttributeWriter objWriter
)
Managed Extensions for C++
protected: void RenderAttributes(
   IContext* objContext,
   IAttributeWriter* objWriter
) override
C++/CLI
protected:
void RenderAttributes(
   IContext^ objContext,
   IAttributeWriter^ objWriter
) override

Parameters

objContext
objWriter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HtmlBox Class
HtmlBox Members


Update Method

[image]
Gizmox.WebGUI.Forms
Update Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > HtmlBox Class : Update Method

Overload List

Overload | Description
Update() |
Update(Boolean) | (Inherited from RegisteredComponent)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HtmlBox Class
HtmlBox Members


Update() Method

[image]
Gizmox.WebGUI.Forms
Update() Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > HtmlBox Class > Update Method : Update() Method

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Sub Update()
Visual Basic (Usage) Copy Code
Dim instance As HtmlBox

instance.Update()
C#
public override void Update()
Managed Extensions for C++
public: void Update(); override
C++/CLI
public:
void Update(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HtmlBox Class
HtmlBox Members
Overload List


HtmlBox Class Properties

[image]
Gizmox.WebGUI.Forms
HtmlBox Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : HtmlBox Class

For a list of all members of this type, see HtmlBox members.

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | ContentType | Gets or sets the content type.
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Expires | Gets or sets the expire time in secodns.
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | Html | Gets or sets the HTML code of the control.
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | Path | Gets or sets the path.
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | Resource | Gets or sets the resource.
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Control)
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | Type | Gets the html box type.
Public Property | Url | Gets or sets the URL.
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | Overridden.
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | Overridden.
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

See Also

Reference

HtmlBox Class
Gizmox.WebGUI.Forms Namespace


ContentType Property

[image]
Gizmox.WebGUI.Forms
ContentType Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > HtmlBox Class : ContentType Property

Gets or sets the content type.

Syntax

Visual Basic (Declaration)
Public Property ContentType As String
Visual Basic (Usage) Copy Code
Dim instance As HtmlBox
Dim value As String

instance.ContentType = value

value = instance.ContentType
C#
public string ContentType {get; set;}
Managed Extensions for C++
public: __property string* get_ContentType();
public: __property void set_ContentType(
   string* value
);
C++/CLI
public:
property String^ ContentType {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HtmlBox Class
HtmlBox Members


DefaultBackColor Property

[image]
Gizmox.WebGUI.Forms
DefaultBackColor Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > HtmlBox Class : DefaultBackColor Property

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property DefaultBackColor As Color
Visual Basic (Usage) Copy Code
Dim instance As HtmlBox
Dim value As Color

value = instance.DefaultBackColor
C#
protected override Color DefaultBackColor {get;}
Managed Extensions for C++
protected: __property Color get_DefaultBackColor() override;
C++/CLI
protected:
property Color DefaultBackColor {
   Color get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HtmlBox Class
HtmlBox Members


DefaultBorderStyle Property

[image]
Gizmox.WebGUI.Forms
DefaultBorderStyle Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > HtmlBox Class : DefaultBorderStyle Property

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property DefaultBorderStyle As BorderStyle
Visual Basic (Usage) Copy Code
Dim instance As HtmlBox
Dim value As BorderStyle

value = instance.DefaultBorderStyle
C#
protected override BorderStyle DefaultBorderStyle {get;}
Managed Extensions for C++
protected: __property BorderStyle get_DefaultBorderStyle() override;
C++/CLI
protected:
property BorderStyle DefaultBorderStyle {
   BorderStyle get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HtmlBox Class
HtmlBox Members


Expires Property

[image]
Gizmox.WebGUI.Forms
Expires Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > HtmlBox Class : Expires Property

Gets or sets the expire time in secodns.

Syntax

Visual Basic (Declaration)
Public Property Expires As Integer
Visual Basic (Usage) Copy Code
Dim instance As HtmlBox
Dim value As Integer

instance.Expires = value

value = instance.Expires
C#
public int Expires {get; set;}
Managed Extensions for C++
public: __property int get_Expires();
public: __property void set_Expires(
   int value
);
C++/CLI
public:
property int Expires {
   int get();
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HtmlBox Class
HtmlBox Members


Html Property

[image]
Gizmox.WebGUI.Forms
Html Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > HtmlBox Class : Html Property

Gets or sets the HTML code of the control.

Syntax

Visual Basic (Declaration)
Public Overridable Property Html As String
Visual Basic (Usage) Copy Code
Dim instance As HtmlBox
Dim value As String

instance.Html = value

value = instance.Html
C#
public virtual string Html {get; set;}
Managed Extensions for C++
public: __property virtual string* get_Html();
public: __property virtual void set_Html(
   string* value
);
C++/CLI
public:
virtual property String^ Html {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HtmlBox Class
HtmlBox Members


Path Property

[image]
Gizmox.WebGUI.Forms
Path Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > HtmlBox Class : Path Property

Gets or sets the path.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Overridable Property Path As String
Visual Basic (Usage) Copy Code
Dim instance As HtmlBox
Dim value As String

instance.Path = value

value = instance.Path
C#
[DefaultValueAttribute()]
public virtual string Path {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property virtual string* get_Path();
public: __property virtual void set_Path(
   string* value
);
C++/CLI
[DefaultValueAttribute()]
public:
virtual property String^ Path {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HtmlBox Class
HtmlBox Members


Resource Property

[image]
Gizmox.WebGUI.Forms
Resource Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > HtmlBox Class : Resource Property

Gets or sets the resource.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Overridable Property Resource As ResourceHandle
Visual Basic (Usage) Copy Code
Dim instance As HtmlBox
Dim value As ResourceHandle

instance.Resource = value

value = instance.Resource
C#
[DefaultValueAttribute()]
public virtual ResourceHandle Resource {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property virtual ResourceHandle* get_Resource();
public: __property virtual void set_Resource(
   ResourceHandle* value
);
C++/CLI
[DefaultValueAttribute()]
public:
virtual property ResourceHandle^ Resource {
   ResourceHandle^ get();
   void set (ResourceHandle^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HtmlBox Class
HtmlBox Members


Type Property

[image]
Gizmox.WebGUI.Forms
Type Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > HtmlBox Class : Type Property

Gets the html box type.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Type As HtmlBoxType
Visual Basic (Usage) Copy Code
Dim instance As HtmlBox
Dim value As HtmlBoxType

value = instance.Type
C#
public HtmlBoxType Type {get;}
Managed Extensions for C++
public: __property HtmlBoxType get_Type();
C++/CLI
public:
property HtmlBoxType Type {
   HtmlBoxType get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HtmlBox Class
HtmlBox Members


Url Property

[image]
Gizmox.WebGUI.Forms
Url Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > HtmlBox Class : Url Property

Gets or sets the URL.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Overridable Property Url As String
Visual Basic (Usage) Copy Code
Dim instance As HtmlBox
Dim value As String

instance.Url = value

value = instance.Url
C#
[DefaultValueAttribute()]
public virtual string Url {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property virtual string* get_Url();
public: __property virtual void set_Url(
   string* value
);
C++/CLI
[DefaultValueAttribute()]
public:
virtual property String^ Url {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HtmlBox Class
HtmlBox Members


HtmlBox.HtmlGateway Class

[image]
Gizmox.WebGUI.Forms
HtmlBox.HtmlGateway Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : HtmlBox.HtmlGateway Class

Html gateway handler

Object Model

Syntax

Visual Basic (Declaration)
Public Class HtmlBox.HtmlGateway
   Inherits GatewayWriter
   Implements IGatewayHandler
Visual Basic (Usage) Copy Code
Dim instance As HtmlBox.HtmlGateway
C#
public class HtmlBox.HtmlGateway : GatewayWriter, IGatewayHandler
Managed Extensions for C++
public __gc class HtmlBox.HtmlGateway : public GatewayWriter, IGatewayHandler
C++/CLI
public ref class HtmlBox.HtmlGateway : public GatewayWriter, IGatewayHandler

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Common.Gateways.GatewayHandler
Gizmox.WebGUI.Common.Gateways.GatewayWriter
Gizmox.WebGUI.Forms.HtmlBox.HtmlGateway

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

HtmlBox.HtmlGateway Members
Gizmox.WebGUI.Forms Namespace


HtmlBox.HtmlGateway Class Members

[image]
Gizmox.WebGUI.Forms
HtmlBox.HtmlGateway Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : HtmlBox.HtmlGateway Class

The following tables list the members exposed by HtmlBox.HtmlGateway.

Public Constructors

 | Name | Description
Public Constructor | HtmlBox.HtmlGateway Constructor |
Top

Protected Properties

 | Name | Description
Protected Property | ContentType | (Inherited from Gizmox.WebGUI.Common.Gateways.GatewayWriter)
Protected Property | GatewayComponent | (Inherited from Gizmox.WebGUI.Common.Gateways.GatewayWriter)
Top

Public Methods

 | Name | Description
Public Method | ProcessGatewayRequest | (Inherited from Gizmox.WebGUI.Common.Gateways.GatewayWriter)
Top

Protected Methods

 | Name | Description
Protected Method | GetFormParam | (Inherited from Gizmox.WebGUI.Common.Gateways.GatewayWriter)
Protected Method | GetQueryParam | (Inherited from Gizmox.WebGUI.Common.Gateways.GatewayWriter)
Protected Method | GetRequestParam | (Inherited from Gizmox.WebGUI.Common.Gateways.GatewayWriter)
Protected Method | ProcessRequest | Overridden. Processes the request.
Protected Method | SetContentDisposition | (Inherited from Gizmox.WebGUI.Common.Gateways.GatewayWriter)
Protected Method | Write | Overloaded. (Inherited from Gizmox.WebGUI.Common.Gateways.GatewayWriter)
Protected Method | WriteFile | (Inherited from Gizmox.WebGUI.Common.Gateways.GatewayWriter)
Top

See Also

Reference

HtmlBox.HtmlGateway Class
Gizmox.WebGUI.Forms Namespace


HtmlBox.HtmlGateway Constructor

[image]
Gizmox.WebGUI.Forms
HtmlBox.HtmlGateway Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > HtmlBox.HtmlGateway Class : HtmlBox.HtmlGateway Constructor

objHtmlBox

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal objHtmlBox As HtmlBox _
)
Visual Basic (Usage) Copy Code
Dim objHtmlBox As HtmlBox

Dim instance As HtmlBox.HtmlGateway(objHtmlBox)
C#
public HtmlBox.HtmlGateway(
   HtmlBox objHtmlBox
)
Managed Extensions for C++
public: HtmlBox.HtmlGateway(
   HtmlBox* objHtmlBox
)
C++/CLI
public:
HtmlBox.HtmlGateway(
   HtmlBox^ objHtmlBox
)

Parameters

objHtmlBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HtmlBox.HtmlGateway Class
HtmlBox.HtmlGateway Members


HtmlBox.HtmlGateway Class Methods

[image]
Gizmox.WebGUI.Forms
HtmlBox.HtmlGateway Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : HtmlBox.HtmlGateway Class

For a list of all members of this type, see HtmlBox.HtmlGateway members.

Public Methods

 | Name | Description
Public Method | ProcessGatewayRequest | (Inherited from Gizmox.WebGUI.Common.Gateways.GatewayWriter)
Top

Protected Methods

 | Name | Description
Protected Method | GetFormParam | (Inherited from Gizmox.WebGUI.Common.Gateways.GatewayWriter)
Protected Method | GetQueryParam | (Inherited from Gizmox.WebGUI.Common.Gateways.GatewayWriter)
Protected Method | GetRequestParam | (Inherited from Gizmox.WebGUI.Common.Gateways.GatewayWriter)
Protected Method | ProcessRequest | Overridden. Processes the request.
Protected Method | SetContentDisposition | (Inherited from Gizmox.WebGUI.Common.Gateways.GatewayWriter)
Protected Method | Write | Overloaded. (Inherited from Gizmox.WebGUI.Common.Gateways.GatewayWriter)
Protected Method | WriteFile | (Inherited from Gizmox.WebGUI.Common.Gateways.GatewayWriter)
Top

See Also

Reference

HtmlBox.HtmlGateway Class
Gizmox.WebGUI.Forms Namespace


ProcessRequest Method

[image]
Gizmox.WebGUI.Forms
ProcessRequest Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > HtmlBox.HtmlGateway Class : ProcessRequest Method

Processes the request.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub ProcessRequest()
Visual Basic (Usage) Copy Code
Dim instance As HtmlBox.HtmlGateway

instance.ProcessRequest()
C#
protected override void ProcessRequest()
Managed Extensions for C++
protected: void ProcessRequest(); override
C++/CLI
protected:
void ProcessRequest(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HtmlBox.HtmlGateway Class
HtmlBox.HtmlGateway Members


ImageList Class

[image]
Gizmox.WebGUI.Forms
ImageList Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ImageList Class

Summary description for ImageList.

Object Model

Syntax

Visual Basic (Declaration)
<DesignerSerializerAttribute(SerializerTypeName="Gizmox.WebGUI.Common.Design.Serialization.ImageListCodeDomSerializer, Gizmox.WebGUI.Common.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=ea5dfe57c8eb7edd", SerializerBaseTypeName="System.ComponentModel.Design.Serialization.CodeDomSerializer, System.Design, Version=2.0.5000.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<ToolboxBitmapAttribute()>
<DesignTimeVisibleAttribute(True)>
<ToolboxItemCategoryAttribute("Components")>
<ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<ToolboxItemFilterAttribute("Gizmox.WebGUI.Forms")>
Public Class ImageList
   Inherits ComponentBase
Visual Basic (Usage) Copy Code
Dim instance As ImageList
C#
[DesignerSerializerAttribute(SerializerTypeName="Gizmox.WebGUI.Common.Design.Serialization.ImageListCodeDomSerializer, Gizmox.WebGUI.Common.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=ea5dfe57c8eb7edd", SerializerBaseTypeName="System.ComponentModel.Design.Serialization.CodeDomSerializer, System.Design, Version=2.0.5000.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ToolboxBitmapAttribute()]
[DesignTimeVisibleAttribute(true)]
[ToolboxItemCategoryAttribute("Components")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ToolboxItemFilterAttribute("Gizmox.WebGUI.Forms")]
public class ImageList : ComponentBase
Managed Extensions for C++
[DesignerSerializerAttribute(SerializerTypeName="Gizmox.WebGUI.Common.Design.Serialization.ImageListCodeDomSerializer, Gizmox.WebGUI.Common.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=ea5dfe57c8eb7edd", SerializerBaseTypeName="System.ComponentModel.Design.Serialization.CodeDomSerializer, System.Design, Version=2.0.5000.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ToolboxBitmapAttribute()]
[DesignTimeVisibleAttribute(true)]
[ToolboxItemCategoryAttribute("Components")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ToolboxItemFilterAttribute("Gizmox.WebGUI.Forms")]
public __gc class ImageList : public ComponentBase
C++/CLI
[DesignerSerializerAttribute(SerializerTypeName="Gizmox.WebGUI.Common.Design.Serialization.ImageListCodeDomSerializer, Gizmox.WebGUI.Common.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=ea5dfe57c8eb7edd", SerializerBaseTypeName="System.ComponentModel.Design.Serialization.CodeDomSerializer, System.Design, Version=2.0.5000.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ToolboxBitmapAttribute()]
[DesignTimeVisibleAttribute(true)]
[ToolboxItemCategoryAttribute("Components")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ToolboxItemFilterAttribute("Gizmox.WebGUI.Forms")]
public ref class ImageList : public ComponentBase

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.ImageList

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

ImageList Members
Gizmox.WebGUI.Forms Namespace


ImageList Class Members

[image]
Gizmox.WebGUI.Forms
ImageList Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : ImageList Class

The following tables list the members exposed by ImageList.

Public Constructors

 | Name | Description
Public Constructor | ImageList Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Container | (Inherited from ComponentBase)
Public Property | HandleCreated | Gets a value indicating whether the underlying Win32 handle has been created.
Public Property | Images | Gets the ImageList.ImageCollection for this image list.
Public Property | ImageSize | Gets or sets the size of the images in the image list.
Public Property | Site | (Inherited from ComponentBase)
Public Property | Tag | Gets or sets an object that contains additional data about the ImageList.
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Top

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded. (Inherited from ComponentBase)
Public Method | Draw | Overloaded. Draws the image indicated by the specified index on the specified Graphics at the given location.
Public Method | ToString | Overridden.
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | GetService | (Inherited from ComponentBase)
Top

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from ComponentBase)
Top

See Also

Reference

ImageList Class
Gizmox.WebGUI.Forms Namespace


ImageList Constructor

[image]
Gizmox.WebGUI.Forms
ImageList Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ImageList Class : ImageList Constructor

Overload List

Overload | Description
ImageList Constructor() |
ImageList Constructor(IContainer) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ImageList Class
ImageList Members


ImageList Constructor()

[image]
Gizmox.WebGUI.Forms
ImageList Constructor()
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ImageList Class > ImageList Constructor : ImageList Constructor()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ImageList()
C#
public ImageList()
Managed Extensions for C++
public: ImageList();
C++/CLI
public:
ImageList();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ImageList Class
ImageList Members
Overload List


ImageList Constructor(IContainer)

[image]
Gizmox.WebGUI.Forms
ImageList Constructor(IContainer)
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ImageList Class > ImageList Constructor : ImageList Constructor(IContainer)

container

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal container As IContainer _
)
Visual Basic (Usage) Copy Code
Dim container As IContainer

Dim instance As ImageList(container)
C#
public ImageList(
   IContainer container
)
Managed Extensions for C++
public: ImageList(
   IContainer* container
)
C++/CLI
public:
ImageList(
   IContainer^ container
)

Parameters

container

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ImageList Class
ImageList Members
Overload List


ImageList Class Methods

[image]
Gizmox.WebGUI.Forms
ImageList Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ImageList Class

For a list of all members of this type, see ImageList members.

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded. (Inherited from ComponentBase)
Public Method | Draw | Overloaded. Draws the image indicated by the specified index on the specified Graphics at the given location.
Public Method | ToString | Overridden.
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | GetService | (Inherited from ComponentBase)
Top

See Also

Reference

ImageList Class
Gizmox.WebGUI.Forms Namespace


Draw Method

[image]
Gizmox.WebGUI.Forms
Draw Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ImageList Class : Draw Method

Draws the image indicated by the specified index on the specified Graphics at the given location.

Overload List

Overload | Description
Draw(Graphics,Point,Int32) | Draws the image indicated by the specified index on the specified Graphics at the given location.
Draw(Graphics,Int32,Int32,Int32) | Draws the image indicated by the given index on the specified Graphics at the specified location.
Draw(Graphics,Int32,Int32,Int32,Int32,Int32) | Draws the image indicated by the given index on the specified Graphics using the specified location and size.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ImageList Class
ImageList Members


Draw(Graphics,Point,Int32) Method

[image]
Gizmox.WebGUI.Forms
Draw(Graphics,Point,Int32) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ImageList Class > Draw Method : Draw(Graphics,Point,Int32) Method

g
The Graphics to draw on.
pt
The location defined by a Point at which to draw the image.
index
The index of the image in the ImageList to draw.
Draws the image indicated by the specified index on the specified Graphics at the given location.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Draw( _
   ByVal g As Graphics, _
   ByVal pt As Point, _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageList
Dim g As Graphics
Dim pt As Point
Dim index As Integer

instance.Draw(g, pt, index)
C#
public void Draw(
   Graphics g,
   Point pt,
   int index
)
Managed Extensions for C++
public: void Draw(
   Graphics* g,
   Point pt,
   int index
)
C++/CLI
public:
void Draw(
   Graphics^ g,
   Point pt,
   int index
)

Parameters

g
The Graphics to draw on.
pt
The location defined by a Point at which to draw the image.
index
The index of the image in the ImageList to draw.

Exceptions

Exception | Description
ArgumentOutOfRangeException | The index is less than 0.-or- The index is greater than or equal to the count of images in the image list.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ImageList Class
ImageList Members
Overload List


Draw(Graphics,Int32,Int32,Int32) Method

[image]
Gizmox.WebGUI.Forms
Draw(Graphics,Int32,Int32,Int32) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ImageList Class > Draw Method : Draw(Graphics,Int32,Int32,Int32) Method

g
The Graphics to draw on.
x
The horizontal position at which to draw the image.
y
The vertical position at which to draw the image.
index
The index of the image in the ImageList to draw.
Draws the image indicated by the given index on the specified Graphics at the specified location.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Draw( _
   ByVal g As Graphics, _
   ByVal x As Integer, _
   ByVal y As Integer, _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageList
Dim g As Graphics
Dim x As Integer
Dim y As Integer
Dim index As Integer

instance.Draw(g, x, y, index)
C#
public void Draw(
   Graphics g,
   int x,
   int y,
   int index
)
Managed Extensions for C++
public: void Draw(
   Graphics* g,
   int x,
   int y,
   int index
)
C++/CLI
public:
void Draw(
   Graphics^ g,
   int x,
   int y,
   int index
)

Parameters

g
The Graphics to draw on.
x
The horizontal position at which to draw the image.
y
The vertical position at which to draw the image.
index
The index of the image in the ImageList to draw.

Exceptions

Exception | Description
ArgumentOutOfRangeException | The index is less than 0.-or- The index is greater than or equal to the count of images in the image list.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ImageList Class
ImageList Members
Overload List


Draw(Graphics,Int32,Int32,Int32,Int32,Int32) Method

[image]
Gizmox.WebGUI.Forms
Draw(Graphics,Int32,Int32,Int32,Int32,Int32) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ImageList Class > Draw Method : Draw(Graphics,Int32,Int32,Int32,Int32,Int32) Method

g
The Graphics to draw on.
x
The horizontal position at which to draw the image.
y
The vertical position at which to draw the image.
width
The width, in pixels, of the destination image.
height
The height, in pixels, of the destination image.
index
The index of the image in the ImageList to draw.
Draws the image indicated by the given index on the specified Graphics using the specified location and size.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Draw( _
   ByVal g As Graphics, _
   ByVal x As Integer, _
   ByVal y As Integer, _
   ByVal width As Integer, _
   ByVal height As Integer, _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageList
Dim g As Graphics
Dim x As Integer
Dim y As Integer
Dim width As Integer
Dim height As Integer
Dim index As Integer

instance.Draw(g, x, y, width, height, index)
C#
public void Draw(
   Graphics g,
   int x,
   int y,
   int width,
   int height,
   int index
)
Managed Extensions for C++
public: void Draw(
   Graphics* g,
   int x,
   int y,
   int width,
   int height,
   int index
)
C++/CLI
public:
void Draw(
   Graphics^ g,
   int x,
   int y,
   int width,
   int height,
   int index
)

Parameters

g
The Graphics to draw on.
x
The horizontal position at which to draw the image.
y
The vertical position at which to draw the image.
width
The width, in pixels, of the destination image.
height
The height, in pixels, of the destination image.
index
The index of the image in the ImageList to draw.

Exceptions

Exception | Description
ArgumentOutOfRangeException | The index is less than 0.-or- The index is greater than or equal to the count of images in the image list.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ImageList Class
ImageList Members
Overload List


ToString Method

[image]
Gizmox.WebGUI.Forms
ToString Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ImageList Class : ToString Method

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As ImageList
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ImageList Class
ImageList Members


ImageList Class Properties

[image]
Gizmox.WebGUI.Forms
ImageList Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ImageList Class

For a list of all members of this type, see ImageList members.

Public Properties

 | Name | Description
Public Property | Container | (Inherited from ComponentBase)
Public Property | HandleCreated | Gets a value indicating whether the underlying Win32 handle has been created.
Public Property | Images | Gets the ImageList.ImageCollection for this image list.
Public Property | ImageSize | Gets or sets the size of the images in the image list.
Public Property | Site | (Inherited from ComponentBase)
Public Property | Tag | Gets or sets an object that contains additional data about the ImageList.
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Top

See Also

Reference

ImageList Class
Gizmox.WebGUI.Forms Namespace


HandleCreated Property

[image]
Gizmox.WebGUI.Forms
HandleCreated Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ImageList Class : HandleCreated Property

Gets a value indicating whether the underlying Win32 handle has been created.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<DesignerSerializationVisibilityAttribute()>
<SRDescriptionAttribute("Indicates if the native handle has been created for this ImageList.")>
Public ReadOnly Property HandleCreated As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ImageList
Dim value As Boolean

value = instance.HandleCreated
C#
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[DesignerSerializationVisibilityAttribute()]
[SRDescriptionAttribute("Indicates if the native handle has been created for this ImageList.")]
public bool HandleCreated {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[DesignerSerializationVisibilityAttribute()]
[SRDescriptionAttribute("Indicates if the native handle has been created for this ImageList.")]
public: __property bool get_HandleCreated();
C++/CLI
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[DesignerSerializationVisibilityAttribute()]
[SRDescriptionAttribute("Indicates if the native handle has been created for this ImageList.")]
public:
property bool HandleCreated {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ImageList Class
ImageList Members


Images Property

[image]
Gizmox.WebGUI.Forms
Images Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ImageList Class : Images Property

Gets the ImageList.ImageCollection for this image list.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Appearance")>
<DesignerSerializationVisibilityAttribute()>
<SRDescriptionAttribute("The images stored in this ImageList.")>
<BrowsableAttribute(True)>
Public ReadOnly Property Images As ImageList.ImageCollection
Visual Basic (Usage) Copy Code
Dim instance As ImageList
Dim value As ImageList.ImageCollection

value = instance.Images
C#
[SRCategoryAttribute("Appearance")]
[DesignerSerializationVisibilityAttribute()]
[SRDescriptionAttribute("The images stored in this ImageList.")]
[BrowsableAttribute(true)]
public ImageList.ImageCollection Images {get;}
Managed Extensions for C++
[SRCategoryAttribute("Appearance")]
[DesignerSerializationVisibilityAttribute()]
[SRDescriptionAttribute("The images stored in this ImageList.")]
[BrowsableAttribute(true)]
public: __property ImageList.ImageCollection* get_Images();
C++/CLI
[SRCategoryAttribute("Appearance")]
[DesignerSerializationVisibilityAttribute()]
[SRDescriptionAttribute("The images stored in this ImageList.")]
[BrowsableAttribute(true)]
public:
property ImageList::ImageCollection^ Images {
   ImageList::ImageCollection^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ImageList Class
ImageList Members


ImageSize Property

[image]
Gizmox.WebGUI.Forms
ImageSize Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ImageList Class : ImageSize Property

Gets or sets the size of the images in the image list.

Syntax

Visual Basic (Declaration)
<LocalizableAttribute(True)>
<BrowsableAttribute(True)>
<SRDescriptionAttribute("The size of individual images in the ImageList.")>
<SRCategoryAttribute("Behavior")>
Public Property ImageSize As Size
Visual Basic (Usage) Copy Code
Dim instance As ImageList
Dim value As Size

instance.ImageSize = value

value = instance.ImageSize
C#
[LocalizableAttribute(true)]
[BrowsableAttribute(true)]
[SRDescriptionAttribute("The size of individual images in the ImageList.")]
[SRCategoryAttribute("Behavior")]
public Size ImageSize {get; set;}
Managed Extensions for C++
[LocalizableAttribute(true)]
[BrowsableAttribute(true)]
[SRDescriptionAttribute("The size of individual images in the ImageList.")]
[SRCategoryAttribute("Behavior")]
public: __property Size get_ImageSize();
public: __property void set_ImageSize(
   Size value
);
C++/CLI
[LocalizableAttribute(true)]
[BrowsableAttribute(true)]
[SRDescriptionAttribute("The size of individual images in the ImageList.")]
[SRCategoryAttribute("Behavior")]
public:
property Size ImageSize {
   Size get();
   void set (Sizevalue);
}

Exceptions

Exception | Description
ArgumentOutOfRangeException | The new size has a dimension less than 0 or greater than 256.
ArgumentException | The value assigned is equal to IsEmpty.-or- The value of the height or width is less than or equal to 0.-or- The value of the height or width is greater than 256.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ImageList Class
ImageList Members


Tag Property

[image]
Gizmox.WebGUI.Forms
Tag Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ImageList Class : Tag Property

Gets or sets an object that contains additional data about the ImageList.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<TypeConverterAttribute("System.ComponentModel.StringConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<LocalizableAttribute(False)>
<BindableAttribute(True)>
<SRDescriptionAttribute("User-defined data associated with the object.")>
<SRCategoryAttribute("Data")>
Public Property Tag As Object
Visual Basic (Usage) Copy Code
Dim instance As ImageList
Dim value As Object

instance.Tag = value

value = instance.Tag
C#
[DefaultValueAttribute()]
[TypeConverterAttribute("System.ComponentModel.StringConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[LocalizableAttribute(false)]
[BindableAttribute(true)]
[SRDescriptionAttribute("User-defined data associated with the object.")]
[SRCategoryAttribute("Data")]
public object Tag {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[TypeConverterAttribute("System.ComponentModel.StringConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[LocalizableAttribute(false)]
[BindableAttribute(true)]
[SRDescriptionAttribute("User-defined data associated with the object.")]
[SRCategoryAttribute("Data")]
public: __property Object* get_Tag();
public: __property void set_Tag(
   Object* value
);
C++/CLI
[DefaultValueAttribute()]
[TypeConverterAttribute("System.ComponentModel.StringConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[LocalizableAttribute(false)]
[BindableAttribute(true)]
[SRDescriptionAttribute("User-defined data associated with the object.")]
[SRCategoryAttribute("Data")]
public:
property Object^ Tag {
   Object^ get();
   void set (Object^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ImageList Class
ImageList Members


ImageList.ImageCollection Class

[image]
Gizmox.WebGUI.Forms
ImageList.ImageCollection Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ImageList.ImageCollection Class

Encapsulates the collection of Gizmox.WebGUI.Common.Resources.ResourceHandle objects in an ImageList.

Object Model

Syntax

Visual Basic (Declaration)
<EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.ImageCollectionEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")>
<DefaultMemberAttribute("Item")>
Public NotInheritable Class ImageList.ImageCollection
Visual Basic (Usage) Copy Code
Dim instance As ImageList.ImageCollection
C#
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.ImageCollectionEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[DefaultMemberAttribute("Item")]
public sealed class ImageList.ImageCollection
Managed Extensions for C++
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.ImageCollectionEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[DefaultMemberAttribute("Item")]
public __gc __sealed class ImageList.ImageCollection
C++/CLI
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.ImageCollectionEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[DefaultMemberAttribute("Item")]
public ref class ImageList.ImageCollection sealed

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ImageList.ImageCollection

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

ImageList.ImageCollection Members
Gizmox.WebGUI.Forms Namespace


ImageList.ImageCollection Class Members

[image]
Gizmox.WebGUI.Forms
ImageList.ImageCollection Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : ImageList.ImageCollection Class

The following tables list the members exposed by ImageList.ImageCollection.

Public Properties

 | Name | Description
Public Property | Count | Gets the number of images currently in the list.
Public Property | Empty | Gets a value indicating whether the ImageList has any images.
Public Property | IsReadOnly | Gets a value indicating whether the list is read-only.
Public Property | Item | Overloaded. Gets an Gizmox.WebGUI.Common.Resources.ResourceHandle with the specified key from the collection.
Public Property | Keys | Gets the collection of keys associated with the images in the ImageList.ImageCollection.
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Adds the specified image to the ImageList.
Public Method | AddIcon | Overloaded. Adds a new icon using a key
Public Method | AddImage | Overloaded. Adds a new image using a key
Public Method | AddRange | Adds an array of images to the collection.
Public Method | Clear | Removes all the images and masks from the ImageList.
Public Method | ContainsKey | Determines if the collection contains an image with the specified key.
Public Method | GetEnumerator | Returns an enumerator that can be used to iterate through the item collection.
Public Method | IndexOfKey | Determines the index of the first occurrence of an image with the specified key in the collection.
Public Method | KeyOfIndex | Determines the key of the image with the specified index.
Public Method | RemoveAt | Removes an image from the list.
Public Method | RemoveByKey | Removes the image with the specified key from the collection.
Public Method | SetKeyName | Sets the key for an image in the collection.
Top

See Also

Reference

ImageList.ImageCollection Class
Gizmox.WebGUI.Forms Namespace


ImageList.ImageCollection Class Methods

[image]
Gizmox.WebGUI.Forms
ImageList.ImageCollection Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ImageList.ImageCollection Class

For a list of all members of this type, see ImageList.ImageCollection members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Adds the specified image to the ImageList.
Public Method | AddIcon | Overloaded. Adds a new icon using a key
Public Method | AddImage | Overloaded. Adds a new image using a key
Public Method | AddRange | Adds an array of images to the collection.
Public Method | Clear | Removes all the images and masks from the ImageList.
Public Method | ContainsKey | Determines if the collection contains an image with the specified key.
Public Method | GetEnumerator | Returns an enumerator that can be used to iterate through the item collection.
Public Method | IndexOfKey | Determines the index of the first occurrence of an image with the specified key in the collection.
Public Method | KeyOfIndex | Determines the key of the image with the specified index.
Public Method | RemoveAt | Removes an image from the list.
Public Method | RemoveByKey | Removes the image with the specified key from the collection.
Public Method | SetKeyName | Sets the key for an image in the collection.
Top

See Also

Reference

ImageList.ImageCollection Class
Gizmox.WebGUI.Forms Namespace


Add Method

[image]
Gizmox.WebGUI.Forms
Add Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ImageList.ImageCollection Class : Add Method

Adds the specified image to the ImageList.

Overload List

Overload | Description
Add(ResourceHandle) | Adds the specified image to the ImageList.
Add(String,ResourceHandle) | Adds an image with the specified key to the end of the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ImageList.ImageCollection Class
ImageList.ImageCollection Members


Add(ResourceHandle) Method

[image]
Gizmox.WebGUI.Forms
Add(ResourceHandle) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ImageList.ImageCollection Class > Add Method : Add(ResourceHandle) Method

value
A Bitmap of the image to add to the list.
Adds the specified image to the ImageList.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Add( _
   ByVal value As ResourceHandle _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageList.ImageCollection
Dim value As ResourceHandle

instance.Add(value)
C#
public void Add(
   ResourceHandle value
)
Managed Extensions for C++
public: void Add(
   ResourceHandle* value
)
C++/CLI
public:
void Add(
   ResourceHandle^ value
)

Parameters

value
A Bitmap of the image to add to the list.

Exceptions

Exception | Description
Exception | The image could not be added.
ArgumentException | The image being added is not a Bitmap.
ArgumentNullException | The image being added is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ImageList.ImageCollection Class
ImageList.ImageCollection Members
Overload List


Add(String,ResourceHandle) Method

[image]
Gizmox.WebGUI.Forms
Add(String,ResourceHandle) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ImageList.ImageCollection Class > Add Method : Add(String,ResourceHandle) Method

key
The name of the image.
image
The Gizmox.WebGUI.Common.Resources.ResourceHandle to add to the collection.
Adds an image with the specified key to the end of the collection.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Add( _
   ByVal key As String, _
   ByVal image As ResourceHandle _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageList.ImageCollection
Dim key As String
Dim image As ResourceHandle

instance.Add(key, image)
C#
public void Add(
   string key,
   ResourceHandle image
)
Managed Extensions for C++
public: void Add(
   string* key,
   ResourceHandle* image
)
C++/CLI
public:
void Add(
   String^ key,
   ResourceHandle^ image
)

Parameters

key
The name of the image.
image
The Gizmox.WebGUI.Common.Resources.ResourceHandle to add to the collection.

Exceptions

Exception | Description
ArgumentNullException | image is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ImageList.ImageCollection Class
ImageList.ImageCollection Members
Overload List


AddIcon Method

[image]
Gizmox.WebGUI.Forms
AddIcon Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ImageList.ImageCollection Class : AddIcon Method

Adds a new icon using a key

Overload List

Overload | Description
AddIcon(String,String) | Adds a new icon using a key
AddIcon(String) | Adds a new icon

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ImageList.ImageCollection Class
ImageList.ImageCollection Members


AddIcon(String,String) Method

[image]
Gizmox.WebGUI.Forms
AddIcon(String,String) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ImageList.ImageCollection Class > AddIcon Method : AddIcon(String,String) Method

key
icon
Adds a new icon using a key

Syntax

Visual Basic (Declaration)
Public Overloads Sub AddIcon( _
   ByVal key As String, _
   ByVal icon As String _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageList.ImageCollection
Dim key As String
Dim icon As String

instance.AddIcon(key, icon)
C#
public void AddIcon(
   string key,
   string icon
)
Managed Extensions for C++
public: void AddIcon(
   string* key,
   string* icon
)
C++/CLI
public:
void AddIcon(
   String^ key,
   String^ icon
)

Parameters

key
icon

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ImageList.ImageCollection Class
ImageList.ImageCollection Members
Overload List


AddIcon(String) Method

[image]
Gizmox.WebGUI.Forms
AddIcon(String) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ImageList.ImageCollection Class > AddIcon Method : AddIcon(String) Method

icon
Adds a new icon

Syntax

Visual Basic (Declaration)
Public Overloads Sub AddIcon( _
   ByVal icon As String _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageList.ImageCollection
Dim icon As String

instance.AddIcon(icon)
C#
public void AddIcon(
   string icon
)
Managed Extensions for C++
public: void AddIcon(
   string* icon
)
C++/CLI
public:
void AddIcon(
   String^ icon
)

Parameters

icon

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ImageList.ImageCollection Class
ImageList.ImageCollection Members
Overload List


AddImage Method

[image]
Gizmox.WebGUI.Forms
AddImage Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ImageList.ImageCollection Class : AddImage Method

Adds a new image using a key

Overload List

Overload | Description
AddImage(String,String) | Adds a new image using a key
AddImage(String) | Adds a new image

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ImageList.ImageCollection Class
ImageList.ImageCollection Members


AddImage(String,String) Method

[image]
Gizmox.WebGUI.Forms
AddImage(String,String) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ImageList.ImageCollection Class > AddImage Method : AddImage(String,String) Method

key
image
Adds a new image using a key

Syntax

Visual Basic (Declaration)
Public Overloads Sub AddImage( _
   ByVal key As String, _
   ByVal image As String _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageList.ImageCollection
Dim key As String
Dim image As String

instance.AddImage(key, image)
C#
public void AddImage(
   string key,
   string image
)
Managed Extensions for C++
public: void AddImage(
   string* key,
   string* image
)
C++/CLI
public:
void AddImage(
   String^ key,
   String^ image
)

Parameters

key
image

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ImageList.ImageCollection Class
ImageList.ImageCollection Members
Overload List


AddImage(String) Method

[image]
Gizmox.WebGUI.Forms
AddImage(String) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ImageList.ImageCollection Class > AddImage Method : AddImage(String) Method

image
Adds a new image

Syntax

Visual Basic (Declaration)
Public Overloads Sub AddImage( _
   ByVal image As String _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageList.ImageCollection
Dim image As String

instance.AddImage(image)
C#
public void AddImage(
   string image
)
Managed Extensions for C++
public: void AddImage(
   string* image
)
C++/CLI
public:
void AddImage(
   String^ image
)

Parameters

image

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ImageList.ImageCollection Class
ImageList.ImageCollection Members
Overload List


AddRange Method

[image]
Gizmox.WebGUI.Forms
AddRange Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ImageList.ImageCollection Class : AddRange Method

images
The array of Gizmox.WebGUI.Common.Resources.ResourceHandle objects to add to the collection.
Adds an array of images to the collection.

Syntax

Visual Basic (Declaration)
Public Sub AddRange( _
   ByVal images() As ResourceHandle _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageList.ImageCollection
Dim images() As ResourceHandle

instance.AddRange(images)
C#
public void AddRange(
   ResourceHandle[] images
)
Managed Extensions for C++
public: void AddRange(
   ResourceHandle*[]* images
)
C++/CLI
public:
void AddRange(
   array<ResourceHandle^>^ images
)

Parameters

images
The array of Gizmox.WebGUI.Common.Resources.ResourceHandle objects to add to the collection.

Exceptions

Exception | Description
ArgumentNullException | images is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ImageList.ImageCollection Class
ImageList.ImageCollection Members


Clear Method

[image]
Gizmox.WebGUI.Forms
Clear Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ImageList.ImageCollection Class : Clear Method

Removes all the images and masks from the ImageList.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As ImageList.ImageCollection

instance.Clear()
C#
public void Clear()
Managed Extensions for C++
public: void Clear();
C++/CLI
public:
void Clear();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ImageList.ImageCollection Class
ImageList.ImageCollection Members


ContainsKey Method

[image]
Gizmox.WebGUI.Forms
ContainsKey Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ImageList.ImageCollection Class : ContainsKey Method

key
The key of the image to search for.
Determines if the collection contains an image with the specified key.

Syntax

Visual Basic (Declaration)
Public Function ContainsKey( _
   ByVal key As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ImageList.ImageCollection
Dim key As String
Dim value As Boolean

value = instance.ContainsKey(key)
C#
public bool ContainsKey(
   string key
)
Managed Extensions for C++
public: bool ContainsKey(
   string* key
)
C++/CLI
public:
bool ContainsKey(
   String^ key
)

Parameters

key
The key of the image to search for.

Return Value

true to indicate an image with the specified key is contained in the collection; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ImageList.ImageCollection Class
ImageList.ImageCollection Members


GetEnumerator Method

[image]
Gizmox.WebGUI.Forms
GetEnumerator Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ImageList.ImageCollection Class : GetEnumerator Method

Returns an enumerator that can be used to iterate through the item collection.

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As ImageList.ImageCollection
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Return Value

An IEnumerator that represents the item collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ImageList.ImageCollection Class
ImageList.ImageCollection Members


IndexOfKey Method

[image]
Gizmox.WebGUI.Forms
IndexOfKey Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ImageList.ImageCollection Class : IndexOfKey Method

key
The key of the image to retrieve the index for.
Determines the index of the first occurrence of an image with the specified key in the collection.

Syntax

Visual Basic (Declaration)
Public Function IndexOfKey( _
   ByVal key As String _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As ImageList.ImageCollection
Dim key As String
Dim value As Integer

value = instance.IndexOfKey(key)
C#
public int IndexOfKey(
   string key
)
Managed Extensions for C++
public: int IndexOfKey(
   string* key
)
C++/CLI
public:
int IndexOfKey(
   String^ key
)

Parameters

key
The key of the image to retrieve the index for.

Return Value

The zero-based index of the first occurrence of an image with the specified key in the collection, if found; otherwise, -1.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ImageList.ImageCollection Class
ImageList.ImageCollection Members


KeyOfIndex Method

[image]
Gizmox.WebGUI.Forms
KeyOfIndex Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ImageList.ImageCollection Class : KeyOfIndex Method

intIndex
The index of the image to retrieve the key for.
Determines the key of the image with the specified index.

Syntax

Visual Basic (Declaration)
Public Function KeyOfIndex( _
   ByVal intIndex As Integer _
) As String
Visual Basic (Usage) Copy Code
Dim instance As ImageList.ImageCollection
Dim intIndex As Integer
Dim value As String

value = instance.KeyOfIndex(intIndex)
C#
public string KeyOfIndex(
   int intIndex
)
Managed Extensions for C++
public: string* KeyOfIndex(
   int intIndex
)
C++/CLI
public:
String^ KeyOfIndex(
   int intIndex
)

Parameters

intIndex
The index of the image to retrieve the key for.

Return Value

The key that was found for the index or null if key was not found.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ImageList.ImageCollection Class
ImageList.ImageCollection Members


RemoveAt Method

[image]
Gizmox.WebGUI.Forms
RemoveAt Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ImageList.ImageCollection Class : RemoveAt Method

index
The index of the image to remove.
Removes an image from the list.

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageList.ImageCollection
Dim index As Integer

instance.RemoveAt(index)
C#
public void RemoveAt(
   int index
)
Managed Extensions for C++
public: void RemoveAt(
   int index
)
C++/CLI
public:
void RemoveAt(
   int index
)

Parameters

index
The index of the image to remove.

Exceptions

Exception | Description
ArgumentOutOfRangeException | The index value was less than 0.-or- The index value is greater than or equal to the Count of images.
InvalidOperationException | The image cannot be removed.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ImageList.ImageCollection Class
ImageList.ImageCollection Members


RemoveByKey Method

[image]
Gizmox.WebGUI.Forms
RemoveByKey Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ImageList.ImageCollection Class : RemoveByKey Method

key
The key of the image to remove from the collection.
Removes the image with the specified key from the collection.

Syntax

Visual Basic (Declaration)
Public Sub RemoveByKey( _
   ByVal key As String _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageList.ImageCollection
Dim key As String

instance.RemoveByKey(key)
C#
public void RemoveByKey(
   string key
)
Managed Extensions for C++
public: void RemoveByKey(
   string* key
)
C++/CLI
public:
void RemoveByKey(
   String^ key
)

Parameters

key
The key of the image to remove from the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ImageList.ImageCollection Class
ImageList.ImageCollection Members


SetKeyName Method

[image]
Gizmox.WebGUI.Forms
SetKeyName Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ImageList.ImageCollection Class : SetKeyName Method

index
The zero-based index of an image in the collection.
name
The name of the image to be set as the image key.
Sets the key for an image in the collection.

Syntax

Visual Basic (Declaration)
Public Sub SetKeyName( _
   ByVal index As Integer, _
   ByVal name As String _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageList.ImageCollection
Dim index As Integer
Dim name As String

instance.SetKeyName(index, name)
C#
public void SetKeyName(
   int index,
   string name
)
Managed Extensions for C++
public: void SetKeyName(
   int index,
   string* name
)
C++/CLI
public:
void SetKeyName(
   int index,
   String^ name
)

Parameters

index
The zero-based index of an image in the collection.
name
The name of the image to be set as the image key.

Exceptions

Exception | Description
IndexOutOfRangeException | The specified index is less than 0 or greater than or equal to Count.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ImageList.ImageCollection Class
ImageList.ImageCollection Members


ImageList.ImageCollection Class Properties

[image]
Gizmox.WebGUI.Forms
ImageList.ImageCollection Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ImageList.ImageCollection Class

For a list of all members of this type, see ImageList.ImageCollection members.

Public Properties

 | Name | Description
Public Property | Count | Gets the number of images currently in the list.
Public Property | Empty | Gets a value indicating whether the ImageList has any images.
Public Property | IsReadOnly | Gets a value indicating whether the list is read-only.
Public Property | Item | Overloaded. Gets an Gizmox.WebGUI.Common.Resources.ResourceHandle with the specified key from the collection.
Public Property | Keys | Gets the collection of keys associated with the images in the ImageList.ImageCollection.
Top

See Also

Reference

ImageList.ImageCollection Class
Gizmox.WebGUI.Forms Namespace


Count Property

[image]
Gizmox.WebGUI.Forms
Count Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ImageList.ImageCollection Class : Count Property

Gets the number of images currently in the list.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As ImageList.ImageCollection
Dim value As Integer

value = instance.Count
C#
[BrowsableAttribute(false)]
public int Count {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property int get_Count();
C++/CLI
[BrowsableAttribute(false)]
public:
property int Count {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ImageList.ImageCollection Class
ImageList.ImageCollection Members


Empty Property

[image]
Gizmox.WebGUI.Forms
Empty Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ImageList.ImageCollection Class : Empty Property

Gets a value indicating whether the ImageList has any images.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Empty As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ImageList.ImageCollection
Dim value As Boolean

value = instance.Empty
C#
public bool Empty {get;}
Managed Extensions for C++
public: __property bool get_Empty();
C++/CLI
public:
property bool Empty {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ImageList.ImageCollection Class
ImageList.ImageCollection Members


IsReadOnly Property

[image]
Gizmox.WebGUI.Forms
IsReadOnly Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ImageList.ImageCollection Class : IsReadOnly Property

Gets a value indicating whether the list is read-only.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsReadOnly As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ImageList.ImageCollection
Dim value As Boolean

value = instance.IsReadOnly
C#
public bool IsReadOnly {get;}
Managed Extensions for C++
public: __property bool get_IsReadOnly();
C++/CLI
public:
property bool IsReadOnly {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ImageList.ImageCollection Class
ImageList.ImageCollection Members


Item Property

[image]
Gizmox.WebGUI.Forms
Item Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ImageList.ImageCollection Class : Item Property

Gets an Gizmox.WebGUI.Common.Resources.ResourceHandle with the specified key from the collection.

Overload List

Overload | Description
Item(String) | Gets an Gizmox.WebGUI.Common.Resources.ResourceHandle with the specified key from the collection.
Item(Int32) | Gets or sets an Gizmox.WebGUI.Common.Resources.ResourceHandle at the specified index within the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ImageList.ImageCollection Class
ImageList.ImageCollection Members


Item(String) Property

[image]
Gizmox.WebGUI.Forms
Item(String) Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ImageList.ImageCollection Class > Item Property : Item(String) Property

key
The name of the image to retrieve from the collection.
Gets an Gizmox.WebGUI.Common.Resources.ResourceHandle with the specified key from the collection.

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal key As String _
) As ResourceHandle
Visual Basic (Usage) Copy Code
Dim instance As ImageList.ImageCollection
Dim key As String
Dim value As ResourceHandle

value = instance.Item(key)
C#
public ResourceHandle Item(
   string key
) {get;}
Managed Extensions for C++
public: __property ResourceHandle* get_Item(
   string* key
);
C++/CLI
public:
property ResourceHandle^ Item {
   ResourceHandle^ get(String^key);
}

Parameters

key
The name of the image to retrieve from the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ImageList.ImageCollection Class
ImageList.ImageCollection Members
Overload List


Item(Int32) Property

[image]
Gizmox.WebGUI.Forms
Item(Int32) Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ImageList.ImageCollection Class > Item Property : Item(Int32) Property

index
The index of the image to get or set.
Gets or sets an Gizmox.WebGUI.Common.Resources.ResourceHandle at the specified index within the collection.

Syntax

Visual Basic (Declaration)
Public Overloads Property Item( _
   ByVal index As Integer _
) As ResourceHandle
Visual Basic (Usage) Copy Code
Dim instance As ImageList.ImageCollection
Dim index As Integer
Dim value As ResourceHandle

instance.Item(index) = value

value = instance.Item(index)
C#
public ResourceHandle Item(
   int index
) {get; set;}
Managed Extensions for C++
public: __property ResourceHandle* get_Item(
   int index
);
public: __property void set_Item(
   int index,
   ResourceHandle* value
);
C++/CLI
public:
property ResourceHandle^ Item {
   ResourceHandle^ get(intindex);
   void set (intindex, ResourceHandle^value);
}

Parameters

index
The index of the image to get or set.

Exceptions

Exception | Description
ArgumentOutOfRangeException | The index is less than 0 or greater than or equal to Count.
InvalidOperationException | The image cannot be added to the list.
ArgumentException | image is not aBitmap.
ArgumentNullException | The image to be assigned is null or not a Bitmap.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ImageList.ImageCollection Class
ImageList.ImageCollection Members
Overload List


Keys Property

[image]
Gizmox.WebGUI.Forms
Keys Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ImageList.ImageCollection Class : Keys Property

Gets the collection of keys associated with the images in the ImageList.ImageCollection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Keys As StringCollection
Visual Basic (Usage) Copy Code
Dim instance As ImageList.ImageCollection
Dim value As StringCollection

value = instance.Keys
C#
public StringCollection Keys {get;}
Managed Extensions for C++
public: __property StringCollection* get_Keys();
C++/CLI
public:
property StringCollection^ Keys {
   StringCollection^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ImageList.ImageCollection Class
ImageList.ImageCollection Members


ItemChangedEventArgs Class

[image]
Gizmox.WebGUI.Forms
ItemChangedEventArgs Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ItemChangedEventArgs Class

Provides data for the ItemChanged event.

Syntax

Visual Basic (Declaration)
Public Class ItemChangedEventArgs
   Inherits EventArgs
Visual Basic (Usage) Copy Code
Dim instance As ItemChangedEventArgs
C#
public class ItemChangedEventArgs : EventArgs
Managed Extensions for C++
public __gc class ItemChangedEventArgs : public EventArgs
C++/CLI
public ref class ItemChangedEventArgs : public EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gizmox.WebGUI.Forms.ItemChangedEventArgs

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

ItemChangedEventArgs Members
Gizmox.WebGUI.Forms Namespace


ItemChangedEventArgs Class Members

[image]
Gizmox.WebGUI.Forms
ItemChangedEventArgs Class Members
See Also Properties Send Feedback
Gizmox.WebGUI.Forms Namespace : ItemChangedEventArgs Class

The following tables list the members exposed by ItemChangedEventArgs.

Public Properties

 | Name | Description
Public Property | Index | Indicates the position of the item being changed within the list.
Top

See Also

Reference

ItemChangedEventArgs Class
Gizmox.WebGUI.Forms Namespace


ItemChangedEventArgs Class Properties

[image]
Gizmox.WebGUI.Forms
ItemChangedEventArgs Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ItemChangedEventArgs Class

For a list of all members of this type, see ItemChangedEventArgs members.

Public Properties

 | Name | Description
Public Property | Index | Indicates the position of the item being changed within the list.
Top

See Also

Reference

ItemChangedEventArgs Class
Gizmox.WebGUI.Forms Namespace


Index Property

[image]
Gizmox.WebGUI.Forms
Index Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ItemChangedEventArgs Class : Index Property

Indicates the position of the item being changed within the list.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Index As Integer
Visual Basic (Usage) Copy Code
Dim instance As ItemChangedEventArgs
Dim value As Integer

value = instance.Index
C#
public int Index {get;}
Managed Extensions for C++
public: __property int get_Index();
C++/CLI
public:
property int Index {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ItemChangedEventArgs Class
ItemChangedEventArgs Members


ItemCheckEventArgs Class

[image]
Gizmox.WebGUI.Forms
ItemCheckEventArgs Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ItemCheckEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class ItemCheckEventArgs
   Inherits EventArgs
Visual Basic (Usage) Copy Code
Dim instance As ItemCheckEventArgs
C#
public class ItemCheckEventArgs : EventArgs
Managed Extensions for C++
public __gc class ItemCheckEventArgs : public EventArgs
C++/CLI
public ref class ItemCheckEventArgs : public EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gizmox.WebGUI.Forms.ItemCheckEventArgs

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

ItemCheckEventArgs Members
Gizmox.WebGUI.Forms Namespace


ItemCheckEventArgs Class Members

[image]
Gizmox.WebGUI.Forms
ItemCheckEventArgs Class Members
See Also Properties Send Feedback
Gizmox.WebGUI.Forms Namespace : ItemCheckEventArgs Class

The following tables list the members exposed by ItemCheckEventArgs.

Public Constructors

 | Name | Description
Public Constructor | ItemCheckEventArgs Constructor | Creates a new ItemCheckEventArgs instance.
Top

Public Properties

 | Name | Description
Public Property | CurrentValue | Gets the current value.
Public Property | Index | Gets the index.
Public Property | NewValue | Gets or sets the new value.
Top

See Also

Reference

ItemCheckEventArgs Class
Gizmox.WebGUI.Forms Namespace


ItemCheckEventArgs Constructor

[image]
Gizmox.WebGUI.Forms
ItemCheckEventArgs Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ItemCheckEventArgs Class : ItemCheckEventArgs Constructor

intIndex
Int index.
enmNewCheckValue
Enm new check value.
enmCurrentValue
Enm current value.
Creates a new ItemCheckEventArgs instance.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal intIndex As Integer, _
   ByVal enmNewCheckValue As CheckState, _
   ByVal enmCurrentValue As CheckState _
)
Visual Basic (Usage) Copy Code
Dim intIndex As Integer
Dim enmNewCheckValue As CheckState
Dim enmCurrentValue As CheckState

Dim instance As ItemCheckEventArgs(intIndex, enmNewCheckValue, enmCurrentValue)
C#
public ItemCheckEventArgs(
   int intIndex,
   CheckState enmNewCheckValue,
   CheckState enmCurrentValue
)
Managed Extensions for C++
public: ItemCheckEventArgs(
   int intIndex,
   CheckState enmNewCheckValue,
   CheckState enmCurrentValue
)
C++/CLI
public:
ItemCheckEventArgs(
   int intIndex,
   CheckState enmNewCheckValue,
   CheckState enmCurrentValue
)

Parameters

intIndex
Int index.
enmNewCheckValue
Enm new check value.
enmCurrentValue
Enm current value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ItemCheckEventArgs Class
ItemCheckEventArgs Members


ItemCheckEventArgs Class Properties

[image]
Gizmox.WebGUI.Forms
ItemCheckEventArgs Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ItemCheckEventArgs Class

For a list of all members of this type, see ItemCheckEventArgs members.

Public Properties

 | Name | Description
Public Property | CurrentValue | Gets the current value.
Public Property | Index | Gets the index.
Public Property | NewValue | Gets or sets the new value.
Top

See Also

Reference

ItemCheckEventArgs Class
Gizmox.WebGUI.Forms Namespace


CurrentValue Property

[image]
Gizmox.WebGUI.Forms
CurrentValue Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ItemCheckEventArgs Class : CurrentValue Property

Gets the current value.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CurrentValue As CheckState
Visual Basic (Usage) Copy Code
Dim instance As ItemCheckEventArgs
Dim value As CheckState

value = instance.CurrentValue
C#
public CheckState CurrentValue {get;}
Managed Extensions for C++
public: __property CheckState get_CurrentValue();
C++/CLI
public:
property CheckState CurrentValue {
   CheckState get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ItemCheckEventArgs Class
ItemCheckEventArgs Members


Index Property

[image]
Gizmox.WebGUI.Forms
Index Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ItemCheckEventArgs Class : Index Property

Gets the index.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Index As Integer
Visual Basic (Usage) Copy Code
Dim instance As ItemCheckEventArgs
Dim value As Integer

value = instance.Index
C#
public int Index {get;}
Managed Extensions for C++
public: __property int get_Index();
C++/CLI
public:
property int Index {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ItemCheckEventArgs Class
ItemCheckEventArgs Members


NewValue Property

[image]
Gizmox.WebGUI.Forms
NewValue Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ItemCheckEventArgs Class : NewValue Property

Gets or sets the new value.

Syntax

Visual Basic (Declaration)
Public Property NewValue As CheckState
Visual Basic (Usage) Copy Code
Dim instance As ItemCheckEventArgs
Dim value As CheckState

instance.NewValue = value

value = instance.NewValue
C#
public CheckState NewValue {get; set;}
Managed Extensions for C++
public: __property CheckState get_NewValue();
public: __property void set_NewValue(
   CheckState value
);
C++/CLI
public:
property CheckState NewValue {
   CheckState get();
   void set (CheckStatevalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ItemCheckEventArgs Class
ItemCheckEventArgs Members


KeyEventArgs Class

[image]
Gizmox.WebGUI.Forms
KeyEventArgs Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : KeyEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class KeyEventArgs
   Inherits EventArgs
Visual Basic (Usage) Copy Code
Dim instance As KeyEventArgs
C#
public class KeyEventArgs : EventArgs
Managed Extensions for C++
public __gc class KeyEventArgs : public EventArgs
C++/CLI
public ref class KeyEventArgs : public EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gizmox.WebGUI.Forms.KeyEventArgs

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

KeyEventArgs Members
Gizmox.WebGUI.Forms Namespace


KeyEventArgs Class Members

[image]
Gizmox.WebGUI.Forms
KeyEventArgs Class Members
See Also Properties Send Feedback
Gizmox.WebGUI.Forms Namespace : KeyEventArgs Class

The following tables list the members exposed by KeyEventArgs.

Public Constructors

 | Name | Description
Public Constructor | KeyEventArgs Constructor |
Top

Public Properties

 | Name | Description
Public Property | Alt |
Public Property | Control |
Public Property | Handled | Gets or sets a value indicating whether the event was handled.
Public Property | KeyCode |
Public Property | KeyData |
Public Property | KeyValue |
Public Property | Modifiers | Gets the modifier flags for a KeyDown or KeyUp event. The flags indicate which combination of CTRL, SHIFT, and ALT keys was pressed.
Public Property | Shift |
Top

See Also

Reference

KeyEventArgs Class
Gizmox.WebGUI.Forms Namespace


KeyEventArgs Constructor

[image]
Gizmox.WebGUI.Forms
KeyEventArgs Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > KeyEventArgs Class : KeyEventArgs Constructor

enmKeyData

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal enmKeyData As Keys _
)
Visual Basic (Usage) Copy Code
Dim enmKeyData As Keys

Dim instance As KeyEventArgs(enmKeyData)
C#
public KeyEventArgs(
   Keys enmKeyData
)
Managed Extensions for C++
public: KeyEventArgs(
   Keys enmKeyData
)
C++/CLI
public:
KeyEventArgs(
   Keys enmKeyData
)

Parameters

enmKeyData

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

KeyEventArgs Class
KeyEventArgs Members


KeyEventArgs Class Properties

[image]
Gizmox.WebGUI.Forms
KeyEventArgs Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : KeyEventArgs Class

For a list of all members of this type, see KeyEventArgs members.

Public Properties

 | Name | Description
Public Property | Alt |
Public Property | Control |
Public Property | Handled | Gets or sets a value indicating whether the event was handled.
Public Property | KeyCode |
Public Property | KeyData |
Public Property | KeyValue |
Public Property | Modifiers | Gets the modifier flags for a KeyDown or KeyUp event. The flags indicate which combination of CTRL, SHIFT, and ALT keys was pressed.
Public Property | Shift |
Top

See Also

Reference

KeyEventArgs Class
Gizmox.WebGUI.Forms Namespace


Alt Property

[image]
Gizmox.WebGUI.Forms
Alt Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > KeyEventArgs Class : Alt Property

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Alt As Boolean
Visual Basic (Usage) Copy Code
Dim instance As KeyEventArgs
Dim value As Boolean

value = instance.Alt
C#
public virtual bool Alt {get;}
Managed Extensions for C++
public: __property virtual bool get_Alt();
C++/CLI
public:
virtual property bool Alt {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

KeyEventArgs Class
KeyEventArgs Members


Control Property

[image]
Gizmox.WebGUI.Forms
Control Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > KeyEventArgs Class : Control Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Control As Boolean
Visual Basic (Usage) Copy Code
Dim instance As KeyEventArgs
Dim value As Boolean

value = instance.Control
C#
public bool Control {get;}
Managed Extensions for C++
public: __property bool get_Control();
C++/CLI
public:
property bool Control {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

KeyEventArgs Class
KeyEventArgs Members


Handled Property

[image]
Gizmox.WebGUI.Forms
Handled Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > KeyEventArgs Class : Handled Property

Gets or sets a value indicating whether the event was handled.

Syntax

Visual Basic (Declaration)
Public Property Handled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As KeyEventArgs
Dim value As Boolean

instance.Handled = value

value = instance.Handled
C#
public bool Handled {get; set;}
Managed Extensions for C++
public: __property bool get_Handled();
public: __property void set_Handled(
   bool value
);
C++/CLI
public:
property bool Handled {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

KeyEventArgs Class
KeyEventArgs Members


KeyCode Property

[image]
Gizmox.WebGUI.Forms
KeyCode Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > KeyEventArgs Class : KeyCode Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property KeyCode As Keys
Visual Basic (Usage) Copy Code
Dim instance As KeyEventArgs
Dim value As Keys

value = instance.KeyCode
C#
public Keys KeyCode {get;}
Managed Extensions for C++
public: __property Keys get_KeyCode();
C++/CLI
public:
property Keys KeyCode {
   Keys get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

KeyEventArgs Class
KeyEventArgs Members


KeyData Property

[image]
Gizmox.WebGUI.Forms
KeyData Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > KeyEventArgs Class : KeyData Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property KeyData As Keys
Visual Basic (Usage) Copy Code
Dim instance As KeyEventArgs
Dim value As Keys

value = instance.KeyData
C#
public Keys KeyData {get;}
Managed Extensions for C++
public: __property Keys get_KeyData();
C++/CLI
public:
property Keys KeyData {
   Keys get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

KeyEventArgs Class
KeyEventArgs Members


KeyValue Property

[image]
Gizmox.WebGUI.Forms
KeyValue Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > KeyEventArgs Class : KeyValue Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property KeyValue As Integer
Visual Basic (Usage) Copy Code
Dim instance As KeyEventArgs
Dim value As Integer

value = instance.KeyValue
C#
public int KeyValue {get;}
Managed Extensions for C++
public: __property int get_KeyValue();
C++/CLI
public:
property int KeyValue {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

KeyEventArgs Class
KeyEventArgs Members


Modifiers Property

[image]
Gizmox.WebGUI.Forms
Modifiers Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > KeyEventArgs Class : Modifiers Property

Gets the modifier flags for a KeyDown or KeyUp event. The flags indicate which combination of CTRL, SHIFT, and ALT keys was pressed.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Modifiers As Keys
Visual Basic (Usage) Copy Code
Dim instance As KeyEventArgs
Dim value As Keys

value = instance.Modifiers
C#
public Keys Modifiers {get;}
Managed Extensions for C++
public: __property Keys get_Modifiers();
C++/CLI
public:
property Keys Modifiers {
   Keys get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

KeyEventArgs Class
KeyEventArgs Members


Shift Property

[image]
Gizmox.WebGUI.Forms
Shift Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > KeyEventArgs Class : Shift Property

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Shift As Boolean
Visual Basic (Usage) Copy Code
Dim instance As KeyEventArgs
Dim value As Boolean

value = instance.Shift
C#
public virtual bool Shift {get;}
Managed Extensions for C++
public: __property virtual bool get_Shift();
C++/CLI
public:
virtual property bool Shift {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

KeyEventArgs Class
KeyEventArgs Members


KeyPressEventArgs Class

[image]
Gizmox.WebGUI.Forms
KeyPressEventArgs Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : KeyPressEventArgs Class

Provides data for the KeyPress event.

Syntax

Visual Basic (Declaration)
Public Class KeyPressEventArgs
   Inherits EventArgs
Visual Basic (Usage) Copy Code
Dim instance As KeyPressEventArgs
C#
public class KeyPressEventArgs : EventArgs
Managed Extensions for C++
public __gc class KeyPressEventArgs : public EventArgs
C++/CLI
public ref class KeyPressEventArgs : public EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gizmox.WebGUI.Forms.KeyPressEventArgs

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

KeyPressEventArgs Members
Gizmox.WebGUI.Forms Namespace


KeyPressEventArgs Class Members

[image]
Gizmox.WebGUI.Forms
KeyPressEventArgs Class Members
See Also Properties Send Feedback
Gizmox.WebGUI.Forms Namespace : KeyPressEventArgs Class

The following tables list the members exposed by KeyPressEventArgs.

Public Constructors

 | Name | Description
Public Constructor | KeyPressEventArgs Constructor | Initializes a new instance of the KeyPressEventArgs class.
Top

Public Properties

 | Name | Description
Public Property | Handled | Gets or sets a value indicating whether the KeyPress event was handled.
Public Property | KeyChar | Gets or sets the character corresponding to the key pressed.
Top

See Also

Reference

KeyPressEventArgs Class
Gizmox.WebGUI.Forms Namespace


KeyPressEventArgs Constructor

[image]
Gizmox.WebGUI.Forms
KeyPressEventArgs Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > KeyPressEventArgs Class : KeyPressEventArgs Constructor

keyChar
The ASCII character corresponding to the key the user pressed.
Initializes a new instance of the KeyPressEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal keyChar As Char _
)
Visual Basic (Usage) Copy Code
Dim keyChar As Char

Dim instance As KeyPressEventArgs(keyChar)
C#
public KeyPressEventArgs(
   char keyChar
)
Managed Extensions for C++
public: KeyPressEventArgs(
   char keyChar
)
C++/CLI
public:
KeyPressEventArgs(
   char keyChar
)

Parameters

keyChar
The ASCII character corresponding to the key the user pressed.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

KeyPressEventArgs Class
KeyPressEventArgs Members


KeyPressEventArgs Class Properties

[image]
Gizmox.WebGUI.Forms
KeyPressEventArgs Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : KeyPressEventArgs Class

For a list of all members of this type, see KeyPressEventArgs members.

Public Properties

 | Name | Description
Public Property | Handled | Gets or sets a value indicating whether the KeyPress event was handled.
Public Property | KeyChar | Gets or sets the character corresponding to the key pressed.
Top

See Also

Reference

KeyPressEventArgs Class
Gizmox.WebGUI.Forms Namespace


Handled Property

[image]
Gizmox.WebGUI.Forms
Handled Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > KeyPressEventArgs Class : Handled Property

Gets or sets a value indicating whether the KeyPress event was handled.

Syntax

Visual Basic (Declaration)
Public Property Handled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As KeyPressEventArgs
Dim value As Boolean

instance.Handled = value

value = instance.Handled
C#
public bool Handled {get; set;}
Managed Extensions for C++
public: __property bool get_Handled();
public: __property void set_Handled(
   bool value
);
C++/CLI
public:
property bool Handled {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

KeyPressEventArgs Class
KeyPressEventArgs Members


KeyChar Property

[image]
Gizmox.WebGUI.Forms
KeyChar Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > KeyPressEventArgs Class : KeyChar Property

Gets or sets the character corresponding to the key pressed.

Syntax

Visual Basic (Declaration)
Public Property KeyChar As Char
Visual Basic (Usage) Copy Code
Dim instance As KeyPressEventArgs
Dim value As Char

instance.KeyChar = value

value = instance.KeyChar
C#
public char KeyChar {get; set;}
Managed Extensions for C++
public: __property char get_KeyChar();
public: __property void set_KeyChar(
   char value
);
C++/CLI
public:
property char KeyChar {
   char get();
   void set (charvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

KeyPressEventArgs Class
KeyPressEventArgs Members


Label Class

[image]
Gizmox.WebGUI.Forms
Label Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : Label Class

Represents a standard Gizmox.WebGUI label.

Object Model

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Provides run-time information or descriptive text for a control.")>
<ClientControllerAttribute()>
<DesignTimeControllerAttribute()>
<ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<DefaultPropertyAttribute("Text")>
<ToolboxItemCategoryAttribute("Common Controls")>
<ToolboxBitmapAttribute()>
<MetadataTagAttribute("L")>
<SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableLabel, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")>
Public Class Label
   Inherits Control
   Implements IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Visual Basic (Usage) Copy Code
Dim instance As Label
C#
[SRDescriptionAttribute("Provides run-time information or descriptive text for a control.")]
[ClientControllerAttribute()]
[DesignTimeControllerAttribute()]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[DefaultPropertyAttribute("Text")]
[ToolboxItemCategoryAttribute("Common Controls")]
[ToolboxBitmapAttribute()]
[MetadataTagAttribute("L")]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableLabel, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
public class Label : Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Managed Extensions for C++
[SRDescriptionAttribute("Provides run-time information or descriptive text for a control.")]
[ClientControllerAttribute()]
[DesignTimeControllerAttribute()]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[DefaultPropertyAttribute("Text")]
[ToolboxItemCategoryAttribute("Common Controls")]
[ToolboxBitmapAttribute()]
[MetadataTagAttribute("L")]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableLabel, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
public __gc class Label : public Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
C++/CLI
[SRDescriptionAttribute("Provides run-time information or descriptive text for a control.")]
[ClientControllerAttribute()]
[DesignTimeControllerAttribute()]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[DefaultPropertyAttribute("Text")]
[ToolboxItemCategoryAttribute("Common Controls")]
[ToolboxBitmapAttribute()]
[MetadataTagAttribute("L")]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableLabel, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
public ref class Label : public Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.Label
Gizmox.WebGUI.Forms.LinkLabel

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Label Members
Gizmox.WebGUI.Forms Namespace


Label Class Members

[image]
Gizmox.WebGUI.Forms
Label Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : Label Class

The following tables list the members exposed by Label.

Public Constructors

 | Name | Description
Public Constructor | Label Constructor | Overloaded. Initializes a new instance of the Label class.
Top

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | AutoSize | Gets or sets a value indicating whether the control is automatically resized to display its entire contents.
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | FlatStyle | Gets or sets the flat style appearance of the label control.
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | Image | Gets or sets the image that is displayed on a button control.
Public Property | ImageAlign | Gets or sets the alignment of the image on the button control.
Public Property | ImageIndex | Gets or sets the index of the image that is displayed for the item.
Public Property | ImageKey | Gets or sets the key for the image that is displayed for the item.
Public Property | ImageList | Gets or sets the ImageList to use when displaying items as small icons in the control.
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Overridden. Gets or sets the text associated with this control.
Public Property | TextAlign | Gets or sets the alignment of text in the label.
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | Overridden.
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Control)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from Control)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Control)
Protected Method | RenderAttributes | Overridden.
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Overridden. Renders the controls sub tree
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeImage | Shoulds the serialize image.
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

Label Class
Gizmox.WebGUI.Forms Namespace


Label Constructor

[image]
Gizmox.WebGUI.Forms
Label Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Label Class : Label Constructor

Initializes a new instance of the Label class.

Overload List

Overload | Description
Label Constructor() | Initializes a new instance of the Label class.
Label Constructor(String) | Initializes a new instance of the Label class.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Label Class
Label Members


Label Constructor()

[image]
Gizmox.WebGUI.Forms
Label Constructor()
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Label Class > Label Constructor : Label Constructor()

Initializes a new instance of the Label class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Label()
C#
public Label()
Managed Extensions for C++
public: Label();
C++/CLI
public:
Label();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Label Class
Label Members
Overload List


Label Constructor(String)

[image]
Gizmox.WebGUI.Forms
Label Constructor(String)
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Label Class > Label Constructor : Label Constructor(String)

strText
The label text.
Initializes a new instance of the Label class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal strText As String _
)
Visual Basic (Usage) Copy Code
Dim strText As String

Dim instance As Label(strText)
C#
public Label(
   string strText
)
Managed Extensions for C++
public: Label(
   string* strText
)
C++/CLI
public:
Label(
   String^ strText
)

Parameters

strText
The label text.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Label Class
Label Members
Overload List


Label Class Methods

[image]
Gizmox.WebGUI.Forms
Label Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : Label Class

For a list of all members of this type, see Label members.

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | Overridden.
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Control)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from Control)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Control)
Protected Method | RenderAttributes | Overridden.
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Overridden. Renders the controls sub tree
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeImage | Shoulds the serialize image.
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

See Also

Reference

Label Class
Gizmox.WebGUI.Forms Namespace


GetPreferredSize Method

[image]
Gizmox.WebGUI.Forms
GetPreferredSize Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Label Class : GetPreferredSize Method

proposedSize

Syntax

Visual Basic (Declaration)
Public Overrides Function GetPreferredSize( _
   ByVal proposedSize As Size _
) As Size
Visual Basic (Usage) Copy Code
Dim instance As Label
Dim proposedSize As Size
Dim value As Size

value = instance.GetPreferredSize(proposedSize)
C#
public override Size GetPreferredSize(
   Size proposedSize
)
Managed Extensions for C++
public: Size GetPreferredSize(
   Size proposedSize
) override
C++/CLI
public:
Size GetPreferredSize(
   Size proposedSize
) override

Parameters

proposedSize

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Label Class
Label Members


RenderAttributes Method

[image]
Gizmox.WebGUI.Forms
RenderAttributes Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Label Class : RenderAttributes Method

objContext
objWriter

Syntax

Visual Basic (Declaration)
Protected Overrides Sub RenderAttributes( _
   ByVal objContext As IContext, _
   ByVal objWriter As IAttributeWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As Label
Dim objContext As IContext
Dim objWriter As IAttributeWriter

instance.RenderAttributes(objContext, objWriter)
C#
protected override void RenderAttributes(
   IContext objContext,
   IAttributeWriter objWriter
)
Managed Extensions for C++
protected: void RenderAttributes(
   IContext* objContext,
   IAttributeWriter* objWriter
) override
C++/CLI
protected:
void RenderAttributes(
   IContext^ objContext,
   IAttributeWriter^ objWriter
) override

Parameters

objContext
objWriter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Label Class
Label Members


RenderControls Method

[image]
Gizmox.WebGUI.Forms
RenderControls Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Label Class : RenderControls Method

Renders the controls sub tree

Overload List

Overload | Description
RenderControls(IContext,IResponseWriter,Int64,Boolean) | Renders the controls sub tree
RenderControls(IContext,IResponseWriter,Int64) | Renders the controls sub tree (Inherited from Control)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Label Class
Label Members


RenderControls(IContext,IResponseWriter,Int64,Boolean) Method

[image]
Gizmox.WebGUI.Forms
RenderControls(IContext,IResponseWriter,Int64,Boolean) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Label Class > RenderControls Method : RenderControls(IContext,IResponseWriter,Int64,Boolean) Method

objContext
objWriter
lngRequestID
blnRenderOwner
Renders the controls sub tree

Syntax

Visual Basic (Declaration)
Protected Overloads Overrides Sub RenderControls( _
   ByVal objContext As IContext, _
   ByVal objWriter As IResponseWriter, _
   ByVal lngRequestID As Long, _
   ByVal blnRenderOwner As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As Label
Dim objContext As IContext
Dim objWriter As IResponseWriter
Dim lngRequestID As Long
Dim blnRenderOwner As Boolean

instance.RenderControls(objContext, objWriter, lngRequestID, blnRenderOwner)
C#
protected override void RenderControls(
   IContext objContext,
   IResponseWriter objWriter,
   long lngRequestID,
   bool blnRenderOwner
)
Managed Extensions for C++
protected: void RenderControls(
   IContext* objContext,
   IResponseWriter* objWriter,
   long lngRequestID,
   bool blnRenderOwner
) override
C++/CLI
protected:
void RenderControls(
   IContext^ objContext,
   IResponseWriter^ objWriter,
   long long lngRequestID,
   bool blnRenderOwner
) override

Parameters

objContext
objWriter
lngRequestID
blnRenderOwner

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Label Class
Label Members
Overload List


ShouldSerializeImage Method

[image]
Gizmox.WebGUI.Forms
ShouldSerializeImage Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Label Class : ShouldSerializeImage Method

Shoulds the serialize image.

Syntax

Visual Basic (Declaration)
Protected Function ShouldSerializeImage() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Label
Dim value As Boolean

value = instance.ShouldSerializeImage()
C#
protected bool ShouldSerializeImage()
Managed Extensions for C++
protected: bool ShouldSerializeImage();
C++/CLI
protected:
bool ShouldSerializeImage();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Label Class
Label Members


Label Class Properties

[image]
Gizmox.WebGUI.Forms
Label Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : Label Class

For a list of all members of this type, see Label members.

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | AutoSize | Gets or sets a value indicating whether the control is automatically resized to display its entire contents.
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | FlatStyle | Gets or sets the flat style appearance of the label control.
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | Image | Gets or sets the image that is displayed on a button control.
Public Property | ImageAlign | Gets or sets the alignment of the image on the button control.
Public Property | ImageIndex | Gets or sets the index of the image that is displayed for the item.
Public Property | ImageKey | Gets or sets the key for the image that is displayed for the item.
Public Property | ImageList | Gets or sets the ImageList to use when displaying items as small icons in the control.
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Overridden. Gets or sets the text associated with this control.
Public Property | TextAlign | Gets or sets the alignment of text in the label.
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

See Also

Reference

Label Class
Gizmox.WebGUI.Forms Namespace


AutoSize Property

[image]
Gizmox.WebGUI.Forms
AutoSize Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Label Class : AutoSize Property

Gets or sets a value indicating whether the control is automatically resized to display its entire contents.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(True)>
<DefaultValueAttribute()>
<EditorBrowsableAttribute()>
<SRDescriptionAttribute("Enables automatic resizing based on font size. Note that this is only valid for label controls that do not wrap text.")>
<SRCategoryAttribute("Layout")>
<RefreshPropertiesAttribute()>
<LocalizableAttribute(True)>
<DesignerSerializationVisibilityAttribute()>
Public Property AutoSize As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Label
Dim value As Boolean

instance.AutoSize = value

value = instance.AutoSize
C#
[BrowsableAttribute(true)]
[DefaultValueAttribute()]
[EditorBrowsableAttribute()]
[SRDescriptionAttribute("Enables automatic resizing based on font size. Note that this is only valid for label controls that do not wrap text.")]
[SRCategoryAttribute("Layout")]
[RefreshPropertiesAttribute()]
[LocalizableAttribute(true)]
[DesignerSerializationVisibilityAttribute()]
public bool AutoSize {get; set;}
Managed Extensions for C++
[BrowsableAttribute(true)]
[DefaultValueAttribute()]
[EditorBrowsableAttribute()]
[SRDescriptionAttribute("Enables automatic resizing based on font size. Note that this is only valid for label controls that do not wrap text.")]
[SRCategoryAttribute("Layout")]
[RefreshPropertiesAttribute()]
[LocalizableAttribute(true)]
[DesignerSerializationVisibilityAttribute()]
public: __property bool get_AutoSize();
public: __property void set_AutoSize(
   bool value
);
C++/CLI
[BrowsableAttribute(true)]
[DefaultValueAttribute()]
[EditorBrowsableAttribute()]
[SRDescriptionAttribute("Enables automatic resizing based on font size. Note that this is only valid for label controls that do not wrap text.")]
[SRCategoryAttribute("Layout")]
[RefreshPropertiesAttribute()]
[LocalizableAttribute(true)]
[DesignerSerializationVisibilityAttribute()]
public:
property bool AutoSize {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Label Class
Label Members


FlatStyle Property

[image]
Gizmox.WebGUI.Forms
FlatStyle Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Label Class : FlatStyle Property

Gets or sets the flat style appearance of the label control.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Determines the appearance of the control when a user moves the mouse over the control and clicks.")>
<SRCategoryAttribute("Appearance")>
<DefaultValueAttribute()>
Public Property FlatStyle As FlatStyle
Visual Basic (Usage) Copy Code
Dim instance As Label
Dim value As FlatStyle

instance.FlatStyle = value

value = instance.FlatStyle
C#
[SRDescriptionAttribute("Determines the appearance of the control when a user moves the mouse over the control and clicks.")]
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
public FlatStyle FlatStyle {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Determines the appearance of the control when a user moves the mouse over the control and clicks.")]
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
public: __property FlatStyle get_FlatStyle();
public: __property void set_FlatStyle(
   FlatStyle value
);
C++/CLI
[SRDescriptionAttribute("Determines the appearance of the control when a user moves the mouse over the control and clicks.")]
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
public:
property FlatStyle FlatStyle {
   FlatStyle get();
   void set (FlatStylevalue);
}

Exceptions

Exception | Description
InvalidEnumArgumentException | The value assigned is not one of the FlatStyle values.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Label Class
Label Members


Image Property

[image]
Gizmox.WebGUI.Forms
Image Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Label Class : Image Property

Gets or sets the image that is displayed on a button control.

Syntax

Visual Basic (Declaration)
Public Property Image As ResourceHandle
Visual Basic (Usage) Copy Code
Dim instance As Label
Dim value As ResourceHandle

instance.Image = value

value = instance.Image
C#
public ResourceHandle Image {get; set;}
Managed Extensions for C++
public: __property ResourceHandle* get_Image();
public: __property void set_Image(
   ResourceHandle* value
);
C++/CLI
public:
property ResourceHandle^ Image {
   ResourceHandle^ get();
   void set (ResourceHandle^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Label Class
Label Members


ImageAlign Property

[image]
Gizmox.WebGUI.Forms
ImageAlign Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Label Class : ImageAlign Property

Gets or sets the alignment of the image on the button control.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property ImageAlign As ContentAlignment
Visual Basic (Usage) Copy Code
Dim instance As Label
Dim value As ContentAlignment

instance.ImageAlign = value

value = instance.ImageAlign
C#
[DefaultValueAttribute()]
public ContentAlignment ImageAlign {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property ContentAlignment get_ImageAlign();
public: __property void set_ImageAlign(
   ContentAlignment value
);
C++/CLI
[DefaultValueAttribute()]
public:
property ContentAlignment ImageAlign {
   ContentAlignment get();
   void set (ContentAlignmentvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Label Class
Label Members


ImageIndex Property

[image]
Gizmox.WebGUI.Forms
ImageIndex Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Label Class : ImageIndex Property

Gets or sets the index of the image that is displayed for the item.

Syntax

Visual Basic (Declaration)
<LocalizableAttribute(True)>
<RefreshPropertiesAttribute()>
<SRCategoryAttribute("Behavior")>
<TypeConverterAttribute("Gizmox.WebGUI.Forms.Design.NoneExcludedImageIndexConverter, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")>
<DefaultValueAttribute()>
<EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.ImageIndexEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")>
<SRDescriptionAttribute("The ImageList index value of the image displayed when the list view item is in the unselected state.")>
Public Property ImageIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As Label
Dim value As Integer

instance.ImageIndex = value

value = instance.ImageIndex
C#
[LocalizableAttribute(true)]
[RefreshPropertiesAttribute()]
[SRCategoryAttribute("Behavior")]
[TypeConverterAttribute("Gizmox.WebGUI.Forms.Design.NoneExcludedImageIndexConverter, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[DefaultValueAttribute()]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.ImageIndexEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[SRDescriptionAttribute("The ImageList index value of the image displayed when the list view item is in the unselected state.")]
public int ImageIndex {get; set;}
Managed Extensions for C++
[LocalizableAttribute(true)]
[RefreshPropertiesAttribute()]
[SRCategoryAttribute("Behavior")]
[TypeConverterAttribute("Gizmox.WebGUI.Forms.Design.NoneExcludedImageIndexConverter, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[DefaultValueAttribute()]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.ImageIndexEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[SRDescriptionAttribute("The ImageList index value of the image displayed when the list view item is in the unselected state.")]
public: __property int get_ImageIndex();
public: __property void set_ImageIndex(
   int value
);
C++/CLI
[LocalizableAttribute(true)]
[RefreshPropertiesAttribute()]
[SRCategoryAttribute("Behavior")]
[TypeConverterAttribute("Gizmox.WebGUI.Forms.Design.NoneExcludedImageIndexConverter, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[DefaultValueAttribute()]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.ImageIndexEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[SRDescriptionAttribute("The ImageList index value of the image displayed when the list view item is in the unselected state.")]
public:
property int ImageIndex {
   int get();
   void set (intvalue);
}

Exceptions

Exception | Description
ArgumentException | The value specified is less than -1.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Label Class
Label Members


ImageKey Property

[image]
Gizmox.WebGUI.Forms
ImageKey Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Label Class : ImageKey Property

Gets or sets the key for the image that is displayed for the item.

Syntax

Visual Basic (Declaration)
<LocalizableAttribute(True)>
<DefaultValueAttribute()>
<TypeConverterAttribute("Gizmox.WebGUI.Forms.Design.ImageKeyConverter, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")>
<RefreshPropertiesAttribute()>
<EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.ImageIndexEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")>
<SRCategoryAttribute("Behavior")>
Public Property ImageKey As String
Visual Basic (Usage) Copy Code
Dim instance As Label
Dim value As String

instance.ImageKey = value

value = instance.ImageKey
C#
[LocalizableAttribute(true)]
[DefaultValueAttribute()]
[TypeConverterAttribute("Gizmox.WebGUI.Forms.Design.ImageKeyConverter, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[RefreshPropertiesAttribute()]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.ImageIndexEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[SRCategoryAttribute("Behavior")]
public string ImageKey {get; set;}
Managed Extensions for C++
[LocalizableAttribute(true)]
[DefaultValueAttribute()]
[TypeConverterAttribute("Gizmox.WebGUI.Forms.Design.ImageKeyConverter, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[RefreshPropertiesAttribute()]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.ImageIndexEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[SRCategoryAttribute("Behavior")]
public: __property string* get_ImageKey();
public: __property void set_ImageKey(
   string* value
);
C++/CLI
[LocalizableAttribute(true)]
[DefaultValueAttribute()]
[TypeConverterAttribute("Gizmox.WebGUI.Forms.Design.ImageKeyConverter, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[RefreshPropertiesAttribute()]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.ImageIndexEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[SRCategoryAttribute("Behavior")]
public:
property String^ ImageKey {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Label Class
Label Members


ImageList Property

[image]
Gizmox.WebGUI.Forms
ImageList Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Label Class : ImageList Property

Gets or sets the ImageList to use when displaying items as small icons in the control.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<SRDescriptionAttribute("The ImageList control used by the ListView for images in all views except for the large icon view.")>
<SRCategoryAttribute("Behavior")>
Public Property ImageList As ImageList
Visual Basic (Usage) Copy Code
Dim instance As Label
Dim value As ImageList

instance.ImageList = value

value = instance.ImageList
C#
[DefaultValueAttribute()]
[SRDescriptionAttribute("The ImageList control used by the ListView for images in all views except for the large icon view.")]
[SRCategoryAttribute("Behavior")]
public ImageList ImageList {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[SRDescriptionAttribute("The ImageList control used by the ListView for images in all views except for the large icon view.")]
[SRCategoryAttribute("Behavior")]
public: __property ImageList* get_ImageList();
public: __property void set_ImageList(
   ImageList* value
);
C++/CLI
[DefaultValueAttribute()]
[SRDescriptionAttribute("The ImageList control used by the ListView for images in all views except for the large icon view.")]
[SRCategoryAttribute("Behavior")]
public:
property ImageList^ ImageList {
   ImageList^ get();
   void set (ImageList^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Label Class
Label Members


Text Property

[image]
Gizmox.WebGUI.Forms
Text Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Label Class : Text Property

Gets or sets the text associated with this control.

Syntax

Visual Basic (Declaration)
<EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="System.ComponentModel.Design.MultilineStringEditor, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<SettingsBindableAttribute(True)>
Public Overrides Property Text As String
Visual Basic (Usage) Copy Code
Dim instance As Label
Dim value As String

instance.Text = value

value = instance.Text
C#
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="System.ComponentModel.Design.MultilineStringEditor, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[SettingsBindableAttribute(true)]
public override string Text {get; set;}
Managed Extensions for C++
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="System.ComponentModel.Design.MultilineStringEditor, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[SettingsBindableAttribute(true)]
public: __property string* get_Text() override;
public: __property void set_Text(
   string* value
) override;
C++/CLI
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="System.ComponentModel.Design.MultilineStringEditor, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[SettingsBindableAttribute(true)]
public:
property String^ Text {
   String^ get() override;
   void set (String^value) override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Label Class
Label Members


TextAlign Property

[image]
Gizmox.WebGUI.Forms
TextAlign Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Label Class : TextAlign Property

Gets or sets the alignment of text in the label.

Syntax

Visual Basic (Declaration)
<LocalizableAttribute(True)>
<SRCategoryAttribute("Appearance")>
<DefaultValueAttribute()>
<SRDescriptionAttribute("Determines the position of the text within the label.")>
Public Property TextAlign As ContentAlignment
Visual Basic (Usage) Copy Code
Dim instance As Label
Dim value As ContentAlignment

instance.TextAlign = value

value = instance.TextAlign
C#
[LocalizableAttribute(true)]
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Determines the position of the text within the label.")]
public ContentAlignment TextAlign {get; set;}
Managed Extensions for C++
[LocalizableAttribute(true)]
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Determines the position of the text within the label.")]
public: __property ContentAlignment get_TextAlign();
public: __property void set_TextAlign(
   ContentAlignment value
);
C++/CLI
[LocalizableAttribute(true)]
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Determines the position of the text within the label.")]
public:
property ContentAlignment TextAlign {
   ContentAlignment get();
   void set (ContentAlignmentvalue);
}

Exceptions

Exception | Description
InvalidEnumArgumentException | The value assigned is not one of the ContentAlignment values.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Label Class
Label Members


LayoutEngine Class

[image]
Gizmox.WebGUI.Forms
LayoutEngine Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : LayoutEngine Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class LayoutEngine
Visual Basic (Usage) Copy Code
Dim instance As LayoutEngine
C#
public abstract class LayoutEngine
Managed Extensions for C++
public __gc abstract class LayoutEngine
C++/CLI
public ref class LayoutEngine abstract

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.LayoutEngine

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

LayoutEngine Members
Gizmox.WebGUI.Forms Namespace


LayoutEngine Class Members

[image]
Gizmox.WebGUI.Forms
LayoutEngine Class Members
See Also Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : LayoutEngine Class

The following tables list the members exposed by LayoutEngine.

Public Methods

 | Name | Description
Public Method | InitLayout |
Public Method | Layout |
Top

See Also

Reference

LayoutEngine Class
Gizmox.WebGUI.Forms Namespace


LayoutEngine Class Methods

[image]
Gizmox.WebGUI.Forms
LayoutEngine Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : LayoutEngine Class

For a list of all members of this type, see LayoutEngine members.

Public Methods

 | Name | Description
Public Method | InitLayout |
Public Method | Layout |
Top

See Also

Reference

LayoutEngine Class
Gizmox.WebGUI.Forms Namespace


InitLayout Method

[image]
Gizmox.WebGUI.Forms
InitLayout Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > LayoutEngine Class : InitLayout Method

child
specified

Syntax

Visual Basic (Declaration)
Public Overridable Sub InitLayout( _
   ByVal child As Object, _
   ByVal specified As BoundsSpecified _
)
Visual Basic (Usage) Copy Code
Dim instance As LayoutEngine
Dim child As Object
Dim specified As BoundsSpecified

instance.InitLayout(child, specified)
C#
public virtual void InitLayout(
   object child,
   BoundsSpecified specified
)
Managed Extensions for C++
public: virtual void InitLayout(
   Object* child,
   BoundsSpecified specified
)
C++/CLI
public:
virtual void InitLayout(
   Object^ child,
   BoundsSpecified specified
)

Parameters

child
specified

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LayoutEngine Class
LayoutEngine Members


Layout Method

[image]
Gizmox.WebGUI.Forms
Layout Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > LayoutEngine Class : Layout Method

container
layoutEventArgs

Syntax

Visual Basic (Declaration)
Public Overridable Function Layout( _
   ByVal container As Object, _
   ByVal layoutEventArgs As LayoutEventArgs _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LayoutEngine
Dim container As Object
Dim layoutEventArgs As LayoutEventArgs
Dim value As Boolean

value = instance.Layout(container, layoutEventArgs)
C#
public virtual bool Layout(
   object container,
   LayoutEventArgs layoutEventArgs
)
Managed Extensions for C++
public: virtual bool Layout(
   Object* container,
   LayoutEventArgs* layoutEventArgs
)
C++/CLI
public:
virtual bool Layout(
   Object^ container,
   LayoutEventArgs^ layoutEventArgs
)

Parameters

container
layoutEventArgs

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LayoutEngine Class
LayoutEngine Members


LayoutEventArgs Class

[image]
Gizmox.WebGUI.Forms
LayoutEventArgs Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : LayoutEventArgs Class

Object Model

Syntax

Visual Basic (Declaration)
Public NotInheritable Class LayoutEventArgs
   Inherits EventArgs
Visual Basic (Usage) Copy Code
Dim instance As LayoutEventArgs
C#
public sealed class LayoutEventArgs : EventArgs
Managed Extensions for C++
public __gc __sealed class LayoutEventArgs : public EventArgs
C++/CLI
public ref class LayoutEventArgs sealed : public EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gizmox.WebGUI.Forms.LayoutEventArgs

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

LayoutEventArgs Members
Gizmox.WebGUI.Forms Namespace


LayoutEventArgs Class Members

[image]
Gizmox.WebGUI.Forms
LayoutEventArgs Class Members
See Also Properties Send Feedback
Gizmox.WebGUI.Forms Namespace : LayoutEventArgs Class

The following tables list the members exposed by LayoutEventArgs.

Public Constructors

 | Name | Description
Public Constructor | LayoutEventArgs Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | AffectedComponent |
Public Property | AffectedControl |
Public Property | AffectedProperty |
Top

See Also

Reference

LayoutEventArgs Class
Gizmox.WebGUI.Forms Namespace


LayoutEventArgs Constructor

[image]
Gizmox.WebGUI.Forms
LayoutEventArgs Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > LayoutEventArgs Class : LayoutEventArgs Constructor

Overload List

Overload | Description
LayoutEventArgs Constructor(Control,String) |
LayoutEventArgs Constructor(IComponent,String) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LayoutEventArgs Class
LayoutEventArgs Members


LayoutEventArgs Constructor(Control,String)

[image]
Gizmox.WebGUI.Forms
LayoutEventArgs Constructor(Control,String)
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > LayoutEventArgs Class > LayoutEventArgs Constructor : LayoutEventArgs Constructor(Control,String)

affectedControl
affectedProperty

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal affectedControl As Control, _
   ByVal affectedProperty As String _
)
Visual Basic (Usage) Copy Code
Dim affectedControl As Control
Dim affectedProperty As String

Dim instance As LayoutEventArgs(affectedControl, affectedProperty)
C#
public LayoutEventArgs(
   Control affectedControl,
   string affectedProperty
)
Managed Extensions for C++
public: LayoutEventArgs(
   Control* affectedControl,
   string* affectedProperty
)
C++/CLI
public:
LayoutEventArgs(
   Control^ affectedControl,
   String^ affectedProperty
)

Parameters

affectedControl
affectedProperty

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LayoutEventArgs Class
LayoutEventArgs Members
Overload List


LayoutEventArgs Constructor(IComponent,String)

[image]
Gizmox.WebGUI.Forms
LayoutEventArgs Constructor(IComponent,String)
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > LayoutEventArgs Class > LayoutEventArgs Constructor : LayoutEventArgs Constructor(IComponent,String)

affectedComponent
affectedProperty

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal affectedComponent As IComponent, _
   ByVal affectedProperty As String _
)
Visual Basic (Usage) Copy Code
Dim affectedComponent As IComponent
Dim affectedProperty As String

Dim instance As LayoutEventArgs(affectedComponent, affectedProperty)
C#
public LayoutEventArgs(
   IComponent affectedComponent,
   string affectedProperty
)
Managed Extensions for C++
public: LayoutEventArgs(
   IComponent* affectedComponent,
   string* affectedProperty
)
C++/CLI
public:
LayoutEventArgs(
   IComponent^ affectedComponent,
   String^ affectedProperty
)

Parameters

affectedComponent
affectedProperty

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LayoutEventArgs Class
LayoutEventArgs Members
Overload List


LayoutEventArgs Class Properties

[image]
Gizmox.WebGUI.Forms
LayoutEventArgs Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : LayoutEventArgs Class

For a list of all members of this type, see LayoutEventArgs members.

Public Properties

 | Name | Description
Public Property | AffectedComponent |
Public Property | AffectedControl |
Public Property | AffectedProperty |
Top

See Also

Reference

LayoutEventArgs Class
Gizmox.WebGUI.Forms Namespace


AffectedComponent Property

[image]
Gizmox.WebGUI.Forms
AffectedComponent Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > LayoutEventArgs Class : AffectedComponent Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AffectedComponent As IComponent
Visual Basic (Usage) Copy Code
Dim instance As LayoutEventArgs
Dim value As IComponent

value = instance.AffectedComponent
C#
public IComponent AffectedComponent {get;}
Managed Extensions for C++
public: __property IComponent* get_AffectedComponent();
C++/CLI
public:
property IComponent^ AffectedComponent {
   IComponent^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LayoutEventArgs Class
LayoutEventArgs Members


AffectedControl Property

[image]
Gizmox.WebGUI.Forms
AffectedControl Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > LayoutEventArgs Class : AffectedControl Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AffectedControl As Control
Visual Basic (Usage) Copy Code
Dim instance As LayoutEventArgs
Dim value As Control

value = instance.AffectedControl
C#
public Control AffectedControl {get;}
Managed Extensions for C++
public: __property Control* get_AffectedControl();
C++/CLI
public:
property Control^ AffectedControl {
   Control^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LayoutEventArgs Class
LayoutEventArgs Members


AffectedProperty Property

[image]
Gizmox.WebGUI.Forms
AffectedProperty Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > LayoutEventArgs Class : AffectedProperty Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AffectedProperty As String
Visual Basic (Usage) Copy Code
Dim instance As LayoutEventArgs
Dim value As String

value = instance.AffectedProperty
C#
public string AffectedProperty {get;}
Managed Extensions for C++
public: __property string* get_AffectedProperty();
C++/CLI
public:
property String^ AffectedProperty {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LayoutEventArgs Class
LayoutEventArgs Members


LayoutSettings Class

[image]
Gizmox.WebGUI.Forms
LayoutSettings Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : LayoutSettings Class

Object Model

Syntax

Visual Basic (Declaration)
Public MustInherit Class LayoutSettings
Visual Basic (Usage) Copy Code
Dim instance As LayoutSettings
C#
public abstract class LayoutSettings
Managed Extensions for C++
public __gc abstract class LayoutSettings
C++/CLI
public ref class LayoutSettings abstract

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.LayoutSettings
Gizmox.WebGUI.Forms.TableLayoutSettings

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

LayoutSettings Members
Gizmox.WebGUI.Forms Namespace


LayoutSettings Class Members

[image]
Gizmox.WebGUI.Forms
LayoutSettings Class Members
See Also Properties Send Feedback
Gizmox.WebGUI.Forms Namespace : LayoutSettings Class

The following tables list the members exposed by LayoutSettings.

Public Properties

 | Name | Description
Public Property | LayoutEngine |
Top

See Also

Reference

LayoutSettings Class
Gizmox.WebGUI.Forms Namespace


LayoutSettings Class Properties

[image]
Gizmox.WebGUI.Forms
LayoutSettings Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : LayoutSettings Class

For a list of all members of this type, see LayoutSettings members.

Public Properties

 | Name | Description
Public Property | LayoutEngine |
Top

See Also

Reference

LayoutSettings Class
Gizmox.WebGUI.Forms Namespace


LayoutEngine Property

[image]
Gizmox.WebGUI.Forms
LayoutEngine Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > LayoutSettings Class : LayoutEngine Property

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property LayoutEngine As LayoutEngine
Visual Basic (Usage) Copy Code
Dim instance As LayoutSettings
Dim value As LayoutEngine

value = instance.LayoutEngine
C#
public virtual LayoutEngine LayoutEngine {get;}
Managed Extensions for C++
public: __property virtual LayoutEngine* get_LayoutEngine();
C++/CLI
public:
virtual property LayoutEngine^ LayoutEngine {
   LayoutEngine^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LayoutSettings Class
LayoutSettings Members


Link Class

[image]
Gizmox.WebGUI.Forms
Link Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : Link Class

The Link class provides services for opening links in a new window

Syntax

Visual Basic (Declaration)
Public Class Link
   Implements ILink
Visual Basic (Usage) Copy Code
Dim instance As Link
C#
public class Link : ILink
Managed Extensions for C++
public __gc class Link : public ILink
C++/CLI
public ref class Link : public ILink

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.Link

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Link Members
Gizmox.WebGUI.Forms Namespace


Link Class Members

[image]
Gizmox.WebGUI.Forms
Link Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : Link Class

The following tables list the members exposed by Link.

Public Properties

 | Name | Description
Public Property | Url | Gets the link url
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Open | Overloaded. Opens a new url
Top

See Also

Reference

Link Class
Gizmox.WebGUI.Forms Namespace


Link Class Methods

[image]
Gizmox.WebGUI.Forms
Link Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : Link Class

For a list of all members of this type, see Link members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Open | Overloaded. Opens a new url
Top

See Also

Reference

Link Class
Gizmox.WebGUI.Forms Namespace


Open Method

[image]
Gizmox.WebGUI.Forms
Open Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Link Class : Open Method

Opens a new url

Overload List

Overload | Description
Open(String) | Opens a new url
Open(String,LinkParameters) | Opens a new url with window parameters
Open(GatewayReference) | Opens a gateway link
Open(GatewayReference,LinkParameters) | Opens a gateway link with parameters
Open(FormReference) | Opens a form reference link
Open(FormReference,LinkParameters) | Opens a form reference link with parameters

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Link Class
Link Members


Open(String) Method

[image]
Gizmox.WebGUI.Forms
Open(String) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Link Class > Open Method : Open(String) Method

strUrl
The url to open
Opens a new url

Syntax

Visual Basic (Declaration)
Public Overloads Shared Sub Open( _
   ByVal strUrl As String _
)
Visual Basic (Usage) Copy Code
Dim strUrl As String

Link.Open(strUrl)
C#
public static void Open(
   string strUrl
)
Managed Extensions for C++
public: static void Open(
   string* strUrl
)
C++/CLI
public:
static void Open(
   String^ strUrl
)

Parameters

strUrl
The url to open

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Link Class
Link Members
Overload List


Open(String,LinkParameters) Method

[image]
Gizmox.WebGUI.Forms
Open(String,LinkParameters) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Link Class > Open Method : Open(String,LinkParameters) Method

strUrl
The url to open
objLinkParameters
The link window paramters
Opens a new url with window parameters

Syntax

Visual Basic (Declaration)
Public Overloads Shared Sub Open( _
   ByVal strUrl As String, _
   ByVal objLinkParameters As LinkParameters _
)
Visual Basic (Usage) Copy Code
Dim strUrl As String
Dim objLinkParameters As LinkParameters

Link.Open(strUrl, objLinkParameters)
C#
public static void Open(
   string strUrl,
   LinkParameters objLinkParameters
)
Managed Extensions for C++
public: static void Open(
   string* strUrl,
   LinkParameters* objLinkParameters
)
C++/CLI
public:
static void Open(
   String^ strUrl,
   LinkParameters^ objLinkParameters
)

Parameters

strUrl
The url to open
objLinkParameters
The link window paramters

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Link Class
Link Members
Overload List


Open(GatewayReference) Method

[image]
Gizmox.WebGUI.Forms
Open(GatewayReference) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Link Class > Open Method : Open(GatewayReference) Method

objGatewayReference
The gateway reference
Opens a gateway link

Syntax

Visual Basic (Declaration)
Public Overloads Shared Sub Open( _
   ByVal objGatewayReference As GatewayReference _
)
Visual Basic (Usage) Copy Code
Dim objGatewayReference As GatewayReference

Link.Open(objGatewayReference)
C#
public static void Open(
   GatewayReference objGatewayReference
)
Managed Extensions for C++
public: static void Open(
   GatewayReference* objGatewayReference
)
C++/CLI
public:
static void Open(
   GatewayReference^ objGatewayReference
)

Parameters

objGatewayReference
The gateway reference

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Link Class
Link Members
Overload List


Open(GatewayReference,LinkParameters) Method

[image]
Gizmox.WebGUI.Forms
Open(GatewayReference,LinkParameters) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Link Class > Open Method : Open(GatewayReference,LinkParameters) Method

objGatewayReference
The gateway reference
objLinkParameters
The link window paramters
Opens a gateway link with parameters

Syntax

Visual Basic (Declaration)
Public Overloads Shared Sub Open( _
   ByVal objGatewayReference As GatewayReference, _
   ByVal objLinkParameters As LinkParameters _
)
Visual Basic (Usage) Copy Code
Dim objGatewayReference As GatewayReference
Dim objLinkParameters As LinkParameters

Link.Open(objGatewayReference, objLinkParameters)
C#
public static void Open(
   GatewayReference objGatewayReference,
   LinkParameters objLinkParameters
)
Managed Extensions for C++
public: static void Open(
   GatewayReference* objGatewayReference,
   LinkParameters* objLinkParameters
)
C++/CLI
public:
static void Open(
   GatewayReference^ objGatewayReference,
   LinkParameters^ objLinkParameters
)

Parameters

objGatewayReference
The gateway reference
objLinkParameters
The link window paramters

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Link Class
Link Members
Overload List


Open(FormReference) Method

[image]
Gizmox.WebGUI.Forms
Open(FormReference) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Link Class > Open Method : Open(FormReference) Method

objFormReference
The form reference
Opens a form reference link

Syntax

Visual Basic (Declaration)
Public Overloads Shared Sub Open( _
   ByVal objFormReference As FormReference _
)
Visual Basic (Usage) Copy Code
Dim objFormReference As FormReference

Link.Open(objFormReference)
C#
public static void Open(
   FormReference objFormReference
)
Managed Extensions for C++
public: static void Open(
   FormReference* objFormReference
)
C++/CLI
public:
static void Open(
   FormReference^ objFormReference
)

Parameters

objFormReference
The form reference

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Link Class
Link Members
Overload List


Open(FormReference,LinkParameters) Method

[image]
Gizmox.WebGUI.Forms
Open(FormReference,LinkParameters) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Link Class > Open Method : Open(FormReference,LinkParameters) Method

objFormReference
The form reference
objLinkParameters
The link window paramters
Opens a form reference link with parameters

Syntax

Visual Basic (Declaration)
Public Overloads Shared Sub Open( _
   ByVal objFormReference As FormReference, _
   ByVal objLinkParameters As LinkParameters _
)
Visual Basic (Usage) Copy Code
Dim objFormReference As FormReference
Dim objLinkParameters As LinkParameters

Link.Open(objFormReference, objLinkParameters)
C#
public static void Open(
   FormReference objFormReference,
   LinkParameters objLinkParameters
)
Managed Extensions for C++
public: static void Open(
   FormReference* objFormReference,
   LinkParameters* objLinkParameters
)
C++/CLI
public:
static void Open(
   FormReference^ objFormReference,
   LinkParameters^ objLinkParameters
)

Parameters

objFormReference
The form reference
objLinkParameters
The link window paramters

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Link Class
Link Members
Overload List


Link Class Properties

[image]
Gizmox.WebGUI.Forms
Link Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : Link Class

For a list of all members of this type, see Link members.

Public Properties

 | Name | Description
Public Property | Url | Gets the link url
Top

See Also

Reference

Link Class
Gizmox.WebGUI.Forms Namespace


Url Property

[image]
Gizmox.WebGUI.Forms
Url Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Link Class : Url Property

Gets the link url

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Url As String
Visual Basic (Usage) Copy Code
Dim instance As Link
Dim value As String

value = instance.Url
C#
public string Url {get;}
Managed Extensions for C++
public: __property string* get_Url();
C++/CLI
public:
property String^ Url {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Link Class
Link Members


LinkLabel Class

[image]
Gizmox.WebGUI.Forms
LinkLabel Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : LinkLabel Class

Represents a Gizmox.WebGUI.Forms label control that can display hyperlinks.

Object Model

Syntax

Visual Basic (Declaration)
<ToolboxItemCategoryAttribute("Common Controls")>
<SRDescriptionAttribute("Displays a label control that supports hyperlink functionality, formatting, and tracking.")>
<ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<DesignTimeControllerAttribute()>
<SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableLinkLabel, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")>
<ToolboxBitmapAttribute()>
<DefaultEventAttribute("LinkClicked")>
<ClientControllerAttribute()>
<MetadataTagAttribute("LL")>
Public Class LinkLabel
   Inherits Label
   Implements IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Visual Basic (Usage) Copy Code
Dim instance As LinkLabel
C#
[ToolboxItemCategoryAttribute("Common Controls")]
[SRDescriptionAttribute("Displays a label control that supports hyperlink functionality, formatting, and tracking.")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[DesignTimeControllerAttribute()]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableLinkLabel, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[ToolboxBitmapAttribute()]
[DefaultEventAttribute("LinkClicked")]
[ClientControllerAttribute()]
[MetadataTagAttribute("LL")]
public class LinkLabel : Label, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Managed Extensions for C++
[ToolboxItemCategoryAttribute("Common Controls")]
[SRDescriptionAttribute("Displays a label control that supports hyperlink functionality, formatting, and tracking.")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[DesignTimeControllerAttribute()]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableLinkLabel, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[ToolboxBitmapAttribute()]
[DefaultEventAttribute("LinkClicked")]
[ClientControllerAttribute()]
[MetadataTagAttribute("LL")]
public __gc class LinkLabel : public Label, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
C++/CLI
[ToolboxItemCategoryAttribute("Common Controls")]
[SRDescriptionAttribute("Displays a label control that supports hyperlink functionality, formatting, and tracking.")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[DesignTimeControllerAttribute()]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableLinkLabel, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[ToolboxBitmapAttribute()]
[DefaultEventAttribute("LinkClicked")]
[ClientControllerAttribute()]
[MetadataTagAttribute("LL")]
public ref class LinkLabel : public Label, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.Label
Gizmox.WebGUI.Forms.LinkLabel

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

LinkLabel Members
Gizmox.WebGUI.Forms Namespace


LinkLabel Class Members

[image]
Gizmox.WebGUI.Forms
LinkLabel Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : LinkLabel Class

The following tables list the members exposed by LinkLabel.

Public Constructors

 | Name | Description
Public Constructor | LinkLabel Constructor | Overloaded. Initializes a new default instance of the LinkLabel class.
Top

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | AutoSize | Gets or sets a value indicating whether the control is automatically resized to display its entire contents. (Inherited from Label)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | FlatStyle | Gets or sets the flat style appearance of the label control. (Inherited from Label)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | Image | Gets or sets the image that is displayed on a button control. (Inherited from Label)
Public Property | ImageAlign | Gets or sets the alignment of the image on the button control. (Inherited from Label)
Public Property | ImageIndex | Gets or sets the index of the image that is displayed for the item. (Inherited from Label)
Public Property | ImageKey | Gets or sets the key for the image that is displayed for the item. (Inherited from Label)
Public Property | ImageList | Gets or sets the ImageList to use when displaying items as small icons in the control. (Inherited from Label)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Label)
Public Property | TextAlign | Gets or sets the alignment of text in the label. (Inherited from Label)
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | Url | Gets or sets the URL.
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Label)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Control)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from Control)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLinkClicked | Invokes LinkClicked event.
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Control)
Protected Method | RenderAttributes | (Inherited from Label)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Label)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeImage | Shoulds the serialize image. (Inherited from Label)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LinkClicked | Occurs when a link is clicked within the control.
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

LinkLabel Class
Gizmox.WebGUI.Forms Namespace


LinkLabel Constructor

[image]
Gizmox.WebGUI.Forms
LinkLabel Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > LinkLabel Class : LinkLabel Constructor

Initializes a new default instance of the LinkLabel class.

Overload List

Overload | Description
LinkLabel Constructor() | Initializes a new default instance of the LinkLabel class.
LinkLabel Constructor(String) | Initializes a new instance of the LinkLabel class.
LinkLabel Constructor(String,String) | Initializes a new instance of the LinkLabel class.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LinkLabel Class
LinkLabel Members


LinkLabel Constructor()

[image]
Gizmox.WebGUI.Forms
LinkLabel Constructor()
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > LinkLabel Class > LinkLabel Constructor : LinkLabel Constructor()

Initializes a new default instance of the LinkLabel class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As LinkLabel()
C#
public LinkLabel()
Managed Extensions for C++
public: LinkLabel();
C++/CLI
public:
LinkLabel();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LinkLabel Class
LinkLabel Members
Overload List


LinkLabel Constructor(String)

[image]
Gizmox.WebGUI.Forms
LinkLabel Constructor(String)
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > LinkLabel Class > LinkLabel Constructor : LinkLabel Constructor(String)

strText
Label text.
Initializes a new instance of the LinkLabel class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal strText As String _
)
Visual Basic (Usage) Copy Code
Dim strText As String

Dim instance As LinkLabel(strText)
C#
public LinkLabel(
   string strText
)
Managed Extensions for C++
public: LinkLabel(
   string* strText
)
C++/CLI
public:
LinkLabel(
   String^ strText
)

Parameters

strText
Label text.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LinkLabel Class
LinkLabel Members
Overload List


LinkLabel Constructor(String,String)

[image]
Gizmox.WebGUI.Forms
LinkLabel Constructor(String,String)
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > LinkLabel Class > LinkLabel Constructor : LinkLabel Constructor(String,String)

strText
Label text.
strUrl
Label url.
Initializes a new instance of the LinkLabel class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal strText As String, _
   ByVal strUrl As String _
)
Visual Basic (Usage) Copy Code
Dim strText As String
Dim strUrl As String

Dim instance As LinkLabel(strText, strUrl)
C#
public LinkLabel(
   string strText,
   string strUrl
)
Managed Extensions for C++
public: LinkLabel(
   string* strText,
   string* strUrl
)
C++/CLI
public:
LinkLabel(
   String^ strText,
   String^ strUrl
)

Parameters

strText
Label text.
strUrl
Label url.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LinkLabel Class
LinkLabel Members
Overload List


LinkLabel Class Methods

[image]
Gizmox.WebGUI.Forms
LinkLabel Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : LinkLabel Class

For a list of all members of this type, see LinkLabel members.

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Label)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Control)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from Control)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLinkClicked | Invokes LinkClicked event.
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Control)
Protected Method | RenderAttributes | (Inherited from Label)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Label)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeImage | Shoulds the serialize image. (Inherited from Label)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

See Also

Reference

LinkLabel Class
Gizmox.WebGUI.Forms Namespace


OnLinkClicked Method

[image]
Gizmox.WebGUI.Forms
OnLinkClicked Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > LinkLabel Class : OnLinkClicked Method

e
Event arguments
Invokes LinkClicked event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnLinkClicked( _
   ByVal e As LinkLabelLinkClickedEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As LinkLabel
Dim e As LinkLabelLinkClickedEventArgs

instance.OnLinkClicked(e)
C#
protected virtual void OnLinkClicked(
   LinkLabelLinkClickedEventArgs e
)
Managed Extensions for C++
protected: virtual void OnLinkClicked(
   LinkLabelLinkClickedEventArgs* e
)
C++/CLI
protected:
virtual void OnLinkClicked(
   LinkLabelLinkClickedEventArgs^ e
)

Parameters

e
Event arguments

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LinkLabel Class
LinkLabel Members


LinkLabel Class Properties

[image]
Gizmox.WebGUI.Forms
LinkLabel Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : LinkLabel Class

For a list of all members of this type, see LinkLabel members.

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | AutoSize | Gets or sets a value indicating whether the control is automatically resized to display its entire contents. (Inherited from Label)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | FlatStyle | Gets or sets the flat style appearance of the label control. (Inherited from Label)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | Image | Gets or sets the image that is displayed on a button control. (Inherited from Label)
Public Property | ImageAlign | Gets or sets the alignment of the image on the button control. (Inherited from Label)
Public Property | ImageIndex | Gets or sets the index of the image that is displayed for the item. (Inherited from Label)
Public Property | ImageKey | Gets or sets the key for the image that is displayed for the item. (Inherited from Label)
Public Property | ImageList | Gets or sets the ImageList to use when displaying items as small icons in the control. (Inherited from Label)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Label)
Public Property | TextAlign | Gets or sets the alignment of text in the label. (Inherited from Label)
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | Url | Gets or sets the URL.
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

See Also

Reference

LinkLabel Class
Gizmox.WebGUI.Forms Namespace


Url Property

[image]
Gizmox.WebGUI.Forms
Url Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > LinkLabel Class : Url Property

Gets or sets the URL.

Syntax

Visual Basic (Declaration)
Public Property Url As String
Visual Basic (Usage) Copy Code
Dim instance As LinkLabel
Dim value As String

instance.Url = value

value = instance.Url
C#
public string Url {get; set;}
Managed Extensions for C++
public: __property string* get_Url();
public: __property void set_Url(
   string* value
);
C++/CLI
public:
property String^ Url {
   String^ get();
   void set (String^value);
}

Return Value

The URL.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LinkLabel Class
LinkLabel Members


LinkLabel Class Events

[image]
Gizmox.WebGUI.Forms
LinkLabel Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : LinkLabel Class

For a list of all members of this type, see LinkLabel members.

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LinkClicked | Occurs when a link is clicked within the control.
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

LinkLabel Class
Gizmox.WebGUI.Forms Namespace


LinkClicked Event

[image]
Gizmox.WebGUI.Forms
LinkClicked Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > LinkLabel Class : LinkClicked Event

Occurs when a link is clicked within the control.

Syntax

Visual Basic (Declaration)
Public Event LinkClicked() As LinkLabelLinkClickedEventHandler
Visual Basic (Usage) Copy Code
Dim instance As LinkLabel
Dim handler As LinkLabelLinkClickedEventHandler

AddHandler instance.LinkClicked, handler
C#
public event LinkLabelLinkClickedEventHandler LinkClicked()
Managed Extensions for C++
public: __event LinkLabelLinkClickedEventHandler* LinkClicked
C++/CLI
public:
event LinkLabelLinkClickedEventHandler^ LinkClicked

Event Data

The event handler receives an argument of type LinkLabelLinkClickedEventArgs containing data related to this event. The following LinkLabelLinkClickedEventArgs properties provide information specific to this event.

Property | Description
Link | Gets the LinkLabel.Link that was clicked.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LinkLabel Class
LinkLabel Members


LinkLabel.Link Class

[image]
Gizmox.WebGUI.Forms
LinkLabel.Link Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : LinkLabel.Link Class

Represents a link within a LinkLabel control.

Syntax

Visual Basic (Declaration)
Public Class LinkLabel.Link
   Implements ILink
Visual Basic (Usage) Copy Code
Dim instance As LinkLabel.Link
C#
public class LinkLabel.Link : ILink
Managed Extensions for C++
public __gc class LinkLabel.Link : public ILink
C++/CLI
public ref class LinkLabel.Link : public ILink

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.LinkLabel.Link

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

LinkLabel.Link Members
Gizmox.WebGUI.Forms Namespace


LinkLabel.Link Class Members

[image]
Gizmox.WebGUI.Forms
LinkLabel.Link Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : LinkLabel.Link Class

The following tables list the members exposed by LinkLabel.Link.

Public Properties

 | Name | Description
Public Property | Enabled | Gets or sets a value indicating whether the link is enabled.
Public Property | Length | Gets or sets the number of characters in the link text.
Public Property | LinkData | Gets or sets the data associated with the link.
Public Property | Start | Gets or sets the starting location of the link within the text of the LinkLabel.
Public Property | Visited | Gets or sets a value indicating whether the user has visited the link.
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Open | Opens the specified link.
Top

See Also

Reference

LinkLabel.Link Class
Gizmox.WebGUI.Forms Namespace


LinkLabel.Link Class Methods

[image]
Gizmox.WebGUI.Forms
LinkLabel.Link Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : LinkLabel.Link Class

For a list of all members of this type, see LinkLabel.Link members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Open | Opens the specified link.
Top

See Also

Reference

LinkLabel.Link Class
Gizmox.WebGUI.Forms Namespace


Open Method

[image]
Gizmox.WebGUI.Forms
Open Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > LinkLabel.Link Class : Open Method

objLink
The link.
Opens the specified link.

Syntax

Visual Basic (Declaration)
Public Shared Sub Open( _
   ByVal objLink As LinkLabel.Link _
)
Visual Basic (Usage) Copy Code
Dim objLink As LinkLabel.Link

LinkLabel.Link.Open(objLink)
C#
public static void Open(
   LinkLabel.Link objLink
)
Managed Extensions for C++
public: static void Open(
   LinkLabel.Link* objLink
)
C++/CLI
public:
static void Open(
   LinkLabel::Link^ objLink
)

Parameters

objLink
The link.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LinkLabel.Link Class
LinkLabel.Link Members


LinkLabel.Link Class Properties

[image]
Gizmox.WebGUI.Forms
LinkLabel.Link Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : LinkLabel.Link Class

For a list of all members of this type, see LinkLabel.Link members.

Public Properties

 | Name | Description
Public Property | Enabled | Gets or sets a value indicating whether the link is enabled.
Public Property | Length | Gets or sets the number of characters in the link text.
Public Property | LinkData | Gets or sets the data associated with the link.
Public Property | Start | Gets or sets the starting location of the link within the text of the LinkLabel.
Public Property | Visited | Gets or sets a value indicating whether the user has visited the link.
Top

See Also

Reference

LinkLabel.Link Class
Gizmox.WebGUI.Forms Namespace


Enabled Property

[image]
Gizmox.WebGUI.Forms
Enabled Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > LinkLabel.Link Class : Enabled Property

Gets or sets a value indicating whether the link is enabled.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property Enabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LinkLabel.Link
Dim value As Boolean

instance.Enabled = value

value = instance.Enabled
C#
[DefaultValueAttribute()]
public bool Enabled {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property bool get_Enabled();
public: __property void set_Enabled(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
public:
property bool Enabled {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LinkLabel.Link Class
LinkLabel.Link Members


Length Property

[image]
Gizmox.WebGUI.Forms
Length Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > LinkLabel.Link Class : Length Property

Gets or sets the number of characters in the link text.

Syntax

Visual Basic (Declaration)
Public Property Length As Integer
Visual Basic (Usage) Copy Code
Dim instance As LinkLabel.Link
Dim value As Integer

instance.Length = value

value = instance.Length
C#
public int Length {get; set;}
Managed Extensions for C++
public: __property int get_Length();
public: __property void set_Length(
   int value
);
C++/CLI
public:
property int Length {
   int get();
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LinkLabel.Link Class
LinkLabel.Link Members


LinkData Property

[image]
Gizmox.WebGUI.Forms
LinkData Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > LinkLabel.Link Class : LinkData Property

Gets or sets the data associated with the link.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property LinkData As Object
Visual Basic (Usage) Copy Code
Dim instance As LinkLabel.Link
Dim value As Object

instance.LinkData = value

value = instance.LinkData
C#
[DefaultValueAttribute()]
public object LinkData {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property Object* get_LinkData();
public: __property void set_LinkData(
   Object* value
);
C++/CLI
[DefaultValueAttribute()]
public:
property Object^ LinkData {
   Object^ get();
   void set (Object^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LinkLabel.Link Class
LinkLabel.Link Members


Start Property

[image]
Gizmox.WebGUI.Forms
Start Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > LinkLabel.Link Class : Start Property

Gets or sets the starting location of the link within the text of the LinkLabel.

Syntax

Visual Basic (Declaration)
Public Property Start As Integer
Visual Basic (Usage) Copy Code
Dim instance As LinkLabel.Link
Dim value As Integer

instance.Start = value

value = instance.Start
C#
public int Start {get; set;}
Managed Extensions for C++
public: __property int get_Start();
public: __property void set_Start(
   int value
);
C++/CLI
public:
property int Start {
   int get();
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LinkLabel.Link Class
LinkLabel.Link Members


Visited Property

[image]
Gizmox.WebGUI.Forms
Visited Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > LinkLabel.Link Class : Visited Property

Gets or sets a value indicating whether the user has visited the link.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property Visited As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LinkLabel.Link
Dim value As Boolean

instance.Visited = value

value = instance.Visited
C#
[DefaultValueAttribute()]
public bool Visited {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property bool get_Visited();
public: __property void set_Visited(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
public:
property bool Visited {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LinkLabel.Link Class
LinkLabel.Link Members


LinkLabelLinkClickedEventArgs Class

[image]
Gizmox.WebGUI.Forms
LinkLabelLinkClickedEventArgs Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : LinkLabelLinkClickedEventArgs Class

Provides data for the LinkLabel.LinkClicked event.

Object Model

Syntax

Visual Basic (Declaration)
Public Class LinkLabelLinkClickedEventArgs
   Inherits EventArgs
Visual Basic (Usage) Copy Code
Dim instance As LinkLabelLinkClickedEventArgs
C#
public class LinkLabelLinkClickedEventArgs : EventArgs
Managed Extensions for C++
public __gc class LinkLabelLinkClickedEventArgs : public EventArgs
C++/CLI
public ref class LinkLabelLinkClickedEventArgs : public EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gizmox.WebGUI.Forms.LinkLabelLinkClickedEventArgs

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

LinkLabelLinkClickedEventArgs Members
Gizmox.WebGUI.Forms Namespace


LinkLabelLinkClickedEventArgs Class Members

[image]
Gizmox.WebGUI.Forms
LinkLabelLinkClickedEventArgs Class Members
See Also Properties Send Feedback
Gizmox.WebGUI.Forms Namespace : LinkLabelLinkClickedEventArgs Class

The following tables list the members exposed by LinkLabelLinkClickedEventArgs.

Public Constructors

 | Name | Description
Public Constructor | LinkLabelLinkClickedEventArgs Constructor | Initializes a new instance of the LinkLabelLinkClickedEventArgs class with the specified link.
Top

Public Properties

 | Name | Description
Public Property | Link | Gets the LinkLabel.Link that was clicked.
Top

See Also

Reference

LinkLabelLinkClickedEventArgs Class
Gizmox.WebGUI.Forms Namespace


LinkLabelLinkClickedEventArgs Constructor

[image]
Gizmox.WebGUI.Forms
LinkLabelLinkClickedEventArgs Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > LinkLabelLinkClickedEventArgs Class : LinkLabelLinkClickedEventArgs Constructor

link
The LinkLabel.Link that was clicked.
Initializes a new instance of the LinkLabelLinkClickedEventArgs class with the specified link.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal link As LinkLabel.Link _
)
Visual Basic (Usage) Copy Code
Dim link As LinkLabel.Link

Dim instance As LinkLabelLinkClickedEventArgs(link)
C#
public LinkLabelLinkClickedEventArgs(
   LinkLabel.Link link
)
Managed Extensions for C++
public: LinkLabelLinkClickedEventArgs(
   LinkLabel.Link* link
)
C++/CLI
public:
LinkLabelLinkClickedEventArgs(
   LinkLabel::Link^ link
)

Parameters

link
The LinkLabel.Link that was clicked.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LinkLabelLinkClickedEventArgs Class
LinkLabelLinkClickedEventArgs Members


LinkLabelLinkClickedEventArgs Class Properties

[image]
Gizmox.WebGUI.Forms
LinkLabelLinkClickedEventArgs Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : LinkLabelLinkClickedEventArgs Class

For a list of all members of this type, see LinkLabelLinkClickedEventArgs members.

Public Properties

 | Name | Description
Public Property | Link | Gets the LinkLabel.Link that was clicked.
Top

See Also

Reference

LinkLabelLinkClickedEventArgs Class
Gizmox.WebGUI.Forms Namespace


Link Property

[image]
Gizmox.WebGUI.Forms
Link Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > LinkLabelLinkClickedEventArgs Class : Link Property

Gets the LinkLabel.Link that was clicked.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Link As LinkLabel.Link
Visual Basic (Usage) Copy Code
Dim instance As LinkLabelLinkClickedEventArgs
Dim value As LinkLabel.Link

value = instance.Link
C#
public LinkLabel.Link Link {get;}
Managed Extensions for C++
public: __property LinkLabel.Link* get_Link();
C++/CLI
public:
property LinkLabel::Link^ Link {
   LinkLabel::Link^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LinkLabelLinkClickedEventArgs Class
LinkLabelLinkClickedEventArgs Members


LinkParameters Class

[image]
Gizmox.WebGUI.Forms
LinkParameters Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : LinkParameters Class

Holds window parameters for opening links

Object Model

Syntax

Visual Basic (Declaration)
Public Class LinkParameters
   Implements ILinkParameters
Visual Basic (Usage) Copy Code
Dim instance As LinkParameters
C#
public class LinkParameters : ILinkParameters
Managed Extensions for C++
public __gc class LinkParameters : public ILinkParameters
C++/CLI
public ref class LinkParameters : public ILinkParameters

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.LinkParameters

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

LinkParameters Members
Gizmox.WebGUI.Forms Namespace


LinkParameters Class Members

[image]
Gizmox.WebGUI.Forms
LinkParameters Class Members
See Also Properties Send Feedback
Gizmox.WebGUI.Forms Namespace : LinkParameters Class

The following tables list the members exposed by LinkParameters.

Public Constructors

 | Name | Description
Public Constructor | LinkParameters Constructor | Overloaded. Create a new link parameters instance
Top

Public Properties

 | Name | Description
Public Property | Form | Gets or sets form arguments
Public Property | FullScreen | Gets or sets the link window full screen mode
Public Property | Location | Gets or sets the link window location
Public Property | QueryString | Gets or sets query string arguments
Public Property | Resizable | Gets or sets the resizable mode of the link window
Public Property | ScrollBars | Gets or sets the scrollbars visibility in the link window
Public Property | ShowLocationBar | Gets or sets the link windows location bar visibility
Public Property | ShowMenuBar | Gets or sets the link windows menu bar visibility
Public Property | ShowStatusBar | Gets or sets the link windows status bar visibility
Public Property | ShowTitleBar | Gets or sets the link windows title bar visibility
Public Property | ShowToolBar | Gets or sets the link windows toolbar visibility
Public Property | Size | Gets or sets the window size
Public Property | Target | Gets or sets the link targer
Public Property | WindowStyle | Get or sets the window style
Top

See Also

Reference

LinkParameters Class
Gizmox.WebGUI.Forms Namespace


LinkParameters Constructor

[image]
Gizmox.WebGUI.Forms
LinkParameters Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > LinkParameters Class : LinkParameters Constructor

Create a new link parameters instance

Overload List

Overload | Description
LinkParameters Constructor() | Create a new link parameters instance
LinkParameters Constructor(LinkWindowStyle) | Create a new link parameters instance
LinkParameters Constructor(LinkWindowStyle,Size) | Create a new link parameters instance

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LinkParameters Class
LinkParameters Members


LinkParameters Constructor()

[image]
Gizmox.WebGUI.Forms
LinkParameters Constructor()
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > LinkParameters Class > LinkParameters Constructor : LinkParameters Constructor()

Create a new link parameters instance

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As LinkParameters()
C#
public LinkParameters()
Managed Extensions for C++
public: LinkParameters();
C++/CLI
public:
LinkParameters();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LinkParameters Class
LinkParameters Members
Overload List


LinkParameters Constructor(LinkWindowStyle)

[image]
Gizmox.WebGUI.Forms
LinkParameters Constructor(LinkWindowStyle)
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > LinkParameters Class > LinkParameters Constructor : LinkParameters Constructor(LinkWindowStyle)

enmWindowStyle
The link window style
Create a new link parameters instance

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal enmWindowStyle As LinkWindowStyle _
)
Visual Basic (Usage) Copy Code
Dim enmWindowStyle As LinkWindowStyle

Dim instance As LinkParameters(enmWindowStyle)
C#
public LinkParameters(
   LinkWindowStyle enmWindowStyle
)
Managed Extensions for C++
public: LinkParameters(
   LinkWindowStyle enmWindowStyle
)
C++/CLI
public:
LinkParameters(
   LinkWindowStyle enmWindowStyle
)

Parameters

enmWindowStyle
The link window style

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LinkParameters Class
LinkParameters Members
Overload List


LinkParameters Constructor(LinkWindowStyle,Size)

[image]
Gizmox.WebGUI.Forms
LinkParameters Constructor(LinkWindowStyle,Size)
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > LinkParameters Class > LinkParameters Constructor : LinkParameters Constructor(LinkWindowStyle,Size)

enmWindowStyle
The link window style
objWindowSize
The link window size
Create a new link parameters instance

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal enmWindowStyle As LinkWindowStyle, _
   ByVal objWindowSize As Size _
)
Visual Basic (Usage) Copy Code
Dim enmWindowStyle As LinkWindowStyle
Dim objWindowSize As Size

Dim instance As LinkParameters(enmWindowStyle, objWindowSize)
C#
public LinkParameters(
   LinkWindowStyle enmWindowStyle,
   Size objWindowSize
)
Managed Extensions for C++
public: LinkParameters(
   LinkWindowStyle enmWindowStyle,
   Size objWindowSize
)
C++/CLI
public:
LinkParameters(
   LinkWindowStyle enmWindowStyle,
   Size objWindowSize
)

Parameters

enmWindowStyle
The link window style
objWindowSize
The link window size

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LinkParameters Class
LinkParameters Members
Overload List


LinkParameters Class Properties

[image]
Gizmox.WebGUI.Forms
LinkParameters Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : LinkParameters Class

For a list of all members of this type, see LinkParameters members.

Public Properties

 | Name | Description
Public Property | Form | Gets or sets form arguments
Public Property | FullScreen | Gets or sets the link window full screen mode
Public Property | Location | Gets or sets the link window location
Public Property | QueryString | Gets or sets query string arguments
Public Property | Resizable | Gets or sets the resizable mode of the link window
Public Property | ScrollBars | Gets or sets the scrollbars visibility in the link window
Public Property | ShowLocationBar | Gets or sets the link windows location bar visibility
Public Property | ShowMenuBar | Gets or sets the link windows menu bar visibility
Public Property | ShowStatusBar | Gets or sets the link windows status bar visibility
Public Property | ShowTitleBar | Gets or sets the link windows title bar visibility
Public Property | ShowToolBar | Gets or sets the link windows toolbar visibility
Public Property | Size | Gets or sets the window size
Public Property | Target | Gets or sets the link targer
Public Property | WindowStyle | Get or sets the window style
Top

See Also

Reference

LinkParameters Class
Gizmox.WebGUI.Forms Namespace


Form Property

[image]
Gizmox.WebGUI.Forms
Form Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > LinkParameters Class : Form Property

Gets or sets form arguments

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Form As ILinkArguments
Visual Basic (Usage) Copy Code
Dim instance As LinkParameters
Dim value As ILinkArguments

value = instance.Form
C#
public ILinkArguments Form {get;}
Managed Extensions for C++
public: __property ILinkArguments* get_Form();
C++/CLI
public:
property ILinkArguments^ Form {
   ILinkArguments^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LinkParameters Class
LinkParameters Members


FullScreen Property

[image]
Gizmox.WebGUI.Forms
FullScreen Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > LinkParameters Class : FullScreen Property

Gets or sets the link window full screen mode

Syntax

Visual Basic (Declaration)
Public Property FullScreen As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LinkParameters
Dim value As Boolean

instance.FullScreen = value

value = instance.FullScreen
C#
public bool FullScreen {get; set;}
Managed Extensions for C++
public: __property bool get_FullScreen();
public: __property void set_FullScreen(
   bool value
);
C++/CLI
public:
property bool FullScreen {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LinkParameters Class
LinkParameters Members


Location Property

[image]
Gizmox.WebGUI.Forms
Location Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > LinkParameters Class : Location Property

Gets or sets the link window location

Syntax

Visual Basic (Declaration)
Public Property Location As Point
Visual Basic (Usage) Copy Code
Dim instance As LinkParameters
Dim value As Point

instance.Location = value

value = instance.Location
C#
public Point Location {get; set;}
Managed Extensions for C++
public: __property Point get_Location();
public: __property void set_Location(
   Point value
);
C++/CLI
public:
property Point Location {
   Point get();
   void set (Pointvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LinkParameters Class
LinkParameters Members


QueryString Property

[image]
Gizmox.WebGUI.Forms
QueryString Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > LinkParameters Class : QueryString Property

Gets or sets query string arguments

Syntax

Visual Basic (Declaration)
Public ReadOnly Property QueryString As ILinkArguments
Visual Basic (Usage) Copy Code
Dim instance As LinkParameters
Dim value As ILinkArguments

value = instance.QueryString
C#
public ILinkArguments QueryString {get;}
Managed Extensions for C++
public: __property ILinkArguments* get_QueryString();
C++/CLI
public:
property ILinkArguments^ QueryString {
   ILinkArguments^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LinkParameters Class
LinkParameters Members


Resizable Property

[image]
Gizmox.WebGUI.Forms
Resizable Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > LinkParameters Class : Resizable Property

Gets or sets the resizable mode of the link window

Syntax

Visual Basic (Declaration)
Public Property Resizable As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LinkParameters
Dim value As Boolean

instance.Resizable = value

value = instance.Resizable
C#
public bool Resizable {get; set;}
Managed Extensions for C++
public: __property bool get_Resizable();
public: __property void set_Resizable(
   bool value
);
C++/CLI
public:
property bool Resizable {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LinkParameters Class
LinkParameters Members


ScrollBars Property

[image]
Gizmox.WebGUI.Forms
ScrollBars Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > LinkParameters Class : ScrollBars Property

Gets or sets the scrollbars visibility in the link window

Syntax

Visual Basic (Declaration)
Public Property ScrollBars As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LinkParameters
Dim value As Boolean

instance.ScrollBars = value

value = instance.ScrollBars
C#
public bool ScrollBars {get; set;}
Managed Extensions for C++
public: __property bool get_ScrollBars();
public: __property void set_ScrollBars(
   bool value
);
C++/CLI
public:
property bool ScrollBars {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LinkParameters Class
LinkParameters Members


ShowLocationBar Property

[image]
Gizmox.WebGUI.Forms
ShowLocationBar Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > LinkParameters Class : ShowLocationBar Property

Gets or sets the link windows location bar visibility

Syntax

Visual Basic (Declaration)
Public Property ShowLocationBar As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LinkParameters
Dim value As Boolean

instance.ShowLocationBar = value

value = instance.ShowLocationBar
C#
public bool ShowLocationBar {get; set;}
Managed Extensions for C++
public: __property bool get_ShowLocationBar();
public: __property void set_ShowLocationBar(
   bool value
);
C++/CLI
public:
property bool ShowLocationBar {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LinkParameters Class
LinkParameters Members


ShowMenuBar Property

[image]
Gizmox.WebGUI.Forms
ShowMenuBar Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > LinkParameters Class : ShowMenuBar Property

Gets or sets the link windows menu bar visibility

Syntax

Visual Basic (Declaration)
Public Property ShowMenuBar As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LinkParameters
Dim value As Boolean

instance.ShowMenuBar = value

value = instance.ShowMenuBar
C#
public bool ShowMenuBar {get; set;}
Managed Extensions for C++
public: __property bool get_ShowMenuBar();
public: __property void set_ShowMenuBar(
   bool value
);
C++/CLI
public:
property bool ShowMenuBar {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LinkParameters Class
LinkParameters Members


ShowStatusBar Property

[image]
Gizmox.WebGUI.Forms
ShowStatusBar Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > LinkParameters Class : ShowStatusBar Property

Gets or sets the link windows status bar visibility

Syntax

Visual Basic (Declaration)
Public Property ShowStatusBar As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LinkParameters
Dim value As Boolean

instance.ShowStatusBar = value

value = instance.ShowStatusBar
C#
public bool ShowStatusBar {get; set;}
Managed Extensions for C++
public: __property bool get_ShowStatusBar();
public: __property void set_ShowStatusBar(
   bool value
);
C++/CLI
public:
property bool ShowStatusBar {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LinkParameters Class
LinkParameters Members


ShowTitleBar Property

[image]
Gizmox.WebGUI.Forms
ShowTitleBar Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > LinkParameters Class : ShowTitleBar Property

Gets or sets the link windows title bar visibility

Syntax

Visual Basic (Declaration)
Public Property ShowTitleBar As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LinkParameters
Dim value As Boolean

instance.ShowTitleBar = value

value = instance.ShowTitleBar
C#
public bool ShowTitleBar {get; set;}
Managed Extensions for C++
public: __property bool get_ShowTitleBar();
public: __property void set_ShowTitleBar(
   bool value
);
C++/CLI
public:
property bool ShowTitleBar {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LinkParameters Class
LinkParameters Members


ShowToolBar Property

[image]
Gizmox.WebGUI.Forms
ShowToolBar Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > LinkParameters Class : ShowToolBar Property

Gets or sets the link windows toolbar visibility

Syntax

Visual Basic (Declaration)
Public Property ShowToolBar As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LinkParameters
Dim value As Boolean

instance.ShowToolBar = value

value = instance.ShowToolBar
C#
public bool ShowToolBar {get; set;}
Managed Extensions for C++
public: __property bool get_ShowToolBar();
public: __property void set_ShowToolBar(
   bool value
);
C++/CLI
public:
property bool ShowToolBar {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LinkParameters Class
LinkParameters Members


Size Property

[image]
Gizmox.WebGUI.Forms
Size Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > LinkParameters Class : Size Property

Gets or sets the window size

Syntax

Visual Basic (Declaration)
Public Property Size As Size
Visual Basic (Usage) Copy Code
Dim instance As LinkParameters
Dim value As Size

instance.Size = value

value = instance.Size
C#
public Size Size {get; set;}
Managed Extensions for C++
public: __property Size get_Size();
public: __property void set_Size(
   Size value
);
C++/CLI
public:
property Size Size {
   Size get();
   void set (Sizevalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LinkParameters Class
LinkParameters Members


Target Property

[image]
Gizmox.WebGUI.Forms
Target Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > LinkParameters Class : Target Property

Gets or sets the link targer

Syntax

Visual Basic (Declaration)
Public Property Target As String
Visual Basic (Usage) Copy Code
Dim instance As LinkParameters
Dim value As String

instance.Target = value

value = instance.Target
C#
public string Target {get; set;}
Managed Extensions for C++
public: __property string* get_Target();
public: __property void set_Target(
   string* value
);
C++/CLI
public:
property String^ Target {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LinkParameters Class
LinkParameters Members


WindowStyle Property

[image]
Gizmox.WebGUI.Forms
WindowStyle Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > LinkParameters Class : WindowStyle Property

Get or sets the window style

Syntax

Visual Basic (Declaration)
Public Property WindowStyle As LinkWindowStyle
Visual Basic (Usage) Copy Code
Dim instance As LinkParameters
Dim value As LinkWindowStyle

instance.WindowStyle = value

value = instance.WindowStyle
C#
public LinkWindowStyle WindowStyle {get; set;}
Managed Extensions for C++
public: __property LinkWindowStyle get_WindowStyle();
public: __property void set_WindowStyle(
   LinkWindowStyle value
);
C++/CLI
public:
property LinkWindowStyle WindowStyle {
   LinkWindowStyle get();
   void set (LinkWindowStylevalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LinkParameters Class
LinkParameters Members


LinkParameters.LinkArguments Class

[image]
Gizmox.WebGUI.Forms
LinkParameters.LinkArguments Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : LinkParameters.LinkArguments Class

Holds arguments to open links with

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class LinkParameters.LinkArguments
   Implements ILinkArguments
Visual Basic (Usage) Copy Code
Dim instance As LinkParameters.LinkArguments
C#
[DefaultMemberAttribute("Item")]
public class LinkParameters.LinkArguments : ILinkArguments
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
public __gc class LinkParameters.LinkArguments : public ILinkArguments
C++/CLI
[DefaultMemberAttribute("Item")]
public ref class LinkParameters.LinkArguments : public ILinkArguments

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.LinkParameters.LinkArguments

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

LinkParameters.LinkArguments Members
Gizmox.WebGUI.Forms Namespace


LinkParameters.LinkArguments Class Members

[image]
Gizmox.WebGUI.Forms
LinkParameters.LinkArguments Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : LinkParameters.LinkArguments Class

The following tables list the members exposed by LinkParameters.LinkArguments.

Public Constructors

 | Name | Description
Public Constructor | LinkParameters.LinkArguments Constructor |
Top

Public Properties

 | Name | Description
Public Property | Count | Gets the arguments count
Public Property | Item | Set or get arguments
Public Property | Names | Gets an array of argument names
Top

Public Methods

 | Name | Description
Public Method | Clear | Clears the argument collection
Top

See Also

Reference

LinkParameters.LinkArguments Class
Gizmox.WebGUI.Forms Namespace


LinkParameters.LinkArguments Constructor

[image]
Gizmox.WebGUI.Forms
LinkParameters.LinkArguments Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > LinkParameters.LinkArguments Class : LinkParameters.LinkArguments Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As LinkParameters.LinkArguments()
C#
public LinkParameters.LinkArguments()
Managed Extensions for C++
public: LinkParameters.LinkArguments();
C++/CLI
public:
LinkParameters.LinkArguments();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LinkParameters.LinkArguments Class
LinkParameters.LinkArguments Members


LinkParameters.LinkArguments Class Methods

[image]
Gizmox.WebGUI.Forms
LinkParameters.LinkArguments Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : LinkParameters.LinkArguments Class

For a list of all members of this type, see LinkParameters.LinkArguments members.

Public Methods

 | Name | Description
Public Method | Clear | Clears the argument collection
Top

See Also

Reference

LinkParameters.LinkArguments Class
Gizmox.WebGUI.Forms Namespace


Clear Method

[image]
Gizmox.WebGUI.Forms
Clear Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > LinkParameters.LinkArguments Class : Clear Method

Clears the argument collection

Syntax

Visual Basic (Declaration)
Public Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As LinkParameters.LinkArguments

instance.Clear()
C#
public void Clear()
Managed Extensions for C++
public: void Clear();
C++/CLI
public:
void Clear();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LinkParameters.LinkArguments Class
LinkParameters.LinkArguments Members


LinkParameters.LinkArguments Class Properties

[image]
Gizmox.WebGUI.Forms
LinkParameters.LinkArguments Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : LinkParameters.LinkArguments Class

For a list of all members of this type, see LinkParameters.LinkArguments members.

Public Properties

 | Name | Description
Public Property | Count | Gets the arguments count
Public Property | Item | Set or get arguments
Public Property | Names | Gets an array of argument names
Top

See Also

Reference

LinkParameters.LinkArguments Class
Gizmox.WebGUI.Forms Namespace


Count Property

[image]
Gizmox.WebGUI.Forms
Count Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > LinkParameters.LinkArguments Class : Count Property

Gets the arguments count

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As LinkParameters.LinkArguments
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LinkParameters.LinkArguments Class
LinkParameters.LinkArguments Members


Item Property

[image]
Gizmox.WebGUI.Forms
Item Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > LinkParameters.LinkArguments Class : Item Property

name
Set or get arguments

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal name As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As LinkParameters.LinkArguments
Dim name As String
Dim value As String

instance.Item(name) = value

value = instance.Item(name)
C#
public string this[
   string name
]; {get; set;}
Managed Extensions for C++
public: __property string* get_Item(
   string* name
);
public: __property void set_Item(
   string* name,
   string* value
);
C++/CLI
public:
property String^ default [String^] {
   String^ get(String^name);
   void set (String^name, String^value);
}

Parameters

name

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LinkParameters.LinkArguments Class
LinkParameters.LinkArguments Members


Names Property

[image]
Gizmox.WebGUI.Forms
Names Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > LinkParameters.LinkArguments Class : Names Property

Gets an array of argument names

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Names As String()
Visual Basic (Usage) Copy Code
Dim instance As LinkParameters.LinkArguments
Dim value() As String

value = instance.Names
C#
public string[] Names {get;}
Managed Extensions for C++
public: __property string*[]* get_Names();
C++/CLI
public:
property array<String^>^ Names {
   array<String^>^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LinkParameters.LinkArguments Class
LinkParameters.LinkArguments Members


ListBindingConverter Class

[image]
Gizmox.WebGUI.Forms
ListBindingConverter Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ListBindingConverter Class

Provides a type converter to convert Binding objects to and from various other representations.

Syntax

Visual Basic (Declaration)
Public Class ListBindingConverter
   Inherits TypeConverter
Visual Basic (Usage) Copy Code
Dim instance As ListBindingConverter
C#
public class ListBindingConverter : TypeConverter
Managed Extensions for C++
public __gc class ListBindingConverter : public TypeConverter
C++/CLI
public ref class ListBindingConverter : public TypeConverter

Inheritance Hierarchy

System.Object
System.ComponentModel.TypeConverter
Gizmox.WebGUI.Forms.ListBindingConverter

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

ListBindingConverter Members
Gizmox.WebGUI.Forms Namespace


ListBindingConverter Class Members

[image]
Gizmox.WebGUI.Forms
ListBindingConverter Class Members
See Also Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : ListBindingConverter Class

The following tables list the members exposed by ListBindingConverter.

Public Constructors

 | Name | Description
Public Constructor | ListBindingConverter Constructor |
Top

Public Methods

 | Name | Description
Public Method | CanConvertFrom | Overloaded. Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from System.ComponentModel.TypeConverter)
Public Method | CanConvertTo | Overloaded. Overridden. Returns whether this converter can convert the object to the specified type.
Public Method | ConvertFrom | Overloaded. Converts the given value to the type of this converter. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertFromInvariantString | Overloaded. Converts the given string to the type of this converter, using the invariant culture. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertFromString | Overloaded. Converts the specified text to an object. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertTo | Overloaded. Overridden. Converts the given value object to the specified type, using the arguments.
Public Method | ConvertToInvariantString | Overloaded. Converts the specified value to a culture-invariant string representation. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertToString | Overloaded. Converts the specified value to a string representation. (Inherited from System.ComponentModel.TypeConverter)
Public Method | CreateInstance | Overloaded. Overridden. Re-creates an Object given a set of property values for the object.
Public Method | GetCreateInstanceSupported | Overloaded. Overridden. Returns whether changing a value on this object requires a call to the CreateInstance method to create a new value.
Public Method | GetProperties | Overloaded. Returns a collection of properties for the type of array specified by the value parameter. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetPropertiesSupported | Overloaded. Returns whether this object supports properties. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValues | Overloaded. Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValuesExclusive | Overloaded. Returns whether the collection of standard values returned from GetStandardValues is an exclusive list. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValuesSupported | Overloaded. Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from System.ComponentModel.TypeConverter)
Public Method | IsValid | Overloaded. Returns whether the given value object is valid for this type. (Inherited from System.ComponentModel.TypeConverter)
Top

Protected Methods

 | Name | Description
Protected Method | GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from System.ComponentModel.TypeConverter)
Protected Method | GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from System.ComponentModel.TypeConverter)
Protected Method | SortProperties | (Inherited from System.ComponentModel.TypeConverter)
Top

See Also

Reference

ListBindingConverter Class
Gizmox.WebGUI.Forms Namespace


ListBindingConverter Constructor

[image]
Gizmox.WebGUI.Forms
ListBindingConverter Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListBindingConverter Class : ListBindingConverter Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ListBindingConverter()
C#
public ListBindingConverter()
Managed Extensions for C++
public: ListBindingConverter();
C++/CLI
public:
ListBindingConverter();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListBindingConverter Class
ListBindingConverter Members


ListBindingConverter Class Methods

[image]
Gizmox.WebGUI.Forms
ListBindingConverter Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ListBindingConverter Class

For a list of all members of this type, see ListBindingConverter members.

Public Methods

 | Name | Description
Public Method | CanConvertFrom | Overloaded. Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from System.ComponentModel.TypeConverter)
Public Method | CanConvertTo | Overloaded. Overridden. Returns whether this converter can convert the object to the specified type.
Public Method | ConvertFrom | Overloaded. Converts the given value to the type of this converter. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertFromInvariantString | Overloaded. Converts the given string to the type of this converter, using the invariant culture. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertFromString | Overloaded. Converts the specified text to an object. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertTo | Overloaded. Overridden. Converts the given value object to the specified type, using the arguments.
Public Method | ConvertToInvariantString | Overloaded. Converts the specified value to a culture-invariant string representation. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertToString | Overloaded. Converts the specified value to a string representation. (Inherited from System.ComponentModel.TypeConverter)
Public Method | CreateInstance | Overloaded. Overridden. Re-creates an Object given a set of property values for the object.
Public Method | GetCreateInstanceSupported | Overloaded. Overridden. Returns whether changing a value on this object requires a call to the CreateInstance method to create a new value.
Public Method | GetProperties | Overloaded. Returns a collection of properties for the type of array specified by the value parameter. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetPropertiesSupported | Overloaded. Returns whether this object supports properties. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValues | Overloaded. Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValuesExclusive | Overloaded. Returns whether the collection of standard values returned from GetStandardValues is an exclusive list. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValuesSupported | Overloaded. Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from System.ComponentModel.TypeConverter)
Public Method | IsValid | Overloaded. Returns whether the given value object is valid for this type. (Inherited from System.ComponentModel.TypeConverter)
Top

Protected Methods

 | Name | Description
Protected Method | GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from System.ComponentModel.TypeConverter)
Protected Method | GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from System.ComponentModel.TypeConverter)
Protected Method | SortProperties | (Inherited from System.ComponentModel.TypeConverter)
Top

See Also

Reference

ListBindingConverter Class
Gizmox.WebGUI.Forms Namespace


CanConvertTo Method

[image]
Gizmox.WebGUI.Forms
CanConvertTo Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListBindingConverter Class : CanConvertTo Method

Returns whether this converter can convert the object to the specified type.

Overload List

Overload | Description
CanConvertTo(ITypeDescriptorContext,Type) |
CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from System.ComponentModel.TypeConverter)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListBindingConverter Class
ListBindingConverter Members


CanConvertTo(ITypeDescriptorContext,Type) Method

[image]
Gizmox.WebGUI.Forms
CanConvertTo(ITypeDescriptorContext,Type) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListBindingConverter Class > CanConvertTo Method : CanConvertTo(ITypeDescriptorContext,Type) Method

context
destinationType

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function CanConvertTo( _
   ByVal context As ITypeDescriptorContext, _
   ByVal destinationType As Type _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ListBindingConverter
Dim context As ITypeDescriptorContext
Dim destinationType As Type
Dim value As Boolean

value = instance.CanConvertTo(context, destinationType)
C#
public override bool CanConvertTo(
   ITypeDescriptorContext context,
   Type destinationType
)
Managed Extensions for C++
public: bool CanConvertTo(
   ITypeDescriptorContext* context,
   Type* destinationType
) override
C++/CLI
public:
bool CanConvertTo(
   ITypeDescriptorContext^ context,
   Type^ destinationType
) override

Parameters

context
destinationType

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListBindingConverter Class
ListBindingConverter Members
Overload List


ConvertTo Method

[image]
Gizmox.WebGUI.Forms
ConvertTo Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListBindingConverter Class : ConvertTo Method

Converts the given value object to the specified type, using the arguments.

Overload List

Overload | Description
ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) |
ConvertTo(Object,Type) | Converts the given value object to the specified type, using the arguments. (Inherited from System.ComponentModel.TypeConverter)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListBindingConverter Class
ListBindingConverter Members


ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) Method

[image]
Gizmox.WebGUI.Forms
ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListBindingConverter Class > ConvertTo Method : ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) Method

context
culture
value
destinationType

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function ConvertTo( _
   ByVal context As ITypeDescriptorContext, _
   ByVal culture As CultureInfo, _
   ByVal value As Object, _
   ByVal destinationType As Type _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As ListBindingConverter
Dim context As ITypeDescriptorContext
Dim culture As CultureInfo
Dim value As Object
Dim destinationType As Type
Dim value As Object

value = instance.ConvertTo(context, culture, value, destinationType)
C#
public override object ConvertTo(
   ITypeDescriptorContext context,
   CultureInfo culture,
   object value,
   Type destinationType
)
Managed Extensions for C++
public: Object* ConvertTo(
   ITypeDescriptorContext* context,
   CultureInfo* culture,
   Object* value,
   Type* destinationType
) override
C++/CLI
public:
Object^ ConvertTo(
   ITypeDescriptorContext^ context,
   CultureInfo^ culture,
   Object^ value,
   Type^ destinationType
) override

Parameters

context
culture
value
destinationType

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListBindingConverter Class
ListBindingConverter Members
Overload List


CreateInstance Method

[image]
Gizmox.WebGUI.Forms
CreateInstance Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListBindingConverter Class : CreateInstance Method

Re-creates an Object given a set of property values for the object.

Overload List

Overload | Description
CreateInstance(ITypeDescriptorContext,IDictionary) |
CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from System.ComponentModel.TypeConverter)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListBindingConverter Class
ListBindingConverter Members


CreateInstance(ITypeDescriptorContext,IDictionary) Method

[image]
Gizmox.WebGUI.Forms
CreateInstance(ITypeDescriptorContext,IDictionary) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListBindingConverter Class > CreateInstance Method : CreateInstance(ITypeDescriptorContext,IDictionary) Method

context
propertyValues

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function CreateInstance( _
   ByVal context As ITypeDescriptorContext, _
   ByVal propertyValues As IDictionary _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As ListBindingConverter
Dim context As ITypeDescriptorContext
Dim propertyValues As IDictionary
Dim value As Object

value = instance.CreateInstance(context, propertyValues)
C#
public override object CreateInstance(
   ITypeDescriptorContext context,
   IDictionary propertyValues
)
Managed Extensions for C++
public: Object* CreateInstance(
   ITypeDescriptorContext* context,
   IDictionary* propertyValues
) override
C++/CLI
public:
Object^ CreateInstance(
   ITypeDescriptorContext^ context,
   IDictionary^ propertyValues
) override

Parameters

context
propertyValues

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListBindingConverter Class
ListBindingConverter Members
Overload List


GetCreateInstanceSupported Method

[image]
Gizmox.WebGUI.Forms
GetCreateInstanceSupported Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListBindingConverter Class : GetCreateInstanceSupported Method

Returns whether changing a value on this object requires a call to the CreateInstance method to create a new value.

Overload List

Overload | Description
GetCreateInstanceSupported(ITypeDescriptorContext) |
GetCreateInstanceSupported() | Returns whether changing a value on this object requires a call to the CreateInstance method to create a new value. (Inherited from System.ComponentModel.TypeConverter)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListBindingConverter Class
ListBindingConverter Members


GetCreateInstanceSupported(ITypeDescriptorContext) Method

[image]
Gizmox.WebGUI.Forms
GetCreateInstanceSupported(ITypeDescriptorContext) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListBindingConverter Class > GetCreateInstanceSupported Method : GetCreateInstanceSupported(ITypeDescriptorContext) Method

context

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function GetCreateInstanceSupported( _
   ByVal context As ITypeDescriptorContext _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ListBindingConverter
Dim context As ITypeDescriptorContext
Dim value As Boolean

value = instance.GetCreateInstanceSupported(context)
C#
public override bool GetCreateInstanceSupported(
   ITypeDescriptorContext context
)
Managed Extensions for C++
public: bool GetCreateInstanceSupported(
   ITypeDescriptorContext* context
) override
C++/CLI
public:
bool GetCreateInstanceSupported(
   ITypeDescriptorContext^ context
) override

Parameters

context

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListBindingConverter Class
ListBindingConverter Members
Overload List


ListBindingHelper Class

[image]
Gizmox.WebGUI.Forms
ListBindingHelper Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ListBindingHelper Class

Provides functionality to discover a bindable list and the properties of the items contained in the list when they differ from the public properties of the object to which they bind.

Syntax

Visual Basic (Declaration)
Public Class ListBindingHelper
Visual Basic (Usage) Copy Code
Dim instance As ListBindingHelper
C#
public class ListBindingHelper
Managed Extensions for C++
public __gc class ListBindingHelper
C++/CLI
public ref class ListBindingHelper

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ListBindingHelper

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

ListBindingHelper Members
Gizmox.WebGUI.Forms Namespace


ListBindingHelper Class Members

[image]
Gizmox.WebGUI.Forms
ListBindingHelper Class Members
See Also Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : ListBindingHelper Class

The following tables list the members exposed by ListBindingHelper.

Public Constructors

 | Name | Description
Public Constructor | ListBindingHelper Constructor |
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetList | Overloaded. Returns a list associated with the specified data source.
static (Shared in Visual Basic) | GetListItemProperties | Overloaded. Returns the PropertyDescriptorCollection that describes the properties of an item type contained in a specified data source, or properties of the specified data source.
static (Shared in Visual Basic) | GetListItemType | Overloaded. Returns the data type of the items in the specified list.
static (Shared in Visual Basic) | GetListName | Returns the name of an underlying list, given a data source and optional PropertyDescriptor array.
Top

See Also

Reference

ListBindingHelper Class
Gizmox.WebGUI.Forms Namespace


ListBindingHelper Constructor

[image]
Gizmox.WebGUI.Forms
ListBindingHelper Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListBindingHelper Class : ListBindingHelper Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ListBindingHelper()
C#
public ListBindingHelper()
Managed Extensions for C++
public: ListBindingHelper();
C++/CLI
public:
ListBindingHelper();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListBindingHelper Class
ListBindingHelper Members


ListBindingHelper Class Methods

[image]
Gizmox.WebGUI.Forms
ListBindingHelper Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ListBindingHelper Class

For a list of all members of this type, see ListBindingHelper members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetList | Overloaded. Returns a list associated with the specified data source.
static (Shared in Visual Basic) | GetListItemProperties | Overloaded. Returns the PropertyDescriptorCollection that describes the properties of an item type contained in a specified data source, or properties of the specified data source.
static (Shared in Visual Basic) | GetListItemType | Overloaded. Returns the data type of the items in the specified list.
static (Shared in Visual Basic) | GetListName | Returns the name of an underlying list, given a data source and optional PropertyDescriptor array.
Top

See Also

Reference

ListBindingHelper Class
Gizmox.WebGUI.Forms Namespace


GetList Method

[image]
Gizmox.WebGUI.Forms
GetList Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListBindingHelper Class : GetList Method

Returns a list associated with the specified data source.

Overload List

Overload | Description
GetList(Object) | Returns a list associated with the specified data source.
GetList(Object,String) | Returns an object, typically a list, from the evaluation of a specified data source and optional data member.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListBindingHelper Class
ListBindingHelper Members


GetList(Object) Method

[image]
Gizmox.WebGUI.Forms
GetList(Object) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListBindingHelper Class > GetList Method : GetList(Object) Method

list
The data source to examine for its underlying list.
Returns a list associated with the specified data source.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function GetList( _
   ByVal list As Object _
) As Object
Visual Basic (Usage) Copy Code
Dim list As Object
Dim value As Object

value = ListBindingHelper.GetList(list)
C#
public static object GetList(
   object list
)
Managed Extensions for C++
public: static Object* GetList(
   Object* list
)
C++/CLI
public:
static Object^ GetList(
   Object^ list
)

Parameters

list
The data source to examine for its underlying list.

Return Value

An Object representing the underlying list if it exists; otherwise, the original data source specified by list.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListBindingHelper Class
ListBindingHelper Members
Overload List


GetList(Object,String) Method

[image]
Gizmox.WebGUI.Forms
GetList(Object,String) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListBindingHelper Class > GetList Method : GetList(Object,String) Method

dataSource
The data source from which to find the list.
dataMember
The name of the data source property that contains the list. This can be null.
Returns an object, typically a list, from the evaluation of a specified data source and optional data member.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function GetList( _
   ByVal dataSource As Object, _
   ByVal dataMember As String _
) As Object
Visual Basic (Usage) Copy Code
Dim dataSource As Object
Dim dataMember As String
Dim value As Object

value = ListBindingHelper.GetList(dataSource, dataMember)
C#
public static object GetList(
   object dataSource,
   string dataMember
)
Managed Extensions for C++
public: static Object* GetList(
   Object* dataSource,
   string* dataMember
)
C++/CLI
public:
static Object^ GetList(
   Object^ dataSource,
   String^ dataMember
)

Parameters

dataSource
The data source from which to find the list.
dataMember
The name of the data source property that contains the list. This can be null.

Return Value

An Object representing the underlying list if it was found; otherwise, dataSource.

Exceptions

Exception | Description
ArgumentException | The specified data member name did not match any of the properties found for the data source.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListBindingHelper Class
ListBindingHelper Members
Overload List


GetListItemProperties Method

[image]
Gizmox.WebGUI.Forms
GetListItemProperties Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListBindingHelper Class : GetListItemProperties Method

Returns the PropertyDescriptorCollection that describes the properties of an item type contained in a specified data source, or properties of the specified data source.

Overload List

Overload | Description
GetListItemProperties(Object) | Returns the PropertyDescriptorCollection that describes the properties of an item type contained in a specified data source, or properties of the specified data source.
GetListItemProperties(Object,PropertyDescriptor[]) | Returns the PropertyDescriptorCollection that describes the properties of an item type contained in a collection property of a data source. Uses the specified PropertyDescriptor array to indicate which properties to examine.
GetListItemProperties(Object,String,PropertyDescriptor[]) | Returns the PropertyDescriptorCollection that describes the properties of an item type contained in the specified data member of a data source. Uses the specified PropertyDescriptor array to indicate which properties to examine.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListBindingHelper Class
ListBindingHelper Members


GetListItemProperties(Object) Method

[image]
Gizmox.WebGUI.Forms
GetListItemProperties(Object) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListBindingHelper Class > GetListItemProperties Method : GetListItemProperties(Object) Method

list
The data source to examine for property information.
Returns the PropertyDescriptorCollection that describes the properties of an item type contained in a specified data source, or properties of the specified data source.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function GetListItemProperties( _
   ByVal list As Object _
) As PropertyDescriptorCollection
Visual Basic (Usage) Copy Code
Dim list As Object
Dim value As PropertyDescriptorCollection

value = ListBindingHelper.GetListItemProperties(list)
C#
public static PropertyDescriptorCollection GetListItemProperties(
   object list
)
Managed Extensions for C++
public: static PropertyDescriptorCollection* GetListItemProperties(
   Object* list
)
C++/CLI
public:
static PropertyDescriptorCollection^ GetListItemProperties(
   Object^ list
)

Parameters

list
The data source to examine for property information.

Return Value

The PropertyDescriptorCollection containing the properties of the items contained in list, or properties of list.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListBindingHelper Class
ListBindingHelper Members
Overload List


GetListItemProperties(Object,PropertyDescriptor[]) Method

[image]
Gizmox.WebGUI.Forms
GetListItemProperties(Object,PropertyDescriptor[]) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListBindingHelper Class > GetListItemProperties Method : GetListItemProperties(Object,PropertyDescriptor[]) Method

list
The data source to be examined for property information.
listAccessors
The PropertyDescriptor array describing which properties of the data source to examine. This can be null.
Returns the PropertyDescriptorCollection that describes the properties of an item type contained in a collection property of a data source. Uses the specified PropertyDescriptor array to indicate which properties to examine.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function GetListItemProperties( _
   ByVal list As Object, _
   ByVal listAccessors() As PropertyDescriptor _
) As PropertyDescriptorCollection
Visual Basic (Usage) Copy Code
Dim list As Object
Dim listAccessors() As PropertyDescriptor
Dim value As PropertyDescriptorCollection

value = ListBindingHelper.GetListItemProperties(list, listAccessors)
C#
public static PropertyDescriptorCollection GetListItemProperties(
   object list,
   PropertyDescriptor[] listAccessors
)
Managed Extensions for C++
public: static PropertyDescriptorCollection* GetListItemProperties(
   Object* list,
   PropertyDescriptor*[]* listAccessors
)
C++/CLI
public:
static PropertyDescriptorCollection^ GetListItemProperties(
   Object^ list,
   array<PropertyDescriptor^>^ listAccessors
)

Parameters

list
The data source to be examined for property information.
listAccessors
The PropertyDescriptor array describing which properties of the data source to examine. This can be null.

Return Value

The PropertyDescriptorCollection describing the properties of the item type contained in a collection property of the data source.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListBindingHelper Class
ListBindingHelper Members
Overload List


GetListItemProperties(Object,String,PropertyDescriptor[]) Method

[image]
Gizmox.WebGUI.Forms
GetListItemProperties(Object,String,PropertyDescriptor[]) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListBindingHelper Class > GetListItemProperties Method : GetListItemProperties(Object,String,PropertyDescriptor[]) Method

dataSource
The data source to be examined for property information.
dataMember
The optional data member to be examined for property information. This can be null.
listAccessors
The PropertyDescriptor array describing which properties of the data member to examine. This can be null.
Returns the PropertyDescriptorCollection that describes the properties of an item type contained in the specified data member of a data source. Uses the specified PropertyDescriptor array to indicate which properties to examine.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function GetListItemProperties( _
   ByVal dataSource As Object, _
   ByVal dataMember As String, _
   ByVal listAccessors() As PropertyDescriptor _
) As PropertyDescriptorCollection
Visual Basic (Usage) Copy Code
Dim dataSource As Object
Dim dataMember As String
Dim listAccessors() As PropertyDescriptor
Dim value As PropertyDescriptorCollection

value = ListBindingHelper.GetListItemProperties(dataSource, dataMember, listAccessors)
C#
public static PropertyDescriptorCollection GetListItemProperties(
   object dataSource,
   string dataMember,
   PropertyDescriptor[] listAccessors
)
Managed Extensions for C++
public: static PropertyDescriptorCollection* GetListItemProperties(
   Object* dataSource,
   string* dataMember,
   PropertyDescriptor*[]* listAccessors
)
C++/CLI
public:
static PropertyDescriptorCollection^ GetListItemProperties(
   Object^ dataSource,
   String^ dataMember,
   array<PropertyDescriptor^>^ listAccessors
)

Parameters

dataSource
The data source to be examined for property information.
dataMember
The optional data member to be examined for property information. This can be null.
listAccessors
The PropertyDescriptor array describing which properties of the data member to examine. This can be null.

Return Value

The PropertyDescriptorCollection describing the properties of an item type contained in a collection property of the specified data source.

Exceptions

Exception | Description
ArgumentException | The specified data member could not be found in the specified data source.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListBindingHelper Class
ListBindingHelper Members
Overload List


GetListItemType Method

[image]
Gizmox.WebGUI.Forms
GetListItemType Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListBindingHelper Class : GetListItemType Method

Returns the data type of the items in the specified list.

Overload List

Overload | Description
GetListItemType(Object) | Returns the data type of the items in the specified list.
GetListItemType(Object,String) | Returns the data type of the items in the specified data source.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListBindingHelper Class
ListBindingHelper Members


GetListItemType(Object) Method

[image]
Gizmox.WebGUI.Forms
GetListItemType(Object) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListBindingHelper Class > GetListItemType Method : GetListItemType(Object) Method

list
The list to be examined for type information.
Returns the data type of the items in the specified list.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function GetListItemType( _
   ByVal list As Object _
) As Type
Visual Basic (Usage) Copy Code
Dim list As Object
Dim value As Type

value = ListBindingHelper.GetListItemType(list)
C#
public static Type GetListItemType(
   object list
)
Managed Extensions for C++
public: static Type* GetListItemType(
   Object* list
)
C++/CLI
public:
static Type^ GetListItemType(
   Object^ list
)

Parameters

list
The list to be examined for type information.

Return Value

The Type of the items contained in the list.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListBindingHelper Class
ListBindingHelper Members
Overload List


GetListItemType(Object,String) Method

[image]
Gizmox.WebGUI.Forms
GetListItemType(Object,String) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListBindingHelper Class > GetListItemType Method : GetListItemType(Object,String) Method

dataSource
The data source to examine for items.
dataMember
The optional name of the property on the data source that is to be used as the data member. This can be null.
Returns the data type of the items in the specified data source.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function GetListItemType( _
   ByVal dataSource As Object, _
   ByVal dataMember As String _
) As Type
Visual Basic (Usage) Copy Code
Dim dataSource As Object
Dim dataMember As String
Dim value As Type

value = ListBindingHelper.GetListItemType(dataSource, dataMember)
C#
public static Type GetListItemType(
   object dataSource,
   string dataMember
)
Managed Extensions for C++
public: static Type* GetListItemType(
   Object* dataSource,
   string* dataMember
)
C++/CLI
public:
static Type^ GetListItemType(
   Object^ dataSource,
   String^ dataMember
)

Parameters

dataSource
The data source to examine for items.
dataMember
The optional name of the property on the data source that is to be used as the data member. This can be null.

Return Value

For complex data binding, the Type of the items represented by the dataMember in the data source; otherwise, the Type of the item in the list itself.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListBindingHelper Class
ListBindingHelper Members
Overload List


GetListName Method

[image]
Gizmox.WebGUI.Forms
GetListName Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListBindingHelper Class : GetListName Method

list
The data source to examine for the list name.
listAccessors
An array of PropertyDescriptor objects to find in the data source. This can be null.
Returns the name of an underlying list, given a data source and optional PropertyDescriptor array.

Syntax

Visual Basic (Declaration)
Public Shared Function GetListName( _
   ByVal list As Object, _
   ByVal listAccessors() As PropertyDescriptor _
) As String
Visual Basic (Usage) Copy Code
Dim list As Object
Dim listAccessors() As PropertyDescriptor
Dim value As String

value = ListBindingHelper.GetListName(list, listAccessors)
C#
public static string GetListName(
   object list,
   PropertyDescriptor[] listAccessors
)
Managed Extensions for C++
public: static string* GetListName(
   Object* list,
   PropertyDescriptor*[]* listAccessors
)
C++/CLI
public:
static String^ GetListName(
   Object^ list,
   array<PropertyDescriptor^>^ listAccessors
)

Parameters

list
The data source to examine for the list name.
listAccessors
An array of PropertyDescriptor objects to find in the data source. This can be null.

Return Value

The name of the list in the data source, as described by listAccessors, orthe name of the data source type.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListBindingHelper Class
ListBindingHelper Members


ListBox Class

[image]
Gizmox.WebGUI.Forms
ListBox Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ListBox Class

Implementation of ListBox class.

Object Model

Syntax

Visual Basic (Declaration)
<MetadataTagAttribute("LX")>
<DesignTimeControllerAttribute()>
<ToolboxBitmapAttribute()>
<SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableListBox, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")>
<ClientControllerAttribute()>
<ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
Public Class ListBox
   Inherits ListControl
   Implements IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Visual Basic (Usage) Copy Code
Dim instance As ListBox
C#
[MetadataTagAttribute("LX")]
[DesignTimeControllerAttribute()]
[ToolboxBitmapAttribute()]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableListBox, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[ClientControllerAttribute()]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
public class ListBox : ListControl, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Managed Extensions for C++
[MetadataTagAttribute("LX")]
[DesignTimeControllerAttribute()]
[ToolboxBitmapAttribute()]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableListBox, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[ClientControllerAttribute()]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
public __gc class ListBox : public ListControl, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
C++/CLI
[MetadataTagAttribute("LX")]
[DesignTimeControllerAttribute()]
[ToolboxBitmapAttribute()]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableListBox, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[ClientControllerAttribute()]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
public ref class ListBox : public ListControl, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.ListControl
Gizmox.WebGUI.Forms.ListBox
Gizmox.WebGUI.Forms.CheckedListBox
Gizmox.WebGUI.Forms.ColorListBox

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

ListBox Members
Gizmox.WebGUI.Forms Namespace


ListBox Class Members

[image]
Gizmox.WebGUI.Forms
ListBox Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : ListBox Class

The following tables list the members exposed by ListBox.

Public Constructors

 | Name | Description
Public Constructor | ListBox Constructor | Initializes a new instance of the ListBox class.
Top

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | CheckBoxes | Gets or sets a value indicating whether [check boxes].
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | DataSource | Gets or sets the data source for this ListControl. (Inherited from ListControl)
Public Property | DisplayMember | Gets or sets the property to display for this ListControl. (Inherited from ListControl)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | FormatInfo | Gets or sets the IFormatProvider that provides custom formatting behavior. (Inherited from ListControl)
Public Property | FormatString | Gets or sets the format-specifier characters that indicate how a value is to be displayed. (Inherited from ListControl)
Public Property | FormattingEnabled | Gets or sets a value indicating whether formatting is applied to the ListControl.DisplayMember property of the ListControl. (Inherited from ListControl)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | Items | Gets the items of the ListBox.
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | RadioBoxes | Gets or sets a value indicating whether [radio boxes].
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | SelectedIndex | Overridden. Gets or sets the zero-based index of the currently selected item in a ListBox.
Public Property | SelectedIndices | Gets a collection that contains the zero-based indexes of all currently selected items in the ListBox.
Public Property | SelectedItem | Gets or sets the currently selected item in the ListBox.
Public Property | SelectedItems | Gets a collection containing the currently selected items in the ListBox.
Public Property | SelectedValue | Gets or sets the value of the member property specified by the ListControl.ValueMember property. (Inherited from ListControl)
Public Property | SelectionMode | Gets or sets the method in which items are selected in the ListBox.
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | Sorted | Gets or sets a value indicating whether the items in the ListBox are sorted alphabetically.
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Control)
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | ValueMember | Gets or sets the property to use as the actual value for the items in the ListControl. (Inherited from ListControl)
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | AllowSelection | Gets a value indicating whether the list enables selection of list items. (Inherited from ListControl)
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DataManager | Gets the CurrencyManager associated with this control. (Inherited from ListControl)
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | Overridden. Gets a value indicating whether this instance is delayed drawing.
Protected Property | IsPostBackRequired | Indicates if the list control context requires its events to cause callback (Inherited from ListControl)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | ClearSelected | Unselects all items in the ListBox.
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | FindString | Overloaded. Finds the first item in the ListBox that starts with the specified string.
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetItemText | Returns the text representation of the specified item. (Inherited from ListControl)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | SetSelected | Selects or clears the selection for the specified item in a ListBox.
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | SwapItems | Swaps the items.
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | CreateItemCollection | Creates the item collection.
Protected Method | FilterItemOnProperty | Overloaded. Retrieves the current value of the ListControl item, if it is a property of an object, given the item. (Inherited from ListControl)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Overridden. Fires an event.
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Overridden. Gets the critical events.
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from Control)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from ListControl)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDataSourceChanged | Overridden. Raises the ListControl.DataSourceChanged event.
Protected Method | OnDisplayMemberChanged | Overridden.
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnFormat | Raises the ListControl.Format event. (Inherited from ListControl)
Protected Method | OnFormatInfoChanged | Raises the ListControl.FormatInfoChanged event. (Inherited from ListControl)
Protected Method | OnFormatStringChanged | Raises the ListControl.FormatStringChanged event. (Inherited from ListControl)
Protected Method | OnFormattingEnabledChanged | Raises the ListControl.FormattingEnabledChanged event. (Inherited from ListControl)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnSelectedIndexChanged | Overridden.
Protected Method | OnSelectedValueChanged | Raises the ListControl.SelectedValueChanged event. (Inherited from ListControl)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnValueMemberChanged | Raises the ListControl.ValueMemberChanged event. (Inherited from ListControl)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RefreshItem | Overridden. When overridden in a derived class, resynchronizes the data of the object at the specified index with the contents of the data source.
Protected Method | RefreshItems | Overridden. Refreshes all ListBox items and retrieves new strings for them.
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | Overridden. Renders the current control.
Protected Method | RenderAttributes | Renders the controls meta attributes (Inherited from Control)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderItemAttributes |
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetItemCore | When overridden in a derived class, sets the object with the specified index in the derived class. (Inherited from ListControl)
Protected Method | SetItemsCore | Overridden. When overridden in a derived class, sets the specified array of objects in a collection in the derived class.
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSelectionMode | Should serialize selection mode.
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | Sort | Sorts the items in the ListBox.
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | DataSourceChanged | Occurs when the ListControl.DataSource changes. (Inherited from ListControl)
Public Event | DisplayMemberChanged | Occurs when the ListControl.DisplayMember property changes. (Inherited from ListControl)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | Format | Occurs when the control is bound to a data value. (Inherited from ListControl)
Public Event | FormatInfoChanged | Occurs when the value of the ListControl.FormatInfo property changes. (Inherited from ListControl)
Public Event | FormatStringChanged | Occurs when value of the ListControl.FormatString property changes (Inherited from ListControl)
Public Event | FormattingEnabledChanged | Occurs when the value of the ListControl.FormattingEnabled property changes. (Inherited from ListControl)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | SelectedIndexChanged | Occurs when the SelectedIndex property has changed.
Public Event | SelectedValueChanged | Occurs when the ListControl.SelectedValue property changes. (Inherited from ListControl)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | ValueMemberChanged | Occurs when the ListControl.ValueMember property changes. (Inherited from ListControl)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

ListBox Class
Gizmox.WebGUI.Forms Namespace


ListBox Constructor

[image]
Gizmox.WebGUI.Forms
ListBox Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListBox Class : ListBox Constructor

Initializes a new instance of the ListBox class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ListBox()
C#
public ListBox()
Managed Extensions for C++
public: ListBox();
C++/CLI
public:
ListBox();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListBox Class
ListBox Members


ListBox Class Methods

[image]
Gizmox.WebGUI.Forms
ListBox Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ListBox Class

For a list of all members of this type, see ListBox members.

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | ClearSelected | Unselects all items in the ListBox.
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | FindString | Overloaded. Finds the first item in the ListBox that starts with the specified string.
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetItemText | Returns the text representation of the specified item. (Inherited from ListControl)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | SetSelected | Selects or clears the selection for the specified item in a ListBox.
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | SwapItems | Swaps the items.
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | CreateItemCollection | Creates the item collection.
Protected Method | FilterItemOnProperty | Overloaded. Retrieves the current value of the ListControl item, if it is a property of an object, given the item. (Inherited from ListControl)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Overridden. Fires an event.
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Overridden. Gets the critical events.
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from Control)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from ListControl)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDataSourceChanged | Overridden. Raises the ListControl.DataSourceChanged event.
Protected Method | OnDisplayMemberChanged | Overridden.
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnFormat | Raises the ListControl.Format event. (Inherited from ListControl)
Protected Method | OnFormatInfoChanged | Raises the ListControl.FormatInfoChanged event. (Inherited from ListControl)
Protected Method | OnFormatStringChanged | Raises the ListControl.FormatStringChanged event. (Inherited from ListControl)
Protected Method | OnFormattingEnabledChanged | Raises the ListControl.FormattingEnabledChanged event. (Inherited from ListControl)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnSelectedIndexChanged | Overridden.
Protected Method | OnSelectedValueChanged | Raises the ListControl.SelectedValueChanged event. (Inherited from ListControl)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnValueMemberChanged | Raises the ListControl.ValueMemberChanged event. (Inherited from ListControl)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RefreshItem | Overridden. When overridden in a derived class, resynchronizes the data of the object at the specified index with the contents of the data source.
Protected Method | RefreshItems | Overridden. Refreshes all ListBox items and retrieves new strings for them.
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | Overridden. Renders the current control.
Protected Method | RenderAttributes | Renders the controls meta attributes (Inherited from Control)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderItemAttributes |
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetItemCore | When overridden in a derived class, sets the object with the specified index in the derived class. (Inherited from ListControl)
Protected Method | SetItemsCore | Overridden. When overridden in a derived class, sets the specified array of objects in a collection in the derived class.
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSelectionMode | Should serialize selection mode.
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | Sort | Sorts the items in the ListBox.
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

See Also

Reference

ListBox Class
Gizmox.WebGUI.Forms Namespace


ClearSelected Method

[image]
Gizmox.WebGUI.Forms
ClearSelected Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListBox Class : ClearSelected Method

Unselects all items in the ListBox.

Syntax

Visual Basic (Declaration)
Public Sub ClearSelected()
Visual Basic (Usage) Copy Code
Dim instance As ListBox

instance.ClearSelected()
C#
public void ClearSelected()
Managed Extensions for C++
public: void ClearSelected();
C++/CLI
public:
void ClearSelected();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListBox Class
ListBox Members


CreateItemCollection Method

[image]
Gizmox.WebGUI.Forms
CreateItemCollection Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListBox Class : CreateItemCollection Method

Creates the item collection.

Syntax

Visual Basic (Declaration)
Protected Overridable Function CreateItemCollection() As ListBox.ObjectCollection
Visual Basic (Usage) Copy Code
Dim instance As ListBox
Dim value As ListBox.ObjectCollection

value = instance.CreateItemCollection()
C#
protected virtual ListBox.ObjectCollection CreateItemCollection()
Managed Extensions for C++
protected: virtual ListBox.ObjectCollection* CreateItemCollection();
C++/CLI
protected:
virtual ListBox::ObjectCollection^ CreateItemCollection();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListBox Class
ListBox Members


FindString Method

[image]
Gizmox.WebGUI.Forms
FindString Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListBox Class : FindString Method

Finds the first item in the ListBox that starts with the specified string.

Overload List

Overload | Description
FindString(String) | Finds the first item in the ListBox that starts with the specified string.
FindString(String,Int32) | Finds the first item in the ListBox that starts with the specified string. The search starts at a specific starting index.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListBox Class
ListBox Members


FindString(String) Method

[image]
Gizmox.WebGUI.Forms
FindString(String) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListBox Class > FindString Method : FindString(String) Method

strValue
The text to search for.
Finds the first item in the ListBox that starts with the specified string.

Syntax

Visual Basic (Declaration)
Public Overloads Function FindString( _
   ByVal strValue As String _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As ListBox
Dim strValue As String
Dim value As Integer

value = instance.FindString(strValue)
C#
public int FindString(
   string strValue
)
Managed Extensions for C++
public: int FindString(
   string* strValue
)
C++/CLI
public:
int FindString(
   String^ strValue
)

Parameters

strValue
The text to search for.

Return Value

The zero-based index of the first item found; returns ListBox.NoMatches if no match is found.

Exceptions

Exception | Description
ArgumentOutOfRangeException | The value of the s parameter is less than -1 or greater than or equal to the item count.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListBox Class
ListBox Members
Overload List


FindString(String,Int32) Method

[image]
Gizmox.WebGUI.Forms
FindString(String,Int32) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListBox Class > FindString Method : FindString(String,Int32) Method

strValue
The text to search for.
intStartIndex
The zero-based index of the item before the first item to be searched. Set to negative one (-1) to search from the beginning of the control.
Finds the first item in the ListBox that starts with the specified string. The search starts at a specific starting index.

Syntax

Visual Basic (Declaration)
Public Overloads Function FindString( _
   ByVal strValue As String, _
   ByVal intStartIndex As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As ListBox
Dim strValue As String
Dim intStartIndex As Integer
Dim value As Integer

value = instance.FindString(strValue, intStartIndex)
C#
public int FindString(
   string strValue,
   int intStartIndex
)
Managed Extensions for C++
public: int FindString(
   string* strValue,
   int intStartIndex
)
C++/CLI
public:
int FindString(
   String^ strValue,
   int intStartIndex
)

Parameters

strValue
The text to search for.
intStartIndex
The zero-based index of the item before the first item to be searched. Set to negative one (-1) to search from the beginning of the control.

Return Value

The zero-based index of the first item found; returns ListBox.NoMatches if no match is found.

Exceptions

Exception | Description
ArgumentOutOfRangeException | The startIndex parameter is less than zero or greater than or equal to the value of the ListBox+ObjectCollection.Count property of the ListBox.ObjectCollection class.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListBox Class
ListBox Members
Overload List


FireEvent Method

[image]
Gizmox.WebGUI.Forms
FireEvent Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListBox Class : FireEvent Method

objEvent
event.
Fires an event.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub FireEvent( _
   ByVal objEvent As IEvent _
)
Visual Basic (Usage) Copy Code
Dim instance As ListBox
Dim objEvent As IEvent

instance.FireEvent(objEvent)
C#
protected override void FireEvent(
   IEvent objEvent
)
Managed Extensions for C++
protected: void FireEvent(
   IEvent* objEvent
) override
C++/CLI
protected:
void FireEvent(
   IEvent^ objEvent
) override

Parameters

objEvent
event.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListBox Class
ListBox Members


GetCriticalEvents Method

[image]
Gizmox.WebGUI.Forms
GetCriticalEvents Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListBox Class : GetCriticalEvents Method

Gets the critical events.

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetCriticalEvents() As EventTypes
Visual Basic (Usage) Copy Code
Dim instance As ListBox
Dim value As EventTypes

value = instance.GetCriticalEvents()
C#
protected override EventTypes GetCriticalEvents()
Managed Extensions for C++
protected: EventTypes GetCriticalEvents(); override
C++/CLI
protected:
EventTypes GetCriticalEvents(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListBox Class
ListBox Members


OnDataSourceChanged Method

[image]
Gizmox.WebGUI.Forms
OnDataSourceChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListBox Class : OnDataSourceChanged Method

e
An EventArgs that contains the event data.
Raises the ListControl.DataSourceChanged event.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnDataSourceChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ListBox
Dim e As EventArgs

instance.OnDataSourceChanged(e)
C#
protected override void OnDataSourceChanged(
   EventArgs e
)
Managed Extensions for C++
protected: void OnDataSourceChanged(
   EventArgs* e
) override
C++/CLI
protected:
void OnDataSourceChanged(
   EventArgs^ e
) override

Parameters

e
An EventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListBox Class
ListBox Members


OnDisplayMemberChanged Method

[image]
Gizmox.WebGUI.Forms
OnDisplayMemberChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListBox Class : OnDisplayMemberChanged Method

e

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnDisplayMemberChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ListBox
Dim e As EventArgs

instance.OnDisplayMemberChanged(e)
C#
protected override void OnDisplayMemberChanged(
   EventArgs e
)
Managed Extensions for C++
protected: void OnDisplayMemberChanged(
   EventArgs* e
) override
C++/CLI
protected:
void OnDisplayMemberChanged(
   EventArgs^ e
) override

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListBox Class
ListBox Members


OnSelectedIndexChanged Method

[image]
Gizmox.WebGUI.Forms
OnSelectedIndexChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListBox Class : OnSelectedIndexChanged Method

e

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnSelectedIndexChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ListBox
Dim e As EventArgs

instance.OnSelectedIndexChanged(e)
C#
protected override void OnSelectedIndexChanged(
   EventArgs e
)
Managed Extensions for C++
protected: void OnSelectedIndexChanged(
   EventArgs* e
) override
C++/CLI
protected:
void OnSelectedIndexChanged(
   EventArgs^ e
) override

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListBox Class
ListBox Members


RefreshItem Method

[image]
Gizmox.WebGUI.Forms
RefreshItem Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListBox Class : RefreshItem Method

index
The zero-based index of the item whose data to refresh.
When overridden in a derived class, resynchronizes the data of the object at the specified index with the contents of the data source.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub RefreshItem( _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As ListBox
Dim index As Integer

instance.RefreshItem(index)
C#
protected override void RefreshItem(
   int index
)
Managed Extensions for C++
protected: void RefreshItem(
   int index
) override
C++/CLI
protected:
void RefreshItem(
   int index
) override

Parameters

index
The zero-based index of the item whose data to refresh.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListBox Class
ListBox Members


RefreshItems Method

[image]
Gizmox.WebGUI.Forms
RefreshItems Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListBox Class : RefreshItems Method

Refreshes all ListBox items and retrieves new strings for them.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub RefreshItems()
Visual Basic (Usage) Copy Code
Dim instance As ListBox

instance.RefreshItems()
C#
protected override void RefreshItems()
Managed Extensions for C++
protected: void RefreshItems(); override
C++/CLI
protected:
void RefreshItems(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListBox Class
ListBox Members


Render Method

[image]
Gizmox.WebGUI.Forms
Render Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListBox Class : Render Method

objContext
Request context.
objWriter
lngRequestID
Renders the current control.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub Render( _
   ByVal objContext As IContext, _
   ByVal objWriter As IResponseWriter, _
   ByVal lngRequestID As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As ListBox
Dim objContext As IContext
Dim objWriter As IResponseWriter
Dim lngRequestID As Long

instance.Render(objContext, objWriter, lngRequestID)
C#
protected override void Render(
   IContext objContext,
   IResponseWriter objWriter,
   long lngRequestID
)
Managed Extensions for C++
protected: void Render(
   IContext* objContext,
   IResponseWriter* objWriter,
   long lngRequestID
) override
C++/CLI
protected:
void Render(
   IContext^ objContext,
   IResponseWriter^ objWriter,
   long long lngRequestID
) override

Parameters

objContext
Request context.
objWriter
lngRequestID

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListBox Class
ListBox Members


RenderItemAttributes Method

[image]
Gizmox.WebGUI.Forms
RenderItemAttributes Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListBox Class : RenderItemAttributes Method

objWriter
objItem
intIndex

Syntax

Visual Basic (Declaration)
Protected Overridable Sub RenderItemAttributes( _
   ByVal objWriter As IResponseWriter, _
   ByVal objItem As Object, _
   ByVal intIndex As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As ListBox
Dim objWriter As IResponseWriter
Dim objItem As Object
Dim intIndex As Integer

instance.RenderItemAttributes(objWriter, objItem, intIndex)
C#
protected virtual void RenderItemAttributes(
   IResponseWriter objWriter,
   object objItem,
   int intIndex
)
Managed Extensions for C++
protected: virtual void RenderItemAttributes(
   IResponseWriter* objWriter,
   Object* objItem,
   int intIndex
)
C++/CLI
protected:
virtual void RenderItemAttributes(
   IResponseWriter^ objWriter,
   Object^ objItem,
   int intIndex
)

Parameters

objWriter
objItem
intIndex

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListBox Class
ListBox Members


SetItemsCore Method

[image]
Gizmox.WebGUI.Forms
SetItemsCore Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListBox Class : SetItemsCore Method

items
An array of items.
When overridden in a derived class, sets the specified array of objects in a collection in the derived class.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub SetItemsCore( _
   ByVal items As IList _
)
Visual Basic (Usage) Copy Code
Dim instance As ListBox
Dim items As IList

instance.SetItemsCore(items)
C#
protected override void SetItemsCore(
   IList items
)
Managed Extensions for C++
protected: void SetItemsCore(
   IList* items
) override
C++/CLI
protected:
void SetItemsCore(
   IList^ items
) override

Parameters

items
An array of items.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListBox Class
ListBox Members


SetSelected Method

[image]
Gizmox.WebGUI.Forms
SetSelected Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListBox Class : SetSelected Method

index
The zero-based index of the item in a ListBox to select or clear the selection for.
value
true to select the specified item; otherwise, false.
Selects or clears the selection for the specified item in a ListBox.

Syntax

Visual Basic (Declaration)
Public Sub SetSelected( _
   ByVal index As Integer, _
   ByVal value As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ListBox
Dim index As Integer
Dim value As Boolean

instance.SetSelected(index, value)
C#
public void SetSelected(
   int index,
   bool value
)
Managed Extensions for C++
public: void SetSelected(
   int index,
   bool value
)
C++/CLI
public:
void SetSelected(
   int index,
   bool value
)

Parameters

index
The zero-based index of the item in a ListBox to select or clear the selection for.
value
true to select the specified item; otherwise, false.

Exceptions

Exception | Description
InvalidOperationException | The SelectionMode property was set to None.
ArgumentOutOfRangeException | The specified index was outside the range of valid values.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListBox Class
ListBox Members


ShouldSerializeSelectionMode Method

[image]
Gizmox.WebGUI.Forms
ShouldSerializeSelectionMode Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListBox Class : ShouldSerializeSelectionMode Method

Should serialize selection mode.

Syntax

Visual Basic (Declaration)
Protected Overridable Function ShouldSerializeSelectionMode() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ListBox
Dim value As Boolean

value = instance.ShouldSerializeSelectionMode()
C#
protected virtual bool ShouldSerializeSelectionMode()
Managed Extensions for C++
protected: virtual bool ShouldSerializeSelectionMode();
C++/CLI
protected:
virtual bool ShouldSerializeSelectionMode();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListBox Class
ListBox Members


Sort Method

[image]
Gizmox.WebGUI.Forms
Sort Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListBox Class : Sort Method

Sorts the items in the ListBox.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub Sort()
Visual Basic (Usage) Copy Code
Dim instance As ListBox

instance.Sort()
C#
protected virtual void Sort()
Managed Extensions for C++
protected: virtual void Sort();
C++/CLI
protected:
virtual void Sort();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListBox Class
ListBox Members


SwapItems Method

[image]
Gizmox.WebGUI.Forms
SwapItems Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListBox Class : SwapItems Method

intIndexA
The int index A.
intIndexB
The int index B.
Swaps the items.

Syntax

Visual Basic (Declaration)
Public Overridable Sub SwapItems( _
   ByVal intIndexA As Integer, _
   ByVal intIndexB As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As ListBox
Dim intIndexA As Integer
Dim intIndexB As Integer

instance.SwapItems(intIndexA, intIndexB)
C#
public virtual void SwapItems(
   int intIndexA,
   int intIndexB
)
Managed Extensions for C++
public: virtual void SwapItems(
   int intIndexA,
   int intIndexB
)
C++/CLI
public:
virtual void SwapItems(
   int intIndexA,
   int intIndexB
)

Parameters

intIndexA
The int index A.
intIndexB
The int index B.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListBox Class
ListBox Members


ListBox Class Properties

[image]
Gizmox.WebGUI.Forms
ListBox Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ListBox Class

For a list of all members of this type, see ListBox members.

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | CheckBoxes | Gets or sets a value indicating whether [check boxes].
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | DataSource | Gets or sets the data source for this ListControl. (Inherited from ListControl)
Public Property | DisplayMember | Gets or sets the property to display for this ListControl. (Inherited from ListControl)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | FormatInfo | Gets or sets the IFormatProvider that provides custom formatting behavior. (Inherited from ListControl)
Public Property | FormatString | Gets or sets the format-specifier characters that indicate how a value is to be displayed. (Inherited from ListControl)
Public Property | FormattingEnabled | Gets or sets a value indicating whether formatting is applied to the ListControl.DisplayMember property of the ListControl. (Inherited from ListControl)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | Items | Gets the items of the ListBox.
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | RadioBoxes | Gets or sets a value indicating whether [radio boxes].
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | SelectedIndex | Overridden. Gets or sets the zero-based index of the currently selected item in a ListBox.
Public Property | SelectedIndices | Gets a collection that contains the zero-based indexes of all currently selected items in the ListBox.
Public Property | SelectedItem | Gets or sets the currently selected item in the ListBox.
Public Property | SelectedItems | Gets a collection containing the currently selected items in the ListBox.
Public Property | SelectedValue | Gets or sets the value of the member property specified by the ListControl.ValueMember property. (Inherited from ListControl)
Public Property | SelectionMode | Gets or sets the method in which items are selected in the ListBox.
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | Sorted | Gets or sets a value indicating whether the items in the ListBox are sorted alphabetically.
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Control)
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | ValueMember | Gets or sets the property to use as the actual value for the items in the ListControl. (Inherited from ListControl)
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | AllowSelection | Gets a value indicating whether the list enables selection of list items. (Inherited from ListControl)
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DataManager | Gets the CurrencyManager associated with this control. (Inherited from ListControl)
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | Overridden. Gets a value indicating whether this instance is delayed drawing.
Protected Property | IsPostBackRequired | Indicates if the list control context requires its events to cause callback (Inherited from ListControl)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

See Also

Reference

ListBox Class
Gizmox.WebGUI.Forms Namespace


CheckBoxes Property

[image]
Gizmox.WebGUI.Forms
CheckBoxes Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListBox Class : CheckBoxes Property

Gets or sets a value indicating whether [check boxes].

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property CheckBoxes As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ListBox
Dim value As Boolean

instance.CheckBoxes = value

value = instance.CheckBoxes
C#
[DefaultValueAttribute()]
public bool CheckBoxes {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property bool get_CheckBoxes();
public: __property void set_CheckBoxes(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
public:
property bool CheckBoxes {
   bool get();
   void set (boolvalue);
}

Return Value

true if [check boxes]; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListBox Class
ListBox Members


IsDelayedDrawing Property

[image]
Gizmox.WebGUI.Forms
IsDelayedDrawing Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListBox Class : IsDelayedDrawing Property

Gets a value indicating whether this instance is delayed drawing.

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property IsDelayedDrawing As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ListBox
Dim value As Boolean

value = instance.IsDelayedDrawing
C#
protected override bool IsDelayedDrawing {get;}
Managed Extensions for C++
protected: __property bool get_IsDelayedDrawing() override;
C++/CLI
protected:
property bool IsDelayedDrawing {
   bool get() override;
}

Return Value

true if this instance is delayed drawing; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListBox Class
ListBox Members


Items Property

[image]
Gizmox.WebGUI.Forms
Items Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListBox Class : Items Property

Gets the items of the ListBox.

Syntax

Visual Basic (Declaration)
<LocalizableAttribute(True)>
<SRCategoryAttribute("Data")>
<EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.ListControlStringCollectionEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")>
<SRDescriptionAttribute("The items in the list box.")>
<DesignerSerializationVisibilityAttribute()>
Public ReadOnly Property Items As ListBox.ObjectCollection
Visual Basic (Usage) Copy Code
Dim instance As ListBox
Dim value As ListBox.ObjectCollection

value = instance.Items
C#
[LocalizableAttribute(true)]
[SRCategoryAttribute("Data")]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.ListControlStringCollectionEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[SRDescriptionAttribute("The items in the list box.")]
[DesignerSerializationVisibilityAttribute()]
public ListBox.ObjectCollection Items {get;}
Managed Extensions for C++
[LocalizableAttribute(true)]
[SRCategoryAttribute("Data")]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.ListControlStringCollectionEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[SRDescriptionAttribute("The items in the list box.")]
[DesignerSerializationVisibilityAttribute()]
public: __property ListBox.ObjectCollection* get_Items();
C++/CLI
[LocalizableAttribute(true)]
[SRCategoryAttribute("Data")]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.ListControlStringCollectionEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[SRDescriptionAttribute("The items in the list box.")]
[DesignerSerializationVisibilityAttribute()]
public:
property ListBox::ObjectCollection^ Items {
   ListBox::ObjectCollection^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListBox Class
ListBox Members


RadioBoxes Property

[image]
Gizmox.WebGUI.Forms
RadioBoxes Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListBox Class : RadioBoxes Property

Gets or sets a value indicating whether [radio boxes].

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property RadioBoxes As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ListBox
Dim value As Boolean

instance.RadioBoxes = value

value = instance.RadioBoxes
C#
[DefaultValueAttribute()]
public bool RadioBoxes {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property bool get_RadioBoxes();
public: __property void set_RadioBoxes(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
public:
property bool RadioBoxes {
   bool get();
   void set (boolvalue);
}

Return Value

true if [radio boxes]; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListBox Class
ListBox Members


SelectedIndex Property

[image]
Gizmox.WebGUI.Forms
SelectedIndex Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListBox Class : SelectedIndex Property

Gets or sets the zero-based index of the currently selected item in a ListBox.

Syntax

Visual Basic (Declaration)
<BindableAttribute(True)>
<BrowsableAttribute(False)>
<DefaultValueAttribute()>
<SRDescriptionAttribute("Retrieves the index of the first selection in the list box, or -1 if there is no selection.")>
<DesignerSerializationVisibilityAttribute()>
Public Overrides Property SelectedIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As ListBox
Dim value As Integer

instance.SelectedIndex = value

value = instance.SelectedIndex
C#
[BindableAttribute(true)]
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Retrieves the index of the first selection in the list box, or -1 if there is no selection.")]
[DesignerSerializationVisibilityAttribute()]
public override int SelectedIndex {get; set;}
Managed Extensions for C++
[BindableAttribute(true)]
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Retrieves the index of the first selection in the list box, or -1 if there is no selection.")]
[DesignerSerializationVisibilityAttribute()]
public: __property int get_SelectedIndex() override;
public: __property void set_SelectedIndex(
   int value
) override;
C++/CLI
[BindableAttribute(true)]
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Retrieves the index of the first selection in the list box, or -1 if there is no selection.")]
[DesignerSerializationVisibilityAttribute()]
public:
property int SelectedIndex {
   int get() override;
   void set (intvalue) override;
}

Exceptions

Exception | Description
ArgumentException | The SelectionMode property is set to None.
ArgumentOutOfRangeException | The assigned value is less than -1 or greater than or equal to the item count.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListBox Class
ListBox Members


SelectedIndices Property

[image]
Gizmox.WebGUI.Forms
SelectedIndices Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListBox Class : SelectedIndices Property

Gets a collection that contains the zero-based indexes of all currently selected items in the ListBox.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
<SRDescriptionAttribute("A collection of indexes for the currently selected items in the list box.")>
Public ReadOnly Property SelectedIndices As ICollection
Visual Basic (Usage) Copy Code
Dim instance As ListBox
Dim value As ICollection

value = instance.SelectedIndices
C#
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
[SRDescriptionAttribute("A collection of indexes for the currently selected items in the list box.")]
public ICollection SelectedIndices {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
[SRDescriptionAttribute("A collection of indexes for the currently selected items in the list box.")]
public: __property ICollection* get_SelectedIndices();
C++/CLI
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
[SRDescriptionAttribute("A collection of indexes for the currently selected items in the list box.")]
public:
property ICollection^ SelectedIndices {
   ICollection^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListBox Class
ListBox Members


SelectedItem Property

[image]
Gizmox.WebGUI.Forms
SelectedItem Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListBox Class : SelectedItem Property

Gets or sets the currently selected item in the ListBox.

Syntax

Visual Basic (Declaration)
<BindableAttribute(True)>
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
Public Property SelectedItem As Object
Visual Basic (Usage) Copy Code
Dim instance As ListBox
Dim value As Object

instance.SelectedItem = value

value = instance.SelectedItem
C#
[BindableAttribute(true)]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public object SelectedItem {get; set;}
Managed Extensions for C++
[BindableAttribute(true)]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public: __property Object* get_SelectedItem();
public: __property void set_SelectedItem(
   Object* value
);
C++/CLI
[BindableAttribute(true)]
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public:
property Object^ SelectedItem {
   Object^ get();
   void set (Object^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListBox Class
ListBox Members


SelectedItems Property

[image]
Gizmox.WebGUI.Forms
SelectedItems Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListBox Class : SelectedItems Property

Gets a collection containing the currently selected items in the ListBox.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("A collection of currently selected items.")>
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public ReadOnly Property SelectedItems As ListBox.SelectedObjectCollection
Visual Basic (Usage) Copy Code
Dim instance As ListBox
Dim value As ListBox.SelectedObjectCollection

value = instance.SelectedItems
C#
[SRDescriptionAttribute("A collection of currently selected items.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public ListBox.SelectedObjectCollection SelectedItems {get;}
Managed Extensions for C++
[SRDescriptionAttribute("A collection of currently selected items.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property ListBox.SelectedObjectCollection* get_SelectedItems();
C++/CLI
[SRDescriptionAttribute("A collection of currently selected items.")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
property ListBox::SelectedObjectCollection^ SelectedItems {
   ListBox::SelectedObjectCollection^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListBox Class
ListBox Members


SelectionMode Property

[image]
Gizmox.WebGUI.Forms
SelectionMode Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListBox Class : SelectionMode Property

Gets or sets the method in which items are selected in the ListBox.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<SRDescriptionAttribute("Indicates if the list box is to be single-select, multi-select, or not selectable.")>
<SRCategoryAttribute("Behavior")>
Public Property SelectionMode As SelectionMode
Visual Basic (Usage) Copy Code
Dim instance As ListBox
Dim value As SelectionMode

instance.SelectionMode = value

value = instance.SelectionMode
C#
[DefaultValueAttribute()]
[SRDescriptionAttribute("Indicates if the list box is to be single-select, multi-select, or not selectable.")]
[SRCategoryAttribute("Behavior")]
public SelectionMode SelectionMode {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[SRDescriptionAttribute("Indicates if the list box is to be single-select, multi-select, or not selectable.")]
[SRCategoryAttribute("Behavior")]
public: __property SelectionMode get_SelectionMode();
public: __property void set_SelectionMode(
   SelectionMode value
);
C++/CLI
[DefaultValueAttribute()]
[SRDescriptionAttribute("Indicates if the list box is to be single-select, multi-select, or not selectable.")]
[SRCategoryAttribute("Behavior")]
public:
property SelectionMode SelectionMode {
   SelectionMode get();
   void set (SelectionModevalue);
}

Exceptions

Exception | Description
InvalidEnumArgumentException | The assigned value is not one of the SelectionMode values.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListBox Class
ListBox Members


Sorted Property

[image]
Gizmox.WebGUI.Forms
Sorted Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListBox Class : Sorted Property

Gets or sets a value indicating whether the items in the ListBox are sorted alphabetically.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<SRCategoryAttribute("Behavior")>
<SRDescriptionAttribute("Controls whether the list is sorted.")>
Public Property Sorted As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ListBox
Dim value As Boolean

instance.Sorted = value

value = instance.Sorted
C#
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Controls whether the list is sorted.")]
public bool Sorted {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Controls whether the list is sorted.")]
public: __property bool get_Sorted();
public: __property void set_Sorted(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Controls whether the list is sorted.")]
public:
property bool Sorted {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListBox Class
ListBox Members


ListBox Class Events

[image]
Gizmox.WebGUI.Forms
ListBox Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ListBox Class

For a list of all members of this type, see ListBox members.

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | DataSourceChanged | Occurs when the ListControl.DataSource changes. (Inherited from ListControl)
Public Event | DisplayMemberChanged | Occurs when the ListControl.DisplayMember property changes. (Inherited from ListControl)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | Format | Occurs when the control is bound to a data value. (Inherited from ListControl)
Public Event | FormatInfoChanged | Occurs when the value of the ListControl.FormatInfo property changes. (Inherited from ListControl)
Public Event | FormatStringChanged | Occurs when value of the ListControl.FormatString property changes (Inherited from ListControl)
Public Event | FormattingEnabledChanged | Occurs when the value of the ListControl.FormattingEnabled property changes. (Inherited from ListControl)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | SelectedIndexChanged | Occurs when the SelectedIndex property has changed.
Public Event | SelectedValueChanged | Occurs when the ListControl.SelectedValue property changes. (Inherited from ListControl)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | ValueMemberChanged | Occurs when the ListControl.ValueMember property changes. (Inherited from ListControl)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

ListBox Class
Gizmox.WebGUI.Forms Namespace


SelectedIndexChanged Event

[image]
Gizmox.WebGUI.Forms
SelectedIndexChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListBox Class : SelectedIndexChanged Event

Occurs when the SelectedIndex property has changed.

Syntax

Visual Basic (Declaration)
Public Event SelectedIndexChanged() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As ListBox
Dim handler As EventHandler

AddHandler instance.SelectedIndexChanged, handler
C#
public event EventHandler SelectedIndexChanged()
Managed Extensions for C++
public: __event EventHandler* SelectedIndexChanged
C++/CLI
public:
event EventHandler^ SelectedIndexChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListBox Class
ListBox Members


ListBox.ObjectCollection Class

[image]
Gizmox.WebGUI.Forms
ListBox.ObjectCollection Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ListBox.ObjectCollection Class

The list box object collection

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class ListBox.ObjectCollection
Visual Basic (Usage) Copy Code
Dim instance As ListBox.ObjectCollection
C#
[DefaultMemberAttribute("Item")]
public class ListBox.ObjectCollection
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
public __gc class ListBox.ObjectCollection
C++/CLI
[DefaultMemberAttribute("Item")]
public ref class ListBox.ObjectCollection

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ListBox.ObjectCollection
Gizmox.WebGUI.Forms.CheckedListBox.ObjectCollection
Gizmox.WebGUI.Forms.ColorListBox.ObjectCollection

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

ListBox.ObjectCollection Members
Gizmox.WebGUI.Forms Namespace


ListBox.ObjectCollection Class Members

[image]
Gizmox.WebGUI.Forms
ListBox.ObjectCollection Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : ListBox.ObjectCollection Class

The following tables list the members exposed by ListBox.ObjectCollection.

Public Properties

 | Name | Description
Public Property | Count | Gets the number of items in the collection.
Public Property | IsFixedSize | Gets a value indicating whether the collection has a fixed size.
Public Property | IsReadOnly | Gets a value indicating whether the collection is read-only.
Public Property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe).
Public Property | Item | Gets or sets the item at the specified index within the collection.
Public Property | SyncRoot | Gets the sync root.
Top

Public Methods

 | Name | Description
Public Method | Add | Adds an item to the list of items for a ListBox.
Public Method | AddRange | Overloaded. Adds an array of items to the list of items for a ListBox.
Public Method | Clear | Removes all items from the IList.
Public Method | Contains | Determines whether the specified item is located within the collection.
Public Method | CopyTo | Copies the entire collection into an existing array of objects at a specified location within the array.
Public Method | GetEnumerator | Returns an enumerator to use to iterate through the item collection.
Public Method | IndexOf | Returns the index within the collection of the specified item.
Public Method | Insert | Inserts an item into the list box at the specified index.
Public Method | Remove | Removes the specified object from the collection.
Public Method | RemoveAt | Removes the item at the specified index within the collection.
Top

Protected Methods

 | Name | Description
Protected Method | GetItemInvalidMessage | Gets the item invalid message.
Protected Method | IsItemValid | Determines whether item is valid.
Top

See Also

Reference

ListBox.ObjectCollection Class
Gizmox.WebGUI.Forms Namespace


ListBox.ObjectCollection Class Methods

[image]
Gizmox.WebGUI.Forms
ListBox.ObjectCollection Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ListBox.ObjectCollection Class

For a list of all members of this type, see ListBox.ObjectCollection members.

Public Methods

 | Name | Description
Public Method | Add | Adds an item to the list of items for a ListBox.
Public Method | AddRange | Overloaded. Adds an array of items to the list of items for a ListBox.
Public Method | Clear | Removes all items from the IList.
Public Method | Contains | Determines whether the specified item is located within the collection.
Public Method | CopyTo | Copies the entire collection into an existing array of objects at a specified location within the array.
Public Method | GetEnumerator | Returns an enumerator to use to iterate through the item collection.
Public Method | IndexOf | Returns the index within the collection of the specified item.
Public Method | Insert | Inserts an item into the list box at the specified index.
Public Method | Remove | Removes the specified object from the collection.
Public Method | RemoveAt | Removes the item at the specified index within the collection.
Top

Protected Methods

 | Name | Description
Protected Method | GetItemInvalidMessage | Gets the item invalid message.
Protected Method | IsItemValid | Determines whether item is valid.
Top

See Also

Reference

ListBox.ObjectCollection Class
Gizmox.WebGUI.Forms Namespace


Add Method

[image]
Gizmox.WebGUI.Forms
Add Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListBox.ObjectCollection Class : Add Method

objObject
An object representing the item to add to the collection.
Adds an item to the list of items for a ListBox.

Syntax

Visual Basic (Declaration)
Public Function Add( _
   ByVal objObject As Object _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As ListBox.ObjectCollection
Dim objObject As Object
Dim value As Integer

value = instance.Add(objObject)
C#
public int Add(
   object objObject
)
Managed Extensions for C++
public: int Add(
   Object* objObject
)
C++/CLI
public:
int Add(
   Object^ objObject
)

Parameters

objObject
An object representing the item to add to the collection.

Return Value

The zero-based index of the item in the collection, or -1 if BeginUpdate has been called.

Exceptions

Exception | Description
SystemException | There is insufficient space available to add the new item to the list.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListBox.ObjectCollection Class
ListBox.ObjectCollection Members


AddRange Method

[image]
Gizmox.WebGUI.Forms
AddRange Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListBox.ObjectCollection Class : AddRange Method

Adds an array of items to the list of items for a ListBox.

Overload List

Overload | Description
AddRange(Object[]) | Adds an array of items to the list of items for a ListBox.
AddRange(ICollection) | Adds the items of an existing ListBox.ObjectCollection to the list of items in a ListBox.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListBox.ObjectCollection Class
ListBox.ObjectCollection Members


AddRange(Object[]) Method

[image]
Gizmox.WebGUI.Forms
AddRange(Object[]) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListBox.ObjectCollection Class > AddRange Method : AddRange(Object[]) Method

objObjects
An array of objects to add to the list.
Adds an array of items to the list of items for a ListBox.

Syntax

Visual Basic (Declaration)
Public Overloads Sub AddRange( _
   ByVal objObjects() As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ListBox.ObjectCollection
Dim objObjects() As Object

instance.AddRange(objObjects)
C#
public void AddRange(
   object[] objObjects
)
Managed Extensions for C++
public: void AddRange(
   Object*[]* objObjects
)
C++/CLI
public:
void AddRange(
   array<Object^>^ objObjects
)

Parameters

objObjects
An array of objects to add to the list.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListBox.ObjectCollection Class
ListBox.ObjectCollection Members
Overload List


AddRange(ICollection) Method

[image]
Gizmox.WebGUI.Forms
AddRange(ICollection) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListBox.ObjectCollection Class > AddRange Method : AddRange(ICollection) Method

objObjects
A ListBox.ObjectCollection to load into this collection.
Adds the items of an existing ListBox.ObjectCollection to the list of items in a ListBox.

Syntax

Visual Basic (Declaration)
Public Overloads Sub AddRange( _
   ByVal objObjects As ICollection _
)
Visual Basic (Usage) Copy Code
Dim instance As ListBox.ObjectCollection
Dim objObjects As ICollection

instance.AddRange(objObjects)
C#
public void AddRange(
   ICollection objObjects
)
Managed Extensions for C++
public: void AddRange(
   ICollection* objObjects
)
C++/CLI
public:
void AddRange(
   ICollection^ objObjects
)

Parameters

objObjects
A ListBox.ObjectCollection to load into this collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListBox.ObjectCollection Class
ListBox.ObjectCollection Members
Overload List


Clear Method

[image]
Gizmox.WebGUI.Forms
Clear Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListBox.ObjectCollection Class : Clear Method

Removes all items from the IList.

Syntax

Visual Basic (Declaration)
Public Overridable Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As ListBox.ObjectCollection

instance.Clear()
C#
public virtual void Clear()
Managed Extensions for C++
public: virtual void Clear();
C++/CLI
public:
virtual void Clear();

Exceptions

Exception | Description
NotSupportedException | The IList is read-only.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListBox.ObjectCollection Class
ListBox.ObjectCollection Members


Contains Method

[image]
Gizmox.WebGUI.Forms
Contains Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListBox.ObjectCollection Class : Contains Method

value
An object representing the item to locate in the collection.
Determines whether the specified item is located within the collection.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal value As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ListBox.ObjectCollection
Dim value As Object
Dim value As Boolean

value = instance.Contains(value)
C#
public bool Contains(
   object value
)
Managed Extensions for C++
public: bool Contains(
   Object* value
)
C++/CLI
public:
bool Contains(
   Object^ value
)

Parameters

value
An object representing the item to locate in the collection.

Return Value

true if the item is located within the collection; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListBox.ObjectCollection Class
ListBox.ObjectCollection Members


CopyTo Method

[image]
Gizmox.WebGUI.Forms
CopyTo Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListBox.ObjectCollection Class : CopyTo Method

destination
The object array in which the items from the collection are copied to.
arrayIndex
The location within the destination array to copy the items from the collection to.
Copies the entire collection into an existing array of objects at a specified location within the array.

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal destination As Array, _
   ByVal arrayIndex As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As ListBox.ObjectCollection
Dim destination As Array
Dim arrayIndex As Integer

instance.CopyTo(destination, arrayIndex)
C#
public void CopyTo(
   Array destination,
   int arrayIndex
)
Managed Extensions for C++
public: void CopyTo(
   Array* destination,
   int arrayIndex
)
C++/CLI
public:
void CopyTo(
   Array^ destination,
   int arrayIndex
)

Parameters

destination
The object array in which the items from the collection are copied to.
arrayIndex
The location within the destination array to copy the items from the collection to.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListBox.ObjectCollection Class
ListBox.ObjectCollection Members


GetEnumerator Method

[image]
Gizmox.WebGUI.Forms
GetEnumerator Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListBox.ObjectCollection Class : GetEnumerator Method

Returns an enumerator to use to iterate through the item collection.

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As ListBox.ObjectCollection
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Return Value

An IEnumerator that represents the item collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListBox.ObjectCollection Class
ListBox.ObjectCollection Members


GetItemInvalidMessage Method

[image]
Gizmox.WebGUI.Forms
GetItemInvalidMessage Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListBox.ObjectCollection Class : GetItemInvalidMessage Method

objItem
The item to check validite.
Gets the item invalid message.

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetItemInvalidMessage( _
   ByVal objItem As Object _
) As String
Visual Basic (Usage) Copy Code
Dim instance As ListBox.ObjectCollection
Dim objItem As Object
Dim value As String

value = instance.GetItemInvalidMessage(objItem)
C#
protected virtual string GetItemInvalidMessage(
   object objItem
)
Managed Extensions for C++
protected: virtual string* GetItemInvalidMessage(
   Object* objItem
)
C++/CLI
protected:
virtual String^ GetItemInvalidMessage(
   Object^ objItem
)

Parameters

objItem
The item to check validite.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListBox.ObjectCollection Class
ListBox.ObjectCollection Members


IndexOf Method

[image]
Gizmox.WebGUI.Forms
IndexOf Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListBox.ObjectCollection Class : IndexOf Method

objObject
An object representing the item to locate in the collection.
Returns the index within the collection of the specified item.

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal objObject As Object _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As ListBox.ObjectCollection
Dim objObject As Object
Dim value As Integer

value = instance.IndexOf(objObject)
C#
public int IndexOf(
   object objObject
)
Managed Extensions for C++
public: int IndexOf(
   Object* objObject
)
C++/CLI
public:
int IndexOf(
   Object^ objObject
)

Parameters

objObject
An object representing the item to locate in the collection.

Return Value

The zero-based index where the item is located within the collection; otherwise, negative one (-1).

Exceptions

Exception | Description
ArgumentNullException | The value parameter is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListBox.ObjectCollection Class
ListBox.ObjectCollection Members


Insert Method

[image]
Gizmox.WebGUI.Forms
Insert Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListBox.ObjectCollection Class : Insert Method

index
The zero-based index location where the item is inserted.
value
An object representing the item to insert.
Inserts an item into the list box at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal value As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ListBox.ObjectCollection
Dim index As Integer
Dim value As Object

instance.Insert(index, value)
C#
public void Insert(
   int index,
   object value
)
Managed Extensions for C++
public: void Insert(
   int index,
   Object* value
)
C++/CLI
public:
void Insert(
   int index,
   Object^ value
)

Parameters

index
The zero-based index location where the item is inserted.
value
An object representing the item to insert.

Exceptions

Exception | Description
ArgumentOutOfRangeException | The index parameter is less than zero or greater than value of the ListBox+ObjectCollection.Count property of the ListBox.ObjectCollection class.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListBox.ObjectCollection Class
ListBox.ObjectCollection Members


IsItemValid Method

[image]
Gizmox.WebGUI.Forms
IsItemValid Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListBox.ObjectCollection Class : IsItemValid Method

objItem
The item to check validite.
Determines whether item is valid.

Syntax

Visual Basic (Declaration)
Protected Overridable Function IsItemValid( _
   ByVal objItem As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ListBox.ObjectCollection
Dim objItem As Object
Dim value As Boolean

value = instance.IsItemValid(objItem)
C#
protected virtual bool IsItemValid(
   object objItem
)
Managed Extensions for C++
protected: virtual bool IsItemValid(
   Object* objItem
)
C++/CLI
protected:
virtual bool IsItemValid(
   Object^ objItem
)

Parameters

objItem
The item to check validite.

Return Value

true if valid item; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListBox.ObjectCollection Class
ListBox.ObjectCollection Members


Remove Method

[image]
Gizmox.WebGUI.Forms
Remove Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListBox.ObjectCollection Class : Remove Method

objObject
An object representing the item to remove from the collection.
Removes the specified object from the collection.

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal objObject As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ListBox.ObjectCollection
Dim objObject As Object

instance.Remove(objObject)
C#
public void Remove(
   object objObject
)
Managed Extensions for C++
public: void Remove(
   Object* objObject
)
C++/CLI
public:
void Remove(
   Object^ objObject
)

Parameters

objObject
An object representing the item to remove from the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListBox.ObjectCollection Class
ListBox.ObjectCollection Members


RemoveAt Method

[image]
Gizmox.WebGUI.Forms
RemoveAt Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListBox.ObjectCollection Class : RemoveAt Method

index
The zero-based index of the item to remove.
Removes the item at the specified index within the collection.

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As ListBox.ObjectCollection
Dim index As Integer

instance.RemoveAt(index)
C#
public void RemoveAt(
   int index
)
Managed Extensions for C++
public: void RemoveAt(
   int index
)
C++/CLI
public:
void RemoveAt(
   int index
)

Parameters

index
The zero-based index of the item to remove.

Exceptions

Exception | Description
ArgumentOutOfRangeException | The index parameter is less than zero or greater than or equal to the value of the ListBox+ObjectCollection.Count property of the ListBox.ObjectCollection class.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListBox.ObjectCollection Class
ListBox.ObjectCollection Members


ListBox.ObjectCollection Class Properties

[image]
Gizmox.WebGUI.Forms
ListBox.ObjectCollection Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ListBox.ObjectCollection Class

For a list of all members of this type, see ListBox.ObjectCollection members.

Public Properties

 | Name | Description
Public Property | Count | Gets the number of items in the collection.
Public Property | IsFixedSize | Gets a value indicating whether the collection has a fixed size.
Public Property | IsReadOnly | Gets a value indicating whether the collection is read-only.
Public Property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe).
Public Property | Item | Gets or sets the item at the specified index within the collection.
Public Property | SyncRoot | Gets the sync root.
Top

See Also

Reference

ListBox.ObjectCollection Class
Gizmox.WebGUI.Forms Namespace


Count Property

[image]
Gizmox.WebGUI.Forms
Count Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListBox.ObjectCollection Class : Count Property

Gets the number of items in the collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As ListBox.ObjectCollection
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListBox.ObjectCollection Class
ListBox.ObjectCollection Members


IsFixedSize Property

[image]
Gizmox.WebGUI.Forms
IsFixedSize Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListBox.ObjectCollection Class : IsFixedSize Property

Gets a value indicating whether the collection has a fixed size.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsFixedSize As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ListBox.ObjectCollection
Dim value As Boolean

value = instance.IsFixedSize
C#
public bool IsFixedSize {get;}
Managed Extensions for C++
public: __property bool get_IsFixedSize();
C++/CLI
public:
property bool IsFixedSize {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListBox.ObjectCollection Class
ListBox.ObjectCollection Members


IsReadOnly Property

[image]
Gizmox.WebGUI.Forms
IsReadOnly Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListBox.ObjectCollection Class : IsReadOnly Property

Gets a value indicating whether the collection is read-only.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsReadOnly As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ListBox.ObjectCollection
Dim value As Boolean

value = instance.IsReadOnly
C#
public bool IsReadOnly {get;}
Managed Extensions for C++
public: __property bool get_IsReadOnly();
C++/CLI
public:
property bool IsReadOnly {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListBox.ObjectCollection Class
ListBox.ObjectCollection Members


IsSynchronized Property

[image]
Gizmox.WebGUI.Forms
IsSynchronized Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListBox.ObjectCollection Class : IsSynchronized Property

Gets a value indicating whether access to the collection is synchronized (thread safe).

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsSynchronized As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ListBox.ObjectCollection
Dim value As Boolean

value = instance.IsSynchronized
C#
public bool IsSynchronized {get;}
Managed Extensions for C++
public: __property bool get_IsSynchronized();
C++/CLI
public:
property bool IsSynchronized {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListBox.ObjectCollection Class
ListBox.ObjectCollection Members


Item Property

[image]
Gizmox.WebGUI.Forms
Item Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListBox.ObjectCollection Class : Item Property

intIndex
The index of the item in the collection to get or set.
Gets or sets the item at the specified index within the collection.

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
Public Default Property Item( _
   ByVal intIndex As Integer _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As ListBox.ObjectCollection
Dim intIndex As Integer
Dim value As Object

instance.Item(intIndex) = value

value = instance.Item(intIndex)
C#
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public object this[
   int intIndex
]; {get; set;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public: __property Object* get_Item(
   int intIndex
);
public: __property void set_Item(
   int intIndex,
   Object* value
);
C++/CLI
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public:
property Object^ default [int] {
   Object^ get(intintIndex);
   void set (intintIndex, Object^value);
}

Parameters

intIndex
The index of the item in the collection to get or set.

Exceptions

Exception | Description
ArgumentOutOfRangeException | The index parameter is less than zero or greater than or equal to the value of the ListBox+ObjectCollection.Count property of the ListBox.ObjectCollection class.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListBox.ObjectCollection Class
ListBox.ObjectCollection Members


SyncRoot Property

[image]
Gizmox.WebGUI.Forms
SyncRoot Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListBox.ObjectCollection Class : SyncRoot Property

Gets the sync root.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SyncRoot As Object
Visual Basic (Usage) Copy Code
Dim instance As ListBox.ObjectCollection
Dim value As Object

value = instance.SyncRoot
C#
public object SyncRoot {get;}
Managed Extensions for C++
public: __property Object* get_SyncRoot();
C++/CLI
public:
property Object^ SyncRoot {
   Object^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListBox.ObjectCollection Class
ListBox.ObjectCollection Members


ListBox.SelectedObjectCollection Class

[image]
Gizmox.WebGUI.Forms
ListBox.SelectedObjectCollection Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ListBox.SelectedObjectCollection Class

Represents the collection of selected items in the ListBox.

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class ListBox.SelectedObjectCollection
Visual Basic (Usage) Copy Code
Dim instance As ListBox.SelectedObjectCollection
C#
[DefaultMemberAttribute("Item")]
public class ListBox.SelectedObjectCollection
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
public __gc class ListBox.SelectedObjectCollection
C++/CLI
[DefaultMemberAttribute("Item")]
public ref class ListBox.SelectedObjectCollection

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ListBox.SelectedObjectCollection

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

ListBox.SelectedObjectCollection Members
Gizmox.WebGUI.Forms Namespace


ListBox.SelectedObjectCollection Class Members

[image]
Gizmox.WebGUI.Forms
ListBox.SelectedObjectCollection Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : ListBox.SelectedObjectCollection Class

The following tables list the members exposed by ListBox.SelectedObjectCollection.

Public Constructors

 | Name | Description
Public Constructor | ListBox.SelectedObjectCollection Constructor | Initializes a new instance of the ListBox.SelectedObjectCollection class.
Top

Public Properties

 | Name | Description
Public Property | Count | Gets the number of items in the collection.
Public Property | IsReadOnly | Gets a value indicating whether the collection is read-only.
Public Property | Item | Gets the item at the specified index within the collection.
Top

Public Methods

 | Name | Description
Public Method | Add | Adds an item to the list of selected items for a ListBox.
Public Method | Clear | Removes all items from the collection of selected items.
Public Method | Contains | Determines whether the specified item is located within the collection.
Public Method | CopyTo | Copies the entire collection into an existing array at a specified location within the array.
Public Method | GetEnumerator | Returns an enumerator that can be used to iterate through the selected item collection.
Public Method | IndexOf | Returns the index within the collection of the specified item.
Public Method | Remove | Removes the specified object from the collection of selected items.
Top

See Also

Reference

ListBox.SelectedObjectCollection Class
Gizmox.WebGUI.Forms Namespace


ListBox.SelectedObjectCollection Constructor

[image]
Gizmox.WebGUI.Forms
ListBox.SelectedObjectCollection Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListBox.SelectedObjectCollection Class : ListBox.SelectedObjectCollection Constructor

objOwner
A ListBox representing the mobjOwner of the collection.
Initializes a new instance of the ListBox.SelectedObjectCollection class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal objOwner As ListBox _
)
Visual Basic (Usage) Copy Code
Dim objOwner As ListBox

Dim instance As ListBox.SelectedObjectCollection(objOwner)
C#
public ListBox.SelectedObjectCollection(
   ListBox objOwner
)
Managed Extensions for C++
public: ListBox.SelectedObjectCollection(
   ListBox* objOwner
)
C++/CLI
public:
ListBox.SelectedObjectCollection(
   ListBox^ objOwner
)

Parameters

objOwner
A ListBox representing the mobjOwner of the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListBox.SelectedObjectCollection Class
ListBox.SelectedObjectCollection Members


ListBox.SelectedObjectCollection Class Methods

[image]
Gizmox.WebGUI.Forms
ListBox.SelectedObjectCollection Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ListBox.SelectedObjectCollection Class

For a list of all members of this type, see ListBox.SelectedObjectCollection members.

Public Methods

 | Name | Description
Public Method | Add | Adds an item to the list of selected items for a ListBox.
Public Method | Clear | Removes all items from the collection of selected items.
Public Method | Contains | Determines whether the specified item is located within the collection.
Public Method | CopyTo | Copies the entire collection into an existing array at a specified location within the array.
Public Method | GetEnumerator | Returns an enumerator that can be used to iterate through the selected item collection.
Public Method | IndexOf | Returns the index within the collection of the specified item.
Public Method | Remove | Removes the specified object from the collection of selected items.
Top

See Also

Reference

ListBox.SelectedObjectCollection Class
Gizmox.WebGUI.Forms Namespace


Add Method

[image]
Gizmox.WebGUI.Forms
Add Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListBox.SelectedObjectCollection Class : Add Method

value
An object representing the item to add to the collection of selected items.
Adds an item to the list of selected items for a ListBox.

Syntax

Visual Basic (Declaration)
Public Sub Add( _
   ByVal value As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ListBox.SelectedObjectCollection
Dim value As Object

instance.Add(value)
C#
public void Add(
   object value
)
Managed Extensions for C++
public: void Add(
   Object* value
)
C++/CLI
public:
void Add(
   Object^ value
)

Parameters

value
An object representing the item to add to the collection of selected items.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListBox.SelectedObjectCollection Class
ListBox.SelectedObjectCollection Members


Clear Method

[image]
Gizmox.WebGUI.Forms
Clear Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListBox.SelectedObjectCollection Class : Clear Method

Removes all items from the collection of selected items.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As ListBox.SelectedObjectCollection

instance.Clear()
C#
public void Clear()
Managed Extensions for C++
public: void Clear();
C++/CLI
public:
void Clear();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListBox.SelectedObjectCollection Class
ListBox.SelectedObjectCollection Members


Contains Method

[image]
Gizmox.WebGUI.Forms
Contains Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListBox.SelectedObjectCollection Class : Contains Method

selectedObject
An object representing the item to locate in the collection.
Determines whether the specified item is located within the collection.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal selectedObject As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ListBox.SelectedObjectCollection
Dim selectedObject As Object
Dim value As Boolean

value = instance.Contains(selectedObject)
C#
public bool Contains(
   object selectedObject
)
Managed Extensions for C++
public: bool Contains(
   Object* selectedObject
)
C++/CLI
public:
bool Contains(
   Object^ selectedObject
)

Parameters

selectedObject
An object representing the item to locate in the collection.

Return Value

true if the specified item is located in the collection; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListBox.SelectedObjectCollection Class
ListBox.SelectedObjectCollection Members


CopyTo Method

[image]
Gizmox.WebGUI.Forms
CopyTo Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListBox.SelectedObjectCollection Class : CopyTo Method

destination
An Array representing the array to copy the contents of the collection to.
index
The location within the destination array to copy the items from the collection to.
Copies the entire collection into an existing array at a specified location within the array.

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal destination As Array, _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As ListBox.SelectedObjectCollection
Dim destination As Array
Dim index As Integer

instance.CopyTo(destination, index)
C#
public void CopyTo(
   Array destination,
   int index
)
Managed Extensions for C++
public: void CopyTo(
   Array* destination,
   int index
)
C++/CLI
public:
void CopyTo(
   Array^ destination,
   int index
)

Parameters

destination
An Array representing the array to copy the contents of the collection to.
index
The location within the destination array to copy the items from the collection to.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListBox.SelectedObjectCollection Class
ListBox.SelectedObjectCollection Members


GetEnumerator Method

[image]
Gizmox.WebGUI.Forms
GetEnumerator Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListBox.SelectedObjectCollection Class : GetEnumerator Method

Returns an enumerator that can be used to iterate through the selected item collection.

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As ListBox.SelectedObjectCollection
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Return Value

An IEnumerator that represents the item collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListBox.SelectedObjectCollection Class
ListBox.SelectedObjectCollection Members


IndexOf Method

[image]
Gizmox.WebGUI.Forms
IndexOf Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListBox.SelectedObjectCollection Class : IndexOf Method

selectedObject
An object representing the item to locate in the collection.
Returns the index within the collection of the specified item.

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal selectedObject As Object _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As ListBox.SelectedObjectCollection
Dim selectedObject As Object
Dim value As Integer

value = instance.IndexOf(selectedObject)
C#
public int IndexOf(
   object selectedObject
)
Managed Extensions for C++
public: int IndexOf(
   Object* selectedObject
)
C++/CLI
public:
int IndexOf(
   Object^ selectedObject
)

Parameters

selectedObject
An object representing the item to locate in the collection.

Return Value

The zero-based index of the item in the collection; otherwise, -1.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListBox.SelectedObjectCollection Class
ListBox.SelectedObjectCollection Members


Remove Method

[image]
Gizmox.WebGUI.Forms
Remove Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListBox.SelectedObjectCollection Class : Remove Method

value
An object representing the item to remove from the collection.
Removes the specified object from the collection of selected items.

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal value As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ListBox.SelectedObjectCollection
Dim value As Object

instance.Remove(value)
C#
public void Remove(
   object value
)
Managed Extensions for C++
public: void Remove(
   Object* value
)
C++/CLI
public:
void Remove(
   Object^ value
)

Parameters

value
An object representing the item to remove from the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListBox.SelectedObjectCollection Class
ListBox.SelectedObjectCollection Members


ListBox.SelectedObjectCollection Class Properties

[image]
Gizmox.WebGUI.Forms
ListBox.SelectedObjectCollection Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ListBox.SelectedObjectCollection Class

For a list of all members of this type, see ListBox.SelectedObjectCollection members.

Public Properties

 | Name | Description
Public Property | Count | Gets the number of items in the collection.
Public Property | IsReadOnly | Gets a value indicating whether the collection is read-only.
Public Property | Item | Gets the item at the specified index within the collection.
Top

See Also

Reference

ListBox.SelectedObjectCollection Class
Gizmox.WebGUI.Forms Namespace


Count Property

[image]
Gizmox.WebGUI.Forms
Count Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListBox.SelectedObjectCollection Class : Count Property

Gets the number of items in the collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As ListBox.SelectedObjectCollection
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListBox.SelectedObjectCollection Class
ListBox.SelectedObjectCollection Members


IsReadOnly Property

[image]
Gizmox.WebGUI.Forms
IsReadOnly Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListBox.SelectedObjectCollection Class : IsReadOnly Property

Gets a value indicating whether the collection is read-only.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsReadOnly As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ListBox.SelectedObjectCollection
Dim value As Boolean

value = instance.IsReadOnly
C#
public bool IsReadOnly {get;}
Managed Extensions for C++
public: __property bool get_IsReadOnly();
C++/CLI
public:
property bool IsReadOnly {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListBox.SelectedObjectCollection Class
ListBox.SelectedObjectCollection Members


Item Property

[image]
Gizmox.WebGUI.Forms
Item Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListBox.SelectedObjectCollection Class : Item Property

index
The index of the item in the collection to retrieve.
Gets the item at the specified index within the collection.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public Default Property Item( _
   ByVal index As Integer _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As ListBox.SelectedObjectCollection
Dim index As Integer
Dim value As Object

instance.Item(index) = value

value = instance.Item(index)
C#
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public object this[
   int index
]; {get; set;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property Object* get_Item(
   int index
);
public: __property void set_Item(
   int index,
   Object* value
);
C++/CLI
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
property Object^ default [int] {
   Object^ get(intindex);
   void set (intindex, Object^value);
}

Parameters

index
The index of the item in the collection to retrieve.

Exceptions

Exception | Description
ArgumentOutOfRangeException | The index parameter is less than zero or greater than or equal to the value of the ListBox+ObjectCollection.Count property of the ListBox.SelectedObjectCollection class.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListBox.SelectedObjectCollection Class
ListBox.SelectedObjectCollection Members


ListControl Class

[image]
Gizmox.WebGUI.Forms
ListControl Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ListControl Class

Provides a common implementation of members for the ListBox and ComboBox classes.

Object Model

Syntax

Visual Basic (Declaration)
Public MustInherit Class ListControl
   Inherits Control
   Implements IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Visual Basic (Usage) Copy Code
Dim instance As ListControl
C#
public abstract class ListControl : Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Managed Extensions for C++
public __gc abstract class ListControl : public Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
C++/CLI
public ref class ListControl abstract : public Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.ListControl
Gizmox.WebGUI.Forms.ComboBox
Gizmox.WebGUI.Forms.ListBox

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

ListControl Members
Gizmox.WebGUI.Forms Namespace


ListControl Class Members

[image]
Gizmox.WebGUI.Forms
ListControl Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : ListControl Class

The following tables list the members exposed by ListControl.

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | DataSource | Gets or sets the data source for this ListControl.
Public Property | DisplayMember | Gets or sets the property to display for this ListControl.
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | FormatInfo | Gets or sets the IFormatProvider that provides custom formatting behavior.
Public Property | FormatString | Gets or sets the format-specifier characters that indicate how a value is to be displayed.
Public Property | FormattingEnabled | Gets or sets a value indicating whether formatting is applied to the ListControl.DisplayMember property of the ListControl.
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | SelectedIndex | When overridden in a derived class, gets or sets the zero-based index of the currently selected item.
Public Property | SelectedValue | Gets or sets the value of the member property specified by the ListControl.ValueMember property.
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Control)
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | ValueMember | Gets or sets the property to use as the actual value for the items in the ListControl.
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | AllowSelection | Gets a value indicating whether the list enables selection of list items.
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DataManager | Gets the CurrencyManager associated with this control.
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | IsPostBackRequired | Indicates if the list control context requires its events to cause callback
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetItemText | Returns the text representation of the specified item.
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | FilterItemOnProperty | Overloaded. Retrieves the current value of the ListControl item, if it is a property of an object, given the item.
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Control)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Overridden. Gets the critical events.
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from Control)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | Overridden.
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDataSourceChanged | Raises the ListControl.DataSourceChanged event.
Protected Method | OnDisplayMemberChanged | Raises the ListControl.DisplayMemberChanged event.
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnFormat | Raises the ListControl.Format event.
Protected Method | OnFormatInfoChanged | Raises the ListControl.FormatInfoChanged event.
Protected Method | OnFormatStringChanged | Raises the ListControl.FormatStringChanged event.
Protected Method | OnFormattingEnabledChanged | Raises the ListControl.FormattingEnabledChanged event.
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnSelectedIndexChanged | Raises the ListControl.SelectedValueChanged event.
Protected Method | OnSelectedValueChanged | Raises the ListControl.SelectedValueChanged event.
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnValueMemberChanged | Raises the ListControl.ValueMemberChanged event.
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RefreshItem | When overridden in a derived class, resynchronizes the data of the object at the specified index with the contents of the data source.
Protected Method | RefreshItems | When overridden in a derived class, resynchronizes the item data with the contents of the data source.
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Control)
Protected Method | RenderAttributes | Renders the controls meta attributes (Inherited from Control)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetItemCore | When overridden in a derived class, sets the object with the specified index in the derived class.
Protected Method | SetItemsCore | When overridden in a derived class, sets the specified array of objects in a collection in the derived class.
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | DataSourceChanged | Occurs when the ListControl.DataSource changes.
Public Event | DisplayMemberChanged | Occurs when the ListControl.DisplayMember property changes.
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | Format | Occurs when the control is bound to a data value.
Public Event | FormatInfoChanged | Occurs when the value of the ListControl.FormatInfo property changes.
Public Event | FormatStringChanged | Occurs when value of the ListControl.FormatString property changes
Public Event | FormattingEnabledChanged | Occurs when the value of the ListControl.FormattingEnabled property changes.
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | SelectedValueChanged | Occurs when the ListControl.SelectedValue property changes.
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | ValueMemberChanged | Occurs when the ListControl.ValueMember property changes.
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

ListControl Class
Gizmox.WebGUI.Forms Namespace


ListControl Class Methods

[image]
Gizmox.WebGUI.Forms
ListControl Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ListControl Class

For a list of all members of this type, see ListControl members.

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetItemText | Returns the text representation of the specified item.
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | FilterItemOnProperty | Overloaded. Retrieves the current value of the ListControl item, if it is a property of an object, given the item.
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Control)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Overridden. Gets the critical events.
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from Control)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | Overridden.
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDataSourceChanged | Raises the ListControl.DataSourceChanged event.
Protected Method | OnDisplayMemberChanged | Raises the ListControl.DisplayMemberChanged event.
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnFormat | Raises the ListControl.Format event.
Protected Method | OnFormatInfoChanged | Raises the ListControl.FormatInfoChanged event.
Protected Method | OnFormatStringChanged | Raises the ListControl.FormatStringChanged event.
Protected Method | OnFormattingEnabledChanged | Raises the ListControl.FormattingEnabledChanged event.
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnSelectedIndexChanged | Raises the ListControl.SelectedValueChanged event.
Protected Method | OnSelectedValueChanged | Raises the ListControl.SelectedValueChanged event.
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnValueMemberChanged | Raises the ListControl.ValueMemberChanged event.
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RefreshItem | When overridden in a derived class, resynchronizes the data of the object at the specified index with the contents of the data source.
Protected Method | RefreshItems | When overridden in a derived class, resynchronizes the item data with the contents of the data source.
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Control)
Protected Method | RenderAttributes | Renders the controls meta attributes (Inherited from Control)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetItemCore | When overridden in a derived class, sets the object with the specified index in the derived class.
Protected Method | SetItemsCore | When overridden in a derived class, sets the specified array of objects in a collection in the derived class.
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

See Also

Reference

ListControl Class
Gizmox.WebGUI.Forms Namespace


FilterItemOnProperty Method

[image]
Gizmox.WebGUI.Forms
FilterItemOnProperty Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListControl Class : FilterItemOnProperty Method

Retrieves the current value of the ListControl item, if it is a property of an object, given the item.

Overload List

Overload | Description
FilterItemOnProperty(Object) | Retrieves the current value of the ListControl item, if it is a property of an object, given the item.
FilterItemOnProperty(Object,String) | Returns the current value of the ListControl item, if it is a property of an object given the item and the property name.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListControl Class
ListControl Members


FilterItemOnProperty(Object) Method

[image]
Gizmox.WebGUI.Forms
FilterItemOnProperty(Object) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListControl Class > FilterItemOnProperty Method : FilterItemOnProperty(Object) Method

item
The object the ListControl item is bound to.
Retrieves the current value of the ListControl item, if it is a property of an object, given the item.

Syntax

Visual Basic (Declaration)
Protected Overloads Function FilterItemOnProperty( _
   ByVal item As Object _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As ListControl
Dim item As Object
Dim value As Object

value = instance.FilterItemOnProperty(item)
C#
protected object FilterItemOnProperty(
   object item
)
Managed Extensions for C++
protected: Object* FilterItemOnProperty(
   Object* item
)
C++/CLI
protected:
Object^ FilterItemOnProperty(
   Object^ item
)

Parameters

item
The object the ListControl item is bound to.

Return Value

The filtered object.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListControl Class
ListControl Members
Overload List


FilterItemOnProperty(Object,String) Method

[image]
Gizmox.WebGUI.Forms
FilterItemOnProperty(Object,String) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListControl Class > FilterItemOnProperty Method : FilterItemOnProperty(Object,String) Method

item
The object the ListControl item is bound to.
field
The property name of the item the ListControl is bound to.
Returns the current value of the ListControl item, if it is a property of an object given the item and the property name.

Syntax

Visual Basic (Declaration)
Protected Overloads Function FilterItemOnProperty( _
   ByVal item As Object, _
   ByVal field As String _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As ListControl
Dim item As Object
Dim field As String
Dim value As Object

value = instance.FilterItemOnProperty(item, field)
C#
protected object FilterItemOnProperty(
   object item,
   string field
)
Managed Extensions for C++
protected: Object* FilterItemOnProperty(
   Object* item,
   string* field
)
C++/CLI
protected:
Object^ FilterItemOnProperty(
   Object^ item,
   String^ field
)

Parameters

item
The object the ListControl item is bound to.
field
The property name of the item the ListControl is bound to.

Return Value

The filtered object.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListControl Class
ListControl Members
Overload List


GetCriticalEvents Method

[image]
Gizmox.WebGUI.Forms
GetCriticalEvents Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListControl Class : GetCriticalEvents Method

Gets the critical events.

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetCriticalEvents() As EventTypes
Visual Basic (Usage) Copy Code
Dim instance As ListControl
Dim value As EventTypes

value = instance.GetCriticalEvents()
C#
protected override EventTypes GetCriticalEvents()
Managed Extensions for C++
protected: EventTypes GetCriticalEvents(); override
C++/CLI
protected:
EventTypes GetCriticalEvents(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListControl Class
ListControl Members


GetItemText Method

[image]
Gizmox.WebGUI.Forms
GetItemText Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListControl Class : GetItemText Method

item
The object from which to get the contents to display.
Returns the text representation of the specified item.

Syntax

Visual Basic (Declaration)
Public Overridable Function GetItemText( _
   ByVal item As Object _
) As String
Visual Basic (Usage) Copy Code
Dim instance As ListControl
Dim item As Object
Dim value As String

value = instance.GetItemText(item)
C#
public virtual string GetItemText(
   object item
)
Managed Extensions for C++
public: virtual string* GetItemText(
   Object* item
)
C++/CLI
public:
virtual String^ GetItemText(
   Object^ item
)

Parameters

item
The object from which to get the contents to display.

Return Value

If the ListControl.DisplayMember property is not specified, the value returned by GetItemText is the value of the item's ToString method. Otherwise, the method returns the string value of the member specified in the ListControl.DisplayMember property for the object specified in the item parameter.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListControl Class
ListControl Members


OnBindingContextChanged Method

[image]
Gizmox.WebGUI.Forms
OnBindingContextChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListControl Class : OnBindingContextChanged Method

e

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnBindingContextChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ListControl
Dim e As EventArgs

instance.OnBindingContextChanged(e)
C#
protected override void OnBindingContextChanged(
   EventArgs e
)
Managed Extensions for C++
protected: void OnBindingContextChanged(
   EventArgs* e
) override
C++/CLI
protected:
void OnBindingContextChanged(
   EventArgs^ e
) override

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListControl Class
ListControl Members


OnDataSourceChanged Method

[image]
Gizmox.WebGUI.Forms
OnDataSourceChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListControl Class : OnDataSourceChanged Method

e
An EventArgs that contains the event data.
Raises the ListControl.DataSourceChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnDataSourceChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ListControl
Dim e As EventArgs

instance.OnDataSourceChanged(e)
C#
protected virtual void OnDataSourceChanged(
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnDataSourceChanged(
   EventArgs* e
)
C++/CLI
protected:
virtual void OnDataSourceChanged(
   EventArgs^ e
)

Parameters

e
An EventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListControl Class
ListControl Members


OnDisplayMemberChanged Method

[image]
Gizmox.WebGUI.Forms
OnDisplayMemberChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListControl Class : OnDisplayMemberChanged Method

e
An EventArgs that contains the event data.
Raises the ListControl.DisplayMemberChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnDisplayMemberChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ListControl
Dim e As EventArgs

instance.OnDisplayMemberChanged(e)
C#
protected virtual void OnDisplayMemberChanged(
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnDisplayMemberChanged(
   EventArgs* e
)
C++/CLI
protected:
virtual void OnDisplayMemberChanged(
   EventArgs^ e
)

Parameters

e
An EventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListControl Class
ListControl Members


OnFormat Method

[image]
Gizmox.WebGUI.Forms
OnFormat Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListControl Class : OnFormat Method

e
A ListControlConvertEventArgs that contains the event data.
Raises the ListControl.Format event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnFormat( _
   ByVal e As ListControlConvertEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ListControl
Dim e As ListControlConvertEventArgs

instance.OnFormat(e)
C#
protected virtual void OnFormat(
   ListControlConvertEventArgs e
)
Managed Extensions for C++
protected: virtual void OnFormat(
   ListControlConvertEventArgs* e
)
C++/CLI
protected:
virtual void OnFormat(
   ListControlConvertEventArgs^ e
)

Parameters

e
A ListControlConvertEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListControl Class
ListControl Members


OnFormatInfoChanged Method

[image]
Gizmox.WebGUI.Forms
OnFormatInfoChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListControl Class : OnFormatInfoChanged Method

e
An EventArgs that contains the event data.
Raises the ListControl.FormatInfoChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnFormatInfoChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ListControl
Dim e As EventArgs

instance.OnFormatInfoChanged(e)
C#
protected virtual void OnFormatInfoChanged(
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnFormatInfoChanged(
   EventArgs* e
)
C++/CLI
protected:
virtual void OnFormatInfoChanged(
   EventArgs^ e
)

Parameters

e
An EventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListControl Class
ListControl Members


OnFormatStringChanged Method

[image]
Gizmox.WebGUI.Forms
OnFormatStringChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListControl Class : OnFormatStringChanged Method

e
An EventArgs that contains the event data.
Raises the ListControl.FormatStringChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnFormatStringChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ListControl
Dim e As EventArgs

instance.OnFormatStringChanged(e)
C#
protected virtual void OnFormatStringChanged(
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnFormatStringChanged(
   EventArgs* e
)
C++/CLI
protected:
virtual void OnFormatStringChanged(
   EventArgs^ e
)

Parameters

e
An EventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListControl Class
ListControl Members


OnFormattingEnabledChanged Method

[image]
Gizmox.WebGUI.Forms
OnFormattingEnabledChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListControl Class : OnFormattingEnabledChanged Method

e
An EventArgs that contains the event data.
Raises the ListControl.FormattingEnabledChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnFormattingEnabledChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ListControl
Dim e As EventArgs

instance.OnFormattingEnabledChanged(e)
C#
protected virtual void OnFormattingEnabledChanged(
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnFormattingEnabledChanged(
   EventArgs* e
)
C++/CLI
protected:
virtual void OnFormattingEnabledChanged(
   EventArgs^ e
)

Parameters

e
An EventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListControl Class
ListControl Members


OnSelectedIndexChanged Method

[image]
Gizmox.WebGUI.Forms
OnSelectedIndexChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListControl Class : OnSelectedIndexChanged Method

e
An EventArgs that contains the event data.
Raises the ListControl.SelectedValueChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnSelectedIndexChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ListControl
Dim e As EventArgs

instance.OnSelectedIndexChanged(e)
C#
protected virtual void OnSelectedIndexChanged(
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnSelectedIndexChanged(
   EventArgs* e
)
C++/CLI
protected:
virtual void OnSelectedIndexChanged(
   EventArgs^ e
)

Parameters

e
An EventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListControl Class
ListControl Members


OnSelectedValueChanged Method

[image]
Gizmox.WebGUI.Forms
OnSelectedValueChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListControl Class : OnSelectedValueChanged Method

e
An EventArgs that contains the event data.
Raises the ListControl.SelectedValueChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnSelectedValueChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ListControl
Dim e As EventArgs

instance.OnSelectedValueChanged(e)
C#
protected virtual void OnSelectedValueChanged(
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnSelectedValueChanged(
   EventArgs* e
)
C++/CLI
protected:
virtual void OnSelectedValueChanged(
   EventArgs^ e
)

Parameters

e
An EventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListControl Class
ListControl Members


OnValueMemberChanged Method

[image]
Gizmox.WebGUI.Forms
OnValueMemberChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListControl Class : OnValueMemberChanged Method

e
An EventArgs that contains the event data.
Raises the ListControl.ValueMemberChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnValueMemberChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ListControl
Dim e As EventArgs

instance.OnValueMemberChanged(e)
C#
protected virtual void OnValueMemberChanged(
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnValueMemberChanged(
   EventArgs* e
)
C++/CLI
protected:
virtual void OnValueMemberChanged(
   EventArgs^ e
)

Parameters

e
An EventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListControl Class
ListControl Members


RefreshItem Method

[image]
Gizmox.WebGUI.Forms
RefreshItem Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListControl Class : RefreshItem Method

index
The zero-based index of the item whose data to refresh.
When overridden in a derived class, resynchronizes the data of the object at the specified index with the contents of the data source.

Syntax

Visual Basic (Declaration)
Protected MustOverride Sub RefreshItem( _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As ListControl
Dim index As Integer

instance.RefreshItem(index)
C#
protected abstract void RefreshItem(
   int index
)
Managed Extensions for C++
protected: abstract void RefreshItem(
   int index
)
C++/CLI
protected:
abstract void RefreshItem(
   int index
)

Parameters

index
The zero-based index of the item whose data to refresh.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListControl Class
ListControl Members


RefreshItems Method

[image]
Gizmox.WebGUI.Forms
RefreshItems Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListControl Class : RefreshItems Method

When overridden in a derived class, resynchronizes the item data with the contents of the data source.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub RefreshItems()
Visual Basic (Usage) Copy Code
Dim instance As ListControl

instance.RefreshItems()
C#
protected virtual void RefreshItems()
Managed Extensions for C++
protected: virtual void RefreshItems();
C++/CLI
protected:
virtual void RefreshItems();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListControl Class
ListControl Members


SetItemCore Method

[image]
Gizmox.WebGUI.Forms
SetItemCore Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListControl Class : SetItemCore Method

index
The array index of the object.
value
The object.
When overridden in a derived class, sets the object with the specified index in the derived class.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub SetItemCore( _
   ByVal index As Integer, _
   ByVal value As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ListControl
Dim index As Integer
Dim value As Object

instance.SetItemCore(index, value)
C#
protected virtual void SetItemCore(
   int index,
   object value
)
Managed Extensions for C++
protected: virtual void SetItemCore(
   int index,
   Object* value
)
C++/CLI
protected:
virtual void SetItemCore(
   int index,
   Object^ value
)

Parameters

index
The array index of the object.
value
The object.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListControl Class
ListControl Members


SetItemsCore Method

[image]
Gizmox.WebGUI.Forms
SetItemsCore Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListControl Class : SetItemsCore Method

items
An array of items.
When overridden in a derived class, sets the specified array of objects in a collection in the derived class.

Syntax

Visual Basic (Declaration)
Protected MustOverride Sub SetItemsCore( _
   ByVal items As IList _
)
Visual Basic (Usage) Copy Code
Dim instance As ListControl
Dim items As IList

instance.SetItemsCore(items)
C#
protected abstract void SetItemsCore(
   IList items
)
Managed Extensions for C++
protected: abstract void SetItemsCore(
   IList* items
)
C++/CLI
protected:
abstract void SetItemsCore(
   IList^ items
)

Parameters

items
An array of items.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListControl Class
ListControl Members


ListControl Class Properties

[image]
Gizmox.WebGUI.Forms
ListControl Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ListControl Class

For a list of all members of this type, see ListControl members.

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | DataSource | Gets or sets the data source for this ListControl.
Public Property | DisplayMember | Gets or sets the property to display for this ListControl.
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | FormatInfo | Gets or sets the IFormatProvider that provides custom formatting behavior.
Public Property | FormatString | Gets or sets the format-specifier characters that indicate how a value is to be displayed.
Public Property | FormattingEnabled | Gets or sets a value indicating whether formatting is applied to the ListControl.DisplayMember property of the ListControl.
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | SelectedIndex | When overridden in a derived class, gets or sets the zero-based index of the currently selected item.
Public Property | SelectedValue | Gets or sets the value of the member property specified by the ListControl.ValueMember property.
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Control)
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | ValueMember | Gets or sets the property to use as the actual value for the items in the ListControl.
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | AllowSelection | Gets a value indicating whether the list enables selection of list items.
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DataManager | Gets the CurrencyManager associated with this control.
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | IsPostBackRequired | Indicates if the list control context requires its events to cause callback
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

See Also

Reference

ListControl Class
Gizmox.WebGUI.Forms Namespace


AllowSelection Property

[image]
Gizmox.WebGUI.Forms
AllowSelection Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListControl Class : AllowSelection Property

Gets a value indicating whether the list enables selection of list items.

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property AllowSelection As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ListControl
Dim value As Boolean

value = instance.AllowSelection
C#
protected virtual bool AllowSelection {get;}
Managed Extensions for C++
protected: __property virtual bool get_AllowSelection();
C++/CLI
protected:
virtual property bool AllowSelection {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListControl Class
ListControl Members


DataManager Property

[image]
Gizmox.WebGUI.Forms
DataManager Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListControl Class : DataManager Property

Gets the CurrencyManager associated with this control.

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property DataManager As CurrencyManager
Visual Basic (Usage) Copy Code
Dim instance As ListControl
Dim value As CurrencyManager

value = instance.DataManager
C#
protected CurrencyManager DataManager {get;}
Managed Extensions for C++
protected: __property CurrencyManager* get_DataManager();
C++/CLI
protected:
property CurrencyManager^ DataManager {
   CurrencyManager^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListControl Class
ListControl Members


DataSource Property

[image]
Gizmox.WebGUI.Forms
DataSource Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListControl Class : DataSource Property

Gets or sets the data source for this ListControl.

Syntax

Visual Basic (Declaration)
<AttributeProviderAttribute(TypeName="Gizmox.WebGUI.Forms.Binding+IDataSourceAttributeProvider, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d", PropertyName="")>
<DefaultValueAttribute()>
<SRDescriptionAttribute("Indicates the list that this control will use to get its items.")>
<SRCategoryAttribute("Data")>
<RefreshPropertiesAttribute()>
Public Property DataSource As Object
Visual Basic (Usage) Copy Code
Dim instance As ListControl
Dim value As Object

instance.DataSource = value

value = instance.DataSource
C#
[AttributeProviderAttribute(TypeName="Gizmox.WebGUI.Forms.Binding+IDataSourceAttributeProvider, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d", PropertyName="")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Indicates the list that this control will use to get its items.")]
[SRCategoryAttribute("Data")]
[RefreshPropertiesAttribute()]
public object DataSource {get; set;}
Managed Extensions for C++
[AttributeProviderAttribute(TypeName="Gizmox.WebGUI.Forms.Binding+IDataSourceAttributeProvider, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d", PropertyName="")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Indicates the list that this control will use to get its items.")]
[SRCategoryAttribute("Data")]
[RefreshPropertiesAttribute()]
public: __property Object* get_DataSource();
public: __property void set_DataSource(
   Object* value
);
C++/CLI
[AttributeProviderAttribute(TypeName="Gizmox.WebGUI.Forms.Binding+IDataSourceAttributeProvider, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d", PropertyName="")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Indicates the list that this control will use to get its items.")]
[SRCategoryAttribute("Data")]
[RefreshPropertiesAttribute()]
public:
property Object^ DataSource {
   Object^ get();
   void set (Object^value);
}

Exceptions

Exception | Description
ArgumentException | The assigned value does not implement the IList or IListSource interfaces.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListControl Class
ListControl Members


DisplayMember Property

[image]
Gizmox.WebGUI.Forms
DisplayMember Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListControl Class : DisplayMember Property

Gets or sets the property to display for this ListControl.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<TypeConverterAttribute("System.Windows.Forms.Design.DataMemberFieldConverter, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<SRCategoryAttribute("Data")>
<SRDescriptionAttribute("Indicates the property to display for the items in this control.")>
<EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="System.Windows.Forms.Design.DataMemberFieldEditor, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
Public Property DisplayMember As String
Visual Basic (Usage) Copy Code
Dim instance As ListControl
Dim value As String

instance.DisplayMember = value

value = instance.DisplayMember
C#
[DefaultValueAttribute()]
[TypeConverterAttribute("System.Windows.Forms.Design.DataMemberFieldConverter, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[SRCategoryAttribute("Data")]
[SRDescriptionAttribute("Indicates the property to display for the items in this control.")]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="System.Windows.Forms.Design.DataMemberFieldEditor, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
public string DisplayMember {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[TypeConverterAttribute("System.Windows.Forms.Design.DataMemberFieldConverter, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[SRCategoryAttribute("Data")]
[SRDescriptionAttribute("Indicates the property to display for the items in this control.")]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="System.Windows.Forms.Design.DataMemberFieldEditor, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
public: __property string* get_DisplayMember();
public: __property void set_DisplayMember(
   string* value
);
C++/CLI
[DefaultValueAttribute()]
[TypeConverterAttribute("System.Windows.Forms.Design.DataMemberFieldConverter, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[SRCategoryAttribute("Data")]
[SRDescriptionAttribute("Indicates the property to display for the items in this control.")]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="System.Windows.Forms.Design.DataMemberFieldEditor, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
public:
property String^ DisplayMember {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListControl Class
ListControl Members


FormatInfo Property

[image]
Gizmox.WebGUI.Forms
FormatInfo Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListControl Class : FormatInfo Property

Gets or sets the IFormatProvider that provides custom formatting behavior.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<BrowsableAttribute(False)>
Public Property FormatInfo As IFormatProvider
Visual Basic (Usage) Copy Code
Dim instance As ListControl
Dim value As IFormatProvider

instance.FormatInfo = value

value = instance.FormatInfo
C#
[DefaultValueAttribute()]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[BrowsableAttribute(false)]
public IFormatProvider FormatInfo {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[BrowsableAttribute(false)]
public: __property IFormatProvider* get_FormatInfo();
public: __property void set_FormatInfo(
   IFormatProvider* value
);
C++/CLI
[DefaultValueAttribute()]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[BrowsableAttribute(false)]
public:
property IFormatProvider^ FormatInfo {
   IFormatProvider^ get();
   void set (IFormatProvider^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListControl Class
ListControl Members


FormatString Property

[image]
Gizmox.WebGUI.Forms
FormatString Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListControl Class : FormatString Property

Gets or sets the format-specifier characters that indicate how a value is to be displayed.

Syntax

Visual Basic (Declaration)
<MergablePropertyAttribute(False)>
<SRDescriptionAttribute("The format specifier characters that indicate how a value is to be displayed.")>
<DefaultValueAttribute()>
Public Property FormatString As String
Visual Basic (Usage) Copy Code
Dim instance As ListControl
Dim value As String

instance.FormatString = value

value = instance.FormatString
C#
[MergablePropertyAttribute(false)]
[SRDescriptionAttribute("The format specifier characters that indicate how a value is to be displayed.")]
[DefaultValueAttribute()]
public string FormatString {get; set;}
Managed Extensions for C++
[MergablePropertyAttribute(false)]
[SRDescriptionAttribute("The format specifier characters that indicate how a value is to be displayed.")]
[DefaultValueAttribute()]
public: __property string* get_FormatString();
public: __property void set_FormatString(
   string* value
);
C++/CLI
[MergablePropertyAttribute(false)]
[SRDescriptionAttribute("The format specifier characters that indicate how a value is to be displayed.")]
[DefaultValueAttribute()]
public:
property String^ FormatString {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListControl Class
ListControl Members


FormattingEnabled Property

[image]
Gizmox.WebGUI.Forms
FormattingEnabled Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListControl Class : FormattingEnabled Property

Gets or sets a value indicating whether formatting is applied to the ListControl.DisplayMember property of the ListControl.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("If this property is true, the value of FormatString is used to convert the value of DisplayMember into a value that can be displayed.")>
<DefaultValueAttribute()>
Public Property FormattingEnabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ListControl
Dim value As Boolean

instance.FormattingEnabled = value

value = instance.FormattingEnabled
C#
[SRDescriptionAttribute("If this property is true, the value of FormatString is used to convert the value of DisplayMember into a value that can be displayed.")]
[DefaultValueAttribute()]
public bool FormattingEnabled {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("If this property is true, the value of FormatString is used to convert the value of DisplayMember into a value that can be displayed.")]
[DefaultValueAttribute()]
public: __property bool get_FormattingEnabled();
public: __property void set_FormattingEnabled(
   bool value
);
C++/CLI
[SRDescriptionAttribute("If this property is true, the value of FormatString is used to convert the value of DisplayMember into a value that can be displayed.")]
[DefaultValueAttribute()]
public:
property bool FormattingEnabled {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListControl Class
ListControl Members


IsPostBackRequired Property

[image]
Gizmox.WebGUI.Forms
IsPostBackRequired Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListControl Class : IsPostBackRequired Property

Indicates if the list control context requires its events to cause callback

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property IsPostBackRequired As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ListControl
Dim value As Boolean

value = instance.IsPostBackRequired
C#
protected virtual bool IsPostBackRequired {get;}
Managed Extensions for C++
protected: __property virtual bool get_IsPostBackRequired();
C++/CLI
protected:
virtual property bool IsPostBackRequired {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListControl Class
ListControl Members


SelectedIndex Property

[image]
Gizmox.WebGUI.Forms
SelectedIndex Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListControl Class : SelectedIndex Property

When overridden in a derived class, gets or sets the zero-based index of the currently selected item.

Syntax

Visual Basic (Declaration)
<BindableAttribute(True)>
Public MustOverride Property SelectedIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As ListControl
Dim value As Integer

instance.SelectedIndex = value

value = instance.SelectedIndex
C#
[BindableAttribute(true)]
public abstract int SelectedIndex {get; set;}
Managed Extensions for C++
[BindableAttribute(true)]
public: __property abstract int get_SelectedIndex();
public: __property abstract void set_SelectedIndex(
   int value
);
C++/CLI
[BindableAttribute(true)]
public:
abstract property int SelectedIndex {
   int get();
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListControl Class
ListControl Members


SelectedValue Property

[image]
Gizmox.WebGUI.Forms
SelectedValue Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListControl Class : SelectedValue Property

Gets or sets the value of the member property specified by the ListControl.ValueMember property.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<BindableAttribute(True)>
<DesignerSerializationVisibilityAttribute()>
<SRCategoryAttribute("Data")>
<BrowsableAttribute(False)>
<SRDescriptionAttribute("Indicates the actual value of the currently selected item. Setting it will cause the item whose actual value is equal to become selected.")>
Public Property SelectedValue As Object
Visual Basic (Usage) Copy Code
Dim instance As ListControl
Dim value As Object

instance.SelectedValue = value

value = instance.SelectedValue
C#
[DefaultValueAttribute()]
[BindableAttribute(true)]
[DesignerSerializationVisibilityAttribute()]
[SRCategoryAttribute("Data")]
[BrowsableAttribute(false)]
[SRDescriptionAttribute("Indicates the actual value of the currently selected item. Setting it will cause the item whose actual value is equal to become selected.")]
public object SelectedValue {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[BindableAttribute(true)]
[DesignerSerializationVisibilityAttribute()]
[SRCategoryAttribute("Data")]
[BrowsableAttribute(false)]
[SRDescriptionAttribute("Indicates the actual value of the currently selected item. Setting it will cause the item whose actual value is equal to become selected.")]
public: __property Object* get_SelectedValue();
public: __property void set_SelectedValue(
   Object* value
);
C++/CLI
[DefaultValueAttribute()]
[BindableAttribute(true)]
[DesignerSerializationVisibilityAttribute()]
[SRCategoryAttribute("Data")]
[BrowsableAttribute(false)]
[SRDescriptionAttribute("Indicates the actual value of the currently selected item. Setting it will cause the item whose actual value is equal to become selected.")]
public:
property Object^ SelectedValue {
   Object^ get();
   void set (Object^value);
}

Exceptions

Exception | Description
InvalidOperationException | The assigned value is null or the empty string ("").

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListControl Class
ListControl Members


ValueMember Property

[image]
Gizmox.WebGUI.Forms
ValueMember Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListControl Class : ValueMember Property

Gets or sets the property to use as the actual value for the items in the ListControl.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="System.Windows.Forms.Design.DataMemberFieldEditor, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<SRCategoryAttribute("Data")>
<SRDescriptionAttribute("Indicates the property to use as the actual value for the items in the control.")>
Public Property ValueMember As String
Visual Basic (Usage) Copy Code
Dim instance As ListControl
Dim value As String

instance.ValueMember = value

value = instance.ValueMember
C#
[DefaultValueAttribute()]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="System.Windows.Forms.Design.DataMemberFieldEditor, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[SRCategoryAttribute("Data")]
[SRDescriptionAttribute("Indicates the property to use as the actual value for the items in the control.")]
public string ValueMember {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="System.Windows.Forms.Design.DataMemberFieldEditor, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[SRCategoryAttribute("Data")]
[SRDescriptionAttribute("Indicates the property to use as the actual value for the items in the control.")]
public: __property string* get_ValueMember();
public: __property void set_ValueMember(
   string* value
);
C++/CLI
[DefaultValueAttribute()]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="System.Windows.Forms.Design.DataMemberFieldEditor, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[SRCategoryAttribute("Data")]
[SRDescriptionAttribute("Indicates the property to use as the actual value for the items in the control.")]
public:
property String^ ValueMember {
   String^ get();
   void set (String^value);
}

Exceptions

Exception | Description
ArgumentException | The specified property cannot be found on the object specified by the ListControl.DataSource property.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListControl Class
ListControl Members


ListControl Class Events

[image]
Gizmox.WebGUI.Forms
ListControl Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ListControl Class

For a list of all members of this type, see ListControl members.

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | DataSourceChanged | Occurs when the ListControl.DataSource changes.
Public Event | DisplayMemberChanged | Occurs when the ListControl.DisplayMember property changes.
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | Format | Occurs when the control is bound to a data value.
Public Event | FormatInfoChanged | Occurs when the value of the ListControl.FormatInfo property changes.
Public Event | FormatStringChanged | Occurs when value of the ListControl.FormatString property changes
Public Event | FormattingEnabledChanged | Occurs when the value of the ListControl.FormattingEnabled property changes.
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | SelectedValueChanged | Occurs when the ListControl.SelectedValue property changes.
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | ValueMemberChanged | Occurs when the ListControl.ValueMember property changes.
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

ListControl Class
Gizmox.WebGUI.Forms Namespace


DataSourceChanged Event

[image]
Gizmox.WebGUI.Forms
DataSourceChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListControl Class : DataSourceChanged Event

Occurs when the ListControl.DataSource changes.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Event raised when the value of the DataSource property is changed on ListControl.")>
<SRCategoryAttribute("Property Changed")>
Public Event DataSourceChanged() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As ListControl
Dim handler As EventHandler

AddHandler instance.DataSourceChanged, handler
C#
[SRDescriptionAttribute("Event raised when the value of the DataSource property is changed on ListControl.")]
[SRCategoryAttribute("Property Changed")]
public event EventHandler DataSourceChanged()
Managed Extensions for C++
[SRDescriptionAttribute("Event raised when the value of the DataSource property is changed on ListControl.")]
[SRCategoryAttribute("Property Changed")]
public: __event EventHandler* DataSourceChanged
C++/CLI
[SRDescriptionAttribute("Event raised when the value of the DataSource property is changed on ListControl.")]
[SRCategoryAttribute("Property Changed")]
public:
event EventHandler^ DataSourceChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListControl Class
ListControl Members


DisplayMemberChanged Event

[image]
Gizmox.WebGUI.Forms
DisplayMemberChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListControl Class : DisplayMemberChanged Event

Occurs when the ListControl.DisplayMember property changes.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Event raised when the value of the DisplayMember property is changed on ListControl.")>
<SRCategoryAttribute("Property Changed")>
Public Event DisplayMemberChanged() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As ListControl
Dim handler As EventHandler

AddHandler instance.DisplayMemberChanged, handler
C#
[SRDescriptionAttribute("Event raised when the value of the DisplayMember property is changed on ListControl.")]
[SRCategoryAttribute("Property Changed")]
public event EventHandler DisplayMemberChanged()
Managed Extensions for C++
[SRDescriptionAttribute("Event raised when the value of the DisplayMember property is changed on ListControl.")]
[SRCategoryAttribute("Property Changed")]
public: __event EventHandler* DisplayMemberChanged
C++/CLI
[SRDescriptionAttribute("Event raised when the value of the DisplayMember property is changed on ListControl.")]
[SRCategoryAttribute("Property Changed")]
public:
event EventHandler^ DisplayMemberChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListControl Class
ListControl Members


Format Event

[image]
Gizmox.WebGUI.Forms
Format Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListControl Class : Format Event

Occurs when the control is bound to a data value.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Property Changed")>
<SRDescriptionAttribute("Event raised to allow you to convert the value to a value suitable for display.")>
Public Event Format() As ListControlConvertEventHandler
Visual Basic (Usage) Copy Code
Dim instance As ListControl
Dim handler As ListControlConvertEventHandler

AddHandler instance.Format, handler
C#
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised to allow you to convert the value to a value suitable for display.")]
public event ListControlConvertEventHandler Format()
Managed Extensions for C++
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised to allow you to convert the value to a value suitable for display.")]
public: __event ListControlConvertEventHandler* Format
C++/CLI
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised to allow you to convert the value to a value suitable for display.")]
public:
event ListControlConvertEventHandler^ Format

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListControl Class
ListControl Members


FormatInfoChanged Event

[image]
Gizmox.WebGUI.Forms
FormatInfoChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListControl Class : FormatInfoChanged Event

Occurs when the value of the ListControl.FormatInfo property changes.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Property Changed")>
<BrowsableAttribute(False)>
<SRDescriptionAttribute("Event raised when the value of the FormatInfo property changed.")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Event FormatInfoChanged() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As ListControl
Dim handler As EventHandler

AddHandler instance.FormatInfoChanged, handler
C#
[SRCategoryAttribute("Property Changed")]
[BrowsableAttribute(false)]
[SRDescriptionAttribute("Event raised when the value of the FormatInfo property changed.")]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public event EventHandler FormatInfoChanged()
Managed Extensions for C++
[SRCategoryAttribute("Property Changed")]
[BrowsableAttribute(false)]
[SRDescriptionAttribute("Event raised when the value of the FormatInfo property changed.")]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: __event EventHandler* FormatInfoChanged
C++/CLI
[SRCategoryAttribute("Property Changed")]
[BrowsableAttribute(false)]
[SRDescriptionAttribute("Event raised when the value of the FormatInfo property changed.")]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
event EventHandler^ FormatInfoChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListControl Class
ListControl Members


FormatStringChanged Event

[image]
Gizmox.WebGUI.Forms
FormatStringChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListControl Class : FormatStringChanged Event

Occurs when value of the ListControl.FormatString property changes

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Event raised when the value of the FormatString property is changed.")>
<SRCategoryAttribute("Property Changed")>
Public Event FormatStringChanged() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As ListControl
Dim handler As EventHandler

AddHandler instance.FormatStringChanged, handler
C#
[SRDescriptionAttribute("Event raised when the value of the FormatString property is changed.")]
[SRCategoryAttribute("Property Changed")]
public event EventHandler FormatStringChanged()
Managed Extensions for C++
[SRDescriptionAttribute("Event raised when the value of the FormatString property is changed.")]
[SRCategoryAttribute("Property Changed")]
public: __event EventHandler* FormatStringChanged
C++/CLI
[SRDescriptionAttribute("Event raised when the value of the FormatString property is changed.")]
[SRCategoryAttribute("Property Changed")]
public:
event EventHandler^ FormatStringChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListControl Class
ListControl Members


FormattingEnabledChanged Event

[image]
Gizmox.WebGUI.Forms
FormattingEnabledChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListControl Class : FormattingEnabledChanged Event

Occurs when the value of the ListControl.FormattingEnabled property changes.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Property Changed")>
<SRDescriptionAttribute("Event raised when the value of the FormattingEnabled property is changed.")>
Public Event FormattingEnabledChanged() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As ListControl
Dim handler As EventHandler

AddHandler instance.FormattingEnabledChanged, handler
C#
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the FormattingEnabled property is changed.")]
public event EventHandler FormattingEnabledChanged()
Managed Extensions for C++
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the FormattingEnabled property is changed.")]
public: __event EventHandler* FormattingEnabledChanged
C++/CLI
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the FormattingEnabled property is changed.")]
public:
event EventHandler^ FormattingEnabledChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListControl Class
ListControl Members


SelectedValueChanged Event

[image]
Gizmox.WebGUI.Forms
SelectedValueChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListControl Class : SelectedValueChanged Event

Occurs when the ListControl.SelectedValue property changes.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Property Changed")>
<SRDescriptionAttribute("Event raised when the value of the SelectedValue property is changed on ListControl.")>
Public Event SelectedValueChanged() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As ListControl
Dim handler As EventHandler

AddHandler instance.SelectedValueChanged, handler
C#
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the SelectedValue property is changed on ListControl.")]
public event EventHandler SelectedValueChanged()
Managed Extensions for C++
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the SelectedValue property is changed on ListControl.")]
public: __event EventHandler* SelectedValueChanged
C++/CLI
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the SelectedValue property is changed on ListControl.")]
public:
event EventHandler^ SelectedValueChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListControl Class
ListControl Members


ValueMemberChanged Event

[image]
Gizmox.WebGUI.Forms
ValueMemberChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListControl Class : ValueMemberChanged Event

Occurs when the ListControl.ValueMember property changes.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Event raised when the value of the ValueMember property is changed on ListControl.")>
<SRCategoryAttribute("Property Changed")>
Public Event ValueMemberChanged() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As ListControl
Dim handler As EventHandler

AddHandler instance.ValueMemberChanged, handler
C#
[SRDescriptionAttribute("Event raised when the value of the ValueMember property is changed on ListControl.")]
[SRCategoryAttribute("Property Changed")]
public event EventHandler ValueMemberChanged()
Managed Extensions for C++
[SRDescriptionAttribute("Event raised when the value of the ValueMember property is changed on ListControl.")]
[SRCategoryAttribute("Property Changed")]
public: __event EventHandler* ValueMemberChanged
C++/CLI
[SRDescriptionAttribute("Event raised when the value of the ValueMember property is changed on ListControl.")]
[SRCategoryAttribute("Property Changed")]
public:
event EventHandler^ ValueMemberChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListControl Class
ListControl Members


ListControlConvertEventArgs Class

[image]
Gizmox.WebGUI.Forms
ListControlConvertEventArgs Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ListControlConvertEventArgs Class

Provides data for the ListControl.Format event.

Syntax

Visual Basic (Declaration)
Public Class ListControlConvertEventArgs
   Inherits ConvertEventArgs
Visual Basic (Usage) Copy Code
Dim instance As ListControlConvertEventArgs
C#
public class ListControlConvertEventArgs : ConvertEventArgs
Managed Extensions for C++
public __gc class ListControlConvertEventArgs : public ConvertEventArgs
C++/CLI
public ref class ListControlConvertEventArgs : public ConvertEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gizmox.WebGUI.Forms.ConvertEventArgs
Gizmox.WebGUI.Forms.ListControlConvertEventArgs

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

ListControlConvertEventArgs Members
Gizmox.WebGUI.Forms Namespace


ListControlConvertEventArgs Class Members

[image]
Gizmox.WebGUI.Forms
ListControlConvertEventArgs Class Members
See Also Properties Send Feedback
Gizmox.WebGUI.Forms Namespace : ListControlConvertEventArgs Class

The following tables list the members exposed by ListControlConvertEventArgs.

Public Constructors

 | Name | Description
Public Constructor | ListControlConvertEventArgs Constructor | Initializes a new instance of the ListControlConvertEventArgs class with the specified object, type, and list item.
Top

Public Properties

 | Name | Description
Public Property | DesiredType | Gets the data type of the desired value. (Inherited from ConvertEventArgs)
Public Property | ListItem | Gets a data source item.
Public Property | Value | Gets or sets the value of the ConvertEventArgs. (Inherited from ConvertEventArgs)
Top

See Also

Reference

ListControlConvertEventArgs Class
Gizmox.WebGUI.Forms Namespace


ListControlConvertEventArgs Constructor

[image]
Gizmox.WebGUI.Forms
ListControlConvertEventArgs Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListControlConvertEventArgs Class : ListControlConvertEventArgs Constructor

value
The value displayed in the ListControl.
desiredType
The Type for the displayed item.
listItem
The data source item to be displayed in the ListControl.
Initializes a new instance of the ListControlConvertEventArgs class with the specified object, type, and list item.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal value As Object, _
   ByVal desiredType As Type, _
   ByVal listItem As Object _
)
Visual Basic (Usage) Copy Code
Dim value As Object
Dim desiredType As Type
Dim listItem As Object

Dim instance As ListControlConvertEventArgs(value, desiredType, listItem)
C#
public ListControlConvertEventArgs(
   object value,
   Type desiredType,
   object listItem
)
Managed Extensions for C++
public: ListControlConvertEventArgs(
   Object* value,
   Type* desiredType,
   Object* listItem
)
C++/CLI
public:
ListControlConvertEventArgs(
   Object^ value,
   Type^ desiredType,
   Object^ listItem
)

Parameters

value
The value displayed in the ListControl.
desiredType
The Type for the displayed item.
listItem
The data source item to be displayed in the ListControl.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListControlConvertEventArgs Class
ListControlConvertEventArgs Members


ListControlConvertEventArgs Class Properties

[image]
Gizmox.WebGUI.Forms
ListControlConvertEventArgs Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ListControlConvertEventArgs Class

For a list of all members of this type, see ListControlConvertEventArgs members.

Public Properties

 | Name | Description
Public Property | DesiredType | Gets the data type of the desired value. (Inherited from ConvertEventArgs)
Public Property | ListItem | Gets a data source item.
Public Property | Value | Gets or sets the value of the ConvertEventArgs. (Inherited from ConvertEventArgs)
Top

See Also

Reference

ListControlConvertEventArgs Class
Gizmox.WebGUI.Forms Namespace


ListItem Property

[image]
Gizmox.WebGUI.Forms
ListItem Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListControlConvertEventArgs Class : ListItem Property

Gets a data source item.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ListItem As Object
Visual Basic (Usage) Copy Code
Dim instance As ListControlConvertEventArgs
Dim value As Object

value = instance.ListItem
C#
public object ListItem {get;}
Managed Extensions for C++
public: __property Object* get_ListItem();
C++/CLI
public:
property Object^ ListItem {
   Object^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListControlConvertEventArgs Class
ListControlConvertEventArgs Members


ListView Class

[image]
Gizmox.WebGUI.Forms
ListView Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ListView Class

A ListView control.

Object Model

Syntax

Visual Basic (Declaration)
<ToolboxBitmapAttribute()>
<DesignTimeControllerAttribute()>
<ClientControllerAttribute()>
<ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<MetadataTagAttribute("LV")>
<SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableListView, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")>
<ToolboxItemCategoryAttribute("Common Controls")>
<DefaultEventAttribute("SelectedIndexChanged")>
Public Class ListView
   Inherits Control
   Implements IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Visual Basic (Usage) Copy Code
Dim instance As ListView
C#
[ToolboxBitmapAttribute()]
[DesignTimeControllerAttribute()]
[ClientControllerAttribute()]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[MetadataTagAttribute("LV")]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableListView, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[ToolboxItemCategoryAttribute("Common Controls")]
[DefaultEventAttribute("SelectedIndexChanged")]
public class ListView : Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Managed Extensions for C++
[ToolboxBitmapAttribute()]
[DesignTimeControllerAttribute()]
[ClientControllerAttribute()]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[MetadataTagAttribute("LV")]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableListView, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[ToolboxItemCategoryAttribute("Common Controls")]
[DefaultEventAttribute("SelectedIndexChanged")]
public __gc class ListView : public Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
C++/CLI
[ToolboxBitmapAttribute()]
[DesignTimeControllerAttribute()]
[ClientControllerAttribute()]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[MetadataTagAttribute("LV")]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableListView, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[ToolboxItemCategoryAttribute("Common Controls")]
[DefaultEventAttribute("SelectedIndexChanged")]
public ref class ListView : public Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement

Remarks

The list view control is used to display a list of items.

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.ListView

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

ListView Members
Gizmox.WebGUI.Forms Namespace


ListView Class Members

[image]
Gizmox.WebGUI.Forms
ListView Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : ListView Class

The following tables list the members exposed by ListView.

Public Constructors

 | Name | Description
Public Constructor | ListView Constructor | Creates a new ListView instance.
Top

Public Properties

 | Name | Description
Public Property | Activation | Set/Gets the activation type (Not implemented).
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | AutoColumnGeneration | Gets or sets if auto column generation is active when using data binding
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Overridden. Gets a value indicating whether this instance can focus.
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | CheckBoxes | Gets or sets a value indicating whether a check box appears next to each item in the control.
Public Property | CheckedIndices | Gets the checked indices.
Public Property | CheckedItems | Gets the checked items.
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | ColumnResizeStyle | Gets or sets if column auto resizing mode
Public Property | Columns | Gets the collection of columns contained within the listview.
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | CurrentPage | Gets or sets the current page.
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | DataMember | The listview data memeber
Public Property | DataSource | The listview data source
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | FocusedItem | Gets the focused item (Not implemented).
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | FullRowSelect | Gets or sets a value indicating whether full row select is enabled.
Public Property | GridLines |
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | HeaderStyle | Gets or sets the header style.
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | HideSelection |
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | Items | Gets the collection of items contained within the listview.
Public Property | ItemsPerPage |
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | LargeImageList | Gets or sets the ImageList to use when displaying items as large icons in the control.
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | ListViewItemSorter | Gets or sets the list view item sorter.
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MultiSelect | Gets or sets a value indicating whether multiple items can be selected.
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | Scrollable | Gets or sets a value indicating whether a scroll bar is added to the control when there is not enough room to display all items.
Public Property | SelectedIndex | Gets the currently selected item index.
Public Property | SelectedIndices | Gets the selected indices.
Public Property | SelectedItem | Gets the currently selected item index.
Public Property | SelectedItems | Gets the selected items.
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | SmallImageList | Gets or sets the ImageList to use when displaying items as small icons in the control.
Public Property | StateImageList | Gets or sets the ImageList associated with application-defined states in the control.
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Control)
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | TotalItems | Gets or sets the total items.
Public Property | TotalPages | Gets or sets the total pages.
Public Property | UseInternalPaging | Uses internal paging algorithem
Public Property | View | Gets or sets the list view mode.
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | Overridden.
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | Overridden.
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | Overridden.
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

Public Methods

 | Name | Description
Public Method | AutoResizeColumn | Resizes the width of the given column as indicated by the resize style.
Public Method | BeginUpdate | Flags that the listview is currently going through updates.
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Clear | Removes all items and columns from the control.
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | EndUpdate | Finish batch updates and flags that the listview has finished updates.
Public Method | EnsureVisible | Ensures that the specified item is visible within the control, scrolling the contents of the control if necessary.
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | Sort | Sorts this list items.
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | ApplyGrouping | Apply grouping
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Overridden. Fires an event.
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Overridden. Gets the critical events.
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from Control)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | Overridden. Raises the Control.BindingContextChanged event.
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateColumn | Creates the column
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGetCellValue | Gets the row item value
Protected Method | OnGetCellValueAsObject | Gets the row item value
Protected Method | OnGetColumn | Get column from property
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnRowFormating | Called when [row formating].
Protected Method | OnSelectedIndexChanged |
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | Overridden.
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | Overridden. Renders the current control.
Protected Method | RenderAttributes | Renders the controls meta attributes (Inherited from Control)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Overridden. Renders the controls sub tree
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderSelectionButtons | Renders the list view selection buttons data
Protected Method | RenderUpdatedAttributes | Overridden.
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ColumnClick |
Public Event | ColumnUpdate | Columns where updated by the user
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | ItemActivate | Occurs when an item is activated.
Public Event | ItemCheck | Occurs when the checked state of an item changes.
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | PagingChanged | Occurs when the paging params have changed.
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | SelectedIndexChanged | Occurs when the SelectedIndex property has changed.
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

ListView Class
Gizmox.WebGUI.Forms Namespace


ListView Constructor

[image]
Gizmox.WebGUI.Forms
ListView Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView Class : ListView Constructor

Creates a new ListView instance.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ListView()
C#
public ListView()
Managed Extensions for C++
public: ListView();
C++/CLI
public:
ListView();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView Class
ListView Members


ListView Class Methods

[image]
Gizmox.WebGUI.Forms
ListView Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ListView Class

For a list of all members of this type, see ListView members.

Public Methods

 | Name | Description
Public Method | AutoResizeColumn | Resizes the width of the given column as indicated by the resize style.
Public Method | BeginUpdate | Flags that the listview is currently going through updates.
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Clear | Removes all items and columns from the control.
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | EndUpdate | Finish batch updates and flags that the listview has finished updates.
Public Method | EnsureVisible | Ensures that the specified item is visible within the control, scrolling the contents of the control if necessary.
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | Sort | Sorts this list items.
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | ApplyGrouping | Apply grouping
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Overridden. Fires an event.
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Overridden. Gets the critical events.
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from Control)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | Overridden. Raises the Control.BindingContextChanged event.
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateColumn | Creates the column
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGetCellValue | Gets the row item value
Protected Method | OnGetCellValueAsObject | Gets the row item value
Protected Method | OnGetColumn | Get column from property
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnRowFormating | Called when [row formating].
Protected Method | OnSelectedIndexChanged |
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | Overridden.
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | Overridden. Renders the current control.
Protected Method | RenderAttributes | Renders the controls meta attributes (Inherited from Control)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Overridden. Renders the controls sub tree
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderSelectionButtons | Renders the list view selection buttons data
Protected Method | RenderUpdatedAttributes | Overridden.
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

See Also

Reference

ListView Class
Gizmox.WebGUI.Forms Namespace


ApplyGrouping Method

[image]
Gizmox.WebGUI.Forms
ApplyGrouping Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView Class : ApplyGrouping Method

Apply grouping

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ApplyGrouping()
Visual Basic (Usage) Copy Code
Dim instance As ListView

instance.ApplyGrouping()
C#
protected virtual void ApplyGrouping()
Managed Extensions for C++
protected: virtual void ApplyGrouping();
C++/CLI
protected:
virtual void ApplyGrouping();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView Class
ListView Members


AutoResizeColumn Method

[image]
Gizmox.WebGUI.Forms
AutoResizeColumn Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView Class : AutoResizeColumn Method

columnIndex
The zero-based index of the column to resize.
headerAutoResize
One of the ColumnHeaderAutoResizeStyle values.
Resizes the width of the given column as indicated by the resize style.

Syntax

Visual Basic (Declaration)
Public Sub AutoResizeColumn( _
   ByVal columnIndex As Integer, _
   ByVal headerAutoResize As ColumnHeaderAutoResizeStyle _
)
Visual Basic (Usage) Copy Code
Dim instance As ListView
Dim columnIndex As Integer
Dim headerAutoResize As ColumnHeaderAutoResizeStyle

instance.AutoResizeColumn(columnIndex, headerAutoResize)
C#
public void AutoResizeColumn(
   int columnIndex,
   ColumnHeaderAutoResizeStyle headerAutoResize
)
Managed Extensions for C++
public: void AutoResizeColumn(
   int columnIndex,
   ColumnHeaderAutoResizeStyle headerAutoResize
)
C++/CLI
public:
void AutoResizeColumn(
   int columnIndex,
   ColumnHeaderAutoResizeStyle headerAutoResize
)

Parameters

columnIndex
The zero-based index of the column to resize.
headerAutoResize
One of the ColumnHeaderAutoResizeStyle values.

Exceptions

Exception | Description
InvalidEnumArgumentException | headerAutoResize is not a member of the ColumnHeaderAutoResizeStyle enumeration.
ArgumentOutOfRangeException | columnIndex is greater than 0 when Columns is null-or-columnIndex is less than 0 or greater than the number of columns set.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView Class
ListView Members


BeginUpdate Method

[image]
Gizmox.WebGUI.Forms
BeginUpdate Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView Class : BeginUpdate Method

Flags that the listview is currently going through updates.

Syntax

Visual Basic (Declaration)
Public Sub BeginUpdate()
Visual Basic (Usage) Copy Code
Dim instance As ListView

instance.BeginUpdate()
C#
public void BeginUpdate()
Managed Extensions for C++
public: void BeginUpdate();
C++/CLI
public:
void BeginUpdate();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView Class
ListView Members


Clear Method

[image]
Gizmox.WebGUI.Forms
Clear Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView Class : Clear Method

Removes all items and columns from the control.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As ListView

instance.Clear()
C#
public void Clear()
Managed Extensions for C++
public: void Clear();
C++/CLI
public:
void Clear();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView Class
ListView Members


EndUpdate Method

[image]
Gizmox.WebGUI.Forms
EndUpdate Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView Class : EndUpdate Method

Finish batch updates and flags that the listview has finished updates.

Syntax

Visual Basic (Declaration)
Public Sub EndUpdate()
Visual Basic (Usage) Copy Code
Dim instance As ListView

instance.EndUpdate()
C#
public void EndUpdate()
Managed Extensions for C++
public: void EndUpdate();
C++/CLI
public:
void EndUpdate();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView Class
ListView Members


EnsureVisible Method

[image]
Gizmox.WebGUI.Forms
EnsureVisible Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView Class : EnsureVisible Method

index
The zero-based index of the item to scroll into view.
Ensures that the specified item is visible within the control, scrolling the contents of the control if necessary.

Syntax

Visual Basic (Declaration)
Public Sub EnsureVisible( _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As ListView
Dim index As Integer

instance.EnsureVisible(index)
C#
public void EnsureVisible(
   int index
)
Managed Extensions for C++
public: void EnsureVisible(
   int index
)
C++/CLI
public:
void EnsureVisible(
   int index
)

Parameters

index
The zero-based index of the item to scroll into view.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView Class
ListView Members


FireEvent Method

[image]
Gizmox.WebGUI.Forms
FireEvent Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView Class : FireEvent Method

objEvent
event.
Fires an event.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub FireEvent( _
   ByVal objEvent As IEvent _
)
Visual Basic (Usage) Copy Code
Dim instance As ListView
Dim objEvent As IEvent

instance.FireEvent(objEvent)
C#
protected override void FireEvent(
   IEvent objEvent
)
Managed Extensions for C++
protected: void FireEvent(
   IEvent* objEvent
) override
C++/CLI
protected:
void FireEvent(
   IEvent^ objEvent
) override

Parameters

objEvent
event.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView Class
ListView Members


GetCriticalEvents Method

[image]
Gizmox.WebGUI.Forms
GetCriticalEvents Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView Class : GetCriticalEvents Method

Gets the critical events.

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetCriticalEvents() As EventTypes
Visual Basic (Usage) Copy Code
Dim instance As ListView
Dim value As EventTypes

value = instance.GetCriticalEvents()
C#
protected override EventTypes GetCriticalEvents()
Managed Extensions for C++
protected: EventTypes GetCriticalEvents(); override
C++/CLI
protected:
EventTypes GetCriticalEvents(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView Class
ListView Members


OnBindingContextChanged Method

[image]
Gizmox.WebGUI.Forms
OnBindingContextChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView Class : OnBindingContextChanged Method

e
An EventArgs that contains the event data.
Raises the Control.BindingContextChanged event.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnBindingContextChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ListView
Dim e As EventArgs

instance.OnBindingContextChanged(e)
C#
protected override void OnBindingContextChanged(
   EventArgs e
)
Managed Extensions for C++
protected: void OnBindingContextChanged(
   EventArgs* e
) override
C++/CLI
protected:
void OnBindingContextChanged(
   EventArgs^ e
) override

Parameters

e
An EventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView Class
ListView Members


OnCreateColumn Method

[image]
Gizmox.WebGUI.Forms
OnCreateColumn Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView Class : OnCreateColumn Method

objProperty
Creates the column

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnCreateColumn( _
   ByVal objProperty As PropertyDescriptor _
) As ColumnHeader
Visual Basic (Usage) Copy Code
Dim instance As ListView
Dim objProperty As PropertyDescriptor
Dim value As ColumnHeader

value = instance.OnCreateColumn(objProperty)
C#
protected virtual ColumnHeader OnCreateColumn(
   PropertyDescriptor objProperty
)
Managed Extensions for C++
protected: virtual ColumnHeader* OnCreateColumn(
   PropertyDescriptor* objProperty
)
C++/CLI
protected:
virtual ColumnHeader^ OnCreateColumn(
   PropertyDescriptor^ objProperty
)

Parameters

objProperty

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView Class
ListView Members


OnGetCellValue Method

[image]
Gizmox.WebGUI.Forms
OnGetCellValue Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView Class : OnGetCellValue Method

objRow
objProperty
Gets the row item value

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnGetCellValue( _
   ByVal objRow As Object, _
   ByVal objProperty As PropertyDescriptor _
) As String
Visual Basic (Usage) Copy Code
Dim instance As ListView
Dim objRow As Object
Dim objProperty As PropertyDescriptor
Dim value As String

value = instance.OnGetCellValue(objRow, objProperty)
C#
protected virtual string OnGetCellValue(
   object objRow,
   PropertyDescriptor objProperty
)
Managed Extensions for C++
protected: virtual string* OnGetCellValue(
   Object* objRow,
   PropertyDescriptor* objProperty
)
C++/CLI
protected:
virtual String^ OnGetCellValue(
   Object^ objRow,
   PropertyDescriptor^ objProperty
)

Parameters

objRow
objProperty

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView Class
ListView Members


OnGetCellValueAsObject Method

[image]
Gizmox.WebGUI.Forms
OnGetCellValueAsObject Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView Class : OnGetCellValueAsObject Method

objRow
objProperty
Gets the row item value

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnGetCellValueAsObject( _
   ByVal objRow As Object, _
   ByVal objProperty As PropertyDescriptor _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As ListView
Dim objRow As Object
Dim objProperty As PropertyDescriptor
Dim value As Object

value = instance.OnGetCellValueAsObject(objRow, objProperty)
C#
protected virtual object OnGetCellValueAsObject(
   object objRow,
   PropertyDescriptor objProperty
)
Managed Extensions for C++
protected: virtual Object* OnGetCellValueAsObject(
   Object* objRow,
   PropertyDescriptor* objProperty
)
C++/CLI
protected:
virtual Object^ OnGetCellValueAsObject(
   Object^ objRow,
   PropertyDescriptor^ objProperty
)

Parameters

objRow
objProperty

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView Class
ListView Members


OnGetColumn Method

[image]
Gizmox.WebGUI.Forms
OnGetColumn Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView Class : OnGetColumn Method

objProperty
Get column from property

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnGetColumn( _
   ByVal objProperty As PropertyDescriptor _
) As ColumnHeader
Visual Basic (Usage) Copy Code
Dim instance As ListView
Dim objProperty As PropertyDescriptor
Dim value As ColumnHeader

value = instance.OnGetColumn(objProperty)
C#
protected virtual ColumnHeader OnGetColumn(
   PropertyDescriptor objProperty
)
Managed Extensions for C++
protected: virtual ColumnHeader* OnGetColumn(
   PropertyDescriptor* objProperty
)
C++/CLI
protected:
virtual ColumnHeader^ OnGetColumn(
   PropertyDescriptor^ objProperty
)

Parameters

objProperty

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView Class
ListView Members


OnRowFormating Method

[image]
Gizmox.WebGUI.Forms
OnRowFormating Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView Class : OnRowFormating Method

objRow
The row.
objListViewItem
The list view item.
Called when [row formating].

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnRowFormating( _
   ByVal objRow As Object, _
   ByVal objListViewItem As ListViewItem _
)
Visual Basic (Usage) Copy Code
Dim instance As ListView
Dim objRow As Object
Dim objListViewItem As ListViewItem

instance.OnRowFormating(objRow, objListViewItem)
C#
protected virtual void OnRowFormating(
   object objRow,
   ListViewItem objListViewItem
)
Managed Extensions for C++
protected: virtual void OnRowFormating(
   Object* objRow,
   ListViewItem* objListViewItem
)
C++/CLI
protected:
virtual void OnRowFormating(
   Object^ objRow,
   ListViewItem^ objListViewItem
)

Parameters

objRow
The row.
objListViewItem
The list view item.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView Class
ListView Members


OnSelectedIndexChanged Method

[image]
Gizmox.WebGUI.Forms
OnSelectedIndexChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView Class : OnSelectedIndexChanged Method

e

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnSelectedIndexChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ListView
Dim e As EventArgs

instance.OnSelectedIndexChanged(e)
C#
protected virtual void OnSelectedIndexChanged(
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnSelectedIndexChanged(
   EventArgs* e
)
C++/CLI
protected:
virtual void OnSelectedIndexChanged(
   EventArgs^ e
)

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView Class
ListView Members


OnUnregisterComponents Method

[image]
Gizmox.WebGUI.Forms
OnUnregisterComponents Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView Class : OnUnregisterComponents Method

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnUnregisterComponents()
Visual Basic (Usage) Copy Code
Dim instance As ListView

instance.OnUnregisterComponents()
C#
protected override void OnUnregisterComponents()
Managed Extensions for C++
protected: void OnUnregisterComponents(); override
C++/CLI
protected:
void OnUnregisterComponents(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView Class
ListView Members


Render Method

[image]
Gizmox.WebGUI.Forms
Render Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView Class : Render Method

objContext
Request context.
objWriter
lngRequestID
Renders the current control.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub Render( _
   ByVal objContext As IContext, _
   ByVal objWriter As IResponseWriter, _
   ByVal lngRequestID As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As ListView
Dim objContext As IContext
Dim objWriter As IResponseWriter
Dim lngRequestID As Long

instance.Render(objContext, objWriter, lngRequestID)
C#
protected override void Render(
   IContext objContext,
   IResponseWriter objWriter,
   long lngRequestID
)
Managed Extensions for C++
protected: void Render(
   IContext* objContext,
   IResponseWriter* objWriter,
   long lngRequestID
) override
C++/CLI
protected:
void Render(
   IContext^ objContext,
   IResponseWriter^ objWriter,
   long long lngRequestID
) override

Parameters

objContext
Request context.
objWriter
lngRequestID

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView Class
ListView Members


RenderControls Method

[image]
Gizmox.WebGUI.Forms
RenderControls Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView Class : RenderControls Method

Renders the controls sub tree

Overload List

Overload | Description
RenderControls(IContext,IResponseWriter,Int64) |
RenderControls(IContext,IResponseWriter,Int64,Boolean) | Renders the controls sub tree (Inherited from Control)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView Class
ListView Members


RenderControls(IContext,IResponseWriter,Int64) Method

[image]
Gizmox.WebGUI.Forms
RenderControls(IContext,IResponseWriter,Int64) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView Class > RenderControls Method : RenderControls(IContext,IResponseWriter,Int64) Method

objContext
Request context.
objWriter
The response writer object.
lngRequestID
Request ID.

Syntax

Visual Basic (Declaration)
Protected Overloads Overrides Sub RenderControls( _
   ByVal objContext As IContext, _
   ByVal objWriter As IResponseWriter, _
   ByVal lngRequestID As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As ListView
Dim objContext As IContext
Dim objWriter As IResponseWriter
Dim lngRequestID As Long

instance.RenderControls(objContext, objWriter, lngRequestID)
C#
protected override void RenderControls(
   IContext objContext,
   IResponseWriter objWriter,
   long lngRequestID
)
Managed Extensions for C++
protected: void RenderControls(
   IContext* objContext,
   IResponseWriter* objWriter,
   long lngRequestID
) override
C++/CLI
protected:
void RenderControls(
   IContext^ objContext,
   IResponseWriter^ objWriter,
   long long lngRequestID
) override

Parameters

objContext
Request context.
objWriter
The response writer object.
lngRequestID
Request ID.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView Class
ListView Members
Overload List


RenderSelectionButtons Method

[image]
Gizmox.WebGUI.Forms
RenderSelectionButtons Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView Class : RenderSelectionButtons Method

objContext
objWriter
Renders the list view selection buttons data

Syntax

Visual Basic (Declaration)
Protected Overridable Sub RenderSelectionButtons( _
   ByVal objContext As IContext, _
   ByVal objWriter As IResponseWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As ListView
Dim objContext As IContext
Dim objWriter As IResponseWriter

instance.RenderSelectionButtons(objContext, objWriter)
C#
protected virtual void RenderSelectionButtons(
   IContext objContext,
   IResponseWriter objWriter
)
Managed Extensions for C++
protected: virtual void RenderSelectionButtons(
   IContext* objContext,
   IResponseWriter* objWriter
)
C++/CLI
protected:
virtual void RenderSelectionButtons(
   IContext^ objContext,
   IResponseWriter^ objWriter
)

Parameters

objContext
objWriter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView Class
ListView Members


RenderUpdatedAttributes Method

[image]
Gizmox.WebGUI.Forms
RenderUpdatedAttributes Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView Class : RenderUpdatedAttributes Method

objContext
Request context.
objWriter
lngRequestID

Syntax

Visual Basic (Declaration)
Protected Overrides Sub RenderUpdatedAttributes( _
   ByVal objContext As IContext, _
   ByVal objWriter As IAttributeWriter, _
   ByVal lngRequestID As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As ListView
Dim objContext As IContext
Dim objWriter As IAttributeWriter
Dim lngRequestID As Long

instance.RenderUpdatedAttributes(objContext, objWriter, lngRequestID)
C#
protected override void RenderUpdatedAttributes(
   IContext objContext,
   IAttributeWriter objWriter,
   long lngRequestID
)
Managed Extensions for C++
protected: void RenderUpdatedAttributes(
   IContext* objContext,
   IAttributeWriter* objWriter,
   long lngRequestID
) override
C++/CLI
protected:
void RenderUpdatedAttributes(
   IContext^ objContext,
   IAttributeWriter^ objWriter,
   long long lngRequestID
) override

Parameters

objContext
Request context.
objWriter
lngRequestID

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView Class
ListView Members


Sort Method

[image]
Gizmox.WebGUI.Forms
Sort Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView Class : Sort Method

Sorts this list items.

Syntax

Visual Basic (Declaration)
Public Overridable Sub Sort()
Visual Basic (Usage) Copy Code
Dim instance As ListView

instance.Sort()
C#
public virtual void Sort()
Managed Extensions for C++
public: virtual void Sort();
C++/CLI
public:
virtual void Sort();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView Class
ListView Members


ListView Class Properties

[image]
Gizmox.WebGUI.Forms
ListView Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ListView Class

For a list of all members of this type, see ListView members.

Public Properties

 | Name | Description
Public Property | Activation | Set/Gets the activation type (Not implemented).
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | AutoColumnGeneration | Gets or sets if auto column generation is active when using data binding
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Overridden. Gets a value indicating whether this instance can focus.
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | CheckBoxes | Gets or sets a value indicating whether a check box appears next to each item in the control.
Public Property | CheckedIndices | Gets the checked indices.
Public Property | CheckedItems | Gets the checked items.
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | ColumnResizeStyle | Gets or sets if column auto resizing mode
Public Property | Columns | Gets the collection of columns contained within the listview.
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | CurrentPage | Gets or sets the current page.
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | DataMember | The listview data memeber
Public Property | DataSource | The listview data source
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | FocusedItem | Gets the focused item (Not implemented).
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | FullRowSelect | Gets or sets a value indicating whether full row select is enabled.
Public Property | GridLines |
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | HeaderStyle | Gets or sets the header style.
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | HideSelection |
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | Items | Gets the collection of items contained within the listview.
Public Property | ItemsPerPage |
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | LargeImageList | Gets or sets the ImageList to use when displaying items as large icons in the control.
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | ListViewItemSorter | Gets or sets the list view item sorter.
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MultiSelect | Gets or sets a value indicating whether multiple items can be selected.
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | Scrollable | Gets or sets a value indicating whether a scroll bar is added to the control when there is not enough room to display all items.
Public Property | SelectedIndex | Gets the currently selected item index.
Public Property | SelectedIndices | Gets the selected indices.
Public Property | SelectedItem | Gets the currently selected item index.
Public Property | SelectedItems | Gets the selected items.
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | SmallImageList | Gets or sets the ImageList to use when displaying items as small icons in the control.
Public Property | StateImageList | Gets or sets the ImageList associated with application-defined states in the control.
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Control)
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | TotalItems | Gets or sets the total items.
Public Property | TotalPages | Gets or sets the total pages.
Public Property | UseInternalPaging | Uses internal paging algorithem
Public Property | View | Gets or sets the list view mode.
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | Overridden.
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | Overridden.
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | Overridden.
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

See Also

Reference

ListView Class
Gizmox.WebGUI.Forms Namespace


Activation Property

[image]
Gizmox.WebGUI.Forms
Activation Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView Class : Activation Property

Set/Gets the activation type (Not implemented).

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property Activation As ItemActivation
Visual Basic (Usage) Copy Code
Dim instance As ListView
Dim value As ItemActivation

instance.Activation = value

value = instance.Activation
C#
[DefaultValueAttribute()]
public ItemActivation Activation {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property ItemActivation get_Activation();
public: __property void set_Activation(
   ItemActivation value
);
C++/CLI
[DefaultValueAttribute()]
public:
property ItemActivation Activation {
   ItemActivation get();
   void set (ItemActivationvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView Class
ListView Members


AutoColumnGeneration Property

[image]
Gizmox.WebGUI.Forms
AutoColumnGeneration Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView Class : AutoColumnGeneration Property

Gets or sets if auto column generation is active when using data binding

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<SRCategoryAttribute("Data")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Property AutoColumnGeneration As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ListView
Dim value As Boolean

instance.AutoColumnGeneration = value

value = instance.AutoColumnGeneration
C#
[DefaultValueAttribute()]
[SRCategoryAttribute("Data")]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public bool AutoColumnGeneration {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[SRCategoryAttribute("Data")]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: __property bool get_AutoColumnGeneration();
public: __property void set_AutoColumnGeneration(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
[SRCategoryAttribute("Data")]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
property bool AutoColumnGeneration {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView Class
ListView Members


CanFocus Property

[image]
Gizmox.WebGUI.Forms
CanFocus Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView Class : CanFocus Property

Gets a value indicating whether this instance can focus.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanFocus As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ListView
Dim value As Boolean

value = instance.CanFocus
C#
public override bool CanFocus {get;}
Managed Extensions for C++
public: __property bool get_CanFocus() override;
C++/CLI
public:
property bool CanFocus {
   bool get() override;
}

Return Value

true if this instance can focus; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView Class
ListView Members


CheckBoxes Property

[image]
Gizmox.WebGUI.Forms
CheckBoxes Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView Class : CheckBoxes Property

Gets or sets a value indicating whether a check box appears next to each item in the control.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<BrowsableAttribute(True)>
Public Property CheckBoxes As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ListView
Dim value As Boolean

instance.CheckBoxes = value

value = instance.CheckBoxes
C#
[DefaultValueAttribute()]
[BrowsableAttribute(true)]
public bool CheckBoxes {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[BrowsableAttribute(true)]
public: __property bool get_CheckBoxes();
public: __property void set_CheckBoxes(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
[BrowsableAttribute(true)]
public:
property bool CheckBoxes {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView Class
ListView Members


CheckedIndices Property

[image]
Gizmox.WebGUI.Forms
CheckedIndices Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView Class : CheckedIndices Property

Gets the checked indices.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property CheckedIndices As ArrayList
Visual Basic (Usage) Copy Code
Dim instance As ListView
Dim value As ArrayList

value = instance.CheckedIndices
C#
[BrowsableAttribute(false)]
public ArrayList CheckedIndices {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property ArrayList* get_CheckedIndices();
C++/CLI
[BrowsableAttribute(false)]
public:
property ArrayList^ CheckedIndices {
   ArrayList^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView Class
ListView Members


CheckedItems Property

[image]
Gizmox.WebGUI.Forms
CheckedItems Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView Class : CheckedItems Property

Gets the checked items.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property CheckedItems As ArrayList
Visual Basic (Usage) Copy Code
Dim instance As ListView
Dim value As ArrayList

value = instance.CheckedItems
C#
[BrowsableAttribute(false)]
public ArrayList CheckedItems {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property ArrayList* get_CheckedItems();
C++/CLI
[BrowsableAttribute(false)]
public:
property ArrayList^ CheckedItems {
   ArrayList^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView Class
ListView Members


ColumnResizeStyle Property

[image]
Gizmox.WebGUI.Forms
ColumnResizeStyle Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView Class : ColumnResizeStyle Property

Gets or sets if column auto resizing mode

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<SRCategoryAttribute("Data")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Property ColumnResizeStyle As ColumnHeaderAutoResizeStyle
Visual Basic (Usage) Copy Code
Dim instance As ListView
Dim value As ColumnHeaderAutoResizeStyle

instance.ColumnResizeStyle = value

value = instance.ColumnResizeStyle
C#
[DefaultValueAttribute()]
[SRCategoryAttribute("Data")]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public ColumnHeaderAutoResizeStyle ColumnResizeStyle {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[SRCategoryAttribute("Data")]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: __property ColumnHeaderAutoResizeStyle get_ColumnResizeStyle();
public: __property void set_ColumnResizeStyle(
   ColumnHeaderAutoResizeStyle value
);
C++/CLI
[DefaultValueAttribute()]
[SRCategoryAttribute("Data")]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
property ColumnHeaderAutoResizeStyle ColumnResizeStyle {
   ColumnHeaderAutoResizeStyle get();
   void set (ColumnHeaderAutoResizeStylevalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView Class
ListView Members


Columns Property

[image]
Gizmox.WebGUI.Forms
Columns Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView Class : Columns Property

Gets the collection of columns contained within the listview.

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(True)>
Public ReadOnly Property Columns As ListView.ColumnHeaderCollection
Visual Basic (Usage) Copy Code
Dim instance As ListView
Dim value As ListView.ColumnHeaderCollection

value = instance.Columns
C#
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(true)]
public ListView.ColumnHeaderCollection Columns {get;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(true)]
public: __property ListView.ColumnHeaderCollection* get_Columns();
C++/CLI
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(true)]
public:
property ListView::ColumnHeaderCollection^ Columns {
   ListView::ColumnHeaderCollection^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView Class
ListView Members


CurrentPage Property

[image]
Gizmox.WebGUI.Forms
CurrentPage Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView Class : CurrentPage Property

Gets or sets the current page.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property CurrentPage As Integer
Visual Basic (Usage) Copy Code
Dim instance As ListView
Dim value As Integer

instance.CurrentPage = value

value = instance.CurrentPage
C#
[DefaultValueAttribute()]
public int CurrentPage {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property int get_CurrentPage();
public: __property void set_CurrentPage(
   int value
);
C++/CLI
[DefaultValueAttribute()]
public:
property int CurrentPage {
   int get();
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView Class
ListView Members


DataMember Property

[image]
Gizmox.WebGUI.Forms
DataMember Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView Class : DataMember Property

The listview data memeber

Syntax

Visual Basic (Declaration)
<EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.DataMemberListEditor, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<SRCategoryAttribute("Data")>
<DefaultValueAttribute()>
Public Property DataMember As String
Visual Basic (Usage) Copy Code
Dim instance As ListView
Dim value As String

instance.DataMember = value

value = instance.DataMember
C#
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.DataMemberListEditor, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[SRCategoryAttribute("Data")]
[DefaultValueAttribute()]
public string DataMember {get; set;}
Managed Extensions for C++
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.DataMemberListEditor, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[SRCategoryAttribute("Data")]
[DefaultValueAttribute()]
public: __property string* get_DataMember();
public: __property void set_DataMember(
   string* value
);
C++/CLI
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.DataMemberListEditor, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[SRCategoryAttribute("Data")]
[DefaultValueAttribute()]
public:
property String^ DataMember {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView Class
ListView Members


DataSource Property

[image]
Gizmox.WebGUI.Forms
DataSource Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView Class : DataSource Property

The listview data source

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Data")>
<DefaultValueAttribute()>
<RefreshPropertiesAttribute()>
<AttributeProviderAttribute(TypeName="Gizmox.WebGUI.Forms.Binding+IDataSourceAttributeProvider, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d", PropertyName="")>
Public Property DataSource As Object
Visual Basic (Usage) Copy Code
Dim instance As ListView
Dim value As Object

instance.DataSource = value

value = instance.DataSource
C#
[SRCategoryAttribute("Data")]
[DefaultValueAttribute()]
[RefreshPropertiesAttribute()]
[AttributeProviderAttribute(TypeName="Gizmox.WebGUI.Forms.Binding+IDataSourceAttributeProvider, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d", PropertyName="")]
public object DataSource {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Data")]
[DefaultValueAttribute()]
[RefreshPropertiesAttribute()]
[AttributeProviderAttribute(TypeName="Gizmox.WebGUI.Forms.Binding+IDataSourceAttributeProvider, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d", PropertyName="")]
public: __property Object* get_DataSource();
public: __property void set_DataSource(
   Object* value
);
C++/CLI
[SRCategoryAttribute("Data")]
[DefaultValueAttribute()]
[RefreshPropertiesAttribute()]
[AttributeProviderAttribute(TypeName="Gizmox.WebGUI.Forms.Binding+IDataSourceAttributeProvider, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d", PropertyName="")]
public:
property Object^ DataSource {
   Object^ get();
   void set (Object^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView Class
ListView Members


DefaultBackColor Property

[image]
Gizmox.WebGUI.Forms
DefaultBackColor Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView Class : DefaultBackColor Property

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property DefaultBackColor As Color
Visual Basic (Usage) Copy Code
Dim instance As ListView
Dim value As Color

value = instance.DefaultBackColor
C#
protected override Color DefaultBackColor {get;}
Managed Extensions for C++
protected: __property Color get_DefaultBackColor() override;
C++/CLI
protected:
property Color DefaultBackColor {
   Color get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView Class
ListView Members


DefaultBorderStyle Property

[image]
Gizmox.WebGUI.Forms
DefaultBorderStyle Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView Class : DefaultBorderStyle Property

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property DefaultBorderStyle As BorderStyle
Visual Basic (Usage) Copy Code
Dim instance As ListView
Dim value As BorderStyle

value = instance.DefaultBorderStyle
C#
protected override BorderStyle DefaultBorderStyle {get;}
Managed Extensions for C++
protected: __property BorderStyle get_DefaultBorderStyle() override;
C++/CLI
protected:
property BorderStyle DefaultBorderStyle {
   BorderStyle get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView Class
ListView Members


FocusedItem Property

[image]
Gizmox.WebGUI.Forms
FocusedItem Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView Class : FocusedItem Property

Gets the focused item (Not implemented).

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FocusedItem As ListViewItem
Visual Basic (Usage) Copy Code
Dim instance As ListView
Dim value As ListViewItem

value = instance.FocusedItem
C#
public ListViewItem FocusedItem {get;}
Managed Extensions for C++
public: __property ListViewItem* get_FocusedItem();
C++/CLI
public:
property ListViewItem^ FocusedItem {
   ListViewItem^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView Class
ListView Members


FullRowSelect Property

[image]
Gizmox.WebGUI.Forms
FullRowSelect Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView Class : FullRowSelect Property

Gets or sets a value indicating whether full row select is enabled.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<BrowsableAttribute(True)>
Public Property FullRowSelect As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ListView
Dim value As Boolean

instance.FullRowSelect = value

value = instance.FullRowSelect
C#
[DefaultValueAttribute()]
[BrowsableAttribute(true)]
public bool FullRowSelect {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[BrowsableAttribute(true)]
public: __property bool get_FullRowSelect();
public: __property void set_FullRowSelect(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
[BrowsableAttribute(true)]
public:
property bool FullRowSelect {
   bool get();
   void set (boolvalue);
}

Return Value

true if full row select is enabled; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView Class
ListView Members


GridLines Property

[image]
Gizmox.WebGUI.Forms
GridLines Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView Class : GridLines Property

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<BrowsableAttribute(True)>
Public Property GridLines As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ListView
Dim value As Boolean

instance.GridLines = value

value = instance.GridLines
C#
[DefaultValueAttribute()]
[BrowsableAttribute(true)]
public bool GridLines {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[BrowsableAttribute(true)]
public: __property bool get_GridLines();
public: __property void set_GridLines(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
[BrowsableAttribute(true)]
public:
property bool GridLines {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView Class
ListView Members


HeaderStyle Property

[image]
Gizmox.WebGUI.Forms
HeaderStyle Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView Class : HeaderStyle Property

Gets or sets the header style.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(True)>
<DefaultValueAttribute()>
Public Property HeaderStyle As ColumnHeaderStyle
Visual Basic (Usage) Copy Code
Dim instance As ListView
Dim value As ColumnHeaderStyle

instance.HeaderStyle = value

value = instance.HeaderStyle
C#
[BrowsableAttribute(true)]
[DefaultValueAttribute()]
public ColumnHeaderStyle HeaderStyle {get; set;}
Managed Extensions for C++
[BrowsableAttribute(true)]
[DefaultValueAttribute()]
public: __property ColumnHeaderStyle get_HeaderStyle();
public: __property void set_HeaderStyle(
   ColumnHeaderStyle value
);
C++/CLI
[BrowsableAttribute(true)]
[DefaultValueAttribute()]
public:
property ColumnHeaderStyle HeaderStyle {
   ColumnHeaderStyle get();
   void set (ColumnHeaderStylevalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView Class
ListView Members


HideSelection Property

[image]
Gizmox.WebGUI.Forms
HideSelection Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView Class : HideSelection Property

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(True)>
<DefaultValueAttribute()>
Public Property HideSelection As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ListView
Dim value As Boolean

instance.HideSelection = value

value = instance.HideSelection
C#
[BrowsableAttribute(true)]
[DefaultValueAttribute()]
public bool HideSelection {get; set;}
Managed Extensions for C++
[BrowsableAttribute(true)]
[DefaultValueAttribute()]
public: __property bool get_HideSelection();
public: __property void set_HideSelection(
   bool value
);
C++/CLI
[BrowsableAttribute(true)]
[DefaultValueAttribute()]
public:
property bool HideSelection {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView Class
ListView Members


IsDelayedDrawing Property

[image]
Gizmox.WebGUI.Forms
IsDelayedDrawing Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView Class : IsDelayedDrawing Property

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property IsDelayedDrawing As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ListView
Dim value As Boolean

value = instance.IsDelayedDrawing
C#
protected override bool IsDelayedDrawing {get;}
Managed Extensions for C++
protected: __property bool get_IsDelayedDrawing() override;
C++/CLI
protected:
property bool IsDelayedDrawing {
   bool get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView Class
ListView Members


Items Property

[image]
Gizmox.WebGUI.Forms
Items Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView Class : Items Property

Gets the collection of items contained within the listview.

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
Public ReadOnly Property Items As ListView.ListViewItemCollection
Visual Basic (Usage) Copy Code
Dim instance As ListView
Dim value As ListView.ListViewItemCollection

value = instance.Items
C#
[DesignerSerializationVisibilityAttribute()]
public ListView.ListViewItemCollection Items {get;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
public: __property ListView.ListViewItemCollection* get_Items();
C++/CLI
[DesignerSerializationVisibilityAttribute()]
public:
property ListView::ListViewItemCollection^ Items {
   ListView::ListViewItemCollection^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView Class
ListView Members


ItemsPerPage Property

[image]
Gizmox.WebGUI.Forms
ItemsPerPage Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView Class : ItemsPerPage Property

Syntax

Visual Basic (Declaration)
Public Property ItemsPerPage As Integer
Visual Basic (Usage) Copy Code
Dim instance As ListView
Dim value As Integer

instance.ItemsPerPage = value

value = instance.ItemsPerPage
C#
public int ItemsPerPage {get; set;}
Managed Extensions for C++
public: __property int get_ItemsPerPage();
public: __property void set_ItemsPerPage(
   int value
);
C++/CLI
public:
property int ItemsPerPage {
   int get();
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView Class
ListView Members


LargeImageList Property

[image]
Gizmox.WebGUI.Forms
LargeImageList Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView Class : LargeImageList Property

Gets or sets the ImageList to use when displaying items as large icons in the control.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Behavior")>
<DefaultValueAttribute()>
<SRDescriptionAttribute("The ImageList control used by the ListView for images in Large Icon View.")>
Public Property LargeImageList As ImageList
Visual Basic (Usage) Copy Code
Dim instance As ListView
Dim value As ImageList

instance.LargeImageList = value

value = instance.LargeImageList
C#
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("The ImageList control used by the ListView for images in Large Icon View.")]
public ImageList LargeImageList {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("The ImageList control used by the ListView for images in Large Icon View.")]
public: __property ImageList* get_LargeImageList();
public: __property void set_LargeImageList(
   ImageList* value
);
C++/CLI
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("The ImageList control used by the ListView for images in Large Icon View.")]
public:
property ImageList^ LargeImageList {
   ImageList^ get();
   void set (ImageList^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView Class
ListView Members


ListViewItemSorter Property

[image]
Gizmox.WebGUI.Forms
ListViewItemSorter Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView Class : ListViewItemSorter Property

Gets or sets the list view item sorter.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public Property ListViewItemSorter As IComparer
Visual Basic (Usage) Copy Code
Dim instance As ListView
Dim value As IComparer

instance.ListViewItemSorter = value

value = instance.ListViewItemSorter
C#
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public IComparer ListViewItemSorter {get; set;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property IComparer* get_ListViewItemSorter();
public: __property void set_ListViewItemSorter(
   IComparer* value
);
C++/CLI
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
property IComparer^ ListViewItemSorter {
   IComparer^ get();
   void set (IComparer^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView Class
ListView Members


MultiSelect Property

[image]
Gizmox.WebGUI.Forms
MultiSelect Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView Class : MultiSelect Property

Gets or sets a value indicating whether multiple items can be selected.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<BrowsableAttribute(True)>
Public Property MultiSelect As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ListView
Dim value As Boolean

instance.MultiSelect = value

value = instance.MultiSelect
C#
[DefaultValueAttribute()]
[BrowsableAttribute(true)]
public bool MultiSelect {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[BrowsableAttribute(true)]
public: __property bool get_MultiSelect();
public: __property void set_MultiSelect(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
[BrowsableAttribute(true)]
public:
property bool MultiSelect {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView Class
ListView Members


Scrollable Property

[image]
Gizmox.WebGUI.Forms
Scrollable Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView Class : Scrollable Property

Gets or sets a value indicating whether a scroll bar is added to the control when there is not enough room to display all items.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<SRCategoryAttribute("Behavior")>
<SRDescriptionAttribute("Indicates whether the control will display scroll bars if it contains more items than can fit in the client area.")>
Public Property Scrollable As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ListView
Dim value As Boolean

instance.Scrollable = value

value = instance.Scrollable
C#
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Indicates whether the control will display scroll bars if it contains more items than can fit in the client area.")]
public bool Scrollable {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Indicates whether the control will display scroll bars if it contains more items than can fit in the client area.")]
public: __property bool get_Scrollable();
public: __property void set_Scrollable(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Indicates whether the control will display scroll bars if it contains more items than can fit in the client area.")]
public:
property bool Scrollable {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView Class
ListView Members


SelectedIndex Property

[image]
Gizmox.WebGUI.Forms
SelectedIndex Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView Class : SelectedIndex Property

Gets the currently selected item index.

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
Public Property SelectedIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As ListView
Dim value As Integer

instance.SelectedIndex = value

value = instance.SelectedIndex
C#
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public int SelectedIndex {get; set;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public: __property int get_SelectedIndex();
public: __property void set_SelectedIndex(
   int value
);
C++/CLI
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public:
property int SelectedIndex {
   int get();
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView Class
ListView Members


SelectedIndices Property

[image]
Gizmox.WebGUI.Forms
SelectedIndices Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView Class : SelectedIndices Property

Gets the selected indices.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property SelectedIndices As ArrayList
Visual Basic (Usage) Copy Code
Dim instance As ListView
Dim value As ArrayList

value = instance.SelectedIndices
C#
[BrowsableAttribute(false)]
public ArrayList SelectedIndices {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property ArrayList* get_SelectedIndices();
C++/CLI
[BrowsableAttribute(false)]
public:
property ArrayList^ SelectedIndices {
   ArrayList^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView Class
ListView Members


SelectedItem Property

[image]
Gizmox.WebGUI.Forms
SelectedItem Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView Class : SelectedItem Property

Gets the currently selected item index.

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
Public Property SelectedItem As ListViewItem
Visual Basic (Usage) Copy Code
Dim instance As ListView
Dim value As ListViewItem

instance.SelectedItem = value

value = instance.SelectedItem
C#
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public ListViewItem SelectedItem {get; set;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public: __property ListViewItem* get_SelectedItem();
public: __property void set_SelectedItem(
   ListViewItem* value
);
C++/CLI
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public:
property ListViewItem^ SelectedItem {
   ListViewItem^ get();
   void set (ListViewItem^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView Class
ListView Members


SelectedItems Property

[image]
Gizmox.WebGUI.Forms
SelectedItems Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView Class : SelectedItems Property

Gets the selected items.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property SelectedItems As ListView.SelectedListViewItemCollection
Visual Basic (Usage) Copy Code
Dim instance As ListView
Dim value As ListView.SelectedListViewItemCollection

value = instance.SelectedItems
C#
[BrowsableAttribute(false)]
public ListView.SelectedListViewItemCollection SelectedItems {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property ListView.SelectedListViewItemCollection* get_SelectedItems();
C++/CLI
[BrowsableAttribute(false)]
public:
property ListView::SelectedListViewItemCollection^ SelectedItems {
   ListView::SelectedListViewItemCollection^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView Class
ListView Members


SmallImageList Property

[image]
Gizmox.WebGUI.Forms
SmallImageList Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView Class : SmallImageList Property

Gets or sets the ImageList to use when displaying items as small icons in the control.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<SRCategoryAttribute("Behavior")>
<SRDescriptionAttribute("The ImageList control used by the ListView for images in all views except for the large icon view.")>
Public Property SmallImageList As ImageList
Visual Basic (Usage) Copy Code
Dim instance As ListView
Dim value As ImageList

instance.SmallImageList = value

value = instance.SmallImageList
C#
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("The ImageList control used by the ListView for images in all views except for the large icon view.")]
public ImageList SmallImageList {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("The ImageList control used by the ListView for images in all views except for the large icon view.")]
public: __property ImageList* get_SmallImageList();
public: __property void set_SmallImageList(
   ImageList* value
);
C++/CLI
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("The ImageList control used by the ListView for images in all views except for the large icon view.")]
public:
property ImageList^ SmallImageList {
   ImageList^ get();
   void set (ImageList^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView Class
ListView Members


StateImageList Property

[image]
Gizmox.WebGUI.Forms
StateImageList Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView Class : StateImageList Property

Gets or sets the ImageList associated with application-defined states in the control.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<SRCategoryAttribute("Behavior")>
<SRDescriptionAttribute("The ImageList control used by the ListView for custom states.")>
Public Property StateImageList As ImageList
Visual Basic (Usage) Copy Code
Dim instance As ListView
Dim value As ImageList

instance.StateImageList = value

value = instance.StateImageList
C#
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("The ImageList control used by the ListView for custom states.")]
public ImageList StateImageList {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("The ImageList control used by the ListView for custom states.")]
public: __property ImageList* get_StateImageList();
public: __property void set_StateImageList(
   ImageList* value
);
C++/CLI
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("The ImageList control used by the ListView for custom states.")]
public:
property ImageList^ StateImageList {
   ImageList^ get();
   void set (ImageList^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView Class
ListView Members


TotalItems Property

[image]
Gizmox.WebGUI.Forms
TotalItems Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView Class : TotalItems Property

Gets or sets the total items.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property TotalItems As Integer
Visual Basic (Usage) Copy Code
Dim instance As ListView
Dim value As Integer

instance.TotalItems = value

value = instance.TotalItems
C#
[DefaultValueAttribute()]
public int TotalItems {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property int get_TotalItems();
public: __property void set_TotalItems(
   int value
);
C++/CLI
[DefaultValueAttribute()]
public:
property int TotalItems {
   int get();
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView Class
ListView Members


TotalPages Property

[image]
Gizmox.WebGUI.Forms
TotalPages Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView Class : TotalPages Property

Gets or sets the total pages.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property TotalPages As Integer
Visual Basic (Usage) Copy Code
Dim instance As ListView
Dim value As Integer

instance.TotalPages = value

value = instance.TotalPages
C#
[DefaultValueAttribute()]
public int TotalPages {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property int get_TotalPages();
public: __property void set_TotalPages(
   int value
);
C++/CLI
[DefaultValueAttribute()]
public:
property int TotalPages {
   int get();
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView Class
ListView Members


UseInternalPaging Property

[image]
Gizmox.WebGUI.Forms
UseInternalPaging Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView Class : UseInternalPaging Property

Uses internal paging algorithem

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property UseInternalPaging As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ListView
Dim value As Boolean

instance.UseInternalPaging = value

value = instance.UseInternalPaging
C#
[DefaultValueAttribute()]
public bool UseInternalPaging {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property bool get_UseInternalPaging();
public: __property void set_UseInternalPaging(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
public:
property bool UseInternalPaging {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView Class
ListView Members


View Property

[image]
Gizmox.WebGUI.Forms
View Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView Class : View Property

Gets or sets the list view mode.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(True)>
<DefaultValueAttribute()>
Public Property View As View
Visual Basic (Usage) Copy Code
Dim instance As ListView
Dim value As View

instance.View = value

value = instance.View
C#
[BrowsableAttribute(true)]
[DefaultValueAttribute()]
public View View {get; set;}
Managed Extensions for C++
[BrowsableAttribute(true)]
[DefaultValueAttribute()]
public: __property View get_View();
public: __property void set_View(
   View value
);
C++/CLI
[BrowsableAttribute(true)]
[DefaultValueAttribute()]
public:
property View View {
   View get();
   void set (Viewvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView Class
ListView Members


ListView Class Events

[image]
Gizmox.WebGUI.Forms
ListView Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ListView Class

For a list of all members of this type, see ListView members.

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ColumnClick |
Public Event | ColumnUpdate | Columns where updated by the user
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | ItemActivate | Occurs when an item is activated.
Public Event | ItemCheck | Occurs when the checked state of an item changes.
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | PagingChanged | Occurs when the paging params have changed.
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | SelectedIndexChanged | Occurs when the SelectedIndex property has changed.
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

ListView Class
Gizmox.WebGUI.Forms Namespace


ColumnClick Event

[image]
Gizmox.WebGUI.Forms
ColumnClick Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView Class : ColumnClick Event

Syntax

Visual Basic (Declaration)
Public Event ColumnClick() As ColumnClickEventHandler
Visual Basic (Usage) Copy Code
Dim instance As ListView
Dim handler As ColumnClickEventHandler

AddHandler instance.ColumnClick, handler
C#
public event ColumnClickEventHandler ColumnClick()
Managed Extensions for C++
public: __event ColumnClickEventHandler* ColumnClick
C++/CLI
public:
event ColumnClickEventHandler^ ColumnClick

Event Data

The event handler receives an argument of type ColumnClickEventArgs containing data related to this event. The following ColumnClickEventArgs properties provide information specific to this event.

Property | Description
Column |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView Class
ListView Members


ColumnUpdate Event

[image]
Gizmox.WebGUI.Forms
ColumnUpdate Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView Class : ColumnUpdate Event

Columns where updated by the user

Syntax

Visual Basic (Declaration)
Public Event ColumnUpdate() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As ListView
Dim handler As EventHandler

AddHandler instance.ColumnUpdate, handler
C#
public event EventHandler ColumnUpdate()
Managed Extensions for C++
public: __event EventHandler* ColumnUpdate
C++/CLI
public:
event EventHandler^ ColumnUpdate

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView Class
ListView Members


ItemActivate Event

[image]
Gizmox.WebGUI.Forms
ItemActivate Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView Class : ItemActivate Event

Occurs when an item is activated.

Syntax

Visual Basic (Declaration)
Public Event ItemActivate() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As ListView
Dim handler As EventHandler

AddHandler instance.ItemActivate, handler
C#
public event EventHandler ItemActivate()
Managed Extensions for C++
public: __event EventHandler* ItemActivate
C++/CLI
public:
event EventHandler^ ItemActivate

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView Class
ListView Members


ItemCheck Event

[image]
Gizmox.WebGUI.Forms
ItemCheck Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView Class : ItemCheck Event

Occurs when the checked state of an item changes.

Syntax

Visual Basic (Declaration)
Public Event ItemCheck() As ItemCheckHandler
Visual Basic (Usage) Copy Code
Dim instance As ListView
Dim handler As ItemCheckHandler

AddHandler instance.ItemCheck, handler
C#
public event ItemCheckHandler ItemCheck()
Managed Extensions for C++
public: __event ItemCheckHandler* ItemCheck
C++/CLI
public:
event ItemCheckHandler^ ItemCheck

Event Data

The event handler receives an argument of type ItemCheckEventArgs containing data related to this event. The following ItemCheckEventArgs properties provide information specific to this event.

Property | Description
CurrentValue | Gets the current value.
Index | Gets the index.
NewValue | Gets or sets the new value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView Class
ListView Members


PagingChanged Event

[image]
Gizmox.WebGUI.Forms
PagingChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView Class : PagingChanged Event

Occurs when the paging params have changed.

Syntax

Visual Basic (Declaration)
Public Event PagingChanged() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As ListView
Dim handler As EventHandler

AddHandler instance.PagingChanged, handler
C#
public event EventHandler PagingChanged()
Managed Extensions for C++
public: __event EventHandler* PagingChanged
C++/CLI
public:
event EventHandler^ PagingChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView Class
ListView Members


SelectedIndexChanged Event

[image]
Gizmox.WebGUI.Forms
SelectedIndexChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView Class : SelectedIndexChanged Event

Occurs when the SelectedIndex property has changed.

Syntax

Visual Basic (Declaration)
Public Event SelectedIndexChanged() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As ListView
Dim handler As EventHandler

AddHandler instance.SelectedIndexChanged, handler
C#
public event EventHandler SelectedIndexChanged()
Managed Extensions for C++
public: __event EventHandler* SelectedIndexChanged
C++/CLI
public:
event EventHandler^ SelectedIndexChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView Class
ListView Members


ListView.ColumnHeaderCollection Class

[image]
Gizmox.WebGUI.Forms
ListView.ColumnHeaderCollection Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ListView.ColumnHeaderCollection Class

Represents the collection of column headers in a ListView control.

Object Model

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class ListView.ColumnHeaderCollection
   Implements IObservableList
Visual Basic (Usage) Copy Code
Dim instance As ListView.ColumnHeaderCollection
C#
[DefaultMemberAttribute("Item")]
public class ListView.ColumnHeaderCollection : IObservableList
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
public __gc class ListView.ColumnHeaderCollection : public IObservableList
C++/CLI
[DefaultMemberAttribute("Item")]
public ref class ListView.ColumnHeaderCollection : public IObservableList

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ListView.ColumnHeaderCollection

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

ListView.ColumnHeaderCollection Members
Gizmox.WebGUI.Forms Namespace


ListView.ColumnHeaderCollection Class Members

[image]
Gizmox.WebGUI.Forms
ListView.ColumnHeaderCollection Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : ListView.ColumnHeaderCollection Class

The following tables list the members exposed by ListView.ColumnHeaderCollection.

Public Constructors

 | Name | Description
Public Constructor | ListView.ColumnHeaderCollection Constructor | Creates a new ListView.ColumnHeaderCollection instance.
Top

Public Properties

 | Name | Description
Public Property | Count | Gets the count.
Public Property | IsFixedSize |
Public Property | IsReadOnly |
Public Property | IsSynchronized | Gets a value indicating whether this instance is synchronized.
Public Property | Item | Gets the ColumnHeader with the specified int index.
Public Property | SortedColumns | Gets the position sorted column list.
Public Property | SyncRoot | Gets the sync root.
Public Property | VisibleColumns | Gets the visible columns.
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Adds the specified list view column.
Public Method | AddRange | Adds the range.
Public Method | Clear | Clears this instance.
Public Method | Contains |
Public Method | CopyTo | Copies to.
Public Method | GetEnumerator | Gets the enumerator.
Public Method | IndexOf |
Public Method | Insert |
Public Method | Remove | Removes the specified list view column.
Public Method | RemoveAt |
Public Method | UpdateColumns | Updates the listview columns.
Top

See Also

Reference

ListView.ColumnHeaderCollection Class
Gizmox.WebGUI.Forms Namespace


ListView.ColumnHeaderCollection Constructor

[image]
Gizmox.WebGUI.Forms
ListView.ColumnHeaderCollection Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView.ColumnHeaderCollection Class : ListView.ColumnHeaderCollection Constructor

objListView
Creates a new ListView.ColumnHeaderCollection instance.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal objListView As ListView _
)
Visual Basic (Usage) Copy Code
Dim objListView As ListView

Dim instance As ListView.ColumnHeaderCollection(objListView)
C#
public ListView.ColumnHeaderCollection(
   ListView objListView
)
Managed Extensions for C++
public: ListView.ColumnHeaderCollection(
   ListView* objListView
)
C++/CLI
public:
ListView.ColumnHeaderCollection(
   ListView^ objListView
)

Parameters

objListView

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView.ColumnHeaderCollection Class
ListView.ColumnHeaderCollection Members


ListView.ColumnHeaderCollection Class Methods

[image]
Gizmox.WebGUI.Forms
ListView.ColumnHeaderCollection Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ListView.ColumnHeaderCollection Class

For a list of all members of this type, see ListView.ColumnHeaderCollection members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Adds the specified list view column.
Public Method | AddRange | Adds the range.
Public Method | Clear | Clears this instance.
Public Method | Contains |
Public Method | CopyTo | Copies to.
Public Method | GetEnumerator | Gets the enumerator.
Public Method | IndexOf |
Public Method | Insert |
Public Method | Remove | Removes the specified list view column.
Public Method | RemoveAt |
Public Method | UpdateColumns | Updates the listview columns.
Top

See Also

Reference

ListView.ColumnHeaderCollection Class
Gizmox.WebGUI.Forms Namespace


Add Method

[image]
Gizmox.WebGUI.Forms
Add Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView.ColumnHeaderCollection Class : Add Method

Adds the specified list view column.

Overload List

Overload | Description
Add(ColumnHeader) | Adds the specified list view column.
Add(String,Int32,HorizontalAlignment) | Creates and adds a new list view column.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView.ColumnHeaderCollection Class
ListView.ColumnHeaderCollection Members


Add(ColumnHeader) Method

[image]
Gizmox.WebGUI.Forms
Add(ColumnHeader) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView.ColumnHeaderCollection Class > Add Method : Add(ColumnHeader) Method

objListViewColumn
Obj list view column.
Adds the specified list view column.

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal objListViewColumn As ColumnHeader _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As ListView.ColumnHeaderCollection
Dim objListViewColumn As ColumnHeader
Dim value As Integer

value = instance.Add(objListViewColumn)
C#
public int Add(
   ColumnHeader objListViewColumn
)
Managed Extensions for C++
public: int Add(
   ColumnHeader* objListViewColumn
)
C++/CLI
public:
int Add(
   ColumnHeader^ objListViewColumn
)

Parameters

objListViewColumn
Obj list view column.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView.ColumnHeaderCollection Class
ListView.ColumnHeaderCollection Members
Overload List


Add(String,Int32,HorizontalAlignment) Method

[image]
Gizmox.WebGUI.Forms
Add(String,Int32,HorizontalAlignment) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView.ColumnHeaderCollection Class > Add Method : Add(String,Int32,HorizontalAlignment) Method

strLabel
Label.
intWidth
Width.
textAlign
Text align.
Creates and adds a new list view column.

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal strLabel As String, _
   ByVal intWidth As Integer, _
   ByVal textAlign As HorizontalAlignment _
) As ColumnHeader
Visual Basic (Usage) Copy Code
Dim instance As ListView.ColumnHeaderCollection
Dim strLabel As String
Dim intWidth As Integer
Dim textAlign As HorizontalAlignment
Dim value As ColumnHeader

value = instance.Add(strLabel, intWidth, textAlign)
C#
public ColumnHeader Add(
   string strLabel,
   int intWidth,
   HorizontalAlignment textAlign
)
Managed Extensions for C++
public: ColumnHeader* Add(
   string* strLabel,
   int intWidth,
   HorizontalAlignment textAlign
)
C++/CLI
public:
ColumnHeader^ Add(
   String^ strLabel,
   int intWidth,
   HorizontalAlignment textAlign
)

Parameters

strLabel
Label.
intWidth
Width.
textAlign
Text align.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView.ColumnHeaderCollection Class
ListView.ColumnHeaderCollection Members
Overload List


AddRange Method

[image]
Gizmox.WebGUI.Forms
AddRange Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView.ColumnHeaderCollection Class : AddRange Method

objColumnHeaders
Obj column headers.
Adds the range.

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddRange( _
   ByVal objColumnHeaders() As ColumnHeader _
)
Visual Basic (Usage) Copy Code
Dim instance As ListView.ColumnHeaderCollection
Dim objColumnHeaders() As ColumnHeader

instance.AddRange(objColumnHeaders)
C#
public virtual void AddRange(
   ColumnHeader[] objColumnHeaders
)
Managed Extensions for C++
public: virtual void AddRange(
   ColumnHeader*[]* objColumnHeaders
)
C++/CLI
public:
virtual void AddRange(
   array<ColumnHeader^>^ objColumnHeaders
)

Parameters

objColumnHeaders
Obj column headers.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView.ColumnHeaderCollection Class
ListView.ColumnHeaderCollection Members


Clear Method

[image]
Gizmox.WebGUI.Forms
Clear Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView.ColumnHeaderCollection Class : Clear Method

Clears this instance.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As ListView.ColumnHeaderCollection

instance.Clear()
C#
public void Clear()
Managed Extensions for C++
public: void Clear();
C++/CLI
public:
void Clear();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView.ColumnHeaderCollection Class
ListView.ColumnHeaderCollection Members


Contains Method

[image]
Gizmox.WebGUI.Forms
Contains Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView.ColumnHeaderCollection Class : Contains Method

value

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal value As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ListView.ColumnHeaderCollection
Dim value As Object
Dim value As Boolean

value = instance.Contains(value)
C#
public bool Contains(
   object value
)
Managed Extensions for C++
public: bool Contains(
   Object* value
)
C++/CLI
public:
bool Contains(
   Object^ value
)

Parameters

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView.ColumnHeaderCollection Class
ListView.ColumnHeaderCollection Members


CopyTo Method

[image]
Gizmox.WebGUI.Forms
CopyTo Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView.ColumnHeaderCollection Class : CopyTo Method

array
Array.
index
Index.
Copies to.

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array As Array, _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As ListView.ColumnHeaderCollection
Dim array As Array
Dim index As Integer

instance.CopyTo(array, index)
C#
public void CopyTo(
   Array array,
   int index
)
Managed Extensions for C++
public: void CopyTo(
   Array* array,
   int index
)
C++/CLI
public:
void CopyTo(
   Array^ array,
   int index
)

Parameters

array
Array.
index
Index.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView.ColumnHeaderCollection Class
ListView.ColumnHeaderCollection Members


GetEnumerator Method

[image]
Gizmox.WebGUI.Forms
GetEnumerator Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView.ColumnHeaderCollection Class : GetEnumerator Method

Gets the enumerator.

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As ListView.ColumnHeaderCollection
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView.ColumnHeaderCollection Class
ListView.ColumnHeaderCollection Members


IndexOf Method

[image]
Gizmox.WebGUI.Forms
IndexOf Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView.ColumnHeaderCollection Class : IndexOf Method

value

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal value As Object _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As ListView.ColumnHeaderCollection
Dim value As Object
Dim value As Integer

value = instance.IndexOf(value)
C#
public int IndexOf(
   object value
)
Managed Extensions for C++
public: int IndexOf(
   Object* value
)
C++/CLI
public:
int IndexOf(
   Object^ value
)

Parameters

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView.ColumnHeaderCollection Class
ListView.ColumnHeaderCollection Members


Insert Method

[image]
Gizmox.WebGUI.Forms
Insert Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView.ColumnHeaderCollection Class : Insert Method

index
value

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal value As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ListView.ColumnHeaderCollection
Dim index As Integer
Dim value As Object

instance.Insert(index, value)
C#
public void Insert(
   int index,
   object value
)
Managed Extensions for C++
public: void Insert(
   int index,
   Object* value
)
C++/CLI
public:
void Insert(
   int index,
   Object^ value
)

Parameters

index
value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView.ColumnHeaderCollection Class
ListView.ColumnHeaderCollection Members


Remove Method

[image]
Gizmox.WebGUI.Forms
Remove Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView.ColumnHeaderCollection Class : Remove Method

objListViewColumn
list view column.
Removes the specified list view column.

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal objListViewColumn As ColumnHeader _
)
Visual Basic (Usage) Copy Code
Dim instance As ListView.ColumnHeaderCollection
Dim objListViewColumn As ColumnHeader

instance.Remove(objListViewColumn)
C#
public void Remove(
   ColumnHeader objListViewColumn
)
Managed Extensions for C++
public: void Remove(
   ColumnHeader* objListViewColumn
)
C++/CLI
public:
void Remove(
   ColumnHeader^ objListViewColumn
)

Parameters

objListViewColumn
list view column.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView.ColumnHeaderCollection Class
ListView.ColumnHeaderCollection Members


RemoveAt Method

[image]
Gizmox.WebGUI.Forms
RemoveAt Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView.ColumnHeaderCollection Class : RemoveAt Method

index

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As ListView.ColumnHeaderCollection
Dim index As Integer

instance.RemoveAt(index)
C#
public void RemoveAt(
   int index
)
Managed Extensions for C++
public: void RemoveAt(
   int index
)
C++/CLI
public:
void RemoveAt(
   int index
)

Parameters

index

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView.ColumnHeaderCollection Class
ListView.ColumnHeaderCollection Members


UpdateColumns Method

[image]
Gizmox.WebGUI.Forms
UpdateColumns Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView.ColumnHeaderCollection Class : UpdateColumns Method

Updates the listview columns.

Syntax

Visual Basic (Declaration)
Public Sub UpdateColumns()
Visual Basic (Usage) Copy Code
Dim instance As ListView.ColumnHeaderCollection

instance.UpdateColumns()
C#
public void UpdateColumns()
Managed Extensions for C++
public: void UpdateColumns();
C++/CLI
public:
void UpdateColumns();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView.ColumnHeaderCollection Class
ListView.ColumnHeaderCollection Members


ListView.ColumnHeaderCollection Class Properties

[image]
Gizmox.WebGUI.Forms
ListView.ColumnHeaderCollection Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ListView.ColumnHeaderCollection Class

For a list of all members of this type, see ListView.ColumnHeaderCollection members.

Public Properties

 | Name | Description
Public Property | Count | Gets the count.
Public Property | IsFixedSize |
Public Property | IsReadOnly |
Public Property | IsSynchronized | Gets a value indicating whether this instance is synchronized.
Public Property | Item | Gets the ColumnHeader with the specified int index.
Public Property | SortedColumns | Gets the position sorted column list.
Public Property | SyncRoot | Gets the sync root.
Public Property | VisibleColumns | Gets the visible columns.
Top

See Also

Reference

ListView.ColumnHeaderCollection Class
Gizmox.WebGUI.Forms Namespace


Count Property

[image]
Gizmox.WebGUI.Forms
Count Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView.ColumnHeaderCollection Class : Count Property

Gets the count.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As ListView.ColumnHeaderCollection
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView.ColumnHeaderCollection Class
ListView.ColumnHeaderCollection Members


IsFixedSize Property

[image]
Gizmox.WebGUI.Forms
IsFixedSize Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView.ColumnHeaderCollection Class : IsFixedSize Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsFixedSize As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ListView.ColumnHeaderCollection
Dim value As Boolean

value = instance.IsFixedSize
C#
public bool IsFixedSize {get;}
Managed Extensions for C++
public: __property bool get_IsFixedSize();
C++/CLI
public:
property bool IsFixedSize {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView.ColumnHeaderCollection Class
ListView.ColumnHeaderCollection Members


IsReadOnly Property

[image]
Gizmox.WebGUI.Forms
IsReadOnly Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView.ColumnHeaderCollection Class : IsReadOnly Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsReadOnly As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ListView.ColumnHeaderCollection
Dim value As Boolean

value = instance.IsReadOnly
C#
public bool IsReadOnly {get;}
Managed Extensions for C++
public: __property bool get_IsReadOnly();
C++/CLI
public:
property bool IsReadOnly {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView.ColumnHeaderCollection Class
ListView.ColumnHeaderCollection Members


IsSynchronized Property

[image]
Gizmox.WebGUI.Forms
IsSynchronized Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView.ColumnHeaderCollection Class : IsSynchronized Property

Gets a value indicating whether this instance is synchronized.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsSynchronized As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ListView.ColumnHeaderCollection
Dim value As Boolean

value = instance.IsSynchronized
C#
public bool IsSynchronized {get;}
Managed Extensions for C++
public: __property bool get_IsSynchronized();
C++/CLI
public:
property bool IsSynchronized {
   bool get();
}

Return Value

true if this instance is synchronized; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView.ColumnHeaderCollection Class
ListView.ColumnHeaderCollection Members


Item Property

[image]
Gizmox.WebGUI.Forms
Item Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView.ColumnHeaderCollection Class : Item Property

intIndex
Gets the ColumnHeader with the specified int index.

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal intIndex As Integer _
) As ColumnHeader
Visual Basic (Usage) Copy Code
Dim instance As ListView.ColumnHeaderCollection
Dim intIndex As Integer
Dim value As ColumnHeader

value = instance.Item(intIndex)
C#
public ColumnHeader this[
   int intIndex
]; {get;}
Managed Extensions for C++
public: __property ColumnHeader* get_Item(
   int intIndex
);
C++/CLI
public:
property ColumnHeader^ default [int] {
   ColumnHeader^ get(intintIndex);
}

Parameters

intIndex

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView.ColumnHeaderCollection Class
ListView.ColumnHeaderCollection Members


SortedColumns Property

[image]
Gizmox.WebGUI.Forms
SortedColumns Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView.ColumnHeaderCollection Class : SortedColumns Property

Gets the position sorted column list.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SortedColumns As ICollection
Visual Basic (Usage) Copy Code
Dim instance As ListView.ColumnHeaderCollection
Dim value As ICollection

value = instance.SortedColumns
C#
public ICollection SortedColumns {get;}
Managed Extensions for C++
public: __property ICollection* get_SortedColumns();
C++/CLI
public:
property ICollection^ SortedColumns {
   ICollection^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView.ColumnHeaderCollection Class
ListView.ColumnHeaderCollection Members


SyncRoot Property

[image]
Gizmox.WebGUI.Forms
SyncRoot Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView.ColumnHeaderCollection Class : SyncRoot Property

Gets the sync root.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SyncRoot As Object
Visual Basic (Usage) Copy Code
Dim instance As ListView.ColumnHeaderCollection
Dim value As Object

value = instance.SyncRoot
C#
public object SyncRoot {get;}
Managed Extensions for C++
public: __property Object* get_SyncRoot();
C++/CLI
public:
property Object^ SyncRoot {
   Object^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView.ColumnHeaderCollection Class
ListView.ColumnHeaderCollection Members


VisibleColumns Property

[image]
Gizmox.WebGUI.Forms
VisibleColumns Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView.ColumnHeaderCollection Class : VisibleColumns Property

Gets the visible columns.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property VisibleColumns As ICollection
Visual Basic (Usage) Copy Code
Dim instance As ListView.ColumnHeaderCollection
Dim value As ICollection

value = instance.VisibleColumns
C#
public ICollection VisibleColumns {get;}
Managed Extensions for C++
public: __property ICollection* get_VisibleColumns();
C++/CLI
public:
property ICollection^ VisibleColumns {
   ICollection^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView.ColumnHeaderCollection Class
ListView.ColumnHeaderCollection Members


ListView.ListViewItemCollection Class

[image]
Gizmox.WebGUI.Forms
ListView.ListViewItemCollection Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ListView.ListViewItemCollection Class

Represents the collection of items in a ListView control.

Object Model

Syntax

Visual Basic (Declaration)
<ClientControllerAttribute()>
<DesignTimeControllerAttribute()>
<BrowsableAttribute(True)>
<EditorBrowsableAttribute()>
<DefaultMemberAttribute("Item")>
Public Class ListView.ListViewItemCollection
   Implements IObservableList
Visual Basic (Usage) Copy Code
Dim instance As ListView.ListViewItemCollection
C#
[ClientControllerAttribute()]
[DesignTimeControllerAttribute()]
[BrowsableAttribute(true)]
[EditorBrowsableAttribute()]
[DefaultMemberAttribute("Item")]
public class ListView.ListViewItemCollection : IObservableList
Managed Extensions for C++
[ClientControllerAttribute()]
[DesignTimeControllerAttribute()]
[BrowsableAttribute(true)]
[EditorBrowsableAttribute()]
[DefaultMemberAttribute("Item")]
public __gc class ListView.ListViewItemCollection : public IObservableList
C++/CLI
[ClientControllerAttribute()]
[DesignTimeControllerAttribute()]
[BrowsableAttribute(true)]
[EditorBrowsableAttribute()]
[DefaultMemberAttribute("Item")]
public ref class ListView.ListViewItemCollection : public IObservableList

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ListView.ListViewItemCollection

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

ListView.ListViewItemCollection Members
Gizmox.WebGUI.Forms Namespace


ListView.ListViewItemCollection Class Members

[image]
Gizmox.WebGUI.Forms
ListView.ListViewItemCollection Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : ListView.ListViewItemCollection Class

The following tables list the members exposed by ListView.ListViewItemCollection.

Public Constructors

 | Name | Description
Public Constructor | ListView.ListViewItemCollection Constructor | Creates a new ListViewColumnCollection instance.
Top

Public Properties

 | Name | Description
Public Property | Count | Gets the count.
Public Property | IsFixedSize |
Public Property | IsReadOnly |
Public Property | IsSynchronized | Gets a value indicating whether this instance is synchronized.
Public Property | Item | Gets the ListViewItem at the specified int index.
Public Property | SyncRoot | Gets the sync root.
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Adds the specified STR text.
Public Method | AddRange | Adds an array of ListViewItem objects to the collection.
Public Method | Clear | Clears this list items.
Public Method | Contains |
Public Method | CopyTo | Copies to an array.
Public Method | GetEnumerator | Gets an enumerator.
Public Method | IndexOf | Overloaded. Get the index the of the specified list view item.
Public Method | Insert | Overloaded. Creates a new item and inserts it into the collection at the specified index.
Public Method | Remove | Removes the specified list view item.
Public Method | RemoveAt |
Top

Public Events

 | Name | Description
Public Event | ObservableItemAdded |
Public Event | ObservableItemInserted |
Public Event | ObservableItemRemoved |
Public Event | ObservableListCleared |
Top

See Also

Reference

ListView.ListViewItemCollection Class
Gizmox.WebGUI.Forms Namespace


ListView.ListViewItemCollection Constructor

[image]
Gizmox.WebGUI.Forms
ListView.ListViewItemCollection Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView.ListViewItemCollection Class : ListView.ListViewItemCollection Constructor

objListView
Creates a new ListViewColumnCollection instance.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal objListView As ListView _
)
Visual Basic (Usage) Copy Code
Dim objListView As ListView

Dim instance As ListView.ListViewItemCollection(objListView)
C#
public ListView.ListViewItemCollection(
   ListView objListView
)
Managed Extensions for C++
public: ListView.ListViewItemCollection(
   ListView* objListView
)
C++/CLI
public:
ListView.ListViewItemCollection(
   ListView^ objListView
)

Parameters

objListView

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView.ListViewItemCollection Class
ListView.ListViewItemCollection Members


ListView.ListViewItemCollection Class Methods

[image]
Gizmox.WebGUI.Forms
ListView.ListViewItemCollection Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ListView.ListViewItemCollection Class

For a list of all members of this type, see ListView.ListViewItemCollection members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Adds the specified STR text.
Public Method | AddRange | Adds an array of ListViewItem objects to the collection.
Public Method | Clear | Clears this list items.
Public Method | Contains |
Public Method | CopyTo | Copies to an array.
Public Method | GetEnumerator | Gets an enumerator.
Public Method | IndexOf | Overloaded. Get the index the of the specified list view item.
Public Method | Insert | Overloaded. Creates a new item and inserts it into the collection at the specified index.
Public Method | Remove | Removes the specified list view item.
Public Method | RemoveAt |
Top

See Also

Reference

ListView.ListViewItemCollection Class
Gizmox.WebGUI.Forms Namespace


Add Method

[image]
Gizmox.WebGUI.Forms
Add Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView.ListViewItemCollection Class : Add Method

Adds the specified STR text.

Overload List

Overload | Description
Add(String) | Adds the specified STR text.
Add(ListViewItem) | Adds the specified obj list view item.
Add(String,Int32) | Adds the specified text.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView.ListViewItemCollection Class
ListView.ListViewItemCollection Members


Add(String) Method

[image]
Gizmox.WebGUI.Forms
Add(String) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView.ListViewItemCollection Class > Add Method : Add(String) Method

strText
STR text.
Adds the specified STR text.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function Add( _
   ByVal strText As String _
) As ListViewItem
Visual Basic (Usage) Copy Code
Dim instance As ListView.ListViewItemCollection
Dim strText As String
Dim value As ListViewItem

value = instance.Add(strText)
C#
public virtual ListViewItem Add(
   string strText
)
Managed Extensions for C++
public: virtual ListViewItem* Add(
   string* strText
)
C++/CLI
public:
virtual ListViewItem^ Add(
   String^ strText
)

Parameters

strText
STR text.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView.ListViewItemCollection Class
ListView.ListViewItemCollection Members
Overload List


Add(ListViewItem) Method

[image]
Gizmox.WebGUI.Forms
Add(ListViewItem) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView.ListViewItemCollection Class > Add Method : Add(ListViewItem) Method

objListViewItem
Obj list view item.
Adds the specified obj list view item.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function Add( _
   ByVal objListViewItem As ListViewItem _
) As ListViewItem
Visual Basic (Usage) Copy Code
Dim instance As ListView.ListViewItemCollection
Dim objListViewItem As ListViewItem
Dim value As ListViewItem

value = instance.Add(objListViewItem)
C#
public virtual ListViewItem Add(
   ListViewItem objListViewItem
)
Managed Extensions for C++
public: virtual ListViewItem* Add(
   ListViewItem* objListViewItem
)
C++/CLI
public:
virtual ListViewItem^ Add(
   ListViewItem^ objListViewItem
)

Parameters

objListViewItem
Obj list view item.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView.ListViewItemCollection Class
ListView.ListViewItemCollection Members
Overload List


Add(String,Int32) Method

[image]
Gizmox.WebGUI.Forms
Add(String,Int32) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView.ListViewItemCollection Class > Add Method : Add(String,Int32) Method

strText
Text.
imageIndex
Image index.
Adds the specified text.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function Add( _
   ByVal strText As String, _
   ByVal imageIndex As Integer _
) As ListViewItem
Visual Basic (Usage) Copy Code
Dim instance As ListView.ListViewItemCollection
Dim strText As String
Dim imageIndex As Integer
Dim value As ListViewItem

value = instance.Add(strText, imageIndex)
C#
public virtual ListViewItem Add(
   string strText,
   int imageIndex
)
Managed Extensions for C++
public: virtual ListViewItem* Add(
   string* strText,
   int imageIndex
)
C++/CLI
public:
virtual ListViewItem^ Add(
   String^ strText,
   int imageIndex
)

Parameters

strText
Text.
imageIndex
Image index.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView.ListViewItemCollection Class
ListView.ListViewItemCollection Members
Overload List


AddRange Method

[image]
Gizmox.WebGUI.Forms
AddRange Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView.ListViewItemCollection Class : AddRange Method

objListViewItems
An array of ListViewItem objects to add to the collection.
Adds an array of ListViewItem objects to the collection.

Syntax

Visual Basic (Declaration)
Public Sub AddRange( _
   ByVal objListViewItems() As ListViewItem _
)
Visual Basic (Usage) Copy Code
Dim instance As ListView.ListViewItemCollection
Dim objListViewItems() As ListViewItem

instance.AddRange(objListViewItems)
C#
public void AddRange(
   ListViewItem[] objListViewItems
)
Managed Extensions for C++
public: void AddRange(
   ListViewItem*[]* objListViewItems
)
C++/CLI
public:
void AddRange(
   array<ListViewItem^>^ objListViewItems
)

Parameters

objListViewItems
An array of ListViewItem objects to add to the collection.

Exceptions

Exception | Description
ArgumentNullException | items is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView.ListViewItemCollection Class
ListView.ListViewItemCollection Members


Clear Method

[image]
Gizmox.WebGUI.Forms
Clear Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView.ListViewItemCollection Class : Clear Method

Clears this list items.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As ListView.ListViewItemCollection

instance.Clear()
C#
public void Clear()
Managed Extensions for C++
public: void Clear();
C++/CLI
public:
void Clear();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView.ListViewItemCollection Class
ListView.ListViewItemCollection Members


Contains Method

[image]
Gizmox.WebGUI.Forms
Contains Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView.ListViewItemCollection Class : Contains Method

value

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal value As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ListView.ListViewItemCollection
Dim value As Object
Dim value As Boolean

value = instance.Contains(value)
C#
public bool Contains(
   object value
)
Managed Extensions for C++
public: bool Contains(
   Object* value
)
C++/CLI
public:
bool Contains(
   Object^ value
)

Parameters

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView.ListViewItemCollection Class
ListView.ListViewItemCollection Members


CopyTo Method

[image]
Gizmox.WebGUI.Forms
CopyTo Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView.ListViewItemCollection Class : CopyTo Method

objArray
intIndex
Copies to an array.

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal objArray As Array, _
   ByVal intIndex As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As ListView.ListViewItemCollection
Dim objArray As Array
Dim intIndex As Integer

instance.CopyTo(objArray, intIndex)
C#
public void CopyTo(
   Array objArray,
   int intIndex
)
Managed Extensions for C++
public: void CopyTo(
   Array* objArray,
   int intIndex
)
C++/CLI
public:
void CopyTo(
   Array^ objArray,
   int intIndex
)

Parameters

objArray
intIndex

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView.ListViewItemCollection Class
ListView.ListViewItemCollection Members


GetEnumerator Method

[image]
Gizmox.WebGUI.Forms
GetEnumerator Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView.ListViewItemCollection Class : GetEnumerator Method

Gets an enumerator.

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As ListView.ListViewItemCollection
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView.ListViewItemCollection Class
ListView.ListViewItemCollection Members


IndexOf Method

[image]
Gizmox.WebGUI.Forms
IndexOf Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView.ListViewItemCollection Class : IndexOf Method

Get the index the of the specified list view item.

Overload List

Overload | Description
IndexOf(ListViewItem) | Get the index the of the specified list view item.
IndexOf(Object) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView.ListViewItemCollection Class
ListView.ListViewItemCollection Members


IndexOf(ListViewItem) Method

[image]
Gizmox.WebGUI.Forms
IndexOf(ListViewItem) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView.ListViewItemCollection Class > IndexOf Method : IndexOf(ListViewItem) Method

objListViewItem
Obj list view item.
Get the index the of the specified list view item.

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal objListViewItem As ListViewItem _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As ListView.ListViewItemCollection
Dim objListViewItem As ListViewItem
Dim value As Integer

value = instance.IndexOf(objListViewItem)
C#
public int IndexOf(
   ListViewItem objListViewItem
)
Managed Extensions for C++
public: int IndexOf(
   ListViewItem* objListViewItem
)
C++/CLI
public:
int IndexOf(
   ListViewItem^ objListViewItem
)

Parameters

objListViewItem
Obj list view item.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView.ListViewItemCollection Class
ListView.ListViewItemCollection Members
Overload List


IndexOf(Object) Method

[image]
Gizmox.WebGUI.Forms
IndexOf(Object) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView.ListViewItemCollection Class > IndexOf Method : IndexOf(Object) Method

value

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal value As Object _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As ListView.ListViewItemCollection
Dim value As Object
Dim value As Integer

value = instance.IndexOf(value)
C#
public int IndexOf(
   object value
)
Managed Extensions for C++
public: int IndexOf(
   Object* value
)
C++/CLI
public:
int IndexOf(
   Object^ value
)

Parameters

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView.ListViewItemCollection Class
ListView.ListViewItemCollection Members
Overload List


Insert Method

[image]
Gizmox.WebGUI.Forms
Insert Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView.ListViewItemCollection Class : Insert Method

Creates a new item and inserts it into the collection at the specified index.

Overload List

Overload | Description
Insert(Int32,String) | Creates a new item and inserts it into the collection at the specified index.
Insert(Int32,ListViewItem) | Inserts an existing ListViewItem into the collection at the specified index.
Insert(Int32,String,Int32) | Creates a new item with the specified image index and inserts it into the collection at the specified index.
Insert(Int32,String,String) | Creates a new item with the specified text and image and inserts it in the collection at the specified index.
Insert(Int32,String,String,Int32) | Creates a new item with the specified key, text, and image, and inserts it in the collection at the specified index.
Insert(Int32,String,String,String) | Creates a new item with the specified key, text, and image, and adds it to the collection at the specified index.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView.ListViewItemCollection Class
ListView.ListViewItemCollection Members


Insert(Int32,String) Method

[image]
Gizmox.WebGUI.Forms
Insert(Int32,String) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView.ListViewItemCollection Class > Insert Method : Insert(Int32,String) Method

index
The zero-based index location where the item is inserted.
text
The text to display for the item.
Creates a new item and inserts it into the collection at the specified index.

Syntax

Visual Basic (Declaration)
Public Overloads Function Insert( _
   ByVal index As Integer, _
   ByVal text As String _
) As ListViewItem
Visual Basic (Usage) Copy Code
Dim instance As ListView.ListViewItemCollection
Dim index As Integer
Dim text As String
Dim value As ListViewItem

value = instance.Insert(index, text)
C#
public ListViewItem Insert(
   int index,
   string text
)
Managed Extensions for C++
public: ListViewItem* Insert(
   int index,
   string* text
)
C++/CLI
public:
ListViewItem^ Insert(
   int index,
   String^ text
)

Parameters

index
The zero-based index location where the item is inserted.
text
The text to display for the item.

Return Value

The ListViewItem that was inserted into the collection.

Exceptions

Exception | Description
ArgumentOutOfRangeException | The index parameter is less than 0 or greater than the value of the Count property of the ListView.ListViewItemCollection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView.ListViewItemCollection Class
ListView.ListViewItemCollection Members
Overload List


Insert(Int32,ListViewItem) Method

[image]
Gizmox.WebGUI.Forms
Insert(Int32,ListViewItem) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView.ListViewItemCollection Class > Insert Method : Insert(Int32,ListViewItem) Method

index
The zero-based index location where the item is inserted.
item
The ListViewItem that represents the item to insert.
Inserts an existing ListViewItem into the collection at the specified index.

Syntax

Visual Basic (Declaration)
Public Overloads Function Insert( _
   ByVal index As Integer, _
   ByVal item As ListViewItem _
) As ListViewItem
Visual Basic (Usage) Copy Code
Dim instance As ListView.ListViewItemCollection
Dim index As Integer
Dim item As ListViewItem
Dim value As ListViewItem

value = instance.Insert(index, item)
C#
public ListViewItem Insert(
   int index,
   ListViewItem item
)
Managed Extensions for C++
public: ListViewItem* Insert(
   int index,
   ListViewItem* item
)
C++/CLI
public:
ListViewItem^ Insert(
   int index,
   ListViewItem^ item
)

Parameters

index
The zero-based index location where the item is inserted.
item
The ListViewItem that represents the item to insert.

Return Value

The ListViewItem that was inserted into the collection.

Exceptions

Exception | Description
ArgumentOutOfRangeException | The index parameter is less than 0 or greater than the value of the Count property of the ListView.ListViewItemCollection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView.ListViewItemCollection Class
ListView.ListViewItemCollection Members
Overload List


Insert(Int32,String,Int32) Method

[image]
Gizmox.WebGUI.Forms
Insert(Int32,String,Int32) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView.ListViewItemCollection Class > Insert Method : Insert(Int32,String,Int32) Method

index
The zero-based index location where the item is inserted.
text
The text to display for the item.
imageIndex
The index of the image to display for the item.
Creates a new item with the specified image index and inserts it into the collection at the specified index.

Syntax

Visual Basic (Declaration)
Public Overloads Function Insert( _
   ByVal index As Integer, _
   ByVal text As String, _
   ByVal imageIndex As Integer _
) As ListViewItem
Visual Basic (Usage) Copy Code
Dim instance As ListView.ListViewItemCollection
Dim index As Integer
Dim text As String
Dim imageIndex As Integer
Dim value As ListViewItem

value = instance.Insert(index, text, imageIndex)
C#
public ListViewItem Insert(
   int index,
   string text,
   int imageIndex
)
Managed Extensions for C++
public: ListViewItem* Insert(
   int index,
   string* text,
   int imageIndex
)
C++/CLI
public:
ListViewItem^ Insert(
   int index,
   String^ text,
   int imageIndex
)

Parameters

index
The zero-based index location where the item is inserted.
text
The text to display for the item.
imageIndex
The index of the image to display for the item.

Return Value

The ListViewItem that was inserted into the collection.

Exceptions

Exception | Description
ArgumentOutOfRangeException | The index parameter is less than 0 or greater than the value of the Count property of the ListView.ListViewItemCollection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView.ListViewItemCollection Class
ListView.ListViewItemCollection Members
Overload List


Insert(Int32,String,String) Method

[image]
Gizmox.WebGUI.Forms
Insert(Int32,String,String) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView.ListViewItemCollection Class > Insert Method : Insert(Int32,String,String) Method

index
The zero-based index location where the item is inserted.
text
The text of the ListViewItem.
imageKey
The key of the image to display for the item.
Creates a new item with the specified text and image and inserts it in the collection at the specified index.

Syntax

Visual Basic (Declaration)
Public Overloads Function Insert( _
   ByVal index As Integer, _
   ByVal text As String, _
   ByVal imageKey As String _
) As ListViewItem
Visual Basic (Usage) Copy Code
Dim instance As ListView.ListViewItemCollection
Dim index As Integer
Dim text As String
Dim imageKey As String
Dim value As ListViewItem

value = instance.Insert(index, text, imageKey)
C#
public ListViewItem Insert(
   int index,
   string text,
   string imageKey
)
Managed Extensions for C++
public: ListViewItem* Insert(
   int index,
   string* text,
   string* imageKey
)
C++/CLI
public:
ListViewItem^ Insert(
   int index,
   String^ text,
   String^ imageKey
)

Parameters

index
The zero-based index location where the item is inserted.
text
The text of the ListViewItem.
imageKey
The key of the image to display for the item.

Return Value

The ListViewItem added to the collection.

Exceptions

Exception | Description
ArgumentOutOfRangeException | The index parameter is less than 0 or greater than the value of the Count property of the ListView.ListViewItemCollection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView.ListViewItemCollection Class
ListView.ListViewItemCollection Members
Overload List


Insert(Int32,String,String,Int32) Method

[image]
Gizmox.WebGUI.Forms
Insert(Int32,String,String,Int32) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView.ListViewItemCollection Class > Insert Method : Insert(Int32,String,String,Int32) Method

index
The zero-based index location where the item is inserted
key
The Name of the item.
text
The text of the item.
imageIndex
The index of the image to display for the item.
Creates a new item with the specified key, text, and image, and inserts it in the collection at the specified index.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function Insert( _
   ByVal index As Integer, _
   ByVal key As String, _
   ByVal text As String, _
   ByVal imageIndex As Integer _
) As ListViewItem
Visual Basic (Usage) Copy Code
Dim instance As ListView.ListViewItemCollection
Dim index As Integer
Dim key As String
Dim text As String
Dim imageIndex As Integer
Dim value As ListViewItem

value = instance.Insert(index, key, text, imageIndex)
C#
public virtual ListViewItem Insert(
   int index,
   string key,
   string text,
   int imageIndex
)
Managed Extensions for C++
public: virtual ListViewItem* Insert(
   int index,
   string* key,
   string* text,
   int imageIndex
)
C++/CLI
public:
virtual ListViewItem^ Insert(
   int index,
   String^ key,
   String^ text,
   int imageIndex
)

Parameters

index
The zero-based index location where the item is inserted
key
The Name of the item.
text
The text of the item.
imageIndex
The index of the image to display for the item.

Return Value

The ListViewItem added to the collection.

Exceptions

Exception | Description
ArgumentOutOfRangeException | The index parameter is less than 0 or greater than the value of the Count property of the ListView.ListViewItemCollection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView.ListViewItemCollection Class
ListView.ListViewItemCollection Members
Overload List


Insert(Int32,String,String,String) Method

[image]
Gizmox.WebGUI.Forms
Insert(Int32,String,String,String) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView.ListViewItemCollection Class > Insert Method : Insert(Int32,String,String,String) Method

index
The zero-based index location where the item is inserted.
key
The Name of the item.
text
The text of the item.
imageKey
The key of the image to display for the item.
Creates a new item with the specified key, text, and image, and adds it to the collection at the specified index.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function Insert( _
   ByVal index As Integer, _
   ByVal key As String, _
   ByVal text As String, _
   ByVal imageKey As String _
) As ListViewItem
Visual Basic (Usage) Copy Code
Dim instance As ListView.ListViewItemCollection
Dim index As Integer
Dim key As String
Dim text As String
Dim imageKey As String
Dim value As ListViewItem

value = instance.Insert(index, key, text, imageKey)
C#
public virtual ListViewItem Insert(
   int index,
   string key,
   string text,
   string imageKey
)
Managed Extensions for C++
public: virtual ListViewItem* Insert(
   int index,
   string* key,
   string* text,
   string* imageKey
)
C++/CLI
public:
virtual ListViewItem^ Insert(
   int index,
   String^ key,
   String^ text,
   String^ imageKey
)

Parameters

index
The zero-based index location where the item is inserted.
key
The Name of the item.
text
The text of the item.
imageKey
The key of the image to display for the item.

Return Value

The ListViewItem added to the collection.

Exceptions

Exception | Description
ArgumentOutOfRangeException | The index parameter is less than 0 or greater than the value of the Count property of the ListView.ListViewItemCollection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView.ListViewItemCollection Class
ListView.ListViewItemCollection Members
Overload List


Remove Method

[image]
Gizmox.WebGUI.Forms
Remove Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView.ListViewItemCollection Class : Remove Method

objListViewItem
list view item.
Removes the specified list view item.

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal objListViewItem As ListViewItem _
)
Visual Basic (Usage) Copy Code
Dim instance As ListView.ListViewItemCollection
Dim objListViewItem As ListViewItem

instance.Remove(objListViewItem)
C#
public void Remove(
   ListViewItem objListViewItem
)
Managed Extensions for C++
public: void Remove(
   ListViewItem* objListViewItem
)
C++/CLI
public:
void Remove(
   ListViewItem^ objListViewItem
)

Parameters

objListViewItem
list view item.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView.ListViewItemCollection Class
ListView.ListViewItemCollection Members


RemoveAt Method

[image]
Gizmox.WebGUI.Forms
RemoveAt Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView.ListViewItemCollection Class : RemoveAt Method

index

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As ListView.ListViewItemCollection
Dim index As Integer

instance.RemoveAt(index)
C#
public void RemoveAt(
   int index
)
Managed Extensions for C++
public: void RemoveAt(
   int index
)
C++/CLI
public:
void RemoveAt(
   int index
)

Parameters

index

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView.ListViewItemCollection Class
ListView.ListViewItemCollection Members


ListView.ListViewItemCollection Class Properties

[image]
Gizmox.WebGUI.Forms
ListView.ListViewItemCollection Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ListView.ListViewItemCollection Class

For a list of all members of this type, see ListView.ListViewItemCollection members.

Public Properties

 | Name | Description
Public Property | Count | Gets the count.
Public Property | IsFixedSize |
Public Property | IsReadOnly |
Public Property | IsSynchronized | Gets a value indicating whether this instance is synchronized.
Public Property | Item | Gets the ListViewItem at the specified int index.
Public Property | SyncRoot | Gets the sync root.
Top

See Also

Reference

ListView.ListViewItemCollection Class
Gizmox.WebGUI.Forms Namespace


Count Property

[image]
Gizmox.WebGUI.Forms
Count Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView.ListViewItemCollection Class : Count Property

Gets the count.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As ListView.ListViewItemCollection
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView.ListViewItemCollection Class
ListView.ListViewItemCollection Members


IsFixedSize Property

[image]
Gizmox.WebGUI.Forms
IsFixedSize Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView.ListViewItemCollection Class : IsFixedSize Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsFixedSize As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ListView.ListViewItemCollection
Dim value As Boolean

value = instance.IsFixedSize
C#
public bool IsFixedSize {get;}
Managed Extensions for C++
public: __property bool get_IsFixedSize();
C++/CLI
public:
property bool IsFixedSize {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView.ListViewItemCollection Class
ListView.ListViewItemCollection Members


IsReadOnly Property

[image]
Gizmox.WebGUI.Forms
IsReadOnly Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView.ListViewItemCollection Class : IsReadOnly Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsReadOnly As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ListView.ListViewItemCollection
Dim value As Boolean

value = instance.IsReadOnly
C#
public bool IsReadOnly {get;}
Managed Extensions for C++
public: __property bool get_IsReadOnly();
C++/CLI
public:
property bool IsReadOnly {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView.ListViewItemCollection Class
ListView.ListViewItemCollection Members


IsSynchronized Property

[image]
Gizmox.WebGUI.Forms
IsSynchronized Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView.ListViewItemCollection Class : IsSynchronized Property

Gets a value indicating whether this instance is synchronized.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsSynchronized As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ListView.ListViewItemCollection
Dim value As Boolean

value = instance.IsSynchronized
C#
public bool IsSynchronized {get;}
Managed Extensions for C++
public: __property bool get_IsSynchronized();
C++/CLI
public:
property bool IsSynchronized {
   bool get();
}

Return Value

true if this instance is synchronized; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView.ListViewItemCollection Class
ListView.ListViewItemCollection Members


Item Property

[image]
Gizmox.WebGUI.Forms
Item Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView.ListViewItemCollection Class : Item Property

intIndex
Gets the ListViewItem at the specified int index.

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal intIndex As Integer _
) As ListViewItem
Visual Basic (Usage) Copy Code
Dim instance As ListView.ListViewItemCollection
Dim intIndex As Integer
Dim value As ListViewItem

value = instance.Item(intIndex)
C#
public ListViewItem this[
   int intIndex
]; {get;}
Managed Extensions for C++
public: __property ListViewItem* get_Item(
   int intIndex
);
C++/CLI
public:
property ListViewItem^ default [int] {
   ListViewItem^ get(intintIndex);
}

Parameters

intIndex

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView.ListViewItemCollection Class
ListView.ListViewItemCollection Members


SyncRoot Property

[image]
Gizmox.WebGUI.Forms
SyncRoot Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView.ListViewItemCollection Class : SyncRoot Property

Gets the sync root.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SyncRoot As Object
Visual Basic (Usage) Copy Code
Dim instance As ListView.ListViewItemCollection
Dim value As Object

value = instance.SyncRoot
C#
public object SyncRoot {get;}
Managed Extensions for C++
public: __property Object* get_SyncRoot();
C++/CLI
public:
property Object^ SyncRoot {
   Object^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView.ListViewItemCollection Class
ListView.ListViewItemCollection Members


ListView.ListViewItemCollection Class Events

[image]
Gizmox.WebGUI.Forms
ListView.ListViewItemCollection Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ListView.ListViewItemCollection Class

For a list of all members of this type, see ListView.ListViewItemCollection members.

Public Events

 | Name | Description
Public Event | ObservableItemAdded |
Public Event | ObservableItemInserted |
Public Event | ObservableItemRemoved |
Public Event | ObservableListCleared |
Top

See Also

Reference

ListView.ListViewItemCollection Class
Gizmox.WebGUI.Forms Namespace


ObservableItemAdded Event

[image]
Gizmox.WebGUI.Forms
ObservableItemAdded Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView.ListViewItemCollection Class : ObservableItemAdded Event

Syntax

Visual Basic (Declaration)
Public Event ObservableItemAdded() As ObservableListEventHandler
Visual Basic (Usage) Copy Code
Dim instance As ListView.ListViewItemCollection
Dim handler As ObservableListEventHandler

AddHandler instance.ObservableItemAdded, handler
C#
public event ObservableListEventHandler ObservableItemAdded()
Managed Extensions for C++
public: __event ObservableListEventHandler* ObservableItemAdded
C++/CLI
public:
event ObservableListEventHandler^ ObservableItemAdded

Event Data

The event handler receives an argument of type ObservableListEventArgs containing data related to this event. The following ObservableListEventArgs properties provide information specific to this event.

Property | Description
Item |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView.ListViewItemCollection Class
ListView.ListViewItemCollection Members


ObservableItemInserted Event

[image]
Gizmox.WebGUI.Forms
ObservableItemInserted Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView.ListViewItemCollection Class : ObservableItemInserted Event

Syntax

Visual Basic (Declaration)
Public Event ObservableItemInserted() As ObservableListEventHandler
Visual Basic (Usage) Copy Code
Dim instance As ListView.ListViewItemCollection
Dim handler As ObservableListEventHandler

AddHandler instance.ObservableItemInserted, handler
C#
public event ObservableListEventHandler ObservableItemInserted()
Managed Extensions for C++
public: __event ObservableListEventHandler* ObservableItemInserted
C++/CLI
public:
event ObservableListEventHandler^ ObservableItemInserted

Event Data

The event handler receives an argument of type ObservableListEventArgs containing data related to this event. The following ObservableListEventArgs properties provide information specific to this event.

Property | Description
Item |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView.ListViewItemCollection Class
ListView.ListViewItemCollection Members


ObservableItemRemoved Event

[image]
Gizmox.WebGUI.Forms
ObservableItemRemoved Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView.ListViewItemCollection Class : ObservableItemRemoved Event

Syntax

Visual Basic (Declaration)
Public Event ObservableItemRemoved() As ObservableListEventHandler
Visual Basic (Usage) Copy Code
Dim instance As ListView.ListViewItemCollection
Dim handler As ObservableListEventHandler

AddHandler instance.ObservableItemRemoved, handler
C#
public event ObservableListEventHandler ObservableItemRemoved()
Managed Extensions for C++
public: __event ObservableListEventHandler* ObservableItemRemoved
C++/CLI
public:
event ObservableListEventHandler^ ObservableItemRemoved

Event Data

The event handler receives an argument of type ObservableListEventArgs containing data related to this event. The following ObservableListEventArgs properties provide information specific to this event.

Property | Description
Item |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView.ListViewItemCollection Class
ListView.ListViewItemCollection Members


ObservableListCleared Event

[image]
Gizmox.WebGUI.Forms
ObservableListCleared Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView.ListViewItemCollection Class : ObservableListCleared Event

Syntax

Visual Basic (Declaration)
Public Event ObservableListCleared() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As ListView.ListViewItemCollection
Dim handler As EventHandler

AddHandler instance.ObservableListCleared, handler
C#
public event EventHandler ObservableListCleared()
Managed Extensions for C++
public: __event EventHandler* ObservableListCleared
C++/CLI
public:
event EventHandler^ ObservableListCleared

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView.ListViewItemCollection Class
ListView.ListViewItemCollection Members


ListView.SelectedListViewItemCollection Class

[image]
Gizmox.WebGUI.Forms
ListView.SelectedListViewItemCollection Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ListView.SelectedListViewItemCollection Class

Object Model

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class ListView.SelectedListViewItemCollection
Visual Basic (Usage) Copy Code
Dim instance As ListView.SelectedListViewItemCollection
C#
[DefaultMemberAttribute("Item")]
public class ListView.SelectedListViewItemCollection
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
public __gc class ListView.SelectedListViewItemCollection
C++/CLI
[DefaultMemberAttribute("Item")]
public ref class ListView.SelectedListViewItemCollection

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ListView.SelectedListViewItemCollection

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

ListView.SelectedListViewItemCollection Members
Gizmox.WebGUI.Forms Namespace


ListView.SelectedListViewItemCollection Class Members

[image]
Gizmox.WebGUI.Forms
ListView.SelectedListViewItemCollection Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : ListView.SelectedListViewItemCollection Class

The following tables list the members exposed by ListView.SelectedListViewItemCollection.

Public Constructors

 | Name | Description
Public Constructor | ListView.SelectedListViewItemCollection Constructor |
Top

Public Properties

 | Name | Description
Public Property | Count |
Public Property | IsReadOnly |
Public Property | Item |
Top

Public Methods

 | Name | Description
Public Method | Contains |
Public Method | CopyTo |
Public Method | GetEnumerator |
Public Method | IndexOf |
Top

See Also

Reference

ListView.SelectedListViewItemCollection Class
Gizmox.WebGUI.Forms Namespace


ListView.SelectedListViewItemCollection Constructor

[image]
Gizmox.WebGUI.Forms
ListView.SelectedListViewItemCollection Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView.SelectedListViewItemCollection Class : ListView.SelectedListViewItemCollection Constructor

objListView

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal objListView As ListView _
)
Visual Basic (Usage) Copy Code
Dim objListView As ListView

Dim instance As ListView.SelectedListViewItemCollection(objListView)
C#
public ListView.SelectedListViewItemCollection(
   ListView objListView
)
Managed Extensions for C++
public: ListView.SelectedListViewItemCollection(
   ListView* objListView
)
C++/CLI
public:
ListView.SelectedListViewItemCollection(
   ListView^ objListView
)

Parameters

objListView

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView.SelectedListViewItemCollection Class
ListView.SelectedListViewItemCollection Members


ListView.SelectedListViewItemCollection Class Methods

[image]
Gizmox.WebGUI.Forms
ListView.SelectedListViewItemCollection Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ListView.SelectedListViewItemCollection Class

For a list of all members of this type, see ListView.SelectedListViewItemCollection members.

Public Methods

 | Name | Description
Public Method | Contains |
Public Method | CopyTo |
Public Method | GetEnumerator |
Public Method | IndexOf |
Top

See Also

Reference

ListView.SelectedListViewItemCollection Class
Gizmox.WebGUI.Forms Namespace


Contains Method

[image]
Gizmox.WebGUI.Forms
Contains Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView.SelectedListViewItemCollection Class : Contains Method

objListViewItem

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal objListViewItem As ListViewItem _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ListView.SelectedListViewItemCollection
Dim objListViewItem As ListViewItem
Dim value As Boolean

value = instance.Contains(objListViewItem)
C#
public bool Contains(
   ListViewItem objListViewItem
)
Managed Extensions for C++
public: bool Contains(
   ListViewItem* objListViewItem
)
C++/CLI
public:
bool Contains(
   ListViewItem^ objListViewItem
)

Parameters

objListViewItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView.SelectedListViewItemCollection Class
ListView.SelectedListViewItemCollection Members


CopyTo Method

[image]
Gizmox.WebGUI.Forms
CopyTo Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView.SelectedListViewItemCollection Class : CopyTo Method

array
index

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array As Array, _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As ListView.SelectedListViewItemCollection
Dim array As Array
Dim index As Integer

instance.CopyTo(array, index)
C#
public void CopyTo(
   Array array,
   int index
)
Managed Extensions for C++
public: void CopyTo(
   Array* array,
   int index
)
C++/CLI
public:
void CopyTo(
   Array^ array,
   int index
)

Parameters

array
index

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView.SelectedListViewItemCollection Class
ListView.SelectedListViewItemCollection Members


GetEnumerator Method

[image]
Gizmox.WebGUI.Forms
GetEnumerator Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView.SelectedListViewItemCollection Class : GetEnumerator Method

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As ListView.SelectedListViewItemCollection
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView.SelectedListViewItemCollection Class
ListView.SelectedListViewItemCollection Members


IndexOf Method

[image]
Gizmox.WebGUI.Forms
IndexOf Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView.SelectedListViewItemCollection Class : IndexOf Method

objListViewItem

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal objListViewItem As ListViewItem _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As ListView.SelectedListViewItemCollection
Dim objListViewItem As ListViewItem
Dim value As Integer

value = instance.IndexOf(objListViewItem)
C#
public int IndexOf(
   ListViewItem objListViewItem
)
Managed Extensions for C++
public: int IndexOf(
   ListViewItem* objListViewItem
)
C++/CLI
public:
int IndexOf(
   ListViewItem^ objListViewItem
)

Parameters

objListViewItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView.SelectedListViewItemCollection Class
ListView.SelectedListViewItemCollection Members


ListView.SelectedListViewItemCollection Class Properties

[image]
Gizmox.WebGUI.Forms
ListView.SelectedListViewItemCollection Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ListView.SelectedListViewItemCollection Class

For a list of all members of this type, see ListView.SelectedListViewItemCollection members.

Public Properties

 | Name | Description
Public Property | Count |
Public Property | IsReadOnly |
Public Property | Item |
Top

See Also

Reference

ListView.SelectedListViewItemCollection Class
Gizmox.WebGUI.Forms Namespace


Count Property

[image]
Gizmox.WebGUI.Forms
Count Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView.SelectedListViewItemCollection Class : Count Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As ListView.SelectedListViewItemCollection
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView.SelectedListViewItemCollection Class
ListView.SelectedListViewItemCollection Members


IsReadOnly Property

[image]
Gizmox.WebGUI.Forms
IsReadOnly Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView.SelectedListViewItemCollection Class : IsReadOnly Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsReadOnly As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ListView.SelectedListViewItemCollection
Dim value As Boolean

value = instance.IsReadOnly
C#
public bool IsReadOnly {get;}
Managed Extensions for C++
public: __property bool get_IsReadOnly();
C++/CLI
public:
property bool IsReadOnly {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView.SelectedListViewItemCollection Class
ListView.SelectedListViewItemCollection Members


Item Property

[image]
Gizmox.WebGUI.Forms
Item Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListView.SelectedListViewItemCollection Class : Item Property

index

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal index As Integer _
) As ListViewItem
Visual Basic (Usage) Copy Code
Dim instance As ListView.SelectedListViewItemCollection
Dim index As Integer
Dim value As ListViewItem

value = instance.Item(index)
C#
public ListViewItem this[
   int index
]; {get;}
Managed Extensions for C++
public: __property ListViewItem* get_Item(
   int index
);
C++/CLI
public:
property ListViewItem^ default [int] {
   ListViewItem^ get(intindex);
}

Parameters

index

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListView.SelectedListViewItemCollection Class
ListView.SelectedListViewItemCollection Members


ListViewItem Class

[image]
Gizmox.WebGUI.Forms
ListViewItem Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ListViewItem Class

Implementation of ListViewItem class.

Object Model

Syntax

Visual Basic (Declaration)
<ClientControllerAttribute()>
<DesignTimeControllerAttribute()>
<DesignTimeVisibleAttribute()>
<TypeConverterAttribute("Gizmox.WebGUI.Forms.ListViewItemConverter, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d")>
<ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")>
Public Class ListViewItem
   Inherits Component
   Implements IAttributeExtender, IEventHandler, IGatewayComponent, IObservableItem, IRegisteredComponent
Visual Basic (Usage) Copy Code
Dim instance As ListViewItem
C#
[ClientControllerAttribute()]
[DesignTimeControllerAttribute()]
[DesignTimeVisibleAttribute()]
[TypeConverterAttribute("Gizmox.WebGUI.Forms.ListViewItemConverter, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d")]
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
public class ListViewItem : Component, IAttributeExtender, IEventHandler, IGatewayComponent, IObservableItem, IRegisteredComponent
Managed Extensions for C++
[ClientControllerAttribute()]
[DesignTimeControllerAttribute()]
[DesignTimeVisibleAttribute()]
[TypeConverterAttribute("Gizmox.WebGUI.Forms.ListViewItemConverter, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d")]
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
public __gc class ListViewItem : public Component, IAttributeExtender, IEventHandler, IGatewayComponent, IObservableItem, IRegisteredComponent
C++/CLI
[ClientControllerAttribute()]
[DesignTimeControllerAttribute()]
[DesignTimeVisibleAttribute()]
[TypeConverterAttribute("Gizmox.WebGUI.Forms.ListViewItemConverter, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d")]
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
public ref class ListViewItem : public Component, IAttributeExtender, IEventHandler, IGatewayComponent, IObservableItem, IRegisteredComponent

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.ListViewItem

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

ListViewItem Members
Gizmox.WebGUI.Forms Namespace


ListViewItem Class Members

[image]
Gizmox.WebGUI.Forms
ListViewItem Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : ListViewItem Class

The following tables list the members exposed by ListViewItem.

Public Constructors

 | Name | Description
Public Constructor | ListViewItem Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | BackColor | Gets or sets the background color of the item's text.
Public Property | Checked | Gets or sets a value indicating whether this ListViewItem is checked.
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContextMenu | Gets or sets the context menu code. (Inherited from Component)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Font | Gets or sets the font.
Public Property | ForeColor | Gets or sets the foreground color of the item's text.
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Guid | Overridden. Gets the GUID.
Public Property | ImageIndex | Gets or sets the index of the image that is displayed for the item.
Public Property | ImageKey | Gets or sets the key for the image that is displayed for the item.
Public Property | ImageList | Gets the ImageList that contains the image displayed with the item.
Public Property | IndentCount | Gets or sets the number of small image widths by which to indent the ListViewItem.
Public Property | Index | Gets the zero-based index of the item within the ListView control.
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | LargeImage | Provides a way to define a large image for this list view item.
Public Property | ListView | Gets the list view.
Public Property | Selected | Gets or sets a value indicating whether this ListViewItem is selected.
Public Property | Site | (Inherited from ComponentBase)
Public Property | SmallImage | Gets or sets the small image that is displayed for the item.
Public Property | SubItems | Gets the sub items.
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the list view item text.
Public Property | UseItemStyleForSubItems | Gets or sets a value indicating whether the Font, ForeColor, and BackColor properties for the item are used for all its subitems.
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded. Disposes the specified component. (Inherited from Component)
Public Method | EnsureVisible | Ensures that the item is visible within the control, scrolling the contents of the control, if necessary.
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | Remove |
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. Overridden.
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Overridden. Fires an event.
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCriticalEvents | (Inherited from Component)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnUnregisterComponents | (Inherited from Component)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeImage | Shows the serialize image.
Protected Method | ShouldSerializeLargeImage | Shows the serialize large image.
Protected Method | ShouldSerializeSmallImage | Should the serialize large image.
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Top

See Also

Reference

ListViewItem Class
Gizmox.WebGUI.Forms Namespace


ListViewItem Constructor

[image]
Gizmox.WebGUI.Forms
ListViewItem Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListViewItem Class : ListViewItem Constructor

Overload List

Overload | Description
ListViewItem Constructor() |
ListViewItem Constructor(ListViewSubItem[],Int32) |
ListViewItem Constructor(String) |
ListViewItem Constructor(String,Int32) |
ListViewItem Constructor(String[]) |
ListViewItem Constructor(String[],Int32) |
ListViewItem Constructor(String[],Int32,Color,Color,Font) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListViewItem Class
ListViewItem Members


ListViewItem Constructor()

[image]
Gizmox.WebGUI.Forms
ListViewItem Constructor()
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListViewItem Class > ListViewItem Constructor : ListViewItem Constructor()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ListViewItem()
C#
public ListViewItem()
Managed Extensions for C++
public: ListViewItem();
C++/CLI
public:
ListViewItem();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListViewItem Class
ListViewItem Members
Overload List


ListViewItem Constructor(ListViewSubItem[],Int32)

[image]
Gizmox.WebGUI.Forms
ListViewItem Constructor(ListViewSubItem[],Int32)
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListViewItem Class > ListViewItem Constructor : ListViewItem Constructor(ListViewSubItem[],Int32)

arrSubItems
intImageIndex

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal arrSubItems() As ListViewItem.ListViewSubItem, _
   ByVal intImageIndex As Integer _
)
Visual Basic (Usage) Copy Code
Dim arrSubItems() As ListViewItem.ListViewSubItem
Dim intImageIndex As Integer

Dim instance As ListViewItem(arrSubItems, intImageIndex)
C#
public ListViewItem(
   ListViewItem.ListViewSubItem[] arrSubItems,
   int intImageIndex
)
Managed Extensions for C++
public: ListViewItem(
   ListViewItem.ListViewSubItem*[]* arrSubItems,
   int intImageIndex
)
C++/CLI
public:
ListViewItem(
   array<ListViewItem::ListViewSubItem^>^ arrSubItems,
   int intImageIndex
)

Parameters

arrSubItems
intImageIndex

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListViewItem Class
ListViewItem Members
Overload List


ListViewItem Constructor(String)

[image]
Gizmox.WebGUI.Forms
ListViewItem Constructor(String)
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListViewItem Class > ListViewItem Constructor : ListViewItem Constructor(String)

strText

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal strText As String _
)
Visual Basic (Usage) Copy Code
Dim strText As String

Dim instance As ListViewItem(strText)
C#
public ListViewItem(
   string strText
)
Managed Extensions for C++
public: ListViewItem(
   string* strText
)
C++/CLI
public:
ListViewItem(
   String^ strText
)

Parameters

strText

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListViewItem Class
ListViewItem Members
Overload List


ListViewItem Constructor(String,Int32)

[image]
Gizmox.WebGUI.Forms
ListViewItem Constructor(String,Int32)
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListViewItem Class > ListViewItem Constructor : ListViewItem Constructor(String,Int32)

strText
intImageIndex

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal strText As String, _
   ByVal intImageIndex As Integer _
)
Visual Basic (Usage) Copy Code
Dim strText As String
Dim intImageIndex As Integer

Dim instance As ListViewItem(strText, intImageIndex)
C#
public ListViewItem(
   string strText,
   int intImageIndex
)
Managed Extensions for C++
public: ListViewItem(
   string* strText,
   int intImageIndex
)
C++/CLI
public:
ListViewItem(
   String^ strText,
   int intImageIndex
)

Parameters

strText
intImageIndex

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListViewItem Class
ListViewItem Members
Overload List


ListViewItem Constructor(String[])

[image]
Gizmox.WebGUI.Forms
ListViewItem Constructor(String[])
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListViewItem Class > ListViewItem Constructor : ListViewItem Constructor(String[])

strItems

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal strItems() As String _
)
Visual Basic (Usage) Copy Code
Dim strItems() As String

Dim instance As ListViewItem(strItems)
C#
public ListViewItem(
   string[] strItems
)
Managed Extensions for C++
public: ListViewItem(
   string*[]* strItems
)
C++/CLI
public:
ListViewItem(
   array<String^>^ strItems
)

Parameters

strItems

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListViewItem Class
ListViewItem Members
Overload List


ListViewItem Constructor(String[],Int32)

[image]
Gizmox.WebGUI.Forms
ListViewItem Constructor(String[],Int32)
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListViewItem Class > ListViewItem Constructor : ListViewItem Constructor(String[],Int32)

strItems
intImageIndex

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal strItems() As String, _
   ByVal intImageIndex As Integer _
)
Visual Basic (Usage) Copy Code
Dim strItems() As String
Dim intImageIndex As Integer

Dim instance As ListViewItem(strItems, intImageIndex)
C#
public ListViewItem(
   string[] strItems,
   int intImageIndex
)
Managed Extensions for C++
public: ListViewItem(
   string*[]* strItems,
   int intImageIndex
)
C++/CLI
public:
ListViewItem(
   array<String^>^ strItems,
   int intImageIndex
)

Parameters

strItems
intImageIndex

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListViewItem Class
ListViewItem Members
Overload List


ListViewItem Constructor(String[],Int32,Color,Color,Font)

[image]
Gizmox.WebGUI.Forms
ListViewItem Constructor(String[],Int32,Color,Color,Font)
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListViewItem Class > ListViewItem Constructor : ListViewItem Constructor(String[],Int32,Color,Color,Font)

strItems
intImageIndex
objForeColor
objBackColor
objFont

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal strItems() As String, _
   ByVal intImageIndex As Integer, _
   ByVal objForeColor As Color, _
   ByVal objBackColor As Color, _
   ByVal objFont As Font _
)
Visual Basic (Usage) Copy Code
Dim strItems() As String
Dim intImageIndex As Integer
Dim objForeColor As Color
Dim objBackColor As Color
Dim objFont As Font

Dim instance As ListViewItem(strItems, intImageIndex, objForeColor, objBackColor, objFont)
C#
public ListViewItem(
   string[] strItems,
   int intImageIndex,
   Color objForeColor,
   Color objBackColor,
   Font objFont
)
Managed Extensions for C++
public: ListViewItem(
   string*[]* strItems,
   int intImageIndex,
   Color objForeColor,
   Color objBackColor,
   Font* objFont
)
C++/CLI
public:
ListViewItem(
   array<String^>^ strItems,
   int intImageIndex,
   Color objForeColor,
   Color objBackColor,
   Font^ objFont
)

Parameters

strItems
intImageIndex
objForeColor
objBackColor
objFont

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListViewItem Class
ListViewItem Members
Overload List


ListViewItem Class Methods

[image]
Gizmox.WebGUI.Forms
ListViewItem Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ListViewItem Class

For a list of all members of this type, see ListViewItem members.

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded. Disposes the specified component. (Inherited from Component)
Public Method | EnsureVisible | Ensures that the item is visible within the control, scrolling the contents of the control, if necessary.
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | Remove |
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. Overridden.
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Overridden. Fires an event.
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCriticalEvents | (Inherited from Component)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnUnregisterComponents | (Inherited from Component)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeImage | Shows the serialize image.
Protected Method | ShouldSerializeLargeImage | Shows the serialize large image.
Protected Method | ShouldSerializeSmallImage | Should the serialize large image.
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

See Also

Reference

ListViewItem Class
Gizmox.WebGUI.Forms Namespace


EnsureVisible Method

[image]
Gizmox.WebGUI.Forms
EnsureVisible Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListViewItem Class : EnsureVisible Method

Ensures that the item is visible within the control, scrolling the contents of the control, if necessary.

Syntax

Visual Basic (Declaration)
Public Overridable Sub EnsureVisible()
Visual Basic (Usage) Copy Code
Dim instance As ListViewItem

instance.EnsureVisible()
C#
public virtual void EnsureVisible()
Managed Extensions for C++
public: virtual void EnsureVisible();
C++/CLI
public:
virtual void EnsureVisible();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListViewItem Class
ListViewItem Members


FireEvent Method

[image]
Gizmox.WebGUI.Forms
FireEvent Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListViewItem Class : FireEvent Method

objEvent
event.
Fires an event.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub FireEvent( _
   ByVal objEvent As IEvent _
)
Visual Basic (Usage) Copy Code
Dim instance As ListViewItem
Dim objEvent As IEvent

instance.FireEvent(objEvent)
C#
protected override void FireEvent(
   IEvent objEvent
)
Managed Extensions for C++
protected: void FireEvent(
   IEvent* objEvent
) override
C++/CLI
protected:
void FireEvent(
   IEvent^ objEvent
) override

Parameters

objEvent
event.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListViewItem Class
ListViewItem Members


Remove Method

[image]
Gizmox.WebGUI.Forms
Remove Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListViewItem Class : Remove Method

Syntax

Visual Basic (Declaration)
Public Sub Remove()
Visual Basic (Usage) Copy Code
Dim instance As ListViewItem

instance.Remove()
C#
public void Remove()
Managed Extensions for C++
public: void Remove();
C++/CLI
public:
void Remove();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListViewItem Class
ListViewItem Members


ShouldSerializeImage Method

[image]
Gizmox.WebGUI.Forms
ShouldSerializeImage Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListViewItem Class : ShouldSerializeImage Method

Shows the serialize image.

Syntax

Visual Basic (Declaration)
Protected Function ShouldSerializeImage() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ListViewItem
Dim value As Boolean

value = instance.ShouldSerializeImage()
C#
protected bool ShouldSerializeImage()
Managed Extensions for C++
protected: bool ShouldSerializeImage();
C++/CLI
protected:
bool ShouldSerializeImage();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListViewItem Class
ListViewItem Members


ShouldSerializeLargeImage Method

[image]
Gizmox.WebGUI.Forms
ShouldSerializeLargeImage Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListViewItem Class : ShouldSerializeLargeImage Method

Shows the serialize large image.

Syntax

Visual Basic (Declaration)
Protected Function ShouldSerializeLargeImage() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ListViewItem
Dim value As Boolean

value = instance.ShouldSerializeLargeImage()
C#
protected bool ShouldSerializeLargeImage()
Managed Extensions for C++
protected: bool ShouldSerializeLargeImage();
C++/CLI
protected:
bool ShouldSerializeLargeImage();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListViewItem Class
ListViewItem Members


ShouldSerializeSmallImage Method

[image]
Gizmox.WebGUI.Forms
ShouldSerializeSmallImage Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListViewItem Class : ShouldSerializeSmallImage Method

Should the serialize large image.

Syntax

Visual Basic (Declaration)
Protected Function ShouldSerializeSmallImage() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ListViewItem
Dim value As Boolean

value = instance.ShouldSerializeSmallImage()
C#
protected bool ShouldSerializeSmallImage()
Managed Extensions for C++
protected: bool ShouldSerializeSmallImage();
C++/CLI
protected:
bool ShouldSerializeSmallImage();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListViewItem Class
ListViewItem Members


Update Method

[image]
Gizmox.WebGUI.Forms
Update Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListViewItem Class : Update Method

Overload List

Overload | Description
Update() |
Update(Boolean) | (Inherited from RegisteredComponent)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListViewItem Class
ListViewItem Members


Update() Method

[image]
Gizmox.WebGUI.Forms
Update() Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListViewItem Class > Update Method : Update() Method

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Sub Update()
Visual Basic (Usage) Copy Code
Dim instance As ListViewItem

instance.Update()
C#
public override void Update()
Managed Extensions for C++
public: void Update(); override
C++/CLI
public:
void Update(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListViewItem Class
ListViewItem Members
Overload List


ListViewItem Class Properties

[image]
Gizmox.WebGUI.Forms
ListViewItem Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ListViewItem Class

For a list of all members of this type, see ListViewItem members.

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | BackColor | Gets or sets the background color of the item's text.
Public Property | Checked | Gets or sets a value indicating whether this ListViewItem is checked.
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContextMenu | Gets or sets the context menu code. (Inherited from Component)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Font | Gets or sets the font.
Public Property | ForeColor | Gets or sets the foreground color of the item's text.
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Guid | Overridden. Gets the GUID.
Public Property | ImageIndex | Gets or sets the index of the image that is displayed for the item.
Public Property | ImageKey | Gets or sets the key for the image that is displayed for the item.
Public Property | ImageList | Gets the ImageList that contains the image displayed with the item.
Public Property | IndentCount | Gets or sets the number of small image widths by which to indent the ListViewItem.
Public Property | Index | Gets the zero-based index of the item within the ListView control.
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | LargeImage | Provides a way to define a large image for this list view item.
Public Property | ListView | Gets the list view.
Public Property | Selected | Gets or sets a value indicating whether this ListViewItem is selected.
Public Property | Site | (Inherited from ComponentBase)
Public Property | SmallImage | Gets or sets the small image that is displayed for the item.
Public Property | SubItems | Gets the sub items.
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the list view item text.
Public Property | UseItemStyleForSubItems | Gets or sets a value indicating whether the Font, ForeColor, and BackColor properties for the item are used for all its subitems.
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

See Also

Reference

ListViewItem Class
Gizmox.WebGUI.Forms Namespace


BackColor Property

[image]
Gizmox.WebGUI.Forms
BackColor Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListViewItem Class : BackColor Property

Gets or sets the background color of the item's text.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Appearance")>
<DesignerSerializationVisibilityAttribute()>
Public Property BackColor As Color
Visual Basic (Usage) Copy Code
Dim instance As ListViewItem
Dim value As Color

instance.BackColor = value

value = instance.BackColor
C#
[SRCategoryAttribute("Appearance")]
[DesignerSerializationVisibilityAttribute()]
public Color BackColor {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Appearance")]
[DesignerSerializationVisibilityAttribute()]
public: __property Color get_BackColor();
public: __property void set_BackColor(
   Color value
);
C++/CLI
[SRCategoryAttribute("Appearance")]
[DesignerSerializationVisibilityAttribute()]
public:
property Color BackColor {
   Color get();
   void set (Colorvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListViewItem Class
ListViewItem Members


Checked Property

[image]
Gizmox.WebGUI.Forms
Checked Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListViewItem Class : Checked Property

Gets or sets a value indicating whether this ListViewItem is checked.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property Checked As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ListViewItem
Dim value As Boolean

instance.Checked = value

value = instance.Checked
C#
[DefaultValueAttribute()]
public bool Checked {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property bool get_Checked();
public: __property void set_Checked(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
public:
property bool Checked {
   bool get();
   void set (boolvalue);
}

Return Value

true if checked; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListViewItem Class
ListViewItem Members


Font Property

[image]
Gizmox.WebGUI.Forms
Font Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListViewItem Class : Font Property

Gets or sets the font.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property Font As Font
Visual Basic (Usage) Copy Code
Dim instance As ListViewItem
Dim value As Font

instance.Font = value

value = instance.Font
C#
[DefaultValueAttribute()]
public Font Font {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property Font* get_Font();
public: __property void set_Font(
   Font* value
);
C++/CLI
[DefaultValueAttribute()]
public:
property Font^ Font {
   Font^ get();
   void set (Font^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListViewItem Class
ListViewItem Members


ForeColor Property

[image]
Gizmox.WebGUI.Forms
ForeColor Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListViewItem Class : ForeColor Property

Gets or sets the foreground color of the item's text.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Appearance")>
<DesignerSerializationVisibilityAttribute()>
Public Property ForeColor As Color
Visual Basic (Usage) Copy Code
Dim instance As ListViewItem
Dim value As Color

instance.ForeColor = value

value = instance.ForeColor
C#
[SRCategoryAttribute("Appearance")]
[DesignerSerializationVisibilityAttribute()]
public Color ForeColor {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Appearance")]
[DesignerSerializationVisibilityAttribute()]
public: __property Color get_ForeColor();
public: __property void set_ForeColor(
   Color value
);
C++/CLI
[SRCategoryAttribute("Appearance")]
[DesignerSerializationVisibilityAttribute()]
public:
property Color ForeColor {
   Color get();
   void set (Colorvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListViewItem Class
ListViewItem Members


Guid Property

[image]
Gizmox.WebGUI.Forms
Guid Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListViewItem Class : Guid Property

Gets the GUID.

Syntax

Visual Basic (Declaration)
Public Overrides Property Guid As Long
Visual Basic (Usage) Copy Code
Dim instance As ListViewItem
Dim value As Long

instance.Guid = value

value = instance.Guid
C#
public override long Guid {get; set;}
Managed Extensions for C++
public: __property long get_Guid() override;
public: __property void set_Guid(
   long value
) override;
C++/CLI
public:
property long long Guid {
   long long get() override;
   void set (long longvalue) override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListViewItem Class
ListViewItem Members


ImageIndex Property

[image]
Gizmox.WebGUI.Forms
ImageIndex Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListViewItem Class : ImageIndex Property

Gets or sets the index of the image that is displayed for the item.

Syntax

Visual Basic (Declaration)
<TypeConverterAttribute("Gizmox.WebGUI.Forms.Design.NoneExcludedImageIndexConverter, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")>
<LocalizableAttribute(True)>
<EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.ImageIndexEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")>
<DefaultValueAttribute()>
<RefreshPropertiesAttribute()>
<SRDescriptionAttribute("The ImageList index value of the image displayed when the list view item is in the unselected state.")>
<SRCategoryAttribute("Behavior")>
Public Property ImageIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As ListViewItem
Dim value As Integer

instance.ImageIndex = value

value = instance.ImageIndex
C#
[TypeConverterAttribute("Gizmox.WebGUI.Forms.Design.NoneExcludedImageIndexConverter, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[LocalizableAttribute(true)]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.ImageIndexEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[DefaultValueAttribute()]
[RefreshPropertiesAttribute()]
[SRDescriptionAttribute("The ImageList index value of the image displayed when the list view item is in the unselected state.")]
[SRCategoryAttribute("Behavior")]
public int ImageIndex {get; set;}
Managed Extensions for C++
[TypeConverterAttribute("Gizmox.WebGUI.Forms.Design.NoneExcludedImageIndexConverter, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[LocalizableAttribute(true)]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.ImageIndexEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[DefaultValueAttribute()]
[RefreshPropertiesAttribute()]
[SRDescriptionAttribute("The ImageList index value of the image displayed when the list view item is in the unselected state.")]
[SRCategoryAttribute("Behavior")]
public: __property int get_ImageIndex();
public: __property void set_ImageIndex(
   int value
);
C++/CLI
[TypeConverterAttribute("Gizmox.WebGUI.Forms.Design.NoneExcludedImageIndexConverter, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[LocalizableAttribute(true)]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.ImageIndexEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[DefaultValueAttribute()]
[RefreshPropertiesAttribute()]
[SRDescriptionAttribute("The ImageList index value of the image displayed when the list view item is in the unselected state.")]
[SRCategoryAttribute("Behavior")]
public:
property int ImageIndex {
   int get();
   void set (intvalue);
}

Exceptions

Exception | Description
ArgumentException | The value specified is less than -1.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListViewItem Class
ListViewItem Members


ImageKey Property

[image]
Gizmox.WebGUI.Forms
ImageKey Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListViewItem Class : ImageKey Property

Gets or sets the key for the image that is displayed for the item.

Syntax

Visual Basic (Declaration)
<EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.ImageIndexEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")>
<DefaultValueAttribute()>
<TypeConverterAttribute("Gizmox.WebGUI.Forms.Design.ImageKeyConverter, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")>
<SRCategoryAttribute("Behavior")>
<RefreshPropertiesAttribute()>
<LocalizableAttribute(True)>
Public Property ImageKey As String
Visual Basic (Usage) Copy Code
Dim instance As ListViewItem
Dim value As String

instance.ImageKey = value

value = instance.ImageKey
C#
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.ImageIndexEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[DefaultValueAttribute()]
[TypeConverterAttribute("Gizmox.WebGUI.Forms.Design.ImageKeyConverter, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[SRCategoryAttribute("Behavior")]
[RefreshPropertiesAttribute()]
[LocalizableAttribute(true)]
public string ImageKey {get; set;}
Managed Extensions for C++
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.ImageIndexEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[DefaultValueAttribute()]
[TypeConverterAttribute("Gizmox.WebGUI.Forms.Design.ImageKeyConverter, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[SRCategoryAttribute("Behavior")]
[RefreshPropertiesAttribute()]
[LocalizableAttribute(true)]
public: __property string* get_ImageKey();
public: __property void set_ImageKey(
   string* value
);
C++/CLI
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.ImageIndexEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[DefaultValueAttribute()]
[TypeConverterAttribute("Gizmox.WebGUI.Forms.Design.ImageKeyConverter, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[SRCategoryAttribute("Behavior")]
[RefreshPropertiesAttribute()]
[LocalizableAttribute(true)]
public:
property String^ ImageKey {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListViewItem Class
ListViewItem Members


ImageList Property

[image]
Gizmox.WebGUI.Forms
ImageList Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListViewItem Class : ImageList Property

Gets the ImageList that contains the image displayed with the item.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property ImageList As ImageList
Visual Basic (Usage) Copy Code
Dim instance As ListViewItem
Dim value As ImageList

value = instance.ImageList
C#
[BrowsableAttribute(false)]
public ImageList ImageList {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property ImageList* get_ImageList();
C++/CLI
[BrowsableAttribute(false)]
public:
property ImageList^ ImageList {
   ImageList^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListViewItem Class
ListViewItem Members


IndentCount Property

[image]
Gizmox.WebGUI.Forms
IndentCount Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListViewItem Class : IndentCount Property

Gets or sets the number of small image widths by which to indent the ListViewItem.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Display")>
<SRDescriptionAttribute("Number of indents for a list ListViewItem")>
<DefaultValueAttribute()>
Public Property IndentCount As Integer
Visual Basic (Usage) Copy Code
Dim instance As ListViewItem
Dim value As Integer

instance.IndentCount = value

value = instance.IndentCount
C#
[SRCategoryAttribute("Display")]
[SRDescriptionAttribute("Number of indents for a list ListViewItem")]
[DefaultValueAttribute()]
public int IndentCount {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Display")]
[SRDescriptionAttribute("Number of indents for a list ListViewItem")]
[DefaultValueAttribute()]
public: __property int get_IndentCount();
public: __property void set_IndentCount(
   int value
);
C++/CLI
[SRCategoryAttribute("Display")]
[SRDescriptionAttribute("Number of indents for a list ListViewItem")]
[DefaultValueAttribute()]
public:
property int IndentCount {
   int get();
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListViewItem Class
ListViewItem Members


Index Property

[image]
Gizmox.WebGUI.Forms
Index Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListViewItem Class : Index Property

Gets the zero-based index of the item within the ListView control.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property Index As Integer
Visual Basic (Usage) Copy Code
Dim instance As ListViewItem
Dim value As Integer

value = instance.Index
C#
[BrowsableAttribute(false)]
public int Index {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property int get_Index();
C++/CLI
[BrowsableAttribute(false)]
public:
property int Index {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListViewItem Class
ListViewItem Members


LargeImage Property

[image]
Gizmox.WebGUI.Forms
LargeImage Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListViewItem Class : LargeImage Property

Provides a way to define a large image for this list view item.

Syntax

Visual Basic (Declaration)
Public Property LargeImage As ResourceHandle
Visual Basic (Usage) Copy Code
Dim instance As ListViewItem
Dim value As ResourceHandle

instance.LargeImage = value

value = instance.LargeImage
C#
public ResourceHandle LargeImage {get; set;}
Managed Extensions for C++
public: __property ResourceHandle* get_LargeImage();
public: __property void set_LargeImage(
   ResourceHandle* value
);
C++/CLI
public:
property ResourceHandle^ LargeImage {
   ResourceHandle^ get();
   void set (ResourceHandle^value);
}

Remarks

This property will throw an error if the owning list view has a large imagelist set to it.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListViewItem Class
ListViewItem Members


ListView Property

[image]
Gizmox.WebGUI.Forms
ListView Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListViewItem Class : ListView Property

Gets the list view.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property ListView As ListView
Visual Basic (Usage) Copy Code
Dim instance As ListViewItem
Dim value As ListView

value = instance.ListView
C#
[BrowsableAttribute(false)]
public ListView ListView {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property ListView* get_ListView();
C++/CLI
[BrowsableAttribute(false)]
public:
property ListView^ ListView {
   ListView^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListViewItem Class
ListViewItem Members


Selected Property

[image]
Gizmox.WebGUI.Forms
Selected Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListViewItem Class : Selected Property

Gets or sets a value indicating whether this ListViewItem is selected.

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
<DefaultValueAttribute()>
Public Property Selected As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ListViewItem
Dim value As Boolean

instance.Selected = value

value = instance.Selected
C#
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
public bool Selected {get; set;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
public: __property bool get_Selected();
public: __property void set_Selected(
   bool value
);
C++/CLI
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
public:
property bool Selected {
   bool get();
   void set (boolvalue);
}

Return Value

true if selected; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListViewItem Class
ListViewItem Members


SmallImage Property

[image]
Gizmox.WebGUI.Forms
SmallImage Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListViewItem Class : SmallImage Property

Gets or sets the small image that is displayed for the item.

Syntax

Visual Basic (Declaration)
Public Property SmallImage As ResourceHandle
Visual Basic (Usage) Copy Code
Dim instance As ListViewItem
Dim value As ResourceHandle

instance.SmallImage = value

value = instance.SmallImage
C#
public ResourceHandle SmallImage {get; set;}
Managed Extensions for C++
public: __property ResourceHandle* get_SmallImage();
public: __property void set_SmallImage(
   ResourceHandle* value
);
C++/CLI
public:
property ResourceHandle^ SmallImage {
   ResourceHandle^ get();
   void set (ResourceHandle^value);
}

Remarks

This property does not work and throws an exception if the owning listview has a ImageList set.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListViewItem Class
ListViewItem Members


SubItems Property

[image]
Gizmox.WebGUI.Forms
SubItems Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListViewItem Class : SubItems Property

Gets the sub items.

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
<SRDescriptionAttribute("The SubItems for this ListViewItem.")>
<SRCategoryAttribute("Data")>
Public ReadOnly Property SubItems As ListViewItem.ListViewSubItemCollection
Visual Basic (Usage) Copy Code
Dim instance As ListViewItem
Dim value As ListViewItem.ListViewSubItemCollection

value = instance.SubItems
C#
[DesignerSerializationVisibilityAttribute()]
[SRDescriptionAttribute("The SubItems for this ListViewItem.")]
[SRCategoryAttribute("Data")]
public ListViewItem.ListViewSubItemCollection SubItems {get;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
[SRDescriptionAttribute("The SubItems for this ListViewItem.")]
[SRCategoryAttribute("Data")]
public: __property ListViewItem.ListViewSubItemCollection* get_SubItems();
C++/CLI
[DesignerSerializationVisibilityAttribute()]
[SRDescriptionAttribute("The SubItems for this ListViewItem.")]
[SRCategoryAttribute("Data")]
public:
property ListViewItem::ListViewSubItemCollection^ SubItems {
   ListViewItem::ListViewSubItemCollection^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListViewItem Class
ListViewItem Members


Text Property

[image]
Gizmox.WebGUI.Forms
Text Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListViewItem Class : Text Property

Gets or sets the list view item text.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property Text As String
Visual Basic (Usage) Copy Code
Dim instance As ListViewItem
Dim value As String

instance.Text = value

value = instance.Text
C#
[DefaultValueAttribute()]
public string Text {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property string* get_Text();
public: __property void set_Text(
   string* value
);
C++/CLI
[DefaultValueAttribute()]
public:
property String^ Text {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListViewItem Class
ListViewItem Members


UseItemStyleForSubItems Property

[image]
Gizmox.WebGUI.Forms
UseItemStyleForSubItems Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListViewItem Class : UseItemStyleForSubItems Property

Gets or sets a value indicating whether the Font, ForeColor, and BackColor properties for the item are used for all its subitems.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Appearance")>
<DefaultValueAttribute()>
Public Property UseItemStyleForSubItems As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ListViewItem
Dim value As Boolean

instance.UseItemStyleForSubItems = value

value = instance.UseItemStyleForSubItems
C#
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
public bool UseItemStyleForSubItems {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
public: __property bool get_UseItemStyleForSubItems();
public: __property void set_UseItemStyleForSubItems(
   bool value
);
C++/CLI
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
public:
property bool UseItemStyleForSubItems {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListViewItem Class
ListViewItem Members


ListViewItem.ListViewSubItem Class

[image]
Gizmox.WebGUI.Forms
ListViewItem.ListViewSubItem Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ListViewItem.ListViewSubItem Class

Represents a subitem of a ListViewItem .

Syntax

Visual Basic (Declaration)
<ClientControllerAttribute()>
<DesignTimeControllerAttribute()>
<DesignTimeVisibleAttribute()>
<TypeConverterAttribute("Gizmox.WebGUI.Forms.ListViewSubItemConverter, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d")>
Public Class ListViewItem.ListViewSubItem
Visual Basic (Usage) Copy Code
Dim instance As ListViewItem.ListViewSubItem
C#
[ClientControllerAttribute()]
[DesignTimeControllerAttribute()]
[DesignTimeVisibleAttribute()]
[TypeConverterAttribute("Gizmox.WebGUI.Forms.ListViewSubItemConverter, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d")]
public class ListViewItem.ListViewSubItem
Managed Extensions for C++
[ClientControllerAttribute()]
[DesignTimeControllerAttribute()]
[DesignTimeVisibleAttribute()]
[TypeConverterAttribute("Gizmox.WebGUI.Forms.ListViewSubItemConverter, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d")]
public __gc class ListViewItem.ListViewSubItem
C++/CLI
[ClientControllerAttribute()]
[DesignTimeControllerAttribute()]
[DesignTimeVisibleAttribute()]
[TypeConverterAttribute("Gizmox.WebGUI.Forms.ListViewSubItemConverter, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d")]
public ref class ListViewItem.ListViewSubItem

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ListViewItem.ListViewSubItem

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

ListViewItem.ListViewSubItem Members
Gizmox.WebGUI.Forms Namespace


ListViewItem.ListViewSubItem Class Members

[image]
Gizmox.WebGUI.Forms
ListViewItem.ListViewSubItem Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : ListViewItem.ListViewSubItem Class

The following tables list the members exposed by ListViewItem.ListViewSubItem.

Public Constructors

 | Name | Description
Public Constructor | ListViewItem.ListViewSubItem Constructor | Overloaded. Creates a new ListViewItem.ListViewSubItem instance.
Top

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the color of the back.
Public Property | Font | Gets or sets the font.
Public Property | ForeColor | Gets or sets the color of the fore.
Public Property | Text | Gets or sets the text.
Top

Public Methods

 | Name | Description
Public Method | ResetStyle | Resets the style.
Public Method | ToString | Overridden. Returns the sub item text value.
Top

See Also

Reference

ListViewItem.ListViewSubItem Class
Gizmox.WebGUI.Forms Namespace


ListViewItem.ListViewSubItem Constructor

[image]
Gizmox.WebGUI.Forms
ListViewItem.ListViewSubItem Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListViewItem.ListViewSubItem Class : ListViewItem.ListViewSubItem Constructor

Creates a new ListViewItem.ListViewSubItem instance.

Overload List

Overload | Description
ListViewItem.ListViewSubItem Constructor() | Creates a new ListViewItem.ListViewSubItem instance.
ListViewItem.ListViewSubItem Constructor(ListViewItem,String) | Creates a new ListViewItem.ListViewSubItem instance.
ListViewItem.ListViewSubItem Constructor(ListViewItem,String,Color,Color,Font) | Creates a new ListViewItem.ListViewSubItem instance.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListViewItem.ListViewSubItem Class
ListViewItem.ListViewSubItem Members


ListViewItem.ListViewSubItem Constructor()

[image]
Gizmox.WebGUI.Forms
ListViewItem.ListViewSubItem Constructor()
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListViewItem.ListViewSubItem Class > ListViewItem.ListViewSubItem Constructor : ListViewItem.ListViewSubItem Constructor()

Creates a new ListViewItem.ListViewSubItem instance.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ListViewItem.ListViewSubItem()
C#
public ListViewItem.ListViewSubItem()
Managed Extensions for C++
public: ListViewItem.ListViewSubItem();
C++/CLI
public:
ListViewItem.ListViewSubItem();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListViewItem.ListViewSubItem Class
ListViewItem.ListViewSubItem Members
Overload List


ListViewItem.ListViewSubItem Constructor(ListViewItem,String)

[image]
Gizmox.WebGUI.Forms
ListViewItem.ListViewSubItem Constructor(ListViewItem,String)
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListViewItem.ListViewSubItem Class > ListViewItem.ListViewSubItem Constructor : ListViewItem.ListViewSubItem Constructor(ListViewItem,String)

objListViewItem
The owner list view.
strText
The sub item text.
Creates a new ListViewItem.ListViewSubItem instance.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal objListViewItem As ListViewItem, _
   ByVal strText As String _
)
Visual Basic (Usage) Copy Code
Dim objListViewItem As ListViewItem
Dim strText As String

Dim instance As ListViewItem.ListViewSubItem(objListViewItem, strText)
C#
public ListViewItem.ListViewSubItem(
   ListViewItem objListViewItem,
   string strText
)
Managed Extensions for C++
public: ListViewItem.ListViewSubItem(
   ListViewItem* objListViewItem,
   string* strText
)
C++/CLI
public:
ListViewItem.ListViewSubItem(
   ListViewItem^ objListViewItem,
   String^ strText
)

Parameters

objListViewItem
The owner list view.
strText
The sub item text.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListViewItem.ListViewSubItem Class
ListViewItem.ListViewSubItem Members
Overload List


ListViewItem.ListViewSubItem Constructor(ListViewItem,String,Color,Color,Font)

[image]
Gizmox.WebGUI.Forms
ListViewItem.ListViewSubItem Constructor(ListViewItem,String,Color,Color,Font)
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListViewItem.ListViewSubItem Class > ListViewItem.ListViewSubItem Constructor : ListViewItem.ListViewSubItem Constructor(ListViewItem,String,Color,Color,Font)

objListViewItem
The owner list view.
strText
The sub item text.
objForeColor
The sub item fore color.
objBackColor
The sub item back color.
objFont
The sub item font.
Creates a new ListViewItem.ListViewSubItem instance.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal objListViewItem As ListViewItem, _
   ByVal strText As String, _
   ByVal objForeColor As Color, _
   ByVal objBackColor As Color, _
   ByVal objFont As Font _
)
Visual Basic (Usage) Copy Code
Dim objListViewItem As ListViewItem
Dim strText As String
Dim objForeColor As Color
Dim objBackColor As Color
Dim objFont As Font

Dim instance As ListViewItem.ListViewSubItem(objListViewItem, strText, objForeColor, objBackColor, objFont)
C#
public ListViewItem.ListViewSubItem(
   ListViewItem objListViewItem,
   string strText,
   Color objForeColor,
   Color objBackColor,
   Font objFont
)
Managed Extensions for C++
public: ListViewItem.ListViewSubItem(
   ListViewItem* objListViewItem,
   string* strText,
   Color objForeColor,
   Color objBackColor,
   Font* objFont
)
C++/CLI
public:
ListViewItem.ListViewSubItem(
   ListViewItem^ objListViewItem,
   String^ strText,
   Color objForeColor,
   Color objBackColor,
   Font^ objFont
)

Parameters

objListViewItem
The owner list view.
strText
The sub item text.
objForeColor
The sub item fore color.
objBackColor
The sub item back color.
objFont
The sub item font.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListViewItem.ListViewSubItem Class
ListViewItem.ListViewSubItem Members
Overload List


ListViewItem.ListViewSubItem Class Methods

[image]
Gizmox.WebGUI.Forms
ListViewItem.ListViewSubItem Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ListViewItem.ListViewSubItem Class

For a list of all members of this type, see ListViewItem.ListViewSubItem members.

Public Methods

 | Name | Description
Public Method | ResetStyle | Resets the style.
Public Method | ToString | Overridden. Returns the sub item text value.
Top

See Also

Reference

ListViewItem.ListViewSubItem Class
Gizmox.WebGUI.Forms Namespace


ResetStyle Method

[image]
Gizmox.WebGUI.Forms
ResetStyle Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListViewItem.ListViewSubItem Class : ResetStyle Method

Resets the style.

Syntax

Visual Basic (Declaration)
Public Sub ResetStyle()
Visual Basic (Usage) Copy Code
Dim instance As ListViewItem.ListViewSubItem

instance.ResetStyle()
C#
public void ResetStyle()
Managed Extensions for C++
public: void ResetStyle();
C++/CLI
public:
void ResetStyle();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListViewItem.ListViewSubItem Class
ListViewItem.ListViewSubItem Members


ToString Method

[image]
Gizmox.WebGUI.Forms
ToString Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListViewItem.ListViewSubItem Class : ToString Method

Returns the sub item text value.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As ListViewItem.ListViewSubItem
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListViewItem.ListViewSubItem Class
ListViewItem.ListViewSubItem Members


ListViewItem.ListViewSubItem Class Properties

[image]
Gizmox.WebGUI.Forms
ListViewItem.ListViewSubItem Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ListViewItem.ListViewSubItem Class

For a list of all members of this type, see ListViewItem.ListViewSubItem members.

Public Properties

 | Name | Description
Public Property | BackColor | Gets or sets the color of the back.
Public Property | Font | Gets or sets the font.
Public Property | ForeColor | Gets or sets the color of the fore.
Public Property | Text | Gets or sets the text.
Top

See Also

Reference

ListViewItem.ListViewSubItem Class
Gizmox.WebGUI.Forms Namespace


BackColor Property

[image]
Gizmox.WebGUI.Forms
BackColor Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListViewItem.ListViewSubItem Class : BackColor Property

Gets or sets the color of the back.

Syntax

Visual Basic (Declaration)
Public Property BackColor As Color
Visual Basic (Usage) Copy Code
Dim instance As ListViewItem.ListViewSubItem
Dim value As Color

instance.BackColor = value

value = instance.BackColor
C#
public Color BackColor {get; set;}
Managed Extensions for C++
public: __property Color get_BackColor();
public: __property void set_BackColor(
   Color value
);
C++/CLI
public:
property Color BackColor {
   Color get();
   void set (Colorvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListViewItem.ListViewSubItem Class
ListViewItem.ListViewSubItem Members


Font Property

[image]
Gizmox.WebGUI.Forms
Font Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListViewItem.ListViewSubItem Class : Font Property

Gets or sets the font.

Syntax

Visual Basic (Declaration)
Public Property Font As Font
Visual Basic (Usage) Copy Code
Dim instance As ListViewItem.ListViewSubItem
Dim value As Font

instance.Font = value

value = instance.Font
C#
public Font Font {get; set;}
Managed Extensions for C++
public: __property Font* get_Font();
public: __property void set_Font(
   Font* value
);
C++/CLI
public:
property Font^ Font {
   Font^ get();
   void set (Font^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListViewItem.ListViewSubItem Class
ListViewItem.ListViewSubItem Members


ForeColor Property

[image]
Gizmox.WebGUI.Forms
ForeColor Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListViewItem.ListViewSubItem Class : ForeColor Property

Gets or sets the color of the fore.

Syntax

Visual Basic (Declaration)
Public Property ForeColor As Color
Visual Basic (Usage) Copy Code
Dim instance As ListViewItem.ListViewSubItem
Dim value As Color

instance.ForeColor = value

value = instance.ForeColor
C#
public Color ForeColor {get; set;}
Managed Extensions for C++
public: __property Color get_ForeColor();
public: __property void set_ForeColor(
   Color value
);
C++/CLI
public:
property Color ForeColor {
   Color get();
   void set (Colorvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListViewItem.ListViewSubItem Class
ListViewItem.ListViewSubItem Members


Text Property

[image]
Gizmox.WebGUI.Forms
Text Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListViewItem.ListViewSubItem Class : Text Property

Gets or sets the text.

Syntax

Visual Basic (Declaration)
Public Property Text As String
Visual Basic (Usage) Copy Code
Dim instance As ListViewItem.ListViewSubItem
Dim value As String

instance.Text = value

value = instance.Text
C#
public string Text {get; set;}
Managed Extensions for C++
public: __property string* get_Text();
public: __property void set_Text(
   string* value
);
C++/CLI
public:
property String^ Text {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListViewItem.ListViewSubItem Class
ListViewItem.ListViewSubItem Members


ListViewItem.ListViewSubItemCollection Class

[image]
Gizmox.WebGUI.Forms
ListViewItem.ListViewSubItemCollection Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ListViewItem.ListViewSubItemCollection Class

Represents a collection of ListViewSubItem objects stored in a ListViewItem .

Object Model

Syntax

Visual Basic (Declaration)
<ClientControllerAttribute()>
<DesignTimeControllerAttribute()>
<DefaultMemberAttribute("Item")>
Public Class ListViewItem.ListViewSubItemCollection
Visual Basic (Usage) Copy Code
Dim instance As ListViewItem.ListViewSubItemCollection
C#
[ClientControllerAttribute()]
[DesignTimeControllerAttribute()]
[DefaultMemberAttribute("Item")]
public class ListViewItem.ListViewSubItemCollection
Managed Extensions for C++
[ClientControllerAttribute()]
[DesignTimeControllerAttribute()]
[DefaultMemberAttribute("Item")]
public __gc class ListViewItem.ListViewSubItemCollection
C++/CLI
[ClientControllerAttribute()]
[DesignTimeControllerAttribute()]
[DefaultMemberAttribute("Item")]
public ref class ListViewItem.ListViewSubItemCollection

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ListViewItem.ListViewSubItemCollection

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

ListViewItem.ListViewSubItemCollection Members
Gizmox.WebGUI.Forms Namespace


ListViewItem.ListViewSubItemCollection Class Members

[image]
Gizmox.WebGUI.Forms
ListViewItem.ListViewSubItemCollection Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : ListViewItem.ListViewSubItemCollection Class

The following tables list the members exposed by ListViewItem.ListViewSubItemCollection.

Public Constructors

 | Name | Description
Public Constructor | ListViewItem.ListViewSubItemCollection Constructor | Creates a new ListViewItem.ListViewSubItemCollection instance.
Top

Public Properties

 | Name | Description
Public Property | Count | Gets the count.
Public Property | IsFixedSize |
Public Property | IsReadOnly | Gets a value indicating whether this instance is read only.
Public Property | IsSynchronized | Gets a value indicating whether this instance is synchronized.
Public Property | Item | Gets or sets the ListViewItem.ListViewSubItem at the specified index.
Public Property | SyncRoot | Gets the sync root.
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Adds the specified sub item.
Public Method | AddRange | Overloaded. Adds a range of sub items.
Public Method | Clear | Clears the sub items.
Public Method | Contains | Checks if a sub item is contained.
Public Method | CopyTo | Copies to an array.
Public Method | GetEnumerator | Gets an enumerator.
Public Method | IndexOf | returns the indexes of a given sub item.
Public Method | Insert | Inserts a sub item at a specified index.
Public Method | Remove | Removes the specified sub item.
Public Method | RemoveAt | Removes a sub item at a specified index.
Top

See Also

Reference

ListViewItem.ListViewSubItemCollection Class
Gizmox.WebGUI.Forms Namespace


ListViewItem.ListViewSubItemCollection Constructor

[image]
Gizmox.WebGUI.Forms
ListViewItem.ListViewSubItemCollection Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListViewItem.ListViewSubItemCollection Class : ListViewItem.ListViewSubItemCollection Constructor

objListViewItem
Owner list view item.
Creates a new ListViewItem.ListViewSubItemCollection instance.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal objListViewItem As ListViewItem _
)
Visual Basic (Usage) Copy Code
Dim objListViewItem As ListViewItem

Dim instance As ListViewItem.ListViewSubItemCollection(objListViewItem)
C#
public ListViewItem.ListViewSubItemCollection(
   ListViewItem objListViewItem
)
Managed Extensions for C++
public: ListViewItem.ListViewSubItemCollection(
   ListViewItem* objListViewItem
)
C++/CLI
public:
ListViewItem.ListViewSubItemCollection(
   ListViewItem^ objListViewItem
)

Parameters

objListViewItem
Owner list view item.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListViewItem.ListViewSubItemCollection Class
ListViewItem.ListViewSubItemCollection Members


ListViewItem.ListViewSubItemCollection Class Methods

[image]
Gizmox.WebGUI.Forms
ListViewItem.ListViewSubItemCollection Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ListViewItem.ListViewSubItemCollection Class

For a list of all members of this type, see ListViewItem.ListViewSubItemCollection members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Adds the specified sub item.
Public Method | AddRange | Overloaded. Adds a range of sub items.
Public Method | Clear | Clears the sub items.
Public Method | Contains | Checks if a sub item is contained.
Public Method | CopyTo | Copies to an array.
Public Method | GetEnumerator | Gets an enumerator.
Public Method | IndexOf | returns the indexes of a given sub item.
Public Method | Insert | Inserts a sub item at a specified index.
Public Method | Remove | Removes the specified sub item.
Public Method | RemoveAt | Removes a sub item at a specified index.
Top

See Also

Reference

ListViewItem.ListViewSubItemCollection Class
Gizmox.WebGUI.Forms Namespace


Add Method

[image]
Gizmox.WebGUI.Forms
Add Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListViewItem.ListViewSubItemCollection Class : Add Method

Adds the specified sub item.

Overload List

Overload | Description
Add(ListViewSubItem) | Adds the specified sub item.
Add(String) | Adds a new sub item.
Add(String,Color,Color,Font) | Adds the a sub item with styles.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListViewItem.ListViewSubItemCollection Class
ListViewItem.ListViewSubItemCollection Members


Add(ListViewSubItem) Method

[image]
Gizmox.WebGUI.Forms
Add(ListViewSubItem) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListViewItem.ListViewSubItemCollection Class > Add Method : Add(ListViewSubItem) Method

objSubItem
Sub item.
Adds the specified sub item.

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal objSubItem As ListViewItem.ListViewSubItem _
) As ListViewItem.ListViewSubItem
Visual Basic (Usage) Copy Code
Dim instance As ListViewItem.ListViewSubItemCollection
Dim objSubItem As ListViewItem.ListViewSubItem
Dim value As ListViewItem.ListViewSubItem

value = instance.Add(objSubItem)
C#
public ListViewItem.ListViewSubItem Add(
   ListViewItem.ListViewSubItem objSubItem
)
Managed Extensions for C++
public: ListViewItem.ListViewSubItem* Add(
   ListViewItem.ListViewSubItem* objSubItem
)
C++/CLI
public:
ListViewItem::ListViewSubItem^ Add(
   ListViewItem::ListViewSubItem^ objSubItem
)

Parameters

objSubItem
Sub item.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListViewItem.ListViewSubItemCollection Class
ListViewItem.ListViewSubItemCollection Members
Overload List


Add(String) Method

[image]
Gizmox.WebGUI.Forms
Add(String) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListViewItem.ListViewSubItemCollection Class > Add Method : Add(String) Method

strText
STR text.
Adds a new sub item.

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal strText As String _
) As ListViewItem.ListViewSubItem
Visual Basic (Usage) Copy Code
Dim instance As ListViewItem.ListViewSubItemCollection
Dim strText As String
Dim value As ListViewItem.ListViewSubItem

value = instance.Add(strText)
C#
public ListViewItem.ListViewSubItem Add(
   string strText
)
Managed Extensions for C++
public: ListViewItem.ListViewSubItem* Add(
   string* strText
)
C++/CLI
public:
ListViewItem::ListViewSubItem^ Add(
   String^ strText
)

Parameters

strText
STR text.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListViewItem.ListViewSubItemCollection Class
ListViewItem.ListViewSubItemCollection Members
Overload List


Add(String,Color,Color,Font) Method

[image]
Gizmox.WebGUI.Forms
Add(String,Color,Color,Font) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListViewItem.ListViewSubItemCollection Class > Add Method : Add(String,Color,Color,Font) Method

strText
The sub item text.
objForeColor
The sub item fore color.
objBackColor
The sub item back color.
objFont
The sub item font.
Adds the a sub item with styles.

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal strText As String, _
   ByVal objForeColor As Color, _
   ByVal objBackColor As Color, _
   ByVal objFont As Font _
) As ListViewItem.ListViewSubItem
Visual Basic (Usage) Copy Code
Dim instance As ListViewItem.ListViewSubItemCollection
Dim strText As String
Dim objForeColor As Color
Dim objBackColor As Color
Dim objFont As Font
Dim value As ListViewItem.ListViewSubItem

value = instance.Add(strText, objForeColor, objBackColor, objFont)
C#
public ListViewItem.ListViewSubItem Add(
   string strText,
   Color objForeColor,
   Color objBackColor,
   Font objFont
)
Managed Extensions for C++
public: ListViewItem.ListViewSubItem* Add(
   string* strText,
   Color objForeColor,
   Color objBackColor,
   Font* objFont
)
C++/CLI
public:
ListViewItem::ListViewSubItem^ Add(
   String^ strText,
   Color objForeColor,
   Color objBackColor,
   Font^ objFont
)

Parameters

strText
The sub item text.
objForeColor
The sub item fore color.
objBackColor
The sub item back color.
objFont
The sub item font.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListViewItem.ListViewSubItemCollection Class
ListViewItem.ListViewSubItemCollection Members
Overload List


AddRange Method

[image]
Gizmox.WebGUI.Forms
AddRange Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListViewItem.ListViewSubItemCollection Class : AddRange Method

Adds a range of sub items.

Overload List

Overload | Description
AddRange(ListViewSubItem[]) | Adds a range of sub items.
AddRange(String[]) | Adds a range of items.
AddRange(String[],Color,Color,Font) | Adds a range of sub items with styles.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListViewItem.ListViewSubItemCollection Class
ListViewItem.ListViewSubItemCollection Members


AddRange(ListViewSubItem[]) Method

[image]
Gizmox.WebGUI.Forms
AddRange(ListViewSubItem[]) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListViewItem.ListViewSubItemCollection Class > AddRange Method : AddRange(ListViewSubItem[]) Method

objItems
Sub items array.
Adds a range of sub items.

Syntax

Visual Basic (Declaration)
Public Overloads Sub AddRange( _
   ByVal objItems() As ListViewItem.ListViewSubItem _
)
Visual Basic (Usage) Copy Code
Dim instance As ListViewItem.ListViewSubItemCollection
Dim objItems() As ListViewItem.ListViewSubItem

instance.AddRange(objItems)
C#
public void AddRange(
   ListViewItem.ListViewSubItem[] objItems
)
Managed Extensions for C++
public: void AddRange(
   ListViewItem.ListViewSubItem*[]* objItems
)
C++/CLI
public:
void AddRange(
   array<ListViewItem::ListViewSubItem^>^ objItems
)

Parameters

objItems
Sub items array.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListViewItem.ListViewSubItemCollection Class
ListViewItem.ListViewSubItemCollection Members
Overload List


AddRange(String[]) Method

[image]
Gizmox.WebGUI.Forms
AddRange(String[]) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListViewItem.ListViewSubItemCollection Class > AddRange Method : AddRange(String[]) Method

strItems
Range of items.
Adds a range of items.

Syntax

Visual Basic (Declaration)
Public Overloads Sub AddRange( _
   ByVal strItems() As String _
)
Visual Basic (Usage) Copy Code
Dim instance As ListViewItem.ListViewSubItemCollection
Dim strItems() As String

instance.AddRange(strItems)
C#
public void AddRange(
   string[] strItems
)
Managed Extensions for C++
public: void AddRange(
   string*[]* strItems
)
C++/CLI
public:
void AddRange(
   array<String^>^ strItems
)

Parameters

strItems
Range of items.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListViewItem.ListViewSubItemCollection Class
ListViewItem.ListViewSubItemCollection Members
Overload List


AddRange(String[],Color,Color,Font) Method

[image]
Gizmox.WebGUI.Forms
AddRange(String[],Color,Color,Font) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListViewItem.ListViewSubItemCollection Class > AddRange Method : AddRange(String[],Color,Color,Font) Method

strItems
The sub items text array.
objForeColor
The sub item fore color.
objBackColor
The sub item back color.
objFont
The sub item font.
Adds a range of sub items with styles.

Syntax

Visual Basic (Declaration)
Public Overloads Sub AddRange( _
   ByVal strItems() As String, _
   ByVal objForeColor As Color, _
   ByVal objBackColor As Color, _
   ByVal objFont As Font _
)
Visual Basic (Usage) Copy Code
Dim instance As ListViewItem.ListViewSubItemCollection
Dim strItems() As String
Dim objForeColor As Color
Dim objBackColor As Color
Dim objFont As Font

instance.AddRange(strItems, objForeColor, objBackColor, objFont)
C#
public void AddRange(
   string[] strItems,
   Color objForeColor,
   Color objBackColor,
   Font objFont
)
Managed Extensions for C++
public: void AddRange(
   string*[]* strItems,
   Color objForeColor,
   Color objBackColor,
   Font* objFont
)
C++/CLI
public:
void AddRange(
   array<String^>^ strItems,
   Color objForeColor,
   Color objBackColor,
   Font^ objFont
)

Parameters

strItems
The sub items text array.
objForeColor
The sub item fore color.
objBackColor
The sub item back color.
objFont
The sub item font.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListViewItem.ListViewSubItemCollection Class
ListViewItem.ListViewSubItemCollection Members
Overload List


Clear Method

[image]
Gizmox.WebGUI.Forms
Clear Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListViewItem.ListViewSubItemCollection Class : Clear Method

Clears the sub items.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As ListViewItem.ListViewSubItemCollection

instance.Clear()
C#
public void Clear()
Managed Extensions for C++
public: void Clear();
C++/CLI
public:
void Clear();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListViewItem.ListViewSubItemCollection Class
ListViewItem.ListViewSubItemCollection Members


Contains Method

[image]
Gizmox.WebGUI.Forms
Contains Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListViewItem.ListViewSubItemCollection Class : Contains Method

objSubItem
A sub item.
Checks if a sub item is contained.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal objSubItem As ListViewItem.ListViewSubItem _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ListViewItem.ListViewSubItemCollection
Dim objSubItem As ListViewItem.ListViewSubItem
Dim value As Boolean

value = instance.Contains(objSubItem)
C#
public bool Contains(
   ListViewItem.ListViewSubItem objSubItem
)
Managed Extensions for C++
public: bool Contains(
   ListViewItem.ListViewSubItem* objSubItem
)
C++/CLI
public:
bool Contains(
   ListViewItem::ListViewSubItem^ objSubItem
)

Parameters

objSubItem
A sub item.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListViewItem.ListViewSubItemCollection Class
ListViewItem.ListViewSubItemCollection Members


CopyTo Method

[image]
Gizmox.WebGUI.Forms
CopyTo Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListViewItem.ListViewSubItemCollection Class : CopyTo Method

arrDest
Arr dest.
intIndex
Int index.
Copies to an array.

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal arrDest As Array, _
   ByVal intIndex As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As ListViewItem.ListViewSubItemCollection
Dim arrDest As Array
Dim intIndex As Integer

instance.CopyTo(arrDest, intIndex)
C#
public void CopyTo(
   Array arrDest,
   int intIndex
)
Managed Extensions for C++
public: void CopyTo(
   Array* arrDest,
   int intIndex
)
C++/CLI
public:
void CopyTo(
   Array^ arrDest,
   int intIndex
)

Parameters

arrDest
Arr dest.
intIndex
Int index.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListViewItem.ListViewSubItemCollection Class
ListViewItem.ListViewSubItemCollection Members


GetEnumerator Method

[image]
Gizmox.WebGUI.Forms
GetEnumerator Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListViewItem.ListViewSubItemCollection Class : GetEnumerator Method

Gets an enumerator.

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As ListViewItem.ListViewSubItemCollection
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListViewItem.ListViewSubItemCollection Class
ListViewItem.ListViewSubItemCollection Members


IndexOf Method

[image]
Gizmox.WebGUI.Forms
IndexOf Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListViewItem.ListViewSubItemCollection Class : IndexOf Method

objSubItem
A sub item.
returns the indexes of a given sub item.

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal objSubItem As ListViewItem.ListViewSubItem _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As ListViewItem.ListViewSubItemCollection
Dim objSubItem As ListViewItem.ListViewSubItem
Dim value As Integer

value = instance.IndexOf(objSubItem)
C#
public int IndexOf(
   ListViewItem.ListViewSubItem objSubItem
)
Managed Extensions for C++
public: int IndexOf(
   ListViewItem.ListViewSubItem* objSubItem
)
C++/CLI
public:
int IndexOf(
   ListViewItem::ListViewSubItem^ objSubItem
)

Parameters

objSubItem
A sub item.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListViewItem.ListViewSubItemCollection Class
ListViewItem.ListViewSubItemCollection Members


Insert Method

[image]
Gizmox.WebGUI.Forms
Insert Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListViewItem.ListViewSubItemCollection Class : Insert Method

intIndex
Index.
objSubItem
The sub item.
Inserts a sub item at a specified index.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal intIndex As Integer, _
   ByVal objSubItem As ListViewItem.ListViewSubItem _
)
Visual Basic (Usage) Copy Code
Dim instance As ListViewItem.ListViewSubItemCollection
Dim intIndex As Integer
Dim objSubItem As ListViewItem.ListViewSubItem

instance.Insert(intIndex, objSubItem)
C#
public void Insert(
   int intIndex,
   ListViewItem.ListViewSubItem objSubItem
)
Managed Extensions for C++
public: void Insert(
   int intIndex,
   ListViewItem.ListViewSubItem* objSubItem
)
C++/CLI
public:
void Insert(
   int intIndex,
   ListViewItem::ListViewSubItem^ objSubItem
)

Parameters

intIndex
Index.
objSubItem
The sub item.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListViewItem.ListViewSubItemCollection Class
ListViewItem.ListViewSubItemCollection Members


Remove Method

[image]
Gizmox.WebGUI.Forms
Remove Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListViewItem.ListViewSubItemCollection Class : Remove Method

objSubItem
Obj sub item.
Removes the specified sub item.

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal objSubItem As ListViewItem.ListViewSubItem _
)
Visual Basic (Usage) Copy Code
Dim instance As ListViewItem.ListViewSubItemCollection
Dim objSubItem As ListViewItem.ListViewSubItem

instance.Remove(objSubItem)
C#
public void Remove(
   ListViewItem.ListViewSubItem objSubItem
)
Managed Extensions for C++
public: void Remove(
   ListViewItem.ListViewSubItem* objSubItem
)
C++/CLI
public:
void Remove(
   ListViewItem::ListViewSubItem^ objSubItem
)

Parameters

objSubItem
Obj sub item.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListViewItem.ListViewSubItemCollection Class
ListViewItem.ListViewSubItemCollection Members


RemoveAt Method

[image]
Gizmox.WebGUI.Forms
RemoveAt Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListViewItem.ListViewSubItemCollection Class : RemoveAt Method

intIndex
Index.
Removes a sub item at a specified index.

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal intIndex As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As ListViewItem.ListViewSubItemCollection
Dim intIndex As Integer

instance.RemoveAt(intIndex)
C#
public void RemoveAt(
   int intIndex
)
Managed Extensions for C++
public: void RemoveAt(
   int intIndex
)
C++/CLI
public:
void RemoveAt(
   int intIndex
)

Parameters

intIndex
Index.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListViewItem.ListViewSubItemCollection Class
ListViewItem.ListViewSubItemCollection Members


ListViewItem.ListViewSubItemCollection Class Properties

[image]
Gizmox.WebGUI.Forms
ListViewItem.ListViewSubItemCollection Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ListViewItem.ListViewSubItemCollection Class

For a list of all members of this type, see ListViewItem.ListViewSubItemCollection members.

Public Properties

 | Name | Description
Public Property | Count | Gets the count.
Public Property | IsFixedSize |
Public Property | IsReadOnly | Gets a value indicating whether this instance is read only.
Public Property | IsSynchronized | Gets a value indicating whether this instance is synchronized.
Public Property | Item | Gets or sets the ListViewItem.ListViewSubItem at the specified index.
Public Property | SyncRoot | Gets the sync root.
Top

See Also

Reference

ListViewItem.ListViewSubItemCollection Class
Gizmox.WebGUI.Forms Namespace


Count Property

[image]
Gizmox.WebGUI.Forms
Count Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListViewItem.ListViewSubItemCollection Class : Count Property

Gets the count.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As ListViewItem.ListViewSubItemCollection
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListViewItem.ListViewSubItemCollection Class
ListViewItem.ListViewSubItemCollection Members


IsFixedSize Property

[image]
Gizmox.WebGUI.Forms
IsFixedSize Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListViewItem.ListViewSubItemCollection Class : IsFixedSize Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsFixedSize As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ListViewItem.ListViewSubItemCollection
Dim value As Boolean

value = instance.IsFixedSize
C#
public bool IsFixedSize {get;}
Managed Extensions for C++
public: __property bool get_IsFixedSize();
C++/CLI
public:
property bool IsFixedSize {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListViewItem.ListViewSubItemCollection Class
ListViewItem.ListViewSubItemCollection Members


IsReadOnly Property

[image]
Gizmox.WebGUI.Forms
IsReadOnly Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListViewItem.ListViewSubItemCollection Class : IsReadOnly Property

Gets a value indicating whether this instance is read only.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsReadOnly As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ListViewItem.ListViewSubItemCollection
Dim value As Boolean

value = instance.IsReadOnly
C#
public bool IsReadOnly {get;}
Managed Extensions for C++
public: __property bool get_IsReadOnly();
C++/CLI
public:
property bool IsReadOnly {
   bool get();
}

Return Value

true if this instance is read only; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListViewItem.ListViewSubItemCollection Class
ListViewItem.ListViewSubItemCollection Members


IsSynchronized Property

[image]
Gizmox.WebGUI.Forms
IsSynchronized Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListViewItem.ListViewSubItemCollection Class : IsSynchronized Property

Gets a value indicating whether this instance is synchronized.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsSynchronized As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ListViewItem.ListViewSubItemCollection
Dim value As Boolean

value = instance.IsSynchronized
C#
public bool IsSynchronized {get;}
Managed Extensions for C++
public: __property bool get_IsSynchronized();
C++/CLI
public:
property bool IsSynchronized {
   bool get();
}

Return Value

true if this instance is synchronized; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListViewItem.ListViewSubItemCollection Class
ListViewItem.ListViewSubItemCollection Members


Item Property

[image]
Gizmox.WebGUI.Forms
Item Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListViewItem.ListViewSubItemCollection Class : Item Property

index
Gets or sets the ListViewItem.ListViewSubItem at the specified index.

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal index As Integer _
) As ListViewItem.ListViewSubItem
Visual Basic (Usage) Copy Code
Dim instance As ListViewItem.ListViewSubItemCollection
Dim index As Integer
Dim value As ListViewItem.ListViewSubItem

instance.Item(index) = value

value = instance.Item(index)
C#
public ListViewItem.ListViewSubItem this[
   int index
]; {get; set;}
Managed Extensions for C++
public: __property ListViewItem.ListViewSubItem* get_Item(
   int index
);
public: __property void set_Item(
   int index,
   ListViewItem.ListViewSubItem* value
);
C++/CLI
public:
property ListViewItem::ListViewSubItem^ default [int] {
   ListViewItem::ListViewSubItem^ get(intindex);
   void set (intindex, ListViewItem::ListViewSubItem^value);
}

Parameters

index

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListViewItem.ListViewSubItemCollection Class
ListViewItem.ListViewSubItemCollection Members


SyncRoot Property

[image]
Gizmox.WebGUI.Forms
SyncRoot Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListViewItem.ListViewSubItemCollection Class : SyncRoot Property

Gets the sync root.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SyncRoot As Object
Visual Basic (Usage) Copy Code
Dim instance As ListViewItem.ListViewSubItemCollection
Dim value As Object

value = instance.SyncRoot
C#
public object SyncRoot {get;}
Managed Extensions for C++
public: __property Object* get_SyncRoot();
C++/CLI
public:
property Object^ SyncRoot {
   Object^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListViewItem.ListViewSubItemCollection Class
ListViewItem.ListViewSubItemCollection Members


ListViewItemConverter Class

[image]
Gizmox.WebGUI.Forms
ListViewItemConverter Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ListViewItemConverter Class

Provides a type converter to convert ListViewItem objects to and from various other representations.

Syntax

Visual Basic (Declaration)
Public Class ListViewItemConverter
   Inherits ExpandableObjectConverter
Visual Basic (Usage) Copy Code
Dim instance As ListViewItemConverter
C#
public class ListViewItemConverter : ExpandableObjectConverter
Managed Extensions for C++
public __gc class ListViewItemConverter : public ExpandableObjectConverter
C++/CLI
public ref class ListViewItemConverter : public ExpandableObjectConverter

Inheritance Hierarchy

System.Object
System.ComponentModel.TypeConverter
System.ComponentModel.ExpandableObjectConverter
Gizmox.WebGUI.Forms.ListViewItemConverter

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

ListViewItemConverter Members
Gizmox.WebGUI.Forms Namespace


ListViewItemConverter Class Members

[image]
Gizmox.WebGUI.Forms
ListViewItemConverter Class Members
See Also Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : ListViewItemConverter Class

The following tables list the members exposed by ListViewItemConverter.

Public Constructors

 | Name | Description
Public Constructor | ListViewItemConverter Constructor | Initializes a new instance of the ListViewItemConverter class.
Top

Public Methods

 | Name | Description
Public Method | CanConvertFrom | Overloaded. Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from System.ComponentModel.TypeConverter)
Public Method | CanConvertTo | Overloaded. Overridden. Returns whether this converter can convert the object to the specified type, using the specified context.
Public Method | ConvertFrom | Overloaded. Converts the given value to the type of this converter. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertFromInvariantString | Overloaded. Converts the given string to the type of this converter, using the invariant culture. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertFromString | Overloaded. Converts the specified text to an object. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertTo | Overloaded. Overridden. Converts the given value object to the specified type, using the specified context and culture information.
Public Method | ConvertToInvariantString | Overloaded. Converts the specified value to a culture-invariant string representation. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertToString | Overloaded. Converts the specified value to a string representation. (Inherited from System.ComponentModel.TypeConverter)
Public Method | CreateInstance | Overloaded. Re-creates an Object given a set of property values for the object. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetCreateInstanceSupported | Overloaded. Returns whether changing a value on this object requires a call to the CreateInstance method to create a new value. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetProperties | Overloaded. Returns a collection of properties for the type of array specified by the value parameter. (Inherited from System.ComponentModel.ExpandableObjectConverter)
Public Method | GetPropertiesSupported | Overloaded. Gets a value indicating whether this object supports properties using the specified context. (Inherited from System.ComponentModel.ExpandableObjectConverter)
Public Method | GetStandardValues | Overloaded. Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValuesExclusive | Overloaded. Returns whether the collection of standard values returned from GetStandardValues is an exclusive list. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValuesSupported | Overloaded. Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from System.ComponentModel.TypeConverter)
Public Method | IsValid | Overloaded. Returns whether the given value object is valid for this type. (Inherited from System.ComponentModel.TypeConverter)
Top

Protected Methods

 | Name | Description
Protected Method | GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from System.ComponentModel.TypeConverter)
Protected Method | GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from System.ComponentModel.TypeConverter)
Protected Method | SortProperties | (Inherited from System.ComponentModel.TypeConverter)
Top

See Also

Reference

ListViewItemConverter Class
Gizmox.WebGUI.Forms Namespace


ListViewItemConverter Constructor

[image]
Gizmox.WebGUI.Forms
ListViewItemConverter Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListViewItemConverter Class : ListViewItemConverter Constructor

Initializes a new instance of the ListViewItemConverter class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ListViewItemConverter()
C#
public ListViewItemConverter()
Managed Extensions for C++
public: ListViewItemConverter();
C++/CLI
public:
ListViewItemConverter();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListViewItemConverter Class
ListViewItemConverter Members


ListViewItemConverter Class Methods

[image]
Gizmox.WebGUI.Forms
ListViewItemConverter Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ListViewItemConverter Class

For a list of all members of this type, see ListViewItemConverter members.

Public Methods

 | Name | Description
Public Method | CanConvertFrom | Overloaded. Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from System.ComponentModel.TypeConverter)
Public Method | CanConvertTo | Overloaded. Overridden. Returns whether this converter can convert the object to the specified type, using the specified context.
Public Method | ConvertFrom | Overloaded. Converts the given value to the type of this converter. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertFromInvariantString | Overloaded. Converts the given string to the type of this converter, using the invariant culture. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertFromString | Overloaded. Converts the specified text to an object. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertTo | Overloaded. Overridden. Converts the given value object to the specified type, using the specified context and culture information.
Public Method | ConvertToInvariantString | Overloaded. Converts the specified value to a culture-invariant string representation. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertToString | Overloaded. Converts the specified value to a string representation. (Inherited from System.ComponentModel.TypeConverter)
Public Method | CreateInstance | Overloaded. Re-creates an Object given a set of property values for the object. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetCreateInstanceSupported | Overloaded. Returns whether changing a value on this object requires a call to the CreateInstance method to create a new value. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetProperties | Overloaded. Returns a collection of properties for the type of array specified by the value parameter. (Inherited from System.ComponentModel.ExpandableObjectConverter)
Public Method | GetPropertiesSupported | Overloaded. Gets a value indicating whether this object supports properties using the specified context. (Inherited from System.ComponentModel.ExpandableObjectConverter)
Public Method | GetStandardValues | Overloaded. Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValuesExclusive | Overloaded. Returns whether the collection of standard values returned from GetStandardValues is an exclusive list. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValuesSupported | Overloaded. Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from System.ComponentModel.TypeConverter)
Public Method | IsValid | Overloaded. Returns whether the given value object is valid for this type. (Inherited from System.ComponentModel.TypeConverter)
Top

Protected Methods

 | Name | Description
Protected Method | GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from System.ComponentModel.TypeConverter)
Protected Method | GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from System.ComponentModel.TypeConverter)
Protected Method | SortProperties | (Inherited from System.ComponentModel.TypeConverter)
Top

See Also

Reference

ListViewItemConverter Class
Gizmox.WebGUI.Forms Namespace


CanConvertTo Method

[image]
Gizmox.WebGUI.Forms
CanConvertTo Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListViewItemConverter Class : CanConvertTo Method

Returns whether this converter can convert the object to the specified type, using the specified context.

Overload List

Overload | Description
CanConvertTo(ITypeDescriptorContext,Type) | Returns whether this converter can convert the object to the specified type, using the specified context.
CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from System.ComponentModel.TypeConverter)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListViewItemConverter Class
ListViewItemConverter Members


CanConvertTo(ITypeDescriptorContext,Type) Method

[image]
Gizmox.WebGUI.Forms
CanConvertTo(ITypeDescriptorContext,Type) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListViewItemConverter Class > CanConvertTo Method : CanConvertTo(ITypeDescriptorContext,Type) Method

context
An ITypeDescriptorContext that provides a format context.
destinationType
A Type that represents the type you want to convert to.
Returns whether this converter can convert the object to the specified type, using the specified context.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function CanConvertTo( _
   ByVal context As ITypeDescriptorContext, _
   ByVal destinationType As Type _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ListViewItemConverter
Dim context As ITypeDescriptorContext
Dim destinationType As Type
Dim value As Boolean

value = instance.CanConvertTo(context, destinationType)
C#
public override bool CanConvertTo(
   ITypeDescriptorContext context,
   Type destinationType
)
Managed Extensions for C++
public: bool CanConvertTo(
   ITypeDescriptorContext* context,
   Type* destinationType
) override
C++/CLI
public:
bool CanConvertTo(
   ITypeDescriptorContext^ context,
   Type^ destinationType
) override

Parameters

context
An ITypeDescriptorContext that provides a format context.
destinationType
A Type that represents the type you want to convert to.

Return Value

true if this converter can perform the conversion; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListViewItemConverter Class
ListViewItemConverter Members
Overload List


ConvertTo Method

[image]
Gizmox.WebGUI.Forms
ConvertTo Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListViewItemConverter Class : ConvertTo Method

Converts the given value object to the specified type, using the specified context and culture information.

Overload List

Overload | Description
ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) | Converts the given value object to the specified type, using the specified context and culture information.
ConvertTo(Object,Type) | Converts the given value object to the specified type, using the arguments. (Inherited from System.ComponentModel.TypeConverter)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListViewItemConverter Class
ListViewItemConverter Members


ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) Method

[image]
Gizmox.WebGUI.Forms
ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListViewItemConverter Class > ConvertTo Method : ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) Method

context
An ITypeDescriptorContext that provides a format context.
culture
A CultureInfo. If null is passed, the current culture is assumed.
value
The Object to convert.
destinationType
The Type to convert the value parameter to.
Converts the given value object to the specified type, using the specified context and culture information.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function ConvertTo( _
   ByVal context As ITypeDescriptorContext, _
   ByVal culture As CultureInfo, _
   ByVal value As Object, _
   ByVal destinationType As Type _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As ListViewItemConverter
Dim context As ITypeDescriptorContext
Dim culture As CultureInfo
Dim value As Object
Dim destinationType As Type
Dim value As Object

value = instance.ConvertTo(context, culture, value, destinationType)
C#
public override object ConvertTo(
   ITypeDescriptorContext context,
   CultureInfo culture,
   object value,
   Type destinationType
)
Managed Extensions for C++
public: Object* ConvertTo(
   ITypeDescriptorContext* context,
   CultureInfo* culture,
   Object* value,
   Type* destinationType
) override
C++/CLI
public:
Object^ ConvertTo(
   ITypeDescriptorContext^ context,
   CultureInfo^ culture,
   Object^ value,
   Type^ destinationType
) override

Parameters

context
An ITypeDescriptorContext that provides a format context.
culture
A CultureInfo. If null is passed, the current culture is assumed.
value
The Object to convert.
destinationType
The Type to convert the value parameter to.

Return Value

An Object that represents the converted value.

Exceptions

Exception | Description
NotSupportedException | The conversion cannot be performed.
ArgumentNullException | The destinationType parameter is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListViewItemConverter Class
ListViewItemConverter Members
Overload List


ListViewItemEventArgs Class

[image]
Gizmox.WebGUI.Forms
ListViewItemEventArgs Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ListViewItemEventArgs Class

Object Model

Syntax

Visual Basic (Declaration)
Public Class ListViewItemEventArgs
   Inherits EventArgs
Visual Basic (Usage) Copy Code
Dim instance As ListViewItemEventArgs
C#
public class ListViewItemEventArgs : EventArgs
Managed Extensions for C++
public __gc class ListViewItemEventArgs : public EventArgs
C++/CLI
public ref class ListViewItemEventArgs : public EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gizmox.WebGUI.Forms.ListViewItemEventArgs

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

ListViewItemEventArgs Members
Gizmox.WebGUI.Forms Namespace


ListViewItemEventArgs Class Members

[image]
Gizmox.WebGUI.Forms
ListViewItemEventArgs Class Members
See Also Fields Send Feedback
Gizmox.WebGUI.Forms Namespace : ListViewItemEventArgs Class

The following tables list the members exposed by ListViewItemEventArgs.

Public Constructors

 | Name | Description
Public Constructor | ListViewItemEventArgs Constructor | Creates a new ListViewItemEventArgs instance.
Top

Public Fields

 | Name | Description
Public Field | Item |
Top

See Also

Reference

ListViewItemEventArgs Class
Gizmox.WebGUI.Forms Namespace


ListViewItemEventArgs Constructor

[image]
Gizmox.WebGUI.Forms
ListViewItemEventArgs Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListViewItemEventArgs Class : ListViewItemEventArgs Constructor

objListViewItem
Item.
Creates a new ListViewItemEventArgs instance.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal objListViewItem As ListViewItem _
)
Visual Basic (Usage) Copy Code
Dim objListViewItem As ListViewItem

Dim instance As ListViewItemEventArgs(objListViewItem)
C#
public ListViewItemEventArgs(
   ListViewItem objListViewItem
)
Managed Extensions for C++
public: ListViewItemEventArgs(
   ListViewItem* objListViewItem
)
C++/CLI
public:
ListViewItemEventArgs(
   ListViewItem^ objListViewItem
)

Parameters

objListViewItem
Item.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListViewItemEventArgs Class
ListViewItemEventArgs Members


ListViewItemEventArgs Class Fields

[image]
Gizmox.WebGUI.Forms
ListViewItemEventArgs Class Fields
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ListViewItemEventArgs Class

For a list of all members of this type, see ListViewItemEventArgs members.

Public Fields

 | Name | Description
Public Field | Item |
Top

See Also

Reference

ListViewItemEventArgs Class
Gizmox.WebGUI.Forms Namespace


Item Field

[image]
Gizmox.WebGUI.Forms
Item Field
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListViewItemEventArgs Class : Item Field

Syntax

Visual Basic (Declaration)
Public ReadOnly Item As ListViewItem
Visual Basic (Usage) Copy Code
Dim instance As ListViewItemEventArgs
Dim value As ListViewItem

value = instance.Item
C#
public readonly ListViewItem Item
Managed Extensions for C++
public: readonly ListViewItem* Item
C++/CLI
public:
readonly ListViewItem^ Item

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListViewItemEventArgs Class
ListViewItemEventArgs Members


ListViewItemSorter Class

[image]
Gizmox.WebGUI.Forms
ListViewItemSorter Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ListViewItemSorter Class

Gets or sets the sorting comparer for the control.

Syntax

Visual Basic (Declaration)
Public Class ListViewItemSorter
Visual Basic (Usage) Copy Code
Dim instance As ListViewItemSorter
C#
public class ListViewItemSorter
Managed Extensions for C++
public __gc class ListViewItemSorter
C++/CLI
public ref class ListViewItemSorter

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ListViewItemSorter

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

ListViewItemSorter Members
Gizmox.WebGUI.Forms Namespace


ListViewItemSorter Class Members

[image]
Gizmox.WebGUI.Forms
ListViewItemSorter Class Members
See Also Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : ListViewItemSorter Class

The following tables list the members exposed by ListViewItemSorter.

Public Constructors

 | Name | Description
Public Constructor | ListViewItemSorter Constructor | Creates a new ListViewItemSorter instance.
Top

Public Methods

 | Name | Description
Public Method | Compare | Compares two ListView Items
Top

See Also

Reference

ListViewItemSorter Class
Gizmox.WebGUI.Forms Namespace


ListViewItemSorter Constructor

[image]
Gizmox.WebGUI.Forms
ListViewItemSorter Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListViewItemSorter Class : ListViewItemSorter Constructor

objListView
list view.
Creates a new ListViewItemSorter instance.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal objListView As ListView _
)
Visual Basic (Usage) Copy Code
Dim objListView As ListView

Dim instance As ListViewItemSorter(objListView)
C#
public ListViewItemSorter(
   ListView objListView
)
Managed Extensions for C++
public: ListViewItemSorter(
   ListView* objListView
)
C++/CLI
public:
ListViewItemSorter(
   ListView^ objListView
)

Parameters

objListView
list view.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListViewItemSorter Class
ListViewItemSorter Members


ListViewItemSorter Class Methods

[image]
Gizmox.WebGUI.Forms
ListViewItemSorter Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ListViewItemSorter Class

For a list of all members of this type, see ListViewItemSorter members.

Public Methods

 | Name | Description
Public Method | Compare | Compares two ListView Items
Top

See Also

Reference

ListViewItemSorter Class
Gizmox.WebGUI.Forms Namespace


Compare Method

[image]
Gizmox.WebGUI.Forms
Compare Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ListViewItemSorter Class : Compare Method

objObjectA
object A.
objObjectB
object B.
Compares two ListView Items

Syntax

Visual Basic (Declaration)
Public Function Compare( _
   ByVal objObjectA As Object, _
   ByVal objObjectB As Object _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As ListViewItemSorter
Dim objObjectA As Object
Dim objObjectB As Object
Dim value As Integer

value = instance.Compare(objObjectA, objObjectB)
C#
public int Compare(
   object objObjectA,
   object objObjectB
)
Managed Extensions for C++
public: int Compare(
   Object* objObjectA,
   Object* objObjectB
)
C++/CLI
public:
int Compare(
   Object^ objObjectA,
   Object^ objObjectB
)

Parameters

objObjectA
object A.
objObjectB
object B.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListViewItemSorter Class
ListViewItemSorter Members


MainMenu Class

[image]
Gizmox.WebGUI.Forms
MainMenu Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : MainMenu Class

Summary description for MainMenu.

Object Model

Syntax

Visual Basic (Declaration)
<ToolboxItemFilterAttribute("Gizmox.WebGUI.Forms")>
<ToolboxItemCategoryAttribute("Menus & Toolbars")>
<ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<DesignTimeControllerAttribute()>
<ClientControllerAttribute()>
<ToolboxBitmapAttribute()>
<SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableMenu, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")>
<MetadataTagAttribute("MM")>
Public Class MainMenu
   Inherits Control
   Implements IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IMainMenu, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRegisteredComponentContainer, IRenderableComponent, IBindableComponent, IArrangedElement
Visual Basic (Usage) Copy Code
Dim instance As MainMenu
C#
[ToolboxItemFilterAttribute("Gizmox.WebGUI.Forms")]
[ToolboxItemCategoryAttribute("Menus & Toolbars")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[DesignTimeControllerAttribute()]
[ClientControllerAttribute()]
[ToolboxBitmapAttribute()]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableMenu, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[MetadataTagAttribute("MM")]
public class MainMenu : Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IMainMenu, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRegisteredComponentContainer, IRenderableComponent, IBindableComponent, IArrangedElement
Managed Extensions for C++
[ToolboxItemFilterAttribute("Gizmox.WebGUI.Forms")]
[ToolboxItemCategoryAttribute("Menus & Toolbars")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[DesignTimeControllerAttribute()]
[ClientControllerAttribute()]
[ToolboxBitmapAttribute()]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableMenu, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[MetadataTagAttribute("MM")]
public __gc class MainMenu : public Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IMainMenu, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRegisteredComponentContainer, IRenderableComponent, IBindableComponent, IArrangedElement
C++/CLI
[ToolboxItemFilterAttribute("Gizmox.WebGUI.Forms")]
[ToolboxItemCategoryAttribute("Menus & Toolbars")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[DesignTimeControllerAttribute()]
[ClientControllerAttribute()]
[ToolboxBitmapAttribute()]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableMenu, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[MetadataTagAttribute("MM")]
public ref class MainMenu : public Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IMainMenu, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRegisteredComponentContainer, IRenderableComponent, IBindableComponent, IArrangedElement

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.MainMenu

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

MainMenu Members
Gizmox.WebGUI.Forms Namespace


MainMenu Class Members

[image]
Gizmox.WebGUI.Forms
MainMenu Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : MainMenu Class

The following tables list the members exposed by MainMenu.

Public Constructors

 | Name | Description
Public Constructor | MainMenu Constructor |
Top

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Overridden. Gets a value indicating whether this instance can focus.
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | InternalParent | Overridden.
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MenuItems |
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Control)
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Control)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from Control)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | Overridden.
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | Overridden. MainMenu render impementation
Protected Method | RenderAttributes | Renders the controls meta attributes (Inherited from Control)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

MainMenu Class
Gizmox.WebGUI.Forms Namespace


MainMenu Constructor

[image]
Gizmox.WebGUI.Forms
MainMenu Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > MainMenu Class : MainMenu Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As MainMenu()
C#
public MainMenu()
Managed Extensions for C++
public: MainMenu();
C++/CLI
public:
MainMenu();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MainMenu Class
MainMenu Members


MainMenu Class Methods

[image]
Gizmox.WebGUI.Forms
MainMenu Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : MainMenu Class

For a list of all members of this type, see MainMenu members.

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Control)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from Control)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | Overridden.
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | Overridden. MainMenu render impementation
Protected Method | RenderAttributes | Renders the controls meta attributes (Inherited from Control)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

See Also

Reference

MainMenu Class
Gizmox.WebGUI.Forms Namespace


OnUnregisterComponents Method

[image]
Gizmox.WebGUI.Forms
OnUnregisterComponents Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > MainMenu Class : OnUnregisterComponents Method

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnUnregisterComponents()
Visual Basic (Usage) Copy Code
Dim instance As MainMenu

instance.OnUnregisterComponents()
C#
protected override void OnUnregisterComponents()
Managed Extensions for C++
protected: void OnUnregisterComponents(); override
C++/CLI
protected:
void OnUnregisterComponents(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MainMenu Class
MainMenu Members


Render Method

[image]
Gizmox.WebGUI.Forms
Render Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > MainMenu Class : Render Method

objContext
objWriter
lngRequestID
MainMenu render impementation

Syntax

Visual Basic (Declaration)
Protected Overrides Sub Render( _
   ByVal objContext As IContext, _
   ByVal objWriter As IResponseWriter, _
   ByVal lngRequestID As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As MainMenu
Dim objContext As IContext
Dim objWriter As IResponseWriter
Dim lngRequestID As Long

instance.Render(objContext, objWriter, lngRequestID)
C#
protected override void Render(
   IContext objContext,
   IResponseWriter objWriter,
   long lngRequestID
)
Managed Extensions for C++
protected: void Render(
   IContext* objContext,
   IResponseWriter* objWriter,
   long lngRequestID
) override
C++/CLI
protected:
void Render(
   IContext^ objContext,
   IResponseWriter^ objWriter,
   long long lngRequestID
) override

Parameters

objContext
objWriter
lngRequestID

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MainMenu Class
MainMenu Members


MainMenu Class Properties

[image]
Gizmox.WebGUI.Forms
MainMenu Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : MainMenu Class

For a list of all members of this type, see MainMenu members.

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Overridden. Gets a value indicating whether this instance can focus.
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | InternalParent | Overridden.
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MenuItems |
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Control)
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

See Also

Reference

MainMenu Class
Gizmox.WebGUI.Forms Namespace


CanFocus Property

[image]
Gizmox.WebGUI.Forms
CanFocus Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > MainMenu Class : CanFocus Property

Gets a value indicating whether this instance can focus.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanFocus As Boolean
Visual Basic (Usage) Copy Code
Dim instance As MainMenu
Dim value As Boolean

value = instance.CanFocus
C#
public override bool CanFocus {get;}
Managed Extensions for C++
public: __property bool get_CanFocus() override;
C++/CLI
public:
property bool CanFocus {
   bool get() override;
}

Return Value

true if this instance can focus; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MainMenu Class
MainMenu Members


InternalParent Property

[image]
Gizmox.WebGUI.Forms
InternalParent Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > MainMenu Class : InternalParent Property

Syntax

Visual Basic (Declaration)
Public Overrides Property InternalParent As Component
Visual Basic (Usage) Copy Code
Dim instance As MainMenu
Dim value As Component

instance.InternalParent = value

value = instance.InternalParent
C#
public override Component InternalParent {get; set;}
Managed Extensions for C++
public: __property Component* get_InternalParent() override;
public: __property void set_InternalParent(
   Component* value
) override;
C++/CLI
public:
property Component^ InternalParent {
   Component^ get() override;
   void set (Component^value) override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MainMenu Class
MainMenu Members


MenuItems Property

[image]
Gizmox.WebGUI.Forms
MenuItems Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > MainMenu Class : MenuItems Property

Syntax

Visual Basic (Declaration)
<ListBindableAttribute(False)>
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public ReadOnly Property MenuItems As MenuItemCollection
Visual Basic (Usage) Copy Code
Dim instance As MainMenu
Dim value As MenuItemCollection

value = instance.MenuItems
C#
[ListBindableAttribute(false)]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public MenuItemCollection MenuItems {get;}
Managed Extensions for C++
[ListBindableAttribute(false)]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property MenuItemCollection* get_MenuItems();
C++/CLI
[ListBindableAttribute(false)]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
property MenuItemCollection^ MenuItems {
   MenuItemCollection^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MainMenu Class
MainMenu Members


MaskedTextBox Class

[image]
Gizmox.WebGUI.Forms
MaskedTextBox Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : MaskedTextBox Class

Uses a mask to distinguish between proper and improper user input.

Object Model

Syntax

Visual Basic (Declaration)
<DesignTimeControllerAttribute()>
<SRDescriptionAttribute("Uses a mask to distinguish between proper and improper user input.")>
<ClientControllerAttribute()>
<SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableTextBox, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")>
<DefaultPropertyAttribute("Mask")>
<ToolboxItemCategoryAttribute("Common Controls")>
Public Class MaskedTextBox
   Inherits TextBox
   Implements IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Visual Basic (Usage) Copy Code
Dim instance As MaskedTextBox
C#
[DesignTimeControllerAttribute()]
[SRDescriptionAttribute("Uses a mask to distinguish between proper and improper user input.")]
[ClientControllerAttribute()]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableTextBox, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[DefaultPropertyAttribute("Mask")]
[ToolboxItemCategoryAttribute("Common Controls")]
public class MaskedTextBox : TextBox, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Managed Extensions for C++
[DesignTimeControllerAttribute()]
[SRDescriptionAttribute("Uses a mask to distinguish between proper and improper user input.")]
[ClientControllerAttribute()]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableTextBox, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[DefaultPropertyAttribute("Mask")]
[ToolboxItemCategoryAttribute("Common Controls")]
public __gc class MaskedTextBox : public TextBox, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
C++/CLI
[DesignTimeControllerAttribute()]
[SRDescriptionAttribute("Uses a mask to distinguish between proper and improper user input.")]
[ClientControllerAttribute()]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableTextBox, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[DefaultPropertyAttribute("Mask")]
[ToolboxItemCategoryAttribute("Common Controls")]
public ref class MaskedTextBox : public TextBox, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.TextBoxBase
Gizmox.WebGUI.Forms.TextBox
Gizmox.WebGUI.Forms.MaskedTextBox

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

MaskedTextBox Members
Gizmox.WebGUI.Forms Namespace


MaskedTextBox Class Members

[image]
Gizmox.WebGUI.Forms
MaskedTextBox Class Members
See Also Fields Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : MaskedTextBox Class

The following tables list the members exposed by MaskedTextBox.

Public Constructors

 | Name | Description
Public Constructor | MaskedTextBox Constructor | Initializes a new instance of the MaskedTextBox class using defaults.
Top

Protected Fields

 | Name | Description
Protected Field | menmScrollBars | Member which holds the scrollbars mode. (Inherited from TextBox)
Top

Public Properties

 | Name | Description
Public Property | AcceptsReturn | Gets or sets a value indicating whether pressing ENTER in a multiline TextBox control creates a new line of text in the control or activates the default button for the form. (Inherited from TextBox)
Public Property | AcceptsTab | (Inherited from TextBoxBase)
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | (Inherited from TextBox)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | CanUndo | Gets a value indicating whether the user can undo the previous operation in a text box control. (Inherited from TextBox)
Public Property | CharacterCasing | Indicates if all characters should be left alone or converted to uppercase or lowercase (Inherited from TextBox)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DragTargets | Gets a value indicating whether this instance is dragable. (Inherited from TextBox)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | HidePromptOnLeave | Gets or sets a value indicating whether the prompt characters in the input mask are hidden when the masked text box loses focus.
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Lines | (Inherited from TextBoxBase)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | Mask | Gets or sets the input mask to use at run time.
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MaxLength | (Inherited from TextBoxBase)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Multiline | Gets or sets a value indicating whether text box is multi line. (Inherited from TextBoxBase)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PasswordChar | Gets or sets the password charecter. (Inherited from TextBox)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | PromptChar | Gets or sets the character used to represent the absence of user input in MaskedTextBox.
Public Property | ReadOnly | Gets or sets a value indicating whether [read only]. (Inherited from TextBoxBase)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | ScrollBars | Gets or sets which scroll bars should appear in a multiline TextBox control. (Inherited from TextBox)
Public Property | SelectedText | Gets or sets a value indicating the currently selected text in the control. (Inherited from TextBoxBase)
Public Property | SelectionLength | Gets or sets the number of characters selected in the text box. (Inherited from TextBoxBase)
Public Property | SelectionStart | Gets or sets the starting point of text selected in the text box. (Inherited from TextBoxBase)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Overridden. Gets or sets the text associated with this control.
Public Property | TextAlign | Gets or sets how text is aligned in a TextBox control. (Inherited from TextBox)
Public Property | TextLength | Gets the length of text in the control. (Inherited from TextBoxBase)
Public Property | TextMaskFormat | Defines how Text property should be formatted
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | Validator | Gets or sets the text box validator. (Inherited from TextBox)
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Public Property | WordWrap | (Inherited from TextBoxBase)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from TextBox)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from TextBox)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

Public Methods

 | Name | Description
Public Method | AppendText | Appends text to the current text of a text box. (Inherited from TextBoxBase)
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Clear | Clears all text from the text box control. (Inherited from TextBoxBase)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | Copy | Copies the current selection in the text box to the Clipboard. (Inherited from TextBoxBase)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Cut | Moves the current selection in the text box to the Clipboard. (Inherited from TextBoxBase)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | Paste | Replaces the current selection in the text box with the contents of the Clipboard. (Inherited from TextBoxBase)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | ScrollToCaret | Scrolls the contents of the control to the current caret position. (Inherited from TextBoxBase)
Public Method | Select | Overloaded. Selects a range of text in the text box. (Inherited from TextBoxBase)
Public Method | SelectAll | Selects all text in the text box. (Inherited from TextBoxBase)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | Undo | Undoes the last edit operation in the text box. (Inherited from TextBox)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from TextBox)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetClipboardContent | Get content to be added to the clip board (Inherited from TextBox)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from TextBox)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from Control)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | InvokeSelection | Overridden. Implements the actual client side selection
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Control)
Protected Method | RenderAttributes | Overridden. Renders the current control attributes.
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | Render control params (Inherited from TextBoxBase)
Protected Method | RenderValue | Overridden. Renders the value.
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetClipboardContent | Set the value from the clip board (Inherited from TextBox)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | EnterKeyDown | Occurs on enter key down only on single line. (Inherited from TextBox)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

MaskedTextBox Class
Gizmox.WebGUI.Forms Namespace


MaskedTextBox Constructor

[image]
Gizmox.WebGUI.Forms
MaskedTextBox Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > MaskedTextBox Class : MaskedTextBox Constructor

Initializes a new instance of the MaskedTextBox class using defaults.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As MaskedTextBox()
C#
public MaskedTextBox()
Managed Extensions for C++
public: MaskedTextBox();
C++/CLI
public:
MaskedTextBox();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MaskedTextBox Class
MaskedTextBox Members


MaskedTextBox Class Methods

[image]
Gizmox.WebGUI.Forms
MaskedTextBox Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : MaskedTextBox Class

For a list of all members of this type, see MaskedTextBox members.

Public Methods

 | Name | Description
Public Method | AppendText | Appends text to the current text of a text box. (Inherited from TextBoxBase)
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Clear | Clears all text from the text box control. (Inherited from TextBoxBase)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | Copy | Copies the current selection in the text box to the Clipboard. (Inherited from TextBoxBase)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Cut | Moves the current selection in the text box to the Clipboard. (Inherited from TextBoxBase)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | Paste | Replaces the current selection in the text box with the contents of the Clipboard. (Inherited from TextBoxBase)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | ScrollToCaret | Scrolls the contents of the control to the current caret position. (Inherited from TextBoxBase)
Public Method | Select | Overloaded. Selects a range of text in the text box. (Inherited from TextBoxBase)
Public Method | SelectAll | Selects all text in the text box. (Inherited from TextBoxBase)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | Undo | Undoes the last edit operation in the text box. (Inherited from TextBox)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from TextBox)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetClipboardContent | Get content to be added to the clip board (Inherited from TextBox)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from TextBox)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from Control)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | InvokeSelection | Overridden. Implements the actual client side selection
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Control)
Protected Method | RenderAttributes | Overridden. Renders the current control attributes.
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | Render control params (Inherited from TextBoxBase)
Protected Method | RenderValue | Overridden. Renders the value.
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetClipboardContent | Set the value from the clip board (Inherited from TextBox)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

See Also

Reference

MaskedTextBox Class
Gizmox.WebGUI.Forms Namespace


InvokeSelection Method

[image]
Gizmox.WebGUI.Forms
InvokeSelection Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > MaskedTextBox Class : InvokeSelection Method

start
length
Implements the actual client side selection

Syntax

Visual Basic (Declaration)
Protected Overrides Sub InvokeSelection( _
   ByVal start As Integer, _
   ByVal length As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As MaskedTextBox
Dim start As Integer
Dim length As Integer

instance.InvokeSelection(start, length)
C#
protected override void InvokeSelection(
   int start,
   int length
)
Managed Extensions for C++
protected: void InvokeSelection(
   int start,
   int length
) override
C++/CLI
protected:
void InvokeSelection(
   int start,
   int length
) override

Parameters

start
length

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MaskedTextBox Class
MaskedTextBox Members


RenderAttributes Method

[image]
Gizmox.WebGUI.Forms
RenderAttributes Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > MaskedTextBox Class : RenderAttributes Method

objContext
Request context.
objWriter
The response writer object.
Renders the current control attributes.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub RenderAttributes( _
   ByVal objContext As IContext, _
   ByVal objWriter As IAttributeWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As MaskedTextBox
Dim objContext As IContext
Dim objWriter As IAttributeWriter

instance.RenderAttributes(objContext, objWriter)
C#
protected override void RenderAttributes(
   IContext objContext,
   IAttributeWriter objWriter
)
Managed Extensions for C++
protected: void RenderAttributes(
   IContext* objContext,
   IAttributeWriter* objWriter
) override
C++/CLI
protected:
void RenderAttributes(
   IContext^ objContext,
   IAttributeWriter^ objWriter
) override

Parameters

objContext
Request context.
objWriter
The response writer object.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MaskedTextBox Class
MaskedTextBox Members


RenderValue Method

[image]
Gizmox.WebGUI.Forms
RenderValue Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > MaskedTextBox Class : RenderValue Method

objContext
The context.
objWriter
The writer.
Renders the value.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub RenderValue( _
   ByVal objContext As IContext, _
   ByVal objWriter As IAttributeWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As MaskedTextBox
Dim objContext As IContext
Dim objWriter As IAttributeWriter

instance.RenderValue(objContext, objWriter)
C#
protected override void RenderValue(
   IContext objContext,
   IAttributeWriter objWriter
)
Managed Extensions for C++
protected: void RenderValue(
   IContext* objContext,
   IAttributeWriter* objWriter
) override
C++/CLI
protected:
void RenderValue(
   IContext^ objContext,
   IAttributeWriter^ objWriter
) override

Parameters

objContext
The context.
objWriter
The writer.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MaskedTextBox Class
MaskedTextBox Members


MaskedTextBox Class Properties

[image]
Gizmox.WebGUI.Forms
MaskedTextBox Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : MaskedTextBox Class

For a list of all members of this type, see MaskedTextBox members.

Public Properties

 | Name | Description
Public Property | AcceptsReturn | Gets or sets a value indicating whether pressing ENTER in a multiline TextBox control creates a new line of text in the control or activates the default button for the form. (Inherited from TextBox)
Public Property | AcceptsTab | (Inherited from TextBoxBase)
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | (Inherited from TextBox)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | CanUndo | Gets a value indicating whether the user can undo the previous operation in a text box control. (Inherited from TextBox)
Public Property | CharacterCasing | Indicates if all characters should be left alone or converted to uppercase or lowercase (Inherited from TextBox)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DragTargets | Gets a value indicating whether this instance is dragable. (Inherited from TextBox)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | HidePromptOnLeave | Gets or sets a value indicating whether the prompt characters in the input mask are hidden when the masked text box loses focus.
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Lines | (Inherited from TextBoxBase)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | Mask | Gets or sets the input mask to use at run time.
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MaxLength | (Inherited from TextBoxBase)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Multiline | Gets or sets a value indicating whether text box is multi line. (Inherited from TextBoxBase)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PasswordChar | Gets or sets the password charecter. (Inherited from TextBox)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | PromptChar | Gets or sets the character used to represent the absence of user input in MaskedTextBox.
Public Property | ReadOnly | Gets or sets a value indicating whether [read only]. (Inherited from TextBoxBase)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | ScrollBars | Gets or sets which scroll bars should appear in a multiline TextBox control. (Inherited from TextBox)
Public Property | SelectedText | Gets or sets a value indicating the currently selected text in the control. (Inherited from TextBoxBase)
Public Property | SelectionLength | Gets or sets the number of characters selected in the text box. (Inherited from TextBoxBase)
Public Property | SelectionStart | Gets or sets the starting point of text selected in the text box. (Inherited from TextBoxBase)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Overridden. Gets or sets the text associated with this control.
Public Property | TextAlign | Gets or sets how text is aligned in a TextBox control. (Inherited from TextBox)
Public Property | TextLength | Gets the length of text in the control. (Inherited from TextBoxBase)
Public Property | TextMaskFormat | Defines how Text property should be formatted
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | Validator | Gets or sets the text box validator. (Inherited from TextBox)
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Public Property | WordWrap | (Inherited from TextBoxBase)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from TextBox)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from TextBox)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

See Also

Reference

MaskedTextBox Class
Gizmox.WebGUI.Forms Namespace


HidePromptOnLeave Property

[image]
Gizmox.WebGUI.Forms
HidePromptOnLeave Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > MaskedTextBox Class : HidePromptOnLeave Property

Gets or sets a value indicating whether the prompt characters in the input mask are hidden when the masked text box loses focus.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Behavior")>
<DefaultValueAttribute()>
<SRDescriptionAttribute("Indicates whether prompt characters are displayed when the control does not have focus.")>
<RefreshPropertiesAttribute()>
Public Property HidePromptOnLeave As Boolean
Visual Basic (Usage) Copy Code
Dim instance As MaskedTextBox
Dim value As Boolean

instance.HidePromptOnLeave = value

value = instance.HidePromptOnLeave
C#
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Indicates whether prompt characters are displayed when the control does not have focus.")]
[RefreshPropertiesAttribute()]
public bool HidePromptOnLeave {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Indicates whether prompt characters are displayed when the control does not have focus.")]
[RefreshPropertiesAttribute()]
public: __property bool get_HidePromptOnLeave();
public: __property void set_HidePromptOnLeave(
   bool value
);
C++/CLI
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Indicates whether prompt characters are displayed when the control does not have focus.")]
[RefreshPropertiesAttribute()]
public:
property bool HidePromptOnLeave {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MaskedTextBox Class
MaskedTextBox Members


Mask Property

[image]
Gizmox.WebGUI.Forms
Mask Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > MaskedTextBox Class : Mask Property

Gets or sets the input mask to use at run time.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Behavior")>
<LocalizableAttribute(True)>
<EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.MaskEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")>
<SRDescriptionAttribute("Sets the string governing the input allowed for this control.")>
<RefreshPropertiesAttribute()>
<DefaultValueAttribute()>
Public Property Mask As String
Visual Basic (Usage) Copy Code
Dim instance As MaskedTextBox
Dim value As String

instance.Mask = value

value = instance.Mask
C#
[SRCategoryAttribute("Behavior")]
[LocalizableAttribute(true)]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.MaskEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[SRDescriptionAttribute("Sets the string governing the input allowed for this control.")]
[RefreshPropertiesAttribute()]
[DefaultValueAttribute()]
public string Mask {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Behavior")]
[LocalizableAttribute(true)]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.MaskEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[SRDescriptionAttribute("Sets the string governing the input allowed for this control.")]
[RefreshPropertiesAttribute()]
[DefaultValueAttribute()]
public: __property string* get_Mask();
public: __property void set_Mask(
   string* value
);
C++/CLI
[SRCategoryAttribute("Behavior")]
[LocalizableAttribute(true)]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.MaskEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[SRDescriptionAttribute("Sets the string governing the input allowed for this control.")]
[RefreshPropertiesAttribute()]
[DefaultValueAttribute()]
public:
property String^ Mask {
   String^ get();
   void set (String^value);
}

Exceptions

Exception | Description
ArgumentException | The string supplied to the Mask property is not a valid mask. Invalid masks include masks containing non-printable characters.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MaskedTextBox Class
MaskedTextBox Members


PromptChar Property

[image]
Gizmox.WebGUI.Forms
PromptChar Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > MaskedTextBox Class : PromptChar Property

Gets or sets the character used to represent the absence of user input in MaskedTextBox.

Syntax

Visual Basic (Declaration)
<LocalizableAttribute(True)>
<SRCategoryAttribute("Appearance")>
<SRDescriptionAttribute("Indicates the character used as the placeholder.")>
<DefaultValueAttribute()>
<RefreshPropertiesAttribute()>
Public Property PromptChar As Char
Visual Basic (Usage) Copy Code
Dim instance As MaskedTextBox
Dim value As Char

instance.PromptChar = value

value = instance.PromptChar
C#
[LocalizableAttribute(true)]
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Indicates the character used as the placeholder.")]
[DefaultValueAttribute()]
[RefreshPropertiesAttribute()]
public char PromptChar {get; set;}
Managed Extensions for C++
[LocalizableAttribute(true)]
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Indicates the character used as the placeholder.")]
[DefaultValueAttribute()]
[RefreshPropertiesAttribute()]
public: __property char get_PromptChar();
public: __property void set_PromptChar(
   char value
);
C++/CLI
[LocalizableAttribute(true)]
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Indicates the character used as the placeholder.")]
[DefaultValueAttribute()]
[RefreshPropertiesAttribute()]
public:
property char PromptChar {
   char get();
   void set (charvalue);
}

Exceptions

Exception | Description
InvalidOperationException | The prompt character specified is the same as the current password character, PasswordChar. The two are required to be different.
ArgumentException | The character specified when setting this property is not a valid prompt character, as determined by the IsValidPasswordChar method of the MaskedTextProvider class.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MaskedTextBox Class
MaskedTextBox Members


Text Property

[image]
Gizmox.WebGUI.Forms
Text Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > MaskedTextBox Class : Text Property

Gets or sets the text associated with this control.

Syntax

Visual Basic (Declaration)
<LocalizableAttribute(True)>
<SRCategoryAttribute("Appearance")>
<SRDescriptionAttribute("The text associated with the control.")>
<DefaultValueAttribute()>
<BindableAttribute(True)>
Public Overrides Property Text As String
Visual Basic (Usage) Copy Code
Dim instance As MaskedTextBox
Dim value As String

instance.Text = value

value = instance.Text
C#
[LocalizableAttribute(true)]
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("The text associated with the control.")]
[DefaultValueAttribute()]
[BindableAttribute(true)]
public override string Text {get; set;}
Managed Extensions for C++
[LocalizableAttribute(true)]
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("The text associated with the control.")]
[DefaultValueAttribute()]
[BindableAttribute(true)]
public: __property string* get_Text() override;
public: __property void set_Text(
   string* value
) override;
C++/CLI
[LocalizableAttribute(true)]
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("The text associated with the control.")]
[DefaultValueAttribute()]
[BindableAttribute(true)]
public:
property String^ Text {
   String^ get() override;
   void set (String^value) override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MaskedTextBox Class
MaskedTextBox Members


TextMaskFormat Property

[image]
Gizmox.WebGUI.Forms
TextMaskFormat Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > MaskedTextBox Class : TextMaskFormat Property

Defines how Text property should be formatted

Syntax

Visual Basic (Declaration)
Public Property TextMaskFormat As MaskFormat
Visual Basic (Usage) Copy Code
Dim instance As MaskedTextBox
Dim value As MaskFormat

instance.TextMaskFormat = value

value = instance.TextMaskFormat
C#
public MaskFormat TextMaskFormat {get; set;}
Managed Extensions for C++
public: __property MaskFormat get_TextMaskFormat();
public: __property void set_TextMaskFormat(
   MaskFormat value
);
C++/CLI
public:
property MaskFormat TextMaskFormat {
   MaskFormat get();
   void set (MaskFormatvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MaskedTextBox Class
MaskedTextBox Members


MdiClient Class

[image]
Gizmox.WebGUI.Forms
MdiClient Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : MdiClient Class

Represents the container for multiple-document interface (MDI) child forms. This class cannot be inherited.

Object Model

Syntax

Visual Basic (Declaration)
<MetadataTagAttribute("MDIC")>
<SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableMdiClient, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")>
<DesignTimeVisibleAttribute()>
<ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")>
Public NotInheritable Class MdiClient
   Inherits Control
   Implements IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Visual Basic (Usage) Copy Code
Dim instance As MdiClient
C#
[MetadataTagAttribute("MDIC")]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableMdiClient, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[DesignTimeVisibleAttribute()]
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
public sealed class MdiClient : Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Managed Extensions for C++
[MetadataTagAttribute("MDIC")]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableMdiClient, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[DesignTimeVisibleAttribute()]
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
public __gc __sealed class MdiClient : public Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
C++/CLI
[MetadataTagAttribute("MDIC")]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableMdiClient, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[DesignTimeVisibleAttribute()]
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
public ref class MdiClient sealed : public Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.MdiClient

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

MdiClient Members
Gizmox.WebGUI.Forms Namespace


MdiClient Class Members

[image]
Gizmox.WebGUI.Forms
MdiClient Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : MdiClient Class

The following tables list the members exposed by MdiClient.

Public Constructors

 | Name | Description
Public Constructor | MdiClient Constructor | Initializes a new instance of the MdiClient class.
Top

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Overridden. Gets or sets the background image displayed in the MdiClient control.
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MdiChildren | Gets the child multiple-document interface (MDI) forms of the MdiClient control.
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Control)
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form.
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | Overridden. Creates a new instance of the control collection for the control.
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Control)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from Control)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Control)
Protected Method | RenderAttributes | Overridden. Renders the controls meta attributes
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | Overridden.
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | Overridden.
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

MdiClient Class
Gizmox.WebGUI.Forms Namespace


MdiClient Constructor

[image]
Gizmox.WebGUI.Forms
MdiClient Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > MdiClient Class : MdiClient Constructor

Initializes a new instance of the MdiClient class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As MdiClient()
C#
public MdiClient()
Managed Extensions for C++
public: MdiClient();
C++/CLI
public:
MdiClient();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MdiClient Class
MdiClient Members


MdiClient Class Methods

[image]
Gizmox.WebGUI.Forms
MdiClient Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : MdiClient Class

For a list of all members of this type, see MdiClient members.

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form.
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | Overridden. Creates a new instance of the control collection for the control.
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Control)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from Control)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Control)
Protected Method | RenderAttributes | Overridden. Renders the controls meta attributes
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | Overridden.
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | Overridden.
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

See Also

Reference

MdiClient Class
Gizmox.WebGUI.Forms Namespace


CreateControlsInstance Method

[image]
Gizmox.WebGUI.Forms
CreateControlsInstance Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > MdiClient Class : CreateControlsInstance Method

Creates a new instance of the control collection for the control.

Syntax

Visual Basic (Declaration)
Protected Overrides NotOverridable Function CreateControlsInstance() As Control.ControlCollection
Visual Basic (Usage) Copy Code
Dim instance As MdiClient
Dim value As Control.ControlCollection

value = instance.CreateControlsInstance()
C#
protected override Control.ControlCollection CreateControlsInstance()
Managed Extensions for C++
protected: Control.ControlCollection* CreateControlsInstance(); override
C++/CLI
protected:
Control::ControlCollection^ CreateControlsInstance(); override

Return Value

A new instance of Control.ControlCollection assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MdiClient Class
MdiClient Members


LayoutMdi Method

[image]
Gizmox.WebGUI.Forms
LayoutMdi Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > MdiClient Class : LayoutMdi Method

value
One of the MdiLayout values that defines the layout of MDI child forms.
Arranges the multiple-document interface (MDI) child forms within the MDI parent form.

Syntax

Visual Basic (Declaration)
Public Sub LayoutMdi( _
   ByVal value As MdiLayout _
)
Visual Basic (Usage) Copy Code
Dim instance As MdiClient
Dim value As MdiLayout

instance.LayoutMdi(value)
C#
public void LayoutMdi(
   MdiLayout value
)
Managed Extensions for C++
public: void LayoutMdi(
   MdiLayout value
)
C++/CLI
public:
void LayoutMdi(
   MdiLayout value
)

Parameters

value
One of the MdiLayout values that defines the layout of MDI child forms.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MdiClient Class
MdiClient Members


RenderAttributes Method

[image]
Gizmox.WebGUI.Forms
RenderAttributes Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > MdiClient Class : RenderAttributes Method

objContext
objWriter
Renders the controls meta attributes

Syntax

Visual Basic (Declaration)
Protected Overrides NotOverridable Sub RenderAttributes( _
   ByVal objContext As IContext, _
   ByVal objWriter As IAttributeWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As MdiClient
Dim objContext As IContext
Dim objWriter As IAttributeWriter

instance.RenderAttributes(objContext, objWriter)
C#
protected override void RenderAttributes(
   IContext objContext,
   IAttributeWriter objWriter
)
Managed Extensions for C++
protected: void RenderAttributes(
   IContext* objContext,
   IAttributeWriter* objWriter
) override
C++/CLI
protected:
void RenderAttributes(
   IContext^ objContext,
   IAttributeWriter^ objWriter
) override

Parameters

objContext
objWriter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MdiClient Class
MdiClient Members


ShouldSerializeBackColor Method

[image]
Gizmox.WebGUI.Forms
ShouldSerializeBackColor Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > MdiClient Class : ShouldSerializeBackColor Method

Syntax

Visual Basic (Declaration)
Protected Overrides NotOverridable Function ShouldSerializeBackColor() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As MdiClient
Dim value As Boolean

value = instance.ShouldSerializeBackColor()
C#
protected override bool ShouldSerializeBackColor()
Managed Extensions for C++
protected: bool ShouldSerializeBackColor(); override
C++/CLI
protected:
bool ShouldSerializeBackColor(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MdiClient Class
MdiClient Members


ShouldSerializeSize Method

[image]
Gizmox.WebGUI.Forms
ShouldSerializeSize Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > MdiClient Class : ShouldSerializeSize Method

Syntax

Visual Basic (Declaration)
Protected Overrides NotOverridable Function ShouldSerializeSize() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As MdiClient
Dim value As Boolean

value = instance.ShouldSerializeSize()
C#
protected override bool ShouldSerializeSize()
Managed Extensions for C++
protected: bool ShouldSerializeSize(); override
C++/CLI
protected:
bool ShouldSerializeSize(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MdiClient Class
MdiClient Members


MdiClient Class Properties

[image]
Gizmox.WebGUI.Forms
MdiClient Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : MdiClient Class

For a list of all members of this type, see MdiClient members.

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Overridden. Gets or sets the background image displayed in the MdiClient control.
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MdiChildren | Gets the child multiple-document interface (MDI) forms of the MdiClient control.
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Control)
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

See Also

Reference

MdiClient Class
Gizmox.WebGUI.Forms Namespace


BackgroundImage Property

[image]
Gizmox.WebGUI.Forms
BackgroundImage Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > MdiClient Class : BackgroundImage Property

Gets or sets the background image displayed in the MdiClient control.

Syntax

Visual Basic (Declaration)
<LocalizableAttribute(True)>
Public Overrides NotOverridable Property BackgroundImage As ResourceHandle
Visual Basic (Usage) Copy Code
Dim instance As MdiClient
Dim value As ResourceHandle

instance.BackgroundImage = value

value = instance.BackgroundImage
C#
[LocalizableAttribute(true)]
public override ResourceHandle BackgroundImage {get; set;}
Managed Extensions for C++
[LocalizableAttribute(true)]
public: __property ResourceHandle* get_BackgroundImage() override;
public: __property void set_BackgroundImage(
   ResourceHandle* value
) override;
C++/CLI
[LocalizableAttribute(true)]
public:
property ResourceHandle^ BackgroundImage {
   ResourceHandle^ get() override;
   void set (ResourceHandle^value) override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MdiClient Class
MdiClient Members


MdiChildren Property

[image]
Gizmox.WebGUI.Forms
MdiChildren Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > MdiClient Class : MdiChildren Property

Gets the child multiple-document interface (MDI) forms of the MdiClient control.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MdiChildren As Form()
Visual Basic (Usage) Copy Code
Dim instance As MdiClient
Dim value() As Form

value = instance.MdiChildren
C#
public Form[] MdiChildren {get;}
Managed Extensions for C++
public: __property Form*[]* get_MdiChildren();
C++/CLI
public:
property array<Form^>^ MdiChildren {
   array<Form^>^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MdiClient Class
MdiClient Members


MdiClient.ControlCollection Class

[image]
Gizmox.WebGUI.Forms
MdiClient.ControlCollection Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : MdiClient.ControlCollection Class

Contains a collection of MdiClient controls.

Object Model

Syntax

Visual Basic (Declaration)
Public Class MdiClient.ControlCollection
   Inherits Control.ControlCollection
   Implements IObservableList
Visual Basic (Usage) Copy Code
Dim instance As MdiClient.ControlCollection
C#
public class MdiClient.ControlCollection : Control.ControlCollection, IObservableList
Managed Extensions for C++
public __gc class MdiClient.ControlCollection : public Control.ControlCollection, IObservableList
C++/CLI
public ref class MdiClient.ControlCollection : public Control::ControlCollection, IObservableList

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.Layout.ArrangedElementCollection
Gizmox.WebGUI.Forms.Control.ControlCollection
Gizmox.WebGUI.Forms.MdiClient.ControlCollection

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

MdiClient.ControlCollection Members
Gizmox.WebGUI.Forms Namespace


MdiClient.ControlCollection Class Members

[image]
Gizmox.WebGUI.Forms
MdiClient.ControlCollection Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : MdiClient.ControlCollection Class

The following tables list the members exposed by MdiClient.ControlCollection.

Public Constructors

 | Name | Description
Public Constructor | MdiClient.ControlCollection Constructor | Initializes a new instance of the MdiClient.ControlCollection class, specifying the owner of the collection.
Top

Public Properties

 | Name | Description
Public Property | Count | (Inherited from Control.ControlCollection)
Public Property | IsFixedSize | (Inherited from Control.ControlCollection)
Public Property | IsReadOnly | (Inherited from Control.ControlCollection)
Public Property | Item | Overloaded. Indicates a Control with the specified key in the collection. (Inherited from Control.ControlCollection)
Public Property | Owner | Gets the control that owns this Control.ControlCollection. (Inherited from Control.ControlCollection)
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Overridden. Adds a control to the multiple-document interface (MDI) Container.
Public Method | AddRange | Adds an array of control objects to the collection. (Inherited from Control.ControlCollection)
Public Method | Clear | Removes all controls from the collection. (Inherited from Control.ControlCollection)
Public Method | Contains | Determines whether the specified control is a member of the collection. (Inherited from Control.ControlCollection)
Public Method | ContainsKey | Determines whether the Control.ControlCollection contains an item with the specified key. (Inherited from Control.ControlCollection)
Public Method | CopyTo | Copies the entire contents of this collection to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Gizmox.WebGUI.Forms.Layout.ArrangedElementCollection)
Public Method | Equals | Determines whether two ArrangedElementCollection instances are equal. (Inherited from Gizmox.WebGUI.Forms.Layout.ArrangedElementCollection)
Public Method | Find | Searches for controls by their Control.Name property and builds an array of all the controls that match. (Inherited from Control.ControlCollection)
Public Method | GetChildIndex | Overloaded. Retrieves the index of the specified child control within the control collection. (Inherited from Control.ControlCollection)
Public Method | GetEnumerator | Retrieves a reference to an enumerator object that is used to iterate over a Control.ControlCollection. (Inherited from Control.ControlCollection)
Public Method | GetHashCode | Returns the hash code for this instance. (Inherited from Gizmox.WebGUI.Forms.Layout.ArrangedElementCollection)
Public Method | IndexOf | Retrieves the index of the specified control in the control collection. (Inherited from Control.ControlCollection)
Public Method | IndexOfKey | Retrieves the index of the first occurrence of the specified item within the collection. (Inherited from Control.ControlCollection)
Public Method | Insert | (Inherited from Control.ControlCollection)
Public Method | Remove | Overridden. Removes a child control.
Public Method | RemoveAt | Removes a control from the control collection at the specified indexed location. (Inherited from Control.ControlCollection)
Public Method | RemoveByKey | Removes the child control with the specified key. (Inherited from Control.ControlCollection)
Public Method | SetChildIndex | Sets the index of the specified child control in the collection to the specified index value. (Inherited from Control.ControlCollection)
Top

See Also

Reference

MdiClient.ControlCollection Class
Gizmox.WebGUI.Forms Namespace


MdiClient.ControlCollection Constructor

[image]
Gizmox.WebGUI.Forms
MdiClient.ControlCollection Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > MdiClient.ControlCollection Class : MdiClient.ControlCollection Constructor

objOwner
The owner of the collection.
Initializes a new instance of the MdiClient.ControlCollection class, specifying the owner of the collection.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal objOwner As MdiClient _
)
Visual Basic (Usage) Copy Code
Dim objOwner As MdiClient

Dim instance As MdiClient.ControlCollection(objOwner)
C#
public MdiClient.ControlCollection(
   MdiClient objOwner
)
Managed Extensions for C++
public: MdiClient.ControlCollection(
   MdiClient* objOwner
)
C++/CLI
public:
MdiClient.ControlCollection(
   MdiClient^ objOwner
)

Parameters

objOwner
The owner of the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MdiClient.ControlCollection Class
MdiClient.ControlCollection Members


MdiClient.ControlCollection Class Methods

[image]
Gizmox.WebGUI.Forms
MdiClient.ControlCollection Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : MdiClient.ControlCollection Class

For a list of all members of this type, see MdiClient.ControlCollection members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Overridden. Adds a control to the multiple-document interface (MDI) Container.
Public Method | AddRange | Adds an array of control objects to the collection. (Inherited from Control.ControlCollection)
Public Method | Clear | Removes all controls from the collection. (Inherited from Control.ControlCollection)
Public Method | Contains | Determines whether the specified control is a member of the collection. (Inherited from Control.ControlCollection)
Public Method | ContainsKey | Determines whether the Control.ControlCollection contains an item with the specified key. (Inherited from Control.ControlCollection)
Public Method | CopyTo | Copies the entire contents of this collection to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Gizmox.WebGUI.Forms.Layout.ArrangedElementCollection)
Public Method | Equals | Determines whether two ArrangedElementCollection instances are equal. (Inherited from Gizmox.WebGUI.Forms.Layout.ArrangedElementCollection)
Public Method | Find | Searches for controls by their Control.Name property and builds an array of all the controls that match. (Inherited from Control.ControlCollection)
Public Method | GetChildIndex | Overloaded. Retrieves the index of the specified child control within the control collection. (Inherited from Control.ControlCollection)
Public Method | GetEnumerator | Retrieves a reference to an enumerator object that is used to iterate over a Control.ControlCollection. (Inherited from Control.ControlCollection)
Public Method | GetHashCode | Returns the hash code for this instance. (Inherited from Gizmox.WebGUI.Forms.Layout.ArrangedElementCollection)
Public Method | IndexOf | Retrieves the index of the specified control in the control collection. (Inherited from Control.ControlCollection)
Public Method | IndexOfKey | Retrieves the index of the first occurrence of the specified item within the collection. (Inherited from Control.ControlCollection)
Public Method | Insert | (Inherited from Control.ControlCollection)
Public Method | Remove | Overridden. Removes a child control.
Public Method | RemoveAt | Removes a control from the control collection at the specified indexed location. (Inherited from Control.ControlCollection)
Public Method | RemoveByKey | Removes the child control with the specified key. (Inherited from Control.ControlCollection)
Public Method | SetChildIndex | Sets the index of the specified child control in the collection to the specified index value. (Inherited from Control.ControlCollection)
Top

See Also

Reference

MdiClient.ControlCollection Class
Gizmox.WebGUI.Forms Namespace


Add Method

[image]
Gizmox.WebGUI.Forms
Add Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > MdiClient.ControlCollection Class : Add Method

Adds a control to the multiple-document interface (MDI) Container.

Overload List

Overload | Description
Add(Control) | Adds a control to the multiple-document interface (MDI) Container.
Add(Control,Boolean) | Adds the specified control to the control collection. (Inherited from Control.ControlCollection)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MdiClient.ControlCollection Class
MdiClient.ControlCollection Members


Add(Control) Method

[image]
Gizmox.WebGUI.Forms
Add(Control) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > MdiClient.ControlCollection Class > Add Method : Add(Control) Method

objControl
MDI Child Form to add.
Adds a control to the multiple-document interface (MDI) Container.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Sub Add( _
   ByVal objControl As Control _
)
Visual Basic (Usage) Copy Code
Dim instance As MdiClient.ControlCollection
Dim objControl As Control

instance.Add(objControl)
C#
public override void Add(
   Control objControl
)
Managed Extensions for C++
public: void Add(
   Control* objControl
) override
C++/CLI
public:
void Add(
   Control^ objControl
) override

Parameters

objControl
MDI Child Form to add.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MdiClient.ControlCollection Class
MdiClient.ControlCollection Members
Overload List


Remove Method

[image]
Gizmox.WebGUI.Forms
Remove Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > MdiClient.ControlCollection Class : Remove Method

value
MDI Child Form to remove.
Removes a child control.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Remove( _
   ByVal value As Control _
)
Visual Basic (Usage) Copy Code
Dim instance As MdiClient.ControlCollection
Dim value As Control

instance.Remove(value)
C#
public override void Remove(
   Control value
)
Managed Extensions for C++
public: void Remove(
   Control* value
) override
C++/CLI
public:
void Remove(
   Control^ value
) override

Parameters

value
MDI Child Form to remove.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MdiClient.ControlCollection Class
MdiClient.ControlCollection Members


Menu Class

[image]
Gizmox.WebGUI.Forms
Menu Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : Menu Class

The base class for all GUI elements

Object Model

Syntax

Visual Basic (Declaration)
<ToolboxItemCategoryAttribute("Menus & Toolbars")>
<ListBindableAttribute(False)>
<WebCompilerPagesAttribute(Assembly=Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d,
   Namespace="Gizmox.WebGUI.Forms",
   Resoruces=System.String[])>
<DesignTimeVisibleAttribute()>
<ToolboxItemFilterAttribute("Gizmox.WebGUI.Forms")>
Public Class Menu
   Inherits Component
   Implements IAttributeExtender, IEventHandler, IGatewayComponent, IMenu, IObservableItem, IRegisteredComponent, IRegisteredComponentContainer
Visual Basic (Usage) Copy Code
Dim instance As Menu
C#
[ToolboxItemCategoryAttribute("Menus & Toolbars")]
[ListBindableAttribute(false)]
[WebCompilerPagesAttribute(Assembly=Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d,
   Namespace="Gizmox.WebGUI.Forms",
   Resoruces=System.String[])]
[DesignTimeVisibleAttribute()]
[ToolboxItemFilterAttribute("Gizmox.WebGUI.Forms")]
public class Menu : Component, IAttributeExtender, IEventHandler, IGatewayComponent, IMenu, IObservableItem, IRegisteredComponent, IRegisteredComponentContainer
Managed Extensions for C++
[ToolboxItemCategoryAttribute("Menus & Toolbars")]
[ListBindableAttribute(false)]
[WebCompilerPagesAttribute(Assembly=Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d,
   Namespace="Gizmox.WebGUI.Forms",
   Resoruces=System.String[])]
[DesignTimeVisibleAttribute()]
[ToolboxItemFilterAttribute("Gizmox.WebGUI.Forms")]
public __gc class Menu : public Component, IAttributeExtender, IEventHandler, IGatewayComponent, IMenu, IObservableItem, IRegisteredComponent, IRegisteredComponentContainer
C++/CLI
[ToolboxItemCategoryAttribute("Menus & Toolbars")]
[ListBindableAttribute(false)]
[WebCompilerPagesAttribute(Assembly=Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d,
   Namespace="Gizmox.WebGUI.Forms",
   Resoruces=System.String[])]
[DesignTimeVisibleAttribute()]
[ToolboxItemFilterAttribute("Gizmox.WebGUI.Forms")]
public ref class Menu : public Component, IAttributeExtender, IEventHandler, IGatewayComponent, IMenu, IObservableItem, IRegisteredComponent, IRegisteredComponentContainer

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Menu
Gizmox.WebGUI.Forms.ContextMenu
Gizmox.WebGUI.Forms.MenuItem

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Menu Members
Gizmox.WebGUI.Forms Namespace


Menu Class Members

[image]
Gizmox.WebGUI.Forms
Menu Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : Menu Class

The following tables list the members exposed by Menu.

Public Constructors

 | Name | Description
Public Constructor | Menu Constructor |
Top

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContextMenu | Overridden. Gets or sets the context menu code.
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | MenuItems |
Public Property | Site | (Inherited from ComponentBase)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded. Disposes the specified component. (Inherited from Component)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | RegisterMenu |
Public Method | Render | MainMenu render impementation
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | UnregisterMenu |
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Component)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCriticalEvents | (Inherited from Component)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnUnregisterComponents | Overridden.
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Top

See Also

Reference

Menu Class
Gizmox.WebGUI.Forms Namespace


Menu Constructor

[image]
Gizmox.WebGUI.Forms
Menu Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Menu Class : Menu Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Menu()
C#
public Menu()
Managed Extensions for C++
public: Menu();
C++/CLI
public:
Menu();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Menu Class
Menu Members


Menu Class Methods

[image]
Gizmox.WebGUI.Forms
Menu Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : Menu Class

For a list of all members of this type, see Menu members.

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded. Disposes the specified component. (Inherited from Component)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | RegisterMenu |
Public Method | Render | MainMenu render impementation
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | UnregisterMenu |
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Component)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCriticalEvents | (Inherited from Component)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnUnregisterComponents | Overridden.
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

See Also

Reference

Menu Class
Gizmox.WebGUI.Forms Namespace


OnUnregisterComponents Method

[image]
Gizmox.WebGUI.Forms
OnUnregisterComponents Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Menu Class : OnUnregisterComponents Method

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnUnregisterComponents()
Visual Basic (Usage) Copy Code
Dim instance As Menu

instance.OnUnregisterComponents()
C#
protected override void OnUnregisterComponents()
Managed Extensions for C++
protected: void OnUnregisterComponents(); override
C++/CLI
protected:
void OnUnregisterComponents(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Menu Class
Menu Members


RegisterMenu Method

[image]
Gizmox.WebGUI.Forms
RegisterMenu Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Menu Class : RegisterMenu Method

objCaller

Syntax

Visual Basic (Declaration)
Public Sub RegisterMenu( _
   ByVal objCaller As Component _
)
Visual Basic (Usage) Copy Code
Dim instance As Menu
Dim objCaller As Component

instance.RegisterMenu(objCaller)
C#
public void RegisterMenu(
   Component objCaller
)
Managed Extensions for C++
public: void RegisterMenu(
   Component* objCaller
)
C++/CLI
public:
void RegisterMenu(
   Component^ objCaller
)

Parameters

objCaller

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Menu Class
Menu Members


Render Method

[image]
Gizmox.WebGUI.Forms
Render Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Menu Class : Render Method

objContext
objWriter
lngRequestID
MainMenu render impementation

Syntax

Visual Basic (Declaration)
Public Sub Render( _
   ByVal objContext As IContext, _
   ByVal objWriter As IResponseWriter, _
   ByVal lngRequestID As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As Menu
Dim objContext As IContext
Dim objWriter As IResponseWriter
Dim lngRequestID As Long

instance.Render(objContext, objWriter, lngRequestID)
C#
public void Render(
   IContext objContext,
   IResponseWriter objWriter,
   long lngRequestID
)
Managed Extensions for C++
public: void Render(
   IContext* objContext,
   IResponseWriter* objWriter,
   long lngRequestID
)
C++/CLI
public:
void Render(
   IContext^ objContext,
   IResponseWriter^ objWriter,
   long long lngRequestID
)

Parameters

objContext
objWriter
lngRequestID

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Menu Class
Menu Members


UnregisterMenu Method

[image]
Gizmox.WebGUI.Forms
UnregisterMenu Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Menu Class : UnregisterMenu Method

objCaller

Syntax

Visual Basic (Declaration)
Public Sub UnregisterMenu( _
   ByVal objCaller As Component _
)
Visual Basic (Usage) Copy Code
Dim instance As Menu
Dim objCaller As Component

instance.UnregisterMenu(objCaller)
C#
public void UnregisterMenu(
   Component objCaller
)
Managed Extensions for C++
public: void UnregisterMenu(
   Component* objCaller
)
C++/CLI
public:
void UnregisterMenu(
   Component^ objCaller
)

Parameters

objCaller

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Menu Class
Menu Members


Menu Class Properties

[image]
Gizmox.WebGUI.Forms
Menu Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : Menu Class

For a list of all members of this type, see Menu members.

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContextMenu | Overridden. Gets or sets the context menu code.
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | MenuItems |
Public Property | Site | (Inherited from ComponentBase)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

See Also

Reference

Menu Class
Gizmox.WebGUI.Forms Namespace


ContextMenu Property

[image]
Gizmox.WebGUI.Forms
ContextMenu Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Menu Class : ContextMenu Property

Gets or sets the context menu code.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public Overrides Property ContextMenu As ContextMenu
Visual Basic (Usage) Copy Code
Dim instance As Menu
Dim value As ContextMenu

instance.ContextMenu = value

value = instance.ContextMenu
C#
[BrowsableAttribute(false)]
public override ContextMenu ContextMenu {get; set;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property ContextMenu* get_ContextMenu() override;
public: __property void set_ContextMenu(
   ContextMenu* value
) override;
C++/CLI
[BrowsableAttribute(false)]
public:
property ContextMenu^ ContextMenu {
   ContextMenu^ get() override;
   void set (ContextMenu^value) override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Menu Class
Menu Members


MenuItems Property

[image]
Gizmox.WebGUI.Forms
MenuItems Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Menu Class : MenuItems Property

Syntax

Visual Basic (Declaration)
<ListBindableAttribute(False)>
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public ReadOnly Property MenuItems As MenuItemCollection
Visual Basic (Usage) Copy Code
Dim instance As Menu
Dim value As MenuItemCollection

value = instance.MenuItems
C#
[ListBindableAttribute(false)]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public MenuItemCollection MenuItems {get;}
Managed Extensions for C++
[ListBindableAttribute(false)]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property MenuItemCollection* get_MenuItems();
C++/CLI
[ListBindableAttribute(false)]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
property MenuItemCollection^ MenuItems {
   MenuItemCollection^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Menu Class
Menu Members


MenuCollection Class

[image]
Gizmox.WebGUI.Forms
MenuCollection Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : MenuCollection Class

The base class for all GUI elements

Object Model

Syntax

Visual Basic (Declaration)
Public Class MenuCollection
   Inherits Component
   Implements IAttributeExtender, IEventHandler, IGatewayComponent, IObservableItem, IRegisteredComponent
Visual Basic (Usage) Copy Code
Dim instance As MenuCollection
C#
public class MenuCollection : Component, IAttributeExtender, IEventHandler, IGatewayComponent, IObservableItem, IRegisteredComponent
Managed Extensions for C++
public __gc class MenuCollection : public Component, IAttributeExtender, IEventHandler, IGatewayComponent, IObservableItem, IRegisteredComponent
C++/CLI
public ref class MenuCollection : public Component, IAttributeExtender, IEventHandler, IGatewayComponent, IObservableItem, IRegisteredComponent

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.MenuCollection

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

MenuCollection Members
Gizmox.WebGUI.Forms Namespace


MenuCollection Class Members

[image]
Gizmox.WebGUI.Forms
MenuCollection Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : MenuCollection Class

The following tables list the members exposed by MenuCollection.

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContextMenu | Gets or sets the context menu code. (Inherited from Component)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

Public Methods

 | Name | Description
Public Method | Add |
Public Method | Dispose | Overloaded. Disposes the specified component. (Inherited from Component)
Public Method | GetEnumerator |
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | Remove |
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Component)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCriticalEvents | (Inherited from Component)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnUnregisterComponents | (Inherited from Component)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Top

See Also

Reference

MenuCollection Class
Gizmox.WebGUI.Forms Namespace


MenuCollection Class Methods

[image]
Gizmox.WebGUI.Forms
MenuCollection Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : MenuCollection Class

For a list of all members of this type, see MenuCollection members.

Public Methods

 | Name | Description
Public Method | Add |
Public Method | Dispose | Overloaded. Disposes the specified component. (Inherited from Component)
Public Method | GetEnumerator |
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | Remove |
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Component)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCriticalEvents | (Inherited from Component)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnUnregisterComponents | (Inherited from Component)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

See Also

Reference

MenuCollection Class
Gizmox.WebGUI.Forms Namespace


Add Method

[image]
Gizmox.WebGUI.Forms
Add Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > MenuCollection Class : Add Method

objMenu

Syntax

Visual Basic (Declaration)
Public Function Add( _
   ByVal objMenu As Menu _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As MenuCollection
Dim objMenu As Menu
Dim value As Integer

value = instance.Add(objMenu)
C#
public int Add(
   Menu objMenu
)
Managed Extensions for C++
public: int Add(
   Menu* objMenu
)
C++/CLI
public:
int Add(
   Menu^ objMenu
)

Parameters

objMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MenuCollection Class
MenuCollection Members


GetEnumerator Method

[image]
Gizmox.WebGUI.Forms
GetEnumerator Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > MenuCollection Class : GetEnumerator Method

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As MenuCollection
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MenuCollection Class
MenuCollection Members


Remove Method

[image]
Gizmox.WebGUI.Forms
Remove Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > MenuCollection Class : Remove Method

objMenu

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal objMenu As Menu _
)
Visual Basic (Usage) Copy Code
Dim instance As MenuCollection
Dim objMenu As Menu

instance.Remove(objMenu)
C#
public void Remove(
   Menu objMenu
)
Managed Extensions for C++
public: void Remove(
   Menu* objMenu
)
C++/CLI
public:
void Remove(
   Menu^ objMenu
)

Parameters

objMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MenuCollection Class
MenuCollection Members


MenuItem Class

[image]
Gizmox.WebGUI.Forms
MenuItem Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : MenuItem Class

Summary description for Menu Item.

Object Model

Syntax

Visual Basic (Declaration)
<DesignTimeControllerAttribute()>
<ClientControllerAttribute()>
<DesignTimeVisibleAttribute()>
Public Class MenuItem
   Inherits Menu
   Implements IAttributeExtender, IEventHandler, IGatewayComponent, IMenu, IObservableItem, IRegisteredComponent, IRegisteredComponentContainer
Visual Basic (Usage) Copy Code
Dim instance As MenuItem
C#
[DesignTimeControllerAttribute()]
[ClientControllerAttribute()]
[DesignTimeVisibleAttribute()]
public class MenuItem : Menu, IAttributeExtender, IEventHandler, IGatewayComponent, IMenu, IObservableItem, IRegisteredComponent, IRegisteredComponentContainer
Managed Extensions for C++
[DesignTimeControllerAttribute()]
[ClientControllerAttribute()]
[DesignTimeVisibleAttribute()]
public __gc class MenuItem : public Menu, IAttributeExtender, IEventHandler, IGatewayComponent, IMenu, IObservableItem, IRegisteredComponent, IRegisteredComponentContainer
C++/CLI
[DesignTimeControllerAttribute()]
[ClientControllerAttribute()]
[DesignTimeVisibleAttribute()]
public ref class MenuItem : public Menu, IAttributeExtender, IEventHandler, IGatewayComponent, IMenu, IObservableItem, IRegisteredComponent, IRegisteredComponentContainer

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Menu
Gizmox.WebGUI.Forms.MenuItem

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

MenuItem Members
Gizmox.WebGUI.Forms Namespace


MenuItem Class Members

[image]
Gizmox.WebGUI.Forms
MenuItem Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : MenuItem Class

The following tables list the members exposed by MenuItem.

Public Constructors

 | Name | Description
Public Constructor | MenuItem Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Checked | Gets or sets a value indicating whether a check mark appears next to the text of the menu item.
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContextMenu | Gets or sets the context menu code. (Inherited from Menu)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets a value indicating whether this MenuItem is enabled.
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Icon | Gets or sets the menu icon.
Public Property | Index | Gets or sets a value indicating the position of the menu item in its parent menu.
Public Property | InternalParent | Overridden.
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | MenuItems | (Inherited from Menu)
Public Property | Parent | Gets the parent menu of this menu item.
Public Property | RadioCheck | Gets or sets a value indicating whether the MenuItem , if checked, displays a radio-button instead of a check mark.
Public Property | Shortcut | Gets or sets the shortcut.
Public Property | Site | (Inherited from ComponentBase)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the menu item Text.
Public Property | Visible | Indicated if the menu item is visible.
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded. Disposes the specified component. (Inherited from Component)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | RegisterMenu | (Inherited from Menu)
Public Method | Render | MainMenu render impementation (Inherited from Menu)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | UnregisterMenu | (Inherited from Menu)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Overridden. Fires an event.
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCriticalEvents | (Inherited from Component)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnUnregisterComponents | (Inherited from Menu)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

Public Events

 | Name | Description
Public Event | Click |
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Top

See Also

Reference

MenuItem Class
Gizmox.WebGUI.Forms Namespace


MenuItem Constructor

[image]
Gizmox.WebGUI.Forms
MenuItem Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > MenuItem Class : MenuItem Constructor

Overload List

Overload | Description
MenuItem Constructor() |
MenuItem Constructor(String) |
MenuItem Constructor(String,String) |
MenuItem Constructor(String,String,Object) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MenuItem Class
MenuItem Members


MenuItem Constructor()

[image]
Gizmox.WebGUI.Forms
MenuItem Constructor()
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > MenuItem Class > MenuItem Constructor : MenuItem Constructor()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As MenuItem()
C#
public MenuItem()
Managed Extensions for C++
public: MenuItem();
C++/CLI
public:
MenuItem();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MenuItem Class
MenuItem Members
Overload List


MenuItem Constructor(String)

[image]
Gizmox.WebGUI.Forms
MenuItem Constructor(String)
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > MenuItem Class > MenuItem Constructor : MenuItem Constructor(String)

strText

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal strText As String _
)
Visual Basic (Usage) Copy Code
Dim strText As String

Dim instance As MenuItem(strText)
C#
public MenuItem(
   string strText
)
Managed Extensions for C++
public: MenuItem(
   string* strText
)
C++/CLI
public:
MenuItem(
   String^ strText
)

Parameters

strText

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MenuItem Class
MenuItem Members
Overload List


MenuItem Constructor(String,String)

[image]
Gizmox.WebGUI.Forms
MenuItem Constructor(String,String)
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > MenuItem Class > MenuItem Constructor : MenuItem Constructor(String,String)

strText
strIcon

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal strText As String, _
   ByVal strIcon As String _
)
Visual Basic (Usage) Copy Code
Dim strText As String
Dim strIcon As String

Dim instance As MenuItem(strText, strIcon)
C#
public MenuItem(
   string strText,
   string strIcon
)
Managed Extensions for C++
public: MenuItem(
   string* strText,
   string* strIcon
)
C++/CLI
public:
MenuItem(
   String^ strText,
   String^ strIcon
)

Parameters

strText
strIcon

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MenuItem Class
MenuItem Members
Overload List


MenuItem Constructor(String,String,Object)

[image]
Gizmox.WebGUI.Forms
MenuItem Constructor(String,String,Object)
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > MenuItem Class > MenuItem Constructor : MenuItem Constructor(String,String,Object)

strText
The menu item Text
strIcon
The menu item icon
objTag

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal strText As String, _
   ByVal strIcon As String, _
   ByVal objTag As Object _
)
Visual Basic (Usage) Copy Code
Dim strText As String
Dim strIcon As String
Dim objTag As Object

Dim instance As MenuItem(strText, strIcon, objTag)
C#
public MenuItem(
   string strText,
   string strIcon,
   object objTag
)
Managed Extensions for C++
public: MenuItem(
   string* strText,
   string* strIcon,
   Object* objTag
)
C++/CLI
public:
MenuItem(
   String^ strText,
   String^ strIcon,
   Object^ objTag
)

Parameters

strText
The menu item Text
strIcon
The menu item icon
objTag

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MenuItem Class
MenuItem Members
Overload List


MenuItem Class Methods

[image]
Gizmox.WebGUI.Forms
MenuItem Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : MenuItem Class

For a list of all members of this type, see MenuItem members.

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded. Disposes the specified component. (Inherited from Component)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | RegisterMenu | (Inherited from Menu)
Public Method | Render | MainMenu render impementation (Inherited from Menu)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | UnregisterMenu | (Inherited from Menu)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Overridden. Fires an event.
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCriticalEvents | (Inherited from Component)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnUnregisterComponents | (Inherited from Menu)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

See Also

Reference

MenuItem Class
Gizmox.WebGUI.Forms Namespace


FireEvent Method

[image]
Gizmox.WebGUI.Forms
FireEvent Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > MenuItem Class : FireEvent Method

objEvent
event.
Fires an event.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub FireEvent( _
   ByVal objEvent As IEvent _
)
Visual Basic (Usage) Copy Code
Dim instance As MenuItem
Dim objEvent As IEvent

instance.FireEvent(objEvent)
C#
protected override void FireEvent(
   IEvent objEvent
)
Managed Extensions for C++
protected: void FireEvent(
   IEvent* objEvent
) override
C++/CLI
protected:
void FireEvent(
   IEvent^ objEvent
) override

Parameters

objEvent
event.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MenuItem Class
MenuItem Members


MenuItem Class Properties

[image]
Gizmox.WebGUI.Forms
MenuItem Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : MenuItem Class

For a list of all members of this type, see MenuItem members.

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Checked | Gets or sets a value indicating whether a check mark appears next to the text of the menu item.
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContextMenu | Gets or sets the context menu code. (Inherited from Menu)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets a value indicating whether this MenuItem is enabled.
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Icon | Gets or sets the menu icon.
Public Property | Index | Gets or sets a value indicating the position of the menu item in its parent menu.
Public Property | InternalParent | Overridden.
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | MenuItems | (Inherited from Menu)
Public Property | Parent | Gets the parent menu of this menu item.
Public Property | RadioCheck | Gets or sets a value indicating whether the MenuItem , if checked, displays a radio-button instead of a check mark.
Public Property | Shortcut | Gets or sets the shortcut.
Public Property | Site | (Inherited from ComponentBase)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the menu item Text.
Public Property | Visible | Indicated if the menu item is visible.
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

See Also

Reference

MenuItem Class
Gizmox.WebGUI.Forms Namespace


Checked Property

[image]
Gizmox.WebGUI.Forms
Checked Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > MenuItem Class : Checked Property

Gets or sets a value indicating whether a check mark appears next to the text of the menu item.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property Checked As Boolean
Visual Basic (Usage) Copy Code
Dim instance As MenuItem
Dim value As Boolean

instance.Checked = value

value = instance.Checked
C#
[DefaultValueAttribute()]
public bool Checked {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property bool get_Checked();
public: __property void set_Checked(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
public:
property bool Checked {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MenuItem Class
MenuItem Members


Enabled Property

[image]
Gizmox.WebGUI.Forms
Enabled Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > MenuItem Class : Enabled Property

Gets or sets a value indicating whether this MenuItem is enabled.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property Enabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As MenuItem
Dim value As Boolean

instance.Enabled = value

value = instance.Enabled
C#
[DefaultValueAttribute()]
public bool Enabled {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property bool get_Enabled();
public: __property void set_Enabled(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
public:
property bool Enabled {
   bool get();
   void set (boolvalue);
}

Return Value

true if enabled; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MenuItem Class
MenuItem Members


Icon Property

[image]
Gizmox.WebGUI.Forms
Icon Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > MenuItem Class : Icon Property

Gets or sets the menu icon.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property Icon As ResourceHandle
Visual Basic (Usage) Copy Code
Dim instance As MenuItem
Dim value As ResourceHandle

instance.Icon = value

value = instance.Icon
C#
[DefaultValueAttribute()]
public ResourceHandle Icon {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property ResourceHandle* get_Icon();
public: __property void set_Icon(
   ResourceHandle* value
);
C++/CLI
[DefaultValueAttribute()]
public:
property ResourceHandle^ Icon {
   ResourceHandle^ get();
   void set (ResourceHandle^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MenuItem Class
MenuItem Members


Index Property

[image]
Gizmox.WebGUI.Forms
Index Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > MenuItem Class : Index Property

Gets or sets a value indicating the position of the menu item in its parent menu.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public Property Index As Integer
Visual Basic (Usage) Copy Code
Dim instance As MenuItem
Dim value As Integer

instance.Index = value

value = instance.Index
C#
[BrowsableAttribute(false)]
public int Index {get; set;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property int get_Index();
public: __property void set_Index(
   int value
);
C++/CLI
[BrowsableAttribute(false)]
public:
property int Index {
   int get();
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MenuItem Class
MenuItem Members


InternalParent Property

[image]
Gizmox.WebGUI.Forms
InternalParent Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > MenuItem Class : InternalParent Property

Syntax

Visual Basic (Declaration)
Public Overrides Property InternalParent As Component
Visual Basic (Usage) Copy Code
Dim instance As MenuItem
Dim value As Component

instance.InternalParent = value

value = instance.InternalParent
C#
public override Component InternalParent {get; set;}
Managed Extensions for C++
public: __property Component* get_InternalParent() override;
public: __property void set_InternalParent(
   Component* value
) override;
C++/CLI
public:
property Component^ InternalParent {
   Component^ get() override;
   void set (Component^value) override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MenuItem Class
MenuItem Members


Parent Property

[image]
Gizmox.WebGUI.Forms
Parent Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > MenuItem Class : Parent Property

Gets the parent menu of this menu item.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property Parent As Menu
Visual Basic (Usage) Copy Code
Dim instance As MenuItem
Dim value As Menu

value = instance.Parent
C#
[BrowsableAttribute(false)]
public Menu Parent {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property Menu* get_Parent();
C++/CLI
[BrowsableAttribute(false)]
public:
property Menu^ Parent {
   Menu^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MenuItem Class
MenuItem Members


RadioCheck Property

[image]
Gizmox.WebGUI.Forms
RadioCheck Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > MenuItem Class : RadioCheck Property

Gets or sets a value indicating whether the MenuItem , if checked, displays a radio-button instead of a check mark.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property RadioCheck As Boolean
Visual Basic (Usage) Copy Code
Dim instance As MenuItem
Dim value As Boolean

instance.RadioCheck = value

value = instance.RadioCheck
C#
[DefaultValueAttribute()]
public bool RadioCheck {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property bool get_RadioCheck();
public: __property void set_RadioCheck(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
public:
property bool RadioCheck {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MenuItem Class
MenuItem Members


Shortcut Property

[image]
Gizmox.WebGUI.Forms
Shortcut Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > MenuItem Class : Shortcut Property

Gets or sets the shortcut.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<DefaultValueAttribute()>
Public Property Shortcut As Shortcut
Visual Basic (Usage) Copy Code
Dim instance As MenuItem
Dim value As Shortcut

instance.Shortcut = value

value = instance.Shortcut
C#
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
public Shortcut Shortcut {get; set;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
public: __property Shortcut get_Shortcut();
public: __property void set_Shortcut(
   Shortcut value
);
C++/CLI
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
public:
property Shortcut Shortcut {
   Shortcut get();
   void set (Shortcutvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MenuItem Class
MenuItem Members


Text Property

[image]
Gizmox.WebGUI.Forms
Text Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > MenuItem Class : Text Property

Gets or sets the menu item Text.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<LocalizableAttribute(True)>
<SRDescriptionAttribute("The caption displayed by the item.")>
Public Property Text As String
Visual Basic (Usage) Copy Code
Dim instance As MenuItem
Dim value As String

instance.Text = value

value = instance.Text
C#
[DefaultValueAttribute()]
[LocalizableAttribute(true)]
[SRDescriptionAttribute("The caption displayed by the item.")]
public string Text {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[LocalizableAttribute(true)]
[SRDescriptionAttribute("The caption displayed by the item.")]
public: __property string* get_Text();
public: __property void set_Text(
   string* value
);
C++/CLI
[DefaultValueAttribute()]
[LocalizableAttribute(true)]
[SRDescriptionAttribute("The caption displayed by the item.")]
public:
property String^ Text {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MenuItem Class
MenuItem Members


Visible Property

[image]
Gizmox.WebGUI.Forms
Visible Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > MenuItem Class : Visible Property

Indicated if the menu item is visible.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<BrowsableAttribute(False)>
Public Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As MenuItem
Dim value As Boolean

instance.Visible = value

value = instance.Visible
C#
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
public bool Visible {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
public: __property bool get_Visible();
public: __property void set_Visible(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
public:
property bool Visible {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MenuItem Class
MenuItem Members


MenuItem Class Events

[image]
Gizmox.WebGUI.Forms
MenuItem Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : MenuItem Class

For a list of all members of this type, see MenuItem members.

Public Events

 | Name | Description
Public Event | Click |
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Top

See Also

Reference

MenuItem Class
Gizmox.WebGUI.Forms Namespace


Click Event

[image]
Gizmox.WebGUI.Forms
Click Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > MenuItem Class : Click Event

Syntax

Visual Basic (Declaration)
Public Event Click() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As MenuItem
Dim handler As EventHandler

AddHandler instance.Click, handler
C#
public event EventHandler Click()
Managed Extensions for C++
public: __event EventHandler* Click
C++/CLI
public:
event EventHandler^ Click

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MenuItem Class
MenuItem Members


MenuItemCollection Class

[image]
Gizmox.WebGUI.Forms
MenuItemCollection Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : MenuItemCollection Class

Object Model

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class MenuItemCollection
Visual Basic (Usage) Copy Code
Dim instance As MenuItemCollection
C#
[DefaultMemberAttribute("Item")]
public class MenuItemCollection
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
public __gc class MenuItemCollection
C++/CLI
[DefaultMemberAttribute("Item")]
public ref class MenuItemCollection

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.MenuItemCollection

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

MenuItemCollection Members
Gizmox.WebGUI.Forms Namespace


MenuItemCollection Class Members

[image]
Gizmox.WebGUI.Forms
MenuItemCollection Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : MenuItemCollection Class

The following tables list the members exposed by MenuItemCollection.

Public Constructors

 | Name | Description
Public Constructor | MenuItemCollection Constructor |
Top

Public Properties

 | Name | Description
Public Property | Count | Gets the menu item count.
Public Property | IsSynchronized |
Public Property | Item |
Public Property | SyncRoot |
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Adds a previously created MenuItem at the specified index within the menu item collection.
Public Method | AddRange | Adds the range.
Public Method | Clear |
Public Method | Contains |
Public Method | CopyTo |
Public Method | GetEnumerator |
Public Method | Remove |
Public Method | RemoveAt | Removes a MenuItem from the menu item collection at a specified index.
Top

See Also

Reference

MenuItemCollection Class
Gizmox.WebGUI.Forms Namespace


MenuItemCollection Constructor

[image]
Gizmox.WebGUI.Forms
MenuItemCollection Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > MenuItemCollection Class : MenuItemCollection Constructor

objParent

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal objParent As Component _
)
Visual Basic (Usage) Copy Code
Dim objParent As Component

Dim instance As MenuItemCollection(objParent)
C#
public MenuItemCollection(
   Component objParent
)
Managed Extensions for C++
public: MenuItemCollection(
   Component* objParent
)
C++/CLI
public:
MenuItemCollection(
   Component^ objParent
)

Parameters

objParent

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MenuItemCollection Class
MenuItemCollection Members


MenuItemCollection Class Methods

[image]
Gizmox.WebGUI.Forms
MenuItemCollection Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : MenuItemCollection Class

For a list of all members of this type, see MenuItemCollection members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Adds a previously created MenuItem at the specified index within the menu item collection.
Public Method | AddRange | Adds the range.
Public Method | Clear |
Public Method | Contains |
Public Method | CopyTo |
Public Method | GetEnumerator |
Public Method | Remove |
Public Method | RemoveAt | Removes a MenuItem from the menu item collection at a specified index.
Top

See Also

Reference

MenuItemCollection Class
Gizmox.WebGUI.Forms Namespace


Add Method

[image]
Gizmox.WebGUI.Forms
Add Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > MenuItemCollection Class : Add Method

Adds a previously created MenuItem at the specified index within the menu item collection.

Overload List

Overload | Description
Add(Int32,MenuItem) | Adds a previously created MenuItem at the specified index within the menu item collection.
Add(MenuItem) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MenuItemCollection Class
MenuItemCollection Members


Add(Int32,MenuItem) Method

[image]
Gizmox.WebGUI.Forms
Add(Int32,MenuItem) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > MenuItemCollection Class > Add Method : Add(Int32,MenuItem) Method

index
The position to add the new item.
item
The MenuItem to add.

Adds a previously created MenuItem at the specified index within the menu item collection.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function Add( _
   ByVal index As Integer, _
   ByVal item As MenuItem _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As MenuItemCollection
Dim index As Integer
Dim item As MenuItem
Dim value As Integer

value = instance.Add(index, item)
C#
public virtual int Add(
   int index,
   MenuItem item
)
Managed Extensions for C++
public: virtual int Add(
   int index,
   MenuItem* item
)
C++/CLI
public:
virtual int Add(
   int index,
   MenuItem^ item
)

Parameters

index
The position to add the new item.
item
The MenuItem to add.

Return Value

The zero-based index where the item is stored in the collection.

Exceptions

Exception | Description
Exception | The MenuItem being added is already in use.
ArgumentException | The index supplied in the index parameter is larger than the size of the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MenuItemCollection Class
MenuItemCollection Members
Overload List


Add(MenuItem) Method

[image]
Gizmox.WebGUI.Forms
Add(MenuItem) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > MenuItemCollection Class > Add Method : Add(MenuItem) Method

objMenuItem

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal objMenuItem As MenuItem _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As MenuItemCollection
Dim objMenuItem As MenuItem
Dim value As Integer

value = instance.Add(objMenuItem)
C#
public int Add(
   MenuItem objMenuItem
)
Managed Extensions for C++
public: int Add(
   MenuItem* objMenuItem
)
C++/CLI
public:
int Add(
   MenuItem^ objMenuItem
)

Parameters

objMenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MenuItemCollection Class
MenuItemCollection Members
Overload List


AddRange Method

[image]
Gizmox.WebGUI.Forms
AddRange Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > MenuItemCollection Class : AddRange Method

objMenuItems
The obj menu items.
Adds the range.

Syntax

Visual Basic (Declaration)
Public Sub AddRange( _
   ByVal objMenuItems() As MenuItem _
)
Visual Basic (Usage) Copy Code
Dim instance As MenuItemCollection
Dim objMenuItems() As MenuItem

instance.AddRange(objMenuItems)
C#
public void AddRange(
   MenuItem[] objMenuItems
)
Managed Extensions for C++
public: void AddRange(
   MenuItem*[]* objMenuItems
)
C++/CLI
public:
void AddRange(
   array<MenuItem^>^ objMenuItems
)

Parameters

objMenuItems
The obj menu items.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MenuItemCollection Class
MenuItemCollection Members


Clear Method

[image]
Gizmox.WebGUI.Forms
Clear Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > MenuItemCollection Class : Clear Method

Syntax

Visual Basic (Declaration)
Public Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As MenuItemCollection

instance.Clear()
C#
public void Clear()
Managed Extensions for C++
public: void Clear();
C++/CLI
public:
void Clear();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MenuItemCollection Class
MenuItemCollection Members


Contains Method

[image]
Gizmox.WebGUI.Forms
Contains Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > MenuItemCollection Class : Contains Method

objMenuItem

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal objMenuItem As MenuItem _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As MenuItemCollection
Dim objMenuItem As MenuItem
Dim value As Boolean

value = instance.Contains(objMenuItem)
C#
public bool Contains(
   MenuItem objMenuItem
)
Managed Extensions for C++
public: bool Contains(
   MenuItem* objMenuItem
)
C++/CLI
public:
bool Contains(
   MenuItem^ objMenuItem
)

Parameters

objMenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MenuItemCollection Class
MenuItemCollection Members


CopyTo Method

[image]
Gizmox.WebGUI.Forms
CopyTo Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > MenuItemCollection Class : CopyTo Method

array
index

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array As Array, _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As MenuItemCollection
Dim array As Array
Dim index As Integer

instance.CopyTo(array, index)
C#
public void CopyTo(
   Array array,
   int index
)
Managed Extensions for C++
public: void CopyTo(
   Array* array,
   int index
)
C++/CLI
public:
void CopyTo(
   Array^ array,
   int index
)

Parameters

array
index

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MenuItemCollection Class
MenuItemCollection Members


GetEnumerator Method

[image]
Gizmox.WebGUI.Forms
GetEnumerator Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > MenuItemCollection Class : GetEnumerator Method

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As MenuItemCollection
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MenuItemCollection Class
MenuItemCollection Members


Remove Method

[image]
Gizmox.WebGUI.Forms
Remove Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > MenuItemCollection Class : Remove Method

objMenuItem

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal objMenuItem As MenuItem _
)
Visual Basic (Usage) Copy Code
Dim instance As MenuItemCollection
Dim objMenuItem As MenuItem

instance.Remove(objMenuItem)
C#
public void Remove(
   MenuItem objMenuItem
)
Managed Extensions for C++
public: void Remove(
   MenuItem* objMenuItem
)
C++/CLI
public:
void Remove(
   MenuItem^ objMenuItem
)

Parameters

objMenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MenuItemCollection Class
MenuItemCollection Members


RemoveAt Method

[image]
Gizmox.WebGUI.Forms
RemoveAt Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > MenuItemCollection Class : RemoveAt Method

index
The index of the MenuItem to remove.

Removes a MenuItem from the menu item collection at a specified index.

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveAt( _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As MenuItemCollection
Dim index As Integer

instance.RemoveAt(index)
C#
public virtual void RemoveAt(
   int index
)
Managed Extensions for C++
public: virtual void RemoveAt(
   int index
)
C++/CLI
public:
virtual void RemoveAt(
   int index
)

Parameters

index
The index of the MenuItem to remove.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MenuItemCollection Class
MenuItemCollection Members


MenuItemCollection Class Properties

[image]
Gizmox.WebGUI.Forms
MenuItemCollection Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : MenuItemCollection Class

For a list of all members of this type, see MenuItemCollection members.

Public Properties

 | Name | Description
Public Property | Count | Gets the menu item count.
Public Property | IsSynchronized |
Public Property | Item |
Public Property | SyncRoot |
Top

See Also

Reference

MenuItemCollection Class
Gizmox.WebGUI.Forms Namespace


Count Property

[image]
Gizmox.WebGUI.Forms
Count Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > MenuItemCollection Class : Count Property

Gets the menu item count.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As MenuItemCollection
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MenuItemCollection Class
MenuItemCollection Members


IsSynchronized Property

[image]
Gizmox.WebGUI.Forms
IsSynchronized Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > MenuItemCollection Class : IsSynchronized Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsSynchronized As Boolean
Visual Basic (Usage) Copy Code
Dim instance As MenuItemCollection
Dim value As Boolean

value = instance.IsSynchronized
C#
public bool IsSynchronized {get;}
Managed Extensions for C++
public: __property bool get_IsSynchronized();
C++/CLI
public:
property bool IsSynchronized {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MenuItemCollection Class
MenuItemCollection Members


Item Property

[image]
Gizmox.WebGUI.Forms
Item Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > MenuItemCollection Class : Item Property

index

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal index As Integer _
) As MenuItem
Visual Basic (Usage) Copy Code
Dim instance As MenuItemCollection
Dim index As Integer
Dim value As MenuItem

value = instance.Item(index)
C#
public MenuItem this[
   int index
]; {get;}
Managed Extensions for C++
public: __property MenuItem* get_Item(
   int index
);
C++/CLI
public:
property MenuItem^ default [int] {
   MenuItem^ get(intindex);
}

Parameters

index

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MenuItemCollection Class
MenuItemCollection Members


SyncRoot Property

[image]
Gizmox.WebGUI.Forms
SyncRoot Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > MenuItemCollection Class : SyncRoot Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SyncRoot As Object
Visual Basic (Usage) Copy Code
Dim instance As MenuItemCollection
Dim value As Object

value = instance.SyncRoot
C#
public object SyncRoot {get;}
Managed Extensions for C++
public: __property Object* get_SyncRoot();
C++/CLI
public:
property Object^ SyncRoot {
   Object^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MenuItemCollection Class
MenuItemCollection Members


MenuItemEventArgs Class

[image]
Gizmox.WebGUI.Forms
MenuItemEventArgs Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : MenuItemEventArgs Class

Menu item event arguments

Object Model

Syntax

Visual Basic (Declaration)
Public Class MenuItemEventArgs
   Inherits EventArgs
Visual Basic (Usage) Copy Code
Dim instance As MenuItemEventArgs
C#
public class MenuItemEventArgs : EventArgs
Managed Extensions for C++
public __gc class MenuItemEventArgs : public EventArgs
C++/CLI
public ref class MenuItemEventArgs : public EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gizmox.WebGUI.Forms.MenuItemEventArgs

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

MenuItemEventArgs Members
Gizmox.WebGUI.Forms Namespace


MenuItemEventArgs Class Members

[image]
Gizmox.WebGUI.Forms
MenuItemEventArgs Class Members
See Also Fields Send Feedback
Gizmox.WebGUI.Forms Namespace : MenuItemEventArgs Class

The following tables list the members exposed by MenuItemEventArgs.

Public Fields

 | Name | Description
Public Field | MenuItem |
Top

See Also

Reference

MenuItemEventArgs Class
Gizmox.WebGUI.Forms Namespace


MenuItemEventArgs Class Fields

[image]
Gizmox.WebGUI.Forms
MenuItemEventArgs Class Fields
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : MenuItemEventArgs Class

For a list of all members of this type, see MenuItemEventArgs members.

Public Fields

 | Name | Description
Public Field | MenuItem |
Top

See Also

Reference

MenuItemEventArgs Class
Gizmox.WebGUI.Forms Namespace


MenuItem Field

[image]
Gizmox.WebGUI.Forms
MenuItem Field
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > MenuItemEventArgs Class : MenuItem Field

Syntax

Visual Basic (Declaration)
Public ReadOnly MenuItem As MenuItem
Visual Basic (Usage) Copy Code
Dim instance As MenuItemEventArgs
Dim value As MenuItem

value = instance.MenuItem
C#
public readonly MenuItem MenuItem
Managed Extensions for C++
public: readonly MenuItem* MenuItem
C++/CLI
public:
readonly MenuItem^ MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MenuItemEventArgs Class
MenuItemEventArgs Members


MessageBox Class

[image]
Gizmox.WebGUI.Forms
MessageBox Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : MessageBox Class

Displays a message box that can contain text, buttons, and symbols that inform and instruct the user.

Syntax

Visual Basic (Declaration)
Public Class MessageBox
Visual Basic (Usage) Copy Code
Dim instance As MessageBox
C#
public class MessageBox
Managed Extensions for C++
public __gc class MessageBox
C++/CLI
public ref class MessageBox

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.MessageBox

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

MessageBox Members
Gizmox.WebGUI.Forms Namespace


MessageBox Class Members

[image]
Gizmox.WebGUI.Forms
MessageBox Class Members
See Also Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : MessageBox Class

The following tables list the members exposed by MessageBox.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Show | Overloaded. Displays a message box with specified text. The Show MessageBox in Visual WebGui works differently than WinForms. Code lines after this call are executed immediately and won’t wait for the dialog to close. If you need to run code only after the dialog is closed or only if a specific result is returned use Show(string strText,EventHandler objEventHandler).
Top

See Also

Reference

MessageBox Class
Gizmox.WebGUI.Forms Namespace


MessageBox Class Methods

[image]
Gizmox.WebGUI.Forms
MessageBox Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : MessageBox Class

For a list of all members of this type, see MessageBox members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Show | Overloaded. Displays a message box with specified text. The Show MessageBox in Visual WebGui works differently than WinForms. Code lines after this call are executed immediately and won’t wait for the dialog to close. If you need to run code only after the dialog is closed or only if a specific result is returned use Show(string strText,EventHandler objEventHandler).
Top

See Also

Reference

MessageBox Class
Gizmox.WebGUI.Forms Namespace


Show Method

[image]
Gizmox.WebGUI.Forms
Show Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > MessageBox Class : Show Method

Displays a message box with specified text.

The Show MessageBox in Visual WebGui works differently than WinForms. Code lines after this call are executed immediately and won’t wait for the dialog to close. If you need to run code only after the dialog is closed or only if a specific result is returned use Show(string strText,EventHandler objEventHandler).

Overload List

Overload | Description
Show(String) | Displays a message box with specified text. The Show MessageBox in Visual WebGui works differently than WinForms. Code lines after this call are executed immediately and won’t wait for the dialog to close. If you need to run code only after the dialog is closed or only if a specific result is returned use Show(string strText,EventHandler objEventHandler).
Show(String,EventHandler) | Displays a message box with specified text. The Show MessageBox in Visual WebGui works differently than WinForms. Code lines after this call are executed immediately and won’t wait for the dialog to close. If you need to run code only after the dialog is closed or only if a specific result is returned place that code in the EventHandler function that will run once the dialog is closed.
Show(String,String) | Displays a message box with specified text and caption. The Show MessageBox in Visual WebGui works differently than WinForms. Code lines after this call are executed immediately and won’t wait for the dialog to close. If you need to run code only after the dialog is closed or only if a specific result is returned use Show(string strText, string strCaption,EventHandler objEventHandler)
Show(String,String,EventHandler) | Displays a message box with specified text and caption. The Show MessageBox in Visual WebGui works differently than WinForms. Code lines after this call are executed immediately and won’t wait for the dialog to close. If you need to run code only after the dialog is closed or only if a specific result is returned place that code in the EventHandler function that will run once the dialog is closed.
Show(Form,String) | Displays a message box in front of the specified object and with the specified text. The Show MessageBox in Visual WebGui works differently than WinForms. Code lines after this call are executed immediately and won’t wait for the dialog to close. If you need to run code only after the dialog is closed or only if a specific result is returned use Show(Form objOwner, string strText,EventHandler objEventHandler)
Show(Form,String,EventHandler) | Displays a message box in front of the specified object and with the specified text. The Show MessageBox in Visual WebGui works differently than WinForms. Code lines after this call are executed immediately and won’t wait for the dialog to close. If you need to run code only after the dialog is closed or only if a specific result is returned place that code in the EventHandler function that will run once the dialog is closed.
Show(String,String,MessageBoxButtons) | Displays a message box with specified text, caption, and buttons. The Show MessageBox in Visual WebGui works differently than WinForms. Code lines after this call are executed immediately and won’t wait for the dialog to close. If you need to run code only after the dialog is closed or only if a specific result is returned use Show(string strText, string strCaption, MessageBoxButtons enmButtons, EventHandler objEventHandler)
Show(String,String,MessageBoxButtons,EventHandler) | Displays a message box with specified text, caption, and buttons. The Show MessageBox in Visual WebGui works differently than WinForms. Code lines after this call are executed immediately and won’t wait for the dialog to close. If you need to run code only after the dialog is closed or only if a specific result is returned place that code in the EventHandler function that will run once the dialog is closed.
Show(Form,String,String) | Displays a message box in front of the specified object and with the specified text and caption. The Show MessageBox in Visual WebGui works differently than WinForms. Code lines after this call are executed immediately and won’t wait for the dialog to close. If you need to run code only after the dialog is closed or only if a specific result is returned use Show(Form objOwner, string strText, string strCaption,EventHandler objEventHandler).
Show(Form,String,String,EventHandler) | Displays a message box in front of the specified object and with the specified text and caption. The Show MessageBox in Visual WebGui works differently than WinForms. Code lines after this call are executed immediately and won’t wait for the dialog to close. If you need to run code only after the dialog is closed or only if a specific result is returned place that code in the EventHandler function that will run once the dialog is closed.
Show(String,String,MessageBoxButtons,MessageBoxIcon) | Displays a message box with specified text, caption, buttons, and icon. The Show MessageBox in Visual WebGui works differently than WinForms. Code lines after this call are executed immediately and won’t wait for the dialog to close. If you need to run code only after the dialog is closed or only if a specific result is returned use Show(string strText, string strCaption, MessageBoxButtons enmButtons, MessageBoxIcon enmIcon,EventHandler objEventHandler)
Show(String,String,MessageBoxButtons,MessageBoxIcon,EventHandler) | Displays a message box with specified text, caption, buttons, and icon. The Show MessageBox in Visual WebGui works differently than WinForms. Code lines after this call are executed immediately and won’t wait for the dialog to close. If you need to run code only after the dialog is closed or only if a specific result is returned place that code in the EventHandler function that will run once the dialog is closed.
Show(Form,String,String,MessageBoxButtons) | Displays a message box in front of the specified object and with the specified text, caption, and buttons. The Show MessageBox in Visual WebGui works differently than WinForms. Code lines after this call are executed immediately and won’t wait for the dialog to close. If you need to run code only after the dialog is closed or only if a specific result is returned use Show(Form objOwner, string strText, string strCaption, MessageBoxButtons enmButtons, EventHandler objEventHandler)
Show(Form,String,String,MessageBoxButtons,EventHandler) | Displays a message box in front of the specified object and with the specified text, caption, and buttons. The Show MessageBox in Visual WebGui works differently than WinForms. Code lines after this call are executed immediately and won’t wait for the dialog to close. If you need to run code only after the dialog is closed or only if a specific result is returned place that code in the EventHandler function that will run once the dialog is closed.
Show(String,String,MessageBoxButtons,MessageBoxIcon,MessageBoxDefaultButton) | Displays a message box with the specified text, caption, buttons, icon, and default button. The Show MessageBox in Visual WebGui works differently than WinForms. Code lines after this call are executed immediately and won’t wait for the dialog to close. If you need to run code only after the dialog is closed or only if a specific result is returned use Show(string strText, string strCaption, MessageBoxButtons enmButtons, MessageBoxIcon enmIcon, MessageBoxDefaultButton enmDefaultButton,EventHandler objEventHandler)
Show(String,String,MessageBoxButtons,MessageBoxIcon,MessageBoxDefaultButton,EventHandler) | Displays a message box with the specified text, caption, buttons, icon, and default button. The Show MessageBox in Visual WebGui works differently than WinForms. Code lines after this call are executed immediately and won’t wait for the dialog to close. If you need to run code only after the dialog is closed or only if a specific result is returned place that code in the EventHandler function that will run once the dialog is closed.
Show(Form,String,String,MessageBoxButtons,MessageBoxIcon) | Displays a message box in front of the specified object and with the specified text, caption, buttons, and icon. The Show MessageBox in Visual WebGui works differently than WinForms. Code lines after this call are executed immediately and won’t wait for the dialog to close. If you need to run code only after the dialog is closed or only if a specific result is returned use Show(Form objOwner, string strText, string strCaption, MessageBoxButtons enmButtons, MessageBoxIcon enmIcon,EventHandler objEventHandler)
Show(Form,String,String,MessageBoxButtons,MessageBoxIcon,EventHandler) | Displays a message box in front of the specified object and with the specified text, caption, buttons, and icon. The Show MessageBox in Visual WebGui works differently than WinForms. Code lines after this call are executed immediately and won’t wait for the dialog to close. If you need to run code only after the dialog is closed or only if a specific result is returned place that code in the EventHandler function that will run once the dialog is closed.
Show(String,String,MessageBoxButtons,MessageBoxIcon,MessageBoxDefaultButton,MessageBoxOptions) | Displays a message box with the specified text, caption, buttons, icon, default button, and options. The Show MessageBox in Visual WebGui works differently than WinForms. Code lines after this call are executed immediately and won’t wait for the dialog to close. If you need to run code only after the dialog is closed or only if a specific result is returned use Show(string strText, string strCaption, MessageBoxButtons enmButtons, MessageBoxIcon enmIcon, MessageBoxDefaultButton enmDefaultButton, MessageBoxOptions enmOptions,EventHandler objEventHandler)
Show(String,String,MessageBoxButtons,MessageBoxIcon,MessageBoxDefaultButton,MessageBoxOptions,EventHandler) | Displays a message box with the specified text, caption, buttons, icon, default button, and options. The Show MessageBox in Visual WebGui works differently than WinForms. Code lines after this call are executed immediately and won’t wait for the dialog to close. If you need to run code only after the dialog is closed or only if a specific result is returned place that code in the EventHandler function that will run once the dialog is closed.
Show(Form,String,String,MessageBoxButtons,MessageBoxIcon,MessageBoxDefaultButton) | Displays a message box in front of the specified object and with the specified text, caption, buttons, icon, and default button. The Show MessageBox in Visual WebGui works differently than WinForms. Code lines after this call are executed immediately and won’t wait for the dialog to close. If you need to run code only after the dialog is closed or only if a specific result is returned use Show(Form objOwner, string strText, string strCaption, MessageBoxButtons enmButtons, MessageBoxIcon enmIcon, MessageBoxDefaultButton enmDefaultButton, EventHandler objEventHandler)
Show(Form,String,String,MessageBoxButtons,MessageBoxIcon,MessageBoxDefaultButton,EventHandler) | Displays a message box in front of the specified object and with the specified text, caption, buttons, icon, and default button. The Show MessageBox in Visual WebGui works differently than WinForms. Code lines after this call are executed immediately and won’t wait for the dialog to close. If you need to run code only after the dialog is closed or only if a specific result is returned place that code in the EventHandler function that will run once the dialog is closed.
Show(Form,String,String,MessageBoxButtons,MessageBoxIcon,MessageBoxDefaultButton,MessageBoxOptions) | Displays a message box in front of the specified object and with the specified text, caption, buttons, icon, default button, and options. The Show MessageBox in Visual WebGui works differently than WinForms. Code lines after this call are executed immediately and won’t wait for the dialog to close. If you need to run code only after the dialog is closed or only if a specific result is returned use Show(Form objOwner, string strText, string strCaption, MessageBoxButtons enmButtons, MessageBoxIcon enmIcon, MessageBoxDefaultButton enmDefaultButton, MessageBoxOptions enmOptions,EventHandler objEventHandler)
Show(Form,String,String,MessageBoxButtons,MessageBoxIcon,MessageBoxDefaultButton,MessageBoxOptions,EventHandler) | Displays a message box in front of the specified object and with the specified text, caption, buttons, icon, default button, and options. The Show MessageBox in Visual WebGui works differently than WinForms. Code lines after this call are executed immediately and won’t wait for the dialog to close. If you need to run code only after the dialog is closed or only if a specific result is returned place that code in the EventHandler function that will run once the dialog is closed.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageBox Class
MessageBox Members


Show(String) Method

[image]
Gizmox.WebGUI.Forms
Show(String) Method
See Also Example Send Feedback
Gizmox.WebGUI.Forms Namespace > MessageBox Class > Show Method : Show(String) Method

text
The text to display in the message box.

Displays a message box with specified text.

The Show MessageBox in Visual WebGui works differently than WinForms. Code lines after this call are executed immediately and won’t wait for the dialog to close. If you need to run code only after the dialog is closed or only if a specific result is returned use Show(string strText,EventHandler objEventHandler).

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Show( _
   ByVal text As String _
) As DialogResult
Visual Basic (Usage) Copy Code
Dim text As String
Dim value As DialogResult

value = MessageBox.Show(text)
C#
public static DialogResult Show(
   string text
)
Managed Extensions for C++
public: static DialogResult Show(
   string* text
)
C++/CLI
public:
static DialogResult Show(
   String^ text
)

Parameters

text
The text to display in the message box.

Return Value

One of the DialogResult values.

Example

The following code example displays a simple message box.
C# Copy Code
private void button1_Click(object sender, EventArgs e)
{
   MessageBox.Show("My message");
}
Visual Basic Copy Code
Private Sub button1_Click(ByVal sender As Object, ByVal e As EventArgs)
    MessageBox.Show("My message")
End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageBox Class
MessageBox Members
Overload List


Show(String,EventHandler) Method

[image]
Gizmox.WebGUI.Forms
Show(String,EventHandler) Method
See Also Example Send Feedback
Gizmox.WebGUI.Forms Namespace > MessageBox Class > Show Method : Show(String,EventHandler) Method

strText
The text to display in the message box.
objEventHandler
An System.EventHandler function.

Displays a message box with specified text.

The Show MessageBox in Visual WebGui works differently than WinForms. Code lines after this call are executed immediately and won’t wait for the dialog to close. If you need to run code only after the dialog is closed or only if a specific result is returned place that code in the EventHandler function that will run once the dialog is closed.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Show( _
   ByVal strText As String, _
   ByVal objEventHandler As EventHandler _
) As DialogResult
Visual Basic (Usage) Copy Code
Dim strText As String
Dim objEventHandler As EventHandler
Dim value As DialogResult

value = MessageBox.Show(strText, objEventHandler)
C#
public static DialogResult Show(
   string strText,
   EventHandler objEventHandler
)
Managed Extensions for C++
public: static DialogResult Show(
   string* strText,
   EventHandler* objEventHandler
)
C++/CLI
public:
static DialogResult Show(
   String^ strText,
   EventHandler^ objEventHandler
)

Parameters

strText
The text to display in the message box.
objEventHandler
An System.EventHandler function.

Return Value

One of the DialogResult values.

Example

C# Copy Code
private void button1_Click(object sender, EventArgs e)
{
   MessageBox.Show("My message", objMessageBox_Closed);
}

 private void objMessageBox_Closed(object sender, EventArgs e)
{

   if (((MessageBoxWindow)sender).DialogResult == DialogResult.OK) {
       MessageBox.Show("Message Box OK");
   }
}
Visual Basic Copy Code
Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
        MessageBox.Show("My message", AddressOf objMessageBox_Closed)
    End Sub

    Private Sub objMessageBox_Closed(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Closed
        If DirectCast(sender, MessageBoxWindow).DialogResult = DialogResult.OK Then
            MessageBox.Show("Message Box OK")
        End If

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageBox Class
MessageBox Members
Overload List


Show(String,String) Method

[image]
Gizmox.WebGUI.Forms
Show(String,String) Method
See Also Example Send Feedback
Gizmox.WebGUI.Forms Namespace > MessageBox Class > Show Method : Show(String,String) Method

strText
The text to display in the message box.
strCaption
The text to display in the title bar of the message box.

Displays a message box with specified text and caption.

The Show MessageBox in Visual WebGui works differently than WinForms. Code lines after this call are executed immediately and won’t wait for the dialog to close. If you need to run code only after the dialog is closed or only if a specific result is returned use Show(string strText, string strCaption,EventHandler objEventHandler)

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Show( _
   ByVal strText As String, _
   ByVal strCaption As String _
) As DialogResult
Visual Basic (Usage) Copy Code
Dim strText As String
Dim strCaption As String
Dim value As DialogResult

value = MessageBox.Show(strText, strCaption)
C#
public static DialogResult Show(
   string strText,
   string strCaption
)
Managed Extensions for C++
public: static DialogResult Show(
   string* strText,
   string* strCaption
)
C++/CLI
public:
static DialogResult Show(
   String^ strText,
   String^ strCaption
)

Parameters

strText
The text to display in the message box.
strCaption
The text to display in the title bar of the message box.

Return Value

One of the DialogResult values.

Example

C# Copy Code
private void button1_Click(object sender, EventArgs e)
{
   MessageBox.Show("My message", "My message caption");
}
Visual Basic Copy Code
Private Sub button1_Click(ByVal sender As Object, ByVal e As EventArgs)
    MessageBox.Show("My message", "My message caption")
End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageBox Class
MessageBox Members
Overload List


Show(String,String,EventHandler) Method

[image]
Gizmox.WebGUI.Forms
Show(String,String,EventHandler) Method
See Also Example Send Feedback
Gizmox.WebGUI.Forms Namespace > MessageBox Class > Show Method : Show(String,String,EventHandler) Method

strText
The text to display in the message box.
strCaption
The text to display in the title bar of the message box.
objEventHandler
An System.EventHandler function.

Displays a message box with specified text and caption.

The Show MessageBox in Visual WebGui works differently than WinForms. Code lines after this call are executed immediately and won’t wait for the dialog to close. If you need to run code only after the dialog is closed or only if a specific result is returned place that code in the EventHandler function that will run once the dialog is closed.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Show( _
   ByVal strText As String, _
   ByVal strCaption As String, _
   ByVal objEventHandler As EventHandler _
) As DialogResult
Visual Basic (Usage) Copy Code
Dim strText As String
Dim strCaption As String
Dim objEventHandler As EventHandler
Dim value As DialogResult

value = MessageBox.Show(strText, strCaption, objEventHandler)
C#
public static DialogResult Show(
   string strText,
   string strCaption,
   EventHandler objEventHandler
)
Managed Extensions for C++
public: static DialogResult Show(
   string* strText,
   string* strCaption,
   EventHandler* objEventHandler
)
C++/CLI
public:
static DialogResult Show(
   String^ strText,
   String^ strCaption,
   EventHandler^ objEventHandler
)

Parameters

strText
The text to display in the message box.
strCaption
The text to display in the title bar of the message box.
objEventHandler
An System.EventHandler function.

Return Value

One of the DialogResult values.

Example

C# Copy Code
private void button1_Click(object sender, EventArgs e)
{
   MessageBox.Show("My message", "My message caption", objMessageBox_Closed);
}

 private void objMessageBox_Closed(object sender, EventArgs e)
{

   if (((MessageBoxWindow)sender).DialogResult == DialogResult.OK) {
       MessageBox.Show("Message Box OK");
   }
}
Visual Basic Copy Code
Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
        MessageBox.Show("My message", "My message caption", AddressOf objMessageBox_Closed)
    End Sub

    Private Sub objMessageBox_Closed(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Closed
        If DirectCast(sender, MessageBoxWindow).DialogResult = DialogResult.OK Then
            MessageBox.Show("Message Box OK")
        End If

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageBox Class
MessageBox Members
Overload List


Show(Form,String) Method

[image]
Gizmox.WebGUI.Forms
Show(Form,String) Method
See Also Example Send Feedback
Gizmox.WebGUI.Forms Namespace > MessageBox Class > Show Method : Show(Form,String) Method

Owner
An implementation of Form that will own the modal dialog box.
Text
The text to display in the message box.

Displays a message box in front of the specified object and with the specified text.

The Show MessageBox in Visual WebGui works differently than WinForms. Code lines after this call are executed immediately and won’t wait for the dialog to close. If you need to run code only after the dialog is closed or only if a specific result is returned use Show(Form objOwner, string strText,EventHandler objEventHandler)

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Show( _
   ByVal Owner As Form, _
   ByVal Text As String _
) As DialogResult
Visual Basic (Usage) Copy Code
Dim Owner As Form
Dim Text As String
Dim value As DialogResult

value = MessageBox.Show(Owner, Text)
C#
public static DialogResult Show(
   Form Owner,
   string Text
)
Managed Extensions for C++
public: static DialogResult Show(
   Form* Owner,
   string* Text
)
C++/CLI
public:
static DialogResult Show(
   Form^ Owner,
   String^ Text
)

Parameters

Owner
An implementation of Form that will own the modal dialog box.
Text
The text to display in the message box.

Return Value

One of the DialogResult values.

Example

C# Copy Code
private Form2 objForm2 = new Form2();

 private void button1_Click(object sender, EventArgs e)
{
   MessageBox.Show(objForm2, "My message");
}
Visual Basic Copy Code
Private objForm2 As New Form2()

Private Sub button1_Click(ByVal sender As Object, ByVal e As EventArgs)
    MessageBox.Show(objForm2, "My message")
End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageBox Class
MessageBox Members
Overload List


Show(Form,String,EventHandler) Method

[image]
Gizmox.WebGUI.Forms
Show(Form,String,EventHandler) Method
See Also Example Send Feedback
Gizmox.WebGUI.Forms Namespace > MessageBox Class > Show Method : Show(Form,String,EventHandler) Method

objOwner
An implementation of Form that will own the modal dialog box.
strText
The text to display in the message box.
objEventHandler
An System.EventHandler function.

Displays a message box in front of the specified object and with the specified text.

The Show MessageBox in Visual WebGui works differently than WinForms. Code lines after this call are executed immediately and won’t wait for the dialog to close. If you need to run code only after the dialog is closed or only if a specific result is returned place that code in the EventHandler function that will run once the dialog is closed.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Show( _
   ByVal objOwner As Form, _
   ByVal strText As String, _
   ByVal objEventHandler As EventHandler _
) As DialogResult
Visual Basic (Usage) Copy Code
Dim objOwner As Form
Dim strText As String
Dim objEventHandler As EventHandler
Dim value As DialogResult

value = MessageBox.Show(objOwner, strText, objEventHandler)
C#
public static DialogResult Show(
   Form objOwner,
   string strText,
   EventHandler objEventHandler
)
Managed Extensions for C++
public: static DialogResult Show(
   Form* objOwner,
   string* strText,
   EventHandler* objEventHandler
)
C++/CLI
public:
static DialogResult Show(
   Form^ objOwner,
   String^ strText,
   EventHandler^ objEventHandler
)

Parameters

objOwner
An implementation of Form that will own the modal dialog box.
strText
The text to display in the message box.
objEventHandler
An System.EventHandler function.

Return Value

One of the DialogResult values.

Example

C# Copy Code
private Form2 objForm2 = new Form2();

 private void button1_Click(object sender, EventArgs e)
{
   MessageBox.Show(objForm2, "My message", objMessageBox_Closed);
}

 private void objMessageBox_Closed(object sender, EventArgs e)
{

   if (((MessageBoxWindow)sender).DialogResult == DialogResult.OK) {
       MessageBox.Show("Message Box OK");
   }
}
Visual Basic Copy Code
Private objForm2 As New Form2()

Private Sub button1_Click(ByVal sender As Object, ByVal e As EventArgs)
    MessageBox.Show(objForm2, "My message", AddressOf objMessageBox_Closed)
    End Sub

    Private Sub objMessageBox_Closed(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Closed
        If DirectCast(sender, MessageBoxWindow).DialogResult = DialogResult.OK Then
            MessageBox.Show("Message Box OK")
        End If

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageBox Class
MessageBox Members
Overload List


Show(String,String,MessageBoxButtons) Method

[image]
Gizmox.WebGUI.Forms
Show(String,String,MessageBoxButtons) Method
See Also Example Send Feedback
Gizmox.WebGUI.Forms Namespace > MessageBox Class > Show Method : Show(String,String,MessageBoxButtons) Method

strText
The text to display in the message box.
strCaption
The text to display in the title bar of the message box.
enmButtons
One of the MessageBoxButtons values that specifies which buttons to display in the message box.

Displays a message box with specified text, caption, and buttons.

The Show MessageBox in Visual WebGui works differently than WinForms. Code lines after this call are executed immediately and won’t wait for the dialog to close. If you need to run code only after the dialog is closed or only if a specific result is returned use Show(string strText, string strCaption, MessageBoxButtons enmButtons,
EventHandler objEventHandler)

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Show( _
   ByVal strText As String, _
   ByVal strCaption As String, _
   ByVal enmButtons As MessageBoxButtons _
) As DialogResult
Visual Basic (Usage) Copy Code
Dim strText As String
Dim strCaption As String
Dim enmButtons As MessageBoxButtons
Dim value As DialogResult

value = MessageBox.Show(strText, strCaption, enmButtons)
C#
public static DialogResult Show(
   string strText,
   string strCaption,
   MessageBoxButtons enmButtons
)
Managed Extensions for C++
public: static DialogResult Show(
   string* strText,
   string* strCaption,
   MessageBoxButtons enmButtons
)
C++/CLI
public:
static DialogResult Show(
   String^ strText,
   String^ strCaption,
   MessageBoxButtons enmButtons
)

Parameters

strText
The text to display in the message box.
strCaption
The text to display in the title bar of the message box.
enmButtons
One of the MessageBoxButtons values that specifies which buttons to display in the message box.

Return Value

One of the DialogResult values.

Exceptions

Exception | Description
InvalidEnumArgumentException | The buttons parameter specified is not a member of MessageBoxButtons.
InvalidOperationException | An attempt was made to display the MessageBox in a process that is not running in User Interactive mode. This is specified by the UserInteractive property.

Example

C# Copy Code
private void button1_Click(object sender, EventArgs e)
{
   MessageBox.Show("My message", "My message caption", MessageBoxButtons.OK);
}
Visual Basic Copy Code
Private Sub button1_Click(ByVal sender As Object, ByVal e As EventArgs)
    MessageBox.Show("My message", "My message caption", MessageBoxButtons.OK)
End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageBox Class
MessageBox Members
Overload List


Show(String,String,MessageBoxButtons,EventHandler) Method

[image]
Gizmox.WebGUI.Forms
Show(String,String,MessageBoxButtons,EventHandler) Method
See Also Example Send Feedback
Gizmox.WebGUI.Forms Namespace > MessageBox Class > Show Method : Show(String,String,MessageBoxButtons,EventHandler) Method

strText
The text to display in the message box.
strCaption
The text to display in the title bar of the message box.
enmButtons
One of the MessageBoxButtons values that specifies which buttons to display in the message box.
objEventHandler
An System.EventHandler function.

Displays a message box with specified text, caption, and buttons.

The Show MessageBox in Visual WebGui works differently than WinForms. Code lines after this call are executed immediately and won’t wait for the dialog to close. If you need to run code only after the dialog is closed or only if a specific result is returned place that code in the EventHandler function that will run once the dialog is closed.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Show( _
   ByVal strText As String, _
   ByVal strCaption As String, _
   ByVal enmButtons As MessageBoxButtons, _
   ByVal objEventHandler As EventHandler _
) As DialogResult
Visual Basic (Usage) Copy Code
Dim strText As String
Dim strCaption As String
Dim enmButtons As MessageBoxButtons
Dim objEventHandler As EventHandler
Dim value As DialogResult

value = MessageBox.Show(strText, strCaption, enmButtons, objEventHandler)
C#
public static DialogResult Show(
   string strText,
   string strCaption,
   MessageBoxButtons enmButtons,
   EventHandler objEventHandler
)
Managed Extensions for C++
public: static DialogResult Show(
   string* strText,
   string* strCaption,
   MessageBoxButtons enmButtons,
   EventHandler* objEventHandler
)
C++/CLI
public:
static DialogResult Show(
   String^ strText,
   String^ strCaption,
   MessageBoxButtons enmButtons,
   EventHandler^ objEventHandler
)

Parameters

strText
The text to display in the message box.
strCaption
The text to display in the title bar of the message box.
enmButtons
One of the MessageBoxButtons values that specifies which buttons to display in the message box.
objEventHandler
An System.EventHandler function.

Return Value

One of the DialogResult values.

Exceptions

Exception | Description
InvalidEnumArgumentException | The buttons parameter specified is not a member of MessageBoxButtons.
InvalidOperationException | An attempt was made to display the MessageBox in a process that is not running in User Interactive mode. This is specified by the UserInteractive property.

Example

C# Copy Code
private void button1_Click(object sender, EventArgs e)
{
   MessageBox.Show("My message", "My message caption", MessageBoxButtons.OK, objMessageBox_Closed);
}

 private void objMessageBox_Closed(object sender, EventArgs e)
{

   if (((MessageBoxWindow)sender).DialogResult == DialogResult.OK) {
       MessageBox.Show("Message Box OK");
   }
}
Visual Basic Copy Code
Private Sub button1_Click(ByVal sender As Object, ByVal e As EventArgs)
    MessageBox.Show("My message", "My message caption", MessageBoxButtons.OK, AddressOf objMessageBox_Closed)
    End Sub

    Private Sub objMessageBox_Closed(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Closed
        If DirectCast(sender, MessageBoxWindow).DialogResult = DialogResult.OK Then
            MessageBox.Show("Message Box OK")
        End If

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageBox Class
MessageBox Members
Overload List


Show(Form,String,String) Method

[image]
Gizmox.WebGUI.Forms
Show(Form,String,String) Method
See Also Example Send Feedback
Gizmox.WebGUI.Forms Namespace > MessageBox Class > Show Method : Show(Form,String,String) Method

objOwner
An implementation of Form that will own the modal dialog box.
strText
The text to display in the message box.
strCaption
The text to display in the title bar of the message box.

Displays a message box in front of the specified object and with the specified text and caption.

The Show MessageBox in Visual WebGui works differently than WinForms. Code lines after this call are executed immediately and won’t wait for the dialog to close. If you need to run code only after the dialog is closed or only if a specific result is returned use Show(Form objOwner, string strText, string strCaption,EventHandler objEventHandler).

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Show( _
   ByVal objOwner As Form, _
   ByVal strText As String, _
   ByVal strCaption As String _
) As DialogResult
Visual Basic (Usage) Copy Code
Dim objOwner As Form
Dim strText As String
Dim strCaption As String
Dim value As DialogResult

value = MessageBox.Show(objOwner, strText, strCaption)
C#
public static DialogResult Show(
   Form objOwner,
   string strText,
   string strCaption
)
Managed Extensions for C++
public: static DialogResult Show(
   Form* objOwner,
   string* strText,
   string* strCaption
)
C++/CLI
public:
static DialogResult Show(
   Form^ objOwner,
   String^ strText,
   String^ strCaption
)

Parameters

objOwner
An implementation of Form that will own the modal dialog box.
strText
The text to display in the message box.
strCaption
The text to display in the title bar of the message box.

Return Value

One of the DialogResult values.

Example

C# Copy Code
private void button1_Click(object sender, EventArgs e)
{
   MessageBox.Show(objForm2,"My message", "My message caption");
}
Visual Basic Copy Code
Private Sub button1_Click(ByVal sender As Object, ByVal e As EventArgs)
    MessageBox.Show(objForm2, "My message", "My message caption")
End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageBox Class
MessageBox Members
Overload List


Show(Form,String,String,EventHandler) Method

[image]
Gizmox.WebGUI.Forms
Show(Form,String,String,EventHandler) Method
See Also Example Send Feedback
Gizmox.WebGUI.Forms Namespace > MessageBox Class > Show Method : Show(Form,String,String,EventHandler) Method

objOwner
An implementation of Form that will own the modal dialog box.
strText
The text to display in the message box.
strCaption
The text to display in the title bar of the message box.
objEventHandler
An System.EventHandler function.

Displays a message box in front of the specified object and with the specified text and caption.

The Show MessageBox in Visual WebGui works differently than WinForms. Code lines after this call are executed immediately and won’t wait for the dialog to close. If you need to run code only after the dialog is closed or only if a specific result is returned place that code in the EventHandler function that will run once the dialog is closed.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Show( _
   ByVal objOwner As Form, _
   ByVal strText As String, _
   ByVal strCaption As String, _
   ByVal objEventHandler As EventHandler _
) As DialogResult
Visual Basic (Usage) Copy Code
Dim objOwner As Form
Dim strText As String
Dim strCaption As String
Dim objEventHandler As EventHandler
Dim value As DialogResult

value = MessageBox.Show(objOwner, strText, strCaption, objEventHandler)
C#
public static DialogResult Show(
   Form objOwner,
   string strText,
   string strCaption,
   EventHandler objEventHandler
)
Managed Extensions for C++
public: static DialogResult Show(
   Form* objOwner,
   string* strText,
   string* strCaption,
   EventHandler* objEventHandler
)
C++/CLI
public:
static DialogResult Show(
   Form^ objOwner,
   String^ strText,
   String^ strCaption,
   EventHandler^ objEventHandler
)

Parameters

objOwner
An implementation of Form that will own the modal dialog box.
strText
The text to display in the message box.
strCaption
The text to display in the title bar of the message box.
objEventHandler
An System.EventHandler function.

Return Value

One of the DialogResult values.

Example

C# Copy Code
private void button1_Click(object sender, EventArgs e)
{
   MessageBox.Show(objForm2,"My message", "My message caption", objMessageBox_Closed);
}

 private void objMessageBox_Closed(object sender, EventArgs e)
{

   if (((MessageBoxWindow)sender).DialogResult == DialogResult.OK) {
       MessageBox.Show("Message Box OK");
   }
}
Visual Basic Copy Code
Private Sub button1_Click(ByVal sender As Object, ByVal e As EventArgs)
    MessageBox.Show(objForm2, "My message", "My message caption", AddressOf objMessageBox_Closed)
    End Sub

    Private Sub objMessageBox_Closed(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Closed
        If DirectCast(sender, MessageBoxWindow).DialogResult = DialogResult.OK Then
            MessageBox.Show("Message Box OK")
        End If

    End Sub
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageBox Class
MessageBox Members
Overload List


Show(String,String,MessageBoxButtons,MessageBoxIcon) Method

[image]
Gizmox.WebGUI.Forms
Show(String,String,MessageBoxButtons,MessageBoxIcon) Method
See Also Example Send Feedback
Gizmox.WebGUI.Forms Namespace > MessageBox Class > Show Method : Show(String,String,MessageBoxButtons,MessageBoxIcon) Method

strText
The text to display in the message box.
strCaption
The text to display in the title bar of the message box.
enmButtons
One of the MessageBoxButtons values that specifies which buttons to display in the message box.
enmIcon
One of the MessageBoxIcon values that specifies which icon to display in the message box.

Displays a message box with specified text, caption, buttons, and icon.

The Show MessageBox in Visual WebGui works differently than WinForms. Code lines after this call are executed immediately and won’t wait for the dialog to close. If you need to run code only after the dialog is closed or only if a specific result is returned use Show(string strText, string strCaption, MessageBoxButtons enmButtons,
MessageBoxIcon enmIcon,EventHandler objEventHandler)

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Show( _
   ByVal strText As String, _
   ByVal strCaption As String, _
   ByVal enmButtons As MessageBoxButtons, _
   ByVal enmIcon As MessageBoxIcon _
) As DialogResult
Visual Basic (Usage) Copy Code
Dim strText As String
Dim strCaption As String
Dim enmButtons As MessageBoxButtons
Dim enmIcon As MessageBoxIcon
Dim value As DialogResult

value = MessageBox.Show(strText, strCaption, enmButtons, enmIcon)
C#
public static DialogResult Show(
   string strText,
   string strCaption,
   MessageBoxButtons enmButtons,
   MessageBoxIcon enmIcon
)
Managed Extensions for C++
public: static DialogResult Show(
   string* strText,
   string* strCaption,
   MessageBoxButtons enmButtons,
   MessageBoxIcon enmIcon
)
C++/CLI
public:
static DialogResult Show(
   String^ strText,
   String^ strCaption,
   MessageBoxButtons enmButtons,
   MessageBoxIcon enmIcon
)

Parameters

strText
The text to display in the message box.
strCaption
The text to display in the title bar of the message box.
enmButtons
One of the MessageBoxButtons values that specifies which buttons to display in the message box.
enmIcon
One of the MessageBoxIcon values that specifies which icon to display in the message box.

Return Value

One of the DialogResult values.

Exceptions

Exception | Description
InvalidEnumArgumentException | The buttons parameter specified is not a member of MessageBoxButtons.-or- The icon parameter specified is not a member of MessageBoxIcon.
InvalidOperationException | An attempt was made to display the MessageBox in a process that is not running in User Interactive mode. This is specified by the UserInteractive property.

Example

C# Copy Code
private void button1_Click(object sender, EventArgs e)
{
   MessageBox.Show("My message", "My message caption",MessageBoxButtons.OK,MessageBoxIcon.Information);
}
Visual Basic Copy Code
Private Sub button1_Click(ByVal sender As Object, ByVal e As EventArgs)
    MessageBox.Show("My message", "My message caption", MessageBoxButtons.OK, MessageBoxIcon.Information)
End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageBox Class
MessageBox Members
Overload List


Show(String,String,MessageBoxButtons,MessageBoxIcon,EventHandler) Method

[image]
Gizmox.WebGUI.Forms
Show(String,String,MessageBoxButtons,MessageBoxIcon,EventHandler) Method
See Also Example Send Feedback
Gizmox.WebGUI.Forms Namespace > MessageBox Class > Show Method : Show(String,String,MessageBoxButtons,MessageBoxIcon,EventHandler) Method

strText
The text to display in the message box.
strCaption
The text to display in the title bar of the message box.
enmButtons
One of the MessageBoxButtons values that specifies which buttons to display in the message box.
enmIcon
One of the MessageBoxIcon values that specifies which icon to display in the message box.
objEventHandler
An System.EventHandler function.

Displays a message box with specified text, caption, buttons, and icon.

The Show MessageBox in Visual WebGui works differently than WinForms. Code lines after this call are executed immediately and won’t wait for the dialog to close. If you need to run code only after the dialog is closed or only if a specific result is returned place that code in the EventHandler function that will run once the dialog is closed.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Show( _
   ByVal strText As String, _
   ByVal strCaption As String, _
   ByVal enmButtons As MessageBoxButtons, _
   ByVal enmIcon As MessageBoxIcon, _
   ByVal objEventHandler As EventHandler _
) As DialogResult
Visual Basic (Usage) Copy Code
Dim strText As String
Dim strCaption As String
Dim enmButtons As MessageBoxButtons
Dim enmIcon As MessageBoxIcon
Dim objEventHandler As EventHandler
Dim value As DialogResult

value = MessageBox.Show(strText, strCaption, enmButtons, enmIcon, objEventHandler)
C#
public static DialogResult Show(
   string strText,
   string strCaption,
   MessageBoxButtons enmButtons,
   MessageBoxIcon enmIcon,
   EventHandler objEventHandler
)
Managed Extensions for C++
public: static DialogResult Show(
   string* strText,
   string* strCaption,
   MessageBoxButtons enmButtons,
   MessageBoxIcon enmIcon,
   EventHandler* objEventHandler
)
C++/CLI
public:
static DialogResult Show(
   String^ strText,
   String^ strCaption,
   MessageBoxButtons enmButtons,
   MessageBoxIcon enmIcon,
   EventHandler^ objEventHandler
)

Parameters

strText
The text to display in the message box.
strCaption
The text to display in the title bar of the message box.
enmButtons
One of the MessageBoxButtons values that specifies which buttons to display in the message box.
enmIcon
One of the MessageBoxIcon values that specifies which icon to display in the message box.
objEventHandler
An System.EventHandler function.

Return Value

One of the DialogResult values.

Exceptions

Exception | Description
InvalidEnumArgumentException | The buttons parameter specified is not a member of MessageBoxButtons.-or- The icon parameter specified is not a member of MessageBoxIcon.
InvalidOperationException | An attempt was made to display the MessageBox in a process that is not running in User Interactive mode. This is specified by the UserInteractive property.

Example

C# Copy Code
private void button1_Click(object sender, EventArgs e)
{
   MessageBox.Show("My message", "My message caption",MessageBoxButtons.OK, MessageBoxIcon.Information, objMessageBox_Closed);
}

 private void objMessageBox_Closed(object sender, EventArgs e)
{

   if (((MessageBoxWindow)sender).DialogResult == DialogResult.OK) {
       MessageBox.Show("Message Box OK");
   }
}
Visual Basic Copy Code
Private Sub button1_Click(ByVal sender As Object, ByVal e As EventArgs)
    MessageBox.Show("My message", "My message caption", MessageBoxButtons.OK, MessageBoxIcon.Information, AddressOf objMessageBox_Closed)
    End Sub

    Private Sub objMessageBox_Closed(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Closed
        If DirectCast(sender, MessageBoxWindow).DialogResult = DialogResult.OK Then
            MessageBox.Show("Message Box OK")
        End If

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageBox Class
MessageBox Members
Overload List


Show(Form,String,String,MessageBoxButtons) Method

[image]
Gizmox.WebGUI.Forms
Show(Form,String,String,MessageBoxButtons) Method
See Also Example Send Feedback
Gizmox.WebGUI.Forms Namespace > MessageBox Class > Show Method : Show(Form,String,String,MessageBoxButtons) Method

objOwner
An implementation of Form that will own the modal dialog box.
strText
The text to display in the message box.
strCaption
The text to display in the title bar of the message box.
enmButtons
One of the MessageBoxButtons values that specifies which buttons to display in the message box.

Displays a message box in front of the specified object and with the specified text, caption, and buttons.

The Show MessageBox in Visual WebGui works differently than WinForms. Code lines after this call are executed immediately and won’t wait for the dialog to close. If you need to run code only after the dialog is closed or only if a specific result is returned use Show(Form objOwner, string strText, string strCaption, MessageBoxButtons enmButtons, EventHandler objEventHandler)

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Show( _
   ByVal objOwner As Form, _
   ByVal strText As String, _
   ByVal strCaption As String, _
   ByVal enmButtons As MessageBoxButtons _
) As DialogResult
Visual Basic (Usage) Copy Code
Dim objOwner As Form
Dim strText As String
Dim strCaption As String
Dim enmButtons As MessageBoxButtons
Dim value As DialogResult

value = MessageBox.Show(objOwner, strText, strCaption, enmButtons)
C#
public static DialogResult Show(
   Form objOwner,
   string strText,
   string strCaption,
   MessageBoxButtons enmButtons
)
Managed Extensions for C++
public: static DialogResult Show(
   Form* objOwner,
   string* strText,
   string* strCaption,
   MessageBoxButtons enmButtons
)
C++/CLI
public:
static DialogResult Show(
   Form^ objOwner,
   String^ strText,
   String^ strCaption,
   MessageBoxButtons enmButtons
)

Parameters

objOwner
An implementation of Form that will own the modal dialog box.
strText
The text to display in the message box.
strCaption
The text to display in the title bar of the message box.
enmButtons
One of the MessageBoxButtons values that specifies which buttons to display in the message box.

Return Value

One of the DialogResult values.

Exceptions

Exception | Description
InvalidOperationException | An attempt was made to display the MessageBox in a process that is not running in User Interactive mode. This is specified by the UserInteractive property.
InvalidEnumArgumentException | buttons is not a member of MessageBoxButtons.

Example

C# Copy Code
private void button1_Click(object sender, EventArgs e)
{
   MessageBox.Show(objForm2, "My message", "My message caption", MessageBoxButtons.OK);
}
Visual Basic Copy Code
Private Sub button1_Click(ByVal sender As Object, ByVal e As EventArgs)
    MessageBox.Show(objForm2, "My message", "My message caption", MessageBoxButtons.OK)
End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageBox Class
MessageBox Members
Overload List


Show(Form,String,String,MessageBoxButtons,EventHandler) Method

[image]
Gizmox.WebGUI.Forms
Show(Form,String,String,MessageBoxButtons,EventHandler) Method
See Also Example Send Feedback
Gizmox.WebGUI.Forms Namespace > MessageBox Class > Show Method : Show(Form,String,String,MessageBoxButtons,EventHandler) Method

objOwner
An implementation of Form that will own the modal dialog box.
strText
The text to display in the message box.
strCaption
The text to display in the title bar of the message box.
enmButtons
One of the MessageBoxButtons values that specifies which buttons to display in the message box.
objEventHandler
An System.EventHandler function.

Displays a message box in front of the specified object and with the specified text, caption, and buttons.

The Show MessageBox in Visual WebGui works differently than WinForms. Code lines after this call are executed immediately and won’t wait for the dialog to close. If you need to run code only after the dialog is closed or only if a specific result is returned place that code in the EventHandler function that will run once the dialog is closed.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Show( _
   ByVal objOwner As Form, _
   ByVal strText As String, _
   ByVal strCaption As String, _
   ByVal enmButtons As MessageBoxButtons, _
   ByVal objEventHandler As EventHandler _
) As DialogResult
Visual Basic (Usage) Copy Code
Dim objOwner As Form
Dim strText As String
Dim strCaption As String
Dim enmButtons As MessageBoxButtons
Dim objEventHandler As EventHandler
Dim value As DialogResult

value = MessageBox.Show(objOwner, strText, strCaption, enmButtons, objEventHandler)
C#
public static DialogResult Show(
   Form objOwner,
   string strText,
   string strCaption,
   MessageBoxButtons enmButtons,
   EventHandler objEventHandler
)
Managed Extensions for C++
public: static DialogResult Show(
   Form* objOwner,
   string* strText,
   string* strCaption,
   MessageBoxButtons enmButtons,
   EventHandler* objEventHandler
)
C++/CLI
public:
static DialogResult Show(
   Form^ objOwner,
   String^ strText,
   String^ strCaption,
   MessageBoxButtons enmButtons,
   EventHandler^ objEventHandler
)

Parameters

objOwner
An implementation of Form that will own the modal dialog box.
strText
The text to display in the message box.
strCaption
The text to display in the title bar of the message box.
enmButtons
One of the MessageBoxButtons values that specifies which buttons to display in the message box.
objEventHandler
An System.EventHandler function.

Return Value

One of the DialogResult values.

Exceptions

Exception | Description
InvalidOperationException | An attempt was made to display the MessageBox in a process that is not running in User Interactive mode. This is specified by the UserInteractive property.
InvalidEnumArgumentException | buttons is not a member of MessageBoxButtons.

Example

C# Copy Code
private void button1_Click(object sender, EventArgs e)
{
   MessageBox.Show(objForm2, "My message", "My message caption", MessageBoxButtons.OK, objMessageBox_Closed);
}

 private void objMessageBox_Closed(object sender, EventArgs e)
{

   if (((MessageBoxWindow)sender).DialogResult == DialogResult.OK) {
       MessageBox.Show("Message Box OK");
   }
}
Visual Basic Copy Code
Private Sub button1_Click(ByVal sender As Object, ByVal e As EventArgs)
    MessageBox.Show(objForm2, "My message", "My message caption", MessageBoxButtons.OK, AddressOf objMessageBox_Closed)
    End Sub

    Private Sub objMessageBox_Closed(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Closed
        If DirectCast(sender, MessageBoxWindow).DialogResult = DialogResult.OK Then
            MessageBox.Show("Message Box OK")
        End If

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageBox Class
MessageBox Members
Overload List


Show(String,String,MessageBoxButtons,MessageBoxIcon,MessageBoxDefaultButton) Method

[image]
Gizmox.WebGUI.Forms
Show(String,String,MessageBoxButtons,MessageBoxIcon,MessageBoxDefaultButton) Method
See Also Example Send Feedback
Gizmox.WebGUI.Forms Namespace > MessageBox Class > Show Method : Show(String,String,MessageBoxButtons,MessageBoxIcon,MessageBoxDefaultButton) Method

strText
The text to display in the message box.
strCaption
The text to display in the title bar of the message box.
enmButtons
One of the MessageBoxButtons values that specifies which buttons to display in the message box.
enmIcon
One of the MessageBoxIcon values that specifies which icon to display in the message box.
enmDefaultButton
One of the MessageBoxDefaultButton values that specifies the default button for the message box.

Displays a message box with the specified text, caption, buttons, icon, and default button.

The Show MessageBox in Visual WebGui works differently than WinForms. Code lines after this call are executed immediately and won’t wait for the dialog to close. If you need to run code only after the dialog is closed or only if a specific result is returned use Show(string strText, string strCaption, MessageBoxButtons enmButtons, MessageBoxIcon enmIcon, MessageBoxDefaultButton enmDefaultButton,EventHandler objEventHandler)

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Show( _
   ByVal strText As String, _
   ByVal strCaption As String, _
   ByVal enmButtons As MessageBoxButtons, _
   ByVal enmIcon As MessageBoxIcon, _
   ByVal enmDefaultButton As MessageBoxDefaultButton _
) As DialogResult
Visual Basic (Usage) Copy Code
Dim strText As String
Dim strCaption As String
Dim enmButtons As MessageBoxButtons
Dim enmIcon As MessageBoxIcon
Dim enmDefaultButton As MessageBoxDefaultButton
Dim value As DialogResult

value = MessageBox.Show(strText, strCaption, enmButtons, enmIcon, enmDefaultButton)
C#
public static DialogResult Show(
   string strText,
   string strCaption,
   MessageBoxButtons enmButtons,
   MessageBoxIcon enmIcon,
   MessageBoxDefaultButton enmDefaultButton
)
Managed Extensions for C++
public: static DialogResult Show(
   string* strText,
   string* strCaption,
   MessageBoxButtons enmButtons,
   MessageBoxIcon enmIcon,
   MessageBoxDefaultButton enmDefaultButton
)
C++/CLI
public:
static DialogResult Show(
   String^ strText,
   String^ strCaption,
   MessageBoxButtons enmButtons,
   MessageBoxIcon enmIcon,
   MessageBoxDefaultButton enmDefaultButton
)

Parameters

strText
The text to display in the message box.
strCaption
The text to display in the title bar of the message box.
enmButtons
One of the MessageBoxButtons values that specifies which buttons to display in the message box.
enmIcon
One of the MessageBoxIcon values that specifies which icon to display in the message box.
enmDefaultButton
One of the MessageBoxDefaultButton values that specifies the default button for the message box.

Return Value

One of the DialogResult values.

Exceptions

Exception | Description
InvalidEnumArgumentException | buttons is not a member of MessageBoxButtons.-or- icon is not a member of MessageBoxIcon.-or- defaultButton is not a member of MessageBoxDefaultButton.
InvalidOperationException | An attempt was made to display the MessageBox in a process that is not running in User Interactive mode. This is specified by the UserInteractive property.

Example

C# Copy Code
private void button1_Click(object sender, EventArgs e)
{
   MessageBox.Show("My message", "My message caption",MessageBoxButtons.OK,MessageBoxIcon.Information,MessageBoxDefaultButton.Button1);
}
Visual Basic Copy Code
Private Sub button1_Click(ByVal sender As Object, ByVal e As EventArgs)
    MessageBox.Show("My message", "My message caption", MessageBoxButtons.OK, MessageBoxIcon.Information, MessageBoxDefaultButton.Button1)
End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageBox Class
MessageBox Members
Overload List


Show(String,String,MessageBoxButtons,MessageBoxIcon,MessageBoxDefaultButton,EventHandler) Method

[image]
Gizmox.WebGUI.Forms
Show(String,String,MessageBoxButtons,MessageBoxIcon,MessageBoxDefaultButton,EventHandler) Method
See Also Example Send Feedback
Gizmox.WebGUI.Forms Namespace > MessageBox Class > Show Method : Show(String,String,MessageBoxButtons,MessageBoxIcon,MessageBoxDefaultButton,EventHandler) Method

strText
The text to display in the message box.
strCaption
The text to display in the title bar of the message box.
enmButtons
One of the MessageBoxButtons values that specifies which buttons to display in the message box.
enmIcon
One of the MessageBoxIcon values that specifies which icon to display in the message box.
enmDefaultButton
One of the MessageBoxDefaultButton values that specifies the default button for the message box.
objEventHandler
An System.EventHandler function.

Displays a message box with the specified text, caption, buttons, icon, and default button.

The Show MessageBox in Visual WebGui works differently than WinForms. Code lines after this call are executed immediately and won’t wait for the dialog to close. If you need to run code only after the dialog is closed or only if a specific result is returned place that code in the EventHandler function that will run once the dialog is closed.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Show( _
   ByVal strText As String, _
   ByVal strCaption As String, _
   ByVal enmButtons As MessageBoxButtons, _
   ByVal enmIcon As MessageBoxIcon, _
   ByVal enmDefaultButton As MessageBoxDefaultButton, _
   ByVal objEventHandler As EventHandler _
) As DialogResult
Visual Basic (Usage) Copy Code
Dim strText As String
Dim strCaption As String
Dim enmButtons As MessageBoxButtons
Dim enmIcon As MessageBoxIcon
Dim enmDefaultButton As MessageBoxDefaultButton
Dim objEventHandler As EventHandler
Dim value As DialogResult

value = MessageBox.Show(strText, strCaption, enmButtons, enmIcon, enmDefaultButton, objEventHandler)
C#
public static DialogResult Show(
   string strText,
   string strCaption,
   MessageBoxButtons enmButtons,
   MessageBoxIcon enmIcon,
   MessageBoxDefaultButton enmDefaultButton,
   EventHandler objEventHandler
)
Managed Extensions for C++
public: static DialogResult Show(
   string* strText,
   string* strCaption,
   MessageBoxButtons enmButtons,
   MessageBoxIcon enmIcon,
   MessageBoxDefaultButton enmDefaultButton,
   EventHandler* objEventHandler
)
C++/CLI
public:
static DialogResult Show(
   String^ strText,
   String^ strCaption,
   MessageBoxButtons enmButtons,
   MessageBoxIcon enmIcon,
   MessageBoxDefaultButton enmDefaultButton,
   EventHandler^ objEventHandler
)

Parameters

strText
The text to display in the message box.
strCaption
The text to display in the title bar of the message box.
enmButtons
One of the MessageBoxButtons values that specifies which buttons to display in the message box.
enmIcon
One of the MessageBoxIcon values that specifies which icon to display in the message box.
enmDefaultButton
One of the MessageBoxDefaultButton values that specifies the default button for the message box.
objEventHandler
An System.EventHandler function.

Return Value

One of the DialogResult values.

Exceptions

Exception | Description
InvalidEnumArgumentException | buttons is not a member of MessageBoxButtons.-or- icon is not a member of MessageBoxIcon.-or- defaultButton is not a member of MessageBoxDefaultButton.
InvalidOperationException | An attempt was made to display the MessageBox in a process that is not running in User Interactive mode. This is specified by the UserInteractive property.

Example

C# Copy Code
private void button1_Click(object sender, EventArgs e)
{
   MessageBox.Show("My message", "My message caption",MessageBoxButtons.OK,MessageBoxIcon.Information,MessageBoxDefaultButton.Button1, objMessageBox_Closed);
}

 private void objMessageBox_Closed(object sender, EventArgs e)
{

   if (((MessageBoxWindow)sender).DialogResult == DialogResult.OK) {
       MessageBox.Show("Message Box OK");
   }
}
Visual Basic Copy Code
Private Sub button1_Click(ByVal sender As Object, ByVal e As EventArgs)
    MessageBox.Show("My message", "My message caption", MessageBoxButtons.OK, MessageBoxIcon.Information, MessageBoxDefaultButton.Button1, AddressOf objMessageBox_Closed)
    End Sub

    Private Sub objMessageBox_Closed(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Closed
        If DirectCast(sender, MessageBoxWindow).DialogResult = DialogResult.OK Then
            MessageBox.Show("Message Box OK")
        End If

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageBox Class
MessageBox Members
Overload List


Show(Form,String,String,MessageBoxButtons,MessageBoxIcon) Method

[image]
Gizmox.WebGUI.Forms
Show(Form,String,String,MessageBoxButtons,MessageBoxIcon) Method
See Also Example Send Feedback
Gizmox.WebGUI.Forms Namespace > MessageBox Class > Show Method : Show(Form,String,String,MessageBoxButtons,MessageBoxIcon) Method

objOwner
An implementation of Form that will own the modal dialog box.
strText
The text to display in the message box.
strCaption
The text to display in the title bar of the message box.
enmButtons
One of the MessageBoxButtons values that specifies which buttons to display in the message box.
enmIcon
One of the MessageBoxIcon values that specifies which icon to display in the message box.

Displays a message box in front of the specified object and with the specified text, caption, buttons, and icon.

The Show MessageBox in Visual WebGui works differently than WinForms. Code lines after this call are executed immediately and won’t wait for the dialog to close. If you need to run code only after the dialog is closed or only if a specific result is returned use Show(Form objOwner, string strText, string strCaption,
MessageBoxButtons enmButtons, MessageBoxIcon enmIcon,EventHandler objEventHandler)

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Show( _
   ByVal objOwner As Form, _
   ByVal strText As String, _
   ByVal strCaption As String, _
   ByVal enmButtons As MessageBoxButtons, _
   ByVal enmIcon As MessageBoxIcon _
) As DialogResult
Visual Basic (Usage) Copy Code
Dim objOwner As Form
Dim strText As String
Dim strCaption As String
Dim enmButtons As MessageBoxButtons
Dim enmIcon As MessageBoxIcon
Dim value As DialogResult

value = MessageBox.Show(objOwner, strText, strCaption, enmButtons, enmIcon)
C#
public static DialogResult Show(
   Form objOwner,
   string strText,
   string strCaption,
   MessageBoxButtons enmButtons,
   MessageBoxIcon enmIcon
)
Managed Extensions for C++
public: static DialogResult Show(
   Form* objOwner,
   string* strText,
   string* strCaption,
   MessageBoxButtons enmButtons,
   MessageBoxIcon enmIcon
)
C++/CLI
public:
static DialogResult Show(
   Form^ objOwner,
   String^ strText,
   String^ strCaption,
   MessageBoxButtons enmButtons,
   MessageBoxIcon enmIcon
)

Parameters

objOwner
An implementation of Form that will own the modal dialog box.
strText
The text to display in the message box.
strCaption
The text to display in the title bar of the message box.
enmButtons
One of the MessageBoxButtons values that specifies which buttons to display in the message box.
enmIcon
One of the MessageBoxIcon values that specifies which icon to display in the message box.

Return Value

One of the DialogResult values.

Exceptions

Exception | Description
InvalidEnumArgumentException | buttons is not a member of MessageBoxButtons.-or- icon is not a member of MessageBoxIcon.
InvalidOperationException | An attempt was made to display the MessageBox in a process that is not running in User Interactive mode. This is specified by the UserInteractive property.

Example

C# Copy Code
private void button1_Click(object sender, EventArgs e)
{
   MessageBox.Show(objForm2, "My message", "My message caption", MessageBoxButtons.OK, MessageBoxIcon.Information);
}
Visual Basic Copy Code
Private Sub button1_Click(ByVal sender As Object, ByVal e As EventArgs)
    MessageBox.Show(objForm2, "My message", "My message caption", MessageBoxButtons.OK, MessageBoxIcon.Information)
End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageBox Class
MessageBox Members
Overload List


Show(Form,String,String,MessageBoxButtons,MessageBoxIcon,EventHandler) Method

[image]
Gizmox.WebGUI.Forms
Show(Form,String,String,MessageBoxButtons,MessageBoxIcon,EventHandler) Method
See Also Example Send Feedback
Gizmox.WebGUI.Forms Namespace > MessageBox Class > Show Method : Show(Form,String,String,MessageBoxButtons,MessageBoxIcon,EventHandler) Method

objOwner
An implementation of Form that will own the modal dialog box.
strText
The text to display in the message box.
strCaption
The text to display in the title bar of the message box.
enmButtons
One of the MessageBoxButtons values that specifies which buttons to display in the message box.
enmIcon
One of the MessageBoxIcon values that specifies which icon to display in the message box.
objEventHandler
An System.EventHandler function.

Displays a message box in front of the specified object and with the specified text, caption, buttons, and icon.

The Show MessageBox in Visual WebGui works differently than WinForms. Code lines after this call are executed immediately and won’t wait for the dialog to close. If you need to run code only after the dialog is closed or only if a specific result is returned place that code in the EventHandler function that will run once the dialog is closed.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Show( _
   ByVal objOwner As Form, _
   ByVal strText As String, _
   ByVal strCaption As String, _
   ByVal enmButtons As MessageBoxButtons, _
   ByVal enmIcon As MessageBoxIcon, _
   ByVal objEventHandler As EventHandler _
) As DialogResult
Visual Basic (Usage) Copy Code
Dim objOwner As Form
Dim strText As String
Dim strCaption As String
Dim enmButtons As MessageBoxButtons
Dim enmIcon As MessageBoxIcon
Dim objEventHandler As EventHandler
Dim value As DialogResult

value = MessageBox.Show(objOwner, strText, strCaption, enmButtons, enmIcon, objEventHandler)
C#
public static DialogResult Show(
   Form objOwner,
   string strText,
   string strCaption,
   MessageBoxButtons enmButtons,
   MessageBoxIcon enmIcon,
   EventHandler objEventHandler
)
Managed Extensions for C++
public: static DialogResult Show(
   Form* objOwner,
   string* strText,
   string* strCaption,
   MessageBoxButtons enmButtons,
   MessageBoxIcon enmIcon,
   EventHandler* objEventHandler
)
C++/CLI
public:
static DialogResult Show(
   Form^ objOwner,
   String^ strText,
   String^ strCaption,
   MessageBoxButtons enmButtons,
   MessageBoxIcon enmIcon,
   EventHandler^ objEventHandler
)

Parameters

objOwner
An implementation of Form that will own the modal dialog box.
strText
The text to display in the message box.
strCaption
The text to display in the title bar of the message box.
enmButtons
One of the MessageBoxButtons values that specifies which buttons to display in the message box.
enmIcon
One of the MessageBoxIcon values that specifies which icon to display in the message box.
objEventHandler
An System.EventHandler function.

Return Value

One of the DialogResult values.

Exceptions

Exception | Description
InvalidEnumArgumentException | buttons is not a member of MessageBoxButtons.-or- icon is not a member of MessageBoxIcon.
InvalidOperationException | An attempt was made to display the MessageBox in a process that is not running in User Interactive mode. This is specified by the UserInteractive property.

Example

C# Copy Code
private void button1_Click(object sender, EventArgs e)
{
   MessageBox.Show(objForm2, "My message", "My message caption", MessageBoxButtons.OK, MessageBoxIcon.Information, objMessageBox_Closed);
}

 private void objMessageBox_Closed(object sender, EventArgs e)
{

   if (((MessageBoxWindow)sender).DialogResult == DialogResult.OK) {
       MessageBox.Show("Message Box OK");
   }
}
Visual Basic Copy Code
Private Sub button1_Click(ByVal sender As Object, ByVal e As EventArgs)
    MessageBox.Show(objForm2, "My message", "My message caption", MessageBoxButtons.OK, MessageBoxIcon.Information, AddressOf objMessageBox_Closed)
    End Sub

    Private Sub objMessageBox_Closed(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Closed
        If DirectCast(sender, MessageBoxWindow).DialogResult = DialogResult.OK Then
            MessageBox.Show("Message Box OK")
        End If

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageBox Class
MessageBox Members
Overload List


Show(String,String,MessageBoxButtons,MessageBoxIcon,MessageBoxDefaultButton,MessageBoxOptions) Method

[image]
Gizmox.WebGUI.Forms
Show(String,String,MessageBoxButtons,MessageBoxIcon,MessageBoxDefaultButton,MessageBoxOptions) Method
See Also Example Send Feedback
Gizmox.WebGUI.Forms Namespace > MessageBox Class > Show Method : Show(String,String,MessageBoxButtons,MessageBoxIcon,MessageBoxDefaultButton,MessageBoxOptions) Method

strText
The text to display in the message box.
strCaption
The text to display in the title bar of the message box.
enmButtons
One of the MessageBoxButtons values that specifies which buttons to display in the message box.
enmIcon
One of the MessageBoxIcon values that specifies which icon to display in the message box.
enmDefaultButton
One of the MessageBoxDefaultButton values that specifies the default button for the message box.
enmOptions
One of the MessageBoxOptions values that specifies which display and association options will be used for the message box. You may pass in 0 if you wish to use the defaults.

Displays a message box with the specified text, caption, buttons, icon, default button, and options.

The Show MessageBox in Visual WebGui works differently than WinForms. Code lines after this call are executed immediately and won’t wait for the dialog to close. If you need to run code only after the dialog is closed or only if a specific result is returned use Show(string strText, string strCaption,
MessageBoxButtons enmButtons, MessageBoxIcon enmIcon, MessageBoxDefaultButton enmDefaultButton,
MessageBoxOptions enmOptions,EventHandler objEventHandler)

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Show( _
   ByVal strText As String, _
   ByVal strCaption As String, _
   ByVal enmButtons As MessageBoxButtons, _
   ByVal enmIcon As MessageBoxIcon, _
   ByVal enmDefaultButton As MessageBoxDefaultButton, _
   ByVal enmOptions As MessageBoxOptions _
) As DialogResult
Visual Basic (Usage) Copy Code
Dim strText As String
Dim strCaption As String
Dim enmButtons As MessageBoxButtons
Dim enmIcon As MessageBoxIcon
Dim enmDefaultButton As MessageBoxDefaultButton
Dim enmOptions As MessageBoxOptions
Dim value As DialogResult

value = MessageBox.Show(strText, strCaption, enmButtons, enmIcon, enmDefaultButton, enmOptions)
C#
public static DialogResult Show(
   string strText,
   string strCaption,
   MessageBoxButtons enmButtons,
   MessageBoxIcon enmIcon,
   MessageBoxDefaultButton enmDefaultButton,
   MessageBoxOptions enmOptions
)
Managed Extensions for C++
public: static DialogResult Show(
   string* strText,
   string* strCaption,
   MessageBoxButtons enmButtons,
   MessageBoxIcon enmIcon,
   MessageBoxDefaultButton enmDefaultButton,
   MessageBoxOptions enmOptions
)
C++/CLI
public:
static DialogResult Show(
   String^ strText,
   String^ strCaption,
   MessageBoxButtons enmButtons,
   MessageBoxIcon enmIcon,
   MessageBoxDefaultButton enmDefaultButton,
   MessageBoxOptions enmOptions
)

Parameters

strText
The text to display in the message box.
strCaption
The text to display in the title bar of the message box.
enmButtons
One of the MessageBoxButtons values that specifies which buttons to display in the message box.
enmIcon
One of the MessageBoxIcon values that specifies which icon to display in the message box.
enmDefaultButton
One of the MessageBoxDefaultButton values that specifies the default button for the message box.
enmOptions
One of the MessageBoxOptions values that specifies which display and association options will be used for the message box. You may pass in 0 if you wish to use the defaults.

Return Value

One of the DialogResult values.

Exceptions

Exception | Description
InvalidEnumArgumentException | buttons is not a member of MessageBoxButtons.-or- icon is not a member of MessageBoxIcon.-or- The defaultButton specified is not a member of MessageBoxDefaultButton.
ArgumentException | options specified both MessageBoxOptions.DefaultDesktopOnly and MessageBoxOptions.ServiceNotification.-or- buttons specified an invalid combination of MessageBoxButtons.
InvalidOperationException | An attempt was made to display the MessageBox in a process that is not running in User Interactive mode. This is specified by the UserInteractive property.

Example

C# Copy Code
private void button1_Click(object sender, EventArgs e)
{
   MessageBox.Show("My message", "My message caption",MessageBoxButtons.OK,MessageBoxIcon.Information,MessageBoxDefaultButton.Button1,MessageBoxOptions.RightAlign);
}
Visual Basic Copy Code
Private Sub button1_Click(ByVal sender As Object, ByVal e As EventArgs)
    MessageBox.Show("My message", "My message caption", MessageBoxButtons.OK, MessageBoxIcon.Information, MessageBoxDefaultButton.Button1, MessageBoxOptions.RightAlign)
End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageBox Class
MessageBox Members
Overload List


Show(String,String,MessageBoxButtons,MessageBoxIcon,MessageBoxDefaultButton,MessageBoxOptions,EventHandler) Method

[image]
Gizmox.WebGUI.Forms
Show(String,String,MessageBoxButtons,MessageBoxIcon,MessageBoxDefaultButton,MessageBoxOptions,EventHandler) Method
See Also Example Send Feedback
Gizmox.WebGUI.Forms Namespace > MessageBox Class > Show Method : Show(String,String,MessageBoxButtons,MessageBoxIcon,MessageBoxDefaultButton,MessageBoxOptions,EventHandler) Method

strText
The text to display in the message box.
strCaption
The text to display in the title bar of the message box.
enmButtons
One of the MessageBoxButtons values that specifies which buttons to display in the message box.
enmIcon
One of the MessageBoxIcon values that specifies which icon to display in the message box.
enmDefaultButton
One of the MessageBoxDefaultButton values that specifies the default button for the message box.
enmOptions
One of the MessageBoxOptions values that specifies which display and association options will be used for the message box. You may pass in 0 if you wish to use the defaults.
objEventHandler
An System.EventHandler function.

Displays a message box with the specified text, caption, buttons, icon, default button, and options.

The Show MessageBox in Visual WebGui works differently than WinForms. Code lines after this call are executed immediately and won’t wait for the dialog to close. If you need to run code only after the dialog is closed or only if a specific result is returned place that code in the EventHandler function that will run once the dialog is closed.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Show( _
   ByVal strText As String, _
   ByVal strCaption As String, _
   ByVal enmButtons As MessageBoxButtons, _
   ByVal enmIcon As MessageBoxIcon, _
   ByVal enmDefaultButton As MessageBoxDefaultButton, _
   ByVal enmOptions As MessageBoxOptions, _
   ByVal objEventHandler As EventHandler _
) As DialogResult
Visual Basic (Usage) Copy Code
Dim strText As String
Dim strCaption As String
Dim enmButtons As MessageBoxButtons
Dim enmIcon As MessageBoxIcon
Dim enmDefaultButton As MessageBoxDefaultButton
Dim enmOptions As MessageBoxOptions
Dim objEventHandler As EventHandler
Dim value As DialogResult

value = MessageBox.Show(strText, strCaption, enmButtons, enmIcon, enmDefaultButton, enmOptions, objEventHandler)
C#
public static DialogResult Show(
   string strText,
   string strCaption,
   MessageBoxButtons enmButtons,
   MessageBoxIcon enmIcon,
   MessageBoxDefaultButton enmDefaultButton,
   MessageBoxOptions enmOptions,
   EventHandler objEventHandler
)
Managed Extensions for C++
public: static DialogResult Show(
   string* strText,
   string* strCaption,
   MessageBoxButtons enmButtons,
   MessageBoxIcon enmIcon,
   MessageBoxDefaultButton enmDefaultButton,
   MessageBoxOptions enmOptions,
   EventHandler* objEventHandler
)
C++/CLI
public:
static DialogResult Show(
   String^ strText,
   String^ strCaption,
   MessageBoxButtons enmButtons,
   MessageBoxIcon enmIcon,
   MessageBoxDefaultButton enmDefaultButton,
   MessageBoxOptions enmOptions,
   EventHandler^ objEventHandler
)

Parameters

strText
The text to display in the message box.
strCaption
The text to display in the title bar of the message box.
enmButtons
One of the MessageBoxButtons values that specifies which buttons to display in the message box.
enmIcon
One of the MessageBoxIcon values that specifies which icon to display in the message box.
enmDefaultButton
One of the MessageBoxDefaultButton values that specifies the default button for the message box.
enmOptions
One of the MessageBoxOptions values that specifies which display and association options will be used for the message box. You may pass in 0 if you wish to use the defaults.
objEventHandler
An System.EventHandler function.

Return Value

One of the DialogResult values.

Exceptions

Exception | Description
InvalidEnumArgumentException | buttons is not a member of MessageBoxButtons.-or- icon is not a member of MessageBoxIcon.-or- The defaultButton specified is not a member of MessageBoxDefaultButton.
ArgumentException | options specified both MessageBoxOptions.DefaultDesktopOnly and MessageBoxOptions.ServiceNotification.-or- buttons specified an invalid combination of MessageBoxButtons.
InvalidOperationException | An attempt was made to display the MessageBox in a process that is not running in User Interactive mode. This is specified by the UserInteractive property.

Example

C# Copy Code
private void button1_Click(object sender, EventArgs e)
{
   MessageBox.Show("My message", "My message caption",MessageBoxButtons.OK,MessageBoxIcon.Information,MessageBoxDefaultButton.Button1,MessageBoxOptions.RightAlign, objMessageBox_Closed);
}

 private void objMessageBox_Closed(object sender, EventArgs e)
{

   if (((MessageBoxWindow)sender).DialogResult == DialogResult.OK) {
       MessageBox.Show("Message Box OK");
   }
}
Visual Basic Copy Code
Private Sub button1_Click(ByVal sender As Object, ByVal e As EventArgs)
    MessageBox.Show("My message", "My message caption", MessageBoxButtons.OK, MessageBoxIcon.Information, MessageBoxDefaultButton.Button1, MessageBoxOptions.RightAlign, AddressOf objMessageBox_Closed)
    End Sub

    Private Sub objMessageBox_Closed(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Closed
        If DirectCast(sender, MessageBoxWindow).DialogResult = DialogResult.OK Then
            MessageBox.Show("Message Box OK")
        End If

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageBox Class
MessageBox Members
Overload List


Show(Form,String,String,MessageBoxButtons,MessageBoxIcon,MessageBoxDefaultButton) Method

[image]
Gizmox.WebGUI.Forms
Show(Form,String,String,MessageBoxButtons,MessageBoxIcon,MessageBoxDefaultButton) Method
See Also Example Send Feedback
Gizmox.WebGUI.Forms Namespace > MessageBox Class > Show Method : Show(Form,String,String,MessageBoxButtons,MessageBoxIcon,MessageBoxDefaultButton) Method

objOwner
An implementation of Form that will own the modal dialog box.
strText
The text to display in the message box.
strCaption
The text to display in the title bar of the message box.
enmButtons
One of the MessageBoxButtons values that specifies which buttons to display in the message box.
enmIcon
One of the MessageBoxIcon values that specifies which icon to display in the message box.
enmDefaultButton
One of the MessageBoxDefaultButton values that specifies the default button for the message box.

Displays a message box in front of the specified object and with the specified text, caption, buttons, icon, and default button.

The Show MessageBox in Visual WebGui works differently than WinForms. Code lines after this call are executed immediately and won’t wait for the dialog to close. If you need to run code only after the dialog is closed or only if a specific result is returned use Show(Form objOwner, string strText, string strCaption,
MessageBoxButtons enmButtons, MessageBoxIcon enmIcon, MessageBoxDefaultButton enmDefaultButton, EventHandler objEventHandler)

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Show( _
   ByVal objOwner As Form, _
   ByVal strText As String, _
   ByVal strCaption As String, _
   ByVal enmButtons As MessageBoxButtons, _
   ByVal enmIcon As MessageBoxIcon, _
   ByVal enmDefaultButton As MessageBoxDefaultButton _
) As DialogResult
Visual Basic (Usage) Copy Code
Dim objOwner As Form
Dim strText As String
Dim strCaption As String
Dim enmButtons As MessageBoxButtons
Dim enmIcon As MessageBoxIcon
Dim enmDefaultButton As MessageBoxDefaultButton
Dim value As DialogResult

value = MessageBox.Show(objOwner, strText, strCaption, enmButtons, enmIcon, enmDefaultButton)
C#
public static DialogResult Show(
   Form objOwner,
   string strText,
   string strCaption,
   MessageBoxButtons enmButtons,
   MessageBoxIcon enmIcon,
   MessageBoxDefaultButton enmDefaultButton
)
Managed Extensions for C++
public: static DialogResult Show(
   Form* objOwner,
   string* strText,
   string* strCaption,
   MessageBoxButtons enmButtons,
   MessageBoxIcon enmIcon,
   MessageBoxDefaultButton enmDefaultButton
)
C++/CLI
public:
static DialogResult Show(
   Form^ objOwner,
   String^ strText,
   String^ strCaption,
   MessageBoxButtons enmButtons,
   MessageBoxIcon enmIcon,
   MessageBoxDefaultButton enmDefaultButton
)

Parameters

objOwner
An implementation of Form that will own the modal dialog box.
strText
The text to display in the message box.
strCaption
The text to display in the title bar of the message box.
enmButtons
One of the MessageBoxButtons values that specifies which buttons to display in the message box.
enmIcon
One of the MessageBoxIcon values that specifies which icon to display in the message box.
enmDefaultButton
One of the MessageBoxDefaultButton values that specifies the default button for the message box.

Return Value

One of the DialogResult values.

Exceptions

Exception | Description
InvalidEnumArgumentException | buttons is not a member of MessageBoxButtons.-or- icon is not a member of MessageBoxIcon.-or- defaultButton is not a member of MessageBoxDefaultButton.
InvalidOperationException | An attempt was made to display the MessageBox in a process that is not running in User Interactive mode. This is specified by the UserInteractive property.

Example

C# Copy Code
private void button1_Click(object sender, EventArgs e)
{
   MessageBox.Show(objForm2,"My message", "My message caption",MessageBoxButtons.OK,MessageBoxIcon.Information,MessageBoxDefaultButton.Button1);
}
Visual Basic Copy Code
Private Sub button1_Click(ByVal sender As Object, ByVal e As EventArgs)
    MessageBox.Show(objForm2, "My message", "My message caption", MessageBoxButtons.OK, MessageBoxIcon.Information, MessageBoxDefaultButton.Button1)
End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageBox Class
MessageBox Members
Overload List


Show(Form,String,String,MessageBoxButtons,MessageBoxIcon,MessageBoxDefaultButton,EventHandler) Method

[image]
Gizmox.WebGUI.Forms
Show(Form,String,String,MessageBoxButtons,MessageBoxIcon,MessageBoxDefaultButton,EventHandler) Method
See Also Example Send Feedback
Gizmox.WebGUI.Forms Namespace > MessageBox Class > Show Method : Show(Form,String,String,MessageBoxButtons,MessageBoxIcon,MessageBoxDefaultButton,EventHandler) Method

objOwner
An implementation of Form that will own the modal dialog box.
strText
The text to display in the message box.
strCaption
The text to display in the title bar of the message box.
enmButtons
One of the MessageBoxButtons values that specifies which buttons to display in the message box.
enmIcon
One of the MessageBoxIcon values that specifies which icon to display in the message box.
enmDefaultButton
One of the MessageBoxDefaultButton values that specifies the default button for the message box.
objEventHandler
An System.EventHandler function.

Displays a message box in front of the specified object and with the specified text, caption, buttons, icon, and default button.

The Show MessageBox in Visual WebGui works differently than WinForms. Code lines after this call are executed immediately and won’t wait for the dialog to close. If you need to run code only after the dialog is closed or only if a specific result is returned place that code in the EventHandler function that will run once the dialog is closed.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Show( _
   ByVal objOwner As Form, _
   ByVal strText As String, _
   ByVal strCaption As String, _
   ByVal enmButtons As MessageBoxButtons, _
   ByVal enmIcon As MessageBoxIcon, _
   ByVal enmDefaultButton As MessageBoxDefaultButton, _
   ByVal objEventHandler As EventHandler _
) As DialogResult
Visual Basic (Usage) Copy Code
Dim objOwner As Form
Dim strText As String
Dim strCaption As String
Dim enmButtons As MessageBoxButtons
Dim enmIcon As MessageBoxIcon
Dim enmDefaultButton As MessageBoxDefaultButton
Dim objEventHandler As EventHandler
Dim value As DialogResult

value = MessageBox.Show(objOwner, strText, strCaption, enmButtons, enmIcon, enmDefaultButton, objEventHandler)
C#
public static DialogResult Show(
   Form objOwner,
   string strText,
   string strCaption,
   MessageBoxButtons enmButtons,
   MessageBoxIcon enmIcon,
   MessageBoxDefaultButton enmDefaultButton,
   EventHandler objEventHandler
)
Managed Extensions for C++
public: static DialogResult Show(
   Form* objOwner,
   string* strText,
   string* strCaption,
   MessageBoxButtons enmButtons,
   MessageBoxIcon enmIcon,
   MessageBoxDefaultButton enmDefaultButton,
   EventHandler* objEventHandler
)
C++/CLI
public:
static DialogResult Show(
   Form^ objOwner,
   String^ strText,
   String^ strCaption,
   MessageBoxButtons enmButtons,
   MessageBoxIcon enmIcon,
   MessageBoxDefaultButton enmDefaultButton,
   EventHandler^ objEventHandler
)

Parameters

objOwner
An implementation of Form that will own the modal dialog box.
strText
The text to display in the message box.
strCaption
The text to display in the title bar of the message box.
enmButtons
One of the MessageBoxButtons values that specifies which buttons to display in the message box.
enmIcon
One of the MessageBoxIcon values that specifies which icon to display in the message box.
enmDefaultButton
One of the MessageBoxDefaultButton values that specifies the default button for the message box.
objEventHandler
An System.EventHandler function.

Return Value

One of the DialogResult values.

Exceptions

Exception | Description
InvalidEnumArgumentException | buttons is not a member of MessageBoxButtons.-or- icon is not a member of MessageBoxIcon.-or- defaultButton is not a member of MessageBoxDefaultButton.
InvalidOperationException | An attempt was made to display the MessageBox in a process that is not running in User Interactive mode. This is specified by the UserInteractive property.

Example

C# Copy Code
private void button1_Click(object sender, EventArgs e)
{
   MessageBox.Show(objForm2,"My message", "My message caption",MessageBoxButtons.OK,MessageBoxIcon.Information,MessageBoxDefaultButton.Button1, objMessageBox_Closed);
}

 private void objMessageBox_Closed(object sender, EventArgs e)
{

   if (((MessageBoxWindow)sender).DialogResult == DialogResult.OK) {
       MessageBox.Show("Message Box OK");
   }
}
Visual Basic Copy Code
Private Sub button1_Click(ByVal sender As Object, ByVal e As EventArgs)
    MessageBox.Show(objForm2, "My message", "My message caption", MessageBoxButtons.OK, MessageBoxIcon.Information, MessageBoxDefaultButton.Button1, AddressOf objMessageBox_Closed)
    End Sub

    Private Sub objMessageBox_Closed(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Closed
        If DirectCast(sender, MessageBoxWindow).DialogResult = DialogResult.OK Then
            MessageBox.Show("Message Box OK")
        End If

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageBox Class
MessageBox Members
Overload List


Show(Form,String,String,MessageBoxButtons,MessageBoxIcon,MessageBoxDefaultButton,MessageBoxOptions) Method

[image]
Gizmox.WebGUI.Forms
Show(Form,String,String,MessageBoxButtons,MessageBoxIcon,MessageBoxDefaultButton,MessageBoxOptions) Method
See Also Example Send Feedback
Gizmox.WebGUI.Forms Namespace > MessageBox Class > Show Method : Show(Form,String,String,MessageBoxButtons,MessageBoxIcon,MessageBoxDefaultButton,MessageBoxOptions) Method

objOwner
An implementation of Form that will own the modal dialog box.
strText
The text to display in the message box.
strCaption
The text to display in the title bar of the message box.
enmButtons
One of the MessageBoxButtons values that specifies which buttons to display in the message box.
enmIcon
One of the MessageBoxIcon values that specifies which icon to display in the message box.
enmDefaultButton
One of the MessageBoxDefaultButton values the specifies the default button for the message box.
enmOptions
One of the MessageBoxOptions values that specifies which display and association options will be used for the message box. You may pass in 0 if you wish to use the defaults.

Displays a message box in front of the specified object and with the specified text, caption, buttons, icon, default button, and options.

The Show MessageBox in Visual WebGui works differently than WinForms. Code lines after this call are executed immediately and won’t wait for the dialog to close. If you need to run code only after the dialog is closed or only if a specific result is returned use Show(Form objOwner, string strText, string strCaption,
MessageBoxButtons enmButtons, MessageBoxIcon enmIcon, MessageBoxDefaultButton enmDefaultButton,
MessageBoxOptions enmOptions,EventHandler objEventHandler)

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Show( _
   ByVal objOwner As Form, _
   ByVal strText As String, _
   ByVal strCaption As String, _
   ByVal enmButtons As MessageBoxButtons, _
   ByVal enmIcon As MessageBoxIcon, _
   ByVal enmDefaultButton As MessageBoxDefaultButton, _
   ByVal enmOptions As MessageBoxOptions _
) As DialogResult
Visual Basic (Usage) Copy Code
Dim objOwner As Form
Dim strText As String
Dim strCaption As String
Dim enmButtons As MessageBoxButtons
Dim enmIcon As MessageBoxIcon
Dim enmDefaultButton As MessageBoxDefaultButton
Dim enmOptions As MessageBoxOptions
Dim value As DialogResult

value = MessageBox.Show(objOwner, strText, strCaption, enmButtons, enmIcon, enmDefaultButton, enmOptions)
C#
public static DialogResult Show(
   Form objOwner,
   string strText,
   string strCaption,
   MessageBoxButtons enmButtons,
   MessageBoxIcon enmIcon,
   MessageBoxDefaultButton enmDefaultButton,
   MessageBoxOptions enmOptions
)
Managed Extensions for C++
public: static DialogResult Show(
   Form* objOwner,
   string* strText,
   string* strCaption,
   MessageBoxButtons enmButtons,
   MessageBoxIcon enmIcon,
   MessageBoxDefaultButton enmDefaultButton,
   MessageBoxOptions enmOptions
)
C++/CLI
public:
static DialogResult Show(
   Form^ objOwner,
   String^ strText,
   String^ strCaption,
   MessageBoxButtons enmButtons,
   MessageBoxIcon enmIcon,
   MessageBoxDefaultButton enmDefaultButton,
   MessageBoxOptions enmOptions
)

Parameters

objOwner
An implementation of Form that will own the modal dialog box.
strText
The text to display in the message box.
strCaption
The text to display in the title bar of the message box.
enmButtons
One of the MessageBoxButtons values that specifies which buttons to display in the message box.
enmIcon
One of the MessageBoxIcon values that specifies which icon to display in the message box.
enmDefaultButton
One of the MessageBoxDefaultButton values the specifies the default button for the message box.
enmOptions
One of the MessageBoxOptions values that specifies which display and association options will be used for the message box. You may pass in 0 if you wish to use the defaults.

Return Value

One of the DialogResult values.

Exceptions

Exception | Description
ArgumentException | options specified both MessageBoxOptions.DefaultDesktopOnly and MessageBoxOptions.ServiceNotification.-or- options specified MessageBoxOptions.DefaultDesktopOnly or MessageBoxOptions.ServiceNotification and specified a value in the owner parameter. These two options should be used only if you invoke the version of this method that does not take an owner parameter.-or- buttons specified an invalid combination of MessageBoxButtons.
InvalidEnumArgumentException | buttons is not a member of MessageBoxButtons.-or- icon is not a member of MessageBoxIcon.-or- defaultButton is not a member of MessageBoxDefaultButton.
InvalidOperationException | An attempt was made to display the MessageBox in a process that is not running in User Interactive mode. This is specified by the UserInteractive property.

Example

C# Copy Code
private void button1_Click(object sender, EventArgs e)
{
   MessageBox.Show(objForm2,"My message", "My message caption",MessageBoxButtons.OK,MessageBoxIcon.Information,MessageBoxDefaultButton.Button1,MessageBoxOptions.RtlReading);
}
Visual Basic Copy Code
Private Sub button1_Click(ByVal sender As Object, ByVal e As EventArgs)
    MessageBox.Show(objForm2, "My message", "My message caption", MessageBoxButtons.OK, MessageBoxIcon.Information, MessageBoxDefaultButton.Button1, _
        MessageBoxOptions.RtlReading)
End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageBox Class
MessageBox Members
Overload List


Show(Form,String,String,MessageBoxButtons,MessageBoxIcon,MessageBoxDefaultButton,MessageBoxOptions,EventHandler) Method

[image]
Gizmox.WebGUI.Forms
Show(Form,String,String,MessageBoxButtons,MessageBoxIcon,MessageBoxDefaultButton,MessageBoxOptions,EventHandler) Method
See Also Example Send Feedback
Gizmox.WebGUI.Forms Namespace > MessageBox Class > Show Method : Show(Form,String,String,MessageBoxButtons,MessageBoxIcon,MessageBoxDefaultButton,MessageBoxOptions,EventHandler) Method

objOwner
An implementation of Form that will own the modal dialog box.
strText
The text to display in the message box.
strCaption
The text to display in the title bar of the message box.
enmButtons
One of the MessageBoxButtons values that specifies which buttons to display in the message box.
enmIcon
One of the MessageBoxIcon values that specifies which icon to display in the message box.
enmDefaultButton
One of the MessageBoxDefaultButton values the specifies the default button for the message box.
enmOptions
One of the MessageBoxOptions values that specifies which display and association options will be used for the message box. You may pass in 0 if you wish to use the defaults.
objEventHandler
An System.EventHandler function.

Displays a message box in front of the specified object and with the specified text, caption, buttons, icon, default button, and options.

The Show MessageBox in Visual WebGui works differently than WinForms. Code lines after this call are executed immediately and won’t wait for the dialog to close. If you need to run code only after the dialog is closed or only if a specific result is returned place that code in the EventHandler function that will run once the dialog is closed.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Show( _
   ByVal objOwner As Form, _
   ByVal strText As String, _
   ByVal strCaption As String, _
   ByVal enmButtons As MessageBoxButtons, _
   ByVal enmIcon As MessageBoxIcon, _
   ByVal enmDefaultButton As MessageBoxDefaultButton, _
   ByVal enmOptions As MessageBoxOptions, _
   ByVal objEventHandler As EventHandler _
) As DialogResult
Visual Basic (Usage) Copy Code
Dim objOwner As Form
Dim strText As String
Dim strCaption As String
Dim enmButtons As MessageBoxButtons
Dim enmIcon As MessageBoxIcon
Dim enmDefaultButton As MessageBoxDefaultButton
Dim enmOptions As MessageBoxOptions
Dim objEventHandler As EventHandler
Dim value As DialogResult

value = MessageBox.Show(objOwner, strText, strCaption, enmButtons, enmIcon, enmDefaultButton, enmOptions, objEventHandler)
C#
public static DialogResult Show(
   Form objOwner,
   string strText,
   string strCaption,
   MessageBoxButtons enmButtons,
   MessageBoxIcon enmIcon,
   MessageBoxDefaultButton enmDefaultButton,
   MessageBoxOptions enmOptions,
   EventHandler objEventHandler
)
Managed Extensions for C++
public: static DialogResult Show(
   Form* objOwner,
   string* strText,
   string* strCaption,
   MessageBoxButtons enmButtons,
   MessageBoxIcon enmIcon,
   MessageBoxDefaultButton enmDefaultButton,
   MessageBoxOptions enmOptions,
   EventHandler* objEventHandler
)
C++/CLI
public:
static DialogResult Show(
   Form^ objOwner,
   String^ strText,
   String^ strCaption,
   MessageBoxButtons enmButtons,
   MessageBoxIcon enmIcon,
   MessageBoxDefaultButton enmDefaultButton,
   MessageBoxOptions enmOptions,
   EventHandler^ objEventHandler
)

Parameters

objOwner
An implementation of Form that will own the modal dialog box.
strText
The text to display in the message box.
strCaption
The text to display in the title bar of the message box.
enmButtons
One of the MessageBoxButtons values that specifies which buttons to display in the message box.
enmIcon
One of the MessageBoxIcon values that specifies which icon to display in the message box.
enmDefaultButton
One of the MessageBoxDefaultButton values the specifies the default button for the message box.
enmOptions
One of the MessageBoxOptions values that specifies which display and association options will be used for the message box. You may pass in 0 if you wish to use the defaults.
objEventHandler
An System.EventHandler function.

Return Value

One of the DialogResult values.

Exceptions

Exception | Description
ArgumentException | options specified both MessageBoxOptions.DefaultDesktopOnly and MessageBoxOptions.ServiceNotification.-or- options specified MessageBoxOptions.DefaultDesktopOnly or MessageBoxOptions.ServiceNotification and specified a value in the owner parameter. These two options should be used only if you invoke the version of this method that does not take an owner parameter.-or- buttons specified an invalid combination of MessageBoxButtons.
InvalidEnumArgumentException | buttons is not a member of MessageBoxButtons.-or- icon is not a member of MessageBoxIcon.-or- defaultButton is not a member of MessageBoxDefaultButton.
InvalidOperationException | An attempt was made to display the MessageBox in a process that is not running in User Interactive mode. This is specified by the UserInteractive property.

Example

C# Copy Code
private void button1_Click(object sender, EventArgs e)
{
   MessageBox.Show(objForm2,"My message", "My message caption",MessageBoxButtons.OK,MessageBoxIcon.Information,MessageBoxDefaultButton.Button1,MessageBoxOptions.RtlReading, objMessageBox_Closed);
}

 private void objMessageBox_Closed(object sender, EventArgs e)
{

   if (((MessageBoxWindow)sender).DialogResult == DialogResult.OK) {
       MessageBox.Show("Message Box OK");
   }
}
Visual Basic Copy Code
Private Sub button1_Click(ByVal sender As Object, ByVal e As EventArgs)
    MessageBox.Show(objForm2, "My message", "My message caption", MessageBoxButtons.OK, MessageBoxIcon.Information, MessageBoxDefaultButton.Button1, _
        MessageBoxOptions.RtlReading, AddressOf objMessageBox_Closed)
    End Sub

    Private Sub objMessageBox_Closed(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Closed
        If DirectCast(sender, MessageBoxWindow).DialogResult = DialogResult.OK Then
            MessageBox.Show("Message Box OK")
        End If

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MessageBox Class
MessageBox Members
Overload List


MessageBoxWindow Class

[image]
Gizmox.WebGUI.Forms
MessageBoxWindow Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : MessageBoxWindow Class

Implementation of MessageBoxWindow class.

Object Model

Syntax

Visual Basic (Declaration)
Public Class MessageBoxWindow
   Inherits Form
   Implements IAttributeExtender, IControl, IEventHandler, IForm, IGatewayComponent, IObservableItem, IObservableLayoutItem, IObservableList, IRegisteredComponent, IRenderableComponent, IBindableComponent, IContainerControl, IArrangedElement
Visual Basic (Usage) Copy Code
Dim instance As MessageBoxWindow
C#
public class MessageBoxWindow : Form, IAttributeExtender, IControl, IEventHandler, IForm, IGatewayComponent, IObservableItem, IObservableLayoutItem, IObservableList, IRegisteredComponent, IRenderableComponent, IBindableComponent, IContainerControl, IArrangedElement
Managed Extensions for C++
public __gc class MessageBoxWindow : public Form, IAttributeExtender, IControl, IEventHandler, IForm, IGatewayComponent, IObservableItem, IObservableLayoutItem, IObservableList, IRegisteredComponent, IRenderableComponent, IBindableComponent, IContainerControl, IArrangedElement
C++/CLI
public ref class MessageBoxWindow : public Form, IAttributeExtender, IControl, IEventHandler, IForm, IGatewayComponent, IObservableItem, IObservableLayoutItem, IObservableList, IRegisteredComponent, IRenderableComponent, IBindableComponent, IContainerControl, IArrangedElement

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.ScrollableControl
Gizmox.WebGUI.Forms.ContainerControl
Gizmox.WebGUI.Forms.Form
Gizmox.WebGUI.Forms.MessageBoxWindow

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

MessageBoxWindow Members
Gizmox.WebGUI.Forms Namespace


MessageBoxWindow Class Members

[image]
Gizmox.WebGUI.Forms
MessageBoxWindow Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : MessageBoxWindow Class

The following tables list the members exposed by MessageBoxWindow.

Public Properties

 | Name | Description
Public Property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form)
Public Property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl)
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | AutoScaleBaseSize | Gets or sets the size of the auto scale base. Not implemented. (Inherited from Form)
Public Property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BeforeUnloadMessage | Gets or sets the before unload message. (Inherited from Form)
Public Property | BindingContext | (Inherited from ContainerControl)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CancelButton | Gets or sets the button on the form that is clicked when the user presses the ESC key. (Inherited from Form)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Form)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Components | (Inherited from ContainerControl)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Form)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | DialogResult | Gets or sets the dialog result. (Inherited from Form)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl)
Public Property | DragMappings | Gets the form drag mappings. (Inherited from Form)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | FormBorderStyle | Gets or sets the form border style. (Inherited from Form)
Public Property | FormStyle | Gets or sets the form style. (Inherited from Form)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this control has controls. (Inherited from Form)
Public Property | Header | Gets or sets the form header control. (Inherited from Form)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | Icon | Gets or sets the form icon (Inherited from Form)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (Inherited from Form)
Public Property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (Inherited from Form)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximizeBox | Gets or sets a value indicating whether [maximize box]. (Inherited from Form)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (Inherited from Form)
Public Property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form)
Public Property | MinimizeBox | Gets or sets a value indicating whether [minimize box]. (Inherited from Form)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Modal | Gets or sets a value indicating whether this window is modal. (Inherited from Form)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | OwnedForms | Gets the child forms. (Inherited from Form)
Public Property | Owner | Gets the parent window. (Inherited from Form)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | ShowInTaskbar | Gets or sets a value indicating whether [show in taskbar]. Not implemented by design (Inherited from Form)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | StartPosition | Gets or sets the form start position. (Inherited from Form)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Control)
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form)
Public Property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. Not implemented by design. (Inherited from Form)
Public Property | Visible | Get/Sets the form visibility (Inherited from Form)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Public Property | WindowState | Gets or sets the state of the window. (Inherited from Form)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | IsWindowSized | Calculate size invluding borders (Inherited from Form)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets or sets the main form. (Inherited from Form)
Protected Property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl)
Top

Public Methods

 | Name | Description
Public Method | Add | (Inherited from ContainerControl)
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Close | Closes this window. (Inherited from Form)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from ContainerControl)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | Remove | (Inherited from ContainerControl)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | (Inherited from Form)
Public Method | ShowDialog | Overloaded. Shows a the form as a dialog. The ShowDialog in Visual WebGui works differently than WinForms. Code lines after this call is executed immediately and won’t wait for the dialog to close. If you need to run code only after the dialog is closed or only if a specific result is returned register to the close event of the dialog. See documentation for code example. (Inherited from Form)
Public Method | ShowPopup | Overloaded. Displays the form as a popup window. (Inherited from Form)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Form)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from ScrollableControl)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnActivated | Raises the Activated event. (Inherited from Form)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnClosed | (Inherited from Form)
Protected Method | OnClosing | (Inherited from Form)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Occurs when control is created (Inherited from Form)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLoad | Raises the Load event. (Inherited from Form)
Protected Method | OnLocationChanged | (Inherited from Form)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Form)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | Render the form content (Inherited from Form)
Protected Method | RenderAttributes | Renders the forms attribute (Inherited from Form)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Form)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Form)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | (Inherited from Form)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

Public Events

 | Name | Description
Public Event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form)
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | Closed | (Inherited from Form)
Public Event | Closing | The form closing event. This event is not raised on the main form. (Inherited from Form)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | Load | The form load event (Inherited from Form)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

MessageBoxWindow Class
Gizmox.WebGUI.Forms Namespace


MonthCalendar Class

[image]
Gizmox.WebGUI.Forms
MonthCalendar Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : MonthCalendar Class

A calendar control.

Object Model

Syntax

Visual Basic (Declaration)
<MetadataTagAttribute("MC")>
<ToolboxBitmapAttribute()>
<ToolboxItemCategoryAttribute("Common Controls")>
<SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableCalendar, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")>
<ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<DefaultEventAttribute("DateChanged")>
<DesignTimeControllerAttribute()>
<ClientControllerAttribute()>
Public Class MonthCalendar
   Inherits Control
   Implements IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Visual Basic (Usage) Copy Code
Dim instance As MonthCalendar
C#
[MetadataTagAttribute("MC")]
[ToolboxBitmapAttribute()]
[ToolboxItemCategoryAttribute("Common Controls")]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableCalendar, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[DefaultEventAttribute("DateChanged")]
[DesignTimeControllerAttribute()]
[ClientControllerAttribute()]
public class MonthCalendar : Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Managed Extensions for C++
[MetadataTagAttribute("MC")]
[ToolboxBitmapAttribute()]
[ToolboxItemCategoryAttribute("Common Controls")]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableCalendar, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[DefaultEventAttribute("DateChanged")]
[DesignTimeControllerAttribute()]
[ClientControllerAttribute()]
public __gc class MonthCalendar : public Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
C++/CLI
[MetadataTagAttribute("MC")]
[ToolboxBitmapAttribute()]
[ToolboxItemCategoryAttribute("Common Controls")]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableCalendar, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[DefaultEventAttribute("DateChanged")]
[DesignTimeControllerAttribute()]
[ClientControllerAttribute()]
public ref class MonthCalendar : public Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.MonthCalendar

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

MonthCalendar Members
Gizmox.WebGUI.Forms Namespace


MonthCalendar Class Members

[image]
Gizmox.WebGUI.Forms
MonthCalendar Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : MonthCalendar Class

The following tables list the members exposed by MonthCalendar.

Public Constructors

 | Name | Description
Public Constructor | MonthCalendar Constructor | Creates a new MonthCalendar instance.
Top

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | FirstDayOfWeek | Gets or sets the first day of the week as displayed in the month calendar.
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Control)
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | Value | Gets or sets the current date.
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | Overridden.
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | Overridden.
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Overridden. Fires an event.
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Overridden. Gets the critical events.
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from Control)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | Overridden. Renders the current control.
Protected Method | RenderAttributes | Renders the controls meta attributes (Inherited from Control)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | DateChanged | Occurs when the date is changed
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

MonthCalendar Class
Gizmox.WebGUI.Forms Namespace


MonthCalendar Constructor

[image]
Gizmox.WebGUI.Forms
MonthCalendar Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > MonthCalendar Class : MonthCalendar Constructor

Creates a new MonthCalendar instance.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As MonthCalendar()
C#
public MonthCalendar()
Managed Extensions for C++
public: MonthCalendar();
C++/CLI
public:
MonthCalendar();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MonthCalendar Class
MonthCalendar Members


MonthCalendar Class Methods

[image]
Gizmox.WebGUI.Forms
MonthCalendar Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : MonthCalendar Class

For a list of all members of this type, see MonthCalendar members.

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Overridden. Fires an event.
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Overridden. Gets the critical events.
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from Control)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | Overridden. Renders the current control.
Protected Method | RenderAttributes | Renders the controls meta attributes (Inherited from Control)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

See Also

Reference

MonthCalendar Class
Gizmox.WebGUI.Forms Namespace


FireEvent Method

[image]
Gizmox.WebGUI.Forms
FireEvent Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > MonthCalendar Class : FireEvent Method

objEvent
event.
Fires an event.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub FireEvent( _
   ByVal objEvent As IEvent _
)
Visual Basic (Usage) Copy Code
Dim instance As MonthCalendar
Dim objEvent As IEvent

instance.FireEvent(objEvent)
C#
protected override void FireEvent(
   IEvent objEvent
)
Managed Extensions for C++
protected: void FireEvent(
   IEvent* objEvent
) override
C++/CLI
protected:
void FireEvent(
   IEvent^ objEvent
) override

Parameters

objEvent
event.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MonthCalendar Class
MonthCalendar Members


GetCriticalEvents Method

[image]
Gizmox.WebGUI.Forms
GetCriticalEvents Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > MonthCalendar Class : GetCriticalEvents Method

Gets the critical events.

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetCriticalEvents() As EventTypes
Visual Basic (Usage) Copy Code
Dim instance As MonthCalendar
Dim value As EventTypes

value = instance.GetCriticalEvents()
C#
protected override EventTypes GetCriticalEvents()
Managed Extensions for C++
protected: EventTypes GetCriticalEvents(); override
C++/CLI
protected:
EventTypes GetCriticalEvents(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MonthCalendar Class
MonthCalendar Members


Render Method

[image]
Gizmox.WebGUI.Forms
Render Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > MonthCalendar Class : Render Method

objContext
Request context.
objWriter
lngRequestID
Renders the current control.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub Render( _
   ByVal objContext As IContext, _
   ByVal objWriter As IResponseWriter, _
   ByVal lngRequestID As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As MonthCalendar
Dim objContext As IContext
Dim objWriter As IResponseWriter
Dim lngRequestID As Long

instance.Render(objContext, objWriter, lngRequestID)
C#
protected override void Render(
   IContext objContext,
   IResponseWriter objWriter,
   long lngRequestID
)
Managed Extensions for C++
protected: void Render(
   IContext* objContext,
   IResponseWriter* objWriter,
   long lngRequestID
) override
C++/CLI
protected:
void Render(
   IContext^ objContext,
   IResponseWriter^ objWriter,
   long long lngRequestID
) override

Parameters

objContext
Request context.
objWriter
lngRequestID

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MonthCalendar Class
MonthCalendar Members


MonthCalendar Class Properties

[image]
Gizmox.WebGUI.Forms
MonthCalendar Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : MonthCalendar Class

For a list of all members of this type, see MonthCalendar members.

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | FirstDayOfWeek | Gets or sets the first day of the week as displayed in the month calendar.
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Control)
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | Value | Gets or sets the current date.
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | Overridden.
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | Overridden.
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

See Also

Reference

MonthCalendar Class
Gizmox.WebGUI.Forms Namespace


DefaultBackColor Property

[image]
Gizmox.WebGUI.Forms
DefaultBackColor Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > MonthCalendar Class : DefaultBackColor Property

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property DefaultBackColor As Color
Visual Basic (Usage) Copy Code
Dim instance As MonthCalendar
Dim value As Color

value = instance.DefaultBackColor
C#
protected override Color DefaultBackColor {get;}
Managed Extensions for C++
protected: __property Color get_DefaultBackColor() override;
C++/CLI
protected:
property Color DefaultBackColor {
   Color get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MonthCalendar Class
MonthCalendar Members


DefaultBorderStyle Property

[image]
Gizmox.WebGUI.Forms
DefaultBorderStyle Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > MonthCalendar Class : DefaultBorderStyle Property

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property DefaultBorderStyle As BorderStyle
Visual Basic (Usage) Copy Code
Dim instance As MonthCalendar
Dim value As BorderStyle

value = instance.DefaultBorderStyle
C#
protected override BorderStyle DefaultBorderStyle {get;}
Managed Extensions for C++
protected: __property BorderStyle get_DefaultBorderStyle() override;
C++/CLI
protected:
property BorderStyle DefaultBorderStyle {
   BorderStyle get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MonthCalendar Class
MonthCalendar Members


FirstDayOfWeek Property

[image]
Gizmox.WebGUI.Forms
FirstDayOfWeek Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > MonthCalendar Class : FirstDayOfWeek Property

Gets or sets the first day of the week as displayed in the month calendar.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Behavior")>
<SRDescriptionAttribute("The first day of the week.")>
<LocalizableAttribute(True)>
<DefaultValueAttribute()>
Public Property FirstDayOfWeek As Day
Visual Basic (Usage) Copy Code
Dim instance As MonthCalendar
Dim value As Day

instance.FirstDayOfWeek = value

value = instance.FirstDayOfWeek
C#
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("The first day of the week.")]
[LocalizableAttribute(true)]
[DefaultValueAttribute()]
public Day FirstDayOfWeek {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("The first day of the week.")]
[LocalizableAttribute(true)]
[DefaultValueAttribute()]
public: __property Day get_FirstDayOfWeek();
public: __property void set_FirstDayOfWeek(
   Day value
);
C++/CLI
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("The first day of the week.")]
[LocalizableAttribute(true)]
[DefaultValueAttribute()]
public:
property Day FirstDayOfWeek {
   Day get();
   void set (Dayvalue);
}

Exceptions

Exception | Description
InvalidEnumArgumentException | The assigned value is not one of the Day enumeration members.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MonthCalendar Class
MonthCalendar Members


Value Property

[image]
Gizmox.WebGUI.Forms
Value Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > MonthCalendar Class : Value Property

Gets or sets the current date.

Syntax

Visual Basic (Declaration)
Public Property Value As Date
Visual Basic (Usage) Copy Code
Dim instance As MonthCalendar
Dim value As Date

instance.Value = value

value = instance.Value
C#
public DateTime Value {get; set;}
Managed Extensions for C++
public: __property DateTime get_Value();
public: __property void set_Value(
   DateTime value
);
C++/CLI
public:
property DateTime Value {
   DateTime get();
   void set (DateTimevalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MonthCalendar Class
MonthCalendar Members


MonthCalendar Class Events

[image]
Gizmox.WebGUI.Forms
MonthCalendar Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : MonthCalendar Class

For a list of all members of this type, see MonthCalendar members.

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | DateChanged | Occurs when the date is changed
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

MonthCalendar Class
Gizmox.WebGUI.Forms Namespace


DateChanged Event

[image]
Gizmox.WebGUI.Forms
DateChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > MonthCalendar Class : DateChanged Event

Occurs when the date is changed

Syntax

Visual Basic (Declaration)
Public Event DateChanged() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As MonthCalendar
Dim handler As EventHandler

AddHandler instance.DateChanged, handler
C#
public event EventHandler DateChanged()
Managed Extensions for C++
public: __event EventHandler* DateChanged
C++/CLI
public:
event EventHandler^ DateChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MonthCalendar Class
MonthCalendar Members


MonthCalendarEventArgs Class

[image]
Gizmox.WebGUI.Forms
MonthCalendarEventArgs Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : MonthCalendarEventArgs Class

A calendar event arguments class

Object Model

Syntax

Visual Basic (Declaration)
Public Class MonthCalendarEventArgs
   Inherits EventArgs
Visual Basic (Usage) Copy Code
Dim instance As MonthCalendarEventArgs
C#
public class MonthCalendarEventArgs : EventArgs
Managed Extensions for C++
public __gc class MonthCalendarEventArgs : public EventArgs
C++/CLI
public ref class MonthCalendarEventArgs : public EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gizmox.WebGUI.Forms.MonthCalendarEventArgs

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

MonthCalendarEventArgs Members
Gizmox.WebGUI.Forms Namespace


MonthCalendarEventArgs Class Members

[image]
Gizmox.WebGUI.Forms
MonthCalendarEventArgs Class Members
See Also Fields Send Feedback
Gizmox.WebGUI.Forms Namespace : MonthCalendarEventArgs Class

The following tables list the members exposed by MonthCalendarEventArgs.

Public Constructors

 | Name | Description
Public Constructor | MonthCalendarEventArgs Constructor | Creates a new MonthCalendarEventArgs instance.
Top

Public Fields

 | Name | Description
Public Field | MonthCalendar | The calendar object
Top

See Also

Reference

MonthCalendarEventArgs Class
Gizmox.WebGUI.Forms Namespace


MonthCalendarEventArgs Constructor

[image]
Gizmox.WebGUI.Forms
MonthCalendarEventArgs Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > MonthCalendarEventArgs Class : MonthCalendarEventArgs Constructor

objMonthCalendar
MonthCalendar object.
Creates a new MonthCalendarEventArgs instance.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal objMonthCalendar As MonthCalendar _
)
Visual Basic (Usage) Copy Code
Dim objMonthCalendar As MonthCalendar

Dim instance As MonthCalendarEventArgs(objMonthCalendar)
C#
public MonthCalendarEventArgs(
   MonthCalendar objMonthCalendar
)
Managed Extensions for C++
public: MonthCalendarEventArgs(
   MonthCalendar* objMonthCalendar
)
C++/CLI
public:
MonthCalendarEventArgs(
   MonthCalendar^ objMonthCalendar
)

Parameters

objMonthCalendar
MonthCalendar object.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MonthCalendarEventArgs Class
MonthCalendarEventArgs Members


MonthCalendarEventArgs Class Fields

[image]
Gizmox.WebGUI.Forms
MonthCalendarEventArgs Class Fields
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : MonthCalendarEventArgs Class

For a list of all members of this type, see MonthCalendarEventArgs members.

Public Fields

 | Name | Description
Public Field | MonthCalendar | The calendar object
Top

See Also

Reference

MonthCalendarEventArgs Class
Gizmox.WebGUI.Forms Namespace


MonthCalendar Field

[image]
Gizmox.WebGUI.Forms
MonthCalendar Field
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > MonthCalendarEventArgs Class : MonthCalendar Field

The calendar object

Syntax

Visual Basic (Declaration)
Public ReadOnly MonthCalendar As MonthCalendar
Visual Basic (Usage) Copy Code
Dim instance As MonthCalendarEventArgs
Dim value As MonthCalendar

value = instance.MonthCalendar
C#
public readonly MonthCalendar MonthCalendar
Managed Extensions for C++
public: readonly MonthCalendar* MonthCalendar
C++/CLI
public:
readonly MonthCalendar^ MonthCalendar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MonthCalendarEventArgs Class
MonthCalendarEventArgs Members


MouseEventArgs Class

[image]
Gizmox.WebGUI.Forms
MouseEventArgs Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : MouseEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class MouseEventArgs
   Inherits EventArgs
Visual Basic (Usage) Copy Code
Dim instance As MouseEventArgs
C#
public class MouseEventArgs : EventArgs
Managed Extensions for C++
public __gc class MouseEventArgs : public EventArgs
C++/CLI
public ref class MouseEventArgs : public EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gizmox.WebGUI.Forms.MouseEventArgs
Gizmox.WebGUI.Forms.DataGridViewCellMouseEventArgs
Gizmox.WebGUI.Forms.HandledMouseEventArgs
Gizmox.WebGUI.Forms.TreeNodeMouseClickEventArgs

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

MouseEventArgs Members
Gizmox.WebGUI.Forms Namespace


MouseEventArgs Class Members

[image]
Gizmox.WebGUI.Forms
MouseEventArgs Class Members
See Also Properties Send Feedback
Gizmox.WebGUI.Forms Namespace : MouseEventArgs Class

The following tables list the members exposed by MouseEventArgs.

Public Constructors

 | Name | Description
Public Constructor | MouseEventArgs Constructor |
Top

Public Properties

 | Name | Description
Public Property | Button |
Public Property | Clicks |
Public Property | Delta |
Public Property | X |
Public Property | Y |
Top

See Also

Reference

MouseEventArgs Class
Gizmox.WebGUI.Forms Namespace


MouseEventArgs Constructor

[image]
Gizmox.WebGUI.Forms
MouseEventArgs Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > MouseEventArgs Class : MouseEventArgs Constructor

button
clicks
x
y
delta

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal button As MouseButtons, _
   ByVal clicks As Integer, _
   ByVal x As Integer, _
   ByVal y As Integer, _
   ByVal delta As Integer _
)
Visual Basic (Usage) Copy Code
Dim button As MouseButtons
Dim clicks As Integer
Dim x As Integer
Dim y As Integer
Dim delta As Integer

Dim instance As MouseEventArgs(button, clicks, x, y, delta)
C#
public MouseEventArgs(
   MouseButtons button,
   int clicks,
   int x,
   int y,
   int delta
)
Managed Extensions for C++
public: MouseEventArgs(
   MouseButtons button,
   int clicks,
   int x,
   int y,
   int delta
)
C++/CLI
public:
MouseEventArgs(
   MouseButtons button,
   int clicks,
   int x,
   int y,
   int delta
)

Parameters

button
clicks
x
y
delta

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MouseEventArgs Class
MouseEventArgs Members


MouseEventArgs Class Properties

[image]
Gizmox.WebGUI.Forms
MouseEventArgs Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : MouseEventArgs Class

For a list of all members of this type, see MouseEventArgs members.

Public Properties

 | Name | Description
Public Property | Button |
Public Property | Clicks |
Public Property | Delta |
Public Property | X |
Public Property | Y |
Top

See Also

Reference

MouseEventArgs Class
Gizmox.WebGUI.Forms Namespace


Button Property

[image]
Gizmox.WebGUI.Forms
Button Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > MouseEventArgs Class : Button Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Button As MouseButtons
Visual Basic (Usage) Copy Code
Dim instance As MouseEventArgs
Dim value As MouseButtons

value = instance.Button
C#
public MouseButtons Button {get;}
Managed Extensions for C++
public: __property MouseButtons get_Button();
C++/CLI
public:
property MouseButtons Button {
   MouseButtons get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MouseEventArgs Class
MouseEventArgs Members


Clicks Property

[image]
Gizmox.WebGUI.Forms
Clicks Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > MouseEventArgs Class : Clicks Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Clicks As Integer
Visual Basic (Usage) Copy Code
Dim instance As MouseEventArgs
Dim value As Integer

value = instance.Clicks
C#
public int Clicks {get;}
Managed Extensions for C++
public: __property int get_Clicks();
C++/CLI
public:
property int Clicks {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MouseEventArgs Class
MouseEventArgs Members


Delta Property

[image]
Gizmox.WebGUI.Forms
Delta Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > MouseEventArgs Class : Delta Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Delta As Integer
Visual Basic (Usage) Copy Code
Dim instance As MouseEventArgs
Dim value As Integer

value = instance.Delta
C#
public int Delta {get;}
Managed Extensions for C++
public: __property int get_Delta();
C++/CLI
public:
property int Delta {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MouseEventArgs Class
MouseEventArgs Members


X Property

[image]
Gizmox.WebGUI.Forms
X Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > MouseEventArgs Class : X Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property X As Integer
Visual Basic (Usage) Copy Code
Dim instance As MouseEventArgs
Dim value As Integer

value = instance.X
C#
public int X {get;}
Managed Extensions for C++
public: __property int get_X();
C++/CLI
public:
property int X {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MouseEventArgs Class
MouseEventArgs Members


Y Property

[image]
Gizmox.WebGUI.Forms
Y Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > MouseEventArgs Class : Y Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Y As Integer
Visual Basic (Usage) Copy Code
Dim instance As MouseEventArgs
Dim value As Integer

value = instance.Y
C#
public int Y {get;}
Managed Extensions for C++
public: __property int get_Y();
C++/CLI
public:
property int Y {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MouseEventArgs Class
MouseEventArgs Members


NodeLabelEditEventArgs Class

[image]
Gizmox.WebGUI.Forms
NodeLabelEditEventArgs Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : NodeLabelEditEventArgs Class

Object Model

Syntax

Visual Basic (Declaration)
Public Class NodeLabelEditEventArgs
   Inherits EventArgs
Visual Basic (Usage) Copy Code
Dim instance As NodeLabelEditEventArgs
C#
public class NodeLabelEditEventArgs : EventArgs
Managed Extensions for C++
public __gc class NodeLabelEditEventArgs : public EventArgs
C++/CLI
public ref class NodeLabelEditEventArgs : public EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gizmox.WebGUI.Forms.NodeLabelEditEventArgs

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

NodeLabelEditEventArgs Members
Gizmox.WebGUI.Forms Namespace


NodeLabelEditEventArgs Class Members

[image]
Gizmox.WebGUI.Forms
NodeLabelEditEventArgs Class Members
See Also Properties Send Feedback
Gizmox.WebGUI.Forms Namespace : NodeLabelEditEventArgs Class

The following tables list the members exposed by NodeLabelEditEventArgs.

Public Constructors

 | Name | Description
Public Constructor | NodeLabelEditEventArgs Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | CancelEdit |
Public Property | Label |
Public Property | Node |
Top

See Also

Reference

NodeLabelEditEventArgs Class
Gizmox.WebGUI.Forms Namespace


NodeLabelEditEventArgs Constructor

[image]
Gizmox.WebGUI.Forms
NodeLabelEditEventArgs Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > NodeLabelEditEventArgs Class : NodeLabelEditEventArgs Constructor

Overload List

Overload | Description
NodeLabelEditEventArgs Constructor(TreeNode) |
NodeLabelEditEventArgs Constructor(TreeNode,String) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

NodeLabelEditEventArgs Class
NodeLabelEditEventArgs Members


NodeLabelEditEventArgs Constructor(TreeNode)

[image]
Gizmox.WebGUI.Forms
NodeLabelEditEventArgs Constructor(TreeNode)
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > NodeLabelEditEventArgs Class > NodeLabelEditEventArgs Constructor : NodeLabelEditEventArgs Constructor(TreeNode)

node

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal node As TreeNode _
)
Visual Basic (Usage) Copy Code
Dim node As TreeNode

Dim instance As NodeLabelEditEventArgs(node)
C#
public NodeLabelEditEventArgs(
   TreeNode node
)
Managed Extensions for C++
public: NodeLabelEditEventArgs(
   TreeNode* node
)
C++/CLI
public:
NodeLabelEditEventArgs(
   TreeNode^ node
)

Parameters

node

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

NodeLabelEditEventArgs Class
NodeLabelEditEventArgs Members
Overload List


NodeLabelEditEventArgs Constructor(TreeNode,String)

[image]
Gizmox.WebGUI.Forms
NodeLabelEditEventArgs Constructor(TreeNode,String)
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > NodeLabelEditEventArgs Class > NodeLabelEditEventArgs Constructor : NodeLabelEditEventArgs Constructor(TreeNode,String)

node
label

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal node As TreeNode, _
   ByVal label As String _
)
Visual Basic (Usage) Copy Code
Dim node As TreeNode
Dim label As String

Dim instance As NodeLabelEditEventArgs(node, label)
C#
public NodeLabelEditEventArgs(
   TreeNode node,
   string label
)
Managed Extensions for C++
public: NodeLabelEditEventArgs(
   TreeNode* node,
   string* label
)
C++/CLI
public:
NodeLabelEditEventArgs(
   TreeNode^ node,
   String^ label
)

Parameters

node
label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

NodeLabelEditEventArgs Class
NodeLabelEditEventArgs Members
Overload List


NodeLabelEditEventArgs Class Properties

[image]
Gizmox.WebGUI.Forms
NodeLabelEditEventArgs Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : NodeLabelEditEventArgs Class

For a list of all members of this type, see NodeLabelEditEventArgs members.

Public Properties

 | Name | Description
Public Property | CancelEdit |
Public Property | Label |
Public Property | Node |
Top

See Also

Reference

NodeLabelEditEventArgs Class
Gizmox.WebGUI.Forms Namespace


CancelEdit Property

[image]
Gizmox.WebGUI.Forms
CancelEdit Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > NodeLabelEditEventArgs Class : CancelEdit Property

Syntax

Visual Basic (Declaration)
Public Property CancelEdit As Boolean
Visual Basic (Usage) Copy Code
Dim instance As NodeLabelEditEventArgs
Dim value As Boolean

instance.CancelEdit = value

value = instance.CancelEdit
C#
public bool CancelEdit {get; set;}
Managed Extensions for C++
public: __property bool get_CancelEdit();
public: __property void set_CancelEdit(
   bool value
);
C++/CLI
public:
property bool CancelEdit {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

NodeLabelEditEventArgs Class
NodeLabelEditEventArgs Members


Label Property

[image]
Gizmox.WebGUI.Forms
Label Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > NodeLabelEditEventArgs Class : Label Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Label As String
Visual Basic (Usage) Copy Code
Dim instance As NodeLabelEditEventArgs
Dim value As String

value = instance.Label
C#
public string Label {get;}
Managed Extensions for C++
public: __property string* get_Label();
C++/CLI
public:
property String^ Label {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

NodeLabelEditEventArgs Class
NodeLabelEditEventArgs Members


Node Property

[image]
Gizmox.WebGUI.Forms
Node Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > NodeLabelEditEventArgs Class : Node Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Node As TreeNode
Visual Basic (Usage) Copy Code
Dim instance As NodeLabelEditEventArgs
Dim value As TreeNode

value = instance.Node
C#
public TreeNode Node {get;}
Managed Extensions for C++
public: __property TreeNode* get_Node();
C++/CLI
public:
property TreeNode^ Node {
   TreeNode^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

NodeLabelEditEventArgs Class
NodeLabelEditEventArgs Members


NumericUpDown Class

[image]
Gizmox.WebGUI.Forms
NumericUpDown Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : NumericUpDown Class

Represents a Windows spin box (also known as an up-down control) that displays numeric values.

Object Model

Syntax

Visual Basic (Declaration)
<DesignTimeControllerAttribute()>
<MetadataTagAttribute("NUD")>
<SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableNumericUpDown, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")>
<ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<ClientControllerAttribute()>
<ToolboxBitmapAttribute()>
<SRDescriptionAttribute("Displays a single numeric value that the user can increment and decrement by clicking up and down buttons on the control.")>
<DefaultPropertyAttribute("Value")>
<DefaultEventAttribute("ValueChanged")>
<ToolboxItemCategoryAttribute("Common Controls")>
Public Class NumericUpDown
   Inherits UpDownBase
   Implements IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IContainerControl, IArrangedElement
Visual Basic (Usage) Copy Code
Dim instance As NumericUpDown
C#
[DesignTimeControllerAttribute()]
[MetadataTagAttribute("NUD")]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableNumericUpDown, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ClientControllerAttribute()]
[ToolboxBitmapAttribute()]
[SRDescriptionAttribute("Displays a single numeric value that the user can increment and decrement by clicking up and down buttons on the control.")]
[DefaultPropertyAttribute("Value")]
[DefaultEventAttribute("ValueChanged")]
[ToolboxItemCategoryAttribute("Common Controls")]
public class NumericUpDown : UpDownBase, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IContainerControl, IArrangedElement
Managed Extensions for C++
[DesignTimeControllerAttribute()]
[MetadataTagAttribute("NUD")]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableNumericUpDown, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ClientControllerAttribute()]
[ToolboxBitmapAttribute()]
[SRDescriptionAttribute("Displays a single numeric value that the user can increment and decrement by clicking up and down buttons on the control.")]
[DefaultPropertyAttribute("Value")]
[DefaultEventAttribute("ValueChanged")]
[ToolboxItemCategoryAttribute("Common Controls")]
public __gc class NumericUpDown : public UpDownBase, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IContainerControl, IArrangedElement
C++/CLI
[DesignTimeControllerAttribute()]
[MetadataTagAttribute("NUD")]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableNumericUpDown, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ClientControllerAttribute()]
[ToolboxBitmapAttribute()]
[SRDescriptionAttribute("Displays a single numeric value that the user can increment and decrement by clicking up and down buttons on the control.")]
[DefaultPropertyAttribute("Value")]
[DefaultEventAttribute("ValueChanged")]
[ToolboxItemCategoryAttribute("Common Controls")]
public ref class NumericUpDown : public UpDownBase, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IContainerControl, IArrangedElement

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.ScrollableControl
Gizmox.WebGUI.Forms.ContainerControl
Gizmox.WebGUI.Forms.UpDownBase
Gizmox.WebGUI.Forms.NumericUpDown

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

NumericUpDown Members
Gizmox.WebGUI.Forms Namespace


NumericUpDown Class Members

[image]
Gizmox.WebGUI.Forms
NumericUpDown Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : NumericUpDown Class

The following tables list the members exposed by NumericUpDown.

Public Constructors

 | Name | Description
Public Constructor | NumericUpDown Constructor | Initializes a new instance of the NumericUpDown class.
Top

Public Properties

 | Name | Description
Public Property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl)
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from ContainerControl)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Components | (Inherited from ContainerControl)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | DecimalPlaces | Gets or sets the number of decimal places to display in the spin box (also known as an up-down control).
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | Hexadecimal | Gets or sets a value indicating whether the spin box (also known as an up-down control) should display the value it contains in hexadecimal format.
Public Property | HideButtons | Gets or sets a value indicating whether the buttons are hidden or not. (Inherited from UpDownBase)
Public Property | Increment | Gets or sets the value to increment or decrement the spin box (also known as an up-down control) when the up or down buttons are clicked.
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | Maximum | Gets or sets the maximum value for the spin box (also known as an up-down control).
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Minimum | Gets or sets the minimum allowed value for the spin box (also known as an up-down control).
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | ReadOnly | Gets or sets a value indicating whether the text can be changed by the use of the up or down buttons only. (Inherited from UpDownBase)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | TextAlign | Gets or sets the alignment of the text in the spin box (also known as an up-down control). (Inherited from UpDownBase)
Public Property | ThousandsSeparator | Gets or sets a value indicating whether a thousands separator is displayed in the spin box (also known as an up-down control) when appropriate.
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | UpDownAlign | Gets or sets the alignment of the up and down buttons on the spin box (also known as an up-down control). (Inherited from UpDownBase)
Public Property | Value | Gets or sets the value assigned to the spin box (also known as an up-down control).
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Protected Property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl)
Top

Public Methods

 | Name | Description
Public Method | Add | (Inherited from ContainerControl)
Public Method | BeginInit | Begins the initialization of a NumericUpDown control that is used on a form or used by another component. The initialization occurs at run time.
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from ContainerControl)
Public Method | DownButton | Overridden. Decrements the value of the spin box (also known as an up-down control).
Public Method | EndInit | Ends the initialization of a NumericUpDown control that is used on a form or used by another component. The initialization occurs at run time.
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | Remove | (Inherited from ContainerControl)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl)
Public Method | Select | Overloaded. Selects a range of text in the spin box (also known as an up-down control) specifying the starting position and number of characters to select. (Inherited from UpDownBase)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | Overridden. Returns a string that represents the NumericUpDown control.
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | UpButton | Overridden. Increments the value of the spin box (also known as an up-down control).
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from UpDownBase)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Overridden. Gets the critical events.
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from ScrollableControl)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Overridden. Raises the Control.KeyDown event.
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Overridden. Raises the Control.KeyUp event.
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | Overridden. Raises the Control.LostFocus event.
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnValueChanged | Raises the ValueChanged event.
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ParseEditText | Converts the text displayed in the spin box (also known as an up-down control) to a numeric value and evaluates it.
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Control)
Protected Method | RenderAttributes | Overridden. Renders the scrollable attribute
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetValue | Overridden.
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateEditText | Overridden. Displays the current value of the spin box (also known as an up-down control) in the appropriate format.
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Protected Method | ValidateEditText | Overridden. Validates and updates the text displayed in the spin box (also known as an up-down control).
Top

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | ValueChanged | Occurs when the Value property has been changed in some way.
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

NumericUpDown Class
Gizmox.WebGUI.Forms Namespace


NumericUpDown Constructor

[image]
Gizmox.WebGUI.Forms
NumericUpDown Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > NumericUpDown Class : NumericUpDown Constructor

Initializes a new instance of the NumericUpDown class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As NumericUpDown()
C#
public NumericUpDown()
Managed Extensions for C++
public: NumericUpDown();
C++/CLI
public:
NumericUpDown();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

NumericUpDown Class
NumericUpDown Members


NumericUpDown Class Methods

[image]
Gizmox.WebGUI.Forms
NumericUpDown Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : NumericUpDown Class

For a list of all members of this type, see NumericUpDown members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from ContainerControl)
Public Method | BeginInit | Begins the initialization of a NumericUpDown control that is used on a form or used by another component. The initialization occurs at run time.
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from ContainerControl)
Public Method | DownButton | Overridden. Decrements the value of the spin box (also known as an up-down control).
Public Method | EndInit | Ends the initialization of a NumericUpDown control that is used on a form or used by another component. The initialization occurs at run time.
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | Remove | (Inherited from ContainerControl)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl)
Public Method | Select | Overloaded. Selects a range of text in the spin box (also known as an up-down control) specifying the starting position and number of characters to select. (Inherited from UpDownBase)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | Overridden. Returns a string that represents the NumericUpDown control.
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | UpButton | Overridden. Increments the value of the spin box (also known as an up-down control).
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from UpDownBase)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Overridden. Gets the critical events.
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from ScrollableControl)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Overridden. Raises the Control.KeyDown event.
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Overridden. Raises the Control.KeyUp event.
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | Overridden. Raises the Control.LostFocus event.
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnValueChanged | Raises the ValueChanged event.
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ParseEditText | Converts the text displayed in the spin box (also known as an up-down control) to a numeric value and evaluates it.
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Control)
Protected Method | RenderAttributes | Overridden. Renders the scrollable attribute
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetValue | Overridden.
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateEditText | Overridden. Displays the current value of the spin box (also known as an up-down control) in the appropriate format.
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Protected Method | ValidateEditText | Overridden. Validates and updates the text displayed in the spin box (also known as an up-down control).
Top

See Also

Reference

NumericUpDown Class
Gizmox.WebGUI.Forms Namespace


BeginInit Method

[image]
Gizmox.WebGUI.Forms
BeginInit Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > NumericUpDown Class : BeginInit Method

Begins the initialization of a NumericUpDown control that is used on a form or used by another component. The initialization occurs at run time.

Syntax

Visual Basic (Declaration)
Public Sub BeginInit()
Visual Basic (Usage) Copy Code
Dim instance As NumericUpDown

instance.BeginInit()
C#
public void BeginInit()
Managed Extensions for C++
public: void BeginInit();
C++/CLI
public:
void BeginInit();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

NumericUpDown Class
NumericUpDown Members


DownButton Method

[image]
Gizmox.WebGUI.Forms
DownButton Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > NumericUpDown Class : DownButton Method

Decrements the value of the spin box (also known as an up-down control).

Syntax

Visual Basic (Declaration)
Public Overrides Sub DownButton()
Visual Basic (Usage) Copy Code
Dim instance As NumericUpDown

instance.DownButton()
C#
public override void DownButton()
Managed Extensions for C++
public: void DownButton(); override
C++/CLI
public:
void DownButton(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

NumericUpDown Class
NumericUpDown Members


EndInit Method

[image]
Gizmox.WebGUI.Forms
EndInit Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > NumericUpDown Class : EndInit Method

Ends the initialization of a NumericUpDown control that is used on a form or used by another component. The initialization occurs at run time.

Syntax

Visual Basic (Declaration)
Public Sub EndInit()
Visual Basic (Usage) Copy Code
Dim instance As NumericUpDown

instance.EndInit()
C#
public void EndInit()
Managed Extensions for C++
public: void EndInit();
C++/CLI
public:
void EndInit();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

NumericUpDown Class
NumericUpDown Members


GetCriticalEvents Method

[image]
Gizmox.WebGUI.Forms
GetCriticalEvents Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > NumericUpDown Class : GetCriticalEvents Method

Gets the critical events.

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetCriticalEvents() As EventTypes
Visual Basic (Usage) Copy Code
Dim instance As NumericUpDown
Dim value As EventTypes

value = instance.GetCriticalEvents()
C#
protected override EventTypes GetCriticalEvents()
Managed Extensions for C++
protected: EventTypes GetCriticalEvents(); override
C++/CLI
protected:
EventTypes GetCriticalEvents(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

NumericUpDown Class
NumericUpDown Members


OnKeyDown Method

[image]
Gizmox.WebGUI.Forms
OnKeyDown Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > NumericUpDown Class : OnKeyDown Method

e
A KeyEventArgs that contains the event data.
Raises the Control.KeyDown event.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnKeyDown( _
   ByVal e As KeyEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As NumericUpDown
Dim e As KeyEventArgs

instance.OnKeyDown(e)
C#
protected override void OnKeyDown(
   KeyEventArgs e
)
Managed Extensions for C++
protected: void OnKeyDown(
   KeyEventArgs* e
) override
C++/CLI
protected:
void OnKeyDown(
   KeyEventArgs^ e
) override

Parameters

e
A KeyEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

NumericUpDown Class
NumericUpDown Members


OnKeyUp Method

[image]
Gizmox.WebGUI.Forms
OnKeyUp Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > NumericUpDown Class : OnKeyUp Method

e
A KeyEventArgs that contains the event data.
Raises the Control.KeyUp event.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnKeyUp( _
   ByVal e As KeyEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As NumericUpDown
Dim e As KeyEventArgs

instance.OnKeyUp(e)
C#
protected override void OnKeyUp(
   KeyEventArgs e
)
Managed Extensions for C++
protected: void OnKeyUp(
   KeyEventArgs* e
) override
C++/CLI
protected:
void OnKeyUp(
   KeyEventArgs^ e
) override

Parameters

e
A KeyEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

NumericUpDown Class
NumericUpDown Members


OnLostFocus Method

[image]
Gizmox.WebGUI.Forms
OnLostFocus Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > NumericUpDown Class : OnLostFocus Method

e
An EventArgs that contains the event data.
Raises the Control.LostFocus event.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnLostFocus( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As NumericUpDown
Dim e As EventArgs

instance.OnLostFocus(e)
C#
protected override void OnLostFocus(
   EventArgs e
)
Managed Extensions for C++
protected: void OnLostFocus(
   EventArgs* e
) override
C++/CLI
protected:
void OnLostFocus(
   EventArgs^ e
) override

Parameters

e
An EventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

NumericUpDown Class
NumericUpDown Members


OnValueChanged Method

[image]
Gizmox.WebGUI.Forms
OnValueChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > NumericUpDown Class : OnValueChanged Method

e
An EventArgs that contains the event data.
Raises the ValueChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnValueChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As NumericUpDown
Dim e As EventArgs

instance.OnValueChanged(e)
C#
protected virtual void OnValueChanged(
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnValueChanged(
   EventArgs* e
)
C++/CLI
protected:
virtual void OnValueChanged(
   EventArgs^ e
)

Parameters

e
An EventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

NumericUpDown Class
NumericUpDown Members


ParseEditText Method

[image]
Gizmox.WebGUI.Forms
ParseEditText Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > NumericUpDown Class : ParseEditText Method

Converts the text displayed in the spin box (also known as an up-down control) to a numeric value and evaluates it.

Syntax

Visual Basic (Declaration)
Protected Sub ParseEditText()
Visual Basic (Usage) Copy Code
Dim instance As NumericUpDown

instance.ParseEditText()
C#
protected void ParseEditText()
Managed Extensions for C++
protected: void ParseEditText();
C++/CLI
protected:
void ParseEditText();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

NumericUpDown Class
NumericUpDown Members


RenderAttributes Method

[image]
Gizmox.WebGUI.Forms
RenderAttributes Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > NumericUpDown Class : RenderAttributes Method

objContext
objWriter
Renders the scrollable attribute

Syntax

Visual Basic (Declaration)
Protected Overrides Sub RenderAttributes( _
   ByVal objContext As IContext, _
   ByVal objWriter As IAttributeWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As NumericUpDown
Dim objContext As IContext
Dim objWriter As IAttributeWriter

instance.RenderAttributes(objContext, objWriter)
C#
protected override void RenderAttributes(
   IContext objContext,
   IAttributeWriter objWriter
)
Managed Extensions for C++
protected: void RenderAttributes(
   IContext* objContext,
   IAttributeWriter* objWriter
) override
C++/CLI
protected:
void RenderAttributes(
   IContext^ objContext,
   IAttributeWriter^ objWriter
) override

Parameters

objContext
objWriter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

NumericUpDown Class
NumericUpDown Members


SetValue Method

[image]
Gizmox.WebGUI.Forms
SetValue Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > NumericUpDown Class : SetValue Method

strValue

Syntax

Visual Basic (Declaration)
Protected Overrides Sub SetValue( _
   ByVal strValue As String _
)
Visual Basic (Usage) Copy Code
Dim instance As NumericUpDown
Dim strValue As String

instance.SetValue(strValue)
C#
protected override void SetValue(
   string strValue
)
Managed Extensions for C++
protected: void SetValue(
   string* strValue
) override
C++/CLI
protected:
void SetValue(
   String^ strValue
) override

Parameters

strValue

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

NumericUpDown Class
NumericUpDown Members


ToString Method

[image]
Gizmox.WebGUI.Forms
ToString Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > NumericUpDown Class : ToString Method

Returns a string that represents the NumericUpDown control.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As NumericUpDown
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Return Value

A string that represents the current NumericUpDown.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

NumericUpDown Class
NumericUpDown Members


UpButton Method

[image]
Gizmox.WebGUI.Forms
UpButton Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > NumericUpDown Class : UpButton Method

Increments the value of the spin box (also known as an up-down control).

Syntax

Visual Basic (Declaration)
Public Overrides Sub UpButton()
Visual Basic (Usage) Copy Code
Dim instance As NumericUpDown

instance.UpButton()
C#
public override void UpButton()
Managed Extensions for C++
public: void UpButton(); override
C++/CLI
public:
void UpButton(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

NumericUpDown Class
NumericUpDown Members


UpdateEditText Method

[image]
Gizmox.WebGUI.Forms
UpdateEditText Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > NumericUpDown Class : UpdateEditText Method

Displays the current value of the spin box (also known as an up-down control) in the appropriate format.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub UpdateEditText()
Visual Basic (Usage) Copy Code
Dim instance As NumericUpDown

instance.UpdateEditText()
C#
protected override void UpdateEditText()
Managed Extensions for C++
protected: void UpdateEditText(); override
C++/CLI
protected:
void UpdateEditText(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

NumericUpDown Class
NumericUpDown Members


ValidateEditText Method

[image]
Gizmox.WebGUI.Forms
ValidateEditText Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > NumericUpDown Class : ValidateEditText Method

Validates and updates the text displayed in the spin box (also known as an up-down control).

Syntax

Visual Basic (Declaration)
Protected Overrides Sub ValidateEditText()
Visual Basic (Usage) Copy Code
Dim instance As NumericUpDown

instance.ValidateEditText()
C#
protected override void ValidateEditText()
Managed Extensions for C++
protected: void ValidateEditText(); override
C++/CLI
protected:
void ValidateEditText(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

NumericUpDown Class
NumericUpDown Members


NumericUpDown Class Properties

[image]
Gizmox.WebGUI.Forms
NumericUpDown Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : NumericUpDown Class

For a list of all members of this type, see NumericUpDown members.

Public Properties

 | Name | Description
Public Property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl)
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from ContainerControl)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Components | (Inherited from ContainerControl)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | DecimalPlaces | Gets or sets the number of decimal places to display in the spin box (also known as an up-down control).
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | Hexadecimal | Gets or sets a value indicating whether the spin box (also known as an up-down control) should display the value it contains in hexadecimal format.
Public Property | HideButtons | Gets or sets a value indicating whether the buttons are hidden or not. (Inherited from UpDownBase)
Public Property | Increment | Gets or sets the value to increment or decrement the spin box (also known as an up-down control) when the up or down buttons are clicked.
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | Maximum | Gets or sets the maximum value for the spin box (also known as an up-down control).
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Minimum | Gets or sets the minimum allowed value for the spin box (also known as an up-down control).
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | ReadOnly | Gets or sets a value indicating whether the text can be changed by the use of the up or down buttons only. (Inherited from UpDownBase)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | TextAlign | Gets or sets the alignment of the text in the spin box (also known as an up-down control). (Inherited from UpDownBase)
Public Property | ThousandsSeparator | Gets or sets a value indicating whether a thousands separator is displayed in the spin box (also known as an up-down control) when appropriate.
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | UpDownAlign | Gets or sets the alignment of the up and down buttons on the spin box (also known as an up-down control). (Inherited from UpDownBase)
Public Property | Value | Gets or sets the value assigned to the spin box (also known as an up-down control).
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Protected Property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl)
Top

See Also

Reference

NumericUpDown Class
Gizmox.WebGUI.Forms Namespace


DecimalPlaces Property

[image]
Gizmox.WebGUI.Forms
DecimalPlaces Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > NumericUpDown Class : DecimalPlaces Property

Gets or sets the number of decimal places to display in the spin box (also known as an up-down control).

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Data")>
<DefaultValueAttribute()>
<SRDescriptionAttribute("Indicates the number of decimal places to display.")>
Public Property DecimalPlaces As Integer
Visual Basic (Usage) Copy Code
Dim instance As NumericUpDown
Dim value As Integer

instance.DecimalPlaces = value

value = instance.DecimalPlaces
C#
[SRCategoryAttribute("Data")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Indicates the number of decimal places to display.")]
public int DecimalPlaces {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Data")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Indicates the number of decimal places to display.")]
public: __property int get_DecimalPlaces();
public: __property void set_DecimalPlaces(
   int value
);
C++/CLI
[SRCategoryAttribute("Data")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Indicates the number of decimal places to display.")]
public:
property int DecimalPlaces {
   int get();
   void set (intvalue);
}

Exceptions

Exception | Description
ArgumentOutOfRangeException | The value assigned is less than 0.-or- The value assigned is greater than 99.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

NumericUpDown Class
NumericUpDown Members


Hexadecimal Property

[image]
Gizmox.WebGUI.Forms
Hexadecimal Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > NumericUpDown Class : Hexadecimal Property

Gets or sets a value indicating whether the spin box (also known as an up-down control) should display the value it contains in hexadecimal format.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Indicates whether the numeric up-down should display its value in hexadecimal.")>
<DefaultValueAttribute()>
<SRCategoryAttribute("Appearance")>
Public Property Hexadecimal As Boolean
Visual Basic (Usage) Copy Code
Dim instance As NumericUpDown
Dim value As Boolean

instance.Hexadecimal = value

value = instance.Hexadecimal
C#
[SRDescriptionAttribute("Indicates whether the numeric up-down should display its value in hexadecimal.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
public bool Hexadecimal {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Indicates whether the numeric up-down should display its value in hexadecimal.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
public: __property bool get_Hexadecimal();
public: __property void set_Hexadecimal(
   bool value
);
C++/CLI
[SRDescriptionAttribute("Indicates whether the numeric up-down should display its value in hexadecimal.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
public:
property bool Hexadecimal {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

NumericUpDown Class
NumericUpDown Members


Increment Property

[image]
Gizmox.WebGUI.Forms
Increment Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > NumericUpDown Class : Increment Property

Gets or sets the value to increment or decrement the spin box (also known as an up-down control) when the up or down buttons are clicked.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Data")>
<SRDescriptionAttribute("Indicates the amount to increment or decrement on each button click.")>
Public Property Increment As Decimal
Visual Basic (Usage) Copy Code
Dim instance As NumericUpDown
Dim value As Decimal

instance.Increment = value

value = instance.Increment
C#
[SRCategoryAttribute("Data")]
[SRDescriptionAttribute("Indicates the amount to increment or decrement on each button click.")]
public decimal Increment {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Data")]
[SRDescriptionAttribute("Indicates the amount to increment or decrement on each button click.")]
public: __property decimal get_Increment();
public: __property void set_Increment(
   decimal value
);
C++/CLI
[SRCategoryAttribute("Data")]
[SRDescriptionAttribute("Indicates the amount to increment or decrement on each button click.")]
public:
property decimal Increment {
   decimal get();
   void set (decimalvalue);
}

Exceptions

Exception | Description
ArgumentOutOfRangeException | The assigned value is not a positive number.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

NumericUpDown Class
NumericUpDown Members


Maximum Property

[image]
Gizmox.WebGUI.Forms
Maximum Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > NumericUpDown Class : Maximum Property

Gets or sets the maximum value for the spin box (also known as an up-down control).

Syntax

Visual Basic (Declaration)
<RefreshPropertiesAttribute()>
<SRDescriptionAttribute("Indicates the maximum value for the numeric up-down control.")>
<SRCategoryAttribute("Data")>
Public Property Maximum As Decimal
Visual Basic (Usage) Copy Code
Dim instance As NumericUpDown
Dim value As Decimal

instance.Maximum = value

value = instance.Maximum
C#
[RefreshPropertiesAttribute()]
[SRDescriptionAttribute("Indicates the maximum value for the numeric up-down control.")]
[SRCategoryAttribute("Data")]
public decimal Maximum {get; set;}
Managed Extensions for C++
[RefreshPropertiesAttribute()]
[SRDescriptionAttribute("Indicates the maximum value for the numeric up-down control.")]
[SRCategoryAttribute("Data")]
public: __property decimal get_Maximum();
public: __property void set_Maximum(
   decimal value
);
C++/CLI
[RefreshPropertiesAttribute()]
[SRDescriptionAttribute("Indicates the maximum value for the numeric up-down control.")]
[SRCategoryAttribute("Data")]
public:
property decimal Maximum {
   decimal get();
   void set (decimalvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

NumericUpDown Class
NumericUpDown Members


Minimum Property

[image]
Gizmox.WebGUI.Forms
Minimum Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > NumericUpDown Class : Minimum Property

Gets or sets the minimum allowed value for the spin box (also known as an up-down control).

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Data")>
<RefreshPropertiesAttribute()>
<SRDescriptionAttribute("Indicates the minimum value for the numeric up-down control.")>
Public Property Minimum As Decimal
Visual Basic (Usage) Copy Code
Dim instance As NumericUpDown
Dim value As Decimal

instance.Minimum = value

value = instance.Minimum
C#
[SRCategoryAttribute("Data")]
[RefreshPropertiesAttribute()]
[SRDescriptionAttribute("Indicates the minimum value for the numeric up-down control.")]
public decimal Minimum {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Data")]
[RefreshPropertiesAttribute()]
[SRDescriptionAttribute("Indicates the minimum value for the numeric up-down control.")]
public: __property decimal get_Minimum();
public: __property void set_Minimum(
   decimal value
);
C++/CLI
[SRCategoryAttribute("Data")]
[RefreshPropertiesAttribute()]
[SRDescriptionAttribute("Indicates the minimum value for the numeric up-down control.")]
public:
property decimal Minimum {
   decimal get();
   void set (decimalvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

NumericUpDown Class
NumericUpDown Members


ThousandsSeparator Property

[image]
Gizmox.WebGUI.Forms
ThousandsSeparator Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > NumericUpDown Class : ThousandsSeparator Property

Gets or sets a value indicating whether a thousands separator is displayed in the spin box (also known as an up-down control) when appropriate.

Syntax

Visual Basic (Declaration)
<LocalizableAttribute(True)>
<DefaultValueAttribute()>
<SRDescriptionAttribute("Indicates whether the thousands separator will be inserted between every three decimal digits.")>
<SRCategoryAttribute("Data")>
Public Property ThousandsSeparator As Boolean
Visual Basic (Usage) Copy Code
Dim instance As NumericUpDown
Dim value As Boolean

instance.ThousandsSeparator = value

value = instance.ThousandsSeparator
C#
[LocalizableAttribute(true)]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Indicates whether the thousands separator will be inserted between every three decimal digits.")]
[SRCategoryAttribute("Data")]
public bool ThousandsSeparator {get; set;}
Managed Extensions for C++
[LocalizableAttribute(true)]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Indicates whether the thousands separator will be inserted between every three decimal digits.")]
[SRCategoryAttribute("Data")]
public: __property bool get_ThousandsSeparator();
public: __property void set_ThousandsSeparator(
   bool value
);
C++/CLI
[LocalizableAttribute(true)]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Indicates whether the thousands separator will be inserted between every three decimal digits.")]
[SRCategoryAttribute("Data")]
public:
property bool ThousandsSeparator {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

NumericUpDown Class
NumericUpDown Members


Value Property

[image]
Gizmox.WebGUI.Forms
Value Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > NumericUpDown Class : Value Property

Gets or sets the value assigned to the spin box (also known as an up-down control).

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("The current value of the numeric up-down control.")>
<BindableAttribute(True)>
<SRCategoryAttribute("Appearance")>
Public Property Value As Decimal
Visual Basic (Usage) Copy Code
Dim instance As NumericUpDown
Dim value As Decimal

instance.Value = value

value = instance.Value
C#
[SRDescriptionAttribute("The current value of the numeric up-down control.")]
[BindableAttribute(true)]
[SRCategoryAttribute("Appearance")]
public decimal Value {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("The current value of the numeric up-down control.")]
[BindableAttribute(true)]
[SRCategoryAttribute("Appearance")]
public: __property decimal get_Value();
public: __property void set_Value(
   decimal value
);
C++/CLI
[SRDescriptionAttribute("The current value of the numeric up-down control.")]
[BindableAttribute(true)]
[SRCategoryAttribute("Appearance")]
public:
property decimal Value {
   decimal get();
   void set (decimalvalue);
}

Exceptions

Exception | Description
ArgumentOutOfRangeException | The assigned value is less than the Minimum property value.-or- The assigned value is greater than the Maximum property value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

NumericUpDown Class
NumericUpDown Members


NumericUpDown Class Events

[image]
Gizmox.WebGUI.Forms
NumericUpDown Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : NumericUpDown Class

For a list of all members of this type, see NumericUpDown members.

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | ValueChanged | Occurs when the Value property has been changed in some way.
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

NumericUpDown Class
Gizmox.WebGUI.Forms Namespace


ValueChanged Event

[image]
Gizmox.WebGUI.Forms
ValueChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > NumericUpDown Class : ValueChanged Event

Occurs when the Value property has been changed in some way.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Action")>
<SRDescriptionAttribute("Occurs when the value in the up-down control changes.")>
Public Event ValueChanged() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As NumericUpDown
Dim handler As EventHandler

AddHandler instance.ValueChanged, handler
C#
[SRCategoryAttribute("Action")]
[SRDescriptionAttribute("Occurs when the value in the up-down control changes.")]
public event EventHandler ValueChanged()
Managed Extensions for C++
[SRCategoryAttribute("Action")]
[SRDescriptionAttribute("Occurs when the value in the up-down control changes.")]
public: __event EventHandler* ValueChanged
C++/CLI
[SRCategoryAttribute("Action")]
[SRDescriptionAttribute("Occurs when the value in the up-down control changes.")]
public:
event EventHandler^ ValueChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

NumericUpDown Class
NumericUpDown Members


OpenFileDialog Class

[image]
Gizmox.WebGUI.Forms
OpenFileDialog Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : OpenFileDialog Class

Prompts the user to open a file. This class cannot be inherited.

Object Model

Syntax

Visual Basic (Declaration)
<ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<SRDescriptionAttribute("Displays a dialog box that prompts the user to open a file.")>
<ToolboxBitmapAttribute()>
Public NotInheritable Class OpenFileDialog
   Inherits FileDialog
   Implements ICommonDialog
Visual Basic (Usage) Copy Code
Dim instance As OpenFileDialog
C#
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[SRDescriptionAttribute("Displays a dialog box that prompts the user to open a file.")]
[ToolboxBitmapAttribute()]
public sealed class OpenFileDialog : FileDialog, ICommonDialog
Managed Extensions for C++
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[SRDescriptionAttribute("Displays a dialog box that prompts the user to open a file.")]
[ToolboxBitmapAttribute()]
public __gc __sealed class OpenFileDialog : public FileDialog, ICommonDialog
C++/CLI
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[SRDescriptionAttribute("Displays a dialog box that prompts the user to open a file.")]
[ToolboxBitmapAttribute()]
public ref class OpenFileDialog sealed : public FileDialog, ICommonDialog

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.CommonDialog
Gizmox.WebGUI.Forms.FileDialog
Gizmox.WebGUI.Forms.OpenFileDialog

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

OpenFileDialog Members
Gizmox.WebGUI.Forms Namespace


OpenFileDialog Class Members

[image]
Gizmox.WebGUI.Forms
OpenFileDialog Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : OpenFileDialog Class

The following tables list the members exposed by OpenFileDialog.

Public Constructors

 | Name | Description
Public Constructor | OpenFileDialog Constructor | Initializes an instance of the OpenFileDialog class.
Top

Public Properties

 | Name | Description
Public Property | AddExtension | Gets or sets a value indicating whether the dialog box automatically adds an extension to a file name if the user omits the extension. (Inherited from FileDialog)
Public Property | CheckFileExists | Overridden. Gets or sets a value indicating whether the dialog box displays a warning if the user specifies a file name that does not exist.
Public Property | CheckPathExists | Gets or sets a value indicating whether the dialog box displays a warning if the user specifies a path that does not exist. (Inherited from FileDialog)
Public Property | Container | (Inherited from ComponentBase)
Public Property | DefaultExt | Gets or sets the default file name extension. (Inherited from FileDialog)
Public Property | DereferenceLinks | Gets or sets a value indicating whether the dialog box returns the location of the file referenced by the shortcut or whether it returns the location of the shortcut (.lnk). (Inherited from FileDialog)
Public Property | DialogResult | Returns the last dialog result (Inherited from CommonDialog)
Public Property | File | Gets the current selected file (Inherited from FileDialog)
Public Property | FileName | Gets or sets a string containing the file name selected in the file dialog box. (Inherited from FileDialog)
Public Property | FileNames | Gets the file names of all selected files in the dialog box. (Inherited from FileDialog)
Public Property | Files | Gets the current selected files (Inherited from FileDialog)
Public Property | Filter | Gets or sets the current file name filter string, which determines the choices that appear in the "Save as file type" or "Files of type" box in the dialog box. (Inherited from FileDialog)
Public Property | FilterIndex | Gets or sets the index of the filter currently selected in the file dialog box. (Inherited from FileDialog)
Public Property | InitialDirectory | Gets or sets the initial directory displayed by the file dialog box. (Inherited from FileDialog)
Public Property | MaxFileSize | Gets of sets the Maximum file size allowed in kilobytes. (Inherited from FileDialog)
Public Property | Multiselect | Gets or sets a value indicating whether the dialog box allows multiple files to be selected.
Public Property | ReadOnlyChecked | Gets or sets a value indicating whether the read-only check box is selected.
Public Property | RestoreDirectory | Gets or sets a value indicating whether the dialog box restores the current directory before closing. (Inherited from FileDialog)
Public Property | ShowHelp | Gets or sets a value indicating whether the Help button is displayed in the file dialog box. (Inherited from FileDialog)
Public Property | ShowReadOnly | Gets or sets a value indicating whether the dialog box contains a read-only check box.
Public Property | Site | (Inherited from ComponentBase)
Public Property | SupportMultiDottedExtensions | (Inherited from FileDialog)
Public Property | Tag | Gets or sets an object that contains data about the control. (Inherited from CommonDialog)
Public Property | Title | Gets or sets the file dialog box title. (Inherited from FileDialog)
Public Property | ValidateNames | Gets or sets a value indicating whether the dialog box accepts only valid Win32 file names. (Inherited from FileDialog)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | Options | Gets values to initialize the FileDialog. (Inherited from FileDialog)
Top

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded. (Inherited from ComponentBase)
Public Method | OpenFile | Opens the file selected by the user, with read-only permission. The file is specified by the FileDialog.FileName property.
Public Method | Reset | Overridden. Resets all properties to their default values.
Public Method | ShowDialog | Overloaded. Runs a common dialog box with a default owner. (Inherited from CommonDialog)
Public Method | ToString | Provides a string version of this object. (Inherited from FileDialog)
Top

Protected Methods

 | Name | Description
Protected Method | CreateForm | Overridden. Create the open file dialog form
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | OnApply | Handles apply event (Inherited from CommonDialog)
Protected Method | OnClosed | Handler the dialog closing event (Inherited from FileDialog)
Protected Method | OnFileOk | Raises the FileOk event. (Inherited from FileDialog)
Protected Method | OnHelpRequest | Raises the CommonDialog.HelpRequest event. (Inherited from CommonDialog)
Top

Public Events

 | Name | Description
Public Event | Closed | The form close event (Inherited from CommonDialog)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | FileOk | Occurs when the user clicks on the Open or Save button on a file dialog box. (Inherited from FileDialog)
Public Event | HelpRequest | Occurs when the user clicks the Help button on a common dialog box. (Inherited from CommonDialog)
Top

See Also

Reference

OpenFileDialog Class
Gizmox.WebGUI.Forms Namespace


OpenFileDialog Constructor

[image]
Gizmox.WebGUI.Forms
OpenFileDialog Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > OpenFileDialog Class : OpenFileDialog Constructor

Initializes an instance of the OpenFileDialog class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As OpenFileDialog()
C#
public OpenFileDialog()
Managed Extensions for C++
public: OpenFileDialog();
C++/CLI
public:
OpenFileDialog();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

OpenFileDialog Class
OpenFileDialog Members


OpenFileDialog Class Methods

[image]
Gizmox.WebGUI.Forms
OpenFileDialog Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : OpenFileDialog Class

For a list of all members of this type, see OpenFileDialog members.

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded. (Inherited from ComponentBase)
Public Method | OpenFile | Opens the file selected by the user, with read-only permission. The file is specified by the FileDialog.FileName property.
Public Method | Reset | Overridden. Resets all properties to their default values.
Public Method | ShowDialog | Overloaded. Runs a common dialog box with a default owner. (Inherited from CommonDialog)
Public Method | ToString | Provides a string version of this object. (Inherited from FileDialog)
Top

Protected Methods

 | Name | Description
Protected Method | CreateForm | Overridden. Create the open file dialog form
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | OnApply | Handles apply event (Inherited from CommonDialog)
Protected Method | OnClosed | Handler the dialog closing event (Inherited from FileDialog)
Protected Method | OnFileOk | Raises the FileOk event. (Inherited from FileDialog)
Protected Method | OnHelpRequest | Raises the CommonDialog.HelpRequest event. (Inherited from CommonDialog)
Top

See Also

Reference

OpenFileDialog Class
Gizmox.WebGUI.Forms Namespace


CreateForm Method

[image]
Gizmox.WebGUI.Forms
CreateForm Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > OpenFileDialog Class : CreateForm Method

Create the open file dialog form

Syntax

Visual Basic (Declaration)
Protected Overrides NotOverridable Function CreateForm() As CommonDialog.CommonDialogForm
Visual Basic (Usage) Copy Code
Dim instance As OpenFileDialog
Dim value As CommonDialog.CommonDialogForm

value = instance.CreateForm()
C#
protected override CommonDialog.CommonDialogForm CreateForm()
Managed Extensions for C++
protected: CommonDialog.CommonDialogForm* CreateForm(); override
C++/CLI
protected:
CommonDialog::CommonDialogForm^ CreateForm(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

OpenFileDialog Class
OpenFileDialog Members


OpenFile Method

[image]
Gizmox.WebGUI.Forms
OpenFile Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > OpenFileDialog Class : OpenFile Method

Opens the file selected by the user, with read-only permission. The file is specified by the FileDialog.FileName property.

Syntax

Visual Basic (Declaration)
Public Function OpenFile() As Stream
Visual Basic (Usage) Copy Code
Dim instance As OpenFileDialog
Dim value As Stream

value = instance.OpenFile()
C#
public Stream OpenFile()
Managed Extensions for C++
public: Stream* OpenFile();
C++/CLI
public:
Stream^ OpenFile();

Return Value

A Stream that specifies the read-only file selected by the user.

Exceptions

Exception | Description
ArgumentNullException | The file name is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

OpenFileDialog Class
OpenFileDialog Members


Reset Method

[image]
Gizmox.WebGUI.Forms
Reset Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > OpenFileDialog Class : Reset Method

Resets all properties to their default values.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As OpenFileDialog

instance.Reset()
C#
public override void Reset()
Managed Extensions for C++
public: void Reset(); override
C++/CLI
public:
void Reset(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

OpenFileDialog Class
OpenFileDialog Members


OpenFileDialog Class Properties

[image]
Gizmox.WebGUI.Forms
OpenFileDialog Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : OpenFileDialog Class

For a list of all members of this type, see OpenFileDialog members.

Public Properties

 | Name | Description
Public Property | AddExtension | Gets or sets a value indicating whether the dialog box automatically adds an extension to a file name if the user omits the extension. (Inherited from FileDialog)
Public Property | CheckFileExists | Overridden. Gets or sets a value indicating whether the dialog box displays a warning if the user specifies a file name that does not exist.
Public Property | CheckPathExists | Gets or sets a value indicating whether the dialog box displays a warning if the user specifies a path that does not exist. (Inherited from FileDialog)
Public Property | Container | (Inherited from ComponentBase)
Public Property | DefaultExt | Gets or sets the default file name extension. (Inherited from FileDialog)
Public Property | DereferenceLinks | Gets or sets a value indicating whether the dialog box returns the location of the file referenced by the shortcut or whether it returns the location of the shortcut (.lnk). (Inherited from FileDialog)
Public Property | DialogResult | Returns the last dialog result (Inherited from CommonDialog)
Public Property | File | Gets the current selected file (Inherited from FileDialog)
Public Property | FileName | Gets or sets a string containing the file name selected in the file dialog box. (Inherited from FileDialog)
Public Property | FileNames | Gets the file names of all selected files in the dialog box. (Inherited from FileDialog)
Public Property | Files | Gets the current selected files (Inherited from FileDialog)
Public Property | Filter | Gets or sets the current file name filter string, which determines the choices that appear in the "Save as file type" or "Files of type" box in the dialog box. (Inherited from FileDialog)
Public Property | FilterIndex | Gets or sets the index of the filter currently selected in the file dialog box. (Inherited from FileDialog)
Public Property | InitialDirectory | Gets or sets the initial directory displayed by the file dialog box. (Inherited from FileDialog)
Public Property | MaxFileSize | Gets of sets the Maximum file size allowed in kilobytes. (Inherited from FileDialog)
Public Property | Multiselect | Gets or sets a value indicating whether the dialog box allows multiple files to be selected.
Public Property | ReadOnlyChecked | Gets or sets a value indicating whether the read-only check box is selected.
Public Property | RestoreDirectory | Gets or sets a value indicating whether the dialog box restores the current directory before closing. (Inherited from FileDialog)
Public Property | ShowHelp | Gets or sets a value indicating whether the Help button is displayed in the file dialog box. (Inherited from FileDialog)
Public Property | ShowReadOnly | Gets or sets a value indicating whether the dialog box contains a read-only check box.
Public Property | Site | (Inherited from ComponentBase)
Public Property | SupportMultiDottedExtensions | (Inherited from FileDialog)
Public Property | Tag | Gets or sets an object that contains data about the control. (Inherited from CommonDialog)
Public Property | Title | Gets or sets the file dialog box title. (Inherited from FileDialog)
Public Property | ValidateNames | Gets or sets a value indicating whether the dialog box accepts only valid Win32 file names. (Inherited from FileDialog)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | Options | Gets values to initialize the FileDialog. (Inherited from FileDialog)
Top

See Also

Reference

OpenFileDialog Class
Gizmox.WebGUI.Forms Namespace


CheckFileExists Property

[image]
Gizmox.WebGUI.Forms
CheckFileExists Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > OpenFileDialog Class : CheckFileExists Property

Gets or sets a value indicating whether the dialog box displays a warning if the user specifies a file name that does not exist.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<SRDescriptionAttribute("Indicates whether a warning appears when the user specifies a file that does not exist.")>
Public Overrides NotOverridable Property CheckFileExists As Boolean
Visual Basic (Usage) Copy Code
Dim instance As OpenFileDialog
Dim value As Boolean

instance.CheckFileExists = value

value = instance.CheckFileExists
C#
[DefaultValueAttribute()]
[SRDescriptionAttribute("Indicates whether a warning appears when the user specifies a file that does not exist.")]
public override bool CheckFileExists {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[SRDescriptionAttribute("Indicates whether a warning appears when the user specifies a file that does not exist.")]
public: __property bool get_CheckFileExists() override;
public: __property void set_CheckFileExists(
   bool value
) override;
C++/CLI
[DefaultValueAttribute()]
[SRDescriptionAttribute("Indicates whether a warning appears when the user specifies a file that does not exist.")]
public:
property bool CheckFileExists {
   bool get() override;
   void set (boolvalue) override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

OpenFileDialog Class
OpenFileDialog Members


Multiselect Property

[image]
Gizmox.WebGUI.Forms
Multiselect Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > OpenFileDialog Class : Multiselect Property

Gets or sets a value indicating whether the dialog box allows multiple files to be selected.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<SRCategoryAttribute("Behavior")>
<SRDescriptionAttribute("Controls whether multiple files can be selected in the dialog.")>
Public Property Multiselect As Boolean
Visual Basic (Usage) Copy Code
Dim instance As OpenFileDialog
Dim value As Boolean

instance.Multiselect = value

value = instance.Multiselect
C#
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Controls whether multiple files can be selected in the dialog.")]
public bool Multiselect {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Controls whether multiple files can be selected in the dialog.")]
public: __property bool get_Multiselect();
public: __property void set_Multiselect(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Controls whether multiple files can be selected in the dialog.")]
public:
property bool Multiselect {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

OpenFileDialog Class
OpenFileDialog Members


ReadOnlyChecked Property

[image]
Gizmox.WebGUI.Forms
ReadOnlyChecked Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > OpenFileDialog Class : ReadOnlyChecked Property

Gets or sets a value indicating whether the read-only check box is selected.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Behavior")>
<SRDescriptionAttribute("The state of the read-only check box in the dialog.")>
<DefaultValueAttribute()>
Public Property ReadOnlyChecked As Boolean
Visual Basic (Usage) Copy Code
Dim instance As OpenFileDialog
Dim value As Boolean

instance.ReadOnlyChecked = value

value = instance.ReadOnlyChecked
C#
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("The state of the read-only check box in the dialog.")]
[DefaultValueAttribute()]
public bool ReadOnlyChecked {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("The state of the read-only check box in the dialog.")]
[DefaultValueAttribute()]
public: __property bool get_ReadOnlyChecked();
public: __property void set_ReadOnlyChecked(
   bool value
);
C++/CLI
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("The state of the read-only check box in the dialog.")]
[DefaultValueAttribute()]
public:
property bool ReadOnlyChecked {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

OpenFileDialog Class
OpenFileDialog Members


ShowReadOnly Property

[image]
Gizmox.WebGUI.Forms
ShowReadOnly Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > OpenFileDialog Class : ShowReadOnly Property

Gets or sets a value indicating whether the dialog box contains a read-only check box.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Controls whether to show the read-only check box in the dialog.")>
<SRCategoryAttribute("Behavior")>
<DefaultValueAttribute()>
Public Property ShowReadOnly As Boolean
Visual Basic (Usage) Copy Code
Dim instance As OpenFileDialog
Dim value As Boolean

instance.ShowReadOnly = value

value = instance.ShowReadOnly
C#
[SRDescriptionAttribute("Controls whether to show the read-only check box in the dialog.")]
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
public bool ShowReadOnly {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Controls whether to show the read-only check box in the dialog.")]
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
public: __property bool get_ShowReadOnly();
public: __property void set_ShowReadOnly(
   bool value
);
C++/CLI
[SRDescriptionAttribute("Controls whether to show the read-only check box in the dialog.")]
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
public:
property bool ShowReadOnly {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

OpenFileDialog Class
OpenFileDialog Members


PagingStrip Class

[image]
Gizmox.WebGUI.Forms
PagingStrip Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : PagingStrip Class

A panel that has paging controls embeded

Object Model

Syntax

Visual Basic (Declaration)
<DesignTimeControllerAttribute()>
<ToolboxBitmapAttribute()>
<MetadataTagAttribute("PagingStrip")>
<ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")>
<ClientControllerAttribute()>
Public Class PagingStrip
   Inherits Control
   Implements IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Visual Basic (Usage) Copy Code
Dim instance As PagingStrip
C#
[DesignTimeControllerAttribute()]
[ToolboxBitmapAttribute()]
[MetadataTagAttribute("PagingStrip")]
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
[ClientControllerAttribute()]
public class PagingStrip : Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Managed Extensions for C++
[DesignTimeControllerAttribute()]
[ToolboxBitmapAttribute()]
[MetadataTagAttribute("PagingStrip")]
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
[ClientControllerAttribute()]
public __gc class PagingStrip : public Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
C++/CLI
[DesignTimeControllerAttribute()]
[ToolboxBitmapAttribute()]
[MetadataTagAttribute("PagingStrip")]
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
[ClientControllerAttribute()]
public ref class PagingStrip : public Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.PagingStrip

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

PagingStrip Members
Gizmox.WebGUI.Forms Namespace


PagingStrip Class Members

[image]
Gizmox.WebGUI.Forms
PagingStrip Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : PagingStrip Class

The following tables list the members exposed by PagingStrip.

Public Constructors

 | Name | Description
Public Constructor | PagingStrip Constructor | Creates a new PagingStrip instance.
Top

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | CurrentPage | Gets or sets the current page.
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | PagesPerView | Gets or sets the pages per view.
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Control)
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | TotalItems | Gets or sets the total items.
Public Property | TotalPages | Gets or sets the total pages.
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Overridden.
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from Control)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Control)
Protected Method | RenderAttributes | Overridden. Renders the attributes.
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | Overridden.
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | ValueChanged |
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

PagingStrip Class
Gizmox.WebGUI.Forms Namespace


PagingStrip Constructor

[image]
Gizmox.WebGUI.Forms
PagingStrip Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PagingStrip Class : PagingStrip Constructor

Creates a new PagingStrip instance.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PagingStrip()
C#
public PagingStrip()
Managed Extensions for C++
public: PagingStrip();
C++/CLI
public:
PagingStrip();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PagingStrip Class
PagingStrip Members


PagingStrip Class Methods

[image]
Gizmox.WebGUI.Forms
PagingStrip Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : PagingStrip Class

For a list of all members of this type, see PagingStrip members.

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Overridden.
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from Control)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Control)
Protected Method | RenderAttributes | Overridden. Renders the attributes.
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | Overridden.
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

See Also

Reference

PagingStrip Class
Gizmox.WebGUI.Forms Namespace


FireEvent Method

[image]
Gizmox.WebGUI.Forms
FireEvent Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PagingStrip Class : FireEvent Method

objEvent

Syntax

Visual Basic (Declaration)
Protected Overrides Sub FireEvent( _
   ByVal objEvent As IEvent _
)
Visual Basic (Usage) Copy Code
Dim instance As PagingStrip
Dim objEvent As IEvent

instance.FireEvent(objEvent)
C#
protected override void FireEvent(
   IEvent objEvent
)
Managed Extensions for C++
protected: void FireEvent(
   IEvent* objEvent
) override
C++/CLI
protected:
void FireEvent(
   IEvent^ objEvent
) override

Parameters

objEvent

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PagingStrip Class
PagingStrip Members


RenderAttributes Method

[image]
Gizmox.WebGUI.Forms
RenderAttributes Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PagingStrip Class : RenderAttributes Method

objContext
Request context.
objWriter
writer.
Renders the attributes.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub RenderAttributes( _
   ByVal objContext As IContext, _
   ByVal objWriter As IAttributeWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As PagingStrip
Dim objContext As IContext
Dim objWriter As IAttributeWriter

instance.RenderAttributes(objContext, objWriter)
C#
protected override void RenderAttributes(
   IContext objContext,
   IAttributeWriter objWriter
)
Managed Extensions for C++
protected: void RenderAttributes(
   IContext* objContext,
   IAttributeWriter* objWriter
) override
C++/CLI
protected:
void RenderAttributes(
   IContext^ objContext,
   IAttributeWriter^ objWriter
) override

Parameters

objContext
Request context.
objWriter
writer.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PagingStrip Class
PagingStrip Members


RenderUpdatedAttributes Method

[image]
Gizmox.WebGUI.Forms
RenderUpdatedAttributes Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PagingStrip Class : RenderUpdatedAttributes Method

objContext
objWriter
lngRequestID

Syntax

Visual Basic (Declaration)
Protected Overrides Sub RenderUpdatedAttributes( _
   ByVal objContext As IContext, _
   ByVal objWriter As IAttributeWriter, _
   ByVal lngRequestID As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As PagingStrip
Dim objContext As IContext
Dim objWriter As IAttributeWriter
Dim lngRequestID As Long

instance.RenderUpdatedAttributes(objContext, objWriter, lngRequestID)
C#
protected override void RenderUpdatedAttributes(
   IContext objContext,
   IAttributeWriter objWriter,
   long lngRequestID
)
Managed Extensions for C++
protected: void RenderUpdatedAttributes(
   IContext* objContext,
   IAttributeWriter* objWriter,
   long lngRequestID
) override
C++/CLI
protected:
void RenderUpdatedAttributes(
   IContext^ objContext,
   IAttributeWriter^ objWriter,
   long long lngRequestID
) override

Parameters

objContext
objWriter
lngRequestID

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PagingStrip Class
PagingStrip Members


PagingStrip Class Properties

[image]
Gizmox.WebGUI.Forms
PagingStrip Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : PagingStrip Class

For a list of all members of this type, see PagingStrip members.

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | CurrentPage | Gets or sets the current page.
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | PagesPerView | Gets or sets the pages per view.
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Control)
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | TotalItems | Gets or sets the total items.
Public Property | TotalPages | Gets or sets the total pages.
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

See Also

Reference

PagingStrip Class
Gizmox.WebGUI.Forms Namespace


CurrentPage Property

[image]
Gizmox.WebGUI.Forms
CurrentPage Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PagingStrip Class : CurrentPage Property

Gets or sets the current page.

Syntax

Visual Basic (Declaration)
Public Property CurrentPage As Integer
Visual Basic (Usage) Copy Code
Dim instance As PagingStrip
Dim value As Integer

instance.CurrentPage = value

value = instance.CurrentPage
C#
public int CurrentPage {get; set;}
Managed Extensions for C++
public: __property int get_CurrentPage();
public: __property void set_CurrentPage(
   int value
);
C++/CLI
public:
property int CurrentPage {
   int get();
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PagingStrip Class
PagingStrip Members


PagesPerView Property

[image]
Gizmox.WebGUI.Forms
PagesPerView Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PagingStrip Class : PagesPerView Property

Gets or sets the pages per view.

Syntax

Visual Basic (Declaration)
Public Property PagesPerView As Integer
Visual Basic (Usage) Copy Code
Dim instance As PagingStrip
Dim value As Integer

instance.PagesPerView = value

value = instance.PagesPerView
C#
public int PagesPerView {get; set;}
Managed Extensions for C++
public: __property int get_PagesPerView();
public: __property void set_PagesPerView(
   int value
);
C++/CLI
public:
property int PagesPerView {
   int get();
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PagingStrip Class
PagingStrip Members


TotalItems Property

[image]
Gizmox.WebGUI.Forms
TotalItems Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PagingStrip Class : TotalItems Property

Gets or sets the total items.

Syntax

Visual Basic (Declaration)
Public Property TotalItems As Integer
Visual Basic (Usage) Copy Code
Dim instance As PagingStrip
Dim value As Integer

instance.TotalItems = value

value = instance.TotalItems
C#
public int TotalItems {get; set;}
Managed Extensions for C++
public: __property int get_TotalItems();
public: __property void set_TotalItems(
   int value
);
C++/CLI
public:
property int TotalItems {
   int get();
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PagingStrip Class
PagingStrip Members


TotalPages Property

[image]
Gizmox.WebGUI.Forms
TotalPages Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PagingStrip Class : TotalPages Property

Gets or sets the total pages.

Syntax

Visual Basic (Declaration)
Public Property TotalPages As Integer
Visual Basic (Usage) Copy Code
Dim instance As PagingStrip
Dim value As Integer

instance.TotalPages = value

value = instance.TotalPages
C#
public int TotalPages {get; set;}
Managed Extensions for C++
public: __property int get_TotalPages();
public: __property void set_TotalPages(
   int value
);
C++/CLI
public:
property int TotalPages {
   int get();
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PagingStrip Class
PagingStrip Members


PagingStrip Class Events

[image]
Gizmox.WebGUI.Forms
PagingStrip Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : PagingStrip Class

For a list of all members of this type, see PagingStrip members.

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | ValueChanged |
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

PagingStrip Class
Gizmox.WebGUI.Forms Namespace


ValueChanged Event

[image]
Gizmox.WebGUI.Forms
ValueChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PagingStrip Class : ValueChanged Event

Syntax

Visual Basic (Declaration)
Public Event ValueChanged() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As PagingStrip
Dim handler As EventHandler

AddHandler instance.ValueChanged, handler
C#
public event EventHandler ValueChanged()
Managed Extensions for C++
public: __event EventHandler* ValueChanged
C++/CLI
public:
event EventHandler^ ValueChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PagingStrip Class
PagingStrip Members


PaintEventArgs Class

[image]
Gizmox.WebGUI.Forms
PaintEventArgs Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : PaintEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class PaintEventArgs
   Inherits EventArgs
Visual Basic (Usage) Copy Code
Dim instance As PaintEventArgs
C#
public class PaintEventArgs : EventArgs
Managed Extensions for C++
public __gc class PaintEventArgs : public EventArgs
C++/CLI
public ref class PaintEventArgs : public EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gizmox.WebGUI.Forms.PaintEventArgs
Gizmox.WebGUI.Forms.TableLayoutCellPaintEventArgs

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

PaintEventArgs Members
Gizmox.WebGUI.Forms Namespace


PaintEventArgs Class Members

[image]
Gizmox.WebGUI.Forms
PaintEventArgs Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : PaintEventArgs Class

The following tables list the members exposed by PaintEventArgs.

Public Constructors

 | Name | Description
Public Constructor | PaintEventArgs Constructor |
Top

Public Properties

 | Name | Description
Public Property | ClipRectangle |
Public Property | Graphics |
Top

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded.
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | Overridden.
Top

See Also

Reference

PaintEventArgs Class
Gizmox.WebGUI.Forms Namespace


PaintEventArgs Constructor

[image]
Gizmox.WebGUI.Forms
PaintEventArgs Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PaintEventArgs Class : PaintEventArgs Constructor

graphics
clipRect

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal graphics As Graphics, _
   ByVal clipRect As Rectangle _
)
Visual Basic (Usage) Copy Code
Dim graphics As Graphics
Dim clipRect As Rectangle

Dim instance As PaintEventArgs(graphics, clipRect)
C#
public PaintEventArgs(
   Graphics graphics,
   Rectangle clipRect
)
Managed Extensions for C++
public: PaintEventArgs(
   Graphics* graphics,
   Rectangle clipRect
)
C++/CLI
public:
PaintEventArgs(
   Graphics^ graphics,
   Rectangle clipRect
)

Parameters

graphics
clipRect

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PaintEventArgs Class
PaintEventArgs Members


PaintEventArgs Class Methods

[image]
Gizmox.WebGUI.Forms
PaintEventArgs Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : PaintEventArgs Class

For a list of all members of this type, see PaintEventArgs members.

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded.
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | Overridden.
Top

See Also

Reference

PaintEventArgs Class
Gizmox.WebGUI.Forms Namespace


Dispose Method

[image]
Gizmox.WebGUI.Forms
Dispose Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PaintEventArgs Class : Dispose Method

Overload List

Overload | Description
Dispose() |
Dispose(Boolean) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PaintEventArgs Class
PaintEventArgs Members


Dispose() Method

[image]
Gizmox.WebGUI.Forms
Dispose() Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PaintEventArgs Class > Dispose Method : Dispose() Method

Syntax

Visual Basic (Declaration)
Public Overloads Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As PaintEventArgs

instance.Dispose()
C#
public void Dispose()
Managed Extensions for C++
public: void Dispose();
C++/CLI
public:
void Dispose();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PaintEventArgs Class
PaintEventArgs Members
Overload List


Dispose(Boolean) Method

[image]
Gizmox.WebGUI.Forms
Dispose(Boolean) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PaintEventArgs Class > Dispose Method : Dispose(Boolean) Method

disposing

Syntax

Visual Basic (Declaration)
Protected Overloads Overridable Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As PaintEventArgs
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected virtual void Dispose(
   bool disposing
)
Managed Extensions for C++
protected: virtual void Dispose(
   bool disposing
)
C++/CLI
protected:
virtual void Dispose(
   bool disposing
)

Parameters

disposing

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PaintEventArgs Class
PaintEventArgs Members
Overload List


Finalize Method

[image]
Gizmox.WebGUI.Forms
Finalize Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PaintEventArgs Class : Finalize Method

Syntax

Visual Basic (Declaration)
Protected Overrides Sub Finalize()
Visual Basic (Usage) Copy Code
Dim instance As PaintEventArgs

instance.Finalize()
C#
protected override void Finalize()
Managed Extensions for C++
protected: void Finalize(); override
C++/CLI
protected:
void Finalize(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PaintEventArgs Class
PaintEventArgs Members


PaintEventArgs Class Properties

[image]
Gizmox.WebGUI.Forms
PaintEventArgs Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : PaintEventArgs Class

For a list of all members of this type, see PaintEventArgs members.

Public Properties

 | Name | Description
Public Property | ClipRectangle |
Public Property | Graphics |
Top

See Also

Reference

PaintEventArgs Class
Gizmox.WebGUI.Forms Namespace


ClipRectangle Property

[image]
Gizmox.WebGUI.Forms
ClipRectangle Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PaintEventArgs Class : ClipRectangle Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ClipRectangle As Rectangle
Visual Basic (Usage) Copy Code
Dim instance As PaintEventArgs
Dim value As Rectangle

value = instance.ClipRectangle
C#
public Rectangle ClipRectangle {get;}
Managed Extensions for C++
public: __property Rectangle get_ClipRectangle();
C++/CLI
public:
property Rectangle ClipRectangle {
   Rectangle get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PaintEventArgs Class
PaintEventArgs Members


Graphics Property

[image]
Gizmox.WebGUI.Forms
Graphics Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PaintEventArgs Class : Graphics Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Graphics As Graphics
Visual Basic (Usage) Copy Code
Dim instance As PaintEventArgs
Dim value As Graphics

value = instance.Graphics
C#
public Graphics Graphics {get;}
Managed Extensions for C++
public: __property Graphics* get_Graphics();
C++/CLI
public:
property Graphics^ Graphics {
   Graphics^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PaintEventArgs Class
PaintEventArgs Members


Panel Class

[image]
Gizmox.WebGUI.Forms
Panel Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : Panel Class

Represents a Panel control.

Object Model

Syntax

Visual Basic (Declaration)
<DesignTimeControllerAttribute()>
<MetadataTagAttribute("P")>
<SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableDockPanel, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")>
<ClientControllerAttribute()>
<ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<ToolboxBitmapAttribute()>
<ToolboxItemCategoryAttribute("Containers")>
Public Class Panel
   Inherits ScrollableControl
   Implements IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Visual Basic (Usage) Copy Code
Dim instance As Panel
C#
[DesignTimeControllerAttribute()]
[MetadataTagAttribute("P")]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableDockPanel, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[ClientControllerAttribute()]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ToolboxBitmapAttribute()]
[ToolboxItemCategoryAttribute("Containers")]
public class Panel : ScrollableControl, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Managed Extensions for C++
[DesignTimeControllerAttribute()]
[MetadataTagAttribute("P")]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableDockPanel, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[ClientControllerAttribute()]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ToolboxBitmapAttribute()]
[ToolboxItemCategoryAttribute("Containers")]
public __gc class Panel : public ScrollableControl, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
C++/CLI
[DesignTimeControllerAttribute()]
[MetadataTagAttribute("P")]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableDockPanel, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[ClientControllerAttribute()]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ToolboxBitmapAttribute()]
[ToolboxItemCategoryAttribute("Containers")]
public ref class Panel : public ScrollableControl, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.ScrollableControl
Gizmox.WebGUI.Forms.Panel
Gizmox.WebGUI.Forms.FlowLayoutPanel
Gizmox.WebGUI.Forms.HeaderedPanel
Gizmox.WebGUI.Forms.SplitterPanel
Gizmox.WebGUI.Forms.SurfacePanel
Gizmox.WebGUI.Forms.TabPage

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Panel Members
Gizmox.WebGUI.Forms Namespace


Panel Class Members

[image]
Gizmox.WebGUI.Forms
Panel Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : Panel Class

The following tables list the members exposed by Panel.

Public Constructors

 | Name | Description
Public Constructor | Panel Constructor | Creates a new Panel instance.
Top

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl)
Public Property | AutoSize | Overridden.
Public Property | AutoSizeMode | Indicates the automatic sizing behavior of the control.
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Overridden. Gets a value indicating whether this control can recive focus.
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Overridden. Gets or sets the text.
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Protected Property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl)
Top

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Control)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from ScrollableControl)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Control)
Protected Method | RenderAttributes | Overridden.
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | Overridden.
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializePanelType |
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

Panel Class
Gizmox.WebGUI.Forms Namespace


Panel Constructor

[image]
Gizmox.WebGUI.Forms
Panel Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Panel Class : Panel Constructor

Creates a new Panel instance.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Panel()
C#
public Panel()
Managed Extensions for C++
public: Panel();
C++/CLI
public:
Panel();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Panel Class
Panel Members


Panel Class Methods

[image]
Gizmox.WebGUI.Forms
Panel Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : Panel Class

For a list of all members of this type, see Panel members.

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Control)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from ScrollableControl)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Control)
Protected Method | RenderAttributes | Overridden.
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | Overridden.
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializePanelType |
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

See Also

Reference

Panel Class
Gizmox.WebGUI.Forms Namespace


RenderAttributes Method

[image]
Gizmox.WebGUI.Forms
RenderAttributes Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Panel Class : RenderAttributes Method

objContext
objWriter

Syntax

Visual Basic (Declaration)
Protected Overrides Sub RenderAttributes( _
   ByVal objContext As IContext, _
   ByVal objWriter As IAttributeWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As Panel
Dim objContext As IContext
Dim objWriter As IAttributeWriter

instance.RenderAttributes(objContext, objWriter)
C#
protected override void RenderAttributes(
   IContext objContext,
   IAttributeWriter objWriter
)
Managed Extensions for C++
protected: void RenderAttributes(
   IContext* objContext,
   IAttributeWriter* objWriter
) override
C++/CLI
protected:
void RenderAttributes(
   IContext^ objContext,
   IAttributeWriter^ objWriter
) override

Parameters

objContext
objWriter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Panel Class
Panel Members


RenderUpdatedAttributes Method

[image]
Gizmox.WebGUI.Forms
RenderUpdatedAttributes Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Panel Class : RenderUpdatedAttributes Method

objContext
objWriter
lngRequestID

Syntax

Visual Basic (Declaration)
Protected Overrides Sub RenderUpdatedAttributes( _
   ByVal objContext As IContext, _
   ByVal objWriter As IAttributeWriter, _
   ByVal lngRequestID As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As Panel
Dim objContext As IContext
Dim objWriter As IAttributeWriter
Dim lngRequestID As Long

instance.RenderUpdatedAttributes(objContext, objWriter, lngRequestID)
C#
protected override void RenderUpdatedAttributes(
   IContext objContext,
   IAttributeWriter objWriter,
   long lngRequestID
)
Managed Extensions for C++
protected: void RenderUpdatedAttributes(
   IContext* objContext,
   IAttributeWriter* objWriter,
   long lngRequestID
) override
C++/CLI
protected:
void RenderUpdatedAttributes(
   IContext^ objContext,
   IAttributeWriter^ objWriter,
   long long lngRequestID
) override

Parameters

objContext
objWriter
lngRequestID

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Panel Class
Panel Members


ShouldSerializePanelType Method

[image]
Gizmox.WebGUI.Forms
ShouldSerializePanelType Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Panel Class : ShouldSerializePanelType Method

Syntax

Visual Basic (Declaration)
Protected Overridable Function ShouldSerializePanelType() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Panel
Dim value As Boolean

value = instance.ShouldSerializePanelType()
C#
protected virtual bool ShouldSerializePanelType()
Managed Extensions for C++
protected: virtual bool ShouldSerializePanelType();
C++/CLI
protected:
virtual bool ShouldSerializePanelType();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Panel Class
Panel Members


Panel Class Properties

[image]
Gizmox.WebGUI.Forms
Panel Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : Panel Class

For a list of all members of this type, see Panel members.

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl)
Public Property | AutoSize | Overridden.
Public Property | AutoSizeMode | Indicates the automatic sizing behavior of the control.
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Overridden. Gets a value indicating whether this control can recive focus.
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Overridden. Gets or sets the text.
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Protected Property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl)
Top

See Also

Reference

Panel Class
Gizmox.WebGUI.Forms Namespace


AutoSize Property

[image]
Gizmox.WebGUI.Forms
AutoSize Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Panel Class : AutoSize Property

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
<EditorBrowsableAttribute()>
<BrowsableAttribute(True)>
Public Overrides Property AutoSize As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Panel
Dim value As Boolean

instance.AutoSize = value

value = instance.AutoSize
C#
[DesignerSerializationVisibilityAttribute()]
[EditorBrowsableAttribute()]
[BrowsableAttribute(true)]
public override bool AutoSize {get; set;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
[EditorBrowsableAttribute()]
[BrowsableAttribute(true)]
public: __property bool get_AutoSize() override;
public: __property void set_AutoSize(
   bool value
) override;
C++/CLI
[DesignerSerializationVisibilityAttribute()]
[EditorBrowsableAttribute()]
[BrowsableAttribute(true)]
public:
property bool AutoSize {
   bool get() override;
   void set (boolvalue) override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Panel Class
Panel Members


AutoSizeMode Property

[image]
Gizmox.WebGUI.Forms
AutoSizeMode Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Panel Class : AutoSizeMode Property

Indicates the automatic sizing behavior of the control.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(True)>
<EditorBrowsableAttribute()>
<DesignerSerializationVisibilityAttribute()>
Public Overridable Property AutoSizeMode As AutoSizeMode
Visual Basic (Usage) Copy Code
Dim instance As Panel
Dim value As AutoSizeMode

instance.AutoSizeMode = value

value = instance.AutoSizeMode
C#
[BrowsableAttribute(true)]
[EditorBrowsableAttribute()]
[DesignerSerializationVisibilityAttribute()]
public virtual AutoSizeMode AutoSizeMode {get; set;}
Managed Extensions for C++
[BrowsableAttribute(true)]
[EditorBrowsableAttribute()]
[DesignerSerializationVisibilityAttribute()]
public: __property virtual AutoSizeMode get_AutoSizeMode();
public: __property virtual void set_AutoSizeMode(
   AutoSizeMode value
);
C++/CLI
[BrowsableAttribute(true)]
[EditorBrowsableAttribute()]
[DesignerSerializationVisibilityAttribute()]
public:
virtual property AutoSizeMode AutoSizeMode {
   AutoSizeMode get();
   void set (AutoSizeModevalue);
}

Exceptions

Exception | Description
InvalidEnumArgumentException | The specified value when setting this property is not a valid AutoSizeMode values.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Panel Class
Panel Members


CanFocus Property

[image]
Gizmox.WebGUI.Forms
CanFocus Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Panel Class : CanFocus Property

Gets a value indicating whether this control can recive focus.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanFocus As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Panel
Dim value As Boolean

value = instance.CanFocus
C#
public override bool CanFocus {get;}
Managed Extensions for C++
public: __property bool get_CanFocus() override;
C++/CLI
public:
property bool CanFocus {
   bool get() override;
}

Return Value

true if this instance can focus; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Panel Class
Panel Members


Text Property

[image]
Gizmox.WebGUI.Forms
Text Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Panel Class : Text Property

Gets or sets the text.

Syntax

Visual Basic (Declaration)
Public Overrides Property Text As String
Visual Basic (Usage) Copy Code
Dim instance As Panel
Dim value As String

instance.Text = value

value = instance.Text
C#
public override string Text {get; set;}
Managed Extensions for C++
public: __property string* get_Text() override;
public: __property void set_Text(
   string* value
) override;
C++/CLI
public:
property String^ Text {
   String^ get() override;
   void set (String^value) override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Panel Class
Panel Members


PictureBox Class

[image]
Gizmox.WebGUI.Forms
PictureBox Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : PictureBox Class

A picture box control

Object Model

Syntax

Visual Basic (Declaration)
<ToolboxBitmapAttribute()>
<SRDescriptionAttribute("Displays an image.")>
<DefaultPropertyAttribute("Image")>
<SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableImageBox, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")>
<ClientControllerAttribute()>
<DefaultBindingPropertyAttribute("Image")>
<DesignTimeControllerAttribute()>
<ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<ToolboxItemCategoryAttribute("Common Controls")>
<MetadataTagAttribute("PBX")>
Public Class PictureBox
   Inherits Control
   Implements IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Visual Basic (Usage) Copy Code
Dim instance As PictureBox
C#
[ToolboxBitmapAttribute()]
[SRDescriptionAttribute("Displays an image.")]
[DefaultPropertyAttribute("Image")]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableImageBox, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[ClientControllerAttribute()]
[DefaultBindingPropertyAttribute("Image")]
[DesignTimeControllerAttribute()]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ToolboxItemCategoryAttribute("Common Controls")]
[MetadataTagAttribute("PBX")]
public class PictureBox : Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Managed Extensions for C++
[ToolboxBitmapAttribute()]
[SRDescriptionAttribute("Displays an image.")]
[DefaultPropertyAttribute("Image")]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableImageBox, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[ClientControllerAttribute()]
[DefaultBindingPropertyAttribute("Image")]
[DesignTimeControllerAttribute()]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ToolboxItemCategoryAttribute("Common Controls")]
[MetadataTagAttribute("PBX")]
public __gc class PictureBox : public Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
C++/CLI
[ToolboxBitmapAttribute()]
[SRDescriptionAttribute("Displays an image.")]
[DefaultPropertyAttribute("Image")]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableImageBox, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[ClientControllerAttribute()]
[DefaultBindingPropertyAttribute("Image")]
[DesignTimeControllerAttribute()]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ToolboxItemCategoryAttribute("Common Controls")]
[MetadataTagAttribute("PBX")]
public ref class PictureBox : public Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.PictureBox

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

PictureBox Members
Gizmox.WebGUI.Forms Namespace


PictureBox Class Members

[image]
Gizmox.WebGUI.Forms
PictureBox Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : PictureBox Class

The following tables list the members exposed by PictureBox.

Public Constructors

 | Name | Description
Public Constructor | PictureBox Constructor | Initializes a new instance of the PictureBox class.
Top

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | Image | Gets or sets the image that is displayed by PictureBox.
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | SizeMode | Indicates how the image is displayed.
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Control)
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Control)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from Control)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | Overridden. Renders the current control.
Protected Method | RenderAttributes | Renders the controls meta attributes (Inherited from Control)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

PictureBox Class
Gizmox.WebGUI.Forms Namespace


PictureBox Constructor

[image]
Gizmox.WebGUI.Forms
PictureBox Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PictureBox Class : PictureBox Constructor

Initializes a new instance of the PictureBox class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PictureBox()
C#
public PictureBox()
Managed Extensions for C++
public: PictureBox();
C++/CLI
public:
PictureBox();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PictureBox Class
PictureBox Members


PictureBox Class Methods

[image]
Gizmox.WebGUI.Forms
PictureBox Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : PictureBox Class

For a list of all members of this type, see PictureBox members.

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Control)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from Control)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | Overridden. Renders the current control.
Protected Method | RenderAttributes | Renders the controls meta attributes (Inherited from Control)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

See Also

Reference

PictureBox Class
Gizmox.WebGUI.Forms Namespace


Render Method

[image]
Gizmox.WebGUI.Forms
Render Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PictureBox Class : Render Method

objContext
Request context.
objWriter
The response writer object.
lngRequestID
Request ID.
Renders the current control.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub Render( _
   ByVal objContext As IContext, _
   ByVal objWriter As IResponseWriter, _
   ByVal lngRequestID As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As PictureBox
Dim objContext As IContext
Dim objWriter As IResponseWriter
Dim lngRequestID As Long

instance.Render(objContext, objWriter, lngRequestID)
C#
protected override void Render(
   IContext objContext,
   IResponseWriter objWriter,
   long lngRequestID
)
Managed Extensions for C++
protected: void Render(
   IContext* objContext,
   IResponseWriter* objWriter,
   long lngRequestID
) override
C++/CLI
protected:
void Render(
   IContext^ objContext,
   IResponseWriter^ objWriter,
   long long lngRequestID
) override

Parameters

objContext
Request context.
objWriter
The response writer object.
lngRequestID
Request ID.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PictureBox Class
PictureBox Members


PictureBox Class Properties

[image]
Gizmox.WebGUI.Forms
PictureBox Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : PictureBox Class

For a list of all members of this type, see PictureBox members.

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | Image | Gets or sets the image that is displayed by PictureBox.
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | SizeMode | Indicates how the image is displayed.
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Control)
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

See Also

Reference

PictureBox Class
Gizmox.WebGUI.Forms Namespace


Image Property

[image]
Gizmox.WebGUI.Forms
Image Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PictureBox Class : Image Property

Gets or sets the image that is displayed by PictureBox.

Syntax

Visual Basic (Declaration)
<LocalizableAttribute(True)>
<SRCategoryAttribute("Appearance")>
<SRDescriptionAttribute("The image displayed in the PictureBox.")>
<BindableAttribute(True)>
Public Property Image As ResourceHandle
Visual Basic (Usage) Copy Code
Dim instance As PictureBox
Dim value As ResourceHandle

instance.Image = value

value = instance.Image
C#
[LocalizableAttribute(true)]
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("The image displayed in the PictureBox.")]
[BindableAttribute(true)]
public ResourceHandle Image {get; set;}
Managed Extensions for C++
[LocalizableAttribute(true)]
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("The image displayed in the PictureBox.")]
[BindableAttribute(true)]
public: __property ResourceHandle* get_Image();
public: __property void set_Image(
   ResourceHandle* value
);
C++/CLI
[LocalizableAttribute(true)]
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("The image displayed in the PictureBox.")]
[BindableAttribute(true)]
public:
property ResourceHandle^ Image {
   ResourceHandle^ get();
   void set (ResourceHandle^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PictureBox Class
PictureBox Members


SizeMode Property

[image]
Gizmox.WebGUI.Forms
SizeMode Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PictureBox Class : SizeMode Property

Indicates how the image is displayed.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Controls how the PictureBox will handle image placement and control sizing.")>
<LocalizableAttribute(True)>
<RefreshPropertiesAttribute()>
<SRCategoryAttribute("Behavior")>
<DefaultValueAttribute()>
Public Property SizeMode As PictureBoxSizeMode
Visual Basic (Usage) Copy Code
Dim instance As PictureBox
Dim value As PictureBoxSizeMode

instance.SizeMode = value

value = instance.SizeMode
C#
[SRDescriptionAttribute("Controls how the PictureBox will handle image placement and control sizing.")]
[LocalizableAttribute(true)]
[RefreshPropertiesAttribute()]
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
public PictureBoxSizeMode SizeMode {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Controls how the PictureBox will handle image placement and control sizing.")]
[LocalizableAttribute(true)]
[RefreshPropertiesAttribute()]
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
public: __property PictureBoxSizeMode get_SizeMode();
public: __property void set_SizeMode(
   PictureBoxSizeMode value
);
C++/CLI
[SRDescriptionAttribute("Controls how the PictureBox will handle image placement and control sizing.")]
[LocalizableAttribute(true)]
[RefreshPropertiesAttribute()]
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
public:
property PictureBoxSizeMode SizeMode {
   PictureBoxSizeMode get();
   void set (PictureBoxSizeModevalue);
}

Exceptions

Exception | Description
InvalidEnumArgumentException | The value assigned is not one of the PictureBoxSizeMode values.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PictureBox Class
PictureBox Members


ProfessionalColors Class

[image]
Gizmox.WebGUI.Forms
ProfessionalColors Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ProfessionalColors Class

Provides Color structures that are colors of a Windows display element. This class cannot be inherited.

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ProfessionalColors
Visual Basic (Usage) Copy Code
Dim instance As ProfessionalColors
C#
public sealed class ProfessionalColors
Managed Extensions for C++
public __gc __sealed class ProfessionalColors
C++/CLI
public ref class ProfessionalColors sealed

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ProfessionalColors

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

ProfessionalColors Members
Gizmox.WebGUI.Forms Namespace


ProfessionalColors Class Members

[image]
Gizmox.WebGUI.Forms
ProfessionalColors Class Members
See Also Properties Send Feedback
Gizmox.WebGUI.Forms Namespace : ProfessionalColors Class

The following tables list the members exposed by ProfessionalColors.

Public Properties

 | Name | Description
static (Shared in Visual Basic) | ButtonCheckedGradientBegin | Gets the starting color of the gradient used when the button is checked.
static (Shared in Visual Basic) | ButtonCheckedGradientEnd | Gets the end color of the gradient used when the button is checked.
static (Shared in Visual Basic) | ButtonCheckedGradientMiddle | Gets the middle color of the gradient used when the button is checked.
static (Shared in Visual Basic) | ButtonCheckedHighlight | Gets the solid color used when the button is checked.
static (Shared in Visual Basic) | ButtonCheckedHighlightBorder | Gets the border color to use with ButtonCheckedHighlight.
static (Shared in Visual Basic) | ButtonPressedBorder | Gets the border color to use with the ButtonPressedGradientBegin, ButtonPressedGradientMiddle, and ButtonPressedGradientEnd colors.
static (Shared in Visual Basic) | ButtonPressedGradientBegin | Gets the starting color of the gradient used when the button is pressed down.
static (Shared in Visual Basic) | ButtonPressedGradientEnd | Gets the end color of the gradient used when the button is pressed down.
static (Shared in Visual Basic) | ButtonPressedGradientMiddle | Gets the middle color of the gradient used when the button is pressed down.
static (Shared in Visual Basic) | ButtonPressedHighlight | Gets the solid color used when the button is pressed down.
static (Shared in Visual Basic) | ButtonPressedHighlightBorder | Gets the border color to use with ButtonPressedHighlight.
static (Shared in Visual Basic) | ButtonSelectedBorder | Gets the border color to use with the ButtonSelectedGradientBegin, ButtonSelectedGradientMiddle, and ButtonSelectedGradientEnd colors.
static (Shared in Visual Basic) | ButtonSelectedGradientBegin | Gets the starting color of the gradient used when the button is selected.
static (Shared in Visual Basic) | ButtonSelectedGradientEnd | Gets the end color of the gradient used when the button is selected.
static (Shared in Visual Basic) | ButtonSelectedGradientMiddle | Gets the middle color of the gradient used when the button is selected.
static (Shared in Visual Basic) | ButtonSelectedHighlight | Gets the solid color used when the button is selected.
static (Shared in Visual Basic) | ButtonSelectedHighlightBorder | Gets the border color to use with ButtonSelectedHighlight.
static (Shared in Visual Basic) | CheckBackground | Gets the solid color to use when the check box is selected and gradients are being used.
static (Shared in Visual Basic) | CheckPressedBackground | Gets the solid color to use when the check box is selected and gradients are being used.
static (Shared in Visual Basic) | CheckSelectedBackground | Gets the solid color to use when the check box is selected and gradients are being used.
static (Shared in Visual Basic) | GripDark | Gets the color to use for shadow effects on the grip or move handle.
static (Shared in Visual Basic) | GripLight | Gets the color to use for highlight effects on the grip or move handle.
static (Shared in Visual Basic) | ImageMarginGradientBegin | Gets the starting color of the gradient used in the image margin of a ToolStripDropDownMenu.
static (Shared in Visual Basic) | ImageMarginGradientEnd | Gets the end color of the gradient used in the image margin of a ToolStripDropDownMenu.
static (Shared in Visual Basic) | ImageMarginGradientMiddle | Gets the middle color of the gradient used in the image margin of a ToolStripDropDownMenu.
static (Shared in Visual Basic) | ImageMarginRevealedGradientBegin | Gets the starting color of the gradient used in the image margin of a ToolStripDropDownMenu when an item is revealed.
static (Shared in Visual Basic) | ImageMarginRevealedGradientEnd | Gets the end color of the gradient used in the image margin of a ToolStripDropDownMenu when an item is revealed.
static (Shared in Visual Basic) | ImageMarginRevealedGradientMiddle | Gets the middle color of the gradient used in the image margin of a ToolStripDropDownMenu when an item is revealed.
static (Shared in Visual Basic) | MenuBorder | Gets the border color or a MenuStrip.
static (Shared in Visual Basic) | MenuItemBorder | Gets the border color to use with a ToolStripMenuItem.
static (Shared in Visual Basic) | MenuItemPressedGradientBegin | Gets the starting color of the gradient used when a top-level ToolStripMenuItem is pressed down.
static (Shared in Visual Basic) | MenuItemPressedGradientEnd | Gets the end color of the gradient used when a top-level ToolStripMenuItem is pressed down.
static (Shared in Visual Basic) | MenuItemPressedGradientMiddle | Gets the middle color of the gradient used when a top-level ToolStripMenuItem is pressed down.
static (Shared in Visual Basic) | MenuItemSelected | Gets the solid color to use when a ToolStripMenuItem other than the top-level ToolStripMenuItem is selected.
static (Shared in Visual Basic) | MenuItemSelectedGradientBegin | Gets the starting color of the gradient used when the ToolStripMenuItem is selected.
static (Shared in Visual Basic) | MenuItemSelectedGradientEnd | Gets the end color of the gradient used when the ToolStripMenuItem is selected.
static (Shared in Visual Basic) | MenuStripGradientBegin | Gets the starting color of the gradient used in the MenuStrip.
static (Shared in Visual Basic) | MenuStripGradientEnd | Gets the end color of the gradient used in the MenuStrip.
static (Shared in Visual Basic) | OverflowButtonGradientBegin | Gets the starting color of the gradient used in the ToolStripOverflowButton.
static (Shared in Visual Basic) | OverflowButtonGradientEnd | Gets the end color of the gradient used in the ToolStripOverflowButton.
static (Shared in Visual Basic) | OverflowButtonGradientMiddle | Gets the middle color of the gradient used in the ToolStripOverflowButton.
static (Shared in Visual Basic) | RaftingContainerGradientBegin | Gets the starting color of the gradient used in the ToolStripContainer.
static (Shared in Visual Basic) | RaftingContainerGradientEnd | Gets the end color of the gradient used in the ToolStripContainer.
static (Shared in Visual Basic) | SeparatorDark | Gets the color to use to for shadow effects on the ToolStripSeparator.
static (Shared in Visual Basic) | SeparatorLight | Gets the color to use to for highlight effects on the ToolStripSeparator.
static (Shared in Visual Basic) | StatusStripGradientBegin | Gets the starting color of the gradient used on the StatusStrip.
static (Shared in Visual Basic) | StatusStripGradientEnd | Gets the end color of the gradient used on the StatusStrip.
static (Shared in Visual Basic) | ToolStripBorder | Gets the border color to use on the bottom edge of the ToolStrip.
static (Shared in Visual Basic) | ToolStripContentPanelGradientBegin | Gets the starting color of the gradient used in the ToolStripContentPanel.
static (Shared in Visual Basic) | ToolStripContentPanelGradientEnd | Gets the end color of the gradient used in the ToolStripContentPanel.
static (Shared in Visual Basic) | ToolStripDropDownBackground | Gets the solid background color of the ToolStripDropDown.
static (Shared in Visual Basic) | ToolStripGradientBegin | Gets the starting color of the gradient used in the ToolStrip background.
static (Shared in Visual Basic) | ToolStripGradientEnd | Gets the end color of the gradient used in the ToolStrip background.
static (Shared in Visual Basic) | ToolStripGradientMiddle | Gets the middle color of the gradient used in the ToolStrip background.
static (Shared in Visual Basic) | ToolStripPanelGradientBegin | Gets the starting color of the gradient used in the ToolStripPanel.
static (Shared in Visual Basic) | ToolStripPanelGradientEnd | Gets the end color of the gradient used in the ToolStripPanel.
Top

See Also

Reference

ProfessionalColors Class
Gizmox.WebGUI.Forms Namespace


ProfessionalColors Class Properties

[image]
Gizmox.WebGUI.Forms
ProfessionalColors Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ProfessionalColors Class

For a list of all members of this type, see ProfessionalColors members.

Public Properties

 | Name | Description
static (Shared in Visual Basic) | ButtonCheckedGradientBegin | Gets the starting color of the gradient used when the button is checked.
static (Shared in Visual Basic) | ButtonCheckedGradientEnd | Gets the end color of the gradient used when the button is checked.
static (Shared in Visual Basic) | ButtonCheckedGradientMiddle | Gets the middle color of the gradient used when the button is checked.
static (Shared in Visual Basic) | ButtonCheckedHighlight | Gets the solid color used when the button is checked.
static (Shared in Visual Basic) | ButtonCheckedHighlightBorder | Gets the border color to use with ButtonCheckedHighlight.
static (Shared in Visual Basic) | ButtonPressedBorder | Gets the border color to use with the ButtonPressedGradientBegin, ButtonPressedGradientMiddle, and ButtonPressedGradientEnd colors.
static (Shared in Visual Basic) | ButtonPressedGradientBegin | Gets the starting color of the gradient used when the button is pressed down.
static (Shared in Visual Basic) | ButtonPressedGradientEnd | Gets the end color of the gradient used when the button is pressed down.
static (Shared in Visual Basic) | ButtonPressedGradientMiddle | Gets the middle color of the gradient used when the button is pressed down.
static (Shared in Visual Basic) | ButtonPressedHighlight | Gets the solid color used when the button is pressed down.
static (Shared in Visual Basic) | ButtonPressedHighlightBorder | Gets the border color to use with ButtonPressedHighlight.
static (Shared in Visual Basic) | ButtonSelectedBorder | Gets the border color to use with the ButtonSelectedGradientBegin, ButtonSelectedGradientMiddle, and ButtonSelectedGradientEnd colors.
static (Shared in Visual Basic) | ButtonSelectedGradientBegin | Gets the starting color of the gradient used when the button is selected.
static (Shared in Visual Basic) | ButtonSelectedGradientEnd | Gets the end color of the gradient used when the button is selected.
static (Shared in Visual Basic) | ButtonSelectedGradientMiddle | Gets the middle color of the gradient used when the button is selected.
static (Shared in Visual Basic) | ButtonSelectedHighlight | Gets the solid color used when the button is selected.
static (Shared in Visual Basic) | ButtonSelectedHighlightBorder | Gets the border color to use with ButtonSelectedHighlight.
static (Shared in Visual Basic) | CheckBackground | Gets the solid color to use when the check box is selected and gradients are being used.
static (Shared in Visual Basic) | CheckPressedBackground | Gets the solid color to use when the check box is selected and gradients are being used.
static (Shared in Visual Basic) | CheckSelectedBackground | Gets the solid color to use when the check box is selected and gradients are being used.
static (Shared in Visual Basic) | GripDark | Gets the color to use for shadow effects on the grip or move handle.
static (Shared in Visual Basic) | GripLight | Gets the color to use for highlight effects on the grip or move handle.
static (Shared in Visual Basic) | ImageMarginGradientBegin | Gets the starting color of the gradient used in the image margin of a ToolStripDropDownMenu.
static (Shared in Visual Basic) | ImageMarginGradientEnd | Gets the end color of the gradient used in the image margin of a ToolStripDropDownMenu.
static (Shared in Visual Basic) | ImageMarginGradientMiddle | Gets the middle color of the gradient used in the image margin of a ToolStripDropDownMenu.
static (Shared in Visual Basic) | ImageMarginRevealedGradientBegin | Gets the starting color of the gradient used in the image margin of a ToolStripDropDownMenu when an item is revealed.
static (Shared in Visual Basic) | ImageMarginRevealedGradientEnd | Gets the end color of the gradient used in the image margin of a ToolStripDropDownMenu when an item is revealed.
static (Shared in Visual Basic) | ImageMarginRevealedGradientMiddle | Gets the middle color of the gradient used in the image margin of a ToolStripDropDownMenu when an item is revealed.
static (Shared in Visual Basic) | MenuBorder | Gets the border color or a MenuStrip.
static (Shared in Visual Basic) | MenuItemBorder | Gets the border color to use with a ToolStripMenuItem.
static (Shared in Visual Basic) | MenuItemPressedGradientBegin | Gets the starting color of the gradient used when a top-level ToolStripMenuItem is pressed down.
static (Shared in Visual Basic) | MenuItemPressedGradientEnd | Gets the end color of the gradient used when a top-level ToolStripMenuItem is pressed down.
static (Shared in Visual Basic) | MenuItemPressedGradientMiddle | Gets the middle color of the gradient used when a top-level ToolStripMenuItem is pressed down.
static (Shared in Visual Basic) | MenuItemSelected | Gets the solid color to use when a ToolStripMenuItem other than the top-level ToolStripMenuItem is selected.
static (Shared in Visual Basic) | MenuItemSelectedGradientBegin | Gets the starting color of the gradient used when the ToolStripMenuItem is selected.
static (Shared in Visual Basic) | MenuItemSelectedGradientEnd | Gets the end color of the gradient used when the ToolStripMenuItem is selected.
static (Shared in Visual Basic) | MenuStripGradientBegin | Gets the starting color of the gradient used in the MenuStrip.
static (Shared in Visual Basic) | MenuStripGradientEnd | Gets the end color of the gradient used in the MenuStrip.
static (Shared in Visual Basic) | OverflowButtonGradientBegin | Gets the starting color of the gradient used in the ToolStripOverflowButton.
static (Shared in Visual Basic) | OverflowButtonGradientEnd | Gets the end color of the gradient used in the ToolStripOverflowButton.
static (Shared in Visual Basic) | OverflowButtonGradientMiddle | Gets the middle color of the gradient used in the ToolStripOverflowButton.
static (Shared in Visual Basic) | RaftingContainerGradientBegin | Gets the starting color of the gradient used in the ToolStripContainer.
static (Shared in Visual Basic) | RaftingContainerGradientEnd | Gets the end color of the gradient used in the ToolStripContainer.
static (Shared in Visual Basic) | SeparatorDark | Gets the color to use to for shadow effects on the ToolStripSeparator.
static (Shared in Visual Basic) | SeparatorLight | Gets the color to use to for highlight effects on the ToolStripSeparator.
static (Shared in Visual Basic) | StatusStripGradientBegin | Gets the starting color of the gradient used on the StatusStrip.
static (Shared in Visual Basic) | StatusStripGradientEnd | Gets the end color of the gradient used on the StatusStrip.
static (Shared in Visual Basic) | ToolStripBorder | Gets the border color to use on the bottom edge of the ToolStrip.
static (Shared in Visual Basic) | ToolStripContentPanelGradientBegin | Gets the starting color of the gradient used in the ToolStripContentPanel.
static (Shared in Visual Basic) | ToolStripContentPanelGradientEnd | Gets the end color of the gradient used in the ToolStripContentPanel.
static (Shared in Visual Basic) | ToolStripDropDownBackground | Gets the solid background color of the ToolStripDropDown.
static (Shared in Visual Basic) | ToolStripGradientBegin | Gets the starting color of the gradient used in the ToolStrip background.
static (Shared in Visual Basic) | ToolStripGradientEnd | Gets the end color of the gradient used in the ToolStrip background.
static (Shared in Visual Basic) | ToolStripGradientMiddle | Gets the middle color of the gradient used in the ToolStrip background.
static (Shared in Visual Basic) | ToolStripPanelGradientBegin | Gets the starting color of the gradient used in the ToolStripPanel.
static (Shared in Visual Basic) | ToolStripPanelGradientEnd | Gets the end color of the gradient used in the ToolStripPanel.
Top

See Also

Reference

ProfessionalColors Class
Gizmox.WebGUI.Forms Namespace


ButtonCheckedGradientBegin Property

[image]
Gizmox.WebGUI.Forms
ButtonCheckedGradientBegin Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColors Class : ButtonCheckedGradientBegin Property

Gets the starting color of the gradient used when the button is checked.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Starting color of the gradient used when the button is checked.")>
Public Shared ReadOnly Property ButtonCheckedGradientBegin As Color
Visual Basic (Usage) Copy Code
Dim value As Color

value = ProfessionalColors.ButtonCheckedGradientBegin
C#
[SRDescriptionAttribute("Starting color of the gradient used when the button is checked.")]
public static Color ButtonCheckedGradientBegin {get;}
Managed Extensions for C++
[SRDescriptionAttribute("Starting color of the gradient used when the button is checked.")]
public: __property static Color get_ButtonCheckedGradientBegin();
C++/CLI
[SRDescriptionAttribute("Starting color of the gradient used when the button is checked.")]
public:
static property Color ButtonCheckedGradientBegin {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColors Class
ProfessionalColors Members


ButtonCheckedGradientEnd Property

[image]
Gizmox.WebGUI.Forms
ButtonCheckedGradientEnd Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColors Class : ButtonCheckedGradientEnd Property

Gets the end color of the gradient used when the button is checked.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("End color of the gradient used when the button is checked.")>
Public Shared ReadOnly Property ButtonCheckedGradientEnd As Color
Visual Basic (Usage) Copy Code
Dim value As Color

value = ProfessionalColors.ButtonCheckedGradientEnd
C#
[SRDescriptionAttribute("End color of the gradient used when the button is checked.")]
public static Color ButtonCheckedGradientEnd {get;}
Managed Extensions for C++
[SRDescriptionAttribute("End color of the gradient used when the button is checked.")]
public: __property static Color get_ButtonCheckedGradientEnd();
C++/CLI
[SRDescriptionAttribute("End color of the gradient used when the button is checked.")]
public:
static property Color ButtonCheckedGradientEnd {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColors Class
ProfessionalColors Members


ButtonCheckedGradientMiddle Property

[image]
Gizmox.WebGUI.Forms
ButtonCheckedGradientMiddle Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColors Class : ButtonCheckedGradientMiddle Property

Gets the middle color of the gradient used when the button is checked.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Middle color of the gradient used when the button is checked.")>
Public Shared ReadOnly Property ButtonCheckedGradientMiddle As Color
Visual Basic (Usage) Copy Code
Dim value As Color

value = ProfessionalColors.ButtonCheckedGradientMiddle
C#
[SRDescriptionAttribute("Middle color of the gradient used when the button is checked.")]
public static Color ButtonCheckedGradientMiddle {get;}
Managed Extensions for C++
[SRDescriptionAttribute("Middle color of the gradient used when the button is checked.")]
public: __property static Color get_ButtonCheckedGradientMiddle();
C++/CLI
[SRDescriptionAttribute("Middle color of the gradient used when the button is checked.")]
public:
static property Color ButtonCheckedGradientMiddle {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColors Class
ProfessionalColors Members


ButtonCheckedHighlight Property

[image]
Gizmox.WebGUI.Forms
ButtonCheckedHighlight Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColors Class : ButtonCheckedHighlight Property

Gets the solid color used when the button is checked.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Solid color used when the button is checked.")>
Public Shared ReadOnly Property ButtonCheckedHighlight As Color
Visual Basic (Usage) Copy Code
Dim value As Color

value = ProfessionalColors.ButtonCheckedHighlight
C#
[SRDescriptionAttribute("Solid color used when the button is checked.")]
public static Color ButtonCheckedHighlight {get;}
Managed Extensions for C++
[SRDescriptionAttribute("Solid color used when the button is checked.")]
public: __property static Color get_ButtonCheckedHighlight();
C++/CLI
[SRDescriptionAttribute("Solid color used when the button is checked.")]
public:
static property Color ButtonCheckedHighlight {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColors Class
ProfessionalColors Members


ButtonCheckedHighlightBorder Property

[image]
Gizmox.WebGUI.Forms
ButtonCheckedHighlightBorder Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColors Class : ButtonCheckedHighlightBorder Property

Gets the border color to use with ButtonCheckedHighlight.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Border color to use with ButtonCheckedHighlight.")>
Public Shared ReadOnly Property ButtonCheckedHighlightBorder As Color
Visual Basic (Usage) Copy Code
Dim value As Color

value = ProfessionalColors.ButtonCheckedHighlightBorder
C#
[SRDescriptionAttribute("Border color to use with ButtonCheckedHighlight.")]
public static Color ButtonCheckedHighlightBorder {get;}
Managed Extensions for C++
[SRDescriptionAttribute("Border color to use with ButtonCheckedHighlight.")]
public: __property static Color get_ButtonCheckedHighlightBorder();
C++/CLI
[SRDescriptionAttribute("Border color to use with ButtonCheckedHighlight.")]
public:
static property Color ButtonCheckedHighlightBorder {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColors Class
ProfessionalColors Members


ButtonPressedBorder Property

[image]
Gizmox.WebGUI.Forms
ButtonPressedBorder Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColors Class : ButtonPressedBorder Property

Gets the border color to use with the ButtonPressedGradientBegin, ButtonPressedGradientMiddle, and ButtonPressedGradientEnd colors.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Border color to use with the pressed button gradient colors (ButtonPressedGradient*).")>
Public Shared ReadOnly Property ButtonPressedBorder As Color
Visual Basic (Usage) Copy Code
Dim value As Color

value = ProfessionalColors.ButtonPressedBorder
C#
[SRDescriptionAttribute("Border color to use with the pressed button gradient colors (ButtonPressedGradient*).")]
public static Color ButtonPressedBorder {get;}
Managed Extensions for C++
[SRDescriptionAttribute("Border color to use with the pressed button gradient colors (ButtonPressedGradient*).")]
public: __property static Color get_ButtonPressedBorder();
C++/CLI
[SRDescriptionAttribute("Border color to use with the pressed button gradient colors (ButtonPressedGradient*).")]
public:
static property Color ButtonPressedBorder {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColors Class
ProfessionalColors Members


ButtonPressedGradientBegin Property

[image]
Gizmox.WebGUI.Forms
ButtonPressedGradientBegin Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColors Class : ButtonPressedGradientBegin Property

Gets the starting color of the gradient used when the button is pressed down.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Starting color of the gradient used when the button is pressed.")>
Public Shared ReadOnly Property ButtonPressedGradientBegin As Color
Visual Basic (Usage) Copy Code
Dim value As Color

value = ProfessionalColors.ButtonPressedGradientBegin
C#
[SRDescriptionAttribute("Starting color of the gradient used when the button is pressed.")]
public static Color ButtonPressedGradientBegin {get;}
Managed Extensions for C++
[SRDescriptionAttribute("Starting color of the gradient used when the button is pressed.")]
public: __property static Color get_ButtonPressedGradientBegin();
C++/CLI
[SRDescriptionAttribute("Starting color of the gradient used when the button is pressed.")]
public:
static property Color ButtonPressedGradientBegin {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColors Class
ProfessionalColors Members


ButtonPressedGradientEnd Property

[image]
Gizmox.WebGUI.Forms
ButtonPressedGradientEnd Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColors Class : ButtonPressedGradientEnd Property

Gets the end color of the gradient used when the button is pressed down.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("End color of the gradient used when the button is pressed.")>
Public Shared ReadOnly Property ButtonPressedGradientEnd As Color
Visual Basic (Usage) Copy Code
Dim value As Color

value = ProfessionalColors.ButtonPressedGradientEnd
C#
[SRDescriptionAttribute("End color of the gradient used when the button is pressed.")]
public static Color ButtonPressedGradientEnd {get;}
Managed Extensions for C++
[SRDescriptionAttribute("End color of the gradient used when the button is pressed.")]
public: __property static Color get_ButtonPressedGradientEnd();
C++/CLI
[SRDescriptionAttribute("End color of the gradient used when the button is pressed.")]
public:
static property Color ButtonPressedGradientEnd {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColors Class
ProfessionalColors Members


ButtonPressedGradientMiddle Property

[image]
Gizmox.WebGUI.Forms
ButtonPressedGradientMiddle Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColors Class : ButtonPressedGradientMiddle Property

Gets the middle color of the gradient used when the button is pressed down.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Middle color of the gradient used when the button is pressed.")>
Public Shared ReadOnly Property ButtonPressedGradientMiddle As Color
Visual Basic (Usage) Copy Code
Dim value As Color

value = ProfessionalColors.ButtonPressedGradientMiddle
C#
[SRDescriptionAttribute("Middle color of the gradient used when the button is pressed.")]
public static Color ButtonPressedGradientMiddle {get;}
Managed Extensions for C++
[SRDescriptionAttribute("Middle color of the gradient used when the button is pressed.")]
public: __property static Color get_ButtonPressedGradientMiddle();
C++/CLI
[SRDescriptionAttribute("Middle color of the gradient used when the button is pressed.")]
public:
static property Color ButtonPressedGradientMiddle {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColors Class
ProfessionalColors Members


ButtonPressedHighlight Property

[image]
Gizmox.WebGUI.Forms
ButtonPressedHighlight Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColors Class : ButtonPressedHighlight Property

Gets the solid color used when the button is pressed down.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Solid color used when the button is pressed.")>
Public Shared ReadOnly Property ButtonPressedHighlight As Color
Visual Basic (Usage) Copy Code
Dim value As Color

value = ProfessionalColors.ButtonPressedHighlight
C#
[SRDescriptionAttribute("Solid color used when the button is pressed.")]
public static Color ButtonPressedHighlight {get;}
Managed Extensions for C++
[SRDescriptionAttribute("Solid color used when the button is pressed.")]
public: __property static Color get_ButtonPressedHighlight();
C++/CLI
[SRDescriptionAttribute("Solid color used when the button is pressed.")]
public:
static property Color ButtonPressedHighlight {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColors Class
ProfessionalColors Members


ButtonPressedHighlightBorder Property

[image]
Gizmox.WebGUI.Forms
ButtonPressedHighlightBorder Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColors Class : ButtonPressedHighlightBorder Property

Gets the border color to use with ButtonPressedHighlight.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Border color to use with ButtonPressedHighlight.")>
Public Shared ReadOnly Property ButtonPressedHighlightBorder As Color
Visual Basic (Usage) Copy Code
Dim value As Color

value = ProfessionalColors.ButtonPressedHighlightBorder
C#
[SRDescriptionAttribute("Border color to use with ButtonPressedHighlight.")]
public static Color ButtonPressedHighlightBorder {get;}
Managed Extensions for C++
[SRDescriptionAttribute("Border color to use with ButtonPressedHighlight.")]
public: __property static Color get_ButtonPressedHighlightBorder();
C++/CLI
[SRDescriptionAttribute("Border color to use with ButtonPressedHighlight.")]
public:
static property Color ButtonPressedHighlightBorder {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColors Class
ProfessionalColors Members


ButtonSelectedBorder Property

[image]
Gizmox.WebGUI.Forms
ButtonSelectedBorder Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColors Class : ButtonSelectedBorder Property

Gets the border color to use with the ButtonSelectedGradientBegin, ButtonSelectedGradientMiddle, and ButtonSelectedGradientEnd colors.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Border color to use with the selected button gradient colors (ButtonCheckedGradient*).")>
Public Shared ReadOnly Property ButtonSelectedBorder As Color
Visual Basic (Usage) Copy Code
Dim value As Color

value = ProfessionalColors.ButtonSelectedBorder
C#
[SRDescriptionAttribute("Border color to use with the selected button gradient colors (ButtonCheckedGradient*).")]
public static Color ButtonSelectedBorder {get;}
Managed Extensions for C++
[SRDescriptionAttribute("Border color to use with the selected button gradient colors (ButtonCheckedGradient*).")]
public: __property static Color get_ButtonSelectedBorder();
C++/CLI
[SRDescriptionAttribute("Border color to use with the selected button gradient colors (ButtonCheckedGradient*).")]
public:
static property Color ButtonSelectedBorder {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColors Class
ProfessionalColors Members


ButtonSelectedGradientBegin Property

[image]
Gizmox.WebGUI.Forms
ButtonSelectedGradientBegin Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColors Class : ButtonSelectedGradientBegin Property

Gets the starting color of the gradient used when the button is selected.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Starting color of the gradient used when the button is selected.")>
Public Shared ReadOnly Property ButtonSelectedGradientBegin As Color
Visual Basic (Usage) Copy Code
Dim value As Color

value = ProfessionalColors.ButtonSelectedGradientBegin
C#
[SRDescriptionAttribute("Starting color of the gradient used when the button is selected.")]
public static Color ButtonSelectedGradientBegin {get;}
Managed Extensions for C++
[SRDescriptionAttribute("Starting color of the gradient used when the button is selected.")]
public: __property static Color get_ButtonSelectedGradientBegin();
C++/CLI
[SRDescriptionAttribute("Starting color of the gradient used when the button is selected.")]
public:
static property Color ButtonSelectedGradientBegin {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColors Class
ProfessionalColors Members


ButtonSelectedGradientEnd Property

[image]
Gizmox.WebGUI.Forms
ButtonSelectedGradientEnd Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColors Class : ButtonSelectedGradientEnd Property

Gets the end color of the gradient used when the button is selected.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("End color of the gradient used when the button is selected.")>
Public Shared ReadOnly Property ButtonSelectedGradientEnd As Color
Visual Basic (Usage) Copy Code
Dim value As Color

value = ProfessionalColors.ButtonSelectedGradientEnd
C#
[SRDescriptionAttribute("End color of the gradient used when the button is selected.")]
public static Color ButtonSelectedGradientEnd {get;}
Managed Extensions for C++
[SRDescriptionAttribute("End color of the gradient used when the button is selected.")]
public: __property static Color get_ButtonSelectedGradientEnd();
C++/CLI
[SRDescriptionAttribute("End color of the gradient used when the button is selected.")]
public:
static property Color ButtonSelectedGradientEnd {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColors Class
ProfessionalColors Members


ButtonSelectedGradientMiddle Property

[image]
Gizmox.WebGUI.Forms
ButtonSelectedGradientMiddle Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColors Class : ButtonSelectedGradientMiddle Property

Gets the middle color of the gradient used when the button is selected.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Middle color of the gradient used when the button is selected.")>
Public Shared ReadOnly Property ButtonSelectedGradientMiddle As Color
Visual Basic (Usage) Copy Code
Dim value As Color

value = ProfessionalColors.ButtonSelectedGradientMiddle
C#
[SRDescriptionAttribute("Middle color of the gradient used when the button is selected.")]
public static Color ButtonSelectedGradientMiddle {get;}
Managed Extensions for C++
[SRDescriptionAttribute("Middle color of the gradient used when the button is selected.")]
public: __property static Color get_ButtonSelectedGradientMiddle();
C++/CLI
[SRDescriptionAttribute("Middle color of the gradient used when the button is selected.")]
public:
static property Color ButtonSelectedGradientMiddle {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColors Class
ProfessionalColors Members


ButtonSelectedHighlight Property

[image]
Gizmox.WebGUI.Forms
ButtonSelectedHighlight Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColors Class : ButtonSelectedHighlight Property

Gets the solid color used when the button is selected.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Solid color used when the button is selected.")>
Public Shared ReadOnly Property ButtonSelectedHighlight As Color
Visual Basic (Usage) Copy Code
Dim value As Color

value = ProfessionalColors.ButtonSelectedHighlight
C#
[SRDescriptionAttribute("Solid color used when the button is selected.")]
public static Color ButtonSelectedHighlight {get;}
Managed Extensions for C++
[SRDescriptionAttribute("Solid color used when the button is selected.")]
public: __property static Color get_ButtonSelectedHighlight();
C++/CLI
[SRDescriptionAttribute("Solid color used when the button is selected.")]
public:
static property Color ButtonSelectedHighlight {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColors Class
ProfessionalColors Members


ButtonSelectedHighlightBorder Property

[image]
Gizmox.WebGUI.Forms
ButtonSelectedHighlightBorder Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColors Class : ButtonSelectedHighlightBorder Property

Gets the border color to use with ButtonSelectedHighlight.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Border color to use with ButtonSelectedHighlight.")>
Public Shared ReadOnly Property ButtonSelectedHighlightBorder As Color
Visual Basic (Usage) Copy Code
Dim value As Color

value = ProfessionalColors.ButtonSelectedHighlightBorder
C#
[SRDescriptionAttribute("Border color to use with ButtonSelectedHighlight.")]
public static Color ButtonSelectedHighlightBorder {get;}
Managed Extensions for C++
[SRDescriptionAttribute("Border color to use with ButtonSelectedHighlight.")]
public: __property static Color get_ButtonSelectedHighlightBorder();
C++/CLI
[SRDescriptionAttribute("Border color to use with ButtonSelectedHighlight.")]
public:
static property Color ButtonSelectedHighlightBorder {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColors Class
ProfessionalColors Members


CheckBackground Property

[image]
Gizmox.WebGUI.Forms
CheckBackground Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColors Class : CheckBackground Property

Gets the solid color to use when the check box is selected and gradients are being used.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Solid color to use when the button is checked and gradients are being used.")>
Public Shared ReadOnly Property CheckBackground As Color
Visual Basic (Usage) Copy Code
Dim value As Color

value = ProfessionalColors.CheckBackground
C#
[SRDescriptionAttribute("Solid color to use when the button is checked and gradients are being used.")]
public static Color CheckBackground {get;}
Managed Extensions for C++
[SRDescriptionAttribute("Solid color to use when the button is checked and gradients are being used.")]
public: __property static Color get_CheckBackground();
C++/CLI
[SRDescriptionAttribute("Solid color to use when the button is checked and gradients are being used.")]
public:
static property Color CheckBackground {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColors Class
ProfessionalColors Members


CheckPressedBackground Property

[image]
Gizmox.WebGUI.Forms
CheckPressedBackground Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColors Class : CheckPressedBackground Property

Gets the solid color to use when the check box is selected and gradients are being used.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Solid color to use when the button is checked and selected and gradients are being used.")>
Public Shared ReadOnly Property CheckPressedBackground As Color
Visual Basic (Usage) Copy Code
Dim value As Color

value = ProfessionalColors.CheckPressedBackground
C#
[SRDescriptionAttribute("Solid color to use when the button is checked and selected and gradients are being used.")]
public static Color CheckPressedBackground {get;}
Managed Extensions for C++
[SRDescriptionAttribute("Solid color to use when the button is checked and selected and gradients are being used.")]
public: __property static Color get_CheckPressedBackground();
C++/CLI
[SRDescriptionAttribute("Solid color to use when the button is checked and selected and gradients are being used.")]
public:
static property Color CheckPressedBackground {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColors Class
ProfessionalColors Members


CheckSelectedBackground Property

[image]
Gizmox.WebGUI.Forms
CheckSelectedBackground Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColors Class : CheckSelectedBackground Property

Gets the solid color to use when the check box is selected and gradients are being used.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Solid color to use when the button is checked and selected and gradients are being used.")>
Public Shared ReadOnly Property CheckSelectedBackground As Color
Visual Basic (Usage) Copy Code
Dim value As Color

value = ProfessionalColors.CheckSelectedBackground
C#
[SRDescriptionAttribute("Solid color to use when the button is checked and selected and gradients are being used.")]
public static Color CheckSelectedBackground {get;}
Managed Extensions for C++
[SRDescriptionAttribute("Solid color to use when the button is checked and selected and gradients are being used.")]
public: __property static Color get_CheckSelectedBackground();
C++/CLI
[SRDescriptionAttribute("Solid color to use when the button is checked and selected and gradients are being used.")]
public:
static property Color CheckSelectedBackground {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColors Class
ProfessionalColors Members


GripDark Property

[image]
Gizmox.WebGUI.Forms
GripDark Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColors Class : GripDark Property

Gets the color to use for shadow effects on the grip or move handle.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Color to use to for shadow effects on the grip.")>
Public Shared ReadOnly Property GripDark As Color
Visual Basic (Usage) Copy Code
Dim value As Color

value = ProfessionalColors.GripDark
C#
[SRDescriptionAttribute("Color to use to for shadow effects on the grip.")]
public static Color GripDark {get;}
Managed Extensions for C++
[SRDescriptionAttribute("Color to use to for shadow effects on the grip.")]
public: __property static Color get_GripDark();
C++/CLI
[SRDescriptionAttribute("Color to use to for shadow effects on the grip.")]
public:
static property Color GripDark {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColors Class
ProfessionalColors Members


GripLight Property

[image]
Gizmox.WebGUI.Forms
GripLight Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColors Class : GripLight Property

Gets the color to use for highlight effects on the grip or move handle.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Color to use to for highlight effects on the grip.")>
Public Shared ReadOnly Property GripLight As Color
Visual Basic (Usage) Copy Code
Dim value As Color

value = ProfessionalColors.GripLight
C#
[SRDescriptionAttribute("Color to use to for highlight effects on the grip.")]
public static Color GripLight {get;}
Managed Extensions for C++
[SRDescriptionAttribute("Color to use to for highlight effects on the grip.")]
public: __property static Color get_GripLight();
C++/CLI
[SRDescriptionAttribute("Color to use to for highlight effects on the grip.")]
public:
static property Color GripLight {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColors Class
ProfessionalColors Members


ImageMarginGradientBegin Property

[image]
Gizmox.WebGUI.Forms
ImageMarginGradientBegin Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColors Class : ImageMarginGradientBegin Property

Gets the starting color of the gradient used in the image margin of a ToolStripDropDownMenu.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Starting color of the gradient used in the image margin.")>
Public Shared ReadOnly Property ImageMarginGradientBegin As Color
Visual Basic (Usage) Copy Code
Dim value As Color

value = ProfessionalColors.ImageMarginGradientBegin
C#
[SRDescriptionAttribute("Starting color of the gradient used in the image margin.")]
public static Color ImageMarginGradientBegin {get;}
Managed Extensions for C++
[SRDescriptionAttribute("Starting color of the gradient used in the image margin.")]
public: __property static Color get_ImageMarginGradientBegin();
C++/CLI
[SRDescriptionAttribute("Starting color of the gradient used in the image margin.")]
public:
static property Color ImageMarginGradientBegin {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColors Class
ProfessionalColors Members


ImageMarginGradientEnd Property

[image]
Gizmox.WebGUI.Forms
ImageMarginGradientEnd Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColors Class : ImageMarginGradientEnd Property

Gets the end color of the gradient used in the image margin of a ToolStripDropDownMenu.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("End color of the gradient used in the image margin.")>
Public Shared ReadOnly Property ImageMarginGradientEnd As Color
Visual Basic (Usage) Copy Code
Dim value As Color

value = ProfessionalColors.ImageMarginGradientEnd
C#
[SRDescriptionAttribute("End color of the gradient used in the image margin.")]
public static Color ImageMarginGradientEnd {get;}
Managed Extensions for C++
[SRDescriptionAttribute("End color of the gradient used in the image margin.")]
public: __property static Color get_ImageMarginGradientEnd();
C++/CLI
[SRDescriptionAttribute("End color of the gradient used in the image margin.")]
public:
static property Color ImageMarginGradientEnd {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColors Class
ProfessionalColors Members


ImageMarginGradientMiddle Property

[image]
Gizmox.WebGUI.Forms
ImageMarginGradientMiddle Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColors Class : ImageMarginGradientMiddle Property

Gets the middle color of the gradient used in the image margin of a ToolStripDropDownMenu.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Middle color of the gradient used in the image margin.")>
Public Shared ReadOnly Property ImageMarginGradientMiddle As Color
Visual Basic (Usage) Copy Code
Dim value As Color

value = ProfessionalColors.ImageMarginGradientMiddle
C#
[SRDescriptionAttribute("Middle color of the gradient used in the image margin.")]
public static Color ImageMarginGradientMiddle {get;}
Managed Extensions for C++
[SRDescriptionAttribute("Middle color of the gradient used in the image margin.")]
public: __property static Color get_ImageMarginGradientMiddle();
C++/CLI
[SRDescriptionAttribute("Middle color of the gradient used in the image margin.")]
public:
static property Color ImageMarginGradientMiddle {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColors Class
ProfessionalColors Members


ImageMarginRevealedGradientBegin Property

[image]
Gizmox.WebGUI.Forms
ImageMarginRevealedGradientBegin Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColors Class : ImageMarginRevealedGradientBegin Property

Gets the starting color of the gradient used in the image margin of a ToolStripDropDownMenu when an item is revealed.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Starting color of the gradient used in the image margin when an item is revealed.")>
Public Shared ReadOnly Property ImageMarginRevealedGradientBegin As Color
Visual Basic (Usage) Copy Code
Dim value As Color

value = ProfessionalColors.ImageMarginRevealedGradientBegin
C#
[SRDescriptionAttribute("Starting color of the gradient used in the image margin when an item is revealed.")]
public static Color ImageMarginRevealedGradientBegin {get;}
Managed Extensions for C++
[SRDescriptionAttribute("Starting color of the gradient used in the image margin when an item is revealed.")]
public: __property static Color get_ImageMarginRevealedGradientBegin();
C++/CLI
[SRDescriptionAttribute("Starting color of the gradient used in the image margin when an item is revealed.")]
public:
static property Color ImageMarginRevealedGradientBegin {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColors Class
ProfessionalColors Members


ImageMarginRevealedGradientEnd Property

[image]
Gizmox.WebGUI.Forms
ImageMarginRevealedGradientEnd Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColors Class : ImageMarginRevealedGradientEnd Property

Gets the end color of the gradient used in the image margin of a ToolStripDropDownMenu when an item is revealed.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("End color of the gradient used in the image margin when an item is revealed.")>
Public Shared ReadOnly Property ImageMarginRevealedGradientEnd As Color
Visual Basic (Usage) Copy Code
Dim value As Color

value = ProfessionalColors.ImageMarginRevealedGradientEnd
C#
[SRDescriptionAttribute("End color of the gradient used in the image margin when an item is revealed.")]
public static Color ImageMarginRevealedGradientEnd {get;}
Managed Extensions for C++
[SRDescriptionAttribute("End color of the gradient used in the image margin when an item is revealed.")]
public: __property static Color get_ImageMarginRevealedGradientEnd();
C++/CLI
[SRDescriptionAttribute("End color of the gradient used in the image margin when an item is revealed.")]
public:
static property Color ImageMarginRevealedGradientEnd {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColors Class
ProfessionalColors Members


ImageMarginRevealedGradientMiddle Property

[image]
Gizmox.WebGUI.Forms
ImageMarginRevealedGradientMiddle Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColors Class : ImageMarginRevealedGradientMiddle Property

Gets the middle color of the gradient used in the image margin of a ToolStripDropDownMenu when an item is revealed.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Middle color of the gradient used in the image margin when an item is revealed.")>
Public Shared ReadOnly Property ImageMarginRevealedGradientMiddle As Color
Visual Basic (Usage) Copy Code
Dim value As Color

value = ProfessionalColors.ImageMarginRevealedGradientMiddle
C#
[SRDescriptionAttribute("Middle color of the gradient used in the image margin when an item is revealed.")]
public static Color ImageMarginRevealedGradientMiddle {get;}
Managed Extensions for C++
[SRDescriptionAttribute("Middle color of the gradient used in the image margin when an item is revealed.")]
public: __property static Color get_ImageMarginRevealedGradientMiddle();
C++/CLI
[SRDescriptionAttribute("Middle color of the gradient used in the image margin when an item is revealed.")]
public:
static property Color ImageMarginRevealedGradientMiddle {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColors Class
ProfessionalColors Members


MenuBorder Property

[image]
Gizmox.WebGUI.Forms
MenuBorder Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColors Class : MenuBorder Property

Gets the border color or a MenuStrip.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("The border color to use around the edge of a drop-down menu.")>
Public Shared ReadOnly Property MenuBorder As Color
Visual Basic (Usage) Copy Code
Dim value As Color

value = ProfessionalColors.MenuBorder
C#
[SRDescriptionAttribute("The border color to use around the edge of a drop-down menu.")]
public static Color MenuBorder {get;}
Managed Extensions for C++
[SRDescriptionAttribute("The border color to use around the edge of a drop-down menu.")]
public: __property static Color get_MenuBorder();
C++/CLI
[SRDescriptionAttribute("The border color to use around the edge of a drop-down menu.")]
public:
static property Color MenuBorder {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColors Class
ProfessionalColors Members


MenuItemBorder Property

[image]
Gizmox.WebGUI.Forms
MenuItemBorder Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColors Class : MenuItemBorder Property

Gets the border color to use with a ToolStripMenuItem.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("The border color to use with MenuItem.")>
Public Shared ReadOnly Property MenuItemBorder As Color
Visual Basic (Usage) Copy Code
Dim value As Color

value = ProfessionalColors.MenuItemBorder
C#
[SRDescriptionAttribute("The border color to use with MenuItem.")]
public static Color MenuItemBorder {get;}
Managed Extensions for C++
[SRDescriptionAttribute("The border color to use with MenuItem.")]
public: __property static Color get_MenuItemBorder();
C++/CLI
[SRDescriptionAttribute("The border color to use with MenuItem.")]
public:
static property Color MenuItemBorder {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColors Class
ProfessionalColors Members


MenuItemPressedGradientBegin Property

[image]
Gizmox.WebGUI.Forms
MenuItemPressedGradientBegin Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColors Class : MenuItemPressedGradientBegin Property

Gets the starting color of the gradient used when a top-level ToolStripMenuItem is pressed down.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Starting color of the gradient used when a top level menu item is pressed.")>
Public Shared ReadOnly Property MenuItemPressedGradientBegin As Color
Visual Basic (Usage) Copy Code
Dim value As Color

value = ProfessionalColors.MenuItemPressedGradientBegin
C#
[SRDescriptionAttribute("Starting color of the gradient used when a top level menu item is pressed.")]
public static Color MenuItemPressedGradientBegin {get;}
Managed Extensions for C++
[SRDescriptionAttribute("Starting color of the gradient used when a top level menu item is pressed.")]
public: __property static Color get_MenuItemPressedGradientBegin();
C++/CLI
[SRDescriptionAttribute("Starting color of the gradient used when a top level menu item is pressed.")]
public:
static property Color MenuItemPressedGradientBegin {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColors Class
ProfessionalColors Members


MenuItemPressedGradientEnd Property

[image]
Gizmox.WebGUI.Forms
MenuItemPressedGradientEnd Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColors Class : MenuItemPressedGradientEnd Property

Gets the end color of the gradient used when a top-level ToolStripMenuItem is pressed down.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("End color of the gradient used when a top level menu item is pressed.")>
Public Shared ReadOnly Property MenuItemPressedGradientEnd As Color
Visual Basic (Usage) Copy Code
Dim value As Color

value = ProfessionalColors.MenuItemPressedGradientEnd
C#
[SRDescriptionAttribute("End color of the gradient used when a top level menu item is pressed.")]
public static Color MenuItemPressedGradientEnd {get;}
Managed Extensions for C++
[SRDescriptionAttribute("End color of the gradient used when a top level menu item is pressed.")]
public: __property static Color get_MenuItemPressedGradientEnd();
C++/CLI
[SRDescriptionAttribute("End color of the gradient used when a top level menu item is pressed.")]
public:
static property Color MenuItemPressedGradientEnd {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColors Class
ProfessionalColors Members


MenuItemPressedGradientMiddle Property

[image]
Gizmox.WebGUI.Forms
MenuItemPressedGradientMiddle Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColors Class : MenuItemPressedGradientMiddle Property

Gets the middle color of the gradient used when a top-level ToolStripMenuItem is pressed down.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Middle color of the gradient used when a top level menu item is pressed.")>
Public Shared ReadOnly Property MenuItemPressedGradientMiddle As Color
Visual Basic (Usage) Copy Code
Dim value As Color

value = ProfessionalColors.MenuItemPressedGradientMiddle
C#
[SRDescriptionAttribute("Middle color of the gradient used when a top level menu item is pressed.")]
public static Color MenuItemPressedGradientMiddle {get;}
Managed Extensions for C++
[SRDescriptionAttribute("Middle color of the gradient used when a top level menu item is pressed.")]
public: __property static Color get_MenuItemPressedGradientMiddle();
C++/CLI
[SRDescriptionAttribute("Middle color of the gradient used when a top level menu item is pressed.")]
public:
static property Color MenuItemPressedGradientMiddle {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColors Class
ProfessionalColors Members


MenuItemSelected Property

[image]
Gizmox.WebGUI.Forms
MenuItemSelected Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColors Class : MenuItemSelected Property

Gets the solid color to use when a ToolStripMenuItem other than the top-level ToolStripMenuItem is selected.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Solid color to use when a non-top level menu item is selected")>
Public Shared ReadOnly Property MenuItemSelected As Color
Visual Basic (Usage) Copy Code
Dim value As Color

value = ProfessionalColors.MenuItemSelected
C#
[SRDescriptionAttribute("Solid color to use when a non-top level menu item is selected")]
public static Color MenuItemSelected {get;}
Managed Extensions for C++
[SRDescriptionAttribute("Solid color to use when a non-top level menu item is selected")]
public: __property static Color get_MenuItemSelected();
C++/CLI
[SRDescriptionAttribute("Solid color to use when a non-top level menu item is selected")]
public:
static property Color MenuItemSelected {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColors Class
ProfessionalColors Members


MenuItemSelectedGradientBegin Property

[image]
Gizmox.WebGUI.Forms
MenuItemSelectedGradientBegin Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColors Class : MenuItemSelectedGradientBegin Property

Gets the starting color of the gradient used when the ToolStripMenuItem is selected.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Starting color of the gradient used when the menu item is selected.")>
Public Shared ReadOnly Property MenuItemSelectedGradientBegin As Color
Visual Basic (Usage) Copy Code
Dim value As Color

value = ProfessionalColors.MenuItemSelectedGradientBegin
C#
[SRDescriptionAttribute("Starting color of the gradient used when the menu item is selected.")]
public static Color MenuItemSelectedGradientBegin {get;}
Managed Extensions for C++
[SRDescriptionAttribute("Starting color of the gradient used when the menu item is selected.")]
public: __property static Color get_MenuItemSelectedGradientBegin();
C++/CLI
[SRDescriptionAttribute("Starting color of the gradient used when the menu item is selected.")]
public:
static property Color MenuItemSelectedGradientBegin {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColors Class
ProfessionalColors Members


MenuItemSelectedGradientEnd Property

[image]
Gizmox.WebGUI.Forms
MenuItemSelectedGradientEnd Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColors Class : MenuItemSelectedGradientEnd Property

Gets the end color of the gradient used when the ToolStripMenuItem is selected.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("End color of the gradient used when the menu item is selected.")>
Public Shared ReadOnly Property MenuItemSelectedGradientEnd As Color
Visual Basic (Usage) Copy Code
Dim value As Color

value = ProfessionalColors.MenuItemSelectedGradientEnd
C#
[SRDescriptionAttribute("End color of the gradient used when the menu item is selected.")]
public static Color MenuItemSelectedGradientEnd {get;}
Managed Extensions for C++
[SRDescriptionAttribute("End color of the gradient used when the menu item is selected.")]
public: __property static Color get_MenuItemSelectedGradientEnd();
C++/CLI
[SRDescriptionAttribute("End color of the gradient used when the menu item is selected.")]
public:
static property Color MenuItemSelectedGradientEnd {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColors Class
ProfessionalColors Members


MenuStripGradientBegin Property

[image]
Gizmox.WebGUI.Forms
MenuStripGradientBegin Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColors Class : MenuStripGradientBegin Property

Gets the starting color of the gradient used in the MenuStrip.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Starting color of the gradient used in the MenuStrip.")>
Public Shared ReadOnly Property MenuStripGradientBegin As Color
Visual Basic (Usage) Copy Code
Dim value As Color

value = ProfessionalColors.MenuStripGradientBegin
C#
[SRDescriptionAttribute("Starting color of the gradient used in the MenuStrip.")]
public static Color MenuStripGradientBegin {get;}
Managed Extensions for C++
[SRDescriptionAttribute("Starting color of the gradient used in the MenuStrip.")]
public: __property static Color get_MenuStripGradientBegin();
C++/CLI
[SRDescriptionAttribute("Starting color of the gradient used in the MenuStrip.")]
public:
static property Color MenuStripGradientBegin {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColors Class
ProfessionalColors Members


MenuStripGradientEnd Property

[image]
Gizmox.WebGUI.Forms
MenuStripGradientEnd Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColors Class : MenuStripGradientEnd Property

Gets the end color of the gradient used in the MenuStrip.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Middle color of the gradient used in the MenuStrip.")>
Public Shared ReadOnly Property MenuStripGradientEnd As Color
Visual Basic (Usage) Copy Code
Dim value As Color

value = ProfessionalColors.MenuStripGradientEnd
C#
[SRDescriptionAttribute("Middle color of the gradient used in the MenuStrip.")]
public static Color MenuStripGradientEnd {get;}
Managed Extensions for C++
[SRDescriptionAttribute("Middle color of the gradient used in the MenuStrip.")]
public: __property static Color get_MenuStripGradientEnd();
C++/CLI
[SRDescriptionAttribute("Middle color of the gradient used in the MenuStrip.")]
public:
static property Color MenuStripGradientEnd {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColors Class
ProfessionalColors Members


OverflowButtonGradientBegin Property

[image]
Gizmox.WebGUI.Forms
OverflowButtonGradientBegin Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColors Class : OverflowButtonGradientBegin Property

Gets the starting color of the gradient used in the ToolStripOverflowButton.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Starting color of the gradient used in the overflow button.")>
Public Shared ReadOnly Property OverflowButtonGradientBegin As Color
Visual Basic (Usage) Copy Code
Dim value As Color

value = ProfessionalColors.OverflowButtonGradientBegin
C#
[SRDescriptionAttribute("Starting color of the gradient used in the overflow button.")]
public static Color OverflowButtonGradientBegin {get;}
Managed Extensions for C++
[SRDescriptionAttribute("Starting color of the gradient used in the overflow button.")]
public: __property static Color get_OverflowButtonGradientBegin();
C++/CLI
[SRDescriptionAttribute("Starting color of the gradient used in the overflow button.")]
public:
static property Color OverflowButtonGradientBegin {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColors Class
ProfessionalColors Members


OverflowButtonGradientEnd Property

[image]
Gizmox.WebGUI.Forms
OverflowButtonGradientEnd Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColors Class : OverflowButtonGradientEnd Property

Gets the end color of the gradient used in the ToolStripOverflowButton.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("End color of the gradient used in the overflow button.")>
Public Shared ReadOnly Property OverflowButtonGradientEnd As Color
Visual Basic (Usage) Copy Code
Dim value As Color

value = ProfessionalColors.OverflowButtonGradientEnd
C#
[SRDescriptionAttribute("End color of the gradient used in the overflow button.")]
public static Color OverflowButtonGradientEnd {get;}
Managed Extensions for C++
[SRDescriptionAttribute("End color of the gradient used in the overflow button.")]
public: __property static Color get_OverflowButtonGradientEnd();
C++/CLI
[SRDescriptionAttribute("End color of the gradient used in the overflow button.")]
public:
static property Color OverflowButtonGradientEnd {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColors Class
ProfessionalColors Members


OverflowButtonGradientMiddle Property

[image]
Gizmox.WebGUI.Forms
OverflowButtonGradientMiddle Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColors Class : OverflowButtonGradientMiddle Property

Gets the middle color of the gradient used in the ToolStripOverflowButton.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Middle color of the gradient used in the overflow button.")>
Public Shared ReadOnly Property OverflowButtonGradientMiddle As Color
Visual Basic (Usage) Copy Code
Dim value As Color

value = ProfessionalColors.OverflowButtonGradientMiddle
C#
[SRDescriptionAttribute("Middle color of the gradient used in the overflow button.")]
public static Color OverflowButtonGradientMiddle {get;}
Managed Extensions for C++
[SRDescriptionAttribute("Middle color of the gradient used in the overflow button.")]
public: __property static Color get_OverflowButtonGradientMiddle();
C++/CLI
[SRDescriptionAttribute("Middle color of the gradient used in the overflow button.")]
public:
static property Color OverflowButtonGradientMiddle {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColors Class
ProfessionalColors Members


RaftingContainerGradientBegin Property

[image]
Gizmox.WebGUI.Forms
RaftingContainerGradientBegin Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColors Class : RaftingContainerGradientBegin Property

Gets the starting color of the gradient used in the ToolStripContainer.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Starting color of the gradient used in the RaftingContainer.")>
Public Shared ReadOnly Property RaftingContainerGradientBegin As Color
Visual Basic (Usage) Copy Code
Dim value As Color

value = ProfessionalColors.RaftingContainerGradientBegin
C#
[SRDescriptionAttribute("Starting color of the gradient used in the RaftingContainer.")]
public static Color RaftingContainerGradientBegin {get;}
Managed Extensions for C++
[SRDescriptionAttribute("Starting color of the gradient used in the RaftingContainer.")]
public: __property static Color get_RaftingContainerGradientBegin();
C++/CLI
[SRDescriptionAttribute("Starting color of the gradient used in the RaftingContainer.")]
public:
static property Color RaftingContainerGradientBegin {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColors Class
ProfessionalColors Members


RaftingContainerGradientEnd Property

[image]
Gizmox.WebGUI.Forms
RaftingContainerGradientEnd Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColors Class : RaftingContainerGradientEnd Property

Gets the end color of the gradient used in the ToolStripContainer.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("End color of the gradient used in the RaftingContainer.")>
Public Shared ReadOnly Property RaftingContainerGradientEnd As Color
Visual Basic (Usage) Copy Code
Dim value As Color

value = ProfessionalColors.RaftingContainerGradientEnd
C#
[SRDescriptionAttribute("End color of the gradient used in the RaftingContainer.")]
public static Color RaftingContainerGradientEnd {get;}
Managed Extensions for C++
[SRDescriptionAttribute("End color of the gradient used in the RaftingContainer.")]
public: __property static Color get_RaftingContainerGradientEnd();
C++/CLI
[SRDescriptionAttribute("End color of the gradient used in the RaftingContainer.")]
public:
static property Color RaftingContainerGradientEnd {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColors Class
ProfessionalColors Members


SeparatorDark Property

[image]
Gizmox.WebGUI.Forms
SeparatorDark Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColors Class : SeparatorDark Property

Gets the color to use to for shadow effects on the ToolStripSeparator.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Color to use to for shadow effects on the separator.")>
Public Shared ReadOnly Property SeparatorDark As Color
Visual Basic (Usage) Copy Code
Dim value As Color

value = ProfessionalColors.SeparatorDark
C#
[SRDescriptionAttribute("Color to use to for shadow effects on the separator.")]
public static Color SeparatorDark {get;}
Managed Extensions for C++
[SRDescriptionAttribute("Color to use to for shadow effects on the separator.")]
public: __property static Color get_SeparatorDark();
C++/CLI
[SRDescriptionAttribute("Color to use to for shadow effects on the separator.")]
public:
static property Color SeparatorDark {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColors Class
ProfessionalColors Members


SeparatorLight Property

[image]
Gizmox.WebGUI.Forms
SeparatorLight Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColors Class : SeparatorLight Property

Gets the color to use to for highlight effects on the ToolStripSeparator.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Color to use to for highlight effects on the separator.")>
Public Shared ReadOnly Property SeparatorLight As Color
Visual Basic (Usage) Copy Code
Dim value As Color

value = ProfessionalColors.SeparatorLight
C#
[SRDescriptionAttribute("Color to use to for highlight effects on the separator.")]
public static Color SeparatorLight {get;}
Managed Extensions for C++
[SRDescriptionAttribute("Color to use to for highlight effects on the separator.")]
public: __property static Color get_SeparatorLight();
C++/CLI
[SRDescriptionAttribute("Color to use to for highlight effects on the separator.")]
public:
static property Color SeparatorLight {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColors Class
ProfessionalColors Members


StatusStripGradientBegin Property

[image]
Gizmox.WebGUI.Forms
StatusStripGradientBegin Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColors Class : StatusStripGradientBegin Property

Gets the starting color of the gradient used on the StatusStrip.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Starting color of the gradient used in the StatusStrip.")>
Public Shared ReadOnly Property StatusStripGradientBegin As Color
Visual Basic (Usage) Copy Code
Dim value As Color

value = ProfessionalColors.StatusStripGradientBegin
C#
[SRDescriptionAttribute("Starting color of the gradient used in the StatusStrip.")]
public static Color StatusStripGradientBegin {get;}
Managed Extensions for C++
[SRDescriptionAttribute("Starting color of the gradient used in the StatusStrip.")]
public: __property static Color get_StatusStripGradientBegin();
C++/CLI
[SRDescriptionAttribute("Starting color of the gradient used in the StatusStrip.")]
public:
static property Color StatusStripGradientBegin {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColors Class
ProfessionalColors Members


StatusStripGradientEnd Property

[image]
Gizmox.WebGUI.Forms
StatusStripGradientEnd Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColors Class : StatusStripGradientEnd Property

Gets the end color of the gradient used on the StatusStrip.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("End color of the gradient used in the StatusStrip.")>
Public Shared ReadOnly Property StatusStripGradientEnd As Color
Visual Basic (Usage) Copy Code
Dim value As Color

value = ProfessionalColors.StatusStripGradientEnd
C#
[SRDescriptionAttribute("End color of the gradient used in the StatusStrip.")]
public static Color StatusStripGradientEnd {get;}
Managed Extensions for C++
[SRDescriptionAttribute("End color of the gradient used in the StatusStrip.")]
public: __property static Color get_StatusStripGradientEnd();
C++/CLI
[SRDescriptionAttribute("End color of the gradient used in the StatusStrip.")]
public:
static property Color StatusStripGradientEnd {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColors Class
ProfessionalColors Members


ToolStripBorder Property

[image]
Gizmox.WebGUI.Forms
ToolStripBorder Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColors Class : ToolStripBorder Property

Gets the border color to use on the bottom edge of the ToolStrip.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Border color to use on the bottom edge of the ToolStrip.")>
Public Shared ReadOnly Property ToolStripBorder As Color
Visual Basic (Usage) Copy Code
Dim value As Color

value = ProfessionalColors.ToolStripBorder
C#
[SRDescriptionAttribute("Border color to use on the bottom edge of the ToolStrip.")]
public static Color ToolStripBorder {get;}
Managed Extensions for C++
[SRDescriptionAttribute("Border color to use on the bottom edge of the ToolStrip.")]
public: __property static Color get_ToolStripBorder();
C++/CLI
[SRDescriptionAttribute("Border color to use on the bottom edge of the ToolStrip.")]
public:
static property Color ToolStripBorder {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColors Class
ProfessionalColors Members


ToolStripContentPanelGradientBegin Property

[image]
Gizmox.WebGUI.Forms
ToolStripContentPanelGradientBegin Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColors Class : ToolStripContentPanelGradientBegin Property

Gets the starting color of the gradient used in the ToolStripContentPanel.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Starting color of the gradient used in the ToolStripContentPanel.")>
Public Shared ReadOnly Property ToolStripContentPanelGradientBegin As Color
Visual Basic (Usage) Copy Code
Dim value As Color

value = ProfessionalColors.ToolStripContentPanelGradientBegin
C#
[SRDescriptionAttribute("Starting color of the gradient used in the ToolStripContentPanel.")]
public static Color ToolStripContentPanelGradientBegin {get;}
Managed Extensions for C++
[SRDescriptionAttribute("Starting color of the gradient used in the ToolStripContentPanel.")]
public: __property static Color get_ToolStripContentPanelGradientBegin();
C++/CLI
[SRDescriptionAttribute("Starting color of the gradient used in the ToolStripContentPanel.")]
public:
static property Color ToolStripContentPanelGradientBegin {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColors Class
ProfessionalColors Members


ToolStripContentPanelGradientEnd Property

[image]
Gizmox.WebGUI.Forms
ToolStripContentPanelGradientEnd Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColors Class : ToolStripContentPanelGradientEnd Property

Gets the end color of the gradient used in the ToolStripContentPanel.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("End color of the gradient used in the ToolStripContentPanel.")>
Public Shared ReadOnly Property ToolStripContentPanelGradientEnd As Color
Visual Basic (Usage) Copy Code
Dim value As Color

value = ProfessionalColors.ToolStripContentPanelGradientEnd
C#
[SRDescriptionAttribute("End color of the gradient used in the ToolStripContentPanel.")]
public static Color ToolStripContentPanelGradientEnd {get;}
Managed Extensions for C++
[SRDescriptionAttribute("End color of the gradient used in the ToolStripContentPanel.")]
public: __property static Color get_ToolStripContentPanelGradientEnd();
C++/CLI
[SRDescriptionAttribute("End color of the gradient used in the ToolStripContentPanel.")]
public:
static property Color ToolStripContentPanelGradientEnd {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColors Class
ProfessionalColors Members


ToolStripDropDownBackground Property

[image]
Gizmox.WebGUI.Forms
ToolStripDropDownBackground Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColors Class : ToolStripDropDownBackground Property

Gets the solid background color of the ToolStripDropDown.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Solid background color of the ToolStripDropDown.")>
Public Shared ReadOnly Property ToolStripDropDownBackground As Color
Visual Basic (Usage) Copy Code
Dim value As Color

value = ProfessionalColors.ToolStripDropDownBackground
C#
[SRDescriptionAttribute("Solid background color of the ToolStripDropDown.")]
public static Color ToolStripDropDownBackground {get;}
Managed Extensions for C++
[SRDescriptionAttribute("Solid background color of the ToolStripDropDown.")]
public: __property static Color get_ToolStripDropDownBackground();
C++/CLI
[SRDescriptionAttribute("Solid background color of the ToolStripDropDown.")]
public:
static property Color ToolStripDropDownBackground {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColors Class
ProfessionalColors Members


ToolStripGradientBegin Property

[image]
Gizmox.WebGUI.Forms
ToolStripGradientBegin Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColors Class : ToolStripGradientBegin Property

Gets the starting color of the gradient used in the ToolStrip background.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Starting color of the gradient used in the ToolStrip background.")>
Public Shared ReadOnly Property ToolStripGradientBegin As Color
Visual Basic (Usage) Copy Code
Dim value As Color

value = ProfessionalColors.ToolStripGradientBegin
C#
[SRDescriptionAttribute("Starting color of the gradient used in the ToolStrip background.")]
public static Color ToolStripGradientBegin {get;}
Managed Extensions for C++
[SRDescriptionAttribute("Starting color of the gradient used in the ToolStrip background.")]
public: __property static Color get_ToolStripGradientBegin();
C++/CLI
[SRDescriptionAttribute("Starting color of the gradient used in the ToolStrip background.")]
public:
static property Color ToolStripGradientBegin {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColors Class
ProfessionalColors Members


ToolStripGradientEnd Property

[image]
Gizmox.WebGUI.Forms
ToolStripGradientEnd Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColors Class : ToolStripGradientEnd Property

Gets the end color of the gradient used in the ToolStrip background.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("End color of the gradient used in the ToolStrip background.")>
Public Shared ReadOnly Property ToolStripGradientEnd As Color
Visual Basic (Usage) Copy Code
Dim value As Color

value = ProfessionalColors.ToolStripGradientEnd
C#
[SRDescriptionAttribute("End color of the gradient used in the ToolStrip background.")]
public static Color ToolStripGradientEnd {get;}
Managed Extensions for C++
[SRDescriptionAttribute("End color of the gradient used in the ToolStrip background.")]
public: __property static Color get_ToolStripGradientEnd();
C++/CLI
[SRDescriptionAttribute("End color of the gradient used in the ToolStrip background.")]
public:
static property Color ToolStripGradientEnd {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColors Class
ProfessionalColors Members


ToolStripGradientMiddle Property

[image]
Gizmox.WebGUI.Forms
ToolStripGradientMiddle Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColors Class : ToolStripGradientMiddle Property

Gets the middle color of the gradient used in the ToolStrip background.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Middle color of the gradient used in the ToolStrip background.")>
Public Shared ReadOnly Property ToolStripGradientMiddle As Color
Visual Basic (Usage) Copy Code
Dim value As Color

value = ProfessionalColors.ToolStripGradientMiddle
C#
[SRDescriptionAttribute("Middle color of the gradient used in the ToolStrip background.")]
public static Color ToolStripGradientMiddle {get;}
Managed Extensions for C++
[SRDescriptionAttribute("Middle color of the gradient used in the ToolStrip background.")]
public: __property static Color get_ToolStripGradientMiddle();
C++/CLI
[SRDescriptionAttribute("Middle color of the gradient used in the ToolStrip background.")]
public:
static property Color ToolStripGradientMiddle {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColors Class
ProfessionalColors Members


ToolStripPanelGradientBegin Property

[image]
Gizmox.WebGUI.Forms
ToolStripPanelGradientBegin Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColors Class : ToolStripPanelGradientBegin Property

Gets the starting color of the gradient used in the ToolStripPanel.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Starting color of the gradient used in the ToolStripPanel.")>
Public Shared ReadOnly Property ToolStripPanelGradientBegin As Color
Visual Basic (Usage) Copy Code
Dim value As Color

value = ProfessionalColors.ToolStripPanelGradientBegin
C#
[SRDescriptionAttribute("Starting color of the gradient used in the ToolStripPanel.")]
public static Color ToolStripPanelGradientBegin {get;}
Managed Extensions for C++
[SRDescriptionAttribute("Starting color of the gradient used in the ToolStripPanel.")]
public: __property static Color get_ToolStripPanelGradientBegin();
C++/CLI
[SRDescriptionAttribute("Starting color of the gradient used in the ToolStripPanel.")]
public:
static property Color ToolStripPanelGradientBegin {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColors Class
ProfessionalColors Members


ToolStripPanelGradientEnd Property

[image]
Gizmox.WebGUI.Forms
ToolStripPanelGradientEnd Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColors Class : ToolStripPanelGradientEnd Property

Gets the end color of the gradient used in the ToolStripPanel.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("End color of the gradient used in the ToolStripPanel.")>
Public Shared ReadOnly Property ToolStripPanelGradientEnd As Color
Visual Basic (Usage) Copy Code
Dim value As Color

value = ProfessionalColors.ToolStripPanelGradientEnd
C#
[SRDescriptionAttribute("End color of the gradient used in the ToolStripPanel.")]
public static Color ToolStripPanelGradientEnd {get;}
Managed Extensions for C++
[SRDescriptionAttribute("End color of the gradient used in the ToolStripPanel.")]
public: __property static Color get_ToolStripPanelGradientEnd();
C++/CLI
[SRDescriptionAttribute("End color of the gradient used in the ToolStripPanel.")]
public:
static property Color ToolStripPanelGradientEnd {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColors Class
ProfessionalColors Members


ProfessionalColorTable Class

[image]
Gizmox.WebGUI.Forms
ProfessionalColorTable Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ProfessionalColorTable Class

Provides colors used for Microsoft Office display elements.

Syntax

Visual Basic (Declaration)
Public Class ProfessionalColorTable
Visual Basic (Usage) Copy Code
Dim instance As ProfessionalColorTable
C#
public class ProfessionalColorTable
Managed Extensions for C++
public __gc class ProfessionalColorTable
C++/CLI
public ref class ProfessionalColorTable

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ProfessionalColorTable

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

ProfessionalColorTable Members
Gizmox.WebGUI.Forms Namespace


ProfessionalColorTable Class Members

[image]
Gizmox.WebGUI.Forms
ProfessionalColorTable Class Members
See Also Properties Send Feedback
Gizmox.WebGUI.Forms Namespace : ProfessionalColorTable Class

The following tables list the members exposed by ProfessionalColorTable.

Public Constructors

 | Name | Description
Public Constructor | ProfessionalColorTable Constructor |
Top

Public Properties

 | Name | Description
Public Property | ButtonCheckedGradientBegin | Gets the starting color of the gradient used when the button is checked.
Public Property | ButtonCheckedGradientEnd | Gets the end color of the gradient used when the button is checked.
Public Property | ButtonCheckedGradientMiddle | Gets the middle color of the gradient used when the button is checked.
Public Property | ButtonCheckedHighlight | Gets the solid color used when the button is checked.
Public Property | ButtonCheckedHighlightBorder | Gets the border color to use with ButtonCheckedHighlight.
Public Property | ButtonPressedBorder | Gets the border color to use with the ButtonPressedGradientBegin, ButtonPressedGradientMiddle, and ButtonPressedGradientEnd colors.
Public Property | ButtonPressedGradientBegin | Gets the starting color of the gradient used when the button is pressed.
Public Property | ButtonPressedGradientEnd | Gets the end color of the gradient used when the button is pressed.
Public Property | ButtonPressedGradientMiddle | Gets the middle color of the gradient used when the button is pressed.
Public Property | ButtonPressedHighlight | Gets the solid color used when the button is pressed.
Public Property | ButtonPressedHighlightBorder | Gets the border color to use with ButtonPressedHighlight.
Public Property | ButtonSelectedBorder | Gets the border color to use with the ButtonSelectedGradientBegin, ButtonSelectedGradientMiddle, and ButtonSelectedGradientEnd colors.
Public Property | ButtonSelectedGradientBegin | Gets the starting color of the gradient used when the button is selected.
Public Property | ButtonSelectedGradientEnd | Gets the end color of the gradient used when the button is selected.
Public Property | ButtonSelectedGradientMiddle | Gets the middle color of the gradient used when the button is selected.
Public Property | ButtonSelectedHighlight | Gets the solid color used when the button is selected.
Public Property | ButtonSelectedHighlightBorder | Gets the border color to use with ButtonSelectedHighlight.
Public Property | CheckBackground | Gets the solid color to use when the button is checked and gradients are being used.
Public Property | CheckPressedBackground | Gets the solid color to use when the button is checked and selected and gradients are being used.
Public Property | CheckSelectedBackground | Gets the solid color to use when the button is checked and selected and gradients are being used.
Public Property | GripDark | Gets the color to use for shadow effects on the grip (move handle).
Public Property | GripLight | Gets the color to use for highlight effects on the grip (move handle).
Public Property | ImageMarginGradientBegin | Gets the starting color of the gradient used in the image margin of a ToolStripDropDownMenu.
Public Property | ImageMarginGradientEnd | Gets the end color of the gradient used in the image margin of a ToolStripDropDownMenu.
Public Property | ImageMarginGradientMiddle | Gets the middle color of the gradient used in the image margin of a ToolStripDropDownMenu.
Public Property | ImageMarginRevealedGradientBegin | Gets the starting color of the gradient used in the image margin of a ToolStripDropDownMenu when an item is revealed.
Public Property | ImageMarginRevealedGradientEnd | Gets the end color of the gradient used in the image margin of a ToolStripDropDownMenu when an item is revealed.
Public Property | ImageMarginRevealedGradientMiddle | Gets the middle color of the gradient used in the image margin of a ToolStripDropDownMenu when an item is revealed.
Public Property | MenuBorder | Gets the color that is the border color to use on a MenuStrip.
Public Property | MenuItemBorder | Gets the border color to use with a ToolStripMenuItem.
Public Property | MenuItemPressedGradientBegin | Gets the starting color of the gradient used when a top-level ToolStripMenuItem is pressed.
Public Property | MenuItemPressedGradientEnd | Gets the end color of the gradient used when a top-level ToolStripMenuItem is pressed.
Public Property | MenuItemPressedGradientMiddle | Gets the middle color of the gradient used when a top-level ToolStripMenuItem is pressed.
Public Property | MenuItemSelected | Gets the solid color to use when a ToolStripMenuItem other than the top-level ToolStripMenuItem is selected.
Public Property | MenuItemSelectedGradientBegin | Gets the starting color of the gradient used when the ToolStripMenuItem is selected.
Public Property | MenuItemSelectedGradientEnd | Gets the end color of the gradient used when the ToolStripMenuItem is selected.
Public Property | MenuStripGradientBegin | Gets the starting color of the gradient used in the MenuStrip.
Public Property | MenuStripGradientEnd | Gets the end color of the gradient used in the MenuStrip.
Public Property | OverflowButtonGradientBegin | Gets the starting color of the gradient used in the ToolStripOverflowButton.
Public Property | OverflowButtonGradientEnd | Gets the end color of the gradient used in the ToolStripOverflowButton.
Public Property | OverflowButtonGradientMiddle | Gets the middle color of the gradient used in the ToolStripOverflowButton.
Public Property | RaftingContainerGradientBegin | Gets the starting color of the gradient used in the ToolStripContainer.
Public Property | RaftingContainerGradientEnd | Gets the end color of the gradient used in the ToolStripContainer.
Public Property | SeparatorDark | Gets the color to use to for shadow effects on the ToolStripSeparator.
Public Property | SeparatorLight | Gets the color to use to for highlight effects on the ToolStripSeparator.
Public Property | StatusStripGradientBegin | Gets the starting color of the gradient used on the StatusStrip.
Public Property | StatusStripGradientEnd | Gets the end color of the gradient used on the StatusStrip.
Public Property | ToolStripBorder | Gets the border color to use on the bottom edge of the ToolStrip.
Public Property | ToolStripContentPanelGradientBegin | Gets the starting color of the gradient used in the ToolStripContentPanel.
Public Property | ToolStripContentPanelGradientEnd | Gets the end color of the gradient used in the ToolStripContentPanel.
Public Property | ToolStripDropDownBackground | Gets the solid background color of the ToolStripDropDown.
Public Property | ToolStripGradientBegin | Gets the starting color of the gradient used in the ToolStrip background.
Public Property | ToolStripGradientEnd | Gets the end color of the gradient used in the ToolStrip background.
Public Property | ToolStripGradientMiddle | Gets the middle color of the gradient used in the ToolStrip background.
Public Property | ToolStripPanelGradientBegin | Gets the starting color of the gradient used in the ToolStripPanel.
Public Property | ToolStripPanelGradientEnd | Gets the end color of the gradient used in the ToolStripPanel.
Public Property | UseSystemColors | Gets or sets a value indicating whether to use SystemColors rather than colors that match the current visual style.
Top

See Also

Reference

ProfessionalColorTable Class
Gizmox.WebGUI.Forms Namespace


ProfessionalColorTable Constructor

[image]
Gizmox.WebGUI.Forms
ProfessionalColorTable Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColorTable Class : ProfessionalColorTable Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ProfessionalColorTable()
C#
public ProfessionalColorTable()
Managed Extensions for C++
public: ProfessionalColorTable();
C++/CLI
public:
ProfessionalColorTable();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColorTable Class
ProfessionalColorTable Members


ProfessionalColorTable Class Properties

[image]
Gizmox.WebGUI.Forms
ProfessionalColorTable Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ProfessionalColorTable Class

For a list of all members of this type, see ProfessionalColorTable members.

Public Properties

 | Name | Description
Public Property | ButtonCheckedGradientBegin | Gets the starting color of the gradient used when the button is checked.
Public Property | ButtonCheckedGradientEnd | Gets the end color of the gradient used when the button is checked.
Public Property | ButtonCheckedGradientMiddle | Gets the middle color of the gradient used when the button is checked.
Public Property | ButtonCheckedHighlight | Gets the solid color used when the button is checked.
Public Property | ButtonCheckedHighlightBorder | Gets the border color to use with ButtonCheckedHighlight.
Public Property | ButtonPressedBorder | Gets the border color to use with the ButtonPressedGradientBegin, ButtonPressedGradientMiddle, and ButtonPressedGradientEnd colors.
Public Property | ButtonPressedGradientBegin | Gets the starting color of the gradient used when the button is pressed.
Public Property | ButtonPressedGradientEnd | Gets the end color of the gradient used when the button is pressed.
Public Property | ButtonPressedGradientMiddle | Gets the middle color of the gradient used when the button is pressed.
Public Property | ButtonPressedHighlight | Gets the solid color used when the button is pressed.
Public Property | ButtonPressedHighlightBorder | Gets the border color to use with ButtonPressedHighlight.
Public Property | ButtonSelectedBorder | Gets the border color to use with the ButtonSelectedGradientBegin, ButtonSelectedGradientMiddle, and ButtonSelectedGradientEnd colors.
Public Property | ButtonSelectedGradientBegin | Gets the starting color of the gradient used when the button is selected.
Public Property | ButtonSelectedGradientEnd | Gets the end color of the gradient used when the button is selected.
Public Property | ButtonSelectedGradientMiddle | Gets the middle color of the gradient used when the button is selected.
Public Property | ButtonSelectedHighlight | Gets the solid color used when the button is selected.
Public Property | ButtonSelectedHighlightBorder | Gets the border color to use with ButtonSelectedHighlight.
Public Property | CheckBackground | Gets the solid color to use when the button is checked and gradients are being used.
Public Property | CheckPressedBackground | Gets the solid color to use when the button is checked and selected and gradients are being used.
Public Property | CheckSelectedBackground | Gets the solid color to use when the button is checked and selected and gradients are being used.
Public Property | GripDark | Gets the color to use for shadow effects on the grip (move handle).
Public Property | GripLight | Gets the color to use for highlight effects on the grip (move handle).
Public Property | ImageMarginGradientBegin | Gets the starting color of the gradient used in the image margin of a ToolStripDropDownMenu.
Public Property | ImageMarginGradientEnd | Gets the end color of the gradient used in the image margin of a ToolStripDropDownMenu.
Public Property | ImageMarginGradientMiddle | Gets the middle color of the gradient used in the image margin of a ToolStripDropDownMenu.
Public Property | ImageMarginRevealedGradientBegin | Gets the starting color of the gradient used in the image margin of a ToolStripDropDownMenu when an item is revealed.
Public Property | ImageMarginRevealedGradientEnd | Gets the end color of the gradient used in the image margin of a ToolStripDropDownMenu when an item is revealed.
Public Property | ImageMarginRevealedGradientMiddle | Gets the middle color of the gradient used in the image margin of a ToolStripDropDownMenu when an item is revealed.
Public Property | MenuBorder | Gets the color that is the border color to use on a MenuStrip.
Public Property | MenuItemBorder | Gets the border color to use with a ToolStripMenuItem.
Public Property | MenuItemPressedGradientBegin | Gets the starting color of the gradient used when a top-level ToolStripMenuItem is pressed.
Public Property | MenuItemPressedGradientEnd | Gets the end color of the gradient used when a top-level ToolStripMenuItem is pressed.
Public Property | MenuItemPressedGradientMiddle | Gets the middle color of the gradient used when a top-level ToolStripMenuItem is pressed.
Public Property | MenuItemSelected | Gets the solid color to use when a ToolStripMenuItem other than the top-level ToolStripMenuItem is selected.
Public Property | MenuItemSelectedGradientBegin | Gets the starting color of the gradient used when the ToolStripMenuItem is selected.
Public Property | MenuItemSelectedGradientEnd | Gets the end color of the gradient used when the ToolStripMenuItem is selected.
Public Property | MenuStripGradientBegin | Gets the starting color of the gradient used in the MenuStrip.
Public Property | MenuStripGradientEnd | Gets the end color of the gradient used in the MenuStrip.
Public Property | OverflowButtonGradientBegin | Gets the starting color of the gradient used in the ToolStripOverflowButton.
Public Property | OverflowButtonGradientEnd | Gets the end color of the gradient used in the ToolStripOverflowButton.
Public Property | OverflowButtonGradientMiddle | Gets the middle color of the gradient used in the ToolStripOverflowButton.
Public Property | RaftingContainerGradientBegin | Gets the starting color of the gradient used in the ToolStripContainer.
Public Property | RaftingContainerGradientEnd | Gets the end color of the gradient used in the ToolStripContainer.
Public Property | SeparatorDark | Gets the color to use to for shadow effects on the ToolStripSeparator.
Public Property | SeparatorLight | Gets the color to use to for highlight effects on the ToolStripSeparator.
Public Property | StatusStripGradientBegin | Gets the starting color of the gradient used on the StatusStrip.
Public Property | StatusStripGradientEnd | Gets the end color of the gradient used on the StatusStrip.
Public Property | ToolStripBorder | Gets the border color to use on the bottom edge of the ToolStrip.
Public Property | ToolStripContentPanelGradientBegin | Gets the starting color of the gradient used in the ToolStripContentPanel.
Public Property | ToolStripContentPanelGradientEnd | Gets the end color of the gradient used in the ToolStripContentPanel.
Public Property | ToolStripDropDownBackground | Gets the solid background color of the ToolStripDropDown.
Public Property | ToolStripGradientBegin | Gets the starting color of the gradient used in the ToolStrip background.
Public Property | ToolStripGradientEnd | Gets the end color of the gradient used in the ToolStrip background.
Public Property | ToolStripGradientMiddle | Gets the middle color of the gradient used in the ToolStrip background.
Public Property | ToolStripPanelGradientBegin | Gets the starting color of the gradient used in the ToolStripPanel.
Public Property | ToolStripPanelGradientEnd | Gets the end color of the gradient used in the ToolStripPanel.
Public Property | UseSystemColors | Gets or sets a value indicating whether to use SystemColors rather than colors that match the current visual style.
Top

See Also

Reference

ProfessionalColorTable Class
Gizmox.WebGUI.Forms Namespace


ButtonCheckedGradientBegin Property

[image]
Gizmox.WebGUI.Forms
ButtonCheckedGradientBegin Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColorTable Class : ButtonCheckedGradientBegin Property

Gets the starting color of the gradient used when the button is checked.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Starting color of the gradient used when the button is checked.")>
Public Overridable ReadOnly Property ButtonCheckedGradientBegin As Color
Visual Basic (Usage) Copy Code
Dim instance As ProfessionalColorTable
Dim value As Color

value = instance.ButtonCheckedGradientBegin
C#
[SRDescriptionAttribute("Starting color of the gradient used when the button is checked.")]
public virtual Color ButtonCheckedGradientBegin {get;}
Managed Extensions for C++
[SRDescriptionAttribute("Starting color of the gradient used when the button is checked.")]
public: __property virtual Color get_ButtonCheckedGradientBegin();
C++/CLI
[SRDescriptionAttribute("Starting color of the gradient used when the button is checked.")]
public:
virtual property Color ButtonCheckedGradientBegin {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColorTable Class
ProfessionalColorTable Members


ButtonCheckedGradientEnd Property

[image]
Gizmox.WebGUI.Forms
ButtonCheckedGradientEnd Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColorTable Class : ButtonCheckedGradientEnd Property

Gets the end color of the gradient used when the button is checked.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("End color of the gradient used when the button is checked.")>
Public Overridable ReadOnly Property ButtonCheckedGradientEnd As Color
Visual Basic (Usage) Copy Code
Dim instance As ProfessionalColorTable
Dim value As Color

value = instance.ButtonCheckedGradientEnd
C#
[SRDescriptionAttribute("End color of the gradient used when the button is checked.")]
public virtual Color ButtonCheckedGradientEnd {get;}
Managed Extensions for C++
[SRDescriptionAttribute("End color of the gradient used when the button is checked.")]
public: __property virtual Color get_ButtonCheckedGradientEnd();
C++/CLI
[SRDescriptionAttribute("End color of the gradient used when the button is checked.")]
public:
virtual property Color ButtonCheckedGradientEnd {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColorTable Class
ProfessionalColorTable Members


ButtonCheckedGradientMiddle Property

[image]
Gizmox.WebGUI.Forms
ButtonCheckedGradientMiddle Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColorTable Class : ButtonCheckedGradientMiddle Property

Gets the middle color of the gradient used when the button is checked.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Middle color of the gradient used when the button is checked.")>
Public Overridable ReadOnly Property ButtonCheckedGradientMiddle As Color
Visual Basic (Usage) Copy Code
Dim instance As ProfessionalColorTable
Dim value As Color

value = instance.ButtonCheckedGradientMiddle
C#
[SRDescriptionAttribute("Middle color of the gradient used when the button is checked.")]
public virtual Color ButtonCheckedGradientMiddle {get;}
Managed Extensions for C++
[SRDescriptionAttribute("Middle color of the gradient used when the button is checked.")]
public: __property virtual Color get_ButtonCheckedGradientMiddle();
C++/CLI
[SRDescriptionAttribute("Middle color of the gradient used when the button is checked.")]
public:
virtual property Color ButtonCheckedGradientMiddle {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColorTable Class
ProfessionalColorTable Members


ButtonCheckedHighlight Property

[image]
Gizmox.WebGUI.Forms
ButtonCheckedHighlight Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColorTable Class : ButtonCheckedHighlight Property

Gets the solid color used when the button is checked.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Solid color used when the button is checked.")>
Public Overridable ReadOnly Property ButtonCheckedHighlight As Color
Visual Basic (Usage) Copy Code
Dim instance As ProfessionalColorTable
Dim value As Color

value = instance.ButtonCheckedHighlight
C#
[SRDescriptionAttribute("Solid color used when the button is checked.")]
public virtual Color ButtonCheckedHighlight {get;}
Managed Extensions for C++
[SRDescriptionAttribute("Solid color used when the button is checked.")]
public: __property virtual Color get_ButtonCheckedHighlight();
C++/CLI
[SRDescriptionAttribute("Solid color used when the button is checked.")]
public:
virtual property Color ButtonCheckedHighlight {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColorTable Class
ProfessionalColorTable Members


ButtonCheckedHighlightBorder Property

[image]
Gizmox.WebGUI.Forms
ButtonCheckedHighlightBorder Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColorTable Class : ButtonCheckedHighlightBorder Property

Gets the border color to use with ButtonCheckedHighlight.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Border color to use with ButtonCheckedHighlight.")>
Public Overridable ReadOnly Property ButtonCheckedHighlightBorder As Color
Visual Basic (Usage) Copy Code
Dim instance As ProfessionalColorTable
Dim value As Color

value = instance.ButtonCheckedHighlightBorder
C#
[SRDescriptionAttribute("Border color to use with ButtonCheckedHighlight.")]
public virtual Color ButtonCheckedHighlightBorder {get;}
Managed Extensions for C++
[SRDescriptionAttribute("Border color to use with ButtonCheckedHighlight.")]
public: __property virtual Color get_ButtonCheckedHighlightBorder();
C++/CLI
[SRDescriptionAttribute("Border color to use with ButtonCheckedHighlight.")]
public:
virtual property Color ButtonCheckedHighlightBorder {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColorTable Class
ProfessionalColorTable Members


ButtonPressedBorder Property

[image]
Gizmox.WebGUI.Forms
ButtonPressedBorder Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColorTable Class : ButtonPressedBorder Property

Gets the border color to use with the ButtonPressedGradientBegin, ButtonPressedGradientMiddle, and ButtonPressedGradientEnd colors.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Border color to use with the pressed button gradient colors (ButtonPressedGradient*).")>
Public Overridable ReadOnly Property ButtonPressedBorder As Color
Visual Basic (Usage) Copy Code
Dim instance As ProfessionalColorTable
Dim value As Color

value = instance.ButtonPressedBorder
C#
[SRDescriptionAttribute("Border color to use with the pressed button gradient colors (ButtonPressedGradient*).")]
public virtual Color ButtonPressedBorder {get;}
Managed Extensions for C++
[SRDescriptionAttribute("Border color to use with the pressed button gradient colors (ButtonPressedGradient*).")]
public: __property virtual Color get_ButtonPressedBorder();
C++/CLI
[SRDescriptionAttribute("Border color to use with the pressed button gradient colors (ButtonPressedGradient*).")]
public:
virtual property Color ButtonPressedBorder {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColorTable Class
ProfessionalColorTable Members


ButtonPressedGradientBegin Property

[image]
Gizmox.WebGUI.Forms
ButtonPressedGradientBegin Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColorTable Class : ButtonPressedGradientBegin Property

Gets the starting color of the gradient used when the button is pressed.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Starting color of the gradient used when the button is pressed.")>
Public Overridable ReadOnly Property ButtonPressedGradientBegin As Color
Visual Basic (Usage) Copy Code
Dim instance As ProfessionalColorTable
Dim value As Color

value = instance.ButtonPressedGradientBegin
C#
[SRDescriptionAttribute("Starting color of the gradient used when the button is pressed.")]
public virtual Color ButtonPressedGradientBegin {get;}
Managed Extensions for C++
[SRDescriptionAttribute("Starting color of the gradient used when the button is pressed.")]
public: __property virtual Color get_ButtonPressedGradientBegin();
C++/CLI
[SRDescriptionAttribute("Starting color of the gradient used when the button is pressed.")]
public:
virtual property Color ButtonPressedGradientBegin {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColorTable Class
ProfessionalColorTable Members


ButtonPressedGradientEnd Property

[image]
Gizmox.WebGUI.Forms
ButtonPressedGradientEnd Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColorTable Class : ButtonPressedGradientEnd Property

Gets the end color of the gradient used when the button is pressed.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("End color of the gradient used when the button is pressed.")>
Public Overridable ReadOnly Property ButtonPressedGradientEnd As Color
Visual Basic (Usage) Copy Code
Dim instance As ProfessionalColorTable
Dim value As Color

value = instance.ButtonPressedGradientEnd
C#
[SRDescriptionAttribute("End color of the gradient used when the button is pressed.")]
public virtual Color ButtonPressedGradientEnd {get;}
Managed Extensions for C++
[SRDescriptionAttribute("End color of the gradient used when the button is pressed.")]
public: __property virtual Color get_ButtonPressedGradientEnd();
C++/CLI
[SRDescriptionAttribute("End color of the gradient used when the button is pressed.")]
public:
virtual property Color ButtonPressedGradientEnd {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColorTable Class
ProfessionalColorTable Members


ButtonPressedGradientMiddle Property

[image]
Gizmox.WebGUI.Forms
ButtonPressedGradientMiddle Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColorTable Class : ButtonPressedGradientMiddle Property

Gets the middle color of the gradient used when the button is pressed.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Middle color of the gradient used when the button is pressed.")>
Public Overridable ReadOnly Property ButtonPressedGradientMiddle As Color
Visual Basic (Usage) Copy Code
Dim instance As ProfessionalColorTable
Dim value As Color

value = instance.ButtonPressedGradientMiddle
C#
[SRDescriptionAttribute("Middle color of the gradient used when the button is pressed.")]
public virtual Color ButtonPressedGradientMiddle {get;}
Managed Extensions for C++
[SRDescriptionAttribute("Middle color of the gradient used when the button is pressed.")]
public: __property virtual Color get_ButtonPressedGradientMiddle();
C++/CLI
[SRDescriptionAttribute("Middle color of the gradient used when the button is pressed.")]
public:
virtual property Color ButtonPressedGradientMiddle {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColorTable Class
ProfessionalColorTable Members


ButtonPressedHighlight Property

[image]
Gizmox.WebGUI.Forms
ButtonPressedHighlight Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColorTable Class : ButtonPressedHighlight Property

Gets the solid color used when the button is pressed.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Solid color used when the button is pressed.")>
Public Overridable ReadOnly Property ButtonPressedHighlight As Color
Visual Basic (Usage) Copy Code
Dim instance As ProfessionalColorTable
Dim value As Color

value = instance.ButtonPressedHighlight
C#
[SRDescriptionAttribute("Solid color used when the button is pressed.")]
public virtual Color ButtonPressedHighlight {get;}
Managed Extensions for C++
[SRDescriptionAttribute("Solid color used when the button is pressed.")]
public: __property virtual Color get_ButtonPressedHighlight();
C++/CLI
[SRDescriptionAttribute("Solid color used when the button is pressed.")]
public:
virtual property Color ButtonPressedHighlight {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColorTable Class
ProfessionalColorTable Members


ButtonPressedHighlightBorder Property

[image]
Gizmox.WebGUI.Forms
ButtonPressedHighlightBorder Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColorTable Class : ButtonPressedHighlightBorder Property

Gets the border color to use with ButtonPressedHighlight.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Border color to use with ButtonPressedHighlight.")>
Public Overridable ReadOnly Property ButtonPressedHighlightBorder As Color
Visual Basic (Usage) Copy Code
Dim instance As ProfessionalColorTable
Dim value As Color

value = instance.ButtonPressedHighlightBorder
C#
[SRDescriptionAttribute("Border color to use with ButtonPressedHighlight.")]
public virtual Color ButtonPressedHighlightBorder {get;}
Managed Extensions for C++
[SRDescriptionAttribute("Border color to use with ButtonPressedHighlight.")]
public: __property virtual Color get_ButtonPressedHighlightBorder();
C++/CLI
[SRDescriptionAttribute("Border color to use with ButtonPressedHighlight.")]
public:
virtual property Color ButtonPressedHighlightBorder {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColorTable Class
ProfessionalColorTable Members


ButtonSelectedBorder Property

[image]
Gizmox.WebGUI.Forms
ButtonSelectedBorder Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColorTable Class : ButtonSelectedBorder Property

Gets the border color to use with the ButtonSelectedGradientBegin, ButtonSelectedGradientMiddle, and ButtonSelectedGradientEnd colors.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Border color to use with the selected button gradient colors (ButtonCheckedGradient*).")>
Public Overridable ReadOnly Property ButtonSelectedBorder As Color
Visual Basic (Usage) Copy Code
Dim instance As ProfessionalColorTable
Dim value As Color

value = instance.ButtonSelectedBorder
C#
[SRDescriptionAttribute("Border color to use with the selected button gradient colors (ButtonCheckedGradient*).")]
public virtual Color ButtonSelectedBorder {get;}
Managed Extensions for C++
[SRDescriptionAttribute("Border color to use with the selected button gradient colors (ButtonCheckedGradient*).")]
public: __property virtual Color get_ButtonSelectedBorder();
C++/CLI
[SRDescriptionAttribute("Border color to use with the selected button gradient colors (ButtonCheckedGradient*).")]
public:
virtual property Color ButtonSelectedBorder {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColorTable Class
ProfessionalColorTable Members


ButtonSelectedGradientBegin Property

[image]
Gizmox.WebGUI.Forms
ButtonSelectedGradientBegin Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColorTable Class : ButtonSelectedGradientBegin Property

Gets the starting color of the gradient used when the button is selected.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Starting color of the gradient used when the button is selected.")>
Public Overridable ReadOnly Property ButtonSelectedGradientBegin As Color
Visual Basic (Usage) Copy Code
Dim instance As ProfessionalColorTable
Dim value As Color

value = instance.ButtonSelectedGradientBegin
C#
[SRDescriptionAttribute("Starting color of the gradient used when the button is selected.")]
public virtual Color ButtonSelectedGradientBegin {get;}
Managed Extensions for C++
[SRDescriptionAttribute("Starting color of the gradient used when the button is selected.")]
public: __property virtual Color get_ButtonSelectedGradientBegin();
C++/CLI
[SRDescriptionAttribute("Starting color of the gradient used when the button is selected.")]
public:
virtual property Color ButtonSelectedGradientBegin {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColorTable Class
ProfessionalColorTable Members


ButtonSelectedGradientEnd Property

[image]
Gizmox.WebGUI.Forms
ButtonSelectedGradientEnd Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColorTable Class : ButtonSelectedGradientEnd Property

Gets the end color of the gradient used when the button is selected.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("End color of the gradient used when the button is selected.")>
Public Overridable ReadOnly Property ButtonSelectedGradientEnd As Color
Visual Basic (Usage) Copy Code
Dim instance As ProfessionalColorTable
Dim value As Color

value = instance.ButtonSelectedGradientEnd
C#
[SRDescriptionAttribute("End color of the gradient used when the button is selected.")]
public virtual Color ButtonSelectedGradientEnd {get;}
Managed Extensions for C++
[SRDescriptionAttribute("End color of the gradient used when the button is selected.")]
public: __property virtual Color get_ButtonSelectedGradientEnd();
C++/CLI
[SRDescriptionAttribute("End color of the gradient used when the button is selected.")]
public:
virtual property Color ButtonSelectedGradientEnd {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColorTable Class
ProfessionalColorTable Members


ButtonSelectedGradientMiddle Property

[image]
Gizmox.WebGUI.Forms
ButtonSelectedGradientMiddle Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColorTable Class : ButtonSelectedGradientMiddle Property

Gets the middle color of the gradient used when the button is selected.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Middle color of the gradient used when the button is selected.")>
Public Overridable ReadOnly Property ButtonSelectedGradientMiddle As Color
Visual Basic (Usage) Copy Code
Dim instance As ProfessionalColorTable
Dim value As Color

value = instance.ButtonSelectedGradientMiddle
C#
[SRDescriptionAttribute("Middle color of the gradient used when the button is selected.")]
public virtual Color ButtonSelectedGradientMiddle {get;}
Managed Extensions for C++
[SRDescriptionAttribute("Middle color of the gradient used when the button is selected.")]
public: __property virtual Color get_ButtonSelectedGradientMiddle();
C++/CLI
[SRDescriptionAttribute("Middle color of the gradient used when the button is selected.")]
public:
virtual property Color ButtonSelectedGradientMiddle {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColorTable Class
ProfessionalColorTable Members


ButtonSelectedHighlight Property

[image]
Gizmox.WebGUI.Forms
ButtonSelectedHighlight Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColorTable Class : ButtonSelectedHighlight Property

Gets the solid color used when the button is selected.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Solid color used when the button is selected.")>
Public Overridable ReadOnly Property ButtonSelectedHighlight As Color
Visual Basic (Usage) Copy Code
Dim instance As ProfessionalColorTable
Dim value As Color

value = instance.ButtonSelectedHighlight
C#
[SRDescriptionAttribute("Solid color used when the button is selected.")]
public virtual Color ButtonSelectedHighlight {get;}
Managed Extensions for C++
[SRDescriptionAttribute("Solid color used when the button is selected.")]
public: __property virtual Color get_ButtonSelectedHighlight();
C++/CLI
[SRDescriptionAttribute("Solid color used when the button is selected.")]
public:
virtual property Color ButtonSelectedHighlight {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColorTable Class
ProfessionalColorTable Members


ButtonSelectedHighlightBorder Property

[image]
Gizmox.WebGUI.Forms
ButtonSelectedHighlightBorder Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColorTable Class : ButtonSelectedHighlightBorder Property

Gets the border color to use with ButtonSelectedHighlight.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Border color to use with ButtonSelectedHighlight.")>
Public Overridable ReadOnly Property ButtonSelectedHighlightBorder As Color
Visual Basic (Usage) Copy Code
Dim instance As ProfessionalColorTable
Dim value As Color

value = instance.ButtonSelectedHighlightBorder
C#
[SRDescriptionAttribute("Border color to use with ButtonSelectedHighlight.")]
public virtual Color ButtonSelectedHighlightBorder {get;}
Managed Extensions for C++
[SRDescriptionAttribute("Border color to use with ButtonSelectedHighlight.")]
public: __property virtual Color get_ButtonSelectedHighlightBorder();
C++/CLI
[SRDescriptionAttribute("Border color to use with ButtonSelectedHighlight.")]
public:
virtual property Color ButtonSelectedHighlightBorder {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColorTable Class
ProfessionalColorTable Members


CheckBackground Property

[image]
Gizmox.WebGUI.Forms
CheckBackground Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColorTable Class : CheckBackground Property

Gets the solid color to use when the button is checked and gradients are being used.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Solid color to use when the button is checked and gradients are being used.")>
Public Overridable ReadOnly Property CheckBackground As Color
Visual Basic (Usage) Copy Code
Dim instance As ProfessionalColorTable
Dim value As Color

value = instance.CheckBackground
C#
[SRDescriptionAttribute("Solid color to use when the button is checked and gradients are being used.")]
public virtual Color CheckBackground {get;}
Managed Extensions for C++
[SRDescriptionAttribute("Solid color to use when the button is checked and gradients are being used.")]
public: __property virtual Color get_CheckBackground();
C++/CLI
[SRDescriptionAttribute("Solid color to use when the button is checked and gradients are being used.")]
public:
virtual property Color CheckBackground {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColorTable Class
ProfessionalColorTable Members


CheckPressedBackground Property

[image]
Gizmox.WebGUI.Forms
CheckPressedBackground Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColorTable Class : CheckPressedBackground Property

Gets the solid color to use when the button is checked and selected and gradients are being used.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Solid color to use when the button is checked and selected and gradients are being used.")>
Public Overridable ReadOnly Property CheckPressedBackground As Color
Visual Basic (Usage) Copy Code
Dim instance As ProfessionalColorTable
Dim value As Color

value = instance.CheckPressedBackground
C#
[SRDescriptionAttribute("Solid color to use when the button is checked and selected and gradients are being used.")]
public virtual Color CheckPressedBackground {get;}
Managed Extensions for C++
[SRDescriptionAttribute("Solid color to use when the button is checked and selected and gradients are being used.")]
public: __property virtual Color get_CheckPressedBackground();
C++/CLI
[SRDescriptionAttribute("Solid color to use when the button is checked and selected and gradients are being used.")]
public:
virtual property Color CheckPressedBackground {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColorTable Class
ProfessionalColorTable Members


CheckSelectedBackground Property

[image]
Gizmox.WebGUI.Forms
CheckSelectedBackground Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColorTable Class : CheckSelectedBackground Property

Gets the solid color to use when the button is checked and selected and gradients are being used.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Solid color to use when the button is checked and selected and gradients are being used.")>
Public Overridable ReadOnly Property CheckSelectedBackground As Color
Visual Basic (Usage) Copy Code
Dim instance As ProfessionalColorTable
Dim value As Color

value = instance.CheckSelectedBackground
C#
[SRDescriptionAttribute("Solid color to use when the button is checked and selected and gradients are being used.")]
public virtual Color CheckSelectedBackground {get;}
Managed Extensions for C++
[SRDescriptionAttribute("Solid color to use when the button is checked and selected and gradients are being used.")]
public: __property virtual Color get_CheckSelectedBackground();
C++/CLI
[SRDescriptionAttribute("Solid color to use when the button is checked and selected and gradients are being used.")]
public:
virtual property Color CheckSelectedBackground {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColorTable Class
ProfessionalColorTable Members


GripDark Property

[image]
Gizmox.WebGUI.Forms
GripDark Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColorTable Class : GripDark Property

Gets the color to use for shadow effects on the grip (move handle).

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Color to use to for shadow effects on the grip.")>
Public Overridable ReadOnly Property GripDark As Color
Visual Basic (Usage) Copy Code
Dim instance As ProfessionalColorTable
Dim value As Color

value = instance.GripDark
C#
[SRDescriptionAttribute("Color to use to for shadow effects on the grip.")]
public virtual Color GripDark {get;}
Managed Extensions for C++
[SRDescriptionAttribute("Color to use to for shadow effects on the grip.")]
public: __property virtual Color get_GripDark();
C++/CLI
[SRDescriptionAttribute("Color to use to for shadow effects on the grip.")]
public:
virtual property Color GripDark {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColorTable Class
ProfessionalColorTable Members


GripLight Property

[image]
Gizmox.WebGUI.Forms
GripLight Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColorTable Class : GripLight Property

Gets the color to use for highlight effects on the grip (move handle).

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Color to use to for highlight effects on the grip.")>
Public Overridable ReadOnly Property GripLight As Color
Visual Basic (Usage) Copy Code
Dim instance As ProfessionalColorTable
Dim value As Color

value = instance.GripLight
C#
[SRDescriptionAttribute("Color to use to for highlight effects on the grip.")]
public virtual Color GripLight {get;}
Managed Extensions for C++
[SRDescriptionAttribute("Color to use to for highlight effects on the grip.")]
public: __property virtual Color get_GripLight();
C++/CLI
[SRDescriptionAttribute("Color to use to for highlight effects on the grip.")]
public:
virtual property Color GripLight {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColorTable Class
ProfessionalColorTable Members


ImageMarginGradientBegin Property

[image]
Gizmox.WebGUI.Forms
ImageMarginGradientBegin Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColorTable Class : ImageMarginGradientBegin Property

Gets the starting color of the gradient used in the image margin of a ToolStripDropDownMenu.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Starting color of the gradient used in the image margin.")>
Public Overridable ReadOnly Property ImageMarginGradientBegin As Color
Visual Basic (Usage) Copy Code
Dim instance As ProfessionalColorTable
Dim value As Color

value = instance.ImageMarginGradientBegin
C#
[SRDescriptionAttribute("Starting color of the gradient used in the image margin.")]
public virtual Color ImageMarginGradientBegin {get;}
Managed Extensions for C++
[SRDescriptionAttribute("Starting color of the gradient used in the image margin.")]
public: __property virtual Color get_ImageMarginGradientBegin();
C++/CLI
[SRDescriptionAttribute("Starting color of the gradient used in the image margin.")]
public:
virtual property Color ImageMarginGradientBegin {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColorTable Class
ProfessionalColorTable Members


ImageMarginGradientEnd Property

[image]
Gizmox.WebGUI.Forms
ImageMarginGradientEnd Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColorTable Class : ImageMarginGradientEnd Property

Gets the end color of the gradient used in the image margin of a ToolStripDropDownMenu.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("End color of the gradient used in the image margin.")>
Public Overridable ReadOnly Property ImageMarginGradientEnd As Color
Visual Basic (Usage) Copy Code
Dim instance As ProfessionalColorTable
Dim value As Color

value = instance.ImageMarginGradientEnd
C#
[SRDescriptionAttribute("End color of the gradient used in the image margin.")]
public virtual Color ImageMarginGradientEnd {get;}
Managed Extensions for C++
[SRDescriptionAttribute("End color of the gradient used in the image margin.")]
public: __property virtual Color get_ImageMarginGradientEnd();
C++/CLI
[SRDescriptionAttribute("End color of the gradient used in the image margin.")]
public:
virtual property Color ImageMarginGradientEnd {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColorTable Class
ProfessionalColorTable Members


ImageMarginGradientMiddle Property

[image]
Gizmox.WebGUI.Forms
ImageMarginGradientMiddle Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColorTable Class : ImageMarginGradientMiddle Property

Gets the middle color of the gradient used in the image margin of a ToolStripDropDownMenu.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Middle color of the gradient used in the image margin.")>
Public Overridable ReadOnly Property ImageMarginGradientMiddle As Color
Visual Basic (Usage) Copy Code
Dim instance As ProfessionalColorTable
Dim value As Color

value = instance.ImageMarginGradientMiddle
C#
[SRDescriptionAttribute("Middle color of the gradient used in the image margin.")]
public virtual Color ImageMarginGradientMiddle {get;}
Managed Extensions for C++
[SRDescriptionAttribute("Middle color of the gradient used in the image margin.")]
public: __property virtual Color get_ImageMarginGradientMiddle();
C++/CLI
[SRDescriptionAttribute("Middle color of the gradient used in the image margin.")]
public:
virtual property Color ImageMarginGradientMiddle {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColorTable Class
ProfessionalColorTable Members


ImageMarginRevealedGradientBegin Property

[image]
Gizmox.WebGUI.Forms
ImageMarginRevealedGradientBegin Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColorTable Class : ImageMarginRevealedGradientBegin Property

Gets the starting color of the gradient used in the image margin of a ToolStripDropDownMenu when an item is revealed.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Starting color of the gradient used in the image margin when an item is revealed.")>
Public Overridable ReadOnly Property ImageMarginRevealedGradientBegin As Color
Visual Basic (Usage) Copy Code
Dim instance As ProfessionalColorTable
Dim value As Color

value = instance.ImageMarginRevealedGradientBegin
C#
[SRDescriptionAttribute("Starting color of the gradient used in the image margin when an item is revealed.")]
public virtual Color ImageMarginRevealedGradientBegin {get;}
Managed Extensions for C++
[SRDescriptionAttribute("Starting color of the gradient used in the image margin when an item is revealed.")]
public: __property virtual Color get_ImageMarginRevealedGradientBegin();
C++/CLI
[SRDescriptionAttribute("Starting color of the gradient used in the image margin when an item is revealed.")]
public:
virtual property Color ImageMarginRevealedGradientBegin {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColorTable Class
ProfessionalColorTable Members


ImageMarginRevealedGradientEnd Property

[image]
Gizmox.WebGUI.Forms
ImageMarginRevealedGradientEnd Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColorTable Class : ImageMarginRevealedGradientEnd Property

Gets the end color of the gradient used in the image margin of a ToolStripDropDownMenu when an item is revealed.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("End color of the gradient used in the image margin when an item is revealed.")>
Public Overridable ReadOnly Property ImageMarginRevealedGradientEnd As Color
Visual Basic (Usage) Copy Code
Dim instance As ProfessionalColorTable
Dim value As Color

value = instance.ImageMarginRevealedGradientEnd
C#
[SRDescriptionAttribute("End color of the gradient used in the image margin when an item is revealed.")]
public virtual Color ImageMarginRevealedGradientEnd {get;}
Managed Extensions for C++
[SRDescriptionAttribute("End color of the gradient used in the image margin when an item is revealed.")]
public: __property virtual Color get_ImageMarginRevealedGradientEnd();
C++/CLI
[SRDescriptionAttribute("End color of the gradient used in the image margin when an item is revealed.")]
public:
virtual property Color ImageMarginRevealedGradientEnd {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColorTable Class
ProfessionalColorTable Members


ImageMarginRevealedGradientMiddle Property

[image]
Gizmox.WebGUI.Forms
ImageMarginRevealedGradientMiddle Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColorTable Class : ImageMarginRevealedGradientMiddle Property

Gets the middle color of the gradient used in the image margin of a ToolStripDropDownMenu when an item is revealed.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Middle color of the gradient used in the image margin when an item is revealed.")>
Public Overridable ReadOnly Property ImageMarginRevealedGradientMiddle As Color
Visual Basic (Usage) Copy Code
Dim instance As ProfessionalColorTable
Dim value As Color

value = instance.ImageMarginRevealedGradientMiddle
C#
[SRDescriptionAttribute("Middle color of the gradient used in the image margin when an item is revealed.")]
public virtual Color ImageMarginRevealedGradientMiddle {get;}
Managed Extensions for C++
[SRDescriptionAttribute("Middle color of the gradient used in the image margin when an item is revealed.")]
public: __property virtual Color get_ImageMarginRevealedGradientMiddle();
C++/CLI
[SRDescriptionAttribute("Middle color of the gradient used in the image margin when an item is revealed.")]
public:
virtual property Color ImageMarginRevealedGradientMiddle {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColorTable Class
ProfessionalColorTable Members


MenuBorder Property

[image]
Gizmox.WebGUI.Forms
MenuBorder Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColorTable Class : MenuBorder Property

Gets the color that is the border color to use on a MenuStrip.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("The border color to use around the edge of a drop-down menu.")>
Public Overridable ReadOnly Property MenuBorder As Color
Visual Basic (Usage) Copy Code
Dim instance As ProfessionalColorTable
Dim value As Color

value = instance.MenuBorder
C#
[SRDescriptionAttribute("The border color to use around the edge of a drop-down menu.")]
public virtual Color MenuBorder {get;}
Managed Extensions for C++
[SRDescriptionAttribute("The border color to use around the edge of a drop-down menu.")]
public: __property virtual Color get_MenuBorder();
C++/CLI
[SRDescriptionAttribute("The border color to use around the edge of a drop-down menu.")]
public:
virtual property Color MenuBorder {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColorTable Class
ProfessionalColorTable Members


MenuItemBorder Property

[image]
Gizmox.WebGUI.Forms
MenuItemBorder Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColorTable Class : MenuItemBorder Property

Gets the border color to use with a ToolStripMenuItem.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("The border color to use with MenuItem.")>
Public Overridable ReadOnly Property MenuItemBorder As Color
Visual Basic (Usage) Copy Code
Dim instance As ProfessionalColorTable
Dim value As Color

value = instance.MenuItemBorder
C#
[SRDescriptionAttribute("The border color to use with MenuItem.")]
public virtual Color MenuItemBorder {get;}
Managed Extensions for C++
[SRDescriptionAttribute("The border color to use with MenuItem.")]
public: __property virtual Color get_MenuItemBorder();
C++/CLI
[SRDescriptionAttribute("The border color to use with MenuItem.")]
public:
virtual property Color MenuItemBorder {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColorTable Class
ProfessionalColorTable Members


MenuItemPressedGradientBegin Property

[image]
Gizmox.WebGUI.Forms
MenuItemPressedGradientBegin Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColorTable Class : MenuItemPressedGradientBegin Property

Gets the starting color of the gradient used when a top-level ToolStripMenuItem is pressed.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Starting color of the gradient used when a top level menu item is pressed.")>
Public Overridable ReadOnly Property MenuItemPressedGradientBegin As Color
Visual Basic (Usage) Copy Code
Dim instance As ProfessionalColorTable
Dim value As Color

value = instance.MenuItemPressedGradientBegin
C#
[SRDescriptionAttribute("Starting color of the gradient used when a top level menu item is pressed.")]
public virtual Color MenuItemPressedGradientBegin {get;}
Managed Extensions for C++
[SRDescriptionAttribute("Starting color of the gradient used when a top level menu item is pressed.")]
public: __property virtual Color get_MenuItemPressedGradientBegin();
C++/CLI
[SRDescriptionAttribute("Starting color of the gradient used when a top level menu item is pressed.")]
public:
virtual property Color MenuItemPressedGradientBegin {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColorTable Class
ProfessionalColorTable Members


MenuItemPressedGradientEnd Property

[image]
Gizmox.WebGUI.Forms
MenuItemPressedGradientEnd Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColorTable Class : MenuItemPressedGradientEnd Property

Gets the end color of the gradient used when a top-level ToolStripMenuItem is pressed.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("End color of the gradient used when a top level menu item is pressed.")>
Public Overridable ReadOnly Property MenuItemPressedGradientEnd As Color
Visual Basic (Usage) Copy Code
Dim instance As ProfessionalColorTable
Dim value As Color

value = instance.MenuItemPressedGradientEnd
C#
[SRDescriptionAttribute("End color of the gradient used when a top level menu item is pressed.")]
public virtual Color MenuItemPressedGradientEnd {get;}
Managed Extensions for C++
[SRDescriptionAttribute("End color of the gradient used when a top level menu item is pressed.")]
public: __property virtual Color get_MenuItemPressedGradientEnd();
C++/CLI
[SRDescriptionAttribute("End color of the gradient used when a top level menu item is pressed.")]
public:
virtual property Color MenuItemPressedGradientEnd {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColorTable Class
ProfessionalColorTable Members


MenuItemPressedGradientMiddle Property

[image]
Gizmox.WebGUI.Forms
MenuItemPressedGradientMiddle Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColorTable Class : MenuItemPressedGradientMiddle Property

Gets the middle color of the gradient used when a top-level ToolStripMenuItem is pressed.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Middle color of the gradient used when a top level menu item is pressed.")>
Public Overridable ReadOnly Property MenuItemPressedGradientMiddle As Color
Visual Basic (Usage) Copy Code
Dim instance As ProfessionalColorTable
Dim value As Color

value = instance.MenuItemPressedGradientMiddle
C#
[SRDescriptionAttribute("Middle color of the gradient used when a top level menu item is pressed.")]
public virtual Color MenuItemPressedGradientMiddle {get;}
Managed Extensions for C++
[SRDescriptionAttribute("Middle color of the gradient used when a top level menu item is pressed.")]
public: __property virtual Color get_MenuItemPressedGradientMiddle();
C++/CLI
[SRDescriptionAttribute("Middle color of the gradient used when a top level menu item is pressed.")]
public:
virtual property Color MenuItemPressedGradientMiddle {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColorTable Class
ProfessionalColorTable Members


MenuItemSelected Property

[image]
Gizmox.WebGUI.Forms
MenuItemSelected Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColorTable Class : MenuItemSelected Property

Gets the solid color to use when a ToolStripMenuItem other than the top-level ToolStripMenuItem is selected.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Solid color to use when a non-top level menu item is selected")>
Public Overridable ReadOnly Property MenuItemSelected As Color
Visual Basic (Usage) Copy Code
Dim instance As ProfessionalColorTable
Dim value As Color

value = instance.MenuItemSelected
C#
[SRDescriptionAttribute("Solid color to use when a non-top level menu item is selected")]
public virtual Color MenuItemSelected {get;}
Managed Extensions for C++
[SRDescriptionAttribute("Solid color to use when a non-top level menu item is selected")]
public: __property virtual Color get_MenuItemSelected();
C++/CLI
[SRDescriptionAttribute("Solid color to use when a non-top level menu item is selected")]
public:
virtual property Color MenuItemSelected {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColorTable Class
ProfessionalColorTable Members


MenuItemSelectedGradientBegin Property

[image]
Gizmox.WebGUI.Forms
MenuItemSelectedGradientBegin Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColorTable Class : MenuItemSelectedGradientBegin Property

Gets the starting color of the gradient used when the ToolStripMenuItem is selected.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Starting color of the gradient used when the menu item is selected.")>
Public Overridable ReadOnly Property MenuItemSelectedGradientBegin As Color
Visual Basic (Usage) Copy Code
Dim instance As ProfessionalColorTable
Dim value As Color

value = instance.MenuItemSelectedGradientBegin
C#
[SRDescriptionAttribute("Starting color of the gradient used when the menu item is selected.")]
public virtual Color MenuItemSelectedGradientBegin {get;}
Managed Extensions for C++
[SRDescriptionAttribute("Starting color of the gradient used when the menu item is selected.")]
public: __property virtual Color get_MenuItemSelectedGradientBegin();
C++/CLI
[SRDescriptionAttribute("Starting color of the gradient used when the menu item is selected.")]
public:
virtual property Color MenuItemSelectedGradientBegin {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColorTable Class
ProfessionalColorTable Members


MenuItemSelectedGradientEnd Property

[image]
Gizmox.WebGUI.Forms
MenuItemSelectedGradientEnd Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColorTable Class : MenuItemSelectedGradientEnd Property

Gets the end color of the gradient used when the ToolStripMenuItem is selected.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("End color of the gradient used when the menu item is selected.")>
Public Overridable ReadOnly Property MenuItemSelectedGradientEnd As Color
Visual Basic (Usage) Copy Code
Dim instance As ProfessionalColorTable
Dim value As Color

value = instance.MenuItemSelectedGradientEnd
C#
[SRDescriptionAttribute("End color of the gradient used when the menu item is selected.")]
public virtual Color MenuItemSelectedGradientEnd {get;}
Managed Extensions for C++
[SRDescriptionAttribute("End color of the gradient used when the menu item is selected.")]
public: __property virtual Color get_MenuItemSelectedGradientEnd();
C++/CLI
[SRDescriptionAttribute("End color of the gradient used when the menu item is selected.")]
public:
virtual property Color MenuItemSelectedGradientEnd {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColorTable Class
ProfessionalColorTable Members


MenuStripGradientBegin Property

[image]
Gizmox.WebGUI.Forms
MenuStripGradientBegin Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColorTable Class : MenuStripGradientBegin Property

Gets the starting color of the gradient used in the MenuStrip.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Starting color of the gradient used in the MenuStrip.")>
Public Overridable ReadOnly Property MenuStripGradientBegin As Color
Visual Basic (Usage) Copy Code
Dim instance As ProfessionalColorTable
Dim value As Color

value = instance.MenuStripGradientBegin
C#
[SRDescriptionAttribute("Starting color of the gradient used in the MenuStrip.")]
public virtual Color MenuStripGradientBegin {get;}
Managed Extensions for C++
[SRDescriptionAttribute("Starting color of the gradient used in the MenuStrip.")]
public: __property virtual Color get_MenuStripGradientBegin();
C++/CLI
[SRDescriptionAttribute("Starting color of the gradient used in the MenuStrip.")]
public:
virtual property Color MenuStripGradientBegin {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColorTable Class
ProfessionalColorTable Members


MenuStripGradientEnd Property

[image]
Gizmox.WebGUI.Forms
MenuStripGradientEnd Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColorTable Class : MenuStripGradientEnd Property

Gets the end color of the gradient used in the MenuStrip.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Middle color of the gradient used in the MenuStrip.")>
Public Overridable ReadOnly Property MenuStripGradientEnd As Color
Visual Basic (Usage) Copy Code
Dim instance As ProfessionalColorTable
Dim value As Color

value = instance.MenuStripGradientEnd
C#
[SRDescriptionAttribute("Middle color of the gradient used in the MenuStrip.")]
public virtual Color MenuStripGradientEnd {get;}
Managed Extensions for C++
[SRDescriptionAttribute("Middle color of the gradient used in the MenuStrip.")]
public: __property virtual Color get_MenuStripGradientEnd();
C++/CLI
[SRDescriptionAttribute("Middle color of the gradient used in the MenuStrip.")]
public:
virtual property Color MenuStripGradientEnd {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColorTable Class
ProfessionalColorTable Members


OverflowButtonGradientBegin Property

[image]
Gizmox.WebGUI.Forms
OverflowButtonGradientBegin Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColorTable Class : OverflowButtonGradientBegin Property

Gets the starting color of the gradient used in the ToolStripOverflowButton.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Starting color of the gradient used in the overflow button.")>
Public Overridable ReadOnly Property OverflowButtonGradientBegin As Color
Visual Basic (Usage) Copy Code
Dim instance As ProfessionalColorTable
Dim value As Color

value = instance.OverflowButtonGradientBegin
C#
[SRDescriptionAttribute("Starting color of the gradient used in the overflow button.")]
public virtual Color OverflowButtonGradientBegin {get;}
Managed Extensions for C++
[SRDescriptionAttribute("Starting color of the gradient used in the overflow button.")]
public: __property virtual Color get_OverflowButtonGradientBegin();
C++/CLI
[SRDescriptionAttribute("Starting color of the gradient used in the overflow button.")]
public:
virtual property Color OverflowButtonGradientBegin {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColorTable Class
ProfessionalColorTable Members


OverflowButtonGradientEnd Property

[image]
Gizmox.WebGUI.Forms
OverflowButtonGradientEnd Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColorTable Class : OverflowButtonGradientEnd Property

Gets the end color of the gradient used in the ToolStripOverflowButton.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("End color of the gradient used in the overflow button.")>
Public Overridable ReadOnly Property OverflowButtonGradientEnd As Color
Visual Basic (Usage) Copy Code
Dim instance As ProfessionalColorTable
Dim value As Color

value = instance.OverflowButtonGradientEnd
C#
[SRDescriptionAttribute("End color of the gradient used in the overflow button.")]
public virtual Color OverflowButtonGradientEnd {get;}
Managed Extensions for C++
[SRDescriptionAttribute("End color of the gradient used in the overflow button.")]
public: __property virtual Color get_OverflowButtonGradientEnd();
C++/CLI
[SRDescriptionAttribute("End color of the gradient used in the overflow button.")]
public:
virtual property Color OverflowButtonGradientEnd {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColorTable Class
ProfessionalColorTable Members


OverflowButtonGradientMiddle Property

[image]
Gizmox.WebGUI.Forms
OverflowButtonGradientMiddle Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColorTable Class : OverflowButtonGradientMiddle Property

Gets the middle color of the gradient used in the ToolStripOverflowButton.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Middle color of the gradient used in the overflow button.")>
Public Overridable ReadOnly Property OverflowButtonGradientMiddle As Color
Visual Basic (Usage) Copy Code
Dim instance As ProfessionalColorTable
Dim value As Color

value = instance.OverflowButtonGradientMiddle
C#
[SRDescriptionAttribute("Middle color of the gradient used in the overflow button.")]
public virtual Color OverflowButtonGradientMiddle {get;}
Managed Extensions for C++
[SRDescriptionAttribute("Middle color of the gradient used in the overflow button.")]
public: __property virtual Color get_OverflowButtonGradientMiddle();
C++/CLI
[SRDescriptionAttribute("Middle color of the gradient used in the overflow button.")]
public:
virtual property Color OverflowButtonGradientMiddle {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColorTable Class
ProfessionalColorTable Members


RaftingContainerGradientBegin Property

[image]
Gizmox.WebGUI.Forms
RaftingContainerGradientBegin Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColorTable Class : RaftingContainerGradientBegin Property

Gets the starting color of the gradient used in the ToolStripContainer.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Starting color of the gradient used in the RaftingContainer.")>
Public Overridable ReadOnly Property RaftingContainerGradientBegin As Color
Visual Basic (Usage) Copy Code
Dim instance As ProfessionalColorTable
Dim value As Color

value = instance.RaftingContainerGradientBegin
C#
[SRDescriptionAttribute("Starting color of the gradient used in the RaftingContainer.")]
public virtual Color RaftingContainerGradientBegin {get;}
Managed Extensions for C++
[SRDescriptionAttribute("Starting color of the gradient used in the RaftingContainer.")]
public: __property virtual Color get_RaftingContainerGradientBegin();
C++/CLI
[SRDescriptionAttribute("Starting color of the gradient used in the RaftingContainer.")]
public:
virtual property Color RaftingContainerGradientBegin {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColorTable Class
ProfessionalColorTable Members


RaftingContainerGradientEnd Property

[image]
Gizmox.WebGUI.Forms
RaftingContainerGradientEnd Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColorTable Class : RaftingContainerGradientEnd Property

Gets the end color of the gradient used in the ToolStripContainer.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("End color of the gradient used in the RaftingContainer.")>
Public Overridable ReadOnly Property RaftingContainerGradientEnd As Color
Visual Basic (Usage) Copy Code
Dim instance As ProfessionalColorTable
Dim value As Color

value = instance.RaftingContainerGradientEnd
C#
[SRDescriptionAttribute("End color of the gradient used in the RaftingContainer.")]
public virtual Color RaftingContainerGradientEnd {get;}
Managed Extensions for C++
[SRDescriptionAttribute("End color of the gradient used in the RaftingContainer.")]
public: __property virtual Color get_RaftingContainerGradientEnd();
C++/CLI
[SRDescriptionAttribute("End color of the gradient used in the RaftingContainer.")]
public:
virtual property Color RaftingContainerGradientEnd {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColorTable Class
ProfessionalColorTable Members


SeparatorDark Property

[image]
Gizmox.WebGUI.Forms
SeparatorDark Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColorTable Class : SeparatorDark Property

Gets the color to use to for shadow effects on the ToolStripSeparator.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Color to use to for shadow effects on the separator.")>
Public Overridable ReadOnly Property SeparatorDark As Color
Visual Basic (Usage) Copy Code
Dim instance As ProfessionalColorTable
Dim value As Color

value = instance.SeparatorDark
C#
[SRDescriptionAttribute("Color to use to for shadow effects on the separator.")]
public virtual Color SeparatorDark {get;}
Managed Extensions for C++
[SRDescriptionAttribute("Color to use to for shadow effects on the separator.")]
public: __property virtual Color get_SeparatorDark();
C++/CLI
[SRDescriptionAttribute("Color to use to for shadow effects on the separator.")]
public:
virtual property Color SeparatorDark {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColorTable Class
ProfessionalColorTable Members


SeparatorLight Property

[image]
Gizmox.WebGUI.Forms
SeparatorLight Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColorTable Class : SeparatorLight Property

Gets the color to use to for highlight effects on the ToolStripSeparator.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Color to use to for highlight effects on the separator.")>
Public Overridable ReadOnly Property SeparatorLight As Color
Visual Basic (Usage) Copy Code
Dim instance As ProfessionalColorTable
Dim value As Color

value = instance.SeparatorLight
C#
[SRDescriptionAttribute("Color to use to for highlight effects on the separator.")]
public virtual Color SeparatorLight {get;}
Managed Extensions for C++
[SRDescriptionAttribute("Color to use to for highlight effects on the separator.")]
public: __property virtual Color get_SeparatorLight();
C++/CLI
[SRDescriptionAttribute("Color to use to for highlight effects on the separator.")]
public:
virtual property Color SeparatorLight {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColorTable Class
ProfessionalColorTable Members


StatusStripGradientBegin Property

[image]
Gizmox.WebGUI.Forms
StatusStripGradientBegin Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColorTable Class : StatusStripGradientBegin Property

Gets the starting color of the gradient used on the StatusStrip.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Starting color of the gradient used in the StatusStrip.")>
Public Overridable ReadOnly Property StatusStripGradientBegin As Color
Visual Basic (Usage) Copy Code
Dim instance As ProfessionalColorTable
Dim value As Color

value = instance.StatusStripGradientBegin
C#
[SRDescriptionAttribute("Starting color of the gradient used in the StatusStrip.")]
public virtual Color StatusStripGradientBegin {get;}
Managed Extensions for C++
[SRDescriptionAttribute("Starting color of the gradient used in the StatusStrip.")]
public: __property virtual Color get_StatusStripGradientBegin();
C++/CLI
[SRDescriptionAttribute("Starting color of the gradient used in the StatusStrip.")]
public:
virtual property Color StatusStripGradientBegin {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColorTable Class
ProfessionalColorTable Members


StatusStripGradientEnd Property

[image]
Gizmox.WebGUI.Forms
StatusStripGradientEnd Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColorTable Class : StatusStripGradientEnd Property

Gets the end color of the gradient used on the StatusStrip.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("End color of the gradient used in the StatusStrip.")>
Public Overridable ReadOnly Property StatusStripGradientEnd As Color
Visual Basic (Usage) Copy Code
Dim instance As ProfessionalColorTable
Dim value As Color

value = instance.StatusStripGradientEnd
C#
[SRDescriptionAttribute("End color of the gradient used in the StatusStrip.")]
public virtual Color StatusStripGradientEnd {get;}
Managed Extensions for C++
[SRDescriptionAttribute("End color of the gradient used in the StatusStrip.")]
public: __property virtual Color get_StatusStripGradientEnd();
C++/CLI
[SRDescriptionAttribute("End color of the gradient used in the StatusStrip.")]
public:
virtual property Color StatusStripGradientEnd {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColorTable Class
ProfessionalColorTable Members


ToolStripBorder Property

[image]
Gizmox.WebGUI.Forms
ToolStripBorder Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColorTable Class : ToolStripBorder Property

Gets the border color to use on the bottom edge of the ToolStrip.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Border color to use on the bottom edge of the ToolStrip.")>
Public Overridable ReadOnly Property ToolStripBorder As Color
Visual Basic (Usage) Copy Code
Dim instance As ProfessionalColorTable
Dim value As Color

value = instance.ToolStripBorder
C#
[SRDescriptionAttribute("Border color to use on the bottom edge of the ToolStrip.")]
public virtual Color ToolStripBorder {get;}
Managed Extensions for C++
[SRDescriptionAttribute("Border color to use on the bottom edge of the ToolStrip.")]
public: __property virtual Color get_ToolStripBorder();
C++/CLI
[SRDescriptionAttribute("Border color to use on the bottom edge of the ToolStrip.")]
public:
virtual property Color ToolStripBorder {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColorTable Class
ProfessionalColorTable Members


ToolStripContentPanelGradientBegin Property

[image]
Gizmox.WebGUI.Forms
ToolStripContentPanelGradientBegin Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColorTable Class : ToolStripContentPanelGradientBegin Property

Gets the starting color of the gradient used in the ToolStripContentPanel.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Starting color of the gradient used in the ToolStripContentPanel.")>
Public Overridable ReadOnly Property ToolStripContentPanelGradientBegin As Color
Visual Basic (Usage) Copy Code
Dim instance As ProfessionalColorTable
Dim value As Color

value = instance.ToolStripContentPanelGradientBegin
C#
[SRDescriptionAttribute("Starting color of the gradient used in the ToolStripContentPanel.")]
public virtual Color ToolStripContentPanelGradientBegin {get;}
Managed Extensions for C++
[SRDescriptionAttribute("Starting color of the gradient used in the ToolStripContentPanel.")]
public: __property virtual Color get_ToolStripContentPanelGradientBegin();
C++/CLI
[SRDescriptionAttribute("Starting color of the gradient used in the ToolStripContentPanel.")]
public:
virtual property Color ToolStripContentPanelGradientBegin {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColorTable Class
ProfessionalColorTable Members


ToolStripContentPanelGradientEnd Property

[image]
Gizmox.WebGUI.Forms
ToolStripContentPanelGradientEnd Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColorTable Class : ToolStripContentPanelGradientEnd Property

Gets the end color of the gradient used in the ToolStripContentPanel.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("End color of the gradient used in the ToolStripContentPanel.")>
Public Overridable ReadOnly Property ToolStripContentPanelGradientEnd As Color
Visual Basic (Usage) Copy Code
Dim instance As ProfessionalColorTable
Dim value As Color

value = instance.ToolStripContentPanelGradientEnd
C#
[SRDescriptionAttribute("End color of the gradient used in the ToolStripContentPanel.")]
public virtual Color ToolStripContentPanelGradientEnd {get;}
Managed Extensions for C++
[SRDescriptionAttribute("End color of the gradient used in the ToolStripContentPanel.")]
public: __property virtual Color get_ToolStripContentPanelGradientEnd();
C++/CLI
[SRDescriptionAttribute("End color of the gradient used in the ToolStripContentPanel.")]
public:
virtual property Color ToolStripContentPanelGradientEnd {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColorTable Class
ProfessionalColorTable Members


ToolStripDropDownBackground Property

[image]
Gizmox.WebGUI.Forms
ToolStripDropDownBackground Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColorTable Class : ToolStripDropDownBackground Property

Gets the solid background color of the ToolStripDropDown.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Solid background color of the ToolStripDropDown.")>
Public Overridable ReadOnly Property ToolStripDropDownBackground As Color
Visual Basic (Usage) Copy Code
Dim instance As ProfessionalColorTable
Dim value As Color

value = instance.ToolStripDropDownBackground
C#
[SRDescriptionAttribute("Solid background color of the ToolStripDropDown.")]
public virtual Color ToolStripDropDownBackground {get;}
Managed Extensions for C++
[SRDescriptionAttribute("Solid background color of the ToolStripDropDown.")]
public: __property virtual Color get_ToolStripDropDownBackground();
C++/CLI
[SRDescriptionAttribute("Solid background color of the ToolStripDropDown.")]
public:
virtual property Color ToolStripDropDownBackground {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColorTable Class
ProfessionalColorTable Members


ToolStripGradientBegin Property

[image]
Gizmox.WebGUI.Forms
ToolStripGradientBegin Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColorTable Class : ToolStripGradientBegin Property

Gets the starting color of the gradient used in the ToolStrip background.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Starting color of the gradient used in the ToolStrip background.")>
Public Overridable ReadOnly Property ToolStripGradientBegin As Color
Visual Basic (Usage) Copy Code
Dim instance As ProfessionalColorTable
Dim value As Color

value = instance.ToolStripGradientBegin
C#
[SRDescriptionAttribute("Starting color of the gradient used in the ToolStrip background.")]
public virtual Color ToolStripGradientBegin {get;}
Managed Extensions for C++
[SRDescriptionAttribute("Starting color of the gradient used in the ToolStrip background.")]
public: __property virtual Color get_ToolStripGradientBegin();
C++/CLI
[SRDescriptionAttribute("Starting color of the gradient used in the ToolStrip background.")]
public:
virtual property Color ToolStripGradientBegin {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColorTable Class
ProfessionalColorTable Members


ToolStripGradientEnd Property

[image]
Gizmox.WebGUI.Forms
ToolStripGradientEnd Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColorTable Class : ToolStripGradientEnd Property

Gets the end color of the gradient used in the ToolStrip background.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("End color of the gradient used in the ToolStrip background.")>
Public Overridable ReadOnly Property ToolStripGradientEnd As Color
Visual Basic (Usage) Copy Code
Dim instance As ProfessionalColorTable
Dim value As Color

value = instance.ToolStripGradientEnd
C#
[SRDescriptionAttribute("End color of the gradient used in the ToolStrip background.")]
public virtual Color ToolStripGradientEnd {get;}
Managed Extensions for C++
[SRDescriptionAttribute("End color of the gradient used in the ToolStrip background.")]
public: __property virtual Color get_ToolStripGradientEnd();
C++/CLI
[SRDescriptionAttribute("End color of the gradient used in the ToolStrip background.")]
public:
virtual property Color ToolStripGradientEnd {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColorTable Class
ProfessionalColorTable Members


ToolStripGradientMiddle Property

[image]
Gizmox.WebGUI.Forms
ToolStripGradientMiddle Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColorTable Class : ToolStripGradientMiddle Property

Gets the middle color of the gradient used in the ToolStrip background.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Middle color of the gradient used in the ToolStrip background.")>
Public Overridable ReadOnly Property ToolStripGradientMiddle As Color
Visual Basic (Usage) Copy Code
Dim instance As ProfessionalColorTable
Dim value As Color

value = instance.ToolStripGradientMiddle
C#
[SRDescriptionAttribute("Middle color of the gradient used in the ToolStrip background.")]
public virtual Color ToolStripGradientMiddle {get;}
Managed Extensions for C++
[SRDescriptionAttribute("Middle color of the gradient used in the ToolStrip background.")]
public: __property virtual Color get_ToolStripGradientMiddle();
C++/CLI
[SRDescriptionAttribute("Middle color of the gradient used in the ToolStrip background.")]
public:
virtual property Color ToolStripGradientMiddle {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColorTable Class
ProfessionalColorTable Members


ToolStripPanelGradientBegin Property

[image]
Gizmox.WebGUI.Forms
ToolStripPanelGradientBegin Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColorTable Class : ToolStripPanelGradientBegin Property

Gets the starting color of the gradient used in the ToolStripPanel.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Starting color of the gradient used in the ToolStripPanel.")>
Public Overridable ReadOnly Property ToolStripPanelGradientBegin As Color
Visual Basic (Usage) Copy Code
Dim instance As ProfessionalColorTable
Dim value As Color

value = instance.ToolStripPanelGradientBegin
C#
[SRDescriptionAttribute("Starting color of the gradient used in the ToolStripPanel.")]
public virtual Color ToolStripPanelGradientBegin {get;}
Managed Extensions for C++
[SRDescriptionAttribute("Starting color of the gradient used in the ToolStripPanel.")]
public: __property virtual Color get_ToolStripPanelGradientBegin();
C++/CLI
[SRDescriptionAttribute("Starting color of the gradient used in the ToolStripPanel.")]
public:
virtual property Color ToolStripPanelGradientBegin {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColorTable Class
ProfessionalColorTable Members


ToolStripPanelGradientEnd Property

[image]
Gizmox.WebGUI.Forms
ToolStripPanelGradientEnd Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColorTable Class : ToolStripPanelGradientEnd Property

Gets the end color of the gradient used in the ToolStripPanel.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("End color of the gradient used in the ToolStripPanel.")>
Public Overridable ReadOnly Property ToolStripPanelGradientEnd As Color
Visual Basic (Usage) Copy Code
Dim instance As ProfessionalColorTable
Dim value As Color

value = instance.ToolStripPanelGradientEnd
C#
[SRDescriptionAttribute("End color of the gradient used in the ToolStripPanel.")]
public virtual Color ToolStripPanelGradientEnd {get;}
Managed Extensions for C++
[SRDescriptionAttribute("End color of the gradient used in the ToolStripPanel.")]
public: __property virtual Color get_ToolStripPanelGradientEnd();
C++/CLI
[SRDescriptionAttribute("End color of the gradient used in the ToolStripPanel.")]
public:
virtual property Color ToolStripPanelGradientEnd {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColorTable Class
ProfessionalColorTable Members


UseSystemColors Property

[image]
Gizmox.WebGUI.Forms
UseSystemColors Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProfessionalColorTable Class : UseSystemColors Property

Gets or sets a value indicating whether to use SystemColors rather than colors that match the current visual style.

Syntax

Visual Basic (Declaration)
Public Property UseSystemColors As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ProfessionalColorTable
Dim value As Boolean

instance.UseSystemColors = value

value = instance.UseSystemColors
C#
public bool UseSystemColors {get; set;}
Managed Extensions for C++
public: __property bool get_UseSystemColors();
public: __property void set_UseSystemColors(
   bool value
);
C++/CLI
public:
property bool UseSystemColors {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProfessionalColorTable Class
ProfessionalColorTable Members


ProgressBar Class

[image]
Gizmox.WebGUI.Forms
ProgressBar Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ProgressBar Class

Represents a WebGUI progress bar control.

Object Model

Syntax

Visual Basic (Declaration)
<DefaultBindingPropertyAttribute("Value")>
<DesignTimeControllerAttribute()>
<SRDescriptionAttribute("Displays a bar that fills to indicate to the user the progress of an operation.")>
<SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableProgressBar, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")>
<DefaultPropertyAttribute("Value")>
<ToolboxBitmapAttribute()>
<ClientControllerAttribute()>
<MetadataTagAttribute("PB")>
<ToolboxItemCategoryAttribute("Common Controls")>
<ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
Public Class ProgressBar
   Inherits Control
   Implements IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Visual Basic (Usage) Copy Code
Dim instance As ProgressBar
C#
[DefaultBindingPropertyAttribute("Value")]
[DesignTimeControllerAttribute()]
[SRDescriptionAttribute("Displays a bar that fills to indicate to the user the progress of an operation.")]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableProgressBar, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[DefaultPropertyAttribute("Value")]
[ToolboxBitmapAttribute()]
[ClientControllerAttribute()]
[MetadataTagAttribute("PB")]
[ToolboxItemCategoryAttribute("Common Controls")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
public class ProgressBar : Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Managed Extensions for C++
[DefaultBindingPropertyAttribute("Value")]
[DesignTimeControllerAttribute()]
[SRDescriptionAttribute("Displays a bar that fills to indicate to the user the progress of an operation.")]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableProgressBar, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[DefaultPropertyAttribute("Value")]
[ToolboxBitmapAttribute()]
[ClientControllerAttribute()]
[MetadataTagAttribute("PB")]
[ToolboxItemCategoryAttribute("Common Controls")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
public __gc class ProgressBar : public Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
C++/CLI
[DefaultBindingPropertyAttribute("Value")]
[DesignTimeControllerAttribute()]
[SRDescriptionAttribute("Displays a bar that fills to indicate to the user the progress of an operation.")]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableProgressBar, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[DefaultPropertyAttribute("Value")]
[ToolboxBitmapAttribute()]
[ClientControllerAttribute()]
[MetadataTagAttribute("PB")]
[ToolboxItemCategoryAttribute("Common Controls")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
public ref class ProgressBar : public Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.ProgressBar

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

ProgressBar Members
Gizmox.WebGUI.Forms Namespace


ProgressBar Class Members

[image]
Gizmox.WebGUI.Forms
ProgressBar Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : ProgressBar Class

The following tables list the members exposed by ProgressBar.

Public Constructors

 | Name | Description
Public Constructor | ProgressBar Constructor | Initializes a new instance of the ProgressBar class.
Top

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | Maximum | Gets or sets the maximum value of the range of the control.
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Minimum | Gets or sets the minimum value of the range of the control.
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | Step | Gets or sets the amount by which a call to the PerformStep method increases the current position of the progress bar.
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Control)
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | Value | Gets or sets the current position of the progress bar.
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Increment | Advances the current position of the progress bar by the specified amount.
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | PerformStep | Advances the current position of the progress bar by the amount of the Step property.
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Control)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from Control)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | Overridden. Renders the current control.
Protected Method | RenderAttributes | Renders the controls meta attributes (Inherited from Control)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

ProgressBar Class
Gizmox.WebGUI.Forms Namespace


ProgressBar Constructor

[image]
Gizmox.WebGUI.Forms
ProgressBar Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProgressBar Class : ProgressBar Constructor

Initializes a new instance of the ProgressBar class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ProgressBar()
C#
public ProgressBar()
Managed Extensions for C++
public: ProgressBar();
C++/CLI
public:
ProgressBar();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProgressBar Class
ProgressBar Members


ProgressBar Class Methods

[image]
Gizmox.WebGUI.Forms
ProgressBar Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ProgressBar Class

For a list of all members of this type, see ProgressBar members.

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Increment | Advances the current position of the progress bar by the specified amount.
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | PerformStep | Advances the current position of the progress bar by the amount of the Step property.
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Control)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from Control)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | Overridden. Renders the current control.
Protected Method | RenderAttributes | Renders the controls meta attributes (Inherited from Control)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

See Also

Reference

ProgressBar Class
Gizmox.WebGUI.Forms Namespace


Increment Method

[image]
Gizmox.WebGUI.Forms
Increment Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProgressBar Class : Increment Method

value
The amount by which to increment the progress bar's current position.
Advances the current position of the progress bar by the specified amount.

Syntax

Visual Basic (Declaration)
Public Sub Increment( _
   ByVal value As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As ProgressBar
Dim value As Integer

instance.Increment(value)
C#
public void Increment(
   int value
)
Managed Extensions for C++
public: void Increment(
   int value
)
C++/CLI
public:
void Increment(
   int value
)

Parameters

value
The amount by which to increment the progress bar's current position.

Exceptions

Exception | Description
InvalidOperationException | The Style property is set to Marquee

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProgressBar Class
ProgressBar Members


PerformStep Method

[image]
Gizmox.WebGUI.Forms
PerformStep Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProgressBar Class : PerformStep Method

Advances the current position of the progress bar by the amount of the Step property.

Syntax

Visual Basic (Declaration)
Public Sub PerformStep()
Visual Basic (Usage) Copy Code
Dim instance As ProgressBar

instance.PerformStep()
C#
public void PerformStep()
Managed Extensions for C++
public: void PerformStep();
C++/CLI
public:
void PerformStep();

Exceptions

Exception | Description
InvalidOperationException | Style is set to Marquee.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProgressBar Class
ProgressBar Members


Render Method

[image]
Gizmox.WebGUI.Forms
Render Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProgressBar Class : Render Method

objContext
Request context.
objWriter
lngRequestID
Renders the current control.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub Render( _
   ByVal objContext As IContext, _
   ByVal objWriter As IResponseWriter, _
   ByVal lngRequestID As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As ProgressBar
Dim objContext As IContext
Dim objWriter As IResponseWriter
Dim lngRequestID As Long

instance.Render(objContext, objWriter, lngRequestID)
C#
protected override void Render(
   IContext objContext,
   IResponseWriter objWriter,
   long lngRequestID
)
Managed Extensions for C++
protected: void Render(
   IContext* objContext,
   IResponseWriter* objWriter,
   long lngRequestID
) override
C++/CLI
protected:
void Render(
   IContext^ objContext,
   IResponseWriter^ objWriter,
   long long lngRequestID
) override

Parameters

objContext
Request context.
objWriter
lngRequestID

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProgressBar Class
ProgressBar Members


ProgressBar Class Properties

[image]
Gizmox.WebGUI.Forms
ProgressBar Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ProgressBar Class

For a list of all members of this type, see ProgressBar members.

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | Maximum | Gets or sets the maximum value of the range of the control.
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Minimum | Gets or sets the minimum value of the range of the control.
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | Step | Gets or sets the amount by which a call to the PerformStep method increases the current position of the progress bar.
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Control)
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | Value | Gets or sets the current position of the progress bar.
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

See Also

Reference

ProgressBar Class
Gizmox.WebGUI.Forms Namespace


Maximum Property

[image]
Gizmox.WebGUI.Forms
Maximum Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProgressBar Class : Maximum Property

Gets or sets the maximum value of the range of the control.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<RefreshPropertiesAttribute()>
<SRDescriptionAttribute("The upper bound of the range this ProgressBar is working with.")>
<SRCategoryAttribute("Behavior")>
Public Property Maximum As Integer
Visual Basic (Usage) Copy Code
Dim instance As ProgressBar
Dim value As Integer

instance.Maximum = value

value = instance.Maximum
C#
[DefaultValueAttribute()]
[RefreshPropertiesAttribute()]
[SRDescriptionAttribute("The upper bound of the range this ProgressBar is working with.")]
[SRCategoryAttribute("Behavior")]
public int Maximum {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[RefreshPropertiesAttribute()]
[SRDescriptionAttribute("The upper bound of the range this ProgressBar is working with.")]
[SRCategoryAttribute("Behavior")]
public: __property int get_Maximum();
public: __property void set_Maximum(
   int value
);
C++/CLI
[DefaultValueAttribute()]
[RefreshPropertiesAttribute()]
[SRDescriptionAttribute("The upper bound of the range this ProgressBar is working with.")]
[SRCategoryAttribute("Behavior")]
public:
property int Maximum {
   int get();
   void set (intvalue);
}

Exceptions

Exception | Description
ArgumentException | The value specified is less than 0.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProgressBar Class
ProgressBar Members


Minimum Property

[image]
Gizmox.WebGUI.Forms
Minimum Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProgressBar Class : Minimum Property

Gets or sets the minimum value of the range of the control.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("The lower bound of the range this ProgressBar is working with.")>
<SRCategoryAttribute("Behavior")>
<RefreshPropertiesAttribute()>
<DefaultValueAttribute()>
Public Property Minimum As Integer
Visual Basic (Usage) Copy Code
Dim instance As ProgressBar
Dim value As Integer

instance.Minimum = value

value = instance.Minimum
C#
[SRDescriptionAttribute("The lower bound of the range this ProgressBar is working with.")]
[SRCategoryAttribute("Behavior")]
[RefreshPropertiesAttribute()]
[DefaultValueAttribute()]
public int Minimum {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("The lower bound of the range this ProgressBar is working with.")]
[SRCategoryAttribute("Behavior")]
[RefreshPropertiesAttribute()]
[DefaultValueAttribute()]
public: __property int get_Minimum();
public: __property void set_Minimum(
   int value
);
C++/CLI
[SRDescriptionAttribute("The lower bound of the range this ProgressBar is working with.")]
[SRCategoryAttribute("Behavior")]
[RefreshPropertiesAttribute()]
[DefaultValueAttribute()]
public:
property int Minimum {
   int get();
   void set (intvalue);
}

Exceptions

Exception | Description
ArgumentException | The value specified for the property is less than 0.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProgressBar Class
ProgressBar Members


Step Property

[image]
Gizmox.WebGUI.Forms
Step Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProgressBar Class : Step Property

Gets or sets the amount by which a call to the PerformStep method increases the current position of the progress bar.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<SRDescriptionAttribute("The amount to increment the current value of the control by when the PerformStep() method is called.")>
<SRCategoryAttribute("Behavior")>
Public Property Step As Integer
Visual Basic (Usage) Copy Code
Dim instance As ProgressBar
Dim value As Integer

instance.Step = value

value = instance.Step
C#
[DefaultValueAttribute()]
[SRDescriptionAttribute("The amount to increment the current value of the control by when the PerformStep() method is called.")]
[SRCategoryAttribute("Behavior")]
public int Step {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[SRDescriptionAttribute("The amount to increment the current value of the control by when the PerformStep() method is called.")]
[SRCategoryAttribute("Behavior")]
public: __property int get_Step();
public: __property void set_Step(
   int value
);
C++/CLI
[DefaultValueAttribute()]
[SRDescriptionAttribute("The amount to increment the current value of the control by when the PerformStep() method is called.")]
[SRCategoryAttribute("Behavior")]
public:
property int Step {
   int get();
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProgressBar Class
ProgressBar Members


Value Property

[image]
Gizmox.WebGUI.Forms
Value Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ProgressBar Class : Value Property

Gets or sets the current position of the progress bar.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Behavior")>
<SRDescriptionAttribute("The current value for the ProgressBar, in the range specified by the minimum and maximum properties.")>
<DefaultValueAttribute()>
<BindableAttribute(True)>
Public Property Value As Integer
Visual Basic (Usage) Copy Code
Dim instance As ProgressBar
Dim value As Integer

instance.Value = value

value = instance.Value
C#
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("The current value for the ProgressBar, in the range specified by the minimum and maximum properties.")]
[DefaultValueAttribute()]
[BindableAttribute(true)]
public int Value {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("The current value for the ProgressBar, in the range specified by the minimum and maximum properties.")]
[DefaultValueAttribute()]
[BindableAttribute(true)]
public: __property int get_Value();
public: __property void set_Value(
   int value
);
C++/CLI
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("The current value for the ProgressBar, in the range specified by the minimum and maximum properties.")]
[DefaultValueAttribute()]
[BindableAttribute(true)]
public:
property int Value {
   int get();
   void set (intvalue);
}

Exceptions

Exception | Description
ArgumentException | The value specified is greater than the value of the Maximum property.-or- The value specified is less than the value of the Minimum property.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ProgressBar Class
ProgressBar Members


PropertyGrid Class

[image]
Gizmox.WebGUI.Forms
PropertyGrid Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : PropertyGrid Class

Provides a user interface for browsing the properties of an object.

Object Model

Syntax

Visual Basic (Declaration)
<DesignTimeControllerAttribute()>
<ToolboxBitmapAttribute()>
<ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<ToolboxItemCategoryAttribute("Data")>
<MetadataTagAttribute("PG")>
<ClientControllerAttribute()>
<SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableDockPanel, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")>
Public Class PropertyGrid
   Inherits ContainerControl
   Implements IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, ISealedComponent, IBindableComponent, IContainerControl, IArrangedElement
Visual Basic (Usage) Copy Code
Dim instance As PropertyGrid
C#
[DesignTimeControllerAttribute()]
[ToolboxBitmapAttribute()]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ToolboxItemCategoryAttribute("Data")]
[MetadataTagAttribute("PG")]
[ClientControllerAttribute()]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableDockPanel, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
public class PropertyGrid : ContainerControl, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, ISealedComponent, IBindableComponent, IContainerControl, IArrangedElement
Managed Extensions for C++
[DesignTimeControllerAttribute()]
[ToolboxBitmapAttribute()]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ToolboxItemCategoryAttribute("Data")]
[MetadataTagAttribute("PG")]
[ClientControllerAttribute()]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableDockPanel, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
public __gc class PropertyGrid : public ContainerControl, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, ISealedComponent, IBindableComponent, IContainerControl, IArrangedElement
C++/CLI
[DesignTimeControllerAttribute()]
[ToolboxBitmapAttribute()]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ToolboxItemCategoryAttribute("Data")]
[MetadataTagAttribute("PG")]
[ClientControllerAttribute()]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableDockPanel, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
public ref class PropertyGrid : public ContainerControl, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, ISealedComponent, IBindableComponent, IContainerControl, IArrangedElement

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.ScrollableControl
Gizmox.WebGUI.Forms.ContainerControl
Gizmox.WebGUI.Forms.PropertyGrid

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

PropertyGrid Members
Gizmox.WebGUI.Forms Namespace


PropertyGrid Class Members

[image]
Gizmox.WebGUI.Forms
PropertyGrid Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : PropertyGrid Class

The following tables list the members exposed by PropertyGrid.

Public Constructors

 | Name | Description
Public Constructor | PropertyGrid Constructor | Initializes a new instance of the PropertyGrid class.
Top

Public Properties

 | Name | Description
Public Property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl)
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from ContainerControl)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | BrowsableAttributes | Gets or sets the browsable attributes associated with the object that the property grid is attached to.
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | CanShowCommands | Gets a value indicating whether the commands pane can be made visible for the currently selected objects.
Public Property | CategoryForeColor | Gets or sets the text color used for category headings.
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CommandsVisible | Gets a value indicating whether the commands pane is visible.
Public Property | CommandsVisibleIfAvailable | Gets or sets a value indicating whether the commands pane is visible for objects that expose verbs.
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Components | (Inherited from ContainerControl)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | HelpBackColor | Gets or sets the background color for the Help region.
Public Property | HelpForeColor | Gets or sets the foreground color for the Help region.
Public Property | HelpVisible | Gets or sets a value indicating whether the Help text is visible.
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | LargeButtons | Gets or sets a value indicating whether buttons appear in standard size or in large size.
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | LineColor | Gets or sets the color of the gridlines and borders.
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | PropertySort | Gets or sets the type of sorting the PropertyGrid uses to display properties.
Public Property | PropertyTabs | Gets the collection of property tabs that are displayed in the grid.
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | SelectedGridItem | Gets or sets the selected grid item.
Public Property | SelectedObject | Gets or sets the object for which the grid displays properties.
Public Property | SelectedObjects | Gets or sets the currently selected objects.
Public Property | SelectedTab | Gets the currently selected property tab.
Public Property | Site | Overridden.
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Overridden.
Public Property | ToolbarVisible | Gets or sets a value indicating whether the toolbar is visible.
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | ViewBackColor | Gets or sets a value indicating the background color in the grid.
Public Property | ViewForeColor | Gets or sets a value indicating the color of the text in the grid.
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | Overridden.
Protected Property | DefaultTabType | Gets the type of the default tab.
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | DrawFlatToolbar | Gets or sets a value indicating whether the PropertyGrid control paints its toolbar with flat buttons.
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Protected Property | ShowFocusCues |
Protected Property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl)
Top

Public Methods

 | Name | Description
Public Method | Add | (Inherited from ContainerControl)
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | CollapseAllGridItems | Collapses all the categories in the PropertyGrid.
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from ContainerControl)
Public Method | ExpandAllGridItems | Expands all the categories in the PropertyGrid.
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | Refresh | Causes the property grid to refresh it's view.
Public Method | RefreshTabs | Refreshes the property tabs of the specified scope.
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | Remove | (Inherited from ContainerControl)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | CreatePropertyTab | When overridden in a derived class, enables the creation of a PropertyTab.
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Control)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from ScrollableControl)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnNotifyPropertyValueUIItemsChanged | Raises the NotifyPropertyValueUIItemsChanged event.
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnPropertySortChanged | Raises the PropertySortChanged event.
Protected Method | OnPropertyTabChanged | Raises the PropertyTabChanged event.
Protected Method | OnPropertyValueChanged | Raises the PropertyValueChanged event.
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnSelectedGridItemChanged | Raises the SelectedGridItemChanged event.
Protected Method | OnSelectedObjectsChanged | Raises the SelectedObjectsChanged event.
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Control)
Protected Method | RenderAttributes | Renders the scrollable attribute (Inherited from ScrollableControl)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Overridden.
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | ShowEventsButton | Show or hide the events button.
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | PropertySortChanged | Occurs when the sort mode is changed.
Public Event | PropertyTabChanged | Occurs when a property tab changes.
Public Event | PropertyValueChanged | Occurs when a property value changes.
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | SelectedGridItemChanged | Occurs when the selected GridItem is changed.
Public Event | SelectedObjectsChanged | Occurs when the objects selected by the SelectedObjects property have changed.
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

PropertyGrid Class
Gizmox.WebGUI.Forms Namespace


PropertyGrid Constructor

[image]
Gizmox.WebGUI.Forms
PropertyGrid Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyGrid Class : PropertyGrid Constructor

Initializes a new instance of the PropertyGrid class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PropertyGrid()
C#
public PropertyGrid()
Managed Extensions for C++
public: PropertyGrid();
C++/CLI
public:
PropertyGrid();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyGrid Class
PropertyGrid Members


PropertyGrid Class Methods

[image]
Gizmox.WebGUI.Forms
PropertyGrid Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : PropertyGrid Class

For a list of all members of this type, see PropertyGrid members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from ContainerControl)
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | CollapseAllGridItems | Collapses all the categories in the PropertyGrid.
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from ContainerControl)
Public Method | ExpandAllGridItems | Expands all the categories in the PropertyGrid.
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | Refresh | Causes the property grid to refresh it's view.
Public Method | RefreshTabs | Refreshes the property tabs of the specified scope.
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | Remove | (Inherited from ContainerControl)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | CreatePropertyTab | When overridden in a derived class, enables the creation of a PropertyTab.
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Control)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from ScrollableControl)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnNotifyPropertyValueUIItemsChanged | Raises the NotifyPropertyValueUIItemsChanged event.
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnPropertySortChanged | Raises the PropertySortChanged event.
Protected Method | OnPropertyTabChanged | Raises the PropertyTabChanged event.
Protected Method | OnPropertyValueChanged | Raises the PropertyValueChanged event.
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnSelectedGridItemChanged | Raises the SelectedGridItemChanged event.
Protected Method | OnSelectedObjectsChanged | Raises the SelectedObjectsChanged event.
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Control)
Protected Method | RenderAttributes | Renders the scrollable attribute (Inherited from ScrollableControl)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Overridden.
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | ShowEventsButton | Show or hide the events button.
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

See Also

Reference

PropertyGrid Class
Gizmox.WebGUI.Forms Namespace


CollapseAllGridItems Method

[image]
Gizmox.WebGUI.Forms
CollapseAllGridItems Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyGrid Class : CollapseAllGridItems Method

Collapses all the categories in the PropertyGrid.

Syntax

Visual Basic (Declaration)
Public Sub CollapseAllGridItems()
Visual Basic (Usage) Copy Code
Dim instance As PropertyGrid

instance.CollapseAllGridItems()
C#
public void CollapseAllGridItems()
Managed Extensions for C++
public: void CollapseAllGridItems();
C++/CLI
public:
void CollapseAllGridItems();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyGrid Class
PropertyGrid Members


CreatePropertyTab Method

[image]
Gizmox.WebGUI.Forms
CreatePropertyTab Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyGrid Class : CreatePropertyTab Method

objTabType
The type of tab to create.
When overridden in a derived class, enables the creation of a PropertyTab.

Syntax

Visual Basic (Declaration)
Protected Overridable Function CreatePropertyTab( _
   ByVal objTabType As Type _
) As PropertyTab
Visual Basic (Usage) Copy Code
Dim instance As PropertyGrid
Dim objTabType As Type
Dim value As PropertyTab

value = instance.CreatePropertyTab(objTabType)
C#
protected virtual PropertyTab CreatePropertyTab(
   Type objTabType
)
Managed Extensions for C++
protected: virtual PropertyTab* CreatePropertyTab(
   Type* objTabType
)
C++/CLI
protected:
virtual PropertyTab^ CreatePropertyTab(
   Type^ objTabType
)

Parameters

objTabType
The type of tab to create.

Return Value

The newly created property tab. Returns null in its default implementation.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyGrid Class
PropertyGrid Members


ExpandAllGridItems Method

[image]
Gizmox.WebGUI.Forms
ExpandAllGridItems Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyGrid Class : ExpandAllGridItems Method

Expands all the categories in the PropertyGrid.

Syntax

Visual Basic (Declaration)
Public Sub ExpandAllGridItems()
Visual Basic (Usage) Copy Code
Dim instance As PropertyGrid

instance.ExpandAllGridItems()
C#
public void ExpandAllGridItems()
Managed Extensions for C++
public: void ExpandAllGridItems();
C++/CLI
public:
void ExpandAllGridItems();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyGrid Class
PropertyGrid Members


OnNotifyPropertyValueUIItemsChanged Method

[image]
Gizmox.WebGUI.Forms
OnNotifyPropertyValueUIItemsChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyGrid Class : OnNotifyPropertyValueUIItemsChanged Method

sender
The source of the event.
e
A EventArgs that contains the event data.
Raises the NotifyPropertyValueUIItemsChanged event.

Syntax

Visual Basic (Declaration)
Protected Sub OnNotifyPropertyValueUIItemsChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As PropertyGrid
Dim sender As Object
Dim e As EventArgs

instance.OnNotifyPropertyValueUIItemsChanged(sender, e)
C#
protected void OnNotifyPropertyValueUIItemsChanged(
   object sender,
   EventArgs e
)
Managed Extensions for C++
protected: void OnNotifyPropertyValueUIItemsChanged(
   Object* sender,
   EventArgs* e
)
C++/CLI
protected:
void OnNotifyPropertyValueUIItemsChanged(
   Object^ sender,
   EventArgs^ e
)

Parameters

sender
The source of the event.
e
A EventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyGrid Class
PropertyGrid Members


OnPropertySortChanged Method

[image]
Gizmox.WebGUI.Forms
OnPropertySortChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyGrid Class : OnPropertySortChanged Method

e
A EventArgs that contains the event data.
Raises the PropertySortChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnPropertySortChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As PropertyGrid
Dim e As EventArgs

instance.OnPropertySortChanged(e)
C#
protected virtual void OnPropertySortChanged(
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnPropertySortChanged(
   EventArgs* e
)
C++/CLI
protected:
virtual void OnPropertySortChanged(
   EventArgs^ e
)

Parameters

e
A EventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyGrid Class
PropertyGrid Members


OnPropertyTabChanged Method

[image]
Gizmox.WebGUI.Forms
OnPropertyTabChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyGrid Class : OnPropertyTabChanged Method

e
A PropertyTabChangedEventArgs that contains the event data.
Raises the PropertyTabChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnPropertyTabChanged( _
   ByVal e As PropertyTabChangedEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As PropertyGrid
Dim e As PropertyTabChangedEventArgs

instance.OnPropertyTabChanged(e)
C#
protected virtual void OnPropertyTabChanged(
   PropertyTabChangedEventArgs e
)
Managed Extensions for C++
protected: virtual void OnPropertyTabChanged(
   PropertyTabChangedEventArgs* e
)
C++/CLI
protected:
virtual void OnPropertyTabChanged(
   PropertyTabChangedEventArgs^ e
)

Parameters

e
A PropertyTabChangedEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyGrid Class
PropertyGrid Members


OnPropertyValueChanged Method

[image]
Gizmox.WebGUI.Forms
OnPropertyValueChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyGrid Class : OnPropertyValueChanged Method

e
A PropertyValueChangedEventArgs that contains the event data.
Raises the PropertyValueChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnPropertyValueChanged( _
   ByVal e As PropertyValueChangedEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As PropertyGrid
Dim e As PropertyValueChangedEventArgs

instance.OnPropertyValueChanged(e)
C#
protected virtual void OnPropertyValueChanged(
   PropertyValueChangedEventArgs e
)
Managed Extensions for C++
protected: virtual void OnPropertyValueChanged(
   PropertyValueChangedEventArgs* e
)
C++/CLI
protected:
virtual void OnPropertyValueChanged(
   PropertyValueChangedEventArgs^ e
)

Parameters

e
A PropertyValueChangedEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyGrid Class
PropertyGrid Members


OnSelectedGridItemChanged Method

[image]
Gizmox.WebGUI.Forms
OnSelectedGridItemChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyGrid Class : OnSelectedGridItemChanged Method

e
A SelectedGridItemChangedEventArgs that contains the event data.
Raises the SelectedGridItemChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnSelectedGridItemChanged( _
   ByVal e As SelectedGridItemChangedEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As PropertyGrid
Dim e As SelectedGridItemChangedEventArgs

instance.OnSelectedGridItemChanged(e)
C#
protected virtual void OnSelectedGridItemChanged(
   SelectedGridItemChangedEventArgs e
)
Managed Extensions for C++
protected: virtual void OnSelectedGridItemChanged(
   SelectedGridItemChangedEventArgs* e
)
C++/CLI
protected:
virtual void OnSelectedGridItemChanged(
   SelectedGridItemChangedEventArgs^ e
)

Parameters

e
A SelectedGridItemChangedEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyGrid Class
PropertyGrid Members


OnSelectedObjectsChanged Method

[image]
Gizmox.WebGUI.Forms
OnSelectedObjectsChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyGrid Class : OnSelectedObjectsChanged Method

e
An EventArgs that contains the event data.
Raises the SelectedObjectsChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnSelectedObjectsChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As PropertyGrid
Dim e As EventArgs

instance.OnSelectedObjectsChanged(e)
C#
protected virtual void OnSelectedObjectsChanged(
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnSelectedObjectsChanged(
   EventArgs* e
)
C++/CLI
protected:
virtual void OnSelectedObjectsChanged(
   EventArgs^ e
)

Parameters

e
An EventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyGrid Class
PropertyGrid Members


Refresh Method

[image]
Gizmox.WebGUI.Forms
Refresh Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyGrid Class : Refresh Method

Causes the property grid to refresh it's view.

Syntax

Visual Basic (Declaration)
Public Sub Refresh()
Visual Basic (Usage) Copy Code
Dim instance As PropertyGrid

instance.Refresh()
C#
public void Refresh()
Managed Extensions for C++
public: void Refresh();
C++/CLI
public:
void Refresh();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyGrid Class
PropertyGrid Members


RefreshTabs Method

[image]
Gizmox.WebGUI.Forms
RefreshTabs Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyGrid Class : RefreshTabs Method

objPropertyTabScope
Either the Component or Document value of PropertyTabScope.
Refreshes the property tabs of the specified scope.

Syntax

Visual Basic (Declaration)
Public Sub RefreshTabs( _
   ByVal objPropertyTabScope As PropertyTabScope _
)
Visual Basic (Usage) Copy Code
Dim instance As PropertyGrid
Dim objPropertyTabScope As PropertyTabScope

instance.RefreshTabs(objPropertyTabScope)
C#
public void RefreshTabs(
   PropertyTabScope objPropertyTabScope
)
Managed Extensions for C++
public: void RefreshTabs(
   PropertyTabScope objPropertyTabScope
)
C++/CLI
public:
void RefreshTabs(
   PropertyTabScope objPropertyTabScope
)

Parameters

objPropertyTabScope
Either the Component or Document value of PropertyTabScope.

Exceptions

Exception | Description
ArgumentException | The objPropertyTabScope parameter is not the Component or Document value of PropertyTabScope.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyGrid Class
PropertyGrid Members


RenderControl Method

[image]
Gizmox.WebGUI.Forms
RenderControl Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyGrid Class : RenderControl Method

objContext
objWriter
lngRequestID

Syntax

Visual Basic (Declaration)
Protected Overrides Sub RenderControl( _
   ByVal objContext As IContext, _
   ByVal objWriter As IResponseWriter, _
   ByVal lngRequestID As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As PropertyGrid
Dim objContext As IContext
Dim objWriter As IResponseWriter
Dim lngRequestID As Long

instance.RenderControl(objContext, objWriter, lngRequestID)
C#
protected override void RenderControl(
   IContext objContext,
   IResponseWriter objWriter,
   long lngRequestID
)
Managed Extensions for C++
protected: void RenderControl(
   IContext* objContext,
   IResponseWriter* objWriter,
   long lngRequestID
) override
C++/CLI
protected:
void RenderControl(
   IContext^ objContext,
   IResponseWriter^ objWriter,
   long long lngRequestID
) override

Parameters

objContext
objWriter
lngRequestID

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyGrid Class
PropertyGrid Members


ShowEventsButton Method

[image]
Gizmox.WebGUI.Forms
ShowEventsButton Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyGrid Class : ShowEventsButton Method

blnValue
Show or hide the events button.

Syntax

Visual Basic (Declaration)
Protected Sub ShowEventsButton( _
   ByVal blnValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As PropertyGrid
Dim blnValue As Boolean

instance.ShowEventsButton(blnValue)
C#
protected void ShowEventsButton(
   bool blnValue
)
Managed Extensions for C++
protected: void ShowEventsButton(
   bool blnValue
)
C++/CLI
protected:
void ShowEventsButton(
   bool blnValue
)

Parameters

blnValue

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyGrid Class
PropertyGrid Members


PropertyGrid Class Properties

[image]
Gizmox.WebGUI.Forms
PropertyGrid Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : PropertyGrid Class

For a list of all members of this type, see PropertyGrid members.

Public Properties

 | Name | Description
Public Property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl)
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from ContainerControl)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | BrowsableAttributes | Gets or sets the browsable attributes associated with the object that the property grid is attached to.
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | CanShowCommands | Gets a value indicating whether the commands pane can be made visible for the currently selected objects.
Public Property | CategoryForeColor | Gets or sets the text color used for category headings.
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CommandsVisible | Gets a value indicating whether the commands pane is visible.
Public Property | CommandsVisibleIfAvailable | Gets or sets a value indicating whether the commands pane is visible for objects that expose verbs.
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Components | (Inherited from ContainerControl)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | HelpBackColor | Gets or sets the background color for the Help region.
Public Property | HelpForeColor | Gets or sets the foreground color for the Help region.
Public Property | HelpVisible | Gets or sets a value indicating whether the Help text is visible.
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | LargeButtons | Gets or sets a value indicating whether buttons appear in standard size or in large size.
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | LineColor | Gets or sets the color of the gridlines and borders.
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | PropertySort | Gets or sets the type of sorting the PropertyGrid uses to display properties.
Public Property | PropertyTabs | Gets the collection of property tabs that are displayed in the grid.
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | SelectedGridItem | Gets or sets the selected grid item.
Public Property | SelectedObject | Gets or sets the object for which the grid displays properties.
Public Property | SelectedObjects | Gets or sets the currently selected objects.
Public Property | SelectedTab | Gets the currently selected property tab.
Public Property | Site | Overridden.
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Overridden.
Public Property | ToolbarVisible | Gets or sets a value indicating whether the toolbar is visible.
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | ViewBackColor | Gets or sets a value indicating the background color in the grid.
Public Property | ViewForeColor | Gets or sets a value indicating the color of the text in the grid.
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | Overridden.
Protected Property | DefaultTabType | Gets the type of the default tab.
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | DrawFlatToolbar | Gets or sets a value indicating whether the PropertyGrid control paints its toolbar with flat buttons.
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Protected Property | ShowFocusCues |
Protected Property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl)
Top

See Also

Reference

PropertyGrid Class
Gizmox.WebGUI.Forms Namespace


BrowsableAttributes Property

[image]
Gizmox.WebGUI.Forms
BrowsableAttributes Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyGrid Class : BrowsableAttributes Property

Gets or sets the browsable attributes associated with the object that the property grid is attached to.

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Property BrowsableAttributes As AttributeCollection
Visual Basic (Usage) Copy Code
Dim instance As PropertyGrid
Dim value As AttributeCollection

instance.BrowsableAttributes = value

value = instance.BrowsableAttributes
C#
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public AttributeCollection BrowsableAttributes {get; set;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: __property AttributeCollection* get_BrowsableAttributes();
public: __property void set_BrowsableAttributes(
   AttributeCollection* value
);
C++/CLI
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
property AttributeCollection^ BrowsableAttributes {
   AttributeCollection^ get();
   void set (AttributeCollection^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyGrid Class
PropertyGrid Members


CanShowCommands Property

[image]
Gizmox.WebGUI.Forms
CanShowCommands Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyGrid Class : CanShowCommands Property

Gets a value indicating whether the commands pane can be made visible for the currently selected objects.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<SRDescriptionAttribute("Sets whether the commands window will be displayed for components with commands.")>
Public Overridable ReadOnly Property CanShowCommands As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PropertyGrid
Dim value As Boolean

value = instance.CanShowCommands
C#
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRDescriptionAttribute("Sets whether the commands window will be displayed for components with commands.")]
public virtual bool CanShowCommands {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRDescriptionAttribute("Sets whether the commands window will be displayed for components with commands.")]
public: __property virtual bool get_CanShowCommands();
C++/CLI
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRDescriptionAttribute("Sets whether the commands window will be displayed for components with commands.")]
public:
virtual property bool CanShowCommands {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyGrid Class
PropertyGrid Members


CategoryForeColor Property

[image]
Gizmox.WebGUI.Forms
CategoryForeColor Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyGrid Class : CategoryForeColor Property

Gets or sets the text color used for category headings.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Appearance")>
<SRDescriptionAttribute("The text color used for category headings. The background color is determined by the LineColor property.")>
<DefaultValueAttribute()>
Public Property CategoryForeColor As Color
Visual Basic (Usage) Copy Code
Dim instance As PropertyGrid
Dim value As Color

instance.CategoryForeColor = value

value = instance.CategoryForeColor
C#
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("The text color used for category headings. The background color is determined by the LineColor property.")]
[DefaultValueAttribute()]
public Color CategoryForeColor {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("The text color used for category headings. The background color is determined by the LineColor property.")]
[DefaultValueAttribute()]
public: __property Color get_CategoryForeColor();
public: __property void set_CategoryForeColor(
   Color value
);
C++/CLI
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("The text color used for category headings. The background color is determined by the LineColor property.")]
[DefaultValueAttribute()]
public:
property Color CategoryForeColor {
   Color get();
   void set (Colorvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyGrid Class
PropertyGrid Members


CommandsVisible Property

[image]
Gizmox.WebGUI.Forms
CommandsVisible Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyGrid Class : CommandsVisible Property

Gets a value indicating whether the commands pane is visible.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Overridable ReadOnly Property CommandsVisible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PropertyGrid
Dim value As Boolean

value = instance.CommandsVisible
C#
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public virtual bool CommandsVisible {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: __property virtual bool get_CommandsVisible();
C++/CLI
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
virtual property bool CommandsVisible {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyGrid Class
PropertyGrid Members


CommandsVisibleIfAvailable Property

[image]
Gizmox.WebGUI.Forms
CommandsVisibleIfAvailable Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyGrid Class : CommandsVisibleIfAvailable Property

Gets or sets a value indicating whether the commands pane is visible for objects that expose verbs.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Appearance")>
<SRDescriptionAttribute("Show the commands pane if the selected object exposes verbs.")>
<DefaultValueAttribute()>
Public Overridable Property CommandsVisibleIfAvailable As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PropertyGrid
Dim value As Boolean

instance.CommandsVisibleIfAvailable = value

value = instance.CommandsVisibleIfAvailable
C#
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Show the commands pane if the selected object exposes verbs.")]
[DefaultValueAttribute()]
public virtual bool CommandsVisibleIfAvailable {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Show the commands pane if the selected object exposes verbs.")]
[DefaultValueAttribute()]
public: __property virtual bool get_CommandsVisibleIfAvailable();
public: __property virtual void set_CommandsVisibleIfAvailable(
   bool value
);
C++/CLI
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Show the commands pane if the selected object exposes verbs.")]
[DefaultValueAttribute()]
public:
virtual property bool CommandsVisibleIfAvailable {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyGrid Class
PropertyGrid Members


DefaultSize Property

[image]
Gizmox.WebGUI.Forms
DefaultSize Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyGrid Class : DefaultSize Property

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property DefaultSize As Size
Visual Basic (Usage) Copy Code
Dim instance As PropertyGrid
Dim value As Size

value = instance.DefaultSize
C#
protected override Size DefaultSize {get;}
Managed Extensions for C++
protected: __property Size get_DefaultSize() override;
C++/CLI
protected:
property Size DefaultSize {
   Size get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyGrid Class
PropertyGrid Members


DefaultTabType Property

[image]
Gizmox.WebGUI.Forms
DefaultTabType Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyGrid Class : DefaultTabType Property

Gets the type of the default tab.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<DesignerSerializationVisibilityAttribute()>
Protected Overridable ReadOnly Property DefaultTabType As Type
Visual Basic (Usage) Copy Code
Dim instance As PropertyGrid
Dim value As Type

value = instance.DefaultTabType
C#
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[DesignerSerializationVisibilityAttribute()]
protected virtual Type DefaultTabType {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[DesignerSerializationVisibilityAttribute()]
protected: __property virtual Type* get_DefaultTabType();
C++/CLI
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[DesignerSerializationVisibilityAttribute()]
protected:
virtual property Type^ DefaultTabType {
   Type^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyGrid Class
PropertyGrid Members


DrawFlatToolbar Property

[image]
Gizmox.WebGUI.Forms
DrawFlatToolbar Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyGrid Class : DrawFlatToolbar Property

Gets or sets a value indicating whether the PropertyGrid control paints its toolbar with flat buttons.

Syntax

Visual Basic (Declaration)
Protected Property DrawFlatToolbar As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PropertyGrid
Dim value As Boolean

instance.DrawFlatToolbar = value

value = instance.DrawFlatToolbar
C#
protected bool DrawFlatToolbar {get; set;}
Managed Extensions for C++
protected: __property bool get_DrawFlatToolbar();
protected: __property void set_DrawFlatToolbar(
   bool value
);
C++/CLI
protected:
property bool DrawFlatToolbar {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyGrid Class
PropertyGrid Members


HelpBackColor Property

[image]
Gizmox.WebGUI.Forms
HelpBackColor Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyGrid Class : HelpBackColor Property

Gets or sets the background color for the Help region.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Appearance")>
<SRDescriptionAttribute("The background color of the description pane.")>
<DefaultValueAttribute()>
Public Property HelpBackColor As Color
Visual Basic (Usage) Copy Code
Dim instance As PropertyGrid
Dim value As Color

instance.HelpBackColor = value

value = instance.HelpBackColor
C#
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("The background color of the description pane.")]
[DefaultValueAttribute()]
public Color HelpBackColor {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("The background color of the description pane.")]
[DefaultValueAttribute()]
public: __property Color get_HelpBackColor();
public: __property void set_HelpBackColor(
   Color value
);
C++/CLI
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("The background color of the description pane.")]
[DefaultValueAttribute()]
public:
property Color HelpBackColor {
   Color get();
   void set (Colorvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyGrid Class
PropertyGrid Members


HelpForeColor Property

[image]
Gizmox.WebGUI.Forms
HelpForeColor Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyGrid Class : HelpForeColor Property

Gets or sets the foreground color for the Help region.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("The foreground color of the description pane.")>
<DefaultValueAttribute()>
<SRCategoryAttribute("Appearance")>
Public Property HelpForeColor As Color
Visual Basic (Usage) Copy Code
Dim instance As PropertyGrid
Dim value As Color

instance.HelpForeColor = value

value = instance.HelpForeColor
C#
[SRDescriptionAttribute("The foreground color of the description pane.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
public Color HelpForeColor {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("The foreground color of the description pane.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
public: __property Color get_HelpForeColor();
public: __property void set_HelpForeColor(
   Color value
);
C++/CLI
[SRDescriptionAttribute("The foreground color of the description pane.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
public:
property Color HelpForeColor {
   Color get();
   void set (Colorvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyGrid Class
PropertyGrid Members


HelpVisible Property

[image]
Gizmox.WebGUI.Forms
HelpVisible Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyGrid Class : HelpVisible Property

Gets or sets a value indicating whether the Help text is visible.

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
<SRCategoryAttribute("Appearance")>
<DefaultValueAttribute()>
<LocalizableAttribute(True)>
<SRDescriptionAttribute("Sets whether to show the description pane.")>
Public Overridable Property HelpVisible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PropertyGrid
Dim value As Boolean

instance.HelpVisible = value

value = instance.HelpVisible
C#
[DesignerSerializationVisibilityAttribute()]
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
[LocalizableAttribute(true)]
[SRDescriptionAttribute("Sets whether to show the description pane.")]
public virtual bool HelpVisible {get; set;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
[LocalizableAttribute(true)]
[SRDescriptionAttribute("Sets whether to show the description pane.")]
public: __property virtual bool get_HelpVisible();
public: __property virtual void set_HelpVisible(
   bool value
);
C++/CLI
[DesignerSerializationVisibilityAttribute()]
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
[LocalizableAttribute(true)]
[SRDescriptionAttribute("Sets whether to show the description pane.")]
public:
virtual property bool HelpVisible {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyGrid Class
PropertyGrid Members


LargeButtons Property

[image]
Gizmox.WebGUI.Forms
LargeButtons Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyGrid Class : LargeButtons Property

Gets or sets a value indicating whether buttons appear in standard size or in large size.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Appearance")>
<DefaultValueAttribute()>
<SRDescriptionAttribute("Sets buttons to large (32x32) on the PropertyGrid tool bar.")>
Public Property LargeButtons As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PropertyGrid
Dim value As Boolean

instance.LargeButtons = value

value = instance.LargeButtons
C#
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Sets buttons to large (32x32) on the PropertyGrid tool bar.")]
public bool LargeButtons {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Sets buttons to large (32x32) on the PropertyGrid tool bar.")]
public: __property bool get_LargeButtons();
public: __property void set_LargeButtons(
   bool value
);
C++/CLI
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Sets buttons to large (32x32) on the PropertyGrid tool bar.")]
public:
property bool LargeButtons {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyGrid Class
PropertyGrid Members


LineColor Property

[image]
Gizmox.WebGUI.Forms
LineColor Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyGrid Class : LineColor Property

Gets or sets the color of the gridlines and borders.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Sets the color of the borders and grid lines within the grid area.")>
<DefaultValueAttribute()>
<SRCategoryAttribute("Appearance")>
Public Property LineColor As Color
Visual Basic (Usage) Copy Code
Dim instance As PropertyGrid
Dim value As Color

instance.LineColor = value

value = instance.LineColor
C#
[SRDescriptionAttribute("Sets the color of the borders and grid lines within the grid area.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
public Color LineColor {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Sets the color of the borders and grid lines within the grid area.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
public: __property Color get_LineColor();
public: __property void set_LineColor(
   Color value
);
C++/CLI
[SRDescriptionAttribute("Sets the color of the borders and grid lines within the grid area.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
public:
property Color LineColor {
   Color get();
   void set (Colorvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyGrid Class
PropertyGrid Members


PropertySort Property

[image]
Gizmox.WebGUI.Forms
PropertySort Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyGrid Class : PropertySort Property

Gets or sets the type of sorting the PropertyGrid uses to display properties.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Appearance")>
<DefaultValueAttribute()>
<SRDescriptionAttribute("Sets the type of sorting that the PropertyGrid will use to display properties.")>
Public Property PropertySort As PropertySort
Visual Basic (Usage) Copy Code
Dim instance As PropertyGrid
Dim value As PropertySort

instance.PropertySort = value

value = instance.PropertySort
C#
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Sets the type of sorting that the PropertyGrid will use to display properties.")]
public PropertySort PropertySort {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Sets the type of sorting that the PropertyGrid will use to display properties.")]
public: __property PropertySort get_PropertySort();
public: __property void set_PropertySort(
   PropertySort value
);
C++/CLI
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Sets the type of sorting that the PropertyGrid will use to display properties.")]
public:
property PropertySort PropertySort {
   PropertySort get();
   void set (PropertySortvalue);
}

Exceptions

Exception | Description
InvalidEnumArgumentException | The assigned value is not one of the PropertySort values.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyGrid Class
PropertyGrid Members


PropertyTabs Property

[image]
Gizmox.WebGUI.Forms
PropertyTabs Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyGrid Class : PropertyTabs Property

Gets the collection of property tabs that are displayed in the grid.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public ReadOnly Property PropertyTabs As PropertyGrid.PropertyTabCollection
Visual Basic (Usage) Copy Code
Dim instance As PropertyGrid
Dim value As PropertyGrid.PropertyTabCollection

value = instance.PropertyTabs
C#
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public PropertyGrid.PropertyTabCollection PropertyTabs {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: __property PropertyGrid.PropertyTabCollection* get_PropertyTabs();
C++/CLI
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
property PropertyGrid::PropertyTabCollection^ PropertyTabs {
   PropertyGrid::PropertyTabCollection^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyGrid Class
PropertyGrid Members


SelectedGridItem Property

[image]
Gizmox.WebGUI.Forms
SelectedGridItem Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyGrid Class : SelectedGridItem Property

Gets or sets the selected grid item.

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public Property SelectedGridItem As GridItem
Visual Basic (Usage) Copy Code
Dim instance As PropertyGrid
Dim value As GridItem

instance.SelectedGridItem = value

value = instance.SelectedGridItem
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public GridItem SelectedGridItem {get; set;}
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property GridItem* get_SelectedGridItem();
public: __property void set_SelectedGridItem(
   GridItem* value
);
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
property GridItem^ SelectedGridItem {
   GridItem^ get();
   void set (GridItem^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyGrid Class
PropertyGrid Members


SelectedObject Property

[image]
Gizmox.WebGUI.Forms
SelectedObject Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyGrid Class : SelectedObject Property

Gets or sets the object for which the grid displays properties.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Behavior")>
<DefaultValueAttribute()>
<TypeConverterAttribute("Gizmox.WebGUI.Forms.PropertyGrid+SelectedObjectConverter, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d")>
<SRDescriptionAttribute("Sets the currently selected object that the grid will browse.")>
Public Property SelectedObject As Object
Visual Basic (Usage) Copy Code
Dim instance As PropertyGrid
Dim value As Object

instance.SelectedObject = value

value = instance.SelectedObject
C#
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[TypeConverterAttribute("Gizmox.WebGUI.Forms.PropertyGrid+SelectedObjectConverter, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d")]
[SRDescriptionAttribute("Sets the currently selected object that the grid will browse.")]
public object SelectedObject {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[TypeConverterAttribute("Gizmox.WebGUI.Forms.PropertyGrid+SelectedObjectConverter, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d")]
[SRDescriptionAttribute("Sets the currently selected object that the grid will browse.")]
public: __property Object* get_SelectedObject();
public: __property void set_SelectedObject(
   Object* value
);
C++/CLI
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[TypeConverterAttribute("Gizmox.WebGUI.Forms.PropertyGrid+SelectedObjectConverter, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d")]
[SRDescriptionAttribute("Sets the currently selected object that the grid will browse.")]
public:
property Object^ SelectedObject {
   Object^ get();
   void set (Object^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyGrid Class
PropertyGrid Members


SelectedObjects Property

[image]
Gizmox.WebGUI.Forms
SelectedObjects Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyGrid Class : SelectedObjects Property

Gets or sets the currently selected objects.

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
Public Property SelectedObjects As Object()
Visual Basic (Usage) Copy Code
Dim instance As PropertyGrid
Dim value() As Object

instance.SelectedObjects = value

value = instance.SelectedObjects
C#
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public object[] SelectedObjects {get; set;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public: __property Object*[]* get_SelectedObjects();
public: __property void set_SelectedObjects(
   Object*[]* value
);
C++/CLI
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public:
property array<Object^>^ SelectedObjects {
   array<Object^>^ get();
   void set (Object^array<value>^value);
}

Exceptions

Exception | Description
ArgumentException | One of the items in the array of objects had a null value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyGrid Class
PropertyGrid Members


SelectedTab Property

[image]
Gizmox.WebGUI.Forms
SelectedTab Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyGrid Class : SelectedTab Property

Gets the currently selected property tab.

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<BrowsableAttribute(False)>
Public ReadOnly Property SelectedTab As PropertyTab
Visual Basic (Usage) Copy Code
Dim instance As PropertyGrid
Dim value As PropertyTab

value = instance.SelectedTab
C#
[DesignerSerializationVisibilityAttribute()]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[BrowsableAttribute(false)]
public PropertyTab SelectedTab {get;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[BrowsableAttribute(false)]
public: __property PropertyTab* get_SelectedTab();
C++/CLI
[DesignerSerializationVisibilityAttribute()]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[BrowsableAttribute(false)]
public:
property PropertyTab^ SelectedTab {
   PropertyTab^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyGrid Class
PropertyGrid Members


ShowFocusCues Property

[image]
Gizmox.WebGUI.Forms
ShowFocusCues Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyGrid Class : ShowFocusCues Property

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property ShowFocusCues As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PropertyGrid
Dim value As Boolean

value = instance.ShowFocusCues
C#
protected bool ShowFocusCues {get;}
Managed Extensions for C++
protected: __property bool get_ShowFocusCues();
C++/CLI
protected:
property bool ShowFocusCues {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyGrid Class
PropertyGrid Members


Site Property

[image]
Gizmox.WebGUI.Forms
Site Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyGrid Class : Site Property

Syntax

Visual Basic (Declaration)
Public Overrides Property Site As ISite
Visual Basic (Usage) Copy Code
Dim instance As PropertyGrid
Dim value As ISite

instance.Site = value

value = instance.Site
C#
public override ISite Site {get; set;}
Managed Extensions for C++
public: __property ISite* get_Site() override;
public: __property void set_Site(
   ISite* value
) override;
C++/CLI
public:
property ISite^ Site {
   ISite^ get() override;
   void set (ISite^value) override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyGrid Class
PropertyGrid Members


Text Property

[image]
Gizmox.WebGUI.Forms
Text Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyGrid Class : Text Property

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
Public Overrides Property Text As String
Visual Basic (Usage) Copy Code
Dim instance As PropertyGrid
Dim value As String

instance.Text = value

value = instance.Text
C#
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public override string Text {get; set;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public: __property string* get_Text() override;
public: __property void set_Text(
   string* value
) override;
C++/CLI
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public:
property String^ Text {
   String^ get() override;
   void set (String^value) override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyGrid Class
PropertyGrid Members


ToolbarVisible Property

[image]
Gizmox.WebGUI.Forms
ToolbarVisible Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyGrid Class : ToolbarVisible Property

Gets or sets a value indicating whether the toolbar is visible.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Appearance")>
<SRDescriptionAttribute("Sets whether to display the ToolBar at the top of the PropertyGrid.")>
<DefaultValueAttribute()>
Public Overridable Property ToolbarVisible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PropertyGrid
Dim value As Boolean

instance.ToolbarVisible = value

value = instance.ToolbarVisible
C#
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Sets whether to display the ToolBar at the top of the PropertyGrid.")]
[DefaultValueAttribute()]
public virtual bool ToolbarVisible {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Sets whether to display the ToolBar at the top of the PropertyGrid.")]
[DefaultValueAttribute()]
public: __property virtual bool get_ToolbarVisible();
public: __property virtual void set_ToolbarVisible(
   bool value
);
C++/CLI
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Sets whether to display the ToolBar at the top of the PropertyGrid.")]
[DefaultValueAttribute()]
public:
virtual property bool ToolbarVisible {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyGrid Class
PropertyGrid Members


ViewBackColor Property

[image]
Gizmox.WebGUI.Forms
ViewBackColor Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyGrid Class : ViewBackColor Property

Gets or sets a value indicating the background color in the grid.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<SRCategoryAttribute("Appearance")>
<SRDescriptionAttribute("Sets the background color of the grid area.")>
Public Property ViewBackColor As Color
Visual Basic (Usage) Copy Code
Dim instance As PropertyGrid
Dim value As Color

instance.ViewBackColor = value

value = instance.ViewBackColor
C#
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Sets the background color of the grid area.")]
public Color ViewBackColor {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Sets the background color of the grid area.")]
public: __property Color get_ViewBackColor();
public: __property void set_ViewBackColor(
   Color value
);
C++/CLI
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Sets the background color of the grid area.")]
public:
property Color ViewBackColor {
   Color get();
   void set (Colorvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyGrid Class
PropertyGrid Members


ViewForeColor Property

[image]
Gizmox.WebGUI.Forms
ViewForeColor Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyGrid Class : ViewForeColor Property

Gets or sets a value indicating the color of the text in the grid.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<SRCategoryAttribute("Appearance")>
<SRDescriptionAttribute("Sets the foreground color of the grid area.")>
Public Property ViewForeColor As Color
Visual Basic (Usage) Copy Code
Dim instance As PropertyGrid
Dim value As Color

instance.ViewForeColor = value

value = instance.ViewForeColor
C#
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Sets the foreground color of the grid area.")]
public Color ViewForeColor {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Sets the foreground color of the grid area.")]
public: __property Color get_ViewForeColor();
public: __property void set_ViewForeColor(
   Color value
);
C++/CLI
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Sets the foreground color of the grid area.")]
public:
property Color ViewForeColor {
   Color get();
   void set (Colorvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyGrid Class
PropertyGrid Members


PropertyGrid Class Events

[image]
Gizmox.WebGUI.Forms
PropertyGrid Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : PropertyGrid Class

For a list of all members of this type, see PropertyGrid members.

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | PropertySortChanged | Occurs when the sort mode is changed.
Public Event | PropertyTabChanged | Occurs when a property tab changes.
Public Event | PropertyValueChanged | Occurs when a property value changes.
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | SelectedGridItemChanged | Occurs when the selected GridItem is changed.
Public Event | SelectedObjectsChanged | Occurs when the objects selected by the SelectedObjects property have changed.
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

PropertyGrid Class
Gizmox.WebGUI.Forms Namespace


PropertySortChanged Event

[image]
Gizmox.WebGUI.Forms
PropertySortChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyGrid Class : PropertySortChanged Event

Occurs when the sort mode is changed.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the PropertySort property on the PropertyGrid has changed.")>
<SRCategoryAttribute("Property Changed")>
Public Event PropertySortChanged() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As PropertyGrid
Dim handler As EventHandler

AddHandler instance.PropertySortChanged, handler
C#
[SRDescriptionAttribute("Occurs when the PropertySort property on the PropertyGrid has changed.")]
[SRCategoryAttribute("Property Changed")]
public event EventHandler PropertySortChanged()
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the PropertySort property on the PropertyGrid has changed.")]
[SRCategoryAttribute("Property Changed")]
public: __event EventHandler* PropertySortChanged
C++/CLI
[SRDescriptionAttribute("Occurs when the PropertySort property on the PropertyGrid has changed.")]
[SRCategoryAttribute("Property Changed")]
public:
event EventHandler^ PropertySortChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyGrid Class
PropertyGrid Members


PropertyTabChanged Event

[image]
Gizmox.WebGUI.Forms
PropertyTabChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyGrid Class : PropertyTabChanged Event

Occurs when a property tab changes.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when a property tab changes.")>
<SRCategoryAttribute("Property Changed")>
Public Event PropertyTabChanged() As PropertyTabChangedEventHandler
Visual Basic (Usage) Copy Code
Dim instance As PropertyGrid
Dim handler As PropertyTabChangedEventHandler

AddHandler instance.PropertyTabChanged, handler
C#
[SRDescriptionAttribute("Occurs when a property tab changes.")]
[SRCategoryAttribute("Property Changed")]
public event PropertyTabChangedEventHandler PropertyTabChanged()
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when a property tab changes.")]
[SRCategoryAttribute("Property Changed")]
public: __event PropertyTabChangedEventHandler* PropertyTabChanged
C++/CLI
[SRDescriptionAttribute("Occurs when a property tab changes.")]
[SRCategoryAttribute("Property Changed")]
public:
event PropertyTabChangedEventHandler^ PropertyTabChanged

Event Data

The event handler receives an argument of type PropertyTabChangedEventArgs containing data related to this event. The following PropertyTabChangedEventArgs properties provide information specific to this event.

Property | Description
NewTab | Gets the new PropertyTab selected.
OldTab | Gets the old PropertyTab selected.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyGrid Class
PropertyGrid Members


PropertyValueChanged Event

[image]
Gizmox.WebGUI.Forms
PropertyValueChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyGrid Class : PropertyValueChanged Event

Occurs when a property value changes.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when a property value changes.")>
<SRCategoryAttribute("Property Changed")>
Public Event PropertyValueChanged() As PropertyValueChangedEventHandler
Visual Basic (Usage) Copy Code
Dim instance As PropertyGrid
Dim handler As PropertyValueChangedEventHandler

AddHandler instance.PropertyValueChanged, handler
C#
[SRDescriptionAttribute("Occurs when a property value changes.")]
[SRCategoryAttribute("Property Changed")]
public event PropertyValueChangedEventHandler PropertyValueChanged()
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when a property value changes.")]
[SRCategoryAttribute("Property Changed")]
public: __event PropertyValueChangedEventHandler* PropertyValueChanged
C++/CLI
[SRDescriptionAttribute("Occurs when a property value changes.")]
[SRCategoryAttribute("Property Changed")]
public:
event PropertyValueChangedEventHandler^ PropertyValueChanged

Event Data

The event handler receives an argument of type PropertyValueChangedEventArgs containing data related to this event. The following PropertyValueChangedEventArgs properties provide information specific to this event.

Property | Description
ChangedItem | Gets the GridItem that was changed.
OldValue | The value of the grid item before it was changed.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyGrid Class
PropertyGrid Members


SelectedGridItemChanged Event

[image]
Gizmox.WebGUI.Forms
SelectedGridItemChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyGrid Class : SelectedGridItemChanged Event

Occurs when the selected GridItem is changed.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Property Changed")>
<SRDescriptionAttribute("Occurs when the selected grid item has changed.")>
Public Event SelectedGridItemChanged() As SelectedGridItemChangedEventHandler
Visual Basic (Usage) Copy Code
Dim instance As PropertyGrid
Dim handler As SelectedGridItemChangedEventHandler

AddHandler instance.SelectedGridItemChanged, handler
C#
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when the selected grid item has changed.")]
public event SelectedGridItemChangedEventHandler SelectedGridItemChanged()
Managed Extensions for C++
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when the selected grid item has changed.")]
public: __event SelectedGridItemChangedEventHandler* SelectedGridItemChanged
C++/CLI
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when the selected grid item has changed.")]
public:
event SelectedGridItemChangedEventHandler^ SelectedGridItemChanged

Event Data

The event handler receives an argument of type SelectedGridItemChangedEventArgs containing data related to this event. The following SelectedGridItemChangedEventArgs properties provide information specific to this event.

Property | Description
NewSelection | Gets the newly selected GridItem.
OldSelection | Gets the previously selected GridItem.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyGrid Class
PropertyGrid Members


SelectedObjectsChanged Event

[image]
Gizmox.WebGUI.Forms
SelectedObjectsChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyGrid Class : SelectedObjectsChanged Event

Occurs when the objects selected by the SelectedObjects property have changed.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Property Changed")>
<SRDescriptionAttribute("Occurs when the SelectedObjects property has changed.")>
Public Event SelectedObjectsChanged() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As PropertyGrid
Dim handler As EventHandler

AddHandler instance.SelectedObjectsChanged, handler
C#
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when the SelectedObjects property has changed.")]
public event EventHandler SelectedObjectsChanged()
Managed Extensions for C++
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when the SelectedObjects property has changed.")]
public: __event EventHandler* SelectedObjectsChanged
C++/CLI
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when the SelectedObjects property has changed.")]
public:
event EventHandler^ SelectedObjectsChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyGrid Class
PropertyGrid Members


PropertyGrid.PropertyTabCollection Class

[image]
Gizmox.WebGUI.Forms
PropertyGrid.PropertyTabCollection Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : PropertyGrid.PropertyTabCollection Class

Contains a collection of PropertyTab objects.

Object Model

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
<PermissionSetAttribute(File="",
   UnicodeEncoded=False,
   Name="FullTrust",
   XML="",
   Hex="",
   Unrestricted=False)>
Public Class PropertyGrid.PropertyTabCollection
Visual Basic (Usage) Copy Code
Dim instance As PropertyGrid.PropertyTabCollection
C#
[DefaultMemberAttribute("Item")]
[PermissionSetAttribute(File="",
   UnicodeEncoded=false,
   Name="FullTrust",
   XML="",
   Hex="",
   Unrestricted=false)]
public class PropertyGrid.PropertyTabCollection
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
[PermissionSetAttribute(File="",
   UnicodeEncoded=false,
   Name="FullTrust",
   XML="",
   Hex="",
   Unrestricted=false)]
public __gc class PropertyGrid.PropertyTabCollection
C++/CLI
[DefaultMemberAttribute("Item")]
[PermissionSetAttribute(File="",
   UnicodeEncoded=false,
   Name="FullTrust",
   XML="",
   Hex="",
   Unrestricted=false)]
public ref class PropertyGrid.PropertyTabCollection

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.PropertyGrid.PropertyTabCollection

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

PropertyGrid.PropertyTabCollection Members
Gizmox.WebGUI.Forms Namespace


PropertyGrid.PropertyTabCollection Class Members

[image]
Gizmox.WebGUI.Forms
PropertyGrid.PropertyTabCollection Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : PropertyGrid.PropertyTabCollection Class

The following tables list the members exposed by PropertyGrid.PropertyTabCollection.

Public Properties

 | Name | Description
Public Property | Count | Gets the number of Property tabs in the collection.
Public Property | Item | Gets the PropertyTab at the specified index.
Top

Public Methods

 | Name | Description
Public Method | AddTabType | Overloaded. Adds a Property tab of the specified type to the collection.
Public Method | Clear | Removes all the Property tabs of the specified scope from the collection.
Public Method | GetEnumerator | Returns an enumeration of all the Property tabs in the collection.
Public Method | RemoveTabType | Removes the specified tab type from the collection.
Top

See Also

Reference

PropertyGrid.PropertyTabCollection Class
Gizmox.WebGUI.Forms Namespace


PropertyGrid.PropertyTabCollection Class Methods

[image]
Gizmox.WebGUI.Forms
PropertyGrid.PropertyTabCollection Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : PropertyGrid.PropertyTabCollection Class

For a list of all members of this type, see PropertyGrid.PropertyTabCollection members.

Public Methods

 | Name | Description
Public Method | AddTabType | Overloaded. Adds a Property tab of the specified type to the collection.
Public Method | Clear | Removes all the Property tabs of the specified scope from the collection.
Public Method | GetEnumerator | Returns an enumeration of all the Property tabs in the collection.
Public Method | RemoveTabType | Removes the specified tab type from the collection.
Top

See Also

Reference

PropertyGrid.PropertyTabCollection Class
Gizmox.WebGUI.Forms Namespace


AddTabType Method

[image]
Gizmox.WebGUI.Forms
AddTabType Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyGrid.PropertyTabCollection Class : AddTabType Method

Adds a Property tab of the specified type to the collection.

Overload List

Overload | Description
AddTabType(Type) | Adds a Property tab of the specified type to the collection.
AddTabType(Type,PropertyTabScope) | Adds a Property tab of the specified type and with the specified scope to the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyGrid.PropertyTabCollection Class
PropertyGrid.PropertyTabCollection Members


AddTabType(Type) Method

[image]
Gizmox.WebGUI.Forms
AddTabType(Type) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyGrid.PropertyTabCollection Class > AddTabType Method : AddTabType(Type) Method

propertyTabType
The Property tab type to add to the grid.
Adds a Property tab of the specified type to the collection.

Syntax

Visual Basic (Declaration)
Public Overloads Sub AddTabType( _
   ByVal propertyTabType As Type _
)
Visual Basic (Usage) Copy Code
Dim instance As PropertyGrid.PropertyTabCollection
Dim propertyTabType As Type

instance.AddTabType(propertyTabType)
C#
public void AddTabType(
   Type propertyTabType
)
Managed Extensions for C++
public: void AddTabType(
   Type* propertyTabType
)
C++/CLI
public:
void AddTabType(
   Type^ propertyTabType
)

Parameters

propertyTabType
The Property tab type to add to the grid.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyGrid.PropertyTabCollection Class
PropertyGrid.PropertyTabCollection Members
Overload List


AddTabType(Type,PropertyTabScope) Method

[image]
Gizmox.WebGUI.Forms
AddTabType(Type,PropertyTabScope) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyGrid.PropertyTabCollection Class > AddTabType Method : AddTabType(Type,PropertyTabScope) Method

propertyTabType
The Property tab type to add to the grid.
objPropertyTabScope
One of the PropertyTabScope values.
Adds a Property tab of the specified type and with the specified scope to the collection.

Syntax

Visual Basic (Declaration)
Public Overloads Sub AddTabType( _
   ByVal propertyTabType As Type, _
   ByVal objPropertyTabScope As PropertyTabScope _
)
Visual Basic (Usage) Copy Code
Dim instance As PropertyGrid.PropertyTabCollection
Dim propertyTabType As Type
Dim objPropertyTabScope As PropertyTabScope

instance.AddTabType(propertyTabType, objPropertyTabScope)
C#
public void AddTabType(
   Type propertyTabType,
   PropertyTabScope objPropertyTabScope
)
Managed Extensions for C++
public: void AddTabType(
   Type* propertyTabType,
   PropertyTabScope objPropertyTabScope
)
C++/CLI
public:
void AddTabType(
   Type^ propertyTabType,
   PropertyTabScope objPropertyTabScope
)

Parameters

propertyTabType
The Property tab type to add to the grid.
objPropertyTabScope
One of the PropertyTabScope values.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyGrid.PropertyTabCollection Class
PropertyGrid.PropertyTabCollection Members
Overload List


Clear Method

[image]
Gizmox.WebGUI.Forms
Clear Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyGrid.PropertyTabCollection Class : Clear Method

objPropertyTabScope
The scope of the tabs to clear.
Removes all the Property tabs of the specified scope from the collection.

Syntax

Visual Basic (Declaration)
Public Sub Clear( _
   ByVal objPropertyTabScope As PropertyTabScope _
)
Visual Basic (Usage) Copy Code
Dim instance As PropertyGrid.PropertyTabCollection
Dim objPropertyTabScope As PropertyTabScope

instance.Clear(objPropertyTabScope)
C#
public void Clear(
   PropertyTabScope objPropertyTabScope
)
Managed Extensions for C++
public: void Clear(
   PropertyTabScope objPropertyTabScope
)
C++/CLI
public:
void Clear(
   PropertyTabScope objPropertyTabScope
)

Parameters

objPropertyTabScope
The scope of the tabs to clear.

Exceptions

Exception | Description
ArgumentException | The assigned value of the objPropertyTabScope parameter is less than the Document value of PropertyTabScope.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyGrid.PropertyTabCollection Class
PropertyGrid.PropertyTabCollection Members


GetEnumerator Method

[image]
Gizmox.WebGUI.Forms
GetEnumerator Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyGrid.PropertyTabCollection Class : GetEnumerator Method

Returns an enumeration of all the Property tabs in the collection.

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As PropertyGrid.PropertyTabCollection
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Return Value

An IEnumerator for the PropertyGrid.PropertyTabCollection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyGrid.PropertyTabCollection Class
PropertyGrid.PropertyTabCollection Members


RemoveTabType Method

[image]
Gizmox.WebGUI.Forms
RemoveTabType Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyGrid.PropertyTabCollection Class : RemoveTabType Method

propertyTabType
The tab type to remove from the collection.
Removes the specified tab type from the collection.

Syntax

Visual Basic (Declaration)
Public Sub RemoveTabType( _
   ByVal propertyTabType As Type _
)
Visual Basic (Usage) Copy Code
Dim instance As PropertyGrid.PropertyTabCollection
Dim propertyTabType As Type

instance.RemoveTabType(propertyTabType)
C#
public void RemoveTabType(
   Type propertyTabType
)
Managed Extensions for C++
public: void RemoveTabType(
   Type* propertyTabType
)
C++/CLI
public:
void RemoveTabType(
   Type^ propertyTabType
)

Parameters

propertyTabType
The tab type to remove from the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyGrid.PropertyTabCollection Class
PropertyGrid.PropertyTabCollection Members


PropertyGrid.PropertyTabCollection Class Properties

[image]
Gizmox.WebGUI.Forms
PropertyGrid.PropertyTabCollection Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : PropertyGrid.PropertyTabCollection Class

For a list of all members of this type, see PropertyGrid.PropertyTabCollection members.

Public Properties

 | Name | Description
Public Property | Count | Gets the number of Property tabs in the collection.
Public Property | Item | Gets the PropertyTab at the specified index.
Top

See Also

Reference

PropertyGrid.PropertyTabCollection Class
Gizmox.WebGUI.Forms Namespace


Count Property

[image]
Gizmox.WebGUI.Forms
Count Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyGrid.PropertyTabCollection Class : Count Property

Gets the number of Property tabs in the collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As PropertyGrid.PropertyTabCollection
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyGrid.PropertyTabCollection Class
PropertyGrid.PropertyTabCollection Members


Item Property

[image]
Gizmox.WebGUI.Forms
Item Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyGrid.PropertyTabCollection Class : Item Property

index
The index of the PropertyTab to return.
Gets the PropertyTab at the specified index.

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal index As Integer _
) As PropertyTab
Visual Basic (Usage) Copy Code
Dim instance As PropertyGrid.PropertyTabCollection
Dim index As Integer
Dim value As PropertyTab

value = instance.Item(index)
C#
public PropertyTab this[
   int index
]; {get;}
Managed Extensions for C++
public: __property PropertyTab* get_Item(
   int index
);
C++/CLI
public:
property PropertyTab^ default [int] {
   PropertyTab^ get(intindex);
}

Parameters

index
The index of the PropertyTab to return.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyGrid.PropertyTabCollection Class
PropertyGrid.PropertyTabCollection Members


PropertyManager Class

[image]
Gizmox.WebGUI.Forms
PropertyManager Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : PropertyManager Class

Maintains a Binding between an object's property and a data-bound control property.

Object Model

Syntax

Visual Basic (Declaration)
Public Class PropertyManager
   Inherits BindingManagerBase
Visual Basic (Usage) Copy Code
Dim instance As PropertyManager
C#
public class PropertyManager : BindingManagerBase
Managed Extensions for C++
public __gc class PropertyManager : public BindingManagerBase
C++/CLI
public ref class PropertyManager : public BindingManagerBase

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.BindingManagerBase
Gizmox.WebGUI.Forms.PropertyManager

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

PropertyManager Members
Gizmox.WebGUI.Forms Namespace


PropertyManager Class Members

[image]
Gizmox.WebGUI.Forms
PropertyManager Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : PropertyManager Class

The following tables list the members exposed by PropertyManager.

Public Constructors

 | Name | Description
Public Constructor | PropertyManager Constructor | Initializes a new instance of the PropertyManager class.
Top

Public Properties

 | Name | Description
Public Property | Bindings | Gets the collection of bindings being managed. (Inherited from BindingManagerBase)
Public Property | Count | Overridden.
Public Property | Current | Overridden. Gets the object to which the data-bound property belongs.
Public Property | IsBindingSuspended | Gets a value indicating whether binding is suspended. (Inherited from BindingManagerBase)
Public Property | Position | Overridden.
Top

Public Methods

 | Name | Description
Public Method | AddNew | Overridden.
Public Method | CancelCurrentEdit | Overridden.
Public Method | EndCurrentEdit | Overridden.
Public Method | GetItemProperties | Overloaded. When overridden in a derived class, gets the collection of property descriptors for the binding. (Inherited from BindingManagerBase)
Public Method | RemoveAt | Overridden.
Public Method | ResumeBinding | Overridden.
Public Method | SuspendBinding | Overridden. Suspends the data binding between a data source and a data-bound property.
Top

Protected Methods

 | Name | Description
Protected Method | FireCurrentChanged | (Inherited from BindingManagerBase)
Protected Method | FireCurrentItemChanged | (Inherited from BindingManagerBase)
Protected Method | FirePositionChanged | (Inherited from BindingManagerBase)
Protected Method | GetListName | Overridden.
Protected Method | OnBindingComplete | Raises the BindingComplete event. (Inherited from BindingManagerBase)
Protected Method | OnCurrentChanged | Overridden.
Protected Method | OnCurrentItemChanged | Overridden. Raises the CurrentItemChanged event.
Protected Method | OnDataError | Raises the DataError event. (Inherited from BindingManagerBase)
Protected Method | PullData | Pulls data from the data-bound control into the data source, returning no information. (Inherited from BindingManagerBase)
Protected Method | PushData | Pushes data from the data source into the data-bound control, returning no information. (Inherited from BindingManagerBase)
Protected Method | UpdateIsBinding | Overridden. Updates the current Binding between a data binding and a data-bound property.
Top

Public Events

 | Name | Description
Public Event | BindingComplete | Occurs at the completion of a data-binding operation. (Inherited from BindingManagerBase)
Public Event | CurrentChanged | Occurs when the currently bound item changes. (Inherited from BindingManagerBase)
Public Event | CurrentItemChanged | Occurs when the state of the currently bound item changes. (Inherited from BindingManagerBase)
Public Event | DataError | Occurs when an Exception is silently handled by the BindingManagerBase. (Inherited from BindingManagerBase)
Public Event | PositionChanged | Occurs after the value of the Position property has changed. (Inherited from BindingManagerBase)
Top

See Also

Reference

PropertyManager Class
Gizmox.WebGUI.Forms Namespace


PropertyManager Constructor

[image]
Gizmox.WebGUI.Forms
PropertyManager Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyManager Class : PropertyManager Constructor

Initializes a new instance of the PropertyManager class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PropertyManager()
C#
public PropertyManager()
Managed Extensions for C++
public: PropertyManager();
C++/CLI
public:
PropertyManager();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyManager Class
PropertyManager Members


PropertyManager Class Methods

[image]
Gizmox.WebGUI.Forms
PropertyManager Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : PropertyManager Class

For a list of all members of this type, see PropertyManager members.

Public Methods

 | Name | Description
Public Method | AddNew | Overridden.
Public Method | CancelCurrentEdit | Overridden.
Public Method | EndCurrentEdit | Overridden.
Public Method | GetItemProperties | Overloaded. When overridden in a derived class, gets the collection of property descriptors for the binding. (Inherited from BindingManagerBase)
Public Method | RemoveAt | Overridden.
Public Method | ResumeBinding | Overridden.
Public Method | SuspendBinding | Overridden. Suspends the data binding between a data source and a data-bound property.
Top

Protected Methods

 | Name | Description
Protected Method | FireCurrentChanged | (Inherited from BindingManagerBase)
Protected Method | FireCurrentItemChanged | (Inherited from BindingManagerBase)
Protected Method | FirePositionChanged | (Inherited from BindingManagerBase)
Protected Method | GetListName | Overridden.
Protected Method | OnBindingComplete | Raises the BindingComplete event. (Inherited from BindingManagerBase)
Protected Method | OnCurrentChanged | Overridden.
Protected Method | OnCurrentItemChanged | Overridden. Raises the CurrentItemChanged event.
Protected Method | OnDataError | Raises the DataError event. (Inherited from BindingManagerBase)
Protected Method | PullData | Pulls data from the data-bound control into the data source, returning no information. (Inherited from BindingManagerBase)
Protected Method | PushData | Pushes data from the data source into the data-bound control, returning no information. (Inherited from BindingManagerBase)
Protected Method | UpdateIsBinding | Overridden. Updates the current Binding between a data binding and a data-bound property.
Top

See Also

Reference

PropertyManager Class
Gizmox.WebGUI.Forms Namespace


AddNew Method

[image]
Gizmox.WebGUI.Forms
AddNew Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyManager Class : AddNew Method

Syntax

Visual Basic (Declaration)
Public Overrides Sub AddNew()
Visual Basic (Usage) Copy Code
Dim instance As PropertyManager

instance.AddNew()
C#
public override void AddNew()
Managed Extensions for C++
public: void AddNew(); override
C++/CLI
public:
void AddNew(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyManager Class
PropertyManager Members


CancelCurrentEdit Method

[image]
Gizmox.WebGUI.Forms
CancelCurrentEdit Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyManager Class : CancelCurrentEdit Method

Syntax

Visual Basic (Declaration)
Public Overrides Sub CancelCurrentEdit()
Visual Basic (Usage) Copy Code
Dim instance As PropertyManager

instance.CancelCurrentEdit()
C#
public override void CancelCurrentEdit()
Managed Extensions for C++
public: void CancelCurrentEdit(); override
C++/CLI
public:
void CancelCurrentEdit(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyManager Class
PropertyManager Members


EndCurrentEdit Method

[image]
Gizmox.WebGUI.Forms
EndCurrentEdit Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyManager Class : EndCurrentEdit Method

Syntax

Visual Basic (Declaration)
Public Overrides Sub EndCurrentEdit()
Visual Basic (Usage) Copy Code
Dim instance As PropertyManager

instance.EndCurrentEdit()
C#
public override void EndCurrentEdit()
Managed Extensions for C++
public: void EndCurrentEdit(); override
C++/CLI
public:
void EndCurrentEdit(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyManager Class
PropertyManager Members


GetListName Method

[image]
Gizmox.WebGUI.Forms
GetListName Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyManager Class : GetListName Method

listAccessors

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetListName( _
   ByVal listAccessors As ArrayList _
) As String
Visual Basic (Usage) Copy Code
Dim instance As PropertyManager
Dim listAccessors As ArrayList
Dim value As String

value = instance.GetListName(listAccessors)
C#
protected override string GetListName(
   ArrayList listAccessors
)
Managed Extensions for C++
protected: string* GetListName(
   ArrayList* listAccessors
) override
C++/CLI
protected:
String^ GetListName(
   ArrayList^ listAccessors
) override

Parameters

listAccessors

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyManager Class
PropertyManager Members


OnCurrentChanged Method

[image]
Gizmox.WebGUI.Forms
OnCurrentChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyManager Class : OnCurrentChanged Method

ea

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnCurrentChanged( _
   ByVal ea As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As PropertyManager
Dim ea As EventArgs

instance.OnCurrentChanged(ea)
C#
protected override void OnCurrentChanged(
   EventArgs ea
)
Managed Extensions for C++
protected: void OnCurrentChanged(
   EventArgs* ea
) override
C++/CLI
protected:
void OnCurrentChanged(
   EventArgs^ ea
) override

Parameters

ea

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyManager Class
PropertyManager Members


OnCurrentItemChanged Method

[image]
Gizmox.WebGUI.Forms
OnCurrentItemChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyManager Class : OnCurrentItemChanged Method

ea
An EventArgs containing the event data.
Raises the CurrentItemChanged event.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnCurrentItemChanged( _
   ByVal ea As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As PropertyManager
Dim ea As EventArgs

instance.OnCurrentItemChanged(ea)
C#
protected override void OnCurrentItemChanged(
   EventArgs ea
)
Managed Extensions for C++
protected: void OnCurrentItemChanged(
   EventArgs* ea
) override
C++/CLI
protected:
void OnCurrentItemChanged(
   EventArgs^ ea
) override

Parameters

ea
An EventArgs containing the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyManager Class
PropertyManager Members


RemoveAt Method

[image]
Gizmox.WebGUI.Forms
RemoveAt Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyManager Class : RemoveAt Method

index

Syntax

Visual Basic (Declaration)
Public Overrides Sub RemoveAt( _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As PropertyManager
Dim index As Integer

instance.RemoveAt(index)
C#
public override void RemoveAt(
   int index
)
Managed Extensions for C++
public: void RemoveAt(
   int index
) override
C++/CLI
public:
void RemoveAt(
   int index
) override

Parameters

index

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyManager Class
PropertyManager Members


ResumeBinding Method

[image]
Gizmox.WebGUI.Forms
ResumeBinding Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyManager Class : ResumeBinding Method

Syntax

Visual Basic (Declaration)
Public Overrides Sub ResumeBinding()
Visual Basic (Usage) Copy Code
Dim instance As PropertyManager

instance.ResumeBinding()
C#
public override void ResumeBinding()
Managed Extensions for C++
public: void ResumeBinding(); override
C++/CLI
public:
void ResumeBinding(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyManager Class
PropertyManager Members


SuspendBinding Method

[image]
Gizmox.WebGUI.Forms
SuspendBinding Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyManager Class : SuspendBinding Method

Suspends the data binding between a data source and a data-bound property.

Syntax

Visual Basic (Declaration)
Public Overrides Sub SuspendBinding()
Visual Basic (Usage) Copy Code
Dim instance As PropertyManager

instance.SuspendBinding()
C#
public override void SuspendBinding()
Managed Extensions for C++
public: void SuspendBinding(); override
C++/CLI
public:
void SuspendBinding(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyManager Class
PropertyManager Members


UpdateIsBinding Method

[image]
Gizmox.WebGUI.Forms
UpdateIsBinding Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyManager Class : UpdateIsBinding Method

Updates the current Binding between a data binding and a data-bound property.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub UpdateIsBinding()
Visual Basic (Usage) Copy Code
Dim instance As PropertyManager

instance.UpdateIsBinding()
C#
protected override void UpdateIsBinding()
Managed Extensions for C++
protected: void UpdateIsBinding(); override
C++/CLI
protected:
void UpdateIsBinding(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyManager Class
PropertyManager Members


PropertyManager Class Properties

[image]
Gizmox.WebGUI.Forms
PropertyManager Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : PropertyManager Class

For a list of all members of this type, see PropertyManager members.

Public Properties

 | Name | Description
Public Property | Bindings | Gets the collection of bindings being managed. (Inherited from BindingManagerBase)
Public Property | Count | Overridden.
Public Property | Current | Overridden. Gets the object to which the data-bound property belongs.
Public Property | IsBindingSuspended | Gets a value indicating whether binding is suspended. (Inherited from BindingManagerBase)
Public Property | Position | Overridden.
Top

See Also

Reference

PropertyManager Class
Gizmox.WebGUI.Forms Namespace


Count Property

[image]
Gizmox.WebGUI.Forms
Count Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyManager Class : Count Property

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As PropertyManager
Dim value As Integer

value = instance.Count
C#
public override int Count {get;}
Managed Extensions for C++
public: __property int get_Count() override;
C++/CLI
public:
property int Count {
   int get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyManager Class
PropertyManager Members


Current Property

[image]
Gizmox.WebGUI.Forms
Current Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyManager Class : Current Property

Gets the object to which the data-bound property belongs.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Current As Object
Visual Basic (Usage) Copy Code
Dim instance As PropertyManager
Dim value As Object

value = instance.Current
C#
public override object Current {get;}
Managed Extensions for C++
public: __property Object* get_Current() override;
C++/CLI
public:
property Object^ Current {
   Object^ get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyManager Class
PropertyManager Members


Position Property

[image]
Gizmox.WebGUI.Forms
Position Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyManager Class : Position Property

Syntax

Visual Basic (Declaration)
Public Overrides Property Position As Integer
Visual Basic (Usage) Copy Code
Dim instance As PropertyManager
Dim value As Integer

instance.Position = value

value = instance.Position
C#
public override int Position {get; set;}
Managed Extensions for C++
public: __property int get_Position() override;
public: __property void set_Position(
   int value
) override;
C++/CLI
public:
property int Position {
   int get() override;
   void set (intvalue) override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyManager Class
PropertyManager Members


PropertyStore Class

[image]
Gizmox.WebGUI.Forms
PropertyStore Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : PropertyStore Class

Syntax

Visual Basic (Declaration)
Public Class PropertyStore
Visual Basic (Usage) Copy Code
Dim instance As PropertyStore
C#
public class PropertyStore
Managed Extensions for C++
public __gc class PropertyStore
C++/CLI
public ref class PropertyStore

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.PropertyStore

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

PropertyStore Members
Gizmox.WebGUI.Forms Namespace


PropertyStore Class Members

[image]
Gizmox.WebGUI.Forms
PropertyStore Class Members
See Also Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : PropertyStore Class

The following tables list the members exposed by PropertyStore.

Public Constructors

 | Name | Description
Public Constructor | PropertyStore Constructor |
Top

Public Methods

 | Name | Description
Public Method | ContainsInteger |
Public Method | ContainsObject |
static (Shared in Visual Basic) | CreateKey |
Public Method | GetColor | Overloaded.
Public Method | GetInteger | Overloaded.
Public Method | GetObject | Overloaded.
Public Method | GetPadding | Overloaded.
Public Method | GetRectangle | Overloaded.
Public Method | GetSize |
Public Method | RemoveInteger |
Public Method | RemoveObject |
Public Method | SetColor |
Public Method | SetInteger |
Public Method | SetObject |
Public Method | SetPadding |
Public Method | SetRectangle |
Public Method | SetSize |
Top

See Also

Reference

PropertyStore Class
Gizmox.WebGUI.Forms Namespace


PropertyStore Constructor

[image]
Gizmox.WebGUI.Forms
PropertyStore Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyStore Class : PropertyStore Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PropertyStore()
C#
public PropertyStore()
Managed Extensions for C++
public: PropertyStore();
C++/CLI
public:
PropertyStore();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyStore Class
PropertyStore Members


PropertyStore Class Methods

[image]
Gizmox.WebGUI.Forms
PropertyStore Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : PropertyStore Class

For a list of all members of this type, see PropertyStore members.

Public Methods

 | Name | Description
Public Method | ContainsInteger |
Public Method | ContainsObject |
static (Shared in Visual Basic) | CreateKey |
Public Method | GetColor | Overloaded.
Public Method | GetInteger | Overloaded.
Public Method | GetObject | Overloaded.
Public Method | GetPadding | Overloaded.
Public Method | GetRectangle | Overloaded.
Public Method | GetSize |
Public Method | RemoveInteger |
Public Method | RemoveObject |
Public Method | SetColor |
Public Method | SetInteger |
Public Method | SetObject |
Public Method | SetPadding |
Public Method | SetRectangle |
Public Method | SetSize |
Top

See Also

Reference

PropertyStore Class
Gizmox.WebGUI.Forms Namespace


ContainsInteger Method

[image]
Gizmox.WebGUI.Forms
ContainsInteger Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyStore Class : ContainsInteger Method

key

Syntax

Visual Basic (Declaration)
Public Function ContainsInteger( _
   ByVal key As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PropertyStore
Dim key As Integer
Dim value As Boolean

value = instance.ContainsInteger(key)
C#
public bool ContainsInteger(
   int key
)
Managed Extensions for C++
public: bool ContainsInteger(
   int key
)
C++/CLI
public:
bool ContainsInteger(
   int key
)

Parameters

key

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyStore Class
PropertyStore Members


ContainsObject Method

[image]
Gizmox.WebGUI.Forms
ContainsObject Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyStore Class : ContainsObject Method

key

Syntax

Visual Basic (Declaration)
Public Function ContainsObject( _
   ByVal key As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PropertyStore
Dim key As Integer
Dim value As Boolean

value = instance.ContainsObject(key)
C#
public bool ContainsObject(
   int key
)
Managed Extensions for C++
public: bool ContainsObject(
   int key
)
C++/CLI
public:
bool ContainsObject(
   int key
)

Parameters

key

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyStore Class
PropertyStore Members


CreateKey Method

[image]
Gizmox.WebGUI.Forms
CreateKey Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyStore Class : CreateKey Method

Syntax

Visual Basic (Declaration)
Public Shared Function CreateKey() As Integer
Visual Basic (Usage) Copy Code
Dim value As Integer

value = PropertyStore.CreateKey()
C#
public static int CreateKey()
Managed Extensions for C++
public: static int CreateKey();
C++/CLI
public:
static int CreateKey();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyStore Class
PropertyStore Members


GetColor Method

[image]
Gizmox.WebGUI.Forms
GetColor Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyStore Class : GetColor Method

Overload List

Overload | Description
GetColor(Int32) |
GetColor(Int32,Boolean) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyStore Class
PropertyStore Members


GetColor(Int32) Method

[image]
Gizmox.WebGUI.Forms
GetColor(Int32) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyStore Class > GetColor Method : GetColor(Int32) Method

key

Syntax

Visual Basic (Declaration)
Public Overloads Function GetColor( _
   ByVal key As Integer _
) As Color
Visual Basic (Usage) Copy Code
Dim instance As PropertyStore
Dim key As Integer
Dim value As Color

value = instance.GetColor(key)
C#
public Color GetColor(
   int key
)
Managed Extensions for C++
public: Color GetColor(
   int key
)
C++/CLI
public:
Color GetColor(
   int key
)

Parameters

key

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyStore Class
PropertyStore Members
Overload List


GetColor(Int32,Boolean) Method

[image]
Gizmox.WebGUI.Forms
GetColor(Int32,Boolean) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyStore Class > GetColor Method : GetColor(Int32,Boolean) Method

key
found

Syntax

Visual Basic (Declaration)
Public Overloads Function GetColor( _
   ByVal key As Integer, _
   ByRef found As Boolean _
) As Color
Visual Basic (Usage) Copy Code
Dim instance As PropertyStore
Dim key As Integer
Dim found As Boolean
Dim value As Color

value = instance.GetColor(key, found)
C#
public Color GetColor(
   int key,
   out bool found
)
Managed Extensions for C++
public: Color GetColor(
   int key,
   [PARAMFLAG::Out] bool found
)
C++/CLI
public:
Color GetColor(
   int key,
   [Out] bool found
)

Parameters

key
found

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyStore Class
PropertyStore Members
Overload List


GetInteger Method

[image]
Gizmox.WebGUI.Forms
GetInteger Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyStore Class : GetInteger Method

Overload List

Overload | Description
GetInteger(Int32) |
GetInteger(Int32,Boolean) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyStore Class
PropertyStore Members


GetInteger(Int32) Method

[image]
Gizmox.WebGUI.Forms
GetInteger(Int32) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyStore Class > GetInteger Method : GetInteger(Int32) Method

key

Syntax

Visual Basic (Declaration)
Public Overloads Function GetInteger( _
   ByVal key As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As PropertyStore
Dim key As Integer
Dim value As Integer

value = instance.GetInteger(key)
C#
public int GetInteger(
   int key
)
Managed Extensions for C++
public: int GetInteger(
   int key
)
C++/CLI
public:
int GetInteger(
   int key
)

Parameters

key

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyStore Class
PropertyStore Members
Overload List


GetInteger(Int32,Boolean) Method

[image]
Gizmox.WebGUI.Forms
GetInteger(Int32,Boolean) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyStore Class > GetInteger Method : GetInteger(Int32,Boolean) Method

key
found

Syntax

Visual Basic (Declaration)
Public Overloads Function GetInteger( _
   ByVal key As Integer, _
   ByRef found As Boolean _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As PropertyStore
Dim key As Integer
Dim found As Boolean
Dim value As Integer

value = instance.GetInteger(key, found)
C#
public int GetInteger(
   int key,
   out bool found
)
Managed Extensions for C++
public: int GetInteger(
   int key,
   [PARAMFLAG::Out] bool found
)
C++/CLI
public:
int GetInteger(
   int key,
   [Out] bool found
)

Parameters

key
found

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyStore Class
PropertyStore Members
Overload List


GetObject Method

[image]
Gizmox.WebGUI.Forms
GetObject Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyStore Class : GetObject Method

Overload List

Overload | Description
GetObject(Int32) |
GetObject(Int32,Boolean) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyStore Class
PropertyStore Members


GetObject(Int32) Method

[image]
Gizmox.WebGUI.Forms
GetObject(Int32) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyStore Class > GetObject Method : GetObject(Int32) Method

key

Syntax

Visual Basic (Declaration)
Public Overloads Function GetObject( _
   ByVal key As Integer _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As PropertyStore
Dim key As Integer
Dim value As Object

value = instance.GetObject(key)
C#
public object GetObject(
   int key
)
Managed Extensions for C++
public: Object* GetObject(
   int key
)
C++/CLI
public:
Object^ GetObject(
   int key
)

Parameters

key

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyStore Class
PropertyStore Members
Overload List


GetObject(Int32,Boolean) Method

[image]
Gizmox.WebGUI.Forms
GetObject(Int32,Boolean) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyStore Class > GetObject Method : GetObject(Int32,Boolean) Method

key
found

Syntax

Visual Basic (Declaration)
Public Overloads Function GetObject( _
   ByVal key As Integer, _
   ByRef found As Boolean _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As PropertyStore
Dim key As Integer
Dim found As Boolean
Dim value As Object

value = instance.GetObject(key, found)
C#
public object GetObject(
   int key,
   out bool found
)
Managed Extensions for C++
public: Object* GetObject(
   int key,
   [PARAMFLAG::Out] bool found
)
C++/CLI
public:
Object^ GetObject(
   int key,
   [Out] bool found
)

Parameters

key
found

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyStore Class
PropertyStore Members
Overload List


GetPadding Method

[image]
Gizmox.WebGUI.Forms
GetPadding Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyStore Class : GetPadding Method

Overload List

Overload | Description
GetPadding(Int32) |
GetPadding(Int32,Boolean) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyStore Class
PropertyStore Members


GetPadding(Int32) Method

[image]
Gizmox.WebGUI.Forms
GetPadding(Int32) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyStore Class > GetPadding Method : GetPadding(Int32) Method

key

Syntax

Visual Basic (Declaration)
Public Overloads Function GetPadding( _
   ByVal key As Integer _
) As Padding
Visual Basic (Usage) Copy Code
Dim instance As PropertyStore
Dim key As Integer
Dim value As Padding

value = instance.GetPadding(key)
C#
public Padding GetPadding(
   int key
)
Managed Extensions for C++
public: Padding GetPadding(
   int key
)
C++/CLI
public:
Padding GetPadding(
   int key
)

Parameters

key

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyStore Class
PropertyStore Members
Overload List


GetPadding(Int32,Boolean) Method

[image]
Gizmox.WebGUI.Forms
GetPadding(Int32,Boolean) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyStore Class > GetPadding Method : GetPadding(Int32,Boolean) Method

key
found

Syntax

Visual Basic (Declaration)
Public Overloads Function GetPadding( _
   ByVal key As Integer, _
   ByRef found As Boolean _
) As Padding
Visual Basic (Usage) Copy Code
Dim instance As PropertyStore
Dim key As Integer
Dim found As Boolean
Dim value As Padding

value = instance.GetPadding(key, found)
C#
public Padding GetPadding(
   int key,
   out bool found
)
Managed Extensions for C++
public: Padding GetPadding(
   int key,
   [PARAMFLAG::Out] bool found
)
C++/CLI
public:
Padding GetPadding(
   int key,
   [Out] bool found
)

Parameters

key
found

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyStore Class
PropertyStore Members
Overload List


GetRectangle Method

[image]
Gizmox.WebGUI.Forms
GetRectangle Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyStore Class : GetRectangle Method

Overload List

Overload | Description
GetRectangle(Int32) |
GetRectangle(Int32,Boolean) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyStore Class
PropertyStore Members


GetRectangle(Int32) Method

[image]
Gizmox.WebGUI.Forms
GetRectangle(Int32) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyStore Class > GetRectangle Method : GetRectangle(Int32) Method

key

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRectangle( _
   ByVal key As Integer _
) As Rectangle
Visual Basic (Usage) Copy Code
Dim instance As PropertyStore
Dim key As Integer
Dim value As Rectangle

value = instance.GetRectangle(key)
C#
public Rectangle GetRectangle(
   int key
)
Managed Extensions for C++
public: Rectangle GetRectangle(
   int key
)
C++/CLI
public:
Rectangle GetRectangle(
   int key
)

Parameters

key

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyStore Class
PropertyStore Members
Overload List


GetRectangle(Int32,Boolean) Method

[image]
Gizmox.WebGUI.Forms
GetRectangle(Int32,Boolean) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyStore Class > GetRectangle Method : GetRectangle(Int32,Boolean) Method

key
found

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRectangle( _
   ByVal key As Integer, _
   ByRef found As Boolean _
) As Rectangle
Visual Basic (Usage) Copy Code
Dim instance As PropertyStore
Dim key As Integer
Dim found As Boolean
Dim value As Rectangle

value = instance.GetRectangle(key, found)
C#
public Rectangle GetRectangle(
   int key,
   out bool found
)
Managed Extensions for C++
public: Rectangle GetRectangle(
   int key,
   [PARAMFLAG::Out] bool found
)
C++/CLI
public:
Rectangle GetRectangle(
   int key,
   [Out] bool found
)

Parameters

key
found

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyStore Class
PropertyStore Members
Overload List


GetSize Method

[image]
Gizmox.WebGUI.Forms
GetSize Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyStore Class : GetSize Method

key
found

Syntax

Visual Basic (Declaration)
Public Function GetSize( _
   ByVal key As Integer, _
   ByRef found As Boolean _
) As Size
Visual Basic (Usage) Copy Code
Dim instance As PropertyStore
Dim key As Integer
Dim found As Boolean
Dim value As Size

value = instance.GetSize(key, found)
C#
public Size GetSize(
   int key,
   out bool found
)
Managed Extensions for C++
public: Size GetSize(
   int key,
   [PARAMFLAG::Out] bool found
)
C++/CLI
public:
Size GetSize(
   int key,
   [Out] bool found
)

Parameters

key
found

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyStore Class
PropertyStore Members


RemoveInteger Method

[image]
Gizmox.WebGUI.Forms
RemoveInteger Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyStore Class : RemoveInteger Method

key

Syntax

Visual Basic (Declaration)
Public Sub RemoveInteger( _
   ByVal key As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As PropertyStore
Dim key As Integer

instance.RemoveInteger(key)
C#
public void RemoveInteger(
   int key
)
Managed Extensions for C++
public: void RemoveInteger(
   int key
)
C++/CLI
public:
void RemoveInteger(
   int key
)

Parameters

key

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyStore Class
PropertyStore Members


RemoveObject Method

[image]
Gizmox.WebGUI.Forms
RemoveObject Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyStore Class : RemoveObject Method

key

Syntax

Visual Basic (Declaration)
Public Sub RemoveObject( _
   ByVal key As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As PropertyStore
Dim key As Integer

instance.RemoveObject(key)
C#
public void RemoveObject(
   int key
)
Managed Extensions for C++
public: void RemoveObject(
   int key
)
C++/CLI
public:
void RemoveObject(
   int key
)

Parameters

key

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyStore Class
PropertyStore Members


SetColor Method

[image]
Gizmox.WebGUI.Forms
SetColor Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyStore Class : SetColor Method

key
value

Syntax

Visual Basic (Declaration)
Public Sub SetColor( _
   ByVal key As Integer, _
   ByVal value As Color _
)
Visual Basic (Usage) Copy Code
Dim instance As PropertyStore
Dim key As Integer
Dim value As Color

instance.SetColor(key, value)
C#
public void SetColor(
   int key,
   Color value
)
Managed Extensions for C++
public: void SetColor(
   int key,
   Color value
)
C++/CLI
public:
void SetColor(
   int key,
   Color value
)

Parameters

key
value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyStore Class
PropertyStore Members


SetInteger Method

[image]
Gizmox.WebGUI.Forms
SetInteger Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyStore Class : SetInteger Method

key
value

Syntax

Visual Basic (Declaration)
Public Sub SetInteger( _
   ByVal key As Integer, _
   ByVal value As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As PropertyStore
Dim key As Integer
Dim value As Integer

instance.SetInteger(key, value)
C#
public void SetInteger(
   int key,
   int value
)
Managed Extensions for C++
public: void SetInteger(
   int key,
   int value
)
C++/CLI
public:
void SetInteger(
   int key,
   int value
)

Parameters

key
value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyStore Class
PropertyStore Members


SetObject Method

[image]
Gizmox.WebGUI.Forms
SetObject Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyStore Class : SetObject Method

key
value

Syntax

Visual Basic (Declaration)
Public Sub SetObject( _
   ByVal key As Integer, _
   ByVal value As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As PropertyStore
Dim key As Integer
Dim value As Object

instance.SetObject(key, value)
C#
public void SetObject(
   int key,
   object value
)
Managed Extensions for C++
public: void SetObject(
   int key,
   Object* value
)
C++/CLI
public:
void SetObject(
   int key,
   Object^ value
)

Parameters

key
value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyStore Class
PropertyStore Members


SetPadding Method

[image]
Gizmox.WebGUI.Forms
SetPadding Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyStore Class : SetPadding Method

key
value

Syntax

Visual Basic (Declaration)
Public Sub SetPadding( _
   ByVal key As Integer, _
   ByVal value As Padding _
)
Visual Basic (Usage) Copy Code
Dim instance As PropertyStore
Dim key As Integer
Dim value As Padding

instance.SetPadding(key, value)
C#
public void SetPadding(
   int key,
   Padding value
)
Managed Extensions for C++
public: void SetPadding(
   int key,
   Padding value
)
C++/CLI
public:
void SetPadding(
   int key,
   Padding value
)

Parameters

key
value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyStore Class
PropertyStore Members


SetRectangle Method

[image]
Gizmox.WebGUI.Forms
SetRectangle Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyStore Class : SetRectangle Method

key
value

Syntax

Visual Basic (Declaration)
Public Sub SetRectangle( _
   ByVal key As Integer, _
   ByVal value As Rectangle _
)
Visual Basic (Usage) Copy Code
Dim instance As PropertyStore
Dim key As Integer
Dim value As Rectangle

instance.SetRectangle(key, value)
C#
public void SetRectangle(
   int key,
   Rectangle value
)
Managed Extensions for C++
public: void SetRectangle(
   int key,
   Rectangle value
)
C++/CLI
public:
void SetRectangle(
   int key,
   Rectangle value
)

Parameters

key
value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyStore Class
PropertyStore Members


SetSize Method

[image]
Gizmox.WebGUI.Forms
SetSize Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyStore Class : SetSize Method

key
value

Syntax

Visual Basic (Declaration)
Public Sub SetSize( _
   ByVal key As Integer, _
   ByVal value As Size _
)
Visual Basic (Usage) Copy Code
Dim instance As PropertyStore
Dim key As Integer
Dim value As Size

instance.SetSize(key, value)
C#
public void SetSize(
   int key,
   Size value
)
Managed Extensions for C++
public: void SetSize(
   int key,
   Size value
)
C++/CLI
public:
void SetSize(
   int key,
   Size value
)

Parameters

key
value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyStore Class
PropertyStore Members


PropertyTabChangedEventArgs Class

[image]
Gizmox.WebGUI.Forms
PropertyTabChangedEventArgs Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : PropertyTabChangedEventArgs Class

Provides data for the PropertyTabChanged event of a PropertyGrid.

Object Model

Syntax

Visual Basic (Declaration)
<ComVisibleAttribute(True)>
Public Class PropertyTabChangedEventArgs
   Inherits EventArgs
Visual Basic (Usage) Copy Code
Dim instance As PropertyTabChangedEventArgs
C#
[ComVisibleAttribute(true)]
public class PropertyTabChangedEventArgs : EventArgs
Managed Extensions for C++
[ComVisibleAttribute(true)]
public __gc class PropertyTabChangedEventArgs : public EventArgs
C++/CLI
[ComVisibleAttribute(true)]
public ref class PropertyTabChangedEventArgs : public EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gizmox.WebGUI.Forms.PropertyTabChangedEventArgs

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

PropertyTabChangedEventArgs Members
Gizmox.WebGUI.Forms Namespace


PropertyTabChangedEventArgs Class Members

[image]
Gizmox.WebGUI.Forms
PropertyTabChangedEventArgs Class Members
See Also Properties Send Feedback
Gizmox.WebGUI.Forms Namespace : PropertyTabChangedEventArgs Class

The following tables list the members exposed by PropertyTabChangedEventArgs.

Public Constructors

 | Name | Description
Public Constructor | PropertyTabChangedEventArgs Constructor | Initializes a new instance of the PropertyTabChangedEventArgs class.
Top

Public Properties

 | Name | Description
Public Property | NewTab | Gets the new PropertyTab selected.
Public Property | OldTab | Gets the old PropertyTab selected.
Top

See Also

Reference

PropertyTabChangedEventArgs Class
Gizmox.WebGUI.Forms Namespace


PropertyTabChangedEventArgs Constructor

[image]
Gizmox.WebGUI.Forms
PropertyTabChangedEventArgs Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyTabChangedEventArgs Class : PropertyTabChangedEventArgs Constructor

oldTab
The Previously selected property tab.
newTab
The newly selected property tab.
Initializes a new instance of the PropertyTabChangedEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal oldTab As PropertyTab, _
   ByVal newTab As PropertyTab _
)
Visual Basic (Usage) Copy Code
Dim oldTab As PropertyTab
Dim newTab As PropertyTab

Dim instance As PropertyTabChangedEventArgs(oldTab, newTab)
C#
public PropertyTabChangedEventArgs(
   PropertyTab oldTab,
   PropertyTab newTab
)
Managed Extensions for C++
public: PropertyTabChangedEventArgs(
   PropertyTab* oldTab,
   PropertyTab* newTab
)
C++/CLI
public:
PropertyTabChangedEventArgs(
   PropertyTab^ oldTab,
   PropertyTab^ newTab
)

Parameters

oldTab
The Previously selected property tab.
newTab
The newly selected property tab.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyTabChangedEventArgs Class
PropertyTabChangedEventArgs Members


PropertyTabChangedEventArgs Class Properties

[image]
Gizmox.WebGUI.Forms
PropertyTabChangedEventArgs Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : PropertyTabChangedEventArgs Class

For a list of all members of this type, see PropertyTabChangedEventArgs members.

Public Properties

 | Name | Description
Public Property | NewTab | Gets the new PropertyTab selected.
Public Property | OldTab | Gets the old PropertyTab selected.
Top

See Also

Reference

PropertyTabChangedEventArgs Class
Gizmox.WebGUI.Forms Namespace


NewTab Property

[image]
Gizmox.WebGUI.Forms
NewTab Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyTabChangedEventArgs Class : NewTab Property

Gets the new PropertyTab selected.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property NewTab As PropertyTab
Visual Basic (Usage) Copy Code
Dim instance As PropertyTabChangedEventArgs
Dim value As PropertyTab

value = instance.NewTab
C#
public PropertyTab NewTab {get;}
Managed Extensions for C++
public: __property PropertyTab* get_NewTab();
C++/CLI
public:
property PropertyTab^ NewTab {
   PropertyTab^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyTabChangedEventArgs Class
PropertyTabChangedEventArgs Members


OldTab Property

[image]
Gizmox.WebGUI.Forms
OldTab Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyTabChangedEventArgs Class : OldTab Property

Gets the old PropertyTab selected.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OldTab As PropertyTab
Visual Basic (Usage) Copy Code
Dim instance As PropertyTabChangedEventArgs
Dim value As PropertyTab

value = instance.OldTab
C#
public PropertyTab OldTab {get;}
Managed Extensions for C++
public: __property PropertyTab* get_OldTab();
C++/CLI
public:
property PropertyTab^ OldTab {
   PropertyTab^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyTabChangedEventArgs Class
PropertyTabChangedEventArgs Members


PropertyValueChangedEventArgs Class

[image]
Gizmox.WebGUI.Forms
PropertyValueChangedEventArgs Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : PropertyValueChangedEventArgs Class

Provides data for the PropertyValueChanged event of a PropertyGrid.

Object Model

Syntax

Visual Basic (Declaration)
<ComVisibleAttribute(True)>
Public Class PropertyValueChangedEventArgs
   Inherits EventArgs
Visual Basic (Usage) Copy Code
Dim instance As PropertyValueChangedEventArgs
C#
[ComVisibleAttribute(true)]
public class PropertyValueChangedEventArgs : EventArgs
Managed Extensions for C++
[ComVisibleAttribute(true)]
public __gc class PropertyValueChangedEventArgs : public EventArgs
C++/CLI
[ComVisibleAttribute(true)]
public ref class PropertyValueChangedEventArgs : public EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gizmox.WebGUI.Forms.PropertyValueChangedEventArgs

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

PropertyValueChangedEventArgs Members
Gizmox.WebGUI.Forms Namespace


PropertyValueChangedEventArgs Class Members

[image]
Gizmox.WebGUI.Forms
PropertyValueChangedEventArgs Class Members
See Also Properties Send Feedback
Gizmox.WebGUI.Forms Namespace : PropertyValueChangedEventArgs Class

The following tables list the members exposed by PropertyValueChangedEventArgs.

Public Constructors

 | Name | Description
Public Constructor | PropertyValueChangedEventArgs Constructor | Initializes a new instance of the PropertyValueChangedEventArgs class.
Top

Public Properties

 | Name | Description
Public Property | ChangedItem | Gets the GridItem that was changed.
Public Property | OldValue | The value of the grid item before it was changed.
Top

See Also

Reference

PropertyValueChangedEventArgs Class
Gizmox.WebGUI.Forms Namespace


PropertyValueChangedEventArgs Constructor

[image]
Gizmox.WebGUI.Forms
PropertyValueChangedEventArgs Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyValueChangedEventArgs Class : PropertyValueChangedEventArgs Constructor

changedItem
The item in the grid that changed.
oldValue
The old property value.
Initializes a new instance of the PropertyValueChangedEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal changedItem As GridItem, _
   ByVal oldValue As Object _
)
Visual Basic (Usage) Copy Code
Dim changedItem As GridItem
Dim oldValue As Object

Dim instance As PropertyValueChangedEventArgs(changedItem, oldValue)
C#
public PropertyValueChangedEventArgs(
   GridItem changedItem,
   object oldValue
)
Managed Extensions for C++
public: PropertyValueChangedEventArgs(
   GridItem* changedItem,
   Object* oldValue
)
C++/CLI
public:
PropertyValueChangedEventArgs(
   GridItem^ changedItem,
   Object^ oldValue
)

Parameters

changedItem
The item in the grid that changed.
oldValue
The old property value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyValueChangedEventArgs Class
PropertyValueChangedEventArgs Members


PropertyValueChangedEventArgs Class Properties

[image]
Gizmox.WebGUI.Forms
PropertyValueChangedEventArgs Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : PropertyValueChangedEventArgs Class

For a list of all members of this type, see PropertyValueChangedEventArgs members.

Public Properties

 | Name | Description
Public Property | ChangedItem | Gets the GridItem that was changed.
Public Property | OldValue | The value of the grid item before it was changed.
Top

See Also

Reference

PropertyValueChangedEventArgs Class
Gizmox.WebGUI.Forms Namespace


ChangedItem Property

[image]
Gizmox.WebGUI.Forms
ChangedItem Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyValueChangedEventArgs Class : ChangedItem Property

Gets the GridItem that was changed.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ChangedItem As GridItem
Visual Basic (Usage) Copy Code
Dim instance As PropertyValueChangedEventArgs
Dim value As GridItem

value = instance.ChangedItem
C#
public GridItem ChangedItem {get;}
Managed Extensions for C++
public: __property GridItem* get_ChangedItem();
C++/CLI
public:
property GridItem^ ChangedItem {
   GridItem^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyValueChangedEventArgs Class
PropertyValueChangedEventArgs Members


OldValue Property

[image]
Gizmox.WebGUI.Forms
OldValue Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > PropertyValueChangedEventArgs Class : OldValue Property

The value of the grid item before it was changed.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OldValue As Object
Visual Basic (Usage) Copy Code
Dim instance As PropertyValueChangedEventArgs
Dim value As Object

value = instance.OldValue
C#
public object OldValue {get;}
Managed Extensions for C++
public: __property Object* get_OldValue();
C++/CLI
public:
property Object^ OldValue {
   Object^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyValueChangedEventArgs Class
PropertyValueChangedEventArgs Members


QuestionEventArgs Class

[image]
Gizmox.WebGUI.Forms
QuestionEventArgs Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : QuestionEventArgs Class

Provides data for events that need a true or false answer to a question.

Syntax

Visual Basic (Declaration)
Public Class QuestionEventArgs
   Inherits EventArgs
Visual Basic (Usage) Copy Code
Dim instance As QuestionEventArgs
C#
public class QuestionEventArgs : EventArgs
Managed Extensions for C++
public __gc class QuestionEventArgs : public EventArgs
C++/CLI
public ref class QuestionEventArgs : public EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gizmox.WebGUI.Forms.QuestionEventArgs

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

QuestionEventArgs Members
Gizmox.WebGUI.Forms Namespace


QuestionEventArgs Class Members

[image]
Gizmox.WebGUI.Forms
QuestionEventArgs Class Members
See Also Properties Send Feedback
Gizmox.WebGUI.Forms Namespace : QuestionEventArgs Class

The following tables list the members exposed by QuestionEventArgs.

Public Constructors

 | Name | Description
Public Constructor | QuestionEventArgs Constructor | Overloaded. Initializes a new instance of the QuestionEventArgs class using a default Response property value of false.
Top

Public Properties

 | Name | Description
Public Property | Response | Gets or sets a value indicating the response to a question represented by the event.
Top

See Also

Reference

QuestionEventArgs Class
Gizmox.WebGUI.Forms Namespace


QuestionEventArgs Constructor

[image]
Gizmox.WebGUI.Forms
QuestionEventArgs Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > QuestionEventArgs Class : QuestionEventArgs Constructor

Initializes a new instance of the QuestionEventArgs class using a default Response property value of false.

Overload List

Overload | Description
QuestionEventArgs Constructor() | Initializes a new instance of the QuestionEventArgs class using a default Response property value of false.
QuestionEventArgs Constructor(Boolean) | Initializes a new instance of the QuestionEventArgs class using the specified default value for the Response property.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

QuestionEventArgs Class
QuestionEventArgs Members


QuestionEventArgs Constructor()

[image]
Gizmox.WebGUI.Forms
QuestionEventArgs Constructor()
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > QuestionEventArgs Class > QuestionEventArgs Constructor : QuestionEventArgs Constructor()

Initializes a new instance of the QuestionEventArgs class using a default Response property value of false.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As QuestionEventArgs()
C#
public QuestionEventArgs()
Managed Extensions for C++
public: QuestionEventArgs();
C++/CLI
public:
QuestionEventArgs();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

QuestionEventArgs Class
QuestionEventArgs Members
Overload List


QuestionEventArgs Constructor(Boolean)

[image]
Gizmox.WebGUI.Forms
QuestionEventArgs Constructor(Boolean)
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > QuestionEventArgs Class > QuestionEventArgs Constructor : QuestionEventArgs Constructor(Boolean)

response
The default value of the Response property.
Initializes a new instance of the QuestionEventArgs class using the specified default value for the Response property.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal response As Boolean _
)
Visual Basic (Usage) Copy Code
Dim response As Boolean

Dim instance As QuestionEventArgs(response)
C#
public QuestionEventArgs(
   bool response
)
Managed Extensions for C++
public: QuestionEventArgs(
   bool response
)
C++/CLI
public:
QuestionEventArgs(
   bool response
)

Parameters

response
The default value of the Response property.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

QuestionEventArgs Class
QuestionEventArgs Members
Overload List


QuestionEventArgs Class Properties

[image]
Gizmox.WebGUI.Forms
QuestionEventArgs Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : QuestionEventArgs Class

For a list of all members of this type, see QuestionEventArgs members.

Public Properties

 | Name | Description
Public Property | Response | Gets or sets a value indicating the response to a question represented by the event.
Top

See Also

Reference

QuestionEventArgs Class
Gizmox.WebGUI.Forms Namespace


Response Property

[image]
Gizmox.WebGUI.Forms
Response Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > QuestionEventArgs Class : Response Property

Gets or sets a value indicating the response to a question represented by the event.

Syntax

Visual Basic (Declaration)
Public Property Response As Boolean
Visual Basic (Usage) Copy Code
Dim instance As QuestionEventArgs
Dim value As Boolean

instance.Response = value

value = instance.Response
C#
public bool Response {get; set;}
Managed Extensions for C++
public: __property bool get_Response();
public: __property void set_Response(
   bool value
);
C++/CLI
public:
property bool Response {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

QuestionEventArgs Class
QuestionEventArgs Members


RadioButton Class

[image]
Gizmox.WebGUI.Forms
RadioButton Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RadioButton Class

Enables the user to select a single option from a group of choices when paired with other RadioButton controls.

Object Model

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Enables the user to select a single option from a group of choices when paired with other RadioButtons.")>
<ToolboxItemCategoryAttribute("Common Controls")>
<MetadataTagAttribute("RB")>
<SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableRadioButton, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")>
<ClientControllerAttribute()>
<DefaultBindingPropertyAttribute("Checked")>
<ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<ToolboxBitmapAttribute()>
<DesignTimeControllerAttribute()>
<DefaultPropertyAttribute("Checked")>
<DefaultEventAttribute("CheckedChanged")>
Public Class RadioButton
   Inherits Control
   Implements IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Visual Basic (Usage) Copy Code
Dim instance As RadioButton
C#
[SRDescriptionAttribute("Enables the user to select a single option from a group of choices when paired with other RadioButtons.")]
[ToolboxItemCategoryAttribute("Common Controls")]
[MetadataTagAttribute("RB")]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableRadioButton, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[ClientControllerAttribute()]
[DefaultBindingPropertyAttribute("Checked")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ToolboxBitmapAttribute()]
[DesignTimeControllerAttribute()]
[DefaultPropertyAttribute("Checked")]
[DefaultEventAttribute("CheckedChanged")]
public class RadioButton : Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Managed Extensions for C++
[SRDescriptionAttribute("Enables the user to select a single option from a group of choices when paired with other RadioButtons.")]
[ToolboxItemCategoryAttribute("Common Controls")]
[MetadataTagAttribute("RB")]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableRadioButton, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[ClientControllerAttribute()]
[DefaultBindingPropertyAttribute("Checked")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ToolboxBitmapAttribute()]
[DesignTimeControllerAttribute()]
[DefaultPropertyAttribute("Checked")]
[DefaultEventAttribute("CheckedChanged")]
public __gc class RadioButton : public Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
C++/CLI
[SRDescriptionAttribute("Enables the user to select a single option from a group of choices when paired with other RadioButtons.")]
[ToolboxItemCategoryAttribute("Common Controls")]
[MetadataTagAttribute("RB")]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableRadioButton, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[ClientControllerAttribute()]
[DefaultBindingPropertyAttribute("Checked")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ToolboxBitmapAttribute()]
[DesignTimeControllerAttribute()]
[DefaultPropertyAttribute("Checked")]
[DefaultEventAttribute("CheckedChanged")]
public ref class RadioButton : public Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.RadioButton

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

RadioButton Members
Gizmox.WebGUI.Forms Namespace


RadioButton Class Members

[image]
Gizmox.WebGUI.Forms
RadioButton Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : RadioButton Class

The following tables list the members exposed by RadioButton.

Public Constructors

 | Name | Description
Public Constructor | RadioButton Constructor | Initializes a new instance of the RadioButton class.
Top

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | Checked | Gets or sets a value indicating whether the control is checked.
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Control)
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Overridden. Fires an event.
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Overridden. Gets the critical events.
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from Control)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnCheckedChanged | Raises the CheckedChanged event.
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | Overridden. Renders the current control.
Protected Method | RenderAttributes | Renders the controls meta attributes (Inherited from Control)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | Overridden.
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | CheckedChanged | Occurs when the value of the Checked property changes.
Public Event | CheckedChangedQueued | Occurs when checked property value queued for change.
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

RadioButton Class
Gizmox.WebGUI.Forms Namespace


RadioButton Constructor

[image]
Gizmox.WebGUI.Forms
RadioButton Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RadioButton Class : RadioButton Constructor

Initializes a new instance of the RadioButton class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RadioButton()
C#
public RadioButton()
Managed Extensions for C++
public: RadioButton();
C++/CLI
public:
RadioButton();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadioButton Class
RadioButton Members


RadioButton Class Methods

[image]
Gizmox.WebGUI.Forms
RadioButton Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RadioButton Class

For a list of all members of this type, see RadioButton members.

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Overridden. Fires an event.
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Overridden. Gets the critical events.
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from Control)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnCheckedChanged | Raises the CheckedChanged event.
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | Overridden. Renders the current control.
Protected Method | RenderAttributes | Renders the controls meta attributes (Inherited from Control)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | Overridden.
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

See Also

Reference

RadioButton Class
Gizmox.WebGUI.Forms Namespace


FireEvent Method

[image]
Gizmox.WebGUI.Forms
FireEvent Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RadioButton Class : FireEvent Method

objEvent
event.
Fires an event.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub FireEvent( _
   ByVal objEvent As IEvent _
)
Visual Basic (Usage) Copy Code
Dim instance As RadioButton
Dim objEvent As IEvent

instance.FireEvent(objEvent)
C#
protected override void FireEvent(
   IEvent objEvent
)
Managed Extensions for C++
protected: void FireEvent(
   IEvent* objEvent
) override
C++/CLI
protected:
void FireEvent(
   IEvent^ objEvent
) override

Parameters

objEvent
event.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadioButton Class
RadioButton Members


GetCriticalEvents Method

[image]
Gizmox.WebGUI.Forms
GetCriticalEvents Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RadioButton Class : GetCriticalEvents Method

Gets the critical events.

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetCriticalEvents() As EventTypes
Visual Basic (Usage) Copy Code
Dim instance As RadioButton
Dim value As EventTypes

value = instance.GetCriticalEvents()
C#
protected override EventTypes GetCriticalEvents()
Managed Extensions for C++
protected: EventTypes GetCriticalEvents(); override
C++/CLI
protected:
EventTypes GetCriticalEvents(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadioButton Class
RadioButton Members


OnCheckedChanged Method

[image]
Gizmox.WebGUI.Forms
OnCheckedChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RadioButton Class : OnCheckedChanged Method

e
An EventArgs that contains the event data.
Raises the CheckedChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnCheckedChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RadioButton
Dim e As EventArgs

instance.OnCheckedChanged(e)
C#
protected virtual void OnCheckedChanged(
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnCheckedChanged(
   EventArgs* e
)
C++/CLI
protected:
virtual void OnCheckedChanged(
   EventArgs^ e
)

Parameters

e
An EventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadioButton Class
RadioButton Members


Render Method

[image]
Gizmox.WebGUI.Forms
Render Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RadioButton Class : Render Method

objContext
Request context.
objWriter
lngRequestID
Renders the current control.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub Render( _
   ByVal objContext As IContext, _
   ByVal objWriter As IResponseWriter, _
   ByVal lngRequestID As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As RadioButton
Dim objContext As IContext
Dim objWriter As IResponseWriter
Dim lngRequestID As Long

instance.Render(objContext, objWriter, lngRequestID)
C#
protected override void Render(
   IContext objContext,
   IResponseWriter objWriter,
   long lngRequestID
)
Managed Extensions for C++
protected: void Render(
   IContext* objContext,
   IResponseWriter* objWriter,
   long lngRequestID
) override
C++/CLI
protected:
void Render(
   IContext^ objContext,
   IResponseWriter^ objWriter,
   long long lngRequestID
) override

Parameters

objContext
Request context.
objWriter
lngRequestID

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadioButton Class
RadioButton Members


RenderUpdatedAttributes Method

[image]
Gizmox.WebGUI.Forms
RenderUpdatedAttributes Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RadioButton Class : RenderUpdatedAttributes Method

objContext
Request context.
objWriter
lngRequestID

Syntax

Visual Basic (Declaration)
Protected Overrides Sub RenderUpdatedAttributes( _
   ByVal objContext As IContext, _
   ByVal objWriter As IAttributeWriter, _
   ByVal lngRequestID As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As RadioButton
Dim objContext As IContext
Dim objWriter As IAttributeWriter
Dim lngRequestID As Long

instance.RenderUpdatedAttributes(objContext, objWriter, lngRequestID)
C#
protected override void RenderUpdatedAttributes(
   IContext objContext,
   IAttributeWriter objWriter,
   long lngRequestID
)
Managed Extensions for C++
protected: void RenderUpdatedAttributes(
   IContext* objContext,
   IAttributeWriter* objWriter,
   long lngRequestID
) override
C++/CLI
protected:
void RenderUpdatedAttributes(
   IContext^ objContext,
   IAttributeWriter^ objWriter,
   long long lngRequestID
) override

Parameters

objContext
Request context.
objWriter
lngRequestID

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadioButton Class
RadioButton Members


RadioButton Class Properties

[image]
Gizmox.WebGUI.Forms
RadioButton Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RadioButton Class

For a list of all members of this type, see RadioButton members.

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | Checked | Gets or sets a value indicating whether the control is checked.
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Control)
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

See Also

Reference

RadioButton Class
Gizmox.WebGUI.Forms Namespace


Checked Property

[image]
Gizmox.WebGUI.Forms
Checked Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RadioButton Class : Checked Property

Gets or sets a value indicating whether the control is checked.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<SRDescriptionAttribute("Indicates whether the radio button is checked or not.")>
<SRCategoryAttribute("Appearance")>
<BindableAttribute(True)>
Public Property Checked As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RadioButton
Dim value As Boolean

instance.Checked = value

value = instance.Checked
C#
[DefaultValueAttribute()]
[SRDescriptionAttribute("Indicates whether the radio button is checked or not.")]
[SRCategoryAttribute("Appearance")]
[BindableAttribute(true)]
public bool Checked {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[SRDescriptionAttribute("Indicates whether the radio button is checked or not.")]
[SRCategoryAttribute("Appearance")]
[BindableAttribute(true)]
public: __property bool get_Checked();
public: __property void set_Checked(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
[SRDescriptionAttribute("Indicates whether the radio button is checked or not.")]
[SRCategoryAttribute("Appearance")]
[BindableAttribute(true)]
public:
property bool Checked {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadioButton Class
RadioButton Members


RadioButton Class Events

[image]
Gizmox.WebGUI.Forms
RadioButton Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RadioButton Class

For a list of all members of this type, see RadioButton members.

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | CheckedChanged | Occurs when the value of the Checked property changes.
Public Event | CheckedChangedQueued | Occurs when checked property value queued for change.
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

RadioButton Class
Gizmox.WebGUI.Forms Namespace


CheckedChanged Event

[image]
Gizmox.WebGUI.Forms
CheckedChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RadioButton Class : CheckedChanged Event

Occurs when the value of the Checked property changes.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs whenever the 'checked' property changes value.")>
Public Event CheckedChanged() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As RadioButton
Dim handler As EventHandler

AddHandler instance.CheckedChanged, handler
C#
[SRDescriptionAttribute("Occurs whenever the 'checked' property changes value.")]
public event EventHandler CheckedChanged()
Managed Extensions for C++
[SRDescriptionAttribute("Occurs whenever the 'checked' property changes value.")]
public: __event EventHandler* CheckedChanged
C++/CLI
[SRDescriptionAttribute("Occurs whenever the 'checked' property changes value.")]
public:
event EventHandler^ CheckedChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadioButton Class
RadioButton Members


CheckedChangedQueued Event

[image]
Gizmox.WebGUI.Forms
CheckedChangedQueued Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RadioButton Class : CheckedChangedQueued Event

Occurs when checked property value queued for change.

Syntax

Visual Basic (Declaration)
Public Event CheckedChangedQueued() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As RadioButton
Dim handler As EventHandler

AddHandler instance.CheckedChangedQueued, handler
C#
public event EventHandler CheckedChangedQueued()
Managed Extensions for C++
public: __event EventHandler* CheckedChangedQueued
C++/CLI
public:
event EventHandler^ CheckedChangedQueued

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RadioButton Class
RadioButton Members


RelatedImageListAttribute Class

[image]
Gizmox.WebGUI.Forms
RelatedImageListAttribute Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RelatedImageListAttribute Class

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AllowMultiple=False, Inherited=True)>
Public NotInheritable Class RelatedImageListAttribute
   Inherits Attribute
Visual Basic (Usage) Copy Code
Dim instance As RelatedImageListAttribute
C#
[AttributeUsageAttribute(AllowMultiple=false, Inherited=true)]
public sealed class RelatedImageListAttribute : Attribute
Managed Extensions for C++
[AttributeUsageAttribute(AllowMultiple=false, Inherited=true)]
public __gc __sealed class RelatedImageListAttribute : public Attribute
C++/CLI
[AttributeUsageAttribute(AllowMultiple=false, Inherited=true)]
public ref class RelatedImageListAttribute sealed : public Attribute

Inheritance Hierarchy

System.Object
System.Attribute
Gizmox.WebGUI.Forms.RelatedImageListAttribute

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

RelatedImageListAttribute Members
Gizmox.WebGUI.Forms Namespace


RelatedImageListAttribute Class Members

[image]
Gizmox.WebGUI.Forms
RelatedImageListAttribute Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : RelatedImageListAttribute Class

The following tables list the members exposed by RelatedImageListAttribute.

Public Constructors

 | Name | Description
Public Constructor | RelatedImageListAttribute Constructor | Initializes a new instance of the RelatedImageListAttribute class.
Top

Public Properties

 | Name | Description
Public Property | RelatedImageList | Gets the related image list.
Public Property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from System.Attribute)
Top

Public Methods

 | Name | Description
Public Method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from System.Attribute)
Public Method | GetHashCode | Returns the hash code for this instance. (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from System.Attribute)
Public Method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from System.Attribute)
Top

See Also

Reference

RelatedImageListAttribute Class
Gizmox.WebGUI.Forms Namespace


RelatedImageListAttribute Constructor

[image]
Gizmox.WebGUI.Forms
RelatedImageListAttribute Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RelatedImageListAttribute Class : RelatedImageListAttribute Constructor

relatedImageList
The related image list.
Initializes a new instance of the RelatedImageListAttribute class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal relatedImageList As String _
)
Visual Basic (Usage) Copy Code
Dim relatedImageList As String

Dim instance As RelatedImageListAttribute(relatedImageList)
C#
public RelatedImageListAttribute(
   string relatedImageList
)
Managed Extensions for C++
public: RelatedImageListAttribute(
   string* relatedImageList
)
C++/CLI
public:
RelatedImageListAttribute(
   String^ relatedImageList
)

Parameters

relatedImageList
The related image list.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RelatedImageListAttribute Class
RelatedImageListAttribute Members


RelatedImageListAttribute Class Properties

[image]
Gizmox.WebGUI.Forms
RelatedImageListAttribute Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RelatedImageListAttribute Class

For a list of all members of this type, see RelatedImageListAttribute members.

Public Properties

 | Name | Description
Public Property | RelatedImageList | Gets the related image list.
Public Property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from System.Attribute)
Top

See Also

Reference

RelatedImageListAttribute Class
Gizmox.WebGUI.Forms Namespace


RelatedImageList Property

[image]
Gizmox.WebGUI.Forms
RelatedImageList Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RelatedImageListAttribute Class : RelatedImageList Property

Gets the related image list.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RelatedImageList As String
Visual Basic (Usage) Copy Code
Dim instance As RelatedImageListAttribute
Dim value As String

value = instance.RelatedImageList
C#
public string RelatedImageList {get;}
Managed Extensions for C++
public: __property string* get_RelatedImageList();
C++/CLI
public:
property String^ RelatedImageList {
   String^ get();
}

Return Value

The related image list.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RelatedImageListAttribute Class
RelatedImageListAttribute Members


RichTextBox Class

[image]
Gizmox.WebGUI.Forms
RichTextBox Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RichTextBox Class

Represents a Gizmox.WebGUI.Forms rich text box control.

Object Model

Syntax

Visual Basic (Declaration)
<MetadataTagAttribute("RX")>
<WebCompilerPagesAttribute(Assembly=Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d,
   Namespace="Gizmox.WebGUI.Forms",
   Resoruces=System.String[])>
<SRDescriptionAttribute("Provides advanced text entry and editing features such as character and paragraph formatting.")>
<ToolboxBitmapAttribute()>
<ClientControllerAttribute()>
<SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableRichTextBox, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")>
<ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<DesignTimeControllerAttribute()>
<ToolboxItemCategoryAttribute("Common Controls")>
Public Class RichTextBox
   Inherits TextBoxBase
   Implements IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Visual Basic (Usage) Copy Code
Dim instance As RichTextBox
C#
[MetadataTagAttribute("RX")]
[WebCompilerPagesAttribute(Assembly=Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d,
   Namespace="Gizmox.WebGUI.Forms",
   Resoruces=System.String[])]
[SRDescriptionAttribute("Provides advanced text entry and editing features such as character and paragraph formatting.")]
[ToolboxBitmapAttribute()]
[ClientControllerAttribute()]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableRichTextBox, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[DesignTimeControllerAttribute()]
[ToolboxItemCategoryAttribute("Common Controls")]
public class RichTextBox : TextBoxBase, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Managed Extensions for C++
[MetadataTagAttribute("RX")]
[WebCompilerPagesAttribute(Assembly=Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d,
   Namespace="Gizmox.WebGUI.Forms",
   Resoruces=System.String[])]
[SRDescriptionAttribute("Provides advanced text entry and editing features such as character and paragraph formatting.")]
[ToolboxBitmapAttribute()]
[ClientControllerAttribute()]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableRichTextBox, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[DesignTimeControllerAttribute()]
[ToolboxItemCategoryAttribute("Common Controls")]
public __gc class RichTextBox : public TextBoxBase, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
C++/CLI
[MetadataTagAttribute("RX")]
[WebCompilerPagesAttribute(Assembly=Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d,
   Namespace="Gizmox.WebGUI.Forms",
   Resoruces=System.String[])]
[SRDescriptionAttribute("Provides advanced text entry and editing features such as character and paragraph formatting.")]
[ToolboxBitmapAttribute()]
[ClientControllerAttribute()]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableRichTextBox, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[DesignTimeControllerAttribute()]
[ToolboxItemCategoryAttribute("Common Controls")]
public ref class RichTextBox : public TextBoxBase, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.TextBoxBase
Gizmox.WebGUI.Forms.RichTextBox

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

RichTextBox Members
Gizmox.WebGUI.Forms Namespace


RichTextBox Class Members

[image]
Gizmox.WebGUI.Forms
RichTextBox Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : RichTextBox Class

The following tables list the members exposed by RichTextBox.

Public Constructors

 | Name | Description
Public Constructor | RichTextBox Constructor | Initializes a new instance of the RichTextBox class.
Top

Public Properties

 | Name | Description
Public Property | AcceptsTab | (Inherited from TextBoxBase)
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Overridden. Gets a value indicating whether the control can receive focus.
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | Html | Gets or sets the HTML string.
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Lines | (Inherited from TextBoxBase)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MaxLength | (Inherited from TextBoxBase)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Multiline | Gets or sets a value indicating whether text box is multi line.
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | ReadOnly | Gets or sets a value indicating whether [read only]. (Inherited from TextBoxBase)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | SelectedText | Gets or sets a value indicating the currently selected text in the control. (Inherited from TextBoxBase)
Public Property | SelectionFont | Gets or sets the font of the current text selection or insertion point.
Public Property | SelectionLength | Gets or sets the number of characters selected in the text box. (Inherited from TextBoxBase)
Public Property | SelectionStart | Gets or sets the starting point of text selected in the text box. (Inherited from TextBoxBase)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Control)
Public Property | TextLength | Gets the length of text in the control. (Inherited from TextBoxBase)
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Public Property | WordWrap | (Inherited from TextBoxBase)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | Overridden. Gets the default back color of the control.
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | Overridden. Gets the default border style.
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

Public Methods

 | Name | Description
Public Method | AppendText | Appends text to the current text of a text box. (Inherited from TextBoxBase)
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Clear | Clears all text from the text box control. (Inherited from TextBoxBase)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | Copy | Copies the current selection in the text box to the Clipboard. (Inherited from TextBoxBase)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Cut | Moves the current selection in the text box to the Clipboard. (Inherited from TextBoxBase)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | Paste | Replaces the current selection in the text box with the contents of the Clipboard. (Inherited from TextBoxBase)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | Print | Prints the current RichTextBox content
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | ScrollToCaret | Scrolls the contents of the control to the current caret position. (Inherited from TextBoxBase)
Public Method | Select | Overloaded. Selects a range of text in the text box. (Inherited from TextBoxBase)
Public Method | SelectAll | Selects all text in the text box. (Inherited from TextBoxBase)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | DoImageInsert |
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Overridden. Fires an event.
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetClipboardContent |
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Overridden.
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from Control)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | InvokeSelection | Invokes client side selection (Inherited from TextBoxBase)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Control)
Protected Method | RenderAttributes | Renders the current control attributes. (Inherited from TextBoxBase)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | Render control params (Inherited from TextBoxBase)
Protected Method | RenderValue | Overridden.
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetClipboardContent |
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | HtmlChange |
Public Event | HtmlChangeQueued |
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

RichTextBox Class
Gizmox.WebGUI.Forms Namespace


RichTextBox Constructor

[image]
Gizmox.WebGUI.Forms
RichTextBox Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RichTextBox Class : RichTextBox Constructor

Initializes a new instance of the RichTextBox class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RichTextBox()
C#
public RichTextBox()
Managed Extensions for C++
public: RichTextBox();
C++/CLI
public:
RichTextBox();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RichTextBox Class
RichTextBox Members


RichTextBox Class Methods

[image]
Gizmox.WebGUI.Forms
RichTextBox Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RichTextBox Class

For a list of all members of this type, see RichTextBox members.

Public Methods

 | Name | Description
Public Method | AppendText | Appends text to the current text of a text box. (Inherited from TextBoxBase)
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Clear | Clears all text from the text box control. (Inherited from TextBoxBase)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | Copy | Copies the current selection in the text box to the Clipboard. (Inherited from TextBoxBase)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Cut | Moves the current selection in the text box to the Clipboard. (Inherited from TextBoxBase)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | Paste | Replaces the current selection in the text box with the contents of the Clipboard. (Inherited from TextBoxBase)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | Print | Prints the current RichTextBox content
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | ScrollToCaret | Scrolls the contents of the control to the current caret position. (Inherited from TextBoxBase)
Public Method | Select | Overloaded. Selects a range of text in the text box. (Inherited from TextBoxBase)
Public Method | SelectAll | Selects all text in the text box. (Inherited from TextBoxBase)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | DoImageInsert |
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Overridden. Fires an event.
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetClipboardContent |
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Overridden.
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from Control)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | InvokeSelection | Invokes client side selection (Inherited from TextBoxBase)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Control)
Protected Method | RenderAttributes | Renders the current control attributes. (Inherited from TextBoxBase)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | Render control params (Inherited from TextBoxBase)
Protected Method | RenderValue | Overridden.
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetClipboardContent |
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

See Also

Reference

RichTextBox Class
Gizmox.WebGUI.Forms Namespace


DoImageInsert Method

[image]
Gizmox.WebGUI.Forms
DoImageInsert Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RichTextBox Class : DoImageInsert Method

strArg

Syntax

Visual Basic (Declaration)
Protected Function DoImageInsert( _
   ByVal strArg As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As RichTextBox
Dim strArg As String
Dim value As String

value = instance.DoImageInsert(strArg)
C#
protected string DoImageInsert(
   string strArg
)
Managed Extensions for C++
protected: string* DoImageInsert(
   string* strArg
)
C++/CLI
protected:
String^ DoImageInsert(
   String^ strArg
)

Parameters

strArg

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RichTextBox Class
RichTextBox Members


FireEvent Method

[image]
Gizmox.WebGUI.Forms
FireEvent Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RichTextBox Class : FireEvent Method

objEvent
event.
Fires an event.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub FireEvent( _
   ByVal objEvent As IEvent _
)
Visual Basic (Usage) Copy Code
Dim instance As RichTextBox
Dim objEvent As IEvent

instance.FireEvent(objEvent)
C#
protected override void FireEvent(
   IEvent objEvent
)
Managed Extensions for C++
protected: void FireEvent(
   IEvent* objEvent
) override
C++/CLI
protected:
void FireEvent(
   IEvent^ objEvent
) override

Parameters

objEvent
event.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RichTextBox Class
RichTextBox Members


GetClipboardContent Method

[image]
Gizmox.WebGUI.Forms
GetClipboardContent Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RichTextBox Class : GetClipboardContent Method

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetClipboardContent() As String
Visual Basic (Usage) Copy Code
Dim instance As RichTextBox
Dim value As String

value = instance.GetClipboardContent()
C#
protected virtual string GetClipboardContent()
Managed Extensions for C++
protected: virtual string* GetClipboardContent();
C++/CLI
protected:
virtual String^ GetClipboardContent();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RichTextBox Class
RichTextBox Members


GetCriticalEvents Method

[image]
Gizmox.WebGUI.Forms
GetCriticalEvents Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RichTextBox Class : GetCriticalEvents Method

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetCriticalEvents() As EventTypes
Visual Basic (Usage) Copy Code
Dim instance As RichTextBox
Dim value As EventTypes

value = instance.GetCriticalEvents()
C#
protected override EventTypes GetCriticalEvents()
Managed Extensions for C++
protected: EventTypes GetCriticalEvents(); override
C++/CLI
protected:
EventTypes GetCriticalEvents(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RichTextBox Class
RichTextBox Members


Print Method

[image]
Gizmox.WebGUI.Forms
Print Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RichTextBox Class : Print Method

Prints the current RichTextBox content

Syntax

Visual Basic (Declaration)
Public Sub Print()
Visual Basic (Usage) Copy Code
Dim instance As RichTextBox

instance.Print()
C#
public void Print()
Managed Extensions for C++
public: void Print();
C++/CLI
public:
void Print();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RichTextBox Class
RichTextBox Members


RenderValue Method

[image]
Gizmox.WebGUI.Forms
RenderValue Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RichTextBox Class : RenderValue Method

objContext
objWriter

Syntax

Visual Basic (Declaration)
Protected Overrides Sub RenderValue( _
   ByVal objContext As IContext, _
   ByVal objWriter As IAttributeWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As RichTextBox
Dim objContext As IContext
Dim objWriter As IAttributeWriter

instance.RenderValue(objContext, objWriter)
C#
protected override void RenderValue(
   IContext objContext,
   IAttributeWriter objWriter
)
Managed Extensions for C++
protected: void RenderValue(
   IContext* objContext,
   IAttributeWriter* objWriter
) override
C++/CLI
protected:
void RenderValue(
   IContext^ objContext,
   IAttributeWriter^ objWriter
) override

Parameters

objContext
objWriter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RichTextBox Class
RichTextBox Members


SetClipboardContent Method

[image]
Gizmox.WebGUI.Forms
SetClipboardContent Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RichTextBox Class : SetClipboardContent Method

strValue

Syntax

Visual Basic (Declaration)
Protected Overridable Sub SetClipboardContent( _
   ByVal strValue As String _
)
Visual Basic (Usage) Copy Code
Dim instance As RichTextBox
Dim strValue As String

instance.SetClipboardContent(strValue)
C#
protected virtual void SetClipboardContent(
   string strValue
)
Managed Extensions for C++
protected: virtual void SetClipboardContent(
   string* strValue
)
C++/CLI
protected:
virtual void SetClipboardContent(
   String^ strValue
)

Parameters

strValue

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RichTextBox Class
RichTextBox Members


RichTextBox Class Properties

[image]
Gizmox.WebGUI.Forms
RichTextBox Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RichTextBox Class

For a list of all members of this type, see RichTextBox members.

Public Properties

 | Name | Description
Public Property | AcceptsTab | (Inherited from TextBoxBase)
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Overridden. Gets a value indicating whether the control can receive focus.
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | Html | Gets or sets the HTML string.
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Lines | (Inherited from TextBoxBase)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MaxLength | (Inherited from TextBoxBase)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Multiline | Gets or sets a value indicating whether text box is multi line.
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | ReadOnly | Gets or sets a value indicating whether [read only]. (Inherited from TextBoxBase)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | SelectedText | Gets or sets a value indicating the currently selected text in the control. (Inherited from TextBoxBase)
Public Property | SelectionFont | Gets or sets the font of the current text selection or insertion point.
Public Property | SelectionLength | Gets or sets the number of characters selected in the text box. (Inherited from TextBoxBase)
Public Property | SelectionStart | Gets or sets the starting point of text selected in the text box. (Inherited from TextBoxBase)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Control)
Public Property | TextLength | Gets the length of text in the control. (Inherited from TextBoxBase)
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Public Property | WordWrap | (Inherited from TextBoxBase)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | Overridden. Gets the default back color of the control.
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | Overridden. Gets the default border style.
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

See Also

Reference

RichTextBox Class
Gizmox.WebGUI.Forms Namespace


CanFocus Property

[image]
Gizmox.WebGUI.Forms
CanFocus Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RichTextBox Class : CanFocus Property

Gets a value indicating whether the control can receive focus.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanFocus As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RichTextBox
Dim value As Boolean

value = instance.CanFocus
C#
public override bool CanFocus {get;}
Managed Extensions for C++
public: __property bool get_CanFocus() override;
C++/CLI
public:
property bool CanFocus {
   bool get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RichTextBox Class
RichTextBox Members


DefaultBackColor Property

[image]
Gizmox.WebGUI.Forms
DefaultBackColor Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RichTextBox Class : DefaultBackColor Property

Gets the default back color of the control.

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property DefaultBackColor As Color
Visual Basic (Usage) Copy Code
Dim instance As RichTextBox
Dim value As Color

value = instance.DefaultBackColor
C#
protected override Color DefaultBackColor {get;}
Managed Extensions for C++
protected: __property Color get_DefaultBackColor() override;
C++/CLI
protected:
property Color DefaultBackColor {
   Color get() override;
}

Return Value

The default back color of the control

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RichTextBox Class
RichTextBox Members


DefaultBorderStyle Property

[image]
Gizmox.WebGUI.Forms
DefaultBorderStyle Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RichTextBox Class : DefaultBorderStyle Property

Gets the default border style.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Indicates whether the edit control should have a border.")>
<SRCategoryAttribute("Appearance")>
<DefaultValueAttribute()>
Protected Overrides ReadOnly Property DefaultBorderStyle As BorderStyle
Visual Basic (Usage) Copy Code
Dim instance As RichTextBox
Dim value As BorderStyle

value = instance.DefaultBorderStyle
C#
[SRDescriptionAttribute("Indicates whether the edit control should have a border.")]
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
protected override BorderStyle DefaultBorderStyle {get;}
Managed Extensions for C++
[SRDescriptionAttribute("Indicates whether the edit control should have a border.")]
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
protected: __property BorderStyle get_DefaultBorderStyle() override;
C++/CLI
[SRDescriptionAttribute("Indicates whether the edit control should have a border.")]
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
protected:
property BorderStyle DefaultBorderStyle {
   BorderStyle get() override;
}

Return Value

The default border style.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RichTextBox Class
RichTextBox Members


Html Property

[image]
Gizmox.WebGUI.Forms
Html Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RichTextBox Class : Html Property

Gets or sets the HTML string.

Syntax

Visual Basic (Declaration)
Public Property Html As String
Visual Basic (Usage) Copy Code
Dim instance As RichTextBox
Dim value As String

instance.Html = value

value = instance.Html
C#
public string Html {get; set;}
Managed Extensions for C++
public: __property string* get_Html();
public: __property void set_Html(
   string* value
);
C++/CLI
public:
property String^ Html {
   String^ get();
   void set (String^value);
}

Return Value

The HTML string.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RichTextBox Class
RichTextBox Members


Multiline Property

[image]
Gizmox.WebGUI.Forms
Multiline Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RichTextBox Class : Multiline Property

Gets or sets a value indicating whether text box is multi line.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<DefaultValueAttribute()>
Public ReadOnly Property Multiline As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RichTextBox
Dim value As Boolean

value = instance.Multiline
C#
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
public bool Multiline {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
public: __property bool get_Multiline();
C++/CLI
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
public:
property bool Multiline {
   bool get();
}

Return Value

true if multi line otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RichTextBox Class
RichTextBox Members


SelectionFont Property

[image]
Gizmox.WebGUI.Forms
SelectionFont Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RichTextBox Class : SelectionFont Property

Gets or sets the font of the current text selection or insertion point.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<SRDescriptionAttribute("Defines the font of the currently selected text.")>
<DesignerSerializationVisibilityAttribute()>
Public Property SelectionFont As Font
Visual Basic (Usage) Copy Code
Dim instance As RichTextBox
Dim value As Font

instance.SelectionFont = value

value = instance.SelectionFont
C#
[BrowsableAttribute(false)]
[SRDescriptionAttribute("Defines the font of the currently selected text.")]
[DesignerSerializationVisibilityAttribute()]
public Font SelectionFont {get; set;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[SRDescriptionAttribute("Defines the font of the currently selected text.")]
[DesignerSerializationVisibilityAttribute()]
public: __property Font* get_SelectionFont();
public: __property void set_SelectionFont(
   Font* value
);
C++/CLI
[BrowsableAttribute(false)]
[SRDescriptionAttribute("Defines the font of the currently selected text.")]
[DesignerSerializationVisibilityAttribute()]
public:
property Font^ SelectionFont {
   Font^ get();
   void set (Font^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RichTextBox Class
RichTextBox Members


RichTextBox Class Events

[image]
Gizmox.WebGUI.Forms
RichTextBox Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RichTextBox Class

For a list of all members of this type, see RichTextBox members.

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | HtmlChange |
Public Event | HtmlChangeQueued |
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

RichTextBox Class
Gizmox.WebGUI.Forms Namespace


HtmlChange Event

[image]
Gizmox.WebGUI.Forms
HtmlChange Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RichTextBox Class : HtmlChange Event

Syntax

Visual Basic (Declaration)
Public Event HtmlChange() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As RichTextBox
Dim handler As EventHandler

AddHandler instance.HtmlChange, handler
C#
public event EventHandler HtmlChange()
Managed Extensions for C++
public: __event EventHandler* HtmlChange
C++/CLI
public:
event EventHandler^ HtmlChange

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RichTextBox Class
RichTextBox Members


HtmlChangeQueued Event

[image]
Gizmox.WebGUI.Forms
HtmlChangeQueued Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RichTextBox Class : HtmlChangeQueued Event

Syntax

Visual Basic (Declaration)
Public Event HtmlChangeQueued() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As RichTextBox
Dim handler As EventHandler

AddHandler instance.HtmlChangeQueued, handler
C#
public event EventHandler HtmlChangeQueued()
Managed Extensions for C++
public: __event EventHandler* HtmlChangeQueued
C++/CLI
public:
event EventHandler^ HtmlChangeQueued

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RichTextBox Class
RichTextBox Members


RowStyle Class

[image]
Gizmox.WebGUI.Forms
RowStyle Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RowStyle Class

Syntax

Visual Basic (Declaration)
<ClientControllerAttribute()>
<DesignTimeControllerAttribute()>
Public Class RowStyle
   Inherits TableLayoutStyle
   Implements IObservableItem
Visual Basic (Usage) Copy Code
Dim instance As RowStyle
C#
[ClientControllerAttribute()]
[DesignTimeControllerAttribute()]
public class RowStyle : TableLayoutStyle, IObservableItem
Managed Extensions for C++
[ClientControllerAttribute()]
[DesignTimeControllerAttribute()]
public __gc class RowStyle : public TableLayoutStyle, IObservableItem
C++/CLI
[ClientControllerAttribute()]
[DesignTimeControllerAttribute()]
public ref class RowStyle : public TableLayoutStyle, IObservableItem

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.TableLayoutStyle
Gizmox.WebGUI.Forms.RowStyle

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

RowStyle Members
Gizmox.WebGUI.Forms Namespace


RowStyle Class Members

[image]
Gizmox.WebGUI.Forms
RowStyle Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : RowStyle Class

The following tables list the members exposed by RowStyle.

Public Constructors

 | Name | Description
Public Constructor | RowStyle Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Height | Gets or sets the height.
Public Property | SizeType | (Inherited from TableLayoutStyle)
Top

Protected Methods

 | Name | Description
Protected Method | FireObservableItemPropertyChanged | Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from TableLayoutStyle)
Top

See Also

Reference

RowStyle Class
Gizmox.WebGUI.Forms Namespace


RowStyle Constructor

[image]
Gizmox.WebGUI.Forms
RowStyle Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RowStyle Class : RowStyle Constructor

Overload List

Overload | Description
RowStyle Constructor() |
RowStyle Constructor(Int32) |
RowStyle Constructor(SizeType) |
RowStyle Constructor(SizeType,Single) |
RowStyle Constructor(String) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RowStyle Class
RowStyle Members


RowStyle Constructor()

[image]
Gizmox.WebGUI.Forms
RowStyle Constructor()
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RowStyle Class > RowStyle Constructor : RowStyle Constructor()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RowStyle()
C#
public RowStyle()
Managed Extensions for C++
public: RowStyle();
C++/CLI
public:
RowStyle();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RowStyle Class
RowStyle Members
Overload List


RowStyle Constructor(Int32)

[image]
Gizmox.WebGUI.Forms
RowStyle Constructor(Int32)
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RowStyle Class > RowStyle Constructor : RowStyle Constructor(Int32)

intHight

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal intHight As Integer _
)
Visual Basic (Usage) Copy Code
Dim intHight As Integer

Dim instance As RowStyle(intHight)
C#
public RowStyle(
   int intHight
)
Managed Extensions for C++
public: RowStyle(
   int intHight
)
C++/CLI
public:
RowStyle(
   int intHight
)

Parameters

intHight

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RowStyle Class
RowStyle Members
Overload List


RowStyle Constructor(SizeType)

[image]
Gizmox.WebGUI.Forms
RowStyle Constructor(SizeType)
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RowStyle Class > RowStyle Constructor : RowStyle Constructor(SizeType)

sizeType

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal sizeType As SizeType _
)
Visual Basic (Usage) Copy Code
Dim sizeType As SizeType

Dim instance As RowStyle(sizeType)
C#
public RowStyle(
   SizeType sizeType
)
Managed Extensions for C++
public: RowStyle(
   SizeType sizeType
)
C++/CLI
public:
RowStyle(
   SizeType sizeType
)

Parameters

sizeType

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RowStyle Class
RowStyle Members
Overload List


RowStyle Constructor(SizeType,Single)

[image]
Gizmox.WebGUI.Forms
RowStyle Constructor(SizeType,Single)
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RowStyle Class > RowStyle Constructor : RowStyle Constructor(SizeType,Single)

sizeType
height

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal sizeType As SizeType, _
   ByVal height As Single _
)
Visual Basic (Usage) Copy Code
Dim sizeType As SizeType
Dim height As Single

Dim instance As RowStyle(sizeType, height)
C#
public RowStyle(
   SizeType sizeType,
   float height
)
Managed Extensions for C++
public: RowStyle(
   SizeType sizeType,
   float height
)
C++/CLI
public:
RowStyle(
   SizeType sizeType,
   float height
)

Parameters

sizeType
height

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RowStyle Class
RowStyle Members
Overload List


RowStyle Constructor(String)

[image]
Gizmox.WebGUI.Forms
RowStyle Constructor(String)
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RowStyle Class > RowStyle Constructor : RowStyle Constructor(String)

strHight

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal strHight As String _
)
Visual Basic (Usage) Copy Code
Dim strHight As String

Dim instance As RowStyle(strHight)
C#
public RowStyle(
   string strHight
)
Managed Extensions for C++
public: RowStyle(
   string* strHight
)
C++/CLI
public:
RowStyle(
   String^ strHight
)

Parameters

strHight

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RowStyle Class
RowStyle Members
Overload List


RowStyle Class Properties

[image]
Gizmox.WebGUI.Forms
RowStyle Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RowStyle Class

For a list of all members of this type, see RowStyle members.

Public Properties

 | Name | Description
Public Property | Height | Gets or sets the height.
Public Property | SizeType | (Inherited from TableLayoutStyle)
Top

See Also

Reference

RowStyle Class
Gizmox.WebGUI.Forms Namespace


Height Property

[image]
Gizmox.WebGUI.Forms
Height Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RowStyle Class : Height Property

Gets or sets the height.

Syntax

Visual Basic (Declaration)
Public Property Height As Single
Visual Basic (Usage) Copy Code
Dim instance As RowStyle
Dim value As Single

instance.Height = value

value = instance.Height
C#
public float Height {get; set;}
Managed Extensions for C++
public: __property float get_Height();
public: __property void set_Height(
   float value
);
C++/CLI
public:
property float Height {
   float get();
   void set (floatvalue);
}

Return Value

The height.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RowStyle Class
RowStyle Members


Screen Class

[image]
Gizmox.WebGUI.Forms
Screen Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : Screen Class

Represents a display device or multiple display devices on a single system.

Syntax

Visual Basic (Declaration)
Public Class Screen
Visual Basic (Usage) Copy Code
Dim instance As Screen
C#
public class Screen
Managed Extensions for C++
public __gc class Screen
C++/CLI
public ref class Screen

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.Screen

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Screen Members
Gizmox.WebGUI.Forms Namespace


Screen Class Members

[image]
Gizmox.WebGUI.Forms
Screen Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : Screen Class

The following tables list the members exposed by Screen.

Public Properties

 | Name | Description
static (Shared in Visual Basic) | AllScreens | Gets an array of all displays on the system.
Public Property | BitsPerPixel | Gets the number of bits of memory, associated with one pixel of data.
Public Property | Bounds | Gets the bounds of the display.
Public Property | DeviceName | Gets the device name associated with a display.
Public Property | Primary | Gets a value indicating whether a particular display is the primary device.
static (Shared in Visual Basic) | PrimaryScreen | Gets the primary display.
Public Property | WorkingArea | Gets the working area of the display. The working area is the desktop area of the display, excluding taskbars, docked windows, and docked tool bars.
Top

Public Methods

 | Name | Description
Public Method | Equals | Overridden. Gets or sets a value indicating whether the specified object is equal to this Screen.
static (Shared in Visual Basic) | FromControl | Retrieves a Screen for the display that contains the largest portion of the specified control.
static (Shared in Visual Basic) | FromHandle | Retrieves a Screen for the display that contains the largest portion of the object referred to by the specified handle.
static (Shared in Visual Basic) | FromPoint | Retrieves a Screen for the display that contains the specified point.
static (Shared in Visual Basic) | FromRectangle | Retrieves a Screen for the display that contains the largest portion of the rectangle.
static (Shared in Visual Basic) | GetBounds | Overloaded. Retrieves the bounds of the display that contains the largest portion of the specified rectangle.
Public Method | GetHashCode | Overridden. Computes and retrieves a hash code for an object.
static (Shared in Visual Basic) | GetWorkingArea | Overloaded. Retrieves the working area closest to the specified point. The working area is the desktop area of the display, excluding taskbars, docked windows, and docked tool bars.
Public Method | ToString | Overridden. Retrieves a string representing this object.
Top

See Also

Reference

Screen Class
Gizmox.WebGUI.Forms Namespace


Screen Class Methods

[image]
Gizmox.WebGUI.Forms
Screen Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : Screen Class

For a list of all members of this type, see Screen members.

Public Methods

 | Name | Description
Public Method | Equals | Overridden. Gets or sets a value indicating whether the specified object is equal to this Screen.
static (Shared in Visual Basic) | FromControl | Retrieves a Screen for the display that contains the largest portion of the specified control.
static (Shared in Visual Basic) | FromHandle | Retrieves a Screen for the display that contains the largest portion of the object referred to by the specified handle.
static (Shared in Visual Basic) | FromPoint | Retrieves a Screen for the display that contains the specified point.
static (Shared in Visual Basic) | FromRectangle | Retrieves a Screen for the display that contains the largest portion of the rectangle.
static (Shared in Visual Basic) | GetBounds | Overloaded. Retrieves the bounds of the display that contains the largest portion of the specified rectangle.
Public Method | GetHashCode | Overridden. Computes and retrieves a hash code for an object.
static (Shared in Visual Basic) | GetWorkingArea | Overloaded. Retrieves the working area closest to the specified point. The working area is the desktop area of the display, excluding taskbars, docked windows, and docked tool bars.
Public Method | ToString | Overridden. Retrieves a string representing this object.
Top

See Also

Reference

Screen Class
Gizmox.WebGUI.Forms Namespace


Equals Method

[image]
Gizmox.WebGUI.Forms
Equals Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Screen Class : Equals Method

obj
The object to compare to this Screen.
Gets or sets a value indicating whether the specified object is equal to this Screen.

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Screen
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
C#
public override bool Equals(
   object obj
)
Managed Extensions for C++
public: bool Equals(
   Object* obj
) override
C++/CLI
public:
bool Equals(
   Object^ obj
) override

Parameters

obj
The object to compare to this Screen.

Return Value

true if the specified object is equal to this Screen; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Screen Class
Screen Members


FromControl Method

[image]
Gizmox.WebGUI.Forms
FromControl Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Screen Class : FromControl Method

control
A Control for which to retrieve a Screen.
Retrieves a Screen for the display that contains the largest portion of the specified control.

Syntax

Visual Basic (Declaration)
Public Shared Function FromControl( _
   ByVal control As Control _
) As Screen
Visual Basic (Usage) Copy Code
Dim control As Control
Dim value As Screen

value = Screen.FromControl(control)
C#
public static Screen FromControl(
   Control control
)
Managed Extensions for C++
public: static Screen* FromControl(
   Control* control
)
C++/CLI
public:
static Screen^ FromControl(
   Control^ control
)

Parameters

control
A Control for which to retrieve a Screen.

Return Value

A Screen for the display that contains the largest region of the specified control. In multiple display environments where no display contains the control, the display closest to the specified control is returned.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Screen Class
Screen Members


FromHandle Method

[image]
Gizmox.WebGUI.Forms
FromHandle Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Screen Class : FromHandle Method

hwnd
The window handle for which to retrieve the Screen.
Retrieves a Screen for the display that contains the largest portion of the object referred to by the specified handle.

Syntax

Visual Basic (Declaration)
Public Shared Function FromHandle( _
   ByVal hwnd As IntPtr _
) As Screen
Visual Basic (Usage) Copy Code
Dim hwnd As IntPtr
Dim value As Screen

value = Screen.FromHandle(hwnd)
C#
public static Screen FromHandle(
   IntPtr hwnd
)
Managed Extensions for C++
public: static Screen* FromHandle(
   IntPtr hwnd
)
C++/CLI
public:
static Screen^ FromHandle(
   IntPtr hwnd
)

Parameters

hwnd
The window handle for which to retrieve the Screen.

Return Value

A Screen for the display that contains the largest region of the object. In multiple display environments where no display contains any portion of the specified window, the display closest to the object is returned.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Screen Class
Screen Members


FromPoint Method

[image]
Gizmox.WebGUI.Forms
FromPoint Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Screen Class : FromPoint Method

point
A Point that specifies the location for which to retrieve a Screen.
Retrieves a Screen for the display that contains the specified point.

Syntax

Visual Basic (Declaration)
Public Shared Function FromPoint( _
   ByVal point As Point _
) As Screen
Visual Basic (Usage) Copy Code
Dim point As Point
Dim value As Screen

value = Screen.FromPoint(point)
C#
public static Screen FromPoint(
   Point point
)
Managed Extensions for C++
public: static Screen* FromPoint(
   Point point
)
C++/CLI
public:
static Screen^ FromPoint(
   Point point
)

Parameters

point
A Point that specifies the location for which to retrieve a Screen.

Return Value

A Screen for the display that contains the point. In multiple display environments where no display contains the point, the display closest to the specified point is returned.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Screen Class
Screen Members


FromRectangle Method

[image]
Gizmox.WebGUI.Forms
FromRectangle Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Screen Class : FromRectangle Method

rect
A Rectangle that specifies the area for which to retrieve the display.
Retrieves a Screen for the display that contains the largest portion of the rectangle.

Syntax

Visual Basic (Declaration)
Public Shared Function FromRectangle( _
   ByVal rect As Rectangle _
) As Screen
Visual Basic (Usage) Copy Code
Dim rect As Rectangle
Dim value As Screen

value = Screen.FromRectangle(rect)
C#
public static Screen FromRectangle(
   Rectangle rect
)
Managed Extensions for C++
public: static Screen* FromRectangle(
   Rectangle rect
)
C++/CLI
public:
static Screen^ FromRectangle(
   Rectangle rect
)

Parameters

rect
A Rectangle that specifies the area for which to retrieve the display.

Return Value

A Screen for the display that contains the largest region of the specified rectangle. In multiple display environments where no display contains the rectangle, the display closest to the rectangle is returned.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Screen Class
Screen Members


GetBounds Method

[image]
Gizmox.WebGUI.Forms
GetBounds Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Screen Class : GetBounds Method

Retrieves the bounds of the display that contains the largest portion of the specified rectangle.

Overload List

Overload | Description
GetBounds(Point) |
GetBounds(Rectangle) | Retrieves the bounds of the display that contains the largest portion of the specified rectangle.
GetBounds(Control) | Retrieves the bounds of the display that contains the largest portion of the specified control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Screen Class
Screen Members


GetBounds(Point) Method

[image]
Gizmox.WebGUI.Forms
GetBounds(Point) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Screen Class > GetBounds Method : GetBounds(Point) Method

pt

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function GetBounds( _
   ByVal pt As Point _
) As Rectangle
Visual Basic (Usage) Copy Code
Dim pt As Point
Dim value As Rectangle

value = Screen.GetBounds(pt)
C#
public static Rectangle GetBounds(
   Point pt
)
Managed Extensions for C++
public: static Rectangle GetBounds(
   Point pt
)
C++/CLI
public:
static Rectangle GetBounds(
   Point pt
)

Parameters

pt

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Screen Class
Screen Members
Overload List


GetBounds(Rectangle) Method

[image]
Gizmox.WebGUI.Forms
GetBounds(Rectangle) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Screen Class > GetBounds Method : GetBounds(Rectangle) Method

rect
A Rectangle that specifies the area for which to retrieve the display bounds.
Retrieves the bounds of the display that contains the largest portion of the specified rectangle.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function GetBounds( _
   ByVal rect As Rectangle _
) As Rectangle
Visual Basic (Usage) Copy Code
Dim rect As Rectangle
Dim value As Rectangle

value = Screen.GetBounds(rect)
C#
public static Rectangle GetBounds(
   Rectangle rect
)
Managed Extensions for C++
public: static Rectangle GetBounds(
   Rectangle rect
)
C++/CLI
public:
static Rectangle GetBounds(
   Rectangle rect
)

Parameters

rect
A Rectangle that specifies the area for which to retrieve the display bounds.

Return Value

A Rectangle that specifies the bounds of the display that contains the specified rectangle. In multiple display environments where no monitor contains the specified rectangle, the monitor closest to the rectangle is returned.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Screen Class
Screen Members
Overload List


GetBounds(Control) Method

[image]
Gizmox.WebGUI.Forms
GetBounds(Control) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Screen Class > GetBounds Method : GetBounds(Control) Method

ctl
The Control for which to retrieve the display bounds.
Retrieves the bounds of the display that contains the largest portion of the specified control.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function GetBounds( _
   ByVal ctl As Control _
) As Rectangle
Visual Basic (Usage) Copy Code
Dim ctl As Control
Dim value As Rectangle

value = Screen.GetBounds(ctl)
C#
public static Rectangle GetBounds(
   Control ctl
)
Managed Extensions for C++
public: static Rectangle GetBounds(
   Control* ctl
)
C++/CLI
public:
static Rectangle GetBounds(
   Control^ ctl
)

Parameters

ctl
The Control for which to retrieve the display bounds.

Return Value

A Rectangle that specifies the bounds of the display that contains the specified control. In multiple display environments where no display contains the specified control, the display closest to the control is returned.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Screen Class
Screen Members
Overload List


GetHashCode Method

[image]
Gizmox.WebGUI.Forms
GetHashCode Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Screen Class : GetHashCode Method

Computes and retrieves a hash code for an object.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As Screen
Dim value As Integer

value = instance.GetHashCode()
C#
public override int GetHashCode()
Managed Extensions for C++
public: int GetHashCode(); override
C++/CLI
public:
int GetHashCode(); override

Return Value

A hash code for an object.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Screen Class
Screen Members


GetWorkingArea Method

[image]
Gizmox.WebGUI.Forms
GetWorkingArea Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Screen Class : GetWorkingArea Method

Retrieves the working area closest to the specified point. The working area is the desktop area of the display, excluding taskbars, docked windows, and docked tool bars.

Overload List

Overload | Description
GetWorkingArea(Point) | Retrieves the working area closest to the specified point. The working area is the desktop area of the display, excluding taskbars, docked windows, and docked tool bars.
GetWorkingArea(Rectangle) | Retrieves the working area for the display that contains the largest portion of the specified rectangle. The working area is the desktop area of the display, excluding taskbars, docked windows, and docked tool bars.
GetWorkingArea(Control) | Retrieves the working area for the display that contains the largest region of the specified control. The working area is the desktop area of the display, excluding taskbars, docked windows, and docked tool bars.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Screen Class
Screen Members


GetWorkingArea(Point) Method

[image]
Gizmox.WebGUI.Forms
GetWorkingArea(Point) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Screen Class > GetWorkingArea Method : GetWorkingArea(Point) Method

pt
A Point that specifies the coordinates for which to retrieve the working area.
Retrieves the working area closest to the specified point. The working area is the desktop area of the display, excluding taskbars, docked windows, and docked tool bars.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function GetWorkingArea( _
   ByVal pt As Point _
) As Rectangle
Visual Basic (Usage) Copy Code
Dim pt As Point
Dim value As Rectangle

value = Screen.GetWorkingArea(pt)
C#
public static Rectangle GetWorkingArea(
   Point pt
)
Managed Extensions for C++
public: static Rectangle GetWorkingArea(
   Point pt
)
C++/CLI
public:
static Rectangle GetWorkingArea(
   Point pt
)

Parameters

pt
A Point that specifies the coordinates for which to retrieve the working area.

Return Value

A Rectangle that specifies the working area. In multiple display environments where no display contains the specified point, the display closest to the point is returned.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Screen Class
Screen Members
Overload List


GetWorkingArea(Rectangle) Method

[image]
Gizmox.WebGUI.Forms
GetWorkingArea(Rectangle) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Screen Class > GetWorkingArea Method : GetWorkingArea(Rectangle) Method

rect
The Rectangle that specifies the area for which to retrieve the working area.
Retrieves the working area for the display that contains the largest portion of the specified rectangle. The working area is the desktop area of the display, excluding taskbars, docked windows, and docked tool bars.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function GetWorkingArea( _
   ByVal rect As Rectangle _
) As Rectangle
Visual Basic (Usage) Copy Code
Dim rect As Rectangle
Dim value As Rectangle

value = Screen.GetWorkingArea(rect)
C#
public static Rectangle GetWorkingArea(
   Rectangle rect
)
Managed Extensions for C++
public: static Rectangle GetWorkingArea(
   Rectangle rect
)
C++/CLI
public:
static Rectangle GetWorkingArea(
   Rectangle rect
)

Parameters

rect
The Rectangle that specifies the area for which to retrieve the working area.

Return Value

A Rectangle that specifies the working area. In multiple display environments where no display contains the specified rectangle, the display closest to the rectangle is returned.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Screen Class
Screen Members
Overload List


GetWorkingArea(Control) Method

[image]
Gizmox.WebGUI.Forms
GetWorkingArea(Control) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Screen Class > GetWorkingArea Method : GetWorkingArea(Control) Method

ctl
The Control for which to retrieve the working area.
Retrieves the working area for the display that contains the largest region of the specified control. The working area is the desktop area of the display, excluding taskbars, docked windows, and docked tool bars.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function GetWorkingArea( _
   ByVal ctl As Control _
) As Rectangle
Visual Basic (Usage) Copy Code
Dim ctl As Control
Dim value As Rectangle

value = Screen.GetWorkingArea(ctl)
C#
public static Rectangle GetWorkingArea(
   Control ctl
)
Managed Extensions for C++
public: static Rectangle GetWorkingArea(
   Control* ctl
)
C++/CLI
public:
static Rectangle GetWorkingArea(
   Control^ ctl
)

Parameters

ctl
The Control for which to retrieve the working area.

Return Value

A Rectangle that specifies the working area. In multiple display environments where no display contains the specified control, the display closest to the control is returned.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Screen Class
Screen Members
Overload List


ToString Method

[image]
Gizmox.WebGUI.Forms
ToString Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Screen Class : ToString Method

Retrieves a string representing this object.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As Screen
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Return Value

A string representation of the object.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Screen Class
Screen Members


Screen Class Properties

[image]
Gizmox.WebGUI.Forms
Screen Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : Screen Class

For a list of all members of this type, see Screen members.

Public Properties

 | Name | Description
static (Shared in Visual Basic) | AllScreens | Gets an array of all displays on the system.
Public Property | BitsPerPixel | Gets the number of bits of memory, associated with one pixel of data.
Public Property | Bounds | Gets the bounds of the display.
Public Property | DeviceName | Gets the device name associated with a display.
Public Property | Primary | Gets a value indicating whether a particular display is the primary device.
static (Shared in Visual Basic) | PrimaryScreen | Gets the primary display.
Public Property | WorkingArea | Gets the working area of the display. The working area is the desktop area of the display, excluding taskbars, docked windows, and docked tool bars.
Top

See Also

Reference

Screen Class
Gizmox.WebGUI.Forms Namespace


AllScreens Property

[image]
Gizmox.WebGUI.Forms
AllScreens Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Screen Class : AllScreens Property

Gets an array of all displays on the system.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property AllScreens As Screen()
Visual Basic (Usage) Copy Code
Dim value() As Screen

value = Screen.AllScreens
C#
public static Screen[] AllScreens {get;}
Managed Extensions for C++
public: __property static Screen*[]* get_AllScreens();
C++/CLI
public:
static property array<Screen^>^ AllScreens {
   array<Screen^>^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Screen Class
Screen Members


BitsPerPixel Property

[image]
Gizmox.WebGUI.Forms
BitsPerPixel Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Screen Class : BitsPerPixel Property

Gets the number of bits of memory, associated with one pixel of data.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property BitsPerPixel As Integer
Visual Basic (Usage) Copy Code
Dim instance As Screen
Dim value As Integer

value = instance.BitsPerPixel
C#
public int BitsPerPixel {get;}
Managed Extensions for C++
public: __property int get_BitsPerPixel();
C++/CLI
public:
property int BitsPerPixel {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Screen Class
Screen Members


Bounds Property

[image]
Gizmox.WebGUI.Forms
Bounds Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Screen Class : Bounds Property

Gets the bounds of the display.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Bounds As Rectangle
Visual Basic (Usage) Copy Code
Dim instance As Screen
Dim value As Rectangle

value = instance.Bounds
C#
public Rectangle Bounds {get;}
Managed Extensions for C++
public: __property Rectangle get_Bounds();
C++/CLI
public:
property Rectangle Bounds {
   Rectangle get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Screen Class
Screen Members


DeviceName Property

[image]
Gizmox.WebGUI.Forms
DeviceName Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Screen Class : DeviceName Property

Gets the device name associated with a display.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DeviceName As String
Visual Basic (Usage) Copy Code
Dim instance As Screen
Dim value As String

value = instance.DeviceName
C#
public string DeviceName {get;}
Managed Extensions for C++
public: __property string* get_DeviceName();
C++/CLI
public:
property String^ DeviceName {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Screen Class
Screen Members


Primary Property

[image]
Gizmox.WebGUI.Forms
Primary Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Screen Class : Primary Property

Gets a value indicating whether a particular display is the primary device.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Primary As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Screen
Dim value As Boolean

value = instance.Primary
C#
public bool Primary {get;}
Managed Extensions for C++
public: __property bool get_Primary();
C++/CLI
public:
property bool Primary {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Screen Class
Screen Members


PrimaryScreen Property

[image]
Gizmox.WebGUI.Forms
PrimaryScreen Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Screen Class : PrimaryScreen Property

Gets the primary display.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property PrimaryScreen As Screen
Visual Basic (Usage) Copy Code
Dim value As Screen

value = Screen.PrimaryScreen
C#
public static Screen PrimaryScreen {get;}
Managed Extensions for C++
public: __property static Screen* get_PrimaryScreen();
C++/CLI
public:
static property Screen^ PrimaryScreen {
   Screen^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Screen Class
Screen Members


WorkingArea Property

[image]
Gizmox.WebGUI.Forms
WorkingArea Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Screen Class : WorkingArea Property

Gets the working area of the display. The working area is the desktop area of the display, excluding taskbars, docked windows, and docked tool bars.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property WorkingArea As Rectangle
Visual Basic (Usage) Copy Code
Dim instance As Screen
Dim value As Rectangle

value = instance.WorkingArea
C#
public Rectangle WorkingArea {get;}
Managed Extensions for C++
public: __property Rectangle get_WorkingArea();
C++/CLI
public:
property Rectangle WorkingArea {
   Rectangle get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Screen Class
Screen Members


ScrollableControl Class

[image]
Gizmox.WebGUI.Forms
ScrollableControl Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ScrollableControl Class

Defines a base class for controls that support auto-scrolling behavior.

Object Model

Syntax

Visual Basic (Declaration)
Public Class ScrollableControl
   Inherits Control
   Implements IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Visual Basic (Usage) Copy Code
Dim instance As ScrollableControl
C#
public class ScrollableControl : Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Managed Extensions for C++
public __gc class ScrollableControl : public Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
C++/CLI
public ref class ScrollableControl : public Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.ScrollableControl
Gizmox.WebGUI.Forms.ContainerControl
Gizmox.WebGUI.Forms.Panel

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

ScrollableControl Members
Gizmox.WebGUI.Forms Namespace


ScrollableControl Class Members

[image]
Gizmox.WebGUI.Forms
ScrollableControl Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : ScrollableControl Class

The following tables list the members exposed by ScrollableControl.

Public Constructors

 | Name | Description
Public Constructor | ScrollableControl Constructor | Initializes a new instance of the ScrollableControl class.
Top

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DockPadding | Gets the dock padding settings for all edges of the control.
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Control)
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible.
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Protected Property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible.
Top

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control.
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Control)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | Overridden.
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Control)
Protected Method | RenderAttributes | Overridden. Renders the scrollable attribute
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

ScrollableControl Class
Gizmox.WebGUI.Forms Namespace


ScrollableControl Constructor

[image]
Gizmox.WebGUI.Forms
ScrollableControl Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ScrollableControl Class : ScrollableControl Constructor

Initializes a new instance of the ScrollableControl class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ScrollableControl()
C#
public ScrollableControl()
Managed Extensions for C++
public: ScrollableControl();
C++/CLI
public:
ScrollableControl();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ScrollableControl Class
ScrollableControl Members


ScrollableControl Class Methods

[image]
Gizmox.WebGUI.Forms
ScrollableControl Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ScrollableControl Class

For a list of all members of this type, see ScrollableControl members.

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control.
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Control)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | Overridden.
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Control)
Protected Method | RenderAttributes | Overridden. Renders the scrollable attribute
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

See Also

Reference

ScrollableControl Class
Gizmox.WebGUI.Forms Namespace


GetPreferredSizeCore Method

[image]
Gizmox.WebGUI.Forms
GetPreferredSizeCore Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ScrollableControl Class : GetPreferredSizeCore Method

proposedSize

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetPreferredSizeCore( _
   ByVal proposedSize As Size _
) As Size
Visual Basic (Usage) Copy Code
Dim instance As ScrollableControl
Dim proposedSize As Size
Dim value As Size

value = instance.GetPreferredSizeCore(proposedSize)
C#
protected override Size GetPreferredSizeCore(
   Size proposedSize
)
Managed Extensions for C++
protected: Size GetPreferredSizeCore(
   Size proposedSize
) override
C++/CLI
protected:
Size GetPreferredSizeCore(
   Size proposedSize
) override

Parameters

proposedSize

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ScrollableControl Class
ScrollableControl Members


RenderAttributes Method

[image]
Gizmox.WebGUI.Forms
RenderAttributes Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ScrollableControl Class : RenderAttributes Method

objContext
objWriter
Renders the scrollable attribute

Syntax

Visual Basic (Declaration)
Protected Overrides Sub RenderAttributes( _
   ByVal objContext As IContext, _
   ByVal objWriter As IAttributeWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As ScrollableControl
Dim objContext As IContext
Dim objWriter As IAttributeWriter

instance.RenderAttributes(objContext, objWriter)
C#
protected override void RenderAttributes(
   IContext objContext,
   IAttributeWriter objWriter
)
Managed Extensions for C++
protected: void RenderAttributes(
   IContext* objContext,
   IAttributeWriter* objWriter
) override
C++/CLI
protected:
void RenderAttributes(
   IContext^ objContext,
   IAttributeWriter^ objWriter
) override

Parameters

objContext
objWriter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ScrollableControl Class
ScrollableControl Members


ScrollControlIntoView Method

[image]
Gizmox.WebGUI.Forms
ScrollControlIntoView Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ScrollableControl Class : ScrollControlIntoView Method

activeControl
The child control to scroll into view.
Scrolls the specified child control into view on an auto-scroll enabled control.

Syntax

Visual Basic (Declaration)
Public Sub ScrollControlIntoView( _
   ByVal activeControl As Control _
)
Visual Basic (Usage) Copy Code
Dim instance As ScrollableControl
Dim activeControl As Control

instance.ScrollControlIntoView(activeControl)
C#
public void ScrollControlIntoView(
   Control activeControl
)
Managed Extensions for C++
public: void ScrollControlIntoView(
   Control* activeControl
)
C++/CLI
public:
void ScrollControlIntoView(
   Control^ activeControl
)

Parameters

activeControl
The child control to scroll into view.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ScrollableControl Class
ScrollableControl Members


ScrollableControl Class Properties

[image]
Gizmox.WebGUI.Forms
ScrollableControl Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ScrollableControl Class

For a list of all members of this type, see ScrollableControl members.

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DockPadding | Gets the dock padding settings for all edges of the control.
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Control)
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible.
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Protected Property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible.
Top

See Also

Reference

ScrollableControl Class
Gizmox.WebGUI.Forms Namespace


AutoScroll Property

[image]
Gizmox.WebGUI.Forms
AutoScroll Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ScrollableControl Class : AutoScroll Property

Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<SRDescriptionAttribute("Indicates whether scroll bars automatically appear when the control contents are larger than its visible area.")>
<LocalizableAttribute(True)>
<SRCategoryAttribute("Layout")>
Public Overridable Property AutoScroll As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ScrollableControl
Dim value As Boolean

instance.AutoScroll = value

value = instance.AutoScroll
C#
[DefaultValueAttribute()]
[SRDescriptionAttribute("Indicates whether scroll bars automatically appear when the control contents are larger than its visible area.")]
[LocalizableAttribute(true)]
[SRCategoryAttribute("Layout")]
public virtual bool AutoScroll {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[SRDescriptionAttribute("Indicates whether scroll bars automatically appear when the control contents are larger than its visible area.")]
[LocalizableAttribute(true)]
[SRCategoryAttribute("Layout")]
public: __property virtual bool get_AutoScroll();
public: __property virtual void set_AutoScroll(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
[SRDescriptionAttribute("Indicates whether scroll bars automatically appear when the control contents are larger than its visible area.")]
[LocalizableAttribute(true)]
[SRCategoryAttribute("Layout")]
public:
virtual property bool AutoScroll {
   bool get();
   void set (boolvalue);
}

Return Value

true if the container enables auto-scrolling; otherwise, false. The default value is false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ScrollableControl Class
ScrollableControl Members


DockPadding Property

[image]
Gizmox.WebGUI.Forms
DockPadding Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ScrollableControl Class : DockPadding Property

Gets the dock padding settings for all edges of the control.

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
Public ReadOnly Property DockPadding As ScrollableControl.DockPaddingEdges
Visual Basic (Usage) Copy Code
Dim instance As ScrollableControl
Dim value As ScrollableControl.DockPaddingEdges

value = instance.DockPadding
C#
[DesignerSerializationVisibilityAttribute()]
public ScrollableControl.DockPaddingEdges DockPadding {get;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
public: __property ScrollableControl.DockPaddingEdges* get_DockPadding();
C++/CLI
[DesignerSerializationVisibilityAttribute()]
public:
property ScrollableControl::DockPaddingEdges^ DockPadding {
   ScrollableControl::DockPaddingEdges^ get();
}

Return Value

A ScrollableControl.DockPaddingEdges that represents the padding for all the edges of a docked control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ScrollableControl Class
ScrollableControl Members


HScroll Property

[image]
Gizmox.WebGUI.Forms
HScroll Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ScrollableControl Class : HScroll Property

Gets or sets a value indicating whether the horizontal scroll bar is visible.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Protected Property HScroll As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ScrollableControl
Dim value As Boolean

instance.HScroll = value

value = instance.HScroll
C#
[DefaultValueAttribute()]
protected bool HScroll {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
protected: __property bool get_HScroll();
protected: __property void set_HScroll(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
protected:
property bool HScroll {
   bool get();
   void set (boolvalue);
}

Return Value

true if the horizontal scroll bar is visible; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ScrollableControl Class
ScrollableControl Members


VScroll Property

[image]
Gizmox.WebGUI.Forms
VScroll Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ScrollableControl Class : VScroll Property

Gets or sets a value indicating whether the vertical scroll bar is visible.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Protected Property VScroll As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ScrollableControl
Dim value As Boolean

instance.VScroll = value

value = instance.VScroll
C#
[DefaultValueAttribute()]
protected bool VScroll {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
protected: __property bool get_VScroll();
protected: __property void set_VScroll(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
protected:
property bool VScroll {
   bool get();
   void set (boolvalue);
}

Return Value

true if the vertical scroll bar is visible; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ScrollableControl Class
ScrollableControl Members


ScrollableControl.DockPaddingEdges Class

[image]
Gizmox.WebGUI.Forms
ScrollableControl.DockPaddingEdges Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ScrollableControl.DockPaddingEdges Class

Determines the border padding for docked controls.

Syntax

Visual Basic (Declaration)
<TypeConverterAttribute("Gizmox.WebGUI.Forms.ScrollableControl+DockPaddingEdgesConverter, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d")>
Public Class ScrollableControl.DockPaddingEdges
Visual Basic (Usage) Copy Code
Dim instance As ScrollableControl.DockPaddingEdges
C#
[TypeConverterAttribute("Gizmox.WebGUI.Forms.ScrollableControl+DockPaddingEdgesConverter, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d")]
public class ScrollableControl.DockPaddingEdges
Managed Extensions for C++
[TypeConverterAttribute("Gizmox.WebGUI.Forms.ScrollableControl+DockPaddingEdgesConverter, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d")]
public __gc class ScrollableControl.DockPaddingEdges
C++/CLI
[TypeConverterAttribute("Gizmox.WebGUI.Forms.ScrollableControl+DockPaddingEdgesConverter, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d")]
public ref class ScrollableControl.DockPaddingEdges

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ScrollableControl.DockPaddingEdges

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

ScrollableControl.DockPaddingEdges Members
Gizmox.WebGUI.Forms Namespace


ScrollableControl.DockPaddingEdges Class Members

[image]
Gizmox.WebGUI.Forms
ScrollableControl.DockPaddingEdges Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : ScrollableControl.DockPaddingEdges Class

The following tables list the members exposed by ScrollableControl.DockPaddingEdges.

Public Properties

 | Name | Description
Public Property | All | Gets or sets the padding width for all edges of a docked control.
Public Property | Bottom | Gets or sets the padding width for the bottom edge of a docked control.
Public Property | Left | Gets or sets the padding width for the left edge of a docked control.
Public Property | Right | Gets or sets the padding width for the right edge of a docked control.
Public Property | Top | Gets or sets the padding width for the top edge of a docked control.
Top

Public Methods

 | Name | Description
Public Method | ToString | Overridden. Returns an empty string.
Top

See Also

Reference

ScrollableControl.DockPaddingEdges Class
Gizmox.WebGUI.Forms Namespace


ScrollableControl.DockPaddingEdges Class Methods

[image]
Gizmox.WebGUI.Forms
ScrollableControl.DockPaddingEdges Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ScrollableControl.DockPaddingEdges Class

For a list of all members of this type, see ScrollableControl.DockPaddingEdges members.

Public Methods

 | Name | Description
Public Method | ToString | Overridden. Returns an empty string.
Top

See Also

Reference

ScrollableControl.DockPaddingEdges Class
Gizmox.WebGUI.Forms Namespace


ToString Method

[image]
Gizmox.WebGUI.Forms
ToString Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ScrollableControl.DockPaddingEdges Class : ToString Method

Returns an empty string.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As ScrollableControl.DockPaddingEdges
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Return Value

An empty string.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ScrollableControl.DockPaddingEdges Class
ScrollableControl.DockPaddingEdges Members


ScrollableControl.DockPaddingEdges Class Properties

[image]
Gizmox.WebGUI.Forms
ScrollableControl.DockPaddingEdges Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ScrollableControl.DockPaddingEdges Class

For a list of all members of this type, see ScrollableControl.DockPaddingEdges members.

Public Properties

 | Name | Description
Public Property | All | Gets or sets the padding width for all edges of a docked control.
Public Property | Bottom | Gets or sets the padding width for the bottom edge of a docked control.
Public Property | Left | Gets or sets the padding width for the left edge of a docked control.
Public Property | Right | Gets or sets the padding width for the right edge of a docked control.
Public Property | Top | Gets or sets the padding width for the top edge of a docked control.
Top

See Also

Reference

ScrollableControl.DockPaddingEdges Class
Gizmox.WebGUI.Forms Namespace


All Property

[image]
Gizmox.WebGUI.Forms
All Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ScrollableControl.DockPaddingEdges Class : All Property

Gets or sets the padding width for all edges of a docked control.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Number of pixels along all borders to pad docked controls.")>
<RefreshPropertiesAttribute()>
Public Property All As Integer
Visual Basic (Usage) Copy Code
Dim instance As ScrollableControl.DockPaddingEdges
Dim value As Integer

instance.All = value

value = instance.All
C#
[SRDescriptionAttribute("Number of pixels along all borders to pad docked controls.")]
[RefreshPropertiesAttribute()]
public int All {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Number of pixels along all borders to pad docked controls.")]
[RefreshPropertiesAttribute()]
public: __property int get_All();
public: __property void set_All(
   int value
);
C++/CLI
[SRDescriptionAttribute("Number of pixels along all borders to pad docked controls.")]
[RefreshPropertiesAttribute()]
public:
property int All {
   int get();
   void set (intvalue);
}

Return Value

The padding width, in pixels.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ScrollableControl.DockPaddingEdges Class
ScrollableControl.DockPaddingEdges Members


Bottom Property

[image]
Gizmox.WebGUI.Forms
Bottom Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ScrollableControl.DockPaddingEdges Class : Bottom Property

Gets or sets the padding width for the bottom edge of a docked control.

Syntax

Visual Basic (Declaration)
<RefreshPropertiesAttribute()>
<SRDescriptionAttribute("Number of pixels along the bottom border to pad docked controls.")>
Public Property Bottom As Integer
Visual Basic (Usage) Copy Code
Dim instance As ScrollableControl.DockPaddingEdges
Dim value As Integer

instance.Bottom = value

value = instance.Bottom
C#
[RefreshPropertiesAttribute()]
[SRDescriptionAttribute("Number of pixels along the bottom border to pad docked controls.")]
public int Bottom {get; set;}
Managed Extensions for C++
[RefreshPropertiesAttribute()]
[SRDescriptionAttribute("Number of pixels along the bottom border to pad docked controls.")]
public: __property int get_Bottom();
public: __property void set_Bottom(
   int value
);
C++/CLI
[RefreshPropertiesAttribute()]
[SRDescriptionAttribute("Number of pixels along the bottom border to pad docked controls.")]
public:
property int Bottom {
   int get();
   void set (intvalue);
}

Return Value

The padding width, in pixels.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ScrollableControl.DockPaddingEdges Class
ScrollableControl.DockPaddingEdges Members


Left Property

[image]
Gizmox.WebGUI.Forms
Left Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ScrollableControl.DockPaddingEdges Class : Left Property

Gets or sets the padding width for the left edge of a docked control.

Syntax

Visual Basic (Declaration)
<RefreshPropertiesAttribute()>
<SRDescriptionAttribute("Number of pixels along the left border to pad docked controls.")>
Public Property Left As Integer
Visual Basic (Usage) Copy Code
Dim instance As ScrollableControl.DockPaddingEdges
Dim value As Integer

instance.Left = value

value = instance.Left
C#
[RefreshPropertiesAttribute()]
[SRDescriptionAttribute("Number of pixels along the left border to pad docked controls.")]
public int Left {get; set;}
Managed Extensions for C++
[RefreshPropertiesAttribute()]
[SRDescriptionAttribute("Number of pixels along the left border to pad docked controls.")]
public: __property int get_Left();
public: __property void set_Left(
   int value
);
C++/CLI
[RefreshPropertiesAttribute()]
[SRDescriptionAttribute("Number of pixels along the left border to pad docked controls.")]
public:
property int Left {
   int get();
   void set (intvalue);
}

Return Value

The padding width, in pixels.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ScrollableControl.DockPaddingEdges Class
ScrollableControl.DockPaddingEdges Members


Right Property

[image]
Gizmox.WebGUI.Forms
Right Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ScrollableControl.DockPaddingEdges Class : Right Property

Gets or sets the padding width for the right edge of a docked control.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Number of pixels along the right border to pad docked controls.")>
<RefreshPropertiesAttribute()>
Public Property Right As Integer
Visual Basic (Usage) Copy Code
Dim instance As ScrollableControl.DockPaddingEdges
Dim value As Integer

instance.Right = value

value = instance.Right
C#
[SRDescriptionAttribute("Number of pixels along the right border to pad docked controls.")]
[RefreshPropertiesAttribute()]
public int Right {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Number of pixels along the right border to pad docked controls.")]
[RefreshPropertiesAttribute()]
public: __property int get_Right();
public: __property void set_Right(
   int value
);
C++/CLI
[SRDescriptionAttribute("Number of pixels along the right border to pad docked controls.")]
[RefreshPropertiesAttribute()]
public:
property int Right {
   int get();
   void set (intvalue);
}

Return Value

The padding width, in pixels.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ScrollableControl.DockPaddingEdges Class
ScrollableControl.DockPaddingEdges Members


Top Property

[image]
Gizmox.WebGUI.Forms
Top Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ScrollableControl.DockPaddingEdges Class : Top Property

Gets or sets the padding width for the top edge of a docked control.

Syntax

Visual Basic (Declaration)
<RefreshPropertiesAttribute()>
<SRDescriptionAttribute("Number of pixels along the top border to pad docked controls.")>
Public Property Top As Integer
Visual Basic (Usage) Copy Code
Dim instance As ScrollableControl.DockPaddingEdges
Dim value As Integer

instance.Top = value

value = instance.Top
C#
[RefreshPropertiesAttribute()]
[SRDescriptionAttribute("Number of pixels along the top border to pad docked controls.")]
public int Top {get; set;}
Managed Extensions for C++
[RefreshPropertiesAttribute()]
[SRDescriptionAttribute("Number of pixels along the top border to pad docked controls.")]
public: __property int get_Top();
public: __property void set_Top(
   int value
);
C++/CLI
[RefreshPropertiesAttribute()]
[SRDescriptionAttribute("Number of pixels along the top border to pad docked controls.")]
public:
property int Top {
   int get();
   void set (intvalue);
}

Return Value

The padding width, in pixels.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ScrollableControl.DockPaddingEdges Class
ScrollableControl.DockPaddingEdges Members


ScrollableControl.DockPaddingEdgesConverter Class

[image]
Gizmox.WebGUI.Forms
ScrollableControl.DockPaddingEdgesConverter Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ScrollableControl.DockPaddingEdgesConverter Class

DockPaddingEdgesConverter class.

Syntax

Visual Basic (Declaration)
Public Class ScrollableControl.DockPaddingEdgesConverter
   Inherits TypeConverter
Visual Basic (Usage) Copy Code
Dim instance As ScrollableControl.DockPaddingEdgesConverter
C#
public class ScrollableControl.DockPaddingEdgesConverter : TypeConverter
Managed Extensions for C++
public __gc class ScrollableControl.DockPaddingEdgesConverter : public TypeConverter
C++/CLI
public ref class ScrollableControl.DockPaddingEdgesConverter : public TypeConverter

Inheritance Hierarchy

System.Object
System.ComponentModel.TypeConverter
Gizmox.WebGUI.Forms.ScrollableControl.DockPaddingEdgesConverter

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

ScrollableControl.DockPaddingEdgesConverter Members
Gizmox.WebGUI.Forms Namespace


ScrollableControl.DockPaddingEdgesConverter Class Members

[image]
Gizmox.WebGUI.Forms
ScrollableControl.DockPaddingEdgesConverter Class Members
See Also Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : ScrollableControl.DockPaddingEdgesConverter Class

The following tables list the members exposed by ScrollableControl.DockPaddingEdgesConverter.

Public Constructors

 | Name | Description
Public Constructor | ScrollableControl.DockPaddingEdgesConverter Constructor | Initializes a new instance of the ScrollableControl.DockPaddingEdgesConverter class.
Top

Public Methods

 | Name | Description
Public Method | CanConvertFrom | Overloaded. Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from System.ComponentModel.TypeConverter)
Public Method | CanConvertTo | Overloaded. Returns whether this converter can convert the object to the specified type. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertFrom | Overloaded. Converts the given value to the type of this converter. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertFromInvariantString | Overloaded. Converts the given string to the type of this converter, using the invariant culture. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertFromString | Overloaded. Converts the specified text to an object. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertTo | Overloaded. Converts the given value object to the specified type, using the arguments. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertToInvariantString | Overloaded. Converts the specified value to a culture-invariant string representation. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertToString | Overloaded. Converts the specified value to a string representation. (Inherited from System.ComponentModel.TypeConverter)
Public Method | CreateInstance | Overloaded. Re-creates an Object given a set of property values for the object. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetCreateInstanceSupported | Overloaded. Returns whether changing a value on this object requires a call to the CreateInstance method to create a new value. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetProperties | Overloaded. Overridden. Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes.
Public Method | GetPropertiesSupported | Overloaded. Overridden. Returns whether this object supports properties, using the specified context.
Public Method | GetStandardValues | Overloaded. Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValuesExclusive | Overloaded. Returns whether the collection of standard values returned from GetStandardValues is an exclusive list. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValuesSupported | Overloaded. Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from System.ComponentModel.TypeConverter)
Public Method | IsValid | Overloaded. Returns whether the given value object is valid for this type. (Inherited from System.ComponentModel.TypeConverter)
Top

Protected Methods

 | Name | Description
Protected Method | GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from System.ComponentModel.TypeConverter)
Protected Method | GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from System.ComponentModel.TypeConverter)
Protected Method | SortProperties | (Inherited from System.ComponentModel.TypeConverter)
Top

See Also

Reference

ScrollableControl.DockPaddingEdgesConverter Class
Gizmox.WebGUI.Forms Namespace


ScrollableControl.DockPaddingEdgesConverter Constructor

[image]
Gizmox.WebGUI.Forms
ScrollableControl.DockPaddingEdgesConverter Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ScrollableControl.DockPaddingEdgesConverter Class : ScrollableControl.DockPaddingEdgesConverter Constructor

Initializes a new instance of the ScrollableControl.DockPaddingEdgesConverter class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ScrollableControl.DockPaddingEdgesConverter()
C#
public ScrollableControl.DockPaddingEdgesConverter()
Managed Extensions for C++
public: ScrollableControl.DockPaddingEdgesConverter();
C++/CLI
public:
ScrollableControl.DockPaddingEdgesConverter();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ScrollableControl.DockPaddingEdgesConverter Class
ScrollableControl.DockPaddingEdgesConverter Members


ScrollableControl.DockPaddingEdgesConverter Class Methods

[image]
Gizmox.WebGUI.Forms
ScrollableControl.DockPaddingEdgesConverter Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ScrollableControl.DockPaddingEdgesConverter Class

For a list of all members of this type, see ScrollableControl.DockPaddingEdgesConverter members.

Public Methods

 | Name | Description
Public Method | CanConvertFrom | Overloaded. Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from System.ComponentModel.TypeConverter)
Public Method | CanConvertTo | Overloaded. Returns whether this converter can convert the object to the specified type. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertFrom | Overloaded. Converts the given value to the type of this converter. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertFromInvariantString | Overloaded. Converts the given string to the type of this converter, using the invariant culture. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertFromString | Overloaded. Converts the specified text to an object. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertTo | Overloaded. Converts the given value object to the specified type, using the arguments. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertToInvariantString | Overloaded. Converts the specified value to a culture-invariant string representation. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertToString | Overloaded. Converts the specified value to a string representation. (Inherited from System.ComponentModel.TypeConverter)
Public Method | CreateInstance | Overloaded. Re-creates an Object given a set of property values for the object. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetCreateInstanceSupported | Overloaded. Returns whether changing a value on this object requires a call to the CreateInstance method to create a new value. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetProperties | Overloaded. Overridden. Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes.
Public Method | GetPropertiesSupported | Overloaded. Overridden. Returns whether this object supports properties, using the specified context.
Public Method | GetStandardValues | Overloaded. Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValuesExclusive | Overloaded. Returns whether the collection of standard values returned from GetStandardValues is an exclusive list. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValuesSupported | Overloaded. Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from System.ComponentModel.TypeConverter)
Public Method | IsValid | Overloaded. Returns whether the given value object is valid for this type. (Inherited from System.ComponentModel.TypeConverter)
Top

Protected Methods

 | Name | Description
Protected Method | GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from System.ComponentModel.TypeConverter)
Protected Method | GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from System.ComponentModel.TypeConverter)
Protected Method | SortProperties | (Inherited from System.ComponentModel.TypeConverter)
Top

See Also

Reference

ScrollableControl.DockPaddingEdgesConverter Class
Gizmox.WebGUI.Forms Namespace


GetProperties Method

[image]
Gizmox.WebGUI.Forms
GetProperties Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ScrollableControl.DockPaddingEdgesConverter Class : GetProperties Method

Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes.

Overload List

Overload | Description
GetProperties(ITypeDescriptorContext,Object,Attribute[]) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes.
GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from System.ComponentModel.TypeConverter)
GetProperties(ITypeDescriptorContext,Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from System.ComponentModel.TypeConverter)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ScrollableControl.DockPaddingEdgesConverter Class
ScrollableControl.DockPaddingEdgesConverter Members


GetProperties(ITypeDescriptorContext,Object,Attribute[]) Method

[image]
Gizmox.WebGUI.Forms
GetProperties(ITypeDescriptorContext,Object,Attribute[]) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ScrollableControl.DockPaddingEdgesConverter Class > GetProperties Method : GetProperties(ITypeDescriptorContext,Object,Attribute[]) Method

context
An ITypeDescriptorContext that provides a format context.
value
An Object that specifies the type of array for which to get properties.
attributes
An array of type Attribute that is used as a filter.
Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function GetProperties( _
   ByVal context As ITypeDescriptorContext, _
   ByVal value As Object, _
   ByVal attributes() As Attribute _
) As PropertyDescriptorCollection
Visual Basic (Usage) Copy Code
Dim instance As ScrollableControl.DockPaddingEdgesConverter
Dim context As ITypeDescriptorContext
Dim value As Object
Dim attributes() As Attribute
Dim value As PropertyDescriptorCollection

value = instance.GetProperties(context, value, attributes)
C#
public override PropertyDescriptorCollection GetProperties(
   ITypeDescriptorContext context,
   object value,
   Attribute[] attributes
)
Managed Extensions for C++
public: PropertyDescriptorCollection* GetProperties(
   ITypeDescriptorContext* context,
   Object* value,
   Attribute*[]* attributes
) override
C++/CLI
public:
PropertyDescriptorCollection^ GetProperties(
   ITypeDescriptorContext^ context,
   Object^ value,
   array<Attribute^>^ attributes
) override

Parameters

context
An ITypeDescriptorContext that provides a format context.
value
An Object that specifies the type of array for which to get properties.
attributes
An array of type Attribute that is used as a filter.

Return Value

A PropertyDescriptorCollection with the properties that are exposed for this data type, or null if there are no properties.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ScrollableControl.DockPaddingEdgesConverter Class
ScrollableControl.DockPaddingEdgesConverter Members
Overload List


GetPropertiesSupported Method

[image]
Gizmox.WebGUI.Forms
GetPropertiesSupported Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ScrollableControl.DockPaddingEdgesConverter Class : GetPropertiesSupported Method

Returns whether this object supports properties, using the specified context.

Overload List

Overload | Description
GetPropertiesSupported(ITypeDescriptorContext) | Returns whether this object supports properties, using the specified context.
GetPropertiesSupported() | Returns whether this object supports properties. (Inherited from System.ComponentModel.TypeConverter)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ScrollableControl.DockPaddingEdgesConverter Class
ScrollableControl.DockPaddingEdgesConverter Members


GetPropertiesSupported(ITypeDescriptorContext) Method

[image]
Gizmox.WebGUI.Forms
GetPropertiesSupported(ITypeDescriptorContext) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ScrollableControl.DockPaddingEdgesConverter Class > GetPropertiesSupported Method : GetPropertiesSupported(ITypeDescriptorContext) Method

context
An ITypeDescriptorContext that provides a format context.
Returns whether this object supports properties, using the specified context.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function GetPropertiesSupported( _
   ByVal context As ITypeDescriptorContext _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ScrollableControl.DockPaddingEdgesConverter
Dim context As ITypeDescriptorContext
Dim value As Boolean

value = instance.GetPropertiesSupported(context)
C#
public override bool GetPropertiesSupported(
   ITypeDescriptorContext context
)
Managed Extensions for C++
public: bool GetPropertiesSupported(
   ITypeDescriptorContext* context
) override
C++/CLI
public:
bool GetPropertiesSupported(
   ITypeDescriptorContext^ context
) override

Parameters

context
An ITypeDescriptorContext that provides a format context.

Return Value

true if GetProperties should be called to find the properties of this object; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ScrollableControl.DockPaddingEdgesConverter Class
ScrollableControl.DockPaddingEdgesConverter Members
Overload List


SelectedGridItemChangedEventArgs Class

[image]
Gizmox.WebGUI.Forms
SelectedGridItemChangedEventArgs Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : SelectedGridItemChangedEventArgs Class

Provides data for the SelectedGridItemChanged event of the PropertyGrid control.

Object Model

Syntax

Visual Basic (Declaration)
Public Class SelectedGridItemChangedEventArgs
   Inherits EventArgs
Visual Basic (Usage) Copy Code
Dim instance As SelectedGridItemChangedEventArgs
C#
public class SelectedGridItemChangedEventArgs : EventArgs
Managed Extensions for C++
public __gc class SelectedGridItemChangedEventArgs : public EventArgs
C++/CLI
public ref class SelectedGridItemChangedEventArgs : public EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gizmox.WebGUI.Forms.SelectedGridItemChangedEventArgs

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

SelectedGridItemChangedEventArgs Members
Gizmox.WebGUI.Forms Namespace


SelectedGridItemChangedEventArgs Class Members

[image]
Gizmox.WebGUI.Forms
SelectedGridItemChangedEventArgs Class Members
See Also Properties Send Feedback
Gizmox.WebGUI.Forms Namespace : SelectedGridItemChangedEventArgs Class

The following tables list the members exposed by SelectedGridItemChangedEventArgs.

Public Constructors

 | Name | Description
Public Constructor | SelectedGridItemChangedEventArgs Constructor | Initializes a new instance of the SelectedGridItemChangedEventArgs class.
Top

Public Properties

 | Name | Description
Public Property | NewSelection | Gets the newly selected GridItem.
Public Property | OldSelection | Gets the previously selected GridItem.
Top

See Also

Reference

SelectedGridItemChangedEventArgs Class
Gizmox.WebGUI.Forms Namespace


SelectedGridItemChangedEventArgs Constructor

[image]
Gizmox.WebGUI.Forms
SelectedGridItemChangedEventArgs Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > SelectedGridItemChangedEventArgs Class : SelectedGridItemChangedEventArgs Constructor

oldSel
The previously selected grid item.
newSel
The newly selected grid item.
Initializes a new instance of the SelectedGridItemChangedEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal oldSel As GridItem, _
   ByVal newSel As GridItem _
)
Visual Basic (Usage) Copy Code
Dim oldSel As GridItem
Dim newSel As GridItem

Dim instance As SelectedGridItemChangedEventArgs(oldSel, newSel)
C#
public SelectedGridItemChangedEventArgs(
   GridItem oldSel,
   GridItem newSel
)
Managed Extensions for C++
public: SelectedGridItemChangedEventArgs(
   GridItem* oldSel,
   GridItem* newSel
)
C++/CLI
public:
SelectedGridItemChangedEventArgs(
   GridItem^ oldSel,
   GridItem^ newSel
)

Parameters

oldSel
The previously selected grid item.
newSel
The newly selected grid item.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SelectedGridItemChangedEventArgs Class
SelectedGridItemChangedEventArgs Members


SelectedGridItemChangedEventArgs Class Properties

[image]
Gizmox.WebGUI.Forms
SelectedGridItemChangedEventArgs Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : SelectedGridItemChangedEventArgs Class

For a list of all members of this type, see SelectedGridItemChangedEventArgs members.

Public Properties

 | Name | Description
Public Property | NewSelection | Gets the newly selected GridItem.
Public Property | OldSelection | Gets the previously selected GridItem.
Top

See Also

Reference

SelectedGridItemChangedEventArgs Class
Gizmox.WebGUI.Forms Namespace


NewSelection Property

[image]
Gizmox.WebGUI.Forms
NewSelection Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > SelectedGridItemChangedEventArgs Class : NewSelection Property

Gets the newly selected GridItem.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property NewSelection As GridItem
Visual Basic (Usage) Copy Code
Dim instance As SelectedGridItemChangedEventArgs
Dim value As GridItem

value = instance.NewSelection
C#
public GridItem NewSelection {get;}
Managed Extensions for C++
public: __property GridItem* get_NewSelection();
C++/CLI
public:
property GridItem^ NewSelection {
   GridItem^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SelectedGridItemChangedEventArgs Class
SelectedGridItemChangedEventArgs Members


OldSelection Property

[image]
Gizmox.WebGUI.Forms
OldSelection Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > SelectedGridItemChangedEventArgs Class : OldSelection Property

Gets the previously selected GridItem.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OldSelection As GridItem
Visual Basic (Usage) Copy Code
Dim instance As SelectedGridItemChangedEventArgs
Dim value As GridItem

value = instance.OldSelection
C#
public GridItem OldSelection {get;}
Managed Extensions for C++
public: __property GridItem* get_OldSelection();
C++/CLI
public:
property GridItem^ OldSelection {
   GridItem^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SelectedGridItemChangedEventArgs Class
SelectedGridItemChangedEventArgs Members


ShortcutsContainer Class

[image]
Gizmox.WebGUI.Forms
ShortcutsContainer Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ShortcutsContainer Class

Contains a collection of mapped shortcuts

Object Model

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
<ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")>
Public Class ShortcutsContainer
   Inherits Component
   Implements IAttributeExtender, IEventHandler, IGatewayComponent, IObservableItem, IRegisteredComponent
Visual Basic (Usage) Copy Code
Dim instance As ShortcutsContainer
C#
[DefaultMemberAttribute("Item")]
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
public class ShortcutsContainer : Component, IAttributeExtender, IEventHandler, IGatewayComponent, IObservableItem, IRegisteredComponent
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
public __gc class ShortcutsContainer : public Component, IAttributeExtender, IEventHandler, IGatewayComponent, IObservableItem, IRegisteredComponent
C++/CLI
[DefaultMemberAttribute("Item")]
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
public ref class ShortcutsContainer : public Component, IAttributeExtender, IEventHandler, IGatewayComponent, IObservableItem, IRegisteredComponent

Remarks

The chortcut container is used internaly by the VWG form to hold all shortcuts and their component mappings.

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.ShortcutsContainer

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

ShortcutsContainer Members
Gizmox.WebGUI.Forms Namespace


ShortcutsContainer Class Members

[image]
Gizmox.WebGUI.Forms
ShortcutsContainer Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : ShortcutsContainer Class

The following tables list the members exposed by ShortcutsContainer.

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContextMenu | Gets or sets the context menu code. (Inherited from Component)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | Item | Overloaded. Get compenent mapped to shortcut
Public Property | Site | (Inherited from ComponentBase)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

Public Methods

 | Name | Description
Public Method | Add | Maps a new shortcut
Public Method | Dispose | Overloaded. Disposes the specified component. (Inherited from Component)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | Remove | Removes an existing shortcut mapping
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Component)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCriticalEvents | (Inherited from Component)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnUnregisterComponents | (Inherited from Component)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Top

See Also

Reference

ShortcutsContainer Class
Gizmox.WebGUI.Forms Namespace


ShortcutsContainer Class Methods

[image]
Gizmox.WebGUI.Forms
ShortcutsContainer Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ShortcutsContainer Class

For a list of all members of this type, see ShortcutsContainer members.

Public Methods

 | Name | Description
Public Method | Add | Maps a new shortcut
Public Method | Dispose | Overloaded. Disposes the specified component. (Inherited from Component)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | Remove | Removes an existing shortcut mapping
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Component)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCriticalEvents | (Inherited from Component)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnUnregisterComponents | (Inherited from Component)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

See Also

Reference

ShortcutsContainer Class
Gizmox.WebGUI.Forms Namespace


Add Method

[image]
Gizmox.WebGUI.Forms
Add Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ShortcutsContainer Class : Add Method

enmShortcut
objComponent
Maps a new shortcut

Syntax

Visual Basic (Declaration)
Public Sub Add( _
   ByVal enmShortcut As Shortcut, _
   ByVal objComponent As IRegisteredComponent _
)
Visual Basic (Usage) Copy Code
Dim instance As ShortcutsContainer
Dim enmShortcut As Shortcut
Dim objComponent As IRegisteredComponent

instance.Add(enmShortcut, objComponent)
C#
public void Add(
   Shortcut enmShortcut,
   IRegisteredComponent objComponent
)
Managed Extensions for C++
public: void Add(
   Shortcut enmShortcut,
   IRegisteredComponent* objComponent
)
C++/CLI
public:
void Add(
   Shortcut enmShortcut,
   IRegisteredComponent^ objComponent
)

Parameters

enmShortcut
objComponent

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ShortcutsContainer Class
ShortcutsContainer Members


Remove Method

[image]
Gizmox.WebGUI.Forms
Remove Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ShortcutsContainer Class : Remove Method

objComponent
Removes an existing shortcut mapping

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal objComponent As IRegisteredComponent _
)
Visual Basic (Usage) Copy Code
Dim instance As ShortcutsContainer
Dim objComponent As IRegisteredComponent

instance.Remove(objComponent)
C#
public void Remove(
   IRegisteredComponent objComponent
)
Managed Extensions for C++
public: void Remove(
   IRegisteredComponent* objComponent
)
C++/CLI
public:
void Remove(
   IRegisteredComponent^ objComponent
)

Parameters

objComponent

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ShortcutsContainer Class
ShortcutsContainer Members


ShortcutsContainer Class Properties

[image]
Gizmox.WebGUI.Forms
ShortcutsContainer Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ShortcutsContainer Class

For a list of all members of this type, see ShortcutsContainer members.

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContextMenu | Gets or sets the context menu code. (Inherited from Component)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | Item | Overloaded. Get compenent mapped to shortcut
Public Property | Site | (Inherited from ComponentBase)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

See Also

Reference

ShortcutsContainer Class
Gizmox.WebGUI.Forms Namespace


Item Property

[image]
Gizmox.WebGUI.Forms
Item Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ShortcutsContainer Class : Item Property

Get compenent mapped to shortcut

Overload List

Overload | Description
Item(Shortcut) | Get compenent mapped to shortcut
Item(IRegisteredComponent) | Get shortcut mapped to component

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ShortcutsContainer Class
ShortcutsContainer Members


Item(Shortcut) Property

[image]
Gizmox.WebGUI.Forms
Item(Shortcut) Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ShortcutsContainer Class > Item Property : Item(Shortcut) Property

enmShortcut
Get compenent mapped to shortcut

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal enmShortcut As Shortcut _
) As IRegisteredComponent
Visual Basic (Usage) Copy Code
Dim instance As ShortcutsContainer
Dim enmShortcut As Shortcut
Dim value As IRegisteredComponent

value = instance.Item(enmShortcut)
C#
public IRegisteredComponent Item(
   Shortcut enmShortcut
) {get;}
Managed Extensions for C++
public: __property IRegisteredComponent* get_Item(
   Shortcut enmShortcut
);
C++/CLI
public:
property IRegisteredComponent^ Item {
   IRegisteredComponent^ get(ShortcutenmShortcut);
}

Parameters

enmShortcut

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ShortcutsContainer Class
ShortcutsContainer Members
Overload List


Item(IRegisteredComponent) Property

[image]
Gizmox.WebGUI.Forms
Item(IRegisteredComponent) Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ShortcutsContainer Class > Item Property : Item(IRegisteredComponent) Property

objComponent
Get shortcut mapped to component

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal objComponent As IRegisteredComponent _
) As Shortcut
Visual Basic (Usage) Copy Code
Dim instance As ShortcutsContainer
Dim objComponent As IRegisteredComponent
Dim value As Shortcut

value = instance.Item(objComponent)
C#
public Shortcut Item(
   IRegisteredComponent objComponent
) {get;}
Managed Extensions for C++
public: __property Shortcut get_Item(
   IRegisteredComponent* objComponent
);
C++/CLI
public:
property Shortcut Item {
   Shortcut get(IRegisteredComponent^objComponent);
}

Parameters

objComponent

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ShortcutsContainer Class
ShortcutsContainer Members
Overload List


SplitContainer Class

[image]
Gizmox.WebGUI.Forms
SplitContainer Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : SplitContainer Class

A split container control.

Object Model

Syntax

Visual Basic (Declaration)
<DesignTimeControllerAttribute()>
<ClassInterfaceAttribute()>
<DefaultEventAttribute("SplitterMoved")>
<MetadataTagAttribute("P")>
<ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<ToolboxBitmapAttribute()>
<SRDescriptionAttribute("Divides a container's display area into two resizable panels to which you can add controls.")>
<ComVisibleAttribute(True)>
<ClientControllerAttribute()>
<ToolboxItemCategoryAttribute("Containers")>
Public Class SplitContainer
   Inherits ContainerControl
   Implements IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IContainerControl, IArrangedElement
Visual Basic (Usage) Copy Code
Dim instance As SplitContainer
C#
[DesignTimeControllerAttribute()]
[ClassInterfaceAttribute()]
[DefaultEventAttribute("SplitterMoved")]
[MetadataTagAttribute("P")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ToolboxBitmapAttribute()]
[SRDescriptionAttribute("Divides a container's display area into two resizable panels to which you can add controls.")]
[ComVisibleAttribute(true)]
[ClientControllerAttribute()]
[ToolboxItemCategoryAttribute("Containers")]
public class SplitContainer : ContainerControl, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IContainerControl, IArrangedElement
Managed Extensions for C++
[DesignTimeControllerAttribute()]
[ClassInterfaceAttribute()]
[DefaultEventAttribute("SplitterMoved")]
[MetadataTagAttribute("P")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ToolboxBitmapAttribute()]
[SRDescriptionAttribute("Divides a container's display area into two resizable panels to which you can add controls.")]
[ComVisibleAttribute(true)]
[ClientControllerAttribute()]
[ToolboxItemCategoryAttribute("Containers")]
public __gc class SplitContainer : public ContainerControl, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IContainerControl, IArrangedElement
C++/CLI
[DesignTimeControllerAttribute()]
[ClassInterfaceAttribute()]
[DefaultEventAttribute("SplitterMoved")]
[MetadataTagAttribute("P")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ToolboxBitmapAttribute()]
[SRDescriptionAttribute("Divides a container's display area into two resizable panels to which you can add controls.")]
[ComVisibleAttribute(true)]
[ClientControllerAttribute()]
[ToolboxItemCategoryAttribute("Containers")]
public ref class SplitContainer : public ContainerControl, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IContainerControl, IArrangedElement

Remarks

Use this control to split your UI.

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.ScrollableControl
Gizmox.WebGUI.Forms.ContainerControl
Gizmox.WebGUI.Forms.SplitContainer

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

SplitContainer Members
Gizmox.WebGUI.Forms Namespace


SplitContainer Class Members

[image]
Gizmox.WebGUI.Forms
SplitContainer Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : SplitContainer Class

The following tables list the members exposed by SplitContainer.

Public Constructors

 | Name | Description
Public Constructor | SplitContainer Constructor |
Top

Public Properties

 | Name | Description
Public Property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl)
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage |
Public Property | BindingContext | Overridden.
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle |
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Components | (Inherited from ContainerControl)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock |
Public Property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | FixedPanel |
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | IsSplitterFixed |
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Orientation |
Public Property | Panel1 |
Public Property | Panel1Collapsed |
Public Property | Panel1MinSize |
Public Property | Panel2 |
Public Property | Panel2Collapsed |
Public Property | Panel2MinSize |
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | SplitterDistance |
Public Property | SplitterIncrement |
Public Property | SplitterRectangle |
Public Property | SplitterWidth |
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop |
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | Overridden.
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Overridden. Gets a value indicating whether to reverse control rendering.
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Protected Property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl)
Top

Public Methods

 | Name | Description
Public Method | Add | (Inherited from ContainerControl)
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from ContainerControl)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | OnSplitterMoved |
Public Method | OnSplitterMoving |
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | Remove | (Inherited from ContainerControl)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | Overridden.
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Control)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from ScrollableControl)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | Overridden.
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Overridden.
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Overridden.
Protected Method | OnLayout |
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | Overridden.
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Overridden.
Protected Method | OnMouseLeave |
Protected Method | OnMouseMove |
Protected Method | OnMouseUp | Overridden.
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnRightToLeftChanged |
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Control)
Protected Method | RenderAttributes | Overridden. Renders the panel type attribute
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Overridden. Renders the controls sub tree
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | ScaleControl |
Protected Method | SetBoundsCore |
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged |
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | SplitterMoved |
Public Event | SplitterMoving |
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

SplitContainer Class
Gizmox.WebGUI.Forms Namespace


SplitContainer Constructor

[image]
Gizmox.WebGUI.Forms
SplitContainer Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > SplitContainer Class : SplitContainer Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As SplitContainer()
C#
public SplitContainer()
Managed Extensions for C++
public: SplitContainer();
C++/CLI
public:
SplitContainer();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SplitContainer Class
SplitContainer Members


SplitContainer Class Methods

[image]
Gizmox.WebGUI.Forms
SplitContainer Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : SplitContainer Class

For a list of all members of this type, see SplitContainer members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from ContainerControl)
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from ContainerControl)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | OnSplitterMoved |
Public Method | OnSplitterMoving |
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | Remove | (Inherited from ContainerControl)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | Overridden.
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Control)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from ScrollableControl)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | Overridden.
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Overridden.
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Overridden.
Protected Method | OnLayout |
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | Overridden.
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Overridden.
Protected Method | OnMouseLeave |
Protected Method | OnMouseMove |
Protected Method | OnMouseUp | Overridden.
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnRightToLeftChanged |
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Control)
Protected Method | RenderAttributes | Overridden. Renders the panel type attribute
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Overridden. Renders the controls sub tree
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | ScaleControl |
Protected Method | SetBoundsCore |
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

See Also

Reference

SplitContainer Class
Gizmox.WebGUI.Forms Namespace


CreateControlsInstance Method

[image]
Gizmox.WebGUI.Forms
CreateControlsInstance Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > SplitContainer Class : CreateControlsInstance Method

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overrides Function CreateControlsInstance() As Control.ControlCollection
Visual Basic (Usage) Copy Code
Dim instance As SplitContainer
Dim value As Control.ControlCollection

value = instance.CreateControlsInstance()
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected override Control.ControlCollection CreateControlsInstance()
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: Control.ControlCollection* CreateControlsInstance(); override
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
Control::ControlCollection^ CreateControlsInstance(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SplitContainer Class
SplitContainer Members


OnGotFocus Method

[image]
Gizmox.WebGUI.Forms
OnGotFocus Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > SplitContainer Class : OnGotFocus Method

e

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnGotFocus( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As SplitContainer
Dim e As EventArgs

instance.OnGotFocus(e)
C#
protected override void OnGotFocus(
   EventArgs e
)
Managed Extensions for C++
protected: void OnGotFocus(
   EventArgs* e
) override
C++/CLI
protected:
void OnGotFocus(
   EventArgs^ e
) override

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SplitContainer Class
SplitContainer Members


OnKeyDown Method

[image]
Gizmox.WebGUI.Forms
OnKeyDown Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > SplitContainer Class : OnKeyDown Method

e

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnKeyDown( _
   ByVal e As KeyEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As SplitContainer
Dim e As KeyEventArgs

instance.OnKeyDown(e)
C#
protected override void OnKeyDown(
   KeyEventArgs e
)
Managed Extensions for C++
protected: void OnKeyDown(
   KeyEventArgs* e
) override
C++/CLI
protected:
void OnKeyDown(
   KeyEventArgs^ e
) override

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SplitContainer Class
SplitContainer Members


OnKeyUp Method

[image]
Gizmox.WebGUI.Forms
OnKeyUp Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > SplitContainer Class : OnKeyUp Method

e

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnKeyUp( _
   ByVal e As KeyEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As SplitContainer
Dim e As KeyEventArgs

instance.OnKeyUp(e)
C#
protected override void OnKeyUp(
   KeyEventArgs e
)
Managed Extensions for C++
protected: void OnKeyUp(
   KeyEventArgs* e
) override
C++/CLI
protected:
void OnKeyUp(
   KeyEventArgs^ e
) override

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SplitContainer Class
SplitContainer Members


OnLayout Method

[image]
Gizmox.WebGUI.Forms
OnLayout Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > SplitContainer Class : OnLayout Method

e

Syntax

Visual Basic (Declaration)
Protected Sub OnLayout( _
   ByVal e As LayoutEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As SplitContainer
Dim e As LayoutEventArgs

instance.OnLayout(e)
C#
protected void OnLayout(
   LayoutEventArgs e
)
Managed Extensions for C++
protected: void OnLayout(
   LayoutEventArgs* e
)
C++/CLI
protected:
void OnLayout(
   LayoutEventArgs^ e
)

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SplitContainer Class
SplitContainer Members


OnLostFocus Method

[image]
Gizmox.WebGUI.Forms
OnLostFocus Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > SplitContainer Class : OnLostFocus Method

e

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnLostFocus( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As SplitContainer
Dim e As EventArgs

instance.OnLostFocus(e)
C#
protected override void OnLostFocus(
   EventArgs e
)
Managed Extensions for C++
protected: void OnLostFocus(
   EventArgs* e
) override
C++/CLI
protected:
void OnLostFocus(
   EventArgs^ e
) override

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SplitContainer Class
SplitContainer Members


OnMouseDown Method

[image]
Gizmox.WebGUI.Forms
OnMouseDown Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > SplitContainer Class : OnMouseDown Method

e

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnMouseDown( _
   ByVal e As MouseEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As SplitContainer
Dim e As MouseEventArgs

instance.OnMouseDown(e)
C#
protected override void OnMouseDown(
   MouseEventArgs e
)
Managed Extensions for C++
protected: void OnMouseDown(
   MouseEventArgs* e
) override
C++/CLI
protected:
void OnMouseDown(
   MouseEventArgs^ e
) override

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SplitContainer Class
SplitContainer Members


OnMouseLeave Method

[image]
Gizmox.WebGUI.Forms
OnMouseLeave Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > SplitContainer Class : OnMouseLeave Method

e

Syntax

Visual Basic (Declaration)
Protected Sub OnMouseLeave( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As SplitContainer
Dim e As EventArgs

instance.OnMouseLeave(e)
C#
protected void OnMouseLeave(
   EventArgs e
)
Managed Extensions for C++
protected: void OnMouseLeave(
   EventArgs* e
)
C++/CLI
protected:
void OnMouseLeave(
   EventArgs^ e
)

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SplitContainer Class
SplitContainer Members


OnMouseMove Method

[image]
Gizmox.WebGUI.Forms
OnMouseMove Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > SplitContainer Class : OnMouseMove Method

e

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Sub OnMouseMove( _
   ByVal e As MouseEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As SplitContainer
Dim e As MouseEventArgs

instance.OnMouseMove(e)
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected void OnMouseMove(
   MouseEventArgs e
)
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: void OnMouseMove(
   MouseEventArgs* e
)
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
void OnMouseMove(
   MouseEventArgs^ e
)

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SplitContainer Class
SplitContainer Members


OnMouseUp Method

[image]
Gizmox.WebGUI.Forms
OnMouseUp Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > SplitContainer Class : OnMouseUp Method

e

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnMouseUp( _
   ByVal e As MouseEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As SplitContainer
Dim e As MouseEventArgs

instance.OnMouseUp(e)
C#
protected override void OnMouseUp(
   MouseEventArgs e
)
Managed Extensions for C++
protected: void OnMouseUp(
   MouseEventArgs* e
) override
C++/CLI
protected:
void OnMouseUp(
   MouseEventArgs^ e
) override

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SplitContainer Class
SplitContainer Members


OnRightToLeftChanged Method

[image]
Gizmox.WebGUI.Forms
OnRightToLeftChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > SplitContainer Class : OnRightToLeftChanged Method

e

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Sub OnRightToLeftChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As SplitContainer
Dim e As EventArgs

instance.OnRightToLeftChanged(e)
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected void OnRightToLeftChanged(
   EventArgs e
)
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: void OnRightToLeftChanged(
   EventArgs* e
)
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
void OnRightToLeftChanged(
   EventArgs^ e
)

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SplitContainer Class
SplitContainer Members


OnSplitterMoved Method

[image]
Gizmox.WebGUI.Forms
OnSplitterMoved Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > SplitContainer Class : OnSplitterMoved Method

e

Syntax

Visual Basic (Declaration)
Public Sub OnSplitterMoved( _
   ByVal e As SplitterEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As SplitContainer
Dim e As SplitterEventArgs

instance.OnSplitterMoved(e)
C#
public void OnSplitterMoved(
   SplitterEventArgs e
)
Managed Extensions for C++
public: void OnSplitterMoved(
   SplitterEventArgs* e
)
C++/CLI
public:
void OnSplitterMoved(
   SplitterEventArgs^ e
)

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SplitContainer Class
SplitContainer Members


OnSplitterMoving Method

[image]
Gizmox.WebGUI.Forms
OnSplitterMoving Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > SplitContainer Class : OnSplitterMoving Method

e

Syntax

Visual Basic (Declaration)
Public Sub OnSplitterMoving( _
   ByVal e As SplitterCancelEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As SplitContainer
Dim e As SplitterCancelEventArgs

instance.OnSplitterMoving(e)
C#
public void OnSplitterMoving(
   SplitterCancelEventArgs e
)
Managed Extensions for C++
public: void OnSplitterMoving(
   SplitterCancelEventArgs* e
)
C++/CLI
public:
void OnSplitterMoving(
   SplitterCancelEventArgs^ e
)

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SplitContainer Class
SplitContainer Members


RenderAttributes Method

[image]
Gizmox.WebGUI.Forms
RenderAttributes Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > SplitContainer Class : RenderAttributes Method

objContext
objWriter
Renders the panel type attribute

Syntax

Visual Basic (Declaration)
Protected Overrides Sub RenderAttributes( _
   ByVal objContext As IContext, _
   ByVal objWriter As IAttributeWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As SplitContainer
Dim objContext As IContext
Dim objWriter As IAttributeWriter

instance.RenderAttributes(objContext, objWriter)
C#
protected override void RenderAttributes(
   IContext objContext,
   IAttributeWriter objWriter
)
Managed Extensions for C++
protected: void RenderAttributes(
   IContext* objContext,
   IAttributeWriter* objWriter
) override
C++/CLI
protected:
void RenderAttributes(
   IContext^ objContext,
   IAttributeWriter^ objWriter
) override

Parameters

objContext
objWriter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SplitContainer Class
SplitContainer Members


RenderControls Method

[image]
Gizmox.WebGUI.Forms
RenderControls Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > SplitContainer Class : RenderControls Method

Renders the controls sub tree

Overload List

Overload | Description
RenderControls(IContext,IResponseWriter,Int64) |
RenderControls(IContext,IResponseWriter,Int64,Boolean) | Renders the controls sub tree (Inherited from Control)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SplitContainer Class
SplitContainer Members


RenderControls(IContext,IResponseWriter,Int64) Method

[image]
Gizmox.WebGUI.Forms
RenderControls(IContext,IResponseWriter,Int64) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > SplitContainer Class > RenderControls Method : RenderControls(IContext,IResponseWriter,Int64) Method

objContext
objWriter
lngRequestID

Syntax

Visual Basic (Declaration)
Protected Overloads Overrides Sub RenderControls( _
   ByVal objContext As IContext, _
   ByVal objWriter As IResponseWriter, _
   ByVal lngRequestID As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As SplitContainer
Dim objContext As IContext
Dim objWriter As IResponseWriter
Dim lngRequestID As Long

instance.RenderControls(objContext, objWriter, lngRequestID)
C#
protected override void RenderControls(
   IContext objContext,
   IResponseWriter objWriter,
   long lngRequestID
)
Managed Extensions for C++
protected: void RenderControls(
   IContext* objContext,
   IResponseWriter* objWriter,
   long lngRequestID
) override
C++/CLI
protected:
void RenderControls(
   IContext^ objContext,
   IResponseWriter^ objWriter,
   long long lngRequestID
) override

Parameters

objContext
objWriter
lngRequestID

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SplitContainer Class
SplitContainer Members
Overload List


ScaleControl Method

[image]
Gizmox.WebGUI.Forms
ScaleControl Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > SplitContainer Class : ScaleControl Method

factor
specified

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Sub ScaleControl( _
   ByVal factor As SizeF, _
   ByVal specified As BoundsSpecified _
)
Visual Basic (Usage) Copy Code
Dim instance As SplitContainer
Dim factor As SizeF
Dim specified As BoundsSpecified

instance.ScaleControl(factor, specified)
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected void ScaleControl(
   SizeF factor,
   BoundsSpecified specified
)
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: void ScaleControl(
   SizeF factor,
   BoundsSpecified specified
)
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
void ScaleControl(
   SizeF factor,
   BoundsSpecified specified
)

Parameters

factor
specified

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SplitContainer Class
SplitContainer Members


SetBoundsCore Method

[image]
Gizmox.WebGUI.Forms
SetBoundsCore Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > SplitContainer Class : SetBoundsCore Method

x
y
width
height
specified

Syntax

Visual Basic (Declaration)
Protected Sub SetBoundsCore( _
   ByVal x As Integer, _
   ByVal y As Integer, _
   ByVal width As Integer, _
   ByVal height As Integer, _
   ByVal specified As BoundsSpecified _
)
Visual Basic (Usage) Copy Code
Dim instance As SplitContainer
Dim x As Integer
Dim y As Integer
Dim width As Integer
Dim height As Integer
Dim specified As BoundsSpecified

instance.SetBoundsCore(x, y, width, height, specified)
C#
protected void SetBoundsCore(
   int x,
   int y,
   int width,
   int height,
   BoundsSpecified specified
)
Managed Extensions for C++
protected: void SetBoundsCore(
   int x,
   int y,
   int width,
   int height,
   BoundsSpecified specified
)
C++/CLI
protected:
void SetBoundsCore(
   int x,
   int y,
   int width,
   int height,
   BoundsSpecified specified
)

Parameters

x
y
width
height
specified

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SplitContainer Class
SplitContainer Members


SplitContainer Class Properties

[image]
Gizmox.WebGUI.Forms
SplitContainer Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : SplitContainer Class

For a list of all members of this type, see SplitContainer members.

Public Properties

 | Name | Description
Public Property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl)
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage |
Public Property | BindingContext | Overridden.
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle |
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Components | (Inherited from ContainerControl)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock |
Public Property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | FixedPanel |
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | IsSplitterFixed |
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Orientation |
Public Property | Panel1 |
Public Property | Panel1Collapsed |
Public Property | Panel1MinSize |
Public Property | Panel2 |
Public Property | Panel2Collapsed |
Public Property | Panel2MinSize |
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | SplitterDistance |
Public Property | SplitterIncrement |
Public Property | SplitterRectangle |
Public Property | SplitterWidth |
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop |
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | Overridden.
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Overridden. Gets a value indicating whether to reverse control rendering.
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Protected Property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl)
Top

See Also

Reference

SplitContainer Class
Gizmox.WebGUI.Forms Namespace


BackgroundImage Property

[image]
Gizmox.WebGUI.Forms
BackgroundImage Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > SplitContainer Class : BackgroundImage Property

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute()>
<BrowsableAttribute(True)>
Public Property BackgroundImage As ResourceHandle
Visual Basic (Usage) Copy Code
Dim instance As SplitContainer
Dim value As ResourceHandle

instance.BackgroundImage = value

value = instance.BackgroundImage
C#
[EditorBrowsableAttribute()]
[BrowsableAttribute(true)]
public ResourceHandle BackgroundImage {get; set;}
Managed Extensions for C++
[EditorBrowsableAttribute()]
[BrowsableAttribute(true)]
public: __property ResourceHandle* get_BackgroundImage();
public: __property void set_BackgroundImage(
   ResourceHandle* value
);
C++/CLI
[EditorBrowsableAttribute()]
[BrowsableAttribute(true)]
public:
property ResourceHandle^ BackgroundImage {
   ResourceHandle^ get();
   void set (ResourceHandle^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SplitContainer Class
SplitContainer Members


BindingContext Property

[image]
Gizmox.WebGUI.Forms
BindingContext Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > SplitContainer Class : BindingContext Property

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("The binding manager for the container control.  This manages all bindings of child controls to lists.")>
<BrowsableAttribute(False)>
Public Overrides Property BindingContext As BindingContext
Visual Basic (Usage) Copy Code
Dim instance As SplitContainer
Dim value As BindingContext

instance.BindingContext = value

value = instance.BindingContext
C#
[SRDescriptionAttribute("The binding manager for the container control.  This manages all bindings of child controls to lists.")]
[BrowsableAttribute(false)]
public override BindingContext BindingContext {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("The binding manager for the container control.  This manages all bindings of child controls to lists.")]
[BrowsableAttribute(false)]
public: __property BindingContext* get_BindingContext() override;
public: __property void set_BindingContext(
   BindingContext* value
) override;
C++/CLI
[SRDescriptionAttribute("The binding manager for the container control.  This manages all bindings of child controls to lists.")]
[BrowsableAttribute(false)]
public:
property BindingContext^ BindingContext {
   BindingContext^ get() override;
   void set (BindingContext^value) override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SplitContainer Class
SplitContainer Members


BorderStyle Property

[image]
Gizmox.WebGUI.Forms
BorderStyle Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > SplitContainer Class : BorderStyle Property

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Appearance")>
<DefaultValueAttribute()>
<DispIdAttribute(-504)>
<SRDescriptionAttribute("The border type of the control.")>
Public Property BorderStyle As BorderStyle
Visual Basic (Usage) Copy Code
Dim instance As SplitContainer
Dim value As BorderStyle

instance.BorderStyle = value

value = instance.BorderStyle
C#
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
[DispIdAttribute(-504)]
[SRDescriptionAttribute("The border type of the control.")]
public BorderStyle BorderStyle {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
[DispIdAttribute(-504)]
[SRDescriptionAttribute("The border type of the control.")]
public: __property BorderStyle get_BorderStyle();
public: __property void set_BorderStyle(
   BorderStyle value
);
C++/CLI
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
[DispIdAttribute(-504)]
[SRDescriptionAttribute("The border type of the control.")]
public:
property BorderStyle BorderStyle {
   BorderStyle get();
   void set (BorderStylevalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SplitContainer Class
SplitContainer Members


DefaultSize Property

[image]
Gizmox.WebGUI.Forms
DefaultSize Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > SplitContainer Class : DefaultSize Property

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property DefaultSize As Size
Visual Basic (Usage) Copy Code
Dim instance As SplitContainer
Dim value As Size

value = instance.DefaultSize
C#
protected override Size DefaultSize {get;}
Managed Extensions for C++
protected: __property Size get_DefaultSize() override;
C++/CLI
protected:
property Size DefaultSize {
   Size get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SplitContainer Class
SplitContainer Members


Dock Property

[image]
Gizmox.WebGUI.Forms
Dock Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > SplitContainer Class : Dock Property

Syntax

Visual Basic (Declaration)
Public Property Dock As DockStyle
Visual Basic (Usage) Copy Code
Dim instance As SplitContainer
Dim value As DockStyle

instance.Dock = value

value = instance.Dock
C#
public DockStyle Dock {get; set;}
Managed Extensions for C++
public: __property DockStyle get_Dock();
public: __property void set_Dock(
   DockStyle value
);
C++/CLI
public:
property DockStyle Dock {
   DockStyle get();
   void set (DockStylevalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SplitContainer Class
SplitContainer Members


FixedPanel Property

[image]
Gizmox.WebGUI.Forms
FixedPanel Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > SplitContainer Class : FixedPanel Property

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<SRDescriptionAttribute("Indicates that a particular SplitContainer's Panel should remain fixed in size during resize events.")>
<SRCategoryAttribute("Layout")>
Public Property FixedPanel As FixedPanel
Visual Basic (Usage) Copy Code
Dim instance As SplitContainer
Dim value As FixedPanel

instance.FixedPanel = value

value = instance.FixedPanel
C#
[DefaultValueAttribute()]
[SRDescriptionAttribute("Indicates that a particular SplitContainer's Panel should remain fixed in size during resize events.")]
[SRCategoryAttribute("Layout")]
public FixedPanel FixedPanel {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[SRDescriptionAttribute("Indicates that a particular SplitContainer's Panel should remain fixed in size during resize events.")]
[SRCategoryAttribute("Layout")]
public: __property FixedPanel get_FixedPanel();
public: __property void set_FixedPanel(
   FixedPanel value
);
C++/CLI
[DefaultValueAttribute()]
[SRDescriptionAttribute("Indicates that a particular SplitContainer's Panel should remain fixed in size during resize events.")]
[SRCategoryAttribute("Layout")]
public:
property FixedPanel FixedPanel {
   FixedPanel get();
   void set (FixedPanelvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SplitContainer Class
SplitContainer Members


IsSplitterFixed Property

[image]
Gizmox.WebGUI.Forms
IsSplitterFixed Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > SplitContainer Class : IsSplitterFixed Property

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Layout")>
<DefaultValueAttribute()>
<LocalizableAttribute(True)>
<SRDescriptionAttribute("Determines if the splitter can move.")>
Public Property IsSplitterFixed As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SplitContainer
Dim value As Boolean

instance.IsSplitterFixed = value

value = instance.IsSplitterFixed
C#
[SRCategoryAttribute("Layout")]
[DefaultValueAttribute()]
[LocalizableAttribute(true)]
[SRDescriptionAttribute("Determines if the splitter can move.")]
public bool IsSplitterFixed {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Layout")]
[DefaultValueAttribute()]
[LocalizableAttribute(true)]
[SRDescriptionAttribute("Determines if the splitter can move.")]
public: __property bool get_IsSplitterFixed();
public: __property void set_IsSplitterFixed(
   bool value
);
C++/CLI
[SRCategoryAttribute("Layout")]
[DefaultValueAttribute()]
[LocalizableAttribute(true)]
[SRDescriptionAttribute("Determines if the splitter can move.")]
public:
property bool IsSplitterFixed {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SplitContainer Class
SplitContainer Members


Orientation Property

[image]
Gizmox.WebGUI.Forms
Orientation Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > SplitContainer Class : Orientation Property

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Behavior")>
<LocalizableAttribute(True)>
<SRDescriptionAttribute("Determines if the splitter is vertical or horizontal.")>
<DefaultValueAttribute()>
Public Property Orientation As Orientation
Visual Basic (Usage) Copy Code
Dim instance As SplitContainer
Dim value As Orientation

instance.Orientation = value

value = instance.Orientation
C#
[SRCategoryAttribute("Behavior")]
[LocalizableAttribute(true)]
[SRDescriptionAttribute("Determines if the splitter is vertical or horizontal.")]
[DefaultValueAttribute()]
public Orientation Orientation {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Behavior")]
[LocalizableAttribute(true)]
[SRDescriptionAttribute("Determines if the splitter is vertical or horizontal.")]
[DefaultValueAttribute()]
public: __property Orientation get_Orientation();
public: __property void set_Orientation(
   Orientation value
);
C++/CLI
[SRCategoryAttribute("Behavior")]
[LocalizableAttribute(true)]
[SRDescriptionAttribute("Determines if the splitter is vertical or horizontal.")]
[DefaultValueAttribute()]
public:
property Orientation Orientation {
   Orientation get();
   void set (Orientationvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SplitContainer Class
SplitContainer Members


Panel1 Property

[image]
Gizmox.WebGUI.Forms
Panel1 Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > SplitContainer Class : Panel1 Property

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("The Left or Top panel in the SplitContainer.")>
<LocalizableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
<SRCategoryAttribute("Appearance")>
Public ReadOnly Property Panel1 As SplitterPanel
Visual Basic (Usage) Copy Code
Dim instance As SplitContainer
Dim value As SplitterPanel

value = instance.Panel1
C#
[SRDescriptionAttribute("The Left or Top panel in the SplitContainer.")]
[LocalizableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
[SRCategoryAttribute("Appearance")]
public SplitterPanel Panel1 {get;}
Managed Extensions for C++
[SRDescriptionAttribute("The Left or Top panel in the SplitContainer.")]
[LocalizableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
[SRCategoryAttribute("Appearance")]
public: __property SplitterPanel* get_Panel1();
C++/CLI
[SRDescriptionAttribute("The Left or Top panel in the SplitContainer.")]
[LocalizableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
[SRCategoryAttribute("Appearance")]
public:
property SplitterPanel^ Panel1 {
   SplitterPanel^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SplitContainer Class
SplitContainer Members


Panel1Collapsed Property

[image]
Gizmox.WebGUI.Forms
Panel1Collapsed Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > SplitContainer Class : Panel1Collapsed Property

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<SRCategoryAttribute("Layout")>
<SRDescriptionAttribute("This determines if Panel1 is collapsed.")>
Public Property Panel1Collapsed As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SplitContainer
Dim value As Boolean

instance.Panel1Collapsed = value

value = instance.Panel1Collapsed
C#
[DefaultValueAttribute()]
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("This determines if Panel1 is collapsed.")]
public bool Panel1Collapsed {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("This determines if Panel1 is collapsed.")]
public: __property bool get_Panel1Collapsed();
public: __property void set_Panel1Collapsed(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("This determines if Panel1 is collapsed.")]
public:
property bool Panel1Collapsed {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SplitContainer Class
SplitContainer Members


Panel1MinSize Property

[image]
Gizmox.WebGUI.Forms
Panel1MinSize Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > SplitContainer Class : Panel1MinSize Property

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Layout")>
<DefaultValueAttribute()>
<LocalizableAttribute(True)>
<RefreshPropertiesAttribute()>
<SRDescriptionAttribute("Determines the minimum distance of pixels of the splitter from the left or the top edge of Panel1.")>
Public Property Panel1MinSize As Integer
Visual Basic (Usage) Copy Code
Dim instance As SplitContainer
Dim value As Integer

instance.Panel1MinSize = value

value = instance.Panel1MinSize
C#
[SRCategoryAttribute("Layout")]
[DefaultValueAttribute()]
[LocalizableAttribute(true)]
[RefreshPropertiesAttribute()]
[SRDescriptionAttribute("Determines the minimum distance of pixels of the splitter from the left or the top edge of Panel1.")]
public int Panel1MinSize {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Layout")]
[DefaultValueAttribute()]
[LocalizableAttribute(true)]
[RefreshPropertiesAttribute()]
[SRDescriptionAttribute("Determines the minimum distance of pixels of the splitter from the left or the top edge of Panel1.")]
public: __property int get_Panel1MinSize();
public: __property void set_Panel1MinSize(
   int value
);
C++/CLI
[SRCategoryAttribute("Layout")]
[DefaultValueAttribute()]
[LocalizableAttribute(true)]
[RefreshPropertiesAttribute()]
[SRDescriptionAttribute("Determines the minimum distance of pixels of the splitter from the left or the top edge of Panel1.")]
public:
property int Panel1MinSize {
   int get();
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SplitContainer Class
SplitContainer Members


Panel2 Property

[image]
Gizmox.WebGUI.Forms
Panel2 Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > SplitContainer Class : Panel2 Property

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
<SRDescriptionAttribute("The Right or Bottom panel in the SplitContainer.")>
<LocalizableAttribute(False)>
<SRCategoryAttribute("Appearance")>
Public ReadOnly Property Panel2 As SplitterPanel
Visual Basic (Usage) Copy Code
Dim instance As SplitContainer
Dim value As SplitterPanel

value = instance.Panel2
C#
[DesignerSerializationVisibilityAttribute()]
[SRDescriptionAttribute("The Right or Bottom panel in the SplitContainer.")]
[LocalizableAttribute(false)]
[SRCategoryAttribute("Appearance")]
public SplitterPanel Panel2 {get;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
[SRDescriptionAttribute("The Right or Bottom panel in the SplitContainer.")]
[LocalizableAttribute(false)]
[SRCategoryAttribute("Appearance")]
public: __property SplitterPanel* get_Panel2();
C++/CLI
[DesignerSerializationVisibilityAttribute()]
[SRDescriptionAttribute("The Right or Bottom panel in the SplitContainer.")]
[LocalizableAttribute(false)]
[SRCategoryAttribute("Appearance")]
public:
property SplitterPanel^ Panel2 {
   SplitterPanel^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SplitContainer Class
SplitContainer Members


Panel2Collapsed Property

[image]
Gizmox.WebGUI.Forms
Panel2Collapsed Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > SplitContainer Class : Panel2Collapsed Property

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<SRDescriptionAttribute("This determines if Panel2 is collapsed.")>
<SRCategoryAttribute("Layout")>
Public Property Panel2Collapsed As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SplitContainer
Dim value As Boolean

instance.Panel2Collapsed = value

value = instance.Panel2Collapsed
C#
[DefaultValueAttribute()]
[SRDescriptionAttribute("This determines if Panel2 is collapsed.")]
[SRCategoryAttribute("Layout")]
public bool Panel2Collapsed {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[SRDescriptionAttribute("This determines if Panel2 is collapsed.")]
[SRCategoryAttribute("Layout")]
public: __property bool get_Panel2Collapsed();
public: __property void set_Panel2Collapsed(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
[SRDescriptionAttribute("This determines if Panel2 is collapsed.")]
[SRCategoryAttribute("Layout")]
public:
property bool Panel2Collapsed {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SplitContainer Class
SplitContainer Members


Panel2MinSize Property

[image]
Gizmox.WebGUI.Forms
Panel2MinSize Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > SplitContainer Class : Panel2MinSize Property

Syntax

Visual Basic (Declaration)
<RefreshPropertiesAttribute()>
<SRCategoryAttribute("Layout")>
<DefaultValueAttribute()>
<LocalizableAttribute(True)>
<SRDescriptionAttribute("Determines the minimum distance of pixels of the splitter from the right or the bottom edge of Panel2.")>
Public Property Panel2MinSize As Integer
Visual Basic (Usage) Copy Code
Dim instance As SplitContainer
Dim value As Integer

instance.Panel2MinSize = value

value = instance.Panel2MinSize
C#
[RefreshPropertiesAttribute()]
[SRCategoryAttribute("Layout")]
[DefaultValueAttribute()]
[LocalizableAttribute(true)]
[SRDescriptionAttribute("Determines the minimum distance of pixels of the splitter from the right or the bottom edge of Panel2.")]
public int Panel2MinSize {get; set;}
Managed Extensions for C++
[RefreshPropertiesAttribute()]
[SRCategoryAttribute("Layout")]
[DefaultValueAttribute()]
[LocalizableAttribute(true)]
[SRDescriptionAttribute("Determines the minimum distance of pixels of the splitter from the right or the bottom edge of Panel2.")]
public: __property int get_Panel2MinSize();
public: __property void set_Panel2MinSize(
   int value
);
C++/CLI
[RefreshPropertiesAttribute()]
[SRCategoryAttribute("Layout")]
[DefaultValueAttribute()]
[LocalizableAttribute(true)]
[SRDescriptionAttribute("Determines the minimum distance of pixels of the splitter from the right or the bottom edge of Panel2.")]
public:
property int Panel2MinSize {
   int get();
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SplitContainer Class
SplitContainer Members


ReverseControls Property

[image]
Gizmox.WebGUI.Forms
ReverseControls Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > SplitContainer Class : ReverseControls Property

Gets a value indicating whether to reverse control rendering.

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property ReverseControls As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SplitContainer
Dim value As Boolean

value = instance.ReverseControls
C#
protected override bool ReverseControls {get;}
Managed Extensions for C++
protected: __property bool get_ReverseControls() override;
C++/CLI
protected:
property bool ReverseControls {
   bool get() override;
}

Return Value

true if to reverse control rendering; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SplitContainer Class
SplitContainer Members


SplitterDistance Property

[image]
Gizmox.WebGUI.Forms
SplitterDistance Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > SplitContainer Class : SplitterDistance Property

Syntax

Visual Basic (Declaration)
<SettingsBindableAttribute(True)>
<LocalizableAttribute(True)>
<SRDescriptionAttribute("Determines pixel distance of the splitter from the left or top edge.")>
<DefaultValueAttribute()>
<SRCategoryAttribute("Layout")>
Public Property SplitterDistance As Integer
Visual Basic (Usage) Copy Code
Dim instance As SplitContainer
Dim value As Integer

instance.SplitterDistance = value

value = instance.SplitterDistance
C#
[SettingsBindableAttribute(true)]
[LocalizableAttribute(true)]
[SRDescriptionAttribute("Determines pixel distance of the splitter from the left or top edge.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Layout")]
public int SplitterDistance {get; set;}
Managed Extensions for C++
[SettingsBindableAttribute(true)]
[LocalizableAttribute(true)]
[SRDescriptionAttribute("Determines pixel distance of the splitter from the left or top edge.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Layout")]
public: __property int get_SplitterDistance();
public: __property void set_SplitterDistance(
   int value
);
C++/CLI
[SettingsBindableAttribute(true)]
[LocalizableAttribute(true)]
[SRDescriptionAttribute("Determines pixel distance of the splitter from the left or top edge.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Layout")]
public:
property int SplitterDistance {
   int get();
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SplitContainer Class
SplitContainer Members


SplitterIncrement Property

[image]
Gizmox.WebGUI.Forms
SplitterIncrement Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > SplitContainer Class : SplitterIncrement Property

Syntax

Visual Basic (Declaration)
<LocalizableAttribute(True)>
<DefaultValueAttribute()>
<SRDescriptionAttribute("Determines the number of pixels the splitter moves in increments. Default is 1.")>
<SRCategoryAttribute("Layout")>
Public Property SplitterIncrement As Integer
Visual Basic (Usage) Copy Code
Dim instance As SplitContainer
Dim value As Integer

instance.SplitterIncrement = value

value = instance.SplitterIncrement
C#
[LocalizableAttribute(true)]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Determines the number of pixels the splitter moves in increments. Default is 1.")]
[SRCategoryAttribute("Layout")]
public int SplitterIncrement {get; set;}
Managed Extensions for C++
[LocalizableAttribute(true)]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Determines the number of pixels the splitter moves in increments. Default is 1.")]
[SRCategoryAttribute("Layout")]
public: __property int get_SplitterIncrement();
public: __property void set_SplitterIncrement(
   int value
);
C++/CLI
[LocalizableAttribute(true)]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Determines the number of pixels the splitter moves in increments. Default is 1.")]
[SRCategoryAttribute("Layout")]
public:
property int SplitterIncrement {
   int get();
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SplitContainer Class
SplitContainer Members


SplitterRectangle Property

[image]
Gizmox.WebGUI.Forms
SplitterRectangle Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > SplitContainer Class : SplitterRectangle Property

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Layout")>
<BrowsableAttribute(False)>
<SRDescriptionAttribute("Determines the rectangle bounds of the splitter.")>
Public ReadOnly Property SplitterRectangle As Rectangle
Visual Basic (Usage) Copy Code
Dim instance As SplitContainer
Dim value As Rectangle

value = instance.SplitterRectangle
C#
[SRCategoryAttribute("Layout")]
[BrowsableAttribute(false)]
[SRDescriptionAttribute("Determines the rectangle bounds of the splitter.")]
public Rectangle SplitterRectangle {get;}
Managed Extensions for C++
[SRCategoryAttribute("Layout")]
[BrowsableAttribute(false)]
[SRDescriptionAttribute("Determines the rectangle bounds of the splitter.")]
public: __property Rectangle get_SplitterRectangle();
C++/CLI
[SRCategoryAttribute("Layout")]
[BrowsableAttribute(false)]
[SRDescriptionAttribute("Determines the rectangle bounds of the splitter.")]
public:
property Rectangle SplitterRectangle {
   Rectangle get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SplitContainer Class
SplitContainer Members


SplitterWidth Property

[image]
Gizmox.WebGUI.Forms
SplitterWidth Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > SplitContainer Class : SplitterWidth Property

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Determines the thickness of the splitter.")>
<LocalizableAttribute(True)>
<SRCategoryAttribute("Layout")>
<DefaultValueAttribute()>
Public Property SplitterWidth As Integer
Visual Basic (Usage) Copy Code
Dim instance As SplitContainer
Dim value As Integer

instance.SplitterWidth = value

value = instance.SplitterWidth
C#
[SRDescriptionAttribute("Determines the thickness of the splitter.")]
[LocalizableAttribute(true)]
[SRCategoryAttribute("Layout")]
[DefaultValueAttribute()]
public int SplitterWidth {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Determines the thickness of the splitter.")]
[LocalizableAttribute(true)]
[SRCategoryAttribute("Layout")]
[DefaultValueAttribute()]
public: __property int get_SplitterWidth();
public: __property void set_SplitterWidth(
   int value
);
C++/CLI
[SRDescriptionAttribute("Determines the thickness of the splitter.")]
[LocalizableAttribute(true)]
[SRCategoryAttribute("Layout")]
[DefaultValueAttribute()]
public:
property int SplitterWidth {
   int get();
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SplitContainer Class
SplitContainer Members


TabStop Property

[image]
Gizmox.WebGUI.Forms
TabStop Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > SplitContainer Class : TabStop Property

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Behavior")>
<DefaultValueAttribute()>
<DispIdAttribute(-516)>
<SRDescriptionAttribute("Indicates whether the user can use the TAB key to give focus to the control.")>
Public Property TabStop As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SplitContainer
Dim value As Boolean

instance.TabStop = value

value = instance.TabStop
C#
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[DispIdAttribute(-516)]
[SRDescriptionAttribute("Indicates whether the user can use the TAB key to give focus to the control.")]
public bool TabStop {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[DispIdAttribute(-516)]
[SRDescriptionAttribute("Indicates whether the user can use the TAB key to give focus to the control.")]
public: __property bool get_TabStop();
public: __property void set_TabStop(
   bool value
);
C++/CLI
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[DispIdAttribute(-516)]
[SRDescriptionAttribute("Indicates whether the user can use the TAB key to give focus to the control.")]
public:
property bool TabStop {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SplitContainer Class
SplitContainer Members


SplitContainer Class Events

[image]
Gizmox.WebGUI.Forms
SplitContainer Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : SplitContainer Class

For a list of all members of this type, see SplitContainer members.

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged |
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | SplitterMoved |
Public Event | SplitterMoving |
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

SplitContainer Class
Gizmox.WebGUI.Forms Namespace


BackgroundImageChanged Event

[image]
Gizmox.WebGUI.Forms
BackgroundImageChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > SplitContainer Class : BackgroundImageChanged Event

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute()>
<BrowsableAttribute(True)>
Public Event BackgroundImageChanged() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As SplitContainer
Dim handler As EventHandler

AddHandler instance.BackgroundImageChanged, handler
C#
[EditorBrowsableAttribute()]
[BrowsableAttribute(true)]
public event EventHandler BackgroundImageChanged()
Managed Extensions for C++
[EditorBrowsableAttribute()]
[BrowsableAttribute(true)]
public: __event EventHandler* BackgroundImageChanged
C++/CLI
[EditorBrowsableAttribute()]
[BrowsableAttribute(true)]
public:
event EventHandler^ BackgroundImageChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SplitContainer Class
SplitContainer Members


SplitterMoved Event

[image]
Gizmox.WebGUI.Forms
SplitterMoved Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > SplitContainer Class : SplitterMoved Event

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the splitter is done being moved.")>
<SRCategoryAttribute("Behavior")>
Public Event SplitterMoved() As SplitterEventHandler
Visual Basic (Usage) Copy Code
Dim instance As SplitContainer
Dim handler As SplitterEventHandler

AddHandler instance.SplitterMoved, handler
C#
[SRDescriptionAttribute("Occurs when the splitter is done being moved.")]
[SRCategoryAttribute("Behavior")]
public event SplitterEventHandler SplitterMoved()
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the splitter is done being moved.")]
[SRCategoryAttribute("Behavior")]
public: __event SplitterEventHandler* SplitterMoved
C++/CLI
[SRDescriptionAttribute("Occurs when the splitter is done being moved.")]
[SRCategoryAttribute("Behavior")]
public:
event SplitterEventHandler^ SplitterMoved

Event Data

The event handler receives an argument of type SplitterEventArgs containing data related to this event. The following SplitterEventArgs properties provide information specific to this event.

Property | Description
SplitX |
SplitY |
X |
Y |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SplitContainer Class
SplitContainer Members


SplitterMoving Event

[image]
Gizmox.WebGUI.Forms
SplitterMoving Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > SplitContainer Class : SplitterMoving Event

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Behavior")>
<SRDescriptionAttribute("Occurs when the splitter is being moved.")>
Public Event SplitterMoving() As SplitterCancelEventHandler
Visual Basic (Usage) Copy Code
Dim instance As SplitContainer
Dim handler As SplitterCancelEventHandler

AddHandler instance.SplitterMoving, handler
C#
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when the splitter is being moved.")]
public event SplitterCancelEventHandler SplitterMoving()
Managed Extensions for C++
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when the splitter is being moved.")]
public: __event SplitterCancelEventHandler* SplitterMoving
C++/CLI
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when the splitter is being moved.")]
public:
event SplitterCancelEventHandler^ SplitterMoving

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SplitContainer Class
SplitContainer Members


Splitter Class

[image]
Gizmox.WebGUI.Forms
Splitter Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : Splitter Class

Represents a splitter control that enables the user to resize docked controls. Splitter has been replaced by SplitContainer and is provided only for compatibility with previous versions.

Object Model

Syntax

Visual Basic (Declaration)
<ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableSplitter, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")>
<DesignTimeControllerAttribute()>
<ClientControllerAttribute()>
<ToolboxBitmapAttribute()>
<ToolboxItemCategoryAttribute("Common Controls")>
<MetadataTagAttribute("S")>
Public Class Splitter
   Inherits Control
   Implements IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Visual Basic (Usage) Copy Code
Dim instance As Splitter
C#
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableSplitter, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[DesignTimeControllerAttribute()]
[ClientControllerAttribute()]
[ToolboxBitmapAttribute()]
[ToolboxItemCategoryAttribute("Common Controls")]
[MetadataTagAttribute("S")]
public class Splitter : Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Managed Extensions for C++
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableSplitter, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[DesignTimeControllerAttribute()]
[ClientControllerAttribute()]
[ToolboxBitmapAttribute()]
[ToolboxItemCategoryAttribute("Common Controls")]
[MetadataTagAttribute("S")]
public __gc class Splitter : public Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
C++/CLI
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableSplitter, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[DesignTimeControllerAttribute()]
[ClientControllerAttribute()]
[ToolboxBitmapAttribute()]
[ToolboxItemCategoryAttribute("Common Controls")]
[MetadataTagAttribute("S")]
public ref class Splitter : public Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.Splitter

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Splitter Members
Gizmox.WebGUI.Forms Namespace


Splitter Class Members

[image]
Gizmox.WebGUI.Forms
Splitter Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : Splitter Class

The following tables list the members exposed by Splitter.

Public Constructors

 | Name | Description
Public Constructor | Splitter Constructor | Initializes a new instance of the Splitter class. Splitter has been replaced by SplitContainer, and is provided only for compatibility with previous versions.
Top

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Control)
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | OnSplitterMoved | Raises the SplitterMoved event.
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Overridden. Fires an event.
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from Control)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | Overridden. An abstract control method rendering
Protected Method | RenderAttributes | Renders the controls meta attributes (Inherited from Control)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | SplitterMoved |
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

Splitter Class
Gizmox.WebGUI.Forms Namespace


Splitter Constructor

[image]
Gizmox.WebGUI.Forms
Splitter Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Splitter Class : Splitter Constructor

Initializes a new instance of the Splitter class. Splitter has been replaced by SplitContainer, and is provided only for compatibility with previous versions.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Splitter()
C#
public Splitter()
Managed Extensions for C++
public: Splitter();
C++/CLI
public:
Splitter();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Splitter Class
Splitter Members


Splitter Class Methods

[image]
Gizmox.WebGUI.Forms
Splitter Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : Splitter Class

For a list of all members of this type, see Splitter members.

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | OnSplitterMoved | Raises the SplitterMoved event.
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Overridden. Fires an event.
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from Control)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | Overridden. An abstract control method rendering
Protected Method | RenderAttributes | Renders the controls meta attributes (Inherited from Control)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

See Also

Reference

Splitter Class
Gizmox.WebGUI.Forms Namespace


FireEvent Method

[image]
Gizmox.WebGUI.Forms
FireEvent Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Splitter Class : FireEvent Method

objEvent
event.
Fires an event.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub FireEvent( _
   ByVal objEvent As IEvent _
)
Visual Basic (Usage) Copy Code
Dim instance As Splitter
Dim objEvent As IEvent

instance.FireEvent(objEvent)
C#
protected override void FireEvent(
   IEvent objEvent
)
Managed Extensions for C++
protected: void FireEvent(
   IEvent* objEvent
) override
C++/CLI
protected:
void FireEvent(
   IEvent^ objEvent
) override

Parameters

objEvent
event.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Splitter Class
Splitter Members


OnSplitterMoved Method

[image]
Gizmox.WebGUI.Forms
OnSplitterMoved Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Splitter Class : OnSplitterMoved Method

e
The SplitterEventArgs instance containing the event data.
Raises the SplitterMoved event.

Syntax

Visual Basic (Declaration)
Public Sub OnSplitterMoved( _
   ByVal e As SplitterEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As Splitter
Dim e As SplitterEventArgs

instance.OnSplitterMoved(e)
C#
public void OnSplitterMoved(
   SplitterEventArgs e
)
Managed Extensions for C++
public: void OnSplitterMoved(
   SplitterEventArgs* e
)
C++/CLI
public:
void OnSplitterMoved(
   SplitterEventArgs^ e
)

Parameters

e
The SplitterEventArgs instance containing the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Splitter Class
Splitter Members


Render Method

[image]
Gizmox.WebGUI.Forms
Render Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Splitter Class : Render Method

objContext
objWriter
lngRequestID
An abstract control method rendering

Syntax

Visual Basic (Declaration)
Protected Overrides Sub Render( _
   ByVal objContext As IContext, _
   ByVal objWriter As IResponseWriter, _
   ByVal lngRequestID As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As Splitter
Dim objContext As IContext
Dim objWriter As IResponseWriter
Dim lngRequestID As Long

instance.Render(objContext, objWriter, lngRequestID)
C#
protected override void Render(
   IContext objContext,
   IResponseWriter objWriter,
   long lngRequestID
)
Managed Extensions for C++
protected: void Render(
   IContext* objContext,
   IResponseWriter* objWriter,
   long lngRequestID
) override
C++/CLI
protected:
void Render(
   IContext^ objContext,
   IResponseWriter^ objWriter,
   long long lngRequestID
) override

Parameters

objContext
objWriter
lngRequestID

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Splitter Class
Splitter Members


Splitter Class Events

[image]
Gizmox.WebGUI.Forms
Splitter Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : Splitter Class

For a list of all members of this type, see Splitter members.

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | SplitterMoved |
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

Splitter Class
Gizmox.WebGUI.Forms Namespace


SplitterMoved Event

[image]
Gizmox.WebGUI.Forms
SplitterMoved Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Splitter Class : SplitterMoved Event

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the splitter is done being moved.")>
<SRCategoryAttribute("Behavior")>
Public Event SplitterMoved() As SplitterEventHandler
Visual Basic (Usage) Copy Code
Dim instance As Splitter
Dim handler As SplitterEventHandler

AddHandler instance.SplitterMoved, handler
C#
[SRDescriptionAttribute("Occurs when the splitter is done being moved.")]
[SRCategoryAttribute("Behavior")]
public event SplitterEventHandler SplitterMoved()
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the splitter is done being moved.")]
[SRCategoryAttribute("Behavior")]
public: __event SplitterEventHandler* SplitterMoved
C++/CLI
[SRDescriptionAttribute("Occurs when the splitter is done being moved.")]
[SRCategoryAttribute("Behavior")]
public:
event SplitterEventHandler^ SplitterMoved

Event Data

The event handler receives an argument of type SplitterEventArgs containing data related to this event. The following SplitterEventArgs properties provide information specific to this event.

Property | Description
SplitX |
SplitY |
X |
Y |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Splitter Class
Splitter Members


SplitterCancelEventArgs Class

[image]
Gizmox.WebGUI.Forms
SplitterCancelEventArgs Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : SplitterCancelEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class SplitterCancelEventArgs
   Inherits CancelEventArgs
Visual Basic (Usage) Copy Code
Dim instance As SplitterCancelEventArgs
C#
public class SplitterCancelEventArgs : CancelEventArgs
Managed Extensions for C++
public __gc class SplitterCancelEventArgs : public CancelEventArgs
C++/CLI
public ref class SplitterCancelEventArgs : public CancelEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
System.ComponentModel.CancelEventArgs
Gizmox.WebGUI.Forms.SplitterCancelEventArgs

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

SplitterCancelEventArgs Members
Gizmox.WebGUI.Forms Namespace


SplitterCancelEventArgs Class Members

[image]
Gizmox.WebGUI.Forms
SplitterCancelEventArgs Class Members
See Also Properties Send Feedback
Gizmox.WebGUI.Forms Namespace : SplitterCancelEventArgs Class

The following tables list the members exposed by SplitterCancelEventArgs.

Public Constructors

 | Name | Description
Public Constructor | SplitterCancelEventArgs Constructor |
Top

Public Properties

 | Name | Description
Public Property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from System.ComponentModel.CancelEventArgs)
Public Property | MouseCursorX |
Public Property | MouseCursorY |
Public Property | SplitX |
Public Property | SplitY |
Top

See Also

Reference

SplitterCancelEventArgs Class
Gizmox.WebGUI.Forms Namespace


SplitterCancelEventArgs Constructor

[image]
Gizmox.WebGUI.Forms
SplitterCancelEventArgs Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > SplitterCancelEventArgs Class : SplitterCancelEventArgs Constructor

mouseCursorX
mouseCursorY
splitX
splitY

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal mouseCursorX As Integer, _
   ByVal mouseCursorY As Integer, _
   ByVal splitX As Integer, _
   ByVal splitY As Integer _
)
Visual Basic (Usage) Copy Code
Dim mouseCursorX As Integer
Dim mouseCursorY As Integer
Dim splitX As Integer
Dim splitY As Integer

Dim instance As SplitterCancelEventArgs(mouseCursorX, mouseCursorY, splitX, splitY)
C#
public SplitterCancelEventArgs(
   int mouseCursorX,
   int mouseCursorY,
   int splitX,
   int splitY
)
Managed Extensions for C++
public: SplitterCancelEventArgs(
   int mouseCursorX,
   int mouseCursorY,
   int splitX,
   int splitY
)
C++/CLI
public:
SplitterCancelEventArgs(
   int mouseCursorX,
   int mouseCursorY,
   int splitX,
   int splitY
)

Parameters

mouseCursorX
mouseCursorY
splitX
splitY

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SplitterCancelEventArgs Class
SplitterCancelEventArgs Members


SplitterCancelEventArgs Class Properties

[image]
Gizmox.WebGUI.Forms
SplitterCancelEventArgs Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : SplitterCancelEventArgs Class

For a list of all members of this type, see SplitterCancelEventArgs members.

Public Properties

 | Name | Description
Public Property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from System.ComponentModel.CancelEventArgs)
Public Property | MouseCursorX |
Public Property | MouseCursorY |
Public Property | SplitX |
Public Property | SplitY |
Top

See Also

Reference

SplitterCancelEventArgs Class
Gizmox.WebGUI.Forms Namespace


MouseCursorX Property

[image]
Gizmox.WebGUI.Forms
MouseCursorX Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > SplitterCancelEventArgs Class : MouseCursorX Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MouseCursorX As Integer
Visual Basic (Usage) Copy Code
Dim instance As SplitterCancelEventArgs
Dim value As Integer

value = instance.MouseCursorX
C#
public int MouseCursorX {get;}
Managed Extensions for C++
public: __property int get_MouseCursorX();
C++/CLI
public:
property int MouseCursorX {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SplitterCancelEventArgs Class
SplitterCancelEventArgs Members


MouseCursorY Property

[image]
Gizmox.WebGUI.Forms
MouseCursorY Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > SplitterCancelEventArgs Class : MouseCursorY Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MouseCursorY As Integer
Visual Basic (Usage) Copy Code
Dim instance As SplitterCancelEventArgs
Dim value As Integer

value = instance.MouseCursorY
C#
public int MouseCursorY {get;}
Managed Extensions for C++
public: __property int get_MouseCursorY();
C++/CLI
public:
property int MouseCursorY {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SplitterCancelEventArgs Class
SplitterCancelEventArgs Members


SplitX Property

[image]
Gizmox.WebGUI.Forms
SplitX Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > SplitterCancelEventArgs Class : SplitX Property

Syntax

Visual Basic (Declaration)
Public Property SplitX As Integer
Visual Basic (Usage) Copy Code
Dim instance As SplitterCancelEventArgs
Dim value As Integer

instance.SplitX = value

value = instance.SplitX
C#
public int SplitX {get; set;}
Managed Extensions for C++
public: __property int get_SplitX();
public: __property void set_SplitX(
   int value
);
C++/CLI
public:
property int SplitX {
   int get();
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SplitterCancelEventArgs Class
SplitterCancelEventArgs Members


SplitY Property

[image]
Gizmox.WebGUI.Forms
SplitY Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > SplitterCancelEventArgs Class : SplitY Property

Syntax

Visual Basic (Declaration)
Public Property SplitY As Integer
Visual Basic (Usage) Copy Code
Dim instance As SplitterCancelEventArgs
Dim value As Integer

instance.SplitY = value

value = instance.SplitY
C#
public int SplitY {get; set;}
Managed Extensions for C++
public: __property int get_SplitY();
public: __property void set_SplitY(
   int value
);
C++/CLI
public:
property int SplitY {
   int get();
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SplitterCancelEventArgs Class
SplitterCancelEventArgs Members


SplitterEventArgs Class

[image]
Gizmox.WebGUI.Forms
SplitterEventArgs Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : SplitterEventArgs Class

Syntax

Visual Basic (Declaration)
<ComVisibleAttribute(True)>
Public Class SplitterEventArgs
   Inherits EventArgs
Visual Basic (Usage) Copy Code
Dim instance As SplitterEventArgs
C#
[ComVisibleAttribute(true)]
public class SplitterEventArgs : EventArgs
Managed Extensions for C++
[ComVisibleAttribute(true)]
public __gc class SplitterEventArgs : public EventArgs
C++/CLI
[ComVisibleAttribute(true)]
public ref class SplitterEventArgs : public EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gizmox.WebGUI.Forms.SplitterEventArgs

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

SplitterEventArgs Members
Gizmox.WebGUI.Forms Namespace


SplitterEventArgs Class Members

[image]
Gizmox.WebGUI.Forms
SplitterEventArgs Class Members
See Also Properties Send Feedback
Gizmox.WebGUI.Forms Namespace : SplitterEventArgs Class

The following tables list the members exposed by SplitterEventArgs.

Public Constructors

 | Name | Description
Public Constructor | SplitterEventArgs Constructor |
Top

Public Properties

 | Name | Description
Public Property | SplitX |
Public Property | SplitY |
Public Property | X |
Public Property | Y |
Top

See Also

Reference

SplitterEventArgs Class
Gizmox.WebGUI.Forms Namespace


SplitterEventArgs Constructor

[image]
Gizmox.WebGUI.Forms
SplitterEventArgs Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > SplitterEventArgs Class : SplitterEventArgs Constructor

x
y
splitX
splitY

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal x As Integer, _
   ByVal y As Integer, _
   ByVal splitX As Integer, _
   ByVal splitY As Integer _
)
Visual Basic (Usage) Copy Code
Dim x As Integer
Dim y As Integer
Dim splitX As Integer
Dim splitY As Integer

Dim instance As SplitterEventArgs(x, y, splitX, splitY)
C#
public SplitterEventArgs(
   int x,
   int y,
   int splitX,
   int splitY
)
Managed Extensions for C++
public: SplitterEventArgs(
   int x,
   int y,
   int splitX,
   int splitY
)
C++/CLI
public:
SplitterEventArgs(
   int x,
   int y,
   int splitX,
   int splitY
)

Parameters

x
y
splitX
splitY

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SplitterEventArgs Class
SplitterEventArgs Members


SplitterEventArgs Class Properties

[image]
Gizmox.WebGUI.Forms
SplitterEventArgs Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : SplitterEventArgs Class

For a list of all members of this type, see SplitterEventArgs members.

Public Properties

 | Name | Description
Public Property | SplitX |
Public Property | SplitY |
Public Property | X |
Public Property | Y |
Top

See Also

Reference

SplitterEventArgs Class
Gizmox.WebGUI.Forms Namespace


SplitX Property

[image]
Gizmox.WebGUI.Forms
SplitX Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > SplitterEventArgs Class : SplitX Property

Syntax

Visual Basic (Declaration)
Public Property SplitX As Integer
Visual Basic (Usage) Copy Code
Dim instance As SplitterEventArgs
Dim value As Integer

instance.SplitX = value

value = instance.SplitX
C#
public int SplitX {get; set;}
Managed Extensions for C++
public: __property int get_SplitX();
public: __property void set_SplitX(
   int value
);
C++/CLI
public:
property int SplitX {
   int get();
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SplitterEventArgs Class
SplitterEventArgs Members


SplitY Property

[image]
Gizmox.WebGUI.Forms
SplitY Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > SplitterEventArgs Class : SplitY Property

Syntax

Visual Basic (Declaration)
Public Property SplitY As Integer
Visual Basic (Usage) Copy Code
Dim instance As SplitterEventArgs
Dim value As Integer

instance.SplitY = value

value = instance.SplitY
C#
public int SplitY {get; set;}
Managed Extensions for C++
public: __property int get_SplitY();
public: __property void set_SplitY(
   int value
);
C++/CLI
public:
property int SplitY {
   int get();
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SplitterEventArgs Class
SplitterEventArgs Members


X Property

[image]
Gizmox.WebGUI.Forms
X Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > SplitterEventArgs Class : X Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property X As Integer
Visual Basic (Usage) Copy Code
Dim instance As SplitterEventArgs
Dim value As Integer

value = instance.X
C#
public int X {get;}
Managed Extensions for C++
public: __property int get_X();
C++/CLI
public:
property int X {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SplitterEventArgs Class
SplitterEventArgs Members


Y Property

[image]
Gizmox.WebGUI.Forms
Y Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > SplitterEventArgs Class : Y Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Y As Integer
Visual Basic (Usage) Copy Code
Dim instance As SplitterEventArgs
Dim value As Integer

value = instance.Y
C#
public int Y {get;}
Managed Extensions for C++
public: __property int get_Y();
C++/CLI
public:
property int Y {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SplitterEventArgs Class
SplitterEventArgs Members


SplitterPanel Class

[image]
Gizmox.WebGUI.Forms
SplitterPanel Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : SplitterPanel Class

Represents a Panel control.

Object Model

Syntax

Visual Basic (Declaration)
<DesignTimeControllerAttribute()>
<ClassInterfaceAttribute()>
<ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")>
<ClientControllerAttribute()>
<ComVisibleAttribute(True)>
Public NotInheritable Class SplitterPanel
   Inherits Panel
   Implements IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Visual Basic (Usage) Copy Code
Dim instance As SplitterPanel
C#
[DesignTimeControllerAttribute()]
[ClassInterfaceAttribute()]
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
[ClientControllerAttribute()]
[ComVisibleAttribute(true)]
public sealed class SplitterPanel : Panel, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Managed Extensions for C++
[DesignTimeControllerAttribute()]
[ClassInterfaceAttribute()]
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
[ClientControllerAttribute()]
[ComVisibleAttribute(true)]
public __gc __sealed class SplitterPanel : public Panel, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
C++/CLI
[DesignTimeControllerAttribute()]
[ClassInterfaceAttribute()]
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
[ClientControllerAttribute()]
[ComVisibleAttribute(true)]
public ref class SplitterPanel sealed : public Panel, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.ScrollableControl
Gizmox.WebGUI.Forms.Panel
Gizmox.WebGUI.Forms.SplitterPanel

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

SplitterPanel Members
Gizmox.WebGUI.Forms Namespace


SplitterPanel Class Members

[image]
Gizmox.WebGUI.Forms
SplitterPanel Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : SplitterPanel Class

The following tables list the members exposed by SplitterPanel.

Public Constructors

 | Name | Description
Public Constructor | SplitterPanel Constructor |
Top

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Gets a value indicating whether this control can recive focus. (Inherited from Panel)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height |
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text. (Inherited from Panel)
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | Width |
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | Overridden.
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Protected Property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl)
Top

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Control)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from ScrollableControl)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Control)
Protected Method | RenderAttributes | (Inherited from Panel)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | (Inherited from Panel)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializePanelType | (Inherited from Panel)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Top

See Also

Reference

SplitterPanel Class
Gizmox.WebGUI.Forms Namespace


SplitterPanel Constructor

[image]
Gizmox.WebGUI.Forms
SplitterPanel Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > SplitterPanel Class : SplitterPanel Constructor

owner

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal owner As SplitContainer _
)
Visual Basic (Usage) Copy Code
Dim owner As SplitContainer

Dim instance As SplitterPanel(owner)
C#
public SplitterPanel(
   SplitContainer owner
)
Managed Extensions for C++
public: SplitterPanel(
   SplitContainer* owner
)
C++/CLI
public:
SplitterPanel(
   SplitContainer^ owner
)

Parameters

owner

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SplitterPanel Class
SplitterPanel Members


SplitterPanel Class Properties

[image]
Gizmox.WebGUI.Forms
SplitterPanel Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : SplitterPanel Class

For a list of all members of this type, see SplitterPanel members.

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Gets a value indicating whether this control can recive focus. (Inherited from Panel)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height |
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text. (Inherited from Panel)
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | Width |
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | Overridden.
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Protected Property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl)
Top

See Also

Reference

SplitterPanel Class
Gizmox.WebGUI.Forms Namespace


DefaultMargin Property

[image]
Gizmox.WebGUI.Forms
DefaultMargin Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > SplitterPanel Class : DefaultMargin Property

Syntax

Visual Basic (Declaration)
Protected Overrides NotOverridable ReadOnly Property DefaultMargin As Padding
Visual Basic (Usage) Copy Code
Dim instance As SplitterPanel
Dim value As Padding

value = instance.DefaultMargin
C#
protected override Padding DefaultMargin {get;}
Managed Extensions for C++
protected: __property Padding get_DefaultMargin() override;
C++/CLI
protected:
property Padding DefaultMargin {
   Padding get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SplitterPanel Class
SplitterPanel Members


Height Property

[image]
Gizmox.WebGUI.Forms
Height Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > SplitterPanel Class : Height Property

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute()>
<SRDescriptionAttribute("The height of the user interface element, in pixels.")>
<BrowsableAttribute(False)>
<SRCategoryAttribute("Layout")>
<DesignerSerializationVisibilityAttribute()>
Public Property Height As Integer
Visual Basic (Usage) Copy Code
Dim instance As SplitterPanel
Dim value As Integer

instance.Height = value

value = instance.Height
C#
[EditorBrowsableAttribute()]
[SRDescriptionAttribute("The height of the user interface element, in pixels.")]
[BrowsableAttribute(false)]
[SRCategoryAttribute("Layout")]
[DesignerSerializationVisibilityAttribute()]
public int Height {get; set;}
Managed Extensions for C++
[EditorBrowsableAttribute()]
[SRDescriptionAttribute("The height of the user interface element, in pixels.")]
[BrowsableAttribute(false)]
[SRCategoryAttribute("Layout")]
[DesignerSerializationVisibilityAttribute()]
public: __property int get_Height();
public: __property void set_Height(
   int value
);
C++/CLI
[EditorBrowsableAttribute()]
[SRDescriptionAttribute("The height of the user interface element, in pixels.")]
[BrowsableAttribute(false)]
[SRCategoryAttribute("Layout")]
[DesignerSerializationVisibilityAttribute()]
public:
property int Height {
   int get();
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SplitterPanel Class
SplitterPanel Members


Width Property

[image]
Gizmox.WebGUI.Forms
Width Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > SplitterPanel Class : Width Property

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<SRCategoryAttribute("Layout")>
<EditorBrowsableAttribute()>
<DesignerSerializationVisibilityAttribute()>
<SRDescriptionAttribute("The width of the control, in container coordinates.")>
Public Property Width As Integer
Visual Basic (Usage) Copy Code
Dim instance As SplitterPanel
Dim value As Integer

instance.Width = value

value = instance.Width
C#
[BrowsableAttribute(false)]
[SRCategoryAttribute("Layout")]
[EditorBrowsableAttribute()]
[DesignerSerializationVisibilityAttribute()]
[SRDescriptionAttribute("The width of the control, in container coordinates.")]
public int Width {get; set;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[SRCategoryAttribute("Layout")]
[EditorBrowsableAttribute()]
[DesignerSerializationVisibilityAttribute()]
[SRDescriptionAttribute("The width of the control, in container coordinates.")]
public: __property int get_Width();
public: __property void set_Width(
   int value
);
C++/CLI
[BrowsableAttribute(false)]
[SRCategoryAttribute("Layout")]
[EditorBrowsableAttribute()]
[DesignerSerializationVisibilityAttribute()]
[SRDescriptionAttribute("The width of the control, in container coordinates.")]
public:
property int Width {
   int get();
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SplitterPanel Class
SplitterPanel Members


StatusBar Class

[image]
Gizmox.WebGUI.Forms
StatusBar Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : StatusBar Class

Represents a Gizmox.WebGUI.Forms status bar control. Although ToolStripStatusLabel replaces and adds functionality to the StatusBar control of previous versions, StatusBar is retained for both backward compatibility and future use if you choose.

Object Model

Syntax

Visual Basic (Declaration)
<ToolboxBitmapAttribute()>
<DefaultPropertyAttribute("Text")>
<ToolboxItemCategoryAttribute("Common Controls")>
<SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableStatusBar, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")>
<ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<DesignTimeControllerAttribute()>
<ClientControllerAttribute()>
<MetadataTagAttribute("SB")>
Public Class StatusBar
   Inherits Control
   Implements IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Visual Basic (Usage) Copy Code
Dim instance As StatusBar
C#
[ToolboxBitmapAttribute()]
[DefaultPropertyAttribute("Text")]
[ToolboxItemCategoryAttribute("Common Controls")]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableStatusBar, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[DesignTimeControllerAttribute()]
[ClientControllerAttribute()]
[MetadataTagAttribute("SB")]
public class StatusBar : Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Managed Extensions for C++
[ToolboxBitmapAttribute()]
[DefaultPropertyAttribute("Text")]
[ToolboxItemCategoryAttribute("Common Controls")]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableStatusBar, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[DesignTimeControllerAttribute()]
[ClientControllerAttribute()]
[MetadataTagAttribute("SB")]
public __gc class StatusBar : public Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
C++/CLI
[ToolboxBitmapAttribute()]
[DefaultPropertyAttribute("Text")]
[ToolboxItemCategoryAttribute("Common Controls")]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableStatusBar, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[DesignTimeControllerAttribute()]
[ClientControllerAttribute()]
[MetadataTagAttribute("SB")]
public ref class StatusBar : public Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.StatusBar

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

StatusBar Members
Gizmox.WebGUI.Forms Namespace


StatusBar Class Members

[image]
Gizmox.WebGUI.Forms
StatusBar Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : StatusBar Class

The following tables list the members exposed by StatusBar.

Public Constructors

 | Name | Description
Public Constructor | StatusBar Constructor | Initializes a new instance of the StatusBar class.
Top

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Panels | Gets the collection of StatusBar panels contained within the control.
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | ShowPanels | Gets or sets a value indicating whether any panels that have been added to the control are displayed.
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Control)
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Control)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from Control)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | Overridden.
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Control)
Protected Method | RenderAttributes | Overridden.
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Overridden. Renders the controls sub tree
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | Overridden.
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

StatusBar Class
Gizmox.WebGUI.Forms Namespace


StatusBar Constructor

[image]
Gizmox.WebGUI.Forms
StatusBar Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > StatusBar Class : StatusBar Constructor

Initializes a new instance of the StatusBar class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StatusBar()
C#
public StatusBar()
Managed Extensions for C++
public: StatusBar();
C++/CLI
public:
StatusBar();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

StatusBar Class
StatusBar Members


StatusBar Class Methods

[image]
Gizmox.WebGUI.Forms
StatusBar Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : StatusBar Class

For a list of all members of this type, see StatusBar members.

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Control)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from Control)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | Overridden.
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Control)
Protected Method | RenderAttributes | Overridden.
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Overridden. Renders the controls sub tree
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | Overridden.
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

See Also

Reference

StatusBar Class
Gizmox.WebGUI.Forms Namespace


OnUnregisterComponents Method

[image]
Gizmox.WebGUI.Forms
OnUnregisterComponents Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > StatusBar Class : OnUnregisterComponents Method

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnUnregisterComponents()
Visual Basic (Usage) Copy Code
Dim instance As StatusBar

instance.OnUnregisterComponents()
C#
protected override void OnUnregisterComponents()
Managed Extensions for C++
protected: void OnUnregisterComponents(); override
C++/CLI
protected:
void OnUnregisterComponents(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

StatusBar Class
StatusBar Members


RenderAttributes Method

[image]
Gizmox.WebGUI.Forms
RenderAttributes Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > StatusBar Class : RenderAttributes Method

objContext
objWriter

Syntax

Visual Basic (Declaration)
Protected Overrides Sub RenderAttributes( _
   ByVal objContext As IContext, _
   ByVal objWriter As IAttributeWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As StatusBar
Dim objContext As IContext
Dim objWriter As IAttributeWriter

instance.RenderAttributes(objContext, objWriter)
C#
protected override void RenderAttributes(
   IContext objContext,
   IAttributeWriter objWriter
)
Managed Extensions for C++
protected: void RenderAttributes(
   IContext* objContext,
   IAttributeWriter* objWriter
) override
C++/CLI
protected:
void RenderAttributes(
   IContext^ objContext,
   IAttributeWriter^ objWriter
) override

Parameters

objContext
objWriter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

StatusBar Class
StatusBar Members


RenderControls Method

[image]
Gizmox.WebGUI.Forms
RenderControls Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > StatusBar Class : RenderControls Method

Renders the controls sub tree

Overload List

Overload | Description
RenderControls(IContext,IResponseWriter,Int64) | Renders the controls sub tree
RenderControls(IContext,IResponseWriter,Int64,Boolean) | Renders the controls sub tree (Inherited from Control)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

StatusBar Class
StatusBar Members


RenderControls(IContext,IResponseWriter,Int64) Method

[image]
Gizmox.WebGUI.Forms
RenderControls(IContext,IResponseWriter,Int64) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > StatusBar Class > RenderControls Method : RenderControls(IContext,IResponseWriter,Int64) Method

objContext
Request context.
objWriter
lngRequestID
Renders the controls sub tree

Syntax

Visual Basic (Declaration)
Protected Overloads Overrides Sub RenderControls( _
   ByVal objContext As IContext, _
   ByVal objWriter As IResponseWriter, _
   ByVal lngRequestID As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As StatusBar
Dim objContext As IContext
Dim objWriter As IResponseWriter
Dim lngRequestID As Long

instance.RenderControls(objContext, objWriter, lngRequestID)
C#
protected override void RenderControls(
   IContext objContext,
   IResponseWriter objWriter,
   long lngRequestID
)
Managed Extensions for C++
protected: void RenderControls(
   IContext* objContext,
   IResponseWriter* objWriter,
   long lngRequestID
) override
C++/CLI
protected:
void RenderControls(
   IContext^ objContext,
   IResponseWriter^ objWriter,
   long long lngRequestID
) override

Parameters

objContext
Request context.
objWriter
lngRequestID

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

StatusBar Class
StatusBar Members
Overload List


RenderUpdatedAttributes Method

[image]
Gizmox.WebGUI.Forms
RenderUpdatedAttributes Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > StatusBar Class : RenderUpdatedAttributes Method

objContext
objWriter
lngRequestID

Syntax

Visual Basic (Declaration)
Protected Overrides Sub RenderUpdatedAttributes( _
   ByVal objContext As IContext, _
   ByVal objWriter As IAttributeWriter, _
   ByVal lngRequestID As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As StatusBar
Dim objContext As IContext
Dim objWriter As IAttributeWriter
Dim lngRequestID As Long

instance.RenderUpdatedAttributes(objContext, objWriter, lngRequestID)
C#
protected override void RenderUpdatedAttributes(
   IContext objContext,
   IAttributeWriter objWriter,
   long lngRequestID
)
Managed Extensions for C++
protected: void RenderUpdatedAttributes(
   IContext* objContext,
   IAttributeWriter* objWriter,
   long lngRequestID
) override
C++/CLI
protected:
void RenderUpdatedAttributes(
   IContext^ objContext,
   IAttributeWriter^ objWriter,
   long long lngRequestID
) override

Parameters

objContext
objWriter
lngRequestID

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

StatusBar Class
StatusBar Members


StatusBar Class Properties

[image]
Gizmox.WebGUI.Forms
StatusBar Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : StatusBar Class

For a list of all members of this type, see StatusBar members.

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Panels | Gets the collection of StatusBar panels contained within the control.
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | ShowPanels | Gets or sets a value indicating whether any panels that have been added to the control are displayed.
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Control)
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

See Also

Reference

StatusBar Class
Gizmox.WebGUI.Forms Namespace


Panels Property

[image]
Gizmox.WebGUI.Forms
Panels Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > StatusBar Class : Panels Property

Gets the collection of StatusBar panels contained within the control.

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
<SRDescriptionAttribute("The panels in the status bar.")>
<LocalizableAttribute(True)>
<MergablePropertyAttribute(False)>
<SRCategoryAttribute("Appearance")>
<BrowsableAttribute(True)>
Public ReadOnly Property Panels As StatusBar.StatusBarPanelCollection
Visual Basic (Usage) Copy Code
Dim instance As StatusBar
Dim value As StatusBar.StatusBarPanelCollection

value = instance.Panels
C#
[DesignerSerializationVisibilityAttribute()]
[SRDescriptionAttribute("The panels in the status bar.")]
[LocalizableAttribute(true)]
[MergablePropertyAttribute(false)]
[SRCategoryAttribute("Appearance")]
[BrowsableAttribute(true)]
public StatusBar.StatusBarPanelCollection Panels {get;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
[SRDescriptionAttribute("The panels in the status bar.")]
[LocalizableAttribute(true)]
[MergablePropertyAttribute(false)]
[SRCategoryAttribute("Appearance")]
[BrowsableAttribute(true)]
public: __property StatusBar.StatusBarPanelCollection* get_Panels();
C++/CLI
[DesignerSerializationVisibilityAttribute()]
[SRDescriptionAttribute("The panels in the status bar.")]
[LocalizableAttribute(true)]
[MergablePropertyAttribute(false)]
[SRCategoryAttribute("Appearance")]
[BrowsableAttribute(true)]
public:
property StatusBar::StatusBarPanelCollection^ Panels {
   StatusBar::StatusBarPanelCollection^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

StatusBar Class
StatusBar Members


ShowPanels Property

[image]
Gizmox.WebGUI.Forms
ShowPanels Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > StatusBar Class : ShowPanels Property

Gets or sets a value indicating whether any panels that have been added to the control are displayed.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Determines if a status bar displays panels, or if it displays a single line of text.")>
<SRCategoryAttribute("Behavior")>
<DefaultValueAttribute()>
Public Property ShowPanels As Boolean
Visual Basic (Usage) Copy Code
Dim instance As StatusBar
Dim value As Boolean

instance.ShowPanels = value

value = instance.ShowPanels
C#
[SRDescriptionAttribute("Determines if a status bar displays panels, or if it displays a single line of text.")]
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
public bool ShowPanels {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Determines if a status bar displays panels, or if it displays a single line of text.")]
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
public: __property bool get_ShowPanels();
public: __property void set_ShowPanels(
   bool value
);
C++/CLI
[SRDescriptionAttribute("Determines if a status bar displays panels, or if it displays a single line of text.")]
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
public:
property bool ShowPanels {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

StatusBar Class
StatusBar Members


StatusBar.StatusBarPanelCollection Class

[image]
Gizmox.WebGUI.Forms
StatusBar.StatusBarPanelCollection Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : StatusBar.StatusBarPanelCollection Class

Represents the collection of panels in a StatusBar control.

Object Model

Syntax

Visual Basic (Declaration)
<ListBindableAttribute(False)>
<DefaultMemberAttribute("Item")>
Public Class StatusBar.StatusBarPanelCollection
   Implements IObservableList
Visual Basic (Usage) Copy Code
Dim instance As StatusBar.StatusBarPanelCollection
C#
[ListBindableAttribute(false)]
[DefaultMemberAttribute("Item")]
public class StatusBar.StatusBarPanelCollection : IObservableList
Managed Extensions for C++
[ListBindableAttribute(false)]
[DefaultMemberAttribute("Item")]
public __gc class StatusBar.StatusBarPanelCollection : public IObservableList
C++/CLI
[ListBindableAttribute(false)]
[DefaultMemberAttribute("Item")]
public ref class StatusBar.StatusBarPanelCollection : public IObservableList

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.StatusBar.StatusBarPanelCollection

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

StatusBar.StatusBarPanelCollection Members
Gizmox.WebGUI.Forms Namespace


StatusBar.StatusBarPanelCollection Class Members

[image]
Gizmox.WebGUI.Forms
StatusBar.StatusBarPanelCollection Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : StatusBar.StatusBarPanelCollection Class

The following tables list the members exposed by StatusBar.StatusBarPanelCollection.

Public Constructors

 | Name | Description
Public Constructor | StatusBar.StatusBarPanelCollection Constructor | Initializes a new instance of the StatusBarPanelCollection class.
Top

Public Properties

 | Name | Description
Public Property | IsFixedSize | Gets a value indicating whether the collection has a fixed size.
Public Property | IsReadOnly | Gets a value indicating whether this collection is read-only.
Public Property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe).
Public Property | Item | Gets or sets the StatusBarPanel at the specified index.
Public Property | SyncRoot | Gets an object that can be used to synchronize access to the collection.
Top

Public Methods

 | Name | Description
Public Method | Add | Adds a StatusBarPanel to the collection.
Public Method | AddRange | Adds an array of StatusBarPanel objects to the collection.
Public Method | Clear | Removes all items from the collection.
Public Method | Contains | Determines whether the specified panel is located within the collection.
Public Method | CopyTo | Copies the StatusBarPanelCollection to a compatible one-dimensional array, starting at the specified index of the target array.
Public Method | GetEnumerator | Returns an enumerator to use to iterate through the item collection.
Public Method | IndexOf | Returns the index within the collection of the specified panel.
Public Method | Insert | Inserts the specified StatusBarPanel into the collection at the specified index.
Public Method | Remove | Removes the specified StatusBarPanel from the collection.
Public Method | RemoveAt | Removes the StatusBarPanel located at the specified index within the collection.
Top

See Also

Reference

StatusBar.StatusBarPanelCollection Class
Gizmox.WebGUI.Forms Namespace


StatusBar.StatusBarPanelCollection Constructor

[image]
Gizmox.WebGUI.Forms
StatusBar.StatusBarPanelCollection Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > StatusBar.StatusBarPanelCollection Class : StatusBar.StatusBarPanelCollection Constructor

objStatusBar
The StatusBar control that contains this collection.
Initializes a new instance of the StatusBarPanelCollection class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal objStatusBar As StatusBar _
)
Visual Basic (Usage) Copy Code
Dim objStatusBar As StatusBar

Dim instance As StatusBar.StatusBarPanelCollection(objStatusBar)
C#
public StatusBar.StatusBarPanelCollection(
   StatusBar objStatusBar
)
Managed Extensions for C++
public: StatusBar.StatusBarPanelCollection(
   StatusBar* objStatusBar
)
C++/CLI
public:
StatusBar.StatusBarPanelCollection(
   StatusBar^ objStatusBar
)

Parameters

objStatusBar
The StatusBar control that contains this collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

StatusBar.StatusBarPanelCollection Class
StatusBar.StatusBarPanelCollection Members


StatusBar.StatusBarPanelCollection Class Methods

[image]
Gizmox.WebGUI.Forms
StatusBar.StatusBarPanelCollection Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : StatusBar.StatusBarPanelCollection Class

For a list of all members of this type, see StatusBar.StatusBarPanelCollection members.

Public Methods

 | Name | Description
Public Method | Add | Adds a StatusBarPanel to the collection.
Public Method | AddRange | Adds an array of StatusBarPanel objects to the collection.
Public Method | Clear | Removes all items from the collection.
Public Method | Contains | Determines whether the specified panel is located within the collection.
Public Method | CopyTo | Copies the StatusBarPanelCollection to a compatible one-dimensional array, starting at the specified index of the target array.
Public Method | GetEnumerator | Returns an enumerator to use to iterate through the item collection.
Public Method | IndexOf | Returns the index within the collection of the specified panel.
Public Method | Insert | Inserts the specified StatusBarPanel into the collection at the specified index.
Public Method | Remove | Removes the specified StatusBarPanel from the collection.
Public Method | RemoveAt | Removes the StatusBarPanel located at the specified index within the collection.
Top

See Also

Reference

StatusBar.StatusBarPanelCollection Class
Gizmox.WebGUI.Forms Namespace


Add Method

[image]
Gizmox.WebGUI.Forms
Add Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > StatusBar.StatusBarPanelCollection Class : Add Method

value
A StatusBarPanel that represents the panel to add to the collection.
Adds a StatusBarPanel to the collection.

Syntax

Visual Basic (Declaration)
Public Function Add( _
   ByVal value As StatusBarPanel _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As StatusBar.StatusBarPanelCollection
Dim value As StatusBarPanel
Dim value As Integer

value = instance.Add(value)
C#
public int Add(
   StatusBarPanel value
)
Managed Extensions for C++
public: int Add(
   StatusBarPanel* value
)
C++/CLI
public:
int Add(
   StatusBarPanel^ value
)

Parameters

value
A StatusBarPanel that represents the panel to add to the collection.

Return Value

The zero-based index of the item in the collection.

Exceptions

Exception | Description
ArgumentException | The parent of the StatusBarPanel specified in the value parameter is not null.
ArgumentNullException | The StatusBarPanel being added to the collection was null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

StatusBar.StatusBarPanelCollection Class
StatusBar.StatusBarPanelCollection Members


AddRange Method

[image]
Gizmox.WebGUI.Forms
AddRange Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > StatusBar.StatusBarPanelCollection Class : AddRange Method

panels
An array of StatusBarPanel objects to add.
Adds an array of StatusBarPanel objects to the collection.

Syntax

Visual Basic (Declaration)
Public Sub AddRange( _
   ByVal panels() As StatusBarPanel _
)
Visual Basic (Usage) Copy Code
Dim instance As StatusBar.StatusBarPanelCollection
Dim panels() As StatusBarPanel

instance.AddRange(panels)
C#
public void AddRange(
   StatusBarPanel[] panels
)
Managed Extensions for C++
public: void AddRange(
   StatusBarPanel*[]* panels
)
C++/CLI
public:
void AddRange(
   array<StatusBarPanel^>^ panels
)

Parameters

panels
An array of StatusBarPanel objects to add.

Exceptions

Exception | Description
ArgumentNullException | The array of StatusBarPanel objects being added to the collection was null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

StatusBar.StatusBarPanelCollection Class
StatusBar.StatusBarPanelCollection Members


Clear Method

[image]
Gizmox.WebGUI.Forms
Clear Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > StatusBar.StatusBarPanelCollection Class : Clear Method

Removes all items from the collection.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As StatusBar.StatusBarPanelCollection

instance.Clear()
C#
public void Clear()
Managed Extensions for C++
public: void Clear();
C++/CLI
public:
void Clear();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

StatusBar.StatusBarPanelCollection Class
StatusBar.StatusBarPanelCollection Members


Contains Method

[image]
Gizmox.WebGUI.Forms
Contains Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > StatusBar.StatusBarPanelCollection Class : Contains Method

panel
The StatusBarPanel to locate in the collection.
Determines whether the specified panel is located within the collection.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal panel As StatusBarPanel _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As StatusBar.StatusBarPanelCollection
Dim panel As StatusBarPanel
Dim value As Boolean

value = instance.Contains(panel)
C#
public bool Contains(
   StatusBarPanel panel
)
Managed Extensions for C++
public: bool Contains(
   StatusBarPanel* panel
)
C++/CLI
public:
bool Contains(
   StatusBarPanel^ panel
)

Parameters

panel
The StatusBarPanel to locate in the collection.

Return Value

true if the panel is located within the collection; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

StatusBar.StatusBarPanelCollection Class
StatusBar.StatusBarPanelCollection Members


CopyTo Method

[image]
Gizmox.WebGUI.Forms
CopyTo Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > StatusBar.StatusBarPanelCollection Class : CopyTo Method

dest
The one-dimensional array that is the destination of the elements copied from the collection. The array must have zero-based indexing.
index
The zero-based index in the array at which copying begins.
Copies the StatusBarPanelCollection to a compatible one-dimensional array, starting at the specified index of the target array.

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal dest As Array, _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As StatusBar.StatusBarPanelCollection
Dim dest As Array
Dim index As Integer

instance.CopyTo(dest, index)
C#
public void CopyTo(
   Array dest,
   int index
)
Managed Extensions for C++
public: void CopyTo(
   Array* dest,
   int index
)
C++/CLI
public:
void CopyTo(
   Array^ dest,
   int index
)

Parameters

dest
The one-dimensional array that is the destination of the elements copied from the collection. The array must have zero-based indexing.
index
The zero-based index in the array at which copying begins.

Exceptions

Exception | Description
InvalidCastException | The type in the collection cannot be cast automatically to the type of array.
ArgumentOutOfRangeException | index is less than zero.
ArgumentException | array is multidimensional.-or-index is equal to or greater than the length of array.-or-The number of elements in the StatusBarPanelCollection is greater than the available space from index to the end of array.
ArgumentNullException | array is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

StatusBar.StatusBarPanelCollection Class
StatusBar.StatusBarPanelCollection Members


GetEnumerator Method

[image]
Gizmox.WebGUI.Forms
GetEnumerator Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > StatusBar.StatusBarPanelCollection Class : GetEnumerator Method

Returns an enumerator to use to iterate through the item collection.

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As StatusBar.StatusBarPanelCollection
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Return Value

An IEnumerator that represents the item collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

StatusBar.StatusBarPanelCollection Class
StatusBar.StatusBarPanelCollection Members


IndexOf Method

[image]
Gizmox.WebGUI.Forms
IndexOf Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > StatusBar.StatusBarPanelCollection Class : IndexOf Method

panel
The StatusBarPanel to locate in the collection.
Returns the index within the collection of the specified panel.

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal panel As StatusBarPanel _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As StatusBar.StatusBarPanelCollection
Dim panel As StatusBarPanel
Dim value As Integer

value = instance.IndexOf(panel)
C#
public int IndexOf(
   StatusBarPanel panel
)
Managed Extensions for C++
public: int IndexOf(
   StatusBarPanel* panel
)
C++/CLI
public:
int IndexOf(
   StatusBarPanel^ panel
)

Parameters

panel
The StatusBarPanel to locate in the collection.

Return Value

The zero-based index where the panel is located within the collection; otherwise, negative one (-1).

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

StatusBar.StatusBarPanelCollection Class
StatusBar.StatusBarPanelCollection Members


Insert Method

[image]
Gizmox.WebGUI.Forms
Insert Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > StatusBar.StatusBarPanelCollection Class : Insert Method

index
The zero-based index location where the panel is inserted.
value
A StatusBarPanel representing the panel to insert.
Inserts the specified StatusBarPanel into the collection at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal value As StatusBarPanel _
)
Visual Basic (Usage) Copy Code
Dim instance As StatusBar.StatusBarPanelCollection
Dim index As Integer
Dim value As StatusBarPanel

instance.Insert(index, value)
C#
public void Insert(
   int index,
   StatusBarPanel value
)
Managed Extensions for C++
public: void Insert(
   int index,
   StatusBarPanel* value
)
C++/CLI
public:
void Insert(
   int index,
   StatusBarPanel^ value
)

Parameters

index
The zero-based index location where the panel is inserted.
value
A StatusBarPanel representing the panel to insert.

Exceptions

Exception | Description
InvalidEnumArgumentException | The StatusBarPanel.AutoSize property of the value parameter's panel is not a valid StatusBarPanelAutoSize value.
ArgumentNullException | The value parameter is null.
ArgumentOutOfRangeException | The index parameter is less than zero or greater than the value of the Count property of the StatusBarPanelCollection class.
ArgumentException | The value parameter's parent is not null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

StatusBar.StatusBarPanelCollection Class
StatusBar.StatusBarPanelCollection Members


Remove Method

[image]
Gizmox.WebGUI.Forms
Remove Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > StatusBar.StatusBarPanelCollection Class : Remove Method

value
The StatusBarPanel representing the panel to remove from the collection.
Removes the specified StatusBarPanel from the collection.

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal value As StatusBarPanel _
)
Visual Basic (Usage) Copy Code
Dim instance As StatusBar.StatusBarPanelCollection
Dim value As StatusBarPanel

instance.Remove(value)
C#
public void Remove(
   StatusBarPanel value
)
Managed Extensions for C++
public: void Remove(
   StatusBarPanel* value
)
C++/CLI
public:
void Remove(
   StatusBarPanel^ value
)

Parameters

value
The StatusBarPanel representing the panel to remove from the collection.

Exceptions

Exception | Description
ArgumentNullException | The StatusBarPanel assigned to the value parameter is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

StatusBar.StatusBarPanelCollection Class
StatusBar.StatusBarPanelCollection Members


RemoveAt Method

[image]
Gizmox.WebGUI.Forms
RemoveAt Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > StatusBar.StatusBarPanelCollection Class : RemoveAt Method

index
The zero-based index of the item to remove.
Removes the StatusBarPanel located at the specified index within the collection.

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As StatusBar.StatusBarPanelCollection
Dim index As Integer

instance.RemoveAt(index)
C#
public void RemoveAt(
   int index
)
Managed Extensions for C++
public: void RemoveAt(
   int index
)
C++/CLI
public:
void RemoveAt(
   int index
)

Parameters

index
The zero-based index of the item to remove.

Exceptions

Exception | Description
ArgumentOutOfRangeException | The index parameter is less than zero or greater than or equal to the value of the Count property of the StatusBarPanelCollection class.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

StatusBar.StatusBarPanelCollection Class
StatusBar.StatusBarPanelCollection Members


StatusBar.StatusBarPanelCollection Class Properties

[image]
Gizmox.WebGUI.Forms
StatusBar.StatusBarPanelCollection Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : StatusBar.StatusBarPanelCollection Class

For a list of all members of this type, see StatusBar.StatusBarPanelCollection members.

Public Properties

 | Name | Description
Public Property | IsFixedSize | Gets a value indicating whether the collection has a fixed size.
Public Property | IsReadOnly | Gets a value indicating whether this collection is read-only.
Public Property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe).
Public Property | Item | Gets or sets the StatusBarPanel at the specified index.
Public Property | SyncRoot | Gets an object that can be used to synchronize access to the collection.
Top

See Also

Reference

StatusBar.StatusBarPanelCollection Class
Gizmox.WebGUI.Forms Namespace


IsFixedSize Property

[image]
Gizmox.WebGUI.Forms
IsFixedSize Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > StatusBar.StatusBarPanelCollection Class : IsFixedSize Property

Gets a value indicating whether the collection has a fixed size.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsFixedSize As Boolean
Visual Basic (Usage) Copy Code
Dim instance As StatusBar.StatusBarPanelCollection
Dim value As Boolean

value = instance.IsFixedSize
C#
public bool IsFixedSize {get;}
Managed Extensions for C++
public: __property bool get_IsFixedSize();
C++/CLI
public:
property bool IsFixedSize {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

StatusBar.StatusBarPanelCollection Class
StatusBar.StatusBarPanelCollection Members


IsReadOnly Property

[image]
Gizmox.WebGUI.Forms
IsReadOnly Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > StatusBar.StatusBarPanelCollection Class : IsReadOnly Property

Gets a value indicating whether this collection is read-only.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsReadOnly As Boolean
Visual Basic (Usage) Copy Code
Dim instance As StatusBar.StatusBarPanelCollection
Dim value As Boolean

value = instance.IsReadOnly
C#
public bool IsReadOnly {get;}
Managed Extensions for C++
public: __property bool get_IsReadOnly();
C++/CLI
public:
property bool IsReadOnly {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

StatusBar.StatusBarPanelCollection Class
StatusBar.StatusBarPanelCollection Members


IsSynchronized Property

[image]
Gizmox.WebGUI.Forms
IsSynchronized Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > StatusBar.StatusBarPanelCollection Class : IsSynchronized Property

Gets a value indicating whether access to the collection is synchronized (thread safe).

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsSynchronized As Boolean
Visual Basic (Usage) Copy Code
Dim instance As StatusBar.StatusBarPanelCollection
Dim value As Boolean

value = instance.IsSynchronized
C#
public bool IsSynchronized {get;}
Managed Extensions for C++
public: __property bool get_IsSynchronized();
C++/CLI
public:
property bool IsSynchronized {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

StatusBar.StatusBarPanelCollection Class
StatusBar.StatusBarPanelCollection Members


Item Property

[image]
Gizmox.WebGUI.Forms
Item Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > StatusBar.StatusBarPanelCollection Class : Item Property

index
The index of the panel in the collection to get or set.
Gets or sets the StatusBarPanel at the specified index.

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal index As Integer _
) As StatusBarPanel
Visual Basic (Usage) Copy Code
Dim instance As StatusBar.StatusBarPanelCollection
Dim index As Integer
Dim value As StatusBarPanel

instance.Item(index) = value

value = instance.Item(index)
C#
public StatusBarPanel this[
   int index
]; {get; set;}
Managed Extensions for C++
public: __property StatusBarPanel* get_Item(
   int index
);
public: __property void set_Item(
   int index,
   StatusBarPanel* value
);
C++/CLI
public:
property StatusBarPanel^ default [int] {
   StatusBarPanel^ get(intindex);
   void set (intindex, StatusBarPanel^value);
}

Parameters

index
The index of the panel in the collection to get or set.

Exceptions

Exception | Description
ArgumentOutOfRangeException | The index parameter is less than zero or greater than or equal to the value of the Count property of the StatusBarPanelCollection class.
ArgumentNullException | The StatusBarPanel assigned to the collection was null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

StatusBar.StatusBarPanelCollection Class
StatusBar.StatusBarPanelCollection Members


SyncRoot Property

[image]
Gizmox.WebGUI.Forms
SyncRoot Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > StatusBar.StatusBarPanelCollection Class : SyncRoot Property

Gets an object that can be used to synchronize access to the collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SyncRoot As Object
Visual Basic (Usage) Copy Code
Dim instance As StatusBar.StatusBarPanelCollection
Dim value As Object

value = instance.SyncRoot
C#
public object SyncRoot {get;}
Managed Extensions for C++
public: __property Object* get_SyncRoot();
C++/CLI
public:
property Object^ SyncRoot {
   Object^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

StatusBar.StatusBarPanelCollection Class
StatusBar.StatusBarPanelCollection Members


StatusBarPanel Class

[image]
Gizmox.WebGUI.Forms
StatusBarPanel Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : StatusBarPanel Class

Represents a panel in a StatusBar control. Although the StatusStrip control replaces and adds functionality to the StatusBar control of previous versions, StatusBar is retained for both backward compatibility and future use if you choose.

Object Model

Syntax

Visual Basic (Declaration)
<ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")>
<DesignTimeVisibleAttribute()>
<DesignTimeControllerAttribute()>
<ClientControllerAttribute()>
<DefaultPropertyAttribute("Text")>
Public Class StatusBarPanel
   Inherits Component
   Implements IAttributeExtender, IEventHandler, IGatewayComponent, IObservableItem, IRegisteredComponent
Visual Basic (Usage) Copy Code
Dim instance As StatusBarPanel
C#
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
[DesignTimeVisibleAttribute()]
[DesignTimeControllerAttribute()]
[ClientControllerAttribute()]
[DefaultPropertyAttribute("Text")]
public class StatusBarPanel : Component, IAttributeExtender, IEventHandler, IGatewayComponent, IObservableItem, IRegisteredComponent
Managed Extensions for C++
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
[DesignTimeVisibleAttribute()]
[DesignTimeControllerAttribute()]
[ClientControllerAttribute()]
[DefaultPropertyAttribute("Text")]
public __gc class StatusBarPanel : public Component, IAttributeExtender, IEventHandler, IGatewayComponent, IObservableItem, IRegisteredComponent
C++/CLI
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
[DesignTimeVisibleAttribute()]
[DesignTimeControllerAttribute()]
[ClientControllerAttribute()]
[DefaultPropertyAttribute("Text")]
public ref class StatusBarPanel : public Component, IAttributeExtender, IEventHandler, IGatewayComponent, IObservableItem, IRegisteredComponent

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.StatusBarPanel

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

StatusBarPanel Members
Gizmox.WebGUI.Forms Namespace


StatusBarPanel Class Members

[image]
Gizmox.WebGUI.Forms
StatusBarPanel Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : StatusBarPanel Class

The following tables list the members exposed by StatusBarPanel.

Public Constructors

 | Name | Description
Public Constructor | StatusBarPanel Constructor | Initializes a new instance of the StatusBarPanel class.
Top

Public Properties

 | Name | Description
Public Property | Alignment | Gets or sets the alignment of text and icons within the status bar panel.
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | AutoSize | Gets or sets a value indicating whether the status bar panel is automatically resized.
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContextMenu | Gets or sets the context menu code. (Inherited from Component)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text of the status bar panel.
Public Property | Width | Gets or sets the width of the status bar panel within the StatusBar control.
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

Public Methods

 | Name | Description
Public Method | BeginInit |
Public Method | Dispose | Overloaded. Disposes the specified component. (Inherited from Component)
Public Method | EndInit |
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Component)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCriticalEvents | (Inherited from Component)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnUnregisterComponents | (Inherited from Component)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Top

See Also

Reference

StatusBarPanel Class
Gizmox.WebGUI.Forms Namespace


StatusBarPanel Constructor

[image]
Gizmox.WebGUI.Forms
StatusBarPanel Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > StatusBarPanel Class : StatusBarPanel Constructor

Initializes a new instance of the StatusBarPanel class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StatusBarPanel()
C#
public StatusBarPanel()
Managed Extensions for C++
public: StatusBarPanel();
C++/CLI
public:
StatusBarPanel();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

StatusBarPanel Class
StatusBarPanel Members


StatusBarPanel Class Methods

[image]
Gizmox.WebGUI.Forms
StatusBarPanel Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : StatusBarPanel Class

For a list of all members of this type, see StatusBarPanel members.

Public Methods

 | Name | Description
Public Method | BeginInit |
Public Method | Dispose | Overloaded. Disposes the specified component. (Inherited from Component)
Public Method | EndInit |
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Component)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCriticalEvents | (Inherited from Component)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnUnregisterComponents | (Inherited from Component)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

See Also

Reference

StatusBarPanel Class
Gizmox.WebGUI.Forms Namespace


BeginInit Method

[image]
Gizmox.WebGUI.Forms
BeginInit Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > StatusBarPanel Class : BeginInit Method

Syntax

Visual Basic (Declaration)
Public Sub BeginInit()
Visual Basic (Usage) Copy Code
Dim instance As StatusBarPanel

instance.BeginInit()
C#
public void BeginInit()
Managed Extensions for C++
public: void BeginInit();
C++/CLI
public:
void BeginInit();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

StatusBarPanel Class
StatusBarPanel Members


EndInit Method

[image]
Gizmox.WebGUI.Forms
EndInit Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > StatusBarPanel Class : EndInit Method

Syntax

Visual Basic (Declaration)
Public Sub EndInit()
Visual Basic (Usage) Copy Code
Dim instance As StatusBarPanel

instance.EndInit()
C#
public void EndInit()
Managed Extensions for C++
public: void EndInit();
C++/CLI
public:
void EndInit();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

StatusBarPanel Class
StatusBarPanel Members


StatusBarPanel Class Properties

[image]
Gizmox.WebGUI.Forms
StatusBarPanel Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : StatusBarPanel Class

For a list of all members of this type, see StatusBarPanel members.

Public Properties

 | Name | Description
Public Property | Alignment | Gets or sets the alignment of text and icons within the status bar panel.
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | AutoSize | Gets or sets a value indicating whether the status bar panel is automatically resized.
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContextMenu | Gets or sets the context menu code. (Inherited from Component)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text of the status bar panel.
Public Property | Width | Gets or sets the width of the status bar panel within the StatusBar control.
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

See Also

Reference

StatusBarPanel Class
Gizmox.WebGUI.Forms Namespace


Alignment Property

[image]
Gizmox.WebGUI.Forms
Alignment Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > StatusBarPanel Class : Alignment Property

Gets or sets the alignment of text and icons within the status bar panel.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<LocalizableAttribute(True)>
<SRCategoryAttribute("Appearance")>
<SRDescriptionAttribute("The alignment of the panel's text.")>
Public Property Alignment As HorizontalAlignment
Visual Basic (Usage) Copy Code
Dim instance As StatusBarPanel
Dim value As HorizontalAlignment

instance.Alignment = value

value = instance.Alignment
C#
[DefaultValueAttribute()]
[LocalizableAttribute(true)]
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("The alignment of the panel's text.")]
public HorizontalAlignment Alignment {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[LocalizableAttribute(true)]
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("The alignment of the panel's text.")]
public: __property HorizontalAlignment get_Alignment();
public: __property void set_Alignment(
   HorizontalAlignment value
);
C++/CLI
[DefaultValueAttribute()]
[LocalizableAttribute(true)]
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("The alignment of the panel's text.")]
public:
property HorizontalAlignment Alignment {
   HorizontalAlignment get();
   void set (HorizontalAlignmentvalue);
}

Exceptions

Exception | Description
InvalidEnumArgumentException | The value assigned to the property is not a member of the HorizontalAlignment enumeration.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

StatusBarPanel Class
StatusBarPanel Members


AutoSize Property

[image]
Gizmox.WebGUI.Forms
AutoSize Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > StatusBarPanel Class : AutoSize Property

Gets or sets a value indicating whether the status bar panel is automatically resized.

Syntax

Visual Basic (Declaration)
<RefreshPropertiesAttribute()>
<SRDescriptionAttribute("Determines how a panel will resize when the parent changes size.")>
<DefaultValueAttribute()>
<SRCategoryAttribute("Appearance")>
Public Property AutoSize As StatusBarPanelAutoSize
Visual Basic (Usage) Copy Code
Dim instance As StatusBarPanel
Dim value As StatusBarPanelAutoSize

instance.AutoSize = value

value = instance.AutoSize
C#
[RefreshPropertiesAttribute()]
[SRDescriptionAttribute("Determines how a panel will resize when the parent changes size.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
public StatusBarPanelAutoSize AutoSize {get; set;}
Managed Extensions for C++
[RefreshPropertiesAttribute()]
[SRDescriptionAttribute("Determines how a panel will resize when the parent changes size.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
public: __property StatusBarPanelAutoSize get_AutoSize();
public: __property void set_AutoSize(
   StatusBarPanelAutoSize value
);
C++/CLI
[RefreshPropertiesAttribute()]
[SRDescriptionAttribute("Determines how a panel will resize when the parent changes size.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
public:
property StatusBarPanelAutoSize AutoSize {
   StatusBarPanelAutoSize get();
   void set (StatusBarPanelAutoSizevalue);
}

Exceptions

Exception | Description
InvalidEnumArgumentException | The value assigned to the property is not a member of the StatusBarPanelAutoSize enumeration.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

StatusBarPanel Class
StatusBarPanel Members


Text Property

[image]
Gizmox.WebGUI.Forms
Text Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > StatusBarPanel Class : Text Property

Gets or sets the text of the status bar panel.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("The text displayed in the panel.")>
<LocalizableAttribute(True)>
<SRCategoryAttribute("Appearance")>
<DefaultValueAttribute()>
Public Property Text As String
Visual Basic (Usage) Copy Code
Dim instance As StatusBarPanel
Dim value As String

instance.Text = value

value = instance.Text
C#
[SRDescriptionAttribute("The text displayed in the panel.")]
[LocalizableAttribute(true)]
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
public string Text {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("The text displayed in the panel.")]
[LocalizableAttribute(true)]
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
public: __property string* get_Text();
public: __property void set_Text(
   string* value
);
C++/CLI
[SRDescriptionAttribute("The text displayed in the panel.")]
[LocalizableAttribute(true)]
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
public:
property String^ Text {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

StatusBarPanel Class
StatusBarPanel Members


Width Property

[image]
Gizmox.WebGUI.Forms
Width Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > StatusBarPanel Class : Width Property

Gets or sets the width of the status bar panel within the StatusBar control.

Syntax

Visual Basic (Declaration)
<LocalizableAttribute(True)>
<DefaultValueAttribute()>
<SRDescriptionAttribute("The width of the panel.")>
<SRCategoryAttribute("Appearance")>
Public Property Width As Integer
Visual Basic (Usage) Copy Code
Dim instance As StatusBarPanel
Dim value As Integer

instance.Width = value

value = instance.Width
C#
[LocalizableAttribute(true)]
[DefaultValueAttribute()]
[SRDescriptionAttribute("The width of the panel.")]
[SRCategoryAttribute("Appearance")]
public int Width {get; set;}
Managed Extensions for C++
[LocalizableAttribute(true)]
[DefaultValueAttribute()]
[SRDescriptionAttribute("The width of the panel.")]
[SRCategoryAttribute("Appearance")]
public: __property int get_Width();
public: __property void set_Width(
   int value
);
C++/CLI
[LocalizableAttribute(true)]
[DefaultValueAttribute()]
[SRDescriptionAttribute("The width of the panel.")]
[SRCategoryAttribute("Appearance")]
public:
property int Width {
   int get();
   void set (intvalue);
}

Exceptions

Exception | Description
ArgumentException | The width specified is less than the value of the MinWidth property.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

StatusBarPanel Class
StatusBarPanel Members


TabControl Class

[image]
Gizmox.WebGUI.Forms
TabControl Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TabControl Class

Manages a related set of tab pages.

Object Model

Syntax

Visual Basic (Declaration)
<SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableLogicalTabControl, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="Logical")>
<DesignTimeControllerAttribute()>
<ClientControllerAttribute()>
<DefaultPropertyAttribute("TabPages")>
<SRDescriptionAttribute("Manages and displays to the user a related collection of tabs that can contain controls and components.")>
<DefaultEventAttribute("SelectedIndexChanged")>
<ToolboxItemCategoryAttribute("Containers")>
<MetadataTagAttribute("TC")>
<ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<ToolboxBitmapAttribute()>
Public Class TabControl
   Inherits Control
   Implements IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Visual Basic (Usage) Copy Code
Dim instance As TabControl
C#
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableLogicalTabControl, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="Logical")]
[DesignTimeControllerAttribute()]
[ClientControllerAttribute()]
[DefaultPropertyAttribute("TabPages")]
[SRDescriptionAttribute("Manages and displays to the user a related collection of tabs that can contain controls and components.")]
[DefaultEventAttribute("SelectedIndexChanged")]
[ToolboxItemCategoryAttribute("Containers")]
[MetadataTagAttribute("TC")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ToolboxBitmapAttribute()]
public class TabControl : Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Managed Extensions for C++
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableLogicalTabControl, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="Logical")]
[DesignTimeControllerAttribute()]
[ClientControllerAttribute()]
[DefaultPropertyAttribute("TabPages")]
[SRDescriptionAttribute("Manages and displays to the user a related collection of tabs that can contain controls and components.")]
[DefaultEventAttribute("SelectedIndexChanged")]
[ToolboxItemCategoryAttribute("Containers")]
[MetadataTagAttribute("TC")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ToolboxBitmapAttribute()]
public __gc class TabControl : public Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
C++/CLI
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableLogicalTabControl, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="Logical")]
[DesignTimeControllerAttribute()]
[ClientControllerAttribute()]
[DefaultPropertyAttribute("TabPages")]
[SRDescriptionAttribute("Manages and displays to the user a related collection of tabs that can contain controls and components.")]
[DefaultEventAttribute("SelectedIndexChanged")]
[ToolboxItemCategoryAttribute("Containers")]
[MetadataTagAttribute("TC")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ToolboxBitmapAttribute()]
public ref class TabControl : public Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.TabControl
Gizmox.WebGUI.Forms.NavigationTabs
Gizmox.WebGUI.Forms.WorkspaceTabs

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

TabControl Members
Gizmox.WebGUI.Forms Namespace


TabControl Class Members

[image]
Gizmox.WebGUI.Forms
TabControl Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : TabControl Class

The following tables list the members exposed by TabControl.

Public Constructors

 | Name | Description
Public Constructor | TabControl Constructor | Initializes a new instance of the TabControl class.
Top

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | Appearance | Gets or sets the visual appearance of the control's tabs.
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientBehavior | Gets or sets the client drawing mode behavior
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | ImageList | Gets or sets the image list.
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Multiline | Gets or sets a value indicating whether more than one row of tabs can be displayed.
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | SelectedIndex | Gets or sets the index of the currently selected tab page.
Public Property | SelectedItem | Gets the selected item.
Public Property | ShowCloseButton | Gets or Sets value indication if the close button (when Appearance==TabAppearance.Workspace) should be shown
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabPages | Gets the collection of tab pages in this tab control.
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Control)
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | Overridden. Gets the update handler.
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | Overridden. This member overrides Control.CreateControlsInstance.
Protected Method | CreateTabPageCollection | Creates the tab page collection.
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Overridden. Fires an event.
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Overridden. Gets the critical events.
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from Control)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnSelectedIndexChanged | Raises the SelectedIndexChanged event.
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Control)
Protected Method | RenderAttributes | Overridden. Renders the controls meta attributes
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Overridden. Renders the controls.
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | Overridden. An abstract param attribute rendering
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | CloseClick | Occurs when the user clicks the tab control close button
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | SelectedIndexChanged | Occurs when the SelectedIndex property is changed.
Public Event | SelectedIndexChanging | Occurs when the SelectedIndex property is about to change.
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

TabControl Class
Gizmox.WebGUI.Forms Namespace


TabControl Constructor

[image]
Gizmox.WebGUI.Forms
TabControl Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TabControl Class : TabControl Constructor

Initializes a new instance of the TabControl class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As TabControl()
C#
public TabControl()
Managed Extensions for C++
public: TabControl();
C++/CLI
public:
TabControl();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TabControl Class
TabControl Members


TabControl Class Methods

[image]
Gizmox.WebGUI.Forms
TabControl Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TabControl Class

For a list of all members of this type, see TabControl members.

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | Overridden. This member overrides Control.CreateControlsInstance.
Protected Method | CreateTabPageCollection | Creates the tab page collection.
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Overridden. Fires an event.
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Overridden. Gets the critical events.
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from Control)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnSelectedIndexChanged | Raises the SelectedIndexChanged event.
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Control)
Protected Method | RenderAttributes | Overridden. Renders the controls meta attributes
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Overridden. Renders the controls.
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | Overridden. An abstract param attribute rendering
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

See Also

Reference

TabControl Class
Gizmox.WebGUI.Forms Namespace


CreateControlsInstance Method

[image]
Gizmox.WebGUI.Forms
CreateControlsInstance Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TabControl Class : CreateControlsInstance Method

This member overrides Control.CreateControlsInstance.

Syntax

Visual Basic (Declaration)
Protected Overrides Function CreateControlsInstance() As Control.ControlCollection
Visual Basic (Usage) Copy Code
Dim instance As TabControl
Dim value As Control.ControlCollection

value = instance.CreateControlsInstance()
C#
protected override Control.ControlCollection CreateControlsInstance()
Managed Extensions for C++
protected: Control.ControlCollection* CreateControlsInstance(); override
C++/CLI
protected:
Control::ControlCollection^ CreateControlsInstance(); override

Return Value

A new instance of Control.ControlCollection assigned to the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TabControl Class
TabControl Members


CreateTabPageCollection Method

[image]
Gizmox.WebGUI.Forms
CreateTabPageCollection Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TabControl Class : CreateTabPageCollection Method

Creates the tab page collection.

Syntax

Visual Basic (Declaration)
Protected Overridable Function CreateTabPageCollection() As TabPageCollection
Visual Basic (Usage) Copy Code
Dim instance As TabControl
Dim value As TabPageCollection

value = instance.CreateTabPageCollection()
C#
protected virtual TabPageCollection CreateTabPageCollection()
Managed Extensions for C++
protected: virtual TabPageCollection* CreateTabPageCollection();
C++/CLI
protected:
virtual TabPageCollection^ CreateTabPageCollection();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TabControl Class
TabControl Members


FireEvent Method

[image]
Gizmox.WebGUI.Forms
FireEvent Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TabControl Class : FireEvent Method

objEvent
event.
Fires an event.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub FireEvent( _
   ByVal objEvent As IEvent _
)
Visual Basic (Usage) Copy Code
Dim instance As TabControl
Dim objEvent As IEvent

instance.FireEvent(objEvent)
C#
protected override void FireEvent(
   IEvent objEvent
)
Managed Extensions for C++
protected: void FireEvent(
   IEvent* objEvent
) override
C++/CLI
protected:
void FireEvent(
   IEvent^ objEvent
) override

Parameters

objEvent
event.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TabControl Class
TabControl Members


GetCriticalEvents Method

[image]
Gizmox.WebGUI.Forms
GetCriticalEvents Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TabControl Class : GetCriticalEvents Method

Gets the critical events.

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetCriticalEvents() As EventTypes
Visual Basic (Usage) Copy Code
Dim instance As TabControl
Dim value As EventTypes

value = instance.GetCriticalEvents()
C#
protected override EventTypes GetCriticalEvents()
Managed Extensions for C++
protected: EventTypes GetCriticalEvents(); override
C++/CLI
protected:
EventTypes GetCriticalEvents(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TabControl Class
TabControl Members


OnSelectedIndexChanged Method

[image]
Gizmox.WebGUI.Forms
OnSelectedIndexChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TabControl Class : OnSelectedIndexChanged Method

e
An EventArgs that contains the event data.
Raises the SelectedIndexChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnSelectedIndexChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As TabControl
Dim e As EventArgs

instance.OnSelectedIndexChanged(e)
C#
protected virtual void OnSelectedIndexChanged(
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnSelectedIndexChanged(
   EventArgs* e
)
C++/CLI
protected:
virtual void OnSelectedIndexChanged(
   EventArgs^ e
)

Parameters

e
An EventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TabControl Class
TabControl Members


RenderAttributes Method

[image]
Gizmox.WebGUI.Forms
RenderAttributes Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TabControl Class : RenderAttributes Method

objContext
objWriter
Renders the controls meta attributes

Syntax

Visual Basic (Declaration)
Protected Overrides Sub RenderAttributes( _
   ByVal objContext As IContext, _
   ByVal objWriter As IAttributeWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As TabControl
Dim objContext As IContext
Dim objWriter As IAttributeWriter

instance.RenderAttributes(objContext, objWriter)
C#
protected override void RenderAttributes(
   IContext objContext,
   IAttributeWriter objWriter
)
Managed Extensions for C++
protected: void RenderAttributes(
   IContext* objContext,
   IAttributeWriter* objWriter
) override
C++/CLI
protected:
void RenderAttributes(
   IContext^ objContext,
   IAttributeWriter^ objWriter
) override

Parameters

objContext
objWriter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TabControl Class
TabControl Members


RenderControls Method

[image]
Gizmox.WebGUI.Forms
RenderControls Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TabControl Class : RenderControls Method

Renders the controls.

Overload List

Overload | Description
RenderControls(IContext,IResponseWriter,Int64) | Renders the controls.
RenderControls(IContext,IResponseWriter,Int64,Boolean) | Renders the controls sub tree (Inherited from Control)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TabControl Class
TabControl Members


RenderControls(IContext,IResponseWriter,Int64) Method

[image]
Gizmox.WebGUI.Forms
RenderControls(IContext,IResponseWriter,Int64) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TabControl Class > RenderControls Method : RenderControls(IContext,IResponseWriter,Int64) Method

objContext
Request context.
objWriter
writer.
lngRequestID
Request ID.
Renders the controls.

Syntax

Visual Basic (Declaration)
Protected Overloads Overrides Sub RenderControls( _
   ByVal objContext As IContext, _
   ByVal objWriter As IResponseWriter, _
   ByVal lngRequestID As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As TabControl
Dim objContext As IContext
Dim objWriter As IResponseWriter
Dim lngRequestID As Long

instance.RenderControls(objContext, objWriter, lngRequestID)
C#
protected override void RenderControls(
   IContext objContext,
   IResponseWriter objWriter,
   long lngRequestID
)
Managed Extensions for C++
protected: void RenderControls(
   IContext* objContext,
   IResponseWriter* objWriter,
   long lngRequestID
) override
C++/CLI
protected:
void RenderControls(
   IContext^ objContext,
   IResponseWriter^ objWriter,
   long long lngRequestID
) override

Parameters

objContext
Request context.
objWriter
writer.
lngRequestID
Request ID.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TabControl Class
TabControl Members
Overload List


RenderUpdatedAttributes Method

[image]
Gizmox.WebGUI.Forms
RenderUpdatedAttributes Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TabControl Class : RenderUpdatedAttributes Method

objContext
Request context.
objWriter
lngRequestID
An abstract param attribute rendering

Syntax

Visual Basic (Declaration)
Protected Overrides Sub RenderUpdatedAttributes( _
   ByVal objContext As IContext, _
   ByVal objWriter As IAttributeWriter, _
   ByVal lngRequestID As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As TabControl
Dim objContext As IContext
Dim objWriter As IAttributeWriter
Dim lngRequestID As Long

instance.RenderUpdatedAttributes(objContext, objWriter, lngRequestID)
C#
protected override void RenderUpdatedAttributes(
   IContext objContext,
   IAttributeWriter objWriter,
   long lngRequestID
)
Managed Extensions for C++
protected: void RenderUpdatedAttributes(
   IContext* objContext,
   IAttributeWriter* objWriter,
   long lngRequestID
) override
C++/CLI
protected:
void RenderUpdatedAttributes(
   IContext^ objContext,
   IAttributeWriter^ objWriter,
   long long lngRequestID
) override

Parameters

objContext
Request context.
objWriter
lngRequestID

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TabControl Class
TabControl Members


TabControl Class Properties

[image]
Gizmox.WebGUI.Forms
TabControl Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TabControl Class

For a list of all members of this type, see TabControl members.

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | Appearance | Gets or sets the visual appearance of the control's tabs.
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientBehavior | Gets or sets the client drawing mode behavior
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | ImageList | Gets or sets the image list.
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Multiline | Gets or sets a value indicating whether more than one row of tabs can be displayed.
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | SelectedIndex | Gets or sets the index of the currently selected tab page.
Public Property | SelectedItem | Gets the selected item.
Public Property | ShowCloseButton | Gets or Sets value indication if the close button (when Appearance==TabAppearance.Workspace) should be shown
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabPages | Gets the collection of tab pages in this tab control.
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Control)
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | Overridden. Gets the update handler.
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

See Also

Reference

TabControl Class
Gizmox.WebGUI.Forms Namespace


Appearance Property

[image]
Gizmox.WebGUI.Forms
Appearance Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TabControl Class : Appearance Property

Gets or sets the visual appearance of the control's tabs.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Behavior")>
<DefaultValueAttribute()>
<LocalizableAttribute(True)>
<SRDescriptionAttribute("Indicates whether the tabs are painted as buttons or regular tabs.")>
Public Property Appearance As TabAppearance
Visual Basic (Usage) Copy Code
Dim instance As TabControl
Dim value As TabAppearance

instance.Appearance = value

value = instance.Appearance
C#
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[LocalizableAttribute(true)]
[SRDescriptionAttribute("Indicates whether the tabs are painted as buttons or regular tabs.")]
public TabAppearance Appearance {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[LocalizableAttribute(true)]
[SRDescriptionAttribute("Indicates whether the tabs are painted as buttons or regular tabs.")]
public: __property TabAppearance get_Appearance();
public: __property void set_Appearance(
   TabAppearance value
);
C++/CLI
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[LocalizableAttribute(true)]
[SRDescriptionAttribute("Indicates whether the tabs are painted as buttons or regular tabs.")]
public:
property TabAppearance Appearance {
   TabAppearance get();
   void set (TabAppearancevalue);
}

Exceptions

Exception | Description
InvalidEnumArgumentException | The property value is not a valid TabAppearance value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TabControl Class
TabControl Members


ClientBehavior Property

[image]
Gizmox.WebGUI.Forms
ClientBehavior Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TabControl Class : ClientBehavior Property

Gets or sets the client drawing mode behavior

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property ClientBehavior As TabControlClientBehavior
Visual Basic (Usage) Copy Code
Dim instance As TabControl
Dim value As TabControlClientBehavior

instance.ClientBehavior = value

value = instance.ClientBehavior
C#
[DefaultValueAttribute()]
public TabControlClientBehavior ClientBehavior {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property TabControlClientBehavior get_ClientBehavior();
public: __property void set_ClientBehavior(
   TabControlClientBehavior value
);
C++/CLI
[DefaultValueAttribute()]
public:
property TabControlClientBehavior ClientBehavior {
   TabControlClientBehavior get();
   void set (TabControlClientBehaviorvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TabControl Class
TabControl Members


ClientUpdateHandler Property

[image]
Gizmox.WebGUI.Forms
ClientUpdateHandler Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TabControl Class : ClientUpdateHandler Property

Gets the update handler.

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property ClientUpdateHandler As String
Visual Basic (Usage) Copy Code
Dim instance As TabControl
Dim value As String

value = instance.ClientUpdateHandler
C#
protected override string ClientUpdateHandler {get;}
Managed Extensions for C++
protected: __property string* get_ClientUpdateHandler() override;
C++/CLI
protected:
property String^ ClientUpdateHandler {
   String^ get() override;
}

Return Value

The update handler.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TabControl Class
TabControl Members


ImageList Property

[image]
Gizmox.WebGUI.Forms
ImageList Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TabControl Class : ImageList Property

Gets or sets the image list.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<SRCategoryAttribute("Appearance")>
<RefreshPropertiesAttribute()>
<SRDescriptionAttribute("The ImageList object from which this tab takes its images.")>
Public Property ImageList As ImageList
Visual Basic (Usage) Copy Code
Dim instance As TabControl
Dim value As ImageList

instance.ImageList = value

value = instance.ImageList
C#
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
[RefreshPropertiesAttribute()]
[SRDescriptionAttribute("The ImageList object from which this tab takes its images.")]
public ImageList ImageList {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
[RefreshPropertiesAttribute()]
[SRDescriptionAttribute("The ImageList object from which this tab takes its images.")]
public: __property ImageList* get_ImageList();
public: __property void set_ImageList(
   ImageList* value
);
C++/CLI
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
[RefreshPropertiesAttribute()]
[SRDescriptionAttribute("The ImageList object from which this tab takes its images.")]
public:
property ImageList^ ImageList {
   ImageList^ get();
   void set (ImageList^value);
}

Return Value

The image list.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TabControl Class
TabControl Members


Multiline Property

[image]
Gizmox.WebGUI.Forms
Multiline Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TabControl Class : Multiline Property

Gets or sets a value indicating whether more than one row of tabs can be displayed.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Indicates if more than one row of tabs is allowed.")>
<SRCategoryAttribute("Behavior")>
<DefaultValueAttribute()>
Public Property Multiline As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TabControl
Dim value As Boolean

instance.Multiline = value

value = instance.Multiline
C#
[SRDescriptionAttribute("Indicates if more than one row of tabs is allowed.")]
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
public bool Multiline {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Indicates if more than one row of tabs is allowed.")]
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
public: __property bool get_Multiline();
public: __property void set_Multiline(
   bool value
);
C++/CLI
[SRDescriptionAttribute("Indicates if more than one row of tabs is allowed.")]
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
public:
property bool Multiline {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TabControl Class
TabControl Members


SelectedIndex Property

[image]
Gizmox.WebGUI.Forms
SelectedIndex Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TabControl Class : SelectedIndex Property

Gets or sets the index of the currently selected tab page.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("The index of the currently selected item.")>
<SRCategoryAttribute("Behavior")>
<DefaultValueAttribute()>
<BrowsableAttribute(False)>
Public Property SelectedIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As TabControl
Dim value As Integer

instance.SelectedIndex = value

value = instance.SelectedIndex
C#
[SRDescriptionAttribute("The index of the currently selected item.")]
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
public int SelectedIndex {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("The index of the currently selected item.")]
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
public: __property int get_SelectedIndex();
public: __property void set_SelectedIndex(
   int value
);
C++/CLI
[SRDescriptionAttribute("The index of the currently selected item.")]
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
public:
property int SelectedIndex {
   int get();
   void set (intvalue);
}

Exceptions

Exception | Description
ArgumentOutOfRangeException | The value is less than -1.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TabControl Class
TabControl Members


SelectedItem Property

[image]
Gizmox.WebGUI.Forms
SelectedItem Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TabControl Class : SelectedItem Property

Gets the selected item.

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
Public Property SelectedItem As TabPage
Visual Basic (Usage) Copy Code
Dim instance As TabControl
Dim value As TabPage

instance.SelectedItem = value

value = instance.SelectedItem
C#
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public TabPage SelectedItem {get; set;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public: __property TabPage* get_SelectedItem();
public: __property void set_SelectedItem(
   TabPage* value
);
C++/CLI
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public:
property TabPage^ SelectedItem {
   TabPage^ get();
   void set (TabPage^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TabControl Class
TabControl Members


ShowCloseButton Property

[image]
Gizmox.WebGUI.Forms
ShowCloseButton Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TabControl Class : ShowCloseButton Property

Gets or Sets value indication if the close button (when Appearance==TabAppearance.Workspace) should be shown

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property ShowCloseButton As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TabControl
Dim value As Boolean

instance.ShowCloseButton = value

value = instance.ShowCloseButton
C#
[DefaultValueAttribute()]
public bool ShowCloseButton {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property bool get_ShowCloseButton();
public: __property void set_ShowCloseButton(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
public:
property bool ShowCloseButton {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TabControl Class
TabControl Members


TabPages Property

[image]
Gizmox.WebGUI.Forms
TabPages Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TabControl Class : TabPages Property

Gets the collection of tab pages in this tab control.

Syntax

Visual Basic (Declaration)
<MergablePropertyAttribute(False)>
<SRDescriptionAttribute("The TabPages in the TabControl.")>
<DesignerSerializationVisibilityAttribute()>
<SRCategoryAttribute("Behavior")>
Public ReadOnly Property TabPages As TabPageCollection
Visual Basic (Usage) Copy Code
Dim instance As TabControl
Dim value As TabPageCollection

value = instance.TabPages
C#
[MergablePropertyAttribute(false)]
[SRDescriptionAttribute("The TabPages in the TabControl.")]
[DesignerSerializationVisibilityAttribute()]
[SRCategoryAttribute("Behavior")]
public TabPageCollection TabPages {get;}
Managed Extensions for C++
[MergablePropertyAttribute(false)]
[SRDescriptionAttribute("The TabPages in the TabControl.")]
[DesignerSerializationVisibilityAttribute()]
[SRCategoryAttribute("Behavior")]
public: __property TabPageCollection* get_TabPages();
C++/CLI
[MergablePropertyAttribute(false)]
[SRDescriptionAttribute("The TabPages in the TabControl.")]
[DesignerSerializationVisibilityAttribute()]
[SRCategoryAttribute("Behavior")]
public:
property TabPageCollection^ TabPages {
   TabPageCollection^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TabControl Class
TabControl Members


TabControl Class Events

[image]
Gizmox.WebGUI.Forms
TabControl Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TabControl Class

For a list of all members of this type, see TabControl members.

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | CloseClick | Occurs when the user clicks the tab control close button
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | SelectedIndexChanged | Occurs when the SelectedIndex property is changed.
Public Event | SelectedIndexChanging | Occurs when the SelectedIndex property is about to change.
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

TabControl Class
Gizmox.WebGUI.Forms Namespace


CloseClick Event

[image]
Gizmox.WebGUI.Forms
CloseClick Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TabControl Class : CloseClick Event

Occurs when the user clicks the tab control close button

Syntax

Visual Basic (Declaration)
Public Event CloseClick() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As TabControl
Dim handler As EventHandler

AddHandler instance.CloseClick, handler
C#
public event EventHandler CloseClick()
Managed Extensions for C++
public: __event EventHandler* CloseClick
C++/CLI
public:
event EventHandler^ CloseClick

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TabControl Class
TabControl Members


SelectedIndexChanged Event

[image]
Gizmox.WebGUI.Forms
SelectedIndexChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TabControl Class : SelectedIndexChanged Event

Occurs when the SelectedIndex property is changed.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Behavior")>
<SRDescriptionAttribute("Occurs when the value of the SelectedIndex property changes.")>
Public Event SelectedIndexChanged() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As TabControl
Dim handler As EventHandler

AddHandler instance.SelectedIndexChanged, handler
C#
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when the value of the SelectedIndex property changes.")]
public event EventHandler SelectedIndexChanged()
Managed Extensions for C++
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when the value of the SelectedIndex property changes.")]
public: __event EventHandler* SelectedIndexChanged
C++/CLI
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when the value of the SelectedIndex property changes.")]
public:
event EventHandler^ SelectedIndexChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TabControl Class
TabControl Members


SelectedIndexChanging Event

[image]
Gizmox.WebGUI.Forms
SelectedIndexChanging Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TabControl Class : SelectedIndexChanging Event

Occurs when the SelectedIndex property is about to change.

Syntax

Visual Basic (Declaration)
Public Event SelectedIndexChanging() As TabControlCancelEventHandler
Visual Basic (Usage) Copy Code
Dim instance As TabControl
Dim handler As TabControlCancelEventHandler

AddHandler instance.SelectedIndexChanging, handler
C#
public event TabControlCancelEventHandler SelectedIndexChanging()
Managed Extensions for C++
public: __event TabControlCancelEventHandler* SelectedIndexChanging
C++/CLI
public:
event TabControlCancelEventHandler^ SelectedIndexChanging

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TabControl Class
TabControl Members


TabControlCancelEventArgs Class

[image]
Gizmox.WebGUI.Forms
TabControlCancelEventArgs Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TabControlCancelEventArgs Class

Provides data for the Selecting and Deselecting events of a TabControl control.

Object Model

Syntax

Visual Basic (Declaration)
Public Class TabControlCancelEventArgs
   Inherits CancelEventArgs
Visual Basic (Usage) Copy Code
Dim instance As TabControlCancelEventArgs
C#
public class TabControlCancelEventArgs : CancelEventArgs
Managed Extensions for C++
public __gc class TabControlCancelEventArgs : public CancelEventArgs
C++/CLI
public ref class TabControlCancelEventArgs : public CancelEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
System.ComponentModel.CancelEventArgs
Gizmox.WebGUI.Forms.TabControlCancelEventArgs

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

TabControlCancelEventArgs Members
Gizmox.WebGUI.Forms Namespace


TabControlCancelEventArgs Class Members

[image]
Gizmox.WebGUI.Forms
TabControlCancelEventArgs Class Members
See Also Properties Send Feedback
Gizmox.WebGUI.Forms Namespace : TabControlCancelEventArgs Class

The following tables list the members exposed by TabControlCancelEventArgs.

Public Constructors

 | Name | Description
Public Constructor | TabControlCancelEventArgs Constructor | Initializes a new instance of the TabControlCancelEventArgs class.
Top

Public Properties

 | Name | Description
Public Property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from System.ComponentModel.CancelEventArgs)
Public Property | TabPage | Gets the TabPage the event is occurring for.
Top

See Also

Reference

TabControlCancelEventArgs Class
Gizmox.WebGUI.Forms Namespace


TabControlCancelEventArgs Constructor

[image]
Gizmox.WebGUI.Forms
TabControlCancelEventArgs Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TabControlCancelEventArgs Class : TabControlCancelEventArgs Constructor

tabPage
The TabPage the event is occurring for.
cancel
true to cancel the tab change by default; otherwise, false.
Initializes a new instance of the TabControlCancelEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal tabPage As TabPage, _
   ByVal cancel As Boolean _
)
Visual Basic (Usage) Copy Code
Dim tabPage As TabPage
Dim cancel As Boolean

Dim instance As TabControlCancelEventArgs(tabPage, cancel)
C#
public TabControlCancelEventArgs(
   TabPage tabPage,
   bool cancel
)
Managed Extensions for C++
public: TabControlCancelEventArgs(
   TabPage* tabPage,
   bool cancel
)
C++/CLI
public:
TabControlCancelEventArgs(
   TabPage^ tabPage,
   bool cancel
)

Parameters

tabPage
The TabPage the event is occurring for.
cancel
true to cancel the tab change by default; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TabControlCancelEventArgs Class
TabControlCancelEventArgs Members


TabControlCancelEventArgs Class Properties

[image]
Gizmox.WebGUI.Forms
TabControlCancelEventArgs Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TabControlCancelEventArgs Class

For a list of all members of this type, see TabControlCancelEventArgs members.

Public Properties

 | Name | Description
Public Property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from System.ComponentModel.CancelEventArgs)
Public Property | TabPage | Gets the TabPage the event is occurring for.
Top

See Also

Reference

TabControlCancelEventArgs Class
Gizmox.WebGUI.Forms Namespace


TabPage Property

[image]
Gizmox.WebGUI.Forms
TabPage Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TabControlCancelEventArgs Class : TabPage Property

Gets the TabPage the event is occurring for.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TabPage As TabPage
Visual Basic (Usage) Copy Code
Dim instance As TabControlCancelEventArgs
Dim value As TabPage

value = instance.TabPage
C#
public TabPage TabPage {get;}
Managed Extensions for C++
public: __property TabPage* get_TabPage();
C++/CLI
public:
property TabPage^ TabPage {
   TabPage^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TabControlCancelEventArgs Class
TabControlCancelEventArgs Members


TableLayoutCellPaintEventArgs Class

[image]
Gizmox.WebGUI.Forms
TableLayoutCellPaintEventArgs Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TableLayoutCellPaintEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class TableLayoutCellPaintEventArgs
   Inherits PaintEventArgs
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutCellPaintEventArgs
C#
public class TableLayoutCellPaintEventArgs : PaintEventArgs
Managed Extensions for C++
public __gc class TableLayoutCellPaintEventArgs : public PaintEventArgs
C++/CLI
public ref class TableLayoutCellPaintEventArgs : public PaintEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gizmox.WebGUI.Forms.PaintEventArgs
Gizmox.WebGUI.Forms.TableLayoutCellPaintEventArgs

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

TableLayoutCellPaintEventArgs Members
Gizmox.WebGUI.Forms Namespace


TableLayoutCellPaintEventArgs Class Members

[image]
Gizmox.WebGUI.Forms
TableLayoutCellPaintEventArgs Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : TableLayoutCellPaintEventArgs Class

The following tables list the members exposed by TableLayoutCellPaintEventArgs.

Public Constructors

 | Name | Description
Public Constructor | TableLayoutCellPaintEventArgs Constructor |
Top

Public Properties

 | Name | Description
Public Property | CellBounds |
Public Property | ClipRectangle | (Inherited from PaintEventArgs)
Public Property | Column |
Public Property | Graphics | (Inherited from PaintEventArgs)
Public Property | Row |
Top

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded. (Inherited from PaintEventArgs)
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | (Inherited from PaintEventArgs)
Top

See Also

Reference

TableLayoutCellPaintEventArgs Class
Gizmox.WebGUI.Forms Namespace


TableLayoutCellPaintEventArgs Constructor

[image]
Gizmox.WebGUI.Forms
TableLayoutCellPaintEventArgs Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutCellPaintEventArgs Class : TableLayoutCellPaintEventArgs Constructor

g
clipRectangle
cellBounds
column
row

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal g As Graphics, _
   ByVal clipRectangle As Rectangle, _
   ByVal cellBounds As Rectangle, _
   ByVal column As Integer, _
   ByVal row As Integer _
)
Visual Basic (Usage) Copy Code
Dim g As Graphics
Dim clipRectangle As Rectangle
Dim cellBounds As Rectangle
Dim column As Integer
Dim row As Integer

Dim instance As TableLayoutCellPaintEventArgs(g, clipRectangle, cellBounds, column, row)
C#
public TableLayoutCellPaintEventArgs(
   Graphics g,
   Rectangle clipRectangle,
   Rectangle cellBounds,
   int column,
   int row
)
Managed Extensions for C++
public: TableLayoutCellPaintEventArgs(
   Graphics* g,
   Rectangle clipRectangle,
   Rectangle cellBounds,
   int column,
   int row
)
C++/CLI
public:
TableLayoutCellPaintEventArgs(
   Graphics^ g,
   Rectangle clipRectangle,
   Rectangle cellBounds,
   int column,
   int row
)

Parameters

g
clipRectangle
cellBounds
column
row

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutCellPaintEventArgs Class
TableLayoutCellPaintEventArgs Members


TableLayoutCellPaintEventArgs Class Properties

[image]
Gizmox.WebGUI.Forms
TableLayoutCellPaintEventArgs Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TableLayoutCellPaintEventArgs Class

For a list of all members of this type, see TableLayoutCellPaintEventArgs members.

Public Properties

 | Name | Description
Public Property | CellBounds |
Public Property | ClipRectangle | (Inherited from PaintEventArgs)
Public Property | Column |
Public Property | Graphics | (Inherited from PaintEventArgs)
Public Property | Row |
Top

See Also

Reference

TableLayoutCellPaintEventArgs Class
Gizmox.WebGUI.Forms Namespace


CellBounds Property

[image]
Gizmox.WebGUI.Forms
CellBounds Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutCellPaintEventArgs Class : CellBounds Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CellBounds As Rectangle
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutCellPaintEventArgs
Dim value As Rectangle

value = instance.CellBounds
C#
public Rectangle CellBounds {get;}
Managed Extensions for C++
public: __property Rectangle get_CellBounds();
C++/CLI
public:
property Rectangle CellBounds {
   Rectangle get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutCellPaintEventArgs Class
TableLayoutCellPaintEventArgs Members


Column Property

[image]
Gizmox.WebGUI.Forms
Column Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutCellPaintEventArgs Class : Column Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Column As Integer
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutCellPaintEventArgs
Dim value As Integer

value = instance.Column
C#
public int Column {get;}
Managed Extensions for C++
public: __property int get_Column();
C++/CLI
public:
property int Column {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutCellPaintEventArgs Class
TableLayoutCellPaintEventArgs Members


Row Property

[image]
Gizmox.WebGUI.Forms
Row Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutCellPaintEventArgs Class : Row Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Row As Integer
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutCellPaintEventArgs
Dim value As Integer

value = instance.Row
C#
public int Row {get;}
Managed Extensions for C++
public: __property int get_Row();
C++/CLI
public:
property int Row {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutCellPaintEventArgs Class
TableLayoutCellPaintEventArgs Members


TableLayoutColumnStyleCollection Class

[image]
Gizmox.WebGUI.Forms
TableLayoutColumnStyleCollection Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TableLayoutColumnStyleCollection Class

Object Model

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
<DesignTimeControllerAttribute()>
<ClientControllerAttribute()>
Public Class TableLayoutColumnStyleCollection
   Inherits TableLayoutStyleCollection
   Implements IObservableList
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutColumnStyleCollection
C#
[DefaultMemberAttribute("Item")]
[DesignTimeControllerAttribute()]
[ClientControllerAttribute()]
public class TableLayoutColumnStyleCollection : TableLayoutStyleCollection, IObservableList
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
[DesignTimeControllerAttribute()]
[ClientControllerAttribute()]
public __gc class TableLayoutColumnStyleCollection : public TableLayoutStyleCollection, IObservableList
C++/CLI
[DefaultMemberAttribute("Item")]
[DesignTimeControllerAttribute()]
[ClientControllerAttribute()]
public ref class TableLayoutColumnStyleCollection : public TableLayoutStyleCollection, IObservableList

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.TableLayoutStyleCollection
Gizmox.WebGUI.Forms.TableLayoutColumnStyleCollection

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

TableLayoutColumnStyleCollection Members
Gizmox.WebGUI.Forms Namespace


TableLayoutColumnStyleCollection Class Members

[image]
Gizmox.WebGUI.Forms
TableLayoutColumnStyleCollection Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : TableLayoutColumnStyleCollection Class

The following tables list the members exposed by TableLayoutColumnStyleCollection.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from TableLayoutStyleCollection)
Public Property | Item |
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Adds a new column style.
Public Method | Clear | (Inherited from TableLayoutStyleCollection)
Public Method | Contains |
Public Method | IndexOf |
Public Method | Insert |
Public Method | Remove |
Public Method | RemoveAt | (Inherited from TableLayoutStyleCollection)
Top

See Also

Reference

TableLayoutColumnStyleCollection Class
Gizmox.WebGUI.Forms Namespace


TableLayoutColumnStyleCollection Class Methods

[image]
Gizmox.WebGUI.Forms
TableLayoutColumnStyleCollection Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TableLayoutColumnStyleCollection Class

For a list of all members of this type, see TableLayoutColumnStyleCollection members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Adds a new column style.
Public Method | Clear | (Inherited from TableLayoutStyleCollection)
Public Method | Contains |
Public Method | IndexOf |
Public Method | Insert |
Public Method | Remove |
Public Method | RemoveAt | (Inherited from TableLayoutStyleCollection)
Top

See Also

Reference

TableLayoutColumnStyleCollection Class
Gizmox.WebGUI.Forms Namespace


Add Method

[image]
Gizmox.WebGUI.Forms
Add Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutColumnStyleCollection Class : Add Method

Adds a new column style.

Overload List

Overload | Description
Add(ColumnStyle) |
Add(Int32) | Adds a new column style.
Add(TableLayoutStyle) | (Inherited from TableLayoutStyleCollection)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutColumnStyleCollection Class
TableLayoutColumnStyleCollection Members


Add(ColumnStyle) Method

[image]
Gizmox.WebGUI.Forms
Add(ColumnStyle) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutColumnStyleCollection Class > Add Method : Add(ColumnStyle) Method

columnStyle

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal columnStyle As ColumnStyle _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutColumnStyleCollection
Dim columnStyle As ColumnStyle
Dim value As Integer

value = instance.Add(columnStyle)
C#
public int Add(
   ColumnStyle columnStyle
)
Managed Extensions for C++
public: int Add(
   ColumnStyle* columnStyle
)
C++/CLI
public:
int Add(
   ColumnStyle^ columnStyle
)

Parameters

columnStyle

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutColumnStyleCollection Class
TableLayoutColumnStyleCollection Members
Overload List


Add(Int32) Method

[image]
Gizmox.WebGUI.Forms
Add(Int32) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutColumnStyleCollection Class > Add Method : Add(Int32) Method

intWidth
Adds a new column style.

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal intWidth As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutColumnStyleCollection
Dim intWidth As Integer
Dim value As Integer

value = instance.Add(intWidth)
C#
public int Add(
   int intWidth
)
Managed Extensions for C++
public: int Add(
   int intWidth
)
C++/CLI
public:
int Add(
   int intWidth
)

Parameters

intWidth

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutColumnStyleCollection Class
TableLayoutColumnStyleCollection Members
Overload List


Contains Method

[image]
Gizmox.WebGUI.Forms
Contains Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutColumnStyleCollection Class : Contains Method

columnStyle

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal columnStyle As ColumnStyle _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutColumnStyleCollection
Dim columnStyle As ColumnStyle
Dim value As Boolean

value = instance.Contains(columnStyle)
C#
public bool Contains(
   ColumnStyle columnStyle
)
Managed Extensions for C++
public: bool Contains(
   ColumnStyle* columnStyle
)
C++/CLI
public:
bool Contains(
   ColumnStyle^ columnStyle
)

Parameters

columnStyle

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutColumnStyleCollection Class
TableLayoutColumnStyleCollection Members


IndexOf Method

[image]
Gizmox.WebGUI.Forms
IndexOf Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutColumnStyleCollection Class : IndexOf Method

columnStyle

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal columnStyle As ColumnStyle _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutColumnStyleCollection
Dim columnStyle As ColumnStyle
Dim value As Integer

value = instance.IndexOf(columnStyle)
C#
public int IndexOf(
   ColumnStyle columnStyle
)
Managed Extensions for C++
public: int IndexOf(
   ColumnStyle* columnStyle
)
C++/CLI
public:
int IndexOf(
   ColumnStyle^ columnStyle
)

Parameters

columnStyle

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutColumnStyleCollection Class
TableLayoutColumnStyleCollection Members


Insert Method

[image]
Gizmox.WebGUI.Forms
Insert Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutColumnStyleCollection Class : Insert Method

index
columnStyle

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal columnStyle As ColumnStyle _
)
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutColumnStyleCollection
Dim index As Integer
Dim columnStyle As ColumnStyle

instance.Insert(index, columnStyle)
C#
public void Insert(
   int index,
   ColumnStyle columnStyle
)
Managed Extensions for C++
public: void Insert(
   int index,
   ColumnStyle* columnStyle
)
C++/CLI
public:
void Insert(
   int index,
   ColumnStyle^ columnStyle
)

Parameters

index
columnStyle

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutColumnStyleCollection Class
TableLayoutColumnStyleCollection Members


Remove Method

[image]
Gizmox.WebGUI.Forms
Remove Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutColumnStyleCollection Class : Remove Method

columnStyle

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal columnStyle As ColumnStyle _
)
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutColumnStyleCollection
Dim columnStyle As ColumnStyle

instance.Remove(columnStyle)
C#
public void Remove(
   ColumnStyle columnStyle
)
Managed Extensions for C++
public: void Remove(
   ColumnStyle* columnStyle
)
C++/CLI
public:
void Remove(
   ColumnStyle^ columnStyle
)

Parameters

columnStyle

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutColumnStyleCollection Class
TableLayoutColumnStyleCollection Members


TableLayoutColumnStyleCollection Class Properties

[image]
Gizmox.WebGUI.Forms
TableLayoutColumnStyleCollection Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TableLayoutColumnStyleCollection Class

For a list of all members of this type, see TableLayoutColumnStyleCollection members.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from TableLayoutStyleCollection)
Public Property | Item |
Top

See Also

Reference

TableLayoutColumnStyleCollection Class
Gizmox.WebGUI.Forms Namespace


Item Property

[image]
Gizmox.WebGUI.Forms
Item Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutColumnStyleCollection Class : Item Property

index

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal index As Integer _
) As ColumnStyle
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutColumnStyleCollection
Dim index As Integer
Dim value As ColumnStyle

instance.Item(index) = value

value = instance.Item(index)
C#
public ColumnStyle this[
   int index
]; {get; set;}
Managed Extensions for C++
public: __property ColumnStyle* get_Item(
   int index
);
public: __property void set_Item(
   int index,
   ColumnStyle* value
);
C++/CLI
public:
property ColumnStyle^ default [int] {
   ColumnStyle^ get(intindex);
   void set (intindex, ColumnStyle^value);
}

Parameters

index

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutColumnStyleCollection Class
TableLayoutColumnStyleCollection Members


TableLayoutControlCollection Class

[image]
Gizmox.WebGUI.Forms
TableLayoutControlCollection Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TableLayoutControlCollection Class

Represents a collection of objects.

Object Model

Syntax

Visual Basic (Declaration)
<DesignTimeControllerAttribute()>
<ClientControllerAttribute()>
<DesignerSerializerAttribute(SerializerTypeName="Gizmox.WebGUI.Common.Design.Serialization.TableLayoutControlCollectionCodeDomSerializer, Gizmox.WebGUI.Common.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=ea5dfe57c8eb7edd", SerializerBaseTypeName="System.ComponentModel.Design.Serialization.CodeDomSerializer, System.Design, Version=1.0.5000.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<ListBindableAttribute(False)>
Public Class TableLayoutControlCollection
   Inherits Control.ControlCollection
   Implements IObservableList
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutControlCollection
C#
[DesignTimeControllerAttribute()]
[ClientControllerAttribute()]
[DesignerSerializerAttribute(SerializerTypeName="Gizmox.WebGUI.Common.Design.Serialization.TableLayoutControlCollectionCodeDomSerializer, Gizmox.WebGUI.Common.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=ea5dfe57c8eb7edd", SerializerBaseTypeName="System.ComponentModel.Design.Serialization.CodeDomSerializer, System.Design, Version=1.0.5000.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ListBindableAttribute(false)]
public class TableLayoutControlCollection : Control.ControlCollection, IObservableList
Managed Extensions for C++
[DesignTimeControllerAttribute()]
[ClientControllerAttribute()]
[DesignerSerializerAttribute(SerializerTypeName="Gizmox.WebGUI.Common.Design.Serialization.TableLayoutControlCollectionCodeDomSerializer, Gizmox.WebGUI.Common.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=ea5dfe57c8eb7edd", SerializerBaseTypeName="System.ComponentModel.Design.Serialization.CodeDomSerializer, System.Design, Version=1.0.5000.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ListBindableAttribute(false)]
public __gc class TableLayoutControlCollection : public Control.ControlCollection, IObservableList
C++/CLI
[DesignTimeControllerAttribute()]
[ClientControllerAttribute()]
[DesignerSerializerAttribute(SerializerTypeName="Gizmox.WebGUI.Common.Design.Serialization.TableLayoutControlCollectionCodeDomSerializer, Gizmox.WebGUI.Common.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=ea5dfe57c8eb7edd", SerializerBaseTypeName="System.ComponentModel.Design.Serialization.CodeDomSerializer, System.Design, Version=1.0.5000.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ListBindableAttribute(false)]
public ref class TableLayoutControlCollection : public Control::ControlCollection, IObservableList

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.Layout.ArrangedElementCollection
Gizmox.WebGUI.Forms.Control.ControlCollection
Gizmox.WebGUI.Forms.TableLayoutControlCollection

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

TableLayoutControlCollection Members
Gizmox.WebGUI.Forms Namespace


TableLayoutControlCollection Class Members

[image]
Gizmox.WebGUI.Forms
TableLayoutControlCollection Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : TableLayoutControlCollection Class

The following tables list the members exposed by TableLayoutControlCollection.

Public Constructors

 | Name | Description
Public Constructor | TableLayoutControlCollection Constructor |
Top

Public Properties

 | Name | Description
Public Property | Container |
Public Property | Count | (Inherited from Control.ControlCollection)
Public Property | IsFixedSize | (Inherited from Control.ControlCollection)
Public Property | IsReadOnly | (Inherited from Control.ControlCollection)
Public Property | Item | Overloaded. Indicates a Control with the specified key in the collection. (Inherited from Control.ControlCollection)
Public Property | Owner | Gets the control that owns this Control.ControlCollection. (Inherited from Control.ControlCollection)
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Adds the specified control to the control collection.
Public Method | AddRange | Adds an array of control objects to the collection. (Inherited from Control.ControlCollection)
Public Method | Clear | Removes all controls from the collection. (Inherited from Control.ControlCollection)
Public Method | Contains | Determines whether the specified control is a member of the collection. (Inherited from Control.ControlCollection)
Public Method | ContainsKey | Determines whether the Control.ControlCollection contains an item with the specified key. (Inherited from Control.ControlCollection)
Public Method | CopyTo | Copies the entire contents of this collection to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Gizmox.WebGUI.Forms.Layout.ArrangedElementCollection)
Public Method | Equals | Determines whether two ArrangedElementCollection instances are equal. (Inherited from Gizmox.WebGUI.Forms.Layout.ArrangedElementCollection)
Public Method | Find | Searches for controls by their Control.Name property and builds an array of all the controls that match. (Inherited from Control.ControlCollection)
Public Method | GetChildIndex | Overloaded. Retrieves the index of the specified child control within the control collection. (Inherited from Control.ControlCollection)
Public Method | GetEnumerator | Retrieves a reference to an enumerator object that is used to iterate over a Control.ControlCollection. (Inherited from Control.ControlCollection)
Public Method | GetHashCode | Returns the hash code for this instance. (Inherited from Gizmox.WebGUI.Forms.Layout.ArrangedElementCollection)
Public Method | IndexOf | Retrieves the index of the specified control in the control collection. (Inherited from Control.ControlCollection)
Public Method | IndexOfKey | Retrieves the index of the first occurrence of the specified item within the collection. (Inherited from Control.ControlCollection)
Public Method | Insert | (Inherited from Control.ControlCollection)
Public Method | Remove | Removes the specified control from the control collection. (Inherited from Control.ControlCollection)
Public Method | RemoveAt | Removes a control from the control collection at the specified indexed location. (Inherited from Control.ControlCollection)
Public Method | RemoveByKey | Removes the child control with the specified key. (Inherited from Control.ControlCollection)
Public Method | SetChildIndex | Sets the index of the specified child control in the collection to the specified index value. (Inherited from Control.ControlCollection)
Top

See Also

Reference

TableLayoutControlCollection Class
Gizmox.WebGUI.Forms Namespace


TableLayoutControlCollection Constructor

[image]
Gizmox.WebGUI.Forms
TableLayoutControlCollection Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutControlCollection Class : TableLayoutControlCollection Constructor

container

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal container As TableLayoutPanel _
)
Visual Basic (Usage) Copy Code
Dim container As TableLayoutPanel

Dim instance As TableLayoutControlCollection(container)
C#
public TableLayoutControlCollection(
   TableLayoutPanel container
)
Managed Extensions for C++
public: TableLayoutControlCollection(
   TableLayoutPanel* container
)
C++/CLI
public:
TableLayoutControlCollection(
   TableLayoutPanel^ container
)

Parameters

container

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutControlCollection Class
TableLayoutControlCollection Members


TableLayoutControlCollection Class Methods

[image]
Gizmox.WebGUI.Forms
TableLayoutControlCollection Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TableLayoutControlCollection Class

For a list of all members of this type, see TableLayoutControlCollection members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Adds the specified control to the control collection.
Public Method | AddRange | Adds an array of control objects to the collection. (Inherited from Control.ControlCollection)
Public Method | Clear | Removes all controls from the collection. (Inherited from Control.ControlCollection)
Public Method | Contains | Determines whether the specified control is a member of the collection. (Inherited from Control.ControlCollection)
Public Method | ContainsKey | Determines whether the Control.ControlCollection contains an item with the specified key. (Inherited from Control.ControlCollection)
Public Method | CopyTo | Copies the entire contents of this collection to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Gizmox.WebGUI.Forms.Layout.ArrangedElementCollection)
Public Method | Equals | Determines whether two ArrangedElementCollection instances are equal. (Inherited from Gizmox.WebGUI.Forms.Layout.ArrangedElementCollection)
Public Method | Find | Searches for controls by their Control.Name property and builds an array of all the controls that match. (Inherited from Control.ControlCollection)
Public Method | GetChildIndex | Overloaded. Retrieves the index of the specified child control within the control collection. (Inherited from Control.ControlCollection)
Public Method | GetEnumerator | Retrieves a reference to an enumerator object that is used to iterate over a Control.ControlCollection. (Inherited from Control.ControlCollection)
Public Method | GetHashCode | Returns the hash code for this instance. (Inherited from Gizmox.WebGUI.Forms.Layout.ArrangedElementCollection)
Public Method | IndexOf | Retrieves the index of the specified control in the control collection. (Inherited from Control.ControlCollection)
Public Method | IndexOfKey | Retrieves the index of the first occurrence of the specified item within the collection. (Inherited from Control.ControlCollection)
Public Method | Insert | (Inherited from Control.ControlCollection)
Public Method | Remove | Removes the specified control from the control collection. (Inherited from Control.ControlCollection)
Public Method | RemoveAt | Removes a control from the control collection at the specified indexed location. (Inherited from Control.ControlCollection)
Public Method | RemoveByKey | Removes the child control with the specified key. (Inherited from Control.ControlCollection)
Public Method | SetChildIndex | Sets the index of the specified child control in the collection to the specified index value. (Inherited from Control.ControlCollection)
Top

See Also

Reference

TableLayoutControlCollection Class
Gizmox.WebGUI.Forms Namespace


Add Method

[image]
Gizmox.WebGUI.Forms
Add Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutControlCollection Class : Add Method

Adds the specified control to the control collection.

Overload List

Overload | Description
Add(Control,Int32,Int32) |
Add(Control) |
Add(Control,Boolean) | Adds the specified control to the control collection. (Inherited from Control.ControlCollection)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutControlCollection Class
TableLayoutControlCollection Members


Add(Control,Int32,Int32) Method

[image]
Gizmox.WebGUI.Forms
Add(Control,Int32,Int32) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutControlCollection Class > Add Method : Add(Control,Int32,Int32) Method

control
column
row

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub Add( _
   ByVal control As Control, _
   ByVal column As Integer, _
   ByVal row As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutControlCollection
Dim control As Control
Dim column As Integer
Dim row As Integer

instance.Add(control, column, row)
C#
public virtual void Add(
   Control control,
   int column,
   int row
)
Managed Extensions for C++
public: virtual void Add(
   Control* control,
   int column,
   int row
)
C++/CLI
public:
virtual void Add(
   Control^ control,
   int column,
   int row
)

Parameters

control
column
row

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutControlCollection Class
TableLayoutControlCollection Members
Overload List


Add(Control) Method

[image]
Gizmox.WebGUI.Forms
Add(Control) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutControlCollection Class > Add Method : Add(Control) Method

value

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Sub Add( _
   ByVal value As Control _
)
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutControlCollection
Dim value As Control

instance.Add(value)
C#
public override void Add(
   Control value
)
Managed Extensions for C++
public: void Add(
   Control* value
) override
C++/CLI
public:
void Add(
   Control^ value
) override

Parameters

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutControlCollection Class
TableLayoutControlCollection Members
Overload List


TableLayoutControlCollection Class Properties

[image]
Gizmox.WebGUI.Forms
TableLayoutControlCollection Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TableLayoutControlCollection Class

For a list of all members of this type, see TableLayoutControlCollection members.

Public Properties

 | Name | Description
Public Property | Container |
Public Property | Count | (Inherited from Control.ControlCollection)
Public Property | IsFixedSize | (Inherited from Control.ControlCollection)
Public Property | IsReadOnly | (Inherited from Control.ControlCollection)
Public Property | Item | Overloaded. Indicates a Control with the specified key in the collection. (Inherited from Control.ControlCollection)
Public Property | Owner | Gets the control that owns this Control.ControlCollection. (Inherited from Control.ControlCollection)
Top

See Also

Reference

TableLayoutControlCollection Class
Gizmox.WebGUI.Forms Namespace


Container Property

[image]
Gizmox.WebGUI.Forms
Container Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutControlCollection Class : Container Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Container As TableLayoutPanel
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutControlCollection
Dim value As TableLayoutPanel

value = instance.Container
C#
public TableLayoutPanel Container {get;}
Managed Extensions for C++
public: __property TableLayoutPanel* get_Container();
C++/CLI
public:
property TableLayoutPanel^ Container {
   TableLayoutPanel^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutControlCollection Class
TableLayoutControlCollection Members


TableLayoutPanel Class

[image]
Gizmox.WebGUI.Forms
TableLayoutPanel Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TableLayoutPanel Class

A table layout control.

Object Model

Syntax

Visual Basic (Declaration)
<MetadataTagAttribute("TLP")>
<ProvidePropertyAttribute(PropertyName="Row", ReceiverTypeName="Gizmox.WebGUI.Forms.Control, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d")>
<SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableGrid, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")>
<ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<ToolboxBitmapAttribute()>
<DesignTimeControllerAttribute()>
<ClientControllerAttribute()>
<SRDescriptionAttribute("Handles the layout of its components and arranges them in the format of a table automatically.")>
<DefaultPropertyAttribute("ColumnCount")>
<DesignerSerializerAttribute(SerializerTypeName="Gizmox.WebGUI.Common.Design.Serialization.TableLayoutPanelCodeDomSerializer, Gizmox.WebGUI.Common.Design, Version=2.0.5701.0, Culture=neutral, PublicKeyToken=ea5dfe57c8eb7edd", SerializerBaseTypeName="System.ComponentModel.Design.Serialization.CodeDomSerializer, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<ComVisibleAttribute(True)>
<ClassInterfaceAttribute()>
<ToolboxItemCategoryAttribute("Containers")>
Public Class TableLayoutPanel
   Inherits Control
   Implements IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutPanel
C#
[MetadataTagAttribute("TLP")]
[ProvidePropertyAttribute(PropertyName="Row", ReceiverTypeName="Gizmox.WebGUI.Forms.Control, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d")]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableGrid, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ToolboxBitmapAttribute()]
[DesignTimeControllerAttribute()]
[ClientControllerAttribute()]
[SRDescriptionAttribute("Handles the layout of its components and arranges them in the format of a table automatically.")]
[DefaultPropertyAttribute("ColumnCount")]
[DesignerSerializerAttribute(SerializerTypeName="Gizmox.WebGUI.Common.Design.Serialization.TableLayoutPanelCodeDomSerializer, Gizmox.WebGUI.Common.Design, Version=2.0.5701.0, Culture=neutral, PublicKeyToken=ea5dfe57c8eb7edd", SerializerBaseTypeName="System.ComponentModel.Design.Serialization.CodeDomSerializer, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ComVisibleAttribute(true)]
[ClassInterfaceAttribute()]
[ToolboxItemCategoryAttribute("Containers")]
public class TableLayoutPanel : Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Managed Extensions for C++
[MetadataTagAttribute("TLP")]
[ProvidePropertyAttribute(PropertyName="Row", ReceiverTypeName="Gizmox.WebGUI.Forms.Control, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d")]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableGrid, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ToolboxBitmapAttribute()]
[DesignTimeControllerAttribute()]
[ClientControllerAttribute()]
[SRDescriptionAttribute("Handles the layout of its components and arranges them in the format of a table automatically.")]
[DefaultPropertyAttribute("ColumnCount")]
[DesignerSerializerAttribute(SerializerTypeName="Gizmox.WebGUI.Common.Design.Serialization.TableLayoutPanelCodeDomSerializer, Gizmox.WebGUI.Common.Design, Version=2.0.5701.0, Culture=neutral, PublicKeyToken=ea5dfe57c8eb7edd", SerializerBaseTypeName="System.ComponentModel.Design.Serialization.CodeDomSerializer, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ComVisibleAttribute(true)]
[ClassInterfaceAttribute()]
[ToolboxItemCategoryAttribute("Containers")]
public __gc class TableLayoutPanel : public Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
C++/CLI
[MetadataTagAttribute("TLP")]
[ProvidePropertyAttribute(PropertyName="Row", ReceiverTypeName="Gizmox.WebGUI.Forms.Control, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d")]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableGrid, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ToolboxBitmapAttribute()]
[DesignTimeControllerAttribute()]
[ClientControllerAttribute()]
[SRDescriptionAttribute("Handles the layout of its components and arranges them in the format of a table automatically.")]
[DefaultPropertyAttribute("ColumnCount")]
[DesignerSerializerAttribute(SerializerTypeName="Gizmox.WebGUI.Common.Design.Serialization.TableLayoutPanelCodeDomSerializer, Gizmox.WebGUI.Common.Design, Version=2.0.5701.0, Culture=neutral, PublicKeyToken=ea5dfe57c8eb7edd", SerializerBaseTypeName="System.ComponentModel.Design.Serialization.CodeDomSerializer, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ComVisibleAttribute(true)]
[ClassInterfaceAttribute()]
[ToolboxItemCategoryAttribute("Containers")]
public ref class TableLayoutPanel : public Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement

Remarks

Use this layout control to create static layout that updates with control resizing.

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.TableLayoutPanel

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

TableLayoutPanel Members
Gizmox.WebGUI.Forms Namespace


TableLayoutPanel Class Members

[image]
Gizmox.WebGUI.Forms
TableLayoutPanel Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : TableLayoutPanel Class

The following tables list the members exposed by TableLayoutPanel.

Public Constructors

 | Name | Description
Public Constructor | TableLayoutPanel Constructor |
Top

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | CellBorderStyle |
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | ColumnCount |
Public Property | ColumnStyles |
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls |
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | GrowStyle |
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | LayoutEngine |
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | RowCount |
Public Property | RowStyles |
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Control)
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetCellPosition |
Public Method | GetColumn |
Public Method | GetColumnSpan |
Public Method | GetControlFromPosition | Returns the child control occupying the specified position.
Public Method | GetNewColAndRowCount | Gets the new row and column number according to the newly added controls.
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPositionFromControl |
Public Method | GetPreferredSize | Overridden. Gets the size of the control.
Public Method | GetRow |
Public Method | GetRowSpan |
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetCellPosition |
Public Method | SetColumn |
Public Method | SetColumnSpan |
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | SetRow |
Public Method | SetRowSpan |
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | Overridden.
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Control)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from Control)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnCellPaint |
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | Overridden. Raises the E:ControlRemoved event.
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLayout |
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnPaintBackground |
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | Overridden. Renders the current control.
Protected Method | RenderAttributes | Renders the controls meta attributes (Inherited from Control)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Overridden. Renders the child controls.
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | ScaleControl |
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | CellPaint |
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

TableLayoutPanel Class
Gizmox.WebGUI.Forms Namespace


TableLayoutPanel Constructor

[image]
Gizmox.WebGUI.Forms
TableLayoutPanel Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutPanel Class : TableLayoutPanel Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutPanel()
C#
public TableLayoutPanel()
Managed Extensions for C++
public: TableLayoutPanel();
C++/CLI
public:
TableLayoutPanel();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutPanel Class
TableLayoutPanel Members


TableLayoutPanel Class Methods

[image]
Gizmox.WebGUI.Forms
TableLayoutPanel Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TableLayoutPanel Class

For a list of all members of this type, see TableLayoutPanel members.

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetCellPosition |
Public Method | GetColumn |
Public Method | GetColumnSpan |
Public Method | GetControlFromPosition | Returns the child control occupying the specified position.
Public Method | GetNewColAndRowCount | Gets the new row and column number according to the newly added controls.
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPositionFromControl |
Public Method | GetPreferredSize | Overridden. Gets the size of the control.
Public Method | GetRow |
Public Method | GetRowSpan |
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetCellPosition |
Public Method | SetColumn |
Public Method | SetColumnSpan |
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | SetRow |
Public Method | SetRowSpan |
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | Overridden.
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Control)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from Control)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnCellPaint |
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | Overridden. Raises the E:ControlRemoved event.
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLayout |
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnPaintBackground |
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | Overridden. Renders the current control.
Protected Method | RenderAttributes | Renders the controls meta attributes (Inherited from Control)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Overridden. Renders the child controls.
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | ScaleControl |
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

See Also

Reference

TableLayoutPanel Class
Gizmox.WebGUI.Forms Namespace


CreateControlsInstance Method

[image]
Gizmox.WebGUI.Forms
CreateControlsInstance Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutPanel Class : CreateControlsInstance Method

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overrides Function CreateControlsInstance() As Control.ControlCollection
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutPanel
Dim value As Control.ControlCollection

value = instance.CreateControlsInstance()
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected override Control.ControlCollection CreateControlsInstance()
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: Control.ControlCollection* CreateControlsInstance(); override
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
Control::ControlCollection^ CreateControlsInstance(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutPanel Class
TableLayoutPanel Members


GetCellPosition Method

[image]
Gizmox.WebGUI.Forms
GetCellPosition Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutPanel Class : GetCellPosition Method

control

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<DisplayNameAttribute("Cell")>
<SRCategoryAttribute("Layout")>
<DesignerSerializationVisibilityAttribute()>
<SRDescriptionAttribute("Specifies the Row and Column position of the control.")>
Public Function GetCellPosition( _
   ByVal control As Control _
) As TableLayoutPanelCellPosition
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutPanel
Dim control As Control
Dim value As TableLayoutPanelCellPosition

value = instance.GetCellPosition(control)
C#
[DefaultValueAttribute()]
[DisplayNameAttribute("Cell")]
[SRCategoryAttribute("Layout")]
[DesignerSerializationVisibilityAttribute()]
[SRDescriptionAttribute("Specifies the Row and Column position of the control.")]
public TableLayoutPanelCellPosition GetCellPosition(
   Control control
)
Managed Extensions for C++
[DefaultValueAttribute()]
[DisplayNameAttribute("Cell")]
[SRCategoryAttribute("Layout")]
[DesignerSerializationVisibilityAttribute()]
[SRDescriptionAttribute("Specifies the Row and Column position of the control.")]
public: TableLayoutPanelCellPosition GetCellPosition(
   Control* control
)
C++/CLI
[DefaultValueAttribute()]
[DisplayNameAttribute("Cell")]
[SRCategoryAttribute("Layout")]
[DesignerSerializationVisibilityAttribute()]
[SRDescriptionAttribute("Specifies the Row and Column position of the control.")]
public:
TableLayoutPanelCellPosition GetCellPosition(
   Control^ control
)

Parameters

control

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutPanel Class
TableLayoutPanel Members


GetColumn Method

[image]
Gizmox.WebGUI.Forms
GetColumn Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutPanel Class : GetColumn Method

control

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
<SRDescriptionAttribute("The column position of the specified child control.")>
<SRCategoryAttribute("Layout")>
<DefaultValueAttribute()>
<DisplayNameAttribute("Column")>
Public Function GetColumn( _
   ByVal control As Control _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutPanel
Dim control As Control
Dim value As Integer

value = instance.GetColumn(control)
C#
[DesignerSerializationVisibilityAttribute()]
[SRDescriptionAttribute("The column position of the specified child control.")]
[SRCategoryAttribute("Layout")]
[DefaultValueAttribute()]
[DisplayNameAttribute("Column")]
public int GetColumn(
   Control control
)
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
[SRDescriptionAttribute("The column position of the specified child control.")]
[SRCategoryAttribute("Layout")]
[DefaultValueAttribute()]
[DisplayNameAttribute("Column")]
public: int GetColumn(
   Control* control
)
C++/CLI
[DesignerSerializationVisibilityAttribute()]
[SRDescriptionAttribute("The column position of the specified child control.")]
[SRCategoryAttribute("Layout")]
[DefaultValueAttribute()]
[DisplayNameAttribute("Column")]
public:
int GetColumn(
   Control^ control
)

Parameters

control

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutPanel Class
TableLayoutPanel Members


GetColumnSpan Method

[image]
Gizmox.WebGUI.Forms
GetColumnSpan Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutPanel Class : GetColumnSpan Method

control

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<SRCategoryAttribute("Layout")>
<DisplayNameAttribute("ColumnSpan")>
<SRDescriptionAttribute("The column span of the control.")>
Public Function GetColumnSpan( _
   ByVal control As Control _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutPanel
Dim control As Control
Dim value As Integer

value = instance.GetColumnSpan(control)
C#
[DefaultValueAttribute()]
[SRCategoryAttribute("Layout")]
[DisplayNameAttribute("ColumnSpan")]
[SRDescriptionAttribute("The column span of the control.")]
public int GetColumnSpan(
   Control control
)
Managed Extensions for C++
[DefaultValueAttribute()]
[SRCategoryAttribute("Layout")]
[DisplayNameAttribute("ColumnSpan")]
[SRDescriptionAttribute("The column span of the control.")]
public: int GetColumnSpan(
   Control* control
)
C++/CLI
[DefaultValueAttribute()]
[SRCategoryAttribute("Layout")]
[DisplayNameAttribute("ColumnSpan")]
[SRDescriptionAttribute("The column span of the control.")]
public:
int GetColumnSpan(
   Control^ control
)

Parameters

control

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutPanel Class
TableLayoutPanel Members


GetControlFromPosition Method

[image]
Gizmox.WebGUI.Forms
GetControlFromPosition Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutPanel Class : GetControlFromPosition Method

intColumn
The column position of the control to retrieve.
intRow
The row position of the control to retrieve.
Returns the child control occupying the specified position.

Syntax

Visual Basic (Declaration)
Public Function GetControlFromPosition( _
   ByVal intColumn As Integer, _
   ByVal intRow As Integer _
) As Control
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutPanel
Dim intColumn As Integer
Dim intRow As Integer
Dim value As Control

value = instance.GetControlFromPosition(intColumn, intRow)
C#
public Control GetControlFromPosition(
   int intColumn,
   int intRow
)
Managed Extensions for C++
public: Control* GetControlFromPosition(
   int intColumn,
   int intRow
)
C++/CLI
public:
Control^ GetControlFromPosition(
   int intColumn,
   int intRow
)

Parameters

intColumn
The column position of the control to retrieve.
intRow
The row position of the control to retrieve.

Return Value

The child control occupying the specified cell; otherwise, null if no control exists at the specified column and row.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutPanel Class
TableLayoutPanel Members


GetNewColAndRowCount Method

[image]
Gizmox.WebGUI.Forms
GetNewColAndRowCount Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutPanel Class : GetNewColAndRowCount Method

intNewRowNum
The row count return value.
intNewColNum
The column count return value.
Gets the new row and column number according to the newly added controls.

Syntax

Visual Basic (Declaration)
Public Sub GetNewColAndRowCount( _
   ByRef intNewRowNum As Integer, _
   ByRef intNewColNum As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutPanel
Dim intNewRowNum As Integer
Dim intNewColNum As Integer

instance.GetNewColAndRowCount(intNewRowNum, intNewColNum)
C#
public void GetNewColAndRowCount(
   out int intNewRowNum,
   out int intNewColNum
)
Managed Extensions for C++
public: void GetNewColAndRowCount(
   [PARAMFLAG::Out] int intNewRowNum,
   [PARAMFLAG::Out] int intNewColNum
)
C++/CLI
public:
void GetNewColAndRowCount(
   [Out] int intNewRowNum,
   [Out] int intNewColNum
)

Parameters

intNewRowNum
The row count return value.
intNewColNum
The column count return value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutPanel Class
TableLayoutPanel Members


GetPositionFromControl Method

[image]
Gizmox.WebGUI.Forms
GetPositionFromControl Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutPanel Class : GetPositionFromControl Method

control

Syntax

Visual Basic (Declaration)
Public Function GetPositionFromControl( _
   ByVal control As Control _
) As TableLayoutPanelCellPosition
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutPanel
Dim control As Control
Dim value As TableLayoutPanelCellPosition

value = instance.GetPositionFromControl(control)
C#
public TableLayoutPanelCellPosition GetPositionFromControl(
   Control control
)
Managed Extensions for C++
public: TableLayoutPanelCellPosition GetPositionFromControl(
   Control* control
)
C++/CLI
public:
TableLayoutPanelCellPosition GetPositionFromControl(
   Control^ control
)

Parameters

control

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutPanel Class
TableLayoutPanel Members


GetPreferredSize Method

[image]
Gizmox.WebGUI.Forms
GetPreferredSize Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutPanel Class : GetPreferredSize Method

proposedSize
The proposed size in a 'Size' struct format.
Gets the size of the control.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetPreferredSize( _
   ByVal proposedSize As Size _
) As Size
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutPanel
Dim proposedSize As Size
Dim value As Size

value = instance.GetPreferredSize(proposedSize)
C#
public override Size GetPreferredSize(
   Size proposedSize
)
Managed Extensions for C++
public: Size GetPreferredSize(
   Size proposedSize
) override
C++/CLI
public:
Size GetPreferredSize(
   Size proposedSize
) override

Parameters

proposedSize
The proposed size in a 'Size' struct format.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutPanel Class
TableLayoutPanel Members


GetRow Method

[image]
Gizmox.WebGUI.Forms
GetRow Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutPanel Class : GetRow Method

control

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
<DisplayNameAttribute("Row")>
<DefaultValueAttribute()>
<SRDescriptionAttribute("The row position of the absolutely positioned element.")>
<SRCategoryAttribute("Layout")>
Public Function GetRow( _
   ByVal control As Control _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutPanel
Dim control As Control
Dim value As Integer

value = instance.GetRow(control)
C#
[DesignerSerializationVisibilityAttribute()]
[DisplayNameAttribute("Row")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("The row position of the absolutely positioned element.")]
[SRCategoryAttribute("Layout")]
public int GetRow(
   Control control
)
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
[DisplayNameAttribute("Row")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("The row position of the absolutely positioned element.")]
[SRCategoryAttribute("Layout")]
public: int GetRow(
   Control* control
)
C++/CLI
[DesignerSerializationVisibilityAttribute()]
[DisplayNameAttribute("Row")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("The row position of the absolutely positioned element.")]
[SRCategoryAttribute("Layout")]
public:
int GetRow(
   Control^ control
)

Parameters

control

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutPanel Class
TableLayoutPanel Members


GetRowSpan Method

[image]
Gizmox.WebGUI.Forms
GetRowSpan Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutPanel Class : GetRowSpan Method

control

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Layout")>
<SRDescriptionAttribute("The row span of the control.")>
<DefaultValueAttribute()>
<DisplayNameAttribute("RowSpan")>
Public Function GetRowSpan( _
   ByVal control As Control _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutPanel
Dim control As Control
Dim value As Integer

value = instance.GetRowSpan(control)
C#
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("The row span of the control.")]
[DefaultValueAttribute()]
[DisplayNameAttribute("RowSpan")]
public int GetRowSpan(
   Control control
)
Managed Extensions for C++
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("The row span of the control.")]
[DefaultValueAttribute()]
[DisplayNameAttribute("RowSpan")]
public: int GetRowSpan(
   Control* control
)
C++/CLI
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("The row span of the control.")]
[DefaultValueAttribute()]
[DisplayNameAttribute("RowSpan")]
public:
int GetRowSpan(
   Control^ control
)

Parameters

control

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutPanel Class
TableLayoutPanel Members


OnCellPaint Method

[image]
Gizmox.WebGUI.Forms
OnCellPaint Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutPanel Class : OnCellPaint Method

e

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnCellPaint( _
   ByVal e As TableLayoutCellPaintEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutPanel
Dim e As TableLayoutCellPaintEventArgs

instance.OnCellPaint(e)
C#
protected virtual void OnCellPaint(
   TableLayoutCellPaintEventArgs e
)
Managed Extensions for C++
protected: virtual void OnCellPaint(
   TableLayoutCellPaintEventArgs* e
)
C++/CLI
protected:
virtual void OnCellPaint(
   TableLayoutCellPaintEventArgs^ e
)

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutPanel Class
TableLayoutPanel Members


OnControlRemoved Method

[image]
Gizmox.WebGUI.Forms
OnControlRemoved Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutPanel Class : OnControlRemoved Method

e
The ControlEventArgs instance containing the event data.
Raises the E:ControlRemoved event.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnControlRemoved( _
   ByVal e As ControlEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutPanel
Dim e As ControlEventArgs

instance.OnControlRemoved(e)
C#
protected override void OnControlRemoved(
   ControlEventArgs e
)
Managed Extensions for C++
protected: void OnControlRemoved(
   ControlEventArgs* e
) override
C++/CLI
protected:
void OnControlRemoved(
   ControlEventArgs^ e
) override

Parameters

e
The ControlEventArgs instance containing the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutPanel Class
TableLayoutPanel Members


OnLayout Method

[image]
Gizmox.WebGUI.Forms
OnLayout Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutPanel Class : OnLayout Method

levent

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Sub OnLayout( _
   ByVal levent As LayoutEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutPanel
Dim levent As LayoutEventArgs

instance.OnLayout(levent)
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected void OnLayout(
   LayoutEventArgs levent
)
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: void OnLayout(
   LayoutEventArgs* levent
)
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
void OnLayout(
   LayoutEventArgs^ levent
)

Parameters

levent

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutPanel Class
TableLayoutPanel Members


OnPaintBackground Method

[image]
Gizmox.WebGUI.Forms
OnPaintBackground Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutPanel Class : OnPaintBackground Method

e

Syntax

Visual Basic (Declaration)
Protected Sub OnPaintBackground( _
   ByVal e As PaintEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutPanel
Dim e As PaintEventArgs

instance.OnPaintBackground(e)
C#
protected void OnPaintBackground(
   PaintEventArgs e
)
Managed Extensions for C++
protected: void OnPaintBackground(
   PaintEventArgs* e
)
C++/CLI
protected:
void OnPaintBackground(
   PaintEventArgs^ e
)

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutPanel Class
TableLayoutPanel Members


Render Method

[image]
Gizmox.WebGUI.Forms
Render Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutPanel Class : Render Method

objContext
Request context.
objWriter
lngRequestID
Renders the current control.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub Render( _
   ByVal objContext As IContext, _
   ByVal objWriter As IResponseWriter, _
   ByVal lngRequestID As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutPanel
Dim objContext As IContext
Dim objWriter As IResponseWriter
Dim lngRequestID As Long

instance.Render(objContext, objWriter, lngRequestID)
C#
protected override void Render(
   IContext objContext,
   IResponseWriter objWriter,
   long lngRequestID
)
Managed Extensions for C++
protected: void Render(
   IContext* objContext,
   IResponseWriter* objWriter,
   long lngRequestID
) override
C++/CLI
protected:
void Render(
   IContext^ objContext,
   IResponseWriter^ objWriter,
   long long lngRequestID
) override

Parameters

objContext
Request context.
objWriter
lngRequestID

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutPanel Class
TableLayoutPanel Members


RenderControls Method

[image]
Gizmox.WebGUI.Forms
RenderControls Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutPanel Class : RenderControls Method

Renders the child controls.

Overload List

Overload | Description
RenderControls(IContext,IResponseWriter,Int64) | Renders the child controls.
RenderControls(IContext,IResponseWriter,Int64,Boolean) | Renders the controls sub tree (Inherited from Control)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutPanel Class
TableLayoutPanel Members


RenderControls(IContext,IResponseWriter,Int64) Method

[image]
Gizmox.WebGUI.Forms
RenderControls(IContext,IResponseWriter,Int64) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutPanel Class > RenderControls Method : RenderControls(IContext,IResponseWriter,Int64) Method

objContext
Request context.
objWriter
The response writer object.
lngRequestID
Request ID.
Renders the child controls.

Syntax

Visual Basic (Declaration)
Protected Overloads Overrides Sub RenderControls( _
   ByVal objContext As IContext, _
   ByVal objWriter As IResponseWriter, _
   ByVal lngRequestID As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutPanel
Dim objContext As IContext
Dim objWriter As IResponseWriter
Dim lngRequestID As Long

instance.RenderControls(objContext, objWriter, lngRequestID)
C#
protected override void RenderControls(
   IContext objContext,
   IResponseWriter objWriter,
   long lngRequestID
)
Managed Extensions for C++
protected: void RenderControls(
   IContext* objContext,
   IResponseWriter* objWriter,
   long lngRequestID
) override
C++/CLI
protected:
void RenderControls(
   IContext^ objContext,
   IResponseWriter^ objWriter,
   long long lngRequestID
) override

Parameters

objContext
Request context.
objWriter
The response writer object.
lngRequestID
Request ID.

Remarks

Overrides default controls rendering cause the fill docking mechanism is not fit to handle table layout children.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutPanel Class
TableLayoutPanel Members
Overload List


ScaleControl Method

[image]
Gizmox.WebGUI.Forms
ScaleControl Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutPanel Class : ScaleControl Method

factor
specified

Syntax

Visual Basic (Declaration)
Protected Sub ScaleControl( _
   ByVal factor As SizeF, _
   ByVal specified As BoundsSpecified _
)
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutPanel
Dim factor As SizeF
Dim specified As BoundsSpecified

instance.ScaleControl(factor, specified)
C#
protected void ScaleControl(
   SizeF factor,
   BoundsSpecified specified
)
Managed Extensions for C++
protected: void ScaleControl(
   SizeF factor,
   BoundsSpecified specified
)
C++/CLI
protected:
void ScaleControl(
   SizeF factor,
   BoundsSpecified specified
)

Parameters

factor
specified

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutPanel Class
TableLayoutPanel Members


SetCellPosition Method

[image]
Gizmox.WebGUI.Forms
SetCellPosition Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutPanel Class : SetCellPosition Method

control
position

Syntax

Visual Basic (Declaration)
Public Sub SetCellPosition( _
   ByVal control As Control, _
   ByVal position As TableLayoutPanelCellPosition _
)
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutPanel
Dim control As Control
Dim position As TableLayoutPanelCellPosition

instance.SetCellPosition(control, position)
C#
public void SetCellPosition(
   Control control,
   TableLayoutPanelCellPosition position
)
Managed Extensions for C++
public: void SetCellPosition(
   Control* control,
   TableLayoutPanelCellPosition position
)
C++/CLI
public:
void SetCellPosition(
   Control^ control,
   TableLayoutPanelCellPosition position
)

Parameters

control
position

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutPanel Class
TableLayoutPanel Members


SetColumn Method

[image]
Gizmox.WebGUI.Forms
SetColumn Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutPanel Class : SetColumn Method

control
column

Syntax

Visual Basic (Declaration)
Public Sub SetColumn( _
   ByVal control As Control, _
   ByVal column As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutPanel
Dim control As Control
Dim column As Integer

instance.SetColumn(control, column)
C#
public void SetColumn(
   Control control,
   int column
)
Managed Extensions for C++
public: void SetColumn(
   Control* control,
   int column
)
C++/CLI
public:
void SetColumn(
   Control^ control,
   int column
)

Parameters

control
column

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutPanel Class
TableLayoutPanel Members


SetColumnSpan Method

[image]
Gizmox.WebGUI.Forms
SetColumnSpan Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutPanel Class : SetColumnSpan Method

control
value

Syntax

Visual Basic (Declaration)
Public Sub SetColumnSpan( _
   ByVal control As Control, _
   ByVal value As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutPanel
Dim control As Control
Dim value As Integer

instance.SetColumnSpan(control, value)
C#
public void SetColumnSpan(
   Control control,
   int value
)
Managed Extensions for C++
public: void SetColumnSpan(
   Control* control,
   int value
)
C++/CLI
public:
void SetColumnSpan(
   Control^ control,
   int value
)

Parameters

control
value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutPanel Class
TableLayoutPanel Members


SetRow Method

[image]
Gizmox.WebGUI.Forms
SetRow Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutPanel Class : SetRow Method

control
row

Syntax

Visual Basic (Declaration)
Public Sub SetRow( _
   ByVal control As Control, _
   ByVal row As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutPanel
Dim control As Control
Dim row As Integer

instance.SetRow(control, row)
C#
public void SetRow(
   Control control,
   int row
)
Managed Extensions for C++
public: void SetRow(
   Control* control,
   int row
)
C++/CLI
public:
void SetRow(
   Control^ control,
   int row
)

Parameters

control
row

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutPanel Class
TableLayoutPanel Members


SetRowSpan Method

[image]
Gizmox.WebGUI.Forms
SetRowSpan Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutPanel Class : SetRowSpan Method

control
value

Syntax

Visual Basic (Declaration)
Public Sub SetRowSpan( _
   ByVal control As Control, _
   ByVal value As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutPanel
Dim control As Control
Dim value As Integer

instance.SetRowSpan(control, value)
C#
public void SetRowSpan(
   Control control,
   int value
)
Managed Extensions for C++
public: void SetRowSpan(
   Control* control,
   int value
)
C++/CLI
public:
void SetRowSpan(
   Control^ control,
   int value
)

Parameters

control
value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutPanel Class
TableLayoutPanel Members


TableLayoutPanel Class Properties

[image]
Gizmox.WebGUI.Forms
TableLayoutPanel Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TableLayoutPanel Class

For a list of all members of this type, see TableLayoutPanel members.

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | CellBorderStyle |
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | ColumnCount |
Public Property | ColumnStyles |
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls |
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | GrowStyle |
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | LayoutEngine |
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | RowCount |
Public Property | RowStyles |
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Control)
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

See Also

Reference

TableLayoutPanel Class
Gizmox.WebGUI.Forms Namespace


CellBorderStyle Property

[image]
Gizmox.WebGUI.Forms
CellBorderStyle Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutPanel Class : CellBorderStyle Property

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<SRDescriptionAttribute("Indicates the appearance of cell borders in a table.")>
<SRCategoryAttribute("Appearance")>
<LocalizableAttribute(True)>
Public Property CellBorderStyle As TableLayoutPanelCellBorderStyle
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutPanel
Dim value As TableLayoutPanelCellBorderStyle

instance.CellBorderStyle = value

value = instance.CellBorderStyle
C#
[DefaultValueAttribute()]
[SRDescriptionAttribute("Indicates the appearance of cell borders in a table.")]
[SRCategoryAttribute("Appearance")]
[LocalizableAttribute(true)]
public TableLayoutPanelCellBorderStyle CellBorderStyle {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[SRDescriptionAttribute("Indicates the appearance of cell borders in a table.")]
[SRCategoryAttribute("Appearance")]
[LocalizableAttribute(true)]
public: __property TableLayoutPanelCellBorderStyle get_CellBorderStyle();
public: __property void set_CellBorderStyle(
   TableLayoutPanelCellBorderStyle value
);
C++/CLI
[DefaultValueAttribute()]
[SRDescriptionAttribute("Indicates the appearance of cell borders in a table.")]
[SRCategoryAttribute("Appearance")]
[LocalizableAttribute(true)]
public:
property TableLayoutPanelCellBorderStyle CellBorderStyle {
   TableLayoutPanelCellBorderStyle get();
   void set (TableLayoutPanelCellBorderStylevalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutPanel Class
TableLayoutPanel Members


ColumnCount Property

[image]
Gizmox.WebGUI.Forms
ColumnCount Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutPanel Class : ColumnCount Property

Syntax

Visual Basic (Declaration)
<LocalizableAttribute(True)>
<DefaultValueAttribute()>
<SRDescriptionAttribute("The number of columns on the table.")>
<SRCategoryAttribute("Layout")>
Public Property ColumnCount As Integer
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutPanel
Dim value As Integer

instance.ColumnCount = value

value = instance.ColumnCount
C#
[LocalizableAttribute(true)]
[DefaultValueAttribute()]
[SRDescriptionAttribute("The number of columns on the table.")]
[SRCategoryAttribute("Layout")]
public int ColumnCount {get; set;}
Managed Extensions for C++
[LocalizableAttribute(true)]
[DefaultValueAttribute()]
[SRDescriptionAttribute("The number of columns on the table.")]
[SRCategoryAttribute("Layout")]
public: __property int get_ColumnCount();
public: __property void set_ColumnCount(
   int value
);
C++/CLI
[LocalizableAttribute(true)]
[DefaultValueAttribute()]
[SRDescriptionAttribute("The number of columns on the table.")]
[SRCategoryAttribute("Layout")]
public:
property int ColumnCount {
   int get();
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutPanel Class
TableLayoutPanel Members


ColumnStyles Property

[image]
Gizmox.WebGUI.Forms
ColumnStyles Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutPanel Class : ColumnStyles Property

Syntax

Visual Basic (Declaration)
<DisplayNameAttribute("Columns")>
<BrowsableAttribute(True)>
<DesignerSerializationVisibilityAttribute()>
<SRDescriptionAttribute("The column styles of the table.")>
<MergablePropertyAttribute(False)>
<SRCategoryAttribute("Layout")>
Public ReadOnly Property ColumnStyles As TableLayoutColumnStyleCollection
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutPanel
Dim value As TableLayoutColumnStyleCollection

value = instance.ColumnStyles
C#
[DisplayNameAttribute("Columns")]
[BrowsableAttribute(true)]
[DesignerSerializationVisibilityAttribute()]
[SRDescriptionAttribute("The column styles of the table.")]
[MergablePropertyAttribute(false)]
[SRCategoryAttribute("Layout")]
public TableLayoutColumnStyleCollection ColumnStyles {get;}
Managed Extensions for C++
[DisplayNameAttribute("Columns")]
[BrowsableAttribute(true)]
[DesignerSerializationVisibilityAttribute()]
[SRDescriptionAttribute("The column styles of the table.")]
[MergablePropertyAttribute(false)]
[SRCategoryAttribute("Layout")]
public: __property TableLayoutColumnStyleCollection* get_ColumnStyles();
C++/CLI
[DisplayNameAttribute("Columns")]
[BrowsableAttribute(true)]
[DesignerSerializationVisibilityAttribute()]
[SRDescriptionAttribute("The column styles of the table.")]
[MergablePropertyAttribute(false)]
[SRCategoryAttribute("Layout")]
public:
property TableLayoutColumnStyleCollection^ ColumnStyles {
   TableLayoutColumnStyleCollection^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutPanel Class
TableLayoutPanel Members


Controls Property

[image]
Gizmox.WebGUI.Forms
Controls Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutPanel Class : Controls Property

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<SRDescriptionAttribute("The collection of child controls within this control.")>
<DesignerSerializationVisibilityAttribute()>
Public ReadOnly Property Controls As TableLayoutControlCollection
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutPanel
Dim value As TableLayoutControlCollection

value = instance.Controls
C#
[BrowsableAttribute(false)]
[SRDescriptionAttribute("The collection of child controls within this control.")]
[DesignerSerializationVisibilityAttribute()]
public TableLayoutControlCollection Controls {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[SRDescriptionAttribute("The collection of child controls within this control.")]
[DesignerSerializationVisibilityAttribute()]
public: __property TableLayoutControlCollection* get_Controls();
C++/CLI
[BrowsableAttribute(false)]
[SRDescriptionAttribute("The collection of child controls within this control.")]
[DesignerSerializationVisibilityAttribute()]
public:
property TableLayoutControlCollection^ Controls {
   TableLayoutControlCollection^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutPanel Class
TableLayoutPanel Members


GrowStyle Property

[image]
Gizmox.WebGUI.Forms
GrowStyle Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutPanel Class : GrowStyle Property

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Layout")>
<DefaultValueAttribute()>
<SRDescriptionAttribute("Indicates whether a TableLayoutPanel will expand to include new cells when all existing cells are occupied.")>
Public Property GrowStyle As TableLayoutPanelGrowStyle
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutPanel
Dim value As TableLayoutPanelGrowStyle

instance.GrowStyle = value

value = instance.GrowStyle
C#
[SRCategoryAttribute("Layout")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Indicates whether a TableLayoutPanel will expand to include new cells when all existing cells are occupied.")]
public TableLayoutPanelGrowStyle GrowStyle {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Layout")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Indicates whether a TableLayoutPanel will expand to include new cells when all existing cells are occupied.")]
public: __property TableLayoutPanelGrowStyle get_GrowStyle();
public: __property void set_GrowStyle(
   TableLayoutPanelGrowStyle value
);
C++/CLI
[SRCategoryAttribute("Layout")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Indicates whether a TableLayoutPanel will expand to include new cells when all existing cells are occupied.")]
public:
property TableLayoutPanelGrowStyle GrowStyle {
   TableLayoutPanelGrowStyle get();
   void set (TableLayoutPanelGrowStylevalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutPanel Class
TableLayoutPanel Members


LayoutEngine Property

[image]
Gizmox.WebGUI.Forms
LayoutEngine Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutPanel Class : LayoutEngine Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LayoutEngine As LayoutEngine
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutPanel
Dim value As LayoutEngine

value = instance.LayoutEngine
C#
public LayoutEngine LayoutEngine {get;}
Managed Extensions for C++
public: __property LayoutEngine* get_LayoutEngine();
C++/CLI
public:
property LayoutEngine^ LayoutEngine {
   LayoutEngine^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutPanel Class
TableLayoutPanel Members


RowCount Property

[image]
Gizmox.WebGUI.Forms
RowCount Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutPanel Class : RowCount Property

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<LocalizableAttribute(True)>
<SRDescriptionAttribute("The number of rows on the table.")>
<SRCategoryAttribute("Layout")>
Public Property RowCount As Integer
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutPanel
Dim value As Integer

instance.RowCount = value

value = instance.RowCount
C#
[DefaultValueAttribute()]
[LocalizableAttribute(true)]
[SRDescriptionAttribute("The number of rows on the table.")]
[SRCategoryAttribute("Layout")]
public int RowCount {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[LocalizableAttribute(true)]
[SRDescriptionAttribute("The number of rows on the table.")]
[SRCategoryAttribute("Layout")]
public: __property int get_RowCount();
public: __property void set_RowCount(
   int value
);
C++/CLI
[DefaultValueAttribute()]
[LocalizableAttribute(true)]
[SRDescriptionAttribute("The number of rows on the table.")]
[SRCategoryAttribute("Layout")]
public:
property int RowCount {
   int get();
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutPanel Class
TableLayoutPanel Members


RowStyles Property

[image]
Gizmox.WebGUI.Forms
RowStyles Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutPanel Class : RowStyles Property

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Layout")>
<DisplayNameAttribute("Rows")>
<SRDescriptionAttribute("The row styles of the table.")>
<DesignerSerializationVisibilityAttribute()>
<MergablePropertyAttribute(False)>
<BrowsableAttribute(True)>
Public ReadOnly Property RowStyles As TableLayoutRowStyleCollection
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutPanel
Dim value As TableLayoutRowStyleCollection

value = instance.RowStyles
C#
[SRCategoryAttribute("Layout")]
[DisplayNameAttribute("Rows")]
[SRDescriptionAttribute("The row styles of the table.")]
[DesignerSerializationVisibilityAttribute()]
[MergablePropertyAttribute(false)]
[BrowsableAttribute(true)]
public TableLayoutRowStyleCollection RowStyles {get;}
Managed Extensions for C++
[SRCategoryAttribute("Layout")]
[DisplayNameAttribute("Rows")]
[SRDescriptionAttribute("The row styles of the table.")]
[DesignerSerializationVisibilityAttribute()]
[MergablePropertyAttribute(false)]
[BrowsableAttribute(true)]
public: __property TableLayoutRowStyleCollection* get_RowStyles();
C++/CLI
[SRCategoryAttribute("Layout")]
[DisplayNameAttribute("Rows")]
[SRDescriptionAttribute("The row styles of the table.")]
[DesignerSerializationVisibilityAttribute()]
[MergablePropertyAttribute(false)]
[BrowsableAttribute(true)]
public:
property TableLayoutRowStyleCollection^ RowStyles {
   TableLayoutRowStyleCollection^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutPanel Class
TableLayoutPanel Members


TableLayoutPanel Class Events

[image]
Gizmox.WebGUI.Forms
TableLayoutPanel Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TableLayoutPanel Class

For a list of all members of this type, see TableLayoutPanel members.

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | CellPaint |
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

TableLayoutPanel Class
Gizmox.WebGUI.Forms Namespace


CellPaint Event

[image]
Gizmox.WebGUI.Forms
CellPaint Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutPanel Class : CellPaint Event

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when a cell needs repainting.")>
<SRCategoryAttribute("Appearance")>
Public Event CellPaint() As TableLayoutCellPaintEventHandler
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutPanel
Dim handler As TableLayoutCellPaintEventHandler

AddHandler instance.CellPaint, handler
C#
[SRDescriptionAttribute("Occurs when a cell needs repainting.")]
[SRCategoryAttribute("Appearance")]
public event TableLayoutCellPaintEventHandler CellPaint()
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when a cell needs repainting.")]
[SRCategoryAttribute("Appearance")]
public: __event TableLayoutCellPaintEventHandler* CellPaint
C++/CLI
[SRDescriptionAttribute("Occurs when a cell needs repainting.")]
[SRCategoryAttribute("Appearance")]
public:
event TableLayoutCellPaintEventHandler^ CellPaint

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutPanel Class
TableLayoutPanel Members


TableLayoutRowStyleCollection Class

[image]
Gizmox.WebGUI.Forms
TableLayoutRowStyleCollection Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TableLayoutRowStyleCollection Class

Object Model

Syntax

Visual Basic (Declaration)
<ClientControllerAttribute()>
<DefaultMemberAttribute("Item")>
<DesignTimeControllerAttribute()>
Public Class TableLayoutRowStyleCollection
   Inherits TableLayoutStyleCollection
   Implements IObservableList
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutRowStyleCollection
C#
[ClientControllerAttribute()]
[DefaultMemberAttribute("Item")]
[DesignTimeControllerAttribute()]
public class TableLayoutRowStyleCollection : TableLayoutStyleCollection, IObservableList
Managed Extensions for C++
[ClientControllerAttribute()]
[DefaultMemberAttribute("Item")]
[DesignTimeControllerAttribute()]
public __gc class TableLayoutRowStyleCollection : public TableLayoutStyleCollection, IObservableList
C++/CLI
[ClientControllerAttribute()]
[DefaultMemberAttribute("Item")]
[DesignTimeControllerAttribute()]
public ref class TableLayoutRowStyleCollection : public TableLayoutStyleCollection, IObservableList

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.TableLayoutStyleCollection
Gizmox.WebGUI.Forms.TableLayoutRowStyleCollection

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

TableLayoutRowStyleCollection Members
Gizmox.WebGUI.Forms Namespace


TableLayoutRowStyleCollection Class Members

[image]
Gizmox.WebGUI.Forms
TableLayoutRowStyleCollection Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : TableLayoutRowStyleCollection Class

The following tables list the members exposed by TableLayoutRowStyleCollection.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from TableLayoutStyleCollection)
Public Property | Item |
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Adds a row style.
Public Method | Clear | (Inherited from TableLayoutStyleCollection)
Public Method | Contains |
Public Method | IndexOf |
Public Method | Insert |
Public Method | Remove |
Public Method | RemoveAt | (Inherited from TableLayoutStyleCollection)
Top

See Also

Reference

TableLayoutRowStyleCollection Class
Gizmox.WebGUI.Forms Namespace


TableLayoutRowStyleCollection Class Methods

[image]
Gizmox.WebGUI.Forms
TableLayoutRowStyleCollection Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TableLayoutRowStyleCollection Class

For a list of all members of this type, see TableLayoutRowStyleCollection members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Adds a row style.
Public Method | Clear | (Inherited from TableLayoutStyleCollection)
Public Method | Contains |
Public Method | IndexOf |
Public Method | Insert |
Public Method | Remove |
Public Method | RemoveAt | (Inherited from TableLayoutStyleCollection)
Top

See Also

Reference

TableLayoutRowStyleCollection Class
Gizmox.WebGUI.Forms Namespace


Add Method

[image]
Gizmox.WebGUI.Forms
Add Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutRowStyleCollection Class : Add Method

Adds a row style.

Overload List

Overload | Description
Add(RowStyle) |
Add(Int32) | Adds a row style.
Add(TableLayoutStyle) | (Inherited from TableLayoutStyleCollection)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutRowStyleCollection Class
TableLayoutRowStyleCollection Members


Add(RowStyle) Method

[image]
Gizmox.WebGUI.Forms
Add(RowStyle) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutRowStyleCollection Class > Add Method : Add(RowStyle) Method

rowStyle

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal rowStyle As RowStyle _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutRowStyleCollection
Dim rowStyle As RowStyle
Dim value As Integer

value = instance.Add(rowStyle)
C#
public int Add(
   RowStyle rowStyle
)
Managed Extensions for C++
public: int Add(
   RowStyle* rowStyle
)
C++/CLI
public:
int Add(
   RowStyle^ rowStyle
)

Parameters

rowStyle

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutRowStyleCollection Class
TableLayoutRowStyleCollection Members
Overload List


Add(Int32) Method

[image]
Gizmox.WebGUI.Forms
Add(Int32) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutRowStyleCollection Class > Add Method : Add(Int32) Method

intHeight
Adds a row style.

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal intHeight As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutRowStyleCollection
Dim intHeight As Integer
Dim value As Integer

value = instance.Add(intHeight)
C#
public int Add(
   int intHeight
)
Managed Extensions for C++
public: int Add(
   int intHeight
)
C++/CLI
public:
int Add(
   int intHeight
)

Parameters

intHeight

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutRowStyleCollection Class
TableLayoutRowStyleCollection Members
Overload List


Contains Method

[image]
Gizmox.WebGUI.Forms
Contains Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutRowStyleCollection Class : Contains Method

rowStyle

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal rowStyle As RowStyle _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutRowStyleCollection
Dim rowStyle As RowStyle
Dim value As Boolean

value = instance.Contains(rowStyle)
C#
public bool Contains(
   RowStyle rowStyle
)
Managed Extensions for C++
public: bool Contains(
   RowStyle* rowStyle
)
C++/CLI
public:
bool Contains(
   RowStyle^ rowStyle
)

Parameters

rowStyle

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutRowStyleCollection Class
TableLayoutRowStyleCollection Members


IndexOf Method

[image]
Gizmox.WebGUI.Forms
IndexOf Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutRowStyleCollection Class : IndexOf Method

rowStyle

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal rowStyle As RowStyle _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutRowStyleCollection
Dim rowStyle As RowStyle
Dim value As Integer

value = instance.IndexOf(rowStyle)
C#
public int IndexOf(
   RowStyle rowStyle
)
Managed Extensions for C++
public: int IndexOf(
   RowStyle* rowStyle
)
C++/CLI
public:
int IndexOf(
   RowStyle^ rowStyle
)

Parameters

rowStyle

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutRowStyleCollection Class
TableLayoutRowStyleCollection Members


Insert Method

[image]
Gizmox.WebGUI.Forms
Insert Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutRowStyleCollection Class : Insert Method

index
rowStyle

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal rowStyle As RowStyle _
)
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutRowStyleCollection
Dim index As Integer
Dim rowStyle As RowStyle

instance.Insert(index, rowStyle)
C#
public void Insert(
   int index,
   RowStyle rowStyle
)
Managed Extensions for C++
public: void Insert(
   int index,
   RowStyle* rowStyle
)
C++/CLI
public:
void Insert(
   int index,
   RowStyle^ rowStyle
)

Parameters

index
rowStyle

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutRowStyleCollection Class
TableLayoutRowStyleCollection Members


Remove Method

[image]
Gizmox.WebGUI.Forms
Remove Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutRowStyleCollection Class : Remove Method

rowStyle

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal rowStyle As RowStyle _
)
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutRowStyleCollection
Dim rowStyle As RowStyle

instance.Remove(rowStyle)
C#
public void Remove(
   RowStyle rowStyle
)
Managed Extensions for C++
public: void Remove(
   RowStyle* rowStyle
)
C++/CLI
public:
void Remove(
   RowStyle^ rowStyle
)

Parameters

rowStyle

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutRowStyleCollection Class
TableLayoutRowStyleCollection Members


TableLayoutRowStyleCollection Class Properties

[image]
Gizmox.WebGUI.Forms
TableLayoutRowStyleCollection Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TableLayoutRowStyleCollection Class

For a list of all members of this type, see TableLayoutRowStyleCollection members.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from TableLayoutStyleCollection)
Public Property | Item |
Top

See Also

Reference

TableLayoutRowStyleCollection Class
Gizmox.WebGUI.Forms Namespace


Item Property

[image]
Gizmox.WebGUI.Forms
Item Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutRowStyleCollection Class : Item Property

index

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal index As Integer _
) As RowStyle
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutRowStyleCollection
Dim index As Integer
Dim value As RowStyle

instance.Item(index) = value

value = instance.Item(index)
C#
public RowStyle this[
   int index
]; {get; set;}
Managed Extensions for C++
public: __property RowStyle* get_Item(
   int index
);
public: __property void set_Item(
   int index,
   RowStyle* value
);
C++/CLI
public:
property RowStyle^ default [int] {
   RowStyle^ get(intindex);
   void set (intindex, RowStyle^value);
}

Parameters

index

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutRowStyleCollection Class
TableLayoutRowStyleCollection Members


TableLayoutSettings Class

[image]
Gizmox.WebGUI.Forms
TableLayoutSettings Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TableLayoutSettings Class

Object Model

Syntax

Visual Basic (Declaration)
<DesignTimeControllerAttribute()>
<ClientControllerAttribute()>
<TypeConverterAttribute("Gizmox.WebGUI.Forms.TableLayoutSettingsTypeConverter, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d")>
Public NotInheritable Class TableLayoutSettings
   Inherits LayoutSettings
   Implements IObservableItem
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutSettings
C#
[DesignTimeControllerAttribute()]
[ClientControllerAttribute()]
[TypeConverterAttribute("Gizmox.WebGUI.Forms.TableLayoutSettingsTypeConverter, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d")]
public sealed class TableLayoutSettings : LayoutSettings, IObservableItem
Managed Extensions for C++
[DesignTimeControllerAttribute()]
[ClientControllerAttribute()]
[TypeConverterAttribute("Gizmox.WebGUI.Forms.TableLayoutSettingsTypeConverter, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d")]
public __gc __sealed class TableLayoutSettings : public LayoutSettings, IObservableItem
C++/CLI
[DesignTimeControllerAttribute()]
[ClientControllerAttribute()]
[TypeConverterAttribute("Gizmox.WebGUI.Forms.TableLayoutSettingsTypeConverter, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d")]
public ref class TableLayoutSettings sealed : public LayoutSettings, IObservableItem

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.LayoutSettings
Gizmox.WebGUI.Forms.TableLayoutSettings

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

TableLayoutSettings Members
Gizmox.WebGUI.Forms Namespace


TableLayoutSettings Class Members

[image]
Gizmox.WebGUI.Forms
TableLayoutSettings Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : TableLayoutSettings Class

The following tables list the members exposed by TableLayoutSettings.

Public Properties

 | Name | Description
Public Property | ColumnCount |
Public Property | ColumnStyles |
Public Property | GrowStyle |
Public Property | LayoutEngine | Overridden.
Public Property | RowCount |
Public Property | RowStyles |
Top

Public Methods

 | Name | Description
Public Method | GetCellPosition |
Public Method | GetColumn |
Public Method | GetColumnSpan |
Public Method | GetRow |
Public Method | GetRowSpan |
Public Method | SetCellPosition |
Public Method | SetColumn |
Public Method | SetColumnSpan |
Public Method | SetRow |
Public Method | SetRowSpan |
Top

Protected Methods

 | Name | Description
Protected Method | FireObservableItemPropertyChanged | Fires the ObservableItemPropertyChanged event of the IObservableItem interface.
Top

See Also

Reference

TableLayoutSettings Class
Gizmox.WebGUI.Forms Namespace


TableLayoutSettings Class Methods

[image]
Gizmox.WebGUI.Forms
TableLayoutSettings Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TableLayoutSettings Class

For a list of all members of this type, see TableLayoutSettings members.

Public Methods

 | Name | Description
Public Method | GetCellPosition |
Public Method | GetColumn |
Public Method | GetColumnSpan |
Public Method | GetRow |
Public Method | GetRowSpan |
Public Method | SetCellPosition |
Public Method | SetColumn |
Public Method | SetColumnSpan |
Public Method | SetRow |
Public Method | SetRowSpan |
Top

Protected Methods

 | Name | Description
Protected Method | FireObservableItemPropertyChanged | Fires the ObservableItemPropertyChanged event of the IObservableItem interface.
Top

See Also

Reference

TableLayoutSettings Class
Gizmox.WebGUI.Forms Namespace


FireObservableItemPropertyChanged Method

[image]
Gizmox.WebGUI.Forms
FireObservableItemPropertyChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutSettings Class : FireObservableItemPropertyChanged Method

strProperty
The name of the property that has changed
Fires the ObservableItemPropertyChanged event of the IObservableItem interface.

Syntax

Visual Basic (Declaration)
Protected Sub FireObservableItemPropertyChanged( _
   ByVal strProperty As String _
)
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutSettings
Dim strProperty As String

instance.FireObservableItemPropertyChanged(strProperty)
C#
protected void FireObservableItemPropertyChanged(
   string strProperty
)
Managed Extensions for C++
protected: void FireObservableItemPropertyChanged(
   string* strProperty
)
C++/CLI
protected:
void FireObservableItemPropertyChanged(
   String^ strProperty
)

Parameters

strProperty
The name of the property that has changed

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutSettings Class
TableLayoutSettings Members


GetCellPosition Method

[image]
Gizmox.WebGUI.Forms
GetCellPosition Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutSettings Class : GetCellPosition Method

control

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Layout")>
<DefaultValueAttribute()>
<SRDescriptionAttribute("Indicates the row and column of the cell.")>
Public Function GetCellPosition( _
   ByVal control As Object _
) As TableLayoutPanelCellPosition
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutSettings
Dim control As Object
Dim value As TableLayoutPanelCellPosition

value = instance.GetCellPosition(control)
C#
[SRCategoryAttribute("Layout")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Indicates the row and column of the cell.")]
public TableLayoutPanelCellPosition GetCellPosition(
   object control
)
Managed Extensions for C++
[SRCategoryAttribute("Layout")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Indicates the row and column of the cell.")]
public: TableLayoutPanelCellPosition GetCellPosition(
   Object* control
)
C++/CLI
[SRCategoryAttribute("Layout")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Indicates the row and column of the cell.")]
public:
TableLayoutPanelCellPosition GetCellPosition(
   Object^ control
)

Parameters

control

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutSettings Class
TableLayoutSettings Members


GetColumn Method

[image]
Gizmox.WebGUI.Forms
GetColumn Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutSettings Class : GetColumn Method

control

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("The column position of the specified child control.")>
<DefaultValueAttribute()>
<SRCategoryAttribute("Layout")>
Public Function GetColumn( _
   ByVal control As Object _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutSettings
Dim control As Object
Dim value As Integer

value = instance.GetColumn(control)
C#
[SRDescriptionAttribute("The column position of the specified child control.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Layout")]
public int GetColumn(
   object control
)
Managed Extensions for C++
[SRDescriptionAttribute("The column position of the specified child control.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Layout")]
public: int GetColumn(
   Object* control
)
C++/CLI
[SRDescriptionAttribute("The column position of the specified child control.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Layout")]
public:
int GetColumn(
   Object^ control
)

Parameters

control

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutSettings Class
TableLayoutSettings Members


GetColumnSpan Method

[image]
Gizmox.WebGUI.Forms
GetColumnSpan Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutSettings Class : GetColumnSpan Method

control

Syntax

Visual Basic (Declaration)
Public Function GetColumnSpan( _
   ByVal control As Object _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutSettings
Dim control As Object
Dim value As Integer

value = instance.GetColumnSpan(control)
C#
public int GetColumnSpan(
   object control
)
Managed Extensions for C++
public: int GetColumnSpan(
   Object* control
)
C++/CLI
public:
int GetColumnSpan(
   Object^ control
)

Parameters

control

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutSettings Class
TableLayoutSettings Members


GetRow Method

[image]
Gizmox.WebGUI.Forms
GetRow Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutSettings Class : GetRow Method

control

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("The row position of the absolutely positioned element.")>
<SRCategoryAttribute("Layout")>
<DefaultValueAttribute()>
Public Function GetRow( _
   ByVal control As Object _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutSettings
Dim control As Object
Dim value As Integer

value = instance.GetRow(control)
C#
[SRDescriptionAttribute("The row position of the absolutely positioned element.")]
[SRCategoryAttribute("Layout")]
[DefaultValueAttribute()]
public int GetRow(
   object control
)
Managed Extensions for C++
[SRDescriptionAttribute("The row position of the absolutely positioned element.")]
[SRCategoryAttribute("Layout")]
[DefaultValueAttribute()]
public: int GetRow(
   Object* control
)
C++/CLI
[SRDescriptionAttribute("The row position of the absolutely positioned element.")]
[SRCategoryAttribute("Layout")]
[DefaultValueAttribute()]
public:
int GetRow(
   Object^ control
)

Parameters

control

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutSettings Class
TableLayoutSettings Members


GetRowSpan Method

[image]
Gizmox.WebGUI.Forms
GetRowSpan Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutSettings Class : GetRowSpan Method

control

Syntax

Visual Basic (Declaration)
Public Function GetRowSpan( _
   ByVal control As Object _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutSettings
Dim control As Object
Dim value As Integer

value = instance.GetRowSpan(control)
C#
public int GetRowSpan(
   object control
)
Managed Extensions for C++
public: int GetRowSpan(
   Object* control
)
C++/CLI
public:
int GetRowSpan(
   Object^ control
)

Parameters

control

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutSettings Class
TableLayoutSettings Members


SetCellPosition Method

[image]
Gizmox.WebGUI.Forms
SetCellPosition Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutSettings Class : SetCellPosition Method

control
cellPosition

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<SRDescriptionAttribute("Sets the row and column of the cell.")>
<SRCategoryAttribute("Layout")>
Public Sub SetCellPosition( _
   ByVal control As Object, _
   ByVal cellPosition As TableLayoutPanelCellPosition _
)
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutSettings
Dim control As Object
Dim cellPosition As TableLayoutPanelCellPosition

instance.SetCellPosition(control, cellPosition)
C#
[DefaultValueAttribute()]
[SRDescriptionAttribute("Sets the row and column of the cell.")]
[SRCategoryAttribute("Layout")]
public void SetCellPosition(
   object control,
   TableLayoutPanelCellPosition cellPosition
)
Managed Extensions for C++
[DefaultValueAttribute()]
[SRDescriptionAttribute("Sets the row and column of the cell.")]
[SRCategoryAttribute("Layout")]
public: void SetCellPosition(
   Object* control,
   TableLayoutPanelCellPosition cellPosition
)
C++/CLI
[DefaultValueAttribute()]
[SRDescriptionAttribute("Sets the row and column of the cell.")]
[SRCategoryAttribute("Layout")]
public:
void SetCellPosition(
   Object^ control,
   TableLayoutPanelCellPosition cellPosition
)

Parameters

control
cellPosition

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutSettings Class
TableLayoutSettings Members


SetColumn Method

[image]
Gizmox.WebGUI.Forms
SetColumn Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutSettings Class : SetColumn Method

control
column

Syntax

Visual Basic (Declaration)
Public Sub SetColumn( _
   ByVal control As Object, _
   ByVal column As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutSettings
Dim control As Object
Dim column As Integer

instance.SetColumn(control, column)
C#
public void SetColumn(
   object control,
   int column
)
Managed Extensions for C++
public: void SetColumn(
   Object* control,
   int column
)
C++/CLI
public:
void SetColumn(
   Object^ control,
   int column
)

Parameters

control
column

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutSettings Class
TableLayoutSettings Members


SetColumnSpan Method

[image]
Gizmox.WebGUI.Forms
SetColumnSpan Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutSettings Class : SetColumnSpan Method

control
value

Syntax

Visual Basic (Declaration)
Public Sub SetColumnSpan( _
   ByVal control As Object, _
   ByVal value As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutSettings
Dim control As Object
Dim value As Integer

instance.SetColumnSpan(control, value)
C#
public void SetColumnSpan(
   object control,
   int value
)
Managed Extensions for C++
public: void SetColumnSpan(
   Object* control,
   int value
)
C++/CLI
public:
void SetColumnSpan(
   Object^ control,
   int value
)

Parameters

control
value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutSettings Class
TableLayoutSettings Members


SetRow Method

[image]
Gizmox.WebGUI.Forms
SetRow Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutSettings Class : SetRow Method

control
row

Syntax

Visual Basic (Declaration)
Public Sub SetRow( _
   ByVal control As Object, _
   ByVal row As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutSettings
Dim control As Object
Dim row As Integer

instance.SetRow(control, row)
C#
public void SetRow(
   object control,
   int row
)
Managed Extensions for C++
public: void SetRow(
   Object* control,
   int row
)
C++/CLI
public:
void SetRow(
   Object^ control,
   int row
)

Parameters

control
row

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutSettings Class
TableLayoutSettings Members


SetRowSpan Method

[image]
Gizmox.WebGUI.Forms
SetRowSpan Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutSettings Class : SetRowSpan Method

control
value

Syntax

Visual Basic (Declaration)
Public Sub SetRowSpan( _
   ByVal control As Object, _
   ByVal value As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutSettings
Dim control As Object
Dim value As Integer

instance.SetRowSpan(control, value)
C#
public void SetRowSpan(
   object control,
   int value
)
Managed Extensions for C++
public: void SetRowSpan(
   Object* control,
   int value
)
C++/CLI
public:
void SetRowSpan(
   Object^ control,
   int value
)

Parameters

control
value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutSettings Class
TableLayoutSettings Members


TableLayoutSettings Class Properties

[image]
Gizmox.WebGUI.Forms
TableLayoutSettings Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TableLayoutSettings Class

For a list of all members of this type, see TableLayoutSettings members.

Public Properties

 | Name | Description
Public Property | ColumnCount |
Public Property | ColumnStyles |
Public Property | GrowStyle |
Public Property | LayoutEngine | Overridden.
Public Property | RowCount |
Public Property | RowStyles |
Top

See Also

Reference

TableLayoutSettings Class
Gizmox.WebGUI.Forms Namespace


ColumnCount Property

[image]
Gizmox.WebGUI.Forms
ColumnCount Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutSettings Class : ColumnCount Property

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("The number of columns on the table.")>
<DefaultValueAttribute()>
<SRCategoryAttribute("Layout")>
Public Property ColumnCount As Integer
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutSettings
Dim value As Integer

instance.ColumnCount = value

value = instance.ColumnCount
C#
[SRDescriptionAttribute("The number of columns on the table.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Layout")]
public int ColumnCount {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("The number of columns on the table.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Layout")]
public: __property int get_ColumnCount();
public: __property void set_ColumnCount(
   int value
);
C++/CLI
[SRDescriptionAttribute("The number of columns on the table.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Layout")]
public:
property int ColumnCount {
   int get();
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutSettings Class
TableLayoutSettings Members


ColumnStyles Property

[image]
Gizmox.WebGUI.Forms
ColumnStyles Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutSettings Class : ColumnStyles Property

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Layout")>
<DesignerSerializationVisibilityAttribute()>
<SRDescriptionAttribute("The column styles of the table.")>
Public ReadOnly Property ColumnStyles As TableLayoutColumnStyleCollection
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutSettings
Dim value As TableLayoutColumnStyleCollection

value = instance.ColumnStyles
C#
[SRCategoryAttribute("Layout")]
[DesignerSerializationVisibilityAttribute()]
[SRDescriptionAttribute("The column styles of the table.")]
public TableLayoutColumnStyleCollection ColumnStyles {get;}
Managed Extensions for C++
[SRCategoryAttribute("Layout")]
[DesignerSerializationVisibilityAttribute()]
[SRDescriptionAttribute("The column styles of the table.")]
public: __property TableLayoutColumnStyleCollection* get_ColumnStyles();
C++/CLI
[SRCategoryAttribute("Layout")]
[DesignerSerializationVisibilityAttribute()]
[SRDescriptionAttribute("The column styles of the table.")]
public:
property TableLayoutColumnStyleCollection^ ColumnStyles {
   TableLayoutColumnStyleCollection^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutSettings Class
TableLayoutSettings Members


GrowStyle Property

[image]
Gizmox.WebGUI.Forms
GrowStyle Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutSettings Class : GrowStyle Property

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Layout")>
<SRDescriptionAttribute("Indicates whether a TableLayoutPanel will expand to include new cells when all existing cells are occupied.")>
<DefaultValueAttribute()>
Public Property GrowStyle As TableLayoutPanelGrowStyle
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutSettings
Dim value As TableLayoutPanelGrowStyle

instance.GrowStyle = value

value = instance.GrowStyle
C#
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Indicates whether a TableLayoutPanel will expand to include new cells when all existing cells are occupied.")]
[DefaultValueAttribute()]
public TableLayoutPanelGrowStyle GrowStyle {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Indicates whether a TableLayoutPanel will expand to include new cells when all existing cells are occupied.")]
[DefaultValueAttribute()]
public: __property TableLayoutPanelGrowStyle get_GrowStyle();
public: __property void set_GrowStyle(
   TableLayoutPanelGrowStyle value
);
C++/CLI
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Indicates whether a TableLayoutPanel will expand to include new cells when all existing cells are occupied.")]
[DefaultValueAttribute()]
public:
property TableLayoutPanelGrowStyle GrowStyle {
   TableLayoutPanelGrowStyle get();
   void set (TableLayoutPanelGrowStylevalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutSettings Class
TableLayoutSettings Members


LayoutEngine Property

[image]
Gizmox.WebGUI.Forms
LayoutEngine Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutSettings Class : LayoutEngine Property

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property LayoutEngine As LayoutEngine
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutSettings
Dim value As LayoutEngine

value = instance.LayoutEngine
C#
public override LayoutEngine LayoutEngine {get;}
Managed Extensions for C++
public: __property LayoutEngine* get_LayoutEngine() override;
C++/CLI
public:
property LayoutEngine^ LayoutEngine {
   LayoutEngine^ get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutSettings Class
TableLayoutSettings Members


RowCount Property

[image]
Gizmox.WebGUI.Forms
RowCount Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutSettings Class : RowCount Property

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("The number of rows on the table.")>
<SRCategoryAttribute("Layout")>
<DefaultValueAttribute()>
Public Property RowCount As Integer
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutSettings
Dim value As Integer

instance.RowCount = value

value = instance.RowCount
C#
[SRDescriptionAttribute("The number of rows on the table.")]
[SRCategoryAttribute("Layout")]
[DefaultValueAttribute()]
public int RowCount {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("The number of rows on the table.")]
[SRCategoryAttribute("Layout")]
[DefaultValueAttribute()]
public: __property int get_RowCount();
public: __property void set_RowCount(
   int value
);
C++/CLI
[SRDescriptionAttribute("The number of rows on the table.")]
[SRCategoryAttribute("Layout")]
[DefaultValueAttribute()]
public:
property int RowCount {
   int get();
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutSettings Class
TableLayoutSettings Members


RowStyles Property

[image]
Gizmox.WebGUI.Forms
RowStyles Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutSettings Class : RowStyles Property

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Layout")>
<SRDescriptionAttribute("The row styles of the table.")>
<DesignerSerializationVisibilityAttribute()>
Public ReadOnly Property RowStyles As TableLayoutRowStyleCollection
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutSettings
Dim value As TableLayoutRowStyleCollection

value = instance.RowStyles
C#
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("The row styles of the table.")]
[DesignerSerializationVisibilityAttribute()]
public TableLayoutRowStyleCollection RowStyles {get;}
Managed Extensions for C++
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("The row styles of the table.")]
[DesignerSerializationVisibilityAttribute()]
public: __property TableLayoutRowStyleCollection* get_RowStyles();
C++/CLI
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("The row styles of the table.")]
[DesignerSerializationVisibilityAttribute()]
public:
property TableLayoutRowStyleCollection^ RowStyles {
   TableLayoutRowStyleCollection^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutSettings Class
TableLayoutSettings Members


TableLayoutSettingsTypeConverter Class

[image]
Gizmox.WebGUI.Forms
TableLayoutSettingsTypeConverter Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TableLayoutSettingsTypeConverter Class

Syntax

Visual Basic (Declaration)
Public Class TableLayoutSettingsTypeConverter
   Inherits TypeConverter
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutSettingsTypeConverter
C#
public class TableLayoutSettingsTypeConverter : TypeConverter
Managed Extensions for C++
public __gc class TableLayoutSettingsTypeConverter : public TypeConverter
C++/CLI
public ref class TableLayoutSettingsTypeConverter : public TypeConverter

Inheritance Hierarchy

System.Object
System.ComponentModel.TypeConverter
Gizmox.WebGUI.Forms.TableLayoutSettingsTypeConverter

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

TableLayoutSettingsTypeConverter Members
Gizmox.WebGUI.Forms Namespace


TableLayoutSettingsTypeConverter Class Members

[image]
Gizmox.WebGUI.Forms
TableLayoutSettingsTypeConverter Class Members
See Also Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : TableLayoutSettingsTypeConverter Class

The following tables list the members exposed by TableLayoutSettingsTypeConverter.

Public Constructors

 | Name | Description
Public Constructor | TableLayoutSettingsTypeConverter Constructor |
Top

Public Methods

 | Name | Description
Public Method | CanConvertFrom | Overloaded. Overridden. Returns whether this converter can convert an object of the given type to the type of this converter.
Public Method | CanConvertTo | Overloaded. Overridden. Returns whether this converter can convert the object to the specified type.
Public Method | ConvertFrom | Overloaded. Overridden. Converts the given value to the type of this converter.
Public Method | ConvertFromInvariantString | Overloaded. Converts the given string to the type of this converter, using the invariant culture. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertFromString | Overloaded. Converts the specified text to an object. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertTo | Overloaded. Overridden. Converts the given value object to the specified type, using the arguments.
Public Method | ConvertToInvariantString | Overloaded. Converts the specified value to a culture-invariant string representation. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertToString | Overloaded. Converts the specified value to a string representation. (Inherited from System.ComponentModel.TypeConverter)
Public Method | CreateInstance | Overloaded. Re-creates an Object given a set of property values for the object. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetCreateInstanceSupported | Overloaded. Returns whether changing a value on this object requires a call to the CreateInstance method to create a new value. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetProperties | Overloaded. Returns a collection of properties for the type of array specified by the value parameter. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetPropertiesSupported | Overloaded. Returns whether this object supports properties. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValues | Overloaded. Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValuesExclusive | Overloaded. Returns whether the collection of standard values returned from GetStandardValues is an exclusive list. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValuesSupported | Overloaded. Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from System.ComponentModel.TypeConverter)
Public Method | IsValid | Overloaded. Returns whether the given value object is valid for this type. (Inherited from System.ComponentModel.TypeConverter)
Top

Protected Methods

 | Name | Description
Protected Method | GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from System.ComponentModel.TypeConverter)
Protected Method | GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from System.ComponentModel.TypeConverter)
Protected Method | SortProperties | (Inherited from System.ComponentModel.TypeConverter)
Top

See Also

Reference

TableLayoutSettingsTypeConverter Class
Gizmox.WebGUI.Forms Namespace


TableLayoutSettingsTypeConverter Constructor

[image]
Gizmox.WebGUI.Forms
TableLayoutSettingsTypeConverter Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutSettingsTypeConverter Class : TableLayoutSettingsTypeConverter Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutSettingsTypeConverter()
C#
public TableLayoutSettingsTypeConverter()
Managed Extensions for C++
public: TableLayoutSettingsTypeConverter();
C++/CLI
public:
TableLayoutSettingsTypeConverter();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutSettingsTypeConverter Class
TableLayoutSettingsTypeConverter Members


TableLayoutSettingsTypeConverter Class Methods

[image]
Gizmox.WebGUI.Forms
TableLayoutSettingsTypeConverter Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TableLayoutSettingsTypeConverter Class

For a list of all members of this type, see TableLayoutSettingsTypeConverter members.

Public Methods

 | Name | Description
Public Method | CanConvertFrom | Overloaded. Overridden. Returns whether this converter can convert an object of the given type to the type of this converter.
Public Method | CanConvertTo | Overloaded. Overridden. Returns whether this converter can convert the object to the specified type.
Public Method | ConvertFrom | Overloaded. Overridden. Converts the given value to the type of this converter.
Public Method | ConvertFromInvariantString | Overloaded. Converts the given string to the type of this converter, using the invariant culture. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertFromString | Overloaded. Converts the specified text to an object. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertTo | Overloaded. Overridden. Converts the given value object to the specified type, using the arguments.
Public Method | ConvertToInvariantString | Overloaded. Converts the specified value to a culture-invariant string representation. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertToString | Overloaded. Converts the specified value to a string representation. (Inherited from System.ComponentModel.TypeConverter)
Public Method | CreateInstance | Overloaded. Re-creates an Object given a set of property values for the object. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetCreateInstanceSupported | Overloaded. Returns whether changing a value on this object requires a call to the CreateInstance method to create a new value. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetProperties | Overloaded. Returns a collection of properties for the type of array specified by the value parameter. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetPropertiesSupported | Overloaded. Returns whether this object supports properties. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValues | Overloaded. Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValuesExclusive | Overloaded. Returns whether the collection of standard values returned from GetStandardValues is an exclusive list. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValuesSupported | Overloaded. Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from System.ComponentModel.TypeConverter)
Public Method | IsValid | Overloaded. Returns whether the given value object is valid for this type. (Inherited from System.ComponentModel.TypeConverter)
Top

Protected Methods

 | Name | Description
Protected Method | GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from System.ComponentModel.TypeConverter)
Protected Method | GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from System.ComponentModel.TypeConverter)
Protected Method | SortProperties | (Inherited from System.ComponentModel.TypeConverter)
Top

See Also

Reference

TableLayoutSettingsTypeConverter Class
Gizmox.WebGUI.Forms Namespace


CanConvertFrom Method

[image]
Gizmox.WebGUI.Forms
CanConvertFrom Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutSettingsTypeConverter Class : CanConvertFrom Method

Returns whether this converter can convert an object of the given type to the type of this converter.

Overload List

Overload | Description
CanConvertFrom(ITypeDescriptorContext,Type) |
CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from System.ComponentModel.TypeConverter)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutSettingsTypeConverter Class
TableLayoutSettingsTypeConverter Members


CanConvertFrom(ITypeDescriptorContext,Type) Method

[image]
Gizmox.WebGUI.Forms
CanConvertFrom(ITypeDescriptorContext,Type) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutSettingsTypeConverter Class > CanConvertFrom Method : CanConvertFrom(ITypeDescriptorContext,Type) Method

context
sourceType

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function CanConvertFrom( _
   ByVal context As ITypeDescriptorContext, _
   ByVal sourceType As Type _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutSettingsTypeConverter
Dim context As ITypeDescriptorContext
Dim sourceType As Type
Dim value As Boolean

value = instance.CanConvertFrom(context, sourceType)
C#
public override bool CanConvertFrom(
   ITypeDescriptorContext context,
   Type sourceType
)
Managed Extensions for C++
public: bool CanConvertFrom(
   ITypeDescriptorContext* context,
   Type* sourceType
) override
C++/CLI
public:
bool CanConvertFrom(
   ITypeDescriptorContext^ context,
   Type^ sourceType
) override

Parameters

context
sourceType

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutSettingsTypeConverter Class
TableLayoutSettingsTypeConverter Members
Overload List


CanConvertTo Method

[image]
Gizmox.WebGUI.Forms
CanConvertTo Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutSettingsTypeConverter Class : CanConvertTo Method

Returns whether this converter can convert the object to the specified type.

Overload List

Overload | Description
CanConvertTo(ITypeDescriptorContext,Type) |
CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from System.ComponentModel.TypeConverter)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutSettingsTypeConverter Class
TableLayoutSettingsTypeConverter Members


CanConvertTo(ITypeDescriptorContext,Type) Method

[image]
Gizmox.WebGUI.Forms
CanConvertTo(ITypeDescriptorContext,Type) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutSettingsTypeConverter Class > CanConvertTo Method : CanConvertTo(ITypeDescriptorContext,Type) Method

context
destinationType

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function CanConvertTo( _
   ByVal context As ITypeDescriptorContext, _
   ByVal destinationType As Type _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutSettingsTypeConverter
Dim context As ITypeDescriptorContext
Dim destinationType As Type
Dim value As Boolean

value = instance.CanConvertTo(context, destinationType)
C#
public override bool CanConvertTo(
   ITypeDescriptorContext context,
   Type destinationType
)
Managed Extensions for C++
public: bool CanConvertTo(
   ITypeDescriptorContext* context,
   Type* destinationType
) override
C++/CLI
public:
bool CanConvertTo(
   ITypeDescriptorContext^ context,
   Type^ destinationType
) override

Parameters

context
destinationType

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutSettingsTypeConverter Class
TableLayoutSettingsTypeConverter Members
Overload List


ConvertFrom Method

[image]
Gizmox.WebGUI.Forms
ConvertFrom Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutSettingsTypeConverter Class : ConvertFrom Method

Converts the given value to the type of this converter.

Overload List

Overload | Description
ConvertFrom(ITypeDescriptorContext,CultureInfo,Object) |
ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from System.ComponentModel.TypeConverter)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutSettingsTypeConverter Class
TableLayoutSettingsTypeConverter Members


ConvertFrom(ITypeDescriptorContext,CultureInfo,Object) Method

[image]
Gizmox.WebGUI.Forms
ConvertFrom(ITypeDescriptorContext,CultureInfo,Object) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutSettingsTypeConverter Class > ConvertFrom Method : ConvertFrom(ITypeDescriptorContext,CultureInfo,Object) Method

context
culture
value

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function ConvertFrom( _
   ByVal context As ITypeDescriptorContext, _
   ByVal culture As CultureInfo, _
   ByVal value As Object _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutSettingsTypeConverter
Dim context As ITypeDescriptorContext
Dim culture As CultureInfo
Dim value As Object
Dim value As Object

value = instance.ConvertFrom(context, culture, value)
C#
public override object ConvertFrom(
   ITypeDescriptorContext context,
   CultureInfo culture,
   object value
)
Managed Extensions for C++
public: Object* ConvertFrom(
   ITypeDescriptorContext* context,
   CultureInfo* culture,
   Object* value
) override
C++/CLI
public:
Object^ ConvertFrom(
   ITypeDescriptorContext^ context,
   CultureInfo^ culture,
   Object^ value
) override

Parameters

context
culture
value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutSettingsTypeConverter Class
TableLayoutSettingsTypeConverter Members
Overload List


ConvertTo Method

[image]
Gizmox.WebGUI.Forms
ConvertTo Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutSettingsTypeConverter Class : ConvertTo Method

Converts the given value object to the specified type, using the arguments.

Overload List

Overload | Description
ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) |
ConvertTo(Object,Type) | Converts the given value object to the specified type, using the arguments. (Inherited from System.ComponentModel.TypeConverter)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutSettingsTypeConverter Class
TableLayoutSettingsTypeConverter Members


ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) Method

[image]
Gizmox.WebGUI.Forms
ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutSettingsTypeConverter Class > ConvertTo Method : ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) Method

context
culture
value
destinationType

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function ConvertTo( _
   ByVal context As ITypeDescriptorContext, _
   ByVal culture As CultureInfo, _
   ByVal value As Object, _
   ByVal destinationType As Type _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutSettingsTypeConverter
Dim context As ITypeDescriptorContext
Dim culture As CultureInfo
Dim value As Object
Dim destinationType As Type
Dim value As Object

value = instance.ConvertTo(context, culture, value, destinationType)
C#
public override object ConvertTo(
   ITypeDescriptorContext context,
   CultureInfo culture,
   object value,
   Type destinationType
)
Managed Extensions for C++
public: Object* ConvertTo(
   ITypeDescriptorContext* context,
   CultureInfo* culture,
   Object* value,
   Type* destinationType
) override
C++/CLI
public:
Object^ ConvertTo(
   ITypeDescriptorContext^ context,
   CultureInfo^ culture,
   Object^ value,
   Type^ destinationType
) override

Parameters

context
culture
value
destinationType

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutSettingsTypeConverter Class
TableLayoutSettingsTypeConverter Members
Overload List


TableLayoutStyle Class

[image]
Gizmox.WebGUI.Forms
TableLayoutStyle Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TableLayoutStyle Class

Syntax

Visual Basic (Declaration)
<DesignTimeControllerAttribute()>
<ClientControllerAttribute()>
<TypeConverterAttribute("Gizmox.WebGUI.Forms.TableLayoutSettings+StyleConverter, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d")>
Public MustInherit Class TableLayoutStyle
   Implements IObservableItem
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutStyle
C#
[DesignTimeControllerAttribute()]
[ClientControllerAttribute()]
[TypeConverterAttribute("Gizmox.WebGUI.Forms.TableLayoutSettings+StyleConverter, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d")]
public abstract class TableLayoutStyle : IObservableItem
Managed Extensions for C++
[DesignTimeControllerAttribute()]
[ClientControllerAttribute()]
[TypeConverterAttribute("Gizmox.WebGUI.Forms.TableLayoutSettings+StyleConverter, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d")]
public __gc abstract class TableLayoutStyle : public IObservableItem
C++/CLI
[DesignTimeControllerAttribute()]
[ClientControllerAttribute()]
[TypeConverterAttribute("Gizmox.WebGUI.Forms.TableLayoutSettings+StyleConverter, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d")]
public ref class TableLayoutStyle abstract : public IObservableItem

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.TableLayoutStyle
Gizmox.WebGUI.Forms.ColumnStyle
Gizmox.WebGUI.Forms.RowStyle

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

TableLayoutStyle Members
Gizmox.WebGUI.Forms Namespace


TableLayoutStyle Class Members

[image]
Gizmox.WebGUI.Forms
TableLayoutStyle Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : TableLayoutStyle Class

The following tables list the members exposed by TableLayoutStyle.

Public Properties

 | Name | Description
Public Property | SizeType |
Top

Protected Methods

 | Name | Description
Protected Method | FireObservableItemPropertyChanged | Fires the ObservableItemPropertyChanged event of the IObservableItem interface.
Top

See Also

Reference

TableLayoutStyle Class
Gizmox.WebGUI.Forms Namespace


TableLayoutStyle Class Methods

[image]
Gizmox.WebGUI.Forms
TableLayoutStyle Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TableLayoutStyle Class

For a list of all members of this type, see TableLayoutStyle members.

Protected Methods

 | Name | Description
Protected Method | FireObservableItemPropertyChanged | Fires the ObservableItemPropertyChanged event of the IObservableItem interface.
Top

See Also

Reference

TableLayoutStyle Class
Gizmox.WebGUI.Forms Namespace


FireObservableItemPropertyChanged Method

[image]
Gizmox.WebGUI.Forms
FireObservableItemPropertyChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutStyle Class : FireObservableItemPropertyChanged Method

strProperty
The name of the property that has changed
Fires the ObservableItemPropertyChanged event of the IObservableItem interface.

Syntax

Visual Basic (Declaration)
Protected Sub FireObservableItemPropertyChanged( _
   ByVal strProperty As String _
)
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutStyle
Dim strProperty As String

instance.FireObservableItemPropertyChanged(strProperty)
C#
protected void FireObservableItemPropertyChanged(
   string strProperty
)
Managed Extensions for C++
protected: void FireObservableItemPropertyChanged(
   string* strProperty
)
C++/CLI
protected:
void FireObservableItemPropertyChanged(
   String^ strProperty
)

Parameters

strProperty
The name of the property that has changed

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutStyle Class
TableLayoutStyle Members


TableLayoutStyle Class Properties

[image]
Gizmox.WebGUI.Forms
TableLayoutStyle Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TableLayoutStyle Class

For a list of all members of this type, see TableLayoutStyle members.

Public Properties

 | Name | Description
Public Property | SizeType |
Top

See Also

Reference

TableLayoutStyle Class
Gizmox.WebGUI.Forms Namespace


SizeType Property

[image]
Gizmox.WebGUI.Forms
SizeType Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutStyle Class : SizeType Property

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property SizeType As SizeType
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutStyle
Dim value As SizeType

instance.SizeType = value

value = instance.SizeType
C#
[DefaultValueAttribute()]
public SizeType SizeType {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property SizeType get_SizeType();
public: __property void set_SizeType(
   SizeType value
);
C++/CLI
[DefaultValueAttribute()]
public:
property SizeType SizeType {
   SizeType get();
   void set (SizeTypevalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutStyle Class
TableLayoutStyle Members


TableLayoutStyleCollection Class

[image]
Gizmox.WebGUI.Forms
TableLayoutStyleCollection Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TableLayoutStyleCollection Class

Object Model

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
<EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.StyleCollectionEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")>
<DesignTimeControllerAttribute()>
<ClientControllerAttribute()>
Public MustInherit Class TableLayoutStyleCollection
   Implements IObservableList
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutStyleCollection
C#
[DefaultMemberAttribute("Item")]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.StyleCollectionEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[DesignTimeControllerAttribute()]
[ClientControllerAttribute()]
public abstract class TableLayoutStyleCollection : IObservableList
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.StyleCollectionEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[DesignTimeControllerAttribute()]
[ClientControllerAttribute()]
public __gc abstract class TableLayoutStyleCollection : public IObservableList
C++/CLI
[DefaultMemberAttribute("Item")]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.StyleCollectionEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[DesignTimeControllerAttribute()]
[ClientControllerAttribute()]
public ref class TableLayoutStyleCollection abstract : public IObservableList

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.TableLayoutStyleCollection
Gizmox.WebGUI.Forms.TableLayoutColumnStyleCollection
Gizmox.WebGUI.Forms.TableLayoutRowStyleCollection

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

TableLayoutStyleCollection Members
Gizmox.WebGUI.Forms Namespace


TableLayoutStyleCollection Class Members

[image]
Gizmox.WebGUI.Forms
TableLayoutStyleCollection Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : TableLayoutStyleCollection Class

The following tables list the members exposed by TableLayoutStyleCollection.

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item |
Top

Public Methods

 | Name | Description
Public Method | Add |
Public Method | Clear |
Public Method | RemoveAt |
Top

See Also

Reference

TableLayoutStyleCollection Class
Gizmox.WebGUI.Forms Namespace


TableLayoutStyleCollection Class Methods

[image]
Gizmox.WebGUI.Forms
TableLayoutStyleCollection Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TableLayoutStyleCollection Class

For a list of all members of this type, see TableLayoutStyleCollection members.

Public Methods

 | Name | Description
Public Method | Add |
Public Method | Clear |
Public Method | RemoveAt |
Top

See Also

Reference

TableLayoutStyleCollection Class
Gizmox.WebGUI.Forms Namespace


Add Method

[image]
Gizmox.WebGUI.Forms
Add Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutStyleCollection Class : Add Method

style

Syntax

Visual Basic (Declaration)
Public Function Add( _
   ByVal style As TableLayoutStyle _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutStyleCollection
Dim style As TableLayoutStyle
Dim value As Integer

value = instance.Add(style)
C#
public int Add(
   TableLayoutStyle style
)
Managed Extensions for C++
public: int Add(
   TableLayoutStyle* style
)
C++/CLI
public:
int Add(
   TableLayoutStyle^ style
)

Parameters

style

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutStyleCollection Class
TableLayoutStyleCollection Members


Clear Method

[image]
Gizmox.WebGUI.Forms
Clear Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutStyleCollection Class : Clear Method

Syntax

Visual Basic (Declaration)
Public Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutStyleCollection

instance.Clear()
C#
public void Clear()
Managed Extensions for C++
public: void Clear();
C++/CLI
public:
void Clear();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutStyleCollection Class
TableLayoutStyleCollection Members


RemoveAt Method

[image]
Gizmox.WebGUI.Forms
RemoveAt Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutStyleCollection Class : RemoveAt Method

index

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutStyleCollection
Dim index As Integer

instance.RemoveAt(index)
C#
public void RemoveAt(
   int index
)
Managed Extensions for C++
public: void RemoveAt(
   int index
)
C++/CLI
public:
void RemoveAt(
   int index
)

Parameters

index

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutStyleCollection Class
TableLayoutStyleCollection Members


TableLayoutStyleCollection Class Properties

[image]
Gizmox.WebGUI.Forms
TableLayoutStyleCollection Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TableLayoutStyleCollection Class

For a list of all members of this type, see TableLayoutStyleCollection members.

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item |
Top

See Also

Reference

TableLayoutStyleCollection Class
Gizmox.WebGUI.Forms Namespace


Count Property

[image]
Gizmox.WebGUI.Forms
Count Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutStyleCollection Class : Count Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutStyleCollection
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutStyleCollection Class
TableLayoutStyleCollection Members


Item Property

[image]
Gizmox.WebGUI.Forms
Item Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutStyleCollection Class : Item Property

index

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal index As Integer _
) As TableLayoutStyle
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutStyleCollection
Dim index As Integer
Dim value As TableLayoutStyle

instance.Item(index) = value

value = instance.Item(index)
C#
public TableLayoutStyle this[
   int index
]; {get; set;}
Managed Extensions for C++
public: __property TableLayoutStyle* get_Item(
   int index
);
public: __property void set_Item(
   int index,
   TableLayoutStyle* value
);
C++/CLI
public:
property TableLayoutStyle^ default [int] {
   TableLayoutStyle^ get(intindex);
   void set (intindex, TableLayoutStyle^value);
}

Parameters

index

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutStyleCollection Class
TableLayoutStyleCollection Members


TabPage Class

[image]
Gizmox.WebGUI.Forms
TabPage Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TabPage Class

Represents a single tab page in a TabControl.

Object Model

Syntax

Visual Basic (Declaration)
<ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")>
<DesignTimeVisibleAttribute()>
<ClientControllerAttribute()>
<DesignTimeControllerAttribute()>
<DefaultPropertyAttribute("Text")>
<MetadataTagAttribute("TP")>
Public Class TabPage
   Inherits Panel
   Implements IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Visual Basic (Usage) Copy Code
Dim instance As TabPage
C#
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
[DesignTimeVisibleAttribute()]
[ClientControllerAttribute()]
[DesignTimeControllerAttribute()]
[DefaultPropertyAttribute("Text")]
[MetadataTagAttribute("TP")]
public class TabPage : Panel, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Managed Extensions for C++
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
[DesignTimeVisibleAttribute()]
[ClientControllerAttribute()]
[DesignTimeControllerAttribute()]
[DefaultPropertyAttribute("Text")]
[MetadataTagAttribute("TP")]
public __gc class TabPage : public Panel, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
C++/CLI
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
[DesignTimeVisibleAttribute()]
[ClientControllerAttribute()]
[DesignTimeControllerAttribute()]
[DefaultPropertyAttribute("Text")]
[MetadataTagAttribute("TP")]
public ref class TabPage : public Panel, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.ScrollableControl
Gizmox.WebGUI.Forms.Panel
Gizmox.WebGUI.Forms.TabPage
Gizmox.WebGUI.Forms.NavigationTab
Gizmox.WebGUI.Forms.WorkspaceTab

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

TabPage Members
Gizmox.WebGUI.Forms Namespace


TabPage Class Members

[image]
Gizmox.WebGUI.Forms
TabPage Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : TabPage Class

The following tables list the members exposed by TabPage.

Public Constructors

 | Name | Description
Public Constructor | TabPage Constructor | Overloaded. Initializes a new instance of the TabPage class.
Top

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl)
Public Property | AutoSize | (Inherited from Panel)
Public Property | AutoSizeMode | Indicates the automatic sizing behavior of the control. (Inherited from Panel)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Gets a value indicating whether this control can recive focus. (Inherited from Panel)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | Image | Gets or sets the image.
Public Property | ImageIndex | Gets or sets the index of the image that is displayed for the item.
Public Property | ImageKey | Gets or sets the key for the image that is displayed for the item.
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Loaded | Gets a value indicating whether this TabPage is loaded.
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | PanelType | Gets or sets the panel type.
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | TabControl | Gets the TabControl control.
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Overridden. Gets or sets the text to display on the tab.
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | Visible | Overridden. Gets or sets the control visability.
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Protected Property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl)
Top

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | CompareTo | Compares the current instance with another object of the same type.
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | Overridden. Returns a string containing the value of the Text property.
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Control)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from ScrollableControl)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Control)
Protected Method | RenderAttributes | Overridden. Render control attributes
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Overridden. Renders the controls sub tree
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | (Inherited from Panel)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeImage | Shows the serialize image.
Protected Method | ShouldSerializePanelType | (Inherited from Panel)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

TabPage Class
Gizmox.WebGUI.Forms Namespace


TabPage Constructor

[image]
Gizmox.WebGUI.Forms
TabPage Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TabPage Class : TabPage Constructor

Initializes a new instance of the TabPage class.

Overload List

Overload | Description
TabPage Constructor() | Initializes a new instance of the TabPage class.
TabPage Constructor(String) | Initializes a new instance of the TabPage class and specifies the text for the tab.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TabPage Class
TabPage Members


TabPage Constructor()

[image]
Gizmox.WebGUI.Forms
TabPage Constructor()
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TabPage Class > TabPage Constructor : TabPage Constructor()

Initializes a new instance of the TabPage class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As TabPage()
C#
public TabPage()
Managed Extensions for C++
public: TabPage();
C++/CLI
public:
TabPage();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TabPage Class
TabPage Members
Overload List


TabPage Constructor(String)

[image]
Gizmox.WebGUI.Forms
TabPage Constructor(String)
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TabPage Class > TabPage Constructor : TabPage Constructor(String)

strText
The text for the tab.
Initializes a new instance of the TabPage class and specifies the text for the tab.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal strText As String _
)
Visual Basic (Usage) Copy Code
Dim strText As String

Dim instance As TabPage(strText)
C#
public TabPage(
   string strText
)
Managed Extensions for C++
public: TabPage(
   string* strText
)
C++/CLI
public:
TabPage(
   String^ strText
)

Parameters

strText
The text for the tab.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TabPage Class
TabPage Members
Overload List


TabPage Class Methods

[image]
Gizmox.WebGUI.Forms
TabPage Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TabPage Class

For a list of all members of this type, see TabPage members.

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | CompareTo | Compares the current instance with another object of the same type.
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | Overridden. Returns a string containing the value of the Text property.
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Control)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from ScrollableControl)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Control)
Protected Method | RenderAttributes | Overridden. Render control attributes
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Overridden. Renders the controls sub tree
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | (Inherited from Panel)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeImage | Shows the serialize image.
Protected Method | ShouldSerializePanelType | (Inherited from Panel)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

See Also

Reference

TabPage Class
Gizmox.WebGUI.Forms Namespace


CompareTo Method

[image]
Gizmox.WebGUI.Forms
CompareTo Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TabPage Class : CompareTo Method

obj
An object to compare with this instance.
Compares the current instance with another object of the same type.

Syntax

Visual Basic (Declaration)
Public Function CompareTo( _
   ByVal obj As Object _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As TabPage
Dim obj As Object
Dim value As Integer

value = instance.CompareTo(obj)
C#
public int CompareTo(
   object obj
)
Managed Extensions for C++
public: int CompareTo(
   Object* obj
)
C++/CLI
public:
int CompareTo(
   Object^ obj
)

Parameters

obj
An object to compare with this instance.

Return Value

A 32-bit signed integer that indicates the relative order of the objects being compared. The return value has these meanings: Value Meaning Less than zero This instance is less than obj. Zero This instance is equal to obj. Greater than zero This instance is greater than obj.

Exceptions

Exception | Description
ArgumentException | obj is not the same type as this instance.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TabPage Class
TabPage Members


RenderAttributes Method

[image]
Gizmox.WebGUI.Forms
RenderAttributes Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TabPage Class : RenderAttributes Method

objContext
Request context.
objWriter
The response writer object.
Render control attributes

Syntax

Visual Basic (Declaration)
Protected Overrides Sub RenderAttributes( _
   ByVal objContext As IContext, _
   ByVal objWriter As IAttributeWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As TabPage
Dim objContext As IContext
Dim objWriter As IAttributeWriter

instance.RenderAttributes(objContext, objWriter)
C#
protected override void RenderAttributes(
   IContext objContext,
   IAttributeWriter objWriter
)
Managed Extensions for C++
protected: void RenderAttributes(
   IContext* objContext,
   IAttributeWriter* objWriter
) override
C++/CLI
protected:
void RenderAttributes(
   IContext^ objContext,
   IAttributeWriter^ objWriter
) override

Parameters

objContext
Request context.
objWriter
The response writer object.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TabPage Class
TabPage Members


RenderControls Method

[image]
Gizmox.WebGUI.Forms
RenderControls Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TabPage Class : RenderControls Method

Renders the controls sub tree

Overload List

Overload | Description
RenderControls(IContext,IResponseWriter,Int64) | Renders the controls sub tree
RenderControls(IContext,IResponseWriter,Int64,Boolean) | Renders the controls sub tree (Inherited from Control)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TabPage Class
TabPage Members


RenderControls(IContext,IResponseWriter,Int64) Method

[image]
Gizmox.WebGUI.Forms
RenderControls(IContext,IResponseWriter,Int64) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TabPage Class > RenderControls Method : RenderControls(IContext,IResponseWriter,Int64) Method

objContext
Request context.
objWriter
The response writer object.
lngRequestID
Request ID.
Renders the controls sub tree

Syntax

Visual Basic (Declaration)
Protected Overloads Overrides Sub RenderControls( _
   ByVal objContext As IContext, _
   ByVal objWriter As IResponseWriter, _
   ByVal lngRequestID As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As TabPage
Dim objContext As IContext
Dim objWriter As IResponseWriter
Dim lngRequestID As Long

instance.RenderControls(objContext, objWriter, lngRequestID)
C#
protected override void RenderControls(
   IContext objContext,
   IResponseWriter objWriter,
   long lngRequestID
)
Managed Extensions for C++
protected: void RenderControls(
   IContext* objContext,
   IResponseWriter* objWriter,
   long lngRequestID
) override
C++/CLI
protected:
void RenderControls(
   IContext^ objContext,
   IResponseWriter^ objWriter,
   long long lngRequestID
) override

Parameters

objContext
Request context.
objWriter
The response writer object.
lngRequestID
Request ID.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TabPage Class
TabPage Members
Overload List


ShouldSerializeImage Method

[image]
Gizmox.WebGUI.Forms
ShouldSerializeImage Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TabPage Class : ShouldSerializeImage Method

Shows the serialize image.

Syntax

Visual Basic (Declaration)
Protected Function ShouldSerializeImage() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TabPage
Dim value As Boolean

value = instance.ShouldSerializeImage()
C#
protected bool ShouldSerializeImage()
Managed Extensions for C++
protected: bool ShouldSerializeImage();
C++/CLI
protected:
bool ShouldSerializeImage();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TabPage Class
TabPage Members


ToString Method

[image]
Gizmox.WebGUI.Forms
ToString Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TabPage Class : ToString Method

Returns a string containing the value of the Text property.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As TabPage
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Return Value

A string containing the value of the Text property.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TabPage Class
TabPage Members


TabPage Class Properties

[image]
Gizmox.WebGUI.Forms
TabPage Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TabPage Class

For a list of all members of this type, see TabPage members.

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl)
Public Property | AutoSize | (Inherited from Panel)
Public Property | AutoSizeMode | Indicates the automatic sizing behavior of the control. (Inherited from Panel)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Gets a value indicating whether this control can recive focus. (Inherited from Panel)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | Image | Gets or sets the image.
Public Property | ImageIndex | Gets or sets the index of the image that is displayed for the item.
Public Property | ImageKey | Gets or sets the key for the image that is displayed for the item.
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Loaded | Gets a value indicating whether this TabPage is loaded.
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | PanelType | Gets or sets the panel type.
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | TabControl | Gets the TabControl control.
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Overridden. Gets or sets the text to display on the tab.
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | Visible | Overridden. Gets or sets the control visability.
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Protected Property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl)
Top

See Also

Reference

TabPage Class
Gizmox.WebGUI.Forms Namespace


Image Property

[image]
Gizmox.WebGUI.Forms
Image Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TabPage Class : Image Property

Gets or sets the image.

Syntax

Visual Basic (Declaration)
Public Property Image As ResourceHandle
Visual Basic (Usage) Copy Code
Dim instance As TabPage
Dim value As ResourceHandle

instance.Image = value

value = instance.Image
C#
public ResourceHandle Image {get; set;}
Managed Extensions for C++
public: __property ResourceHandle* get_Image();
public: __property void set_Image(
   ResourceHandle* value
);
C++/CLI
public:
property ResourceHandle^ Image {
   ResourceHandle^ get();
   void set (ResourceHandle^value);
}

Return Value

The image.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TabPage Class
TabPage Members


ImageIndex Property

[image]
Gizmox.WebGUI.Forms
ImageIndex Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TabPage Class : ImageIndex Property

Gets or sets the index of the image that is displayed for the item.

Syntax

Visual Basic (Declaration)
<RefreshPropertiesAttribute()>
<SRDescriptionAttribute("The ImageList index value of the image displayed when the list view item is in the unselected state.")>
<SRCategoryAttribute("Behavior")>
<LocalizableAttribute(True)>
<EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.ImageIndexEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")>
<TypeConverterAttribute("Gizmox.WebGUI.Forms.Design.NoneExcludedImageIndexConverter, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")>
<DefaultValueAttribute()>
Public Property ImageIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As TabPage
Dim value As Integer

instance.ImageIndex = value

value = instance.ImageIndex
C#
[RefreshPropertiesAttribute()]
[SRDescriptionAttribute("The ImageList index value of the image displayed when the list view item is in the unselected state.")]
[SRCategoryAttribute("Behavior")]
[LocalizableAttribute(true)]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.ImageIndexEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[TypeConverterAttribute("Gizmox.WebGUI.Forms.Design.NoneExcludedImageIndexConverter, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[DefaultValueAttribute()]
public int ImageIndex {get; set;}
Managed Extensions for C++
[RefreshPropertiesAttribute()]
[SRDescriptionAttribute("The ImageList index value of the image displayed when the list view item is in the unselected state.")]
[SRCategoryAttribute("Behavior")]
[LocalizableAttribute(true)]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.ImageIndexEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[TypeConverterAttribute("Gizmox.WebGUI.Forms.Design.NoneExcludedImageIndexConverter, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[DefaultValueAttribute()]
public: __property int get_ImageIndex();
public: __property void set_ImageIndex(
   int value
);
C++/CLI
[RefreshPropertiesAttribute()]
[SRDescriptionAttribute("The ImageList index value of the image displayed when the list view item is in the unselected state.")]
[SRCategoryAttribute("Behavior")]
[LocalizableAttribute(true)]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.ImageIndexEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[TypeConverterAttribute("Gizmox.WebGUI.Forms.Design.NoneExcludedImageIndexConverter, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[DefaultValueAttribute()]
public:
property int ImageIndex {
   int get();
   void set (intvalue);
}

Exceptions

Exception | Description
ArgumentException | The value specified is less than -1.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TabPage Class
TabPage Members


ImageKey Property

[image]
Gizmox.WebGUI.Forms
ImageKey Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TabPage Class : ImageKey Property

Gets or sets the key for the image that is displayed for the item.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<LocalizableAttribute(True)>
<EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.ImageIndexEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")>
<RefreshPropertiesAttribute()>
<TypeConverterAttribute("Gizmox.WebGUI.Forms.Design.ImageKeyConverter, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")>
<SRCategoryAttribute("Behavior")>
Public Property ImageKey As String
Visual Basic (Usage) Copy Code
Dim instance As TabPage
Dim value As String

instance.ImageKey = value

value = instance.ImageKey
C#
[DefaultValueAttribute()]
[LocalizableAttribute(true)]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.ImageIndexEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[RefreshPropertiesAttribute()]
[TypeConverterAttribute("Gizmox.WebGUI.Forms.Design.ImageKeyConverter, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[SRCategoryAttribute("Behavior")]
public string ImageKey {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[LocalizableAttribute(true)]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.ImageIndexEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[RefreshPropertiesAttribute()]
[TypeConverterAttribute("Gizmox.WebGUI.Forms.Design.ImageKeyConverter, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[SRCategoryAttribute("Behavior")]
public: __property string* get_ImageKey();
public: __property void set_ImageKey(
   string* value
);
C++/CLI
[DefaultValueAttribute()]
[LocalizableAttribute(true)]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.ImageIndexEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[RefreshPropertiesAttribute()]
[TypeConverterAttribute("Gizmox.WebGUI.Forms.Design.ImageKeyConverter, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[SRCategoryAttribute("Behavior")]
public:
property String^ ImageKey {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TabPage Class
TabPage Members


Loaded Property

[image]
Gizmox.WebGUI.Forms
Loaded Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TabPage Class : Loaded Property

Gets a value indicating whether this TabPage is loaded.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property Loaded As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TabPage
Dim value As Boolean

value = instance.Loaded
C#
[BrowsableAttribute(false)]
public bool Loaded {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property bool get_Loaded();
C++/CLI
[BrowsableAttribute(false)]
public:
property bool Loaded {
   bool get();
}

Return Value

true if loaded; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TabPage Class
TabPage Members


PanelType Property

[image]
Gizmox.WebGUI.Forms
PanelType Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TabPage Class : PanelType Property

Gets or sets the panel type.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public Property PanelType As PanelType
Visual Basic (Usage) Copy Code
Dim instance As TabPage
Dim value As PanelType

instance.PanelType = value

value = instance.PanelType
C#
[BrowsableAttribute(false)]
public PanelType PanelType {get; set;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property PanelType get_PanelType();
public: __property void set_PanelType(
   PanelType value
);
C++/CLI
[BrowsableAttribute(false)]
public:
property PanelType PanelType {
   PanelType get();
   void set (PanelTypevalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TabPage Class
TabPage Members


TabControl Property

[image]
Gizmox.WebGUI.Forms
TabControl Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TabPage Class : TabControl Property

Gets the TabControl control.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property TabControl As TabControl
Visual Basic (Usage) Copy Code
Dim instance As TabPage
Dim value As TabControl

value = instance.TabControl
C#
[BrowsableAttribute(false)]
public TabControl TabControl {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property TabControl* get_TabControl();
C++/CLI
[BrowsableAttribute(false)]
public:
property TabControl^ TabControl {
   TabControl^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TabPage Class
TabPage Members


Text Property

[image]
Gizmox.WebGUI.Forms
Text Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TabPage Class : Text Property

Gets or sets the text to display on the tab.

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute()>
<LocalizableAttribute(True)>
<BrowsableAttribute(True)>
Public Overrides Property Text As String
Visual Basic (Usage) Copy Code
Dim instance As TabPage
Dim value As String

instance.Text = value

value = instance.Text
C#
[EditorBrowsableAttribute()]
[LocalizableAttribute(true)]
[BrowsableAttribute(true)]
public override string Text {get; set;}
Managed Extensions for C++
[EditorBrowsableAttribute()]
[LocalizableAttribute(true)]
[BrowsableAttribute(true)]
public: __property string* get_Text() override;
public: __property void set_Text(
   string* value
) override;
C++/CLI
[EditorBrowsableAttribute()]
[LocalizableAttribute(true)]
[BrowsableAttribute(true)]
public:
property String^ Text {
   String^ get() override;
   void set (String^value) override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TabPage Class
TabPage Members


Visible Property

[image]
Gizmox.WebGUI.Forms
Visible Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TabPage Class : Visible Property

Gets or sets the control visability.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<SRDescriptionAttribute("Determines whether the control is visible or hidden.")>
<SRCategoryAttribute("Behavior")>
Public Overrides Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TabPage
Dim value As Boolean

instance.Visible = value

value = instance.Visible
C#
[DefaultValueAttribute()]
[SRDescriptionAttribute("Determines whether the control is visible or hidden.")]
[SRCategoryAttribute("Behavior")]
public override bool Visible {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[SRDescriptionAttribute("Determines whether the control is visible or hidden.")]
[SRCategoryAttribute("Behavior")]
public: __property bool get_Visible() override;
public: __property void set_Visible(
   bool value
) override;
C++/CLI
[DefaultValueAttribute()]
[SRDescriptionAttribute("Determines whether the control is visible or hidden.")]
[SRCategoryAttribute("Behavior")]
public:
property bool Visible {
   bool get() override;
   void set (boolvalue) override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TabPage Class
TabPage Members


TabPageCollection Class

[image]
Gizmox.WebGUI.Forms
TabPageCollection Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TabPageCollection Class

Contains a collection of TabPage objects.

Object Model

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class TabPageCollection
Visual Basic (Usage) Copy Code
Dim instance As TabPageCollection
C#
[DefaultMemberAttribute("Item")]
public class TabPageCollection
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
public __gc class TabPageCollection
C++/CLI
[DefaultMemberAttribute("Item")]
public ref class TabPageCollection

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.TabPageCollection
Gizmox.WebGUI.Forms.NavigationTabCollection
Gizmox.WebGUI.Forms.WorkspaceTabsCollection

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

TabPageCollection Members
Gizmox.WebGUI.Forms Namespace


TabPageCollection Class Members

[image]
Gizmox.WebGUI.Forms
TabPageCollection Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : TabPageCollection Class

The following tables list the members exposed by TabPageCollection.

Public Properties

 | Name | Description
Public Property | Count | Gets the number of tab pages in the collection.
Public Property | IsFixedSize | Gets a value indicating whether the TabPageCollection has a fixed size.
Public Property | IsReadOnly | Gets a value indicating whether the collection is read-only.
Public Property | IsSynchronized | Gets a value indicating whether access to the TabPageCollection is synchronized (thread safe).
Public Property | Item | Gets or sets a TabPage in the collection.
Public Property | SyncRoot | Gets an object that can be used to synchronize access to the TabPageCollection.
Top

Public Methods

 | Name | Description
Public Method | Add | Adds a TabPage to the collection.
Public Method | Clear | Removes all the tab pages from the collection.
Public Method | Compare | Compares the index of two sequencial TabPages in the TabPageCollection.
Public Method | Contains | Determines whether the specified TabPage control is in the TabPageCollection.
Public Method | CopyTo | Copies the elements of the collection to the specified array, starting at the specified index.
Public Method | GetEnumerator | Returns an enumeration of all the tab pages in the collection.
Public Method | IndexOf | Returns the index of the specified tab page in the collection.
Public Method | Insert | Inserts an existing tab page into the collection at the specified index.
Public Method | Remove | Removes a TabPage from the collection.
Public Method | RemoveAt | Removes the tab page at the specified index from the collection.
Top

Protected Methods

 | Name | Description
Protected Method | AdvanceTabIndexFromIndex | Overloaded. Advances the TabIndex property by the value of 'advanceBy', begginning at the 'fromIndex' position.
Protected Method | GetSortedTabPageListFromCurrent | Returns a sorted TabPage list from current unsorted TabPageCollection.
Top

See Also

Reference

TabPageCollection Class
Gizmox.WebGUI.Forms Namespace


TabPageCollection Class Methods

[image]
Gizmox.WebGUI.Forms
TabPageCollection Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TabPageCollection Class

For a list of all members of this type, see TabPageCollection members.

Public Methods

 | Name | Description
Public Method | Add | Adds a TabPage to the collection.
Public Method | Clear | Removes all the tab pages from the collection.
Public Method | Compare | Compares the index of two sequencial TabPages in the TabPageCollection.
Public Method | Contains | Determines whether the specified TabPage control is in the TabPageCollection.
Public Method | CopyTo | Copies the elements of the collection to the specified array, starting at the specified index.
Public Method | GetEnumerator | Returns an enumeration of all the tab pages in the collection.
Public Method | IndexOf | Returns the index of the specified tab page in the collection.
Public Method | Insert | Inserts an existing tab page into the collection at the specified index.
Public Method | Remove | Removes a TabPage from the collection.
Public Method | RemoveAt | Removes the tab page at the specified index from the collection.
Top

Protected Methods

 | Name | Description
Protected Method | AdvanceTabIndexFromIndex | Overloaded. Advances the TabIndex property by the value of 'advanceBy', begginning at the 'fromIndex' position.
Protected Method | GetSortedTabPageListFromCurrent | Returns a sorted TabPage list from current unsorted TabPageCollection.
Top

See Also

Reference

TabPageCollection Class
Gizmox.WebGUI.Forms Namespace


Add Method

[image]
Gizmox.WebGUI.Forms
Add Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TabPageCollection Class : Add Method

value
The TabPage to add.
Adds a TabPage to the collection.

Syntax

Visual Basic (Declaration)
Public Overridable Function Add( _
   ByVal value As TabPage _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As TabPageCollection
Dim value As TabPage
Dim value As Integer

value = instance.Add(value)
C#
public virtual int Add(
   TabPage value
)
Managed Extensions for C++
public: virtual int Add(
   TabPage* value
)
C++/CLI
public:
virtual int Add(
   TabPage^ value
)

Parameters

value
The TabPage to add.

Exceptions

Exception | Description
ArgumentNullException | The specified value is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TabPageCollection Class
TabPageCollection Members


AdvanceTabIndexFromIndex Method

[image]
Gizmox.WebGUI.Forms
AdvanceTabIndexFromIndex Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TabPageCollection Class : AdvanceTabIndexFromIndex Method

Advances the TabIndex property by the value of 'advanceBy', begginning at the 'fromIndex' position.

Overload List

Overload | Description
AdvanceTabIndexFromIndex(UInt16,UInt16) | Advances the TabIndex property by the value of 'advanceBy', begginning at the 'fromIndex' position.
AdvanceTabIndexFromIndex(ArrayList,UInt16,UInt16) | Advances the TabIndex property by the value of 'advanceBy', begginning at the 'fromIndex' position.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TabPageCollection Class
TabPageCollection Members


AdvanceTabIndexFromIndex(UInt16,UInt16) Method

[image]
Gizmox.WebGUI.Forms
AdvanceTabIndexFromIndex(UInt16,UInt16) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TabPageCollection Class > AdvanceTabIndexFromIndex Method : AdvanceTabIndexFromIndex(UInt16,UInt16) Method

usrFromIndex
usrAdvanceBy
Advances the TabIndex property by the value of 'advanceBy', begginning at the 'fromIndex' position.

Syntax

Visual Basic (Declaration)
Protected Overloads Sub AdvanceTabIndexFromIndex( _
   ByVal usrFromIndex As UShort, _
   ByVal usrAdvanceBy As UShort _
)
Visual Basic (Usage) Copy Code
Dim instance As TabPageCollection
Dim usrFromIndex As UShort
Dim usrAdvanceBy As UShort

instance.AdvanceTabIndexFromIndex(usrFromIndex, usrAdvanceBy)
C#
protected void AdvanceTabIndexFromIndex(
   ushort usrFromIndex,
   ushort usrAdvanceBy
)
Managed Extensions for C++
protected: void AdvanceTabIndexFromIndex(
   ushort usrFromIndex,
   ushort usrAdvanceBy
)
C++/CLI
protected:
void AdvanceTabIndexFromIndex(
   ushort usrFromIndex,
   ushort usrAdvanceBy
)

Parameters

usrFromIndex
usrAdvanceBy

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TabPageCollection Class
TabPageCollection Members
Overload List


AdvanceTabIndexFromIndex(ArrayList,UInt16,UInt16) Method

[image]
Gizmox.WebGUI.Forms
AdvanceTabIndexFromIndex(ArrayList,UInt16,UInt16) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TabPageCollection Class > AdvanceTabIndexFromIndex Method : AdvanceTabIndexFromIndex(ArrayList,UInt16,UInt16) Method

objTabPageList
usrFromIndex
usrAdvanceBy
Advances the TabIndex property by the value of 'advanceBy', begginning at the 'fromIndex' position.

Syntax

Visual Basic (Declaration)
Protected Overloads Sub AdvanceTabIndexFromIndex( _
   ByRef objTabPageList As ArrayList, _
   ByVal usrFromIndex As UShort, _
   ByVal usrAdvanceBy As UShort _
)
Visual Basic (Usage) Copy Code
Dim instance As TabPageCollection
Dim objTabPageList As ArrayList
Dim usrFromIndex As UShort
Dim usrAdvanceBy As UShort

instance.AdvanceTabIndexFromIndex(objTabPageList, usrFromIndex, usrAdvanceBy)
C#
protected void AdvanceTabIndexFromIndex(
   ref ArrayList objTabPageList,
   ushort usrFromIndex,
   ushort usrAdvanceBy
)
Managed Extensions for C++
protected: void AdvanceTabIndexFromIndex(
   ref ArrayList* objTabPageList,
   ushort usrFromIndex,
   ushort usrAdvanceBy
)
C++/CLI
protected:
void AdvanceTabIndexFromIndex(
   ArrayList^% objTabPageList,
   ushort usrFromIndex,
   ushort usrAdvanceBy
)

Parameters

objTabPageList
usrFromIndex
usrAdvanceBy

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TabPageCollection Class
TabPageCollection Members
Overload List


Clear Method

[image]
Gizmox.WebGUI.Forms
Clear Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TabPageCollection Class : Clear Method

Removes all the tab pages from the collection.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As TabPageCollection

instance.Clear()
C#
public void Clear()
Managed Extensions for C++
public: void Clear();
C++/CLI
public:
void Clear();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TabPageCollection Class
TabPageCollection Members


Compare Method

[image]
Gizmox.WebGUI.Forms
Compare Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TabPageCollection Class : Compare Method

objArgFirstTP
The first TabPage.
objArgSecondTP
The second TabPage.
Compares the index of two sequencial TabPages in the TabPageCollection.

Syntax

Visual Basic (Declaration)
Public Function Compare( _
   ByVal objArgFirstTP As Object, _
   ByVal objArgSecondTP As Object _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As TabPageCollection
Dim objArgFirstTP As Object
Dim objArgSecondTP As Object
Dim value As Integer

value = instance.Compare(objArgFirstTP, objArgSecondTP)
C#
public int Compare(
   object objArgFirstTP,
   object objArgSecondTP
)
Managed Extensions for C++
public: int Compare(
   Object* objArgFirstTP,
   Object* objArgSecondTP
)
C++/CLI
public:
int Compare(
   Object^ objArgFirstTP,
   Object^ objArgSecondTP
)

Parameters

objArgFirstTP
The first TabPage.
objArgSecondTP
The second TabPage.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TabPageCollection Class
TabPageCollection Members


Contains Method

[image]
Gizmox.WebGUI.Forms
Contains Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TabPageCollection Class : Contains Method

value
The object to locate in the collection.
Determines whether the specified TabPage control is in the TabPageCollection.

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal value As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TabPageCollection
Dim value As Object
Dim value As Boolean

value = instance.Contains(value)
C#
public bool Contains(
   object value
)
Managed Extensions for C++
public: bool Contains(
   Object* value
)
C++/CLI
public:
bool Contains(
   Object^ value
)

Parameters

value
The object to locate in the collection.

Return Value

true if the specified object is a TabPage in the collection; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TabPageCollection Class
TabPageCollection Members


CopyTo Method

[image]
Gizmox.WebGUI.Forms
CopyTo Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TabPageCollection Class : CopyTo Method

dest
The one-dimensional array that is the destination of the elements copied from the collection. The array must have zero-based indexing.
index
The zero-based index in the array at which copying begins.
Copies the elements of the collection to the specified array, starting at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal dest As Array, _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As TabPageCollection
Dim dest As Array
Dim index As Integer

instance.CopyTo(dest, index)
C#
public void CopyTo(
   Array dest,
   int index
)
Managed Extensions for C++
public: void CopyTo(
   Array* dest,
   int index
)
C++/CLI
public:
void CopyTo(
   Array^ dest,
   int index
)

Parameters

dest
The one-dimensional array that is the destination of the elements copied from the collection. The array must have zero-based indexing.
index
The zero-based index in the array at which copying begins.

Exceptions

Exception | Description
ArgumentException | dest is multidimensional.-or-index is equal to or greater than the length of dest.-or-The number of elements in the TabPageCollection is greater than the available space from index to the end of dest.
ArgumentOutOfRangeException | index is less than zero.
InvalidCastException | The items in the TabPageCollection cannot be cast automatically to the type of dest.
ArgumentNullException | dest is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TabPageCollection Class
TabPageCollection Members


GetEnumerator Method

[image]
Gizmox.WebGUI.Forms
GetEnumerator Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TabPageCollection Class : GetEnumerator Method

Returns an enumeration of all the tab pages in the collection.

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As TabPageCollection
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Return Value

An IEnumerator for the TabPageCollection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TabPageCollection Class
TabPageCollection Members


GetSortedTabPageListFromCurrent Method

[image]
Gizmox.WebGUI.Forms
GetSortedTabPageListFromCurrent Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TabPageCollection Class : GetSortedTabPageListFromCurrent Method

blnSortByIndex
Returns a sorted TabPage list from current unsorted TabPageCollection.

Syntax

Visual Basic (Declaration)
Protected Function GetSortedTabPageListFromCurrent( _
   ByVal blnSortByIndex As Boolean _
) As ArrayList
Visual Basic (Usage) Copy Code
Dim instance As TabPageCollection
Dim blnSortByIndex As Boolean
Dim value As ArrayList

value = instance.GetSortedTabPageListFromCurrent(blnSortByIndex)
C#
protected ArrayList GetSortedTabPageListFromCurrent(
   bool blnSortByIndex
)
Managed Extensions for C++
protected: ArrayList* GetSortedTabPageListFromCurrent(
   bool blnSortByIndex
)
C++/CLI
protected:
ArrayList^ GetSortedTabPageListFromCurrent(
   bool blnSortByIndex
)

Parameters

blnSortByIndex

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TabPageCollection Class
TabPageCollection Members


IndexOf Method

[image]
Gizmox.WebGUI.Forms
IndexOf Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TabPageCollection Class : IndexOf Method

page
The TabPage to locate in the collection.
Returns the index of the specified tab page in the collection.

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal page As TabPage _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As TabPageCollection
Dim page As TabPage
Dim value As Integer

value = instance.IndexOf(page)
C#
public int IndexOf(
   TabPage page
)
Managed Extensions for C++
public: int IndexOf(
   TabPage* page
)
C++/CLI
public:
int IndexOf(
   TabPage^ page
)

Parameters

page
The TabPage to locate in the collection.

Return Value

The zero-based index of the tab page; -1 if it cannot be found.

Exceptions

Exception | Description
ArgumentNullException | The value of page is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TabPageCollection Class
TabPageCollection Members


Insert Method

[image]
Gizmox.WebGUI.Forms
Insert Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TabPageCollection Class : Insert Method

index
The location where the tab page is inserted.
tabPage
The TabPage to insert in the collection.
Inserts an existing tab page into the collection at the specified index.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal tabPage As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As TabPageCollection
Dim index As Integer
Dim tabPage As Object

instance.Insert(index, tabPage)
C#
public void Insert(
   int index,
   object tabPage
)
Managed Extensions for C++
public: void Insert(
   int index,
   Object* tabPage
)
C++/CLI
public:
void Insert(
   int index,
   Object^ tabPage
)

Parameters

index
The location where the tab page is inserted.
tabPage
The TabPage to insert in the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TabPageCollection Class
TabPageCollection Members


Remove Method

[image]
Gizmox.WebGUI.Forms
Remove Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TabPageCollection Class : Remove Method

value
The TabPage to remove.
Removes a TabPage from the collection.

Syntax

Visual Basic (Declaration)
Public Overridable Sub Remove( _
   ByVal value As TabPage _
)
Visual Basic (Usage) Copy Code
Dim instance As TabPageCollection
Dim value As TabPage

instance.Remove(value)
C#
public virtual void Remove(
   TabPage value
)
Managed Extensions for C++
public: virtual void Remove(
   TabPage* value
)
C++/CLI
public:
virtual void Remove(
   TabPage^ value
)

Parameters

value
The TabPage to remove.

Exceptions

Exception | Description
ArgumentNullException | The value parameter is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TabPageCollection Class
TabPageCollection Members


RemoveAt Method

[image]
Gizmox.WebGUI.Forms
RemoveAt Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TabPageCollection Class : RemoveAt Method

index
The zero-based index of the TabPage to remove.
Removes the tab page at the specified index from the collection.

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As TabPageCollection
Dim index As Integer

instance.RemoveAt(index)
C#
public void RemoveAt(
   int index
)
Managed Extensions for C++
public: void RemoveAt(
   int index
)
C++/CLI
public:
void RemoveAt(
   int index
)

Parameters

index
The zero-based index of the TabPage to remove.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TabPageCollection Class
TabPageCollection Members


TabPageCollection Class Properties

[image]
Gizmox.WebGUI.Forms
TabPageCollection Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TabPageCollection Class

For a list of all members of this type, see TabPageCollection members.

Public Properties

 | Name | Description
Public Property | Count | Gets the number of tab pages in the collection.
Public Property | IsFixedSize | Gets a value indicating whether the TabPageCollection has a fixed size.
Public Property | IsReadOnly | Gets a value indicating whether the collection is read-only.
Public Property | IsSynchronized | Gets a value indicating whether access to the TabPageCollection is synchronized (thread safe).
Public Property | Item | Gets or sets a TabPage in the collection.
Public Property | SyncRoot | Gets an object that can be used to synchronize access to the TabPageCollection.
Top

See Also

Reference

TabPageCollection Class
Gizmox.WebGUI.Forms Namespace


Count Property

[image]
Gizmox.WebGUI.Forms
Count Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TabPageCollection Class : Count Property

Gets the number of tab pages in the collection.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As TabPageCollection
Dim value As Integer

value = instance.Count
C#
[BrowsableAttribute(false)]
public int Count {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property int get_Count();
C++/CLI
[BrowsableAttribute(false)]
public:
property int Count {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TabPageCollection Class
TabPageCollection Members


IsFixedSize Property

[image]
Gizmox.WebGUI.Forms
IsFixedSize Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TabPageCollection Class : IsFixedSize Property

Gets a value indicating whether the TabPageCollection has a fixed size.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsFixedSize As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TabPageCollection
Dim value As Boolean

value = instance.IsFixedSize
C#
public bool IsFixedSize {get;}
Managed Extensions for C++
public: __property bool get_IsFixedSize();
C++/CLI
public:
property bool IsFixedSize {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TabPageCollection Class
TabPageCollection Members


IsReadOnly Property

[image]
Gizmox.WebGUI.Forms
IsReadOnly Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TabPageCollection Class : IsReadOnly Property

Gets a value indicating whether the collection is read-only.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsReadOnly As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TabPageCollection
Dim value As Boolean

value = instance.IsReadOnly
C#
public bool IsReadOnly {get;}
Managed Extensions for C++
public: __property bool get_IsReadOnly();
C++/CLI
public:
property bool IsReadOnly {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TabPageCollection Class
TabPageCollection Members


IsSynchronized Property

[image]
Gizmox.WebGUI.Forms
IsSynchronized Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TabPageCollection Class : IsSynchronized Property

Gets a value indicating whether access to the TabPageCollection is synchronized (thread safe).

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsSynchronized As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TabPageCollection
Dim value As Boolean

value = instance.IsSynchronized
C#
public bool IsSynchronized {get;}
Managed Extensions for C++
public: __property bool get_IsSynchronized();
C++/CLI
public:
property bool IsSynchronized {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TabPageCollection Class
TabPageCollection Members


Item Property

[image]
Gizmox.WebGUI.Forms
Item Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TabPageCollection Class : Item Property

index
The zero-based index of the tab page to get or set.
Gets or sets a TabPage in the collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal index As Integer _
) As TabPage
Visual Basic (Usage) Copy Code
Dim instance As TabPageCollection
Dim index As Integer
Dim value As TabPage

value = instance.Item(index)
C#
public TabPage this[
   int index
]; {get;}
Managed Extensions for C++
public: __property TabPage* get_Item(
   int index
);
C++/CLI
public:
property TabPage^ default [int] {
   TabPage^ get(intindex);
}

Parameters

index
The zero-based index of the tab page to get or set.

Exceptions

Exception | Description
ArgumentOutOfRangeException | index is less than zero or greater than the highest available index.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TabPageCollection Class
TabPageCollection Members


SyncRoot Property

[image]
Gizmox.WebGUI.Forms
SyncRoot Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TabPageCollection Class : SyncRoot Property

Gets an object that can be used to synchronize access to the TabPageCollection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SyncRoot As Object
Visual Basic (Usage) Copy Code
Dim instance As TabPageCollection
Dim value As Object

value = instance.SyncRoot
C#
public object SyncRoot {get;}
Managed Extensions for C++
public: __property Object* get_SyncRoot();
C++/CLI
public:
property Object^ SyncRoot {
   Object^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TabPageCollection Class
TabPageCollection Members


TabPageCollection.TabIndexComparer Class

[image]
Gizmox.WebGUI.Forms
TabPageCollection.TabIndexComparer Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TabPageCollection.TabIndexComparer Class

Implements IComparer for TabPages sorting by TabIndex

Syntax

Visual Basic (Declaration)
Private Class TabPageCollection.TabIndexComparer
Visual Basic (Usage) Copy Code
Dim instance As TabPageCollection.TabIndexComparer
C#
private class TabPageCollection.TabIndexComparer
Managed Extensions for C++
private __gc class TabPageCollection.TabIndexComparer
C++/CLI
private ref class TabPageCollection.TabIndexComparer

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.TabPageCollection.TabIndexComparer

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

TabPageCollection.TabIndexComparer Members
Gizmox.WebGUI.Forms Namespace


TabPageCollection.TabIndexComparer Class Members

[image]
Gizmox.WebGUI.Forms
TabPageCollection.TabIndexComparer Class Members
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TabPageCollection.TabIndexComparer Class

The following tables list the members exposed by TabPageCollection.TabIndexComparer.

Public Constructors

 | Name | Description
Public Constructor | TabPageCollection.TabIndexComparer Constructor |
Top

See Also

Reference

TabPageCollection.TabIndexComparer Class
Gizmox.WebGUI.Forms Namespace


TabPageCollection.TabIndexComparer Constructor

[image]
Gizmox.WebGUI.Forms
TabPageCollection.TabIndexComparer Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TabPageCollection.TabIndexComparer Class : TabPageCollection.TabIndexComparer Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As TabPageCollection.TabIndexComparer()
C#
public TabPageCollection.TabIndexComparer()
Managed Extensions for C++
public: TabPageCollection.TabIndexComparer();
C++/CLI
public:
TabPageCollection.TabIndexComparer();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TabPageCollection.TabIndexComparer Class
TabPageCollection.TabIndexComparer Members


TabPageEventArgs Class

[image]
Gizmox.WebGUI.Forms
TabPageEventArgs Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TabPageEventArgs Class

Provides data for events of a TabControl control.

Object Model

Syntax

Visual Basic (Declaration)
Public Class TabPageEventArgs
   Inherits EventArgs
Visual Basic (Usage) Copy Code
Dim instance As TabPageEventArgs
C#
public class TabPageEventArgs : EventArgs
Managed Extensions for C++
public __gc class TabPageEventArgs : public EventArgs
C++/CLI
public ref class TabPageEventArgs : public EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gizmox.WebGUI.Forms.TabPageEventArgs

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

TabPageEventArgs Members
Gizmox.WebGUI.Forms Namespace


TabPageEventArgs Class Members

[image]
Gizmox.WebGUI.Forms
TabPageEventArgs Class Members
See Also Fields Send Feedback
Gizmox.WebGUI.Forms Namespace : TabPageEventArgs Class

The following tables list the members exposed by TabPageEventArgs.

Public Constructors

 | Name | Description
Public Constructor | TabPageEventArgs Constructor | Initializes a new instance of the TabPageEventArgs class.
Top

Public Fields

 | Name | Description
Public Field | TabPage | Represents the TabPage
Top

See Also

Reference

TabPageEventArgs Class
Gizmox.WebGUI.Forms Namespace


TabPageEventArgs Constructor

[image]
Gizmox.WebGUI.Forms
TabPageEventArgs Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TabPageEventArgs Class : TabPageEventArgs Constructor

objTabPage
The tab page.
Initializes a new instance of the TabPageEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal objTabPage As TabPage _
)
Visual Basic (Usage) Copy Code
Dim objTabPage As TabPage

Dim instance As TabPageEventArgs(objTabPage)
C#
public TabPageEventArgs(
   TabPage objTabPage
)
Managed Extensions for C++
public: TabPageEventArgs(
   TabPage* objTabPage
)
C++/CLI
public:
TabPageEventArgs(
   TabPage^ objTabPage
)

Parameters

objTabPage
The tab page.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TabPageEventArgs Class
TabPageEventArgs Members


TabPageEventArgs Class Fields

[image]
Gizmox.WebGUI.Forms
TabPageEventArgs Class Fields
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TabPageEventArgs Class

For a list of all members of this type, see TabPageEventArgs members.

Public Fields

 | Name | Description
Public Field | TabPage | Represents the TabPage
Top

See Also

Reference

TabPageEventArgs Class
Gizmox.WebGUI.Forms Namespace


TabPage Field

[image]
Gizmox.WebGUI.Forms
TabPage Field
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TabPageEventArgs Class : TabPage Field

Represents the TabPage

Syntax

Visual Basic (Declaration)
Public ReadOnly TabPage As TabPage
Visual Basic (Usage) Copy Code
Dim instance As TabPageEventArgs
Dim value As TabPage

value = instance.TabPage
C#
public readonly TabPage TabPage
Managed Extensions for C++
public: readonly TabPage* TabPage
C++/CLI
public:
readonly TabPage^ TabPage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TabPageEventArgs Class
TabPageEventArgs Members


TextBox Class

[image]
Gizmox.WebGUI.Forms
TextBox Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TextBox Class

Implementation of TextBox class.

Object Model

Syntax

Visual Basic (Declaration)
<DesignTimeControllerAttribute()>
<ClientControllerAttribute()>
<ToolboxBitmapAttribute()>
<ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<ToolboxItemCategoryAttribute("Common Controls")>
<MetadataTagAttribute("T")>
<SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableTextBox, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")>
Public Class TextBox
   Inherits TextBoxBase
   Implements IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Visual Basic (Usage) Copy Code
Dim instance As TextBox
C#
[DesignTimeControllerAttribute()]
[ClientControllerAttribute()]
[ToolboxBitmapAttribute()]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ToolboxItemCategoryAttribute("Common Controls")]
[MetadataTagAttribute("T")]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableTextBox, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
public class TextBox : TextBoxBase, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Managed Extensions for C++
[DesignTimeControllerAttribute()]
[ClientControllerAttribute()]
[ToolboxBitmapAttribute()]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ToolboxItemCategoryAttribute("Common Controls")]
[MetadataTagAttribute("T")]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableTextBox, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
public __gc class TextBox : public TextBoxBase, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
C++/CLI
[DesignTimeControllerAttribute()]
[ClientControllerAttribute()]
[ToolboxBitmapAttribute()]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ToolboxItemCategoryAttribute("Common Controls")]
[MetadataTagAttribute("T")]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableTextBox, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
public ref class TextBox : public TextBoxBase, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.TextBoxBase
Gizmox.WebGUI.Forms.TextBox
Gizmox.WebGUI.Forms.DataGridViewTextBoxEditingControl
Gizmox.WebGUI.Forms.MaskedTextBox
Gizmox.WebGUI.Forms.SearchTextBox
Gizmox.WebGUI.Forms.WatermarkTextBox

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

TextBox Members
Gizmox.WebGUI.Forms Namespace


TextBox Class Members

[image]
Gizmox.WebGUI.Forms
TextBox Class Members
See Also Fields Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : TextBox Class

The following tables list the members exposed by TextBox.

Public Constructors

 | Name | Description
Public Constructor | TextBox Constructor | Creates a new TextBox instance.
Top

Protected Fields

 | Name | Description
Protected Field | menmScrollBars | Member which holds the scrollbars mode.
Top

Public Properties

 | Name | Description
Public Property | AcceptsReturn | Gets or sets a value indicating whether pressing ENTER in a multiline TextBox control creates a new line of text in the control or activates the default button for the form.
Public Property | AcceptsTab | (Inherited from TextBoxBase)
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Overridden.
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | CanUndo | Gets a value indicating whether the user can undo the previous operation in a text box control.
Public Property | CharacterCasing | Indicates if all characters should be left alone or converted to uppercase or lowercase
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DragTargets | Overridden. Gets a value indicating whether this instance is dragable.
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Lines | (Inherited from TextBoxBase)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MaxLength | (Inherited from TextBoxBase)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Multiline | Gets or sets a value indicating whether text box is multi line. (Inherited from TextBoxBase)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PasswordChar | Gets or sets the password charecter.
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | ReadOnly | Gets or sets a value indicating whether [read only]. (Inherited from TextBoxBase)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | ScrollBars | Gets or sets which scroll bars should appear in a multiline TextBox control.
Public Property | SelectedText | Gets or sets a value indicating the currently selected text in the control. (Inherited from TextBoxBase)
Public Property | SelectionLength | Gets or sets the number of characters selected in the text box. (Inherited from TextBoxBase)
Public Property | SelectionStart | Gets or sets the starting point of text selected in the text box. (Inherited from TextBoxBase)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Control)
Public Property | TextAlign | Gets or sets how text is aligned in a TextBox control.
Public Property | TextLength | Gets the length of text in the control. (Inherited from TextBoxBase)
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | Validator | Gets or sets the text box validator.
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Public Property | WordWrap | (Inherited from TextBoxBase)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | Overridden.
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | Overridden.
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

Public Methods

 | Name | Description
Public Method | AppendText | Appends text to the current text of a text box. (Inherited from TextBoxBase)
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Clear | Clears all text from the text box control. (Inherited from TextBoxBase)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | Copy | Copies the current selection in the text box to the Clipboard. (Inherited from TextBoxBase)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Cut | Moves the current selection in the text box to the Clipboard. (Inherited from TextBoxBase)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | Paste | Replaces the current selection in the text box with the contents of the Clipboard. (Inherited from TextBoxBase)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | ScrollToCaret | Scrolls the contents of the control to the current caret position. (Inherited from TextBoxBase)
Public Method | Select | Overloaded. Selects a range of text in the text box. (Inherited from TextBoxBase)
Public Method | SelectAll | Selects all text in the text box. (Inherited from TextBoxBase)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | Undo | Undoes the last edit operation in the text box.
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Overridden. Fires an event.
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetClipboardContent | Get content to be added to the clip board
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Overridden. Gets the critical events.
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from Control)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | InvokeSelection | Overridden. Implements the actual client side selection
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Control)
Protected Method | RenderAttributes | Overridden. Renders the current control attributes.
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | Render control params (Inherited from TextBoxBase)
Protected Method | RenderValue | Overridden.
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetClipboardContent | Set the value from the clip board
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | EnterKeyDown | Occurs on enter key down only on single line.
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

TextBox Class
Gizmox.WebGUI.Forms Namespace


TextBox Constructor

[image]
Gizmox.WebGUI.Forms
TextBox Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TextBox Class : TextBox Constructor

Creates a new TextBox instance.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As TextBox()
C#
public TextBox()
Managed Extensions for C++
public: TextBox();
C++/CLI
public:
TextBox();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextBox Class
TextBox Members


TextBox Class Methods

[image]
Gizmox.WebGUI.Forms
TextBox Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TextBox Class

For a list of all members of this type, see TextBox members.

Public Methods

 | Name | Description
Public Method | AppendText | Appends text to the current text of a text box. (Inherited from TextBoxBase)
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Clear | Clears all text from the text box control. (Inherited from TextBoxBase)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | Copy | Copies the current selection in the text box to the Clipboard. (Inherited from TextBoxBase)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Cut | Moves the current selection in the text box to the Clipboard. (Inherited from TextBoxBase)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | Paste | Replaces the current selection in the text box with the contents of the Clipboard. (Inherited from TextBoxBase)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | ScrollToCaret | Scrolls the contents of the control to the current caret position. (Inherited from TextBoxBase)
Public Method | Select | Overloaded. Selects a range of text in the text box. (Inherited from TextBoxBase)
Public Method | SelectAll | Selects all text in the text box. (Inherited from TextBoxBase)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | Undo | Undoes the last edit operation in the text box.
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Overridden. Fires an event.
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetClipboardContent | Get content to be added to the clip board
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Overridden. Gets the critical events.
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from Control)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | InvokeSelection | Overridden. Implements the actual client side selection
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Control)
Protected Method | RenderAttributes | Overridden. Renders the current control attributes.
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | Render control params (Inherited from TextBoxBase)
Protected Method | RenderValue | Overridden.
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetClipboardContent | Set the value from the clip board
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

See Also

Reference

TextBox Class
Gizmox.WebGUI.Forms Namespace


FireEvent Method

[image]
Gizmox.WebGUI.Forms
FireEvent Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TextBox Class : FireEvent Method

objEvent
event.
Fires an event.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub FireEvent( _
   ByVal objEvent As IEvent _
)
Visual Basic (Usage) Copy Code
Dim instance As TextBox
Dim objEvent As IEvent

instance.FireEvent(objEvent)
C#
protected override void FireEvent(
   IEvent objEvent
)
Managed Extensions for C++
protected: void FireEvent(
   IEvent* objEvent
) override
C++/CLI
protected:
void FireEvent(
   IEvent^ objEvent
) override

Parameters

objEvent
event.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextBox Class
TextBox Members


GetClipboardContent Method

[image]
Gizmox.WebGUI.Forms
GetClipboardContent Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TextBox Class : GetClipboardContent Method

Get content to be added to the clip board

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetClipboardContent() As String
Visual Basic (Usage) Copy Code
Dim instance As TextBox
Dim value As String

value = instance.GetClipboardContent()
C#
protected virtual string GetClipboardContent()
Managed Extensions for C++
protected: virtual string* GetClipboardContent();
C++/CLI
protected:
virtual String^ GetClipboardContent();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextBox Class
TextBox Members


GetCriticalEvents Method

[image]
Gizmox.WebGUI.Forms
GetCriticalEvents Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TextBox Class : GetCriticalEvents Method

Gets the critical events.

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetCriticalEvents() As EventTypes
Visual Basic (Usage) Copy Code
Dim instance As TextBox
Dim value As EventTypes

value = instance.GetCriticalEvents()
C#
protected override EventTypes GetCriticalEvents()
Managed Extensions for C++
protected: EventTypes GetCriticalEvents(); override
C++/CLI
protected:
EventTypes GetCriticalEvents(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextBox Class
TextBox Members


InvokeSelection Method

[image]
Gizmox.WebGUI.Forms
InvokeSelection Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TextBox Class : InvokeSelection Method

start
length
Implements the actual client side selection

Syntax

Visual Basic (Declaration)
Protected Overrides Sub InvokeSelection( _
   ByVal start As Integer, _
   ByVal length As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As TextBox
Dim start As Integer
Dim length As Integer

instance.InvokeSelection(start, length)
C#
protected override void InvokeSelection(
   int start,
   int length
)
Managed Extensions for C++
protected: void InvokeSelection(
   int start,
   int length
) override
C++/CLI
protected:
void InvokeSelection(
   int start,
   int length
) override

Parameters

start
length

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextBox Class
TextBox Members


RenderAttributes Method

[image]
Gizmox.WebGUI.Forms
RenderAttributes Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TextBox Class : RenderAttributes Method

objContext
Request context.
objWriter
The response writer object.
Renders the current control attributes.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub RenderAttributes( _
   ByVal objContext As IContext, _
   ByVal objWriter As IAttributeWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As TextBox
Dim objContext As IContext
Dim objWriter As IAttributeWriter

instance.RenderAttributes(objContext, objWriter)
C#
protected override void RenderAttributes(
   IContext objContext,
   IAttributeWriter objWriter
)
Managed Extensions for C++
protected: void RenderAttributes(
   IContext* objContext,
   IAttributeWriter* objWriter
) override
C++/CLI
protected:
void RenderAttributes(
   IContext^ objContext,
   IAttributeWriter^ objWriter
) override

Parameters

objContext
Request context.
objWriter
The response writer object.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextBox Class
TextBox Members


RenderValue Method

[image]
Gizmox.WebGUI.Forms
RenderValue Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TextBox Class : RenderValue Method

objContext
objWriter

Syntax

Visual Basic (Declaration)
Protected Overrides Sub RenderValue( _
   ByVal objContext As IContext, _
   ByVal objWriter As IAttributeWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As TextBox
Dim objContext As IContext
Dim objWriter As IAttributeWriter

instance.RenderValue(objContext, objWriter)
C#
protected override void RenderValue(
   IContext objContext,
   IAttributeWriter objWriter
)
Managed Extensions for C++
protected: void RenderValue(
   IContext* objContext,
   IAttributeWriter* objWriter
) override
C++/CLI
protected:
void RenderValue(
   IContext^ objContext,
   IAttributeWriter^ objWriter
) override

Parameters

objContext
objWriter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextBox Class
TextBox Members


SetClipboardContent Method

[image]
Gizmox.WebGUI.Forms
SetClipboardContent Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TextBox Class : SetClipboardContent Method

strValue
Set the value from the clip board

Syntax

Visual Basic (Declaration)
Protected Overridable Sub SetClipboardContent( _
   ByVal strValue As String _
)
Visual Basic (Usage) Copy Code
Dim instance As TextBox
Dim strValue As String

instance.SetClipboardContent(strValue)
C#
protected virtual void SetClipboardContent(
   string strValue
)
Managed Extensions for C++
protected: virtual void SetClipboardContent(
   string* strValue
)
C++/CLI
protected:
virtual void SetClipboardContent(
   String^ strValue
)

Parameters

strValue

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextBox Class
TextBox Members


Undo Method

[image]
Gizmox.WebGUI.Forms
Undo Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TextBox Class : Undo Method

Undoes the last edit operation in the text box.

Syntax

Visual Basic (Declaration)
Public Sub Undo()
Visual Basic (Usage) Copy Code
Dim instance As TextBox

instance.Undo()
C#
public void Undo()
Managed Extensions for C++
public: void Undo();
C++/CLI
public:
void Undo();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextBox Class
TextBox Members


TextBox Class Properties

[image]
Gizmox.WebGUI.Forms
TextBox Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TextBox Class

For a list of all members of this type, see TextBox members.

Public Properties

 | Name | Description
Public Property | AcceptsReturn | Gets or sets a value indicating whether pressing ENTER in a multiline TextBox control creates a new line of text in the control or activates the default button for the form.
Public Property | AcceptsTab | (Inherited from TextBoxBase)
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Overridden.
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | CanUndo | Gets a value indicating whether the user can undo the previous operation in a text box control.
Public Property | CharacterCasing | Indicates if all characters should be left alone or converted to uppercase or lowercase
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DragTargets | Overridden. Gets a value indicating whether this instance is dragable.
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Lines | (Inherited from TextBoxBase)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MaxLength | (Inherited from TextBoxBase)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Multiline | Gets or sets a value indicating whether text box is multi line. (Inherited from TextBoxBase)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PasswordChar | Gets or sets the password charecter.
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | ReadOnly | Gets or sets a value indicating whether [read only]. (Inherited from TextBoxBase)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | ScrollBars | Gets or sets which scroll bars should appear in a multiline TextBox control.
Public Property | SelectedText | Gets or sets a value indicating the currently selected text in the control. (Inherited from TextBoxBase)
Public Property | SelectionLength | Gets or sets the number of characters selected in the text box. (Inherited from TextBoxBase)
Public Property | SelectionStart | Gets or sets the starting point of text selected in the text box. (Inherited from TextBoxBase)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Control)
Public Property | TextAlign | Gets or sets how text is aligned in a TextBox control.
Public Property | TextLength | Gets the length of text in the control. (Inherited from TextBoxBase)
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | Validator | Gets or sets the text box validator.
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Public Property | WordWrap | (Inherited from TextBoxBase)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | Overridden.
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | Overridden.
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

See Also

Reference

TextBox Class
Gizmox.WebGUI.Forms Namespace


AcceptsReturn Property

[image]
Gizmox.WebGUI.Forms
AcceptsReturn Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TextBox Class : AcceptsReturn Property

Gets or sets a value indicating whether pressing ENTER in a multiline TextBox control creates a new line of text in the control or activates the default button for the form.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property AcceptsReturn As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TextBox
Dim value As Boolean

instance.AcceptsReturn = value

value = instance.AcceptsReturn
C#
[DefaultValueAttribute()]
public bool AcceptsReturn {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property bool get_AcceptsReturn();
public: __property void set_AcceptsReturn(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
public:
property bool AcceptsReturn {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextBox Class
TextBox Members


CanFocus Property

[image]
Gizmox.WebGUI.Forms
CanFocus Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TextBox Class : CanFocus Property

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanFocus As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TextBox
Dim value As Boolean

value = instance.CanFocus
C#
public override bool CanFocus {get;}
Managed Extensions for C++
public: __property bool get_CanFocus() override;
C++/CLI
public:
property bool CanFocus {
   bool get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextBox Class
TextBox Members


CanUndo Property

[image]
Gizmox.WebGUI.Forms
CanUndo Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TextBox Class : CanUndo Property

Gets a value indicating whether the user can undo the previous operation in a text box control.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Indicates if the edit control can undo the previous action.")>
<SRCategoryAttribute("Behavior")>
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public ReadOnly Property CanUndo As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TextBox
Dim value As Boolean

value = instance.CanUndo
C#
[SRDescriptionAttribute("Indicates if the edit control can undo the previous action.")]
[SRCategoryAttribute("Behavior")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public bool CanUndo {get;}
Managed Extensions for C++
[SRDescriptionAttribute("Indicates if the edit control can undo the previous action.")]
[SRCategoryAttribute("Behavior")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property bool get_CanUndo();
C++/CLI
[SRDescriptionAttribute("Indicates if the edit control can undo the previous action.")]
[SRCategoryAttribute("Behavior")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
property bool CanUndo {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextBox Class
TextBox Members


CharacterCasing Property

[image]
Gizmox.WebGUI.Forms
CharacterCasing Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TextBox Class : CharacterCasing Property

Indicates if all characters should be left alone or converted to uppercase or lowercase

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Behavior")>
<DefaultValueAttribute()>
<SRDescriptionAttribute("Indicates if all characters should be left alone or converted to uppercase or lowercase.")>
Public Property CharacterCasing As CharacterCasing
Visual Basic (Usage) Copy Code
Dim instance As TextBox
Dim value As CharacterCasing

instance.CharacterCasing = value

value = instance.CharacterCasing
C#
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Indicates if all characters should be left alone or converted to uppercase or lowercase.")]
public CharacterCasing CharacterCasing {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Indicates if all characters should be left alone or converted to uppercase or lowercase.")]
public: __property CharacterCasing get_CharacterCasing();
public: __property void set_CharacterCasing(
   CharacterCasing value
);
C++/CLI
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Indicates if all characters should be left alone or converted to uppercase or lowercase.")]
public:
property CharacterCasing CharacterCasing {
   CharacterCasing get();
   void set (CharacterCasingvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextBox Class
TextBox Members


DefaultBackColor Property

[image]
Gizmox.WebGUI.Forms
DefaultBackColor Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TextBox Class : DefaultBackColor Property

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property DefaultBackColor As Color
Visual Basic (Usage) Copy Code
Dim instance As TextBox
Dim value As Color

value = instance.DefaultBackColor
C#
protected override Color DefaultBackColor {get;}
Managed Extensions for C++
protected: __property Color get_DefaultBackColor() override;
C++/CLI
protected:
property Color DefaultBackColor {
   Color get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextBox Class
TextBox Members


DefaultBorderStyle Property

[image]
Gizmox.WebGUI.Forms
DefaultBorderStyle Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TextBox Class : DefaultBorderStyle Property

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property DefaultBorderStyle As BorderStyle
Visual Basic (Usage) Copy Code
Dim instance As TextBox
Dim value As BorderStyle

value = instance.DefaultBorderStyle
C#
protected override BorderStyle DefaultBorderStyle {get;}
Managed Extensions for C++
protected: __property BorderStyle get_DefaultBorderStyle() override;
C++/CLI
protected:
property BorderStyle DefaultBorderStyle {
   BorderStyle get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextBox Class
TextBox Members


DragTargets Property

[image]
Gizmox.WebGUI.Forms
DragTargets Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TextBox Class : DragTargets Property

Gets a value indicating whether this instance is dragable.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property DragTargets As Component()
Visual Basic (Usage) Copy Code
Dim instance As TextBox
Dim value() As Component

value = instance.DragTargets
C#
public override Component[] DragTargets {get;}
Managed Extensions for C++
public: __property Component*[]* get_DragTargets() override;
C++/CLI
public:
property array<Component^>^ DragTargets {
   array<Component^>^ get() override;
}

Return Value

true if this instance is dragable; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextBox Class
TextBox Members


PasswordChar Property

[image]
Gizmox.WebGUI.Forms
PasswordChar Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TextBox Class : PasswordChar Property

Gets or sets the password charecter.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Indicates the character to display for password input for single-line edit controls.")>
<DefaultValueAttribute()>
<SRCategoryAttribute("Behavior")>
Public Property PasswordChar As Char
Visual Basic (Usage) Copy Code
Dim instance As TextBox
Dim value As Char

instance.PasswordChar = value

value = instance.PasswordChar
C#
[SRDescriptionAttribute("Indicates the character to display for password input for single-line edit controls.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
public char PasswordChar {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Indicates the character to display for password input for single-line edit controls.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
public: __property char get_PasswordChar();
public: __property void set_PasswordChar(
   char value
);
C++/CLI
[SRDescriptionAttribute("Indicates the character to display for password input for single-line edit controls.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
public:
property char PasswordChar {
   char get();
   void set (charvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextBox Class
TextBox Members


ScrollBars Property

[image]
Gizmox.WebGUI.Forms
ScrollBars Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TextBox Class : ScrollBars Property

Gets or sets which scroll bars should appear in a multiline TextBox control.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Style")>
<SRDescriptionAttribute("Scrollbar state definition")>
<DefaultValueAttribute()>
Public Property ScrollBars As ScrollBars
Visual Basic (Usage) Copy Code
Dim instance As TextBox
Dim value As ScrollBars

instance.ScrollBars = value

value = instance.ScrollBars
C#
[SRCategoryAttribute("Style")]
[SRDescriptionAttribute("Scrollbar state definition")]
[DefaultValueAttribute()]
public ScrollBars ScrollBars {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Style")]
[SRDescriptionAttribute("Scrollbar state definition")]
[DefaultValueAttribute()]
public: __property ScrollBars get_ScrollBars();
public: __property void set_ScrollBars(
   ScrollBars value
);
C++/CLI
[SRCategoryAttribute("Style")]
[SRDescriptionAttribute("Scrollbar state definition")]
[DefaultValueAttribute()]
public:
property ScrollBars ScrollBars {
   ScrollBars get();
   void set (ScrollBarsvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextBox Class
TextBox Members


TextAlign Property

[image]
Gizmox.WebGUI.Forms
TextAlign Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TextBox Class : TextAlign Property

Gets or sets how text is aligned in a TextBox control.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Indicates how the text should be aligned for edit controls.")>
<DefaultValueAttribute()>
<LocalizableAttribute(True)>
<SRCategoryAttribute("Appearance")>
Public Property TextAlign As HorizontalAlignment
Visual Basic (Usage) Copy Code
Dim instance As TextBox
Dim value As HorizontalAlignment

instance.TextAlign = value

value = instance.TextAlign
C#
[SRDescriptionAttribute("Indicates how the text should be aligned for edit controls.")]
[DefaultValueAttribute()]
[LocalizableAttribute(true)]
[SRCategoryAttribute("Appearance")]
public HorizontalAlignment TextAlign {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Indicates how the text should be aligned for edit controls.")]
[DefaultValueAttribute()]
[LocalizableAttribute(true)]
[SRCategoryAttribute("Appearance")]
public: __property HorizontalAlignment get_TextAlign();
public: __property void set_TextAlign(
   HorizontalAlignment value
);
C++/CLI
[SRDescriptionAttribute("Indicates how the text should be aligned for edit controls.")]
[DefaultValueAttribute()]
[LocalizableAttribute(true)]
[SRCategoryAttribute("Appearance")]
public:
property HorizontalAlignment TextAlign {
   HorizontalAlignment get();
   void set (HorizontalAlignmentvalue);
}

Exceptions

Exception | Description
InvalidEnumArgumentException | A value that is not within the range of valid values for the enumeration was assigned to the property.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextBox Class
TextBox Members


Validator Property

[image]
Gizmox.WebGUI.Forms
Validator Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TextBox Class : Validator Property

Gets or sets the text box validator.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
<DefaultValueAttribute()>
Public Property Validator As TextBoxValidation
Visual Basic (Usage) Copy Code
Dim instance As TextBox
Dim value As TextBoxValidation

instance.Validator = value

value = instance.Validator
C#
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
public TextBoxValidation Validator {get; set;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
public: __property TextBoxValidation* get_Validator();
public: __property void set_Validator(
   TextBoxValidation* value
);
C++/CLI
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
public:
property TextBoxValidation^ Validator {
   TextBoxValidation^ get();
   void set (TextBoxValidation^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextBox Class
TextBox Members


TextBox Class Fields

[image]
Gizmox.WebGUI.Forms
TextBox Class Fields
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TextBox Class

For a list of all members of this type, see TextBox members.

Protected Fields

 | Name | Description
Protected Field | menmScrollBars | Member which holds the scrollbars mode.
Top

See Also

Reference

TextBox Class
Gizmox.WebGUI.Forms Namespace


menmScrollBars Field

[image]
Gizmox.WebGUI.Forms
menmScrollBars Field
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TextBox Class : menmScrollBars Field

Member which holds the scrollbars mode.

Syntax

Visual Basic (Declaration)
Protected menmScrollBars As ScrollBars
Visual Basic (Usage) Copy Code
Dim instance As TextBox
Dim value As ScrollBars

value = instance.menmScrollBars

instance.menmScrollBars = value
C#
protected ScrollBars menmScrollBars
Managed Extensions for C++
protected: ScrollBars menmScrollBars
C++/CLI
protected:
ScrollBars menmScrollBars

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextBox Class
TextBox Members


TextBox Class Events

[image]
Gizmox.WebGUI.Forms
TextBox Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TextBox Class

For a list of all members of this type, see TextBox members.

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | EnterKeyDown | Occurs on enter key down only on single line.
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

TextBox Class
Gizmox.WebGUI.Forms Namespace


EnterKeyDown Event

[image]
Gizmox.WebGUI.Forms
EnterKeyDown Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TextBox Class : EnterKeyDown Event

Occurs on enter key down only on single line.

Syntax

Visual Basic (Declaration)
Public Event EnterKeyDown() As KeyEventHandler
Visual Basic (Usage) Copy Code
Dim instance As TextBox
Dim handler As KeyEventHandler

AddHandler instance.EnterKeyDown, handler
C#
public event KeyEventHandler EnterKeyDown()
Managed Extensions for C++
public: __event KeyEventHandler* EnterKeyDown
C++/CLI
public:
event KeyEventHandler^ EnterKeyDown

Event Data

The event handler receives an argument of type KeyEventArgs containing data related to this event. The following KeyEventArgs properties provide information specific to this event.

Property | Description
Alt |
Control |
Handled | Gets or sets a value indicating whether the event was handled.
KeyCode |
KeyData |
KeyValue |
Modifiers | Gets the modifier flags for a KeyDown or KeyUp event. The flags indicate which combination of CTRL, SHIFT, and ALT keys was pressed.
Shift |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextBox Class
TextBox Members


TextBoxBase Class

[image]
Gizmox.WebGUI.Forms
TextBoxBase Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TextBoxBase Class

Implements the basic functionality required by text controls.

Object Model

Syntax

Visual Basic (Declaration)
Public MustInherit Class TextBoxBase
   Inherits Control
   Implements IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Visual Basic (Usage) Copy Code
Dim instance As TextBoxBase
C#
public abstract class TextBoxBase : Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Managed Extensions for C++
public __gc abstract class TextBoxBase : public Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
C++/CLI
public ref class TextBoxBase abstract : public Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.TextBoxBase
Gizmox.WebGUI.Forms.RichTextBox
Gizmox.WebGUI.Forms.TextBox

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

TextBoxBase Members
Gizmox.WebGUI.Forms Namespace


TextBoxBase Class Members

[image]
Gizmox.WebGUI.Forms
TextBoxBase Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : TextBoxBase Class

The following tables list the members exposed by TextBoxBase.

Public Properties

 | Name | Description
Public Property | AcceptsTab |
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Lines |
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MaxLength |
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Multiline | Gets or sets a value indicating whether text box is multi line.
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | ReadOnly | Gets or sets a value indicating whether [read only].
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | SelectedText | Gets or sets a value indicating the currently selected text in the control.
Public Property | SelectionLength | Gets or sets the number of characters selected in the text box.
Public Property | SelectionStart | Gets or sets the starting point of text selected in the text box.
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Control)
Public Property | TextLength | Gets the length of text in the control.
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Public Property | WordWrap |
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

Public Methods

 | Name | Description
Public Method | AppendText | Appends text to the current text of a text box.
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Clear | Clears all text from the text box control.
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | Copy | Copies the current selection in the text box to the Clipboard.
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Cut | Moves the current selection in the text box to the Clipboard.
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | Paste | Replaces the current selection in the text box with the contents of the Clipboard.
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | ScrollToCaret | Scrolls the contents of the control to the current caret position.
Public Method | Select | Overloaded. Selects a range of text in the text box.
Public Method | SelectAll | Selects all text in the text box.
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Overridden. Fires an event.
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetClipboardContent |
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Overridden. Gets the critical events.
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from Control)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | InvokeSelection | Invokes client side selection
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Control)
Protected Method | RenderAttributes | Overridden. Renders the current control attributes.
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | Overridden. Render control params
Protected Method | RenderValue |
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetClipboardContent |
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

TextBoxBase Class
Gizmox.WebGUI.Forms Namespace


TextBoxBase Class Methods

[image]
Gizmox.WebGUI.Forms
TextBoxBase Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TextBoxBase Class

For a list of all members of this type, see TextBoxBase members.

Public Methods

 | Name | Description
Public Method | AppendText | Appends text to the current text of a text box.
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Clear | Clears all text from the text box control.
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | Copy | Copies the current selection in the text box to the Clipboard.
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Cut | Moves the current selection in the text box to the Clipboard.
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | Paste | Replaces the current selection in the text box with the contents of the Clipboard.
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | ScrollToCaret | Scrolls the contents of the control to the current caret position.
Public Method | Select | Overloaded. Selects a range of text in the text box.
Public Method | SelectAll | Selects all text in the text box.
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Overridden. Fires an event.
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetClipboardContent |
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Overridden. Gets the critical events.
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from Control)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | InvokeSelection | Invokes client side selection
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Control)
Protected Method | RenderAttributes | Overridden. Renders the current control attributes.
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | Overridden. Render control params
Protected Method | RenderValue |
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetClipboardContent |
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

See Also

Reference

TextBoxBase Class
Gizmox.WebGUI.Forms Namespace


AppendText Method

[image]
Gizmox.WebGUI.Forms
AppendText Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TextBoxBase Class : AppendText Method

text
The text to append to the current contents of the text box.
Appends text to the current text of a text box.

Syntax

Visual Basic (Declaration)
Public Sub AppendText( _
   ByVal text As String _
)
Visual Basic (Usage) Copy Code
Dim instance As TextBoxBase
Dim text As String

instance.AppendText(text)
C#
public void AppendText(
   string text
)
Managed Extensions for C++
public: void AppendText(
   string* text
)
C++/CLI
public:
void AppendText(
   String^ text
)

Parameters

text
The text to append to the current contents of the text box.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextBoxBase Class
TextBoxBase Members


Clear Method

[image]
Gizmox.WebGUI.Forms
Clear Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TextBoxBase Class : Clear Method

Clears all text from the text box control.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As TextBoxBase

instance.Clear()
C#
public void Clear()
Managed Extensions for C++
public: void Clear();
C++/CLI
public:
void Clear();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextBoxBase Class
TextBoxBase Members


Copy Method

[image]
Gizmox.WebGUI.Forms
Copy Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TextBoxBase Class : Copy Method

Copies the current selection in the text box to the Clipboard.

Syntax

Visual Basic (Declaration)
Public Sub Copy()
Visual Basic (Usage) Copy Code
Dim instance As TextBoxBase

instance.Copy()
C#
public void Copy()
Managed Extensions for C++
public: void Copy();
C++/CLI
public:
void Copy();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextBoxBase Class
TextBoxBase Members


Cut Method

[image]
Gizmox.WebGUI.Forms
Cut Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TextBoxBase Class : Cut Method

Moves the current selection in the text box to the Clipboard.

Syntax

Visual Basic (Declaration)
Public Sub Cut()
Visual Basic (Usage) Copy Code
Dim instance As TextBoxBase

instance.Cut()
C#
public void Cut()
Managed Extensions for C++
public: void Cut();
C++/CLI
public:
void Cut();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextBoxBase Class
TextBoxBase Members


FireEvent Method

[image]
Gizmox.WebGUI.Forms
FireEvent Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TextBoxBase Class : FireEvent Method

objEvent
event.
Fires an event.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub FireEvent( _
   ByVal objEvent As IEvent _
)
Visual Basic (Usage) Copy Code
Dim instance As TextBoxBase
Dim objEvent As IEvent

instance.FireEvent(objEvent)
C#
protected override void FireEvent(
   IEvent objEvent
)
Managed Extensions for C++
protected: void FireEvent(
   IEvent* objEvent
) override
C++/CLI
protected:
void FireEvent(
   IEvent^ objEvent
) override

Parameters

objEvent
event.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextBoxBase Class
TextBoxBase Members


GetClipboardContent Method

[image]
Gizmox.WebGUI.Forms
GetClipboardContent Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TextBoxBase Class : GetClipboardContent Method

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetClipboardContent() As String
Visual Basic (Usage) Copy Code
Dim instance As TextBoxBase
Dim value As String

value = instance.GetClipboardContent()
C#
protected virtual string GetClipboardContent()
Managed Extensions for C++
protected: virtual string* GetClipboardContent();
C++/CLI
protected:
virtual String^ GetClipboardContent();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextBoxBase Class
TextBoxBase Members


GetCriticalEvents Method

[image]
Gizmox.WebGUI.Forms
GetCriticalEvents Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TextBoxBase Class : GetCriticalEvents Method

Gets the critical events.

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetCriticalEvents() As EventTypes
Visual Basic (Usage) Copy Code
Dim instance As TextBoxBase
Dim value As EventTypes

value = instance.GetCriticalEvents()
C#
protected override EventTypes GetCriticalEvents()
Managed Extensions for C++
protected: EventTypes GetCriticalEvents(); override
C++/CLI
protected:
EventTypes GetCriticalEvents(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextBoxBase Class
TextBoxBase Members


InvokeSelection Method

[image]
Gizmox.WebGUI.Forms
InvokeSelection Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TextBoxBase Class : InvokeSelection Method

start
length
Invokes client side selection

Syntax

Visual Basic (Declaration)
Protected Overridable Sub InvokeSelection( _
   ByVal start As Integer, _
   ByVal length As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As TextBoxBase
Dim start As Integer
Dim length As Integer

instance.InvokeSelection(start, length)
C#
protected virtual void InvokeSelection(
   int start,
   int length
)
Managed Extensions for C++
protected: virtual void InvokeSelection(
   int start,
   int length
)
C++/CLI
protected:
virtual void InvokeSelection(
   int start,
   int length
)

Parameters

start
length

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextBoxBase Class
TextBoxBase Members


Paste Method

[image]
Gizmox.WebGUI.Forms
Paste Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TextBoxBase Class : Paste Method

Replaces the current selection in the text box with the contents of the Clipboard.

Syntax

Visual Basic (Declaration)
Public Sub Paste()
Visual Basic (Usage) Copy Code
Dim instance As TextBoxBase

instance.Paste()
C#
public void Paste()
Managed Extensions for C++
public: void Paste();
C++/CLI
public:
void Paste();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextBoxBase Class
TextBoxBase Members


RenderAttributes Method

[image]
Gizmox.WebGUI.Forms
RenderAttributes Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TextBoxBase Class : RenderAttributes Method

objContext
Request context.
objWriter
The response writer object.
Renders the current control attributes.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub RenderAttributes( _
   ByVal objContext As IContext, _
   ByVal objWriter As IAttributeWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As TextBoxBase
Dim objContext As IContext
Dim objWriter As IAttributeWriter

instance.RenderAttributes(objContext, objWriter)
C#
protected override void RenderAttributes(
   IContext objContext,
   IAttributeWriter objWriter
)
Managed Extensions for C++
protected: void RenderAttributes(
   IContext* objContext,
   IAttributeWriter* objWriter
) override
C++/CLI
protected:
void RenderAttributes(
   IContext^ objContext,
   IAttributeWriter^ objWriter
) override

Parameters

objContext
Request context.
objWriter
The response writer object.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextBoxBase Class
TextBoxBase Members


RenderUpdatedAttributes Method

[image]
Gizmox.WebGUI.Forms
RenderUpdatedAttributes Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TextBoxBase Class : RenderUpdatedAttributes Method

objContext
Request context.
objWriter
The response writer object.
lngRequestID
Request ID.
Render control params

Syntax

Visual Basic (Declaration)
Protected Overrides Sub RenderUpdatedAttributes( _
   ByVal objContext As IContext, _
   ByVal objWriter As IAttributeWriter, _
   ByVal lngRequestID As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As TextBoxBase
Dim objContext As IContext
Dim objWriter As IAttributeWriter
Dim lngRequestID As Long

instance.RenderUpdatedAttributes(objContext, objWriter, lngRequestID)
C#
protected override void RenderUpdatedAttributes(
   IContext objContext,
   IAttributeWriter objWriter,
   long lngRequestID
)
Managed Extensions for C++
protected: void RenderUpdatedAttributes(
   IContext* objContext,
   IAttributeWriter* objWriter,
   long lngRequestID
) override
C++/CLI
protected:
void RenderUpdatedAttributes(
   IContext^ objContext,
   IAttributeWriter^ objWriter,
   long long lngRequestID
) override

Parameters

objContext
Request context.
objWriter
The response writer object.
lngRequestID
Request ID.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextBoxBase Class
TextBoxBase Members


RenderValue Method

[image]
Gizmox.WebGUI.Forms
RenderValue Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TextBoxBase Class : RenderValue Method

objContext
objWriter

Syntax

Visual Basic (Declaration)
Protected MustOverride Sub RenderValue( _
   ByVal objContext As IContext, _
   ByVal objWriter As IAttributeWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As TextBoxBase
Dim objContext As IContext
Dim objWriter As IAttributeWriter

instance.RenderValue(objContext, objWriter)
C#
protected abstract void RenderValue(
   IContext objContext,
   IAttributeWriter objWriter
)
Managed Extensions for C++
protected: abstract void RenderValue(
   IContext* objContext,
   IAttributeWriter* objWriter
)
C++/CLI
protected:
abstract void RenderValue(
   IContext^ objContext,
   IAttributeWriter^ objWriter
)

Parameters

objContext
objWriter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextBoxBase Class
TextBoxBase Members


ScrollToCaret Method

[image]
Gizmox.WebGUI.Forms
ScrollToCaret Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TextBoxBase Class : ScrollToCaret Method

Scrolls the contents of the control to the current caret position.

Syntax

Visual Basic (Declaration)
Public Sub ScrollToCaret()
Visual Basic (Usage) Copy Code
Dim instance As TextBoxBase

instance.ScrollToCaret()
C#
public void ScrollToCaret()
Managed Extensions for C++
public: void ScrollToCaret();
C++/CLI
public:
void ScrollToCaret();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextBoxBase Class
TextBoxBase Members


Select Method

[image]
Gizmox.WebGUI.Forms
Select Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TextBoxBase Class : Select Method

Selects a range of text in the text box.

Overload List

Overload | Description
Select(Int32,Int32) | Selects a range of text in the text box.
Select() | Activates the control. (Inherited from Control)
Select(Boolean,Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextBoxBase Class
TextBoxBase Members


Select(Int32,Int32) Method

[image]
Gizmox.WebGUI.Forms
Select(Int32,Int32) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TextBoxBase Class > Select Method : Select(Int32,Int32) Method

start
The position of the first character in the current text selection within the text box.
length
The number of characters to select.
Selects a range of text in the text box.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Select( _
   ByVal start As Integer, _
   ByVal length As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As TextBoxBase
Dim start As Integer
Dim length As Integer

instance.Select(start, length)
C#
public void Select(
   int start,
   int length
)
Managed Extensions for C++
public: void Select(
   int start,
   int length
)
C++/CLI
public:
void Select(
   int start,
   int length
)

Parameters

start
The position of the first character in the current text selection within the text box.
length
The number of characters to select.

Exceptions

Exception | Description
ArgumentOutOfRangeException | The value of the start parameter is less than zero.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextBoxBase Class
TextBoxBase Members
Overload List


SelectAll Method

[image]
Gizmox.WebGUI.Forms
SelectAll Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TextBoxBase Class : SelectAll Method

Selects all text in the text box.

Syntax

Visual Basic (Declaration)
Public Sub SelectAll()
Visual Basic (Usage) Copy Code
Dim instance As TextBoxBase

instance.SelectAll()
C#
public void SelectAll()
Managed Extensions for C++
public: void SelectAll();
C++/CLI
public:
void SelectAll();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextBoxBase Class
TextBoxBase Members


SetClipboardContent Method

[image]
Gizmox.WebGUI.Forms
SetClipboardContent Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TextBoxBase Class : SetClipboardContent Method

strValue

Syntax

Visual Basic (Declaration)
Protected Overridable Sub SetClipboardContent( _
   ByVal strValue As String _
)
Visual Basic (Usage) Copy Code
Dim instance As TextBoxBase
Dim strValue As String

instance.SetClipboardContent(strValue)
C#
protected virtual void SetClipboardContent(
   string strValue
)
Managed Extensions for C++
protected: virtual void SetClipboardContent(
   string* strValue
)
C++/CLI
protected:
virtual void SetClipboardContent(
   String^ strValue
)

Parameters

strValue

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextBoxBase Class
TextBoxBase Members


TextBoxBase Class Properties

[image]
Gizmox.WebGUI.Forms
TextBoxBase Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TextBoxBase Class

For a list of all members of this type, see TextBoxBase members.

Public Properties

 | Name | Description
Public Property | AcceptsTab |
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Lines |
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MaxLength |
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Multiline | Gets or sets a value indicating whether text box is multi line.
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | ReadOnly | Gets or sets a value indicating whether [read only].
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | SelectedText | Gets or sets a value indicating the currently selected text in the control.
Public Property | SelectionLength | Gets or sets the number of characters selected in the text box.
Public Property | SelectionStart | Gets or sets the starting point of text selected in the text box.
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Control)
Public Property | TextLength | Gets the length of text in the control.
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Public Property | WordWrap |
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

See Also

Reference

TextBoxBase Class
Gizmox.WebGUI.Forms Namespace


AcceptsTab Property

[image]
Gizmox.WebGUI.Forms
AcceptsTab Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TextBoxBase Class : AcceptsTab Property

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property AcceptsTab As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TextBoxBase
Dim value As Boolean

instance.AcceptsTab = value

value = instance.AcceptsTab
C#
[DefaultValueAttribute()]
public bool AcceptsTab {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property bool get_AcceptsTab();
public: __property void set_AcceptsTab(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
public:
property bool AcceptsTab {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextBoxBase Class
TextBoxBase Members


Lines Property

[image]
Gizmox.WebGUI.Forms
Lines Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TextBoxBase Class : Lines Property

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
Public Property Lines As String()
Visual Basic (Usage) Copy Code
Dim instance As TextBoxBase
Dim value() As String

instance.Lines = value

value = instance.Lines
C#
[DesignerSerializationVisibilityAttribute()]
public string[] Lines {get; set;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
public: __property string*[]* get_Lines();
public: __property void set_Lines(
   string*[]* value
);
C++/CLI
[DesignerSerializationVisibilityAttribute()]
public:
property array<String^>^ Lines {
   array<String^>^ get();
   void set (String^array<value>^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextBoxBase Class
TextBoxBase Members


MaxLength Property

[image]
Gizmox.WebGUI.Forms
MaxLength Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TextBoxBase Class : MaxLength Property

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Specifies the maximum number of characters that can be entered into the edit control.")>
<DefaultValueAttribute()>
<SRCategoryAttribute("Behavior")>
<LocalizableAttribute(True)>
Public Property MaxLength As Integer
Visual Basic (Usage) Copy Code
Dim instance As TextBoxBase
Dim value As Integer

instance.MaxLength = value

value = instance.MaxLength
C#
[SRDescriptionAttribute("Specifies the maximum number of characters that can be entered into the edit control.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
[LocalizableAttribute(true)]
public int MaxLength {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Specifies the maximum number of characters that can be entered into the edit control.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
[LocalizableAttribute(true)]
public: __property int get_MaxLength();
public: __property void set_MaxLength(
   int value
);
C++/CLI
[SRDescriptionAttribute("Specifies the maximum number of characters that can be entered into the edit control.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
[LocalizableAttribute(true)]
public:
property int MaxLength {
   int get();
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextBoxBase Class
TextBoxBase Members


Multiline Property

[image]
Gizmox.WebGUI.Forms
Multiline Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TextBoxBase Class : Multiline Property

Gets or sets a value indicating whether text box is multi line.

Syntax

Visual Basic (Declaration)
<RefreshPropertiesAttribute()>
<SRDescriptionAttribute("Controls whether the text of the edit control can span more than one line.")>
<LocalizableAttribute(True)>
<SRCategoryAttribute("Behavior")>
<DefaultValueAttribute()>
Public Property Multiline As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TextBoxBase
Dim value As Boolean

instance.Multiline = value

value = instance.Multiline
C#
[RefreshPropertiesAttribute()]
[SRDescriptionAttribute("Controls whether the text of the edit control can span more than one line.")]
[LocalizableAttribute(true)]
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
public bool Multiline {get; set;}
Managed Extensions for C++
[RefreshPropertiesAttribute()]
[SRDescriptionAttribute("Controls whether the text of the edit control can span more than one line.")]
[LocalizableAttribute(true)]
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
public: __property bool get_Multiline();
public: __property void set_Multiline(
   bool value
);
C++/CLI
[RefreshPropertiesAttribute()]
[SRDescriptionAttribute("Controls whether the text of the edit control can span more than one line.")]
[LocalizableAttribute(true)]
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
public:
property bool Multiline {
   bool get();
   void set (boolvalue);
}

Return Value

true if multi line otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextBoxBase Class
TextBoxBase Members


ReadOnly Property

[image]
Gizmox.WebGUI.Forms
ReadOnly Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TextBoxBase Class : ReadOnly Property

Gets or sets a value indicating whether [read only].

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Controls whether the text in the edit control can be changed or not.")>
<RefreshPropertiesAttribute()>
<SRCategoryAttribute("Behavior")>
<DefaultValueAttribute()>
Public Property ReadOnly As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TextBoxBase
Dim value As Boolean

instance.ReadOnly = value

value = instance.ReadOnly
C#
[SRDescriptionAttribute("Controls whether the text in the edit control can be changed or not.")]
[RefreshPropertiesAttribute()]
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
public bool ReadOnly {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Controls whether the text in the edit control can be changed or not.")]
[RefreshPropertiesAttribute()]
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
public: __property bool get_ReadOnly();
public: __property void set_ReadOnly(
   bool value
);
C++/CLI
[SRDescriptionAttribute("Controls whether the text in the edit control can be changed or not.")]
[RefreshPropertiesAttribute()]
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
public:
property bool ReadOnly {
   bool get();
   void set (boolvalue);
}

Return Value

true if [read only]; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextBoxBase Class
TextBoxBase Members


SelectedText Property

[image]
Gizmox.WebGUI.Forms
SelectedText Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TextBoxBase Class : SelectedText Property

Gets or sets a value indicating the currently selected text in the control.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("The currently selected text.")>
<SRCategoryAttribute("Appearance")>
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public Overridable Property SelectedText As String
Visual Basic (Usage) Copy Code
Dim instance As TextBoxBase
Dim value As String

instance.SelectedText = value

value = instance.SelectedText
C#
[SRDescriptionAttribute("The currently selected text.")]
[SRCategoryAttribute("Appearance")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public virtual string SelectedText {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("The currently selected text.")]
[SRCategoryAttribute("Appearance")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property virtual string* get_SelectedText();
public: __property virtual void set_SelectedText(
   string* value
);
C++/CLI
[SRDescriptionAttribute("The currently selected text.")]
[SRCategoryAttribute("Appearance")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
virtual property String^ SelectedText {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextBoxBase Class
TextBoxBase Members


SelectionLength Property

[image]
Gizmox.WebGUI.Forms
SelectionLength Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TextBoxBase Class : SelectionLength Property

Gets or sets the number of characters selected in the text box.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("The length of the currently selected text.")>
<SRCategoryAttribute("Appearance")>
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public Overridable Property SelectionLength As Integer
Visual Basic (Usage) Copy Code
Dim instance As TextBoxBase
Dim value As Integer

instance.SelectionLength = value

value = instance.SelectionLength
C#
[SRDescriptionAttribute("The length of the currently selected text.")]
[SRCategoryAttribute("Appearance")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public virtual int SelectionLength {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("The length of the currently selected text.")]
[SRCategoryAttribute("Appearance")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property virtual int get_SelectionLength();
public: __property virtual void set_SelectionLength(
   int value
);
C++/CLI
[SRDescriptionAttribute("The length of the currently selected text.")]
[SRCategoryAttribute("Appearance")]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
virtual property int SelectionLength {
   int get();
   void set (intvalue);
}

Exceptions

Exception | Description
ArgumentOutOfRangeException | The assigned value is less than zero.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextBoxBase Class
TextBoxBase Members


SelectionStart Property

[image]
Gizmox.WebGUI.Forms
SelectionStart Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TextBoxBase Class : SelectionStart Property

Gets or sets the starting point of text selected in the text box.

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
<SRDescriptionAttribute("The beginning of the currently selected text.")>
<BrowsableAttribute(False)>
<SRCategoryAttribute("Appearance")>
Public Property SelectionStart As Integer
Visual Basic (Usage) Copy Code
Dim instance As TextBoxBase
Dim value As Integer

instance.SelectionStart = value

value = instance.SelectionStart
C#
[DesignerSerializationVisibilityAttribute()]
[SRDescriptionAttribute("The beginning of the currently selected text.")]
[BrowsableAttribute(false)]
[SRCategoryAttribute("Appearance")]
public int SelectionStart {get; set;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
[SRDescriptionAttribute("The beginning of the currently selected text.")]
[BrowsableAttribute(false)]
[SRCategoryAttribute("Appearance")]
public: __property int get_SelectionStart();
public: __property void set_SelectionStart(
   int value
);
C++/CLI
[DesignerSerializationVisibilityAttribute()]
[SRDescriptionAttribute("The beginning of the currently selected text.")]
[BrowsableAttribute(false)]
[SRCategoryAttribute("Appearance")]
public:
property int SelectionStart {
   int get();
   void set (intvalue);
}

Exceptions

Exception | Description
ArgumentOutOfRangeException | The assigned value is less than zero.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextBoxBase Class
TextBoxBase Members


TextLength Property

[image]
Gizmox.WebGUI.Forms
TextLength Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TextBoxBase Class : TextLength Property

Gets the length of text in the control.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public Overridable ReadOnly Property TextLength As Integer
Visual Basic (Usage) Copy Code
Dim instance As TextBoxBase
Dim value As Integer

value = instance.TextLength
C#
[BrowsableAttribute(false)]
public virtual int TextLength {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property virtual int get_TextLength();
C++/CLI
[BrowsableAttribute(false)]
public:
virtual property int TextLength {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextBoxBase Class
TextBoxBase Members


WordWrap Property

[image]
Gizmox.WebGUI.Forms
WordWrap Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TextBoxBase Class : WordWrap Property

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property WordWrap As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TextBoxBase
Dim value As Boolean

instance.WordWrap = value

value = instance.WordWrap
C#
[DefaultValueAttribute()]
public bool WordWrap {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property bool get_WordWrap();
public: __property void set_WordWrap(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
public:
property bool WordWrap {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextBoxBase Class
TextBoxBase Members


TextBoxChangedEventArgs Class

[image]
Gizmox.WebGUI.Forms
TextBoxChangedEventArgs Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TextBoxChangedEventArgs Class

Object Model

Syntax

Visual Basic (Declaration)
Public Class TextBoxChangedEventArgs
   Inherits EventArgs
Visual Basic (Usage) Copy Code
Dim instance As TextBoxChangedEventArgs
C#
public class TextBoxChangedEventArgs : EventArgs
Managed Extensions for C++
public __gc class TextBoxChangedEventArgs : public EventArgs
C++/CLI
public ref class TextBoxChangedEventArgs : public EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gizmox.WebGUI.Forms.TextBoxChangedEventArgs

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

TextBoxChangedEventArgs Members
Gizmox.WebGUI.Forms Namespace


TextBoxChangedEventArgs Class Members

[image]
Gizmox.WebGUI.Forms
TextBoxChangedEventArgs Class Members
See Also Fields Send Feedback
Gizmox.WebGUI.Forms Namespace : TextBoxChangedEventArgs Class

The following tables list the members exposed by TextBoxChangedEventArgs.

Public Constructors

 | Name | Description
Public Constructor | TextBoxChangedEventArgs Constructor |
Top

Public Fields

 | Name | Description
Public Field | OldValue |
Public Field | TextBox |
Top

See Also

Reference

TextBoxChangedEventArgs Class
Gizmox.WebGUI.Forms Namespace


TextBoxChangedEventArgs Constructor

[image]
Gizmox.WebGUI.Forms
TextBoxChangedEventArgs Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TextBoxChangedEventArgs Class : TextBoxChangedEventArgs Constructor

objTextBox
strOldValue

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal objTextBox As TextBox, _
   ByVal strOldValue As String _
)
Visual Basic (Usage) Copy Code
Dim objTextBox As TextBox
Dim strOldValue As String

Dim instance As TextBoxChangedEventArgs(objTextBox, strOldValue)
C#
public TextBoxChangedEventArgs(
   TextBox objTextBox,
   string strOldValue
)
Managed Extensions for C++
public: TextBoxChangedEventArgs(
   TextBox* objTextBox,
   string* strOldValue
)
C++/CLI
public:
TextBoxChangedEventArgs(
   TextBox^ objTextBox,
   String^ strOldValue
)

Parameters

objTextBox
strOldValue

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextBoxChangedEventArgs Class
TextBoxChangedEventArgs Members


TextBoxChangedEventArgs Class Fields

[image]
Gizmox.WebGUI.Forms
TextBoxChangedEventArgs Class Fields
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TextBoxChangedEventArgs Class

For a list of all members of this type, see TextBoxChangedEventArgs members.

Public Fields

 | Name | Description
Public Field | OldValue |
Public Field | TextBox |
Top

See Also

Reference

TextBoxChangedEventArgs Class
Gizmox.WebGUI.Forms Namespace


OldValue Field

[image]
Gizmox.WebGUI.Forms
OldValue Field
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TextBoxChangedEventArgs Class : OldValue Field

Syntax

Visual Basic (Declaration)
Public ReadOnly OldValue As String
Visual Basic (Usage) Copy Code
Dim instance As TextBoxChangedEventArgs
Dim value As String

value = instance.OldValue
C#
public readonly string OldValue
Managed Extensions for C++
public: readonly string* OldValue
C++/CLI
public:
readonly String^ OldValue

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextBoxChangedEventArgs Class
TextBoxChangedEventArgs Members


TextBox Field

[image]
Gizmox.WebGUI.Forms
TextBox Field
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TextBoxChangedEventArgs Class : TextBox Field

Syntax

Visual Basic (Declaration)
Public ReadOnly TextBox As TextBox
Visual Basic (Usage) Copy Code
Dim instance As TextBoxChangedEventArgs
Dim value As TextBox

value = instance.TextBox
C#
public readonly TextBox TextBox
Managed Extensions for C++
public: readonly TextBox* TextBox
C++/CLI
public:
readonly TextBox^ TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextBoxChangedEventArgs Class
TextBoxChangedEventArgs Members


TextBoxValidation Class

[image]
Gizmox.WebGUI.Forms
TextBoxValidation Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TextBoxValidation Class

Syntax

Visual Basic (Declaration)
Public Class TextBoxValidation
Visual Basic (Usage) Copy Code
Dim instance As TextBoxValidation
C#
public class TextBoxValidation
Managed Extensions for C++
public __gc class TextBoxValidation
C++/CLI
public ref class TextBoxValidation

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.TextBoxValidation

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

TextBoxValidation Members
Gizmox.WebGUI.Forms Namespace


TextBoxValidation Class Members

[image]
Gizmox.WebGUI.Forms
TextBoxValidation Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : TextBoxValidation Class

The following tables list the members exposed by TextBoxValidation.

Public Constructors

 | Name | Description
Public Constructor | TextBoxValidation Constructor | Overloaded. Initializes a new instance of the TextBoxValidation class.
Top

Public Properties

 | Name | Description
Public Property | CharacterValidationExpression | Gets or sets the character validation expression.
Public Property | CharacterValidationMask | Gets the character validation mask.
static (Shared in Visual Basic) | CodeMaskValidator | Gets an code mask validator.
static (Shared in Visual Basic) | EmailValidator | Gets an email validator.
static (Shared in Visual Basic) | FloatMaskValidator | Gets an floating point number mask validator.
static (Shared in Visual Basic) | FloatValidator | Gets an floating point number validator.
static (Shared in Visual Basic) | IntegerMaskValidator | Gets an integer mask validator.
static (Shared in Visual Basic) | IntegerValidator | Gets an integer validator.
Public Property | InValidateMessage | Gets the in validate message.
Public Property | ValueValidationExpression | Gets the value validation expression.
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | CreateFloatValidator |
static (Shared in Visual Basic) | CreateIntegerValidator |
Top

See Also

Reference

TextBoxValidation Class
Gizmox.WebGUI.Forms Namespace


TextBoxValidation Constructor

[image]
Gizmox.WebGUI.Forms
TextBoxValidation Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TextBoxValidation Class : TextBoxValidation Constructor

Initializes a new instance of the TextBoxValidation class.

Overload List

Overload | Description
TextBoxValidation Constructor(String,String) | Initializes a new instance of the TextBoxValidation class.
TextBoxValidation Constructor(String,String,String) | Initializes a new instance of the TextBoxValidation class.
TextBoxValidation Constructor(String,String,String,String) | Initializes a new instance of the TextBoxValidation class.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextBoxValidation Class
TextBoxValidation Members


TextBoxValidation Constructor(String,String)

[image]
Gizmox.WebGUI.Forms
TextBoxValidation Constructor(String,String)
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TextBoxValidation Class > TextBoxValidation Constructor : TextBoxValidation Constructor(String,String)

strValueValidationExpression
The value validation expression.
strInValidateMessage
The in validate message.
Initializes a new instance of the TextBoxValidation class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal strValueValidationExpression As String, _
   ByVal strInValidateMessage As String _
)
Visual Basic (Usage) Copy Code
Dim strValueValidationExpression As String
Dim strInValidateMessage As String

Dim instance As TextBoxValidation(strValueValidationExpression, strInValidateMessage)
C#
public TextBoxValidation(
   string strValueValidationExpression,
   string strInValidateMessage
)
Managed Extensions for C++
public: TextBoxValidation(
   string* strValueValidationExpression,
   string* strInValidateMessage
)
C++/CLI
public:
TextBoxValidation(
   String^ strValueValidationExpression,
   String^ strInValidateMessage
)

Parameters

strValueValidationExpression
The value validation expression.
strInValidateMessage
The in validate message.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextBoxValidation Class
TextBoxValidation Members
Overload List


TextBoxValidation Constructor(String,String,String)

[image]
Gizmox.WebGUI.Forms
TextBoxValidation Constructor(String,String,String)
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TextBoxValidation Class > TextBoxValidation Constructor : TextBoxValidation Constructor(String,String,String)

strValueValidationExpression
The value validation expression.
strInValidateMessage
The in validate message.
strCharacterValidationMask
The character validation mask.
Initializes a new instance of the TextBoxValidation class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal strValueValidationExpression As String, _
   ByVal strInValidateMessage As String, _
   ByVal strCharacterValidationMask As String _
)
Visual Basic (Usage) Copy Code
Dim strValueValidationExpression As String
Dim strInValidateMessage As String
Dim strCharacterValidationMask As String

Dim instance As TextBoxValidation(strValueValidationExpression, strInValidateMessage, strCharacterValidationMask)
C#
public TextBoxValidation(
   string strValueValidationExpression,
   string strInValidateMessage,
   string strCharacterValidationMask
)
Managed Extensions for C++
public: TextBoxValidation(
   string* strValueValidationExpression,
   string* strInValidateMessage,
   string* strCharacterValidationMask
)
C++/CLI
public:
TextBoxValidation(
   String^ strValueValidationExpression,
   String^ strInValidateMessage,
   String^ strCharacterValidationMask
)

Parameters

strValueValidationExpression
The value validation expression.
strInValidateMessage
The in validate message.
strCharacterValidationMask
The character validation mask.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextBoxValidation Class
TextBoxValidation Members
Overload List


TextBoxValidation Constructor(String,String,String,String)

[image]
Gizmox.WebGUI.Forms
TextBoxValidation Constructor(String,String,String,String)
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TextBoxValidation Class > TextBoxValidation Constructor : TextBoxValidation Constructor(String,String,String,String)

strValueValidationExpression
The value validation expression.
strInValidateMessage
The in validate message.
strCharacterValidationMask
The character validation mask.
strCharacterValidationExpression
The character validation expression.
Initializes a new instance of the TextBoxValidation class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal strValueValidationExpression As String, _
   ByVal strInValidateMessage As String, _
   ByVal strCharacterValidationMask As String, _
   ByVal strCharacterValidationExpression As String _
)
Visual Basic (Usage) Copy Code
Dim strValueValidationExpression As String
Dim strInValidateMessage As String
Dim strCharacterValidationMask As String
Dim strCharacterValidationExpression As String

Dim instance As TextBoxValidation(strValueValidationExpression, strInValidateMessage, strCharacterValidationMask, strCharacterValidationExpression)
C#
public TextBoxValidation(
   string strValueValidationExpression,
   string strInValidateMessage,
   string strCharacterValidationMask,
   string strCharacterValidationExpression
)
Managed Extensions for C++
public: TextBoxValidation(
   string* strValueValidationExpression,
   string* strInValidateMessage,
   string* strCharacterValidationMask,
   string* strCharacterValidationExpression
)
C++/CLI
public:
TextBoxValidation(
   String^ strValueValidationExpression,
   String^ strInValidateMessage,
   String^ strCharacterValidationMask,
   String^ strCharacterValidationExpression
)

Parameters

strValueValidationExpression
The value validation expression.
strInValidateMessage
The in validate message.
strCharacterValidationMask
The character validation mask.
strCharacterValidationExpression
The character validation expression.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextBoxValidation Class
TextBoxValidation Members
Overload List


TextBoxValidation Class Methods

[image]
Gizmox.WebGUI.Forms
TextBoxValidation Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TextBoxValidation Class

For a list of all members of this type, see TextBoxValidation members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | CreateFloatValidator |
static (Shared in Visual Basic) | CreateIntegerValidator |
Top

See Also

Reference

TextBoxValidation Class
Gizmox.WebGUI.Forms Namespace


CreateFloatValidator Method

[image]
Gizmox.WebGUI.Forms
CreateFloatValidator Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TextBoxValidation Class : CreateFloatValidator Method

intMinValue
intMaxValue

Syntax

Visual Basic (Declaration)
Public Shared Function CreateFloatValidator( _
   ByVal intMinValue As Double, _
   ByVal intMaxValue As Double _
) As TextBoxValidation
Visual Basic (Usage) Copy Code
Dim intMinValue As Double
Dim intMaxValue As Double
Dim value As TextBoxValidation

value = TextBoxValidation.CreateFloatValidator(intMinValue, intMaxValue)
C#
public static TextBoxValidation CreateFloatValidator(
   double intMinValue,
   double intMaxValue
)
Managed Extensions for C++
public: static TextBoxValidation* CreateFloatValidator(
   double intMinValue,
   double intMaxValue
)
C++/CLI
public:
static TextBoxValidation^ CreateFloatValidator(
   double intMinValue,
   double intMaxValue
)

Parameters

intMinValue
intMaxValue

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextBoxValidation Class
TextBoxValidation Members


CreateIntegerValidator Method

[image]
Gizmox.WebGUI.Forms
CreateIntegerValidator Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TextBoxValidation Class : CreateIntegerValidator Method

intMinValue
intMaxValue

Syntax

Visual Basic (Declaration)
Public Shared Function CreateIntegerValidator( _
   ByVal intMinValue As Integer, _
   ByVal intMaxValue As Integer _
) As TextBoxValidation
Visual Basic (Usage) Copy Code
Dim intMinValue As Integer
Dim intMaxValue As Integer
Dim value As TextBoxValidation

value = TextBoxValidation.CreateIntegerValidator(intMinValue, intMaxValue)
C#
public static TextBoxValidation CreateIntegerValidator(
   int intMinValue,
   int intMaxValue
)
Managed Extensions for C++
public: static TextBoxValidation* CreateIntegerValidator(
   int intMinValue,
   int intMaxValue
)
C++/CLI
public:
static TextBoxValidation^ CreateIntegerValidator(
   int intMinValue,
   int intMaxValue
)

Parameters

intMinValue
intMaxValue

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextBoxValidation Class
TextBoxValidation Members


TextBoxValidation Class Properties

[image]
Gizmox.WebGUI.Forms
TextBoxValidation Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TextBoxValidation Class

For a list of all members of this type, see TextBoxValidation members.

Public Properties

 | Name | Description
Public Property | CharacterValidationExpression | Gets or sets the character validation expression.
Public Property | CharacterValidationMask | Gets the character validation mask.
static (Shared in Visual Basic) | CodeMaskValidator | Gets an code mask validator.
static (Shared in Visual Basic) | EmailValidator | Gets an email validator.
static (Shared in Visual Basic) | FloatMaskValidator | Gets an floating point number mask validator.
static (Shared in Visual Basic) | FloatValidator | Gets an floating point number validator.
static (Shared in Visual Basic) | IntegerMaskValidator | Gets an integer mask validator.
static (Shared in Visual Basic) | IntegerValidator | Gets an integer validator.
Public Property | InValidateMessage | Gets the in validate message.
Public Property | ValueValidationExpression | Gets the value validation expression.
Top

See Also

Reference

TextBoxValidation Class
Gizmox.WebGUI.Forms Namespace


CharacterValidationExpression Property

[image]
Gizmox.WebGUI.Forms
CharacterValidationExpression Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TextBoxValidation Class : CharacterValidationExpression Property

Gets or sets the character validation expression.

Syntax

Visual Basic (Declaration)
Public Property CharacterValidationExpression As String
Visual Basic (Usage) Copy Code
Dim instance As TextBoxValidation
Dim value As String

instance.CharacterValidationExpression = value

value = instance.CharacterValidationExpression
C#
public string CharacterValidationExpression {get; set;}
Managed Extensions for C++
public: __property string* get_CharacterValidationExpression();
public: __property void set_CharacterValidationExpression(
   string* value
);
C++/CLI
public:
property String^ CharacterValidationExpression {
   String^ get();
   void set (String^value);
}

Return Value

The character validation expression.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextBoxValidation Class
TextBoxValidation Members


CharacterValidationMask Property

[image]
Gizmox.WebGUI.Forms
CharacterValidationMask Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TextBoxValidation Class : CharacterValidationMask Property

Gets the character validation mask.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CharacterValidationMask As String
Visual Basic (Usage) Copy Code
Dim instance As TextBoxValidation
Dim value As String

value = instance.CharacterValidationMask
C#
public string CharacterValidationMask {get;}
Managed Extensions for C++
public: __property string* get_CharacterValidationMask();
C++/CLI
public:
property String^ CharacterValidationMask {
   String^ get();
}

Return Value

The character validation mask.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextBoxValidation Class
TextBoxValidation Members


CodeMaskValidator Property

[image]
Gizmox.WebGUI.Forms
CodeMaskValidator Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TextBoxValidation Class : CodeMaskValidator Property

Gets an code mask validator.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property CodeMaskValidator As TextBoxValidation
Visual Basic (Usage) Copy Code
Dim value As TextBoxValidation

value = TextBoxValidation.CodeMaskValidator
C#
public static TextBoxValidation CodeMaskValidator {get;}
Managed Extensions for C++
public: __property static TextBoxValidation* get_CodeMaskValidator();
C++/CLI
public:
static property TextBoxValidation^ CodeMaskValidator {
   TextBoxValidation^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextBoxValidation Class
TextBoxValidation Members


EmailValidator Property

[image]
Gizmox.WebGUI.Forms
EmailValidator Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TextBoxValidation Class : EmailValidator Property

Gets an email validator.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property EmailValidator As TextBoxValidation
Visual Basic (Usage) Copy Code
Dim value As TextBoxValidation

value = TextBoxValidation.EmailValidator
C#
public static TextBoxValidation EmailValidator {get;}
Managed Extensions for C++
public: __property static TextBoxValidation* get_EmailValidator();
C++/CLI
public:
static property TextBoxValidation^ EmailValidator {
   TextBoxValidation^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextBoxValidation Class
TextBoxValidation Members


FloatMaskValidator Property

[image]
Gizmox.WebGUI.Forms
FloatMaskValidator Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TextBoxValidation Class : FloatMaskValidator Property

Gets an floating point number mask validator.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property FloatMaskValidator As TextBoxValidation
Visual Basic (Usage) Copy Code
Dim value As TextBoxValidation

value = TextBoxValidation.FloatMaskValidator
C#
public static TextBoxValidation FloatMaskValidator {get;}
Managed Extensions for C++
public: __property static TextBoxValidation* get_FloatMaskValidator();
C++/CLI
public:
static property TextBoxValidation^ FloatMaskValidator {
   TextBoxValidation^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextBoxValidation Class
TextBoxValidation Members


FloatValidator Property

[image]
Gizmox.WebGUI.Forms
FloatValidator Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TextBoxValidation Class : FloatValidator Property

Gets an floating point number validator.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property FloatValidator As TextBoxValidation
Visual Basic (Usage) Copy Code
Dim value As TextBoxValidation

value = TextBoxValidation.FloatValidator
C#
public static TextBoxValidation FloatValidator {get;}
Managed Extensions for C++
public: __property static TextBoxValidation* get_FloatValidator();
C++/CLI
public:
static property TextBoxValidation^ FloatValidator {
   TextBoxValidation^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextBoxValidation Class
TextBoxValidation Members


IntegerMaskValidator Property

[image]
Gizmox.WebGUI.Forms
IntegerMaskValidator Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TextBoxValidation Class : IntegerMaskValidator Property

Gets an integer mask validator.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property IntegerMaskValidator As TextBoxValidation
Visual Basic (Usage) Copy Code
Dim value As TextBoxValidation

value = TextBoxValidation.IntegerMaskValidator
C#
public static TextBoxValidation IntegerMaskValidator {get;}
Managed Extensions for C++
public: __property static TextBoxValidation* get_IntegerMaskValidator();
C++/CLI
public:
static property TextBoxValidation^ IntegerMaskValidator {
   TextBoxValidation^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextBoxValidation Class
TextBoxValidation Members


IntegerValidator Property

[image]
Gizmox.WebGUI.Forms
IntegerValidator Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TextBoxValidation Class : IntegerValidator Property

Gets an integer validator.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property IntegerValidator As TextBoxValidation
Visual Basic (Usage) Copy Code
Dim value As TextBoxValidation

value = TextBoxValidation.IntegerValidator
C#
public static TextBoxValidation IntegerValidator {get;}
Managed Extensions for C++
public: __property static TextBoxValidation* get_IntegerValidator();
C++/CLI
public:
static property TextBoxValidation^ IntegerValidator {
   TextBoxValidation^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextBoxValidation Class
TextBoxValidation Members


InValidateMessage Property

[image]
Gizmox.WebGUI.Forms
InValidateMessage Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TextBoxValidation Class : InValidateMessage Property

Gets the in validate message.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property InValidateMessage As String
Visual Basic (Usage) Copy Code
Dim instance As TextBoxValidation
Dim value As String

value = instance.InValidateMessage
C#
public string InValidateMessage {get;}
Managed Extensions for C++
public: __property string* get_InValidateMessage();
C++/CLI
public:
property String^ InValidateMessage {
   String^ get();
}

Return Value

The in validate message.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextBoxValidation Class
TextBoxValidation Members


ValueValidationExpression Property

[image]
Gizmox.WebGUI.Forms
ValueValidationExpression Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TextBoxValidation Class : ValueValidationExpression Property

Gets the value validation expression.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ValueValidationExpression As String
Visual Basic (Usage) Copy Code
Dim instance As TextBoxValidation
Dim value As String

value = instance.ValueValidationExpression
C#
public string ValueValidationExpression {get;}
Managed Extensions for C++
public: __property string* get_ValueValidationExpression();
C++/CLI
public:
property String^ ValueValidationExpression {
   String^ get();
}

Return Value

The value validation expression.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TextBoxValidation Class
TextBoxValidation Members


Timer Class

[image]
Gizmox.WebGUI.Forms
Timer Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : Timer Class

Implements a timer that raises an event at user-defined intervals. This timer is optimized for use in Gizmox.WebGUI.Forms applications and must be used in a window.

Syntax

Visual Basic (Declaration)
<ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<ToolboxItemCategoryAttribute("Components")>
<ToolboxBitmapAttribute()>
<DefaultEventAttribute("Tick")>
<DefaultPropertyAttribute("Interval")>
<SRDescriptionAttribute("Component that raises an event at user defined intervals")>
<ToolboxItemFilterAttribute("Gizmox.WebGUI.Forms")>
Public Class Timer
   Inherits ComponentBase
   Implements ITimer
Visual Basic (Usage) Copy Code
Dim instance As Timer
C#
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ToolboxItemCategoryAttribute("Components")]
[ToolboxBitmapAttribute()]
[DefaultEventAttribute("Tick")]
[DefaultPropertyAttribute("Interval")]
[SRDescriptionAttribute("Component that raises an event at user defined intervals")]
[ToolboxItemFilterAttribute("Gizmox.WebGUI.Forms")]
public class Timer : ComponentBase, ITimer
Managed Extensions for C++
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ToolboxItemCategoryAttribute("Components")]
[ToolboxBitmapAttribute()]
[DefaultEventAttribute("Tick")]
[DefaultPropertyAttribute("Interval")]
[SRDescriptionAttribute("Component that raises an event at user defined intervals")]
[ToolboxItemFilterAttribute("Gizmox.WebGUI.Forms")]
public __gc class Timer : public ComponentBase, ITimer
C++/CLI
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ToolboxItemCategoryAttribute("Components")]
[ToolboxBitmapAttribute()]
[DefaultEventAttribute("Tick")]
[DefaultPropertyAttribute("Interval")]
[SRDescriptionAttribute("Component that raises an event at user defined intervals")]
[ToolboxItemFilterAttribute("Gizmox.WebGUI.Forms")]
public ref class Timer : public ComponentBase, ITimer

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.Timer

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Timer Members
Gizmox.WebGUI.Forms Namespace


Timer Class Members

[image]
Gizmox.WebGUI.Forms
Timer Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : Timer Class

The following tables list the members exposed by Timer.

Public Constructors

 | Name | Description
Public Constructor | Timer Constructor | Overloaded. Initializes a new instance of the Timer class with the specified container.
Top

Public Properties

 | Name | Description
Public Property | Container | (Inherited from ComponentBase)
Public Property | Enabled | Gets or sets whether the timer is running.
Public Property | Interval | Gets or sets the time, in milliseconds, between timer ticks.
Public Property | Site | (Inherited from ComponentBase)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Top

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded. Disposes of the resources (other than memory) used by the timer.
Public Method | Start | Starts the timer.
Public Method | Stop | Stops the timer.
Public Method | ToString | Overridden. Returns a string that represents the Timer.
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | OnTick | Raises the Tick event.
Top

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | Tick | Occurs when the specified timer interval has elapsed and the timer is enabled.
Top

See Also

Reference

Timer Class
Gizmox.WebGUI.Forms Namespace


Timer Constructor

[image]
Gizmox.WebGUI.Forms
Timer Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Timer Class : Timer Constructor

Initializes a new instance of the Timer class with the specified container.

Overload List

Overload | Description
Timer Constructor() | Initializes a new instance of the Timer class.
Timer Constructor(IContainer) | Initializes a new instance of the Timer class with the specified container.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Timer Class
Timer Members


Timer Constructor()

[image]
Gizmox.WebGUI.Forms
Timer Constructor()
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Timer Class > Timer Constructor : Timer Constructor()

Initializes a new instance of the Timer class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Timer()
C#
public Timer()
Managed Extensions for C++
public: Timer();
C++/CLI
public:
Timer();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Timer Class
Timer Members
Overload List


Timer Constructor(IContainer)

[image]
Gizmox.WebGUI.Forms
Timer Constructor(IContainer)
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Timer Class > Timer Constructor : Timer Constructor(IContainer)

container
An IContainer that represents the container for the timer.
Initializes a new instance of the Timer class with the specified container.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal container As IContainer _
)
Visual Basic (Usage) Copy Code
Dim container As IContainer

Dim instance As Timer(container)
C#
public Timer(
   IContainer container
)
Managed Extensions for C++
public: Timer(
   IContainer* container
)
C++/CLI
public:
Timer(
   IContainer^ container
)

Parameters

container
An IContainer that represents the container for the timer.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Timer Class
Timer Members
Overload List


Timer Class Methods

[image]
Gizmox.WebGUI.Forms
Timer Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : Timer Class

For a list of all members of this type, see Timer members.

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded. Disposes of the resources (other than memory) used by the timer.
Public Method | Start | Starts the timer.
Public Method | Stop | Stops the timer.
Public Method | ToString | Overridden. Returns a string that represents the Timer.
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | OnTick | Raises the Tick event.
Top

See Also

Reference

Timer Class
Gizmox.WebGUI.Forms Namespace


Dispose Method

[image]
Gizmox.WebGUI.Forms
Dispose Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Timer Class : Dispose Method

Disposes of the resources (other than memory) used by the timer.

Overload List

Overload | Description
Dispose(Boolean) | Disposes of the resources (other than memory) used by the timer.
Dispose() | (Inherited from ComponentBase)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Timer Class
Timer Members


Dispose(Boolean) Method

[image]
Gizmox.WebGUI.Forms
Dispose(Boolean) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Timer Class > Dispose Method : Dispose(Boolean) Method

disposing
Disposes of the resources (other than memory) used by the timer.

Syntax

Visual Basic (Declaration)
Protected Overloads Overridable Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As Timer
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected virtual void Dispose(
   bool disposing
)
Managed Extensions for C++
protected: virtual void Dispose(
   bool disposing
)
C++/CLI
protected:
virtual void Dispose(
   bool disposing
)

Parameters

disposing

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Timer Class
Timer Members
Overload List


OnTick Method

[image]
Gizmox.WebGUI.Forms
OnTick Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Timer Class : OnTick Method

e
An EventArgs that contains the event data. This is always Empty.
Raises the Tick event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnTick( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As Timer
Dim e As EventArgs

instance.OnTick(e)
C#
protected virtual void OnTick(
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnTick(
   EventArgs* e
)
C++/CLI
protected:
virtual void OnTick(
   EventArgs^ e
)

Parameters

e
An EventArgs that contains the event data. This is always Empty.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Timer Class
Timer Members


Start Method

[image]
Gizmox.WebGUI.Forms
Start Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Timer Class : Start Method

Starts the timer.

Syntax

Visual Basic (Declaration)
Public Sub Start()
Visual Basic (Usage) Copy Code
Dim instance As Timer

instance.Start()
C#
public void Start()
Managed Extensions for C++
public: void Start();
C++/CLI
public:
void Start();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Timer Class
Timer Members


Stop Method

[image]
Gizmox.WebGUI.Forms
Stop Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Timer Class : Stop Method

Stops the timer.

Syntax

Visual Basic (Declaration)
Public Sub Stop()
Visual Basic (Usage) Copy Code
Dim instance As Timer

instance.Stop()
C#
public void Stop()
Managed Extensions for C++
public: void Stop();
C++/CLI
public:
void Stop();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Timer Class
Timer Members


ToString Method

[image]
Gizmox.WebGUI.Forms
ToString Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Timer Class : ToString Method

Returns a string that represents the Timer.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As Timer
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Return Value

A string that represents the current Timer.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Timer Class
Timer Members


Timer Class Properties

[image]
Gizmox.WebGUI.Forms
Timer Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : Timer Class

For a list of all members of this type, see Timer members.

Public Properties

 | Name | Description
Public Property | Container | (Inherited from ComponentBase)
Public Property | Enabled | Gets or sets whether the timer is running.
Public Property | Interval | Gets or sets the time, in milliseconds, between timer ticks.
Public Property | Site | (Inherited from ComponentBase)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Top

See Also

Reference

Timer Class
Gizmox.WebGUI.Forms Namespace


Enabled Property

[image]
Gizmox.WebGUI.Forms
Enabled Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Timer Class : Enabled Property

Gets or sets whether the timer is running.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Enables generation of Elapsed events.")>
<SRCategoryAttribute("Behavior")>
<DefaultValueAttribute()>
Public Overridable Property Enabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Timer
Dim value As Boolean

instance.Enabled = value

value = instance.Enabled
C#
[SRDescriptionAttribute("Enables generation of Elapsed events.")]
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
public virtual bool Enabled {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Enables generation of Elapsed events.")]
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
public: __property virtual bool get_Enabled();
public: __property virtual void set_Enabled(
   bool value
);
C++/CLI
[SRDescriptionAttribute("Enables generation of Elapsed events.")]
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
public:
virtual property bool Enabled {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Timer Class
Timer Members


Interval Property

[image]
Gizmox.WebGUI.Forms
Interval Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Timer Class : Interval Property

Gets or sets the time, in milliseconds, between timer ticks.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("The frequency of Elapsed events in milliseconds.")>
<SRCategoryAttribute("Behavior")>
<DefaultValueAttribute()>
Public Property Interval As Integer
Visual Basic (Usage) Copy Code
Dim instance As Timer
Dim value As Integer

instance.Interval = value

value = instance.Interval
C#
[SRDescriptionAttribute("The frequency of Elapsed events in milliseconds.")]
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
public int Interval {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("The frequency of Elapsed events in milliseconds.")]
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
public: __property int get_Interval();
public: __property void set_Interval(
   int value
);
C++/CLI
[SRDescriptionAttribute("The frequency of Elapsed events in milliseconds.")]
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
public:
property int Interval {
   int get();
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Timer Class
Timer Members


Timer Class Events

[image]
Gizmox.WebGUI.Forms
Timer Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : Timer Class

For a list of all members of this type, see Timer members.

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | Tick | Occurs when the specified timer interval has elapsed and the timer is enabled.
Top

See Also

Reference

Timer Class
Gizmox.WebGUI.Forms Namespace


Tick Event

[image]
Gizmox.WebGUI.Forms
Tick Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Timer Class : Tick Event

Occurs when the specified timer interval has elapsed and the timer is enabled.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Behavior")>
<SRDescriptionAttribute("Occurs whenever the specified interval time elapses.")>
Public Event Tick() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As Timer
Dim handler As EventHandler

AddHandler instance.Tick, handler
C#
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs whenever the specified interval time elapses.")]
public event EventHandler Tick()
Managed Extensions for C++
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs whenever the specified interval time elapses.")]
public: __event EventHandler* Tick
C++/CLI
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs whenever the specified interval time elapses.")]
public:
event EventHandler^ Tick

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Timer Class
Timer Members


ToolBar Class

[image]
Gizmox.WebGUI.Forms
ToolBar Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ToolBar Class

ToolBar control.

Object Model

Syntax

Visual Basic (Declaration)
<SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableToolBar, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")>
<MetadataTagAttribute("T1")>
<ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<ClientControllerAttribute()>
<DesignTimeControllerAttribute()>
<ToolboxBitmapAttribute()>
<ToolboxItemCategoryAttribute("Menus & Toolbars")>
Public Class ToolBar
   Inherits Control
   Implements IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Visual Basic (Usage) Copy Code
Dim instance As ToolBar
C#
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableToolBar, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[MetadataTagAttribute("T1")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ClientControllerAttribute()]
[DesignTimeControllerAttribute()]
[ToolboxBitmapAttribute()]
[ToolboxItemCategoryAttribute("Menus & Toolbars")]
public class ToolBar : Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Managed Extensions for C++
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableToolBar, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[MetadataTagAttribute("T1")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ClientControllerAttribute()]
[DesignTimeControllerAttribute()]
[ToolboxBitmapAttribute()]
[ToolboxItemCategoryAttribute("Menus & Toolbars")]
public __gc class ToolBar : public Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
C++/CLI
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableToolBar, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[MetadataTagAttribute("T1")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ClientControllerAttribute()]
[DesignTimeControllerAttribute()]
[ToolboxBitmapAttribute()]
[ToolboxItemCategoryAttribute("Menus & Toolbars")]
public ref class ToolBar : public Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.ToolBar
Gizmox.WebGUI.Forms.BindingNavigator

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

ToolBar Members
Gizmox.WebGUI.Forms Namespace


ToolBar Class Members

[image]
Gizmox.WebGUI.Forms
ToolBar Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : ToolBar Class

The following tables list the members exposed by ToolBar.

Public Constructors

 | Name | Description
Public Constructor | ToolBar Constructor | Creates a new ToolBar instance.
Top

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | Appearance | Gets or sets the toolbar appearance.
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | Buttons | Gets the toolbar button collecction
Public Property | ButtonSize | Gets or sets the size of the buttons.
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DragHandle | Gets or sets a value indicating whether to display drag handle.
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | DropDownArrows | Gets or sets a value indicating whether to display dropdown arrows.
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | ImageList | Gets or sets the toolbar image list.
Public Property | ImageSize | Gets the size of the images in the image list assigned to the toolbar.
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MenuHandle | Gets or sets a value indicating whether to display menu handle.
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether to invert buttons.
Public Property | ShowToolTips | Gets or sets a value indicating whether to show tooltips.
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Control)
Public Property | TextAlign | Gets or sets the buttons text align.
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Control)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from Control)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnButtonClick | Raises the ButtonClick event.
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | Overridden.
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | Overridden. ToolBar render implementation
Protected Method | RenderAttributes | Renders the controls meta attributes (Inherited from Control)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Overridden.
Protected Method | RenderControls | Overloaded. Overridden. Render buttons
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | Overridden. Do not serialize the size on docked mode
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | Overridden. Do not serialize size on docked mode
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | ButtonClick | Occurs when a user clicks on a button
Public Event | Click | Occurs when a user clicks on a button
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

ToolBar Class
Gizmox.WebGUI.Forms Namespace


ToolBar Constructor

[image]
Gizmox.WebGUI.Forms
ToolBar Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ToolBar Class : ToolBar Constructor

Creates a new ToolBar instance.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ToolBar()
C#
public ToolBar()
Managed Extensions for C++
public: ToolBar();
C++/CLI
public:
ToolBar();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ToolBar Class
ToolBar Members


ToolBar Class Methods

[image]
Gizmox.WebGUI.Forms
ToolBar Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ToolBar Class

For a list of all members of this type, see ToolBar members.

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Control)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from Control)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnButtonClick | Raises the ButtonClick event.
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | Overridden.
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | Overridden. ToolBar render implementation
Protected Method | RenderAttributes | Renders the controls meta attributes (Inherited from Control)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Overridden.
Protected Method | RenderControls | Overloaded. Overridden. Render buttons
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | Overridden. Do not serialize the size on docked mode
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | Overridden. Do not serialize size on docked mode
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

See Also

Reference

ToolBar Class
Gizmox.WebGUI.Forms Namespace


OnButtonClick Method

[image]
Gizmox.WebGUI.Forms
OnButtonClick Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ToolBar Class : OnButtonClick Method

e
A ToolBarButtonClickEventArgs that contains the event data.
Raises the ButtonClick event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnButtonClick( _
   ByVal e As ToolBarButtonClickEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ToolBar
Dim e As ToolBarButtonClickEventArgs

instance.OnButtonClick(e)
C#
protected virtual void OnButtonClick(
   ToolBarButtonClickEventArgs e
)
Managed Extensions for C++
protected: virtual void OnButtonClick(
   ToolBarButtonClickEventArgs* e
)
C++/CLI
protected:
virtual void OnButtonClick(
   ToolBarButtonClickEventArgs^ e
)

Parameters

e
A ToolBarButtonClickEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ToolBar Class
ToolBar Members


OnUnregisterComponents Method

[image]
Gizmox.WebGUI.Forms
OnUnregisterComponents Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ToolBar Class : OnUnregisterComponents Method

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnUnregisterComponents()
Visual Basic (Usage) Copy Code
Dim instance As ToolBar

instance.OnUnregisterComponents()
C#
protected override void OnUnregisterComponents()
Managed Extensions for C++
protected: void OnUnregisterComponents(); override
C++/CLI
protected:
void OnUnregisterComponents(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ToolBar Class
ToolBar Members


Render Method

[image]
Gizmox.WebGUI.Forms
Render Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ToolBar Class : Render Method

objContext
objWriter
lngRequestID
ToolBar render implementation

Syntax

Visual Basic (Declaration)
Protected Overrides Sub Render( _
   ByVal objContext As IContext, _
   ByVal objWriter As IResponseWriter, _
   ByVal lngRequestID As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As ToolBar
Dim objContext As IContext
Dim objWriter As IResponseWriter
Dim lngRequestID As Long

instance.Render(objContext, objWriter, lngRequestID)
C#
protected override void Render(
   IContext objContext,
   IResponseWriter objWriter,
   long lngRequestID
)
Managed Extensions for C++
protected: void Render(
   IContext* objContext,
   IResponseWriter* objWriter,
   long lngRequestID
) override
C++/CLI
protected:
void Render(
   IContext^ objContext,
   IResponseWriter^ objWriter,
   long long lngRequestID
) override

Parameters

objContext
objWriter
lngRequestID

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ToolBar Class
ToolBar Members


RenderControl Method

[image]
Gizmox.WebGUI.Forms
RenderControl Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ToolBar Class : RenderControl Method

objContext
objWriter
lngRequestID

Syntax

Visual Basic (Declaration)
Protected Overrides Sub RenderControl( _
   ByVal objContext As IContext, _
   ByVal objWriter As IResponseWriter, _
   ByVal lngRequestID As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As ToolBar
Dim objContext As IContext
Dim objWriter As IResponseWriter
Dim lngRequestID As Long

instance.RenderControl(objContext, objWriter, lngRequestID)
C#
protected override void RenderControl(
   IContext objContext,
   IResponseWriter objWriter,
   long lngRequestID
)
Managed Extensions for C++
protected: void RenderControl(
   IContext* objContext,
   IResponseWriter* objWriter,
   long lngRequestID
) override
C++/CLI
protected:
void RenderControl(
   IContext^ objContext,
   IResponseWriter^ objWriter,
   long long lngRequestID
) override

Parameters

objContext
objWriter
lngRequestID

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ToolBar Class
ToolBar Members


RenderControls Method

[image]
Gizmox.WebGUI.Forms
RenderControls Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ToolBar Class : RenderControls Method

Render buttons

Overload List

Overload | Description
RenderControls(IContext,IResponseWriter,Int64) | Render buttons
RenderControls(IContext,IResponseWriter,Int64,Boolean) | Renders the controls sub tree (Inherited from Control)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ToolBar Class
ToolBar Members


RenderControls(IContext,IResponseWriter,Int64) Method

[image]
Gizmox.WebGUI.Forms
RenderControls(IContext,IResponseWriter,Int64) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ToolBar Class > RenderControls Method : RenderControls(IContext,IResponseWriter,Int64) Method

objContext
Request context.
objWriter
The response writer object.
lngRequestID
Request ID.
Render buttons

Syntax

Visual Basic (Declaration)
Protected Overloads Overrides Sub RenderControls( _
   ByVal objContext As IContext, _
   ByVal objWriter As IResponseWriter, _
   ByVal lngRequestID As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As ToolBar
Dim objContext As IContext
Dim objWriter As IResponseWriter
Dim lngRequestID As Long

instance.RenderControls(objContext, objWriter, lngRequestID)
C#
protected override void RenderControls(
   IContext objContext,
   IResponseWriter objWriter,
   long lngRequestID
)
Managed Extensions for C++
protected: void RenderControls(
   IContext* objContext,
   IResponseWriter* objWriter,
   long lngRequestID
) override
C++/CLI
protected:
void RenderControls(
   IContext^ objContext,
   IResponseWriter^ objWriter,
   long long lngRequestID
) override

Parameters

objContext
Request context.
objWriter
The response writer object.
lngRequestID
Request ID.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ToolBar Class
ToolBar Members
Overload List


ShouldSerializeClientSize Method

[image]
Gizmox.WebGUI.Forms
ShouldSerializeClientSize Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ToolBar Class : ShouldSerializeClientSize Method

Do not serialize the size on docked mode

Syntax

Visual Basic (Declaration)
Protected Overrides Function ShouldSerializeClientSize() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ToolBar
Dim value As Boolean

value = instance.ShouldSerializeClientSize()
C#
protected override bool ShouldSerializeClientSize()
Managed Extensions for C++
protected: bool ShouldSerializeClientSize(); override
C++/CLI
protected:
bool ShouldSerializeClientSize(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ToolBar Class
ToolBar Members


ShouldSerializeSize Method

[image]
Gizmox.WebGUI.Forms
ShouldSerializeSize Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ToolBar Class : ShouldSerializeSize Method

Do not serialize size on docked mode

Syntax

Visual Basic (Declaration)
Protected Overrides Function ShouldSerializeSize() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ToolBar
Dim value As Boolean

value = instance.ShouldSerializeSize()
C#
protected override bool ShouldSerializeSize()
Managed Extensions for C++
protected: bool ShouldSerializeSize(); override
C++/CLI
protected:
bool ShouldSerializeSize(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ToolBar Class
ToolBar Members


ToolBar Class Properties

[image]
Gizmox.WebGUI.Forms
ToolBar Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ToolBar Class

For a list of all members of this type, see ToolBar members.

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | Appearance | Gets or sets the toolbar appearance.
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | Buttons | Gets the toolbar button collecction
Public Property | ButtonSize | Gets or sets the size of the buttons.
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DragHandle | Gets or sets a value indicating whether to display drag handle.
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | DropDownArrows | Gets or sets a value indicating whether to display dropdown arrows.
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | ImageList | Gets or sets the toolbar image list.
Public Property | ImageSize | Gets the size of the images in the image list assigned to the toolbar.
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MenuHandle | Gets or sets a value indicating whether to display menu handle.
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether to invert buttons.
Public Property | ShowToolTips | Gets or sets a value indicating whether to show tooltips.
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Control)
Public Property | TextAlign | Gets or sets the buttons text align.
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

See Also

Reference

ToolBar Class
Gizmox.WebGUI.Forms Namespace


Appearance Property

[image]
Gizmox.WebGUI.Forms
Appearance Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ToolBar Class : Appearance Property

Gets or sets the toolbar appearance.

Syntax

Visual Basic (Declaration)
Public Property Appearance As ToolBarAppearance
Visual Basic (Usage) Copy Code
Dim instance As ToolBar
Dim value As ToolBarAppearance

instance.Appearance = value

value = instance.Appearance
C#
public ToolBarAppearance Appearance {get; set;}
Managed Extensions for C++
public: __property ToolBarAppearance get_Appearance();
public: __property void set_Appearance(
   ToolBarAppearance value
);
C++/CLI
public:
property ToolBarAppearance Appearance {
   ToolBarAppearance get();
   void set (ToolBarAppearancevalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ToolBar Class
ToolBar Members


Buttons Property

[image]
Gizmox.WebGUI.Forms
Buttons Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ToolBar Class : Buttons Property

Gets the toolbar button collecction

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(True)>
Public ReadOnly Property Buttons As ToolBarItemCollection
Visual Basic (Usage) Copy Code
Dim instance As ToolBar
Dim value As ToolBarItemCollection

value = instance.Buttons
C#
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(true)]
public ToolBarItemCollection Buttons {get;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(true)]
public: __property ToolBarItemCollection* get_Buttons();
C++/CLI
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(true)]
public:
property ToolBarItemCollection^ Buttons {
   ToolBarItemCollection^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ToolBar Class
ToolBar Members


ButtonSize Property

[image]
Gizmox.WebGUI.Forms
ButtonSize Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ToolBar Class : ButtonSize Property

Gets or sets the size of the buttons.

Syntax

Visual Basic (Declaration)
Public Property ButtonSize As Size
Visual Basic (Usage) Copy Code
Dim instance As ToolBar
Dim value As Size

instance.ButtonSize = value

value = instance.ButtonSize
C#
public Size ButtonSize {get; set;}
Managed Extensions for C++
public: __property Size get_ButtonSize();
public: __property void set_ButtonSize(
   Size value
);
C++/CLI
public:
property Size ButtonSize {
   Size get();
   void set (Sizevalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ToolBar Class
ToolBar Members


DragHandle Property

[image]
Gizmox.WebGUI.Forms
DragHandle Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ToolBar Class : DragHandle Property

Gets or sets a value indicating whether to display drag handle.

Syntax

Visual Basic (Declaration)
Public Property DragHandle As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ToolBar
Dim value As Boolean

instance.DragHandle = value

value = instance.DragHandle
C#
public bool DragHandle {get; set;}
Managed Extensions for C++
public: __property bool get_DragHandle();
public: __property void set_DragHandle(
   bool value
);
C++/CLI
public:
property bool DragHandle {
   bool get();
   void set (boolvalue);
}

Return Value

true if to display drag handle; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ToolBar Class
ToolBar Members


DropDownArrows Property

[image]
Gizmox.WebGUI.Forms
DropDownArrows Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ToolBar Class : DropDownArrows Property

Gets or sets a value indicating whether to display dropdown arrows.

Syntax

Visual Basic (Declaration)
Public Property DropDownArrows As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ToolBar
Dim value As Boolean

instance.DropDownArrows = value

value = instance.DropDownArrows
C#
public bool DropDownArrows {get; set;}
Managed Extensions for C++
public: __property bool get_DropDownArrows();
public: __property void set_DropDownArrows(
   bool value
);
C++/CLI
public:
property bool DropDownArrows {
   bool get();
   void set (boolvalue);
}

Return Value

true if to display dropdown arrows; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ToolBar Class
ToolBar Members


ImageList Property

[image]
Gizmox.WebGUI.Forms
ImageList Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ToolBar Class : ImageList Property

Gets or sets the toolbar image list.

Syntax

Visual Basic (Declaration)
Public Property ImageList As ImageList
Visual Basic (Usage) Copy Code
Dim instance As ToolBar
Dim value As ImageList

instance.ImageList = value

value = instance.ImageList
C#
public ImageList ImageList {get; set;}
Managed Extensions for C++
public: __property ImageList* get_ImageList();
public: __property void set_ImageList(
   ImageList* value
);
C++/CLI
public:
property ImageList^ ImageList {
   ImageList^ get();
   void set (ImageList^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ToolBar Class
ToolBar Members


ImageSize Property

[image]
Gizmox.WebGUI.Forms
ImageSize Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ToolBar Class : ImageSize Property

Gets the size of the images in the image list assigned to the toolbar.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("The size of the images within the ToolBar's ImageList.")>
<SRCategoryAttribute("Behavior")>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Property ImageSize As Size
Visual Basic (Usage) Copy Code
Dim instance As ToolBar
Dim value As Size

instance.ImageSize = value

value = instance.ImageSize
C#
[SRDescriptionAttribute("The size of the images within the ToolBar's ImageList.")]
[SRCategoryAttribute("Behavior")]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public Size ImageSize {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("The size of the images within the ToolBar's ImageList.")]
[SRCategoryAttribute("Behavior")]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: __property Size get_ImageSize();
public: __property void set_ImageSize(
   Size value
);
C++/CLI
[SRDescriptionAttribute("The size of the images within the ToolBar's ImageList.")]
[SRCategoryAttribute("Behavior")]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
property Size ImageSize {
   Size get();
   void set (Sizevalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ToolBar Class
ToolBar Members


MenuHandle Property

[image]
Gizmox.WebGUI.Forms
MenuHandle Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ToolBar Class : MenuHandle Property

Gets or sets a value indicating whether to display menu handle.

Syntax

Visual Basic (Declaration)
Public Property MenuHandle As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ToolBar
Dim value As Boolean

instance.MenuHandle = value

value = instance.MenuHandle
C#
public bool MenuHandle {get; set;}
Managed Extensions for C++
public: __property bool get_MenuHandle();
public: __property void set_MenuHandle(
   bool value
);
C++/CLI
public:
property bool MenuHandle {
   bool get();
   void set (boolvalue);
}

Return Value

true if to display menu handle; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ToolBar Class
ToolBar Members


RightToLeft Property

[image]
Gizmox.WebGUI.Forms
RightToLeft Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ToolBar Class : RightToLeft Property

Gets or sets a value indicating whether to invert buttons.

Syntax

Visual Basic (Declaration)
Public Property RightToLeft As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ToolBar
Dim value As Boolean

instance.RightToLeft = value

value = instance.RightToLeft
C#
public bool RightToLeft {get; set;}
Managed Extensions for C++
public: __property bool get_RightToLeft();
public: __property void set_RightToLeft(
   bool value
);
C++/CLI
public:
property bool RightToLeft {
   bool get();
   void set (boolvalue);
}

Return Value

true if to invert buttons; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ToolBar Class
ToolBar Members


ShowToolTips Property

[image]
Gizmox.WebGUI.Forms
ShowToolTips Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ToolBar Class : ShowToolTips Property

Gets or sets a value indicating whether to show tooltips.

Syntax

Visual Basic (Declaration)
Public Property ShowToolTips As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ToolBar
Dim value As Boolean

instance.ShowToolTips = value

value = instance.ShowToolTips
C#
public bool ShowToolTips {get; set;}
Managed Extensions for C++
public: __property bool get_ShowToolTips();
public: __property void set_ShowToolTips(
   bool value
);
C++/CLI
public:
property bool ShowToolTips {
   bool get();
   void set (boolvalue);
}

Return Value

true if to show tooltips; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ToolBar Class
ToolBar Members


TextAlign Property

[image]
Gizmox.WebGUI.Forms
TextAlign Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ToolBar Class : TextAlign Property

Gets or sets the buttons text align.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property TextAlign As ToolBarTextAlign
Visual Basic (Usage) Copy Code
Dim instance As ToolBar
Dim value As ToolBarTextAlign

instance.TextAlign = value

value = instance.TextAlign
C#
[DefaultValueAttribute()]
public ToolBarTextAlign TextAlign {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property ToolBarTextAlign get_TextAlign();
public: __property void set_TextAlign(
   ToolBarTextAlign value
);
C++/CLI
[DefaultValueAttribute()]
public:
property ToolBarTextAlign TextAlign {
   ToolBarTextAlign get();
   void set (ToolBarTextAlignvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ToolBar Class
ToolBar Members


ToolBar Class Events

[image]
Gizmox.WebGUI.Forms
ToolBar Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ToolBar Class

For a list of all members of this type, see ToolBar members.

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | ButtonClick | Occurs when a user clicks on a button
Public Event | Click | Occurs when a user clicks on a button
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

ToolBar Class
Gizmox.WebGUI.Forms Namespace


ButtonClick Event

[image]
Gizmox.WebGUI.Forms
ButtonClick Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ToolBar Class : ButtonClick Event

Occurs when a user clicks on a button

Syntax

Visual Basic (Declaration)
Public Event ButtonClick() As ToolBarButtonClickEventHandler
Visual Basic (Usage) Copy Code
Dim instance As ToolBar
Dim handler As ToolBarButtonClickEventHandler

AddHandler instance.ButtonClick, handler
C#
public event ToolBarButtonClickEventHandler ButtonClick()
Managed Extensions for C++
public: __event ToolBarButtonClickEventHandler* ButtonClick
C++/CLI
public:
event ToolBarButtonClickEventHandler^ ButtonClick

Event Data

The event handler receives an argument of type ToolBarButtonClickEventArgs containing data related to this event. The following ToolBarButtonClickEventArgs properties provide information specific to this event.

Property | Description
Button |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ToolBar Class
ToolBar Members


Click Event

[image]
Gizmox.WebGUI.Forms
Click Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ToolBar Class : Click Event

Occurs when a user clicks on a button

Syntax

Visual Basic (Declaration)
Public Event Click() As ToolBarItemHandler
Visual Basic (Usage) Copy Code
Dim instance As ToolBar
Dim handler As ToolBarItemHandler

AddHandler instance.Click, handler
C#
public event ToolBarItemHandler Click()
Managed Extensions for C++
public: __event ToolBarItemHandler* Click
C++/CLI
public:
event ToolBarItemHandler^ Click

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ToolBar Class
ToolBar Members


ToolBarButton Class

[image]
Gizmox.WebGUI.Forms
ToolBarButton Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ToolBarButton Class

Summary description for ToolBarButton.

Object Model

Syntax

Visual Basic (Declaration)
<ClientControllerAttribute()>
<DesignTimeControllerAttribute()>
<DesignTimeVisibleAttribute()>
Public Class ToolBarButton
   Inherits Component
   Implements IAttributeExtender, IEventHandler, IGatewayComponent, IObservableItem, IRegisteredComponent
Visual Basic (Usage) Copy Code
Dim instance As ToolBarButton
C#
[ClientControllerAttribute()]
[DesignTimeControllerAttribute()]
[DesignTimeVisibleAttribute()]
public class ToolBarButton : Component, IAttributeExtender, IEventHandler, IGatewayComponent, IObservableItem, IRegisteredComponent
Managed Extensions for C++
[ClientControllerAttribute()]
[DesignTimeControllerAttribute()]
[DesignTimeVisibleAttribute()]
public __gc class ToolBarButton : public Component, IAttributeExtender, IEventHandler, IGatewayComponent, IObservableItem, IRegisteredComponent
C++/CLI
[ClientControllerAttribute()]
[DesignTimeControllerAttribute()]
[DesignTimeVisibleAttribute()]
public ref class ToolBarButton : public Component, IAttributeExtender, IEventHandler, IGatewayComponent, IObservableItem, IRegisteredComponent

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.ToolBarButton

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

ToolBarButton Members
Gizmox.WebGUI.Forms Namespace


ToolBarButton Class Members

[image]
Gizmox.WebGUI.Forms
ToolBarButton Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : ToolBarButton Class

The following tables list the members exposed by ToolBarButton.

Public Constructors

 | Name | Description
Public Constructor | ToolBarButton Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContextMenu | Gets or sets the context menu code. (Inherited from Component)
Public Property | CustomStyle |
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | DropDownMenu |
Public Property | Enabled | Gets or sets a value indicating whether this MenuItem is enabled.
Public Property | Font | Sets the current toolbar button font
Public Property | ForeColor | Sets the current button fore color
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Image | Gets or sets the small image that is displayed for the item.
Public Property | ImageIndex | Gets or sets the index of the image that is displayed for the item.
Public Property | ImageKey | Gets or sets the key for the image that is displayed for the item.
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | Name |
Public Property | Pushed |
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size |
Public Property | Style | Gets or sets the button style.
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text |
Public Property | ToolBar | Gets or sets the toolbar.
Public Property | ToolTipText |
Public Property | Visible |
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded. Disposes the specified component. (Inherited from Component)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Overridden. Fires an event.
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetButtonDocking | Gets the button docking.
Protected Method | GetCriticalEvents | Overridden.
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnUnregisterComponents | Overridden.
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor |
Protected Method | ShouldSerializeImage | Shoulds the image.attribute be serialized
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

Public Events

 | Name | Description
Public Event | Click |
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Top

See Also

Reference

ToolBarButton Class
Gizmox.WebGUI.Forms Namespace


ToolBarButton Constructor

[image]
Gizmox.WebGUI.Forms
ToolBarButton Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ToolBarButton Class : ToolBarButton Constructor

Overload List

Overload | Description
ToolBarButton Constructor() |
ToolBarButton Constructor(String,String) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ToolBarButton Class
ToolBarButton Members


ToolBarButton Constructor()

[image]
Gizmox.WebGUI.Forms
ToolBarButton Constructor()
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ToolBarButton Class > ToolBarButton Constructor : ToolBarButton Constructor()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ToolBarButton()
C#
public ToolBarButton()
Managed Extensions for C++
public: ToolBarButton();
C++/CLI
public:
ToolBarButton();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ToolBarButton Class
ToolBarButton Members
Overload List


ToolBarButton Constructor(String,String)

[image]
Gizmox.WebGUI.Forms
ToolBarButton Constructor(String,String)
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ToolBarButton Class > ToolBarButton Constructor : ToolBarButton Constructor(String,String)

strName
strLabel

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal strName As String, _
   ByVal strLabel As String _
)
Visual Basic (Usage) Copy Code
Dim strName As String
Dim strLabel As String

Dim instance As ToolBarButton(strName, strLabel)
C#
public ToolBarButton(
   string strName,
   string strLabel
)
Managed Extensions for C++
public: ToolBarButton(
   string* strName,
   string* strLabel
)
C++/CLI
public:
ToolBarButton(
   String^ strName,
   String^ strLabel
)

Parameters

strName
strLabel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ToolBarButton Class
ToolBarButton Members
Overload List


ToolBarButton Class Methods

[image]
Gizmox.WebGUI.Forms
ToolBarButton Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ToolBarButton Class

For a list of all members of this type, see ToolBarButton members.

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded. Disposes the specified component. (Inherited from Component)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Overridden. Fires an event.
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetButtonDocking | Gets the button docking.
Protected Method | GetCriticalEvents | Overridden.
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnUnregisterComponents | Overridden.
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor |
Protected Method | ShouldSerializeImage | Shoulds the image.attribute be serialized
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

See Also

Reference

ToolBarButton Class
Gizmox.WebGUI.Forms Namespace


FireEvent Method

[image]
Gizmox.WebGUI.Forms
FireEvent Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ToolBarButton Class : FireEvent Method

objEvent
event.
Fires an event.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub FireEvent( _
   ByVal objEvent As IEvent _
)
Visual Basic (Usage) Copy Code
Dim instance As ToolBarButton
Dim objEvent As IEvent

instance.FireEvent(objEvent)
C#
protected override void FireEvent(
   IEvent objEvent
)
Managed Extensions for C++
protected: void FireEvent(
   IEvent* objEvent
) override
C++/CLI
protected:
void FireEvent(
   IEvent^ objEvent
) override

Parameters

objEvent
event.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ToolBarButton Class
ToolBarButton Members


GetButtonDocking Method

[image]
Gizmox.WebGUI.Forms
GetButtonDocking Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ToolBarButton Class : GetButtonDocking Method

strDocking
The STR docking.
Gets the button docking.

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetButtonDocking( _
   ByVal strDocking As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As ToolBarButton
Dim strDocking As String
Dim value As String

value = instance.GetButtonDocking(strDocking)
C#
protected virtual string GetButtonDocking(
   string strDocking
)
Managed Extensions for C++
protected: virtual string* GetButtonDocking(
   string* strDocking
)
C++/CLI
protected:
virtual String^ GetButtonDocking(
   String^ strDocking
)

Parameters

strDocking
The STR docking.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ToolBarButton Class
ToolBarButton Members


GetCriticalEvents Method

[image]
Gizmox.WebGUI.Forms
GetCriticalEvents Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ToolBarButton Class : GetCriticalEvents Method

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetCriticalEvents() As EventTypes
Visual Basic (Usage) Copy Code
Dim instance As ToolBarButton
Dim value As EventTypes

value = instance.GetCriticalEvents()
C#
protected override EventTypes GetCriticalEvents()
Managed Extensions for C++
protected: EventTypes GetCriticalEvents(); override
C++/CLI
protected:
EventTypes GetCriticalEvents(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ToolBarButton Class
ToolBarButton Members


OnUnregisterComponents Method

[image]
Gizmox.WebGUI.Forms
OnUnregisterComponents Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ToolBarButton Class : OnUnregisterComponents Method

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnUnregisterComponents()
Visual Basic (Usage) Copy Code
Dim instance As ToolBarButton

instance.OnUnregisterComponents()
C#
protected override void OnUnregisterComponents()
Managed Extensions for C++
protected: void OnUnregisterComponents(); override
C++/CLI
protected:
void OnUnregisterComponents(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ToolBarButton Class
ToolBarButton Members


ShouldSerializeForeColor Method

[image]
Gizmox.WebGUI.Forms
ShouldSerializeForeColor Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ToolBarButton Class : ShouldSerializeForeColor Method

Syntax

Visual Basic (Declaration)
Protected Overridable Function ShouldSerializeForeColor() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ToolBarButton
Dim value As Boolean

value = instance.ShouldSerializeForeColor()
C#
protected virtual bool ShouldSerializeForeColor()
Managed Extensions for C++
protected: virtual bool ShouldSerializeForeColor();
C++/CLI
protected:
virtual bool ShouldSerializeForeColor();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ToolBarButton Class
ToolBarButton Members


ShouldSerializeImage Method

[image]
Gizmox.WebGUI.Forms
ShouldSerializeImage Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ToolBarButton Class : ShouldSerializeImage Method

Shoulds the image.attribute be serialized

Syntax

Visual Basic (Declaration)
Protected Function ShouldSerializeImage() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ToolBarButton
Dim value As Boolean

value = instance.ShouldSerializeImage()
C#
protected bool ShouldSerializeImage()
Managed Extensions for C++
protected: bool ShouldSerializeImage();
C++/CLI
protected:
bool ShouldSerializeImage();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ToolBarButton Class
ToolBarButton Members


ToolBarButton Class Properties

[image]
Gizmox.WebGUI.Forms
ToolBarButton Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ToolBarButton Class

For a list of all members of this type, see ToolBarButton members.

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContextMenu | Gets or sets the context menu code. (Inherited from Component)
Public Property | CustomStyle |
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | DropDownMenu |
Public Property | Enabled | Gets or sets a value indicating whether this MenuItem is enabled.
Public Property | Font | Sets the current toolbar button font
Public Property | ForeColor | Sets the current button fore color
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Image | Gets or sets the small image that is displayed for the item.
Public Property | ImageIndex | Gets or sets the index of the image that is displayed for the item.
Public Property | ImageKey | Gets or sets the key for the image that is displayed for the item.
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | Name |
Public Property | Pushed |
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size |
Public Property | Style | Gets or sets the button style.
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text |
Public Property | ToolBar | Gets or sets the toolbar.
Public Property | ToolTipText |
Public Property | Visible |
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

See Also

Reference

ToolBarButton Class
Gizmox.WebGUI.Forms Namespace


CustomStyle Property

[image]
Gizmox.WebGUI.Forms
CustomStyle Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ToolBarButton Class : CustomStyle Property

Syntax

Visual Basic (Declaration)
Public Property CustomStyle As String
Visual Basic (Usage) Copy Code
Dim instance As ToolBarButton
Dim value As String

instance.CustomStyle = value

value = instance.CustomStyle
C#
public string CustomStyle {get; set;}
Managed Extensions for C++
public: __property string* get_CustomStyle();
public: __property void set_CustomStyle(
   string* value
);
C++/CLI
public:
property String^ CustomStyle {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ToolBarButton Class
ToolBarButton Members


DropDownMenu Property

[image]
Gizmox.WebGUI.Forms
DropDownMenu Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ToolBarButton Class : DropDownMenu Property

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property DropDownMenu As ContextMenu
Visual Basic (Usage) Copy Code
Dim instance As ToolBarButton
Dim value As ContextMenu

instance.DropDownMenu = value

value = instance.DropDownMenu
C#
[DefaultValueAttribute()]
public ContextMenu DropDownMenu {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property ContextMenu* get_DropDownMenu();
public: __property void set_DropDownMenu(
   ContextMenu* value
);
C++/CLI
[DefaultValueAttribute()]
public:
property ContextMenu^ DropDownMenu {
   ContextMenu^ get();
   void set (ContextMenu^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ToolBarButton Class
ToolBarButton Members


Enabled Property

[image]
Gizmox.WebGUI.Forms
Enabled Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ToolBarButton Class : Enabled Property

Gets or sets a value indicating whether this MenuItem is enabled.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property Enabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ToolBarButton
Dim value As Boolean

instance.Enabled = value

value = instance.Enabled
C#
[DefaultValueAttribute()]
public bool Enabled {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property bool get_Enabled();
public: __property void set_Enabled(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
public:
property bool Enabled {
   bool get();
   void set (boolvalue);
}

Return Value

true if enabled; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ToolBarButton Class
ToolBarButton Members


Font Property

[image]
Gizmox.WebGUI.Forms
Font Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ToolBarButton Class : Font Property

Sets the current toolbar button font

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property Font As Font
Visual Basic (Usage) Copy Code
Dim instance As ToolBarButton
Dim value As Font

instance.Font = value

value = instance.Font
C#
[DefaultValueAttribute()]
public Font Font {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property Font* get_Font();
public: __property void set_Font(
   Font* value
);
C++/CLI
[DefaultValueAttribute()]
public:
property Font^ Font {
   Font^ get();
   void set (Font^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ToolBarButton Class
ToolBarButton Members


ForeColor Property

[image]
Gizmox.WebGUI.Forms
ForeColor Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ToolBarButton Class : ForeColor Property

Sets the current button fore color

Syntax

Visual Basic (Declaration)
Public Property ForeColor As Color
Visual Basic (Usage) Copy Code
Dim instance As ToolBarButton
Dim value As Color

instance.ForeColor = value

value = instance.ForeColor
C#
public Color ForeColor {get; set;}
Managed Extensions for C++
public: __property Color get_ForeColor();
public: __property void set_ForeColor(
   Color value
);
C++/CLI
public:
property Color ForeColor {
   Color get();
   void set (Colorvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ToolBarButton Class
ToolBarButton Members


Image Property

[image]
Gizmox.WebGUI.Forms
Image Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ToolBarButton Class : Image Property

Gets or sets the small image that is displayed for the item.

Syntax

Visual Basic (Declaration)
Public Property Image As ResourceHandle
Visual Basic (Usage) Copy Code
Dim instance As ToolBarButton
Dim value As ResourceHandle

instance.Image = value

value = instance.Image
C#
public ResourceHandle Image {get; set;}
Managed Extensions for C++
public: __property ResourceHandle* get_Image();
public: __property void set_Image(
   ResourceHandle* value
);
C++/CLI
public:
property ResourceHandle^ Image {
   ResourceHandle^ get();
   void set (ResourceHandle^value);
}

Remarks

This property does not work and throws an exception if the owning listview has a ImageList set.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ToolBarButton Class
ToolBarButton Members


ImageIndex Property

[image]
Gizmox.WebGUI.Forms
ImageIndex Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ToolBarButton Class : ImageIndex Property

Gets or sets the index of the image that is displayed for the item.

Syntax

Visual Basic (Declaration)
<TypeConverterAttribute("Gizmox.WebGUI.Forms.Design.ImageIndexConverter, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")>
<RelatedImageListAttribute("ToolBar.ImageList")>
<RefreshPropertiesAttribute()>
<SRDescriptionAttribute("Identifies the image displayed on the button.")>
<SRCategoryAttribute("Behavior")>
<DefaultValueAttribute()>
<EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.ImageIndexEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")>
<LocalizableAttribute(True)>
Public Property ImageIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As ToolBarButton
Dim value As Integer

instance.ImageIndex = value

value = instance.ImageIndex
C#
[TypeConverterAttribute("Gizmox.WebGUI.Forms.Design.ImageIndexConverter, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[RelatedImageListAttribute("ToolBar.ImageList")]
[RefreshPropertiesAttribute()]
[SRDescriptionAttribute("Identifies the image displayed on the button.")]
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.ImageIndexEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[LocalizableAttribute(true)]
public int ImageIndex {get; set;}
Managed Extensions for C++
[TypeConverterAttribute("Gizmox.WebGUI.Forms.Design.ImageIndexConverter, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[RelatedImageListAttribute("ToolBar.ImageList")]
[RefreshPropertiesAttribute()]
[SRDescriptionAttribute("Identifies the image displayed on the button.")]
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.ImageIndexEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[LocalizableAttribute(true)]
public: __property int get_ImageIndex();
public: __property void set_ImageIndex(
   int value
);
C++/CLI
[TypeConverterAttribute("Gizmox.WebGUI.Forms.Design.ImageIndexConverter, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[RelatedImageListAttribute("ToolBar.ImageList")]
[RefreshPropertiesAttribute()]
[SRDescriptionAttribute("Identifies the image displayed on the button.")]
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.ImageIndexEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[LocalizableAttribute(true)]
public:
property int ImageIndex {
   int get();
   void set (intvalue);
}

Exceptions

Exception | Description
ArgumentException | The value specified is less than -1.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ToolBarButton Class
ToolBarButton Members


ImageKey Property

[image]
Gizmox.WebGUI.Forms
ImageKey Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ToolBarButton Class : ImageKey Property

Gets or sets the key for the image that is displayed for the item.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<SRDescriptionAttribute("Identifies the image displayed on the button.")>
<RelatedImageListAttribute("ToolBar.ImageList")>
<RefreshPropertiesAttribute()>
<EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.ImageIndexEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")>
<LocalizableAttribute(True)>
<SRCategoryAttribute("Behavior")>
<TypeConverterAttribute("Gizmox.WebGUI.Forms.Design.ImageKeyConverter, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")>
Public Property ImageKey As String
Visual Basic (Usage) Copy Code
Dim instance As ToolBarButton
Dim value As String

instance.ImageKey = value

value = instance.ImageKey
C#
[DefaultValueAttribute()]
[SRDescriptionAttribute("Identifies the image displayed on the button.")]
[RelatedImageListAttribute("ToolBar.ImageList")]
[RefreshPropertiesAttribute()]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.ImageIndexEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[LocalizableAttribute(true)]
[SRCategoryAttribute("Behavior")]
[TypeConverterAttribute("Gizmox.WebGUI.Forms.Design.ImageKeyConverter, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
public string ImageKey {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[SRDescriptionAttribute("Identifies the image displayed on the button.")]
[RelatedImageListAttribute("ToolBar.ImageList")]
[RefreshPropertiesAttribute()]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.ImageIndexEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[LocalizableAttribute(true)]
[SRCategoryAttribute("Behavior")]
[TypeConverterAttribute("Gizmox.WebGUI.Forms.Design.ImageKeyConverter, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
public: __property string* get_ImageKey();
public: __property void set_ImageKey(
   string* value
);
C++/CLI
[DefaultValueAttribute()]
[SRDescriptionAttribute("Identifies the image displayed on the button.")]
[RelatedImageListAttribute("ToolBar.ImageList")]
[RefreshPropertiesAttribute()]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.ImageIndexEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[LocalizableAttribute(true)]
[SRCategoryAttribute("Behavior")]
[TypeConverterAttribute("Gizmox.WebGUI.Forms.Design.ImageKeyConverter, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
public:
property String^ ImageKey {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ToolBarButton Class
ToolBarButton Members


Name Property

[image]
Gizmox.WebGUI.Forms
Name Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ToolBarButton Class : Name Property

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<BrowsableAttribute(False)>
Public Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As ToolBarButton
Dim value As String

instance.Name = value

value = instance.Name
C#
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
public string Name {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
public: __property string* get_Name();
public: __property void set_Name(
   string* value
);
C++/CLI
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
public:
property String^ Name {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ToolBarButton Class
ToolBarButton Members


Pushed Property

[image]
Gizmox.WebGUI.Forms
Pushed Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ToolBarButton Class : Pushed Property

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property Pushed As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ToolBarButton
Dim value As Boolean

instance.Pushed = value

value = instance.Pushed
C#
[DefaultValueAttribute()]
public bool Pushed {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property bool get_Pushed();
public: __property void set_Pushed(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
public:
property bool Pushed {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ToolBarButton Class
ToolBarButton Members


Size Property

[image]
Gizmox.WebGUI.Forms
Size Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ToolBarButton Class : Size Property

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property Size As Integer
Visual Basic (Usage) Copy Code
Dim instance As ToolBarButton
Dim value As Integer

instance.Size = value

value = instance.Size
C#
[DefaultValueAttribute()]
public int Size {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property int get_Size();
public: __property void set_Size(
   int value
);
C++/CLI
[DefaultValueAttribute()]
public:
property int Size {
   int get();
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ToolBarButton Class
ToolBarButton Members


Style Property

[image]
Gizmox.WebGUI.Forms
Style Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ToolBarButton Class : Style Property

Gets or sets the button style.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property Style As ToolBarButtonStyle
Visual Basic (Usage) Copy Code
Dim instance As ToolBarButton
Dim value As ToolBarButtonStyle

instance.Style = value

value = instance.Style
C#
[DefaultValueAttribute()]
public ToolBarButtonStyle Style {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property ToolBarButtonStyle get_Style();
public: __property void set_Style(
   ToolBarButtonStyle value
);
C++/CLI
[DefaultValueAttribute()]
public:
property ToolBarButtonStyle Style {
   ToolBarButtonStyle get();
   void set (ToolBarButtonStylevalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ToolBarButton Class
ToolBarButton Members


Text Property

[image]
Gizmox.WebGUI.Forms
Text Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ToolBarButton Class : Text Property

Syntax

Visual Basic (Declaration)
<LocalizableAttribute(True)>
<DefaultValueAttribute()>
<SRDescriptionAttribute("The caption to be displayed for this button.")>
Public Property Text As String
Visual Basic (Usage) Copy Code
Dim instance As ToolBarButton
Dim value As String

instance.Text = value

value = instance.Text
C#
[LocalizableAttribute(true)]
[DefaultValueAttribute()]
[SRDescriptionAttribute("The caption to be displayed for this button.")]
public string Text {get; set;}
Managed Extensions for C++
[LocalizableAttribute(true)]
[DefaultValueAttribute()]
[SRDescriptionAttribute("The caption to be displayed for this button.")]
public: __property string* get_Text();
public: __property void set_Text(
   string* value
);
C++/CLI
[LocalizableAttribute(true)]
[DefaultValueAttribute()]
[SRDescriptionAttribute("The caption to be displayed for this button.")]
public:
property String^ Text {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ToolBarButton Class
ToolBarButton Members


ToolBar Property

[image]
Gizmox.WebGUI.Forms
ToolBar Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ToolBarButton Class : ToolBar Property

Gets or sets the toolbar.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public Property ToolBar As ToolBar
Visual Basic (Usage) Copy Code
Dim instance As ToolBarButton
Dim value As ToolBar

instance.ToolBar = value

value = instance.ToolBar
C#
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public ToolBar ToolBar {get; set;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property ToolBar* get_ToolBar();
public: __property void set_ToolBar(
   ToolBar* value
);
C++/CLI
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
property ToolBar^ ToolBar {
   ToolBar^ get();
   void set (ToolBar^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ToolBarButton Class
ToolBarButton Members


ToolTipText Property

[image]
Gizmox.WebGUI.Forms
ToolTipText Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ToolBarButton Class : ToolTipText Property

Syntax

Visual Basic (Declaration)
Public Property ToolTipText As String
Visual Basic (Usage) Copy Code
Dim instance As ToolBarButton
Dim value As String

instance.ToolTipText = value

value = instance.ToolTipText
C#
public string ToolTipText {get; set;}
Managed Extensions for C++
public: __property string* get_ToolTipText();
public: __property void set_ToolTipText(
   string* value
);
C++/CLI
public:
property String^ ToolTipText {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ToolBarButton Class
ToolBarButton Members


Visible Property

[image]
Gizmox.WebGUI.Forms
Visible Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ToolBarButton Class : Visible Property

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ToolBarButton
Dim value As Boolean

instance.Visible = value

value = instance.Visible
C#
[DefaultValueAttribute()]
public bool Visible {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property bool get_Visible();
public: __property void set_Visible(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
public:
property bool Visible {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ToolBarButton Class
ToolBarButton Members


ToolBarButton Class Events

[image]
Gizmox.WebGUI.Forms
ToolBarButton Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ToolBarButton Class

For a list of all members of this type, see ToolBarButton members.

Public Events

 | Name | Description
Public Event | Click |
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Top

See Also

Reference

ToolBarButton Class
Gizmox.WebGUI.Forms Namespace


Click Event

[image]
Gizmox.WebGUI.Forms
Click Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ToolBarButton Class : Click Event

Syntax

Visual Basic (Declaration)
Public Event Click() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As ToolBarButton
Dim handler As EventHandler

AddHandler instance.Click, handler
C#
public event EventHandler Click()
Managed Extensions for C++
public: __event EventHandler* Click
C++/CLI
public:
event EventHandler^ Click

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ToolBarButton Class
ToolBarButton Members


ToolBarButtonClickEventArgs Class

[image]
Gizmox.WebGUI.Forms
ToolBarButtonClickEventArgs Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ToolBarButtonClickEventArgs Class

Object Model

Syntax

Visual Basic (Declaration)
Public Class ToolBarButtonClickEventArgs
   Inherits EventArgs
Visual Basic (Usage) Copy Code
Dim instance As ToolBarButtonClickEventArgs
C#
public class ToolBarButtonClickEventArgs : EventArgs
Managed Extensions for C++
public __gc class ToolBarButtonClickEventArgs : public EventArgs
C++/CLI
public ref class ToolBarButtonClickEventArgs : public EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gizmox.WebGUI.Forms.ToolBarButtonClickEventArgs

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

ToolBarButtonClickEventArgs Members
Gizmox.WebGUI.Forms Namespace


ToolBarButtonClickEventArgs Class Members

[image]
Gizmox.WebGUI.Forms
ToolBarButtonClickEventArgs Class Members
See Also Properties Send Feedback
Gizmox.WebGUI.Forms Namespace : ToolBarButtonClickEventArgs Class

The following tables list the members exposed by ToolBarButtonClickEventArgs.

Public Constructors

 | Name | Description
Public Constructor | ToolBarButtonClickEventArgs Constructor |
Top

Public Properties

 | Name | Description
Public Property | Button |
Top

See Also

Reference

ToolBarButtonClickEventArgs Class
Gizmox.WebGUI.Forms Namespace


ToolBarButtonClickEventArgs Constructor

[image]
Gizmox.WebGUI.Forms
ToolBarButtonClickEventArgs Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ToolBarButtonClickEventArgs Class : ToolBarButtonClickEventArgs Constructor

button

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal button As ToolBarButton _
)
Visual Basic (Usage) Copy Code
Dim button As ToolBarButton

Dim instance As ToolBarButtonClickEventArgs(button)
C#
public ToolBarButtonClickEventArgs(
   ToolBarButton button
)
Managed Extensions for C++
public: ToolBarButtonClickEventArgs(
   ToolBarButton* button
)
C++/CLI
public:
ToolBarButtonClickEventArgs(
   ToolBarButton^ button
)

Parameters

button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ToolBarButtonClickEventArgs Class
ToolBarButtonClickEventArgs Members


ToolBarButtonClickEventArgs Class Properties

[image]
Gizmox.WebGUI.Forms
ToolBarButtonClickEventArgs Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ToolBarButtonClickEventArgs Class

For a list of all members of this type, see ToolBarButtonClickEventArgs members.

Public Properties

 | Name | Description
Public Property | Button |
Top

See Also

Reference

ToolBarButtonClickEventArgs Class
Gizmox.WebGUI.Forms Namespace


Button Property

[image]
Gizmox.WebGUI.Forms
Button Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ToolBarButtonClickEventArgs Class : Button Property

Syntax

Visual Basic (Declaration)
Public Property Button As ToolBarButton
Visual Basic (Usage) Copy Code
Dim instance As ToolBarButtonClickEventArgs
Dim value As ToolBarButton

instance.Button = value

value = instance.Button
C#
public ToolBarButton Button {get; set;}
Managed Extensions for C++
public: __property ToolBarButton* get_Button();
public: __property void set_Button(
   ToolBarButton* value
);
C++/CLI
public:
property ToolBarButton^ Button {
   ToolBarButton^ get();
   void set (ToolBarButton^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ToolBarButtonClickEventArgs Class
ToolBarButtonClickEventArgs Members


ToolBarCollection Class

[image]
Gizmox.WebGUI.Forms
ToolBarCollection Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ToolBarCollection Class

ToolBar collection.

Object Model

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class ToolBarCollection
   Inherits CollectionBase
Visual Basic (Usage) Copy Code
Dim instance As ToolBarCollection
C#
[DefaultMemberAttribute("Item")]
public class ToolBarCollection : CollectionBase
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
public __gc class ToolBarCollection : public CollectionBase
C++/CLI
[DefaultMemberAttribute("Item")]
public ref class ToolBarCollection : public CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
Gizmox.WebGUI.Forms.ToolBarCollection

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

ToolBarCollection Members
Gizmox.WebGUI.Forms Namespace


ToolBarCollection Class Members

[image]
Gizmox.WebGUI.Forms
ToolBarCollection Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : ToolBarCollection Class

The following tables list the members exposed by ToolBarCollection.

Public Constructors

 | Name | Description
Public Constructor | ToolBarCollection Constructor |
Top

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets the ToolBar with the specified int index.
Top

Protected Properties

 | Name | Description
Protected Property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Protected Property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Top

Public Methods

 | Name | Description
Public Method | Add |
Public Method | Clear | Removes all objects from the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | Remove |
Public Method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Top

Protected Methods

 | Name | Description
Protected Method | OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Protected Method | OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Protected Method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Protected Method | OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Protected Method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Protected Method | OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Protected Method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Protected Method | OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Protected Method | OnValidate | Performs additional custom processes when validating a value. (Inherited from System.Collections.CollectionBase)
Top

See Also

Reference

ToolBarCollection Class
Gizmox.WebGUI.Forms Namespace


ToolBarCollection Constructor

[image]
Gizmox.WebGUI.Forms
ToolBarCollection Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ToolBarCollection Class : ToolBarCollection Constructor

objParent

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal objParent As Control _
)
Visual Basic (Usage) Copy Code
Dim objParent As Control

Dim instance As ToolBarCollection(objParent)
C#
public ToolBarCollection(
   Control objParent
)
Managed Extensions for C++
public: ToolBarCollection(
   Control* objParent
)
C++/CLI
public:
ToolBarCollection(
   Control^ objParent
)

Parameters

objParent

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ToolBarCollection Class
ToolBarCollection Members


ToolBarCollection Class Methods

[image]
Gizmox.WebGUI.Forms
ToolBarCollection Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ToolBarCollection Class

For a list of all members of this type, see ToolBarCollection members.

Public Methods

 | Name | Description
Public Method | Add |
Public Method | Clear | Removes all objects from the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | Remove |
Public Method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Top

Protected Methods

 | Name | Description
Protected Method | OnClear | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Protected Method | OnClearComplete | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Protected Method | OnInsert | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Protected Method | OnInsertComplete | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Protected Method | OnRemove | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Protected Method | OnRemoveComplete | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Protected Method | OnSet | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Protected Method | OnSetComplete | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Protected Method | OnValidate | Performs additional custom processes when validating a value. (Inherited from System.Collections.CollectionBase)
Top

See Also

Reference

ToolBarCollection Class
Gizmox.WebGUI.Forms Namespace


Add Method

[image]
Gizmox.WebGUI.Forms
Add Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ToolBarCollection Class : Add Method

objToolBar

Syntax

Visual Basic (Declaration)
Public Function Add( _
   ByVal objToolBar As ToolBar _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As ToolBarCollection
Dim objToolBar As ToolBar
Dim value As Integer

value = instance.Add(objToolBar)
C#
public int Add(
   ToolBar objToolBar
)
Managed Extensions for C++
public: int Add(
   ToolBar* objToolBar
)
C++/CLI
public:
int Add(
   ToolBar^ objToolBar
)

Parameters

objToolBar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ToolBarCollection Class
ToolBarCollection Members


Remove Method

[image]
Gizmox.WebGUI.Forms
Remove Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ToolBarCollection Class : Remove Method

objToolBar

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal objToolBar As ToolBar _
)
Visual Basic (Usage) Copy Code
Dim instance As ToolBarCollection
Dim objToolBar As ToolBar

instance.Remove(objToolBar)
C#
public void Remove(
   ToolBar objToolBar
)
Managed Extensions for C++
public: void Remove(
   ToolBar* objToolBar
)
C++/CLI
public:
void Remove(
   ToolBar^ objToolBar
)

Parameters

objToolBar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ToolBarCollection Class
ToolBarCollection Members


ToolBarCollection Class Properties

[image]
Gizmox.WebGUI.Forms
ToolBarCollection Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ToolBarCollection Class

For a list of all members of this type, see ToolBarCollection members.

Public Properties

 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets the ToolBar with the specified int index.
Top

Protected Properties

 | Name | Description
Protected Property | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Protected Property | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Top

See Also

Reference

ToolBarCollection Class
Gizmox.WebGUI.Forms Namespace


Item Property

[image]
Gizmox.WebGUI.Forms
Item Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ToolBarCollection Class : Item Property

intIndex
Gets or sets the ToolBar with the specified int index.

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal intIndex As Integer _
) As ToolBar
Visual Basic (Usage) Copy Code
Dim instance As ToolBarCollection
Dim intIndex As Integer
Dim value As ToolBar

instance.Item(intIndex) = value

value = instance.Item(intIndex)
C#
public ToolBar this[
   int intIndex
]; {get; set;}
Managed Extensions for C++
public: __property ToolBar* get_Item(
   int intIndex
);
public: __property void set_Item(
   int intIndex,
   ToolBar* value
);
C++/CLI
public:
property ToolBar^ default [int] {
   ToolBar^ get(intintIndex);
   void set (intintIndex, ToolBar^value);
}

Parameters

intIndex

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ToolBarCollection Class
ToolBarCollection Members


ToolBarItemCollection Class

[image]
Gizmox.WebGUI.Forms
ToolBarItemCollection Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ToolBarItemCollection Class

Object Model

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class ToolBarItemCollection
   Implements IObservableList
Visual Basic (Usage) Copy Code
Dim instance As ToolBarItemCollection
C#
[DefaultMemberAttribute("Item")]
public class ToolBarItemCollection : IObservableList
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
public __gc class ToolBarItemCollection : public IObservableList
C++/CLI
[DefaultMemberAttribute("Item")]
public ref class ToolBarItemCollection : public IObservableList

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ToolBarItemCollection

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

ToolBarItemCollection Members
Gizmox.WebGUI.Forms Namespace


ToolBarItemCollection Class Members

[image]
Gizmox.WebGUI.Forms
ToolBarItemCollection Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : ToolBarItemCollection Class

The following tables list the members exposed by ToolBarItemCollection.

Public Constructors

 | Name | Description
Public Constructor | ToolBarItemCollection Constructor | Creates a new ToolBarItemCollection instance.
Top

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item | Gets or sets the ToolBarButton with the specified int index.
Top

Protected Properties

 | Name | Description
Protected Property | List |
Top

Public Methods

 | Name | Description
Public Method | Add |
Public Method | AddRange |
Public Method | Clear |
Public Method | Remove |
Top

Public Events

 | Name | Description
Public Event | ObservableItemAdded |
Public Event | ObservableItemInserted |
Public Event | ObservableItemRemoved |
Public Event | ObservableListCleared |
Top

See Also

Reference

ToolBarItemCollection Class
Gizmox.WebGUI.Forms Namespace


ToolBarItemCollection Constructor

[image]
Gizmox.WebGUI.Forms
ToolBarItemCollection Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ToolBarItemCollection Class : ToolBarItemCollection Constructor

objToolBar
Creates a new ToolBarItemCollection instance.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal objToolBar As ToolBar _
)
Visual Basic (Usage) Copy Code
Dim objToolBar As ToolBar

Dim instance As ToolBarItemCollection(objToolBar)
C#
public ToolBarItemCollection(
   ToolBar objToolBar
)
Managed Extensions for C++
public: ToolBarItemCollection(
   ToolBar* objToolBar
)
C++/CLI
public:
ToolBarItemCollection(
   ToolBar^ objToolBar
)

Parameters

objToolBar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ToolBarItemCollection Class
ToolBarItemCollection Members


ToolBarItemCollection Class Methods

[image]
Gizmox.WebGUI.Forms
ToolBarItemCollection Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ToolBarItemCollection Class

For a list of all members of this type, see ToolBarItemCollection members.

Public Methods

 | Name | Description
Public Method | Add |
Public Method | AddRange |
Public Method | Clear |
Public Method | Remove |
Top

See Also

Reference

ToolBarItemCollection Class
Gizmox.WebGUI.Forms Namespace


Add Method

[image]
Gizmox.WebGUI.Forms
Add Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ToolBarItemCollection Class : Add Method

objToolBarButton

Syntax

Visual Basic (Declaration)
Public Function Add( _
   ByVal objToolBarButton As ToolBarButton _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As ToolBarItemCollection
Dim objToolBarButton As ToolBarButton
Dim value As Integer

value = instance.Add(objToolBarButton)
C#
public int Add(
   ToolBarButton objToolBarButton
)
Managed Extensions for C++
public: int Add(
   ToolBarButton* objToolBarButton
)
C++/CLI
public:
int Add(
   ToolBarButton^ objToolBarButton
)

Parameters

objToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ToolBarItemCollection Class
ToolBarItemCollection Members


AddRange Method

[image]
Gizmox.WebGUI.Forms
AddRange Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ToolBarItemCollection Class : AddRange Method

objToolBarButtons

Syntax

Visual Basic (Declaration)
Public Sub AddRange( _
   ByVal objToolBarButtons() As ToolBarButton _
)
Visual Basic (Usage) Copy Code
Dim instance As ToolBarItemCollection
Dim objToolBarButtons() As ToolBarButton

instance.AddRange(objToolBarButtons)
C#
public void AddRange(
   ToolBarButton[] objToolBarButtons
)
Managed Extensions for C++
public: void AddRange(
   ToolBarButton*[]* objToolBarButtons
)
C++/CLI
public:
void AddRange(
   array<ToolBarButton^>^ objToolBarButtons
)

Parameters

objToolBarButtons

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ToolBarItemCollection Class
ToolBarItemCollection Members


Clear Method

[image]
Gizmox.WebGUI.Forms
Clear Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ToolBarItemCollection Class : Clear Method

Syntax

Visual Basic (Declaration)
Public Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As ToolBarItemCollection

instance.Clear()
C#
public void Clear()
Managed Extensions for C++
public: void Clear();
C++/CLI
public:
void Clear();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ToolBarItemCollection Class
ToolBarItemCollection Members


Remove Method

[image]
Gizmox.WebGUI.Forms
Remove Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ToolBarItemCollection Class : Remove Method

objToolBarButton

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal objToolBarButton As ToolBarButton _
)
Visual Basic (Usage) Copy Code
Dim instance As ToolBarItemCollection
Dim objToolBarButton As ToolBarButton

instance.Remove(objToolBarButton)
C#
public void Remove(
   ToolBarButton objToolBarButton
)
Managed Extensions for C++
public: void Remove(
   ToolBarButton* objToolBarButton
)
C++/CLI
public:
void Remove(
   ToolBarButton^ objToolBarButton
)

Parameters

objToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ToolBarItemCollection Class
ToolBarItemCollection Members


ToolBarItemCollection Class Properties

[image]
Gizmox.WebGUI.Forms
ToolBarItemCollection Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ToolBarItemCollection Class

For a list of all members of this type, see ToolBarItemCollection members.

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item | Gets or sets the ToolBarButton with the specified int index.
Top

Protected Properties

 | Name | Description
Protected Property | List |
Top

See Also

Reference

ToolBarItemCollection Class
Gizmox.WebGUI.Forms Namespace


Count Property

[image]
Gizmox.WebGUI.Forms
Count Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ToolBarItemCollection Class : Count Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As ToolBarItemCollection
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ToolBarItemCollection Class
ToolBarItemCollection Members


Item Property

[image]
Gizmox.WebGUI.Forms
Item Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ToolBarItemCollection Class : Item Property

intIndex
Gets or sets the ToolBarButton with the specified int index.

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal intIndex As Integer _
) As ToolBarButton
Visual Basic (Usage) Copy Code
Dim instance As ToolBarItemCollection
Dim intIndex As Integer
Dim value As ToolBarButton

instance.Item(intIndex) = value

value = instance.Item(intIndex)
C#
public ToolBarButton this[
   int intIndex
]; {get; set;}
Managed Extensions for C++
public: __property ToolBarButton* get_Item(
   int intIndex
);
public: __property void set_Item(
   int intIndex,
   ToolBarButton* value
);
C++/CLI
public:
property ToolBarButton^ default [int] {
   ToolBarButton^ get(intintIndex);
   void set (intintIndex, ToolBarButton^value);
}

Parameters

intIndex

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ToolBarItemCollection Class
ToolBarItemCollection Members


List Property

[image]
Gizmox.WebGUI.Forms
List Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ToolBarItemCollection Class : List Property

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property List As ArrayList
Visual Basic (Usage) Copy Code
Dim instance As ToolBarItemCollection
Dim value As ArrayList

value = instance.List
C#
protected virtual ArrayList List {get;}
Managed Extensions for C++
protected: __property virtual ArrayList* get_List();
C++/CLI
protected:
virtual property ArrayList^ List {
   ArrayList^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ToolBarItemCollection Class
ToolBarItemCollection Members


ToolBarItemCollection Class Events

[image]
Gizmox.WebGUI.Forms
ToolBarItemCollection Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ToolBarItemCollection Class

For a list of all members of this type, see ToolBarItemCollection members.

Public Events

 | Name | Description
Public Event | ObservableItemAdded |
Public Event | ObservableItemInserted |
Public Event | ObservableItemRemoved |
Public Event | ObservableListCleared |
Top

See Also

Reference

ToolBarItemCollection Class
Gizmox.WebGUI.Forms Namespace


ObservableItemAdded Event

[image]
Gizmox.WebGUI.Forms
ObservableItemAdded Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ToolBarItemCollection Class : ObservableItemAdded Event

Syntax

Visual Basic (Declaration)
Public Event ObservableItemAdded() As ObservableListEventHandler
Visual Basic (Usage) Copy Code
Dim instance As ToolBarItemCollection
Dim handler As ObservableListEventHandler

AddHandler instance.ObservableItemAdded, handler
C#
public event ObservableListEventHandler ObservableItemAdded()
Managed Extensions for C++
public: __event ObservableListEventHandler* ObservableItemAdded
C++/CLI
public:
event ObservableListEventHandler^ ObservableItemAdded

Event Data

The event handler receives an argument of type ObservableListEventArgs containing data related to this event. The following ObservableListEventArgs properties provide information specific to this event.

Property | Description
Item |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ToolBarItemCollection Class
ToolBarItemCollection Members


ObservableItemInserted Event

[image]
Gizmox.WebGUI.Forms
ObservableItemInserted Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ToolBarItemCollection Class : ObservableItemInserted Event

Syntax

Visual Basic (Declaration)
Public Event ObservableItemInserted() As ObservableListEventHandler
Visual Basic (Usage) Copy Code
Dim instance As ToolBarItemCollection
Dim handler As ObservableListEventHandler

AddHandler instance.ObservableItemInserted, handler
C#
public event ObservableListEventHandler ObservableItemInserted()
Managed Extensions for C++
public: __event ObservableListEventHandler* ObservableItemInserted
C++/CLI
public:
event ObservableListEventHandler^ ObservableItemInserted

Event Data

The event handler receives an argument of type ObservableListEventArgs containing data related to this event. The following ObservableListEventArgs properties provide information specific to this event.

Property | Description
Item |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ToolBarItemCollection Class
ToolBarItemCollection Members


ObservableItemRemoved Event

[image]
Gizmox.WebGUI.Forms
ObservableItemRemoved Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ToolBarItemCollection Class : ObservableItemRemoved Event

Syntax

Visual Basic (Declaration)
Public Event ObservableItemRemoved() As ObservableListEventHandler
Visual Basic (Usage) Copy Code
Dim instance As ToolBarItemCollection
Dim handler As ObservableListEventHandler

AddHandler instance.ObservableItemRemoved, handler
C#
public event ObservableListEventHandler ObservableItemRemoved()
Managed Extensions for C++
public: __event ObservableListEventHandler* ObservableItemRemoved
C++/CLI
public:
event ObservableListEventHandler^ ObservableItemRemoved

Event Data

The event handler receives an argument of type ObservableListEventArgs containing data related to this event. The following ObservableListEventArgs properties provide information specific to this event.

Property | Description
Item |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ToolBarItemCollection Class
ToolBarItemCollection Members


ObservableListCleared Event

[image]
Gizmox.WebGUI.Forms
ObservableListCleared Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ToolBarItemCollection Class : ObservableListCleared Event

Syntax

Visual Basic (Declaration)
Public Event ObservableListCleared() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As ToolBarItemCollection
Dim handler As EventHandler

AddHandler instance.ObservableListCleared, handler
C#
public event EventHandler ObservableListCleared()
Managed Extensions for C++
public: __event EventHandler* ObservableListCleared
C++/CLI
public:
event EventHandler^ ObservableListCleared

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ToolBarItemCollection Class
ToolBarItemCollection Members


ToolBarItemEventArgs Class

[image]
Gizmox.WebGUI.Forms
ToolBarItemEventArgs Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ToolBarItemEventArgs Class

Object Model

Syntax

Visual Basic (Declaration)
Public Class ToolBarItemEventArgs
   Inherits EventArgs
Visual Basic (Usage) Copy Code
Dim instance As ToolBarItemEventArgs
C#
public class ToolBarItemEventArgs : EventArgs
Managed Extensions for C++
public __gc class ToolBarItemEventArgs : public EventArgs
C++/CLI
public ref class ToolBarItemEventArgs : public EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gizmox.WebGUI.Forms.ToolBarItemEventArgs

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

ToolBarItemEventArgs Members
Gizmox.WebGUI.Forms Namespace


ToolBarItemEventArgs Class Members

[image]
Gizmox.WebGUI.Forms
ToolBarItemEventArgs Class Members
See Also Fields Send Feedback
Gizmox.WebGUI.Forms Namespace : ToolBarItemEventArgs Class

The following tables list the members exposed by ToolBarItemEventArgs.

Public Constructors

 | Name | Description
Public Constructor | ToolBarItemEventArgs Constructor |
Top

Public Fields

 | Name | Description
Public Field | ToolBarButton |
Top

See Also

Reference

ToolBarItemEventArgs Class
Gizmox.WebGUI.Forms Namespace


ToolBarItemEventArgs Constructor

[image]
Gizmox.WebGUI.Forms
ToolBarItemEventArgs Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ToolBarItemEventArgs Class : ToolBarItemEventArgs Constructor

objToolBarButton

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal objToolBarButton As ToolBarButton _
)
Visual Basic (Usage) Copy Code
Dim objToolBarButton As ToolBarButton

Dim instance As ToolBarItemEventArgs(objToolBarButton)
C#
public ToolBarItemEventArgs(
   ToolBarButton objToolBarButton
)
Managed Extensions for C++
public: ToolBarItemEventArgs(
   ToolBarButton* objToolBarButton
)
C++/CLI
public:
ToolBarItemEventArgs(
   ToolBarButton^ objToolBarButton
)

Parameters

objToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ToolBarItemEventArgs Class
ToolBarItemEventArgs Members


ToolBarItemEventArgs Class Fields

[image]
Gizmox.WebGUI.Forms
ToolBarItemEventArgs Class Fields
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ToolBarItemEventArgs Class

For a list of all members of this type, see ToolBarItemEventArgs members.

Public Fields

 | Name | Description
Public Field | ToolBarButton |
Top

See Also

Reference

ToolBarItemEventArgs Class
Gizmox.WebGUI.Forms Namespace


ToolBarButton Field

[image]
Gizmox.WebGUI.Forms
ToolBarButton Field
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ToolBarItemEventArgs Class : ToolBarButton Field

Syntax

Visual Basic (Declaration)
Public ReadOnly ToolBarButton As ToolBarButton
Visual Basic (Usage) Copy Code
Dim instance As ToolBarItemEventArgs
Dim value As ToolBarButton

value = instance.ToolBarButton
C#
public readonly ToolBarButton ToolBarButton
Managed Extensions for C++
public: readonly ToolBarButton* ToolBarButton
C++/CLI
public:
readonly ToolBarButton^ ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ToolBarItemEventArgs Class
ToolBarItemEventArgs Members


ToolTip Class

[image]
Gizmox.WebGUI.Forms
ToolTip Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ToolTip Class

Represents a small rectangular pop-up window that displays a brief description of a control's purpose when the user rests the pointer on the control.

Syntax

Visual Basic (Declaration)
<ProvidePropertyAttribute(PropertyName="ToolTip", ReceiverTypeName="Gizmox.WebGUI.Forms.Control, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d")>
<ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<ToolboxBitmapAttribute()>
<ToolboxItemFilterAttribute("Gizmox.WebGUI.Forms")>
<SRDescriptionAttribute("Displays information when the user moves the pointer over an associated control.")>
Public Class ToolTip
   Inherits ComponentBase
Visual Basic (Usage) Copy Code
Dim instance As ToolTip
C#
[ProvidePropertyAttribute(PropertyName="ToolTip", ReceiverTypeName="Gizmox.WebGUI.Forms.Control, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ToolboxBitmapAttribute()]
[ToolboxItemFilterAttribute("Gizmox.WebGUI.Forms")]
[SRDescriptionAttribute("Displays information when the user moves the pointer over an associated control.")]
public class ToolTip : ComponentBase
Managed Extensions for C++
[ProvidePropertyAttribute(PropertyName="ToolTip", ReceiverTypeName="Gizmox.WebGUI.Forms.Control, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ToolboxBitmapAttribute()]
[ToolboxItemFilterAttribute("Gizmox.WebGUI.Forms")]
[SRDescriptionAttribute("Displays information when the user moves the pointer over an associated control.")]
public __gc class ToolTip : public ComponentBase
C++/CLI
[ProvidePropertyAttribute(PropertyName="ToolTip", ReceiverTypeName="Gizmox.WebGUI.Forms.Control, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ToolboxBitmapAttribute()]
[ToolboxItemFilterAttribute("Gizmox.WebGUI.Forms")]
[SRDescriptionAttribute("Displays information when the user moves the pointer over an associated control.")]
public ref class ToolTip : public ComponentBase

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.ToolTip

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

ToolTip Members
Gizmox.WebGUI.Forms Namespace


ToolTip Class Members

[image]
Gizmox.WebGUI.Forms
ToolTip Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : ToolTip Class

The following tables list the members exposed by ToolTip.

Public Constructors

 | Name | Description
Public Constructor | ToolTip Constructor | Overloaded. Initializes a new instance of the ToolTip without a specified container.
Top

Public Properties

 | Name | Description
Public Property | Container | (Inherited from ComponentBase)
Public Property | Site | (Inherited from ComponentBase)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Top

Public Methods

 | Name | Description
Public Method | CanExtend |
Public Method | Dispose | Overloaded. (Inherited from ComponentBase)
Public Method | GetToolTip | Retrieves the ToolTip text associated with the specified control.
Public Method | SetToolTip | Associates ToolTip text with the specified control.
Public Method | ToString | (Inherited from ComponentBase)
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | GetService | (Inherited from ComponentBase)
Top

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from ComponentBase)
Top

See Also

Reference

ToolTip Class
Gizmox.WebGUI.Forms Namespace


ToolTip Constructor

[image]
Gizmox.WebGUI.Forms
ToolTip Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ToolTip Class : ToolTip Constructor

Initializes a new instance of the ToolTip without a specified container.

Overload List

Overload | Description
ToolTip Constructor() | Initializes a new instance of the ToolTip without a specified container.
ToolTip Constructor(IContainer) | Initializes a new instance of the ToolTip class with a specified container.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ToolTip Class
ToolTip Members


ToolTip Constructor()

[image]
Gizmox.WebGUI.Forms
ToolTip Constructor()
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ToolTip Class > ToolTip Constructor : ToolTip Constructor()

Initializes a new instance of the ToolTip without a specified container.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ToolTip()
C#
public ToolTip()
Managed Extensions for C++
public: ToolTip();
C++/CLI
public:
ToolTip();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ToolTip Class
ToolTip Members
Overload List


ToolTip Constructor(IContainer)

[image]
Gizmox.WebGUI.Forms
ToolTip Constructor(IContainer)
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ToolTip Class > ToolTip Constructor : ToolTip Constructor(IContainer)

objContainer
An IContainer that represents the container of the ToolTip.
Initializes a new instance of the ToolTip class with a specified container.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal objContainer As IContainer _
)
Visual Basic (Usage) Copy Code
Dim objContainer As IContainer

Dim instance As ToolTip(objContainer)
C#
public ToolTip(
   IContainer objContainer
)
Managed Extensions for C++
public: ToolTip(
   IContainer* objContainer
)
C++/CLI
public:
ToolTip(
   IContainer^ objContainer
)

Parameters

objContainer
An IContainer that represents the container of the ToolTip.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ToolTip Class
ToolTip Members
Overload List


ToolTip Class Methods

[image]
Gizmox.WebGUI.Forms
ToolTip Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ToolTip Class

For a list of all members of this type, see ToolTip members.

Public Methods

 | Name | Description
Public Method | CanExtend |
Public Method | Dispose | Overloaded. (Inherited from ComponentBase)
Public Method | GetToolTip | Retrieves the ToolTip text associated with the specified control.
Public Method | SetToolTip | Associates ToolTip text with the specified control.
Public Method | ToString | (Inherited from ComponentBase)
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | GetService | (Inherited from ComponentBase)
Top

See Also

Reference

ToolTip Class
Gizmox.WebGUI.Forms Namespace


CanExtend Method

[image]
Gizmox.WebGUI.Forms
CanExtend Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ToolTip Class : CanExtend Method

target

Syntax

Visual Basic (Declaration)
Public Function CanExtend( _
   ByVal target As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ToolTip
Dim target As Object
Dim value As Boolean

value = instance.CanExtend(target)
C#
public bool CanExtend(
   object target
)
Managed Extensions for C++
public: bool CanExtend(
   Object* target
)
C++/CLI
public:
bool CanExtend(
   Object^ target
)

Parameters

target

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ToolTip Class
ToolTip Members


GetToolTip Method

[image]
Gizmox.WebGUI.Forms
GetToolTip Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ToolTip Class : GetToolTip Method

objControl
The Control for which to retrieve the ToolTip text.
Retrieves the ToolTip text associated with the specified control.

Syntax

Visual Basic (Declaration)
<LocalizableAttribute(True)>
<EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="System.ComponentModel.Design.MultilineStringEditor, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<DefaultValueAttribute()>
<SRDescriptionAttribute("Determines the ToolTip shown when the mouse hovers over the control.")>
Public Function GetToolTip( _
   ByVal objControl As Control _
) As String
Visual Basic (Usage) Copy Code
Dim instance As ToolTip
Dim objControl As Control
Dim value As String

value = instance.GetToolTip(objControl)
C#
[LocalizableAttribute(true)]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="System.ComponentModel.Design.MultilineStringEditor, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Determines the ToolTip shown when the mouse hovers over the control.")]
public string GetToolTip(
   Control objControl
)
Managed Extensions for C++
[LocalizableAttribute(true)]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="System.ComponentModel.Design.MultilineStringEditor, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Determines the ToolTip shown when the mouse hovers over the control.")]
public: string* GetToolTip(
   Control* objControl
)
C++/CLI
[LocalizableAttribute(true)]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="System.ComponentModel.Design.MultilineStringEditor, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Determines the ToolTip shown when the mouse hovers over the control.")]
public:
String^ GetToolTip(
   Control^ objControl
)

Parameters

objControl
The Control for which to retrieve the ToolTip text.

Return Value

A String containing the ToolTip text for the specified control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ToolTip Class
ToolTip Members


SetToolTip Method

[image]
Gizmox.WebGUI.Forms
SetToolTip Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ToolTip Class : SetToolTip Method

objControl
The Control to associate the ToolTip text with.
strCaption
The ToolTip text to display when the pointer is on the control.
Associates ToolTip text with the specified control.

Syntax

Visual Basic (Declaration)
Public Sub SetToolTip( _
   ByVal objControl As Control, _
   ByVal strCaption As String _
)
Visual Basic (Usage) Copy Code
Dim instance As ToolTip
Dim objControl As Control
Dim strCaption As String

instance.SetToolTip(objControl, strCaption)
C#
public void SetToolTip(
   Control objControl,
   string strCaption
)
Managed Extensions for C++
public: void SetToolTip(
   Control* objControl,
   string* strCaption
)
C++/CLI
public:
void SetToolTip(
   Control^ objControl,
   String^ strCaption
)

Parameters

objControl
The Control to associate the ToolTip text with.
strCaption
The ToolTip text to display when the pointer is on the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ToolTip Class
ToolTip Members


TrackBar Class

[image]
Gizmox.WebGUI.Forms
TrackBar Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TrackBar Class

Represents a standard Visual WebGui track bar.

Object Model

Syntax

Visual Basic (Declaration)
<DefaultPropertyAttribute("Value")>
<ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<DesignTimeControllerAttribute()>
<DefaultEventAttribute("ValueChanged")>
<SRDescriptionAttribute("Enables the user to choose between a range of values by sliding a small bar along another bar.")>
<ToolboxBitmapAttribute()>
<MetadataTagAttribute("TRB")>
<SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableSlider, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")>
<ClientControllerAttribute()>
<ToolboxItemCategoryAttribute("Common Controls")>
Public Class TrackBar
   Inherits Control
   Implements IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Visual Basic (Usage) Copy Code
Dim instance As TrackBar
C#
[DefaultPropertyAttribute("Value")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[DesignTimeControllerAttribute()]
[DefaultEventAttribute("ValueChanged")]
[SRDescriptionAttribute("Enables the user to choose between a range of values by sliding a small bar along another bar.")]
[ToolboxBitmapAttribute()]
[MetadataTagAttribute("TRB")]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableSlider, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[ClientControllerAttribute()]
[ToolboxItemCategoryAttribute("Common Controls")]
public class TrackBar : Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Managed Extensions for C++
[DefaultPropertyAttribute("Value")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[DesignTimeControllerAttribute()]
[DefaultEventAttribute("ValueChanged")]
[SRDescriptionAttribute("Enables the user to choose between a range of values by sliding a small bar along another bar.")]
[ToolboxBitmapAttribute()]
[MetadataTagAttribute("TRB")]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableSlider, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[ClientControllerAttribute()]
[ToolboxItemCategoryAttribute("Common Controls")]
public __gc class TrackBar : public Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
C++/CLI
[DefaultPropertyAttribute("Value")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[DesignTimeControllerAttribute()]
[DefaultEventAttribute("ValueChanged")]
[SRDescriptionAttribute("Enables the user to choose between a range of values by sliding a small bar along another bar.")]
[ToolboxBitmapAttribute()]
[MetadataTagAttribute("TRB")]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableSlider, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[ClientControllerAttribute()]
[ToolboxItemCategoryAttribute("Common Controls")]
public ref class TrackBar : public Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.TrackBar

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

TrackBar Members
Gizmox.WebGUI.Forms Namespace


TrackBar Class Members

[image]
Gizmox.WebGUI.Forms
TrackBar Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : TrackBar Class

The following tables list the members exposed by TrackBar.

Public Constructors

 | Name | Description
Public Constructor | TrackBar Constructor | Initializes a new instance of the TrackBar class.
Top

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | LargeChange | Gets or sets a value to be added to or subtracted from the Value property when the scroll box is moved a large distance.
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | Maximum | Gets or sets the upper limit of the range this TrackBar is working with.
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Minimum | Gets or sets the lower limit of the range this TrackBar is working with.
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Orientation | Gets or sets a value indicating the horizontal or vertical orientation of the track bar.
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | SmallChange | Gets or sets the value added to or subtracted from the Value property when the scroll box is moved a small distance.
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Control)
Public Property | TickFrequency | Gets or sets a value that specifies the delta between ticks drawn on the control.
Public Property | TickStyle | Gets or sets a value indicating how to display the tick marks on the track bar.
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | Value | Gets or sets a numeric value that represents the current position of the scroll box on the track bar.
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

Public Methods

 | Name | Description
Public Method | BeginInit | Begins the initialization of a TrackBar that is used on a form or used by another component. The initialization occurs at run time.
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | EndInit | Ends the initialization of a TrackBar that is used on a form or used by another component. The initialization occurs at run time.
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | SetRange | Sets the minimum and maximum values for a TrackBar.
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | Overridden. Returns a string that represents the TrackBar control.
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Overridden. Fires an event.
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from Control)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnValueChanged | Raises the ValueChanged event.
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Control)
Protected Method | RenderAttributes | Overridden. Renders the controls meta attributes
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | ValueChanged | Occurs when the Value property of a track bar changes, either by movement of the scroll box or by manipulation in code.
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

TrackBar Class
Gizmox.WebGUI.Forms Namespace


TrackBar Constructor

[image]
Gizmox.WebGUI.Forms
TrackBar Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TrackBar Class : TrackBar Constructor

Initializes a new instance of the TrackBar class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As TrackBar()
C#
public TrackBar()
Managed Extensions for C++
public: TrackBar();
C++/CLI
public:
TrackBar();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TrackBar Class
TrackBar Members


TrackBar Class Methods

[image]
Gizmox.WebGUI.Forms
TrackBar Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TrackBar Class

For a list of all members of this type, see TrackBar members.

Public Methods

 | Name | Description
Public Method | BeginInit | Begins the initialization of a TrackBar that is used on a form or used by another component. The initialization occurs at run time.
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | EndInit | Ends the initialization of a TrackBar that is used on a form or used by another component. The initialization occurs at run time.
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | SetRange | Sets the minimum and maximum values for a TrackBar.
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | Overridden. Returns a string that represents the TrackBar control.
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Overridden. Fires an event.
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from Control)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnValueChanged | Raises the ValueChanged event.
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Control)
Protected Method | RenderAttributes | Overridden. Renders the controls meta attributes
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

See Also

Reference

TrackBar Class
Gizmox.WebGUI.Forms Namespace


BeginInit Method

[image]
Gizmox.WebGUI.Forms
BeginInit Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TrackBar Class : BeginInit Method

Begins the initialization of a TrackBar that is used on a form or used by another component. The initialization occurs at run time.

Syntax

Visual Basic (Declaration)
Public Sub BeginInit()
Visual Basic (Usage) Copy Code
Dim instance As TrackBar

instance.BeginInit()
C#
public void BeginInit()
Managed Extensions for C++
public: void BeginInit();
C++/CLI
public:
void BeginInit();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TrackBar Class
TrackBar Members


EndInit Method

[image]
Gizmox.WebGUI.Forms
EndInit Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TrackBar Class : EndInit Method

Ends the initialization of a TrackBar that is used on a form or used by another component. The initialization occurs at run time.

Syntax

Visual Basic (Declaration)
Public Sub EndInit()
Visual Basic (Usage) Copy Code
Dim instance As TrackBar

instance.EndInit()
C#
public void EndInit()
Managed Extensions for C++
public: void EndInit();
C++/CLI
public:
void EndInit();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TrackBar Class
TrackBar Members


FireEvent Method

[image]
Gizmox.WebGUI.Forms
FireEvent Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TrackBar Class : FireEvent Method

objEvent
event.
Fires an event.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub FireEvent( _
   ByVal objEvent As IEvent _
)
Visual Basic (Usage) Copy Code
Dim instance As TrackBar
Dim objEvent As IEvent

instance.FireEvent(objEvent)
C#
protected override void FireEvent(
   IEvent objEvent
)
Managed Extensions for C++
protected: void FireEvent(
   IEvent* objEvent
) override
C++/CLI
protected:
void FireEvent(
   IEvent^ objEvent
) override

Parameters

objEvent
event.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TrackBar Class
TrackBar Members


OnValueChanged Method

[image]
Gizmox.WebGUI.Forms
OnValueChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TrackBar Class : OnValueChanged Method

e
The EventArgs that contains the event data.
Raises the ValueChanged event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnValueChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As TrackBar
Dim e As EventArgs

instance.OnValueChanged(e)
C#
protected virtual void OnValueChanged(
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnValueChanged(
   EventArgs* e
)
C++/CLI
protected:
virtual void OnValueChanged(
   EventArgs^ e
)

Parameters

e
The EventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TrackBar Class
TrackBar Members


RenderAttributes Method

[image]
Gizmox.WebGUI.Forms
RenderAttributes Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TrackBar Class : RenderAttributes Method

objContext
objWriter
Renders the controls meta attributes

Syntax

Visual Basic (Declaration)
Protected Overrides Sub RenderAttributes( _
   ByVal objContext As IContext, _
   ByVal objWriter As IAttributeWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As TrackBar
Dim objContext As IContext
Dim objWriter As IAttributeWriter

instance.RenderAttributes(objContext, objWriter)
C#
protected override void RenderAttributes(
   IContext objContext,
   IAttributeWriter objWriter
)
Managed Extensions for C++
protected: void RenderAttributes(
   IContext* objContext,
   IAttributeWriter* objWriter
) override
C++/CLI
protected:
void RenderAttributes(
   IContext^ objContext,
   IAttributeWriter^ objWriter
) override

Parameters

objContext
objWriter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TrackBar Class
TrackBar Members


SetRange Method

[image]
Gizmox.WebGUI.Forms
SetRange Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TrackBar Class : SetRange Method

minValue
The lower limit of the range of the track bar.
maxValue
The upper limit of the range of the track bar.
Sets the minimum and maximum values for a TrackBar.

Syntax

Visual Basic (Declaration)
Public Sub SetRange( _
   ByVal minValue As Integer, _
   ByVal maxValue As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As TrackBar
Dim minValue As Integer
Dim maxValue As Integer

instance.SetRange(minValue, maxValue)
C#
public void SetRange(
   int minValue,
   int maxValue
)
Managed Extensions for C++
public: void SetRange(
   int minValue,
   int maxValue
)
C++/CLI
public:
void SetRange(
   int minValue,
   int maxValue
)

Parameters

minValue
The lower limit of the range of the track bar.
maxValue
The upper limit of the range of the track bar.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TrackBar Class
TrackBar Members


ToString Method

[image]
Gizmox.WebGUI.Forms
ToString Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TrackBar Class : ToString Method

Returns a string that represents the TrackBar control.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As TrackBar
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Return Value

A string that represents the current TrackBar.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TrackBar Class
TrackBar Members


TrackBar Class Properties

[image]
Gizmox.WebGUI.Forms
TrackBar Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TrackBar Class

For a list of all members of this type, see TrackBar members.

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | LargeChange | Gets or sets a value to be added to or subtracted from the Value property when the scroll box is moved a large distance.
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | Maximum | Gets or sets the upper limit of the range this TrackBar is working with.
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Minimum | Gets or sets the lower limit of the range this TrackBar is working with.
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Orientation | Gets or sets a value indicating the horizontal or vertical orientation of the track bar.
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | SmallChange | Gets or sets the value added to or subtracted from the Value property when the scroll box is moved a small distance.
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Control)
Public Property | TickFrequency | Gets or sets a value that specifies the delta between ticks drawn on the control.
Public Property | TickStyle | Gets or sets a value indicating how to display the tick marks on the track bar.
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | Value | Gets or sets a numeric value that represents the current position of the scroll box on the track bar.
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

See Also

Reference

TrackBar Class
Gizmox.WebGUI.Forms Namespace


LargeChange Property

[image]
Gizmox.WebGUI.Forms
LargeChange Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TrackBar Class : LargeChange Property

Gets or sets a value to be added to or subtracted from the Value property when the scroll box is moved a large distance.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("The number of positions the slider moves in response to mouse clicks or the PAGE UP and PAGE DOWN keys.")>
<DefaultValueAttribute()>
<SRCategoryAttribute("Behavior")>
Public Property LargeChange As Integer
Visual Basic (Usage) Copy Code
Dim instance As TrackBar
Dim value As Integer

instance.LargeChange = value

value = instance.LargeChange
C#
[SRDescriptionAttribute("The number of positions the slider moves in response to mouse clicks or the PAGE UP and PAGE DOWN keys.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
public int LargeChange {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("The number of positions the slider moves in response to mouse clicks or the PAGE UP and PAGE DOWN keys.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
public: __property int get_LargeChange();
public: __property void set_LargeChange(
   int value
);
C++/CLI
[SRDescriptionAttribute("The number of positions the slider moves in response to mouse clicks or the PAGE UP and PAGE DOWN keys.")]
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
public:
property int LargeChange {
   int get();
   void set (intvalue);
}

Exceptions

Exception | Description
ArgumentException | The assigned value is less than 0.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TrackBar Class
TrackBar Members


Maximum Property

[image]
Gizmox.WebGUI.Forms
Maximum Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TrackBar Class : Maximum Property

Gets or sets the upper limit of the range this TrackBar is working with.

Syntax

Visual Basic (Declaration)
<RefreshPropertiesAttribute()>
<DefaultValueAttribute()>
<SRDescriptionAttribute("The maximum value for the position of the slider on the TrackBar.")>
<SRCategoryAttribute("Behavior")>
Public Property Maximum As Integer
Visual Basic (Usage) Copy Code
Dim instance As TrackBar
Dim value As Integer

instance.Maximum = value

value = instance.Maximum
C#
[RefreshPropertiesAttribute()]
[DefaultValueAttribute()]
[SRDescriptionAttribute("The maximum value for the position of the slider on the TrackBar.")]
[SRCategoryAttribute("Behavior")]
public int Maximum {get; set;}
Managed Extensions for C++
[RefreshPropertiesAttribute()]
[DefaultValueAttribute()]
[SRDescriptionAttribute("The maximum value for the position of the slider on the TrackBar.")]
[SRCategoryAttribute("Behavior")]
public: __property int get_Maximum();
public: __property void set_Maximum(
   int value
);
C++/CLI
[RefreshPropertiesAttribute()]
[DefaultValueAttribute()]
[SRDescriptionAttribute("The maximum value for the position of the slider on the TrackBar.")]
[SRCategoryAttribute("Behavior")]
public:
property int Maximum {
   int get();
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TrackBar Class
TrackBar Members


Minimum Property

[image]
Gizmox.WebGUI.Forms
Minimum Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TrackBar Class : Minimum Property

Gets or sets the lower limit of the range this TrackBar is working with.

Syntax

Visual Basic (Declaration)
<RefreshPropertiesAttribute()>
<DefaultValueAttribute()>
<SRCategoryAttribute("Behavior")>
<SRDescriptionAttribute("The minimum value for the position of the slider on the TrackBar.")>
Public Property Minimum As Integer
Visual Basic (Usage) Copy Code
Dim instance As TrackBar
Dim value As Integer

instance.Minimum = value

value = instance.Minimum
C#
[RefreshPropertiesAttribute()]
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("The minimum value for the position of the slider on the TrackBar.")]
public int Minimum {get; set;}
Managed Extensions for C++
[RefreshPropertiesAttribute()]
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("The minimum value for the position of the slider on the TrackBar.")]
public: __property int get_Minimum();
public: __property void set_Minimum(
   int value
);
C++/CLI
[RefreshPropertiesAttribute()]
[DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("The minimum value for the position of the slider on the TrackBar.")]
public:
property int Minimum {
   int get();
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TrackBar Class
TrackBar Members


Orientation Property

[image]
Gizmox.WebGUI.Forms
Orientation Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TrackBar Class : Orientation Property

Gets or sets a value indicating the horizontal or vertical orientation of the track bar.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<SRDescriptionAttribute("The orientation of the control.")>
<LocalizableAttribute(True)>
<SRCategoryAttribute("Appearance")>
Public Property Orientation As Orientation
Visual Basic (Usage) Copy Code
Dim instance As TrackBar
Dim value As Orientation

instance.Orientation = value

value = instance.Orientation
C#
[DefaultValueAttribute()]
[SRDescriptionAttribute("The orientation of the control.")]
[LocalizableAttribute(true)]
[SRCategoryAttribute("Appearance")]
public Orientation Orientation {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[SRDescriptionAttribute("The orientation of the control.")]
[LocalizableAttribute(true)]
[SRCategoryAttribute("Appearance")]
public: __property Orientation get_Orientation();
public: __property void set_Orientation(
   Orientation value
);
C++/CLI
[DefaultValueAttribute()]
[SRDescriptionAttribute("The orientation of the control.")]
[LocalizableAttribute(true)]
[SRCategoryAttribute("Appearance")]
public:
property Orientation Orientation {
   Orientation get();
   void set (Orientationvalue);
}

Exceptions

Exception | Description
InvalidEnumArgumentException | The assigned value is not one of the Orientation values.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TrackBar Class
TrackBar Members


SmallChange Property

[image]
Gizmox.WebGUI.Forms
SmallChange Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TrackBar Class : SmallChange Property

Gets or sets the value added to or subtracted from the Value property when the scroll box is moved a small distance.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("The number of positions the slider moves in response to keyboard input (arrow keys).")>
<SRCategoryAttribute("Appearance")>
<DefaultValueAttribute()>
Public Property SmallChange As Integer
Visual Basic (Usage) Copy Code
Dim instance As TrackBar
Dim value As Integer

instance.SmallChange = value

value = instance.SmallChange
C#
[SRDescriptionAttribute("The number of positions the slider moves in response to keyboard input (arrow keys).")]
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
public int SmallChange {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("The number of positions the slider moves in response to keyboard input (arrow keys).")]
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
public: __property int get_SmallChange();
public: __property void set_SmallChange(
   int value
);
C++/CLI
[SRDescriptionAttribute("The number of positions the slider moves in response to keyboard input (arrow keys).")]
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
public:
property int SmallChange {
   int get();
   void set (intvalue);
}

Exceptions

Exception | Description
ArgumentException | The assigned value is less than 0.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TrackBar Class
TrackBar Members


TickFrequency Property

[image]
Gizmox.WebGUI.Forms
TickFrequency Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TrackBar Class : TickFrequency Property

Gets or sets a value that specifies the delta between ticks drawn on the control.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Appearance")>
<DefaultValueAttribute()>
<SRDescriptionAttribute("The number of positions between tick marks.")>
Public Property TickFrequency As Integer
Visual Basic (Usage) Copy Code
Dim instance As TrackBar
Dim value As Integer

instance.TickFrequency = value

value = instance.TickFrequency
C#
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("The number of positions between tick marks.")]
public int TickFrequency {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("The number of positions between tick marks.")]
public: __property int get_TickFrequency();
public: __property void set_TickFrequency(
   int value
);
C++/CLI
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("The number of positions between tick marks.")]
public:
property int TickFrequency {
   int get();
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TrackBar Class
TrackBar Members


TickStyle Property

[image]
Gizmox.WebGUI.Forms
TickStyle Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TrackBar Class : TickStyle Property

Gets or sets a value indicating how to display the tick marks on the track bar.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Indicates where the ticks appear on the TrackBar.")>
<SRCategoryAttribute("Appearance")>
<DefaultValueAttribute()>
Public Property TickStyle As TickStyle
Visual Basic (Usage) Copy Code
Dim instance As TrackBar
Dim value As TickStyle

instance.TickStyle = value

value = instance.TickStyle
C#
[SRDescriptionAttribute("Indicates where the ticks appear on the TrackBar.")]
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
public TickStyle TickStyle {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Indicates where the ticks appear on the TrackBar.")]
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
public: __property TickStyle get_TickStyle();
public: __property void set_TickStyle(
   TickStyle value
);
C++/CLI
[SRDescriptionAttribute("Indicates where the ticks appear on the TrackBar.")]
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
public:
property TickStyle TickStyle {
   TickStyle get();
   void set (TickStylevalue);
}

Exceptions

Exception | Description
InvalidEnumArgumentException | The assigned value is not a valid TickStyle.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TrackBar Class
TrackBar Members


Value Property

[image]
Gizmox.WebGUI.Forms
Value Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TrackBar Class : Value Property

Gets or sets a numeric value that represents the current position of the scroll box on the track bar.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<BindableAttribute(True)>
<SRCategoryAttribute("Behavior")>
<SRDescriptionAttribute("The position of the slider.")>
Public Property Value As Integer
Visual Basic (Usage) Copy Code
Dim instance As TrackBar
Dim value As Integer

instance.Value = value

value = instance.Value
C#
[DefaultValueAttribute()]
[BindableAttribute(true)]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("The position of the slider.")]
public int Value {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[BindableAttribute(true)]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("The position of the slider.")]
public: __property int get_Value();
public: __property void set_Value(
   int value
);
C++/CLI
[DefaultValueAttribute()]
[BindableAttribute(true)]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("The position of the slider.")]
public:
property int Value {
   int get();
   void set (intvalue);
}

Exceptions

Exception | Description
ArgumentException | The assigned value is less than the value of Minimum.-or- The assigned value is greater than the value of Maximum.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TrackBar Class
TrackBar Members


TrackBar Class Events

[image]
Gizmox.WebGUI.Forms
TrackBar Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TrackBar Class

For a list of all members of this type, see TrackBar members.

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | ValueChanged | Occurs when the Value property of a track bar changes, either by movement of the scroll box or by manipulation in code.
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

TrackBar Class
Gizmox.WebGUI.Forms Namespace


ValueChanged Event

[image]
Gizmox.WebGUI.Forms
ValueChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TrackBar Class : ValueChanged Event

Occurs when the Value property of a track bar changes, either by movement of the scroll box or by manipulation in code.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the value of the control changes.")>
<SRCategoryAttribute("Action")>
Public Event ValueChanged() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As TrackBar
Dim handler As EventHandler

AddHandler instance.ValueChanged, handler
C#
[SRDescriptionAttribute("Occurs when the value of the control changes.")]
[SRCategoryAttribute("Action")]
public event EventHandler ValueChanged()
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the value of the control changes.")]
[SRCategoryAttribute("Action")]
public: __event EventHandler* ValueChanged
C++/CLI
[SRDescriptionAttribute("Occurs when the value of the control changes.")]
[SRCategoryAttribute("Action")]
public:
event EventHandler^ ValueChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TrackBar Class
TrackBar Members


TreeNode Class

[image]
Gizmox.WebGUI.Forms
TreeNode Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TreeNode Class

Summary description for TreeNode.

Object Model

Syntax

Visual Basic (Declaration)
<ClientControllerAttribute()>
<DesignTimeControllerAttribute()>
Public Class TreeNode
   Inherits Component
   Implements IAttributeExtender, IEventHandler, IGatewayComponent, IObservableItem, IRegisteredComponent
Visual Basic (Usage) Copy Code
Dim instance As TreeNode
C#
[ClientControllerAttribute()]
[DesignTimeControllerAttribute()]
public class TreeNode : Component, IAttributeExtender, IEventHandler, IGatewayComponent, IObservableItem, IRegisteredComponent
Managed Extensions for C++
[ClientControllerAttribute()]
[DesignTimeControllerAttribute()]
public __gc class TreeNode : public Component, IAttributeExtender, IEventHandler, IGatewayComponent, IObservableItem, IRegisteredComponent
C++/CLI
[ClientControllerAttribute()]
[DesignTimeControllerAttribute()]
public ref class TreeNode : public Component, IAttributeExtender, IEventHandler, IGatewayComponent, IObservableItem, IRegisteredComponent

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.TreeNode

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

TreeNode Members
Gizmox.WebGUI.Forms Namespace


TreeNode Class Members

[image]
Gizmox.WebGUI.Forms
TreeNode Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : TreeNode Class

The following tables list the members exposed by TreeNode.

Public Constructors

 | Name | Description
Public Constructor | TreeNode Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | BackColor | Gets or sets the background color of the tree node.
Public Property | CheckBox | Gets or sets a value indicating whether check boxes are displayed.
Public Property | Checked |
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContextMenu | Gets or sets the context menu code. (Inherited from Component)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | ExpandedImage | The expanded tree node icon
Public Property | ExpandedImageIndex | Gets or sets the expanded image index.
Public Property | FirstNode | Gets the first child tree node in the tree node collection.
Public Property | ForeColor | Gets or sets the foreground color of the tree node.
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | FullPath | Gets the full path.
Public Property | HasNodes | Gets or sets a value indicating whether this instance has nodes.
Public Property | ImageIndex | Gets or sets the image index.
Public Property | ImageKey | Gets or sets the key for the image that is displayed for the item.
Public Property | Index | Gets the position of the tree node in the tree node collection.
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsEditing | Gets a value indicating whether the tree node is in an editable state.
Public Property | IsExpanded | Gets a value indicating whether the tree node is in the expanded state.
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | IsSelected | Gets a value indicating whether the tree node is in the selected state.
Public Property | IsVisible | Gets a value indicating whether the tree node is visible or partially visible.
Public Property | Label | The tree node label
Public Property | LastNode | Gets the last child tree node.
Public Property | Level | Gets the zero-based depth of the tree node in the TreeView control.
Public Property | Loaded | Gets or sets a value indicating whether this TreeNode is loaded.
Public Property | Name | The tree node name
Public Property | NextNode | Gets the next sibling tree node.
Public Property | NextVisibleNode | Gets the next visible tree node.
Public Property | NodeFont | Gets or sets the node font.
Public Property | Nodes | Gets the collection of TreeNode objects assigned to the current tree node.
Public Property | Parent | Gets the tree node parent.
Public Property | PrevNode | Gets the previous sibling tree node.
Public Property | PrevVisibleNode | Gets the previous visible tree node.
Public Property | SelectedImage | The selected tree node icon
Public Property | SelectedImageIndex | Gets or sets the selected image index.
Public Property | SelectOnRightClick |
Public Property | Site | (Inherited from ComponentBase)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text.
Public Property | ToolTipText | Gets or sets the tool tip text for the tree node.
Public Property | TreeView | Gets the parent tree view that the tree node is assigned to.
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

Public Methods

 | Name | Description
Public Method | BeginEdit | Initiates the editing of the tree node label.
Public Method | Collapse | Overloaded. Collapses the tree node.
Public Method | Dispose | Overloaded. Disposes the specified component. (Inherited from Component)
Public Method | EndEdit | Ends the editing of the tree node label.
Public Method | EnsureVisible | Ensures that the tree node is visible, expanding tree nodes and scrolling the tree view control as necessary.
Public Method | Expand | Expands the tree node.
Public Method | ExpandAll | Expands all the child tree nodes.
Public Method | GetNodeCount | Returns the number of child tree nodes.
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | Remove | Removes the current tree node from the tree view control.
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Toggle | Toggles the tree node to either the expanded or collapsed state.
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Overridden. Fires an event.
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCriticalEvents | Overridden.
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnAfterCheck | Raises the TreeView.AfterCheck event.
Protected Method | OnAfterCollapse | Raises the TreeView.AfterCollapse event.
Protected Method | OnAfterExpand | Raises the TreeView.AfterExpand event.
Protected Method | OnAfterLabelEdit | Raises the E:AfterLabelEdit event.
Protected Method | OnAfterSelect | Raises the TreeView.AfterSelect event.
Protected Method | OnBeforeCheck | Raises the TreeView.BeforeCheck event.
Protected Method | OnBeforeCollapse | Raises the TreeView.BeforeCollapse event.
Protected Method | OnBeforeExpand | Raises the TreeView.BeforeExpand event.
Protected Method | OnBeforeSelect | Raises the E:BeforeSelect event.
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnNodeMouseClick | Raises the NodeMouseClick event.
Protected Method | OnNodeMouseDoubleClick | Raises the NodeMouseDoubleClick event.
Protected Method | OnUnregisterComponents | Overridden.
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor |
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor |
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

Public Events

 | Name | Description
Public Event | AfterCheck | Occurs after the tree node check box is checked.
Public Event | AfterCollapse | Occurs after the tree node is collapsed.
Public Event | AfterExpand | Occurs after the tree node is expanded.
Public Event | AfterLabelEdit | Occurs after the tree node label text is edited.
Public Event | AfterSelect | Occurs after the tree node is selected.
Public Event | BeforeCheck | Occurs before the tree node check box is checked.
Public Event | BeforeCollapse | Occurs before the tree node is collapsed.
Public Event | BeforeExpand | Occurs before the tree node is expanded.
Public Event | BeforeLabelEdit | Occurs before the tree node label text is edited.
Public Event | BeforeSelect | Occurs before the tree node is selected.
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | NodeMouseClick | Occurs when the user clicks a TreeNode with the mouse.
Public Event | NodeMouseDoubleClick | Occurs when the user double-clicks a TreeNode with the mouse.
Top

See Also

Reference

TreeNode Class
Gizmox.WebGUI.Forms Namespace


TreeNode Constructor

[image]
Gizmox.WebGUI.Forms
TreeNode Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNode Class : TreeNode Constructor

Overload List

Overload | Description
TreeNode Constructor() |
TreeNode Constructor(String) |
TreeNode Constructor(String,Int32,Int32) |
TreeNode Constructor(String,Int32,Int32,TreeNode[]) |
TreeNode Constructor(String,String,String) |
TreeNode Constructor(String,TreeNode[]) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNode Class
TreeNode Members


TreeNode Constructor()

[image]
Gizmox.WebGUI.Forms
TreeNode Constructor()
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNode Class > TreeNode Constructor : TreeNode Constructor()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As TreeNode()
C#
public TreeNode()
Managed Extensions for C++
public: TreeNode();
C++/CLI
public:
TreeNode();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNode Class
TreeNode Members
Overload List


TreeNode Constructor(String)

[image]
Gizmox.WebGUI.Forms
TreeNode Constructor(String)
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNode Class > TreeNode Constructor : TreeNode Constructor(String)

strLabel

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal strLabel As String _
)
Visual Basic (Usage) Copy Code
Dim strLabel As String

Dim instance As TreeNode(strLabel)
C#
public TreeNode(
   string strLabel
)
Managed Extensions for C++
public: TreeNode(
   string* strLabel
)
C++/CLI
public:
TreeNode(
   String^ strLabel
)

Parameters

strLabel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNode Class
TreeNode Members
Overload List


TreeNode Constructor(String,Int32,Int32)

[image]
Gizmox.WebGUI.Forms
TreeNode Constructor(String,Int32,Int32)
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNode Class > TreeNode Constructor : TreeNode Constructor(String,Int32,Int32)

strLabel
intImageIndex
intSelectedImageIndex

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal strLabel As String, _
   ByVal intImageIndex As Integer, _
   ByVal intSelectedImageIndex As Integer _
)
Visual Basic (Usage) Copy Code
Dim strLabel As String
Dim intImageIndex As Integer
Dim intSelectedImageIndex As Integer

Dim instance As TreeNode(strLabel, intImageIndex, intSelectedImageIndex)
C#
public TreeNode(
   string strLabel,
   int intImageIndex,
   int intSelectedImageIndex
)
Managed Extensions for C++
public: TreeNode(
   string* strLabel,
   int intImageIndex,
   int intSelectedImageIndex
)
C++/CLI
public:
TreeNode(
   String^ strLabel,
   int intImageIndex,
   int intSelectedImageIndex
)

Parameters

strLabel
intImageIndex
intSelectedImageIndex

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNode Class
TreeNode Members
Overload List


TreeNode Constructor(String,Int32,Int32,TreeNode[])

[image]
Gizmox.WebGUI.Forms
TreeNode Constructor(String,Int32,Int32,TreeNode[])
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNode Class > TreeNode Constructor : TreeNode Constructor(String,Int32,Int32,TreeNode[])

strLabel
intImageIndex
intSelectedImageIndex
objTreeNodes

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal strLabel As String, _
   ByVal intImageIndex As Integer, _
   ByVal intSelectedImageIndex As Integer, _
   ByVal objTreeNodes() As TreeNode _
)
Visual Basic (Usage) Copy Code
Dim strLabel As String
Dim intImageIndex As Integer
Dim intSelectedImageIndex As Integer
Dim objTreeNodes() As TreeNode

Dim instance As TreeNode(strLabel, intImageIndex, intSelectedImageIndex, objTreeNodes)
C#
public TreeNode(
   string strLabel,
   int intImageIndex,
   int intSelectedImageIndex,
   TreeNode[] objTreeNodes
)
Managed Extensions for C++
public: TreeNode(
   string* strLabel,
   int intImageIndex,
   int intSelectedImageIndex,
   TreeNode*[]* objTreeNodes
)
C++/CLI
public:
TreeNode(
   String^ strLabel,
   int intImageIndex,
   int intSelectedImageIndex,
   array<TreeNode^>^ objTreeNodes
)

Parameters

strLabel
intImageIndex
intSelectedImageIndex
objTreeNodes

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNode Class
TreeNode Members
Overload List


TreeNode Constructor(String,String,String)

[image]
Gizmox.WebGUI.Forms
TreeNode Constructor(String,String,String)
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNode Class > TreeNode Constructor : TreeNode Constructor(String,String,String)

strName
strLabel
strIcon

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal strName As String, _
   ByVal strLabel As String, _
   ByVal strIcon As String _
)
Visual Basic (Usage) Copy Code
Dim strName As String
Dim strLabel As String
Dim strIcon As String

Dim instance As TreeNode(strName, strLabel, strIcon)
C#
public TreeNode(
   string strName,
   string strLabel,
   string strIcon
)
Managed Extensions for C++
public: TreeNode(
   string* strName,
   string* strLabel,
   string* strIcon
)
C++/CLI
public:
TreeNode(
   String^ strName,
   String^ strLabel,
   String^ strIcon
)

Parameters

strName
strLabel
strIcon

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNode Class
TreeNode Members
Overload List


TreeNode Constructor(String,TreeNode[])

[image]
Gizmox.WebGUI.Forms
TreeNode Constructor(String,TreeNode[])
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNode Class > TreeNode Constructor : TreeNode Constructor(String,TreeNode[])

strLabel
objTreeNodes

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal strLabel As String, _
   ByVal objTreeNodes() As TreeNode _
)
Visual Basic (Usage) Copy Code
Dim strLabel As String
Dim objTreeNodes() As TreeNode

Dim instance As TreeNode(strLabel, objTreeNodes)
C#
public TreeNode(
   string strLabel,
   TreeNode[] objTreeNodes
)
Managed Extensions for C++
public: TreeNode(
   string* strLabel,
   TreeNode*[]* objTreeNodes
)
C++/CLI
public:
TreeNode(
   String^ strLabel,
   array<TreeNode^>^ objTreeNodes
)

Parameters

strLabel
objTreeNodes

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNode Class
TreeNode Members
Overload List


TreeNode Class Methods

[image]
Gizmox.WebGUI.Forms
TreeNode Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TreeNode Class

For a list of all members of this type, see TreeNode members.

Public Methods

 | Name | Description
Public Method | BeginEdit | Initiates the editing of the tree node label.
Public Method | Collapse | Overloaded. Collapses the tree node.
Public Method | Dispose | Overloaded. Disposes the specified component. (Inherited from Component)
Public Method | EndEdit | Ends the editing of the tree node label.
Public Method | EnsureVisible | Ensures that the tree node is visible, expanding tree nodes and scrolling the tree view control as necessary.
Public Method | Expand | Expands the tree node.
Public Method | ExpandAll | Expands all the child tree nodes.
Public Method | GetNodeCount | Returns the number of child tree nodes.
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | Remove | Removes the current tree node from the tree view control.
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Toggle | Toggles the tree node to either the expanded or collapsed state.
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Overridden. Fires an event.
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCriticalEvents | Overridden.
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnAfterCheck | Raises the TreeView.AfterCheck event.
Protected Method | OnAfterCollapse | Raises the TreeView.AfterCollapse event.
Protected Method | OnAfterExpand | Raises the TreeView.AfterExpand event.
Protected Method | OnAfterLabelEdit | Raises the E:AfterLabelEdit event.
Protected Method | OnAfterSelect | Raises the TreeView.AfterSelect event.
Protected Method | OnBeforeCheck | Raises the TreeView.BeforeCheck event.
Protected Method | OnBeforeCollapse | Raises the TreeView.BeforeCollapse event.
Protected Method | OnBeforeExpand | Raises the TreeView.BeforeExpand event.
Protected Method | OnBeforeSelect | Raises the E:BeforeSelect event.
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnNodeMouseClick | Raises the NodeMouseClick event.
Protected Method | OnNodeMouseDoubleClick | Raises the NodeMouseDoubleClick event.
Protected Method | OnUnregisterComponents | Overridden.
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor |
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor |
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

See Also

Reference

TreeNode Class
Gizmox.WebGUI.Forms Namespace


BeginEdit Method

[image]
Gizmox.WebGUI.Forms
BeginEdit Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNode Class : BeginEdit Method

Initiates the editing of the tree node label.

Syntax

Visual Basic (Declaration)
Public Sub BeginEdit()
Visual Basic (Usage) Copy Code
Dim instance As TreeNode

instance.BeginEdit()
C#
public void BeginEdit()
Managed Extensions for C++
public: void BeginEdit();
C++/CLI
public:
void BeginEdit();

Exceptions

Exception | Description
InvalidOperationException | LabelEdit is set to false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNode Class
TreeNode Members


Collapse Method

[image]
Gizmox.WebGUI.Forms
Collapse Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNode Class : Collapse Method

Collapses the tree node.

Overload List

Overload | Description
Collapse() | Collapses the tree node.
Collapse(Boolean) | Collapses the TreeNode and optionally collapses its children.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNode Class
TreeNode Members


Collapse() Method

[image]
Gizmox.WebGUI.Forms
Collapse() Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNode Class > Collapse Method : Collapse() Method

Collapses the tree node.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Collapse()
Visual Basic (Usage) Copy Code
Dim instance As TreeNode

instance.Collapse()
C#
public void Collapse()
Managed Extensions for C++
public: void Collapse();
C++/CLI
public:
void Collapse();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNode Class
TreeNode Members
Overload List


Collapse(Boolean) Method

[image]
Gizmox.WebGUI.Forms
Collapse(Boolean) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNode Class > Collapse Method : Collapse(Boolean) Method

ignoreChildren
true to leave the child nodes in their current state; false to collapse the child nodes.
Collapses the TreeNode and optionally collapses its children.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Collapse( _
   ByVal ignoreChildren As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As TreeNode
Dim ignoreChildren As Boolean

instance.Collapse(ignoreChildren)
C#
public void Collapse(
   bool ignoreChildren
)
Managed Extensions for C++
public: void Collapse(
   bool ignoreChildren
)
C++/CLI
public:
void Collapse(
   bool ignoreChildren
)

Parameters

ignoreChildren
true to leave the child nodes in their current state; false to collapse the child nodes.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNode Class
TreeNode Members
Overload List


EndEdit Method

[image]
Gizmox.WebGUI.Forms
EndEdit Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNode Class : EndEdit Method

cancel
true if the editing of the tree node label text was canceled without being saved; otherwise, false.
Ends the editing of the tree node label.

Syntax

Visual Basic (Declaration)
Public Sub EndEdit( _
   ByVal cancel As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As TreeNode
Dim cancel As Boolean

instance.EndEdit(cancel)
C#
public void EndEdit(
   bool cancel
)
Managed Extensions for C++
public: void EndEdit(
   bool cancel
)
C++/CLI
public:
void EndEdit(
   bool cancel
)

Parameters

cancel
true if the editing of the tree node label text was canceled without being saved; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNode Class
TreeNode Members


EnsureVisible Method

[image]
Gizmox.WebGUI.Forms
EnsureVisible Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNode Class : EnsureVisible Method

Ensures that the tree node is visible, expanding tree nodes and scrolling the tree view control as necessary.

Syntax

Visual Basic (Declaration)
Public Sub EnsureVisible()
Visual Basic (Usage) Copy Code
Dim instance As TreeNode

instance.EnsureVisible()
C#
public void EnsureVisible()
Managed Extensions for C++
public: void EnsureVisible();
C++/CLI
public:
void EnsureVisible();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNode Class
TreeNode Members


Expand Method

[image]
Gizmox.WebGUI.Forms
Expand Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNode Class : Expand Method

Expands the tree node.

Syntax

Visual Basic (Declaration)
Public Sub Expand()
Visual Basic (Usage) Copy Code
Dim instance As TreeNode

instance.Expand()
C#
public void Expand()
Managed Extensions for C++
public: void Expand();
C++/CLI
public:
void Expand();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNode Class
TreeNode Members


ExpandAll Method

[image]
Gizmox.WebGUI.Forms
ExpandAll Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNode Class : ExpandAll Method

Expands all the child tree nodes.

Syntax

Visual Basic (Declaration)
Public Sub ExpandAll()
Visual Basic (Usage) Copy Code
Dim instance As TreeNode

instance.ExpandAll()
C#
public void ExpandAll()
Managed Extensions for C++
public: void ExpandAll();
C++/CLI
public:
void ExpandAll();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNode Class
TreeNode Members


FireEvent Method

[image]
Gizmox.WebGUI.Forms
FireEvent Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNode Class : FireEvent Method

objEvent
event.
Fires an event.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub FireEvent( _
   ByVal objEvent As IEvent _
)
Visual Basic (Usage) Copy Code
Dim instance As TreeNode
Dim objEvent As IEvent

instance.FireEvent(objEvent)
C#
protected override void FireEvent(
   IEvent objEvent
)
Managed Extensions for C++
protected: void FireEvent(
   IEvent* objEvent
) override
C++/CLI
protected:
void FireEvent(
   IEvent^ objEvent
) override

Parameters

objEvent
event.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNode Class
TreeNode Members


GetCriticalEvents Method

[image]
Gizmox.WebGUI.Forms
GetCriticalEvents Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNode Class : GetCriticalEvents Method

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetCriticalEvents() As EventTypes
Visual Basic (Usage) Copy Code
Dim instance As TreeNode
Dim value As EventTypes

value = instance.GetCriticalEvents()
C#
protected override EventTypes GetCriticalEvents()
Managed Extensions for C++
protected: EventTypes GetCriticalEvents(); override
C++/CLI
protected:
EventTypes GetCriticalEvents(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNode Class
TreeNode Members


GetNodeCount Method

[image]
Gizmox.WebGUI.Forms
GetNodeCount Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNode Class : GetNodeCount Method

blnIncludeSubTrees
true if the resulting count includes all tree nodes indirectly rooted at this tree node; otherwise, false .
Returns the number of child tree nodes.

Syntax

Visual Basic (Declaration)
Public Function GetNodeCount( _
   ByVal blnIncludeSubTrees As Boolean _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As TreeNode
Dim blnIncludeSubTrees As Boolean
Dim value As Integer

value = instance.GetNodeCount(blnIncludeSubTrees)
C#
public int GetNodeCount(
   bool blnIncludeSubTrees
)
Managed Extensions for C++
public: int GetNodeCount(
   bool blnIncludeSubTrees
)
C++/CLI
public:
int GetNodeCount(
   bool blnIncludeSubTrees
)

Parameters

blnIncludeSubTrees
true if the resulting count includes all tree nodes indirectly rooted at this tree node; otherwise, false .

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNode Class
TreeNode Members


OnAfterCheck Method

[image]
Gizmox.WebGUI.Forms
OnAfterCheck Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNode Class : OnAfterCheck Method

e
A TreeViewEventArgs that contains the event data.
Raises the TreeView.AfterCheck event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnAfterCheck( _
   ByVal e As TreeViewEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As TreeNode
Dim e As TreeViewEventArgs

instance.OnAfterCheck(e)
C#
protected virtual void OnAfterCheck(
   TreeViewEventArgs e
)
Managed Extensions for C++
protected: virtual void OnAfterCheck(
   TreeViewEventArgs* e
)
C++/CLI
protected:
virtual void OnAfterCheck(
   TreeViewEventArgs^ e
)

Parameters

e
A TreeViewEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNode Class
TreeNode Members


OnAfterCollapse Method

[image]
Gizmox.WebGUI.Forms
OnAfterCollapse Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNode Class : OnAfterCollapse Method

e
A TreeViewEventArgs that contains the event data.
Raises the TreeView.AfterCollapse event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnAfterCollapse( _
   ByVal e As TreeViewEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As TreeNode
Dim e As TreeViewEventArgs

instance.OnAfterCollapse(e)
C#
protected virtual void OnAfterCollapse(
   TreeViewEventArgs e
)
Managed Extensions for C++
protected: virtual void OnAfterCollapse(
   TreeViewEventArgs* e
)
C++/CLI
protected:
virtual void OnAfterCollapse(
   TreeViewEventArgs^ e
)

Parameters

e
A TreeViewEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNode Class
TreeNode Members


OnAfterExpand Method

[image]
Gizmox.WebGUI.Forms
OnAfterExpand Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNode Class : OnAfterExpand Method

e
A TreeViewEventArgs that contains the event data.
Raises the TreeView.AfterExpand event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnAfterExpand( _
   ByVal e As TreeViewEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As TreeNode
Dim e As TreeViewEventArgs

instance.OnAfterExpand(e)
C#
protected virtual void OnAfterExpand(
   TreeViewEventArgs e
)
Managed Extensions for C++
protected: virtual void OnAfterExpand(
   TreeViewEventArgs* e
)
C++/CLI
protected:
virtual void OnAfterExpand(
   TreeViewEventArgs^ e
)

Parameters

e
A TreeViewEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNode Class
TreeNode Members


OnAfterLabelEdit Method

[image]
Gizmox.WebGUI.Forms
OnAfterLabelEdit Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNode Class : OnAfterLabelEdit Method

e
The NodeLabelEditEventArgs instance containing the event data.
Raises the E:AfterLabelEdit event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnAfterLabelEdit( _
   ByVal e As NodeLabelEditEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As TreeNode
Dim e As NodeLabelEditEventArgs

instance.OnAfterLabelEdit(e)
C#
protected virtual void OnAfterLabelEdit(
   NodeLabelEditEventArgs e
)
Managed Extensions for C++
protected: virtual void OnAfterLabelEdit(
   NodeLabelEditEventArgs* e
)
C++/CLI
protected:
virtual void OnAfterLabelEdit(
   NodeLabelEditEventArgs^ e
)

Parameters

e
The NodeLabelEditEventArgs instance containing the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNode Class
TreeNode Members


OnAfterSelect Method

[image]
Gizmox.WebGUI.Forms
OnAfterSelect Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNode Class : OnAfterSelect Method

e
A TreeViewEventArgs that contains the event data.
Raises the TreeView.AfterSelect event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnAfterSelect( _
   ByVal e As TreeViewEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As TreeNode
Dim e As TreeViewEventArgs

instance.OnAfterSelect(e)
C#
protected virtual void OnAfterSelect(
   TreeViewEventArgs e
)
Managed Extensions for C++
protected: virtual void OnAfterSelect(
   TreeViewEventArgs* e
)
C++/CLI
protected:
virtual void OnAfterSelect(
   TreeViewEventArgs^ e
)

Parameters

e
A TreeViewEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNode Class
TreeNode Members


OnBeforeCheck Method

[image]
Gizmox.WebGUI.Forms
OnBeforeCheck Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNode Class : OnBeforeCheck Method

e
A TreeViewCancelEventArgs that contains the event data.
Raises the TreeView.BeforeCheck event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnBeforeCheck( _
   ByVal e As TreeViewCancelEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As TreeNode
Dim e As TreeViewCancelEventArgs

instance.OnBeforeCheck(e)
C#
protected virtual void OnBeforeCheck(
   TreeViewCancelEventArgs e
)
Managed Extensions for C++
protected: virtual void OnBeforeCheck(
   TreeViewCancelEventArgs* e
)
C++/CLI
protected:
virtual void OnBeforeCheck(
   TreeViewCancelEventArgs^ e
)

Parameters

e
A TreeViewCancelEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNode Class
TreeNode Members


OnBeforeCollapse Method

[image]
Gizmox.WebGUI.Forms
OnBeforeCollapse Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNode Class : OnBeforeCollapse Method

e
A TreeViewCancelEventArgs that contains the event data.
Raises the TreeView.BeforeCollapse event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnBeforeCollapse( _
   ByVal e As TreeViewCancelEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As TreeNode
Dim e As TreeViewCancelEventArgs

instance.OnBeforeCollapse(e)
C#
protected virtual void OnBeforeCollapse(
   TreeViewCancelEventArgs e
)
Managed Extensions for C++
protected: virtual void OnBeforeCollapse(
   TreeViewCancelEventArgs* e
)
C++/CLI
protected:
virtual void OnBeforeCollapse(
   TreeViewCancelEventArgs^ e
)

Parameters

e
A TreeViewCancelEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNode Class
TreeNode Members


OnBeforeExpand Method

[image]
Gizmox.WebGUI.Forms
OnBeforeExpand Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNode Class : OnBeforeExpand Method

e
A TreeViewCancelEventArgs that contains the event data.
Raises the TreeView.BeforeExpand event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnBeforeExpand( _
   ByVal e As TreeViewCancelEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As TreeNode
Dim e As TreeViewCancelEventArgs

instance.OnBeforeExpand(e)
C#
protected virtual void OnBeforeExpand(
   TreeViewCancelEventArgs e
)
Managed Extensions for C++
protected: virtual void OnBeforeExpand(
   TreeViewCancelEventArgs* e
)
C++/CLI
protected:
virtual void OnBeforeExpand(
   TreeViewCancelEventArgs^ e
)

Parameters

e
A TreeViewCancelEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNode Class
TreeNode Members


OnBeforeSelect Method

[image]
Gizmox.WebGUI.Forms
OnBeforeSelect Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNode Class : OnBeforeSelect Method

e
The TreeViewCancelEventArgs instance containing the event data.
Raises the E:BeforeSelect event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnBeforeSelect( _
   ByVal e As TreeViewCancelEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As TreeNode
Dim e As TreeViewCancelEventArgs

instance.OnBeforeSelect(e)
C#
protected virtual void OnBeforeSelect(
   TreeViewCancelEventArgs e
)
Managed Extensions for C++
protected: virtual void OnBeforeSelect(
   TreeViewCancelEventArgs* e
)
C++/CLI
protected:
virtual void OnBeforeSelect(
   TreeViewCancelEventArgs^ e
)

Parameters

e
The TreeViewCancelEventArgs instance containing the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNode Class
TreeNode Members


OnNodeMouseClick Method

[image]
Gizmox.WebGUI.Forms
OnNodeMouseClick Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNode Class : OnNodeMouseClick Method

e
A TreeNodeMouseClickEventArgs that contains the event data.
Raises the NodeMouseClick event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnNodeMouseClick( _
   ByVal e As TreeNodeMouseClickEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As TreeNode
Dim e As TreeNodeMouseClickEventArgs

instance.OnNodeMouseClick(e)
C#
protected virtual void OnNodeMouseClick(
   TreeNodeMouseClickEventArgs e
)
Managed Extensions for C++
protected: virtual void OnNodeMouseClick(
   TreeNodeMouseClickEventArgs* e
)
C++/CLI
protected:
virtual void OnNodeMouseClick(
   TreeNodeMouseClickEventArgs^ e
)

Parameters

e
A TreeNodeMouseClickEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNode Class
TreeNode Members


OnNodeMouseDoubleClick Method

[image]
Gizmox.WebGUI.Forms
OnNodeMouseDoubleClick Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNode Class : OnNodeMouseDoubleClick Method

e
A TreeNodeMouseClickEventArgs that contains the event data.
Raises the NodeMouseDoubleClick event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnNodeMouseDoubleClick( _
   ByVal e As TreeNodeMouseClickEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As TreeNode
Dim e As TreeNodeMouseClickEventArgs

instance.OnNodeMouseDoubleClick(e)
C#
protected virtual void OnNodeMouseDoubleClick(
   TreeNodeMouseClickEventArgs e
)
Managed Extensions for C++
protected: virtual void OnNodeMouseDoubleClick(
   TreeNodeMouseClickEventArgs* e
)
C++/CLI
protected:
virtual void OnNodeMouseDoubleClick(
   TreeNodeMouseClickEventArgs^ e
)

Parameters

e
A TreeNodeMouseClickEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNode Class
TreeNode Members


OnUnregisterComponents Method

[image]
Gizmox.WebGUI.Forms
OnUnregisterComponents Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNode Class : OnUnregisterComponents Method

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnUnregisterComponents()
Visual Basic (Usage) Copy Code
Dim instance As TreeNode

instance.OnUnregisterComponents()
C#
protected override void OnUnregisterComponents()
Managed Extensions for C++
protected: void OnUnregisterComponents(); override
C++/CLI
protected:
void OnUnregisterComponents(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNode Class
TreeNode Members


Remove Method

[image]
Gizmox.WebGUI.Forms
Remove Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNode Class : Remove Method

Removes the current tree node from the tree view control.

Syntax

Visual Basic (Declaration)
Public Sub Remove()
Visual Basic (Usage) Copy Code
Dim instance As TreeNode

instance.Remove()
C#
public void Remove()
Managed Extensions for C++
public: void Remove();
C++/CLI
public:
void Remove();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNode Class
TreeNode Members


ShouldSerializeBackColor Method

[image]
Gizmox.WebGUI.Forms
ShouldSerializeBackColor Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNode Class : ShouldSerializeBackColor Method

Syntax

Visual Basic (Declaration)
Protected Overridable Function ShouldSerializeBackColor() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TreeNode
Dim value As Boolean

value = instance.ShouldSerializeBackColor()
C#
protected virtual bool ShouldSerializeBackColor()
Managed Extensions for C++
protected: virtual bool ShouldSerializeBackColor();
C++/CLI
protected:
virtual bool ShouldSerializeBackColor();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNode Class
TreeNode Members


ShouldSerializeForeColor Method

[image]
Gizmox.WebGUI.Forms
ShouldSerializeForeColor Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNode Class : ShouldSerializeForeColor Method

Syntax

Visual Basic (Declaration)
Protected Overridable Function ShouldSerializeForeColor() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TreeNode
Dim value As Boolean

value = instance.ShouldSerializeForeColor()
C#
protected virtual bool ShouldSerializeForeColor()
Managed Extensions for C++
protected: virtual bool ShouldSerializeForeColor();
C++/CLI
protected:
virtual bool ShouldSerializeForeColor();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNode Class
TreeNode Members


Toggle Method

[image]
Gizmox.WebGUI.Forms
Toggle Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNode Class : Toggle Method

Toggles the tree node to either the expanded or collapsed state.

Syntax

Visual Basic (Declaration)
Public Sub Toggle()
Visual Basic (Usage) Copy Code
Dim instance As TreeNode

instance.Toggle()
C#
public void Toggle()
Managed Extensions for C++
public: void Toggle();
C++/CLI
public:
void Toggle();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNode Class
TreeNode Members


TreeNode Class Properties

[image]
Gizmox.WebGUI.Forms
TreeNode Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TreeNode Class

For a list of all members of this type, see TreeNode members.

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | BackColor | Gets or sets the background color of the tree node.
Public Property | CheckBox | Gets or sets a value indicating whether check boxes are displayed.
Public Property | Checked |
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContextMenu | Gets or sets the context menu code. (Inherited from Component)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | ExpandedImage | The expanded tree node icon
Public Property | ExpandedImageIndex | Gets or sets the expanded image index.
Public Property | FirstNode | Gets the first child tree node in the tree node collection.
Public Property | ForeColor | Gets or sets the foreground color of the tree node.
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | FullPath | Gets the full path.
Public Property | HasNodes | Gets or sets a value indicating whether this instance has nodes.
Public Property | ImageIndex | Gets or sets the image index.
Public Property | ImageKey | Gets or sets the key for the image that is displayed for the item.
Public Property | Index | Gets the position of the tree node in the tree node collection.
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsEditing | Gets a value indicating whether the tree node is in an editable state.
Public Property | IsExpanded | Gets a value indicating whether the tree node is in the expanded state.
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | IsSelected | Gets a value indicating whether the tree node is in the selected state.
Public Property | IsVisible | Gets a value indicating whether the tree node is visible or partially visible.
Public Property | Label | The tree node label
Public Property | LastNode | Gets the last child tree node.
Public Property | Level | Gets the zero-based depth of the tree node in the TreeView control.
Public Property | Loaded | Gets or sets a value indicating whether this TreeNode is loaded.
Public Property | Name | The tree node name
Public Property | NextNode | Gets the next sibling tree node.
Public Property | NextVisibleNode | Gets the next visible tree node.
Public Property | NodeFont | Gets or sets the node font.
Public Property | Nodes | Gets the collection of TreeNode objects assigned to the current tree node.
Public Property | Parent | Gets the tree node parent.
Public Property | PrevNode | Gets the previous sibling tree node.
Public Property | PrevVisibleNode | Gets the previous visible tree node.
Public Property | SelectedImage | The selected tree node icon
Public Property | SelectedImageIndex | Gets or sets the selected image index.
Public Property | SelectOnRightClick |
Public Property | Site | (Inherited from ComponentBase)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text.
Public Property | ToolTipText | Gets or sets the tool tip text for the tree node.
Public Property | TreeView | Gets the parent tree view that the tree node is assigned to.
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

See Also

Reference

TreeNode Class
Gizmox.WebGUI.Forms Namespace


BackColor Property

[image]
Gizmox.WebGUI.Forms
BackColor Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNode Class : BackColor Property

Gets or sets the background color of the tree node.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Appearance")>
<SRDescriptionAttribute("The background color of tree node.")>
Public Property BackColor As Color
Visual Basic (Usage) Copy Code
Dim instance As TreeNode
Dim value As Color

instance.BackColor = value

value = instance.BackColor
C#
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("The background color of tree node.")]
public Color BackColor {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("The background color of tree node.")]
public: __property Color get_BackColor();
public: __property void set_BackColor(
   Color value
);
C++/CLI
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("The background color of tree node.")]
public:
property Color BackColor {
   Color get();
   void set (Colorvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNode Class
TreeNode Members


CheckBox Property

[image]
Gizmox.WebGUI.Forms
CheckBox Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNode Class : CheckBox Property

Gets or sets a value indicating whether check boxes are displayed.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property CheckBox As CheckBoxVisibility
Visual Basic (Usage) Copy Code
Dim instance As TreeNode
Dim value As CheckBoxVisibility

instance.CheckBox = value

value = instance.CheckBox
C#
[DefaultValueAttribute()]
public CheckBoxVisibility CheckBox {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property CheckBoxVisibility get_CheckBox();
public: __property void set_CheckBox(
   CheckBoxVisibility value
);
C++/CLI
[DefaultValueAttribute()]
public:
property CheckBoxVisibility CheckBox {
   CheckBoxVisibility get();
   void set (CheckBoxVisibilityvalue);
}

Return Value

true if check boxes are displayed; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNode Class
TreeNode Members


Checked Property

[image]
Gizmox.WebGUI.Forms
Checked Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNode Class : Checked Property

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property Checked As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TreeNode
Dim value As Boolean

instance.Checked = value

value = instance.Checked
C#
[DefaultValueAttribute()]
public bool Checked {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property bool get_Checked();
public: __property void set_Checked(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
public:
property bool Checked {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNode Class
TreeNode Members


ExpandedImage Property

[image]
Gizmox.WebGUI.Forms
ExpandedImage Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNode Class : ExpandedImage Property

The expanded tree node icon

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
<DefaultValueAttribute()>
<BrowsableAttribute(False)>
Public Property ExpandedImage As ResourceHandle
Visual Basic (Usage) Copy Code
Dim instance As TreeNode
Dim value As ResourceHandle

instance.ExpandedImage = value

value = instance.ExpandedImage
C#
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
public ResourceHandle ExpandedImage {get; set;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
public: __property ResourceHandle* get_ExpandedImage();
public: __property void set_ExpandedImage(
   ResourceHandle* value
);
C++/CLI
[DesignerSerializationVisibilityAttribute()]
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
public:
property ResourceHandle^ ExpandedImage {
   ResourceHandle^ get();
   void set (ResourceHandle^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNode Class
TreeNode Members


ExpandedImageIndex Property

[image]
Gizmox.WebGUI.Forms
ExpandedImageIndex Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNode Class : ExpandedImageIndex Property

Gets or sets the expanded image index.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property ExpandedImageIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As TreeNode
Dim value As Integer

instance.ExpandedImageIndex = value

value = instance.ExpandedImageIndex
C#
[DefaultValueAttribute()]
public int ExpandedImageIndex {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property int get_ExpandedImageIndex();
public: __property void set_ExpandedImageIndex(
   int value
);
C++/CLI
[DefaultValueAttribute()]
public:
property int ExpandedImageIndex {
   int get();
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNode Class
TreeNode Members


FirstNode Property

[image]
Gizmox.WebGUI.Forms
FirstNode Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNode Class : FirstNode Property

Gets the first child tree node in the tree node collection.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property FirstNode As TreeNode
Visual Basic (Usage) Copy Code
Dim instance As TreeNode
Dim value As TreeNode

value = instance.FirstNode
C#
[BrowsableAttribute(false)]
public TreeNode FirstNode {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property TreeNode* get_FirstNode();
C++/CLI
[BrowsableAttribute(false)]
public:
property TreeNode^ FirstNode {
   TreeNode^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNode Class
TreeNode Members


ForeColor Property

[image]
Gizmox.WebGUI.Forms
ForeColor Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNode Class : ForeColor Property

Gets or sets the foreground color of the tree node.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Appearance")>
<SRDescriptionAttribute("The foreground color of tree node.")>
Public Property ForeColor As Color
Visual Basic (Usage) Copy Code
Dim instance As TreeNode
Dim value As Color

instance.ForeColor = value

value = instance.ForeColor
C#
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("The foreground color of tree node.")]
public Color ForeColor {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("The foreground color of tree node.")]
public: __property Color get_ForeColor();
public: __property void set_ForeColor(
   Color value
);
C++/CLI
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("The foreground color of tree node.")]
public:
property Color ForeColor {
   Color get();
   void set (Colorvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNode Class
TreeNode Members


FullPath Property

[image]
Gizmox.WebGUI.Forms
FullPath Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNode Class : FullPath Property

Gets the full path.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FullPath As String
Visual Basic (Usage) Copy Code
Dim instance As TreeNode
Dim value As String

value = instance.FullPath
C#
public string FullPath {get;}
Managed Extensions for C++
public: __property string* get_FullPath();
C++/CLI
public:
property String^ FullPath {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNode Class
TreeNode Members


HasNodes Property

[image]
Gizmox.WebGUI.Forms
HasNodes Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNode Class : HasNodes Property

Gets or sets a value indicating whether this instance has nodes.

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
Public Property HasNodes As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TreeNode
Dim value As Boolean

instance.HasNodes = value

value = instance.HasNodes
C#
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public bool HasNodes {get; set;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public: __property bool get_HasNodes();
public: __property void set_HasNodes(
   bool value
);
C++/CLI
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public:
property bool HasNodes {
   bool get();
   void set (boolvalue);
}

Return Value

true if this instance has nodes; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNode Class
TreeNode Members


ImageIndex Property

[image]
Gizmox.WebGUI.Forms
ImageIndex Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNode Class : ImageIndex Property

Gets or sets the image index.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("The ImageList index value of the image displayed when the tree node is in the unselected state.")>
<EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.ImageIndexEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")>
<TypeConverterAttribute("Gizmox.WebGUI.Forms.Design.TreeViewImageIndexConverter, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")>
<DefaultValueAttribute()>
<RefreshPropertiesAttribute()>
<RelatedImageListAttribute("TreeView.ImageList")>
<LocalizableAttribute(True)>
<SRCategoryAttribute("Behavior")>
Public Property ImageIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As TreeNode
Dim value As Integer

instance.ImageIndex = value

value = instance.ImageIndex
C#
[SRDescriptionAttribute("The ImageList index value of the image displayed when the tree node is in the unselected state.")]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.ImageIndexEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[TypeConverterAttribute("Gizmox.WebGUI.Forms.Design.TreeViewImageIndexConverter, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[DefaultValueAttribute()]
[RefreshPropertiesAttribute()]
[RelatedImageListAttribute("TreeView.ImageList")]
[LocalizableAttribute(true)]
[SRCategoryAttribute("Behavior")]
public int ImageIndex {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("The ImageList index value of the image displayed when the tree node is in the unselected state.")]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.ImageIndexEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[TypeConverterAttribute("Gizmox.WebGUI.Forms.Design.TreeViewImageIndexConverter, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[DefaultValueAttribute()]
[RefreshPropertiesAttribute()]
[RelatedImageListAttribute("TreeView.ImageList")]
[LocalizableAttribute(true)]
[SRCategoryAttribute("Behavior")]
public: __property int get_ImageIndex();
public: __property void set_ImageIndex(
   int value
);
C++/CLI
[SRDescriptionAttribute("The ImageList index value of the image displayed when the tree node is in the unselected state.")]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.ImageIndexEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[TypeConverterAttribute("Gizmox.WebGUI.Forms.Design.TreeViewImageIndexConverter, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[DefaultValueAttribute()]
[RefreshPropertiesAttribute()]
[RelatedImageListAttribute("TreeView.ImageList")]
[LocalizableAttribute(true)]
[SRCategoryAttribute("Behavior")]
public:
property int ImageIndex {
   int get();
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNode Class
TreeNode Members


ImageKey Property

[image]
Gizmox.WebGUI.Forms
ImageKey Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNode Class : ImageKey Property

Gets or sets the key for the image that is displayed for the item.

Syntax

Visual Basic (Declaration)
<EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.ImageIndexEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")>
<DefaultValueAttribute()>
<TypeConverterAttribute("Gizmox.WebGUI.Forms.Design.TreeViewImageKeyConverter, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")>
<SRCategoryAttribute("Behavior")>
<RefreshPropertiesAttribute()>
<RelatedImageListAttribute("TreeView.ImageList")>
<SRDescriptionAttribute("Identifies the image to display on the node when it is not selected.")>
<LocalizableAttribute(True)>
Public Property ImageKey As String
Visual Basic (Usage) Copy Code
Dim instance As TreeNode
Dim value As String

instance.ImageKey = value

value = instance.ImageKey
C#
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.ImageIndexEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[DefaultValueAttribute()]
[TypeConverterAttribute("Gizmox.WebGUI.Forms.Design.TreeViewImageKeyConverter, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[SRCategoryAttribute("Behavior")]
[RefreshPropertiesAttribute()]
[RelatedImageListAttribute("TreeView.ImageList")]
[SRDescriptionAttribute("Identifies the image to display on the node when it is not selected.")]
[LocalizableAttribute(true)]
public string ImageKey {get; set;}
Managed Extensions for C++
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.ImageIndexEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[DefaultValueAttribute()]
[TypeConverterAttribute("Gizmox.WebGUI.Forms.Design.TreeViewImageKeyConverter, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[SRCategoryAttribute("Behavior")]
[RefreshPropertiesAttribute()]
[RelatedImageListAttribute("TreeView.ImageList")]
[SRDescriptionAttribute("Identifies the image to display on the node when it is not selected.")]
[LocalizableAttribute(true)]
public: __property string* get_ImageKey();
public: __property void set_ImageKey(
   string* value
);
C++/CLI
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.ImageIndexEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[DefaultValueAttribute()]
[TypeConverterAttribute("Gizmox.WebGUI.Forms.Design.TreeViewImageKeyConverter, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[SRCategoryAttribute("Behavior")]
[RefreshPropertiesAttribute()]
[RelatedImageListAttribute("TreeView.ImageList")]
[SRDescriptionAttribute("Identifies the image to display on the node when it is not selected.")]
[LocalizableAttribute(true)]
public:
property String^ ImageKey {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNode Class
TreeNode Members


Index Property

[image]
Gizmox.WebGUI.Forms
Index Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNode Class : Index Property

Gets the position of the tree node in the tree node collection.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("The position of the tree node in the tree node collection.")>
<SRCategoryAttribute("Behavior")>
Public ReadOnly Property Index As Integer
Visual Basic (Usage) Copy Code
Dim instance As TreeNode
Dim value As Integer

value = instance.Index
C#
[SRDescriptionAttribute("The position of the tree node in the tree node collection.")]
[SRCategoryAttribute("Behavior")]
public int Index {get;}
Managed Extensions for C++
[SRDescriptionAttribute("The position of the tree node in the tree node collection.")]
[SRCategoryAttribute("Behavior")]
public: __property int get_Index();
C++/CLI
[SRDescriptionAttribute("The position of the tree node in the tree node collection.")]
[SRCategoryAttribute("Behavior")]
public:
property int Index {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNode Class
TreeNode Members


IsEditing Property

[image]
Gizmox.WebGUI.Forms
IsEditing Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNode Class : IsEditing Property

Gets a value indicating whether the tree node is in an editable state.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property IsEditing As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TreeNode
Dim value As Boolean

value = instance.IsEditing
C#
[BrowsableAttribute(false)]
public bool IsEditing {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property bool get_IsEditing();
C++/CLI
[BrowsableAttribute(false)]
public:
property bool IsEditing {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNode Class
TreeNode Members


IsExpanded Property

[image]
Gizmox.WebGUI.Forms
IsExpanded Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNode Class : IsExpanded Property

Gets a value indicating whether the tree node is in the expanded state.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public Property IsExpanded As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TreeNode
Dim value As Boolean

instance.IsExpanded = value

value = instance.IsExpanded
C#
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public bool IsExpanded {get; set;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property bool get_IsExpanded();
public: __property void set_IsExpanded(
   bool value
);
C++/CLI
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
property bool IsExpanded {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNode Class
TreeNode Members


IsSelected Property

[image]
Gizmox.WebGUI.Forms
IsSelected Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNode Class : IsSelected Property

Gets a value indicating whether the tree node is in the selected state.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property IsSelected As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TreeNode
Dim value As Boolean

value = instance.IsSelected
C#
[BrowsableAttribute(false)]
public bool IsSelected {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property bool get_IsSelected();
C++/CLI
[BrowsableAttribute(false)]
public:
property bool IsSelected {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNode Class
TreeNode Members


IsVisible Property

[image]
Gizmox.WebGUI.Forms
IsVisible Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNode Class : IsVisible Property

Gets a value indicating whether the tree node is visible or partially visible.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property IsVisible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TreeNode
Dim value As Boolean

value = instance.IsVisible
C#
[BrowsableAttribute(false)]
public bool IsVisible {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property bool get_IsVisible();
C++/CLI
[BrowsableAttribute(false)]
public:
property bool IsVisible {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNode Class
TreeNode Members


Label Property

[image]
Gizmox.WebGUI.Forms
Label Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNode Class : Label Property

The tree node label

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
Public Property Label As String
Visual Basic (Usage) Copy Code
Dim instance As TreeNode
Dim value As String

instance.Label = value

value = instance.Label
C#
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public string Label {get; set;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public: __property string* get_Label();
public: __property void set_Label(
   string* value
);
C++/CLI
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public:
property String^ Label {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNode Class
TreeNode Members


LastNode Property

[image]
Gizmox.WebGUI.Forms
LastNode Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNode Class : LastNode Property

Gets the last child tree node.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property LastNode As TreeNode
Visual Basic (Usage) Copy Code
Dim instance As TreeNode
Dim value As TreeNode

value = instance.LastNode
C#
[BrowsableAttribute(false)]
public TreeNode LastNode {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property TreeNode* get_LastNode();
C++/CLI
[BrowsableAttribute(false)]
public:
property TreeNode^ LastNode {
   TreeNode^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNode Class
TreeNode Members


Level Property

[image]
Gizmox.WebGUI.Forms
Level Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNode Class : Level Property

Gets the zero-based depth of the tree node in the TreeView control.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property Level As Integer
Visual Basic (Usage) Copy Code
Dim instance As TreeNode
Dim value As Integer

value = instance.Level
C#
[BrowsableAttribute(false)]
public int Level {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property int get_Level();
C++/CLI
[BrowsableAttribute(false)]
public:
property int Level {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNode Class
TreeNode Members


Loaded Property

[image]
Gizmox.WebGUI.Forms
Loaded Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNode Class : Loaded Property

Gets or sets a value indicating whether this TreeNode is loaded.

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
Public Property Loaded As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TreeNode
Dim value As Boolean

instance.Loaded = value

value = instance.Loaded
C#
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public bool Loaded {get; set;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public: __property bool get_Loaded();
public: __property void set_Loaded(
   bool value
);
C++/CLI
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public:
property bool Loaded {
   bool get();
   void set (boolvalue);
}

Return Value

true if loaded; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNode Class
TreeNode Members


Name Property

[image]
Gizmox.WebGUI.Forms
Name Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNode Class : Name Property

The tree node name

Syntax

Visual Basic (Declaration)
Public Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As TreeNode
Dim value As String

instance.Name = value

value = instance.Name
C#
public string Name {get; set;}
Managed Extensions for C++
public: __property string* get_Name();
public: __property void set_Name(
   string* value
);
C++/CLI
public:
property String^ Name {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNode Class
TreeNode Members


NextNode Property

[image]
Gizmox.WebGUI.Forms
NextNode Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNode Class : NextNode Property

Gets the next sibling tree node.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property NextNode As TreeNode
Visual Basic (Usage) Copy Code
Dim instance As TreeNode
Dim value As TreeNode

value = instance.NextNode
C#
[BrowsableAttribute(false)]
public TreeNode NextNode {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property TreeNode* get_NextNode();
C++/CLI
[BrowsableAttribute(false)]
public:
property TreeNode^ NextNode {
   TreeNode^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNode Class
TreeNode Members


NextVisibleNode Property

[image]
Gizmox.WebGUI.Forms
NextVisibleNode Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNode Class : NextVisibleNode Property

Gets the next visible tree node.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property NextVisibleNode As TreeNode
Visual Basic (Usage) Copy Code
Dim instance As TreeNode
Dim value As TreeNode

value = instance.NextVisibleNode
C#
[BrowsableAttribute(false)]
public TreeNode NextVisibleNode {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property TreeNode* get_NextVisibleNode();
C++/CLI
[BrowsableAttribute(false)]
public:
property TreeNode^ NextVisibleNode {
   TreeNode^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNode Class
TreeNode Members


NodeFont Property

[image]
Gizmox.WebGUI.Forms
NodeFont Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNode Class : NodeFont Property

Gets or sets the node font.

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
Public Property NodeFont As Font
Visual Basic (Usage) Copy Code
Dim instance As TreeNode
Dim value As Font

instance.NodeFont = value

value = instance.NodeFont
C#
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public Font NodeFont {get; set;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public: __property Font* get_NodeFont();
public: __property void set_NodeFont(
   Font* value
);
C++/CLI
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public:
property Font^ NodeFont {
   Font^ get();
   void set (Font^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNode Class
TreeNode Members


Nodes Property

[image]
Gizmox.WebGUI.Forms
Nodes Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNode Class : Nodes Property

Gets the collection of TreeNode objects assigned to the current tree node.

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
<ListBindableAttribute(False)>
Public ReadOnly Property Nodes As TreeNodeCollection
Visual Basic (Usage) Copy Code
Dim instance As TreeNode
Dim value As TreeNodeCollection

value = instance.Nodes
C#
[DesignerSerializationVisibilityAttribute()]
[ListBindableAttribute(false)]
public TreeNodeCollection Nodes {get;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
[ListBindableAttribute(false)]
public: __property TreeNodeCollection* get_Nodes();
C++/CLI
[DesignerSerializationVisibilityAttribute()]
[ListBindableAttribute(false)]
public:
property TreeNodeCollection^ Nodes {
   TreeNodeCollection^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNode Class
TreeNode Members


Parent Property

[image]
Gizmox.WebGUI.Forms
Parent Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNode Class : Parent Property

Gets the tree node parent.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public ReadOnly Property Parent As TreeNode
Visual Basic (Usage) Copy Code
Dim instance As TreeNode
Dim value As TreeNode

value = instance.Parent
C#
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public TreeNode Parent {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property TreeNode* get_Parent();
C++/CLI
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
property TreeNode^ Parent {
   TreeNode^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNode Class
TreeNode Members


PrevNode Property

[image]
Gizmox.WebGUI.Forms
PrevNode Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNode Class : PrevNode Property

Gets the previous sibling tree node.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property PrevNode As TreeNode
Visual Basic (Usage) Copy Code
Dim instance As TreeNode
Dim value As TreeNode

value = instance.PrevNode
C#
[BrowsableAttribute(false)]
public TreeNode PrevNode {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property TreeNode* get_PrevNode();
C++/CLI
[BrowsableAttribute(false)]
public:
property TreeNode^ PrevNode {
   TreeNode^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNode Class
TreeNode Members


PrevVisibleNode Property

[image]
Gizmox.WebGUI.Forms
PrevVisibleNode Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNode Class : PrevVisibleNode Property

Gets the previous visible tree node.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property PrevVisibleNode As TreeNode
Visual Basic (Usage) Copy Code
Dim instance As TreeNode
Dim value As TreeNode

value = instance.PrevVisibleNode
C#
[BrowsableAttribute(false)]
public TreeNode PrevVisibleNode {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property TreeNode* get_PrevVisibleNode();
C++/CLI
[BrowsableAttribute(false)]
public:
property TreeNode^ PrevVisibleNode {
   TreeNode^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNode Class
TreeNode Members


SelectedImage Property

[image]
Gizmox.WebGUI.Forms
SelectedImage Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNode Class : SelectedImage Property

The selected tree node icon

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public Property SelectedImage As ResourceHandle
Visual Basic (Usage) Copy Code
Dim instance As TreeNode
Dim value As ResourceHandle

instance.SelectedImage = value

value = instance.SelectedImage
C#
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public ResourceHandle SelectedImage {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property ResourceHandle* get_SelectedImage();
public: __property void set_SelectedImage(
   ResourceHandle* value
);
C++/CLI
[DefaultValueAttribute()]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
property ResourceHandle^ SelectedImage {
   ResourceHandle^ get();
   void set (ResourceHandle^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNode Class
TreeNode Members


SelectedImageIndex Property

[image]
Gizmox.WebGUI.Forms
SelectedImageIndex Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNode Class : SelectedImageIndex Property

Gets or sets the selected image index.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property SelectedImageIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As TreeNode
Dim value As Integer

instance.SelectedImageIndex = value

value = instance.SelectedImageIndex
C#
[DefaultValueAttribute()]
public int SelectedImageIndex {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property int get_SelectedImageIndex();
public: __property void set_SelectedImageIndex(
   int value
);
C++/CLI
[DefaultValueAttribute()]
public:
property int SelectedImageIndex {
   int get();
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNode Class
TreeNode Members


SelectOnRightClick Property

[image]
Gizmox.WebGUI.Forms
SelectOnRightClick Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNode Class : SelectOnRightClick Property

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Appearance")>
<SRDescriptionAttribute("Allow / disallow the tree node to be selected on right click.")>
Public Property SelectOnRightClick As SelectOnRightClickBehvior
Visual Basic (Usage) Copy Code
Dim instance As TreeNode
Dim value As SelectOnRightClickBehvior

instance.SelectOnRightClick = value

value = instance.SelectOnRightClick
C#
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Allow / disallow the tree node to be selected on right click.")]
public SelectOnRightClickBehvior SelectOnRightClick {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Allow / disallow the tree node to be selected on right click.")]
public: __property SelectOnRightClickBehvior get_SelectOnRightClick();
public: __property void set_SelectOnRightClick(
   SelectOnRightClickBehvior value
);
C++/CLI
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Allow / disallow the tree node to be selected on right click.")]
public:
property SelectOnRightClickBehvior SelectOnRightClick {
   SelectOnRightClickBehvior get();
   void set (SelectOnRightClickBehviorvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNode Class
TreeNode Members


Text Property

[image]
Gizmox.WebGUI.Forms
Text Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNode Class : Text Property

Gets or sets the text.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property Text As String
Visual Basic (Usage) Copy Code
Dim instance As TreeNode
Dim value As String

instance.Text = value

value = instance.Text
C#
[DefaultValueAttribute()]
public string Text {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property string* get_Text();
public: __property void set_Text(
   string* value
);
C++/CLI
[DefaultValueAttribute()]
public:
property String^ Text {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNode Class
TreeNode Members


ToolTipText Property

[image]
Gizmox.WebGUI.Forms
ToolTipText Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNode Class : ToolTipText Property

Gets or sets the tool tip text for the tree node.

Syntax

Visual Basic (Declaration)
Public Property ToolTipText As String
Visual Basic (Usage) Copy Code
Dim instance As TreeNode
Dim value As String

instance.ToolTipText = value

value = instance.ToolTipText
C#
public string ToolTipText {get; set;}
Managed Extensions for C++
public: __property string* get_ToolTipText();
public: __property void set_ToolTipText(
   string* value
);
C++/CLI
public:
property String^ ToolTipText {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNode Class
TreeNode Members


TreeView Property

[image]
Gizmox.WebGUI.Forms
TreeView Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNode Class : TreeView Property

Gets the parent tree view that the tree node is assigned to.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public ReadOnly Property TreeView As TreeView
Visual Basic (Usage) Copy Code
Dim instance As TreeNode
Dim value As TreeView

value = instance.TreeView
C#
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public TreeView TreeView {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property TreeView* get_TreeView();
C++/CLI
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
property TreeView^ TreeView {
   TreeView^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNode Class
TreeNode Members


TreeNode Class Events

[image]
Gizmox.WebGUI.Forms
TreeNode Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TreeNode Class

For a list of all members of this type, see TreeNode members.

Public Events

 | Name | Description
Public Event | AfterCheck | Occurs after the tree node check box is checked.
Public Event | AfterCollapse | Occurs after the tree node is collapsed.
Public Event | AfterExpand | Occurs after the tree node is expanded.
Public Event | AfterLabelEdit | Occurs after the tree node label text is edited.
Public Event | AfterSelect | Occurs after the tree node is selected.
Public Event | BeforeCheck | Occurs before the tree node check box is checked.
Public Event | BeforeCollapse | Occurs before the tree node is collapsed.
Public Event | BeforeExpand | Occurs before the tree node is expanded.
Public Event | BeforeLabelEdit | Occurs before the tree node label text is edited.
Public Event | BeforeSelect | Occurs before the tree node is selected.
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | NodeMouseClick | Occurs when the user clicks a TreeNode with the mouse.
Public Event | NodeMouseDoubleClick | Occurs when the user double-clicks a TreeNode with the mouse.
Top

See Also

Reference

TreeNode Class
Gizmox.WebGUI.Forms Namespace


AfterCheck Event

[image]
Gizmox.WebGUI.Forms
AfterCheck Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNode Class : AfterCheck Event

Occurs after the tree node check box is checked.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Behavior")>
<SRDescriptionAttribute("Occurs when a check box on a tree node has been checked or unchecked.")>
Public Event AfterCheck() As TreeViewEventHandler
Visual Basic (Usage) Copy Code
Dim instance As TreeNode
Dim handler As TreeViewEventHandler

AddHandler instance.AfterCheck, handler
C#
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when a check box on a tree node has been checked or unchecked.")]
public event TreeViewEventHandler AfterCheck()
Managed Extensions for C++
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when a check box on a tree node has been checked or unchecked.")]
public: __event TreeViewEventHandler* AfterCheck
C++/CLI
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when a check box on a tree node has been checked or unchecked.")]
public:
event TreeViewEventHandler^ AfterCheck

Event Data

The event handler receives an argument of type TreeViewEventArgs containing data related to this event. The following TreeViewEventArgs properties provide information specific to this event.

Property | Description
Action |
Node |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNode Class
TreeNode Members


AfterCollapse Event

[image]
Gizmox.WebGUI.Forms
AfterCollapse Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNode Class : AfterCollapse Event

Occurs after the tree node is collapsed.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Behavior")>
<SRDescriptionAttribute("Occurs when a node has been collapsed.")>
Public Event AfterCollapse() As TreeViewEventHandler
Visual Basic (Usage) Copy Code
Dim instance As TreeNode
Dim handler As TreeViewEventHandler

AddHandler instance.AfterCollapse, handler
C#
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when a node has been collapsed.")]
public event TreeViewEventHandler AfterCollapse()
Managed Extensions for C++
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when a node has been collapsed.")]
public: __event TreeViewEventHandler* AfterCollapse
C++/CLI
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when a node has been collapsed.")]
public:
event TreeViewEventHandler^ AfterCollapse

Event Data

The event handler receives an argument of type TreeViewEventArgs containing data related to this event. The following TreeViewEventArgs properties provide information specific to this event.

Property | Description
Action |
Node |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNode Class
TreeNode Members


AfterExpand Event

[image]
Gizmox.WebGUI.Forms
AfterExpand Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNode Class : AfterExpand Event

Occurs after the tree node is expanded.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when a node has been expanded.")>
<SRCategoryAttribute("Behavior")>
Public Event AfterExpand() As TreeViewEventHandler
Visual Basic (Usage) Copy Code
Dim instance As TreeNode
Dim handler As TreeViewEventHandler

AddHandler instance.AfterExpand, handler
C#
[SRDescriptionAttribute("Occurs when a node has been expanded.")]
[SRCategoryAttribute("Behavior")]
public event TreeViewEventHandler AfterExpand()
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when a node has been expanded.")]
[SRCategoryAttribute("Behavior")]
public: __event TreeViewEventHandler* AfterExpand
C++/CLI
[SRDescriptionAttribute("Occurs when a node has been expanded.")]
[SRCategoryAttribute("Behavior")]
public:
event TreeViewEventHandler^ AfterExpand

Event Data

The event handler receives an argument of type TreeViewEventArgs containing data related to this event. The following TreeViewEventArgs properties provide information specific to this event.

Property | Description
Action |
Node |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNode Class
TreeNode Members


AfterLabelEdit Event

[image]
Gizmox.WebGUI.Forms
AfterLabelEdit Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNode Class : AfterLabelEdit Event

Occurs after the tree node label text is edited.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the text of a node has been edited by the user.")>
<SRCategoryAttribute("Behavior")>
Public Event AfterLabelEdit() As NodeLabelEditEventHandler
Visual Basic (Usage) Copy Code
Dim instance As TreeNode
Dim handler As NodeLabelEditEventHandler

AddHandler instance.AfterLabelEdit, handler
C#
[SRDescriptionAttribute("Occurs when the text of a node has been edited by the user.")]
[SRCategoryAttribute("Behavior")]
public event NodeLabelEditEventHandler AfterLabelEdit()
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the text of a node has been edited by the user.")]
[SRCategoryAttribute("Behavior")]
public: __event NodeLabelEditEventHandler* AfterLabelEdit
C++/CLI
[SRDescriptionAttribute("Occurs when the text of a node has been edited by the user.")]
[SRCategoryAttribute("Behavior")]
public:
event NodeLabelEditEventHandler^ AfterLabelEdit

Event Data

The event handler receives an argument of type NodeLabelEditEventArgs containing data related to this event. The following NodeLabelEditEventArgs properties provide information specific to this event.

Property | Description
CancelEdit |
Label |
Node |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNode Class
TreeNode Members


AfterSelect Event

[image]
Gizmox.WebGUI.Forms
AfterSelect Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNode Class : AfterSelect Event

Occurs after the tree node is selected.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Behavior")>
<SRDescriptionAttribute("Occurs when the selection has been changed.")>
Public Event AfterSelect() As TreeViewEventHandler
Visual Basic (Usage) Copy Code
Dim instance As TreeNode
Dim handler As TreeViewEventHandler

AddHandler instance.AfterSelect, handler
C#
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when the selection has been changed.")]
public event TreeViewEventHandler AfterSelect()
Managed Extensions for C++
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when the selection has been changed.")]
public: __event TreeViewEventHandler* AfterSelect
C++/CLI
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when the selection has been changed.")]
public:
event TreeViewEventHandler^ AfterSelect

Event Data

The event handler receives an argument of type TreeViewEventArgs containing data related to this event. The following TreeViewEventArgs properties provide information specific to this event.

Property | Description
Action |
Node |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNode Class
TreeNode Members


BeforeCheck Event

[image]
Gizmox.WebGUI.Forms
BeforeCheck Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNode Class : BeforeCheck Event

Occurs before the tree node check box is checked.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when a check box on a tree node is about to be checked or unchecked.")>
<SRCategoryAttribute("Behavior")>
Public Event BeforeCheck() As TreeViewCancelEventHandler
Visual Basic (Usage) Copy Code
Dim instance As TreeNode
Dim handler As TreeViewCancelEventHandler

AddHandler instance.BeforeCheck, handler
C#
[SRDescriptionAttribute("Occurs when a check box on a tree node is about to be checked or unchecked.")]
[SRCategoryAttribute("Behavior")]
public event TreeViewCancelEventHandler BeforeCheck()
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when a check box on a tree node is about to be checked or unchecked.")]
[SRCategoryAttribute("Behavior")]
public: __event TreeViewCancelEventHandler* BeforeCheck
C++/CLI
[SRDescriptionAttribute("Occurs when a check box on a tree node is about to be checked or unchecked.")]
[SRCategoryAttribute("Behavior")]
public:
event TreeViewCancelEventHandler^ BeforeCheck

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNode Class
TreeNode Members


BeforeCollapse Event

[image]
Gizmox.WebGUI.Forms
BeforeCollapse Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNode Class : BeforeCollapse Event

Occurs before the tree node is collapsed.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when a node is about to be collapsed.")>
<SRCategoryAttribute("Behavior")>
Public Event BeforeCollapse() As TreeViewCancelEventHandler
Visual Basic (Usage) Copy Code
Dim instance As TreeNode
Dim handler As TreeViewCancelEventHandler

AddHandler instance.BeforeCollapse, handler
C#
[SRDescriptionAttribute("Occurs when a node is about to be collapsed.")]
[SRCategoryAttribute("Behavior")]
public event TreeViewCancelEventHandler BeforeCollapse()
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when a node is about to be collapsed.")]
[SRCategoryAttribute("Behavior")]
public: __event TreeViewCancelEventHandler* BeforeCollapse
C++/CLI
[SRDescriptionAttribute("Occurs when a node is about to be collapsed.")]
[SRCategoryAttribute("Behavior")]
public:
event TreeViewCancelEventHandler^ BeforeCollapse

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNode Class
TreeNode Members


BeforeExpand Event

[image]
Gizmox.WebGUI.Forms
BeforeExpand Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNode Class : BeforeExpand Event

Occurs before the tree node is expanded.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when a node is about to be expanded.")>
<SRCategoryAttribute("Behavior")>
Public Event BeforeExpand() As TreeViewCancelEventHandler
Visual Basic (Usage) Copy Code
Dim instance As TreeNode
Dim handler As TreeViewCancelEventHandler

AddHandler instance.BeforeExpand, handler
C#
[SRDescriptionAttribute("Occurs when a node is about to be expanded.")]
[SRCategoryAttribute("Behavior")]
public event TreeViewCancelEventHandler BeforeExpand()
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when a node is about to be expanded.")]
[SRCategoryAttribute("Behavior")]
public: __event TreeViewCancelEventHandler* BeforeExpand
C++/CLI
[SRDescriptionAttribute("Occurs when a node is about to be expanded.")]
[SRCategoryAttribute("Behavior")]
public:
event TreeViewCancelEventHandler^ BeforeExpand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNode Class
TreeNode Members


BeforeLabelEdit Event

[image]
Gizmox.WebGUI.Forms
BeforeLabelEdit Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNode Class : BeforeLabelEdit Event

Occurs before the tree node label text is edited.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the text of a node is about to be edited by the user.")>
<SRCategoryAttribute("Behavior")>
Public Event BeforeLabelEdit() As NodeLabelEditEventHandler
Visual Basic (Usage) Copy Code
Dim instance As TreeNode
Dim handler As NodeLabelEditEventHandler

AddHandler instance.BeforeLabelEdit, handler
C#
[SRDescriptionAttribute("Occurs when the text of a node is about to be edited by the user.")]
[SRCategoryAttribute("Behavior")]
public event NodeLabelEditEventHandler BeforeLabelEdit()
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the text of a node is about to be edited by the user.")]
[SRCategoryAttribute("Behavior")]
public: __event NodeLabelEditEventHandler* BeforeLabelEdit
C++/CLI
[SRDescriptionAttribute("Occurs when the text of a node is about to be edited by the user.")]
[SRCategoryAttribute("Behavior")]
public:
event NodeLabelEditEventHandler^ BeforeLabelEdit

Event Data

The event handler receives an argument of type NodeLabelEditEventArgs containing data related to this event. The following NodeLabelEditEventArgs properties provide information specific to this event.

Property | Description
CancelEdit |
Label |
Node |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNode Class
TreeNode Members


BeforeSelect Event

[image]
Gizmox.WebGUI.Forms
BeforeSelect Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNode Class : BeforeSelect Event

Occurs before the tree node is selected.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Behavior")>
<SRDescriptionAttribute("Occurs when the selection is about to change.")>
Public Event BeforeSelect() As TreeViewCancelEventHandler
Visual Basic (Usage) Copy Code
Dim instance As TreeNode
Dim handler As TreeViewCancelEventHandler

AddHandler instance.BeforeSelect, handler
C#
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when the selection is about to change.")]
public event TreeViewCancelEventHandler BeforeSelect()
Managed Extensions for C++
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when the selection is about to change.")]
public: __event TreeViewCancelEventHandler* BeforeSelect
C++/CLI
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when the selection is about to change.")]
public:
event TreeViewCancelEventHandler^ BeforeSelect

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNode Class
TreeNode Members


NodeMouseClick Event

[image]
Gizmox.WebGUI.Forms
NodeMouseClick Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNode Class : NodeMouseClick Event

Occurs when the user clicks a TreeNode with the mouse.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Behavior")>
<SRDescriptionAttribute("Occurs when a node is clicked with the mouse.")>
Public Event NodeMouseClick() As TreeNodeMouseClickEventHandler
Visual Basic (Usage) Copy Code
Dim instance As TreeNode
Dim handler As TreeNodeMouseClickEventHandler

AddHandler instance.NodeMouseClick, handler
C#
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when a node is clicked with the mouse.")]
public event TreeNodeMouseClickEventHandler NodeMouseClick()
Managed Extensions for C++
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when a node is clicked with the mouse.")]
public: __event TreeNodeMouseClickEventHandler* NodeMouseClick
C++/CLI
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when a node is clicked with the mouse.")]
public:
event TreeNodeMouseClickEventHandler^ NodeMouseClick

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNode Class
TreeNode Members


NodeMouseDoubleClick Event

[image]
Gizmox.WebGUI.Forms
NodeMouseDoubleClick Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNode Class : NodeMouseDoubleClick Event

Occurs when the user double-clicks a TreeNode with the mouse.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Behavior")>
<SRDescriptionAttribute("Occurs when a node is double-clicked with the mouse.")>
Public Event NodeMouseDoubleClick() As TreeNodeMouseClickEventHandler
Visual Basic (Usage) Copy Code
Dim instance As TreeNode
Dim handler As TreeNodeMouseClickEventHandler

AddHandler instance.NodeMouseDoubleClick, handler
C#
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when a node is double-clicked with the mouse.")]
public event TreeNodeMouseClickEventHandler NodeMouseDoubleClick()
Managed Extensions for C++
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when a node is double-clicked with the mouse.")]
public: __event TreeNodeMouseClickEventHandler* NodeMouseDoubleClick
C++/CLI
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when a node is double-clicked with the mouse.")]
public:
event TreeNodeMouseClickEventHandler^ NodeMouseDoubleClick

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNode Class
TreeNode Members


TreeNodeCollection Class

[image]
Gizmox.WebGUI.Forms
TreeNodeCollection Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TreeNodeCollection Class

Collection of tree view nodes

Object Model

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute()>
<DefaultMemberAttribute("Item")>
<BrowsableAttribute(True)>
Public Class TreeNodeCollection
   Inherits BaseCollection
   Implements IObservableList
Visual Basic (Usage) Copy Code
Dim instance As TreeNodeCollection
C#
[EditorBrowsableAttribute()]
[DefaultMemberAttribute("Item")]
[BrowsableAttribute(true)]
public class TreeNodeCollection : BaseCollection, IObservableList
Managed Extensions for C++
[EditorBrowsableAttribute()]
[DefaultMemberAttribute("Item")]
[BrowsableAttribute(true)]
public __gc class TreeNodeCollection : public BaseCollection, IObservableList
C++/CLI
[EditorBrowsableAttribute()]
[DefaultMemberAttribute("Item")]
[BrowsableAttribute(true)]
public ref class TreeNodeCollection : public BaseCollection, IObservableList

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.BaseCollection
Gizmox.WebGUI.Forms.TreeNodeCollection

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

TreeNodeCollection Members
Gizmox.WebGUI.Forms Namespace


TreeNodeCollection Class Members

[image]
Gizmox.WebGUI.Forms
TreeNodeCollection Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : TreeNodeCollection Class

The following tables list the members exposed by TreeNodeCollection.

Public Constructors

 | Name | Description
Public Constructor | TreeNodeCollection Constructor | Creates a new TreeNodeCollection instance.
Top

Public Properties

 | Name | Description
Public Property | Count | Gets the total number of elements in the collection. (Inherited from BaseCollection)
Public Property | ImageIndex |
Public Property | IsReadOnly | Gets a value indicating whether the collection is read-only. (Inherited from BaseCollection)
Public Property | IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized. (Inherited from BaseCollection)
Public Property | Item | Returns the node at this index
Public Property | SyncRoot | Gets an object that can be used to synchronize access to the BaseCollection. (Inherited from BaseCollection)
Top

Protected Properties

 | Name | Description
Protected Property | List | Overridden.
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Adds the specified tree view node.
Public Method | AddRange |
Public Method | Clear | Clear the node collection
Public Method | ContainsKey | Determines whether the collection contains a tree node with the specified key.
Public Method | CopyTo |
Public Method | GetEnumerator | Gets the object that enables iterating through the members of the collection. (Inherited from BaseCollection)
Public Method | IndexOfKey | Returns the index of the first occurrence of a tree node with the specified key.
Public Method | Insert | Insert the specified tree view node.
Public Method | Remove | Removes the specified tree view node.
Public Method | RemoveAt | Removes the current tree node from the tree view control at a specified index.
Public Method | RemoveByKey | Removes the tree node with the specified key from the collection.
Top

Public Events

 | Name | Description
Public Event | ObservableItemAdded |
Public Event | ObservableItemInserted |
Public Event | ObservableItemRemoved |
Public Event | ObservableListCleared |
Top

See Also

Reference

TreeNodeCollection Class
Gizmox.WebGUI.Forms Namespace


TreeNodeCollection Constructor

[image]
Gizmox.WebGUI.Forms
TreeNodeCollection Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNodeCollection Class : TreeNodeCollection Constructor

objParent
Obj parent.
Creates a new TreeNodeCollection instance.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal objParent As Component _
)
Visual Basic (Usage) Copy Code
Dim objParent As Component

Dim instance As TreeNodeCollection(objParent)
C#
public TreeNodeCollection(
   Component objParent
)
Managed Extensions for C++
public: TreeNodeCollection(
   Component* objParent
)
C++/CLI
public:
TreeNodeCollection(
   Component^ objParent
)

Parameters

objParent
Obj parent.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNodeCollection Class
TreeNodeCollection Members


TreeNodeCollection Class Methods

[image]
Gizmox.WebGUI.Forms
TreeNodeCollection Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TreeNodeCollection Class

For a list of all members of this type, see TreeNodeCollection members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Adds the specified tree view node.
Public Method | AddRange |
Public Method | Clear | Clear the node collection
Public Method | ContainsKey | Determines whether the collection contains a tree node with the specified key.
Public Method | CopyTo |
Public Method | GetEnumerator | Gets the object that enables iterating through the members of the collection. (Inherited from BaseCollection)
Public Method | IndexOfKey | Returns the index of the first occurrence of a tree node with the specified key.
Public Method | Insert | Insert the specified tree view node.
Public Method | Remove | Removes the specified tree view node.
Public Method | RemoveAt | Removes the current tree node from the tree view control at a specified index.
Public Method | RemoveByKey | Removes the tree node with the specified key from the collection.
Top

See Also

Reference

TreeNodeCollection Class
Gizmox.WebGUI.Forms Namespace


Add Method

[image]
Gizmox.WebGUI.Forms
Add Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNodeCollection Class : Add Method

Adds the specified tree view node.

Overload List

Overload | Description
Add(TreeNode) | Adds the specified tree view node.
Add(String) | Adds a new tree node to the end of the current tree node collection with the specified label text.
Add(String,String) | Creates a new tree node with the specified key and text, and adds it to the collection.
Add(String,String,Int32) | Creates a tree node with the specified key, text, and image, and adds it to the collection.
Add(String,String,String) | Creates a tree node with the specified key, text, and image, and adds it to the collection.
Add(String,String,Int32,Int32) | Creates a tree node with the specified key, text, and images, and adds it to the collection
Add(String,String,String,String) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNodeCollection Class
TreeNodeCollection Members


Add(TreeNode) Method

[image]
Gizmox.WebGUI.Forms
Add(TreeNode) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNodeCollection Class > Add Method : Add(TreeNode) Method

objTreeViewNode
Obj tree view node.
Adds the specified tree view node.

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal objTreeViewNode As TreeNode _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As TreeNodeCollection
Dim objTreeViewNode As TreeNode
Dim value As Integer

value = instance.Add(objTreeViewNode)
C#
public int Add(
   TreeNode objTreeViewNode
)
Managed Extensions for C++
public: int Add(
   TreeNode* objTreeViewNode
)
C++/CLI
public:
int Add(
   TreeNode^ objTreeViewNode
)

Parameters

objTreeViewNode
Obj tree view node.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNodeCollection Class
TreeNodeCollection Members
Overload List


Add(String) Method

[image]
Gizmox.WebGUI.Forms
Add(String) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNodeCollection Class > Add Method : Add(String) Method

strText
The label text displayed by the TreeNode .
Adds a new tree node to the end of the current tree node collection with the specified label text.

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal strText As String _
) As TreeNode
Visual Basic (Usage) Copy Code
Dim instance As TreeNodeCollection
Dim strText As String
Dim value As TreeNode

value = instance.Add(strText)
C#
public TreeNode Add(
   string strText
)
Managed Extensions for C++
public: TreeNode* Add(
   string* strText
)
C++/CLI
public:
TreeNode^ Add(
   String^ strText
)

Parameters

strText
The label text displayed by the TreeNode .

Return Value

A TreeNode that represents the tree node being added to the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNodeCollection Class
TreeNodeCollection Members
Overload List


Add(String,String) Method

[image]
Gizmox.WebGUI.Forms
Add(String,String) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNodeCollection Class > Add Method : Add(String,String) Method

key
The name of the tree node.
strText
The text to display in the tree node.
Creates a new tree node with the specified key and text, and adds it to the collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal key As String, _
   ByVal strText As String _
) As TreeNode
Visual Basic (Usage) Copy Code
Dim instance As TreeNodeCollection
Dim key As String
Dim strText As String
Dim value As TreeNode

value = instance.Add(key, strText)
C#
public TreeNode Add(
   string key,
   string strText
)
Managed Extensions for C++
public: TreeNode* Add(
   string* key,
   string* strText
)
C++/CLI
public:
TreeNode^ Add(
   String^ key,
   String^ strText
)

Parameters

key
The name of the tree node.
strText
The text to display in the tree node.

Return Value

The TreeNode that was added to the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNodeCollection Class
TreeNodeCollection Members
Overload List


Add(String,String,Int32) Method

[image]
Gizmox.WebGUI.Forms
Add(String,String,Int32) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNodeCollection Class > Add Method : Add(String,String,Int32) Method

key
The name of the tree node.
strText
The text to display in the tree node.
imageIndex
The index of the image to display in the tree node.
Creates a tree node with the specified key, text, and image, and adds it to the collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal key As String, _
   ByVal strText As String, _
   ByVal imageIndex As Integer _
) As TreeNode
Visual Basic (Usage) Copy Code
Dim instance As TreeNodeCollection
Dim key As String
Dim strText As String
Dim imageIndex As Integer
Dim value As TreeNode

value = instance.Add(key, strText, imageIndex)
C#
public TreeNode Add(
   string key,
   string strText,
   int imageIndex
)
Managed Extensions for C++
public: TreeNode* Add(
   string* key,
   string* strText,
   int imageIndex
)
C++/CLI
public:
TreeNode^ Add(
   String^ key,
   String^ strText,
   int imageIndex
)

Parameters

key
The name of the tree node.
strText
The text to display in the tree node.
imageIndex
The index of the image to display in the tree node.

Return Value

The TreeNode that was added to the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNodeCollection Class
TreeNodeCollection Members
Overload List


Add(String,String,String) Method

[image]
Gizmox.WebGUI.Forms
Add(String,String,String) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNodeCollection Class > Add Method : Add(String,String,String) Method

key
The name of the tree node.
strText
The text to display in the tree node.
imageKey
The image to display in the tree node.
Creates a tree node with the specified key, text, and image, and adds it to the collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal key As String, _
   ByVal strText As String, _
   ByVal imageKey As String _
) As TreeNode
Visual Basic (Usage) Copy Code
Dim instance As TreeNodeCollection
Dim key As String
Dim strText As String
Dim imageKey As String
Dim value As TreeNode

value = instance.Add(key, strText, imageKey)
C#
public TreeNode Add(
   string key,
   string strText,
   string imageKey
)
Managed Extensions for C++
public: TreeNode* Add(
   string* key,
   string* strText,
   string* imageKey
)
C++/CLI
public:
TreeNode^ Add(
   String^ key,
   String^ strText,
   String^ imageKey
)

Parameters

key
The name of the tree node.
strText
The text to display in the tree node.
imageKey
The image to display in the tree node.

Return Value

The TreeNode that was added to the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNodeCollection Class
TreeNodeCollection Members
Overload List


Add(String,String,Int32,Int32) Method

[image]
Gizmox.WebGUI.Forms
Add(String,String,Int32,Int32) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNodeCollection Class > Add Method : Add(String,String,Int32,Int32) Method

key
The name of the tree node.
strText
The text to display in the tree node.
imageIndex
The index of the image to display in the tree node.
selectedImageIndex
The index of the image to be displayed in the tree node when it is in a selected state.
Creates a tree node with the specified key, text, and images, and adds it to the collection

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal key As String, _
   ByVal strText As String, _
   ByVal imageIndex As Integer, _
   ByVal selectedImageIndex As Integer _
) As TreeNode
Visual Basic (Usage) Copy Code
Dim instance As TreeNodeCollection
Dim key As String
Dim strText As String
Dim imageIndex As Integer
Dim selectedImageIndex As Integer
Dim value As TreeNode

value = instance.Add(key, strText, imageIndex, selectedImageIndex)
C#
public TreeNode Add(
   string key,
   string strText,
   int imageIndex,
   int selectedImageIndex
)
Managed Extensions for C++
public: TreeNode* Add(
   string* key,
   string* strText,
   int imageIndex,
   int selectedImageIndex
)
C++/CLI
public:
TreeNode^ Add(
   String^ key,
   String^ strText,
   int imageIndex,
   int selectedImageIndex
)

Parameters

key
The name of the tree node.
strText
The text to display in the tree node.
imageIndex
The index of the image to display in the tree node.
selectedImageIndex
The index of the image to be displayed in the tree node when it is in a selected state.

Return Value

The TreeNode that was added to the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNodeCollection Class
TreeNodeCollection Members
Overload List


Add(String,String,String,String) Method

[image]
Gizmox.WebGUI.Forms
Add(String,String,String,String) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNodeCollection Class > Add Method : Add(String,String,String,String) Method

key
The name of the tree node.
strText
The text to display in the tree node.
imageKey
The key of the image to display in the tree node.
selectedImageKey
The key of the image to display when the node is in a selected state.

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal key As String, _
   ByVal strText As String, _
   ByVal imageKey As String, _
   ByVal selectedImageKey As String _
) As TreeNode
Visual Basic (Usage) Copy Code
Dim instance As TreeNodeCollection
Dim key As String
Dim strText As String
Dim imageKey As String
Dim selectedImageKey As String
Dim value As TreeNode

value = instance.Add(key, strText, imageKey, selectedImageKey)
C#
public TreeNode Add(
   string key,
   string strText,
   string imageKey,
   string selectedImageKey
)
Managed Extensions for C++
public: TreeNode* Add(
   string* key,
   string* strText,
   string* imageKey,
   string* selectedImageKey
)
C++/CLI
public:
TreeNode^ Add(
   String^ key,
   String^ strText,
   String^ imageKey,
   String^ selectedImageKey
)

Parameters

key
The name of the tree node.
strText
The text to display in the tree node.
imageKey
The key of the image to display in the tree node.
selectedImageKey
The key of the image to display when the node is in a selected state.

Return Value

The TreeNode that was added to the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNodeCollection Class
TreeNodeCollection Members
Overload List


AddRange Method

[image]
Gizmox.WebGUI.Forms
AddRange Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNodeCollection Class : AddRange Method

objTreeViewNodes

Syntax

Visual Basic (Declaration)
Public Sub AddRange( _
   ByVal objTreeViewNodes() As TreeNode _
)
Visual Basic (Usage) Copy Code
Dim instance As TreeNodeCollection
Dim objTreeViewNodes() As TreeNode

instance.AddRange(objTreeViewNodes)
C#
public void AddRange(
   TreeNode[] objTreeViewNodes
)
Managed Extensions for C++
public: void AddRange(
   TreeNode*[]* objTreeViewNodes
)
C++/CLI
public:
void AddRange(
   array<TreeNode^>^ objTreeViewNodes
)

Parameters

objTreeViewNodes

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNodeCollection Class
TreeNodeCollection Members


Clear Method

[image]
Gizmox.WebGUI.Forms
Clear Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNodeCollection Class : Clear Method

Clear the node collection

Syntax

Visual Basic (Declaration)
Public Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As TreeNodeCollection

instance.Clear()
C#
public void Clear()
Managed Extensions for C++
public: void Clear();
C++/CLI
public:
void Clear();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNodeCollection Class
TreeNodeCollection Members


ContainsKey Method

[image]
Gizmox.WebGUI.Forms
ContainsKey Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNodeCollection Class : ContainsKey Method

key
Determines whether the collection contains a tree node with the specified key.

Syntax

Visual Basic (Declaration)
Public Function ContainsKey( _
   ByVal key As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TreeNodeCollection
Dim key As String
Dim value As Boolean

value = instance.ContainsKey(key)
C#
public bool ContainsKey(
   string key
)
Managed Extensions for C++
public: bool ContainsKey(
   string* key
)
C++/CLI
public:
bool ContainsKey(
   String^ key
)

Parameters

key

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNodeCollection Class
TreeNodeCollection Members


CopyTo Method

[image]
Gizmox.WebGUI.Forms
CopyTo Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNodeCollection Class : CopyTo Method

objArray
intIndex

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal objArray As Array, _
   ByVal intIndex As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As TreeNodeCollection
Dim objArray As Array
Dim intIndex As Integer

instance.CopyTo(objArray, intIndex)
C#
public void CopyTo(
   Array objArray,
   int intIndex
)
Managed Extensions for C++
public: void CopyTo(
   Array* objArray,
   int intIndex
)
C++/CLI
public:
void CopyTo(
   Array^ objArray,
   int intIndex
)

Parameters

objArray
intIndex

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNodeCollection Class
TreeNodeCollection Members


IndexOfKey Method

[image]
Gizmox.WebGUI.Forms
IndexOfKey Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNodeCollection Class : IndexOfKey Method

key
Returns the index of the first occurrence of a tree node with the specified key.

Syntax

Visual Basic (Declaration)
Public Function IndexOfKey( _
   ByVal key As String _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As TreeNodeCollection
Dim key As String
Dim value As Integer

value = instance.IndexOfKey(key)
C#
public int IndexOfKey(
   string key
)
Managed Extensions for C++
public: int IndexOfKey(
   string* key
)
C++/CLI
public:
int IndexOfKey(
   String^ key
)

Parameters

key

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNodeCollection Class
TreeNodeCollection Members


Insert Method

[image]
Gizmox.WebGUI.Forms
Insert Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNodeCollection Class : Insert Method

index
objTreeViewNode
Insert the specified tree view node.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal objTreeViewNode As TreeNode _
)
Visual Basic (Usage) Copy Code
Dim instance As TreeNodeCollection
Dim index As Integer
Dim objTreeViewNode As TreeNode

instance.Insert(index, objTreeViewNode)
C#
public void Insert(
   int index,
   TreeNode objTreeViewNode
)
Managed Extensions for C++
public: void Insert(
   int index,
   TreeNode* objTreeViewNode
)
C++/CLI
public:
void Insert(
   int index,
   TreeNode^ objTreeViewNode
)

Parameters

index
objTreeViewNode

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNodeCollection Class
TreeNodeCollection Members


Remove Method

[image]
Gizmox.WebGUI.Forms
Remove Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNodeCollection Class : Remove Method

objTreeViewNode
Obj tree view node.
Removes the specified tree view node.

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal objTreeViewNode As TreeNode _
)
Visual Basic (Usage) Copy Code
Dim instance As TreeNodeCollection
Dim objTreeViewNode As TreeNode

instance.Remove(objTreeViewNode)
C#
public void Remove(
   TreeNode objTreeViewNode
)
Managed Extensions for C++
public: void Remove(
   TreeNode* objTreeViewNode
)
C++/CLI
public:
void Remove(
   TreeNode^ objTreeViewNode
)

Parameters

objTreeViewNode
Obj tree view node.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNodeCollection Class
TreeNodeCollection Members


RemoveAt Method

[image]
Gizmox.WebGUI.Forms
RemoveAt Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNodeCollection Class : RemoveAt Method

index
Removes the current tree node from the tree view control at a specified index.

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As TreeNodeCollection
Dim index As Integer

instance.RemoveAt(index)
C#
public void RemoveAt(
   int index
)
Managed Extensions for C++
public: void RemoveAt(
   int index
)
C++/CLI
public:
void RemoveAt(
   int index
)

Parameters

index

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNodeCollection Class
TreeNodeCollection Members


RemoveByKey Method

[image]
Gizmox.WebGUI.Forms
RemoveByKey Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNodeCollection Class : RemoveByKey Method

key
Removes the tree node with the specified key from the collection.

Syntax

Visual Basic (Declaration)
Public Sub RemoveByKey( _
   ByVal key As String _
)
Visual Basic (Usage) Copy Code
Dim instance As TreeNodeCollection
Dim key As String

instance.RemoveByKey(key)
C#
public void RemoveByKey(
   string key
)
Managed Extensions for C++
public: void RemoveByKey(
   string* key
)
C++/CLI
public:
void RemoveByKey(
   String^ key
)

Parameters

key

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNodeCollection Class
TreeNodeCollection Members


TreeNodeCollection Class Properties

[image]
Gizmox.WebGUI.Forms
TreeNodeCollection Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TreeNodeCollection Class

For a list of all members of this type, see TreeNodeCollection members.

Public Properties

 | Name | Description
Public Property | Count | Gets the total number of elements in the collection. (Inherited from BaseCollection)
Public Property | ImageIndex |
Public Property | IsReadOnly | Gets a value indicating whether the collection is read-only. (Inherited from BaseCollection)
Public Property | IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized. (Inherited from BaseCollection)
Public Property | Item | Returns the node at this index
Public Property | SyncRoot | Gets an object that can be used to synchronize access to the BaseCollection. (Inherited from BaseCollection)
Top

Protected Properties

 | Name | Description
Protected Property | List | Overridden.
Top

See Also

Reference

TreeNodeCollection Class
Gizmox.WebGUI.Forms Namespace


ImageIndex Property

[image]
Gizmox.WebGUI.Forms
ImageIndex Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNodeCollection Class : ImageIndex Property

Syntax

Visual Basic (Declaration)
Public Property ImageIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As TreeNodeCollection
Dim value As Integer

instance.ImageIndex = value

value = instance.ImageIndex
C#
public int ImageIndex {get; set;}
Managed Extensions for C++
public: __property int get_ImageIndex();
public: __property void set_ImageIndex(
   int value
);
C++/CLI
public:
property int ImageIndex {
   int get();
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNodeCollection Class
TreeNodeCollection Members


Item Property

[image]
Gizmox.WebGUI.Forms
Item Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNodeCollection Class : Item Property

intIndex
Returns the node at this index

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal intIndex As Integer _
) As TreeNode
Visual Basic (Usage) Copy Code
Dim instance As TreeNodeCollection
Dim intIndex As Integer
Dim value As TreeNode

value = instance.Item(intIndex)
C#
public TreeNode this[
   int intIndex
]; {get;}
Managed Extensions for C++
public: __property TreeNode* get_Item(
   int intIndex
);
C++/CLI
public:
property TreeNode^ default [int] {
   TreeNode^ get(intintIndex);
}

Parameters

intIndex

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNodeCollection Class
TreeNodeCollection Members


List Property

[image]
Gizmox.WebGUI.Forms
List Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNodeCollection Class : List Property

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property List As ArrayList
Visual Basic (Usage) Copy Code
Dim instance As TreeNodeCollection
Dim value As ArrayList

value = instance.List
C#
protected override ArrayList List {get;}
Managed Extensions for C++
protected: __property ArrayList* get_List() override;
C++/CLI
protected:
property ArrayList^ List {
   ArrayList^ get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNodeCollection Class
TreeNodeCollection Members


TreeNodeCollection Class Events

[image]
Gizmox.WebGUI.Forms
TreeNodeCollection Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TreeNodeCollection Class

For a list of all members of this type, see TreeNodeCollection members.

Public Events

 | Name | Description
Public Event | ObservableItemAdded |
Public Event | ObservableItemInserted |
Public Event | ObservableItemRemoved |
Public Event | ObservableListCleared |
Top

See Also

Reference

TreeNodeCollection Class
Gizmox.WebGUI.Forms Namespace


ObservableItemAdded Event

[image]
Gizmox.WebGUI.Forms
ObservableItemAdded Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNodeCollection Class : ObservableItemAdded Event

Syntax

Visual Basic (Declaration)
Public Event ObservableItemAdded() As ObservableListEventHandler
Visual Basic (Usage) Copy Code
Dim instance As TreeNodeCollection
Dim handler As ObservableListEventHandler

AddHandler instance.ObservableItemAdded, handler
C#
public event ObservableListEventHandler ObservableItemAdded()
Managed Extensions for C++
public: __event ObservableListEventHandler* ObservableItemAdded
C++/CLI
public:
event ObservableListEventHandler^ ObservableItemAdded

Event Data

The event handler receives an argument of type ObservableListEventArgs containing data related to this event. The following ObservableListEventArgs properties provide information specific to this event.

Property | Description
Item |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNodeCollection Class
TreeNodeCollection Members


ObservableItemInserted Event

[image]
Gizmox.WebGUI.Forms
ObservableItemInserted Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNodeCollection Class : ObservableItemInserted Event

Syntax

Visual Basic (Declaration)
Public Event ObservableItemInserted() As ObservableListEventHandler
Visual Basic (Usage) Copy Code
Dim instance As TreeNodeCollection
Dim handler As ObservableListEventHandler

AddHandler instance.ObservableItemInserted, handler
C#
public event ObservableListEventHandler ObservableItemInserted()
Managed Extensions for C++
public: __event ObservableListEventHandler* ObservableItemInserted
C++/CLI
public:
event ObservableListEventHandler^ ObservableItemInserted

Event Data

The event handler receives an argument of type ObservableListEventArgs containing data related to this event. The following ObservableListEventArgs properties provide information specific to this event.

Property | Description
Item |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNodeCollection Class
TreeNodeCollection Members


ObservableItemRemoved Event

[image]
Gizmox.WebGUI.Forms
ObservableItemRemoved Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNodeCollection Class : ObservableItemRemoved Event

Syntax

Visual Basic (Declaration)
Public Event ObservableItemRemoved() As ObservableListEventHandler
Visual Basic (Usage) Copy Code
Dim instance As TreeNodeCollection
Dim handler As ObservableListEventHandler

AddHandler instance.ObservableItemRemoved, handler
C#
public event ObservableListEventHandler ObservableItemRemoved()
Managed Extensions for C++
public: __event ObservableListEventHandler* ObservableItemRemoved
C++/CLI
public:
event ObservableListEventHandler^ ObservableItemRemoved

Event Data

The event handler receives an argument of type ObservableListEventArgs containing data related to this event. The following ObservableListEventArgs properties provide information specific to this event.

Property | Description
Item |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNodeCollection Class
TreeNodeCollection Members


ObservableListCleared Event

[image]
Gizmox.WebGUI.Forms
ObservableListCleared Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNodeCollection Class : ObservableListCleared Event

Syntax

Visual Basic (Declaration)
Public Event ObservableListCleared() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As TreeNodeCollection
Dim handler As EventHandler

AddHandler instance.ObservableListCleared, handler
C#
public event EventHandler ObservableListCleared()
Managed Extensions for C++
public: __event EventHandler* ObservableListCleared
C++/CLI
public:
event EventHandler^ ObservableListCleared

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNodeCollection Class
TreeNodeCollection Members


TreeNodeMouseClickEventArgs Class

[image]
Gizmox.WebGUI.Forms
TreeNodeMouseClickEventArgs Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TreeNodeMouseClickEventArgs Class

Provides data for the TreeView.NodeMouseClick and TreeView.NodeMouseDoubleClick events.

Object Model

Syntax

Visual Basic (Declaration)
Public Class TreeNodeMouseClickEventArgs
   Inherits MouseEventArgs
Visual Basic (Usage) Copy Code
Dim instance As TreeNodeMouseClickEventArgs
C#
public class TreeNodeMouseClickEventArgs : MouseEventArgs
Managed Extensions for C++
public __gc class TreeNodeMouseClickEventArgs : public MouseEventArgs
C++/CLI
public ref class TreeNodeMouseClickEventArgs : public MouseEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gizmox.WebGUI.Forms.MouseEventArgs
Gizmox.WebGUI.Forms.TreeNodeMouseClickEventArgs

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

TreeNodeMouseClickEventArgs Members
Gizmox.WebGUI.Forms Namespace


TreeNodeMouseClickEventArgs Class Members

[image]
Gizmox.WebGUI.Forms
TreeNodeMouseClickEventArgs Class Members
See Also Properties Send Feedback
Gizmox.WebGUI.Forms Namespace : TreeNodeMouseClickEventArgs Class

The following tables list the members exposed by TreeNodeMouseClickEventArgs.

Public Constructors

 | Name | Description
Public Constructor | TreeNodeMouseClickEventArgs Constructor | Initializes a new instance of the TreeNodeMouseClickEventArgs class.
Top

Public Properties

 | Name | Description
Public Property | Button | (Inherited from MouseEventArgs)
Public Property | Clicks | (Inherited from MouseEventArgs)
Public Property | Delta | (Inherited from MouseEventArgs)
Public Property | Node | Gets the node that was clicked.
Public Property | X | (Inherited from MouseEventArgs)
Public Property | Y | (Inherited from MouseEventArgs)
Top

See Also

Reference

TreeNodeMouseClickEventArgs Class
Gizmox.WebGUI.Forms Namespace


TreeNodeMouseClickEventArgs Constructor

[image]
Gizmox.WebGUI.Forms
TreeNodeMouseClickEventArgs Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNodeMouseClickEventArgs Class : TreeNodeMouseClickEventArgs Constructor

objNode
The node that was clicked.
objButton
One of the MouseButtons members.
intClicks
The number of clicks that occurred.
intX
The x-coordinate where the click occurred.
intY
The y-coordinate where the click occurred.
Initializes a new instance of the TreeNodeMouseClickEventArgs class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal objNode As TreeNode, _
   ByVal objButton As MouseButtons, _
   ByVal intClicks As Integer, _
   ByVal intX As Integer, _
   ByVal intY As Integer _
)
Visual Basic (Usage) Copy Code
Dim objNode As TreeNode
Dim objButton As MouseButtons
Dim intClicks As Integer
Dim intX As Integer
Dim intY As Integer

Dim instance As TreeNodeMouseClickEventArgs(objNode, objButton, intClicks, intX, intY)
C#
public TreeNodeMouseClickEventArgs(
   TreeNode objNode,
   MouseButtons objButton,
   int intClicks,
   int intX,
   int intY
)
Managed Extensions for C++
public: TreeNodeMouseClickEventArgs(
   TreeNode* objNode,
   MouseButtons objButton,
   int intClicks,
   int intX,
   int intY
)
C++/CLI
public:
TreeNodeMouseClickEventArgs(
   TreeNode^ objNode,
   MouseButtons objButton,
   int intClicks,
   int intX,
   int intY
)

Parameters

objNode
The node that was clicked.
objButton
One of the MouseButtons members.
intClicks
The number of clicks that occurred.
intX
The x-coordinate where the click occurred.
intY
The y-coordinate where the click occurred.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNodeMouseClickEventArgs Class
TreeNodeMouseClickEventArgs Members


TreeNodeMouseClickEventArgs Class Properties

[image]
Gizmox.WebGUI.Forms
TreeNodeMouseClickEventArgs Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TreeNodeMouseClickEventArgs Class

For a list of all members of this type, see TreeNodeMouseClickEventArgs members.

Public Properties

 | Name | Description
Public Property | Button | (Inherited from MouseEventArgs)
Public Property | Clicks | (Inherited from MouseEventArgs)
Public Property | Delta | (Inherited from MouseEventArgs)
Public Property | Node | Gets the node that was clicked.
Public Property | X | (Inherited from MouseEventArgs)
Public Property | Y | (Inherited from MouseEventArgs)
Top

See Also

Reference

TreeNodeMouseClickEventArgs Class
Gizmox.WebGUI.Forms Namespace


Node Property

[image]
Gizmox.WebGUI.Forms
Node Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeNodeMouseClickEventArgs Class : Node Property

Gets the node that was clicked.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Node As TreeNode
Visual Basic (Usage) Copy Code
Dim instance As TreeNodeMouseClickEventArgs
Dim value As TreeNode

value = instance.Node
C#
public TreeNode Node {get;}
Managed Extensions for C++
public: __property TreeNode* get_Node();
C++/CLI
public:
property TreeNode^ Node {
   TreeNode^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeNodeMouseClickEventArgs Class
TreeNodeMouseClickEventArgs Members


TreeView Class

[image]
Gizmox.WebGUI.Forms
TreeView Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TreeView Class

Summary description for TreeView.

Object Model

Syntax

Visual Basic (Declaration)
<SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableTreeView, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")>
<ToolboxItemCategoryAttribute("Common Controls")>
<DesignTimeControllerAttribute()>
<DefaultEventAttribute("AfterSelect")>
<ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<ClientControllerAttribute()>
<ToolboxBitmapAttribute()>
<MetadataTagAttribute("TV")>
Public Class TreeView
   Inherits Control
   Implements IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Visual Basic (Usage) Copy Code
Dim instance As TreeView
C#
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableTreeView, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[ToolboxItemCategoryAttribute("Common Controls")]
[DesignTimeControllerAttribute()]
[DefaultEventAttribute("AfterSelect")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ClientControllerAttribute()]
[ToolboxBitmapAttribute()]
[MetadataTagAttribute("TV")]
public class TreeView : Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Managed Extensions for C++
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableTreeView, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[ToolboxItemCategoryAttribute("Common Controls")]
[DesignTimeControllerAttribute()]
[DefaultEventAttribute("AfterSelect")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ClientControllerAttribute()]
[ToolboxBitmapAttribute()]
[MetadataTagAttribute("TV")]
public __gc class TreeView : public Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
C++/CLI
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableTreeView, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[ToolboxItemCategoryAttribute("Common Controls")]
[DesignTimeControllerAttribute()]
[DefaultEventAttribute("AfterSelect")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ClientControllerAttribute()]
[ToolboxBitmapAttribute()]
[MetadataTagAttribute("TV")]
public ref class TreeView : public Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.TreeView

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

TreeView Members
Gizmox.WebGUI.Forms Namespace


TreeView Class Members

[image]
Gizmox.WebGUI.Forms
TreeView Class Members
See Also Fields Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : TreeView Class

The following tables list the members exposed by TreeView.

Public Constructors

 | Name | Description
Public Constructor | TreeView Constructor | Creates a new TreeView instance.
Top

Protected Fields

 | Name | Description
Protected Field | mblnLabelEdit | Indicates if label editing is enabled.
Top

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Overridden. Gets a value indicating whether this instance can focus.
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | CheckBoxes | Gets or sets a value indicating whether check boxes are displayed.
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | HideSelection |
Public Property | ImageIndex | Gets or sets the index of the image that is displayed for the item.
Public Property | ImageKey | Gets or sets the key for the image that is displayed for the item.
Public Property | ImageList |
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | LabelEdit | Gets or sets a value indicating whether the label text of the tree nodes can be edited.
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Nodes | Gets the collection of tree nodes that are assigned to the tree view control.
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PathSeparator |
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | SelectedImageIndex |
Public Property | SelectedNode | Gets or sets the selected node.
Public Property | ShowLines | Gets or sets a value indicating whether to show lines.
Public Property | ShowPlusMinus | Gets or sets a value indicating whether to show plus minus.
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Control)
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | TreeViewNodeSorter | Gets or sets the implementation of IComparer to perform a custom sort of the TreeView nodes.
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | Overridden. Gets the default color of the back ground.
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | Overridden.
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | Overridden.
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

Public Methods

 | Name | Description
Public Method | BeginUpdate | Disables any redrawing of the tree view.
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | CollapseAll | Collapses all the tree nodes.
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | EndUpdate | Enables the redrawing of the tree view.
Public Method | ExpandAll | Expands all the tree nodes.
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetNodeAt | Retrieves the tree node that is at the specified point. Not implemented
Public Method | GetNodeCount | Retrieves the number of tree nodes, optionally including those in all subtrees, assigned to the tree view control.
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | Sort | Sorts the items if the value of the TreeViewNodeSorter property is not null.
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Control)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Overridden. Gets the critical events.
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from Control)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnAfterCheck | Raises the TreeView.AfterCheck event.
Protected Method | OnAfterCollapse | Raises the TreeView.AfterCollapse event.
Protected Method | OnAfterExpand | Raises the TreeView.AfterExpand event.
Protected Method | OnAfterLabelEdit | Raises the AfterLabelEdit event.
Protected Method | OnAfterSelect | Raises the E:AfterSelect event.
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBeforeCheck | Raises the TreeView.BeforeCheck event.
Protected Method | OnBeforeCollapse | Raises the TreeView.BeforeCollapse event.
Protected Method | OnBeforeExpand | Raises the TreeView.BeforeExpand event.
Protected Method | OnBeforeLabelEdit | Raises the BeforeLabelEdit event.
Protected Method | OnBeforeSelect | Raises the BeforeSelect event.
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnNodeMouseClick | Raises the TreeView.NodeMouseClick event.
Protected Method | OnNodeMouseDoubleClick | Raises the TreeView.NodeMouseDoubleClick event.
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | Overridden.
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | Overridden. Renderes the tree view control
Protected Method | RenderAttributes | Overridden. Renders the controls meta attributes
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Overridden. Renders the controls sub tree
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderEditingInformation | Renders the editing information.
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

Public Events

 | Name | Description
Public Event | AfterCheck | Occurs after the tree node check box is checked.
Public Event | AfterCollapse | Occurs after the tree node is collapsed.
Public Event | AfterExpand | Occurs after the tree node is expanded.
Public Event | AfterLabelEdit | Occurs after the tree node label text is edited.
Public Event | AfterSelect | Occurs after the tree node is selected.
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BeforeCheck | Occurs before the tree node check box is checked.
Public Event | BeforeCollapse | Occurs before the tree node is collapsed.
Public Event | BeforeExpand | Occurs before the tree node is expanded.
Public Event | BeforeLabelEdit | Occurs before the tree node label text is edited.
Public Event | BeforeSelect | Occurs before the tree node is selected.
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | NodeMouseClick | Occurs when the user clicks a TreeNode with the mouse.
Public Event | NodeMouseDoubleClick | Occurs when the user double-clicks a TreeNode with the mouse.
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

TreeView Class
Gizmox.WebGUI.Forms Namespace


TreeView Constructor

[image]
Gizmox.WebGUI.Forms
TreeView Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeView Class : TreeView Constructor

Creates a new TreeView instance.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As TreeView()
C#
public TreeView()
Managed Extensions for C++
public: TreeView();
C++/CLI
public:
TreeView();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeView Class
TreeView Members


TreeView Class Methods

[image]
Gizmox.WebGUI.Forms
TreeView Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TreeView Class

For a list of all members of this type, see TreeView members.

Public Methods

 | Name | Description
Public Method | BeginUpdate | Disables any redrawing of the tree view.
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | CollapseAll | Collapses all the tree nodes.
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | EndUpdate | Enables the redrawing of the tree view.
Public Method | ExpandAll | Expands all the tree nodes.
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetNodeAt | Retrieves the tree node that is at the specified point. Not implemented
Public Method | GetNodeCount | Retrieves the number of tree nodes, optionally including those in all subtrees, assigned to the tree view control.
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | Sort | Sorts the items if the value of the TreeViewNodeSorter property is not null.
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Control)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Overridden. Gets the critical events.
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from Control)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnAfterCheck | Raises the TreeView.AfterCheck event.
Protected Method | OnAfterCollapse | Raises the TreeView.AfterCollapse event.
Protected Method | OnAfterExpand | Raises the TreeView.AfterExpand event.
Protected Method | OnAfterLabelEdit | Raises the AfterLabelEdit event.
Protected Method | OnAfterSelect | Raises the E:AfterSelect event.
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBeforeCheck | Raises the TreeView.BeforeCheck event.
Protected Method | OnBeforeCollapse | Raises the TreeView.BeforeCollapse event.
Protected Method | OnBeforeExpand | Raises the TreeView.BeforeExpand event.
Protected Method | OnBeforeLabelEdit | Raises the BeforeLabelEdit event.
Protected Method | OnBeforeSelect | Raises the BeforeSelect event.
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnNodeMouseClick | Raises the TreeView.NodeMouseClick event.
Protected Method | OnNodeMouseDoubleClick | Raises the TreeView.NodeMouseDoubleClick event.
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | Overridden.
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | Overridden. Renderes the tree view control
Protected Method | RenderAttributes | Overridden. Renders the controls meta attributes
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Overridden. Renders the controls sub tree
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderEditingInformation | Renders the editing information.
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

See Also

Reference

TreeView Class
Gizmox.WebGUI.Forms Namespace


BeginUpdate Method

[image]
Gizmox.WebGUI.Forms
BeginUpdate Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeView Class : BeginUpdate Method

Disables any redrawing of the tree view.

Syntax

Visual Basic (Declaration)
Public Sub BeginUpdate()
Visual Basic (Usage) Copy Code
Dim instance As TreeView

instance.BeginUpdate()
C#
public void BeginUpdate()
Managed Extensions for C++
public: void BeginUpdate();
C++/CLI
public:
void BeginUpdate();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeView Class
TreeView Members


CollapseAll Method

[image]
Gizmox.WebGUI.Forms
CollapseAll Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeView Class : CollapseAll Method

Collapses all the tree nodes.

Syntax

Visual Basic (Declaration)
Public Sub CollapseAll()
Visual Basic (Usage) Copy Code
Dim instance As TreeView

instance.CollapseAll()
C#
public void CollapseAll()
Managed Extensions for C++
public: void CollapseAll();
C++/CLI
public:
void CollapseAll();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeView Class
TreeView Members


EndUpdate Method

[image]
Gizmox.WebGUI.Forms
EndUpdate Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeView Class : EndUpdate Method

Enables the redrawing of the tree view.

Syntax

Visual Basic (Declaration)
Public Sub EndUpdate()
Visual Basic (Usage) Copy Code
Dim instance As TreeView

instance.EndUpdate()
C#
public void EndUpdate()
Managed Extensions for C++
public: void EndUpdate();
C++/CLI
public:
void EndUpdate();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeView Class
TreeView Members


ExpandAll Method

[image]
Gizmox.WebGUI.Forms
ExpandAll Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeView Class : ExpandAll Method

Expands all the tree nodes.

Syntax

Visual Basic (Declaration)
Public Sub ExpandAll()
Visual Basic (Usage) Copy Code
Dim instance As TreeView

instance.ExpandAll()
C#
public void ExpandAll()
Managed Extensions for C++
public: void ExpandAll();
C++/CLI
public:
void ExpandAll();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeView Class
TreeView Members


GetCriticalEvents Method

[image]
Gizmox.WebGUI.Forms
GetCriticalEvents Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeView Class : GetCriticalEvents Method

Gets the critical events.

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetCriticalEvents() As EventTypes
Visual Basic (Usage) Copy Code
Dim instance As TreeView
Dim value As EventTypes

value = instance.GetCriticalEvents()
C#
protected override EventTypes GetCriticalEvents()
Managed Extensions for C++
protected: EventTypes GetCriticalEvents(); override
C++/CLI
protected:
EventTypes GetCriticalEvents(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeView Class
TreeView Members


GetNodeAt Method

[image]
Gizmox.WebGUI.Forms
GetNodeAt Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeView Class : GetNodeAt Method

intX
intY
Retrieves the tree node that is at the specified point. Not implemented

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("Not implemented")>
Public Function GetNodeAt( _
   ByVal intX As Integer, _
   ByVal intY As Integer _
) As TreeNode
Visual Basic (Usage) Copy Code
Dim instance As TreeView
Dim intX As Integer
Dim intY As Integer
Dim value As TreeNode

value = instance.GetNodeAt(intX, intY)
C#
[ObsoleteAttribute("Not implemented")]
public TreeNode GetNodeAt(
   int intX,
   int intY
)
Managed Extensions for C++
[ObsoleteAttribute("Not implemented")]
public: TreeNode* GetNodeAt(
   int intX,
   int intY
)
C++/CLI
[ObsoleteAttribute("Not implemented")]
public:
TreeNode^ GetNodeAt(
   int intX,
   int intY
)

Parameters

intX
intY

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeView Class
TreeView Members


GetNodeCount Method

[image]
Gizmox.WebGUI.Forms
GetNodeCount Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeView Class : GetNodeCount Method

includeSubTrees
Retrieves the number of tree nodes, optionally including those in all subtrees, assigned to the tree view control.

Syntax

Visual Basic (Declaration)
Public Function GetNodeCount( _
   ByVal includeSubTrees As Boolean _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As TreeView
Dim includeSubTrees As Boolean
Dim value As Integer

value = instance.GetNodeCount(includeSubTrees)
C#
public int GetNodeCount(
   bool includeSubTrees
)
Managed Extensions for C++
public: int GetNodeCount(
   bool includeSubTrees
)
C++/CLI
public:
int GetNodeCount(
   bool includeSubTrees
)

Parameters

includeSubTrees

Return Value

The number of tree nodes, optionally including those in all subtrees, assigned to the tree view control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeView Class
TreeView Members


OnAfterCheck Method

[image]
Gizmox.WebGUI.Forms
OnAfterCheck Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeView Class : OnAfterCheck Method

e
A TreeViewEventArgs that contains the event data.
Raises the TreeView.AfterCheck event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnAfterCheck( _
   ByVal e As TreeViewEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As TreeView
Dim e As TreeViewEventArgs

instance.OnAfterCheck(e)
C#
protected virtual void OnAfterCheck(
   TreeViewEventArgs e
)
Managed Extensions for C++
protected: virtual void OnAfterCheck(
   TreeViewEventArgs* e
)
C++/CLI
protected:
virtual void OnAfterCheck(
   TreeViewEventArgs^ e
)

Parameters

e
A TreeViewEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeView Class
TreeView Members


OnAfterCollapse Method

[image]
Gizmox.WebGUI.Forms
OnAfterCollapse Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeView Class : OnAfterCollapse Method

e
A TreeViewEventArgs that contains the event data.
Raises the TreeView.AfterCollapse event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnAfterCollapse( _
   ByVal e As TreeViewEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As TreeView
Dim e As TreeViewEventArgs

instance.OnAfterCollapse(e)
C#
protected virtual void OnAfterCollapse(
   TreeViewEventArgs e
)
Managed Extensions for C++
protected: virtual void OnAfterCollapse(
   TreeViewEventArgs* e
)
C++/CLI
protected:
virtual void OnAfterCollapse(
   TreeViewEventArgs^ e
)

Parameters

e
A TreeViewEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeView Class
TreeView Members


OnAfterExpand Method

[image]
Gizmox.WebGUI.Forms
OnAfterExpand Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeView Class : OnAfterExpand Method

e
A TreeViewEventArgs that contains the event data.
Raises the TreeView.AfterExpand event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnAfterExpand( _
   ByVal e As TreeViewEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As TreeView
Dim e As TreeViewEventArgs

instance.OnAfterExpand(e)
C#
protected virtual void OnAfterExpand(
   TreeViewEventArgs e
)
Managed Extensions for C++
protected: virtual void OnAfterExpand(
   TreeViewEventArgs* e
)
C++/CLI
protected:
virtual void OnAfterExpand(
   TreeViewEventArgs^ e
)

Parameters

e
A TreeViewEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeView Class
TreeView Members


OnAfterLabelEdit Method

[image]
Gizmox.WebGUI.Forms
OnAfterLabelEdit Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeView Class : OnAfterLabelEdit Method

e
A NodeLabelEditEventArgs that contains the event data.
Raises the AfterLabelEdit event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnAfterLabelEdit( _
   ByVal e As NodeLabelEditEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As TreeView
Dim e As NodeLabelEditEventArgs

instance.OnAfterLabelEdit(e)
C#
protected virtual void OnAfterLabelEdit(
   NodeLabelEditEventArgs e
)
Managed Extensions for C++
protected: virtual void OnAfterLabelEdit(
   NodeLabelEditEventArgs* e
)
C++/CLI
protected:
virtual void OnAfterLabelEdit(
   NodeLabelEditEventArgs^ e
)

Parameters

e
A NodeLabelEditEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeView Class
TreeView Members


OnAfterSelect Method

[image]
Gizmox.WebGUI.Forms
OnAfterSelect Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeView Class : OnAfterSelect Method

e
The TreeViewEventArgs instance containing the event data.
Raises the E:AfterSelect event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnAfterSelect( _
   ByVal e As TreeViewEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As TreeView
Dim e As TreeViewEventArgs

instance.OnAfterSelect(e)
C#
protected virtual void OnAfterSelect(
   TreeViewEventArgs e
)
Managed Extensions for C++
protected: virtual void OnAfterSelect(
   TreeViewEventArgs* e
)
C++/CLI
protected:
virtual void OnAfterSelect(
   TreeViewEventArgs^ e
)

Parameters

e
The TreeViewEventArgs instance containing the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeView Class
TreeView Members


OnBeforeCheck Method

[image]
Gizmox.WebGUI.Forms
OnBeforeCheck Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeView Class : OnBeforeCheck Method

e
A TreeViewCancelEventArgs that contains the event data.
Raises the TreeView.BeforeCheck event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnBeforeCheck( _
   ByVal e As TreeViewCancelEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As TreeView
Dim e As TreeViewCancelEventArgs

instance.OnBeforeCheck(e)
C#
protected virtual void OnBeforeCheck(
   TreeViewCancelEventArgs e
)
Managed Extensions for C++
protected: virtual void OnBeforeCheck(
   TreeViewCancelEventArgs* e
)
C++/CLI
protected:
virtual void OnBeforeCheck(
   TreeViewCancelEventArgs^ e
)

Parameters

e
A TreeViewCancelEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeView Class
TreeView Members


OnBeforeCollapse Method

[image]
Gizmox.WebGUI.Forms
OnBeforeCollapse Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeView Class : OnBeforeCollapse Method

e
A TreeViewCancelEventArgs that contains the event data.
Raises the TreeView.BeforeCollapse event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnBeforeCollapse( _
   ByVal e As TreeViewCancelEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As TreeView
Dim e As TreeViewCancelEventArgs

instance.OnBeforeCollapse(e)
C#
protected virtual void OnBeforeCollapse(
   TreeViewCancelEventArgs e
)
Managed Extensions for C++
protected: virtual void OnBeforeCollapse(
   TreeViewCancelEventArgs* e
)
C++/CLI
protected:
virtual void OnBeforeCollapse(
   TreeViewCancelEventArgs^ e
)

Parameters

e
A TreeViewCancelEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeView Class
TreeView Members


OnBeforeExpand Method

[image]
Gizmox.WebGUI.Forms
OnBeforeExpand Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeView Class : OnBeforeExpand Method

e
A TreeViewCancelEventArgs that contains the event data.
Raises the TreeView.BeforeExpand event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnBeforeExpand( _
   ByVal e As TreeViewCancelEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As TreeView
Dim e As TreeViewCancelEventArgs

instance.OnBeforeExpand(e)
C#
protected virtual void OnBeforeExpand(
   TreeViewCancelEventArgs e
)
Managed Extensions for C++
protected: virtual void OnBeforeExpand(
   TreeViewCancelEventArgs* e
)
C++/CLI
protected:
virtual void OnBeforeExpand(
   TreeViewCancelEventArgs^ e
)

Parameters

e
A TreeViewCancelEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeView Class
TreeView Members


OnBeforeLabelEdit Method

[image]
Gizmox.WebGUI.Forms
OnBeforeLabelEdit Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeView Class : OnBeforeLabelEdit Method

e
A NodeLabelEditEventArgs that contains the event data.
Raises the BeforeLabelEdit event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnBeforeLabelEdit( _
   ByVal e As NodeLabelEditEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As TreeView
Dim e As NodeLabelEditEventArgs

instance.OnBeforeLabelEdit(e)
C#
protected virtual void OnBeforeLabelEdit(
   NodeLabelEditEventArgs e
)
Managed Extensions for C++
protected: virtual void OnBeforeLabelEdit(
   NodeLabelEditEventArgs* e
)
C++/CLI
protected:
virtual void OnBeforeLabelEdit(
   NodeLabelEditEventArgs^ e
)

Parameters

e
A NodeLabelEditEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeView Class
TreeView Members


OnBeforeSelect Method

[image]
Gizmox.WebGUI.Forms
OnBeforeSelect Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeView Class : OnBeforeSelect Method

e
A TreeViewCancelEventArgs that contains the event data.
Raises the BeforeSelect event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnBeforeSelect( _
   ByVal e As TreeViewCancelEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As TreeView
Dim e As TreeViewCancelEventArgs

instance.OnBeforeSelect(e)
C#
protected virtual void OnBeforeSelect(
   TreeViewCancelEventArgs e
)
Managed Extensions for C++
protected: virtual void OnBeforeSelect(
   TreeViewCancelEventArgs* e
)
C++/CLI
protected:
virtual void OnBeforeSelect(
   TreeViewCancelEventArgs^ e
)

Parameters

e
A TreeViewCancelEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeView Class
TreeView Members


OnNodeMouseClick Method

[image]
Gizmox.WebGUI.Forms
OnNodeMouseClick Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeView Class : OnNodeMouseClick Method

e
A TreeNodeMouseClickEventArgs that contains the event data.
Raises the TreeView.NodeMouseClick event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnNodeMouseClick( _
   ByVal e As TreeNodeMouseClickEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As TreeView
Dim e As TreeNodeMouseClickEventArgs

instance.OnNodeMouseClick(e)
C#
protected virtual void OnNodeMouseClick(
   TreeNodeMouseClickEventArgs e
)
Managed Extensions for C++
protected: virtual void OnNodeMouseClick(
   TreeNodeMouseClickEventArgs* e
)
C++/CLI
protected:
virtual void OnNodeMouseClick(
   TreeNodeMouseClickEventArgs^ e
)

Parameters

e
A TreeNodeMouseClickEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeView Class
TreeView Members


OnNodeMouseDoubleClick Method

[image]
Gizmox.WebGUI.Forms
OnNodeMouseDoubleClick Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeView Class : OnNodeMouseDoubleClick Method

e
A TreeNodeMouseClickEventArgs that contains the event data.
Raises the TreeView.NodeMouseDoubleClick event.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnNodeMouseDoubleClick( _
   ByVal e As TreeNodeMouseClickEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As TreeView
Dim e As TreeNodeMouseClickEventArgs

instance.OnNodeMouseDoubleClick(e)
C#
protected virtual void OnNodeMouseDoubleClick(
   TreeNodeMouseClickEventArgs e
)
Managed Extensions for C++
protected: virtual void OnNodeMouseDoubleClick(
   TreeNodeMouseClickEventArgs* e
)
C++/CLI
protected:
virtual void OnNodeMouseDoubleClick(
   TreeNodeMouseClickEventArgs^ e
)

Parameters

e
A TreeNodeMouseClickEventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeView Class
TreeView Members


OnUnregisterComponents Method

[image]
Gizmox.WebGUI.Forms
OnUnregisterComponents Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeView Class : OnUnregisterComponents Method

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnUnregisterComponents()
Visual Basic (Usage) Copy Code
Dim instance As TreeView

instance.OnUnregisterComponents()
C#
protected override void OnUnregisterComponents()
Managed Extensions for C++
protected: void OnUnregisterComponents(); override
C++/CLI
protected:
void OnUnregisterComponents(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeView Class
TreeView Members


Render Method

[image]
Gizmox.WebGUI.Forms
Render Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeView Class : Render Method

objContext
objWriter
lngRequestID
Renderes the tree view control

Syntax

Visual Basic (Declaration)
Protected Overrides Sub Render( _
   ByVal objContext As IContext, _
   ByVal objWriter As IResponseWriter, _
   ByVal lngRequestID As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As TreeView
Dim objContext As IContext
Dim objWriter As IResponseWriter
Dim lngRequestID As Long

instance.Render(objContext, objWriter, lngRequestID)
C#
protected override void Render(
   IContext objContext,
   IResponseWriter objWriter,
   long lngRequestID
)
Managed Extensions for C++
protected: void Render(
   IContext* objContext,
   IResponseWriter* objWriter,
   long lngRequestID
) override
C++/CLI
protected:
void Render(
   IContext^ objContext,
   IResponseWriter^ objWriter,
   long long lngRequestID
) override

Parameters

objContext
objWriter
lngRequestID

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeView Class
TreeView Members


RenderAttributes Method

[image]
Gizmox.WebGUI.Forms
RenderAttributes Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeView Class : RenderAttributes Method

objContext
objWriter
Renders the controls meta attributes

Syntax

Visual Basic (Declaration)
Protected Overrides Sub RenderAttributes( _
   ByVal objContext As IContext, _
   ByVal objWriter As IAttributeWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As TreeView
Dim objContext As IContext
Dim objWriter As IAttributeWriter

instance.RenderAttributes(objContext, objWriter)
C#
protected override void RenderAttributes(
   IContext objContext,
   IAttributeWriter objWriter
)
Managed Extensions for C++
protected: void RenderAttributes(
   IContext* objContext,
   IAttributeWriter* objWriter
) override
C++/CLI
protected:
void RenderAttributes(
   IContext^ objContext,
   IAttributeWriter^ objWriter
) override

Parameters

objContext
objWriter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeView Class
TreeView Members


RenderControls Method

[image]
Gizmox.WebGUI.Forms
RenderControls Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeView Class : RenderControls Method

Renders the controls sub tree

Overload List

Overload | Description
RenderControls(IContext,IResponseWriter,Int64) |
RenderControls(IContext,IResponseWriter,Int64,Boolean) | Renders the controls sub tree (Inherited from Control)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeView Class
TreeView Members


RenderControls(IContext,IResponseWriter,Int64) Method

[image]
Gizmox.WebGUI.Forms
RenderControls(IContext,IResponseWriter,Int64) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeView Class > RenderControls Method : RenderControls(IContext,IResponseWriter,Int64) Method

objContext
Request context.
objWriter
lngRequestID

Syntax

Visual Basic (Declaration)
Protected Overloads Overrides Sub RenderControls( _
   ByVal objContext As IContext, _
   ByVal objWriter As IResponseWriter, _
   ByVal lngRequestID As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As TreeView
Dim objContext As IContext
Dim objWriter As IResponseWriter
Dim lngRequestID As Long

instance.RenderControls(objContext, objWriter, lngRequestID)
C#
protected override void RenderControls(
   IContext objContext,
   IResponseWriter objWriter,
   long lngRequestID
)
Managed Extensions for C++
protected: void RenderControls(
   IContext* objContext,
   IResponseWriter* objWriter,
   long lngRequestID
) override
C++/CLI
protected:
void RenderControls(
   IContext^ objContext,
   IResponseWriter^ objWriter,
   long long lngRequestID
) override

Parameters

objContext
Request context.
objWriter
lngRequestID

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeView Class
TreeView Members
Overload List


RenderEditingInformation Method

[image]
Gizmox.WebGUI.Forms
RenderEditingInformation Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeView Class : RenderEditingInformation Method

objContext
The obj context.
objWriter
The obj writer.
Renders the editing information.

Syntax

Visual Basic (Declaration)
Protected Sub RenderEditingInformation( _
   ByVal objContext As IContext, _
   ByVal objWriter As IAttributeWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As TreeView
Dim objContext As IContext
Dim objWriter As IAttributeWriter

instance.RenderEditingInformation(objContext, objWriter)
C#
protected void RenderEditingInformation(
   IContext objContext,
   IAttributeWriter objWriter
)
Managed Extensions for C++
protected: void RenderEditingInformation(
   IContext* objContext,
   IAttributeWriter* objWriter
)
C++/CLI
protected:
void RenderEditingInformation(
   IContext^ objContext,
   IAttributeWriter^ objWriter
)

Parameters

objContext
The obj context.
objWriter
The obj writer.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeView Class
TreeView Members


Sort Method

[image]
Gizmox.WebGUI.Forms
Sort Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeView Class : Sort Method

Sorts the items if the value of the TreeViewNodeSorter property is not null.

Syntax

Visual Basic (Declaration)
Public Sub Sort()
Visual Basic (Usage) Copy Code
Dim instance As TreeView

instance.Sort()
C#
public void Sort()
Managed Extensions for C++
public: void Sort();
C++/CLI
public:
void Sort();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeView Class
TreeView Members


TreeView Class Properties

[image]
Gizmox.WebGUI.Forms
TreeView Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TreeView Class

For a list of all members of this type, see TreeView members.

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Overridden. Gets a value indicating whether this instance can focus.
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | CheckBoxes | Gets or sets a value indicating whether check boxes are displayed.
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | HideSelection |
Public Property | ImageIndex | Gets or sets the index of the image that is displayed for the item.
Public Property | ImageKey | Gets or sets the key for the image that is displayed for the item.
Public Property | ImageList |
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | LabelEdit | Gets or sets a value indicating whether the label text of the tree nodes can be edited.
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Nodes | Gets the collection of tree nodes that are assigned to the tree view control.
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PathSeparator |
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | SelectedImageIndex |
Public Property | SelectedNode | Gets or sets the selected node.
Public Property | ShowLines | Gets or sets a value indicating whether to show lines.
Public Property | ShowPlusMinus | Gets or sets a value indicating whether to show plus minus.
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Control)
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | TreeViewNodeSorter | Gets or sets the implementation of IComparer to perform a custom sort of the TreeView nodes.
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | Overridden. Gets the default color of the back ground.
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | Overridden.
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | Overridden.
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

See Also

Reference

TreeView Class
Gizmox.WebGUI.Forms Namespace


CanFocus Property

[image]
Gizmox.WebGUI.Forms
CanFocus Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeView Class : CanFocus Property

Gets a value indicating whether this instance can focus.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanFocus As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TreeView
Dim value As Boolean

value = instance.CanFocus
C#
public override bool CanFocus {get;}
Managed Extensions for C++
public: __property bool get_CanFocus() override;
C++/CLI
public:
property bool CanFocus {
   bool get() override;
}

Return Value

true if this instance can focus; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeView Class
TreeView Members


CheckBoxes Property

[image]
Gizmox.WebGUI.Forms
CheckBoxes Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeView Class : CheckBoxes Property

Gets or sets a value indicating whether check boxes are displayed.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property CheckBoxes As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TreeView
Dim value As Boolean

instance.CheckBoxes = value

value = instance.CheckBoxes
C#
[DefaultValueAttribute()]
public bool CheckBoxes {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property bool get_CheckBoxes();
public: __property void set_CheckBoxes(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
public:
property bool CheckBoxes {
   bool get();
   void set (boolvalue);
}

Return Value

true if check boxes are displayed; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeView Class
TreeView Members


DefaultBackColor Property

[image]
Gizmox.WebGUI.Forms
DefaultBackColor Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeView Class : DefaultBackColor Property

Gets the default color of the back ground.

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property DefaultBackColor As Color
Visual Basic (Usage) Copy Code
Dim instance As TreeView
Dim value As Color

value = instance.DefaultBackColor
C#
protected override Color DefaultBackColor {get;}
Managed Extensions for C++
protected: __property Color get_DefaultBackColor() override;
C++/CLI
protected:
property Color DefaultBackColor {
   Color get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeView Class
TreeView Members


DefaultBorderStyle Property

[image]
Gizmox.WebGUI.Forms
DefaultBorderStyle Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeView Class : DefaultBorderStyle Property

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property DefaultBorderStyle As BorderStyle
Visual Basic (Usage) Copy Code
Dim instance As TreeView
Dim value As BorderStyle

value = instance.DefaultBorderStyle
C#
protected override BorderStyle DefaultBorderStyle {get;}
Managed Extensions for C++
protected: __property BorderStyle get_DefaultBorderStyle() override;
C++/CLI
protected:
property BorderStyle DefaultBorderStyle {
   BorderStyle get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeView Class
TreeView Members


HideSelection Property

[image]
Gizmox.WebGUI.Forms
HideSelection Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeView Class : HideSelection Property

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property HideSelection As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TreeView
Dim value As Boolean

instance.HideSelection = value

value = instance.HideSelection
C#
[DefaultValueAttribute()]
public bool HideSelection {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property bool get_HideSelection();
public: __property void set_HideSelection(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
public:
property bool HideSelection {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeView Class
TreeView Members


ImageIndex Property

[image]
Gizmox.WebGUI.Forms
ImageIndex Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeView Class : ImageIndex Property

Gets or sets the index of the image that is displayed for the item.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("The default image index for nodes.")>
<RefreshPropertiesAttribute()>
<TypeConverterAttribute("Gizmox.WebGUI.Forms.Design.NoneExcludedImageIndexConverter, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")>
<LocalizableAttribute(True)>
<SRCategoryAttribute("Behavior")>
<EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.ImageIndexEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")>
<DefaultValueAttribute()>
Public Property ImageIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As TreeView
Dim value As Integer

instance.ImageIndex = value

value = instance.ImageIndex
C#
[SRDescriptionAttribute("The default image index for nodes.")]
[RefreshPropertiesAttribute()]
[TypeConverterAttribute("Gizmox.WebGUI.Forms.Design.NoneExcludedImageIndexConverter, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[LocalizableAttribute(true)]
[SRCategoryAttribute("Behavior")]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.ImageIndexEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[DefaultValueAttribute()]
public int ImageIndex {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("The default image index for nodes.")]
[RefreshPropertiesAttribute()]
[TypeConverterAttribute("Gizmox.WebGUI.Forms.Design.NoneExcludedImageIndexConverter, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[LocalizableAttribute(true)]
[SRCategoryAttribute("Behavior")]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.ImageIndexEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[DefaultValueAttribute()]
public: __property int get_ImageIndex();
public: __property void set_ImageIndex(
   int value
);
C++/CLI
[SRDescriptionAttribute("The default image index for nodes.")]
[RefreshPropertiesAttribute()]
[TypeConverterAttribute("Gizmox.WebGUI.Forms.Design.NoneExcludedImageIndexConverter, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[LocalizableAttribute(true)]
[SRCategoryAttribute("Behavior")]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.ImageIndexEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[DefaultValueAttribute()]
public:
property int ImageIndex {
   int get();
   void set (intvalue);
}

Exceptions

Exception | Description
ArgumentException | The value specified is less than -1.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeView Class
TreeView Members


ImageKey Property

[image]
Gizmox.WebGUI.Forms
ImageKey Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeView Class : ImageKey Property

Gets or sets the key for the image that is displayed for the item.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Behavior")>
<EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.ImageIndexEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")>
<TypeConverterAttribute("Gizmox.WebGUI.Forms.Design.ImageKeyConverter, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")>
<RefreshPropertiesAttribute()>
<LocalizableAttribute(True)>
<DefaultValueAttribute()>
Public Property ImageKey As String
Visual Basic (Usage) Copy Code
Dim instance As TreeView
Dim value As String

instance.ImageKey = value

value = instance.ImageKey
C#
[SRCategoryAttribute("Behavior")]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.ImageIndexEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[TypeConverterAttribute("Gizmox.WebGUI.Forms.Design.ImageKeyConverter, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[RefreshPropertiesAttribute()]
[LocalizableAttribute(true)]
[DefaultValueAttribute()]
public string ImageKey {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Behavior")]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.ImageIndexEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[TypeConverterAttribute("Gizmox.WebGUI.Forms.Design.ImageKeyConverter, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[RefreshPropertiesAttribute()]
[LocalizableAttribute(true)]
[DefaultValueAttribute()]
public: __property string* get_ImageKey();
public: __property void set_ImageKey(
   string* value
);
C++/CLI
[SRCategoryAttribute("Behavior")]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.ImageIndexEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[TypeConverterAttribute("Gizmox.WebGUI.Forms.Design.ImageKeyConverter, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[RefreshPropertiesAttribute()]
[LocalizableAttribute(true)]
[DefaultValueAttribute()]
public:
property String^ ImageKey {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeView Class
TreeView Members


ImageList Property

[image]
Gizmox.WebGUI.Forms
ImageList Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeView Class : ImageList Property

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Behavior")>
<SRDescriptionAttribute("The ImageList control from which node images are taken.")>
<DefaultValueAttribute()>
Public Property ImageList As ImageList
Visual Basic (Usage) Copy Code
Dim instance As TreeView
Dim value As ImageList

instance.ImageList = value

value = instance.ImageList
C#
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("The ImageList control from which node images are taken.")]
[DefaultValueAttribute()]
public ImageList ImageList {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("The ImageList control from which node images are taken.")]
[DefaultValueAttribute()]
public: __property ImageList* get_ImageList();
public: __property void set_ImageList(
   ImageList* value
);
C++/CLI
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("The ImageList control from which node images are taken.")]
[DefaultValueAttribute()]
public:
property ImageList^ ImageList {
   ImageList^ get();
   void set (ImageList^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeView Class
TreeView Members


IsDelayedDrawing Property

[image]
Gizmox.WebGUI.Forms
IsDelayedDrawing Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeView Class : IsDelayedDrawing Property

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property IsDelayedDrawing As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TreeView
Dim value As Boolean

value = instance.IsDelayedDrawing
C#
protected override bool IsDelayedDrawing {get;}
Managed Extensions for C++
protected: __property bool get_IsDelayedDrawing() override;
C++/CLI
protected:
property bool IsDelayedDrawing {
   bool get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeView Class
TreeView Members


LabelEdit Property

[image]
Gizmox.WebGUI.Forms
LabelEdit Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeView Class : LabelEdit Property

Gets or sets a value indicating whether the label text of the tree nodes can be edited.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Indicates whether the user can edit the label text of nodes.")>
<SRCategoryAttribute("Behavior")>
<DefaultValueAttribute()>
Public Property LabelEdit As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TreeView
Dim value As Boolean

instance.LabelEdit = value

value = instance.LabelEdit
C#
[SRDescriptionAttribute("Indicates whether the user can edit the label text of nodes.")]
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
public bool LabelEdit {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Indicates whether the user can edit the label text of nodes.")]
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
public: __property bool get_LabelEdit();
public: __property void set_LabelEdit(
   bool value
);
C++/CLI
[SRDescriptionAttribute("Indicates whether the user can edit the label text of nodes.")]
[SRCategoryAttribute("Behavior")]
[DefaultValueAttribute()]
public:
property bool LabelEdit {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeView Class
TreeView Members


Nodes Property

[image]
Gizmox.WebGUI.Forms
Nodes Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeView Class : Nodes Property

Gets the collection of tree nodes that are assigned to the tree view control.

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
<SRCategoryAttribute("Behavior")>
<MergablePropertyAttribute(False)>
<LocalizableAttribute(True)>
<SRDescriptionAttribute("The root nodes in the TreeView control.")>
Public ReadOnly Property Nodes As TreeNodeCollection
Visual Basic (Usage) Copy Code
Dim instance As TreeView
Dim value As TreeNodeCollection

value = instance.Nodes
C#
[DesignerSerializationVisibilityAttribute()]
[SRCategoryAttribute("Behavior")]
[MergablePropertyAttribute(false)]
[LocalizableAttribute(true)]
[SRDescriptionAttribute("The root nodes in the TreeView control.")]
public TreeNodeCollection Nodes {get;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
[SRCategoryAttribute("Behavior")]
[MergablePropertyAttribute(false)]
[LocalizableAttribute(true)]
[SRDescriptionAttribute("The root nodes in the TreeView control.")]
public: __property TreeNodeCollection* get_Nodes();
C++/CLI
[DesignerSerializationVisibilityAttribute()]
[SRCategoryAttribute("Behavior")]
[MergablePropertyAttribute(false)]
[LocalizableAttribute(true)]
[SRDescriptionAttribute("The root nodes in the TreeView control.")]
public:
property TreeNodeCollection^ Nodes {
   TreeNodeCollection^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeView Class
TreeView Members


PathSeparator Property

[image]
Gizmox.WebGUI.Forms
PathSeparator Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeView Class : PathSeparator Property

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property PathSeparator As String
Visual Basic (Usage) Copy Code
Dim instance As TreeView
Dim value As String

instance.PathSeparator = value

value = instance.PathSeparator
C#
[DefaultValueAttribute()]
public string PathSeparator {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property string* get_PathSeparator();
public: __property void set_PathSeparator(
   string* value
);
C++/CLI
[DefaultValueAttribute()]
public:
property String^ PathSeparator {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeView Class
TreeView Members


SelectedImageIndex Property

[image]
Gizmox.WebGUI.Forms
SelectedImageIndex Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeView Class : SelectedImageIndex Property

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property SelectedImageIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As TreeView
Dim value As Integer

instance.SelectedImageIndex = value

value = instance.SelectedImageIndex
C#
[DefaultValueAttribute()]
public int SelectedImageIndex {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property int get_SelectedImageIndex();
public: __property void set_SelectedImageIndex(
   int value
);
C++/CLI
[DefaultValueAttribute()]
public:
property int SelectedImageIndex {
   int get();
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeView Class
TreeView Members


SelectedNode Property

[image]
Gizmox.WebGUI.Forms
SelectedNode Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeView Class : SelectedNode Property

Gets or sets the selected node.

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
Public Property SelectedNode As TreeNode
Visual Basic (Usage) Copy Code
Dim instance As TreeView
Dim value As TreeNode

instance.SelectedNode = value

value = instance.SelectedNode
C#
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public TreeNode SelectedNode {get; set;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public: __property TreeNode* get_SelectedNode();
public: __property void set_SelectedNode(
   TreeNode* value
);
C++/CLI
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public:
property TreeNode^ SelectedNode {
   TreeNode^ get();
   void set (TreeNode^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeView Class
TreeView Members


ShowLines Property

[image]
Gizmox.WebGUI.Forms
ShowLines Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeView Class : ShowLines Property

Gets or sets a value indicating whether to show lines.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property ShowLines As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TreeView
Dim value As Boolean

instance.ShowLines = value

value = instance.ShowLines
C#
[DefaultValueAttribute()]
public bool ShowLines {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property bool get_ShowLines();
public: __property void set_ShowLines(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
public:
property bool ShowLines {
   bool get();
   void set (boolvalue);
}

Return Value

true if to show lines; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeView Class
TreeView Members


ShowPlusMinus Property

[image]
Gizmox.WebGUI.Forms
ShowPlusMinus Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeView Class : ShowPlusMinus Property

Gets or sets a value indicating whether to show plus minus.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property ShowPlusMinus As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TreeView
Dim value As Boolean

instance.ShowPlusMinus = value

value = instance.ShowPlusMinus
C#
[DefaultValueAttribute()]
public bool ShowPlusMinus {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property bool get_ShowPlusMinus();
public: __property void set_ShowPlusMinus(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
public:
property bool ShowPlusMinus {
   bool get();
   void set (boolvalue);
}

Return Value

true if [to show plus minus]; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeView Class
TreeView Members


TreeViewNodeSorter Property

[image]
Gizmox.WebGUI.Forms
TreeViewNodeSorter Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeView Class : TreeViewNodeSorter Property

Gets or sets the implementation of IComparer to perform a custom sort of the TreeView nodes.

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
<SRCategoryAttribute("Behavior")>
<SRDescriptionAttribute("The sorting comparer for the TreeView.")>
Public Property TreeViewNodeSorter As IComparer
Visual Basic (Usage) Copy Code
Dim instance As TreeView
Dim value As IComparer

instance.TreeViewNodeSorter = value

value = instance.TreeViewNodeSorter
C#
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("The sorting comparer for the TreeView.")]
public IComparer TreeViewNodeSorter {get; set;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("The sorting comparer for the TreeView.")]
public: __property IComparer* get_TreeViewNodeSorter();
public: __property void set_TreeViewNodeSorter(
   IComparer* value
);
C++/CLI
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("The sorting comparer for the TreeView.")]
public:
property IComparer^ TreeViewNodeSorter {
   IComparer^ get();
   void set (IComparer^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeView Class
TreeView Members


TreeView Class Fields

[image]
Gizmox.WebGUI.Forms
TreeView Class Fields
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TreeView Class

For a list of all members of this type, see TreeView members.

Protected Fields

 | Name | Description
Protected Field | mblnLabelEdit | Indicates if label editing is enabled.
Top

See Also

Reference

TreeView Class
Gizmox.WebGUI.Forms Namespace


mblnLabelEdit Field

[image]
Gizmox.WebGUI.Forms
mblnLabelEdit Field
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeView Class : mblnLabelEdit Field

Indicates if label editing is enabled.

Syntax

Visual Basic (Declaration)
Protected mblnLabelEdit As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TreeView
Dim value As Boolean

value = instance.mblnLabelEdit

instance.mblnLabelEdit = value
C#
protected bool mblnLabelEdit
Managed Extensions for C++
protected: bool mblnLabelEdit
C++/CLI
protected:
bool mblnLabelEdit

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeView Class
TreeView Members


TreeView Class Events

[image]
Gizmox.WebGUI.Forms
TreeView Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TreeView Class

For a list of all members of this type, see TreeView members.

Public Events

 | Name | Description
Public Event | AfterCheck | Occurs after the tree node check box is checked.
Public Event | AfterCollapse | Occurs after the tree node is collapsed.
Public Event | AfterExpand | Occurs after the tree node is expanded.
Public Event | AfterLabelEdit | Occurs after the tree node label text is edited.
Public Event | AfterSelect | Occurs after the tree node is selected.
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BeforeCheck | Occurs before the tree node check box is checked.
Public Event | BeforeCollapse | Occurs before the tree node is collapsed.
Public Event | BeforeExpand | Occurs before the tree node is expanded.
Public Event | BeforeLabelEdit | Occurs before the tree node label text is edited.
Public Event | BeforeSelect | Occurs before the tree node is selected.
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | NodeMouseClick | Occurs when the user clicks a TreeNode with the mouse.
Public Event | NodeMouseDoubleClick | Occurs when the user double-clicks a TreeNode with the mouse.
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

TreeView Class
Gizmox.WebGUI.Forms Namespace


AfterCheck Event

[image]
Gizmox.WebGUI.Forms
AfterCheck Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeView Class : AfterCheck Event

Occurs after the tree node check box is checked.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when a check box on a tree node has been checked or unchecked.")>
<SRCategoryAttribute("Behavior")>
Public Event AfterCheck() As TreeViewEventHandler
Visual Basic (Usage) Copy Code
Dim instance As TreeView
Dim handler As TreeViewEventHandler

AddHandler instance.AfterCheck, handler
C#
[SRDescriptionAttribute("Occurs when a check box on a tree node has been checked or unchecked.")]
[SRCategoryAttribute("Behavior")]
public event TreeViewEventHandler AfterCheck()
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when a check box on a tree node has been checked or unchecked.")]
[SRCategoryAttribute("Behavior")]
public: __event TreeViewEventHandler* AfterCheck
C++/CLI
[SRDescriptionAttribute("Occurs when a check box on a tree node has been checked or unchecked.")]
[SRCategoryAttribute("Behavior")]
public:
event TreeViewEventHandler^ AfterCheck

Event Data

The event handler receives an argument of type TreeViewEventArgs containing data related to this event. The following TreeViewEventArgs properties provide information specific to this event.

Property | Description
Action |
Node |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeView Class
TreeView Members


AfterCollapse Event

[image]
Gizmox.WebGUI.Forms
AfterCollapse Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeView Class : AfterCollapse Event

Occurs after the tree node is collapsed.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Behavior")>
<SRDescriptionAttribute("Occurs when a node has been collapsed.")>
Public Event AfterCollapse() As TreeViewEventHandler
Visual Basic (Usage) Copy Code
Dim instance As TreeView
Dim handler As TreeViewEventHandler

AddHandler instance.AfterCollapse, handler
C#
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when a node has been collapsed.")]
public event TreeViewEventHandler AfterCollapse()
Managed Extensions for C++
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when a node has been collapsed.")]
public: __event TreeViewEventHandler* AfterCollapse
C++/CLI
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when a node has been collapsed.")]
public:
event TreeViewEventHandler^ AfterCollapse

Event Data

The event handler receives an argument of type TreeViewEventArgs containing data related to this event. The following TreeViewEventArgs properties provide information specific to this event.

Property | Description
Action |
Node |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeView Class
TreeView Members


AfterExpand Event

[image]
Gizmox.WebGUI.Forms
AfterExpand Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeView Class : AfterExpand Event

Occurs after the tree node is expanded.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when a node has been expanded.")>
<SRCategoryAttribute("Behavior")>
Public Event AfterExpand() As TreeViewEventHandler
Visual Basic (Usage) Copy Code
Dim instance As TreeView
Dim handler As TreeViewEventHandler

AddHandler instance.AfterExpand, handler
C#
[SRDescriptionAttribute("Occurs when a node has been expanded.")]
[SRCategoryAttribute("Behavior")]
public event TreeViewEventHandler AfterExpand()
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when a node has been expanded.")]
[SRCategoryAttribute("Behavior")]
public: __event TreeViewEventHandler* AfterExpand
C++/CLI
[SRDescriptionAttribute("Occurs when a node has been expanded.")]
[SRCategoryAttribute("Behavior")]
public:
event TreeViewEventHandler^ AfterExpand

Event Data

The event handler receives an argument of type TreeViewEventArgs containing data related to this event. The following TreeViewEventArgs properties provide information specific to this event.

Property | Description
Action |
Node |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeView Class
TreeView Members


AfterLabelEdit Event

[image]
Gizmox.WebGUI.Forms
AfterLabelEdit Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeView Class : AfterLabelEdit Event

Occurs after the tree node label text is edited.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Behavior")>
<SRDescriptionAttribute("Occurs when the text of a node has been edited by the user.")>
Public Event AfterLabelEdit() As NodeLabelEditEventHandler
Visual Basic (Usage) Copy Code
Dim instance As TreeView
Dim handler As NodeLabelEditEventHandler

AddHandler instance.AfterLabelEdit, handler
C#
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when the text of a node has been edited by the user.")]
public event NodeLabelEditEventHandler AfterLabelEdit()
Managed Extensions for C++
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when the text of a node has been edited by the user.")]
public: __event NodeLabelEditEventHandler* AfterLabelEdit
C++/CLI
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when the text of a node has been edited by the user.")]
public:
event NodeLabelEditEventHandler^ AfterLabelEdit

Event Data

The event handler receives an argument of type NodeLabelEditEventArgs containing data related to this event. The following NodeLabelEditEventArgs properties provide information specific to this event.

Property | Description
CancelEdit |
Label |
Node |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeView Class
TreeView Members


AfterSelect Event

[image]
Gizmox.WebGUI.Forms
AfterSelect Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeView Class : AfterSelect Event

Occurs after the tree node is selected.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the selection has been changed.")>
<SRCategoryAttribute("Behavior")>
Public Event AfterSelect() As TreeViewEventHandler
Visual Basic (Usage) Copy Code
Dim instance As TreeView
Dim handler As TreeViewEventHandler

AddHandler instance.AfterSelect, handler
C#
[SRDescriptionAttribute("Occurs when the selection has been changed.")]
[SRCategoryAttribute("Behavior")]
public event TreeViewEventHandler AfterSelect()
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the selection has been changed.")]
[SRCategoryAttribute("Behavior")]
public: __event TreeViewEventHandler* AfterSelect
C++/CLI
[SRDescriptionAttribute("Occurs when the selection has been changed.")]
[SRCategoryAttribute("Behavior")]
public:
event TreeViewEventHandler^ AfterSelect

Event Data

The event handler receives an argument of type TreeViewEventArgs containing data related to this event. The following TreeViewEventArgs properties provide information specific to this event.

Property | Description
Action |
Node |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeView Class
TreeView Members


BeforeCheck Event

[image]
Gizmox.WebGUI.Forms
BeforeCheck Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeView Class : BeforeCheck Event

Occurs before the tree node check box is checked.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Behavior")>
<SRDescriptionAttribute("Occurs when a check box on a tree node is about to be checked or unchecked.")>
Public Event BeforeCheck() As TreeViewCancelEventHandler
Visual Basic (Usage) Copy Code
Dim instance As TreeView
Dim handler As TreeViewCancelEventHandler

AddHandler instance.BeforeCheck, handler
C#
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when a check box on a tree node is about to be checked or unchecked.")]
public event TreeViewCancelEventHandler BeforeCheck()
Managed Extensions for C++
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when a check box on a tree node is about to be checked or unchecked.")]
public: __event TreeViewCancelEventHandler* BeforeCheck
C++/CLI
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when a check box on a tree node is about to be checked or unchecked.")]
public:
event TreeViewCancelEventHandler^ BeforeCheck

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeView Class
TreeView Members


BeforeCollapse Event

[image]
Gizmox.WebGUI.Forms
BeforeCollapse Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeView Class : BeforeCollapse Event

Occurs before the tree node is collapsed.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Behavior")>
<SRDescriptionAttribute("Occurs when a node is about to be collapsed.")>
Public Event BeforeCollapse() As TreeViewCancelEventHandler
Visual Basic (Usage) Copy Code
Dim instance As TreeView
Dim handler As TreeViewCancelEventHandler

AddHandler instance.BeforeCollapse, handler
C#
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when a node is about to be collapsed.")]
public event TreeViewCancelEventHandler BeforeCollapse()
Managed Extensions for C++
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when a node is about to be collapsed.")]
public: __event TreeViewCancelEventHandler* BeforeCollapse
C++/CLI
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when a node is about to be collapsed.")]
public:
event TreeViewCancelEventHandler^ BeforeCollapse

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeView Class
TreeView Members


BeforeExpand Event

[image]
Gizmox.WebGUI.Forms
BeforeExpand Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeView Class : BeforeExpand Event

Occurs before the tree node is expanded.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Behavior")>
<SRDescriptionAttribute("Occurs when a node is about to be expanded.")>
Public Event BeforeExpand() As TreeViewCancelEventHandler
Visual Basic (Usage) Copy Code
Dim instance As TreeView
Dim handler As TreeViewCancelEventHandler

AddHandler instance.BeforeExpand, handler
C#
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when a node is about to be expanded.")]
public event TreeViewCancelEventHandler BeforeExpand()
Managed Extensions for C++
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when a node is about to be expanded.")]
public: __event TreeViewCancelEventHandler* BeforeExpand
C++/CLI
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when a node is about to be expanded.")]
public:
event TreeViewCancelEventHandler^ BeforeExpand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeView Class
TreeView Members


BeforeLabelEdit Event

[image]
Gizmox.WebGUI.Forms
BeforeLabelEdit Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeView Class : BeforeLabelEdit Event

Occurs before the tree node label text is edited.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the text of a node is about to be edited by the user.")>
<SRCategoryAttribute("Behavior")>
Public Event BeforeLabelEdit() As NodeLabelEditEventHandler
Visual Basic (Usage) Copy Code
Dim instance As TreeView
Dim handler As NodeLabelEditEventHandler

AddHandler instance.BeforeLabelEdit, handler
C#
[SRDescriptionAttribute("Occurs when the text of a node is about to be edited by the user.")]
[SRCategoryAttribute("Behavior")]
public event NodeLabelEditEventHandler BeforeLabelEdit()
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the text of a node is about to be edited by the user.")]
[SRCategoryAttribute("Behavior")]
public: __event NodeLabelEditEventHandler* BeforeLabelEdit
C++/CLI
[SRDescriptionAttribute("Occurs when the text of a node is about to be edited by the user.")]
[SRCategoryAttribute("Behavior")]
public:
event NodeLabelEditEventHandler^ BeforeLabelEdit

Event Data

The event handler receives an argument of type NodeLabelEditEventArgs containing data related to this event. The following NodeLabelEditEventArgs properties provide information specific to this event.

Property | Description
CancelEdit |
Label |
Node |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeView Class
TreeView Members


BeforeSelect Event

[image]
Gizmox.WebGUI.Forms
BeforeSelect Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeView Class : BeforeSelect Event

Occurs before the tree node is selected.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the selection is about to change.")>
<SRCategoryAttribute("Behavior")>
Public Event BeforeSelect() As TreeViewCancelEventHandler
Visual Basic (Usage) Copy Code
Dim instance As TreeView
Dim handler As TreeViewCancelEventHandler

AddHandler instance.BeforeSelect, handler
C#
[SRDescriptionAttribute("Occurs when the selection is about to change.")]
[SRCategoryAttribute("Behavior")]
public event TreeViewCancelEventHandler BeforeSelect()
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the selection is about to change.")]
[SRCategoryAttribute("Behavior")]
public: __event TreeViewCancelEventHandler* BeforeSelect
C++/CLI
[SRDescriptionAttribute("Occurs when the selection is about to change.")]
[SRCategoryAttribute("Behavior")]
public:
event TreeViewCancelEventHandler^ BeforeSelect

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeView Class
TreeView Members


NodeMouseClick Event

[image]
Gizmox.WebGUI.Forms
NodeMouseClick Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeView Class : NodeMouseClick Event

Occurs when the user clicks a TreeNode with the mouse.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when a node is clicked with the mouse.")>
<SRCategoryAttribute("Behavior")>
Public Event NodeMouseClick() As TreeNodeMouseClickEventHandler
Visual Basic (Usage) Copy Code
Dim instance As TreeView
Dim handler As TreeNodeMouseClickEventHandler

AddHandler instance.NodeMouseClick, handler
C#
[SRDescriptionAttribute("Occurs when a node is clicked with the mouse.")]
[SRCategoryAttribute("Behavior")]
public event TreeNodeMouseClickEventHandler NodeMouseClick()
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when a node is clicked with the mouse.")]
[SRCategoryAttribute("Behavior")]
public: __event TreeNodeMouseClickEventHandler* NodeMouseClick
C++/CLI
[SRDescriptionAttribute("Occurs when a node is clicked with the mouse.")]
[SRCategoryAttribute("Behavior")]
public:
event TreeNodeMouseClickEventHandler^ NodeMouseClick

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeView Class
TreeView Members


NodeMouseDoubleClick Event

[image]
Gizmox.WebGUI.Forms
NodeMouseDoubleClick Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeView Class : NodeMouseDoubleClick Event

Occurs when the user double-clicks a TreeNode with the mouse.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when a node is double-clicked with the mouse.")>
<SRCategoryAttribute("Behavior")>
Public Event NodeMouseDoubleClick() As TreeNodeMouseClickEventHandler
Visual Basic (Usage) Copy Code
Dim instance As TreeView
Dim handler As TreeNodeMouseClickEventHandler

AddHandler instance.NodeMouseDoubleClick, handler
C#
[SRDescriptionAttribute("Occurs when a node is double-clicked with the mouse.")]
[SRCategoryAttribute("Behavior")]
public event TreeNodeMouseClickEventHandler NodeMouseDoubleClick()
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when a node is double-clicked with the mouse.")]
[SRCategoryAttribute("Behavior")]
public: __event TreeNodeMouseClickEventHandler* NodeMouseDoubleClick
C++/CLI
[SRDescriptionAttribute("Occurs when a node is double-clicked with the mouse.")]
[SRCategoryAttribute("Behavior")]
public:
event TreeNodeMouseClickEventHandler^ NodeMouseDoubleClick

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeView Class
TreeView Members


TreeViewCancelEventArgs Class

[image]
Gizmox.WebGUI.Forms
TreeViewCancelEventArgs Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TreeViewCancelEventArgs Class

Object Model

Syntax

Visual Basic (Declaration)
Public Class TreeViewCancelEventArgs
   Inherits CancelEventArgs
Visual Basic (Usage) Copy Code
Dim instance As TreeViewCancelEventArgs
C#
public class TreeViewCancelEventArgs : CancelEventArgs
Managed Extensions for C++
public __gc class TreeViewCancelEventArgs : public CancelEventArgs
C++/CLI
public ref class TreeViewCancelEventArgs : public CancelEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
System.ComponentModel.CancelEventArgs
Gizmox.WebGUI.Forms.TreeViewCancelEventArgs

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

TreeViewCancelEventArgs Members
Gizmox.WebGUI.Forms Namespace


TreeViewCancelEventArgs Class Members

[image]
Gizmox.WebGUI.Forms
TreeViewCancelEventArgs Class Members
See Also Properties Send Feedback
Gizmox.WebGUI.Forms Namespace : TreeViewCancelEventArgs Class

The following tables list the members exposed by TreeViewCancelEventArgs.

Public Constructors

 | Name | Description
Public Constructor | TreeViewCancelEventArgs Constructor |
Top

Public Properties

 | Name | Description
Public Property | Action |
Public Property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from System.ComponentModel.CancelEventArgs)
Public Property | Node |
Top

See Also

Reference

TreeViewCancelEventArgs Class
Gizmox.WebGUI.Forms Namespace


TreeViewCancelEventArgs Constructor

[image]
Gizmox.WebGUI.Forms
TreeViewCancelEventArgs Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeViewCancelEventArgs Class : TreeViewCancelEventArgs Constructor

node
cancel
action

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal node As TreeNode, _
   ByVal cancel As Boolean, _
   ByVal action As TreeViewAction _
)
Visual Basic (Usage) Copy Code
Dim node As TreeNode
Dim cancel As Boolean
Dim action As TreeViewAction

Dim instance As TreeViewCancelEventArgs(node, cancel, action)
C#
public TreeViewCancelEventArgs(
   TreeNode node,
   bool cancel,
   TreeViewAction action
)
Managed Extensions for C++
public: TreeViewCancelEventArgs(
   TreeNode* node,
   bool cancel,
   TreeViewAction action
)
C++/CLI
public:
TreeViewCancelEventArgs(
   TreeNode^ node,
   bool cancel,
   TreeViewAction action
)

Parameters

node
cancel
action

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeViewCancelEventArgs Class
TreeViewCancelEventArgs Members


TreeViewCancelEventArgs Class Properties

[image]
Gizmox.WebGUI.Forms
TreeViewCancelEventArgs Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TreeViewCancelEventArgs Class

For a list of all members of this type, see TreeViewCancelEventArgs members.

Public Properties

 | Name | Description
Public Property | Action |
Public Property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from System.ComponentModel.CancelEventArgs)
Public Property | Node |
Top

See Also

Reference

TreeViewCancelEventArgs Class
Gizmox.WebGUI.Forms Namespace


Action Property

[image]
Gizmox.WebGUI.Forms
Action Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeViewCancelEventArgs Class : Action Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Action As TreeViewAction
Visual Basic (Usage) Copy Code
Dim instance As TreeViewCancelEventArgs
Dim value As TreeViewAction

value = instance.Action
C#
public TreeViewAction Action {get;}
Managed Extensions for C++
public: __property TreeViewAction get_Action();
C++/CLI
public:
property TreeViewAction Action {
   TreeViewAction get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeViewCancelEventArgs Class
TreeViewCancelEventArgs Members


Node Property

[image]
Gizmox.WebGUI.Forms
Node Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeViewCancelEventArgs Class : Node Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Node As TreeNode
Visual Basic (Usage) Copy Code
Dim instance As TreeViewCancelEventArgs
Dim value As TreeNode

value = instance.Node
C#
public TreeNode Node {get;}
Managed Extensions for C++
public: __property TreeNode* get_Node();
C++/CLI
public:
property TreeNode^ Node {
   TreeNode^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeViewCancelEventArgs Class
TreeViewCancelEventArgs Members


TreeViewEventArgs Class

[image]
Gizmox.WebGUI.Forms
TreeViewEventArgs Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TreeViewEventArgs Class

Object Model

Syntax

Visual Basic (Declaration)
Public Class TreeViewEventArgs
   Inherits EventArgs
Visual Basic (Usage) Copy Code
Dim instance As TreeViewEventArgs
C#
public class TreeViewEventArgs : EventArgs
Managed Extensions for C++
public __gc class TreeViewEventArgs : public EventArgs
C++/CLI
public ref class TreeViewEventArgs : public EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gizmox.WebGUI.Forms.TreeViewEventArgs

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

TreeViewEventArgs Members
Gizmox.WebGUI.Forms Namespace


TreeViewEventArgs Class Members

[image]
Gizmox.WebGUI.Forms
TreeViewEventArgs Class Members
See Also Properties Send Feedback
Gizmox.WebGUI.Forms Namespace : TreeViewEventArgs Class

The following tables list the members exposed by TreeViewEventArgs.

Public Constructors

 | Name | Description
Public Constructor | TreeViewEventArgs Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Action |
Public Property | Node |
Top

See Also

Reference

TreeViewEventArgs Class
Gizmox.WebGUI.Forms Namespace


TreeViewEventArgs Constructor

[image]
Gizmox.WebGUI.Forms
TreeViewEventArgs Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeViewEventArgs Class : TreeViewEventArgs Constructor

Overload List

Overload | Description
TreeViewEventArgs Constructor(TreeNode) |
TreeViewEventArgs Constructor(TreeNode,TreeViewAction) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeViewEventArgs Class
TreeViewEventArgs Members


TreeViewEventArgs Constructor(TreeNode)

[image]
Gizmox.WebGUI.Forms
TreeViewEventArgs Constructor(TreeNode)
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeViewEventArgs Class > TreeViewEventArgs Constructor : TreeViewEventArgs Constructor(TreeNode)

node

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal node As TreeNode _
)
Visual Basic (Usage) Copy Code
Dim node As TreeNode

Dim instance As TreeViewEventArgs(node)
C#
public TreeViewEventArgs(
   TreeNode node
)
Managed Extensions for C++
public: TreeViewEventArgs(
   TreeNode* node
)
C++/CLI
public:
TreeViewEventArgs(
   TreeNode^ node
)

Parameters

node

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeViewEventArgs Class
TreeViewEventArgs Members
Overload List


TreeViewEventArgs Constructor(TreeNode,TreeViewAction)

[image]
Gizmox.WebGUI.Forms
TreeViewEventArgs Constructor(TreeNode,TreeViewAction)
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeViewEventArgs Class > TreeViewEventArgs Constructor : TreeViewEventArgs Constructor(TreeNode,TreeViewAction)

node
action

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal node As TreeNode, _
   ByVal action As TreeViewAction _
)
Visual Basic (Usage) Copy Code
Dim node As TreeNode
Dim action As TreeViewAction

Dim instance As TreeViewEventArgs(node, action)
C#
public TreeViewEventArgs(
   TreeNode node,
   TreeViewAction action
)
Managed Extensions for C++
public: TreeViewEventArgs(
   TreeNode* node,
   TreeViewAction action
)
C++/CLI
public:
TreeViewEventArgs(
   TreeNode^ node,
   TreeViewAction action
)

Parameters

node
action

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeViewEventArgs Class
TreeViewEventArgs Members
Overload List


TreeViewEventArgs Class Properties

[image]
Gizmox.WebGUI.Forms
TreeViewEventArgs Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TreeViewEventArgs Class

For a list of all members of this type, see TreeViewEventArgs members.

Public Properties

 | Name | Description
Public Property | Action |
Public Property | Node |
Top

See Also

Reference

TreeViewEventArgs Class
Gizmox.WebGUI.Forms Namespace


Action Property

[image]
Gizmox.WebGUI.Forms
Action Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeViewEventArgs Class : Action Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Action As TreeViewAction
Visual Basic (Usage) Copy Code
Dim instance As TreeViewEventArgs
Dim value As TreeViewAction

value = instance.Action
C#
public TreeViewAction Action {get;}
Managed Extensions for C++
public: __property TreeViewAction get_Action();
C++/CLI
public:
property TreeViewAction Action {
   TreeViewAction get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeViewEventArgs Class
TreeViewEventArgs Members


Node Property

[image]
Gizmox.WebGUI.Forms
Node Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TreeViewEventArgs Class : Node Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Node As TreeNode
Visual Basic (Usage) Copy Code
Dim instance As TreeViewEventArgs
Dim value As TreeNode

value = instance.Node
C#
public TreeNode Node {get;}
Managed Extensions for C++
public: __property TreeNode* get_Node();
C++/CLI
public:
property TreeNode^ Node {
   TreeNode^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TreeViewEventArgs Class
TreeViewEventArgs Members


UpDownBase Class

[image]
Gizmox.WebGUI.Forms
UpDownBase Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : UpDownBase Class

Implements the basic functionality required by a spin box (also known as an up-down control).

Object Model

Syntax

Visual Basic (Declaration)
Public MustInherit Class UpDownBase
   Inherits ContainerControl
   Implements IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IContainerControl, IArrangedElement
Visual Basic (Usage) Copy Code
Dim instance As UpDownBase
C#
public abstract class UpDownBase : ContainerControl, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IContainerControl, IArrangedElement
Managed Extensions for C++
public __gc abstract class UpDownBase : public ContainerControl, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IContainerControl, IArrangedElement
C++/CLI
public ref class UpDownBase abstract : public ContainerControl, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IContainerControl, IArrangedElement

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.ScrollableControl
Gizmox.WebGUI.Forms.ContainerControl
Gizmox.WebGUI.Forms.UpDownBase
Gizmox.WebGUI.Forms.DomainUpDown
Gizmox.WebGUI.Forms.NumericUpDown

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

UpDownBase Members
Gizmox.WebGUI.Forms Namespace


UpDownBase Class Members

[image]
Gizmox.WebGUI.Forms
UpDownBase Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : UpDownBase Class

The following tables list the members exposed by UpDownBase.

Public Properties

 | Name | Description
Public Property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl)
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from ContainerControl)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Components | (Inherited from ContainerControl)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | HideButtons | Gets or sets a value indicating whether the buttons are hidden or not.
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | ReadOnly | Gets or sets a value indicating whether the text can be changed by the use of the up or down buttons only.
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Control)
Public Property | TextAlign | Gets or sets the alignment of the text in the spin box (also known as an up-down control).
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | UpDownAlign | Gets or sets the alignment of the up and down buttons on the spin box (also known as an up-down control).
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Protected Property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl)
Top

Public Methods

 | Name | Description
Public Method | Add | (Inherited from ContainerControl)
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from ContainerControl)
Public Method | DownButton | When overridden in a derived class, handles the clicking of the down button on the spin box (also known as an up-down control).
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | Remove | (Inherited from ContainerControl)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl)
Public Method | Select | Overloaded. Selects a range of text in the spin box (also known as an up-down control) specifying the starting position and number of characters to select.
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | UpButton | When overridden in a derived class, handles the clicking of the up button on the spin box (also known as an up-down control).
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Overridden. Fires an event.
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from ScrollableControl)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Control)
Protected Method | RenderAttributes | Overridden. Renders the scrollable attribute
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetValue | Sets the value.
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateEditText | When overridden in a derived class, updates the text displayed in the spin box (also known as an up-down control).
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Protected Method | ValidateEditText | When overridden in a derived class, validates the text displayed in the spin box (also known as an up-down control).
Top

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

UpDownBase Class
Gizmox.WebGUI.Forms Namespace


UpDownBase Class Methods

[image]
Gizmox.WebGUI.Forms
UpDownBase Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : UpDownBase Class

For a list of all members of this type, see UpDownBase members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from ContainerControl)
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from ContainerControl)
Public Method | DownButton | When overridden in a derived class, handles the clicking of the down button on the spin box (also known as an up-down control).
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | Remove | (Inherited from ContainerControl)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl)
Public Method | Select | Overloaded. Selects a range of text in the spin box (also known as an up-down control) specifying the starting position and number of characters to select.
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | UpButton | When overridden in a derived class, handles the clicking of the up button on the spin box (also known as an up-down control).
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Overridden. Fires an event.
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from ScrollableControl)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Control)
Protected Method | RenderAttributes | Overridden. Renders the scrollable attribute
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetValue | Sets the value.
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateEditText | When overridden in a derived class, updates the text displayed in the spin box (also known as an up-down control).
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Protected Method | ValidateEditText | When overridden in a derived class, validates the text displayed in the spin box (also known as an up-down control).
Top

See Also

Reference

UpDownBase Class
Gizmox.WebGUI.Forms Namespace


DownButton Method

[image]
Gizmox.WebGUI.Forms
DownButton Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > UpDownBase Class : DownButton Method

When overridden in a derived class, handles the clicking of the down button on the spin box (also known as an up-down control).

Syntax

Visual Basic (Declaration)
Public MustOverride Sub DownButton()
Visual Basic (Usage) Copy Code
Dim instance As UpDownBase

instance.DownButton()
C#
public abstract void DownButton()
Managed Extensions for C++
public: abstract void DownButton();
C++/CLI
public:
abstract void DownButton();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

UpDownBase Class
UpDownBase Members


FireEvent Method

[image]
Gizmox.WebGUI.Forms
FireEvent Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > UpDownBase Class : FireEvent Method

objEvent
event.
Fires an event.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub FireEvent( _
   ByVal objEvent As IEvent _
)
Visual Basic (Usage) Copy Code
Dim instance As UpDownBase
Dim objEvent As IEvent

instance.FireEvent(objEvent)
C#
protected override void FireEvent(
   IEvent objEvent
)
Managed Extensions for C++
protected: void FireEvent(
   IEvent* objEvent
) override
C++/CLI
protected:
void FireEvent(
   IEvent^ objEvent
) override

Parameters

objEvent
event.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

UpDownBase Class
UpDownBase Members


RenderAttributes Method

[image]
Gizmox.WebGUI.Forms
RenderAttributes Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > UpDownBase Class : RenderAttributes Method

objContext
objWriter
Renders the scrollable attribute

Syntax

Visual Basic (Declaration)
Protected Overrides Sub RenderAttributes( _
   ByVal objContext As IContext, _
   ByVal objWriter As IAttributeWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As UpDownBase
Dim objContext As IContext
Dim objWriter As IAttributeWriter

instance.RenderAttributes(objContext, objWriter)
C#
protected override void RenderAttributes(
   IContext objContext,
   IAttributeWriter objWriter
)
Managed Extensions for C++
protected: void RenderAttributes(
   IContext* objContext,
   IAttributeWriter* objWriter
) override
C++/CLI
protected:
void RenderAttributes(
   IContext^ objContext,
   IAttributeWriter^ objWriter
) override

Parameters

objContext
objWriter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

UpDownBase Class
UpDownBase Members


Select Method

[image]
Gizmox.WebGUI.Forms
Select Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > UpDownBase Class : Select Method

Selects a range of text in the spin box (also known as an up-down control) specifying the starting position and number of characters to select.

Overload List

Overload | Description
Select(Int32,Int32) | Selects a range of text in the spin box (also known as an up-down control) specifying the starting position and number of characters to select.
Select() | Activates the control. (Inherited from Control)
Select(Boolean,Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

UpDownBase Class
UpDownBase Members


Select(Int32,Int32) Method

[image]
Gizmox.WebGUI.Forms
Select(Int32,Int32) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > UpDownBase Class > Select Method : Select(Int32,Int32) Method

start
The position of the first character to be selected.
length
The total number of characters to be selected.
Selects a range of text in the spin box (also known as an up-down control) specifying the starting position and number of characters to select.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Select( _
   ByVal start As Integer, _
   ByVal length As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As UpDownBase
Dim start As Integer
Dim length As Integer

instance.Select(start, length)
C#
public void Select(
   int start,
   int length
)
Managed Extensions for C++
public: void Select(
   int start,
   int length
)
C++/CLI
public:
void Select(
   int start,
   int length
)

Parameters

start
The position of the first character to be selected.
length
The total number of characters to be selected.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

UpDownBase Class
UpDownBase Members
Overload List


SetValue Method

[image]
Gizmox.WebGUI.Forms
SetValue Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > UpDownBase Class : SetValue Method

strValue
The STR value.
Sets the value.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub SetValue( _
   ByVal strValue As String _
)
Visual Basic (Usage) Copy Code
Dim instance As UpDownBase
Dim strValue As String

instance.SetValue(strValue)
C#
protected virtual void SetValue(
   string strValue
)
Managed Extensions for C++
protected: virtual void SetValue(
   string* strValue
)
C++/CLI
protected:
virtual void SetValue(
   String^ strValue
)

Parameters

strValue
The STR value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

UpDownBase Class
UpDownBase Members


UpButton Method

[image]
Gizmox.WebGUI.Forms
UpButton Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > UpDownBase Class : UpButton Method

When overridden in a derived class, handles the clicking of the up button on the spin box (also known as an up-down control).

Syntax

Visual Basic (Declaration)
Public MustOverride Sub UpButton()
Visual Basic (Usage) Copy Code
Dim instance As UpDownBase

instance.UpButton()
C#
public abstract void UpButton()
Managed Extensions for C++
public: abstract void UpButton();
C++/CLI
public:
abstract void UpButton();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

UpDownBase Class
UpDownBase Members


UpdateEditText Method

[image]
Gizmox.WebGUI.Forms
UpdateEditText Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > UpDownBase Class : UpdateEditText Method

When overridden in a derived class, updates the text displayed in the spin box (also known as an up-down control).

Syntax

Visual Basic (Declaration)
Protected MustOverride Sub UpdateEditText()
Visual Basic (Usage) Copy Code
Dim instance As UpDownBase

instance.UpdateEditText()
C#
protected abstract void UpdateEditText()
Managed Extensions for C++
protected: abstract void UpdateEditText();
C++/CLI
protected:
abstract void UpdateEditText();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

UpDownBase Class
UpDownBase Members


ValidateEditText Method

[image]
Gizmox.WebGUI.Forms
ValidateEditText Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > UpDownBase Class : ValidateEditText Method

When overridden in a derived class, validates the text displayed in the spin box (also known as an up-down control).

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ValidateEditText()
Visual Basic (Usage) Copy Code
Dim instance As UpDownBase

instance.ValidateEditText()
C#
protected virtual void ValidateEditText()
Managed Extensions for C++
protected: virtual void ValidateEditText();
C++/CLI
protected:
virtual void ValidateEditText();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

UpDownBase Class
UpDownBase Members


UpDownBase Class Properties

[image]
Gizmox.WebGUI.Forms
UpDownBase Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : UpDownBase Class

For a list of all members of this type, see UpDownBase members.

Public Properties

 | Name | Description
Public Property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl)
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from ContainerControl)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Components | (Inherited from ContainerControl)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | HideButtons | Gets or sets a value indicating whether the buttons are hidden or not.
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | ReadOnly | Gets or sets a value indicating whether the text can be changed by the use of the up or down buttons only.
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Control)
Public Property | TextAlign | Gets or sets the alignment of the text in the spin box (also known as an up-down control).
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | UpDownAlign | Gets or sets the alignment of the up and down buttons on the spin box (also known as an up-down control).
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Protected Property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl)
Top

See Also

Reference

UpDownBase Class
Gizmox.WebGUI.Forms Namespace


HideButtons Property

[image]
Gizmox.WebGUI.Forms
HideButtons Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > UpDownBase Class : HideButtons Property

Gets or sets a value indicating whether the buttons are hidden or not.

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Appearance")>
<DefaultValueAttribute()>
Public Property HideButtons As Boolean
Visual Basic (Usage) Copy Code
Dim instance As UpDownBase
Dim value As Boolean

instance.HideButtons = value

value = instance.HideButtons
C#
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
public bool HideButtons {get; set;}
Managed Extensions for C++
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
public: __property bool get_HideButtons();
public: __property void set_HideButtons(
   bool value
);
C++/CLI
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
public:
property bool HideButtons {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

UpDownBase Class
UpDownBase Members


ReadOnly Property

[image]
Gizmox.WebGUI.Forms
ReadOnly Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > UpDownBase Class : ReadOnly Property

Gets or sets a value indicating whether the text can be changed by the use of the up or down buttons only.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<SRDescriptionAttribute("Indicates whether the edit box is read-only.")>
<SRCategoryAttribute("Behavior")>
Public Property ReadOnly As Boolean
Visual Basic (Usage) Copy Code
Dim instance As UpDownBase
Dim value As Boolean

instance.ReadOnly = value

value = instance.ReadOnly
C#
[DefaultValueAttribute()]
[SRDescriptionAttribute("Indicates whether the edit box is read-only.")]
[SRCategoryAttribute("Behavior")]
public bool ReadOnly {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[SRDescriptionAttribute("Indicates whether the edit box is read-only.")]
[SRCategoryAttribute("Behavior")]
public: __property bool get_ReadOnly();
public: __property void set_ReadOnly(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
[SRDescriptionAttribute("Indicates whether the edit box is read-only.")]
[SRCategoryAttribute("Behavior")]
public:
property bool ReadOnly {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

UpDownBase Class
UpDownBase Members


TextAlign Property

[image]
Gizmox.WebGUI.Forms
TextAlign Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > UpDownBase Class : TextAlign Property

Gets or sets the alignment of the text in the spin box (also known as an up-down control).

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Indicates how the text should be aligned in the edit box.")>
<LocalizableAttribute(True)>
<DefaultValueAttribute()>
<SRCategoryAttribute("Appearance")>
Public Property TextAlign As HorizontalAlignment
Visual Basic (Usage) Copy Code
Dim instance As UpDownBase
Dim value As HorizontalAlignment

instance.TextAlign = value

value = instance.TextAlign
C#
[SRDescriptionAttribute("Indicates how the text should be aligned in the edit box.")]
[LocalizableAttribute(true)]
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
public HorizontalAlignment TextAlign {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Indicates how the text should be aligned in the edit box.")]
[LocalizableAttribute(true)]
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
public: __property HorizontalAlignment get_TextAlign();
public: __property void set_TextAlign(
   HorizontalAlignment value
);
C++/CLI
[SRDescriptionAttribute("Indicates how the text should be aligned in the edit box.")]
[LocalizableAttribute(true)]
[DefaultValueAttribute()]
[SRCategoryAttribute("Appearance")]
public:
property HorizontalAlignment TextAlign {
   HorizontalAlignment get();
   void set (HorizontalAlignmentvalue);
}

Exceptions

Exception | Description
InvalidEnumArgumentException | The value assigned is not one of the HorizontalAlignment values.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

UpDownBase Class
UpDownBase Members


UpDownAlign Property

[image]
Gizmox.WebGUI.Forms
UpDownAlign Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > UpDownBase Class : UpDownAlign Property

Gets or sets the alignment of the up and down buttons on the spin box (also known as an up-down control).

Syntax

Visual Basic (Declaration)
<LocalizableAttribute(True)>
<SRCategoryAttribute("Appearance")>
<DefaultValueAttribute()>
<SRDescriptionAttribute("Indicates how the up-down control will position the up and down buttons relative to its edit box.")>
Public Property UpDownAlign As LeftRightAlignment
Visual Basic (Usage) Copy Code
Dim instance As UpDownBase
Dim value As LeftRightAlignment

instance.UpDownAlign = value

value = instance.UpDownAlign
C#
[LocalizableAttribute(true)]
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Indicates how the up-down control will position the up and down buttons relative to its edit box.")]
public LeftRightAlignment UpDownAlign {get; set;}
Managed Extensions for C++
[LocalizableAttribute(true)]
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Indicates how the up-down control will position the up and down buttons relative to its edit box.")]
public: __property LeftRightAlignment get_UpDownAlign();
public: __property void set_UpDownAlign(
   LeftRightAlignment value
);
C++/CLI
[LocalizableAttribute(true)]
[SRCategoryAttribute("Appearance")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("Indicates how the up-down control will position the up and down buttons relative to its edit box.")]
public:
property LeftRightAlignment UpDownAlign {
   LeftRightAlignment get();
   void set (LeftRightAlignmentvalue);
}

Exceptions

Exception | Description
InvalidEnumArgumentException | The value assigned is not one of the LeftRightAlignment values.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

UpDownBase Class
UpDownBase Members


UserControl Class

[image]
Gizmox.WebGUI.Forms
UserControl Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : UserControl Class

Provides an empty control that can be used to create other controls.

Object Model

Syntax

Visual Basic (Declaration)
<DesignTimeControllerAttribute()>
<DesignerCategoryAttribute("UserControl")>
<MetadataTagAttribute("UC")>
<SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableDockPanel, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")>
<DefaultEventAttribute("Load")>
<DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IRootDesigner, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089", DesignerTypeName="Gizmox.WebGUI.Common.Design.UserControlDocumentDesigner, Gizmox.WebGUI.Common.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=ea5dfe57c8eb7edd")>
<ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
Public Class UserControl
   Inherits ContainerControl
   Implements IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IUserControl, IBindableComponent, IContainerControl, IArrangedElement
Visual Basic (Usage) Copy Code
Dim instance As UserControl
C#
[DesignTimeControllerAttribute()]
[DesignerCategoryAttribute("UserControl")]
[MetadataTagAttribute("UC")]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableDockPanel, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[DefaultEventAttribute("Load")]
[DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IRootDesigner, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089", DesignerTypeName="Gizmox.WebGUI.Common.Design.UserControlDocumentDesigner, Gizmox.WebGUI.Common.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=ea5dfe57c8eb7edd")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
public class UserControl : ContainerControl, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IUserControl, IBindableComponent, IContainerControl, IArrangedElement
Managed Extensions for C++
[DesignTimeControllerAttribute()]
[DesignerCategoryAttribute("UserControl")]
[MetadataTagAttribute("UC")]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableDockPanel, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[DefaultEventAttribute("Load")]
[DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IRootDesigner, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089", DesignerTypeName="Gizmox.WebGUI.Common.Design.UserControlDocumentDesigner, Gizmox.WebGUI.Common.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=ea5dfe57c8eb7edd")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
public __gc class UserControl : public ContainerControl, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IUserControl, IBindableComponent, IContainerControl, IArrangedElement
C++/CLI
[DesignTimeControllerAttribute()]
[DesignerCategoryAttribute("UserControl")]
[MetadataTagAttribute("UC")]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableDockPanel, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[DefaultEventAttribute("Load")]
[DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IRootDesigner, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089", DesignerTypeName="Gizmox.WebGUI.Common.Design.UserControlDocumentDesigner, Gizmox.WebGUI.Common.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=ea5dfe57c8eb7edd")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
public ref class UserControl : public ContainerControl, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IUserControl, IBindableComponent, IContainerControl, IArrangedElement

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.ScrollableControl
Gizmox.WebGUI.Forms.ContainerControl
Gizmox.WebGUI.Forms.UserControl
Gizmox.WebGUI.Forms.Controls.ItemChooser
Gizmox.WebGUI.Forms.RibbonBar

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

UserControl Members
Gizmox.WebGUI.Forms Namespace


UserControl Class Members

[image]
Gizmox.WebGUI.Forms
UserControl Class Members
See Also Fields Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : UserControl Class

The following tables list the members exposed by UserControl.

Public Constructors

 | Name | Description
Public Constructor | UserControl Constructor | Initializes a new instance of the UserControl class.
Top

Public Fields

 | Name | Description
Public Field | mblnIsLoaded | Gets a value indicating whether the instance of UserControl is loaded.
Top

Public Properties

 | Name | Description
Public Property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl)
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl)
Public Property | AutoSize | Overridden.
Public Property | AutoSizeMode | Indicates the automatic sizing behavior of the control.
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from ContainerControl)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Components | (Inherited from ContainerControl)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Overridden. Gets the context.
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Overridden. Gets a value indicating whether this control has controls.
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Control)
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Protected Property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl)
Top

Public Methods

 | Name | Description
Public Method | Add | (Inherited from ContainerControl)
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from ContainerControl)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | Remove | (Inherited from ContainerControl)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Control)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from ScrollableControl)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Overridden. Raises the CreateControl event.
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLoad | Raises the Load event.
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | Overridden. Renders the specified obj context.
Protected Method | RenderAttributes | Renders the scrollable attribute (Inherited from ScrollableControl)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | Load | Occurs before the control becomes visible for the first time.
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

UserControl Class
Gizmox.WebGUI.Forms Namespace


UserControl Constructor

[image]
Gizmox.WebGUI.Forms
UserControl Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > UserControl Class : UserControl Constructor

Initializes a new instance of the UserControl class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As UserControl()
C#
public UserControl()
Managed Extensions for C++
public: UserControl();
C++/CLI
public:
UserControl();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

UserControl Class
UserControl Members


UserControl Class Methods

[image]
Gizmox.WebGUI.Forms
UserControl Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : UserControl Class

For a list of all members of this type, see UserControl members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from ContainerControl)
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from ContainerControl)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | Remove | (Inherited from ContainerControl)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Control)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from ScrollableControl)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Overridden. Raises the CreateControl event.
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLoad | Raises the Load event.
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | Overridden. Renders the specified obj context.
Protected Method | RenderAttributes | Renders the scrollable attribute (Inherited from ScrollableControl)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

See Also

Reference

UserControl Class
Gizmox.WebGUI.Forms Namespace


OnCreateControl Method

[image]
Gizmox.WebGUI.Forms
OnCreateControl Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > UserControl Class : OnCreateControl Method

Raises the CreateControl event.

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overrides Sub OnCreateControl()
Visual Basic (Usage) Copy Code
Dim instance As UserControl

instance.OnCreateControl()
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected override void OnCreateControl()
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: void OnCreateControl(); override
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
void OnCreateControl(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

UserControl Class
UserControl Members


OnLoad Method

[image]
Gizmox.WebGUI.Forms
OnLoad Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > UserControl Class : OnLoad Method

e
An EventArgs that contains the event data.
Raises the Load event.

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnLoad( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As UserControl
Dim e As EventArgs

instance.OnLoad(e)
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnLoad(
   EventArgs e
)
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnLoad(
   EventArgs* e
)
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnLoad(
   EventArgs^ e
)

Parameters

e
An EventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

UserControl Class
UserControl Members


Render Method

[image]
Gizmox.WebGUI.Forms
Render Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > UserControl Class : Render Method

objContext
objWriter
lngRequestID
Renders the specified obj context.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub Render( _
   ByVal objContext As IContext, _
   ByVal objWriter As IResponseWriter, _
   ByVal lngRequestID As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As UserControl
Dim objContext As IContext
Dim objWriter As IResponseWriter
Dim lngRequestID As Long

instance.Render(objContext, objWriter, lngRequestID)
C#
protected override void Render(
   IContext objContext,
   IResponseWriter objWriter,
   long lngRequestID
)
Managed Extensions for C++
protected: void Render(
   IContext* objContext,
   IResponseWriter* objWriter,
   long lngRequestID
) override
C++/CLI
protected:
void Render(
   IContext^ objContext,
   IResponseWriter^ objWriter,
   long long lngRequestID
) override

Parameters

objContext
objWriter
lngRequestID

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

UserControl Class
UserControl Members


UserControl Class Properties

[image]
Gizmox.WebGUI.Forms
UserControl Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : UserControl Class

For a list of all members of this type, see UserControl members.

Public Properties

 | Name | Description
Public Property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl)
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl)
Public Property | AutoSize | Overridden.
Public Property | AutoSizeMode | Indicates the automatic sizing behavior of the control.
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from ContainerControl)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Components | (Inherited from ContainerControl)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Overridden. Gets the context.
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Overridden. Gets a value indicating whether this control has controls.
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Control)
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Protected Property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl)
Top

See Also

Reference

UserControl Class
Gizmox.WebGUI.Forms Namespace


AutoSize Property

[image]
Gizmox.WebGUI.Forms
AutoSize Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > UserControl Class : AutoSize Property

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(True)>
<EditorBrowsableAttribute()>
Public Overrides Property AutoSize As Boolean
Visual Basic (Usage) Copy Code
Dim instance As UserControl
Dim value As Boolean

instance.AutoSize = value

value = instance.AutoSize
C#
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(true)]
[EditorBrowsableAttribute()]
public override bool AutoSize {get; set;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(true)]
[EditorBrowsableAttribute()]
public: __property bool get_AutoSize() override;
public: __property void set_AutoSize(
   bool value
) override;
C++/CLI
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(true)]
[EditorBrowsableAttribute()]
public:
property bool AutoSize {
   bool get() override;
   void set (boolvalue) override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

UserControl Class
UserControl Members


AutoSizeMode Property

[image]
Gizmox.WebGUI.Forms
AutoSizeMode Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > UserControl Class : AutoSizeMode Property

Indicates the automatic sizing behavior of the control.

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
<EditorBrowsableAttribute()>
<BrowsableAttribute(True)>
Public Overridable Property AutoSizeMode As AutoSizeMode
Visual Basic (Usage) Copy Code
Dim instance As UserControl
Dim value As AutoSizeMode

instance.AutoSizeMode = value

value = instance.AutoSizeMode
C#
[DesignerSerializationVisibilityAttribute()]
[EditorBrowsableAttribute()]
[BrowsableAttribute(true)]
public virtual AutoSizeMode AutoSizeMode {get; set;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
[EditorBrowsableAttribute()]
[BrowsableAttribute(true)]
public: __property virtual AutoSizeMode get_AutoSizeMode();
public: __property virtual void set_AutoSizeMode(
   AutoSizeMode value
);
C++/CLI
[DesignerSerializationVisibilityAttribute()]
[EditorBrowsableAttribute()]
[BrowsableAttribute(true)]
public:
virtual property AutoSizeMode AutoSizeMode {
   AutoSizeMode get();
   void set (AutoSizeModevalue);
}

Exceptions

Exception | Description
InvalidEnumArgumentException | The specified value when setting this property is not a valid AutoSizeMode values.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

UserControl Class
UserControl Members


Context Property

[image]
Gizmox.WebGUI.Forms
Context Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > UserControl Class : Context Property

Gets the context.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Context As IContext
Visual Basic (Usage) Copy Code
Dim instance As UserControl
Dim value As IContext

value = instance.Context
C#
public override IContext Context {get;}
Managed Extensions for C++
public: __property IContext* get_Context() override;
C++/CLI
public:
property IContext^ Context {
   IContext^ get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

UserControl Class
UserControl Members


HasControls Property

[image]
Gizmox.WebGUI.Forms
HasControls Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > UserControl Class : HasControls Property

Gets a value indicating whether this control has controls.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property HasControls As Boolean
Visual Basic (Usage) Copy Code
Dim instance As UserControl
Dim value As Boolean

value = instance.HasControls
C#
public override bool HasControls {get;}
Managed Extensions for C++
public: __property bool get_HasControls() override;
C++/CLI
public:
property bool HasControls {
   bool get() override;
}

Return Value

true if this control has controls; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

UserControl Class
UserControl Members


UserControl Class Fields

[image]
Gizmox.WebGUI.Forms
UserControl Class Fields
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : UserControl Class

For a list of all members of this type, see UserControl members.

Public Fields

 | Name | Description
Public Field | mblnIsLoaded | Gets a value indicating whether the instance of UserControl is loaded.
Top

See Also

Reference

UserControl Class
Gizmox.WebGUI.Forms Namespace


mblnIsLoaded Field

[image]
Gizmox.WebGUI.Forms
mblnIsLoaded Field
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > UserControl Class : mblnIsLoaded Field

Gets a value indicating whether the instance of UserControl is loaded.

Syntax

Visual Basic (Declaration)
Public mblnIsLoaded As Boolean
Visual Basic (Usage) Copy Code
Dim instance As UserControl
Dim value As Boolean

value = instance.mblnIsLoaded

instance.mblnIsLoaded = value
C#
public bool mblnIsLoaded
Managed Extensions for C++
public: bool mblnIsLoaded
C++/CLI
public:
bool mblnIsLoaded

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

UserControl Class
UserControl Members


UserControl Class Events

[image]
Gizmox.WebGUI.Forms
UserControl Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : UserControl Class

For a list of all members of this type, see UserControl members.

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | Load | Occurs before the control becomes visible for the first time.
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

UserControl Class
Gizmox.WebGUI.Forms Namespace


Load Event

[image]
Gizmox.WebGUI.Forms
Load Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > UserControl Class : Load Event

Occurs before the control becomes visible for the first time.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs whenever the user control loads.")>
<SRCategoryAttribute("Behavior")>
Public Event Load() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As UserControl
Dim handler As EventHandler

AddHandler instance.Load, handler
C#
[SRDescriptionAttribute("Occurs whenever the user control loads.")]
[SRCategoryAttribute("Behavior")]
public event EventHandler Load()
Managed Extensions for C++
[SRDescriptionAttribute("Occurs whenever the user control loads.")]
[SRCategoryAttribute("Behavior")]
public: __event EventHandler* Load
C++/CLI
[SRDescriptionAttribute("Occurs whenever the user control loads.")]
[SRCategoryAttribute("Behavior")]
public:
event EventHandler^ Load

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

UserControl Class
UserControl Members


WGSite Class

[image]
Gizmox.WebGUI.Forms
WGSite Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : WGSite Class

Syntax

Visual Basic (Declaration)
Public Class WGSite
Visual Basic (Usage) Copy Code
Dim instance As WGSite
C#
public class WGSite
Managed Extensions for C++
public __gc class WGSite
C++/CLI
public ref class WGSite

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.WGSite

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

WGSite Members
Gizmox.WebGUI.Forms Namespace


WGSite Class Members

[image]
Gizmox.WebGUI.Forms
WGSite Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : WGSite Class

The following tables list the members exposed by WGSite.

Public Constructors

 | Name | Description
Public Constructor | WGSite Constructor |
Top

Public Properties

 | Name | Description
Public Property | Component |
Public Property | Container |
Public Property | DesignMode |
Public Property | Name |
Top

Public Methods

 | Name | Description
Public Method | GetService |
Top

See Also

Reference

WGSite Class
Gizmox.WebGUI.Forms Namespace


WGSite Constructor

[image]
Gizmox.WebGUI.Forms
WGSite Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > WGSite Class : WGSite Constructor

objContainer
objComponent

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal objContainer As IContainer, _
   ByVal objComponent As IComponent _
)
Visual Basic (Usage) Copy Code
Dim objContainer As IContainer
Dim objComponent As IComponent

Dim instance As WGSite(objContainer, objComponent)
C#
public WGSite(
   IContainer objContainer,
   IComponent objComponent
)
Managed Extensions for C++
public: WGSite(
   IContainer* objContainer,
   IComponent* objComponent
)
C++/CLI
public:
WGSite(
   IContainer^ objContainer,
   IComponent^ objComponent
)

Parameters

objContainer
objComponent

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGSite Class
WGSite Members


WGSite Class Methods

[image]
Gizmox.WebGUI.Forms
WGSite Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : WGSite Class

For a list of all members of this type, see WGSite members.

Public Methods

 | Name | Description
Public Method | GetService |
Top

See Also

Reference

WGSite Class
Gizmox.WebGUI.Forms Namespace


GetService Method

[image]
Gizmox.WebGUI.Forms
GetService Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > WGSite Class : GetService Method

serviceType

Syntax

Visual Basic (Declaration)
Public Function GetService( _
   ByVal serviceType As Type _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As WGSite
Dim serviceType As Type
Dim value As Object

value = instance.GetService(serviceType)
C#
public object GetService(
   Type serviceType
)
Managed Extensions for C++
public: Object* GetService(
   Type* serviceType
)
C++/CLI
public:
Object^ GetService(
   Type^ serviceType
)

Parameters

serviceType

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGSite Class
WGSite Members


WGSite Class Properties

[image]
Gizmox.WebGUI.Forms
WGSite Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : WGSite Class

For a list of all members of this type, see WGSite members.

Public Properties

 | Name | Description
Public Property | Component |
Public Property | Container |
Public Property | DesignMode |
Public Property | Name |
Top

See Also

Reference

WGSite Class
Gizmox.WebGUI.Forms Namespace


Component Property

[image]
Gizmox.WebGUI.Forms
Component Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > WGSite Class : Component Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Component As IComponent
Visual Basic (Usage) Copy Code
Dim instance As WGSite
Dim value As IComponent

value = instance.Component
C#
public IComponent Component {get;}
Managed Extensions for C++
public: __property IComponent* get_Component();
C++/CLI
public:
property IComponent^ Component {
   IComponent^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGSite Class
WGSite Members


Container Property

[image]
Gizmox.WebGUI.Forms
Container Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > WGSite Class : Container Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Container As IContainer
Visual Basic (Usage) Copy Code
Dim instance As WGSite
Dim value As IContainer

value = instance.Container
C#
public IContainer Container {get;}
Managed Extensions for C++
public: __property IContainer* get_Container();
C++/CLI
public:
property IContainer^ Container {
   IContainer^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGSite Class
WGSite Members


DesignMode Property

[image]
Gizmox.WebGUI.Forms
DesignMode Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > WGSite Class : DesignMode Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DesignMode As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WGSite
Dim value As Boolean

value = instance.DesignMode
C#
public bool DesignMode {get;}
Managed Extensions for C++
public: __property bool get_DesignMode();
C++/CLI
public:
property bool DesignMode {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGSite Class
WGSite Members


Name Property

[image]
Gizmox.WebGUI.Forms
Name Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > WGSite Class : Name Property

Syntax

Visual Basic (Declaration)
Public Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As WGSite
Dim value As String

instance.Name = value

value = instance.Name
C#
public string Name {get; set;}
Managed Extensions for C++
public: __property string* get_Name();
public: __property void set_Name(
   string* value
);
C++/CLI
public:
property String^ Name {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGSite Class
WGSite Members


XamlBox Class

[image]
Gizmox.WebGUI.Forms
XamlBox Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : XamlBox Class

A html control

Object Model

Syntax

Visual Basic (Declaration)
<SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableXamlBox, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")>
<MetadataTagAttribute("XB")>
<ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<ToolboxBitmapAttribute()>
<ToolboxItemCategoryAttribute("Host Controls")>
Public Class XamlBox
   Inherits Control
   Implements IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IGatewayControl, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Visual Basic (Usage) Copy Code
Dim instance As XamlBox
C#
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableXamlBox, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[MetadataTagAttribute("XB")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ToolboxBitmapAttribute()]
[ToolboxItemCategoryAttribute("Host Controls")]
public class XamlBox : Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IGatewayControl, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Managed Extensions for C++
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableXamlBox, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[MetadataTagAttribute("XB")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ToolboxBitmapAttribute()]
[ToolboxItemCategoryAttribute("Host Controls")]
public __gc class XamlBox : public Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IGatewayControl, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
C++/CLI
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableXamlBox, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[MetadataTagAttribute("XB")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ToolboxBitmapAttribute()]
[ToolboxItemCategoryAttribute("Host Controls")]
public ref class XamlBox : public Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IGatewayControl, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.XamlBox

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

XamlBox Members
Gizmox.WebGUI.Forms Namespace


XamlBox Class Members

[image]
Gizmox.WebGUI.Forms
XamlBox Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : XamlBox Class

The following tables list the members exposed by XamlBox.

Public Constructors

 | Name | Description
Public Constructor | XamlBox Constructor | Creates a new HtmlBox instance.
Top

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | Path | Gets or sets the path to the Xaml code.
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | Resource | Gets or sets a resource that contains Xaml.
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Control)
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | Type | Gets the html box type.
Public Property | Url | Gets or sets the URL to the Xaml code.
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Public Property | Windowless | Gets or sets a flag indicating if the Xaml control should be windowless.
Public Property | Xaml | Gets or sets the Xaml code of the control.
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | Overridden.
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | Overridden.
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetGatewayHandler |
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. Overridden.
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Control)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from Control)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Control)
Protected Method | RenderAttributes | Overridden.
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

XamlBox Class
Gizmox.WebGUI.Forms Namespace


XamlBox Constructor

[image]
Gizmox.WebGUI.Forms
XamlBox Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > XamlBox Class : XamlBox Constructor

Creates a new HtmlBox instance.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As XamlBox()
C#
public XamlBox()
Managed Extensions for C++
public: XamlBox();
C++/CLI
public:
XamlBox();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

XamlBox Class
XamlBox Members


XamlBox Class Methods

[image]
Gizmox.WebGUI.Forms
XamlBox Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : XamlBox Class

For a list of all members of this type, see XamlBox members.

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetGatewayHandler |
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. Overridden.
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Control)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from Control)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Control)
Protected Method | RenderAttributes | Overridden.
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

See Also

Reference

XamlBox Class
Gizmox.WebGUI.Forms Namespace


GetGatewayHandler Method

[image]
Gizmox.WebGUI.Forms
GetGatewayHandler Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > XamlBox Class : GetGatewayHandler Method

objContext
strAction

Syntax

Visual Basic (Declaration)
Public Function GetGatewayHandler( _
   ByVal objContext As IContext, _
   ByVal strAction As String _
) As IGatewayHandler
Visual Basic (Usage) Copy Code
Dim instance As XamlBox
Dim objContext As IContext
Dim strAction As String
Dim value As IGatewayHandler

value = instance.GetGatewayHandler(objContext, strAction)
C#
public IGatewayHandler GetGatewayHandler(
   IContext objContext,
   string strAction
)
Managed Extensions for C++
public: IGatewayHandler* GetGatewayHandler(
   IContext* objContext,
   string* strAction
)
C++/CLI
public:
IGatewayHandler^ GetGatewayHandler(
   IContext^ objContext,
   String^ strAction
)

Parameters

objContext
strAction

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

XamlBox Class
XamlBox Members


RenderAttributes Method

[image]
Gizmox.WebGUI.Forms
RenderAttributes Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > XamlBox Class : RenderAttributes Method

objContext
objWriter

Syntax

Visual Basic (Declaration)
Protected Overrides Sub RenderAttributes( _
   ByVal objContext As IContext, _
   ByVal objWriter As IAttributeWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As XamlBox
Dim objContext As IContext
Dim objWriter As IAttributeWriter

instance.RenderAttributes(objContext, objWriter)
C#
protected override void RenderAttributes(
   IContext objContext,
   IAttributeWriter objWriter
)
Managed Extensions for C++
protected: void RenderAttributes(
   IContext* objContext,
   IAttributeWriter* objWriter
) override
C++/CLI
protected:
void RenderAttributes(
   IContext^ objContext,
   IAttributeWriter^ objWriter
) override

Parameters

objContext
objWriter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

XamlBox Class
XamlBox Members


Update Method

[image]
Gizmox.WebGUI.Forms
Update Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > XamlBox Class : Update Method

Overload List

Overload | Description
Update() |
Update(Boolean) | (Inherited from RegisteredComponent)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

XamlBox Class
XamlBox Members


Update() Method

[image]
Gizmox.WebGUI.Forms
Update() Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > XamlBox Class > Update Method : Update() Method

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Sub Update()
Visual Basic (Usage) Copy Code
Dim instance As XamlBox

instance.Update()
C#
public override void Update()
Managed Extensions for C++
public: void Update(); override
C++/CLI
public:
void Update(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

XamlBox Class
XamlBox Members
Overload List


XamlBox Class Properties

[image]
Gizmox.WebGUI.Forms
XamlBox Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : XamlBox Class

For a list of all members of this type, see XamlBox members.

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | Path | Gets or sets the path to the Xaml code.
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | Resource | Gets or sets a resource that contains Xaml.
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Control)
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | Type | Gets the html box type.
Public Property | Url | Gets or sets the URL to the Xaml code.
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Public Property | Windowless | Gets or sets a flag indicating if the Xaml control should be windowless.
Public Property | Xaml | Gets or sets the Xaml code of the control.
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | Overridden.
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | Overridden.
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

See Also

Reference

XamlBox Class
Gizmox.WebGUI.Forms Namespace


DefaultBackColor Property

[image]
Gizmox.WebGUI.Forms
DefaultBackColor Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > XamlBox Class : DefaultBackColor Property

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property DefaultBackColor As Color
Visual Basic (Usage) Copy Code
Dim instance As XamlBox
Dim value As Color

value = instance.DefaultBackColor
C#
protected override Color DefaultBackColor {get;}
Managed Extensions for C++
protected: __property Color get_DefaultBackColor() override;
C++/CLI
protected:
property Color DefaultBackColor {
   Color get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

XamlBox Class
XamlBox Members


DefaultBorderStyle Property

[image]
Gizmox.WebGUI.Forms
DefaultBorderStyle Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > XamlBox Class : DefaultBorderStyle Property

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property DefaultBorderStyle As BorderStyle
Visual Basic (Usage) Copy Code
Dim instance As XamlBox
Dim value As BorderStyle

value = instance.DefaultBorderStyle
C#
protected override BorderStyle DefaultBorderStyle {get;}
Managed Extensions for C++
protected: __property BorderStyle get_DefaultBorderStyle() override;
C++/CLI
protected:
property BorderStyle DefaultBorderStyle {
   BorderStyle get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

XamlBox Class
XamlBox Members


Path Property

[image]
Gizmox.WebGUI.Forms
Path Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > XamlBox Class : Path Property

Gets or sets the path to the Xaml code.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property Path As String
Visual Basic (Usage) Copy Code
Dim instance As XamlBox
Dim value As String

instance.Path = value

value = instance.Path
C#
[DefaultValueAttribute()]
public string Path {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property string* get_Path();
public: __property void set_Path(
   string* value
);
C++/CLI
[DefaultValueAttribute()]
public:
property String^ Path {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

XamlBox Class
XamlBox Members


Resource Property

[image]
Gizmox.WebGUI.Forms
Resource Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > XamlBox Class : Resource Property

Gets or sets a resource that contains Xaml.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property Resource As ResourceHandle
Visual Basic (Usage) Copy Code
Dim instance As XamlBox
Dim value As ResourceHandle

instance.Resource = value

value = instance.Resource
C#
[DefaultValueAttribute()]
public ResourceHandle Resource {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property ResourceHandle* get_Resource();
public: __property void set_Resource(
   ResourceHandle* value
);
C++/CLI
[DefaultValueAttribute()]
public:
property ResourceHandle^ Resource {
   ResourceHandle^ get();
   void set (ResourceHandle^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

XamlBox Class
XamlBox Members


Type Property

[image]
Gizmox.WebGUI.Forms
Type Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > XamlBox Class : Type Property

Gets the html box type.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Type As XamlBoxType
Visual Basic (Usage) Copy Code
Dim instance As XamlBox
Dim value As XamlBoxType

value = instance.Type
C#
public XamlBoxType Type {get;}
Managed Extensions for C++
public: __property XamlBoxType get_Type();
C++/CLI
public:
property XamlBoxType Type {
   XamlBoxType get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

XamlBox Class
XamlBox Members


Url Property

[image]
Gizmox.WebGUI.Forms
Url Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > XamlBox Class : Url Property

Gets or sets the URL to the Xaml code.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property Url As String
Visual Basic (Usage) Copy Code
Dim instance As XamlBox
Dim value As String

instance.Url = value

value = instance.Url
C#
[DefaultValueAttribute()]
public string Url {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property string* get_Url();
public: __property void set_Url(
   string* value
);
C++/CLI
[DefaultValueAttribute()]
public:
property String^ Url {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

XamlBox Class
XamlBox Members


Windowless Property

[image]
Gizmox.WebGUI.Forms
Windowless Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > XamlBox Class : Windowless Property

Gets or sets a flag indicating if the Xaml control should be windowless.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property Windowless As Boolean
Visual Basic (Usage) Copy Code
Dim instance As XamlBox
Dim value As Boolean

instance.Windowless = value

value = instance.Windowless
C#
[DefaultValueAttribute()]
public bool Windowless {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property bool get_Windowless();
public: __property void set_Windowless(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
public:
property bool Windowless {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

XamlBox Class
XamlBox Members


Xaml Property

[image]
Gizmox.WebGUI.Forms
Xaml Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > XamlBox Class : Xaml Property

Gets or sets the Xaml code of the control.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property Xaml As String
Visual Basic (Usage) Copy Code
Dim instance As XamlBox
Dim value As String

instance.Xaml = value

value = instance.Xaml
C#
[DefaultValueAttribute()]
public string Xaml {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property string* get_Xaml();
public: __property void set_Xaml(
   string* value
);
C++/CLI
[DefaultValueAttribute()]
public:
property String^ Xaml {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

XamlBox Class
XamlBox Members


XamlBox.XamlGateway Class

[image]
Gizmox.WebGUI.Forms
XamlBox.XamlGateway Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : XamlBox.XamlGateway Class

Xaml gateway handler

Object Model

Syntax

Visual Basic (Declaration)
Public Class XamlBox.XamlGateway
   Inherits GatewayWriter
   Implements IGatewayHandler
Visual Basic (Usage) Copy Code
Dim instance As XamlBox.XamlGateway
C#
public class XamlBox.XamlGateway : GatewayWriter, IGatewayHandler
Managed Extensions for C++
public __gc class XamlBox.XamlGateway : public GatewayWriter, IGatewayHandler
C++/CLI
public ref class XamlBox.XamlGateway : public GatewayWriter, IGatewayHandler

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Common.Gateways.GatewayHandler
Gizmox.WebGUI.Common.Gateways.GatewayWriter
Gizmox.WebGUI.Forms.XamlBox.XamlGateway

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

XamlBox.XamlGateway Members
Gizmox.WebGUI.Forms Namespace


XamlBox.XamlGateway Class Members

[image]
Gizmox.WebGUI.Forms
XamlBox.XamlGateway Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : XamlBox.XamlGateway Class

The following tables list the members exposed by XamlBox.XamlGateway.

Public Constructors

 | Name | Description
Public Constructor | XamlBox.XamlGateway Constructor |
Top

Protected Properties

 | Name | Description
Protected Property | ContentType | (Inherited from Gizmox.WebGUI.Common.Gateways.GatewayWriter)
Protected Property | GatewayComponent | (Inherited from Gizmox.WebGUI.Common.Gateways.GatewayWriter)
Top

Public Methods

 | Name | Description
Public Method | ProcessGatewayRequest | (Inherited from Gizmox.WebGUI.Common.Gateways.GatewayWriter)
Top

Protected Methods

 | Name | Description
Protected Method | GetFormParam | (Inherited from Gizmox.WebGUI.Common.Gateways.GatewayWriter)
Protected Method | GetQueryParam | (Inherited from Gizmox.WebGUI.Common.Gateways.GatewayWriter)
Protected Method | GetRequestParam | (Inherited from Gizmox.WebGUI.Common.Gateways.GatewayWriter)
Protected Method | ProcessRequest | Overridden. Processes the request.
Protected Method | SetContentDisposition | (Inherited from Gizmox.WebGUI.Common.Gateways.GatewayWriter)
Protected Method | Write | Overloaded. (Inherited from Gizmox.WebGUI.Common.Gateways.GatewayWriter)
Protected Method | WriteFile | (Inherited from Gizmox.WebGUI.Common.Gateways.GatewayWriter)
Top

See Also

Reference

XamlBox.XamlGateway Class
Gizmox.WebGUI.Forms Namespace


XamlBox.XamlGateway Constructor

[image]
Gizmox.WebGUI.Forms
XamlBox.XamlGateway Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > XamlBox.XamlGateway Class : XamlBox.XamlGateway Constructor

objXamlBox

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal objXamlBox As XamlBox _
)
Visual Basic (Usage) Copy Code
Dim objXamlBox As XamlBox

Dim instance As XamlBox.XamlGateway(objXamlBox)
C#
public XamlBox.XamlGateway(
   XamlBox objXamlBox
)
Managed Extensions for C++
public: XamlBox.XamlGateway(
   XamlBox* objXamlBox
)
C++/CLI
public:
XamlBox.XamlGateway(
   XamlBox^ objXamlBox
)

Parameters

objXamlBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

XamlBox.XamlGateway Class
XamlBox.XamlGateway Members


XamlBox.XamlGateway Class Methods

[image]
Gizmox.WebGUI.Forms
XamlBox.XamlGateway Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : XamlBox.XamlGateway Class

For a list of all members of this type, see XamlBox.XamlGateway members.

Public Methods

 | Name | Description
Public Method | ProcessGatewayRequest | (Inherited from Gizmox.WebGUI.Common.Gateways.GatewayWriter)
Top

Protected Methods

 | Name | Description
Protected Method | GetFormParam | (Inherited from Gizmox.WebGUI.Common.Gateways.GatewayWriter)
Protected Method | GetQueryParam | (Inherited from Gizmox.WebGUI.Common.Gateways.GatewayWriter)
Protected Method | GetRequestParam | (Inherited from Gizmox.WebGUI.Common.Gateways.GatewayWriter)
Protected Method | ProcessRequest | Overridden. Processes the request.
Protected Method | SetContentDisposition | (Inherited from Gizmox.WebGUI.Common.Gateways.GatewayWriter)
Protected Method | Write | Overloaded. (Inherited from Gizmox.WebGUI.Common.Gateways.GatewayWriter)
Protected Method | WriteFile | (Inherited from Gizmox.WebGUI.Common.Gateways.GatewayWriter)
Top

See Also

Reference

XamlBox.XamlGateway Class
Gizmox.WebGUI.Forms Namespace


ProcessRequest Method

[image]
Gizmox.WebGUI.Forms
ProcessRequest Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > XamlBox.XamlGateway Class : ProcessRequest Method

Processes the request.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub ProcessRequest()
Visual Basic (Usage) Copy Code
Dim instance As XamlBox.XamlGateway

instance.ProcessRequest()
C#
protected override void ProcessRequest()
Managed Extensions for C++
protected: void ProcessRequest(); override
C++/CLI
protected:
void ProcessRequest(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

XamlBox.XamlGateway Class
XamlBox.XamlGateway Members


AnchorStyles Enumeration

[image]
Gizmox.WebGUI.Forms
AnchorStyles Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : AnchorStyles Enumeration

Control anchoring styles

Syntax

Visual Basic (Declaration)
<EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.AnchorEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")>
<FlagsAttribute()>
Public Enum AnchorStyles
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As AnchorStyles
C#
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.AnchorEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[FlagsAttribute()]
public enum AnchorStyles : Enum
Managed Extensions for C++
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.AnchorEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[FlagsAttribute()]
__value public enum AnchorStyles : public Enum
C++/CLI
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.AnchorEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[FlagsAttribute()]
public enum class AnchorStyles : public Enum

Members

Member | Description
Bottom |
Left |
None |
Right |
Top |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.AnchorStyles

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


AutoCompleteMode Enumeration

[image]
Gizmox.WebGUI.Forms
AutoCompleteMode Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : AutoCompleteMode Enumeration

Specifies the mode for the automatic completion feature used in the ComboBox and TextBox controls.

Syntax

Visual Basic (Declaration)
Public Enum AutoCompleteMode
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As AutoCompleteMode
C#
public enum AutoCompleteMode : Enum
Managed Extensions for C++
__value public enum AutoCompleteMode : public Enum
C++/CLI
public enum class AutoCompleteMode : public Enum

Members

Member | Description
None | Disables the automatic completion feature for the ComboBox and TextBox controls.
Suggest | Displays the auxiliary drop-down list associated with the edit control. This drop-down is populated with one or more suggested completion strings.
Append | Appends the remainder of the most likely candidate string to the existing characters, highlighting the appended characters.
SuggestAppend | Applies both Suggest and Append options.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.AutoCompleteMode

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


AutoCompleteSource Enumeration

[image]
Gizmox.WebGUI.Forms
AutoCompleteSource Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : AutoCompleteSource Enumeration

Specifies the source for ComboBox and TextBox automatic completion functionality.

Syntax

Visual Basic (Declaration)
Public Enum AutoCompleteSource
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As AutoCompleteSource
C#
public enum AutoCompleteSource : Enum
Managed Extensions for C++
__value public enum AutoCompleteSource : public Enum
C++/CLI
public enum class AutoCompleteSource : public Enum

Members

Member | Description
AllSystemSources | Specifies the equivalent of FileSystem and AllUrl as the source. This is the default value when AutoCompleteMode has been set to a value other than the default.
AllUrl | Specifies the equivalent of HistoryList and RecentlyUsedList as the source.
CustomSource | Specifies strings from a built-in AutoCompleteStringCollection as the source.
FileSystem | Specifies the file system as the source.
FileSystemDirectories | Specifies that only directory names and not file names will be automatically completed.
HistoryList | Includes the Uniform Resource Locators (URLs) in the history list.
ListItems | Specifies that the items of the ComboBox represent the source.
None | Specifies that no AutoCompleteSource is currently in use. This is the default value of AutoCompleteSource.
RecentlyUsedList | Includes the Uniform Resource Locators (URLs) in the list of those URLs most recently used.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.AutoCompleteSource

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


AutoSizeMode Enumeration

[image]
Gizmox.WebGUI.Forms
AutoSizeMode Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : AutoSizeMode Enumeration

Specifies how a control will behave when its Control.AutoSize property is enabled.

Syntax

Visual Basic (Declaration)
Public Enum AutoSizeMode
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As AutoSizeMode
C#
public enum AutoSizeMode : Enum
Managed Extensions for C++
__value public enum AutoSizeMode : public Enum
C++/CLI
public enum class AutoSizeMode : public Enum

Members

Member | Description
GrowAndShrink |
GrowOnly |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.AutoSizeMode

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


BindingCompleteContext Enumeration

[image]
Gizmox.WebGUI.Forms
BindingCompleteContext Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : BindingCompleteContext Enumeration

Specifies the direction of the binding operation.

Syntax

Visual Basic (Declaration)
Public Enum BindingCompleteContext
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As BindingCompleteContext
C#
public enum BindingCompleteContext : Enum
Managed Extensions for C++
__value public enum BindingCompleteContext : public Enum
C++/CLI
public enum class BindingCompleteContext : public Enum

Members

Member | Description
ControlUpdate |
DataSourceUpdate |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.BindingCompleteContext

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


BindingCompleteState Enumeration

[image]
Gizmox.WebGUI.Forms
BindingCompleteState Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : BindingCompleteState Enumeration

Indicates the result of a completed binding operation.

Syntax

Visual Basic (Declaration)
Public Enum BindingCompleteState
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As BindingCompleteState
C#
public enum BindingCompleteState : Enum
Managed Extensions for C++
__value public enum BindingCompleteState : public Enum
C++/CLI
public enum class BindingCompleteState : public Enum

Members

Member | Description
Success |
DataError |
Exception |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.BindingCompleteState

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


BorderStyle Enumeration

[image]
Gizmox.WebGUI.Forms
BorderStyle Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : BorderStyle Enumeration

Border style types

Syntax

Visual Basic (Declaration)
Public Enum BorderStyle
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As BorderStyle
C#
public enum BorderStyle : Enum
Managed Extensions for C++
__value public enum BorderStyle : public Enum
C++/CLI
public enum class BorderStyle : public Enum

Members

Member | Description
Clear |
FixedSingle |
Dashed |
Dotted |
Inset |
Outset |
Fixed3D |
None |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.BorderStyle

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


BoundsSpecified Enumeration

[image]
Gizmox.WebGUI.Forms
BoundsSpecified Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : BoundsSpecified Enumeration

Syntax

Visual Basic (Declaration)
Public Enum BoundsSpecified
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As BoundsSpecified
C#
public enum BoundsSpecified : Enum
Managed Extensions for C++
__value public enum BoundsSpecified : public Enum
C++/CLI
public enum class BoundsSpecified : public Enum

Members

Member | Description
All |
Height |
Location |
None |
Size |
Width |
X |
Y |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.BoundsSpecified

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


ButtonState Enumeration

[image]
Gizmox.WebGUI.Forms
ButtonState Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ButtonState Enumeration

Specifies the appearance of a button.

Syntax

Visual Basic (Declaration)
<FlagsAttribute()>
Public Enum ButtonState
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As ButtonState
C#
[FlagsAttribute()]
public enum ButtonState : Enum
Managed Extensions for C++
[FlagsAttribute()]
__value public enum ButtonState : public Enum
C++/CLI
[FlagsAttribute()]
public enum class ButtonState : public Enum

Members

Member | Description
All | All flags except Normal are set.
Checked | The button has a checked or latched appearance. Use this appearance to show that a toggle button has been pressed.
Flat | The button has a flat, two-dimensional appearance.
Inactive | The button is inactive (grayed).
Normal | The button has its normal appearance (three-dimensional).
Pushed | The button appears pressed.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.ButtonState

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


ButtonStyle Enumeration

[image]
Gizmox.WebGUI.Forms
ButtonStyle Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ButtonStyle Enumeration

Syntax

Visual Basic (Declaration)
Public Enum ButtonStyle
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As ButtonStyle
C#
public enum ButtonStyle : Enum
Managed Extensions for C++
__value public enum ButtonStyle : public Enum
C++/CLI
public enum class ButtonStyle : public Enum

Members

Member | Description
Normal |
Custom |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.ButtonStyle

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


CharacterCasing Enumeration

[image]
Gizmox.WebGUI.Forms
CharacterCasing Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : CharacterCasing Enumeration

Specifies the case of characters in a TextBox control.

Syntax

Visual Basic (Declaration)
Public Enum CharacterCasing
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As CharacterCasing
C#
public enum CharacterCasing : Enum
Managed Extensions for C++
__value public enum CharacterCasing : public Enum
C++/CLI
public enum class CharacterCasing : public Enum

Members

Member | Description
Normal |
Upper |
Lower |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.CharacterCasing

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


CheckBoxVisibility Enumeration

[image]
Gizmox.WebGUI.Forms
CheckBoxVisibility Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : CheckBoxVisibility Enumeration

Defines the node's check box - visiiblity

Syntax

Visual Basic (Declaration)
Public Enum CheckBoxVisibility
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As CheckBoxVisibility
C#
public enum CheckBoxVisibility : Enum
Managed Extensions for C++
__value public enum CheckBoxVisibility : public Enum
C++/CLI
public enum class CheckBoxVisibility : public Enum

Members

Member | Description
False |
True |
Inherited |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.CheckBoxVisibility

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


ColumnHeaderAutoResizeStyle Enumeration

[image]
Gizmox.WebGUI.Forms
ColumnHeaderAutoResizeStyle Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ColumnHeaderAutoResizeStyle Enumeration

Specifies how a column contained in a ListView should be resized.

Syntax

Visual Basic (Declaration)
Public Enum ColumnHeaderAutoResizeStyle
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As ColumnHeaderAutoResizeStyle
C#
public enum ColumnHeaderAutoResizeStyle : Enum
Managed Extensions for C++
__value public enum ColumnHeaderAutoResizeStyle : public Enum
C++/CLI
public enum class ColumnHeaderAutoResizeStyle : public Enum

Members

Member | Description
None |
HeaderSize |
ColumnContent |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.ColumnHeaderAutoResizeStyle

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


ColumnHeaderStyle Enumeration

[image]
Gizmox.WebGUI.Forms
ColumnHeaderStyle Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ColumnHeaderStyle Enumeration

Specifies the styles of the column headers in a ListView control.

Syntax

Visual Basic (Declaration)
Public Enum ColumnHeaderStyle
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As ColumnHeaderStyle
C#
public enum ColumnHeaderStyle : Enum
Managed Extensions for C++
__value public enum ColumnHeaderStyle : public Enum
C++/CLI
public enum class ColumnHeaderStyle : public Enum

Members

Member | Description
Clickable |
Nonclickable |
None |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.ColumnHeaderStyle

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


ComboBoxStyle Enumeration

[image]
Gizmox.WebGUI.Forms
ComboBoxStyle Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ComboBoxStyle Enumeration

Specifies the ComboBox style.

Syntax

Visual Basic (Declaration)
Public Enum ComboBoxStyle
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As ComboBoxStyle
C#
public enum ComboBoxStyle : Enum
Managed Extensions for C++
__value public enum ComboBoxStyle : public Enum
C++/CLI
public enum class ComboBoxStyle : public Enum

Members

Member | Description
DropDown | The text portion is editable. The user must click the arrow button to display the list portion. This is the default style.
DropDownList | The user cannot directly edit the text portion. The user must click the arrow button to display the list portion. The list displays only if ComboBox.AutoCompleteMode is AutoCompleteMode.Suggest or AutoCompleteMode.SuggestAppend.
Simple | The text portion is editable. The list portion is always visible.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.ComboBoxStyle

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


ControlStyles Enumeration

[image]
Gizmox.WebGUI.Forms
ControlStyles Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ControlStyles Enumeration

Syntax

Visual Basic (Declaration)
<FlagsAttribute()>
Public Enum ControlStyles
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As ControlStyles
C#
[FlagsAttribute()]
public enum ControlStyles : Enum
Managed Extensions for C++
[FlagsAttribute()]
__value public enum ControlStyles : public Enum
C++/CLI
[FlagsAttribute()]
public enum class ControlStyles : public Enum

Members

Member | Description
AllPaintingInWmPaint | If true, the control ignores the window message WM_ERASEBKGND to reduce flicker. This style should only be applied if the UserPaint bit is set to true.
CacheText | If true, the control keeps a copy of the text rather than getting it from the Handle each time it is needed. This style defaults to false. This behavior improves performance, but makes it difficult to keep the text synchronized.
ContainerControl | If true, the control is a container-like control.
DoubleBuffer | If true, drawing is performed in a buffer, and after it completes, the result is output to the screen. Double-buffering prevents flicker caused by the redrawing of the control. If you set DoubleBuffer to true, you should alsoset UserPaint and AllPaintingInWmPaint to true.
EnableNotifyMessage | If true, the OnNotifyMessage method is called for every message sent to the control's WndProc. This style defaults to false. EnableNotifyMessage does not work in partial trust.
FixedHeight | If true, the control has a fixed height when auto-scaled. For example, if a layout operation attempts to rescale the control to accommodate a new Font, the control's Height remains unchanged.
FixedWidth | If true, the control has a fixed width when auto-scaled. For example, if a layout operation attempts to rescale the control to accommodate a new Font, the control's Width remains unchanged.
Opaque | If true, the control is drawn opaque and the background is not painted.
OptimizedDoubleBuffer | If true, the control is first drawn to a buffer rather than directly to the screen, which can reduce flicker. If you set this property to true, you should also set the AllPaintingInWmPaint to true.
ResizeRedraw | If true, the control is redrawn when it is resized.
Selectable | If true, the control can receive focus.
StandardClick | If true, the control implements the standard Click behavior.
StandardDoubleClick | If true, the control implements the standard DoubleClick behavior. This style is ignored if the StandardClick bit is not set to true.
SupportsTransparentBackColor | If true, the control accepts a BackColor with an alpha component of less than 255 to simulate transparency. Transparency will be simulated only if the UserPaint bit is set to true and the parent control is derived from Control.
UserMouse | If true, the control does its own mouse processing, and mouse events are not handled by the operating system.
UserPaint | If true, the control paints itself rather than the operating system doing so. If false, the Paint event is not raised. This style only applies to classes derived from Control.
UseTextForAccessibility | Specifies that the value of the control's Text property, if set, determines the control's default Active Accessibility name and shortcut key.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.ControlStyles

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


ControlUpdateMode Enumeration

[image]
Gizmox.WebGUI.Forms
ControlUpdateMode Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ControlUpdateMode Enumeration

Determines when changes to a data source value get propagated to the corresponding data-bound control property.

Syntax

Visual Basic (Declaration)
Public Enum ControlUpdateMode
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As ControlUpdateMode
C#
public enum ControlUpdateMode : Enum
Managed Extensions for C++
__value public enum ControlUpdateMode : public Enum
C++/CLI
public enum class ControlUpdateMode : public Enum

Members

Member | Description
OnPropertyChanged |
Never |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.ControlUpdateMode

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


DataGridViewAdvancedCellBorderStyle Enumeration

[image]
Gizmox.WebGUI.Forms
DataGridViewAdvancedCellBorderStyle Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewAdvancedCellBorderStyle Enumeration

Specifies the border styles that can be applied to the cells of a DataGridView control.

Syntax

Visual Basic (Declaration)
Public Enum DataGridViewAdvancedCellBorderStyle
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewAdvancedCellBorderStyle
C#
public enum DataGridViewAdvancedCellBorderStyle : Enum
Managed Extensions for C++
__value public enum DataGridViewAdvancedCellBorderStyle : public Enum
C++/CLI
public enum class DataGridViewAdvancedCellBorderStyle : public Enum

Members

Member | Description
NotSet |
None |
Single |
Inset |
InsetDouble |
Outset |
OutsetDouble |
OutsetPartial |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.DataGridViewAdvancedCellBorderStyle

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


DataGridViewAutoSizeColumnMode Enumeration

[image]
Gizmox.WebGUI.Forms
DataGridViewAutoSizeColumnMode Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewAutoSizeColumnMode Enumeration

Defines values for specifying how the width of a column is adjusted.

Syntax

Visual Basic (Declaration)
Public Enum DataGridViewAutoSizeColumnMode
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewAutoSizeColumnMode
C#
public enum DataGridViewAutoSizeColumnMode : Enum
Managed Extensions for C++
__value public enum DataGridViewAutoSizeColumnMode : public Enum
C++/CLI
public enum class DataGridViewAutoSizeColumnMode : public Enum

Members

Member | Description
AllCells | The column width adjusts to fit the contents of all cells in the column, including the header cell.
AllCellsExceptHeader | The column width adjusts to fit the contents of all cells in the column, excluding the header cell.
ColumnHeader | The column width adjusts to fit the contents of the column header cell.
DisplayedCells | The column width adjusts to fit the contents of all cells in the column that are in rows currently displayed onscreen, including the header cell.
DisplayedCellsExceptHeader | The column width adjusts to fit the contents of all cells in the column that are in rows currently displayed onscreen, excluding the header cell.
Fill | The column width adjusts so that the widths of all columns exactly fills the display area of the control, requiring horizontal scrolling only to keep column widths above the DataGridViewColumn.MinimumWidth property values. Relative column widths are determined by the relative DataGridViewColumn.FillWeight property values.
None | The column width does not automatically adjust.
NotSet | The sizing behavior of the column is inherited from the DataGridView.AutoSizeColumnsMode property.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.DataGridViewAutoSizeColumnMode

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


DataGridViewAutoSizeColumnsMode Enumeration

[image]
Gizmox.WebGUI.Forms
DataGridViewAutoSizeColumnsMode Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewAutoSizeColumnsMode Enumeration

Defines values for specifying how the widths of columns are adjusted.

Syntax

Visual Basic (Declaration)
Public Enum DataGridViewAutoSizeColumnsMode
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewAutoSizeColumnsMode
C#
public enum DataGridViewAutoSizeColumnsMode : Enum
Managed Extensions for C++
__value public enum DataGridViewAutoSizeColumnsMode : public Enum
C++/CLI
public enum class DataGridViewAutoSizeColumnsMode : public Enum

Members

Member | Description
AllCells | The column widths adjust to fit the contents of all cells in the columns, including header cells.
None | The column widths do not automatically adjust.
AllCellsExceptHeader | The column widths adjust to fit the contents of all cells in the columns, excluding header cells.
ColumnHeader | The column widths adjust to fit the contents of the column header cells.
DisplayedCells | The column widths adjust to fit the contents of all cells in the columns that are in rows currently displayed onscreen, including header cells.
DisplayedCellsExceptHeader | The column widths adjust to fit the contents of all cells in the columns that are in rows currently displayed onscreen, excluding header cells.
Fill | The column widths adjust so that the widths of all columns exactly fill the display area of the control, requiring horizontal scrolling only to keep column widths above the DataGridViewColumn.MinimumWidth property values. Relative column widths are determined by the relative DataGridViewColumn.FillWeight property values.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.DataGridViewAutoSizeColumnsMode

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


DataGridViewAutoSizeRowMode Enumeration

[image]
Gizmox.WebGUI.Forms
DataGridViewAutoSizeRowMode Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewAutoSizeRowMode Enumeration

Defines values for specifying how the height of a row is adjusted.

Syntax

Visual Basic (Declaration)
Public Enum DataGridViewAutoSizeRowMode
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewAutoSizeRowMode
C#
public enum DataGridViewAutoSizeRowMode : Enum
Managed Extensions for C++
__value public enum DataGridViewAutoSizeRowMode : public Enum
C++/CLI
public enum class DataGridViewAutoSizeRowMode : public Enum

Members

Member | Description
AllCells | The row height adjusts to fit the contents of all cells in the row, including the header cell.
AllCellsExceptHeader | The row height adjusts to fit the contents of all cells in the row, excluding the header cell.
RowHeader | The row height adjusts to fit the contents of the row header.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.DataGridViewAutoSizeRowMode

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


DataGridViewAutoSizeRowsMode Enumeration

[image]
Gizmox.WebGUI.Forms
DataGridViewAutoSizeRowsMode Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewAutoSizeRowsMode Enumeration

Defines values for specifying how the heights of rows are adjusted.

Syntax

Visual Basic (Declaration)
Public Enum DataGridViewAutoSizeRowsMode
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewAutoSizeRowsMode
C#
public enum DataGridViewAutoSizeRowsMode : Enum
Managed Extensions for C++
__value public enum DataGridViewAutoSizeRowsMode : public Enum
C++/CLI
public enum class DataGridViewAutoSizeRowsMode : public Enum

Members

Member | Description
None | The row heights do not automatically adjust.
AllCells | The row heights adjust to fit the contents of all cells in the rows, including header cells.
AllCellsExceptHeaders | The row heights adjust to fit the contents of all cells in the rows, excluding header cells.
AllHeaders | The row heights adjust to fit the contents of the row header.
DisplayedCells | The row heights adjust to fit the contents of all cells in rows currently displayed onscreen, including header cells.
DisplayedCellsExceptHeaders | The row heights adjust to fit the contents of all cells in rows currently displayed onscreen, excluding header cells.
DisplayedHeaders | The row heights adjust to fit the contents of the row headers currently displayed onscreen.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.DataGridViewAutoSizeRowsMode

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


DataGridViewCellBorderStyle Enumeration

[image]
Gizmox.WebGUI.Forms
DataGridViewCellBorderStyle Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewCellBorderStyle Enumeration

Specifies the border styles that can be applied to the cells of a DataGridView control.

Syntax

Visual Basic (Declaration)
Public Enum DataGridViewCellBorderStyle
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCellBorderStyle
C#
public enum DataGridViewCellBorderStyle : Enum
Managed Extensions for C++
__value public enum DataGridViewCellBorderStyle : public Enum
C++/CLI
public enum class DataGridViewCellBorderStyle : public Enum

Members

Member | Description
Custom |
Single |
Raised |
Sunken |
None |
SingleVertical |
RaisedVertical |
SunkenVertical |
SingleHorizontal |
RaisedHorizontal |
SunkenHorizontal |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.DataGridViewCellBorderStyle

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


DataGridViewCellStyleScopes Enumeration

[image]
Gizmox.WebGUI.Forms
DataGridViewCellStyleScopes Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewCellStyleScopes Enumeration

Specifies the DataGridView entity that owns the cell style that was changed.

Syntax

Visual Basic (Declaration)
<FlagsAttribute()>
Public Enum DataGridViewCellStyleScopes
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewCellStyleScopes
C#
[FlagsAttribute()]
public enum DataGridViewCellStyleScopes : Enum
Managed Extensions for C++
[FlagsAttribute()]
__value public enum DataGridViewCellStyleScopes : public Enum
C++/CLI
[FlagsAttribute()]
public enum class DataGridViewCellStyleScopes : public Enum

Members

Member | Description
AlternatingRows | One or more values of the object returned by the DataGridView.AlternatingRowsDefaultCellStyle property changed.
Cell | One or more values of the object returned by the DataGridViewCell.Style property changed.
Column | One or more values of the object returned by the DataGridViewColumn.DefaultCellStyle property changed.
ColumnHeaders | One or more values of the object returned by the DataGridView.ColumnHeadersDefaultCellStyle property changed.
DataGridView | One or more values of the object returned by the DataGridView.DefaultCellStyle property changed.
None | The owning entity is unspecified.
Row | One or more values of the object returned by the DataGridViewRow.DefaultCellStyle property changed.
RowHeaders | One or more values of the object returned by the DataGridView.RowHeadersDefaultCellStyle property changed.
Rows | One or more values of the object returned by the DataGridView.RowsDefaultCellStyle property changed.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.DataGridViewCellStyleScopes

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


DataGridViewClipboardCopyMode Enumeration

[image]
Gizmox.WebGUI.Forms
DataGridViewClipboardCopyMode Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewClipboardCopyMode Enumeration

Defines constants that indicate whether content is copied from a DataGridView control to the Clipboard.

Syntax

Visual Basic (Declaration)
Public Enum DataGridViewClipboardCopyMode
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewClipboardCopyMode
C#
public enum DataGridViewClipboardCopyMode : Enum
Managed Extensions for C++
__value public enum DataGridViewClipboardCopyMode : public Enum
C++/CLI
public enum class DataGridViewClipboardCopyMode : public Enum

Members

Member | Description
Disable |
EnableWithAutoHeaderText |
EnableWithoutHeaderText |
EnableAlwaysIncludeHeaderText |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.DataGridViewClipboardCopyMode

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


DataGridViewColumnHeadersHeightSizeMode Enumeration

[image]
Gizmox.WebGUI.Forms
DataGridViewColumnHeadersHeightSizeMode Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewColumnHeadersHeightSizeMode Enumeration

Defines values for specifying how the height of the column headers is adjusted.

Syntax

Visual Basic (Declaration)
Public Enum DataGridViewColumnHeadersHeightSizeMode
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewColumnHeadersHeightSizeMode
C#
public enum DataGridViewColumnHeadersHeightSizeMode : Enum
Managed Extensions for C++
__value public enum DataGridViewColumnHeadersHeightSizeMode : public Enum
C++/CLI
public enum class DataGridViewColumnHeadersHeightSizeMode : public Enum

Members

Member | Description
EnableResizing |
DisableResizing |
AutoSize |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.DataGridViewColumnHeadersHeightSizeMode

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


DataGridViewColumnSortMode Enumeration

[image]
Gizmox.WebGUI.Forms
DataGridViewColumnSortMode Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewColumnSortMode Enumeration

Defines how a DataGridView column can be sorted by the user.

Syntax

Visual Basic (Declaration)
Public Enum DataGridViewColumnSortMode
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewColumnSortMode
C#
public enum DataGridViewColumnSortMode : Enum
Managed Extensions for C++
__value public enum DataGridViewColumnSortMode : public Enum
C++/CLI
public enum class DataGridViewColumnSortMode : public Enum

Members

Member | Description
NotSortable |
Automatic |
Programmatic |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.DataGridViewColumnSortMode

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


DataGridViewComboBoxDisplayStyle Enumeration

[image]
Gizmox.WebGUI.Forms
DataGridViewComboBoxDisplayStyle Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewComboBoxDisplayStyle Enumeration

Defines constants that indicate how a DataGridViewComboBoxCell is displayed.

Syntax

Visual Basic (Declaration)
Public Enum DataGridViewComboBoxDisplayStyle
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewComboBoxDisplayStyle
C#
public enum DataGridViewComboBoxDisplayStyle : Enum
Managed Extensions for C++
__value public enum DataGridViewComboBoxDisplayStyle : public Enum
C++/CLI
public enum class DataGridViewComboBoxDisplayStyle : public Enum

Members

Member | Description
ComboBox |
DropDownButton |
Nothing |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.DataGridViewComboBoxDisplayStyle

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


DataGridViewContentAlignment Enumeration

[image]
Gizmox.WebGUI.Forms
DataGridViewContentAlignment Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewContentAlignment Enumeration

Defines constants that indicate the alignment of content within a DataGridView cell.

Syntax

Visual Basic (Declaration)
Public Enum DataGridViewContentAlignment
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewContentAlignment
C#
public enum DataGridViewContentAlignment : Enum
Managed Extensions for C++
__value public enum DataGridViewContentAlignment : public Enum
C++/CLI
public enum class DataGridViewContentAlignment : public Enum

Members

Member | Description
BottomCenter | The content is aligned vertically at the bottom and horizontally at the center of a cell.
BottomLeft | The content is aligned vertically at the bottom and horizontally at the left of a cell.
BottomRight | The content is aligned vertically at the bottom and horizontally at the right of a cell.
MiddleCenter | The content is aligned at the vertical and horizontal center of a cell.
MiddleLeft | The content is aligned vertically at the middle and horizontally at the left of a cell.
MiddleRight | The content is aligned vertically at the middle and horizontally at the right of a cell.
NotSet | The alignment is not set.
TopCenter | The content is aligned vertically at the top and horizontally at the center of a cell.
TopLeft | The content is aligned vertically at the top and horizontally at the left of a cell.
TopRight | The content is aligned vertically at the top and horizontally at the right of a cell.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.DataGridViewContentAlignment

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


DataGridViewDataErrorContexts Enumeration

[image]
Gizmox.WebGUI.Forms
DataGridViewDataErrorContexts Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewDataErrorContexts Enumeration

Represents the state of a data-bound DataGridView control when a data error occurred.

Syntax

Visual Basic (Declaration)
<FlagsAttribute()>
Public Enum DataGridViewDataErrorContexts
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewDataErrorContexts
C#
[FlagsAttribute()]
public enum DataGridViewDataErrorContexts : Enum
Managed Extensions for C++
[FlagsAttribute()]
__value public enum DataGridViewDataErrorContexts : public Enum
C++/CLI
[FlagsAttribute()]
public enum class DataGridViewDataErrorContexts : public Enum

Members

Member | Description
ClipboardContent | A data error occurred when copying content to the Clipboard. This value indicates that the cell value could not be converted to a string.
Commit | A data error occurred when committing changes to the data store. This value indicates that data entered in a cell could not be committed to the underlying data store.
CurrentCellChange | A data error occurred when the selection cursor moved to another cell. This value indicates that a user selected a cell when the previously selected cell had an error condition.
Display | A data error occurred when displaying a cell that was populated by a data source. This value indicates that the value from the data source cannot be displayed by the cell, or a mapping that translates the value from the data source to the cell is missing.
Formatting | A data error occurred when trying to format data that is either being sent to a data store, or being loaded from a data store. This value indicates that a change to a cell failed to format correctly. Either the new cell value needs to be corrected or the cell's formatting needs to change.
InitialValueRestoration | A data error occurred when restoring a cell to its previous value. This value indicates that a cell tried to cancel an edit and the rollback to the initial value failed. This can occur if the cell formatting changed so that it is incompatible with the initial value.
LeaveControl | A data error occurred when the DataGridView lost focus. This value indicates that the DataGridView could not commit user changes after losing focus.
Parsing | A data error occurred when parsing new data. This value indicates that the DataGridView could not parse new data that was entered by the user or loaded from the underlying data store.
PreferredSize | A data error occurred when calculating the preferred size of a cell. This value indicates that the DataGridView failed to calculate the preferred width or height of a cell when programmatically resizing a column or row. This can occur if the cell failed to format its value.
RowDeletion | A data error occurred when deleting a row. This value indicates that the underlying data store threw an exception when a data-bound DataGridView deleted a row.
Scroll | A data error occurred when scrolling a new region into view. This value indicates that a cell with data errors scrolled into view programmatically or with the scroll bar.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.DataGridViewDataErrorContexts

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


DataGridViewEditMode Enumeration

[image]
Gizmox.WebGUI.Forms
DataGridViewEditMode Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewEditMode Enumeration

Specifies how a user starts cell editing in the DataGridView control.

Syntax

Visual Basic (Declaration)
Public Enum DataGridViewEditMode
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewEditMode
C#
public enum DataGridViewEditMode : Enum
Managed Extensions for C++
__value public enum DataGridViewEditMode : public Enum
C++/CLI
public enum class DataGridViewEditMode : public Enum

Members

Member | Description
EditOnEnter |
EditOnKeystroke |
EditOnKeystrokeOrF2 |
EditOnF2 |
EditProgrammatically |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.DataGridViewEditMode

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


DataGridViewElementStates Enumeration

[image]
Gizmox.WebGUI.Forms
DataGridViewElementStates Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewElementStates Enumeration

Specifies the user interface (UI) state of a element within a DataGridView control.

Syntax

Visual Basic (Declaration)
<FlagsAttribute()>
Public Enum DataGridViewElementStates
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewElementStates
C#
[FlagsAttribute()]
public enum DataGridViewElementStates : Enum
Managed Extensions for C++
[FlagsAttribute()]
__value public enum DataGridViewElementStates : public Enum
C++/CLI
[FlagsAttribute()]
public enum class DataGridViewElementStates : public Enum

Members

Member | Description
Displayed | Indicates the an element is currently displayed onscreen.
Frozen | Indicates that an element cannot be scrolled through the UI.
None | Indicates that an element is in its default state.
ReadOnly | Indicates that an element will not accept user input to change its value.
Resizable | Indicates that an element can be resized through the UI. This value is ignored except when combined with the ResizableSet value.
ResizableSet | Indicates that an element does not inherit the resizable state of its parent.
Selected | Indicates that an element is in a selected (highlighted) UI state.
Visible | Indicates that an element is visible (displayable).

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.DataGridViewElementStates

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


DataGridViewHeaderBorderStyle Enumeration

[image]
Gizmox.WebGUI.Forms
DataGridViewHeaderBorderStyle Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewHeaderBorderStyle Enumeration

Specifies the border style that can be applied to the DataGridView.ColumnHeadersBorderStyle and DataGridView.RowHeadersBorderStyle properties of a DataGridView control.

Syntax

Visual Basic (Declaration)
Public Enum DataGridViewHeaderBorderStyle
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewHeaderBorderStyle
C#
public enum DataGridViewHeaderBorderStyle : Enum
Managed Extensions for C++
__value public enum DataGridViewHeaderBorderStyle : public Enum
C++/CLI
public enum class DataGridViewHeaderBorderStyle : public Enum

Members

Member | Description
Custom |
Single |
Raised |
Sunken |
None |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.DataGridViewHeaderBorderStyle

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


DataGridViewHitTestType Enumeration

[image]
Gizmox.WebGUI.Forms
DataGridViewHitTestType Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewHitTestType Enumeration

Specifies a location in a DataGridView control.

Syntax

Visual Basic (Declaration)
Public Enum DataGridViewHitTestType
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewHitTestType
C#
public enum DataGridViewHitTestType : Enum
Managed Extensions for C++
__value public enum DataGridViewHitTestType : public Enum
C++/CLI
public enum class DataGridViewHitTestType : public Enum

Members

Member | Description
None |
Cell |
ColumnHeader |
RowHeader |
TopLeftHeader |
HorizontalScrollBar |
VerticalScrollBar |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.DataGridViewHitTestType

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


DataGridViewImageCellLayout Enumeration

[image]
Gizmox.WebGUI.Forms
DataGridViewImageCellLayout Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewImageCellLayout Enumeration

Specifies the layout for an image contained in a DataGridViewCell.

Syntax

Visual Basic (Declaration)
Public Enum DataGridViewImageCellLayout
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewImageCellLayout
C#
public enum DataGridViewImageCellLayout : Enum
Managed Extensions for C++
__value public enum DataGridViewImageCellLayout : public Enum
C++/CLI
public enum class DataGridViewImageCellLayout : public Enum

Members

Member | Description
NotSet |
Normal |
Stretch |
Zoom |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.DataGridViewImageCellLayout

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


DataGridViewPaintParts Enumeration

[image]
Gizmox.WebGUI.Forms
DataGridViewPaintParts Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewPaintParts Enumeration

Defines values for specifying the parts of a DataGridViewCell that are to be painted.

Syntax

Visual Basic (Declaration)
<FlagsAttribute()>
Public Enum DataGridViewPaintParts
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewPaintParts
C#
[FlagsAttribute()]
public enum DataGridViewPaintParts : Enum
Managed Extensions for C++
[FlagsAttribute()]
__value public enum DataGridViewPaintParts : public Enum
C++/CLI
[FlagsAttribute()]
public enum class DataGridViewPaintParts : public Enum

Members

Member | Description
All | All parts of the cell should be painted.
Background | The background of the cell should be painted.
Border | The border of the cell should be painted.
ContentBackground | The background of the cell content should be painted.
ContentForeground | The foreground of the cell content should be painted.
ErrorIcon | The cell error icon should be painted.
Focus | The focus rectangle should be painted around the cell.
None | Nothing should be painted.
SelectionBackground | The background of the cell should be painted when the cell is selected.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.DataGridViewPaintParts

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


DataGridViewRowHeadersWidthSizeMode Enumeration

[image]
Gizmox.WebGUI.Forms
DataGridViewRowHeadersWidthSizeMode Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewRowHeadersWidthSizeMode Enumeration

Defines values for specifying how the row header width is adjusted.

Syntax

Visual Basic (Declaration)
Public Enum DataGridViewRowHeadersWidthSizeMode
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewRowHeadersWidthSizeMode
C#
public enum DataGridViewRowHeadersWidthSizeMode : Enum
Managed Extensions for C++
__value public enum DataGridViewRowHeadersWidthSizeMode : public Enum
C++/CLI
public enum class DataGridViewRowHeadersWidthSizeMode : public Enum

Members

Member | Description
EnableResizing |
DisableResizing |
AutoSizeToAllHeaders |
AutoSizeToDisplayedHeaders |
AutoSizeToFirstHeader |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.DataGridViewRowHeadersWidthSizeMode

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


DataGridViewSelectionMode Enumeration

[image]
Gizmox.WebGUI.Forms
DataGridViewSelectionMode Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewSelectionMode Enumeration

Describes how cells of a DataGridView control can be selected.

Syntax

Visual Basic (Declaration)
Public Enum DataGridViewSelectionMode
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewSelectionMode
C#
public enum DataGridViewSelectionMode : Enum
Managed Extensions for C++
__value public enum DataGridViewSelectionMode : public Enum
C++/CLI
public enum class DataGridViewSelectionMode : public Enum

Members

Member | Description
CellSelect |
FullRowSelect |
FullColumnSelect |
RowHeaderSelect |
ColumnHeaderSelect |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.DataGridViewSelectionMode

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


DataGridViewTriState Enumeration

[image]
Gizmox.WebGUI.Forms
DataGridViewTriState Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewTriState Enumeration

Defines values for specifying one of three possible states.

Syntax

Visual Basic (Declaration)
Public Enum DataGridViewTriState
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As DataGridViewTriState
C#
public enum DataGridViewTriState : Enum
Managed Extensions for C++
__value public enum DataGridViewTriState : public Enum
C++/CLI
public enum class DataGridViewTriState : public Enum

Members

Member | Description
NotSet |
True |
False |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.DataGridViewTriState

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


DataSourceUpdateMode Enumeration

[image]
Gizmox.WebGUI.Forms
DataSourceUpdateMode Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataSourceUpdateMode Enumeration

Specifies when a data source is updated when changes occur in the bound control.

Syntax

Visual Basic (Declaration)
Public Enum DataSourceUpdateMode
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As DataSourceUpdateMode
C#
public enum DataSourceUpdateMode : Enum
Managed Extensions for C++
__value public enum DataSourceUpdateMode : public Enum
C++/CLI
public enum class DataSourceUpdateMode : public Enum

Members

Member | Description
OnValidation |
OnPropertyChanged |
Never |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.DataSourceUpdateMode

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


DateTimePickerFormat Enumeration

[image]
Gizmox.WebGUI.Forms
DateTimePickerFormat Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DateTimePickerFormat Enumeration

Specifies the date and time format the DateTimePicker control displays.

Syntax

Visual Basic (Declaration)
Public Enum DateTimePickerFormat
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As DateTimePickerFormat
C#
public enum DateTimePickerFormat : Enum
Managed Extensions for C++
__value public enum DateTimePickerFormat : public Enum
C++/CLI
public enum class DateTimePickerFormat : public Enum

Members

Member | Description
Custom | The DateTimePicker control displays the date/time value in a custom format.
Long | The DateTimePicker control displays the date/time value in the long date format set by the user's operating system.
Short | The DateTimePicker control displays the date/time value in the short date format set by the user's operating system.
Time | The DateTimePicker control displays the date/time value in the time format set by the user's operating system.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.DateTimePickerFormat

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


Day Enumeration

[image]
Gizmox.WebGUI.Forms
Day Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : Day Enumeration

Specifies the day of the week.

Syntax

Visual Basic (Declaration)
Public Enum Day
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As Day
C#
public enum Day : Enum
Managed Extensions for C++
__value public enum Day : public Enum
C++/CLI
public enum class Day : public Enum

Members

Member | Description
Monday |
Tuesday |
Wednesday |
Thursday |
Friday |
Saturday |
Sunday |
Default |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.Day

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


DialogAlignment Enumeration

[image]
Gizmox.WebGUI.Forms
DialogAlignment Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DialogAlignment Enumeration

Reletive aligment of a aligned dialog.

Syntax

Visual Basic (Declaration)
Public Enum DialogAlignment
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As DialogAlignment
C#
public enum DialogAlignment : Enum
Managed Extensions for C++
__value public enum DialogAlignment : public Enum
C++/CLI
public enum class DialogAlignment : public Enum

Members

Member | Description
None |
Above |
Left |
Right |
Below |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.DialogAlignment

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


DockStyle Enumeration

[image]
Gizmox.WebGUI.Forms
DockStyle Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DockStyle Enumeration

Control docking style

Syntax

Visual Basic (Declaration)
<EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.DockEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")>
Public Enum DockStyle
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As DockStyle
C#
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.DockEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
public enum DockStyle : Enum
Managed Extensions for C++
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.DockEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
__value public enum DockStyle : public Enum
C++/CLI
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.DockEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
public enum class DockStyle : public Enum

Members

Member | Description
None |
Fill |
Top |
Right |
Bottom |
Left |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.DockStyle

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


DragDropEffects Enumeration

[image]
Gizmox.WebGUI.Forms
DragDropEffects Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DragDropEffects Enumeration

Specifies the effects of a drag-and-drop operation.

Syntax

Visual Basic (Declaration)
<FlagsAttribute()>
Public Enum DragDropEffects
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As DragDropEffects
C#
[FlagsAttribute()]
public enum DragDropEffects : Enum
Managed Extensions for C++
[FlagsAttribute()]
__value public enum DragDropEffects : public Enum
C++/CLI
[FlagsAttribute()]
public enum class DragDropEffects : public Enum

Members

Member | Description
All | The data is copied, removed from the drag source, and scrolled in the drop target.
Copy | The data is copied to the drop target.
Link | The data from the drag source is linked to the drop target.
Move | The data from the drag source is moved to the drop target.
None | The drop target does not accept the data.
Scroll | Scrolling is about to start or is currently occurring in the drop target.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.DragDropEffects

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


ErrorBlinkStyle Enumeration

[image]
Gizmox.WebGUI.Forms
ErrorBlinkStyle Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ErrorBlinkStyle Enumeration

Specifies constants indicating when the error icon, supplied by an ErrorProvider, should blink to alert the user that an error has occurred.

Syntax

Visual Basic (Declaration)
Public Enum ErrorBlinkStyle
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As ErrorBlinkStyle
C#
public enum ErrorBlinkStyle : Enum
Managed Extensions for C++
__value public enum ErrorBlinkStyle : public Enum
C++/CLI
public enum class ErrorBlinkStyle : public Enum

Members

Member | Description
AlwaysBlink | Always blink when the error icon is first displayed, or when a error description string is set for the control and the error icon is already displayed.
BlinkIfDifferentError | Blinks when the icon is already displayed and a new error string is set for the control.
NeverBlink | Never blink the error icon.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.ErrorBlinkStyle

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


ErrorIconAlignment Enumeration

[image]
Gizmox.WebGUI.Forms
ErrorIconAlignment Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ErrorIconAlignment Enumeration

Specifies constants indicating the locations that an error icon can appear in relation to the control with an error.

Syntax

Visual Basic (Declaration)
Public Enum ErrorIconAlignment
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As ErrorIconAlignment
C#
public enum ErrorIconAlignment : Enum
Managed Extensions for C++
__value public enum ErrorIconAlignment : public Enum
C++/CLI
public enum class ErrorIconAlignment : public Enum

Members

Member | Description
BottomLeft | The icon appears aligned with the bottom of the control and the left of the control.
BottomRight | The icon appears aligned with the bottom of the control and the right of the control.
MiddleLeft | The icon appears aligned with the middle of the control and the left of the control.
MiddleRight | The icon appears aligned with the middle of the control and the right of the control.
TopLeft | The icon appears aligned with the top of the control and to the left of the control.
TopRight | The icon appears aligned with the top of the control and to the right of the control.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.ErrorIconAlignment

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


ExtendedHorizontalAlignment Enumeration

[image]
Gizmox.WebGUI.Forms
ExtendedHorizontalAlignment Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ExtendedHorizontalAlignment Enumeration

Specifies how an object or text in a control is horizontally aligned relative to an element of the control and includes inheritance definition.

Syntax

Visual Basic (Declaration)
Public Enum ExtendedHorizontalAlignment
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As ExtendedHorizontalAlignment
C#
public enum ExtendedHorizontalAlignment : Enum
Managed Extensions for C++
__value public enum ExtendedHorizontalAlignment : public Enum
C++/CLI
public enum class ExtendedHorizontalAlignment : public Enum

Members

Member | Description
Center | The object or text is aligned in the center of the control element.
Left | The object or text is aligned on the left of the control element.
Right | The object or text is aligned on the right of the control element.
Inherit | The object or text is aligned according to the inherited definition.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.ExtendedHorizontalAlignment

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


FixedPanel Enumeration

[image]
Gizmox.WebGUI.Forms
FixedPanel Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : FixedPanel Enumeration

Syntax

Visual Basic (Declaration)
Public Enum FixedPanel
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As FixedPanel
C#
public enum FixedPanel : Enum
Managed Extensions for C++
__value public enum FixedPanel : public Enum
C++/CLI
public enum class FixedPanel : public Enum

Members

Member | Description
None |
Panel1 |
Panel2 |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.FixedPanel

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


FlatStyle Enumeration

[image]
Gizmox.WebGUI.Forms
FlatStyle Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : FlatStyle Enumeration

The component style (WinForms Complaint)

Syntax

Visual Basic (Declaration)
Public Enum FlatStyle
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As FlatStyle
C#
public enum FlatStyle : Enum
Managed Extensions for C++
__value public enum FlatStyle : public Enum
C++/CLI
public enum class FlatStyle : public Enum

Members

Member | Description
Flat |
Popup |
Standard |
System |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.FlatStyle

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


FlowDirection Enumeration

[image]
Gizmox.WebGUI.Forms
FlowDirection Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : FlowDirection Enumeration

Defines constants that specify the direction in which consecutive user interface (UI) elements are placed in a linear layout container.

Syntax

Visual Basic (Declaration)
Public Enum FlowDirection
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As FlowDirection
C#
public enum FlowDirection : Enum
Managed Extensions for C++
__value public enum FlowDirection : public Enum
C++/CLI
public enum class FlowDirection : public Enum

Members

Member | Description
LeftToRight | Elements flow from the left edge of the design surface to the right.
TopDown | Elements flow from the top of the design surface to the bottom.
RightToLeft | Elements flow from the right edge of the design surface to the left.
BottomUp | Elements flow from the bottom of the design surface to the top.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.FlowDirection

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


FormBorderStyle Enumeration

[image]
Gizmox.WebGUI.Forms
FormBorderStyle Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : FormBorderStyle Enumeration

Syntax

Visual Basic (Declaration)
Public Enum FormBorderStyle
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As FormBorderStyle
C#
public enum FormBorderStyle : Enum
Managed Extensions for C++
__value public enum FormBorderStyle : public Enum
C++/CLI
public enum class FormBorderStyle : public Enum

Members

Member | Description
Fixed3D |
FixedDialog |
FixedSingle |
FixedToolWindow |
None |
Sizable |
SizableToolWindow |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.FormBorderStyle

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


FormStartPosition Enumeration

[image]
Gizmox.WebGUI.Forms
FormStartPosition Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : FormStartPosition Enumeration

Syntax

Visual Basic (Declaration)
Public Enum FormStartPosition
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As FormStartPosition
C#
public enum FormStartPosition : Enum
Managed Extensions for C++
__value public enum FormStartPosition : public Enum
C++/CLI
public enum class FormStartPosition : public Enum

Members

Member | Description
CenterParent |
CenterScreen |
Manual |
WindowsDefaultBounds |
WindowsDefaultLocation |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.FormStartPosition

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


FormStyle Enumeration

[image]
Gizmox.WebGUI.Forms
FormStyle Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : FormStyle Enumeration

Syntax

Visual Basic (Declaration)
Public Enum FormStyle
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As FormStyle
C#
public enum FormStyle : Enum
Managed Extensions for C++
__value public enum FormStyle : public Enum
C++/CLI
public enum class FormStyle : public Enum

Members

Member | Description
Dialog |
Application |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.FormStyle

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


FormWindowState Enumeration

[image]
Gizmox.WebGUI.Forms
FormWindowState Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : FormWindowState Enumeration

Syntax

Visual Basic (Declaration)
Public Enum FormWindowState
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As FormWindowState
C#
public enum FormWindowState : Enum
Managed Extensions for C++
__value public enum FormWindowState : public Enum
C++/CLI
public enum class FormWindowState : public Enum

Members

Member | Description
Maximized |
Minimized |
Normal |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.FormWindowState

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


GridItemType Enumeration

[image]
Gizmox.WebGUI.Forms
GridItemType Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : GridItemType Enumeration

Specifies the valid grid item types for a PropertyGrid.

Syntax

Visual Basic (Declaration)
Public Enum GridItemType
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As GridItemType
C#
public enum GridItemType : Enum
Managed Extensions for C++
__value public enum GridItemType : public Enum
C++/CLI
public enum class GridItemType : public Enum

Members

Member | Description
Property | A grid entry that corresponds to a property.
Category | A grid entry that is a category name. A category is a descriptive grouping for groups of GridItem rows. Typical categories include the following Behavior, Layout, Data, and Appearance.
ArrayValue | The GridItem is an element of an array.
Root | A root item in the grid hierarchy.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.GridItemType

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


HelpNavigator Enumeration

[image]
Gizmox.WebGUI.Forms
HelpNavigator Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : HelpNavigator Enumeration

Specifies constants indicating which elements of the Help file to display.

Syntax

Visual Basic (Declaration)
Public Enum HelpNavigator
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As HelpNavigator
C#
public enum HelpNavigator : Enum
Managed Extensions for C++
__value public enum HelpNavigator : public Enum
C++/CLI
public enum class HelpNavigator : public Enum

Members

Member | Description
AssociateIndex | The Help file opens to the index entry for the first letter of a specified topic.
Find | The Help file opens to the search page.
Index | The Help file opens to the index.
KeywordIndex | The Help file opens to the topic with the specified index entry, if one exists; otherwise, the index entry closest to the specified keyword is displayed.
TableOfContents | The Help file opens to the table of contents.
Topic | The Help file opens to a specified topic, if the topic exists.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.HelpNavigator

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


HorizontalAlignment Enumeration

[image]
Gizmox.WebGUI.Forms
HorizontalAlignment Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : HorizontalAlignment Enumeration

Specifies how an object or text in a control is horizontally aligned relative to an element of the control.

Syntax

Visual Basic (Declaration)
Public Enum HorizontalAlignment
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As HorizontalAlignment
C#
public enum HorizontalAlignment : Enum
Managed Extensions for C++
__value public enum HorizontalAlignment : public Enum
C++/CLI
public enum class HorizontalAlignment : public Enum

Members

Member | Description
Center | The object or text is aligned in the center of the control element.
Left | The object or text is aligned on the left of the control element.
Right | The object or text is aligned on the right of the control element.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.HorizontalAlignment

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


HtmlBoxType Enumeration

[image]
Gizmox.WebGUI.Forms
HtmlBoxType Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : HtmlBoxType Enumeration

The html box content type

Syntax

Visual Basic (Declaration)
Public Enum HtmlBoxType
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As HtmlBoxType
C#
public enum HtmlBoxType : Enum
Managed Extensions for C++
__value public enum HtmlBoxType : public Enum
C++/CLI
public enum class HtmlBoxType : public Enum

Members

Member | Description
HTML |
URL |
UNC |
RESOURCE |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.HtmlBoxType

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


ImageLayout Enumeration

[image]
Gizmox.WebGUI.Forms
ImageLayout Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ImageLayout Enumeration

Specifies the position of the image on the control.

Syntax

Visual Basic (Declaration)
Public Enum ImageLayout
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As ImageLayout
C#
public enum ImageLayout : Enum
Managed Extensions for C++
__value public enum ImageLayout : public Enum
C++/CLI
public enum class ImageLayout : public Enum

Members

Member | Description
None |
Tile |
Center |
Stretch |
Zoom |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.ImageLayout

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


ItemActivation Enumeration

[image]
Gizmox.WebGUI.Forms
ItemActivation Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ItemActivation Enumeration

Syntax

Visual Basic (Declaration)
Public Enum ItemActivation
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As ItemActivation
C#
public enum ItemActivation : Enum
Managed Extensions for C++
__value public enum ItemActivation : public Enum
C++/CLI
public enum class ItemActivation : public Enum

Members

Member | Description
OneClick |
Standard |
TwoClick |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.ItemActivation

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


LeftRightAlignment Enumeration

[image]
Gizmox.WebGUI.Forms
LeftRightAlignment Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : LeftRightAlignment Enumeration

Specifies whether an object or text is aligned to the left or right of a reference point.

Syntax

Visual Basic (Declaration)
Public Enum LeftRightAlignment
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As LeftRightAlignment
C#
public enum LeftRightAlignment : Enum
Managed Extensions for C++
__value public enum LeftRightAlignment : public Enum
C++/CLI
public enum class LeftRightAlignment : public Enum

Members

Member | Description
Left | The object or text is aligned to the left of the reference point.
Right | The object or text is aligned to the right of the reference point.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.LeftRightAlignment

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


LinkBehavior Enumeration

[image]
Gizmox.WebGUI.Forms
LinkBehavior Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : LinkBehavior Enumeration

Specifies the behaviors of a link in a LinkLabel.

Syntax

Visual Basic (Declaration)
Public Enum LinkBehavior
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As LinkBehavior
C#
public enum LinkBehavior : Enum
Managed Extensions for C++
__value public enum LinkBehavior : public Enum
C++/CLI
public enum class LinkBehavior : public Enum

Members

Member | Description
SystemDefault | The behavior of this setting depends on the options set using the Internet Options dialog box in Control Panel or Internet Explorer.
AlwaysUnderline | The link always displays with underlined text.
HoverUnderline | The link displays underlined text only when the mouse is hovered over the link text.
NeverUnderline | The link text is never underlined. The link can still be distinguished from other text by use of the LinkColor property of the LinkLabel control.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.LinkBehavior

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


LinkState Enumeration

[image]
Gizmox.WebGUI.Forms
LinkState Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : LinkState Enumeration

Specifies constants that define the state of the link.

Syntax

Visual Basic (Declaration)
Public Enum LinkState
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As LinkState
C#
public enum LinkState : Enum
Managed Extensions for C++
__value public enum LinkState : public Enum
C++/CLI
public enum class LinkState : public Enum

Members

Member | Description
Active | The state of a link that has been clicked.
Hover | The state of a link over which a mouse pointer is resting.
Normal | The state of a link in its normal state (none of the other states apply).
Visited | The state of a link that has been visited.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.LinkState

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


ListViewColumnType Enumeration

[image]
Gizmox.WebGUI.Forms
ListViewColumnType Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ListViewColumnType Enumeration

Syntax

Visual Basic (Declaration)
Public Enum ListViewColumnType
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As ListViewColumnType
C#
public enum ListViewColumnType : Enum
Managed Extensions for C++
__value public enum ListViewColumnType : public Enum
C++/CLI
public enum class ListViewColumnType : public Enum

Members

Member | Description
Text |
Number |
Date |
Icon |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.ListViewColumnType

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


MaskFormat Enumeration

[image]
Gizmox.WebGUI.Forms
MaskFormat Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : MaskFormat Enumeration

Defines how to format the Text property. MaskedTextBox.

Syntax

Visual Basic (Declaration)
Public Enum MaskFormat
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As MaskFormat
C#
public enum MaskFormat : Enum
Managed Extensions for C++
__value public enum MaskFormat : public Enum
C++/CLI
public enum class MaskFormat : public Enum

Members

Member | Description
ExcludePromptAndLiterals |
IncludePrompt |
IncludeLiterals |
IncludePromptAndLiterals |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.MaskFormat

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


MdiLayout Enumeration

[image]
Gizmox.WebGUI.Forms
MdiLayout Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : MdiLayout Enumeration

Specifies the layout of multiple document interface (MDI) child windows in an MDI parent window.

Syntax

Visual Basic (Declaration)
Public Enum MdiLayout
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As MdiLayout
C#
public enum MdiLayout : Enum
Managed Extensions for C++
__value public enum MdiLayout : public Enum
C++/CLI
public enum class MdiLayout : public Enum

Members

Member | Description
Cascade | All MDI child windows are cascaded within the client region of the MDI parent form.
TileHorizontal | All MDI child windows are tiled horizontally within the client region of the MDI parent form.
TileVertical | All MDI child windows are tiled vertically within the client region of the MDI parent form.
ArrangeIcons | All MDI child icons are arranged within the client region of the MDI parent form.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.MdiLayout

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


MessageBoxButtons Enumeration

[image]
Gizmox.WebGUI.Forms
MessageBoxButtons Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : MessageBoxButtons Enumeration

Specifies constants defining which buttons to display on a MessageBox.

Syntax

Visual Basic (Declaration)
Public Enum MessageBoxButtons
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As MessageBoxButtons
C#
public enum MessageBoxButtons : Enum
Managed Extensions for C++
__value public enum MessageBoxButtons : public Enum
C++/CLI
public enum class MessageBoxButtons : public Enum

Members

Member | Description
AbortRetryIgnore | The message box contains Abort, Retry, and Ignore buttons.
OK | The message box contains an OK button.
OKCancel | The message box contains OK and Cancel buttons.
RetryCancel | The message box contains Retry and Cancel buttons.
YesNo | The message box contains Yes and No buttons.
YesNoCancel | The message box contains Yes, No, and Cancel buttons.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.MessageBoxButtons

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


MessageBoxDefaultButton Enumeration

[image]
Gizmox.WebGUI.Forms
MessageBoxDefaultButton Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : MessageBoxDefaultButton Enumeration

Specifies constants defining the default button on a MessageBox.

Syntax

Visual Basic (Declaration)
Public Enum MessageBoxDefaultButton
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As MessageBoxDefaultButton
C#
public enum MessageBoxDefaultButton : Enum
Managed Extensions for C++
__value public enum MessageBoxDefaultButton : public Enum
C++/CLI
public enum class MessageBoxDefaultButton : public Enum

Members

Member | Description
Button1 | The first button on the message box is the default button.
Button2 | The second button on the message box is the default button.
Button3 | The third button on the message box is the default button.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.MessageBoxDefaultButton

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


MessageBoxIcon Enumeration

[image]
Gizmox.WebGUI.Forms
MessageBoxIcon Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : MessageBoxIcon Enumeration

Specifies constants defining which information to display.

Syntax

Visual Basic (Declaration)
Public Enum MessageBoxIcon
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As MessageBoxIcon
C#
public enum MessageBoxIcon : Enum
Managed Extensions for C++
__value public enum MessageBoxIcon : public Enum
C++/CLI
public enum class MessageBoxIcon : public Enum

Members

Member | Description
Asterisk | The message box contains a symbol consisting of a lowercase letter i in a circle.
Error | The message box contains a symbol consisting of white X in a circle with a red background.
Exclamation | The message box contains a symbol consisting of an exclamation point in a triangle with a yellow background.
Hand | The message box contains a symbol consisting of a white X in a circle with a red background.
Information | The message box contains a symbol consisting of a lowercase letter i in a circle.
None | The message box contain no symbols.
Question | The message box contains a symbol consisting of a question mark in a circle.
Stop | The message box contains a symbol consisting of white X in a circle with a red background.
Warning | The message box contains a symbol consisting of an exclamation point in a triangle with a yellow background.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.MessageBoxIcon

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


MessageBoxOptions Enumeration

[image]
Gizmox.WebGUI.Forms
MessageBoxOptions Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : MessageBoxOptions Enumeration

Specifies options on a MessageBox.

Syntax

Visual Basic (Declaration)
<FlagsAttribute()>
Public Enum MessageBoxOptions
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As MessageBoxOptions
C#
[FlagsAttribute()]
public enum MessageBoxOptions : Enum
Managed Extensions for C++
[FlagsAttribute()]
__value public enum MessageBoxOptions : public Enum
C++/CLI
[FlagsAttribute()]
public enum class MessageBoxOptions : public Enum

Members

Member | Description
DefaultDesktopOnly | The message box is displayed on the active desktop.
RightAlign | The message box text is right-aligned.
RtlReading | Specifies that the message box text is displayed with right to left reading order.
ServiceNotification | The message box is displayed on the active desktop.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.MessageBoxOptions

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


Orientation Enumeration

[image]
Gizmox.WebGUI.Forms
Orientation Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : Orientation Enumeration

Specifies the orientation of controls or elements of controls.

Syntax

Visual Basic (Declaration)
Public Enum Orientation
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As Orientation
C#
public enum Orientation : Enum
Managed Extensions for C++
__value public enum Orientation : public Enum
C++/CLI
public enum class Orientation : public Enum

Members

Member | Description
Horizontal | The control or element is oriented horizontally.
Vertical | The control or element is oriented vertically.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.Orientation

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


PanelType Enumeration

[image]
Gizmox.WebGUI.Forms
PanelType Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : PanelType Enumeration

The panel display tyle

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
<ObsoleteAttribute("Use HeaderedPanel in the office extension instead")>
Public Enum PanelType
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As PanelType
C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
[ObsoleteAttribute("Use HeaderedPanel in the office extension instead")]
public enum PanelType : Enum
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
[ObsoleteAttribute("Use HeaderedPanel in the office extension instead")]
__value public enum PanelType : public Enum
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
[ObsoleteAttribute("Use HeaderedPanel in the office extension instead")]
public enum class PanelType : public Enum

Members

Member | Description
Normal |
Titled |
Border |
Page |
Custom |
Navigation |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.PanelType

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


PictureBoxSizeMode Enumeration

[image]
Gizmox.WebGUI.Forms
PictureBoxSizeMode Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : PictureBoxSizeMode Enumeration

Specifies how an image is positioned within a PictureBox.

Syntax

Visual Basic (Declaration)
Public Enum PictureBoxSizeMode
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As PictureBoxSizeMode
C#
public enum PictureBoxSizeMode : Enum
Managed Extensions for C++
__value public enum PictureBoxSizeMode : public Enum
C++/CLI
public enum class PictureBoxSizeMode : public Enum

Members

Member | Description
AutoSize | The PictureBox is sized equal to the size of the image that it contains.
CenterImage | The image is displayed in the center if the PictureBox is larger than the image. If the image is larger than the PictureBox, the picture is placed in the center of the PictureBox and the outside edges are clipped.
Normal | The image is placed in the upper-left corner of the PictureBox. The image is clipped if it is larger than the PictureBox it is contained in.
StretchImage | The image within the PictureBox is stretched or shrunk to fit the size of the PictureBox.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.PictureBoxSizeMode

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


ProfessionalColorTable.KnownColors Enumeration

[image]
Gizmox.WebGUI.Forms
ProfessionalColorTable.KnownColors Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ProfessionalColorTable.KnownColors Enumeration

Syntax

Visual Basic (Declaration)
Private Enum ProfessionalColorTable.KnownColors
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As ProfessionalColorTable.KnownColors
C#
private enum ProfessionalColorTable.KnownColors : Enum
Managed Extensions for C++
__value private enum ProfessionalColorTable.KnownColors : public Enum
C++/CLI
private enum class ProfessionalColorTable.KnownColors : public Enum

Members

Member | Description
ButtonCheckedHighlight |
ButtonPressedHighlight |
ButtonSelectedHighlight |
lastKnownColor |
msocbvcrCBBdrOuterDocked |
msocbvcrCBBdrOuterFloating |
msocbvcrCBBkgd |
msocbvcrCBCtlBdrMouseDown |
msocbvcrCBCtlBdrMouseOver |
msocbvcrCBCtlBdrSelected |
msocbvcrCBCtlBdrSelectedMouseOver |
msocbvcrCBCtlBkgd |
msocbvcrCBCtlBkgdLight |
msocbvcrCBCtlBkgdMouseDown |
msocbvcrCBCtlBkgdMouseOver |
msocbvcrCBCtlBkgdSelected |
msocbvcrCBCtlBkgdSelectedMouseOver |
msocbvcrCBCtlText |
msocbvcrCBCtlTextDisabled |
msocbvcrCBCtlTextLight |
msocbvcrCBCtlTextMouseDown |
msocbvcrCBCtlTextMouseOver |
msocbvcrCBDockSeparatorLine |
msocbvcrCBDragHandle |
msocbvcrCBDragHandleShadow |
msocbvcrCBDropDownArrow |
msocbvcrCBGradMainMenuHorzBegin |
msocbvcrCBGradMainMenuHorzEnd |
msocbvcrCBGradMenuIconBkgdDroppedBegin |
msocbvcrCBGradMenuIconBkgdDroppedEnd |
msocbvcrCBGradMenuIconBkgdDroppedMiddle |
msocbvcrCBGradMenuTitleBkgdBegin |
msocbvcrCBGradMenuTitleBkgdEnd |
msocbvcrCBGradMouseDownBegin |
msocbvcrCBGradMouseDownEnd |
msocbvcrCBGradMouseDownMiddle |
msocbvcrCBGradMouseOverBegin |
msocbvcrCBGradMouseOverEnd |
msocbvcrCBGradMouseOverMiddle |
msocbvcrCBGradOptionsBegin |
msocbvcrCBGradOptionsEnd |
msocbvcrCBGradOptionsMiddle |
msocbvcrCBGradOptionsMouseOverBegin |
msocbvcrCBGradOptionsMouseOverEnd |
msocbvcrCBGradOptionsMouseOverMiddle |
msocbvcrCBGradOptionsSelectedBegin |
msocbvcrCBGradOptionsSelectedEnd |
msocbvcrCBGradOptionsSelectedMiddle |
msocbvcrCBGradSelectedBegin |
msocbvcrCBGradSelectedEnd |
msocbvcrCBGradSelectedMiddle |
msocbvcrCBGradVertBegin |
msocbvcrCBGradVertEnd |
msocbvcrCBGradVertMiddle |
msocbvcrCBIconDisabledDark |
msocbvcrCBIconDisabledLight |
msocbvcrCBLabelBkgnd |
msocbvcrCBLowColorIconDisabled |
msocbvcrCBMainMenuBkgd |
msocbvcrCBMenuBdrOuter |
msocbvcrCBMenuBkgd |
msocbvcrCBMenuCtlText |
msocbvcrCBMenuCtlTextDisabled |
msocbvcrCBMenuIconBkgd |
msocbvcrCBMenuIconBkgdDropped |
msocbvcrCBMenuShadow |
msocbvcrCBMenuSplitArrow |
msocbvcrCBOptionsButtonShadow |
msocbvcrCBShadow |
msocbvcrCBSplitterLine |
msocbvcrCBSplitterLineLight |
msocbvcrCBTearOffHandle |
msocbvcrCBTearOffHandleMouseOver |
msocbvcrCBTitleBkgd |
msocbvcrCBTitleText |
msocbvcrDisabledFocuslessHighlightedText |
msocbvcrDisabledHighlightedText |
msocbvcrDlgGroupBoxText |
msocbvcrDocTabBdr |
msocbvcrDocTabBdrDark |
msocbvcrDocTabBdrDarkMouseDown |
msocbvcrDocTabBdrDarkMouseOver |
msocbvcrDocTabBdrLight |
msocbvcrDocTabBdrLightMouseDown |
msocbvcrDocTabBdrLightMouseOver |
msocbvcrDocTabBdrMouseDown |
msocbvcrDocTabBdrMouseOver |
msocbvcrDocTabBdrSelected |
msocbvcrDocTabBkgd |
msocbvcrDocTabBkgdMouseDown |
msocbvcrDocTabBkgdMouseOver |
msocbvcrDocTabBkgdSelected |
msocbvcrDocTabText |
msocbvcrDocTabTextMouseDown |
msocbvcrDocTabTextMouseOver |
msocbvcrDocTabTextSelected |
msocbvcrDWActiveTabBkgd |
msocbvcrDWActiveTabText |
msocbvcrDWActiveTabTextDisabled |
msocbvcrDWInactiveTabBkgd |
msocbvcrDWInactiveTabText |
msocbvcrDWTabBkgdMouseDown |
msocbvcrDWTabBkgdMouseOver |
msocbvcrDWTabTextMouseDown |
msocbvcrDWTabTextMouseOver |
msocbvcrFocuslessHighlightedBkgd |
msocbvcrFocuslessHighlightedText |
msocbvcrGDHeaderBdr |
msocbvcrGDHeaderBkgd |
msocbvcrGDHeaderCellBdr |
msocbvcrGDHeaderCellBkgd |
msocbvcrGDHeaderCellBkgdSelected |
msocbvcrGDHeaderSeeThroughSelection |
msocbvcrGSPDarkBkgd |
msocbvcrGSPGroupContentDarkBkgd |
msocbvcrGSPGroupContentLightBkgd |
msocbvcrGSPGroupContentText |
msocbvcrGSPGroupContentTextDisabled |
msocbvcrGSPGroupHeaderDarkBkgd |
msocbvcrGSPGroupHeaderLightBkgd |
msocbvcrGSPGroupHeaderText |
msocbvcrGSPGroupline |
msocbvcrGSPHyperlink |
msocbvcrGSPLightBkgd |
msocbvcrHyperlink |
msocbvcrHyperlinkFollowed |
msocbvcrJotNavUIBdr |
msocbvcrJotNavUIGradBegin |
msocbvcrJotNavUIGradEnd |
msocbvcrJotNavUIGradMiddle |
msocbvcrJotNavUIText |
msocbvcrListHeaderArrow |
msocbvcrNetLookBkgnd |
msocbvcrOABBkgd |
msocbvcrOBBkgdBdr |
msocbvcrOBBkgdBdrContrast |
msocbvcrOGMDIParentWorkspaceBkgd |
msocbvcrOGRulerActiveBkgd |
msocbvcrOGRulerBdr |
msocbvcrOGRulerBkgd |
msocbvcrOGRulerInactiveBkgd |
msocbvcrOGRulerTabBoxBdr |
msocbvcrOGRulerTabBoxBdrHighlight |
msocbvcrOGRulerTabStopTicks |
msocbvcrOGRulerText |
msocbvcrOGTaskPaneGroupBoxHeaderBkgd |
msocbvcrOGWorkspaceBkgd |
msocbvcrOLKFlagNone |
msocbvcrOLKFolderbarDark |
msocbvcrOLKFolderbarLight |
msocbvcrOLKFolderbarText |
msocbvcrOLKGridlines |
msocbvcrOLKGroupLine |
msocbvcrOLKGroupNested |
msocbvcrOLKGroupShaded |
msocbvcrOLKGroupText |
msocbvcrOLKIconBar |
msocbvcrOLKInfoBarBkgd |
msocbvcrOLKInfoBarText |
msocbvcrOLKPreviewPaneLabelText |
msocbvcrOLKTodayIndicatorDark |
msocbvcrOLKTodayIndicatorLight |
msocbvcrOLKWBActionDividerLine |
msocbvcrOLKWBButtonDark |
msocbvcrOLKWBButtonLight |
msocbvcrOLKWBDarkOutline |
msocbvcrOLKWBFoldersBackground |
msocbvcrOLKWBHoverButtonDark |
msocbvcrOLKWBHoverButtonLight |
msocbvcrOLKWBLabelText |
msocbvcrOLKWBPressedButtonDark |
msocbvcrOLKWBPressedButtonLight |
msocbvcrOLKWBSelectedButtonDark |
msocbvcrOLKWBSelectedButtonLight |
msocbvcrOLKWBSplitterDark |
msocbvcrOLKWBSplitterLight |
msocbvcrPlacesBarBkgd |
msocbvcrPPOutlineThumbnailsPaneTabAreaBkgd |
msocbvcrPPOutlineThumbnailsPaneTabBdr |
msocbvcrPPOutlineThumbnailsPaneTabInactiveBkgd |
msocbvcrPPOutlineThumbnailsPaneTabText |
msocbvcrPPSlideBdrActiveSelected |
msocbvcrPPSlideBdrActiveSelectedMouseOver |
msocbvcrPPSlideBdrInactiveSelected |
msocbvcrPPSlideBdrMouseOver |
msocbvcrPubPrintDocScratchPageBkgd |
msocbvcrPubWebDocScratchPageBkgd |
msocbvcrSBBdr |
msocbvcrScrollbarBkgd |
msocbvcrToastGradBegin |
msocbvcrToastGradEnd |
msocbvcrWPBdrInnerDocked |
msocbvcrWPBdrOuterDocked |
msocbvcrWPBdrOuterFloating |
msocbvcrWPBkgd |
msocbvcrWPCtlBdr |
msocbvcrWPCtlBdrDefault |
msocbvcrWPCtlBdrDisabled |
msocbvcrWPCtlBkgd |
msocbvcrWPCtlBkgdDisabled |
msocbvcrWPCtlText |
msocbvcrWPCtlTextDisabled |
msocbvcrWPCtlTextMouseDown |
msocbvcrWPGroupline |
msocbvcrWPInfoTipBkgd |
msocbvcrWPInfoTipText |
msocbvcrWPNavBarBkgnd |
msocbvcrWPText |
msocbvcrWPTextDisabled |
msocbvcrWPTitleBkgdActive |
msocbvcrWPTitleBkgdInactive |
msocbvcrWPTitleTextActive |
msocbvcrWPTitleTextInactive |
msocbvcrXLFormulaBarBkgd |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.ProfessionalColorTable.KnownColors

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


PropertySort Enumeration

[image]
Gizmox.WebGUI.Forms
PropertySort Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : PropertySort Enumeration

Specifies how properties are sorted in the PropertyGrid.

Syntax

Visual Basic (Declaration)
Public Enum PropertySort
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As PropertySort
C#
public enum PropertySort : Enum
Managed Extensions for C++
__value public enum PropertySort : public Enum
C++/CLI
public enum class PropertySort : public Enum

Members

Member | Description
NoSort | Properties are displayed in the order in which they are retrieved from the TypeDescriptor.
Alphabetical | Properties are sorted in an alphabetical list.
Categorized | Properties are displayed according to their category in a group. The categories are defined by the properties themselves.
CategorizedAlphabetical | Properties are displayed according to their category in a group. The properties are further sorted alphabetically within the group. The categories are defined by the properties themselves.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.PropertySort

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


RightToLeft Enumeration

[image]
Gizmox.WebGUI.Forms
RightToLeft Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RightToLeft Enumeration

Specifies a value indicating whether the text appears from right to left, such as when using Hebrew or Arabic fonts.

Syntax

Visual Basic (Declaration)
Public Enum RightToLeft
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As RightToLeft
C#
public enum RightToLeft : Enum
Managed Extensions for C++
__value public enum RightToLeft : public Enum
C++/CLI
public enum class RightToLeft : public Enum

Members

Member | Description
No |
Yes |
Inherit |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.RightToLeft

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


ScrollBars Enumeration

[image]
Gizmox.WebGUI.Forms
ScrollBars Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ScrollBars Enumeration

Specifies which scroll bars will be visible on a control.

Syntax

Visual Basic (Declaration)
Public Enum ScrollBars
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As ScrollBars
C#
public enum ScrollBars : Enum
Managed Extensions for C++
__value public enum ScrollBars : public Enum
C++/CLI
public enum class ScrollBars : public Enum

Members

Member | Description
Horizontal |
None |
Both |
Vertical |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.ScrollBars

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


ScrollStyle Enumeration

[image]
Gizmox.WebGUI.Forms
ScrollStyle Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ScrollStyle Enumeration

Control scrolling style

Syntax

Visual Basic (Declaration)
Public Enum ScrollStyle
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As ScrollStyle
C#
public enum ScrollStyle : Enum
Managed Extensions for C++
__value public enum ScrollStyle : public Enum
C++/CLI
public enum class ScrollStyle : public Enum

Members

Member | Description
None |
Both |
Horizontal |
Vertical |
Automatic |
Strech |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.ScrollStyle

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


SelectionMode Enumeration

[image]
Gizmox.WebGUI.Forms
SelectionMode Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : SelectionMode Enumeration

Specifies the selection behavior of a list box.

Syntax

Visual Basic (Declaration)
Public Enum SelectionMode
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As SelectionMode
C#
public enum SelectionMode : Enum
Managed Extensions for C++
__value public enum SelectionMode : public Enum
C++/CLI
public enum class SelectionMode : public Enum

Members

Member | Description
MultiExtended | Multiple items can be selected, and the user can use the SHIFT, CTRL, and arrow keys to make selections
MultiSimple | Multiple items can be selected.
None | No items can be selected.
One | Only one item can be selected.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.SelectionMode

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


SelectOnRightClickBehvior Enumeration

[image]
Gizmox.WebGUI.Forms
SelectOnRightClickBehvior Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : SelectOnRightClickBehvior Enumeration

Syntax

Visual Basic (Declaration)
Public Enum SelectOnRightClickBehvior
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As SelectOnRightClickBehvior
C#
public enum SelectOnRightClickBehvior : Enum
Managed Extensions for C++
__value public enum SelectOnRightClickBehvior : public Enum
C++/CLI
public enum class SelectOnRightClickBehvior : public Enum

Members

Member | Description
No |
Yes |
Inherit |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.SelectOnRightClickBehvior

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


Shortcut Enumeration

[image]
Gizmox.WebGUI.Forms
Shortcut Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : Shortcut Enumeration

Syntax

Visual Basic (Declaration)
Public Enum Shortcut
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As Shortcut
C#
public enum Shortcut : Enum
Managed Extensions for C++
__value public enum Shortcut : public Enum
C++/CLI
public enum class Shortcut : public Enum

Members

Member | Description
Alt0 |
Alt1 |
Alt2 |
Alt3 |
Alt4 |
Alt5 |
Alt6 |
Alt7 |
Alt8 |
Alt9 |
AltBksp |
AltF1 |
AltF10 |
AltF11 |
AltF12 |
AltF2 |
AltF3 |
AltF4 |
AltF5 |
AltF6 |
AltF7 |
AltF8 |
AltF9 |
Ctrl0 |
Ctrl1 |
Ctrl2 |
Ctrl3 |
Ctrl4 |
Ctrl5 |
Ctrl6 |
Ctrl7 |
Ctrl8 |
Ctrl9 |
CtrlA |
CtrlB |
CtrlC |
CtrlD |
CtrlDel |
CtrlE |
CtrlF |
CtrlF1 |
CtrlF10 |
CtrlF11 |
CtrlF12 |
CtrlF2 |
CtrlF3 |
CtrlF4 |
CtrlF5 |
CtrlF6 |
CtrlF7 |
CtrlF8 |
CtrlF9 |
CtrlG |
CtrlH |
CtrlI |
CtrlIns |
CtrlJ |
CtrlK |
CtrlL |
CtrlM |
CtrlN |
CtrlO |
CtrlP |
CtrlQ |
CtrlR |
CtrlS |
CtrlShift0 |
CtrlShift1 |
CtrlShift2 |
CtrlShift3 |
CtrlShift4 |
CtrlShift5 |
CtrlShift6 |
CtrlShift7 |
CtrlShift8 |
CtrlShift9 |
CtrlShiftA |
CtrlShiftB |
CtrlShiftC |
CtrlShiftD |
CtrlShiftE |
CtrlShiftF |
CtrlShiftF1 |
CtrlShiftF10 |
CtrlShiftF11 |
CtrlShiftF12 |
CtrlShiftF2 |
CtrlShiftF3 |
CtrlShiftF4 |
CtrlShiftF5 |
CtrlShiftF6 |
CtrlShiftF7 |
CtrlShiftF8 |
CtrlShiftF9 |
CtrlShiftG |
CtrlShiftH |
CtrlShiftI |
CtrlShiftJ |
CtrlShiftK |
CtrlShiftL |
CtrlShiftM |
CtrlShiftN |
CtrlShiftO |
CtrlShiftP |
CtrlShiftQ |
CtrlShiftR |
CtrlShiftS |
CtrlShiftT |
CtrlShiftU |
CtrlShiftV |
CtrlShiftW |
CtrlShiftX |
CtrlShiftY |
CtrlShiftZ |
CtrlT |
CtrlU |
CtrlV |
CtrlW |
CtrlX |
CtrlY |
CtrlZ |
Del |
F1 |
F10 |
F11 |
F12 |
F2 |
F3 |
F4 |
F5 |
F6 |
F7 |
F8 |
F9 |
Ins |
None |
ShiftDel |
ShiftF1 |
ShiftF10 |
ShiftF11 |
ShiftF12 |
ShiftF2 |
ShiftF3 |
ShiftF4 |
ShiftF5 |
ShiftF6 |
ShiftF7 |
ShiftF8 |
ShiftF9 |
ShiftIns |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.Shortcut

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


SizeType Enumeration

[image]
Gizmox.WebGUI.Forms
SizeType Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : SizeType Enumeration

Syntax

Visual Basic (Declaration)
Public Enum SizeType
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As SizeType
C#
public enum SizeType : Enum
Managed Extensions for C++
__value public enum SizeType : public Enum
C++/CLI
public enum class SizeType : public Enum

Members

Member | Description
AutoSize |
Absolute |
Percent |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.SizeType

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


SortOrder Enumeration

[image]
Gizmox.WebGUI.Forms
SortOrder Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : SortOrder Enumeration

sort order options enumeration

Syntax

Visual Basic (Declaration)
Public Enum SortOrder
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As SortOrder
C#
public enum SortOrder : Enum
Managed Extensions for C++
__value public enum SortOrder : public Enum
C++/CLI
public enum class SortOrder : public Enum

Members

Member | Description
Ascending |
Descending |
None |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.SortOrder

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


StatusBarPanelAutoSize Enumeration

[image]
Gizmox.WebGUI.Forms
StatusBarPanelAutoSize Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : StatusBarPanelAutoSize Enumeration

Specifies how a StatusBarPanel on a StatusBar control behaves when the control resizes.

Syntax

Visual Basic (Declaration)
Public Enum StatusBarPanelAutoSize
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As StatusBarPanelAutoSize
C#
public enum StatusBarPanelAutoSize : Enum
Managed Extensions for C++
__value public enum StatusBarPanelAutoSize : public Enum
C++/CLI
public enum class StatusBarPanelAutoSize : public Enum

Members

Member | Description
Contents | The width of the StatusBarPanel is determined by its contents.
None | The StatusBarPanel does not change size when the StatusBar control resizes.
Spring | The StatusBarPanel shares the available space on the StatusBar (the space not taken up by other panels whose StatusBarPanel.AutoSize property is set to None or Contents) with other panels that have their StatusBarPanel.AutoSize property set to Spring.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.StatusBarPanelAutoSize

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


TabAppearance Enumeration

[image]
Gizmox.WebGUI.Forms
TabAppearance Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TabAppearance Enumeration

Specifies the appearance of the tabs in a tab control.

Syntax

Visual Basic (Declaration)
Public Enum TabAppearance
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As TabAppearance
C#
public enum TabAppearance : Enum
Managed Extensions for C++
__value public enum TabAppearance : public Enum
C++/CLI
public enum class TabAppearance : public Enum

Members

Member | Description
Normal | The tabs have the standard appearance of tabs.
Buttons | The tabs have the appearance of three-dimensional buttons.
FlatButtons | The tabs have the appearance of flat buttons.
Workspace | The tabs have the appearance of workspace buttons.
Logical | The tabs have the appearance of logical buttons.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.TabAppearance

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


TabControlClientBehavior Enumeration

[image]
Gizmox.WebGUI.Forms
TabControlClientBehavior Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TabControlClientBehavior Enumeration

Tab control client behavior modes

Syntax

Visual Basic (Declaration)
Public Enum TabControlClientBehavior
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As TabControlClientBehavior
C#
public enum TabControlClientBehavior : Enum
Managed Extensions for C++
__value public enum TabControlClientBehavior : public Enum
C++/CLI
public enum class TabControlClientBehavior : public Enum

Members

Member | Description
MemoryOptimized | TabControl draws only on tab at a time. This mode is optimized for large tab page content displaying in DHTML. When loading lots of controls or data intensive controls in multiple tabs, this mode avoids browser from having to deal with large amount of dom elements.
DrawingOptimized | TabControl does not redraw its tabs when switching between tabs. This mode is optimized for resonable tab page content and provides an advantage for working with browser navigation inside the tab pages.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.TabControlClientBehavior

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


TableLayoutPanelCellBorderStyle Enumeration

[image]
Gizmox.WebGUI.Forms
TableLayoutPanelCellBorderStyle Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TableLayoutPanelCellBorderStyle Enumeration

Syntax

Visual Basic (Declaration)
Public Enum TableLayoutPanelCellBorderStyle
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutPanelCellBorderStyle
C#
public enum TableLayoutPanelCellBorderStyle : Enum
Managed Extensions for C++
__value public enum TableLayoutPanelCellBorderStyle : public Enum
C++/CLI
public enum class TableLayoutPanelCellBorderStyle : public Enum

Members

Member | Description
None |
Single |
Inset |
InsetDouble |
Outset |
OutsetDouble |
OutsetPartial |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.TableLayoutPanelCellBorderStyle

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


TableLayoutPanelGrowStyle Enumeration

[image]
Gizmox.WebGUI.Forms
TableLayoutPanelGrowStyle Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TableLayoutPanelGrowStyle Enumeration

Syntax

Visual Basic (Declaration)
Public Enum TableLayoutPanelGrowStyle
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutPanelGrowStyle
C#
public enum TableLayoutPanelGrowStyle : Enum
Managed Extensions for C++
__value public enum TableLayoutPanelGrowStyle : public Enum
C++/CLI
public enum class TableLayoutPanelGrowStyle : public Enum

Members

Member | Description
FixedSize |
AddRows |
AddColumns |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.TableLayoutPanelGrowStyle

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


TextDataFormat Enumeration

[image]
Gizmox.WebGUI.Forms
TextDataFormat Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TextDataFormat Enumeration

Specifies the formats used with text-related methods of the Clipboard and DataObject classes.

Syntax

Visual Basic (Declaration)
Public Enum TextDataFormat
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As TextDataFormat
C#
public enum TextDataFormat : Enum
Managed Extensions for C++
__value public enum TextDataFormat : public Enum
C++/CLI
public enum class TextDataFormat : public Enum

Members

Member | Description
Text |
UnicodeText |
Rtf |
Html |
CommaSeparatedValue |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.TextDataFormat

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


TextFormatFlags Enumeration

[image]
Gizmox.WebGUI.Forms
TextFormatFlags Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TextFormatFlags Enumeration

Specifies the display and layout information for text strings.

Syntax

Visual Basic (Declaration)
<FlagsAttribute()>
Public Enum TextFormatFlags
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As TextFormatFlags
C#
[FlagsAttribute()]
public enum TextFormatFlags : Enum
Managed Extensions for C++
[FlagsAttribute()]
__value public enum TextFormatFlags : public Enum
C++/CLI
[FlagsAttribute()]
public enum class TextFormatFlags : public Enum

Members

Member | Description
Bottom | Aligns the text on the bottom of the bounding rectangle. Applied only when the text is a single line.
Default | Applies the default formatting, which is left-aligned.
EndEllipsis | Removes the end of trimmed lines, and replaces them with an ellipsis.
ExpandTabs | Expands tab characters. The default number of characters per tab is eight. The WordEllipsis, PathEllipsis, and EndEllipsis values cannot be used with ExpandTabs.
ExternalLeading | Includes the font external leading in line height. Typically, external leading is not included in the height of a line of text.
GlyphOverhangPadding | Adds padding to the bounding rectangle to accommodate overhanging glyphs.
HidePrefix | Applies to Windows 2000 and Windows XP only:
HorizontalCenter | Centers the text horizontally within the bounding rectangle.
Internal | Uses the system font to calculate text metrics.
Left | Aligns the text on the left side of the clipping area.
LeftAndRightPadding | Adds padding to both sides of the bounding rectangle.
ModifyString | Modifies the specified string to match the displayed text. This value has no effect unless EndEllipsis or PathEllipsis is also specified.
NoClipping | Allows the overhanging parts of glyphs and unwrapped text reaching outside the formatting rectangle to show.
NoFullWidthCharacterBreak | Applies to Windows 98, Windows Me, Windows 2000, or Windows XP only:
NoPadding | Does not add padding to the bounding rectangle.
NoPrefix | Turns off processing of prefix characters. Typically, the ampersand (&) mnemonic-prefix character is interpreted as a directive to underscore the character that follows, and the double-ampersand (&&) mnemonic-prefix characters as a directive to print a single ampersand. By specifying NoPrefix, this processing is turned off. For example, an input string of "A&bc&&d" with NoPrefix applied would result in output of "A&bc&&d".
PathEllipsis | Removes the center of trimmed lines and replaces it with an ellipsis.
PrefixOnly | Applies to Windows 2000 or Windows XP only:
PreserveGraphicsClipping | Preserves the clipping specified by a Graphics object. Applies only to methods receiving an IDeviceContext that is a Graphics.
PreserveGraphicsTranslateTransform | Preserves the transformation specified by a Graphics. Applies only to methods receiving an IDeviceContext that is a Graphics.
Right | Aligns the text on the right side of the clipping area.
RightToLeft | Displays the text from right to left.
SingleLine | Displays the text in a single line.
TextBoxControl | Specifies the text should be formatted for display on a TextBox control.
Top | Aligns the text on the top of the bounding rectangle.
VerticalCenter | Centers the text vertically, within the bounding rectangle.
WordBreak | Breaks the text at the end of a word.
WordEllipsis | Trims the line to the nearest word and an ellipsis is placed at the end of a trimmed line.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.TextFormatFlags

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


TextImageRelation Enumeration

[image]
Gizmox.WebGUI.Forms
TextImageRelation Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TextImageRelation Enumeration

Specifies the position of the text and image relative to each other on a control.

Syntax

Visual Basic (Declaration)
Public Enum TextImageRelation
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As TextImageRelation
C#
public enum TextImageRelation : Enum
Managed Extensions for C++
__value public enum TextImageRelation : public Enum
C++/CLI
public enum class TextImageRelation : public Enum

Members

Member | Description
ImageAboveText | Specifies that the image is displayed vertically above the text of a control.
ImageBeforeText | Specifies that the image is displayed horizontally before the text of a control.
Overlay | Specifies that the image and text share the same space on a control.
TextAboveImage | Specifies that the text is displayed vertically above the image of a control.
TextBeforeImage | Specifies that the text is displayed horizontally before the image of a control.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.TextImageRelation

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


TickStyle Enumeration

[image]
Gizmox.WebGUI.Forms
TickStyle Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TickStyle Enumeration

Specifies the location of tick marks in a TrackBar control.

Syntax

Visual Basic (Declaration)
Public Enum TickStyle
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As TickStyle
C#
public enum TickStyle : Enum
Managed Extensions for C++
__value public enum TickStyle : public Enum
C++/CLI
public enum class TickStyle : public Enum

Members

Member | Description
None | No tick marks appear in the control.
TopLeft | Tick marks are located on the top of a horizontal control or on the left of a vertical control.
BottomRight | Tick marks are located on the bottom of a horizontal control or on the right side of a vertical control.
Both | Tick marks are located on both sides of the control.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.TickStyle

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


ToolBarAppearance Enumeration

[image]
Gizmox.WebGUI.Forms
ToolBarAppearance Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ToolBarAppearance Enumeration

Toolbar appeatance style

Syntax

Visual Basic (Declaration)
Public Enum ToolBarAppearance
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As ToolBarAppearance
C#
public enum ToolBarAppearance : Enum
Managed Extensions for C++
__value public enum ToolBarAppearance : public Enum
C++/CLI
public enum class ToolBarAppearance : public Enum

Members

Member | Description
Flat |
Normal |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.ToolBarAppearance

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


ToolBarButtonStyle Enumeration

[image]
Gizmox.WebGUI.Forms
ToolBarButtonStyle Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ToolBarButtonStyle Enumeration

Toolbar button stylr

Syntax

Visual Basic (Declaration)
Public Enum ToolBarButtonStyle
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As ToolBarButtonStyle
C#
public enum ToolBarButtonStyle : Enum
Managed Extensions for C++
__value public enum ToolBarButtonStyle : public Enum
C++/CLI
public enum class ToolBarButtonStyle : public Enum

Members

Member | Description
DropDownButton |
PushButton |
Separator |
ToggleButton |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.ToolBarButtonStyle

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


ToolBarTextAlign Enumeration

[image]
Gizmox.WebGUI.Forms
ToolBarTextAlign Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ToolBarTextAlign Enumeration

Toolbar buttons text alignment

Syntax

Visual Basic (Declaration)
Public Enum ToolBarTextAlign
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As ToolBarTextAlign
C#
public enum ToolBarTextAlign : Enum
Managed Extensions for C++
__value public enum ToolBarTextAlign : public Enum
C++/CLI
public enum class ToolBarTextAlign : public Enum

Members

Member | Description
Right |
Underneath |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.ToolBarTextAlign

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


TreeViewAction Enumeration

[image]
Gizmox.WebGUI.Forms
TreeViewAction Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TreeViewAction Enumeration

Syntax

Visual Basic (Declaration)
Public Enum TreeViewAction
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As TreeViewAction
C#
public enum TreeViewAction : Enum
Managed Extensions for C++
__value public enum TreeViewAction : public Enum
C++/CLI
public enum class TreeViewAction : public Enum

Members

Member | Description
ByKeyboard |
ByMouse |
Collapse |
Expand |
Unknown |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.TreeViewAction

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


View Enumeration

[image]
Gizmox.WebGUI.Forms
View Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : View Enumeration

The list display mode

Syntax

Visual Basic (Declaration)
Public Enum View
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As View
C#
public enum View : Enum
Managed Extensions for C++
__value public enum View : public Enum
C++/CLI
public enum class View : public Enum

Members

Member | Description
Details |
LargeIcon |
List |
SmallIcon |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.View

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


XamlBoxType Enumeration

[image]
Gizmox.WebGUI.Forms
XamlBoxType Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : XamlBoxType Enumeration

The silverlight content type

Syntax

Visual Basic (Declaration)
Public Enum XamlBoxType
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As XamlBoxType
C#
public enum XamlBoxType : Enum
Managed Extensions for C++
__value public enum XamlBoxType : public Enum
C++/CLI
public enum class XamlBoxType : public Enum

Members

Member | Description
XAML |
URL |
UNC |
RESOURCE |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.XamlBoxType

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


BindingMemberInfo Structure

[image]
Gizmox.WebGUI.Forms
BindingMemberInfo Structure
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : BindingMemberInfo Structure

Contains information that enables a Binding to resolve a data binding to either the property of an object or the property of the current object in a list of objects.

Syntax

Visual Basic (Declaration)
Public Structure BindingMemberInfo
   Inherits ValueType
Visual Basic (Usage) Copy Code
Dim instance As BindingMemberInfo
C#
public struct BindingMemberInfo : ValueType
Managed Extensions for C++
public __value struct BindingMemberInfo : public ValueType
C++/CLI
public value class BindingMemberInfo : public ValueType

Inheritance Hierarchy

System.Object
System.ValueType
Gizmox.WebGUI.Forms.BindingMemberInfo

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

BindingMemberInfo Members
Gizmox.WebGUI.Forms Namespace


BindingMemberInfo Structure Members

[image]
Gizmox.WebGUI.Forms
BindingMemberInfo Structure Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : BindingMemberInfo Structure

The following tables list the members exposed by BindingMemberInfo.

Public Constructors

 | Name | Description
Public Constructor | BindingMemberInfo Constructor | Initializes a new instance of the BindingMemberInfo class.
Top

Public Properties

 | Name | Description
Public Property | BindingField | Gets the property name of the data-bound object.
Public Property | BindingMember | Gets the information that is used to specify the property name of the data-bound object.
Public Property | BindingPath | Gets the property name, or the period-delimited hierarchy of property names, that comes before the property name of the data-bound object.
Top

Public Methods

 | Name | Description
Public Method | Equals | Overridden. Determines whether the specified object is equal to this BindingMemberInfo.
Public Method | GetHashCode | Overridden. Returns the hash code for this BindingMemberInfo.
Public Method | ToString | Returns the fully qualified type name of this instance. (Inherited from System.ValueType)
Top

See Also

Reference

BindingMemberInfo Structure
Gizmox.WebGUI.Forms Namespace


BindingMemberInfo Constructor

[image]
Gizmox.WebGUI.Forms
BindingMemberInfo Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingMemberInfo Structure : BindingMemberInfo Constructor

dataMember
A navigation path that resolves to either the property of an object or the property of the current object in a list of objects.
Initializes a new instance of the BindingMemberInfo class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal dataMember As String _
)
Visual Basic (Usage) Copy Code
Dim dataMember As String

Dim instance As BindingMemberInfo(dataMember)
C#
public BindingMemberInfo(
   string dataMember
)
Managed Extensions for C++
public: BindingMemberInfo(
   string* dataMember
)
C++/CLI
public:
BindingMemberInfo(
   String^ dataMember
)

Parameters

dataMember
A navigation path that resolves to either the property of an object or the property of the current object in a list of objects.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingMemberInfo Structure
BindingMemberInfo Members


BindingMemberInfo Structure Methods

[image]
Gizmox.WebGUI.Forms
BindingMemberInfo Structure Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : BindingMemberInfo Structure

For a list of all members of this type, see BindingMemberInfo members.

Public Methods

 | Name | Description
Public Method | Equals | Overridden. Determines whether the specified object is equal to this BindingMemberInfo.
Public Method | GetHashCode | Overridden. Returns the hash code for this BindingMemberInfo.
Public Method | ToString | Returns the fully qualified type name of this instance. (Inherited from System.ValueType)
Top

See Also

Reference

BindingMemberInfo Structure
Gizmox.WebGUI.Forms Namespace


Equals Method

[image]
Gizmox.WebGUI.Forms
Equals Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingMemberInfo Structure : Equals Method

otherObject
The object to compare for equality.
Determines whether the specified object is equal to this BindingMemberInfo.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function Equals( _
   ByVal otherObject As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As BindingMemberInfo
Dim otherObject As Object
Dim value As Boolean

value = instance.Equals(otherObject)
C#
public override bool Equals(
   object otherObject
)
Managed Extensions for C++
public: bool Equals(
   Object* otherObject
) override
C++/CLI
public:
bool Equals(
   Object^ otherObject
) override

Parameters

otherObject
The object to compare for equality.

Return Value

true if otherObject is a BindingMemberInfo and both BindingMember strings are equal; otherwise false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingMemberInfo Structure
BindingMemberInfo Members


GetHashCode Method

[image]
Gizmox.WebGUI.Forms
GetHashCode Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingMemberInfo Structure : GetHashCode Method

Returns the hash code for this BindingMemberInfo.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As BindingMemberInfo
Dim value As Integer

value = instance.GetHashCode()
C#
public override int GetHashCode()
Managed Extensions for C++
public: int GetHashCode(); override
C++/CLI
public:
int GetHashCode(); override

Return Value

The hash code for this BindingMemberInfo.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingMemberInfo Structure
BindingMemberInfo Members


BindingMemberInfo Structure Properties

[image]
Gizmox.WebGUI.Forms
BindingMemberInfo Structure Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : BindingMemberInfo Structure

For a list of all members of this type, see BindingMemberInfo members.

Public Properties

 | Name | Description
Public Property | BindingField | Gets the property name of the data-bound object.
Public Property | BindingMember | Gets the information that is used to specify the property name of the data-bound object.
Public Property | BindingPath | Gets the property name, or the period-delimited hierarchy of property names, that comes before the property name of the data-bound object.
Top

See Also

Reference

BindingMemberInfo Structure
Gizmox.WebGUI.Forms Namespace


BindingField Property

[image]
Gizmox.WebGUI.Forms
BindingField Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingMemberInfo Structure : BindingField Property

Gets the property name of the data-bound object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property BindingField As String
Visual Basic (Usage) Copy Code
Dim instance As BindingMemberInfo
Dim value As String

value = instance.BindingField
C#
public string BindingField {get;}
Managed Extensions for C++
public: __property string* get_BindingField();
C++/CLI
public:
property String^ BindingField {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingMemberInfo Structure
BindingMemberInfo Members


BindingMember Property

[image]
Gizmox.WebGUI.Forms
BindingMember Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingMemberInfo Structure : BindingMember Property

Gets the information that is used to specify the property name of the data-bound object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property BindingMember As String
Visual Basic (Usage) Copy Code
Dim instance As BindingMemberInfo
Dim value As String

value = instance.BindingMember
C#
public string BindingMember {get;}
Managed Extensions for C++
public: __property string* get_BindingMember();
C++/CLI
public:
property String^ BindingMember {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingMemberInfo Structure
BindingMemberInfo Members


BindingPath Property

[image]
Gizmox.WebGUI.Forms
BindingPath Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > BindingMemberInfo Structure : BindingPath Property

Gets the property name, or the period-delimited hierarchy of property names, that comes before the property name of the data-bound object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property BindingPath As String
Visual Basic (Usage) Copy Code
Dim instance As BindingMemberInfo
Dim value As String

value = instance.BindingPath
C#
public string BindingPath {get;}
Managed Extensions for C++
public: __property string* get_BindingPath();
C++/CLI
public:
property String^ BindingPath {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

BindingMemberInfo Structure
BindingMemberInfo Members


Padding Structure

[image]
Gizmox.WebGUI.Forms
Padding Structure
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : Padding Structure

Represents padding or margin information associated with a user interface (UI) element.

Syntax

Visual Basic (Declaration)
<TypeConverterAttribute("Gizmox.WebGUI.Forms.PaddingConverter, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d")>
Public Structure Padding
   Inherits ValueType
Visual Basic (Usage) Copy Code
Dim instance As Padding
C#
[TypeConverterAttribute("Gizmox.WebGUI.Forms.PaddingConverter, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d")]
public struct Padding : ValueType
Managed Extensions for C++
[TypeConverterAttribute("Gizmox.WebGUI.Forms.PaddingConverter, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d")]
public __value struct Padding : public ValueType
C++/CLI
[TypeConverterAttribute("Gizmox.WebGUI.Forms.PaddingConverter, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d")]
public value class Padding : public ValueType

Inheritance Hierarchy

System.Object
System.ValueType
Gizmox.WebGUI.Forms.Padding

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Padding Members
Gizmox.WebGUI.Forms Namespace


Padding Structure Members

[image]
Gizmox.WebGUI.Forms
Padding Structure Members
See Also Fields Properties Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : Padding Structure

The following tables list the members exposed by Padding.

Public Constructors

 | Name | Description
Public Constructor | Padding Constructor | Overloaded. Initializes a new instance of the Padding class using the supplied padding size for all edges.
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Empty | Provides a Padding object with no padding.
Top

Public Properties

 | Name | Description
Public Property | All | Gets or sets the padding value for all the edges.
Public Property | Bottom | Gets or sets the padding value for the bottom edge.
Public Property | Horizontal | Gets the combined padding for the right and left edges.
Public Property | Left | Gets or sets the padding value for the left edge.
Public Property | Right | Gets or sets the padding value for the right edge.
Public Property | Size | Gets the padding information in the form of a Size.
Public Property | Top | Gets or sets the padding value for the top edge.
Public Property | Vertical | Gets the combined padding for the top and bottom edges.
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Add | Computes the sum of the two specified Padding values.
Public Method | Equals | Overridden. Determines whether the value of the specified object is equivalent to the current Padding.
Public Method | GetHashCode | Overridden. Generates a hash code for the current Padding.
static (Shared in Visual Basic) | Subtract | Subtracts one specified Padding value from another.
Public Method | ToString | Overridden. Returns a string that represents the current Padding.
Top

See Also

Reference

Padding Structure
Gizmox.WebGUI.Forms Namespace


Padding Constructor

[image]
Gizmox.WebGUI.Forms
Padding Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Padding Structure : Padding Constructor

Initializes a new instance of the Padding class using the supplied padding size for all edges.

Overload List

Overload | Description
Padding Constructor(Int32) | Initializes a new instance of the Padding class using the supplied padding size for all edges.
Padding Constructor(Int32,Int32,Int32,Int32) | Initializes a new instance of the Padding class using a separate padding size for each edge.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Padding Structure
Padding Members


Padding Constructor(Int32)

[image]
Gizmox.WebGUI.Forms
Padding Constructor(Int32)
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Padding Structure > Padding Constructor : Padding Constructor(Int32)

all
The number of pixels to be used for padding for all edges.
Initializes a new instance of the Padding class using the supplied padding size for all edges.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal all As Integer _
)
Visual Basic (Usage) Copy Code
Dim all As Integer

Dim instance As Padding(all)
C#
public Padding(
   int all
)
Managed Extensions for C++
public: Padding(
   int all
)
C++/CLI
public:
Padding(
   int all
)

Parameters

all
The number of pixels to be used for padding for all edges.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Padding Structure
Padding Members
Overload List


Padding Constructor(Int32,Int32,Int32,Int32)

[image]
Gizmox.WebGUI.Forms
Padding Constructor(Int32,Int32,Int32,Int32)
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Padding Structure > Padding Constructor : Padding Constructor(Int32,Int32,Int32,Int32)

left
The padding size, in pixels, for the left edge.
top
The padding size, in pixels, for the top edge.
right
The padding size, in pixels, for the right edge.
bottom
The padding size, in pixels, for the bottom edge.
Initializes a new instance of the Padding class using a separate padding size for each edge.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal left As Integer, _
   ByVal top As Integer, _
   ByVal right As Integer, _
   ByVal bottom As Integer _
)
Visual Basic (Usage) Copy Code
Dim left As Integer
Dim top As Integer
Dim right As Integer
Dim bottom As Integer

Dim instance As Padding(left, top, right, bottom)
C#
public Padding(
   int left,
   int top,
   int right,
   int bottom
)
Managed Extensions for C++
public: Padding(
   int left,
   int top,
   int right,
   int bottom
)
C++/CLI
public:
Padding(
   int left,
   int top,
   int right,
   int bottom
)

Parameters

left
The padding size, in pixels, for the left edge.
top
The padding size, in pixels, for the top edge.
right
The padding size, in pixels, for the right edge.
bottom
The padding size, in pixels, for the bottom edge.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Padding Structure
Padding Members
Overload List


Padding Structure Methods

[image]
Gizmox.WebGUI.Forms
Padding Structure Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : Padding Structure

For a list of all members of this type, see Padding members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Add | Computes the sum of the two specified Padding values.
Public Method | Equals | Overridden. Determines whether the value of the specified object is equivalent to the current Padding.
Public Method | GetHashCode | Overridden. Generates a hash code for the current Padding.
static (Shared in Visual Basic) | Subtract | Subtracts one specified Padding value from another.
Public Method | ToString | Overridden. Returns a string that represents the current Padding.
Top

See Also

Reference

Padding Structure
Gizmox.WebGUI.Forms Namespace


Add Method

[image]
Gizmox.WebGUI.Forms
Add Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Padding Structure : Add Method

p1
A Padding.
p2
A Padding.
Computes the sum of the two specified Padding values.

Syntax

Visual Basic (Declaration)
Public Shared Function Add( _
   ByVal p1 As Padding, _
   ByVal p2 As Padding _
) As Padding
Visual Basic (Usage) Copy Code
Dim p1 As Padding
Dim p2 As Padding
Dim value As Padding

value = Padding.Add(p1, p2)
C#
public static Padding Add(
   Padding p1,
   Padding p2
)
Managed Extensions for C++
public: static Padding Add(
   Padding p1,
   Padding p2
)
C++/CLI
public:
static Padding Add(
   Padding p1,
   Padding p2
)

Parameters

p1
A Padding.
p2
A Padding.

Return Value

A Padding that contains the sum of the two specified Padding values.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Padding Structure
Padding Members


Equals Method

[image]
Gizmox.WebGUI.Forms
Equals Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Padding Structure : Equals Method

other
The object to compare to the current Padding.
Determines whether the value of the specified object is equivalent to the current Padding.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function Equals( _
   ByVal other As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Padding
Dim other As Object
Dim value As Boolean

value = instance.Equals(other)
C#
public override bool Equals(
   object other
)
Managed Extensions for C++
public: bool Equals(
   Object* other
) override
C++/CLI
public:
bool Equals(
   Object^ other
) override

Parameters

other
The object to compare to the current Padding.

Return Value

true if the Padding objects are equivalent; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Padding Structure
Padding Members


GetHashCode Method

[image]
Gizmox.WebGUI.Forms
GetHashCode Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Padding Structure : GetHashCode Method

Generates a hash code for the current Padding.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As Padding
Dim value As Integer

value = instance.GetHashCode()
C#
public override int GetHashCode()
Managed Extensions for C++
public: int GetHashCode(); override
C++/CLI
public:
int GetHashCode(); override

Return Value

A 32-bit signed integer.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Padding Structure
Padding Members


Subtract Method

[image]
Gizmox.WebGUI.Forms
Subtract Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Padding Structure : Subtract Method

p1
A Padding.
p2
A Padding.
Subtracts one specified Padding value from another.

Syntax

Visual Basic (Declaration)
Public Shared Function Subtract( _
   ByVal p1 As Padding, _
   ByVal p2 As Padding _
) As Padding
Visual Basic (Usage) Copy Code
Dim p1 As Padding
Dim p2 As Padding
Dim value As Padding

value = Padding.Subtract(p1, p2)
C#
public static Padding Subtract(
   Padding p1,
   Padding p2
)
Managed Extensions for C++
public: static Padding Subtract(
   Padding p1,
   Padding p2
)
C++/CLI
public:
static Padding Subtract(
   Padding p1,
   Padding p2
)

Parameters

p1
A Padding.
p2
A Padding.

Return Value

A Padding that contains the result of the subtraction of one specified Padding value from another.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Padding Structure
Padding Members


ToString Method

[image]
Gizmox.WebGUI.Forms
ToString Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Padding Structure : ToString Method

Returns a string that represents the current Padding.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As Padding
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Return Value

A String that represents the current Padding.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Padding Structure
Padding Members


Padding Structure Properties

[image]
Gizmox.WebGUI.Forms
Padding Structure Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : Padding Structure

For a list of all members of this type, see Padding members.

Public Properties

 | Name | Description
Public Property | All | Gets or sets the padding value for all the edges.
Public Property | Bottom | Gets or sets the padding value for the bottom edge.
Public Property | Horizontal | Gets the combined padding for the right and left edges.
Public Property | Left | Gets or sets the padding value for the left edge.
Public Property | Right | Gets or sets the padding value for the right edge.
Public Property | Size | Gets the padding information in the form of a Size.
Public Property | Top | Gets or sets the padding value for the top edge.
Public Property | Vertical | Gets the combined padding for the top and bottom edges.
Top

See Also

Reference

Padding Structure
Gizmox.WebGUI.Forms Namespace


All Property

[image]
Gizmox.WebGUI.Forms
All Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Padding Structure : All Property

Gets or sets the padding value for all the edges.

Syntax

Visual Basic (Declaration)
<RefreshPropertiesAttribute()>
Public Property All As Integer
Visual Basic (Usage) Copy Code
Dim instance As Padding
Dim value As Integer

instance.All = value

value = instance.All
C#
[RefreshPropertiesAttribute()]
public int All {get; set;}
Managed Extensions for C++
[RefreshPropertiesAttribute()]
public: __property int get_All();
public: __property void set_All(
   int value
);
C++/CLI
[RefreshPropertiesAttribute()]
public:
property int All {
   int get();
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Padding Structure
Padding Members


Bottom Property

[image]
Gizmox.WebGUI.Forms
Bottom Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Padding Structure : Bottom Property

Gets or sets the padding value for the bottom edge.

Syntax

Visual Basic (Declaration)
<RefreshPropertiesAttribute()>
Public Property Bottom As Integer
Visual Basic (Usage) Copy Code
Dim instance As Padding
Dim value As Integer

instance.Bottom = value

value = instance.Bottom
C#
[RefreshPropertiesAttribute()]
public int Bottom {get; set;}
Managed Extensions for C++
[RefreshPropertiesAttribute()]
public: __property int get_Bottom();
public: __property void set_Bottom(
   int value
);
C++/CLI
[RefreshPropertiesAttribute()]
public:
property int Bottom {
   int get();
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Padding Structure
Padding Members


Horizontal Property

[image]
Gizmox.WebGUI.Forms
Horizontal Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Padding Structure : Horizontal Property

Gets the combined padding for the right and left edges.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property Horizontal As Integer
Visual Basic (Usage) Copy Code
Dim instance As Padding
Dim value As Integer

value = instance.Horizontal
C#
[BrowsableAttribute(false)]
public int Horizontal {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property int get_Horizontal();
C++/CLI
[BrowsableAttribute(false)]
public:
property int Horizontal {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Padding Structure
Padding Members


Left Property

[image]
Gizmox.WebGUI.Forms
Left Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Padding Structure : Left Property

Gets or sets the padding value for the left edge.

Syntax

Visual Basic (Declaration)
<RefreshPropertiesAttribute()>
Public Property Left As Integer
Visual Basic (Usage) Copy Code
Dim instance As Padding
Dim value As Integer

instance.Left = value

value = instance.Left
C#
[RefreshPropertiesAttribute()]
public int Left {get; set;}
Managed Extensions for C++
[RefreshPropertiesAttribute()]
public: __property int get_Left();
public: __property void set_Left(
   int value
);
C++/CLI
[RefreshPropertiesAttribute()]
public:
property int Left {
   int get();
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Padding Structure
Padding Members


Right Property

[image]
Gizmox.WebGUI.Forms
Right Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Padding Structure : Right Property

Gets or sets the padding value for the right edge.

Syntax

Visual Basic (Declaration)
<RefreshPropertiesAttribute()>
Public Property Right As Integer
Visual Basic (Usage) Copy Code
Dim instance As Padding
Dim value As Integer

instance.Right = value

value = instance.Right
C#
[RefreshPropertiesAttribute()]
public int Right {get; set;}
Managed Extensions for C++
[RefreshPropertiesAttribute()]
public: __property int get_Right();
public: __property void set_Right(
   int value
);
C++/CLI
[RefreshPropertiesAttribute()]
public:
property int Right {
   int get();
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Padding Structure
Padding Members


Size Property

[image]
Gizmox.WebGUI.Forms
Size Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Padding Structure : Size Property

Gets the padding information in the form of a Size.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property Size As Size
Visual Basic (Usage) Copy Code
Dim instance As Padding
Dim value As Size

value = instance.Size
C#
[BrowsableAttribute(false)]
public Size Size {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property Size get_Size();
C++/CLI
[BrowsableAttribute(false)]
public:
property Size Size {
   Size get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Padding Structure
Padding Members


Top Property

[image]
Gizmox.WebGUI.Forms
Top Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Padding Structure : Top Property

Gets or sets the padding value for the top edge.

Syntax

Visual Basic (Declaration)
<RefreshPropertiesAttribute()>
Public Property Top As Integer
Visual Basic (Usage) Copy Code
Dim instance As Padding
Dim value As Integer

instance.Top = value

value = instance.Top
C#
[RefreshPropertiesAttribute()]
public int Top {get; set;}
Managed Extensions for C++
[RefreshPropertiesAttribute()]
public: __property int get_Top();
public: __property void set_Top(
   int value
);
C++/CLI
[RefreshPropertiesAttribute()]
public:
property int Top {
   int get();
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Padding Structure
Padding Members


Vertical Property

[image]
Gizmox.WebGUI.Forms
Vertical Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Padding Structure : Vertical Property

Gets the combined padding for the top and bottom edges.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property Vertical As Integer
Visual Basic (Usage) Copy Code
Dim instance As Padding
Dim value As Integer

value = instance.Vertical
C#
[BrowsableAttribute(false)]
public int Vertical {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property int get_Vertical();
C++/CLI
[BrowsableAttribute(false)]
public:
property int Vertical {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Padding Structure
Padding Members


Padding Structure Fields

[image]
Gizmox.WebGUI.Forms
Padding Structure Fields
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : Padding Structure

For a list of all members of this type, see Padding members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Empty | Provides a Padding object with no padding.
Top

See Also

Reference

Padding Structure
Gizmox.WebGUI.Forms Namespace


Empty Field

[image]
Gizmox.WebGUI.Forms
Empty Field
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Padding Structure : Empty Field

Provides a Padding object with no padding.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Empty As Padding
Visual Basic (Usage) Copy Code
Dim value As Padding

value = Padding.Empty
C#
public static readonly Padding Empty
Managed Extensions for C++
public: static readonly Padding Empty
C++/CLI
public:
static readonly Padding Empty

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Padding Structure
Padding Members


TableLayoutPanelCellPosition Structure

[image]
Gizmox.WebGUI.Forms
TableLayoutPanelCellPosition Structure
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TableLayoutPanelCellPosition Structure

Syntax

Visual Basic (Declaration)
<TypeConverterAttribute("Gizmox.WebGUI.Forms.TableLayoutPanelCellPositionTypeConverter, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d")>
Public Structure TableLayoutPanelCellPosition
   Inherits ValueType
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutPanelCellPosition
C#
[TypeConverterAttribute("Gizmox.WebGUI.Forms.TableLayoutPanelCellPositionTypeConverter, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d")]
public struct TableLayoutPanelCellPosition : ValueType
Managed Extensions for C++
[TypeConverterAttribute("Gizmox.WebGUI.Forms.TableLayoutPanelCellPositionTypeConverter, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d")]
public __value struct TableLayoutPanelCellPosition : public ValueType
C++/CLI
[TypeConverterAttribute("Gizmox.WebGUI.Forms.TableLayoutPanelCellPositionTypeConverter, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d")]
public value class TableLayoutPanelCellPosition : public ValueType

Inheritance Hierarchy

System.Object
System.ValueType
Gizmox.WebGUI.Forms.TableLayoutPanelCellPosition

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

TableLayoutPanelCellPosition Members
Gizmox.WebGUI.Forms Namespace


TableLayoutPanelCellPosition Structure Members

[image]
Gizmox.WebGUI.Forms
TableLayoutPanelCellPosition Structure Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : TableLayoutPanelCellPosition Structure

The following tables list the members exposed by TableLayoutPanelCellPosition.

Public Constructors

 | Name | Description
Public Constructor | TableLayoutPanelCellPosition Constructor |
Top

Public Properties

 | Name | Description
Public Property | Column |
Public Property | Row |
Top

Public Methods

 | Name | Description
Public Method | Equals | Overridden.
Public Method | GetHashCode | Overridden.
Public Method | ToString | Overridden.
Top

See Also

Reference

TableLayoutPanelCellPosition Structure
Gizmox.WebGUI.Forms Namespace


TableLayoutPanelCellPosition Constructor

[image]
Gizmox.WebGUI.Forms
TableLayoutPanelCellPosition Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutPanelCellPosition Structure : TableLayoutPanelCellPosition Constructor

column
row

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal column As Integer, _
   ByVal row As Integer _
)
Visual Basic (Usage) Copy Code
Dim column As Integer
Dim row As Integer

Dim instance As TableLayoutPanelCellPosition(column, row)
C#
public TableLayoutPanelCellPosition(
   int column,
   int row
)
Managed Extensions for C++
public: TableLayoutPanelCellPosition(
   int column,
   int row
)
C++/CLI
public:
TableLayoutPanelCellPosition(
   int column,
   int row
)

Parameters

column
row

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutPanelCellPosition Structure
TableLayoutPanelCellPosition Members


TableLayoutPanelCellPosition Structure Methods

[image]
Gizmox.WebGUI.Forms
TableLayoutPanelCellPosition Structure Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TableLayoutPanelCellPosition Structure

For a list of all members of this type, see TableLayoutPanelCellPosition members.

Public Methods

 | Name | Description
Public Method | Equals | Overridden.
Public Method | GetHashCode | Overridden.
Public Method | ToString | Overridden.
Top

See Also

Reference

TableLayoutPanelCellPosition Structure
Gizmox.WebGUI.Forms Namespace


Equals Method

[image]
Gizmox.WebGUI.Forms
Equals Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutPanelCellPosition Structure : Equals Method

other

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function Equals( _
   ByVal other As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutPanelCellPosition
Dim other As Object
Dim value As Boolean

value = instance.Equals(other)
C#
public override bool Equals(
   object other
)
Managed Extensions for C++
public: bool Equals(
   Object* other
) override
C++/CLI
public:
bool Equals(
   Object^ other
) override

Parameters

other

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutPanelCellPosition Structure
TableLayoutPanelCellPosition Members


GetHashCode Method

[image]
Gizmox.WebGUI.Forms
GetHashCode Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutPanelCellPosition Structure : GetHashCode Method

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutPanelCellPosition
Dim value As Integer

value = instance.GetHashCode()
C#
public override int GetHashCode()
Managed Extensions for C++
public: int GetHashCode(); override
C++/CLI
public:
int GetHashCode(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutPanelCellPosition Structure
TableLayoutPanelCellPosition Members


ToString Method

[image]
Gizmox.WebGUI.Forms
ToString Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutPanelCellPosition Structure : ToString Method

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutPanelCellPosition
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutPanelCellPosition Structure
TableLayoutPanelCellPosition Members


TableLayoutPanelCellPosition Structure Properties

[image]
Gizmox.WebGUI.Forms
TableLayoutPanelCellPosition Structure Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TableLayoutPanelCellPosition Structure

For a list of all members of this type, see TableLayoutPanelCellPosition members.

Public Properties

 | Name | Description
Public Property | Column |
Public Property | Row |
Top

See Also

Reference

TableLayoutPanelCellPosition Structure
Gizmox.WebGUI.Forms Namespace


Column Property

[image]
Gizmox.WebGUI.Forms
Column Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutPanelCellPosition Structure : Column Property

Syntax

Visual Basic (Declaration)
Public Property Column As Integer
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutPanelCellPosition
Dim value As Integer

instance.Column = value

value = instance.Column
C#
public int Column {get; set;}
Managed Extensions for C++
public: __property int get_Column();
public: __property void set_Column(
   int value
);
C++/CLI
public:
property int Column {
   int get();
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutPanelCellPosition Structure
TableLayoutPanelCellPosition Members


Row Property

[image]
Gizmox.WebGUI.Forms
Row Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > TableLayoutPanelCellPosition Structure : Row Property

Syntax

Visual Basic (Declaration)
Public Property Row As Integer
Visual Basic (Usage) Copy Code
Dim instance As TableLayoutPanelCellPosition
Dim value As Integer

instance.Row = value

value = instance.Row
C#
public int Row {get; set;}
Managed Extensions for C++
public: __property int get_Row();
public: __property void set_Row(
   int value
);
C++/CLI
public:
property int Row {
   int get();
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TableLayoutPanelCellPosition Structure
TableLayoutPanelCellPosition Members


Binding.IDataSourceAttributeProvider Interface

[image]
Gizmox.WebGUI.Forms
Binding.IDataSourceAttributeProvider Interface
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : Binding.IDataSourceAttributeProvider Interface

Provides design time attributes for the DataSource property

Syntax

Visual Basic (Declaration)
<EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.DataSourceListEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")>
<TypeConverterAttribute("Gizmox.WebGUI.Forms.Design.DataSourceConverter, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")>
Public Interface Binding.IDataSourceAttributeProvider
Visual Basic (Usage) Copy Code
Dim instance As Binding.IDataSourceAttributeProvider
C#
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.DataSourceListEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[TypeConverterAttribute("Gizmox.WebGUI.Forms.Design.DataSourceConverter, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
public interface Binding.IDataSourceAttributeProvider
Managed Extensions for C++
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.DataSourceListEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[TypeConverterAttribute("Gizmox.WebGUI.Forms.Design.DataSourceConverter, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
public __gc __interface Binding.IDataSourceAttributeProvider
C++/CLI
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.DataSourceListEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[TypeConverterAttribute("Gizmox.WebGUI.Forms.Design.DataSourceConverter, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
public interface class Binding.IDataSourceAttributeProvider

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Binding.IDataSourceAttributeProvider Members
Gizmox.WebGUI.Forms Namespace


Binding.IDataSourceAttributeProvider Interface Members

[image]
Gizmox.WebGUI.Forms
Binding.IDataSourceAttributeProvider Interface Members
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : Binding.IDataSourceAttributeProvider Interface

The following tables list the members exposed by Binding.IDataSourceAttributeProvider.

See Also

Reference

Binding.IDataSourceAttributeProvider Interface
Gizmox.WebGUI.Forms Namespace


IBindableComponent Interface

[image]
Gizmox.WebGUI.Forms
IBindableComponent Interface
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : IBindableComponent Interface

Enables a non-control component to emulate the data-binding behavior of a Windows Forms control.

Syntax

Visual Basic (Declaration)
Public Interface IBindableComponent
Visual Basic (Usage) Copy Code
Dim instance As IBindableComponent
C#
public interface IBindableComponent
Managed Extensions for C++
public __gc __interface IBindableComponent
C++/CLI
public interface class IBindableComponent

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

IBindableComponent Members
Gizmox.WebGUI.Forms Namespace


IBindableComponent Interface Members

[image]
Gizmox.WebGUI.Forms
IBindableComponent Interface Members
See Also Properties Send Feedback
Gizmox.WebGUI.Forms Namespace : IBindableComponent Interface

The following tables list the members exposed by IBindableComponent.

Public Properties

 | Name | Description
Property | BindingContext | Gets or sets the collection of currency managers for the IBindableComponent.
Property | DataBindings | Gets the collection of data-binding objects for this IBindableComponent.
Top

See Also

Reference

IBindableComponent Interface
Gizmox.WebGUI.Forms Namespace


IBindableComponent Interface Properties

[image]
Gizmox.WebGUI.Forms
IBindableComponent Interface Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : IBindableComponent Interface

For a list of all members of this type, see IBindableComponent members.

Public Properties

 | Name | Description
Property | BindingContext | Gets or sets the collection of currency managers for the IBindableComponent.
Property | DataBindings | Gets the collection of data-binding objects for this IBindableComponent.
Top

See Also

Reference

IBindableComponent Interface
Gizmox.WebGUI.Forms Namespace


BindingContext Property

[image]
Gizmox.WebGUI.Forms
BindingContext Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > IBindableComponent Interface : BindingContext Property

Gets or sets the collection of currency managers for the IBindableComponent.

Syntax

Visual Basic (Declaration)
Property BindingContext As BindingContext
Visual Basic (Usage) Copy Code
Dim instance As IBindableComponent
Dim value As BindingContext

instance.BindingContext = value

value = instance.BindingContext
C#
BindingContext BindingContext {get; set;}
Managed Extensions for C++
__property BindingContext* get_BindingContext();
__property void set_BindingContext(
   BindingContext* value
);
C++/CLI
property BindingContext^ BindingContext {
   BindingContext^ get();
   void set (BindingContext^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IBindableComponent Interface
IBindableComponent Members


DataBindings Property

[image]
Gizmox.WebGUI.Forms
DataBindings Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > IBindableComponent Interface : DataBindings Property

Gets the collection of data-binding objects for this IBindableComponent.

Syntax

Visual Basic (Declaration)
ReadOnly Property DataBindings As ControlBindingsCollection
Visual Basic (Usage) Copy Code
Dim instance As IBindableComponent
Dim value As ControlBindingsCollection

value = instance.DataBindings
C#
ControlBindingsCollection DataBindings {get;}
Managed Extensions for C++
__property ControlBindingsCollection* get_DataBindings();
C++/CLI
property ControlBindingsCollection^ DataBindings {
   ControlBindingsCollection^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IBindableComponent Interface
IBindableComponent Members


IButtonControl Interface

[image]
Gizmox.WebGUI.Forms
IButtonControl Interface
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : IButtonControl Interface

Summary description for IButton.

Syntax

Visual Basic (Declaration)
Public Interface IButtonControl
Visual Basic (Usage) Copy Code
Dim instance As IButtonControl
C#
public interface IButtonControl
Managed Extensions for C++
public __gc __interface IButtonControl
C++/CLI
public interface class IButtonControl

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

IButtonControl Members
Gizmox.WebGUI.Forms Namespace


IButtonControl Interface Members

[image]
Gizmox.WebGUI.Forms
IButtonControl Interface Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : IButtonControl Interface

The following tables list the members exposed by IButtonControl.

Public Properties

 | Name | Description
Property | DialogResult | Gets or sets the value returned to the parent form when the button is clicked.
Top

Public Methods

 | Name | Description
Method | NotifyDefault | Notifies a control that it is the default button so that its appearance and behavior is adjusted accordingly.
Method | PerformClick | Generates a Click event for the control.
Top

See Also

Reference

IButtonControl Interface
Gizmox.WebGUI.Forms Namespace


IButtonControl Interface Methods

[image]
Gizmox.WebGUI.Forms
IButtonControl Interface Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : IButtonControl Interface

For a list of all members of this type, see IButtonControl members.

Public Methods

 | Name | Description
Method | NotifyDefault | Notifies a control that it is the default button so that its appearance and behavior is adjusted accordingly.
Method | PerformClick | Generates a Click event for the control.
Top

See Also

Reference

IButtonControl Interface
Gizmox.WebGUI.Forms Namespace


NotifyDefault Method

[image]
Gizmox.WebGUI.Forms
NotifyDefault Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > IButtonControl Interface : NotifyDefault Method

value
true if the control should behave as a default button; otherwise false.

Notifies a control that it is the default button so that its appearance and behavior is adjusted accordingly.

Syntax

Visual Basic (Declaration)
Sub NotifyDefault( _
   ByVal value As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As IButtonControl
Dim value As Boolean

instance.NotifyDefault(value)
C#
void NotifyDefault(
   bool value
)
Managed Extensions for C++
void NotifyDefault(
   bool value
)
C++/CLI
void NotifyDefault(
   bool value
)

Parameters

value
true if the control should behave as a default button; otherwise false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IButtonControl Interface
IButtonControl Members


PerformClick Method

[image]
Gizmox.WebGUI.Forms
PerformClick Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > IButtonControl Interface : PerformClick Method

Generates a Click event for the control.

Syntax

Visual Basic (Declaration)
Sub PerformClick()
Visual Basic (Usage) Copy Code
Dim instance As IButtonControl

instance.PerformClick()
C#
void PerformClick()
Managed Extensions for C++
void PerformClick();
C++/CLI
void PerformClick();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IButtonControl Interface
IButtonControl Members


IButtonControl Interface Properties

[image]
Gizmox.WebGUI.Forms
IButtonControl Interface Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : IButtonControl Interface

For a list of all members of this type, see IButtonControl members.

Public Properties

 | Name | Description
Property | DialogResult | Gets or sets the value returned to the parent form when the button is clicked.
Top

See Also

Reference

IButtonControl Interface
Gizmox.WebGUI.Forms Namespace


DialogResult Property

[image]
Gizmox.WebGUI.Forms
DialogResult Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > IButtonControl Interface : DialogResult Property

Gets or sets the value returned to the parent form when the button is clicked.

Syntax

Visual Basic (Declaration)
Property DialogResult As DialogResult
Visual Basic (Usage) Copy Code
Dim instance As IButtonControl
Dim value As DialogResult

instance.DialogResult = value

value = instance.DialogResult
C#
DialogResult DialogResult {get; set;}
Managed Extensions for C++
__property DialogResult get_DialogResult();
__property void set_DialogResult(
   DialogResult value
);
C++/CLI
property DialogResult DialogResult {
   DialogResult get();
   void set (DialogResultvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IButtonControl Interface
IButtonControl Members


IContainerControl Interface

[image]
Gizmox.WebGUI.Forms
IContainerControl Interface
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : IContainerControl Interface

Provides the functionality for a control to act as a parent for other controls.

Syntax

Visual Basic (Declaration)
Public Interface IContainerControl
Visual Basic (Usage) Copy Code
Dim instance As IContainerControl
C#
public interface IContainerControl
Managed Extensions for C++
public __gc __interface IContainerControl
C++/CLI
public interface class IContainerControl

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

IContainerControl Members
Gizmox.WebGUI.Forms Namespace


IContainerControl Interface Members

[image]
Gizmox.WebGUI.Forms
IContainerControl Interface Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : IContainerControl Interface

The following tables list the members exposed by IContainerControl.

Public Properties

 | Name | Description
Property | ActiveControl | Gets or sets the control that is active on the container control.
Top

Public Methods

 | Name | Description
Method | ActivateControl | Activates a specified control.
Top

See Also

Reference

IContainerControl Interface
Gizmox.WebGUI.Forms Namespace


IContainerControl Interface Methods

[image]
Gizmox.WebGUI.Forms
IContainerControl Interface Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : IContainerControl Interface

For a list of all members of this type, see IContainerControl members.

Public Methods

 | Name | Description
Method | ActivateControl | Activates a specified control.
Top

See Also

Reference

IContainerControl Interface
Gizmox.WebGUI.Forms Namespace


ActivateControl Method

[image]
Gizmox.WebGUI.Forms
ActivateControl Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > IContainerControl Interface : ActivateControl Method

active
The Control being activated.
Activates a specified control.

Syntax

Visual Basic (Declaration)
Function ActivateControl( _
   ByVal active As Control _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As IContainerControl
Dim active As Control
Dim value As Boolean

value = instance.ActivateControl(active)
C#
bool ActivateControl(
   Control active
)
Managed Extensions for C++
bool ActivateControl(
   Control* active
)
C++/CLI
bool ActivateControl(
   Control^ active
)

Parameters

active
The Control being activated.

Return Value

true if the control is successfully activated; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IContainerControl Interface
IContainerControl Members


IContainerControl Interface Properties

[image]
Gizmox.WebGUI.Forms
IContainerControl Interface Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : IContainerControl Interface

For a list of all members of this type, see IContainerControl members.

Public Properties

 | Name | Description
Property | ActiveControl | Gets or sets the control that is active on the container control.
Top

See Also

Reference

IContainerControl Interface
Gizmox.WebGUI.Forms Namespace


ActiveControl Property

[image]
Gizmox.WebGUI.Forms
ActiveControl Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > IContainerControl Interface : ActiveControl Property

Gets or sets the control that is active on the container control.

Syntax

Visual Basic (Declaration)
Property ActiveControl As Control
Visual Basic (Usage) Copy Code
Dim instance As IContainerControl
Dim value As Control

instance.ActiveControl = value

value = instance.ActiveControl
C#
Control ActiveControl {get; set;}
Managed Extensions for C++
__property Control* get_ActiveControl();
__property void set_ActiveControl(
   Control* value
);
C++/CLI
property Control^ ActiveControl {
   Control^ get();
   void set (Control^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IContainerControl Interface
IContainerControl Members


ICurrencyManagerProvider Interface

[image]
Gizmox.WebGUI.Forms
ICurrencyManagerProvider Interface
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ICurrencyManagerProvider Interface

Provides custom binding management for components.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Provides custom binding management for components.")>
Public Interface ICurrencyManagerProvider
Visual Basic (Usage) Copy Code
Dim instance As ICurrencyManagerProvider
C#
[SRDescriptionAttribute("Provides custom binding management for components.")]
public interface ICurrencyManagerProvider
Managed Extensions for C++
[SRDescriptionAttribute("Provides custom binding management for components.")]
public __gc __interface ICurrencyManagerProvider
C++/CLI
[SRDescriptionAttribute("Provides custom binding management for components.")]
public interface class ICurrencyManagerProvider

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

ICurrencyManagerProvider Members
Gizmox.WebGUI.Forms Namespace


ICurrencyManagerProvider Interface Members

[image]
Gizmox.WebGUI.Forms
ICurrencyManagerProvider Interface Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : ICurrencyManagerProvider Interface

The following tables list the members exposed by ICurrencyManagerProvider.

Public Properties

 | Name | Description
Property | CurrencyManager | Gets the CurrencyManager associated with this ICurrencyManagerProvider.
Top

Public Methods

 | Name | Description
Method | GetRelatedCurrencyManager | Gets the CurrencyManager for this ICurrencyManagerProvider and the specified data member.
Top

See Also

Reference

ICurrencyManagerProvider Interface
Gizmox.WebGUI.Forms Namespace


ICurrencyManagerProvider Interface Methods

[image]
Gizmox.WebGUI.Forms
ICurrencyManagerProvider Interface Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ICurrencyManagerProvider Interface

For a list of all members of this type, see ICurrencyManagerProvider members.

Public Methods

 | Name | Description
Method | GetRelatedCurrencyManager | Gets the CurrencyManager for this ICurrencyManagerProvider and the specified data member.
Top

See Also

Reference

ICurrencyManagerProvider Interface
Gizmox.WebGUI.Forms Namespace


GetRelatedCurrencyManager Method

[image]
Gizmox.WebGUI.Forms
GetRelatedCurrencyManager Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ICurrencyManagerProvider Interface : GetRelatedCurrencyManager Method

dataMember
The name of the column or list, within the data source, to obtain the CurrencyManager for.
Gets the CurrencyManager for this ICurrencyManagerProvider and the specified data member.

Syntax

Visual Basic (Declaration)
Function GetRelatedCurrencyManager( _
   ByVal dataMember As String _
) As CurrencyManager
Visual Basic (Usage) Copy Code
Dim instance As ICurrencyManagerProvider
Dim dataMember As String
Dim value As CurrencyManager

value = instance.GetRelatedCurrencyManager(dataMember)
C#
CurrencyManager GetRelatedCurrencyManager(
   string dataMember
)
Managed Extensions for C++
CurrencyManager* GetRelatedCurrencyManager(
   string* dataMember
)
C++/CLI
CurrencyManager^ GetRelatedCurrencyManager(
   String^ dataMember
)

Parameters

dataMember
The name of the column or list, within the data source, to obtain the CurrencyManager for.

Return Value

The related CurrencyManager obtained from this ICurrencyManagerProvider and the specified data member.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ICurrencyManagerProvider Interface
ICurrencyManagerProvider Members


ICurrencyManagerProvider Interface Properties

[image]
Gizmox.WebGUI.Forms
ICurrencyManagerProvider Interface Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ICurrencyManagerProvider Interface

For a list of all members of this type, see ICurrencyManagerProvider members.

Public Properties

 | Name | Description
Property | CurrencyManager | Gets the CurrencyManager associated with this ICurrencyManagerProvider.
Top

See Also

Reference

ICurrencyManagerProvider Interface
Gizmox.WebGUI.Forms Namespace


CurrencyManager Property

[image]
Gizmox.WebGUI.Forms
CurrencyManager Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ICurrencyManagerProvider Interface : CurrencyManager Property

Gets the CurrencyManager associated with this ICurrencyManagerProvider.

Syntax

Visual Basic (Declaration)
ReadOnly Property CurrencyManager As CurrencyManager
Visual Basic (Usage) Copy Code
Dim instance As ICurrencyManagerProvider
Dim value As CurrencyManager

value = instance.CurrencyManager
C#
CurrencyManager CurrencyManager {get;}
Managed Extensions for C++
__property CurrencyManager* get_CurrencyManager();
C++/CLI
property CurrencyManager^ CurrencyManager {
   CurrencyManager^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ICurrencyManagerProvider Interface
ICurrencyManagerProvider Members


IDataGridViewEditingCell Interface

[image]
Gizmox.WebGUI.Forms
IDataGridViewEditingCell Interface
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : IDataGridViewEditingCell Interface

Defines common functionality for a cell that allows the manipulation of its value.

Syntax

Visual Basic (Declaration)
Public Interface IDataGridViewEditingCell
Visual Basic (Usage) Copy Code
Dim instance As IDataGridViewEditingCell
C#
public interface IDataGridViewEditingCell
Managed Extensions for C++
public __gc __interface IDataGridViewEditingCell
C++/CLI
public interface class IDataGridViewEditingCell

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

IDataGridViewEditingCell Members
Gizmox.WebGUI.Forms Namespace


IDataGridViewEditingCell Interface Members

[image]
Gizmox.WebGUI.Forms
IDataGridViewEditingCell Interface Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : IDataGridViewEditingCell Interface

The following tables list the members exposed by IDataGridViewEditingCell.

Public Properties

 | Name | Description
Property | EditingCellFormattedValue | Gets or sets the formatted value of the cell.
Property | EditingCellValueChanged | Gets or sets a value indicating whether the value of the cell has changed.
Top

Public Methods

 | Name | Description
Method | GetEditingCellFormattedValue | Retrieves the formatted value of the cell.
Method | PrepareEditingCellForEdit | Prepares the currently selected cell for editing.
Top

See Also

Reference

IDataGridViewEditingCell Interface
Gizmox.WebGUI.Forms Namespace


IDataGridViewEditingCell Interface Methods

[image]
Gizmox.WebGUI.Forms
IDataGridViewEditingCell Interface Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : IDataGridViewEditingCell Interface

For a list of all members of this type, see IDataGridViewEditingCell members.

Public Methods

 | Name | Description
Method | GetEditingCellFormattedValue | Retrieves the formatted value of the cell.
Method | PrepareEditingCellForEdit | Prepares the currently selected cell for editing.
Top

See Also

Reference

IDataGridViewEditingCell Interface
Gizmox.WebGUI.Forms Namespace


GetEditingCellFormattedValue Method

[image]
Gizmox.WebGUI.Forms
GetEditingCellFormattedValue Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > IDataGridViewEditingCell Interface : GetEditingCellFormattedValue Method

context
A bitwise combination of DataGridViewDataErrorContexts values that specifies the context in which the data is needed.
Retrieves the formatted value of the cell.

Syntax

Visual Basic (Declaration)
Function GetEditingCellFormattedValue( _
   ByVal context As DataGridViewDataErrorContexts _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As IDataGridViewEditingCell
Dim context As DataGridViewDataErrorContexts
Dim value As Object

value = instance.GetEditingCellFormattedValue(context)
C#
object GetEditingCellFormattedValue(
   DataGridViewDataErrorContexts context
)
Managed Extensions for C++
Object* GetEditingCellFormattedValue(
   DataGridViewDataErrorContexts context
)
C++/CLI
Object^ GetEditingCellFormattedValue(
   DataGridViewDataErrorContexts context
)

Parameters

context
A bitwise combination of DataGridViewDataErrorContexts values that specifies the context in which the data is needed.

Return Value

An Object that represents the formatted version of the cell contents.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IDataGridViewEditingCell Interface
IDataGridViewEditingCell Members


PrepareEditingCellForEdit Method

[image]
Gizmox.WebGUI.Forms
PrepareEditingCellForEdit Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > IDataGridViewEditingCell Interface : PrepareEditingCellForEdit Method

selectAll
true to select the cell contents; otherwise, false.
Prepares the currently selected cell for editing.

Syntax

Visual Basic (Declaration)
Sub PrepareEditingCellForEdit( _
   ByVal selectAll As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As IDataGridViewEditingCell
Dim selectAll As Boolean

instance.PrepareEditingCellForEdit(selectAll)
C#
void PrepareEditingCellForEdit(
   bool selectAll
)
Managed Extensions for C++
void PrepareEditingCellForEdit(
   bool selectAll
)
C++/CLI
void PrepareEditingCellForEdit(
   bool selectAll
)

Parameters

selectAll
true to select the cell contents; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IDataGridViewEditingCell Interface
IDataGridViewEditingCell Members


IDataGridViewEditingCell Interface Properties

[image]
Gizmox.WebGUI.Forms
IDataGridViewEditingCell Interface Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : IDataGridViewEditingCell Interface

For a list of all members of this type, see IDataGridViewEditingCell members.

Public Properties

 | Name | Description
Property | EditingCellFormattedValue | Gets or sets the formatted value of the cell.
Property | EditingCellValueChanged | Gets or sets a value indicating whether the value of the cell has changed.
Top

See Also

Reference

IDataGridViewEditingCell Interface
Gizmox.WebGUI.Forms Namespace


EditingCellFormattedValue Property

[image]
Gizmox.WebGUI.Forms
EditingCellFormattedValue Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > IDataGridViewEditingCell Interface : EditingCellFormattedValue Property

Gets or sets the formatted value of the cell.

Syntax

Visual Basic (Declaration)
Property EditingCellFormattedValue As Object
Visual Basic (Usage) Copy Code
Dim instance As IDataGridViewEditingCell
Dim value As Object

instance.EditingCellFormattedValue = value

value = instance.EditingCellFormattedValue
C#
object EditingCellFormattedValue {get; set;}
Managed Extensions for C++
__property Object* get_EditingCellFormattedValue();
__property void set_EditingCellFormattedValue(
   Object* value
);
C++/CLI
property Object^ EditingCellFormattedValue {
   Object^ get();
   void set (Object^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IDataGridViewEditingCell Interface
IDataGridViewEditingCell Members


EditingCellValueChanged Property

[image]
Gizmox.WebGUI.Forms
EditingCellValueChanged Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > IDataGridViewEditingCell Interface : EditingCellValueChanged Property

Gets or sets a value indicating whether the value of the cell has changed.

Syntax

Visual Basic (Declaration)
Property EditingCellValueChanged As Boolean
Visual Basic (Usage) Copy Code
Dim instance As IDataGridViewEditingCell
Dim value As Boolean

instance.EditingCellValueChanged = value

value = instance.EditingCellValueChanged
C#
bool EditingCellValueChanged {get; set;}
Managed Extensions for C++
__property bool get_EditingCellValueChanged();
__property void set_EditingCellValueChanged(
   bool value
);
C++/CLI
property bool EditingCellValueChanged {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IDataGridViewEditingCell Interface
IDataGridViewEditingCell Members


IDataGridViewEditingControl Interface

[image]
Gizmox.WebGUI.Forms
IDataGridViewEditingControl Interface
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : IDataGridViewEditingControl Interface

Defines common functionality for controls that are hosted within cells of a DataGridView.

Syntax

Visual Basic (Declaration)
Public Interface IDataGridViewEditingControl
Visual Basic (Usage) Copy Code
Dim instance As IDataGridViewEditingControl
C#
public interface IDataGridViewEditingControl
Managed Extensions for C++
public __gc __interface IDataGridViewEditingControl
C++/CLI
public interface class IDataGridViewEditingControl

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

IDataGridViewEditingControl Members
Gizmox.WebGUI.Forms Namespace


IDataGridViewEditingControl Interface Members

[image]
Gizmox.WebGUI.Forms
IDataGridViewEditingControl Interface Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : IDataGridViewEditingControl Interface

The following tables list the members exposed by IDataGridViewEditingControl.

Public Properties

 | Name | Description
Property | EditingControlDataGridView | Gets or sets the DataGridView that contains the cell.
Property | EditingControlFormattedValue | Gets or sets the formatted value of the cell being modified by the editor.
Property | EditingControlRowIndex | Gets or sets the index of the hosting cell's parent row.
Property | EditingControlValueChanged | Gets or sets a value indicating whether the value of the editing control differs from the value of the hosting cell.
Property | EditingPanelCursor | Gets the cursor used when the mouse pointer is over the DataGridView.EditingPanel but not over the editing control.
Property | RepositionEditingControlOnValueChange | Gets or sets a value indicating whether the cell contents need to be repositioned whenever the value changes.
Top

Public Methods

 | Name | Description
Method | ApplyCellStyleToEditingControl | Changes the control's user interface (UI) to be consistent with the specified cell style.
Method | EditingControlWantsInputKey | Determines whether the specified key is a regular input key that the editing control should process or a special key that the DataGridView should process.
Method | GetEditingControlFormattedValue | Retrieves the formatted value of the cell.
Method | PrepareEditingControlForEdit | Prepares the currently selected cell for editing.
Top

See Also

Reference

IDataGridViewEditingControl Interface
Gizmox.WebGUI.Forms Namespace


IDataGridViewEditingControl Interface Methods

[image]
Gizmox.WebGUI.Forms
IDataGridViewEditingControl Interface Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : IDataGridViewEditingControl Interface

For a list of all members of this type, see IDataGridViewEditingControl members.

Public Methods

 | Name | Description
Method | ApplyCellStyleToEditingControl | Changes the control's user interface (UI) to be consistent with the specified cell style.
Method | EditingControlWantsInputKey | Determines whether the specified key is a regular input key that the editing control should process or a special key that the DataGridView should process.
Method | GetEditingControlFormattedValue | Retrieves the formatted value of the cell.
Method | PrepareEditingControlForEdit | Prepares the currently selected cell for editing.
Top

See Also

Reference

IDataGridViewEditingControl Interface
Gizmox.WebGUI.Forms Namespace


ApplyCellStyleToEditingControl Method

[image]
Gizmox.WebGUI.Forms
ApplyCellStyleToEditingControl Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > IDataGridViewEditingControl Interface : ApplyCellStyleToEditingControl Method

dataGridViewCellStyle
The DataGridViewCellStyle to use as the model for the UI.
Changes the control's user interface (UI) to be consistent with the specified cell style.

Syntax

Visual Basic (Declaration)
Sub ApplyCellStyleToEditingControl( _
   ByVal dataGridViewCellStyle As DataGridViewCellStyle _
)
Visual Basic (Usage) Copy Code
Dim instance As IDataGridViewEditingControl
Dim dataGridViewCellStyle As DataGridViewCellStyle

instance.ApplyCellStyleToEditingControl(dataGridViewCellStyle)
C#
void ApplyCellStyleToEditingControl(
   DataGridViewCellStyle dataGridViewCellStyle
)
Managed Extensions for C++
void ApplyCellStyleToEditingControl(
   DataGridViewCellStyle* dataGridViewCellStyle
)
C++/CLI
void ApplyCellStyleToEditingControl(
   DataGridViewCellStyle^ dataGridViewCellStyle
)

Parameters

dataGridViewCellStyle
The DataGridViewCellStyle to use as the model for the UI.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IDataGridViewEditingControl Interface
IDataGridViewEditingControl Members


EditingControlWantsInputKey Method

[image]
Gizmox.WebGUI.Forms
EditingControlWantsInputKey Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > IDataGridViewEditingControl Interface : EditingControlWantsInputKey Method

keyData
A Keys that represents the key that was pressed.
dataGridViewWantsInputKey
true when the DataGridView wants to process the Keys in keyData; otherwise, false.
Determines whether the specified key is a regular input key that the editing control should process or a special key that the DataGridView should process.

Syntax

Visual Basic (Declaration)
Function EditingControlWantsInputKey( _
   ByVal keyData As Keys, _
   ByVal dataGridViewWantsInputKey As Boolean _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As IDataGridViewEditingControl
Dim keyData As Keys
Dim dataGridViewWantsInputKey As Boolean
Dim value As Boolean

value = instance.EditingControlWantsInputKey(keyData, dataGridViewWantsInputKey)
C#
bool EditingControlWantsInputKey(
   Keys keyData,
   bool dataGridViewWantsInputKey
)
Managed Extensions for C++
bool EditingControlWantsInputKey(
   Keys keyData,
   bool dataGridViewWantsInputKey
)
C++/CLI
bool EditingControlWantsInputKey(
   Keys keyData,
   bool dataGridViewWantsInputKey
)

Parameters

keyData
A Keys that represents the key that was pressed.
dataGridViewWantsInputKey
true when the DataGridView wants to process the Keys in keyData; otherwise, false.

Return Value

true if the specified key is a regular input key that should be handled by the editing control; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IDataGridViewEditingControl Interface
IDataGridViewEditingControl Members


GetEditingControlFormattedValue Method

[image]
Gizmox.WebGUI.Forms
GetEditingControlFormattedValue Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > IDataGridViewEditingControl Interface : GetEditingControlFormattedValue Method

context
A bitwise combination of DataGridViewDataErrorContexts values that specifies the context in which the data is needed.
Retrieves the formatted value of the cell.

Syntax

Visual Basic (Declaration)
Function GetEditingControlFormattedValue( _
   ByVal context As DataGridViewDataErrorContexts _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As IDataGridViewEditingControl
Dim context As DataGridViewDataErrorContexts
Dim value As Object

value = instance.GetEditingControlFormattedValue(context)
C#
object GetEditingControlFormattedValue(
   DataGridViewDataErrorContexts context
)
Managed Extensions for C++
Object* GetEditingControlFormattedValue(
   DataGridViewDataErrorContexts context
)
C++/CLI
Object^ GetEditingControlFormattedValue(
   DataGridViewDataErrorContexts context
)

Parameters

context
A bitwise combination of DataGridViewDataErrorContexts values that specifies the context in which the data is needed.

Return Value

An Object that represents the formatted version of the cell contents.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IDataGridViewEditingControl Interface
IDataGridViewEditingControl Members


PrepareEditingControlForEdit Method

[image]
Gizmox.WebGUI.Forms
PrepareEditingControlForEdit Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > IDataGridViewEditingControl Interface : PrepareEditingControlForEdit Method

selectAll
true to select all of the cell's content; otherwise, false.
Prepares the currently selected cell for editing.

Syntax

Visual Basic (Declaration)
Sub PrepareEditingControlForEdit( _
   ByVal selectAll As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As IDataGridViewEditingControl
Dim selectAll As Boolean

instance.PrepareEditingControlForEdit(selectAll)
C#
void PrepareEditingControlForEdit(
   bool selectAll
)
Managed Extensions for C++
void PrepareEditingControlForEdit(
   bool selectAll
)
C++/CLI
void PrepareEditingControlForEdit(
   bool selectAll
)

Parameters

selectAll
true to select all of the cell's content; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IDataGridViewEditingControl Interface
IDataGridViewEditingControl Members


IDataGridViewEditingControl Interface Properties

[image]
Gizmox.WebGUI.Forms
IDataGridViewEditingControl Interface Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : IDataGridViewEditingControl Interface

For a list of all members of this type, see IDataGridViewEditingControl members.

Public Properties

 | Name | Description
Property | EditingControlDataGridView | Gets or sets the DataGridView that contains the cell.
Property | EditingControlFormattedValue | Gets or sets the formatted value of the cell being modified by the editor.
Property | EditingControlRowIndex | Gets or sets the index of the hosting cell's parent row.
Property | EditingControlValueChanged | Gets or sets a value indicating whether the value of the editing control differs from the value of the hosting cell.
Property | EditingPanelCursor | Gets the cursor used when the mouse pointer is over the DataGridView.EditingPanel but not over the editing control.
Property | RepositionEditingControlOnValueChange | Gets or sets a value indicating whether the cell contents need to be repositioned whenever the value changes.
Top

See Also

Reference

IDataGridViewEditingControl Interface
Gizmox.WebGUI.Forms Namespace


EditingControlDataGridView Property

[image]
Gizmox.WebGUI.Forms
EditingControlDataGridView Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > IDataGridViewEditingControl Interface : EditingControlDataGridView Property

Gets or sets the DataGridView that contains the cell.

Syntax

Visual Basic (Declaration)
Property EditingControlDataGridView As DataGridView
Visual Basic (Usage) Copy Code
Dim instance As IDataGridViewEditingControl
Dim value As DataGridView

instance.EditingControlDataGridView = value

value = instance.EditingControlDataGridView
C#
DataGridView EditingControlDataGridView {get; set;}
Managed Extensions for C++
__property DataGridView* get_EditingControlDataGridView();
__property void set_EditingControlDataGridView(
   DataGridView* value
);
C++/CLI
property DataGridView^ EditingControlDataGridView {
   DataGridView^ get();
   void set (DataGridView^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IDataGridViewEditingControl Interface
IDataGridViewEditingControl Members


EditingControlFormattedValue Property

[image]
Gizmox.WebGUI.Forms
EditingControlFormattedValue Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > IDataGridViewEditingControl Interface : EditingControlFormattedValue Property

Gets or sets the formatted value of the cell being modified by the editor.

Syntax

Visual Basic (Declaration)
Property EditingControlFormattedValue As Object
Visual Basic (Usage) Copy Code
Dim instance As IDataGridViewEditingControl
Dim value As Object

instance.EditingControlFormattedValue = value

value = instance.EditingControlFormattedValue
C#
object EditingControlFormattedValue {get; set;}
Managed Extensions for C++
__property Object* get_EditingControlFormattedValue();
__property void set_EditingControlFormattedValue(
   Object* value
);
C++/CLI
property Object^ EditingControlFormattedValue {
   Object^ get();
   void set (Object^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IDataGridViewEditingControl Interface
IDataGridViewEditingControl Members


EditingControlRowIndex Property

[image]
Gizmox.WebGUI.Forms
EditingControlRowIndex Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > IDataGridViewEditingControl Interface : EditingControlRowIndex Property

Gets or sets the index of the hosting cell's parent row.

Syntax

Visual Basic (Declaration)
Property EditingControlRowIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As IDataGridViewEditingControl
Dim value As Integer

instance.EditingControlRowIndex = value

value = instance.EditingControlRowIndex
C#
int EditingControlRowIndex {get; set;}
Managed Extensions for C++
__property int get_EditingControlRowIndex();
__property void set_EditingControlRowIndex(
   int value
);
C++/CLI
property int EditingControlRowIndex {
   int get();
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IDataGridViewEditingControl Interface
IDataGridViewEditingControl Members


EditingControlValueChanged Property

[image]
Gizmox.WebGUI.Forms
EditingControlValueChanged Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > IDataGridViewEditingControl Interface : EditingControlValueChanged Property

Gets or sets a value indicating whether the value of the editing control differs from the value of the hosting cell.

Syntax

Visual Basic (Declaration)
Property EditingControlValueChanged As Boolean
Visual Basic (Usage) Copy Code
Dim instance As IDataGridViewEditingControl
Dim value As Boolean

instance.EditingControlValueChanged = value

value = instance.EditingControlValueChanged
C#
bool EditingControlValueChanged {get; set;}
Managed Extensions for C++
__property bool get_EditingControlValueChanged();
__property void set_EditingControlValueChanged(
   bool value
);
C++/CLI
property bool EditingControlValueChanged {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IDataGridViewEditingControl Interface
IDataGridViewEditingControl Members


EditingPanelCursor Property

[image]
Gizmox.WebGUI.Forms
EditingPanelCursor Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > IDataGridViewEditingControl Interface : EditingPanelCursor Property

Gets the cursor used when the mouse pointer is over the DataGridView.EditingPanel but not over the editing control.

Syntax

Visual Basic (Declaration)
ReadOnly Property EditingPanelCursor As Cursor
Visual Basic (Usage) Copy Code
Dim instance As IDataGridViewEditingControl
Dim value As Cursor

value = instance.EditingPanelCursor
C#
Cursor EditingPanelCursor {get;}
Managed Extensions for C++
__property Cursor* get_EditingPanelCursor();
C++/CLI
property Cursor^ EditingPanelCursor {
   Cursor^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IDataGridViewEditingControl Interface
IDataGridViewEditingControl Members


RepositionEditingControlOnValueChange Property

[image]
Gizmox.WebGUI.Forms
RepositionEditingControlOnValueChange Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > IDataGridViewEditingControl Interface : RepositionEditingControlOnValueChange Property

Gets or sets a value indicating whether the cell contents need to be repositioned whenever the value changes.

Syntax

Visual Basic (Declaration)
ReadOnly Property RepositionEditingControlOnValueChange As Boolean
Visual Basic (Usage) Copy Code
Dim instance As IDataGridViewEditingControl
Dim value As Boolean

value = instance.RepositionEditingControlOnValueChange
C#
bool RepositionEditingControlOnValueChange {get;}
Managed Extensions for C++
__property bool get_RepositionEditingControlOnValueChange();
C++/CLI
property bool RepositionEditingControlOnValueChange {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IDataGridViewEditingControl Interface
IDataGridViewEditingControl Members


BindingCompleteEventHandler Delegate

[image]
Gizmox.WebGUI.Forms
BindingCompleteEventHandler Delegate
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : BindingCompleteEventHandler Delegate

sender
e
Represents the method that will handle the BindingComplete event in data-binding scenarios.

Syntax

Visual Basic (Declaration)
Public Delegate Sub BindingCompleteEventHandler( _
   ByVal sender As Object, _
   ByVal e As BindingCompleteEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New BindingCompleteEventHandler(AddressOf HandlerMethod)
C#
public delegate void BindingCompleteEventHandler(
   object sender,
   BindingCompleteEventArgs e
)
Managed Extensions for C++
public: __gc __delegate void BindingCompleteEventHandler(
   Object* sender,
   BindingCompleteEventArgs* e
)
C++/CLI
public delegate void BindingCompleteEventHandler(
   Object^ sender,
   BindingCompleteEventArgs^ e
)

Parameters

sender
e

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


BindingManagerDataErrorEventHandler Delegate

[image]
Gizmox.WebGUI.Forms
BindingManagerDataErrorEventHandler Delegate
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : BindingManagerDataErrorEventHandler Delegate

sender
e
Represents the method that will handle the DataError event of a BindingManagerBase.

Syntax

Visual Basic (Declaration)
Public Delegate Sub BindingManagerDataErrorEventHandler( _
   ByVal sender As Object, _
   ByVal e As BindingManagerDataErrorEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New BindingManagerDataErrorEventHandler(AddressOf HandlerMethod)
C#
public delegate void BindingManagerDataErrorEventHandler(
   object sender,
   BindingManagerDataErrorEventArgs e
)
Managed Extensions for C++
public: __gc __delegate void BindingManagerDataErrorEventHandler(
   Object* sender,
   BindingManagerDataErrorEventArgs* e
)
C++/CLI
public delegate void BindingManagerDataErrorEventHandler(
   Object^ sender,
   BindingManagerDataErrorEventArgs^ e
)

Parameters

sender
e

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


ColumnClickEventHandler Delegate

[image]
Gizmox.WebGUI.Forms
ColumnClickEventHandler Delegate
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ColumnClickEventHandler Delegate

sender
e

Syntax

Visual Basic (Declaration)
Public Delegate Sub ColumnClickEventHandler( _
   ByVal sender As Object, _
   ByVal e As ColumnClickEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New ColumnClickEventHandler(AddressOf HandlerMethod)
C#
public delegate void ColumnClickEventHandler(
   object sender,
   ColumnClickEventArgs e
)
Managed Extensions for C++
public: __gc __delegate void ColumnClickEventHandler(
   Object* sender,
   ColumnClickEventArgs* e
)
C++/CLI
public delegate void ColumnClickEventHandler(
   Object^ sender,
   ColumnClickEventArgs^ e
)

Parameters

sender
e

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


ControlEventHandler Delegate

[image]
Gizmox.WebGUI.Forms
ControlEventHandler Delegate
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ControlEventHandler Delegate

sender
e
Represents the method that will handle the ControlAdded and ControlRemoved events of the Control class.

Syntax

Visual Basic (Declaration)
Public Delegate Sub ControlEventHandler( _
   ByVal sender As Object, _
   ByVal e As ControlEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New ControlEventHandler(AddressOf HandlerMethod)
C#
public delegate void ControlEventHandler(
   object sender,
   ControlEventArgs e
)
Managed Extensions for C++
public: __gc __delegate void ControlEventHandler(
   Object* sender,
   ControlEventArgs* e
)
C++/CLI
public delegate void ControlEventHandler(
   Object^ sender,
   ControlEventArgs^ e
)

Parameters

sender
e

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


ConvertEventHandler Delegate

[image]
Gizmox.WebGUI.Forms
ConvertEventHandler Delegate
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ConvertEventHandler Delegate

sender
e
Represents the method that will handle the Parse and Format events of a Binding.

Syntax

Visual Basic (Declaration)
Public Delegate Sub ConvertEventHandler( _
   ByVal sender As Object, _
   ByVal e As ConvertEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New ConvertEventHandler(AddressOf HandlerMethod)
C#
public delegate void ConvertEventHandler(
   object sender,
   ConvertEventArgs e
)
Managed Extensions for C++
public: __gc __delegate void ConvertEventHandler(
   Object* sender,
   ConvertEventArgs* e
)
C++/CLI
public delegate void ConvertEventHandler(
   Object^ sender,
   ConvertEventArgs^ e
)

Parameters

sender
e

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


DataGridViewAutoSizeColumnModeEventHandler Delegate

[image]
Gizmox.WebGUI.Forms
DataGridViewAutoSizeColumnModeEventHandler Delegate
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewAutoSizeColumnModeEventHandler Delegate

sender
e
Represents the method that will handle the AutoSizeColumnModeChanged event of a DataGridView control.

Syntax

Visual Basic (Declaration)
Public Delegate Sub DataGridViewAutoSizeColumnModeEventHandler( _
   ByVal sender As Object, _
   ByVal e As DataGridViewAutoSizeColumnModeEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New DataGridViewAutoSizeColumnModeEventHandler(AddressOf HandlerMethod)
C#
public delegate void DataGridViewAutoSizeColumnModeEventHandler(
   object sender,
   DataGridViewAutoSizeColumnModeEventArgs e
)
Managed Extensions for C++
public: __gc __delegate void DataGridViewAutoSizeColumnModeEventHandler(
   Object* sender,
   DataGridViewAutoSizeColumnModeEventArgs* e
)
C++/CLI
public delegate void DataGridViewAutoSizeColumnModeEventHandler(
   Object^ sender,
   DataGridViewAutoSizeColumnModeEventArgs^ e
)

Parameters

sender
e

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


DataGridViewAutoSizeColumnsModeEventHandler Delegate

[image]
Gizmox.WebGUI.Forms
DataGridViewAutoSizeColumnsModeEventHandler Delegate
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewAutoSizeColumnsModeEventHandler Delegate

sender
e
Represents the method that will handle the AutoSizeColumnsModeChanged event of a DataGridView control.

Syntax

Visual Basic (Declaration)
Public Delegate Sub DataGridViewAutoSizeColumnsModeEventHandler( _
   ByVal sender As Object, _
   ByVal e As DataGridViewAutoSizeColumnsModeEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New DataGridViewAutoSizeColumnsModeEventHandler(AddressOf HandlerMethod)
C#
public delegate void DataGridViewAutoSizeColumnsModeEventHandler(
   object sender,
   DataGridViewAutoSizeColumnsModeEventArgs e
)
Managed Extensions for C++
public: __gc __delegate void DataGridViewAutoSizeColumnsModeEventHandler(
   Object* sender,
   DataGridViewAutoSizeColumnsModeEventArgs* e
)
C++/CLI
public delegate void DataGridViewAutoSizeColumnsModeEventHandler(
   Object^ sender,
   DataGridViewAutoSizeColumnsModeEventArgs^ e
)

Parameters

sender
e

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


DataGridViewAutoSizeModeEventHandler Delegate

[image]
Gizmox.WebGUI.Forms
DataGridViewAutoSizeModeEventHandler Delegate
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewAutoSizeModeEventHandler Delegate

sender
e
Represents the method that will handle the AutoSizeRowsModeChanged or RowHeadersWidthSizeModeChanged events of a DataGridView.

Syntax

Visual Basic (Declaration)
Public Delegate Sub DataGridViewAutoSizeModeEventHandler( _
   ByVal sender As Object, _
   ByVal e As DataGridViewAutoSizeModeEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New DataGridViewAutoSizeModeEventHandler(AddressOf HandlerMethod)
C#
public delegate void DataGridViewAutoSizeModeEventHandler(
   object sender,
   DataGridViewAutoSizeModeEventArgs e
)
Managed Extensions for C++
public: __gc __delegate void DataGridViewAutoSizeModeEventHandler(
   Object* sender,
   DataGridViewAutoSizeModeEventArgs* e
)
C++/CLI
public delegate void DataGridViewAutoSizeModeEventHandler(
   Object^ sender,
   DataGridViewAutoSizeModeEventArgs^ e
)

Parameters

sender
e

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


DataGridViewBindingCompleteEventHandler Delegate

[image]
Gizmox.WebGUI.Forms
DataGridViewBindingCompleteEventHandler Delegate
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewBindingCompleteEventHandler Delegate

sender
e
Represents the method that will handle the DataBindingComplete event of a DataGridView.

Syntax

Visual Basic (Declaration)
Public Delegate Sub DataGridViewBindingCompleteEventHandler( _
   ByVal sender As Object, _
   ByVal e As DataGridViewBindingCompleteEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New DataGridViewBindingCompleteEventHandler(AddressOf HandlerMethod)
C#
public delegate void DataGridViewBindingCompleteEventHandler(
   object sender,
   DataGridViewBindingCompleteEventArgs e
)
Managed Extensions for C++
public: __gc __delegate void DataGridViewBindingCompleteEventHandler(
   Object* sender,
   DataGridViewBindingCompleteEventArgs* e
)
C++/CLI
public delegate void DataGridViewBindingCompleteEventHandler(
   Object^ sender,
   DataGridViewBindingCompleteEventArgs^ e
)

Parameters

sender
e

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


DataGridViewCellCancelEventHandler Delegate

[image]
Gizmox.WebGUI.Forms
DataGridViewCellCancelEventHandler Delegate
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewCellCancelEventHandler Delegate

sender
e
Represents the method that will handle the CellBeginEdit and RowValidating events of a DataGridView.

Syntax

Visual Basic (Declaration)
Public Delegate Sub DataGridViewCellCancelEventHandler( _
   ByVal sender As Object, _
   ByVal e As DataGridViewCellCancelEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New DataGridViewCellCancelEventHandler(AddressOf HandlerMethod)
C#
public delegate void DataGridViewCellCancelEventHandler(
   object sender,
   DataGridViewCellCancelEventArgs e
)
Managed Extensions for C++
public: __gc __delegate void DataGridViewCellCancelEventHandler(
   Object* sender,
   DataGridViewCellCancelEventArgs* e
)
C++/CLI
public delegate void DataGridViewCellCancelEventHandler(
   Object^ sender,
   DataGridViewCellCancelEventArgs^ e
)

Parameters

sender
e

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


DataGridViewCellErrorTextNeededEventHandler Delegate

[image]
Gizmox.WebGUI.Forms
DataGridViewCellErrorTextNeededEventHandler Delegate
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewCellErrorTextNeededEventHandler Delegate

sender
e
Represents the method that will handle the CellErrorTextNeeded event of a DataGridView.

Syntax

Visual Basic (Declaration)
Public Delegate Sub DataGridViewCellErrorTextNeededEventHandler( _
   ByVal sender As Object, _
   ByVal e As DataGridViewCellErrorTextNeededEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New DataGridViewCellErrorTextNeededEventHandler(AddressOf HandlerMethod)
C#
public delegate void DataGridViewCellErrorTextNeededEventHandler(
   object sender,
   DataGridViewCellErrorTextNeededEventArgs e
)
Managed Extensions for C++
public: __gc __delegate void DataGridViewCellErrorTextNeededEventHandler(
   Object* sender,
   DataGridViewCellErrorTextNeededEventArgs* e
)
C++/CLI
public delegate void DataGridViewCellErrorTextNeededEventHandler(
   Object^ sender,
   DataGridViewCellErrorTextNeededEventArgs^ e
)

Parameters

sender
e

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


DataGridViewCellEventHandler Delegate

[image]
Gizmox.WebGUI.Forms
DataGridViewCellEventHandler Delegate
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewCellEventHandler Delegate

sender
e
Represents the method that will handle DataGridView events related to cell and row operations.

Syntax

Visual Basic (Declaration)
Public Delegate Sub DataGridViewCellEventHandler( _
   ByVal sender As Object, _
   ByVal e As DataGridViewCellEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New DataGridViewCellEventHandler(AddressOf HandlerMethod)
C#
public delegate void DataGridViewCellEventHandler(
   object sender,
   DataGridViewCellEventArgs e
)
Managed Extensions for C++
public: __gc __delegate void DataGridViewCellEventHandler(
   Object* sender,
   DataGridViewCellEventArgs* e
)
C++/CLI
public delegate void DataGridViewCellEventHandler(
   Object^ sender,
   DataGridViewCellEventArgs^ e
)

Parameters

sender
e

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


DataGridViewCellFormattingEventHandler Delegate

[image]
Gizmox.WebGUI.Forms
DataGridViewCellFormattingEventHandler Delegate
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewCellFormattingEventHandler Delegate

sender
e
Represents the method that will handle the CellFormatting event of a DataGridView.

Syntax

Visual Basic (Declaration)
Public Delegate Sub DataGridViewCellFormattingEventHandler( _
   ByVal sender As Object, _
   ByVal e As DataGridViewCellFormattingEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New DataGridViewCellFormattingEventHandler(AddressOf HandlerMethod)
C#
public delegate void DataGridViewCellFormattingEventHandler(
   object sender,
   DataGridViewCellFormattingEventArgs e
)
Managed Extensions for C++
public: __gc __delegate void DataGridViewCellFormattingEventHandler(
   Object* sender,
   DataGridViewCellFormattingEventArgs* e
)
C++/CLI
public delegate void DataGridViewCellFormattingEventHandler(
   Object^ sender,
   DataGridViewCellFormattingEventArgs^ e
)

Parameters

sender
e

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


DataGridViewCellMouseEventHandler Delegate

[image]
Gizmox.WebGUI.Forms
DataGridViewCellMouseEventHandler Delegate
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewCellMouseEventHandler Delegate

sender
e
Represents the method that will handle mouse-related events raised by a DataGridView.

Syntax

Visual Basic (Declaration)
Public Delegate Sub DataGridViewCellMouseEventHandler( _
   ByVal sender As Object, _
   ByVal e As DataGridViewCellMouseEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New DataGridViewCellMouseEventHandler(AddressOf HandlerMethod)
C#
public delegate void DataGridViewCellMouseEventHandler(
   object sender,
   DataGridViewCellMouseEventArgs e
)
Managed Extensions for C++
public: __gc __delegate void DataGridViewCellMouseEventHandler(
   Object* sender,
   DataGridViewCellMouseEventArgs* e
)
C++/CLI
public delegate void DataGridViewCellMouseEventHandler(
   Object^ sender,
   DataGridViewCellMouseEventArgs^ e
)

Parameters

sender
e

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


DataGridViewCellParsingEventHandler Delegate

[image]
Gizmox.WebGUI.Forms
DataGridViewCellParsingEventHandler Delegate
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewCellParsingEventHandler Delegate

sender
e
Represents the method that will handle a DataGridView.CellParsing event of a DataGridView.

Syntax

Visual Basic (Declaration)
Public Delegate Sub DataGridViewCellParsingEventHandler( _
   ByVal sender As Object, _
   ByVal e As DataGridViewCellParsingEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New DataGridViewCellParsingEventHandler(AddressOf HandlerMethod)
C#
public delegate void DataGridViewCellParsingEventHandler(
   object sender,
   DataGridViewCellParsingEventArgs e
)
Managed Extensions for C++
public: __gc __delegate void DataGridViewCellParsingEventHandler(
   Object* sender,
   DataGridViewCellParsingEventArgs* e
)
C++/CLI
public delegate void DataGridViewCellParsingEventHandler(
   Object^ sender,
   DataGridViewCellParsingEventArgs^ e
)

Parameters

sender
e

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


DataGridViewCellStateChangedEventHandler Delegate

[image]
Gizmox.WebGUI.Forms
DataGridViewCellStateChangedEventHandler Delegate
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewCellStateChangedEventHandler Delegate

sender
e
Represents the method that will handle the CellStateChanged event of a DataGridView.

Syntax

Visual Basic (Declaration)
Public Delegate Sub DataGridViewCellStateChangedEventHandler( _
   ByVal sender As Object, _
   ByVal e As DataGridViewCellStateChangedEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New DataGridViewCellStateChangedEventHandler(AddressOf HandlerMethod)
C#
public delegate void DataGridViewCellStateChangedEventHandler(
   object sender,
   DataGridViewCellStateChangedEventArgs e
)
Managed Extensions for C++
public: __gc __delegate void DataGridViewCellStateChangedEventHandler(
   Object* sender,
   DataGridViewCellStateChangedEventArgs* e
)
C++/CLI
public delegate void DataGridViewCellStateChangedEventHandler(
   Object^ sender,
   DataGridViewCellStateChangedEventArgs^ e
)

Parameters

sender
e

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


DataGridViewCellStyleContentChangedEventHandler Delegate

[image]
Gizmox.WebGUI.Forms
DataGridViewCellStyleContentChangedEventHandler Delegate
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewCellStyleContentChangedEventHandler Delegate

sender
e
Represents the method that will handle the CellStyleContentChanged event of a DataGridView.

Syntax

Visual Basic (Declaration)
Public Delegate Sub DataGridViewCellStyleContentChangedEventHandler( _
   ByVal sender As Object, _
   ByVal e As DataGridViewCellStyleContentChangedEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New DataGridViewCellStyleContentChangedEventHandler(AddressOf HandlerMethod)
C#
public delegate void DataGridViewCellStyleContentChangedEventHandler(
   object sender,
   DataGridViewCellStyleContentChangedEventArgs e
)
Managed Extensions for C++
public: __gc __delegate void DataGridViewCellStyleContentChangedEventHandler(
   Object* sender,
   DataGridViewCellStyleContentChangedEventArgs* e
)
C++/CLI
public delegate void DataGridViewCellStyleContentChangedEventHandler(
   Object^ sender,
   DataGridViewCellStyleContentChangedEventArgs^ e
)

Parameters

sender
e

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


DataGridViewCellToolTipTextNeededEventHandler Delegate

[image]
Gizmox.WebGUI.Forms
DataGridViewCellToolTipTextNeededEventHandler Delegate
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewCellToolTipTextNeededEventHandler Delegate

sender
e
Represents the method that will handle the CellToolTipTextNeeded event of a DataGridView.

Syntax

Visual Basic (Declaration)
Public Delegate Sub DataGridViewCellToolTipTextNeededEventHandler( _
   ByVal sender As Object, _
   ByVal e As DataGridViewCellToolTipTextNeededEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New DataGridViewCellToolTipTextNeededEventHandler(AddressOf HandlerMethod)
C#
public delegate void DataGridViewCellToolTipTextNeededEventHandler(
   object sender,
   DataGridViewCellToolTipTextNeededEventArgs e
)
Managed Extensions for C++
public: __gc __delegate void DataGridViewCellToolTipTextNeededEventHandler(
   Object* sender,
   DataGridViewCellToolTipTextNeededEventArgs* e
)
C++/CLI
public delegate void DataGridViewCellToolTipTextNeededEventHandler(
   Object^ sender,
   DataGridViewCellToolTipTextNeededEventArgs^ e
)

Parameters

sender
e

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


DataGridViewCellValidatingEventHandler Delegate

[image]
Gizmox.WebGUI.Forms
DataGridViewCellValidatingEventHandler Delegate
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewCellValidatingEventHandler Delegate

sender
e
Represents the method that will handle the DataGridView.CellValidating event of a DataGridView control.

Syntax

Visual Basic (Declaration)
Public Delegate Sub DataGridViewCellValidatingEventHandler( _
   ByVal sender As Object, _
   ByVal e As DataGridViewCellValidatingEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New DataGridViewCellValidatingEventHandler(AddressOf HandlerMethod)
C#
public delegate void DataGridViewCellValidatingEventHandler(
   object sender,
   DataGridViewCellValidatingEventArgs e
)
Managed Extensions for C++
public: __gc __delegate void DataGridViewCellValidatingEventHandler(
   Object* sender,
   DataGridViewCellValidatingEventArgs* e
)
C++/CLI
public delegate void DataGridViewCellValidatingEventHandler(
   Object^ sender,
   DataGridViewCellValidatingEventArgs^ e
)

Parameters

sender
e

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


DataGridViewCellValueEventHandler Delegate

[image]
Gizmox.WebGUI.Forms
DataGridViewCellValueEventHandler Delegate
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewCellValueEventHandler Delegate

sender
e
Represents the method that will handle the CellValueNeeded event or CellValuePushed event of a DataGridView.

Syntax

Visual Basic (Declaration)
Public Delegate Sub DataGridViewCellValueEventHandler( _
   ByVal sender As Object, _
   ByVal e As DataGridViewCellValueEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New DataGridViewCellValueEventHandler(AddressOf HandlerMethod)
C#
public delegate void DataGridViewCellValueEventHandler(
   object sender,
   DataGridViewCellValueEventArgs e
)
Managed Extensions for C++
public: __gc __delegate void DataGridViewCellValueEventHandler(
   Object* sender,
   DataGridViewCellValueEventArgs* e
)
C++/CLI
public delegate void DataGridViewCellValueEventHandler(
   Object^ sender,
   DataGridViewCellValueEventArgs^ e
)

Parameters

sender
e

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


DataGridViewColumnDividerDoubleClickEventHandler Delegate

[image]
Gizmox.WebGUI.Forms
DataGridViewColumnDividerDoubleClickEventHandler Delegate
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewColumnDividerDoubleClickEventHandler Delegate

sender
e
Represents the method that will handle the ColumnDividerDoubleClick event of a DataGridView.

Syntax

Visual Basic (Declaration)
Public Delegate Sub DataGridViewColumnDividerDoubleClickEventHandler( _
   ByVal sender As Object, _
   ByVal e As DataGridViewColumnDividerDoubleClickEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New DataGridViewColumnDividerDoubleClickEventHandler(AddressOf HandlerMethod)
C#
public delegate void DataGridViewColumnDividerDoubleClickEventHandler(
   object sender,
   DataGridViewColumnDividerDoubleClickEventArgs e
)
Managed Extensions for C++
public: __gc __delegate void DataGridViewColumnDividerDoubleClickEventHandler(
   Object* sender,
   DataGridViewColumnDividerDoubleClickEventArgs* e
)
C++/CLI
public delegate void DataGridViewColumnDividerDoubleClickEventHandler(
   Object^ sender,
   DataGridViewColumnDividerDoubleClickEventArgs^ e
)

Parameters

sender
e

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


DataGridViewColumnEventHandler Delegate

[image]
Gizmox.WebGUI.Forms
DataGridViewColumnEventHandler Delegate
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewColumnEventHandler Delegate

sender
e
Represents the method that will handle column-related events of a DataGridView.

Syntax

Visual Basic (Declaration)
Public Delegate Sub DataGridViewColumnEventHandler( _
   ByVal sender As Object, _
   ByVal e As DataGridViewColumnEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New DataGridViewColumnEventHandler(AddressOf HandlerMethod)
C#
public delegate void DataGridViewColumnEventHandler(
   object sender,
   DataGridViewColumnEventArgs e
)
Managed Extensions for C++
public: __gc __delegate void DataGridViewColumnEventHandler(
   Object* sender,
   DataGridViewColumnEventArgs* e
)
C++/CLI
public delegate void DataGridViewColumnEventHandler(
   Object^ sender,
   DataGridViewColumnEventArgs^ e
)

Parameters

sender
e

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


DataGridViewColumnStateChangedEventHandler Delegate

[image]
Gizmox.WebGUI.Forms
DataGridViewColumnStateChangedEventHandler Delegate
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewColumnStateChangedEventHandler Delegate

sender
e
Represents the method that will handle the ColumnStateChanged event of a DataGridView.

Syntax

Visual Basic (Declaration)
Public Delegate Sub DataGridViewColumnStateChangedEventHandler( _
   ByVal sender As Object, _
   ByVal e As DataGridViewColumnStateChangedEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New DataGridViewColumnStateChangedEventHandler(AddressOf HandlerMethod)
C#
public delegate void DataGridViewColumnStateChangedEventHandler(
   object sender,
   DataGridViewColumnStateChangedEventArgs e
)
Managed Extensions for C++
public: __gc __delegate void DataGridViewColumnStateChangedEventHandler(
   Object* sender,
   DataGridViewColumnStateChangedEventArgs* e
)
C++/CLI
public delegate void DataGridViewColumnStateChangedEventHandler(
   Object^ sender,
   DataGridViewColumnStateChangedEventArgs^ e
)

Parameters

sender
e

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


DataGridViewDataErrorEventHandler Delegate

[image]
Gizmox.WebGUI.Forms
DataGridViewDataErrorEventHandler Delegate
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewDataErrorEventHandler Delegate

sender
e
Represents the method that will handle the DataError event of a DataGridView.

Syntax

Visual Basic (Declaration)
Public Delegate Sub DataGridViewDataErrorEventHandler( _
   ByVal sender As Object, _
   ByVal e As DataGridViewDataErrorEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New DataGridViewDataErrorEventHandler(AddressOf HandlerMethod)
C#
public delegate void DataGridViewDataErrorEventHandler(
   object sender,
   DataGridViewDataErrorEventArgs e
)
Managed Extensions for C++
public: __gc __delegate void DataGridViewDataErrorEventHandler(
   Object* sender,
   DataGridViewDataErrorEventArgs* e
)
C++/CLI
public delegate void DataGridViewDataErrorEventHandler(
   Object^ sender,
   DataGridViewDataErrorEventArgs^ e
)

Parameters

sender
e

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


DataGridViewEditingControlShowingEventHandler Delegate

[image]
Gizmox.WebGUI.Forms
DataGridViewEditingControlShowingEventHandler Delegate
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewEditingControlShowingEventHandler Delegate

sender
e
Represents the method that will handle the EditingControlShowing event of a DataGridView.

Syntax

Visual Basic (Declaration)
Public Delegate Sub DataGridViewEditingControlShowingEventHandler( _
   ByVal sender As Object, _
   ByVal e As DataGridViewEditingControlShowingEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New DataGridViewEditingControlShowingEventHandler(AddressOf HandlerMethod)
C#
public delegate void DataGridViewEditingControlShowingEventHandler(
   object sender,
   DataGridViewEditingControlShowingEventArgs e
)
Managed Extensions for C++
public: __gc __delegate void DataGridViewEditingControlShowingEventHandler(
   Object* sender,
   DataGridViewEditingControlShowingEventArgs* e
)
C++/CLI
public delegate void DataGridViewEditingControlShowingEventHandler(
   Object^ sender,
   DataGridViewEditingControlShowingEventArgs^ e
)

Parameters

sender
e

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


DataGridViewRowCancelEventHandler Delegate

[image]
Gizmox.WebGUI.Forms
DataGridViewRowCancelEventHandler Delegate
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewRowCancelEventHandler Delegate

sender
e
Represents the method that will handle the UserDeletingRow event of a DataGridView.

Syntax

Visual Basic (Declaration)
Public Delegate Sub DataGridViewRowCancelEventHandler( _
   ByVal sender As Object, _
   ByVal e As DataGridViewRowCancelEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New DataGridViewRowCancelEventHandler(AddressOf HandlerMethod)
C#
public delegate void DataGridViewRowCancelEventHandler(
   object sender,
   DataGridViewRowCancelEventArgs e
)
Managed Extensions for C++
public: __gc __delegate void DataGridViewRowCancelEventHandler(
   Object* sender,
   DataGridViewRowCancelEventArgs* e
)
C++/CLI
public delegate void DataGridViewRowCancelEventHandler(
   Object^ sender,
   DataGridViewRowCancelEventArgs^ e
)

Parameters

sender
e

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


DataGridViewRowContextMenuStripNeededEventHandler Delegate

[image]
Gizmox.WebGUI.Forms
DataGridViewRowContextMenuStripNeededEventHandler Delegate
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewRowContextMenuStripNeededEventHandler Delegate

sender
e
Represents the method that will handle the RowContextMenuStripNeeded event of a DataGridView.

Syntax

Visual Basic (Declaration)
Public Delegate Sub DataGridViewRowContextMenuStripNeededEventHandler( _
   ByVal sender As Object, _
   ByVal e As DataGridViewRowContextMenuStripNeededEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New DataGridViewRowContextMenuStripNeededEventHandler(AddressOf HandlerMethod)
C#
public delegate void DataGridViewRowContextMenuStripNeededEventHandler(
   object sender,
   DataGridViewRowContextMenuStripNeededEventArgs e
)
Managed Extensions for C++
public: __gc __delegate void DataGridViewRowContextMenuStripNeededEventHandler(
   Object* sender,
   DataGridViewRowContextMenuStripNeededEventArgs* e
)
C++/CLI
public delegate void DataGridViewRowContextMenuStripNeededEventHandler(
   Object^ sender,
   DataGridViewRowContextMenuStripNeededEventArgs^ e
)

Parameters

sender
e

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


DataGridViewRowDividerDoubleClickEventHandler Delegate

[image]
Gizmox.WebGUI.Forms
DataGridViewRowDividerDoubleClickEventHandler Delegate
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewRowDividerDoubleClickEventHandler Delegate

sender
e
Represents the method that will handle the RowDividerDoubleClick event of a DataGridView.

Syntax

Visual Basic (Declaration)
Public Delegate Sub DataGridViewRowDividerDoubleClickEventHandler( _
   ByVal sender As Object, _
   ByVal e As DataGridViewRowDividerDoubleClickEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New DataGridViewRowDividerDoubleClickEventHandler(AddressOf HandlerMethod)
C#
public delegate void DataGridViewRowDividerDoubleClickEventHandler(
   object sender,
   DataGridViewRowDividerDoubleClickEventArgs e
)
Managed Extensions for C++
public: __gc __delegate void DataGridViewRowDividerDoubleClickEventHandler(
   Object* sender,
   DataGridViewRowDividerDoubleClickEventArgs* e
)
C++/CLI
public delegate void DataGridViewRowDividerDoubleClickEventHandler(
   Object^ sender,
   DataGridViewRowDividerDoubleClickEventArgs^ e
)

Parameters

sender
e

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


DataGridViewRowErrorTextNeededEventHandler Delegate

[image]
Gizmox.WebGUI.Forms
DataGridViewRowErrorTextNeededEventHandler Delegate
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewRowErrorTextNeededEventHandler Delegate

sender
e
Represents the method that will handle the RowErrorTextNeeded event of a DataGridView.

Syntax

Visual Basic (Declaration)
Public Delegate Sub DataGridViewRowErrorTextNeededEventHandler( _
   ByVal sender As Object, _
   ByVal e As DataGridViewRowErrorTextNeededEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New DataGridViewRowErrorTextNeededEventHandler(AddressOf HandlerMethod)
C#
public delegate void DataGridViewRowErrorTextNeededEventHandler(
   object sender,
   DataGridViewRowErrorTextNeededEventArgs e
)
Managed Extensions for C++
public: __gc __delegate void DataGridViewRowErrorTextNeededEventHandler(
   Object* sender,
   DataGridViewRowErrorTextNeededEventArgs* e
)
C++/CLI
public delegate void DataGridViewRowErrorTextNeededEventHandler(
   Object^ sender,
   DataGridViewRowErrorTextNeededEventArgs^ e
)

Parameters

sender
e

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


DataGridViewRowEventHandler Delegate

[image]
Gizmox.WebGUI.Forms
DataGridViewRowEventHandler Delegate
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewRowEventHandler Delegate

sender
e
Represents the method that will handle row-related events of a DataGridView.

Syntax

Visual Basic (Declaration)
Public Delegate Sub DataGridViewRowEventHandler( _
   ByVal sender As Object, _
   ByVal e As DataGridViewRowEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New DataGridViewRowEventHandler(AddressOf HandlerMethod)
C#
public delegate void DataGridViewRowEventHandler(
   object sender,
   DataGridViewRowEventArgs e
)
Managed Extensions for C++
public: __gc __delegate void DataGridViewRowEventHandler(
   Object* sender,
   DataGridViewRowEventArgs* e
)
C++/CLI
public delegate void DataGridViewRowEventHandler(
   Object^ sender,
   DataGridViewRowEventArgs^ e
)

Parameters

sender
e

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


DataGridViewRowHeightInfoNeededEventHandler Delegate

[image]
Gizmox.WebGUI.Forms
DataGridViewRowHeightInfoNeededEventHandler Delegate
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewRowHeightInfoNeededEventHandler Delegate

sender
e
Represents the method that will handle an RowHeightInfoNeeded event of a DataGridView control.

Syntax

Visual Basic (Declaration)
Public Delegate Sub DataGridViewRowHeightInfoNeededEventHandler( _
   ByVal sender As Object, _
   ByVal e As DataGridViewRowHeightInfoNeededEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New DataGridViewRowHeightInfoNeededEventHandler(AddressOf HandlerMethod)
C#
public delegate void DataGridViewRowHeightInfoNeededEventHandler(
   object sender,
   DataGridViewRowHeightInfoNeededEventArgs e
)
Managed Extensions for C++
public: __gc __delegate void DataGridViewRowHeightInfoNeededEventHandler(
   Object* sender,
   DataGridViewRowHeightInfoNeededEventArgs* e
)
C++/CLI
public delegate void DataGridViewRowHeightInfoNeededEventHandler(
   Object^ sender,
   DataGridViewRowHeightInfoNeededEventArgs^ e
)

Parameters

sender
e

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


DataGridViewRowHeightInfoPushedEventHandler Delegate

[image]
Gizmox.WebGUI.Forms
DataGridViewRowHeightInfoPushedEventHandler Delegate
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewRowHeightInfoPushedEventHandler Delegate

sender
e
Represents the method that will handle the RowHeightInfoPushed event of a DataGridView.

Syntax

Visual Basic (Declaration)
Public Delegate Sub DataGridViewRowHeightInfoPushedEventHandler( _
   ByVal sender As Object, _
   ByVal e As DataGridViewRowHeightInfoPushedEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New DataGridViewRowHeightInfoPushedEventHandler(AddressOf HandlerMethod)
C#
public delegate void DataGridViewRowHeightInfoPushedEventHandler(
   object sender,
   DataGridViewRowHeightInfoPushedEventArgs e
)
Managed Extensions for C++
public: __gc __delegate void DataGridViewRowHeightInfoPushedEventHandler(
   Object* sender,
   DataGridViewRowHeightInfoPushedEventArgs* e
)
C++/CLI
public delegate void DataGridViewRowHeightInfoPushedEventHandler(
   Object^ sender,
   DataGridViewRowHeightInfoPushedEventArgs^ e
)

Parameters

sender
e

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


DataGridViewRowsAddedEventHandler Delegate

[image]
Gizmox.WebGUI.Forms
DataGridViewRowsAddedEventHandler Delegate
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewRowsAddedEventHandler Delegate

sender
e
Represents the method that will handle the RowsAdded event of a DataGridView.

Syntax

Visual Basic (Declaration)
Public Delegate Sub DataGridViewRowsAddedEventHandler( _
   ByVal sender As Object, _
   ByVal e As DataGridViewRowsAddedEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New DataGridViewRowsAddedEventHandler(AddressOf HandlerMethod)
C#
public delegate void DataGridViewRowsAddedEventHandler(
   object sender,
   DataGridViewRowsAddedEventArgs e
)
Managed Extensions for C++
public: __gc __delegate void DataGridViewRowsAddedEventHandler(
   Object* sender,
   DataGridViewRowsAddedEventArgs* e
)
C++/CLI
public delegate void DataGridViewRowsAddedEventHandler(
   Object^ sender,
   DataGridViewRowsAddedEventArgs^ e
)

Parameters

sender
e

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


DataGridViewRowsRemovedEventHandler Delegate

[image]
Gizmox.WebGUI.Forms
DataGridViewRowsRemovedEventHandler Delegate
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewRowsRemovedEventHandler Delegate

sender
e
Represents the method that will handle the RowsRemoved event of a DataGridView.

Syntax

Visual Basic (Declaration)
Public Delegate Sub DataGridViewRowsRemovedEventHandler( _
   ByVal sender As Object, _
   ByVal e As DataGridViewRowsRemovedEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New DataGridViewRowsRemovedEventHandler(AddressOf HandlerMethod)
C#
public delegate void DataGridViewRowsRemovedEventHandler(
   object sender,
   DataGridViewRowsRemovedEventArgs e
)
Managed Extensions for C++
public: __gc __delegate void DataGridViewRowsRemovedEventHandler(
   Object* sender,
   DataGridViewRowsRemovedEventArgs* e
)
C++/CLI
public delegate void DataGridViewRowsRemovedEventHandler(
   Object^ sender,
   DataGridViewRowsRemovedEventArgs^ e
)

Parameters

sender
e

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


DataGridViewRowStateChangedEventHandler Delegate

[image]
Gizmox.WebGUI.Forms
DataGridViewRowStateChangedEventHandler Delegate
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewRowStateChangedEventHandler Delegate

sender
e
Represents the method that will handle the RowStateChanged event of a DataGridView.

Syntax

Visual Basic (Declaration)
Public Delegate Sub DataGridViewRowStateChangedEventHandler( _
   ByVal sender As Object, _
   ByVal e As DataGridViewRowStateChangedEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New DataGridViewRowStateChangedEventHandler(AddressOf HandlerMethod)
C#
public delegate void DataGridViewRowStateChangedEventHandler(
   object sender,
   DataGridViewRowStateChangedEventArgs e
)
Managed Extensions for C++
public: __gc __delegate void DataGridViewRowStateChangedEventHandler(
   Object* sender,
   DataGridViewRowStateChangedEventArgs* e
)
C++/CLI
public delegate void DataGridViewRowStateChangedEventHandler(
   Object^ sender,
   DataGridViewRowStateChangedEventArgs^ e
)

Parameters

sender
e

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


DataGridViewSortCompareEventHandler Delegate

[image]
Gizmox.WebGUI.Forms
DataGridViewSortCompareEventHandler Delegate
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewSortCompareEventHandler Delegate

sender
e
Represents the method that will handle the SortCompare event of a DataGridView control.

Syntax

Visual Basic (Declaration)
Public Delegate Sub DataGridViewSortCompareEventHandler( _
   ByVal sender As Object, _
   ByVal e As DataGridViewSortCompareEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New DataGridViewSortCompareEventHandler(AddressOf HandlerMethod)
C#
public delegate void DataGridViewSortCompareEventHandler(
   object sender,
   DataGridViewSortCompareEventArgs e
)
Managed Extensions for C++
public: __gc __delegate void DataGridViewSortCompareEventHandler(
   Object* sender,
   DataGridViewSortCompareEventArgs* e
)
C++/CLI
public delegate void DataGridViewSortCompareEventHandler(
   Object^ sender,
   DataGridViewSortCompareEventArgs^ e
)

Parameters

sender
e

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


DragEventHandler Delegate

[image]
Gizmox.WebGUI.Forms
DragEventHandler Delegate
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DragEventHandler Delegate

sender
e
Represents the method that will handle the DragDrop, DragEnter, or DragOver event of a Control.

Syntax

Visual Basic (Declaration)
Public Delegate Sub DragEventHandler( _
   ByVal sender As Object, _
   ByVal e As DragEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New DragEventHandler(AddressOf HandlerMethod)
C#
public delegate void DragEventHandler(
   object sender,
   DragEventArgs e
)
Managed Extensions for C++
public: __gc __delegate void DragEventHandler(
   Object* sender,
   DragEventArgs* e
)
C++/CLI
public delegate void DragEventHandler(
   Object^ sender,
   DragEventArgs^ e
)

Parameters

sender
e

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


HelpEventHandler Delegate

[image]
Gizmox.WebGUI.Forms
HelpEventHandler Delegate
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : HelpEventHandler Delegate

sender
hlpevent
Represents the method that will handle the HelpRequested event of a Control.

Syntax

Visual Basic (Declaration)
Public Delegate Sub HelpEventHandler( _
   ByVal sender As Object, _
   ByVal hlpevent As HelpEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New HelpEventHandler(AddressOf HandlerMethod)
C#
public delegate void HelpEventHandler(
   object sender,
   HelpEventArgs hlpevent
)
Managed Extensions for C++
public: __gc __delegate void HelpEventHandler(
   Object* sender,
   HelpEventArgs* hlpevent
)
C++/CLI
public delegate void HelpEventHandler(
   Object^ sender,
   HelpEventArgs^ hlpevent
)

Parameters

sender
hlpevent

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


ItemChangedEventHandler Delegate

[image]
Gizmox.WebGUI.Forms
ItemChangedEventHandler Delegate
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ItemChangedEventHandler Delegate

sender
e
Represents the method that will handle the ItemChanged event of the CurrencyManager class.

Syntax

Visual Basic (Declaration)
Public Delegate Sub ItemChangedEventHandler( _
   ByVal sender As Object, _
   ByVal e As ItemChangedEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New ItemChangedEventHandler(AddressOf HandlerMethod)
C#
public delegate void ItemChangedEventHandler(
   object sender,
   ItemChangedEventArgs e
)
Managed Extensions for C++
public: __gc __delegate void ItemChangedEventHandler(
   Object* sender,
   ItemChangedEventArgs* e
)
C++/CLI
public delegate void ItemChangedEventHandler(
   Object^ sender,
   ItemChangedEventArgs^ e
)

Parameters

sender
e

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


ItemCheckHandler Delegate

[image]
Gizmox.WebGUI.Forms
ItemCheckHandler Delegate
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ItemCheckHandler Delegate

objSender
objArgs
The item check delgate

Syntax

Visual Basic (Declaration)
Public Delegate Sub ItemCheckHandler( _
   ByVal objSender As Object, _
   ByVal objArgs As ItemCheckEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New ItemCheckHandler(AddressOf HandlerMethod)
C#
public delegate void ItemCheckHandler(
   object objSender,
   ItemCheckEventArgs objArgs
)
Managed Extensions for C++
public: __gc __delegate void ItemCheckHandler(
   Object* objSender,
   ItemCheckEventArgs* objArgs
)
C++/CLI
public delegate void ItemCheckHandler(
   Object^ objSender,
   ItemCheckEventArgs^ objArgs
)

Parameters

objSender
objArgs

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


KeyEventHandler Delegate

[image]
Gizmox.WebGUI.Forms
KeyEventHandler Delegate
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : KeyEventHandler Delegate

objSender
objArgs
Key event hablder

Syntax

Visual Basic (Declaration)
Public Delegate Sub KeyEventHandler( _
   ByVal objSender As Object, _
   ByVal objArgs As KeyEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New KeyEventHandler(AddressOf HandlerMethod)
C#
public delegate void KeyEventHandler(
   object objSender,
   KeyEventArgs objArgs
)
Managed Extensions for C++
public: __gc __delegate void KeyEventHandler(
   Object* objSender,
   KeyEventArgs* objArgs
)
C++/CLI
public delegate void KeyEventHandler(
   Object^ objSender,
   KeyEventArgs^ objArgs
)

Parameters

objSender
objArgs

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


KeyPressEventHandler Delegate

[image]
Gizmox.WebGUI.Forms
KeyPressEventHandler Delegate
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : KeyPressEventHandler Delegate

sender
e
Represents the method that will handle the KeyPress event of a Control.

Syntax

Visual Basic (Declaration)
Public Delegate Sub KeyPressEventHandler( _
   ByVal sender As Object, _
   ByVal e As KeyPressEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New KeyPressEventHandler(AddressOf HandlerMethod)
C#
public delegate void KeyPressEventHandler(
   object sender,
   KeyPressEventArgs e
)
Managed Extensions for C++
public: __gc __delegate void KeyPressEventHandler(
   Object* sender,
   KeyPressEventArgs* e
)
C++/CLI
public delegate void KeyPressEventHandler(
   Object^ sender,
   KeyPressEventArgs^ e
)

Parameters

sender
e

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


LinkLabelLinkClickedEventHandler Delegate

[image]
Gizmox.WebGUI.Forms
LinkLabelLinkClickedEventHandler Delegate
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : LinkLabelLinkClickedEventHandler Delegate

sender
e
Represents the method that will handle the LinkLabel.LinkClicked event of a LinkLabel.

Syntax

Visual Basic (Declaration)
Public Delegate Sub LinkLabelLinkClickedEventHandler( _
   ByVal sender As Object, _
   ByVal e As LinkLabelLinkClickedEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New LinkLabelLinkClickedEventHandler(AddressOf HandlerMethod)
C#
public delegate void LinkLabelLinkClickedEventHandler(
   object sender,
   LinkLabelLinkClickedEventArgs e
)
Managed Extensions for C++
public: __gc __delegate void LinkLabelLinkClickedEventHandler(
   Object* sender,
   LinkLabelLinkClickedEventArgs* e
)
C++/CLI
public delegate void LinkLabelLinkClickedEventHandler(
   Object^ sender,
   LinkLabelLinkClickedEventArgs^ e
)

Parameters

sender
e

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


ListControlConvertEventHandler Delegate

[image]
Gizmox.WebGUI.Forms
ListControlConvertEventHandler Delegate
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ListControlConvertEventHandler Delegate

sender
e
Represents the method that will handle converting a ListControl.

Syntax

Visual Basic (Declaration)
Public Delegate Sub ListControlConvertEventHandler( _
   ByVal sender As Object, _
   ByVal e As ListControlConvertEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New ListControlConvertEventHandler(AddressOf HandlerMethod)
C#
public delegate void ListControlConvertEventHandler(
   object sender,
   ListControlConvertEventArgs e
)
Managed Extensions for C++
public: __gc __delegate void ListControlConvertEventHandler(
   Object* sender,
   ListControlConvertEventArgs* e
)
C++/CLI
public delegate void ListControlConvertEventHandler(
   Object^ sender,
   ListControlConvertEventArgs^ e
)

Parameters

sender
e

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


ListViewItemEventHandler Delegate

[image]
Gizmox.WebGUI.Forms
ListViewItemEventHandler Delegate
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ListViewItemEventHandler Delegate

objSource
objArgs
A list item event handler delegate

Syntax

Visual Basic (Declaration)
Public Delegate Sub ListViewItemEventHandler( _
   ByVal objSource As Object, _
   ByVal objArgs As ListViewItemEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New ListViewItemEventHandler(AddressOf HandlerMethod)
C#
public delegate void ListViewItemEventHandler(
   object objSource,
   ListViewItemEventArgs objArgs
)
Managed Extensions for C++
public: __gc __delegate void ListViewItemEventHandler(
   Object* objSource,
   ListViewItemEventArgs* objArgs
)
C++/CLI
public delegate void ListViewItemEventHandler(
   Object^ objSource,
   ListViewItemEventArgs^ objArgs
)

Parameters

objSource
objArgs

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


MenuEventHandler Delegate

[image]
Gizmox.WebGUI.Forms
MenuEventHandler Delegate
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : MenuEventHandler Delegate

objSource
objArgs
Handles menu item events

Syntax

Visual Basic (Declaration)
Public Delegate Sub MenuEventHandler( _
   ByVal objSource As Object, _
   ByVal objArgs As MenuItemEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New MenuEventHandler(AddressOf HandlerMethod)
C#
public delegate void MenuEventHandler(
   object objSource,
   MenuItemEventArgs objArgs
)
Managed Extensions for C++
public: __gc __delegate void MenuEventHandler(
   Object* objSource,
   MenuItemEventArgs* objArgs
)
C++/CLI
public delegate void MenuEventHandler(
   Object^ objSource,
   MenuItemEventArgs^ objArgs
)

Parameters

objSource
objArgs

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


MonthCalendarEventHandler Delegate

[image]
Gizmox.WebGUI.Forms
MonthCalendarEventHandler Delegate
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : MonthCalendarEventHandler Delegate

objSource
objArgs
Calendaer event handler delgate

Syntax

Visual Basic (Declaration)
Public Delegate Sub MonthCalendarEventHandler( _
   ByVal objSource As Object, _
   ByVal objArgs As EventHandler _
)
Visual Basic (Usage) Copy Code
Dim instance As New MonthCalendarEventHandler(AddressOf HandlerMethod)
C#
public delegate void MonthCalendarEventHandler(
   object objSource,
   EventHandler objArgs
)
Managed Extensions for C++
public: __gc __delegate void MonthCalendarEventHandler(
   Object* objSource,
   EventHandler* objArgs
)
C++/CLI
public delegate void MonthCalendarEventHandler(
   Object^ objSource,
   EventHandler^ objArgs
)

Parameters

objSource
objArgs

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


MouseEventHandler Delegate

[image]
Gizmox.WebGUI.Forms
MouseEventHandler Delegate
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : MouseEventHandler Delegate

sender
e

Syntax

Visual Basic (Declaration)
Public Delegate Sub MouseEventHandler( _
   ByVal sender As Object, _
   ByVal e As MouseEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New MouseEventHandler(AddressOf HandlerMethod)
C#
public delegate void MouseEventHandler(
   object sender,
   MouseEventArgs e
)
Managed Extensions for C++
public: __gc __delegate void MouseEventHandler(
   Object* sender,
   MouseEventArgs* e
)
C++/CLI
public delegate void MouseEventHandler(
   Object^ sender,
   MouseEventArgs^ e
)

Parameters

sender
e

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


NodeLabelEditEventHandler Delegate

[image]
Gizmox.WebGUI.Forms
NodeLabelEditEventHandler Delegate
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : NodeLabelEditEventHandler Delegate

sender
e

Syntax

Visual Basic (Declaration)
Public Delegate Sub NodeLabelEditEventHandler( _
   ByVal sender As Object, _
   ByVal e As NodeLabelEditEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New NodeLabelEditEventHandler(AddressOf HandlerMethod)
C#
public delegate void NodeLabelEditEventHandler(
   object sender,
   NodeLabelEditEventArgs e
)
Managed Extensions for C++
public: __gc __delegate void NodeLabelEditEventHandler(
   Object* sender,
   NodeLabelEditEventArgs* e
)
C++/CLI
public delegate void NodeLabelEditEventHandler(
   Object^ sender,
   NodeLabelEditEventArgs^ e
)

Parameters

sender
e

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


PropertyTabChangedEventHandler Delegate

[image]
Gizmox.WebGUI.Forms
PropertyTabChangedEventHandler Delegate
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : PropertyTabChangedEventHandler Delegate

s
e
Represents the method that will handle the PropertyTabChanged event of a PropertyGrid.

Syntax

Visual Basic (Declaration)
Public Delegate Sub PropertyTabChangedEventHandler( _
   ByVal s As Object, _
   ByVal e As PropertyTabChangedEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New PropertyTabChangedEventHandler(AddressOf HandlerMethod)
C#
public delegate void PropertyTabChangedEventHandler(
   object s,
   PropertyTabChangedEventArgs e
)
Managed Extensions for C++
public: __gc __delegate void PropertyTabChangedEventHandler(
   Object* s,
   PropertyTabChangedEventArgs* e
)
C++/CLI
public delegate void PropertyTabChangedEventHandler(
   Object^ s,
   PropertyTabChangedEventArgs^ e
)

Parameters

s
e

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


PropertyValueChangedEventHandler Delegate

[image]
Gizmox.WebGUI.Forms
PropertyValueChangedEventHandler Delegate
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : PropertyValueChangedEventHandler Delegate

s
e
The event handler class that is invoked when a property in the grid is modified by the user.

Syntax

Visual Basic (Declaration)
Public Delegate Sub PropertyValueChangedEventHandler( _
   ByVal s As Object, _
   ByVal e As PropertyValueChangedEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New PropertyValueChangedEventHandler(AddressOf HandlerMethod)
C#
public delegate void PropertyValueChangedEventHandler(
   object s,
   PropertyValueChangedEventArgs e
)
Managed Extensions for C++
public: __gc __delegate void PropertyValueChangedEventHandler(
   Object* s,
   PropertyValueChangedEventArgs* e
)
C++/CLI
public delegate void PropertyValueChangedEventHandler(
   Object^ s,
   PropertyValueChangedEventArgs^ e
)

Parameters

s
e

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


QuestionEventHandler Delegate

[image]
Gizmox.WebGUI.Forms
QuestionEventHandler Delegate
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : QuestionEventHandler Delegate

sender
e
Represents the method that will handle the CancelRowEdit event or the RowDirtyStateNeeded event of a DataGridView.

Syntax

Visual Basic (Declaration)
Public Delegate Sub QuestionEventHandler( _
   ByVal sender As Object, _
   ByVal e As QuestionEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New QuestionEventHandler(AddressOf HandlerMethod)
C#
public delegate void QuestionEventHandler(
   object sender,
   QuestionEventArgs e
)
Managed Extensions for C++
public: __gc __delegate void QuestionEventHandler(
   Object* sender,
   QuestionEventArgs* e
)
C++/CLI
public delegate void QuestionEventHandler(
   Object^ sender,
   QuestionEventArgs^ e
)

Parameters

sender
e

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


SelectedGridItemChangedEventHandler Delegate

[image]
Gizmox.WebGUI.Forms
SelectedGridItemChangedEventHandler Delegate
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : SelectedGridItemChangedEventHandler Delegate

sender
e
Represents the method that will handle the SelectedGridItemChanged event of a PropertyGrid.

Syntax

Visual Basic (Declaration)
Public Delegate Sub SelectedGridItemChangedEventHandler( _
   ByVal sender As Object, _
   ByVal e As SelectedGridItemChangedEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New SelectedGridItemChangedEventHandler(AddressOf HandlerMethod)
C#
public delegate void SelectedGridItemChangedEventHandler(
   object sender,
   SelectedGridItemChangedEventArgs e
)
Managed Extensions for C++
public: __gc __delegate void SelectedGridItemChangedEventHandler(
   Object* sender,
   SelectedGridItemChangedEventArgs* e
)
C++/CLI
public delegate void SelectedGridItemChangedEventHandler(
   Object^ sender,
   SelectedGridItemChangedEventArgs^ e
)

Parameters

sender
e

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


SplitterCancelEventHandler Delegate

[image]
Gizmox.WebGUI.Forms
SplitterCancelEventHandler Delegate
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : SplitterCancelEventHandler Delegate

sender
e

Syntax

Visual Basic (Declaration)
Public Delegate Sub SplitterCancelEventHandler( _
   ByVal sender As Object, _
   ByVal e As SplitterCancelEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New SplitterCancelEventHandler(AddressOf HandlerMethod)
C#
public delegate void SplitterCancelEventHandler(
   object sender,
   SplitterCancelEventArgs e
)
Managed Extensions for C++
public: __gc __delegate void SplitterCancelEventHandler(
   Object* sender,
   SplitterCancelEventArgs* e
)
C++/CLI
public delegate void SplitterCancelEventHandler(
   Object^ sender,
   SplitterCancelEventArgs^ e
)

Parameters

sender
e

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


SplitterEventHandler Delegate

[image]
Gizmox.WebGUI.Forms
SplitterEventHandler Delegate
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : SplitterEventHandler Delegate

sender
e

Syntax

Visual Basic (Declaration)
Public Delegate Sub SplitterEventHandler( _
   ByVal sender As Object, _
   ByVal e As SplitterEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New SplitterEventHandler(AddressOf HandlerMethod)
C#
public delegate void SplitterEventHandler(
   object sender,
   SplitterEventArgs e
)
Managed Extensions for C++
public: __gc __delegate void SplitterEventHandler(
   Object* sender,
   SplitterEventArgs* e
)
C++/CLI
public delegate void SplitterEventHandler(
   Object^ sender,
   SplitterEventArgs^ e
)

Parameters

sender
e

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


TabControlCancelEventHandler Delegate

[image]
Gizmox.WebGUI.Forms
TabControlCancelEventHandler Delegate
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TabControlCancelEventHandler Delegate

sender
e
Represents the method that will handle the Selecting or Deselecting event of a TabControl control.

Syntax

Visual Basic (Declaration)
Public Delegate Sub TabControlCancelEventHandler( _
   ByVal sender As Object, _
   ByVal e As TabControlCancelEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New TabControlCancelEventHandler(AddressOf HandlerMethod)
C#
public delegate void TabControlCancelEventHandler(
   object sender,
   TabControlCancelEventArgs e
)
Managed Extensions for C++
public: __gc __delegate void TabControlCancelEventHandler(
   Object* sender,
   TabControlCancelEventArgs* e
)
C++/CLI
public delegate void TabControlCancelEventHandler(
   Object^ sender,
   TabControlCancelEventArgs^ e
)

Parameters

sender
e

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


TableLayoutCellPaintEventHandler Delegate

[image]
Gizmox.WebGUI.Forms
TableLayoutCellPaintEventHandler Delegate
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TableLayoutCellPaintEventHandler Delegate

sender
e

Syntax

Visual Basic (Declaration)
Public Delegate Sub TableLayoutCellPaintEventHandler( _
   ByVal sender As Object, _
   ByVal e As TableLayoutCellPaintEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New TableLayoutCellPaintEventHandler(AddressOf HandlerMethod)
C#
public delegate void TableLayoutCellPaintEventHandler(
   object sender,
   TableLayoutCellPaintEventArgs e
)
Managed Extensions for C++
public: __gc __delegate void TableLayoutCellPaintEventHandler(
   Object* sender,
   TableLayoutCellPaintEventArgs* e
)
C++/CLI
public delegate void TableLayoutCellPaintEventHandler(
   Object^ sender,
   TableLayoutCellPaintEventArgs^ e
)

Parameters

sender
e

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


TabPageEventHandler Delegate

[image]
Gizmox.WebGUI.Forms
TabPageEventHandler Delegate
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TabPageEventHandler Delegate

objSource
objArgs
Represents the method that will handle events of a TabControl control.

Syntax

Visual Basic (Declaration)
Public Delegate Sub TabPageEventHandler( _
   ByVal objSource As Object, _
   ByVal objArgs As TabPageEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New TabPageEventHandler(AddressOf HandlerMethod)
C#
public delegate void TabPageEventHandler(
   object objSource,
   TabPageEventArgs objArgs
)
Managed Extensions for C++
public: __gc __delegate void TabPageEventHandler(
   Object* objSource,
   TabPageEventArgs* objArgs
)
C++/CLI
public delegate void TabPageEventHandler(
   Object^ objSource,
   TabPageEventArgs^ objArgs
)

Parameters

objSource
objArgs

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


ToolBarButtonClickEventHandler Delegate

[image]
Gizmox.WebGUI.Forms
ToolBarButtonClickEventHandler Delegate
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ToolBarButtonClickEventHandler Delegate

sender
e

Syntax

Visual Basic (Declaration)
Public Delegate Sub ToolBarButtonClickEventHandler( _
   ByVal sender As Object, _
   ByVal e As ToolBarButtonClickEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New ToolBarButtonClickEventHandler(AddressOf HandlerMethod)
C#
public delegate void ToolBarButtonClickEventHandler(
   object sender,
   ToolBarButtonClickEventArgs e
)
Managed Extensions for C++
public: __gc __delegate void ToolBarButtonClickEventHandler(
   Object* sender,
   ToolBarButtonClickEventArgs* e
)
C++/CLI
public delegate void ToolBarButtonClickEventHandler(
   Object^ sender,
   ToolBarButtonClickEventArgs^ e
)

Parameters

sender
e

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


ToolBarItemHandler Delegate

[image]
Gizmox.WebGUI.Forms
ToolBarItemHandler Delegate
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ToolBarItemHandler Delegate

objSource
objArgs

Syntax

Visual Basic (Declaration)
Public Delegate Sub ToolBarItemHandler( _
   ByVal objSource As Object, _
   ByVal objArgs As ToolBarItemEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New ToolBarItemHandler(AddressOf HandlerMethod)
C#
public delegate void ToolBarItemHandler(
   object objSource,
   ToolBarItemEventArgs objArgs
)
Managed Extensions for C++
public: __gc __delegate void ToolBarItemHandler(
   Object* objSource,
   ToolBarItemEventArgs* objArgs
)
C++/CLI
public delegate void ToolBarItemHandler(
   Object^ objSource,
   ToolBarItemEventArgs^ objArgs
)

Parameters

objSource
objArgs

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


TreeNodeMouseClickEventHandler Delegate

[image]
Gizmox.WebGUI.Forms
TreeNodeMouseClickEventHandler Delegate
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TreeNodeMouseClickEventHandler Delegate

sender
e
Represents the method that will handle the TreeView.NodeMouseClick and TreeView.NodeMouseDoubleClick events of a TreeView.

Syntax

Visual Basic (Declaration)
Public Delegate Sub TreeNodeMouseClickEventHandler( _
   ByVal sender As Object, _
   ByVal e As TreeNodeMouseClickEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New TreeNodeMouseClickEventHandler(AddressOf HandlerMethod)
C#
public delegate void TreeNodeMouseClickEventHandler(
   object sender,
   TreeNodeMouseClickEventArgs e
)
Managed Extensions for C++
public: __gc __delegate void TreeNodeMouseClickEventHandler(
   Object* sender,
   TreeNodeMouseClickEventArgs* e
)
C++/CLI
public delegate void TreeNodeMouseClickEventHandler(
   Object^ sender,
   TreeNodeMouseClickEventArgs^ e
)

Parameters

sender
e

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


TreeViewCancelEventHandler Delegate

[image]
Gizmox.WebGUI.Forms
TreeViewCancelEventHandler Delegate
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TreeViewCancelEventHandler Delegate

sender
e

Syntax

Visual Basic (Declaration)
Public Delegate Sub TreeViewCancelEventHandler( _
   ByVal sender As Object, _
   ByVal e As TreeViewCancelEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New TreeViewCancelEventHandler(AddressOf HandlerMethod)
C#
public delegate void TreeViewCancelEventHandler(
   object sender,
   TreeViewCancelEventArgs e
)
Managed Extensions for C++
public: __gc __delegate void TreeViewCancelEventHandler(
   Object* sender,
   TreeViewCancelEventArgs* e
)
C++/CLI
public delegate void TreeViewCancelEventHandler(
   Object^ sender,
   TreeViewCancelEventArgs^ e
)

Parameters

sender
e

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


TreeViewEventHandler Delegate

[image]
Gizmox.WebGUI.Forms
TreeViewEventHandler Delegate
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TreeViewEventHandler Delegate

sender
e

Syntax

Visual Basic (Declaration)
Public Delegate Sub TreeViewEventHandler( _
   ByVal sender As Object, _
   ByVal e As TreeViewEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New TreeViewEventHandler(AddressOf HandlerMethod)
C#
public delegate void TreeViewEventHandler(
   object sender,
   TreeViewEventArgs e
)
Managed Extensions for C++
public: __gc __delegate void TreeViewEventHandler(
   Object* sender,
   TreeViewEventArgs* e
)
C++/CLI
public delegate void TreeViewEventHandler(
   Object^ sender,
   TreeViewEventArgs^ e
)

Parameters

sender
e

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


Gizmox.WebGUI.Forms.Authentication Namespace

Gizmox.WebGUI.Forms.Authentication Namespace
See Also Inheritance Hierarchy Send Feedback

Classes

 | Class | Description
Class | LogonForm | Impementation for LogonForm class.
Class | LogonListenerForm | Impementation for LogonListnerForm class.
Class | LogonOpenerForm | Impementation for LogonOpenerForm class.

See Also

Reference

Gizmox.WebGUI.Forms Assembly


LogonForm Class

[image]
Gizmox.WebGUI.Forms
LogonForm Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms.Authentication Namespace : LogonForm Class

Impementation for LogonForm class.

Object Model

Syntax

Visual Basic (Declaration)
<ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")>
Public Class LogonForm
   Inherits Form
   Implements IAttributeExtender, IControl, IEventHandler, IForm, IGatewayComponent, ILogonForm, IObservableItem, IObservableLayoutItem, IObservableList, IRegisteredComponent, IRenderableComponent, IBindableComponent, IContainerControl, IArrangedElement
Visual Basic (Usage) Copy Code
Dim instance As LogonForm
C#
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
public class LogonForm : Form, IAttributeExtender, IControl, IEventHandler, IForm, IGatewayComponent, ILogonForm, IObservableItem, IObservableLayoutItem, IObservableList, IRegisteredComponent, IRenderableComponent, IBindableComponent, IContainerControl, IArrangedElement
Managed Extensions for C++
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
public __gc class LogonForm : public Form, IAttributeExtender, IControl, IEventHandler, IForm, IGatewayComponent, ILogonForm, IObservableItem, IObservableLayoutItem, IObservableList, IRegisteredComponent, IRenderableComponent, IBindableComponent, IContainerControl, IArrangedElement
C++/CLI
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
public ref class LogonForm : public Form, IAttributeExtender, IControl, IEventHandler, IForm, IGatewayComponent, ILogonForm, IObservableItem, IObservableLayoutItem, IObservableList, IRegisteredComponent, IRenderableComponent, IBindableComponent, IContainerControl, IArrangedElement

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.ScrollableControl
Gizmox.WebGUI.Forms.ContainerControl
Gizmox.WebGUI.Forms.Form
Gizmox.WebGUI.Forms.Authentication.LogonForm

Requirements

Namespace: Gizmox.WebGUI.Forms.Authentication

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

LogonForm Members
Gizmox.WebGUI.Forms.Authentication Namespace


LogonForm Class Members

[image]
Gizmox.WebGUI.Forms
LogonForm Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms.Authentication Namespace : LogonForm Class

The following tables list the members exposed by LogonForm.

Public Constructors

 | Name | Description
Public Constructor | LogonForm Constructor | Creates a new LogonForm instance.
Top

Public Properties

 | Name | Description
Public Property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | ActiveControl | Gets or sets the active control on the container control. (Inherited from Gizmox.WebGUI.Forms.ContainerControl)
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | AutoScaleBaseSize | Gets or sets the size of the auto scale base. Not implemented. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Public Property | BackColor | Gets or sets the background color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BeforeUnloadMessage | Gets or sets the before unload message. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | BindingContext | (Inherited from Gizmox.WebGUI.Forms.ContainerControl)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CancelButton | Gets or sets the button on the form that is clicked when the user presses the ESC key. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Components | (Inherited from Gizmox.WebGUI.Forms.ContainerControl)
Public Property | Container | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Context | Gets the context. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | DialogResult | Gets or sets the dialog result. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Public Property | DragMappings | Gets the form drag mappings. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Form | Gets the owner form. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | FormBorderStyle | Gets or sets the form border style. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | FormStyle | Gets or sets the form style. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | HasControls | Gets a value indicating whether this control has controls. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Header | Gets or sets the form header control. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Height | Gets/Sets the height position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Icon | Gets or sets the form icon (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | IsRegistered | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Left | Gets/Sets the left position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Location | Gets or sets the control location. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | MaximizeBox | Gets or sets a value indicating whether [maximize box]. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | MinimizeBox | Gets or sets a value indicating whether [minimize box]. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Modal | Gets or sets a value indicating whether this window is modal. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | OwnedForms | Gets the child forms. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Owner | Gets the parent window. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Padding | Gets or sets the control padding. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Right | Gets/Sets the right position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ShowInTaskbar | Gets or sets a value indicating whether [show in taskbar]. Not implemented by design (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Site | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | StartPosition | Gets or sets the form start position. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Top | Gets/Sets the top position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Visible | Get/Sets the form visibility (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Width | Gets/Sets the width position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | WindowState | Gets or sets the state of the window. (Inherited from Gizmox.WebGUI.Forms.Form)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultBorderColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultBorderStyle | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultForeColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMargin | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultPadding | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DesignMode | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | Events | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Protected Property | IsConnected | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Property | IsDelayedDrawing | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | IsWindowSized | Calculate size invluding borders (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | Session | Gets or sets the main form. (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Top

Public Methods

 | Name | Description
Public Method | Add | (Inherited from Gizmox.WebGUI.Forms.ContainerControl)
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Close | Closes this window. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Gizmox.WebGUI.Forms.ContainerControl)
Public Method | Focus | Sets focus to this control (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | GetPreferredSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Remove | (Inherited from Gizmox.WebGUI.Forms.ContainerControl)
Public Method | ResetText | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Public Method | Select | Overloaded. Activates the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SendToBack | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Show | (Inherited from Gizmox.WebGUI.Forms.Form)
Public Method | ShowDialog | Overloaded. Shows a the form as a dialog. The ShowDialog in Visual WebGui works differently than WinForms. Code lines after this call is executed immediately and won’t wait for the dialog to close. If you need to run code only after the dialog is closed or only if a specific result is returned register to the close event of the dialog. See documentation for code example. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Method | ShowPopup | Overloaded. Displays the form as a popup window. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ToString | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Update | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | Finalize | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCommandText | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetImage | Gets the image. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetPreferredSizeCore | (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Protected Method | GetService | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | InvokeMethod | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | IsDirty | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | OnActivated | Raises the Activated event. (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBindingContextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnClosed | (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnClosing | (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnControlAdded | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnControlRemoved | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnCreateControl | Occurs when control is created (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | OnEnabledChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnGotFocus | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLoad | Raises the Load event. (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnLocationChanged | (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnLostFocus | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentVisibleChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnResize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnTextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnUnregisterComponents | (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnValidated | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnValidating | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ProcessGatewayRequest | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RegisterSelf | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | Render | Render the form content (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | RenderAttributes | Renders the forms attribute (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderClientUpdateHandler | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderComponentEventAttributes | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderUpdatedAttributes | (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetImage | Sets the image. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeText | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | UnRegisterBatch | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | UnRegisterSelf | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | UpdateParams | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Top

Public Events

 | Name | Description
Public Event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Closed | (Inherited from Gizmox.WebGUI.Forms.Form)
Public Event | Closing | The form closing event. This event is not raised on the main form. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Disposed | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Load | The form load event (Inherited from Gizmox.WebGUI.Forms.Form)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Gizmox.WebGUI.Forms.Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Top

See Also

Reference

LogonForm Class
Gizmox.WebGUI.Forms.Authentication Namespace


LogonForm Constructor

[image]
Gizmox.WebGUI.Forms
LogonForm Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms.Authentication Namespace > LogonForm Class : LogonForm Constructor

Creates a new LogonForm instance.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As LogonForm()
C#
public LogonForm()
Managed Extensions for C++
public: LogonForm();
C++/CLI
public:
LogonForm();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LogonForm Class
LogonForm Members


LogonListenerForm Class

[image]
Gizmox.WebGUI.Forms
LogonListenerForm Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms.Authentication Namespace : LogonListenerForm Class

Impementation for LogonListnerForm class.

Object Model

Syntax

Visual Basic (Declaration)
<ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")>
Public Class LogonListenerForm
   Inherits Form
   Implements IAttributeExtender, IControl, IEventHandler, IForm, IGatewayComponent, ILogonForm, IObservableItem, IObservableLayoutItem, IObservableList, IRegisteredComponent, IRenderableComponent, IBindableComponent, IContainerControl, IArrangedElement
Visual Basic (Usage) Copy Code
Dim instance As LogonListenerForm
C#
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
public class LogonListenerForm : Form, IAttributeExtender, IControl, IEventHandler, IForm, IGatewayComponent, ILogonForm, IObservableItem, IObservableLayoutItem, IObservableList, IRegisteredComponent, IRenderableComponent, IBindableComponent, IContainerControl, IArrangedElement
Managed Extensions for C++
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
public __gc class LogonListenerForm : public Form, IAttributeExtender, IControl, IEventHandler, IForm, IGatewayComponent, ILogonForm, IObservableItem, IObservableLayoutItem, IObservableList, IRegisteredComponent, IRenderableComponent, IBindableComponent, IContainerControl, IArrangedElement
C++/CLI
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
public ref class LogonListenerForm : public Form, IAttributeExtender, IControl, IEventHandler, IForm, IGatewayComponent, ILogonForm, IObservableItem, IObservableLayoutItem, IObservableList, IRegisteredComponent, IRenderableComponent, IBindableComponent, IContainerControl, IArrangedElement

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.ScrollableControl
Gizmox.WebGUI.Forms.ContainerControl
Gizmox.WebGUI.Forms.Form
Gizmox.WebGUI.Forms.Authentication.LogonListenerForm

Requirements

Namespace: Gizmox.WebGUI.Forms.Authentication

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

LogonListenerForm Members
Gizmox.WebGUI.Forms.Authentication Namespace


LogonListenerForm Class Members

[image]
Gizmox.WebGUI.Forms
LogonListenerForm Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms.Authentication Namespace : LogonListenerForm Class

The following tables list the members exposed by LogonListenerForm.

Public Constructors

 | Name | Description
Public Constructor | LogonListenerForm Constructor |
Top

Public Properties

 | Name | Description
Public Property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | ActiveControl | Gets or sets the active control on the container control. (Inherited from Gizmox.WebGUI.Forms.ContainerControl)
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | AutoScaleBaseSize | Gets or sets the size of the auto scale base. Not implemented. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Public Property | BackColor | Gets or sets the background color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BeforeUnloadMessage | Gets or sets the before unload message. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | BindingContext | (Inherited from Gizmox.WebGUI.Forms.ContainerControl)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CancelButton | Gets or sets the button on the form that is clicked when the user presses the ESC key. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Components | (Inherited from Gizmox.WebGUI.Forms.ContainerControl)
Public Property | Container | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Context | Gets the context. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | DialogResult | Gets or sets the dialog result. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Public Property | DragMappings | Gets the form drag mappings. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Form | Gets the owner form. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | FormBorderStyle | Gets or sets the form border style. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | FormStyle | Gets or sets the form style. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | HasControls | Gets a value indicating whether this control has controls. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Header | Gets or sets the form header control. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Height | Gets/Sets the height position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Icon | Gets or sets the form icon (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | IsRegistered | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Left | Gets/Sets the left position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Location | Gets or sets the control location. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | MaximizeBox | Gets or sets a value indicating whether [maximize box]. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | MinimizeBox | Gets or sets a value indicating whether [minimize box]. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Modal | Gets or sets a value indicating whether this window is modal. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | OwnedForms | Gets the child forms. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Owner | Gets the parent window. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Padding | Gets or sets the control padding. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Right | Gets/Sets the right position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ShowInTaskbar | Gets or sets a value indicating whether [show in taskbar]. Not implemented by design (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Site | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | StartPosition | Gets or sets the form start position. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Top | Gets/Sets the top position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Visible | Get/Sets the form visibility (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Width | Gets/Sets the width position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | WindowState | Gets or sets the state of the window. (Inherited from Gizmox.WebGUI.Forms.Form)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultBorderColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultBorderStyle | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultForeColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMargin | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultPadding | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DesignMode | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | Events | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Protected Property | IsConnected | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Property | IsDelayedDrawing | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | IsWindowSized | Calculate size invluding borders (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | Session | Gets or sets the main form. (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Top

Public Methods

 | Name | Description
Public Method | Add | (Inherited from Gizmox.WebGUI.Forms.ContainerControl)
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Close | Closes this window. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Gizmox.WebGUI.Forms.ContainerControl)
Public Method | Focus | Sets focus to this control (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | GetPreferredSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Remove | (Inherited from Gizmox.WebGUI.Forms.ContainerControl)
Public Method | ResetText | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Public Method | Select | Overloaded. Activates the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SendToBack | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Show | (Inherited from Gizmox.WebGUI.Forms.Form)
Public Method | ShowDialog | Overloaded. Shows a the form as a dialog. The ShowDialog in Visual WebGui works differently than WinForms. Code lines after this call is executed immediately and won’t wait for the dialog to close. If you need to run code only after the dialog is closed or only if a specific result is returned register to the close event of the dialog. See documentation for code example. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Method | ShowPopup | Overloaded. Displays the form as a popup window. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ToString | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Update | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | Finalize | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCommandText | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetImage | Gets the image. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetPreferredSizeCore | (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Protected Method | GetService | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | InvokeMethod | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | IsDirty | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | OnActivated | Raises the Activated event. (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBindingContextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnClosed | (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnClosing | (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnControlAdded | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnControlRemoved | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnCreateControl | Occurs when control is created (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | OnEnabledChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnGotFocus | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLoad | Raises the Load event. (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnLocationChanged | (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnLostFocus | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentVisibleChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnResize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnTextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnUnregisterComponents | (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnValidated | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnValidating | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ProcessGatewayRequest | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RegisterSelf | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | Render | Render the form content (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | RenderAttributes | Renders the forms attribute (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderClientUpdateHandler | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderComponentEventAttributes | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderUpdatedAttributes | (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetImage | Sets the image. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeText | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | UnRegisterBatch | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | UnRegisterSelf | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | UpdateParams | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Top

Public Events

 | Name | Description
Public Event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Closed | (Inherited from Gizmox.WebGUI.Forms.Form)
Public Event | Closing | The form closing event. This event is not raised on the main form. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Disposed | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Load | The form load event (Inherited from Gizmox.WebGUI.Forms.Form)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Gizmox.WebGUI.Forms.Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Top

See Also

Reference

LogonListenerForm Class
Gizmox.WebGUI.Forms.Authentication Namespace


LogonListenerForm Constructor

[image]
Gizmox.WebGUI.Forms
LogonListenerForm Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms.Authentication Namespace > LogonListenerForm Class : LogonListenerForm Constructor

objWGContext

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal objWGContext As IContext _
)
Visual Basic (Usage) Copy Code
Dim objWGContext As IContext

Dim instance As LogonListenerForm(objWGContext)
C#
public LogonListenerForm(
   IContext objWGContext
)
Managed Extensions for C++
public: LogonListenerForm(
   IContext* objWGContext
)
C++/CLI
public:
LogonListenerForm(
   IContext^ objWGContext
)

Parameters

objWGContext

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LogonListenerForm Class
LogonListenerForm Members


LogonOpenerForm Class

[image]
Gizmox.WebGUI.Forms
LogonOpenerForm Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms.Authentication Namespace : LogonOpenerForm Class

Impementation for LogonOpenerForm class.

Object Model

Syntax

Visual Basic (Declaration)
<ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")>
Public Class LogonOpenerForm
   Inherits Form
   Implements IAttributeExtender, IControl, IEventHandler, IForm, IGatewayComponent, ILogonForm, IObservableItem, IObservableLayoutItem, IObservableList, IRegisteredComponent, IRenderableComponent, IBindableComponent, IContainerControl, IArrangedElement
Visual Basic (Usage) Copy Code
Dim instance As LogonOpenerForm
C#
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
public class LogonOpenerForm : Form, IAttributeExtender, IControl, IEventHandler, IForm, IGatewayComponent, ILogonForm, IObservableItem, IObservableLayoutItem, IObservableList, IRegisteredComponent, IRenderableComponent, IBindableComponent, IContainerControl, IArrangedElement
Managed Extensions for C++
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
public __gc class LogonOpenerForm : public Form, IAttributeExtender, IControl, IEventHandler, IForm, IGatewayComponent, ILogonForm, IObservableItem, IObservableLayoutItem, IObservableList, IRegisteredComponent, IRenderableComponent, IBindableComponent, IContainerControl, IArrangedElement
C++/CLI
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
public ref class LogonOpenerForm : public Form, IAttributeExtender, IControl, IEventHandler, IForm, IGatewayComponent, ILogonForm, IObservableItem, IObservableLayoutItem, IObservableList, IRegisteredComponent, IRenderableComponent, IBindableComponent, IContainerControl, IArrangedElement

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.ScrollableControl
Gizmox.WebGUI.Forms.ContainerControl
Gizmox.WebGUI.Forms.Form
Gizmox.WebGUI.Forms.Authentication.LogonOpenerForm

Requirements

Namespace: Gizmox.WebGUI.Forms.Authentication

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

LogonOpenerForm Members
Gizmox.WebGUI.Forms.Authentication Namespace


LogonOpenerForm Class Members

[image]
Gizmox.WebGUI.Forms
LogonOpenerForm Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms.Authentication Namespace : LogonOpenerForm Class

The following tables list the members exposed by LogonOpenerForm.

Public Constructors

 | Name | Description
Public Constructor | LogonOpenerForm Constructor |
Top

Public Properties

 | Name | Description
Public Property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | ActiveControl | Gets or sets the active control on the container control. (Inherited from Gizmox.WebGUI.Forms.ContainerControl)
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | AutoScaleBaseSize | Gets or sets the size of the auto scale base. Not implemented. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Public Property | BackColor | Gets or sets the background color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BeforeUnloadMessage | Gets or sets the before unload message. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | BindingContext | (Inherited from Gizmox.WebGUI.Forms.ContainerControl)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CancelButton | Gets or sets the button on the form that is clicked when the user presses the ESC key. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Components | (Inherited from Gizmox.WebGUI.Forms.ContainerControl)
Public Property | Container | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Context | Gets the context. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | DialogResult | Gets or sets the dialog result. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Public Property | DragMappings | Gets the form drag mappings. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Form | Gets the owner form. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | FormBorderStyle | Gets or sets the form border style. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | FormStyle | Gets or sets the form style. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | HasControls | Gets a value indicating whether this control has controls. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Header | Gets or sets the form header control. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Height | Gets/Sets the height position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Icon | Gets or sets the form icon (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | IsRegistered | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Left | Gets/Sets the left position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Location | Gets or sets the control location. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | MaximizeBox | Gets or sets a value indicating whether [maximize box]. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | MinimizeBox | Gets or sets a value indicating whether [minimize box]. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Modal | Gets or sets a value indicating whether this window is modal. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | OwnedForms | Gets the child forms. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Owner | Gets the parent window. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Padding | Gets or sets the control padding. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Right | Gets/Sets the right position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ShowInTaskbar | Gets or sets a value indicating whether [show in taskbar]. Not implemented by design (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Site | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | StartPosition | Gets or sets the form start position. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Top | Gets/Sets the top position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Visible | Get/Sets the form visibility (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Width | Gets/Sets the width position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | WindowState | Gets or sets the state of the window. (Inherited from Gizmox.WebGUI.Forms.Form)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultBorderColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultBorderStyle | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultForeColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMargin | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultPadding | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DesignMode | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | Events | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Protected Property | IsConnected | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Property | IsDelayedDrawing | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | IsWindowSized | Calculate size invluding borders (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | Session | Gets or sets the main form. (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Top

Public Methods

 | Name | Description
Public Method | Add | (Inherited from Gizmox.WebGUI.Forms.ContainerControl)
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Close | Closes this window. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Gizmox.WebGUI.Forms.ContainerControl)
Public Method | Focus | Sets focus to this control (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | GetPreferredSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Remove | (Inherited from Gizmox.WebGUI.Forms.ContainerControl)
Public Method | ResetText | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Public Method | Select | Overloaded. Activates the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SendToBack | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Show | (Inherited from Gizmox.WebGUI.Forms.Form)
Public Method | ShowDialog | Overloaded. Shows a the form as a dialog. The ShowDialog in Visual WebGui works differently than WinForms. Code lines after this call is executed immediately and won’t wait for the dialog to close. If you need to run code only after the dialog is closed or only if a specific result is returned register to the close event of the dialog. See documentation for code example. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Method | ShowPopup | Overloaded. Displays the form as a popup window. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ToString | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Update | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | Finalize | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCommandText | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetImage | Gets the image. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetPreferredSizeCore | (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Protected Method | GetService | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | InvokeMethod | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | IsDirty | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | OnActivated | Raises the Activated event. (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBindingContextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnClosed | (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnClosing | (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnControlAdded | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnControlRemoved | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnCreateControl | Occurs when control is created (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | OnEnabledChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnGotFocus | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLoad | Raises the Load event. (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnLocationChanged | (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnLostFocus | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentVisibleChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnResize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnTextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnUnregisterComponents | (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnValidated | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnValidating | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ProcessGatewayRequest | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RegisterSelf | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | Render | Render the form content (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | RenderAttributes | Renders the forms attribute (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderClientUpdateHandler | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderComponentEventAttributes | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderUpdatedAttributes | (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetImage | Sets the image. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeText | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | UnRegisterBatch | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | UnRegisterSelf | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | UpdateParams | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Top

Public Events

 | Name | Description
Public Event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Closed | (Inherited from Gizmox.WebGUI.Forms.Form)
Public Event | Closing | The form closing event. This event is not raised on the main form. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Disposed | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Load | The form load event (Inherited from Gizmox.WebGUI.Forms.Form)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Gizmox.WebGUI.Forms.Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Top

See Also

Reference

LogonOpenerForm Class
Gizmox.WebGUI.Forms.Authentication Namespace


LogonOpenerForm Constructor

[image]
Gizmox.WebGUI.Forms
LogonOpenerForm Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms.Authentication Namespace > LogonOpenerForm Class : LogonOpenerForm Constructor

objWGContext
objLogonForm

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal objWGContext As IContext, _
   ByVal objLogonForm As LogonForm _
)
Visual Basic (Usage) Copy Code
Dim objWGContext As IContext
Dim objLogonForm As LogonForm

Dim instance As LogonOpenerForm(objWGContext, objLogonForm)
C#
public LogonOpenerForm(
   IContext objWGContext,
   LogonForm objLogonForm
)
Managed Extensions for C++
public: LogonOpenerForm(
   IContext* objWGContext,
   LogonForm* objLogonForm
)
C++/CLI
public:
LogonOpenerForm(
   IContext^ objWGContext,
   LogonForm^ objLogonForm
)

Parameters

objWGContext
objLogonForm

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LogonOpenerForm Class
LogonOpenerForm Members


Gizmox.WebGUI.Forms.Controls Namespace

Gizmox.WebGUI.Forms.Controls Namespace
See Also Inheritance Hierarchy Send Feedback

Classes

 | Class | Description
Class | ItemChooser | Provides an empty control that can be used to create other controls.

See Also

Reference

Gizmox.WebGUI.Forms Assembly


ItemChooser Class

[image]
Gizmox.WebGUI.Forms
ItemChooser Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms.Controls Namespace : ItemChooser Class

Provides an empty control that can be used to create other controls.

Object Model

Syntax

Visual Basic (Declaration)
<ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")>
Public Class ItemChooser
   Inherits UserControl
   Implements IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IUserControl, IBindableComponent, IContainerControl, IArrangedElement
Visual Basic (Usage) Copy Code
Dim instance As ItemChooser
C#
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
public class ItemChooser : UserControl, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IUserControl, IBindableComponent, IContainerControl, IArrangedElement
Managed Extensions for C++
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
public __gc class ItemChooser : public UserControl, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IUserControl, IBindableComponent, IContainerControl, IArrangedElement
C++/CLI
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
public ref class ItemChooser : public UserControl, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IUserControl, IBindableComponent, IContainerControl, IArrangedElement

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.ScrollableControl
Gizmox.WebGUI.Forms.ContainerControl
Gizmox.WebGUI.Forms.UserControl
Gizmox.WebGUI.Forms.Controls.ItemChooser

Requirements

Namespace: Gizmox.WebGUI.Forms.Controls

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

ItemChooser Members
Gizmox.WebGUI.Forms.Controls Namespace


ItemChooser Class Members

[image]
Gizmox.WebGUI.Forms
ItemChooser Class Members
See Also Fields Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms.Controls Namespace : ItemChooser Class

The following tables list the members exposed by ItemChooser.

Public Constructors

 | Name | Description
Public Constructor | ItemChooser Constructor | Creates a new ItemChooser instance.
Top

Public Fields

 | Name | Description
Public Field | mblnIsLoaded | Gets a value indicating whether the instance of UserControl is loaded. (Inherited from Gizmox.WebGUI.Forms.UserControl)
Top

Public Properties

 | Name | Description
Public Property | ActiveControl | Gets or sets the active control on the container control. (Inherited from Gizmox.WebGUI.Forms.ContainerControl)
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Public Property | AutoSize | (Inherited from Gizmox.WebGUI.Forms.UserControl)
Public Property | AutoSizeMode | Indicates the automatic sizing behavior of the control. (Inherited from Gizmox.WebGUI.Forms.UserControl)
Public Property | BackColor | Gets or sets the background color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BindingContext | (Inherited from Gizmox.WebGUI.Forms.ContainerControl)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Checked | Gets or sets the checked collection.
Public Property | CheckLabel | Gets or sets the check label.
Public Property | ClientAction | Gets or sets the client action. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Components | (Inherited from Gizmox.WebGUI.Forms.ContainerControl)
Public Property | Container | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Context | Gets the context. (Inherited from Gizmox.WebGUI.Forms.UserControl)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | EnableItemMove | Gets or sets a value indicating whether to enable item move.
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Form | Gets the owner form. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | HasControls | Gets a value indicating whether this control has controls. (Inherited from Gizmox.WebGUI.Forms.UserControl)
Public Property | Height | Gets/Sets the height position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | IsRegistered | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Public Property | Items | Gets or sets the items collection.
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Left | Gets/Sets the left position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Location | Gets or sets the control location. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | MoveDownLabel | Gets or sets the move down label.
Public Property | MoveUpLabel | Gets or sets the moveup label.
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Right | Gets/Sets the right position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | SelectedItem | Gets the selected item.
Public Property | Site | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Top | Gets/Sets the top position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | UncheckLabel | Gets or sets the uncheck label.
Public Property | Visible | Gets or sets the control visability. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Width | Gets/Sets the width position (Inherited from Gizmox.WebGUI.Forms.Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultBorderColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultBorderStyle | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultForeColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMargin | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultPadding | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DesignMode | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | Events | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Protected Property | IsConnected | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Property | IsDelayedDrawing | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | Session | Gets the application object. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Top

Public Methods

 | Name | Description
Public Method | Add | (Inherited from Gizmox.WebGUI.Forms.ContainerControl)
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Gizmox.WebGUI.Forms.ContainerControl)
Public Method | Focus | Sets focus to this control (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | GetPreferredSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Remove | (Inherited from Gizmox.WebGUI.Forms.ContainerControl)
Public Method | ResetText | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Public Method | Select | Overloaded. Activates the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SendToBack | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Show | Displays the control to the user. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ToString | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Update | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Public Method | UpdateButtonsState | Updates the state of the buttons.
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | Finalize | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCommandText | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetImage | Gets the image. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetPreferredSizeCore | (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Protected Method | GetService | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | InvokeMethod | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | IsDirty | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBindingContextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnControlAdded | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnControlRemoved | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnCreateControl | Raises the CreateControl event. (Inherited from Gizmox.WebGUI.Forms.UserControl)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | OnEnabledChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnGotFocus | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLoad | Raises the Load event. (Inherited from Gizmox.WebGUI.Forms.UserControl)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLostFocus | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentVisibleChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnResize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnTextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnUnregisterComponents | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnValidated | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnValidating | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ProcessGatewayRequest | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RegisterSelf | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | Render | Renders the specified obj context. (Inherited from Gizmox.WebGUI.Forms.UserControl)
Protected Method | RenderAttributes | Renders the scrollable attribute (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderClientUpdateHandler | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderComponentEventAttributes | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetImage | Sets the image. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeText | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | UnRegisterBatch | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | UnRegisterSelf | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | UpdateParams | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Top

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Disposed | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ItemCheck | Occurs when an item is checked
Public Event | ItemSelected | Occurs when an item is selected
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Load | Occurs before the control becomes visible for the first time. (Inherited from Gizmox.WebGUI.Forms.UserControl)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Gizmox.WebGUI.Forms.Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Top

See Also

Reference

ItemChooser Class
Gizmox.WebGUI.Forms.Controls Namespace


ItemChooser Constructor

[image]
Gizmox.WebGUI.Forms
ItemChooser Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms.Controls Namespace > ItemChooser Class : ItemChooser Constructor

Creates a new ItemChooser instance.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ItemChooser()
C#
public ItemChooser()
Managed Extensions for C++
public: ItemChooser();
C++/CLI
public:
ItemChooser();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ItemChooser Class
ItemChooser Members


ItemChooser Class Methods

[image]
Gizmox.WebGUI.Forms
ItemChooser Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms.Controls Namespace : ItemChooser Class

For a list of all members of this type, see ItemChooser members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from Gizmox.WebGUI.Forms.ContainerControl)
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Gizmox.WebGUI.Forms.ContainerControl)
Public Method | Focus | Sets focus to this control (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | GetPreferredSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Remove | (Inherited from Gizmox.WebGUI.Forms.ContainerControl)
Public Method | ResetText | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Public Method | Select | Overloaded. Activates the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SendToBack | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Show | Displays the control to the user. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ToString | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Update | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Public Method | UpdateButtonsState | Updates the state of the buttons.
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | Finalize | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCommandText | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetImage | Gets the image. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetPreferredSizeCore | (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Protected Method | GetService | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | InvokeMethod | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | IsDirty | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBindingContextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnControlAdded | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnControlRemoved | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnCreateControl | Raises the CreateControl event. (Inherited from Gizmox.WebGUI.Forms.UserControl)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | OnEnabledChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnGotFocus | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLoad | Raises the Load event. (Inherited from Gizmox.WebGUI.Forms.UserControl)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLostFocus | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentVisibleChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnResize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnTextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnUnregisterComponents | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnValidated | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnValidating | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ProcessGatewayRequest | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RegisterSelf | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | Render | Renders the specified obj context. (Inherited from Gizmox.WebGUI.Forms.UserControl)
Protected Method | RenderAttributes | Renders the scrollable attribute (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderClientUpdateHandler | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderComponentEventAttributes | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetImage | Sets the image. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeText | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | UnRegisterBatch | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | UnRegisterSelf | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | UpdateParams | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Top

See Also

Reference

ItemChooser Class
Gizmox.WebGUI.Forms.Controls Namespace


UpdateButtonsState Method

[image]
Gizmox.WebGUI.Forms
UpdateButtonsState Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Controls Namespace > ItemChooser Class : UpdateButtonsState Method

Updates the state of the buttons.

Syntax

Visual Basic (Declaration)
Public Sub UpdateButtonsState()
Visual Basic (Usage) Copy Code
Dim instance As ItemChooser

instance.UpdateButtonsState()
C#
public void UpdateButtonsState()
Managed Extensions for C++
public: void UpdateButtonsState();
C++/CLI
public:
void UpdateButtonsState();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ItemChooser Class
ItemChooser Members


ItemChooser Class Properties

[image]
Gizmox.WebGUI.Forms
ItemChooser Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms.Controls Namespace : ItemChooser Class

For a list of all members of this type, see ItemChooser members.

Public Properties

 | Name | Description
Public Property | ActiveControl | Gets or sets the active control on the container control. (Inherited from Gizmox.WebGUI.Forms.ContainerControl)
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Public Property | AutoSize | (Inherited from Gizmox.WebGUI.Forms.UserControl)
Public Property | AutoSizeMode | Indicates the automatic sizing behavior of the control. (Inherited from Gizmox.WebGUI.Forms.UserControl)
Public Property | BackColor | Gets or sets the background color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BindingContext | (Inherited from Gizmox.WebGUI.Forms.ContainerControl)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Checked | Gets or sets the checked collection.
Public Property | CheckLabel | Gets or sets the check label.
Public Property | ClientAction | Gets or sets the client action. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Components | (Inherited from Gizmox.WebGUI.Forms.ContainerControl)
Public Property | Container | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Context | Gets the context. (Inherited from Gizmox.WebGUI.Forms.UserControl)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | EnableItemMove | Gets or sets a value indicating whether to enable item move.
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Form | Gets the owner form. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | HasControls | Gets a value indicating whether this control has controls. (Inherited from Gizmox.WebGUI.Forms.UserControl)
Public Property | Height | Gets/Sets the height position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | IsRegistered | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Public Property | Items | Gets or sets the items collection.
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Left | Gets/Sets the left position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Location | Gets or sets the control location. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | MoveDownLabel | Gets or sets the move down label.
Public Property | MoveUpLabel | Gets or sets the moveup label.
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Right | Gets/Sets the right position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | SelectedItem | Gets the selected item.
Public Property | Site | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Top | Gets/Sets the top position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | UncheckLabel | Gets or sets the uncheck label.
Public Property | Visible | Gets or sets the control visability. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Width | Gets/Sets the width position (Inherited from Gizmox.WebGUI.Forms.Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultBorderColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultBorderStyle | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultForeColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMargin | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultPadding | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DesignMode | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | Events | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Protected Property | IsConnected | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Property | IsDelayedDrawing | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | Session | Gets the application object. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Top

See Also

Reference

ItemChooser Class
Gizmox.WebGUI.Forms.Controls Namespace


Checked Property

[image]
Gizmox.WebGUI.Forms
Checked Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Controls Namespace > ItemChooser Class : Checked Property

Gets or sets the checked collection.

Syntax

Visual Basic (Declaration)
Public Property Checked As ICollection
Visual Basic (Usage) Copy Code
Dim instance As ItemChooser
Dim value As ICollection

instance.Checked = value

value = instance.Checked
C#
public ICollection Checked {get; set;}
Managed Extensions for C++
public: __property ICollection* get_Checked();
public: __property void set_Checked(
   ICollection* value
);
C++/CLI
public:
property ICollection^ Checked {
   ICollection^ get();
   void set (ICollection^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ItemChooser Class
ItemChooser Members


CheckLabel Property

[image]
Gizmox.WebGUI.Forms
CheckLabel Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Controls Namespace > ItemChooser Class : CheckLabel Property

Gets or sets the check label.

Syntax

Visual Basic (Declaration)
Public Property CheckLabel As String
Visual Basic (Usage) Copy Code
Dim instance As ItemChooser
Dim value As String

instance.CheckLabel = value

value = instance.CheckLabel
C#
public string CheckLabel {get; set;}
Managed Extensions for C++
public: __property string* get_CheckLabel();
public: __property void set_CheckLabel(
   string* value
);
C++/CLI
public:
property String^ CheckLabel {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ItemChooser Class
ItemChooser Members


EnableItemMove Property

[image]
Gizmox.WebGUI.Forms
EnableItemMove Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Controls Namespace > ItemChooser Class : EnableItemMove Property

Gets or sets a value indicating whether to enable item move.

Syntax

Visual Basic (Declaration)
Public Property EnableItemMove As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ItemChooser
Dim value As Boolean

instance.EnableItemMove = value

value = instance.EnableItemMove
C#
public bool EnableItemMove {get; set;}
Managed Extensions for C++
public: __property bool get_EnableItemMove();
public: __property void set_EnableItemMove(
   bool value
);
C++/CLI
public:
property bool EnableItemMove {
   bool get();
   void set (boolvalue);
}

Return Value

true if to enable item move; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ItemChooser Class
ItemChooser Members


Items Property

[image]
Gizmox.WebGUI.Forms
Items Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Controls Namespace > ItemChooser Class : Items Property

Gets or sets the items collection.

Syntax

Visual Basic (Declaration)
Public Property Items As ICollection
Visual Basic (Usage) Copy Code
Dim instance As ItemChooser
Dim value As ICollection

instance.Items = value

value = instance.Items
C#
public ICollection Items {get; set;}
Managed Extensions for C++
public: __property ICollection* get_Items();
public: __property void set_Items(
   ICollection* value
);
C++/CLI
public:
property ICollection^ Items {
   ICollection^ get();
   void set (ICollection^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ItemChooser Class
ItemChooser Members


MoveDownLabel Property

[image]
Gizmox.WebGUI.Forms
MoveDownLabel Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Controls Namespace > ItemChooser Class : MoveDownLabel Property

Gets or sets the move down label.

Syntax

Visual Basic (Declaration)
Public Property MoveDownLabel As String
Visual Basic (Usage) Copy Code
Dim instance As ItemChooser
Dim value As String

instance.MoveDownLabel = value

value = instance.MoveDownLabel
C#
public string MoveDownLabel {get; set;}
Managed Extensions for C++
public: __property string* get_MoveDownLabel();
public: __property void set_MoveDownLabel(
   string* value
);
C++/CLI
public:
property String^ MoveDownLabel {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ItemChooser Class
ItemChooser Members


MoveUpLabel Property

[image]
Gizmox.WebGUI.Forms
MoveUpLabel Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Controls Namespace > ItemChooser Class : MoveUpLabel Property

Gets or sets the moveup label.

Syntax

Visual Basic (Declaration)
Public Property MoveUpLabel As String
Visual Basic (Usage) Copy Code
Dim instance As ItemChooser
Dim value As String

instance.MoveUpLabel = value

value = instance.MoveUpLabel
C#
public string MoveUpLabel {get; set;}
Managed Extensions for C++
public: __property string* get_MoveUpLabel();
public: __property void set_MoveUpLabel(
   string* value
);
C++/CLI
public:
property String^ MoveUpLabel {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ItemChooser Class
ItemChooser Members


SelectedItem Property

[image]
Gizmox.WebGUI.Forms
SelectedItem Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Controls Namespace > ItemChooser Class : SelectedItem Property

Gets the selected item.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SelectedItem As Object
Visual Basic (Usage) Copy Code
Dim instance As ItemChooser
Dim value As Object

value = instance.SelectedItem
C#
public object SelectedItem {get;}
Managed Extensions for C++
public: __property Object* get_SelectedItem();
C++/CLI
public:
property Object^ SelectedItem {
   Object^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ItemChooser Class
ItemChooser Members


UncheckLabel Property

[image]
Gizmox.WebGUI.Forms
UncheckLabel Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Controls Namespace > ItemChooser Class : UncheckLabel Property

Gets or sets the uncheck label.

Syntax

Visual Basic (Declaration)
Public Property UncheckLabel As String
Visual Basic (Usage) Copy Code
Dim instance As ItemChooser
Dim value As String

instance.UncheckLabel = value

value = instance.UncheckLabel
C#
public string UncheckLabel {get; set;}
Managed Extensions for C++
public: __property string* get_UncheckLabel();
public: __property void set_UncheckLabel(
   string* value
);
C++/CLI
public:
property String^ UncheckLabel {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ItemChooser Class
ItemChooser Members


ItemChooser Class Events

[image]
Gizmox.WebGUI.Forms
ItemChooser Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms.Controls Namespace : ItemChooser Class

For a list of all members of this type, see ItemChooser members.

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Disposed | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ItemCheck | Occurs when an item is checked
Public Event | ItemSelected | Occurs when an item is selected
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Load | Occurs before the control becomes visible for the first time. (Inherited from Gizmox.WebGUI.Forms.UserControl)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Gizmox.WebGUI.Forms.Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Top

See Also

Reference

ItemChooser Class
Gizmox.WebGUI.Forms.Controls Namespace


ItemCheck Event

[image]
Gizmox.WebGUI.Forms
ItemCheck Event
See Also Send Feedback
Gizmox.WebGUI.Forms.Controls Namespace > ItemChooser Class : ItemCheck Event

Occurs when an item is checked

Syntax

Visual Basic (Declaration)
Public Event ItemCheck() As ItemCheckHandler
Visual Basic (Usage) Copy Code
Dim instance As ItemChooser
Dim handler As ItemCheckHandler

AddHandler instance.ItemCheck, handler
C#
public event ItemCheckHandler ItemCheck()
Managed Extensions for C++
public: __event ItemCheckHandler* ItemCheck
C++/CLI
public:
event ItemCheckHandler^ ItemCheck

Event Data

The event handler receives an argument of type ItemCheckEventArgs containing data related to this event. The following ItemCheckEventArgs properties provide information specific to this event.

Property | Description
CurrentValue | Gets the current value.
Index | Gets the index.
NewValue | Gets or sets the new value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ItemChooser Class
ItemChooser Members


ItemSelected Event

[image]
Gizmox.WebGUI.Forms
ItemSelected Event
See Also Send Feedback
Gizmox.WebGUI.Forms.Controls Namespace > ItemChooser Class : ItemSelected Event

Occurs when an item is selected

Syntax

Visual Basic (Declaration)
Public Event ItemSelected() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As ItemChooser
Dim handler As EventHandler

AddHandler instance.ItemSelected, handler
C#
public event EventHandler ItemSelected()
Managed Extensions for C++
public: __event EventHandler* ItemSelected
C++/CLI
public:
event EventHandler^ ItemSelected

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ItemChooser Class
ItemChooser Members


Gizmox.WebGUI.Forms.Design Namespace (Gizmox.WebGUI.Forms)

Gizmox.WebGUI.Forms.Design Namespace (Gizmox.WebGUI.Forms)
See Also Inheritance Hierarchy Send Feedback

Classes

 | Class | Description
Class | AnchorEditor | Provides a base class that can be used to design value editors that can provide a web user interface (Web UI) for representing and editing the values of objects of the supported data types.
Class | CollectionEditor | Provides a user interface that can edit most types of collections at design time.
Class | ColorEditor | Provides a base class that can be used to design value editors that can provide a web user interface (Web UI) for representing and editing the values of objects of the supported data types.
Class | DateTimeEditor | Provides a base class that can be used to design value editors that can provide a web user interface (Web UI) for representing and editing the values of objects of the supported data types.
Class | DockEditor | Provides a base class that can be used to design value editors that can provide a web user interface (Web UI) for representing and editing the values of objects of the supported data types.
Class | EventsTab | Provides a PropertyTab that can display events for selection and linking.
Class | FontEditor | Provides a base class that can be used to design value editors that can provide a web user interface (Web UI) for representing and editing the values of objects of the supported data types.
Class | PropertyTab | Provides a base class for property tabs.
Class | WebEditorAttribute | Specifies the editor to use to change a property. This class cannot be inherited.
Class | WebUITypeEditor | Provides a base class that can be used to design value editors that can provide a web user interface (Web UI) for representing and editing the values of objects of the supported data types.

Interfaces

 | Interface | Description
Interface | IWebUIEditorService | Provides an interface for a WebUITypeEditor to display Windows Forms or to display a control in a drop-down area from a property grid control in design mode.

Delegates

 | Delegate | Description
Delegate | WebUITypeEditorHandler |

See Also

Reference

Gizmox.WebGUI.Forms Assembly


AnchorEditor Class

[image]
Gizmox.WebGUI.Forms
AnchorEditor Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace : AnchorEditor Class

Provides a base class that can be used to design value editors that can provide a web user interface (Web UI) for representing and editing the values of objects of the supported data types.

Syntax

Visual Basic (Declaration)
Public Class AnchorEditor
   Inherits WebUITypeEditor
Visual Basic (Usage) Copy Code
Dim instance As AnchorEditor
C#
public class AnchorEditor : WebUITypeEditor
Managed Extensions for C++
public __gc class AnchorEditor : public WebUITypeEditor
C++/CLI
public ref class AnchorEditor : public WebUITypeEditor

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.Design.WebUITypeEditor
Gizmox.WebGUI.Forms.Design.AnchorEditor

Requirements

Namespace: Gizmox.WebGUI.Forms.Design

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

AnchorEditor Members
Gizmox.WebGUI.Forms.Design Namespace


AnchorEditor Class Members

[image]
Gizmox.WebGUI.Forms
AnchorEditor Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms.Design Namespace : AnchorEditor Class

The following tables list the members exposed by AnchorEditor.

Public Constructors

 | Name | Description
Public Constructor | AnchorEditor Constructor |
Top

Public Properties

 | Name | Description
Public Property | IsDropDownResizable | Gets a value indicating whether drop-down editors should be resizable by the user. (Inherited from WebUITypeEditor)
Public Property | IsTextEditable | Gets a value indicating whether this editor value should support text editing. (Inherited from WebUITypeEditor)
Top

Protected Properties

 | Name | Description
Protected Property | PropertyValue |
Top

Public Methods

 | Name | Description
Public Method | EditValue | Overloaded. Overridden. Edits the value of the specified object using the editor style indicated by the WebUITypeEditor.GetEditStyle method.
Public Method | GetEditStyle | Overloaded. Overridden. Gets the editor style used by the EditValue method.
Top

Protected Methods

 | Name | Description
Protected Method | GetEditorValueFromPropertyValue | Supplies a editor level mechanism to convert property values before editing (Inherited from WebUITypeEditor)
Protected Method | GetPropertyValueFromEditorValue | Supplies a editor level mechanism to convert editor returned values before assigning to property (Inherited from WebUITypeEditor)
Protected Method | OnValueChangeError | Raise error on value change (Inherited from WebUITypeEditor)
Protected Method | ValidatePropertyValue | Validated property value (Inherited from WebUITypeEditor)
Top

See Also

Reference

AnchorEditor Class
Gizmox.WebGUI.Forms.Design Namespace


AnchorEditor Constructor

[image]
Gizmox.WebGUI.Forms
AnchorEditor Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > AnchorEditor Class : AnchorEditor Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As AnchorEditor()
C#
public AnchorEditor()
Managed Extensions for C++
public: AnchorEditor();
C++/CLI
public:
AnchorEditor();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AnchorEditor Class
AnchorEditor Members


AnchorEditor Class Methods

[image]
Gizmox.WebGUI.Forms
AnchorEditor Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace : AnchorEditor Class

For a list of all members of this type, see AnchorEditor members.

Public Methods

 | Name | Description
Public Method | EditValue | Overloaded. Overridden. Edits the value of the specified object using the editor style indicated by the WebUITypeEditor.GetEditStyle method.
Public Method | GetEditStyle | Overloaded. Overridden. Gets the editor style used by the EditValue method.
Top

Protected Methods

 | Name | Description
Protected Method | GetEditorValueFromPropertyValue | Supplies a editor level mechanism to convert property values before editing (Inherited from WebUITypeEditor)
Protected Method | GetPropertyValueFromEditorValue | Supplies a editor level mechanism to convert editor returned values before assigning to property (Inherited from WebUITypeEditor)
Protected Method | OnValueChangeError | Raise error on value change (Inherited from WebUITypeEditor)
Protected Method | ValidatePropertyValue | Validated property value (Inherited from WebUITypeEditor)
Top

See Also

Reference

AnchorEditor Class
Gizmox.WebGUI.Forms.Design Namespace


EditValue Method

[image]
Gizmox.WebGUI.Forms
EditValue Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > AnchorEditor Class : EditValue Method

Edits the value of the specified object using the editor style indicated by the WebUITypeEditor.GetEditStyle method.

Overload List

Overload | Description
EditValue(ITypeDescriptorContext,IServiceProvider,Object,WebUITypeEditorHandler) |
EditValue(IServiceProvider,Object,WebUITypeEditorHandler) | Edits the value of the specified object using the editor style indicated by the WebUITypeEditor.GetEditStyle method. (Inherited from WebUITypeEditor)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AnchorEditor Class
AnchorEditor Members


EditValue(ITypeDescriptorContext,IServiceProvider,Object,WebUITypeEditorHandler) Method

[image]
Gizmox.WebGUI.Forms
EditValue(ITypeDescriptorContext,IServiceProvider,Object,WebUITypeEditorHandler) Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > AnchorEditor Class > EditValue Method : EditValue(ITypeDescriptorContext,IServiceProvider,Object,WebUITypeEditorHandler) Method

context
provider
value
objHandler

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Sub EditValue( _
   ByVal context As ITypeDescriptorContext, _
   ByVal provider As IServiceProvider, _
   ByVal value As Object, _
   ByVal objHandler As WebUITypeEditorHandler _
)
Visual Basic (Usage) Copy Code
Dim instance As AnchorEditor
Dim context As ITypeDescriptorContext
Dim provider As IServiceProvider
Dim value As Object
Dim objHandler As WebUITypeEditorHandler

instance.EditValue(context, provider, value, objHandler)
C#
public override void EditValue(
   ITypeDescriptorContext context,
   IServiceProvider provider,
   object value,
   WebUITypeEditorHandler objHandler
)
Managed Extensions for C++
public: void EditValue(
   ITypeDescriptorContext* context,
   IServiceProvider* provider,
   Object* value,
   WebUITypeEditorHandler* objHandler
) override
C++/CLI
public:
void EditValue(
   ITypeDescriptorContext^ context,
   IServiceProvider^ provider,
   Object^ value,
   WebUITypeEditorHandler^ objHandler
) override

Parameters

context
provider
value
objHandler

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AnchorEditor Class
AnchorEditor Members
Overload List


GetEditStyle Method

[image]
Gizmox.WebGUI.Forms
GetEditStyle Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > AnchorEditor Class : GetEditStyle Method

Gets the editor style used by the EditValue method.

Overload List

Overload | Description
GetEditStyle(ITypeDescriptorContext) |
GetEditStyle() | Gets the editor style used by the EditValue method. (Inherited from WebUITypeEditor)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AnchorEditor Class
AnchorEditor Members


GetEditStyle(ITypeDescriptorContext) Method

[image]
Gizmox.WebGUI.Forms
GetEditStyle(ITypeDescriptorContext) Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > AnchorEditor Class > GetEditStyle Method : GetEditStyle(ITypeDescriptorContext) Method

context

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function GetEditStyle( _
   ByVal context As ITypeDescriptorContext _
) As UITypeEditorEditStyle
Visual Basic (Usage) Copy Code
Dim instance As AnchorEditor
Dim context As ITypeDescriptorContext
Dim value As UITypeEditorEditStyle

value = instance.GetEditStyle(context)
C#
public override UITypeEditorEditStyle GetEditStyle(
   ITypeDescriptorContext context
)
Managed Extensions for C++
public: UITypeEditorEditStyle GetEditStyle(
   ITypeDescriptorContext* context
) override
C++/CLI
public:
UITypeEditorEditStyle GetEditStyle(
   ITypeDescriptorContext^ context
) override

Parameters

context

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AnchorEditor Class
AnchorEditor Members
Overload List


AnchorEditor Class Properties

[image]
Gizmox.WebGUI.Forms
AnchorEditor Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace : AnchorEditor Class

For a list of all members of this type, see AnchorEditor members.

Public Properties

 | Name | Description
Public Property | IsDropDownResizable | Gets a value indicating whether drop-down editors should be resizable by the user. (Inherited from WebUITypeEditor)
Public Property | IsTextEditable | Gets a value indicating whether this editor value should support text editing. (Inherited from WebUITypeEditor)
Top

Protected Properties

 | Name | Description
Protected Property | PropertyValue |
Top

See Also

Reference

AnchorEditor Class
Gizmox.WebGUI.Forms.Design Namespace


PropertyValue Property

[image]
Gizmox.WebGUI.Forms
PropertyValue Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > AnchorEditor Class : PropertyValue Property

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property PropertyValue As AnchorStyles
Visual Basic (Usage) Copy Code
Dim instance As AnchorEditor
Dim value As AnchorStyles

value = instance.PropertyValue
C#
protected AnchorStyles PropertyValue {get;}
Managed Extensions for C++
protected: __property AnchorStyles get_PropertyValue();
C++/CLI
protected:
property AnchorStyles PropertyValue {
   AnchorStyles get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AnchorEditor Class
AnchorEditor Members


CollectionEditor Class

[image]
Gizmox.WebGUI.Forms
CollectionEditor Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace : CollectionEditor Class

Provides a user interface that can edit most types of collections at design time.

Syntax

Visual Basic (Declaration)
Public Class CollectionEditor
   Inherits WebUITypeEditor
Visual Basic (Usage) Copy Code
Dim instance As CollectionEditor
C#
public class CollectionEditor : WebUITypeEditor
Managed Extensions for C++
public __gc class CollectionEditor : public WebUITypeEditor
C++/CLI
public ref class CollectionEditor : public WebUITypeEditor

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.Design.WebUITypeEditor
Gizmox.WebGUI.Forms.Design.CollectionEditor

Requirements

Namespace: Gizmox.WebGUI.Forms.Design

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

CollectionEditor Members
Gizmox.WebGUI.Forms.Design Namespace


CollectionEditor Class Members

[image]
Gizmox.WebGUI.Forms
CollectionEditor Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms.Design Namespace : CollectionEditor Class

The following tables list the members exposed by CollectionEditor.

Public Constructors

 | Name | Description
Public Constructor | CollectionEditor Constructor | Initializes a new instance of the CollectionEditor class using the specified collection type.
Top

Public Properties

 | Name | Description
Public Property | IsDropDownResizable | Gets a value indicating whether drop-down editors should be resizable by the user. (Inherited from WebUITypeEditor)
Public Property | IsTextEditable | Overridden.
Top

Protected Properties

 | Name | Description
Protected Property | CollectionItemType | Gets the data type of each item in the collection.
Protected Property | CollectionType | Gets the data type of the collection object.
Protected Property | Context | Gets a type descriptor that indicates the current context.
Protected Property | NewItemTypes | Gets the available types of items that can be created for this collection.
Top

Public Methods

 | Name | Description
Public Method | EditValue | Overloaded. Overridden. Edits the value of the specified object using the specified service provider and context.
Public Method | GetEditStyle | Overloaded. Overridden. Gets the edit style used by the EditValue method.
Top

Protected Methods

 | Name | Description
Protected Method | CancelChanges | Cancels changes to the collection.
Protected Method | CanRemoveInstance | Indicates whether original members of the collection can be removed.
Protected Method | CanSelectMultipleInstances | Indicates whether multiple collection items can be selected at once.
Protected Method | CreateCollectionForm | Creates a new form to display and edit the current collection.
Protected Method | CreateCollectionItemType | Gets the data type that this collection contains.
Protected Method | CreateInstance | Creates a new instance of the specified collection item type.
Protected Method | CreateNewItemTypes | Gets the data types that this collection editor can contain.
Protected Method | DestroyInstance | Destroys the specified instance of the object.
Protected Method | GetDisplayText | Retrieves the display text for the given list item.
Protected Method | GetEditorValueFromPropertyValue | Supplies a editor level mechanism to convert property values before editing (Inherited from WebUITypeEditor)
Protected Method | GetItems | Gets an array of objects containing the specified collection.
Protected Method | GetObjectsFromInstance | Returns a list containing the given object
Protected Method | GetPropertyValueFromEditorValue | Supplies a editor level mechanism to convert editor returned values before assigning to property (Inherited from WebUITypeEditor)
Protected Method | GetService | Gets the requested service, if it is available.
Protected Method | OnValueChangeError | Raise error on value change (Inherited from WebUITypeEditor)
Protected Method | SetItems | Sets the specified array as the items of the collection.
Protected Method | ShowHelp | Displays the default Help topic for the collection editor.
Protected Method | ValidatePropertyValue | Validated property value (Inherited from WebUITypeEditor)
Top

See Also

Reference

CollectionEditor Class
Gizmox.WebGUI.Forms.Design Namespace


CollectionEditor Constructor

[image]
Gizmox.WebGUI.Forms
CollectionEditor Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > CollectionEditor Class : CollectionEditor Constructor

type
The type of the collection for this editor to edit.
Initializes a new instance of the CollectionEditor class using the specified collection type.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal type As Type _
)
Visual Basic (Usage) Copy Code
Dim type As Type

Dim instance As CollectionEditor(type)
C#
public CollectionEditor(
   Type type
)
Managed Extensions for C++
public: CollectionEditor(
   Type* type
)
C++/CLI
public:
CollectionEditor(
   Type^ type
)

Parameters

type
The type of the collection for this editor to edit.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CollectionEditor Class
CollectionEditor Members


CollectionEditor Class Methods

[image]
Gizmox.WebGUI.Forms
CollectionEditor Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace : CollectionEditor Class

For a list of all members of this type, see CollectionEditor members.

Public Methods

 | Name | Description
Public Method | EditValue | Overloaded. Overridden. Edits the value of the specified object using the specified service provider and context.
Public Method | GetEditStyle | Overloaded. Overridden. Gets the edit style used by the EditValue method.
Top

Protected Methods

 | Name | Description
Protected Method | CancelChanges | Cancels changes to the collection.
Protected Method | CanRemoveInstance | Indicates whether original members of the collection can be removed.
Protected Method | CanSelectMultipleInstances | Indicates whether multiple collection items can be selected at once.
Protected Method | CreateCollectionForm | Creates a new form to display and edit the current collection.
Protected Method | CreateCollectionItemType | Gets the data type that this collection contains.
Protected Method | CreateInstance | Creates a new instance of the specified collection item type.
Protected Method | CreateNewItemTypes | Gets the data types that this collection editor can contain.
Protected Method | DestroyInstance | Destroys the specified instance of the object.
Protected Method | GetDisplayText | Retrieves the display text for the given list item.
Protected Method | GetEditorValueFromPropertyValue | Supplies a editor level mechanism to convert property values before editing (Inherited from WebUITypeEditor)
Protected Method | GetItems | Gets an array of objects containing the specified collection.
Protected Method | GetObjectsFromInstance | Returns a list containing the given object
Protected Method | GetPropertyValueFromEditorValue | Supplies a editor level mechanism to convert editor returned values before assigning to property (Inherited from WebUITypeEditor)
Protected Method | GetService | Gets the requested service, if it is available.
Protected Method | OnValueChangeError | Raise error on value change (Inherited from WebUITypeEditor)
Protected Method | SetItems | Sets the specified array as the items of the collection.
Protected Method | ShowHelp | Displays the default Help topic for the collection editor.
Protected Method | ValidatePropertyValue | Validated property value (Inherited from WebUITypeEditor)
Top

See Also

Reference

CollectionEditor Class
Gizmox.WebGUI.Forms.Design Namespace


CancelChanges Method

[image]
Gizmox.WebGUI.Forms
CancelChanges Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > CollectionEditor Class : CancelChanges Method

Cancels changes to the collection.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub CancelChanges()
Visual Basic (Usage) Copy Code
Dim instance As CollectionEditor

instance.CancelChanges()
C#
protected virtual void CancelChanges()
Managed Extensions for C++
protected: virtual void CancelChanges();
C++/CLI
protected:
virtual void CancelChanges();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CollectionEditor Class
CollectionEditor Members


CanRemoveInstance Method

[image]
Gizmox.WebGUI.Forms
CanRemoveInstance Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > CollectionEditor Class : CanRemoveInstance Method

value
The value to remove.
Indicates whether original members of the collection can be removed.

Syntax

Visual Basic (Declaration)
Protected Overridable Function CanRemoveInstance( _
   ByVal value As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As CollectionEditor
Dim value As Object
Dim value As Boolean

value = instance.CanRemoveInstance(value)
C#
protected virtual bool CanRemoveInstance(
   object value
)
Managed Extensions for C++
protected: virtual bool CanRemoveInstance(
   Object* value
)
C++/CLI
protected:
virtual bool CanRemoveInstance(
   Object^ value
)

Parameters

value
The value to remove.

Return Value

true if it is permissible to remove this value from the collection; otherwise, false. The default implementation always returns true.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CollectionEditor Class
CollectionEditor Members


CanSelectMultipleInstances Method

[image]
Gizmox.WebGUI.Forms
CanSelectMultipleInstances Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > CollectionEditor Class : CanSelectMultipleInstances Method

Indicates whether multiple collection items can be selected at once.

Syntax

Visual Basic (Declaration)
Protected Overridable Function CanSelectMultipleInstances() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As CollectionEditor
Dim value As Boolean

value = instance.CanSelectMultipleInstances()
C#
protected virtual bool CanSelectMultipleInstances()
Managed Extensions for C++
protected: virtual bool CanSelectMultipleInstances();
C++/CLI
protected:
virtual bool CanSelectMultipleInstances();

Return Value

true if it multiple collection members can be selected at the same time; otherwise, false. By default, this returns true.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CollectionEditor Class
CollectionEditor Members


CreateCollectionForm Method

[image]
Gizmox.WebGUI.Forms
CreateCollectionForm Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > CollectionEditor Class : CreateCollectionForm Method

Creates a new form to display and edit the current collection.

Syntax

Visual Basic (Declaration)
Protected Overridable Function CreateCollectionForm() As CollectionEditor.CollectionForm
Visual Basic (Usage) Copy Code
Dim instance As CollectionEditor
Dim value As CollectionEditor.CollectionForm

value = instance.CreateCollectionForm()
C#
protected virtual CollectionEditor.CollectionForm CreateCollectionForm()
Managed Extensions for C++
protected: virtual CollectionEditor.CollectionForm* CreateCollectionForm();
C++/CLI
protected:
virtual CollectionEditor::CollectionForm^ CreateCollectionForm();

Return Value

A CollectionForm to provide as the user interface for editing the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CollectionEditor Class
CollectionEditor Members


CreateCollectionItemType Method

[image]
Gizmox.WebGUI.Forms
CreateCollectionItemType Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > CollectionEditor Class : CreateCollectionItemType Method

Gets the data type that this collection contains.

Syntax

Visual Basic (Declaration)
Protected Overridable Function CreateCollectionItemType() As Type
Visual Basic (Usage) Copy Code
Dim instance As CollectionEditor
Dim value As Type

value = instance.CreateCollectionItemType()
C#
protected virtual Type CreateCollectionItemType()
Managed Extensions for C++
protected: virtual Type* CreateCollectionItemType();
C++/CLI
protected:
virtual Type^ CreateCollectionItemType();

Return Value

The data type of the items in the collection, or an Object if no Item property can be located on the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CollectionEditor Class
CollectionEditor Members


CreateInstance Method

[image]
Gizmox.WebGUI.Forms
CreateInstance Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > CollectionEditor Class : CreateInstance Method

itemType
The type of item to create.
Creates a new instance of the specified collection item type.

Syntax

Visual Basic (Declaration)
Protected Overridable Function CreateInstance( _
   ByVal itemType As Type _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As CollectionEditor
Dim itemType As Type
Dim value As Object

value = instance.CreateInstance(itemType)
C#
protected virtual object CreateInstance(
   Type itemType
)
Managed Extensions for C++
protected: virtual Object* CreateInstance(
   Type* itemType
)
C++/CLI
protected:
virtual Object^ CreateInstance(
   Type^ itemType
)

Parameters

itemType
The type of item to create.

Return Value

A new instance of the specified object.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CollectionEditor Class
CollectionEditor Members


CreateNewItemTypes Method

[image]
Gizmox.WebGUI.Forms
CreateNewItemTypes Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > CollectionEditor Class : CreateNewItemTypes Method

Gets the data types that this collection editor can contain.

Syntax

Visual Basic (Declaration)
Protected Overridable Function CreateNewItemTypes() As Type()
Visual Basic (Usage) Copy Code
Dim instance As CollectionEditor
Dim value() As Type

value = instance.CreateNewItemTypes()
C#
protected virtual Type[] CreateNewItemTypes()
Managed Extensions for C++
protected: virtual Type*[]* CreateNewItemTypes();
C++/CLI
protected:
virtual array<Type^>^ CreateNewItemTypes();

Return Value

An array of data types that this collection can contain.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CollectionEditor Class
CollectionEditor Members


DestroyInstance Method

[image]
Gizmox.WebGUI.Forms
DestroyInstance Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > CollectionEditor Class : DestroyInstance Method

instance
The object to destroy.
Destroys the specified instance of the object.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub DestroyInstance( _
   ByVal instance As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As CollectionEditor
Dim instance As Object

instance.DestroyInstance(instance)
C#
protected virtual void DestroyInstance(
   object instance
)
Managed Extensions for C++
protected: virtual void DestroyInstance(
   Object* instance
)
C++/CLI
protected:
virtual void DestroyInstance(
   Object^ instance
)

Parameters

instance
The object to destroy.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CollectionEditor Class
CollectionEditor Members


EditValue Method

[image]
Gizmox.WebGUI.Forms
EditValue Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > CollectionEditor Class : EditValue Method

Edits the value of the specified object using the specified service provider and context.

Overload List

Overload | Description
EditValue(ITypeDescriptorContext,IServiceProvider,Object,WebUITypeEditorHandler) | Edits the value of the specified object using the specified service provider and context.
EditValue(IServiceProvider,Object,WebUITypeEditorHandler) | Edits the value of the specified object using the editor style indicated by the WebUITypeEditor.GetEditStyle method. (Inherited from WebUITypeEditor)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CollectionEditor Class
CollectionEditor Members


EditValue(ITypeDescriptorContext,IServiceProvider,Object,WebUITypeEditorHandler) Method

[image]
Gizmox.WebGUI.Forms
EditValue(ITypeDescriptorContext,IServiceProvider,Object,WebUITypeEditorHandler) Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > CollectionEditor Class > EditValue Method : EditValue(ITypeDescriptorContext,IServiceProvider,Object,WebUITypeEditorHandler) Method

context
An ITypeDescriptorContext that can be used to gain additional context information.
provider
A service provider object through which editing services can be obtained.
value
The object to edit the value of.
objHandler
Edits the value of the specified object using the specified service provider and context.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Sub EditValue( _
   ByVal context As ITypeDescriptorContext, _
   ByVal provider As IServiceProvider, _
   ByVal value As Object, _
   ByVal objHandler As WebUITypeEditorHandler _
)
Visual Basic (Usage) Copy Code
Dim instance As CollectionEditor
Dim context As ITypeDescriptorContext
Dim provider As IServiceProvider
Dim value As Object
Dim objHandler As WebUITypeEditorHandler

instance.EditValue(context, provider, value, objHandler)
C#
public override void EditValue(
   ITypeDescriptorContext context,
   IServiceProvider provider,
   object value,
   WebUITypeEditorHandler objHandler
)
Managed Extensions for C++
public: void EditValue(
   ITypeDescriptorContext* context,
   IServiceProvider* provider,
   Object* value,
   WebUITypeEditorHandler* objHandler
) override
C++/CLI
public:
void EditValue(
   ITypeDescriptorContext^ context,
   IServiceProvider^ provider,
   Object^ value,
   WebUITypeEditorHandler^ objHandler
) override

Parameters

context
An ITypeDescriptorContext that can be used to gain additional context information.
provider
A service provider object through which editing services can be obtained.
value
The object to edit the value of.
objHandler

Return Value

The new value of the object. If the value of the object has not changed, this should return the same object it was passed.

Exceptions

Exception | Description
CheckoutException | An attempt to check out a file that is checked into a source code management program did not succeed.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CollectionEditor Class
CollectionEditor Members
Overload List


GetDisplayText Method

[image]
Gizmox.WebGUI.Forms
GetDisplayText Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > CollectionEditor Class : GetDisplayText Method

value
The list item for which to retrieve display text.
Retrieves the display text for the given list item.

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetDisplayText( _
   ByVal value As Object _
) As String
Visual Basic (Usage) Copy Code
Dim instance As CollectionEditor
Dim value As Object
Dim value As String

value = instance.GetDisplayText(value)
C#
protected virtual string GetDisplayText(
   object value
)
Managed Extensions for C++
protected: virtual string* GetDisplayText(
   Object* value
)
C++/CLI
protected:
virtual String^ GetDisplayText(
   Object^ value
)

Parameters

value
The list item for which to retrieve display text.

Return Value

The display text for value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CollectionEditor Class
CollectionEditor Members


GetEditStyle Method

[image]
Gizmox.WebGUI.Forms
GetEditStyle Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > CollectionEditor Class : GetEditStyle Method

Gets the edit style used by the EditValue method.

Overload List

Overload | Description
GetEditStyle(ITypeDescriptorContext) | Gets the edit style used by the EditValue method.
GetEditStyle() | Gets the editor style used by the EditValue method. (Inherited from WebUITypeEditor)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CollectionEditor Class
CollectionEditor Members


GetEditStyle(ITypeDescriptorContext) Method

[image]
Gizmox.WebGUI.Forms
GetEditStyle(ITypeDescriptorContext) Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > CollectionEditor Class > GetEditStyle Method : GetEditStyle(ITypeDescriptorContext) Method

context
An ITypeDescriptorContext that can be used to gain additional context information.
Gets the edit style used by the EditValue method.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function GetEditStyle( _
   ByVal context As ITypeDescriptorContext _
) As UITypeEditorEditStyle
Visual Basic (Usage) Copy Code
Dim instance As CollectionEditor
Dim context As ITypeDescriptorContext
Dim value As UITypeEditorEditStyle

value = instance.GetEditStyle(context)
C#
public override UITypeEditorEditStyle GetEditStyle(
   ITypeDescriptorContext context
)
Managed Extensions for C++
public: UITypeEditorEditStyle GetEditStyle(
   ITypeDescriptorContext* context
) override
C++/CLI
public:
UITypeEditorEditStyle GetEditStyle(
   ITypeDescriptorContext^ context
) override

Parameters

context
An ITypeDescriptorContext that can be used to gain additional context information.

Return Value

A UITypeEditorEditStyle enumeration value indicating the provided editing style. If the method is not supported in the specified context, this method will return the None identifier.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CollectionEditor Class
CollectionEditor Members
Overload List


GetItems Method

[image]
Gizmox.WebGUI.Forms
GetItems Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > CollectionEditor Class : GetItems Method

editValue
The collection to edit.
Gets an array of objects containing the specified collection.

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetItems( _
   ByVal editValue As Object _
) As Object()
Visual Basic (Usage) Copy Code
Dim instance As CollectionEditor
Dim editValue As Object
Dim value() As Object

value = instance.GetItems(editValue)
C#
protected virtual object[] GetItems(
   object editValue
)
Managed Extensions for C++
protected: virtual Object*[]* GetItems(
   Object* editValue
)
C++/CLI
protected:
virtual array<Object^>^ GetItems(
   Object^ editValue
)

Parameters

editValue
The collection to edit.

Return Value

An array containing the collection objects, or an empty object array if the specified collection does not inherit from ICollection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CollectionEditor Class
CollectionEditor Members


GetObjectsFromInstance Method

[image]
Gizmox.WebGUI.Forms
GetObjectsFromInstance Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > CollectionEditor Class : GetObjectsFromInstance Method

instance
An ArrayList returned as an object.
Returns a list containing the given object

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetObjectsFromInstance( _
   ByVal instance As Object _
) As IList
Visual Basic (Usage) Copy Code
Dim instance As CollectionEditor
Dim instance As Object
Dim value As IList

value = instance.GetObjectsFromInstance(instance)
C#
protected virtual IList GetObjectsFromInstance(
   object instance
)
Managed Extensions for C++
protected: virtual IList* GetObjectsFromInstance(
   Object* instance
)
C++/CLI
protected:
virtual IList^ GetObjectsFromInstance(
   Object^ instance
)

Parameters

instance
An ArrayList returned as an object.

Return Value

An ArrayList which contains the individual objects to be created.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CollectionEditor Class
CollectionEditor Members


GetService Method

[image]
Gizmox.WebGUI.Forms
GetService Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > CollectionEditor Class : GetService Method

serviceType
The type of service to retrieve.
Gets the requested service, if it is available.

Syntax

Visual Basic (Declaration)
Protected Function GetService( _
   ByVal serviceType As Type _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As CollectionEditor
Dim serviceType As Type
Dim value As Object

value = instance.GetService(serviceType)
C#
protected object GetService(
   Type serviceType
)
Managed Extensions for C++
protected: Object* GetService(
   Type* serviceType
)
C++/CLI
protected:
Object^ GetService(
   Type^ serviceType
)

Parameters

serviceType
The type of service to retrieve.

Return Value

An instance of the service, or null if the service cannot be found.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CollectionEditor Class
CollectionEditor Members


SetItems Method

[image]
Gizmox.WebGUI.Forms
SetItems Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > CollectionEditor Class : SetItems Method

editValue
The collection to edit.
value
An array of objects to set as the collection items.
Sets the specified array as the items of the collection.

Syntax

Visual Basic (Declaration)
Protected Overridable Function SetItems( _
   ByVal editValue As Object, _
   ByVal value() As Object _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As CollectionEditor
Dim editValue As Object
Dim value() As Object
Dim value As Object

value = instance.SetItems(editValue, value)
C#
protected virtual object SetItems(
   object editValue,
   object[] value
)
Managed Extensions for C++
protected: virtual Object* SetItems(
   Object* editValue,
   Object*[]* value
)
C++/CLI
protected:
virtual Object^ SetItems(
   Object^ editValue,
   array<Object^>^ value
)

Parameters

editValue
The collection to edit.
value
An array of objects to set as the collection items.

Return Value

The newly created collection object or, otherwise, the collection indicated by the editValue parameter.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CollectionEditor Class
CollectionEditor Members


ShowHelp Method

[image]
Gizmox.WebGUI.Forms
ShowHelp Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > CollectionEditor Class : ShowHelp Method

Displays the default Help topic for the collection editor.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ShowHelp()
Visual Basic (Usage) Copy Code
Dim instance As CollectionEditor

instance.ShowHelp()
C#
protected virtual void ShowHelp()
Managed Extensions for C++
protected: virtual void ShowHelp();
C++/CLI
protected:
virtual void ShowHelp();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CollectionEditor Class
CollectionEditor Members


CollectionEditor Class Properties

[image]
Gizmox.WebGUI.Forms
CollectionEditor Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace : CollectionEditor Class

For a list of all members of this type, see CollectionEditor members.

Public Properties

 | Name | Description
Public Property | IsDropDownResizable | Gets a value indicating whether drop-down editors should be resizable by the user. (Inherited from WebUITypeEditor)
Public Property | IsTextEditable | Overridden.
Top

Protected Properties

 | Name | Description
Protected Property | CollectionItemType | Gets the data type of each item in the collection.
Protected Property | CollectionType | Gets the data type of the collection object.
Protected Property | Context | Gets a type descriptor that indicates the current context.
Protected Property | NewItemTypes | Gets the available types of items that can be created for this collection.
Top

See Also

Reference

CollectionEditor Class
Gizmox.WebGUI.Forms.Design Namespace


CollectionItemType Property

[image]
Gizmox.WebGUI.Forms
CollectionItemType Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > CollectionEditor Class : CollectionItemType Property

Gets the data type of each item in the collection.

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property CollectionItemType As Type
Visual Basic (Usage) Copy Code
Dim instance As CollectionEditor
Dim value As Type

value = instance.CollectionItemType
C#
protected Type CollectionItemType {get;}
Managed Extensions for C++
protected: __property Type* get_CollectionItemType();
C++/CLI
protected:
property Type^ CollectionItemType {
   Type^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CollectionEditor Class
CollectionEditor Members


CollectionType Property

[image]
Gizmox.WebGUI.Forms
CollectionType Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > CollectionEditor Class : CollectionType Property

Gets the data type of the collection object.

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property CollectionType As Type
Visual Basic (Usage) Copy Code
Dim instance As CollectionEditor
Dim value As Type

value = instance.CollectionType
C#
protected Type CollectionType {get;}
Managed Extensions for C++
protected: __property Type* get_CollectionType();
C++/CLI
protected:
property Type^ CollectionType {
   Type^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CollectionEditor Class
CollectionEditor Members


Context Property

[image]
Gizmox.WebGUI.Forms
Context Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > CollectionEditor Class : Context Property

Gets a type descriptor that indicates the current context.

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property Context As ITypeDescriptorContext
Visual Basic (Usage) Copy Code
Dim instance As CollectionEditor
Dim value As ITypeDescriptorContext

value = instance.Context
C#
protected ITypeDescriptorContext Context {get;}
Managed Extensions for C++
protected: __property ITypeDescriptorContext* get_Context();
C++/CLI
protected:
property ITypeDescriptorContext^ Context {
   ITypeDescriptorContext^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CollectionEditor Class
CollectionEditor Members


IsTextEditable Property

[image]
Gizmox.WebGUI.Forms
IsTextEditable Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > CollectionEditor Class : IsTextEditable Property

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property IsTextEditable As Boolean
Visual Basic (Usage) Copy Code
Dim instance As CollectionEditor
Dim value As Boolean

value = instance.IsTextEditable
C#
public override bool IsTextEditable {get;}
Managed Extensions for C++
public: __property bool get_IsTextEditable() override;
C++/CLI
public:
property bool IsTextEditable {
   bool get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CollectionEditor Class
CollectionEditor Members


NewItemTypes Property

[image]
Gizmox.WebGUI.Forms
NewItemTypes Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > CollectionEditor Class : NewItemTypes Property

Gets the available types of items that can be created for this collection.

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property NewItemTypes As Type()
Visual Basic (Usage) Copy Code
Dim instance As CollectionEditor
Dim value() As Type

value = instance.NewItemTypes
C#
protected Type[] NewItemTypes {get;}
Managed Extensions for C++
protected: __property Type*[]* get_NewItemTypes();
C++/CLI
protected:
property array<Type^>^ NewItemTypes {
   array<Type^>^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CollectionEditor Class
CollectionEditor Members


ColorEditor Class

[image]
Gizmox.WebGUI.Forms
ColorEditor Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace : ColorEditor Class

Provides a base class that can be used to design value editors that can provide a web user interface (Web UI) for representing and editing the values of objects of the supported data types.

Syntax

Visual Basic (Declaration)
Public Class ColorEditor
   Inherits WebUITypeEditor
Visual Basic (Usage) Copy Code
Dim instance As ColorEditor
C#
public class ColorEditor : WebUITypeEditor
Managed Extensions for C++
public __gc class ColorEditor : public WebUITypeEditor
C++/CLI
public ref class ColorEditor : public WebUITypeEditor

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.Design.WebUITypeEditor
Gizmox.WebGUI.Forms.Design.ColorEditor

Requirements

Namespace: Gizmox.WebGUI.Forms.Design

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

ColorEditor Members
Gizmox.WebGUI.Forms.Design Namespace


ColorEditor Class Members

[image]
Gizmox.WebGUI.Forms
ColorEditor Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms.Design Namespace : ColorEditor Class

The following tables list the members exposed by ColorEditor.

Public Constructors

 | Name | Description
Public Constructor | ColorEditor Constructor |
Top

Public Properties

 | Name | Description
Public Property | IsDropDownResizable | Gets a value indicating whether drop-down editors should be resizable by the user. (Inherited from WebUITypeEditor)
Public Property | IsTextEditable | Gets a value indicating whether this editor value should support text editing. (Inherited from WebUITypeEditor)
Top

Protected Properties

 | Name | Description
Protected Property | PropertyValue |
Top

Public Methods

 | Name | Description
Public Method | EditValue | Overloaded. Overridden. Edits the value of the specified object using the editor style indicated by the WebUITypeEditor.GetEditStyle method.
Public Method | GetEditStyle | Overloaded. Overridden. Gets the editor style used by the EditValue method.
Top

Protected Methods

 | Name | Description
Protected Method | GetEditorValueFromPropertyValue | Overridden.
Protected Method | GetPropertyValueFromEditorValue | Overridden.
Protected Method | OnValueChangeError | Raise error on value change (Inherited from WebUITypeEditor)
Protected Method | ValidatePropertyValue | Validated property value (Inherited from WebUITypeEditor)
Top

See Also

Reference

ColorEditor Class
Gizmox.WebGUI.Forms.Design Namespace


ColorEditor Constructor

[image]
Gizmox.WebGUI.Forms
ColorEditor Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > ColorEditor Class : ColorEditor Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ColorEditor()
C#
public ColorEditor()
Managed Extensions for C++
public: ColorEditor();
C++/CLI
public:
ColorEditor();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ColorEditor Class
ColorEditor Members


ColorEditor Class Methods

[image]
Gizmox.WebGUI.Forms
ColorEditor Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace : ColorEditor Class

For a list of all members of this type, see ColorEditor members.

Public Methods

 | Name | Description
Public Method | EditValue | Overloaded. Overridden. Edits the value of the specified object using the editor style indicated by the WebUITypeEditor.GetEditStyle method.
Public Method | GetEditStyle | Overloaded. Overridden. Gets the editor style used by the EditValue method.
Top

Protected Methods

 | Name | Description
Protected Method | GetEditorValueFromPropertyValue | Overridden.
Protected Method | GetPropertyValueFromEditorValue | Overridden.
Protected Method | OnValueChangeError | Raise error on value change (Inherited from WebUITypeEditor)
Protected Method | ValidatePropertyValue | Validated property value (Inherited from WebUITypeEditor)
Top

See Also

Reference

ColorEditor Class
Gizmox.WebGUI.Forms.Design Namespace


EditValue Method

[image]
Gizmox.WebGUI.Forms
EditValue Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > ColorEditor Class : EditValue Method

Edits the value of the specified object using the editor style indicated by the WebUITypeEditor.GetEditStyle method.

Overload List

Overload | Description
EditValue(ITypeDescriptorContext,IServiceProvider,Object,WebUITypeEditorHandler) |
EditValue(IServiceProvider,Object,WebUITypeEditorHandler) | Edits the value of the specified object using the editor style indicated by the WebUITypeEditor.GetEditStyle method. (Inherited from WebUITypeEditor)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ColorEditor Class
ColorEditor Members


EditValue(ITypeDescriptorContext,IServiceProvider,Object,WebUITypeEditorHandler) Method

[image]
Gizmox.WebGUI.Forms
EditValue(ITypeDescriptorContext,IServiceProvider,Object,WebUITypeEditorHandler) Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > ColorEditor Class > EditValue Method : EditValue(ITypeDescriptorContext,IServiceProvider,Object,WebUITypeEditorHandler) Method

context
provider
value
objHandler

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Sub EditValue( _
   ByVal context As ITypeDescriptorContext, _
   ByVal provider As IServiceProvider, _
   ByVal value As Object, _
   ByVal objHandler As WebUITypeEditorHandler _
)
Visual Basic (Usage) Copy Code
Dim instance As ColorEditor
Dim context As ITypeDescriptorContext
Dim provider As IServiceProvider
Dim value As Object
Dim objHandler As WebUITypeEditorHandler

instance.EditValue(context, provider, value, objHandler)
C#
public override void EditValue(
   ITypeDescriptorContext context,
   IServiceProvider provider,
   object value,
   WebUITypeEditorHandler objHandler
)
Managed Extensions for C++
public: void EditValue(
   ITypeDescriptorContext* context,
   IServiceProvider* provider,
   Object* value,
   WebUITypeEditorHandler* objHandler
) override
C++/CLI
public:
void EditValue(
   ITypeDescriptorContext^ context,
   IServiceProvider^ provider,
   Object^ value,
   WebUITypeEditorHandler^ objHandler
) override

Parameters

context
provider
value
objHandler

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ColorEditor Class
ColorEditor Members
Overload List


GetEditorValueFromPropertyValue Method

[image]
Gizmox.WebGUI.Forms
GetEditorValueFromPropertyValue Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > ColorEditor Class : GetEditorValueFromPropertyValue Method

value

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetEditorValueFromPropertyValue( _
   ByVal value As Object _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As ColorEditor
Dim value As Object
Dim value As Object

value = instance.GetEditorValueFromPropertyValue(value)
C#
protected override object GetEditorValueFromPropertyValue(
   object value
)
Managed Extensions for C++
protected: Object* GetEditorValueFromPropertyValue(
   Object* value
) override
C++/CLI
protected:
Object^ GetEditorValueFromPropertyValue(
   Object^ value
) override

Parameters

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ColorEditor Class
ColorEditor Members


GetEditStyle Method

[image]
Gizmox.WebGUI.Forms
GetEditStyle Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > ColorEditor Class : GetEditStyle Method

Gets the editor style used by the EditValue method.

Overload List

Overload | Description
GetEditStyle(ITypeDescriptorContext) |
GetEditStyle() | Gets the editor style used by the EditValue method. (Inherited from WebUITypeEditor)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ColorEditor Class
ColorEditor Members


GetEditStyle(ITypeDescriptorContext) Method

[image]
Gizmox.WebGUI.Forms
GetEditStyle(ITypeDescriptorContext) Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > ColorEditor Class > GetEditStyle Method : GetEditStyle(ITypeDescriptorContext) Method

context

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function GetEditStyle( _
   ByVal context As ITypeDescriptorContext _
) As UITypeEditorEditStyle
Visual Basic (Usage) Copy Code
Dim instance As ColorEditor
Dim context As ITypeDescriptorContext
Dim value As UITypeEditorEditStyle

value = instance.GetEditStyle(context)
C#
public override UITypeEditorEditStyle GetEditStyle(
   ITypeDescriptorContext context
)
Managed Extensions for C++
public: UITypeEditorEditStyle GetEditStyle(
   ITypeDescriptorContext* context
) override
C++/CLI
public:
UITypeEditorEditStyle GetEditStyle(
   ITypeDescriptorContext^ context
) override

Parameters

context

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ColorEditor Class
ColorEditor Members
Overload List


GetPropertyValueFromEditorValue Method

[image]
Gizmox.WebGUI.Forms
GetPropertyValueFromEditorValue Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > ColorEditor Class : GetPropertyValueFromEditorValue Method

value

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetPropertyValueFromEditorValue( _
   ByVal value As Object _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As ColorEditor
Dim value As Object
Dim value As Object

value = instance.GetPropertyValueFromEditorValue(value)
C#
protected override object GetPropertyValueFromEditorValue(
   object value
)
Managed Extensions for C++
protected: Object* GetPropertyValueFromEditorValue(
   Object* value
) override
C++/CLI
protected:
Object^ GetPropertyValueFromEditorValue(
   Object^ value
) override

Parameters

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ColorEditor Class
ColorEditor Members


ColorEditor Class Properties

[image]
Gizmox.WebGUI.Forms
ColorEditor Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace : ColorEditor Class

For a list of all members of this type, see ColorEditor members.

Public Properties

 | Name | Description
Public Property | IsDropDownResizable | Gets a value indicating whether drop-down editors should be resizable by the user. (Inherited from WebUITypeEditor)
Public Property | IsTextEditable | Gets a value indicating whether this editor value should support text editing. (Inherited from WebUITypeEditor)
Top

Protected Properties

 | Name | Description
Protected Property | PropertyValue |
Top

See Also

Reference

ColorEditor Class
Gizmox.WebGUI.Forms.Design Namespace


PropertyValue Property

[image]
Gizmox.WebGUI.Forms
PropertyValue Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > ColorEditor Class : PropertyValue Property

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property PropertyValue As Color
Visual Basic (Usage) Copy Code
Dim instance As ColorEditor
Dim value As Color

value = instance.PropertyValue
C#
protected Color PropertyValue {get;}
Managed Extensions for C++
protected: __property Color get_PropertyValue();
C++/CLI
protected:
property Color PropertyValue {
   Color get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ColorEditor Class
ColorEditor Members


DateTimeEditor Class

[image]
Gizmox.WebGUI.Forms
DateTimeEditor Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace : DateTimeEditor Class

Provides a base class that can be used to design value editors that can provide a web user interface (Web UI) for representing and editing the values of objects of the supported data types.

Syntax

Visual Basic (Declaration)
Public Class DateTimeEditor
   Inherits WebUITypeEditor
Visual Basic (Usage) Copy Code
Dim instance As DateTimeEditor
C#
public class DateTimeEditor : WebUITypeEditor
Managed Extensions for C++
public __gc class DateTimeEditor : public WebUITypeEditor
C++/CLI
public ref class DateTimeEditor : public WebUITypeEditor

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.Design.WebUITypeEditor
Gizmox.WebGUI.Forms.Design.DateTimeEditor

Requirements

Namespace: Gizmox.WebGUI.Forms.Design

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

DateTimeEditor Members
Gizmox.WebGUI.Forms.Design Namespace


DateTimeEditor Class Members

[image]
Gizmox.WebGUI.Forms
DateTimeEditor Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms.Design Namespace : DateTimeEditor Class

The following tables list the members exposed by DateTimeEditor.

Public Constructors

 | Name | Description
Public Constructor | DateTimeEditor Constructor |
Top

Public Properties

 | Name | Description
Public Property | IsDropDownResizable | Gets a value indicating whether drop-down editors should be resizable by the user. (Inherited from WebUITypeEditor)
Public Property | IsTextEditable | Gets a value indicating whether this editor value should support text editing. (Inherited from WebUITypeEditor)
Top

Public Methods

 | Name | Description
Public Method | EditValue | Overloaded. Overridden. Edits the value of the specified object using the editor style indicated by the WebUITypeEditor.GetEditStyle method.
Public Method | GetEditStyle | Overloaded. Overridden. Gets the editor style used by the EditValue method.
Top

Protected Methods

 | Name | Description
Protected Method | GetEditorValueFromPropertyValue | Supplies a editor level mechanism to convert property values before editing (Inherited from WebUITypeEditor)
Protected Method | GetPropertyValueFromEditorValue | Supplies a editor level mechanism to convert editor returned values before assigning to property (Inherited from WebUITypeEditor)
Protected Method | OnValueChangeError | Raise error on value change (Inherited from WebUITypeEditor)
Protected Method | ValidatePropertyValue | Validated property value (Inherited from WebUITypeEditor)
Top

See Also

Reference

DateTimeEditor Class
Gizmox.WebGUI.Forms.Design Namespace


DateTimeEditor Constructor

[image]
Gizmox.WebGUI.Forms
DateTimeEditor Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > DateTimeEditor Class : DateTimeEditor Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As DateTimeEditor()
C#
public DateTimeEditor()
Managed Extensions for C++
public: DateTimeEditor();
C++/CLI
public:
DateTimeEditor();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DateTimeEditor Class
DateTimeEditor Members


DateTimeEditor Class Methods

[image]
Gizmox.WebGUI.Forms
DateTimeEditor Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace : DateTimeEditor Class

For a list of all members of this type, see DateTimeEditor members.

Public Methods

 | Name | Description
Public Method | EditValue | Overloaded. Overridden. Edits the value of the specified object using the editor style indicated by the WebUITypeEditor.GetEditStyle method.
Public Method | GetEditStyle | Overloaded. Overridden. Gets the editor style used by the EditValue method.
Top

Protected Methods

 | Name | Description
Protected Method | GetEditorValueFromPropertyValue | Supplies a editor level mechanism to convert property values before editing (Inherited from WebUITypeEditor)
Protected Method | GetPropertyValueFromEditorValue | Supplies a editor level mechanism to convert editor returned values before assigning to property (Inherited from WebUITypeEditor)
Protected Method | OnValueChangeError | Raise error on value change (Inherited from WebUITypeEditor)
Protected Method | ValidatePropertyValue | Validated property value (Inherited from WebUITypeEditor)
Top

See Also

Reference

DateTimeEditor Class
Gizmox.WebGUI.Forms.Design Namespace


EditValue Method

[image]
Gizmox.WebGUI.Forms
EditValue Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > DateTimeEditor Class : EditValue Method

Edits the value of the specified object using the editor style indicated by the WebUITypeEditor.GetEditStyle method.

Overload List

Overload | Description
EditValue(ITypeDescriptorContext,IServiceProvider,Object,WebUITypeEditorHandler) |
EditValue(IServiceProvider,Object,WebUITypeEditorHandler) | Edits the value of the specified object using the editor style indicated by the WebUITypeEditor.GetEditStyle method. (Inherited from WebUITypeEditor)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DateTimeEditor Class
DateTimeEditor Members


EditValue(ITypeDescriptorContext,IServiceProvider,Object,WebUITypeEditorHandler) Method

[image]
Gizmox.WebGUI.Forms
EditValue(ITypeDescriptorContext,IServiceProvider,Object,WebUITypeEditorHandler) Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > DateTimeEditor Class > EditValue Method : EditValue(ITypeDescriptorContext,IServiceProvider,Object,WebUITypeEditorHandler) Method

context
provider
value
objHandler

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Sub EditValue( _
   ByVal context As ITypeDescriptorContext, _
   ByVal provider As IServiceProvider, _
   ByVal value As Object, _
   ByVal objHandler As WebUITypeEditorHandler _
)
Visual Basic (Usage) Copy Code
Dim instance As DateTimeEditor
Dim context As ITypeDescriptorContext
Dim provider As IServiceProvider
Dim value As Object
Dim objHandler As WebUITypeEditorHandler

instance.EditValue(context, provider, value, objHandler)
C#
public override void EditValue(
   ITypeDescriptorContext context,
   IServiceProvider provider,
   object value,
   WebUITypeEditorHandler objHandler
)
Managed Extensions for C++
public: void EditValue(
   ITypeDescriptorContext* context,
   IServiceProvider* provider,
   Object* value,
   WebUITypeEditorHandler* objHandler
) override
C++/CLI
public:
void EditValue(
   ITypeDescriptorContext^ context,
   IServiceProvider^ provider,
   Object^ value,
   WebUITypeEditorHandler^ objHandler
) override

Parameters

context
provider
value
objHandler

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DateTimeEditor Class
DateTimeEditor Members
Overload List


GetEditStyle Method

[image]
Gizmox.WebGUI.Forms
GetEditStyle Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > DateTimeEditor Class : GetEditStyle Method

Gets the editor style used by the EditValue method.

Overload List

Overload | Description
GetEditStyle(ITypeDescriptorContext) |
GetEditStyle() | Gets the editor style used by the EditValue method. (Inherited from WebUITypeEditor)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DateTimeEditor Class
DateTimeEditor Members


GetEditStyle(ITypeDescriptorContext) Method

[image]
Gizmox.WebGUI.Forms
GetEditStyle(ITypeDescriptorContext) Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > DateTimeEditor Class > GetEditStyle Method : GetEditStyle(ITypeDescriptorContext) Method

context

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function GetEditStyle( _
   ByVal context As ITypeDescriptorContext _
) As UITypeEditorEditStyle
Visual Basic (Usage) Copy Code
Dim instance As DateTimeEditor
Dim context As ITypeDescriptorContext
Dim value As UITypeEditorEditStyle

value = instance.GetEditStyle(context)
C#
public override UITypeEditorEditStyle GetEditStyle(
   ITypeDescriptorContext context
)
Managed Extensions for C++
public: UITypeEditorEditStyle GetEditStyle(
   ITypeDescriptorContext* context
) override
C++/CLI
public:
UITypeEditorEditStyle GetEditStyle(
   ITypeDescriptorContext^ context
) override

Parameters

context

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DateTimeEditor Class
DateTimeEditor Members
Overload List


DockEditor Class

[image]
Gizmox.WebGUI.Forms
DockEditor Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace : DockEditor Class

Provides a base class that can be used to design value editors that can provide a web user interface (Web UI) for representing and editing the values of objects of the supported data types.

Syntax

Visual Basic (Declaration)
Public Class DockEditor
   Inherits WebUITypeEditor
Visual Basic (Usage) Copy Code
Dim instance As DockEditor
C#
public class DockEditor : WebUITypeEditor
Managed Extensions for C++
public __gc class DockEditor : public WebUITypeEditor
C++/CLI
public ref class DockEditor : public WebUITypeEditor

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.Design.WebUITypeEditor
Gizmox.WebGUI.Forms.Design.DockEditor

Requirements

Namespace: Gizmox.WebGUI.Forms.Design

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

DockEditor Members
Gizmox.WebGUI.Forms.Design Namespace


DockEditor Class Members

[image]
Gizmox.WebGUI.Forms
DockEditor Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms.Design Namespace : DockEditor Class

The following tables list the members exposed by DockEditor.

Public Constructors

 | Name | Description
Public Constructor | DockEditor Constructor |
Top

Public Properties

 | Name | Description
Public Property | IsDropDownResizable | Gets a value indicating whether drop-down editors should be resizable by the user. (Inherited from WebUITypeEditor)
Public Property | IsTextEditable | Gets a value indicating whether this editor value should support text editing. (Inherited from WebUITypeEditor)
Top

Protected Properties

 | Name | Description
Protected Property | PropertyValue |
Top

Public Methods

 | Name | Description
Public Method | EditValue | Overloaded. Overridden. Edits the value of the specified object using the editor style indicated by the WebUITypeEditor.GetEditStyle method.
Public Method | GetEditStyle | Overloaded. Overridden. Gets the editor style used by the EditValue method.
Top

Protected Methods

 | Name | Description
Protected Method | GetEditorValueFromPropertyValue | Supplies a editor level mechanism to convert property values before editing (Inherited from WebUITypeEditor)
Protected Method | GetPropertyValueFromEditorValue | Supplies a editor level mechanism to convert editor returned values before assigning to property (Inherited from WebUITypeEditor)
Protected Method | OnValueChangeError | Raise error on value change (Inherited from WebUITypeEditor)
Protected Method | ValidatePropertyValue | Validated property value (Inherited from WebUITypeEditor)
Top

See Also

Reference

DockEditor Class
Gizmox.WebGUI.Forms.Design Namespace


DockEditor Constructor

[image]
Gizmox.WebGUI.Forms
DockEditor Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > DockEditor Class : DockEditor Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As DockEditor()
C#
public DockEditor()
Managed Extensions for C++
public: DockEditor();
C++/CLI
public:
DockEditor();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DockEditor Class
DockEditor Members


DockEditor Class Methods

[image]
Gizmox.WebGUI.Forms
DockEditor Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace : DockEditor Class

For a list of all members of this type, see DockEditor members.

Public Methods

 | Name | Description
Public Method | EditValue | Overloaded. Overridden. Edits the value of the specified object using the editor style indicated by the WebUITypeEditor.GetEditStyle method.
Public Method | GetEditStyle | Overloaded. Overridden. Gets the editor style used by the EditValue method.
Top

Protected Methods

 | Name | Description
Protected Method | GetEditorValueFromPropertyValue | Supplies a editor level mechanism to convert property values before editing (Inherited from WebUITypeEditor)
Protected Method | GetPropertyValueFromEditorValue | Supplies a editor level mechanism to convert editor returned values before assigning to property (Inherited from WebUITypeEditor)
Protected Method | OnValueChangeError | Raise error on value change (Inherited from WebUITypeEditor)
Protected Method | ValidatePropertyValue | Validated property value (Inherited from WebUITypeEditor)
Top

See Also

Reference

DockEditor Class
Gizmox.WebGUI.Forms.Design Namespace


EditValue Method

[image]
Gizmox.WebGUI.Forms
EditValue Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > DockEditor Class : EditValue Method

Edits the value of the specified object using the editor style indicated by the WebUITypeEditor.GetEditStyle method.

Overload List

Overload | Description
EditValue(ITypeDescriptorContext,IServiceProvider,Object,WebUITypeEditorHandler) |
EditValue(IServiceProvider,Object,WebUITypeEditorHandler) | Edits the value of the specified object using the editor style indicated by the WebUITypeEditor.GetEditStyle method. (Inherited from WebUITypeEditor)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DockEditor Class
DockEditor Members


EditValue(ITypeDescriptorContext,IServiceProvider,Object,WebUITypeEditorHandler) Method

[image]
Gizmox.WebGUI.Forms
EditValue(ITypeDescriptorContext,IServiceProvider,Object,WebUITypeEditorHandler) Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > DockEditor Class > EditValue Method : EditValue(ITypeDescriptorContext,IServiceProvider,Object,WebUITypeEditorHandler) Method

context
provider
value
objHandler

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Sub EditValue( _
   ByVal context As ITypeDescriptorContext, _
   ByVal provider As IServiceProvider, _
   ByVal value As Object, _
   ByVal objHandler As WebUITypeEditorHandler _
)
Visual Basic (Usage) Copy Code
Dim instance As DockEditor
Dim context As ITypeDescriptorContext
Dim provider As IServiceProvider
Dim value As Object
Dim objHandler As WebUITypeEditorHandler

instance.EditValue(context, provider, value, objHandler)
C#
public override void EditValue(
   ITypeDescriptorContext context,
   IServiceProvider provider,
   object value,
   WebUITypeEditorHandler objHandler
)
Managed Extensions for C++
public: void EditValue(
   ITypeDescriptorContext* context,
   IServiceProvider* provider,
   Object* value,
   WebUITypeEditorHandler* objHandler
) override
C++/CLI
public:
void EditValue(
   ITypeDescriptorContext^ context,
   IServiceProvider^ provider,
   Object^ value,
   WebUITypeEditorHandler^ objHandler
) override

Parameters

context
provider
value
objHandler

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DockEditor Class
DockEditor Members
Overload List


GetEditStyle Method

[image]
Gizmox.WebGUI.Forms
GetEditStyle Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > DockEditor Class : GetEditStyle Method

Gets the editor style used by the EditValue method.

Overload List

Overload | Description
GetEditStyle(ITypeDescriptorContext) |
GetEditStyle() | Gets the editor style used by the EditValue method. (Inherited from WebUITypeEditor)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DockEditor Class
DockEditor Members


GetEditStyle(ITypeDescriptorContext) Method

[image]
Gizmox.WebGUI.Forms
GetEditStyle(ITypeDescriptorContext) Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > DockEditor Class > GetEditStyle Method : GetEditStyle(ITypeDescriptorContext) Method

context

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function GetEditStyle( _
   ByVal context As ITypeDescriptorContext _
) As UITypeEditorEditStyle
Visual Basic (Usage) Copy Code
Dim instance As DockEditor
Dim context As ITypeDescriptorContext
Dim value As UITypeEditorEditStyle

value = instance.GetEditStyle(context)
C#
public override UITypeEditorEditStyle GetEditStyle(
   ITypeDescriptorContext context
)
Managed Extensions for C++
public: UITypeEditorEditStyle GetEditStyle(
   ITypeDescriptorContext* context
) override
C++/CLI
public:
UITypeEditorEditStyle GetEditStyle(
   ITypeDescriptorContext^ context
) override

Parameters

context

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DockEditor Class
DockEditor Members
Overload List


DockEditor Class Properties

[image]
Gizmox.WebGUI.Forms
DockEditor Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace : DockEditor Class

For a list of all members of this type, see DockEditor members.

Public Properties

 | Name | Description
Public Property | IsDropDownResizable | Gets a value indicating whether drop-down editors should be resizable by the user. (Inherited from WebUITypeEditor)
Public Property | IsTextEditable | Gets a value indicating whether this editor value should support text editing. (Inherited from WebUITypeEditor)
Top

Protected Properties

 | Name | Description
Protected Property | PropertyValue |
Top

See Also

Reference

DockEditor Class
Gizmox.WebGUI.Forms.Design Namespace


PropertyValue Property

[image]
Gizmox.WebGUI.Forms
PropertyValue Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > DockEditor Class : PropertyValue Property

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property PropertyValue As DockStyle
Visual Basic (Usage) Copy Code
Dim instance As DockEditor
Dim value As DockStyle

value = instance.PropertyValue
C#
protected DockStyle PropertyValue {get;}
Managed Extensions for C++
protected: __property DockStyle get_PropertyValue();
C++/CLI
protected:
property DockStyle PropertyValue {
   DockStyle get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DockEditor Class
DockEditor Members


EventsTab Class

[image]
Gizmox.WebGUI.Forms
EventsTab Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace : EventsTab Class

Provides a PropertyTab that can display events for selection and linking.

Syntax

Visual Basic (Declaration)
Public Class EventsTab
   Inherits PropertyTab
Visual Basic (Usage) Copy Code
Dim instance As EventsTab
C#
public class EventsTab : PropertyTab
Managed Extensions for C++
public __gc class EventsTab : public PropertyTab
C++/CLI
public ref class EventsTab : public PropertyTab

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.Design.PropertyTab
Gizmox.WebGUI.Forms.Design.EventsTab

Requirements

Namespace: Gizmox.WebGUI.Forms.Design

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

EventsTab Members
Gizmox.WebGUI.Forms.Design Namespace


EventsTab Class Members

[image]
Gizmox.WebGUI.Forms
EventsTab Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms.Design Namespace : EventsTab Class

The following tables list the members exposed by EventsTab.

Public Constructors

 | Name | Description
Public Constructor | EventsTab Constructor | Initializes a new instance of the EventsTab class.
Top

Public Properties

 | Name | Description
Public Property | Bitmap | Gets the bitmap that is displayed for the PropertyTab. (Inherited from PropertyTab)
Public Property | Components | Gets or sets the array of components the property tab is associated with. (Inherited from PropertyTab)
Public Property | HelpKeyword | Overridden. Gets the Help keyword for the tab.
Public Property | TabName | Overridden. Gets the name of the tab.
Top

Public Methods

 | Name | Description
Public Method | CanExtend | Overridden. Gets a value indicating whether the specified object can be extended.
Public Method | Dispose | Overloaded. Releases all the resources used by the PropertyTab. (Inherited from PropertyTab)
Public Method | GetDefaultProperty | Overridden. Gets the default property from the specified object.
Public Method | GetProperties | Overloaded. Overridden. Gets all the properties of the event tab that match the specified attributes.
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | Allows a PropertyTab to attempt to free resources and perform other cleanup operations before the PropertyTab is reclaimed by garbage collection. (Inherited from PropertyTab)
Top

See Also

Reference

EventsTab Class
Gizmox.WebGUI.Forms.Design Namespace


EventsTab Constructor

[image]
Gizmox.WebGUI.Forms
EventsTab Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > EventsTab Class : EventsTab Constructor

sp
An IServiceProvider to use.
Initializes a new instance of the EventsTab class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal sp As IServiceProvider _
)
Visual Basic (Usage) Copy Code
Dim sp As IServiceProvider

Dim instance As EventsTab(sp)
C#
public EventsTab(
   IServiceProvider sp
)
Managed Extensions for C++
public: EventsTab(
   IServiceProvider* sp
)
C++/CLI
public:
EventsTab(
   IServiceProvider^ sp
)

Parameters

sp
An IServiceProvider to use.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

EventsTab Class
EventsTab Members


EventsTab Class Methods

[image]
Gizmox.WebGUI.Forms
EventsTab Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace : EventsTab Class

For a list of all members of this type, see EventsTab members.

Public Methods

 | Name | Description
Public Method | CanExtend | Overridden. Gets a value indicating whether the specified object can be extended.
Public Method | Dispose | Overloaded. Releases all the resources used by the PropertyTab. (Inherited from PropertyTab)
Public Method | GetDefaultProperty | Overridden. Gets the default property from the specified object.
Public Method | GetProperties | Overloaded. Overridden. Gets all the properties of the event tab that match the specified attributes.
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | Allows a PropertyTab to attempt to free resources and perform other cleanup operations before the PropertyTab is reclaimed by garbage collection. (Inherited from PropertyTab)
Top

See Also

Reference

EventsTab Class
Gizmox.WebGUI.Forms.Design Namespace


CanExtend Method

[image]
Gizmox.WebGUI.Forms
CanExtend Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > EventsTab Class : CanExtend Method

extendee
The object to test for extensibility.
Gets a value indicating whether the specified object can be extended.

Syntax

Visual Basic (Declaration)
Public Overrides Function CanExtend( _
   ByVal extendee As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As EventsTab
Dim extendee As Object
Dim value As Boolean

value = instance.CanExtend(extendee)
C#
public override bool CanExtend(
   object extendee
)
Managed Extensions for C++
public: bool CanExtend(
   Object* extendee
) override
C++/CLI
public:
bool CanExtend(
   Object^ extendee
) override

Parameters

extendee
The object to test for extensibility.

Return Value

true if the specified object can be extended; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

EventsTab Class
EventsTab Members


GetDefaultProperty Method

[image]
Gizmox.WebGUI.Forms
GetDefaultProperty Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > EventsTab Class : GetDefaultProperty Method

obj
The object to retrieve the default property of.
Gets the default property from the specified object.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetDefaultProperty( _
   ByVal obj As Object _
) As PropertyDescriptor
Visual Basic (Usage) Copy Code
Dim instance As EventsTab
Dim obj As Object
Dim value As PropertyDescriptor

value = instance.GetDefaultProperty(obj)
C#
public override PropertyDescriptor GetDefaultProperty(
   object obj
)
Managed Extensions for C++
public: PropertyDescriptor* GetDefaultProperty(
   Object* obj
) override
C++/CLI
public:
PropertyDescriptor^ GetDefaultProperty(
   Object^ obj
) override

Parameters

obj
The object to retrieve the default property of.

Return Value

A PropertyDescriptor indicating the default property.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

EventsTab Class
EventsTab Members


GetProperties Method

[image]
Gizmox.WebGUI.Forms
GetProperties Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > EventsTab Class : GetProperties Method

Gets all the properties of the event tab that match the specified attributes.

Overload List

Overload | Description
GetProperties(Object,Attribute[]) | Gets all the properties of the event tab that match the specified attributes.
GetProperties(ITypeDescriptorContext,Object,Attribute[]) | Gets all the properties of the event tab that match the specified attributes and context.
GetProperties(Object) | Gets the properties of the specified component. (Inherited from PropertyTab)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

EventsTab Class
EventsTab Members


GetProperties(Object,Attribute[]) Method

[image]
Gizmox.WebGUI.Forms
GetProperties(Object,Attribute[]) Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > EventsTab Class > GetProperties Method : GetProperties(Object,Attribute[]) Method

component
The component to retrieve the properties of.
attributes
An array of Attribute that indicates the attributes of the event properties to retrieve.
Gets all the properties of the event tab that match the specified attributes.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function GetProperties( _
   ByVal component As Object, _
   ByVal attributes() As Attribute _
) As PropertyDescriptorCollection
Visual Basic (Usage) Copy Code
Dim instance As EventsTab
Dim component As Object
Dim attributes() As Attribute
Dim value As PropertyDescriptorCollection

value = instance.GetProperties(component, attributes)
C#
public override PropertyDescriptorCollection GetProperties(
   object component,
   Attribute[] attributes
)
Managed Extensions for C++
public: PropertyDescriptorCollection* GetProperties(
   Object* component,
   Attribute*[]* attributes
) override
C++/CLI
public:
PropertyDescriptorCollection^ GetProperties(
   Object^ component,
   array<Attribute^>^ attributes
) override

Parameters

component
The component to retrieve the properties of.
attributes
An array of Attribute that indicates the attributes of the event properties to retrieve.

Return Value

A PropertyDescriptorCollection that contains the properties. This will be an empty PropertyDescriptorCollection if the component does not implement an event service.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

EventsTab Class
EventsTab Members
Overload List


GetProperties(ITypeDescriptorContext,Object,Attribute[]) Method

[image]
Gizmox.WebGUI.Forms
GetProperties(ITypeDescriptorContext,Object,Attribute[]) Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > EventsTab Class > GetProperties Method : GetProperties(ITypeDescriptorContext,Object,Attribute[]) Method

context
An ITypeDescriptorContext that can be used to gain context information.
component
The component to retrieve the properties of.
attributes
An array of type Attribute that indicates the attributes of the event properties to retrieve.
Gets all the properties of the event tab that match the specified attributes and context.

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function GetProperties( _
   ByVal context As ITypeDescriptorContext, _
   ByVal component As Object, _
   ByVal attributes() As Attribute _
) As PropertyDescriptorCollection
Visual Basic (Usage) Copy Code
Dim instance As EventsTab
Dim context As ITypeDescriptorContext
Dim component As Object
Dim attributes() As Attribute
Dim value As PropertyDescriptorCollection

value = instance.GetProperties(context, component, attributes)
C#
public override PropertyDescriptorCollection GetProperties(
   ITypeDescriptorContext context,
   object component,
   Attribute[] attributes
)
Managed Extensions for C++
public: PropertyDescriptorCollection* GetProperties(
   ITypeDescriptorContext* context,
   Object* component,
   Attribute*[]* attributes
) override
C++/CLI
public:
PropertyDescriptorCollection^ GetProperties(
   ITypeDescriptorContext^ context,
   Object^ component,
   array<Attribute^>^ attributes
) override

Parameters

context
An ITypeDescriptorContext that can be used to gain context information.
component
The component to retrieve the properties of.
attributes
An array of type Attribute that indicates the attributes of the event properties to retrieve.

Return Value

A PropertyDescriptorCollection that contains the properties. This will be an empty PropertyDescriptorCollection if the component does not implement an event service.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

EventsTab Class
EventsTab Members
Overload List


EventsTab Class Properties

[image]
Gizmox.WebGUI.Forms
EventsTab Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace : EventsTab Class

For a list of all members of this type, see EventsTab members.

Public Properties

 | Name | Description
Public Property | Bitmap | Gets the bitmap that is displayed for the PropertyTab. (Inherited from PropertyTab)
Public Property | Components | Gets or sets the array of components the property tab is associated with. (Inherited from PropertyTab)
Public Property | HelpKeyword | Overridden. Gets the Help keyword for the tab.
Public Property | TabName | Overridden. Gets the name of the tab.
Top

See Also

Reference

EventsTab Class
Gizmox.WebGUI.Forms.Design Namespace


HelpKeyword Property

[image]
Gizmox.WebGUI.Forms
HelpKeyword Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > EventsTab Class : HelpKeyword Property

Gets the Help keyword for the tab.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property HelpKeyword As String
Visual Basic (Usage) Copy Code
Dim instance As EventsTab
Dim value As String

value = instance.HelpKeyword
C#
public override string HelpKeyword {get;}
Managed Extensions for C++
public: __property string* get_HelpKeyword() override;
C++/CLI
public:
property String^ HelpKeyword {
   String^ get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

EventsTab Class
EventsTab Members


TabName Property

[image]
Gizmox.WebGUI.Forms
TabName Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > EventsTab Class : TabName Property

Gets the name of the tab.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property TabName As String
Visual Basic (Usage) Copy Code
Dim instance As EventsTab
Dim value As String

value = instance.TabName
C#
public override string TabName {get;}
Managed Extensions for C++
public: __property string* get_TabName() override;
C++/CLI
public:
property String^ TabName {
   String^ get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

EventsTab Class
EventsTab Members


FontEditor Class

[image]
Gizmox.WebGUI.Forms
FontEditor Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace : FontEditor Class

Provides a base class that can be used to design value editors that can provide a web user interface (Web UI) for representing and editing the values of objects of the supported data types.

Syntax

Visual Basic (Declaration)
Public Class FontEditor
   Inherits WebUITypeEditor
Visual Basic (Usage) Copy Code
Dim instance As FontEditor
C#
public class FontEditor : WebUITypeEditor
Managed Extensions for C++
public __gc class FontEditor : public WebUITypeEditor
C++/CLI
public ref class FontEditor : public WebUITypeEditor

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.Design.WebUITypeEditor
Gizmox.WebGUI.Forms.Design.FontEditor

Requirements

Namespace: Gizmox.WebGUI.Forms.Design

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

FontEditor Members
Gizmox.WebGUI.Forms.Design Namespace


FontEditor Class Members

[image]
Gizmox.WebGUI.Forms
FontEditor Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms.Design Namespace : FontEditor Class

The following tables list the members exposed by FontEditor.

Public Constructors

 | Name | Description
Public Constructor | FontEditor Constructor |
Top

Public Properties

 | Name | Description
Public Property | IsDropDownResizable | Gets a value indicating whether drop-down editors should be resizable by the user. (Inherited from WebUITypeEditor)
Public Property | IsTextEditable | Gets a value indicating whether this editor value should support text editing. (Inherited from WebUITypeEditor)
Top

Public Methods

 | Name | Description
Public Method | EditValue | Overloaded. Overridden. Edits the value of the specified object using the editor style indicated by the WebUITypeEditor.GetEditStyle method.
Public Method | GetEditStyle | Overloaded. Overridden. Gets the editor style used by the EditValue method.
Top

Protected Methods

 | Name | Description
Protected Method | GetEditorValueFromPropertyValue | Supplies a editor level mechanism to convert property values before editing (Inherited from WebUITypeEditor)
Protected Method | GetPropertyValueFromEditorValue | Supplies a editor level mechanism to convert editor returned values before assigning to property (Inherited from WebUITypeEditor)
Protected Method | OnValueChangeError | Raise error on value change (Inherited from WebUITypeEditor)
Protected Method | ValidatePropertyValue | Validated property value (Inherited from WebUITypeEditor)
Top

See Also

Reference

FontEditor Class
Gizmox.WebGUI.Forms.Design Namespace


FontEditor Constructor

[image]
Gizmox.WebGUI.Forms
FontEditor Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > FontEditor Class : FontEditor Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As FontEditor()
C#
public FontEditor()
Managed Extensions for C++
public: FontEditor();
C++/CLI
public:
FontEditor();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FontEditor Class
FontEditor Members


FontEditor Class Methods

[image]
Gizmox.WebGUI.Forms
FontEditor Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace : FontEditor Class

For a list of all members of this type, see FontEditor members.

Public Methods

 | Name | Description
Public Method | EditValue | Overloaded. Overridden. Edits the value of the specified object using the editor style indicated by the WebUITypeEditor.GetEditStyle method.
Public Method | GetEditStyle | Overloaded. Overridden. Gets the editor style used by the EditValue method.
Top

Protected Methods

 | Name | Description
Protected Method | GetEditorValueFromPropertyValue | Supplies a editor level mechanism to convert property values before editing (Inherited from WebUITypeEditor)
Protected Method | GetPropertyValueFromEditorValue | Supplies a editor level mechanism to convert editor returned values before assigning to property (Inherited from WebUITypeEditor)
Protected Method | OnValueChangeError | Raise error on value change (Inherited from WebUITypeEditor)
Protected Method | ValidatePropertyValue | Validated property value (Inherited from WebUITypeEditor)
Top

See Also

Reference

FontEditor Class
Gizmox.WebGUI.Forms.Design Namespace


EditValue Method

[image]
Gizmox.WebGUI.Forms
EditValue Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > FontEditor Class : EditValue Method

Edits the value of the specified object using the editor style indicated by the WebUITypeEditor.GetEditStyle method.

Overload List

Overload | Description
EditValue(ITypeDescriptorContext,IServiceProvider,Object,WebUITypeEditorHandler) |
EditValue(IServiceProvider,Object,WebUITypeEditorHandler) | Edits the value of the specified object using the editor style indicated by the WebUITypeEditor.GetEditStyle method. (Inherited from WebUITypeEditor)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FontEditor Class
FontEditor Members


EditValue(ITypeDescriptorContext,IServiceProvider,Object,WebUITypeEditorHandler) Method

[image]
Gizmox.WebGUI.Forms
EditValue(ITypeDescriptorContext,IServiceProvider,Object,WebUITypeEditorHandler) Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > FontEditor Class > EditValue Method : EditValue(ITypeDescriptorContext,IServiceProvider,Object,WebUITypeEditorHandler) Method

context
provider
value
objHandler

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Sub EditValue( _
   ByVal context As ITypeDescriptorContext, _
   ByVal provider As IServiceProvider, _
   ByVal value As Object, _
   ByVal objHandler As WebUITypeEditorHandler _
)
Visual Basic (Usage) Copy Code
Dim instance As FontEditor
Dim context As ITypeDescriptorContext
Dim provider As IServiceProvider
Dim value As Object
Dim objHandler As WebUITypeEditorHandler

instance.EditValue(context, provider, value, objHandler)
C#
public override void EditValue(
   ITypeDescriptorContext context,
   IServiceProvider provider,
   object value,
   WebUITypeEditorHandler objHandler
)
Managed Extensions for C++
public: void EditValue(
   ITypeDescriptorContext* context,
   IServiceProvider* provider,
   Object* value,
   WebUITypeEditorHandler* objHandler
) override
C++/CLI
public:
void EditValue(
   ITypeDescriptorContext^ context,
   IServiceProvider^ provider,
   Object^ value,
   WebUITypeEditorHandler^ objHandler
) override

Parameters

context
provider
value
objHandler

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FontEditor Class
FontEditor Members
Overload List


GetEditStyle Method

[image]
Gizmox.WebGUI.Forms
GetEditStyle Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > FontEditor Class : GetEditStyle Method

Gets the editor style used by the EditValue method.

Overload List

Overload | Description
GetEditStyle(ITypeDescriptorContext) |
GetEditStyle() | Gets the editor style used by the EditValue method. (Inherited from WebUITypeEditor)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FontEditor Class
FontEditor Members


GetEditStyle(ITypeDescriptorContext) Method

[image]
Gizmox.WebGUI.Forms
GetEditStyle(ITypeDescriptorContext) Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > FontEditor Class > GetEditStyle Method : GetEditStyle(ITypeDescriptorContext) Method

context

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function GetEditStyle( _
   ByVal context As ITypeDescriptorContext _
) As UITypeEditorEditStyle
Visual Basic (Usage) Copy Code
Dim instance As FontEditor
Dim context As ITypeDescriptorContext
Dim value As UITypeEditorEditStyle

value = instance.GetEditStyle(context)
C#
public override UITypeEditorEditStyle GetEditStyle(
   ITypeDescriptorContext context
)
Managed Extensions for C++
public: UITypeEditorEditStyle GetEditStyle(
   ITypeDescriptorContext* context
) override
C++/CLI
public:
UITypeEditorEditStyle GetEditStyle(
   ITypeDescriptorContext^ context
) override

Parameters

context

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FontEditor Class
FontEditor Members
Overload List


PropertyTab Class

[image]
Gizmox.WebGUI.Forms
PropertyTab Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace : PropertyTab Class

Provides a base class for property tabs.

Syntax

Visual Basic (Declaration)
<PermissionSetAttribute(File="",
   UnicodeEncoded=False,
   Name="FullTrust",
   XML="",
   Hex="",
   Unrestricted=False)>
Public MustInherit Class PropertyTab
Visual Basic (Usage) Copy Code
Dim instance As PropertyTab
C#
[PermissionSetAttribute(File="",
   UnicodeEncoded=false,
   Name="FullTrust",
   XML="",
   Hex="",
   Unrestricted=false)]
public abstract class PropertyTab
Managed Extensions for C++
[PermissionSetAttribute(File="",
   UnicodeEncoded=false,
   Name="FullTrust",
   XML="",
   Hex="",
   Unrestricted=false)]
public __gc abstract class PropertyTab
C++/CLI
[PermissionSetAttribute(File="",
   UnicodeEncoded=false,
   Name="FullTrust",
   XML="",
   Hex="",
   Unrestricted=false)]
public ref class PropertyTab abstract

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.Design.PropertyTab
Gizmox.WebGUI.Forms.Design.EventsTab
Gizmox.WebGUI.Forms.PropertyGridInternal.PropertiesTab

Requirements

Namespace: Gizmox.WebGUI.Forms.Design

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

PropertyTab Members
Gizmox.WebGUI.Forms.Design Namespace


PropertyTab Class Members

[image]
Gizmox.WebGUI.Forms
PropertyTab Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms.Design Namespace : PropertyTab Class

The following tables list the members exposed by PropertyTab.

Public Properties

 | Name | Description
Public Property | Bitmap | Gets the bitmap that is displayed for the PropertyTab.
Public Property | Components | Gets or sets the array of components the property tab is associated with.
Public Property | HelpKeyword | Gets the Help keyword that is to be associated with this tab.
Public Property | TabName | Gets the name for the property tab.
Top

Public Methods

 | Name | Description
Public Method | CanExtend | Gets a value indicating whether this PropertyTab can display properties for the specified component.
Public Method | Dispose | Overloaded. Releases all the resources used by the PropertyTab.
Public Method | GetDefaultProperty | Gets the default property of the specified component.
Public Method | GetProperties | Overloaded. Gets the properties of the specified component.
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | Overridden. Allows a PropertyTab to attempt to free resources and perform other cleanup operations before the PropertyTab is reclaimed by garbage collection.
Top

See Also

Reference

PropertyTab Class
Gizmox.WebGUI.Forms.Design Namespace


PropertyTab Class Methods

[image]
Gizmox.WebGUI.Forms
PropertyTab Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace : PropertyTab Class

For a list of all members of this type, see PropertyTab members.

Public Methods

 | Name | Description
Public Method | CanExtend | Gets a value indicating whether this PropertyTab can display properties for the specified component.
Public Method | Dispose | Overloaded. Releases all the resources used by the PropertyTab.
Public Method | GetDefaultProperty | Gets the default property of the specified component.
Public Method | GetProperties | Overloaded. Gets the properties of the specified component.
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | Overridden. Allows a PropertyTab to attempt to free resources and perform other cleanup operations before the PropertyTab is reclaimed by garbage collection.
Top

See Also

Reference

PropertyTab Class
Gizmox.WebGUI.Forms.Design Namespace


CanExtend Method

[image]
Gizmox.WebGUI.Forms
CanExtend Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > PropertyTab Class : CanExtend Method

extendee
The object to test.
Gets a value indicating whether this PropertyTab can display properties for the specified component.

Syntax

Visual Basic (Declaration)
Public Overridable Function CanExtend( _
   ByVal extendee As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PropertyTab
Dim extendee As Object
Dim value As Boolean

value = instance.CanExtend(extendee)
C#
public virtual bool CanExtend(
   object extendee
)
Managed Extensions for C++
public: virtual bool CanExtend(
   Object* extendee
)
C++/CLI
public:
virtual bool CanExtend(
   Object^ extendee
)

Parameters

extendee
The object to test.

Return Value

true if the object can be extended; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyTab Class
PropertyTab Members


Dispose Method

[image]
Gizmox.WebGUI.Forms
Dispose Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > PropertyTab Class : Dispose Method

Releases all the resources used by the PropertyTab.

Overload List

Overload | Description
Dispose() | Releases all the resources used by the PropertyTab.
Dispose(Boolean) | Releases the unmanaged resources used by the PropertyTab and optionally releases the managed resources.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyTab Class
PropertyTab Members


Dispose() Method

[image]
Gizmox.WebGUI.Forms
Dispose() Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > PropertyTab Class > Dispose Method : Dispose() Method

Releases all the resources used by the PropertyTab.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As PropertyTab

instance.Dispose()
C#
public virtual void Dispose()
Managed Extensions for C++
public: virtual void Dispose();
C++/CLI
public:
virtual void Dispose();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyTab Class
PropertyTab Members
Overload List


Dispose(Boolean) Method

[image]
Gizmox.WebGUI.Forms
Dispose(Boolean) Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > PropertyTab Class > Dispose Method : Dispose(Boolean) Method

disposing
true to release both managed and unmanaged resources; false to release only unmanaged resources.
Releases the unmanaged resources used by the PropertyTab and optionally releases the managed resources.

Syntax

Visual Basic (Declaration)
Protected Overloads Overridable Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As PropertyTab
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected virtual void Dispose(
   bool disposing
)
Managed Extensions for C++
protected: virtual void Dispose(
   bool disposing
)
C++/CLI
protected:
virtual void Dispose(
   bool disposing
)

Parameters

disposing
true to release both managed and unmanaged resources; false to release only unmanaged resources.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyTab Class
PropertyTab Members
Overload List


Finalize Method

[image]
Gizmox.WebGUI.Forms
Finalize Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > PropertyTab Class : Finalize Method

Allows a PropertyTab to attempt to free resources and perform other cleanup operations before the PropertyTab is reclaimed by garbage collection.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub Finalize()
Visual Basic (Usage) Copy Code
Dim instance As PropertyTab

instance.Finalize()
C#
protected override void Finalize()
Managed Extensions for C++
protected: void Finalize(); override
C++/CLI
protected:
void Finalize(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyTab Class
PropertyTab Members


GetDefaultProperty Method

[image]
Gizmox.WebGUI.Forms
GetDefaultProperty Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > PropertyTab Class : GetDefaultProperty Method

component
The component to retrieve the default property of.
Gets the default property of the specified component.

Syntax

Visual Basic (Declaration)
Public Overridable Function GetDefaultProperty( _
   ByVal component As Object _
) As PropertyDescriptor
Visual Basic (Usage) Copy Code
Dim instance As PropertyTab
Dim component As Object
Dim value As PropertyDescriptor

value = instance.GetDefaultProperty(component)
C#
public virtual PropertyDescriptor GetDefaultProperty(
   object component
)
Managed Extensions for C++
public: virtual PropertyDescriptor* GetDefaultProperty(
   Object* component
)
C++/CLI
public:
virtual PropertyDescriptor^ GetDefaultProperty(
   Object^ component
)

Parameters

component
The component to retrieve the default property of.

Return Value

A PropertyDescriptor that represents the default property.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyTab Class
PropertyTab Members


GetProperties Method

[image]
Gizmox.WebGUI.Forms
GetProperties Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > PropertyTab Class : GetProperties Method

Gets the properties of the specified component.

Overload List

Overload | Description
GetProperties(Object) | Gets the properties of the specified component.
GetProperties(Object,Attribute[]) | Gets the properties of the specified component that match the specified attributes.
GetProperties(ITypeDescriptorContext,Object,Attribute[]) | Gets the properties of the specified component that match the specified attributes and context.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyTab Class
PropertyTab Members


GetProperties(Object) Method

[image]
Gizmox.WebGUI.Forms
GetProperties(Object) Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > PropertyTab Class > GetProperties Method : GetProperties(Object) Method

component
The component to retrieve the properties of.
Gets the properties of the specified component.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function GetProperties( _
   ByVal component As Object _
) As PropertyDescriptorCollection
Visual Basic (Usage) Copy Code
Dim instance As PropertyTab
Dim component As Object
Dim value As PropertyDescriptorCollection

value = instance.GetProperties(component)
C#
public virtual PropertyDescriptorCollection GetProperties(
   object component
)
Managed Extensions for C++
public: virtual PropertyDescriptorCollection* GetProperties(
   Object* component
)
C++/CLI
public:
virtual PropertyDescriptorCollection^ GetProperties(
   Object^ component
)

Parameters

component
The component to retrieve the properties of.

Return Value

A PropertyDescriptorCollection that contains the properties of the component.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyTab Class
PropertyTab Members
Overload List


GetProperties(Object,Attribute[]) Method

[image]
Gizmox.WebGUI.Forms
GetProperties(Object,Attribute[]) Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > PropertyTab Class > GetProperties Method : GetProperties(Object,Attribute[]) Method

component
The component to retrieve properties from.
attributes
An array of type Attribute that indicates the attributes of the properties to retrieve.
Gets the properties of the specified component that match the specified attributes.

Syntax

Visual Basic (Declaration)
Public Overloads MustOverride Function GetProperties( _
   ByVal component As Object, _
   ByVal attributes() As Attribute _
) As PropertyDescriptorCollection
Visual Basic (Usage) Copy Code
Dim instance As PropertyTab
Dim component As Object
Dim attributes() As Attribute
Dim value As PropertyDescriptorCollection

value = instance.GetProperties(component, attributes)
C#
public abstract PropertyDescriptorCollection GetProperties(
   object component,
   Attribute[] attributes
)
Managed Extensions for C++
public: abstract PropertyDescriptorCollection* GetProperties(
   Object* component,
   Attribute*[]* attributes
)
C++/CLI
public:
abstract PropertyDescriptorCollection^ GetProperties(
   Object^ component,
   array<Attribute^>^ attributes
)

Parameters

component
The component to retrieve properties from.
attributes
An array of type Attribute that indicates the attributes of the properties to retrieve.

Return Value

A PropertyDescriptorCollection that contains the properties.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyTab Class
PropertyTab Members
Overload List


GetProperties(ITypeDescriptorContext,Object,Attribute[]) Method

[image]
Gizmox.WebGUI.Forms
GetProperties(ITypeDescriptorContext,Object,Attribute[]) Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > PropertyTab Class > GetProperties Method : GetProperties(ITypeDescriptorContext,Object,Attribute[]) Method

context
An ITypeDescriptorContext that indicates the context to retrieve properties from.
component
The component to retrieve properties from.
attributes
An array of type Attribute that indicates the attributes of the properties to retrieve.
Gets the properties of the specified component that match the specified attributes and context.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function GetProperties( _
   ByVal context As ITypeDescriptorContext, _
   ByVal component As Object, _
   ByVal attributes() As Attribute _
) As PropertyDescriptorCollection
Visual Basic (Usage) Copy Code
Dim instance As PropertyTab
Dim context As ITypeDescriptorContext
Dim component As Object
Dim attributes() As Attribute
Dim value As PropertyDescriptorCollection

value = instance.GetProperties(context, component, attributes)
C#
public virtual PropertyDescriptorCollection GetProperties(
   ITypeDescriptorContext context,
   object component,
   Attribute[] attributes
)
Managed Extensions for C++
public: virtual PropertyDescriptorCollection* GetProperties(
   ITypeDescriptorContext* context,
   Object* component,
   Attribute*[]* attributes
)
C++/CLI
public:
virtual PropertyDescriptorCollection^ GetProperties(
   ITypeDescriptorContext^ context,
   Object^ component,
   array<Attribute^>^ attributes
)

Parameters

context
An ITypeDescriptorContext that indicates the context to retrieve properties from.
component
The component to retrieve properties from.
attributes
An array of type Attribute that indicates the attributes of the properties to retrieve.

Return Value

A PropertyDescriptorCollection that contains the properties matching the specified context and attributes.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyTab Class
PropertyTab Members
Overload List


PropertyTab Class Properties

[image]
Gizmox.WebGUI.Forms
PropertyTab Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace : PropertyTab Class

For a list of all members of this type, see PropertyTab members.

Public Properties

 | Name | Description
Public Property | Bitmap | Gets the bitmap that is displayed for the PropertyTab.
Public Property | Components | Gets or sets the array of components the property tab is associated with.
Public Property | HelpKeyword | Gets the Help keyword that is to be associated with this tab.
Public Property | TabName | Gets the name for the property tab.
Top

See Also

Reference

PropertyTab Class
Gizmox.WebGUI.Forms.Design Namespace


Bitmap Property

[image]
Gizmox.WebGUI.Forms
Bitmap Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > PropertyTab Class : Bitmap Property

Gets the bitmap that is displayed for the PropertyTab.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Bitmap As Bitmap
Visual Basic (Usage) Copy Code
Dim instance As PropertyTab
Dim value As Bitmap

value = instance.Bitmap
C#
public virtual Bitmap Bitmap {get;}
Managed Extensions for C++
public: __property virtual Bitmap* get_Bitmap();
C++/CLI
public:
virtual property Bitmap^ Bitmap {
   Bitmap^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyTab Class
PropertyTab Members


Components Property

[image]
Gizmox.WebGUI.Forms
Components Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > PropertyTab Class : Components Property

Gets or sets the array of components the property tab is associated with.

Syntax

Visual Basic (Declaration)
Public Overridable Property Components As Object()
Visual Basic (Usage) Copy Code
Dim instance As PropertyTab
Dim value() As Object

instance.Components = value

value = instance.Components
C#
public virtual object[] Components {get; set;}
Managed Extensions for C++
public: __property virtual Object*[]* get_Components();
public: __property virtual void set_Components(
   Object*[]* value
);
C++/CLI
public:
virtual property array<Object^>^ Components {
   array<Object^>^ get();
   void set (Object^array<value>^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyTab Class
PropertyTab Members


HelpKeyword Property

[image]
Gizmox.WebGUI.Forms
HelpKeyword Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > PropertyTab Class : HelpKeyword Property

Gets the Help keyword that is to be associated with this tab.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property HelpKeyword As String
Visual Basic (Usage) Copy Code
Dim instance As PropertyTab
Dim value As String

value = instance.HelpKeyword
C#
public virtual string HelpKeyword {get;}
Managed Extensions for C++
public: __property virtual string* get_HelpKeyword();
C++/CLI
public:
virtual property String^ HelpKeyword {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyTab Class
PropertyTab Members


TabName Property

[image]
Gizmox.WebGUI.Forms
TabName Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > PropertyTab Class : TabName Property

Gets the name for the property tab.

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property TabName As String
Visual Basic (Usage) Copy Code
Dim instance As PropertyTab
Dim value As String

value = instance.TabName
C#
public abstract string TabName {get;}
Managed Extensions for C++
public: __property abstract string* get_TabName();
C++/CLI
public:
abstract property String^ TabName {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertyTab Class
PropertyTab Members


WebEditorAttribute Class

[image]
Gizmox.WebGUI.Forms
WebEditorAttribute Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace : WebEditorAttribute Class

Specifies the editor to use to change a property. This class cannot be inherited.

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AllowMultiple=True, Inherited=True)>
Public NotInheritable Class WebEditorAttribute
   Inherits Attribute
Visual Basic (Usage) Copy Code
Dim instance As WebEditorAttribute
C#
[AttributeUsageAttribute(AllowMultiple=true, Inherited=true)]
public sealed class WebEditorAttribute : Attribute
Managed Extensions for C++
[AttributeUsageAttribute(AllowMultiple=true, Inherited=true)]
public __gc __sealed class WebEditorAttribute : public Attribute
C++/CLI
[AttributeUsageAttribute(AllowMultiple=true, Inherited=true)]
public ref class WebEditorAttribute sealed : public Attribute

Inheritance Hierarchy

System.Object
System.Attribute
Gizmox.WebGUI.Forms.Design.WebEditorAttribute

Requirements

Namespace: Gizmox.WebGUI.Forms.Design

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

WebEditorAttribute Members
Gizmox.WebGUI.Forms.Design Namespace


WebEditorAttribute Class Members

[image]
Gizmox.WebGUI.Forms
WebEditorAttribute Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms.Design Namespace : WebEditorAttribute Class

The following tables list the members exposed by WebEditorAttribute.

Public Constructors

 | Name | Description
Public Constructor | WebEditorAttribute Constructor | Overloaded. Initializes a new instance of the WebEditorAttribute class with the default editor, which is no editor.
Top

Public Properties

 | Name | Description
Public Property | EditorBaseTypeName | Gets the name of the base class or interface serving as a lookup key for this editor.
Public Property | EditorTypeName | Gets the name of the editor class in the AssemblyQualifiedName format.
Public Property | TypeId | Overridden. Gets a unique ID for this attribute type.
Top

Public Methods

 | Name | Description
Public Method | Equals | Overridden. Returns whether the value of the given object is equal to the current WebEditorAttribute.
Public Method | GetHashCode | Overridden.
Public Method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from System.Attribute)
Public Method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from System.Attribute)
Top

See Also

Reference

WebEditorAttribute Class
Gizmox.WebGUI.Forms.Design Namespace


WebEditorAttribute Constructor

[image]
Gizmox.WebGUI.Forms
WebEditorAttribute Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > WebEditorAttribute Class : WebEditorAttribute Constructor

Initializes a new instance of the WebEditorAttribute class with the default editor, which is no editor.

Overload List

Overload | Description
WebEditorAttribute Constructor() | Initializes a new instance of the WebEditorAttribute class with the default editor, which is no editor.
WebEditorAttribute Constructor(String) | Initializes a new instance of the WebEditorAttribute class with the type name and the base type.
WebEditorAttribute Constructor(String,String) | Initializes a new instance of the WebEditorAttribute class with the type name and base type name of the editor.
WebEditorAttribute Constructor(String,Type) | Initializes a new instance of the WebEditorAttribute class with the type name and the base type.
WebEditorAttribute Constructor(Type,Type) | Initializes a new instance of the WebEditorAttribute class with the type and the base type.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebEditorAttribute Class
WebEditorAttribute Members


WebEditorAttribute Constructor()

[image]
Gizmox.WebGUI.Forms
WebEditorAttribute Constructor()
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > WebEditorAttribute Class > WebEditorAttribute Constructor : WebEditorAttribute Constructor()

Initializes a new instance of the WebEditorAttribute class with the default editor, which is no editor.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As WebEditorAttribute()
C#
public WebEditorAttribute()
Managed Extensions for C++
public: WebEditorAttribute();
C++/CLI
public:
WebEditorAttribute();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebEditorAttribute Class
WebEditorAttribute Members
Overload List


WebEditorAttribute Constructor(String)

[image]
Gizmox.WebGUI.Forms
WebEditorAttribute Constructor(String)
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > WebEditorAttribute Class > WebEditorAttribute Constructor : WebEditorAttribute Constructor(String)

typeName
The fully qualified type name of the editor.
Initializes a new instance of the WebEditorAttribute class with the type name and the base type.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal typeName As String _
)
Visual Basic (Usage) Copy Code
Dim typeName As String

Dim instance As WebEditorAttribute(typeName)
C#
public WebEditorAttribute(
   string typeName
)
Managed Extensions for C++
public: WebEditorAttribute(
   string* typeName
)
C++/CLI
public:
WebEditorAttribute(
   String^ typeName
)

Parameters

typeName
The fully qualified type name of the editor.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebEditorAttribute Class
WebEditorAttribute Members
Overload List


WebEditorAttribute Constructor(String,String)

[image]
Gizmox.WebGUI.Forms
WebEditorAttribute Constructor(String,String)
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > WebEditorAttribute Class > WebEditorAttribute Constructor : WebEditorAttribute Constructor(String,String)

typeName
The fully qualified type name of the editor.
baseTypeName
The fully qualified type name of the base class or interface to use as a lookup key for the editor. This class must be or derive from WebUITypeEditor.
Initializes a new instance of the WebEditorAttribute class with the type name and base type name of the editor.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal typeName As String, _
   ByVal baseTypeName As String _
)
Visual Basic (Usage) Copy Code
Dim typeName As String
Dim baseTypeName As String

Dim instance As WebEditorAttribute(typeName, baseTypeName)
C#
public WebEditorAttribute(
   string typeName,
   string baseTypeName
)
Managed Extensions for C++
public: WebEditorAttribute(
   string* typeName,
   string* baseTypeName
)
C++/CLI
public:
WebEditorAttribute(
   String^ typeName,
   String^ baseTypeName
)

Parameters

typeName
The fully qualified type name of the editor.
baseTypeName
The fully qualified type name of the base class or interface to use as a lookup key for the editor. This class must be or derive from WebUITypeEditor.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebEditorAttribute Class
WebEditorAttribute Members
Overload List


WebEditorAttribute Constructor(String,Type)

[image]
Gizmox.WebGUI.Forms
WebEditorAttribute Constructor(String,Type)
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > WebEditorAttribute Class > WebEditorAttribute Constructor : WebEditorAttribute Constructor(String,Type)

typeName
The fully qualified type name of the editor.
baseType
The Type of the base class or interface to use as a lookup key for the editor. This class must be or derive from WebUITypeEditor.
Initializes a new instance of the WebEditorAttribute class with the type name and the base type.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal typeName As String, _
   ByVal baseType As Type _
)
Visual Basic (Usage) Copy Code
Dim typeName As String
Dim baseType As Type

Dim instance As WebEditorAttribute(typeName, baseType)
C#
public WebEditorAttribute(
   string typeName,
   Type baseType
)
Managed Extensions for C++
public: WebEditorAttribute(
   string* typeName,
   Type* baseType
)
C++/CLI
public:
WebEditorAttribute(
   String^ typeName,
   Type^ baseType
)

Parameters

typeName
The fully qualified type name of the editor.
baseType
The Type of the base class or interface to use as a lookup key for the editor. This class must be or derive from WebUITypeEditor.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebEditorAttribute Class
WebEditorAttribute Members
Overload List


WebEditorAttribute Constructor(Type,Type)

[image]
Gizmox.WebGUI.Forms
WebEditorAttribute Constructor(Type,Type)
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > WebEditorAttribute Class > WebEditorAttribute Constructor : WebEditorAttribute Constructor(Type,Type)

type
A Type that represents the type of the editor.
baseType
The Type of the base class or interface to use as a lookup key for the editor. This class must be or derive from WebUITypeEditor.
Initializes a new instance of the WebEditorAttribute class with the type and the base type.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal type As Type, _
   ByVal baseType As Type _
)
Visual Basic (Usage) Copy Code
Dim type As Type
Dim baseType As Type

Dim instance As WebEditorAttribute(type, baseType)
C#
public WebEditorAttribute(
   Type type,
   Type baseType
)
Managed Extensions for C++
public: WebEditorAttribute(
   Type* type,
   Type* baseType
)
C++/CLI
public:
WebEditorAttribute(
   Type^ type,
   Type^ baseType
)

Parameters

type
A Type that represents the type of the editor.
baseType
The Type of the base class or interface to use as a lookup key for the editor. This class must be or derive from WebUITypeEditor.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebEditorAttribute Class
WebEditorAttribute Members
Overload List


WebEditorAttribute Class Methods

[image]
Gizmox.WebGUI.Forms
WebEditorAttribute Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace : WebEditorAttribute Class

For a list of all members of this type, see WebEditorAttribute members.

Public Methods

 | Name | Description
Public Method | Equals | Overridden. Returns whether the value of the given object is equal to the current WebEditorAttribute.
Public Method | GetHashCode | Overridden.
Public Method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from System.Attribute)
Public Method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from System.Attribute)
Top

See Also

Reference

WebEditorAttribute Class
Gizmox.WebGUI.Forms.Design Namespace


Equals Method

[image]
Gizmox.WebGUI.Forms
Equals Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > WebEditorAttribute Class : Equals Method

obj
The object to test the value equality of.
Returns whether the value of the given object is equal to the current WebEditorAttribute.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function Equals( _
   ByVal obj As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebEditorAttribute
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
C#
public override bool Equals(
   object obj
)
Managed Extensions for C++
public: bool Equals(
   Object* obj
) override
C++/CLI
public:
bool Equals(
   Object^ obj
) override

Parameters

obj
The object to test the value equality of.

Return Value

true if the value of the given object is equal to that of the current object; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebEditorAttribute Class
WebEditorAttribute Members


GetHashCode Method

[image]
Gizmox.WebGUI.Forms
GetHashCode Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > WebEditorAttribute Class : GetHashCode Method

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As WebEditorAttribute
Dim value As Integer

value = instance.GetHashCode()
C#
public override int GetHashCode()
Managed Extensions for C++
public: int GetHashCode(); override
C++/CLI
public:
int GetHashCode(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebEditorAttribute Class
WebEditorAttribute Members


WebEditorAttribute Class Properties

[image]
Gizmox.WebGUI.Forms
WebEditorAttribute Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace : WebEditorAttribute Class

For a list of all members of this type, see WebEditorAttribute members.

Public Properties

 | Name | Description
Public Property | EditorBaseTypeName | Gets the name of the base class or interface serving as a lookup key for this editor.
Public Property | EditorTypeName | Gets the name of the editor class in the AssemblyQualifiedName format.
Public Property | TypeId | Overridden. Gets a unique ID for this attribute type.
Top

See Also

Reference

WebEditorAttribute Class
Gizmox.WebGUI.Forms.Design Namespace


EditorBaseTypeName Property

[image]
Gizmox.WebGUI.Forms
EditorBaseTypeName Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > WebEditorAttribute Class : EditorBaseTypeName Property

Gets the name of the base class or interface serving as a lookup key for this editor.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property EditorBaseTypeName As String
Visual Basic (Usage) Copy Code
Dim instance As WebEditorAttribute
Dim value As String

value = instance.EditorBaseTypeName
C#
public string EditorBaseTypeName {get;}
Managed Extensions for C++
public: __property string* get_EditorBaseTypeName();
C++/CLI
public:
property String^ EditorBaseTypeName {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebEditorAttribute Class
WebEditorAttribute Members


EditorTypeName Property

[image]
Gizmox.WebGUI.Forms
EditorTypeName Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > WebEditorAttribute Class : EditorTypeName Property

Gets the name of the editor class in the AssemblyQualifiedName format.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property EditorTypeName As String
Visual Basic (Usage) Copy Code
Dim instance As WebEditorAttribute
Dim value As String

value = instance.EditorTypeName
C#
public string EditorTypeName {get;}
Managed Extensions for C++
public: __property string* get_EditorTypeName();
C++/CLI
public:
property String^ EditorTypeName {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebEditorAttribute Class
WebEditorAttribute Members


TypeId Property

[image]
Gizmox.WebGUI.Forms
TypeId Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > WebEditorAttribute Class : TypeId Property

Gets a unique ID for this attribute type.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property TypeId As Object
Visual Basic (Usage) Copy Code
Dim instance As WebEditorAttribute
Dim value As Object

value = instance.TypeId
C#
public override object TypeId {get;}
Managed Extensions for C++
public: __property Object* get_TypeId() override;
C++/CLI
public:
property Object^ TypeId {
   Object^ get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebEditorAttribute Class
WebEditorAttribute Members


WebUITypeEditor Class

[image]
Gizmox.WebGUI.Forms
WebUITypeEditor Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace : WebUITypeEditor Class

Provides a base class that can be used to design value editors that can provide a web user interface (Web UI) for representing and editing the values of objects of the supported data types.

Syntax

Visual Basic (Declaration)
Public Class WebUITypeEditor
Visual Basic (Usage) Copy Code
Dim instance As WebUITypeEditor
C#
public class WebUITypeEditor
Managed Extensions for C++
public __gc class WebUITypeEditor
C++/CLI
public ref class WebUITypeEditor

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.Design.WebUITypeEditor
Gizmox.WebGUI.Forms.Design.AnchorEditor
Gizmox.WebGUI.Forms.Design.CollectionEditor
Gizmox.WebGUI.Forms.Design.ColorEditor
Gizmox.WebGUI.Forms.Design.DateTimeEditor
Gizmox.WebGUI.Forms.Design.DockEditor
Gizmox.WebGUI.Forms.Design.FontEditor

Requirements

Namespace: Gizmox.WebGUI.Forms.Design

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

WebUITypeEditor Members
Gizmox.WebGUI.Forms.Design Namespace


WebUITypeEditor Class Members

[image]
Gizmox.WebGUI.Forms
WebUITypeEditor Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms.Design Namespace : WebUITypeEditor Class

The following tables list the members exposed by WebUITypeEditor.

Public Constructors

 | Name | Description
Public Constructor | WebUITypeEditor Constructor | Initializes a new instance of the WebUITypeEditor class.
Top

Public Properties

 | Name | Description
Public Property | IsDropDownResizable | Gets a value indicating whether drop-down editors should be resizable by the user.
Public Property | IsTextEditable | Gets a value indicating whether this editor value should support text editing.
Top

Public Methods

 | Name | Description
Public Method | EditValue | Overloaded. Edits the value of the specified object using the editor style indicated by the WebUITypeEditor.GetEditStyle method.
static (Shared in Visual Basic) | GetEditor | Overloaded. Gets an editor with the WebUITypeEditor base type for the specified component.
Public Method | GetEditStyle | Overloaded. Gets the editor style used by the EditValue method.
static (Shared in Visual Basic) | GetPropertyEditor | Overloaded. Gets an editor from the property attributes
Top

Protected Methods

 | Name | Description
Protected Method | GetEditorValueFromPropertyValue | Supplies a editor level mechanism to convert property values before editing
Protected Method | GetPropertyValueFromEditorValue | Supplies a editor level mechanism to convert editor returned values before assigning to property
Protected Method | OnValueChangeError | Raise error on value change
Protected Method | ValidatePropertyValue | Validated property value
Top

See Also

Reference

WebUITypeEditor Class
Gizmox.WebGUI.Forms.Design Namespace


WebUITypeEditor Constructor

[image]
Gizmox.WebGUI.Forms
WebUITypeEditor Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > WebUITypeEditor Class : WebUITypeEditor Constructor

Initializes a new instance of the WebUITypeEditor class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As WebUITypeEditor()
C#
public WebUITypeEditor()
Managed Extensions for C++
public: WebUITypeEditor();
C++/CLI
public:
WebUITypeEditor();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebUITypeEditor Class
WebUITypeEditor Members


WebUITypeEditor Class Methods

[image]
Gizmox.WebGUI.Forms
WebUITypeEditor Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace : WebUITypeEditor Class

For a list of all members of this type, see WebUITypeEditor members.

Public Methods

 | Name | Description
Public Method | EditValue | Overloaded. Edits the value of the specified object using the editor style indicated by the WebUITypeEditor.GetEditStyle method.
static (Shared in Visual Basic) | GetEditor | Overloaded. Gets an editor with the WebUITypeEditor base type for the specified component.
Public Method | GetEditStyle | Overloaded. Gets the editor style used by the EditValue method.
static (Shared in Visual Basic) | GetPropertyEditor | Overloaded. Gets an editor from the property attributes
Top

Protected Methods

 | Name | Description
Protected Method | GetEditorValueFromPropertyValue | Supplies a editor level mechanism to convert property values before editing
Protected Method | GetPropertyValueFromEditorValue | Supplies a editor level mechanism to convert editor returned values before assigning to property
Protected Method | OnValueChangeError | Raise error on value change
Protected Method | ValidatePropertyValue | Validated property value
Top

See Also

Reference

WebUITypeEditor Class
Gizmox.WebGUI.Forms.Design Namespace


EditValue Method

[image]
Gizmox.WebGUI.Forms
EditValue Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > WebUITypeEditor Class : EditValue Method

Edits the value of the specified object using the editor style indicated by the WebUITypeEditor.GetEditStyle method.

Overload List

Overload | Description
EditValue(IServiceProvider,Object,WebUITypeEditorHandler) | Edits the value of the specified object using the editor style indicated by the WebUITypeEditor.GetEditStyle method.
EditValue(ITypeDescriptorContext,IServiceProvider,Object,WebUITypeEditorHandler) | Edits the specified object's value using the editor style indicated by the WebUITypeEditor.GetEditStyle method.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebUITypeEditor Class
WebUITypeEditor Members


EditValue(IServiceProvider,Object,WebUITypeEditorHandler) Method

[image]
Gizmox.WebGUI.Forms
EditValue(IServiceProvider,Object,WebUITypeEditorHandler) Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > WebUITypeEditor Class > EditValue Method : EditValue(IServiceProvider,Object,WebUITypeEditorHandler) Method

provider
An IServiceProvider that this editor can use to obtain services.
value
The object to edit.
objHandler
Edits the value of the specified object using the editor style indicated by the WebUITypeEditor.GetEditStyle method.

Syntax

Visual Basic (Declaration)
Public Overloads Sub EditValue( _
   ByVal provider As IServiceProvider, _
   ByVal value As Object, _
   ByVal objHandler As WebUITypeEditorHandler _
)
Visual Basic (Usage) Copy Code
Dim instance As WebUITypeEditor
Dim provider As IServiceProvider
Dim value As Object
Dim objHandler As WebUITypeEditorHandler

instance.EditValue(provider, value, objHandler)
C#
public void EditValue(
   IServiceProvider provider,
   object value,
   WebUITypeEditorHandler objHandler
)
Managed Extensions for C++
public: void EditValue(
   IServiceProvider* provider,
   Object* value,
   WebUITypeEditorHandler* objHandler
)
C++/CLI
public:
void EditValue(
   IServiceProvider^ provider,
   Object^ value,
   WebUITypeEditorHandler^ objHandler
)

Parameters

provider
An IServiceProvider that this editor can use to obtain services.
value
The object to edit.
objHandler

Return Value

The new value of the object.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebUITypeEditor Class
WebUITypeEditor Members
Overload List


EditValue(ITypeDescriptorContext,IServiceProvider,Object,WebUITypeEditorHandler) Method

[image]
Gizmox.WebGUI.Forms
EditValue(ITypeDescriptorContext,IServiceProvider,Object,WebUITypeEditorHandler) Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > WebUITypeEditor Class > EditValue Method : EditValue(ITypeDescriptorContext,IServiceProvider,Object,WebUITypeEditorHandler) Method

context
An ITypeDescriptorContext that can be used to gain additional context information.
provider
An IServiceProvider that this editor can use to obtain services.
value
The object to edit.
objHandler
Edits the specified object's value using the editor style indicated by the WebUITypeEditor.GetEditStyle method.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub EditValue( _
   ByVal context As ITypeDescriptorContext, _
   ByVal provider As IServiceProvider, _
   ByVal value As Object, _
   ByVal objHandler As WebUITypeEditorHandler _
)
Visual Basic (Usage) Copy Code
Dim instance As WebUITypeEditor
Dim context As ITypeDescriptorContext
Dim provider As IServiceProvider
Dim value As Object
Dim objHandler As WebUITypeEditorHandler

instance.EditValue(context, provider, value, objHandler)
C#
public virtual void EditValue(
   ITypeDescriptorContext context,
   IServiceProvider provider,
   object value,
   WebUITypeEditorHandler objHandler
)
Managed Extensions for C++
public: virtual void EditValue(
   ITypeDescriptorContext* context,
   IServiceProvider* provider,
   Object* value,
   WebUITypeEditorHandler* objHandler
)
C++/CLI
public:
virtual void EditValue(
   ITypeDescriptorContext^ context,
   IServiceProvider^ provider,
   Object^ value,
   WebUITypeEditorHandler^ objHandler
)

Parameters

context
An ITypeDescriptorContext that can be used to gain additional context information.
provider
An IServiceProvider that this editor can use to obtain services.
value
The object to edit.
objHandler

Return Value

The new value of the object. If the value of the object has not changed, this should return the same object it was passed.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebUITypeEditor Class
WebUITypeEditor Members
Overload List


GetEditor Method

[image]
Gizmox.WebGUI.Forms
GetEditor Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > WebUITypeEditor Class : GetEditor Method

Gets an editor with the WebUITypeEditor base type for the specified component.

Overload List

Overload | Description
GetEditor(Object) | Gets an editor with the WebUITypeEditor base type for the specified component.
GetEditor(Object,Type) | Gets an editor with the specified base type for the specified component.
GetEditor(Type) | Returns an editor with the WebUITypeEditor base type for the specified type.
GetEditor(Type,Type) | Returns an editor with the specified base type for the specified type.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebUITypeEditor Class
WebUITypeEditor Members


GetEditor(Object) Method

[image]
Gizmox.WebGUI.Forms
GetEditor(Object) Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > WebUITypeEditor Class > GetEditor Method : GetEditor(Object) Method

objComponent
The component to get the editor for.
Gets an editor with the WebUITypeEditor base type for the specified component.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function GetEditor( _
   ByVal objComponent As Object _
) As WebUITypeEditor
Visual Basic (Usage) Copy Code
Dim objComponent As Object
Dim value As WebUITypeEditor

value = WebUITypeEditor.GetEditor(objComponent)
C#
public static WebUITypeEditor GetEditor(
   object objComponent
)
Managed Extensions for C++
public: static WebUITypeEditor* GetEditor(
   Object* objComponent
)
C++/CLI
public:
static WebUITypeEditor^ GetEditor(
   Object^ objComponent
)

Parameters

objComponent
The component to get the editor for.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebUITypeEditor Class
WebUITypeEditor Members
Overload List


GetEditor(Object,Type) Method

[image]
Gizmox.WebGUI.Forms
GetEditor(Object,Type) Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > WebUITypeEditor Class > GetEditor Method : GetEditor(Object,Type) Method

objComponent
The component to get the editor for.
objBaseType
A Type that represents the base type of the editor you want to find.
Gets an editor with the specified base type for the specified component.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function GetEditor( _
   ByVal objComponent As Object, _
   ByVal objBaseType As Type _
) As WebUITypeEditor
Visual Basic (Usage) Copy Code
Dim objComponent As Object
Dim objBaseType As Type
Dim value As WebUITypeEditor

value = WebUITypeEditor.GetEditor(objComponent, objBaseType)
C#
public static WebUITypeEditor GetEditor(
   object objComponent,
   Type objBaseType
)
Managed Extensions for C++
public: static WebUITypeEditor* GetEditor(
   Object* objComponent,
   Type* objBaseType
)
C++/CLI
public:
static WebUITypeEditor^ GetEditor(
   Object^ objComponent,
   Type^ objBaseType
)

Parameters

objComponent
The component to get the editor for.
objBaseType
A Type that represents the base type of the editor you want to find.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebUITypeEditor Class
WebUITypeEditor Members
Overload List


GetEditor(Type) Method

[image]
Gizmox.WebGUI.Forms
GetEditor(Type) Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > WebUITypeEditor Class > GetEditor Method : GetEditor(Type) Method

objType
The Type of the target component.
Returns an editor with the WebUITypeEditor base type for the specified type.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function GetEditor( _
   ByVal objType As Type _
) As WebUITypeEditor
Visual Basic (Usage) Copy Code
Dim objType As Type
Dim value As WebUITypeEditor

value = WebUITypeEditor.GetEditor(objType)
C#
public static WebUITypeEditor GetEditor(
   Type objType
)
Managed Extensions for C++
public: static WebUITypeEditor* GetEditor(
   Type* objType
)
C++/CLI
public:
static WebUITypeEditor^ GetEditor(
   Type^ objType
)

Parameters

objType
The Type of the target component.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebUITypeEditor Class
WebUITypeEditor Members
Overload List


GetEditor(Type,Type) Method

[image]
Gizmox.WebGUI.Forms
GetEditor(Type,Type) Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > WebUITypeEditor Class > GetEditor Method : GetEditor(Type,Type) Method

objType
The Type of the target component.
objBaseType
A Type that represents the base type of the editor you are trying to find.
Returns an editor with the specified base type for the specified type.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function GetEditor( _
   ByVal objType As Type, _
   ByVal objBaseType As Type _
) As WebUITypeEditor
Visual Basic (Usage) Copy Code
Dim objType As Type
Dim objBaseType As Type
Dim value As WebUITypeEditor

value = WebUITypeEditor.GetEditor(objType, objBaseType)
C#
public static WebUITypeEditor GetEditor(
   Type objType,
   Type objBaseType
)
Managed Extensions for C++
public: static WebUITypeEditor* GetEditor(
   Type* objType,
   Type* objBaseType
)
C++/CLI
public:
static WebUITypeEditor^ GetEditor(
   Type^ objType,
   Type^ objBaseType
)

Parameters

objType
The Type of the target component.
objBaseType
A Type that represents the base type of the editor you are trying to find.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebUITypeEditor Class
WebUITypeEditor Members
Overload List


GetEditorValueFromPropertyValue Method

[image]
Gizmox.WebGUI.Forms
GetEditorValueFromPropertyValue Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > WebUITypeEditor Class : GetEditorValueFromPropertyValue Method

value
The property value.
Supplies a editor level mechanism to convert property values before editing

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetEditorValueFromPropertyValue( _
   ByVal value As Object _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As WebUITypeEditor
Dim value As Object
Dim value As Object

value = instance.GetEditorValueFromPropertyValue(value)
C#
protected virtual object GetEditorValueFromPropertyValue(
   object value
)
Managed Extensions for C++
protected: virtual Object* GetEditorValueFromPropertyValue(
   Object* value
)
C++/CLI
protected:
virtual Object^ GetEditorValueFromPropertyValue(
   Object^ value
)

Parameters

value
The property value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebUITypeEditor Class
WebUITypeEditor Members


GetEditStyle Method

[image]
Gizmox.WebGUI.Forms
GetEditStyle Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > WebUITypeEditor Class : GetEditStyle Method

Gets the editor style used by the EditValue method.

Overload List

Overload | Description
GetEditStyle() | Gets the editor style used by the EditValue method.
GetEditStyle(ITypeDescriptorContext) | Gets the editor style used by the EditValue method.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebUITypeEditor Class
WebUITypeEditor Members


GetEditStyle() Method

[image]
Gizmox.WebGUI.Forms
GetEditStyle() Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > WebUITypeEditor Class > GetEditStyle Method : GetEditStyle() Method

Gets the editor style used by the EditValue method.

Syntax

Visual Basic (Declaration)
Public Overloads Function GetEditStyle() As UITypeEditorEditStyle
Visual Basic (Usage) Copy Code
Dim instance As WebUITypeEditor
Dim value As UITypeEditorEditStyle

value = instance.GetEditStyle()
C#
public UITypeEditorEditStyle GetEditStyle()
Managed Extensions for C++
public: UITypeEditorEditStyle GetEditStyle();
C++/CLI
public:
UITypeEditorEditStyle GetEditStyle();

Return Value

A UITypeEditorEditStyle enumeration value that indicates the style of editor used by the current WebUITypeEditor. By default, this method will return None.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebUITypeEditor Class
WebUITypeEditor Members
Overload List


GetEditStyle(ITypeDescriptorContext) Method

[image]
Gizmox.WebGUI.Forms
GetEditStyle(ITypeDescriptorContext) Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > WebUITypeEditor Class > GetEditStyle Method : GetEditStyle(ITypeDescriptorContext) Method

context
An ITypeDescriptorContext that can be used to gain additional context information.
Gets the editor style used by the EditValue method.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function GetEditStyle( _
   ByVal context As ITypeDescriptorContext _
) As UITypeEditorEditStyle
Visual Basic (Usage) Copy Code
Dim instance As WebUITypeEditor
Dim context As ITypeDescriptorContext
Dim value As UITypeEditorEditStyle

value = instance.GetEditStyle(context)
C#
public virtual UITypeEditorEditStyle GetEditStyle(
   ITypeDescriptorContext context
)
Managed Extensions for C++
public: virtual UITypeEditorEditStyle GetEditStyle(
   ITypeDescriptorContext* context
)
C++/CLI
public:
virtual UITypeEditorEditStyle GetEditStyle(
   ITypeDescriptorContext^ context
)

Parameters

context
An ITypeDescriptorContext that can be used to gain additional context information.

Return Value

A UITypeEditorEditStyle value that indicates the style of editor used by the EditValue method. If the WebUITypeEditor does not support this method, then WebUITypeEditor.GetEditStyle will return None.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebUITypeEditor Class
WebUITypeEditor Members
Overload List


GetPropertyEditor Method

[image]
Gizmox.WebGUI.Forms
GetPropertyEditor Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > WebUITypeEditor Class : GetPropertyEditor Method

Gets an editor from the property attributes

Overload List

Overload | Description
GetPropertyEditor(PropertyDescriptor) | Gets an editor from the property attributes
GetPropertyEditor(PropertyDescriptor,Type) | Gets a typed inherited editor from property attributes

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebUITypeEditor Class
WebUITypeEditor Members


GetPropertyEditor(PropertyDescriptor) Method

[image]
Gizmox.WebGUI.Forms
GetPropertyEditor(PropertyDescriptor) Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > WebUITypeEditor Class > GetPropertyEditor Method : GetPropertyEditor(PropertyDescriptor) Method

objPropertyInfo
Gets an editor from the property attributes

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function GetPropertyEditor( _
   ByVal objPropertyInfo As PropertyDescriptor _
) As WebUITypeEditor
Visual Basic (Usage) Copy Code
Dim objPropertyInfo As PropertyDescriptor
Dim value As WebUITypeEditor

value = WebUITypeEditor.GetPropertyEditor(objPropertyInfo)
C#
public static WebUITypeEditor GetPropertyEditor(
   PropertyDescriptor objPropertyInfo
)
Managed Extensions for C++
public: static WebUITypeEditor* GetPropertyEditor(
   PropertyDescriptor* objPropertyInfo
)
C++/CLI
public:
static WebUITypeEditor^ GetPropertyEditor(
   PropertyDescriptor^ objPropertyInfo
)

Parameters

objPropertyInfo

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebUITypeEditor Class
WebUITypeEditor Members
Overload List


GetPropertyEditor(PropertyDescriptor,Type) Method

[image]
Gizmox.WebGUI.Forms
GetPropertyEditor(PropertyDescriptor,Type) Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > WebUITypeEditor Class > GetPropertyEditor Method : GetPropertyEditor(PropertyDescriptor,Type) Method

objPropertyInfo
objBaseType
Gets a typed inherited editor from property attributes

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function GetPropertyEditor( _
   ByVal objPropertyInfo As PropertyDescriptor, _
   ByVal objBaseType As Type _
) As WebUITypeEditor
Visual Basic (Usage) Copy Code
Dim objPropertyInfo As PropertyDescriptor
Dim objBaseType As Type
Dim value As WebUITypeEditor

value = WebUITypeEditor.GetPropertyEditor(objPropertyInfo, objBaseType)
C#
public static WebUITypeEditor GetPropertyEditor(
   PropertyDescriptor objPropertyInfo,
   Type objBaseType
)
Managed Extensions for C++
public: static WebUITypeEditor* GetPropertyEditor(
   PropertyDescriptor* objPropertyInfo,
   Type* objBaseType
)
C++/CLI
public:
static WebUITypeEditor^ GetPropertyEditor(
   PropertyDescriptor^ objPropertyInfo,
   Type^ objBaseType
)

Parameters

objPropertyInfo
objBaseType

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebUITypeEditor Class
WebUITypeEditor Members
Overload List


GetPropertyValueFromEditorValue Method

[image]
Gizmox.WebGUI.Forms
GetPropertyValueFromEditorValue Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > WebUITypeEditor Class : GetPropertyValueFromEditorValue Method

value
The editor returned value.
Supplies a editor level mechanism to convert editor returned values before assigning to property

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetPropertyValueFromEditorValue( _
   ByVal value As Object _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As WebUITypeEditor
Dim value As Object
Dim value As Object

value = instance.GetPropertyValueFromEditorValue(value)
C#
protected virtual object GetPropertyValueFromEditorValue(
   object value
)
Managed Extensions for C++
protected: virtual Object* GetPropertyValueFromEditorValue(
   Object* value
)
C++/CLI
protected:
virtual Object^ GetPropertyValueFromEditorValue(
   Object^ value
)

Parameters

value
The editor returned value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebUITypeEditor Class
WebUITypeEditor Members


OnValueChangeError Method

[image]
Gizmox.WebGUI.Forms
OnValueChangeError Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > WebUITypeEditor Class : OnValueChangeError Method

objException
Raise error on value change

Syntax

Visual Basic (Declaration)
Protected Sub OnValueChangeError( _
   ByVal objException As Exception _
)
Visual Basic (Usage) Copy Code
Dim instance As WebUITypeEditor
Dim objException As Exception

instance.OnValueChangeError(objException)
C#
protected void OnValueChangeError(
   Exception objException
)
Managed Extensions for C++
protected: void OnValueChangeError(
   Exception* objException
)
C++/CLI
protected:
void OnValueChangeError(
   Exception^ objException
)

Parameters

objException

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebUITypeEditor Class
WebUITypeEditor Members


ValidatePropertyValue Method

[image]
Gizmox.WebGUI.Forms
ValidatePropertyValue Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > WebUITypeEditor Class : ValidatePropertyValue Method

value
Validated property value

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ValidatePropertyValue( _
   ByVal value As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebUITypeEditor
Dim value As Object

instance.ValidatePropertyValue(value)
C#
protected virtual void ValidatePropertyValue(
   object value
)
Managed Extensions for C++
protected: virtual void ValidatePropertyValue(
   Object* value
)
C++/CLI
protected:
virtual void ValidatePropertyValue(
   Object^ value
)

Parameters

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebUITypeEditor Class
WebUITypeEditor Members


WebUITypeEditor Class Properties

[image]
Gizmox.WebGUI.Forms
WebUITypeEditor Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace : WebUITypeEditor Class

For a list of all members of this type, see WebUITypeEditor members.

Public Properties

 | Name | Description
Public Property | IsDropDownResizable | Gets a value indicating whether drop-down editors should be resizable by the user.
Public Property | IsTextEditable | Gets a value indicating whether this editor value should support text editing.
Top

See Also

Reference

WebUITypeEditor Class
Gizmox.WebGUI.Forms.Design Namespace


IsDropDownResizable Property

[image]
Gizmox.WebGUI.Forms
IsDropDownResizable Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > WebUITypeEditor Class : IsDropDownResizable Property

Gets a value indicating whether drop-down editors should be resizable by the user.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property IsDropDownResizable As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebUITypeEditor
Dim value As Boolean

value = instance.IsDropDownResizable
C#
public virtual bool IsDropDownResizable {get;}
Managed Extensions for C++
public: __property virtual bool get_IsDropDownResizable();
C++/CLI
public:
virtual property bool IsDropDownResizable {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebUITypeEditor Class
WebUITypeEditor Members


IsTextEditable Property

[image]
Gizmox.WebGUI.Forms
IsTextEditable Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > WebUITypeEditor Class : IsTextEditable Property

Gets a value indicating whether this editor value should support text editing.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property IsTextEditable As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebUITypeEditor
Dim value As Boolean

value = instance.IsTextEditable
C#
public virtual bool IsTextEditable {get;}
Managed Extensions for C++
public: __property virtual bool get_IsTextEditable();
C++/CLI
public:
virtual property bool IsTextEditable {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebUITypeEditor Class
WebUITypeEditor Members


IWebUIEditorService Interface

[image]
Gizmox.WebGUI.Forms
IWebUIEditorService Interface
Members See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace : IWebUIEditorService Interface

Provides an interface for a WebUITypeEditor to display Windows Forms or to display a control in a drop-down area from a property grid control in design mode.

Syntax

Visual Basic (Declaration)
Public Interface IWebUIEditorService
Visual Basic (Usage) Copy Code
Dim instance As IWebUIEditorService
C#
public interface IWebUIEditorService
Managed Extensions for C++
public __gc __interface IWebUIEditorService
C++/CLI
public interface class IWebUIEditorService

Requirements

Namespace: Gizmox.WebGUI.Forms.Design

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

IWebUIEditorService Members
Gizmox.WebGUI.Forms.Design Namespace


IWebUIEditorService Interface Members

[image]
Gizmox.WebGUI.Forms
IWebUIEditorService Interface Members
See Also Methods Send Feedback
Gizmox.WebGUI.Forms.Design Namespace : IWebUIEditorService Interface

The following tables list the members exposed by IWebUIEditorService.

Public Methods

 | Name | Description
Method | CloseDropDown | Closes any previously opened drop down control area.
Method | ShowDialog | Overloaded.
Method | ShowDropDown | Displays the specified control in a drop down area below a value field of the property grid that provides this service.
Top

See Also

Reference

IWebUIEditorService Interface
Gizmox.WebGUI.Forms.Design Namespace


IWebUIEditorService Interface Methods

[image]
Gizmox.WebGUI.Forms
IWebUIEditorService Interface Methods
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace : IWebUIEditorService Interface

For a list of all members of this type, see IWebUIEditorService members.

Public Methods

 | Name | Description
Method | CloseDropDown | Closes any previously opened drop down control area.
Method | ShowDialog | Overloaded.
Method | ShowDropDown | Displays the specified control in a drop down area below a value field of the property grid that provides this service.
Top

See Also

Reference

IWebUIEditorService Interface
Gizmox.WebGUI.Forms.Design Namespace


CloseDropDown Method

[image]
Gizmox.WebGUI.Forms
CloseDropDown Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > IWebUIEditorService Interface : CloseDropDown Method

Closes any previously opened drop down control area.

Syntax

Visual Basic (Declaration)
Sub CloseDropDown()
Visual Basic (Usage) Copy Code
Dim instance As IWebUIEditorService

instance.CloseDropDown()
C#
void CloseDropDown()
Managed Extensions for C++
void CloseDropDown();
C++/CLI
void CloseDropDown();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IWebUIEditorService Interface
IWebUIEditorService Members


ShowDialog Method

[image]
Gizmox.WebGUI.Forms
ShowDialog Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > IWebUIEditorService Interface : ShowDialog Method

Overload List

Overload | Description
ShowDialog(Form) | Shows the specified Form.
ShowDialog(CommonDialog) | Shows the specified CommonDialog.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IWebUIEditorService Interface
IWebUIEditorService Members


ShowDialog(Form) Method

[image]
Gizmox.WebGUI.Forms
ShowDialog(Form) Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > IWebUIEditorService Interface > ShowDialog Method : ShowDialog(Form) Method

dialog
The Form to display.
Shows the specified Form.

Syntax

Visual Basic (Declaration)
Overloads Sub ShowDialog( _
   ByVal dialog As Form _
)
Visual Basic (Usage) Copy Code
Dim instance As IWebUIEditorService
Dim dialog As Form

instance.ShowDialog(dialog)
C#
void ShowDialog(
   Form dialog
)
Managed Extensions for C++
void ShowDialog(
   Form* dialog
)
C++/CLI
void ShowDialog(
   Form^ dialog
)

Parameters

dialog
The Form to display.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IWebUIEditorService Interface
IWebUIEditorService Members
Overload List


ShowDialog(CommonDialog) Method

[image]
Gizmox.WebGUI.Forms
ShowDialog(CommonDialog) Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > IWebUIEditorService Interface > ShowDialog Method : ShowDialog(CommonDialog) Method

dialog
The CommonDialog to display.
Shows the specified CommonDialog.

Syntax

Visual Basic (Declaration)
Overloads Sub ShowDialog( _
   ByVal dialog As CommonDialog _
)
Visual Basic (Usage) Copy Code
Dim instance As IWebUIEditorService
Dim dialog As CommonDialog

instance.ShowDialog(dialog)
C#
void ShowDialog(
   CommonDialog dialog
)
Managed Extensions for C++
void ShowDialog(
   CommonDialog* dialog
)
C++/CLI
void ShowDialog(
   CommonDialog^ dialog
)

Parameters

dialog
The CommonDialog to display.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IWebUIEditorService Interface
IWebUIEditorService Members
Overload List


ShowDropDown Method

[image]
Gizmox.WebGUI.Forms
ShowDropDown Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > IWebUIEditorService Interface : ShowDropDown Method

dialog
Displays the specified control in a drop down area below a value field of the property grid that provides this service.

Syntax

Visual Basic (Declaration)
Sub ShowDropDown( _
   ByVal dialog As Form _
)
Visual Basic (Usage) Copy Code
Dim instance As IWebUIEditorService
Dim dialog As Form

instance.ShowDropDown(dialog)
C#
void ShowDropDown(
   Form dialog
)
Managed Extensions for C++
void ShowDropDown(
   Form* dialog
)
C++/CLI
void ShowDropDown(
   Form^ dialog
)

Parameters

dialog

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IWebUIEditorService Interface
IWebUIEditorService Members


WebUITypeEditorHandler Delegate

[image]
Gizmox.WebGUI.Forms
WebUITypeEditorHandler Delegate
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace : WebUITypeEditorHandler Delegate

value

Syntax

Visual Basic (Declaration)
Public Delegate Sub WebUITypeEditorHandler( _
   ByVal value As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As New WebUITypeEditorHandler(AddressOf HandlerMethod)
C#
public delegate void WebUITypeEditorHandler(
   object value
)
Managed Extensions for C++
public: __gc __delegate void WebUITypeEditorHandler(
   Object* value
)
C++/CLI
public delegate void WebUITypeEditorHandler(
   Object^ value
)

Parameters

value

Requirements

Namespace: Gizmox.WebGUI.Forms.Design

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms.Design Namespace


Gizmox.WebGUI.Forms.Dialogs Namespace

Gizmox.WebGUI.Forms.Dialogs Namespace
See Also Inheritance Hierarchy Send Feedback

Classes

 | Class | Description
Class | ListViewColumnOptions | The columens options dialog
Class | ListViewGroupingOptions | Represents a window or dialog box that makes up an application's user interface.
Class | ListViewSortingOptions | Represents a window or dialog box that makes up an application's user interface.
Class | TraceViewer | Summary description for TraceViewer.

See Also

Reference

Gizmox.WebGUI.Forms Assembly


ListViewColumnOptions Class

[image]
Gizmox.WebGUI.Forms
ListViewColumnOptions Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms.Dialogs Namespace : ListViewColumnOptions Class

The columens options dialog

Object Model

Syntax

Visual Basic (Declaration)
Public Class ListViewColumnOptions
   Inherits Form
   Implements IAttributeExtender, IControl, IEventHandler, IForm, IGatewayComponent, IObservableItem, IObservableLayoutItem, IObservableList, IRegisteredComponent, IRenderableComponent, IBindableComponent, IContainerControl, IArrangedElement
Visual Basic (Usage) Copy Code
Dim instance As ListViewColumnOptions
C#
public class ListViewColumnOptions : Form, IAttributeExtender, IControl, IEventHandler, IForm, IGatewayComponent, IObservableItem, IObservableLayoutItem, IObservableList, IRegisteredComponent, IRenderableComponent, IBindableComponent, IContainerControl, IArrangedElement
Managed Extensions for C++
public __gc class ListViewColumnOptions : public Form, IAttributeExtender, IControl, IEventHandler, IForm, IGatewayComponent, IObservableItem, IObservableLayoutItem, IObservableList, IRegisteredComponent, IRenderableComponent, IBindableComponent, IContainerControl, IArrangedElement
C++/CLI
public ref class ListViewColumnOptions : public Form, IAttributeExtender, IControl, IEventHandler, IForm, IGatewayComponent, IObservableItem, IObservableLayoutItem, IObservableList, IRegisteredComponent, IRenderableComponent, IBindableComponent, IContainerControl, IArrangedElement

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.ScrollableControl
Gizmox.WebGUI.Forms.ContainerControl
Gizmox.WebGUI.Forms.Form
Gizmox.WebGUI.Forms.Dialogs.ListViewColumnOptions

Requirements

Namespace: Gizmox.WebGUI.Forms.Dialogs

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

ListViewColumnOptions Members
Gizmox.WebGUI.Forms.Dialogs Namespace


ListViewColumnOptions Class Members

[image]
Gizmox.WebGUI.Forms
ListViewColumnOptions Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms.Dialogs Namespace : ListViewColumnOptions Class

The following tables list the members exposed by ListViewColumnOptions.

Public Constructors

 | Name | Description
Public Constructor | ListViewColumnOptions Constructor | Creates a new ListViewColumnOptions instance.
Top

Public Properties

 | Name | Description
Public Property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | ActiveControl | Gets or sets the active control on the container control. (Inherited from Gizmox.WebGUI.Forms.ContainerControl)
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | AutoScaleBaseSize | Gets or sets the size of the auto scale base. Not implemented. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Public Property | BackColor | Gets or sets the background color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BeforeUnloadMessage | Gets or sets the before unload message. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | BindingContext | (Inherited from Gizmox.WebGUI.Forms.ContainerControl)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CancelButton | Gets or sets the button on the form that is clicked when the user presses the ESC key. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Components | (Inherited from Gizmox.WebGUI.Forms.ContainerControl)
Public Property | Container | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Context | Gets the context. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | DialogResult | Gets or sets the dialog result. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Public Property | DragMappings | Gets the form drag mappings. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Form | Gets the owner form. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | FormBorderStyle | Gets or sets the form border style. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | FormStyle | Gets or sets the form style. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | HasControls | Gets a value indicating whether this control has controls. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Header | Gets or sets the form header control. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Height | Gets/Sets the height position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Icon | Gets or sets the form icon (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | IsRegistered | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Left | Gets/Sets the left position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Location | Gets or sets the control location. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | MaximizeBox | Gets or sets a value indicating whether [maximize box]. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | MinimizeBox | Gets or sets a value indicating whether [minimize box]. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Modal | Gets or sets a value indicating whether this window is modal. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | OwnedForms | Gets the child forms. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Owner | Gets the parent window. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Padding | Gets or sets the control padding. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Right | Gets/Sets the right position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ShowInTaskbar | Gets or sets a value indicating whether [show in taskbar]. Not implemented by design (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Site | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | StartPosition | Gets or sets the form start position. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Top | Gets/Sets the top position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Visible | Get/Sets the form visibility (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Width | Gets/Sets the width position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | WindowState | Gets or sets the state of the window. (Inherited from Gizmox.WebGUI.Forms.Form)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultBorderColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultBorderStyle | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultForeColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMargin | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultPadding | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DesignMode | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | Events | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Protected Property | IsConnected | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Property | IsDelayedDrawing | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | IsWindowSized | Calculate size invluding borders (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | Session | Gets or sets the main form. (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Top

Public Methods

 | Name | Description
Public Method | Add | (Inherited from Gizmox.WebGUI.Forms.ContainerControl)
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Close | Closes this window. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Gizmox.WebGUI.Forms.ContainerControl)
Public Method | Focus | Sets focus to this control (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | GetPreferredSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Remove | (Inherited from Gizmox.WebGUI.Forms.ContainerControl)
Public Method | ResetText | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Public Method | Select | Overloaded. Activates the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SendToBack | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Show | (Inherited from Gizmox.WebGUI.Forms.Form)
Public Method | ShowDialog | Overloaded. Shows a the form as a dialog. The ShowDialog in Visual WebGui works differently than WinForms. Code lines after this call is executed immediately and won’t wait for the dialog to close. If you need to run code only after the dialog is closed or only if a specific result is returned register to the close event of the dialog. See documentation for code example. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Method | ShowPopup | Overloaded. Displays the form as a popup window. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ToString | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Update | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | Finalize | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCommandText | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetImage | Gets the image. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetPreferredSizeCore | (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Protected Method | GetService | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | InvokeMethod | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | IsDirty | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | OnActivated | Raises the Activated event. (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBindingContextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnClosed | (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnClosing | (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnControlAdded | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnControlRemoved | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnCreateControl | Occurs when control is created (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | OnEnabledChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnGotFocus | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLoad | Raises the Load event. (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnLocationChanged | (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnLostFocus | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentVisibleChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnResize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnTextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnUnregisterComponents | (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnValidated | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnValidating | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ProcessGatewayRequest | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RegisterSelf | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | Render | Render the form content (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | RenderAttributes | Renders the forms attribute (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderClientUpdateHandler | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderComponentEventAttributes | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderUpdatedAttributes | (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetImage | Sets the image. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeText | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | UnRegisterBatch | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | UnRegisterSelf | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | UpdateParams | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Top

Public Events

 | Name | Description
Public Event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Closed | (Inherited from Gizmox.WebGUI.Forms.Form)
Public Event | Closing | The form closing event. This event is not raised on the main form. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Disposed | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Load | The form load event (Inherited from Gizmox.WebGUI.Forms.Form)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Gizmox.WebGUI.Forms.Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Top

See Also

Reference

ListViewColumnOptions Class
Gizmox.WebGUI.Forms.Dialogs Namespace


ListViewColumnOptions Constructor

[image]
Gizmox.WebGUI.Forms
ListViewColumnOptions Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms.Dialogs Namespace > ListViewColumnOptions Class : ListViewColumnOptions Constructor

objListView
List view.
Creates a new ListViewColumnOptions instance.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal objListView As ListView _
)
Visual Basic (Usage) Copy Code
Dim objListView As ListView

Dim instance As ListViewColumnOptions(objListView)
C#
public ListViewColumnOptions(
   ListView objListView
)
Managed Extensions for C++
public: ListViewColumnOptions(
   ListView* objListView
)
C++/CLI
public:
ListViewColumnOptions(
   ListView^ objListView
)

Parameters

objListView
List view.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListViewColumnOptions Class
ListViewColumnOptions Members


ListViewGroupingOptions Class

[image]
Gizmox.WebGUI.Forms
ListViewGroupingOptions Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms.Dialogs Namespace : ListViewGroupingOptions Class

Represents a window or dialog box that makes up an application's user interface.

Object Model

Syntax

Visual Basic (Declaration)
Public Class ListViewGroupingOptions
   Inherits Form
   Implements IAttributeExtender, IControl, IEventHandler, IForm, IGatewayComponent, IObservableItem, IObservableLayoutItem, IObservableList, IRegisteredComponent, IRenderableComponent, IBindableComponent, IContainerControl, IArrangedElement
Visual Basic (Usage) Copy Code
Dim instance As ListViewGroupingOptions
C#
public class ListViewGroupingOptions : Form, IAttributeExtender, IControl, IEventHandler, IForm, IGatewayComponent, IObservableItem, IObservableLayoutItem, IObservableList, IRegisteredComponent, IRenderableComponent, IBindableComponent, IContainerControl, IArrangedElement
Managed Extensions for C++
public __gc class ListViewGroupingOptions : public Form, IAttributeExtender, IControl, IEventHandler, IForm, IGatewayComponent, IObservableItem, IObservableLayoutItem, IObservableList, IRegisteredComponent, IRenderableComponent, IBindableComponent, IContainerControl, IArrangedElement
C++/CLI
public ref class ListViewGroupingOptions : public Form, IAttributeExtender, IControl, IEventHandler, IForm, IGatewayComponent, IObservableItem, IObservableLayoutItem, IObservableList, IRegisteredComponent, IRenderableComponent, IBindableComponent, IContainerControl, IArrangedElement

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.ScrollableControl
Gizmox.WebGUI.Forms.ContainerControl
Gizmox.WebGUI.Forms.Form
Gizmox.WebGUI.Forms.Dialogs.ListViewGroupingOptions

Requirements

Namespace: Gizmox.WebGUI.Forms.Dialogs

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

ListViewGroupingOptions Members
Gizmox.WebGUI.Forms.Dialogs Namespace


ListViewGroupingOptions Class Members

[image]
Gizmox.WebGUI.Forms
ListViewGroupingOptions Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms.Dialogs Namespace : ListViewGroupingOptions Class

The following tables list the members exposed by ListViewGroupingOptions.

Public Constructors

 | Name | Description
Public Constructor | ListViewGroupingOptions Constructor | Creates a new ListViewGroupingOptions instance.
Top

Public Properties

 | Name | Description
Public Property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | ActiveControl | Gets or sets the active control on the container control. (Inherited from Gizmox.WebGUI.Forms.ContainerControl)
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | AutoScaleBaseSize | Gets or sets the size of the auto scale base. Not implemented. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Public Property | BackColor | Gets or sets the background color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BeforeUnloadMessage | Gets or sets the before unload message. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | BindingContext | (Inherited from Gizmox.WebGUI.Forms.ContainerControl)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CancelButton | Gets or sets the button on the form that is clicked when the user presses the ESC key. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Components | (Inherited from Gizmox.WebGUI.Forms.ContainerControl)
Public Property | Container | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Context | Gets the context. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | DialogResult | Gets or sets the dialog result. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Public Property | DragMappings | Gets the form drag mappings. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Form | Gets the owner form. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | FormBorderStyle | Gets or sets the form border style. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | FormStyle | Gets or sets the form style. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | HasControls | Gets a value indicating whether this control has controls. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Header | Gets or sets the form header control. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Height | Gets/Sets the height position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Icon | Gets or sets the form icon (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | IsRegistered | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Left | Gets/Sets the left position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Location | Gets or sets the control location. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | MaximizeBox | Gets or sets a value indicating whether [maximize box]. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | MinimizeBox | Gets or sets a value indicating whether [minimize box]. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Modal | Gets or sets a value indicating whether this window is modal. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | OwnedForms | Gets the child forms. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Owner | Gets the parent window. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Padding | Gets or sets the control padding. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Right | Gets/Sets the right position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ShowInTaskbar | Gets or sets a value indicating whether [show in taskbar]. Not implemented by design (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Site | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | StartPosition | Gets or sets the form start position. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Top | Gets/Sets the top position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Visible | Get/Sets the form visibility (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Width | Gets/Sets the width position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | WindowState | Gets or sets the state of the window. (Inherited from Gizmox.WebGUI.Forms.Form)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultBorderColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultBorderStyle | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultForeColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMargin | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultPadding | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DesignMode | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | Events | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Protected Property | IsConnected | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Property | IsDelayedDrawing | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | IsWindowSized | Calculate size invluding borders (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | Session | Gets or sets the main form. (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Top

Public Methods

 | Name | Description
Public Method | Add | (Inherited from Gizmox.WebGUI.Forms.ContainerControl)
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Close | Closes this window. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Gizmox.WebGUI.Forms.ContainerControl)
Public Method | Focus | Sets focus to this control (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | GetPreferredSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Remove | (Inherited from Gizmox.WebGUI.Forms.ContainerControl)
Public Method | ResetText | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Public Method | Select | Overloaded. Activates the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SendToBack | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Show | (Inherited from Gizmox.WebGUI.Forms.Form)
Public Method | ShowDialog | Overloaded. Shows a the form as a dialog. The ShowDialog in Visual WebGui works differently than WinForms. Code lines after this call is executed immediately and won’t wait for the dialog to close. If you need to run code only after the dialog is closed or only if a specific result is returned register to the close event of the dialog. See documentation for code example. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Method | ShowPopup | Overloaded. Displays the form as a popup window. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ToString | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Update | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | Finalize | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCommandText | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetImage | Gets the image. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetPreferredSizeCore | (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Protected Method | GetService | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | InvokeMethod | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | IsDirty | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | OnActivated | Raises the Activated event. (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBindingContextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnClosed | (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnClosing | (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnControlAdded | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnControlRemoved | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnCreateControl | Occurs when control is created (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | OnEnabledChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnGotFocus | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLoad | Raises the Load event. (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnLocationChanged | (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnLostFocus | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentVisibleChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnResize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnTextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnUnregisterComponents | (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnValidated | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnValidating | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ProcessGatewayRequest | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RegisterSelf | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | Render | Render the form content (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | RenderAttributes | Renders the forms attribute (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderClientUpdateHandler | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderComponentEventAttributes | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderUpdatedAttributes | (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetImage | Sets the image. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeText | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | UnRegisterBatch | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | UnRegisterSelf | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | UpdateParams | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Top

Public Events

 | Name | Description
Public Event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Closed | (Inherited from Gizmox.WebGUI.Forms.Form)
Public Event | Closing | The form closing event. This event is not raised on the main form. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Disposed | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Load | The form load event (Inherited from Gizmox.WebGUI.Forms.Form)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Gizmox.WebGUI.Forms.Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Top

See Also

Reference

ListViewGroupingOptions Class
Gizmox.WebGUI.Forms.Dialogs Namespace


ListViewGroupingOptions Constructor

[image]
Gizmox.WebGUI.Forms
ListViewGroupingOptions Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms.Dialogs Namespace > ListViewGroupingOptions Class : ListViewGroupingOptions Constructor

objListView
Creates a new ListViewGroupingOptions instance.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal objListView As ListView _
)
Visual Basic (Usage) Copy Code
Dim objListView As ListView

Dim instance As ListViewGroupingOptions(objListView)
C#
public ListViewGroupingOptions(
   ListView objListView
)
Managed Extensions for C++
public: ListViewGroupingOptions(
   ListView* objListView
)
C++/CLI
public:
ListViewGroupingOptions(
   ListView^ objListView
)

Parameters

objListView

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListViewGroupingOptions Class
ListViewGroupingOptions Members


ListViewSortingOptions Class

[image]
Gizmox.WebGUI.Forms
ListViewSortingOptions Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms.Dialogs Namespace : ListViewSortingOptions Class

Represents a window or dialog box that makes up an application's user interface.

Object Model

Syntax

Visual Basic (Declaration)
Public Class ListViewSortingOptions
   Inherits Form
   Implements IAttributeExtender, IControl, IEventHandler, IForm, IGatewayComponent, IObservableItem, IObservableLayoutItem, IObservableList, IRegisteredComponent, IRenderableComponent, IBindableComponent, IContainerControl, IArrangedElement
Visual Basic (Usage) Copy Code
Dim instance As ListViewSortingOptions
C#
public class ListViewSortingOptions : Form, IAttributeExtender, IControl, IEventHandler, IForm, IGatewayComponent, IObservableItem, IObservableLayoutItem, IObservableList, IRegisteredComponent, IRenderableComponent, IBindableComponent, IContainerControl, IArrangedElement
Managed Extensions for C++
public __gc class ListViewSortingOptions : public Form, IAttributeExtender, IControl, IEventHandler, IForm, IGatewayComponent, IObservableItem, IObservableLayoutItem, IObservableList, IRegisteredComponent, IRenderableComponent, IBindableComponent, IContainerControl, IArrangedElement
C++/CLI
public ref class ListViewSortingOptions : public Form, IAttributeExtender, IControl, IEventHandler, IForm, IGatewayComponent, IObservableItem, IObservableLayoutItem, IObservableList, IRegisteredComponent, IRenderableComponent, IBindableComponent, IContainerControl, IArrangedElement

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.ScrollableControl
Gizmox.WebGUI.Forms.ContainerControl
Gizmox.WebGUI.Forms.Form
Gizmox.WebGUI.Forms.Dialogs.ListViewSortingOptions

Requirements

Namespace: Gizmox.WebGUI.Forms.Dialogs

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

ListViewSortingOptions Members
Gizmox.WebGUI.Forms.Dialogs Namespace


ListViewSortingOptions Class Members

[image]
Gizmox.WebGUI.Forms
ListViewSortingOptions Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms.Dialogs Namespace : ListViewSortingOptions Class

The following tables list the members exposed by ListViewSortingOptions.

Public Constructors

 | Name | Description
Public Constructor | ListViewSortingOptions Constructor | Creates a new ListViewSortingOptions instance.
Top

Public Properties

 | Name | Description
Public Property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | ActiveControl | Gets or sets the active control on the container control. (Inherited from Gizmox.WebGUI.Forms.ContainerControl)
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | AutoScaleBaseSize | Gets or sets the size of the auto scale base. Not implemented. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Public Property | BackColor | Gets or sets the background color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BeforeUnloadMessage | Gets or sets the before unload message. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | BindingContext | (Inherited from Gizmox.WebGUI.Forms.ContainerControl)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CancelButton | Gets or sets the button on the form that is clicked when the user presses the ESC key. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Components | (Inherited from Gizmox.WebGUI.Forms.ContainerControl)
Public Property | Container | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Context | Gets the context. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | DialogResult | Gets or sets the dialog result. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Public Property | DragMappings | Gets the form drag mappings. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Form | Gets the owner form. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | FormBorderStyle | Gets or sets the form border style. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | FormStyle | Gets or sets the form style. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | HasControls | Gets a value indicating whether this control has controls. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Header | Gets or sets the form header control. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Height | Gets/Sets the height position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Icon | Gets or sets the form icon (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | IsRegistered | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Left | Gets/Sets the left position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Location | Gets or sets the control location. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | MaximizeBox | Gets or sets a value indicating whether [maximize box]. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | MinimizeBox | Gets or sets a value indicating whether [minimize box]. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Modal | Gets or sets a value indicating whether this window is modal. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | OwnedForms | Gets the child forms. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Owner | Gets the parent window. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Padding | Gets or sets the control padding. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Right | Gets/Sets the right position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ShowInTaskbar | Gets or sets a value indicating whether [show in taskbar]. Not implemented by design (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Site | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | StartPosition | Gets or sets the form start position. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Top | Gets/Sets the top position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Visible | Get/Sets the form visibility (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Width | Gets/Sets the width position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | WindowState | Gets or sets the state of the window. (Inherited from Gizmox.WebGUI.Forms.Form)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultBorderColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultBorderStyle | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultForeColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMargin | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultPadding | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DesignMode | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | Events | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Protected Property | IsConnected | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Property | IsDelayedDrawing | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | IsWindowSized | Calculate size invluding borders (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | Session | Gets or sets the main form. (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Top

Public Methods

 | Name | Description
Public Method | Add | (Inherited from Gizmox.WebGUI.Forms.ContainerControl)
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Close | Closes this window. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Gizmox.WebGUI.Forms.ContainerControl)
Public Method | Focus | Sets focus to this control (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | GetPreferredSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Remove | (Inherited from Gizmox.WebGUI.Forms.ContainerControl)
Public Method | ResetText | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Public Method | Select | Overloaded. Activates the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SendToBack | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Show | (Inherited from Gizmox.WebGUI.Forms.Form)
Public Method | ShowDialog | Overloaded. Shows a the form as a dialog. The ShowDialog in Visual WebGui works differently than WinForms. Code lines after this call is executed immediately and won’t wait for the dialog to close. If you need to run code only after the dialog is closed or only if a specific result is returned register to the close event of the dialog. See documentation for code example. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Method | ShowPopup | Overloaded. Displays the form as a popup window. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ToString | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Update | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | Finalize | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCommandText | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetImage | Gets the image. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetPreferredSizeCore | (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Protected Method | GetService | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | InvokeMethod | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | IsDirty | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | OnActivated | Raises the Activated event. (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBindingContextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnClosed | (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnClosing | (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnControlAdded | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnControlRemoved | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnCreateControl | Occurs when control is created (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | OnEnabledChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnGotFocus | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLoad | Raises the Load event. (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnLocationChanged | (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnLostFocus | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentVisibleChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnResize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnTextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnUnregisterComponents | (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnValidated | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnValidating | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ProcessGatewayRequest | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RegisterSelf | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | Render | Render the form content (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | RenderAttributes | Renders the forms attribute (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderClientUpdateHandler | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderComponentEventAttributes | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderUpdatedAttributes | (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetImage | Sets the image. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeText | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | UnRegisterBatch | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | UnRegisterSelf | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | UpdateParams | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Top

Public Events

 | Name | Description
Public Event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Closed | (Inherited from Gizmox.WebGUI.Forms.Form)
Public Event | Closing | The form closing event. This event is not raised on the main form. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Disposed | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Load | The form load event (Inherited from Gizmox.WebGUI.Forms.Form)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Gizmox.WebGUI.Forms.Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Top

See Also

Reference

ListViewSortingOptions Class
Gizmox.WebGUI.Forms.Dialogs Namespace


ListViewSortingOptions Constructor

[image]
Gizmox.WebGUI.Forms
ListViewSortingOptions Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms.Dialogs Namespace > ListViewSortingOptions Class : ListViewSortingOptions Constructor

objListView
Creates a new ListViewSortingOptions instance.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal objListView As ListView _
)
Visual Basic (Usage) Copy Code
Dim objListView As ListView

Dim instance As ListViewSortingOptions(objListView)
C#
public ListViewSortingOptions(
   ListView objListView
)
Managed Extensions for C++
public: ListViewSortingOptions(
   ListView* objListView
)
C++/CLI
public:
ListViewSortingOptions(
   ListView^ objListView
)

Parameters

objListView

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ListViewSortingOptions Class
ListViewSortingOptions Members


TraceViewer Class

[image]
Gizmox.WebGUI.Forms
TraceViewer Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms.Dialogs Namespace : TraceViewer Class

Summary description for TraceViewer.

Object Model

Syntax

Visual Basic (Declaration)
Public Class TraceViewer
   Inherits Form
   Implements IAttributeExtender, IControl, IEventHandler, IForm, IGatewayComponent, IObservableItem, IObservableLayoutItem, IObservableList, IRegisteredComponent, IRenderableComponent, IBindableComponent, IContainerControl, IArrangedElement
Visual Basic (Usage) Copy Code
Dim instance As TraceViewer
C#
public class TraceViewer : Form, IAttributeExtender, IControl, IEventHandler, IForm, IGatewayComponent, IObservableItem, IObservableLayoutItem, IObservableList, IRegisteredComponent, IRenderableComponent, IBindableComponent, IContainerControl, IArrangedElement
Managed Extensions for C++
public __gc class TraceViewer : public Form, IAttributeExtender, IControl, IEventHandler, IForm, IGatewayComponent, IObservableItem, IObservableLayoutItem, IObservableList, IRegisteredComponent, IRenderableComponent, IBindableComponent, IContainerControl, IArrangedElement
C++/CLI
public ref class TraceViewer : public Form, IAttributeExtender, IControl, IEventHandler, IForm, IGatewayComponent, IObservableItem, IObservableLayoutItem, IObservableList, IRegisteredComponent, IRenderableComponent, IBindableComponent, IContainerControl, IArrangedElement

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.ScrollableControl
Gizmox.WebGUI.Forms.ContainerControl
Gizmox.WebGUI.Forms.Form
Gizmox.WebGUI.Forms.Dialogs.TraceViewer

Requirements

Namespace: Gizmox.WebGUI.Forms.Dialogs

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

TraceViewer Members
Gizmox.WebGUI.Forms.Dialogs Namespace


TraceViewer Class Members

[image]
Gizmox.WebGUI.Forms
TraceViewer Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms.Dialogs Namespace : TraceViewer Class

The following tables list the members exposed by TraceViewer.

Public Constructors

 | Name | Description
Public Constructor | TraceViewer Constructor |
Top

Public Properties

 | Name | Description
Public Property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | ActiveControl | Gets or sets the active control on the container control. (Inherited from Gizmox.WebGUI.Forms.ContainerControl)
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | AutoScaleBaseSize | Gets or sets the size of the auto scale base. Not implemented. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Public Property | BackColor | Gets or sets the background color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BeforeUnloadMessage | Gets or sets the before unload message. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | BindingContext | (Inherited from Gizmox.WebGUI.Forms.ContainerControl)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CancelButton | Gets or sets the button on the form that is clicked when the user presses the ESC key. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Components | (Inherited from Gizmox.WebGUI.Forms.ContainerControl)
Public Property | Container | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Context | Gets the context. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | DialogResult | Gets or sets the dialog result. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Public Property | DragMappings | Gets the form drag mappings. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Form | Gets the owner form. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | FormBorderStyle | Gets or sets the form border style. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | FormStyle | Gets or sets the form style. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | HasControls | Gets a value indicating whether this control has controls. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Header | Gets or sets the form header control. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Height | Gets/Sets the height position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Icon | Gets or sets the form icon (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | IsRegistered | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Left | Gets/Sets the left position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Location | Gets or sets the control location. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | MaximizeBox | Gets or sets a value indicating whether [maximize box]. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | MinimizeBox | Gets or sets a value indicating whether [minimize box]. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Modal | Gets or sets a value indicating whether this window is modal. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | OwnedForms | Gets the child forms. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Owner | Gets the parent window. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Padding | Gets or sets the control padding. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Right | Gets/Sets the right position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ShowInTaskbar | Gets or sets a value indicating whether [show in taskbar]. Not implemented by design (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Site | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | StartPosition | Gets or sets the form start position. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Top | Gets/Sets the top position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Visible | Get/Sets the form visibility (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Width | Gets/Sets the width position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | WindowState | Gets or sets the state of the window. (Inherited from Gizmox.WebGUI.Forms.Form)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultBorderColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultBorderStyle | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultForeColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMargin | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultPadding | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DesignMode | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | Events | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Protected Property | IsConnected | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Property | IsDelayedDrawing | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | IsWindowSized | Calculate size invluding borders (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | Session | Gets or sets the main form. (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Top

Public Methods

 | Name | Description
Public Method | Add | (Inherited from Gizmox.WebGUI.Forms.ContainerControl)
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Close | Closes this window. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Dispose | Overloaded. Clean up any resources being used.
Public Method | Focus | Sets focus to this control (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | GetPreferredSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Remove | (Inherited from Gizmox.WebGUI.Forms.ContainerControl)
Public Method | ResetText | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Public Method | Select | Overloaded. Activates the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SendToBack | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Show | (Inherited from Gizmox.WebGUI.Forms.Form)
Public Method | ShowDialog | Overloaded. Shows a the form as a dialog. The ShowDialog in Visual WebGui works differently than WinForms. Code lines after this call is executed immediately and won’t wait for the dialog to close. If you need to run code only after the dialog is closed or only if a specific result is returned register to the close event of the dialog. See documentation for code example. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Method | ShowPopup | Overloaded. Displays the form as a popup window. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ToString | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Update | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | Finalize | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCommandText | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetImage | Gets the image. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetPreferredSizeCore | (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Protected Method | GetService | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | InvokeMethod | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | IsDirty | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | OnActivated | Raises the Activated event. (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBindingContextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnClosed | (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnClosing | (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnControlAdded | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnControlRemoved | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnCreateControl | Occurs when control is created (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | OnEnabledChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnGotFocus | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLoad | Raises the Load event. (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnLocationChanged | (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnLostFocus | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentVisibleChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnResize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnTextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnUnregisterComponents | (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnValidated | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnValidating | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ProcessGatewayRequest | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RegisterSelf | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | Render | Render the form content (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | RenderAttributes | Renders the forms attribute (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderClientUpdateHandler | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderComponentEventAttributes | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderUpdatedAttributes | (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetImage | Sets the image. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeText | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | UnRegisterBatch | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | UnRegisterSelf | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | UpdateParams | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Top

Public Events

 | Name | Description
Public Event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Closed | (Inherited from Gizmox.WebGUI.Forms.Form)
Public Event | Closing | The form closing event. This event is not raised on the main form. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Disposed | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Load | The form load event (Inherited from Gizmox.WebGUI.Forms.Form)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Gizmox.WebGUI.Forms.Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Top

See Also

Reference

TraceViewer Class
Gizmox.WebGUI.Forms.Dialogs Namespace


TraceViewer Constructor

[image]
Gizmox.WebGUI.Forms
TraceViewer Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms.Dialogs Namespace > TraceViewer Class : TraceViewer Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As TraceViewer()
C#
public TraceViewer()
Managed Extensions for C++
public: TraceViewer();
C++/CLI
public:
TraceViewer();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TraceViewer Class
TraceViewer Members


TraceViewer Class Methods

[image]
Gizmox.WebGUI.Forms
TraceViewer Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms.Dialogs Namespace : TraceViewer Class

For a list of all members of this type, see TraceViewer members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from Gizmox.WebGUI.Forms.ContainerControl)
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Close | Closes this window. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Dispose | Overloaded. Clean up any resources being used.
Public Method | Focus | Sets focus to this control (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | GetPreferredSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Remove | (Inherited from Gizmox.WebGUI.Forms.ContainerControl)
Public Method | ResetText | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Public Method | Select | Overloaded. Activates the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SendToBack | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Show | (Inherited from Gizmox.WebGUI.Forms.Form)
Public Method | ShowDialog | Overloaded. Shows a the form as a dialog. The ShowDialog in Visual WebGui works differently than WinForms. Code lines after this call is executed immediately and won’t wait for the dialog to close. If you need to run code only after the dialog is closed or only if a specific result is returned register to the close event of the dialog. See documentation for code example. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Method | ShowPopup | Overloaded. Displays the form as a popup window. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ToString | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Update | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | Finalize | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCommandText | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetImage | Gets the image. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetPreferredSizeCore | (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Protected Method | GetService | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | InvokeMethod | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | IsDirty | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | OnActivated | Raises the Activated event. (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBindingContextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnClosed | (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnClosing | (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnControlAdded | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnControlRemoved | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnCreateControl | Occurs when control is created (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | OnEnabledChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnGotFocus | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLoad | Raises the Load event. (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnLocationChanged | (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnLostFocus | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentVisibleChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnResize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnTextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnUnregisterComponents | (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnValidated | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnValidating | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ProcessGatewayRequest | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RegisterSelf | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | Render | Render the form content (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | RenderAttributes | Renders the forms attribute (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderClientUpdateHandler | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderComponentEventAttributes | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderUpdatedAttributes | (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetImage | Sets the image. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeText | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | UnRegisterBatch | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | UnRegisterSelf | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | UpdateParams | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Top

See Also

Reference

TraceViewer Class
Gizmox.WebGUI.Forms.Dialogs Namespace


Dispose Method

[image]
Gizmox.WebGUI.Forms
Dispose Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Dialogs Namespace > TraceViewer Class : Dispose Method

Clean up any resources being used.

Overload List

Overload | Description
Dispose(Boolean) | Clean up any resources being used.
Dispose() | (Inherited from Gizmox.WebGUI.Forms.ContainerControl)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TraceViewer Class
TraceViewer Members


Dispose(Boolean) Method

[image]
Gizmox.WebGUI.Forms
Dispose(Boolean) Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Dialogs Namespace > TraceViewer Class > Dispose Method : Dispose(Boolean) Method

disposing
Clean up any resources being used.

Syntax

Visual Basic (Declaration)
Protected Overloads Overridable Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As TraceViewer
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected virtual void Dispose(
   bool disposing
)
Managed Extensions for C++
protected: virtual void Dispose(
   bool disposing
)
C++/CLI
protected:
virtual void Dispose(
   bool disposing
)

Parameters

disposing

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TraceViewer Class
TraceViewer Members
Overload List


Gizmox.WebGUI.Forms.Extenders Namespace

Gizmox.WebGUI.Forms.Extenders Namespace
See Also Inheritance Hierarchy Send Feedback

Classes

Class | Description
Class | SilverlightExtender | Silverlight extender expose basic Silverlight control properties to Visual WebGui controls in design time and in run time.
Class UniqueIdExtender UniqueIdExtender adds the ability to sets a unique id to a control.

Since Visual WebGui optimizes its requests we can not lean on the internal ids of components specified by the server.

By uniquely identifying anchor components, we ensure that those Ids will be sent back from the server at any response so that we would be able to lean on ids in order to create valuable replays.

See Also

Reference

Gizmox.WebGUI.Forms Assembly


SilverlightExtender Class

[image]
Gizmox.WebGUI.Forms
SilverlightExtender Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms.Extenders Namespace : SilverlightExtender Class

Silverlight extender expose basic Silverlight control properties to Visual WebGui controls in design time and in run time.

Syntax

Visual Basic (Declaration)
<ProvidePropertyAttribute(PropertyName="ScaleX", ReceiverTypeName="Gizmox.WebGUI.Forms.Control, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d")>
<ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<ToolboxBitmapAttribute()>
<ToolboxItemFilterAttribute("Gizmox.WebGUI.Forms")>
Public Class SilverlightExtender
   Inherits ComponentBase
Visual Basic (Usage) Copy Code
Dim instance As SilverlightExtender
C#
[ProvidePropertyAttribute(PropertyName="ScaleX", ReceiverTypeName="Gizmox.WebGUI.Forms.Control, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ToolboxBitmapAttribute()]
[ToolboxItemFilterAttribute("Gizmox.WebGUI.Forms")]
public class SilverlightExtender : ComponentBase
Managed Extensions for C++
[ProvidePropertyAttribute(PropertyName="ScaleX", ReceiverTypeName="Gizmox.WebGUI.Forms.Control, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ToolboxBitmapAttribute()]
[ToolboxItemFilterAttribute("Gizmox.WebGUI.Forms")]
public __gc class SilverlightExtender : public ComponentBase
C++/CLI
[ProvidePropertyAttribute(PropertyName="ScaleX", ReceiverTypeName="Gizmox.WebGUI.Forms.Control, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ToolboxBitmapAttribute()]
[ToolboxItemFilterAttribute("Gizmox.WebGUI.Forms")]
public ref class SilverlightExtender : public ComponentBase

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.Extenders.SilverlightExtender

Requirements

Namespace: Gizmox.WebGUI.Forms.Extenders

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

SilverlightExtender Members
Gizmox.WebGUI.Forms.Extenders Namespace


SilverlightExtender Class Members

[image]
Gizmox.WebGUI.Forms
SilverlightExtender Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms.Extenders Namespace : SilverlightExtender Class

The following tables list the members exposed by SilverlightExtender.

Public Constructors

 | Name | Description
Public Constructor | SilverlightExtender Constructor |
Top

Public Properties

 | Name | Description
Public Property | Container | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | Site | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | DesignMode | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | Events | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Top

Public Methods

 | Name | Description
Public Method | CanExtend | Specifies whether this object can provide its extender properties to the specified object.
Public Method | Dispose | Overloaded. (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Method | GetOpacity | Gets the opacity.
Public Method | GetRotation | Gets the rotation.
Public Method | GetScaleX | Gets the scale X.
Public Method | GetScaleY | Gets the scale Y.
Public Method | GetSkewX | Gets the skew X.
Public Method | GetSkewY | Gets the skew Y.
Public Method | SetOpacity | Sets the opacity.
Public Method | SetRotation | Sets the rotation.
Public Method | SetScaleX | Sets the scale X.
Public Method | SetScaleY | Sets the scale Y.
Public Method | SetSkewX | Sets the skew X.
Public Method | SetSkewY | Sets the skew Y.
Public Method | ToString | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | GetService | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Top

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Top

See Also

Reference

SilverlightExtender Class
Gizmox.WebGUI.Forms.Extenders Namespace


SilverlightExtender Constructor

[image]
Gizmox.WebGUI.Forms
SilverlightExtender Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms.Extenders Namespace > SilverlightExtender Class : SilverlightExtender Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As SilverlightExtender()
C#
public SilverlightExtender()
Managed Extensions for C++
public: SilverlightExtender();
C++/CLI
public:
SilverlightExtender();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SilverlightExtender Class
SilverlightExtender Members


SilverlightExtender Class Methods

[image]
Gizmox.WebGUI.Forms
SilverlightExtender Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms.Extenders Namespace : SilverlightExtender Class

For a list of all members of this type, see SilverlightExtender members.

Public Methods

 | Name | Description
Public Method | CanExtend | Specifies whether this object can provide its extender properties to the specified object.
Public Method | Dispose | Overloaded. (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Method | GetOpacity | Gets the opacity.
Public Method | GetRotation | Gets the rotation.
Public Method | GetScaleX | Gets the scale X.
Public Method | GetScaleY | Gets the scale Y.
Public Method | GetSkewX | Gets the skew X.
Public Method | GetSkewY | Gets the skew Y.
Public Method | SetOpacity | Sets the opacity.
Public Method | SetRotation | Sets the rotation.
Public Method | SetScaleX | Sets the scale X.
Public Method | SetScaleY | Sets the scale Y.
Public Method | SetSkewX | Sets the skew X.
Public Method | SetSkewY | Sets the skew Y.
Public Method | ToString | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | GetService | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Top

See Also

Reference

SilverlightExtender Class
Gizmox.WebGUI.Forms.Extenders Namespace


CanExtend Method

[image]
Gizmox.WebGUI.Forms
CanExtend Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Extenders Namespace > SilverlightExtender Class : CanExtend Method

extendee
The Object to receive the extender properties.
Specifies whether this object can provide its extender properties to the specified object.

Syntax

Visual Basic (Declaration)
Public Function CanExtend( _
   ByVal extendee As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SilverlightExtender
Dim extendee As Object
Dim value As Boolean

value = instance.CanExtend(extendee)
C#
public bool CanExtend(
   object extendee
)
Managed Extensions for C++
public: bool CanExtend(
   Object* extendee
)
C++/CLI
public:
bool CanExtend(
   Object^ extendee
)

Parameters

extendee
The Object to receive the extender properties.

Return Value

true if this object can provide extender properties to the specified object; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SilverlightExtender Class
SilverlightExtender Members


GetOpacity Method

[image]
Gizmox.WebGUI.Forms
GetOpacity Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Extenders Namespace > SilverlightExtender Class : GetOpacity Method

objControl
The obj control.
Gets the opacity.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<DescriptionAttribute("Defines the control opacity")>
<CategoryAttribute("Silverlight")>
Public Function GetOpacity( _
   ByVal objControl As Control _
) As Double
Visual Basic (Usage) Copy Code
Dim instance As SilverlightExtender
Dim objControl As Control
Dim value As Double

value = instance.GetOpacity(objControl)
C#
[DefaultValueAttribute()]
[DescriptionAttribute("Defines the control opacity")]
[CategoryAttribute("Silverlight")]
public double GetOpacity(
   Control objControl
)
Managed Extensions for C++
[DefaultValueAttribute()]
[DescriptionAttribute("Defines the control opacity")]
[CategoryAttribute("Silverlight")]
public: double GetOpacity(
   Control* objControl
)
C++/CLI
[DefaultValueAttribute()]
[DescriptionAttribute("Defines the control opacity")]
[CategoryAttribute("Silverlight")]
public:
double GetOpacity(
   Control^ objControl
)

Parameters

objControl
The obj control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SilverlightExtender Class
SilverlightExtender Members


GetRotation Method

[image]
Gizmox.WebGUI.Forms
GetRotation Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Extenders Namespace > SilverlightExtender Class : GetRotation Method

objControl
The obj control.
Gets the rotation.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<DescriptionAttribute("Defines the control rotation")>
<CategoryAttribute("Silverlight")>
Public Function GetRotation( _
   ByVal objControl As Control _
) As Double
Visual Basic (Usage) Copy Code
Dim instance As SilverlightExtender
Dim objControl As Control
Dim value As Double

value = instance.GetRotation(objControl)
C#
[DefaultValueAttribute()]
[DescriptionAttribute("Defines the control rotation")]
[CategoryAttribute("Silverlight")]
public double GetRotation(
   Control objControl
)
Managed Extensions for C++
[DefaultValueAttribute()]
[DescriptionAttribute("Defines the control rotation")]
[CategoryAttribute("Silverlight")]
public: double GetRotation(
   Control* objControl
)
C++/CLI
[DefaultValueAttribute()]
[DescriptionAttribute("Defines the control rotation")]
[CategoryAttribute("Silverlight")]
public:
double GetRotation(
   Control^ objControl
)

Parameters

objControl
The obj control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SilverlightExtender Class
SilverlightExtender Members


GetScaleX Method

[image]
Gizmox.WebGUI.Forms
GetScaleX Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Extenders Namespace > SilverlightExtender Class : GetScaleX Method

objControl
The obj control.
Gets the scale X.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Defines the control scale X value.")>
<CategoryAttribute("Silverlight")>
<DefaultValueAttribute()>
Public Function GetScaleX( _
   ByVal objControl As Control _
) As Double
Visual Basic (Usage) Copy Code
Dim instance As SilverlightExtender
Dim objControl As Control
Dim value As Double

value = instance.GetScaleX(objControl)
C#
[DescriptionAttribute("Defines the control scale X value.")]
[CategoryAttribute("Silverlight")]
[DefaultValueAttribute()]
public double GetScaleX(
   Control objControl
)
Managed Extensions for C++
[DescriptionAttribute("Defines the control scale X value.")]
[CategoryAttribute("Silverlight")]
[DefaultValueAttribute()]
public: double GetScaleX(
   Control* objControl
)
C++/CLI
[DescriptionAttribute("Defines the control scale X value.")]
[CategoryAttribute("Silverlight")]
[DefaultValueAttribute()]
public:
double GetScaleX(
   Control^ objControl
)

Parameters

objControl
The obj control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SilverlightExtender Class
SilverlightExtender Members


GetScaleY Method

[image]
Gizmox.WebGUI.Forms
GetScaleY Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Extenders Namespace > SilverlightExtender Class : GetScaleY Method

objControl
The obj control.
Gets the scale Y.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Defines the control scale Y value.")>
<CategoryAttribute("Silverlight")>
<DefaultValueAttribute()>
Public Function GetScaleY( _
   ByVal objControl As Control _
) As Double
Visual Basic (Usage) Copy Code
Dim instance As SilverlightExtender
Dim objControl As Control
Dim value As Double

value = instance.GetScaleY(objControl)
C#
[DescriptionAttribute("Defines the control scale Y value.")]
[CategoryAttribute("Silverlight")]
[DefaultValueAttribute()]
public double GetScaleY(
   Control objControl
)
Managed Extensions for C++
[DescriptionAttribute("Defines the control scale Y value.")]
[CategoryAttribute("Silverlight")]
[DefaultValueAttribute()]
public: double GetScaleY(
   Control* objControl
)
C++/CLI
[DescriptionAttribute("Defines the control scale Y value.")]
[CategoryAttribute("Silverlight")]
[DefaultValueAttribute()]
public:
double GetScaleY(
   Control^ objControl
)

Parameters

objControl
The obj control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SilverlightExtender Class
SilverlightExtender Members


GetSkewX Method

[image]
Gizmox.WebGUI.Forms
GetSkewX Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Extenders Namespace > SilverlightExtender Class : GetSkewX Method

objControl
The obj control.
Gets the skew X.

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Silverlight")>
<DescriptionAttribute("Defines the control skew X value.")>
<DefaultValueAttribute()>
Public Function GetSkewX( _
   ByVal objControl As Control _
) As Double
Visual Basic (Usage) Copy Code
Dim instance As SilverlightExtender
Dim objControl As Control
Dim value As Double

value = instance.GetSkewX(objControl)
C#
[CategoryAttribute("Silverlight")]
[DescriptionAttribute("Defines the control skew X value.")]
[DefaultValueAttribute()]
public double GetSkewX(
   Control objControl
)
Managed Extensions for C++
[CategoryAttribute("Silverlight")]
[DescriptionAttribute("Defines the control skew X value.")]
[DefaultValueAttribute()]
public: double GetSkewX(
   Control* objControl
)
C++/CLI
[CategoryAttribute("Silverlight")]
[DescriptionAttribute("Defines the control skew X value.")]
[DefaultValueAttribute()]
public:
double GetSkewX(
   Control^ objControl
)

Parameters

objControl
The obj control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SilverlightExtender Class
SilverlightExtender Members


GetSkewY Method

[image]
Gizmox.WebGUI.Forms
GetSkewY Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Extenders Namespace > SilverlightExtender Class : GetSkewY Method

objControl
The obj control.
Gets the skew Y.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<CategoryAttribute("Silverlight")>
<DescriptionAttribute("Defines the control skew Y value.")>
Public Function GetSkewY( _
   ByVal objControl As Control _
) As Double
Visual Basic (Usage) Copy Code
Dim instance As SilverlightExtender
Dim objControl As Control
Dim value As Double

value = instance.GetSkewY(objControl)
C#
[DefaultValueAttribute()]
[CategoryAttribute("Silverlight")]
[DescriptionAttribute("Defines the control skew Y value.")]
public double GetSkewY(
   Control objControl
)
Managed Extensions for C++
[DefaultValueAttribute()]
[CategoryAttribute("Silverlight")]
[DescriptionAttribute("Defines the control skew Y value.")]
public: double GetSkewY(
   Control* objControl
)
C++/CLI
[DefaultValueAttribute()]
[CategoryAttribute("Silverlight")]
[DescriptionAttribute("Defines the control skew Y value.")]
public:
double GetSkewY(
   Control^ objControl
)

Parameters

objControl
The obj control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SilverlightExtender Class
SilverlightExtender Members


SetOpacity Method

[image]
Gizmox.WebGUI.Forms
SetOpacity Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Extenders Namespace > SilverlightExtender Class : SetOpacity Method

objControl
The obj control.
dblOpacity
The DBL opacity.
Sets the opacity.

Syntax

Visual Basic (Declaration)
Public Sub SetOpacity( _
   ByVal objControl As Control, _
   ByVal dblOpacity As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As SilverlightExtender
Dim objControl As Control
Dim dblOpacity As Double

instance.SetOpacity(objControl, dblOpacity)
C#
public void SetOpacity(
   Control objControl,
   double dblOpacity
)
Managed Extensions for C++
public: void SetOpacity(
   Control* objControl,
   double dblOpacity
)
C++/CLI
public:
void SetOpacity(
   Control^ objControl,
   double dblOpacity
)

Parameters

objControl
The obj control.
dblOpacity
The DBL opacity.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SilverlightExtender Class
SilverlightExtender Members


SetRotation Method

[image]
Gizmox.WebGUI.Forms
SetRotation Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Extenders Namespace > SilverlightExtender Class : SetRotation Method

objControl
The obj control.
dblRotation
The DBL rotation.
Sets the rotation.

Syntax

Visual Basic (Declaration)
Public Sub SetRotation( _
   ByVal objControl As Control, _
   ByVal dblRotation As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As SilverlightExtender
Dim objControl As Control
Dim dblRotation As Double

instance.SetRotation(objControl, dblRotation)
C#
public void SetRotation(
   Control objControl,
   double dblRotation
)
Managed Extensions for C++
public: void SetRotation(
   Control* objControl,
   double dblRotation
)
C++/CLI
public:
void SetRotation(
   Control^ objControl,
   double dblRotation
)

Parameters

objControl
The obj control.
dblRotation
The DBL rotation.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SilverlightExtender Class
SilverlightExtender Members


SetScaleX Method

[image]
Gizmox.WebGUI.Forms
SetScaleX Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Extenders Namespace > SilverlightExtender Class : SetScaleX Method

objControl
The obj control.
dblScaleX
The DBL scale X.
Sets the scale X.

Syntax

Visual Basic (Declaration)
Public Sub SetScaleX( _
   ByVal objControl As Control, _
   ByVal dblScaleX As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As SilverlightExtender
Dim objControl As Control
Dim dblScaleX As Double

instance.SetScaleX(objControl, dblScaleX)
C#
public void SetScaleX(
   Control objControl,
   double dblScaleX
)
Managed Extensions for C++
public: void SetScaleX(
   Control* objControl,
   double dblScaleX
)
C++/CLI
public:
void SetScaleX(
   Control^ objControl,
   double dblScaleX
)

Parameters

objControl
The obj control.
dblScaleX
The DBL scale X.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SilverlightExtender Class
SilverlightExtender Members


SetScaleY Method

[image]
Gizmox.WebGUI.Forms
SetScaleY Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Extenders Namespace > SilverlightExtender Class : SetScaleY Method

objControl
The obj control.
dblScaleY
The DBL scale Y.
Sets the scale Y.

Syntax

Visual Basic (Declaration)
Public Sub SetScaleY( _
   ByVal objControl As Control, _
   ByVal dblScaleY As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As SilverlightExtender
Dim objControl As Control
Dim dblScaleY As Double

instance.SetScaleY(objControl, dblScaleY)
C#
public void SetScaleY(
   Control objControl,
   double dblScaleY
)
Managed Extensions for C++
public: void SetScaleY(
   Control* objControl,
   double dblScaleY
)
C++/CLI
public:
void SetScaleY(
   Control^ objControl,
   double dblScaleY
)

Parameters

objControl
The obj control.
dblScaleY
The DBL scale Y.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SilverlightExtender Class
SilverlightExtender Members


SetSkewX Method

[image]
Gizmox.WebGUI.Forms
SetSkewX Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Extenders Namespace > SilverlightExtender Class : SetSkewX Method

objControl
The obj control.
dblSkewX
The DBL skew X.
Sets the skew X.

Syntax

Visual Basic (Declaration)
Public Sub SetSkewX( _
   ByVal objControl As Control, _
   ByVal dblSkewX As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As SilverlightExtender
Dim objControl As Control
Dim dblSkewX As Double

instance.SetSkewX(objControl, dblSkewX)
C#
public void SetSkewX(
   Control objControl,
   double dblSkewX
)
Managed Extensions for C++
public: void SetSkewX(
   Control* objControl,
   double dblSkewX
)
C++/CLI
public:
void SetSkewX(
   Control^ objControl,
   double dblSkewX
)

Parameters

objControl
The obj control.
dblSkewX
The DBL skew X.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SilverlightExtender Class
SilverlightExtender Members


SetSkewY Method

[image]
Gizmox.WebGUI.Forms
SetSkewY Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Extenders Namespace > SilverlightExtender Class : SetSkewY Method

objControl
The obj control.
dblSkewY
The DBL skew Y.
Sets the skew Y.

Syntax

Visual Basic (Declaration)
Public Sub SetSkewY( _
   ByVal objControl As Control, _
   ByVal dblSkewY As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As SilverlightExtender
Dim objControl As Control
Dim dblSkewY As Double

instance.SetSkewY(objControl, dblSkewY)
C#
public void SetSkewY(
   Control objControl,
   double dblSkewY
)
Managed Extensions for C++
public: void SetSkewY(
   Control* objControl,
   double dblSkewY
)
C++/CLI
public:
void SetSkewY(
   Control^ objControl,
   double dblSkewY
)

Parameters

objControl
The obj control.
dblSkewY
The DBL skew Y.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SilverlightExtender Class
SilverlightExtender Members


UniqueIdExtender Class

[image]
Gizmox.WebGUI.Forms
UniqueIdExtender Class
Members Example See Also Send Feedback
Gizmox.WebGUI.Forms.Extenders Namespace : UniqueIdExtender Class

UniqueIdExtender adds the ability to sets a unique id to a control.

Since Visual WebGui optimizes its requests we can not lean on the internal ids of components specified by the server.

By uniquely identifying anchor components, we ensure that those Ids will be sent back from the server at any response so that we would be able to lean on ids in order to create valuable replays.

Syntax

Visual Basic (Declaration)
<ToolboxItemFilterAttribute("Gizmox.WebGUI.Forms")>
<ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<ToolboxBitmapAttribute()>
<ProvidePropertyAttribute(PropertyName="UniqueId", ReceiverTypeName="Gizmox.WebGUI.Forms.Component, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d")>
Public Class UniqueIdExtender
   Inherits ComponentBase
Visual Basic (Usage) Copy Code
Dim instance As UniqueIdExtender
C#
[ToolboxItemFilterAttribute("Gizmox.WebGUI.Forms")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ToolboxBitmapAttribute()]
[ProvidePropertyAttribute(PropertyName="UniqueId", ReceiverTypeName="Gizmox.WebGUI.Forms.Component, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d")]
public class UniqueIdExtender : ComponentBase
Managed Extensions for C++
[ToolboxItemFilterAttribute("Gizmox.WebGUI.Forms")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ToolboxBitmapAttribute()]
[ProvidePropertyAttribute(PropertyName="UniqueId", ReceiverTypeName="Gizmox.WebGUI.Forms.Component, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d")]
public __gc class UniqueIdExtender : public ComponentBase
C++/CLI
[ToolboxItemFilterAttribute("Gizmox.WebGUI.Forms")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ToolboxBitmapAttribute()]
[ProvidePropertyAttribute(PropertyName="UniqueId", ReceiverTypeName="Gizmox.WebGUI.Forms.Component, Gizmox.WebGUI.Forms, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=c508b41386c60f1d")]
public ref class UniqueIdExtender : public ComponentBase

Example

This shows how to use a UniqueIdExtender and anchor controls to a spesific id.
C# Copy Code
//Create a global unique Identifiers extender object:

 UniqueIdExtender mobjUniqueIdExtender = new UniqueIdExtender();

//Then use it to set Unique-Ids to your anchor components and items:

mobjUniqueIdExtender.SetUniqueId(button1, "B1");

//If you are using control with children controls such as DataGrid or ListView
//remember to unique identify all created items

 DataClasses1DataContext objDataClasses = new DataClasses1DataContext();
foreach (Employee objEmployee in objDataClasses.Employees)
{
   ListViewItem mobjListViewItem = new ListViewItem(new string[]
       {objEmployee.EmployeeID.ToString(), objEmployee.FirstName, objEmployee.LastName,
       objEmployee.Title, objEmployee.Country});
   mobjUniqueIdExtender.SetUniqueId(listView1,string.Format("LI{0}", objEmployee.EmployeeID));

   listView1.Items.Add(mobjListViewItem);
}
Visual Basic Copy Code
'Create a global unique Identifiers extender object:

Dim mobjUniqueIdExtender As New UniqueIdExtender()

'Then use it to set Unique-Ids to your anchor components and items:

mobjUniqueIdExtender.SetUniqueId(Button1, "B1")

'If you are using control with children controls such as DataGrid or ListView
'remember to unique identify all created items
Dim objDataClasses As New DataClasses1DataContext()

For Each objEmployee As Employee In objDataClasses.Employees
    Dim mobjListViewItem As New ListViewItem(New String() {objEmployee.EmployeeID.ToString(), objEmployee.FirstName, objEmployee.LastName, objEmployee.Title, objEmployee.Country})
    mobjUniqueIdExtender.SetUniqueId(ListView1, String.Format("LI{0}", objEmployee.EmployeeID))
    ListView1.Items.Add(mobjListViewItem)
Next

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.Extenders.UniqueIdExtender

Requirements

You nee to add a using/import to Gizmox.WebGUI.Forms.Extenders to the form

See Also

Reference

UniqueIdExtender Members
Gizmox.WebGUI.Forms.Extenders Namespace


UniqueIdExtender Class Members

[image]
Gizmox.WebGUI.Forms
UniqueIdExtender Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms.Extenders Namespace : UniqueIdExtender Class

The following tables list the members exposed by UniqueIdExtender.

Public Constructors

 | Name | Description
Public Constructor | UniqueIdExtender Constructor |
Top

Public Properties

 | Name | Description
Public Property | Container | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | Site | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | DesignMode | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | Events | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Top

Public Methods

 | Name | Description
Public Method | CanExtend | Specifies whether this object can provide its extender properties to the specified object.
Public Method | Dispose | Overloaded. (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Method | GetUniqueId | Gets the unique id.
Public Method | SetUniqueId | Sets the unique id.
Public Method | ToString | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | GetService | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Top

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Top

See Also

Reference

UniqueIdExtender Class
Gizmox.WebGUI.Forms.Extenders Namespace


UniqueIdExtender Constructor

[image]
Gizmox.WebGUI.Forms
UniqueIdExtender Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms.Extenders Namespace > UniqueIdExtender Class : UniqueIdExtender Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As UniqueIdExtender()
C#
public UniqueIdExtender()
Managed Extensions for C++
public: UniqueIdExtender();
C++/CLI
public:
UniqueIdExtender();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

UniqueIdExtender Class
UniqueIdExtender Members


UniqueIdExtender Class Methods

[image]
Gizmox.WebGUI.Forms
UniqueIdExtender Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms.Extenders Namespace : UniqueIdExtender Class

For a list of all members of this type, see UniqueIdExtender members.

Public Methods

 | Name | Description
Public Method | CanExtend | Specifies whether this object can provide its extender properties to the specified object.
Public Method | Dispose | Overloaded. (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Method | GetUniqueId | Gets the unique id.
Public Method | SetUniqueId | Sets the unique id.
Public Method | ToString | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | GetService | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Top

See Also

Reference

UniqueIdExtender Class
Gizmox.WebGUI.Forms.Extenders Namespace


CanExtend Method

[image]
Gizmox.WebGUI.Forms
CanExtend Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Extenders Namespace > UniqueIdExtender Class : CanExtend Method

extendee
The Object to receive the extender properties.
Specifies whether this object can provide its extender properties to the specified object.

Syntax

Visual Basic (Declaration)
Public Function CanExtend( _
   ByVal extendee As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As UniqueIdExtender
Dim extendee As Object
Dim value As Boolean

value = instance.CanExtend(extendee)
C#
public bool CanExtend(
   object extendee
)
Managed Extensions for C++
public: bool CanExtend(
   Object* extendee
)
C++/CLI
public:
bool CanExtend(
   Object^ extendee
)

Parameters

extendee
The Object to receive the extender properties.

Return Value

true if this object can provide extender properties to the specified object; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

UniqueIdExtender Class
UniqueIdExtender Members


GetUniqueId Method

[image]
Gizmox.WebGUI.Forms
GetUniqueId Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Extenders Namespace > UniqueIdExtender Class : GetUniqueId Method

objComponent
The component.
Gets the unique id.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<DescriptionAttribute("Defines the component unique id.")>
Public Function GetUniqueId( _
   ByVal objComponent As Control _
) As String
Visual Basic (Usage) Copy Code
Dim instance As UniqueIdExtender
Dim objComponent As Control
Dim value As String

value = instance.GetUniqueId(objComponent)
C#
[DefaultValueAttribute()]
[DescriptionAttribute("Defines the component unique id.")]
public string GetUniqueId(
   Control objComponent
)
Managed Extensions for C++
[DefaultValueAttribute()]
[DescriptionAttribute("Defines the component unique id.")]
public: string* GetUniqueId(
   Control* objComponent
)
C++/CLI
[DefaultValueAttribute()]
[DescriptionAttribute("Defines the component unique id.")]
public:
String^ GetUniqueId(
   Control^ objComponent
)

Parameters

objComponent
The component.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

UniqueIdExtender Class
UniqueIdExtender Members


SetUniqueId Method

[image]
Gizmox.WebGUI.Forms
SetUniqueId Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Extenders Namespace > UniqueIdExtender Class : SetUniqueId Method

objComponent
The component.
strId
The unique id.
Sets the unique id.

Syntax

Visual Basic (Declaration)
Public Sub SetUniqueId( _
   ByVal objComponent As Component, _
   ByVal strId As String _
)
Visual Basic (Usage) Copy Code
Dim instance As UniqueIdExtender
Dim objComponent As Component
Dim strId As String

instance.SetUniqueId(objComponent, strId)
C#
public void SetUniqueId(
   Component objComponent,
   string strId
)
Managed Extensions for C++
public: void SetUniqueId(
   Component* objComponent,
   string* strId
)
C++/CLI
public:
void SetUniqueId(
   Component^ objComponent,
   String^ strId
)

Parameters

objComponent
The component.
strId
The unique id.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

UniqueIdExtender Class
UniqueIdExtender Members


Gizmox.WebGUI.Forms.Hosts Namespace

Gizmox.WebGUI.Forms.Hosts Namespace
See Also Inheritance Hierarchy Send Feedback

Classes

 | Class | Description
Class | AppletBox | Applet box control can host java applets and embed the in a Visual WebGui application
Class | AppletBoxBase | Summary description for AppletBoxBase.
Class | AspControlBoxBase | AspControlBoxBase provides a base class for creating ASP.NET wrapped controls that can be integrated into VWG as a native control. The class provides services for ASP.NET – VWG communication and using ASP.NET markup code to initialize the ASP.NET control.
Class | AspControlBoxBase.ResourceFile | Provides an implementation of a virtual file that can compile a code at runtime from a string or an embeded resource
Class | AspControlBoxBase.ResourceProvider | Provides a custom resource provider to help build types from string or an embeded resource
Class | AspControlEventArgs | Provides a base class for hosted ASP.NET events
Class | AspPageBase | Provides an System.Web.UI.Page implementation that adds state management and visual webgui pipeline integration
Class | AspPageBox | Summary description for ASPXHostBox
Class | AspPageEventArgs | Provides a base class for hosted ASP.NET events
Class | AspPipeLinePage | Provides an System.Web.UI.Page implementation that adds state management and visual webgui pipeline integration
Class | AspPipeLinePage.AspControlBoxStatePersister | Provides view / control state for the asp control box control
Class | FlashBox | Flash box control can host Flash movies and embed them in a Visual WebGui application.
Class | FlashBoxBase | Summary description for FlashBoxBase.
Class | FormBox |
Class | ObjectBox | Summary description for ObjectBox.

Delegates

 | Delegate | Description
Delegate | AspControlEventHandler | Provides a delegate for the hosted ASP.NET events
Delegate | AspPageEventHandler | Provides a delegate for the hosted ASP.NET events

Enumerations

 | Enumeration | Description
Enumeration | FormBox.ApplicationUITypes |

See Also

Reference

Gizmox.WebGUI.Forms Assembly


AppletBox Class

[image]
Gizmox.WebGUI.Forms
AppletBox Class
Members Example See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace : AppletBox Class

Applet box control can host java applets and embed the in a Visual WebGui application

Object Model

Syntax

Visual Basic (Declaration)
<ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
Public Class AppletBox
   Inherits AppletBoxBase
   Implements IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IGatewayControl, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Visual Basic (Usage) Copy Code
Dim instance As AppletBox
C#
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
public class AppletBox : AppletBoxBase, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IGatewayControl, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Managed Extensions for C++
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
public __gc class AppletBox : public AppletBoxBase, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IGatewayControl, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
C++/CLI
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
public ref class AppletBox : public AppletBoxBase, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IGatewayControl, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement

Example

C# Copy Code
AppletBox objAppletBox = new AppletBox();

objAppletBox.CodeBase = [URL Relative location]
objAppletBox.Code = [Class filename]

 //If your class file is located in Resources folder inside project and it's a dedicated server:

 objAppletBox.CodeBase = "/Resources/";
objAppletBox.Code = "MyClass.class";

 //If your class files located in virtual directory inside server:

 objAppletBox.CodeBase = "Resources/";
objAppletBox.Code = "MyClass.class";
Visual Basic Copy Code
Dim objAppletBox As New AppletBox()

objAppletBox.CodeBase = [URL Relative location]
objAppletBox.Code = [Class filename]

//If your Class file Is located In Resources folder inside project And it's a dedicated server:

objAppletBox.CodeBase = "/Resources/"
objAppletBox.Code = "MyClass.class"

//If your Class files located In virtual directory inside server:

objAppletBox.CodeBase = "Resources/"
objAppletBox.Code = "MyClass.class"

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.Hosts.AppletBoxBase
Gizmox.WebGUI.Forms.Hosts.AppletBox

Requirements

Namespace: Gizmox.WebGUI.Forms.Hosts

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

AppletBox Members
Gizmox.WebGUI.Forms.Hosts Namespace


AppletBox Class Members

[image]
Gizmox.WebGUI.Forms
AppletBox Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace : AppletBox Class

The following tables list the members exposed by AppletBox.

Public Constructors

 | Name | Description
Public Constructor | AppletBox Constructor | Overloaded. Creates a new AppletBox instance.
Top

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Archive | Gets or sets the archive.
Public Property | BackColor | Gets or sets the background color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BindingContext | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Code | Gets or sets the code.
Public Property | CodeBase | Gets or sets the code base.
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Container | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Context | Gets the context. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Form | Gets the owner form. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Height | Gets/Sets the height position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | IsRegistered | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Left | Gets/Sets the left position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Location | Gets or sets the control location. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Right | Gets/Sets the right position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Site | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Top | Gets/Sets the top position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Visible | Gets or sets the control visability. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Width | Gets/Sets the width position (Inherited from Gizmox.WebGUI.Forms.Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultBorderColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultBorderStyle | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultForeColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMargin | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultPadding | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DesignMode | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | Events | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | Gateways | Gets the gateways hash. (Inherited from AppletBoxBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | InternalArchive | Gets or sets the archive. (Inherited from AppletBoxBase)
Protected Property | InternalCode | Gets or sets the code. (Inherited from AppletBoxBase)
Protected Property | InternalCodeBase | Gets or sets the code base. (Inherited from AppletBoxBase)
Protected Property | IsConnected | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Property | IsDelayedDrawing | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | Params | Gets the parameters hash. (Inherited from AppletBoxBase)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | Session | Gets the application object. (Inherited from Gizmox.WebGUI.Forms.Component)
Top

Public Methods

 | Name | Description
Public Method | AddParameter | Overloaded. Adds the parameter.
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ClearParameters | Clears the parameters.
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Focus | Sets focus to this control (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | GetGatewayHandler |
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | GetParameter | Gets the parameter.
Public Method | GetPreferredSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | RemoveParameter | Removes the parameter.
Public Method | ResetText | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SendToBack | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Show | Displays the control to the user. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ToString | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Update | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | Finalize | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCommandText | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetImage | Gets the image. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetPreferredSizeCore | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetService | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | InvokeMethod | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | IsDirty | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBindingContextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnControlAdded | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnControlRemoved | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | OnEnabledChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnGotFocus | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLostFocus | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentVisibleChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnResize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnTextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnUnregisterComponents | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnValidated | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnValidating | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ProcessGatewayRequest | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RegisterSelf | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | Render | Renders the current control. (Inherited from AppletBoxBase)
Protected Method | RenderAttributes | (Inherited from AppletBoxBase)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderClientUpdateHandler | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderComponentEventAttributes | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetImage | Sets the image. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeText | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | UnRegisterBatch | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | UnRegisterSelf | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | UpdateParams | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Top

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Disposed | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Gizmox.WebGUI.Forms.Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Top

See Also

Reference

AppletBox Class
Gizmox.WebGUI.Forms.Hosts Namespace


AppletBox Constructor

[image]
Gizmox.WebGUI.Forms
AppletBox Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AppletBox Class : AppletBox Constructor

Creates a new AppletBox instance.

Overload List

Overload | Description
AppletBox Constructor() | Creates a new AppletBox instance.
AppletBox Constructor(String,String,String) | Creates a new AppletBox instance.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AppletBox Class
AppletBox Members


AppletBox Constructor()

[image]
Gizmox.WebGUI.Forms
AppletBox Constructor()
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AppletBox Class > AppletBox Constructor : AppletBox Constructor()

Creates a new AppletBox instance.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As AppletBox()
C#
public AppletBox()
Managed Extensions for C++
public: AppletBox();
C++/CLI
public:
AppletBox();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AppletBox Class
AppletBox Members
Overload List


AppletBox Constructor(String,String,String)

[image]
Gizmox.WebGUI.Forms
AppletBox Constructor(String,String,String)
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AppletBox Class > AppletBox Constructor : AppletBox Constructor(String,String,String)

strCodeBase
Applet code base.
strArchive
Applet archive.
strCode
Applet code.
Creates a new AppletBox instance.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal strCodeBase As String, _
   ByVal strArchive As String, _
   ByVal strCode As String _
)
Visual Basic (Usage) Copy Code
Dim strCodeBase As String
Dim strArchive As String
Dim strCode As String

Dim instance As AppletBox(strCodeBase, strArchive, strCode)
C#
public AppletBox(
   string strCodeBase,
   string strArchive,
   string strCode
)
Managed Extensions for C++
public: AppletBox(
   string* strCodeBase,
   string* strArchive,
   string* strCode
)
C++/CLI
public:
AppletBox(
   String^ strCodeBase,
   String^ strArchive,
   String^ strCode
)

Parameters

strCodeBase
Applet code base.
strArchive
Applet archive.
strCode
Applet code.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AppletBox Class
AppletBox Members
Overload List


AppletBox Class Methods

[image]
Gizmox.WebGUI.Forms
AppletBox Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace : AppletBox Class

For a list of all members of this type, see AppletBox members.

Public Methods

 | Name | Description
Public Method | AddParameter | Overloaded. Adds the parameter.
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ClearParameters | Clears the parameters.
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Focus | Sets focus to this control (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | GetGatewayHandler |
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | GetParameter | Gets the parameter.
Public Method | GetPreferredSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | RemoveParameter | Removes the parameter.
Public Method | ResetText | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SendToBack | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Show | Displays the control to the user. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ToString | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Update | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | Finalize | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCommandText | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetImage | Gets the image. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetPreferredSizeCore | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetService | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | InvokeMethod | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | IsDirty | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBindingContextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnControlAdded | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnControlRemoved | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | OnEnabledChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnGotFocus | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLostFocus | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentVisibleChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnResize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnTextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnUnregisterComponents | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnValidated | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnValidating | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ProcessGatewayRequest | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RegisterSelf | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | Render | Renders the current control. (Inherited from AppletBoxBase)
Protected Method | RenderAttributes | (Inherited from AppletBoxBase)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderClientUpdateHandler | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderComponentEventAttributes | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetImage | Sets the image. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeText | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | UnRegisterBatch | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | UnRegisterSelf | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | UpdateParams | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Top

See Also

Reference

AppletBox Class
Gizmox.WebGUI.Forms.Hosts Namespace


AddParameter Method

[image]
Gizmox.WebGUI.Forms
AddParameter Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AppletBox Class : AddParameter Method

Adds the parameter.

Overload List

Overload | Description
AddParameter(String,String) | Adds the parameter.
AddParameter(String,GatewayHandler) | Adds the parameter.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AppletBox Class
AppletBox Members


AddParameter(String,String) Method

[image]
Gizmox.WebGUI.Forms
AddParameter(String,String) Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AppletBox Class > AddParameter Method : AddParameter(String,String) Method

strName
strValue
Adds the parameter.

Syntax

Visual Basic (Declaration)
Public Overloads Sub AddParameter( _
   ByVal strName As String, _
   ByVal strValue As String _
)
Visual Basic (Usage) Copy Code
Dim instance As AppletBox
Dim strName As String
Dim strValue As String

instance.AddParameter(strName, strValue)
C#
public void AddParameter(
   string strName,
   string strValue
)
Managed Extensions for C++
public: void AddParameter(
   string* strName,
   string* strValue
)
C++/CLI
public:
void AddParameter(
   String^ strName,
   String^ strValue
)

Parameters

strName
strValue

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AppletBox Class
AppletBox Members
Overload List


AddParameter(String,GatewayHandler) Method

[image]
Gizmox.WebGUI.Forms
AddParameter(String,GatewayHandler) Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AppletBox Class > AddParameter Method : AddParameter(String,GatewayHandler) Method

strName
objHandler
Adds the parameter.

Syntax

Visual Basic (Declaration)
Public Overloads Sub AddParameter( _
   ByVal strName As String, _
   ByVal objHandler As GatewayHandler _
)
Visual Basic (Usage) Copy Code
Dim instance As AppletBox
Dim strName As String
Dim objHandler As GatewayHandler

instance.AddParameter(strName, objHandler)
C#
public void AddParameter(
   string strName,
   GatewayHandler objHandler
)
Managed Extensions for C++
public: void AddParameter(
   string* strName,
   GatewayHandler* objHandler
)
C++/CLI
public:
void AddParameter(
   String^ strName,
   GatewayHandler^ objHandler
)

Parameters

strName
objHandler

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AppletBox Class
AppletBox Members
Overload List


ClearParameters Method

[image]
Gizmox.WebGUI.Forms
ClearParameters Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AppletBox Class : ClearParameters Method

Clears the parameters.

Syntax

Visual Basic (Declaration)
Public Sub ClearParameters()
Visual Basic (Usage) Copy Code
Dim instance As AppletBox

instance.ClearParameters()
C#
public void ClearParameters()
Managed Extensions for C++
public: void ClearParameters();
C++/CLI
public:
void ClearParameters();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AppletBox Class
AppletBox Members


GetGatewayHandler Method

[image]
Gizmox.WebGUI.Forms
GetGatewayHandler Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AppletBox Class : GetGatewayHandler Method

objContext
strAction

Syntax

Visual Basic (Declaration)
Public Function GetGatewayHandler( _
   ByVal objContext As IContext, _
   ByVal strAction As String _
) As IGatewayHandler
Visual Basic (Usage) Copy Code
Dim instance As AppletBox
Dim objContext As IContext
Dim strAction As String
Dim value As IGatewayHandler

value = instance.GetGatewayHandler(objContext, strAction)
C#
public IGatewayHandler GetGatewayHandler(
   IContext objContext,
   string strAction
)
Managed Extensions for C++
public: IGatewayHandler* GetGatewayHandler(
   IContext* objContext,
   string* strAction
)
C++/CLI
public:
IGatewayHandler^ GetGatewayHandler(
   IContext^ objContext,
   String^ strAction
)

Parameters

objContext
strAction

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AppletBox Class
AppletBox Members


GetParameter Method

[image]
Gizmox.WebGUI.Forms
GetParameter Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AppletBox Class : GetParameter Method

strName
Gets the parameter.

Syntax

Visual Basic (Declaration)
Public Function GetParameter( _
   ByVal strName As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As AppletBox
Dim strName As String
Dim value As String

value = instance.GetParameter(strName)
C#
public string GetParameter(
   string strName
)
Managed Extensions for C++
public: string* GetParameter(
   string* strName
)
C++/CLI
public:
String^ GetParameter(
   String^ strName
)

Parameters

strName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AppletBox Class
AppletBox Members


RemoveParameter Method

[image]
Gizmox.WebGUI.Forms
RemoveParameter Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AppletBox Class : RemoveParameter Method

strName
Removes the parameter.

Syntax

Visual Basic (Declaration)
Public Sub RemoveParameter( _
   ByVal strName As String _
)
Visual Basic (Usage) Copy Code
Dim instance As AppletBox
Dim strName As String

instance.RemoveParameter(strName)
C#
public void RemoveParameter(
   string strName
)
Managed Extensions for C++
public: void RemoveParameter(
   string* strName
)
C++/CLI
public:
void RemoveParameter(
   String^ strName
)

Parameters

strName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AppletBox Class
AppletBox Members


AppletBox Class Properties

[image]
Gizmox.WebGUI.Forms
AppletBox Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace : AppletBox Class

For a list of all members of this type, see AppletBox members.

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Archive | Gets or sets the archive.
Public Property | BackColor | Gets or sets the background color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BindingContext | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Code | Gets or sets the code.
Public Property | CodeBase | Gets or sets the code base.
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Container | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Context | Gets the context. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Form | Gets the owner form. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Height | Gets/Sets the height position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | IsRegistered | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Left | Gets/Sets the left position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Location | Gets or sets the control location. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Right | Gets/Sets the right position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Site | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Top | Gets/Sets the top position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Visible | Gets or sets the control visability. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Width | Gets/Sets the width position (Inherited from Gizmox.WebGUI.Forms.Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultBorderColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultBorderStyle | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultForeColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMargin | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultPadding | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DesignMode | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | Events | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | Gateways | Gets the gateways hash. (Inherited from AppletBoxBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | InternalArchive | Gets or sets the archive. (Inherited from AppletBoxBase)
Protected Property | InternalCode | Gets or sets the code. (Inherited from AppletBoxBase)
Protected Property | InternalCodeBase | Gets or sets the code base. (Inherited from AppletBoxBase)
Protected Property | IsConnected | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Property | IsDelayedDrawing | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | Params | Gets the parameters hash. (Inherited from AppletBoxBase)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | Session | Gets the application object. (Inherited from Gizmox.WebGUI.Forms.Component)
Top

See Also

Reference

AppletBox Class
Gizmox.WebGUI.Forms.Hosts Namespace


Archive Property

[image]
Gizmox.WebGUI.Forms
Archive Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AppletBox Class : Archive Property

Gets or sets the archive.

Syntax

Visual Basic (Declaration)
Public Property Archive As String
Visual Basic (Usage) Copy Code
Dim instance As AppletBox
Dim value As String

instance.Archive = value

value = instance.Archive
C#
public string Archive {get; set;}
Managed Extensions for C++
public: __property string* get_Archive();
public: __property void set_Archive(
   string* value
);
C++/CLI
public:
property String^ Archive {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AppletBox Class
AppletBox Members


Code Property

[image]
Gizmox.WebGUI.Forms
Code Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AppletBox Class : Code Property

Gets or sets the code.

Syntax

Visual Basic (Declaration)
Public Property Code As String
Visual Basic (Usage) Copy Code
Dim instance As AppletBox
Dim value As String

instance.Code = value

value = instance.Code
C#
public string Code {get; set;}
Managed Extensions for C++
public: __property string* get_Code();
public: __property void set_Code(
   string* value
);
C++/CLI
public:
property String^ Code {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AppletBox Class
AppletBox Members


CodeBase Property

[image]
Gizmox.WebGUI.Forms
CodeBase Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AppletBox Class : CodeBase Property

Gets or sets the code base.

Syntax

Visual Basic (Declaration)
Public Property CodeBase As String
Visual Basic (Usage) Copy Code
Dim instance As AppletBox
Dim value As String

instance.CodeBase = value

value = instance.CodeBase
C#
public string CodeBase {get; set;}
Managed Extensions for C++
public: __property string* get_CodeBase();
public: __property void set_CodeBase(
   string* value
);
C++/CLI
public:
property String^ CodeBase {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AppletBox Class
AppletBox Members


AppletBoxBase Class

[image]
Gizmox.WebGUI.Forms
AppletBoxBase Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace : AppletBoxBase Class

Summary description for AppletBoxBase.

Object Model

Syntax

Visual Basic (Declaration)
<ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")>
<MetadataTagAttribute("A")>
Public Class AppletBoxBase
   Inherits Control
   Implements IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IGatewayControl, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Visual Basic (Usage) Copy Code
Dim instance As AppletBoxBase
C#
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
[MetadataTagAttribute("A")]
public class AppletBoxBase : Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IGatewayControl, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Managed Extensions for C++
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
[MetadataTagAttribute("A")]
public __gc class AppletBoxBase : public Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IGatewayControl, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
C++/CLI
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
[MetadataTagAttribute("A")]
public ref class AppletBoxBase : public Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IGatewayControl, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.Hosts.AppletBoxBase
Gizmox.WebGUI.Forms.Hosts.AppletBox

Requirements

Namespace: Gizmox.WebGUI.Forms.Hosts

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

AppletBoxBase Members
Gizmox.WebGUI.Forms.Hosts Namespace


AppletBoxBase Class Members

[image]
Gizmox.WebGUI.Forms
AppletBoxBase Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace : AppletBoxBase Class

The following tables list the members exposed by AppletBoxBase.

Public Constructors

 | Name | Description
Public Constructor | AppletBoxBase Constructor | Overloaded. Creates a new AppletBoxBase instance.
Top

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackColor | Gets or sets the background color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BindingContext | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Container | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Context | Gets the context. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Form | Gets the owner form. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Height | Gets/Sets the height position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | IsRegistered | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Left | Gets/Sets the left position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Location | Gets or sets the control location. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Right | Gets/Sets the right position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Site | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Top | Gets/Sets the top position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Visible | Gets or sets the control visability. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Width | Gets/Sets the width position (Inherited from Gizmox.WebGUI.Forms.Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultBorderColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultBorderStyle | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultForeColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMargin | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultPadding | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DesignMode | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | Events | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | Gateways | Gets the gateways hash.
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | InternalArchive | Gets or sets the archive.
Protected Property | InternalCode | Gets or sets the code.
Protected Property | InternalCodeBase | Gets or sets the code base.
Protected Property | IsConnected | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Property | IsDelayedDrawing | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | Params | Gets the parameters hash.
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | Session | Gets the application object. (Inherited from Gizmox.WebGUI.Forms.Component)
Top

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Focus | Sets focus to this control (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | GetGatewayHandler |
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | GetPreferredSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | ResetText | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SendToBack | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Show | Displays the control to the user. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ToString | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Update | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | Finalize | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCommandText | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetImage | Gets the image. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetPreferredSizeCore | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetService | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | InvokeMethod | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | IsDirty | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBindingContextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnControlAdded | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnControlRemoved | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | OnEnabledChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnGotFocus | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLostFocus | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentVisibleChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnResize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnTextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnUnregisterComponents | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnValidated | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnValidating | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ProcessGatewayRequest | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RegisterSelf | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | Render | Overridden. Renders the current control.
Protected Method | RenderAttributes | Overridden.
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderClientUpdateHandler | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderComponentEventAttributes | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetImage | Sets the image. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeText | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | UnRegisterBatch | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | UnRegisterSelf | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | UpdateParams | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Top

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Disposed | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Gizmox.WebGUI.Forms.Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Top

See Also

Reference

AppletBoxBase Class
Gizmox.WebGUI.Forms.Hosts Namespace


AppletBoxBase Constructor

[image]
Gizmox.WebGUI.Forms
AppletBoxBase Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AppletBoxBase Class : AppletBoxBase Constructor

Creates a new AppletBoxBase instance.

Overload List

Overload | Description
AppletBoxBase Constructor() | Creates a new AppletBoxBase instance.
AppletBoxBase Constructor(String,String,String) | Creates a new AppletBoxBase instance.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AppletBoxBase Class
AppletBoxBase Members


AppletBoxBase Constructor()

[image]
Gizmox.WebGUI.Forms
AppletBoxBase Constructor()
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AppletBoxBase Class > AppletBoxBase Constructor : AppletBoxBase Constructor()

Creates a new AppletBoxBase instance.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As AppletBoxBase()
C#
public AppletBoxBase()
Managed Extensions for C++
public: AppletBoxBase();
C++/CLI
public:
AppletBoxBase();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AppletBoxBase Class
AppletBoxBase Members
Overload List


AppletBoxBase Constructor(String,String,String)

[image]
Gizmox.WebGUI.Forms
AppletBoxBase Constructor(String,String,String)
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AppletBoxBase Class > AppletBoxBase Constructor : AppletBoxBase Constructor(String,String,String)

strCodeBase
Applet code base.
strArchive
Applet archive.
strCode
Applet code.
Creates a new AppletBoxBase instance.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal strCodeBase As String, _
   ByVal strArchive As String, _
   ByVal strCode As String _
)
Visual Basic (Usage) Copy Code
Dim strCodeBase As String
Dim strArchive As String
Dim strCode As String

Dim instance As AppletBoxBase(strCodeBase, strArchive, strCode)
C#
public AppletBoxBase(
   string strCodeBase,
   string strArchive,
   string strCode
)
Managed Extensions for C++
public: AppletBoxBase(
   string* strCodeBase,
   string* strArchive,
   string* strCode
)
C++/CLI
public:
AppletBoxBase(
   String^ strCodeBase,
   String^ strArchive,
   String^ strCode
)

Parameters

strCodeBase
Applet code base.
strArchive
Applet archive.
strCode
Applet code.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AppletBoxBase Class
AppletBoxBase Members
Overload List


AppletBoxBase Class Methods

[image]
Gizmox.WebGUI.Forms
AppletBoxBase Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace : AppletBoxBase Class

For a list of all members of this type, see AppletBoxBase members.

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Focus | Sets focus to this control (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | GetGatewayHandler |
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | GetPreferredSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | ResetText | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SendToBack | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Show | Displays the control to the user. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ToString | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Update | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | Finalize | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCommandText | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetImage | Gets the image. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetPreferredSizeCore | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetService | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | InvokeMethod | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | IsDirty | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBindingContextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnControlAdded | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnControlRemoved | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | OnEnabledChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnGotFocus | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLostFocus | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentVisibleChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnResize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnTextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnUnregisterComponents | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnValidated | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnValidating | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ProcessGatewayRequest | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RegisterSelf | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | Render | Overridden. Renders the current control.
Protected Method | RenderAttributes | Overridden.
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderClientUpdateHandler | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderComponentEventAttributes | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetImage | Sets the image. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeText | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | UnRegisterBatch | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | UnRegisterSelf | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | UpdateParams | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Top

See Also

Reference

AppletBoxBase Class
Gizmox.WebGUI.Forms.Hosts Namespace


GetGatewayHandler Method

[image]
Gizmox.WebGUI.Forms
GetGatewayHandler Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AppletBoxBase Class : GetGatewayHandler Method

objContext
strAction

Syntax

Visual Basic (Declaration)
Public Overridable Function GetGatewayHandler( _
   ByVal objContext As IContext, _
   ByVal strAction As String _
) As IGatewayHandler
Visual Basic (Usage) Copy Code
Dim instance As AppletBoxBase
Dim objContext As IContext
Dim strAction As String
Dim value As IGatewayHandler

value = instance.GetGatewayHandler(objContext, strAction)
C#
public virtual IGatewayHandler GetGatewayHandler(
   IContext objContext,
   string strAction
)
Managed Extensions for C++
public: virtual IGatewayHandler* GetGatewayHandler(
   IContext* objContext,
   string* strAction
)
C++/CLI
public:
virtual IGatewayHandler^ GetGatewayHandler(
   IContext^ objContext,
   String^ strAction
)

Parameters

objContext
strAction

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AppletBoxBase Class
AppletBoxBase Members


Render Method

[image]
Gizmox.WebGUI.Forms
Render Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AppletBoxBase Class : Render Method

objContext
Request context.
objWriter
lngRequestID
Renders the current control.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub Render( _
   ByVal objContext As IContext, _
   ByVal objWriter As IResponseWriter, _
   ByVal lngRequestID As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As AppletBoxBase
Dim objContext As IContext
Dim objWriter As IResponseWriter
Dim lngRequestID As Long

instance.Render(objContext, objWriter, lngRequestID)
C#
protected override void Render(
   IContext objContext,
   IResponseWriter objWriter,
   long lngRequestID
)
Managed Extensions for C++
protected: void Render(
   IContext* objContext,
   IResponseWriter* objWriter,
   long lngRequestID
) override
C++/CLI
protected:
void Render(
   IContext^ objContext,
   IResponseWriter^ objWriter,
   long long lngRequestID
) override

Parameters

objContext
Request context.
objWriter
lngRequestID

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AppletBoxBase Class
AppletBoxBase Members


RenderAttributes Method

[image]
Gizmox.WebGUI.Forms
RenderAttributes Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AppletBoxBase Class : RenderAttributes Method

objContext
objWriter

Syntax

Visual Basic (Declaration)
Protected Overrides Sub RenderAttributes( _
   ByVal objContext As IContext, _
   ByVal objWriter As IAttributeWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As AppletBoxBase
Dim objContext As IContext
Dim objWriter As IAttributeWriter

instance.RenderAttributes(objContext, objWriter)
C#
protected override void RenderAttributes(
   IContext objContext,
   IAttributeWriter objWriter
)
Managed Extensions for C++
protected: void RenderAttributes(
   IContext* objContext,
   IAttributeWriter* objWriter
) override
C++/CLI
protected:
void RenderAttributes(
   IContext^ objContext,
   IAttributeWriter^ objWriter
) override

Parameters

objContext
objWriter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AppletBoxBase Class
AppletBoxBase Members


AppletBoxBase Class Properties

[image]
Gizmox.WebGUI.Forms
AppletBoxBase Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace : AppletBoxBase Class

For a list of all members of this type, see AppletBoxBase members.

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackColor | Gets or sets the background color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BindingContext | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Container | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Context | Gets the context. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Form | Gets the owner form. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Height | Gets/Sets the height position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | IsRegistered | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Left | Gets/Sets the left position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Location | Gets or sets the control location. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Right | Gets/Sets the right position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Site | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Top | Gets/Sets the top position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Visible | Gets or sets the control visability. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Width | Gets/Sets the width position (Inherited from Gizmox.WebGUI.Forms.Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultBorderColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultBorderStyle | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultForeColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMargin | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultPadding | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DesignMode | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | Events | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | Gateways | Gets the gateways hash.
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | InternalArchive | Gets or sets the archive.
Protected Property | InternalCode | Gets or sets the code.
Protected Property | InternalCodeBase | Gets or sets the code base.
Protected Property | IsConnected | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Property | IsDelayedDrawing | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | Params | Gets the parameters hash.
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | Session | Gets the application object. (Inherited from Gizmox.WebGUI.Forms.Component)
Top

See Also

Reference

AppletBoxBase Class
Gizmox.WebGUI.Forms.Hosts Namespace


Gateways Property

[image]
Gizmox.WebGUI.Forms
Gateways Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AppletBoxBase Class : Gateways Property

Gets the gateways hash.

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property Gateways As Hashtable
Visual Basic (Usage) Copy Code
Dim instance As AppletBoxBase
Dim value As Hashtable

value = instance.Gateways
C#
protected Hashtable Gateways {get;}
Managed Extensions for C++
protected: __property Hashtable* get_Gateways();
C++/CLI
protected:
property Hashtable^ Gateways {
   Hashtable^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AppletBoxBase Class
AppletBoxBase Members


InternalArchive Property

[image]
Gizmox.WebGUI.Forms
InternalArchive Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AppletBoxBase Class : InternalArchive Property

Gets or sets the archive.

Syntax

Visual Basic (Declaration)
Protected Property InternalArchive As String
Visual Basic (Usage) Copy Code
Dim instance As AppletBoxBase
Dim value As String

instance.InternalArchive = value

value = instance.InternalArchive
C#
protected string InternalArchive {get; set;}
Managed Extensions for C++
protected: __property string* get_InternalArchive();
protected: __property void set_InternalArchive(
   string* value
);
C++/CLI
protected:
property String^ InternalArchive {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AppletBoxBase Class
AppletBoxBase Members


InternalCode Property

[image]
Gizmox.WebGUI.Forms
InternalCode Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AppletBoxBase Class : InternalCode Property

Gets or sets the code.

Syntax

Visual Basic (Declaration)
Protected Property InternalCode As String
Visual Basic (Usage) Copy Code
Dim instance As AppletBoxBase
Dim value As String

instance.InternalCode = value

value = instance.InternalCode
C#
protected string InternalCode {get; set;}
Managed Extensions for C++
protected: __property string* get_InternalCode();
protected: __property void set_InternalCode(
   string* value
);
C++/CLI
protected:
property String^ InternalCode {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AppletBoxBase Class
AppletBoxBase Members


InternalCodeBase Property

[image]
Gizmox.WebGUI.Forms
InternalCodeBase Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AppletBoxBase Class : InternalCodeBase Property

Gets or sets the code base.

Syntax

Visual Basic (Declaration)
Protected Property InternalCodeBase As String
Visual Basic (Usage) Copy Code
Dim instance As AppletBoxBase
Dim value As String

instance.InternalCodeBase = value

value = instance.InternalCodeBase
C#
protected string InternalCodeBase {get; set;}
Managed Extensions for C++
protected: __property string* get_InternalCodeBase();
protected: __property void set_InternalCodeBase(
   string* value
);
C++/CLI
protected:
property String^ InternalCodeBase {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AppletBoxBase Class
AppletBoxBase Members


Params Property

[image]
Gizmox.WebGUI.Forms
Params Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AppletBoxBase Class : Params Property

Gets the parameters hash.

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property Params As Hashtable
Visual Basic (Usage) Copy Code
Dim instance As AppletBoxBase
Dim value As Hashtable

value = instance.Params
C#
protected Hashtable Params {get;}
Managed Extensions for C++
protected: __property Hashtable* get_Params();
C++/CLI
protected:
property Hashtable^ Params {
   Hashtable^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AppletBoxBase Class
AppletBoxBase Members


AspControlBoxBase Class

[image]
Gizmox.WebGUI.Forms
AspControlBoxBase Class
Members Example See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace : AspControlBoxBase Class

AspControlBoxBase provides a base class for creating ASP.NET wrapped controls that can be integrated into VWG as a native control.

The class provides services for ASP.NET – VWG communication and using ASP.NET markup code to initialize the ASP.NET control.

Object Model

Syntax

Visual Basic (Declaration)
<ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")>
<ToolboxBitmapAttribute()>
<DesignTimeControllerAttribute()>
<ClientControllerAttribute()>
<DesignerSerializerAttribute(SerializerTypeName="Gizmox.WebGUI.Common.Design.Serialization.AspControlBoxCodeDomSerializer, Gizmox.WebGUI.Common.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=ea5dfe57c8eb7edd", SerializerBaseTypeName="System.ComponentModel.Design.Serialization.CodeDomSerializer, System.Design, Version=2.0.5000.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<MetadataTagAttribute("ASPX")>
Public MustInherit Class AspControlBoxBase
   Inherits FrameControl
   Implements IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Visual Basic (Usage) Copy Code
Dim instance As AspControlBoxBase
C#
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
[ToolboxBitmapAttribute()]
[DesignTimeControllerAttribute()]
[ClientControllerAttribute()]
[DesignerSerializerAttribute(SerializerTypeName="Gizmox.WebGUI.Common.Design.Serialization.AspControlBoxCodeDomSerializer, Gizmox.WebGUI.Common.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=ea5dfe57c8eb7edd", SerializerBaseTypeName="System.ComponentModel.Design.Serialization.CodeDomSerializer, System.Design, Version=2.0.5000.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[MetadataTagAttribute("ASPX")]
public abstract class AspControlBoxBase : FrameControl, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Managed Extensions for C++
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
[ToolboxBitmapAttribute()]
[DesignTimeControllerAttribute()]
[ClientControllerAttribute()]
[DesignerSerializerAttribute(SerializerTypeName="Gizmox.WebGUI.Common.Design.Serialization.AspControlBoxCodeDomSerializer, Gizmox.WebGUI.Common.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=ea5dfe57c8eb7edd", SerializerBaseTypeName="System.ComponentModel.Design.Serialization.CodeDomSerializer, System.Design, Version=2.0.5000.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[MetadataTagAttribute("ASPX")]
public __gc abstract class AspControlBoxBase : public FrameControl, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
C++/CLI
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
[ToolboxBitmapAttribute()]
[DesignTimeControllerAttribute()]
[ClientControllerAttribute()]
[DesignerSerializerAttribute(SerializerTypeName="Gizmox.WebGUI.Common.Design.Serialization.AspControlBoxCodeDomSerializer, Gizmox.WebGUI.Common.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=ea5dfe57c8eb7edd", SerializerBaseTypeName="System.ComponentModel.Design.Serialization.CodeDomSerializer, System.Design, Version=2.0.5000.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[MetadataTagAttribute("ASPX")]
public ref class AspControlBoxBase abstract : public FrameControl, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement

Example

The following example illustrates the basic use of AspControlBoxBase.

C# Copy Code
           [System.ComponentModel.ToolboxItem(true)]
public class MyWrappedWebControl : Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase
{
  /// <SUMMARY>
  /// Get the hosted control type
  /// </SUMMARY>
  protected override System.Type HostedControlType
  {
      get
      {
          return typeof(WebControl);
      }
  }

  /// <SUMMARY>
  /// Get hosted control typed instance
  /// </SUMMARY>
  protected WebControl HostedASPxTreeList
  {
      get
      {
          return (WebControl)this.HostedControl;
      }
  }

           }
Visual Basic Copy Code
<SYSTEM.COMPONENTMODEL.TOOLBOXITEM(TRUE)> _
 Partial Class MyWrappedWebControl
Inherits Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase

    ''' <SUMMARY>
    ''' Get the hosted control type
    ''' </SUMMARY>
    Protected Overrides Readonly Property HostedControlType() As System.Type
        Get
            Return GetType(System.Web.UI.Control)
        End Get
    End Property

    ''' <SUMMARY>
    ''' Get hosted control typed instance
    ''' </SUMMARY>
    Protected Readonly Property HostedControl As WebControl
        Get
            Return CType(Me.HostedControl, WebControl)
        End Get
    End Property

End Class

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.FrameControl
Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase
Gizmox.WebGUI.Reporting.ReportViewer

Requirements

Namespace: Gizmox.WebGUI.Forms.Hosts

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

AspControlBoxBase Members
Gizmox.WebGUI.Forms.Hosts Namespace


AspControlBoxBase Class Members

[image]
Gizmox.WebGUI.Forms
AspControlBoxBase Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace : AspControlBoxBase Class

The following tables list the members exposed by AspControlBoxBase.

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
Public Property | BackColor | Gets or sets the background color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BindingContext | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Container | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Context | Gets the context. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ControlCode | Gets or sets the control code.
Public Property | ControlID | Gets or sets the control ID, which indicates the id of the hosted control with in the control code.
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Form | Gets the owner form. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Height | Gets/Sets the height position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | IsAspRequest | Gets a value indicating whether this is ASP request.
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | IsRegistered | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Left | Gets/Sets the left position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Location | Gets or sets the control location. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Right | Gets/Sets the right position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Site | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Top | Gets/Sets the top position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Visible | Gets or sets the control visability. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Width | Gets/Sets the width position (Inherited from Gizmox.WebGUI.Forms.Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultBorderColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultBorderStyle | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultForeColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMargin | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultPadding | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DesignMode | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | Events | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | HostedControl | Get the currently hosted control
Protected Property | HostedControlType | The hosted ASP.NET control type
Protected Property | IsConnected | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Property | IsDelayedDrawing | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | IsFixedSize | Gets a value indicating whether this instance is fixed size.
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | Session | Gets the application object. (Inherited from Gizmox.WebGUI.Forms.Component)
Top

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Focus | Sets focus to this control (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | GetPreferredSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | InvokeClientMethod | Invokes a client side method on the hosted control frame. (Inherited from Gizmox.WebGUI.Forms.FrameControl)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | ResetText | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SendToBack | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Show | Displays the control to the user. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ToString | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Update | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | AddEventHandler | Add an event handler to one of the control's event infos.
Protected Method | CreateControlsInstance | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | CreateHostPageBody | Creates the host page body control.
Protected Method | CreateHostPageForm | Creates the host page form control.
Protected Method | CreateHostPageHead | Creates the host page head control.
Protected Method | Finalize | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetBoolProperty | Gets a hosted control boolean property value
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetColorProperty | Gets a hosted control color property value
Protected Method | GetCommandText | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetEventInfo | Get an event information object.
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetImage | Gets the image. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetIntProperty | Gets a hosted control integer property value
Protected Method | GetPreferredSizeCore | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetProperty | Gets a hosted control property value
Protected Method | GetPropertyInfo | Get property info
Protected Method | GetService | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | InvokeMethod | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | IsDirty | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBindingContextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnControlAdded | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnControlRemoved | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | OnEnabledChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnGotFocus | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHostedControlDataBinding |
Protected Method | OnHostedControlDisposed |
Protected Method | OnHostedControlInit |
Protected Method | OnHostedControlLoad |
Protected Method | OnHostedControlPreRender |
Protected Method | OnHostedControlUnload |
Protected Method | OnHostedPageDataBinding |
Protected Method | OnHostedPageDisposed |
Protected Method | OnHostedPageError | Called when hosted page throws error.
Protected Method | OnHostedPageInit |
Protected Method | OnHostedPageInitComplete |
Protected Method | OnHostedPageLoad | Occurs when the hosting page is loaded.
Protected Method | OnHostedPageLoadComplete |
Protected Method | OnHostedPagePreInit |
Protected Method | OnHostedPagePreLoad |
Protected Method | OnHostedPagePreRender |
Protected Method | OnHostedPagePreRenderComplete |
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLostFocus | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentVisibleChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnResize | Overridden. Raises the E:Resize event.
Protected Method | OnTextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnUnregisterComponents | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnValidated | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnValidating | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ProcessGatewayRequest | Overridden. Provides a way to handle gateway requests.
Protected Method | RegisterBatch | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RegisterSelf | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RemoveEventHandler | Removes an event handler from one of the control's event infos.
Protected Method | Render | Overridden. An abstract control method rendering
Protected Method | RenderAttributes | Overridden. Render control attributes
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderClientUpdateHandler | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderComponentEventAttributes | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetImage | Sets the image. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | SetProperty | Sets a hosted control property value
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeText | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | UnRegisterBatch | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | UnRegisterSelf | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | UpdateParams | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Top

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Disposed | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | HostedControlDataBinding |
Public Event | HostedControlDisposed |
Public Event | HostedControlInit |
Public Event | HostedControlLoad |
Public Event | HostedControlPreRender |
Public Event | HostedControlUnload |
Public Event | HostedHostedPageDataBinding |
Public Event | HostedPageDisposed |
Public Event | HostedPageError |
Public Event | HostedPageInitComplete |
Public Event | HostedPageLoad | Occurs when the hosted control page loads
Public Event | HostedPageLoadComplete |
Public Event | HostedPagePageInit |
Public Event | HostedPagePreInit |
Public Event | HostedPagePreLoad |
Public Event | HostedPagePreRender |
Public Event | HostedPagePreRenderComplete |
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Gizmox.WebGUI.Forms.Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Top

See Also

Reference

AspControlBoxBase Class
Gizmox.WebGUI.Forms.Hosts Namespace


AspControlBoxBase Class Methods

[image]
Gizmox.WebGUI.Forms
AspControlBoxBase Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace : AspControlBoxBase Class

For a list of all members of this type, see AspControlBoxBase members.

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Focus | Sets focus to this control (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | GetPreferredSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | InvokeClientMethod | Invokes a client side method on the hosted control frame. (Inherited from Gizmox.WebGUI.Forms.FrameControl)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | ResetText | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SendToBack | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Show | Displays the control to the user. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ToString | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Update | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | AddEventHandler | Add an event handler to one of the control's event infos.
Protected Method | CreateControlsInstance | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | CreateHostPageBody | Creates the host page body control.
Protected Method | CreateHostPageForm | Creates the host page form control.
Protected Method | CreateHostPageHead | Creates the host page head control.
Protected Method | Finalize | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetBoolProperty | Gets a hosted control boolean property value
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetColorProperty | Gets a hosted control color property value
Protected Method | GetCommandText | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetEventInfo | Get an event information object.
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetImage | Gets the image. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetIntProperty | Gets a hosted control integer property value
Protected Method | GetPreferredSizeCore | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetProperty | Gets a hosted control property value
Protected Method | GetPropertyInfo | Get property info
Protected Method | GetService | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | InvokeMethod | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | IsDirty | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBindingContextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnControlAdded | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnControlRemoved | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | OnEnabledChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnGotFocus | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHostedControlDataBinding |
Protected Method | OnHostedControlDisposed |
Protected Method | OnHostedControlInit |
Protected Method | OnHostedControlLoad |
Protected Method | OnHostedControlPreRender |
Protected Method | OnHostedControlUnload |
Protected Method | OnHostedPageDataBinding |
Protected Method | OnHostedPageDisposed |
Protected Method | OnHostedPageError | Called when hosted page throws error.
Protected Method | OnHostedPageInit |
Protected Method | OnHostedPageInitComplete |
Protected Method | OnHostedPageLoad | Occurs when the hosting page is loaded.
Protected Method | OnHostedPageLoadComplete |
Protected Method | OnHostedPagePreInit |
Protected Method | OnHostedPagePreLoad |
Protected Method | OnHostedPagePreRender |
Protected Method | OnHostedPagePreRenderComplete |
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLostFocus | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentVisibleChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnResize | Overridden. Raises the E:Resize event.
Protected Method | OnTextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnUnregisterComponents | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnValidated | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnValidating | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ProcessGatewayRequest | Overridden. Provides a way to handle gateway requests.
Protected Method | RegisterBatch | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RegisterSelf | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RemoveEventHandler | Removes an event handler from one of the control's event infos.
Protected Method | Render | Overridden. An abstract control method rendering
Protected Method | RenderAttributes | Overridden. Render control attributes
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderClientUpdateHandler | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderComponentEventAttributes | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetImage | Sets the image. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | SetProperty | Sets a hosted control property value
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeText | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | UnRegisterBatch | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | UnRegisterSelf | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | UpdateParams | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Top

See Also

Reference

AspControlBoxBase Class
Gizmox.WebGUI.Forms.Hosts Namespace


AddEventHandler Method

[image]
Gizmox.WebGUI.Forms
AddEventHandler Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AspControlBoxBase Class : AddEventHandler Method

strName
objEventHandler
Add an event handler to one of the control's event infos.

Syntax

Visual Basic (Declaration)
Protected Sub AddEventHandler( _
   ByVal strName As String, _
   ByVal objEventHandler As Delegate _
)
Visual Basic (Usage) Copy Code
Dim instance As AspControlBoxBase
Dim strName As String
Dim objEventHandler As Delegate

instance.AddEventHandler(strName, objEventHandler)
C#
protected void AddEventHandler(
   string strName,
   Delegate objEventHandler
)
Managed Extensions for C++
protected: void AddEventHandler(
   string* strName,
   Delegate* objEventHandler
)
C++/CLI
protected:
void AddEventHandler(
   String^ strName,
   Delegate^ objEventHandler
)

Parameters

strName
objEventHandler

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AspControlBoxBase Class
AspControlBoxBase Members


CreateHostPageBody Method

[image]
Gizmox.WebGUI.Forms
CreateHostPageBody Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AspControlBoxBase Class : CreateHostPageBody Method

Creates the host page body control.

Syntax

Visual Basic (Declaration)
Protected Overridable Function CreateHostPageBody() As HtmlControl
Visual Basic (Usage) Copy Code
Dim instance As AspControlBoxBase
Dim value As HtmlControl

value = instance.CreateHostPageBody()
C#
protected virtual HtmlControl CreateHostPageBody()
Managed Extensions for C++
protected: virtual HtmlControl* CreateHostPageBody();
C++/CLI
protected:
virtual HtmlControl^ CreateHostPageBody();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AspControlBoxBase Class
AspControlBoxBase Members


CreateHostPageForm Method

[image]
Gizmox.WebGUI.Forms
CreateHostPageForm Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AspControlBoxBase Class : CreateHostPageForm Method

Creates the host page form control.

Syntax

Visual Basic (Declaration)
Protected Overridable Function CreateHostPageForm() As HtmlForm
Visual Basic (Usage) Copy Code
Dim instance As AspControlBoxBase
Dim value As HtmlForm

value = instance.CreateHostPageForm()
C#
protected virtual HtmlForm CreateHostPageForm()
Managed Extensions for C++
protected: virtual HtmlForm* CreateHostPageForm();
C++/CLI
protected:
virtual HtmlForm^ CreateHostPageForm();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AspControlBoxBase Class
AspControlBoxBase Members


CreateHostPageHead Method

[image]
Gizmox.WebGUI.Forms
CreateHostPageHead Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AspControlBoxBase Class : CreateHostPageHead Method

Creates the host page head control.

Syntax

Visual Basic (Declaration)
Protected Overridable Function CreateHostPageHead() As HtmlHead
Visual Basic (Usage) Copy Code
Dim instance As AspControlBoxBase
Dim value As HtmlHead

value = instance.CreateHostPageHead()
C#
protected virtual HtmlHead CreateHostPageHead()
Managed Extensions for C++
protected: virtual HtmlHead* CreateHostPageHead();
C++/CLI
protected:
virtual HtmlHead^ CreateHostPageHead();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AspControlBoxBase Class
AspControlBoxBase Members


GetBoolProperty Method

[image]
Gizmox.WebGUI.Forms
GetBoolProperty Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AspControlBoxBase Class : GetBoolProperty Method

strName
Gets a hosted control boolean property value

Syntax

Visual Basic (Declaration)
Protected Function GetBoolProperty( _
   ByVal strName As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As AspControlBoxBase
Dim strName As String
Dim value As Boolean

value = instance.GetBoolProperty(strName)
C#
protected bool GetBoolProperty(
   string strName
)
Managed Extensions for C++
protected: bool GetBoolProperty(
   string* strName
)
C++/CLI
protected:
bool GetBoolProperty(
   String^ strName
)

Parameters

strName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AspControlBoxBase Class
AspControlBoxBase Members


GetColorProperty Method

[image]
Gizmox.WebGUI.Forms
GetColorProperty Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AspControlBoxBase Class : GetColorProperty Method

strName
Gets a hosted control color property value

Syntax

Visual Basic (Declaration)
Protected Function GetColorProperty( _
   ByVal strName As String _
) As Color
Visual Basic (Usage) Copy Code
Dim instance As AspControlBoxBase
Dim strName As String
Dim value As Color

value = instance.GetColorProperty(strName)
C#
protected Color GetColorProperty(
   string strName
)
Managed Extensions for C++
protected: Color GetColorProperty(
   string* strName
)
C++/CLI
protected:
Color GetColorProperty(
   String^ strName
)

Parameters

strName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AspControlBoxBase Class
AspControlBoxBase Members


GetEventInfo Method

[image]
Gizmox.WebGUI.Forms
GetEventInfo Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AspControlBoxBase Class : GetEventInfo Method

strName
Get an event information object.

Syntax

Visual Basic (Declaration)
Protected Function GetEventInfo( _
   ByVal strName As String _
) As EventInfo
Visual Basic (Usage) Copy Code
Dim instance As AspControlBoxBase
Dim strName As String
Dim value As EventInfo

value = instance.GetEventInfo(strName)
C#
protected EventInfo GetEventInfo(
   string strName
)
Managed Extensions for C++
protected: EventInfo* GetEventInfo(
   string* strName
)
C++/CLI
protected:
EventInfo^ GetEventInfo(
   String^ strName
)

Parameters

strName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AspControlBoxBase Class
AspControlBoxBase Members


GetIntProperty Method

[image]
Gizmox.WebGUI.Forms
GetIntProperty Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AspControlBoxBase Class : GetIntProperty Method

strName
Gets a hosted control integer property value

Syntax

Visual Basic (Declaration)
Protected Function GetIntProperty( _
   ByVal strName As String _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As AspControlBoxBase
Dim strName As String
Dim value As Integer

value = instance.GetIntProperty(strName)
C#
protected int GetIntProperty(
   string strName
)
Managed Extensions for C++
protected: int GetIntProperty(
   string* strName
)
C++/CLI
protected:
int GetIntProperty(
   String^ strName
)

Parameters

strName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AspControlBoxBase Class
AspControlBoxBase Members


GetProperty Method

[image]
Gizmox.WebGUI.Forms
GetProperty Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AspControlBoxBase Class : GetProperty Method

strName
Gets a hosted control property value

Syntax

Visual Basic (Declaration)
Protected Function GetProperty( _
   ByVal strName As String _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As AspControlBoxBase
Dim strName As String
Dim value As Object

value = instance.GetProperty(strName)
C#
protected object GetProperty(
   string strName
)
Managed Extensions for C++
protected: Object* GetProperty(
   string* strName
)
C++/CLI
protected:
Object^ GetProperty(
   String^ strName
)

Parameters

strName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AspControlBoxBase Class
AspControlBoxBase Members


GetPropertyInfo Method

[image]
Gizmox.WebGUI.Forms
GetPropertyInfo Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AspControlBoxBase Class : GetPropertyInfo Method

strName
Get property info

Syntax

Visual Basic (Declaration)
Protected Function GetPropertyInfo( _
   ByVal strName As String _
) As PropertyInfo
Visual Basic (Usage) Copy Code
Dim instance As AspControlBoxBase
Dim strName As String
Dim value As PropertyInfo

value = instance.GetPropertyInfo(strName)
C#
protected PropertyInfo GetPropertyInfo(
   string strName
)
Managed Extensions for C++
protected: PropertyInfo* GetPropertyInfo(
   string* strName
)
C++/CLI
protected:
PropertyInfo^ GetPropertyInfo(
   String^ strName
)

Parameters

strName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AspControlBoxBase Class
AspControlBoxBase Members


OnHostedControlDataBinding Method

[image]
Gizmox.WebGUI.Forms
OnHostedControlDataBinding Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AspControlBoxBase Class : OnHostedControlDataBinding Method

sender
e

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnHostedControlDataBinding( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As AspControlBoxBase
Dim sender As Object
Dim e As EventArgs

instance.OnHostedControlDataBinding(sender, e)
C#
protected virtual void OnHostedControlDataBinding(
   object sender,
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnHostedControlDataBinding(
   Object* sender,
   EventArgs* e
)
C++/CLI
protected:
virtual void OnHostedControlDataBinding(
   Object^ sender,
   EventArgs^ e
)

Parameters

sender
e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AspControlBoxBase Class
AspControlBoxBase Members


OnHostedControlDisposed Method

[image]
Gizmox.WebGUI.Forms
OnHostedControlDisposed Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AspControlBoxBase Class : OnHostedControlDisposed Method

sender
e

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnHostedControlDisposed( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As AspControlBoxBase
Dim sender As Object
Dim e As EventArgs

instance.OnHostedControlDisposed(sender, e)
C#
protected virtual void OnHostedControlDisposed(
   object sender,
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnHostedControlDisposed(
   Object* sender,
   EventArgs* e
)
C++/CLI
protected:
virtual void OnHostedControlDisposed(
   Object^ sender,
   EventArgs^ e
)

Parameters

sender
e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AspControlBoxBase Class
AspControlBoxBase Members


OnHostedControlInit Method

[image]
Gizmox.WebGUI.Forms
OnHostedControlInit Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AspControlBoxBase Class : OnHostedControlInit Method

sender
e

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnHostedControlInit( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As AspControlBoxBase
Dim sender As Object
Dim e As EventArgs

instance.OnHostedControlInit(sender, e)
C#
protected virtual void OnHostedControlInit(
   object sender,
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnHostedControlInit(
   Object* sender,
   EventArgs* e
)
C++/CLI
protected:
virtual void OnHostedControlInit(
   Object^ sender,
   EventArgs^ e
)

Parameters

sender
e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AspControlBoxBase Class
AspControlBoxBase Members


OnHostedControlLoad Method

[image]
Gizmox.WebGUI.Forms
OnHostedControlLoad Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AspControlBoxBase Class : OnHostedControlLoad Method

sender
e

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnHostedControlLoad( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As AspControlBoxBase
Dim sender As Object
Dim e As EventArgs

instance.OnHostedControlLoad(sender, e)
C#
protected virtual void OnHostedControlLoad(
   object sender,
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnHostedControlLoad(
   Object* sender,
   EventArgs* e
)
C++/CLI
protected:
virtual void OnHostedControlLoad(
   Object^ sender,
   EventArgs^ e
)

Parameters

sender
e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AspControlBoxBase Class
AspControlBoxBase Members


OnHostedControlPreRender Method

[image]
Gizmox.WebGUI.Forms
OnHostedControlPreRender Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AspControlBoxBase Class : OnHostedControlPreRender Method

sender
e

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnHostedControlPreRender( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As AspControlBoxBase
Dim sender As Object
Dim e As EventArgs

instance.OnHostedControlPreRender(sender, e)
C#
protected virtual void OnHostedControlPreRender(
   object sender,
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnHostedControlPreRender(
   Object* sender,
   EventArgs* e
)
C++/CLI
protected:
virtual void OnHostedControlPreRender(
   Object^ sender,
   EventArgs^ e
)

Parameters

sender
e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AspControlBoxBase Class
AspControlBoxBase Members


OnHostedControlUnload Method

[image]
Gizmox.WebGUI.Forms
OnHostedControlUnload Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AspControlBoxBase Class : OnHostedControlUnload Method

sender
e

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnHostedControlUnload( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As AspControlBoxBase
Dim sender As Object
Dim e As EventArgs

instance.OnHostedControlUnload(sender, e)
C#
protected virtual void OnHostedControlUnload(
   object sender,
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnHostedControlUnload(
   Object* sender,
   EventArgs* e
)
C++/CLI
protected:
virtual void OnHostedControlUnload(
   Object^ sender,
   EventArgs^ e
)

Parameters

sender
e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AspControlBoxBase Class
AspControlBoxBase Members


OnHostedPageDataBinding Method

[image]
Gizmox.WebGUI.Forms
OnHostedPageDataBinding Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AspControlBoxBase Class : OnHostedPageDataBinding Method

sender
e

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnHostedPageDataBinding( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As AspControlBoxBase
Dim sender As Object
Dim e As EventArgs

instance.OnHostedPageDataBinding(sender, e)
C#
protected virtual void OnHostedPageDataBinding(
   object sender,
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnHostedPageDataBinding(
   Object* sender,
   EventArgs* e
)
C++/CLI
protected:
virtual void OnHostedPageDataBinding(
   Object^ sender,
   EventArgs^ e
)

Parameters

sender
e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AspControlBoxBase Class
AspControlBoxBase Members


OnHostedPageDisposed Method

[image]
Gizmox.WebGUI.Forms
OnHostedPageDisposed Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AspControlBoxBase Class : OnHostedPageDisposed Method

sender
e

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnHostedPageDisposed( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As AspControlBoxBase
Dim sender As Object
Dim e As EventArgs

instance.OnHostedPageDisposed(sender, e)
C#
protected virtual void OnHostedPageDisposed(
   object sender,
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnHostedPageDisposed(
   Object* sender,
   EventArgs* e
)
C++/CLI
protected:
virtual void OnHostedPageDisposed(
   Object^ sender,
   EventArgs^ e
)

Parameters

sender
e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AspControlBoxBase Class
AspControlBoxBase Members


OnHostedPageError Method

[image]
Gizmox.WebGUI.Forms
OnHostedPageError Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AspControlBoxBase Class : OnHostedPageError Method

sender
The sender.
e
The EventArgs instance containing the event data.
Called when hosted page throws error.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnHostedPageError( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As AspControlBoxBase
Dim sender As Object
Dim e As EventArgs

instance.OnHostedPageError(sender, e)
C#
protected virtual void OnHostedPageError(
   object sender,
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnHostedPageError(
   Object* sender,
   EventArgs* e
)
C++/CLI
protected:
virtual void OnHostedPageError(
   Object^ sender,
   EventArgs^ e
)

Parameters

sender
The sender.
e
The EventArgs instance containing the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AspControlBoxBase Class
AspControlBoxBase Members


OnHostedPageInit Method

[image]
Gizmox.WebGUI.Forms
OnHostedPageInit Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AspControlBoxBase Class : OnHostedPageInit Method

sender
e

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnHostedPageInit( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As AspControlBoxBase
Dim sender As Object
Dim e As EventArgs

instance.OnHostedPageInit(sender, e)
C#
protected virtual void OnHostedPageInit(
   object sender,
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnHostedPageInit(
   Object* sender,
   EventArgs* e
)
C++/CLI
protected:
virtual void OnHostedPageInit(
   Object^ sender,
   EventArgs^ e
)

Parameters

sender
e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AspControlBoxBase Class
AspControlBoxBase Members


OnHostedPageInitComplete Method

[image]
Gizmox.WebGUI.Forms
OnHostedPageInitComplete Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AspControlBoxBase Class : OnHostedPageInitComplete Method

sender
e

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnHostedPageInitComplete( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As AspControlBoxBase
Dim sender As Object
Dim e As EventArgs

instance.OnHostedPageInitComplete(sender, e)
C#
protected virtual void OnHostedPageInitComplete(
   object sender,
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnHostedPageInitComplete(
   Object* sender,
   EventArgs* e
)
C++/CLI
protected:
virtual void OnHostedPageInitComplete(
   Object^ sender,
   EventArgs^ e
)

Parameters

sender
e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AspControlBoxBase Class
AspControlBoxBase Members


OnHostedPageLoad Method

[image]
Gizmox.WebGUI.Forms
OnHostedPageLoad Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AspControlBoxBase Class : OnHostedPageLoad Method

sender
e
Occurs when the hosting page is loaded.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnHostedPageLoad( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As AspControlBoxBase
Dim sender As Object
Dim e As EventArgs

instance.OnHostedPageLoad(sender, e)
C#
protected virtual void OnHostedPageLoad(
   object sender,
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnHostedPageLoad(
   Object* sender,
   EventArgs* e
)
C++/CLI
protected:
virtual void OnHostedPageLoad(
   Object^ sender,
   EventArgs^ e
)

Parameters

sender
e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AspControlBoxBase Class
AspControlBoxBase Members


OnHostedPageLoadComplete Method

[image]
Gizmox.WebGUI.Forms
OnHostedPageLoadComplete Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AspControlBoxBase Class : OnHostedPageLoadComplete Method

sender
e

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnHostedPageLoadComplete( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As AspControlBoxBase
Dim sender As Object
Dim e As EventArgs

instance.OnHostedPageLoadComplete(sender, e)
C#
protected virtual void OnHostedPageLoadComplete(
   object sender,
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnHostedPageLoadComplete(
   Object* sender,
   EventArgs* e
)
C++/CLI
protected:
virtual void OnHostedPageLoadComplete(
   Object^ sender,
   EventArgs^ e
)

Parameters

sender
e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AspControlBoxBase Class
AspControlBoxBase Members


OnHostedPagePreInit Method

[image]
Gizmox.WebGUI.Forms
OnHostedPagePreInit Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AspControlBoxBase Class : OnHostedPagePreInit Method

sender
e

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnHostedPagePreInit( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As AspControlBoxBase
Dim sender As Object
Dim e As EventArgs

instance.OnHostedPagePreInit(sender, e)
C#
protected virtual void OnHostedPagePreInit(
   object sender,
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnHostedPagePreInit(
   Object* sender,
   EventArgs* e
)
C++/CLI
protected:
virtual void OnHostedPagePreInit(
   Object^ sender,
   EventArgs^ e
)

Parameters

sender
e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AspControlBoxBase Class
AspControlBoxBase Members


OnHostedPagePreLoad Method

[image]
Gizmox.WebGUI.Forms
OnHostedPagePreLoad Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AspControlBoxBase Class : OnHostedPagePreLoad Method

sender
e

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnHostedPagePreLoad( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As AspControlBoxBase
Dim sender As Object
Dim e As EventArgs

instance.OnHostedPagePreLoad(sender, e)
C#
protected virtual void OnHostedPagePreLoad(
   object sender,
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnHostedPagePreLoad(
   Object* sender,
   EventArgs* e
)
C++/CLI
protected:
virtual void OnHostedPagePreLoad(
   Object^ sender,
   EventArgs^ e
)

Parameters

sender
e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AspControlBoxBase Class
AspControlBoxBase Members


OnHostedPagePreRender Method

[image]
Gizmox.WebGUI.Forms
OnHostedPagePreRender Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AspControlBoxBase Class : OnHostedPagePreRender Method

sender
e

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnHostedPagePreRender( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As AspControlBoxBase
Dim sender As Object
Dim e As EventArgs

instance.OnHostedPagePreRender(sender, e)
C#
protected virtual void OnHostedPagePreRender(
   object sender,
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnHostedPagePreRender(
   Object* sender,
   EventArgs* e
)
C++/CLI
protected:
virtual void OnHostedPagePreRender(
   Object^ sender,
   EventArgs^ e
)

Parameters

sender
e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AspControlBoxBase Class
AspControlBoxBase Members


OnHostedPagePreRenderComplete Method

[image]
Gizmox.WebGUI.Forms
OnHostedPagePreRenderComplete Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AspControlBoxBase Class : OnHostedPagePreRenderComplete Method

sender
e

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnHostedPagePreRenderComplete( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As AspControlBoxBase
Dim sender As Object
Dim e As EventArgs

instance.OnHostedPagePreRenderComplete(sender, e)
C#
protected virtual void OnHostedPagePreRenderComplete(
   object sender,
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnHostedPagePreRenderComplete(
   Object* sender,
   EventArgs* e
)
C++/CLI
protected:
virtual void OnHostedPagePreRenderComplete(
   Object^ sender,
   EventArgs^ e
)

Parameters

sender
e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AspControlBoxBase Class
AspControlBoxBase Members


OnResize Method

[image]
Gizmox.WebGUI.Forms
OnResize Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AspControlBoxBase Class : OnResize Method

e
The EventArgs instance containing the event data.
Raises the E:Resize event.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnResize( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As AspControlBoxBase
Dim e As EventArgs

instance.OnResize(e)
C#
protected override void OnResize(
   EventArgs e
)
Managed Extensions for C++
protected: void OnResize(
   EventArgs* e
) override
C++/CLI
protected:
void OnResize(
   EventArgs^ e
) override

Parameters

e
The EventArgs instance containing the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AspControlBoxBase Class
AspControlBoxBase Members


ProcessGatewayRequest Method

[image]
Gizmox.WebGUI.Forms
ProcessGatewayRequest Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AspControlBoxBase Class : ProcessGatewayRequest Method

objHttpContext
The gateway request HTTP context.
strAction
The gateway request action.
Provides a way to handle gateway requests.

Syntax

Visual Basic (Declaration)
Protected Overrides Function ProcessGatewayRequest( _
   ByVal objHttpContext As HttpContext, _
   ByVal strAction As String _
) As IGatewayHandler
Visual Basic (Usage) Copy Code
Dim instance As AspControlBoxBase
Dim objHttpContext As HttpContext
Dim strAction As String
Dim value As IGatewayHandler

value = instance.ProcessGatewayRequest(objHttpContext, strAction)
C#
protected override IGatewayHandler ProcessGatewayRequest(
   HttpContext objHttpContext,
   string strAction
)
Managed Extensions for C++
protected: IGatewayHandler* ProcessGatewayRequest(
   HttpContext* objHttpContext,
   string* strAction
) override
C++/CLI
protected:
IGatewayHandler^ ProcessGatewayRequest(
   HttpContext^ objHttpContext,
   String^ strAction
) override

Parameters

objHttpContext
The gateway request HTTP context.
strAction
The gateway request action.

Return Value

By default this method returns a instance of a class which implements the IGatewayHandler and throws a non implemented HttpException.

Remarks

This method is called from the implementation of IGatewayComponent which replaces the IGatewayControl interface. The IGatewayCompoenent is implemented by default in the RegisteredComponent class which is the base class of most of the Visual WebGui components. Referencing a RegisterComponent that overrides this method is done the same way that a control implementing IGatewayControl, which is by using the GatewayReference class.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AspControlBoxBase Class
AspControlBoxBase Members


RemoveEventHandler Method

[image]
Gizmox.WebGUI.Forms
RemoveEventHandler Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AspControlBoxBase Class : RemoveEventHandler Method

strName
objEventHandler
Removes an event handler from one of the control's event infos.

Syntax

Visual Basic (Declaration)
Protected Sub RemoveEventHandler( _
   ByVal strName As String, _
   ByVal objEventHandler As Delegate _
)
Visual Basic (Usage) Copy Code
Dim instance As AspControlBoxBase
Dim strName As String
Dim objEventHandler As Delegate

instance.RemoveEventHandler(strName, objEventHandler)
C#
protected void RemoveEventHandler(
   string strName,
   Delegate objEventHandler
)
Managed Extensions for C++
protected: void RemoveEventHandler(
   string* strName,
   Delegate* objEventHandler
)
C++/CLI
protected:
void RemoveEventHandler(
   String^ strName,
   Delegate^ objEventHandler
)

Parameters

strName
objEventHandler

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AspControlBoxBase Class
AspControlBoxBase Members


Render Method

[image]
Gizmox.WebGUI.Forms
Render Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AspControlBoxBase Class : Render Method

objContext
objWriter
lngRequestID
An abstract control method rendering

Syntax

Visual Basic (Declaration)
Protected Overrides Sub Render( _
   ByVal objContext As IContext, _
   ByVal objWriter As IResponseWriter, _
   ByVal lngRequestID As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As AspControlBoxBase
Dim objContext As IContext
Dim objWriter As IResponseWriter
Dim lngRequestID As Long

instance.Render(objContext, objWriter, lngRequestID)
C#
protected override void Render(
   IContext objContext,
   IResponseWriter objWriter,
   long lngRequestID
)
Managed Extensions for C++
protected: void Render(
   IContext* objContext,
   IResponseWriter* objWriter,
   long lngRequestID
) override
C++/CLI
protected:
void Render(
   IContext^ objContext,
   IResponseWriter^ objWriter,
   long long lngRequestID
) override

Parameters

objContext
objWriter
lngRequestID

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AspControlBoxBase Class
AspControlBoxBase Members


RenderAttributes Method

[image]
Gizmox.WebGUI.Forms
RenderAttributes Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AspControlBoxBase Class : RenderAttributes Method

context
writer
Render control attributes

Syntax

Visual Basic (Declaration)
Protected Overrides Sub RenderAttributes( _
   ByVal context As IContext, _
   ByVal writer As IAttributeWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As AspControlBoxBase
Dim context As IContext
Dim writer As IAttributeWriter

instance.RenderAttributes(context, writer)
C#
protected override void RenderAttributes(
   IContext context,
   IAttributeWriter writer
)
Managed Extensions for C++
protected: void RenderAttributes(
   IContext* context,
   IAttributeWriter* writer
) override
C++/CLI
protected:
void RenderAttributes(
   IContext^ context,
   IAttributeWriter^ writer
) override

Parameters

context
writer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AspControlBoxBase Class
AspControlBoxBase Members


SetProperty Method

[image]
Gizmox.WebGUI.Forms
SetProperty Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AspControlBoxBase Class : SetProperty Method

strName
objValue
Sets a hosted control property value

Syntax

Visual Basic (Declaration)
Protected Sub SetProperty( _
   ByVal strName As String, _
   ByVal objValue As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As AspControlBoxBase
Dim strName As String
Dim objValue As Object

instance.SetProperty(strName, objValue)
C#
protected void SetProperty(
   string strName,
   object objValue
)
Managed Extensions for C++
protected: void SetProperty(
   string* strName,
   Object* objValue
)
C++/CLI
protected:
void SetProperty(
   String^ strName,
   Object^ objValue
)

Parameters

strName
objValue

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AspControlBoxBase Class
AspControlBoxBase Members


AspControlBoxBase Class Properties

[image]
Gizmox.WebGUI.Forms
AspControlBoxBase Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace : AspControlBoxBase Class

For a list of all members of this type, see AspControlBoxBase members.

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
Public Property | BackColor | Gets or sets the background color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BindingContext | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Container | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Context | Gets the context. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ControlCode | Gets or sets the control code.
Public Property | ControlID | Gets or sets the control ID, which indicates the id of the hosted control with in the control code.
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Form | Gets the owner form. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Height | Gets/Sets the height position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | IsAspRequest | Gets a value indicating whether this is ASP request.
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | IsRegistered | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Left | Gets/Sets the left position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Location | Gets or sets the control location. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Right | Gets/Sets the right position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Site | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Top | Gets/Sets the top position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Visible | Gets or sets the control visability. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Width | Gets/Sets the width position (Inherited from Gizmox.WebGUI.Forms.Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultBorderColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultBorderStyle | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultForeColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMargin | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultPadding | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DesignMode | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | Events | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | HostedControl | Get the currently hosted control
Protected Property | HostedControlType | The hosted ASP.NET control type
Protected Property | IsConnected | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Property | IsDelayedDrawing | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | IsFixedSize | Gets a value indicating whether this instance is fixed size.
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | Session | Gets the application object. (Inherited from Gizmox.WebGUI.Forms.Component)
Top

See Also

Reference

AspControlBoxBase Class
Gizmox.WebGUI.Forms.Hosts Namespace


AutoScroll Property

[image]
Gizmox.WebGUI.Forms
AutoScroll Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AspControlBoxBase Class : AutoScroll Property

Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Indicates whether scroll bars automatically appear when the control contents are larger than its visible area.")>
<SRCategoryAttribute("Layout")>
<DefaultValueAttribute()>
Public Overridable Property AutoScroll As Boolean
Visual Basic (Usage) Copy Code
Dim instance As AspControlBoxBase
Dim value As Boolean

instance.AutoScroll = value

value = instance.AutoScroll
C#
[SRDescriptionAttribute("Indicates whether scroll bars automatically appear when the control contents are larger than its visible area.")]
[SRCategoryAttribute("Layout")]
[DefaultValueAttribute()]
public virtual bool AutoScroll {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("Indicates whether scroll bars automatically appear when the control contents are larger than its visible area.")]
[SRCategoryAttribute("Layout")]
[DefaultValueAttribute()]
public: __property virtual bool get_AutoScroll();
public: __property virtual void set_AutoScroll(
   bool value
);
C++/CLI
[SRDescriptionAttribute("Indicates whether scroll bars automatically appear when the control contents are larger than its visible area.")]
[SRCategoryAttribute("Layout")]
[DefaultValueAttribute()]
public:
virtual property bool AutoScroll {
   bool get();
   void set (boolvalue);
}

Return Value

true if the container enables auto-scrolling; otherwise, false. The default value is true.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AspControlBoxBase Class
AspControlBoxBase Members


ControlCode Property

[image]
Gizmox.WebGUI.Forms
ControlCode Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AspControlBoxBase Class : ControlCode Property

Gets or sets the control code.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Provides a way to initialize the control using ASP.NET markup.")>
<DesignerSerializationVisibilityAttribute()>
<CategoryAttribute("Behavior")>
<EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.AspCodeEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")>
Public Property ControlCode As String
Visual Basic (Usage) Copy Code
Dim instance As AspControlBoxBase
Dim value As String

instance.ControlCode = value

value = instance.ControlCode
C#
[DescriptionAttribute("Provides a way to initialize the control using ASP.NET markup.")]
[DesignerSerializationVisibilityAttribute()]
[CategoryAttribute("Behavior")]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.AspCodeEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
public string ControlCode {get; set;}
Managed Extensions for C++
[DescriptionAttribute("Provides a way to initialize the control using ASP.NET markup.")]
[DesignerSerializationVisibilityAttribute()]
[CategoryAttribute("Behavior")]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.AspCodeEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
public: __property string* get_ControlCode();
public: __property void set_ControlCode(
   string* value
);
C++/CLI
[DescriptionAttribute("Provides a way to initialize the control using ASP.NET markup.")]
[DesignerSerializationVisibilityAttribute()]
[CategoryAttribute("Behavior")]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.AspCodeEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
public:
property String^ ControlCode {
   String^ get();
   void set (String^value);
}

Return Value

The control code.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AspControlBoxBase Class
AspControlBoxBase Members


ControlID Property

[image]
Gizmox.WebGUI.Forms
ControlID Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AspControlBoxBase Class : ControlID Property

Gets or sets the control ID, which indicates the id of the hosted control with in the control code.

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Behavior")>
<DefaultValueAttribute()>
<DescriptionAttribute("The control ID of the hosted control in the markup code.")>
Public Property ControlID As String
Visual Basic (Usage) Copy Code
Dim instance As AspControlBoxBase
Dim value As String

instance.ControlID = value

value = instance.ControlID
C#
[CategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[DescriptionAttribute("The control ID of the hosted control in the markup code.")]
public string ControlID {get; set;}
Managed Extensions for C++
[CategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[DescriptionAttribute("The control ID of the hosted control in the markup code.")]
public: __property string* get_ControlID();
public: __property void set_ControlID(
   string* value
);
C++/CLI
[CategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[DescriptionAttribute("The control ID of the hosted control in the markup code.")]
public:
property String^ ControlID {
   String^ get();
   void set (String^value);
}

Return Value

The control ID.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AspControlBoxBase Class
AspControlBoxBase Members


HostedControl Property

[image]
Gizmox.WebGUI.Forms
HostedControl Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AspControlBoxBase Class : HostedControl Property

Get the currently hosted control

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property HostedControl As Control
Visual Basic (Usage) Copy Code
Dim instance As AspControlBoxBase
Dim value As Control

value = instance.HostedControl
C#
protected Control HostedControl {get;}
Managed Extensions for C++
protected: __property Control* get_HostedControl();
C++/CLI
protected:
property Control^ HostedControl {
   Control^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AspControlBoxBase Class
AspControlBoxBase Members


HostedControlType Property

[image]
Gizmox.WebGUI.Forms
HostedControlType Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AspControlBoxBase Class : HostedControlType Property

The hosted ASP.NET control type

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property HostedControlType As Type
Visual Basic (Usage) Copy Code
Dim instance As AspControlBoxBase
Dim value As Type

value = instance.HostedControlType
C#
protected virtual Type HostedControlType {get;}
Managed Extensions for C++
protected: __property virtual Type* get_HostedControlType();
C++/CLI
protected:
virtual property Type^ HostedControlType {
   Type^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AspControlBoxBase Class
AspControlBoxBase Members


IsAspRequest Property

[image]
Gizmox.WebGUI.Forms
IsAspRequest Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AspControlBoxBase Class : IsAspRequest Property

Gets a value indicating whether this is ASP request.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property IsAspRequest As Boolean
Visual Basic (Usage) Copy Code
Dim instance As AspControlBoxBase
Dim value As Boolean

value = instance.IsAspRequest
C#
[BrowsableAttribute(false)]
public bool IsAspRequest {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property bool get_IsAspRequest();
C++/CLI
[BrowsableAttribute(false)]
public:
property bool IsAspRequest {
   bool get();
}

Return Value

true if this is ASP request; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AspControlBoxBase Class
AspControlBoxBase Members


IsFixedSize Property

[image]
Gizmox.WebGUI.Forms
IsFixedSize Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AspControlBoxBase Class : IsFixedSize Property

Gets a value indicating whether this instance is fixed size.

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property IsFixedSize As Boolean
Visual Basic (Usage) Copy Code
Dim instance As AspControlBoxBase
Dim value As Boolean

value = instance.IsFixedSize
C#
protected virtual bool IsFixedSize {get;}
Managed Extensions for C++
protected: __property virtual bool get_IsFixedSize();
C++/CLI
protected:
virtual property bool IsFixedSize {
   bool get();
}

Return Value

true if this instance is fixed size; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AspControlBoxBase Class
AspControlBoxBase Members


AspControlBoxBase Class Events

[image]
Gizmox.WebGUI.Forms
AspControlBoxBase Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace : AspControlBoxBase Class

For a list of all members of this type, see AspControlBoxBase members.

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Disposed | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | HostedControlDataBinding |
Public Event | HostedControlDisposed |
Public Event | HostedControlInit |
Public Event | HostedControlLoad |
Public Event | HostedControlPreRender |
Public Event | HostedControlUnload |
Public Event | HostedHostedPageDataBinding |
Public Event | HostedPageDisposed |
Public Event | HostedPageError |
Public Event | HostedPageInitComplete |
Public Event | HostedPageLoad | Occurs when the hosted control page loads
Public Event | HostedPageLoadComplete |
Public Event | HostedPagePageInit |
Public Event | HostedPagePreInit |
Public Event | HostedPagePreLoad |
Public Event | HostedPagePreRender |
Public Event | HostedPagePreRenderComplete |
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Gizmox.WebGUI.Forms.Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Top

See Also

Reference

AspControlBoxBase Class
Gizmox.WebGUI.Forms.Hosts Namespace


HostedControlDataBinding Event

[image]
Gizmox.WebGUI.Forms
HostedControlDataBinding Event
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AspControlBoxBase Class : HostedControlDataBinding Event

Syntax

Visual Basic (Declaration)
Public Event HostedControlDataBinding() As AspControlEventHandler
Visual Basic (Usage) Copy Code
Dim instance As AspControlBoxBase
Dim handler As AspControlEventHandler

AddHandler instance.HostedControlDataBinding, handler
C#
public event AspControlEventHandler HostedControlDataBinding()
Managed Extensions for C++
public: __event AspControlEventHandler* HostedControlDataBinding
C++/CLI
public:
event AspControlEventHandler^ HostedControlDataBinding

Event Data

The event handler receives an argument of type AspControlEventArgs containing data related to this event. The following AspControlEventArgs properties provide information specific to this event.

Property | Description
Control | Gets the ASP.NET control that fired this event.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AspControlBoxBase Class
AspControlBoxBase Members


HostedControlDisposed Event

[image]
Gizmox.WebGUI.Forms
HostedControlDisposed Event
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AspControlBoxBase Class : HostedControlDisposed Event

Syntax

Visual Basic (Declaration)
Public Event HostedControlDisposed() As AspControlEventHandler
Visual Basic (Usage) Copy Code
Dim instance As AspControlBoxBase
Dim handler As AspControlEventHandler

AddHandler instance.HostedControlDisposed, handler
C#
public event AspControlEventHandler HostedControlDisposed()
Managed Extensions for C++
public: __event AspControlEventHandler* HostedControlDisposed
C++/CLI
public:
event AspControlEventHandler^ HostedControlDisposed

Event Data

The event handler receives an argument of type AspControlEventArgs containing data related to this event. The following AspControlEventArgs properties provide information specific to this event.

Property | Description
Control | Gets the ASP.NET control that fired this event.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AspControlBoxBase Class
AspControlBoxBase Members


HostedControlInit Event

[image]
Gizmox.WebGUI.Forms
HostedControlInit Event
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AspControlBoxBase Class : HostedControlInit Event

Syntax

Visual Basic (Declaration)
Public Event HostedControlInit() As AspControlEventHandler
Visual Basic (Usage) Copy Code
Dim instance As AspControlBoxBase
Dim handler As AspControlEventHandler

AddHandler instance.HostedControlInit, handler
C#
public event AspControlEventHandler HostedControlInit()
Managed Extensions for C++
public: __event AspControlEventHandler* HostedControlInit
C++/CLI
public:
event AspControlEventHandler^ HostedControlInit

Event Data

The event handler receives an argument of type AspControlEventArgs containing data related to this event. The following AspControlEventArgs properties provide information specific to this event.

Property | Description
Control | Gets the ASP.NET control that fired this event.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AspControlBoxBase Class
AspControlBoxBase Members


HostedControlLoad Event

[image]
Gizmox.WebGUI.Forms
HostedControlLoad Event
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AspControlBoxBase Class : HostedControlLoad Event

Syntax

Visual Basic (Declaration)
Public Event HostedControlLoad() As AspControlEventHandler
Visual Basic (Usage) Copy Code
Dim instance As AspControlBoxBase
Dim handler As AspControlEventHandler

AddHandler instance.HostedControlLoad, handler
C#
public event AspControlEventHandler HostedControlLoad()
Managed Extensions for C++
public: __event AspControlEventHandler* HostedControlLoad
C++/CLI
public:
event AspControlEventHandler^ HostedControlLoad

Event Data

The event handler receives an argument of type AspControlEventArgs containing data related to this event. The following AspControlEventArgs properties provide information specific to this event.

Property | Description
Control | Gets the ASP.NET control that fired this event.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AspControlBoxBase Class
AspControlBoxBase Members


HostedControlPreRender Event

[image]
Gizmox.WebGUI.Forms
HostedControlPreRender Event
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AspControlBoxBase Class : HostedControlPreRender Event

Syntax

Visual Basic (Declaration)
Public Event HostedControlPreRender() As AspControlEventHandler
Visual Basic (Usage) Copy Code
Dim instance As AspControlBoxBase
Dim handler As AspControlEventHandler

AddHandler instance.HostedControlPreRender, handler
C#
public event AspControlEventHandler HostedControlPreRender()
Managed Extensions for C++
public: __event AspControlEventHandler* HostedControlPreRender
C++/CLI
public:
event AspControlEventHandler^ HostedControlPreRender

Event Data

The event handler receives an argument of type AspControlEventArgs containing data related to this event. The following AspControlEventArgs properties provide information specific to this event.

Property | Description
Control | Gets the ASP.NET control that fired this event.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AspControlBoxBase Class
AspControlBoxBase Members


HostedControlUnload Event

[image]
Gizmox.WebGUI.Forms
HostedControlUnload Event
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AspControlBoxBase Class : HostedControlUnload Event

Syntax

Visual Basic (Declaration)
Public Event HostedControlUnload() As AspControlEventHandler
Visual Basic (Usage) Copy Code
Dim instance As AspControlBoxBase
Dim handler As AspControlEventHandler

AddHandler instance.HostedControlUnload, handler
C#
public event AspControlEventHandler HostedControlUnload()
Managed Extensions for C++
public: __event AspControlEventHandler* HostedControlUnload
C++/CLI
public:
event AspControlEventHandler^ HostedControlUnload

Event Data

The event handler receives an argument of type AspControlEventArgs containing data related to this event. The following AspControlEventArgs properties provide information specific to this event.

Property | Description
Control | Gets the ASP.NET control that fired this event.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AspControlBoxBase Class
AspControlBoxBase Members


HostedHostedPageDataBinding Event

[image]
Gizmox.WebGUI.Forms
HostedHostedPageDataBinding Event
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AspControlBoxBase Class : HostedHostedPageDataBinding Event

Syntax

Visual Basic (Declaration)
Public Event HostedHostedPageDataBinding() As AspPageEventHandler
Visual Basic (Usage) Copy Code
Dim instance As AspControlBoxBase
Dim handler As AspPageEventHandler

AddHandler instance.HostedHostedPageDataBinding, handler
C#
public event AspPageEventHandler HostedHostedPageDataBinding()
Managed Extensions for C++
public: __event AspPageEventHandler* HostedHostedPageDataBinding
C++/CLI
public:
event AspPageEventHandler^ HostedHostedPageDataBinding

Event Data

The event handler receives an argument of type AspPageEventArgs containing data related to this event. The following AspPageEventArgs properties provide information specific to this event.

Property | Description
Page | Gets the ASP.NET page that fired this event.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AspControlBoxBase Class
AspControlBoxBase Members


HostedPageDisposed Event

[image]
Gizmox.WebGUI.Forms
HostedPageDisposed Event
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AspControlBoxBase Class : HostedPageDisposed Event

Syntax

Visual Basic (Declaration)
Public Event HostedPageDisposed() As AspPageEventHandler
Visual Basic (Usage) Copy Code
Dim instance As AspControlBoxBase
Dim handler As AspPageEventHandler

AddHandler instance.HostedPageDisposed, handler
C#
public event AspPageEventHandler HostedPageDisposed()
Managed Extensions for C++
public: __event AspPageEventHandler* HostedPageDisposed
C++/CLI
public:
event AspPageEventHandler^ HostedPageDisposed

Event Data

The event handler receives an argument of type AspPageEventArgs containing data related to this event. The following AspPageEventArgs properties provide information specific to this event.

Property | Description
Page | Gets the ASP.NET page that fired this event.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AspControlBoxBase Class
AspControlBoxBase Members


HostedPageError Event

[image]
Gizmox.WebGUI.Forms
HostedPageError Event
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AspControlBoxBase Class : HostedPageError Event

Syntax

Visual Basic (Declaration)
Public Event HostedPageError() As AspPageEventHandler
Visual Basic (Usage) Copy Code
Dim instance As AspControlBoxBase
Dim handler As AspPageEventHandler

AddHandler instance.HostedPageError, handler
C#
public event AspPageEventHandler HostedPageError()
Managed Extensions for C++
public: __event AspPageEventHandler* HostedPageError
C++/CLI
public:
event AspPageEventHandler^ HostedPageError

Event Data

The event handler receives an argument of type AspPageEventArgs containing data related to this event. The following AspPageEventArgs properties provide information specific to this event.

Property | Description
Page | Gets the ASP.NET page that fired this event.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AspControlBoxBase Class
AspControlBoxBase Members


HostedPageInitComplete Event

[image]
Gizmox.WebGUI.Forms
HostedPageInitComplete Event
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AspControlBoxBase Class : HostedPageInitComplete Event

Syntax

Visual Basic (Declaration)
Public Event HostedPageInitComplete() As AspPageEventHandler
Visual Basic (Usage) Copy Code
Dim instance As AspControlBoxBase
Dim handler As AspPageEventHandler

AddHandler instance.HostedPageInitComplete, handler
C#
public event AspPageEventHandler HostedPageInitComplete()
Managed Extensions for C++
public: __event AspPageEventHandler* HostedPageInitComplete
C++/CLI
public:
event AspPageEventHandler^ HostedPageInitComplete

Event Data

The event handler receives an argument of type AspPageEventArgs containing data related to this event. The following AspPageEventArgs properties provide information specific to this event.

Property | Description
Page | Gets the ASP.NET page that fired this event.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AspControlBoxBase Class
AspControlBoxBase Members


HostedPageLoad Event

[image]
Gizmox.WebGUI.Forms
HostedPageLoad Event
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AspControlBoxBase Class : HostedPageLoad Event

Occurs when the hosted control page loads

Syntax

Visual Basic (Declaration)
Public Event HostedPageLoad() As AspPageEventHandler
Visual Basic (Usage) Copy Code
Dim instance As AspControlBoxBase
Dim handler As AspPageEventHandler

AddHandler instance.HostedPageLoad, handler
C#
public event AspPageEventHandler HostedPageLoad()
Managed Extensions for C++
public: __event AspPageEventHandler* HostedPageLoad
C++/CLI
public:
event AspPageEventHandler^ HostedPageLoad

Event Data

The event handler receives an argument of type AspPageEventArgs containing data related to this event. The following AspPageEventArgs properties provide information specific to this event.

Property | Description
Page | Gets the ASP.NET page that fired this event.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AspControlBoxBase Class
AspControlBoxBase Members


HostedPageLoadComplete Event

[image]
Gizmox.WebGUI.Forms
HostedPageLoadComplete Event
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AspControlBoxBase Class : HostedPageLoadComplete Event

Syntax

Visual Basic (Declaration)
Public Event HostedPageLoadComplete() As AspPageEventHandler
Visual Basic (Usage) Copy Code
Dim instance As AspControlBoxBase
Dim handler As AspPageEventHandler

AddHandler instance.HostedPageLoadComplete, handler
C#
public event AspPageEventHandler HostedPageLoadComplete()
Managed Extensions for C++
public: __event AspPageEventHandler* HostedPageLoadComplete
C++/CLI
public:
event AspPageEventHandler^ HostedPageLoadComplete

Event Data

The event handler receives an argument of type AspPageEventArgs containing data related to this event. The following AspPageEventArgs properties provide information specific to this event.

Property | Description
Page | Gets the ASP.NET page that fired this event.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AspControlBoxBase Class
AspControlBoxBase Members


HostedPagePageInit Event

[image]
Gizmox.WebGUI.Forms
HostedPagePageInit Event
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AspControlBoxBase Class : HostedPagePageInit Event

Syntax

Visual Basic (Declaration)
Public Event HostedPagePageInit() As AspPageEventHandler
Visual Basic (Usage) Copy Code
Dim instance As AspControlBoxBase
Dim handler As AspPageEventHandler

AddHandler instance.HostedPagePageInit, handler
C#
public event AspPageEventHandler HostedPagePageInit()
Managed Extensions for C++
public: __event AspPageEventHandler* HostedPagePageInit
C++/CLI
public:
event AspPageEventHandler^ HostedPagePageInit

Event Data

The event handler receives an argument of type AspPageEventArgs containing data related to this event. The following AspPageEventArgs properties provide information specific to this event.

Property | Description
Page | Gets the ASP.NET page that fired this event.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AspControlBoxBase Class
AspControlBoxBase Members


HostedPagePreInit Event

[image]
Gizmox.WebGUI.Forms
HostedPagePreInit Event
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AspControlBoxBase Class : HostedPagePreInit Event

Syntax

Visual Basic (Declaration)
Public Event HostedPagePreInit() As AspPageEventHandler
Visual Basic (Usage) Copy Code
Dim instance As AspControlBoxBase
Dim handler As AspPageEventHandler

AddHandler instance.HostedPagePreInit, handler
C#
public event AspPageEventHandler HostedPagePreInit()
Managed Extensions for C++
public: __event AspPageEventHandler* HostedPagePreInit
C++/CLI
public:
event AspPageEventHandler^ HostedPagePreInit

Event Data

The event handler receives an argument of type AspPageEventArgs containing data related to this event. The following AspPageEventArgs properties provide information specific to this event.

Property | Description
Page | Gets the ASP.NET page that fired this event.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AspControlBoxBase Class
AspControlBoxBase Members


HostedPagePreLoad Event

[image]
Gizmox.WebGUI.Forms
HostedPagePreLoad Event
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AspControlBoxBase Class : HostedPagePreLoad Event

Syntax

Visual Basic (Declaration)
Public Event HostedPagePreLoad() As AspPageEventHandler
Visual Basic (Usage) Copy Code
Dim instance As AspControlBoxBase
Dim handler As AspPageEventHandler

AddHandler instance.HostedPagePreLoad, handler
C#
public event AspPageEventHandler HostedPagePreLoad()
Managed Extensions for C++
public: __event AspPageEventHandler* HostedPagePreLoad
C++/CLI
public:
event AspPageEventHandler^ HostedPagePreLoad

Event Data

The event handler receives an argument of type AspPageEventArgs containing data related to this event. The following AspPageEventArgs properties provide information specific to this event.

Property | Description
Page | Gets the ASP.NET page that fired this event.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AspControlBoxBase Class
AspControlBoxBase Members


HostedPagePreRender Event

[image]
Gizmox.WebGUI.Forms
HostedPagePreRender Event
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AspControlBoxBase Class : HostedPagePreRender Event

Syntax

Visual Basic (Declaration)
Public Event HostedPagePreRender() As AspPageEventHandler
Visual Basic (Usage) Copy Code
Dim instance As AspControlBoxBase
Dim handler As AspPageEventHandler

AddHandler instance.HostedPagePreRender, handler
C#
public event AspPageEventHandler HostedPagePreRender()
Managed Extensions for C++
public: __event AspPageEventHandler* HostedPagePreRender
C++/CLI
public:
event AspPageEventHandler^ HostedPagePreRender

Event Data

The event handler receives an argument of type AspPageEventArgs containing data related to this event. The following AspPageEventArgs properties provide information specific to this event.

Property | Description
Page | Gets the ASP.NET page that fired this event.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AspControlBoxBase Class
AspControlBoxBase Members


HostedPagePreRenderComplete Event

[image]
Gizmox.WebGUI.Forms
HostedPagePreRenderComplete Event
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AspControlBoxBase Class : HostedPagePreRenderComplete Event

Syntax

Visual Basic (Declaration)
Public Event HostedPagePreRenderComplete() As AspPageEventHandler
Visual Basic (Usage) Copy Code
Dim instance As AspControlBoxBase
Dim handler As AspPageEventHandler

AddHandler instance.HostedPagePreRenderComplete, handler
C#
public event AspPageEventHandler HostedPagePreRenderComplete()
Managed Extensions for C++
public: __event AspPageEventHandler* HostedPagePreRenderComplete
C++/CLI
public:
event AspPageEventHandler^ HostedPagePreRenderComplete

Event Data

The event handler receives an argument of type AspPageEventArgs containing data related to this event. The following AspPageEventArgs properties provide information specific to this event.

Property | Description
Page | Gets the ASP.NET page that fired this event.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AspControlBoxBase Class
AspControlBoxBase Members


AspControlBoxBase.ResourceFile Class

[image]
Gizmox.WebGUI.Forms
AspControlBoxBase.ResourceFile Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace : AspControlBoxBase.ResourceFile Class

Provides an implementation of a virtual file that can compile a code at runtime from a string or an embeded resource

Syntax

Visual Basic (Declaration)
Private Class AspControlBoxBase.ResourceFile
   Inherits VirtualFile
Visual Basic (Usage) Copy Code
Dim instance As AspControlBoxBase.ResourceFile
C#
private class AspControlBoxBase.ResourceFile : VirtualFile
Managed Extensions for C++
private __gc class AspControlBoxBase.ResourceFile : public VirtualFile
C++/CLI
private ref class AspControlBoxBase.ResourceFile : public VirtualFile

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.Web.Hosting.VirtualFileBase
System.Web.Hosting.VirtualFile
Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase.ResourceFile

Requirements

Namespace: Gizmox.WebGUI.Forms.Hosts

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

AspControlBoxBase.ResourceFile Members
Gizmox.WebGUI.Forms.Hosts Namespace


AspControlBoxBase.ResourceFile Class Members

[image]
Gizmox.WebGUI.Forms
AspControlBoxBase.ResourceFile Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace : AspControlBoxBase.ResourceFile Class

The following tables list the members exposed by AspControlBoxBase.ResourceFile.

Public Properties

 | Name | Description
Public Property | IsDirectory | Gets a value that indicates that this is a virtual resource that should be treated as a file. (Inherited from System.Web.Hosting.VirtualFile)
Public Property | Name | Gets the display name of the virtual resource. (Inherited from System.Web.Hosting.VirtualFileBase)
Public Property | VirtualPath | Gets the virtual file path. (Inherited from System.Web.Hosting.VirtualFileBase)
Top

Public Methods

 | Name | Description
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | Gives a VirtualFileBase instance an infinite lifetime by preventing a lease from being created. (Inherited from System.Web.Hosting.VirtualFileBase)
Public Method | Open | Overridden. Opens this instance.
Top

Protected Methods

 | Name | Description
Protected Method | MemberwiseClone | Overloaded. Creates a shallow copy of the current MarshalByRefObject object. (Inherited from System.MarshalByRefObject)
Top

See Also

Reference

AspControlBoxBase.ResourceFile Class
Gizmox.WebGUI.Forms.Hosts Namespace


AspControlBoxBase.ResourceFile Class Methods

[image]
Gizmox.WebGUI.Forms
AspControlBoxBase.ResourceFile Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace : AspControlBoxBase.ResourceFile Class

For a list of all members of this type, see AspControlBoxBase.ResourceFile members.

Public Methods

 | Name | Description
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | Gives a VirtualFileBase instance an infinite lifetime by preventing a lease from being created. (Inherited from System.Web.Hosting.VirtualFileBase)
Public Method | Open | Overridden. Opens this instance.
Top

Protected Methods

 | Name | Description
Protected Method | MemberwiseClone | Overloaded. Creates a shallow copy of the current MarshalByRefObject object. (Inherited from System.MarshalByRefObject)
Top

See Also

Reference

AspControlBoxBase.ResourceFile Class
Gizmox.WebGUI.Forms.Hosts Namespace


Open Method

[image]
Gizmox.WebGUI.Forms
Open Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AspControlBoxBase.ResourceFile Class : Open Method

Opens this instance.

Syntax

Visual Basic (Declaration)
Public Overrides Function Open() As Stream
Visual Basic (Usage) Copy Code
Dim instance As AspControlBoxBase.ResourceFile
Dim value As Stream

value = instance.Open()
C#
public override Stream Open()
Managed Extensions for C++
public: Stream* Open(); override
C++/CLI
public:
Stream^ Open(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AspControlBoxBase.ResourceFile Class
AspControlBoxBase.ResourceFile Members


AspControlBoxBase.ResourceProvider Class

[image]
Gizmox.WebGUI.Forms
AspControlBoxBase.ResourceProvider Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace : AspControlBoxBase.ResourceProvider Class

Provides a custom resource provider to help build types from string or an embeded resource

Syntax

Visual Basic (Declaration)
Private Class AspControlBoxBase.ResourceProvider
   Inherits VirtualPathProvider
Visual Basic (Usage) Copy Code
Dim instance As AspControlBoxBase.ResourceProvider
C#
private class AspControlBoxBase.ResourceProvider : VirtualPathProvider
Managed Extensions for C++
private __gc class AspControlBoxBase.ResourceProvider : public VirtualPathProvider
C++/CLI
private ref class AspControlBoxBase.ResourceProvider : public VirtualPathProvider

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.Web.Hosting.VirtualPathProvider
Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase.ResourceProvider

Requirements

Namespace: Gizmox.WebGUI.Forms.Hosts

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

AspControlBoxBase.ResourceProvider Members
Gizmox.WebGUI.Forms.Hosts Namespace


AspControlBoxBase.ResourceProvider Class Members

[image]
Gizmox.WebGUI.Forms
AspControlBoxBase.ResourceProvider Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace : AspControlBoxBase.ResourceProvider Class

The following tables list the members exposed by AspControlBoxBase.ResourceProvider.

Protected Properties

 | Name | Description
Protected Property | Previous | Gets a reference to a previously registered VirtualPathProvider object in the compilation system. (Inherited from System.Web.Hosting.VirtualPathProvider)
Top

Public Methods

 | Name | Description
Public Method | CombineVirtualPaths | Combines a base path with a relative path to return a complete path to a virtual resource. (Inherited from System.Web.Hosting.VirtualPathProvider)
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | DirectoryExists | Gets a value that indicates whether a directory exists in the virtual file system. (Inherited from System.Web.Hosting.VirtualPathProvider)
Public Method | FileExists | Overridden. Gets a value that indicates whether a file exists in the virtual file system.
Public Method | GetCacheDependency | Overridden. Creates a cache dependency based on the specified virtual paths.
Public Method | GetCacheKey | Returns a cache key to use for the specified virtual path. (Inherited from System.Web.Hosting.VirtualPathProvider)
static (Shared in Visual Basic) | GetCompiledType | Overloaded. Gets the type compiled from source.
Public Method | GetDirectory | Gets a virtual directory from the virtual file system. (Inherited from System.Web.Hosting.VirtualPathProvider)
Public Method | GetFile | Overridden. Gets the file.
Public Method | GetFileHash | Returns a hash of the specified virtual paths. (Inherited from System.Web.Hosting.VirtualPathProvider)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | Gives the VirtualPathProvider object an infinite lifetime by preventing a lease from being created. (Inherited from System.Web.Hosting.VirtualPathProvider)
Top

Protected Methods

 | Name | Description
Protected Method | Initialize | Initializes the VirtualPathProvider instance. (Inherited from System.Web.Hosting.VirtualPathProvider)
Protected Method | MemberwiseClone | Overloaded. Creates a shallow copy of the current MarshalByRefObject object. (Inherited from System.MarshalByRefObject)
Top

See Also

Reference

AspControlBoxBase.ResourceProvider Class
Gizmox.WebGUI.Forms.Hosts Namespace


AspControlBoxBase.ResourceProvider Class Methods

[image]
Gizmox.WebGUI.Forms
AspControlBoxBase.ResourceProvider Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace : AspControlBoxBase.ResourceProvider Class

For a list of all members of this type, see AspControlBoxBase.ResourceProvider members.

Public Methods

 | Name | Description
Public Method | CombineVirtualPaths | Combines a base path with a relative path to return a complete path to a virtual resource. (Inherited from System.Web.Hosting.VirtualPathProvider)
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | DirectoryExists | Gets a value that indicates whether a directory exists in the virtual file system. (Inherited from System.Web.Hosting.VirtualPathProvider)
Public Method | FileExists | Overridden. Gets a value that indicates whether a file exists in the virtual file system.
Public Method | GetCacheDependency | Overridden. Creates a cache dependency based on the specified virtual paths.
Public Method | GetCacheKey | Returns a cache key to use for the specified virtual path. (Inherited from System.Web.Hosting.VirtualPathProvider)
static (Shared in Visual Basic) | GetCompiledType | Overloaded. Gets the type compiled from source.
Public Method | GetDirectory | Gets a virtual directory from the virtual file system. (Inherited from System.Web.Hosting.VirtualPathProvider)
Public Method | GetFile | Overridden. Gets the file.
Public Method | GetFileHash | Returns a hash of the specified virtual paths. (Inherited from System.Web.Hosting.VirtualPathProvider)
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | InitializeLifetimeService | Gives the VirtualPathProvider object an infinite lifetime by preventing a lease from being created. (Inherited from System.Web.Hosting.VirtualPathProvider)
Top

Protected Methods

 | Name | Description
Protected Method | Initialize | Initializes the VirtualPathProvider instance. (Inherited from System.Web.Hosting.VirtualPathProvider)
Protected Method | MemberwiseClone | Overloaded. Creates a shallow copy of the current MarshalByRefObject object. (Inherited from System.MarshalByRefObject)
Top

See Also

Reference

AspControlBoxBase.ResourceProvider Class
Gizmox.WebGUI.Forms.Hosts Namespace


FileExists Method

[image]
Gizmox.WebGUI.Forms
FileExists Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AspControlBoxBase.ResourceProvider Class : FileExists Method

virtualPath
The path to the virtual file.
Gets a value that indicates whether a file exists in the virtual file system.

Syntax

Visual Basic (Declaration)
Public Overrides Function FileExists( _
   ByVal virtualPath As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As AspControlBoxBase.ResourceProvider
Dim virtualPath As String
Dim value As Boolean

value = instance.FileExists(virtualPath)
C#
public override bool FileExists(
   string virtualPath
)
Managed Extensions for C++
public: bool FileExists(
   string* virtualPath
) override
C++/CLI
public:
bool FileExists(
   String^ virtualPath
) override

Parameters

virtualPath
The path to the virtual file.

Return Value

true if the file exists in the virtual file system; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AspControlBoxBase.ResourceProvider Class
AspControlBoxBase.ResourceProvider Members


GetCacheDependency Method

[image]
Gizmox.WebGUI.Forms
GetCacheDependency Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AspControlBoxBase.ResourceProvider Class : GetCacheDependency Method

virtualPath
The path to the primary virtual resource.
virtualPathDependencies
An array of paths to other resources required by the primary virtual resource.
utcStart
The UTC time at which the virtual resources were read.
Creates a cache dependency based on the specified virtual paths.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetCacheDependency( _
   ByVal virtualPath As String, _
   ByVal virtualPathDependencies As IEnumerable, _
   ByVal utcStart As Date _
) As CacheDependency
Visual Basic (Usage) Copy Code
Dim instance As AspControlBoxBase.ResourceProvider
Dim virtualPath As String
Dim virtualPathDependencies As IEnumerable
Dim utcStart As Date
Dim value As CacheDependency

value = instance.GetCacheDependency(virtualPath, virtualPathDependencies, utcStart)
C#
public override CacheDependency GetCacheDependency(
   string virtualPath,
   IEnumerable virtualPathDependencies,
   DateTime utcStart
)
Managed Extensions for C++
public: CacheDependency* GetCacheDependency(
   string* virtualPath,
   IEnumerable* virtualPathDependencies,
   DateTime utcStart
) override
C++/CLI
public:
CacheDependency^ GetCacheDependency(
   String^ virtualPath,
   IEnumerable^ virtualPathDependencies,
   DateTime utcStart
) override

Parameters

virtualPath
The path to the primary virtual resource.
virtualPathDependencies
An array of paths to other resources required by the primary virtual resource.
utcStart
The UTC time at which the virtual resources were read.

Return Value

A CacheDependency object for the specified virtual resources.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AspControlBoxBase.ResourceProvider Class
AspControlBoxBase.ResourceProvider Members


GetCompiledType Method

[image]
Gizmox.WebGUI.Forms
GetCompiledType Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AspControlBoxBase.ResourceProvider Class : GetCompiledType Method

Gets the type compiled from source.

Overload List

Overload | Description
GetCompiledType(String,String) | Gets the type compiled from source.
GetCompiledType(String) | Gets the type of the compiled.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AspControlBoxBase.ResourceProvider Class
AspControlBoxBase.ResourceProvider Members


GetCompiledType(String,String) Method

[image]
Gizmox.WebGUI.Forms
GetCompiledType(String,String) Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AspControlBoxBase.ResourceProvider Class > GetCompiledType Method : GetCompiledType(String,String) Method

strAssemblyName
The assembly in which the resource is embedded.
strResourceName
The resource name with in the assembly.
Gets the type compiled from source.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function GetCompiledType( _
   ByVal strAssemblyName As String, _
   ByVal strResourceName As String _
) As Type
Visual Basic (Usage) Copy Code
Dim strAssemblyName As String
Dim strResourceName As String
Dim value As Type

value = AspControlBoxBase.ResourceProvider.GetCompiledType(strAssemblyName, strResourceName)
C#
public static Type GetCompiledType(
   string strAssemblyName,
   string strResourceName
)
Managed Extensions for C++
public: static Type* GetCompiledType(
   string* strAssemblyName,
   string* strResourceName
)
C++/CLI
public:
static Type^ GetCompiledType(
   String^ strAssemblyName,
   String^ strResourceName
)

Parameters

strAssemblyName
The assembly in which the resource is embedded.
strResourceName
The resource name with in the assembly.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AspControlBoxBase.ResourceProvider Class
AspControlBoxBase.ResourceProvider Members
Overload List


GetCompiledType(String) Method

[image]
Gizmox.WebGUI.Forms
GetCompiledType(String) Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AspControlBoxBase.ResourceProvider Class > GetCompiledType Method : GetCompiledType(String) Method

strAspCode
The ASP code.
Gets the type of the compiled.

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function GetCompiledType( _
   ByVal strAspCode As String _
) As Type
Visual Basic (Usage) Copy Code
Dim strAspCode As String
Dim value As Type

value = AspControlBoxBase.ResourceProvider.GetCompiledType(strAspCode)
C#
public static Type GetCompiledType(
   string strAspCode
)
Managed Extensions for C++
public: static Type* GetCompiledType(
   string* strAspCode
)
C++/CLI
public:
static Type^ GetCompiledType(
   String^ strAspCode
)

Parameters

strAspCode
The ASP code.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AspControlBoxBase.ResourceProvider Class
AspControlBoxBase.ResourceProvider Members
Overload List


GetFile Method

[image]
Gizmox.WebGUI.Forms
GetFile Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AspControlBoxBase.ResourceProvider Class : GetFile Method

virtualPath
The virtual path.
Gets the file.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetFile( _
   ByVal virtualPath As String _
) As VirtualFile
Visual Basic (Usage) Copy Code
Dim instance As AspControlBoxBase.ResourceProvider
Dim virtualPath As String
Dim value As VirtualFile

value = instance.GetFile(virtualPath)
C#
public override VirtualFile GetFile(
   string virtualPath
)
Managed Extensions for C++
public: VirtualFile* GetFile(
   string* virtualPath
) override
C++/CLI
public:
VirtualFile^ GetFile(
   String^ virtualPath
) override

Parameters

virtualPath
The virtual path.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AspControlBoxBase.ResourceProvider Class
AspControlBoxBase.ResourceProvider Members


AspControlEventArgs Class

[image]
Gizmox.WebGUI.Forms
AspControlEventArgs Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace : AspControlEventArgs Class

Provides a base class for hosted ASP.NET events

Syntax

Visual Basic (Declaration)
Public Class AspControlEventArgs
   Inherits EventArgs
Visual Basic (Usage) Copy Code
Dim instance As AspControlEventArgs
C#
public class AspControlEventArgs : EventArgs
Managed Extensions for C++
public __gc class AspControlEventArgs : public EventArgs
C++/CLI
public ref class AspControlEventArgs : public EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gizmox.WebGUI.Forms.Hosts.AspControlEventArgs

Requirements

Namespace: Gizmox.WebGUI.Forms.Hosts

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

AspControlEventArgs Members
Gizmox.WebGUI.Forms.Hosts Namespace


AspControlEventArgs Class Members

[image]
Gizmox.WebGUI.Forms
AspControlEventArgs Class Members
See Also Properties Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace : AspControlEventArgs Class

The following tables list the members exposed by AspControlEventArgs.

Public Properties

 | Name | Description
Public Property | Control | Gets the ASP.NET control that fired this event.
Top

See Also

Reference

AspControlEventArgs Class
Gizmox.WebGUI.Forms.Hosts Namespace


AspControlEventArgs Class Properties

[image]
Gizmox.WebGUI.Forms
AspControlEventArgs Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace : AspControlEventArgs Class

For a list of all members of this type, see AspControlEventArgs members.

Public Properties

 | Name | Description
Public Property | Control | Gets the ASP.NET control that fired this event.
Top

See Also

Reference

AspControlEventArgs Class
Gizmox.WebGUI.Forms.Hosts Namespace


Control Property

[image]
Gizmox.WebGUI.Forms
Control Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AspControlEventArgs Class : Control Property

Gets the ASP.NET control that fired this event.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Control As Control
Visual Basic (Usage) Copy Code
Dim instance As AspControlEventArgs
Dim value As Control

value = instance.Control
C#
public Control Control {get;}
Managed Extensions for C++
public: __property Control* get_Control();
C++/CLI
public:
property Control^ Control {
   Control^ get();
}

Return Value

The ASP.NET control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AspControlEventArgs Class
AspControlEventArgs Members


AspPageBase Class

[image]
Gizmox.WebGUI.Forms
AspPageBase Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace : AspPageBase Class

Provides an System.Web.UI.Page implementation that adds state management and visual webgui pipeline integration

Object Model

Syntax

Visual Basic (Declaration)
Public Class AspPageBase
   Inherits AspPipeLinePage
Visual Basic (Usage) Copy Code
Dim instance As AspPageBase
C#
public class AspPageBase : AspPipeLinePage
Managed Extensions for C++
public __gc class AspPageBase : public AspPipeLinePage
C++/CLI
public ref class AspPageBase : public AspPipeLinePage

Inheritance Hierarchy

System.Object
System.Web.UI.Control
System.Web.UI.TemplateControl
System.Web.UI.Page
Gizmox.WebGUI.Forms.Hosts.AspPipeLinePage
Gizmox.WebGUI.Forms.Hosts.AspPageBase

Requirements

Namespace: Gizmox.WebGUI.Forms.Hosts

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

AspPageBase Members
Gizmox.WebGUI.Forms.Hosts Namespace


AspPageBase Class Members

[image]
Gizmox.WebGUI.Forms
AspPageBase Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace : AspPageBase Class

The following tables list the members exposed by AspPageBase.

Public Constructors

 | Name | Description
Public Constructor | AspPageBase Constructor |
Top

Public Properties

 | Name | Description
Public Property | Application | Gets the HttpApplicationState object for the current Web request. (Inherited from System.Web.UI.Page)
Public Property | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from System.Web.UI.Control)
Public Property | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from System.Web.UI.TemplateControl)
Public Property | AsyncTimeout | Gets or sets a value indicating the time-out interval used when processing asynchronous tasks. (Inherited from System.Web.UI.Page)
Public Property | AutoPostBackControl | (Inherited from System.Web.UI.Page)
Public Property | Cache | Gets the Cache object associated with the application in which the page resides. (Inherited from System.Web.UI.Page)
Public Property | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from System.Web.UI.Control)
Public Property | ClientQueryString | Gets the query string portion of the requested URL. (Inherited from System.Web.UI.Page)
Public Property | ClientScript | Gets a ClientScriptManager object used to manage, register, and add script to the page. (Inherited from System.Web.UI.Page)
Public Property | ClientTarget | Gets or sets a value that allows you to override automatic detection of browser capabilities and to specify how a page is rendered for particular browser clients. (Inherited from System.Web.UI.Page)
Public Property | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from System.Web.UI.Control)
Public Property | Culture | Sets the culture ID for the Thread object associated with the page. (Inherited from System.Web.UI.Page)
Public Property | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from System.Web.UI.TemplateControl)
Public Property | EnableViewState | Gets or sets a value indicating whether the page maintains its view state, and the view state of any server controls it contains, when the current page request ends. (Inherited from System.Web.UI.Page)
Public Property | ErrorPage | Gets or sets the error page to which the requesting browser is redirected in the event of an unhandled page exception. (Inherited from System.Web.UI.Page)
Public Property | Form | Gets the HTML form for the page. (Inherited from System.Web.UI.Page)
Public Property | Header | Gets the document header for the page if the head element is defined with a runat=server in the page declaration. (Inherited from System.Web.UI.Page)
Public Property | IsAsync | Gets a value indicating whether the page is processed asynchronously. (Inherited from System.Web.UI.Page)
Public Property | IsCallback | Gets a value indicating whether the page request is the result of a call back. (Inherited from System.Web.UI.Page)
Public Property | IsCrossPagePostBack | Gets a value indicating whether the page is involved in a cross-page postback. (Inherited from System.Web.UI.Page)
Public Property | IsPostBack | Gets a value indicating whether the page is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from System.Web.UI.Page)
Public Property | IsPostBackEventControlRegistered | (Inherited from System.Web.UI.Page)
Public Property | IsValid | Gets a value indicating whether page validation succeeded. (Inherited from System.Web.UI.Page)
Public Property | Items | Gets a list of objects stored in the page context. (Inherited from System.Web.UI.Page)
Public Property | MaintainScrollPositionOnPostBack | Gets or sets a value indicating whether to return the user to the same position in the client browser after postback. (Inherited from System.Web.UI.Page)
Public Property | Master | Gets the master page that determines the overall look of the page. (Inherited from System.Web.UI.Page)
Public Property | MasterPageFile | Gets or sets the file name of the master page. (Inherited from System.Web.UI.Page)
Public Property | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from System.Web.UI.Control)
Public Property | Page | Gets a reference to the Page instance that contains the server control. (Inherited from System.Web.UI.Control)
Public Property | PageAdapter | Gets the adapter that renders the page for the specific requesting browser. (Inherited from System.Web.UI.Page)
Public Property | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from System.Web.UI.Control)
Public Property | PreviousPage | Gets the page that transferred control to the current page. (Inherited from System.Web.UI.Page)
Public Property | Request | Gets the HttpRequest object for the requested page. (Inherited from System.Web.UI.Page)
Public Property | Response | Gets the HttpResponse object associated with the Page object. This object allows you to send HTTP response data to a client and contains information about that response. (Inherited from System.Web.UI.Page)
Public Property | Server | Gets the Server object, which is an instance of the HttpServerUtility class. (Inherited from System.Web.UI.Page)
Public Property | Session | Gets the current Session object provided by ASP.NET. (Inherited from System.Web.UI.Page)
Public Property | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from System.Web.UI.Control)
Public Property | SkinID | Gets or sets the skin to apply to the control. (Inherited from System.Web.UI.Control)
Public Property | SmartNavigation | Gets or sets a value indicating whether smart navigation is enabled. (Inherited from System.Web.UI.Page)
Public Property | StyleSheetTheme | Gets or sets the name of the style sheet applied to this page. (Inherited from System.Web.UI.Page)
Public Property | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from System.Web.UI.Control)
Public Property | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from System.Web.UI.Control)
Public Property | Theme | Gets or sets the name of the page theme. (Inherited from System.Web.UI.Page)
Public Property | Title | Gets or sets the title for the page. (Inherited from System.Web.UI.Page)
Public Property | Trace | Gets the TraceContext object for the current Web request. (Inherited from System.Web.UI.Page)
Public Property | UICulture | Sets the user interface (UI) ID for the Thread object associated with the page. (Inherited from System.Web.UI.Page)
Public Property | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from System.Web.UI.Control)
Public Property | User | Gets information about the user making the page request. (Inherited from System.Web.UI.Page)
Public Property | Validators | Gets a collection of all validation controls contained on the requested page. (Inherited from System.Web.UI.Page)
Public Property | ViewStateUserKey | Assigns an identifier to an individual user in the view-state variable associated with the current page. (Inherited from System.Web.UI.Page)
Public Property | Visible | Gets or sets a value indicating whether the Page object is rendered. (Inherited from System.Web.UI.Page)
Top

Protected Properties

 | Name | Description
Protected Property | Adapter | Gets the browser-specific adapter for the control. (Inherited from System.Web.UI.Control)
Protected Property | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from System.Web.UI.Control)
Protected Property | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from System.Web.UI.Control)
Protected Property | Context | Gets the HttpContext object associated with the page. (Inherited from System.Web.UI.Page)
Protected Property | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from System.Web.UI.Control)
Protected Property | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from System.Web.UI.Control)
Protected Property | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from System.Web.UI.Control)
Protected Property | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from System.Web.UI.Control)
Protected Property | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from System.Web.UI.Control)
Protected Property | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from System.Web.UI.Control)
Protected Property | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from System.Web.UI.Control)
Protected Property | PageContext |
Protected Property | PageStatePersister | Gets the PageStatePersister object associated with the page. (Inherited from AspPipeLinePage)
Protected Property | UniqueFilePathSuffix | Gets a unique suffix to append to the file path for caching browsers. (Inherited from System.Web.UI.Page)
Protected Property | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from System.Web.UI.Control)
Protected Property | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from System.Web.UI.Control)
Top

Public Methods

 | Name | Description
Public Method | AddOnPreRenderCompleteAsync | Overloaded. Registers beginning and ending event handler delegates that do not require state information for an asynchronous page. (Inherited from System.Web.UI.Page)
Public Method | ApplyStyleSheetSkin | Applies the style properties defined in the page style sheet to the control. (Inherited from System.Web.UI.Control)
Public Method | DataBind | Overloaded. Binds a data source to the invoked server control and all its child controls. (Inherited from System.Web.UI.Control)
Public Method | Dispose | Enables a server control to perform final clean up before it is released from memory. (Inherited from System.Web.UI.Control)
Public Method | ExecuteRegisteredAsyncTasks | Starts the execution of an asynchronous task. (Inherited from System.Web.UI.Page)
Public Method | FindControl | Overloaded. Searches the page naming container for a server control with the specified identifier. (Inherited from System.Web.UI.Page)
Public Method | Focus | Sets input focus to a control. (Inherited from System.Web.UI.Control)
Public Method | GetDataItem | Gets the data item at the top of the data-binding context stack. (Inherited from System.Web.UI.Page)
Public Method | GetPostBackClientEvent | Gets a reference that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from System.Web.UI.Page)
Public Method | GetPostBackClientHyperlink | Gets a reference, with javascript: appended to the beginning of it, that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from System.Web.UI.Page)
Public Method | GetPostBackEventReference | Overloaded. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object. (Inherited from System.Web.UI.Page)
Public Method | GetValidators | Returns a collection of control validators for a specified validation group. (Inherited from System.Web.UI.Page)
Public Method | HasControls | Determines if the server control contains any child controls. (Inherited from System.Web.UI.Control)
Public Method | IsClientScriptBlockRegistered | Determines whether the client script block with the specified key is registered with the page. (Inherited from System.Web.UI.Page)
Public Method | IsStartupScriptRegistered | Determines whether the client startup script is registered with the Page object. (Inherited from System.Web.UI.Page)
Public Method | LoadControl | Overloaded. Loads a Control object from a file based on a specified virtual path. (Inherited from System.Web.UI.TemplateControl)
Public Method | LoadTemplate | Obtains an instance of the ITemplate interface from an external file. (Inherited from System.Web.UI.TemplateControl)
Public Method | MapPath | Retrieves the physical path that a virtual path, either absolute or relative, or an application-relative path maps to. (Inherited from System.Web.UI.Page)
Public Method | ParseControl | Overloaded. Parses an input string into a Control object on the Web Forms page or user control. (Inherited from System.Web.UI.TemplateControl)
Public Method | RegisterArrayDeclaration | Declares a value that is declared as an ECMAScript array declaration when the page is rendered. (Inherited from System.Web.UI.Page)
Public Method | RegisterAsyncTask | Registers a new asynchronous task with the page. (Inherited from System.Web.UI.Page)
Public Method | RegisterClientScriptBlock | Emits client-side script blocks to the response. (Inherited from System.Web.UI.Page)
Public Method | RegisterHiddenField | Allows server controls to automatically register a hidden field on the form. The field will be sent to the Page object when the HtmlForm server control is rendered. (Inherited from System.Web.UI.Page)
Public Method | RegisterOnSubmitStatement | Allows a page to access the client OnSubmit event. The script should be a function call to client code registered elsewhere. (Inherited from System.Web.UI.Page)
Public Method | RegisterRequiresControlState | Registers a control as one whose control state must be persisted. (Inherited from System.Web.UI.Page)
Public Method | RegisterRequiresPostBack | Registers a control as one that requires postback handling when the page is posted back to the server. (Inherited from System.Web.UI.Page)
Public Method | RegisterRequiresRaiseEvent | Registers an ASP.NET server control as one requiring an event to be raised when the control is processed on the Page object. (Inherited from System.Web.UI.Page)
Public Method | RegisterRequiresViewStateEncryption | Registers a control with the page as one requiring view-state encryption. (Inherited from System.Web.UI.Page)
Public Method | RegisterStartupScript | Emits a client-side script block in the page response. (Inherited from System.Web.UI.Page)
Public Method | RegisterViewStateHandler | Causes page view state to be persisted, if called. (Inherited from System.Web.UI.Page)
Public Method | RenderControl | Overloaded. Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from System.Web.UI.Control)
Public Method | RequiresControlState | Determines whether the specified Control object is registered to participate in control state management. (Inherited from System.Web.UI.Page)
Public Method | ResolveClientUrl | Gets a URL that can be used by the browser. (Inherited from System.Web.UI.Control)
Public Method | ResolveUrl | Converts a URL into one that is usable on the requesting client. (Inherited from System.Web.UI.Control)
Public Method | SetFocus | Overloaded. Sets the browser focus to the specified control. (Inherited from System.Web.UI.Page)
Public Method | SetRenderMethodDelegate | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from System.Web.UI.Control)
Public Method | TestDeviceFilter | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from System.Web.UI.TemplateControl)
Public Method | UnregisterRequiresControlState | Stops persistence of control state for the specified control. (Inherited from System.Web.UI.Page)
Public Method | Validate | Overloaded. Instructs any validation controls included on the page to validate their assigned information. (Inherited from System.Web.UI.Page)
Public Method | VerifyRenderingInServerForm | Confirms that an HtmlForm control is rendered for the specified ASP.NET server control at run time. (Inherited from System.Web.UI.Page)
Top

Protected Methods

 | Name | Description
Protected Method | AddedControl | Called after a child control is added to the Controls collection of the Control object. (Inherited from System.Web.UI.Control)
Protected Method | AddParsedSubObject | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from System.Web.UI.Control)
Protected Method | BuildProfileTree | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from System.Web.UI.Control)
Protected Method | ClearChildControlState | Deletes the control-state information for the server control's child controls. (Inherited from System.Web.UI.Control)
Protected Method | ClearChildState | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from System.Web.UI.Control)
Protected Method | ClearChildViewState | Deletes the view-state information for all the server control's child controls. (Inherited from System.Web.UI.Control)
Protected Method | Construct | Performs design-time logic. (Inherited from System.Web.UI.TemplateControl)
Protected Method | CreateChildControls | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from System.Web.UI.Control)
Protected Method | CreateControlCollection | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from System.Web.UI.Control)
Protected Method | CreateHtmlTextWriter | Creates an HtmlTextWriter object to render the page's content. (Inherited from System.Web.UI.Page)
Protected Method | CreateResourceBasedLiteralControl | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl method is not intended for use from within your code. (Inherited from System.Web.UI.TemplateControl)
Protected Method | DataBindChildren | Binds a data source to the server control's child controls. (Inherited from System.Web.UI.Control)
Protected Method | DeterminePostBackMode | Returns a NameValueCollection of data posted back to the page using either a POST or a GET command. (Inherited from System.Web.UI.Page)
Protected Method | EnsureChildControls | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from System.Web.UI.Control)
Protected Method | EnsureID | Creates an identifier for controls that do not have an identifier assigned. (Inherited from System.Web.UI.Control)
Protected Method | Eval | Overloaded. Evaluates a data-binding expression. (Inherited from System.Web.UI.TemplateControl)
Protected Method | FrameworkInitialize | Initializes the control tree during page generation based on the declarative nature of the page. (Inherited from System.Web.UI.Page)
Protected Method | GetDesignModeState | Gets design-time data for a control. (Inherited from System.Web.UI.Control)
Protected Method | GetGlobalResourceObject | Overloaded. Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from System.Web.UI.TemplateControl)
Protected Method | GetLocalResourceObject | Overloaded. Gets a page-level resource object based on the specified ResourceKey property. (Inherited from System.Web.UI.TemplateControl)
Protected Method | HasEvents | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from System.Web.UI.Control)
Protected Method | InitializeCulture | Sets the Culture and UICulture for the current thread of the page. (Inherited from System.Web.UI.Page)
Protected Method | IsLiteralContent | Determines if the server control holds only literal content. (Inherited from System.Web.UI.Control)
Protected Method | LoadControlState | Restores control-state information from a previous page request that was saved by the SaveControlState method. (Inherited from System.Web.UI.Control)
Protected Method | LoadPageStateFromPersistenceMedium | Loads any saved view-state information to the Page object. (Inherited from System.Web.UI.Page)
Protected Method | LoadViewState | Restores view-state information from a previous page request that was saved by the SaveViewState method. (Inherited from System.Web.UI.Control)
Protected Method | MapPathSecure | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from System.Web.UI.Control)
Protected Method | OnAbortTransaction | Raises the AbortTransaction event. (Inherited from System.Web.UI.TemplateControl)
Protected Method | OnBubbleEvent | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from System.Web.UI.Control)
Protected Method | OnCommitTransaction | Raises the CommitTransaction event. (Inherited from System.Web.UI.TemplateControl)
Protected Method | OnDataBinding | Raises the DataBinding event. (Inherited from System.Web.UI.Control)
Protected Method | OnError | Raises the Error event. (Inherited from System.Web.UI.TemplateControl)
Protected Method | OnInit | Called when the page is initialized (Inherited from AspPipeLinePage)
Protected Method | OnInitComplete | Raises the InitComplete event after page initialization. (Inherited from AspPipeLinePage)
Protected Method | OnLoad | Raises the Load event. (Inherited from System.Web.UI.Control)
Protected Method | OnLoadComplete | Raises the LoadComplete event at the end of the page load stage. (Inherited from System.Web.UI.Page)
Protected Method | OnPreInit | Raises the PreInit event at the beginning of page initialization. (Inherited from System.Web.UI.Page)
Protected Method | OnPreLoad | Called before the page is loaded to get the pipeline events (Inherited from AspPipeLinePage)
Protected Method | OnPreRender | Generates an update command to the pipeline field (Inherited from AspPipeLinePage)
Protected Method | OnPreRenderComplete | Raises the PreRenderComplete event after the OnPreRenderComplete event and before the page is rendered. (Inherited from System.Web.UI.Page)
Protected Method | OnSaveStateComplete | Raises the SaveStateComplete event after the page state has been saved to the persistence medium. (Inherited from System.Web.UI.Page)
Protected Method | OnUnload | Raises the Unload event. (Inherited from System.Web.UI.Control)
Protected Method | OpenFile | Gets a Stream used to read a file. (Inherited from System.Web.UI.Control)
Protected Method | RaiseBubbleEvent | Assigns any sources of the event and its information to the control's parent. (Inherited from System.Web.UI.Control)
Protected Method | RaisePostBackEvent | Notifies the server control that caused the postback that it should handle an incoming postback event. (Inherited from System.Web.UI.Page)
Protected Method | RemovedControl | Called after a control is removed from the Controls collection of another control. (Inherited from System.Web.UI.Control)
Protected Method | Render | Initializes the HtmlTextWriter object and calls on the child controls of the Page to render. (Inherited from System.Web.UI.Page)
Protected Method | RenderChildren | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from System.Web.UI.Control)
Protected Method | ResolveAdapter | Gets the control adapter responsible for rendering the specified control. (Inherited from System.Web.UI.Control)
Protected Method | SaveControlState | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from System.Web.UI.Control)
Protected Method | SavePageStateToPersistenceMedium | Saves any view-state and control-state information for the page. (Inherited from System.Web.UI.Page)
Protected Method | SaveViewState | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from System.Web.UI.Control)
Protected Method | SetDesignModeState | Sets design-time data for a control. (Inherited from System.Web.UI.Control)
Protected Method | TrackViewState | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from System.Web.UI.Control)
Protected Method | XPath | Overloaded. Evaluates an XPath data-binding expression. (Inherited from System.Web.UI.TemplateControl)
Protected Method | XPathSelect | Overloaded. Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from System.Web.UI.TemplateControl)
Top

Public Events

 | Name | Description
Public Event | AbortTransaction | Occurs when a user ends a transaction. (Inherited from System.Web.UI.TemplateControl)
Public Event | CommitTransaction | Occurs when a transaction completes. (Inherited from System.Web.UI.TemplateControl)
Public Event | DataBinding | Occurs when the server control binds to a data source. (Inherited from System.Web.UI.Control)
Public Event | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from System.Web.UI.Control)
Public Event | Error | Occurs when an unhandled exception is thrown. (Inherited from System.Web.UI.TemplateControl)
Public Event | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from System.Web.UI.Control)
Public Event | InitComplete | Occurs when page initialization is complete. (Inherited from System.Web.UI.Page)
Public Event | Load | Occurs when the server control is loaded into the Page object. (Inherited from System.Web.UI.Control)
Public Event | LoadComplete | Occurs at the end of the load stage of the page's life cycle. (Inherited from System.Web.UI.Page)
Public Event | PreInit | Occurs at the beginning of page initialization. (Inherited from System.Web.UI.Page)
Public Event | PreLoad | Occurs before the page Load event. (Inherited from System.Web.UI.Page)
Public Event | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from System.Web.UI.Control)
Public Event | PreRenderComplete | Occurs before the page content is rendered. (Inherited from System.Web.UI.Page)
Public Event | SaveStateComplete | Occurs after the page has completed saving all view state and control state information for the page and controls on the page. (Inherited from System.Web.UI.Page)
Public Event | Unload | Occurs when the server control is unloaded from memory. (Inherited from System.Web.UI.Control)
Top

See Also

Reference

AspPageBase Class
Gizmox.WebGUI.Forms.Hosts Namespace


AspPageBase Constructor

[image]
Gizmox.WebGUI.Forms
AspPageBase Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AspPageBase Class : AspPageBase Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As AspPageBase()
C#
public AspPageBase()
Managed Extensions for C++
public: AspPageBase();
C++/CLI
public:
AspPageBase();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AspPageBase Class
AspPageBase Members


AspPageBase Class Properties

[image]
Gizmox.WebGUI.Forms
AspPageBase Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace : AspPageBase Class

For a list of all members of this type, see AspPageBase members.

Public Properties

 | Name | Description
Public Property | Application | Gets the HttpApplicationState object for the current Web request. (Inherited from System.Web.UI.Page)
Public Property | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from System.Web.UI.Control)
Public Property | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from System.Web.UI.TemplateControl)
Public Property | AsyncTimeout | Gets or sets a value indicating the time-out interval used when processing asynchronous tasks. (Inherited from System.Web.UI.Page)
Public Property | AutoPostBackControl | (Inherited from System.Web.UI.Page)
Public Property | Cache | Gets the Cache object associated with the application in which the page resides. (Inherited from System.Web.UI.Page)
Public Property | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from System.Web.UI.Control)
Public Property | ClientQueryString | Gets the query string portion of the requested URL. (Inherited from System.Web.UI.Page)
Public Property | ClientScript | Gets a ClientScriptManager object used to manage, register, and add script to the page. (Inherited from System.Web.UI.Page)
Public Property | ClientTarget | Gets or sets a value that allows you to override automatic detection of browser capabilities and to specify how a page is rendered for particular browser clients. (Inherited from System.Web.UI.Page)
Public Property | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from System.Web.UI.Control)
Public Property | Culture | Sets the culture ID for the Thread object associated with the page. (Inherited from System.Web.UI.Page)
Public Property | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from System.Web.UI.TemplateControl)
Public Property | EnableViewState | Gets or sets a value indicating whether the page maintains its view state, and the view state of any server controls it contains, when the current page request ends. (Inherited from System.Web.UI.Page)
Public Property | ErrorPage | Gets or sets the error page to which the requesting browser is redirected in the event of an unhandled page exception. (Inherited from System.Web.UI.Page)
Public Property | Form | Gets the HTML form for the page. (Inherited from System.Web.UI.Page)
Public Property | Header | Gets the document header for the page if the head element is defined with a runat=server in the page declaration. (Inherited from System.Web.UI.Page)
Public Property | IsAsync | Gets a value indicating whether the page is processed asynchronously. (Inherited from System.Web.UI.Page)
Public Property | IsCallback | Gets a value indicating whether the page request is the result of a call back. (Inherited from System.Web.UI.Page)
Public Property | IsCrossPagePostBack | Gets a value indicating whether the page is involved in a cross-page postback. (Inherited from System.Web.UI.Page)
Public Property | IsPostBack | Gets a value indicating whether the page is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from System.Web.UI.Page)
Public Property | IsPostBackEventControlRegistered | (Inherited from System.Web.UI.Page)
Public Property | IsValid | Gets a value indicating whether page validation succeeded. (Inherited from System.Web.UI.Page)
Public Property | Items | Gets a list of objects stored in the page context. (Inherited from System.Web.UI.Page)
Public Property | MaintainScrollPositionOnPostBack | Gets or sets a value indicating whether to return the user to the same position in the client browser after postback. (Inherited from System.Web.UI.Page)
Public Property | Master | Gets the master page that determines the overall look of the page. (Inherited from System.Web.UI.Page)
Public Property | MasterPageFile | Gets or sets the file name of the master page. (Inherited from System.Web.UI.Page)
Public Property | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from System.Web.UI.Control)
Public Property | Page | Gets a reference to the Page instance that contains the server control. (Inherited from System.Web.UI.Control)
Public Property | PageAdapter | Gets the adapter that renders the page for the specific requesting browser. (Inherited from System.Web.UI.Page)
Public Property | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from System.Web.UI.Control)
Public Property | PreviousPage | Gets the page that transferred control to the current page. (Inherited from System.Web.UI.Page)
Public Property | Request | Gets the HttpRequest object for the requested page. (Inherited from System.Web.UI.Page)
Public Property | Response | Gets the HttpResponse object associated with the Page object. This object allows you to send HTTP response data to a client and contains information about that response. (Inherited from System.Web.UI.Page)
Public Property | Server | Gets the Server object, which is an instance of the HttpServerUtility class. (Inherited from System.Web.UI.Page)
Public Property | Session | Gets the current Session object provided by ASP.NET. (Inherited from System.Web.UI.Page)
Public Property | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from System.Web.UI.Control)
Public Property | SkinID | Gets or sets the skin to apply to the control. (Inherited from System.Web.UI.Control)
Public Property | SmartNavigation | Gets or sets a value indicating whether smart navigation is enabled. (Inherited from System.Web.UI.Page)
Public Property | StyleSheetTheme | Gets or sets the name of the style sheet applied to this page. (Inherited from System.Web.UI.Page)
Public Property | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from System.Web.UI.Control)
Public Property | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from System.Web.UI.Control)
Public Property | Theme | Gets or sets the name of the page theme. (Inherited from System.Web.UI.Page)
Public Property | Title | Gets or sets the title for the page. (Inherited from System.Web.UI.Page)
Public Property | Trace | Gets the TraceContext object for the current Web request. (Inherited from System.Web.UI.Page)
Public Property | UICulture | Sets the user interface (UI) ID for the Thread object associated with the page. (Inherited from System.Web.UI.Page)
Public Property | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from System.Web.UI.Control)
Public Property | User | Gets information about the user making the page request. (Inherited from System.Web.UI.Page)
Public Property | Validators | Gets a collection of all validation controls contained on the requested page. (Inherited from System.Web.UI.Page)
Public Property | ViewStateUserKey | Assigns an identifier to an individual user in the view-state variable associated with the current page. (Inherited from System.Web.UI.Page)
Public Property | Visible | Gets or sets a value indicating whether the Page object is rendered. (Inherited from System.Web.UI.Page)
Top

Protected Properties

 | Name | Description
Protected Property | Adapter | Gets the browser-specific adapter for the control. (Inherited from System.Web.UI.Control)
Protected Property | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from System.Web.UI.Control)
Protected Property | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from System.Web.UI.Control)
Protected Property | Context | Gets the HttpContext object associated with the page. (Inherited from System.Web.UI.Page)
Protected Property | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from System.Web.UI.Control)
Protected Property | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from System.Web.UI.Control)
Protected Property | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from System.Web.UI.Control)
Protected Property | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from System.Web.UI.Control)
Protected Property | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from System.Web.UI.Control)
Protected Property | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from System.Web.UI.Control)
Protected Property | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from System.Web.UI.Control)
Protected Property | PageContext |
Protected Property | PageStatePersister | Gets the PageStatePersister object associated with the page. (Inherited from AspPipeLinePage)
Protected Property | UniqueFilePathSuffix | Gets a unique suffix to append to the file path for caching browsers. (Inherited from System.Web.UI.Page)
Protected Property | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from System.Web.UI.Control)
Protected Property | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from System.Web.UI.Control)
Top

See Also

Reference

AspPageBase Class
Gizmox.WebGUI.Forms.Hosts Namespace


PageContext Property

[image]
Gizmox.WebGUI.Forms
PageContext Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AspPageBase Class : PageContext Property

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property PageContext As AspPageBox
Visual Basic (Usage) Copy Code
Dim instance As AspPageBase
Dim value As AspPageBox

value = instance.PageContext
C#
protected AspPageBox PageContext {get;}
Managed Extensions for C++
protected: __property AspPageBox* get_PageContext();
C++/CLI
protected:
property AspPageBox^ PageContext {
   AspPageBox^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AspPageBase Class
AspPageBase Members


AspPageBox Class

[image]
Gizmox.WebGUI.Forms
AspPageBox Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace : AspPageBox Class

Summary description for ASPXHostBox

Object Model

Syntax

Visual Basic (Declaration)
<DesignTimeControllerAttribute()>
<ToolboxItemCategoryAttribute("Host Controls")>
<SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableHtmlBox, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")>
<MetadataTagAttribute("ASPX")>
<ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<ToolboxBitmapAttribute()>
<ClientControllerAttribute()>
Public Class AspPageBox
   Inherits FrameControl
   Implements IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IGatewayControl, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Visual Basic (Usage) Copy Code
Dim instance As AspPageBox
C#
[DesignTimeControllerAttribute()]
[ToolboxItemCategoryAttribute("Host Controls")]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableHtmlBox, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[MetadataTagAttribute("ASPX")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ToolboxBitmapAttribute()]
[ClientControllerAttribute()]
public class AspPageBox : FrameControl, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IGatewayControl, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Managed Extensions for C++
[DesignTimeControllerAttribute()]
[ToolboxItemCategoryAttribute("Host Controls")]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableHtmlBox, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[MetadataTagAttribute("ASPX")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ToolboxBitmapAttribute()]
[ClientControllerAttribute()]
public __gc class AspPageBox : public FrameControl, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IGatewayControl, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
C++/CLI
[DesignTimeControllerAttribute()]
[ToolboxItemCategoryAttribute("Host Controls")]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableHtmlBox, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[MetadataTagAttribute("ASPX")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ToolboxBitmapAttribute()]
[ClientControllerAttribute()]
public ref class AspPageBox : public FrameControl, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IGatewayControl, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.FrameControl
Gizmox.WebGUI.Forms.Hosts.AspPageBox

Requirements

Namespace: Gizmox.WebGUI.Forms.Hosts

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

AspPageBox Members
Gizmox.WebGUI.Forms.Hosts Namespace


AspPageBox Class Members

[image]
Gizmox.WebGUI.Forms
AspPageBox Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace : AspPageBox Class

The following tables list the members exposed by AspPageBox.

Public Constructors

 | Name | Description
Public Constructor | AspPageBox Constructor |
Top

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackColor | Gets or sets the background color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BindingContext | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Container | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Context | Gets the context. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Form | Gets the owner form. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Height | Gets/Sets the height position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | IsRegistered | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Left | Gets/Sets the left position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Location | Gets or sets the control location. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Path | The path of the asp page to be displayed
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Right | Gets/Sets the right position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Site | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Top | Gets/Sets the top position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Visible | Gets or sets the control visability. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Width | Gets/Sets the width position (Inherited from Gizmox.WebGUI.Forms.Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultBorderColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultBorderStyle | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultForeColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMargin | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultPadding | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DesignMode | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | Events | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | IsConnected | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Property | IsDelayedDrawing | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | Session | Gets the application object. (Inherited from Gizmox.WebGUI.Forms.Component)
Top

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Focus | Sets focus to this control (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | GetPreferredSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | InvokeClientMethod | Invokes a client side method on the hosted control frame. (Inherited from Gizmox.WebGUI.Forms.FrameControl)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | ResetText | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SendToBack | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Show | Displays the control to the user. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ToString | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Update | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | Finalize | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCommandText | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetImage | Gets the image. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetPreferredSizeCore | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetService | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | InvokeMethod | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | IsDirty | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBindingContextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnControlAdded | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnControlRemoved | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | OnEnabledChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnGotFocus | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLostFocus | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentVisibleChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnResize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnTextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnUnregisterComponents | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnValidated | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnValidating | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ProcessGatewayRequest | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RegisterSelf | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | RenderAttributes | Overridden.
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderClientUpdateHandler | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderComponentEventAttributes | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetImage | Sets the image. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeText | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | UnRegisterBatch | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | UnRegisterSelf | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | UpdateParams | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Top

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Disposed | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Gizmox.WebGUI.Forms.Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Top

See Also

Reference

AspPageBox Class
Gizmox.WebGUI.Forms.Hosts Namespace


AspPageBox Constructor

[image]
Gizmox.WebGUI.Forms
AspPageBox Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AspPageBox Class : AspPageBox Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As AspPageBox()
C#
public AspPageBox()
Managed Extensions for C++
public: AspPageBox();
C++/CLI
public:
AspPageBox();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AspPageBox Class
AspPageBox Members


AspPageBox Class Methods

[image]
Gizmox.WebGUI.Forms
AspPageBox Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace : AspPageBox Class

For a list of all members of this type, see AspPageBox members.

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Focus | Sets focus to this control (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | GetPreferredSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | InvokeClientMethod | Invokes a client side method on the hosted control frame. (Inherited from Gizmox.WebGUI.Forms.FrameControl)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | ResetText | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SendToBack | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Show | Displays the control to the user. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ToString | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Update | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | Finalize | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCommandText | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetImage | Gets the image. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetPreferredSizeCore | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetService | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | InvokeMethod | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | IsDirty | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBindingContextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnControlAdded | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnControlRemoved | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | OnEnabledChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnGotFocus | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLostFocus | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentVisibleChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnResize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnTextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnUnregisterComponents | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnValidated | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnValidating | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ProcessGatewayRequest | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RegisterSelf | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | RenderAttributes | Overridden.
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderClientUpdateHandler | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderComponentEventAttributes | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetImage | Sets the image. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeText | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | UnRegisterBatch | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | UnRegisterSelf | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | UpdateParams | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Top

See Also

Reference

AspPageBox Class
Gizmox.WebGUI.Forms.Hosts Namespace


RenderAttributes Method

[image]
Gizmox.WebGUI.Forms
RenderAttributes Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AspPageBox Class : RenderAttributes Method

context
writer

Syntax

Visual Basic (Declaration)
Protected Overrides Sub RenderAttributes( _
   ByVal context As IContext, _
   ByVal writer As IAttributeWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As AspPageBox
Dim context As IContext
Dim writer As IAttributeWriter

instance.RenderAttributes(context, writer)
C#
protected override void RenderAttributes(
   IContext context,
   IAttributeWriter writer
)
Managed Extensions for C++
protected: void RenderAttributes(
   IContext* context,
   IAttributeWriter* writer
) override
C++/CLI
protected:
void RenderAttributes(
   IContext^ context,
   IAttributeWriter^ writer
) override

Parameters

context
writer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AspPageBox Class
AspPageBox Members


AspPageBox Class Properties

[image]
Gizmox.WebGUI.Forms
AspPageBox Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace : AspPageBox Class

For a list of all members of this type, see AspPageBox members.

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackColor | Gets or sets the background color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BindingContext | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Container | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Context | Gets the context. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Form | Gets the owner form. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Height | Gets/Sets the height position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | IsRegistered | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Left | Gets/Sets the left position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Location | Gets or sets the control location. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Path | The path of the asp page to be displayed
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Right | Gets/Sets the right position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Site | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Top | Gets/Sets the top position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Visible | Gets or sets the control visability. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Width | Gets/Sets the width position (Inherited from Gizmox.WebGUI.Forms.Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultBorderColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultBorderStyle | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultForeColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMargin | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultPadding | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DesignMode | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | Events | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | IsConnected | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Property | IsDelayedDrawing | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | Session | Gets the application object. (Inherited from Gizmox.WebGUI.Forms.Component)
Top

See Also

Reference

AspPageBox Class
Gizmox.WebGUI.Forms.Hosts Namespace


Path Property

[image]
Gizmox.WebGUI.Forms
Path Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AspPageBox Class : Path Property

The path of the asp page to be displayed

Syntax

Visual Basic (Declaration)
Public Property Path As String
Visual Basic (Usage) Copy Code
Dim instance As AspPageBox
Dim value As String

instance.Path = value

value = instance.Path
C#
public string Path {get; set;}
Managed Extensions for C++
public: __property string* get_Path();
public: __property void set_Path(
   string* value
);
C++/CLI
public:
property String^ Path {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AspPageBox Class
AspPageBox Members


AspPageEventArgs Class

[image]
Gizmox.WebGUI.Forms
AspPageEventArgs Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace : AspPageEventArgs Class

Provides a base class for hosted ASP.NET events

Syntax

Visual Basic (Declaration)
Public Class AspPageEventArgs
   Inherits EventArgs
Visual Basic (Usage) Copy Code
Dim instance As AspPageEventArgs
C#
public class AspPageEventArgs : EventArgs
Managed Extensions for C++
public __gc class AspPageEventArgs : public EventArgs
C++/CLI
public ref class AspPageEventArgs : public EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gizmox.WebGUI.Forms.Hosts.AspPageEventArgs

Requirements

Namespace: Gizmox.WebGUI.Forms.Hosts

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

AspPageEventArgs Members
Gizmox.WebGUI.Forms.Hosts Namespace


AspPageEventArgs Class Members

[image]
Gizmox.WebGUI.Forms
AspPageEventArgs Class Members
See Also Properties Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace : AspPageEventArgs Class

The following tables list the members exposed by AspPageEventArgs.

Public Properties

 | Name | Description
Public Property | Page | Gets the ASP.NET page that fired this event.
Top

See Also

Reference

AspPageEventArgs Class
Gizmox.WebGUI.Forms.Hosts Namespace


AspPageEventArgs Class Properties

[image]
Gizmox.WebGUI.Forms
AspPageEventArgs Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace : AspPageEventArgs Class

For a list of all members of this type, see AspPageEventArgs members.

Public Properties

 | Name | Description
Public Property | Page | Gets the ASP.NET page that fired this event.
Top

See Also

Reference

AspPageEventArgs Class
Gizmox.WebGUI.Forms.Hosts Namespace


Page Property

[image]
Gizmox.WebGUI.Forms
Page Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AspPageEventArgs Class : Page Property

Gets the ASP.NET page that fired this event.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Page As Page
Visual Basic (Usage) Copy Code
Dim instance As AspPageEventArgs
Dim value As Page

value = instance.Page
C#
public Page Page {get;}
Managed Extensions for C++
public: __property Page* get_Page();
C++/CLI
public:
property Page^ Page {
   Page^ get();
}

Return Value

The ASP.NET page.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AspPageEventArgs Class
AspPageEventArgs Members


AspPipeLinePage Class

[image]
Gizmox.WebGUI.Forms
AspPipeLinePage Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace : AspPipeLinePage Class

Provides an System.Web.UI.Page implementation that adds state management and visual webgui pipeline integration

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Class AspPipeLinePage
   Inherits Page
Visual Basic (Usage) Copy Code
Dim instance As AspPipeLinePage
C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public class AspPipeLinePage : Page
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public __gc class AspPipeLinePage : public Page
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public ref class AspPipeLinePage : public Page

Inheritance Hierarchy

System.Object
System.Web.UI.Control
System.Web.UI.TemplateControl
System.Web.UI.Page
Gizmox.WebGUI.Forms.Hosts.AspPipeLinePage
Gizmox.WebGUI.Forms.Hosts.AspPageBase

Requirements

Namespace: Gizmox.WebGUI.Forms.Hosts

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

AspPipeLinePage Members
Gizmox.WebGUI.Forms.Hosts Namespace


AspPipeLinePage Class Members

[image]
Gizmox.WebGUI.Forms
AspPipeLinePage Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace : AspPipeLinePage Class

The following tables list the members exposed by AspPipeLinePage.

Public Constructors

 | Name | Description
Public Constructor | AspPipeLinePage Constructor | Initializes a new instance of the AspPipeLinePage class.
Top

Public Properties

 | Name | Description
Public Property | Application | Gets the HttpApplicationState object for the current Web request. (Inherited from System.Web.UI.Page)
Public Property | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from System.Web.UI.Control)
Public Property | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from System.Web.UI.TemplateControl)
Public Property | AsyncTimeout | Gets or sets a value indicating the time-out interval used when processing asynchronous tasks. (Inherited from System.Web.UI.Page)
Public Property | AutoPostBackControl | (Inherited from System.Web.UI.Page)
Public Property | Cache | Gets the Cache object associated with the application in which the page resides. (Inherited from System.Web.UI.Page)
Public Property | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from System.Web.UI.Control)
Public Property | ClientQueryString | Gets the query string portion of the requested URL. (Inherited from System.Web.UI.Page)
Public Property | ClientScript | Gets a ClientScriptManager object used to manage, register, and add script to the page. (Inherited from System.Web.UI.Page)
Public Property | ClientTarget | Gets or sets a value that allows you to override automatic detection of browser capabilities and to specify how a page is rendered for particular browser clients. (Inherited from System.Web.UI.Page)
Public Property | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from System.Web.UI.Control)
Public Property | Culture | Sets the culture ID for the Thread object associated with the page. (Inherited from System.Web.UI.Page)
Public Property | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from System.Web.UI.TemplateControl)
Public Property | EnableViewState | Gets or sets a value indicating whether the page maintains its view state, and the view state of any server controls it contains, when the current page request ends. (Inherited from System.Web.UI.Page)
Public Property | ErrorPage | Gets or sets the error page to which the requesting browser is redirected in the event of an unhandled page exception. (Inherited from System.Web.UI.Page)
Public Property | Form | Gets the HTML form for the page. (Inherited from System.Web.UI.Page)
Public Property | Header | Gets the document header for the page if the head element is defined with a runat=server in the page declaration. (Inherited from System.Web.UI.Page)
Public Property | IsAsync | Gets a value indicating whether the page is processed asynchronously. (Inherited from System.Web.UI.Page)
Public Property | IsCallback | Gets a value indicating whether the page request is the result of a call back. (Inherited from System.Web.UI.Page)
Public Property | IsCrossPagePostBack | Gets a value indicating whether the page is involved in a cross-page postback. (Inherited from System.Web.UI.Page)
Public Property | IsPostBack | Gets a value indicating whether the page is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from System.Web.UI.Page)
Public Property | IsPostBackEventControlRegistered | (Inherited from System.Web.UI.Page)
Public Property | IsValid | Gets a value indicating whether page validation succeeded. (Inherited from System.Web.UI.Page)
Public Property | Items | Gets a list of objects stored in the page context. (Inherited from System.Web.UI.Page)
Public Property | MaintainScrollPositionOnPostBack | Gets or sets a value indicating whether to return the user to the same position in the client browser after postback. (Inherited from System.Web.UI.Page)
Public Property | Master | Gets the master page that determines the overall look of the page. (Inherited from System.Web.UI.Page)
Public Property | MasterPageFile | Gets or sets the file name of the master page. (Inherited from System.Web.UI.Page)
Public Property | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from System.Web.UI.Control)
Public Property | Page | Gets a reference to the Page instance that contains the server control. (Inherited from System.Web.UI.Control)
Public Property | PageAdapter | Gets the adapter that renders the page for the specific requesting browser. (Inherited from System.Web.UI.Page)
Public Property | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from System.Web.UI.Control)
Public Property | PreviousPage | Gets the page that transferred control to the current page. (Inherited from System.Web.UI.Page)
Public Property | Request | Gets the HttpRequest object for the requested page. (Inherited from System.Web.UI.Page)
Public Property | Response | Gets the HttpResponse object associated with the Page object. This object allows you to send HTTP response data to a client and contains information about that response. (Inherited from System.Web.UI.Page)
Public Property | Server | Gets the Server object, which is an instance of the HttpServerUtility class. (Inherited from System.Web.UI.Page)
Public Property | Session | Gets the current Session object provided by ASP.NET. (Inherited from System.Web.UI.Page)
Public Property | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from System.Web.UI.Control)
Public Property | SkinID | Gets or sets the skin to apply to the control. (Inherited from System.Web.UI.Control)
Public Property | SmartNavigation | Gets or sets a value indicating whether smart navigation is enabled. (Inherited from System.Web.UI.Page)
Public Property | StyleSheetTheme | Gets or sets the name of the style sheet applied to this page. (Inherited from System.Web.UI.Page)
Public Property | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from System.Web.UI.Control)
Public Property | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from System.Web.UI.Control)
Public Property | Theme | Gets or sets the name of the page theme. (Inherited from System.Web.UI.Page)
Public Property | Title | Gets or sets the title for the page. (Inherited from System.Web.UI.Page)
Public Property | Trace | Gets the TraceContext object for the current Web request. (Inherited from System.Web.UI.Page)
Public Property | UICulture | Sets the user interface (UI) ID for the Thread object associated with the page. (Inherited from System.Web.UI.Page)
Public Property | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from System.Web.UI.Control)
Public Property | User | Gets information about the user making the page request. (Inherited from System.Web.UI.Page)
Public Property | Validators | Gets a collection of all validation controls contained on the requested page. (Inherited from System.Web.UI.Page)
Public Property | ViewStateUserKey | Assigns an identifier to an individual user in the view-state variable associated with the current page. (Inherited from System.Web.UI.Page)
Public Property | Visible | Gets or sets a value indicating whether the Page object is rendered. (Inherited from System.Web.UI.Page)
Top

Protected Properties

 | Name | Description
Protected Property | Adapter | Gets the browser-specific adapter for the control. (Inherited from System.Web.UI.Control)
Protected Property | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from System.Web.UI.Control)
Protected Property | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from System.Web.UI.Control)
Protected Property | Context | Gets the HttpContext object associated with the page. (Inherited from System.Web.UI.Page)
Protected Property | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from System.Web.UI.Control)
Protected Property | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from System.Web.UI.Control)
Protected Property | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from System.Web.UI.Control)
Protected Property | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from System.Web.UI.Control)
Protected Property | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from System.Web.UI.Control)
Protected Property | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from System.Web.UI.Control)
Protected Property | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from System.Web.UI.Control)
Protected Property | PageStatePersister | Overridden. Gets the PageStatePersister object associated with the page.
Protected Property | UniqueFilePathSuffix | Gets a unique suffix to append to the file path for caching browsers. (Inherited from System.Web.UI.Page)
Protected Property | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from System.Web.UI.Control)
Protected Property | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from System.Web.UI.Control)
Top

Public Methods

 | Name | Description
Public Method | AddOnPreRenderCompleteAsync | Overloaded. Registers beginning and ending event handler delegates that do not require state information for an asynchronous page. (Inherited from System.Web.UI.Page)
Public Method | ApplyStyleSheetSkin | Applies the style properties defined in the page style sheet to the control. (Inherited from System.Web.UI.Control)
Public Method | DataBind | Overloaded. Binds a data source to the invoked server control and all its child controls. (Inherited from System.Web.UI.Control)
Public Method | Dispose | Enables a server control to perform final clean up before it is released from memory. (Inherited from System.Web.UI.Control)
Public Method | ExecuteRegisteredAsyncTasks | Starts the execution of an asynchronous task. (Inherited from System.Web.UI.Page)
Public Method | FindControl | Overloaded. Searches the page naming container for a server control with the specified identifier. (Inherited from System.Web.UI.Page)
Public Method | Focus | Sets input focus to a control. (Inherited from System.Web.UI.Control)
Public Method | GetDataItem | Gets the data item at the top of the data-binding context stack. (Inherited from System.Web.UI.Page)
Public Method | GetPostBackClientEvent | Gets a reference that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from System.Web.UI.Page)
Public Method | GetPostBackClientHyperlink | Gets a reference, with javascript: appended to the beginning of it, that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from System.Web.UI.Page)
Public Method | GetPostBackEventReference | Overloaded. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object. (Inherited from System.Web.UI.Page)
Public Method | GetValidators | Returns a collection of control validators for a specified validation group. (Inherited from System.Web.UI.Page)
Public Method | HasControls | Determines if the server control contains any child controls. (Inherited from System.Web.UI.Control)
Public Method | IsClientScriptBlockRegistered | Determines whether the client script block with the specified key is registered with the page. (Inherited from System.Web.UI.Page)
Public Method | IsStartupScriptRegistered | Determines whether the client startup script is registered with the Page object. (Inherited from System.Web.UI.Page)
Public Method | LoadControl | Overloaded. Loads a Control object from a file based on a specified virtual path. (Inherited from System.Web.UI.TemplateControl)
Public Method | LoadTemplate | Obtains an instance of the ITemplate interface from an external file. (Inherited from System.Web.UI.TemplateControl)
Public Method | MapPath | Retrieves the physical path that a virtual path, either absolute or relative, or an application-relative path maps to. (Inherited from System.Web.UI.Page)
Public Method | ParseControl | Overloaded. Parses an input string into a Control object on the Web Forms page or user control. (Inherited from System.Web.UI.TemplateControl)
Public Method | RegisterArrayDeclaration | Declares a value that is declared as an ECMAScript array declaration when the page is rendered. (Inherited from System.Web.UI.Page)
Public Method | RegisterAsyncTask | Registers a new asynchronous task with the page. (Inherited from System.Web.UI.Page)
Public Method | RegisterClientScriptBlock | Emits client-side script blocks to the response. (Inherited from System.Web.UI.Page)
Public Method | RegisterHiddenField | Allows server controls to automatically register a hidden field on the form. The field will be sent to the Page object when the HtmlForm server control is rendered. (Inherited from System.Web.UI.Page)
Public Method | RegisterOnSubmitStatement | Allows a page to access the client OnSubmit event. The script should be a function call to client code registered elsewhere. (Inherited from System.Web.UI.Page)
Public Method | RegisterRequiresControlState | Registers a control as one whose control state must be persisted. (Inherited from System.Web.UI.Page)
Public Method | RegisterRequiresPostBack | Registers a control as one that requires postback handling when the page is posted back to the server. (Inherited from System.Web.UI.Page)
Public Method | RegisterRequiresRaiseEvent | Registers an ASP.NET server control as one requiring an event to be raised when the control is processed on the Page object. (Inherited from System.Web.UI.Page)
Public Method | RegisterRequiresViewStateEncryption | Registers a control with the page as one requiring view-state encryption. (Inherited from System.Web.UI.Page)
Public Method | RegisterStartupScript | Emits a client-side script block in the page response. (Inherited from System.Web.UI.Page)
Public Method | RegisterViewStateHandler | Causes page view state to be persisted, if called. (Inherited from System.Web.UI.Page)
Public Method | RenderControl | Overloaded. Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from System.Web.UI.Control)
Public Method | RequiresControlState | Determines whether the specified Control object is registered to participate in control state management. (Inherited from System.Web.UI.Page)
Public Method | ResolveClientUrl | Gets a URL that can be used by the browser. (Inherited from System.Web.UI.Control)
Public Method | ResolveUrl | Converts a URL into one that is usable on the requesting client. (Inherited from System.Web.UI.Control)
Public Method | SetFocus | Overloaded. Sets the browser focus to the specified control. (Inherited from System.Web.UI.Page)
Public Method | SetRenderMethodDelegate | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from System.Web.UI.Control)
Public Method | TestDeviceFilter | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from System.Web.UI.TemplateControl)
Public Method | UnregisterRequiresControlState | Stops persistence of control state for the specified control. (Inherited from System.Web.UI.Page)
Public Method | Validate | Overloaded. Instructs any validation controls included on the page to validate their assigned information. (Inherited from System.Web.UI.Page)
Public Method | VerifyRenderingInServerForm | Confirms that an HtmlForm control is rendered for the specified ASP.NET server control at run time. (Inherited from System.Web.UI.Page)
Top

Protected Methods

 | Name | Description
Protected Method | AddedControl | Called after a child control is added to the Controls collection of the Control object. (Inherited from System.Web.UI.Control)
Protected Method | AddParsedSubObject | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from System.Web.UI.Control)
Protected Method | BuildProfileTree | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from System.Web.UI.Control)
Protected Method | ClearChildControlState | Deletes the control-state information for the server control's child controls. (Inherited from System.Web.UI.Control)
Protected Method | ClearChildState | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from System.Web.UI.Control)
Protected Method | ClearChildViewState | Deletes the view-state information for all the server control's child controls. (Inherited from System.Web.UI.Control)
Protected Method | Construct | Performs design-time logic. (Inherited from System.Web.UI.TemplateControl)
Protected Method | CreateChildControls | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from System.Web.UI.Control)
Protected Method | CreateControlCollection | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from System.Web.UI.Control)
Protected Method | CreateHtmlTextWriter | Creates an HtmlTextWriter object to render the page's content. (Inherited from System.Web.UI.Page)
Protected Method | CreateResourceBasedLiteralControl | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl method is not intended for use from within your code. (Inherited from System.Web.UI.TemplateControl)
Protected Method | DataBindChildren | Binds a data source to the server control's child controls. (Inherited from System.Web.UI.Control)
Protected Method | DeterminePostBackMode | Returns a NameValueCollection of data posted back to the page using either a POST or a GET command. (Inherited from System.Web.UI.Page)
Protected Method | EnsureChildControls | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from System.Web.UI.Control)
Protected Method | EnsureID | Creates an identifier for controls that do not have an identifier assigned. (Inherited from System.Web.UI.Control)
Protected Method | Eval | Overloaded. Evaluates a data-binding expression. (Inherited from System.Web.UI.TemplateControl)
Protected Method | FrameworkInitialize | Initializes the control tree during page generation based on the declarative nature of the page. (Inherited from System.Web.UI.Page)
Protected Method | GetDesignModeState | Gets design-time data for a control. (Inherited from System.Web.UI.Control)
Protected Method | GetGlobalResourceObject | Overloaded. Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from System.Web.UI.TemplateControl)
Protected Method | GetLocalResourceObject | Overloaded. Gets a page-level resource object based on the specified ResourceKey property. (Inherited from System.Web.UI.TemplateControl)
Protected Method | HasEvents | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from System.Web.UI.Control)
Protected Method | InitializeCulture | Sets the Culture and UICulture for the current thread of the page. (Inherited from System.Web.UI.Page)
Protected Method | IsLiteralContent | Determines if the server control holds only literal content. (Inherited from System.Web.UI.Control)
Protected Method | LoadControlState | Restores control-state information from a previous page request that was saved by the SaveControlState method. (Inherited from System.Web.UI.Control)
Protected Method | LoadPageStateFromPersistenceMedium | Loads any saved view-state information to the Page object. (Inherited from System.Web.UI.Page)
Protected Method | LoadViewState | Restores view-state information from a previous page request that was saved by the SaveViewState method. (Inherited from System.Web.UI.Control)
Protected Method | MapPathSecure | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from System.Web.UI.Control)
Protected Method | OnAbortTransaction | Raises the AbortTransaction event. (Inherited from System.Web.UI.TemplateControl)
Protected Method | OnBubbleEvent | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from System.Web.UI.Control)
Protected Method | OnCommitTransaction | Raises the CommitTransaction event. (Inherited from System.Web.UI.TemplateControl)
Protected Method | OnDataBinding | Raises the DataBinding event. (Inherited from System.Web.UI.Control)
Protected Method | OnError | Raises the Error event. (Inherited from System.Web.UI.TemplateControl)
Protected Method | OnInit | Overridden. Called when the page is initialized
Protected Method | OnInitComplete | Overridden. Raises the InitComplete event after page initialization.
Protected Method | OnLoad | Raises the Load event. (Inherited from System.Web.UI.Control)
Protected Method | OnLoadComplete | Raises the LoadComplete event at the end of the page load stage. (Inherited from System.Web.UI.Page)
Protected Method | OnPreInit | Raises the PreInit event at the beginning of page initialization. (Inherited from System.Web.UI.Page)
Protected Method | OnPreLoad | Overridden. Called before the page is loaded to get the pipeline events
Protected Method | OnPreRender | Overridden. Generates an update command to the pipeline field
Protected Method | OnPreRenderComplete | Raises the PreRenderComplete event after the OnPreRenderComplete event and before the page is rendered. (Inherited from System.Web.UI.Page)
Protected Method | OnSaveStateComplete | Raises the SaveStateComplete event after the page state has been saved to the persistence medium. (Inherited from System.Web.UI.Page)
Protected Method | OnUnload | Raises the Unload event. (Inherited from System.Web.UI.Control)
Protected Method | OpenFile | Gets a Stream used to read a file. (Inherited from System.Web.UI.Control)
Protected Method | RaiseBubbleEvent | Assigns any sources of the event and its information to the control's parent. (Inherited from System.Web.UI.Control)
Protected Method | RaisePostBackEvent | Notifies the server control that caused the postback that it should handle an incoming postback event. (Inherited from System.Web.UI.Page)
Protected Method | RemovedControl | Called after a control is removed from the Controls collection of another control. (Inherited from System.Web.UI.Control)
Protected Method | Render | Initializes the HtmlTextWriter object and calls on the child controls of the Page to render. (Inherited from System.Web.UI.Page)
Protected Method | RenderChildren | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from System.Web.UI.Control)
Protected Method | ResolveAdapter | Gets the control adapter responsible for rendering the specified control. (Inherited from System.Web.UI.Control)
Protected Method | SaveControlState | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from System.Web.UI.Control)
Protected Method | SavePageStateToPersistenceMedium | Saves any view-state and control-state information for the page. (Inherited from System.Web.UI.Page)
Protected Method | SaveViewState | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from System.Web.UI.Control)
Protected Method | SetDesignModeState | Sets design-time data for a control. (Inherited from System.Web.UI.Control)
Protected Method | TrackViewState | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from System.Web.UI.Control)
Protected Method | XPath | Overloaded. Evaluates an XPath data-binding expression. (Inherited from System.Web.UI.TemplateControl)
Protected Method | XPathSelect | Overloaded. Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from System.Web.UI.TemplateControl)
Top

Public Events

 | Name | Description
Public Event | AbortTransaction | Occurs when a user ends a transaction. (Inherited from System.Web.UI.TemplateControl)
Public Event | CommitTransaction | Occurs when a transaction completes. (Inherited from System.Web.UI.TemplateControl)
Public Event | DataBinding | Occurs when the server control binds to a data source. (Inherited from System.Web.UI.Control)
Public Event | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from System.Web.UI.Control)
Public Event | Error | Occurs when an unhandled exception is thrown. (Inherited from System.Web.UI.TemplateControl)
Public Event | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from System.Web.UI.Control)
Public Event | InitComplete | Occurs when page initialization is complete. (Inherited from System.Web.UI.Page)
Public Event | Load | Occurs when the server control is loaded into the Page object. (Inherited from System.Web.UI.Control)
Public Event | LoadComplete | Occurs at the end of the load stage of the page's life cycle. (Inherited from System.Web.UI.Page)
Public Event | PreInit | Occurs at the beginning of page initialization. (Inherited from System.Web.UI.Page)
Public Event | PreLoad | Occurs before the page Load event. (Inherited from System.Web.UI.Page)
Public Event | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from System.Web.UI.Control)
Public Event | PreRenderComplete | Occurs before the page content is rendered. (Inherited from System.Web.UI.Page)
Public Event | SaveStateComplete | Occurs after the page has completed saving all view state and control state information for the page and controls on the page. (Inherited from System.Web.UI.Page)
Public Event | Unload | Occurs when the server control is unloaded from memory. (Inherited from System.Web.UI.Control)
Top

See Also

Reference

AspPipeLinePage Class
Gizmox.WebGUI.Forms.Hosts Namespace


AspPipeLinePage Constructor

[image]
Gizmox.WebGUI.Forms
AspPipeLinePage Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AspPipeLinePage Class : AspPipeLinePage Constructor

Initializes a new instance of the AspPipeLinePage class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As AspPipeLinePage()
C#
public AspPipeLinePage()
Managed Extensions for C++
public: AspPipeLinePage();
C++/CLI
public:
AspPipeLinePage();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AspPipeLinePage Class
AspPipeLinePage Members


AspPipeLinePage Class Methods

[image]
Gizmox.WebGUI.Forms
AspPipeLinePage Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace : AspPipeLinePage Class

For a list of all members of this type, see AspPipeLinePage members.

Public Methods

 | Name | Description
Public Method | AddOnPreRenderCompleteAsync | Overloaded. Registers beginning and ending event handler delegates that do not require state information for an asynchronous page. (Inherited from System.Web.UI.Page)
Public Method | ApplyStyleSheetSkin | Applies the style properties defined in the page style sheet to the control. (Inherited from System.Web.UI.Control)
Public Method | DataBind | Overloaded. Binds a data source to the invoked server control and all its child controls. (Inherited from System.Web.UI.Control)
Public Method | Dispose | Enables a server control to perform final clean up before it is released from memory. (Inherited from System.Web.UI.Control)
Public Method | ExecuteRegisteredAsyncTasks | Starts the execution of an asynchronous task. (Inherited from System.Web.UI.Page)
Public Method | FindControl | Overloaded. Searches the page naming container for a server control with the specified identifier. (Inherited from System.Web.UI.Page)
Public Method | Focus | Sets input focus to a control. (Inherited from System.Web.UI.Control)
Public Method | GetDataItem | Gets the data item at the top of the data-binding context stack. (Inherited from System.Web.UI.Page)
Public Method | GetPostBackClientEvent | Gets a reference that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from System.Web.UI.Page)
Public Method | GetPostBackClientHyperlink | Gets a reference, with javascript: appended to the beginning of it, that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from System.Web.UI.Page)
Public Method | GetPostBackEventReference | Overloaded. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object. (Inherited from System.Web.UI.Page)
Public Method | GetValidators | Returns a collection of control validators for a specified validation group. (Inherited from System.Web.UI.Page)
Public Method | HasControls | Determines if the server control contains any child controls. (Inherited from System.Web.UI.Control)
Public Method | IsClientScriptBlockRegistered | Determines whether the client script block with the specified key is registered with the page. (Inherited from System.Web.UI.Page)
Public Method | IsStartupScriptRegistered | Determines whether the client startup script is registered with the Page object. (Inherited from System.Web.UI.Page)
Public Method | LoadControl | Overloaded. Loads a Control object from a file based on a specified virtual path. (Inherited from System.Web.UI.TemplateControl)
Public Method | LoadTemplate | Obtains an instance of the ITemplate interface from an external file. (Inherited from System.Web.UI.TemplateControl)
Public Method | MapPath | Retrieves the physical path that a virtual path, either absolute or relative, or an application-relative path maps to. (Inherited from System.Web.UI.Page)
Public Method | ParseControl | Overloaded. Parses an input string into a Control object on the Web Forms page or user control. (Inherited from System.Web.UI.TemplateControl)
Public Method | RegisterArrayDeclaration | Declares a value that is declared as an ECMAScript array declaration when the page is rendered. (Inherited from System.Web.UI.Page)
Public Method | RegisterAsyncTask | Registers a new asynchronous task with the page. (Inherited from System.Web.UI.Page)
Public Method | RegisterClientScriptBlock | Emits client-side script blocks to the response. (Inherited from System.Web.UI.Page)
Public Method | RegisterHiddenField | Allows server controls to automatically register a hidden field on the form. The field will be sent to the Page object when the HtmlForm server control is rendered. (Inherited from System.Web.UI.Page)
Public Method | RegisterOnSubmitStatement | Allows a page to access the client OnSubmit event. The script should be a function call to client code registered elsewhere. (Inherited from System.Web.UI.Page)
Public Method | RegisterRequiresControlState | Registers a control as one whose control state must be persisted. (Inherited from System.Web.UI.Page)
Public Method | RegisterRequiresPostBack | Registers a control as one that requires postback handling when the page is posted back to the server. (Inherited from System.Web.UI.Page)
Public Method | RegisterRequiresRaiseEvent | Registers an ASP.NET server control as one requiring an event to be raised when the control is processed on the Page object. (Inherited from System.Web.UI.Page)
Public Method | RegisterRequiresViewStateEncryption | Registers a control with the page as one requiring view-state encryption. (Inherited from System.Web.UI.Page)
Public Method | RegisterStartupScript | Emits a client-side script block in the page response. (Inherited from System.Web.UI.Page)
Public Method | RegisterViewStateHandler | Causes page view state to be persisted, if called. (Inherited from System.Web.UI.Page)
Public Method | RenderControl | Overloaded. Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from System.Web.UI.Control)
Public Method | RequiresControlState | Determines whether the specified Control object is registered to participate in control state management. (Inherited from System.Web.UI.Page)
Public Method | ResolveClientUrl | Gets a URL that can be used by the browser. (Inherited from System.Web.UI.Control)
Public Method | ResolveUrl | Converts a URL into one that is usable on the requesting client. (Inherited from System.Web.UI.Control)
Public Method | SetFocus | Overloaded. Sets the browser focus to the specified control. (Inherited from System.Web.UI.Page)
Public Method | SetRenderMethodDelegate | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from System.Web.UI.Control)
Public Method | TestDeviceFilter | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from System.Web.UI.TemplateControl)
Public Method | UnregisterRequiresControlState | Stops persistence of control state for the specified control. (Inherited from System.Web.UI.Page)
Public Method | Validate | Overloaded. Instructs any validation controls included on the page to validate their assigned information. (Inherited from System.Web.UI.Page)
Public Method | VerifyRenderingInServerForm | Confirms that an HtmlForm control is rendered for the specified ASP.NET server control at run time. (Inherited from System.Web.UI.Page)
Top

Protected Methods

 | Name | Description
Protected Method | AddedControl | Called after a child control is added to the Controls collection of the Control object. (Inherited from System.Web.UI.Control)
Protected Method | AddParsedSubObject | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from System.Web.UI.Control)
Protected Method | BuildProfileTree | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from System.Web.UI.Control)
Protected Method | ClearChildControlState | Deletes the control-state information for the server control's child controls. (Inherited from System.Web.UI.Control)
Protected Method | ClearChildState | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from System.Web.UI.Control)
Protected Method | ClearChildViewState | Deletes the view-state information for all the server control's child controls. (Inherited from System.Web.UI.Control)
Protected Method | Construct | Performs design-time logic. (Inherited from System.Web.UI.TemplateControl)
Protected Method | CreateChildControls | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from System.Web.UI.Control)
Protected Method | CreateControlCollection | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from System.Web.UI.Control)
Protected Method | CreateHtmlTextWriter | Creates an HtmlTextWriter object to render the page's content. (Inherited from System.Web.UI.Page)
Protected Method | CreateResourceBasedLiteralControl | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl method is not intended for use from within your code. (Inherited from System.Web.UI.TemplateControl)
Protected Method | DataBindChildren | Binds a data source to the server control's child controls. (Inherited from System.Web.UI.Control)
Protected Method | DeterminePostBackMode | Returns a NameValueCollection of data posted back to the page using either a POST or a GET command. (Inherited from System.Web.UI.Page)
Protected Method | EnsureChildControls | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from System.Web.UI.Control)
Protected Method | EnsureID | Creates an identifier for controls that do not have an identifier assigned. (Inherited from System.Web.UI.Control)
Protected Method | Eval | Overloaded. Evaluates a data-binding expression. (Inherited from System.Web.UI.TemplateControl)
Protected Method | FrameworkInitialize | Initializes the control tree during page generation based on the declarative nature of the page. (Inherited from System.Web.UI.Page)
Protected Method | GetDesignModeState | Gets design-time data for a control. (Inherited from System.Web.UI.Control)
Protected Method | GetGlobalResourceObject | Overloaded. Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from System.Web.UI.TemplateControl)
Protected Method | GetLocalResourceObject | Overloaded. Gets a page-level resource object based on the specified ResourceKey property. (Inherited from System.Web.UI.TemplateControl)
Protected Method | HasEvents | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from System.Web.UI.Control)
Protected Method | InitializeCulture | Sets the Culture and UICulture for the current thread of the page. (Inherited from System.Web.UI.Page)
Protected Method | IsLiteralContent | Determines if the server control holds only literal content. (Inherited from System.Web.UI.Control)
Protected Method | LoadControlState | Restores control-state information from a previous page request that was saved by the SaveControlState method. (Inherited from System.Web.UI.Control)
Protected Method | LoadPageStateFromPersistenceMedium | Loads any saved view-state information to the Page object. (Inherited from System.Web.UI.Page)
Protected Method | LoadViewState | Restores view-state information from a previous page request that was saved by the SaveViewState method. (Inherited from System.Web.UI.Control)
Protected Method | MapPathSecure | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from System.Web.UI.Control)
Protected Method | OnAbortTransaction | Raises the AbortTransaction event. (Inherited from System.Web.UI.TemplateControl)
Protected Method | OnBubbleEvent | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from System.Web.UI.Control)
Protected Method | OnCommitTransaction | Raises the CommitTransaction event. (Inherited from System.Web.UI.TemplateControl)
Protected Method | OnDataBinding | Raises the DataBinding event. (Inherited from System.Web.UI.Control)
Protected Method | OnError | Raises the Error event. (Inherited from System.Web.UI.TemplateControl)
Protected Method | OnInit | Overridden. Called when the page is initialized
Protected Method | OnInitComplete | Overridden. Raises the InitComplete event after page initialization.
Protected Method | OnLoad | Raises the Load event. (Inherited from System.Web.UI.Control)
Protected Method | OnLoadComplete | Raises the LoadComplete event at the end of the page load stage. (Inherited from System.Web.UI.Page)
Protected Method | OnPreInit | Raises the PreInit event at the beginning of page initialization. (Inherited from System.Web.UI.Page)
Protected Method | OnPreLoad | Overridden. Called before the page is loaded to get the pipeline events
Protected Method | OnPreRender | Overridden. Generates an update command to the pipeline field
Protected Method | OnPreRenderComplete | Raises the PreRenderComplete event after the OnPreRenderComplete event and before the page is rendered. (Inherited from System.Web.UI.Page)
Protected Method | OnSaveStateComplete | Raises the SaveStateComplete event after the page state has been saved to the persistence medium. (Inherited from System.Web.UI.Page)
Protected Method | OnUnload | Raises the Unload event. (Inherited from System.Web.UI.Control)
Protected Method | OpenFile | Gets a Stream used to read a file. (Inherited from System.Web.UI.Control)
Protected Method | RaiseBubbleEvent | Assigns any sources of the event and its information to the control's parent. (Inherited from System.Web.UI.Control)
Protected Method | RaisePostBackEvent | Notifies the server control that caused the postback that it should handle an incoming postback event. (Inherited from System.Web.UI.Page)
Protected Method | RemovedControl | Called after a control is removed from the Controls collection of another control. (Inherited from System.Web.UI.Control)
Protected Method | Render | Initializes the HtmlTextWriter object and calls on the child controls of the Page to render. (Inherited from System.Web.UI.Page)
Protected Method | RenderChildren | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from System.Web.UI.Control)
Protected Method | ResolveAdapter | Gets the control adapter responsible for rendering the specified control. (Inherited from System.Web.UI.Control)
Protected Method | SaveControlState | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from System.Web.UI.Control)
Protected Method | SavePageStateToPersistenceMedium | Saves any view-state and control-state information for the page. (Inherited from System.Web.UI.Page)
Protected Method | SaveViewState | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from System.Web.UI.Control)
Protected Method | SetDesignModeState | Sets design-time data for a control. (Inherited from System.Web.UI.Control)
Protected Method | TrackViewState | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from System.Web.UI.Control)
Protected Method | XPath | Overloaded. Evaluates an XPath data-binding expression. (Inherited from System.Web.UI.TemplateControl)
Protected Method | XPathSelect | Overloaded. Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from System.Web.UI.TemplateControl)
Top

See Also

Reference

AspPipeLinePage Class
Gizmox.WebGUI.Forms.Hosts Namespace


OnInit Method

[image]
Gizmox.WebGUI.Forms
OnInit Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AspPipeLinePage Class : OnInit Method

e
Called when the page is initialized

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnInit( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As AspPipeLinePage
Dim e As EventArgs

instance.OnInit(e)
C#
protected override void OnInit(
   EventArgs e
)
Managed Extensions for C++
protected: void OnInit(
   EventArgs* e
) override
C++/CLI
protected:
void OnInit(
   EventArgs^ e
) override

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AspPipeLinePage Class
AspPipeLinePage Members


OnInitComplete Method

[image]
Gizmox.WebGUI.Forms
OnInitComplete Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AspPipeLinePage Class : OnInitComplete Method

e
An EventArgs that contains the event data.
Raises the InitComplete event after page initialization.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnInitComplete( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As AspPipeLinePage
Dim e As EventArgs

instance.OnInitComplete(e)
C#
protected override void OnInitComplete(
   EventArgs e
)
Managed Extensions for C++
protected: void OnInitComplete(
   EventArgs* e
) override
C++/CLI
protected:
void OnInitComplete(
   EventArgs^ e
) override

Parameters

e
An EventArgs that contains the event data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AspPipeLinePage Class
AspPipeLinePage Members


OnPreLoad Method

[image]
Gizmox.WebGUI.Forms
OnPreLoad Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AspPipeLinePage Class : OnPreLoad Method

e
Called before the page is loaded to get the pipeline events

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnPreLoad( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As AspPipeLinePage
Dim e As EventArgs

instance.OnPreLoad(e)
C#
protected override void OnPreLoad(
   EventArgs e
)
Managed Extensions for C++
protected: void OnPreLoad(
   EventArgs* e
) override
C++/CLI
protected:
void OnPreLoad(
   EventArgs^ e
) override

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AspPipeLinePage Class
AspPipeLinePage Members


OnPreRender Method

[image]
Gizmox.WebGUI.Forms
OnPreRender Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AspPipeLinePage Class : OnPreRender Method

e
Generates an update command to the pipeline field

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnPreRender( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As AspPipeLinePage
Dim e As EventArgs

instance.OnPreRender(e)
C#
protected override void OnPreRender(
   EventArgs e
)
Managed Extensions for C++
protected: void OnPreRender(
   EventArgs* e
) override
C++/CLI
protected:
void OnPreRender(
   EventArgs^ e
) override

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AspPipeLinePage Class
AspPipeLinePage Members


AspPipeLinePage Class Properties

[image]
Gizmox.WebGUI.Forms
AspPipeLinePage Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace : AspPipeLinePage Class

For a list of all members of this type, see AspPipeLinePage members.

Public Properties

 | Name | Description
Public Property | Application | Gets the HttpApplicationState object for the current Web request. (Inherited from System.Web.UI.Page)
Public Property | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from System.Web.UI.Control)
Public Property | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from System.Web.UI.TemplateControl)
Public Property | AsyncTimeout | Gets or sets a value indicating the time-out interval used when processing asynchronous tasks. (Inherited from System.Web.UI.Page)
Public Property | AutoPostBackControl | (Inherited from System.Web.UI.Page)
Public Property | Cache | Gets the Cache object associated with the application in which the page resides. (Inherited from System.Web.UI.Page)
Public Property | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from System.Web.UI.Control)
Public Property | ClientQueryString | Gets the query string portion of the requested URL. (Inherited from System.Web.UI.Page)
Public Property | ClientScript | Gets a ClientScriptManager object used to manage, register, and add script to the page. (Inherited from System.Web.UI.Page)
Public Property | ClientTarget | Gets or sets a value that allows you to override automatic detection of browser capabilities and to specify how a page is rendered for particular browser clients. (Inherited from System.Web.UI.Page)
Public Property | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from System.Web.UI.Control)
Public Property | Culture | Sets the culture ID for the Thread object associated with the page. (Inherited from System.Web.UI.Page)
Public Property | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from System.Web.UI.TemplateControl)
Public Property | EnableViewState | Gets or sets a value indicating whether the page maintains its view state, and the view state of any server controls it contains, when the current page request ends. (Inherited from System.Web.UI.Page)
Public Property | ErrorPage | Gets or sets the error page to which the requesting browser is redirected in the event of an unhandled page exception. (Inherited from System.Web.UI.Page)
Public Property | Form | Gets the HTML form for the page. (Inherited from System.Web.UI.Page)
Public Property | Header | Gets the document header for the page if the head element is defined with a runat=server in the page declaration. (Inherited from System.Web.UI.Page)
Public Property | IsAsync | Gets a value indicating whether the page is processed asynchronously. (Inherited from System.Web.UI.Page)
Public Property | IsCallback | Gets a value indicating whether the page request is the result of a call back. (Inherited from System.Web.UI.Page)
Public Property | IsCrossPagePostBack | Gets a value indicating whether the page is involved in a cross-page postback. (Inherited from System.Web.UI.Page)
Public Property | IsPostBack | Gets a value indicating whether the page is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from System.Web.UI.Page)
Public Property | IsPostBackEventControlRegistered | (Inherited from System.Web.UI.Page)
Public Property | IsValid | Gets a value indicating whether page validation succeeded. (Inherited from System.Web.UI.Page)
Public Property | Items | Gets a list of objects stored in the page context. (Inherited from System.Web.UI.Page)
Public Property | MaintainScrollPositionOnPostBack | Gets or sets a value indicating whether to return the user to the same position in the client browser after postback. (Inherited from System.Web.UI.Page)
Public Property | Master | Gets the master page that determines the overall look of the page. (Inherited from System.Web.UI.Page)
Public Property | MasterPageFile | Gets or sets the file name of the master page. (Inherited from System.Web.UI.Page)
Public Property | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from System.Web.UI.Control)
Public Property | Page | Gets a reference to the Page instance that contains the server control. (Inherited from System.Web.UI.Control)
Public Property | PageAdapter | Gets the adapter that renders the page for the specific requesting browser. (Inherited from System.Web.UI.Page)
Public Property | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from System.Web.UI.Control)
Public Property | PreviousPage | Gets the page that transferred control to the current page. (Inherited from System.Web.UI.Page)
Public Property | Request | Gets the HttpRequest object for the requested page. (Inherited from System.Web.UI.Page)
Public Property | Response | Gets the HttpResponse object associated with the Page object. This object allows you to send HTTP response data to a client and contains information about that response. (Inherited from System.Web.UI.Page)
Public Property | Server | Gets the Server object, which is an instance of the HttpServerUtility class. (Inherited from System.Web.UI.Page)
Public Property | Session | Gets the current Session object provided by ASP.NET. (Inherited from System.Web.UI.Page)
Public Property | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from System.Web.UI.Control)
Public Property | SkinID | Gets or sets the skin to apply to the control. (Inherited from System.Web.UI.Control)
Public Property | SmartNavigation | Gets or sets a value indicating whether smart navigation is enabled. (Inherited from System.Web.UI.Page)
Public Property | StyleSheetTheme | Gets or sets the name of the style sheet applied to this page. (Inherited from System.Web.UI.Page)
Public Property | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from System.Web.UI.Control)
Public Property | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from System.Web.UI.Control)
Public Property | Theme | Gets or sets the name of the page theme. (Inherited from System.Web.UI.Page)
Public Property | Title | Gets or sets the title for the page. (Inherited from System.Web.UI.Page)
Public Property | Trace | Gets the TraceContext object for the current Web request. (Inherited from System.Web.UI.Page)
Public Property | UICulture | Sets the user interface (UI) ID for the Thread object associated with the page. (Inherited from System.Web.UI.Page)
Public Property | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from System.Web.UI.Control)
Public Property | User | Gets information about the user making the page request. (Inherited from System.Web.UI.Page)
Public Property | Validators | Gets a collection of all validation controls contained on the requested page. (Inherited from System.Web.UI.Page)
Public Property | ViewStateUserKey | Assigns an identifier to an individual user in the view-state variable associated with the current page. (Inherited from System.Web.UI.Page)
Public Property | Visible | Gets or sets a value indicating whether the Page object is rendered. (Inherited from System.Web.UI.Page)
Top

Protected Properties

 | Name | Description
Protected Property | Adapter | Gets the browser-specific adapter for the control. (Inherited from System.Web.UI.Control)
Protected Property | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from System.Web.UI.Control)
Protected Property | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from System.Web.UI.Control)
Protected Property | Context | Gets the HttpContext object associated with the page. (Inherited from System.Web.UI.Page)
Protected Property | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from System.Web.UI.Control)
Protected Property | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from System.Web.UI.Control)
Protected Property | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from System.Web.UI.Control)
Protected Property | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from System.Web.UI.Control)
Protected Property | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from System.Web.UI.Control)
Protected Property | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from System.Web.UI.Control)
Protected Property | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from System.Web.UI.Control)
Protected Property | PageStatePersister | Overridden. Gets the PageStatePersister object associated with the page.
Protected Property | UniqueFilePathSuffix | Gets a unique suffix to append to the file path for caching browsers. (Inherited from System.Web.UI.Page)
Protected Property | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from System.Web.UI.Control)
Protected Property | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from System.Web.UI.Control)
Top

See Also

Reference

AspPipeLinePage Class
Gizmox.WebGUI.Forms.Hosts Namespace


PageStatePersister Property

[image]
Gizmox.WebGUI.Forms
PageStatePersister Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AspPipeLinePage Class : PageStatePersister Property

Gets the PageStatePersister object associated with the page.

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property PageStatePersister As PageStatePersister
Visual Basic (Usage) Copy Code
Dim instance As AspPipeLinePage
Dim value As PageStatePersister

value = instance.PageStatePersister
C#
protected override PageStatePersister PageStatePersister {get;}
Managed Extensions for C++
protected: __property PageStatePersister* get_PageStatePersister() override;
C++/CLI
protected:
property PageStatePersister^ PageStatePersister {
   PageStatePersister^ get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AspPipeLinePage Class
AspPipeLinePage Members


AspPipeLinePage.AspControlBoxStatePersister Class

[image]
Gizmox.WebGUI.Forms
AspPipeLinePage.AspControlBoxStatePersister Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace : AspPipeLinePage.AspControlBoxStatePersister Class

Provides view / control state for the asp control box control

Syntax

Visual Basic (Declaration)
Private Class AspPipeLinePage.AspControlBoxStatePersister
   Inherits PageStatePersister
Visual Basic (Usage) Copy Code
Dim instance As AspPipeLinePage.AspControlBoxStatePersister
C#
private class AspPipeLinePage.AspControlBoxStatePersister : PageStatePersister
Managed Extensions for C++
private __gc class AspPipeLinePage.AspControlBoxStatePersister : public PageStatePersister
C++/CLI
private ref class AspPipeLinePage.AspControlBoxStatePersister : public PageStatePersister

Inheritance Hierarchy

System.Object
System.Web.UI.PageStatePersister
Gizmox.WebGUI.Forms.Hosts.AspPipeLinePage.AspControlBoxStatePersister

Requirements

Namespace: Gizmox.WebGUI.Forms.Hosts

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

AspPipeLinePage.AspControlBoxStatePersister Members
Gizmox.WebGUI.Forms.Hosts Namespace


AspPipeLinePage.AspControlBoxStatePersister Class Members

[image]
Gizmox.WebGUI.Forms
AspPipeLinePage.AspControlBoxStatePersister Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace : AspPipeLinePage.AspControlBoxStatePersister Class

The following tables list the members exposed by AspPipeLinePage.AspControlBoxStatePersister.

Public Constructors

 | Name | Description
Public Constructor | AspPipeLinePage.AspControlBoxStatePersister Constructor | Initializes a new instance of the AspPipeLinePage.AspControlBoxStatePersister class.
Top

Public Properties

 | Name | Description
Public Property | ControlState | Gets or sets an object that represents the data that controls contained by the current Page object use to persist across HTTP requests to the Web server. (Inherited from System.Web.UI.PageStatePersister)
Public Property | ViewState | Gets or sets an object that represents the data that controls contained by the current Page object use to persist across HTTP requests to the Web server. (Inherited from System.Web.UI.PageStatePersister)
Top

Protected Properties

 | Name | Description
Protected Property | Page | Gets or sets the Page object that the view state persistence mechanism is created for. (Inherited from System.Web.UI.PageStatePersister)
Protected Property | StateFormatter | Gets an IStateFormatter object that is used to serialize and deserialize the state information contained in the ViewState and ControlState properties during calls to the Save and Load methods. (Inherited from System.Web.UI.PageStatePersister)
Top

Public Methods

 | Name | Description
Public Method | Load | Overridden. Overridden by derived classes to deserialize and load persisted state information when a Page object initializes its control hierarchy.
Public Method | Save | Overridden. Overridden by derived classes to serialize persisted state information when a Page object is unloaded from memory.
Top

See Also

Reference

AspPipeLinePage.AspControlBoxStatePersister Class
Gizmox.WebGUI.Forms.Hosts Namespace


AspPipeLinePage.AspControlBoxStatePersister Constructor

[image]
Gizmox.WebGUI.Forms
AspPipeLinePage.AspControlBoxStatePersister Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AspPipeLinePage.AspControlBoxStatePersister Class : AspPipeLinePage.AspControlBoxStatePersister Constructor

objAspPipeLinePage
The aspnet page.
objAspControlBox
The hosting Visual WebGui control.
Initializes a new instance of the AspPipeLinePage.AspControlBoxStatePersister class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal objAspPipeLinePage As AspPipeLinePage, _
   ByVal objAspControlBox As AspControlBoxBase _
)
Visual Basic (Usage) Copy Code
Dim objAspPipeLinePage As AspPipeLinePage
Dim objAspControlBox As AspControlBoxBase

Dim instance As AspPipeLinePage.AspControlBoxStatePersister(objAspPipeLinePage, objAspControlBox)
C#
public AspPipeLinePage.AspControlBoxStatePersister(
   AspPipeLinePage objAspPipeLinePage,
   AspControlBoxBase objAspControlBox
)
Managed Extensions for C++
public: AspPipeLinePage.AspControlBoxStatePersister(
   AspPipeLinePage* objAspPipeLinePage,
   AspControlBoxBase* objAspControlBox
)
C++/CLI
public:
AspPipeLinePage.AspControlBoxStatePersister(
   AspPipeLinePage^ objAspPipeLinePage,
   AspControlBoxBase^ objAspControlBox
)

Parameters

objAspPipeLinePage
The aspnet page.
objAspControlBox
The hosting Visual WebGui control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AspPipeLinePage.AspControlBoxStatePersister Class
AspPipeLinePage.AspControlBoxStatePersister Members


AspPipeLinePage.AspControlBoxStatePersister Class Methods

[image]
Gizmox.WebGUI.Forms
AspPipeLinePage.AspControlBoxStatePersister Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace : AspPipeLinePage.AspControlBoxStatePersister Class

For a list of all members of this type, see AspPipeLinePage.AspControlBoxStatePersister members.

Public Methods

 | Name | Description
Public Method | Load | Overridden. Overridden by derived classes to deserialize and load persisted state information when a Page object initializes its control hierarchy.
Public Method | Save | Overridden. Overridden by derived classes to serialize persisted state information when a Page object is unloaded from memory.
Top

See Also

Reference

AspPipeLinePage.AspControlBoxStatePersister Class
Gizmox.WebGUI.Forms.Hosts Namespace


Load Method

[image]
Gizmox.WebGUI.Forms
Load Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AspPipeLinePage.AspControlBoxStatePersister Class : Load Method

Overridden by derived classes to deserialize and load persisted state information when a Page object initializes its control hierarchy.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Load()
Visual Basic (Usage) Copy Code
Dim instance As AspPipeLinePage.AspControlBoxStatePersister

instance.Load()
C#
public override void Load()
Managed Extensions for C++
public: void Load(); override
C++/CLI
public:
void Load(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AspPipeLinePage.AspControlBoxStatePersister Class
AspPipeLinePage.AspControlBoxStatePersister Members


Save Method

[image]
Gizmox.WebGUI.Forms
Save Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > AspPipeLinePage.AspControlBoxStatePersister Class : Save Method

Overridden by derived classes to serialize persisted state information when a Page object is unloaded from memory.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Save()
Visual Basic (Usage) Copy Code
Dim instance As AspPipeLinePage.AspControlBoxStatePersister

instance.Save()
C#
public override void Save()
Managed Extensions for C++
public: void Save(); override
C++/CLI
public:
void Save(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AspPipeLinePage.AspControlBoxStatePersister Class
AspPipeLinePage.AspControlBoxStatePersister Members


FlashBox Class

[image]
Gizmox.WebGUI.Forms
FlashBox Class
Members Example See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace : FlashBox Class

Flash box control can host Flash movies and embed them in a Visual WebGui application.

Object Model

Syntax

Visual Basic (Declaration)
<ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
Public Class FlashBox
   Inherits FlashBoxBase
   Implements IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IGatewayControl, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Visual Basic (Usage) Copy Code
Dim instance As FlashBox
C#
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
public class FlashBox : FlashBoxBase, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IGatewayControl, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Managed Extensions for C++
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
public __gc class FlashBox : public FlashBoxBase, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IGatewayControl, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
C++/CLI
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
public ref class FlashBox : public FlashBoxBase, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IGatewayControl, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement

Example

C# Copy Code
FlashBox objFlashBox = new FlashBox();
objFlashBox.Movie = "../../../../../Resources/Flash/FC_2_3_Column3D.swf";
objFlashBox.AddParameter("FlashVars","&dataURL=../../../../../Resources/Flash/FC_2_3_Column3D.xml");
objFlashBox.AddParameter("quality", "high");
objFlashBox.Dock = DockStyle.Fill;
this.Controls.Add(objFlashBox);
Visual Basic Copy Code
Dim objFlashBox As New FlashBox()
objFlashBox.Movie = "../../../../../Resources/Flash/FC_2_3_Column3D.swf"
objFlashBox.AddParameter("FlashVars", "&dataURL=../../../../../Resources/Flash/FC_2_3_Column3D.xml")
objFlashBox.AddParameter("quality", "high")
objFlashBox.Dock = DockStyle.Fill
Me.Controls.Add(objFlashBox)

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.Hosts.ObjectBox
Gizmox.WebGUI.Forms.Hosts.FlashBoxBase
Gizmox.WebGUI.Forms.Hosts.FlashBox

Requirements

Namespace: Gizmox.WebGUI.Forms.Hosts

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

FlashBox Members
Gizmox.WebGUI.Forms.Hosts Namespace


FlashBox Class Members

[image]
Gizmox.WebGUI.Forms
FlashBox Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace : FlashBox Class

The following tables list the members exposed by FlashBox.

Public Constructors

 | Name | Description
Public Constructor | FlashBox Constructor | Creates a new FlashBox instance.
Top

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackColor | Gets or sets the background color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BindingContext | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Container | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Context | Gets the context. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Form | Gets the owner form. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Height | Gets/Sets the height position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | IsRegistered | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Left | Gets/Sets the left position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Location | Gets or sets the control location. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Movie | Gets or sets the code.
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Right | Gets/Sets the right position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Site | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Top | Gets/Sets the top position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Visible | Gets or sets the control visability. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Width | Gets/Sets the width position (Inherited from Gizmox.WebGUI.Forms.Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultBorderColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultBorderStyle | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultForeColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMargin | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultPadding | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DesignMode | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | Events | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | Gateways | Gets the gateways hash. (Inherited from ObjectBox)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | InternalMovie | Gets or sets the movie. (Inherited from FlashBoxBase)
Protected Property | IsConnected | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Property | IsDelayedDrawing | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ObjectClassId | Gets or sets the object class id. (Inherited from ObjectBox)
Protected Property | ObjectCodeBase | Gets or sets the object code base. (Inherited from ObjectBox)
Protected Property | ObjectPluginsPageType | Gets or sets the type of the object plugins page. (Inherited from ObjectBox)
Protected Property | ObjectType | Gets or sets the type of the object. (Inherited from ObjectBox)
Protected Property | Params | Gets the parameters hash. (Inherited from ObjectBox)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | Session | Gets the application object. (Inherited from Gizmox.WebGUI.Forms.Component)
Top

Public Methods

 | Name | Description
Public Method | AddParameter | Overloaded. Adds the parameter.
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ClearParameters | Clears the parameters.
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Focus | Sets focus to this control (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | GetGatewayHandler | (Inherited from ObjectBox)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | GetParameter | Gets the parameter.
Public Method | GetPreferredSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | RemoveParameter | Removes the parameter.
Public Method | ResetText | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SendToBack | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Show | Displays the control to the user. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ToString | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Update | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | Finalize | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCommandText | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetImage | Gets the image. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetPreferredSizeCore | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetService | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | InvokeMethod | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | IsDirty | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBindingContextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnControlAdded | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnControlRemoved | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | OnEnabledChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnGotFocus | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLostFocus | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentVisibleChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnResize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnTextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnUnregisterComponents | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnValidated | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnValidating | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ProcessGatewayRequest | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RegisterSelf | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | Render | Renders the current control. (Inherited from ObjectBox)
Protected Method | RenderAttributes | Renders the controls meta attributes (Inherited from ObjectBox)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderClientUpdateHandler | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderComponentEventAttributes | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetImage | Sets the image. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeText | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | UnRegisterBatch | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | UnRegisterSelf | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | UpdateParams | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Top

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Disposed | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Gizmox.WebGUI.Forms.Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Top

See Also

Reference

FlashBox Class
Gizmox.WebGUI.Forms.Hosts Namespace


FlashBox Constructor

[image]
Gizmox.WebGUI.Forms
FlashBox Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > FlashBox Class : FlashBox Constructor

Creates a new FlashBox instance.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As FlashBox()
C#
public FlashBox()
Managed Extensions for C++
public: FlashBox();
C++/CLI
public:
FlashBox();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FlashBox Class
FlashBox Members


FlashBox Class Methods

[image]
Gizmox.WebGUI.Forms
FlashBox Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace : FlashBox Class

For a list of all members of this type, see FlashBox members.

Public Methods

 | Name | Description
Public Method | AddParameter | Overloaded. Adds the parameter.
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ClearParameters | Clears the parameters.
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Focus | Sets focus to this control (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | GetGatewayHandler | (Inherited from ObjectBox)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | GetParameter | Gets the parameter.
Public Method | GetPreferredSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | RemoveParameter | Removes the parameter.
Public Method | ResetText | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SendToBack | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Show | Displays the control to the user. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ToString | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Update | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | Finalize | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCommandText | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetImage | Gets the image. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetPreferredSizeCore | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetService | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | InvokeMethod | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | IsDirty | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBindingContextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnControlAdded | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnControlRemoved | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | OnEnabledChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnGotFocus | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLostFocus | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentVisibleChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnResize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnTextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnUnregisterComponents | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnValidated | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnValidating | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ProcessGatewayRequest | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RegisterSelf | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | Render | Renders the current control. (Inherited from ObjectBox)
Protected Method | RenderAttributes | Renders the controls meta attributes (Inherited from ObjectBox)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderClientUpdateHandler | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderComponentEventAttributes | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetImage | Sets the image. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeText | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | UnRegisterBatch | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | UnRegisterSelf | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | UpdateParams | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Top

See Also

Reference

FlashBox Class
Gizmox.WebGUI.Forms.Hosts Namespace


AddParameter Method

[image]
Gizmox.WebGUI.Forms
AddParameter Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > FlashBox Class : AddParameter Method

Adds the parameter.

Overload List

Overload | Description
AddParameter(String,String) | Adds the parameter.
AddParameter(String,GatewayHandler) | Adds the parameter.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FlashBox Class
FlashBox Members


AddParameter(String,String) Method

[image]
Gizmox.WebGUI.Forms
AddParameter(String,String) Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > FlashBox Class > AddParameter Method : AddParameter(String,String) Method

strName
strValue
Adds the parameter.

Syntax

Visual Basic (Declaration)
Public Overloads Sub AddParameter( _
   ByVal strName As String, _
   ByVal strValue As String _
)
Visual Basic (Usage) Copy Code
Dim instance As FlashBox
Dim strName As String
Dim strValue As String

instance.AddParameter(strName, strValue)
C#
public void AddParameter(
   string strName,
   string strValue
)
Managed Extensions for C++
public: void AddParameter(
   string* strName,
   string* strValue
)
C++/CLI
public:
void AddParameter(
   String^ strName,
   String^ strValue
)

Parameters

strName
strValue

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FlashBox Class
FlashBox Members
Overload List


AddParameter(String,GatewayHandler) Method

[image]
Gizmox.WebGUI.Forms
AddParameter(String,GatewayHandler) Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > FlashBox Class > AddParameter Method : AddParameter(String,GatewayHandler) Method

strName
objHandler
Adds the parameter.

Syntax

Visual Basic (Declaration)
Public Overloads Sub AddParameter( _
   ByVal strName As String, _
   ByVal objHandler As GatewayHandler _
)
Visual Basic (Usage) Copy Code
Dim instance As FlashBox
Dim strName As String
Dim objHandler As GatewayHandler

instance.AddParameter(strName, objHandler)
C#
public void AddParameter(
   string strName,
   GatewayHandler objHandler
)
Managed Extensions for C++
public: void AddParameter(
   string* strName,
   GatewayHandler* objHandler
)
C++/CLI
public:
void AddParameter(
   String^ strName,
   GatewayHandler^ objHandler
)

Parameters

strName
objHandler

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FlashBox Class
FlashBox Members
Overload List


ClearParameters Method

[image]
Gizmox.WebGUI.Forms
ClearParameters Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > FlashBox Class : ClearParameters Method

Clears the parameters.

Syntax

Visual Basic (Declaration)
Public Sub ClearParameters()
Visual Basic (Usage) Copy Code
Dim instance As FlashBox

instance.ClearParameters()
C#
public void ClearParameters()
Managed Extensions for C++
public: void ClearParameters();
C++/CLI
public:
void ClearParameters();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FlashBox Class
FlashBox Members


GetParameter Method

[image]
Gizmox.WebGUI.Forms
GetParameter Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > FlashBox Class : GetParameter Method

strName
Gets the parameter.

Syntax

Visual Basic (Declaration)
Public Function GetParameter( _
   ByVal strName As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As FlashBox
Dim strName As String
Dim value As String

value = instance.GetParameter(strName)
C#
public string GetParameter(
   string strName
)
Managed Extensions for C++
public: string* GetParameter(
   string* strName
)
C++/CLI
public:
String^ GetParameter(
   String^ strName
)

Parameters

strName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FlashBox Class
FlashBox Members


RemoveParameter Method

[image]
Gizmox.WebGUI.Forms
RemoveParameter Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > FlashBox Class : RemoveParameter Method

strName
Removes the parameter.

Syntax

Visual Basic (Declaration)
Public Sub RemoveParameter( _
   ByVal strName As String _
)
Visual Basic (Usage) Copy Code
Dim instance As FlashBox
Dim strName As String

instance.RemoveParameter(strName)
C#
public void RemoveParameter(
   string strName
)
Managed Extensions for C++
public: void RemoveParameter(
   string* strName
)
C++/CLI
public:
void RemoveParameter(
   String^ strName
)

Parameters

strName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FlashBox Class
FlashBox Members


FlashBox Class Properties

[image]
Gizmox.WebGUI.Forms
FlashBox Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace : FlashBox Class

For a list of all members of this type, see FlashBox members.

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackColor | Gets or sets the background color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BindingContext | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Container | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Context | Gets the context. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Form | Gets the owner form. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Height | Gets/Sets the height position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | IsRegistered | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Left | Gets/Sets the left position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Location | Gets or sets the control location. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Movie | Gets or sets the code.
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Right | Gets/Sets the right position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Site | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Top | Gets/Sets the top position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Visible | Gets or sets the control visability. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Width | Gets/Sets the width position (Inherited from Gizmox.WebGUI.Forms.Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultBorderColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultBorderStyle | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultForeColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMargin | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultPadding | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DesignMode | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | Events | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | Gateways | Gets the gateways hash. (Inherited from ObjectBox)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | InternalMovie | Gets or sets the movie. (Inherited from FlashBoxBase)
Protected Property | IsConnected | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Property | IsDelayedDrawing | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ObjectClassId | Gets or sets the object class id. (Inherited from ObjectBox)
Protected Property | ObjectCodeBase | Gets or sets the object code base. (Inherited from ObjectBox)
Protected Property | ObjectPluginsPageType | Gets or sets the type of the object plugins page. (Inherited from ObjectBox)
Protected Property | ObjectType | Gets or sets the type of the object. (Inherited from ObjectBox)
Protected Property | Params | Gets the parameters hash. (Inherited from ObjectBox)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | Session | Gets the application object. (Inherited from Gizmox.WebGUI.Forms.Component)
Top

See Also

Reference

FlashBox Class
Gizmox.WebGUI.Forms.Hosts Namespace


Movie Property

[image]
Gizmox.WebGUI.Forms
Movie Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > FlashBox Class : Movie Property

Gets or sets the code.

Syntax

Visual Basic (Declaration)
Public Property Movie As String
Visual Basic (Usage) Copy Code
Dim instance As FlashBox
Dim value As String

instance.Movie = value

value = instance.Movie
C#
public string Movie {get; set;}
Managed Extensions for C++
public: __property string* get_Movie();
public: __property void set_Movie(
   string* value
);
C++/CLI
public:
property String^ Movie {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FlashBox Class
FlashBox Members


FlashBoxBase Class

[image]
Gizmox.WebGUI.Forms
FlashBoxBase Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace : FlashBoxBase Class

Summary description for FlashBoxBase.

Object Model

Syntax

Visual Basic (Declaration)
<ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")>
Public Class FlashBoxBase
   Inherits ObjectBox
   Implements IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IGatewayControl, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Visual Basic (Usage) Copy Code
Dim instance As FlashBoxBase
C#
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
public class FlashBoxBase : ObjectBox, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IGatewayControl, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Managed Extensions for C++
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
public __gc class FlashBoxBase : public ObjectBox, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IGatewayControl, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
C++/CLI
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
public ref class FlashBoxBase : public ObjectBox, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IGatewayControl, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.Hosts.ObjectBox
Gizmox.WebGUI.Forms.Hosts.FlashBoxBase
Gizmox.WebGUI.Forms.Hosts.FlashBox

Requirements

Namespace: Gizmox.WebGUI.Forms.Hosts

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

FlashBoxBase Members
Gizmox.WebGUI.Forms.Hosts Namespace


FlashBoxBase Class Members

[image]
Gizmox.WebGUI.Forms
FlashBoxBase Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace : FlashBoxBase Class

The following tables list the members exposed by FlashBoxBase.

Public Constructors

 | Name | Description
Public Constructor | FlashBoxBase Constructor | Creates a new FlashBoxBase instance.
Top

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackColor | Gets or sets the background color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BindingContext | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Container | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Context | Gets the context. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Form | Gets the owner form. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Height | Gets/Sets the height position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | IsRegistered | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Left | Gets/Sets the left position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Location | Gets or sets the control location. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Right | Gets/Sets the right position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Site | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Top | Gets/Sets the top position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Visible | Gets or sets the control visability. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Width | Gets/Sets the width position (Inherited from Gizmox.WebGUI.Forms.Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultBorderColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultBorderStyle | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultForeColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMargin | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultPadding | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DesignMode | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | Events | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | Gateways | Gets the gateways hash. (Inherited from ObjectBox)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | InternalMovie | Gets or sets the movie.
Protected Property | IsConnected | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Property | IsDelayedDrawing | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ObjectClassId | Gets or sets the object class id. (Inherited from ObjectBox)
Protected Property | ObjectCodeBase | Gets or sets the object code base. (Inherited from ObjectBox)
Protected Property | ObjectPluginsPageType | Gets or sets the type of the object plugins page. (Inherited from ObjectBox)
Protected Property | ObjectType | Gets or sets the type of the object. (Inherited from ObjectBox)
Protected Property | Params | Gets the parameters hash. (Inherited from ObjectBox)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | Session | Gets the application object. (Inherited from Gizmox.WebGUI.Forms.Component)
Top

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Focus | Sets focus to this control (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | GetGatewayHandler | (Inherited from ObjectBox)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | GetPreferredSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | ResetText | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SendToBack | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Show | Displays the control to the user. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ToString | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Update | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | Finalize | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCommandText | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetImage | Gets the image. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetPreferredSizeCore | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetService | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | InvokeMethod | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | IsDirty | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBindingContextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnControlAdded | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnControlRemoved | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | OnEnabledChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnGotFocus | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLostFocus | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentVisibleChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnResize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnTextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnUnregisterComponents | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnValidated | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnValidating | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ProcessGatewayRequest | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RegisterSelf | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | Render | Renders the current control. (Inherited from ObjectBox)
Protected Method | RenderAttributes | Renders the controls meta attributes (Inherited from ObjectBox)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderClientUpdateHandler | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderComponentEventAttributes | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetImage | Sets the image. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeText | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | UnRegisterBatch | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | UnRegisterSelf | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | UpdateParams | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Top

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Disposed | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Gizmox.WebGUI.Forms.Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Top

See Also

Reference

FlashBoxBase Class
Gizmox.WebGUI.Forms.Hosts Namespace


FlashBoxBase Constructor

[image]
Gizmox.WebGUI.Forms
FlashBoxBase Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > FlashBoxBase Class : FlashBoxBase Constructor

Creates a new FlashBoxBase instance.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As FlashBoxBase()
C#
public FlashBoxBase()
Managed Extensions for C++
public: FlashBoxBase();
C++/CLI
public:
FlashBoxBase();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FlashBoxBase Class
FlashBoxBase Members


FlashBoxBase Class Properties

[image]
Gizmox.WebGUI.Forms
FlashBoxBase Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace : FlashBoxBase Class

For a list of all members of this type, see FlashBoxBase members.

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackColor | Gets or sets the background color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BindingContext | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Container | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Context | Gets the context. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Form | Gets the owner form. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Height | Gets/Sets the height position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | IsRegistered | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Left | Gets/Sets the left position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Location | Gets or sets the control location. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Right | Gets/Sets the right position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Site | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Top | Gets/Sets the top position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Visible | Gets or sets the control visability. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Width | Gets/Sets the width position (Inherited from Gizmox.WebGUI.Forms.Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultBorderColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultBorderStyle | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultForeColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMargin | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultPadding | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DesignMode | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | Events | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | Gateways | Gets the gateways hash. (Inherited from ObjectBox)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | InternalMovie | Gets or sets the movie.
Protected Property | IsConnected | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Property | IsDelayedDrawing | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ObjectClassId | Gets or sets the object class id. (Inherited from ObjectBox)
Protected Property | ObjectCodeBase | Gets or sets the object code base. (Inherited from ObjectBox)
Protected Property | ObjectPluginsPageType | Gets or sets the type of the object plugins page. (Inherited from ObjectBox)
Protected Property | ObjectType | Gets or sets the type of the object. (Inherited from ObjectBox)
Protected Property | Params | Gets the parameters hash. (Inherited from ObjectBox)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | Session | Gets the application object. (Inherited from Gizmox.WebGUI.Forms.Component)
Top

See Also

Reference

FlashBoxBase Class
Gizmox.WebGUI.Forms.Hosts Namespace


InternalMovie Property

[image]
Gizmox.WebGUI.Forms
InternalMovie Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > FlashBoxBase Class : InternalMovie Property

Gets or sets the movie.

Syntax

Visual Basic (Declaration)
Protected Property InternalMovie As String
Visual Basic (Usage) Copy Code
Dim instance As FlashBoxBase
Dim value As String

instance.InternalMovie = value

value = instance.InternalMovie
C#
protected string InternalMovie {get; set;}
Managed Extensions for C++
protected: __property string* get_InternalMovie();
protected: __property void set_InternalMovie(
   string* value
);
C++/CLI
protected:
property String^ InternalMovie {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FlashBoxBase Class
FlashBoxBase Members


FormBox Class

[image]
Gizmox.WebGUI.Forms
FormBox Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace : FormBox Class

Object Model

Syntax

Visual Basic (Declaration)
<ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<ToolboxBitmapAttribute()>
<DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="Gizmox.WebGUI.Forms.Design.FormBoxDesigner, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")>
<ToolboxDataAttribute("<{0}:FormBox runat=server></{0}:FormBox>")>
Public Class FormBox
   Inherits Control
Visual Basic (Usage) Copy Code
Dim instance As FormBox
C#
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ToolboxBitmapAttribute()]
[DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="Gizmox.WebGUI.Forms.Design.FormBoxDesigner, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[ToolboxDataAttribute("<{0}:FormBox runat=server></{0}:FormBox>")]
public class FormBox : Control
Managed Extensions for C++
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ToolboxBitmapAttribute()]
[DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="Gizmox.WebGUI.Forms.Design.FormBoxDesigner, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[ToolboxDataAttribute("<{0}:FormBox runat=server></{0}:FormBox>")]
public __gc class FormBox : public Control
C++/CLI
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ToolboxBitmapAttribute()]
[DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="Gizmox.WebGUI.Forms.Design.FormBoxDesigner, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[ToolboxDataAttribute("<{0}:FormBox runat=server></{0}:FormBox>")]
public ref class FormBox : public Control

Inheritance Hierarchy

System.Object
System.Web.UI.Control
Gizmox.WebGUI.Forms.Hosts.FormBox

Requirements

Namespace: Gizmox.WebGUI.Forms.Hosts

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

FormBox Members
Gizmox.WebGUI.Forms.Hosts Namespace


FormBox Class Members

[image]
Gizmox.WebGUI.Forms
FormBox Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace : FormBox Class

The following tables list the members exposed by FormBox.

Public Constructors

 | Name | Description
Public Constructor | FormBox Constructor |
Top

Public Properties

 | Name | Description
Public Property | ApplicationUIType | Gets or sets a value indicating whether this Control show open the internal form as a DHTML Form (wgx) or as a Silverlight Form (swgx).
Public Property | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from System.Web.UI.Control)
Public Property | Arguments | The form arguments which can be used with in the Visual WebGui application
Public Property | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from System.Web.UI.Control)
Public Property | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from System.Web.UI.Control)
Public Property | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from System.Web.UI.Control)
Public Property | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from System.Web.UI.Control)
Public Property | Form | The mapped Visual WebGUI form to be displayed
Public Property | Height | Gets or sets the height of the Web server control.
Public Property | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from System.Web.UI.Control)
Public Property | Instance | The form instance which is used to create instances of the same mapped form
Public Property | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from System.Web.UI.Control)
Public Property | Page | Gets a reference to the Page instance that contains the server control. (Inherited from System.Web.UI.Control)
Public Property | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from System.Web.UI.Control)
Public Property | Results | The form results which can be used to expose parameters and references from the Visual WebGui application
Public Property | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from System.Web.UI.Control)
Public Property | SkinID | Gets or sets the skin to apply to the control. (Inherited from System.Web.UI.Control)
Public Property | Stateless |
Public Property | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from System.Web.UI.Control)
Public Property | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from System.Web.UI.Control)
Public Property | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from System.Web.UI.Control)
Public Property | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from System.Web.UI.Control)
Public Property | Width | Gets or sets the width of the Web server control.
Top

Protected Properties

 | Name | Description
Protected Property | Adapter | Gets the browser-specific adapter for the control. (Inherited from System.Web.UI.Control)
Protected Property | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from System.Web.UI.Control)
Protected Property | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from System.Web.UI.Control)
Protected Property | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from System.Web.UI.Control)
Protected Property | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from System.Web.UI.Control)
Protected Property | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from System.Web.UI.Control)
Protected Property | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from System.Web.UI.Control)
Protected Property | IdSeparator | Gets the character used to separate control identifiers. (Inherited from System.Web.UI.Control)
Protected Property | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from System.Web.UI.Control)
Protected Property | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from System.Web.UI.Control)
Protected Property | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from System.Web.UI.Control)
Protected Property | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from System.Web.UI.Control)
Protected Property | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from System.Web.UI.Control)
Protected Property | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from System.Web.UI.Control)
Top

Public Methods

 | Name | Description
Public Method | ApplyStyleSheetSkin | Applies the style properties defined in the page style sheet to the control. (Inherited from System.Web.UI.Control)
Public Method | DataBind | Overloaded. Binds a data source to the invoked server control and all its child controls. (Inherited from System.Web.UI.Control)
Public Method | Dispose | Enables a server control to perform final clean up before it is released from memory. (Inherited from System.Web.UI.Control)
Public Method | FindControl | Overloaded. Searches the current naming container for a server control with the specified id parameter. (Inherited from System.Web.UI.Control)
Public Method | Focus | Sets input focus to a control. (Inherited from System.Web.UI.Control)
Public Method | HasControls | Determines if the server control contains any child controls. (Inherited from System.Web.UI.Control)
Public Method | RenderControl | Overloaded. Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from System.Web.UI.Control)
Public Method | ResolveClientUrl | Gets a URL that can be used by the browser. (Inherited from System.Web.UI.Control)
Public Method | ResolveUrl | Converts a URL into one that is usable on the requesting client. (Inherited from System.Web.UI.Control)
Public Method | SetRenderMethodDelegate | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from System.Web.UI.Control)
Top

Protected Methods

 | Name | Description
Protected Method | AddedControl | Called after a child control is added to the Controls collection of the Control object. (Inherited from System.Web.UI.Control)
Protected Method | AddParsedSubObject | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from System.Web.UI.Control)
Protected Method | BuildProfileTree | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from System.Web.UI.Control)
Protected Method | ClearChildControlState | Deletes the control-state information for the server control's child controls. (Inherited from System.Web.UI.Control)
Protected Method | ClearChildState | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from System.Web.UI.Control)
Protected Method | ClearChildViewState | Deletes the view-state information for all the server control's child controls. (Inherited from System.Web.UI.Control)
Protected Method | CreateChildControls | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from System.Web.UI.Control)
Protected Method | CreateControlCollection | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from System.Web.UI.Control)
Protected Method | DataBindChildren | Binds a data source to the server control's child controls. (Inherited from System.Web.UI.Control)
Protected Method | EnsureChildControls | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from System.Web.UI.Control)
Protected Method | EnsureID | Creates an identifier for controls that do not have an identifier assigned. (Inherited from System.Web.UI.Control)
Protected Method | GetDesignModeState | Gets design-time data for a control. (Inherited from System.Web.UI.Control)
Protected Method | HasEvents | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from System.Web.UI.Control)
Protected Method | IsLiteralContent | Determines if the server control holds only literal content. (Inherited from System.Web.UI.Control)
Protected Method | LoadControlState | Restores control-state information from a previous page request that was saved by the SaveControlState method. (Inherited from System.Web.UI.Control)
Protected Method | LoadViewState | Restores view-state information from a previous page request that was saved by the SaveViewState method. (Inherited from System.Web.UI.Control)
Protected Method | MapPathSecure | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from System.Web.UI.Control)
Protected Method | OnBubbleEvent | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from System.Web.UI.Control)
Protected Method | OnDataBinding | Raises the DataBinding event. (Inherited from System.Web.UI.Control)
Protected Method | OnInit | Raises the Init event. (Inherited from System.Web.UI.Control)
Protected Method | OnLoad | Raises the Load event. (Inherited from System.Web.UI.Control)
Protected Method | OnPreRender | Raises the PreRender event. (Inherited from System.Web.UI.Control)
Protected Method | OnUnload | Raises the Unload event. (Inherited from System.Web.UI.Control)
Protected Method | OpenFile | Gets a Stream used to read a file. (Inherited from System.Web.UI.Control)
Protected Method | RaiseBubbleEvent | Assigns any sources of the event and its information to the control's parent. (Inherited from System.Web.UI.Control)
Protected Method | RemovedControl | Called after a control is removed from the Controls collection of another control. (Inherited from System.Web.UI.Control)
Protected Method | Render | Overridden.
Protected Method | RenderChildren | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from System.Web.UI.Control)
Protected Method | ResolveAdapter | Gets the control adapter responsible for rendering the specified control. (Inherited from System.Web.UI.Control)
Protected Method | SaveControlState | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from System.Web.UI.Control)
Protected Method | SaveViewState | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from System.Web.UI.Control)
Protected Method | SetDesignModeState | Sets design-time data for a control. (Inherited from System.Web.UI.Control)
Protected Method | TrackViewState | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from System.Web.UI.Control)
Top

Public Events

 | Name | Description
Public Event | DataBinding | Occurs when the server control binds to a data source. (Inherited from System.Web.UI.Control)
Public Event | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from System.Web.UI.Control)
Public Event | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from System.Web.UI.Control)
Public Event | Load | Occurs when the server control is loaded into the Page object. (Inherited from System.Web.UI.Control)
Public Event | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from System.Web.UI.Control)
Public Event | Unload | Occurs when the server control is unloaded from memory. (Inherited from System.Web.UI.Control)
Top

See Also

Reference

FormBox Class
Gizmox.WebGUI.Forms.Hosts Namespace


FormBox Constructor

[image]
Gizmox.WebGUI.Forms
FormBox Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > FormBox Class : FormBox Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As FormBox()
C#
public FormBox()
Managed Extensions for C++
public: FormBox();
C++/CLI
public:
FormBox();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FormBox Class
FormBox Members


FormBox Class Methods

[image]
Gizmox.WebGUI.Forms
FormBox Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace : FormBox Class

For a list of all members of this type, see FormBox members.

Public Methods

 | Name | Description
Public Method | ApplyStyleSheetSkin | Applies the style properties defined in the page style sheet to the control. (Inherited from System.Web.UI.Control)
Public Method | DataBind | Overloaded. Binds a data source to the invoked server control and all its child controls. (Inherited from System.Web.UI.Control)
Public Method | Dispose | Enables a server control to perform final clean up before it is released from memory. (Inherited from System.Web.UI.Control)
Public Method | FindControl | Overloaded. Searches the current naming container for a server control with the specified id parameter. (Inherited from System.Web.UI.Control)
Public Method | Focus | Sets input focus to a control. (Inherited from System.Web.UI.Control)
Public Method | HasControls | Determines if the server control contains any child controls. (Inherited from System.Web.UI.Control)
Public Method | RenderControl | Overloaded. Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from System.Web.UI.Control)
Public Method | ResolveClientUrl | Gets a URL that can be used by the browser. (Inherited from System.Web.UI.Control)
Public Method | ResolveUrl | Converts a URL into one that is usable on the requesting client. (Inherited from System.Web.UI.Control)
Public Method | SetRenderMethodDelegate | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from System.Web.UI.Control)
Top

Protected Methods

 | Name | Description
Protected Method | AddedControl | Called after a child control is added to the Controls collection of the Control object. (Inherited from System.Web.UI.Control)
Protected Method | AddParsedSubObject | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from System.Web.UI.Control)
Protected Method | BuildProfileTree | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from System.Web.UI.Control)
Protected Method | ClearChildControlState | Deletes the control-state information for the server control's child controls. (Inherited from System.Web.UI.Control)
Protected Method | ClearChildState | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from System.Web.UI.Control)
Protected Method | ClearChildViewState | Deletes the view-state information for all the server control's child controls. (Inherited from System.Web.UI.Control)
Protected Method | CreateChildControls | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from System.Web.UI.Control)
Protected Method | CreateControlCollection | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from System.Web.UI.Control)
Protected Method | DataBindChildren | Binds a data source to the server control's child controls. (Inherited from System.Web.UI.Control)
Protected Method | EnsureChildControls | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from System.Web.UI.Control)
Protected Method | EnsureID | Creates an identifier for controls that do not have an identifier assigned. (Inherited from System.Web.UI.Control)
Protected Method | GetDesignModeState | Gets design-time data for a control. (Inherited from System.Web.UI.Control)
Protected Method | HasEvents | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from System.Web.UI.Control)
Protected Method | IsLiteralContent | Determines if the server control holds only literal content. (Inherited from System.Web.UI.Control)
Protected Method | LoadControlState | Restores control-state information from a previous page request that was saved by the SaveControlState method. (Inherited from System.Web.UI.Control)
Protected Method | LoadViewState | Restores view-state information from a previous page request that was saved by the SaveViewState method. (Inherited from System.Web.UI.Control)
Protected Method | MapPathSecure | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from System.Web.UI.Control)
Protected Method | OnBubbleEvent | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from System.Web.UI.Control)
Protected Method | OnDataBinding | Raises the DataBinding event. (Inherited from System.Web.UI.Control)
Protected Method | OnInit | Raises the Init event. (Inherited from System.Web.UI.Control)
Protected Method | OnLoad | Raises the Load event. (Inherited from System.Web.UI.Control)
Protected Method | OnPreRender | Raises the PreRender event. (Inherited from System.Web.UI.Control)
Protected Method | OnUnload | Raises the Unload event. (Inherited from System.Web.UI.Control)
Protected Method | OpenFile | Gets a Stream used to read a file. (Inherited from System.Web.UI.Control)
Protected Method | RaiseBubbleEvent | Assigns any sources of the event and its information to the control's parent. (Inherited from System.Web.UI.Control)
Protected Method | RemovedControl | Called after a control is removed from the Controls collection of another control. (Inherited from System.Web.UI.Control)
Protected Method | Render | Overridden.
Protected Method | RenderChildren | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from System.Web.UI.Control)
Protected Method | ResolveAdapter | Gets the control adapter responsible for rendering the specified control. (Inherited from System.Web.UI.Control)
Protected Method | SaveControlState | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from System.Web.UI.Control)
Protected Method | SaveViewState | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from System.Web.UI.Control)
Protected Method | SetDesignModeState | Sets design-time data for a control. (Inherited from System.Web.UI.Control)
Protected Method | TrackViewState | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from System.Web.UI.Control)
Top

See Also

Reference

FormBox Class
Gizmox.WebGUI.Forms.Hosts Namespace


Render Method

[image]
Gizmox.WebGUI.Forms
Render Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > FormBox Class : Render Method

writer

Syntax

Visual Basic (Declaration)
Protected Overrides Sub Render( _
   ByVal writer As HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As FormBox
Dim writer As HtmlTextWriter

instance.Render(writer)
C#
protected override void Render(
   HtmlTextWriter writer
)
Managed Extensions for C++
protected: void Render(
   HtmlTextWriter* writer
) override
C++/CLI
protected:
void Render(
   HtmlTextWriter^ writer
) override

Parameters

writer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FormBox Class
FormBox Members


FormBox Class Properties

[image]
Gizmox.WebGUI.Forms
FormBox Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace : FormBox Class

For a list of all members of this type, see FormBox members.

Public Properties

 | Name | Description
Public Property | ApplicationUIType | Gets or sets a value indicating whether this Control show open the internal form as a DHTML Form (wgx) or as a Silverlight Form (swgx).
Public Property | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from System.Web.UI.Control)
Public Property | Arguments | The form arguments which can be used with in the Visual WebGui application
Public Property | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from System.Web.UI.Control)
Public Property | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from System.Web.UI.Control)
Public Property | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from System.Web.UI.Control)
Public Property | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from System.Web.UI.Control)
Public Property | Form | The mapped Visual WebGUI form to be displayed
Public Property | Height | Gets or sets the height of the Web server control.
Public Property | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from System.Web.UI.Control)
Public Property | Instance | The form instance which is used to create instances of the same mapped form
Public Property | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from System.Web.UI.Control)
Public Property | Page | Gets a reference to the Page instance that contains the server control. (Inherited from System.Web.UI.Control)
Public Property | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from System.Web.UI.Control)
Public Property | Results | The form results which can be used to expose parameters and references from the Visual WebGui application
Public Property | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from System.Web.UI.Control)
Public Property | SkinID | Gets or sets the skin to apply to the control. (Inherited from System.Web.UI.Control)
Public Property | Stateless |
Public Property | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from System.Web.UI.Control)
Public Property | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from System.Web.UI.Control)
Public Property | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from System.Web.UI.Control)
Public Property | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from System.Web.UI.Control)
Public Property | Width | Gets or sets the width of the Web server control.
Top

Protected Properties

 | Name | Description
Protected Property | Adapter | Gets the browser-specific adapter for the control. (Inherited from System.Web.UI.Control)
Protected Property | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from System.Web.UI.Control)
Protected Property | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from System.Web.UI.Control)
Protected Property | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from System.Web.UI.Control)
Protected Property | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from System.Web.UI.Control)
Protected Property | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from System.Web.UI.Control)
Protected Property | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from System.Web.UI.Control)
Protected Property | IdSeparator | Gets the character used to separate control identifiers. (Inherited from System.Web.UI.Control)
Protected Property | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from System.Web.UI.Control)
Protected Property | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from System.Web.UI.Control)
Protected Property | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from System.Web.UI.Control)
Protected Property | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from System.Web.UI.Control)
Protected Property | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from System.Web.UI.Control)
Protected Property | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from System.Web.UI.Control)
Top

See Also

Reference

FormBox Class
Gizmox.WebGUI.Forms.Hosts Namespace


ApplicationUIType Property

[image]
Gizmox.WebGUI.Forms
ApplicationUIType Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > FormBox Class : ApplicationUIType Property

Gets or sets a value indicating whether this Control show open the internal form as a DHTML Form (wgx) or as a Silverlight Form (swgx).

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<CategoryAttribute("Behavior")>
Public Overridable Property ApplicationUIType As FormBox.ApplicationUITypes
Visual Basic (Usage) Copy Code
Dim instance As FormBox
Dim value As FormBox.ApplicationUITypes

instance.ApplicationUIType = value

value = instance.ApplicationUIType
C#
[DefaultValueAttribute()]
[CategoryAttribute("Behavior")]
public virtual FormBox.ApplicationUITypes ApplicationUIType {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[CategoryAttribute("Behavior")]
public: __property virtual FormBox.ApplicationUITypes get_ApplicationUIType();
public: __property virtual void set_ApplicationUIType(
   FormBox.ApplicationUITypes value
);
C++/CLI
[DefaultValueAttribute()]
[CategoryAttribute("Behavior")]
public:
virtual property FormBox::ApplicationUITypes ApplicationUIType {
   FormBox::ApplicationUITypes get();
   void set (FormBox::ApplicationUITypesvalue);
}

Return Value

true if [Run as DHTML]; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FormBox Class
FormBox Members


Arguments Property

[image]
Gizmox.WebGUI.Forms
Arguments Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > FormBox Class : Arguments Property

The form arguments which can be used with in the Visual WebGui application

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Arguments As IArgumentsWriterProvider
Visual Basic (Usage) Copy Code
Dim instance As FormBox
Dim value As IArgumentsWriterProvider

value = instance.Arguments
C#
public IArgumentsWriterProvider Arguments {get;}
Managed Extensions for C++
public: __property IArgumentsWriterProvider* get_Arguments();
C++/CLI
public:
property IArgumentsWriterProvider^ Arguments {
   IArgumentsWriterProvider^ get();
}

Remarks

Provides a mechanism to send parameters and object references to the Visual WebGui application.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FormBox Class
FormBox Members


Form Property

[image]
Gizmox.WebGUI.Forms
Form Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > FormBox Class : Form Property

The mapped Visual WebGUI form to be displayed

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Data")>
<DefaultValueAttribute()>
Public Property Form As String
Visual Basic (Usage) Copy Code
Dim instance As FormBox
Dim value As String

instance.Form = value

value = instance.Form
C#
[CategoryAttribute("Data")]
[DefaultValueAttribute()]
public string Form {get; set;}
Managed Extensions for C++
[CategoryAttribute("Data")]
[DefaultValueAttribute()]
public: __property string* get_Form();
public: __property void set_Form(
   string* value
);
C++/CLI
[CategoryAttribute("Data")]
[DefaultValueAttribute()]
public:
property String^ Form {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FormBox Class
FormBox Members


Height Property

[image]
Gizmox.WebGUI.Forms
Height Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > FormBox Class : Height Property

Gets or sets the height of the Web server control.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Overridable Property Height As Unit
Visual Basic (Usage) Copy Code
Dim instance As FormBox
Dim value As Unit

instance.Height = value

value = instance.Height
C#
[DefaultValueAttribute()]
public virtual Unit Height {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property virtual Unit get_Height();
public: __property virtual void set_Height(
   Unit value
);
C++/CLI
[DefaultValueAttribute()]
public:
virtual property Unit Height {
   Unit get();
   void set (Unitvalue);
}

Exceptions

Exception | Description
ArgumentException | The height was set to a negative value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FormBox Class
FormBox Members


Instance Property

[image]
Gizmox.WebGUI.Forms
Instance Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > FormBox Class : Instance Property

The form instance which is used to create instances of the same mapped form

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<CategoryAttribute("Data")>
Public Property Instance As String
Visual Basic (Usage) Copy Code
Dim instance As FormBox
Dim value As String

instance.Instance = value

value = instance.Instance
C#
[DefaultValueAttribute()]
[CategoryAttribute("Data")]
public string Instance {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[CategoryAttribute("Data")]
public: __property string* get_Instance();
public: __property void set_Instance(
   string* value
);
C++/CLI
[DefaultValueAttribute()]
[CategoryAttribute("Data")]
public:
property String^ Instance {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FormBox Class
FormBox Members


Results Property

[image]
Gizmox.WebGUI.Forms
Results Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > FormBox Class : Results Property

The form results which can be used to expose parameters and references from the Visual WebGui application

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Results As IResultsReaderProvider
Visual Basic (Usage) Copy Code
Dim instance As FormBox
Dim value As IResultsReaderProvider

value = instance.Results
C#
public IResultsReaderProvider Results {get;}
Managed Extensions for C++
public: __property IResultsReaderProvider* get_Results();
C++/CLI
public:
property IResultsReaderProvider^ Results {
   IResultsReaderProvider^ get();
}

Remarks

Provides a mechanism to return parameters and object references from the Visual WebGui application.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FormBox Class
FormBox Members


Stateless Property

[image]
Gizmox.WebGUI.Forms
Stateless Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > FormBox Class : Stateless Property

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Behavior")>
<DefaultValueAttribute()>
Public Property Stateless As Boolean
Visual Basic (Usage) Copy Code
Dim instance As FormBox
Dim value As Boolean

instance.Stateless = value

value = instance.Stateless
C#
[CategoryAttribute("Behavior")]
[DefaultValueAttribute()]
public bool Stateless {get; set;}
Managed Extensions for C++
[CategoryAttribute("Behavior")]
[DefaultValueAttribute()]
public: __property bool get_Stateless();
public: __property void set_Stateless(
   bool value
);
C++/CLI
[CategoryAttribute("Behavior")]
[DefaultValueAttribute()]
public:
property bool Stateless {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FormBox Class
FormBox Members


Width Property

[image]
Gizmox.WebGUI.Forms
Width Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > FormBox Class : Width Property

Gets or sets the width of the Web server control.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Overridable Property Width As Unit
Visual Basic (Usage) Copy Code
Dim instance As FormBox
Dim value As Unit

instance.Width = value

value = instance.Width
C#
[DefaultValueAttribute()]
public virtual Unit Width {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property virtual Unit get_Width();
public: __property virtual void set_Width(
   Unit value
);
C++/CLI
[DefaultValueAttribute()]
public:
virtual property Unit Width {
   Unit get();
   void set (Unitvalue);
}

Exceptions

Exception | Description
ArgumentException | The width of the Web server control was set to a negative value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FormBox Class
FormBox Members


ObjectBox Class

[image]
Gizmox.WebGUI.Forms
ObjectBox Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace : ObjectBox Class

Summary description for ObjectBox.

Object Model

Syntax

Visual Basic (Declaration)
<SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableHtmlObjectBox, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")>
<ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")>
<MetadataTagAttribute("OBJ")>
Public Class ObjectBox
   Inherits Control
   Implements IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IGatewayControl, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Visual Basic (Usage) Copy Code
Dim instance As ObjectBox
C#
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableHtmlObjectBox, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
[MetadataTagAttribute("OBJ")]
public class ObjectBox : Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IGatewayControl, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Managed Extensions for C++
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableHtmlObjectBox, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
[MetadataTagAttribute("OBJ")]
public __gc class ObjectBox : public Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IGatewayControl, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
C++/CLI
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableHtmlObjectBox, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
[MetadataTagAttribute("OBJ")]
public ref class ObjectBox : public Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IGatewayControl, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.Hosts.ObjectBox
Gizmox.WebGUI.Forms.Hosts.FlashBoxBase

Requirements

Namespace: Gizmox.WebGUI.Forms.Hosts

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

ObjectBox Members
Gizmox.WebGUI.Forms.Hosts Namespace


ObjectBox Class Members

[image]
Gizmox.WebGUI.Forms
ObjectBox Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace : ObjectBox Class

The following tables list the members exposed by ObjectBox.

Public Constructors

 | Name | Description
Public Constructor | ObjectBox Constructor | Creates a new ObjectBox instance.
Top

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackColor | Gets or sets the background color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BindingContext | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Container | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Context | Gets the context. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Form | Gets the owner form. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Height | Gets/Sets the height position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | IsRegistered | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Left | Gets/Sets the left position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Location | Gets or sets the control location. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Right | Gets/Sets the right position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Site | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Top | Gets/Sets the top position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Visible | Gets or sets the control visability. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Width | Gets/Sets the width position (Inherited from Gizmox.WebGUI.Forms.Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultBorderColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultBorderStyle | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultForeColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMargin | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultPadding | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DesignMode | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | Events | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | Gateways | Gets the gateways hash.
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | IsConnected | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Property | IsDelayedDrawing | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ObjectClassId | Gets or sets the object class id.
Protected Property | ObjectCodeBase | Gets or sets the object code base.
Protected Property | ObjectPluginsPageType | Gets or sets the type of the object plugins page.
Protected Property | ObjectType | Gets or sets the type of the object.
Protected Property | Params | Gets the parameters hash.
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | Session | Gets the application object. (Inherited from Gizmox.WebGUI.Forms.Component)
Top

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Focus | Sets focus to this control (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | GetGatewayHandler |
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | GetPreferredSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | ResetText | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SendToBack | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Show | Displays the control to the user. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ToString | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Update | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | Finalize | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCommandText | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetImage | Gets the image. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetPreferredSizeCore | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetService | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | InvokeMethod | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | IsDirty | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBindingContextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnControlAdded | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnControlRemoved | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | OnEnabledChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnGotFocus | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLostFocus | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentVisibleChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnResize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnTextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnUnregisterComponents | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnValidated | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnValidating | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ProcessGatewayRequest | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RegisterSelf | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | Render | Overridden. Renders the current control.
Protected Method | RenderAttributes | Overridden. Renders the controls meta attributes
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderClientUpdateHandler | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderComponentEventAttributes | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetImage | Sets the image. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeText | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | UnRegisterBatch | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | UnRegisterSelf | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | UpdateParams | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Top

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Disposed | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Gizmox.WebGUI.Forms.Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Top

See Also

Reference

ObjectBox Class
Gizmox.WebGUI.Forms.Hosts Namespace


ObjectBox Constructor

[image]
Gizmox.WebGUI.Forms
ObjectBox Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > ObjectBox Class : ObjectBox Constructor

Creates a new ObjectBox instance.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ObjectBox()
C#
public ObjectBox()
Managed Extensions for C++
public: ObjectBox();
C++/CLI
public:
ObjectBox();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ObjectBox Class
ObjectBox Members


ObjectBox Class Methods

[image]
Gizmox.WebGUI.Forms
ObjectBox Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace : ObjectBox Class

For a list of all members of this type, see ObjectBox members.

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Focus | Sets focus to this control (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | GetGatewayHandler |
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | GetPreferredSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | ResetText | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SendToBack | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Show | Displays the control to the user. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ToString | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Update | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | Finalize | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCommandText | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetImage | Gets the image. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetPreferredSizeCore | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetService | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | InvokeMethod | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | IsDirty | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBindingContextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnControlAdded | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnControlRemoved | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | OnEnabledChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnGotFocus | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLostFocus | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentVisibleChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnResize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnTextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnUnregisterComponents | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnValidated | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnValidating | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ProcessGatewayRequest | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RegisterSelf | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | Render | Overridden. Renders the current control.
Protected Method | RenderAttributes | Overridden. Renders the controls meta attributes
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderClientUpdateHandler | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderComponentEventAttributes | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetImage | Sets the image. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeText | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | UnRegisterBatch | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | UnRegisterSelf | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | UpdateParams | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Top

See Also

Reference

ObjectBox Class
Gizmox.WebGUI.Forms.Hosts Namespace


GetGatewayHandler Method

[image]
Gizmox.WebGUI.Forms
GetGatewayHandler Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > ObjectBox Class : GetGatewayHandler Method

objContext
strAction

Syntax

Visual Basic (Declaration)
Public Overridable Function GetGatewayHandler( _
   ByVal objContext As IContext, _
   ByVal strAction As String _
) As IGatewayHandler
Visual Basic (Usage) Copy Code
Dim instance As ObjectBox
Dim objContext As IContext
Dim strAction As String
Dim value As IGatewayHandler

value = instance.GetGatewayHandler(objContext, strAction)
C#
public virtual IGatewayHandler GetGatewayHandler(
   IContext objContext,
   string strAction
)
Managed Extensions for C++
public: virtual IGatewayHandler* GetGatewayHandler(
   IContext* objContext,
   string* strAction
)
C++/CLI
public:
virtual IGatewayHandler^ GetGatewayHandler(
   IContext^ objContext,
   String^ strAction
)

Parameters

objContext
strAction

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ObjectBox Class
ObjectBox Members


Render Method

[image]
Gizmox.WebGUI.Forms
Render Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > ObjectBox Class : Render Method

objContext
Request context.
objWriter
lngRequestID
Renders the current control.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub Render( _
   ByVal objContext As IContext, _
   ByVal objWriter As IResponseWriter, _
   ByVal lngRequestID As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As ObjectBox
Dim objContext As IContext
Dim objWriter As IResponseWriter
Dim lngRequestID As Long

instance.Render(objContext, objWriter, lngRequestID)
C#
protected override void Render(
   IContext objContext,
   IResponseWriter objWriter,
   long lngRequestID
)
Managed Extensions for C++
protected: void Render(
   IContext* objContext,
   IResponseWriter* objWriter,
   long lngRequestID
) override
C++/CLI
protected:
void Render(
   IContext^ objContext,
   IResponseWriter^ objWriter,
   long long lngRequestID
) override

Parameters

objContext
Request context.
objWriter
lngRequestID

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ObjectBox Class
ObjectBox Members


RenderAttributes Method

[image]
Gizmox.WebGUI.Forms
RenderAttributes Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > ObjectBox Class : RenderAttributes Method

objContext
objWriter
Renders the controls meta attributes

Syntax

Visual Basic (Declaration)
Protected Overrides Sub RenderAttributes( _
   ByVal objContext As IContext, _
   ByVal objWriter As IAttributeWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As ObjectBox
Dim objContext As IContext
Dim objWriter As IAttributeWriter

instance.RenderAttributes(objContext, objWriter)
C#
protected override void RenderAttributes(
   IContext objContext,
   IAttributeWriter objWriter
)
Managed Extensions for C++
protected: void RenderAttributes(
   IContext* objContext,
   IAttributeWriter* objWriter
) override
C++/CLI
protected:
void RenderAttributes(
   IContext^ objContext,
   IAttributeWriter^ objWriter
) override

Parameters

objContext
objWriter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ObjectBox Class
ObjectBox Members


ObjectBox Class Properties

[image]
Gizmox.WebGUI.Forms
ObjectBox Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace : ObjectBox Class

For a list of all members of this type, see ObjectBox members.

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackColor | Gets or sets the background color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BindingContext | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Container | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Context | Gets the context. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Form | Gets the owner form. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Height | Gets/Sets the height position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | IsRegistered | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Left | Gets/Sets the left position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Location | Gets or sets the control location. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Right | Gets/Sets the right position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Site | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Top | Gets/Sets the top position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Visible | Gets or sets the control visability. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Width | Gets/Sets the width position (Inherited from Gizmox.WebGUI.Forms.Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultBorderColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultBorderStyle | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultForeColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMargin | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultPadding | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DesignMode | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | Events | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | Gateways | Gets the gateways hash.
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | IsConnected | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Property | IsDelayedDrawing | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ObjectClassId | Gets or sets the object class id.
Protected Property | ObjectCodeBase | Gets or sets the object code base.
Protected Property | ObjectPluginsPageType | Gets or sets the type of the object plugins page.
Protected Property | ObjectType | Gets or sets the type of the object.
Protected Property | Params | Gets the parameters hash.
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | Session | Gets the application object. (Inherited from Gizmox.WebGUI.Forms.Component)
Top

See Also

Reference

ObjectBox Class
Gizmox.WebGUI.Forms.Hosts Namespace


Gateways Property

[image]
Gizmox.WebGUI.Forms
Gateways Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > ObjectBox Class : Gateways Property

Gets the gateways hash.

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property Gateways As Hashtable
Visual Basic (Usage) Copy Code
Dim instance As ObjectBox
Dim value As Hashtable

value = instance.Gateways
C#
protected Hashtable Gateways {get;}
Managed Extensions for C++
protected: __property Hashtable* get_Gateways();
C++/CLI
protected:
property Hashtable^ Gateways {
   Hashtable^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ObjectBox Class
ObjectBox Members


ObjectClassId Property

[image]
Gizmox.WebGUI.Forms
ObjectClassId Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > ObjectBox Class : ObjectClassId Property

Gets or sets the object class id.

Syntax

Visual Basic (Declaration)
Protected Property ObjectClassId As String
Visual Basic (Usage) Copy Code
Dim instance As ObjectBox
Dim value As String

instance.ObjectClassId = value

value = instance.ObjectClassId
C#
protected string ObjectClassId {get; set;}
Managed Extensions for C++
protected: __property string* get_ObjectClassId();
protected: __property void set_ObjectClassId(
   string* value
);
C++/CLI
protected:
property String^ ObjectClassId {
   String^ get();
   void set (String^value);
}

Return Value

The object class id.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ObjectBox Class
ObjectBox Members


ObjectCodeBase Property

[image]
Gizmox.WebGUI.Forms
ObjectCodeBase Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > ObjectBox Class : ObjectCodeBase Property

Gets or sets the object code base.

Syntax

Visual Basic (Declaration)
Protected Property ObjectCodeBase As String
Visual Basic (Usage) Copy Code
Dim instance As ObjectBox
Dim value As String

instance.ObjectCodeBase = value

value = instance.ObjectCodeBase
C#
protected string ObjectCodeBase {get; set;}
Managed Extensions for C++
protected: __property string* get_ObjectCodeBase();
protected: __property void set_ObjectCodeBase(
   string* value
);
C++/CLI
protected:
property String^ ObjectCodeBase {
   String^ get();
   void set (String^value);
}

Return Value

The object code base.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ObjectBox Class
ObjectBox Members


ObjectPluginsPageType Property

[image]
Gizmox.WebGUI.Forms
ObjectPluginsPageType Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > ObjectBox Class : ObjectPluginsPageType Property

Gets or sets the type of the object plugins page.

Syntax

Visual Basic (Declaration)
Protected Property ObjectPluginsPageType As String
Visual Basic (Usage) Copy Code
Dim instance As ObjectBox
Dim value As String

instance.ObjectPluginsPageType = value

value = instance.ObjectPluginsPageType
C#
protected string ObjectPluginsPageType {get; set;}
Managed Extensions for C++
protected: __property string* get_ObjectPluginsPageType();
protected: __property void set_ObjectPluginsPageType(
   string* value
);
C++/CLI
protected:
property String^ ObjectPluginsPageType {
   String^ get();
   void set (String^value);
}

Return Value

The type of the object plugins page.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ObjectBox Class
ObjectBox Members


ObjectType Property

[image]
Gizmox.WebGUI.Forms
ObjectType Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > ObjectBox Class : ObjectType Property

Gets or sets the type of the object.

Syntax

Visual Basic (Declaration)
Protected Property ObjectType As String
Visual Basic (Usage) Copy Code
Dim instance As ObjectBox
Dim value As String

instance.ObjectType = value

value = instance.ObjectType
C#
protected string ObjectType {get; set;}
Managed Extensions for C++
protected: __property string* get_ObjectType();
protected: __property void set_ObjectType(
   string* value
);
C++/CLI
protected:
property String^ ObjectType {
   String^ get();
   void set (String^value);
}

Return Value

The type of the object.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ObjectBox Class
ObjectBox Members


Params Property

[image]
Gizmox.WebGUI.Forms
Params Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace > ObjectBox Class : Params Property

Gets the parameters hash.

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property Params As Hashtable
Visual Basic (Usage) Copy Code
Dim instance As ObjectBox
Dim value As Hashtable

value = instance.Params
C#
protected Hashtable Params {get;}
Managed Extensions for C++
protected: __property Hashtable* get_Params();
C++/CLI
protected:
property Hashtable^ Params {
   Hashtable^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ObjectBox Class
ObjectBox Members


FormBox.ApplicationUITypes Enumeration

[image]
Gizmox.WebGUI.Forms
FormBox.ApplicationUITypes Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace : FormBox.ApplicationUITypes Enumeration

Syntax

Visual Basic (Declaration)
Public Enum FormBox.ApplicationUITypes
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As FormBox.ApplicationUITypes
C#
public enum FormBox.ApplicationUITypes : Enum
Managed Extensions for C++
__value public enum FormBox.ApplicationUITypes : public Enum
C++/CLI
public enum class FormBox.ApplicationUITypes : public Enum

Members

Member | Description
DHTML |
Silverlight |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.Hosts.FormBox.ApplicationUITypes

Requirements

Namespace: Gizmox.WebGUI.Forms.Hosts

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms.Hosts Namespace


AspControlEventHandler Delegate

[image]
Gizmox.WebGUI.Forms
AspControlEventHandler Delegate
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace : AspControlEventHandler Delegate

sender
e
Provides a delegate for the hosted ASP.NET events

Syntax

Visual Basic (Declaration)
Public Delegate Sub AspControlEventHandler( _
   ByVal sender As Object, _
   ByVal e As AspControlEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New AspControlEventHandler(AddressOf HandlerMethod)
C#
public delegate void AspControlEventHandler(
   object sender,
   AspControlEventArgs e
)
Managed Extensions for C++
public: __gc __delegate void AspControlEventHandler(
   Object* sender,
   AspControlEventArgs* e
)
C++/CLI
public delegate void AspControlEventHandler(
   Object^ sender,
   AspControlEventArgs^ e
)

Parameters

sender
e

Requirements

Namespace: Gizmox.WebGUI.Forms.Hosts

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms.Hosts Namespace


AspPageEventHandler Delegate

[image]
Gizmox.WebGUI.Forms
AspPageEventHandler Delegate
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace : AspPageEventHandler Delegate

sender
e
Provides a delegate for the hosted ASP.NET events

Syntax

Visual Basic (Declaration)
Public Delegate Sub AspPageEventHandler( _
   ByVal sender As Object, _
   ByVal e As AspPageEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New AspPageEventHandler(AddressOf HandlerMethod)
C#
public delegate void AspPageEventHandler(
   object sender,
   AspPageEventArgs e
)
Managed Extensions for C++
public: __gc __delegate void AspPageEventHandler(
   Object* sender,
   AspPageEventArgs* e
)
C++/CLI
public delegate void AspPageEventHandler(
   Object^ sender,
   AspPageEventArgs^ e
)

Parameters

sender
e

Requirements

Namespace: Gizmox.WebGUI.Forms.Hosts

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms.Hosts Namespace


Gizmox.WebGUI.Forms.Layout Namespace

Gizmox.WebGUI.Forms.Layout Namespace
See Also Inheritance Hierarchy Send Feedback

Classes

 | Class | Description
Class | ArrangedElementCollection | Represents a collection of objects.

Interfaces

 | Interface | Description
Interface | IArrangedElement |

Enumerations

 | Enumeration | Description
Enumeration | TextImageRelation |

See Also

Reference

Gizmox.WebGUI.Forms Assembly


ArrangedElementCollection Class

[image]
Gizmox.WebGUI.Forms
ArrangedElementCollection Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms.Layout Namespace : ArrangedElementCollection Class

Represents a collection of objects.

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class ArrangedElementCollection
Visual Basic (Usage) Copy Code
Dim instance As ArrangedElementCollection
C#
[DefaultMemberAttribute("Item")]
public class ArrangedElementCollection
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
public __gc class ArrangedElementCollection
C++/CLI
[DefaultMemberAttribute("Item")]
public ref class ArrangedElementCollection

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.Layout.ArrangedElementCollection
Gizmox.WebGUI.Forms.Control.ControlCollection

Requirements

Namespace: Gizmox.WebGUI.Forms.Layout

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

ArrangedElementCollection Members
Gizmox.WebGUI.Forms.Layout Namespace


ArrangedElementCollection Class Members

[image]
Gizmox.WebGUI.Forms
ArrangedElementCollection Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms.Layout Namespace : ArrangedElementCollection Class

The following tables list the members exposed by ArrangedElementCollection.

Public Properties

 | Name | Description
Public Property | Count | Gets the number of elements in the collection.
Public Property | IsReadOnly | Gets a value indicating whether the collection is read-only.
Top

Public Methods

 | Name | Description
Public Method | CopyTo | Copies the entire contents of this collection to a compatible one-dimensional Array, starting at the specified index of the target array.
Public Method | Equals | Overridden. Determines whether two ArrangedElementCollection instances are equal.
Public Method | GetEnumerator | Returns an enumerator for the entire collection.
Public Method | GetHashCode | Overridden. Returns the hash code for this instance.
Top

See Also

Reference

ArrangedElementCollection Class
Gizmox.WebGUI.Forms.Layout Namespace


ArrangedElementCollection Class Methods

[image]
Gizmox.WebGUI.Forms
ArrangedElementCollection Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms.Layout Namespace : ArrangedElementCollection Class

For a list of all members of this type, see ArrangedElementCollection members.

Public Methods

 | Name | Description
Public Method | CopyTo | Copies the entire contents of this collection to a compatible one-dimensional Array, starting at the specified index of the target array.
Public Method | Equals | Overridden. Determines whether two ArrangedElementCollection instances are equal.
Public Method | GetEnumerator | Returns an enumerator for the entire collection.
Public Method | GetHashCode | Overridden. Returns the hash code for this instance.
Top

See Also

Reference

ArrangedElementCollection Class
Gizmox.WebGUI.Forms.Layout Namespace


CopyTo Method

[image]
Gizmox.WebGUI.Forms
CopyTo Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Layout Namespace > ArrangedElementCollection Class : CopyTo Method

array
The one-dimensional Array that is the destination of the elements copied from the current collection. The array must have zero-based indexing.
index
The zero-based index in array at which copying begins.
Copies the entire contents of this collection to a compatible one-dimensional Array, starting at the specified index of the target array.

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array As Array, _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As ArrangedElementCollection
Dim array As Array
Dim index As Integer

instance.CopyTo(array, index)
C#
public void CopyTo(
   Array array,
   int index
)
Managed Extensions for C++
public: void CopyTo(
   Array* array,
   int index
)
C++/CLI
public:
void CopyTo(
   Array^ array,
   int index
)

Parameters

array
The one-dimensional Array that is the destination of the elements copied from the current collection. The array must have zero-based indexing.
index
The zero-based index in array at which copying begins.

Exceptions

Exception | Description
InvalidCastException | The type of the source element cannot be cast automatically to the type of array.
ArgumentOutOfRangeException | index is less than 0.
ArgumentException | One of the following conditions has occurred:array is multidimensional.index is equal to or greater than the length of array.The number of elements in the source collection is greater than the available space from index to the end of array.
ArgumentNullException | array is null.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ArrangedElementCollection Class
ArrangedElementCollection Members


Equals Method

[image]
Gizmox.WebGUI.Forms
Equals Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Layout Namespace > ArrangedElementCollection Class : Equals Method

obj
The ArrangedElementCollection to compare with the current ArrangedElementCollection.
Determines whether two ArrangedElementCollection instances are equal.

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ArrangedElementCollection
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
C#
public override bool Equals(
   object obj
)
Managed Extensions for C++
public: bool Equals(
   Object* obj
) override
C++/CLI
public:
bool Equals(
   Object^ obj
) override

Parameters

obj
The ArrangedElementCollection to compare with the current ArrangedElementCollection.

Return Value

true if the specified ArrangedElementCollection is equal to the current ArrangedElementCollection; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ArrangedElementCollection Class
ArrangedElementCollection Members


GetEnumerator Method

[image]
Gizmox.WebGUI.Forms
GetEnumerator Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Layout Namespace > ArrangedElementCollection Class : GetEnumerator Method

Returns an enumerator for the entire collection.

Syntax

Visual Basic (Declaration)
Public Overridable Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As ArrangedElementCollection
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public virtual IEnumerator GetEnumerator()
Managed Extensions for C++
public: virtual IEnumerator* GetEnumerator();
C++/CLI
public:
virtual IEnumerator^ GetEnumerator();

Return Value

An IEnumerator for the entire collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ArrangedElementCollection Class
ArrangedElementCollection Members


GetHashCode Method

[image]
Gizmox.WebGUI.Forms
GetHashCode Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Layout Namespace > ArrangedElementCollection Class : GetHashCode Method

Returns the hash code for this instance.

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As ArrangedElementCollection
Dim value As Integer

value = instance.GetHashCode()
C#
public override int GetHashCode()
Managed Extensions for C++
public: int GetHashCode(); override
C++/CLI
public:
int GetHashCode(); override

Return Value

A hash code for the current ArrangedElementCollection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ArrangedElementCollection Class
ArrangedElementCollection Members


ArrangedElementCollection Class Properties

[image]
Gizmox.WebGUI.Forms
ArrangedElementCollection Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms.Layout Namespace : ArrangedElementCollection Class

For a list of all members of this type, see ArrangedElementCollection members.

Public Properties

 | Name | Description
Public Property | Count | Gets the number of elements in the collection.
Public Property | IsReadOnly | Gets a value indicating whether the collection is read-only.
Top

See Also

Reference

ArrangedElementCollection Class
Gizmox.WebGUI.Forms.Layout Namespace


Count Property

[image]
Gizmox.WebGUI.Forms
Count Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Layout Namespace > ArrangedElementCollection Class : Count Property

Gets the number of elements in the collection.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As ArrangedElementCollection
Dim value As Integer

value = instance.Count
C#
public virtual int Count {get;}
Managed Extensions for C++
public: __property virtual int get_Count();
C++/CLI
public:
virtual property int Count {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ArrangedElementCollection Class
ArrangedElementCollection Members


IsReadOnly Property

[image]
Gizmox.WebGUI.Forms
IsReadOnly Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Layout Namespace > ArrangedElementCollection Class : IsReadOnly Property

Gets a value indicating whether the collection is read-only.

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property IsReadOnly As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ArrangedElementCollection
Dim value As Boolean

value = instance.IsReadOnly
C#
public virtual bool IsReadOnly {get;}
Managed Extensions for C++
public: __property virtual bool get_IsReadOnly();
C++/CLI
public:
virtual property bool IsReadOnly {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ArrangedElementCollection Class
ArrangedElementCollection Members


TextImageRelation Enumeration

[image]
Gizmox.WebGUI.Forms
TextImageRelation Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms.Layout Namespace : TextImageRelation Enumeration

Syntax

Visual Basic (Declaration)
Public Enum TextImageRelation
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As TextImageRelation
C#
public enum TextImageRelation : Enum
Managed Extensions for C++
__value public enum TextImageRelation : public Enum
C++/CLI
public enum class TextImageRelation : public Enum

Members

Member | Description
ImageAboveText |
ImageBeforeText |
Overlay |
TextAboveImage |
TextBeforeImage |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.Layout.TextImageRelation

Requirements

Namespace: Gizmox.WebGUI.Forms.Layout

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

Gizmox.WebGUI.Forms.Layout Namespace


IArrangedElement Interface

[image]
Gizmox.WebGUI.Forms
IArrangedElement Interface
Members See Also Send Feedback
Gizmox.WebGUI.Forms.Layout Namespace : IArrangedElement Interface

Syntax

Visual Basic (Declaration)
Public Interface IArrangedElement
Visual Basic (Usage) Copy Code
Dim instance As IArrangedElement
C#
public interface IArrangedElement
Managed Extensions for C++
public __gc __interface IArrangedElement
C++/CLI
public interface class IArrangedElement

Requirements

Namespace: Gizmox.WebGUI.Forms.Layout

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

IArrangedElement Members
Gizmox.WebGUI.Forms.Layout Namespace


IArrangedElement Interface Members

[image]
Gizmox.WebGUI.Forms
IArrangedElement Interface Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms.Layout Namespace : IArrangedElement Interface

The following tables list the members exposed by IArrangedElement.

Public Properties

 | Name | Description
Property | Children |
Property | ParticipatesInLayout |
Property | Properties |
Top

Public Methods

 | Name | Description
Method | GetPreferredSize |
Top

See Also

Reference

IArrangedElement Interface
Gizmox.WebGUI.Forms.Layout Namespace


IArrangedElement Interface Methods

[image]
Gizmox.WebGUI.Forms
IArrangedElement Interface Methods
See Also Send Feedback
Gizmox.WebGUI.Forms.Layout Namespace : IArrangedElement Interface

For a list of all members of this type, see IArrangedElement members.

Public Methods

 | Name | Description
Method | GetPreferredSize |
Top

See Also

Reference

IArrangedElement Interface
Gizmox.WebGUI.Forms.Layout Namespace


GetPreferredSize Method

[image]
Gizmox.WebGUI.Forms
GetPreferredSize Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Layout Namespace > IArrangedElement Interface : GetPreferredSize Method

proposedSize

Syntax

Visual Basic (Declaration)
Function GetPreferredSize( _
   ByVal proposedSize As Size _
) As Size
Visual Basic (Usage) Copy Code
Dim instance As IArrangedElement
Dim proposedSize As Size
Dim value As Size

value = instance.GetPreferredSize(proposedSize)
C#
Size GetPreferredSize(
   Size proposedSize
)
Managed Extensions for C++
Size GetPreferredSize(
   Size proposedSize
)
C++/CLI
Size GetPreferredSize(
   Size proposedSize
)

Parameters

proposedSize

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IArrangedElement Interface
IArrangedElement Members


IArrangedElement Interface Properties

[image]
Gizmox.WebGUI.Forms
IArrangedElement Interface Properties
See Also Send Feedback
Gizmox.WebGUI.Forms.Layout Namespace : IArrangedElement Interface

For a list of all members of this type, see IArrangedElement members.

Public Properties

 | Name | Description
Property | Children |
Property | ParticipatesInLayout |
Property | Properties |
Top

See Also

Reference

IArrangedElement Interface
Gizmox.WebGUI.Forms.Layout Namespace


Children Property

[image]
Gizmox.WebGUI.Forms
Children Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Layout Namespace > IArrangedElement Interface : Children Property

Syntax

Visual Basic (Declaration)
ReadOnly Property Children As ArrangedElementCollection
Visual Basic (Usage) Copy Code
Dim instance As IArrangedElement
Dim value As ArrangedElementCollection

value = instance.Children
C#
ArrangedElementCollection Children {get;}
Managed Extensions for C++
__property ArrangedElementCollection* get_Children();
C++/CLI
property ArrangedElementCollection^ Children {
   ArrangedElementCollection^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IArrangedElement Interface
IArrangedElement Members


ParticipatesInLayout Property

[image]
Gizmox.WebGUI.Forms
ParticipatesInLayout Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Layout Namespace > IArrangedElement Interface : ParticipatesInLayout Property

Syntax

Visual Basic (Declaration)
ReadOnly Property ParticipatesInLayout As Boolean
Visual Basic (Usage) Copy Code
Dim instance As IArrangedElement
Dim value As Boolean

value = instance.ParticipatesInLayout
C#
bool ParticipatesInLayout {get;}
Managed Extensions for C++
__property bool get_ParticipatesInLayout();
C++/CLI
property bool ParticipatesInLayout {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IArrangedElement Interface
IArrangedElement Members


Properties Property

[image]
Gizmox.WebGUI.Forms
Properties Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Layout Namespace > IArrangedElement Interface : Properties Property

Syntax

Visual Basic (Declaration)
ReadOnly Property Properties As PropertyStore
Visual Basic (Usage) Copy Code
Dim instance As IArrangedElement
Dim value As PropertyStore

value = instance.Properties
C#
PropertyStore Properties {get;}
Managed Extensions for C++
__property PropertyStore* get_Properties();
C++/CLI
property PropertyStore^ Properties {
   PropertyStore^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IArrangedElement Interface
IArrangedElement Members


Gizmox.WebGUI.Forms.PropertyGridInternal Namespace

Gizmox.WebGUI.Forms.PropertyGridInternal Namespace
See Also Inheritance Hierarchy Send Feedback

Classes

 | Class | Description
Class | PropertiesTab | Provides a base class for property tabs.

Interfaces

 | Interface | Description
Interface | IRootGridEntry | Defines methods and a property that allow filtering on specific attributes.

See Also

Reference

Gizmox.WebGUI.Forms Assembly


PropertiesTab Class

[image]
Gizmox.WebGUI.Forms
PropertiesTab Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms.PropertyGridInternal Namespace : PropertiesTab Class

Provides a base class for property tabs.

Syntax

Visual Basic (Declaration)
Public Class PropertiesTab
   Inherits PropertyTab
Visual Basic (Usage) Copy Code
Dim instance As PropertiesTab
C#
public class PropertiesTab : PropertyTab
Managed Extensions for C++
public __gc class PropertiesTab : public PropertyTab
C++/CLI
public ref class PropertiesTab : public PropertyTab

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.Design.PropertyTab
Gizmox.WebGUI.Forms.PropertyGridInternal.PropertiesTab

Requirements

Namespace: Gizmox.WebGUI.Forms.PropertyGridInternal

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

PropertiesTab Members
Gizmox.WebGUI.Forms.PropertyGridInternal Namespace


PropertiesTab Class Members

[image]
Gizmox.WebGUI.Forms
PropertiesTab Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms.PropertyGridInternal Namespace : PropertiesTab Class

The following tables list the members exposed by PropertiesTab.

Public Constructors

 | Name | Description
Public Constructor | PropertiesTab Constructor |
Top

Public Properties

 | Name | Description
Public Property | Bitmap | Gets the bitmap that is displayed for the PropertyTab. (Inherited from Gizmox.WebGUI.Forms.Design.PropertyTab)
Public Property | Components | Gets or sets the array of components the property tab is associated with. (Inherited from Gizmox.WebGUI.Forms.Design.PropertyTab)
Public Property | HelpKeyword | Overridden. Gets the Help keyword that is to be associated with this tab.
Public Property | TabName | Overridden. Gets the name of the Properties tab.
Top

Public Methods

 | Name | Description
Public Method | CanExtend | Gets a value indicating whether this PropertyTab can display properties for the specified component. (Inherited from Gizmox.WebGUI.Forms.Design.PropertyTab)
Public Method | Dispose | Overloaded. Releases all the resources used by the PropertyTab. (Inherited from Gizmox.WebGUI.Forms.Design.PropertyTab)
Public Method | GetDefaultProperty | Overridden.
Public Method | GetProperties | Overloaded. Overridden. Returns a collection of property descriors
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | Allows a PropertyTab to attempt to free resources and perform other cleanup operations before the PropertyTab is reclaimed by garbage collection. (Inherited from Gizmox.WebGUI.Forms.Design.PropertyTab)
Top

See Also

Reference

PropertiesTab Class
Gizmox.WebGUI.Forms.PropertyGridInternal Namespace


PropertiesTab Constructor

[image]
Gizmox.WebGUI.Forms
PropertiesTab Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms.PropertyGridInternal Namespace > PropertiesTab Class : PropertiesTab Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PropertiesTab()
C#
public PropertiesTab()
Managed Extensions for C++
public: PropertiesTab();
C++/CLI
public:
PropertiesTab();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertiesTab Class
PropertiesTab Members


PropertiesTab Class Methods

[image]
Gizmox.WebGUI.Forms
PropertiesTab Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms.PropertyGridInternal Namespace : PropertiesTab Class

For a list of all members of this type, see PropertiesTab members.

Public Methods

 | Name | Description
Public Method | CanExtend | Gets a value indicating whether this PropertyTab can display properties for the specified component. (Inherited from Gizmox.WebGUI.Forms.Design.PropertyTab)
Public Method | Dispose | Overloaded. Releases all the resources used by the PropertyTab. (Inherited from Gizmox.WebGUI.Forms.Design.PropertyTab)
Public Method | GetDefaultProperty | Overridden.
Public Method | GetProperties | Overloaded. Overridden. Returns a collection of property descriors
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | Allows a PropertyTab to attempt to free resources and perform other cleanup operations before the PropertyTab is reclaimed by garbage collection. (Inherited from Gizmox.WebGUI.Forms.Design.PropertyTab)
Top

See Also

Reference

PropertiesTab Class
Gizmox.WebGUI.Forms.PropertyGridInternal Namespace


GetDefaultProperty Method

[image]
Gizmox.WebGUI.Forms
GetDefaultProperty Method
See Also Send Feedback
Gizmox.WebGUI.Forms.PropertyGridInternal Namespace > PropertiesTab Class : GetDefaultProperty Method

objObject

Syntax

Visual Basic (Declaration)
Public Overrides Function GetDefaultProperty( _
   ByVal objObject As Object _
) As PropertyDescriptor
Visual Basic (Usage) Copy Code
Dim instance As PropertiesTab
Dim objObject As Object
Dim value As PropertyDescriptor

value = instance.GetDefaultProperty(objObject)
C#
public override PropertyDescriptor GetDefaultProperty(
   object objObject
)
Managed Extensions for C++
public: PropertyDescriptor* GetDefaultProperty(
   Object* objObject
) override
C++/CLI
public:
PropertyDescriptor^ GetDefaultProperty(
   Object^ objObject
) override

Parameters

objObject

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertiesTab Class
PropertiesTab Members


GetProperties Method

[image]
Gizmox.WebGUI.Forms
GetProperties Method
See Also Send Feedback
Gizmox.WebGUI.Forms.PropertyGridInternal Namespace > PropertiesTab Class : GetProperties Method

Returns a collection of property descriors

Overload List

Overload | Description
GetProperties(Object,Attribute[]) |
GetProperties(ITypeDescriptorContext,Object,Attribute[]) | Returns a collection of property descriors
GetProperties(Object) | Gets the properties of the specified component. (Inherited from Gizmox.WebGUI.Forms.Design.PropertyTab)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertiesTab Class
PropertiesTab Members


GetProperties(Object,Attribute[]) Method

[image]
Gizmox.WebGUI.Forms
GetProperties(Object,Attribute[]) Method
See Also Send Feedback
Gizmox.WebGUI.Forms.PropertyGridInternal Namespace > PropertiesTab Class > GetProperties Method : GetProperties(Object,Attribute[]) Method

objComponent
arrAttributes

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function GetProperties( _
   ByVal objComponent As Object, _
   ByVal arrAttributes() As Attribute _
) As PropertyDescriptorCollection
Visual Basic (Usage) Copy Code
Dim instance As PropertiesTab
Dim objComponent As Object
Dim arrAttributes() As Attribute
Dim value As PropertyDescriptorCollection

value = instance.GetProperties(objComponent, arrAttributes)
C#
public override PropertyDescriptorCollection GetProperties(
   object objComponent,
   Attribute[] arrAttributes
)
Managed Extensions for C++
public: PropertyDescriptorCollection* GetProperties(
   Object* objComponent,
   Attribute*[]* arrAttributes
) override
C++/CLI
public:
PropertyDescriptorCollection^ GetProperties(
   Object^ objComponent,
   array<Attribute^>^ arrAttributes
) override

Parameters

objComponent
arrAttributes

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertiesTab Class
PropertiesTab Members
Overload List


GetProperties(ITypeDescriptorContext,Object,Attribute[]) Method

[image]
Gizmox.WebGUI.Forms
GetProperties(ITypeDescriptorContext,Object,Attribute[]) Method
See Also Send Feedback
Gizmox.WebGUI.Forms.PropertyGridInternal Namespace > PropertiesTab Class > GetProperties Method : GetProperties(ITypeDescriptorContext,Object,Attribute[]) Method

objContext
objComponent
arrAttributes
Returns a collection of property descriors

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function GetProperties( _
   ByVal objContext As ITypeDescriptorContext, _
   ByVal objComponent As Object, _
   ByVal arrAttributes() As Attribute _
) As PropertyDescriptorCollection
Visual Basic (Usage) Copy Code
Dim instance As PropertiesTab
Dim objContext As ITypeDescriptorContext
Dim objComponent As Object
Dim arrAttributes() As Attribute
Dim value As PropertyDescriptorCollection

value = instance.GetProperties(objContext, objComponent, arrAttributes)
C#
public override PropertyDescriptorCollection GetProperties(
   ITypeDescriptorContext objContext,
   object objComponent,
   Attribute[] arrAttributes
)
Managed Extensions for C++
public: PropertyDescriptorCollection* GetProperties(
   ITypeDescriptorContext* objContext,
   Object* objComponent,
   Attribute*[]* arrAttributes
) override
C++/CLI
public:
PropertyDescriptorCollection^ GetProperties(
   ITypeDescriptorContext^ objContext,
   Object^ objComponent,
   array<Attribute^>^ arrAttributes
) override

Parameters

objContext
objComponent
arrAttributes

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertiesTab Class
PropertiesTab Members
Overload List


PropertiesTab Class Properties

[image]
Gizmox.WebGUI.Forms
PropertiesTab Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms.PropertyGridInternal Namespace : PropertiesTab Class

For a list of all members of this type, see PropertiesTab members.

Public Properties

 | Name | Description
Public Property | Bitmap | Gets the bitmap that is displayed for the PropertyTab. (Inherited from Gizmox.WebGUI.Forms.Design.PropertyTab)
Public Property | Components | Gets or sets the array of components the property tab is associated with. (Inherited from Gizmox.WebGUI.Forms.Design.PropertyTab)
Public Property | HelpKeyword | Overridden. Gets the Help keyword that is to be associated with this tab.
Public Property | TabName | Overridden. Gets the name of the Properties tab.
Top

See Also

Reference

PropertiesTab Class
Gizmox.WebGUI.Forms.PropertyGridInternal Namespace


HelpKeyword Property

[image]
Gizmox.WebGUI.Forms
HelpKeyword Property
See Also Send Feedback
Gizmox.WebGUI.Forms.PropertyGridInternal Namespace > PropertiesTab Class : HelpKeyword Property

Gets the Help keyword that is to be associated with this tab.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property HelpKeyword As String
Visual Basic (Usage) Copy Code
Dim instance As PropertiesTab
Dim value As String

value = instance.HelpKeyword
C#
public override string HelpKeyword {get;}
Managed Extensions for C++
public: __property string* get_HelpKeyword() override;
C++/CLI
public:
property String^ HelpKeyword {
   String^ get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertiesTab Class
PropertiesTab Members


TabName Property

[image]
Gizmox.WebGUI.Forms
TabName Property
See Also Send Feedback
Gizmox.WebGUI.Forms.PropertyGridInternal Namespace > PropertiesTab Class : TabName Property

Gets the name of the Properties tab.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property TabName As String
Visual Basic (Usage) Copy Code
Dim instance As PropertiesTab
Dim value As String

value = instance.TabName
C#
public override string TabName {get;}
Managed Extensions for C++
public: __property string* get_TabName() override;
C++/CLI
public:
property String^ TabName {
   String^ get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PropertiesTab Class
PropertiesTab Members


IRootGridEntry Interface

[image]
Gizmox.WebGUI.Forms
IRootGridEntry Interface
Members See Also Send Feedback
Gizmox.WebGUI.Forms.PropertyGridInternal Namespace : IRootGridEntry Interface

Defines methods and a property that allow filtering on specific attributes.

Syntax

Visual Basic (Declaration)
Public Interface IRootGridEntry
Visual Basic (Usage) Copy Code
Dim instance As IRootGridEntry
C#
public interface IRootGridEntry
Managed Extensions for C++
public __gc __interface IRootGridEntry
C++/CLI
public interface class IRootGridEntry

Requirements

Namespace: Gizmox.WebGUI.Forms.PropertyGridInternal

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms (in Gizmox.WebGUI.Forms.dll)

See Also

Reference

IRootGridEntry Members
Gizmox.WebGUI.Forms.PropertyGridInternal Namespace


IRootGridEntry Interface Members

[image]
Gizmox.WebGUI.Forms
IRootGridEntry Interface Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms.PropertyGridInternal Namespace : IRootGridEntry Interface

The following tables list the members exposed by IRootGridEntry.

Public Properties

 | Name | Description
Property | BrowsableAttributes | Gets or sets the attributes on which the property browser filters.
Top

Public Methods

 | Name | Description
Method | ResetBrowsableAttributes | Resets the BrowsableAttributes property to the default value.
Method | ShowCategories | Sorts the properties in the property browser.
Top

See Also

Reference

IRootGridEntry Interface
Gizmox.WebGUI.Forms.PropertyGridInternal Namespace


IRootGridEntry Interface Methods

[image]
Gizmox.WebGUI.Forms
IRootGridEntry Interface Methods
See Also Send Feedback
Gizmox.WebGUI.Forms.PropertyGridInternal Namespace : IRootGridEntry Interface

For a list of all members of this type, see IRootGridEntry members.

Public Methods

 | Name | Description
Method | ResetBrowsableAttributes | Resets the BrowsableAttributes property to the default value.
Method | ShowCategories | Sorts the properties in the property browser.
Top

See Also

Reference

IRootGridEntry Interface
Gizmox.WebGUI.Forms.PropertyGridInternal Namespace


ResetBrowsableAttributes Method

[image]
Gizmox.WebGUI.Forms
ResetBrowsableAttributes Method
See Also Send Feedback
Gizmox.WebGUI.Forms.PropertyGridInternal Namespace > IRootGridEntry Interface : ResetBrowsableAttributes Method

Resets the BrowsableAttributes property to the default value.

Syntax

Visual Basic (Declaration)
Sub ResetBrowsableAttributes()
Visual Basic (Usage) Copy Code
Dim instance As IRootGridEntry

instance.ResetBrowsableAttributes()
C#
void ResetBrowsableAttributes()
Managed Extensions for C++
void ResetBrowsableAttributes();
C++/CLI
void ResetBrowsableAttributes();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IRootGridEntry Interface
IRootGridEntry Members


ShowCategories Method

[image]
Gizmox.WebGUI.Forms
ShowCategories Method
See Also Send Feedback
Gizmox.WebGUI.Forms.PropertyGridInternal Namespace > IRootGridEntry Interface : ShowCategories Method

showCategories
true to group the properties by category; otherwise, false.
Sorts the properties in the property browser.

Syntax

Visual Basic (Declaration)
Sub ShowCategories( _
   ByVal showCategories As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As IRootGridEntry
Dim showCategories As Boolean

instance.ShowCategories(showCategories)
C#
void ShowCategories(
   bool showCategories
)
Managed Extensions for C++
void ShowCategories(
   bool showCategories
)
C++/CLI
void ShowCategories(
   bool showCategories
)

Parameters

showCategories
true to group the properties by category; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IRootGridEntry Interface
IRootGridEntry Members


IRootGridEntry Interface Properties

[image]
Gizmox.WebGUI.Forms
IRootGridEntry Interface Properties
See Also Send Feedback
Gizmox.WebGUI.Forms.PropertyGridInternal Namespace : IRootGridEntry Interface

For a list of all members of this type, see IRootGridEntry members.

Public Properties

 | Name | Description
Property | BrowsableAttributes | Gets or sets the attributes on which the property browser filters.
Top

See Also

Reference

IRootGridEntry Interface
Gizmox.WebGUI.Forms.PropertyGridInternal Namespace


BrowsableAttributes Property

[image]
Gizmox.WebGUI.Forms
BrowsableAttributes Property
See Also Send Feedback
Gizmox.WebGUI.Forms.PropertyGridInternal Namespace > IRootGridEntry Interface : BrowsableAttributes Property

Gets or sets the attributes on which the property browser filters.

Syntax

Visual Basic (Declaration)
Property BrowsableAttributes As AttributeCollection
Visual Basic (Usage) Copy Code
Dim instance As IRootGridEntry
Dim value As AttributeCollection

instance.BrowsableAttributes = value

value = instance.BrowsableAttributes
C#
AttributeCollection BrowsableAttributes {get; set;}
Managed Extensions for C++
__property AttributeCollection* get_BrowsableAttributes();
__property void set_BrowsableAttributes(
   AttributeCollection* value
);
C++/CLI
property AttributeCollection^ BrowsableAttributes {
   AttributeCollection^ get();
   void set (AttributeCollection^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IRootGridEntry Interface
IRootGridEntry Members


Assembly Overview

Gizmox.WebGUI.Common
Gizmox.WebGUI.Common Assembly
See Also Send Feedback

Namespaces

Namespace | Description
Gizmox.WebGUI |
Gizmox.WebGUI.Client.Design |
Gizmox.WebGUI.Common |
Gizmox.WebGUI.Common.Configuration |
Gizmox.WebGUI.Common.Exceptions |
Gizmox.WebGUI.Common.Extensibility |
Gizmox.WebGUI.Common.Gateways |
Gizmox.WebGUI.Common.Interfaces |
Gizmox.WebGUI.Common.Resources |
Gizmox.WebGUI.Common.Switches |
Gizmox.WebGUI.Common.Trace |
Gizmox.WebGUI.Forms |
Gizmox.WebGUI.Forms.Design |
Gizmox.WebGUI.Forms.Interopability |


Gizmox.WebGUI Namespace

Gizmox.WebGUI.Common
Gizmox.WebGUI Namespace
See Also Inheritance Hierarchy Send Feedback

Classes

 | Class | Description
Class | CommonSwitches |
Class | CommonUtils |
Class | WGAttributes |
Class | WGConst |
Class | WGLabels |
Class | WGTags |

See Also

Reference

Gizmox.WebGUI.Common Assembly


CommonSwitches Class

[image]
Gizmox.WebGUI.Common
CommonSwitches Class
Members See Also Send Feedback
Gizmox.WebGUI Namespace : CommonSwitches Class

Object Model

Syntax

Visual Basic (Declaration)
Public Class CommonSwitches
Visual Basic (Usage) Copy Code
Dim instance As CommonSwitches
C#
public class CommonSwitches
Managed Extensions for C++
public __gc class CommonSwitches
C++/CLI
public ref class CommonSwitches

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.CommonSwitches

Requirements

Namespace: Gizmox.WebGUI

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

CommonSwitches Members
Gizmox.WebGUI Namespace


CommonSwitches Class Members

[image]
Gizmox.WebGUI.Common
CommonSwitches Class Members
See Also Properties Send Feedback
Gizmox.WebGUI Namespace : CommonSwitches Class

The following tables list the members exposed by CommonSwitches.

Public Constructors

 | Name | Description
Public Constructor | CommonSwitches Constructor |
Top

Public Properties

 | Name | Description
static (Shared in Visual Basic) | TraceEnabled |
static (Shared in Visual Basic) | TraceInfo |
static (Shared in Visual Basic) | TraceThreshold |
static (Shared in Visual Basic) | TraceVerbose |
static (Shared in Visual Basic) | Tracing |
Top

See Also

Reference

CommonSwitches Class
Gizmox.WebGUI Namespace


CommonSwitches Constructor

[image]
Gizmox.WebGUI.Common
CommonSwitches Constructor
See Also Send Feedback
Gizmox.WebGUI Namespace > CommonSwitches Class : CommonSwitches Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As CommonSwitches()
C#
public CommonSwitches()
Managed Extensions for C++
public: CommonSwitches();
C++/CLI
public:
CommonSwitches();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CommonSwitches Class
CommonSwitches Members


CommonSwitches Class Properties

[image]
Gizmox.WebGUI.Common
CommonSwitches Class Properties
See Also Send Feedback
Gizmox.WebGUI Namespace : CommonSwitches Class

For a list of all members of this type, see CommonSwitches members.

Public Properties

 | Name | Description
static (Shared in Visual Basic) | TraceEnabled |
static (Shared in Visual Basic) | TraceInfo |
static (Shared in Visual Basic) | TraceThreshold |
static (Shared in Visual Basic) | TraceVerbose |
static (Shared in Visual Basic) | Tracing |
Top

See Also

Reference

CommonSwitches Class
Gizmox.WebGUI Namespace


TraceEnabled Property

[image]
Gizmox.WebGUI.Common
TraceEnabled Property
See Also Send Feedback
Gizmox.WebGUI Namespace > CommonSwitches Class : TraceEnabled Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property TraceEnabled As Boolean
Visual Basic (Usage) Copy Code
Dim value As Boolean

value = CommonSwitches.TraceEnabled
C#
public static bool TraceEnabled {get;}
Managed Extensions for C++
public: __property static bool get_TraceEnabled();
C++/CLI
public:
static property bool TraceEnabled {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CommonSwitches Class
CommonSwitches Members


TraceInfo Property

[image]
Gizmox.WebGUI.Common
TraceInfo Property
See Also Send Feedback
Gizmox.WebGUI Namespace > CommonSwitches Class : TraceInfo Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property TraceInfo As Boolean
Visual Basic (Usage) Copy Code
Dim value As Boolean

value = CommonSwitches.TraceInfo
C#
public static bool TraceInfo {get;}
Managed Extensions for C++
public: __property static bool get_TraceInfo();
C++/CLI
public:
static property bool TraceInfo {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CommonSwitches Class
CommonSwitches Members


TraceThreshold Property

[image]
Gizmox.WebGUI.Common
TraceThreshold Property
See Also Send Feedback
Gizmox.WebGUI Namespace > CommonSwitches Class : TraceThreshold Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property TraceThreshold As Integer
Visual Basic (Usage) Copy Code
Dim value As Integer

value = CommonSwitches.TraceThreshold
C#
public static int TraceThreshold {get;}
Managed Extensions for C++
public: __property static int get_TraceThreshold();
C++/CLI
public:
static property int TraceThreshold {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CommonSwitches Class
CommonSwitches Members


TraceVerbose Property

[image]
Gizmox.WebGUI.Common
TraceVerbose Property
See Also Send Feedback
Gizmox.WebGUI Namespace > CommonSwitches Class : TraceVerbose Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property TraceVerbose As Boolean
Visual Basic (Usage) Copy Code
Dim value As Boolean

value = CommonSwitches.TraceVerbose
C#
public static bool TraceVerbose {get;}
Managed Extensions for C++
public: __property static bool get_TraceVerbose();
C++/CLI
public:
static property bool TraceVerbose {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CommonSwitches Class
CommonSwitches Members


Tracing Property

[image]
Gizmox.WebGUI.Common
Tracing Property
See Also Send Feedback
Gizmox.WebGUI Namespace > CommonSwitches Class : Tracing Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Tracing As WGTracingSwitch
Visual Basic (Usage) Copy Code
Dim value As WGTracingSwitch

value = CommonSwitches.Tracing
C#
public static WGTracingSwitch Tracing {get;}
Managed Extensions for C++
public: __property static WGTracingSwitch* get_Tracing();
C++/CLI
public:
static property WGTracingSwitch^ Tracing {
   WGTracingSwitch^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CommonSwitches Class
CommonSwitches Members


CommonUtils Class

[image]
Gizmox.WebGUI.Common
CommonUtils Class
Members See Also Send Feedback
Gizmox.WebGUI Namespace : CommonUtils Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class CommonUtils
Visual Basic (Usage) Copy Code
Dim instance As CommonUtils
C#
public sealed class CommonUtils
Managed Extensions for C++
public __gc __sealed class CommonUtils
C++/CLI
public ref class CommonUtils sealed

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.CommonUtils

Requirements

Namespace: Gizmox.WebGUI

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

CommonUtils Members
Gizmox.WebGUI Namespace


CommonUtils Class Members

[image]
Gizmox.WebGUI.Common
CommonUtils Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI Namespace : CommonUtils Class

The following tables list the members exposed by CommonUtils.

Public Constructors

 | Name | Description
Public Constructor | CommonUtils Constructor |
Top

Public Properties

 | Name | Description
static (Shared in Visual Basic) | IsMono |
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetCombinedHashCodes |
static (Shared in Visual Basic) | GetWebColor |
static (Shared in Visual Basic) | IsNullOrEmpty |
static (Shared in Visual Basic) | TryParse | Overloaded.
Top

See Also

Reference

CommonUtils Class
Gizmox.WebGUI Namespace


CommonUtils Constructor

[image]
Gizmox.WebGUI.Common
CommonUtils Constructor
See Also Send Feedback
Gizmox.WebGUI Namespace > CommonUtils Class : CommonUtils Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As CommonUtils()
C#
public CommonUtils()
Managed Extensions for C++
public: CommonUtils();
C++/CLI
public:
CommonUtils();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CommonUtils Class
CommonUtils Members


CommonUtils Class Methods

[image]
Gizmox.WebGUI.Common
CommonUtils Class Methods
See Also Send Feedback
Gizmox.WebGUI Namespace : CommonUtils Class

For a list of all members of this type, see CommonUtils members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetCombinedHashCodes |
static (Shared in Visual Basic) | GetWebColor |
static (Shared in Visual Basic) | IsNullOrEmpty |
static (Shared in Visual Basic) | TryParse | Overloaded.
Top

See Also

Reference

CommonUtils Class
Gizmox.WebGUI Namespace


GetCombinedHashCodes Method

[image]
Gizmox.WebGUI.Common
GetCombinedHashCodes Method
See Also Send Feedback
Gizmox.WebGUI Namespace > CommonUtils Class : GetCombinedHashCodes Method

args

Syntax

Visual Basic (Declaration)
Public Shared Function GetCombinedHashCodes( _
   ByVal ParamArray args() As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim args() As Integer
Dim value As Integer

value = CommonUtils.GetCombinedHashCodes(args)
C#
public static int GetCombinedHashCodes(
   params int[] args
)
Managed Extensions for C++
public: static int GetCombinedHashCodes(
   params int[]* args
)
C++/CLI
public:
static int GetCombinedHashCodes(
   ... array<int>^ args
)

Parameters

args

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CommonUtils Class
CommonUtils Members


GetWebColor Method

[image]
Gizmox.WebGUI.Common
GetWebColor Method
See Also Send Feedback
Gizmox.WebGUI Namespace > CommonUtils Class : GetWebColor Method

color

Syntax

Visual Basic (Declaration)
Public Shared Function GetWebColor( _
   ByVal color As Color _
) As String
Visual Basic (Usage) Copy Code
Dim color As Color
Dim value As String

value = CommonUtils.GetWebColor(color)
C#
public static string GetWebColor(
   Color color
)
Managed Extensions for C++
public: static string* GetWebColor(
   Color color
)
C++/CLI
public:
static String^ GetWebColor(
   Color color
)

Parameters

color

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CommonUtils Class
CommonUtils Members


IsNullOrEmpty Method

[image]
Gizmox.WebGUI.Common
IsNullOrEmpty Method
See Also Send Feedback
Gizmox.WebGUI Namespace > CommonUtils Class : IsNullOrEmpty Method

strInputs

Syntax

Visual Basic (Declaration)
Public Shared Function IsNullOrEmpty( _
   ByVal ParamArray strInputs() As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim strInputs() As String
Dim value As Boolean

value = CommonUtils.IsNullOrEmpty(strInputs)
C#
public static bool IsNullOrEmpty(
   params string[] strInputs
)
Managed Extensions for C++
public: static bool IsNullOrEmpty(
   params string*[]* strInputs
)
C++/CLI
public:
static bool IsNullOrEmpty(
   ... array<String^>^ strInputs
)

Parameters

strInputs

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CommonUtils Class
CommonUtils Members


TryParse Method

[image]
Gizmox.WebGUI.Common
TryParse Method
See Also Send Feedback
Gizmox.WebGUI Namespace > CommonUtils Class : TryParse Method

Overload List

Overload | Description
TryParse(String,Single) |
TryParse(String,Double) |
TryParse(String,Int32) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CommonUtils Class
CommonUtils Members


TryParse(String,Single) Method

[image]
Gizmox.WebGUI.Common
TryParse(String,Single) Method
See Also Send Feedback
Gizmox.WebGUI Namespace > CommonUtils Class > TryParse Method : TryParse(String,Single) Method

strValue
fltValue

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function TryParse( _
   ByVal strValue As String, _
   ByRef fltValue As Single _
) As Boolean
Visual Basic (Usage) Copy Code
Dim strValue As String
Dim fltValue As Single
Dim value As Boolean

value = CommonUtils.TryParse(strValue, fltValue)
C#
public static bool TryParse(
   string strValue,
   out float fltValue
)
Managed Extensions for C++
public: static bool TryParse(
   string* strValue,
   [PARAMFLAG::Out] float fltValue
)
C++/CLI
public:
static bool TryParse(
   String^ strValue,
   [Out] float fltValue
)

Parameters

strValue
fltValue

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CommonUtils Class
CommonUtils Members
Overload List


TryParse(String,Double) Method

[image]
Gizmox.WebGUI.Common
TryParse(String,Double) Method
See Also Send Feedback
Gizmox.WebGUI Namespace > CommonUtils Class > TryParse Method : TryParse(String,Double) Method

strValue
dblValue

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function TryParse( _
   ByVal strValue As String, _
   ByRef dblValue As Double _
) As Boolean
Visual Basic (Usage) Copy Code
Dim strValue As String
Dim dblValue As Double
Dim value As Boolean

value = CommonUtils.TryParse(strValue, dblValue)
C#
public static bool TryParse(
   string strValue,
   out double dblValue
)
Managed Extensions for C++
public: static bool TryParse(
   string* strValue,
   [PARAMFLAG::Out] double dblValue
)
C++/CLI
public:
static bool TryParse(
   String^ strValue,
   [Out] double dblValue
)

Parameters

strValue
dblValue

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CommonUtils Class
CommonUtils Members
Overload List


TryParse(String,Int32) Method

[image]
Gizmox.WebGUI.Common
TryParse(String,Int32) Method
See Also Send Feedback
Gizmox.WebGUI Namespace > CommonUtils Class > TryParse Method : TryParse(String,Int32) Method

strValue
intValue

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function TryParse( _
   ByVal strValue As String, _
   ByRef intValue As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim strValue As String
Dim intValue As Integer
Dim value As Boolean

value = CommonUtils.TryParse(strValue, intValue)
C#
public static bool TryParse(
   string strValue,
   out int intValue
)
Managed Extensions for C++
public: static bool TryParse(
   string* strValue,
   [PARAMFLAG::Out] int intValue
)
C++/CLI
public:
static bool TryParse(
   String^ strValue,
   [Out] int intValue
)

Parameters

strValue
intValue

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CommonUtils Class
CommonUtils Members
Overload List


CommonUtils Class Properties

[image]
Gizmox.WebGUI.Common
CommonUtils Class Properties
See Also Send Feedback
Gizmox.WebGUI Namespace : CommonUtils Class

For a list of all members of this type, see CommonUtils members.

Public Properties

 | Name | Description
static (Shared in Visual Basic) | IsMono |
Top

See Also

Reference

CommonUtils Class
Gizmox.WebGUI Namespace


IsMono Property

[image]
Gizmox.WebGUI.Common
IsMono Property
See Also Send Feedback
Gizmox.WebGUI Namespace > CommonUtils Class : IsMono Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property IsMono As Boolean
Visual Basic (Usage) Copy Code
Dim value As Boolean

value = CommonUtils.IsMono
C#
public static bool IsMono {get;}
Managed Extensions for C++
public: __property static bool get_IsMono();
C++/CLI
public:
static property bool IsMono {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CommonUtils Class
CommonUtils Members


WGAttributes Class

[image]
Gizmox.WebGUI.Common
WGAttributes Class
Members See Also Send Feedback
Gizmox.WebGUI Namespace : WGAttributes Class

Syntax

Visual Basic (Declaration)
Public Class WGAttributes
Visual Basic (Usage) Copy Code
Dim instance As WGAttributes
C#
public class WGAttributes
Managed Extensions for C++
public __gc class WGAttributes
C++/CLI
public ref class WGAttributes

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.WGAttributes

Requirements

Namespace: Gizmox.WebGUI

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

WGAttributes Members
Gizmox.WebGUI Namespace


WGAttributes Class Members

[image]
Gizmox.WebGUI.Common
WGAttributes Class Members
See Also Fields Send Feedback
Gizmox.WebGUI Namespace : WGAttributes Class

The following tables list the members exposed by WGAttributes.

Public Constructors

 | Name | Description
Public Constructor | WGAttributes Constructor |
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | AcceptButton |
static (Shared in Visual Basic) | Active |
static (Shared in Visual Basic) | ActiveForm |
static (Shared in Visual Basic) | ActiveLinkColor |
static (Shared in Visual Basic) | Advanced |
static (Shared in Visual Basic) | AlignTo |
static (Shared in Visual Basic) | AlignType |
static (Shared in Visual Basic) | AllowDrop |
static (Shared in Visual Basic) | AllowUserToOrderColumns |
static (Shared in Visual Basic) | AltKey |
static (Shared in Visual Basic) | Anchoring |
static (Shared in Visual Basic) | Archive |
static (Shared in Visual Basic) | Argument |
static (Shared in Visual Basic) | Assembly |
static (Shared in Visual Basic) | AutoCheck |
static (Shared in Visual Basic) | AutoCompleteMode |
static (Shared in Visual Basic) | AutoSize |
static (Shared in Visual Basic) | Background |
static (Shared in Visual Basic) | BackgroundImage |
static (Shared in Visual Basic) | BackgroundImageLayout |
static (Shared in Visual Basic) | BeforeUnloadMessage |
static (Shared in Visual Basic) | Border |
static (Shared in Visual Basic) | BorderStyle |
static (Shared in Visual Basic) | Bottom |
static (Shared in Visual Basic) | ButtonHeight |
static (Shared in Visual Basic) | ButtonWidth |
static (Shared in Visual Basic) | CancelButton |
static (Shared in Visual Basic) | CellBorderStyle |
static (Shared in Visual Basic) | CharacterCasing |
static (Shared in Visual Basic) | CharacterValidationExpression |
static (Shared in Visual Basic) | CharacterValidationMask |
static (Shared in Visual Basic) | CheckBoxes |
static (Shared in Visual Basic) | Checked |
static (Shared in Visual Basic) | ClickOnce |
static (Shared in Visual Basic) | ClientUniqeId |
static (Shared in Visual Basic) | Code |
static (Shared in Visual Basic) | CodeBase |
static (Shared in Visual Basic) | Collapsable |
static (Shared in Visual Basic) | Color |
static (Shared in Visual Basic) | Cols |
static (Shared in Visual Basic) | Colspan |
static (Shared in Visual Basic) | ColumnHeaders |
static (Shared in Visual Basic) | ContentAlign |
static (Shared in Visual Basic) | ControlKey |
static (Shared in Visual Basic) | CurrentCell |
static (Shared in Visual Basic) | CurrentPage |
static (Shared in Visual Basic) | Cursor |
static (Shared in Visual Basic) | CursorPosition |
static (Shared in Visual Basic) | CustomStyle |
static (Shared in Visual Basic) | CustomTemplate |
static (Shared in Visual Basic) | DateTime |
static (Shared in Visual Basic) | DecimalPlaces |
static (Shared in Visual Basic) | Depth |
static (Shared in Visual Basic) | DisableNavigation |
static (Shared in Visual Basic) | Docking |
static (Shared in Visual Basic) | Done |
static (Shared in Visual Basic) | DraggedColumn |
static (Shared in Visual Basic) | DragSource |
static (Shared in Visual Basic) | DragSourceMember |
static (Shared in Visual Basic) | DragTargets |
static (Shared in Visual Basic) | DropDown |
static (Shared in Visual Basic) | DropDownWidth |
static (Shared in Visual Basic) | DropTargetMember |
static (Shared in Visual Basic) | Enabled |
static (Shared in Visual Basic) | EnablesDrop |
static (Shared in Visual Basic) | ErrorIcon |
static (Shared in Visual Basic) | ErrorIconAlignment |
static (Shared in Visual Basic) | ErrorIconPadding |
static (Shared in Visual Basic) | ErrorMessage |
static (Shared in Visual Basic) | Events |
static (Shared in Visual Basic) | Expanded |
static (Shared in Visual Basic) | ExpandedImage |
static (Shared in Visual Basic) | FirstDayOfWeek |
static (Shared in Visual Basic) | FlowDirection |
static (Shared in Visual Basic) | Focus |
static (Shared in Visual Basic) | Focused |
static (Shared in Visual Basic) | Font |
static (Shared in Visual Basic) | Fore |
static (Shared in Visual Basic) | Format |
static (Shared in Visual Basic) | FormBorderStyle |
static (Shared in Visual Basic) | FormSize |
static (Shared in Visual Basic) | FormStartPosition |
static (Shared in Visual Basic) | Frequency |
static (Shared in Visual Basic) | Frozen |
static (Shared in Visual Basic) | FullRowSelect |
static (Shared in Visual Basic) | GridLines |
static (Shared in Visual Basic) | GrowStyle |
static (Shared in Visual Basic) | HasChecked |
static (Shared in Visual Basic) | HasNodes |
static (Shared in Visual Basic) | HasRedrawingParent |
static (Shared in Visual Basic) | HasSelected |
static (Shared in Visual Basic) | HeaderStyle |
static (Shared in Visual Basic) | Height |
static (Shared in Visual Basic) | HelpVisible |
static (Shared in Visual Basic) | Hexadecimal |
static (Shared in Visual Basic) | HideButtons |
static (Shared in Visual Basic) | HidePlusMinus |
static (Shared in Visual Basic) | HidePromptOnLeave |
static (Shared in Visual Basic) | HorizontalAlignment |
static (Shared in Visual Basic) | Icon |
static (Shared in Visual Basic) | Id |
static (Shared in Visual Basic) | IdentCount |
static (Shared in Visual Basic) | Image |
static (Shared in Visual Basic) | ImageAlign |
static (Shared in Visual Basic) | ImageHeight |
static (Shared in Visual Basic) | ImageSize |
static (Shared in Visual Basic) | ImageWidth |
static (Shared in Visual Basic) | Increment |
static (Shared in Visual Basic) | Index |
static (Shared in Visual Basic) | InValidateMessage |
static (Shared in Visual Basic) | IsDlayedDrawing |
static (Shared in Visual Basic) | IsMdiContainer |
static (Shared in Visual Basic) | IsNew |
static (Shared in Visual Basic) | IsSplitterFixed |
static (Shared in Visual Basic) | IsWindowSized |
static (Shared in Visual Basic) | KeyCode |
static (Shared in Visual Basic) | KeyFilter |
static (Shared in Visual Basic) | KeyState |
static (Shared in Visual Basic) | LabelEdit |
static (Shared in Visual Basic) | LablesColumnWidth |
static (Shared in Visual Basic) | LargeImage |
static (Shared in Visual Basic) | LargeImageHeight |
static (Shared in Visual Basic) | LargeImageWidth |
static (Shared in Visual Basic) | LastEditCell |
static (Shared in Visual Basic) | LastRender |
static (Shared in Visual Basic) | Left |
static (Shared in Visual Basic) | Length |
static (Shared in Visual Basic) | LinkColor |
static (Shared in Visual Basic) | LinkState |
static (Shared in Visual Basic) | Loaded |
static (Shared in Visual Basic) | LoadingMessage |
static (Shared in Visual Basic) | Mapping |
static (Shared in Visual Basic) | MarginAll |
static (Shared in Visual Basic) | MarginBottom |
static (Shared in Visual Basic) | MarginLeft |
static (Shared in Visual Basic) | MarginRight |
static (Shared in Visual Basic) | MarginTop |
static (Shared in Visual Basic) | MaxDate |
static (Shared in Visual Basic) | Maximize |
static (Shared in Visual Basic) | Maximum |
static (Shared in Visual Basic) | MaximumHeight |
static (Shared in Visual Basic) | MaximumWidth |
static (Shared in Visual Basic) | MaxLength |
static (Shared in Visual Basic) | MdiParent |
static (Shared in Visual Basic) | Member |
static (Shared in Visual Basic) | MemberID |
static (Shared in Visual Basic) | Menu |
static (Shared in Visual Basic) | Message |
static (Shared in Visual Basic) | MinDate |
static (Shared in Visual Basic) | Minimize |
static (Shared in Visual Basic) | Minimum |
static (Shared in Visual Basic) | MinimumHeight |
static (Shared in Visual Basic) | MinimumWidth |
static (Shared in Visual Basic) | Mode |
static (Shared in Visual Basic) | Movie |
static (Shared in Visual Basic) | Multiline |
static (Shared in Visual Basic) | Multiple |
static (Shared in Visual Basic) | Name |
static (Shared in Visual Basic) | ObjectClassId |
static (Shared in Visual Basic) | ObjectCodeBase |
static (Shared in Visual Basic) | ObjectPluginsPageType |
static (Shared in Visual Basic) | ObjectType |
static (Shared in Visual Basic) | Opacity |
static (Shared in Visual Basic) | Orientation |
static (Shared in Visual Basic) | OwnerID |
static (Shared in Visual Basic) | PaddingAll |
static (Shared in Visual Basic) | PaddingBottom |
static (Shared in Visual Basic) | PaddingLeft |
static (Shared in Visual Basic) | PaddingRight |
static (Shared in Visual Basic) | PaddingTop |
static (Shared in Visual Basic) | Password |
static (Shared in Visual Basic) | PromptChar |
static (Shared in Visual Basic) | Pushed |
static (Shared in Visual Basic) | Quality |
static (Shared in Visual Basic) | RadioButtons |
static (Shared in Visual Basic) | RaiseUnloadEvent |
static (Shared in Visual Basic) | ReadOnly |
static (Shared in Visual Basic) | Redraw |
static (Shared in Visual Basic) | Resize |
static (Shared in Visual Basic) | Return |
static (Shared in Visual Basic) | Right |
static (Shared in Visual Basic) | Rotation |
static (Shared in Visual Basic) | RowHeaders |
static (Shared in Visual Basic) | Rows |
static (Shared in Visual Basic) | Rowspan |
static (Shared in Visual Basic) | ScaleX |
static (Shared in Visual Basic) | ScaleY |
static (Shared in Visual Basic) | Scrollbars |
static (Shared in Visual Basic) | ScrollLeft |
static (Shared in Visual Basic) | ScrollTop |
static (Shared in Visual Basic) | Selectable |
static (Shared in Visual Basic) | Selected |
static (Shared in Visual Basic) | SelectedImage |
static (Shared in Visual Basic) | SelectionBackColor |
static (Shared in Visual Basic) | SelectionButtons |
static (Shared in Visual Basic) | SelectionForeColor |
static (Shared in Visual Basic) | SelectionIcons |
static (Shared in Visual Basic) | SelectionLength |
static (Shared in Visual Basic) | SelectionMode |
static (Shared in Visual Basic) | SelectionStart |
static (Shared in Visual Basic) | SelectOnRightClick |
static (Shared in Visual Basic) | ShiftKey |
static (Shared in Visual Basic) | Shortcut |
static (Shared in Visual Basic) | ShowLines |
static (Shared in Visual Basic) | ShowUpDown |
static (Shared in Visual Basic) | Size |
static (Shared in Visual Basic) | SkewX |
static (Shared in Visual Basic) | SkewY |
static (Shared in Visual Basic) | Sort |
static (Shared in Visual Basic) | SortedColumn |
static (Shared in Visual Basic) | SortOrder |
static (Shared in Visual Basic) | Source |
static (Shared in Visual Basic) | Style |
static (Shared in Visual Basic) | TabIndex |
static (Shared in Visual Basic) | Target |
static (Shared in Visual Basic) | TargetColumn |
static (Shared in Visual Basic) | Text |
static (Shared in Visual Basic) | TextAlign |
static (Shared in Visual Basic) | TextImageRelation |
static (Shared in Visual Basic) | ThousandsSeparator |
static (Shared in Visual Basic) | Timer |
static (Shared in Visual Basic) | ToolBar |
static (Shared in Visual Basic) | ToolTip |
static (Shared in Visual Basic) | Top |
static (Shared in Visual Basic) | TotalItems |
static (Shared in Visual Basic) | TotalPages |
static (Shared in Visual Basic) | Trace |
static (Shared in Visual Basic) | Type |
static (Shared in Visual Basic) | UseItemStyleForSubItems |
static (Shared in Visual Basic) | Value |
static (Shared in Visual Basic) | ValueValidationExpression |
static (Shared in Visual Basic) | VerticalAlignment |
static (Shared in Visual Basic) | View |
static (Shared in Visual Basic) | Visible |
static (Shared in Visual Basic) | VisitedLinkColor |
static (Shared in Visual Basic) | Width |
static (Shared in Visual Basic) | Windowless |
static (Shared in Visual Basic) | WindowState |
static (Shared in Visual Basic) | WordWrap |
static (Shared in Visual Basic) | WrapContents |
Top

See Also

Reference

WGAttributes Class
Gizmox.WebGUI Namespace


WGAttributes Constructor

[image]
Gizmox.WebGUI.Common
WGAttributes Constructor
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : WGAttributes Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As WGAttributes()
C#
public WGAttributes()
Managed Extensions for C++
public: WGAttributes();
C++/CLI
public:
WGAttributes();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


WGAttributes Class Fields

[image]
Gizmox.WebGUI.Common
WGAttributes Class Fields
See Also Send Feedback
Gizmox.WebGUI Namespace : WGAttributes Class

For a list of all members of this type, see WGAttributes members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | AcceptButton |
static (Shared in Visual Basic) | Active |
static (Shared in Visual Basic) | ActiveForm |
static (Shared in Visual Basic) | ActiveLinkColor |
static (Shared in Visual Basic) | Advanced |
static (Shared in Visual Basic) | AlignTo |
static (Shared in Visual Basic) | AlignType |
static (Shared in Visual Basic) | AllowDrop |
static (Shared in Visual Basic) | AllowUserToOrderColumns |
static (Shared in Visual Basic) | AltKey |
static (Shared in Visual Basic) | Anchoring |
static (Shared in Visual Basic) | Archive |
static (Shared in Visual Basic) | Argument |
static (Shared in Visual Basic) | Assembly |
static (Shared in Visual Basic) | AutoCheck |
static (Shared in Visual Basic) | AutoCompleteMode |
static (Shared in Visual Basic) | AutoSize |
static (Shared in Visual Basic) | Background |
static (Shared in Visual Basic) | BackgroundImage |
static (Shared in Visual Basic) | BackgroundImageLayout |
static (Shared in Visual Basic) | BeforeUnloadMessage |
static (Shared in Visual Basic) | Border |
static (Shared in Visual Basic) | BorderStyle |
static (Shared in Visual Basic) | Bottom |
static (Shared in Visual Basic) | ButtonHeight |
static (Shared in Visual Basic) | ButtonWidth |
static (Shared in Visual Basic) | CancelButton |
static (Shared in Visual Basic) | CellBorderStyle |
static (Shared in Visual Basic) | CharacterCasing |
static (Shared in Visual Basic) | CharacterValidationExpression |
static (Shared in Visual Basic) | CharacterValidationMask |
static (Shared in Visual Basic) | CheckBoxes |
static (Shared in Visual Basic) | Checked |
static (Shared in Visual Basic) | ClickOnce |
static (Shared in Visual Basic) | ClientUniqeId |
static (Shared in Visual Basic) | Code |
static (Shared in Visual Basic) | CodeBase |
static (Shared in Visual Basic) | Collapsable |
static (Shared in Visual Basic) | Color |
static (Shared in Visual Basic) | Cols |
static (Shared in Visual Basic) | Colspan |
static (Shared in Visual Basic) | ColumnHeaders |
static (Shared in Visual Basic) | ContentAlign |
static (Shared in Visual Basic) | ControlKey |
static (Shared in Visual Basic) | CurrentCell |
static (Shared in Visual Basic) | CurrentPage |
static (Shared in Visual Basic) | Cursor |
static (Shared in Visual Basic) | CursorPosition |
static (Shared in Visual Basic) | CustomStyle |
static (Shared in Visual Basic) | CustomTemplate |
static (Shared in Visual Basic) | DateTime |
static (Shared in Visual Basic) | DecimalPlaces |
static (Shared in Visual Basic) | Depth |
static (Shared in Visual Basic) | DisableNavigation |
static (Shared in Visual Basic) | Docking |
static (Shared in Visual Basic) | Done |
static (Shared in Visual Basic) | DraggedColumn |
static (Shared in Visual Basic) | DragSource |
static (Shared in Visual Basic) | DragSourceMember |
static (Shared in Visual Basic) | DragTargets |
static (Shared in Visual Basic) | DropDown |
static (Shared in Visual Basic) | DropDownWidth |
static (Shared in Visual Basic) | DropTargetMember |
static (Shared in Visual Basic) | Enabled |
static (Shared in Visual Basic) | EnablesDrop |
static (Shared in Visual Basic) | ErrorIcon |
static (Shared in Visual Basic) | ErrorIconAlignment |
static (Shared in Visual Basic) | ErrorIconPadding |
static (Shared in Visual Basic) | ErrorMessage |
static (Shared in Visual Basic) | Events |
static (Shared in Visual Basic) | Expanded |
static (Shared in Visual Basic) | ExpandedImage |
static (Shared in Visual Basic) | FirstDayOfWeek |
static (Shared in Visual Basic) | FlowDirection |
static (Shared in Visual Basic) | Focus |
static (Shared in Visual Basic) | Focused |
static (Shared in Visual Basic) | Font |
static (Shared in Visual Basic) | Fore |
static (Shared in Visual Basic) | Format |
static (Shared in Visual Basic) | FormBorderStyle |
static (Shared in Visual Basic) | FormSize |
static (Shared in Visual Basic) | FormStartPosition |
static (Shared in Visual Basic) | Frequency |
static (Shared in Visual Basic) | Frozen |
static (Shared in Visual Basic) | FullRowSelect |
static (Shared in Visual Basic) | GridLines |
static (Shared in Visual Basic) | GrowStyle |
static (Shared in Visual Basic) | HasChecked |
static (Shared in Visual Basic) | HasNodes |
static (Shared in Visual Basic) | HasRedrawingParent |
static (Shared in Visual Basic) | HasSelected |
static (Shared in Visual Basic) | HeaderStyle |
static (Shared in Visual Basic) | Height |
static (Shared in Visual Basic) | HelpVisible |
static (Shared in Visual Basic) | Hexadecimal |
static (Shared in Visual Basic) | HideButtons |
static (Shared in Visual Basic) | HidePlusMinus |
static (Shared in Visual Basic) | HidePromptOnLeave |
static (Shared in Visual Basic) | HorizontalAlignment |
static (Shared in Visual Basic) | Icon |
static (Shared in Visual Basic) | Id |
static (Shared in Visual Basic) | IdentCount |
static (Shared in Visual Basic) | Image |
static (Shared in Visual Basic) | ImageAlign |
static (Shared in Visual Basic) | ImageHeight |
static (Shared in Visual Basic) | ImageSize |
static (Shared in Visual Basic) | ImageWidth |
static (Shared in Visual Basic) | Increment |
static (Shared in Visual Basic) | Index |
static (Shared in Visual Basic) | InValidateMessage |
static (Shared in Visual Basic) | IsDlayedDrawing |
static (Shared in Visual Basic) | IsMdiContainer |
static (Shared in Visual Basic) | IsNew |
static (Shared in Visual Basic) | IsSplitterFixed |
static (Shared in Visual Basic) | IsWindowSized |
static (Shared in Visual Basic) | KeyCode |
static (Shared in Visual Basic) | KeyFilter |
static (Shared in Visual Basic) | KeyState |
static (Shared in Visual Basic) | LabelEdit |
static (Shared in Visual Basic) | LablesColumnWidth |
static (Shared in Visual Basic) | LargeImage |
static (Shared in Visual Basic) | LargeImageHeight |
static (Shared in Visual Basic) | LargeImageWidth |
static (Shared in Visual Basic) | LastEditCell |
static (Shared in Visual Basic) | LastRender |
static (Shared in Visual Basic) | Left |
static (Shared in Visual Basic) | Length |
static (Shared in Visual Basic) | LinkColor |
static (Shared in Visual Basic) | LinkState |
static (Shared in Visual Basic) | Loaded |
static (Shared in Visual Basic) | LoadingMessage |
static (Shared in Visual Basic) | Mapping |
static (Shared in Visual Basic) | MarginAll |
static (Shared in Visual Basic) | MarginBottom |
static (Shared in Visual Basic) | MarginLeft |
static (Shared in Visual Basic) | MarginRight |
static (Shared in Visual Basic) | MarginTop |
static (Shared in Visual Basic) | MaxDate |
static (Shared in Visual Basic) | Maximize |
static (Shared in Visual Basic) | Maximum |
static (Shared in Visual Basic) | MaximumHeight |
static (Shared in Visual Basic) | MaximumWidth |
static (Shared in Visual Basic) | MaxLength |
static (Shared in Visual Basic) | MdiParent |
static (Shared in Visual Basic) | Member |
static (Shared in Visual Basic) | MemberID |
static (Shared in Visual Basic) | Menu |
static (Shared in Visual Basic) | Message |
static (Shared in Visual Basic) | MinDate |
static (Shared in Visual Basic) | Minimize |
static (Shared in Visual Basic) | Minimum |
static (Shared in Visual Basic) | MinimumHeight |
static (Shared in Visual Basic) | MinimumWidth |
static (Shared in Visual Basic) | Mode |
static (Shared in Visual Basic) | Movie |
static (Shared in Visual Basic) | Multiline |
static (Shared in Visual Basic) | Multiple |
static (Shared in Visual Basic) | Name |
static (Shared in Visual Basic) | ObjectClassId |
static (Shared in Visual Basic) | ObjectCodeBase |
static (Shared in Visual Basic) | ObjectPluginsPageType |
static (Shared in Visual Basic) | ObjectType |
static (Shared in Visual Basic) | Opacity |
static (Shared in Visual Basic) | Orientation |
static (Shared in Visual Basic) | OwnerID |
static (Shared in Visual Basic) | PaddingAll |
static (Shared in Visual Basic) | PaddingBottom |
static (Shared in Visual Basic) | PaddingLeft |
static (Shared in Visual Basic) | PaddingRight |
static (Shared in Visual Basic) | PaddingTop |
static (Shared in Visual Basic) | Password |
static (Shared in Visual Basic) | PromptChar |
static (Shared in Visual Basic) | Pushed |
static (Shared in Visual Basic) | Quality |
static (Shared in Visual Basic) | RadioButtons |
static (Shared in Visual Basic) | RaiseUnloadEvent |
static (Shared in Visual Basic) | ReadOnly |
static (Shared in Visual Basic) | Redraw |
static (Shared in Visual Basic) | Resize |
static (Shared in Visual Basic) | Return |
static (Shared in Visual Basic) | Right |
static (Shared in Visual Basic) | Rotation |
static (Shared in Visual Basic) | RowHeaders |
static (Shared in Visual Basic) | Rows |
static (Shared in Visual Basic) | Rowspan |
static (Shared in Visual Basic) | ScaleX |
static (Shared in Visual Basic) | ScaleY |
static (Shared in Visual Basic) | Scrollbars |
static (Shared in Visual Basic) | ScrollLeft |
static (Shared in Visual Basic) | ScrollTop |
static (Shared in Visual Basic) | Selectable |
static (Shared in Visual Basic) | Selected |
static (Shared in Visual Basic) | SelectedImage |
static (Shared in Visual Basic) | SelectionBackColor |
static (Shared in Visual Basic) | SelectionButtons |
static (Shared in Visual Basic) | SelectionForeColor |
static (Shared in Visual Basic) | SelectionIcons |
static (Shared in Visual Basic) | SelectionLength |
static (Shared in Visual Basic) | SelectionMode |
static (Shared in Visual Basic) | SelectionStart |
static (Shared in Visual Basic) | SelectOnRightClick |
static (Shared in Visual Basic) | ShiftKey |
static (Shared in Visual Basic) | Shortcut |
static (Shared in Visual Basic) | ShowLines |
static (Shared in Visual Basic) | ShowUpDown |
static (Shared in Visual Basic) | Size |
static (Shared in Visual Basic) | SkewX |
static (Shared in Visual Basic) | SkewY |
static (Shared in Visual Basic) | Sort |
static (Shared in Visual Basic) | SortedColumn |
static (Shared in Visual Basic) | SortOrder |
static (Shared in Visual Basic) | Source |
static (Shared in Visual Basic) | Style |
static (Shared in Visual Basic) | TabIndex |
static (Shared in Visual Basic) | Target |
static (Shared in Visual Basic) | TargetColumn |
static (Shared in Visual Basic) | Text |
static (Shared in Visual Basic) | TextAlign |
static (Shared in Visual Basic) | TextImageRelation |
static (Shared in Visual Basic) | ThousandsSeparator |
static (Shared in Visual Basic) | Timer |
static (Shared in Visual Basic) | ToolBar |
static (Shared in Visual Basic) | ToolTip |
static (Shared in Visual Basic) | Top |
static (Shared in Visual Basic) | TotalItems |
static (Shared in Visual Basic) | TotalPages |
static (Shared in Visual Basic) | Trace |
static (Shared in Visual Basic) | Type |
static (Shared in Visual Basic) | UseItemStyleForSubItems |
static (Shared in Visual Basic) | Value |
static (Shared in Visual Basic) | ValueValidationExpression |
static (Shared in Visual Basic) | VerticalAlignment |
static (Shared in Visual Basic) | View |
static (Shared in Visual Basic) | Visible |
static (Shared in Visual Basic) | VisitedLinkColor |
static (Shared in Visual Basic) | Width |
static (Shared in Visual Basic) | Windowless |
static (Shared in Visual Basic) | WindowState |
static (Shared in Visual Basic) | WordWrap |
static (Shared in Visual Basic) | WrapContents |
Top

See Also

Reference

WGAttributes Class
Gizmox.WebGUI Namespace


AcceptButton Field

[image]
Gizmox.WebGUI.Common
AcceptButton Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : AcceptButton Field

Syntax

Visual Basic (Declaration)
Public Shared AcceptButton As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.AcceptButton

WGAttributes.AcceptButton = value
C#
public static string AcceptButton
Managed Extensions for C++
public: static string* AcceptButton
C++/CLI
public:
static String^ AcceptButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


Active Field

[image]
Gizmox.WebGUI.Common
Active Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : Active Field

Syntax

Visual Basic (Declaration)
Public Shared Active As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.Active

WGAttributes.Active = value
C#
public static string Active
Managed Extensions for C++
public: static string* Active
C++/CLI
public:
static String^ Active

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


ActiveForm Field

[image]
Gizmox.WebGUI.Common
ActiveForm Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : ActiveForm Field

Syntax

Visual Basic (Declaration)
Public Shared ActiveForm As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.ActiveForm

WGAttributes.ActiveForm = value
C#
public static string ActiveForm
Managed Extensions for C++
public: static string* ActiveForm
C++/CLI
public:
static String^ ActiveForm

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


ActiveLinkColor Field

[image]
Gizmox.WebGUI.Common
ActiveLinkColor Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : ActiveLinkColor Field

Syntax

Visual Basic (Declaration)
Public Shared ActiveLinkColor As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.ActiveLinkColor

WGAttributes.ActiveLinkColor = value
C#
public static string ActiveLinkColor
Managed Extensions for C++
public: static string* ActiveLinkColor
C++/CLI
public:
static String^ ActiveLinkColor

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


Advanced Field

[image]
Gizmox.WebGUI.Common
Advanced Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : Advanced Field

Syntax

Visual Basic (Declaration)
Public Shared Advanced As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.Advanced

WGAttributes.Advanced = value
C#
public static string Advanced
Managed Extensions for C++
public: static string* Advanced
C++/CLI
public:
static String^ Advanced

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


AlignTo Field

[image]
Gizmox.WebGUI.Common
AlignTo Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : AlignTo Field

Syntax

Visual Basic (Declaration)
Public Shared AlignTo As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.AlignTo

WGAttributes.AlignTo = value
C#
public static string AlignTo
Managed Extensions for C++
public: static string* AlignTo
C++/CLI
public:
static String^ AlignTo

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


AlignType Field

[image]
Gizmox.WebGUI.Common
AlignType Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : AlignType Field

Syntax

Visual Basic (Declaration)
Public Shared AlignType As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.AlignType

WGAttributes.AlignType = value
C#
public static string AlignType
Managed Extensions for C++
public: static string* AlignType
C++/CLI
public:
static String^ AlignType

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


AllowDrop Field

[image]
Gizmox.WebGUI.Common
AllowDrop Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : AllowDrop Field

Syntax

Visual Basic (Declaration)
Public Shared AllowDrop As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.AllowDrop

WGAttributes.AllowDrop = value
C#
public static string AllowDrop
Managed Extensions for C++
public: static string* AllowDrop
C++/CLI
public:
static String^ AllowDrop

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


AllowUserToOrderColumns Field

[image]
Gizmox.WebGUI.Common
AllowUserToOrderColumns Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : AllowUserToOrderColumns Field

Syntax

Visual Basic (Declaration)
Public Shared AllowUserToOrderColumns As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.AllowUserToOrderColumns

WGAttributes.AllowUserToOrderColumns = value
C#
public static string AllowUserToOrderColumns
Managed Extensions for C++
public: static string* AllowUserToOrderColumns
C++/CLI
public:
static String^ AllowUserToOrderColumns

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


AltKey Field

[image]
Gizmox.WebGUI.Common
AltKey Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : AltKey Field

Syntax

Visual Basic (Declaration)
Public Shared AltKey As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.AltKey

WGAttributes.AltKey = value
C#
public static string AltKey
Managed Extensions for C++
public: static string* AltKey
C++/CLI
public:
static String^ AltKey

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


Anchoring Field

[image]
Gizmox.WebGUI.Common
Anchoring Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : Anchoring Field

Syntax

Visual Basic (Declaration)
Public Shared Anchoring As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.Anchoring

WGAttributes.Anchoring = value
C#
public static string Anchoring
Managed Extensions for C++
public: static string* Anchoring
C++/CLI
public:
static String^ Anchoring

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


Archive Field

[image]
Gizmox.WebGUI.Common
Archive Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : Archive Field

Syntax

Visual Basic (Declaration)
Public Shared Archive As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.Archive

WGAttributes.Archive = value
C#
public static string Archive
Managed Extensions for C++
public: static string* Archive
C++/CLI
public:
static String^ Archive

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


Argument Field

[image]
Gizmox.WebGUI.Common
Argument Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : Argument Field

Syntax

Visual Basic (Declaration)
Public Shared Argument As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.Argument

WGAttributes.Argument = value
C#
public static string Argument
Managed Extensions for C++
public: static string* Argument
C++/CLI
public:
static String^ Argument

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


Assembly Field

[image]
Gizmox.WebGUI.Common
Assembly Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : Assembly Field

Syntax

Visual Basic (Declaration)
Public Shared Assembly As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.Assembly

WGAttributes.Assembly = value
C#
public static string Assembly
Managed Extensions for C++
public: static string* Assembly
C++/CLI
public:
static String^ Assembly

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


AutoCheck Field

[image]
Gizmox.WebGUI.Common
AutoCheck Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : AutoCheck Field

Syntax

Visual Basic (Declaration)
Public Shared AutoCheck As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.AutoCheck

WGAttributes.AutoCheck = value
C#
public static string AutoCheck
Managed Extensions for C++
public: static string* AutoCheck
C++/CLI
public:
static String^ AutoCheck

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


AutoCompleteMode Field

[image]
Gizmox.WebGUI.Common
AutoCompleteMode Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : AutoCompleteMode Field

Syntax

Visual Basic (Declaration)
Public Shared AutoCompleteMode As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.AutoCompleteMode

WGAttributes.AutoCompleteMode = value
C#
public static string AutoCompleteMode
Managed Extensions for C++
public: static string* AutoCompleteMode
C++/CLI
public:
static String^ AutoCompleteMode

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


AutoSize Field

[image]
Gizmox.WebGUI.Common
AutoSize Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : AutoSize Field

Syntax

Visual Basic (Declaration)
Public Shared AutoSize As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.AutoSize

WGAttributes.AutoSize = value
C#
public static string AutoSize
Managed Extensions for C++
public: static string* AutoSize
C++/CLI
public:
static String^ AutoSize

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


Background Field

[image]
Gizmox.WebGUI.Common
Background Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : Background Field

Syntax

Visual Basic (Declaration)
Public Shared Background As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.Background

WGAttributes.Background = value
C#
public static string Background
Managed Extensions for C++
public: static string* Background
C++/CLI
public:
static String^ Background

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


BackgroundImage Field

[image]
Gizmox.WebGUI.Common
BackgroundImage Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : BackgroundImage Field

Syntax

Visual Basic (Declaration)
Public Shared BackgroundImage As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.BackgroundImage

WGAttributes.BackgroundImage = value
C#
public static string BackgroundImage
Managed Extensions for C++
public: static string* BackgroundImage
C++/CLI
public:
static String^ BackgroundImage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


BackgroundImageLayout Field

[image]
Gizmox.WebGUI.Common
BackgroundImageLayout Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : BackgroundImageLayout Field

Syntax

Visual Basic (Declaration)
Public Shared BackgroundImageLayout As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.BackgroundImageLayout

WGAttributes.BackgroundImageLayout = value
C#
public static string BackgroundImageLayout
Managed Extensions for C++
public: static string* BackgroundImageLayout
C++/CLI
public:
static String^ BackgroundImageLayout

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


BeforeUnloadMessage Field

[image]
Gizmox.WebGUI.Common
BeforeUnloadMessage Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : BeforeUnloadMessage Field

Syntax

Visual Basic (Declaration)
Public Shared BeforeUnloadMessage As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.BeforeUnloadMessage

WGAttributes.BeforeUnloadMessage = value
C#
public static string BeforeUnloadMessage
Managed Extensions for C++
public: static string* BeforeUnloadMessage
C++/CLI
public:
static String^ BeforeUnloadMessage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


Border Field

[image]
Gizmox.WebGUI.Common
Border Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : Border Field

Syntax

Visual Basic (Declaration)
Public Shared Border As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.Border

WGAttributes.Border = value
C#
public static string Border
Managed Extensions for C++
public: static string* Border
C++/CLI
public:
static String^ Border

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


BorderStyle Field

[image]
Gizmox.WebGUI.Common
BorderStyle Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : BorderStyle Field

Syntax

Visual Basic (Declaration)
Public Shared BorderStyle As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.BorderStyle

WGAttributes.BorderStyle = value
C#
public static string BorderStyle
Managed Extensions for C++
public: static string* BorderStyle
C++/CLI
public:
static String^ BorderStyle

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


Bottom Field

[image]
Gizmox.WebGUI.Common
Bottom Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : Bottom Field

Syntax

Visual Basic (Declaration)
Public Shared Bottom As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.Bottom

WGAttributes.Bottom = value
C#
public static string Bottom
Managed Extensions for C++
public: static string* Bottom
C++/CLI
public:
static String^ Bottom

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


ButtonHeight Field

[image]
Gizmox.WebGUI.Common
ButtonHeight Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : ButtonHeight Field

Syntax

Visual Basic (Declaration)
Public Shared ButtonHeight As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.ButtonHeight

WGAttributes.ButtonHeight = value
C#
public static string ButtonHeight
Managed Extensions for C++
public: static string* ButtonHeight
C++/CLI
public:
static String^ ButtonHeight

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


ButtonWidth Field

[image]
Gizmox.WebGUI.Common
ButtonWidth Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : ButtonWidth Field

Syntax

Visual Basic (Declaration)
Public Shared ButtonWidth As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.ButtonWidth

WGAttributes.ButtonWidth = value
C#
public static string ButtonWidth
Managed Extensions for C++
public: static string* ButtonWidth
C++/CLI
public:
static String^ ButtonWidth

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


CancelButton Field

[image]
Gizmox.WebGUI.Common
CancelButton Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : CancelButton Field

Syntax

Visual Basic (Declaration)
Public Shared CancelButton As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.CancelButton

WGAttributes.CancelButton = value
C#
public static string CancelButton
Managed Extensions for C++
public: static string* CancelButton
C++/CLI
public:
static String^ CancelButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


CellBorderStyle Field

[image]
Gizmox.WebGUI.Common
CellBorderStyle Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : CellBorderStyle Field

Syntax

Visual Basic (Declaration)
Public Shared CellBorderStyle As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.CellBorderStyle

WGAttributes.CellBorderStyle = value
C#
public static string CellBorderStyle
Managed Extensions for C++
public: static string* CellBorderStyle
C++/CLI
public:
static String^ CellBorderStyle

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


CharacterCasing Field

[image]
Gizmox.WebGUI.Common
CharacterCasing Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : CharacterCasing Field

Syntax

Visual Basic (Declaration)
Public Shared CharacterCasing As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.CharacterCasing

WGAttributes.CharacterCasing = value
C#
public static string CharacterCasing
Managed Extensions for C++
public: static string* CharacterCasing
C++/CLI
public:
static String^ CharacterCasing

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


CharacterValidationExpression Field

[image]
Gizmox.WebGUI.Common
CharacterValidationExpression Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : CharacterValidationExpression Field

Syntax

Visual Basic (Declaration)
Public Shared CharacterValidationExpression As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.CharacterValidationExpression

WGAttributes.CharacterValidationExpression = value
C#
public static string CharacterValidationExpression
Managed Extensions for C++
public: static string* CharacterValidationExpression
C++/CLI
public:
static String^ CharacterValidationExpression

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


CharacterValidationMask Field

[image]
Gizmox.WebGUI.Common
CharacterValidationMask Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : CharacterValidationMask Field

Syntax

Visual Basic (Declaration)
Public Shared CharacterValidationMask As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.CharacterValidationMask

WGAttributes.CharacterValidationMask = value
C#
public static string CharacterValidationMask
Managed Extensions for C++
public: static string* CharacterValidationMask
C++/CLI
public:
static String^ CharacterValidationMask

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


CheckBoxes Field

[image]
Gizmox.WebGUI.Common
CheckBoxes Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : CheckBoxes Field

Syntax

Visual Basic (Declaration)
Public Shared CheckBoxes As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.CheckBoxes

WGAttributes.CheckBoxes = value
C#
public static string CheckBoxes
Managed Extensions for C++
public: static string* CheckBoxes
C++/CLI
public:
static String^ CheckBoxes

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


Checked Field

[image]
Gizmox.WebGUI.Common
Checked Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : Checked Field

Syntax

Visual Basic (Declaration)
Public Shared Checked As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.Checked

WGAttributes.Checked = value
C#
public static string Checked
Managed Extensions for C++
public: static string* Checked
C++/CLI
public:
static String^ Checked

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


ClickOnce Field

[image]
Gizmox.WebGUI.Common
ClickOnce Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : ClickOnce Field

Syntax

Visual Basic (Declaration)
Public Shared ClickOnce As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.ClickOnce

WGAttributes.ClickOnce = value
C#
public static string ClickOnce
Managed Extensions for C++
public: static string* ClickOnce
C++/CLI
public:
static String^ ClickOnce

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


ClientUniqeId Field

[image]
Gizmox.WebGUI.Common
ClientUniqeId Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : ClientUniqeId Field

Syntax

Visual Basic (Declaration)
Public Shared ClientUniqeId As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.ClientUniqeId

WGAttributes.ClientUniqeId = value
C#
public static string ClientUniqeId
Managed Extensions for C++
public: static string* ClientUniqeId
C++/CLI
public:
static String^ ClientUniqeId

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


Code Field

[image]
Gizmox.WebGUI.Common
Code Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : Code Field

Syntax

Visual Basic (Declaration)
Public Shared Code As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.Code

WGAttributes.Code = value
C#
public static string Code
Managed Extensions for C++
public: static string* Code
C++/CLI
public:
static String^ Code

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


CodeBase Field

[image]
Gizmox.WebGUI.Common
CodeBase Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : CodeBase Field

Syntax

Visual Basic (Declaration)
Public Shared CodeBase As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.CodeBase

WGAttributes.CodeBase = value
C#
public static string CodeBase
Managed Extensions for C++
public: static string* CodeBase
C++/CLI
public:
static String^ CodeBase

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


Collapsable Field

[image]
Gizmox.WebGUI.Common
Collapsable Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : Collapsable Field

Syntax

Visual Basic (Declaration)
Public Shared Collapsable As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.Collapsable

WGAttributes.Collapsable = value
C#
public static string Collapsable
Managed Extensions for C++
public: static string* Collapsable
C++/CLI
public:
static String^ Collapsable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


Color Field

[image]
Gizmox.WebGUI.Common
Color Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : Color Field

Syntax

Visual Basic (Declaration)
Public Shared Color As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.Color

WGAttributes.Color = value
C#
public static string Color
Managed Extensions for C++
public: static string* Color
C++/CLI
public:
static String^ Color

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


Cols Field

[image]
Gizmox.WebGUI.Common
Cols Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : Cols Field

Syntax

Visual Basic (Declaration)
Public Shared Cols As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.Cols

WGAttributes.Cols = value
C#
public static string Cols
Managed Extensions for C++
public: static string* Cols
C++/CLI
public:
static String^ Cols

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


Colspan Field

[image]
Gizmox.WebGUI.Common
Colspan Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : Colspan Field

Syntax

Visual Basic (Declaration)
Public Shared Colspan As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.Colspan

WGAttributes.Colspan = value
C#
public static string Colspan
Managed Extensions for C++
public: static string* Colspan
C++/CLI
public:
static String^ Colspan

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


ColumnHeaders Field

[image]
Gizmox.WebGUI.Common
ColumnHeaders Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : ColumnHeaders Field

Syntax

Visual Basic (Declaration)
Public Shared ColumnHeaders As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.ColumnHeaders

WGAttributes.ColumnHeaders = value
C#
public static string ColumnHeaders
Managed Extensions for C++
public: static string* ColumnHeaders
C++/CLI
public:
static String^ ColumnHeaders

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


ContentAlign Field

[image]
Gizmox.WebGUI.Common
ContentAlign Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : ContentAlign Field

Syntax

Visual Basic (Declaration)
Public Shared ContentAlign As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.ContentAlign

WGAttributes.ContentAlign = value
C#
public static string ContentAlign
Managed Extensions for C++
public: static string* ContentAlign
C++/CLI
public:
static String^ ContentAlign

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


ControlKey Field

[image]
Gizmox.WebGUI.Common
ControlKey Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : ControlKey Field

Syntax

Visual Basic (Declaration)
Public Shared ControlKey As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.ControlKey

WGAttributes.ControlKey = value
C#
public static string ControlKey
Managed Extensions for C++
public: static string* ControlKey
C++/CLI
public:
static String^ ControlKey

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


CurrentCell Field

[image]
Gizmox.WebGUI.Common
CurrentCell Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : CurrentCell Field

Syntax

Visual Basic (Declaration)
Public Shared CurrentCell As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.CurrentCell

WGAttributes.CurrentCell = value
C#
public static string CurrentCell
Managed Extensions for C++
public: static string* CurrentCell
C++/CLI
public:
static String^ CurrentCell

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


CurrentPage Field

[image]
Gizmox.WebGUI.Common
CurrentPage Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : CurrentPage Field

Syntax

Visual Basic (Declaration)
Public Shared CurrentPage As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.CurrentPage

WGAttributes.CurrentPage = value
C#
public static string CurrentPage
Managed Extensions for C++
public: static string* CurrentPage
C++/CLI
public:
static String^ CurrentPage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


Cursor Field

[image]
Gizmox.WebGUI.Common
Cursor Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : Cursor Field

Syntax

Visual Basic (Declaration)
Public Shared Cursor As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.Cursor

WGAttributes.Cursor = value
C#
public static string Cursor
Managed Extensions for C++
public: static string* Cursor
C++/CLI
public:
static String^ Cursor

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


CursorPosition Field

[image]
Gizmox.WebGUI.Common
CursorPosition Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : CursorPosition Field

Syntax

Visual Basic (Declaration)
Public Shared CursorPosition As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.CursorPosition

WGAttributes.CursorPosition = value
C#
public static string CursorPosition
Managed Extensions for C++
public: static string* CursorPosition
C++/CLI
public:
static String^ CursorPosition

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


CustomStyle Field

[image]
Gizmox.WebGUI.Common
CustomStyle Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : CustomStyle Field

Syntax

Visual Basic (Declaration)
Public Shared CustomStyle As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.CustomStyle

WGAttributes.CustomStyle = value
C#
public static string CustomStyle
Managed Extensions for C++
public: static string* CustomStyle
C++/CLI
public:
static String^ CustomStyle

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


CustomTemplate Field

[image]
Gizmox.WebGUI.Common
CustomTemplate Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : CustomTemplate Field

Syntax

Visual Basic (Declaration)
Public Shared CustomTemplate As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.CustomTemplate

WGAttributes.CustomTemplate = value
C#
public static string CustomTemplate
Managed Extensions for C++
public: static string* CustomTemplate
C++/CLI
public:
static String^ CustomTemplate

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


DateTime Field

[image]
Gizmox.WebGUI.Common
DateTime Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : DateTime Field

Syntax

Visual Basic (Declaration)
Public Shared DateTime As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.DateTime

WGAttributes.DateTime = value
C#
public static string DateTime
Managed Extensions for C++
public: static string* DateTime
C++/CLI
public:
static String^ DateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


DecimalPlaces Field

[image]
Gizmox.WebGUI.Common
DecimalPlaces Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : DecimalPlaces Field

Syntax

Visual Basic (Declaration)
Public Shared DecimalPlaces As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.DecimalPlaces

WGAttributes.DecimalPlaces = value
C#
public static string DecimalPlaces
Managed Extensions for C++
public: static string* DecimalPlaces
C++/CLI
public:
static String^ DecimalPlaces

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


Depth Field

[image]
Gizmox.WebGUI.Common
Depth Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : Depth Field

Syntax

Visual Basic (Declaration)
Public Shared Depth As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.Depth

WGAttributes.Depth = value
C#
public static string Depth
Managed Extensions for C++
public: static string* Depth
C++/CLI
public:
static String^ Depth

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


DisableNavigation Field

[image]
Gizmox.WebGUI.Common
DisableNavigation Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : DisableNavigation Field

Syntax

Visual Basic (Declaration)
Public Shared DisableNavigation As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.DisableNavigation

WGAttributes.DisableNavigation = value
C#
public static string DisableNavigation
Managed Extensions for C++
public: static string* DisableNavigation
C++/CLI
public:
static String^ DisableNavigation

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


Docking Field

[image]
Gizmox.WebGUI.Common
Docking Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : Docking Field

Syntax

Visual Basic (Declaration)
Public Shared Docking As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.Docking

WGAttributes.Docking = value
C#
public static string Docking
Managed Extensions for C++
public: static string* Docking
C++/CLI
public:
static String^ Docking

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


Done Field

[image]
Gizmox.WebGUI.Common
Done Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : Done Field

Syntax

Visual Basic (Declaration)
Public Shared Done As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.Done

WGAttributes.Done = value
C#
public static string Done
Managed Extensions for C++
public: static string* Done
C++/CLI
public:
static String^ Done

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


DraggedColumn Field

[image]
Gizmox.WebGUI.Common
DraggedColumn Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : DraggedColumn Field

Syntax

Visual Basic (Declaration)
Public Shared DraggedColumn As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.DraggedColumn

WGAttributes.DraggedColumn = value
C#
public static string DraggedColumn
Managed Extensions for C++
public: static string* DraggedColumn
C++/CLI
public:
static String^ DraggedColumn

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


DragSource Field

[image]
Gizmox.WebGUI.Common
DragSource Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : DragSource Field

Syntax

Visual Basic (Declaration)
Public Shared DragSource As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.DragSource

WGAttributes.DragSource = value
C#
public static string DragSource
Managed Extensions for C++
public: static string* DragSource
C++/CLI
public:
static String^ DragSource

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


DragSourceMember Field

[image]
Gizmox.WebGUI.Common
DragSourceMember Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : DragSourceMember Field

Syntax

Visual Basic (Declaration)
Public Shared DragSourceMember As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.DragSourceMember

WGAttributes.DragSourceMember = value
C#
public static string DragSourceMember
Managed Extensions for C++
public: static string* DragSourceMember
C++/CLI
public:
static String^ DragSourceMember

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


DragTargets Field

[image]
Gizmox.WebGUI.Common
DragTargets Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : DragTargets Field

Syntax

Visual Basic (Declaration)
Public Shared DragTargets As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.DragTargets

WGAttributes.DragTargets = value
C#
public static string DragTargets
Managed Extensions for C++
public: static string* DragTargets
C++/CLI
public:
static String^ DragTargets

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


DropDown Field

[image]
Gizmox.WebGUI.Common
DropDown Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : DropDown Field

Syntax

Visual Basic (Declaration)
Public Shared DropDown As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.DropDown

WGAttributes.DropDown = value
C#
public static string DropDown
Managed Extensions for C++
public: static string* DropDown
C++/CLI
public:
static String^ DropDown

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


DropDownWidth Field

[image]
Gizmox.WebGUI.Common
DropDownWidth Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : DropDownWidth Field

Syntax

Visual Basic (Declaration)
Public Shared DropDownWidth As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.DropDownWidth

WGAttributes.DropDownWidth = value
C#
public static string DropDownWidth
Managed Extensions for C++
public: static string* DropDownWidth
C++/CLI
public:
static String^ DropDownWidth

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


DropTargetMember Field

[image]
Gizmox.WebGUI.Common
DropTargetMember Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : DropTargetMember Field

Syntax

Visual Basic (Declaration)
Public Shared DropTargetMember As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.DropTargetMember

WGAttributes.DropTargetMember = value
C#
public static string DropTargetMember
Managed Extensions for C++
public: static string* DropTargetMember
C++/CLI
public:
static String^ DropTargetMember

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


Enabled Field

[image]
Gizmox.WebGUI.Common
Enabled Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : Enabled Field

Syntax

Visual Basic (Declaration)
Public Shared Enabled As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.Enabled

WGAttributes.Enabled = value
C#
public static string Enabled
Managed Extensions for C++
public: static string* Enabled
C++/CLI
public:
static String^ Enabled

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


EnablesDrop Field

[image]
Gizmox.WebGUI.Common
EnablesDrop Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : EnablesDrop Field

Syntax

Visual Basic (Declaration)
Public Shared EnablesDrop As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.EnablesDrop

WGAttributes.EnablesDrop = value
C#
public static string EnablesDrop
Managed Extensions for C++
public: static string* EnablesDrop
C++/CLI
public:
static String^ EnablesDrop

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


ErrorIcon Field

[image]
Gizmox.WebGUI.Common
ErrorIcon Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : ErrorIcon Field

Syntax

Visual Basic (Declaration)
Public Shared ErrorIcon As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.ErrorIcon

WGAttributes.ErrorIcon = value
C#
public static string ErrorIcon
Managed Extensions for C++
public: static string* ErrorIcon
C++/CLI
public:
static String^ ErrorIcon

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


ErrorIconAlignment Field

[image]
Gizmox.WebGUI.Common
ErrorIconAlignment Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : ErrorIconAlignment Field

Syntax

Visual Basic (Declaration)
Public Shared ErrorIconAlignment As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.ErrorIconAlignment

WGAttributes.ErrorIconAlignment = value
C#
public static string ErrorIconAlignment
Managed Extensions for C++
public: static string* ErrorIconAlignment
C++/CLI
public:
static String^ ErrorIconAlignment

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


ErrorIconPadding Field

[image]
Gizmox.WebGUI.Common
ErrorIconPadding Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : ErrorIconPadding Field

Syntax

Visual Basic (Declaration)
Public Shared ErrorIconPadding As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.ErrorIconPadding

WGAttributes.ErrorIconPadding = value
C#
public static string ErrorIconPadding
Managed Extensions for C++
public: static string* ErrorIconPadding
C++/CLI
public:
static String^ ErrorIconPadding

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


ErrorMessage Field

[image]
Gizmox.WebGUI.Common
ErrorMessage Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : ErrorMessage Field

Syntax

Visual Basic (Declaration)
Public Shared ErrorMessage As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.ErrorMessage

WGAttributes.ErrorMessage = value
C#
public static string ErrorMessage
Managed Extensions for C++
public: static string* ErrorMessage
C++/CLI
public:
static String^ ErrorMessage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


Events Field

[image]
Gizmox.WebGUI.Common
Events Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : Events Field

Syntax

Visual Basic (Declaration)
Public Shared Events As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.Events

WGAttributes.Events = value
C#
public static string Events
Managed Extensions for C++
public: static string* Events
C++/CLI
public:
static String^ Events

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


Expanded Field

[image]
Gizmox.WebGUI.Common
Expanded Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : Expanded Field

Syntax

Visual Basic (Declaration)
Public Shared Expanded As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.Expanded

WGAttributes.Expanded = value
C#
public static string Expanded
Managed Extensions for C++
public: static string* Expanded
C++/CLI
public:
static String^ Expanded

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


ExpandedImage Field

[image]
Gizmox.WebGUI.Common
ExpandedImage Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : ExpandedImage Field

Syntax

Visual Basic (Declaration)
Public Shared ExpandedImage As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.ExpandedImage

WGAttributes.ExpandedImage = value
C#
public static string ExpandedImage
Managed Extensions for C++
public: static string* ExpandedImage
C++/CLI
public:
static String^ ExpandedImage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


FirstDayOfWeek Field

[image]
Gizmox.WebGUI.Common
FirstDayOfWeek Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : FirstDayOfWeek Field

Syntax

Visual Basic (Declaration)
Public Shared FirstDayOfWeek As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.FirstDayOfWeek

WGAttributes.FirstDayOfWeek = value
C#
public static string FirstDayOfWeek
Managed Extensions for C++
public: static string* FirstDayOfWeek
C++/CLI
public:
static String^ FirstDayOfWeek

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


FlowDirection Field

[image]
Gizmox.WebGUI.Common
FlowDirection Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : FlowDirection Field

Syntax

Visual Basic (Declaration)
Public Shared FlowDirection As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.FlowDirection

WGAttributes.FlowDirection = value
C#
public static string FlowDirection
Managed Extensions for C++
public: static string* FlowDirection
C++/CLI
public:
static String^ FlowDirection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


Focus Field

[image]
Gizmox.WebGUI.Common
Focus Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : Focus Field

Syntax

Visual Basic (Declaration)
Public Shared Focus As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.Focus

WGAttributes.Focus = value
C#
public static string Focus
Managed Extensions for C++
public: static string* Focus
C++/CLI
public:
static String^ Focus

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


Focused Field

[image]
Gizmox.WebGUI.Common
Focused Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : Focused Field

Syntax

Visual Basic (Declaration)
Public Shared Focused As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.Focused

WGAttributes.Focused = value
C#
public static string Focused
Managed Extensions for C++
public: static string* Focused
C++/CLI
public:
static String^ Focused

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


Font Field

[image]
Gizmox.WebGUI.Common
Font Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : Font Field

Syntax

Visual Basic (Declaration)
Public Shared Font As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.Font

WGAttributes.Font = value
C#
public static string Font
Managed Extensions for C++
public: static string* Font
C++/CLI
public:
static String^ Font

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


Fore Field

[image]
Gizmox.WebGUI.Common
Fore Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : Fore Field

Syntax

Visual Basic (Declaration)
Public Shared Fore As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.Fore

WGAttributes.Fore = value
C#
public static string Fore
Managed Extensions for C++
public: static string* Fore
C++/CLI
public:
static String^ Fore

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


Format Field

[image]
Gizmox.WebGUI.Common
Format Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : Format Field

Syntax

Visual Basic (Declaration)
Public Shared Format As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.Format

WGAttributes.Format = value
C#
public static string Format
Managed Extensions for C++
public: static string* Format
C++/CLI
public:
static String^ Format

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


FormBorderStyle Field

[image]
Gizmox.WebGUI.Common
FormBorderStyle Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : FormBorderStyle Field

Syntax

Visual Basic (Declaration)
Public Shared FormBorderStyle As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.FormBorderStyle

WGAttributes.FormBorderStyle = value
C#
public static string FormBorderStyle
Managed Extensions for C++
public: static string* FormBorderStyle
C++/CLI
public:
static String^ FormBorderStyle

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


FormSize Field

[image]
Gizmox.WebGUI.Common
FormSize Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : FormSize Field

Syntax

Visual Basic (Declaration)
Public Shared FormSize As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.FormSize

WGAttributes.FormSize = value
C#
public static string FormSize
Managed Extensions for C++
public: static string* FormSize
C++/CLI
public:
static String^ FormSize

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


FormStartPosition Field

[image]
Gizmox.WebGUI.Common
FormStartPosition Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : FormStartPosition Field

Syntax

Visual Basic (Declaration)
Public Shared FormStartPosition As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.FormStartPosition

WGAttributes.FormStartPosition = value
C#
public static string FormStartPosition
Managed Extensions for C++
public: static string* FormStartPosition
C++/CLI
public:
static String^ FormStartPosition

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


Frequency Field

[image]
Gizmox.WebGUI.Common
Frequency Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : Frequency Field

Syntax

Visual Basic (Declaration)
Public Shared Frequency As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.Frequency

WGAttributes.Frequency = value
C#
public static string Frequency
Managed Extensions for C++
public: static string* Frequency
C++/CLI
public:
static String^ Frequency

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


Frozen Field

[image]
Gizmox.WebGUI.Common
Frozen Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : Frozen Field

Syntax

Visual Basic (Declaration)
Public Shared Frozen As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.Frozen

WGAttributes.Frozen = value
C#
public static string Frozen
Managed Extensions for C++
public: static string* Frozen
C++/CLI
public:
static String^ Frozen

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


FullRowSelect Field

[image]
Gizmox.WebGUI.Common
FullRowSelect Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : FullRowSelect Field

Syntax

Visual Basic (Declaration)
Public Shared FullRowSelect As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.FullRowSelect

WGAttributes.FullRowSelect = value
C#
public static string FullRowSelect
Managed Extensions for C++
public: static string* FullRowSelect
C++/CLI
public:
static String^ FullRowSelect

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


GridLines Field

[image]
Gizmox.WebGUI.Common
GridLines Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : GridLines Field

Syntax

Visual Basic (Declaration)
Public Shared GridLines As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.GridLines

WGAttributes.GridLines = value
C#
public static string GridLines
Managed Extensions for C++
public: static string* GridLines
C++/CLI
public:
static String^ GridLines

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


GrowStyle Field

[image]
Gizmox.WebGUI.Common
GrowStyle Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : GrowStyle Field

Syntax

Visual Basic (Declaration)
Public Shared GrowStyle As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.GrowStyle

WGAttributes.GrowStyle = value
C#
public static string GrowStyle
Managed Extensions for C++
public: static string* GrowStyle
C++/CLI
public:
static String^ GrowStyle

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


HasChecked Field

[image]
Gizmox.WebGUI.Common
HasChecked Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : HasChecked Field

Syntax

Visual Basic (Declaration)
Public Shared HasChecked As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.HasChecked

WGAttributes.HasChecked = value
C#
public static string HasChecked
Managed Extensions for C++
public: static string* HasChecked
C++/CLI
public:
static String^ HasChecked

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


HasNodes Field

[image]
Gizmox.WebGUI.Common
HasNodes Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : HasNodes Field

Syntax

Visual Basic (Declaration)
Public Shared HasNodes As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.HasNodes

WGAttributes.HasNodes = value
C#
public static string HasNodes
Managed Extensions for C++
public: static string* HasNodes
C++/CLI
public:
static String^ HasNodes

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


HasRedrawingParent Field

[image]
Gizmox.WebGUI.Common
HasRedrawingParent Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : HasRedrawingParent Field

Syntax

Visual Basic (Declaration)
Public Shared HasRedrawingParent As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.HasRedrawingParent

WGAttributes.HasRedrawingParent = value
C#
public static string HasRedrawingParent
Managed Extensions for C++
public: static string* HasRedrawingParent
C++/CLI
public:
static String^ HasRedrawingParent

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


HasSelected Field

[image]
Gizmox.WebGUI.Common
HasSelected Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : HasSelected Field

Syntax

Visual Basic (Declaration)
Public Shared HasSelected As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.HasSelected

WGAttributes.HasSelected = value
C#
public static string HasSelected
Managed Extensions for C++
public: static string* HasSelected
C++/CLI
public:
static String^ HasSelected

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


HeaderStyle Field

[image]
Gizmox.WebGUI.Common
HeaderStyle Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : HeaderStyle Field

Syntax

Visual Basic (Declaration)
Public Shared HeaderStyle As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.HeaderStyle

WGAttributes.HeaderStyle = value
C#
public static string HeaderStyle
Managed Extensions for C++
public: static string* HeaderStyle
C++/CLI
public:
static String^ HeaderStyle

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


Height Field

[image]
Gizmox.WebGUI.Common
Height Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : Height Field

Syntax

Visual Basic (Declaration)
Public Shared Height As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.Height

WGAttributes.Height = value
C#
public static string Height
Managed Extensions for C++
public: static string* Height
C++/CLI
public:
static String^ Height

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


HelpVisible Field

[image]
Gizmox.WebGUI.Common
HelpVisible Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : HelpVisible Field

Syntax

Visual Basic (Declaration)
Public Shared HelpVisible As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.HelpVisible

WGAttributes.HelpVisible = value
C#
public static string HelpVisible
Managed Extensions for C++
public: static string* HelpVisible
C++/CLI
public:
static String^ HelpVisible

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


Hexadecimal Field

[image]
Gizmox.WebGUI.Common
Hexadecimal Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : Hexadecimal Field

Syntax

Visual Basic (Declaration)
Public Shared Hexadecimal As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.Hexadecimal

WGAttributes.Hexadecimal = value
C#
public static string Hexadecimal
Managed Extensions for C++
public: static string* Hexadecimal
C++/CLI
public:
static String^ Hexadecimal

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


HideButtons Field

[image]
Gizmox.WebGUI.Common
HideButtons Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : HideButtons Field

Syntax

Visual Basic (Declaration)
Public Shared HideButtons As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.HideButtons

WGAttributes.HideButtons = value
C#
public static string HideButtons
Managed Extensions for C++
public: static string* HideButtons
C++/CLI
public:
static String^ HideButtons

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


HidePlusMinus Field

[image]
Gizmox.WebGUI.Common
HidePlusMinus Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : HidePlusMinus Field

Syntax

Visual Basic (Declaration)
Public Shared HidePlusMinus As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.HidePlusMinus

WGAttributes.HidePlusMinus = value
C#
public static string HidePlusMinus
Managed Extensions for C++
public: static string* HidePlusMinus
C++/CLI
public:
static String^ HidePlusMinus

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


HidePromptOnLeave Field

[image]
Gizmox.WebGUI.Common
HidePromptOnLeave Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : HidePromptOnLeave Field

Syntax

Visual Basic (Declaration)
Public Shared HidePromptOnLeave As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.HidePromptOnLeave

WGAttributes.HidePromptOnLeave = value
C#
public static string HidePromptOnLeave
Managed Extensions for C++
public: static string* HidePromptOnLeave
C++/CLI
public:
static String^ HidePromptOnLeave

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


HorizontalAlignment Field

[image]
Gizmox.WebGUI.Common
HorizontalAlignment Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : HorizontalAlignment Field

Syntax

Visual Basic (Declaration)
Public Shared HorizontalAlignment As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.HorizontalAlignment

WGAttributes.HorizontalAlignment = value
C#
public static string HorizontalAlignment
Managed Extensions for C++
public: static string* HorizontalAlignment
C++/CLI
public:
static String^ HorizontalAlignment

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


Icon Field

[image]
Gizmox.WebGUI.Common
Icon Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : Icon Field

Syntax

Visual Basic (Declaration)
Public Shared Icon As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.Icon

WGAttributes.Icon = value
C#
public static string Icon
Managed Extensions for C++
public: static string* Icon
C++/CLI
public:
static String^ Icon

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


Id Field

[image]
Gizmox.WebGUI.Common
Id Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : Id Field

Syntax

Visual Basic (Declaration)
Public Shared Id As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.Id

WGAttributes.Id = value
C#
public static string Id
Managed Extensions for C++
public: static string* Id
C++/CLI
public:
static String^ Id

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


IdentCount Field

[image]
Gizmox.WebGUI.Common
IdentCount Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : IdentCount Field

Syntax

Visual Basic (Declaration)
Public Shared IdentCount As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.IdentCount

WGAttributes.IdentCount = value
C#
public static string IdentCount
Managed Extensions for C++
public: static string* IdentCount
C++/CLI
public:
static String^ IdentCount

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


Image Field

[image]
Gizmox.WebGUI.Common
Image Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : Image Field

Syntax

Visual Basic (Declaration)
Public Shared Image As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.Image

WGAttributes.Image = value
C#
public static string Image
Managed Extensions for C++
public: static string* Image
C++/CLI
public:
static String^ Image

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


ImageAlign Field

[image]
Gizmox.WebGUI.Common
ImageAlign Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : ImageAlign Field

Syntax

Visual Basic (Declaration)
Public Shared ImageAlign As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.ImageAlign

WGAttributes.ImageAlign = value
C#
public static string ImageAlign
Managed Extensions for C++
public: static string* ImageAlign
C++/CLI
public:
static String^ ImageAlign

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


ImageHeight Field

[image]
Gizmox.WebGUI.Common
ImageHeight Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : ImageHeight Field

Syntax

Visual Basic (Declaration)
Public Shared ImageHeight As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.ImageHeight

WGAttributes.ImageHeight = value
C#
public static string ImageHeight
Managed Extensions for C++
public: static string* ImageHeight
C++/CLI
public:
static String^ ImageHeight

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


ImageSize Field

[image]
Gizmox.WebGUI.Common
ImageSize Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : ImageSize Field

Syntax

Visual Basic (Declaration)
Public Shared ImageSize As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.ImageSize

WGAttributes.ImageSize = value
C#
public static string ImageSize
Managed Extensions for C++
public: static string* ImageSize
C++/CLI
public:
static String^ ImageSize

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


ImageWidth Field

[image]
Gizmox.WebGUI.Common
ImageWidth Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : ImageWidth Field

Syntax

Visual Basic (Declaration)
Public Shared ImageWidth As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.ImageWidth

WGAttributes.ImageWidth = value
C#
public static string ImageWidth
Managed Extensions for C++
public: static string* ImageWidth
C++/CLI
public:
static String^ ImageWidth

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


Increment Field

[image]
Gizmox.WebGUI.Common
Increment Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : Increment Field

Syntax

Visual Basic (Declaration)
Public Shared Increment As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.Increment

WGAttributes.Increment = value
C#
public static string Increment
Managed Extensions for C++
public: static string* Increment
C++/CLI
public:
static String^ Increment

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


Index Field

[image]
Gizmox.WebGUI.Common
Index Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : Index Field

Syntax

Visual Basic (Declaration)
Public Shared Index As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.Index

WGAttributes.Index = value
C#
public static string Index
Managed Extensions for C++
public: static string* Index
C++/CLI
public:
static String^ Index

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


InValidateMessage Field

[image]
Gizmox.WebGUI.Common
InValidateMessage Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : InValidateMessage Field

Syntax

Visual Basic (Declaration)
Public Shared InValidateMessage As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.InValidateMessage

WGAttributes.InValidateMessage = value
C#
public static string InValidateMessage
Managed Extensions for C++
public: static string* InValidateMessage
C++/CLI
public:
static String^ InValidateMessage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


IsDlayedDrawing Field

[image]
Gizmox.WebGUI.Common
IsDlayedDrawing Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : IsDlayedDrawing Field

Syntax

Visual Basic (Declaration)
Public Shared IsDlayedDrawing As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.IsDlayedDrawing

WGAttributes.IsDlayedDrawing = value
C#
public static string IsDlayedDrawing
Managed Extensions for C++
public: static string* IsDlayedDrawing
C++/CLI
public:
static String^ IsDlayedDrawing

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


IsMdiContainer Field

[image]
Gizmox.WebGUI.Common
IsMdiContainer Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : IsMdiContainer Field

Syntax

Visual Basic (Declaration)
Public Shared IsMdiContainer As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.IsMdiContainer

WGAttributes.IsMdiContainer = value
C#
public static string IsMdiContainer
Managed Extensions for C++
public: static string* IsMdiContainer
C++/CLI
public:
static String^ IsMdiContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


IsNew Field

[image]
Gizmox.WebGUI.Common
IsNew Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : IsNew Field

Syntax

Visual Basic (Declaration)
Public Shared IsNew As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.IsNew

WGAttributes.IsNew = value
C#
public static string IsNew
Managed Extensions for C++
public: static string* IsNew
C++/CLI
public:
static String^ IsNew

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


IsSplitterFixed Field

[image]
Gizmox.WebGUI.Common
IsSplitterFixed Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : IsSplitterFixed Field

Syntax

Visual Basic (Declaration)
Public Shared IsSplitterFixed As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.IsSplitterFixed

WGAttributes.IsSplitterFixed = value
C#
public static string IsSplitterFixed
Managed Extensions for C++
public: static string* IsSplitterFixed
C++/CLI
public:
static String^ IsSplitterFixed

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


IsWindowSized Field

[image]
Gizmox.WebGUI.Common
IsWindowSized Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : IsWindowSized Field

Syntax

Visual Basic (Declaration)
Public Shared IsWindowSized As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.IsWindowSized

WGAttributes.IsWindowSized = value
C#
public static string IsWindowSized
Managed Extensions for C++
public: static string* IsWindowSized
C++/CLI
public:
static String^ IsWindowSized

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


KeyCode Field

[image]
Gizmox.WebGUI.Common
KeyCode Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : KeyCode Field

Syntax

Visual Basic (Declaration)
Public Shared KeyCode As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.KeyCode

WGAttributes.KeyCode = value
C#
public static string KeyCode
Managed Extensions for C++
public: static string* KeyCode
C++/CLI
public:
static String^ KeyCode

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


KeyFilter Field

[image]
Gizmox.WebGUI.Common
KeyFilter Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : KeyFilter Field

Syntax

Visual Basic (Declaration)
Public Shared KeyFilter As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.KeyFilter

WGAttributes.KeyFilter = value
C#
public static string KeyFilter
Managed Extensions for C++
public: static string* KeyFilter
C++/CLI
public:
static String^ KeyFilter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


KeyState Field

[image]
Gizmox.WebGUI.Common
KeyState Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : KeyState Field

Syntax

Visual Basic (Declaration)
Public Shared KeyState As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.KeyState

WGAttributes.KeyState = value
C#
public static string KeyState
Managed Extensions for C++
public: static string* KeyState
C++/CLI
public:
static String^ KeyState

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


LabelEdit Field

[image]
Gizmox.WebGUI.Common
LabelEdit Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : LabelEdit Field

Syntax

Visual Basic (Declaration)
Public Shared LabelEdit As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.LabelEdit

WGAttributes.LabelEdit = value
C#
public static string LabelEdit
Managed Extensions for C++
public: static string* LabelEdit
C++/CLI
public:
static String^ LabelEdit

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


LablesColumnWidth Field

[image]
Gizmox.WebGUI.Common
LablesColumnWidth Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : LablesColumnWidth Field

Syntax

Visual Basic (Declaration)
Public Shared LablesColumnWidth As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.LablesColumnWidth

WGAttributes.LablesColumnWidth = value
C#
public static string LablesColumnWidth
Managed Extensions for C++
public: static string* LablesColumnWidth
C++/CLI
public:
static String^ LablesColumnWidth

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


LargeImage Field

[image]
Gizmox.WebGUI.Common
LargeImage Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : LargeImage Field

Syntax

Visual Basic (Declaration)
Public Shared LargeImage As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.LargeImage

WGAttributes.LargeImage = value
C#
public static string LargeImage
Managed Extensions for C++
public: static string* LargeImage
C++/CLI
public:
static String^ LargeImage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


LargeImageHeight Field

[image]
Gizmox.WebGUI.Common
LargeImageHeight Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : LargeImageHeight Field

Syntax

Visual Basic (Declaration)
Public Shared LargeImageHeight As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.LargeImageHeight

WGAttributes.LargeImageHeight = value
C#
public static string LargeImageHeight
Managed Extensions for C++
public: static string* LargeImageHeight
C++/CLI
public:
static String^ LargeImageHeight

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


LargeImageWidth Field

[image]
Gizmox.WebGUI.Common
LargeImageWidth Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : LargeImageWidth Field

Syntax

Visual Basic (Declaration)
Public Shared LargeImageWidth As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.LargeImageWidth

WGAttributes.LargeImageWidth = value
C#
public static string LargeImageWidth
Managed Extensions for C++
public: static string* LargeImageWidth
C++/CLI
public:
static String^ LargeImageWidth

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


LastEditCell Field

[image]
Gizmox.WebGUI.Common
LastEditCell Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : LastEditCell Field

Syntax

Visual Basic (Declaration)
Public Shared LastEditCell As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.LastEditCell

WGAttributes.LastEditCell = value
C#
public static string LastEditCell
Managed Extensions for C++
public: static string* LastEditCell
C++/CLI
public:
static String^ LastEditCell

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


LastRender Field

[image]
Gizmox.WebGUI.Common
LastRender Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : LastRender Field

Syntax

Visual Basic (Declaration)
Public Shared LastRender As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.LastRender

WGAttributes.LastRender = value
C#
public static string LastRender
Managed Extensions for C++
public: static string* LastRender
C++/CLI
public:
static String^ LastRender

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


Left Field

[image]
Gizmox.WebGUI.Common
Left Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : Left Field

Syntax

Visual Basic (Declaration)
Public Shared Left As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.Left

WGAttributes.Left = value
C#
public static string Left
Managed Extensions for C++
public: static string* Left
C++/CLI
public:
static String^ Left

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


Length Field

[image]
Gizmox.WebGUI.Common
Length Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : Length Field

Syntax

Visual Basic (Declaration)
Public Shared Length As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.Length

WGAttributes.Length = value
C#
public static string Length
Managed Extensions for C++
public: static string* Length
C++/CLI
public:
static String^ Length

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


LinkColor Field

[image]
Gizmox.WebGUI.Common
LinkColor Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : LinkColor Field

Syntax

Visual Basic (Declaration)
Public Shared LinkColor As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.LinkColor

WGAttributes.LinkColor = value
C#
public static string LinkColor
Managed Extensions for C++
public: static string* LinkColor
C++/CLI
public:
static String^ LinkColor

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


LinkState Field

[image]
Gizmox.WebGUI.Common
LinkState Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : LinkState Field

Syntax

Visual Basic (Declaration)
Public Shared LinkState As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.LinkState

WGAttributes.LinkState = value
C#
public static string LinkState
Managed Extensions for C++
public: static string* LinkState
C++/CLI
public:
static String^ LinkState

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


Loaded Field

[image]
Gizmox.WebGUI.Common
Loaded Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : Loaded Field

Syntax

Visual Basic (Declaration)
Public Shared Loaded As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.Loaded

WGAttributes.Loaded = value
C#
public static string Loaded
Managed Extensions for C++
public: static string* Loaded
C++/CLI
public:
static String^ Loaded

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


LoadingMessage Field

[image]
Gizmox.WebGUI.Common
LoadingMessage Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : LoadingMessage Field

Syntax

Visual Basic (Declaration)
Public Shared LoadingMessage As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.LoadingMessage

WGAttributes.LoadingMessage = value
C#
public static string LoadingMessage
Managed Extensions for C++
public: static string* LoadingMessage
C++/CLI
public:
static String^ LoadingMessage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


Mapping Field

[image]
Gizmox.WebGUI.Common
Mapping Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : Mapping Field

Syntax

Visual Basic (Declaration)
Public Shared Mapping As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.Mapping

WGAttributes.Mapping = value
C#
public static string Mapping
Managed Extensions for C++
public: static string* Mapping
C++/CLI
public:
static String^ Mapping

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


MarginAll Field

[image]
Gizmox.WebGUI.Common
MarginAll Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : MarginAll Field

Syntax

Visual Basic (Declaration)
Public Shared MarginAll As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.MarginAll

WGAttributes.MarginAll = value
C#
public static string MarginAll
Managed Extensions for C++
public: static string* MarginAll
C++/CLI
public:
static String^ MarginAll

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


MarginBottom Field

[image]
Gizmox.WebGUI.Common
MarginBottom Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : MarginBottom Field

Syntax

Visual Basic (Declaration)
Public Shared MarginBottom As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.MarginBottom

WGAttributes.MarginBottom = value
C#
public static string MarginBottom
Managed Extensions for C++
public: static string* MarginBottom
C++/CLI
public:
static String^ MarginBottom

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


MarginLeft Field

[image]
Gizmox.WebGUI.Common
MarginLeft Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : MarginLeft Field

Syntax

Visual Basic (Declaration)
Public Shared MarginLeft As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.MarginLeft

WGAttributes.MarginLeft = value
C#
public static string MarginLeft
Managed Extensions for C++
public: static string* MarginLeft
C++/CLI
public:
static String^ MarginLeft

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


MarginRight Field

[image]
Gizmox.WebGUI.Common
MarginRight Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : MarginRight Field

Syntax

Visual Basic (Declaration)
Public Shared MarginRight As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.MarginRight

WGAttributes.MarginRight = value
C#
public static string MarginRight
Managed Extensions for C++
public: static string* MarginRight
C++/CLI
public:
static String^ MarginRight

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


MarginTop Field

[image]
Gizmox.WebGUI.Common
MarginTop Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : MarginTop Field

Syntax

Visual Basic (Declaration)
Public Shared MarginTop As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.MarginTop

WGAttributes.MarginTop = value
C#
public static string MarginTop
Managed Extensions for C++
public: static string* MarginTop
C++/CLI
public:
static String^ MarginTop

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


MaxDate Field

[image]
Gizmox.WebGUI.Common
MaxDate Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : MaxDate Field

Syntax

Visual Basic (Declaration)
Public Shared MaxDate As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.MaxDate

WGAttributes.MaxDate = value
C#
public static string MaxDate
Managed Extensions for C++
public: static string* MaxDate
C++/CLI
public:
static String^ MaxDate

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


Maximize Field

[image]
Gizmox.WebGUI.Common
Maximize Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : Maximize Field

Syntax

Visual Basic (Declaration)
Public Shared Maximize As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.Maximize

WGAttributes.Maximize = value
C#
public static string Maximize
Managed Extensions for C++
public: static string* Maximize
C++/CLI
public:
static String^ Maximize

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


Maximum Field

[image]
Gizmox.WebGUI.Common
Maximum Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : Maximum Field

Syntax

Visual Basic (Declaration)
Public Shared Maximum As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.Maximum

WGAttributes.Maximum = value
C#
public static string Maximum
Managed Extensions for C++
public: static string* Maximum
C++/CLI
public:
static String^ Maximum

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


MaximumHeight Field

[image]
Gizmox.WebGUI.Common
MaximumHeight Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : MaximumHeight Field

Syntax

Visual Basic (Declaration)
Public Shared MaximumHeight As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.MaximumHeight

WGAttributes.MaximumHeight = value
C#
public static string MaximumHeight
Managed Extensions for C++
public: static string* MaximumHeight
C++/CLI
public:
static String^ MaximumHeight

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


MaximumWidth Field

[image]
Gizmox.WebGUI.Common
MaximumWidth Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : MaximumWidth Field

Syntax

Visual Basic (Declaration)
Public Shared MaximumWidth As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.MaximumWidth

WGAttributes.MaximumWidth = value
C#
public static string MaximumWidth
Managed Extensions for C++
public: static string* MaximumWidth
C++/CLI
public:
static String^ MaximumWidth

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


MaxLength Field

[image]
Gizmox.WebGUI.Common
MaxLength Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : MaxLength Field

Syntax

Visual Basic (Declaration)
Public Shared MaxLength As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.MaxLength

WGAttributes.MaxLength = value
C#
public static string MaxLength
Managed Extensions for C++
public: static string* MaxLength
C++/CLI
public:
static String^ MaxLength

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


MdiParent Field

[image]
Gizmox.WebGUI.Common
MdiParent Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : MdiParent Field

Syntax

Visual Basic (Declaration)
Public Shared MdiParent As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.MdiParent

WGAttributes.MdiParent = value
C#
public static string MdiParent
Managed Extensions for C++
public: static string* MdiParent
C++/CLI
public:
static String^ MdiParent

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


Member Field

[image]
Gizmox.WebGUI.Common
Member Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : Member Field

Syntax

Visual Basic (Declaration)
Public Shared Member As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.Member

WGAttributes.Member = value
C#
public static string Member
Managed Extensions for C++
public: static string* Member
C++/CLI
public:
static String^ Member

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


MemberID Field

[image]
Gizmox.WebGUI.Common
MemberID Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : MemberID Field

Syntax

Visual Basic (Declaration)
Public Shared MemberID As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.MemberID

WGAttributes.MemberID = value
C#
public static string MemberID
Managed Extensions for C++
public: static string* MemberID
C++/CLI
public:
static String^ MemberID

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


Menu Field

[image]
Gizmox.WebGUI.Common
Menu Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : Menu Field

Syntax

Visual Basic (Declaration)
Public Shared Menu As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.Menu

WGAttributes.Menu = value
C#
public static string Menu
Managed Extensions for C++
public: static string* Menu
C++/CLI
public:
static String^ Menu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


Message Field

[image]
Gizmox.WebGUI.Common
Message Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : Message Field

Syntax

Visual Basic (Declaration)
Public Shared Message As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.Message

WGAttributes.Message = value
C#
public static string Message
Managed Extensions for C++
public: static string* Message
C++/CLI
public:
static String^ Message

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


MinDate Field

[image]
Gizmox.WebGUI.Common
MinDate Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : MinDate Field

Syntax

Visual Basic (Declaration)
Public Shared MinDate As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.MinDate

WGAttributes.MinDate = value
C#
public static string MinDate
Managed Extensions for C++
public: static string* MinDate
C++/CLI
public:
static String^ MinDate

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


Minimize Field

[image]
Gizmox.WebGUI.Common
Minimize Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : Minimize Field

Syntax

Visual Basic (Declaration)
Public Shared Minimize As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.Minimize

WGAttributes.Minimize = value
C#
public static string Minimize
Managed Extensions for C++
public: static string* Minimize
C++/CLI
public:
static String^ Minimize

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


Minimum Field

[image]
Gizmox.WebGUI.Common
Minimum Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : Minimum Field

Syntax

Visual Basic (Declaration)
Public Shared Minimum As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.Minimum

WGAttributes.Minimum = value
C#
public static string Minimum
Managed Extensions for C++
public: static string* Minimum
C++/CLI
public:
static String^ Minimum

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


MinimumHeight Field

[image]
Gizmox.WebGUI.Common
MinimumHeight Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : MinimumHeight Field

Syntax

Visual Basic (Declaration)
Public Shared MinimumHeight As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.MinimumHeight

WGAttributes.MinimumHeight = value
C#
public static string MinimumHeight
Managed Extensions for C++
public: static string* MinimumHeight
C++/CLI
public:
static String^ MinimumHeight

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


MinimumWidth Field

[image]
Gizmox.WebGUI.Common
MinimumWidth Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : MinimumWidth Field

Syntax

Visual Basic (Declaration)
Public Shared MinimumWidth As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.MinimumWidth

WGAttributes.MinimumWidth = value
C#
public static string MinimumWidth
Managed Extensions for C++
public: static string* MinimumWidth
C++/CLI
public:
static String^ MinimumWidth

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


Mode Field

[image]
Gizmox.WebGUI.Common
Mode Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : Mode Field

Syntax

Visual Basic (Declaration)
Public Shared Mode As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.Mode

WGAttributes.Mode = value
C#
public static string Mode
Managed Extensions for C++
public: static string* Mode
C++/CLI
public:
static String^ Mode

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


Movie Field

[image]
Gizmox.WebGUI.Common
Movie Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : Movie Field

Syntax

Visual Basic (Declaration)
Public Shared Movie As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.Movie

WGAttributes.Movie = value
C#
public static string Movie
Managed Extensions for C++
public: static string* Movie
C++/CLI
public:
static String^ Movie

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


Multiline Field

[image]
Gizmox.WebGUI.Common
Multiline Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : Multiline Field

Syntax

Visual Basic (Declaration)
Public Shared Multiline As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.Multiline

WGAttributes.Multiline = value
C#
public static string Multiline
Managed Extensions for C++
public: static string* Multiline
C++/CLI
public:
static String^ Multiline

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


Multiple Field

[image]
Gizmox.WebGUI.Common
Multiple Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : Multiple Field

Syntax

Visual Basic (Declaration)
Public Shared Multiple As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.Multiple

WGAttributes.Multiple = value
C#
public static string Multiple
Managed Extensions for C++
public: static string* Multiple
C++/CLI
public:
static String^ Multiple

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


Name Field

[image]
Gizmox.WebGUI.Common
Name Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : Name Field

Syntax

Visual Basic (Declaration)
Public Shared Name As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.Name

WGAttributes.Name = value
C#
public static string Name
Managed Extensions for C++
public: static string* Name
C++/CLI
public:
static String^ Name

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


ObjectClassId Field

[image]
Gizmox.WebGUI.Common
ObjectClassId Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : ObjectClassId Field

Syntax

Visual Basic (Declaration)
Public Shared ObjectClassId As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.ObjectClassId

WGAttributes.ObjectClassId = value
C#
public static string ObjectClassId
Managed Extensions for C++
public: static string* ObjectClassId
C++/CLI
public:
static String^ ObjectClassId

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


ObjectCodeBase Field

[image]
Gizmox.WebGUI.Common
ObjectCodeBase Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : ObjectCodeBase Field

Syntax

Visual Basic (Declaration)
Public Shared ObjectCodeBase As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.ObjectCodeBase

WGAttributes.ObjectCodeBase = value
C#
public static string ObjectCodeBase
Managed Extensions for C++
public: static string* ObjectCodeBase
C++/CLI
public:
static String^ ObjectCodeBase

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


ObjectPluginsPageType Field

[image]
Gizmox.WebGUI.Common
ObjectPluginsPageType Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : ObjectPluginsPageType Field

Syntax

Visual Basic (Declaration)
Public Shared ObjectPluginsPageType As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.ObjectPluginsPageType

WGAttributes.ObjectPluginsPageType = value
C#
public static string ObjectPluginsPageType
Managed Extensions for C++
public: static string* ObjectPluginsPageType
C++/CLI
public:
static String^ ObjectPluginsPageType

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


ObjectType Field

[image]
Gizmox.WebGUI.Common
ObjectType Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : ObjectType Field

Syntax

Visual Basic (Declaration)
Public Shared ObjectType As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.ObjectType

WGAttributes.ObjectType = value
C#
public static string ObjectType
Managed Extensions for C++
public: static string* ObjectType
C++/CLI
public:
static String^ ObjectType

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


Opacity Field

[image]
Gizmox.WebGUI.Common
Opacity Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : Opacity Field

Syntax

Visual Basic (Declaration)
Public Shared Opacity As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.Opacity

WGAttributes.Opacity = value
C#
public static string Opacity
Managed Extensions for C++
public: static string* Opacity
C++/CLI
public:
static String^ Opacity

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


Orientation Field

[image]
Gizmox.WebGUI.Common
Orientation Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : Orientation Field

Syntax

Visual Basic (Declaration)
Public Shared Orientation As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.Orientation

WGAttributes.Orientation = value
C#
public static string Orientation
Managed Extensions for C++
public: static string* Orientation
C++/CLI
public:
static String^ Orientation

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


OwnerID Field

[image]
Gizmox.WebGUI.Common
OwnerID Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : OwnerID Field

Syntax

Visual Basic (Declaration)
Public Shared OwnerID As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.OwnerID

WGAttributes.OwnerID = value
C#
public static string OwnerID
Managed Extensions for C++
public: static string* OwnerID
C++/CLI
public:
static String^ OwnerID

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


PaddingAll Field

[image]
Gizmox.WebGUI.Common
PaddingAll Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : PaddingAll Field

Syntax

Visual Basic (Declaration)
Public Shared PaddingAll As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.PaddingAll

WGAttributes.PaddingAll = value
C#
public static string PaddingAll
Managed Extensions for C++
public: static string* PaddingAll
C++/CLI
public:
static String^ PaddingAll

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


PaddingBottom Field

[image]
Gizmox.WebGUI.Common
PaddingBottom Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : PaddingBottom Field

Syntax

Visual Basic (Declaration)
Public Shared PaddingBottom As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.PaddingBottom

WGAttributes.PaddingBottom = value
C#
public static string PaddingBottom
Managed Extensions for C++
public: static string* PaddingBottom
C++/CLI
public:
static String^ PaddingBottom

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


PaddingLeft Field

[image]
Gizmox.WebGUI.Common
PaddingLeft Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : PaddingLeft Field

Syntax

Visual Basic (Declaration)
Public Shared PaddingLeft As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.PaddingLeft

WGAttributes.PaddingLeft = value
C#
public static string PaddingLeft
Managed Extensions for C++
public: static string* PaddingLeft
C++/CLI
public:
static String^ PaddingLeft

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


PaddingRight Field

[image]
Gizmox.WebGUI.Common
PaddingRight Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : PaddingRight Field

Syntax

Visual Basic (Declaration)
Public Shared PaddingRight As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.PaddingRight

WGAttributes.PaddingRight = value
C#
public static string PaddingRight
Managed Extensions for C++
public: static string* PaddingRight
C++/CLI
public:
static String^ PaddingRight

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


PaddingTop Field

[image]
Gizmox.WebGUI.Common
PaddingTop Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : PaddingTop Field

Syntax

Visual Basic (Declaration)
Public Shared PaddingTop As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.PaddingTop

WGAttributes.PaddingTop = value
C#
public static string PaddingTop
Managed Extensions for C++
public: static string* PaddingTop
C++/CLI
public:
static String^ PaddingTop

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


Password Field

[image]
Gizmox.WebGUI.Common
Password Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : Password Field

Syntax

Visual Basic (Declaration)
Public Shared Password As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.Password

WGAttributes.Password = value
C#
public static string Password
Managed Extensions for C++
public: static string* Password
C++/CLI
public:
static String^ Password

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


PromptChar Field

[image]
Gizmox.WebGUI.Common
PromptChar Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : PromptChar Field

Syntax

Visual Basic (Declaration)
Public Shared PromptChar As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.PromptChar

WGAttributes.PromptChar = value
C#
public static string PromptChar
Managed Extensions for C++
public: static string* PromptChar
C++/CLI
public:
static String^ PromptChar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


Pushed Field

[image]
Gizmox.WebGUI.Common
Pushed Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : Pushed Field

Syntax

Visual Basic (Declaration)
Public Shared Pushed As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.Pushed

WGAttributes.Pushed = value
C#
public static string Pushed
Managed Extensions for C++
public: static string* Pushed
C++/CLI
public:
static String^ Pushed

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


Quality Field

[image]
Gizmox.WebGUI.Common
Quality Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : Quality Field

Syntax

Visual Basic (Declaration)
Public Shared Quality As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.Quality

WGAttributes.Quality = value
C#
public static string Quality
Managed Extensions for C++
public: static string* Quality
C++/CLI
public:
static String^ Quality

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


RadioButtons Field

[image]
Gizmox.WebGUI.Common
RadioButtons Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : RadioButtons Field

Syntax

Visual Basic (Declaration)
Public Shared RadioButtons As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.RadioButtons

WGAttributes.RadioButtons = value
C#
public static string RadioButtons
Managed Extensions for C++
public: static string* RadioButtons
C++/CLI
public:
static String^ RadioButtons

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


RaiseUnloadEvent Field

[image]
Gizmox.WebGUI.Common
RaiseUnloadEvent Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : RaiseUnloadEvent Field

Syntax

Visual Basic (Declaration)
Public Shared RaiseUnloadEvent As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.RaiseUnloadEvent

WGAttributes.RaiseUnloadEvent = value
C#
public static string RaiseUnloadEvent
Managed Extensions for C++
public: static string* RaiseUnloadEvent
C++/CLI
public:
static String^ RaiseUnloadEvent

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


ReadOnly Field

[image]
Gizmox.WebGUI.Common
ReadOnly Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : ReadOnly Field

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.ReadOnly

WGAttributes.ReadOnly = value
C#
public static string ReadOnly
Managed Extensions for C++
public: static string* ReadOnly
C++/CLI
public:
static String^ ReadOnly

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


Redraw Field

[image]
Gizmox.WebGUI.Common
Redraw Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : Redraw Field

Syntax

Visual Basic (Declaration)
Public Shared Redraw As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.Redraw

WGAttributes.Redraw = value
C#
public static string Redraw
Managed Extensions for C++
public: static string* Redraw
C++/CLI
public:
static String^ Redraw

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


Resize Field

[image]
Gizmox.WebGUI.Common
Resize Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : Resize Field

Syntax

Visual Basic (Declaration)
Public Shared Resize As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.Resize

WGAttributes.Resize = value
C#
public static string Resize
Managed Extensions for C++
public: static string* Resize
C++/CLI
public:
static String^ Resize

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


Return Field

[image]
Gizmox.WebGUI.Common
Return Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : Return Field

Syntax

Visual Basic (Declaration)
Public Shared Return As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.Return

WGAttributes.Return = value
C#
public static string Return
Managed Extensions for C++
public: static string* Return
C++/CLI
public:
static String^ Return

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


Right Field

[image]
Gizmox.WebGUI.Common
Right Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : Right Field

Syntax

Visual Basic (Declaration)
Public Shared Right As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.Right

WGAttributes.Right = value
C#
public static string Right
Managed Extensions for C++
public: static string* Right
C++/CLI
public:
static String^ Right

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


Rotation Field

[image]
Gizmox.WebGUI.Common
Rotation Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : Rotation Field

Syntax

Visual Basic (Declaration)
Public Shared Rotation As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.Rotation

WGAttributes.Rotation = value
C#
public static string Rotation
Managed Extensions for C++
public: static string* Rotation
C++/CLI
public:
static String^ Rotation

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


RowHeaders Field

[image]
Gizmox.WebGUI.Common
RowHeaders Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : RowHeaders Field

Syntax

Visual Basic (Declaration)
Public Shared RowHeaders As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.RowHeaders

WGAttributes.RowHeaders = value
C#
public static string RowHeaders
Managed Extensions for C++
public: static string* RowHeaders
C++/CLI
public:
static String^ RowHeaders

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


Rows Field

[image]
Gizmox.WebGUI.Common
Rows Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : Rows Field

Syntax

Visual Basic (Declaration)
Public Shared Rows As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.Rows

WGAttributes.Rows = value
C#
public static string Rows
Managed Extensions for C++
public: static string* Rows
C++/CLI
public:
static String^ Rows

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


Rowspan Field

[image]
Gizmox.WebGUI.Common
Rowspan Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : Rowspan Field

Syntax

Visual Basic (Declaration)
Public Shared Rowspan As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.Rowspan

WGAttributes.Rowspan = value
C#
public static string Rowspan
Managed Extensions for C++
public: static string* Rowspan
C++/CLI
public:
static String^ Rowspan

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


ScaleX Field

[image]
Gizmox.WebGUI.Common
ScaleX Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : ScaleX Field

Syntax

Visual Basic (Declaration)
Public Shared ScaleX As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.ScaleX

WGAttributes.ScaleX = value
C#
public static string ScaleX
Managed Extensions for C++
public: static string* ScaleX
C++/CLI
public:
static String^ ScaleX

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


ScaleY Field

[image]
Gizmox.WebGUI.Common
ScaleY Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : ScaleY Field

Syntax

Visual Basic (Declaration)
Public Shared ScaleY As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.ScaleY

WGAttributes.ScaleY = value
C#
public static string ScaleY
Managed Extensions for C++
public: static string* ScaleY
C++/CLI
public:
static String^ ScaleY

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


Scrollbars Field

[image]
Gizmox.WebGUI.Common
Scrollbars Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : Scrollbars Field

Syntax

Visual Basic (Declaration)
Public Shared Scrollbars As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.Scrollbars

WGAttributes.Scrollbars = value
C#
public static string Scrollbars
Managed Extensions for C++
public: static string* Scrollbars
C++/CLI
public:
static String^ Scrollbars

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


ScrollLeft Field

[image]
Gizmox.WebGUI.Common
ScrollLeft Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : ScrollLeft Field

Syntax

Visual Basic (Declaration)
Public Shared ScrollLeft As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.ScrollLeft

WGAttributes.ScrollLeft = value
C#
public static string ScrollLeft
Managed Extensions for C++
public: static string* ScrollLeft
C++/CLI
public:
static String^ ScrollLeft

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


ScrollTop Field

[image]
Gizmox.WebGUI.Common
ScrollTop Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : ScrollTop Field

Syntax

Visual Basic (Declaration)
Public Shared ScrollTop As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.ScrollTop

WGAttributes.ScrollTop = value
C#
public static string ScrollTop
Managed Extensions for C++
public: static string* ScrollTop
C++/CLI
public:
static String^ ScrollTop

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


Selectable Field

[image]
Gizmox.WebGUI.Common
Selectable Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : Selectable Field

Syntax

Visual Basic (Declaration)
Public Shared Selectable As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.Selectable

WGAttributes.Selectable = value
C#
public static string Selectable
Managed Extensions for C++
public: static string* Selectable
C++/CLI
public:
static String^ Selectable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


Selected Field

[image]
Gizmox.WebGUI.Common
Selected Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : Selected Field

Syntax

Visual Basic (Declaration)
Public Shared Selected As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.Selected

WGAttributes.Selected = value
C#
public static string Selected
Managed Extensions for C++
public: static string* Selected
C++/CLI
public:
static String^ Selected

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


SelectedImage Field

[image]
Gizmox.WebGUI.Common
SelectedImage Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : SelectedImage Field

Syntax

Visual Basic (Declaration)
Public Shared SelectedImage As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.SelectedImage

WGAttributes.SelectedImage = value
C#
public static string SelectedImage
Managed Extensions for C++
public: static string* SelectedImage
C++/CLI
public:
static String^ SelectedImage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


SelectionBackColor Field

[image]
Gizmox.WebGUI.Common
SelectionBackColor Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : SelectionBackColor Field

Syntax

Visual Basic (Declaration)
Public Shared SelectionBackColor As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.SelectionBackColor

WGAttributes.SelectionBackColor = value
C#
public static string SelectionBackColor
Managed Extensions for C++
public: static string* SelectionBackColor
C++/CLI
public:
static String^ SelectionBackColor

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


SelectionButtons Field

[image]
Gizmox.WebGUI.Common
SelectionButtons Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : SelectionButtons Field

Syntax

Visual Basic (Declaration)
Public Shared SelectionButtons As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.SelectionButtons

WGAttributes.SelectionButtons = value
C#
public static string SelectionButtons
Managed Extensions for C++
public: static string* SelectionButtons
C++/CLI
public:
static String^ SelectionButtons

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


SelectionForeColor Field

[image]
Gizmox.WebGUI.Common
SelectionForeColor Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : SelectionForeColor Field

Syntax

Visual Basic (Declaration)
Public Shared SelectionForeColor As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.SelectionForeColor

WGAttributes.SelectionForeColor = value
C#
public static string SelectionForeColor
Managed Extensions for C++
public: static string* SelectionForeColor
C++/CLI
public:
static String^ SelectionForeColor

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


SelectionIcons Field

[image]
Gizmox.WebGUI.Common
SelectionIcons Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : SelectionIcons Field

Syntax

Visual Basic (Declaration)
Public Shared SelectionIcons As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.SelectionIcons

WGAttributes.SelectionIcons = value
C#
public static string SelectionIcons
Managed Extensions for C++
public: static string* SelectionIcons
C++/CLI
public:
static String^ SelectionIcons

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


SelectionLength Field

[image]
Gizmox.WebGUI.Common
SelectionLength Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : SelectionLength Field

Syntax

Visual Basic (Declaration)
Public Shared SelectionLength As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.SelectionLength

WGAttributes.SelectionLength = value
C#
public static string SelectionLength
Managed Extensions for C++
public: static string* SelectionLength
C++/CLI
public:
static String^ SelectionLength

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


SelectionMode Field

[image]
Gizmox.WebGUI.Common
SelectionMode Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : SelectionMode Field

Syntax

Visual Basic (Declaration)
Public Shared SelectionMode As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.SelectionMode

WGAttributes.SelectionMode = value
C#
public static string SelectionMode
Managed Extensions for C++
public: static string* SelectionMode
C++/CLI
public:
static String^ SelectionMode

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


SelectionStart Field

[image]
Gizmox.WebGUI.Common
SelectionStart Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : SelectionStart Field

Syntax

Visual Basic (Declaration)
Public Shared SelectionStart As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.SelectionStart

WGAttributes.SelectionStart = value
C#
public static string SelectionStart
Managed Extensions for C++
public: static string* SelectionStart
C++/CLI
public:
static String^ SelectionStart

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


SelectOnRightClick Field

[image]
Gizmox.WebGUI.Common
SelectOnRightClick Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : SelectOnRightClick Field

Syntax

Visual Basic (Declaration)
Public Shared SelectOnRightClick As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.SelectOnRightClick

WGAttributes.SelectOnRightClick = value
C#
public static string SelectOnRightClick
Managed Extensions for C++
public: static string* SelectOnRightClick
C++/CLI
public:
static String^ SelectOnRightClick

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


ShiftKey Field

[image]
Gizmox.WebGUI.Common
ShiftKey Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : ShiftKey Field

Syntax

Visual Basic (Declaration)
Public Shared ShiftKey As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.ShiftKey

WGAttributes.ShiftKey = value
C#
public static string ShiftKey
Managed Extensions for C++
public: static string* ShiftKey
C++/CLI
public:
static String^ ShiftKey

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


Shortcut Field

[image]
Gizmox.WebGUI.Common
Shortcut Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : Shortcut Field

Syntax

Visual Basic (Declaration)
Public Shared Shortcut As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.Shortcut

WGAttributes.Shortcut = value
C#
public static string Shortcut
Managed Extensions for C++
public: static string* Shortcut
C++/CLI
public:
static String^ Shortcut

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


ShowLines Field

[image]
Gizmox.WebGUI.Common
ShowLines Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : ShowLines Field

Syntax

Visual Basic (Declaration)
Public Shared ShowLines As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.ShowLines

WGAttributes.ShowLines = value
C#
public static string ShowLines
Managed Extensions for C++
public: static string* ShowLines
C++/CLI
public:
static String^ ShowLines

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


ShowUpDown Field

[image]
Gizmox.WebGUI.Common
ShowUpDown Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : ShowUpDown Field

Syntax

Visual Basic (Declaration)
Public Shared ShowUpDown As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.ShowUpDown

WGAttributes.ShowUpDown = value
C#
public static string ShowUpDown
Managed Extensions for C++
public: static string* ShowUpDown
C++/CLI
public:
static String^ ShowUpDown

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


Size Field

[image]
Gizmox.WebGUI.Common
Size Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : Size Field

Syntax

Visual Basic (Declaration)
Public Shared Size As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.Size

WGAttributes.Size = value
C#
public static string Size
Managed Extensions for C++
public: static string* Size
C++/CLI
public:
static String^ Size

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


SkewX Field

[image]
Gizmox.WebGUI.Common
SkewX Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : SkewX Field

Syntax

Visual Basic (Declaration)
Public Shared SkewX As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.SkewX

WGAttributes.SkewX = value
C#
public static string SkewX
Managed Extensions for C++
public: static string* SkewX
C++/CLI
public:
static String^ SkewX

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


SkewY Field

[image]
Gizmox.WebGUI.Common
SkewY Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : SkewY Field

Syntax

Visual Basic (Declaration)
Public Shared SkewY As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.SkewY

WGAttributes.SkewY = value
C#
public static string SkewY
Managed Extensions for C++
public: static string* SkewY
C++/CLI
public:
static String^ SkewY

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


Sort Field

[image]
Gizmox.WebGUI.Common
Sort Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : Sort Field

Syntax

Visual Basic (Declaration)
Public Shared Sort As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.Sort

WGAttributes.Sort = value
C#
public static string Sort
Managed Extensions for C++
public: static string* Sort
C++/CLI
public:
static String^ Sort

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


SortedColumn Field

[image]
Gizmox.WebGUI.Common
SortedColumn Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : SortedColumn Field

Syntax

Visual Basic (Declaration)
Public Shared SortedColumn As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.SortedColumn

WGAttributes.SortedColumn = value
C#
public static string SortedColumn
Managed Extensions for C++
public: static string* SortedColumn
C++/CLI
public:
static String^ SortedColumn

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


SortOrder Field

[image]
Gizmox.WebGUI.Common
SortOrder Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : SortOrder Field

Syntax

Visual Basic (Declaration)
Public Shared SortOrder As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.SortOrder

WGAttributes.SortOrder = value
C#
public static string SortOrder
Managed Extensions for C++
public: static string* SortOrder
C++/CLI
public:
static String^ SortOrder

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


Source Field

[image]
Gizmox.WebGUI.Common
Source Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : Source Field

Syntax

Visual Basic (Declaration)
Public Shared Source As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.Source

WGAttributes.Source = value
C#
public static string Source
Managed Extensions for C++
public: static string* Source
C++/CLI
public:
static String^ Source

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


Style Field

[image]
Gizmox.WebGUI.Common
Style Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : Style Field

Syntax

Visual Basic (Declaration)
Public Shared Style As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.Style

WGAttributes.Style = value
C#
public static string Style
Managed Extensions for C++
public: static string* Style
C++/CLI
public:
static String^ Style

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


TabIndex Field

[image]
Gizmox.WebGUI.Common
TabIndex Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : TabIndex Field

Syntax

Visual Basic (Declaration)
Public Shared TabIndex As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.TabIndex

WGAttributes.TabIndex = value
C#
public static string TabIndex
Managed Extensions for C++
public: static string* TabIndex
C++/CLI
public:
static String^ TabIndex

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


Target Field

[image]
Gizmox.WebGUI.Common
Target Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : Target Field

Syntax

Visual Basic (Declaration)
Public Shared Target As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.Target

WGAttributes.Target = value
C#
public static string Target
Managed Extensions for C++
public: static string* Target
C++/CLI
public:
static String^ Target

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


TargetColumn Field

[image]
Gizmox.WebGUI.Common
TargetColumn Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : TargetColumn Field

Syntax

Visual Basic (Declaration)
Public Shared TargetColumn As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.TargetColumn

WGAttributes.TargetColumn = value
C#
public static string TargetColumn
Managed Extensions for C++
public: static string* TargetColumn
C++/CLI
public:
static String^ TargetColumn

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


Text Field

[image]
Gizmox.WebGUI.Common
Text Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : Text Field

Syntax

Visual Basic (Declaration)
Public Shared Text As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.Text

WGAttributes.Text = value
C#
public static string Text
Managed Extensions for C++
public: static string* Text
C++/CLI
public:
static String^ Text

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


TextAlign Field

[image]
Gizmox.WebGUI.Common
TextAlign Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : TextAlign Field

Syntax

Visual Basic (Declaration)
Public Shared TextAlign As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.TextAlign

WGAttributes.TextAlign = value
C#
public static string TextAlign
Managed Extensions for C++
public: static string* TextAlign
C++/CLI
public:
static String^ TextAlign

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


TextImageRelation Field

[image]
Gizmox.WebGUI.Common
TextImageRelation Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : TextImageRelation Field

Syntax

Visual Basic (Declaration)
Public Shared TextImageRelation As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.TextImageRelation

WGAttributes.TextImageRelation = value
C#
public static string TextImageRelation
Managed Extensions for C++
public: static string* TextImageRelation
C++/CLI
public:
static String^ TextImageRelation

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


ThousandsSeparator Field

[image]
Gizmox.WebGUI.Common
ThousandsSeparator Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : ThousandsSeparator Field

Syntax

Visual Basic (Declaration)
Public Shared ThousandsSeparator As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.ThousandsSeparator

WGAttributes.ThousandsSeparator = value
C#
public static string ThousandsSeparator
Managed Extensions for C++
public: static string* ThousandsSeparator
C++/CLI
public:
static String^ ThousandsSeparator

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


Timer Field

[image]
Gizmox.WebGUI.Common
Timer Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : Timer Field

Syntax

Visual Basic (Declaration)
Public Shared Timer As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.Timer

WGAttributes.Timer = value
C#
public static string Timer
Managed Extensions for C++
public: static string* Timer
C++/CLI
public:
static String^ Timer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


ToolBar Field

[image]
Gizmox.WebGUI.Common
ToolBar Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : ToolBar Field

Syntax

Visual Basic (Declaration)
Public Shared ToolBar As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.ToolBar

WGAttributes.ToolBar = value
C#
public static string ToolBar
Managed Extensions for C++
public: static string* ToolBar
C++/CLI
public:
static String^ ToolBar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


ToolTip Field

[image]
Gizmox.WebGUI.Common
ToolTip Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : ToolTip Field

Syntax

Visual Basic (Declaration)
Public Shared ToolTip As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.ToolTip

WGAttributes.ToolTip = value
C#
public static string ToolTip
Managed Extensions for C++
public: static string* ToolTip
C++/CLI
public:
static String^ ToolTip

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


Top Field

[image]
Gizmox.WebGUI.Common
Top Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : Top Field

Syntax

Visual Basic (Declaration)
Public Shared Top As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.Top

WGAttributes.Top = value
C#
public static string Top
Managed Extensions for C++
public: static string* Top
C++/CLI
public:
static String^ Top

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


TotalItems Field

[image]
Gizmox.WebGUI.Common
TotalItems Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : TotalItems Field

Syntax

Visual Basic (Declaration)
Public Shared TotalItems As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.TotalItems

WGAttributes.TotalItems = value
C#
public static string TotalItems
Managed Extensions for C++
public: static string* TotalItems
C++/CLI
public:
static String^ TotalItems

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


TotalPages Field

[image]
Gizmox.WebGUI.Common
TotalPages Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : TotalPages Field

Syntax

Visual Basic (Declaration)
Public Shared TotalPages As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.TotalPages

WGAttributes.TotalPages = value
C#
public static string TotalPages
Managed Extensions for C++
public: static string* TotalPages
C++/CLI
public:
static String^ TotalPages

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


Trace Field

[image]
Gizmox.WebGUI.Common
Trace Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : Trace Field

Syntax

Visual Basic (Declaration)
Public Shared Trace As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.Trace

WGAttributes.Trace = value
C#
public static string Trace
Managed Extensions for C++
public: static string* Trace
C++/CLI
public:
static String^ Trace

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


Type Field

[image]
Gizmox.WebGUI.Common
Type Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : Type Field

Syntax

Visual Basic (Declaration)
Public Shared Type As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.Type

WGAttributes.Type = value
C#
public static string Type
Managed Extensions for C++
public: static string* Type
C++/CLI
public:
static String^ Type

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


UseItemStyleForSubItems Field

[image]
Gizmox.WebGUI.Common
UseItemStyleForSubItems Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : UseItemStyleForSubItems Field

Syntax

Visual Basic (Declaration)
Public Shared UseItemStyleForSubItems As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.UseItemStyleForSubItems

WGAttributes.UseItemStyleForSubItems = value
C#
public static string UseItemStyleForSubItems
Managed Extensions for C++
public: static string* UseItemStyleForSubItems
C++/CLI
public:
static String^ UseItemStyleForSubItems

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


Value Field

[image]
Gizmox.WebGUI.Common
Value Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : Value Field

Syntax

Visual Basic (Declaration)
Public Shared Value As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.Value

WGAttributes.Value = value
C#
public static string Value
Managed Extensions for C++
public: static string* Value
C++/CLI
public:
static String^ Value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


ValueValidationExpression Field

[image]
Gizmox.WebGUI.Common
ValueValidationExpression Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : ValueValidationExpression Field

Syntax

Visual Basic (Declaration)
Public Shared ValueValidationExpression As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.ValueValidationExpression

WGAttributes.ValueValidationExpression = value
C#
public static string ValueValidationExpression
Managed Extensions for C++
public: static string* ValueValidationExpression
C++/CLI
public:
static String^ ValueValidationExpression

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


VerticalAlignment Field

[image]
Gizmox.WebGUI.Common
VerticalAlignment Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : VerticalAlignment Field

Syntax

Visual Basic (Declaration)
Public Shared VerticalAlignment As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.VerticalAlignment

WGAttributes.VerticalAlignment = value
C#
public static string VerticalAlignment
Managed Extensions for C++
public: static string* VerticalAlignment
C++/CLI
public:
static String^ VerticalAlignment

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


View Field

[image]
Gizmox.WebGUI.Common
View Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : View Field

Syntax

Visual Basic (Declaration)
Public Shared View As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.View

WGAttributes.View = value
C#
public static string View
Managed Extensions for C++
public: static string* View
C++/CLI
public:
static String^ View

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


Visible Field

[image]
Gizmox.WebGUI.Common
Visible Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : Visible Field

Syntax

Visual Basic (Declaration)
Public Shared Visible As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.Visible

WGAttributes.Visible = value
C#
public static string Visible
Managed Extensions for C++
public: static string* Visible
C++/CLI
public:
static String^ Visible

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


VisitedLinkColor Field

[image]
Gizmox.WebGUI.Common
VisitedLinkColor Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : VisitedLinkColor Field

Syntax

Visual Basic (Declaration)
Public Shared VisitedLinkColor As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.VisitedLinkColor

WGAttributes.VisitedLinkColor = value
C#
public static string VisitedLinkColor
Managed Extensions for C++
public: static string* VisitedLinkColor
C++/CLI
public:
static String^ VisitedLinkColor

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


Width Field

[image]
Gizmox.WebGUI.Common
Width Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : Width Field

Syntax

Visual Basic (Declaration)
Public Shared Width As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.Width

WGAttributes.Width = value
C#
public static string Width
Managed Extensions for C++
public: static string* Width
C++/CLI
public:
static String^ Width

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


Windowless Field

[image]
Gizmox.WebGUI.Common
Windowless Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : Windowless Field

Syntax

Visual Basic (Declaration)
Public Shared Windowless As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.Windowless

WGAttributes.Windowless = value
C#
public static string Windowless
Managed Extensions for C++
public: static string* Windowless
C++/CLI
public:
static String^ Windowless

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


WindowState Field

[image]
Gizmox.WebGUI.Common
WindowState Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : WindowState Field

Syntax

Visual Basic (Declaration)
Public Shared WindowState As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.WindowState

WGAttributes.WindowState = value
C#
public static string WindowState
Managed Extensions for C++
public: static string* WindowState
C++/CLI
public:
static String^ WindowState

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


WordWrap Field

[image]
Gizmox.WebGUI.Common
WordWrap Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : WordWrap Field

Syntax

Visual Basic (Declaration)
Public Shared WordWrap As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.WordWrap

WGAttributes.WordWrap = value
C#
public static string WordWrap
Managed Extensions for C++
public: static string* WordWrap
C++/CLI
public:
static String^ WordWrap

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


WrapContents Field

[image]
Gizmox.WebGUI.Common
WrapContents Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGAttributes Class : WrapContents Field

Syntax

Visual Basic (Declaration)
Public Shared WrapContents As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGAttributes.WrapContents

WGAttributes.WrapContents = value
C#
public static string WrapContents
Managed Extensions for C++
public: static string* WrapContents
C++/CLI
public:
static String^ WrapContents

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGAttributes Class
WGAttributes Members


WGConst Class

[image]
Gizmox.WebGUI.Common
WGConst Class
Members See Also Send Feedback
Gizmox.WebGUI Namespace : WGConst Class

Syntax

Visual Basic (Declaration)
Public Class WGConst
Visual Basic (Usage) Copy Code
Dim instance As WGConst
C#
public class WGConst
Managed Extensions for C++
public __gc class WGConst
C++/CLI
public ref class WGConst

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.WGConst

Requirements

Namespace: Gizmox.WebGUI

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

WGConst Members
Gizmox.WebGUI Namespace


WGConst Class Members

[image]
Gizmox.WebGUI.Common
WGConst Class Members
See Also Properties Send Feedback
Gizmox.WebGUI Namespace : WGConst Class

The following tables list the members exposed by WGConst.

Public Constructors

 | Name | Description
Public Constructor | WGConst Constructor |
Top

Public Properties

 | Name | Description
static (Shared in Visual Basic) | CacheVersion |
static (Shared in Visual Basic) | ControlsNamespace |
static (Shared in Visual Basic) | ControlsPrefix |
static (Shared in Visual Basic) | Namespace |
static (Shared in Visual Basic) | Prefix |
static (Shared in Visual Basic) | Version |
Top

See Also

Reference

WGConst Class
Gizmox.WebGUI Namespace


WGConst Constructor

[image]
Gizmox.WebGUI.Common
WGConst Constructor
See Also Send Feedback
Gizmox.WebGUI Namespace > WGConst Class : WGConst Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As WGConst()
C#
public WGConst()
Managed Extensions for C++
public: WGConst();
C++/CLI
public:
WGConst();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGConst Class
WGConst Members


WGConst Class Properties

[image]
Gizmox.WebGUI.Common
WGConst Class Properties
See Also Send Feedback
Gizmox.WebGUI Namespace : WGConst Class

For a list of all members of this type, see WGConst members.

Public Properties

 | Name | Description
static (Shared in Visual Basic) | CacheVersion |
static (Shared in Visual Basic) | ControlsNamespace |
static (Shared in Visual Basic) | ControlsPrefix |
static (Shared in Visual Basic) | Namespace |
static (Shared in Visual Basic) | Prefix |
static (Shared in Visual Basic) | Version |
Top

See Also

Reference

WGConst Class
Gizmox.WebGUI Namespace


CacheVersion Property

[image]
Gizmox.WebGUI.Common
CacheVersion Property
See Also Send Feedback
Gizmox.WebGUI Namespace > WGConst Class : CacheVersion Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property CacheVersion As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGConst.CacheVersion
C#
public static string CacheVersion {get;}
Managed Extensions for C++
public: __property static string* get_CacheVersion();
C++/CLI
public:
static property String^ CacheVersion {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGConst Class
WGConst Members


ControlsNamespace Property

[image]
Gizmox.WebGUI.Common
ControlsNamespace Property
See Also Send Feedback
Gizmox.WebGUI Namespace > WGConst Class : ControlsNamespace Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property ControlsNamespace As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGConst.ControlsNamespace
C#
public static string ControlsNamespace {get;}
Managed Extensions for C++
public: __property static string* get_ControlsNamespace();
C++/CLI
public:
static property String^ ControlsNamespace {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGConst Class
WGConst Members


ControlsPrefix Property

[image]
Gizmox.WebGUI.Common
ControlsPrefix Property
See Also Send Feedback
Gizmox.WebGUI Namespace > WGConst Class : ControlsPrefix Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property ControlsPrefix As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGConst.ControlsPrefix
C#
public static string ControlsPrefix {get;}
Managed Extensions for C++
public: __property static string* get_ControlsPrefix();
C++/CLI
public:
static property String^ ControlsPrefix {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGConst Class
WGConst Members


Namespace Property

[image]
Gizmox.WebGUI.Common
Namespace Property
See Also Send Feedback
Gizmox.WebGUI Namespace > WGConst Class : Namespace Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Namespace As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGConst.Namespace
C#
public static string Namespace {get;}
Managed Extensions for C++
public: __property static string* get_Namespace();
C++/CLI
public:
static property String^ Namespace {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGConst Class
WGConst Members


Prefix Property

[image]
Gizmox.WebGUI.Common
Prefix Property
See Also Send Feedback
Gizmox.WebGUI Namespace > WGConst Class : Prefix Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Prefix As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGConst.Prefix
C#
public static string Prefix {get;}
Managed Extensions for C++
public: __property static string* get_Prefix();
C++/CLI
public:
static property String^ Prefix {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGConst Class
WGConst Members


Version Property

[image]
Gizmox.WebGUI.Common
Version Property
See Also Send Feedback
Gizmox.WebGUI Namespace > WGConst Class : Version Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Version As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGConst.Version
C#
public static string Version {get;}
Managed Extensions for C++
public: __property static string* get_Version();
C++/CLI
public:
static property String^ Version {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGConst Class
WGConst Members


WGLabels Class

[image]
Gizmox.WebGUI.Common
WGLabels Class
Members See Also Send Feedback
Gizmox.WebGUI Namespace : WGLabels Class

Syntax

Visual Basic (Declaration)
Public Class WGLabels
Visual Basic (Usage) Copy Code
Dim instance As WGLabels
C#
public class WGLabels
Managed Extensions for C++
public __gc class WGLabels
C++/CLI
public ref class WGLabels

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.WGLabels

Requirements

Namespace: Gizmox.WebGUI

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

WGLabels Members
Gizmox.WebGUI Namespace


WGLabels Class Members

[image]
Gizmox.WebGUI.Common
WGLabels Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI Namespace : WGLabels Class

The following tables list the members exposed by WGLabels.

Public Constructors

 | Name | Description
Public Constructor | WGLabels Constructor |
Top

Public Properties

 | Name | Description
static (Shared in Visual Basic) | Abort |
static (Shared in Visual Basic) | Add |
static (Shared in Visual Basic) | Apply |
static (Shared in Visual Basic) | April |
static (Shared in Visual Basic) | AprilShort |
static (Shared in Visual Basic) | Ascending |
static (Shared in Visual Basic) | August |
static (Shared in Visual Basic) | AugustShort |
static (Shared in Visual Basic) | Back |
static (Shared in Visual Basic) | Cancel |
static (Shared in Visual Basic) | Clear |
static (Shared in Visual Basic) | Close |
static (Shared in Visual Basic) | Columns |
static (Shared in Visual Basic) | DatePicker |
static (Shared in Visual Basic) | December |
static (Shared in Visual Basic) | DecemberShort |
static (Shared in Visual Basic) | Decsending |
static (Shared in Visual Basic) | DirAttribute |
static (Shared in Visual Basic) | February |
static (Shared in Visual Basic) | FebruaryShort |
static (Shared in Visual Basic) | Finish |
static (Shared in Visual Basic) | Friday |
static (Shared in Visual Basic) | FridayShort |
static (Shared in Visual Basic) | Grouping |
static (Shared in Visual Basic) | Help |
static (Shared in Visual Basic) | Hide |
static (Shared in Visual Basic) | Ignore |
static (Shared in Visual Basic) | January |
static (Shared in Visual Basic) | JanuaryShort |
static (Shared in Visual Basic) | July |
static (Shared in Visual Basic) | JulyShort |
static (Shared in Visual Basic) | June |
static (Shared in Visual Basic) | JuneShort |
static (Shared in Visual Basic) | LeftAttribute |
static (Shared in Visual Basic) | Loading |
static (Shared in Visual Basic) | March |
static (Shared in Visual Basic) | MarchShort |
static (Shared in Visual Basic) | May |
static (Shared in Visual Basic) | MayShort |
static (Shared in Visual Basic) | Monday |
static (Shared in Visual Basic) | MondayShort |
static (Shared in Visual Basic) | MoveDown |
static (Shared in Visual Basic) | MoveUp |
static (Shared in Visual Basic) | Next |
static (Shared in Visual Basic) | No |
static (Shared in Visual Basic) | November |
static (Shared in Visual Basic) | NovemberShort |
static (Shared in Visual Basic) | October |
static (Shared in Visual Basic) | OctoberShort |
static (Shared in Visual Basic) | Ok |
static (Shared in Visual Basic) | Open |
static (Shared in Visual Basic) | Previous |
static (Shared in Visual Basic) | Remove |
static (Shared in Visual Basic) | Retry |
static (Shared in Visual Basic) | RightAttribute |
static (Shared in Visual Basic) | Saturday |
static (Shared in Visual Basic) | SaturdayShort |
static (Shared in Visual Basic) | Search |
static (Shared in Visual Basic) | SelectFilesToUpload |
static (Shared in Visual Basic) | September |
static (Shared in Visual Basic) | SeptemberShort |
static (Shared in Visual Basic) | Show |
static (Shared in Visual Basic) | Sorting |
static (Shared in Visual Basic) | Sunday |
static (Shared in Visual Basic) | SundayShort |
static (Shared in Visual Basic) | Thursday |
static (Shared in Visual Basic) | ThursdayShort |
static (Shared in Visual Basic) | Today |
static (Shared in Visual Basic) | Tuesday |
static (Shared in Visual Basic) | TuesdayShort |
static (Shared in Visual Basic) | View |
static (Shared in Visual Basic) | Wednesday |
static (Shared in Visual Basic) | WednesdayShort |
static (Shared in Visual Basic) | Yes |
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetLocalizedDayString |
static (Shared in Visual Basic) | GetLocalizedMonthString |
static (Shared in Visual Basic) | GetString | Overloaded.
Top

See Also

Reference

WGLabels Class
Gizmox.WebGUI Namespace


WGLabels Constructor

[image]
Gizmox.WebGUI.Common
WGLabels Constructor
See Also Send Feedback
Gizmox.WebGUI Namespace > WGLabels Class : WGLabels Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As WGLabels()
C#
public WGLabels()
Managed Extensions for C++
public: WGLabels();
C++/CLI
public:
WGLabels();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGLabels Class
WGLabels Members


WGLabels Class Methods

[image]
Gizmox.WebGUI.Common
WGLabels Class Methods
See Also Send Feedback
Gizmox.WebGUI Namespace : WGLabels Class

For a list of all members of this type, see WGLabels members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetLocalizedDayString |
static (Shared in Visual Basic) | GetLocalizedMonthString |
static (Shared in Visual Basic) | GetString | Overloaded.
Top

See Also

Reference

WGLabels Class
Gizmox.WebGUI Namespace


GetLocalizedDayString Method

[image]
Gizmox.WebGUI.Common
GetLocalizedDayString Method
See Also Send Feedback
Gizmox.WebGUI Namespace > WGLabels Class : GetLocalizedDayString Method

enmWeekDay
blnShort
objContext

Syntax

Visual Basic (Declaration)
Public Shared Function GetLocalizedDayString( _
   ByVal enmWeekDay As DayOfWeek, _
   ByVal blnShort As Boolean, _
   ByVal objContext As IContext _
) As String
Visual Basic (Usage) Copy Code
Dim enmWeekDay As DayOfWeek
Dim blnShort As Boolean
Dim objContext As IContext
Dim value As String

value = WGLabels.GetLocalizedDayString(enmWeekDay, blnShort, objContext)
C#
public static string GetLocalizedDayString(
   DayOfWeek enmWeekDay,
   bool blnShort,
   IContext objContext
)
Managed Extensions for C++
public: static string* GetLocalizedDayString(
   DayOfWeek enmWeekDay,
   bool blnShort,
   IContext* objContext
)
C++/CLI
public:
static String^ GetLocalizedDayString(
   DayOfWeek enmWeekDay,
   bool blnShort,
   IContext^ objContext
)

Parameters

enmWeekDay
blnShort
objContext

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGLabels Class
WGLabels Members


GetLocalizedMonthString Method

[image]
Gizmox.WebGUI.Common
GetLocalizedMonthString Method
See Also Send Feedback
Gizmox.WebGUI Namespace > WGLabels Class : GetLocalizedMonthString Method

intMonthIndex
blnShort
objContext

Syntax

Visual Basic (Declaration)
Public Shared Function GetLocalizedMonthString( _
   ByVal intMonthIndex As Integer, _
   ByVal blnShort As Boolean, _
   ByVal objContext As IContext _
) As String
Visual Basic (Usage) Copy Code
Dim intMonthIndex As Integer
Dim blnShort As Boolean
Dim objContext As IContext
Dim value As String

value = WGLabels.GetLocalizedMonthString(intMonthIndex, blnShort, objContext)
C#
public static string GetLocalizedMonthString(
   int intMonthIndex,
   bool blnShort,
   IContext objContext
)
Managed Extensions for C++
public: static string* GetLocalizedMonthString(
   int intMonthIndex,
   bool blnShort,
   IContext* objContext
)
C++/CLI
public:
static String^ GetLocalizedMonthString(
   int intMonthIndex,
   bool blnShort,
   IContext^ objContext
)

Parameters

intMonthIndex
blnShort
objContext

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGLabels Class
WGLabels Members


GetString Method

[image]
Gizmox.WebGUI.Common
GetString Method
See Also Send Feedback
Gizmox.WebGUI Namespace > WGLabels Class : GetString Method

Overload List

Overload | Description
GetString(String,IContext) |
GetString(String,IContext,Boolean) |
GetString(String) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGLabels Class
WGLabels Members


GetString(String,IContext) Method

[image]
Gizmox.WebGUI.Common
GetString(String,IContext) Method
See Also Send Feedback
Gizmox.WebGUI Namespace > WGLabels Class > GetString Method : GetString(String,IContext) Method

strName
objContext

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function GetString( _
   ByVal strName As String, _
   ByVal objContext As IContext _
) As String
Visual Basic (Usage) Copy Code
Dim strName As String
Dim objContext As IContext
Dim value As String

value = WGLabels.GetString(strName, objContext)
C#
public static string GetString(
   string strName,
   IContext objContext
)
Managed Extensions for C++
public: static string* GetString(
   string* strName,
   IContext* objContext
)
C++/CLI
public:
static String^ GetString(
   String^ strName,
   IContext^ objContext
)

Parameters

strName
objContext

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGLabels Class
WGLabels Members
Overload List


GetString(String,IContext,Boolean) Method

[image]
Gizmox.WebGUI.Common
GetString(String,IContext,Boolean) Method
See Also Send Feedback
Gizmox.WebGUI Namespace > WGLabels Class > GetString Method : GetString(String,IContext,Boolean) Method

strName
objContext
blnApplyCultureInfoValues

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function GetString( _
   ByVal strName As String, _
   ByVal objContext As IContext, _
   ByVal blnApplyCultureInfoValues As Boolean _
) As String
Visual Basic (Usage) Copy Code
Dim strName As String
Dim objContext As IContext
Dim blnApplyCultureInfoValues As Boolean
Dim value As String

value = WGLabels.GetString(strName, objContext, blnApplyCultureInfoValues)
C#
public static string GetString(
   string strName,
   IContext objContext,
   bool blnApplyCultureInfoValues
)
Managed Extensions for C++
public: static string* GetString(
   string* strName,
   IContext* objContext,
   bool blnApplyCultureInfoValues
)
C++/CLI
public:
static String^ GetString(
   String^ strName,
   IContext^ objContext,
   bool blnApplyCultureInfoValues
)

Parameters

strName
objContext
blnApplyCultureInfoValues

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGLabels Class
WGLabels Members
Overload List


GetString(String) Method

[image]
Gizmox.WebGUI.Common
GetString(String) Method
See Also Send Feedback
Gizmox.WebGUI Namespace > WGLabels Class > GetString Method : GetString(String) Method

strName

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function GetString( _
   ByVal strName As String _
) As String
Visual Basic (Usage) Copy Code
Dim strName As String
Dim value As String

value = WGLabels.GetString(strName)
C#
public static string GetString(
   string strName
)
Managed Extensions for C++
public: static string* GetString(
   string* strName
)
C++/CLI
public:
static String^ GetString(
   String^ strName
)

Parameters

strName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGLabels Class
WGLabels Members
Overload List


WGLabels Class Properties

[image]
Gizmox.WebGUI.Common
WGLabels Class Properties
See Also Send Feedback
Gizmox.WebGUI Namespace : WGLabels Class

For a list of all members of this type, see WGLabels members.

Public Properties

 | Name | Description
static (Shared in Visual Basic) | Abort |
static (Shared in Visual Basic) | Add |
static (Shared in Visual Basic) | Apply |
static (Shared in Visual Basic) | April |
static (Shared in Visual Basic) | AprilShort |
static (Shared in Visual Basic) | Ascending |
static (Shared in Visual Basic) | August |
static (Shared in Visual Basic) | AugustShort |
static (Shared in Visual Basic) | Back |
static (Shared in Visual Basic) | Cancel |
static (Shared in Visual Basic) | Clear |
static (Shared in Visual Basic) | Close |
static (Shared in Visual Basic) | Columns |
static (Shared in Visual Basic) | DatePicker |
static (Shared in Visual Basic) | December |
static (Shared in Visual Basic) | DecemberShort |
static (Shared in Visual Basic) | Decsending |
static (Shared in Visual Basic) | DirAttribute |
static (Shared in Visual Basic) | February |
static (Shared in Visual Basic) | FebruaryShort |
static (Shared in Visual Basic) | Finish |
static (Shared in Visual Basic) | Friday |
static (Shared in Visual Basic) | FridayShort |
static (Shared in Visual Basic) | Grouping |
static (Shared in Visual Basic) | Help |
static (Shared in Visual Basic) | Hide |
static (Shared in Visual Basic) | Ignore |
static (Shared in Visual Basic) | January |
static (Shared in Visual Basic) | JanuaryShort |
static (Shared in Visual Basic) | July |
static (Shared in Visual Basic) | JulyShort |
static (Shared in Visual Basic) | June |
static (Shared in Visual Basic) | JuneShort |
static (Shared in Visual Basic) | LeftAttribute |
static (Shared in Visual Basic) | Loading |
static (Shared in Visual Basic) | March |
static (Shared in Visual Basic) | MarchShort |
static (Shared in Visual Basic) | May |
static (Shared in Visual Basic) | MayShort |
static (Shared in Visual Basic) | Monday |
static (Shared in Visual Basic) | MondayShort |
static (Shared in Visual Basic) | MoveDown |
static (Shared in Visual Basic) | MoveUp |
static (Shared in Visual Basic) | Next |
static (Shared in Visual Basic) | No |
static (Shared in Visual Basic) | November |
static (Shared in Visual Basic) | NovemberShort |
static (Shared in Visual Basic) | October |
static (Shared in Visual Basic) | OctoberShort |
static (Shared in Visual Basic) | Ok |
static (Shared in Visual Basic) | Open |
static (Shared in Visual Basic) | Previous |
static (Shared in Visual Basic) | Remove |
static (Shared in Visual Basic) | Retry |
static (Shared in Visual Basic) | RightAttribute |
static (Shared in Visual Basic) | Saturday |
static (Shared in Visual Basic) | SaturdayShort |
static (Shared in Visual Basic) | Search |
static (Shared in Visual Basic) | SelectFilesToUpload |
static (Shared in Visual Basic) | September |
static (Shared in Visual Basic) | SeptemberShort |
static (Shared in Visual Basic) | Show |
static (Shared in Visual Basic) | Sorting |
static (Shared in Visual Basic) | Sunday |
static (Shared in Visual Basic) | SundayShort |
static (Shared in Visual Basic) | Thursday |
static (Shared in Visual Basic) | ThursdayShort |
static (Shared in Visual Basic) | Today |
static (Shared in Visual Basic) | Tuesday |
static (Shared in Visual Basic) | TuesdayShort |
static (Shared in Visual Basic) | View |
static (Shared in Visual Basic) | Wednesday |
static (Shared in Visual Basic) | WednesdayShort |
static (Shared in Visual Basic) | Yes |
Top

See Also

Reference

WGLabels Class
Gizmox.WebGUI Namespace


Abort Property

[image]
Gizmox.WebGUI.Common
Abort Property
See Also Send Feedback
Gizmox.WebGUI Namespace > WGLabels Class : Abort Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Abort As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGLabels.Abort
C#
public static string Abort {get;}
Managed Extensions for C++
public: __property static string* get_Abort();
C++/CLI
public:
static property String^ Abort {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGLabels Class
WGLabels Members


Add Property

[image]
Gizmox.WebGUI.Common
Add Property
See Also Send Feedback
Gizmox.WebGUI Namespace > WGLabels Class : Add Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Add As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGLabels.Add
C#
public static string Add {get;}
Managed Extensions for C++
public: __property static string* get_Add();
C++/CLI
public:
static property String^ Add {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGLabels Class
WGLabels Members


Apply Property

[image]
Gizmox.WebGUI.Common
Apply Property
See Also Send Feedback
Gizmox.WebGUI Namespace > WGLabels Class : Apply Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Apply As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGLabels.Apply
C#
public static string Apply {get;}
Managed Extensions for C++
public: __property static string* get_Apply();
C++/CLI
public:
static property String^ Apply {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGLabels Class
WGLabels Members


April Property

[image]
Gizmox.WebGUI.Common
April Property
See Also Send Feedback
Gizmox.WebGUI Namespace > WGLabels Class : April Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property April As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGLabels.April
C#
public static string April {get;}
Managed Extensions for C++
public: __property static string* get_April();
C++/CLI
public:
static property String^ April {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGLabels Class
WGLabels Members


AprilShort Property

[image]
Gizmox.WebGUI.Common
AprilShort Property
See Also Send Feedback
Gizmox.WebGUI Namespace > WGLabels Class : AprilShort Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property AprilShort As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGLabels.AprilShort
C#
public static string AprilShort {get;}
Managed Extensions for C++
public: __property static string* get_AprilShort();
C++/CLI
public:
static property String^ AprilShort {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGLabels Class
WGLabels Members


Ascending Property

[image]
Gizmox.WebGUI.Common
Ascending Property
See Also Send Feedback
Gizmox.WebGUI Namespace > WGLabels Class : Ascending Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Ascending As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGLabels.Ascending
C#
public static string Ascending {get;}
Managed Extensions for C++
public: __property static string* get_Ascending();
C++/CLI
public:
static property String^ Ascending {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGLabels Class
WGLabels Members


August Property

[image]
Gizmox.WebGUI.Common
August Property
See Also Send Feedback
Gizmox.WebGUI Namespace > WGLabels Class : August Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property August As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGLabels.August
C#
public static string August {get;}
Managed Extensions for C++
public: __property static string* get_August();
C++/CLI
public:
static property String^ August {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGLabels Class
WGLabels Members


AugustShort Property

[image]
Gizmox.WebGUI.Common
AugustShort Property
See Also Send Feedback
Gizmox.WebGUI Namespace > WGLabels Class : AugustShort Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property AugustShort As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGLabels.AugustShort
C#
public static string AugustShort {get;}
Managed Extensions for C++
public: __property static string* get_AugustShort();
C++/CLI
public:
static property String^ AugustShort {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGLabels Class
WGLabels Members


Back Property

[image]
Gizmox.WebGUI.Common
Back Property
See Also Send Feedback
Gizmox.WebGUI Namespace > WGLabels Class : Back Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Back As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGLabels.Back
C#
public static string Back {get;}
Managed Extensions for C++
public: __property static string* get_Back();
C++/CLI
public:
static property String^ Back {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGLabels Class
WGLabels Members


Cancel Property

[image]
Gizmox.WebGUI.Common
Cancel Property
See Also Send Feedback
Gizmox.WebGUI Namespace > WGLabels Class : Cancel Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Cancel As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGLabels.Cancel
C#
public static string Cancel {get;}
Managed Extensions for C++
public: __property static string* get_Cancel();
C++/CLI
public:
static property String^ Cancel {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGLabels Class
WGLabels Members


Clear Property

[image]
Gizmox.WebGUI.Common
Clear Property
See Also Send Feedback
Gizmox.WebGUI Namespace > WGLabels Class : Clear Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Clear As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGLabels.Clear
C#
public static string Clear {get;}
Managed Extensions for C++
public: __property static string* get_Clear();
C++/CLI
public:
static property String^ Clear {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGLabels Class
WGLabels Members


Close Property

[image]
Gizmox.WebGUI.Common
Close Property
See Also Send Feedback
Gizmox.WebGUI Namespace > WGLabels Class : Close Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Close As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGLabels.Close
C#
public static string Close {get;}
Managed Extensions for C++
public: __property static string* get_Close();
C++/CLI
public:
static property String^ Close {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGLabels Class
WGLabels Members


Columns Property

[image]
Gizmox.WebGUI.Common
Columns Property
See Also Send Feedback
Gizmox.WebGUI Namespace > WGLabels Class : Columns Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Columns As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGLabels.Columns
C#
public static string Columns {get;}
Managed Extensions for C++
public: __property static string* get_Columns();
C++/CLI
public:
static property String^ Columns {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGLabels Class
WGLabels Members


DatePicker Property

[image]
Gizmox.WebGUI.Common
DatePicker Property
See Also Send Feedback
Gizmox.WebGUI Namespace > WGLabels Class : DatePicker Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property DatePicker As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGLabels.DatePicker
C#
public static string DatePicker {get;}
Managed Extensions for C++
public: __property static string* get_DatePicker();
C++/CLI
public:
static property String^ DatePicker {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGLabels Class
WGLabels Members


December Property

[image]
Gizmox.WebGUI.Common
December Property
See Also Send Feedback
Gizmox.WebGUI Namespace > WGLabels Class : December Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property December As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGLabels.December
C#
public static string December {get;}
Managed Extensions for C++
public: __property static string* get_December();
C++/CLI
public:
static property String^ December {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGLabels Class
WGLabels Members


DecemberShort Property

[image]
Gizmox.WebGUI.Common
DecemberShort Property
See Also Send Feedback
Gizmox.WebGUI Namespace > WGLabels Class : DecemberShort Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property DecemberShort As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGLabels.DecemberShort
C#
public static string DecemberShort {get;}
Managed Extensions for C++
public: __property static string* get_DecemberShort();
C++/CLI
public:
static property String^ DecemberShort {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGLabels Class
WGLabels Members


Decsending Property

[image]
Gizmox.WebGUI.Common
Decsending Property
See Also Send Feedback
Gizmox.WebGUI Namespace > WGLabels Class : Decsending Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Decsending As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGLabels.Decsending
C#
public static string Decsending {get;}
Managed Extensions for C++
public: __property static string* get_Decsending();
C++/CLI
public:
static property String^ Decsending {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGLabels Class
WGLabels Members


DirAttribute Property

[image]
Gizmox.WebGUI.Common
DirAttribute Property
See Also Send Feedback
Gizmox.WebGUI Namespace > WGLabels Class : DirAttribute Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property DirAttribute As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGLabels.DirAttribute
C#
public static string DirAttribute {get;}
Managed Extensions for C++
public: __property static string* get_DirAttribute();
C++/CLI
public:
static property String^ DirAttribute {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGLabels Class
WGLabels Members


February Property

[image]
Gizmox.WebGUI.Common
February Property
See Also Send Feedback
Gizmox.WebGUI Namespace > WGLabels Class : February Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property February As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGLabels.February
C#
public static string February {get;}
Managed Extensions for C++
public: __property static string* get_February();
C++/CLI
public:
static property String^ February {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGLabels Class
WGLabels Members


FebruaryShort Property

[image]
Gizmox.WebGUI.Common
FebruaryShort Property
See Also Send Feedback
Gizmox.WebGUI Namespace > WGLabels Class : FebruaryShort Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property FebruaryShort As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGLabels.FebruaryShort
C#
public static string FebruaryShort {get;}
Managed Extensions for C++
public: __property static string* get_FebruaryShort();
C++/CLI
public:
static property String^ FebruaryShort {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGLabels Class
WGLabels Members


Finish Property

[image]
Gizmox.WebGUI.Common
Finish Property
See Also Send Feedback
Gizmox.WebGUI Namespace > WGLabels Class : Finish Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Finish As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGLabels.Finish
C#
public static string Finish {get;}
Managed Extensions for C++
public: __property static string* get_Finish();
C++/CLI
public:
static property String^ Finish {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGLabels Class
WGLabels Members


Friday Property

[image]
Gizmox.WebGUI.Common
Friday Property
See Also Send Feedback
Gizmox.WebGUI Namespace > WGLabels Class : Friday Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Friday As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGLabels.Friday
C#
public static string Friday {get;}
Managed Extensions for C++
public: __property static string* get_Friday();
C++/CLI
public:
static property String^ Friday {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGLabels Class
WGLabels Members


FridayShort Property

[image]
Gizmox.WebGUI.Common
FridayShort Property
See Also Send Feedback
Gizmox.WebGUI Namespace > WGLabels Class : FridayShort Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property FridayShort As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGLabels.FridayShort
C#
public static string FridayShort {get;}
Managed Extensions for C++
public: __property static string* get_FridayShort();
C++/CLI
public:
static property String^ FridayShort {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGLabels Class
WGLabels Members


Grouping Property

[image]
Gizmox.WebGUI.Common
Grouping Property
See Also Send Feedback
Gizmox.WebGUI Namespace > WGLabels Class : Grouping Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Grouping As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGLabels.Grouping
C#
public static string Grouping {get;}
Managed Extensions for C++
public: __property static string* get_Grouping();
C++/CLI
public:
static property String^ Grouping {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGLabels Class
WGLabels Members


Help Property

[image]
Gizmox.WebGUI.Common
Help Property
See Also Send Feedback
Gizmox.WebGUI Namespace > WGLabels Class : Help Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Help As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGLabels.Help
C#
public static string Help {get;}
Managed Extensions for C++
public: __property static string* get_Help();
C++/CLI
public:
static property String^ Help {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGLabels Class
WGLabels Members


Hide Property

[image]
Gizmox.WebGUI.Common
Hide Property
See Also Send Feedback
Gizmox.WebGUI Namespace > WGLabels Class : Hide Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Hide As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGLabels.Hide
C#
public static string Hide {get;}
Managed Extensions for C++
public: __property static string* get_Hide();
C++/CLI
public:
static property String^ Hide {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGLabels Class
WGLabels Members


Ignore Property

[image]
Gizmox.WebGUI.Common
Ignore Property
See Also Send Feedback
Gizmox.WebGUI Namespace > WGLabels Class : Ignore Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Ignore As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGLabels.Ignore
C#
public static string Ignore {get;}
Managed Extensions for C++
public: __property static string* get_Ignore();
C++/CLI
public:
static property String^ Ignore {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGLabels Class
WGLabels Members


January Property

[image]
Gizmox.WebGUI.Common
January Property
See Also Send Feedback
Gizmox.WebGUI Namespace > WGLabels Class : January Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property January As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGLabels.January
C#
public static string January {get;}
Managed Extensions for C++
public: __property static string* get_January();
C++/CLI
public:
static property String^ January {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGLabels Class
WGLabels Members


JanuaryShort Property

[image]
Gizmox.WebGUI.Common
JanuaryShort Property
See Also Send Feedback
Gizmox.WebGUI Namespace > WGLabels Class : JanuaryShort Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property JanuaryShort As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGLabels.JanuaryShort
C#
public static string JanuaryShort {get;}
Managed Extensions for C++
public: __property static string* get_JanuaryShort();
C++/CLI
public:
static property String^ JanuaryShort {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGLabels Class
WGLabels Members


July Property

[image]
Gizmox.WebGUI.Common
July Property
See Also Send Feedback
Gizmox.WebGUI Namespace > WGLabels Class : July Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property July As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGLabels.July
C#
public static string July {get;}
Managed Extensions for C++
public: __property static string* get_July();
C++/CLI
public:
static property String^ July {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGLabels Class
WGLabels Members


JulyShort Property

[image]
Gizmox.WebGUI.Common
JulyShort Property
See Also Send Feedback
Gizmox.WebGUI Namespace > WGLabels Class : JulyShort Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property JulyShort As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGLabels.JulyShort
C#
public static string JulyShort {get;}
Managed Extensions for C++
public: __property static string* get_JulyShort();
C++/CLI
public:
static property String^ JulyShort {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGLabels Class
WGLabels Members


June Property

[image]
Gizmox.WebGUI.Common
June Property
See Also Send Feedback
Gizmox.WebGUI Namespace > WGLabels Class : June Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property June As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGLabels.June
C#
public static string June {get;}
Managed Extensions for C++
public: __property static string* get_June();
C++/CLI
public:
static property String^ June {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGLabels Class
WGLabels Members


JuneShort Property

[image]
Gizmox.WebGUI.Common
JuneShort Property
See Also Send Feedback
Gizmox.WebGUI Namespace > WGLabels Class : JuneShort Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property JuneShort As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGLabels.JuneShort
C#
public static string JuneShort {get;}
Managed Extensions for C++
public: __property static string* get_JuneShort();
C++/CLI
public:
static property String^ JuneShort {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGLabels Class
WGLabels Members


LeftAttribute Property

[image]
Gizmox.WebGUI.Common
LeftAttribute Property
See Also Send Feedback
Gizmox.WebGUI Namespace > WGLabels Class : LeftAttribute Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property LeftAttribute As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGLabels.LeftAttribute
C#
public static string LeftAttribute {get;}
Managed Extensions for C++
public: __property static string* get_LeftAttribute();
C++/CLI
public:
static property String^ LeftAttribute {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGLabels Class
WGLabels Members


Loading Property

[image]
Gizmox.WebGUI.Common
Loading Property
See Also Send Feedback
Gizmox.WebGUI Namespace > WGLabels Class : Loading Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Loading As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGLabels.Loading
C#
public static string Loading {get;}
Managed Extensions for C++
public: __property static string* get_Loading();
C++/CLI
public:
static property String^ Loading {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGLabels Class
WGLabels Members


March Property

[image]
Gizmox.WebGUI.Common
March Property
See Also Send Feedback
Gizmox.WebGUI Namespace > WGLabels Class : March Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property March As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGLabels.March
C#
public static string March {get;}
Managed Extensions for C++
public: __property static string* get_March();
C++/CLI
public:
static property String^ March {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGLabels Class
WGLabels Members


MarchShort Property

[image]
Gizmox.WebGUI.Common
MarchShort Property
See Also Send Feedback
Gizmox.WebGUI Namespace > WGLabels Class : MarchShort Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property MarchShort As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGLabels.MarchShort
C#
public static string MarchShort {get;}
Managed Extensions for C++
public: __property static string* get_MarchShort();
C++/CLI
public:
static property String^ MarchShort {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGLabels Class
WGLabels Members


May Property

[image]
Gizmox.WebGUI.Common
May Property
See Also Send Feedback
Gizmox.WebGUI Namespace > WGLabels Class : May Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property May As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGLabels.May
C#
public static string May {get;}
Managed Extensions for C++
public: __property static string* get_May();
C++/CLI
public:
static property String^ May {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGLabels Class
WGLabels Members


MayShort Property

[image]
Gizmox.WebGUI.Common
MayShort Property
See Also Send Feedback
Gizmox.WebGUI Namespace > WGLabels Class : MayShort Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property MayShort As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGLabels.MayShort
C#
public static string MayShort {get;}
Managed Extensions for C++
public: __property static string* get_MayShort();
C++/CLI
public:
static property String^ MayShort {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGLabels Class
WGLabels Members


Monday Property

[image]
Gizmox.WebGUI.Common
Monday Property
See Also Send Feedback
Gizmox.WebGUI Namespace > WGLabels Class : Monday Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Monday As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGLabels.Monday
C#
public static string Monday {get;}
Managed Extensions for C++
public: __property static string* get_Monday();
C++/CLI
public:
static property String^ Monday {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGLabels Class
WGLabels Members


MondayShort Property

[image]
Gizmox.WebGUI.Common
MondayShort Property
See Also Send Feedback
Gizmox.WebGUI Namespace > WGLabels Class : MondayShort Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property MondayShort As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGLabels.MondayShort
C#
public static string MondayShort {get;}
Managed Extensions for C++
public: __property static string* get_MondayShort();
C++/CLI
public:
static property String^ MondayShort {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGLabels Class
WGLabels Members


MoveDown Property

[image]
Gizmox.WebGUI.Common
MoveDown Property
See Also Send Feedback
Gizmox.WebGUI Namespace > WGLabels Class : MoveDown Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property MoveDown As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGLabels.MoveDown
C#
public static string MoveDown {get;}
Managed Extensions for C++
public: __property static string* get_MoveDown();
C++/CLI
public:
static property String^ MoveDown {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGLabels Class
WGLabels Members


MoveUp Property

[image]
Gizmox.WebGUI.Common
MoveUp Property
See Also Send Feedback
Gizmox.WebGUI Namespace > WGLabels Class : MoveUp Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property MoveUp As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGLabels.MoveUp
C#
public static string MoveUp {get;}
Managed Extensions for C++
public: __property static string* get_MoveUp();
C++/CLI
public:
static property String^ MoveUp {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGLabels Class
WGLabels Members


Next Property

[image]
Gizmox.WebGUI.Common
Next Property
See Also Send Feedback
Gizmox.WebGUI Namespace > WGLabels Class : Next Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Next As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGLabels.Next
C#
public static string Next {get;}
Managed Extensions for C++
public: __property static string* get_Next();
C++/CLI
public:
static property String^ Next {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGLabels Class
WGLabels Members


No Property

[image]
Gizmox.WebGUI.Common
No Property
See Also Send Feedback
Gizmox.WebGUI Namespace > WGLabels Class : No Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property No As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGLabels.No
C#
public static string No {get;}
Managed Extensions for C++
public: __property static string* get_No();
C++/CLI
public:
static property String^ No {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGLabels Class
WGLabels Members


November Property

[image]
Gizmox.WebGUI.Common
November Property
See Also Send Feedback
Gizmox.WebGUI Namespace > WGLabels Class : November Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property November As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGLabels.November
C#
public static string November {get;}
Managed Extensions for C++
public: __property static string* get_November();
C++/CLI
public:
static property String^ November {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGLabels Class
WGLabels Members


NovemberShort Property

[image]
Gizmox.WebGUI.Common
NovemberShort Property
See Also Send Feedback
Gizmox.WebGUI Namespace > WGLabels Class : NovemberShort Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property NovemberShort As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGLabels.NovemberShort
C#
public static string NovemberShort {get;}
Managed Extensions for C++
public: __property static string* get_NovemberShort();
C++/CLI
public:
static property String^ NovemberShort {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGLabels Class
WGLabels Members


October Property

[image]
Gizmox.WebGUI.Common
October Property
See Also Send Feedback
Gizmox.WebGUI Namespace > WGLabels Class : October Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property October As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGLabels.October
C#
public static string October {get;}
Managed Extensions for C++
public: __property static string* get_October();
C++/CLI
public:
static property String^ October {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGLabels Class
WGLabels Members


OctoberShort Property

[image]
Gizmox.WebGUI.Common
OctoberShort Property
See Also Send Feedback
Gizmox.WebGUI Namespace > WGLabels Class : OctoberShort Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property OctoberShort As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGLabels.OctoberShort
C#
public static string OctoberShort {get;}
Managed Extensions for C++
public: __property static string* get_OctoberShort();
C++/CLI
public:
static property String^ OctoberShort {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGLabels Class
WGLabels Members


Ok Property

[image]
Gizmox.WebGUI.Common
Ok Property
See Also Send Feedback
Gizmox.WebGUI Namespace > WGLabels Class : Ok Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Ok As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGLabels.Ok
C#
public static string Ok {get;}
Managed Extensions for C++
public: __property static string* get_Ok();
C++/CLI
public:
static property String^ Ok {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGLabels Class
WGLabels Members


Open Property

[image]
Gizmox.WebGUI.Common
Open Property
See Also Send Feedback
Gizmox.WebGUI Namespace > WGLabels Class : Open Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Open As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGLabels.Open
C#
public static string Open {get;}
Managed Extensions for C++
public: __property static string* get_Open();
C++/CLI
public:
static property String^ Open {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGLabels Class
WGLabels Members


Previous Property

[image]
Gizmox.WebGUI.Common
Previous Property
See Also Send Feedback
Gizmox.WebGUI Namespace > WGLabels Class : Previous Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Previous As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGLabels.Previous
C#
public static string Previous {get;}
Managed Extensions for C++
public: __property static string* get_Previous();
C++/CLI
public:
static property String^ Previous {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGLabels Class
WGLabels Members


Remove Property

[image]
Gizmox.WebGUI.Common
Remove Property
See Also Send Feedback
Gizmox.WebGUI Namespace > WGLabels Class : Remove Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Remove As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGLabels.Remove
C#
public static string Remove {get;}
Managed Extensions for C++
public: __property static string* get_Remove();
C++/CLI
public:
static property String^ Remove {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGLabels Class
WGLabels Members


Retry Property

[image]
Gizmox.WebGUI.Common
Retry Property
See Also Send Feedback
Gizmox.WebGUI Namespace > WGLabels Class : Retry Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Retry As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGLabels.Retry
C#
public static string Retry {get;}
Managed Extensions for C++
public: __property static string* get_Retry();
C++/CLI
public:
static property String^ Retry {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGLabels Class
WGLabels Members


RightAttribute Property

[image]
Gizmox.WebGUI.Common
RightAttribute Property
See Also Send Feedback
Gizmox.WebGUI Namespace > WGLabels Class : RightAttribute Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property RightAttribute As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGLabels.RightAttribute
C#
public static string RightAttribute {get;}
Managed Extensions for C++
public: __property static string* get_RightAttribute();
C++/CLI
public:
static property String^ RightAttribute {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGLabels Class
WGLabels Members


Saturday Property

[image]
Gizmox.WebGUI.Common
Saturday Property
See Also Send Feedback
Gizmox.WebGUI Namespace > WGLabels Class : Saturday Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Saturday As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGLabels.Saturday
C#
public static string Saturday {get;}
Managed Extensions for C++
public: __property static string* get_Saturday();
C++/CLI
public:
static property String^ Saturday {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGLabels Class
WGLabels Members


SaturdayShort Property

[image]
Gizmox.WebGUI.Common
SaturdayShort Property
See Also Send Feedback
Gizmox.WebGUI Namespace > WGLabels Class : SaturdayShort Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property SaturdayShort As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGLabels.SaturdayShort
C#
public static string SaturdayShort {get;}
Managed Extensions for C++
public: __property static string* get_SaturdayShort();
C++/CLI
public:
static property String^ SaturdayShort {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGLabels Class
WGLabels Members


Search Property

[image]
Gizmox.WebGUI.Common
Search Property
See Also Send Feedback
Gizmox.WebGUI Namespace > WGLabels Class : Search Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Search As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGLabels.Search
C#
public static string Search {get;}
Managed Extensions for C++
public: __property static string* get_Search();
C++/CLI
public:
static property String^ Search {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGLabels Class
WGLabels Members


SelectFilesToUpload Property

[image]
Gizmox.WebGUI.Common
SelectFilesToUpload Property
See Also Send Feedback
Gizmox.WebGUI Namespace > WGLabels Class : SelectFilesToUpload Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property SelectFilesToUpload As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGLabels.SelectFilesToUpload
C#
public static string SelectFilesToUpload {get;}
Managed Extensions for C++
public: __property static string* get_SelectFilesToUpload();
C++/CLI
public:
static property String^ SelectFilesToUpload {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGLabels Class
WGLabels Members


September Property

[image]
Gizmox.WebGUI.Common
September Property
See Also Send Feedback
Gizmox.WebGUI Namespace > WGLabels Class : September Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property September As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGLabels.September
C#
public static string September {get;}
Managed Extensions for C++
public: __property static string* get_September();
C++/CLI
public:
static property String^ September {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGLabels Class
WGLabels Members


SeptemberShort Property

[image]
Gizmox.WebGUI.Common
SeptemberShort Property
See Also Send Feedback
Gizmox.WebGUI Namespace > WGLabels Class : SeptemberShort Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property SeptemberShort As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGLabels.SeptemberShort
C#
public static string SeptemberShort {get;}
Managed Extensions for C++
public: __property static string* get_SeptemberShort();
C++/CLI
public:
static property String^ SeptemberShort {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGLabels Class
WGLabels Members


Show Property

[image]
Gizmox.WebGUI.Common
Show Property
See Also Send Feedback
Gizmox.WebGUI Namespace > WGLabels Class : Show Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Show As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGLabels.Show
C#
public static string Show {get;}
Managed Extensions for C++
public: __property static string* get_Show();
C++/CLI
public:
static property String^ Show {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGLabels Class
WGLabels Members


Sorting Property

[image]
Gizmox.WebGUI.Common
Sorting Property
See Also Send Feedback
Gizmox.WebGUI Namespace > WGLabels Class : Sorting Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Sorting As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGLabels.Sorting
C#
public static string Sorting {get;}
Managed Extensions for C++
public: __property static string* get_Sorting();
C++/CLI
public:
static property String^ Sorting {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGLabels Class
WGLabels Members


Sunday Property

[image]
Gizmox.WebGUI.Common
Sunday Property
See Also Send Feedback
Gizmox.WebGUI Namespace > WGLabels Class : Sunday Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Sunday As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGLabels.Sunday
C#
public static string Sunday {get;}
Managed Extensions for C++
public: __property static string* get_Sunday();
C++/CLI
public:
static property String^ Sunday {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGLabels Class
WGLabels Members


SundayShort Property

[image]
Gizmox.WebGUI.Common
SundayShort Property
See Also Send Feedback
Gizmox.WebGUI Namespace > WGLabels Class : SundayShort Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property SundayShort As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGLabels.SundayShort
C#
public static string SundayShort {get;}
Managed Extensions for C++
public: __property static string* get_SundayShort();
C++/CLI
public:
static property String^ SundayShort {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGLabels Class
WGLabels Members


Thursday Property

[image]
Gizmox.WebGUI.Common
Thursday Property
See Also Send Feedback
Gizmox.WebGUI Namespace > WGLabels Class : Thursday Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Thursday As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGLabels.Thursday
C#
public static string Thursday {get;}
Managed Extensions for C++
public: __property static string* get_Thursday();
C++/CLI
public:
static property String^ Thursday {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGLabels Class
WGLabels Members


ThursdayShort Property

[image]
Gizmox.WebGUI.Common
ThursdayShort Property
See Also Send Feedback
Gizmox.WebGUI Namespace > WGLabels Class : ThursdayShort Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property ThursdayShort As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGLabels.ThursdayShort
C#
public static string ThursdayShort {get;}
Managed Extensions for C++
public: __property static string* get_ThursdayShort();
C++/CLI
public:
static property String^ ThursdayShort {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGLabels Class
WGLabels Members


Today Property

[image]
Gizmox.WebGUI.Common
Today Property
See Also Send Feedback
Gizmox.WebGUI Namespace > WGLabels Class : Today Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Today As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGLabels.Today
C#
public static string Today {get;}
Managed Extensions for C++
public: __property static string* get_Today();
C++/CLI
public:
static property String^ Today {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGLabels Class
WGLabels Members


Tuesday Property

[image]
Gizmox.WebGUI.Common
Tuesday Property
See Also Send Feedback
Gizmox.WebGUI Namespace > WGLabels Class : Tuesday Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Tuesday As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGLabels.Tuesday
C#
public static string Tuesday {get;}
Managed Extensions for C++
public: __property static string* get_Tuesday();
C++/CLI
public:
static property String^ Tuesday {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGLabels Class
WGLabels Members


TuesdayShort Property

[image]
Gizmox.WebGUI.Common
TuesdayShort Property
See Also Send Feedback
Gizmox.WebGUI Namespace > WGLabels Class : TuesdayShort Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property TuesdayShort As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGLabels.TuesdayShort
C#
public static string TuesdayShort {get;}
Managed Extensions for C++
public: __property static string* get_TuesdayShort();
C++/CLI
public:
static property String^ TuesdayShort {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGLabels Class
WGLabels Members


View Property

[image]
Gizmox.WebGUI.Common
View Property
See Also Send Feedback
Gizmox.WebGUI Namespace > WGLabels Class : View Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property View As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGLabels.View
C#
public static string View {get;}
Managed Extensions for C++
public: __property static string* get_View();
C++/CLI
public:
static property String^ View {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGLabels Class
WGLabels Members


Wednesday Property

[image]
Gizmox.WebGUI.Common
Wednesday Property
See Also Send Feedback
Gizmox.WebGUI Namespace > WGLabels Class : Wednesday Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Wednesday As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGLabels.Wednesday
C#
public static string Wednesday {get;}
Managed Extensions for C++
public: __property static string* get_Wednesday();
C++/CLI
public:
static property String^ Wednesday {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGLabels Class
WGLabels Members


WednesdayShort Property

[image]
Gizmox.WebGUI.Common
WednesdayShort Property
See Also Send Feedback
Gizmox.WebGUI Namespace > WGLabels Class : WednesdayShort Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property WednesdayShort As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGLabels.WednesdayShort
C#
public static string WednesdayShort {get;}
Managed Extensions for C++
public: __property static string* get_WednesdayShort();
C++/CLI
public:
static property String^ WednesdayShort {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGLabels Class
WGLabels Members


Yes Property

[image]
Gizmox.WebGUI.Common
Yes Property
See Also Send Feedback
Gizmox.WebGUI Namespace > WGLabels Class : Yes Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Yes As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGLabels.Yes
C#
public static string Yes {get;}
Managed Extensions for C++
public: __property static string* get_Yes();
C++/CLI
public:
static property String^ Yes {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGLabels Class
WGLabels Members


WGTags Class

[image]
Gizmox.WebGUI.Common
WGTags Class
Members See Also Send Feedback
Gizmox.WebGUI Namespace : WGTags Class

Syntax

Visual Basic (Declaration)
Public Class WGTags
Visual Basic (Usage) Copy Code
Dim instance As WGTags
C#
public class WGTags
Managed Extensions for C++
public __gc class WGTags
C++/CLI
public ref class WGTags

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.WGTags

Requirements

Namespace: Gizmox.WebGUI

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

WGTags Members
Gizmox.WebGUI Namespace


WGTags Class Members

[image]
Gizmox.WebGUI.Common
WGTags Class Members
See Also Fields Send Feedback
Gizmox.WebGUI Namespace : WGTags Class

The following tables list the members exposed by WGTags.

Public Constructors

 | Name | Description
Public Constructor | WGTags Constructor |
Top

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Applet |
static (Shared in Visual Basic) | ASPXBox |
static (Shared in Visual Basic) | Assembly |
static (Shared in Visual Basic) | Button |
static (Shared in Visual Basic) | Chart |
static (Shared in Visual Basic) | CheckBox |
static (Shared in Visual Basic) | CheckedListBox |
static (Shared in Visual Basic) | ColorComboBox |
static (Shared in Visual Basic) | ColorListBox |
static (Shared in Visual Basic) | Column |
static (Shared in Visual Basic) | ComboBox |
static (Shared in Visual Basic) | Commands |
static (Shared in Visual Basic) | Content |
static (Shared in Visual Basic) | ContextMenu |
static (Shared in Visual Basic) | DataGridView |
static (Shared in Visual Basic) | DataGridViewCell |
static (Shared in Visual Basic) | DataGridViewColumn |
static (Shared in Visual Basic) | DataGridViewOptions |
static (Shared in Visual Basic) | DataGridViewRow |
static (Shared in Visual Basic) | DateTimePicker |
static (Shared in Visual Basic) | DomainUpDown |
static (Shared in Visual Basic) | DragElement |
static (Shared in Visual Basic) | DraggedOverElement |
static (Shared in Visual Basic) | Error |
static (Shared in Visual Basic) | Event |
static (Shared in Visual Basic) | Events |
static (Shared in Visual Basic) | FlowLayoutPanel |
static (Shared in Visual Basic) | Form |
static (Shared in Visual Basic) | GroupBox |
static (Shared in Visual Basic) | Header |
static (Shared in Visual Basic) | HtmlBox |
static (Shared in Visual Basic) | InvokeMethod |
static (Shared in Visual Basic) | Item |
static (Shared in Visual Basic) | Label |
static (Shared in Visual Basic) | Line |
static (Shared in Visual Basic) | LinkLabel |
static (Shared in Visual Basic) | ListBox |
static (Shared in Visual Basic) | ListView |
static (Shared in Visual Basic) | MainMenu |
static (Shared in Visual Basic) | Manifest |
static (Shared in Visual Basic) | MdiClient |
static (Shared in Visual Basic) | Menu |
static (Shared in Visual Basic) | MenuItem |
static (Shared in Visual Basic) | MonthCalendar |
static (Shared in Visual Basic) | NumericUpDown |
static (Shared in Visual Basic) | Object |
static (Shared in Visual Basic) | Option |
static (Shared in Visual Basic) | Options |
static (Shared in Visual Basic) | Package |
static (Shared in Visual Basic) | Packages |
static (Shared in Visual Basic) | Panel |
static (Shared in Visual Basic) | Param |
static (Shared in Visual Basic) | PictureBox |
static (Shared in Visual Basic) | ProgressBar |
static (Shared in Visual Basic) | PropertyGrid |
static (Shared in Visual Basic) | PropertyGridEntry |
static (Shared in Visual Basic) | PropertyGridView |
static (Shared in Visual Basic) | RadioButton |
static (Shared in Visual Basic) | Refresh |
static (Shared in Visual Basic) | Response |
static (Shared in Visual Basic) | RichTextBox |
static (Shared in Visual Basic) | Row |
static (Shared in Visual Basic) | Rows |
static (Shared in Visual Basic) | ScheduleBox |
static (Shared in Visual Basic) | ScrollablePanel |
static (Shared in Visual Basic) | ShortcutsContainer |
static (Shared in Visual Basic) | Splitter |
static (Shared in Visual Basic) | StatusBar |
static (Shared in Visual Basic) | StatusPanel |
static (Shared in Visual Basic) | TabControl |
static (Shared in Visual Basic) | TableLayoutCell |
static (Shared in Visual Basic) | TableLayoutCol |
static (Shared in Visual Basic) | TableLayoutPanel |
static (Shared in Visual Basic) | TableLayoutRow |
static (Shared in Visual Basic) | TabPage |
static (Shared in Visual Basic) | Tag |
static (Shared in Visual Basic) | Tags |
static (Shared in Visual Basic) | TextBox |
static (Shared in Visual Basic) | Theme |
static (Shared in Visual Basic) | Themes |
static (Shared in Visual Basic) | ToolBarButton |
static (Shared in Visual Basic) | ToolBarControl |
static (Shared in Visual Basic) | TrackBar |
static (Shared in Visual Basic) | TreeNode |
static (Shared in Visual Basic) | TreeView |
static (Shared in Visual Basic) | UpdateParams |
static (Shared in Visual Basic) | UserControl |
static (Shared in Visual Basic) | XamlBox |
Top

See Also

Reference

WGTags Class
Gizmox.WebGUI Namespace


WGTags Constructor

[image]
Gizmox.WebGUI.Common
WGTags Constructor
See Also Send Feedback
Gizmox.WebGUI Namespace > WGTags Class : WGTags Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As WGTags()
C#
public WGTags()
Managed Extensions for C++
public: WGTags();
C++/CLI
public:
WGTags();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGTags Class
WGTags Members


WGTags Class Fields

[image]
Gizmox.WebGUI.Common
WGTags Class Fields
See Also Send Feedback
Gizmox.WebGUI Namespace : WGTags Class

For a list of all members of this type, see WGTags members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | Applet |
static (Shared in Visual Basic) | ASPXBox |
static (Shared in Visual Basic) | Assembly |
static (Shared in Visual Basic) | Button |
static (Shared in Visual Basic) | Chart |
static (Shared in Visual Basic) | CheckBox |
static (Shared in Visual Basic) | CheckedListBox |
static (Shared in Visual Basic) | ColorComboBox |
static (Shared in Visual Basic) | ColorListBox |
static (Shared in Visual Basic) | Column |
static (Shared in Visual Basic) | ComboBox |
static (Shared in Visual Basic) | Commands |
static (Shared in Visual Basic) | Content |
static (Shared in Visual Basic) | ContextMenu |
static (Shared in Visual Basic) | DataGridView |
static (Shared in Visual Basic) | DataGridViewCell |
static (Shared in Visual Basic) | DataGridViewColumn |
static (Shared in Visual Basic) | DataGridViewOptions |
static (Shared in Visual Basic) | DataGridViewRow |
static (Shared in Visual Basic) | DateTimePicker |
static (Shared in Visual Basic) | DomainUpDown |
static (Shared in Visual Basic) | DragElement |
static (Shared in Visual Basic) | DraggedOverElement |
static (Shared in Visual Basic) | Error |
static (Shared in Visual Basic) | Event |
static (Shared in Visual Basic) | Events |
static (Shared in Visual Basic) | FlowLayoutPanel |
static (Shared in Visual Basic) | Form |
static (Shared in Visual Basic) | GroupBox |
static (Shared in Visual Basic) | Header |
static (Shared in Visual Basic) | HtmlBox |
static (Shared in Visual Basic) | InvokeMethod |
static (Shared in Visual Basic) | Item |
static (Shared in Visual Basic) | Label |
static (Shared in Visual Basic) | Line |
static (Shared in Visual Basic) | LinkLabel |
static (Shared in Visual Basic) | ListBox |
static (Shared in Visual Basic) | ListView |
static (Shared in Visual Basic) | MainMenu |
static (Shared in Visual Basic) | Manifest |
static (Shared in Visual Basic) | MdiClient |
static (Shared in Visual Basic) | Menu |
static (Shared in Visual Basic) | MenuItem |
static (Shared in Visual Basic) | MonthCalendar |
static (Shared in Visual Basic) | NumericUpDown |
static (Shared in Visual Basic) | Object |
static (Shared in Visual Basic) | Option |
static (Shared in Visual Basic) | Options |
static (Shared in Visual Basic) | Package |
static (Shared in Visual Basic) | Packages |
static (Shared in Visual Basic) | Panel |
static (Shared in Visual Basic) | Param |
static (Shared in Visual Basic) | PictureBox |
static (Shared in Visual Basic) | ProgressBar |
static (Shared in Visual Basic) | PropertyGrid |
static (Shared in Visual Basic) | PropertyGridEntry |
static (Shared in Visual Basic) | PropertyGridView |
static (Shared in Visual Basic) | RadioButton |
static (Shared in Visual Basic) | Refresh |
static (Shared in Visual Basic) | Response |
static (Shared in Visual Basic) | RichTextBox |
static (Shared in Visual Basic) | Row |
static (Shared in Visual Basic) | Rows |
static (Shared in Visual Basic) | ScheduleBox |
static (Shared in Visual Basic) | ScrollablePanel |
static (Shared in Visual Basic) | ShortcutsContainer |
static (Shared in Visual Basic) | Splitter |
static (Shared in Visual Basic) | StatusBar |
static (Shared in Visual Basic) | StatusPanel |
static (Shared in Visual Basic) | TabControl |
static (Shared in Visual Basic) | TableLayoutCell |
static (Shared in Visual Basic) | TableLayoutCol |
static (Shared in Visual Basic) | TableLayoutPanel |
static (Shared in Visual Basic) | TableLayoutRow |
static (Shared in Visual Basic) | TabPage |
static (Shared in Visual Basic) | Tag |
static (Shared in Visual Basic) | Tags |
static (Shared in Visual Basic) | TextBox |
static (Shared in Visual Basic) | Theme |
static (Shared in Visual Basic) | Themes |
static (Shared in Visual Basic) | ToolBarButton |
static (Shared in Visual Basic) | ToolBarControl |
static (Shared in Visual Basic) | TrackBar |
static (Shared in Visual Basic) | TreeNode |
static (Shared in Visual Basic) | TreeView |
static (Shared in Visual Basic) | UpdateParams |
static (Shared in Visual Basic) | UserControl |
static (Shared in Visual Basic) | XamlBox |
Top

See Also

Reference

WGTags Class
Gizmox.WebGUI Namespace


Applet Field

[image]
Gizmox.WebGUI.Common
Applet Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGTags Class : Applet Field

Syntax

Visual Basic (Declaration)
Public Shared Applet As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGTags.Applet

WGTags.Applet = value
C#
public static string Applet
Managed Extensions for C++
public: static string* Applet
C++/CLI
public:
static String^ Applet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGTags Class
WGTags Members


ASPXBox Field

[image]
Gizmox.WebGUI.Common
ASPXBox Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGTags Class : ASPXBox Field

Syntax

Visual Basic (Declaration)
Public Shared ASPXBox As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGTags.ASPXBox

WGTags.ASPXBox = value
C#
public static string ASPXBox
Managed Extensions for C++
public: static string* ASPXBox
C++/CLI
public:
static String^ ASPXBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGTags Class
WGTags Members


Assembly Field

[image]
Gizmox.WebGUI.Common
Assembly Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGTags Class : Assembly Field

Syntax

Visual Basic (Declaration)
Public Shared Assembly As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGTags.Assembly

WGTags.Assembly = value
C#
public static string Assembly
Managed Extensions for C++
public: static string* Assembly
C++/CLI
public:
static String^ Assembly

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGTags Class
WGTags Members


Button Field

[image]
Gizmox.WebGUI.Common
Button Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGTags Class : Button Field

Syntax

Visual Basic (Declaration)
Public Shared Button As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGTags.Button

WGTags.Button = value
C#
public static string Button
Managed Extensions for C++
public: static string* Button
C++/CLI
public:
static String^ Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGTags Class
WGTags Members


Chart Field

[image]
Gizmox.WebGUI.Common
Chart Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGTags Class : Chart Field

Syntax

Visual Basic (Declaration)
Public Shared Chart As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGTags.Chart

WGTags.Chart = value
C#
public static string Chart
Managed Extensions for C++
public: static string* Chart
C++/CLI
public:
static String^ Chart

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGTags Class
WGTags Members


CheckBox Field

[image]
Gizmox.WebGUI.Common
CheckBox Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGTags Class : CheckBox Field

Syntax

Visual Basic (Declaration)
Public Shared CheckBox As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGTags.CheckBox

WGTags.CheckBox = value
C#
public static string CheckBox
Managed Extensions for C++
public: static string* CheckBox
C++/CLI
public:
static String^ CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGTags Class
WGTags Members


CheckedListBox Field

[image]
Gizmox.WebGUI.Common
CheckedListBox Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGTags Class : CheckedListBox Field

Syntax

Visual Basic (Declaration)
Public Shared CheckedListBox As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGTags.CheckedListBox

WGTags.CheckedListBox = value
C#
public static string CheckedListBox
Managed Extensions for C++
public: static string* CheckedListBox
C++/CLI
public:
static String^ CheckedListBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGTags Class
WGTags Members


ColorComboBox Field

[image]
Gizmox.WebGUI.Common
ColorComboBox Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGTags Class : ColorComboBox Field

Syntax

Visual Basic (Declaration)
Public Shared ColorComboBox As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGTags.ColorComboBox

WGTags.ColorComboBox = value
C#
public static string ColorComboBox
Managed Extensions for C++
public: static string* ColorComboBox
C++/CLI
public:
static String^ ColorComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGTags Class
WGTags Members


ColorListBox Field

[image]
Gizmox.WebGUI.Common
ColorListBox Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGTags Class : ColorListBox Field

Syntax

Visual Basic (Declaration)
Public Shared ColorListBox As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGTags.ColorListBox

WGTags.ColorListBox = value
C#
public static string ColorListBox
Managed Extensions for C++
public: static string* ColorListBox
C++/CLI
public:
static String^ ColorListBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGTags Class
WGTags Members


Column Field

[image]
Gizmox.WebGUI.Common
Column Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGTags Class : Column Field

Syntax

Visual Basic (Declaration)
Public Shared Column As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGTags.Column

WGTags.Column = value
C#
public static string Column
Managed Extensions for C++
public: static string* Column
C++/CLI
public:
static String^ Column

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGTags Class
WGTags Members


ComboBox Field

[image]
Gizmox.WebGUI.Common
ComboBox Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGTags Class : ComboBox Field

Syntax

Visual Basic (Declaration)
Public Shared ComboBox As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGTags.ComboBox

WGTags.ComboBox = value
C#
public static string ComboBox
Managed Extensions for C++
public: static string* ComboBox
C++/CLI
public:
static String^ ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGTags Class
WGTags Members


Commands Field

[image]
Gizmox.WebGUI.Common
Commands Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGTags Class : Commands Field

Syntax

Visual Basic (Declaration)
Public Shared Commands As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGTags.Commands

WGTags.Commands = value
C#
public static string Commands
Managed Extensions for C++
public: static string* Commands
C++/CLI
public:
static String^ Commands

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGTags Class
WGTags Members


Content Field

[image]
Gizmox.WebGUI.Common
Content Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGTags Class : Content Field

Syntax

Visual Basic (Declaration)
Public Shared Content As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGTags.Content

WGTags.Content = value
C#
public static string Content
Managed Extensions for C++
public: static string* Content
C++/CLI
public:
static String^ Content

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGTags Class
WGTags Members


ContextMenu Field

[image]
Gizmox.WebGUI.Common
ContextMenu Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGTags Class : ContextMenu Field

Syntax

Visual Basic (Declaration)
Public Shared ContextMenu As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGTags.ContextMenu

WGTags.ContextMenu = value
C#
public static string ContextMenu
Managed Extensions for C++
public: static string* ContextMenu
C++/CLI
public:
static String^ ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGTags Class
WGTags Members


DataGridView Field

[image]
Gizmox.WebGUI.Common
DataGridView Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGTags Class : DataGridView Field

Syntax

Visual Basic (Declaration)
Public Shared DataGridView As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGTags.DataGridView

WGTags.DataGridView = value
C#
public static string DataGridView
Managed Extensions for C++
public: static string* DataGridView
C++/CLI
public:
static String^ DataGridView

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGTags Class
WGTags Members


DataGridViewCell Field

[image]
Gizmox.WebGUI.Common
DataGridViewCell Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGTags Class : DataGridViewCell Field

Syntax

Visual Basic (Declaration)
Public Shared DataGridViewCell As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGTags.DataGridViewCell

WGTags.DataGridViewCell = value
C#
public static string DataGridViewCell
Managed Extensions for C++
public: static string* DataGridViewCell
C++/CLI
public:
static String^ DataGridViewCell

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGTags Class
WGTags Members


DataGridViewColumn Field

[image]
Gizmox.WebGUI.Common
DataGridViewColumn Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGTags Class : DataGridViewColumn Field

Syntax

Visual Basic (Declaration)
Public Shared DataGridViewColumn As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGTags.DataGridViewColumn

WGTags.DataGridViewColumn = value
C#
public static string DataGridViewColumn
Managed Extensions for C++
public: static string* DataGridViewColumn
C++/CLI
public:
static String^ DataGridViewColumn

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGTags Class
WGTags Members


DataGridViewOptions Field

[image]
Gizmox.WebGUI.Common
DataGridViewOptions Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGTags Class : DataGridViewOptions Field

Syntax

Visual Basic (Declaration)
Public Shared DataGridViewOptions As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGTags.DataGridViewOptions

WGTags.DataGridViewOptions = value
C#
public static string DataGridViewOptions
Managed Extensions for C++
public: static string* DataGridViewOptions
C++/CLI
public:
static String^ DataGridViewOptions

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGTags Class
WGTags Members


DataGridViewRow Field

[image]
Gizmox.WebGUI.Common
DataGridViewRow Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGTags Class : DataGridViewRow Field

Syntax

Visual Basic (Declaration)
Public Shared DataGridViewRow As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGTags.DataGridViewRow

WGTags.DataGridViewRow = value
C#
public static string DataGridViewRow
Managed Extensions for C++
public: static string* DataGridViewRow
C++/CLI
public:
static String^ DataGridViewRow

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGTags Class
WGTags Members


DateTimePicker Field

[image]
Gizmox.WebGUI.Common
DateTimePicker Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGTags Class : DateTimePicker Field

Syntax

Visual Basic (Declaration)
Public Shared DateTimePicker As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGTags.DateTimePicker

WGTags.DateTimePicker = value
C#
public static string DateTimePicker
Managed Extensions for C++
public: static string* DateTimePicker
C++/CLI
public:
static String^ DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGTags Class
WGTags Members


DomainUpDown Field

[image]
Gizmox.WebGUI.Common
DomainUpDown Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGTags Class : DomainUpDown Field

Syntax

Visual Basic (Declaration)
Public Shared DomainUpDown As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGTags.DomainUpDown

WGTags.DomainUpDown = value
C#
public static string DomainUpDown
Managed Extensions for C++
public: static string* DomainUpDown
C++/CLI
public:
static String^ DomainUpDown

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGTags Class
WGTags Members


DragElement Field

[image]
Gizmox.WebGUI.Common
DragElement Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGTags Class : DragElement Field

Syntax

Visual Basic (Declaration)
Public Shared DragElement As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGTags.DragElement

WGTags.DragElement = value
C#
public static string DragElement
Managed Extensions for C++
public: static string* DragElement
C++/CLI
public:
static String^ DragElement

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGTags Class
WGTags Members


DraggedOverElement Field

[image]
Gizmox.WebGUI.Common
DraggedOverElement Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGTags Class : DraggedOverElement Field

Syntax

Visual Basic (Declaration)
Public Shared DraggedOverElement As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGTags.DraggedOverElement

WGTags.DraggedOverElement = value
C#
public static string DraggedOverElement
Managed Extensions for C++
public: static string* DraggedOverElement
C++/CLI
public:
static String^ DraggedOverElement

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGTags Class
WGTags Members


Error Field

[image]
Gizmox.WebGUI.Common
Error Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGTags Class : Error Field

Syntax

Visual Basic (Declaration)
Public Shared Error As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGTags.Error

WGTags.Error = value
C#
public static string Error
Managed Extensions for C++
public: static string* Error
C++/CLI
public:
static String^ Error

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGTags Class
WGTags Members


Event Field

[image]
Gizmox.WebGUI.Common
Event Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGTags Class : Event Field

Syntax

Visual Basic (Declaration)
Public Shared Event As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGTags.Event

WGTags.Event = value
C#
public static string Event
Managed Extensions for C++
public: static string* Event
C++/CLI
public:
static String^ Event

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGTags Class
WGTags Members


Events Field

[image]
Gizmox.WebGUI.Common
Events Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGTags Class : Events Field

Syntax

Visual Basic (Declaration)
Public Shared Events As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGTags.Events

WGTags.Events = value
C#
public static string Events
Managed Extensions for C++
public: static string* Events
C++/CLI
public:
static String^ Events

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGTags Class
WGTags Members


FlowLayoutPanel Field

[image]
Gizmox.WebGUI.Common
FlowLayoutPanel Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGTags Class : FlowLayoutPanel Field

Syntax

Visual Basic (Declaration)
Public Shared FlowLayoutPanel As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGTags.FlowLayoutPanel

WGTags.FlowLayoutPanel = value
C#
public static string FlowLayoutPanel
Managed Extensions for C++
public: static string* FlowLayoutPanel
C++/CLI
public:
static String^ FlowLayoutPanel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGTags Class
WGTags Members


Form Field

[image]
Gizmox.WebGUI.Common
Form Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGTags Class : Form Field

Syntax

Visual Basic (Declaration)
Public Shared Form As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGTags.Form

WGTags.Form = value
C#
public static string Form
Managed Extensions for C++
public: static string* Form
C++/CLI
public:
static String^ Form

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGTags Class
WGTags Members


GroupBox Field

[image]
Gizmox.WebGUI.Common
GroupBox Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGTags Class : GroupBox Field

Syntax

Visual Basic (Declaration)
Public Shared GroupBox As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGTags.GroupBox

WGTags.GroupBox = value
C#
public static string GroupBox
Managed Extensions for C++
public: static string* GroupBox
C++/CLI
public:
static String^ GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGTags Class
WGTags Members


Header Field

[image]
Gizmox.WebGUI.Common
Header Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGTags Class : Header Field

Syntax

Visual Basic (Declaration)
Public Shared Header As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGTags.Header

WGTags.Header = value
C#
public static string Header
Managed Extensions for C++
public: static string* Header
C++/CLI
public:
static String^ Header

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGTags Class
WGTags Members


HtmlBox Field

[image]
Gizmox.WebGUI.Common
HtmlBox Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGTags Class : HtmlBox Field

Syntax

Visual Basic (Declaration)
Public Shared HtmlBox As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGTags.HtmlBox

WGTags.HtmlBox = value
C#
public static string HtmlBox
Managed Extensions for C++
public: static string* HtmlBox
C++/CLI
public:
static String^ HtmlBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGTags Class
WGTags Members


InvokeMethod Field

[image]
Gizmox.WebGUI.Common
InvokeMethod Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGTags Class : InvokeMethod Field

Syntax

Visual Basic (Declaration)
Public Shared InvokeMethod As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGTags.InvokeMethod

WGTags.InvokeMethod = value
C#
public static string InvokeMethod
Managed Extensions for C++
public: static string* InvokeMethod
C++/CLI
public:
static String^ InvokeMethod

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGTags Class
WGTags Members


Item Field

[image]
Gizmox.WebGUI.Common
Item Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGTags Class : Item Field

Syntax

Visual Basic (Declaration)
Public Shared Item As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGTags.Item

WGTags.Item = value
C#
public static string Item
Managed Extensions for C++
public: static string* Item
C++/CLI
public:
static String^ Item

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGTags Class
WGTags Members


Label Field

[image]
Gizmox.WebGUI.Common
Label Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGTags Class : Label Field

Syntax

Visual Basic (Declaration)
Public Shared Label As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGTags.Label

WGTags.Label = value
C#
public static string Label
Managed Extensions for C++
public: static string* Label
C++/CLI
public:
static String^ Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGTags Class
WGTags Members


Line Field

[image]
Gizmox.WebGUI.Common
Line Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGTags Class : Line Field

Syntax

Visual Basic (Declaration)
Public Shared Line As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGTags.Line

WGTags.Line = value
C#
public static string Line
Managed Extensions for C++
public: static string* Line
C++/CLI
public:
static String^ Line

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGTags Class
WGTags Members


LinkLabel Field

[image]
Gizmox.WebGUI.Common
LinkLabel Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGTags Class : LinkLabel Field

Syntax

Visual Basic (Declaration)
Public Shared LinkLabel As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGTags.LinkLabel

WGTags.LinkLabel = value
C#
public static string LinkLabel
Managed Extensions for C++
public: static string* LinkLabel
C++/CLI
public:
static String^ LinkLabel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGTags Class
WGTags Members


ListBox Field

[image]
Gizmox.WebGUI.Common
ListBox Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGTags Class : ListBox Field

Syntax

Visual Basic (Declaration)
Public Shared ListBox As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGTags.ListBox

WGTags.ListBox = value
C#
public static string ListBox
Managed Extensions for C++
public: static string* ListBox
C++/CLI
public:
static String^ ListBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGTags Class
WGTags Members


ListView Field

[image]
Gizmox.WebGUI.Common
ListView Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGTags Class : ListView Field

Syntax

Visual Basic (Declaration)
Public Shared ListView As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGTags.ListView

WGTags.ListView = value
C#
public static string ListView
Managed Extensions for C++
public: static string* ListView
C++/CLI
public:
static String^ ListView

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGTags Class
WGTags Members


MainMenu Field

[image]
Gizmox.WebGUI.Common
MainMenu Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGTags Class : MainMenu Field

Syntax

Visual Basic (Declaration)
Public Shared MainMenu As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGTags.MainMenu

WGTags.MainMenu = value
C#
public static string MainMenu
Managed Extensions for C++
public: static string* MainMenu
C++/CLI
public:
static String^ MainMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGTags Class
WGTags Members


Manifest Field

[image]
Gizmox.WebGUI.Common
Manifest Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGTags Class : Manifest Field

Syntax

Visual Basic (Declaration)
Public Shared Manifest As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGTags.Manifest

WGTags.Manifest = value
C#
public static string Manifest
Managed Extensions for C++
public: static string* Manifest
C++/CLI
public:
static String^ Manifest

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGTags Class
WGTags Members


MdiClient Field

[image]
Gizmox.WebGUI.Common
MdiClient Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGTags Class : MdiClient Field

Syntax

Visual Basic (Declaration)
Public Shared MdiClient As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGTags.MdiClient

WGTags.MdiClient = value
C#
public static string MdiClient
Managed Extensions for C++
public: static string* MdiClient
C++/CLI
public:
static String^ MdiClient

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGTags Class
WGTags Members


Menu Field

[image]
Gizmox.WebGUI.Common
Menu Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGTags Class : Menu Field

Syntax

Visual Basic (Declaration)
Public Shared Menu As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGTags.Menu

WGTags.Menu = value
C#
public static string Menu
Managed Extensions for C++
public: static string* Menu
C++/CLI
public:
static String^ Menu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGTags Class
WGTags Members


MenuItem Field

[image]
Gizmox.WebGUI.Common
MenuItem Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGTags Class : MenuItem Field

Syntax

Visual Basic (Declaration)
Public Shared MenuItem As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGTags.MenuItem

WGTags.MenuItem = value
C#
public static string MenuItem
Managed Extensions for C++
public: static string* MenuItem
C++/CLI
public:
static String^ MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGTags Class
WGTags Members


MonthCalendar Field

[image]
Gizmox.WebGUI.Common
MonthCalendar Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGTags Class : MonthCalendar Field

Syntax

Visual Basic (Declaration)
Public Shared MonthCalendar As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGTags.MonthCalendar

WGTags.MonthCalendar = value
C#
public static string MonthCalendar
Managed Extensions for C++
public: static string* MonthCalendar
C++/CLI
public:
static String^ MonthCalendar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGTags Class
WGTags Members


NumericUpDown Field

[image]
Gizmox.WebGUI.Common
NumericUpDown Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGTags Class : NumericUpDown Field

Syntax

Visual Basic (Declaration)
Public Shared NumericUpDown As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGTags.NumericUpDown

WGTags.NumericUpDown = value
C#
public static string NumericUpDown
Managed Extensions for C++
public: static string* NumericUpDown
C++/CLI
public:
static String^ NumericUpDown

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGTags Class
WGTags Members


Object Field

[image]
Gizmox.WebGUI.Common
Object Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGTags Class : Object Field

Syntax

Visual Basic (Declaration)
Public Shared Object As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGTags.Object

WGTags.Object = value
C#
public static string Object
Managed Extensions for C++
public: static string* Object
C++/CLI
public:
static String^ Object

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGTags Class
WGTags Members


Option Field

[image]
Gizmox.WebGUI.Common
Option Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGTags Class : Option Field

Syntax

Visual Basic (Declaration)
Public Shared Option As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGTags.Option

WGTags.Option = value
C#
public static string Option
Managed Extensions for C++
public: static string* Option
C++/CLI
public:
static String^ Option

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGTags Class
WGTags Members


Options Field

[image]
Gizmox.WebGUI.Common
Options Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGTags Class : Options Field

Syntax

Visual Basic (Declaration)
Public Shared Options As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGTags.Options

WGTags.Options = value
C#
public static string Options
Managed Extensions for C++
public: static string* Options
C++/CLI
public:
static String^ Options

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGTags Class
WGTags Members


Package Field

[image]
Gizmox.WebGUI.Common
Package Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGTags Class : Package Field

Syntax

Visual Basic (Declaration)
Public Shared Package As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGTags.Package

WGTags.Package = value
C#
public static string Package
Managed Extensions for C++
public: static string* Package
C++/CLI
public:
static String^ Package

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGTags Class
WGTags Members


Packages Field

[image]
Gizmox.WebGUI.Common
Packages Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGTags Class : Packages Field

Syntax

Visual Basic (Declaration)
Public Shared Packages As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGTags.Packages

WGTags.Packages = value
C#
public static string Packages
Managed Extensions for C++
public: static string* Packages
C++/CLI
public:
static String^ Packages

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGTags Class
WGTags Members


Panel Field

[image]
Gizmox.WebGUI.Common
Panel Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGTags Class : Panel Field

Syntax

Visual Basic (Declaration)
Public Shared Panel As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGTags.Panel

WGTags.Panel = value
C#
public static string Panel
Managed Extensions for C++
public: static string* Panel
C++/CLI
public:
static String^ Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGTags Class
WGTags Members


Param Field

[image]
Gizmox.WebGUI.Common
Param Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGTags Class : Param Field

Syntax

Visual Basic (Declaration)
Public Shared Param As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGTags.Param

WGTags.Param = value
C#
public static string Param
Managed Extensions for C++
public: static string* Param
C++/CLI
public:
static String^ Param

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGTags Class
WGTags Members


PictureBox Field

[image]
Gizmox.WebGUI.Common
PictureBox Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGTags Class : PictureBox Field

Syntax

Visual Basic (Declaration)
Public Shared PictureBox As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGTags.PictureBox

WGTags.PictureBox = value
C#
public static string PictureBox
Managed Extensions for C++
public: static string* PictureBox
C++/CLI
public:
static String^ PictureBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGTags Class
WGTags Members


ProgressBar Field

[image]
Gizmox.WebGUI.Common
ProgressBar Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGTags Class : ProgressBar Field

Syntax

Visual Basic (Declaration)
Public Shared ProgressBar As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGTags.ProgressBar

WGTags.ProgressBar = value
C#
public static string ProgressBar
Managed Extensions for C++
public: static string* ProgressBar
C++/CLI
public:
static String^ ProgressBar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGTags Class
WGTags Members


PropertyGrid Field

[image]
Gizmox.WebGUI.Common
PropertyGrid Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGTags Class : PropertyGrid Field

Syntax

Visual Basic (Declaration)
Public Shared PropertyGrid As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGTags.PropertyGrid

WGTags.PropertyGrid = value
C#
public static string PropertyGrid
Managed Extensions for C++
public: static string* PropertyGrid
C++/CLI
public:
static String^ PropertyGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGTags Class
WGTags Members


PropertyGridEntry Field

[image]
Gizmox.WebGUI.Common
PropertyGridEntry Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGTags Class : PropertyGridEntry Field

Syntax

Visual Basic (Declaration)
Public Shared PropertyGridEntry As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGTags.PropertyGridEntry

WGTags.PropertyGridEntry = value
C#
public static string PropertyGridEntry
Managed Extensions for C++
public: static string* PropertyGridEntry
C++/CLI
public:
static String^ PropertyGridEntry

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGTags Class
WGTags Members


PropertyGridView Field

[image]
Gizmox.WebGUI.Common
PropertyGridView Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGTags Class : PropertyGridView Field

Syntax

Visual Basic (Declaration)
Public Shared PropertyGridView As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGTags.PropertyGridView

WGTags.PropertyGridView = value
C#
public static string PropertyGridView
Managed Extensions for C++
public: static string* PropertyGridView
C++/CLI
public:
static String^ PropertyGridView

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGTags Class
WGTags Members


RadioButton Field

[image]
Gizmox.WebGUI.Common
RadioButton Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGTags Class : RadioButton Field

Syntax

Visual Basic (Declaration)
Public Shared RadioButton As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGTags.RadioButton

WGTags.RadioButton = value
C#
public static string RadioButton
Managed Extensions for C++
public: static string* RadioButton
C++/CLI
public:
static String^ RadioButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGTags Class
WGTags Members


Refresh Field

[image]
Gizmox.WebGUI.Common
Refresh Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGTags Class : Refresh Field

Syntax

Visual Basic (Declaration)
Public Shared Refresh As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGTags.Refresh

WGTags.Refresh = value
C#
public static string Refresh
Managed Extensions for C++
public: static string* Refresh
C++/CLI
public:
static String^ Refresh

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGTags Class
WGTags Members


Response Field

[image]
Gizmox.WebGUI.Common
Response Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGTags Class : Response Field

Syntax

Visual Basic (Declaration)
Public Shared Response As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGTags.Response

WGTags.Response = value
C#
public static string Response
Managed Extensions for C++
public: static string* Response
C++/CLI
public:
static String^ Response

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGTags Class
WGTags Members


RichTextBox Field

[image]
Gizmox.WebGUI.Common
RichTextBox Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGTags Class : RichTextBox Field

Syntax

Visual Basic (Declaration)
Public Shared RichTextBox As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGTags.RichTextBox

WGTags.RichTextBox = value
C#
public static string RichTextBox
Managed Extensions for C++
public: static string* RichTextBox
C++/CLI
public:
static String^ RichTextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGTags Class
WGTags Members


Row Field

[image]
Gizmox.WebGUI.Common
Row Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGTags Class : Row Field

Syntax

Visual Basic (Declaration)
Public Shared Row As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGTags.Row

WGTags.Row = value
C#
public static string Row
Managed Extensions for C++
public: static string* Row
C++/CLI
public:
static String^ Row

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGTags Class
WGTags Members


Rows Field

[image]
Gizmox.WebGUI.Common
Rows Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGTags Class : Rows Field

Syntax

Visual Basic (Declaration)
Public Shared Rows As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGTags.Rows

WGTags.Rows = value
C#
public static string Rows
Managed Extensions for C++
public: static string* Rows
C++/CLI
public:
static String^ Rows

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGTags Class
WGTags Members


ScheduleBox Field

[image]
Gizmox.WebGUI.Common
ScheduleBox Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGTags Class : ScheduleBox Field

Syntax

Visual Basic (Declaration)
Public Shared ScheduleBox As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGTags.ScheduleBox

WGTags.ScheduleBox = value
C#
public static string ScheduleBox
Managed Extensions for C++
public: static string* ScheduleBox
C++/CLI
public:
static String^ ScheduleBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGTags Class
WGTags Members


ScrollablePanel Field

[image]
Gizmox.WebGUI.Common
ScrollablePanel Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGTags Class : ScrollablePanel Field

Syntax

Visual Basic (Declaration)
Public Shared ScrollablePanel As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGTags.ScrollablePanel

WGTags.ScrollablePanel = value
C#
public static string ScrollablePanel
Managed Extensions for C++
public: static string* ScrollablePanel
C++/CLI
public:
static String^ ScrollablePanel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGTags Class
WGTags Members


ShortcutsContainer Field

[image]
Gizmox.WebGUI.Common
ShortcutsContainer Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGTags Class : ShortcutsContainer Field

Syntax

Visual Basic (Declaration)
Public Shared ShortcutsContainer As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGTags.ShortcutsContainer

WGTags.ShortcutsContainer = value
C#
public static string ShortcutsContainer
Managed Extensions for C++
public: static string* ShortcutsContainer
C++/CLI
public:
static String^ ShortcutsContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGTags Class
WGTags Members


Splitter Field

[image]
Gizmox.WebGUI.Common
Splitter Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGTags Class : Splitter Field

Syntax

Visual Basic (Declaration)
Public Shared Splitter As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGTags.Splitter

WGTags.Splitter = value
C#
public static string Splitter
Managed Extensions for C++
public: static string* Splitter
C++/CLI
public:
static String^ Splitter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGTags Class
WGTags Members


StatusBar Field

[image]
Gizmox.WebGUI.Common
StatusBar Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGTags Class : StatusBar Field

Syntax

Visual Basic (Declaration)
Public Shared StatusBar As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGTags.StatusBar

WGTags.StatusBar = value
C#
public static string StatusBar
Managed Extensions for C++
public: static string* StatusBar
C++/CLI
public:
static String^ StatusBar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGTags Class
WGTags Members


StatusPanel Field

[image]
Gizmox.WebGUI.Common
StatusPanel Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGTags Class : StatusPanel Field

Syntax

Visual Basic (Declaration)
Public Shared StatusPanel As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGTags.StatusPanel

WGTags.StatusPanel = value
C#
public static string StatusPanel
Managed Extensions for C++
public: static string* StatusPanel
C++/CLI
public:
static String^ StatusPanel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGTags Class
WGTags Members


TabControl Field

[image]
Gizmox.WebGUI.Common
TabControl Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGTags Class : TabControl Field

Syntax

Visual Basic (Declaration)
Public Shared TabControl As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGTags.TabControl

WGTags.TabControl = value
C#
public static string TabControl
Managed Extensions for C++
public: static string* TabControl
C++/CLI
public:
static String^ TabControl

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGTags Class
WGTags Members


TableLayoutCell Field

[image]
Gizmox.WebGUI.Common
TableLayoutCell Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGTags Class : TableLayoutCell Field

Syntax

Visual Basic (Declaration)
Public Shared TableLayoutCell As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGTags.TableLayoutCell

WGTags.TableLayoutCell = value
C#
public static string TableLayoutCell
Managed Extensions for C++
public: static string* TableLayoutCell
C++/CLI
public:
static String^ TableLayoutCell

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGTags Class
WGTags Members


TableLayoutCol Field

[image]
Gizmox.WebGUI.Common
TableLayoutCol Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGTags Class : TableLayoutCol Field

Syntax

Visual Basic (Declaration)
Public Shared TableLayoutCol As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGTags.TableLayoutCol

WGTags.TableLayoutCol = value
C#
public static string TableLayoutCol
Managed Extensions for C++
public: static string* TableLayoutCol
C++/CLI
public:
static String^ TableLayoutCol

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGTags Class
WGTags Members


TableLayoutPanel Field

[image]
Gizmox.WebGUI.Common
TableLayoutPanel Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGTags Class : TableLayoutPanel Field

Syntax

Visual Basic (Declaration)
Public Shared TableLayoutPanel As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGTags.TableLayoutPanel

WGTags.TableLayoutPanel = value
C#
public static string TableLayoutPanel
Managed Extensions for C++
public: static string* TableLayoutPanel
C++/CLI
public:
static String^ TableLayoutPanel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGTags Class
WGTags Members


TableLayoutRow Field

[image]
Gizmox.WebGUI.Common
TableLayoutRow Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGTags Class : TableLayoutRow Field

Syntax

Visual Basic (Declaration)
Public Shared TableLayoutRow As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGTags.TableLayoutRow

WGTags.TableLayoutRow = value
C#
public static string TableLayoutRow
Managed Extensions for C++
public: static string* TableLayoutRow
C++/CLI
public:
static String^ TableLayoutRow

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGTags Class
WGTags Members


TabPage Field

[image]
Gizmox.WebGUI.Common
TabPage Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGTags Class : TabPage Field

Syntax

Visual Basic (Declaration)
Public Shared TabPage As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGTags.TabPage

WGTags.TabPage = value
C#
public static string TabPage
Managed Extensions for C++
public: static string* TabPage
C++/CLI
public:
static String^ TabPage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGTags Class
WGTags Members


Tag Field

[image]
Gizmox.WebGUI.Common
Tag Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGTags Class : Tag Field

Syntax

Visual Basic (Declaration)
Public Shared Tag As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGTags.Tag

WGTags.Tag = value
C#
public static string Tag
Managed Extensions for C++
public: static string* Tag
C++/CLI
public:
static String^ Tag

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGTags Class
WGTags Members


Tags Field

[image]
Gizmox.WebGUI.Common
Tags Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGTags Class : Tags Field

Syntax

Visual Basic (Declaration)
Public Shared Tags As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGTags.Tags

WGTags.Tags = value
C#
public static string Tags
Managed Extensions for C++
public: static string* Tags
C++/CLI
public:
static String^ Tags

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGTags Class
WGTags Members


TextBox Field

[image]
Gizmox.WebGUI.Common
TextBox Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGTags Class : TextBox Field

Syntax

Visual Basic (Declaration)
Public Shared TextBox As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGTags.TextBox

WGTags.TextBox = value
C#
public static string TextBox
Managed Extensions for C++
public: static string* TextBox
C++/CLI
public:
static String^ TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGTags Class
WGTags Members


Theme Field

[image]
Gizmox.WebGUI.Common
Theme Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGTags Class : Theme Field

Syntax

Visual Basic (Declaration)
Public Shared Theme As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGTags.Theme

WGTags.Theme = value
C#
public static string Theme
Managed Extensions for C++
public: static string* Theme
C++/CLI
public:
static String^ Theme

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGTags Class
WGTags Members


Themes Field

[image]
Gizmox.WebGUI.Common
Themes Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGTags Class : Themes Field

Syntax

Visual Basic (Declaration)
Public Shared Themes As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGTags.Themes

WGTags.Themes = value
C#
public static string Themes
Managed Extensions for C++
public: static string* Themes
C++/CLI
public:
static String^ Themes

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGTags Class
WGTags Members


ToolBarButton Field

[image]
Gizmox.WebGUI.Common
ToolBarButton Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGTags Class : ToolBarButton Field

Syntax

Visual Basic (Declaration)
Public Shared ToolBarButton As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGTags.ToolBarButton

WGTags.ToolBarButton = value
C#
public static string ToolBarButton
Managed Extensions for C++
public: static string* ToolBarButton
C++/CLI
public:
static String^ ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGTags Class
WGTags Members


ToolBarControl Field

[image]
Gizmox.WebGUI.Common
ToolBarControl Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGTags Class : ToolBarControl Field

Syntax

Visual Basic (Declaration)
Public Shared ToolBarControl As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGTags.ToolBarControl

WGTags.ToolBarControl = value
C#
public static string ToolBarControl
Managed Extensions for C++
public: static string* ToolBarControl
C++/CLI
public:
static String^ ToolBarControl

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGTags Class
WGTags Members


TrackBar Field

[image]
Gizmox.WebGUI.Common
TrackBar Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGTags Class : TrackBar Field

Syntax

Visual Basic (Declaration)
Public Shared TrackBar As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGTags.TrackBar

WGTags.TrackBar = value
C#
public static string TrackBar
Managed Extensions for C++
public: static string* TrackBar
C++/CLI
public:
static String^ TrackBar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGTags Class
WGTags Members


TreeNode Field

[image]
Gizmox.WebGUI.Common
TreeNode Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGTags Class : TreeNode Field

Syntax

Visual Basic (Declaration)
Public Shared TreeNode As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGTags.TreeNode

WGTags.TreeNode = value
C#
public static string TreeNode
Managed Extensions for C++
public: static string* TreeNode
C++/CLI
public:
static String^ TreeNode

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGTags Class
WGTags Members


TreeView Field

[image]
Gizmox.WebGUI.Common
TreeView Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGTags Class : TreeView Field

Syntax

Visual Basic (Declaration)
Public Shared TreeView As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGTags.TreeView

WGTags.TreeView = value
C#
public static string TreeView
Managed Extensions for C++
public: static string* TreeView
C++/CLI
public:
static String^ TreeView

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGTags Class
WGTags Members


UpdateParams Field

[image]
Gizmox.WebGUI.Common
UpdateParams Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGTags Class : UpdateParams Field

Syntax

Visual Basic (Declaration)
Public Shared UpdateParams As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGTags.UpdateParams

WGTags.UpdateParams = value
C#
public static string UpdateParams
Managed Extensions for C++
public: static string* UpdateParams
C++/CLI
public:
static String^ UpdateParams

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGTags Class
WGTags Members


UserControl Field

[image]
Gizmox.WebGUI.Common
UserControl Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGTags Class : UserControl Field

Syntax

Visual Basic (Declaration)
Public Shared UserControl As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGTags.UserControl

WGTags.UserControl = value
C#
public static string UserControl
Managed Extensions for C++
public: static string* UserControl
C++/CLI
public:
static String^ UserControl

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGTags Class
WGTags Members


XamlBox Field

[image]
Gizmox.WebGUI.Common
XamlBox Field
See Also Send Feedback
Gizmox.WebGUI Namespace > WGTags Class : XamlBox Field

Syntax

Visual Basic (Declaration)
Public Shared XamlBox As String
Visual Basic (Usage) Copy Code
Dim value As String

value = WGTags.XamlBox

WGTags.XamlBox = value
C#
public static string XamlBox
Managed Extensions for C++
public: static string* XamlBox
C++/CLI
public:
static String^ XamlBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGTags Class
WGTags Members


Gizmox.WebGUI.Client.Design Namespace

Gizmox.WebGUI.Common
Gizmox.WebGUI.Client.Design Namespace
See Also Inheritance Hierarchy Send Feedback

Interfaces

 | Interface | Description
Interface | IClientDesigner |
Interface | IClientDesignServices |
Interface | IClientObjectController |
Interface | IClinetDesignContext |
Interface | IContextServices |

See Also

Reference

Gizmox.WebGUI.Common Assembly


IClientDesigner Interface

[image]
Gizmox.WebGUI.Common
IClientDesigner Interface
Members See Also Send Feedback
Gizmox.WebGUI.Client.Design Namespace : IClientDesigner Interface

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Interface IClientDesigner
Visual Basic (Usage) Copy Code
Dim instance As IClientDesigner
C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public interface IClientDesigner
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public __gc __interface IClientDesigner
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public interface class IClientDesigner

Requirements

Namespace: Gizmox.WebGUI.Client.Design

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

IClientDesigner Members
Gizmox.WebGUI.Client.Design Namespace


IClientDesigner Interface Members

[image]
Gizmox.WebGUI.Common
IClientDesigner Interface Members
See Also Methods Send Feedback
Gizmox.WebGUI.Client.Design Namespace : IClientDesigner Interface

The following tables list the members exposed by IClientDesigner.

Public Methods

 | Name | Description
Method | GetVerbs |
Top

See Also

Reference

IClientDesigner Interface
Gizmox.WebGUI.Client.Design Namespace


IClientDesigner Interface Methods

[image]
Gizmox.WebGUI.Common
IClientDesigner Interface Methods
See Also Send Feedback
Gizmox.WebGUI.Client.Design Namespace : IClientDesigner Interface

For a list of all members of this type, see IClientDesigner members.

Public Methods

 | Name | Description
Method | GetVerbs |
Top

See Also

Reference

IClientDesigner Interface
Gizmox.WebGUI.Client.Design Namespace


GetVerbs Method

[image]
Gizmox.WebGUI.Common
GetVerbs Method
See Also Send Feedback
Gizmox.WebGUI.Client.Design Namespace > IClientDesigner Interface : GetVerbs Method

Syntax

Visual Basic (Declaration)
Function GetVerbs() As DesignerVerbCollection
Visual Basic (Usage) Copy Code
Dim instance As IClientDesigner
Dim value As DesignerVerbCollection

value = instance.GetVerbs()
C#
DesignerVerbCollection GetVerbs()
Managed Extensions for C++
DesignerVerbCollection* GetVerbs();
C++/CLI
DesignerVerbCollection^ GetVerbs();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IClientDesigner Interface
IClientDesigner Members


IClientDesignServices Interface

[image]
Gizmox.WebGUI.Common
IClientDesignServices Interface
Members See Also Send Feedback
Gizmox.WebGUI.Client.Design Namespace : IClientDesignServices Interface

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Interface IClientDesignServices
Visual Basic (Usage) Copy Code
Dim instance As IClientDesignServices
C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public interface IClientDesignServices
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public __gc __interface IClientDesignServices
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public interface class IClientDesignServices

Requirements

Namespace: Gizmox.WebGUI.Client.Design

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

IClientDesignServices Members
Gizmox.WebGUI.Client.Design Namespace


IClientDesignServices Interface Members

[image]
Gizmox.WebGUI.Common
IClientDesignServices Interface Members
See Also Methods Send Feedback
Gizmox.WebGUI.Client.Design Namespace : IClientDesignServices Interface

The following tables list the members exposed by IClientDesignServices.

Public Methods

 | Name | Description
Method | FireWebComponentChanged |
Method | FireWebComponentChanging |
Method | GetConfiguration |
Method | GetNamedDirecotry |
Method | GetSelectedWebComponents |
Method | GetSelectedWinComponents |
Method | IsRegisteredWebComponent |
Method | IsRegisteredWinComponent |
Method | RefreshDesigner |
Method | RegisterWebComponent | Overloaded.
Method | RegisterWinComponent | Overloaded.
Method | SelectWebComponent |
Method | UnregisterWebComponent |
Method | UnregisterWinComponent |
Top

See Also

Reference

IClientDesignServices Interface
Gizmox.WebGUI.Client.Design Namespace


IClientDesignServices Interface Methods

[image]
Gizmox.WebGUI.Common
IClientDesignServices Interface Methods
See Also Send Feedback
Gizmox.WebGUI.Client.Design Namespace : IClientDesignServices Interface

For a list of all members of this type, see IClientDesignServices members.

Public Methods

 | Name | Description
Method | FireWebComponentChanged |
Method | FireWebComponentChanging |
Method | GetConfiguration |
Method | GetNamedDirecotry |
Method | GetSelectedWebComponents |
Method | GetSelectedWinComponents |
Method | IsRegisteredWebComponent |
Method | IsRegisteredWinComponent |
Method | RefreshDesigner |
Method | RegisterWebComponent | Overloaded.
Method | RegisterWinComponent | Overloaded.
Method | SelectWebComponent |
Method | UnregisterWebComponent |
Method | UnregisterWinComponent |
Top

See Also

Reference

IClientDesignServices Interface
Gizmox.WebGUI.Client.Design Namespace


FireWebComponentChanged Method

[image]
Gizmox.WebGUI.Common
FireWebComponentChanged Method
See Also Send Feedback
Gizmox.WebGUI.Client.Design Namespace > IClientDesignServices Interface : FireWebComponentChanged Method

objSource
strPropertyName
objOldValue
objNewValue

Syntax

Visual Basic (Declaration)
Sub FireWebComponentChanged( _
   ByVal objSource As Object, _
   ByVal strPropertyName As String, _
   ByVal objOldValue As Object, _
   ByVal objNewValue As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As IClientDesignServices
Dim objSource As Object
Dim strPropertyName As String
Dim objOldValue As Object
Dim objNewValue As Object

instance.FireWebComponentChanged(objSource, strPropertyName, objOldValue, objNewValue)
C#
void FireWebComponentChanged(
   object objSource,
   string strPropertyName,
   object objOldValue,
   object objNewValue
)
Managed Extensions for C++
void FireWebComponentChanged(
   Object* objSource,
   string* strPropertyName,
   Object* objOldValue,
   Object* objNewValue
)
C++/CLI
void FireWebComponentChanged(
   Object^ objSource,
   String^ strPropertyName,
   Object^ objOldValue,
   Object^ objNewValue
)

Parameters

objSource
strPropertyName
objOldValue
objNewValue

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IClientDesignServices Interface
IClientDesignServices Members


FireWebComponentChanging Method

[image]
Gizmox.WebGUI.Common
FireWebComponentChanging Method
See Also Send Feedback
Gizmox.WebGUI.Client.Design Namespace > IClientDesignServices Interface : FireWebComponentChanging Method

objSource
strPropertyName

Syntax

Visual Basic (Declaration)
Sub FireWebComponentChanging( _
   ByVal objSource As Object, _
   ByVal strPropertyName As String _
)
Visual Basic (Usage) Copy Code
Dim instance As IClientDesignServices
Dim objSource As Object
Dim strPropertyName As String

instance.FireWebComponentChanging(objSource, strPropertyName)
C#
void FireWebComponentChanging(
   object objSource,
   string strPropertyName
)
Managed Extensions for C++
void FireWebComponentChanging(
   Object* objSource,
   string* strPropertyName
)
C++/CLI
void FireWebComponentChanging(
   Object^ objSource,
   String^ strPropertyName
)

Parameters

objSource
strPropertyName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IClientDesignServices Interface
IClientDesignServices Members


GetConfiguration Method

[image]
Gizmox.WebGUI.Common
GetConfiguration Method
See Also Send Feedback
Gizmox.WebGUI.Client.Design Namespace > IClientDesignServices Interface : GetConfiguration Method

Syntax

Visual Basic (Declaration)
Function GetConfiguration() As Config
Visual Basic (Usage) Copy Code
Dim instance As IClientDesignServices
Dim value As Config

value = instance.GetConfiguration()
C#
Config GetConfiguration()
Managed Extensions for C++
Config* GetConfiguration();
C++/CLI
Config^ GetConfiguration();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IClientDesignServices Interface
IClientDesignServices Members


GetNamedDirecotry Method

[image]
Gizmox.WebGUI.Common
GetNamedDirecotry Method
See Also Send Feedback
Gizmox.WebGUI.Client.Design Namespace > IClientDesignServices Interface : GetNamedDirecotry Method

strDirectoryName

Syntax

Visual Basic (Declaration)
Function GetNamedDirecotry( _
   ByVal strDirectoryName As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As IClientDesignServices
Dim strDirectoryName As String
Dim value As String

value = instance.GetNamedDirecotry(strDirectoryName)
C#
string GetNamedDirecotry(
   string strDirectoryName
)
Managed Extensions for C++
string* GetNamedDirecotry(
   string* strDirectoryName
)
C++/CLI
String^ GetNamedDirecotry(
   String^ strDirectoryName
)

Parameters

strDirectoryName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IClientDesignServices Interface
IClientDesignServices Members


GetSelectedWebComponents Method

[image]
Gizmox.WebGUI.Common
GetSelectedWebComponents Method
See Also Send Feedback
Gizmox.WebGUI.Client.Design Namespace > IClientDesignServices Interface : GetSelectedWebComponents Method

Syntax

Visual Basic (Declaration)
Function GetSelectedWebComponents() As ICollection
Visual Basic (Usage) Copy Code
Dim instance As IClientDesignServices
Dim value As ICollection

value = instance.GetSelectedWebComponents()
C#
ICollection GetSelectedWebComponents()
Managed Extensions for C++
ICollection* GetSelectedWebComponents();
C++/CLI
ICollection^ GetSelectedWebComponents();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IClientDesignServices Interface
IClientDesignServices Members


GetSelectedWinComponents Method

[image]
Gizmox.WebGUI.Common
GetSelectedWinComponents Method
See Also Send Feedback
Gizmox.WebGUI.Client.Design Namespace > IClientDesignServices Interface : GetSelectedWinComponents Method

Syntax

Visual Basic (Declaration)
Function GetSelectedWinComponents() As ICollection
Visual Basic (Usage) Copy Code
Dim instance As IClientDesignServices
Dim value As ICollection

value = instance.GetSelectedWinComponents()
C#
ICollection GetSelectedWinComponents()
Managed Extensions for C++
ICollection* GetSelectedWinComponents();
C++/CLI
ICollection^ GetSelectedWinComponents();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IClientDesignServices Interface
IClientDesignServices Members


IsRegisteredWebComponent Method

[image]
Gizmox.WebGUI.Common
IsRegisteredWebComponent Method
See Also Send Feedback
Gizmox.WebGUI.Client.Design Namespace > IClientDesignServices Interface : IsRegisteredWebComponent Method

objWebComponent

Syntax

Visual Basic (Declaration)
Function IsRegisteredWebComponent( _
   ByVal objWebComponent As IComponent _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As IClientDesignServices
Dim objWebComponent As IComponent
Dim value As Boolean

value = instance.IsRegisteredWebComponent(objWebComponent)
C#
bool IsRegisteredWebComponent(
   IComponent objWebComponent
)
Managed Extensions for C++
bool IsRegisteredWebComponent(
   IComponent* objWebComponent
)
C++/CLI
bool IsRegisteredWebComponent(
   IComponent^ objWebComponent
)

Parameters

objWebComponent

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IClientDesignServices Interface
IClientDesignServices Members


IsRegisteredWinComponent Method

[image]
Gizmox.WebGUI.Common
IsRegisteredWinComponent Method
See Also Send Feedback
Gizmox.WebGUI.Client.Design Namespace > IClientDesignServices Interface : IsRegisteredWinComponent Method

objWinComponent

Syntax

Visual Basic (Declaration)
Function IsRegisteredWinComponent( _
   ByVal objWinComponent As IComponent _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As IClientDesignServices
Dim objWinComponent As IComponent
Dim value As Boolean

value = instance.IsRegisteredWinComponent(objWinComponent)
C#
bool IsRegisteredWinComponent(
   IComponent objWinComponent
)
Managed Extensions for C++
bool IsRegisteredWinComponent(
   IComponent* objWinComponent
)
C++/CLI
bool IsRegisteredWinComponent(
   IComponent^ objWinComponent
)

Parameters

objWinComponent

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IClientDesignServices Interface
IClientDesignServices Members


RefreshDesigner Method

[image]
Gizmox.WebGUI.Common
RefreshDesigner Method
See Also Send Feedback
Gizmox.WebGUI.Client.Design Namespace > IClientDesignServices Interface : RefreshDesigner Method

Syntax

Visual Basic (Declaration)
Sub RefreshDesigner()
Visual Basic (Usage) Copy Code
Dim instance As IClientDesignServices

instance.RefreshDesigner()
C#
void RefreshDesigner()
Managed Extensions for C++
void RefreshDesigner();
C++/CLI
void RefreshDesigner();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IClientDesignServices Interface
IClientDesignServices Members


RegisterWebComponent Method

[image]
Gizmox.WebGUI.Common
RegisterWebComponent Method
See Also Send Feedback
Gizmox.WebGUI.Client.Design Namespace > IClientDesignServices Interface : RegisterWebComponent Method

Overload List

Overload | Description
RegisterWebComponent(IComponent) |
RegisterWebComponent(IComponent,String) |
RegisterWebComponent(IComponent,IComponent) |
RegisterWebComponent(IComponent,IComponent,String) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IClientDesignServices Interface
IClientDesignServices Members


RegisterWebComponent(IComponent) Method

[image]
Gizmox.WebGUI.Common
RegisterWebComponent(IComponent) Method
See Also Send Feedback
Gizmox.WebGUI.Client.Design Namespace > IClientDesignServices Interface > RegisterWebComponent Method : RegisterWebComponent(IComponent) Method

objWebComponent

Syntax

Visual Basic (Declaration)
Overloads Sub RegisterWebComponent( _
   ByVal objWebComponent As IComponent _
)
Visual Basic (Usage) Copy Code
Dim instance As IClientDesignServices
Dim objWebComponent As IComponent

instance.RegisterWebComponent(objWebComponent)
C#
void RegisterWebComponent(
   IComponent objWebComponent
)
Managed Extensions for C++
void RegisterWebComponent(
   IComponent* objWebComponent
)
C++/CLI
void RegisterWebComponent(
   IComponent^ objWebComponent
)

Parameters

objWebComponent

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IClientDesignServices Interface
IClientDesignServices Members
Overload List


RegisterWebComponent(IComponent,String) Method

[image]
Gizmox.WebGUI.Common
RegisterWebComponent(IComponent,String) Method
See Also Send Feedback
Gizmox.WebGUI.Client.Design Namespace > IClientDesignServices Interface > RegisterWebComponent Method : RegisterWebComponent(IComponent,String) Method

objWebComponent
strName

Syntax

Visual Basic (Declaration)
Overloads Sub RegisterWebComponent( _
   ByVal objWebComponent As IComponent, _
   ByVal strName As String _
)
Visual Basic (Usage) Copy Code
Dim instance As IClientDesignServices
Dim objWebComponent As IComponent
Dim strName As String

instance.RegisterWebComponent(objWebComponent, strName)
C#
void RegisterWebComponent(
   IComponent objWebComponent,
   string strName
)
Managed Extensions for C++
void RegisterWebComponent(
   IComponent* objWebComponent,
   string* strName
)
C++/CLI
void RegisterWebComponent(
   IComponent^ objWebComponent,
   String^ strName
)

Parameters

objWebComponent
strName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IClientDesignServices Interface
IClientDesignServices Members
Overload List


RegisterWebComponent(IComponent,IComponent) Method

[image]
Gizmox.WebGUI.Common
RegisterWebComponent(IComponent,IComponent) Method
See Also Send Feedback
Gizmox.WebGUI.Client.Design Namespace > IClientDesignServices Interface > RegisterWebComponent Method : RegisterWebComponent(IComponent,IComponent) Method

objContainerComponent
objWebComponent

Syntax

Visual Basic (Declaration)
Overloads Sub RegisterWebComponent( _
   ByVal objContainerComponent As IComponent, _
   ByVal objWebComponent As IComponent _
)
Visual Basic (Usage) Copy Code
Dim instance As IClientDesignServices
Dim objContainerComponent As IComponent
Dim objWebComponent As IComponent

instance.RegisterWebComponent(objContainerComponent, objWebComponent)
C#
void RegisterWebComponent(
   IComponent objContainerComponent,
   IComponent objWebComponent
)
Managed Extensions for C++
void RegisterWebComponent(
   IComponent* objContainerComponent,
   IComponent* objWebComponent
)
C++/CLI
void RegisterWebComponent(
   IComponent^ objContainerComponent,
   IComponent^ objWebComponent
)

Parameters

objContainerComponent
objWebComponent

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IClientDesignServices Interface
IClientDesignServices Members
Overload List


RegisterWebComponent(IComponent,IComponent,String) Method

[image]
Gizmox.WebGUI.Common
RegisterWebComponent(IComponent,IComponent,String) Method
See Also Send Feedback
Gizmox.WebGUI.Client.Design Namespace > IClientDesignServices Interface > RegisterWebComponent Method : RegisterWebComponent(IComponent,IComponent,String) Method

objContainerComponent
objWebComponent
strName

Syntax

Visual Basic (Declaration)
Overloads Sub RegisterWebComponent( _
   ByVal objContainerComponent As IComponent, _
   ByVal objWebComponent As IComponent, _
   ByVal strName As String _
)
Visual Basic (Usage) Copy Code
Dim instance As IClientDesignServices
Dim objContainerComponent As IComponent
Dim objWebComponent As IComponent
Dim strName As String

instance.RegisterWebComponent(objContainerComponent, objWebComponent, strName)
C#
void RegisterWebComponent(
   IComponent objContainerComponent,
   IComponent objWebComponent,
   string strName
)
Managed Extensions for C++
void RegisterWebComponent(
   IComponent* objContainerComponent,
   IComponent* objWebComponent,
   string* strName
)
C++/CLI
void RegisterWebComponent(
   IComponent^ objContainerComponent,
   IComponent^ objWebComponent,
   String^ strName
)

Parameters

objContainerComponent
objWebComponent
strName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IClientDesignServices Interface
IClientDesignServices Members
Overload List


RegisterWinComponent Method

[image]
Gizmox.WebGUI.Common
RegisterWinComponent Method
See Also Send Feedback
Gizmox.WebGUI.Client.Design Namespace > IClientDesignServices Interface : RegisterWinComponent Method

Overload List

Overload | Description
RegisterWinComponent(IComponent) |
RegisterWinComponent(IComponent,String) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IClientDesignServices Interface
IClientDesignServices Members


RegisterWinComponent(IComponent) Method

[image]
Gizmox.WebGUI.Common
RegisterWinComponent(IComponent) Method
See Also Send Feedback
Gizmox.WebGUI.Client.Design Namespace > IClientDesignServices Interface > RegisterWinComponent Method : RegisterWinComponent(IComponent) Method

objWinComponent

Syntax

Visual Basic (Declaration)
Overloads Sub RegisterWinComponent( _
   ByVal objWinComponent As IComponent _
)
Visual Basic (Usage) Copy Code
Dim instance As IClientDesignServices
Dim objWinComponent As IComponent

instance.RegisterWinComponent(objWinComponent)
C#
void RegisterWinComponent(
   IComponent objWinComponent
)
Managed Extensions for C++
void RegisterWinComponent(
   IComponent* objWinComponent
)
C++/CLI
void RegisterWinComponent(
   IComponent^ objWinComponent
)

Parameters

objWinComponent

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IClientDesignServices Interface
IClientDesignServices Members
Overload List


RegisterWinComponent(IComponent,String) Method

[image]
Gizmox.WebGUI.Common
RegisterWinComponent(IComponent,String) Method
See Also Send Feedback
Gizmox.WebGUI.Client.Design Namespace > IClientDesignServices Interface > RegisterWinComponent Method : RegisterWinComponent(IComponent,String) Method

objWinComponent
strName

Syntax

Visual Basic (Declaration)
Overloads Sub RegisterWinComponent( _
   ByVal objWinComponent As IComponent, _
   ByVal strName As String _
)
Visual Basic (Usage) Copy Code
Dim instance As IClientDesignServices
Dim objWinComponent As IComponent
Dim strName As String

instance.RegisterWinComponent(objWinComponent, strName)
C#
void RegisterWinComponent(
   IComponent objWinComponent,
   string strName
)
Managed Extensions for C++
void RegisterWinComponent(
   IComponent* objWinComponent,
   string* strName
)
C++/CLI
void RegisterWinComponent(
   IComponent^ objWinComponent,
   String^ strName
)

Parameters

objWinComponent
strName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IClientDesignServices Interface
IClientDesignServices Members
Overload List


SelectWebComponent Method

[image]
Gizmox.WebGUI.Common
SelectWebComponent Method
See Also Send Feedback
Gizmox.WebGUI.Client.Design Namespace > IClientDesignServices Interface : SelectWebComponent Method

objWebComponent

Syntax

Visual Basic (Declaration)
Sub SelectWebComponent( _
   ByVal objWebComponent As IComponent _
)
Visual Basic (Usage) Copy Code
Dim instance As IClientDesignServices
Dim objWebComponent As IComponent

instance.SelectWebComponent(objWebComponent)
C#
void SelectWebComponent(
   IComponent objWebComponent
)
Managed Extensions for C++
void SelectWebComponent(
   IComponent* objWebComponent
)
C++/CLI
void SelectWebComponent(
   IComponent^ objWebComponent
)

Parameters

objWebComponent

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IClientDesignServices Interface
IClientDesignServices Members


UnregisterWebComponent Method

[image]
Gizmox.WebGUI.Common
UnregisterWebComponent Method
See Also Send Feedback
Gizmox.WebGUI.Client.Design Namespace > IClientDesignServices Interface : UnregisterWebComponent Method

objWebComponent

Syntax

Visual Basic (Declaration)
Sub UnregisterWebComponent( _
   ByVal objWebComponent As IComponent _
)
Visual Basic (Usage) Copy Code
Dim instance As IClientDesignServices
Dim objWebComponent As IComponent

instance.UnregisterWebComponent(objWebComponent)
C#
void UnregisterWebComponent(
   IComponent objWebComponent
)
Managed Extensions for C++
void UnregisterWebComponent(
   IComponent* objWebComponent
)
C++/CLI
void UnregisterWebComponent(
   IComponent^ objWebComponent
)

Parameters

objWebComponent

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IClientDesignServices Interface
IClientDesignServices Members


UnregisterWinComponent Method

[image]
Gizmox.WebGUI.Common
UnregisterWinComponent Method
See Also Send Feedback
Gizmox.WebGUI.Client.Design Namespace > IClientDesignServices Interface : UnregisterWinComponent Method

objWinComponent

Syntax

Visual Basic (Declaration)
Sub UnregisterWinComponent( _
   ByVal objWinComponent As IComponent _
)
Visual Basic (Usage) Copy Code
Dim instance As IClientDesignServices
Dim objWinComponent As IComponent

instance.UnregisterWinComponent(objWinComponent)
C#
void UnregisterWinComponent(
   IComponent objWinComponent
)
Managed Extensions for C++
void UnregisterWinComponent(
   IComponent* objWinComponent
)
C++/CLI
void UnregisterWinComponent(
   IComponent^ objWinComponent
)

Parameters

objWinComponent

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IClientDesignServices Interface
IClientDesignServices Members


IClientObjectController Interface

[image]
Gizmox.WebGUI.Common
IClientObjectController Interface
Members See Also Send Feedback
Gizmox.WebGUI.Client.Design Namespace : IClientObjectController Interface

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Interface IClientObjectController
Visual Basic (Usage) Copy Code
Dim instance As IClientObjectController
C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public interface IClientObjectController
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public __gc __interface IClientObjectController
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public interface class IClientObjectController

Requirements

Namespace: Gizmox.WebGUI.Client.Design

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

IClientObjectController Members
Gizmox.WebGUI.Client.Design Namespace


IClientObjectController Interface Members

[image]
Gizmox.WebGUI.Common
IClientObjectController Interface Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Client.Design Namespace : IClientObjectController Interface

The following tables list the members exposed by IClientObjectController.

Public Properties

 | Name | Description
Property | SourceObject |
Property | TargetObject |
Top

Public Methods

 | Name | Description
Method | Initialize |
Method | InitializeNew |
Method | Load |
Method | SetParent |
Method | Terminate |
Top

See Also

Reference

IClientObjectController Interface
Gizmox.WebGUI.Client.Design Namespace


IClientObjectController Interface Methods

[image]
Gizmox.WebGUI.Common
IClientObjectController Interface Methods
See Also Send Feedback
Gizmox.WebGUI.Client.Design Namespace : IClientObjectController Interface

For a list of all members of this type, see IClientObjectController members.

Public Methods

 | Name | Description
Method | Initialize |
Method | InitializeNew |
Method | Load |
Method | SetParent |
Method | Terminate |
Top

See Also

Reference

IClientObjectController Interface
Gizmox.WebGUI.Client.Design Namespace


Initialize Method

[image]
Gizmox.WebGUI.Common
Initialize Method
See Also Send Feedback
Gizmox.WebGUI.Client.Design Namespace > IClientObjectController Interface : Initialize Method

Syntax

Visual Basic (Declaration)
Sub Initialize()
Visual Basic (Usage) Copy Code
Dim instance As IClientObjectController

instance.Initialize()
C#
void Initialize()
Managed Extensions for C++
void Initialize();
C++/CLI
void Initialize();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IClientObjectController Interface
IClientObjectController Members


InitializeNew Method

[image]
Gizmox.WebGUI.Common
InitializeNew Method
See Also Send Feedback
Gizmox.WebGUI.Client.Design Namespace > IClientObjectController Interface : InitializeNew Method

Syntax

Visual Basic (Declaration)
Sub InitializeNew()
Visual Basic (Usage) Copy Code
Dim instance As IClientObjectController

instance.InitializeNew()
C#
void InitializeNew()
Managed Extensions for C++
void InitializeNew();
C++/CLI
void InitializeNew();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IClientObjectController Interface
IClientObjectController Members


Load Method

[image]
Gizmox.WebGUI.Common
Load Method
See Also Send Feedback
Gizmox.WebGUI.Client.Design Namespace > IClientObjectController Interface : Load Method

Syntax

Visual Basic (Declaration)
Sub Load()
Visual Basic (Usage) Copy Code
Dim instance As IClientObjectController

instance.Load()
C#
void Load()
Managed Extensions for C++
void Load();
C++/CLI
void Load();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IClientObjectController Interface
IClientObjectController Members


SetParent Method

[image]
Gizmox.WebGUI.Common
SetParent Method
See Also Send Feedback
Gizmox.WebGUI.Client.Design Namespace > IClientObjectController Interface : SetParent Method

objController

Syntax

Visual Basic (Declaration)
Sub SetParent( _
   ByVal objController As IClientObjectController _
)
Visual Basic (Usage) Copy Code
Dim instance As IClientObjectController
Dim objController As IClientObjectController

instance.SetParent(objController)
C#
void SetParent(
   IClientObjectController objController
)
Managed Extensions for C++
void SetParent(
   IClientObjectController* objController
)
C++/CLI
void SetParent(
   IClientObjectController^ objController
)

Parameters

objController

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IClientObjectController Interface
IClientObjectController Members


Terminate Method

[image]
Gizmox.WebGUI.Common
Terminate Method
See Also Send Feedback
Gizmox.WebGUI.Client.Design Namespace > IClientObjectController Interface : Terminate Method

Syntax

Visual Basic (Declaration)
Sub Terminate()
Visual Basic (Usage) Copy Code
Dim instance As IClientObjectController

instance.Terminate()
C#
void Terminate()
Managed Extensions for C++
void Terminate();
C++/CLI
void Terminate();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IClientObjectController Interface
IClientObjectController Members


IClientObjectController Interface Properties

[image]
Gizmox.WebGUI.Common
IClientObjectController Interface Properties
See Also Send Feedback
Gizmox.WebGUI.Client.Design Namespace : IClientObjectController Interface

For a list of all members of this type, see IClientObjectController members.

Public Properties

 | Name | Description
Property | SourceObject |
Property | TargetObject |
Top

See Also

Reference

IClientObjectController Interface
Gizmox.WebGUI.Client.Design Namespace


SourceObject Property

[image]
Gizmox.WebGUI.Common
SourceObject Property
See Also Send Feedback
Gizmox.WebGUI.Client.Design Namespace > IClientObjectController Interface : SourceObject Property

Syntax

Visual Basic (Declaration)
ReadOnly Property SourceObject As Object
Visual Basic (Usage) Copy Code
Dim instance As IClientObjectController
Dim value As Object

value = instance.SourceObject
C#
object SourceObject {get;}
Managed Extensions for C++
__property Object* get_SourceObject();
C++/CLI
property Object^ SourceObject {
   Object^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IClientObjectController Interface
IClientObjectController Members


TargetObject Property

[image]
Gizmox.WebGUI.Common
TargetObject Property
See Also Send Feedback
Gizmox.WebGUI.Client.Design Namespace > IClientObjectController Interface : TargetObject Property

Syntax

Visual Basic (Declaration)
ReadOnly Property TargetObject As Object
Visual Basic (Usage) Copy Code
Dim instance As IClientObjectController
Dim value As Object

value = instance.TargetObject
C#
object TargetObject {get;}
Managed Extensions for C++
__property Object* get_TargetObject();
C++/CLI
property Object^ TargetObject {
   Object^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IClientObjectController Interface
IClientObjectController Members


IClinetDesignContext Interface

[image]
Gizmox.WebGUI.Common
IClinetDesignContext Interface
Members See Also Send Feedback
Gizmox.WebGUI.Client.Design Namespace : IClinetDesignContext Interface

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Interface IClinetDesignContext
Visual Basic (Usage) Copy Code
Dim instance As IClinetDesignContext
C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public interface IClinetDesignContext
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public __gc __interface IClinetDesignContext
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public interface class IClinetDesignContext

Requirements

Namespace: Gizmox.WebGUI.Client.Design

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

IClinetDesignContext Members
Gizmox.WebGUI.Client.Design Namespace


IClinetDesignContext Interface Members

[image]
Gizmox.WebGUI.Common
IClinetDesignContext Interface Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Client.Design Namespace : IClinetDesignContext Interface

The following tables list the members exposed by IClinetDesignContext.

Public Properties

 | Name | Description
Property | IsNotificationSuspened |
Top

Public Methods

 | Name | Description
Method | CreateControllerByWebObject |
Method | CreateControllerByWebType |
Method | InitializeController |
Method | NotifyItemPropertyChanged |
Method | ResumeNotifications |
Method | SuspendNotifications |
Top

See Also

Reference

IClinetDesignContext Interface
Gizmox.WebGUI.Client.Design Namespace


IClinetDesignContext Interface Methods

[image]
Gizmox.WebGUI.Common
IClinetDesignContext Interface Methods
See Also Send Feedback
Gizmox.WebGUI.Client.Design Namespace : IClinetDesignContext Interface

For a list of all members of this type, see IClinetDesignContext members.

Public Methods

 | Name | Description
Method | CreateControllerByWebObject |
Method | CreateControllerByWebType |
Method | InitializeController |
Method | NotifyItemPropertyChanged |
Method | ResumeNotifications |
Method | SuspendNotifications |
Top

See Also

Reference

IClinetDesignContext Interface
Gizmox.WebGUI.Client.Design Namespace


CreateControllerByWebObject Method

[image]
Gizmox.WebGUI.Common
CreateControllerByWebObject Method
See Also Send Feedback
Gizmox.WebGUI.Client.Design Namespace > IClinetDesignContext Interface : CreateControllerByWebObject Method

objContext
objWebObject

Syntax

Visual Basic (Declaration)
Function CreateControllerByWebObject( _
   ByVal objContext As IContext, _
   ByVal objWebObject As Object _
) As IClientObjectController
Visual Basic (Usage) Copy Code
Dim instance As IClinetDesignContext
Dim objContext As IContext
Dim objWebObject As Object
Dim value As IClientObjectController

value = instance.CreateControllerByWebObject(objContext, objWebObject)
C#
IClientObjectController CreateControllerByWebObject(
   IContext objContext,
   object objWebObject
)
Managed Extensions for C++
IClientObjectController* CreateControllerByWebObject(
   IContext* objContext,
   Object* objWebObject
)
C++/CLI
IClientObjectController^ CreateControllerByWebObject(
   IContext^ objContext,
   Object^ objWebObject
)

Parameters

objContext
objWebObject

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IClinetDesignContext Interface
IClinetDesignContext Members


CreateControllerByWebType Method

[image]
Gizmox.WebGUI.Common
CreateControllerByWebType Method
See Also Send Feedback
Gizmox.WebGUI.Client.Design Namespace > IClinetDesignContext Interface : CreateControllerByWebType Method

objContext
objWebType

Syntax

Visual Basic (Declaration)
Function CreateControllerByWebType( _
   ByVal objContext As IContext, _
   ByVal objWebType As Type _
) As IClientObjectController
Visual Basic (Usage) Copy Code
Dim instance As IClinetDesignContext
Dim objContext As IContext
Dim objWebType As Type
Dim value As IClientObjectController

value = instance.CreateControllerByWebType(objContext, objWebType)
C#
IClientObjectController CreateControllerByWebType(
   IContext objContext,
   Type objWebType
)
Managed Extensions for C++
IClientObjectController* CreateControllerByWebType(
   IContext* objContext,
   Type* objWebType
)
C++/CLI
IClientObjectController^ CreateControllerByWebType(
   IContext^ objContext,
   Type^ objWebType
)

Parameters

objContext
objWebType

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IClinetDesignContext Interface
IClinetDesignContext Members


InitializeController Method

[image]
Gizmox.WebGUI.Common
InitializeController Method
See Also Send Feedback
Gizmox.WebGUI.Client.Design Namespace > IClinetDesignContext Interface : InitializeController Method

objObjectController

Syntax

Visual Basic (Declaration)
Sub InitializeController( _
   ByVal objObjectController As IClientObjectController _
)
Visual Basic (Usage) Copy Code
Dim instance As IClinetDesignContext
Dim objObjectController As IClientObjectController

instance.InitializeController(objObjectController)
C#
void InitializeController(
   IClientObjectController objObjectController
)
Managed Extensions for C++
void InitializeController(
   IClientObjectController* objObjectController
)
C++/CLI
void InitializeController(
   IClientObjectController^ objObjectController
)

Parameters

objObjectController

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IClinetDesignContext Interface
IClinetDesignContext Members


NotifyItemPropertyChanged Method

[image]
Gizmox.WebGUI.Common
NotifyItemPropertyChanged Method
See Also Send Feedback
Gizmox.WebGUI.Client.Design Namespace > IClinetDesignContext Interface : NotifyItemPropertyChanged Method

objObjectController
objPropertyChangeArgs
blnWebEvent

Syntax

Visual Basic (Declaration)
Sub NotifyItemPropertyChanged( _
   ByVal objObjectController As IClientObjectController, _
   ByVal objPropertyChangeArgs As ObservableItemPropertyChangedArgs, _
   ByVal blnWebEvent As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As IClinetDesignContext
Dim objObjectController As IClientObjectController
Dim objPropertyChangeArgs As ObservableItemPropertyChangedArgs
Dim blnWebEvent As Boolean

instance.NotifyItemPropertyChanged(objObjectController, objPropertyChangeArgs, blnWebEvent)
C#
void NotifyItemPropertyChanged(
   IClientObjectController objObjectController,
   ObservableItemPropertyChangedArgs objPropertyChangeArgs,
   bool blnWebEvent
)
Managed Extensions for C++
void NotifyItemPropertyChanged(
   IClientObjectController* objObjectController,
   ObservableItemPropertyChangedArgs* objPropertyChangeArgs,
   bool blnWebEvent
)
C++/CLI
void NotifyItemPropertyChanged(
   IClientObjectController^ objObjectController,
   ObservableItemPropertyChangedArgs^ objPropertyChangeArgs,
   bool blnWebEvent
)

Parameters

objObjectController
objPropertyChangeArgs
blnWebEvent

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IClinetDesignContext Interface
IClinetDesignContext Members


ResumeNotifications Method

[image]
Gizmox.WebGUI.Common
ResumeNotifications Method
See Also Send Feedback
Gizmox.WebGUI.Client.Design Namespace > IClinetDesignContext Interface : ResumeNotifications Method

Syntax

Visual Basic (Declaration)
Sub ResumeNotifications()
Visual Basic (Usage) Copy Code
Dim instance As IClinetDesignContext

instance.ResumeNotifications()
C#
void ResumeNotifications()
Managed Extensions for C++
void ResumeNotifications();
C++/CLI
void ResumeNotifications();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IClinetDesignContext Interface
IClinetDesignContext Members


SuspendNotifications Method

[image]
Gizmox.WebGUI.Common
SuspendNotifications Method
See Also Send Feedback
Gizmox.WebGUI.Client.Design Namespace > IClinetDesignContext Interface : SuspendNotifications Method

Syntax

Visual Basic (Declaration)
Sub SuspendNotifications()
Visual Basic (Usage) Copy Code
Dim instance As IClinetDesignContext

instance.SuspendNotifications()
C#
void SuspendNotifications()
Managed Extensions for C++
void SuspendNotifications();
C++/CLI
void SuspendNotifications();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IClinetDesignContext Interface
IClinetDesignContext Members


IClinetDesignContext Interface Properties

[image]
Gizmox.WebGUI.Common
IClinetDesignContext Interface Properties
See Also Send Feedback
Gizmox.WebGUI.Client.Design Namespace : IClinetDesignContext Interface

For a list of all members of this type, see IClinetDesignContext members.

Public Properties

 | Name | Description
Property | IsNotificationSuspened |
Top

See Also

Reference

IClinetDesignContext Interface
Gizmox.WebGUI.Client.Design Namespace


IsNotificationSuspened Property

[image]
Gizmox.WebGUI.Common
IsNotificationSuspened Property
See Also Send Feedback
Gizmox.WebGUI.Client.Design Namespace > IClinetDesignContext Interface : IsNotificationSuspened Property

Syntax

Visual Basic (Declaration)
ReadOnly Property IsNotificationSuspened As Boolean
Visual Basic (Usage) Copy Code
Dim instance As IClinetDesignContext
Dim value As Boolean

value = instance.IsNotificationSuspened
C#
bool IsNotificationSuspened {get;}
Managed Extensions for C++
__property bool get_IsNotificationSuspened();
C++/CLI
property bool IsNotificationSuspened {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IClinetDesignContext Interface
IClinetDesignContext Members


IContextServices Interface

[image]
Gizmox.WebGUI.Common
IContextServices Interface
Members See Also Send Feedback
Gizmox.WebGUI.Client.Design Namespace : IContextServices Interface

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Interface IContextServices
Visual Basic (Usage) Copy Code
Dim instance As IContextServices
C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public interface IContextServices
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public __gc __interface IContextServices
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public interface class IContextServices

Requirements

Namespace: Gizmox.WebGUI.Client.Design

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

IContextServices Members
Gizmox.WebGUI.Client.Design Namespace


IContextServices Interface Members

[image]
Gizmox.WebGUI.Common
IContextServices Interface Members
See Also Methods Send Feedback
Gizmox.WebGUI.Client.Design Namespace : IContextServices Interface

The following tables list the members exposed by IContextServices.

Public Methods

 | Name | Description
Method | CreateControllerByWebObject |
Method | CreateControllerByWinObject |
Method | GetControllerByWebObject |
Method | GetControllerByWinObject |
Method | GetWebObject |
Method | GetWinObject |
Method | RefreshDesigner |
Method | RegisterController |
Method | UnregisterController |
Method | UnregisterControllerByWebObject |
Method | UnregisterControllerByWinObject |
Top

See Also

Reference

IContextServices Interface
Gizmox.WebGUI.Client.Design Namespace


IContextServices Interface Methods

[image]
Gizmox.WebGUI.Common
IContextServices Interface Methods
See Also Send Feedback
Gizmox.WebGUI.Client.Design Namespace : IContextServices Interface

For a list of all members of this type, see IContextServices members.

Public Methods

 | Name | Description
Method | CreateControllerByWebObject |
Method | CreateControllerByWinObject |
Method | GetControllerByWebObject |
Method | GetControllerByWinObject |
Method | GetWebObject |
Method | GetWinObject |
Method | RefreshDesigner |
Method | RegisterController |
Method | UnregisterController |
Method | UnregisterControllerByWebObject |
Method | UnregisterControllerByWinObject |
Top

See Also

Reference

IContextServices Interface
Gizmox.WebGUI.Client.Design Namespace


CreateControllerByWebObject Method

[image]
Gizmox.WebGUI.Common
CreateControllerByWebObject Method
See Also Send Feedback
Gizmox.WebGUI.Client.Design Namespace > IContextServices Interface : CreateControllerByWebObject Method

objWebObject

Syntax

Visual Basic (Declaration)
Function CreateControllerByWebObject( _
   ByVal objWebObject As Object _
) As IClientObjectController
Visual Basic (Usage) Copy Code
Dim instance As IContextServices
Dim objWebObject As Object
Dim value As IClientObjectController

value = instance.CreateControllerByWebObject(objWebObject)
C#
IClientObjectController CreateControllerByWebObject(
   object objWebObject
)
Managed Extensions for C++
IClientObjectController* CreateControllerByWebObject(
   Object* objWebObject
)
C++/CLI
IClientObjectController^ CreateControllerByWebObject(
   Object^ objWebObject
)

Parameters

objWebObject

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IContextServices Interface
IContextServices Members


CreateControllerByWinObject Method

[image]
Gizmox.WebGUI.Common
CreateControllerByWinObject Method
See Also Send Feedback
Gizmox.WebGUI.Client.Design Namespace > IContextServices Interface : CreateControllerByWinObject Method

objWinObject

Syntax

Visual Basic (Declaration)
Function CreateControllerByWinObject( _
   ByVal objWinObject As Object _
) As IClientObjectController
Visual Basic (Usage) Copy Code
Dim instance As IContextServices
Dim objWinObject As Object
Dim value As IClientObjectController

value = instance.CreateControllerByWinObject(objWinObject)
C#
IClientObjectController CreateControllerByWinObject(
   object objWinObject
)
Managed Extensions for C++
IClientObjectController* CreateControllerByWinObject(
   Object* objWinObject
)
C++/CLI
IClientObjectController^ CreateControllerByWinObject(
   Object^ objWinObject
)

Parameters

objWinObject

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IContextServices Interface
IContextServices Members


GetControllerByWebObject Method

[image]
Gizmox.WebGUI.Common
GetControllerByWebObject Method
See Also Send Feedback
Gizmox.WebGUI.Client.Design Namespace > IContextServices Interface : GetControllerByWebObject Method

objWebObject

Syntax

Visual Basic (Declaration)
Function GetControllerByWebObject( _
   ByVal objWebObject As Object _
) As IClientObjectController
Visual Basic (Usage) Copy Code
Dim instance As IContextServices
Dim objWebObject As Object
Dim value As IClientObjectController

value = instance.GetControllerByWebObject(objWebObject)
C#
IClientObjectController GetControllerByWebObject(
   object objWebObject
)
Managed Extensions for C++
IClientObjectController* GetControllerByWebObject(
   Object* objWebObject
)
C++/CLI
IClientObjectController^ GetControllerByWebObject(
   Object^ objWebObject
)

Parameters

objWebObject

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IContextServices Interface
IContextServices Members


GetControllerByWinObject Method

[image]
Gizmox.WebGUI.Common
GetControllerByWinObject Method
See Also Send Feedback
Gizmox.WebGUI.Client.Design Namespace > IContextServices Interface : GetControllerByWinObject Method

objWinObject

Syntax

Visual Basic (Declaration)
Function GetControllerByWinObject( _
   ByVal objWinObject As Object _
) As IClientObjectController
Visual Basic (Usage) Copy Code
Dim instance As IContextServices
Dim objWinObject As Object
Dim value As IClientObjectController

value = instance.GetControllerByWinObject(objWinObject)
C#
IClientObjectController GetControllerByWinObject(
   object objWinObject
)
Managed Extensions for C++
IClientObjectController* GetControllerByWinObject(
   Object* objWinObject
)
C++/CLI
IClientObjectController^ GetControllerByWinObject(
   Object^ objWinObject
)

Parameters

objWinObject

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IContextServices Interface
IContextServices Members


GetWebObject Method

[image]
Gizmox.WebGUI.Common
GetWebObject Method
See Also Send Feedback
Gizmox.WebGUI.Client.Design Namespace > IContextServices Interface : GetWebObject Method

objWinObject

Syntax

Visual Basic (Declaration)
Function GetWebObject( _
   ByVal objWinObject As Object _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As IContextServices
Dim objWinObject As Object
Dim value As Object

value = instance.GetWebObject(objWinObject)
C#
object GetWebObject(
   object objWinObject
)
Managed Extensions for C++
Object* GetWebObject(
   Object* objWinObject
)
C++/CLI
Object^ GetWebObject(
   Object^ objWinObject
)

Parameters

objWinObject

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IContextServices Interface
IContextServices Members


GetWinObject Method

[image]
Gizmox.WebGUI.Common
GetWinObject Method
See Also Send Feedback
Gizmox.WebGUI.Client.Design Namespace > IContextServices Interface : GetWinObject Method

objWebObject

Syntax

Visual Basic (Declaration)
Function GetWinObject( _
   ByVal objWebObject As Object _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As IContextServices
Dim objWebObject As Object
Dim value As Object

value = instance.GetWinObject(objWebObject)
C#
object GetWinObject(
   object objWebObject
)
Managed Extensions for C++
Object* GetWinObject(
   Object* objWebObject
)
C++/CLI
Object^ GetWinObject(
   Object^ objWebObject
)

Parameters

objWebObject

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IContextServices Interface
IContextServices Members


RefreshDesigner Method

[image]
Gizmox.WebGUI.Common
RefreshDesigner Method
See Also Send Feedback
Gizmox.WebGUI.Client.Design Namespace > IContextServices Interface : RefreshDesigner Method

Syntax

Visual Basic (Declaration)
Sub RefreshDesigner()
Visual Basic (Usage) Copy Code
Dim instance As IContextServices

instance.RefreshDesigner()
C#
void RefreshDesigner()
Managed Extensions for C++
void RefreshDesigner();
C++/CLI
void RefreshDesigner();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IContextServices Interface
IContextServices Members


RegisterController Method

[image]
Gizmox.WebGUI.Common
RegisterController Method
See Also Send Feedback
Gizmox.WebGUI.Client.Design Namespace > IContextServices Interface : RegisterController Method

objController

Syntax

Visual Basic (Declaration)
Sub RegisterController( _
   ByVal objController As IClientObjectController _
)
Visual Basic (Usage) Copy Code
Dim instance As IContextServices
Dim objController As IClientObjectController

instance.RegisterController(objController)
C#
void RegisterController(
   IClientObjectController objController
)
Managed Extensions for C++
void RegisterController(
   IClientObjectController* objController
)
C++/CLI
void RegisterController(
   IClientObjectController^ objController
)

Parameters

objController

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IContextServices Interface
IContextServices Members


UnregisterController Method

[image]
Gizmox.WebGUI.Common
UnregisterController Method
See Also Send Feedback
Gizmox.WebGUI.Client.Design Namespace > IContextServices Interface : UnregisterController Method

objController

Syntax

Visual Basic (Declaration)
Sub UnregisterController( _
   ByVal objController As IClientObjectController _
)
Visual Basic (Usage) Copy Code
Dim instance As IContextServices
Dim objController As IClientObjectController

instance.UnregisterController(objController)
C#
void UnregisterController(
   IClientObjectController objController
)
Managed Extensions for C++
void UnregisterController(
   IClientObjectController* objController
)
C++/CLI
void UnregisterController(
   IClientObjectController^ objController
)

Parameters

objController

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IContextServices Interface
IContextServices Members


UnregisterControllerByWebObject Method

[image]
Gizmox.WebGUI.Common
UnregisterControllerByWebObject Method
See Also Send Feedback
Gizmox.WebGUI.Client.Design Namespace > IContextServices Interface : UnregisterControllerByWebObject Method

objWebObject

Syntax

Visual Basic (Declaration)
Sub UnregisterControllerByWebObject( _
   ByVal objWebObject As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As IContextServices
Dim objWebObject As Object

instance.UnregisterControllerByWebObject(objWebObject)
C#
void UnregisterControllerByWebObject(
   object objWebObject
)
Managed Extensions for C++
void UnregisterControllerByWebObject(
   Object* objWebObject
)
C++/CLI
void UnregisterControllerByWebObject(
   Object^ objWebObject
)

Parameters

objWebObject

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IContextServices Interface
IContextServices Members


UnregisterControllerByWinObject Method

[image]
Gizmox.WebGUI.Common
UnregisterControllerByWinObject Method
See Also Send Feedback
Gizmox.WebGUI.Client.Design Namespace > IContextServices Interface : UnregisterControllerByWinObject Method

objWinObject

Syntax

Visual Basic (Declaration)
Sub UnregisterControllerByWinObject( _
   ByVal objWinObject As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As IContextServices
Dim objWinObject As Object

instance.UnregisterControllerByWinObject(objWinObject)
C#
void UnregisterControllerByWinObject(
   object objWinObject
)
Managed Extensions for C++
void UnregisterControllerByWinObject(
   Object* objWinObject
)
C++/CLI
void UnregisterControllerByWinObject(
   Object^ objWinObject
)

Parameters

objWinObject

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IContextServices Interface
IContextServices Members


Gizmox.WebGUI.Common Namespace

Gizmox.WebGUI.Common
Gizmox.WebGUI.Common Namespace
See Also Inheritance Hierarchy Send Feedback

Classes

 | Class | Description
Class | Global |

See Also

Reference

Gizmox.WebGUI.Common Assembly


Global Class

[image]
Gizmox.WebGUI.Common
Global Class
Members See Also Send Feedback
Gizmox.WebGUI.Common Namespace : Global Class

Object Model

Syntax

Visual Basic (Declaration)
Public Class Global
Visual Basic (Usage) Copy Code
Dim instance As Global
C#
public class Global
Managed Extensions for C++
public __gc class Global
C++/CLI
public ref class Global

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Common.Global

Requirements

Namespace: Gizmox.WebGUI.Common

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

Global Members
Gizmox.WebGUI.Common Namespace


Global Class Members

[image]
Gizmox.WebGUI.Common
Global Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Common Namespace : Global Class

The following tables list the members exposed by Global.

Public Constructors

 | Name | Description
Public Constructor | Global Constructor |
Top

Public Properties

 | Name | Description
static (Shared in Visual Basic) | Context |
static (Shared in Visual Basic) | HasContext |
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | ClearRequestParams |
Top

See Also

Reference

Global Class
Gizmox.WebGUI.Common Namespace


Global Constructor

[image]
Gizmox.WebGUI.Common
Global Constructor
See Also Send Feedback
Gizmox.WebGUI.Common Namespace > Global Class : Global Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Global()
C#
public Global()
Managed Extensions for C++
public: Global();
C++/CLI
public:
Global();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Global Class
Global Members


Global Class Methods

[image]
Gizmox.WebGUI.Common
Global Class Methods
See Also Send Feedback
Gizmox.WebGUI.Common Namespace : Global Class

For a list of all members of this type, see Global members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | ClearRequestParams |
Top

See Also

Reference

Global Class
Gizmox.WebGUI.Common Namespace


ClearRequestParams Method

[image]
Gizmox.WebGUI.Common
ClearRequestParams Method
See Also Send Feedback
Gizmox.WebGUI.Common Namespace > Global Class : ClearRequestParams Method

Syntax

Visual Basic (Declaration)
Public Shared Sub ClearRequestParams()
Visual Basic (Usage) Copy Code
Global.ClearRequestParams()
C#
public static void ClearRequestParams()
Managed Extensions for C++
public: static void ClearRequestParams();
C++/CLI
public:
static void ClearRequestParams();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Global Class
Global Members


Global Class Properties

[image]
Gizmox.WebGUI.Common
Global Class Properties
See Also Send Feedback
Gizmox.WebGUI.Common Namespace : Global Class

For a list of all members of this type, see Global members.

Public Properties

 | Name | Description
static (Shared in Visual Basic) | Context |
static (Shared in Visual Basic) | HasContext |
Top

See Also

Reference

Global Class
Gizmox.WebGUI.Common Namespace


Context Property

[image]
Gizmox.WebGUI.Common
Context Property
See Also Send Feedback
Gizmox.WebGUI.Common Namespace > Global Class : Context Property

Syntax

Visual Basic (Declaration)
Public Shared Property Context As IContext
Visual Basic (Usage) Copy Code
Dim value As IContext

Global.Context = value

value = Global.Context
C#
public static IContext Context {get; set;}
Managed Extensions for C++
public: __property static IContext* get_Context();
public: __property static void set_Context(
   IContext* value
);
C++/CLI
public:
static property IContext^ Context {
   IContext^ get();
   void set (IContext^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Global Class
Global Members


HasContext Property

[image]
Gizmox.WebGUI.Common
HasContext Property
See Also Send Feedback
Gizmox.WebGUI.Common Namespace > Global Class : HasContext Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property HasContext As Boolean
Visual Basic (Usage) Copy Code
Dim value As Boolean

value = Global.HasContext
C#
public static bool HasContext {get;}
Managed Extensions for C++
public: __property static bool get_HasContext();
C++/CLI
public:
static property bool HasContext {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Global Class
Global Members


Gizmox.WebGUI.Common.Configuration Namespace

Gizmox.WebGUI.Common
Gizmox.WebGUI.Common.Configuration Namespace
See Also Inheritance Hierarchy Send Feedback

Classes

 | Class | Description
Class | Config |

See Also

Reference

Gizmox.WebGUI.Common Assembly


Config Class

[image]
Gizmox.WebGUI.Common
Config Class
Members See Also Send Feedback
Gizmox.WebGUI.Common.Configuration Namespace : Config Class

Object Model

Syntax

Visual Basic (Declaration)
Public Class Config
Visual Basic (Usage) Copy Code
Dim instance As Config
C#
public class Config
Managed Extensions for C++
public __gc class Config
C++/CLI
public ref class Config

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Common.Configuration.Config

Requirements

Namespace: Gizmox.WebGUI.Common.Configuration

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

Config Members
Gizmox.WebGUI.Common.Configuration Namespace


Config Class Members

[image]
Gizmox.WebGUI.Common
Config Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Common.Configuration Namespace : Config Class

The following tables list the members exposed by Config.

Public Properties

 | Name | Description
Public Property | Languages |
Public Property | Themes |
Top

Public Methods

 | Name | Description
Public Method | GetDirectory | Overloaded.
Public Method | GetFeatureValue | Overloaded.
static (Shared in Visual Basic) | GetInstance | Overloaded.
Public Method | IsFeatureEnabled |
Top

See Also

Reference

Config Class
Gizmox.WebGUI.Common.Configuration Namespace


Config Class Methods

[image]
Gizmox.WebGUI.Common
Config Class Methods
See Also Send Feedback
Gizmox.WebGUI.Common.Configuration Namespace : Config Class

For a list of all members of this type, see Config members.

Public Methods

 | Name | Description
Public Method | GetDirectory | Overloaded.
Public Method | GetFeatureValue | Overloaded.
static (Shared in Visual Basic) | GetInstance | Overloaded.
Public Method | IsFeatureEnabled |
Top

See Also

Reference

Config Class
Gizmox.WebGUI.Common.Configuration Namespace


GetDirectory Method

[image]
Gizmox.WebGUI.Common
GetDirectory Method
See Also Send Feedback
Gizmox.WebGUI.Common.Configuration Namespace > Config Class : GetDirectory Method

Overload List

Overload | Description
GetDirectory(String,String) |
GetDirectory(String) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Config Class
Config Members


GetDirectory(String,String) Method

[image]
Gizmox.WebGUI.Common
GetDirectory(String,String) Method
See Also Send Feedback
Gizmox.WebGUI.Common.Configuration Namespace > Config Class > GetDirectory Method : GetDirectory(String,String) Method

strCode
strDefault

Syntax

Visual Basic (Declaration)
Public Overloads Function GetDirectory( _
   ByVal strCode As String, _
   ByVal strDefault As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As Config
Dim strCode As String
Dim strDefault As String
Dim value As String

value = instance.GetDirectory(strCode, strDefault)
C#
public string GetDirectory(
   string strCode,
   string strDefault
)
Managed Extensions for C++
public: string* GetDirectory(
   string* strCode,
   string* strDefault
)
C++/CLI
public:
String^ GetDirectory(
   String^ strCode,
   String^ strDefault
)

Parameters

strCode
strDefault

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Config Class
Config Members
Overload List


GetDirectory(String) Method

[image]
Gizmox.WebGUI.Common
GetDirectory(String) Method
See Also Send Feedback
Gizmox.WebGUI.Common.Configuration Namespace > Config Class > GetDirectory Method : GetDirectory(String) Method

strCode

Syntax

Visual Basic (Declaration)
Public Overloads Function GetDirectory( _
   ByVal strCode As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As Config
Dim strCode As String
Dim value As String

value = instance.GetDirectory(strCode)
C#
public string GetDirectory(
   string strCode
)
Managed Extensions for C++
public: string* GetDirectory(
   string* strCode
)
C++/CLI
public:
String^ GetDirectory(
   String^ strCode
)

Parameters

strCode

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Config Class
Config Members
Overload List


GetFeatureValue Method

[image]
Gizmox.WebGUI.Common
GetFeatureValue Method
See Also Send Feedback
Gizmox.WebGUI.Common.Configuration Namespace > Config Class : GetFeatureValue Method

Overload List

Overload | Description
GetFeatureValue(String,String) |
GetFeatureValue(String,Int32) |
GetFeatureValue(String,Boolean) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Config Class
Config Members


GetFeatureValue(String,String) Method

[image]
Gizmox.WebGUI.Common
GetFeatureValue(String,String) Method
See Also Send Feedback
Gizmox.WebGUI.Common.Configuration Namespace > Config Class > GetFeatureValue Method : GetFeatureValue(String,String) Method

strFeature
strDefault

Syntax

Visual Basic (Declaration)
Public Overloads Function GetFeatureValue( _
   ByVal strFeature As String, _
   ByVal strDefault As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As Config
Dim strFeature As String
Dim strDefault As String
Dim value As String

value = instance.GetFeatureValue(strFeature, strDefault)
C#
public string GetFeatureValue(
   string strFeature,
   string strDefault
)
Managed Extensions for C++
public: string* GetFeatureValue(
   string* strFeature,
   string* strDefault
)
C++/CLI
public:
String^ GetFeatureValue(
   String^ strFeature,
   String^ strDefault
)

Parameters

strFeature
strDefault

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Config Class
Config Members
Overload List


GetFeatureValue(String,Int32) Method

[image]
Gizmox.WebGUI.Common
GetFeatureValue(String,Int32) Method
See Also Send Feedback
Gizmox.WebGUI.Common.Configuration Namespace > Config Class > GetFeatureValue Method : GetFeatureValue(String,Int32) Method

strFeature
intDefault

Syntax

Visual Basic (Declaration)
Public Overloads Function GetFeatureValue( _
   ByVal strFeature As String, _
   ByVal intDefault As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As Config
Dim strFeature As String
Dim intDefault As Integer
Dim value As Integer

value = instance.GetFeatureValue(strFeature, intDefault)
C#
public int GetFeatureValue(
   string strFeature,
   int intDefault
)
Managed Extensions for C++
public: int GetFeatureValue(
   string* strFeature,
   int intDefault
)
C++/CLI
public:
int GetFeatureValue(
   String^ strFeature,
   int intDefault
)

Parameters

strFeature
intDefault

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Config Class
Config Members
Overload List


GetFeatureValue(String,Boolean) Method

[image]
Gizmox.WebGUI.Common
GetFeatureValue(String,Boolean) Method
See Also Send Feedback
Gizmox.WebGUI.Common.Configuration Namespace > Config Class > GetFeatureValue Method : GetFeatureValue(String,Boolean) Method

strFeature
blnDefault

Syntax

Visual Basic (Declaration)
Public Overloads Function GetFeatureValue( _
   ByVal strFeature As String, _
   ByVal blnDefault As Boolean _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Config
Dim strFeature As String
Dim blnDefault As Boolean
Dim value As Boolean

value = instance.GetFeatureValue(strFeature, blnDefault)
C#
public bool GetFeatureValue(
   string strFeature,
   bool blnDefault
)
Managed Extensions for C++
public: bool GetFeatureValue(
   string* strFeature,
   bool blnDefault
)
C++/CLI
public:
bool GetFeatureValue(
   String^ strFeature,
   bool blnDefault
)

Parameters

strFeature
blnDefault

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Config Class
Config Members
Overload List


GetInstance Method

[image]
Gizmox.WebGUI.Common
GetInstance Method
See Also Send Feedback
Gizmox.WebGUI.Common.Configuration Namespace > Config Class : GetInstance Method

Overload List

Overload | Description
GetInstance() |
GetInstance(XmlElement) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Config Class
Config Members


GetInstance() Method

[image]
Gizmox.WebGUI.Common
GetInstance() Method
See Also Send Feedback
Gizmox.WebGUI.Common.Configuration Namespace > Config Class > GetInstance Method : GetInstance() Method

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function GetInstance() As Config
Visual Basic (Usage) Copy Code
Dim value As Config

value = Config.GetInstance()
C#
public static Config GetInstance()
Managed Extensions for C++
public: static Config* GetInstance();
C++/CLI
public:
static Config^ GetInstance();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Config Class
Config Members
Overload List


GetInstance(XmlElement) Method

[image]
Gizmox.WebGUI.Common
GetInstance(XmlElement) Method
See Also Send Feedback
Gizmox.WebGUI.Common.Configuration Namespace > Config Class > GetInstance Method : GetInstance(XmlElement) Method

objSection

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function GetInstance( _
   ByVal objSection As XmlElement _
) As Config
Visual Basic (Usage) Copy Code
Dim objSection As XmlElement
Dim value As Config

value = Config.GetInstance(objSection)
C#
public static Config GetInstance(
   XmlElement objSection
)
Managed Extensions for C++
public: static Config* GetInstance(
   XmlElement* objSection
)
C++/CLI
public:
static Config^ GetInstance(
   XmlElement^ objSection
)

Parameters

objSection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Config Class
Config Members
Overload List


IsFeatureEnabled Method

[image]
Gizmox.WebGUI.Common
IsFeatureEnabled Method
See Also Send Feedback
Gizmox.WebGUI.Common.Configuration Namespace > Config Class : IsFeatureEnabled Method

strFeature
blnDefault

Syntax

Visual Basic (Declaration)
Public Function IsFeatureEnabled( _
   ByVal strFeature As String, _
   ByVal blnDefault As Boolean _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Config
Dim strFeature As String
Dim blnDefault As Boolean
Dim value As Boolean

value = instance.IsFeatureEnabled(strFeature, blnDefault)
C#
public bool IsFeatureEnabled(
   string strFeature,
   bool blnDefault
)
Managed Extensions for C++
public: bool IsFeatureEnabled(
   string* strFeature,
   bool blnDefault
)
C++/CLI
public:
bool IsFeatureEnabled(
   String^ strFeature,
   bool blnDefault
)

Parameters

strFeature
blnDefault

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Config Class
Config Members


Config Class Properties

[image]
Gizmox.WebGUI.Common
Config Class Properties
See Also Send Feedback
Gizmox.WebGUI.Common.Configuration Namespace : Config Class

For a list of all members of this type, see Config members.

Public Properties

 | Name | Description
Public Property | Languages |
Public Property | Themes |
Top

See Also

Reference

Config Class
Gizmox.WebGUI.Common.Configuration Namespace


Languages Property

[image]
Gizmox.WebGUI.Common
Languages Property
See Also Send Feedback
Gizmox.WebGUI.Common.Configuration Namespace > Config Class : Languages Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Languages As String()
Visual Basic (Usage) Copy Code
Dim instance As Config
Dim value() As String

value = instance.Languages
C#
public string[] Languages {get;}
Managed Extensions for C++
public: __property string*[]* get_Languages();
C++/CLI
public:
property array<String^>^ Languages {
   array<String^>^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Config Class
Config Members


Themes Property

[image]
Gizmox.WebGUI.Common
Themes Property
See Also Send Feedback
Gizmox.WebGUI.Common.Configuration Namespace > Config Class : Themes Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Themes As Theme.ThemeCollection
Visual Basic (Usage) Copy Code
Dim instance As Config
Dim value As Theme.ThemeCollection

value = instance.Themes
C#
public Theme.ThemeCollection Themes {get;}
Managed Extensions for C++
public: __property Theme.ThemeCollection* get_Themes();
C++/CLI
public:
property Theme::ThemeCollection^ Themes {
   Theme::ThemeCollection^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Config Class
Config Members


Gizmox.WebGUI.Common.Exceptions Namespace

Gizmox.WebGUI.Common
Gizmox.WebGUI.Common.Exceptions Namespace
See Also Inheritance Hierarchy Send Feedback

Classes

 | Class | Description
Class | LogonException |

See Also

Reference

Gizmox.WebGUI.Common Assembly


LogonException Class

[image]
Gizmox.WebGUI.Common
LogonException Class
Members See Also Send Feedback
Gizmox.WebGUI.Common.Exceptions Namespace : LogonException Class

Syntax

Visual Basic (Declaration)
Public Class LogonException
   Inherits Exception
Visual Basic (Usage) Copy Code
Dim instance As LogonException
C#
public class LogonException : Exception
Managed Extensions for C++
public __gc class LogonException : public Exception
C++/CLI
public ref class LogonException : public Exception

Inheritance Hierarchy

System.Object
System.Exception
Gizmox.WebGUI.Common.Exceptions.LogonException

Requirements

Namespace: Gizmox.WebGUI.Common.Exceptions

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

LogonException Members
Gizmox.WebGUI.Common.Exceptions Namespace


LogonException Class Members

[image]
Gizmox.WebGUI.Common
LogonException Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Common.Exceptions Namespace : LogonException Class

The following tables list the members exposed by LogonException.

Public Constructors

 | Name | Description
Public Constructor | LogonException Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
Protected Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
static (Shared in Visual Basic) | IsLogonException |
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

LogonException Class
Gizmox.WebGUI.Common.Exceptions Namespace


LogonException Constructor

[image]
Gizmox.WebGUI.Common
LogonException Constructor
See Also Send Feedback
Gizmox.WebGUI.Common.Exceptions Namespace > LogonException Class : LogonException Constructor

Overload List

Overload | Description
LogonException Constructor() |
LogonException Constructor(String) |
LogonException Constructor(String,Exception) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LogonException Class
LogonException Members


LogonException Constructor()

[image]
Gizmox.WebGUI.Common
LogonException Constructor()
See Also Send Feedback
Gizmox.WebGUI.Common.Exceptions Namespace > LogonException Class > LogonException Constructor : LogonException Constructor()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As LogonException()
C#
public LogonException()
Managed Extensions for C++
public: LogonException();
C++/CLI
public:
LogonException();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LogonException Class
LogonException Members
Overload List


LogonException Constructor(String)

[image]
Gizmox.WebGUI.Common
LogonException Constructor(String)
See Also Send Feedback
Gizmox.WebGUI.Common.Exceptions Namespace > LogonException Class > LogonException Constructor : LogonException Constructor(String)

strMessage

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal strMessage As String _
)
Visual Basic (Usage) Copy Code
Dim strMessage As String

Dim instance As LogonException(strMessage)
C#
public LogonException(
   string strMessage
)
Managed Extensions for C++
public: LogonException(
   string* strMessage
)
C++/CLI
public:
LogonException(
   String^ strMessage
)

Parameters

strMessage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LogonException Class
LogonException Members
Overload List


LogonException Constructor(String,Exception)

[image]
Gizmox.WebGUI.Common
LogonException Constructor(String,Exception)
See Also Send Feedback
Gizmox.WebGUI.Common.Exceptions Namespace > LogonException Class > LogonException Constructor : LogonException Constructor(String,Exception)

strMessage
objInnerException

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal strMessage As String, _
   ByVal objInnerException As Exception _
)
Visual Basic (Usage) Copy Code
Dim strMessage As String
Dim objInnerException As Exception

Dim instance As LogonException(strMessage, objInnerException)
C#
public LogonException(
   string strMessage,
   Exception objInnerException
)
Managed Extensions for C++
public: LogonException(
   string* strMessage,
   Exception* objInnerException
)
C++/CLI
public:
LogonException(
   String^ strMessage,
   Exception^ objInnerException
)

Parameters

strMessage
objInnerException

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LogonException Class
LogonException Members
Overload List


LogonException Class Methods

[image]
Gizmox.WebGUI.Common
LogonException Class Methods
See Also Send Feedback
Gizmox.WebGUI.Common.Exceptions Namespace : LogonException Class

For a list of all members of this type, see LogonException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
static (Shared in Visual Basic) | IsLogonException |
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

LogonException Class
Gizmox.WebGUI.Common.Exceptions Namespace


IsLogonException Method

[image]
Gizmox.WebGUI.Common
IsLogonException Method
See Also Send Feedback
Gizmox.WebGUI.Common.Exceptions Namespace > LogonException Class : IsLogonException Method

objException

Syntax

Visual Basic (Declaration)
Public Shared Function IsLogonException( _
   ByVal objException As Exception _
) As Boolean
Visual Basic (Usage) Copy Code
Dim objException As Exception
Dim value As Boolean

value = LogonException.IsLogonException(objException)
C#
public static bool IsLogonException(
   Exception objException
)
Managed Extensions for C++
public: static bool IsLogonException(
   Exception* objException
)
C++/CLI
public:
static bool IsLogonException(
   Exception^ objException
)

Parameters

objException

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

LogonException Class
LogonException Members


Gizmox.WebGUI.Common.Extensibility Namespace

Gizmox.WebGUI.Common
Gizmox.WebGUI.Common.Extensibility Namespace
See Also Inheritance Hierarchy Send Feedback

Classes

 | Class | Description
Class | ClientControllerAttribute |
Class | SilverlightControlAttribute |
Class | WebCompilerPagesAttribute |
Class | WebCompilerResourcesAttribute |
Class | WinCompilerControllerAttribute |

See Also

Reference

Gizmox.WebGUI.Common Assembly


ClientControllerAttribute Class

[image]
Gizmox.WebGUI.Common
ClientControllerAttribute Class
Members See Also Send Feedback
Gizmox.WebGUI.Common.Extensibility Namespace : ClientControllerAttribute Class

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AllowMultiple=False, Inherited=True)>
Public Class ClientControllerAttribute
   Inherits Attribute
Visual Basic (Usage) Copy Code
Dim instance As ClientControllerAttribute
C#
[AttributeUsageAttribute(AllowMultiple=false, Inherited=true)]
public class ClientControllerAttribute : Attribute
Managed Extensions for C++
[AttributeUsageAttribute(AllowMultiple=false, Inherited=true)]
public __gc class ClientControllerAttribute : public Attribute
C++/CLI
[AttributeUsageAttribute(AllowMultiple=false, Inherited=true)]
public ref class ClientControllerAttribute : public Attribute

Inheritance Hierarchy

System.Object
System.Attribute
Gizmox.WebGUI.Common.Extensibility.ClientControllerAttribute

Requirements

Namespace: Gizmox.WebGUI.Common.Extensibility

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

ClientControllerAttribute Members
Gizmox.WebGUI.Common.Extensibility Namespace


ClientControllerAttribute Class Members

[image]
Gizmox.WebGUI.Common
ClientControllerAttribute Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Common.Extensibility Namespace : ClientControllerAttribute Class

The following tables list the members exposed by ClientControllerAttribute.

Public Constructors

 | Name | Description
Public Constructor | ClientControllerAttribute Constructor |
Top

Public Properties

 | Name | Description
Public Property | Type |
Public Property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from System.Attribute)
Top

Public Methods

 | Name | Description
Public Method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from System.Attribute)
Public Method | GetHashCode | Returns the hash code for this instance. (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from System.Attribute)
Public Method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from System.Attribute)
Top

See Also

Reference

ClientControllerAttribute Class
Gizmox.WebGUI.Common.Extensibility Namespace


ClientControllerAttribute Constructor

[image]
Gizmox.WebGUI.Common
ClientControllerAttribute Constructor
See Also Send Feedback
Gizmox.WebGUI.Common.Extensibility Namespace > ClientControllerAttribute Class : ClientControllerAttribute Constructor

strTypeName

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal strTypeName As String _
)
Visual Basic (Usage) Copy Code
Dim strTypeName As String

Dim instance As ClientControllerAttribute(strTypeName)
C#
public ClientControllerAttribute(
   string strTypeName
)
Managed Extensions for C++
public: ClientControllerAttribute(
   string* strTypeName
)
C++/CLI
public:
ClientControllerAttribute(
   String^ strTypeName
)

Parameters

strTypeName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ClientControllerAttribute Class
ClientControllerAttribute Members


ClientControllerAttribute Class Properties

[image]
Gizmox.WebGUI.Common
ClientControllerAttribute Class Properties
See Also Send Feedback
Gizmox.WebGUI.Common.Extensibility Namespace : ClientControllerAttribute Class

For a list of all members of this type, see ClientControllerAttribute members.

Public Properties

 | Name | Description
Public Property | Type |
Public Property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from System.Attribute)
Top

See Also

Reference

ClientControllerAttribute Class
Gizmox.WebGUI.Common.Extensibility Namespace


Type Property

[image]
Gizmox.WebGUI.Common
Type Property
See Also Send Feedback
Gizmox.WebGUI.Common.Extensibility Namespace > ClientControllerAttribute Class : Type Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Type As Type
Visual Basic (Usage) Copy Code
Dim instance As ClientControllerAttribute
Dim value As Type

value = instance.Type
C#
public Type Type {get;}
Managed Extensions for C++
public: __property Type* get_Type();
C++/CLI
public:
property Type^ Type {
   Type^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ClientControllerAttribute Class
ClientControllerAttribute Members


SilverlightControlAttribute Class

[image]
Gizmox.WebGUI.Common
SilverlightControlAttribute Class
Members See Also Send Feedback
Gizmox.WebGUI.Common.Extensibility Namespace : SilverlightControlAttribute Class

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AllowMultiple=True, Inherited=True)>
Public Class SilverlightControlAttribute
   Inherits Attribute
Visual Basic (Usage) Copy Code
Dim instance As SilverlightControlAttribute
C#
[AttributeUsageAttribute(AllowMultiple=true, Inherited=true)]
public class SilverlightControlAttribute : Attribute
Managed Extensions for C++
[AttributeUsageAttribute(AllowMultiple=true, Inherited=true)]
public __gc class SilverlightControlAttribute : public Attribute
C++/CLI
[AttributeUsageAttribute(AllowMultiple=true, Inherited=true)]
public ref class SilverlightControlAttribute : public Attribute

Inheritance Hierarchy

System.Object
System.Attribute
Gizmox.WebGUI.Common.Extensibility.SilverlightControlAttribute

Requirements

Namespace: Gizmox.WebGUI.Common.Extensibility

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

SilverlightControlAttribute Members
Gizmox.WebGUI.Common.Extensibility Namespace


SilverlightControlAttribute Class Members

[image]
Gizmox.WebGUI.Common
SilverlightControlAttribute Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Common.Extensibility Namespace : SilverlightControlAttribute Class

The following tables list the members exposed by SilverlightControlAttribute.

Public Constructors

 | Name | Description
Public Constructor | SilverlightControlAttribute Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Style |
Public Property | Type |
Public Property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from System.Attribute)
Top

Public Methods

 | Name | Description
Public Method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from System.Attribute)
Public Method | GetHashCode | Returns the hash code for this instance. (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from System.Attribute)
Public Method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from System.Attribute)
Top

See Also

Reference

SilverlightControlAttribute Class
Gizmox.WebGUI.Common.Extensibility Namespace


SilverlightControlAttribute Constructor

[image]
Gizmox.WebGUI.Common
SilverlightControlAttribute Constructor
See Also Send Feedback
Gizmox.WebGUI.Common.Extensibility Namespace > SilverlightControlAttribute Class : SilverlightControlAttribute Constructor

Overload List

Overload | Description
SilverlightControlAttribute Constructor(String) |
SilverlightControlAttribute Constructor(String,String) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SilverlightControlAttribute Class
SilverlightControlAttribute Members


SilverlightControlAttribute Constructor(String)

[image]
Gizmox.WebGUI.Common
SilverlightControlAttribute Constructor(String)
See Also Send Feedback
Gizmox.WebGUI.Common.Extensibility Namespace > SilverlightControlAttribute Class > SilverlightControlAttribute Constructor : SilverlightControlAttribute Constructor(String)

strControlType

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal strControlType As String _
)
Visual Basic (Usage) Copy Code
Dim strControlType As String

Dim instance As SilverlightControlAttribute(strControlType)
C#
public SilverlightControlAttribute(
   string strControlType
)
Managed Extensions for C++
public: SilverlightControlAttribute(
   string* strControlType
)
C++/CLI
public:
SilverlightControlAttribute(
   String^ strControlType
)

Parameters

strControlType

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SilverlightControlAttribute Class
SilverlightControlAttribute Members
Overload List


SilverlightControlAttribute Constructor(String,String)

[image]
Gizmox.WebGUI.Common
SilverlightControlAttribute Constructor(String,String)
See Also Send Feedback
Gizmox.WebGUI.Common.Extensibility Namespace > SilverlightControlAttribute Class > SilverlightControlAttribute Constructor : SilverlightControlAttribute Constructor(String,String)

strControlType
strCustomStyle

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal strControlType As String, _
   ByVal strCustomStyle As String _
)
Visual Basic (Usage) Copy Code
Dim strControlType As String
Dim strCustomStyle As String

Dim instance As SilverlightControlAttribute(strControlType, strCustomStyle)
C#
public SilverlightControlAttribute(
   string strControlType,
   string strCustomStyle
)
Managed Extensions for C++
public: SilverlightControlAttribute(
   string* strControlType,
   string* strCustomStyle
)
C++/CLI
public:
SilverlightControlAttribute(
   String^ strControlType,
   String^ strCustomStyle
)

Parameters

strControlType
strCustomStyle

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SilverlightControlAttribute Class
SilverlightControlAttribute Members
Overload List


SilverlightControlAttribute Class Properties

[image]
Gizmox.WebGUI.Common
SilverlightControlAttribute Class Properties
See Also Send Feedback
Gizmox.WebGUI.Common.Extensibility Namespace : SilverlightControlAttribute Class

For a list of all members of this type, see SilverlightControlAttribute members.

Public Properties

 | Name | Description
Public Property | Style |
Public Property | Type |
Public Property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from System.Attribute)
Top

See Also

Reference

SilverlightControlAttribute Class
Gizmox.WebGUI.Common.Extensibility Namespace


Style Property

[image]
Gizmox.WebGUI.Common
Style Property
See Also Send Feedback
Gizmox.WebGUI.Common.Extensibility Namespace > SilverlightControlAttribute Class : Style Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Style As String
Visual Basic (Usage) Copy Code
Dim instance As SilverlightControlAttribute
Dim value As String

value = instance.Style
C#
public string Style {get;}
Managed Extensions for C++
public: __property string* get_Style();
C++/CLI
public:
property String^ Style {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SilverlightControlAttribute Class
SilverlightControlAttribute Members


Type Property

[image]
Gizmox.WebGUI.Common
Type Property
See Also Send Feedback
Gizmox.WebGUI.Common.Extensibility Namespace > SilverlightControlAttribute Class : Type Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Type As String
Visual Basic (Usage) Copy Code
Dim instance As SilverlightControlAttribute
Dim value As String

value = instance.Type
C#
public string Type {get;}
Managed Extensions for C++
public: __property string* get_Type();
C++/CLI
public:
property String^ Type {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SilverlightControlAttribute Class
SilverlightControlAttribute Members


WebCompilerPagesAttribute Class

[image]
Gizmox.WebGUI.Common
WebCompilerPagesAttribute Class
Members See Also Send Feedback
Gizmox.WebGUI.Common.Extensibility Namespace : WebCompilerPagesAttribute Class

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AllowMultiple=False, Inherited=True)>
Public Class WebCompilerPagesAttribute
   Inherits Attribute
Visual Basic (Usage) Copy Code
Dim instance As WebCompilerPagesAttribute
C#
[AttributeUsageAttribute(AllowMultiple=false, Inherited=true)]
public class WebCompilerPagesAttribute : Attribute
Managed Extensions for C++
[AttributeUsageAttribute(AllowMultiple=false, Inherited=true)]
public __gc class WebCompilerPagesAttribute : public Attribute
C++/CLI
[AttributeUsageAttribute(AllowMultiple=false, Inherited=true)]
public ref class WebCompilerPagesAttribute : public Attribute

Inheritance Hierarchy

System.Object
System.Attribute
Gizmox.WebGUI.Common.Extensibility.WebCompilerPagesAttribute

Requirements

Namespace: Gizmox.WebGUI.Common.Extensibility

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

WebCompilerPagesAttribute Members
Gizmox.WebGUI.Common.Extensibility Namespace


WebCompilerPagesAttribute Class Members

[image]
Gizmox.WebGUI.Common
WebCompilerPagesAttribute Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Common.Extensibility Namespace : WebCompilerPagesAttribute Class

The following tables list the members exposed by WebCompilerPagesAttribute.

Public Constructors

 | Name | Description
Public Constructor | WebCompilerPagesAttribute Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Assembly |
Public Property | Namespace |
Public Property | Resoruces |
Public Property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from System.Attribute)
Top

Public Methods

 | Name | Description
Public Method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from System.Attribute)
Public Method | GetHashCode | Returns the hash code for this instance. (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from System.Attribute)
Public Method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from System.Attribute)
Top

See Also

Reference

WebCompilerPagesAttribute Class
Gizmox.WebGUI.Common.Extensibility Namespace


WebCompilerPagesAttribute Constructor

[image]
Gizmox.WebGUI.Common
WebCompilerPagesAttribute Constructor
See Also Send Feedback
Gizmox.WebGUI.Common.Extensibility Namespace > WebCompilerPagesAttribute Class : WebCompilerPagesAttribute Constructor

Overload List

Overload | Description
WebCompilerPagesAttribute Constructor(String,String) |
WebCompilerPagesAttribute Constructor(String,String,String) |
WebCompilerPagesAttribute Constructor(Type,String) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCompilerPagesAttribute Class
WebCompilerPagesAttribute Members


WebCompilerPagesAttribute Constructor(String,String)

[image]
Gizmox.WebGUI.Common
WebCompilerPagesAttribute Constructor(String,String)
See Also Send Feedback
Gizmox.WebGUI.Common.Extensibility Namespace > WebCompilerPagesAttribute Class > WebCompilerPagesAttribute Constructor : WebCompilerPagesAttribute Constructor(String,String)

strNamespace
strResources

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal strNamespace As String, _
   ByVal strResources As String _
)
Visual Basic (Usage) Copy Code
Dim strNamespace As String
Dim strResources As String

Dim instance As WebCompilerPagesAttribute(strNamespace, strResources)
C#
public WebCompilerPagesAttribute(
   string strNamespace,
   string strResources
)
Managed Extensions for C++
public: WebCompilerPagesAttribute(
   string* strNamespace,
   string* strResources
)
C++/CLI
public:
WebCompilerPagesAttribute(
   String^ strNamespace,
   String^ strResources
)

Parameters

strNamespace
strResources

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCompilerPagesAttribute Class
WebCompilerPagesAttribute Members
Overload List


WebCompilerPagesAttribute Constructor(String,String,String)

[image]
Gizmox.WebGUI.Common
WebCompilerPagesAttribute Constructor(String,String,String)
See Also Send Feedback
Gizmox.WebGUI.Common.Extensibility Namespace > WebCompilerPagesAttribute Class > WebCompilerPagesAttribute Constructor : WebCompilerPagesAttribute Constructor(String,String,String)

strNamespace
strAssembly
strResources

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal strNamespace As String, _
   ByVal strAssembly As String, _
   ByVal strResources As String _
)
Visual Basic (Usage) Copy Code
Dim strNamespace As String
Dim strAssembly As String
Dim strResources As String

Dim instance As WebCompilerPagesAttribute(strNamespace, strAssembly, strResources)
C#
public WebCompilerPagesAttribute(
   string strNamespace,
   string strAssembly,
   string strResources
)
Managed Extensions for C++
public: WebCompilerPagesAttribute(
   string* strNamespace,
   string* strAssembly,
   string* strResources
)
C++/CLI
public:
WebCompilerPagesAttribute(
   String^ strNamespace,
   String^ strAssembly,
   String^ strResources
)

Parameters

strNamespace
strAssembly
strResources

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCompilerPagesAttribute Class
WebCompilerPagesAttribute Members
Overload List


WebCompilerPagesAttribute Constructor(Type,String)

[image]
Gizmox.WebGUI.Common
WebCompilerPagesAttribute Constructor(Type,String)
See Also Send Feedback
Gizmox.WebGUI.Common.Extensibility Namespace > WebCompilerPagesAttribute Class > WebCompilerPagesAttribute Constructor : WebCompilerPagesAttribute Constructor(Type,String)

objReference
strResources

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal objReference As Type, _
   ByVal strResources As String _
)
Visual Basic (Usage) Copy Code
Dim objReference As Type
Dim strResources As String

Dim instance As WebCompilerPagesAttribute(objReference, strResources)
C#
public WebCompilerPagesAttribute(
   Type objReference,
   string strResources
)
Managed Extensions for C++
public: WebCompilerPagesAttribute(
   Type* objReference,
   string* strResources
)
C++/CLI
public:
WebCompilerPagesAttribute(
   Type^ objReference,
   String^ strResources
)

Parameters

objReference
strResources

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCompilerPagesAttribute Class
WebCompilerPagesAttribute Members
Overload List


WebCompilerPagesAttribute Class Properties

[image]
Gizmox.WebGUI.Common
WebCompilerPagesAttribute Class Properties
See Also Send Feedback
Gizmox.WebGUI.Common.Extensibility Namespace : WebCompilerPagesAttribute Class

For a list of all members of this type, see WebCompilerPagesAttribute members.

Public Properties

 | Name | Description
Public Property | Assembly |
Public Property | Namespace |
Public Property | Resoruces |
Public Property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from System.Attribute)
Top

See Also

Reference

WebCompilerPagesAttribute Class
Gizmox.WebGUI.Common.Extensibility Namespace


Assembly Property

[image]
Gizmox.WebGUI.Common
Assembly Property
See Also Send Feedback
Gizmox.WebGUI.Common.Extensibility Namespace > WebCompilerPagesAttribute Class : Assembly Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Assembly As Assembly
Visual Basic (Usage) Copy Code
Dim instance As WebCompilerPagesAttribute
Dim value As Assembly

value = instance.Assembly
C#
public Assembly Assembly {get;}
Managed Extensions for C++
public: __property Assembly* get_Assembly();
C++/CLI
public:
property Assembly^ Assembly {
   Assembly^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCompilerPagesAttribute Class
WebCompilerPagesAttribute Members


Namespace Property

[image]
Gizmox.WebGUI.Common
Namespace Property
See Also Send Feedback
Gizmox.WebGUI.Common.Extensibility Namespace > WebCompilerPagesAttribute Class : Namespace Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Namespace As String
Visual Basic (Usage) Copy Code
Dim instance As WebCompilerPagesAttribute
Dim value As String

value = instance.Namespace
C#
public string Namespace {get;}
Managed Extensions for C++
public: __property string* get_Namespace();
C++/CLI
public:
property String^ Namespace {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCompilerPagesAttribute Class
WebCompilerPagesAttribute Members


Resoruces Property

[image]
Gizmox.WebGUI.Common
Resoruces Property
See Also Send Feedback
Gizmox.WebGUI.Common.Extensibility Namespace > WebCompilerPagesAttribute Class : Resoruces Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Resoruces As String()
Visual Basic (Usage) Copy Code
Dim instance As WebCompilerPagesAttribute
Dim value() As String

value = instance.Resoruces
C#
public string[] Resoruces {get;}
Managed Extensions for C++
public: __property string*[]* get_Resoruces();
C++/CLI
public:
property array<String^>^ Resoruces {
   array<String^>^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCompilerPagesAttribute Class
WebCompilerPagesAttribute Members


WebCompilerResourcesAttribute Class

[image]
Gizmox.WebGUI.Common
WebCompilerResourcesAttribute Class
Members See Also Send Feedback
Gizmox.WebGUI.Common.Extensibility Namespace : WebCompilerResourcesAttribute Class

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AllowMultiple=False, Inherited=True)>
Public Class WebCompilerResourcesAttribute
   Inherits Attribute
Visual Basic (Usage) Copy Code
Dim instance As WebCompilerResourcesAttribute
C#
[AttributeUsageAttribute(AllowMultiple=false, Inherited=true)]
public class WebCompilerResourcesAttribute : Attribute
Managed Extensions for C++
[AttributeUsageAttribute(AllowMultiple=false, Inherited=true)]
public __gc class WebCompilerResourcesAttribute : public Attribute
C++/CLI
[AttributeUsageAttribute(AllowMultiple=false, Inherited=true)]
public ref class WebCompilerResourcesAttribute : public Attribute

Inheritance Hierarchy

System.Object
System.Attribute
Gizmox.WebGUI.Common.Extensibility.WebCompilerResourcesAttribute

Requirements

Namespace: Gizmox.WebGUI.Common.Extensibility

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

WebCompilerResourcesAttribute Members
Gizmox.WebGUI.Common.Extensibility Namespace


WebCompilerResourcesAttribute Class Members

[image]
Gizmox.WebGUI.Common
WebCompilerResourcesAttribute Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Common.Extensibility Namespace : WebCompilerResourcesAttribute Class

The following tables list the members exposed by WebCompilerResourcesAttribute.

Public Constructors

 | Name | Description
Public Constructor | WebCompilerResourcesAttribute Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Assembly |
Public Property | Namespace |
Public Property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from System.Attribute)
Top

Public Methods

 | Name | Description
Public Method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from System.Attribute)
Public Method | GetHashCode | Returns the hash code for this instance. (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from System.Attribute)
Public Method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from System.Attribute)
Top

See Also

Reference

WebCompilerResourcesAttribute Class
Gizmox.WebGUI.Common.Extensibility Namespace


WebCompilerResourcesAttribute Constructor

[image]
Gizmox.WebGUI.Common
WebCompilerResourcesAttribute Constructor
See Also Send Feedback
Gizmox.WebGUI.Common.Extensibility Namespace > WebCompilerResourcesAttribute Class : WebCompilerResourcesAttribute Constructor

Overload List

Overload | Description
WebCompilerResourcesAttribute Constructor(String) |
WebCompilerResourcesAttribute Constructor(String,String) |
WebCompilerResourcesAttribute Constructor(Type) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCompilerResourcesAttribute Class
WebCompilerResourcesAttribute Members


WebCompilerResourcesAttribute Constructor(String)

[image]
Gizmox.WebGUI.Common
WebCompilerResourcesAttribute Constructor(String)
See Also Send Feedback
Gizmox.WebGUI.Common.Extensibility Namespace > WebCompilerResourcesAttribute Class > WebCompilerResourcesAttribute Constructor : WebCompilerResourcesAttribute Constructor(String)

strNamespace

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal strNamespace As String _
)
Visual Basic (Usage) Copy Code
Dim strNamespace As String

Dim instance As WebCompilerResourcesAttribute(strNamespace)
C#
public WebCompilerResourcesAttribute(
   string strNamespace
)
Managed Extensions for C++
public: WebCompilerResourcesAttribute(
   string* strNamespace
)
C++/CLI
public:
WebCompilerResourcesAttribute(
   String^ strNamespace
)

Parameters

strNamespace

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCompilerResourcesAttribute Class
WebCompilerResourcesAttribute Members
Overload List


WebCompilerResourcesAttribute Constructor(String,String)

[image]
Gizmox.WebGUI.Common
WebCompilerResourcesAttribute Constructor(String,String)
See Also Send Feedback
Gizmox.WebGUI.Common.Extensibility Namespace > WebCompilerResourcesAttribute Class > WebCompilerResourcesAttribute Constructor : WebCompilerResourcesAttribute Constructor(String,String)

strNamespace
strAssembly

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal strNamespace As String, _
   ByVal strAssembly As String _
)
Visual Basic (Usage) Copy Code
Dim strNamespace As String
Dim strAssembly As String

Dim instance As WebCompilerResourcesAttribute(strNamespace, strAssembly)
C#
public WebCompilerResourcesAttribute(
   string strNamespace,
   string strAssembly
)
Managed Extensions for C++
public: WebCompilerResourcesAttribute(
   string* strNamespace,
   string* strAssembly
)
C++/CLI
public:
WebCompilerResourcesAttribute(
   String^ strNamespace,
   String^ strAssembly
)

Parameters

strNamespace
strAssembly

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCompilerResourcesAttribute Class
WebCompilerResourcesAttribute Members
Overload List


WebCompilerResourcesAttribute Constructor(Type)

[image]
Gizmox.WebGUI.Common
WebCompilerResourcesAttribute Constructor(Type)
See Also Send Feedback
Gizmox.WebGUI.Common.Extensibility Namespace > WebCompilerResourcesAttribute Class > WebCompilerResourcesAttribute Constructor : WebCompilerResourcesAttribute Constructor(Type)

objReference

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal objReference As Type _
)
Visual Basic (Usage) Copy Code
Dim objReference As Type

Dim instance As WebCompilerResourcesAttribute(objReference)
C#
public WebCompilerResourcesAttribute(
   Type objReference
)
Managed Extensions for C++
public: WebCompilerResourcesAttribute(
   Type* objReference
)
C++/CLI
public:
WebCompilerResourcesAttribute(
   Type^ objReference
)

Parameters

objReference

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCompilerResourcesAttribute Class
WebCompilerResourcesAttribute Members
Overload List


WebCompilerResourcesAttribute Class Properties

[image]
Gizmox.WebGUI.Common
WebCompilerResourcesAttribute Class Properties
See Also Send Feedback
Gizmox.WebGUI.Common.Extensibility Namespace : WebCompilerResourcesAttribute Class

For a list of all members of this type, see WebCompilerResourcesAttribute members.

Public Properties

 | Name | Description
Public Property | Assembly |
Public Property | Namespace |
Public Property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from System.Attribute)
Top

See Also

Reference

WebCompilerResourcesAttribute Class
Gizmox.WebGUI.Common.Extensibility Namespace


Assembly Property

[image]
Gizmox.WebGUI.Common
Assembly Property
See Also Send Feedback
Gizmox.WebGUI.Common.Extensibility Namespace > WebCompilerResourcesAttribute Class : Assembly Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Assembly As Assembly
Visual Basic (Usage) Copy Code
Dim instance As WebCompilerResourcesAttribute
Dim value As Assembly

value = instance.Assembly
C#
public Assembly Assembly {get;}
Managed Extensions for C++
public: __property Assembly* get_Assembly();
C++/CLI
public:
property Assembly^ Assembly {
   Assembly^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCompilerResourcesAttribute Class
WebCompilerResourcesAttribute Members


Namespace Property

[image]
Gizmox.WebGUI.Common
Namespace Property
See Also Send Feedback
Gizmox.WebGUI.Common.Extensibility Namespace > WebCompilerResourcesAttribute Class : Namespace Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Namespace As String
Visual Basic (Usage) Copy Code
Dim instance As WebCompilerResourcesAttribute
Dim value As String

value = instance.Namespace
C#
public string Namespace {get;}
Managed Extensions for C++
public: __property string* get_Namespace();
C++/CLI
public:
property String^ Namespace {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WebCompilerResourcesAttribute Class
WebCompilerResourcesAttribute Members


WinCompilerControllerAttribute Class

[image]
Gizmox.WebGUI.Common
WinCompilerControllerAttribute Class
Members See Also Send Feedback
Gizmox.WebGUI.Common.Extensibility Namespace : WinCompilerControllerAttribute Class

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AllowMultiple=False, Inherited=True)>
Public Class WinCompilerControllerAttribute
   Inherits Attribute
Visual Basic (Usage) Copy Code
Dim instance As WinCompilerControllerAttribute
C#
[AttributeUsageAttribute(AllowMultiple=false, Inherited=true)]
public class WinCompilerControllerAttribute : Attribute
Managed Extensions for C++
[AttributeUsageAttribute(AllowMultiple=false, Inherited=true)]
public __gc class WinCompilerControllerAttribute : public Attribute
C++/CLI
[AttributeUsageAttribute(AllowMultiple=false, Inherited=true)]
public ref class WinCompilerControllerAttribute : public Attribute

Inheritance Hierarchy

System.Object
System.Attribute
Gizmox.WebGUI.Common.Extensibility.WinCompilerControllerAttribute

Requirements

Namespace: Gizmox.WebGUI.Common.Extensibility

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

WinCompilerControllerAttribute Members
Gizmox.WebGUI.Common.Extensibility Namespace


WinCompilerControllerAttribute Class Members

[image]
Gizmox.WebGUI.Common
WinCompilerControllerAttribute Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Common.Extensibility Namespace : WinCompilerControllerAttribute Class

The following tables list the members exposed by WinCompilerControllerAttribute.

Public Constructors

 | Name | Description
Public Constructor | WinCompilerControllerAttribute Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | ControllerType |
Public Property | ControlType |
Public Property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from System.Attribute)
Top

Public Methods

 | Name | Description
Public Method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from System.Attribute)
Public Method | GetHashCode | Returns the hash code for this instance. (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from System.Attribute)
Public Method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from System.Attribute)
Top

See Also

Reference

WinCompilerControllerAttribute Class
Gizmox.WebGUI.Common.Extensibility Namespace


WinCompilerControllerAttribute Constructor

[image]
Gizmox.WebGUI.Common
WinCompilerControllerAttribute Constructor
See Also Send Feedback
Gizmox.WebGUI.Common.Extensibility Namespace > WinCompilerControllerAttribute Class : WinCompilerControllerAttribute Constructor

Overload List

Overload | Description
WinCompilerControllerAttribute Constructor(String,String) |
WinCompilerControllerAttribute Constructor(Type,Type) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WinCompilerControllerAttribute Class
WinCompilerControllerAttribute Members


WinCompilerControllerAttribute Constructor(String,String)

[image]
Gizmox.WebGUI.Common
WinCompilerControllerAttribute Constructor(String,String)
See Also Send Feedback
Gizmox.WebGUI.Common.Extensibility Namespace > WinCompilerControllerAttribute Class > WinCompilerControllerAttribute Constructor : WinCompilerControllerAttribute Constructor(String,String)

strControllerType
strControlType

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal strControllerType As String, _
   ByVal strControlType As String _
)
Visual Basic (Usage) Copy Code
Dim strControllerType As String
Dim strControlType As String

Dim instance As WinCompilerControllerAttribute(strControllerType, strControlType)
C#
public WinCompilerControllerAttribute(
   string strControllerType,
   string strControlType
)
Managed Extensions for C++
public: WinCompilerControllerAttribute(
   string* strControllerType,
   string* strControlType
)
C++/CLI
public:
WinCompilerControllerAttribute(
   String^ strControllerType,
   String^ strControlType
)

Parameters

strControllerType
strControlType

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WinCompilerControllerAttribute Class
WinCompilerControllerAttribute Members
Overload List


WinCompilerControllerAttribute Constructor(Type,Type)

[image]
Gizmox.WebGUI.Common
WinCompilerControllerAttribute Constructor(Type,Type)
See Also Send Feedback
Gizmox.WebGUI.Common.Extensibility Namespace > WinCompilerControllerAttribute Class > WinCompilerControllerAttribute Constructor : WinCompilerControllerAttribute Constructor(Type,Type)

objControllerType
objControlType

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal objControllerType As Type, _
   ByVal objControlType As Type _
)
Visual Basic (Usage) Copy Code
Dim objControllerType As Type
Dim objControlType As Type

Dim instance As WinCompilerControllerAttribute(objControllerType, objControlType)
C#
public WinCompilerControllerAttribute(
   Type objControllerType,
   Type objControlType
)
Managed Extensions for C++
public: WinCompilerControllerAttribute(
   Type* objControllerType,
   Type* objControlType
)
C++/CLI
public:
WinCompilerControllerAttribute(
   Type^ objControllerType,
   Type^ objControlType
)

Parameters

objControllerType
objControlType

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WinCompilerControllerAttribute Class
WinCompilerControllerAttribute Members
Overload List


WinCompilerControllerAttribute Class Properties

[image]
Gizmox.WebGUI.Common
WinCompilerControllerAttribute Class Properties
See Also Send Feedback
Gizmox.WebGUI.Common.Extensibility Namespace : WinCompilerControllerAttribute Class

For a list of all members of this type, see WinCompilerControllerAttribute members.

Public Properties

 | Name | Description
Public Property | ControllerType |
Public Property | ControlType |
Public Property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from System.Attribute)
Top

See Also

Reference

WinCompilerControllerAttribute Class
Gizmox.WebGUI.Common.Extensibility Namespace


ControllerType Property

[image]
Gizmox.WebGUI.Common
ControllerType Property
See Also Send Feedback
Gizmox.WebGUI.Common.Extensibility Namespace > WinCompilerControllerAttribute Class : ControllerType Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ControllerType As Type
Visual Basic (Usage) Copy Code
Dim instance As WinCompilerControllerAttribute
Dim value As Type

value = instance.ControllerType
C#
public Type ControllerType {get;}
Managed Extensions for C++
public: __property Type* get_ControllerType();
C++/CLI
public:
property Type^ ControllerType {
   Type^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WinCompilerControllerAttribute Class
WinCompilerControllerAttribute Members


ControlType Property

[image]
Gizmox.WebGUI.Common
ControlType Property
See Also Send Feedback
Gizmox.WebGUI.Common.Extensibility Namespace > WinCompilerControllerAttribute Class : ControlType Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ControlType As Type
Visual Basic (Usage) Copy Code
Dim instance As WinCompilerControllerAttribute
Dim value As Type

value = instance.ControlType
C#
public Type ControlType {get;}
Managed Extensions for C++
public: __property Type* get_ControlType();
C++/CLI
public:
property Type^ ControlType {
   Type^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WinCompilerControllerAttribute Class
WinCompilerControllerAttribute Members


Gizmox.WebGUI.Common.Gateways Namespace

Gizmox.WebGUI.Common
Gizmox.WebGUI.Common.Gateways Namespace
See Also Inheritance Hierarchy Send Feedback

Classes

 | Class | Description
Class | Gateway |
Class | GatewayFile |
Class | GatewayHandler |
Class | GatewayParameters |
Class | GatewayReference |
Class | GatewayWriter |
Class | GZipGatewayReference |
Class | StaticGateway |
Class | StaticGateway.StaticXmlViewerGateway |

See Also

Reference

Gizmox.WebGUI.Common Assembly


Gateway Class

[image]
Gizmox.WebGUI.Common
Gateway Class
Members See Also Send Feedback
Gizmox.WebGUI.Common.Gateways Namespace : Gateway Class

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Class Gateway
Visual Basic (Usage) Copy Code
Dim instance As Gateway
C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public class Gateway
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public __gc class Gateway
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public ref class Gateway

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Common.Gateways.Gateway

Requirements

Namespace: Gizmox.WebGUI.Common.Gateways

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

Gateway Members
Gizmox.WebGUI.Common.Gateways Namespace


Gateway Class Members

[image]
Gizmox.WebGUI.Common
Gateway Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Common.Gateways Namespace : Gateway Class

The following tables list the members exposed by Gateway.

Public Constructors

 | Name | Description
Public Constructor | Gateway Constructor |
Top

Public Properties

 | Name | Description
Public Property | IsReusable |
Top

Public Methods

 | Name | Description
Public Method | ProcessRequest |
Top

See Also

Reference

Gateway Class
Gizmox.WebGUI.Common.Gateways Namespace


Gateway Constructor

[image]
Gizmox.WebGUI.Common
Gateway Constructor
See Also Send Feedback
Gizmox.WebGUI.Common.Gateways Namespace > Gateway Class : Gateway Constructor

objContext

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal objContext As IContext _
)
Visual Basic (Usage) Copy Code
Dim objContext As IContext

Dim instance As Gateway(objContext)
C#
public Gateway(
   IContext objContext
)
Managed Extensions for C++
public: Gateway(
   IContext* objContext
)
C++/CLI
public:
Gateway(
   IContext^ objContext
)

Parameters

objContext

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Gateway Class
Gateway Members


Gateway Class Methods

[image]
Gizmox.WebGUI.Common
Gateway Class Methods
See Also Send Feedback
Gizmox.WebGUI.Common.Gateways Namespace : Gateway Class

For a list of all members of this type, see Gateway members.

Public Methods

 | Name | Description
Public Method | ProcessRequest |
Top

See Also

Reference

Gateway Class
Gizmox.WebGUI.Common.Gateways Namespace


ProcessRequest Method

[image]
Gizmox.WebGUI.Common
ProcessRequest Method
See Also Send Feedback
Gizmox.WebGUI.Common.Gateways Namespace > Gateway Class : ProcessRequest Method

objHttpContext

Syntax

Visual Basic (Declaration)
Public Sub ProcessRequest( _
   ByVal objHttpContext As HttpContext _
)
Visual Basic (Usage) Copy Code
Dim instance As Gateway
Dim objHttpContext As HttpContext

instance.ProcessRequest(objHttpContext)
C#
public void ProcessRequest(
   HttpContext objHttpContext
)
Managed Extensions for C++
public: void ProcessRequest(
   HttpContext* objHttpContext
)
C++/CLI
public:
void ProcessRequest(
   HttpContext^ objHttpContext
)

Parameters

objHttpContext

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Gateway Class
Gateway Members


Gateway Class Properties

[image]
Gizmox.WebGUI.Common
Gateway Class Properties
See Also Send Feedback
Gizmox.WebGUI.Common.Gateways Namespace : Gateway Class

For a list of all members of this type, see Gateway members.

Public Properties

 | Name | Description
Public Property | IsReusable |
Top

See Also

Reference

Gateway Class
Gizmox.WebGUI.Common.Gateways Namespace


IsReusable Property

[image]
Gizmox.WebGUI.Common
IsReusable Property
See Also Send Feedback
Gizmox.WebGUI.Common.Gateways Namespace > Gateway Class : IsReusable Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsReusable As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Gateway
Dim value As Boolean

value = instance.IsReusable
C#
public bool IsReusable {get;}
Managed Extensions for C++
public: __property bool get_IsReusable();
C++/CLI
public:
property bool IsReusable {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Gateway Class
Gateway Members


GatewayFile Class

[image]
Gizmox.WebGUI.Common
GatewayFile Class
Members See Also Send Feedback
Gizmox.WebGUI.Common.Gateways Namespace : GatewayFile Class

Object Model

Syntax

Visual Basic (Declaration)
Public Class GatewayFile
   Inherits GatewayWriter
   Implements IGatewayHandler
Visual Basic (Usage) Copy Code
Dim instance As GatewayFile
C#
public class GatewayFile : GatewayWriter, IGatewayHandler
Managed Extensions for C++
public __gc class GatewayFile : public GatewayWriter, IGatewayHandler
C++/CLI
public ref class GatewayFile : public GatewayWriter, IGatewayHandler

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Common.Gateways.GatewayHandler
Gizmox.WebGUI.Common.Gateways.GatewayWriter
Gizmox.WebGUI.Common.Gateways.GatewayFile

Requirements

Namespace: Gizmox.WebGUI.Common.Gateways

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

GatewayFile Members
Gizmox.WebGUI.Common.Gateways Namespace


GatewayFile Class Members

[image]
Gizmox.WebGUI.Common
GatewayFile Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Common.Gateways Namespace : GatewayFile Class

The following tables list the members exposed by GatewayFile.

Public Constructors

 | Name | Description
Public Constructor | GatewayFile Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Path |
Top

Protected Properties

 | Name | Description
Protected Property | ContentType | (Inherited from GatewayWriter)
Protected Property | GatewayComponent | (Inherited from GatewayWriter)
Top

Public Methods

 | Name | Description
Public Method | ProcessGatewayRequest | (Inherited from GatewayWriter)
Top

Protected Methods

 | Name | Description
Protected Method | GetFormParam | (Inherited from GatewayWriter)
Protected Method | GetQueryParam | (Inherited from GatewayWriter)
Protected Method | GetRequestParam | (Inherited from GatewayWriter)
Protected Method | ProcessRequest | Overridden.
Protected Method | SetContentDisposition | (Inherited from GatewayWriter)
Protected Method | Write | Overloaded. (Inherited from GatewayWriter)
Protected Method | WriteFile | (Inherited from GatewayWriter)
Top

See Also

Reference

GatewayFile Class
Gizmox.WebGUI.Common.Gateways Namespace


GatewayFile Constructor

[image]
Gizmox.WebGUI.Common
GatewayFile Constructor
See Also Send Feedback
Gizmox.WebGUI.Common.Gateways Namespace > GatewayFile Class : GatewayFile Constructor

Overload List

Overload | Description
GatewayFile Constructor() |
GatewayFile Constructor(String) |
GatewayFile Constructor(String,String) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

GatewayFile Class
GatewayFile Members


GatewayFile Constructor()

[image]
Gizmox.WebGUI.Common
GatewayFile Constructor()
See Also Send Feedback
Gizmox.WebGUI.Common.Gateways Namespace > GatewayFile Class > GatewayFile Constructor : GatewayFile Constructor()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As GatewayFile()
C#
public GatewayFile()
Managed Extensions for C++
public: GatewayFile();
C++/CLI
public:
GatewayFile();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

GatewayFile Class
GatewayFile Members
Overload List


GatewayFile Constructor(String)

[image]
Gizmox.WebGUI.Common
GatewayFile Constructor(String)
See Also Send Feedback
Gizmox.WebGUI.Common.Gateways Namespace > GatewayFile Class > GatewayFile Constructor : GatewayFile Constructor(String)

strPath

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal strPath As String _
)
Visual Basic (Usage) Copy Code
Dim strPath As String

Dim instance As GatewayFile(strPath)
C#
public GatewayFile(
   string strPath
)
Managed Extensions for C++
public: GatewayFile(
   string* strPath
)
C++/CLI
public:
GatewayFile(
   String^ strPath
)

Parameters

strPath

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

GatewayFile Class
GatewayFile Members
Overload List


GatewayFile Constructor(String,String)

[image]
Gizmox.WebGUI.Common
GatewayFile Constructor(String,String)
See Also Send Feedback
Gizmox.WebGUI.Common.Gateways Namespace > GatewayFile Class > GatewayFile Constructor : GatewayFile Constructor(String,String)

strPath
strContentType

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal strPath As String, _
   ByVal strContentType As String _
)
Visual Basic (Usage) Copy Code
Dim strPath As String
Dim strContentType As String

Dim instance As GatewayFile(strPath, strContentType)
C#
public GatewayFile(
   string strPath,
   string strContentType
)
Managed Extensions for C++
public: GatewayFile(
   string* strPath,
   string* strContentType
)
C++/CLI
public:
GatewayFile(
   String^ strPath,
   String^ strContentType
)

Parameters

strPath
strContentType

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

GatewayFile Class
GatewayFile Members
Overload List


GatewayFile Class Methods

[image]
Gizmox.WebGUI.Common
GatewayFile Class Methods
See Also Send Feedback
Gizmox.WebGUI.Common.Gateways Namespace : GatewayFile Class

For a list of all members of this type, see GatewayFile members.

Public Methods

 | Name | Description
Public Method | ProcessGatewayRequest | (Inherited from GatewayWriter)
Top

Protected Methods

 | Name | Description
Protected Method | GetFormParam | (Inherited from GatewayWriter)
Protected Method | GetQueryParam | (Inherited from GatewayWriter)
Protected Method | GetRequestParam | (Inherited from GatewayWriter)
Protected Method | ProcessRequest | Overridden.
Protected Method | SetContentDisposition | (Inherited from GatewayWriter)
Protected Method | Write | Overloaded. (Inherited from GatewayWriter)
Protected Method | WriteFile | (Inherited from GatewayWriter)
Top

See Also

Reference

GatewayFile Class
Gizmox.WebGUI.Common.Gateways Namespace


ProcessRequest Method

[image]
Gizmox.WebGUI.Common
ProcessRequest Method
See Also Send Feedback
Gizmox.WebGUI.Common.Gateways Namespace > GatewayFile Class : ProcessRequest Method

Syntax

Visual Basic (Declaration)
Protected Overrides Sub ProcessRequest()
Visual Basic (Usage) Copy Code
Dim instance As GatewayFile

instance.ProcessRequest()
C#
protected override void ProcessRequest()
Managed Extensions for C++
protected: void ProcessRequest(); override
C++/CLI
protected:
void ProcessRequest(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

GatewayFile Class
GatewayFile Members


GatewayFile Class Properties

[image]
Gizmox.WebGUI.Common
GatewayFile Class Properties
See Also Send Feedback
Gizmox.WebGUI.Common.Gateways Namespace : GatewayFile Class

For a list of all members of this type, see GatewayFile members.

Public Properties

 | Name | Description
Public Property | Path |
Top

Protected Properties

 | Name | Description
Protected Property | ContentType | (Inherited from GatewayWriter)
Protected Property | GatewayComponent | (Inherited from GatewayWriter)
Top

See Also

Reference

GatewayFile Class
Gizmox.WebGUI.Common.Gateways Namespace


Path Property

[image]
Gizmox.WebGUI.Common
Path Property
See Also Send Feedback
Gizmox.WebGUI.Common.Gateways Namespace > GatewayFile Class : Path Property

Syntax

Visual Basic (Declaration)
Public Property Path As String
Visual Basic (Usage) Copy Code
Dim instance As GatewayFile
Dim value As String

instance.Path = value

value = instance.Path
C#
public string Path {get; set;}
Managed Extensions for C++
public: __property string* get_Path();
public: __property void set_Path(
   string* value
);
C++/CLI
public:
property String^ Path {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

GatewayFile Class
GatewayFile Members


GatewayHandler Class

[image]
Gizmox.WebGUI.Common
GatewayHandler Class
Members See Also Send Feedback
Gizmox.WebGUI.Common.Gateways Namespace : GatewayHandler Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class GatewayHandler
   Implements IGatewayHandler
Visual Basic (Usage) Copy Code
Dim instance As GatewayHandler
C#
public abstract class GatewayHandler : IGatewayHandler
Managed Extensions for C++
public __gc abstract class GatewayHandler : public IGatewayHandler
C++/CLI
public ref class GatewayHandler abstract : public IGatewayHandler

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Common.Gateways.GatewayHandler
Gizmox.WebGUI.Common.Gateways.GatewayWriter

Requirements

Namespace: Gizmox.WebGUI.Common.Gateways

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

GatewayHandler Members
Gizmox.WebGUI.Common.Gateways Namespace


GatewayHandler Class Members

[image]
Gizmox.WebGUI.Common
GatewayHandler Class Members
See Also Methods Send Feedback
Gizmox.WebGUI.Common.Gateways Namespace : GatewayHandler Class

The following tables list the members exposed by GatewayHandler.

Public Methods

 | Name | Description
Public Method | ProcessGatewayRequest |
Top

See Also

Reference

GatewayHandler Class
Gizmox.WebGUI.Common.Gateways Namespace


GatewayHandler Class Methods

[image]
Gizmox.WebGUI.Common
GatewayHandler Class Methods
See Also Send Feedback
Gizmox.WebGUI.Common.Gateways Namespace : GatewayHandler Class

For a list of all members of this type, see GatewayHandler members.

Public Methods

 | Name | Description
Public Method | ProcessGatewayRequest |
Top

See Also

Reference

GatewayHandler Class
Gizmox.WebGUI.Common.Gateways Namespace


ProcessGatewayRequest Method

[image]
Gizmox.WebGUI.Common
ProcessGatewayRequest Method
See Also Send Feedback
Gizmox.WebGUI.Common.Gateways Namespace > GatewayHandler Class : ProcessGatewayRequest Method

objContext
objComponent

Syntax

Visual Basic (Declaration)
Public Overridable Sub ProcessGatewayRequest( _
   ByVal objContext As IContext, _
   ByVal objComponent As IRegisteredComponent _
)
Visual Basic (Usage) Copy Code
Dim instance As GatewayHandler
Dim objContext As IContext
Dim objComponent As IRegisteredComponent

instance.ProcessGatewayRequest(objContext, objComponent)
C#
public virtual void ProcessGatewayRequest(
   IContext objContext,
   IRegisteredComponent objComponent
)
Managed Extensions for C++
public: virtual void ProcessGatewayRequest(
   IContext* objContext,
   IRegisteredComponent* objComponent
)
C++/CLI
public:
virtual void ProcessGatewayRequest(
   IContext^ objContext,
   IRegisteredComponent^ objComponent
)

Parameters

objContext
objComponent

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

GatewayHandler Class
GatewayHandler Members


GatewayParameters Class

[image]
Gizmox.WebGUI.Common
GatewayParameters Class
Members See Also Send Feedback
Gizmox.WebGUI.Common.Gateways Namespace : GatewayParameters Class

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Class GatewayParameters
Visual Basic (Usage) Copy Code
Dim instance As GatewayParameters
C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public class GatewayParameters
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public __gc class GatewayParameters
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public ref class GatewayParameters

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Common.Gateways.GatewayParameters

Requirements

Namespace: Gizmox.WebGUI.Common.Gateways

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

GatewayParameters Members
Gizmox.WebGUI.Common.Gateways Namespace


GatewayParameters Class Members

[image]
Gizmox.WebGUI.Common
GatewayParameters Class Members
See Also Properties Send Feedback
Gizmox.WebGUI.Common.Gateways Namespace : GatewayParameters Class

The following tables list the members exposed by GatewayParameters.

Public Constructors

 | Name | Description
Public Constructor | GatewayParameters Constructor |
Top

Public Properties

 | Name | Description
Public Property | Action |
Public Property | Component |
Public Property | IsFullyQualifiedParameters |
Public Property | IsValid |
Public Property | MainForm |
Public Property | MainFormInstance |
Top

See Also

Reference

GatewayParameters Class
Gizmox.WebGUI.Common.Gateways Namespace


GatewayParameters Constructor

[image]
Gizmox.WebGUI.Common
GatewayParameters Constructor
See Also Send Feedback
Gizmox.WebGUI.Common.Gateways Namespace > GatewayParameters Class : GatewayParameters Constructor

strResourceString

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal strResourceString As String _
)
Visual Basic (Usage) Copy Code
Dim strResourceString As String

Dim instance As GatewayParameters(strResourceString)
C#
public GatewayParameters(
   string strResourceString
)
Managed Extensions for C++
public: GatewayParameters(
   string* strResourceString
)
C++/CLI
public:
GatewayParameters(
   String^ strResourceString
)

Parameters

strResourceString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

GatewayParameters Class
GatewayParameters Members


GatewayParameters Class Properties

[image]
Gizmox.WebGUI.Common
GatewayParameters Class Properties
See Also Send Feedback
Gizmox.WebGUI.Common.Gateways Namespace : GatewayParameters Class

For a list of all members of this type, see GatewayParameters members.

Public Properties

 | Name | Description
Public Property | Action |
Public Property | Component |
Public Property | IsFullyQualifiedParameters |
Public Property | IsValid |
Public Property | MainForm |
Public Property | MainFormInstance |
Top

See Also

Reference

GatewayParameters Class
Gizmox.WebGUI.Common.Gateways Namespace


Action Property

[image]
Gizmox.WebGUI.Common
Action Property
See Also Send Feedback
Gizmox.WebGUI.Common.Gateways Namespace > GatewayParameters Class : Action Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Action As String
Visual Basic (Usage) Copy Code
Dim instance As GatewayParameters
Dim value As String

value = instance.Action
C#
public string Action {get;}
Managed Extensions for C++
public: __property string* get_Action();
C++/CLI
public:
property String^ Action {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

GatewayParameters Class
GatewayParameters Members


Component Property

[image]
Gizmox.WebGUI.Common
Component Property
See Also Send Feedback
Gizmox.WebGUI.Common.Gateways Namespace > GatewayParameters Class : Component Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Component As String
Visual Basic (Usage) Copy Code
Dim instance As GatewayParameters
Dim value As String

value = instance.Component
C#
public string Component {get;}
Managed Extensions for C++
public: __property string* get_Component();
C++/CLI
public:
property String^ Component {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

GatewayParameters Class
GatewayParameters Members


IsFullyQualifiedParameters Property

[image]
Gizmox.WebGUI.Common
IsFullyQualifiedParameters Property
See Also Send Feedback
Gizmox.WebGUI.Common.Gateways Namespace > GatewayParameters Class : IsFullyQualifiedParameters Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsFullyQualifiedParameters As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GatewayParameters
Dim value As Boolean

value = instance.IsFullyQualifiedParameters
C#
public bool IsFullyQualifiedParameters {get;}
Managed Extensions for C++
public: __property bool get_IsFullyQualifiedParameters();
C++/CLI
public:
property bool IsFullyQualifiedParameters {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

GatewayParameters Class
GatewayParameters Members


IsValid Property

[image]
Gizmox.WebGUI.Common
IsValid Property
See Also Send Feedback
Gizmox.WebGUI.Common.Gateways Namespace > GatewayParameters Class : IsValid Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsValid As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GatewayParameters
Dim value As Boolean

value = instance.IsValid
C#
public bool IsValid {get;}
Managed Extensions for C++
public: __property bool get_IsValid();
C++/CLI
public:
property bool IsValid {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

GatewayParameters Class
GatewayParameters Members


MainForm Property

[image]
Gizmox.WebGUI.Common
MainForm Property
See Also Send Feedback
Gizmox.WebGUI.Common.Gateways Namespace > GatewayParameters Class : MainForm Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MainForm As String
Visual Basic (Usage) Copy Code
Dim instance As GatewayParameters
Dim value As String

value = instance.MainForm
C#
public string MainForm {get;}
Managed Extensions for C++
public: __property string* get_MainForm();
C++/CLI
public:
property String^ MainForm {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

GatewayParameters Class
GatewayParameters Members


MainFormInstance Property

[image]
Gizmox.WebGUI.Common
MainFormInstance Property
See Also Send Feedback
Gizmox.WebGUI.Common.Gateways Namespace > GatewayParameters Class : MainFormInstance Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MainFormInstance As String
Visual Basic (Usage) Copy Code
Dim instance As GatewayParameters
Dim value As String

value = instance.MainFormInstance
C#
public string MainFormInstance {get;}
Managed Extensions for C++
public: __property string* get_MainFormInstance();
C++/CLI
public:
property String^ MainFormInstance {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

GatewayParameters Class
GatewayParameters Members


GatewayReference Class

[image]
Gizmox.WebGUI.Common
GatewayReference Class
Members See Also Send Feedback
Gizmox.WebGUI.Common.Gateways Namespace : GatewayReference Class

Object Model

Syntax

Visual Basic (Declaration)
Public Class GatewayReference
Visual Basic (Usage) Copy Code
Dim instance As GatewayReference
C#
public class GatewayReference
Managed Extensions for C++
public __gc class GatewayReference
C++/CLI
public ref class GatewayReference

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Common.Gateways.GatewayReference
Gizmox.WebGUI.Common.Gateways.GZipGatewayReference

Requirements

Namespace: Gizmox.WebGUI.Common.Gateways

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

GatewayReference Members
Gizmox.WebGUI.Common.Gateways Namespace


GatewayReference Class Members

[image]
Gizmox.WebGUI.Common
GatewayReference Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Common.Gateways Namespace : GatewayReference Class

The following tables list the members exposed by GatewayReference.

Public Properties

 | Name | Description
Public Property | Action |
Public Property | Chachable |
Public Property | Component |
Public Property | Handler |
Top

Public Methods

 | Name | Description
Public Method | ToString | Overridden.
Top

See Also

Reference

GatewayReference Class
Gizmox.WebGUI.Common.Gateways Namespace


GatewayReference Class Methods

[image]
Gizmox.WebGUI.Common
GatewayReference Class Methods
See Also Send Feedback
Gizmox.WebGUI.Common.Gateways Namespace : GatewayReference Class

For a list of all members of this type, see GatewayReference members.

Public Methods

 | Name | Description
Public Method | ToString | Overridden.
Top

See Also

Reference

GatewayReference Class
Gizmox.WebGUI.Common.Gateways Namespace


ToString Method

[image]
Gizmox.WebGUI.Common
ToString Method
See Also Send Feedback
Gizmox.WebGUI.Common.Gateways Namespace > GatewayReference Class : ToString Method

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As GatewayReference
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

GatewayReference Class
GatewayReference Members


GatewayReference Class Properties

[image]
Gizmox.WebGUI.Common
GatewayReference Class Properties
See Also Send Feedback
Gizmox.WebGUI.Common.Gateways Namespace : GatewayReference Class

For a list of all members of this type, see GatewayReference members.

Public Properties

 | Name | Description
Public Property | Action |
Public Property | Chachable |
Public Property | Component |
Public Property | Handler |
Top

See Also

Reference

GatewayReference Class
Gizmox.WebGUI.Common.Gateways Namespace


Action Property

[image]
Gizmox.WebGUI.Common
Action Property
See Also Send Feedback
Gizmox.WebGUI.Common.Gateways Namespace > GatewayReference Class : Action Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Action As String
Visual Basic (Usage) Copy Code
Dim instance As GatewayReference
Dim value As String

value = instance.Action
C#
public string Action {get;}
Managed Extensions for C++
public: __property string* get_Action();
C++/CLI
public:
property String^ Action {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

GatewayReference Class
GatewayReference Members


Chachable Property

[image]
Gizmox.WebGUI.Common
Chachable Property
See Also Send Feedback
Gizmox.WebGUI.Common.Gateways Namespace > GatewayReference Class : Chachable Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Chachable As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GatewayReference
Dim value As Boolean

value = instance.Chachable
C#
public bool Chachable {get;}
Managed Extensions for C++
public: __property bool get_Chachable();
C++/CLI
public:
property bool Chachable {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

GatewayReference Class
GatewayReference Members


Component Property

[image]
Gizmox.WebGUI.Common
Component Property
See Also Send Feedback
Gizmox.WebGUI.Common.Gateways Namespace > GatewayReference Class : Component Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Component As IRegisteredComponent
Visual Basic (Usage) Copy Code
Dim instance As GatewayReference
Dim value As IRegisteredComponent

value = instance.Component
C#
public IRegisteredComponent Component {get;}
Managed Extensions for C++
public: __property IRegisteredComponent* get_Component();
C++/CLI
public:
property IRegisteredComponent^ Component {
   IRegisteredComponent^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

GatewayReference Class
GatewayReference Members


Handler Property

[image]
Gizmox.WebGUI.Common
Handler Property
See Also Send Feedback
Gizmox.WebGUI.Common.Gateways Namespace > GatewayReference Class : Handler Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Handler As GatewayHandler
Visual Basic (Usage) Copy Code
Dim instance As GatewayReference
Dim value As GatewayHandler

value = instance.Handler
C#
public GatewayHandler Handler {get;}
Managed Extensions for C++
public: __property GatewayHandler* get_Handler();
C++/CLI
public:
property GatewayHandler^ Handler {
   GatewayHandler^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

GatewayReference Class
GatewayReference Members


GatewayWriter Class

[image]
Gizmox.WebGUI.Common
GatewayWriter Class
Members See Also Send Feedback
Gizmox.WebGUI.Common.Gateways Namespace : GatewayWriter Class

Object Model

Syntax

Visual Basic (Declaration)
Public Class GatewayWriter
   Inherits GatewayHandler
   Implements IGatewayHandler
Visual Basic (Usage) Copy Code
Dim instance As GatewayWriter
C#
public class GatewayWriter : GatewayHandler, IGatewayHandler
Managed Extensions for C++
public __gc class GatewayWriter : public GatewayHandler, IGatewayHandler
C++/CLI
public ref class GatewayWriter : public GatewayHandler, IGatewayHandler

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Common.Gateways.GatewayHandler
Gizmox.WebGUI.Common.Gateways.GatewayWriter
Gizmox.WebGUI.Common.Gateways.GatewayFile
Gizmox.WebGUI.Forms.HtmlBox.HtmlGateway
Gizmox.WebGUI.Forms.XamlBox.XamlGateway

Requirements

Namespace: Gizmox.WebGUI.Common.Gateways

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

GatewayWriter Members
Gizmox.WebGUI.Common.Gateways Namespace


GatewayWriter Class Members

[image]
Gizmox.WebGUI.Common
GatewayWriter Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Common.Gateways Namespace : GatewayWriter Class

The following tables list the members exposed by GatewayWriter.

Public Constructors

 | Name | Description
Public Constructor | GatewayWriter Constructor |
Top

Protected Properties

 | Name | Description
Protected Property | ContentType |
Protected Property | GatewayComponent |
Top

Public Methods

 | Name | Description
Public Method | ProcessGatewayRequest | Overridden.
Top

Protected Methods

 | Name | Description
Protected Method | GetFormParam |
Protected Method | GetQueryParam |
Protected Method | GetRequestParam |
Protected Method | ProcessRequest |
Protected Method | SetContentDisposition |
Protected Method | Write | Overloaded.
Protected Method | WriteFile |
Top

See Also

Reference

GatewayWriter Class
Gizmox.WebGUI.Common.Gateways Namespace


GatewayWriter Constructor

[image]
Gizmox.WebGUI.Common
GatewayWriter Constructor
See Also Send Feedback
Gizmox.WebGUI.Common.Gateways Namespace > GatewayWriter Class : GatewayWriter Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As GatewayWriter()
C#
public GatewayWriter()
Managed Extensions for C++
public: GatewayWriter();
C++/CLI
public:
GatewayWriter();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

GatewayWriter Class
GatewayWriter Members


GatewayWriter Class Methods

[image]
Gizmox.WebGUI.Common
GatewayWriter Class Methods
See Also Send Feedback
Gizmox.WebGUI.Common.Gateways Namespace : GatewayWriter Class

For a list of all members of this type, see GatewayWriter members.

Public Methods

 | Name | Description
Public Method | ProcessGatewayRequest | Overridden.
Top

Protected Methods

 | Name | Description
Protected Method | GetFormParam |
Protected Method | GetQueryParam |
Protected Method | GetRequestParam |
Protected Method | ProcessRequest |
Protected Method | SetContentDisposition |
Protected Method | Write | Overloaded.
Protected Method | WriteFile |
Top

See Also

Reference

GatewayWriter Class
Gizmox.WebGUI.Common.Gateways Namespace


GetFormParam Method

[image]
Gizmox.WebGUI.Common
GetFormParam Method
See Also Send Feedback
Gizmox.WebGUI.Common.Gateways Namespace > GatewayWriter Class : GetFormParam Method

strName

Syntax

Visual Basic (Declaration)
Protected Function GetFormParam( _
   ByVal strName As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As GatewayWriter
Dim strName As String
Dim value As String

value = instance.GetFormParam(strName)
C#
protected string GetFormParam(
   string strName
)
Managed Extensions for C++
protected: string* GetFormParam(
   string* strName
)
C++/CLI
protected:
String^ GetFormParam(
   String^ strName
)

Parameters

strName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

GatewayWriter Class
GatewayWriter Members


GetQueryParam Method

[image]
Gizmox.WebGUI.Common
GetQueryParam Method
See Also Send Feedback
Gizmox.WebGUI.Common.Gateways Namespace > GatewayWriter Class : GetQueryParam Method

strName

Syntax

Visual Basic (Declaration)
Protected Function GetQueryParam( _
   ByVal strName As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As GatewayWriter
Dim strName As String
Dim value As String

value = instance.GetQueryParam(strName)
C#
protected string GetQueryParam(
   string strName
)
Managed Extensions for C++
protected: string* GetQueryParam(
   string* strName
)
C++/CLI
protected:
String^ GetQueryParam(
   String^ strName
)

Parameters

strName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

GatewayWriter Class
GatewayWriter Members


GetRequestParam Method

[image]
Gizmox.WebGUI.Common
GetRequestParam Method
See Also Send Feedback
Gizmox.WebGUI.Common.Gateways Namespace > GatewayWriter Class : GetRequestParam Method

strName

Syntax

Visual Basic (Declaration)
Protected Function GetRequestParam( _
   ByVal strName As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As GatewayWriter
Dim strName As String
Dim value As String

value = instance.GetRequestParam(strName)
C#
protected string GetRequestParam(
   string strName
)
Managed Extensions for C++
protected: string* GetRequestParam(
   string* strName
)
C++/CLI
protected:
String^ GetRequestParam(
   String^ strName
)

Parameters

strName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

GatewayWriter Class
GatewayWriter Members


ProcessGatewayRequest Method

[image]
Gizmox.WebGUI.Common
ProcessGatewayRequest Method
See Also Send Feedback
Gizmox.WebGUI.Common.Gateways Namespace > GatewayWriter Class : ProcessGatewayRequest Method

objContext
objComponent

Syntax

Visual Basic (Declaration)
Public Overrides Sub ProcessGatewayRequest( _
   ByVal objContext As IContext, _
   ByVal objComponent As IRegisteredComponent _
)
Visual Basic (Usage) Copy Code
Dim instance As GatewayWriter
Dim objContext As IContext
Dim objComponent As IRegisteredComponent

instance.ProcessGatewayRequest(objContext, objComponent)
C#
public override void ProcessGatewayRequest(
   IContext objContext,
   IRegisteredComponent objComponent
)
Managed Extensions for C++
public: void ProcessGatewayRequest(
   IContext* objContext,
   IRegisteredComponent* objComponent
) override
C++/CLI
public:
void ProcessGatewayRequest(
   IContext^ objContext,
   IRegisteredComponent^ objComponent
) override

Parameters

objContext
objComponent

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

GatewayWriter Class
GatewayWriter Members


ProcessRequest Method

[image]
Gizmox.WebGUI.Common
ProcessRequest Method
See Also Send Feedback
Gizmox.WebGUI.Common.Gateways Namespace > GatewayWriter Class : ProcessRequest Method

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ProcessRequest()
Visual Basic (Usage) Copy Code
Dim instance As GatewayWriter

instance.ProcessRequest()
C#
protected virtual void ProcessRequest()
Managed Extensions for C++
protected: virtual void ProcessRequest();
C++/CLI
protected:
virtual void ProcessRequest();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

GatewayWriter Class
GatewayWriter Members


SetContentDisposition Method

[image]
Gizmox.WebGUI.Common
SetContentDisposition Method
See Also Send Feedback
Gizmox.WebGUI.Common.Gateways Namespace > GatewayWriter Class : SetContentDisposition Method

strFileName

Syntax

Visual Basic (Declaration)
Protected Sub SetContentDisposition( _
   ByVal strFileName As String _
)
Visual Basic (Usage) Copy Code
Dim instance As GatewayWriter
Dim strFileName As String

instance.SetContentDisposition(strFileName)
C#
protected void SetContentDisposition(
   string strFileName
)
Managed Extensions for C++
protected: void SetContentDisposition(
   string* strFileName
)
C++/CLI
protected:
void SetContentDisposition(
   String^ strFileName
)

Parameters

strFileName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

GatewayWriter Class
GatewayWriter Members


Write Method

[image]
Gizmox.WebGUI.Common
Write Method
See Also Send Feedback
Gizmox.WebGUI.Common.Gateways Namespace > GatewayWriter Class : Write Method

Overload List

Overload | Description
Write(String) |
Write(Byte[]) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

GatewayWriter Class
GatewayWriter Members


Write(String) Method

[image]
Gizmox.WebGUI.Common
Write(String) Method
See Also Send Feedback
Gizmox.WebGUI.Common.Gateways Namespace > GatewayWriter Class > Write Method : Write(String) Method

strValue

Syntax

Visual Basic (Declaration)
Protected Overloads Sub Write( _
   ByVal strValue As String _
)
Visual Basic (Usage) Copy Code
Dim instance As GatewayWriter
Dim strValue As String

instance.Write(strValue)
C#
protected void Write(
   string strValue
)
Managed Extensions for C++
protected: void Write(
   string* strValue
)
C++/CLI
protected:
void Write(
   String^ strValue
)

Parameters

strValue

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

GatewayWriter Class
GatewayWriter Members
Overload List


Write(Byte[]) Method

[image]
Gizmox.WebGUI.Common
Write(Byte[]) Method
See Also Send Feedback
Gizmox.WebGUI.Common.Gateways Namespace > GatewayWriter Class > Write Method : Write(Byte[]) Method

arrByte

Syntax

Visual Basic (Declaration)
Protected Overloads Sub Write( _
   ByVal arrByte() As Byte _
)
Visual Basic (Usage) Copy Code
Dim instance As GatewayWriter
Dim arrByte() As Byte

instance.Write(arrByte)
C#
protected void Write(
   byte[] arrByte
)
Managed Extensions for C++
protected: void Write(
   byte[]* arrByte
)
C++/CLI
protected:
void Write(
   array<byte>^ arrByte
)

Parameters

arrByte

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

GatewayWriter Class
GatewayWriter Members
Overload List


WriteFile Method

[image]
Gizmox.WebGUI.Common
WriteFile Method
See Also Send Feedback
Gizmox.WebGUI.Common.Gateways Namespace > GatewayWriter Class : WriteFile Method

strPath

Syntax

Visual Basic (Declaration)
Protected Sub WriteFile( _
   ByVal strPath As String _
)
Visual Basic (Usage) Copy Code
Dim instance As GatewayWriter
Dim strPath As String

instance.WriteFile(strPath)
C#
protected void WriteFile(
   string strPath
)
Managed Extensions for C++
protected: void WriteFile(
   string* strPath
)
C++/CLI
protected:
void WriteFile(
   String^ strPath
)

Parameters

strPath

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

GatewayWriter Class
GatewayWriter Members


GatewayWriter Class Properties

[image]
Gizmox.WebGUI.Common
GatewayWriter Class Properties
See Also Send Feedback
Gizmox.WebGUI.Common.Gateways Namespace : GatewayWriter Class

For a list of all members of this type, see GatewayWriter members.

Protected Properties

 | Name | Description
Protected Property | ContentType |
Protected Property | GatewayComponent |
Top

See Also

Reference

GatewayWriter Class
Gizmox.WebGUI.Common.Gateways Namespace


ContentType Property

[image]
Gizmox.WebGUI.Common
ContentType Property
See Also Send Feedback
Gizmox.WebGUI.Common.Gateways Namespace > GatewayWriter Class : ContentType Property

Syntax

Visual Basic (Declaration)
Protected Property ContentType As String
Visual Basic (Usage) Copy Code
Dim instance As GatewayWriter
Dim value As String

instance.ContentType = value

value = instance.ContentType
C#
protected string ContentType {get; set;}
Managed Extensions for C++
protected: __property string* get_ContentType();
protected: __property void set_ContentType(
   string* value
);
C++/CLI
protected:
property String^ ContentType {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

GatewayWriter Class
GatewayWriter Members


GatewayComponent Property

[image]
Gizmox.WebGUI.Common
GatewayComponent Property
See Also Send Feedback
Gizmox.WebGUI.Common.Gateways Namespace > GatewayWriter Class : GatewayComponent Property

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property GatewayComponent As IRegisteredComponent
Visual Basic (Usage) Copy Code
Dim instance As GatewayWriter
Dim value As IRegisteredComponent

value = instance.GatewayComponent
C#
protected IRegisteredComponent GatewayComponent {get;}
Managed Extensions for C++
protected: __property IRegisteredComponent* get_GatewayComponent();
C++/CLI
protected:
property IRegisteredComponent^ GatewayComponent {
   IRegisteredComponent^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

GatewayWriter Class
GatewayWriter Members


GZipGatewayReference Class

[image]
Gizmox.WebGUI.Common
GZipGatewayReference Class
Members See Also Send Feedback
Gizmox.WebGUI.Common.Gateways Namespace : GZipGatewayReference Class

Object Model

Syntax

Visual Basic (Declaration)
Public Class GZipGatewayReference
   Inherits GatewayReference
Visual Basic (Usage) Copy Code
Dim instance As GZipGatewayReference
C#
public class GZipGatewayReference : GatewayReference
Managed Extensions for C++
public __gc class GZipGatewayReference : public GatewayReference
C++/CLI
public ref class GZipGatewayReference : public GatewayReference

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Common.Gateways.GatewayReference
Gizmox.WebGUI.Common.Gateways.GZipGatewayReference

Requirements

Namespace: Gizmox.WebGUI.Common.Gateways

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

GZipGatewayReference Members
Gizmox.WebGUI.Common.Gateways Namespace


GZipGatewayReference Class Members

[image]
Gizmox.WebGUI.Common
GZipGatewayReference Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Common.Gateways Namespace : GZipGatewayReference Class

The following tables list the members exposed by GZipGatewayReference.

Public Constructors

 | Name | Description
Public Constructor | GZipGatewayReference Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Action | (Inherited from GatewayReference)
Public Property | Chachable | (Inherited from GatewayReference)
Public Property | Component | (Inherited from GatewayReference)
Public Property | Handler | (Inherited from GatewayReference)
Top

Public Methods

 | Name | Description
Public Method | ToString | (Inherited from GatewayReference)
Top

See Also

Reference

GZipGatewayReference Class
Gizmox.WebGUI.Common.Gateways Namespace


GZipGatewayReference Constructor

[image]
Gizmox.WebGUI.Common
GZipGatewayReference Constructor
See Also Send Feedback
Gizmox.WebGUI.Common.Gateways Namespace > GZipGatewayReference Class : GZipGatewayReference Constructor

Overload List

Overload | Description
GZipGatewayReference Constructor(IRegisteredComponent,GatewayHandler,String) |
GZipGatewayReference Constructor(IRegisteredComponent,String) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

GZipGatewayReference Class
GZipGatewayReference Members


GZipGatewayReference Constructor(IRegisteredComponent,GatewayHandler,String)

[image]
Gizmox.WebGUI.Common
GZipGatewayReference Constructor(IRegisteredComponent,GatewayHandler,String)
See Also Send Feedback
Gizmox.WebGUI.Common.Gateways Namespace > GZipGatewayReference Class > GZipGatewayReference Constructor : GZipGatewayReference Constructor(IRegisteredComponent,GatewayHandler,String)

objComponent
objHandler
strAction

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal objComponent As IRegisteredComponent, _
   ByVal objHandler As GatewayHandler, _
   ByVal strAction As String _
)
Visual Basic (Usage) Copy Code
Dim objComponent As IRegisteredComponent
Dim objHandler As GatewayHandler
Dim strAction As String

Dim instance As GZipGatewayReference(objComponent, objHandler, strAction)
C#
public GZipGatewayReference(
   IRegisteredComponent objComponent,
   GatewayHandler objHandler,
   string strAction
)
Managed Extensions for C++
public: GZipGatewayReference(
   IRegisteredComponent* objComponent,
   GatewayHandler* objHandler,
   string* strAction
)
C++/CLI
public:
GZipGatewayReference(
   IRegisteredComponent^ objComponent,
   GatewayHandler^ objHandler,
   String^ strAction
)

Parameters

objComponent
objHandler
strAction

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

GZipGatewayReference Class
GZipGatewayReference Members
Overload List


GZipGatewayReference Constructor(IRegisteredComponent,String)

[image]
Gizmox.WebGUI.Common
GZipGatewayReference Constructor(IRegisteredComponent,String)
See Also Send Feedback
Gizmox.WebGUI.Common.Gateways Namespace > GZipGatewayReference Class > GZipGatewayReference Constructor : GZipGatewayReference Constructor(IRegisteredComponent,String)

objComponent
strAction

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal objComponent As IRegisteredComponent, _
   ByVal strAction As String _
)
Visual Basic (Usage) Copy Code
Dim objComponent As IRegisteredComponent
Dim strAction As String

Dim instance As GZipGatewayReference(objComponent, strAction)
C#
public GZipGatewayReference(
   IRegisteredComponent objComponent,
   string strAction
)
Managed Extensions for C++
public: GZipGatewayReference(
   IRegisteredComponent* objComponent,
   string* strAction
)
C++/CLI
public:
GZipGatewayReference(
   IRegisteredComponent^ objComponent,
   String^ strAction
)

Parameters

objComponent
strAction

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

GZipGatewayReference Class
GZipGatewayReference Members
Overload List


StaticGateway Class

[image]
Gizmox.WebGUI.Common
StaticGateway Class
Members See Also Send Feedback
Gizmox.WebGUI.Common.Gateways Namespace : StaticGateway Class

Syntax

Visual Basic (Declaration)
Public Class StaticGateway
Visual Basic (Usage) Copy Code
Dim instance As StaticGateway
C#
public class StaticGateway
Managed Extensions for C++
public __gc class StaticGateway
C++/CLI
public ref class StaticGateway

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Common.Gateways.StaticGateway

Requirements

Namespace: Gizmox.WebGUI.Common.Gateways

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

StaticGateway Members
Gizmox.WebGUI.Common.Gateways Namespace


StaticGateway Class Members

[image]
Gizmox.WebGUI.Common
StaticGateway Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Common.Gateways Namespace : StaticGateway Class

The following tables list the members exposed by StaticGateway.

Public Constructors

 | Name | Description
Public Constructor | StaticGateway Constructor |
Top

Public Properties

 | Name | Description
Public Property | IsReusable |
Top

Public Methods

 | Name | Description
Public Method | ProcessRequest |
Top

See Also

Reference

StaticGateway Class
Gizmox.WebGUI.Common.Gateways Namespace


StaticGateway Constructor

[image]
Gizmox.WebGUI.Common
StaticGateway Constructor
See Also Send Feedback
Gizmox.WebGUI.Common.Gateways Namespace > StaticGateway Class : StaticGateway Constructor

objContext

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal objContext As IContext _
)
Visual Basic (Usage) Copy Code
Dim objContext As IContext

Dim instance As StaticGateway(objContext)
C#
public StaticGateway(
   IContext objContext
)
Managed Extensions for C++
public: StaticGateway(
   IContext* objContext
)
C++/CLI
public:
StaticGateway(
   IContext^ objContext
)

Parameters

objContext

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

StaticGateway Class
StaticGateway Members


StaticGateway Class Methods

[image]
Gizmox.WebGUI.Common
StaticGateway Class Methods
See Also Send Feedback
Gizmox.WebGUI.Common.Gateways Namespace : StaticGateway Class

For a list of all members of this type, see StaticGateway members.

Public Methods

 | Name | Description
Public Method | ProcessRequest |
Top

See Also

Reference

StaticGateway Class
Gizmox.WebGUI.Common.Gateways Namespace


ProcessRequest Method

[image]
Gizmox.WebGUI.Common
ProcessRequest Method
See Also Send Feedback
Gizmox.WebGUI.Common.Gateways Namespace > StaticGateway Class : ProcessRequest Method

objHttpContext

Syntax

Visual Basic (Declaration)
Public Sub ProcessRequest( _
   ByVal objHttpContext As HttpContext _
)
Visual Basic (Usage) Copy Code
Dim instance As StaticGateway
Dim objHttpContext As HttpContext

instance.ProcessRequest(objHttpContext)
C#
public void ProcessRequest(
   HttpContext objHttpContext
)
Managed Extensions for C++
public: void ProcessRequest(
   HttpContext* objHttpContext
)
C++/CLI
public:
void ProcessRequest(
   HttpContext^ objHttpContext
)

Parameters

objHttpContext

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

StaticGateway Class
StaticGateway Members


StaticGateway Class Properties

[image]
Gizmox.WebGUI.Common
StaticGateway Class Properties
See Also Send Feedback
Gizmox.WebGUI.Common.Gateways Namespace : StaticGateway Class

For a list of all members of this type, see StaticGateway members.

Public Properties

 | Name | Description
Public Property | IsReusable |
Top

See Also

Reference

StaticGateway Class
Gizmox.WebGUI.Common.Gateways Namespace


IsReusable Property

[image]
Gizmox.WebGUI.Common
IsReusable Property
See Also Send Feedback
Gizmox.WebGUI.Common.Gateways Namespace > StaticGateway Class : IsReusable Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsReusable As Boolean
Visual Basic (Usage) Copy Code
Dim instance As StaticGateway
Dim value As Boolean

value = instance.IsReusable
C#
public bool IsReusable {get;}
Managed Extensions for C++
public: __property bool get_IsReusable();
C++/CLI
public:
property bool IsReusable {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

StaticGateway Class
StaticGateway Members


StaticGateway.StaticXmlViewerGateway Class

[image]
Gizmox.WebGUI.Common
StaticGateway.StaticXmlViewerGateway Class
Members See Also Send Feedback
Gizmox.WebGUI.Common.Gateways Namespace : StaticGateway.StaticXmlViewerGateway Class

Syntax

Visual Basic (Declaration)
Private Class StaticGateway.StaticXmlViewerGateway
   Implements IStaticGateway
Visual Basic (Usage) Copy Code
Dim instance As StaticGateway.StaticXmlViewerGateway
C#
private class StaticGateway.StaticXmlViewerGateway : IStaticGateway
Managed Extensions for C++
private __gc class StaticGateway.StaticXmlViewerGateway : public IStaticGateway
C++/CLI
private ref class StaticGateway.StaticXmlViewerGateway : public IStaticGateway

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Common.Gateways.StaticGateway.StaticXmlViewerGateway

Requirements

Namespace: Gizmox.WebGUI.Common.Gateways

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

StaticGateway.StaticXmlViewerGateway Members
Gizmox.WebGUI.Common.Gateways Namespace


StaticGateway.StaticXmlViewerGateway Class Members

[image]
Gizmox.WebGUI.Common
StaticGateway.StaticXmlViewerGateway Class Members
See Also Methods Send Feedback
Gizmox.WebGUI.Common.Gateways Namespace : StaticGateway.StaticXmlViewerGateway Class

The following tables list the members exposed by StaticGateway.StaticXmlViewerGateway.

Public Constructors

 | Name | Description
Public Constructor | StaticGateway.StaticXmlViewerGateway Constructor |
Top

Public Methods

 | Name | Description
Public Method | GetGatewayHandler |
Top

See Also

Reference

StaticGateway.StaticXmlViewerGateway Class
Gizmox.WebGUI.Common.Gateways Namespace


StaticGateway.StaticXmlViewerGateway Constructor

[image]
Gizmox.WebGUI.Common
StaticGateway.StaticXmlViewerGateway Constructor
See Also Send Feedback
Gizmox.WebGUI.Common.Gateways Namespace > StaticGateway.StaticXmlViewerGateway Class : StaticGateway.StaticXmlViewerGateway Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As StaticGateway.StaticXmlViewerGateway()
C#
public StaticGateway.StaticXmlViewerGateway()
Managed Extensions for C++
public: StaticGateway.StaticXmlViewerGateway();
C++/CLI
public:
StaticGateway.StaticXmlViewerGateway();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

StaticGateway.StaticXmlViewerGateway Class
StaticGateway.StaticXmlViewerGateway Members


StaticGateway.StaticXmlViewerGateway Class Methods

[image]
Gizmox.WebGUI.Common
StaticGateway.StaticXmlViewerGateway Class Methods
See Also Send Feedback
Gizmox.WebGUI.Common.Gateways Namespace : StaticGateway.StaticXmlViewerGateway Class

For a list of all members of this type, see StaticGateway.StaticXmlViewerGateway members.

Public Methods

 | Name | Description
Public Method | GetGatewayHandler |
Top

See Also

Reference

StaticGateway.StaticXmlViewerGateway Class
Gizmox.WebGUI.Common.Gateways Namespace


GetGatewayHandler Method

[image]
Gizmox.WebGUI.Common
GetGatewayHandler Method
See Also Send Feedback
Gizmox.WebGUI.Common.Gateways Namespace > StaticGateway.StaticXmlViewerGateway Class : GetGatewayHandler Method

objContext

Syntax

Visual Basic (Declaration)
Public Function GetGatewayHandler( _
   ByVal objContext As IContext _
) As IStaticGatewayHandler
Visual Basic (Usage) Copy Code
Dim instance As StaticGateway.StaticXmlViewerGateway
Dim objContext As IContext
Dim value As IStaticGatewayHandler

value = instance.GetGatewayHandler(objContext)
C#
public IStaticGatewayHandler GetGatewayHandler(
   IContext objContext
)
Managed Extensions for C++
public: IStaticGatewayHandler* GetGatewayHandler(
   IContext* objContext
)
C++/CLI
public:
IStaticGatewayHandler^ GetGatewayHandler(
   IContext^ objContext
)

Parameters

objContext

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

StaticGateway.StaticXmlViewerGateway Class
StaticGateway.StaticXmlViewerGateway Members


Gizmox.WebGUI.Common.Interfaces Namespace

Gizmox.WebGUI.Common
Gizmox.WebGUI.Common.Interfaces Namespace
See Also Inheritance Hierarchy Send Feedback

Classes

 | Class | Description
Class | ObservableItemPropertyChangedArgs |
Class | ObservableListEventArgs |
Class | ObservableResumeLayoutArgs |

Interfaces

 | Interface | Description
Interface | IApplication |
Interface | IApplicationContext |
Interface | IArgumentsProvider |
Interface | IArgumentsWriterProvider |
Interface | IAttributeExtender |
Interface | IAttributeWriter |
Interface | ICommand |
Interface | ICommonDialog |
Interface | ICommonDialogHandler |
Interface | IContext |
Interface | IContextClipboard |
Interface | IContextCommonDialogHandler |
Interface | IContextMenu |
Interface | IContextMethodInvoker |
Interface | IContextParams |
Interface | IContextPipeline |
Interface | IContextTerminate |
Interface | IControl |
Interface | ICookies |
Interface | IEvent |
Interface | IEventCollection |
Interface | IEventHandler |
Interface | IForm |
Interface | IFormFactory |
Interface | IFormLink |
Interface | IGatewayComponent |
Interface | IGatewayControl |
Interface | IGatewayHandler |
Interface | ILink |
Interface | ILinkArguments |
Interface | ILinkParameters |
Interface | ILogonForm |
Interface | IMainMenu |
Interface | IMashupArguments |
Interface | IMenu |
Interface | INonSerializable |
Interface | IObservableItem |
Interface | IObservableLayoutItem |
Interface | IObservableList |
Interface | IRegisteredComponent |
Interface | IRegisteredComponentContainer |
Interface | IRegisteredComponentMember |
Interface | IRenderableComponent |
Interface | IRenderableComponentMember |
Interface | IRequest |
Interface | IRequestParams |
Interface | IRequiredRegistration |
Interface | IResponse |
Interface | IResponseWriter |
Interface | IResultsProvider |
Interface | IResultsReaderProvider |
Interface | IRouter |
Interface | ISealedComponent |
Interface | IServer |
Interface | IServerResponse |
Interface | ISession |
Interface | ISessionRegistry |
Interface | IStaticGateway |
Interface | IStaticGatewayHandler |
Interface | ITimer |
Interface | ITimerHandler |
Interface | ITimerHandlerContainer |
Interface | IUserControl |

Enumerations

 | Enumeration | Description
Enumeration | InvokationUniqueness |
Enumeration | MashupType |
Enumeration | RequestType |

See Also

Reference

Gizmox.WebGUI.Common Assembly


ObservableItemPropertyChangedArgs Class

[image]
Gizmox.WebGUI.Common
ObservableItemPropertyChangedArgs Class
Members See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : ObservableItemPropertyChangedArgs Class

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Class ObservableItemPropertyChangedArgs
   Inherits EventArgs
Visual Basic (Usage) Copy Code
Dim instance As ObservableItemPropertyChangedArgs
C#
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public class ObservableItemPropertyChangedArgs : EventArgs
Managed Extensions for C++
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public __gc class ObservableItemPropertyChangedArgs : public EventArgs
C++/CLI
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public ref class ObservableItemPropertyChangedArgs : public EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gizmox.WebGUI.Common.Interfaces.ObservableItemPropertyChangedArgs

Requirements

Namespace: Gizmox.WebGUI.Common.Interfaces

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

ObservableItemPropertyChangedArgs Members
Gizmox.WebGUI.Common.Interfaces Namespace


ObservableItemPropertyChangedArgs Class Members

[image]
Gizmox.WebGUI.Common
ObservableItemPropertyChangedArgs Class Members
See Also Properties Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : ObservableItemPropertyChangedArgs Class

The following tables list the members exposed by ObservableItemPropertyChangedArgs.

Public Constructors

 | Name | Description
Public Constructor | ObservableItemPropertyChangedArgs Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Property |
Public Property | Subject |
Top

See Also

Reference

ObservableItemPropertyChangedArgs Class
Gizmox.WebGUI.Common.Interfaces Namespace


ObservableItemPropertyChangedArgs Constructor

[image]
Gizmox.WebGUI.Common
ObservableItemPropertyChangedArgs Constructor
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > ObservableItemPropertyChangedArgs Class : ObservableItemPropertyChangedArgs Constructor

Overload List

Overload | Description
ObservableItemPropertyChangedArgs Constructor(String) |
ObservableItemPropertyChangedArgs Constructor(String,Object) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ObservableItemPropertyChangedArgs Class
ObservableItemPropertyChangedArgs Members


ObservableItemPropertyChangedArgs Constructor(String)

[image]
Gizmox.WebGUI.Common
ObservableItemPropertyChangedArgs Constructor(String)
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > ObservableItemPropertyChangedArgs Class > ObservableItemPropertyChangedArgs Constructor : ObservableItemPropertyChangedArgs Constructor(String)

strProperty

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal strProperty As String _
)
Visual Basic (Usage) Copy Code
Dim strProperty As String

Dim instance As ObservableItemPropertyChangedArgs(strProperty)
C#
public ObservableItemPropertyChangedArgs(
   string strProperty
)
Managed Extensions for C++
public: ObservableItemPropertyChangedArgs(
   string* strProperty
)
C++/CLI
public:
ObservableItemPropertyChangedArgs(
   String^ strProperty
)

Parameters

strProperty

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ObservableItemPropertyChangedArgs Class
ObservableItemPropertyChangedArgs Members
Overload List


ObservableItemPropertyChangedArgs Constructor(String,Object)

[image]
Gizmox.WebGUI.Common
ObservableItemPropertyChangedArgs Constructor(String,Object)
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > ObservableItemPropertyChangedArgs Class > ObservableItemPropertyChangedArgs Constructor : ObservableItemPropertyChangedArgs Constructor(String,Object)

strProperty
objSubject

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal strProperty As String, _
   ByVal objSubject As Object _
)
Visual Basic (Usage) Copy Code
Dim strProperty As String
Dim objSubject As Object

Dim instance As ObservableItemPropertyChangedArgs(strProperty, objSubject)
C#
public ObservableItemPropertyChangedArgs(
   string strProperty,
   object objSubject
)
Managed Extensions for C++
public: ObservableItemPropertyChangedArgs(
   string* strProperty,
   Object* objSubject
)
C++/CLI
public:
ObservableItemPropertyChangedArgs(
   String^ strProperty,
   Object^ objSubject
)

Parameters

strProperty
objSubject

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ObservableItemPropertyChangedArgs Class
ObservableItemPropertyChangedArgs Members
Overload List


ObservableItemPropertyChangedArgs Class Properties

[image]
Gizmox.WebGUI.Common
ObservableItemPropertyChangedArgs Class Properties
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : ObservableItemPropertyChangedArgs Class

For a list of all members of this type, see ObservableItemPropertyChangedArgs members.

Public Properties

 | Name | Description
Public Property | Property |
Public Property | Subject |
Top

See Also

Reference

ObservableItemPropertyChangedArgs Class
Gizmox.WebGUI.Common.Interfaces Namespace


Property Property

[image]
Gizmox.WebGUI.Common
Property Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > ObservableItemPropertyChangedArgs Class : Property Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Property As String
Visual Basic (Usage) Copy Code
Dim instance As ObservableItemPropertyChangedArgs
Dim value As String

value = instance.Property
C#
public string Property {get;}
Managed Extensions for C++
public: __property string* get_Property();
C++/CLI
public:
property String^ Property {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ObservableItemPropertyChangedArgs Class
ObservableItemPropertyChangedArgs Members


Subject Property

[image]
Gizmox.WebGUI.Common
Subject Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > ObservableItemPropertyChangedArgs Class : Subject Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Subject As Object
Visual Basic (Usage) Copy Code
Dim instance As ObservableItemPropertyChangedArgs
Dim value As Object

value = instance.Subject
C#
public object Subject {get;}
Managed Extensions for C++
public: __property Object* get_Subject();
C++/CLI
public:
property Object^ Subject {
   Object^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ObservableItemPropertyChangedArgs Class
ObservableItemPropertyChangedArgs Members


ObservableListEventArgs Class

[image]
Gizmox.WebGUI.Common
ObservableListEventArgs Class
Members See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : ObservableListEventArgs Class

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
<BrowsableAttribute(False)>
Public Class ObservableListEventArgs
   Inherits EventArgs
Visual Basic (Usage) Copy Code
Dim instance As ObservableListEventArgs
C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
[BrowsableAttribute(false)]
public class ObservableListEventArgs : EventArgs
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
[BrowsableAttribute(false)]
public __gc class ObservableListEventArgs : public EventArgs
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
[BrowsableAttribute(false)]
public ref class ObservableListEventArgs : public EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gizmox.WebGUI.Common.Interfaces.ObservableListEventArgs

Requirements

Namespace: Gizmox.WebGUI.Common.Interfaces

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

ObservableListEventArgs Members
Gizmox.WebGUI.Common.Interfaces Namespace


ObservableListEventArgs Class Members

[image]
Gizmox.WebGUI.Common
ObservableListEventArgs Class Members
See Also Properties Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : ObservableListEventArgs Class

The following tables list the members exposed by ObservableListEventArgs.

Public Constructors

 | Name | Description
Public Constructor | ObservableListEventArgs Constructor |
Top

Public Properties

 | Name | Description
Public Property | Item |
Top

See Also

Reference

ObservableListEventArgs Class
Gizmox.WebGUI.Common.Interfaces Namespace


ObservableListEventArgs Constructor

[image]
Gizmox.WebGUI.Common
ObservableListEventArgs Constructor
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > ObservableListEventArgs Class : ObservableListEventArgs Constructor

objItem

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal objItem As Object _
)
Visual Basic (Usage) Copy Code
Dim objItem As Object

Dim instance As ObservableListEventArgs(objItem)
C#
public ObservableListEventArgs(
   object objItem
)
Managed Extensions for C++
public: ObservableListEventArgs(
   Object* objItem
)
C++/CLI
public:
ObservableListEventArgs(
   Object^ objItem
)

Parameters

objItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ObservableListEventArgs Class
ObservableListEventArgs Members


ObservableListEventArgs Class Properties

[image]
Gizmox.WebGUI.Common
ObservableListEventArgs Class Properties
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : ObservableListEventArgs Class

For a list of all members of this type, see ObservableListEventArgs members.

Public Properties

 | Name | Description
Public Property | Item |
Top

See Also

Reference

ObservableListEventArgs Class
Gizmox.WebGUI.Common.Interfaces Namespace


Item Property

[image]
Gizmox.WebGUI.Common
Item Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > ObservableListEventArgs Class : Item Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Item As Object
Visual Basic (Usage) Copy Code
Dim instance As ObservableListEventArgs
Dim value As Object

value = instance.Item
C#
public object Item {get;}
Managed Extensions for C++
public: __property Object* get_Item();
C++/CLI
public:
property Object^ Item {
   Object^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ObservableListEventArgs Class
ObservableListEventArgs Members


ObservableResumeLayoutArgs Class

[image]
Gizmox.WebGUI.Common
ObservableResumeLayoutArgs Class
Members See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : ObservableResumeLayoutArgs Class

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Class ObservableResumeLayoutArgs
   Inherits EventArgs
Visual Basic (Usage) Copy Code
Dim instance As ObservableResumeLayoutArgs
C#
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public class ObservableResumeLayoutArgs : EventArgs
Managed Extensions for C++
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public __gc class ObservableResumeLayoutArgs : public EventArgs
C++/CLI
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public ref class ObservableResumeLayoutArgs : public EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gizmox.WebGUI.Common.Interfaces.ObservableResumeLayoutArgs

Requirements

Namespace: Gizmox.WebGUI.Common.Interfaces

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

ObservableResumeLayoutArgs Members
Gizmox.WebGUI.Common.Interfaces Namespace


ObservableResumeLayoutArgs Class Members

[image]
Gizmox.WebGUI.Common
ObservableResumeLayoutArgs Class Members
See Also Properties Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : ObservableResumeLayoutArgs Class

The following tables list the members exposed by ObservableResumeLayoutArgs.

Public Constructors

 | Name | Description
Public Constructor | ObservableResumeLayoutArgs Constructor |
Top

Public Properties

 | Name | Description
Public Property | PerformLayout |
Top

See Also

Reference

ObservableResumeLayoutArgs Class
Gizmox.WebGUI.Common.Interfaces Namespace


ObservableResumeLayoutArgs Constructor

[image]
Gizmox.WebGUI.Common
ObservableResumeLayoutArgs Constructor
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > ObservableResumeLayoutArgs Class : ObservableResumeLayoutArgs Constructor

blnPerformLayout

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal blnPerformLayout As Boolean _
)
Visual Basic (Usage) Copy Code
Dim blnPerformLayout As Boolean

Dim instance As ObservableResumeLayoutArgs(blnPerformLayout)
C#
public ObservableResumeLayoutArgs(
   bool blnPerformLayout
)
Managed Extensions for C++
public: ObservableResumeLayoutArgs(
   bool blnPerformLayout
)
C++/CLI
public:
ObservableResumeLayoutArgs(
   bool blnPerformLayout
)

Parameters

blnPerformLayout

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ObservableResumeLayoutArgs Class
ObservableResumeLayoutArgs Members


ObservableResumeLayoutArgs Class Properties

[image]
Gizmox.WebGUI.Common
ObservableResumeLayoutArgs Class Properties
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : ObservableResumeLayoutArgs Class

For a list of all members of this type, see ObservableResumeLayoutArgs members.

Public Properties

 | Name | Description
Public Property | PerformLayout |
Top

See Also

Reference

ObservableResumeLayoutArgs Class
Gizmox.WebGUI.Common.Interfaces Namespace


PerformLayout Property

[image]
Gizmox.WebGUI.Common
PerformLayout Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > ObservableResumeLayoutArgs Class : PerformLayout Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PerformLayout As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ObservableResumeLayoutArgs
Dim value As Boolean

value = instance.PerformLayout
C#
public bool PerformLayout {get;}
Managed Extensions for C++
public: __property bool get_PerformLayout();
C++/CLI
public:
property bool PerformLayout {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ObservableResumeLayoutArgs Class
ObservableResumeLayoutArgs Members


InvokationUniqueness Enumeration

[image]
Gizmox.WebGUI.Common
InvokationUniqueness Enumeration
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : InvokationUniqueness Enumeration

Syntax

Visual Basic (Declaration)
Public Enum InvokationUniqueness
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As InvokationUniqueness
C#
public enum InvokationUniqueness : Enum
Managed Extensions for C++
__value public enum InvokationUniqueness : public Enum
C++/CLI
public enum class InvokationUniqueness : public Enum

Members

Member | Description
None |
Component |
Global |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Common.Interfaces.InvokationUniqueness

Requirements

Namespace: Gizmox.WebGUI.Common.Interfaces

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

Gizmox.WebGUI.Common.Interfaces Namespace


MashupType Enumeration

[image]
Gizmox.WebGUI.Common
MashupType Enumeration
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : MashupType Enumeration

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Enum MashupType
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As MashupType
C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public enum MashupType : Enum
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
__value public enum MashupType : public Enum
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public enum class MashupType : public Enum

Members

Member | Description
None |
ModalDialog |
ModalessDialog |
Frame |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Common.Interfaces.MashupType

Requirements

Namespace: Gizmox.WebGUI.Common.Interfaces

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

Gizmox.WebGUI.Common.Interfaces Namespace


RequestType Enumeration

[image]
Gizmox.WebGUI.Common
RequestType Enumeration
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : RequestType Enumeration

Syntax

Visual Basic (Declaration)
Public Enum RequestType
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As RequestType
C#
public enum RequestType : Enum
Managed Extensions for C++
__value public enum RequestType : public Enum
C++/CLI
public enum class RequestType : public Enum

Members

Member | Description
Unknown |
Content |
Icons |
Types |
Resources |
Images |
Skins |
Statistics |
Gateway |
Menus |
Data |
Post |
Preload |
Capture |
Replay |
Assemblies |
StaticGateway |
Mashup |
Manifest |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Common.Interfaces.RequestType

Requirements

Namespace: Gizmox.WebGUI.Common.Interfaces

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

Gizmox.WebGUI.Common.Interfaces Namespace


IApplication Interface

[image]
Gizmox.WebGUI.Common
IApplication Interface
Members See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IApplication Interface

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Interface IApplication
   Inherits INonSerializable
Visual Basic (Usage) Copy Code
Dim instance As IApplication
C#
[DefaultMemberAttribute("Item")]
public interface IApplication : INonSerializable
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
public __gc __interface IApplication : public INonSerializable
C++/CLI
[DefaultMemberAttribute("Item")]
public interface class IApplication : public INonSerializable

Requirements

Namespace: Gizmox.WebGUI.Common.Interfaces

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

IApplication Members
Gizmox.WebGUI.Common.Interfaces Namespace


IApplication Interface Members

[image]
Gizmox.WebGUI.Common
IApplication Interface Members
See Also Properties Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IApplication Interface

The following tables list the members exposed by IApplication.

Public Properties

 | Name | Description
Property | Item | Overloaded.
Top

See Also

Reference

IApplication Interface
Gizmox.WebGUI.Common.Interfaces Namespace


IApplication Interface Properties

[image]
Gizmox.WebGUI.Common
IApplication Interface Properties
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IApplication Interface

For a list of all members of this type, see IApplication members.

Public Properties

 | Name | Description
Property | Item | Overloaded.
Top

See Also

Reference

IApplication Interface
Gizmox.WebGUI.Common.Interfaces Namespace


Item Property

[image]
Gizmox.WebGUI.Common
Item Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IApplication Interface : Item Property

Overload List

Overload | Description
Item(String) |
Item(Int32) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IApplication Interface
IApplication Members


Item(String) Property

[image]
Gizmox.WebGUI.Common
Item(String) Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IApplication Interface > Item Property : Item(String) Property

strName

Syntax

Visual Basic (Declaration)
Overloads Property Item( _
   ByVal strName As String _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As IApplication
Dim strName As String
Dim value As Object

instance.Item(strName) = value

value = instance.Item(strName)
C#
object Item(
   string strName
) {get; set;}
Managed Extensions for C++
__property Object* get_Item(
   string* strName
);
__property void set_Item(
   string* strName,
   Object* value
);
C++/CLI
property Object^ Item {
   Object^ get(String^strName);
   void set (String^strName, Object^value);
}

Parameters

strName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IApplication Interface
IApplication Members
Overload List


Item(Int32) Property

[image]
Gizmox.WebGUI.Common
Item(Int32) Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IApplication Interface > Item Property : Item(Int32) Property

intIndex

Syntax

Visual Basic (Declaration)
Overloads ReadOnly Property Item( _
   ByVal intIndex As Integer _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As IApplication
Dim intIndex As Integer
Dim value As Object

value = instance.Item(intIndex)
C#
object Item(
   int intIndex
) {get;}
Managed Extensions for C++
__property Object* get_Item(
   int intIndex
);
C++/CLI
property Object^ Item {
   Object^ get(intintIndex);
}

Parameters

intIndex

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IApplication Interface
IApplication Members
Overload List


IApplicationContext Interface

[image]
Gizmox.WebGUI.Common
IApplicationContext Interface
Members See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IApplicationContext Interface

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Interface IApplicationContext
Visual Basic (Usage) Copy Code
Dim instance As IApplicationContext
C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public interface IApplicationContext
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public __gc __interface IApplicationContext
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public interface class IApplicationContext

Requirements

Namespace: Gizmox.WebGUI.Common.Interfaces

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

IApplicationContext Members
Gizmox.WebGUI.Common.Interfaces Namespace


IApplicationContext Interface Members

[image]
Gizmox.WebGUI.Common
IApplicationContext Interface Members
See Also Methods Events Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IApplicationContext Interface

The following tables list the members exposed by IApplicationContext.

Public Methods

 | Name | Description
Method | GetFocused |
Method | HandleThreadException |
Method | IsFocused |
Method | OnThreadException |
Method | SendThreadMessage |
Method | SetFocused |
Method | SetThreadBookmark |
Method | SetUnhandledExceptionMode |
Top

Public Events

 | Name | Description
Event | ApplicationExit |
Event | EnterThreadModal |
Event | Idle |
Event | LeaveThreadModal |
Event | ThreadBookmarkNavigate |
Event | ThreadException |
Event | ThreadExit |
Event | ThreadMessage |
Event | ThreadRefresh |
Event | ThreadSuspend |
Event | ThreadTick |
Top

See Also

Reference

IApplicationContext Interface
Gizmox.WebGUI.Common.Interfaces Namespace


IApplicationContext Interface Methods

[image]
Gizmox.WebGUI.Common
IApplicationContext Interface Methods
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IApplicationContext Interface

For a list of all members of this type, see IApplicationContext members.

Public Methods

 | Name | Description
Method | GetFocused |
Method | HandleThreadException |
Method | IsFocused |
Method | OnThreadException |
Method | SendThreadMessage |
Method | SetFocused |
Method | SetThreadBookmark |
Method | SetUnhandledExceptionMode |
Top

See Also

Reference

IApplicationContext Interface
Gizmox.WebGUI.Common.Interfaces Namespace


GetFocused Method

[image]
Gizmox.WebGUI.Common
GetFocused Method
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IApplicationContext Interface : GetFocused Method

Syntax

Visual Basic (Declaration)
Function GetFocused() As IControl
Visual Basic (Usage) Copy Code
Dim instance As IApplicationContext
Dim value As IControl

value = instance.GetFocused()
C#
IControl GetFocused()
Managed Extensions for C++
IControl* GetFocused();
C++/CLI
IControl^ GetFocused();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IApplicationContext Interface
IApplicationContext Members


HandleThreadException Method

[image]
Gizmox.WebGUI.Common
HandleThreadException Method
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IApplicationContext Interface : HandleThreadException Method

objThreadException

Syntax

Visual Basic (Declaration)
Function HandleThreadException( _
   ByVal objThreadException As Exception _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As IApplicationContext
Dim objThreadException As Exception
Dim value As Boolean

value = instance.HandleThreadException(objThreadException)
C#
bool HandleThreadException(
   Exception objThreadException
)
Managed Extensions for C++
bool HandleThreadException(
   Exception* objThreadException
)
C++/CLI
bool HandleThreadException(
   Exception^ objThreadException
)

Parameters

objThreadException

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IApplicationContext Interface
IApplicationContext Members


IsFocused Method

[image]
Gizmox.WebGUI.Common
IsFocused Method
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IApplicationContext Interface : IsFocused Method

objControl

Syntax

Visual Basic (Declaration)
Function IsFocused( _
   ByVal objControl As IControl _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As IApplicationContext
Dim objControl As IControl
Dim value As Boolean

value = instance.IsFocused(objControl)
C#
bool IsFocused(
   IControl objControl
)
Managed Extensions for C++
bool IsFocused(
   IControl* objControl
)
C++/CLI
bool IsFocused(
   IControl^ objControl
)

Parameters

objControl

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IApplicationContext Interface
IApplicationContext Members


OnThreadException Method

[image]
Gizmox.WebGUI.Common
OnThreadException Method
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IApplicationContext Interface : OnThreadException Method

objThreadException

Syntax

Visual Basic (Declaration)
Sub OnThreadException( _
   ByVal objThreadException As Exception _
)
Visual Basic (Usage) Copy Code
Dim instance As IApplicationContext
Dim objThreadException As Exception

instance.OnThreadException(objThreadException)
C#
void OnThreadException(
   Exception objThreadException
)
Managed Extensions for C++
void OnThreadException(
   Exception* objThreadException
)
C++/CLI
void OnThreadException(
   Exception^ objThreadException
)

Parameters

objThreadException

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IApplicationContext Interface
IApplicationContext Members


SendThreadMessage Method

[image]
Gizmox.WebGUI.Common
SendThreadMessage Method
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IApplicationContext Interface : SendThreadMessage Method

objThreadMessage

Syntax

Visual Basic (Declaration)
Sub SendThreadMessage( _
   ByVal objThreadMessage As ThreadMessage _
)
Visual Basic (Usage) Copy Code
Dim instance As IApplicationContext
Dim objThreadMessage As ThreadMessage

instance.SendThreadMessage(objThreadMessage)
C#
void SendThreadMessage(
   ThreadMessage objThreadMessage
)
Managed Extensions for C++
void SendThreadMessage(
   ThreadMessage* objThreadMessage
)
C++/CLI
void SendThreadMessage(
   ThreadMessage^ objThreadMessage
)

Parameters

objThreadMessage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IApplicationContext Interface
IApplicationContext Members


SetFocused Method

[image]
Gizmox.WebGUI.Common
SetFocused Method
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IApplicationContext Interface : SetFocused Method

objControl

Syntax

Visual Basic (Declaration)
Sub SetFocused( _
   ByVal objControl As IControl _
)
Visual Basic (Usage) Copy Code
Dim instance As IApplicationContext
Dim objControl As IControl

instance.SetFocused(objControl)
C#
void SetFocused(
   IControl objControl
)
Managed Extensions for C++
void SetFocused(
   IControl* objControl
)
C++/CLI
void SetFocused(
   IControl^ objControl
)

Parameters

objControl

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IApplicationContext Interface
IApplicationContext Members


SetThreadBookmark Method

[image]
Gizmox.WebGUI.Common
SetThreadBookmark Method
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IApplicationContext Interface : SetThreadBookmark Method

objData
strTitle

Syntax

Visual Basic (Declaration)
Sub SetThreadBookmark( _
   ByVal objData As Object, _
   ByVal strTitle As String _
)
Visual Basic (Usage) Copy Code
Dim instance As IApplicationContext
Dim objData As Object
Dim strTitle As String

instance.SetThreadBookmark(objData, strTitle)
C#
void SetThreadBookmark(
   object objData,
   string strTitle
)
Managed Extensions for C++
void SetThreadBookmark(
   Object* objData,
   string* strTitle
)
C++/CLI
void SetThreadBookmark(
   Object^ objData,
   String^ strTitle
)

Parameters

objData
strTitle

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IApplicationContext Interface
IApplicationContext Members


SetUnhandledExceptionMode Method

[image]
Gizmox.WebGUI.Common
SetUnhandledExceptionMode Method
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IApplicationContext Interface : SetUnhandledExceptionMode Method

enmMode
blnThreadScope

Syntax

Visual Basic (Declaration)
Sub SetUnhandledExceptionMode( _
   ByVal enmMode As UnhandledExceptionMode, _
   ByVal blnThreadScope As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As IApplicationContext
Dim enmMode As UnhandledExceptionMode
Dim blnThreadScope As Boolean

instance.SetUnhandledExceptionMode(enmMode, blnThreadScope)
C#
void SetUnhandledExceptionMode(
   UnhandledExceptionMode enmMode,
   bool blnThreadScope
)
Managed Extensions for C++
void SetUnhandledExceptionMode(
   UnhandledExceptionMode enmMode,
   bool blnThreadScope
)
C++/CLI
void SetUnhandledExceptionMode(
   UnhandledExceptionMode enmMode,
   bool blnThreadScope
)

Parameters

enmMode
blnThreadScope

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IApplicationContext Interface
IApplicationContext Members


IApplicationContext Interface Events

[image]
Gizmox.WebGUI.Common
IApplicationContext Interface Events
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IApplicationContext Interface

For a list of all members of this type, see IApplicationContext members.

Public Events

 | Name | Description
Event | ApplicationExit |
Event | EnterThreadModal |
Event | Idle |
Event | LeaveThreadModal |
Event | ThreadBookmarkNavigate |
Event | ThreadException |
Event | ThreadExit |
Event | ThreadMessage |
Event | ThreadRefresh |
Event | ThreadSuspend |
Event | ThreadTick |
Top

See Also

Reference

IApplicationContext Interface
Gizmox.WebGUI.Common.Interfaces Namespace


ApplicationExit Event

[image]
Gizmox.WebGUI.Common
ApplicationExit Event
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IApplicationContext Interface : ApplicationExit Event

Syntax

Visual Basic (Declaration)
Event ApplicationExit() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As IApplicationContext
Dim handler As EventHandler

AddHandler instance.ApplicationExit, handler
C#
event EventHandler ApplicationExit()
Managed Extensions for C++
__event EventHandler* ApplicationExit
C++/CLI
event EventHandler^ ApplicationExit

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IApplicationContext Interface
IApplicationContext Members


EnterThreadModal Event

[image]
Gizmox.WebGUI.Common
EnterThreadModal Event
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IApplicationContext Interface : EnterThreadModal Event

Syntax

Visual Basic (Declaration)
Event EnterThreadModal() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As IApplicationContext
Dim handler As EventHandler

AddHandler instance.EnterThreadModal, handler
C#
event EventHandler EnterThreadModal()
Managed Extensions for C++
__event EventHandler* EnterThreadModal
C++/CLI
event EventHandler^ EnterThreadModal

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IApplicationContext Interface
IApplicationContext Members


Idle Event

[image]
Gizmox.WebGUI.Common
Idle Event
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IApplicationContext Interface : Idle Event

Syntax

Visual Basic (Declaration)
Event Idle() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As IApplicationContext
Dim handler As EventHandler

AddHandler instance.Idle, handler
C#
event EventHandler Idle()
Managed Extensions for C++
__event EventHandler* Idle
C++/CLI
event EventHandler^ Idle

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IApplicationContext Interface
IApplicationContext Members


LeaveThreadModal Event

[image]
Gizmox.WebGUI.Common
LeaveThreadModal Event
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IApplicationContext Interface : LeaveThreadModal Event

Syntax

Visual Basic (Declaration)
Event LeaveThreadModal() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As IApplicationContext
Dim handler As EventHandler

AddHandler instance.LeaveThreadModal, handler
C#
event EventHandler LeaveThreadModal()
Managed Extensions for C++
__event EventHandler* LeaveThreadModal
C++/CLI
event EventHandler^ LeaveThreadModal

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IApplicationContext Interface
IApplicationContext Members


ThreadBookmarkNavigate Event

[image]
Gizmox.WebGUI.Common
ThreadBookmarkNavigate Event
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IApplicationContext Interface : ThreadBookmarkNavigate Event

Syntax

Visual Basic (Declaration)
Event ThreadBookmarkNavigate() As ThreadBookmarkEventHandler
Visual Basic (Usage) Copy Code
Dim instance As IApplicationContext
Dim handler As ThreadBookmarkEventHandler

AddHandler instance.ThreadBookmarkNavigate, handler
C#
event ThreadBookmarkEventHandler ThreadBookmarkNavigate()
Managed Extensions for C++
__event ThreadBookmarkEventHandler* ThreadBookmarkNavigate
C++/CLI
event ThreadBookmarkEventHandler^ ThreadBookmarkNavigate

Event Data

The event handler receives an argument of type ThreadBookmarkEventArgs containing data related to this event. The following ThreadBookmarkEventArgs properties provide information specific to this event.

Property | Description
Data |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IApplicationContext Interface
IApplicationContext Members


ThreadException Event

[image]
Gizmox.WebGUI.Common
ThreadException Event
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IApplicationContext Interface : ThreadException Event

Syntax

Visual Basic (Declaration)
Event ThreadException() As ThreadExceptionEventHandler
Visual Basic (Usage) Copy Code
Dim instance As IApplicationContext
Dim handler As ThreadExceptionEventHandler

AddHandler instance.ThreadException, handler
C#
event ThreadExceptionEventHandler ThreadException()
Managed Extensions for C++
__event ThreadExceptionEventHandler* ThreadException
C++/CLI
event ThreadExceptionEventHandler^ ThreadException

Event Data

The event handler receives an argument of type ThreadExceptionEventArgs containing data related to this event. The following ThreadExceptionEventArgs properties provide information specific to this event.

Property | Description
Exception |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IApplicationContext Interface
IApplicationContext Members


ThreadExit Event

[image]
Gizmox.WebGUI.Common
ThreadExit Event
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IApplicationContext Interface : ThreadExit Event

Syntax

Visual Basic (Declaration)
Event ThreadExit() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As IApplicationContext
Dim handler As EventHandler

AddHandler instance.ThreadExit, handler
C#
event EventHandler ThreadExit()
Managed Extensions for C++
__event EventHandler* ThreadExit
C++/CLI
event EventHandler^ ThreadExit

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IApplicationContext Interface
IApplicationContext Members


ThreadMessage Event

[image]
Gizmox.WebGUI.Common
ThreadMessage Event
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IApplicationContext Interface : ThreadMessage Event

Syntax

Visual Basic (Declaration)
Event ThreadMessage() As ThreadMessageEventHandler
Visual Basic (Usage) Copy Code
Dim instance As IApplicationContext
Dim handler As ThreadMessageEventHandler

AddHandler instance.ThreadMessage, handler
C#
event ThreadMessageEventHandler ThreadMessage()
Managed Extensions for C++
__event ThreadMessageEventHandler* ThreadMessage
C++/CLI
event ThreadMessageEventHandler^ ThreadMessage

Event Data

The event handler receives an argument of type ThreadMessageEventArgs containing data related to this event. The following ThreadMessageEventArgs properties provide information specific to this event.

Property | Description
Message |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IApplicationContext Interface
IApplicationContext Members


ThreadRefresh Event

[image]
Gizmox.WebGUI.Common
ThreadRefresh Event
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IApplicationContext Interface : ThreadRefresh Event

Syntax

Visual Basic (Declaration)
Event ThreadRefresh() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As IApplicationContext
Dim handler As EventHandler

AddHandler instance.ThreadRefresh, handler
C#
event EventHandler ThreadRefresh()
Managed Extensions for C++
__event EventHandler* ThreadRefresh
C++/CLI
event EventHandler^ ThreadRefresh

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IApplicationContext Interface
IApplicationContext Members


ThreadSuspend Event

[image]
Gizmox.WebGUI.Common
ThreadSuspend Event
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IApplicationContext Interface : ThreadSuspend Event

Syntax

Visual Basic (Declaration)
Event ThreadSuspend() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As IApplicationContext
Dim handler As EventHandler

AddHandler instance.ThreadSuspend, handler
C#
event EventHandler ThreadSuspend()
Managed Extensions for C++
__event EventHandler* ThreadSuspend
C++/CLI
event EventHandler^ ThreadSuspend

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IApplicationContext Interface
IApplicationContext Members


ThreadTick Event

[image]
Gizmox.WebGUI.Common
ThreadTick Event
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IApplicationContext Interface : ThreadTick Event

Syntax

Visual Basic (Declaration)
Event ThreadTick() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As IApplicationContext
Dim handler As EventHandler

AddHandler instance.ThreadTick, handler
C#
event EventHandler ThreadTick()
Managed Extensions for C++
__event EventHandler* ThreadTick
C++/CLI
event EventHandler^ ThreadTick

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IApplicationContext Interface
IApplicationContext Members


IArgumentsProvider Interface

[image]
Gizmox.WebGUI.Common
IArgumentsProvider Interface
Members See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IArgumentsProvider Interface

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
<DefaultMemberAttribute("Item")>
Public Interface IArgumentsProvider
Visual Basic (Usage) Copy Code
Dim instance As IArgumentsProvider
C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
[DefaultMemberAttribute("Item")]
public interface IArgumentsProvider
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
[DefaultMemberAttribute("Item")]
public __gc __interface IArgumentsProvider
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
[DefaultMemberAttribute("Item")]
public interface class IArgumentsProvider

Requirements

Namespace: Gizmox.WebGUI.Common.Interfaces

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

IArgumentsProvider Members
Gizmox.WebGUI.Common.Interfaces Namespace


IArgumentsProvider Interface Members

[image]
Gizmox.WebGUI.Common
IArgumentsProvider Interface Members
See Also Properties Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IArgumentsProvider Interface

The following tables list the members exposed by IArgumentsProvider.

Public Properties

 | Name | Description
Property | Item |
Top

See Also

Reference

IArgumentsProvider Interface
Gizmox.WebGUI.Common.Interfaces Namespace


IArgumentsProvider Interface Properties

[image]
Gizmox.WebGUI.Common
IArgumentsProvider Interface Properties
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IArgumentsProvider Interface

For a list of all members of this type, see IArgumentsProvider members.

Public Properties

 | Name | Description
Property | Item |
Top

See Also

Reference

IArgumentsProvider Interface
Gizmox.WebGUI.Common.Interfaces Namespace


Item Property

[image]
Gizmox.WebGUI.Common
Item Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IArgumentsProvider Interface : Item Property

strArgumentName

Syntax

Visual Basic (Declaration)
ReadOnly Default Property Item( _
   ByVal strArgumentName As String _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As IArgumentsProvider
Dim strArgumentName As String
Dim value As Object

value = instance.Item(strArgumentName)
C#
object this[
   string strArgumentName
]; {get;}
Managed Extensions for C++
__property Object* get_Item(
   string* strArgumentName
);
C++/CLI
property Object^ default [String^] {
   Object^ get(String^strArgumentName);
}

Parameters

strArgumentName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IArgumentsProvider Interface
IArgumentsProvider Members


IArgumentsWriterProvider Interface

[image]
Gizmox.WebGUI.Common
IArgumentsWriterProvider Interface
Members See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IArgumentsWriterProvider Interface

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Interface IArgumentsWriterProvider
Visual Basic (Usage) Copy Code
Dim instance As IArgumentsWriterProvider
C#
[DefaultMemberAttribute("Item")]
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public interface IArgumentsWriterProvider
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public __gc __interface IArgumentsWriterProvider
C++/CLI
[DefaultMemberAttribute("Item")]
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public interface class IArgumentsWriterProvider

Requirements

Namespace: Gizmox.WebGUI.Common.Interfaces

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

IArgumentsWriterProvider Members
Gizmox.WebGUI.Common.Interfaces Namespace


IArgumentsWriterProvider Interface Members

[image]
Gizmox.WebGUI.Common
IArgumentsWriterProvider Interface Members
See Also Properties Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IArgumentsWriterProvider Interface

The following tables list the members exposed by IArgumentsWriterProvider.

Public Properties

 | Name | Description
Property | Item |
Top

See Also

Reference

IArgumentsWriterProvider Interface
Gizmox.WebGUI.Common.Interfaces Namespace


IArgumentsWriterProvider Interface Properties

[image]
Gizmox.WebGUI.Common
IArgumentsWriterProvider Interface Properties
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IArgumentsWriterProvider Interface

For a list of all members of this type, see IArgumentsWriterProvider members.

Public Properties

 | Name | Description
Property | Item |
Top

See Also

Reference

IArgumentsWriterProvider Interface
Gizmox.WebGUI.Common.Interfaces Namespace


Item Property

[image]
Gizmox.WebGUI.Common
Item Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IArgumentsWriterProvider Interface : Item Property

strArgumentName

Syntax

Visual Basic (Declaration)
Default Property Item( _
   ByVal strArgumentName As String _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As IArgumentsWriterProvider
Dim strArgumentName As String
Dim value As Object

instance.Item(strArgumentName) = value

value = instance.Item(strArgumentName)
C#
object this[
   string strArgumentName
]; {get; set;}
Managed Extensions for C++
__property Object* get_Item(
   string* strArgumentName
);
__property void set_Item(
   string* strArgumentName,
   Object* value
);
C++/CLI
property Object^ default [String^] {
   Object^ get(String^strArgumentName);
   void set (String^strArgumentName, Object^value);
}

Parameters

strArgumentName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IArgumentsWriterProvider Interface
IArgumentsWriterProvider Members


IAttributeExtender Interface

[image]
Gizmox.WebGUI.Common
IAttributeExtender Interface
Members See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IAttributeExtender Interface

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Interface IAttributeExtender
Visual Basic (Usage) Copy Code
Dim instance As IAttributeExtender
C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public interface IAttributeExtender
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public __gc __interface IAttributeExtender
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public interface class IAttributeExtender

Requirements

Namespace: Gizmox.WebGUI.Common.Interfaces

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

IAttributeExtender Members
Gizmox.WebGUI.Common.Interfaces Namespace


IAttributeExtender Interface Members

[image]
Gizmox.WebGUI.Common
IAttributeExtender Interface Members
See Also Methods Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IAttributeExtender Interface

The following tables list the members exposed by IAttributeExtender.

Public Methods

 | Name | Description
Method | GetAttribute |
Method | RenderAttributes |
Method | RenderUpdatedAttributes |
Method | SetAttribute |
Top

See Also

Reference

IAttributeExtender Interface
Gizmox.WebGUI.Common.Interfaces Namespace


IAttributeExtender Interface Methods

[image]
Gizmox.WebGUI.Common
IAttributeExtender Interface Methods
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IAttributeExtender Interface

For a list of all members of this type, see IAttributeExtender members.

Public Methods

 | Name | Description
Method | GetAttribute |
Method | RenderAttributes |
Method | RenderUpdatedAttributes |
Method | SetAttribute |
Top

See Also

Reference

IAttributeExtender Interface
Gizmox.WebGUI.Common.Interfaces Namespace


GetAttribute Method

[image]
Gizmox.WebGUI.Common
GetAttribute Method
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IAttributeExtender Interface : GetAttribute Method

name

Syntax

Visual Basic (Declaration)
Function GetAttribute( _
   ByVal name As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As IAttributeExtender
Dim name As String
Dim value As String

value = instance.GetAttribute(name)
C#
string GetAttribute(
   string name
)
Managed Extensions for C++
string* GetAttribute(
   string* name
)
C++/CLI
String^ GetAttribute(
   String^ name
)

Parameters

name

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IAttributeExtender Interface
IAttributeExtender Members


RenderAttributes Method

[image]
Gizmox.WebGUI.Common
RenderAttributes Method
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IAttributeExtender Interface : RenderAttributes Method

attributeWriter

Syntax

Visual Basic (Declaration)
Sub RenderAttributes( _
   ByVal attributeWriter As IAttributeWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As IAttributeExtender
Dim attributeWriter As IAttributeWriter

instance.RenderAttributes(attributeWriter)
C#
void RenderAttributes(
   IAttributeWriter attributeWriter
)
Managed Extensions for C++
void RenderAttributes(
   IAttributeWriter* attributeWriter
)
C++/CLI
void RenderAttributes(
   IAttributeWriter^ attributeWriter
)

Parameters

attributeWriter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IAttributeExtender Interface
IAttributeExtender Members


RenderUpdatedAttributes Method

[image]
Gizmox.WebGUI.Common
RenderUpdatedAttributes Method
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IAttributeExtender Interface : RenderUpdatedAttributes Method

objWriter
lngRequestID

Syntax

Visual Basic (Declaration)
Sub RenderUpdatedAttributes( _
   ByVal objWriter As IAttributeWriter, _
   ByVal lngRequestID As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As IAttributeExtender
Dim objWriter As IAttributeWriter
Dim lngRequestID As Long

instance.RenderUpdatedAttributes(objWriter, lngRequestID)
C#
void RenderUpdatedAttributes(
   IAttributeWriter objWriter,
   long lngRequestID
)
Managed Extensions for C++
void RenderUpdatedAttributes(
   IAttributeWriter* objWriter,
   long lngRequestID
)
C++/CLI
void RenderUpdatedAttributes(
   IAttributeWriter^ objWriter,
   long long lngRequestID
)

Parameters

objWriter
lngRequestID

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IAttributeExtender Interface
IAttributeExtender Members


SetAttribute Method

[image]
Gizmox.WebGUI.Common
SetAttribute Method
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IAttributeExtender Interface : SetAttribute Method

name
value

Syntax

Visual Basic (Declaration)
Sub SetAttribute( _
   ByVal name As String, _
   ByVal value As String _
)
Visual Basic (Usage) Copy Code
Dim instance As IAttributeExtender
Dim name As String
Dim value As String

instance.SetAttribute(name, value)
C#
void SetAttribute(
   string name,
   string value
)
Managed Extensions for C++
void SetAttribute(
   string* name,
   string* value
)
C++/CLI
void SetAttribute(
   String^ name,
   String^ value
)

Parameters

name
value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IAttributeExtender Interface
IAttributeExtender Members


IAttributeWriter Interface

[image]
Gizmox.WebGUI.Common
IAttributeWriter Interface
Members See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IAttributeWriter Interface

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Interface IAttributeWriter
   Inherits INonSerializable
Visual Basic (Usage) Copy Code
Dim instance As IAttributeWriter
C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public interface IAttributeWriter : INonSerializable
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public __gc __interface IAttributeWriter : public INonSerializable
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public interface class IAttributeWriter : public INonSerializable

Requirements

Namespace: Gizmox.WebGUI.Common.Interfaces

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

IAttributeWriter Members
Gizmox.WebGUI.Common.Interfaces Namespace


IAttributeWriter Interface Members

[image]
Gizmox.WebGUI.Common
IAttributeWriter Interface Members
See Also Methods Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IAttributeWriter Interface

The following tables list the members exposed by IAttributeWriter.

Public Methods

 | Name | Description
Method | WriteAttributeString | Overloaded.
Top

See Also

Reference

IAttributeWriter Interface
Gizmox.WebGUI.Common.Interfaces Namespace


IAttributeWriter Interface Methods

[image]
Gizmox.WebGUI.Common
IAttributeWriter Interface Methods
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IAttributeWriter Interface

For a list of all members of this type, see IAttributeWriter members.

Public Methods

 | Name | Description
Method | WriteAttributeString | Overloaded.
Top

See Also

Reference

IAttributeWriter Interface
Gizmox.WebGUI.Common.Interfaces Namespace


WriteAttributeString Method

[image]
Gizmox.WebGUI.Common
WriteAttributeString Method
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IAttributeWriter Interface : WriteAttributeString Method

Overload List

Overload | Description
WriteAttributeString(String,String) |
WriteAttributeString(String,Int32) |
WriteAttributeString(String,Boolean) |
WriteAttributeString(String,Double) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IAttributeWriter Interface
IAttributeWriter Members


WriteAttributeString(String,String) Method

[image]
Gizmox.WebGUI.Common
WriteAttributeString(String,String) Method
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IAttributeWriter Interface > WriteAttributeString Method : WriteAttributeString(String,String) Method

strAttribute
strValue

Syntax

Visual Basic (Declaration)
Overloads Sub WriteAttributeString( _
   ByVal strAttribute As String, _
   ByVal strValue As String _
)
Visual Basic (Usage) Copy Code
Dim instance As IAttributeWriter
Dim strAttribute As String
Dim strValue As String

instance.WriteAttributeString(strAttribute, strValue)
C#
void WriteAttributeString(
   string strAttribute,
   string strValue
)
Managed Extensions for C++
void WriteAttributeString(
   string* strAttribute,
   string* strValue
)
C++/CLI
void WriteAttributeString(
   String^ strAttribute,
   String^ strValue
)

Parameters

strAttribute
strValue

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IAttributeWriter Interface
IAttributeWriter Members
Overload List


WriteAttributeString(String,Int32) Method

[image]
Gizmox.WebGUI.Common
WriteAttributeString(String,Int32) Method
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IAttributeWriter Interface > WriteAttributeString Method : WriteAttributeString(String,Int32) Method

strAttribute
intValue

Syntax

Visual Basic (Declaration)
Overloads Sub WriteAttributeString( _
   ByVal strAttribute As String, _
   ByVal intValue As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As IAttributeWriter
Dim strAttribute As String
Dim intValue As Integer

instance.WriteAttributeString(strAttribute, intValue)
C#
void WriteAttributeString(
   string strAttribute,
   int intValue
)
Managed Extensions for C++
void WriteAttributeString(
   string* strAttribute,
   int intValue
)
C++/CLI
void WriteAttributeString(
   String^ strAttribute,
   int intValue
)

Parameters

strAttribute
intValue

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IAttributeWriter Interface
IAttributeWriter Members
Overload List


WriteAttributeString(String,Boolean) Method

[image]
Gizmox.WebGUI.Common
WriteAttributeString(String,Boolean) Method
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IAttributeWriter Interface > WriteAttributeString Method : WriteAttributeString(String,Boolean) Method

strAttribute
blnValue

Syntax

Visual Basic (Declaration)
Overloads Sub WriteAttributeString( _
   ByVal strAttribute As String, _
   ByVal blnValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As IAttributeWriter
Dim strAttribute As String
Dim blnValue As Boolean

instance.WriteAttributeString(strAttribute, blnValue)
C#
void WriteAttributeString(
   string strAttribute,
   bool blnValue
)
Managed Extensions for C++
void WriteAttributeString(
   string* strAttribute,
   bool blnValue
)
C++/CLI
void WriteAttributeString(
   String^ strAttribute,
   bool blnValue
)

Parameters

strAttribute
blnValue

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IAttributeWriter Interface
IAttributeWriter Members
Overload List


WriteAttributeString(String,Double) Method

[image]
Gizmox.WebGUI.Common
WriteAttributeString(String,Double) Method
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IAttributeWriter Interface > WriteAttributeString Method : WriteAttributeString(String,Double) Method

strAttribute
dblValue

Syntax

Visual Basic (Declaration)
Overloads Sub WriteAttributeString( _
   ByVal strAttribute As String, _
   ByVal dblValue As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As IAttributeWriter
Dim strAttribute As String
Dim dblValue As Double

instance.WriteAttributeString(strAttribute, dblValue)
C#
void WriteAttributeString(
   string strAttribute,
   double dblValue
)
Managed Extensions for C++
void WriteAttributeString(
   string* strAttribute,
   double dblValue
)
C++/CLI
void WriteAttributeString(
   String^ strAttribute,
   double dblValue
)

Parameters

strAttribute
dblValue

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IAttributeWriter Interface
IAttributeWriter Members
Overload List


ICommand Interface

[image]
Gizmox.WebGUI.Common
ICommand Interface
Members See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : ICommand Interface

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Interface ICommand
Visual Basic (Usage) Copy Code
Dim instance As ICommand
C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public interface ICommand
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public __gc __interface ICommand
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public interface class ICommand

Requirements

Namespace: Gizmox.WebGUI.Common.Interfaces

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

ICommand Members
Gizmox.WebGUI.Common.Interfaces Namespace


ICommand Interface Members

[image]
Gizmox.WebGUI.Common
ICommand Interface Members
See Also Methods Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : ICommand Interface

The following tables list the members exposed by ICommand.

Public Methods

 | Name | Description
Method | Render |
Top

See Also

Reference

ICommand Interface
Gizmox.WebGUI.Common.Interfaces Namespace


ICommand Interface Methods

[image]
Gizmox.WebGUI.Common
ICommand Interface Methods
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : ICommand Interface

For a list of all members of this type, see ICommand members.

Public Methods

 | Name | Description
Method | Render |
Top

See Also

Reference

ICommand Interface
Gizmox.WebGUI.Common.Interfaces Namespace


Render Method

[image]
Gizmox.WebGUI.Common
Render Method
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > ICommand Interface : Render Method

objContext
objWriter
lngRequestID

Syntax

Visual Basic (Declaration)
Sub Render( _
   ByVal objContext As IContext, _
   ByVal objWriter As IResponseWriter, _
   ByVal lngRequestID As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As ICommand
Dim objContext As IContext
Dim objWriter As IResponseWriter
Dim lngRequestID As Long

instance.Render(objContext, objWriter, lngRequestID)
C#
void Render(
   IContext objContext,
   IResponseWriter objWriter,
   long lngRequestID
)
Managed Extensions for C++
void Render(
   IContext* objContext,
   IResponseWriter* objWriter,
   long lngRequestID
)
C++/CLI
void Render(
   IContext^ objContext,
   IResponseWriter^ objWriter,
   long long lngRequestID
)

Parameters

objContext
objWriter
lngRequestID

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ICommand Interface
ICommand Members


ICommonDialog Interface

[image]
Gizmox.WebGUI.Common
ICommonDialog Interface
Members See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : ICommonDialog Interface

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Interface ICommonDialog
Visual Basic (Usage) Copy Code
Dim instance As ICommonDialog
C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public interface ICommonDialog
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public __gc __interface ICommonDialog
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public interface class ICommonDialog

Requirements

Namespace: Gizmox.WebGUI.Common.Interfaces

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

ICommonDialog Members
Gizmox.WebGUI.Common.Interfaces Namespace


ICommonDialog Interface Members

[image]
Gizmox.WebGUI.Common
ICommonDialog Interface Members
See Also Methods Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : ICommonDialog Interface

The following tables list the members exposed by ICommonDialog.

Public Methods

 | Name | Description
Method | OnApply |
Top

See Also

Reference

ICommonDialog Interface
Gizmox.WebGUI.Common.Interfaces Namespace


ICommonDialog Interface Methods

[image]
Gizmox.WebGUI.Common
ICommonDialog Interface Methods
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : ICommonDialog Interface

For a list of all members of this type, see ICommonDialog members.

Public Methods

 | Name | Description
Method | OnApply |
Top

See Also

Reference

ICommonDialog Interface
Gizmox.WebGUI.Common.Interfaces Namespace


OnApply Method

[image]
Gizmox.WebGUI.Common
OnApply Method
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > ICommonDialog Interface : OnApply Method

Syntax

Visual Basic (Declaration)
Sub OnApply()
Visual Basic (Usage) Copy Code
Dim instance As ICommonDialog

instance.OnApply()
C#
void OnApply()
Managed Extensions for C++
void OnApply();
C++/CLI
void OnApply();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ICommonDialog Interface
ICommonDialog Members


ICommonDialogHandler Interface

[image]
Gizmox.WebGUI.Common
ICommonDialogHandler Interface
Members See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : ICommonDialogHandler Interface

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Interface ICommonDialogHandler
Visual Basic (Usage) Copy Code
Dim instance As ICommonDialogHandler
C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public interface ICommonDialogHandler
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public __gc __interface ICommonDialogHandler
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public interface class ICommonDialogHandler

Requirements

Namespace: Gizmox.WebGUI.Common.Interfaces

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

ICommonDialogHandler Members
Gizmox.WebGUI.Common.Interfaces Namespace


ICommonDialogHandler Interface Members

[image]
Gizmox.WebGUI.Common
ICommonDialogHandler Interface Members
See Also Properties Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : ICommonDialogHandler Interface

The following tables list the members exposed by ICommonDialogHandler.

Public Properties

 | Name | Description
Property | DialogResult |
Property | DirectHandler |
Top

See Also

Reference

ICommonDialogHandler Interface
Gizmox.WebGUI.Common.Interfaces Namespace


ICommonDialogHandler Interface Properties

[image]
Gizmox.WebGUI.Common
ICommonDialogHandler Interface Properties
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : ICommonDialogHandler Interface

For a list of all members of this type, see ICommonDialogHandler members.

Public Properties

 | Name | Description
Property | DialogResult |
Property | DirectHandler |
Top

See Also

Reference

ICommonDialogHandler Interface
Gizmox.WebGUI.Common.Interfaces Namespace


DialogResult Property

[image]
Gizmox.WebGUI.Common
DialogResult Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > ICommonDialogHandler Interface : DialogResult Property

Syntax

Visual Basic (Declaration)
ReadOnly Property DialogResult As DialogResult
Visual Basic (Usage) Copy Code
Dim instance As ICommonDialogHandler
Dim value As DialogResult

value = instance.DialogResult
C#
DialogResult DialogResult {get;}
Managed Extensions for C++
__property DialogResult get_DialogResult();
C++/CLI
property DialogResult DialogResult {
   DialogResult get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ICommonDialogHandler Interface
ICommonDialogHandler Members


DirectHandler Property

[image]
Gizmox.WebGUI.Common
DirectHandler Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > ICommonDialogHandler Interface : DirectHandler Property

Syntax

Visual Basic (Declaration)
ReadOnly Property DirectHandler As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As ICommonDialogHandler
Dim value As EventHandler

value = instance.DirectHandler
C#
EventHandler DirectHandler {get;}
Managed Extensions for C++
__property EventHandler* get_DirectHandler();
C++/CLI
property EventHandler^ DirectHandler {
   EventHandler^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ICommonDialogHandler Interface
ICommonDialogHandler Members


IContext Interface

[image]
Gizmox.WebGUI.Common
IContext Interface
Members See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IContext Interface

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Interface IContext
   Inherits INonSerializable
Visual Basic (Usage) Copy Code
Dim instance As IContext
C#
[DefaultMemberAttribute("Item")]
public interface IContext : INonSerializable
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
public __gc __interface IContext : public INonSerializable
C++/CLI
[DefaultMemberAttribute("Item")]
public interface class IContext : public INonSerializable

Requirements

Namespace: Gizmox.WebGUI.Common.Interfaces

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

IContext Members
Gizmox.WebGUI.Common.Interfaces Namespace


IContext Interface Members

[image]
Gizmox.WebGUI.Common
IContext Interface Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IContext Interface

The following tables list the members exposed by IContext.

Public Properties

 | Name | Description
Property | ActiveForm |
Property | Application |
Property | Arguments |
Property | Config |
Property | Cookies |
Property | CurrentTheme |
Property | CurrentUICulture |
Property | ExecutionMode |
Property | HttpContext |
Property | Item |
Property | MainForm |
Property | Referrer |
Property | Request |
Property | Response |
Property | Results |
Property | RightToLeft |
Property | Server |
Property | Session |
Top

Public Methods

 | Name | Description
Method | OpenLink | Overloaded.
Method | Redirect |
Method | Terminate |
Method | Transfer |
Top

See Also

Reference

IContext Interface
Gizmox.WebGUI.Common.Interfaces Namespace


IContext Interface Methods

[image]
Gizmox.WebGUI.Common
IContext Interface Methods
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IContext Interface

For a list of all members of this type, see IContext members.

Public Methods

 | Name | Description
Method | OpenLink | Overloaded.
Method | Redirect |
Method | Terminate |
Method | Transfer |
Top

See Also

Reference

IContext Interface
Gizmox.WebGUI.Common.Interfaces Namespace


OpenLink Method

[image]
Gizmox.WebGUI.Common
OpenLink Method
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IContext Interface : OpenLink Method

Overload List

Overload | Description
OpenLink(ILink) |
OpenLink(ILink,ILinkParameters) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IContext Interface
IContext Members


OpenLink(ILink) Method

[image]
Gizmox.WebGUI.Common
OpenLink(ILink) Method
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IContext Interface > OpenLink Method : OpenLink(ILink) Method

objLink

Syntax

Visual Basic (Declaration)
Overloads Sub OpenLink( _
   ByVal objLink As ILink _
)
Visual Basic (Usage) Copy Code
Dim instance As IContext
Dim objLink As ILink

instance.OpenLink(objLink)
C#
void OpenLink(
   ILink objLink
)
Managed Extensions for C++
void OpenLink(
   ILink* objLink
)
C++/CLI
void OpenLink(
   ILink^ objLink
)

Parameters

objLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IContext Interface
IContext Members
Overload List


OpenLink(ILink,ILinkParameters) Method

[image]
Gizmox.WebGUI.Common
OpenLink(ILink,ILinkParameters) Method
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IContext Interface > OpenLink Method : OpenLink(ILink,ILinkParameters) Method

objLink
objLinkParameters

Syntax

Visual Basic (Declaration)
Overloads Sub OpenLink( _
   ByVal objLink As ILink, _
   ByVal objLinkParameters As ILinkParameters _
)
Visual Basic (Usage) Copy Code
Dim instance As IContext
Dim objLink As ILink
Dim objLinkParameters As ILinkParameters

instance.OpenLink(objLink, objLinkParameters)
C#
void OpenLink(
   ILink objLink,
   ILinkParameters objLinkParameters
)
Managed Extensions for C++
void OpenLink(
   ILink* objLink,
   ILinkParameters* objLinkParameters
)
C++/CLI
void OpenLink(
   ILink^ objLink,
   ILinkParameters^ objLinkParameters
)

Parameters

objLink
objLinkParameters

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IContext Interface
IContext Members
Overload List


Redirect Method

[image]
Gizmox.WebGUI.Common
Redirect Method
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IContext Interface : Redirect Method

url

Syntax

Visual Basic (Declaration)
Sub Redirect( _
   ByVal url As String _
)
Visual Basic (Usage) Copy Code
Dim instance As IContext
Dim url As String

instance.Redirect(url)
C#
void Redirect(
   string url
)
Managed Extensions for C++
void Redirect(
   string* url
)
C++/CLI
void Redirect(
   String^ url
)

Parameters

url

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IContext Interface
IContext Members


Terminate Method

[image]
Gizmox.WebGUI.Common
Terminate Method
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IContext Interface : Terminate Method

blnLogOff

Syntax

Visual Basic (Declaration)
Sub Terminate( _
   ByVal blnLogOff As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As IContext
Dim blnLogOff As Boolean

instance.Terminate(blnLogOff)
C#
void Terminate(
   bool blnLogOff
)
Managed Extensions for C++
void Terminate(
   bool blnLogOff
)
C++/CLI
void Terminate(
   bool blnLogOff
)

Parameters

blnLogOff

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IContext Interface
IContext Members


Transfer Method

[image]
Gizmox.WebGUI.Common
Transfer Method
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IContext Interface : Transfer Method

objForm

Syntax

Visual Basic (Declaration)
Sub Transfer( _
   ByVal objForm As IForm _
)
Visual Basic (Usage) Copy Code
Dim instance As IContext
Dim objForm As IForm

instance.Transfer(objForm)
C#
void Transfer(
   IForm objForm
)
Managed Extensions for C++
void Transfer(
   IForm* objForm
)
C++/CLI
void Transfer(
   IForm^ objForm
)

Parameters

objForm

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IContext Interface
IContext Members


IContext Interface Properties

[image]
Gizmox.WebGUI.Common
IContext Interface Properties
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IContext Interface

For a list of all members of this type, see IContext members.

Public Properties

 | Name | Description
Property | ActiveForm |
Property | Application |
Property | Arguments |
Property | Config |
Property | Cookies |
Property | CurrentTheme |
Property | CurrentUICulture |
Property | ExecutionMode |
Property | HttpContext |
Property | Item |
Property | MainForm |
Property | Referrer |
Property | Request |
Property | Response |
Property | Results |
Property | RightToLeft |
Property | Server |
Property | Session |
Top

See Also

Reference

IContext Interface
Gizmox.WebGUI.Common.Interfaces Namespace


ActiveForm Property

[image]
Gizmox.WebGUI.Common
ActiveForm Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IContext Interface : ActiveForm Property

Syntax

Visual Basic (Declaration)
Property ActiveForm As IForm
Visual Basic (Usage) Copy Code
Dim instance As IContext
Dim value As IForm

instance.ActiveForm = value

value = instance.ActiveForm
C#
IForm ActiveForm {get; set;}
Managed Extensions for C++
__property IForm* get_ActiveForm();
__property void set_ActiveForm(
   IForm* value
);
C++/CLI
property IForm^ ActiveForm {
   IForm^ get();
   void set (IForm^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IContext Interface
IContext Members


Application Property

[image]
Gizmox.WebGUI.Common
Application Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IContext Interface : Application Property

Syntax

Visual Basic (Declaration)
ReadOnly Property Application As IApplication
Visual Basic (Usage) Copy Code
Dim instance As IContext
Dim value As IApplication

value = instance.Application
C#
IApplication Application {get;}
Managed Extensions for C++
__property IApplication* get_Application();
C++/CLI
property IApplication^ Application {
   IApplication^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IContext Interface
IContext Members


Arguments Property

[image]
Gizmox.WebGUI.Common
Arguments Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IContext Interface : Arguments Property

Syntax

Visual Basic (Declaration)
Property Arguments As IArgumentsProvider
Visual Basic (Usage) Copy Code
Dim instance As IContext
Dim value As IArgumentsProvider

instance.Arguments = value

value = instance.Arguments
C#
IArgumentsProvider Arguments {get; set;}
Managed Extensions for C++
__property IArgumentsProvider* get_Arguments();
__property void set_Arguments(
   IArgumentsProvider* value
);
C++/CLI
property IArgumentsProvider^ Arguments {
   IArgumentsProvider^ get();
   void set (IArgumentsProvider^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IContext Interface
IContext Members


Config Property

[image]
Gizmox.WebGUI.Common
Config Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IContext Interface : Config Property

Syntax

Visual Basic (Declaration)
ReadOnly Property Config As Config
Visual Basic (Usage) Copy Code
Dim instance As IContext
Dim value As Config

value = instance.Config
C#
Config Config {get;}
Managed Extensions for C++
__property Config* get_Config();
C++/CLI
property Config^ Config {
   Config^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IContext Interface
IContext Members


Cookies Property

[image]
Gizmox.WebGUI.Common
Cookies Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IContext Interface : Cookies Property

Syntax

Visual Basic (Declaration)
ReadOnly Property Cookies As ICookies
Visual Basic (Usage) Copy Code
Dim instance As IContext
Dim value As ICookies

value = instance.Cookies
C#
ICookies Cookies {get;}
Managed Extensions for C++
__property ICookies* get_Cookies();
C++/CLI
property ICookies^ Cookies {
   ICookies^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IContext Interface
IContext Members


CurrentTheme Property

[image]
Gizmox.WebGUI.Common
CurrentTheme Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IContext Interface : CurrentTheme Property

Syntax

Visual Basic (Declaration)
Property CurrentTheme As Theme
Visual Basic (Usage) Copy Code
Dim instance As IContext
Dim value As Theme

instance.CurrentTheme = value

value = instance.CurrentTheme
C#
Theme CurrentTheme {get; set;}
Managed Extensions for C++
__property Theme* get_CurrentTheme();
__property void set_CurrentTheme(
   Theme* value
);
C++/CLI
property Theme^ CurrentTheme {
   Theme^ get();
   void set (Theme^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IContext Interface
IContext Members


CurrentUICulture Property

[image]
Gizmox.WebGUI.Common
CurrentUICulture Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IContext Interface : CurrentUICulture Property

Syntax

Visual Basic (Declaration)
Property CurrentUICulture As CultureInfo
Visual Basic (Usage) Copy Code
Dim instance As IContext
Dim value As CultureInfo

instance.CurrentUICulture = value

value = instance.CurrentUICulture
C#
CultureInfo CurrentUICulture {get; set;}
Managed Extensions for C++
__property CultureInfo* get_CurrentUICulture();
__property void set_CurrentUICulture(
   CultureInfo* value
);
C++/CLI
property CultureInfo^ CurrentUICulture {
   CultureInfo^ get();
   void set (CultureInfo^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IContext Interface
IContext Members


ExecutionMode Property

[image]
Gizmox.WebGUI.Common
ExecutionMode Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IContext Interface : ExecutionMode Property

Syntax

Visual Basic (Declaration)
ReadOnly Property ExecutionMode As ExecutionMode
Visual Basic (Usage) Copy Code
Dim instance As IContext
Dim value As ExecutionMode

value = instance.ExecutionMode
C#
ExecutionMode ExecutionMode {get;}
Managed Extensions for C++
__property ExecutionMode get_ExecutionMode();
C++/CLI
property ExecutionMode ExecutionMode {
   ExecutionMode get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IContext Interface
IContext Members


HttpContext Property

[image]
Gizmox.WebGUI.Common
HttpContext Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IContext Interface : HttpContext Property

Syntax

Visual Basic (Declaration)
ReadOnly Property HttpContext As HttpContext
Visual Basic (Usage) Copy Code
Dim instance As IContext
Dim value As HttpContext

value = instance.HttpContext
C#
HttpContext HttpContext {get;}
Managed Extensions for C++
__property HttpContext* get_HttpContext();
C++/CLI
property HttpContext^ HttpContext {
   HttpContext^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IContext Interface
IContext Members


Item Property

[image]
Gizmox.WebGUI.Common
Item Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IContext Interface : Item Property

strKey

Syntax

Visual Basic (Declaration)
Default Property Item( _
   ByVal strKey As String _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As IContext
Dim strKey As String
Dim value As Object

instance.Item(strKey) = value

value = instance.Item(strKey)
C#
object this[
   string strKey
]; {get; set;}
Managed Extensions for C++
__property Object* get_Item(
   string* strKey
);
__property void set_Item(
   string* strKey,
   Object* value
);
C++/CLI
property Object^ default [String^] {
   Object^ get(String^strKey);
   void set (String^strKey, Object^value);
}

Parameters

strKey

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IContext Interface
IContext Members


MainForm Property

[image]
Gizmox.WebGUI.Common
MainForm Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IContext Interface : MainForm Property

Syntax

Visual Basic (Declaration)
Property MainForm As IForm
Visual Basic (Usage) Copy Code
Dim instance As IContext
Dim value As IForm

instance.MainForm = value

value = instance.MainForm
C#
IForm MainForm {get; set;}
Managed Extensions for C++
__property IForm* get_MainForm();
__property void set_MainForm(
   IForm* value
);
C++/CLI
property IForm^ MainForm {
   IForm^ get();
   void set (IForm^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IContext Interface
IContext Members


Referrer Property

[image]
Gizmox.WebGUI.Common
Referrer Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IContext Interface : Referrer Property

Syntax

Visual Basic (Declaration)
Property Referrer As String
Visual Basic (Usage) Copy Code
Dim instance As IContext
Dim value As String

instance.Referrer = value

value = instance.Referrer
C#
string Referrer {get; set;}
Managed Extensions for C++
__property string* get_Referrer();
__property void set_Referrer(
   string* value
);
C++/CLI
property String^ Referrer {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IContext Interface
IContext Members


Request Property

[image]
Gizmox.WebGUI.Common
Request Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IContext Interface : Request Property

Syntax

Visual Basic (Declaration)
ReadOnly Property Request As IRequest
Visual Basic (Usage) Copy Code
Dim instance As IContext
Dim value As IRequest

value = instance.Request
C#
IRequest Request {get;}
Managed Extensions for C++
__property IRequest* get_Request();
C++/CLI
property IRequest^ Request {
   IRequest^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IContext Interface
IContext Members


Response Property

[image]
Gizmox.WebGUI.Common
Response Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IContext Interface : Response Property

Syntax

Visual Basic (Declaration)
ReadOnly Property Response As IResponse
Visual Basic (Usage) Copy Code
Dim instance As IContext
Dim value As IResponse

value = instance.Response
C#
IResponse Response {get;}
Managed Extensions for C++
__property IResponse* get_Response();
C++/CLI
property IResponse^ Response {
   IResponse^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IContext Interface
IContext Members


Results Property

[image]
Gizmox.WebGUI.Common
Results Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IContext Interface : Results Property

Syntax

Visual Basic (Declaration)
ReadOnly Property Results As IResultsProvider
Visual Basic (Usage) Copy Code
Dim instance As IContext
Dim value As IResultsProvider

value = instance.Results
C#
IResultsProvider Results {get;}
Managed Extensions for C++
__property IResultsProvider* get_Results();
C++/CLI
property IResultsProvider^ Results {
   IResultsProvider^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IContext Interface
IContext Members


RightToLeft Property

[image]
Gizmox.WebGUI.Common
RightToLeft Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IContext Interface : RightToLeft Property

Syntax

Visual Basic (Declaration)
ReadOnly Property RightToLeft As Boolean
Visual Basic (Usage) Copy Code
Dim instance As IContext
Dim value As Boolean

value = instance.RightToLeft
C#
bool RightToLeft {get;}
Managed Extensions for C++
__property bool get_RightToLeft();
C++/CLI
property bool RightToLeft {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IContext Interface
IContext Members


Server Property

[image]
Gizmox.WebGUI.Common
Server Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IContext Interface : Server Property

Syntax

Visual Basic (Declaration)
ReadOnly Property Server As IServer
Visual Basic (Usage) Copy Code
Dim instance As IContext
Dim value As IServer

value = instance.Server
C#
IServer Server {get;}
Managed Extensions for C++
__property IServer* get_Server();
C++/CLI
property IServer^ Server {
   IServer^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IContext Interface
IContext Members


Session Property

[image]
Gizmox.WebGUI.Common
Session Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IContext Interface : Session Property

Syntax

Visual Basic (Declaration)
ReadOnly Property Session As ISession
Visual Basic (Usage) Copy Code
Dim instance As IContext
Dim value As ISession

value = instance.Session
C#
ISession Session {get;}
Managed Extensions for C++
__property ISession* get_Session();
C++/CLI
property ISession^ Session {
   ISession^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IContext Interface
IContext Members


IContextClipboard Interface

[image]
Gizmox.WebGUI.Common
IContextClipboard Interface
Members See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IContextClipboard Interface

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Interface IContextClipboard
Visual Basic (Usage) Copy Code
Dim instance As IContextClipboard
C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public interface IContextClipboard
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public __gc __interface IContextClipboard
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public interface class IContextClipboard

Requirements

Namespace: Gizmox.WebGUI.Common.Interfaces

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

IContextClipboard Members
Gizmox.WebGUI.Common.Interfaces Namespace


IContextClipboard Interface Members

[image]
Gizmox.WebGUI.Common
IContextClipboard Interface Members
See Also Methods Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IContextClipboard Interface

The following tables list the members exposed by IContextClipboard.

Public Methods

 | Name | Description
Method | Clear |
Method | GetDataObject |
Method | SetDataObject |
Top

See Also

Reference

IContextClipboard Interface
Gizmox.WebGUI.Common.Interfaces Namespace


IContextClipboard Interface Methods

[image]
Gizmox.WebGUI.Common
IContextClipboard Interface Methods
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IContextClipboard Interface

For a list of all members of this type, see IContextClipboard members.

Public Methods

 | Name | Description
Method | Clear |
Method | GetDataObject |
Method | SetDataObject |
Top

See Also

Reference

IContextClipboard Interface
Gizmox.WebGUI.Common.Interfaces Namespace


Clear Method

[image]
Gizmox.WebGUI.Common
Clear Method
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IContextClipboard Interface : Clear Method

Syntax

Visual Basic (Declaration)
Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As IContextClipboard

instance.Clear()
C#
void Clear()
Managed Extensions for C++
void Clear();
C++/CLI
void Clear();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IContextClipboard Interface
IContextClipboard Members


GetDataObject Method

[image]
Gizmox.WebGUI.Common
GetDataObject Method
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IContextClipboard Interface : GetDataObject Method

Syntax

Visual Basic (Declaration)
Function GetDataObject() As IDataObject
Visual Basic (Usage) Copy Code
Dim instance As IContextClipboard
Dim value As IDataObject

value = instance.GetDataObject()
C#
IDataObject GetDataObject()
Managed Extensions for C++
IDataObject* GetDataObject();
C++/CLI
IDataObject^ GetDataObject();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IContextClipboard Interface
IContextClipboard Members


SetDataObject Method

[image]
Gizmox.WebGUI.Common
SetDataObject Method
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IContextClipboard Interface : SetDataObject Method

data
copy
retryTimes
retryDelay

Syntax

Visual Basic (Declaration)
Sub SetDataObject( _
   ByVal data As IDataObject, _
   ByVal copy As Boolean, _
   ByVal retryTimes As Integer, _
   ByVal retryDelay As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As IContextClipboard
Dim data As IDataObject
Dim copy As Boolean
Dim retryTimes As Integer
Dim retryDelay As Integer

instance.SetDataObject(data, copy, retryTimes, retryDelay)
C#
void SetDataObject(
   IDataObject data,
   bool copy,
   int retryTimes,
   int retryDelay
)
Managed Extensions for C++
void SetDataObject(
   IDataObject* data,
   bool copy,
   int retryTimes,
   int retryDelay
)
C++/CLI
void SetDataObject(
   IDataObject^ data,
   bool copy,
   int retryTimes,
   int retryDelay
)

Parameters

data
copy
retryTimes
retryDelay

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IContextClipboard Interface
IContextClipboard Members


IContextCommonDialogHandler Interface

[image]
Gizmox.WebGUI.Common
IContextCommonDialogHandler Interface
Members See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IContextCommonDialogHandler Interface

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Interface IContextCommonDialogHandler
Visual Basic (Usage) Copy Code
Dim instance As IContextCommonDialogHandler
C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public interface IContextCommonDialogHandler
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public __gc __interface IContextCommonDialogHandler
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public interface class IContextCommonDialogHandler

Requirements

Namespace: Gizmox.WebGUI.Common.Interfaces

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

IContextCommonDialogHandler Members
Gizmox.WebGUI.Common.Interfaces Namespace


IContextCommonDialogHandler Interface Members

[image]
Gizmox.WebGUI.Common
IContextCommonDialogHandler Interface Members
See Also Methods Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IContextCommonDialogHandler Interface

The following tables list the members exposed by IContextCommonDialogHandler.

Public Methods

 | Name | Description
Method | ShowDialog |
Top

See Also

Reference

IContextCommonDialogHandler Interface
Gizmox.WebGUI.Common.Interfaces Namespace


IContextCommonDialogHandler Interface Methods

[image]
Gizmox.WebGUI.Common
IContextCommonDialogHandler Interface Methods
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IContextCommonDialogHandler Interface

For a list of all members of this type, see IContextCommonDialogHandler members.

Public Methods

 | Name | Description
Method | ShowDialog |
Top

See Also

Reference

IContextCommonDialogHandler Interface
Gizmox.WebGUI.Common.Interfaces Namespace


ShowDialog Method

[image]
Gizmox.WebGUI.Common
ShowDialog Method
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IContextCommonDialogHandler Interface : ShowDialog Method

objCommonDialog
objOwner
objCloseHandler
objDirectHandler

Syntax

Visual Basic (Declaration)
Sub ShowDialog( _
   ByVal objCommonDialog As ICommonDialog, _
   ByVal objOwner As IForm, _
   ByVal objCloseHandler As EventHandler, _
   ByVal objDirectHandler As EventHandler _
)
Visual Basic (Usage) Copy Code
Dim instance As IContextCommonDialogHandler
Dim objCommonDialog As ICommonDialog
Dim objOwner As IForm
Dim objCloseHandler As EventHandler
Dim objDirectHandler As EventHandler

instance.ShowDialog(objCommonDialog, objOwner, objCloseHandler, objDirectHandler)
C#
void ShowDialog(
   ICommonDialog objCommonDialog,
   IForm objOwner,
   EventHandler objCloseHandler,
   EventHandler objDirectHandler
)
Managed Extensions for C++
void ShowDialog(
   ICommonDialog* objCommonDialog,
   IForm* objOwner,
   EventHandler* objCloseHandler,
   EventHandler* objDirectHandler
)
C++/CLI
void ShowDialog(
   ICommonDialog^ objCommonDialog,
   IForm^ objOwner,
   EventHandler^ objCloseHandler,
   EventHandler^ objDirectHandler
)

Parameters

objCommonDialog
objOwner
objCloseHandler
objDirectHandler

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IContextCommonDialogHandler Interface
IContextCommonDialogHandler Members


IContextMenu Interface

[image]
Gizmox.WebGUI.Common
IContextMenu Interface
Members See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IContextMenu Interface

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Interface IContextMenu
Visual Basic (Usage) Copy Code
Dim instance As IContextMenu
C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public interface IContextMenu
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public __gc __interface IContextMenu
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public interface class IContextMenu

Requirements

Namespace: Gizmox.WebGUI.Common.Interfaces

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

IContextMenu Members
Gizmox.WebGUI.Common.Interfaces Namespace


IContextMenu Interface Members

[image]
Gizmox.WebGUI.Common
IContextMenu Interface Members
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IContextMenu Interface

The following tables list the members exposed by IContextMenu.

See Also

Reference

IContextMenu Interface
Gizmox.WebGUI.Common.Interfaces Namespace


IContextMethodInvoker Interface

[image]
Gizmox.WebGUI.Common
IContextMethodInvoker Interface
Members See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IContextMethodInvoker Interface

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Interface IContextMethodInvoker
Visual Basic (Usage) Copy Code
Dim instance As IContextMethodInvoker
C#
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public interface IContextMethodInvoker
Managed Extensions for C++
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public __gc __interface IContextMethodInvoker
C++/CLI
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public interface class IContextMethodInvoker

Requirements

Namespace: Gizmox.WebGUI.Common.Interfaces

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

IContextMethodInvoker Members
Gizmox.WebGUI.Common.Interfaces Namespace


IContextMethodInvoker Interface Members

[image]
Gizmox.WebGUI.Common
IContextMethodInvoker Interface Members
See Also Methods Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IContextMethodInvoker Interface

The following tables list the members exposed by IContextMethodInvoker.

Public Methods

 | Name | Description
Method | GetMethodName |
Method | InvokeMethod |
Method | RenderMehtods |
Top

See Also

Reference

IContextMethodInvoker Interface
Gizmox.WebGUI.Common.Interfaces Namespace


IContextMethodInvoker Interface Methods

[image]
Gizmox.WebGUI.Common
IContextMethodInvoker Interface Methods
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IContextMethodInvoker Interface

For a list of all members of this type, see IContextMethodInvoker members.

Public Methods

 | Name | Description
Method | GetMethodName |
Method | InvokeMethod |
Method | RenderMehtods |
Top

See Also

Reference

IContextMethodInvoker Interface
Gizmox.WebGUI.Common.Interfaces Namespace


GetMethodName Method

[image]
Gizmox.WebGUI.Common
GetMethodName Method
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IContextMethodInvoker Interface : GetMethodName Method

objTarget
strMember

Syntax

Visual Basic (Declaration)
Function GetMethodName( _
   ByVal objTarget As IRegisteredComponent, _
   ByVal strMember As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As IContextMethodInvoker
Dim objTarget As IRegisteredComponent
Dim strMember As String
Dim value As String

value = instance.GetMethodName(objTarget, strMember)
C#
string GetMethodName(
   IRegisteredComponent objTarget,
   string strMember
)
Managed Extensions for C++
string* GetMethodName(
   IRegisteredComponent* objTarget,
   string* strMember
)
C++/CLI
String^ GetMethodName(
   IRegisteredComponent^ objTarget,
   String^ strMember
)

Parameters

objTarget
strMember

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IContextMethodInvoker Interface
IContextMethodInvoker Members


InvokeMethod Method

[image]
Gizmox.WebGUI.Common
InvokeMethod Method
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IContextMethodInvoker Interface : InvokeMethod Method

objTarget
enmUniqueness
strMember
arrArgs

Syntax

Visual Basic (Declaration)
Sub InvokeMethod( _
   ByVal objTarget As IRegisteredComponent, _
   ByVal enmUniqueness As InvokationUniqueness, _
   ByVal strMember As String, _
   ByVal ParamArray arrArgs() As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As IContextMethodInvoker
Dim objTarget As IRegisteredComponent
Dim enmUniqueness As InvokationUniqueness
Dim strMember As String
Dim arrArgs() As Object

instance.InvokeMethod(objTarget, enmUniqueness, strMember, arrArgs)
C#
void InvokeMethod(
   IRegisteredComponent objTarget,
   InvokationUniqueness enmUniqueness,
   string strMember,
   params object[] arrArgs
)
Managed Extensions for C++
void InvokeMethod(
   IRegisteredComponent* objTarget,
   InvokationUniqueness enmUniqueness,
   string* strMember,
   params Object*[]* arrArgs
)
C++/CLI
void InvokeMethod(
   IRegisteredComponent^ objTarget,
   InvokationUniqueness enmUniqueness,
   String^ strMember,
   ... array<Object^>^ arrArgs
)

Parameters

objTarget
enmUniqueness
strMember
arrArgs

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IContextMethodInvoker Interface
IContextMethodInvoker Members


RenderMehtods Method

[image]
Gizmox.WebGUI.Common
RenderMehtods Method
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IContextMethodInvoker Interface : RenderMehtods Method

objWriter
lngRequestID

Syntax

Visual Basic (Declaration)
Sub RenderMehtods( _
   ByVal objWriter As IResponseWriter, _
   ByVal lngRequestID As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As IContextMethodInvoker
Dim objWriter As IResponseWriter
Dim lngRequestID As Long

instance.RenderMehtods(objWriter, lngRequestID)
C#
void RenderMehtods(
   IResponseWriter objWriter,
   long lngRequestID
)
Managed Extensions for C++
void RenderMehtods(
   IResponseWriter* objWriter,
   long lngRequestID
)
C++/CLI
void RenderMehtods(
   IResponseWriter^ objWriter,
   long long lngRequestID
)

Parameters

objWriter
lngRequestID

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IContextMethodInvoker Interface
IContextMethodInvoker Members


IContextParams Interface

[image]
Gizmox.WebGUI.Common
IContextParams Interface
Members See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IContextParams Interface

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
<BrowsableAttribute(False)>
Public Interface IContextParams
Visual Basic (Usage) Copy Code
Dim instance As IContextParams
C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
[BrowsableAttribute(false)]
public interface IContextParams
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
[BrowsableAttribute(false)]
public __gc __interface IContextParams
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
[BrowsableAttribute(false)]
public interface class IContextParams

Requirements

Namespace: Gizmox.WebGUI.Common.Interfaces

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

IContextParams Members
Gizmox.WebGUI.Common.Interfaces Namespace


IContextParams Interface Members

[image]
Gizmox.WebGUI.Common
IContextParams Interface Members
See Also Properties Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IContextParams Interface

The following tables list the members exposed by IContextParams.

Public Properties

 | Name | Description
Property | Browser |
Property | MeasurementGraphics |
Property | ScreenAvailableHeight |
Property | ScreenAvailableWidth |
Property | ScreenColorDepth |
Property | ScreenHeight |
Property | ScreenWidth |
Top

See Also

Reference

IContextParams Interface
Gizmox.WebGUI.Common.Interfaces Namespace


IContextParams Interface Properties

[image]
Gizmox.WebGUI.Common
IContextParams Interface Properties
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IContextParams Interface

For a list of all members of this type, see IContextParams members.

Public Properties

 | Name | Description
Property | Browser |
Property | MeasurementGraphics |
Property | ScreenAvailableHeight |
Property | ScreenAvailableWidth |
Property | ScreenColorDepth |
Property | ScreenHeight |
Property | ScreenWidth |
Top

See Also

Reference

IContextParams Interface
Gizmox.WebGUI.Common.Interfaces Namespace


Browser Property

[image]
Gizmox.WebGUI.Common
Browser Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IContextParams Interface : Browser Property

Syntax

Visual Basic (Declaration)
ReadOnly Property Browser As String
Visual Basic (Usage) Copy Code
Dim instance As IContextParams
Dim value As String

value = instance.Browser
C#
string Browser {get;}
Managed Extensions for C++
__property string* get_Browser();
C++/CLI
property String^ Browser {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IContextParams Interface
IContextParams Members


MeasurementGraphics Property

[image]
Gizmox.WebGUI.Common
MeasurementGraphics Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IContextParams Interface : MeasurementGraphics Property

Syntax

Visual Basic (Declaration)
ReadOnly Property MeasurementGraphics As Graphics
Visual Basic (Usage) Copy Code
Dim instance As IContextParams
Dim value As Graphics

value = instance.MeasurementGraphics
C#
Graphics MeasurementGraphics {get;}
Managed Extensions for C++
__property Graphics* get_MeasurementGraphics();
C++/CLI
property Graphics^ MeasurementGraphics {
   Graphics^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IContextParams Interface
IContextParams Members


ScreenAvailableHeight Property

[image]
Gizmox.WebGUI.Common
ScreenAvailableHeight Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IContextParams Interface : ScreenAvailableHeight Property

Syntax

Visual Basic (Declaration)
ReadOnly Property ScreenAvailableHeight As Integer
Visual Basic (Usage) Copy Code
Dim instance As IContextParams
Dim value As Integer

value = instance.ScreenAvailableHeight
C#
int ScreenAvailableHeight {get;}
Managed Extensions for C++
__property int get_ScreenAvailableHeight();
C++/CLI
property int ScreenAvailableHeight {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IContextParams Interface
IContextParams Members


ScreenAvailableWidth Property

[image]
Gizmox.WebGUI.Common
ScreenAvailableWidth Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IContextParams Interface : ScreenAvailableWidth Property

Syntax

Visual Basic (Declaration)
ReadOnly Property ScreenAvailableWidth As Integer
Visual Basic (Usage) Copy Code
Dim instance As IContextParams
Dim value As Integer

value = instance.ScreenAvailableWidth
C#
int ScreenAvailableWidth {get;}
Managed Extensions for C++
__property int get_ScreenAvailableWidth();
C++/CLI
property int ScreenAvailableWidth {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IContextParams Interface
IContextParams Members


ScreenColorDepth Property

[image]
Gizmox.WebGUI.Common
ScreenColorDepth Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IContextParams Interface : ScreenColorDepth Property

Syntax

Visual Basic (Declaration)
ReadOnly Property ScreenColorDepth As Integer
Visual Basic (Usage) Copy Code
Dim instance As IContextParams
Dim value As Integer

value = instance.ScreenColorDepth
C#
int ScreenColorDepth {get;}
Managed Extensions for C++
__property int get_ScreenColorDepth();
C++/CLI
property int ScreenColorDepth {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IContextParams Interface
IContextParams Members


ScreenHeight Property

[image]
Gizmox.WebGUI.Common
ScreenHeight Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IContextParams Interface : ScreenHeight Property

Syntax

Visual Basic (Declaration)
ReadOnly Property ScreenHeight As Integer
Visual Basic (Usage) Copy Code
Dim instance As IContextParams
Dim value As Integer

value = instance.ScreenHeight
C#
int ScreenHeight {get;}
Managed Extensions for C++
__property int get_ScreenHeight();
C++/CLI
property int ScreenHeight {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IContextParams Interface
IContextParams Members


ScreenWidth Property

[image]
Gizmox.WebGUI.Common
ScreenWidth Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IContextParams Interface : ScreenWidth Property

Syntax

Visual Basic (Declaration)
ReadOnly Property ScreenWidth As Integer
Visual Basic (Usage) Copy Code
Dim instance As IContextParams
Dim value As Integer

value = instance.ScreenWidth
C#
int ScreenWidth {get;}
Managed Extensions for C++
__property int get_ScreenWidth();
C++/CLI
property int ScreenWidth {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IContextParams Interface
IContextParams Members


IContextPipeline Interface

[image]
Gizmox.WebGUI.Common
IContextPipeline Interface
Members See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IContextPipeline Interface

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Interface IContextPipeline
Visual Basic (Usage) Copy Code
Dim instance As IContextPipeline
C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public interface IContextPipeline
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public __gc __interface IContextPipeline
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public interface class IContextPipeline

Requirements

Namespace: Gizmox.WebGUI.Common.Interfaces

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

IContextPipeline Members
Gizmox.WebGUI.Common.Interfaces Namespace


IContextPipeline Interface Members

[image]
Gizmox.WebGUI.Common
IContextPipeline Interface Members
See Also Methods Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IContextPipeline Interface

The following tables list the members exposed by IContextPipeline.

Public Methods

 | Name | Description
Method | GenerateResponse |
Method | ProcessRequest |
Top

See Also

Reference

IContextPipeline Interface
Gizmox.WebGUI.Common.Interfaces Namespace


IContextPipeline Interface Methods

[image]
Gizmox.WebGUI.Common
IContextPipeline Interface Methods
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IContextPipeline Interface

For a list of all members of this type, see IContextPipeline members.

Public Methods

 | Name | Description
Method | GenerateResponse |
Method | ProcessRequest |
Top

See Also

Reference

IContextPipeline Interface
Gizmox.WebGUI.Common.Interfaces Namespace


GenerateResponse Method

[image]
Gizmox.WebGUI.Common
GenerateResponse Method
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IContextPipeline Interface : GenerateResponse Method

objOutput
lngRequestId

Syntax

Visual Basic (Declaration)
Sub GenerateResponse( _
   ByVal objOutput As TextWriter, _
   ByVal lngRequestId As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As IContextPipeline
Dim objOutput As TextWriter
Dim lngRequestId As Long

instance.GenerateResponse(objOutput, lngRequestId)
C#
void GenerateResponse(
   TextWriter objOutput,
   long lngRequestId
)
Managed Extensions for C++
void GenerateResponse(
   TextWriter* objOutput,
   long lngRequestId
)
C++/CLI
void GenerateResponse(
   TextWriter^ objOutput,
   long long lngRequestId
)

Parameters

objOutput
lngRequestId

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IContextPipeline Interface
IContextPipeline Members


ProcessRequest Method

[image]
Gizmox.WebGUI.Common
ProcessRequest Method
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IContextPipeline Interface : ProcessRequest Method

strEvents

Syntax

Visual Basic (Declaration)
Function ProcessRequest( _
   ByVal strEvents As String _
) As Long
Visual Basic (Usage) Copy Code
Dim instance As IContextPipeline
Dim strEvents As String
Dim value As Long

value = instance.ProcessRequest(strEvents)
C#
long ProcessRequest(
   string strEvents
)
Managed Extensions for C++
long ProcessRequest(
   string* strEvents
)
C++/CLI
long long ProcessRequest(
   String^ strEvents
)

Parameters

strEvents

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IContextPipeline Interface
IContextPipeline Members


IContextTerminate Interface

[image]
Gizmox.WebGUI.Common
IContextTerminate Interface
Members See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IContextTerminate Interface

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Interface IContextTerminate
Visual Basic (Usage) Copy Code
Dim instance As IContextTerminate
C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public interface IContextTerminate
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public __gc __interface IContextTerminate
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public interface class IContextTerminate

Requirements

Namespace: Gizmox.WebGUI.Common.Interfaces

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

IContextTerminate Members
Gizmox.WebGUI.Common.Interfaces Namespace


IContextTerminate Interface Members

[image]
Gizmox.WebGUI.Common
IContextTerminate Interface Members
See Also Methods Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IContextTerminate Interface

The following tables list the members exposed by IContextTerminate.

Public Methods

 | Name | Description
Method | ClearPendingTermination |
Method | SetPendingTermination |
Method | Terminate |
Top

See Also

Reference

IContextTerminate Interface
Gizmox.WebGUI.Common.Interfaces Namespace


IContextTerminate Interface Methods

[image]
Gizmox.WebGUI.Common
IContextTerminate Interface Methods
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IContextTerminate Interface

For a list of all members of this type, see IContextTerminate members.

Public Methods

 | Name | Description
Method | ClearPendingTermination |
Method | SetPendingTermination |
Method | Terminate |
Top

See Also

Reference

IContextTerminate Interface
Gizmox.WebGUI.Common.Interfaces Namespace


ClearPendingTermination Method

[image]
Gizmox.WebGUI.Common
ClearPendingTermination Method
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IContextTerminate Interface : ClearPendingTermination Method

Syntax

Visual Basic (Declaration)
Sub ClearPendingTermination()
Visual Basic (Usage) Copy Code
Dim instance As IContextTerminate

instance.ClearPendingTermination()
C#
void ClearPendingTermination()
Managed Extensions for C++
void ClearPendingTermination();
C++/CLI
void ClearPendingTermination();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IContextTerminate Interface
IContextTerminate Members


SetPendingTermination Method

[image]
Gizmox.WebGUI.Common
SetPendingTermination Method
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IContextTerminate Interface : SetPendingTermination Method

Syntax

Visual Basic (Declaration)
Sub SetPendingTermination()
Visual Basic (Usage) Copy Code
Dim instance As IContextTerminate

instance.SetPendingTermination()
C#
void SetPendingTermination()
Managed Extensions for C++
void SetPendingTermination();
C++/CLI
void SetPendingTermination();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IContextTerminate Interface
IContextTerminate Members


Terminate Method

[image]
Gizmox.WebGUI.Common
Terminate Method
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IContextTerminate Interface : Terminate Method

blnForce

Syntax

Visual Basic (Declaration)
Sub Terminate( _
   ByVal blnForce As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As IContextTerminate
Dim blnForce As Boolean

instance.Terminate(blnForce)
C#
void Terminate(
   bool blnForce
)
Managed Extensions for C++
void Terminate(
   bool blnForce
)
C++/CLI
void Terminate(
   bool blnForce
)

Parameters

blnForce

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IContextTerminate Interface
IContextTerminate Members


IControl Interface

[image]
Gizmox.WebGUI.Common
IControl Interface
Members See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IControl Interface

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Interface IControl
   Inherits IEventHandler, IRegisteredComponent
Visual Basic (Usage) Copy Code
Dim instance As IControl
C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public interface IControl : IEventHandler, IRegisteredComponent
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public __gc __interface IControl : public IEventHandler, IRegisteredComponent
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public interface class IControl : public IEventHandler, IRegisteredComponent

Requirements

Namespace: Gizmox.WebGUI.Common.Interfaces

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

IControl Members
Gizmox.WebGUI.Common.Interfaces Namespace


IControl Interface Members

[image]
Gizmox.WebGUI.Common
IControl Interface Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IControl Interface

The following tables list the members exposed by IControl.

Public Properties

 | Name | Description
Property | Controls |
Property | HasControls |
Property | Height |
Property | Left |
Property | Parent |
Property | Site |
Property | Top |
Property | Width |
Top

Public Methods

 | Name | Description
Method | BringToFront |
Method | ResumeLayout |
Method | SuspendLayout |
Top

See Also

Reference

IControl Interface
Gizmox.WebGUI.Common.Interfaces Namespace


IControl Interface Methods

[image]
Gizmox.WebGUI.Common
IControl Interface Methods
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IControl Interface

For a list of all members of this type, see IControl members.

Public Methods

 | Name | Description
Method | BringToFront |
Method | ResumeLayout |
Method | SuspendLayout |
Top

See Also

Reference

IControl Interface
Gizmox.WebGUI.Common.Interfaces Namespace


BringToFront Method

[image]
Gizmox.WebGUI.Common
BringToFront Method
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IControl Interface : BringToFront Method

Syntax

Visual Basic (Declaration)
Sub BringToFront()
Visual Basic (Usage) Copy Code
Dim instance As IControl

instance.BringToFront()
C#
void BringToFront()
Managed Extensions for C++
void BringToFront();
C++/CLI
void BringToFront();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IControl Interface
IControl Members


ResumeLayout Method

[image]
Gizmox.WebGUI.Common
ResumeLayout Method
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IControl Interface : ResumeLayout Method

p

Syntax

Visual Basic (Declaration)
Sub ResumeLayout( _
   ByVal p As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As IControl
Dim p As Boolean

instance.ResumeLayout(p)
C#
void ResumeLayout(
   bool p
)
Managed Extensions for C++
void ResumeLayout(
   bool p
)
C++/CLI
void ResumeLayout(
   bool p
)

Parameters

p

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IControl Interface
IControl Members


SuspendLayout Method

[image]
Gizmox.WebGUI.Common
SuspendLayout Method
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IControl Interface : SuspendLayout Method

Syntax

Visual Basic (Declaration)
Sub SuspendLayout()
Visual Basic (Usage) Copy Code
Dim instance As IControl

instance.SuspendLayout()
C#
void SuspendLayout()
Managed Extensions for C++
void SuspendLayout();
C++/CLI
void SuspendLayout();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IControl Interface
IControl Members


IControl Interface Properties

[image]
Gizmox.WebGUI.Common
IControl Interface Properties
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IControl Interface

For a list of all members of this type, see IControl members.

Public Properties

 | Name | Description
Property | Controls |
Property | HasControls |
Property | Height |
Property | Left |
Property | Parent |
Property | Site |
Property | Top |
Property | Width |
Top

See Also

Reference

IControl Interface
Gizmox.WebGUI.Common.Interfaces Namespace


Controls Property

[image]
Gizmox.WebGUI.Common
Controls Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IControl Interface : Controls Property

Syntax

Visual Basic (Declaration)
ReadOnly Property Controls As IList
Visual Basic (Usage) Copy Code
Dim instance As IControl
Dim value As IList

value = instance.Controls
C#
IList Controls {get;}
Managed Extensions for C++
__property IList* get_Controls();
C++/CLI
property IList^ Controls {
   IList^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IControl Interface
IControl Members


HasControls Property

[image]
Gizmox.WebGUI.Common
HasControls Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IControl Interface : HasControls Property

Syntax

Visual Basic (Declaration)
ReadOnly Property HasControls As Boolean
Visual Basic (Usage) Copy Code
Dim instance As IControl
Dim value As Boolean

value = instance.HasControls
C#
bool HasControls {get;}
Managed Extensions for C++
__property bool get_HasControls();
C++/CLI
property bool HasControls {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IControl Interface
IControl Members


Height Property

[image]
Gizmox.WebGUI.Common
Height Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IControl Interface : Height Property

Syntax

Visual Basic (Declaration)
Property Height As Integer
Visual Basic (Usage) Copy Code
Dim instance As IControl
Dim value As Integer

instance.Height = value

value = instance.Height
C#
int Height {get; set;}
Managed Extensions for C++
__property int get_Height();
__property void set_Height(
   int value
);
C++/CLI
property int Height {
   int get();
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IControl Interface
IControl Members


Left Property

[image]
Gizmox.WebGUI.Common
Left Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IControl Interface : Left Property

Syntax

Visual Basic (Declaration)
Property Left As Integer
Visual Basic (Usage) Copy Code
Dim instance As IControl
Dim value As Integer

instance.Left = value

value = instance.Left
C#
int Left {get; set;}
Managed Extensions for C++
__property int get_Left();
__property void set_Left(
   int value
);
C++/CLI
property int Left {
   int get();
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IControl Interface
IControl Members


Parent Property

[image]
Gizmox.WebGUI.Common
Parent Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IControl Interface : Parent Property

Syntax

Visual Basic (Declaration)
ReadOnly Property Parent As IControl
Visual Basic (Usage) Copy Code
Dim instance As IControl
Dim value As IControl

value = instance.Parent
C#
IControl Parent {get;}
Managed Extensions for C++
__property IControl* get_Parent();
C++/CLI
property IControl^ Parent {
   IControl^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IControl Interface
IControl Members


Site Property

[image]
Gizmox.WebGUI.Common
Site Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IControl Interface : Site Property

Syntax

Visual Basic (Declaration)
Property Site As ISite
Visual Basic (Usage) Copy Code
Dim instance As IControl
Dim value As ISite

instance.Site = value

value = instance.Site
C#
ISite Site {get; set;}
Managed Extensions for C++
__property ISite* get_Site();
__property void set_Site(
   ISite* value
);
C++/CLI
property ISite^ Site {
   ISite^ get();
   void set (ISite^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IControl Interface
IControl Members


Top Property

[image]
Gizmox.WebGUI.Common
Top Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IControl Interface : Top Property

Syntax

Visual Basic (Declaration)
Property Top As Integer
Visual Basic (Usage) Copy Code
Dim instance As IControl
Dim value As Integer

instance.Top = value

value = instance.Top
C#
int Top {get; set;}
Managed Extensions for C++
__property int get_Top();
__property void set_Top(
   int value
);
C++/CLI
property int Top {
   int get();
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IControl Interface
IControl Members


Width Property

[image]
Gizmox.WebGUI.Common
Width Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IControl Interface : Width Property

Syntax

Visual Basic (Declaration)
Property Width As Integer
Visual Basic (Usage) Copy Code
Dim instance As IControl
Dim value As Integer

instance.Width = value

value = instance.Width
C#
int Width {get; set;}
Managed Extensions for C++
__property int get_Width();
__property void set_Width(
   int value
);
C++/CLI
property int Width {
   int get();
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IControl Interface
IControl Members


ICookies Interface

[image]
Gizmox.WebGUI.Common
ICookies Interface
Members See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : ICookies Interface

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Interface ICookies
Visual Basic (Usage) Copy Code
Dim instance As ICookies
C#
[DefaultMemberAttribute("Item")]
public interface ICookies
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
public __gc __interface ICookies
C++/CLI
[DefaultMemberAttribute("Item")]
public interface class ICookies

Requirements

Namespace: Gizmox.WebGUI.Common.Interfaces

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

ICookies Members
Gizmox.WebGUI.Common.Interfaces Namespace


ICookies Interface Members

[image]
Gizmox.WebGUI.Common
ICookies Interface Members
See Also Properties Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : ICookies Interface

The following tables list the members exposed by ICookies.

Public Properties

 | Name | Description
Property | Item |
Top

See Also

Reference

ICookies Interface
Gizmox.WebGUI.Common.Interfaces Namespace


ICookies Interface Properties

[image]
Gizmox.WebGUI.Common
ICookies Interface Properties
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : ICookies Interface

For a list of all members of this type, see ICookies members.

Public Properties

 | Name | Description
Property | Item |
Top

See Also

Reference

ICookies Interface
Gizmox.WebGUI.Common.Interfaces Namespace


Item Property

[image]
Gizmox.WebGUI.Common
Item Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > ICookies Interface : Item Property

strKey

Syntax

Visual Basic (Declaration)
Default Property Item( _
   ByVal strKey As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As ICookies
Dim strKey As String
Dim value As String

instance.Item(strKey) = value

value = instance.Item(strKey)
C#
string this[
   string strKey
]; {get; set;}
Managed Extensions for C++
__property string* get_Item(
   string* strKey
);
__property void set_Item(
   string* strKey,
   string* value
);
C++/CLI
property String^ default [String^] {
   String^ get(String^strKey);
   void set (String^strKey, String^value);
}

Parameters

strKey

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ICookies Interface
ICookies Members


IEvent Interface

[image]
Gizmox.WebGUI.Common
IEvent Interface
Members See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IEvent Interface

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Interface IEvent
Visual Basic (Usage) Copy Code
Dim instance As IEvent
C#
[DefaultMemberAttribute("Item")]
public interface IEvent
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
public __gc __interface IEvent
C++/CLI
[DefaultMemberAttribute("Item")]
public interface class IEvent

Requirements

Namespace: Gizmox.WebGUI.Common.Interfaces

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

IEvent Members
Gizmox.WebGUI.Common.Interfaces Namespace


IEvent Interface Members

[image]
Gizmox.WebGUI.Common
IEvent Interface Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IEvent Interface

The following tables list the members exposed by IEvent.

Public Properties

 | Name | Description
Property | AltKey |
Property | ControlKey |
Property | Item |
Property | KeyCode |
Property | Member |
Property | ShiftKey |
Property | Source |
Property | Target |
Property | Type |
Top

Public Methods

 | Name | Description
Method | Contains |
Top

See Also

Reference

IEvent Interface
Gizmox.WebGUI.Common.Interfaces Namespace


IEvent Interface Methods

[image]
Gizmox.WebGUI.Common
IEvent Interface Methods
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IEvent Interface

For a list of all members of this type, see IEvent members.

Public Methods

 | Name | Description
Method | Contains |
Top

See Also

Reference

IEvent Interface
Gizmox.WebGUI.Common.Interfaces Namespace


Contains Method

[image]
Gizmox.WebGUI.Common
Contains Method
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IEvent Interface : Contains Method

strParam

Syntax

Visual Basic (Declaration)
Function Contains( _
   ByVal strParam As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As IEvent
Dim strParam As String
Dim value As Boolean

value = instance.Contains(strParam)
C#
bool Contains(
   string strParam
)
Managed Extensions for C++
bool Contains(
   string* strParam
)
C++/CLI
bool Contains(
   String^ strParam
)

Parameters

strParam

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IEvent Interface
IEvent Members


IEvent Interface Properties

[image]
Gizmox.WebGUI.Common
IEvent Interface Properties
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IEvent Interface

For a list of all members of this type, see IEvent members.

Public Properties

 | Name | Description
Property | AltKey |
Property | ControlKey |
Property | Item |
Property | KeyCode |
Property | Member |
Property | ShiftKey |
Property | Source |
Property | Target |
Property | Type |
Top

See Also

Reference

IEvent Interface
Gizmox.WebGUI.Common.Interfaces Namespace


AltKey Property

[image]
Gizmox.WebGUI.Common
AltKey Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IEvent Interface : AltKey Property

Syntax

Visual Basic (Declaration)
ReadOnly Property AltKey As Boolean
Visual Basic (Usage) Copy Code
Dim instance As IEvent
Dim value As Boolean

value = instance.AltKey
C#
bool AltKey {get;}
Managed Extensions for C++
__property bool get_AltKey();
C++/CLI
property bool AltKey {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IEvent Interface
IEvent Members


ControlKey Property

[image]
Gizmox.WebGUI.Common
ControlKey Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IEvent Interface : ControlKey Property

Syntax

Visual Basic (Declaration)
ReadOnly Property ControlKey As Boolean
Visual Basic (Usage) Copy Code
Dim instance As IEvent
Dim value As Boolean

value = instance.ControlKey
C#
bool ControlKey {get;}
Managed Extensions for C++
__property bool get_ControlKey();
C++/CLI
property bool ControlKey {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IEvent Interface
IEvent Members


Item Property

[image]
Gizmox.WebGUI.Common
Item Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IEvent Interface : Item Property

strParam

Syntax

Visual Basic (Declaration)
ReadOnly Default Property Item( _
   ByVal strParam As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As IEvent
Dim strParam As String
Dim value As String

value = instance.Item(strParam)
C#
string this[
   string strParam
]; {get;}
Managed Extensions for C++
__property string* get_Item(
   string* strParam
);
C++/CLI
property String^ default [String^] {
   String^ get(String^strParam);
}

Parameters

strParam

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IEvent Interface
IEvent Members


KeyCode Property

[image]
Gizmox.WebGUI.Common
KeyCode Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IEvent Interface : KeyCode Property

Syntax

Visual Basic (Declaration)
ReadOnly Property KeyCode As Keys
Visual Basic (Usage) Copy Code
Dim instance As IEvent
Dim value As Keys

value = instance.KeyCode
C#
Keys KeyCode {get;}
Managed Extensions for C++
__property Keys get_KeyCode();
C++/CLI
property Keys KeyCode {
   Keys get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IEvent Interface
IEvent Members


Member Property

[image]
Gizmox.WebGUI.Common
Member Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IEvent Interface : Member Property

Syntax

Visual Basic (Declaration)
ReadOnly Property Member As String
Visual Basic (Usage) Copy Code
Dim instance As IEvent
Dim value As String

value = instance.Member
C#
string Member {get;}
Managed Extensions for C++
__property string* get_Member();
C++/CLI
property String^ Member {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IEvent Interface
IEvent Members


ShiftKey Property

[image]
Gizmox.WebGUI.Common
ShiftKey Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IEvent Interface : ShiftKey Property

Syntax

Visual Basic (Declaration)
ReadOnly Property ShiftKey As Boolean
Visual Basic (Usage) Copy Code
Dim instance As IEvent
Dim value As Boolean

value = instance.ShiftKey
C#
bool ShiftKey {get;}
Managed Extensions for C++
__property bool get_ShiftKey();
C++/CLI
property bool ShiftKey {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IEvent Interface
IEvent Members


Source Property

[image]
Gizmox.WebGUI.Common
Source Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IEvent Interface : Source Property

Syntax

Visual Basic (Declaration)
ReadOnly Property Source As String
Visual Basic (Usage) Copy Code
Dim instance As IEvent
Dim value As String

value = instance.Source
C#
string Source {get;}
Managed Extensions for C++
__property string* get_Source();
C++/CLI
property String^ Source {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IEvent Interface
IEvent Members


Target Property

[image]
Gizmox.WebGUI.Common
Target Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IEvent Interface : Target Property

Syntax

Visual Basic (Declaration)
ReadOnly Property Target As String
Visual Basic (Usage) Copy Code
Dim instance As IEvent
Dim value As String

value = instance.Target
C#
string Target {get;}
Managed Extensions for C++
__property string* get_Target();
C++/CLI
property String^ Target {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IEvent Interface
IEvent Members


Type Property

[image]
Gizmox.WebGUI.Common
Type Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IEvent Interface : Type Property

Syntax

Visual Basic (Declaration)
ReadOnly Property Type As String
Visual Basic (Usage) Copy Code
Dim instance As IEvent
Dim value As String

value = instance.Type
C#
string Type {get;}
Managed Extensions for C++
__property string* get_Type();
C++/CLI
property String^ Type {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IEvent Interface
IEvent Members


IEventCollection Interface

[image]
Gizmox.WebGUI.Common
IEventCollection Interface
Members See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IEventCollection Interface

Syntax

Visual Basic (Declaration)
Public Interface IEventCollection
Visual Basic (Usage) Copy Code
Dim instance As IEventCollection
C#
public interface IEventCollection
Managed Extensions for C++
public __gc __interface IEventCollection
C++/CLI
public interface class IEventCollection

Requirements

Namespace: Gizmox.WebGUI.Common.Interfaces

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

IEventCollection Members
Gizmox.WebGUI.Common.Interfaces Namespace


IEventCollection Interface Members

[image]
Gizmox.WebGUI.Common
IEventCollection Interface Members
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IEventCollection Interface

The following tables list the members exposed by IEventCollection.

See Also

Reference

IEventCollection Interface
Gizmox.WebGUI.Common.Interfaces Namespace


IEventHandler Interface

[image]
Gizmox.WebGUI.Common
IEventHandler Interface
Members See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IEventHandler Interface

Syntax

Visual Basic (Declaration)
Public Interface IEventHandler
Visual Basic (Usage) Copy Code
Dim instance As IEventHandler
C#
public interface IEventHandler
Managed Extensions for C++
public __gc __interface IEventHandler
C++/CLI
public interface class IEventHandler

Requirements

Namespace: Gizmox.WebGUI.Common.Interfaces

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

IEventHandler Members
Gizmox.WebGUI.Common.Interfaces Namespace


IEventHandler Interface Members

[image]
Gizmox.WebGUI.Common
IEventHandler Interface Members
See Also Methods Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IEventHandler Interface

The following tables list the members exposed by IEventHandler.

Public Methods

 | Name | Description
Method | FireEvent |
Top

See Also

Reference

IEventHandler Interface
Gizmox.WebGUI.Common.Interfaces Namespace


IEventHandler Interface Methods

[image]
Gizmox.WebGUI.Common
IEventHandler Interface Methods
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IEventHandler Interface

For a list of all members of this type, see IEventHandler members.

Public Methods

 | Name | Description
Method | FireEvent |
Top

See Also

Reference

IEventHandler Interface
Gizmox.WebGUI.Common.Interfaces Namespace


FireEvent Method

[image]
Gizmox.WebGUI.Common
FireEvent Method
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IEventHandler Interface : FireEvent Method

objEvent

Syntax

Visual Basic (Declaration)
Sub FireEvent( _
   ByVal objEvent As IEvent _
)
Visual Basic (Usage) Copy Code
Dim instance As IEventHandler
Dim objEvent As IEvent

instance.FireEvent(objEvent)
C#
void FireEvent(
   IEvent objEvent
)
Managed Extensions for C++
void FireEvent(
   IEvent* objEvent
)
C++/CLI
void FireEvent(
   IEvent^ objEvent
)

Parameters

objEvent

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IEventHandler Interface
IEventHandler Members


IForm Interface

[image]
Gizmox.WebGUI.Common
IForm Interface
Members See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IForm Interface

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Interface IForm
   Inherits IControl, IEventHandler, IRegisteredComponent
Visual Basic (Usage) Copy Code
Dim instance As IForm
C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public interface IForm : IControl, IEventHandler, IRegisteredComponent
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public __gc __interface IForm : public IControl, IEventHandler, IRegisteredComponent
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public interface class IForm : public IControl, IEventHandler, IRegisteredComponent

Requirements

Namespace: Gizmox.WebGUI.Common.Interfaces

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

IForm Members
Gizmox.WebGUI.Common.Interfaces Namespace


IForm Interface Members

[image]
Gizmox.WebGUI.Common
IForm Interface Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IForm Interface

The following tables list the members exposed by IForm.

Public Properties

 | Name | Description
Property | Forms |
Property | IsClosed |
Property | Menu |
Property | Name |
Property | Visible |
Top

Public Methods

 | Name | Description
Method | ClearContext |
Method | Close |
Method | Dispose |
Method | RenderForm |
Method | SetContext |
Top

See Also

Reference

IForm Interface
Gizmox.WebGUI.Common.Interfaces Namespace


IForm Interface Methods

[image]
Gizmox.WebGUI.Common
IForm Interface Methods
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IForm Interface

For a list of all members of this type, see IForm members.

Public Methods

 | Name | Description
Method | ClearContext |
Method | Close |
Method | Dispose |
Method | RenderForm |
Method | SetContext |
Top

See Also

Reference

IForm Interface
Gizmox.WebGUI.Common.Interfaces Namespace


ClearContext Method

[image]
Gizmox.WebGUI.Common
ClearContext Method
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IForm Interface : ClearContext Method

Syntax

Visual Basic (Declaration)
Sub ClearContext()
Visual Basic (Usage) Copy Code
Dim instance As IForm

instance.ClearContext()
C#
void ClearContext()
Managed Extensions for C++
void ClearContext();
C++/CLI
void ClearContext();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IForm Interface
IForm Members


Close Method

[image]
Gizmox.WebGUI.Common
Close Method
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IForm Interface : Close Method

Syntax

Visual Basic (Declaration)
Sub Close()
Visual Basic (Usage) Copy Code
Dim instance As IForm

instance.Close()
C#
void Close()
Managed Extensions for C++
void Close();
C++/CLI
void Close();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IForm Interface
IForm Members


Dispose Method

[image]
Gizmox.WebGUI.Common
Dispose Method
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IForm Interface : Dispose Method

Syntax

Visual Basic (Declaration)
Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As IForm

instance.Dispose()
C#
void Dispose()
Managed Extensions for C++
void Dispose();
C++/CLI
void Dispose();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IForm Interface
IForm Members


RenderForm Method

[image]
Gizmox.WebGUI.Common
RenderForm Method
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IForm Interface : RenderForm Method

objContext
objWriter
lngRequestID

Syntax

Visual Basic (Declaration)
Sub RenderForm( _
   ByVal objContext As IContext, _
   ByVal objWriter As IResponseWriter, _
   ByVal lngRequestID As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As IForm
Dim objContext As IContext
Dim objWriter As IResponseWriter
Dim lngRequestID As Long

instance.RenderForm(objContext, objWriter, lngRequestID)
C#
void RenderForm(
   IContext objContext,
   IResponseWriter objWriter,
   long lngRequestID
)
Managed Extensions for C++
void RenderForm(
   IContext* objContext,
   IResponseWriter* objWriter,
   long lngRequestID
)
C++/CLI
void RenderForm(
   IContext^ objContext,
   IResponseWriter^ objWriter,
   long long lngRequestID
)

Parameters

objContext
objWriter
lngRequestID

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IForm Interface
IForm Members


SetContext Method

[image]
Gizmox.WebGUI.Common
SetContext Method
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IForm Interface : SetContext Method

objContext

Syntax

Visual Basic (Declaration)
Sub SetContext( _
   ByVal objContext As IContext _
)
Visual Basic (Usage) Copy Code
Dim instance As IForm
Dim objContext As IContext

instance.SetContext(objContext)
C#
void SetContext(
   IContext objContext
)
Managed Extensions for C++
void SetContext(
   IContext* objContext
)
C++/CLI
void SetContext(
   IContext^ objContext
)

Parameters

objContext

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IForm Interface
IForm Members


IForm Interface Properties

[image]
Gizmox.WebGUI.Common
IForm Interface Properties
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IForm Interface

For a list of all members of this type, see IForm members.

Public Properties

 | Name | Description
Property | Forms |
Property | IsClosed |
Property | Menu |
Property | Name |
Property | Visible |
Top

See Also

Reference

IForm Interface
Gizmox.WebGUI.Common.Interfaces Namespace


Forms Property

[image]
Gizmox.WebGUI.Common
Forms Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IForm Interface : Forms Property

Syntax

Visual Basic (Declaration)
ReadOnly Property Forms As IForm()
Visual Basic (Usage) Copy Code
Dim instance As IForm
Dim value() As IForm

value = instance.Forms
C#
IForm[] Forms {get;}
Managed Extensions for C++
__property IForm*[]* get_Forms();
C++/CLI
property array<IForm^>^ Forms {
   array<IForm^>^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IForm Interface
IForm Members


IsClosed Property

[image]
Gizmox.WebGUI.Common
IsClosed Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IForm Interface : IsClosed Property

Syntax

Visual Basic (Declaration)
ReadOnly Property IsClosed As Boolean
Visual Basic (Usage) Copy Code
Dim instance As IForm
Dim value As Boolean

value = instance.IsClosed
C#
bool IsClosed {get;}
Managed Extensions for C++
__property bool get_IsClosed();
C++/CLI
property bool IsClosed {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IForm Interface
IForm Members


Menu Property

[image]
Gizmox.WebGUI.Common
Menu Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IForm Interface : Menu Property

Syntax

Visual Basic (Declaration)
ReadOnly Property Menu As IMainMenu
Visual Basic (Usage) Copy Code
Dim instance As IForm
Dim value As IMainMenu

value = instance.Menu
C#
IMainMenu Menu {get;}
Managed Extensions for C++
__property IMainMenu* get_Menu();
C++/CLI
property IMainMenu^ Menu {
   IMainMenu^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IForm Interface
IForm Members


Name Property

[image]
Gizmox.WebGUI.Common
Name Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IForm Interface : Name Property

Syntax

Visual Basic (Declaration)
ReadOnly Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As IForm
Dim value As String

value = instance.Name
C#
string Name {get;}
Managed Extensions for C++
__property string* get_Name();
C++/CLI
property String^ Name {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IForm Interface
IForm Members


Visible Property

[image]
Gizmox.WebGUI.Common
Visible Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IForm Interface : Visible Property

Syntax

Visual Basic (Declaration)
Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As IForm
Dim value As Boolean

instance.Visible = value

value = instance.Visible
C#
bool Visible {get; set;}
Managed Extensions for C++
__property bool get_Visible();
__property void set_Visible(
   bool value
);
C++/CLI
property bool Visible {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IForm Interface
IForm Members


IFormFactory Interface

[image]
Gizmox.WebGUI.Common
IFormFactory Interface
Members See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IFormFactory Interface

Syntax

Visual Basic (Declaration)
Public Interface IFormFactory
Visual Basic (Usage) Copy Code
Dim instance As IFormFactory
C#
public interface IFormFactory
Managed Extensions for C++
public __gc __interface IFormFactory
C++/CLI
public interface class IFormFactory

Requirements

Namespace: Gizmox.WebGUI.Common.Interfaces

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

IFormFactory Members
Gizmox.WebGUI.Common.Interfaces Namespace


IFormFactory Interface Members

[image]
Gizmox.WebGUI.Common
IFormFactory Interface Members
See Also Methods Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IFormFactory Interface

The following tables list the members exposed by IFormFactory.

Public Methods

 | Name | Description
Method | CreateForm |
Top

See Also

Reference

IFormFactory Interface
Gizmox.WebGUI.Common.Interfaces Namespace


IFormFactory Interface Methods

[image]
Gizmox.WebGUI.Common
IFormFactory Interface Methods
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IFormFactory Interface

For a list of all members of this type, see IFormFactory members.

Public Methods

 | Name | Description
Method | CreateForm |
Top

See Also

Reference

IFormFactory Interface
Gizmox.WebGUI.Common.Interfaces Namespace


CreateForm Method

[image]
Gizmox.WebGUI.Common
CreateForm Method
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IFormFactory Interface : CreateForm Method

strCurrentPage
arrArguments

Syntax

Visual Basic (Declaration)
Function CreateForm( _
   ByVal strCurrentPage As String, _
   ByVal ParamArray arrArguments() As Object _
) As IForm
Visual Basic (Usage) Copy Code
Dim instance As IFormFactory
Dim strCurrentPage As String
Dim arrArguments() As Object
Dim value As IForm

value = instance.CreateForm(strCurrentPage, arrArguments)
C#
IForm CreateForm(
   string strCurrentPage,
   params object[] arrArguments
)
Managed Extensions for C++
IForm* CreateForm(
   string* strCurrentPage,
   params Object*[]* arrArguments
)
C++/CLI
IForm^ CreateForm(
   String^ strCurrentPage,
   ... array<Object^>^ arrArguments
)

Parameters

strCurrentPage
arrArguments

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IFormFactory Interface
IFormFactory Members


IFormLink Interface

[image]
Gizmox.WebGUI.Common
IFormLink Interface
Members See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IFormLink Interface

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Interface IFormLink
   Inherits ILink
Visual Basic (Usage) Copy Code
Dim instance As IFormLink
C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public interface IFormLink : ILink
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public __gc __interface IFormLink : public ILink
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public interface class IFormLink : public ILink

Requirements

Namespace: Gizmox.WebGUI.Common.Interfaces

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

IFormLink Members
Gizmox.WebGUI.Common.Interfaces Namespace


IFormLink Interface Members

[image]
Gizmox.WebGUI.Common
IFormLink Interface Members
See Also Properties Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IFormLink Interface

The following tables list the members exposed by IFormLink.

Public Properties

 | Name | Description
Property | FormApplication |
Property | FormInstance |
Property | FormType |
Top

See Also

Reference

IFormLink Interface
Gizmox.WebGUI.Common.Interfaces Namespace


IFormLink Interface Properties

[image]
Gizmox.WebGUI.Common
IFormLink Interface Properties
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IFormLink Interface

For a list of all members of this type, see IFormLink members.

Public Properties

 | Name | Description
Property | FormApplication |
Property | FormInstance |
Property | FormType |
Top

See Also

Reference

IFormLink Interface
Gizmox.WebGUI.Common.Interfaces Namespace


FormApplication Property

[image]
Gizmox.WebGUI.Common
FormApplication Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IFormLink Interface : FormApplication Property

Syntax

Visual Basic (Declaration)
ReadOnly Property FormApplication As String
Visual Basic (Usage) Copy Code
Dim instance As IFormLink
Dim value As String

value = instance.FormApplication
C#
string FormApplication {get;}
Managed Extensions for C++
__property string* get_FormApplication();
C++/CLI
property String^ FormApplication {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IFormLink Interface
IFormLink Members


FormInstance Property

[image]
Gizmox.WebGUI.Common
FormInstance Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IFormLink Interface : FormInstance Property

Syntax

Visual Basic (Declaration)
ReadOnly Property FormInstance As String
Visual Basic (Usage) Copy Code
Dim instance As IFormLink
Dim value As String

value = instance.FormInstance
C#
string FormInstance {get;}
Managed Extensions for C++
__property string* get_FormInstance();
C++/CLI
property String^ FormInstance {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IFormLink Interface
IFormLink Members


FormType Property

[image]
Gizmox.WebGUI.Common
FormType Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IFormLink Interface : FormType Property

Syntax

Visual Basic (Declaration)
ReadOnly Property FormType As Type
Visual Basic (Usage) Copy Code
Dim instance As IFormLink
Dim value As Type

value = instance.FormType
C#
Type FormType {get;}
Managed Extensions for C++
__property Type* get_FormType();
C++/CLI
property Type^ FormType {
   Type^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IFormLink Interface
IFormLink Members


IGatewayComponent Interface

[image]
Gizmox.WebGUI.Common
IGatewayComponent Interface
Members See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IGatewayComponent Interface

Syntax

Visual Basic (Declaration)
Public Interface IGatewayComponent
Visual Basic (Usage) Copy Code
Dim instance As IGatewayComponent
C#
public interface IGatewayComponent
Managed Extensions for C++
public __gc __interface IGatewayComponent
C++/CLI
public interface class IGatewayComponent

Requirements

Namespace: Gizmox.WebGUI.Common.Interfaces

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

IGatewayComponent Members
Gizmox.WebGUI.Common.Interfaces Namespace


IGatewayComponent Interface Members

[image]
Gizmox.WebGUI.Common
IGatewayComponent Interface Members
See Also Methods Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IGatewayComponent Interface

The following tables list the members exposed by IGatewayComponent.

Public Methods

 | Name | Description
Method | ProcessRequest |
Top

See Also

Reference

IGatewayComponent Interface
Gizmox.WebGUI.Common.Interfaces Namespace


IGatewayComponent Interface Methods

[image]
Gizmox.WebGUI.Common
IGatewayComponent Interface Methods
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IGatewayComponent Interface

For a list of all members of this type, see IGatewayComponent members.

Public Methods

 | Name | Description
Method | ProcessRequest |
Top

See Also

Reference

IGatewayComponent Interface
Gizmox.WebGUI.Common.Interfaces Namespace


ProcessRequest Method

[image]
Gizmox.WebGUI.Common
ProcessRequest Method
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IGatewayComponent Interface : ProcessRequest Method

objContext
strAction

Syntax

Visual Basic (Declaration)
Sub ProcessRequest( _
   ByVal objContext As IContext, _
   ByVal strAction As String _
)
Visual Basic (Usage) Copy Code
Dim instance As IGatewayComponent
Dim objContext As IContext
Dim strAction As String

instance.ProcessRequest(objContext, strAction)
C#
void ProcessRequest(
   IContext objContext,
   string strAction
)
Managed Extensions for C++
void ProcessRequest(
   IContext* objContext,
   string* strAction
)
C++/CLI
void ProcessRequest(
   IContext^ objContext,
   String^ strAction
)

Parameters

objContext
strAction

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IGatewayComponent Interface
IGatewayComponent Members


IGatewayControl Interface

[image]
Gizmox.WebGUI.Common
IGatewayControl Interface
Members See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IGatewayControl Interface

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("This interface is superceded by the IGatewayComponent which is implemented by default in the RegisteredComponent and can be used by overriding the ProcessGatewayRequest method.")>
Public Interface IGatewayControl
Visual Basic (Usage) Copy Code
Dim instance As IGatewayControl
C#
[ObsoleteAttribute("This interface is superceded by the IGatewayComponent which is implemented by default in the RegisteredComponent and can be used by overriding the ProcessGatewayRequest method.")]
public interface IGatewayControl
Managed Extensions for C++
[ObsoleteAttribute("This interface is superceded by the IGatewayComponent which is implemented by default in the RegisteredComponent and can be used by overriding the ProcessGatewayRequest method.")]
public __gc __interface IGatewayControl
C++/CLI
[ObsoleteAttribute("This interface is superceded by the IGatewayComponent which is implemented by default in the RegisteredComponent and can be used by overriding the ProcessGatewayRequest method.")]
public interface class IGatewayControl

Requirements

Namespace: Gizmox.WebGUI.Common.Interfaces

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

IGatewayControl Members
Gizmox.WebGUI.Common.Interfaces Namespace


IGatewayControl Interface Members

[image]
Gizmox.WebGUI.Common
IGatewayControl Interface Members
See Also Methods Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IGatewayControl Interface

The following tables list the members exposed by IGatewayControl.

Public Methods

 | Name | Description
Method | GetGatewayHandler |
Top

See Also

Reference

IGatewayControl Interface
Gizmox.WebGUI.Common.Interfaces Namespace


IGatewayControl Interface Methods

[image]
Gizmox.WebGUI.Common
IGatewayControl Interface Methods
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IGatewayControl Interface

For a list of all members of this type, see IGatewayControl members.

Public Methods

 | Name | Description
Method | GetGatewayHandler |
Top

See Also

Reference

IGatewayControl Interface
Gizmox.WebGUI.Common.Interfaces Namespace


GetGatewayHandler Method

[image]
Gizmox.WebGUI.Common
GetGatewayHandler Method
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IGatewayControl Interface : GetGatewayHandler Method

objContext
strAction

Syntax

Visual Basic (Declaration)
Function GetGatewayHandler( _
   ByVal objContext As IContext, _
   ByVal strAction As String _
) As IGatewayHandler
Visual Basic (Usage) Copy Code
Dim instance As IGatewayControl
Dim objContext As IContext
Dim strAction As String
Dim value As IGatewayHandler

value = instance.GetGatewayHandler(objContext, strAction)
C#
IGatewayHandler GetGatewayHandler(
   IContext objContext,
   string strAction
)
Managed Extensions for C++
IGatewayHandler* GetGatewayHandler(
   IContext* objContext,
   string* strAction
)
C++/CLI
IGatewayHandler^ GetGatewayHandler(
   IContext^ objContext,
   String^ strAction
)

Parameters

objContext
strAction

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IGatewayControl Interface
IGatewayControl Members


IGatewayHandler Interface

[image]
Gizmox.WebGUI.Common
IGatewayHandler Interface
Members See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IGatewayHandler Interface

Syntax

Visual Basic (Declaration)
Public Interface IGatewayHandler
Visual Basic (Usage) Copy Code
Dim instance As IGatewayHandler
C#
public interface IGatewayHandler
Managed Extensions for C++
public __gc __interface IGatewayHandler
C++/CLI
public interface class IGatewayHandler

Requirements

Namespace: Gizmox.WebGUI.Common.Interfaces

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

IGatewayHandler Members
Gizmox.WebGUI.Common.Interfaces Namespace


IGatewayHandler Interface Members

[image]
Gizmox.WebGUI.Common
IGatewayHandler Interface Members
See Also Methods Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IGatewayHandler Interface

The following tables list the members exposed by IGatewayHandler.

Public Methods

 | Name | Description
Method | ProcessGatewayRequest |
Top

See Also

Reference

IGatewayHandler Interface
Gizmox.WebGUI.Common.Interfaces Namespace


IGatewayHandler Interface Methods

[image]
Gizmox.WebGUI.Common
IGatewayHandler Interface Methods
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IGatewayHandler Interface

For a list of all members of this type, see IGatewayHandler members.

Public Methods

 | Name | Description
Method | ProcessGatewayRequest |
Top

See Also

Reference

IGatewayHandler Interface
Gizmox.WebGUI.Common.Interfaces Namespace


ProcessGatewayRequest Method

[image]
Gizmox.WebGUI.Common
ProcessGatewayRequest Method
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IGatewayHandler Interface : ProcessGatewayRequest Method

objContext
objComponent

Syntax

Visual Basic (Declaration)
Sub ProcessGatewayRequest( _
   ByVal objContext As IContext, _
   ByVal objComponent As IRegisteredComponent _
)
Visual Basic (Usage) Copy Code
Dim instance As IGatewayHandler
Dim objContext As IContext
Dim objComponent As IRegisteredComponent

instance.ProcessGatewayRequest(objContext, objComponent)
C#
void ProcessGatewayRequest(
   IContext objContext,
   IRegisteredComponent objComponent
)
Managed Extensions for C++
void ProcessGatewayRequest(
   IContext* objContext,
   IRegisteredComponent* objComponent
)
C++/CLI
void ProcessGatewayRequest(
   IContext^ objContext,
   IRegisteredComponent^ objComponent
)

Parameters

objContext
objComponent

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IGatewayHandler Interface
IGatewayHandler Members


ILink Interface

[image]
Gizmox.WebGUI.Common
ILink Interface
Members See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : ILink Interface

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Interface ILink
Visual Basic (Usage) Copy Code
Dim instance As ILink
C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public interface ILink
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public __gc __interface ILink
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public interface class ILink

Requirements

Namespace: Gizmox.WebGUI.Common.Interfaces

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

ILink Members
Gizmox.WebGUI.Common.Interfaces Namespace


ILink Interface Members

[image]
Gizmox.WebGUI.Common
ILink Interface Members
See Also Properties Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : ILink Interface

The following tables list the members exposed by ILink.

Public Properties

 | Name | Description
Property | Url |
Top

See Also

Reference

ILink Interface
Gizmox.WebGUI.Common.Interfaces Namespace


ILink Interface Properties

[image]
Gizmox.WebGUI.Common
ILink Interface Properties
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : ILink Interface

For a list of all members of this type, see ILink members.

Public Properties

 | Name | Description
Property | Url |
Top

See Also

Reference

ILink Interface
Gizmox.WebGUI.Common.Interfaces Namespace


Url Property

[image]
Gizmox.WebGUI.Common
Url Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > ILink Interface : Url Property

Syntax

Visual Basic (Declaration)
ReadOnly Property Url As String
Visual Basic (Usage) Copy Code
Dim instance As ILink
Dim value As String

value = instance.Url
C#
string Url {get;}
Managed Extensions for C++
__property string* get_Url();
C++/CLI
property String^ Url {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ILink Interface
ILink Members


ILinkArguments Interface

[image]
Gizmox.WebGUI.Common
ILinkArguments Interface
Members See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : ILinkArguments Interface

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Interface ILinkArguments
Visual Basic (Usage) Copy Code
Dim instance As ILinkArguments
C#
[DefaultMemberAttribute("Item")]
public interface ILinkArguments
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
public __gc __interface ILinkArguments
C++/CLI
[DefaultMemberAttribute("Item")]
public interface class ILinkArguments

Requirements

Namespace: Gizmox.WebGUI.Common.Interfaces

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

ILinkArguments Members
Gizmox.WebGUI.Common.Interfaces Namespace


ILinkArguments Interface Members

[image]
Gizmox.WebGUI.Common
ILinkArguments Interface Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : ILinkArguments Interface

The following tables list the members exposed by ILinkArguments.

Public Properties

 | Name | Description
Property | Count |
Property | Item |
Property | Names |
Top

Public Methods

 | Name | Description
Method | Clear |
Top

See Also

Reference

ILinkArguments Interface
Gizmox.WebGUI.Common.Interfaces Namespace


ILinkArguments Interface Methods

[image]
Gizmox.WebGUI.Common
ILinkArguments Interface Methods
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : ILinkArguments Interface

For a list of all members of this type, see ILinkArguments members.

Public Methods

 | Name | Description
Method | Clear |
Top

See Also

Reference

ILinkArguments Interface
Gizmox.WebGUI.Common.Interfaces Namespace


Clear Method

[image]
Gizmox.WebGUI.Common
Clear Method
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > ILinkArguments Interface : Clear Method

Syntax

Visual Basic (Declaration)
Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As ILinkArguments

instance.Clear()
C#
void Clear()
Managed Extensions for C++
void Clear();
C++/CLI
void Clear();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ILinkArguments Interface
ILinkArguments Members


ILinkArguments Interface Properties

[image]
Gizmox.WebGUI.Common
ILinkArguments Interface Properties
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : ILinkArguments Interface

For a list of all members of this type, see ILinkArguments members.

Public Properties

 | Name | Description
Property | Count |
Property | Item |
Property | Names |
Top

See Also

Reference

ILinkArguments Interface
Gizmox.WebGUI.Common.Interfaces Namespace


Count Property

[image]
Gizmox.WebGUI.Common
Count Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > ILinkArguments Interface : Count Property

Syntax

Visual Basic (Declaration)
ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As ILinkArguments
Dim value As Integer

value = instance.Count
C#
int Count {get;}
Managed Extensions for C++
__property int get_Count();
C++/CLI
property int Count {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ILinkArguments Interface
ILinkArguments Members


Item Property

[image]
Gizmox.WebGUI.Common
Item Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > ILinkArguments Interface : Item Property

name

Syntax

Visual Basic (Declaration)
Default Property Item( _
   ByVal name As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As ILinkArguments
Dim name As String
Dim value As String

instance.Item(name) = value

value = instance.Item(name)
C#
string this[
   string name
]; {get; set;}
Managed Extensions for C++
__property string* get_Item(
   string* name
);
__property void set_Item(
   string* name,
   string* value
);
C++/CLI
property String^ default [String^] {
   String^ get(String^name);
   void set (String^name, String^value);
}

Parameters

name

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ILinkArguments Interface
ILinkArguments Members


Names Property

[image]
Gizmox.WebGUI.Common
Names Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > ILinkArguments Interface : Names Property

Syntax

Visual Basic (Declaration)
ReadOnly Property Names As String()
Visual Basic (Usage) Copy Code
Dim instance As ILinkArguments
Dim value() As String

value = instance.Names
C#
string[] Names {get;}
Managed Extensions for C++
__property string*[]* get_Names();
C++/CLI
property array<String^>^ Names {
   array<String^>^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ILinkArguments Interface
ILinkArguments Members


ILinkParameters Interface

[image]
Gizmox.WebGUI.Common
ILinkParameters Interface
Members See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : ILinkParameters Interface

Syntax

Visual Basic (Declaration)
Public Interface ILinkParameters
Visual Basic (Usage) Copy Code
Dim instance As ILinkParameters
C#
public interface ILinkParameters
Managed Extensions for C++
public __gc __interface ILinkParameters
C++/CLI
public interface class ILinkParameters

Requirements

Namespace: Gizmox.WebGUI.Common.Interfaces

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

ILinkParameters Members
Gizmox.WebGUI.Common.Interfaces Namespace


ILinkParameters Interface Members

[image]
Gizmox.WebGUI.Common
ILinkParameters Interface Members
See Also Properties Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : ILinkParameters Interface

The following tables list the members exposed by ILinkParameters.

Public Properties

 | Name | Description
Property | Form |
Property | FullScreen |
Property | Location |
Property | QueryString |
Property | Resizable |
Property | ScrollBars |
Property | ShowLocationBar |
Property | ShowMenuBar |
Property | ShowStatusBar |
Property | ShowTitleBar |
Property | ShowToolBar |
Property | Size |
Property | Target |
Property | WindowStyle |
Top

See Also

Reference

ILinkParameters Interface
Gizmox.WebGUI.Common.Interfaces Namespace


ILinkParameters Interface Properties

[image]
Gizmox.WebGUI.Common
ILinkParameters Interface Properties
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : ILinkParameters Interface

For a list of all members of this type, see ILinkParameters members.

Public Properties

 | Name | Description
Property | Form |
Property | FullScreen |
Property | Location |
Property | QueryString |
Property | Resizable |
Property | ScrollBars |
Property | ShowLocationBar |
Property | ShowMenuBar |
Property | ShowStatusBar |
Property | ShowTitleBar |
Property | ShowToolBar |
Property | Size |
Property | Target |
Property | WindowStyle |
Top

See Also

Reference

ILinkParameters Interface
Gizmox.WebGUI.Common.Interfaces Namespace


Form Property

[image]
Gizmox.WebGUI.Common
Form Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > ILinkParameters Interface : Form Property

Syntax

Visual Basic (Declaration)
ReadOnly Property Form As ILinkArguments
Visual Basic (Usage) Copy Code
Dim instance As ILinkParameters
Dim value As ILinkArguments

value = instance.Form
C#
ILinkArguments Form {get;}
Managed Extensions for C++
__property ILinkArguments* get_Form();
C++/CLI
property ILinkArguments^ Form {
   ILinkArguments^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ILinkParameters Interface
ILinkParameters Members


FullScreen Property

[image]
Gizmox.WebGUI.Common
FullScreen Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > ILinkParameters Interface : FullScreen Property

Syntax

Visual Basic (Declaration)
Property FullScreen As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ILinkParameters
Dim value As Boolean

instance.FullScreen = value

value = instance.FullScreen
C#
bool FullScreen {get; set;}
Managed Extensions for C++
__property bool get_FullScreen();
__property void set_FullScreen(
   bool value
);
C++/CLI
property bool FullScreen {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ILinkParameters Interface
ILinkParameters Members


Location Property

[image]
Gizmox.WebGUI.Common
Location Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > ILinkParameters Interface : Location Property

Syntax

Visual Basic (Declaration)
Property Location As Point
Visual Basic (Usage) Copy Code
Dim instance As ILinkParameters
Dim value As Point

instance.Location = value

value = instance.Location
C#
Point Location {get; set;}
Managed Extensions for C++
__property Point get_Location();
__property void set_Location(
   Point value
);
C++/CLI
property Point Location {
   Point get();
   void set (Pointvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ILinkParameters Interface
ILinkParameters Members


QueryString Property

[image]
Gizmox.WebGUI.Common
QueryString Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > ILinkParameters Interface : QueryString Property

Syntax

Visual Basic (Declaration)
ReadOnly Property QueryString As ILinkArguments
Visual Basic (Usage) Copy Code
Dim instance As ILinkParameters
Dim value As ILinkArguments

value = instance.QueryString
C#
ILinkArguments QueryString {get;}
Managed Extensions for C++
__property ILinkArguments* get_QueryString();
C++/CLI
property ILinkArguments^ QueryString {
   ILinkArguments^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ILinkParameters Interface
ILinkParameters Members


Resizable Property

[image]
Gizmox.WebGUI.Common
Resizable Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > ILinkParameters Interface : Resizable Property

Syntax

Visual Basic (Declaration)
Property Resizable As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ILinkParameters
Dim value As Boolean

instance.Resizable = value

value = instance.Resizable
C#
bool Resizable {get; set;}
Managed Extensions for C++
__property bool get_Resizable();
__property void set_Resizable(
   bool value
);
C++/CLI
property bool Resizable {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ILinkParameters Interface
ILinkParameters Members


ScrollBars Property

[image]
Gizmox.WebGUI.Common
ScrollBars Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > ILinkParameters Interface : ScrollBars Property

Syntax

Visual Basic (Declaration)
Property ScrollBars As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ILinkParameters
Dim value As Boolean

instance.ScrollBars = value

value = instance.ScrollBars
C#
bool ScrollBars {get; set;}
Managed Extensions for C++
__property bool get_ScrollBars();
__property void set_ScrollBars(
   bool value
);
C++/CLI
property bool ScrollBars {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ILinkParameters Interface
ILinkParameters Members


ShowLocationBar Property

[image]
Gizmox.WebGUI.Common
ShowLocationBar Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > ILinkParameters Interface : ShowLocationBar Property

Syntax

Visual Basic (Declaration)
Property ShowLocationBar As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ILinkParameters
Dim value As Boolean

instance.ShowLocationBar = value

value = instance.ShowLocationBar
C#
bool ShowLocationBar {get; set;}
Managed Extensions for C++
__property bool get_ShowLocationBar();
__property void set_ShowLocationBar(
   bool value
);
C++/CLI
property bool ShowLocationBar {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ILinkParameters Interface
ILinkParameters Members


ShowMenuBar Property

[image]
Gizmox.WebGUI.Common
ShowMenuBar Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > ILinkParameters Interface : ShowMenuBar Property

Syntax

Visual Basic (Declaration)
Property ShowMenuBar As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ILinkParameters
Dim value As Boolean

instance.ShowMenuBar = value

value = instance.ShowMenuBar
C#
bool ShowMenuBar {get; set;}
Managed Extensions for C++
__property bool get_ShowMenuBar();
__property void set_ShowMenuBar(
   bool value
);
C++/CLI
property bool ShowMenuBar {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ILinkParameters Interface
ILinkParameters Members


ShowStatusBar Property

[image]
Gizmox.WebGUI.Common
ShowStatusBar Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > ILinkParameters Interface : ShowStatusBar Property

Syntax

Visual Basic (Declaration)
Property ShowStatusBar As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ILinkParameters
Dim value As Boolean

instance.ShowStatusBar = value

value = instance.ShowStatusBar
C#
bool ShowStatusBar {get; set;}
Managed Extensions for C++
__property bool get_ShowStatusBar();
__property void set_ShowStatusBar(
   bool value
);
C++/CLI
property bool ShowStatusBar {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ILinkParameters Interface
ILinkParameters Members


ShowTitleBar Property

[image]
Gizmox.WebGUI.Common
ShowTitleBar Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > ILinkParameters Interface : ShowTitleBar Property

Syntax

Visual Basic (Declaration)
Property ShowTitleBar As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ILinkParameters
Dim value As Boolean

instance.ShowTitleBar = value

value = instance.ShowTitleBar
C#
bool ShowTitleBar {get; set;}
Managed Extensions for C++
__property bool get_ShowTitleBar();
__property void set_ShowTitleBar(
   bool value
);
C++/CLI
property bool ShowTitleBar {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ILinkParameters Interface
ILinkParameters Members


ShowToolBar Property

[image]
Gizmox.WebGUI.Common
ShowToolBar Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > ILinkParameters Interface : ShowToolBar Property

Syntax

Visual Basic (Declaration)
Property ShowToolBar As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ILinkParameters
Dim value As Boolean

instance.ShowToolBar = value

value = instance.ShowToolBar
C#
bool ShowToolBar {get; set;}
Managed Extensions for C++
__property bool get_ShowToolBar();
__property void set_ShowToolBar(
   bool value
);
C++/CLI
property bool ShowToolBar {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ILinkParameters Interface
ILinkParameters Members


Size Property

[image]
Gizmox.WebGUI.Common
Size Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > ILinkParameters Interface : Size Property

Syntax

Visual Basic (Declaration)
Property Size As Size
Visual Basic (Usage) Copy Code
Dim instance As ILinkParameters
Dim value As Size

instance.Size = value

value = instance.Size
C#
Size Size {get; set;}
Managed Extensions for C++
__property Size get_Size();
__property void set_Size(
   Size value
);
C++/CLI
property Size Size {
   Size get();
   void set (Sizevalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ILinkParameters Interface
ILinkParameters Members


Target Property

[image]
Gizmox.WebGUI.Common
Target Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > ILinkParameters Interface : Target Property

Syntax

Visual Basic (Declaration)
Property Target As String
Visual Basic (Usage) Copy Code
Dim instance As ILinkParameters
Dim value As String

instance.Target = value

value = instance.Target
C#
string Target {get; set;}
Managed Extensions for C++
__property string* get_Target();
__property void set_Target(
   string* value
);
C++/CLI
property String^ Target {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ILinkParameters Interface
ILinkParameters Members


WindowStyle Property

[image]
Gizmox.WebGUI.Common
WindowStyle Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > ILinkParameters Interface : WindowStyle Property

Syntax

Visual Basic (Declaration)
Property WindowStyle As LinkWindowStyle
Visual Basic (Usage) Copy Code
Dim instance As ILinkParameters
Dim value As LinkWindowStyle

instance.WindowStyle = value

value = instance.WindowStyle
C#
LinkWindowStyle WindowStyle {get; set;}
Managed Extensions for C++
__property LinkWindowStyle get_WindowStyle();
__property void set_WindowStyle(
   LinkWindowStyle value
);
C++/CLI
property LinkWindowStyle WindowStyle {
   LinkWindowStyle get();
   void set (LinkWindowStylevalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ILinkParameters Interface
ILinkParameters Members


ILogonForm Interface

[image]
Gizmox.WebGUI.Common
ILogonForm Interface
Members See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : ILogonForm Interface

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Interface ILogonForm
Visual Basic (Usage) Copy Code
Dim instance As ILogonForm
C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public interface ILogonForm
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public __gc __interface ILogonForm
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public interface class ILogonForm

Requirements

Namespace: Gizmox.WebGUI.Common.Interfaces

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

ILogonForm Members
Gizmox.WebGUI.Common.Interfaces Namespace


ILogonForm Interface Members

[image]
Gizmox.WebGUI.Common
ILogonForm Interface Members
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : ILogonForm Interface

The following tables list the members exposed by ILogonForm.

See Also

Reference

ILogonForm Interface
Gizmox.WebGUI.Common.Interfaces Namespace


IMainMenu Interface

[image]
Gizmox.WebGUI.Common
IMainMenu Interface
Members See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IMainMenu Interface

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Interface IMainMenu
Visual Basic (Usage) Copy Code
Dim instance As IMainMenu
C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public interface IMainMenu
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public __gc __interface IMainMenu
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public interface class IMainMenu

Requirements

Namespace: Gizmox.WebGUI.Common.Interfaces

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

IMainMenu Members
Gizmox.WebGUI.Common.Interfaces Namespace


IMainMenu Interface Members

[image]
Gizmox.WebGUI.Common
IMainMenu Interface Members
See Also Properties Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IMainMenu Interface

The following tables list the members exposed by IMainMenu.

Public Properties

 | Name | Description
Property | MenuItems |
Property | Parent |
Top

See Also

Reference

IMainMenu Interface
Gizmox.WebGUI.Common.Interfaces Namespace


IMainMenu Interface Properties

[image]
Gizmox.WebGUI.Common
IMainMenu Interface Properties
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IMainMenu Interface

For a list of all members of this type, see IMainMenu members.

Public Properties

 | Name | Description
Property | MenuItems |
Property | Parent |
Top

See Also

Reference

IMainMenu Interface
Gizmox.WebGUI.Common.Interfaces Namespace


MenuItems Property

[image]
Gizmox.WebGUI.Common
MenuItems Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IMainMenu Interface : MenuItems Property

Syntax

Visual Basic (Declaration)
ReadOnly Property MenuItems As ICollection
Visual Basic (Usage) Copy Code
Dim instance As IMainMenu
Dim value As ICollection

value = instance.MenuItems
C#
ICollection MenuItems {get;}
Managed Extensions for C++
__property ICollection* get_MenuItems();
C++/CLI
property ICollection^ MenuItems {
   ICollection^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IMainMenu Interface
IMainMenu Members


Parent Property

[image]
Gizmox.WebGUI.Common
Parent Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IMainMenu Interface : Parent Property

Syntax

Visual Basic (Declaration)
ReadOnly Property Parent As IComponent
Visual Basic (Usage) Copy Code
Dim instance As IMainMenu
Dim value As IComponent

value = instance.Parent
C#
IComponent Parent {get;}
Managed Extensions for C++
__property IComponent* get_Parent();
C++/CLI
property IComponent^ Parent {
   IComponent^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IMainMenu Interface
IMainMenu Members


IMashupArguments Interface

[image]
Gizmox.WebGUI.Common
IMashupArguments Interface
Members See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IMashupArguments Interface

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Interface IMashupArguments
Visual Basic (Usage) Copy Code
Dim instance As IMashupArguments
C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public interface IMashupArguments
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public __gc __interface IMashupArguments
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public interface class IMashupArguments

Requirements

Namespace: Gizmox.WebGUI.Common.Interfaces

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

IMashupArguments Members
Gizmox.WebGUI.Common.Interfaces Namespace


IMashupArguments Interface Members

[image]
Gizmox.WebGUI.Common
IMashupArguments Interface Members
See Also Properties Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IMashupArguments Interface

The following tables list the members exposed by IMashupArguments.

Public Properties

 | Name | Description
Property | Token |
Property | Type |
Top

See Also

Reference

IMashupArguments Interface
Gizmox.WebGUI.Common.Interfaces Namespace


IMashupArguments Interface Properties

[image]
Gizmox.WebGUI.Common
IMashupArguments Interface Properties
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IMashupArguments Interface

For a list of all members of this type, see IMashupArguments members.

Public Properties

 | Name | Description
Property | Token |
Property | Type |
Top

See Also

Reference

IMashupArguments Interface
Gizmox.WebGUI.Common.Interfaces Namespace


Token Property

[image]
Gizmox.WebGUI.Common
Token Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IMashupArguments Interface : Token Property

Syntax

Visual Basic (Declaration)
ReadOnly Property Token As String
Visual Basic (Usage) Copy Code
Dim instance As IMashupArguments
Dim value As String

value = instance.Token
C#
string Token {get;}
Managed Extensions for C++
__property string* get_Token();
C++/CLI
property String^ Token {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IMashupArguments Interface
IMashupArguments Members


Type Property

[image]
Gizmox.WebGUI.Common
Type Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IMashupArguments Interface : Type Property

Syntax

Visual Basic (Declaration)
ReadOnly Property Type As MashupType
Visual Basic (Usage) Copy Code
Dim instance As IMashupArguments
Dim value As MashupType

value = instance.Type
C#
MashupType Type {get;}
Managed Extensions for C++
__property MashupType get_Type();
C++/CLI
property MashupType Type {
   MashupType get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IMashupArguments Interface
IMashupArguments Members


IMenu Interface

[image]
Gizmox.WebGUI.Common
IMenu Interface
Members See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IMenu Interface

Syntax

Visual Basic (Declaration)
Public Interface IMenu
Visual Basic (Usage) Copy Code
Dim instance As IMenu
C#
public interface IMenu
Managed Extensions for C++
public __gc __interface IMenu
C++/CLI
public interface class IMenu

Requirements

Namespace: Gizmox.WebGUI.Common.Interfaces

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

IMenu Members
Gizmox.WebGUI.Common.Interfaces Namespace


IMenu Interface Members

[image]
Gizmox.WebGUI.Common
IMenu Interface Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IMenu Interface

The following tables list the members exposed by IMenu.

Public Properties

 | Name | Description
Property | MenuItems |
Property | Parent |
Top

Public Methods

 | Name | Description
Method | Render |
Top

See Also

Reference

IMenu Interface
Gizmox.WebGUI.Common.Interfaces Namespace


IMenu Interface Methods

[image]
Gizmox.WebGUI.Common
IMenu Interface Methods
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IMenu Interface

For a list of all members of this type, see IMenu members.

Public Methods

 | Name | Description
Method | Render |
Top

See Also

Reference

IMenu Interface
Gizmox.WebGUI.Common.Interfaces Namespace


Render Method

[image]
Gizmox.WebGUI.Common
Render Method
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IMenu Interface : Render Method

objContext
objWriter
lngRequestID

Syntax

Visual Basic (Declaration)
Sub Render( _
   ByVal objContext As IContext, _
   ByVal objWriter As IResponseWriter, _
   ByVal lngRequestID As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As IMenu
Dim objContext As IContext
Dim objWriter As IResponseWriter
Dim lngRequestID As Long

instance.Render(objContext, objWriter, lngRequestID)
C#
void Render(
   IContext objContext,
   IResponseWriter objWriter,
   long lngRequestID
)
Managed Extensions for C++
void Render(
   IContext* objContext,
   IResponseWriter* objWriter,
   long lngRequestID
)
C++/CLI
void Render(
   IContext^ objContext,
   IResponseWriter^ objWriter,
   long long lngRequestID
)

Parameters

objContext
objWriter
lngRequestID

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IMenu Interface
IMenu Members


IMenu Interface Properties

[image]
Gizmox.WebGUI.Common
IMenu Interface Properties
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IMenu Interface

For a list of all members of this type, see IMenu members.

Public Properties

 | Name | Description
Property | MenuItems |
Property | Parent |
Top

See Also

Reference

IMenu Interface
Gizmox.WebGUI.Common.Interfaces Namespace


MenuItems Property

[image]
Gizmox.WebGUI.Common
MenuItems Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IMenu Interface : MenuItems Property

Syntax

Visual Basic (Declaration)
ReadOnly Property MenuItems As ICollection
Visual Basic (Usage) Copy Code
Dim instance As IMenu
Dim value As ICollection

value = instance.MenuItems
C#
ICollection MenuItems {get;}
Managed Extensions for C++
__property ICollection* get_MenuItems();
C++/CLI
property ICollection^ MenuItems {
   ICollection^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IMenu Interface
IMenu Members


Parent Property

[image]
Gizmox.WebGUI.Common
Parent Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IMenu Interface : Parent Property

Syntax

Visual Basic (Declaration)
ReadOnly Property Parent As IComponent
Visual Basic (Usage) Copy Code
Dim instance As IMenu
Dim value As IComponent

value = instance.Parent
C#
IComponent Parent {get;}
Managed Extensions for C++
__property IComponent* get_Parent();
C++/CLI
property IComponent^ Parent {
   IComponent^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IMenu Interface
IMenu Members


INonSerializable Interface

[image]
Gizmox.WebGUI.Common
INonSerializable Interface
Members See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : INonSerializable Interface

Syntax

Visual Basic (Declaration)
Public Interface INonSerializable
Visual Basic (Usage) Copy Code
Dim instance As INonSerializable
C#
public interface INonSerializable
Managed Extensions for C++
public __gc __interface INonSerializable
C++/CLI
public interface class INonSerializable

Requirements

Namespace: Gizmox.WebGUI.Common.Interfaces

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

INonSerializable Members
Gizmox.WebGUI.Common.Interfaces Namespace


INonSerializable Interface Members

[image]
Gizmox.WebGUI.Common
INonSerializable Interface Members
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : INonSerializable Interface

The following tables list the members exposed by INonSerializable.

See Also

Reference

INonSerializable Interface
Gizmox.WebGUI.Common.Interfaces Namespace


IObservableItem Interface

[image]
Gizmox.WebGUI.Common
IObservableItem Interface
Members See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IObservableItem Interface

Syntax

Visual Basic (Declaration)
Public Interface IObservableItem
Visual Basic (Usage) Copy Code
Dim instance As IObservableItem
C#
public interface IObservableItem
Managed Extensions for C++
public __gc __interface IObservableItem
C++/CLI
public interface class IObservableItem

Requirements

Namespace: Gizmox.WebGUI.Common.Interfaces

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

IObservableItem Members
Gizmox.WebGUI.Common.Interfaces Namespace


IObservableItem Interface Members

[image]
Gizmox.WebGUI.Common
IObservableItem Interface Members
See Also Events Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IObservableItem Interface

The following tables list the members exposed by IObservableItem.

Public Events

 | Name | Description
Event | ObservableItemPropertyChanged |
Top

See Also

Reference

IObservableItem Interface
Gizmox.WebGUI.Common.Interfaces Namespace


IObservableItem Interface Events

[image]
Gizmox.WebGUI.Common
IObservableItem Interface Events
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IObservableItem Interface

For a list of all members of this type, see IObservableItem members.

Public Events

 | Name | Description
Event | ObservableItemPropertyChanged |
Top

See Also

Reference

IObservableItem Interface
Gizmox.WebGUI.Common.Interfaces Namespace


ObservableItemPropertyChanged Event

[image]
Gizmox.WebGUI.Common
ObservableItemPropertyChanged Event
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IObservableItem Interface : ObservableItemPropertyChanged Event

Syntax

Visual Basic (Declaration)
Event ObservableItemPropertyChanged() As ObservableItemPropertyChangedHandler
Visual Basic (Usage) Copy Code
Dim instance As IObservableItem
Dim handler As ObservableItemPropertyChangedHandler

AddHandler instance.ObservableItemPropertyChanged, handler
C#
event ObservableItemPropertyChangedHandler ObservableItemPropertyChanged()
Managed Extensions for C++
__event ObservableItemPropertyChangedHandler* ObservableItemPropertyChanged
C++/CLI
event ObservableItemPropertyChangedHandler^ ObservableItemPropertyChanged

Event Data

The event handler receives an argument of type ObservableItemPropertyChangedArgs containing data related to this event. The following ObservableItemPropertyChangedArgs properties provide information specific to this event.

Property | Description
Property |
Subject |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IObservableItem Interface
IObservableItem Members


IObservableLayoutItem Interface

[image]
Gizmox.WebGUI.Common
IObservableLayoutItem Interface
Members See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IObservableLayoutItem Interface

Syntax

Visual Basic (Declaration)
Public Interface IObservableLayoutItem
Visual Basic (Usage) Copy Code
Dim instance As IObservableLayoutItem
C#
public interface IObservableLayoutItem
Managed Extensions for C++
public __gc __interface IObservableLayoutItem
C++/CLI
public interface class IObservableLayoutItem

Requirements

Namespace: Gizmox.WebGUI.Common.Interfaces

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

IObservableLayoutItem Members
Gizmox.WebGUI.Common.Interfaces Namespace


IObservableLayoutItem Interface Members

[image]
Gizmox.WebGUI.Common
IObservableLayoutItem Interface Members
See Also Properties Events Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IObservableLayoutItem Interface

The following tables list the members exposed by IObservableLayoutItem.

Public Properties

 | Name | Description
Property | DesignSize |
Top

Public Events

 | Name | Description
Event | ObservableResumeLayout |
Event | ObservableSuspendLayout |
Top

See Also

Reference

IObservableLayoutItem Interface
Gizmox.WebGUI.Common.Interfaces Namespace


IObservableLayoutItem Interface Properties

[image]
Gizmox.WebGUI.Common
IObservableLayoutItem Interface Properties
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IObservableLayoutItem Interface

For a list of all members of this type, see IObservableLayoutItem members.

Public Properties

 | Name | Description
Property | DesignSize |
Top

See Also

Reference

IObservableLayoutItem Interface
Gizmox.WebGUI.Common.Interfaces Namespace


DesignSize Property

[image]
Gizmox.WebGUI.Common
DesignSize Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IObservableLayoutItem Interface : DesignSize Property

Syntax

Visual Basic (Declaration)
ReadOnly Property DesignSize As Size
Visual Basic (Usage) Copy Code
Dim instance As IObservableLayoutItem
Dim value As Size

value = instance.DesignSize
C#
Size DesignSize {get;}
Managed Extensions for C++
__property Size get_DesignSize();
C++/CLI
property Size DesignSize {
   Size get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IObservableLayoutItem Interface
IObservableLayoutItem Members


IObservableLayoutItem Interface Events

[image]
Gizmox.WebGUI.Common
IObservableLayoutItem Interface Events
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IObservableLayoutItem Interface

For a list of all members of this type, see IObservableLayoutItem members.

Public Events

 | Name | Description
Event | ObservableResumeLayout |
Event | ObservableSuspendLayout |
Top

See Also

Reference

IObservableLayoutItem Interface
Gizmox.WebGUI.Common.Interfaces Namespace


ObservableResumeLayout Event

[image]
Gizmox.WebGUI.Common
ObservableResumeLayout Event
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IObservableLayoutItem Interface : ObservableResumeLayout Event

Syntax

Visual Basic (Declaration)
Event ObservableResumeLayout() As ObservableResumeLayoutHandler
Visual Basic (Usage) Copy Code
Dim instance As IObservableLayoutItem
Dim handler As ObservableResumeLayoutHandler

AddHandler instance.ObservableResumeLayout, handler
C#
event ObservableResumeLayoutHandler ObservableResumeLayout()
Managed Extensions for C++
__event ObservableResumeLayoutHandler* ObservableResumeLayout
C++/CLI
event ObservableResumeLayoutHandler^ ObservableResumeLayout

Event Data

The event handler receives an argument of type ObservableResumeLayoutArgs containing data related to this event. The following ObservableResumeLayoutArgs properties provide information specific to this event.

Property | Description
PerformLayout |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IObservableLayoutItem Interface
IObservableLayoutItem Members


ObservableSuspendLayout Event

[image]
Gizmox.WebGUI.Common
ObservableSuspendLayout Event
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IObservableLayoutItem Interface : ObservableSuspendLayout Event

Syntax

Visual Basic (Declaration)
Event ObservableSuspendLayout() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As IObservableLayoutItem
Dim handler As EventHandler

AddHandler instance.ObservableSuspendLayout, handler
C#
event EventHandler ObservableSuspendLayout()
Managed Extensions for C++
__event EventHandler* ObservableSuspendLayout
C++/CLI
event EventHandler^ ObservableSuspendLayout

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IObservableLayoutItem Interface
IObservableLayoutItem Members


IObservableList Interface

[image]
Gizmox.WebGUI.Common
IObservableList Interface
Members See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IObservableList Interface

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
<BrowsableAttribute(False)>
Public Interface IObservableList
Visual Basic (Usage) Copy Code
Dim instance As IObservableList
C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
[BrowsableAttribute(false)]
public interface IObservableList
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
[BrowsableAttribute(false)]
public __gc __interface IObservableList
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
[BrowsableAttribute(false)]
public interface class IObservableList

Requirements

Namespace: Gizmox.WebGUI.Common.Interfaces

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

IObservableList Members
Gizmox.WebGUI.Common.Interfaces Namespace


IObservableList Interface Members

[image]
Gizmox.WebGUI.Common
IObservableList Interface Members
See Also Events Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IObservableList Interface

The following tables list the members exposed by IObservableList.

Public Events

 | Name | Description
Event | ObservableItemAdded |
Event | ObservableItemInserted |
Event | ObservableItemRemoved |
Event | ObservableListCleared |
Top

See Also

Reference

IObservableList Interface
Gizmox.WebGUI.Common.Interfaces Namespace


IObservableList Interface Events

[image]
Gizmox.WebGUI.Common
IObservableList Interface Events
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IObservableList Interface

For a list of all members of this type, see IObservableList members.

Public Events

 | Name | Description
Event | ObservableItemAdded |
Event | ObservableItemInserted |
Event | ObservableItemRemoved |
Event | ObservableListCleared |
Top

See Also

Reference

IObservableList Interface
Gizmox.WebGUI.Common.Interfaces Namespace


ObservableItemAdded Event

[image]
Gizmox.WebGUI.Common
ObservableItemAdded Event
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IObservableList Interface : ObservableItemAdded Event

Syntax

Visual Basic (Declaration)
Event ObservableItemAdded() As ObservableListEventHandler
Visual Basic (Usage) Copy Code
Dim instance As IObservableList
Dim handler As ObservableListEventHandler

AddHandler instance.ObservableItemAdded, handler
C#
event ObservableListEventHandler ObservableItemAdded()
Managed Extensions for C++
__event ObservableListEventHandler* ObservableItemAdded
C++/CLI
event ObservableListEventHandler^ ObservableItemAdded

Event Data

The event handler receives an argument of type ObservableListEventArgs containing data related to this event. The following ObservableListEventArgs properties provide information specific to this event.

Property | Description
Item |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IObservableList Interface
IObservableList Members


ObservableItemInserted Event

[image]
Gizmox.WebGUI.Common
ObservableItemInserted Event
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IObservableList Interface : ObservableItemInserted Event

Syntax

Visual Basic (Declaration)
Event ObservableItemInserted() As ObservableListEventHandler
Visual Basic (Usage) Copy Code
Dim instance As IObservableList
Dim handler As ObservableListEventHandler

AddHandler instance.ObservableItemInserted, handler
C#
event ObservableListEventHandler ObservableItemInserted()
Managed Extensions for C++
__event ObservableListEventHandler* ObservableItemInserted
C++/CLI
event ObservableListEventHandler^ ObservableItemInserted

Event Data

The event handler receives an argument of type ObservableListEventArgs containing data related to this event. The following ObservableListEventArgs properties provide information specific to this event.

Property | Description
Item |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IObservableList Interface
IObservableList Members


ObservableItemRemoved Event

[image]
Gizmox.WebGUI.Common
ObservableItemRemoved Event
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IObservableList Interface : ObservableItemRemoved Event

Syntax

Visual Basic (Declaration)
Event ObservableItemRemoved() As ObservableListEventHandler
Visual Basic (Usage) Copy Code
Dim instance As IObservableList
Dim handler As ObservableListEventHandler

AddHandler instance.ObservableItemRemoved, handler
C#
event ObservableListEventHandler ObservableItemRemoved()
Managed Extensions for C++
__event ObservableListEventHandler* ObservableItemRemoved
C++/CLI
event ObservableListEventHandler^ ObservableItemRemoved

Event Data

The event handler receives an argument of type ObservableListEventArgs containing data related to this event. The following ObservableListEventArgs properties provide information specific to this event.

Property | Description
Item |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IObservableList Interface
IObservableList Members


ObservableListCleared Event

[image]
Gizmox.WebGUI.Common
ObservableListCleared Event
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IObservableList Interface : ObservableListCleared Event

Syntax

Visual Basic (Declaration)
Event ObservableListCleared() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As IObservableList
Dim handler As EventHandler

AddHandler instance.ObservableListCleared, handler
C#
event EventHandler ObservableListCleared()
Managed Extensions for C++
__event EventHandler* ObservableListCleared
C++/CLI
event EventHandler^ ObservableListCleared

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IObservableList Interface
IObservableList Members


IRegisteredComponent Interface

[image]
Gizmox.WebGUI.Common
IRegisteredComponent Interface
Members See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IRegisteredComponent Interface

Syntax

Visual Basic (Declaration)
Public Interface IRegisteredComponent
   Inherits IEventHandler
Visual Basic (Usage) Copy Code
Dim instance As IRegisteredComponent
C#
public interface IRegisteredComponent : IEventHandler
Managed Extensions for C++
public __gc __interface IRegisteredComponent : public IEventHandler
C++/CLI
public interface class IRegisteredComponent : public IEventHandler

Requirements

Namespace: Gizmox.WebGUI.Common.Interfaces

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

IRegisteredComponent Members
Gizmox.WebGUI.Common.Interfaces Namespace


IRegisteredComponent Interface Members

[image]
Gizmox.WebGUI.Common
IRegisteredComponent Interface Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IRegisteredComponent Interface

The following tables list the members exposed by IRegisteredComponent.

Public Properties

 | Name | Description
Property | Guid |
Property | IsConnected |
Property | IsRegistered |
Top

Public Methods

 | Name | Description
Method | RegisterContextMenu |
Method | UnregisterComponents |
Method | UnregisterContextMenu |
Top

See Also

Reference

IRegisteredComponent Interface
Gizmox.WebGUI.Common.Interfaces Namespace


IRegisteredComponent Interface Methods

[image]
Gizmox.WebGUI.Common
IRegisteredComponent Interface Methods
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IRegisteredComponent Interface

For a list of all members of this type, see IRegisteredComponent members.

Public Methods

 | Name | Description
Method | RegisterContextMenu |
Method | UnregisterComponents |
Method | UnregisterContextMenu |
Top

See Also

Reference

IRegisteredComponent Interface
Gizmox.WebGUI.Common.Interfaces Namespace


RegisterContextMenu Method

[image]
Gizmox.WebGUI.Common
RegisterContextMenu Method
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IRegisteredComponent Interface : RegisterContextMenu Method

Syntax

Visual Basic (Declaration)
Sub RegisterContextMenu()
Visual Basic (Usage) Copy Code
Dim instance As IRegisteredComponent

instance.RegisterContextMenu()
C#
void RegisterContextMenu()
Managed Extensions for C++
void RegisterContextMenu();
C++/CLI
void RegisterContextMenu();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IRegisteredComponent Interface
IRegisteredComponent Members


UnregisterComponents Method

[image]
Gizmox.WebGUI.Common
UnregisterComponents Method
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IRegisteredComponent Interface : UnregisterComponents Method

Syntax

Visual Basic (Declaration)
Sub UnregisterComponents()
Visual Basic (Usage) Copy Code
Dim instance As IRegisteredComponent

instance.UnregisterComponents()
C#
void UnregisterComponents()
Managed Extensions for C++
void UnregisterComponents();
C++/CLI
void UnregisterComponents();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IRegisteredComponent Interface
IRegisteredComponent Members


UnregisterContextMenu Method

[image]
Gizmox.WebGUI.Common
UnregisterContextMenu Method
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IRegisteredComponent Interface : UnregisterContextMenu Method

Syntax

Visual Basic (Declaration)
Sub UnregisterContextMenu()
Visual Basic (Usage) Copy Code
Dim instance As IRegisteredComponent

instance.UnregisterContextMenu()
C#
void UnregisterContextMenu()
Managed Extensions for C++
void UnregisterContextMenu();
C++/CLI
void UnregisterContextMenu();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IRegisteredComponent Interface
IRegisteredComponent Members


IRegisteredComponent Interface Properties

[image]
Gizmox.WebGUI.Common
IRegisteredComponent Interface Properties
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IRegisteredComponent Interface

For a list of all members of this type, see IRegisteredComponent members.

Public Properties

 | Name | Description
Property | Guid |
Property | IsConnected |
Property | IsRegistered |
Top

See Also

Reference

IRegisteredComponent Interface
Gizmox.WebGUI.Common.Interfaces Namespace


Guid Property

[image]
Gizmox.WebGUI.Common
Guid Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IRegisteredComponent Interface : Guid Property

Syntax

Visual Basic (Declaration)
Property Guid As Long
Visual Basic (Usage) Copy Code
Dim instance As IRegisteredComponent
Dim value As Long

instance.Guid = value

value = instance.Guid
C#
long Guid {get; set;}
Managed Extensions for C++
__property long get_Guid();
__property void set_Guid(
   long value
);
C++/CLI
property long long Guid {
   long long get();
   void set (long longvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IRegisteredComponent Interface
IRegisteredComponent Members


IsConnected Property

[image]
Gizmox.WebGUI.Common
IsConnected Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IRegisteredComponent Interface : IsConnected Property

Syntax

Visual Basic (Declaration)
ReadOnly Property IsConnected As Boolean
Visual Basic (Usage) Copy Code
Dim instance As IRegisteredComponent
Dim value As Boolean

value = instance.IsConnected
C#
bool IsConnected {get;}
Managed Extensions for C++
__property bool get_IsConnected();
C++/CLI
property bool IsConnected {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IRegisteredComponent Interface
IRegisteredComponent Members


IsRegistered Property

[image]
Gizmox.WebGUI.Common
IsRegistered Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IRegisteredComponent Interface : IsRegistered Property

Syntax

Visual Basic (Declaration)
Property IsRegistered As Boolean
Visual Basic (Usage) Copy Code
Dim instance As IRegisteredComponent
Dim value As Boolean

instance.IsRegistered = value

value = instance.IsRegistered
C#
bool IsRegistered {get; set;}
Managed Extensions for C++
__property bool get_IsRegistered();
__property void set_IsRegistered(
   bool value
);
C++/CLI
property bool IsRegistered {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IRegisteredComponent Interface
IRegisteredComponent Members


IRegisteredComponentContainer Interface

[image]
Gizmox.WebGUI.Common
IRegisteredComponentContainer Interface
Members See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IRegisteredComponentContainer Interface

Syntax

Visual Basic (Declaration)
Public Interface IRegisteredComponentContainer
Visual Basic (Usage) Copy Code
Dim instance As IRegisteredComponentContainer
C#
public interface IRegisteredComponentContainer
Managed Extensions for C++
public __gc __interface IRegisteredComponentContainer
C++/CLI
public interface class IRegisteredComponentContainer

Requirements

Namespace: Gizmox.WebGUI.Common.Interfaces

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

IRegisteredComponentContainer Members
Gizmox.WebGUI.Common.Interfaces Namespace


IRegisteredComponentContainer Interface Members

[image]
Gizmox.WebGUI.Common
IRegisteredComponentContainer Interface Members
See Also Properties Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IRegisteredComponentContainer Interface

The following tables list the members exposed by IRegisteredComponentContainer.

Public Properties

 | Name | Description
Property | ContainedComponents |
Top

See Also

Reference

IRegisteredComponentContainer Interface
Gizmox.WebGUI.Common.Interfaces Namespace


IRegisteredComponentContainer Interface Properties

[image]
Gizmox.WebGUI.Common
IRegisteredComponentContainer Interface Properties
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IRegisteredComponentContainer Interface

For a list of all members of this type, see IRegisteredComponentContainer members.

Public Properties

 | Name | Description
Property | ContainedComponents |
Top

See Also

Reference

IRegisteredComponentContainer Interface
Gizmox.WebGUI.Common.Interfaces Namespace


ContainedComponents Property

[image]
Gizmox.WebGUI.Common
ContainedComponents Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IRegisteredComponentContainer Interface : ContainedComponents Property

Syntax

Visual Basic (Declaration)
ReadOnly Property ContainedComponents As ICollection
Visual Basic (Usage) Copy Code
Dim instance As IRegisteredComponentContainer
Dim value As ICollection

value = instance.ContainedComponents
C#
ICollection ContainedComponents {get;}
Managed Extensions for C++
__property ICollection* get_ContainedComponents();
C++/CLI
property ICollection^ ContainedComponents {
   ICollection^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IRegisteredComponentContainer Interface
IRegisteredComponentContainer Members


IRegisteredComponentMember Interface

[image]
Gizmox.WebGUI.Common
IRegisteredComponentMember Interface
Members See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IRegisteredComponentMember Interface

Syntax

Visual Basic (Declaration)
Public Interface IRegisteredComponentMember
   Inherits IEventHandler
Visual Basic (Usage) Copy Code
Dim instance As IRegisteredComponentMember
C#
public interface IRegisteredComponentMember : IEventHandler
Managed Extensions for C++
public __gc __interface IRegisteredComponentMember : public IEventHandler
C++/CLI
public interface class IRegisteredComponentMember : public IEventHandler

Requirements

Namespace: Gizmox.WebGUI.Common.Interfaces

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

IRegisteredComponentMember Members
Gizmox.WebGUI.Common.Interfaces Namespace


IRegisteredComponentMember Interface Members

[image]
Gizmox.WebGUI.Common
IRegisteredComponentMember Interface Members
See Also Properties Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IRegisteredComponentMember Interface

The following tables list the members exposed by IRegisteredComponentMember.

Public Properties

 | Name | Description
Property | IsRegistered |
Property | MemberID |
Property | OwnerID |
Top

See Also

Reference

IRegisteredComponentMember Interface
Gizmox.WebGUI.Common.Interfaces Namespace


IRegisteredComponentMember Interface Properties

[image]
Gizmox.WebGUI.Common
IRegisteredComponentMember Interface Properties
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IRegisteredComponentMember Interface

For a list of all members of this type, see IRegisteredComponentMember members.

Public Properties

 | Name | Description
Property | IsRegistered |
Property | MemberID |
Property | OwnerID |
Top

See Also

Reference

IRegisteredComponentMember Interface
Gizmox.WebGUI.Common.Interfaces Namespace


IsRegistered Property

[image]
Gizmox.WebGUI.Common
IsRegistered Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IRegisteredComponentMember Interface : IsRegistered Property

Syntax

Visual Basic (Declaration)
Property IsRegistered As Boolean
Visual Basic (Usage) Copy Code
Dim instance As IRegisteredComponentMember
Dim value As Boolean

instance.IsRegistered = value

value = instance.IsRegistered
C#
bool IsRegistered {get; set;}
Managed Extensions for C++
__property bool get_IsRegistered();
__property void set_IsRegistered(
   bool value
);
C++/CLI
property bool IsRegistered {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IRegisteredComponentMember Interface
IRegisteredComponentMember Members


MemberID Property

[image]
Gizmox.WebGUI.Common
MemberID Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IRegisteredComponentMember Interface : MemberID Property

Syntax

Visual Basic (Declaration)
Property MemberID As Long
Visual Basic (Usage) Copy Code
Dim instance As IRegisteredComponentMember
Dim value As Long

instance.MemberID = value

value = instance.MemberID
C#
long MemberID {get; set;}
Managed Extensions for C++
__property long get_MemberID();
__property void set_MemberID(
   long value
);
C++/CLI
property long long MemberID {
   long long get();
   void set (long longvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IRegisteredComponentMember Interface
IRegisteredComponentMember Members


OwnerID Property

[image]
Gizmox.WebGUI.Common
OwnerID Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IRegisteredComponentMember Interface : OwnerID Property

Syntax

Visual Basic (Declaration)
ReadOnly Property OwnerID As Long
Visual Basic (Usage) Copy Code
Dim instance As IRegisteredComponentMember
Dim value As Long

value = instance.OwnerID
C#
long OwnerID {get;}
Managed Extensions for C++
__property long get_OwnerID();
C++/CLI
property long long OwnerID {
   long long get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IRegisteredComponentMember Interface
IRegisteredComponentMember Members


IRenderableComponent Interface

[image]
Gizmox.WebGUI.Common
IRenderableComponent Interface
Members See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IRenderableComponent Interface

Syntax

Visual Basic (Declaration)
Public Interface IRenderableComponent
Visual Basic (Usage) Copy Code
Dim instance As IRenderableComponent
C#
public interface IRenderableComponent
Managed Extensions for C++
public __gc __interface IRenderableComponent
C++/CLI
public interface class IRenderableComponent

Requirements

Namespace: Gizmox.WebGUI.Common.Interfaces

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

IRenderableComponent Members
Gizmox.WebGUI.Common.Interfaces Namespace


IRenderableComponent Interface Members

[image]
Gizmox.WebGUI.Common
IRenderableComponent Interface Members
See Also Methods Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IRenderableComponent Interface

The following tables list the members exposed by IRenderableComponent.

Public Methods

 | Name | Description
Method | RenderComponent |
Top

See Also

Reference

IRenderableComponent Interface
Gizmox.WebGUI.Common.Interfaces Namespace


IRenderableComponent Interface Methods

[image]
Gizmox.WebGUI.Common
IRenderableComponent Interface Methods
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IRenderableComponent Interface

For a list of all members of this type, see IRenderableComponent members.

Public Methods

 | Name | Description
Method | RenderComponent |
Top

See Also

Reference

IRenderableComponent Interface
Gizmox.WebGUI.Common.Interfaces Namespace


RenderComponent Method

[image]
Gizmox.WebGUI.Common
RenderComponent Method
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IRenderableComponent Interface : RenderComponent Method

objContext
objWriter
lngRequestID

Syntax

Visual Basic (Declaration)
Sub RenderComponent( _
   ByVal objContext As IContext, _
   ByVal objWriter As IResponseWriter, _
   ByVal lngRequestID As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As IRenderableComponent
Dim objContext As IContext
Dim objWriter As IResponseWriter
Dim lngRequestID As Long

instance.RenderComponent(objContext, objWriter, lngRequestID)
C#
void RenderComponent(
   IContext objContext,
   IResponseWriter objWriter,
   long lngRequestID
)
Managed Extensions for C++
void RenderComponent(
   IContext* objContext,
   IResponseWriter* objWriter,
   long lngRequestID
)
C++/CLI
void RenderComponent(
   IContext^ objContext,
   IResponseWriter^ objWriter,
   long long lngRequestID
)

Parameters

objContext
objWriter
lngRequestID

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IRenderableComponent Interface
IRenderableComponent Members


IRenderableComponentMember Interface

[image]
Gizmox.WebGUI.Common
IRenderableComponentMember Interface
Members See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IRenderableComponentMember Interface

Syntax

Visual Basic (Declaration)
Public Interface IRenderableComponentMember
Visual Basic (Usage) Copy Code
Dim instance As IRenderableComponentMember
C#
public interface IRenderableComponentMember
Managed Extensions for C++
public __gc __interface IRenderableComponentMember
C++/CLI
public interface class IRenderableComponentMember

Requirements

Namespace: Gizmox.WebGUI.Common.Interfaces

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

IRenderableComponentMember Members
Gizmox.WebGUI.Common.Interfaces Namespace


IRenderableComponentMember Interface Members

[image]
Gizmox.WebGUI.Common
IRenderableComponentMember Interface Members
See Also Methods Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IRenderableComponentMember Interface

The following tables list the members exposed by IRenderableComponentMember.

Public Methods

 | Name | Description
Method | RenderComponent |
Top

See Also

Reference

IRenderableComponentMember Interface
Gizmox.WebGUI.Common.Interfaces Namespace


IRenderableComponentMember Interface Methods

[image]
Gizmox.WebGUI.Common
IRenderableComponentMember Interface Methods
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IRenderableComponentMember Interface

For a list of all members of this type, see IRenderableComponentMember members.

Public Methods

 | Name | Description
Method | RenderComponent |
Top

See Also

Reference

IRenderableComponentMember Interface
Gizmox.WebGUI.Common.Interfaces Namespace


RenderComponent Method

[image]
Gizmox.WebGUI.Common
RenderComponent Method
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IRenderableComponentMember Interface : RenderComponent Method

objContext
objWriter
lngRequestID
blnRenderOwner

Syntax

Visual Basic (Declaration)
Sub RenderComponent( _
   ByVal objContext As IContext, _
   ByVal objWriter As IResponseWriter, _
   ByVal lngRequestID As Long, _
   ByVal blnRenderOwner As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As IRenderableComponentMember
Dim objContext As IContext
Dim objWriter As IResponseWriter
Dim lngRequestID As Long
Dim blnRenderOwner As Boolean

instance.RenderComponent(objContext, objWriter, lngRequestID, blnRenderOwner)
C#
void RenderComponent(
   IContext objContext,
   IResponseWriter objWriter,
   long lngRequestID,
   bool blnRenderOwner
)
Managed Extensions for C++
void RenderComponent(
   IContext* objContext,
   IResponseWriter* objWriter,
   long lngRequestID,
   bool blnRenderOwner
)
C++/CLI
void RenderComponent(
   IContext^ objContext,
   IResponseWriter^ objWriter,
   long long lngRequestID,
   bool blnRenderOwner
)

Parameters

objContext
objWriter
lngRequestID
blnRenderOwner

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IRenderableComponentMember Interface
IRenderableComponentMember Members


IRequest Interface

[image]
Gizmox.WebGUI.Common
IRequest Interface
Members See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IRequest Interface

Syntax

Visual Basic (Declaration)
Public Interface IRequest
   Inherits INonSerializable
Visual Basic (Usage) Copy Code
Dim instance As IRequest
C#
public interface IRequest : INonSerializable
Managed Extensions for C++
public __gc __interface IRequest : public INonSerializable
C++/CLI
public interface class IRequest : public INonSerializable

Requirements

Namespace: Gizmox.WebGUI.Common.Interfaces

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

IRequest Members
Gizmox.WebGUI.Common.Interfaces Namespace


IRequest Interface Members

[image]
Gizmox.WebGUI.Common
IRequest Interface Members
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IRequest Interface

The following tables list the members exposed by IRequest.

See Also

Reference

IRequest Interface
Gizmox.WebGUI.Common.Interfaces Namespace


IRequestParams Interface

[image]
Gizmox.WebGUI.Common
IRequestParams Interface
Members See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IRequestParams Interface

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Interface IRequestParams
Visual Basic (Usage) Copy Code
Dim instance As IRequestParams
C#
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public interface IRequestParams
Managed Extensions for C++
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public __gc __interface IRequestParams
C++/CLI
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public interface class IRequestParams

Requirements

Namespace: Gizmox.WebGUI.Common.Interfaces

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

IRequestParams Members
Gizmox.WebGUI.Common.Interfaces Namespace


IRequestParams Interface Members

[image]
Gizmox.WebGUI.Common
IRequestParams Interface Members
See Also Properties Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IRequestParams Interface

The following tables list the members exposed by IRequestParams.

Public Properties

 | Name | Description
Property | Events |
Property | HasEvents |
Property | IsInitialization |
Property | IsPostback |
Property | IsUserPostback |
Property | LastRender |
Property | OriginalPage |
Property | Page |
Property | PageInstance |
Property | Resource |
Property | Type |
Top

See Also

Reference

IRequestParams Interface
Gizmox.WebGUI.Common.Interfaces Namespace


IRequestParams Interface Properties

[image]
Gizmox.WebGUI.Common
IRequestParams Interface Properties
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IRequestParams Interface

For a list of all members of this type, see IRequestParams members.

Public Properties

 | Name | Description
Property | Events |
Property | HasEvents |
Property | IsInitialization |
Property | IsPostback |
Property | IsUserPostback |
Property | LastRender |
Property | OriginalPage |
Property | Page |
Property | PageInstance |
Property | Resource |
Property | Type |
Top

See Also

Reference

IRequestParams Interface
Gizmox.WebGUI.Common.Interfaces Namespace


Events Property

[image]
Gizmox.WebGUI.Common
Events Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IRequestParams Interface : Events Property

Syntax

Visual Basic (Declaration)
ReadOnly Property Events As IEventCollection
Visual Basic (Usage) Copy Code
Dim instance As IRequestParams
Dim value As IEventCollection

value = instance.Events
C#
IEventCollection Events {get;}
Managed Extensions for C++
__property IEventCollection* get_Events();
C++/CLI
property IEventCollection^ Events {
   IEventCollection^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IRequestParams Interface
IRequestParams Members


HasEvents Property

[image]
Gizmox.WebGUI.Common
HasEvents Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IRequestParams Interface : HasEvents Property

Syntax

Visual Basic (Declaration)
ReadOnly Property HasEvents As Boolean
Visual Basic (Usage) Copy Code
Dim instance As IRequestParams
Dim value As Boolean

value = instance.HasEvents
C#
bool HasEvents {get;}
Managed Extensions for C++
__property bool get_HasEvents();
C++/CLI
property bool HasEvents {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IRequestParams Interface
IRequestParams Members


IsInitialization Property

[image]
Gizmox.WebGUI.Common
IsInitialization Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IRequestParams Interface : IsInitialization Property

Syntax

Visual Basic (Declaration)
ReadOnly Property IsInitialization As Boolean
Visual Basic (Usage) Copy Code
Dim instance As IRequestParams
Dim value As Boolean

value = instance.IsInitialization
C#
bool IsInitialization {get;}
Managed Extensions for C++
__property bool get_IsInitialization();
C++/CLI
property bool IsInitialization {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IRequestParams Interface
IRequestParams Members


IsPostback Property

[image]
Gizmox.WebGUI.Common
IsPostback Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IRequestParams Interface : IsPostback Property

Syntax

Visual Basic (Declaration)
ReadOnly Property IsPostback As Boolean
Visual Basic (Usage) Copy Code
Dim instance As IRequestParams
Dim value As Boolean

value = instance.IsPostback
C#
bool IsPostback {get;}
Managed Extensions for C++
__property bool get_IsPostback();
C++/CLI
property bool IsPostback {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IRequestParams Interface
IRequestParams Members


IsUserPostback Property

[image]
Gizmox.WebGUI.Common
IsUserPostback Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IRequestParams Interface : IsUserPostback Property

Syntax

Visual Basic (Declaration)
ReadOnly Property IsUserPostback As Boolean
Visual Basic (Usage) Copy Code
Dim instance As IRequestParams
Dim value As Boolean

value = instance.IsUserPostback
C#
bool IsUserPostback {get;}
Managed Extensions for C++
__property bool get_IsUserPostback();
C++/CLI
property bool IsUserPostback {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IRequestParams Interface
IRequestParams Members


LastRender Property

[image]
Gizmox.WebGUI.Common
LastRender Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IRequestParams Interface : LastRender Property

Syntax

Visual Basic (Declaration)
ReadOnly Property LastRender As Long
Visual Basic (Usage) Copy Code
Dim instance As IRequestParams
Dim value As Long

value = instance.LastRender
C#
long LastRender {get;}
Managed Extensions for C++
__property long get_LastRender();
C++/CLI
property long long LastRender {
   long long get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IRequestParams Interface
IRequestParams Members


OriginalPage Property

[image]
Gizmox.WebGUI.Common
OriginalPage Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IRequestParams Interface : OriginalPage Property

Syntax

Visual Basic (Declaration)
ReadOnly Property OriginalPage As String
Visual Basic (Usage) Copy Code
Dim instance As IRequestParams
Dim value As String

value = instance.OriginalPage
C#
string OriginalPage {get;}
Managed Extensions for C++
__property string* get_OriginalPage();
C++/CLI
property String^ OriginalPage {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IRequestParams Interface
IRequestParams Members


Page Property

[image]
Gizmox.WebGUI.Common
Page Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IRequestParams Interface : Page Property

Syntax

Visual Basic (Declaration)
ReadOnly Property Page As String
Visual Basic (Usage) Copy Code
Dim instance As IRequestParams
Dim value As String

value = instance.Page
C#
string Page {get;}
Managed Extensions for C++
__property string* get_Page();
C++/CLI
property String^ Page {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IRequestParams Interface
IRequestParams Members


PageInstance Property

[image]
Gizmox.WebGUI.Common
PageInstance Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IRequestParams Interface : PageInstance Property

Syntax

Visual Basic (Declaration)
ReadOnly Property PageInstance As String
Visual Basic (Usage) Copy Code
Dim instance As IRequestParams
Dim value As String

value = instance.PageInstance
C#
string PageInstance {get;}
Managed Extensions for C++
__property string* get_PageInstance();
C++/CLI
property String^ PageInstance {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IRequestParams Interface
IRequestParams Members


Resource Property

[image]
Gizmox.WebGUI.Common
Resource Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IRequestParams Interface : Resource Property

Syntax

Visual Basic (Declaration)
ReadOnly Property Resource As String
Visual Basic (Usage) Copy Code
Dim instance As IRequestParams
Dim value As String

value = instance.Resource
C#
string Resource {get;}
Managed Extensions for C++
__property string* get_Resource();
C++/CLI
property String^ Resource {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IRequestParams Interface
IRequestParams Members


Type Property

[image]
Gizmox.WebGUI.Common
Type Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IRequestParams Interface : Type Property

Syntax

Visual Basic (Declaration)
ReadOnly Property Type As RequestType
Visual Basic (Usage) Copy Code
Dim instance As IRequestParams
Dim value As RequestType

value = instance.Type
C#
RequestType Type {get;}
Managed Extensions for C++
__property RequestType get_Type();
C++/CLI
property RequestType Type {
   RequestType get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IRequestParams Interface
IRequestParams Members


IRequiredRegistration Interface

[image]
Gizmox.WebGUI.Common
IRequiredRegistration Interface
Members See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IRequiredRegistration Interface

Syntax

Visual Basic (Declaration)
Public Interface IRequiredRegistration
Visual Basic (Usage) Copy Code
Dim instance As IRequiredRegistration
C#
public interface IRequiredRegistration
Managed Extensions for C++
public __gc __interface IRequiredRegistration
C++/CLI
public interface class IRequiredRegistration

Requirements

Namespace: Gizmox.WebGUI.Common.Interfaces

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

IRequiredRegistration Members
Gizmox.WebGUI.Common.Interfaces Namespace


IRequiredRegistration Interface Members

[image]
Gizmox.WebGUI.Common
IRequiredRegistration Interface Members
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IRequiredRegistration Interface

The following tables list the members exposed by IRequiredRegistration.

See Also

Reference

IRequiredRegistration Interface
Gizmox.WebGUI.Common.Interfaces Namespace


IResponse Interface

[image]
Gizmox.WebGUI.Common
IResponse Interface
Members See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IResponse Interface

Syntax

Visual Basic (Declaration)
Public Interface IResponse
   Inherits INonSerializable
Visual Basic (Usage) Copy Code
Dim instance As IResponse
C#
public interface IResponse : INonSerializable
Managed Extensions for C++
public __gc __interface IResponse : public INonSerializable
C++/CLI
public interface class IResponse : public INonSerializable

Requirements

Namespace: Gizmox.WebGUI.Common.Interfaces

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

IResponse Members
Gizmox.WebGUI.Common.Interfaces Namespace


IResponse Interface Members

[image]
Gizmox.WebGUI.Common
IResponse Interface Members
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IResponse Interface

The following tables list the members exposed by IResponse.

See Also

Reference

IResponse Interface
Gizmox.WebGUI.Common.Interfaces Namespace


IResponseWriter Interface

[image]
Gizmox.WebGUI.Common
IResponseWriter Interface
Members See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IResponseWriter Interface

Syntax

Visual Basic (Declaration)
Public Interface IResponseWriter
   Inherits INonSerializable
Visual Basic (Usage) Copy Code
Dim instance As IResponseWriter
C#
public interface IResponseWriter : INonSerializable
Managed Extensions for C++
public __gc __interface IResponseWriter : public INonSerializable
C++/CLI
public interface class IResponseWriter : public INonSerializable

Requirements

Namespace: Gizmox.WebGUI.Common.Interfaces

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

IResponseWriter Members
Gizmox.WebGUI.Common.Interfaces Namespace


IResponseWriter Interface Members

[image]
Gizmox.WebGUI.Common
IResponseWriter Interface Members
See Also Methods Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IResponseWriter Interface

The following tables list the members exposed by IResponseWriter.

Public Methods

 | Name | Description
Method | WriteAttributeString |
Method | WriteEndElement |
Method | WriteStartElement | Overloaded.
Top

See Also

Reference

IResponseWriter Interface
Gizmox.WebGUI.Common.Interfaces Namespace


IResponseWriter Interface Methods

[image]
Gizmox.WebGUI.Common
IResponseWriter Interface Methods
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IResponseWriter Interface

For a list of all members of this type, see IResponseWriter members.

Public Methods

 | Name | Description
Method | WriteAttributeString |
Method | WriteEndElement |
Method | WriteStartElement | Overloaded.
Top

See Also

Reference

IResponseWriter Interface
Gizmox.WebGUI.Common.Interfaces Namespace


WriteAttributeString Method

[image]
Gizmox.WebGUI.Common
WriteAttributeString Method
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IResponseWriter Interface : WriteAttributeString Method

strAttribute
strValue

Syntax

Visual Basic (Declaration)
Sub WriteAttributeString( _
   ByVal strAttribute As String, _
   ByVal strValue As String _
)
Visual Basic (Usage) Copy Code
Dim instance As IResponseWriter
Dim strAttribute As String
Dim strValue As String

instance.WriteAttributeString(strAttribute, strValue)
C#
void WriteAttributeString(
   string strAttribute,
   string strValue
)
Managed Extensions for C++
void WriteAttributeString(
   string* strAttribute,
   string* strValue
)
C++/CLI
void WriteAttributeString(
   String^ strAttribute,
   String^ strValue
)

Parameters

strAttribute
strValue

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IResponseWriter Interface
IResponseWriter Members


WriteEndElement Method

[image]
Gizmox.WebGUI.Common
WriteEndElement Method
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IResponseWriter Interface : WriteEndElement Method

Syntax

Visual Basic (Declaration)
Sub WriteEndElement()
Visual Basic (Usage) Copy Code
Dim instance As IResponseWriter

instance.WriteEndElement()
C#
void WriteEndElement()
Managed Extensions for C++
void WriteEndElement();
C++/CLI
void WriteEndElement();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IResponseWriter Interface
IResponseWriter Members


WriteStartElement Method

[image]
Gizmox.WebGUI.Common
WriteStartElement Method
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IResponseWriter Interface : WriteStartElement Method

Overload List

Overload | Description
WriteStartElement(String) |
WriteStartElement(String,String,String) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IResponseWriter Interface
IResponseWriter Members


WriteStartElement(String) Method

[image]
Gizmox.WebGUI.Common
WriteStartElement(String) Method
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IResponseWriter Interface > WriteStartElement Method : WriteStartElement(String) Method

strElementName

Syntax

Visual Basic (Declaration)
Overloads Sub WriteStartElement( _
   ByVal strElementName As String _
)
Visual Basic (Usage) Copy Code
Dim instance As IResponseWriter
Dim strElementName As String

instance.WriteStartElement(strElementName)
C#
void WriteStartElement(
   string strElementName
)
Managed Extensions for C++
void WriteStartElement(
   string* strElementName
)
C++/CLI
void WriteStartElement(
   String^ strElementName
)

Parameters

strElementName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IResponseWriter Interface
IResponseWriter Members
Overload List


WriteStartElement(String,String,String) Method

[image]
Gizmox.WebGUI.Common
WriteStartElement(String,String,String) Method
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IResponseWriter Interface > WriteStartElement Method : WriteStartElement(String,String,String) Method

strPrefix
strElementName
strNamespace

Syntax

Visual Basic (Declaration)
Overloads Sub WriteStartElement( _
   ByVal strPrefix As String, _
   ByVal strElementName As String, _
   ByVal strNamespace As String _
)
Visual Basic (Usage) Copy Code
Dim instance As IResponseWriter
Dim strPrefix As String
Dim strElementName As String
Dim strNamespace As String

instance.WriteStartElement(strPrefix, strElementName, strNamespace)
C#
void WriteStartElement(
   string strPrefix,
   string strElementName,
   string strNamespace
)
Managed Extensions for C++
void WriteStartElement(
   string* strPrefix,
   string* strElementName,
   string* strNamespace
)
C++/CLI
void WriteStartElement(
   String^ strPrefix,
   String^ strElementName,
   String^ strNamespace
)

Parameters

strPrefix
strElementName
strNamespace

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IResponseWriter Interface
IResponseWriter Members
Overload List


IResultsProvider Interface

[image]
Gizmox.WebGUI.Common
IResultsProvider Interface
Members See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IResultsProvider Interface

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Interface IResultsProvider
Visual Basic (Usage) Copy Code
Dim instance As IResultsProvider
C#
[DefaultMemberAttribute("Item")]
public interface IResultsProvider
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
public __gc __interface IResultsProvider
C++/CLI
[DefaultMemberAttribute("Item")]
public interface class IResultsProvider

Requirements

Namespace: Gizmox.WebGUI.Common.Interfaces

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

IResultsProvider Members
Gizmox.WebGUI.Common.Interfaces Namespace


IResultsProvider Interface Members

[image]
Gizmox.WebGUI.Common
IResultsProvider Interface Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IResultsProvider Interface

The following tables list the members exposed by IResultsProvider.

Public Properties

 | Name | Description
Property | AllKeys |
Property | Item |
Top

Public Methods

 | Name | Description
Method | Clear |
Top

See Also

Reference

IResultsProvider Interface
Gizmox.WebGUI.Common.Interfaces Namespace


IResultsProvider Interface Methods

[image]
Gizmox.WebGUI.Common
IResultsProvider Interface Methods
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IResultsProvider Interface

For a list of all members of this type, see IResultsProvider members.

Public Methods

 | Name | Description
Method | Clear |
Top

See Also

Reference

IResultsProvider Interface
Gizmox.WebGUI.Common.Interfaces Namespace


Clear Method

[image]
Gizmox.WebGUI.Common
Clear Method
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IResultsProvider Interface : Clear Method

Syntax

Visual Basic (Declaration)
Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As IResultsProvider

instance.Clear()
C#
void Clear()
Managed Extensions for C++
void Clear();
C++/CLI
void Clear();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IResultsProvider Interface
IResultsProvider Members


IResultsProvider Interface Properties

[image]
Gizmox.WebGUI.Common
IResultsProvider Interface Properties
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IResultsProvider Interface

For a list of all members of this type, see IResultsProvider members.

Public Properties

 | Name | Description
Property | AllKeys |
Property | Item |
Top

See Also

Reference

IResultsProvider Interface
Gizmox.WebGUI.Common.Interfaces Namespace


AllKeys Property

[image]
Gizmox.WebGUI.Common
AllKeys Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IResultsProvider Interface : AllKeys Property

Syntax

Visual Basic (Declaration)
ReadOnly Property AllKeys As String()
Visual Basic (Usage) Copy Code
Dim instance As IResultsProvider
Dim value() As String

value = instance.AllKeys
C#
string[] AllKeys {get;}
Managed Extensions for C++
__property string*[]* get_AllKeys();
C++/CLI
property array<String^>^ AllKeys {
   array<String^>^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IResultsProvider Interface
IResultsProvider Members


Item Property

[image]
Gizmox.WebGUI.Common
Item Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IResultsProvider Interface : Item Property

strArgumentName

Syntax

Visual Basic (Declaration)
Default Property Item( _
   ByVal strArgumentName As String _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As IResultsProvider
Dim strArgumentName As String
Dim value As Object

instance.Item(strArgumentName) = value

value = instance.Item(strArgumentName)
C#
object this[
   string strArgumentName
]; {get; set;}
Managed Extensions for C++
__property Object* get_Item(
   string* strArgumentName
);
__property void set_Item(
   string* strArgumentName,
   Object* value
);
C++/CLI
property Object^ default [String^] {
   Object^ get(String^strArgumentName);
   void set (String^strArgumentName, Object^value);
}

Parameters

strArgumentName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IResultsProvider Interface
IResultsProvider Members


IResultsReaderProvider Interface

[image]
Gizmox.WebGUI.Common
IResultsReaderProvider Interface
Members See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IResultsReaderProvider Interface

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Interface IResultsReaderProvider
Visual Basic (Usage) Copy Code
Dim instance As IResultsReaderProvider
C#
[DefaultMemberAttribute("Item")]
public interface IResultsReaderProvider
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
public __gc __interface IResultsReaderProvider
C++/CLI
[DefaultMemberAttribute("Item")]
public interface class IResultsReaderProvider

Requirements

Namespace: Gizmox.WebGUI.Common.Interfaces

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

IResultsReaderProvider Members
Gizmox.WebGUI.Common.Interfaces Namespace


IResultsReaderProvider Interface Members

[image]
Gizmox.WebGUI.Common
IResultsReaderProvider Interface Members
See Also Properties Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IResultsReaderProvider Interface

The following tables list the members exposed by IResultsReaderProvider.

Public Properties

 | Name | Description
Property | AllKeys |
Property | Item |
Top

See Also

Reference

IResultsReaderProvider Interface
Gizmox.WebGUI.Common.Interfaces Namespace


IResultsReaderProvider Interface Properties

[image]
Gizmox.WebGUI.Common
IResultsReaderProvider Interface Properties
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IResultsReaderProvider Interface

For a list of all members of this type, see IResultsReaderProvider members.

Public Properties

 | Name | Description
Property | AllKeys |
Property | Item |
Top

See Also

Reference

IResultsReaderProvider Interface
Gizmox.WebGUI.Common.Interfaces Namespace


AllKeys Property

[image]
Gizmox.WebGUI.Common
AllKeys Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IResultsReaderProvider Interface : AllKeys Property

Syntax

Visual Basic (Declaration)
ReadOnly Property AllKeys As String()
Visual Basic (Usage) Copy Code
Dim instance As IResultsReaderProvider
Dim value() As String

value = instance.AllKeys
C#
string[] AllKeys {get;}
Managed Extensions for C++
__property string*[]* get_AllKeys();
C++/CLI
property array<String^>^ AllKeys {
   array<String^>^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IResultsReaderProvider Interface
IResultsReaderProvider Members


Item Property

[image]
Gizmox.WebGUI.Common
Item Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IResultsReaderProvider Interface : Item Property

strArgumentName

Syntax

Visual Basic (Declaration)
ReadOnly Default Property Item( _
   ByVal strArgumentName As String _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As IResultsReaderProvider
Dim strArgumentName As String
Dim value As Object

value = instance.Item(strArgumentName)
C#
object this[
   string strArgumentName
]; {get;}
Managed Extensions for C++
__property Object* get_Item(
   string* strArgumentName
);
C++/CLI
property Object^ default [String^] {
   Object^ get(String^strArgumentName);
}

Parameters

strArgumentName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IResultsReaderProvider Interface
IResultsReaderProvider Members


IRouter Interface

[image]
Gizmox.WebGUI.Common
IRouter Interface
Members See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IRouter Interface

Syntax

Visual Basic (Declaration)
Public Interface IRouter
Visual Basic (Usage) Copy Code
Dim instance As IRouter
C#
public interface IRouter
Managed Extensions for C++
public __gc __interface IRouter
C++/CLI
public interface class IRouter

Requirements

Namespace: Gizmox.WebGUI.Common.Interfaces

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

IRouter Members
Gizmox.WebGUI.Common.Interfaces Namespace


IRouter Interface Members

[image]
Gizmox.WebGUI.Common
IRouter Interface Members
See Also Methods Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IRouter Interface

The following tables list the members exposed by IRouter.

Public Methods

 | Name | Description
Method | GetArguments |
Method | GetResults |
Top

See Also

Reference

IRouter Interface
Gizmox.WebGUI.Common.Interfaces Namespace


IRouter Interface Methods

[image]
Gizmox.WebGUI.Common
IRouter Interface Methods
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IRouter Interface

For a list of all members of this type, see IRouter members.

Public Methods

 | Name | Description
Method | GetArguments |
Method | GetResults |
Top

See Also

Reference

IRouter Interface
Gizmox.WebGUI.Common.Interfaces Namespace


GetArguments Method

[image]
Gizmox.WebGUI.Common
GetArguments Method
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IRouter Interface : GetArguments Method

strForm
strInstance

Syntax

Visual Basic (Declaration)
Function GetArguments( _
   ByVal strForm As String, _
   ByVal strInstance As String _
) As IArgumentsProvider
Visual Basic (Usage) Copy Code
Dim instance As IRouter
Dim strForm As String
Dim strInstance As String
Dim value As IArgumentsProvider

value = instance.GetArguments(strForm, strInstance)
C#
IArgumentsProvider GetArguments(
   string strForm,
   string strInstance
)
Managed Extensions for C++
IArgumentsProvider* GetArguments(
   string* strForm,
   string* strInstance
)
C++/CLI
IArgumentsProvider^ GetArguments(
   String^ strForm,
   String^ strInstance
)

Parameters

strForm
strInstance

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IRouter Interface
IRouter Members


GetResults Method

[image]
Gizmox.WebGUI.Common
GetResults Method
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IRouter Interface : GetResults Method

strForm
strInstance

Syntax

Visual Basic (Declaration)
Function GetResults( _
   ByVal strForm As String, _
   ByVal strInstance As String _
) As IResultsReaderProvider
Visual Basic (Usage) Copy Code
Dim instance As IRouter
Dim strForm As String
Dim strInstance As String
Dim value As IResultsReaderProvider

value = instance.GetResults(strForm, strInstance)
C#
IResultsReaderProvider GetResults(
   string strForm,
   string strInstance
)
Managed Extensions for C++
IResultsReaderProvider* GetResults(
   string* strForm,
   string* strInstance
)
C++/CLI
IResultsReaderProvider^ GetResults(
   String^ strForm,
   String^ strInstance
)

Parameters

strForm
strInstance

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IRouter Interface
IRouter Members


ISealedComponent Interface

[image]
Gizmox.WebGUI.Common
ISealedComponent Interface
Members See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : ISealedComponent Interface

Syntax

Visual Basic (Declaration)
Public Interface ISealedComponent
Visual Basic (Usage) Copy Code
Dim instance As ISealedComponent
C#
public interface ISealedComponent
Managed Extensions for C++
public __gc __interface ISealedComponent
C++/CLI
public interface class ISealedComponent

Requirements

Namespace: Gizmox.WebGUI.Common.Interfaces

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

ISealedComponent Members
Gizmox.WebGUI.Common.Interfaces Namespace


ISealedComponent Interface Members

[image]
Gizmox.WebGUI.Common
ISealedComponent Interface Members
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : ISealedComponent Interface

The following tables list the members exposed by ISealedComponent.

See Also

Reference

ISealedComponent Interface
Gizmox.WebGUI.Common.Interfaces Namespace


IServer Interface

[image]
Gizmox.WebGUI.Common
IServer Interface
Members See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IServer Interface

Syntax

Visual Basic (Declaration)
Public Interface IServer
   Inherits INonSerializable
Visual Basic (Usage) Copy Code
Dim instance As IServer
C#
public interface IServer : INonSerializable
Managed Extensions for C++
public __gc __interface IServer : public INonSerializable
C++/CLI
public interface class IServer : public INonSerializable

Requirements

Namespace: Gizmox.WebGUI.Common.Interfaces

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

IServer Members
Gizmox.WebGUI.Common.Interfaces Namespace


IServer Interface Members

[image]
Gizmox.WebGUI.Common
IServer Interface Members
See Also Methods Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IServer Interface

The following tables list the members exposed by IServer.

Public Methods

 | Name | Description
Method | MapPath |
Top

See Also

Reference

IServer Interface
Gizmox.WebGUI.Common.Interfaces Namespace


IServer Interface Methods

[image]
Gizmox.WebGUI.Common
IServer Interface Methods
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IServer Interface

For a list of all members of this type, see IServer members.

Public Methods

 | Name | Description
Method | MapPath |
Top

See Also

Reference

IServer Interface
Gizmox.WebGUI.Common.Interfaces Namespace


MapPath Method

[image]
Gizmox.WebGUI.Common
MapPath Method
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IServer Interface : MapPath Method

strPath

Syntax

Visual Basic (Declaration)
Function MapPath( _
   ByVal strPath As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As IServer
Dim strPath As String
Dim value As String

value = instance.MapPath(strPath)
C#
string MapPath(
   string strPath
)
Managed Extensions for C++
string* MapPath(
   string* strPath
)
C++/CLI
String^ MapPath(
   String^ strPath
)

Parameters

strPath

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IServer Interface
IServer Members


IServerResponse Interface

[image]
Gizmox.WebGUI.Common
IServerResponse Interface
Members See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IServerResponse Interface

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Interface IServerResponse
Visual Basic (Usage) Copy Code
Dim instance As IServerResponse
C#
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public interface IServerResponse
Managed Extensions for C++
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public __gc __interface IServerResponse
C++/CLI
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public interface class IServerResponse

Requirements

Namespace: Gizmox.WebGUI.Common.Interfaces

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

IServerResponse Members
Gizmox.WebGUI.Common.Interfaces Namespace


IServerResponse Interface Members

[image]
Gizmox.WebGUI.Common
IServerResponse Interface Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IServerResponse Interface

The following tables list the members exposed by IServerResponse.

Public Properties

 | Name | Description
Property | GeneralNamespacePrefix |
Property | GeneralNamespaceUrl |
Top

Public Methods

 | Name | Description
Method | End |
Method | Start |
Method | StartMenus |
Method | WriteClosed |
Method | WriteError |
Method | WriteRefresh |
Top

See Also

Reference

IServerResponse Interface
Gizmox.WebGUI.Common.Interfaces Namespace


IServerResponse Interface Methods

[image]
Gizmox.WebGUI.Common
IServerResponse Interface Methods
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IServerResponse Interface

For a list of all members of this type, see IServerResponse members.

Public Methods

 | Name | Description
Method | End |
Method | Start |
Method | StartMenus |
Method | WriteClosed |
Method | WriteError |
Method | WriteRefresh |
Top

See Also

Reference

IServerResponse Interface
Gizmox.WebGUI.Common.Interfaces Namespace


End Method

[image]
Gizmox.WebGUI.Common
End Method
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IServerResponse Interface : End Method

objXmlWriter

Syntax

Visual Basic (Declaration)
Sub End( _
   ByVal objXmlWriter As IResponseWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As IServerResponse
Dim objXmlWriter As IResponseWriter

instance.End(objXmlWriter)
C#
void End(
   IResponseWriter objXmlWriter
)
Managed Extensions for C++
void End(
   IResponseWriter* objXmlWriter
)
C++/CLI
void End(
   IResponseWriter^ objXmlWriter
)

Parameters

objXmlWriter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IServerResponse Interface
IServerResponse Members


Start Method

[image]
Gizmox.WebGUI.Common
Start Method
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IServerResponse Interface : Start Method

lngLastRender
intNextInvokationTime
objXmlWriter
blnRenderParams
intActiveFormGuid

Syntax

Visual Basic (Declaration)
Sub Start( _
   ByVal lngLastRender As Long, _
   ByVal intNextInvokationTime As Integer, _
   ByRef objXmlWriter As IResponseWriter, _
   ByVal blnRenderParams As Boolean, _
   ByVal intActiveFormGuid As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As IServerResponse
Dim lngLastRender As Long
Dim intNextInvokationTime As Integer
Dim objXmlWriter As IResponseWriter
Dim blnRenderParams As Boolean
Dim intActiveFormGuid As Long

instance.Start(lngLastRender, intNextInvokationTime, objXmlWriter, blnRenderParams, intActiveFormGuid)
C#
void Start(
   long lngLastRender,
   int intNextInvokationTime,
   ref IResponseWriter objXmlWriter,
   bool blnRenderParams,
   long intActiveFormGuid
)
Managed Extensions for C++
void Start(
   long lngLastRender,
   int intNextInvokationTime,
   ref IResponseWriter* objXmlWriter,
   bool blnRenderParams,
   long intActiveFormGuid
)
C++/CLI
void Start(
   long long lngLastRender,
   int intNextInvokationTime,
   IResponseWriter^% objXmlWriter,
   bool blnRenderParams,
   long long intActiveFormGuid
)

Parameters

lngLastRender
intNextInvokationTime
objXmlWriter
blnRenderParams
intActiveFormGuid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IServerResponse Interface
IServerResponse Members


StartMenus Method

[image]
Gizmox.WebGUI.Common
StartMenus Method
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IServerResponse Interface : StartMenus Method

lngLastRender
objXmlWriter

Syntax

Visual Basic (Declaration)
Sub StartMenus( _
   ByVal lngLastRender As Long, _
   ByRef objXmlWriter As IResponseWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As IServerResponse
Dim lngLastRender As Long
Dim objXmlWriter As IResponseWriter

instance.StartMenus(lngLastRender, objXmlWriter)
C#
void StartMenus(
   long lngLastRender,
   ref IResponseWriter objXmlWriter
)
Managed Extensions for C++
void StartMenus(
   long lngLastRender,
   ref IResponseWriter* objXmlWriter
)
C++/CLI
void StartMenus(
   long long lngLastRender,
   IResponseWriter^% objXmlWriter
)

Parameters

lngLastRender
objXmlWriter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IServerResponse Interface
IServerResponse Members


WriteClosed Method

[image]
Gizmox.WebGUI.Common
WriteClosed Method
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IServerResponse Interface : WriteClosed Method

objXmlWriter

Syntax

Visual Basic (Declaration)
Sub WriteClosed( _
   ByRef objXmlWriter As IResponseWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As IServerResponse
Dim objXmlWriter As IResponseWriter

instance.WriteClosed(objXmlWriter)
C#
void WriteClosed(
   ref IResponseWriter objXmlWriter
)
Managed Extensions for C++
void WriteClosed(
   ref IResponseWriter* objXmlWriter
)
C++/CLI
void WriteClosed(
   IResponseWriter^% objXmlWriter
)

Parameters

objXmlWriter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IServerResponse Interface
IServerResponse Members


WriteError Method

[image]
Gizmox.WebGUI.Common
WriteError Method
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IServerResponse Interface : WriteError Method

strSource
strMessage
objXmlWriter

Syntax

Visual Basic (Declaration)
Sub WriteError( _
   ByVal strSource As String, _
   ByVal strMessage As String, _
   ByRef objXmlWriter As IResponseWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As IServerResponse
Dim strSource As String
Dim strMessage As String
Dim objXmlWriter As IResponseWriter

instance.WriteError(strSource, strMessage, objXmlWriter)
C#
void WriteError(
   string strSource,
   string strMessage,
   ref IResponseWriter objXmlWriter
)
Managed Extensions for C++
void WriteError(
   string* strSource,
   string* strMessage,
   ref IResponseWriter* objXmlWriter
)
C++/CLI
void WriteError(
   String^ strSource,
   String^ strMessage,
   IResponseWriter^% objXmlWriter
)

Parameters

strSource
strMessage
objXmlWriter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IServerResponse Interface
IServerResponse Members


WriteRefresh Method

[image]
Gizmox.WebGUI.Common
WriteRefresh Method
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IServerResponse Interface : WriteRefresh Method

objXmlWriter

Syntax

Visual Basic (Declaration)
Sub WriteRefresh( _
   ByRef objXmlWriter As IResponseWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As IServerResponse
Dim objXmlWriter As IResponseWriter

instance.WriteRefresh(objXmlWriter)
C#
void WriteRefresh(
   ref IResponseWriter objXmlWriter
)
Managed Extensions for C++
void WriteRefresh(
   ref IResponseWriter* objXmlWriter
)
C++/CLI
void WriteRefresh(
   IResponseWriter^% objXmlWriter
)

Parameters

objXmlWriter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IServerResponse Interface
IServerResponse Members


IServerResponse Interface Properties

[image]
Gizmox.WebGUI.Common
IServerResponse Interface Properties
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IServerResponse Interface

For a list of all members of this type, see IServerResponse members.

Public Properties

 | Name | Description
Property | GeneralNamespacePrefix |
Property | GeneralNamespaceUrl |
Top

See Also

Reference

IServerResponse Interface
Gizmox.WebGUI.Common.Interfaces Namespace


GeneralNamespacePrefix Property

[image]
Gizmox.WebGUI.Common
GeneralNamespacePrefix Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IServerResponse Interface : GeneralNamespacePrefix Property

Syntax

Visual Basic (Declaration)
ReadOnly Property GeneralNamespacePrefix As String
Visual Basic (Usage) Copy Code
Dim instance As IServerResponse
Dim value As String

value = instance.GeneralNamespacePrefix
C#
string GeneralNamespacePrefix {get;}
Managed Extensions for C++
__property string* get_GeneralNamespacePrefix();
C++/CLI
property String^ GeneralNamespacePrefix {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IServerResponse Interface
IServerResponse Members


GeneralNamespaceUrl Property

[image]
Gizmox.WebGUI.Common
GeneralNamespaceUrl Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IServerResponse Interface : GeneralNamespaceUrl Property

Syntax

Visual Basic (Declaration)
ReadOnly Property GeneralNamespaceUrl As String
Visual Basic (Usage) Copy Code
Dim instance As IServerResponse
Dim value As String

value = instance.GeneralNamespaceUrl
C#
string GeneralNamespaceUrl {get;}
Managed Extensions for C++
__property string* get_GeneralNamespaceUrl();
C++/CLI
property String^ GeneralNamespaceUrl {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IServerResponse Interface
IServerResponse Members


ISession Interface

[image]
Gizmox.WebGUI.Common
ISession Interface
Members See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : ISession Interface

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Interface ISession
Visual Basic (Usage) Copy Code
Dim instance As ISession
C#
[DefaultMemberAttribute("Item")]
public interface ISession
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
public __gc __interface ISession
C++/CLI
[DefaultMemberAttribute("Item")]
public interface class ISession

Requirements

Namespace: Gizmox.WebGUI.Common.Interfaces

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

ISession Members
Gizmox.WebGUI.Common.Interfaces Namespace


ISession Interface Members

[image]
Gizmox.WebGUI.Common
ISession Interface Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : ISession Interface

The following tables list the members exposed by ISession.

Public Properties

 | Name | Description
Property | IsLoggedOn |
Property | Item |
Property | SessionID |
Top

Public Methods

 | Name | Description
Method | GetRegisteredComponent |
Method | RegisterBatch |
Method | RegisterComponent |
Method | UnRegisterBatch |
Method | UnRegisterComponent |
Top

See Also

Reference

ISession Interface
Gizmox.WebGUI.Common.Interfaces Namespace


ISession Interface Methods

[image]
Gizmox.WebGUI.Common
ISession Interface Methods
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : ISession Interface

For a list of all members of this type, see ISession members.

Public Methods

 | Name | Description
Method | GetRegisteredComponent |
Method | RegisterBatch |
Method | RegisterComponent |
Method | UnRegisterBatch |
Method | UnRegisterComponent |
Top

See Also

Reference

ISession Interface
Gizmox.WebGUI.Common.Interfaces Namespace


GetRegisteredComponent Method

[image]
Gizmox.WebGUI.Common
GetRegisteredComponent Method
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > ISession Interface : GetRegisteredComponent Method

strComponentId

Syntax

Visual Basic (Declaration)
Function GetRegisteredComponent( _
   ByVal strComponentId As String _
) As IRegisteredComponent
Visual Basic (Usage) Copy Code
Dim instance As ISession
Dim strComponentId As String
Dim value As IRegisteredComponent

value = instance.GetRegisteredComponent(strComponentId)
C#
IRegisteredComponent GetRegisteredComponent(
   string strComponentId
)
Managed Extensions for C++
IRegisteredComponent* GetRegisteredComponent(
   string* strComponentId
)
C++/CLI
IRegisteredComponent^ GetRegisteredComponent(
   String^ strComponentId
)

Parameters

strComponentId

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISession Interface
ISession Members


RegisterBatch Method

[image]
Gizmox.WebGUI.Common
RegisterBatch Method
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > ISession Interface : RegisterBatch Method

objCollection

Syntax

Visual Basic (Declaration)
Sub RegisterBatch( _
   ByVal objCollection As ICollection _
)
Visual Basic (Usage) Copy Code
Dim instance As ISession
Dim objCollection As ICollection

instance.RegisterBatch(objCollection)
C#
void RegisterBatch(
   ICollection objCollection
)
Managed Extensions for C++
void RegisterBatch(
   ICollection* objCollection
)
C++/CLI
void RegisterBatch(
   ICollection^ objCollection
)

Parameters

objCollection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISession Interface
ISession Members


RegisterComponent Method

[image]
Gizmox.WebGUI.Common
RegisterComponent Method
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > ISession Interface : RegisterComponent Method

objComponent

Syntax

Visual Basic (Declaration)
Sub RegisterComponent( _
   ByVal objComponent As IRegisteredComponent _
)
Visual Basic (Usage) Copy Code
Dim instance As ISession
Dim objComponent As IRegisteredComponent

instance.RegisterComponent(objComponent)
C#
void RegisterComponent(
   IRegisteredComponent objComponent
)
Managed Extensions for C++
void RegisterComponent(
   IRegisteredComponent* objComponent
)
C++/CLI
void RegisterComponent(
   IRegisteredComponent^ objComponent
)

Parameters

objComponent

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISession Interface
ISession Members


UnRegisterBatch Method

[image]
Gizmox.WebGUI.Common
UnRegisterBatch Method
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > ISession Interface : UnRegisterBatch Method

objCollection

Syntax

Visual Basic (Declaration)
Sub UnRegisterBatch( _
   ByVal objCollection As ICollection _
)
Visual Basic (Usage) Copy Code
Dim instance As ISession
Dim objCollection As ICollection

instance.UnRegisterBatch(objCollection)
C#
void UnRegisterBatch(
   ICollection objCollection
)
Managed Extensions for C++
void UnRegisterBatch(
   ICollection* objCollection
)
C++/CLI
void UnRegisterBatch(
   ICollection^ objCollection
)

Parameters

objCollection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISession Interface
ISession Members


UnRegisterComponent Method

[image]
Gizmox.WebGUI.Common
UnRegisterComponent Method
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > ISession Interface : UnRegisterComponent Method

objComponent

Syntax

Visual Basic (Declaration)
Sub UnRegisterComponent( _
   ByVal objComponent As IRegisteredComponent _
)
Visual Basic (Usage) Copy Code
Dim instance As ISession
Dim objComponent As IRegisteredComponent

instance.UnRegisterComponent(objComponent)
C#
void UnRegisterComponent(
   IRegisteredComponent objComponent
)
Managed Extensions for C++
void UnRegisterComponent(
   IRegisteredComponent* objComponent
)
C++/CLI
void UnRegisterComponent(
   IRegisteredComponent^ objComponent
)

Parameters

objComponent

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISession Interface
ISession Members


ISession Interface Properties

[image]
Gizmox.WebGUI.Common
ISession Interface Properties
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : ISession Interface

For a list of all members of this type, see ISession members.

Public Properties

 | Name | Description
Property | IsLoggedOn |
Property | Item |
Property | SessionID |
Top

See Also

Reference

ISession Interface
Gizmox.WebGUI.Common.Interfaces Namespace


IsLoggedOn Property

[image]
Gizmox.WebGUI.Common
IsLoggedOn Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > ISession Interface : IsLoggedOn Property

Syntax

Visual Basic (Declaration)
Property IsLoggedOn As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISession
Dim value As Boolean

instance.IsLoggedOn = value

value = instance.IsLoggedOn
C#
bool IsLoggedOn {get; set;}
Managed Extensions for C++
__property bool get_IsLoggedOn();
__property void set_IsLoggedOn(
   bool value
);
C++/CLI
property bool IsLoggedOn {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISession Interface
ISession Members


Item Property

[image]
Gizmox.WebGUI.Common
Item Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > ISession Interface : Item Property

strProperty

Syntax

Visual Basic (Declaration)
Default Property Item( _
   ByVal strProperty As String _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As ISession
Dim strProperty As String
Dim value As Object

instance.Item(strProperty) = value

value = instance.Item(strProperty)
C#
object this[
   string strProperty
]; {get; set;}
Managed Extensions for C++
__property Object* get_Item(
   string* strProperty
);
__property void set_Item(
   string* strProperty,
   Object* value
);
C++/CLI
property Object^ default [String^] {
   Object^ get(String^strProperty);
   void set (String^strProperty, Object^value);
}

Parameters

strProperty

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISession Interface
ISession Members


SessionID Property

[image]
Gizmox.WebGUI.Common
SessionID Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > ISession Interface : SessionID Property

Syntax

Visual Basic (Declaration)
ReadOnly Property SessionID As String
Visual Basic (Usage) Copy Code
Dim instance As ISession
Dim value As String

value = instance.SessionID
C#
string SessionID {get;}
Managed Extensions for C++
__property string* get_SessionID();
C++/CLI
property String^ SessionID {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISession Interface
ISession Members


ISessionRegistry Interface

[image]
Gizmox.WebGUI.Common
ISessionRegistry Interface
Members See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : ISessionRegistry Interface

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Interface ISessionRegistry
Visual Basic (Usage) Copy Code
Dim instance As ISessionRegistry
C#
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public interface ISessionRegistry
Managed Extensions for C++
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public __gc __interface ISessionRegistry
C++/CLI
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public interface class ISessionRegistry

Requirements

Namespace: Gizmox.WebGUI.Common.Interfaces

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

ISessionRegistry Members
Gizmox.WebGUI.Common.Interfaces Namespace


ISessionRegistry Interface Members

[image]
Gizmox.WebGUI.Common
ISessionRegistry Interface Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : ISessionRegistry Interface

The following tables list the members exposed by ISessionRegistry.

Public Properties

 | Name | Description
Property | Count |
Top

Public Methods

 | Name | Description
Method | GetEnumerator |
Top

See Also

Reference

ISessionRegistry Interface
Gizmox.WebGUI.Common.Interfaces Namespace


ISessionRegistry Interface Methods

[image]
Gizmox.WebGUI.Common
ISessionRegistry Interface Methods
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : ISessionRegistry Interface

For a list of all members of this type, see ISessionRegistry members.

Public Methods

 | Name | Description
Method | GetEnumerator |
Top

See Also

Reference

ISessionRegistry Interface
Gizmox.WebGUI.Common.Interfaces Namespace


GetEnumerator Method

[image]
Gizmox.WebGUI.Common
GetEnumerator Method
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > ISessionRegistry Interface : GetEnumerator Method

Syntax

Visual Basic (Declaration)
Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As ISessionRegistry
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
IEnumerator GetEnumerator()
Managed Extensions for C++
IEnumerator* GetEnumerator();
C++/CLI
IEnumerator^ GetEnumerator();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISessionRegistry Interface
ISessionRegistry Members


ISessionRegistry Interface Properties

[image]
Gizmox.WebGUI.Common
ISessionRegistry Interface Properties
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : ISessionRegistry Interface

For a list of all members of this type, see ISessionRegistry members.

Public Properties

 | Name | Description
Property | Count |
Top

See Also

Reference

ISessionRegistry Interface
Gizmox.WebGUI.Common.Interfaces Namespace


Count Property

[image]
Gizmox.WebGUI.Common
Count Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > ISessionRegistry Interface : Count Property

Syntax

Visual Basic (Declaration)
ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISessionRegistry
Dim value As Integer

value = instance.Count
C#
int Count {get;}
Managed Extensions for C++
__property int get_Count();
C++/CLI
property int Count {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISessionRegistry Interface
ISessionRegistry Members


IStaticGateway Interface

[image]
Gizmox.WebGUI.Common
IStaticGateway Interface
Members See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IStaticGateway Interface

Syntax

Visual Basic (Declaration)
Public Interface IStaticGateway
Visual Basic (Usage) Copy Code
Dim instance As IStaticGateway
C#
public interface IStaticGateway
Managed Extensions for C++
public __gc __interface IStaticGateway
C++/CLI
public interface class IStaticGateway

Requirements

Namespace: Gizmox.WebGUI.Common.Interfaces

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

IStaticGateway Members
Gizmox.WebGUI.Common.Interfaces Namespace


IStaticGateway Interface Members

[image]
Gizmox.WebGUI.Common
IStaticGateway Interface Members
See Also Methods Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IStaticGateway Interface

The following tables list the members exposed by IStaticGateway.

Public Methods

 | Name | Description
Method | GetGatewayHandler |
Top

See Also

Reference

IStaticGateway Interface
Gizmox.WebGUI.Common.Interfaces Namespace


IStaticGateway Interface Methods

[image]
Gizmox.WebGUI.Common
IStaticGateway Interface Methods
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IStaticGateway Interface

For a list of all members of this type, see IStaticGateway members.

Public Methods

 | Name | Description
Method | GetGatewayHandler |
Top

See Also

Reference

IStaticGateway Interface
Gizmox.WebGUI.Common.Interfaces Namespace


GetGatewayHandler Method

[image]
Gizmox.WebGUI.Common
GetGatewayHandler Method
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IStaticGateway Interface : GetGatewayHandler Method

objContext

Syntax

Visual Basic (Declaration)
Function GetGatewayHandler( _
   ByVal objContext As IContext _
) As IStaticGatewayHandler
Visual Basic (Usage) Copy Code
Dim instance As IStaticGateway
Dim objContext As IContext
Dim value As IStaticGatewayHandler

value = instance.GetGatewayHandler(objContext)
C#
IStaticGatewayHandler GetGatewayHandler(
   IContext objContext
)
Managed Extensions for C++
IStaticGatewayHandler* GetGatewayHandler(
   IContext* objContext
)
C++/CLI
IStaticGatewayHandler^ GetGatewayHandler(
   IContext^ objContext
)

Parameters

objContext

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IStaticGateway Interface
IStaticGateway Members


IStaticGatewayHandler Interface

[image]
Gizmox.WebGUI.Common
IStaticGatewayHandler Interface
Members See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IStaticGatewayHandler Interface

Syntax

Visual Basic (Declaration)
Public Interface IStaticGatewayHandler
Visual Basic (Usage) Copy Code
Dim instance As IStaticGatewayHandler
C#
public interface IStaticGatewayHandler
Managed Extensions for C++
public __gc __interface IStaticGatewayHandler
C++/CLI
public interface class IStaticGatewayHandler

Requirements

Namespace: Gizmox.WebGUI.Common.Interfaces

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

IStaticGatewayHandler Members
Gizmox.WebGUI.Common.Interfaces Namespace


IStaticGatewayHandler Interface Members

[image]
Gizmox.WebGUI.Common
IStaticGatewayHandler Interface Members
See Also Methods Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IStaticGatewayHandler Interface

The following tables list the members exposed by IStaticGatewayHandler.

Public Methods

 | Name | Description
Method | ProcessGatewayRequest |
Top

See Also

Reference

IStaticGatewayHandler Interface
Gizmox.WebGUI.Common.Interfaces Namespace


IStaticGatewayHandler Interface Methods

[image]
Gizmox.WebGUI.Common
IStaticGatewayHandler Interface Methods
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IStaticGatewayHandler Interface

For a list of all members of this type, see IStaticGatewayHandler members.

Public Methods

 | Name | Description
Method | ProcessGatewayRequest |
Top

See Also

Reference

IStaticGatewayHandler Interface
Gizmox.WebGUI.Common.Interfaces Namespace


ProcessGatewayRequest Method

[image]
Gizmox.WebGUI.Common
ProcessGatewayRequest Method
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IStaticGatewayHandler Interface : ProcessGatewayRequest Method

objContext

Syntax

Visual Basic (Declaration)
Sub ProcessGatewayRequest( _
   ByVal objContext As IContext _
)
Visual Basic (Usage) Copy Code
Dim instance As IStaticGatewayHandler
Dim objContext As IContext

instance.ProcessGatewayRequest(objContext)
C#
void ProcessGatewayRequest(
   IContext objContext
)
Managed Extensions for C++
void ProcessGatewayRequest(
   IContext* objContext
)
C++/CLI
void ProcessGatewayRequest(
   IContext^ objContext
)

Parameters

objContext

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IStaticGatewayHandler Interface
IStaticGatewayHandler Members


ITimer Interface

[image]
Gizmox.WebGUI.Common
ITimer Interface
Members See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : ITimer Interface

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Interface ITimer
Visual Basic (Usage) Copy Code
Dim instance As ITimer
C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public interface ITimer
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public __gc __interface ITimer
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public interface class ITimer

Requirements

Namespace: Gizmox.WebGUI.Common.Interfaces

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

ITimer Members
Gizmox.WebGUI.Common.Interfaces Namespace


ITimer Interface Members

[image]
Gizmox.WebGUI.Common
ITimer Interface Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : ITimer Interface

The following tables list the members exposed by ITimer.

Public Properties

 | Name | Description
Property | Enabled |
Property | Interval |
Property | TimerID |
Top

Public Methods

 | Name | Description
Method | GetNextInvokation |
Method | InvokeTimer |
Top

See Also

Reference

ITimer Interface
Gizmox.WebGUI.Common.Interfaces Namespace


ITimer Interface Methods

[image]
Gizmox.WebGUI.Common
ITimer Interface Methods
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : ITimer Interface

For a list of all members of this type, see ITimer members.

Public Methods

 | Name | Description
Method | GetNextInvokation |
Method | InvokeTimer |
Top

See Also

Reference

ITimer Interface
Gizmox.WebGUI.Common.Interfaces Namespace


GetNextInvokation Method

[image]
Gizmox.WebGUI.Common
GetNextInvokation Method
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > ITimer Interface : GetNextInvokation Method

lngCurrentTicks

Syntax

Visual Basic (Declaration)
Function GetNextInvokation( _
   ByVal lngCurrentTicks As Long _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As ITimer
Dim lngCurrentTicks As Long
Dim value As Integer

value = instance.GetNextInvokation(lngCurrentTicks)
C#
int GetNextInvokation(
   long lngCurrentTicks
)
Managed Extensions for C++
int GetNextInvokation(
   long lngCurrentTicks
)
C++/CLI
int GetNextInvokation(
   long long lngCurrentTicks
)

Parameters

lngCurrentTicks

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ITimer Interface
ITimer Members


InvokeTimer Method

[image]
Gizmox.WebGUI.Common
InvokeTimer Method
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > ITimer Interface : InvokeTimer Method

Syntax

Visual Basic (Declaration)
Function InvokeTimer() As Integer
Visual Basic (Usage) Copy Code
Dim instance As ITimer
Dim value As Integer

value = instance.InvokeTimer()
C#
int InvokeTimer()
Managed Extensions for C++
int InvokeTimer();
C++/CLI
int InvokeTimer();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ITimer Interface
ITimer Members


ITimer Interface Properties

[image]
Gizmox.WebGUI.Common
ITimer Interface Properties
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : ITimer Interface

For a list of all members of this type, see ITimer members.

Public Properties

 | Name | Description
Property | Enabled |
Property | Interval |
Property | TimerID |
Top

See Also

Reference

ITimer Interface
Gizmox.WebGUI.Common.Interfaces Namespace


Enabled Property

[image]
Gizmox.WebGUI.Common
Enabled Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > ITimer Interface : Enabled Property

Syntax

Visual Basic (Declaration)
ReadOnly Property Enabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ITimer
Dim value As Boolean

value = instance.Enabled
C#
bool Enabled {get;}
Managed Extensions for C++
__property bool get_Enabled();
C++/CLI
property bool Enabled {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ITimer Interface
ITimer Members


Interval Property

[image]
Gizmox.WebGUI.Common
Interval Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > ITimer Interface : Interval Property

Syntax

Visual Basic (Declaration)
ReadOnly Property Interval As Integer
Visual Basic (Usage) Copy Code
Dim instance As ITimer
Dim value As Integer

value = instance.Interval
C#
int Interval {get;}
Managed Extensions for C++
__property int get_Interval();
C++/CLI
property int Interval {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ITimer Interface
ITimer Members


TimerID Property

[image]
Gizmox.WebGUI.Common
TimerID Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > ITimer Interface : TimerID Property

Syntax

Visual Basic (Declaration)
Property TimerID As Integer
Visual Basic (Usage) Copy Code
Dim instance As ITimer
Dim value As Integer

instance.TimerID = value

value = instance.TimerID
C#
int TimerID {get; set;}
Managed Extensions for C++
__property int get_TimerID();
__property void set_TimerID(
   int value
);
C++/CLI
property int TimerID {
   int get();
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ITimer Interface
ITimer Members


ITimerHandler Interface

[image]
Gizmox.WebGUI.Common
ITimerHandler Interface
Members See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : ITimerHandler Interface

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Interface ITimerHandler
Visual Basic (Usage) Copy Code
Dim instance As ITimerHandler
C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public interface ITimerHandler
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public __gc __interface ITimerHandler
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public interface class ITimerHandler

Requirements

Namespace: Gizmox.WebGUI.Common.Interfaces

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

ITimerHandler Members
Gizmox.WebGUI.Common.Interfaces Namespace


ITimerHandler Interface Members

[image]
Gizmox.WebGUI.Common
ITimerHandler Interface Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : ITimerHandler Interface

The following tables list the members exposed by ITimerHandler.

Public Properties

 | Name | Description
Property | HasTimers |
Top

Public Methods

 | Name | Description
Method | AddTimer |
Method | InvokeTimers |
Method | RemoveTimer |
Top

See Also

Reference

ITimerHandler Interface
Gizmox.WebGUI.Common.Interfaces Namespace


ITimerHandler Interface Methods

[image]
Gizmox.WebGUI.Common
ITimerHandler Interface Methods
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : ITimerHandler Interface

For a list of all members of this type, see ITimerHandler members.

Public Methods

 | Name | Description
Method | AddTimer |
Method | InvokeTimers |
Method | RemoveTimer |
Top

See Also

Reference

ITimerHandler Interface
Gizmox.WebGUI.Common.Interfaces Namespace


AddTimer Method

[image]
Gizmox.WebGUI.Common
AddTimer Method
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > ITimerHandler Interface : AddTimer Method

objTimer

Syntax

Visual Basic (Declaration)
Sub AddTimer( _
   ByVal objTimer As ITimer _
)
Visual Basic (Usage) Copy Code
Dim instance As ITimerHandler
Dim objTimer As ITimer

instance.AddTimer(objTimer)
C#
void AddTimer(
   ITimer objTimer
)
Managed Extensions for C++
void AddTimer(
   ITimer* objTimer
)
C++/CLI
void AddTimer(
   ITimer^ objTimer
)

Parameters

objTimer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ITimerHandler Interface
ITimerHandler Members


InvokeTimers Method

[image]
Gizmox.WebGUI.Common
InvokeTimers Method
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > ITimerHandler Interface : InvokeTimers Method

lngCurrentTicks

Syntax

Visual Basic (Declaration)
Function InvokeTimers( _
   ByVal lngCurrentTicks As Long _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As ITimerHandler
Dim lngCurrentTicks As Long
Dim value As Integer

value = instance.InvokeTimers(lngCurrentTicks)
C#
int InvokeTimers(
   long lngCurrentTicks
)
Managed Extensions for C++
int InvokeTimers(
   long lngCurrentTicks
)
C++/CLI
int InvokeTimers(
   long long lngCurrentTicks
)

Parameters

lngCurrentTicks

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ITimerHandler Interface
ITimerHandler Members


RemoveTimer Method

[image]
Gizmox.WebGUI.Common
RemoveTimer Method
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > ITimerHandler Interface : RemoveTimer Method

objTimer

Syntax

Visual Basic (Declaration)
Sub RemoveTimer( _
   ByVal objTimer As ITimer _
)
Visual Basic (Usage) Copy Code
Dim instance As ITimerHandler
Dim objTimer As ITimer

instance.RemoveTimer(objTimer)
C#
void RemoveTimer(
   ITimer objTimer
)
Managed Extensions for C++
void RemoveTimer(
   ITimer* objTimer
)
C++/CLI
void RemoveTimer(
   ITimer^ objTimer
)

Parameters

objTimer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ITimerHandler Interface
ITimerHandler Members


ITimerHandler Interface Properties

[image]
Gizmox.WebGUI.Common
ITimerHandler Interface Properties
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : ITimerHandler Interface

For a list of all members of this type, see ITimerHandler members.

Public Properties

 | Name | Description
Property | HasTimers |
Top

See Also

Reference

ITimerHandler Interface
Gizmox.WebGUI.Common.Interfaces Namespace


HasTimers Property

[image]
Gizmox.WebGUI.Common
HasTimers Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > ITimerHandler Interface : HasTimers Property

Syntax

Visual Basic (Declaration)
ReadOnly Property HasTimers As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ITimerHandler
Dim value As Boolean

value = instance.HasTimers
C#
bool HasTimers {get;}
Managed Extensions for C++
__property bool get_HasTimers();
C++/CLI
property bool HasTimers {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ITimerHandler Interface
ITimerHandler Members


ITimerHandlerContainer Interface

[image]
Gizmox.WebGUI.Common
ITimerHandlerContainer Interface
Members See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : ITimerHandlerContainer Interface

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Interface ITimerHandlerContainer
Visual Basic (Usage) Copy Code
Dim instance As ITimerHandlerContainer
C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public interface ITimerHandlerContainer
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public __gc __interface ITimerHandlerContainer
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public interface class ITimerHandlerContainer

Requirements

Namespace: Gizmox.WebGUI.Common.Interfaces

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

ITimerHandlerContainer Members
Gizmox.WebGUI.Common.Interfaces Namespace


ITimerHandlerContainer Interface Members

[image]
Gizmox.WebGUI.Common
ITimerHandlerContainer Interface Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : ITimerHandlerContainer Interface

The following tables list the members exposed by ITimerHandlerContainer.

Public Properties

 | Name | Description
Property | HasTimers |
Property | Timers |
Top

Public Methods

 | Name | Description
Method | InvokeTimers |
Top

See Also

Reference

ITimerHandlerContainer Interface
Gizmox.WebGUI.Common.Interfaces Namespace


ITimerHandlerContainer Interface Methods

[image]
Gizmox.WebGUI.Common
ITimerHandlerContainer Interface Methods
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : ITimerHandlerContainer Interface

For a list of all members of this type, see ITimerHandlerContainer members.

Public Methods

 | Name | Description
Method | InvokeTimers |
Top

See Also

Reference

ITimerHandlerContainer Interface
Gizmox.WebGUI.Common.Interfaces Namespace


InvokeTimers Method

[image]
Gizmox.WebGUI.Common
InvokeTimers Method
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > ITimerHandlerContainer Interface : InvokeTimers Method

lngCurrentTicks

Syntax

Visual Basic (Declaration)
Function InvokeTimers( _
   ByVal lngCurrentTicks As Long _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As ITimerHandlerContainer
Dim lngCurrentTicks As Long
Dim value As Integer

value = instance.InvokeTimers(lngCurrentTicks)
C#
int InvokeTimers(
   long lngCurrentTicks
)
Managed Extensions for C++
int InvokeTimers(
   long lngCurrentTicks
)
C++/CLI
int InvokeTimers(
   long long lngCurrentTicks
)

Parameters

lngCurrentTicks

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ITimerHandlerContainer Interface
ITimerHandlerContainer Members


ITimerHandlerContainer Interface Properties

[image]
Gizmox.WebGUI.Common
ITimerHandlerContainer Interface Properties
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : ITimerHandlerContainer Interface

For a list of all members of this type, see ITimerHandlerContainer members.

Public Properties

 | Name | Description
Property | HasTimers |
Property | Timers |
Top

See Also

Reference

ITimerHandlerContainer Interface
Gizmox.WebGUI.Common.Interfaces Namespace


HasTimers Property

[image]
Gizmox.WebGUI.Common
HasTimers Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > ITimerHandlerContainer Interface : HasTimers Property

Syntax

Visual Basic (Declaration)
ReadOnly Property HasTimers As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ITimerHandlerContainer
Dim value As Boolean

value = instance.HasTimers
C#
bool HasTimers {get;}
Managed Extensions for C++
__property bool get_HasTimers();
C++/CLI
property bool HasTimers {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ITimerHandlerContainer Interface
ITimerHandlerContainer Members


Timers Property

[image]
Gizmox.WebGUI.Common
Timers Property
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > ITimerHandlerContainer Interface : Timers Property

Syntax

Visual Basic (Declaration)
ReadOnly Property Timers As ITimerHandler
Visual Basic (Usage) Copy Code
Dim instance As ITimerHandlerContainer
Dim value As ITimerHandler

value = instance.Timers
C#
ITimerHandler Timers {get;}
Managed Extensions for C++
__property ITimerHandler* get_Timers();
C++/CLI
property ITimerHandler^ Timers {
   ITimerHandler^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ITimerHandlerContainer Interface
ITimerHandlerContainer Members


IUserControl Interface

[image]
Gizmox.WebGUI.Common
IUserControl Interface
Members See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IUserControl Interface

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Interface IUserControl
   Inherits IControl, IEventHandler, IRegisteredComponent
Visual Basic (Usage) Copy Code
Dim instance As IUserControl
C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public interface IUserControl : IControl, IEventHandler, IRegisteredComponent
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public __gc __interface IUserControl : public IControl, IEventHandler, IRegisteredComponent
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public interface class IUserControl : public IControl, IEventHandler, IRegisteredComponent

Requirements

Namespace: Gizmox.WebGUI.Common.Interfaces

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

IUserControl Members
Gizmox.WebGUI.Common.Interfaces Namespace


IUserControl Interface Members

[image]
Gizmox.WebGUI.Common
IUserControl Interface Members
See Also Methods Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IUserControl Interface

The following tables list the members exposed by IUserControl.

Public Methods

 | Name | Description
Method | SetContext |
Top

See Also

Reference

IUserControl Interface
Gizmox.WebGUI.Common.Interfaces Namespace


IUserControl Interface Methods

[image]
Gizmox.WebGUI.Common
IUserControl Interface Methods
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace : IUserControl Interface

For a list of all members of this type, see IUserControl members.

Public Methods

 | Name | Description
Method | SetContext |
Top

See Also

Reference

IUserControl Interface
Gizmox.WebGUI.Common.Interfaces Namespace


SetContext Method

[image]
Gizmox.WebGUI.Common
SetContext Method
See Also Send Feedback
Gizmox.WebGUI.Common.Interfaces Namespace > IUserControl Interface : SetContext Method

objContext

Syntax

Visual Basic (Declaration)
Sub SetContext( _
   ByVal objContext As IContext _
)
Visual Basic (Usage) Copy Code
Dim instance As IUserControl
Dim objContext As IContext

instance.SetContext(objContext)
C#
void SetContext(
   IContext objContext
)
Managed Extensions for C++
void SetContext(
   IContext* objContext
)
C++/CLI
void SetContext(
   IContext^ objContext
)

Parameters

objContext

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IUserControl Interface
IUserControl Members


Gizmox.WebGUI.Common.Resources Namespace

Gizmox.WebGUI.Common
Gizmox.WebGUI.Common.Resources Namespace
See Also Inheritance Hierarchy Send Feedback

Classes

 | Class | Description
Class | AssemblyResourceHandle |
Class | DatabaseResourceHandle |
Class | DataResourceHandle |
Class | FileHandle |
Class | FileHandleCollection |
Class | FileStreamHandle |
Class | GatewayResourceHandle |
Class | HttpPostedFileHandle |
Class | IconResourceHandle |
Class | ImageResourceHandle |
Class | PhysicalFileHandle |
Class | ResourceHandle |
Class | ResourceHandleConverter |
Class | ResourceManager |
Class | SkinResourceHandle |
Class | StaticGatewayResourceHandle |
Class | TypeResourceHandle |
Class | UrlResourceHandle |

See Also

Reference

Gizmox.WebGUI.Common Assembly


AssemblyResourceHandle Class

[image]
Gizmox.WebGUI.Common
AssemblyResourceHandle Class
Members See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace : AssemblyResourceHandle Class

Object Model

Syntax

Visual Basic (Declaration)
Public Class AssemblyResourceHandle
   Inherits ResourceHandle
Visual Basic (Usage) Copy Code
Dim instance As AssemblyResourceHandle
C#
public class AssemblyResourceHandle : ResourceHandle
Managed Extensions for C++
public __gc class AssemblyResourceHandle : public ResourceHandle
C++/CLI
public ref class AssemblyResourceHandle : public ResourceHandle

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Common.Resources.ResourceHandle
Gizmox.WebGUI.Common.Resources.AssemblyResourceHandle

Requirements

Namespace: Gizmox.WebGUI.Common.Resources

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

AssemblyResourceHandle Members
Gizmox.WebGUI.Common.Resources Namespace


AssemblyResourceHandle Class Members

[image]
Gizmox.WebGUI.Common
AssemblyResourceHandle Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Common.Resources Namespace : AssemblyResourceHandle Class

The following tables list the members exposed by AssemblyResourceHandle.

Public Constructors

 | Name | Description
Public Constructor | AssemblyResourceHandle Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Assembly |
Public Property | File | (Inherited from ResourceHandle)
Top

Protected Properties

 | Name | Description
Protected Property | Config | (Inherited from ResourceHandle)
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from ResourceHandle)
Public Method | ToIcon | (Inherited from ResourceHandle)
Public Method | ToImage | (Inherited from ResourceHandle)
Public Method | ToStream | Overridden.
Public Method | ToString | (Inherited from ResourceHandle)
Top

Protected Methods

 | Name | Description
Protected Method | GetSpecificResourceHandle | Overridden.
Top

See Also

Reference

AssemblyResourceHandle Class
Gizmox.WebGUI.Common.Resources Namespace


AssemblyResourceHandle Constructor

[image]
Gizmox.WebGUI.Common
AssemblyResourceHandle Constructor
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > AssemblyResourceHandle Class : AssemblyResourceHandle Constructor

Overload List

Overload | Description
AssemblyResourceHandle Constructor() |
AssemblyResourceHandle Constructor(Assembly,String) |
AssemblyResourceHandle Constructor(Type,String) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AssemblyResourceHandle Class
AssemblyResourceHandle Members


AssemblyResourceHandle Constructor()

[image]
Gizmox.WebGUI.Common
AssemblyResourceHandle Constructor()
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > AssemblyResourceHandle Class > AssemblyResourceHandle Constructor : AssemblyResourceHandle Constructor()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As AssemblyResourceHandle()
C#
public AssemblyResourceHandle()
Managed Extensions for C++
public: AssemblyResourceHandle();
C++/CLI
public:
AssemblyResourceHandle();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AssemblyResourceHandle Class
AssemblyResourceHandle Members
Overload List


AssemblyResourceHandle Constructor(Assembly,String)

[image]
Gizmox.WebGUI.Common
AssemblyResourceHandle Constructor(Assembly,String)
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > AssemblyResourceHandle Class > AssemblyResourceHandle Constructor : AssemblyResourceHandle Constructor(Assembly,String)

objAssembly
strFile

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal objAssembly As Assembly, _
   ByVal strFile As String _
)
Visual Basic (Usage) Copy Code
Dim objAssembly As Assembly
Dim strFile As String

Dim instance As AssemblyResourceHandle(objAssembly, strFile)
C#
public AssemblyResourceHandle(
   Assembly objAssembly,
   string strFile
)
Managed Extensions for C++
public: AssemblyResourceHandle(
   Assembly* objAssembly,
   string* strFile
)
C++/CLI
public:
AssemblyResourceHandle(
   Assembly^ objAssembly,
   String^ strFile
)

Parameters

objAssembly
strFile

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AssemblyResourceHandle Class
AssemblyResourceHandle Members
Overload List


AssemblyResourceHandle Constructor(Type,String)

[image]
Gizmox.WebGUI.Common
AssemblyResourceHandle Constructor(Type,String)
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > AssemblyResourceHandle Class > AssemblyResourceHandle Constructor : AssemblyResourceHandle Constructor(Type,String)

objType
strFile

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal objType As Type, _
   ByVal strFile As String _
)
Visual Basic (Usage) Copy Code
Dim objType As Type
Dim strFile As String

Dim instance As AssemblyResourceHandle(objType, strFile)
C#
public AssemblyResourceHandle(
   Type objType,
   string strFile
)
Managed Extensions for C++
public: AssemblyResourceHandle(
   Type* objType,
   string* strFile
)
C++/CLI
public:
AssemblyResourceHandle(
   Type^ objType,
   String^ strFile
)

Parameters

objType
strFile

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AssemblyResourceHandle Class
AssemblyResourceHandle Members
Overload List


AssemblyResourceHandle Class Methods

[image]
Gizmox.WebGUI.Common
AssemblyResourceHandle Class Methods
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace : AssemblyResourceHandle Class

For a list of all members of this type, see AssemblyResourceHandle members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from ResourceHandle)
Public Method | ToIcon | (Inherited from ResourceHandle)
Public Method | ToImage | (Inherited from ResourceHandle)
Public Method | ToStream | Overridden.
Public Method | ToString | (Inherited from ResourceHandle)
Top

Protected Methods

 | Name | Description
Protected Method | GetSpecificResourceHandle | Overridden.
Top

See Also

Reference

AssemblyResourceHandle Class
Gizmox.WebGUI.Common.Resources Namespace


GetSpecificResourceHandle Method

[image]
Gizmox.WebGUI.Common
GetSpecificResourceHandle Method
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > AssemblyResourceHandle Class : GetSpecificResourceHandle Method

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetSpecificResourceHandle() As String
Visual Basic (Usage) Copy Code
Dim instance As AssemblyResourceHandle
Dim value As String

value = instance.GetSpecificResourceHandle()
C#
protected override string GetSpecificResourceHandle()
Managed Extensions for C++
protected: string* GetSpecificResourceHandle(); override
C++/CLI
protected:
String^ GetSpecificResourceHandle(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AssemblyResourceHandle Class
AssemblyResourceHandle Members


ToStream Method

[image]
Gizmox.WebGUI.Common
ToStream Method
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > AssemblyResourceHandle Class : ToStream Method

Syntax

Visual Basic (Declaration)
Public Overrides Function ToStream() As Stream
Visual Basic (Usage) Copy Code
Dim instance As AssemblyResourceHandle
Dim value As Stream

value = instance.ToStream()
C#
public override Stream ToStream()
Managed Extensions for C++
public: Stream* ToStream(); override
C++/CLI
public:
Stream^ ToStream(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AssemblyResourceHandle Class
AssemblyResourceHandle Members


AssemblyResourceHandle Class Properties

[image]
Gizmox.WebGUI.Common
AssemblyResourceHandle Class Properties
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace : AssemblyResourceHandle Class

For a list of all members of this type, see AssemblyResourceHandle members.

Public Properties

 | Name | Description
Public Property | Assembly |
Public Property | File | (Inherited from ResourceHandle)
Top

Protected Properties

 | Name | Description
Protected Property | Config | (Inherited from ResourceHandle)
Top

See Also

Reference

AssemblyResourceHandle Class
Gizmox.WebGUI.Common.Resources Namespace


Assembly Property

[image]
Gizmox.WebGUI.Common
Assembly Property
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > AssemblyResourceHandle Class : Assembly Property

Syntax

Visual Basic (Declaration)
Public Property Assembly As Assembly
Visual Basic (Usage) Copy Code
Dim instance As AssemblyResourceHandle
Dim value As Assembly

instance.Assembly = value

value = instance.Assembly
C#
public Assembly Assembly {get; set;}
Managed Extensions for C++
public: __property Assembly* get_Assembly();
public: __property void set_Assembly(
   Assembly* value
);
C++/CLI
public:
property Assembly^ Assembly {
   Assembly^ get();
   void set (Assembly^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AssemblyResourceHandle Class
AssemblyResourceHandle Members


DatabaseResourceHandle Class

[image]
Gizmox.WebGUI.Common
DatabaseResourceHandle Class
Members See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace : DatabaseResourceHandle Class

Object Model

Syntax

Visual Basic (Declaration)
Public MustInherit Class DatabaseResourceHandle
   Inherits StaticGatewayResourceHandle
   Implements IStaticGateway
Visual Basic (Usage) Copy Code
Dim instance As DatabaseResourceHandle
C#
public abstract class DatabaseResourceHandle : StaticGatewayResourceHandle, IStaticGateway
Managed Extensions for C++
public __gc abstract class DatabaseResourceHandle : public StaticGatewayResourceHandle, IStaticGateway
C++/CLI
public ref class DatabaseResourceHandle abstract : public StaticGatewayResourceHandle, IStaticGateway

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Common.Resources.ResourceHandle
Gizmox.WebGUI.Common.Resources.StaticGatewayResourceHandle
Gizmox.WebGUI.Common.Resources.DatabaseResourceHandle

Requirements

Namespace: Gizmox.WebGUI.Common.Resources

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

DatabaseResourceHandle Members
Gizmox.WebGUI.Common.Resources Namespace


DatabaseResourceHandle Class Members

[image]
Gizmox.WebGUI.Common
DatabaseResourceHandle Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Common.Resources Namespace : DatabaseResourceHandle Class

The following tables list the members exposed by DatabaseResourceHandle.

Protected Properties

 | Name | Description
Protected Property | Cacheability |
Protected Property | Config | (Inherited from ResourceHandle)
Protected Property | ContentColumn |
Protected Property | ContentTypeColumn |
Protected Property | Context |
Protected Property | Expires |
Protected Property | Qualifier |
Protected Property | Token |
Protected Property | UseAuthentication |
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from ResourceHandle)
Top

Protected Methods

 | Name | Description
Protected Method | Authenticate |
Protected Method | GetConnection |
Protected Method | GetDataReader |
Protected Method | GetUniqueName |
Protected Method | Write |
Protected Method | WriteCacheHeaders |
Protected Method | WriteContent |
Protected Method | WriteContentType |
Top

See Also

Reference

DatabaseResourceHandle Class
Gizmox.WebGUI.Common.Resources Namespace


DatabaseResourceHandle Class Methods

[image]
Gizmox.WebGUI.Common
DatabaseResourceHandle Class Methods
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace : DatabaseResourceHandle Class

For a list of all members of this type, see DatabaseResourceHandle members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from ResourceHandle)
Top

Protected Methods

 | Name | Description
Protected Method | Authenticate |
Protected Method | GetConnection |
Protected Method | GetDataReader |
Protected Method | GetUniqueName |
Protected Method | Write |
Protected Method | WriteCacheHeaders |
Protected Method | WriteContent |
Protected Method | WriteContentType |
Top

See Also

Reference

DatabaseResourceHandle Class
Gizmox.WebGUI.Common.Resources Namespace


Authenticate Method

[image]
Gizmox.WebGUI.Common
Authenticate Method
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > DatabaseResourceHandle Class : Authenticate Method

objConnection
strToken

Syntax

Visual Basic (Declaration)
Protected Overridable Sub Authenticate( _
   ByVal objConnection As IDbConnection, _
   ByVal strToken As String _
)
Visual Basic (Usage) Copy Code
Dim instance As DatabaseResourceHandle
Dim objConnection As IDbConnection
Dim strToken As String

instance.Authenticate(objConnection, strToken)
C#
protected virtual void Authenticate(
   IDbConnection objConnection,
   string strToken
)
Managed Extensions for C++
protected: virtual void Authenticate(
   IDbConnection* objConnection,
   string* strToken
)
C++/CLI
protected:
virtual void Authenticate(
   IDbConnection^ objConnection,
   String^ strToken
)

Parameters

objConnection
strToken

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DatabaseResourceHandle Class
DatabaseResourceHandle Members


GetConnection Method

[image]
Gizmox.WebGUI.Common
GetConnection Method
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > DatabaseResourceHandle Class : GetConnection Method

Syntax

Visual Basic (Declaration)
Protected MustOverride Function GetConnection() As IDbConnection
Visual Basic (Usage) Copy Code
Dim instance As DatabaseResourceHandle
Dim value As IDbConnection

value = instance.GetConnection()
C#
protected abstract IDbConnection GetConnection()
Managed Extensions for C++
protected: abstract IDbConnection* GetConnection();
C++/CLI
protected:
abstract IDbConnection^ GetConnection();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DatabaseResourceHandle Class
DatabaseResourceHandle Members


GetDataReader Method

[image]
Gizmox.WebGUI.Common
GetDataReader Method
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > DatabaseResourceHandle Class : GetDataReader Method

objConnection
strQualifier

Syntax

Visual Basic (Declaration)
Protected MustOverride Function GetDataReader( _
   ByVal objConnection As IDbConnection, _
   ByVal strQualifier As String _
) As IDataReader
Visual Basic (Usage) Copy Code
Dim instance As DatabaseResourceHandle
Dim objConnection As IDbConnection
Dim strQualifier As String
Dim value As IDataReader

value = instance.GetDataReader(objConnection, strQualifier)
C#
protected abstract IDataReader GetDataReader(
   IDbConnection objConnection,
   string strQualifier
)
Managed Extensions for C++
protected: abstract IDataReader* GetDataReader(
   IDbConnection* objConnection,
   string* strQualifier
)
C++/CLI
protected:
abstract IDataReader^ GetDataReader(
   IDbConnection^ objConnection,
   String^ strQualifier
)

Parameters

objConnection
strQualifier

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DatabaseResourceHandle Class
DatabaseResourceHandle Members


GetUniqueName Method

[image]
Gizmox.WebGUI.Common
GetUniqueName Method
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > DatabaseResourceHandle Class : GetUniqueName Method

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetUniqueName() As String
Visual Basic (Usage) Copy Code
Dim instance As DatabaseResourceHandle
Dim value As String

value = instance.GetUniqueName()
C#
protected virtual string GetUniqueName()
Managed Extensions for C++
protected: virtual string* GetUniqueName();
C++/CLI
protected:
virtual String^ GetUniqueName();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DatabaseResourceHandle Class
DatabaseResourceHandle Members


Write Method

[image]
Gizmox.WebGUI.Common
Write Method
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > DatabaseResourceHandle Class : Write Method

objResponse
objDataReader

Syntax

Visual Basic (Declaration)
Protected Overridable Sub Write( _
   ByVal objResponse As HttpResponse, _
   ByVal objDataReader As IDataReader _
)
Visual Basic (Usage) Copy Code
Dim instance As DatabaseResourceHandle
Dim objResponse As HttpResponse
Dim objDataReader As IDataReader

instance.Write(objResponse, objDataReader)
C#
protected virtual void Write(
   HttpResponse objResponse,
   IDataReader objDataReader
)
Managed Extensions for C++
protected: virtual void Write(
   HttpResponse* objResponse,
   IDataReader* objDataReader
)
C++/CLI
protected:
virtual void Write(
   HttpResponse^ objResponse,
   IDataReader^ objDataReader
)

Parameters

objResponse
objDataReader

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DatabaseResourceHandle Class
DatabaseResourceHandle Members


WriteCacheHeaders Method

[image]
Gizmox.WebGUI.Common
WriteCacheHeaders Method
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > DatabaseResourceHandle Class : WriteCacheHeaders Method

objResponse

Syntax

Visual Basic (Declaration)
Protected Overridable Sub WriteCacheHeaders( _
   ByVal objResponse As HttpResponse _
)
Visual Basic (Usage) Copy Code
Dim instance As DatabaseResourceHandle
Dim objResponse As HttpResponse

instance.WriteCacheHeaders(objResponse)
C#
protected virtual void WriteCacheHeaders(
   HttpResponse objResponse
)
Managed Extensions for C++
protected: virtual void WriteCacheHeaders(
   HttpResponse* objResponse
)
C++/CLI
protected:
virtual void WriteCacheHeaders(
   HttpResponse^ objResponse
)

Parameters

objResponse

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DatabaseResourceHandle Class
DatabaseResourceHandle Members


WriteContent Method

[image]
Gizmox.WebGUI.Common
WriteContent Method
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > DatabaseResourceHandle Class : WriteContent Method

objResponse
objDataReader

Syntax

Visual Basic (Declaration)
Protected Overridable Sub WriteContent( _
   ByVal objResponse As HttpResponse, _
   ByVal objDataReader As IDataReader _
)
Visual Basic (Usage) Copy Code
Dim instance As DatabaseResourceHandle
Dim objResponse As HttpResponse
Dim objDataReader As IDataReader

instance.WriteContent(objResponse, objDataReader)
C#
protected virtual void WriteContent(
   HttpResponse objResponse,
   IDataReader objDataReader
)
Managed Extensions for C++
protected: virtual void WriteContent(
   HttpResponse* objResponse,
   IDataReader* objDataReader
)
C++/CLI
protected:
virtual void WriteContent(
   HttpResponse^ objResponse,
   IDataReader^ objDataReader
)

Parameters

objResponse
objDataReader

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DatabaseResourceHandle Class
DatabaseResourceHandle Members


WriteContentType Method

[image]
Gizmox.WebGUI.Common
WriteContentType Method
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > DatabaseResourceHandle Class : WriteContentType Method

objResponse
objDataReader

Syntax

Visual Basic (Declaration)
Protected Overridable Sub WriteContentType( _
   ByVal objResponse As HttpResponse, _
   ByVal objDataReader As IDataReader _
)
Visual Basic (Usage) Copy Code
Dim instance As DatabaseResourceHandle
Dim objResponse As HttpResponse
Dim objDataReader As IDataReader

instance.WriteContentType(objResponse, objDataReader)
C#
protected virtual void WriteContentType(
   HttpResponse objResponse,
   IDataReader objDataReader
)
Managed Extensions for C++
protected: virtual void WriteContentType(
   HttpResponse* objResponse,
   IDataReader* objDataReader
)
C++/CLI
protected:
virtual void WriteContentType(
   HttpResponse^ objResponse,
   IDataReader^ objDataReader
)

Parameters

objResponse
objDataReader

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DatabaseResourceHandle Class
DatabaseResourceHandle Members


DatabaseResourceHandle Class Properties

[image]
Gizmox.WebGUI.Common
DatabaseResourceHandle Class Properties
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace : DatabaseResourceHandle Class

For a list of all members of this type, see DatabaseResourceHandle members.

Protected Properties

 | Name | Description
Protected Property | Cacheability |
Protected Property | Config | (Inherited from ResourceHandle)
Protected Property | ContentColumn |
Protected Property | ContentTypeColumn |
Protected Property | Context |
Protected Property | Expires |
Protected Property | Qualifier |
Protected Property | Token |
Protected Property | UseAuthentication |
Top

See Also

Reference

DatabaseResourceHandle Class
Gizmox.WebGUI.Common.Resources Namespace


Cacheability Property

[image]
Gizmox.WebGUI.Common
Cacheability Property
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > DatabaseResourceHandle Class : Cacheability Property

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property Cacheability As HttpCacheability
Visual Basic (Usage) Copy Code
Dim instance As DatabaseResourceHandle
Dim value As HttpCacheability

value = instance.Cacheability
C#
protected virtual HttpCacheability Cacheability {get;}
Managed Extensions for C++
protected: __property virtual HttpCacheability get_Cacheability();
C++/CLI
protected:
virtual property HttpCacheability Cacheability {
   HttpCacheability get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DatabaseResourceHandle Class
DatabaseResourceHandle Members


ContentColumn Property

[image]
Gizmox.WebGUI.Common
ContentColumn Property
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > DatabaseResourceHandle Class : ContentColumn Property

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property ContentColumn As String
Visual Basic (Usage) Copy Code
Dim instance As DatabaseResourceHandle
Dim value As String

value = instance.ContentColumn
C#
protected virtual string ContentColumn {get;}
Managed Extensions for C++
protected: __property virtual string* get_ContentColumn();
C++/CLI
protected:
virtual property String^ ContentColumn {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DatabaseResourceHandle Class
DatabaseResourceHandle Members


ContentTypeColumn Property

[image]
Gizmox.WebGUI.Common
ContentTypeColumn Property
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > DatabaseResourceHandle Class : ContentTypeColumn Property

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property ContentTypeColumn As String
Visual Basic (Usage) Copy Code
Dim instance As DatabaseResourceHandle
Dim value As String

value = instance.ContentTypeColumn
C#
protected virtual string ContentTypeColumn {get;}
Managed Extensions for C++
protected: __property virtual string* get_ContentTypeColumn();
C++/CLI
protected:
virtual property String^ ContentTypeColumn {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DatabaseResourceHandle Class
DatabaseResourceHandle Members


Context Property

[image]
Gizmox.WebGUI.Common
Context Property
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > DatabaseResourceHandle Class : Context Property

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property Context As IContext
Visual Basic (Usage) Copy Code
Dim instance As DatabaseResourceHandle
Dim value As IContext

value = instance.Context
C#
protected IContext Context {get;}
Managed Extensions for C++
protected: __property IContext* get_Context();
C++/CLI
protected:
property IContext^ Context {
   IContext^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DatabaseResourceHandle Class
DatabaseResourceHandle Members


Expires Property

[image]
Gizmox.WebGUI.Common
Expires Property
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > DatabaseResourceHandle Class : Expires Property

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property Expires As Integer
Visual Basic (Usage) Copy Code
Dim instance As DatabaseResourceHandle
Dim value As Integer

value = instance.Expires
C#
protected virtual int Expires {get;}
Managed Extensions for C++
protected: __property virtual int get_Expires();
C++/CLI
protected:
virtual property int Expires {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DatabaseResourceHandle Class
DatabaseResourceHandle Members


Qualifier Property

[image]
Gizmox.WebGUI.Common
Qualifier Property
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > DatabaseResourceHandle Class : Qualifier Property

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property Qualifier As String
Visual Basic (Usage) Copy Code
Dim instance As DatabaseResourceHandle
Dim value As String

value = instance.Qualifier
C#
protected string Qualifier {get;}
Managed Extensions for C++
protected: __property string* get_Qualifier();
C++/CLI
protected:
property String^ Qualifier {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DatabaseResourceHandle Class
DatabaseResourceHandle Members


Token Property

[image]
Gizmox.WebGUI.Common
Token Property
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > DatabaseResourceHandle Class : Token Property

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property Token As String
Visual Basic (Usage) Copy Code
Dim instance As DatabaseResourceHandle
Dim value As String

value = instance.Token
C#
protected string Token {get;}
Managed Extensions for C++
protected: __property string* get_Token();
C++/CLI
protected:
property String^ Token {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DatabaseResourceHandle Class
DatabaseResourceHandle Members


UseAuthentication Property

[image]
Gizmox.WebGUI.Common
UseAuthentication Property
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > DatabaseResourceHandle Class : UseAuthentication Property

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property UseAuthentication As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DatabaseResourceHandle
Dim value As Boolean

value = instance.UseAuthentication
C#
protected virtual bool UseAuthentication {get;}
Managed Extensions for C++
protected: __property virtual bool get_UseAuthentication();
C++/CLI
protected:
virtual property bool UseAuthentication {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DatabaseResourceHandle Class
DatabaseResourceHandle Members


DataResourceHandle Class

[image]
Gizmox.WebGUI.Common
DataResourceHandle Class
Members See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace : DataResourceHandle Class

Object Model

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("The DataResourceHandle is Obsolete. You should replace it with other ResourceHandles like Icon, Image, Url or Gateway")>
Public Class DataResourceHandle
   Inherits ResourceHandle
Visual Basic (Usage) Copy Code
Dim instance As DataResourceHandle
C#
[ObsoleteAttribute("The DataResourceHandle is Obsolete. You should replace it with other ResourceHandles like Icon, Image, Url or Gateway")]
public class DataResourceHandle : ResourceHandle
Managed Extensions for C++
[ObsoleteAttribute("The DataResourceHandle is Obsolete. You should replace it with other ResourceHandles like Icon, Image, Url or Gateway")]
public __gc class DataResourceHandle : public ResourceHandle
C++/CLI
[ObsoleteAttribute("The DataResourceHandle is Obsolete. You should replace it with other ResourceHandles like Icon, Image, Url or Gateway")]
public ref class DataResourceHandle : public ResourceHandle

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Common.Resources.ResourceHandle
Gizmox.WebGUI.Common.Resources.DataResourceHandle

Requirements

Namespace: Gizmox.WebGUI.Common.Resources

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

DataResourceHandle Members
Gizmox.WebGUI.Common.Resources Namespace


DataResourceHandle Class Members

[image]
Gizmox.WebGUI.Common
DataResourceHandle Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Common.Resources Namespace : DataResourceHandle Class

The following tables list the members exposed by DataResourceHandle.

Public Constructors

 | Name | Description
Public Constructor | DataResourceHandle Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | File | (Inherited from ResourceHandle)
Top

Protected Properties

 | Name | Description
Protected Property | Config | (Inherited from ResourceHandle)
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from ResourceHandle)
Public Method | ToIcon | (Inherited from ResourceHandle)
Public Method | ToImage | (Inherited from ResourceHandle)
Public Method | ToStream | Overridden.
Public Method | ToString | (Inherited from ResourceHandle)
Top

Protected Methods

 | Name | Description
Protected Method | GetSpecificResourceHandle | Overridden.
Top

See Also

Reference

DataResourceHandle Class
Gizmox.WebGUI.Common.Resources Namespace


DataResourceHandle Constructor

[image]
Gizmox.WebGUI.Common
DataResourceHandle Constructor
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > DataResourceHandle Class : DataResourceHandle Constructor

Overload List

Overload | Description
DataResourceHandle Constructor() |
DataResourceHandle Constructor(String) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataResourceHandle Class
DataResourceHandle Members


DataResourceHandle Constructor()

[image]
Gizmox.WebGUI.Common
DataResourceHandle Constructor()
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > DataResourceHandle Class > DataResourceHandle Constructor : DataResourceHandle Constructor()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As DataResourceHandle()
C#
public DataResourceHandle()
Managed Extensions for C++
public: DataResourceHandle();
C++/CLI
public:
DataResourceHandle();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataResourceHandle Class
DataResourceHandle Members
Overload List


DataResourceHandle Constructor(String)

[image]
Gizmox.WebGUI.Common
DataResourceHandle Constructor(String)
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > DataResourceHandle Class > DataResourceHandle Constructor : DataResourceHandle Constructor(String)

strFile

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal strFile As String _
)
Visual Basic (Usage) Copy Code
Dim strFile As String

Dim instance As DataResourceHandle(strFile)
C#
public DataResourceHandle(
   string strFile
)
Managed Extensions for C++
public: DataResourceHandle(
   string* strFile
)
C++/CLI
public:
DataResourceHandle(
   String^ strFile
)

Parameters

strFile

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataResourceHandle Class
DataResourceHandle Members
Overload List


DataResourceHandle Class Methods

[image]
Gizmox.WebGUI.Common
DataResourceHandle Class Methods
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace : DataResourceHandle Class

For a list of all members of this type, see DataResourceHandle members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from ResourceHandle)
Public Method | ToIcon | (Inherited from ResourceHandle)
Public Method | ToImage | (Inherited from ResourceHandle)
Public Method | ToStream | Overridden.
Public Method | ToString | (Inherited from ResourceHandle)
Top

Protected Methods

 | Name | Description
Protected Method | GetSpecificResourceHandle | Overridden.
Top

See Also

Reference

DataResourceHandle Class
Gizmox.WebGUI.Common.Resources Namespace


GetSpecificResourceHandle Method

[image]
Gizmox.WebGUI.Common
GetSpecificResourceHandle Method
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > DataResourceHandle Class : GetSpecificResourceHandle Method

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetSpecificResourceHandle() As String
Visual Basic (Usage) Copy Code
Dim instance As DataResourceHandle
Dim value As String

value = instance.GetSpecificResourceHandle()
C#
protected override string GetSpecificResourceHandle()
Managed Extensions for C++
protected: string* GetSpecificResourceHandle(); override
C++/CLI
protected:
String^ GetSpecificResourceHandle(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataResourceHandle Class
DataResourceHandle Members


ToStream Method

[image]
Gizmox.WebGUI.Common
ToStream Method
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > DataResourceHandle Class : ToStream Method

Syntax

Visual Basic (Declaration)
Public Overrides Function ToStream() As Stream
Visual Basic (Usage) Copy Code
Dim instance As DataResourceHandle
Dim value As Stream

value = instance.ToStream()
C#
public override Stream ToStream()
Managed Extensions for C++
public: Stream* ToStream(); override
C++/CLI
public:
Stream^ ToStream(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataResourceHandle Class
DataResourceHandle Members


FileHandle Class

[image]
Gizmox.WebGUI.Common
FileHandle Class
Members See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace : FileHandle Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class FileHandle
Visual Basic (Usage) Copy Code
Dim instance As FileHandle
C#
public abstract class FileHandle
Managed Extensions for C++
public __gc abstract class FileHandle
C++/CLI
public ref class FileHandle abstract

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Common.Resources.FileHandle
Gizmox.WebGUI.Common.Resources.FileStreamHandle
Gizmox.WebGUI.Common.Resources.HttpPostedFileHandle
Gizmox.WebGUI.Common.Resources.PhysicalFileHandle

Requirements

Namespace: Gizmox.WebGUI.Common.Resources

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

FileHandle Members
Gizmox.WebGUI.Common.Resources Namespace


FileHandle Class Members

[image]
Gizmox.WebGUI.Common
FileHandle Class Members
See Also Fields Properties Methods Send Feedback
Gizmox.WebGUI.Common.Resources Namespace : FileHandle Class

The following tables list the members exposed by FileHandle.

Protected Fields

 | Name | Description
Protected Field | InternalStream |
Top

Public Properties

 | Name | Description
Public Property | ContentLength |
Public Property | ContentType |
Public Property | FileName |
Public Property | InputStream |
Top

Public Methods

 | Name | Description
Public Method | Close |
Public Method | Dispose | Overloaded.
Public Method | SaveAs |
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | Overridden.
Top

See Also

Reference

FileHandle Class
Gizmox.WebGUI.Common.Resources Namespace


FileHandle Class Methods

[image]
Gizmox.WebGUI.Common
FileHandle Class Methods
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace : FileHandle Class

For a list of all members of this type, see FileHandle members.

Public Methods

 | Name | Description
Public Method | Close |
Public Method | Dispose | Overloaded.
Public Method | SaveAs |
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | Overridden.
Top

See Also

Reference

FileHandle Class
Gizmox.WebGUI.Common.Resources Namespace


Close Method

[image]
Gizmox.WebGUI.Common
Close Method
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > FileHandle Class : Close Method

Syntax

Visual Basic (Declaration)
Public Overridable Sub Close()
Visual Basic (Usage) Copy Code
Dim instance As FileHandle

instance.Close()
C#
public virtual void Close()
Managed Extensions for C++
public: virtual void Close();
C++/CLI
public:
virtual void Close();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FileHandle Class
FileHandle Members


Dispose Method

[image]
Gizmox.WebGUI.Common
Dispose Method
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > FileHandle Class : Dispose Method

Overload List

Overload | Description
Dispose() |
Dispose(Boolean) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FileHandle Class
FileHandle Members


Dispose() Method

[image]
Gizmox.WebGUI.Common
Dispose() Method
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > FileHandle Class > Dispose Method : Dispose() Method

Syntax

Visual Basic (Declaration)
Public Overloads Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As FileHandle

instance.Dispose()
C#
public void Dispose()
Managed Extensions for C++
public: void Dispose();
C++/CLI
public:
void Dispose();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FileHandle Class
FileHandle Members
Overload List


Dispose(Boolean) Method

[image]
Gizmox.WebGUI.Common
Dispose(Boolean) Method
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > FileHandle Class > Dispose Method : Dispose(Boolean) Method

disposing

Syntax

Visual Basic (Declaration)
Protected Overloads Overridable Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As FileHandle
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected virtual void Dispose(
   bool disposing
)
Managed Extensions for C++
protected: virtual void Dispose(
   bool disposing
)
C++/CLI
protected:
virtual void Dispose(
   bool disposing
)

Parameters

disposing

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FileHandle Class
FileHandle Members
Overload List


Finalize Method

[image]
Gizmox.WebGUI.Common
Finalize Method
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > FileHandle Class : Finalize Method

Syntax

Visual Basic (Declaration)
Protected Overrides Sub Finalize()
Visual Basic (Usage) Copy Code
Dim instance As FileHandle

instance.Finalize()
C#
protected override void Finalize()
Managed Extensions for C++
protected: void Finalize(); override
C++/CLI
protected:
void Finalize(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FileHandle Class
FileHandle Members


SaveAs Method

[image]
Gizmox.WebGUI.Common
SaveAs Method
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > FileHandle Class : SaveAs Method

filename

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveAs( _
   ByVal filename As String _
)
Visual Basic (Usage) Copy Code
Dim instance As FileHandle
Dim filename As String

instance.SaveAs(filename)
C#
public virtual void SaveAs(
   string filename
)
Managed Extensions for C++
public: virtual void SaveAs(
   string* filename
)
C++/CLI
public:
virtual void SaveAs(
   String^ filename
)

Parameters

filename

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FileHandle Class
FileHandle Members


FileHandle Class Properties

[image]
Gizmox.WebGUI.Common
FileHandle Class Properties
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace : FileHandle Class

For a list of all members of this type, see FileHandle members.

Public Properties

 | Name | Description
Public Property | ContentLength |
Public Property | ContentType |
Public Property | FileName |
Public Property | InputStream |
Top

See Also

Reference

FileHandle Class
Gizmox.WebGUI.Common.Resources Namespace


ContentLength Property

[image]
Gizmox.WebGUI.Common
ContentLength Property
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > FileHandle Class : ContentLength Property

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property ContentLength As Long
Visual Basic (Usage) Copy Code
Dim instance As FileHandle
Dim value As Long

value = instance.ContentLength
C#
public abstract long ContentLength {get;}
Managed Extensions for C++
public: __property abstract long get_ContentLength();
C++/CLI
public:
abstract property long long ContentLength {
   long long get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FileHandle Class
FileHandle Members


ContentType Property

[image]
Gizmox.WebGUI.Common
ContentType Property
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > FileHandle Class : ContentType Property

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property ContentType As String
Visual Basic (Usage) Copy Code
Dim instance As FileHandle
Dim value As String

value = instance.ContentType
C#
public virtual string ContentType {get;}
Managed Extensions for C++
public: __property virtual string* get_ContentType();
C++/CLI
public:
virtual property String^ ContentType {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FileHandle Class
FileHandle Members


FileName Property

[image]
Gizmox.WebGUI.Common
FileName Property
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > FileHandle Class : FileName Property

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property FileName As String
Visual Basic (Usage) Copy Code
Dim instance As FileHandle
Dim value As String

value = instance.FileName
C#
public abstract string FileName {get;}
Managed Extensions for C++
public: __property abstract string* get_FileName();
C++/CLI
public:
abstract property String^ FileName {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FileHandle Class
FileHandle Members


InputStream Property

[image]
Gizmox.WebGUI.Common
InputStream Property
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > FileHandle Class : InputStream Property

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property InputStream As Stream
Visual Basic (Usage) Copy Code
Dim instance As FileHandle
Dim value As Stream

value = instance.InputStream
C#
public abstract Stream InputStream {get;}
Managed Extensions for C++
public: __property abstract Stream* get_InputStream();
C++/CLI
public:
abstract property Stream^ InputStream {
   Stream^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FileHandle Class
FileHandle Members


FileHandle Class Fields

[image]
Gizmox.WebGUI.Common
FileHandle Class Fields
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace : FileHandle Class

For a list of all members of this type, see FileHandle members.

Protected Fields

 | Name | Description
Protected Field | InternalStream |
Top

See Also

Reference

FileHandle Class
Gizmox.WebGUI.Common.Resources Namespace


InternalStream Field

[image]
Gizmox.WebGUI.Common
InternalStream Field
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > FileHandle Class : InternalStream Field

Syntax

Visual Basic (Declaration)
Protected InternalStream As Stream
Visual Basic (Usage) Copy Code
Dim instance As FileHandle
Dim value As Stream

value = instance.InternalStream

instance.InternalStream = value
C#
protected Stream InternalStream
Managed Extensions for C++
protected: Stream* InternalStream
C++/CLI
protected:
Stream^ InternalStream

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FileHandle Class
FileHandle Members


FileHandleCollection Class

[image]
Gizmox.WebGUI.Common
FileHandleCollection Class
Members See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace : FileHandleCollection Class

Object Model

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class FileHandleCollection
   Inherits NameObjectCollectionBase
Visual Basic (Usage) Copy Code
Dim instance As FileHandleCollection
C#
[DefaultMemberAttribute("Item")]
public class FileHandleCollection : NameObjectCollectionBase
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
public __gc class FileHandleCollection : public NameObjectCollectionBase
C++/CLI
[DefaultMemberAttribute("Item")]
public ref class FileHandleCollection : public NameObjectCollectionBase

Inheritance Hierarchy

System.Object
System.Collections.Specialized.NameObjectCollectionBase
Gizmox.WebGUI.Common.Resources.FileHandleCollection

Requirements

Namespace: Gizmox.WebGUI.Common.Resources

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

FileHandleCollection Members
Gizmox.WebGUI.Common.Resources Namespace


FileHandleCollection Class Members

[image]
Gizmox.WebGUI.Common
FileHandleCollection Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Common.Resources Namespace : FileHandleCollection Class

The following tables list the members exposed by FileHandleCollection.

Public Constructors

 | Name | Description
Public Constructor | FileHandleCollection Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | AllKeys |
Public Property | Count | Gets the number of key/value pairs contained in the NameObjectCollectionBase instance. (Inherited from System.Collections.Specialized.NameObjectCollectionBase)
Public Property | Item | Overloaded.
Public Property | Keys | Gets a KeysCollection instance that contains all the keys in the NameObjectCollectionBase instance. (Inherited from System.Collections.Specialized.NameObjectCollectionBase)
Top

Protected Properties

 | Name | Description
Protected Property | IsReadOnly | Gets or sets a value indicating whether the NameObjectCollectionBase instance is read-only. (Inherited from System.Collections.Specialized.NameObjectCollectionBase)
Top

Public Methods

 | Name | Description
Public Method | Add |
Public Method | Clear |
Public Method | GetEnumerator | Returns an enumerator that iterates through the NameObjectCollectionBase. (Inherited from System.Collections.Specialized.NameObjectCollectionBase)
Public Method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the NameObjectCollectionBase instance. (Inherited from System.Collections.Specialized.NameObjectCollectionBase)
Public Method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from System.Collections.Specialized.NameObjectCollectionBase)
Top

Protected Methods

 | Name | Description
Protected Method | BaseAdd | Adds an entry with the specified key and value into the NameObjectCollectionBase instance. (Inherited from System.Collections.Specialized.NameObjectCollectionBase)
Protected Method | BaseClear | Removes all entries from the NameObjectCollectionBase instance. (Inherited from System.Collections.Specialized.NameObjectCollectionBase)
Protected Method | BaseGet | Overloaded. Gets the value of the first entry with the specified key from the NameObjectCollectionBase instance. (Inherited from System.Collections.Specialized.NameObjectCollectionBase)
Protected Method | BaseGetAllKeys | Returns a String array that contains all the keys in the NameObjectCollectionBase instance. (Inherited from System.Collections.Specialized.NameObjectCollectionBase)
Protected Method | BaseGetAllValues | Overloaded. Returns an Object array that contains all the values in the NameObjectCollectionBase instance. (Inherited from System.Collections.Specialized.NameObjectCollectionBase)
Protected Method | BaseGetKey | Gets the key of the entry at the specified index of the NameObjectCollectionBase instance. (Inherited from System.Collections.Specialized.NameObjectCollectionBase)
Protected Method | BaseHasKeys | Gets a value indicating whether the NameObjectCollectionBase instance contains entries whose keys are not null. (Inherited from System.Collections.Specialized.NameObjectCollectionBase)
Protected Method | BaseRemove | Removes the entries with the specified key from the NameObjectCollectionBase instance. (Inherited from System.Collections.Specialized.NameObjectCollectionBase)
Protected Method | BaseRemoveAt | Removes the entry at the specified index of the NameObjectCollectionBase instance. (Inherited from System.Collections.Specialized.NameObjectCollectionBase)
Protected Method | BaseSet | Overloaded. Sets the value of the first entry with the specified key in the NameObjectCollectionBase instance, if found; otherwise, adds an entry with the specified key and value into the NameObjectCollectionBase instance. (Inherited from System.Collections.Specialized.NameObjectCollectionBase)
Top

See Also

Reference

FileHandleCollection Class
Gizmox.WebGUI.Common.Resources Namespace


FileHandleCollection Constructor

[image]
Gizmox.WebGUI.Common
FileHandleCollection Constructor
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > FileHandleCollection Class : FileHandleCollection Constructor

Overload List

Overload | Description
FileHandleCollection Constructor() |
FileHandleCollection Constructor(SerializationInfo,StreamingContext) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FileHandleCollection Class
FileHandleCollection Members


FileHandleCollection Constructor()

[image]
Gizmox.WebGUI.Common
FileHandleCollection Constructor()
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > FileHandleCollection Class > FileHandleCollection Constructor : FileHandleCollection Constructor()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As FileHandleCollection()
C#
public FileHandleCollection()
Managed Extensions for C++
public: FileHandleCollection();
C++/CLI
public:
FileHandleCollection();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FileHandleCollection Class
FileHandleCollection Members
Overload List


FileHandleCollection Constructor(SerializationInfo,StreamingContext)

[image]
Gizmox.WebGUI.Common
FileHandleCollection Constructor(SerializationInfo,StreamingContext)
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > FileHandleCollection Class > FileHandleCollection Constructor : FileHandleCollection Constructor(SerializationInfo,StreamingContext)

info
context

Syntax

Visual Basic (Declaration)
Protected Function New( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim info As SerializationInfo
Dim context As StreamingContext

Dim instance As FileHandleCollection(info, context)
C#
protected FileHandleCollection(
   SerializationInfo info,
   StreamingContext context
)
Managed Extensions for C++
protected: FileHandleCollection(
   SerializationInfo* info,
   StreamingContext context
)
C++/CLI
protected:
FileHandleCollection(
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

info
context

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FileHandleCollection Class
FileHandleCollection Members
Overload List


FileHandleCollection Class Methods

[image]
Gizmox.WebGUI.Common
FileHandleCollection Class Methods
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace : FileHandleCollection Class

For a list of all members of this type, see FileHandleCollection members.

Public Methods

 | Name | Description
Public Method | Add |
Public Method | Clear |
Public Method | GetEnumerator | Returns an enumerator that iterates through the NameObjectCollectionBase. (Inherited from System.Collections.Specialized.NameObjectCollectionBase)
Public Method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the NameObjectCollectionBase instance. (Inherited from System.Collections.Specialized.NameObjectCollectionBase)
Public Method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from System.Collections.Specialized.NameObjectCollectionBase)
Top

Protected Methods

 | Name | Description
Protected Method | BaseAdd | Adds an entry with the specified key and value into the NameObjectCollectionBase instance. (Inherited from System.Collections.Specialized.NameObjectCollectionBase)
Protected Method | BaseClear | Removes all entries from the NameObjectCollectionBase instance. (Inherited from System.Collections.Specialized.NameObjectCollectionBase)
Protected Method | BaseGet | Overloaded. Gets the value of the first entry with the specified key from the NameObjectCollectionBase instance. (Inherited from System.Collections.Specialized.NameObjectCollectionBase)
Protected Method | BaseGetAllKeys | Returns a String array that contains all the keys in the NameObjectCollectionBase instance. (Inherited from System.Collections.Specialized.NameObjectCollectionBase)
Protected Method | BaseGetAllValues | Overloaded. Returns an Object array that contains all the values in the NameObjectCollectionBase instance. (Inherited from System.Collections.Specialized.NameObjectCollectionBase)
Protected Method | BaseGetKey | Gets the key of the entry at the specified index of the NameObjectCollectionBase instance. (Inherited from System.Collections.Specialized.NameObjectCollectionBase)
Protected Method | BaseHasKeys | Gets a value indicating whether the NameObjectCollectionBase instance contains entries whose keys are not null. (Inherited from System.Collections.Specialized.NameObjectCollectionBase)
Protected Method | BaseRemove | Removes the entries with the specified key from the NameObjectCollectionBase instance. (Inherited from System.Collections.Specialized.NameObjectCollectionBase)
Protected Method | BaseRemoveAt | Removes the entry at the specified index of the NameObjectCollectionBase instance. (Inherited from System.Collections.Specialized.NameObjectCollectionBase)
Protected Method | BaseSet | Overloaded. Sets the value of the first entry with the specified key in the NameObjectCollectionBase instance, if found; otherwise, adds an entry with the specified key and value into the NameObjectCollectionBase instance. (Inherited from System.Collections.Specialized.NameObjectCollectionBase)
Top

See Also

Reference

FileHandleCollection Class
Gizmox.WebGUI.Common.Resources Namespace


Add Method

[image]
Gizmox.WebGUI.Common
Add Method
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > FileHandleCollection Class : Add Method

key
file

Syntax

Visual Basic (Declaration)
Public Sub Add( _
   ByVal key As String, _
   ByVal file As FileHandle _
)
Visual Basic (Usage) Copy Code
Dim instance As FileHandleCollection
Dim key As String
Dim file As FileHandle

instance.Add(key, file)
C#
public void Add(
   string key,
   FileHandle file
)
Managed Extensions for C++
public: void Add(
   string* key,
   FileHandle* file
)
C++/CLI
public:
void Add(
   String^ key,
   FileHandle^ file
)

Parameters

key
file

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FileHandleCollection Class
FileHandleCollection Members


Clear Method

[image]
Gizmox.WebGUI.Common
Clear Method
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > FileHandleCollection Class : Clear Method

Syntax

Visual Basic (Declaration)
Public Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As FileHandleCollection

instance.Clear()
C#
public void Clear()
Managed Extensions for C++
public: void Clear();
C++/CLI
public:
void Clear();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FileHandleCollection Class
FileHandleCollection Members


FileHandleCollection Class Properties

[image]
Gizmox.WebGUI.Common
FileHandleCollection Class Properties
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace : FileHandleCollection Class

For a list of all members of this type, see FileHandleCollection members.

Public Properties

 | Name | Description
Public Property | AllKeys |
Public Property | Count | Gets the number of key/value pairs contained in the NameObjectCollectionBase instance. (Inherited from System.Collections.Specialized.NameObjectCollectionBase)
Public Property | Item | Overloaded.
Public Property | Keys | Gets a KeysCollection instance that contains all the keys in the NameObjectCollectionBase instance. (Inherited from System.Collections.Specialized.NameObjectCollectionBase)
Top

Protected Properties

 | Name | Description
Protected Property | IsReadOnly | Gets or sets a value indicating whether the NameObjectCollectionBase instance is read-only. (Inherited from System.Collections.Specialized.NameObjectCollectionBase)
Top

See Also

Reference

FileHandleCollection Class
Gizmox.WebGUI.Common.Resources Namespace


AllKeys Property

[image]
Gizmox.WebGUI.Common
AllKeys Property
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > FileHandleCollection Class : AllKeys Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AllKeys As String()
Visual Basic (Usage) Copy Code
Dim instance As FileHandleCollection
Dim value() As String

value = instance.AllKeys
C#
public string[] AllKeys {get;}
Managed Extensions for C++
public: __property string*[]* get_AllKeys();
C++/CLI
public:
property array<String^>^ AllKeys {
   array<String^>^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FileHandleCollection Class
FileHandleCollection Members


Item Property

[image]
Gizmox.WebGUI.Common
Item Property
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > FileHandleCollection Class : Item Property

Overload List

Overload | Description
Item(String) |
Item(Int32) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FileHandleCollection Class
FileHandleCollection Members


Item(String) Property

[image]
Gizmox.WebGUI.Common
Item(String) Property
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > FileHandleCollection Class > Item Property : Item(String) Property

key

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal key As String _
) As FileHandle
Visual Basic (Usage) Copy Code
Dim instance As FileHandleCollection
Dim key As String
Dim value As FileHandle

value = instance.Item(key)
C#
public FileHandle Item(
   string key
) {get;}
Managed Extensions for C++
public: __property FileHandle* get_Item(
   string* key
);
C++/CLI
public:
property FileHandle^ Item {
   FileHandle^ get(String^key);
}

Parameters

key

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FileHandleCollection Class
FileHandleCollection Members
Overload List


Item(Int32) Property

[image]
Gizmox.WebGUI.Common
Item(Int32) Property
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > FileHandleCollection Class > Item Property : Item(Int32) Property

index

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal index As Integer _
) As FileHandle
Visual Basic (Usage) Copy Code
Dim instance As FileHandleCollection
Dim index As Integer
Dim value As FileHandle

value = instance.Item(index)
C#
public FileHandle Item(
   int index
) {get;}
Managed Extensions for C++
public: __property FileHandle* get_Item(
   int index
);
C++/CLI
public:
property FileHandle^ Item {
   FileHandle^ get(intindex);
}

Parameters

index

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FileHandleCollection Class
FileHandleCollection Members
Overload List


FileStreamHandle Class

[image]
Gizmox.WebGUI.Common
FileStreamHandle Class
Members See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace : FileStreamHandle Class

Syntax

Visual Basic (Declaration)
Public Class FileStreamHandle
   Inherits FileHandle
Visual Basic (Usage) Copy Code
Dim instance As FileStreamHandle
C#
public class FileStreamHandle : FileHandle
Managed Extensions for C++
public __gc class FileStreamHandle : public FileHandle
C++/CLI
public ref class FileStreamHandle : public FileHandle

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Common.Resources.FileHandle
Gizmox.WebGUI.Common.Resources.FileStreamHandle

Requirements

Namespace: Gizmox.WebGUI.Common.Resources

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

FileStreamHandle Members
Gizmox.WebGUI.Common.Resources Namespace


FileStreamHandle Class Members

[image]
Gizmox.WebGUI.Common
FileStreamHandle Class Members
See Also Fields Properties Methods Send Feedback
Gizmox.WebGUI.Common.Resources Namespace : FileStreamHandle Class

The following tables list the members exposed by FileStreamHandle.

Public Constructors

 | Name | Description
Public Constructor | FileStreamHandle Constructor |
Top

Protected Fields

 | Name | Description
Protected Field | InternalStream | (Inherited from FileHandle)
Top

Public Properties

 | Name | Description
Public Property | ContentLength | Overridden.
Public Property | ContentType | (Inherited from FileHandle)
Public Property | FileName | Overridden.
Public Property | InputStream | Overridden.
Top

Public Methods

 | Name | Description
Public Method | Close | (Inherited from FileHandle)
static (Shared in Visual Basic) | Create |
Public Method | Dispose | Overloaded. (Inherited from FileHandle)
Public Method | SaveAs | (Inherited from FileHandle)
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | (Inherited from FileHandle)
Top

See Also

Reference

FileStreamHandle Class
Gizmox.WebGUI.Common.Resources Namespace


FileStreamHandle Constructor

[image]
Gizmox.WebGUI.Common
FileStreamHandle Constructor
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > FileStreamHandle Class : FileStreamHandle Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As FileStreamHandle()
C#
public FileStreamHandle()
Managed Extensions for C++
public: FileStreamHandle();
C++/CLI
public:
FileStreamHandle();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FileStreamHandle Class
FileStreamHandle Members


FileStreamHandle Class Methods

[image]
Gizmox.WebGUI.Common
FileStreamHandle Class Methods
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace : FileStreamHandle Class

For a list of all members of this type, see FileStreamHandle members.

Public Methods

 | Name | Description
Public Method | Close | (Inherited from FileHandle)
static (Shared in Visual Basic) | Create |
Public Method | Dispose | Overloaded. (Inherited from FileHandle)
Public Method | SaveAs | (Inherited from FileHandle)
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | (Inherited from FileHandle)
Top

See Also

Reference

FileStreamHandle Class
Gizmox.WebGUI.Common.Resources Namespace


Create Method

[image]
Gizmox.WebGUI.Common
Create Method
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > FileStreamHandle Class : Create Method

fileStream

Syntax

Visual Basic (Declaration)
Public Shared Function Create( _
   ByVal fileStream As FileStream _
) As FileStreamHandle
Visual Basic (Usage) Copy Code
Dim fileStream As FileStream
Dim value As FileStreamHandle

value = FileStreamHandle.Create(fileStream)
C#
public static FileStreamHandle Create(
   FileStream fileStream
)
Managed Extensions for C++
public: static FileStreamHandle* Create(
   FileStream* fileStream
)
C++/CLI
public:
static FileStreamHandle^ Create(
   FileStream^ fileStream
)

Parameters

fileStream

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FileStreamHandle Class
FileStreamHandle Members


FileStreamHandle Class Properties

[image]
Gizmox.WebGUI.Common
FileStreamHandle Class Properties
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace : FileStreamHandle Class

For a list of all members of this type, see FileStreamHandle members.

Public Properties

 | Name | Description
Public Property | ContentLength | Overridden.
Public Property | ContentType | (Inherited from FileHandle)
Public Property | FileName | Overridden.
Public Property | InputStream | Overridden.
Top

See Also

Reference

FileStreamHandle Class
Gizmox.WebGUI.Common.Resources Namespace


ContentLength Property

[image]
Gizmox.WebGUI.Common
ContentLength Property
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > FileStreamHandle Class : ContentLength Property

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ContentLength As Long
Visual Basic (Usage) Copy Code
Dim instance As FileStreamHandle
Dim value As Long

value = instance.ContentLength
C#
public override long ContentLength {get;}
Managed Extensions for C++
public: __property long get_ContentLength() override;
C++/CLI
public:
property long long ContentLength {
   long long get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FileStreamHandle Class
FileStreamHandle Members


FileName Property

[image]
Gizmox.WebGUI.Common
FileName Property
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > FileStreamHandle Class : FileName Property

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property FileName As String
Visual Basic (Usage) Copy Code
Dim instance As FileStreamHandle
Dim value As String

value = instance.FileName
C#
public override string FileName {get;}
Managed Extensions for C++
public: __property string* get_FileName() override;
C++/CLI
public:
property String^ FileName {
   String^ get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FileStreamHandle Class
FileStreamHandle Members


InputStream Property

[image]
Gizmox.WebGUI.Common
InputStream Property
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > FileStreamHandle Class : InputStream Property

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property InputStream As Stream
Visual Basic (Usage) Copy Code
Dim instance As FileStreamHandle
Dim value As Stream

value = instance.InputStream
C#
public override Stream InputStream {get;}
Managed Extensions for C++
public: __property Stream* get_InputStream() override;
C++/CLI
public:
property Stream^ InputStream {
   Stream^ get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FileStreamHandle Class
FileStreamHandle Members


GatewayResourceHandle Class

[image]
Gizmox.WebGUI.Common
GatewayResourceHandle Class
Members See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace : GatewayResourceHandle Class

Object Model

Syntax

Visual Basic (Declaration)
Public Class GatewayResourceHandle
   Inherits ResourceHandle
Visual Basic (Usage) Copy Code
Dim instance As GatewayResourceHandle
C#
public class GatewayResourceHandle : ResourceHandle
Managed Extensions for C++
public __gc class GatewayResourceHandle : public ResourceHandle
C++/CLI
public ref class GatewayResourceHandle : public ResourceHandle

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Common.Resources.ResourceHandle
Gizmox.WebGUI.Common.Resources.GatewayResourceHandle

Requirements

Namespace: Gizmox.WebGUI.Common.Resources

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

GatewayResourceHandle Members
Gizmox.WebGUI.Common.Resources Namespace


GatewayResourceHandle Class Members

[image]
Gizmox.WebGUI.Common
GatewayResourceHandle Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Common.Resources Namespace : GatewayResourceHandle Class

The following tables list the members exposed by GatewayResourceHandle.

Public Constructors

 | Name | Description
Public Constructor | GatewayResourceHandle Constructor |
Top

Public Properties

 | Name | Description
Public Property | Action |
Public Property | Component |
Public Property | File | Overridden.
Top

Protected Properties

 | Name | Description
Protected Property | Config | (Inherited from ResourceHandle)
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from ResourceHandle)
Public Method | ToIcon | (Inherited from ResourceHandle)
Public Method | ToImage | (Inherited from ResourceHandle)
Public Method | ToStream | (Inherited from ResourceHandle)
Public Method | ToString | (Inherited from ResourceHandle)
Top

Protected Methods

 | Name | Description
Protected Method | GetSpecificResourceHandle | Overridden.
Top

See Also

Reference

GatewayResourceHandle Class
Gizmox.WebGUI.Common.Resources Namespace


GatewayResourceHandle Constructor

[image]
Gizmox.WebGUI.Common
GatewayResourceHandle Constructor
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > GatewayResourceHandle Class : GatewayResourceHandle Constructor

objGatewayReference

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal objGatewayReference As GatewayReference _
)
Visual Basic (Usage) Copy Code
Dim objGatewayReference As GatewayReference

Dim instance As GatewayResourceHandle(objGatewayReference)
C#
public GatewayResourceHandle(
   GatewayReference objGatewayReference
)
Managed Extensions for C++
public: GatewayResourceHandle(
   GatewayReference* objGatewayReference
)
C++/CLI
public:
GatewayResourceHandle(
   GatewayReference^ objGatewayReference
)

Parameters

objGatewayReference

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

GatewayResourceHandle Class
GatewayResourceHandle Members


GatewayResourceHandle Class Methods

[image]
Gizmox.WebGUI.Common
GatewayResourceHandle Class Methods
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace : GatewayResourceHandle Class

For a list of all members of this type, see GatewayResourceHandle members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from ResourceHandle)
Public Method | ToIcon | (Inherited from ResourceHandle)
Public Method | ToImage | (Inherited from ResourceHandle)
Public Method | ToStream | (Inherited from ResourceHandle)
Public Method | ToString | (Inherited from ResourceHandle)
Top

Protected Methods

 | Name | Description
Protected Method | GetSpecificResourceHandle | Overridden.
Top

See Also

Reference

GatewayResourceHandle Class
Gizmox.WebGUI.Common.Resources Namespace


GetSpecificResourceHandle Method

[image]
Gizmox.WebGUI.Common
GetSpecificResourceHandle Method
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > GatewayResourceHandle Class : GetSpecificResourceHandle Method

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetSpecificResourceHandle() As String
Visual Basic (Usage) Copy Code
Dim instance As GatewayResourceHandle
Dim value As String

value = instance.GetSpecificResourceHandle()
C#
protected override string GetSpecificResourceHandle()
Managed Extensions for C++
protected: string* GetSpecificResourceHandle(); override
C++/CLI
protected:
String^ GetSpecificResourceHandle(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

GatewayResourceHandle Class
GatewayResourceHandle Members


GatewayResourceHandle Class Properties

[image]
Gizmox.WebGUI.Common
GatewayResourceHandle Class Properties
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace : GatewayResourceHandle Class

For a list of all members of this type, see GatewayResourceHandle members.

Public Properties

 | Name | Description
Public Property | Action |
Public Property | Component |
Public Property | File | Overridden.
Top

Protected Properties

 | Name | Description
Protected Property | Config | (Inherited from ResourceHandle)
Top

See Also

Reference

GatewayResourceHandle Class
Gizmox.WebGUI.Common.Resources Namespace


Action Property

[image]
Gizmox.WebGUI.Common
Action Property
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > GatewayResourceHandle Class : Action Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Action As String
Visual Basic (Usage) Copy Code
Dim instance As GatewayResourceHandle
Dim value As String

value = instance.Action
C#
public string Action {get;}
Managed Extensions for C++
public: __property string* get_Action();
C++/CLI
public:
property String^ Action {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

GatewayResourceHandle Class
GatewayResourceHandle Members


Component Property

[image]
Gizmox.WebGUI.Common
Component Property
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > GatewayResourceHandle Class : Component Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Component As IRegisteredComponent
Visual Basic (Usage) Copy Code
Dim instance As GatewayResourceHandle
Dim value As IRegisteredComponent

value = instance.Component
C#
public IRegisteredComponent Component {get;}
Managed Extensions for C++
public: __property IRegisteredComponent* get_Component();
C++/CLI
public:
property IRegisteredComponent^ Component {
   IRegisteredComponent^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

GatewayResourceHandle Class
GatewayResourceHandle Members


File Property

[image]
Gizmox.WebGUI.Common
File Property
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > GatewayResourceHandle Class : File Property

Syntax

Visual Basic (Declaration)
Public Overrides Property File As String
Visual Basic (Usage) Copy Code
Dim instance As GatewayResourceHandle
Dim value As String

instance.File = value

value = instance.File
C#
public override string File {get; set;}
Managed Extensions for C++
public: __property string* get_File() override;
public: __property void set_File(
   string* value
) override;
C++/CLI
public:
property String^ File {
   String^ get() override;
   void set (String^value) override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

GatewayResourceHandle Class
GatewayResourceHandle Members


HttpPostedFileHandle Class

[image]
Gizmox.WebGUI.Common
HttpPostedFileHandle Class
Members See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace : HttpPostedFileHandle Class

Syntax

Visual Basic (Declaration)
Public Class HttpPostedFileHandle
   Inherits FileHandle
Visual Basic (Usage) Copy Code
Dim instance As HttpPostedFileHandle
C#
public class HttpPostedFileHandle : FileHandle
Managed Extensions for C++
public __gc class HttpPostedFileHandle : public FileHandle
C++/CLI
public ref class HttpPostedFileHandle : public FileHandle

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Common.Resources.FileHandle
Gizmox.WebGUI.Common.Resources.HttpPostedFileHandle

Requirements

Namespace: Gizmox.WebGUI.Common.Resources

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

HttpPostedFileHandle Members
Gizmox.WebGUI.Common.Resources Namespace


HttpPostedFileHandle Class Members

[image]
Gizmox.WebGUI.Common
HttpPostedFileHandle Class Members
See Also Fields Properties Methods Send Feedback
Gizmox.WebGUI.Common.Resources Namespace : HttpPostedFileHandle Class

The following tables list the members exposed by HttpPostedFileHandle.

Public Constructors

 | Name | Description
Public Constructor | HttpPostedFileHandle Constructor |
Top

Protected Fields

 | Name | Description
Protected Field | InternalStream | (Inherited from FileHandle)
Top

Public Properties

 | Name | Description
Public Property | ContentLength | Overridden.
Public Property | ContentType | (Inherited from FileHandle)
Public Property | FileName | Overridden.
Public Property | InputStream | Overridden.
Public Property | PostedFileName |
Top

Public Methods

 | Name | Description
Public Method | Close | Overridden.
static (Shared in Visual Basic) | Create |
Public Method | Dispose | Overloaded. (Inherited from FileHandle)
Public Method | SaveAs | (Inherited from FileHandle)
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | (Inherited from FileHandle)
Top

See Also

Reference

HttpPostedFileHandle Class
Gizmox.WebGUI.Common.Resources Namespace


HttpPostedFileHandle Constructor

[image]
Gizmox.WebGUI.Common
HttpPostedFileHandle Constructor
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > HttpPostedFileHandle Class : HttpPostedFileHandle Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As HttpPostedFileHandle()
C#
public HttpPostedFileHandle()
Managed Extensions for C++
public: HttpPostedFileHandle();
C++/CLI
public:
HttpPostedFileHandle();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HttpPostedFileHandle Class
HttpPostedFileHandle Members


HttpPostedFileHandle Class Methods

[image]
Gizmox.WebGUI.Common
HttpPostedFileHandle Class Methods
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace : HttpPostedFileHandle Class

For a list of all members of this type, see HttpPostedFileHandle members.

Public Methods

 | Name | Description
Public Method | Close | Overridden.
static (Shared in Visual Basic) | Create |
Public Method | Dispose | Overloaded. (Inherited from FileHandle)
Public Method | SaveAs | (Inherited from FileHandle)
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | (Inherited from FileHandle)
Top

See Also

Reference

HttpPostedFileHandle Class
Gizmox.WebGUI.Common.Resources Namespace


Close Method

[image]
Gizmox.WebGUI.Common
Close Method
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > HttpPostedFileHandle Class : Close Method

Syntax

Visual Basic (Declaration)
Public Overrides Sub Close()
Visual Basic (Usage) Copy Code
Dim instance As HttpPostedFileHandle

instance.Close()
C#
public override void Close()
Managed Extensions for C++
public: void Close(); override
C++/CLI
public:
void Close(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HttpPostedFileHandle Class
HttpPostedFileHandle Members


Create Method

[image]
Gizmox.WebGUI.Common
Create Method
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > HttpPostedFileHandle Class : Create Method

postedFile

Syntax

Visual Basic (Declaration)
Public Shared Function Create( _
   ByVal postedFile As HttpPostedFile _
) As HttpPostedFileHandle
Visual Basic (Usage) Copy Code
Dim postedFile As HttpPostedFile
Dim value As HttpPostedFileHandle

value = HttpPostedFileHandle.Create(postedFile)
C#
public static HttpPostedFileHandle Create(
   HttpPostedFile postedFile
)
Managed Extensions for C++
public: static HttpPostedFileHandle* Create(
   HttpPostedFile* postedFile
)
C++/CLI
public:
static HttpPostedFileHandle^ Create(
   HttpPostedFile^ postedFile
)

Parameters

postedFile

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HttpPostedFileHandle Class
HttpPostedFileHandle Members


HttpPostedFileHandle Class Properties

[image]
Gizmox.WebGUI.Common
HttpPostedFileHandle Class Properties
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace : HttpPostedFileHandle Class

For a list of all members of this type, see HttpPostedFileHandle members.

Public Properties

 | Name | Description
Public Property | ContentLength | Overridden.
Public Property | ContentType | (Inherited from FileHandle)
Public Property | FileName | Overridden.
Public Property | InputStream | Overridden.
Public Property | PostedFileName |
Top

See Also

Reference

HttpPostedFileHandle Class
Gizmox.WebGUI.Common.Resources Namespace


ContentLength Property

[image]
Gizmox.WebGUI.Common
ContentLength Property
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > HttpPostedFileHandle Class : ContentLength Property

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ContentLength As Long
Visual Basic (Usage) Copy Code
Dim instance As HttpPostedFileHandle
Dim value As Long

value = instance.ContentLength
C#
public override long ContentLength {get;}
Managed Extensions for C++
public: __property long get_ContentLength() override;
C++/CLI
public:
property long long ContentLength {
   long long get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HttpPostedFileHandle Class
HttpPostedFileHandle Members


FileName Property

[image]
Gizmox.WebGUI.Common
FileName Property
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > HttpPostedFileHandle Class : FileName Property

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property FileName As String
Visual Basic (Usage) Copy Code
Dim instance As HttpPostedFileHandle
Dim value As String

value = instance.FileName
C#
public override string FileName {get;}
Managed Extensions for C++
public: __property string* get_FileName() override;
C++/CLI
public:
property String^ FileName {
   String^ get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HttpPostedFileHandle Class
HttpPostedFileHandle Members


InputStream Property

[image]
Gizmox.WebGUI.Common
InputStream Property
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > HttpPostedFileHandle Class : InputStream Property

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property InputStream As Stream
Visual Basic (Usage) Copy Code
Dim instance As HttpPostedFileHandle
Dim value As Stream

value = instance.InputStream
C#
public override Stream InputStream {get;}
Managed Extensions for C++
public: __property Stream* get_InputStream() override;
C++/CLI
public:
property Stream^ InputStream {
   Stream^ get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HttpPostedFileHandle Class
HttpPostedFileHandle Members


PostedFileName Property

[image]
Gizmox.WebGUI.Common
PostedFileName Property
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > HttpPostedFileHandle Class : PostedFileName Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PostedFileName As String
Visual Basic (Usage) Copy Code
Dim instance As HttpPostedFileHandle
Dim value As String

value = instance.PostedFileName
C#
public string PostedFileName {get;}
Managed Extensions for C++
public: __property string* get_PostedFileName();
C++/CLI
public:
property String^ PostedFileName {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HttpPostedFileHandle Class
HttpPostedFileHandle Members


IconResourceHandle Class

[image]
Gizmox.WebGUI.Common
IconResourceHandle Class
Members See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace : IconResourceHandle Class

Object Model

Syntax

Visual Basic (Declaration)
Public Class IconResourceHandle
   Inherits ResourceHandle
Visual Basic (Usage) Copy Code
Dim instance As IconResourceHandle
C#
public class IconResourceHandle : ResourceHandle
Managed Extensions for C++
public __gc class IconResourceHandle : public ResourceHandle
C++/CLI
public ref class IconResourceHandle : public ResourceHandle

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Common.Resources.ResourceHandle
Gizmox.WebGUI.Common.Resources.IconResourceHandle

Requirements

Namespace: Gizmox.WebGUI.Common.Resources

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

IconResourceHandle Members
Gizmox.WebGUI.Common.Resources Namespace


IconResourceHandle Class Members

[image]
Gizmox.WebGUI.Common
IconResourceHandle Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Common.Resources Namespace : IconResourceHandle Class

The following tables list the members exposed by IconResourceHandle.

Public Constructors

 | Name | Description
Public Constructor | IconResourceHandle Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | File | (Inherited from ResourceHandle)
Top

Protected Properties

 | Name | Description
Protected Property | Config | (Inherited from ResourceHandle)
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from ResourceHandle)
Public Method | ToIcon | (Inherited from ResourceHandle)
Public Method | ToImage | (Inherited from ResourceHandle)
Public Method | ToStream | Overridden.
Public Method | ToString | (Inherited from ResourceHandle)
Top

Protected Methods

 | Name | Description
Protected Method | GetSpecificResourceHandle | Overridden.
Top

See Also

Reference

IconResourceHandle Class
Gizmox.WebGUI.Common.Resources Namespace


IconResourceHandle Constructor

[image]
Gizmox.WebGUI.Common
IconResourceHandle Constructor
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > IconResourceHandle Class : IconResourceHandle Constructor

Overload List

Overload | Description
IconResourceHandle Constructor() |
IconResourceHandle Constructor(String) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IconResourceHandle Class
IconResourceHandle Members


IconResourceHandle Constructor()

[image]
Gizmox.WebGUI.Common
IconResourceHandle Constructor()
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > IconResourceHandle Class > IconResourceHandle Constructor : IconResourceHandle Constructor()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As IconResourceHandle()
C#
public IconResourceHandle()
Managed Extensions for C++
public: IconResourceHandle();
C++/CLI
public:
IconResourceHandle();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IconResourceHandle Class
IconResourceHandle Members
Overload List


IconResourceHandle Constructor(String)

[image]
Gizmox.WebGUI.Common
IconResourceHandle Constructor(String)
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > IconResourceHandle Class > IconResourceHandle Constructor : IconResourceHandle Constructor(String)

strFile

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal strFile As String _
)
Visual Basic (Usage) Copy Code
Dim strFile As String

Dim instance As IconResourceHandle(strFile)
C#
public IconResourceHandle(
   string strFile
)
Managed Extensions for C++
public: IconResourceHandle(
   string* strFile
)
C++/CLI
public:
IconResourceHandle(
   String^ strFile
)

Parameters

strFile

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IconResourceHandle Class
IconResourceHandle Members
Overload List


IconResourceHandle Class Methods

[image]
Gizmox.WebGUI.Common
IconResourceHandle Class Methods
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace : IconResourceHandle Class

For a list of all members of this type, see IconResourceHandle members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from ResourceHandle)
Public Method | ToIcon | (Inherited from ResourceHandle)
Public Method | ToImage | (Inherited from ResourceHandle)
Public Method | ToStream | Overridden.
Public Method | ToString | (Inherited from ResourceHandle)
Top

Protected Methods

 | Name | Description
Protected Method | GetSpecificResourceHandle | Overridden.
Top

See Also

Reference

IconResourceHandle Class
Gizmox.WebGUI.Common.Resources Namespace


GetSpecificResourceHandle Method

[image]
Gizmox.WebGUI.Common
GetSpecificResourceHandle Method
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > IconResourceHandle Class : GetSpecificResourceHandle Method

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetSpecificResourceHandle() As String
Visual Basic (Usage) Copy Code
Dim instance As IconResourceHandle
Dim value As String

value = instance.GetSpecificResourceHandle()
C#
protected override string GetSpecificResourceHandle()
Managed Extensions for C++
protected: string* GetSpecificResourceHandle(); override
C++/CLI
protected:
String^ GetSpecificResourceHandle(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IconResourceHandle Class
IconResourceHandle Members


ToStream Method

[image]
Gizmox.WebGUI.Common
ToStream Method
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > IconResourceHandle Class : ToStream Method

Syntax

Visual Basic (Declaration)
Public Overrides Function ToStream() As Stream
Visual Basic (Usage) Copy Code
Dim instance As IconResourceHandle
Dim value As Stream

value = instance.ToStream()
C#
public override Stream ToStream()
Managed Extensions for C++
public: Stream* ToStream(); override
C++/CLI
public:
Stream^ ToStream(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IconResourceHandle Class
IconResourceHandle Members


ImageResourceHandle Class

[image]
Gizmox.WebGUI.Common
ImageResourceHandle Class
Members See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace : ImageResourceHandle Class

Object Model

Syntax

Visual Basic (Declaration)
Public Class ImageResourceHandle
   Inherits ResourceHandle
Visual Basic (Usage) Copy Code
Dim instance As ImageResourceHandle
C#
public class ImageResourceHandle : ResourceHandle
Managed Extensions for C++
public __gc class ImageResourceHandle : public ResourceHandle
C++/CLI
public ref class ImageResourceHandle : public ResourceHandle

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Common.Resources.ResourceHandle
Gizmox.WebGUI.Common.Resources.ImageResourceHandle

Requirements

Namespace: Gizmox.WebGUI.Common.Resources

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

ImageResourceHandle Members
Gizmox.WebGUI.Common.Resources Namespace


ImageResourceHandle Class Members

[image]
Gizmox.WebGUI.Common
ImageResourceHandle Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Common.Resources Namespace : ImageResourceHandle Class

The following tables list the members exposed by ImageResourceHandle.

Public Constructors

 | Name | Description
Public Constructor | ImageResourceHandle Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | File | (Inherited from ResourceHandle)
Top

Protected Properties

 | Name | Description
Protected Property | Config | (Inherited from ResourceHandle)
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from ResourceHandle)
Public Method | ToIcon | (Inherited from ResourceHandle)
Public Method | ToImage | (Inherited from ResourceHandle)
Public Method | ToStream | Overridden.
Public Method | ToString | (Inherited from ResourceHandle)
Top

Protected Methods

 | Name | Description
Protected Method | GetSpecificResourceHandle | Overridden.
Top

See Also

Reference

ImageResourceHandle Class
Gizmox.WebGUI.Common.Resources Namespace


ImageResourceHandle Constructor

[image]
Gizmox.WebGUI.Common
ImageResourceHandle Constructor
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > ImageResourceHandle Class : ImageResourceHandle Constructor

Overload List

Overload | Description
ImageResourceHandle Constructor() |
ImageResourceHandle Constructor(String) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ImageResourceHandle Class
ImageResourceHandle Members


ImageResourceHandle Constructor()

[image]
Gizmox.WebGUI.Common
ImageResourceHandle Constructor()
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > ImageResourceHandle Class > ImageResourceHandle Constructor : ImageResourceHandle Constructor()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ImageResourceHandle()
C#
public ImageResourceHandle()
Managed Extensions for C++
public: ImageResourceHandle();
C++/CLI
public:
ImageResourceHandle();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ImageResourceHandle Class
ImageResourceHandle Members
Overload List


ImageResourceHandle Constructor(String)

[image]
Gizmox.WebGUI.Common
ImageResourceHandle Constructor(String)
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > ImageResourceHandle Class > ImageResourceHandle Constructor : ImageResourceHandle Constructor(String)

strFile

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal strFile As String _
)
Visual Basic (Usage) Copy Code
Dim strFile As String

Dim instance As ImageResourceHandle(strFile)
C#
public ImageResourceHandle(
   string strFile
)
Managed Extensions for C++
public: ImageResourceHandle(
   string* strFile
)
C++/CLI
public:
ImageResourceHandle(
   String^ strFile
)

Parameters

strFile

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ImageResourceHandle Class
ImageResourceHandle Members
Overload List


ImageResourceHandle Class Methods

[image]
Gizmox.WebGUI.Common
ImageResourceHandle Class Methods
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace : ImageResourceHandle Class

For a list of all members of this type, see ImageResourceHandle members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from ResourceHandle)
Public Method | ToIcon | (Inherited from ResourceHandle)
Public Method | ToImage | (Inherited from ResourceHandle)
Public Method | ToStream | Overridden.
Public Method | ToString | (Inherited from ResourceHandle)
Top

Protected Methods

 | Name | Description
Protected Method | GetSpecificResourceHandle | Overridden.
Top

See Also

Reference

ImageResourceHandle Class
Gizmox.WebGUI.Common.Resources Namespace


GetSpecificResourceHandle Method

[image]
Gizmox.WebGUI.Common
GetSpecificResourceHandle Method
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > ImageResourceHandle Class : GetSpecificResourceHandle Method

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetSpecificResourceHandle() As String
Visual Basic (Usage) Copy Code
Dim instance As ImageResourceHandle
Dim value As String

value = instance.GetSpecificResourceHandle()
C#
protected override string GetSpecificResourceHandle()
Managed Extensions for C++
protected: string* GetSpecificResourceHandle(); override
C++/CLI
protected:
String^ GetSpecificResourceHandle(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ImageResourceHandle Class
ImageResourceHandle Members


ToStream Method

[image]
Gizmox.WebGUI.Common
ToStream Method
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > ImageResourceHandle Class : ToStream Method

Syntax

Visual Basic (Declaration)
Public Overrides Function ToStream() As Stream
Visual Basic (Usage) Copy Code
Dim instance As ImageResourceHandle
Dim value As Stream

value = instance.ToStream()
C#
public override Stream ToStream()
Managed Extensions for C++
public: Stream* ToStream(); override
C++/CLI
public:
Stream^ ToStream(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ImageResourceHandle Class
ImageResourceHandle Members


PhysicalFileHandle Class

[image]
Gizmox.WebGUI.Common
PhysicalFileHandle Class
Members See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace : PhysicalFileHandle Class

Syntax

Visual Basic (Declaration)
Public Class PhysicalFileHandle
   Inherits FileHandle
Visual Basic (Usage) Copy Code
Dim instance As PhysicalFileHandle
C#
public class PhysicalFileHandle : FileHandle
Managed Extensions for C++
public __gc class PhysicalFileHandle : public FileHandle
C++/CLI
public ref class PhysicalFileHandle : public FileHandle

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Common.Resources.FileHandle
Gizmox.WebGUI.Common.Resources.PhysicalFileHandle

Requirements

Namespace: Gizmox.WebGUI.Common.Resources

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

PhysicalFileHandle Members
Gizmox.WebGUI.Common.Resources Namespace


PhysicalFileHandle Class Members

[image]
Gizmox.WebGUI.Common
PhysicalFileHandle Class Members
See Also Fields Properties Methods Send Feedback
Gizmox.WebGUI.Common.Resources Namespace : PhysicalFileHandle Class

The following tables list the members exposed by PhysicalFileHandle.

Public Constructors

 | Name | Description
Public Constructor | PhysicalFileHandle Constructor |
Top

Protected Fields

 | Name | Description
Protected Field | InternalStream | (Inherited from FileHandle)
Top

Public Properties

 | Name | Description
Public Property | ContentLength | Overridden.
Public Property | ContentType | (Inherited from FileHandle)
Public Property | FileName | Overridden.
Public Property | InputStream | Overridden.
Top

Public Methods

 | Name | Description
Public Method | Close | (Inherited from FileHandle)
static (Shared in Visual Basic) | Create |
Public Method | Dispose | Overloaded. (Inherited from FileHandle)
Public Method | SaveAs | (Inherited from FileHandle)
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | (Inherited from FileHandle)
Top

See Also

Reference

PhysicalFileHandle Class
Gizmox.WebGUI.Common.Resources Namespace


PhysicalFileHandle Constructor

[image]
Gizmox.WebGUI.Common
PhysicalFileHandle Constructor
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > PhysicalFileHandle Class : PhysicalFileHandle Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As PhysicalFileHandle()
C#
public PhysicalFileHandle()
Managed Extensions for C++
public: PhysicalFileHandle();
C++/CLI
public:
PhysicalFileHandle();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PhysicalFileHandle Class
PhysicalFileHandle Members


PhysicalFileHandle Class Methods

[image]
Gizmox.WebGUI.Common
PhysicalFileHandle Class Methods
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace : PhysicalFileHandle Class

For a list of all members of this type, see PhysicalFileHandle members.

Public Methods

 | Name | Description
Public Method | Close | (Inherited from FileHandle)
static (Shared in Visual Basic) | Create |
Public Method | Dispose | Overloaded. (Inherited from FileHandle)
Public Method | SaveAs | (Inherited from FileHandle)
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | (Inherited from FileHandle)
Top

See Also

Reference

PhysicalFileHandle Class
Gizmox.WebGUI.Common.Resources Namespace


Create Method

[image]
Gizmox.WebGUI.Common
Create Method
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > PhysicalFileHandle Class : Create Method

filename

Syntax

Visual Basic (Declaration)
Public Shared Function Create( _
   ByVal filename As String _
) As PhysicalFileHandle
Visual Basic (Usage) Copy Code
Dim filename As String
Dim value As PhysicalFileHandle

value = PhysicalFileHandle.Create(filename)
C#
public static PhysicalFileHandle Create(
   string filename
)
Managed Extensions for C++
public: static PhysicalFileHandle* Create(
   string* filename
)
C++/CLI
public:
static PhysicalFileHandle^ Create(
   String^ filename
)

Parameters

filename

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PhysicalFileHandle Class
PhysicalFileHandle Members


PhysicalFileHandle Class Properties

[image]
Gizmox.WebGUI.Common
PhysicalFileHandle Class Properties
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace : PhysicalFileHandle Class

For a list of all members of this type, see PhysicalFileHandle members.

Public Properties

 | Name | Description
Public Property | ContentLength | Overridden.
Public Property | ContentType | (Inherited from FileHandle)
Public Property | FileName | Overridden.
Public Property | InputStream | Overridden.
Top

See Also

Reference

PhysicalFileHandle Class
Gizmox.WebGUI.Common.Resources Namespace


ContentLength Property

[image]
Gizmox.WebGUI.Common
ContentLength Property
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > PhysicalFileHandle Class : ContentLength Property

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ContentLength As Long
Visual Basic (Usage) Copy Code
Dim instance As PhysicalFileHandle
Dim value As Long

value = instance.ContentLength
C#
public override long ContentLength {get;}
Managed Extensions for C++
public: __property long get_ContentLength() override;
C++/CLI
public:
property long long ContentLength {
   long long get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PhysicalFileHandle Class
PhysicalFileHandle Members


FileName Property

[image]
Gizmox.WebGUI.Common
FileName Property
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > PhysicalFileHandle Class : FileName Property

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property FileName As String
Visual Basic (Usage) Copy Code
Dim instance As PhysicalFileHandle
Dim value As String

value = instance.FileName
C#
public override string FileName {get;}
Managed Extensions for C++
public: __property string* get_FileName() override;
C++/CLI
public:
property String^ FileName {
   String^ get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PhysicalFileHandle Class
PhysicalFileHandle Members


InputStream Property

[image]
Gizmox.WebGUI.Common
InputStream Property
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > PhysicalFileHandle Class : InputStream Property

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property InputStream As Stream
Visual Basic (Usage) Copy Code
Dim instance As PhysicalFileHandle
Dim value As Stream

value = instance.InputStream
C#
public override Stream InputStream {get;}
Managed Extensions for C++
public: __property Stream* get_InputStream() override;
C++/CLI
public:
property Stream^ InputStream {
   Stream^ get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PhysicalFileHandle Class
PhysicalFileHandle Members


ResourceHandle Class

[image]
Gizmox.WebGUI.Common
ResourceHandle Class
Members See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace : ResourceHandle Class

Object Model

Syntax

Visual Basic (Declaration)
<TypeConverterAttribute("Gizmox.WebGUI.Common.Resources.ResourceHandleConverter, Gizmox.WebGUI.Common, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=263fa4ef694acff6")>
<EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.ResourceHandleEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")>
Public MustInherit Class ResourceHandle
Visual Basic (Usage) Copy Code
Dim instance As ResourceHandle
C#
[TypeConverterAttribute("Gizmox.WebGUI.Common.Resources.ResourceHandleConverter, Gizmox.WebGUI.Common, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=263fa4ef694acff6")]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.ResourceHandleEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
public abstract class ResourceHandle
Managed Extensions for C++
[TypeConverterAttribute("Gizmox.WebGUI.Common.Resources.ResourceHandleConverter, Gizmox.WebGUI.Common, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=263fa4ef694acff6")]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.ResourceHandleEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
public __gc abstract class ResourceHandle
C++/CLI
[TypeConverterAttribute("Gizmox.WebGUI.Common.Resources.ResourceHandleConverter, Gizmox.WebGUI.Common, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=263fa4ef694acff6")]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.ResourceHandleEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
public ref class ResourceHandle abstract

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Common.Resources.ResourceHandle
Gizmox.WebGUI.Common.Resources.AssemblyResourceHandle
Gizmox.WebGUI.Common.Resources.DataResourceHandle
Gizmox.WebGUI.Common.Resources.GatewayResourceHandle
Gizmox.WebGUI.Common.Resources.IconResourceHandle
Gizmox.WebGUI.Common.Resources.ImageResourceHandle
Gizmox.WebGUI.Common.Resources.SkinResourceHandle
Gizmox.WebGUI.Common.Resources.StaticGatewayResourceHandle
Gizmox.WebGUI.Common.Resources.TypeResourceHandle
Gizmox.WebGUI.Common.Resources.UrlResourceHandle

Requirements

Namespace: Gizmox.WebGUI.Common.Resources

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

ResourceHandle Members
Gizmox.WebGUI.Common.Resources Namespace


ResourceHandle Class Members

[image]
Gizmox.WebGUI.Common
ResourceHandle Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Common.Resources Namespace : ResourceHandle Class

The following tables list the members exposed by ResourceHandle.

Public Properties

 | Name | Description
Public Property | File |
Top

Protected Properties

 | Name | Description
Protected Property | Config |
Top

Public Methods

 | Name | Description
Public Method | Equals | Overridden.
Public Method | ToIcon |
Public Method | ToImage |
Public Method | ToStream |
Public Method | ToString | Overridden.
Top

Protected Methods

 | Name | Description
Protected Method | GetSpecificResourceHandle |
Top

See Also

Reference

ResourceHandle Class
Gizmox.WebGUI.Common.Resources Namespace


ResourceHandle Class Methods

[image]
Gizmox.WebGUI.Common
ResourceHandle Class Methods
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace : ResourceHandle Class

For a list of all members of this type, see ResourceHandle members.

Public Methods

 | Name | Description
Public Method | Equals | Overridden.
Public Method | ToIcon |
Public Method | ToImage |
Public Method | ToStream |
Public Method | ToString | Overridden.
Top

Protected Methods

 | Name | Description
Protected Method | GetSpecificResourceHandle |
Top

See Also

Reference

ResourceHandle Class
Gizmox.WebGUI.Common.Resources Namespace


Equals Method

[image]
Gizmox.WebGUI.Common
Equals Method
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > ResourceHandle Class : Equals Method

objObject

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
   ByVal objObject As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ResourceHandle
Dim objObject As Object
Dim value As Boolean

value = instance.Equals(objObject)
C#
public override bool Equals(
   object objObject
)
Managed Extensions for C++
public: bool Equals(
   Object* objObject
) override
C++/CLI
public:
bool Equals(
   Object^ objObject
) override

Parameters

objObject

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ResourceHandle Class
ResourceHandle Members


GetSpecificResourceHandle Method

[image]
Gizmox.WebGUI.Common
GetSpecificResourceHandle Method
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > ResourceHandle Class : GetSpecificResourceHandle Method

Syntax

Visual Basic (Declaration)
Protected MustOverride Function GetSpecificResourceHandle() As String
Visual Basic (Usage) Copy Code
Dim instance As ResourceHandle
Dim value As String

value = instance.GetSpecificResourceHandle()
C#
protected abstract string GetSpecificResourceHandle()
Managed Extensions for C++
protected: abstract string* GetSpecificResourceHandle();
C++/CLI
protected:
abstract String^ GetSpecificResourceHandle();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ResourceHandle Class
ResourceHandle Members


ToIcon Method

[image]
Gizmox.WebGUI.Common
ToIcon Method
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > ResourceHandle Class : ToIcon Method

Syntax

Visual Basic (Declaration)
Public Overridable Function ToIcon() As Icon
Visual Basic (Usage) Copy Code
Dim instance As ResourceHandle
Dim value As Icon

value = instance.ToIcon()
C#
public virtual Icon ToIcon()
Managed Extensions for C++
public: virtual Icon* ToIcon();
C++/CLI
public:
virtual Icon^ ToIcon();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ResourceHandle Class
ResourceHandle Members


ToImage Method

[image]
Gizmox.WebGUI.Common
ToImage Method
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > ResourceHandle Class : ToImage Method

Syntax

Visual Basic (Declaration)
Public Overridable Function ToImage() As Image
Visual Basic (Usage) Copy Code
Dim instance As ResourceHandle
Dim value As Image

value = instance.ToImage()
C#
public virtual Image ToImage()
Managed Extensions for C++
public: virtual Image* ToImage();
C++/CLI
public:
virtual Image^ ToImage();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ResourceHandle Class
ResourceHandle Members


ToStream Method

[image]
Gizmox.WebGUI.Common
ToStream Method
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > ResourceHandle Class : ToStream Method

Syntax

Visual Basic (Declaration)
Public Overridable Function ToStream() As Stream
Visual Basic (Usage) Copy Code
Dim instance As ResourceHandle
Dim value As Stream

value = instance.ToStream()
C#
public virtual Stream ToStream()
Managed Extensions for C++
public: virtual Stream* ToStream();
C++/CLI
public:
virtual Stream^ ToStream();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ResourceHandle Class
ResourceHandle Members


ToString Method

[image]
Gizmox.WebGUI.Common
ToString Method
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > ResourceHandle Class : ToString Method

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As ResourceHandle
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ResourceHandle Class
ResourceHandle Members


ResourceHandle Class Properties

[image]
Gizmox.WebGUI.Common
ResourceHandle Class Properties
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace : ResourceHandle Class

For a list of all members of this type, see ResourceHandle members.

Public Properties

 | Name | Description
Public Property | File |
Top

Protected Properties

 | Name | Description
Protected Property | Config |
Top

See Also

Reference

ResourceHandle Class
Gizmox.WebGUI.Common.Resources Namespace


Config Property

[image]
Gizmox.WebGUI.Common
Config Property
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > ResourceHandle Class : Config Property

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property Config As Config
Visual Basic (Usage) Copy Code
Dim instance As ResourceHandle
Dim value As Config

value = instance.Config
C#
protected Config Config {get;}
Managed Extensions for C++
protected: __property Config* get_Config();
C++/CLI
protected:
property Config^ Config {
   Config^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ResourceHandle Class
ResourceHandle Members


File Property

[image]
Gizmox.WebGUI.Common
File Property
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > ResourceHandle Class : File Property

Syntax

Visual Basic (Declaration)
<EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Common.Design.ResourceFileEditor, Gizmox.WebGUI.Common.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=ea5dfe57c8eb7edd")>
Public Overridable Property File As String
Visual Basic (Usage) Copy Code
Dim instance As ResourceHandle
Dim value As String

instance.File = value

value = instance.File
C#
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Common.Design.ResourceFileEditor, Gizmox.WebGUI.Common.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=ea5dfe57c8eb7edd")]
public virtual string File {get; set;}
Managed Extensions for C++
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Common.Design.ResourceFileEditor, Gizmox.WebGUI.Common.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=ea5dfe57c8eb7edd")]
public: __property virtual string* get_File();
public: __property virtual void set_File(
   string* value
);
C++/CLI
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Common.Design.ResourceFileEditor, Gizmox.WebGUI.Common.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=ea5dfe57c8eb7edd")]
public:
virtual property String^ File {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ResourceHandle Class
ResourceHandle Members


ResourceHandleConverter Class

[image]
Gizmox.WebGUI.Common
ResourceHandleConverter Class
Members See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace : ResourceHandleConverter Class

Syntax

Visual Basic (Declaration)
Public Class ResourceHandleConverter
   Inherits TypeConverter
Visual Basic (Usage) Copy Code
Dim instance As ResourceHandleConverter
C#
public class ResourceHandleConverter : TypeConverter
Managed Extensions for C++
public __gc class ResourceHandleConverter : public TypeConverter
C++/CLI
public ref class ResourceHandleConverter : public TypeConverter

Inheritance Hierarchy

System.Object
System.ComponentModel.TypeConverter
Gizmox.WebGUI.Common.Resources.ResourceHandleConverter

Requirements

Namespace: Gizmox.WebGUI.Common.Resources

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

ResourceHandleConverter Members
Gizmox.WebGUI.Common.Resources Namespace


ResourceHandleConverter Class Members

[image]
Gizmox.WebGUI.Common
ResourceHandleConverter Class Members
See Also Methods Send Feedback
Gizmox.WebGUI.Common.Resources Namespace : ResourceHandleConverter Class

The following tables list the members exposed by ResourceHandleConverter.

Public Constructors

 | Name | Description
Public Constructor | ResourceHandleConverter Constructor |
Top

Public Methods

 | Name | Description
Public Method | CanConvertFrom | Overloaded. Overridden. Returns whether this converter can convert an object of the given type to the type of this converter.
Public Method | CanConvertTo | Overloaded. Overridden. Returns whether this converter can convert the object to the specified type.
Public Method | ConvertFrom | Overloaded. Overridden. Converts the given value to the type of this converter.
Public Method | ConvertFromInvariantString | Overloaded. Converts the given string to the type of this converter, using the invariant culture. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertFromString | Overloaded. Converts the specified text to an object. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertTo | Overloaded. Overridden. Converts the given value object to the specified type, using the arguments.
Public Method | ConvertToInvariantString | Overloaded. Converts the specified value to a culture-invariant string representation. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertToString | Overloaded. Converts the specified value to a string representation. (Inherited from System.ComponentModel.TypeConverter)
Public Method | CreateInstance | Overloaded. Re-creates an Object given a set of property values for the object. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetCreateInstanceSupported | Overloaded. Returns whether changing a value on this object requires a call to the CreateInstance method to create a new value. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetProperties | Overloaded. Returns a collection of properties for the type of array specified by the value parameter. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetPropertiesSupported | Overloaded. Returns whether this object supports properties. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValues | Overloaded. Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValuesExclusive | Overloaded. Returns whether the collection of standard values returned from GetStandardValues is an exclusive list. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValuesSupported | Overloaded. Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from System.ComponentModel.TypeConverter)
Public Method | IsValid | Overloaded. Returns whether the given value object is valid for this type. (Inherited from System.ComponentModel.TypeConverter)
Top

Protected Methods

 | Name | Description
Protected Method | GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from System.ComponentModel.TypeConverter)
Protected Method | GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from System.ComponentModel.TypeConverter)
Protected Method | SortProperties | (Inherited from System.ComponentModel.TypeConverter)
Top

See Also

Reference

ResourceHandleConverter Class
Gizmox.WebGUI.Common.Resources Namespace


ResourceHandleConverter Constructor

[image]
Gizmox.WebGUI.Common
ResourceHandleConverter Constructor
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > ResourceHandleConverter Class : ResourceHandleConverter Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ResourceHandleConverter()
C#
public ResourceHandleConverter()
Managed Extensions for C++
public: ResourceHandleConverter();
C++/CLI
public:
ResourceHandleConverter();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ResourceHandleConverter Class
ResourceHandleConverter Members


ResourceHandleConverter Class Methods

[image]
Gizmox.WebGUI.Common
ResourceHandleConverter Class Methods
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace : ResourceHandleConverter Class

For a list of all members of this type, see ResourceHandleConverter members.

Public Methods

 | Name | Description
Public Method | CanConvertFrom | Overloaded. Overridden. Returns whether this converter can convert an object of the given type to the type of this converter.
Public Method | CanConvertTo | Overloaded. Overridden. Returns whether this converter can convert the object to the specified type.
Public Method | ConvertFrom | Overloaded. Overridden. Converts the given value to the type of this converter.
Public Method | ConvertFromInvariantString | Overloaded. Converts the given string to the type of this converter, using the invariant culture. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertFromString | Overloaded. Converts the specified text to an object. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertTo | Overloaded. Overridden. Converts the given value object to the specified type, using the arguments.
Public Method | ConvertToInvariantString | Overloaded. Converts the specified value to a culture-invariant string representation. (Inherited from System.ComponentModel.TypeConverter)
Public Method | ConvertToString | Overloaded. Converts the specified value to a string representation. (Inherited from System.ComponentModel.TypeConverter)
Public Method | CreateInstance | Overloaded. Re-creates an Object given a set of property values for the object. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetCreateInstanceSupported | Overloaded. Returns whether changing a value on this object requires a call to the CreateInstance method to create a new value. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetProperties | Overloaded. Returns a collection of properties for the type of array specified by the value parameter. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetPropertiesSupported | Overloaded. Returns whether this object supports properties. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValues | Overloaded. Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValuesExclusive | Overloaded. Returns whether the collection of standard values returned from GetStandardValues is an exclusive list. (Inherited from System.ComponentModel.TypeConverter)
Public Method | GetStandardValuesSupported | Overloaded. Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from System.ComponentModel.TypeConverter)
Public Method | IsValid | Overloaded. Returns whether the given value object is valid for this type. (Inherited from System.ComponentModel.TypeConverter)
Top

Protected Methods

 | Name | Description
Protected Method | GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from System.ComponentModel.TypeConverter)
Protected Method | GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from System.ComponentModel.TypeConverter)
Protected Method | SortProperties | (Inherited from System.ComponentModel.TypeConverter)
Top

See Also

Reference

ResourceHandleConverter Class
Gizmox.WebGUI.Common.Resources Namespace


CanConvertFrom Method

[image]
Gizmox.WebGUI.Common
CanConvertFrom Method
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > ResourceHandleConverter Class : CanConvertFrom Method

Returns whether this converter can convert an object of the given type to the type of this converter.

Overload List

Overload | Description
CanConvertFrom(ITypeDescriptorContext,Type) |
CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from System.ComponentModel.TypeConverter)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ResourceHandleConverter Class
ResourceHandleConverter Members


CanConvertFrom(ITypeDescriptorContext,Type) Method

[image]
Gizmox.WebGUI.Common
CanConvertFrom(ITypeDescriptorContext,Type) Method
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > ResourceHandleConverter Class > CanConvertFrom Method : CanConvertFrom(ITypeDescriptorContext,Type) Method

context
sourceType

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function CanConvertFrom( _
   ByVal context As ITypeDescriptorContext, _
   ByVal sourceType As Type _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ResourceHandleConverter
Dim context As ITypeDescriptorContext
Dim sourceType As Type
Dim value As Boolean

value = instance.CanConvertFrom(context, sourceType)
C#
public override bool CanConvertFrom(
   ITypeDescriptorContext context,
   Type sourceType
)
Managed Extensions for C++
public: bool CanConvertFrom(
   ITypeDescriptorContext* context,
   Type* sourceType
) override
C++/CLI
public:
bool CanConvertFrom(
   ITypeDescriptorContext^ context,
   Type^ sourceType
) override

Parameters

context
sourceType

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ResourceHandleConverter Class
ResourceHandleConverter Members
Overload List


CanConvertTo Method

[image]
Gizmox.WebGUI.Common
CanConvertTo Method
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > ResourceHandleConverter Class : CanConvertTo Method

Returns whether this converter can convert the object to the specified type.

Overload List

Overload | Description
CanConvertTo(ITypeDescriptorContext,Type) |
CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from System.ComponentModel.TypeConverter)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ResourceHandleConverter Class
ResourceHandleConverter Members


CanConvertTo(ITypeDescriptorContext,Type) Method

[image]
Gizmox.WebGUI.Common
CanConvertTo(ITypeDescriptorContext,Type) Method
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > ResourceHandleConverter Class > CanConvertTo Method : CanConvertTo(ITypeDescriptorContext,Type) Method

context
destinationType

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function CanConvertTo( _
   ByVal context As ITypeDescriptorContext, _
   ByVal destinationType As Type _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ResourceHandleConverter
Dim context As ITypeDescriptorContext
Dim destinationType As Type
Dim value As Boolean

value = instance.CanConvertTo(context, destinationType)
C#
public override bool CanConvertTo(
   ITypeDescriptorContext context,
   Type destinationType
)
Managed Extensions for C++
public: bool CanConvertTo(
   ITypeDescriptorContext* context,
   Type* destinationType
) override
C++/CLI
public:
bool CanConvertTo(
   ITypeDescriptorContext^ context,
   Type^ destinationType
) override

Parameters

context
destinationType

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ResourceHandleConverter Class
ResourceHandleConverter Members
Overload List


ConvertFrom Method

[image]
Gizmox.WebGUI.Common
ConvertFrom Method
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > ResourceHandleConverter Class : ConvertFrom Method

Converts the given value to the type of this converter.

Overload List

Overload | Description
ConvertFrom(ITypeDescriptorContext,CultureInfo,Object) |
ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from System.ComponentModel.TypeConverter)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ResourceHandleConverter Class
ResourceHandleConverter Members


ConvertFrom(ITypeDescriptorContext,CultureInfo,Object) Method

[image]
Gizmox.WebGUI.Common
ConvertFrom(ITypeDescriptorContext,CultureInfo,Object) Method
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > ResourceHandleConverter Class > ConvertFrom Method : ConvertFrom(ITypeDescriptorContext,CultureInfo,Object) Method

context
culture
value

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function ConvertFrom( _
   ByVal context As ITypeDescriptorContext, _
   ByVal culture As CultureInfo, _
   ByVal value As Object _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As ResourceHandleConverter
Dim context As ITypeDescriptorContext
Dim culture As CultureInfo
Dim value As Object
Dim value As Object

value = instance.ConvertFrom(context, culture, value)
C#
public override object ConvertFrom(
   ITypeDescriptorContext context,
   CultureInfo culture,
   object value
)
Managed Extensions for C++
public: Object* ConvertFrom(
   ITypeDescriptorContext* context,
   CultureInfo* culture,
   Object* value
) override
C++/CLI
public:
Object^ ConvertFrom(
   ITypeDescriptorContext^ context,
   CultureInfo^ culture,
   Object^ value
) override

Parameters

context
culture
value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ResourceHandleConverter Class
ResourceHandleConverter Members
Overload List


ConvertTo Method

[image]
Gizmox.WebGUI.Common
ConvertTo Method
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > ResourceHandleConverter Class : ConvertTo Method

Converts the given value object to the specified type, using the arguments.

Overload List

Overload | Description
ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) |
ConvertTo(Object,Type) | Converts the given value object to the specified type, using the arguments. (Inherited from System.ComponentModel.TypeConverter)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ResourceHandleConverter Class
ResourceHandleConverter Members


ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) Method

[image]
Gizmox.WebGUI.Common
ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) Method
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > ResourceHandleConverter Class > ConvertTo Method : ConvertTo(ITypeDescriptorContext,CultureInfo,Object,Type) Method

context
culture
value
destinationType

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function ConvertTo( _
   ByVal context As ITypeDescriptorContext, _
   ByVal culture As CultureInfo, _
   ByVal value As Object, _
   ByVal destinationType As Type _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As ResourceHandleConverter
Dim context As ITypeDescriptorContext
Dim culture As CultureInfo
Dim value As Object
Dim destinationType As Type
Dim value As Object

value = instance.ConvertTo(context, culture, value, destinationType)
C#
public override object ConvertTo(
   ITypeDescriptorContext context,
   CultureInfo culture,
   object value,
   Type destinationType
)
Managed Extensions for C++
public: Object* ConvertTo(
   ITypeDescriptorContext* context,
   CultureInfo* culture,
   Object* value,
   Type* destinationType
) override
C++/CLI
public:
Object^ ConvertTo(
   ITypeDescriptorContext^ context,
   CultureInfo^ culture,
   Object^ value,
   Type^ destinationType
) override

Parameters

context
culture
value
destinationType

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ResourceHandleConverter Class
ResourceHandleConverter Members
Overload List


ResourceManager Class

[image]
Gizmox.WebGUI.Common
ResourceManager Class
Members See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace : ResourceManager Class

Syntax

Visual Basic (Declaration)
Public Class ResourceManager
Visual Basic (Usage) Copy Code
Dim instance As ResourceManager
C#
public class ResourceManager
Managed Extensions for C++
public __gc class ResourceManager
C++/CLI
public ref class ResourceManager

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Common.Resources.ResourceManager

Requirements

Namespace: Gizmox.WebGUI.Common.Resources

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

ResourceManager Members
Gizmox.WebGUI.Common.Resources Namespace


ResourceManager Class Members

[image]
Gizmox.WebGUI.Common
ResourceManager Class Members
See Also Methods Send Feedback
Gizmox.WebGUI.Common.Resources Namespace : ResourceManager Class

The following tables list the members exposed by ResourceManager.

Public Constructors

 | Name | Description
Public Constructor | ResourceManager Constructor | Overloaded.
Top

Public Methods

 | Name | Description
Public Method | GetAssemblyResource |
Public Method | GetIcon |
Public Method | GetImage |
Public Method | GetObject | Overloaded.
Public Method | GetSkin |
Top

See Also

Reference

ResourceManager Class
Gizmox.WebGUI.Common.Resources Namespace


ResourceManager Constructor

[image]
Gizmox.WebGUI.Common
ResourceManager Constructor
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > ResourceManager Class : ResourceManager Constructor

Overload List

Overload | Description
ResourceManager Constructor() |
ResourceManager Constructor(Type) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ResourceManager Class
ResourceManager Members


ResourceManager Constructor()

[image]
Gizmox.WebGUI.Common
ResourceManager Constructor()
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > ResourceManager Class > ResourceManager Constructor : ResourceManager Constructor()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ResourceManager()
C#
public ResourceManager()
Managed Extensions for C++
public: ResourceManager();
C++/CLI
public:
ResourceManager();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ResourceManager Class
ResourceManager Members
Overload List


ResourceManager Constructor(Type)

[image]
Gizmox.WebGUI.Common
ResourceManager Constructor(Type)
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > ResourceManager Class > ResourceManager Constructor : ResourceManager Constructor(Type)

objType

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal objType As Type _
)
Visual Basic (Usage) Copy Code
Dim objType As Type

Dim instance As ResourceManager(objType)
C#
public ResourceManager(
   Type objType
)
Managed Extensions for C++
public: ResourceManager(
   Type* objType
)
C++/CLI
public:
ResourceManager(
   Type^ objType
)

Parameters

objType

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ResourceManager Class
ResourceManager Members
Overload List


ResourceManager Class Methods

[image]
Gizmox.WebGUI.Common
ResourceManager Class Methods
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace : ResourceManager Class

For a list of all members of this type, see ResourceManager members.

Public Methods

 | Name | Description
Public Method | GetAssemblyResource |
Public Method | GetIcon |
Public Method | GetImage |
Public Method | GetObject | Overloaded.
Public Method | GetSkin |
Top

See Also

Reference

ResourceManager Class
Gizmox.WebGUI.Common.Resources Namespace


GetAssemblyResource Method

[image]
Gizmox.WebGUI.Common
GetAssemblyResource Method
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > ResourceManager Class : GetAssemblyResource Method

strFile

Syntax

Visual Basic (Declaration)
Public Function GetAssemblyResource( _
   ByVal strFile As String _
) As ResourceHandle
Visual Basic (Usage) Copy Code
Dim instance As ResourceManager
Dim strFile As String
Dim value As ResourceHandle

value = instance.GetAssemblyResource(strFile)
C#
public ResourceHandle GetAssemblyResource(
   string strFile
)
Managed Extensions for C++
public: ResourceHandle* GetAssemblyResource(
   string* strFile
)
C++/CLI
public:
ResourceHandle^ GetAssemblyResource(
   String^ strFile
)

Parameters

strFile

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ResourceManager Class
ResourceManager Members


GetIcon Method

[image]
Gizmox.WebGUI.Common
GetIcon Method
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > ResourceManager Class : GetIcon Method

strFile

Syntax

Visual Basic (Declaration)
Public Function GetIcon( _
   ByVal strFile As String _
) As ResourceHandle
Visual Basic (Usage) Copy Code
Dim instance As ResourceManager
Dim strFile As String
Dim value As ResourceHandle

value = instance.GetIcon(strFile)
C#
public ResourceHandle GetIcon(
   string strFile
)
Managed Extensions for C++
public: ResourceHandle* GetIcon(
   string* strFile
)
C++/CLI
public:
ResourceHandle^ GetIcon(
   String^ strFile
)

Parameters

strFile

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ResourceManager Class
ResourceManager Members


GetImage Method

[image]
Gizmox.WebGUI.Common
GetImage Method
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > ResourceManager Class : GetImage Method

strFile

Syntax

Visual Basic (Declaration)
Public Function GetImage( _
   ByVal strFile As String _
) As ResourceHandle
Visual Basic (Usage) Copy Code
Dim instance As ResourceManager
Dim strFile As String
Dim value As ResourceHandle

value = instance.GetImage(strFile)
C#
public ResourceHandle GetImage(
   string strFile
)
Managed Extensions for C++
public: ResourceHandle* GetImage(
   string* strFile
)
C++/CLI
public:
ResourceHandle^ GetImage(
   String^ strFile
)

Parameters

strFile

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ResourceManager Class
ResourceManager Members


GetObject Method

[image]
Gizmox.WebGUI.Common
GetObject Method
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > ResourceManager Class : GetObject Method

Overload List

Overload | Description
GetObject(String) |
GetObject(String,CultureInfo) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ResourceManager Class
ResourceManager Members


GetObject(String) Method

[image]
Gizmox.WebGUI.Common
GetObject(String) Method
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > ResourceManager Class > GetObject Method : GetObject(String) Method

strFile

Syntax

Visual Basic (Declaration)
Public Overloads Function GetObject( _
   ByVal strFile As String _
) As ResourceHandle
Visual Basic (Usage) Copy Code
Dim instance As ResourceManager
Dim strFile As String
Dim value As ResourceHandle

value = instance.GetObject(strFile)
C#
public ResourceHandle GetObject(
   string strFile
)
Managed Extensions for C++
public: ResourceHandle* GetObject(
   string* strFile
)
C++/CLI
public:
ResourceHandle^ GetObject(
   String^ strFile
)

Parameters

strFile

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ResourceManager Class
ResourceManager Members
Overload List


GetObject(String,CultureInfo) Method

[image]
Gizmox.WebGUI.Common
GetObject(String,CultureInfo) Method
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > ResourceManager Class > GetObject Method : GetObject(String,CultureInfo) Method

strFile
objCulture

Syntax

Visual Basic (Declaration)
Public Overloads Function GetObject( _
   ByVal strFile As String, _
   ByVal objCulture As CultureInfo _
) As ResourceHandle
Visual Basic (Usage) Copy Code
Dim instance As ResourceManager
Dim strFile As String
Dim objCulture As CultureInfo
Dim value As ResourceHandle

value = instance.GetObject(strFile, objCulture)
C#
public ResourceHandle GetObject(
   string strFile,
   CultureInfo objCulture
)
Managed Extensions for C++
public: ResourceHandle* GetObject(
   string* strFile,
   CultureInfo* objCulture
)
C++/CLI
public:
ResourceHandle^ GetObject(
   String^ strFile,
   CultureInfo^ objCulture
)

Parameters

strFile
objCulture

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ResourceManager Class
ResourceManager Members
Overload List


GetSkin Method

[image]
Gizmox.WebGUI.Common
GetSkin Method
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > ResourceManager Class : GetSkin Method

strFile

Syntax

Visual Basic (Declaration)
Public Function GetSkin( _
   ByVal strFile As String _
) As ResourceHandle
Visual Basic (Usage) Copy Code
Dim instance As ResourceManager
Dim strFile As String
Dim value As ResourceHandle

value = instance.GetSkin(strFile)
C#
public ResourceHandle GetSkin(
   string strFile
)
Managed Extensions for C++
public: ResourceHandle* GetSkin(
   string* strFile
)
C++/CLI
public:
ResourceHandle^ GetSkin(
   String^ strFile
)

Parameters

strFile

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ResourceManager Class
ResourceManager Members


SkinResourceHandle Class

[image]
Gizmox.WebGUI.Common
SkinResourceHandle Class
Members See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace : SkinResourceHandle Class

Object Model

Syntax

Visual Basic (Declaration)
Public Class SkinResourceHandle
   Inherits ResourceHandle
Visual Basic (Usage) Copy Code
Dim instance As SkinResourceHandle
C#
public class SkinResourceHandle : ResourceHandle
Managed Extensions for C++
public __gc class SkinResourceHandle : public ResourceHandle
C++/CLI
public ref class SkinResourceHandle : public ResourceHandle

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Common.Resources.ResourceHandle
Gizmox.WebGUI.Common.Resources.SkinResourceHandle

Requirements

Namespace: Gizmox.WebGUI.Common.Resources

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

SkinResourceHandle Members
Gizmox.WebGUI.Common.Resources Namespace


SkinResourceHandle Class Members

[image]
Gizmox.WebGUI.Common
SkinResourceHandle Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Common.Resources Namespace : SkinResourceHandle Class

The following tables list the members exposed by SkinResourceHandle.

Public Constructors

 | Name | Description
Public Constructor | SkinResourceHandle Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | File | (Inherited from ResourceHandle)
Top

Protected Properties

 | Name | Description
Protected Property | Config | (Inherited from ResourceHandle)
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from ResourceHandle)
Public Method | ToIcon | (Inherited from ResourceHandle)
Public Method | ToImage | (Inherited from ResourceHandle)
Public Method | ToStream | Overridden.
Public Method | ToString | (Inherited from ResourceHandle)
Top

Protected Methods

 | Name | Description
Protected Method | GetSpecificResourceHandle | Overridden.
Top

See Also

Reference

SkinResourceHandle Class
Gizmox.WebGUI.Common.Resources Namespace


SkinResourceHandle Constructor

[image]
Gizmox.WebGUI.Common
SkinResourceHandle Constructor
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > SkinResourceHandle Class : SkinResourceHandle Constructor

Overload List

Overload | Description
SkinResourceHandle Constructor() |
SkinResourceHandle Constructor(String) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SkinResourceHandle Class
SkinResourceHandle Members


SkinResourceHandle Constructor()

[image]
Gizmox.WebGUI.Common
SkinResourceHandle Constructor()
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > SkinResourceHandle Class > SkinResourceHandle Constructor : SkinResourceHandle Constructor()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As SkinResourceHandle()
C#
public SkinResourceHandle()
Managed Extensions for C++
public: SkinResourceHandle();
C++/CLI
public:
SkinResourceHandle();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SkinResourceHandle Class
SkinResourceHandle Members
Overload List


SkinResourceHandle Constructor(String)

[image]
Gizmox.WebGUI.Common
SkinResourceHandle Constructor(String)
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > SkinResourceHandle Class > SkinResourceHandle Constructor : SkinResourceHandle Constructor(String)

strFile

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal strFile As String _
)
Visual Basic (Usage) Copy Code
Dim strFile As String

Dim instance As SkinResourceHandle(strFile)
C#
public SkinResourceHandle(
   string strFile
)
Managed Extensions for C++
public: SkinResourceHandle(
   string* strFile
)
C++/CLI
public:
SkinResourceHandle(
   String^ strFile
)

Parameters

strFile

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SkinResourceHandle Class
SkinResourceHandle Members
Overload List


SkinResourceHandle Class Methods

[image]
Gizmox.WebGUI.Common
SkinResourceHandle Class Methods
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace : SkinResourceHandle Class

For a list of all members of this type, see SkinResourceHandle members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from ResourceHandle)
Public Method | ToIcon | (Inherited from ResourceHandle)
Public Method | ToImage | (Inherited from ResourceHandle)
Public Method | ToStream | Overridden.
Public Method | ToString | (Inherited from ResourceHandle)
Top

Protected Methods

 | Name | Description
Protected Method | GetSpecificResourceHandle | Overridden.
Top

See Also

Reference

SkinResourceHandle Class
Gizmox.WebGUI.Common.Resources Namespace


GetSpecificResourceHandle Method

[image]
Gizmox.WebGUI.Common
GetSpecificResourceHandle Method
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > SkinResourceHandle Class : GetSpecificResourceHandle Method

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetSpecificResourceHandle() As String
Visual Basic (Usage) Copy Code
Dim instance As SkinResourceHandle
Dim value As String

value = instance.GetSpecificResourceHandle()
C#
protected override string GetSpecificResourceHandle()
Managed Extensions for C++
protected: string* GetSpecificResourceHandle(); override
C++/CLI
protected:
String^ GetSpecificResourceHandle(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SkinResourceHandle Class
SkinResourceHandle Members


ToStream Method

[image]
Gizmox.WebGUI.Common
ToStream Method
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > SkinResourceHandle Class : ToStream Method

Syntax

Visual Basic (Declaration)
Public Overrides Function ToStream() As Stream
Visual Basic (Usage) Copy Code
Dim instance As SkinResourceHandle
Dim value As Stream

value = instance.ToStream()
C#
public override Stream ToStream()
Managed Extensions for C++
public: Stream* ToStream(); override
C++/CLI
public:
Stream^ ToStream(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SkinResourceHandle Class
SkinResourceHandle Members


StaticGatewayResourceHandle Class

[image]
Gizmox.WebGUI.Common
StaticGatewayResourceHandle Class
Members See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace : StaticGatewayResourceHandle Class

Object Model

Syntax

Visual Basic (Declaration)
Public Class StaticGatewayResourceHandle
   Inherits ResourceHandle
Visual Basic (Usage) Copy Code
Dim instance As StaticGatewayResourceHandle
C#
public class StaticGatewayResourceHandle : ResourceHandle
Managed Extensions for C++
public __gc class StaticGatewayResourceHandle : public ResourceHandle
C++/CLI
public ref class StaticGatewayResourceHandle : public ResourceHandle

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Common.Resources.ResourceHandle
Gizmox.WebGUI.Common.Resources.StaticGatewayResourceHandle
Gizmox.WebGUI.Common.Resources.DatabaseResourceHandle

Requirements

Namespace: Gizmox.WebGUI.Common.Resources

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

StaticGatewayResourceHandle Members
Gizmox.WebGUI.Common.Resources Namespace


StaticGatewayResourceHandle Class Members

[image]
Gizmox.WebGUI.Common
StaticGatewayResourceHandle Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Common.Resources Namespace : StaticGatewayResourceHandle Class

The following tables list the members exposed by StaticGatewayResourceHandle.

Public Constructors

 | Name | Description
Public Constructor | StaticGatewayResourceHandle Constructor |
Top

Public Properties

 | Name | Description
Public Property | File | Overridden.
Top

Protected Properties

 | Name | Description
Protected Property | Config | (Inherited from ResourceHandle)
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from ResourceHandle)
Public Method | ToIcon | (Inherited from ResourceHandle)
Public Method | ToImage | (Inherited from ResourceHandle)
Public Method | ToStream | (Inherited from ResourceHandle)
Public Method | ToString | (Inherited from ResourceHandle)
Top

Protected Methods

 | Name | Description
Protected Method | GetSpecificResourceHandle | Overridden.
Top

See Also

Reference

StaticGatewayResourceHandle Class
Gizmox.WebGUI.Common.Resources Namespace


StaticGatewayResourceHandle Constructor

[image]
Gizmox.WebGUI.Common
StaticGatewayResourceHandle Constructor
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > StaticGatewayResourceHandle Class : StaticGatewayResourceHandle Constructor

strFile
objType

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal strFile As String, _
   ByVal objType As Type _
)
Visual Basic (Usage) Copy Code
Dim strFile As String
Dim objType As Type

Dim instance As StaticGatewayResourceHandle(strFile, objType)
C#
public StaticGatewayResourceHandle(
   string strFile,
   Type objType
)
Managed Extensions for C++
public: StaticGatewayResourceHandle(
   string* strFile,
   Type* objType
)
C++/CLI
public:
StaticGatewayResourceHandle(
   String^ strFile,
   Type^ objType
)

Parameters

strFile
objType

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

StaticGatewayResourceHandle Class
StaticGatewayResourceHandle Members


StaticGatewayResourceHandle Class Methods

[image]
Gizmox.WebGUI.Common
StaticGatewayResourceHandle Class Methods
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace : StaticGatewayResourceHandle Class

For a list of all members of this type, see StaticGatewayResourceHandle members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from ResourceHandle)
Public Method | ToIcon | (Inherited from ResourceHandle)
Public Method | ToImage | (Inherited from ResourceHandle)
Public Method | ToStream | (Inherited from ResourceHandle)
Public Method | ToString | (Inherited from ResourceHandle)
Top

Protected Methods

 | Name | Description
Protected Method | GetSpecificResourceHandle | Overridden.
Top

See Also

Reference

StaticGatewayResourceHandle Class
Gizmox.WebGUI.Common.Resources Namespace


GetSpecificResourceHandle Method

[image]
Gizmox.WebGUI.Common
GetSpecificResourceHandle Method
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > StaticGatewayResourceHandle Class : GetSpecificResourceHandle Method

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetSpecificResourceHandle() As String
Visual Basic (Usage) Copy Code
Dim instance As StaticGatewayResourceHandle
Dim value As String

value = instance.GetSpecificResourceHandle()
C#
protected override string GetSpecificResourceHandle()
Managed Extensions for C++
protected: string* GetSpecificResourceHandle(); override
C++/CLI
protected:
String^ GetSpecificResourceHandle(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

StaticGatewayResourceHandle Class
StaticGatewayResourceHandle Members


StaticGatewayResourceHandle Class Properties

[image]
Gizmox.WebGUI.Common
StaticGatewayResourceHandle Class Properties
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace : StaticGatewayResourceHandle Class

For a list of all members of this type, see StaticGatewayResourceHandle members.

Public Properties

 | Name | Description
Public Property | File | Overridden.
Top

Protected Properties

 | Name | Description
Protected Property | Config | (Inherited from ResourceHandle)
Top

See Also

Reference

StaticGatewayResourceHandle Class
Gizmox.WebGUI.Common.Resources Namespace


File Property

[image]
Gizmox.WebGUI.Common
File Property
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > StaticGatewayResourceHandle Class : File Property

Syntax

Visual Basic (Declaration)
Public Overrides Property File As String
Visual Basic (Usage) Copy Code
Dim instance As StaticGatewayResourceHandle
Dim value As String

instance.File = value

value = instance.File
C#
public override string File {get; set;}
Managed Extensions for C++
public: __property string* get_File() override;
public: __property void set_File(
   string* value
) override;
C++/CLI
public:
property String^ File {
   String^ get() override;
   void set (String^value) override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

StaticGatewayResourceHandle Class
StaticGatewayResourceHandle Members


TypeResourceHandle Class

[image]
Gizmox.WebGUI.Common
TypeResourceHandle Class
Members See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace : TypeResourceHandle Class

Object Model

Syntax

Visual Basic (Declaration)
Public Class TypeResourceHandle
   Inherits ResourceHandle
Visual Basic (Usage) Copy Code
Dim instance As TypeResourceHandle
C#
public class TypeResourceHandle : ResourceHandle
Managed Extensions for C++
public __gc class TypeResourceHandle : public ResourceHandle
C++/CLI
public ref class TypeResourceHandle : public ResourceHandle

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Common.Resources.ResourceHandle
Gizmox.WebGUI.Common.Resources.TypeResourceHandle

Requirements

Namespace: Gizmox.WebGUI.Common.Resources

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

TypeResourceHandle Members
Gizmox.WebGUI.Common.Resources Namespace


TypeResourceHandle Class Members

[image]
Gizmox.WebGUI.Common
TypeResourceHandle Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Common.Resources Namespace : TypeResourceHandle Class

The following tables list the members exposed by TypeResourceHandle.

Public Constructors

 | Name | Description
Public Constructor | TypeResourceHandle Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Culture |
Public Property | File | (Inherited from ResourceHandle)
Public Property | Type |
Top

Protected Properties

 | Name | Description
Protected Property | Config | (Inherited from ResourceHandle)
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from ResourceHandle)
Public Method | ToIcon | (Inherited from ResourceHandle)
Public Method | ToImage | (Inherited from ResourceHandle)
Public Method | ToStream | Overridden.
Public Method | ToString | (Inherited from ResourceHandle)
Top

Protected Methods

 | Name | Description
Protected Method | GetSpecificResourceHandle | Overridden.
Top

See Also

Reference

TypeResourceHandle Class
Gizmox.WebGUI.Common.Resources Namespace


TypeResourceHandle Constructor

[image]
Gizmox.WebGUI.Common
TypeResourceHandle Constructor
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > TypeResourceHandle Class : TypeResourceHandle Constructor

Overload List

Overload | Description
TypeResourceHandle Constructor() |
TypeResourceHandle Constructor(Type,String) |
TypeResourceHandle Constructor(Type,String,CultureInfo) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TypeResourceHandle Class
TypeResourceHandle Members


TypeResourceHandle Constructor()

[image]
Gizmox.WebGUI.Common
TypeResourceHandle Constructor()
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > TypeResourceHandle Class > TypeResourceHandle Constructor : TypeResourceHandle Constructor()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As TypeResourceHandle()
C#
public TypeResourceHandle()
Managed Extensions for C++
public: TypeResourceHandle();
C++/CLI
public:
TypeResourceHandle();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TypeResourceHandle Class
TypeResourceHandle Members
Overload List


TypeResourceHandle Constructor(Type,String)

[image]
Gizmox.WebGUI.Common
TypeResourceHandle Constructor(Type,String)
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > TypeResourceHandle Class > TypeResourceHandle Constructor : TypeResourceHandle Constructor(Type,String)

objType
strFile

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal objType As Type, _
   ByVal strFile As String _
)
Visual Basic (Usage) Copy Code
Dim objType As Type
Dim strFile As String

Dim instance As TypeResourceHandle(objType, strFile)
C#
public TypeResourceHandle(
   Type objType,
   string strFile
)
Managed Extensions for C++
public: TypeResourceHandle(
   Type* objType,
   string* strFile
)
C++/CLI
public:
TypeResourceHandle(
   Type^ objType,
   String^ strFile
)

Parameters

objType
strFile

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TypeResourceHandle Class
TypeResourceHandle Members
Overload List


TypeResourceHandle Constructor(Type,String,CultureInfo)

[image]
Gizmox.WebGUI.Common
TypeResourceHandle Constructor(Type,String,CultureInfo)
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > TypeResourceHandle Class > TypeResourceHandle Constructor : TypeResourceHandle Constructor(Type,String,CultureInfo)

objType
strFile
objCulture

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal objType As Type, _
   ByVal strFile As String, _
   ByVal objCulture As CultureInfo _
)
Visual Basic (Usage) Copy Code
Dim objType As Type
Dim strFile As String
Dim objCulture As CultureInfo

Dim instance As TypeResourceHandle(objType, strFile, objCulture)
C#
public TypeResourceHandle(
   Type objType,
   string strFile,
   CultureInfo objCulture
)
Managed Extensions for C++
public: TypeResourceHandle(
   Type* objType,
   string* strFile,
   CultureInfo* objCulture
)
C++/CLI
public:
TypeResourceHandle(
   Type^ objType,
   String^ strFile,
   CultureInfo^ objCulture
)

Parameters

objType
strFile
objCulture

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TypeResourceHandle Class
TypeResourceHandle Members
Overload List


TypeResourceHandle Class Methods

[image]
Gizmox.WebGUI.Common
TypeResourceHandle Class Methods
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace : TypeResourceHandle Class

For a list of all members of this type, see TypeResourceHandle members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from ResourceHandle)
Public Method | ToIcon | (Inherited from ResourceHandle)
Public Method | ToImage | (Inherited from ResourceHandle)
Public Method | ToStream | Overridden.
Public Method | ToString | (Inherited from ResourceHandle)
Top

Protected Methods

 | Name | Description
Protected Method | GetSpecificResourceHandle | Overridden.
Top

See Also

Reference

TypeResourceHandle Class
Gizmox.WebGUI.Common.Resources Namespace


GetSpecificResourceHandle Method

[image]
Gizmox.WebGUI.Common
GetSpecificResourceHandle Method
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > TypeResourceHandle Class : GetSpecificResourceHandle Method

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetSpecificResourceHandle() As String
Visual Basic (Usage) Copy Code
Dim instance As TypeResourceHandle
Dim value As String

value = instance.GetSpecificResourceHandle()
C#
protected override string GetSpecificResourceHandle()
Managed Extensions for C++
protected: string* GetSpecificResourceHandle(); override
C++/CLI
protected:
String^ GetSpecificResourceHandle(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TypeResourceHandle Class
TypeResourceHandle Members


ToStream Method

[image]
Gizmox.WebGUI.Common
ToStream Method
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > TypeResourceHandle Class : ToStream Method

Syntax

Visual Basic (Declaration)
Public Overrides Function ToStream() As Stream
Visual Basic (Usage) Copy Code
Dim instance As TypeResourceHandle
Dim value As Stream

value = instance.ToStream()
C#
public override Stream ToStream()
Managed Extensions for C++
public: Stream* ToStream(); override
C++/CLI
public:
Stream^ ToStream(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TypeResourceHandle Class
TypeResourceHandle Members


TypeResourceHandle Class Properties

[image]
Gizmox.WebGUI.Common
TypeResourceHandle Class Properties
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace : TypeResourceHandle Class

For a list of all members of this type, see TypeResourceHandle members.

Public Properties

 | Name | Description
Public Property | Culture |
Public Property | File | (Inherited from ResourceHandle)
Public Property | Type |
Top

Protected Properties

 | Name | Description
Protected Property | Config | (Inherited from ResourceHandle)
Top

See Also

Reference

TypeResourceHandle Class
Gizmox.WebGUI.Common.Resources Namespace


Culture Property

[image]
Gizmox.WebGUI.Common
Culture Property
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > TypeResourceHandle Class : Culture Property

Syntax

Visual Basic (Declaration)
Public Property Culture As CultureInfo
Visual Basic (Usage) Copy Code
Dim instance As TypeResourceHandle
Dim value As CultureInfo

instance.Culture = value

value = instance.Culture
C#
public CultureInfo Culture {get; set;}
Managed Extensions for C++
public: __property CultureInfo* get_Culture();
public: __property void set_Culture(
   CultureInfo* value
);
C++/CLI
public:
property CultureInfo^ Culture {
   CultureInfo^ get();
   void set (CultureInfo^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TypeResourceHandle Class
TypeResourceHandle Members


Type Property

[image]
Gizmox.WebGUI.Common
Type Property
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > TypeResourceHandle Class : Type Property

Syntax

Visual Basic (Declaration)
Public Property Type As Type
Visual Basic (Usage) Copy Code
Dim instance As TypeResourceHandle
Dim value As Type

instance.Type = value

value = instance.Type
C#
public Type Type {get; set;}
Managed Extensions for C++
public: __property Type* get_Type();
public: __property void set_Type(
   Type* value
);
C++/CLI
public:
property Type^ Type {
   Type^ get();
   void set (Type^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TypeResourceHandle Class
TypeResourceHandle Members


UrlResourceHandle Class

[image]
Gizmox.WebGUI.Common
UrlResourceHandle Class
Members See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace : UrlResourceHandle Class

Object Model

Syntax

Visual Basic (Declaration)
Public Class UrlResourceHandle
   Inherits ResourceHandle
Visual Basic (Usage) Copy Code
Dim instance As UrlResourceHandle
C#
public class UrlResourceHandle : ResourceHandle
Managed Extensions for C++
public __gc class UrlResourceHandle : public ResourceHandle
C++/CLI
public ref class UrlResourceHandle : public ResourceHandle

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Common.Resources.ResourceHandle
Gizmox.WebGUI.Common.Resources.UrlResourceHandle

Requirements

Namespace: Gizmox.WebGUI.Common.Resources

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

UrlResourceHandle Members
Gizmox.WebGUI.Common.Resources Namespace


UrlResourceHandle Class Members

[image]
Gizmox.WebGUI.Common
UrlResourceHandle Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Common.Resources Namespace : UrlResourceHandle Class

The following tables list the members exposed by UrlResourceHandle.

Public Constructors

 | Name | Description
Public Constructor | UrlResourceHandle Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | File | Overridden.
Public Property | Url |
Top

Protected Properties

 | Name | Description
Protected Property | Config | (Inherited from ResourceHandle)
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from ResourceHandle)
Public Method | ToIcon | (Inherited from ResourceHandle)
Public Method | ToImage | (Inherited from ResourceHandle)
Public Method | ToStream | (Inherited from ResourceHandle)
Public Method | ToString | (Inherited from ResourceHandle)
Top

Protected Methods

 | Name | Description
Protected Method | GetSpecificResourceHandle | Overridden.
Top

See Also

Reference

UrlResourceHandle Class
Gizmox.WebGUI.Common.Resources Namespace


UrlResourceHandle Constructor

[image]
Gizmox.WebGUI.Common
UrlResourceHandle Constructor
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > UrlResourceHandle Class : UrlResourceHandle Constructor

Overload List

Overload | Description
UrlResourceHandle Constructor() |
UrlResourceHandle Constructor(String) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

UrlResourceHandle Class
UrlResourceHandle Members


UrlResourceHandle Constructor()

[image]
Gizmox.WebGUI.Common
UrlResourceHandle Constructor()
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > UrlResourceHandle Class > UrlResourceHandle Constructor : UrlResourceHandle Constructor()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As UrlResourceHandle()
C#
public UrlResourceHandle()
Managed Extensions for C++
public: UrlResourceHandle();
C++/CLI
public:
UrlResourceHandle();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

UrlResourceHandle Class
UrlResourceHandle Members
Overload List


UrlResourceHandle Constructor(String)

[image]
Gizmox.WebGUI.Common
UrlResourceHandle Constructor(String)
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > UrlResourceHandle Class > UrlResourceHandle Constructor : UrlResourceHandle Constructor(String)

strUrl

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal strUrl As String _
)
Visual Basic (Usage) Copy Code
Dim strUrl As String

Dim instance As UrlResourceHandle(strUrl)
C#
public UrlResourceHandle(
   string strUrl
)
Managed Extensions for C++
public: UrlResourceHandle(
   string* strUrl
)
C++/CLI
public:
UrlResourceHandle(
   String^ strUrl
)

Parameters

strUrl

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

UrlResourceHandle Class
UrlResourceHandle Members
Overload List


UrlResourceHandle Class Methods

[image]
Gizmox.WebGUI.Common
UrlResourceHandle Class Methods
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace : UrlResourceHandle Class

For a list of all members of this type, see UrlResourceHandle members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from ResourceHandle)
Public Method | ToIcon | (Inherited from ResourceHandle)
Public Method | ToImage | (Inherited from ResourceHandle)
Public Method | ToStream | (Inherited from ResourceHandle)
Public Method | ToString | (Inherited from ResourceHandle)
Top

Protected Methods

 | Name | Description
Protected Method | GetSpecificResourceHandle | Overridden.
Top

See Also

Reference

UrlResourceHandle Class
Gizmox.WebGUI.Common.Resources Namespace


GetSpecificResourceHandle Method

[image]
Gizmox.WebGUI.Common
GetSpecificResourceHandle Method
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > UrlResourceHandle Class : GetSpecificResourceHandle Method

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetSpecificResourceHandle() As String
Visual Basic (Usage) Copy Code
Dim instance As UrlResourceHandle
Dim value As String

value = instance.GetSpecificResourceHandle()
C#
protected override string GetSpecificResourceHandle()
Managed Extensions for C++
protected: string* GetSpecificResourceHandle(); override
C++/CLI
protected:
String^ GetSpecificResourceHandle(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

UrlResourceHandle Class
UrlResourceHandle Members


UrlResourceHandle Class Properties

[image]
Gizmox.WebGUI.Common
UrlResourceHandle Class Properties
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace : UrlResourceHandle Class

For a list of all members of this type, see UrlResourceHandle members.

Public Properties

 | Name | Description
Public Property | File | Overridden.
Public Property | Url |
Top

Protected Properties

 | Name | Description
Protected Property | Config | (Inherited from ResourceHandle)
Top

See Also

Reference

UrlResourceHandle Class
Gizmox.WebGUI.Common.Resources Namespace


File Property

[image]
Gizmox.WebGUI.Common
File Property
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > UrlResourceHandle Class : File Property

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
Public Overrides Property File As String
Visual Basic (Usage) Copy Code
Dim instance As UrlResourceHandle
Dim value As String

instance.File = value

value = instance.File
C#
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public override string File {get; set;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public: __property string* get_File() override;
public: __property void set_File(
   string* value
) override;
C++/CLI
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public:
property String^ File {
   String^ get() override;
   void set (String^value) override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

UrlResourceHandle Class
UrlResourceHandle Members


Url Property

[image]
Gizmox.WebGUI.Common
Url Property
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace > UrlResourceHandle Class : Url Property

Syntax

Visual Basic (Declaration)
Public Property Url As String
Visual Basic (Usage) Copy Code
Dim instance As UrlResourceHandle
Dim value As String

instance.Url = value

value = instance.Url
C#
public string Url {get; set;}
Managed Extensions for C++
public: __property string* get_Url();
public: __property void set_Url(
   string* value
);
C++/CLI
public:
property String^ Url {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

UrlResourceHandle Class
UrlResourceHandle Members


Gizmox.WebGUI.Common.Switches Namespace

Gizmox.WebGUI.Common
Gizmox.WebGUI.Common.Switches Namespace
See Also Inheritance Hierarchy Send Feedback

Classes

 | Class | Description
Class | WGTracingSwitch |
Class | WGTracingThresholdSwitch |

See Also

Reference

Gizmox.WebGUI.Common Assembly


WGTracingSwitch Class

[image]
Gizmox.WebGUI.Common
WGTracingSwitch Class
Members See Also Send Feedback
Gizmox.WebGUI.Common.Switches Namespace : WGTracingSwitch Class

Syntax

Visual Basic (Declaration)
Public Class WGTracingSwitch
   Inherits TraceSwitch
Visual Basic (Usage) Copy Code
Dim instance As WGTracingSwitch
C#
public class WGTracingSwitch : TraceSwitch
Managed Extensions for C++
public __gc class WGTracingSwitch : public TraceSwitch
C++/CLI
public ref class WGTracingSwitch : public TraceSwitch

Inheritance Hierarchy

System.Object
System.Diagnostics.Switch
System.Diagnostics.TraceSwitch
Gizmox.WebGUI.Common.Switches.WGTracingSwitch

Requirements

Namespace: Gizmox.WebGUI.Common.Switches

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

WGTracingSwitch Members
Gizmox.WebGUI.Common.Switches Namespace


WGTracingSwitch Class Members

[image]
Gizmox.WebGUI.Common
WGTracingSwitch Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Common.Switches Namespace : WGTracingSwitch Class

The following tables list the members exposed by WGTracingSwitch.

Public Constructors

 | Name | Description
Public Constructor | WGTracingSwitch Constructor |
Top

Public Properties

 | Name | Description
Public Property | Attributes | Gets the custom switch attributes defined in the application configuration file. (Inherited from System.Diagnostics.Switch)
Public Property | Description | Gets a description of the switch. (Inherited from System.Diagnostics.Switch)
Public Property | DisplayName | Gets a name used to identify the switch. (Inherited from System.Diagnostics.Switch)
Public Property | Enabled |
Public Property | Level | Gets or sets the trace level that determines the messages the switch allows. (Inherited from System.Diagnostics.TraceSwitch)
Public Property | TraceError | Gets a value indicating whether the switch allows error-handling messages. (Inherited from System.Diagnostics.TraceSwitch)
Public Property | TraceInfo | Gets a value indicating whether the switch allows informational messages. (Inherited from System.Diagnostics.TraceSwitch)
Public Property | TraceVerbose | Gets a value indicating whether the switch allows all messages. (Inherited from System.Diagnostics.TraceSwitch)
Public Property | TraceWarning | Gets a value indicating whether the switch allows warning messages. (Inherited from System.Diagnostics.TraceSwitch)
Top

Protected Properties

 | Name | Description
Protected Property | SwitchSetting | Gets or sets the current setting for this switch. (Inherited from System.Diagnostics.Switch)
Protected Property | Value | Gets or sets the value of the switch. (Inherited from System.Diagnostics.Switch)
Top

Protected Methods

 | Name | Description
Protected Method | GetSupportedAttributes | Gets the custom attributes supported by the switch. (Inherited from System.Diagnostics.Switch)
Protected Method | OnSwitchSettingChanged | Updates and corrects the level for this switch. (Inherited from System.Diagnostics.TraceSwitch)
Protected Method | OnValueChanged | Sets the SwitchSetting property to the integer equivalent of the Value property. (Inherited from System.Diagnostics.TraceSwitch)
Top

See Also

Reference

WGTracingSwitch Class
Gizmox.WebGUI.Common.Switches Namespace


WGTracingSwitch Constructor

[image]
Gizmox.WebGUI.Common
WGTracingSwitch Constructor
See Also Send Feedback
Gizmox.WebGUI.Common.Switches Namespace > WGTracingSwitch Class : WGTracingSwitch Constructor

strName
strDescription

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal strName As String, _
   ByVal strDescription As String _
)
Visual Basic (Usage) Copy Code
Dim strName As String
Dim strDescription As String

Dim instance As WGTracingSwitch(strName, strDescription)
C#
public WGTracingSwitch(
   string strName,
   string strDescription
)
Managed Extensions for C++
public: WGTracingSwitch(
   string* strName,
   string* strDescription
)
C++/CLI
public:
WGTracingSwitch(
   String^ strName,
   String^ strDescription
)

Parameters

strName
strDescription

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGTracingSwitch Class
WGTracingSwitch Members


WGTracingSwitch Class Properties

[image]
Gizmox.WebGUI.Common
WGTracingSwitch Class Properties
See Also Send Feedback
Gizmox.WebGUI.Common.Switches Namespace : WGTracingSwitch Class

For a list of all members of this type, see WGTracingSwitch members.

Public Properties

 | Name | Description
Public Property | Attributes | Gets the custom switch attributes defined in the application configuration file. (Inherited from System.Diagnostics.Switch)
Public Property | Description | Gets a description of the switch. (Inherited from System.Diagnostics.Switch)
Public Property | DisplayName | Gets a name used to identify the switch. (Inherited from System.Diagnostics.Switch)
Public Property | Enabled |
Public Property | Level | Gets or sets the trace level that determines the messages the switch allows. (Inherited from System.Diagnostics.TraceSwitch)
Public Property | TraceError | Gets a value indicating whether the switch allows error-handling messages. (Inherited from System.Diagnostics.TraceSwitch)
Public Property | TraceInfo | Gets a value indicating whether the switch allows informational messages. (Inherited from System.Diagnostics.TraceSwitch)
Public Property | TraceVerbose | Gets a value indicating whether the switch allows all messages. (Inherited from System.Diagnostics.TraceSwitch)
Public Property | TraceWarning | Gets a value indicating whether the switch allows warning messages. (Inherited from System.Diagnostics.TraceSwitch)
Top

Protected Properties

 | Name | Description
Protected Property | SwitchSetting | Gets or sets the current setting for this switch. (Inherited from System.Diagnostics.Switch)
Protected Property | Value | Gets or sets the value of the switch. (Inherited from System.Diagnostics.Switch)
Top

See Also

Reference

WGTracingSwitch Class
Gizmox.WebGUI.Common.Switches Namespace


Enabled Property

[image]
Gizmox.WebGUI.Common
Enabled Property
See Also Send Feedback
Gizmox.WebGUI.Common.Switches Namespace > WGTracingSwitch Class : Enabled Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Enabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As WGTracingSwitch
Dim value As Boolean

value = instance.Enabled
C#
public bool Enabled {get;}
Managed Extensions for C++
public: __property bool get_Enabled();
C++/CLI
public:
property bool Enabled {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGTracingSwitch Class
WGTracingSwitch Members


WGTracingThresholdSwitch Class

[image]
Gizmox.WebGUI.Common
WGTracingThresholdSwitch Class
Members See Also Send Feedback
Gizmox.WebGUI.Common.Switches Namespace : WGTracingThresholdSwitch Class

Syntax

Visual Basic (Declaration)
Public Class WGTracingThresholdSwitch
   Inherits Switch
Visual Basic (Usage) Copy Code
Dim instance As WGTracingThresholdSwitch
C#
public class WGTracingThresholdSwitch : Switch
Managed Extensions for C++
public __gc class WGTracingThresholdSwitch : public Switch
C++/CLI
public ref class WGTracingThresholdSwitch : public Switch

Inheritance Hierarchy

System.Object
System.Diagnostics.Switch
Gizmox.WebGUI.Common.Switches.WGTracingThresholdSwitch

Requirements

Namespace: Gizmox.WebGUI.Common.Switches

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

WGTracingThresholdSwitch Members
Gizmox.WebGUI.Common.Switches Namespace


WGTracingThresholdSwitch Class Members

[image]
Gizmox.WebGUI.Common
WGTracingThresholdSwitch Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Common.Switches Namespace : WGTracingThresholdSwitch Class

The following tables list the members exposed by WGTracingThresholdSwitch.

Public Constructors

 | Name | Description
Public Constructor | WGTracingThresholdSwitch Constructor |
Top

Public Properties

 | Name | Description
Public Property | Attributes | Gets the custom switch attributes defined in the application configuration file. (Inherited from System.Diagnostics.Switch)
Public Property | Description | Gets a description of the switch. (Inherited from System.Diagnostics.Switch)
Public Property | DisplayName | Gets a name used to identify the switch. (Inherited from System.Diagnostics.Switch)
Public Property | Threshold |
Top

Protected Properties

 | Name | Description
Protected Property | SwitchSetting | Gets or sets the current setting for this switch. (Inherited from System.Diagnostics.Switch)
Protected Property | Value | Gets or sets the value of the switch. (Inherited from System.Diagnostics.Switch)
Top

Protected Methods

 | Name | Description
Protected Method | GetSupportedAttributes | Gets the custom attributes supported by the switch. (Inherited from System.Diagnostics.Switch)
Protected Method | OnSwitchSettingChanged | Invoked when the SwitchSetting property is changed. (Inherited from System.Diagnostics.Switch)
Protected Method | OnValueChanged | Invoked when the Value property is changed. (Inherited from System.Diagnostics.Switch)
Top

See Also

Reference

WGTracingThresholdSwitch Class
Gizmox.WebGUI.Common.Switches Namespace


WGTracingThresholdSwitch Constructor

[image]
Gizmox.WebGUI.Common
WGTracingThresholdSwitch Constructor
See Also Send Feedback
Gizmox.WebGUI.Common.Switches Namespace > WGTracingThresholdSwitch Class : WGTracingThresholdSwitch Constructor

strName
strDescription

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal strName As String, _
   ByVal strDescription As String _
)
Visual Basic (Usage) Copy Code
Dim strName As String
Dim strDescription As String

Dim instance As WGTracingThresholdSwitch(strName, strDescription)
C#
public WGTracingThresholdSwitch(
   string strName,
   string strDescription
)
Managed Extensions for C++
public: WGTracingThresholdSwitch(
   string* strName,
   string* strDescription
)
C++/CLI
public:
WGTracingThresholdSwitch(
   String^ strName,
   String^ strDescription
)

Parameters

strName
strDescription

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGTracingThresholdSwitch Class
WGTracingThresholdSwitch Members


WGTracingThresholdSwitch Class Properties

[image]
Gizmox.WebGUI.Common
WGTracingThresholdSwitch Class Properties
See Also Send Feedback
Gizmox.WebGUI.Common.Switches Namespace : WGTracingThresholdSwitch Class

For a list of all members of this type, see WGTracingThresholdSwitch members.

Public Properties

 | Name | Description
Public Property | Attributes | Gets the custom switch attributes defined in the application configuration file. (Inherited from System.Diagnostics.Switch)
Public Property | Description | Gets a description of the switch. (Inherited from System.Diagnostics.Switch)
Public Property | DisplayName | Gets a name used to identify the switch. (Inherited from System.Diagnostics.Switch)
Public Property | Threshold |
Top

Protected Properties

 | Name | Description
Protected Property | SwitchSetting | Gets or sets the current setting for this switch. (Inherited from System.Diagnostics.Switch)
Protected Property | Value | Gets or sets the value of the switch. (Inherited from System.Diagnostics.Switch)
Top

See Also

Reference

WGTracingThresholdSwitch Class
Gizmox.WebGUI.Common.Switches Namespace


Threshold Property

[image]
Gizmox.WebGUI.Common
Threshold Property
See Also Send Feedback
Gizmox.WebGUI.Common.Switches Namespace > WGTracingThresholdSwitch Class : Threshold Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Threshold As Integer
Visual Basic (Usage) Copy Code
Dim instance As WGTracingThresholdSwitch
Dim value As Integer

value = instance.Threshold
C#
public int Threshold {get;}
Managed Extensions for C++
public: __property int get_Threshold();
C++/CLI
public:
property int Threshold {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WGTracingThresholdSwitch Class
WGTracingThresholdSwitch Members


Gizmox.WebGUI.Common.Trace Namespace

Gizmox.WebGUI.Common
Gizmox.WebGUI.Common.Trace Namespace
See Also Inheritance Hierarchy Send Feedback

Classes

 | Class | Description
Class | EventTraceRecord |
Class | RenderTraceRecord |
Class | TraceRecord |
Class | VerboseRecord |

See Also

Reference

Gizmox.WebGUI.Common Assembly


EventTraceRecord Class

[image]
Gizmox.WebGUI.Common
EventTraceRecord Class
Members See Also Send Feedback
Gizmox.WebGUI.Common.Trace Namespace : EventTraceRecord Class

Syntax

Visual Basic (Declaration)
Public Class EventTraceRecord
   Inherits TraceRecord
Visual Basic (Usage) Copy Code
Dim instance As EventTraceRecord
C#
public class EventTraceRecord : TraceRecord
Managed Extensions for C++
public __gc class EventTraceRecord : public TraceRecord
C++/CLI
public ref class EventTraceRecord : public TraceRecord

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Common.Trace.TraceRecord
Gizmox.WebGUI.Common.Trace.EventTraceRecord

Requirements

Namespace: Gizmox.WebGUI.Common.Trace

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

EventTraceRecord Members
Gizmox.WebGUI.Common.Trace Namespace


EventTraceRecord Class Members

[image]
Gizmox.WebGUI.Common
EventTraceRecord Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Common.Trace Namespace : EventTraceRecord Class

The following tables list the members exposed by EventTraceRecord.

Public Constructors

 | Name | Description
Public Constructor | EventTraceRecord Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Category | (Inherited from TraceRecord)
Public Property | Description | Overridden.
Public Property | Performance | (Inherited from TraceRecord)
Public Property | Section | Overridden.
Public Property | Subject | Overridden.
Public Property | Type | Overridden.
Public Property | TypeName | (Inherited from TraceRecord)
Top

Protected Methods

 | Name | Description
Protected Method | GetMessage | (Inherited from TraceRecord)
Top

See Also

Reference

EventTraceRecord Class
Gizmox.WebGUI.Common.Trace Namespace


EventTraceRecord Constructor

[image]
Gizmox.WebGUI.Common
EventTraceRecord Constructor
See Also Send Feedback
Gizmox.WebGUI.Common.Trace Namespace > EventTraceRecord Class : EventTraceRecord Constructor

Overload List

Overload | Description
EventTraceRecord Constructor(IEvent,IRegisteredComponent,Int64) |
EventTraceRecord Constructor(String,IRegisteredComponent,Int64) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

EventTraceRecord Class
EventTraceRecord Members


EventTraceRecord Constructor(IEvent,IRegisteredComponent,Int64)

[image]
Gizmox.WebGUI.Common
EventTraceRecord Constructor(IEvent,IRegisteredComponent,Int64)
See Also Send Feedback
Gizmox.WebGUI.Common.Trace Namespace > EventTraceRecord Class > EventTraceRecord Constructor : EventTraceRecord Constructor(IEvent,IRegisteredComponent,Int64)

objEvent
objComponent
lngTimeMarker

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal objEvent As IEvent, _
   ByVal objComponent As IRegisteredComponent, _
   ByVal lngTimeMarker As Long _
)
Visual Basic (Usage) Copy Code
Dim objEvent As IEvent
Dim objComponent As IRegisteredComponent
Dim lngTimeMarker As Long

Dim instance As EventTraceRecord(objEvent, objComponent, lngTimeMarker)
C#
public EventTraceRecord(
   IEvent objEvent,
   IRegisteredComponent objComponent,
   long lngTimeMarker
)
Managed Extensions for C++
public: EventTraceRecord(
   IEvent* objEvent,
   IRegisteredComponent* objComponent,
   long lngTimeMarker
)
C++/CLI
public:
EventTraceRecord(
   IEvent^ objEvent,
   IRegisteredComponent^ objComponent,
   long long lngTimeMarker
)

Parameters

objEvent
objComponent
lngTimeMarker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

EventTraceRecord Class
EventTraceRecord Members
Overload List


EventTraceRecord Constructor(String,IRegisteredComponent,Int64)

[image]
Gizmox.WebGUI.Common
EventTraceRecord Constructor(String,IRegisteredComponent,Int64)
See Also Send Feedback
Gizmox.WebGUI.Common.Trace Namespace > EventTraceRecord Class > EventTraceRecord Constructor : EventTraceRecord Constructor(String,IRegisteredComponent,Int64)

strEventType
objComponent
lngTimeMarker

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal strEventType As String, _
   ByVal objComponent As IRegisteredComponent, _
   ByVal lngTimeMarker As Long _
)
Visual Basic (Usage) Copy Code
Dim strEventType As String
Dim objComponent As IRegisteredComponent
Dim lngTimeMarker As Long

Dim instance As EventTraceRecord(strEventType, objComponent, lngTimeMarker)
C#
public EventTraceRecord(
   string strEventType,
   IRegisteredComponent objComponent,
   long lngTimeMarker
)
Managed Extensions for C++
public: EventTraceRecord(
   string* strEventType,
   IRegisteredComponent* objComponent,
   long lngTimeMarker
)
C++/CLI
public:
EventTraceRecord(
   String^ strEventType,
   IRegisteredComponent^ objComponent,
   long long lngTimeMarker
)

Parameters

strEventType
objComponent
lngTimeMarker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

EventTraceRecord Class
EventTraceRecord Members
Overload List


EventTraceRecord Class Properties

[image]
Gizmox.WebGUI.Common
EventTraceRecord Class Properties
See Also Send Feedback
Gizmox.WebGUI.Common.Trace Namespace : EventTraceRecord Class

For a list of all members of this type, see EventTraceRecord members.

Public Properties

 | Name | Description
Public Property | Category | (Inherited from TraceRecord)
Public Property | Description | Overridden.
Public Property | Performance | (Inherited from TraceRecord)
Public Property | Section | Overridden.
Public Property | Subject | Overridden.
Public Property | Type | Overridden.
Public Property | TypeName | (Inherited from TraceRecord)
Top

See Also

Reference

EventTraceRecord Class
Gizmox.WebGUI.Common.Trace Namespace


Description Property

[image]
Gizmox.WebGUI.Common
Description Property
See Also Send Feedback
Gizmox.WebGUI.Common.Trace Namespace > EventTraceRecord Class : Description Property

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Description As String
Visual Basic (Usage) Copy Code
Dim instance As EventTraceRecord
Dim value As String

value = instance.Description
C#
public override string Description {get;}
Managed Extensions for C++
public: __property string* get_Description() override;
C++/CLI
public:
property String^ Description {
   String^ get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

EventTraceRecord Class
EventTraceRecord Members


Section Property

[image]
Gizmox.WebGUI.Common
Section Property
See Also Send Feedback
Gizmox.WebGUI.Common.Trace Namespace > EventTraceRecord Class : Section Property

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Section As String
Visual Basic (Usage) Copy Code
Dim instance As EventTraceRecord
Dim value As String

value = instance.Section
C#
public override string Section {get;}
Managed Extensions for C++
public: __property string* get_Section() override;
C++/CLI
public:
property String^ Section {
   String^ get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

EventTraceRecord Class
EventTraceRecord Members


Subject Property

[image]
Gizmox.WebGUI.Common
Subject Property
See Also Send Feedback
Gizmox.WebGUI.Common.Trace Namespace > EventTraceRecord Class : Subject Property

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Subject As String
Visual Basic (Usage) Copy Code
Dim instance As EventTraceRecord
Dim value As String

value = instance.Subject
C#
public override string Subject {get;}
Managed Extensions for C++
public: __property string* get_Subject() override;
C++/CLI
public:
property String^ Subject {
   String^ get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

EventTraceRecord Class
EventTraceRecord Members


Type Property

[image]
Gizmox.WebGUI.Common
Type Property
See Also Send Feedback
Gizmox.WebGUI.Common.Trace Namespace > EventTraceRecord Class : Type Property

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Type As Type
Visual Basic (Usage) Copy Code
Dim instance As EventTraceRecord
Dim value As Type

value = instance.Type
C#
public override Type Type {get;}
Managed Extensions for C++
public: __property Type* get_Type() override;
C++/CLI
public:
property Type^ Type {
   Type^ get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

EventTraceRecord Class
EventTraceRecord Members


RenderTraceRecord Class

[image]
Gizmox.WebGUI.Common
RenderTraceRecord Class
Members See Also Send Feedback
Gizmox.WebGUI.Common.Trace Namespace : RenderTraceRecord Class

Syntax

Visual Basic (Declaration)
Public Class RenderTraceRecord
   Inherits TraceRecord
Visual Basic (Usage) Copy Code
Dim instance As RenderTraceRecord
C#
public class RenderTraceRecord : TraceRecord
Managed Extensions for C++
public __gc class RenderTraceRecord : public TraceRecord
C++/CLI
public ref class RenderTraceRecord : public TraceRecord

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Common.Trace.TraceRecord
Gizmox.WebGUI.Common.Trace.RenderTraceRecord

Requirements

Namespace: Gizmox.WebGUI.Common.Trace

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

RenderTraceRecord Members
Gizmox.WebGUI.Common.Trace Namespace


RenderTraceRecord Class Members

[image]
Gizmox.WebGUI.Common
RenderTraceRecord Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Common.Trace Namespace : RenderTraceRecord Class

The following tables list the members exposed by RenderTraceRecord.

Public Constructors

 | Name | Description
Public Constructor | RenderTraceRecord Constructor |
Top

Public Properties

 | Name | Description
Public Property | Category | (Inherited from TraceRecord)
Public Property | Description | Overridden.
Public Property | Performance | (Inherited from TraceRecord)
Public Property | Section | Overridden.
Public Property | Subject | Overridden.
Public Property | Type | Overridden.
Public Property | TypeName | (Inherited from TraceRecord)
Top

Protected Methods

 | Name | Description
Protected Method | GetMessage | (Inherited from TraceRecord)
Top

See Also

Reference

RenderTraceRecord Class
Gizmox.WebGUI.Common.Trace Namespace


RenderTraceRecord Constructor

[image]
Gizmox.WebGUI.Common
RenderTraceRecord Constructor
See Also Send Feedback
Gizmox.WebGUI.Common.Trace Namespace > RenderTraceRecord Class : RenderTraceRecord Constructor

objForm
lngTimeMarker

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal objForm As IForm, _
   ByVal lngTimeMarker As Long _
)
Visual Basic (Usage) Copy Code
Dim objForm As IForm
Dim lngTimeMarker As Long

Dim instance As RenderTraceRecord(objForm, lngTimeMarker)
C#
public RenderTraceRecord(
   IForm objForm,
   long lngTimeMarker
)
Managed Extensions for C++
public: RenderTraceRecord(
   IForm* objForm,
   long lngTimeMarker
)
C++/CLI
public:
RenderTraceRecord(
   IForm^ objForm,
   long long lngTimeMarker
)

Parameters

objForm
lngTimeMarker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RenderTraceRecord Class
RenderTraceRecord Members


RenderTraceRecord Class Properties

[image]
Gizmox.WebGUI.Common
RenderTraceRecord Class Properties
See Also Send Feedback
Gizmox.WebGUI.Common.Trace Namespace : RenderTraceRecord Class

For a list of all members of this type, see RenderTraceRecord members.

Public Properties

 | Name | Description
Public Property | Category | (Inherited from TraceRecord)
Public Property | Description | Overridden.
Public Property | Performance | (Inherited from TraceRecord)
Public Property | Section | Overridden.
Public Property | Subject | Overridden.
Public Property | Type | Overridden.
Public Property | TypeName | (Inherited from TraceRecord)
Top

See Also

Reference

RenderTraceRecord Class
Gizmox.WebGUI.Common.Trace Namespace


Description Property

[image]
Gizmox.WebGUI.Common
Description Property
See Also Send Feedback
Gizmox.WebGUI.Common.Trace Namespace > RenderTraceRecord Class : Description Property

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Description As String
Visual Basic (Usage) Copy Code
Dim instance As RenderTraceRecord
Dim value As String

value = instance.Description
C#
public override string Description {get;}
Managed Extensions for C++
public: __property string* get_Description() override;
C++/CLI
public:
property String^ Description {
   String^ get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RenderTraceRecord Class
RenderTraceRecord Members


Section Property

[image]
Gizmox.WebGUI.Common
Section Property
See Also Send Feedback
Gizmox.WebGUI.Common.Trace Namespace > RenderTraceRecord Class : Section Property

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Section As String
Visual Basic (Usage) Copy Code
Dim instance As RenderTraceRecord
Dim value As String

value = instance.Section
C#
public override string Section {get;}
Managed Extensions for C++
public: __property string* get_Section() override;
C++/CLI
public:
property String^ Section {
   String^ get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RenderTraceRecord Class
RenderTraceRecord Members


Subject Property

[image]
Gizmox.WebGUI.Common
Subject Property
See Also Send Feedback
Gizmox.WebGUI.Common.Trace Namespace > RenderTraceRecord Class : Subject Property

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Subject As String
Visual Basic (Usage) Copy Code
Dim instance As RenderTraceRecord
Dim value As String

value = instance.Subject
C#
public override string Subject {get;}
Managed Extensions for C++
public: __property string* get_Subject() override;
C++/CLI
public:
property String^ Subject {
   String^ get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RenderTraceRecord Class
RenderTraceRecord Members


Type Property

[image]
Gizmox.WebGUI.Common
Type Property
See Also Send Feedback
Gizmox.WebGUI.Common.Trace Namespace > RenderTraceRecord Class : Type Property

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Type As Type
Visual Basic (Usage) Copy Code
Dim instance As RenderTraceRecord
Dim value As Type

value = instance.Type
C#
public override Type Type {get;}
Managed Extensions for C++
public: __property Type* get_Type() override;
C++/CLI
public:
property Type^ Type {
   Type^ get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RenderTraceRecord Class
RenderTraceRecord Members


TraceRecord Class

[image]
Gizmox.WebGUI.Common
TraceRecord Class
Members See Also Send Feedback
Gizmox.WebGUI.Common.Trace Namespace : TraceRecord Class

Syntax

Visual Basic (Declaration)
Public Class TraceRecord
Visual Basic (Usage) Copy Code
Dim instance As TraceRecord
C#
public class TraceRecord
Managed Extensions for C++
public __gc class TraceRecord
C++/CLI
public ref class TraceRecord

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Common.Trace.TraceRecord
Gizmox.WebGUI.Common.Trace.EventTraceRecord
Gizmox.WebGUI.Common.Trace.RenderTraceRecord

Requirements

Namespace: Gizmox.WebGUI.Common.Trace

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

TraceRecord Members
Gizmox.WebGUI.Common.Trace Namespace


TraceRecord Class Members

[image]
Gizmox.WebGUI.Common
TraceRecord Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Common.Trace Namespace : TraceRecord Class

The following tables list the members exposed by TraceRecord.

Public Constructors

 | Name | Description
Public Constructor | TraceRecord Constructor |
Top

Public Properties

 | Name | Description
Public Property | Category |
Public Property | Description |
Public Property | Performance |
Public Property | Section |
Public Property | Subject |
Public Property | Type |
Public Property | TypeName |
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Write |
Top

Protected Methods

 | Name | Description
Protected Method | GetMessage |
Top

See Also

Reference

TraceRecord Class
Gizmox.WebGUI.Common.Trace Namespace


TraceRecord Constructor

[image]
Gizmox.WebGUI.Common
TraceRecord Constructor
See Also Send Feedback
Gizmox.WebGUI.Common.Trace Namespace > TraceRecord Class : TraceRecord Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As TraceRecord()
C#
public TraceRecord()
Managed Extensions for C++
public: TraceRecord();
C++/CLI
public:
TraceRecord();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TraceRecord Class
TraceRecord Members


TraceRecord Class Methods

[image]
Gizmox.WebGUI.Common
TraceRecord Class Methods
See Also Send Feedback
Gizmox.WebGUI.Common.Trace Namespace : TraceRecord Class

For a list of all members of this type, see TraceRecord members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Write |
Top

Protected Methods

 | Name | Description
Protected Method | GetMessage |
Top

See Also

Reference

TraceRecord Class
Gizmox.WebGUI.Common.Trace Namespace


GetMessage Method

[image]
Gizmox.WebGUI.Common
GetMessage Method
See Also Send Feedback
Gizmox.WebGUI.Common.Trace Namespace > TraceRecord Class : GetMessage Method

Syntax

Visual Basic (Declaration)
Protected Function GetMessage() As String
Visual Basic (Usage) Copy Code
Dim instance As TraceRecord
Dim value As String

value = instance.GetMessage()
C#
protected string GetMessage()
Managed Extensions for C++
protected: string* GetMessage();
C++/CLI
protected:
String^ GetMessage();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TraceRecord Class
TraceRecord Members


Write Method

[image]
Gizmox.WebGUI.Common
Write Method
See Also Send Feedback
Gizmox.WebGUI.Common.Trace Namespace > TraceRecord Class : Write Method

objTraceRecord

Syntax

Visual Basic (Declaration)
Public Shared Sub Write( _
   ByVal objTraceRecord As TraceRecord _
)
Visual Basic (Usage) Copy Code
Dim objTraceRecord As TraceRecord

TraceRecord.Write(objTraceRecord)
C#
public static void Write(
   TraceRecord objTraceRecord
)
Managed Extensions for C++
public: static void Write(
   TraceRecord* objTraceRecord
)
C++/CLI
public:
static void Write(
   TraceRecord^ objTraceRecord
)

Parameters

objTraceRecord

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TraceRecord Class
TraceRecord Members


TraceRecord Class Properties

[image]
Gizmox.WebGUI.Common
TraceRecord Class Properties
See Also Send Feedback
Gizmox.WebGUI.Common.Trace Namespace : TraceRecord Class

For a list of all members of this type, see TraceRecord members.

Public Properties

 | Name | Description
Public Property | Category |
Public Property | Description |
Public Property | Performance |
Public Property | Section |
Public Property | Subject |
Public Property | Type |
Public Property | TypeName |
Top

See Also

Reference

TraceRecord Class
Gizmox.WebGUI.Common.Trace Namespace


Category Property

[image]
Gizmox.WebGUI.Common
Category Property
See Also Send Feedback
Gizmox.WebGUI.Common.Trace Namespace > TraceRecord Class : Category Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Category As String
Visual Basic (Usage) Copy Code
Dim instance As TraceRecord
Dim value As String

value = instance.Category
C#
public string Category {get;}
Managed Extensions for C++
public: __property string* get_Category();
C++/CLI
public:
property String^ Category {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TraceRecord Class
TraceRecord Members


Description Property

[image]
Gizmox.WebGUI.Common
Description Property
See Also Send Feedback
Gizmox.WebGUI.Common.Trace Namespace > TraceRecord Class : Description Property

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Description As String
Visual Basic (Usage) Copy Code
Dim instance As TraceRecord
Dim value As String

value = instance.Description
C#
public virtual string Description {get;}
Managed Extensions for C++
public: __property virtual string* get_Description();
C++/CLI
public:
virtual property String^ Description {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TraceRecord Class
TraceRecord Members


Performance Property

[image]
Gizmox.WebGUI.Common
Performance Property
See Also Send Feedback
Gizmox.WebGUI.Common.Trace Namespace > TraceRecord Class : Performance Property

Syntax

Visual Basic (Declaration)
Public Property Performance As Long
Visual Basic (Usage) Copy Code
Dim instance As TraceRecord
Dim value As Long

instance.Performance = value

value = instance.Performance
C#
public long Performance {get; set;}
Managed Extensions for C++
public: __property long get_Performance();
public: __property void set_Performance(
   long value
);
C++/CLI
public:
property long long Performance {
   long long get();
   void set (long longvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TraceRecord Class
TraceRecord Members


Section Property

[image]
Gizmox.WebGUI.Common
Section Property
See Also Send Feedback
Gizmox.WebGUI.Common.Trace Namespace > TraceRecord Class : Section Property

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Section As String
Visual Basic (Usage) Copy Code
Dim instance As TraceRecord
Dim value As String

value = instance.Section
C#
public virtual string Section {get;}
Managed Extensions for C++
public: __property virtual string* get_Section();
C++/CLI
public:
virtual property String^ Section {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TraceRecord Class
TraceRecord Members


Subject Property

[image]
Gizmox.WebGUI.Common
Subject Property
See Also Send Feedback
Gizmox.WebGUI.Common.Trace Namespace > TraceRecord Class : Subject Property

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Subject As String
Visual Basic (Usage) Copy Code
Dim instance As TraceRecord
Dim value As String

value = instance.Subject
C#
public virtual string Subject {get;}
Managed Extensions for C++
public: __property virtual string* get_Subject();
C++/CLI
public:
virtual property String^ Subject {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TraceRecord Class
TraceRecord Members


Type Property

[image]
Gizmox.WebGUI.Common
Type Property
See Also Send Feedback
Gizmox.WebGUI.Common.Trace Namespace > TraceRecord Class : Type Property

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Type As Type
Visual Basic (Usage) Copy Code
Dim instance As TraceRecord
Dim value As Type

value = instance.Type
C#
public virtual Type Type {get;}
Managed Extensions for C++
public: __property virtual Type* get_Type();
C++/CLI
public:
virtual property Type^ Type {
   Type^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TraceRecord Class
TraceRecord Members


TypeName Property

[image]
Gizmox.WebGUI.Common
TypeName Property
See Also Send Feedback
Gizmox.WebGUI.Common.Trace Namespace > TraceRecord Class : TypeName Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TypeName As String
Visual Basic (Usage) Copy Code
Dim instance As TraceRecord
Dim value As String

value = instance.TypeName
C#
public string TypeName {get;}
Managed Extensions for C++
public: __property string* get_TypeName();
C++/CLI
public:
property String^ TypeName {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TraceRecord Class
TraceRecord Members


VerboseRecord Class

[image]
Gizmox.WebGUI.Common
VerboseRecord Class
Members See Also Send Feedback
Gizmox.WebGUI.Common.Trace Namespace : VerboseRecord Class

Syntax

Visual Basic (Declaration)
Public Class VerboseRecord
Visual Basic (Usage) Copy Code
Dim instance As VerboseRecord
C#
public class VerboseRecord
Managed Extensions for C++
public __gc class VerboseRecord
C++/CLI
public ref class VerboseRecord

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Common.Trace.VerboseRecord

Requirements

Namespace: Gizmox.WebGUI.Common.Trace

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

VerboseRecord Members
Gizmox.WebGUI.Common.Trace Namespace


VerboseRecord Class Members

[image]
Gizmox.WebGUI.Common
VerboseRecord Class Members
See Also Methods Send Feedback
Gizmox.WebGUI.Common.Trace Namespace : VerboseRecord Class

The following tables list the members exposed by VerboseRecord.

Public Constructors

 | Name | Description
Public Constructor | VerboseRecord Constructor |
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Write | Overloaded.
Top

See Also

Reference

VerboseRecord Class
Gizmox.WebGUI.Common.Trace Namespace


VerboseRecord Constructor

[image]
Gizmox.WebGUI.Common
VerboseRecord Constructor
See Also Send Feedback
Gizmox.WebGUI.Common.Trace Namespace > VerboseRecord Class : VerboseRecord Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As VerboseRecord()
C#
public VerboseRecord()
Managed Extensions for C++
public: VerboseRecord();
C++/CLI
public:
VerboseRecord();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

VerboseRecord Class
VerboseRecord Members


VerboseRecord Class Methods

[image]
Gizmox.WebGUI.Common
VerboseRecord Class Methods
See Also Send Feedback
Gizmox.WebGUI.Common.Trace Namespace : VerboseRecord Class

For a list of all members of this type, see VerboseRecord members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Write | Overloaded.
Top

See Also

Reference

VerboseRecord Class
Gizmox.WebGUI.Common.Trace Namespace


Write Method

[image]
Gizmox.WebGUI.Common
Write Method
See Also Send Feedback
Gizmox.WebGUI.Common.Trace Namespace > VerboseRecord Class : Write Method

Overload List

Overload | Description
Write(String,String,String,String) |
Write(String,String,String,String,Boolean) |
Write(Object,String,String,String) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

VerboseRecord Class
VerboseRecord Members


Write(String,String,String,String) Method

[image]
Gizmox.WebGUI.Common
Write(String,String,String,String) Method
See Also Send Feedback
Gizmox.WebGUI.Common.Trace Namespace > VerboseRecord Class > Write Method : Write(String,String,String,String) Method

strSource
strActionCategory
strAction
strMessage

Syntax

Visual Basic (Declaration)
Public Overloads Shared Sub Write( _
   ByVal strSource As String, _
   ByVal strActionCategory As String, _
   ByVal strAction As String, _
   ByVal strMessage As String _
)
Visual Basic (Usage) Copy Code
Dim strSource As String
Dim strActionCategory As String
Dim strAction As String
Dim strMessage As String

VerboseRecord.Write(strSource, strActionCategory, strAction, strMessage)
C#
public static void Write(
   string strSource,
   string strActionCategory,
   string strAction,
   string strMessage
)
Managed Extensions for C++
public: static void Write(
   string* strSource,
   string* strActionCategory,
   string* strAction,
   string* strMessage
)
C++/CLI
public:
static void Write(
   String^ strSource,
   String^ strActionCategory,
   String^ strAction,
   String^ strMessage
)

Parameters

strSource
strActionCategory
strAction
strMessage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

VerboseRecord Class
VerboseRecord Members
Overload List


Write(String,String,String,String,Boolean) Method

[image]
Gizmox.WebGUI.Common
Write(String,String,String,String,Boolean) Method
See Also Send Feedback
Gizmox.WebGUI.Common.Trace Namespace > VerboseRecord Class > Write Method : Write(String,String,String,String,Boolean) Method

strSource
strActionCategory
strAction
strMessage
blnCondition

Syntax

Visual Basic (Declaration)
Public Overloads Shared Sub Write( _
   ByVal strSource As String, _
   ByVal strActionCategory As String, _
   ByVal strAction As String, _
   ByVal strMessage As String, _
   ByVal blnCondition As Boolean _
)
Visual Basic (Usage) Copy Code
Dim strSource As String
Dim strActionCategory As String
Dim strAction As String
Dim strMessage As String
Dim blnCondition As Boolean

VerboseRecord.Write(strSource, strActionCategory, strAction, strMessage, blnCondition)
C#
public static void Write(
   string strSource,
   string strActionCategory,
   string strAction,
   string strMessage,
   bool blnCondition
)
Managed Extensions for C++
public: static void Write(
   string* strSource,
   string* strActionCategory,
   string* strAction,
   string* strMessage,
   bool blnCondition
)
C++/CLI
public:
static void Write(
   String^ strSource,
   String^ strActionCategory,
   String^ strAction,
   String^ strMessage,
   bool blnCondition
)

Parameters

strSource
strActionCategory
strAction
strMessage
blnCondition

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

VerboseRecord Class
VerboseRecord Members
Overload List


Write(Object,String,String,String) Method

[image]
Gizmox.WebGUI.Common
Write(Object,String,String,String) Method
See Also Send Feedback
Gizmox.WebGUI.Common.Trace Namespace > VerboseRecord Class > Write Method : Write(Object,String,String,String) Method

objSource
strActionCategory
strAction
strMessage

Syntax

Visual Basic (Declaration)
Public Overloads Shared Sub Write( _
   ByVal objSource As Object, _
   ByVal strActionCategory As String, _
   ByVal strAction As String, _
   ByVal strMessage As String _
)
Visual Basic (Usage) Copy Code
Dim objSource As Object
Dim strActionCategory As String
Dim strAction As String
Dim strMessage As String

VerboseRecord.Write(objSource, strActionCategory, strAction, strMessage)
C#
public static void Write(
   object objSource,
   string strActionCategory,
   string strAction,
   string strMessage
)
Managed Extensions for C++
public: static void Write(
   Object* objSource,
   string* strActionCategory,
   string* strAction,
   string* strMessage
)
C++/CLI
public:
static void Write(
   Object^ objSource,
   String^ strActionCategory,
   String^ strAction,
   String^ strMessage
)

Parameters

objSource
strActionCategory
strAction
strMessage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

VerboseRecord Class
VerboseRecord Members
Overload List


Gizmox.WebGUI.Forms Namespace (Gizmox.WebGUI.Common)

Gizmox.WebGUI.Common
Gizmox.WebGUI.Forms Namespace (Gizmox.WebGUI.Common)
See Also Inheritance Hierarchy Send Feedback

Classes

 | Class | Description
Class | Application |
Class | ComponentBase |
Class | FormCollection |
Class | Metadata |
Class | MetadataControl |
Class | MetadataTagAttribute |
Class | RegisteredClientAction |
Class | RegisteredComponent |
Class | RegisteredComponent.NotImplementedGateway |
Class | Theme |
Class | Theme.FlavorCollection |
Class | Theme.ThemeCollection |
Class | ThemeFlavor |
Class | ThemeFonts |
Class | ThreadBookmarkEventArgs |
Class | ThreadExceptionEventArgs |
Class | ThreadMessage |
Class | ThreadMessageEventArgs |
Class | VWGContext |

Interfaces

 | Interface | Description
Interface | IDataObject |
Interface | IFilteredCompoenent |

Delegates

 | Delegate | Description
Delegate | ThreadBookmarkEventHandler |
Delegate | ThreadExceptionEventHandler |
Delegate | ThreadMessageEventHandler |

Enumerations

 | Enumeration | Description
Enumeration | AttributeType |
Enumeration | CheckState |
Enumeration | DialogResult |
Enumeration | EventTypes |
Enumeration | ExecutionMode |
Enumeration | KeyFilter |
Enumeration | Keys |
Enumeration | LinkWindowStyle |
Enumeration | MouseButtons |
Enumeration | ThreadMessageRecipientType |
Enumeration | UnhandledExceptionMode |

See Also

Reference

Gizmox.WebGUI.Common Assembly


Application Class

[image]
Gizmox.WebGUI.Common
Application Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : Application Class

Object Model

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Application
Visual Basic (Usage) Copy Code
Dim instance As Application
C#
public sealed class Application
Managed Extensions for C++
public __gc __sealed class Application
C++/CLI
public ref class Application sealed

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.Application

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

Application Members
Gizmox.WebGUI.Forms Namespace


Application Class Members

[image]
Gizmox.WebGUI.Common
Application Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : Application Class

The following tables list the members exposed by Application.

Public Constructors

 | Name | Description
Public Constructor | Application Constructor |
Top

Public Properties

 | Name | Description
static (Shared in Visual Basic) | AllowQuit |
static (Shared in Visual Basic) | CompanyName |
static (Shared in Visual Basic) | CurrentCulture |
static (Shared in Visual Basic) | ExecutablePath |
static (Shared in Visual Basic) | LocalUserAppDataPath |
static (Shared in Visual Basic) | MessageLoop |
static (Shared in Visual Basic) | OpenForms |
static (Shared in Visual Basic) | ProductName |
static (Shared in Visual Basic) | ProductVersion |
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | DoEvents |
static (Shared in Visual Basic) | EnableVisualStyles |
static (Shared in Visual Basic) | Exit | Overloaded.
static (Shared in Visual Basic) | ExitThread |
static (Shared in Visual Basic) | OnThreadException |
static (Shared in Visual Basic) | Restart |
static (Shared in Visual Basic) | SetCompatibleTextRenderingDefault |
static (Shared in Visual Basic) | SetThreadBookmark | Overloaded.
static (Shared in Visual Basic) | SetUnhandledExceptionMode | Overloaded.
static (Shared in Visual Basic) | UnregisterMessageLoop |
Top

Public Events

 | Name | Description
Public Event | ApplicationExit |
Public Event | EnterThreadModal |
Public Event | Idle |
Public Event | LeaveThreadModal |
Public Event | ThreadBookmarkNavigate |
Public Event | ThreadException |
Public Event | ThreadExit |
Public Event | ThreadMessage |
Public Event | ThreadRefresh |
Public Event | ThreadSuspend |
Public Event | ThreadTick |
Top

See Also

Reference

Application Class
Gizmox.WebGUI.Forms Namespace


Application Constructor

[image]
Gizmox.WebGUI.Common
Application Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Application Class : Application Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Application()
C#
public Application()
Managed Extensions for C++
public: Application();
C++/CLI
public:
Application();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Application Class
Application Members


Application Class Methods

[image]
Gizmox.WebGUI.Common
Application Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : Application Class

For a list of all members of this type, see Application members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | DoEvents |
static (Shared in Visual Basic) | EnableVisualStyles |
static (Shared in Visual Basic) | Exit | Overloaded.
static (Shared in Visual Basic) | ExitThread |
static (Shared in Visual Basic) | OnThreadException |
static (Shared in Visual Basic) | Restart |
static (Shared in Visual Basic) | SetCompatibleTextRenderingDefault |
static (Shared in Visual Basic) | SetThreadBookmark | Overloaded.
static (Shared in Visual Basic) | SetUnhandledExceptionMode | Overloaded.
static (Shared in Visual Basic) | UnregisterMessageLoop |
Top

See Also

Reference

Application Class
Gizmox.WebGUI.Forms Namespace


DoEvents Method

[image]
Gizmox.WebGUI.Common
DoEvents Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Application Class : DoEvents Method

Syntax

Visual Basic (Declaration)
Public Shared Sub DoEvents()
Visual Basic (Usage) Copy Code
Application.DoEvents()
C#
public static void DoEvents()
Managed Extensions for C++
public: static void DoEvents();
C++/CLI
public:
static void DoEvents();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Application Class
Application Members


EnableVisualStyles Method

[image]
Gizmox.WebGUI.Common
EnableVisualStyles Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Application Class : EnableVisualStyles Method

Syntax

Visual Basic (Declaration)
Public Shared Sub EnableVisualStyles()
Visual Basic (Usage) Copy Code
Application.EnableVisualStyles()
C#
public static void EnableVisualStyles()
Managed Extensions for C++
public: static void EnableVisualStyles();
C++/CLI
public:
static void EnableVisualStyles();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Application Class
Application Members


Exit Method

[image]
Gizmox.WebGUI.Common
Exit Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Application Class : Exit Method

Overload List

Overload | Description
Exit() |
Exit(CancelEventArgs) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Application Class
Application Members


Exit() Method

[image]
Gizmox.WebGUI.Common
Exit() Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Application Class > Exit Method : Exit() Method

Syntax

Visual Basic (Declaration)
Public Overloads Shared Sub Exit()
Visual Basic (Usage) Copy Code
Application.Exit()
C#
public static void Exit()
Managed Extensions for C++
public: static void Exit();
C++/CLI
public:
static void Exit();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Application Class
Application Members
Overload List


Exit(CancelEventArgs) Method

[image]
Gizmox.WebGUI.Common
Exit(CancelEventArgs) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Application Class > Exit Method : Exit(CancelEventArgs) Method

e

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Overloads Shared Sub Exit( _
   ByVal e As CancelEventArgs _
)
Visual Basic (Usage) Copy Code
Dim e As CancelEventArgs

Application.Exit(e)
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public static void Exit(
   CancelEventArgs e
)
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: static void Exit(
   CancelEventArgs* e
)
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
static void Exit(
   CancelEventArgs^ e
)

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Application Class
Application Members
Overload List


ExitThread Method

[image]
Gizmox.WebGUI.Common
ExitThread Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Application Class : ExitThread Method

Syntax

Visual Basic (Declaration)
Public Shared Sub ExitThread()
Visual Basic (Usage) Copy Code
Application.ExitThread()
C#
public static void ExitThread()
Managed Extensions for C++
public: static void ExitThread();
C++/CLI
public:
static void ExitThread();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Application Class
Application Members


OnThreadException Method

[image]
Gizmox.WebGUI.Common
OnThreadException Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Application Class : OnThreadException Method

t

Syntax

Visual Basic (Declaration)
Public Shared Sub OnThreadException( _
   ByVal t As Exception _
)
Visual Basic (Usage) Copy Code
Dim t As Exception

Application.OnThreadException(t)
C#
public static void OnThreadException(
   Exception t
)
Managed Extensions for C++
public: static void OnThreadException(
   Exception* t
)
C++/CLI
public:
static void OnThreadException(
   Exception^ t
)

Parameters

t

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Application Class
Application Members


Restart Method

[image]
Gizmox.WebGUI.Common
Restart Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Application Class : Restart Method

Syntax

Visual Basic (Declaration)
<SecurityPermissionAttribute(Assertion=False,
   UnmanagedCode=True,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=False,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Unrestricted=False)>
Public Shared Sub Restart()
Visual Basic (Usage) Copy Code
Application.Restart()
C#
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public static void Restart()
Managed Extensions for C++
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public: static void Restart();
C++/CLI
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public:
static void Restart();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Application Class
Application Members


SetCompatibleTextRenderingDefault Method

[image]
Gizmox.WebGUI.Common
SetCompatibleTextRenderingDefault Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Application Class : SetCompatibleTextRenderingDefault Method

defaultValue

Syntax

Visual Basic (Declaration)
Public Shared Sub SetCompatibleTextRenderingDefault( _
   ByVal defaultValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim defaultValue As Boolean

Application.SetCompatibleTextRenderingDefault(defaultValue)
C#
public static void SetCompatibleTextRenderingDefault(
   bool defaultValue
)
Managed Extensions for C++
public: static void SetCompatibleTextRenderingDefault(
   bool defaultValue
)
C++/CLI
public:
static void SetCompatibleTextRenderingDefault(
   bool defaultValue
)

Parameters

defaultValue

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Application Class
Application Members


SetThreadBookmark Method

[image]
Gizmox.WebGUI.Common
SetThreadBookmark Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Application Class : SetThreadBookmark Method

Overload List

Overload | Description
SetThreadBookmark(Object) |
SetThreadBookmark(Object,String) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Application Class
Application Members


SetThreadBookmark(Object) Method

[image]
Gizmox.WebGUI.Common
SetThreadBookmark(Object) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Application Class > SetThreadBookmark Method : SetThreadBookmark(Object) Method

objData

Syntax

Visual Basic (Declaration)
Public Overloads Shared Sub SetThreadBookmark( _
   ByVal objData As Object _
)
Visual Basic (Usage) Copy Code
Dim objData As Object

Application.SetThreadBookmark(objData)
C#
public static void SetThreadBookmark(
   object objData
)
Managed Extensions for C++
public: static void SetThreadBookmark(
   Object* objData
)
C++/CLI
public:
static void SetThreadBookmark(
   Object^ objData
)

Parameters

objData

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Application Class
Application Members
Overload List


SetThreadBookmark(Object,String) Method

[image]
Gizmox.WebGUI.Common
SetThreadBookmark(Object,String) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Application Class > SetThreadBookmark Method : SetThreadBookmark(Object,String) Method

objData
strBookmarkTitle

Syntax

Visual Basic (Declaration)
Public Overloads Shared Sub SetThreadBookmark( _
   ByVal objData As Object, _
   ByVal strBookmarkTitle As String _
)
Visual Basic (Usage) Copy Code
Dim objData As Object
Dim strBookmarkTitle As String

Application.SetThreadBookmark(objData, strBookmarkTitle)
C#
public static void SetThreadBookmark(
   object objData,
   string strBookmarkTitle
)
Managed Extensions for C++
public: static void SetThreadBookmark(
   Object* objData,
   string* strBookmarkTitle
)
C++/CLI
public:
static void SetThreadBookmark(
   Object^ objData,
   String^ strBookmarkTitle
)

Parameters

objData
strBookmarkTitle

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Application Class
Application Members
Overload List


SetUnhandledExceptionMode Method

[image]
Gizmox.WebGUI.Common
SetUnhandledExceptionMode Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Application Class : SetUnhandledExceptionMode Method

Overload List

Overload | Description
SetUnhandledExceptionMode(UnhandledExceptionMode) |
SetUnhandledExceptionMode(UnhandledExceptionMode,Boolean) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Application Class
Application Members


SetUnhandledExceptionMode(UnhandledExceptionMode) Method

[image]
Gizmox.WebGUI.Common
SetUnhandledExceptionMode(UnhandledExceptionMode) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Application Class > SetUnhandledExceptionMode Method : SetUnhandledExceptionMode(UnhandledExceptionMode) Method

mode

Syntax

Visual Basic (Declaration)
Public Overloads Shared Sub SetUnhandledExceptionMode( _
   ByVal mode As UnhandledExceptionMode _
)
Visual Basic (Usage) Copy Code
Dim mode As UnhandledExceptionMode

Application.SetUnhandledExceptionMode(mode)
C#
public static void SetUnhandledExceptionMode(
   UnhandledExceptionMode mode
)
Managed Extensions for C++
public: static void SetUnhandledExceptionMode(
   UnhandledExceptionMode mode
)
C++/CLI
public:
static void SetUnhandledExceptionMode(
   UnhandledExceptionMode mode
)

Parameters

mode

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Application Class
Application Members
Overload List


SetUnhandledExceptionMode(UnhandledExceptionMode,Boolean) Method

[image]
Gizmox.WebGUI.Common
SetUnhandledExceptionMode(UnhandledExceptionMode,Boolean) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Application Class > SetUnhandledExceptionMode Method : SetUnhandledExceptionMode(UnhandledExceptionMode,Boolean) Method

mode
threadScope

Syntax

Visual Basic (Declaration)
Public Overloads Shared Sub SetUnhandledExceptionMode( _
   ByVal mode As UnhandledExceptionMode, _
   ByVal threadScope As Boolean _
)
Visual Basic (Usage) Copy Code
Dim mode As UnhandledExceptionMode
Dim threadScope As Boolean

Application.SetUnhandledExceptionMode(mode, threadScope)
C#
public static void SetUnhandledExceptionMode(
   UnhandledExceptionMode mode,
   bool threadScope
)
Managed Extensions for C++
public: static void SetUnhandledExceptionMode(
   UnhandledExceptionMode mode,
   bool threadScope
)
C++/CLI
public:
static void SetUnhandledExceptionMode(
   UnhandledExceptionMode mode,
   bool threadScope
)

Parameters

mode
threadScope

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Application Class
Application Members
Overload List


UnregisterMessageLoop Method

[image]
Gizmox.WebGUI.Common
UnregisterMessageLoop Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Application Class : UnregisterMessageLoop Method

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<SecurityPermissionAttribute(Assertion=False,
   UnmanagedCode=True,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=False,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Unrestricted=False)>
Public Shared Sub UnregisterMessageLoop()
Visual Basic (Usage) Copy Code
Application.UnregisterMessageLoop()
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public static void UnregisterMessageLoop()
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public: static void UnregisterMessageLoop();
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SecurityPermissionAttribute(Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Unrestricted=false)]
public:
static void UnregisterMessageLoop();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Application Class
Application Members


Application Class Properties

[image]
Gizmox.WebGUI.Common
Application Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : Application Class

For a list of all members of this type, see Application members.

Public Properties

 | Name | Description
static (Shared in Visual Basic) | AllowQuit |
static (Shared in Visual Basic) | CompanyName |
static (Shared in Visual Basic) | CurrentCulture |
static (Shared in Visual Basic) | ExecutablePath |
static (Shared in Visual Basic) | LocalUserAppDataPath |
static (Shared in Visual Basic) | MessageLoop |
static (Shared in Visual Basic) | OpenForms |
static (Shared in Visual Basic) | ProductName |
static (Shared in Visual Basic) | ProductVersion |
Top

See Also

Reference

Application Class
Gizmox.WebGUI.Forms Namespace


AllowQuit Property

[image]
Gizmox.WebGUI.Common
AllowQuit Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Application Class : AllowQuit Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property AllowQuit As Boolean
Visual Basic (Usage) Copy Code
Dim value As Boolean

value = Application.AllowQuit
C#
public static bool AllowQuit {get;}
Managed Extensions for C++
public: __property static bool get_AllowQuit();
C++/CLI
public:
static property bool AllowQuit {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Application Class
Application Members


CompanyName Property

[image]
Gizmox.WebGUI.Common
CompanyName Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Application Class : CompanyName Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property CompanyName As String
Visual Basic (Usage) Copy Code
Dim value As String

value = Application.CompanyName
C#
public static string CompanyName {get;}
Managed Extensions for C++
public: __property static string* get_CompanyName();
C++/CLI
public:
static property String^ CompanyName {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Application Class
Application Members


CurrentCulture Property

[image]
Gizmox.WebGUI.Common
CurrentCulture Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Application Class : CurrentCulture Property

Syntax

Visual Basic (Declaration)
Public Shared Property CurrentCulture As CultureInfo
Visual Basic (Usage) Copy Code
Dim value As CultureInfo

Application.CurrentCulture = value

value = Application.CurrentCulture
C#
public static CultureInfo CurrentCulture {get; set;}
Managed Extensions for C++
public: __property static CultureInfo* get_CurrentCulture();
public: __property static void set_CurrentCulture(
   CultureInfo* value
);
C++/CLI
public:
static property CultureInfo^ CurrentCulture {
   CultureInfo^ get();
   void set (CultureInfo^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Application Class
Application Members


ExecutablePath Property

[image]
Gizmox.WebGUI.Common
ExecutablePath Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Application Class : ExecutablePath Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property ExecutablePath As String
Visual Basic (Usage) Copy Code
Dim value As String

value = Application.ExecutablePath
C#
public static string ExecutablePath {get;}
Managed Extensions for C++
public: __property static string* get_ExecutablePath();
C++/CLI
public:
static property String^ ExecutablePath {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Application Class
Application Members


LocalUserAppDataPath Property

[image]
Gizmox.WebGUI.Common
LocalUserAppDataPath Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Application Class : LocalUserAppDataPath Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property LocalUserAppDataPath As String
Visual Basic (Usage) Copy Code
Dim value As String

value = Application.LocalUserAppDataPath
C#
public static string LocalUserAppDataPath {get;}
Managed Extensions for C++
public: __property static string* get_LocalUserAppDataPath();
C++/CLI
public:
static property String^ LocalUserAppDataPath {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Application Class
Application Members


MessageLoop Property

[image]
Gizmox.WebGUI.Common
MessageLoop Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Application Class : MessageLoop Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property MessageLoop As Boolean
Visual Basic (Usage) Copy Code
Dim value As Boolean

value = Application.MessageLoop
C#
public static bool MessageLoop {get;}
Managed Extensions for C++
public: __property static bool get_MessageLoop();
C++/CLI
public:
static property bool MessageLoop {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Application Class
Application Members


OpenForms Property

[image]
Gizmox.WebGUI.Common
OpenForms Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Application Class : OpenForms Property

Syntax

Visual Basic (Declaration)
<UIPermissionAttribute(False)>
Public Shared ReadOnly Property OpenForms As FormCollection
Visual Basic (Usage) Copy Code
Dim value As FormCollection

value = Application.OpenForms
C#
[UIPermissionAttribute(false)]
public static FormCollection OpenForms {get;}
Managed Extensions for C++
[UIPermissionAttribute(false)]
public: __property static FormCollection* get_OpenForms();
C++/CLI
[UIPermissionAttribute(false)]
public:
static property FormCollection^ OpenForms {
   FormCollection^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Application Class
Application Members


ProductName Property

[image]
Gizmox.WebGUI.Common
ProductName Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Application Class : ProductName Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property ProductName As String
Visual Basic (Usage) Copy Code
Dim value As String

value = Application.ProductName
C#
public static string ProductName {get;}
Managed Extensions for C++
public: __property static string* get_ProductName();
C++/CLI
public:
static property String^ ProductName {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Application Class
Application Members


ProductVersion Property

[image]
Gizmox.WebGUI.Common
ProductVersion Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Application Class : ProductVersion Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property ProductVersion As String
Visual Basic (Usage) Copy Code
Dim value As String

value = Application.ProductVersion
C#
public static string ProductVersion {get;}
Managed Extensions for C++
public: __property static string* get_ProductVersion();
C++/CLI
public:
static property String^ ProductVersion {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Application Class
Application Members


Application Class Events

[image]
Gizmox.WebGUI.Common
Application Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : Application Class

For a list of all members of this type, see Application members.

Public Events

 | Name | Description
Public Event | ApplicationExit |
Public Event | EnterThreadModal |
Public Event | Idle |
Public Event | LeaveThreadModal |
Public Event | ThreadBookmarkNavigate |
Public Event | ThreadException |
Public Event | ThreadExit |
Public Event | ThreadMessage |
Public Event | ThreadRefresh |
Public Event | ThreadSuspend |
Public Event | ThreadTick |
Top

See Also

Reference

Application Class
Gizmox.WebGUI.Forms Namespace


ApplicationExit Event

[image]
Gizmox.WebGUI.Common
ApplicationExit Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Application Class : ApplicationExit Event

Syntax

Visual Basic (Declaration)
Public Event ApplicationExit() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As Application
Dim handler As EventHandler

AddHandler instance.ApplicationExit, handler
C#
public event EventHandler ApplicationExit()
Managed Extensions for C++
public: __event EventHandler* ApplicationExit
C++/CLI
public:
event EventHandler^ ApplicationExit

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Application Class
Application Members


EnterThreadModal Event

[image]
Gizmox.WebGUI.Common
EnterThreadModal Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Application Class : EnterThreadModal Event

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Event EnterThreadModal() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As Application
Dim handler As EventHandler

AddHandler instance.EnterThreadModal, handler
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public event EventHandler EnterThreadModal()
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: __event EventHandler* EnterThreadModal
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
event EventHandler^ EnterThreadModal

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Application Class
Application Members


Idle Event

[image]
Gizmox.WebGUI.Common
Idle Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Application Class : Idle Event

Syntax

Visual Basic (Declaration)
Public Event Idle() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As Application
Dim handler As EventHandler

AddHandler instance.Idle, handler
C#
public event EventHandler Idle()
Managed Extensions for C++
public: __event EventHandler* Idle
C++/CLI
public:
event EventHandler^ Idle

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Application Class
Application Members


LeaveThreadModal Event

[image]
Gizmox.WebGUI.Common
LeaveThreadModal Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Application Class : LeaveThreadModal Event

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Event LeaveThreadModal() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As Application
Dim handler As EventHandler

AddHandler instance.LeaveThreadModal, handler
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public event EventHandler LeaveThreadModal()
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: __event EventHandler* LeaveThreadModal
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
event EventHandler^ LeaveThreadModal

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Application Class
Application Members


ThreadBookmarkNavigate Event

[image]
Gizmox.WebGUI.Common
ThreadBookmarkNavigate Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Application Class : ThreadBookmarkNavigate Event

Syntax

Visual Basic (Declaration)
Public Event ThreadBookmarkNavigate() As ThreadBookmarkEventHandler
Visual Basic (Usage) Copy Code
Dim instance As Application
Dim handler As ThreadBookmarkEventHandler

AddHandler instance.ThreadBookmarkNavigate, handler
C#
public event ThreadBookmarkEventHandler ThreadBookmarkNavigate()
Managed Extensions for C++
public: __event ThreadBookmarkEventHandler* ThreadBookmarkNavigate
C++/CLI
public:
event ThreadBookmarkEventHandler^ ThreadBookmarkNavigate

Event Data

The event handler receives an argument of type ThreadBookmarkEventArgs containing data related to this event. The following ThreadBookmarkEventArgs properties provide information specific to this event.

Property | Description
Data |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Application Class
Application Members


ThreadException Event

[image]
Gizmox.WebGUI.Common
ThreadException Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Application Class : ThreadException Event

Syntax

Visual Basic (Declaration)
Public Event ThreadException() As ThreadExceptionEventHandler
Visual Basic (Usage) Copy Code
Dim instance As Application
Dim handler As ThreadExceptionEventHandler

AddHandler instance.ThreadException, handler
C#
public event ThreadExceptionEventHandler ThreadException()
Managed Extensions for C++
public: __event ThreadExceptionEventHandler* ThreadException
C++/CLI
public:
event ThreadExceptionEventHandler^ ThreadException

Event Data

The event handler receives an argument of type ThreadExceptionEventArgs containing data related to this event. The following ThreadExceptionEventArgs properties provide information specific to this event.

Property | Description
Exception |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Application Class
Application Members


ThreadExit Event

[image]
Gizmox.WebGUI.Common
ThreadExit Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Application Class : ThreadExit Event

Syntax

Visual Basic (Declaration)
Public Event ThreadExit() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As Application
Dim handler As EventHandler

AddHandler instance.ThreadExit, handler
C#
public event EventHandler ThreadExit()
Managed Extensions for C++
public: __event EventHandler* ThreadExit
C++/CLI
public:
event EventHandler^ ThreadExit

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Application Class
Application Members


ThreadMessage Event

[image]
Gizmox.WebGUI.Common
ThreadMessage Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Application Class : ThreadMessage Event

Syntax

Visual Basic (Declaration)
Public Event ThreadMessage() As ThreadMessageEventHandler
Visual Basic (Usage) Copy Code
Dim instance As Application
Dim handler As ThreadMessageEventHandler

AddHandler instance.ThreadMessage, handler
C#
public event ThreadMessageEventHandler ThreadMessage()
Managed Extensions for C++
public: __event ThreadMessageEventHandler* ThreadMessage
C++/CLI
public:
event ThreadMessageEventHandler^ ThreadMessage

Event Data

The event handler receives an argument of type ThreadMessageEventArgs containing data related to this event. The following ThreadMessageEventArgs properties provide information specific to this event.

Property | Description
Message |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Application Class
Application Members


ThreadRefresh Event

[image]
Gizmox.WebGUI.Common
ThreadRefresh Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Application Class : ThreadRefresh Event

Syntax

Visual Basic (Declaration)
Public Event ThreadRefresh() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As Application
Dim handler As EventHandler

AddHandler instance.ThreadRefresh, handler
C#
public event EventHandler ThreadRefresh()
Managed Extensions for C++
public: __event EventHandler* ThreadRefresh
C++/CLI
public:
event EventHandler^ ThreadRefresh

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Application Class
Application Members


ThreadSuspend Event

[image]
Gizmox.WebGUI.Common
ThreadSuspend Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Application Class : ThreadSuspend Event

Syntax

Visual Basic (Declaration)
Public Event ThreadSuspend() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As Application
Dim handler As EventHandler

AddHandler instance.ThreadSuspend, handler
C#
public event EventHandler ThreadSuspend()
Managed Extensions for C++
public: __event EventHandler* ThreadSuspend
C++/CLI
public:
event EventHandler^ ThreadSuspend

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Application Class
Application Members


ThreadTick Event

[image]
Gizmox.WebGUI.Common
ThreadTick Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Application Class : ThreadTick Event

Syntax

Visual Basic (Declaration)
Public Event ThreadTick() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As Application
Dim handler As EventHandler

AddHandler instance.ThreadTick, handler
C#
public event EventHandler ThreadTick()
Managed Extensions for C++
public: __event EventHandler* ThreadTick
C++/CLI
public:
event EventHandler^ ThreadTick

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Application Class
Application Members


ComponentBase Class

[image]
Gizmox.WebGUI.Common
ComponentBase Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ComponentBase Class

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Class ComponentBase
Visual Basic (Usage) Copy Code
Dim instance As ComponentBase
C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public class ComponentBase
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public __gc class ComponentBase
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public ref class ComponentBase

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.BindingSource
Gizmox.WebGUI.Forms.CommonDialog
Gizmox.WebGUI.Forms.ErrorProvider
Gizmox.WebGUI.Forms.Extenders.SilverlightExtender
Gizmox.WebGUI.Forms.Extenders.UniqueIdExtender
Gizmox.WebGUI.Forms.HelpProvider
Gizmox.WebGUI.Forms.ImageList
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.RibbonBarItem
Gizmox.WebGUI.Forms.RibbonBarPage
Gizmox.WebGUI.Forms.Timer
Gizmox.WebGUI.Forms.ToolTip

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

ComponentBase Members
Gizmox.WebGUI.Forms Namespace


ComponentBase Class Members

[image]
Gizmox.WebGUI.Common
ComponentBase Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : ComponentBase Class

The following tables list the members exposed by ComponentBase.

Public Constructors

 | Name | Description
Public Constructor | ComponentBase Constructor |
Top

Public Properties

 | Name | Description
Public Property | Container |
Public Property | Site |
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents |
Protected Property | DesignMode |
Protected Property | Events |
Top

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded.
Public Method | ToString | Overridden.
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | Overridden.
Protected Method | GetService |
Top

Public Events

 | Name | Description
Public Event | Disposed |
Top

See Also

Reference

ComponentBase Class
Gizmox.WebGUI.Forms Namespace


ComponentBase Constructor

[image]
Gizmox.WebGUI.Common
ComponentBase Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ComponentBase Class : ComponentBase Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ComponentBase()
C#
public ComponentBase()
Managed Extensions for C++
public: ComponentBase();
C++/CLI
public:
ComponentBase();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ComponentBase Class
ComponentBase Members


ComponentBase Class Methods

[image]
Gizmox.WebGUI.Common
ComponentBase Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ComponentBase Class

For a list of all members of this type, see ComponentBase members.

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded.
Public Method | ToString | Overridden.
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | Overridden.
Protected Method | GetService |
Top

See Also

Reference

ComponentBase Class
Gizmox.WebGUI.Forms Namespace


Dispose Method

[image]
Gizmox.WebGUI.Common
Dispose Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ComponentBase Class : Dispose Method

Overload List

Overload | Description
Dispose() |
Dispose(Boolean) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ComponentBase Class
ComponentBase Members


Dispose() Method

[image]
Gizmox.WebGUI.Common
Dispose() Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ComponentBase Class > Dispose Method : Dispose() Method

Syntax

Visual Basic (Declaration)
Public Overloads Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As ComponentBase

instance.Dispose()
C#
public void Dispose()
Managed Extensions for C++
public: void Dispose();
C++/CLI
public:
void Dispose();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ComponentBase Class
ComponentBase Members
Overload List


Dispose(Boolean) Method

[image]
Gizmox.WebGUI.Common
Dispose(Boolean) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ComponentBase Class > Dispose Method : Dispose(Boolean) Method

disposing

Syntax

Visual Basic (Declaration)
Protected Overloads Overridable Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ComponentBase
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected virtual void Dispose(
   bool disposing
)
Managed Extensions for C++
protected: virtual void Dispose(
   bool disposing
)
C++/CLI
protected:
virtual void Dispose(
   bool disposing
)

Parameters

disposing

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ComponentBase Class
ComponentBase Members
Overload List


Finalize Method

[image]
Gizmox.WebGUI.Common
Finalize Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ComponentBase Class : Finalize Method

Syntax

Visual Basic (Declaration)
Protected Overrides Sub Finalize()
Visual Basic (Usage) Copy Code
Dim instance As ComponentBase

instance.Finalize()
C#
protected override void Finalize()
Managed Extensions for C++
protected: void Finalize(); override
C++/CLI
protected:
void Finalize(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ComponentBase Class
ComponentBase Members


GetService Method

[image]
Gizmox.WebGUI.Common
GetService Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ComponentBase Class : GetService Method

service

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetService( _
   ByVal service As Type _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As ComponentBase
Dim service As Type
Dim value As Object

value = instance.GetService(service)
C#
protected virtual object GetService(
   Type service
)
Managed Extensions for C++
protected: virtual Object* GetService(
   Type* service
)
C++/CLI
protected:
virtual Object^ GetService(
   Type^ service
)

Parameters

service

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ComponentBase Class
ComponentBase Members


ToString Method

[image]
Gizmox.WebGUI.Common
ToString Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ComponentBase Class : ToString Method

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As ComponentBase
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ComponentBase Class
ComponentBase Members


ComponentBase Class Properties

[image]
Gizmox.WebGUI.Common
ComponentBase Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ComponentBase Class

For a list of all members of this type, see ComponentBase members.

Public Properties

 | Name | Description
Public Property | Container |
Public Property | Site |
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents |
Protected Property | DesignMode |
Protected Property | Events |
Top

See Also

Reference

ComponentBase Class
Gizmox.WebGUI.Forms Namespace


CanRaiseEvents Property

[image]
Gizmox.WebGUI.Common
CanRaiseEvents Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ComponentBase Class : CanRaiseEvents Property

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property CanRaiseEvents As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ComponentBase
Dim value As Boolean

value = instance.CanRaiseEvents
C#
protected virtual bool CanRaiseEvents {get;}
Managed Extensions for C++
protected: __property virtual bool get_CanRaiseEvents();
C++/CLI
protected:
virtual property bool CanRaiseEvents {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ComponentBase Class
ComponentBase Members


Container Property

[image]
Gizmox.WebGUI.Common
Container Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ComponentBase Class : Container Property

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
Public ReadOnly Property Container As IContainer
Visual Basic (Usage) Copy Code
Dim instance As ComponentBase
Dim value As IContainer

value = instance.Container
C#
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public IContainer Container {get;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public: __property IContainer* get_Container();
C++/CLI
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public:
property IContainer^ Container {
   IContainer^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ComponentBase Class
ComponentBase Members


DesignMode Property

[image]
Gizmox.WebGUI.Common
DesignMode Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ComponentBase Class : DesignMode Property

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
Protected ReadOnly Property DesignMode As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ComponentBase
Dim value As Boolean

value = instance.DesignMode
C#
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
protected bool DesignMode {get;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
protected: __property bool get_DesignMode();
C++/CLI
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
protected:
property bool DesignMode {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ComponentBase Class
ComponentBase Members


Events Property

[image]
Gizmox.WebGUI.Common
Events Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ComponentBase Class : Events Property

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property Events As EventHandlerList
Visual Basic (Usage) Copy Code
Dim instance As ComponentBase
Dim value As EventHandlerList

value = instance.Events
C#
protected EventHandlerList Events {get;}
Managed Extensions for C++
protected: __property EventHandlerList* get_Events();
C++/CLI
protected:
property EventHandlerList^ Events {
   EventHandlerList^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ComponentBase Class
ComponentBase Members


Site Property

[image]
Gizmox.WebGUI.Common
Site Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ComponentBase Class : Site Property

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public Overridable Property Site As ISite
Visual Basic (Usage) Copy Code
Dim instance As ComponentBase
Dim value As ISite

instance.Site = value

value = instance.Site
C#
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public virtual ISite Site {get; set;}
Managed Extensions for C++
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property virtual ISite* get_Site();
public: __property virtual void set_Site(
   ISite* value
);
C++/CLI
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
virtual property ISite^ Site {
   ISite^ get();
   void set (ISite^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ComponentBase Class
ComponentBase Members


ComponentBase Class Events

[image]
Gizmox.WebGUI.Common
ComponentBase Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ComponentBase Class

For a list of all members of this type, see ComponentBase members.

Public Events

 | Name | Description
Public Event | Disposed |
Top

See Also

Reference

ComponentBase Class
Gizmox.WebGUI.Forms Namespace


Disposed Event

[image]
Gizmox.WebGUI.Common
Disposed Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ComponentBase Class : Disposed Event

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Event Disposed() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As ComponentBase
Dim handler As EventHandler

AddHandler instance.Disposed, handler
C#
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public event EventHandler Disposed()
Managed Extensions for C++
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: __event EventHandler* Disposed
C++/CLI
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
event EventHandler^ Disposed

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ComponentBase Class
ComponentBase Members


FormCollection Class

[image]
Gizmox.WebGUI.Common
FormCollection Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : FormCollection Class

Object Model

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class FormCollection
   Inherits ReadOnlyCollectionBase
Visual Basic (Usage) Copy Code
Dim instance As FormCollection
C#
[DefaultMemberAttribute("Item")]
public class FormCollection : ReadOnlyCollectionBase
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
public __gc class FormCollection : public ReadOnlyCollectionBase
C++/CLI
[DefaultMemberAttribute("Item")]
public ref class FormCollection : public ReadOnlyCollectionBase

Inheritance Hierarchy

System.Object
System.Collections.ReadOnlyCollectionBase
Gizmox.WebGUI.Forms.FormCollection

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

FormCollection Members
Gizmox.WebGUI.Forms Namespace


FormCollection Class Members

[image]
Gizmox.WebGUI.Common
FormCollection Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : FormCollection Class

The following tables list the members exposed by FormCollection.

Public Constructors

 | Name | Description
Public Constructor | FormCollection Constructor |
Top

Public Properties

 | Name | Description
Public Property | Count | Gets the number of elements contained in the ReadOnlyCollectionBase instance. (Inherited from System.Collections.ReadOnlyCollectionBase)
Public Property | Item | Overloaded.
Top

Protected Properties

 | Name | Description
Protected Property | InnerList | Gets the list of elements contained in the ReadOnlyCollectionBase instance. (Inherited from System.Collections.ReadOnlyCollectionBase)
Top

Public Methods

 | Name | Description
Public Method | GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollectionBase instance. (Inherited from System.Collections.ReadOnlyCollectionBase)
Top

See Also

Reference

FormCollection Class
Gizmox.WebGUI.Forms Namespace


FormCollection Constructor

[image]
Gizmox.WebGUI.Common
FormCollection Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > FormCollection Class : FormCollection Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As FormCollection()
C#
public FormCollection()
Managed Extensions for C++
public: FormCollection();
C++/CLI
public:
FormCollection();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FormCollection Class
FormCollection Members


FormCollection Class Properties

[image]
Gizmox.WebGUI.Common
FormCollection Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : FormCollection Class

For a list of all members of this type, see FormCollection members.

Public Properties

 | Name | Description
Public Property | Count | Gets the number of elements contained in the ReadOnlyCollectionBase instance. (Inherited from System.Collections.ReadOnlyCollectionBase)
Public Property | Item | Overloaded.
Top

Protected Properties

 | Name | Description
Protected Property | InnerList | Gets the list of elements contained in the ReadOnlyCollectionBase instance. (Inherited from System.Collections.ReadOnlyCollectionBase)
Top

See Also

Reference

FormCollection Class
Gizmox.WebGUI.Forms Namespace


Item Property

[image]
Gizmox.WebGUI.Common
Item Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > FormCollection Class : Item Property

Overload List

Overload | Description
Item(Int32) |
Item(String) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FormCollection Class
FormCollection Members


Item(Int32) Property

[image]
Gizmox.WebGUI.Common
Item(Int32) Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > FormCollection Class > Item Property : Item(Int32) Property

index

Syntax

Visual Basic (Declaration)
Public Overloads Overridable ReadOnly Property Item( _
   ByVal index As Integer _
) As IForm
Visual Basic (Usage) Copy Code
Dim instance As FormCollection
Dim index As Integer
Dim value As IForm

value = instance.Item(index)
C#
public virtual IForm Item(
   int index
) {get;}
Managed Extensions for C++
public: __property virtual IForm* get_Item(
   int index
);
C++/CLI
public:
virtual property IForm^ Item {
   IForm^ get(intindex);
}

Parameters

index

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FormCollection Class
FormCollection Members
Overload List


Item(String) Property

[image]
Gizmox.WebGUI.Common
Item(String) Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > FormCollection Class > Item Property : Item(String) Property

name

Syntax

Visual Basic (Declaration)
Public Overloads Overridable ReadOnly Property Item( _
   ByVal name As String _
) As IForm
Visual Basic (Usage) Copy Code
Dim instance As FormCollection
Dim name As String
Dim value As IForm

value = instance.Item(name)
C#
public virtual IForm Item(
   string name
) {get;}
Managed Extensions for C++
public: __property virtual IForm* get_Item(
   string* name
);
C++/CLI
public:
virtual property IForm^ Item {
   IForm^ get(String^name);
}

Parameters

name

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FormCollection Class
FormCollection Members
Overload List


Metadata Class

[image]
Gizmox.WebGUI.Common
Metadata Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : Metadata Class

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Class Metadata
Visual Basic (Usage) Copy Code
Dim instance As Metadata
C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public class Metadata
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public __gc class Metadata
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public ref class Metadata

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.Metadata

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

Metadata Members
Gizmox.WebGUI.Forms Namespace


Metadata Class Members

[image]
Gizmox.WebGUI.Common
Metadata Class Members
See Also Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : Metadata Class

The following tables list the members exposed by Metadata.

Public Constructors

 | Name | Description
Public Constructor | Metadata Constructor |
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetSilverlightControl |
static (Shared in Visual Basic) | GetSilverlightControls | Overloaded.
static (Shared in Visual Basic) | GetTag | Overloaded.
Top

See Also

Reference

Metadata Class
Gizmox.WebGUI.Forms Namespace


Metadata Constructor

[image]
Gizmox.WebGUI.Common
Metadata Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Metadata Class : Metadata Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Metadata()
C#
public Metadata()
Managed Extensions for C++
public: Metadata();
C++/CLI
public:
Metadata();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Metadata Class
Metadata Members


Metadata Class Methods

[image]
Gizmox.WebGUI.Common
Metadata Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : Metadata Class

For a list of all members of this type, see Metadata members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetSilverlightControl |
static (Shared in Visual Basic) | GetSilverlightControls | Overloaded.
static (Shared in Visual Basic) | GetTag | Overloaded.
Top

See Also

Reference

Metadata Class
Gizmox.WebGUI.Forms Namespace


GetSilverlightControl Method

[image]
Gizmox.WebGUI.Common
GetSilverlightControl Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Metadata Class : GetSilverlightControl Method

objInstace

Syntax

Visual Basic (Declaration)
Public Shared Function GetSilverlightControl( _
   ByVal objInstace As Object _
) As MetadataControl()
Visual Basic (Usage) Copy Code
Dim objInstace As Object
Dim value() As MetadataControl

value = Metadata.GetSilverlightControl(objInstace)
C#
public static MetadataControl[] GetSilverlightControl(
   object objInstace
)
Managed Extensions for C++
public: static MetadataControl*[]* GetSilverlightControl(
   Object* objInstace
)
C++/CLI
public:
static array<MetadataControl^>^ GetSilverlightControl(
   Object^ objInstace
)

Parameters

objInstace

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Metadata Class
Metadata Members


GetSilverlightControls Method

[image]
Gizmox.WebGUI.Common
GetSilverlightControls Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Metadata Class : GetSilverlightControls Method

Overload List

Overload | Description
GetSilverlightControls(Type) |
GetSilverlightControls(Type,Boolean) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Metadata Class
Metadata Members


GetSilverlightControls(Type) Method

[image]
Gizmox.WebGUI.Common
GetSilverlightControls(Type) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Metadata Class > GetSilverlightControls Method : GetSilverlightControls(Type) Method

objInstanceType

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function GetSilverlightControls( _
   ByVal objInstanceType As Type _
) As MetadataControl()
Visual Basic (Usage) Copy Code
Dim objInstanceType As Type
Dim value() As MetadataControl

value = Metadata.GetSilverlightControls(objInstanceType)
C#
public static MetadataControl[] GetSilverlightControls(
   Type objInstanceType
)
Managed Extensions for C++
public: static MetadataControl*[]* GetSilverlightControls(
   Type* objInstanceType
)
C++/CLI
public:
static array<MetadataControl^>^ GetSilverlightControls(
   Type^ objInstanceType
)

Parameters

objInstanceType

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Metadata Class
Metadata Members
Overload List


GetSilverlightControls(Type,Boolean) Method

[image]
Gizmox.WebGUI.Common
GetSilverlightControls(Type,Boolean) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Metadata Class > GetSilverlightControls Method : GetSilverlightControls(Type,Boolean) Method

objInstanceType
blnThrowError

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function GetSilverlightControls( _
   ByVal objInstanceType As Type, _
   ByVal blnThrowError As Boolean _
) As MetadataControl()
Visual Basic (Usage) Copy Code
Dim objInstanceType As Type
Dim blnThrowError As Boolean
Dim value() As MetadataControl

value = Metadata.GetSilverlightControls(objInstanceType, blnThrowError)
C#
public static MetadataControl[] GetSilverlightControls(
   Type objInstanceType,
   bool blnThrowError
)
Managed Extensions for C++
public: static MetadataControl*[]* GetSilverlightControls(
   Type* objInstanceType,
   bool blnThrowError
)
C++/CLI
public:
static array<MetadataControl^>^ GetSilverlightControls(
   Type^ objInstanceType,
   bool blnThrowError
)

Parameters

objInstanceType
blnThrowError

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Metadata Class
Metadata Members
Overload List


GetTag Method

[image]
Gizmox.WebGUI.Common
GetTag Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Metadata Class : GetTag Method

Overload List

Overload | Description
GetTag(Object) |
GetTag(Type) |
GetTag(Type,Boolean) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Metadata Class
Metadata Members


GetTag(Object) Method

[image]
Gizmox.WebGUI.Common
GetTag(Object) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Metadata Class > GetTag Method : GetTag(Object) Method

objInstace

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function GetTag( _
   ByVal objInstace As Object _
) As String
Visual Basic (Usage) Copy Code
Dim objInstace As Object
Dim value As String

value = Metadata.GetTag(objInstace)
C#
public static string GetTag(
   object objInstace
)
Managed Extensions for C++
public: static string* GetTag(
   Object* objInstace
)
C++/CLI
public:
static String^ GetTag(
   Object^ objInstace
)

Parameters

objInstace

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Metadata Class
Metadata Members
Overload List


GetTag(Type) Method

[image]
Gizmox.WebGUI.Common
GetTag(Type) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Metadata Class > GetTag Method : GetTag(Type) Method

objInstanceType

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function GetTag( _
   ByVal objInstanceType As Type _
) As String
Visual Basic (Usage) Copy Code
Dim objInstanceType As Type
Dim value As String

value = Metadata.GetTag(objInstanceType)
C#
public static string GetTag(
   Type objInstanceType
)
Managed Extensions for C++
public: static string* GetTag(
   Type* objInstanceType
)
C++/CLI
public:
static String^ GetTag(
   Type^ objInstanceType
)

Parameters

objInstanceType

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Metadata Class
Metadata Members
Overload List


GetTag(Type,Boolean) Method

[image]
Gizmox.WebGUI.Common
GetTag(Type,Boolean) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Metadata Class > GetTag Method : GetTag(Type,Boolean) Method

objInstanceType
blnThrowError

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function GetTag( _
   ByVal objInstanceType As Type, _
   ByVal blnThrowError As Boolean _
) As String
Visual Basic (Usage) Copy Code
Dim objInstanceType As Type
Dim blnThrowError As Boolean
Dim value As String

value = Metadata.GetTag(objInstanceType, blnThrowError)
C#
public static string GetTag(
   Type objInstanceType,
   bool blnThrowError
)
Managed Extensions for C++
public: static string* GetTag(
   Type* objInstanceType,
   bool blnThrowError
)
C++/CLI
public:
static String^ GetTag(
   Type^ objInstanceType,
   bool blnThrowError
)

Parameters

objInstanceType
blnThrowError

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Metadata Class
Metadata Members
Overload List


MetadataControl Class

[image]
Gizmox.WebGUI.Common
MetadataControl Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : MetadataControl Class

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Class MetadataControl
Visual Basic (Usage) Copy Code
Dim instance As MetadataControl
C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public class MetadataControl
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public __gc class MetadataControl
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public ref class MetadataControl

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.MetadataControl

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

MetadataControl Members
Gizmox.WebGUI.Forms Namespace


MetadataControl Class Members

[image]
Gizmox.WebGUI.Common
MetadataControl Class Members
See Also Properties Send Feedback
Gizmox.WebGUI.Forms Namespace : MetadataControl Class

The following tables list the members exposed by MetadataControl.

Public Constructors

 | Name | Description
Public Constructor | MetadataControl Constructor |
Top

Public Properties

 | Name | Description
Public Property | Style |
Public Property | Type |
Top

See Also

Reference

MetadataControl Class
Gizmox.WebGUI.Forms Namespace


MetadataControl Constructor

[image]
Gizmox.WebGUI.Common
MetadataControl Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > MetadataControl Class : MetadataControl Constructor

strType
strStyle

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal strType As String, _
   ByVal strStyle As String _
)
Visual Basic (Usage) Copy Code
Dim strType As String
Dim strStyle As String

Dim instance As MetadataControl(strType, strStyle)
C#
public MetadataControl(
   string strType,
   string strStyle
)
Managed Extensions for C++
public: MetadataControl(
   string* strType,
   string* strStyle
)
C++/CLI
public:
MetadataControl(
   String^ strType,
   String^ strStyle
)

Parameters

strType
strStyle

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MetadataControl Class
MetadataControl Members


MetadataControl Class Properties

[image]
Gizmox.WebGUI.Common
MetadataControl Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : MetadataControl Class

For a list of all members of this type, see MetadataControl members.

Public Properties

 | Name | Description
Public Property | Style |
Public Property | Type |
Top

See Also

Reference

MetadataControl Class
Gizmox.WebGUI.Forms Namespace


Style Property

[image]
Gizmox.WebGUI.Common
Style Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > MetadataControl Class : Style Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Style As String
Visual Basic (Usage) Copy Code
Dim instance As MetadataControl
Dim value As String

value = instance.Style
C#
public string Style {get;}
Managed Extensions for C++
public: __property string* get_Style();
C++/CLI
public:
property String^ Style {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MetadataControl Class
MetadataControl Members


Type Property

[image]
Gizmox.WebGUI.Common
Type Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > MetadataControl Class : Type Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Type As String
Visual Basic (Usage) Copy Code
Dim instance As MetadataControl
Dim value As String

value = instance.Type
C#
public string Type {get;}
Managed Extensions for C++
public: __property string* get_Type();
C++/CLI
public:
property String^ Type {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MetadataControl Class
MetadataControl Members


MetadataTagAttribute Class

[image]
Gizmox.WebGUI.Common
MetadataTagAttribute Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : MetadataTagAttribute Class

Syntax

Visual Basic (Declaration)
Public Class MetadataTagAttribute
   Inherits Attribute
Visual Basic (Usage) Copy Code
Dim instance As MetadataTagAttribute
C#
public class MetadataTagAttribute : Attribute
Managed Extensions for C++
public __gc class MetadataTagAttribute : public Attribute
C++/CLI
public ref class MetadataTagAttribute : public Attribute

Inheritance Hierarchy

System.Object
System.Attribute
Gizmox.WebGUI.Forms.MetadataTagAttribute

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

MetadataTagAttribute Members
Gizmox.WebGUI.Forms Namespace


MetadataTagAttribute Class Members

[image]
Gizmox.WebGUI.Common
MetadataTagAttribute Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : MetadataTagAttribute Class

The following tables list the members exposed by MetadataTagAttribute.

Public Constructors

 | Name | Description
Public Constructor | MetadataTagAttribute Constructor |
Top

Public Properties

 | Name | Description
Public Property | TagName |
Public Property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from System.Attribute)
Top

Public Methods

 | Name | Description
Public Method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from System.Attribute)
Public Method | GetHashCode | Returns the hash code for this instance. (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from System.Attribute)
Public Method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from System.Attribute)
Top

See Also

Reference

MetadataTagAttribute Class
Gizmox.WebGUI.Forms Namespace


MetadataTagAttribute Constructor

[image]
Gizmox.WebGUI.Common
MetadataTagAttribute Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > MetadataTagAttribute Class : MetadataTagAttribute Constructor

strTagName

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal strTagName As String _
)
Visual Basic (Usage) Copy Code
Dim strTagName As String

Dim instance As MetadataTagAttribute(strTagName)
C#
public MetadataTagAttribute(
   string strTagName
)
Managed Extensions for C++
public: MetadataTagAttribute(
   string* strTagName
)
C++/CLI
public:
MetadataTagAttribute(
   String^ strTagName
)

Parameters

strTagName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MetadataTagAttribute Class
MetadataTagAttribute Members


MetadataTagAttribute Class Properties

[image]
Gizmox.WebGUI.Common
MetadataTagAttribute Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : MetadataTagAttribute Class

For a list of all members of this type, see MetadataTagAttribute members.

Public Properties

 | Name | Description
Public Property | TagName |
Public Property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from System.Attribute)
Top

See Also

Reference

MetadataTagAttribute Class
Gizmox.WebGUI.Forms Namespace


TagName Property

[image]
Gizmox.WebGUI.Common
TagName Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > MetadataTagAttribute Class : TagName Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TagName As String
Visual Basic (Usage) Copy Code
Dim instance As MetadataTagAttribute
Dim value As String

value = instance.TagName
C#
public string TagName {get;}
Managed Extensions for C++
public: __property string* get_TagName();
C++/CLI
public:
property String^ TagName {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

MetadataTagAttribute Class
MetadataTagAttribute Members


RegisteredClientAction Class

[image]
Gizmox.WebGUI.Common
RegisteredClientAction Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RegisteredClientAction Class

Syntax

Visual Basic (Declaration)
Public Class RegisteredClientAction
Visual Basic (Usage) Copy Code
Dim instance As RegisteredClientAction
C#
public class RegisteredClientAction
Managed Extensions for C++
public __gc class RegisteredClientAction
C++/CLI
public ref class RegisteredClientAction

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.RegisteredClientAction

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

RegisteredClientAction Members
Gizmox.WebGUI.Forms Namespace


RegisteredClientAction Class Members

[image]
Gizmox.WebGUI.Common
RegisteredClientAction Class Members
See Also Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : RegisteredClientAction Class

The following tables list the members exposed by RegisteredClientAction.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Create | Overloaded.
static (Shared in Visual Basic) | CreateWithId |
Top

See Also

Reference

RegisteredClientAction Class
Gizmox.WebGUI.Forms Namespace


RegisteredClientAction Class Methods

[image]
Gizmox.WebGUI.Common
RegisteredClientAction Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RegisteredClientAction Class

For a list of all members of this type, see RegisteredClientAction members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Create | Overloaded.
static (Shared in Visual Basic) | CreateWithId |
Top

See Also

Reference

RegisteredClientAction Class
Gizmox.WebGUI.Forms Namespace


Create Method

[image]
Gizmox.WebGUI.Common
Create Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RegisteredClientAction Class : Create Method

Overload List

Overload | Description
Create(String,String[]) |
Create(IRegisteredComponent,String,String[]) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RegisteredClientAction Class
RegisteredClientAction Members


Create(String,String[]) Method

[image]
Gizmox.WebGUI.Common
Create(String,String[]) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RegisteredClientAction Class > Create Method : Create(String,String[]) Method

strMethod
strArgs

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Create( _
   ByVal strMethod As String, _
   ByVal ParamArray strArgs() As String _
) As RegisteredClientAction
Visual Basic (Usage) Copy Code
Dim strMethod As String
Dim strArgs() As String
Dim value As RegisteredClientAction

value = RegisteredClientAction.Create(strMethod, strArgs)
C#
public static RegisteredClientAction Create(
   string strMethod,
   params string[] strArgs
)
Managed Extensions for C++
public: static RegisteredClientAction* Create(
   string* strMethod,
   params string*[]* strArgs
)
C++/CLI
public:
static RegisteredClientAction^ Create(
   String^ strMethod,
   ... array<String^>^ strArgs
)

Parameters

strMethod
strArgs

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RegisteredClientAction Class
RegisteredClientAction Members
Overload List


Create(IRegisteredComponent,String,String[]) Method

[image]
Gizmox.WebGUI.Common
Create(IRegisteredComponent,String,String[]) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RegisteredClientAction Class > Create Method : Create(IRegisteredComponent,String,String[]) Method

objTarget
strMethod
strArgs

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Create( _
   ByVal objTarget As IRegisteredComponent, _
   ByVal strMethod As String, _
   ByVal ParamArray strArgs() As String _
) As RegisteredClientAction
Visual Basic (Usage) Copy Code
Dim objTarget As IRegisteredComponent
Dim strMethod As String
Dim strArgs() As String
Dim value As RegisteredClientAction

value = RegisteredClientAction.Create(objTarget, strMethod, strArgs)
C#
public static RegisteredClientAction Create(
   IRegisteredComponent objTarget,
   string strMethod,
   params string[] strArgs
)
Managed Extensions for C++
public: static RegisteredClientAction* Create(
   IRegisteredComponent* objTarget,
   string* strMethod,
   params string*[]* strArgs
)
C++/CLI
public:
static RegisteredClientAction^ Create(
   IRegisteredComponent^ objTarget,
   String^ strMethod,
   ... array<String^>^ strArgs
)

Parameters

objTarget
strMethod
strArgs

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RegisteredClientAction Class
RegisteredClientAction Members
Overload List


CreateWithId Method

[image]
Gizmox.WebGUI.Common
CreateWithId Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RegisteredClientAction Class : CreateWithId Method

objTarget
strMethod
strArgs

Syntax

Visual Basic (Declaration)
Public Shared Function CreateWithId( _
   ByVal objTarget As IRegisteredComponent, _
   ByVal strMethod As String, _
   ByVal ParamArray strArgs() As String _
) As RegisteredClientAction
Visual Basic (Usage) Copy Code
Dim objTarget As IRegisteredComponent
Dim strMethod As String
Dim strArgs() As String
Dim value As RegisteredClientAction

value = RegisteredClientAction.CreateWithId(objTarget, strMethod, strArgs)
C#
public static RegisteredClientAction CreateWithId(
   IRegisteredComponent objTarget,
   string strMethod,
   params string[] strArgs
)
Managed Extensions for C++
public: static RegisteredClientAction* CreateWithId(
   IRegisteredComponent* objTarget,
   string* strMethod,
   params string*[]* strArgs
)
C++/CLI
public:
static RegisteredClientAction^ CreateWithId(
   IRegisteredComponent^ objTarget,
   String^ strMethod,
   ... array<String^>^ strArgs
)

Parameters

objTarget
strMethod
strArgs

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RegisteredClientAction Class
RegisteredClientAction Members


RegisteredComponent Class

[image]
Gizmox.WebGUI.Common
RegisteredComponent Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RegisteredComponent Class

Object Model

Syntax

Visual Basic (Declaration)
<ToolboxItemFilterAttribute("Gizmox.WebGUI.Forms")>
<DesignerCategoryAttribute("Component")>
<ClassInterfaceAttribute()>
<ComVisibleAttribute(True)>
Public Class RegisteredComponent
   Inherits ComponentBase
   Implements IEventHandler, IGatewayComponent, IRegisteredComponent
Visual Basic (Usage) Copy Code
Dim instance As RegisteredComponent
C#
[ToolboxItemFilterAttribute("Gizmox.WebGUI.Forms")]
[DesignerCategoryAttribute("Component")]
[ClassInterfaceAttribute()]
[ComVisibleAttribute(true)]
public class RegisteredComponent : ComponentBase, IEventHandler, IGatewayComponent, IRegisteredComponent
Managed Extensions for C++
[ToolboxItemFilterAttribute("Gizmox.WebGUI.Forms")]
[DesignerCategoryAttribute("Component")]
[ClassInterfaceAttribute()]
[ComVisibleAttribute(true)]
public __gc class RegisteredComponent : public ComponentBase, IEventHandler, IGatewayComponent, IRegisteredComponent
C++/CLI
[ToolboxItemFilterAttribute("Gizmox.WebGUI.Forms")]
[DesignerCategoryAttribute("Component")]
[ClassInterfaceAttribute()]
[ComVisibleAttribute(true)]
public ref class RegisteredComponent : public ComponentBase, IEventHandler, IGatewayComponent, IRegisteredComponent

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

RegisteredComponent Members
Gizmox.WebGUI.Forms Namespace


RegisteredComponent Class Members

[image]
Gizmox.WebGUI.Common
RegisteredComponent Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : RegisteredComponent Class

The following tables list the members exposed by RegisteredComponent.

Public Constructors

 | Name | Description
Public Constructor | RegisteredComponent Constructor |
Top

Public Properties

 | Name | Description
Public Property | Container | (Inherited from ComponentBase)
Public Property | IsRegistered |
Public Property | Site | (Inherited from ComponentBase)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler |
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | IsConnected |
Protected Property | Session |
Top

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded. (Inherited from ComponentBase)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | Update | Overloaded.
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent |
Protected Method | GetCriticalEvents |
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | InvokeMethod |
Protected Method | InvokeMethodWithId |
Protected Method | IsDirty |
Protected Method | IsDirtyAttributes | Overloaded.
Protected Method | OnUnregisterComponents |
Protected Method | ProcessGatewayRequest |
Protected Method | RegisterBatch |
Protected Method | RegisterComponent |
Protected Method | RegisterContextMenu |
Protected Method | RegisterSelf |
Protected Method | RenderClientUpdateHandler |
Protected Method | RenderComponentEventAttributes |
Protected Method | UnRegisterBatch |
Protected Method | UnRegisterComponent |
Protected Method | UnregisterContextMenu |
Protected Method | UnRegisterSelf |
Protected Method | UpdateParams | Overloaded.
Top

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from ComponentBase)
Top

See Also

Reference

RegisteredComponent Class
Gizmox.WebGUI.Forms Namespace


RegisteredComponent Constructor

[image]
Gizmox.WebGUI.Common
RegisteredComponent Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RegisteredComponent Class : RegisteredComponent Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RegisteredComponent()
C#
public RegisteredComponent()
Managed Extensions for C++
public: RegisteredComponent();
C++/CLI
public:
RegisteredComponent();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RegisteredComponent Class
RegisteredComponent Members


RegisteredComponent Class Methods

[image]
Gizmox.WebGUI.Common
RegisteredComponent Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RegisteredComponent Class

For a list of all members of this type, see RegisteredComponent members.

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded. (Inherited from ComponentBase)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | Update | Overloaded.
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent |
Protected Method | GetCriticalEvents |
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | InvokeMethod |
Protected Method | InvokeMethodWithId |
Protected Method | IsDirty |
Protected Method | IsDirtyAttributes | Overloaded.
Protected Method | OnUnregisterComponents |
Protected Method | ProcessGatewayRequest |
Protected Method | RegisterBatch |
Protected Method | RegisterComponent |
Protected Method | RegisterContextMenu |
Protected Method | RegisterSelf |
Protected Method | RenderClientUpdateHandler |
Protected Method | RenderComponentEventAttributes |
Protected Method | UnRegisterBatch |
Protected Method | UnRegisterComponent |
Protected Method | UnregisterContextMenu |
Protected Method | UnRegisterSelf |
Protected Method | UpdateParams | Overloaded.
Top

See Also

Reference

RegisteredComponent Class
Gizmox.WebGUI.Forms Namespace


FireEvent Method

[image]
Gizmox.WebGUI.Common
FireEvent Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RegisteredComponent Class : FireEvent Method

objEvent

Syntax

Visual Basic (Declaration)
Protected Overridable Sub FireEvent( _
   ByVal objEvent As IEvent _
)
Visual Basic (Usage) Copy Code
Dim instance As RegisteredComponent
Dim objEvent As IEvent

instance.FireEvent(objEvent)
C#
protected virtual void FireEvent(
   IEvent objEvent
)
Managed Extensions for C++
protected: virtual void FireEvent(
   IEvent* objEvent
)
C++/CLI
protected:
virtual void FireEvent(
   IEvent^ objEvent
)

Parameters

objEvent

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RegisteredComponent Class
RegisteredComponent Members


GetCriticalEvents Method

[image]
Gizmox.WebGUI.Common
GetCriticalEvents Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RegisteredComponent Class : GetCriticalEvents Method

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetCriticalEvents() As EventTypes
Visual Basic (Usage) Copy Code
Dim instance As RegisteredComponent
Dim value As EventTypes

value = instance.GetCriticalEvents()
C#
protected virtual EventTypes GetCriticalEvents()
Managed Extensions for C++
protected: virtual EventTypes GetCriticalEvents();
C++/CLI
protected:
virtual EventTypes GetCriticalEvents();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RegisteredComponent Class
RegisteredComponent Members


InvokeMethod Method

[image]
Gizmox.WebGUI.Common
InvokeMethod Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RegisteredComponent Class : InvokeMethod Method

strMember
arrArgs

Syntax

Visual Basic (Declaration)
Protected Sub InvokeMethod( _
   ByVal strMember As String, _
   ByVal ParamArray arrArgs() As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As RegisteredComponent
Dim strMember As String
Dim arrArgs() As Object

instance.InvokeMethod(strMember, arrArgs)
C#
protected void InvokeMethod(
   string strMember,
   params object[] arrArgs
)
Managed Extensions for C++
protected: void InvokeMethod(
   string* strMember,
   params Object*[]* arrArgs
)
C++/CLI
protected:
void InvokeMethod(
   String^ strMember,
   ... array<Object^>^ arrArgs
)

Parameters

strMember
arrArgs

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RegisteredComponent Class
RegisteredComponent Members


InvokeMethodWithId Method

[image]
Gizmox.WebGUI.Common
InvokeMethodWithId Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RegisteredComponent Class : InvokeMethodWithId Method

strMember
arrArgs

Syntax

Visual Basic (Declaration)
Protected Sub InvokeMethodWithId( _
   ByVal strMember As String, _
   ByVal ParamArray arrArgs() As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As RegisteredComponent
Dim strMember As String
Dim arrArgs() As Object

instance.InvokeMethodWithId(strMember, arrArgs)
C#
protected void InvokeMethodWithId(
   string strMember,
   params object[] arrArgs
)
Managed Extensions for C++
protected: void InvokeMethodWithId(
   string* strMember,
   params Object*[]* arrArgs
)
C++/CLI
protected:
void InvokeMethodWithId(
   String^ strMember,
   ... array<Object^>^ arrArgs
)

Parameters

strMember
arrArgs

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RegisteredComponent Class
RegisteredComponent Members


IsDirty Method

[image]
Gizmox.WebGUI.Common
IsDirty Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RegisteredComponent Class : IsDirty Method

lngRequestID

Syntax

Visual Basic (Declaration)
Protected Function IsDirty( _
   ByVal lngRequestID As Long _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RegisteredComponent
Dim lngRequestID As Long
Dim value As Boolean

value = instance.IsDirty(lngRequestID)
C#
protected bool IsDirty(
   long lngRequestID
)
Managed Extensions for C++
protected: bool IsDirty(
   long lngRequestID
)
C++/CLI
protected:
bool IsDirty(
   long long lngRequestID
)

Parameters

lngRequestID

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RegisteredComponent Class
RegisteredComponent Members


IsDirtyAttributes Method

[image]
Gizmox.WebGUI.Common
IsDirtyAttributes Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RegisteredComponent Class : IsDirtyAttributes Method

Overload List

Overload | Description
IsDirtyAttributes(Int64) |
IsDirtyAttributes(Int64,AttributeType) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RegisteredComponent Class
RegisteredComponent Members


IsDirtyAttributes(Int64) Method

[image]
Gizmox.WebGUI.Common
IsDirtyAttributes(Int64) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RegisteredComponent Class > IsDirtyAttributes Method : IsDirtyAttributes(Int64) Method

lngRequestID

Syntax

Visual Basic (Declaration)
Protected Overloads Function IsDirtyAttributes( _
   ByVal lngRequestID As Long _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RegisteredComponent
Dim lngRequestID As Long
Dim value As Boolean

value = instance.IsDirtyAttributes(lngRequestID)
C#
protected bool IsDirtyAttributes(
   long lngRequestID
)
Managed Extensions for C++
protected: bool IsDirtyAttributes(
   long lngRequestID
)
C++/CLI
protected:
bool IsDirtyAttributes(
   long long lngRequestID
)

Parameters

lngRequestID

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RegisteredComponent Class
RegisteredComponent Members
Overload List


IsDirtyAttributes(Int64,AttributeType) Method

[image]
Gizmox.WebGUI.Common
IsDirtyAttributes(Int64,AttributeType) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RegisteredComponent Class > IsDirtyAttributes Method : IsDirtyAttributes(Int64,AttributeType) Method

lngRequestID
enmParams

Syntax

Visual Basic (Declaration)
Protected Overloads Function IsDirtyAttributes( _
   ByVal lngRequestID As Long, _
   ByVal enmParams As AttributeType _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RegisteredComponent
Dim lngRequestID As Long
Dim enmParams As AttributeType
Dim value As Boolean

value = instance.IsDirtyAttributes(lngRequestID, enmParams)
C#
protected bool IsDirtyAttributes(
   long lngRequestID,
   AttributeType enmParams
)
Managed Extensions for C++
protected: bool IsDirtyAttributes(
   long lngRequestID,
   AttributeType enmParams
)
C++/CLI
protected:
bool IsDirtyAttributes(
   long long lngRequestID,
   AttributeType enmParams
)

Parameters

lngRequestID
enmParams

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RegisteredComponent Class
RegisteredComponent Members
Overload List


OnUnregisterComponents Method

[image]
Gizmox.WebGUI.Common
OnUnregisterComponents Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RegisteredComponent Class : OnUnregisterComponents Method

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnUnregisterComponents()
Visual Basic (Usage) Copy Code
Dim instance As RegisteredComponent

instance.OnUnregisterComponents()
C#
protected virtual void OnUnregisterComponents()
Managed Extensions for C++
protected: virtual void OnUnregisterComponents();
C++/CLI
protected:
virtual void OnUnregisterComponents();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RegisteredComponent Class
RegisteredComponent Members


ProcessGatewayRequest Method

[image]
Gizmox.WebGUI.Common
ProcessGatewayRequest Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RegisteredComponent Class : ProcessGatewayRequest Method

objHttpContext
strAction

Syntax

Visual Basic (Declaration)
Protected Overridable Function ProcessGatewayRequest( _
   ByVal objHttpContext As HttpContext, _
   ByVal strAction As String _
) As IGatewayHandler
Visual Basic (Usage) Copy Code
Dim instance As RegisteredComponent
Dim objHttpContext As HttpContext
Dim strAction As String
Dim value As IGatewayHandler

value = instance.ProcessGatewayRequest(objHttpContext, strAction)
C#
protected virtual IGatewayHandler ProcessGatewayRequest(
   HttpContext objHttpContext,
   string strAction
)
Managed Extensions for C++
protected: virtual IGatewayHandler* ProcessGatewayRequest(
   HttpContext* objHttpContext,
   string* strAction
)
C++/CLI
protected:
virtual IGatewayHandler^ ProcessGatewayRequest(
   HttpContext^ objHttpContext,
   String^ strAction
)

Parameters

objHttpContext
strAction

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RegisteredComponent Class
RegisteredComponent Members


RegisterBatch Method

[image]
Gizmox.WebGUI.Common
RegisterBatch Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RegisteredComponent Class : RegisterBatch Method

objCollection

Syntax

Visual Basic (Declaration)
Protected Overridable Sub RegisterBatch( _
   ByVal objCollection As ICollection _
)
Visual Basic (Usage) Copy Code
Dim instance As RegisteredComponent
Dim objCollection As ICollection

instance.RegisterBatch(objCollection)
C#
protected virtual void RegisterBatch(
   ICollection objCollection
)
Managed Extensions for C++
protected: virtual void RegisterBatch(
   ICollection* objCollection
)
C++/CLI
protected:
virtual void RegisterBatch(
   ICollection^ objCollection
)

Parameters

objCollection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RegisteredComponent Class
RegisteredComponent Members


RegisterComponent Method

[image]
Gizmox.WebGUI.Common
RegisterComponent Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RegisteredComponent Class : RegisterComponent Method

objComponent

Syntax

Visual Basic (Declaration)
Protected Overridable Sub RegisterComponent( _
   ByVal objComponent As IRegisteredComponent _
)
Visual Basic (Usage) Copy Code
Dim instance As RegisteredComponent
Dim objComponent As IRegisteredComponent

instance.RegisterComponent(objComponent)
C#
protected virtual void RegisterComponent(
   IRegisteredComponent objComponent
)
Managed Extensions for C++
protected: virtual void RegisterComponent(
   IRegisteredComponent* objComponent
)
C++/CLI
protected:
virtual void RegisterComponent(
   IRegisteredComponent^ objComponent
)

Parameters

objComponent

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RegisteredComponent Class
RegisteredComponent Members


RegisterContextMenu Method

[image]
Gizmox.WebGUI.Common
RegisterContextMenu Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RegisteredComponent Class : RegisterContextMenu Method

Syntax

Visual Basic (Declaration)
Protected Overridable Sub RegisterContextMenu()
Visual Basic (Usage) Copy Code
Dim instance As RegisteredComponent

instance.RegisterContextMenu()
C#
protected virtual void RegisterContextMenu()
Managed Extensions for C++
protected: virtual void RegisterContextMenu();
C++/CLI
protected:
virtual void RegisterContextMenu();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RegisteredComponent Class
RegisteredComponent Members


RegisterSelf Method

[image]
Gizmox.WebGUI.Common
RegisterSelf Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RegisteredComponent Class : RegisterSelf Method

Syntax

Visual Basic (Declaration)
Protected Sub RegisterSelf()
Visual Basic (Usage) Copy Code
Dim instance As RegisteredComponent

instance.RegisterSelf()
C#
protected void RegisterSelf()
Managed Extensions for C++
protected: void RegisterSelf();
C++/CLI
protected:
void RegisterSelf();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RegisteredComponent Class
RegisteredComponent Members


RenderClientUpdateHandler Method

[image]
Gizmox.WebGUI.Common
RenderClientUpdateHandler Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RegisteredComponent Class : RenderClientUpdateHandler Method

objContext
objWriter

Syntax

Visual Basic (Declaration)
Protected Sub RenderClientUpdateHandler( _
   ByVal objContext As IContext, _
   ByVal objWriter As IAttributeWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As RegisteredComponent
Dim objContext As IContext
Dim objWriter As IAttributeWriter

instance.RenderClientUpdateHandler(objContext, objWriter)
C#
protected void RenderClientUpdateHandler(
   IContext objContext,
   IAttributeWriter objWriter
)
Managed Extensions for C++
protected: void RenderClientUpdateHandler(
   IContext* objContext,
   IAttributeWriter* objWriter
)
C++/CLI
protected:
void RenderClientUpdateHandler(
   IContext^ objContext,
   IAttributeWriter^ objWriter
)

Parameters

objContext
objWriter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RegisteredComponent Class
RegisteredComponent Members


RenderComponentEventAttributes Method

[image]
Gizmox.WebGUI.Common
RenderComponentEventAttributes Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RegisteredComponent Class : RenderComponentEventAttributes Method

objContext
objWriter

Syntax

Visual Basic (Declaration)
Protected Sub RenderComponentEventAttributes( _
   ByVal objContext As IContext, _
   ByVal objWriter As IAttributeWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As RegisteredComponent
Dim objContext As IContext
Dim objWriter As IAttributeWriter

instance.RenderComponentEventAttributes(objContext, objWriter)
C#
protected void RenderComponentEventAttributes(
   IContext objContext,
   IAttributeWriter objWriter
)
Managed Extensions for C++
protected: void RenderComponentEventAttributes(
   IContext* objContext,
   IAttributeWriter* objWriter
)
C++/CLI
protected:
void RenderComponentEventAttributes(
   IContext^ objContext,
   IAttributeWriter^ objWriter
)

Parameters

objContext
objWriter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RegisteredComponent Class
RegisteredComponent Members


UnRegisterBatch Method

[image]
Gizmox.WebGUI.Common
UnRegisterBatch Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RegisteredComponent Class : UnRegisterBatch Method

objCollection

Syntax

Visual Basic (Declaration)
Protected Overridable Sub UnRegisterBatch( _
   ByVal objCollection As ICollection _
)
Visual Basic (Usage) Copy Code
Dim instance As RegisteredComponent
Dim objCollection As ICollection

instance.UnRegisterBatch(objCollection)
C#
protected virtual void UnRegisterBatch(
   ICollection objCollection
)
Managed Extensions for C++
protected: virtual void UnRegisterBatch(
   ICollection* objCollection
)
C++/CLI
protected:
virtual void UnRegisterBatch(
   ICollection^ objCollection
)

Parameters

objCollection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RegisteredComponent Class
RegisteredComponent Members


UnRegisterComponent Method

[image]
Gizmox.WebGUI.Common
UnRegisterComponent Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RegisteredComponent Class : UnRegisterComponent Method

objComponent

Syntax

Visual Basic (Declaration)
Protected Overridable Sub UnRegisterComponent( _
   ByVal objComponent As IRegisteredComponent _
)
Visual Basic (Usage) Copy Code
Dim instance As RegisteredComponent
Dim objComponent As IRegisteredComponent

instance.UnRegisterComponent(objComponent)
C#
protected virtual void UnRegisterComponent(
   IRegisteredComponent objComponent
)
Managed Extensions for C++
protected: virtual void UnRegisterComponent(
   IRegisteredComponent* objComponent
)
C++/CLI
protected:
virtual void UnRegisterComponent(
   IRegisteredComponent^ objComponent
)

Parameters

objComponent

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RegisteredComponent Class
RegisteredComponent Members


UnregisterContextMenu Method

[image]
Gizmox.WebGUI.Common
UnregisterContextMenu Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RegisteredComponent Class : UnregisterContextMenu Method

Syntax

Visual Basic (Declaration)
Protected Overridable Sub UnregisterContextMenu()
Visual Basic (Usage) Copy Code
Dim instance As RegisteredComponent

instance.UnregisterContextMenu()
C#
protected virtual void UnregisterContextMenu()
Managed Extensions for C++
protected: virtual void UnregisterContextMenu();
C++/CLI
protected:
virtual void UnregisterContextMenu();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RegisteredComponent Class
RegisteredComponent Members


UnRegisterSelf Method

[image]
Gizmox.WebGUI.Common
UnRegisterSelf Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RegisteredComponent Class : UnRegisterSelf Method

Syntax

Visual Basic (Declaration)
Protected Sub UnRegisterSelf()
Visual Basic (Usage) Copy Code
Dim instance As RegisteredComponent

instance.UnRegisterSelf()
C#
protected void UnRegisterSelf()
Managed Extensions for C++
protected: void UnRegisterSelf();
C++/CLI
protected:
void UnRegisterSelf();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RegisteredComponent Class
RegisteredComponent Members


Update Method

[image]
Gizmox.WebGUI.Common
Update Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RegisteredComponent Class : Update Method

Overload List

Overload | Description
Update() |
Update(Boolean) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RegisteredComponent Class
RegisteredComponent Members


Update() Method

[image]
Gizmox.WebGUI.Common
Update() Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RegisteredComponent Class > Update Method : Update() Method

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub Update()
Visual Basic (Usage) Copy Code
Dim instance As RegisteredComponent

instance.Update()
C#
public virtual void Update()
Managed Extensions for C++
public: virtual void Update();
C++/CLI
public:
virtual void Update();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RegisteredComponent Class
RegisteredComponent Members
Overload List


Update(Boolean) Method

[image]
Gizmox.WebGUI.Common
Update(Boolean) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RegisteredComponent Class > Update Method : Update(Boolean) Method

blnRedrawOnly

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub Update( _
   ByVal blnRedrawOnly As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As RegisteredComponent
Dim blnRedrawOnly As Boolean

instance.Update(blnRedrawOnly)
C#
public virtual void Update(
   bool blnRedrawOnly
)
Managed Extensions for C++
public: virtual void Update(
   bool blnRedrawOnly
)
C++/CLI
public:
virtual void Update(
   bool blnRedrawOnly
)

Parameters

blnRedrawOnly

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RegisteredComponent Class
RegisteredComponent Members
Overload List


UpdateParams Method

[image]
Gizmox.WebGUI.Common
UpdateParams Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RegisteredComponent Class : UpdateParams Method

Overload List

Overload | Description
UpdateParams() |
UpdateParams(AttributeType) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RegisteredComponent Class
RegisteredComponent Members


UpdateParams() Method

[image]
Gizmox.WebGUI.Common
UpdateParams() Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RegisteredComponent Class > UpdateParams Method : UpdateParams() Method

Syntax

Visual Basic (Declaration)
Protected Overloads Sub UpdateParams()
Visual Basic (Usage) Copy Code
Dim instance As RegisteredComponent

instance.UpdateParams()
C#
protected void UpdateParams()
Managed Extensions for C++
protected: void UpdateParams();
C++/CLI
protected:
void UpdateParams();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RegisteredComponent Class
RegisteredComponent Members
Overload List


UpdateParams(AttributeType) Method

[image]
Gizmox.WebGUI.Common
UpdateParams(AttributeType) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RegisteredComponent Class > UpdateParams Method : UpdateParams(AttributeType) Method

enmParams

Syntax

Visual Basic (Declaration)
Protected Overloads Sub UpdateParams( _
   ByVal enmParams As AttributeType _
)
Visual Basic (Usage) Copy Code
Dim instance As RegisteredComponent
Dim enmParams As AttributeType

instance.UpdateParams(enmParams)
C#
protected void UpdateParams(
   AttributeType enmParams
)
Managed Extensions for C++
protected: void UpdateParams(
   AttributeType enmParams
)
C++/CLI
protected:
void UpdateParams(
   AttributeType enmParams
)

Parameters

enmParams

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RegisteredComponent Class
RegisteredComponent Members
Overload List


RegisteredComponent Class Properties

[image]
Gizmox.WebGUI.Common
RegisteredComponent Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RegisteredComponent Class

For a list of all members of this type, see RegisteredComponent members.

Public Properties

 | Name | Description
Public Property | Container | (Inherited from ComponentBase)
Public Property | IsRegistered |
Public Property | Site | (Inherited from ComponentBase)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler |
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | IsConnected |
Protected Property | Session |
Top

See Also

Reference

RegisteredComponent Class
Gizmox.WebGUI.Forms Namespace


ClientUpdateHandler Property

[image]
Gizmox.WebGUI.Common
ClientUpdateHandler Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RegisteredComponent Class : ClientUpdateHandler Property

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property ClientUpdateHandler As String
Visual Basic (Usage) Copy Code
Dim instance As RegisteredComponent
Dim value As String

value = instance.ClientUpdateHandler
C#
protected virtual string ClientUpdateHandler {get;}
Managed Extensions for C++
protected: __property virtual string* get_ClientUpdateHandler();
C++/CLI
protected:
virtual property String^ ClientUpdateHandler {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RegisteredComponent Class
RegisteredComponent Members


IsConnected Property

[image]
Gizmox.WebGUI.Common
IsConnected Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RegisteredComponent Class : IsConnected Property

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property IsConnected As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RegisteredComponent
Dim value As Boolean

value = instance.IsConnected
C#
protected virtual bool IsConnected {get;}
Managed Extensions for C++
protected: __property virtual bool get_IsConnected();
C++/CLI
protected:
virtual property bool IsConnected {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RegisteredComponent Class
RegisteredComponent Members


IsRegistered Property

[image]
Gizmox.WebGUI.Common
IsRegistered Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RegisteredComponent Class : IsRegistered Property

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
<DefaultValueAttribute()>
Public Property IsRegistered As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RegisteredComponent
Dim value As Boolean

instance.IsRegistered = value

value = instance.IsRegistered
C#
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
public bool IsRegistered {get; set;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
public: __property bool get_IsRegistered();
public: __property void set_IsRegistered(
   bool value
);
C++/CLI
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
[DefaultValueAttribute()]
public:
property bool IsRegistered {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RegisteredComponent Class
RegisteredComponent Members


Session Property

[image]
Gizmox.WebGUI.Common
Session Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RegisteredComponent Class : Session Property

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property Session As ISession
Visual Basic (Usage) Copy Code
Dim instance As RegisteredComponent
Dim value As ISession

value = instance.Session
C#
protected virtual ISession Session {get;}
Managed Extensions for C++
protected: __property virtual ISession* get_Session();
C++/CLI
protected:
virtual property ISession^ Session {
   ISession^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RegisteredComponent Class
RegisteredComponent Members


RegisteredComponent.NotImplementedGateway Class

[image]
Gizmox.WebGUI.Common
RegisteredComponent.NotImplementedGateway Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RegisteredComponent.NotImplementedGateway Class

Syntax

Visual Basic (Declaration)
Private Class RegisteredComponent.NotImplementedGateway
   Implements IGatewayHandler
Visual Basic (Usage) Copy Code
Dim instance As RegisteredComponent.NotImplementedGateway
C#
private class RegisteredComponent.NotImplementedGateway : IGatewayHandler
Managed Extensions for C++
private __gc class RegisteredComponent.NotImplementedGateway : public IGatewayHandler
C++/CLI
private ref class RegisteredComponent.NotImplementedGateway : public IGatewayHandler

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.RegisteredComponent.NotImplementedGateway

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

RegisteredComponent.NotImplementedGateway Members
Gizmox.WebGUI.Forms Namespace


RegisteredComponent.NotImplementedGateway Class Members

[image]
Gizmox.WebGUI.Common
RegisteredComponent.NotImplementedGateway Class Members
See Also Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : RegisteredComponent.NotImplementedGateway Class

The following tables list the members exposed by RegisteredComponent.NotImplementedGateway.

Public Constructors

 | Name | Description
Public Constructor | RegisteredComponent.NotImplementedGateway Constructor |
Top

Public Methods

 | Name | Description
Public Method | ProcessGatewayRequest |
Top

See Also

Reference

RegisteredComponent.NotImplementedGateway Class
Gizmox.WebGUI.Forms Namespace


RegisteredComponent.NotImplementedGateway Constructor

[image]
Gizmox.WebGUI.Common
RegisteredComponent.NotImplementedGateway Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RegisteredComponent.NotImplementedGateway Class : RegisteredComponent.NotImplementedGateway Constructor

strAction

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal strAction As String _
)
Visual Basic (Usage) Copy Code
Dim strAction As String

Dim instance As RegisteredComponent.NotImplementedGateway(strAction)
C#
public RegisteredComponent.NotImplementedGateway(
   string strAction
)
Managed Extensions for C++
public: RegisteredComponent.NotImplementedGateway(
   string* strAction
)
C++/CLI
public:
RegisteredComponent.NotImplementedGateway(
   String^ strAction
)

Parameters

strAction

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RegisteredComponent.NotImplementedGateway Class
RegisteredComponent.NotImplementedGateway Members


RegisteredComponent.NotImplementedGateway Class Methods

[image]
Gizmox.WebGUI.Common
RegisteredComponent.NotImplementedGateway Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RegisteredComponent.NotImplementedGateway Class

For a list of all members of this type, see RegisteredComponent.NotImplementedGateway members.

Public Methods

 | Name | Description
Public Method | ProcessGatewayRequest |
Top

See Also

Reference

RegisteredComponent.NotImplementedGateway Class
Gizmox.WebGUI.Forms Namespace


ProcessGatewayRequest Method

[image]
Gizmox.WebGUI.Common
ProcessGatewayRequest Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RegisteredComponent.NotImplementedGateway Class : ProcessGatewayRequest Method

objContext
objComponent

Syntax

Visual Basic (Declaration)
Public Sub ProcessGatewayRequest( _
   ByVal objContext As IContext, _
   ByVal objComponent As IRegisteredComponent _
)
Visual Basic (Usage) Copy Code
Dim instance As RegisteredComponent.NotImplementedGateway
Dim objContext As IContext
Dim objComponent As IRegisteredComponent

instance.ProcessGatewayRequest(objContext, objComponent)
C#
public void ProcessGatewayRequest(
   IContext objContext,
   IRegisteredComponent objComponent
)
Managed Extensions for C++
public: void ProcessGatewayRequest(
   IContext* objContext,
   IRegisteredComponent* objComponent
)
C++/CLI
public:
void ProcessGatewayRequest(
   IContext^ objContext,
   IRegisteredComponent^ objComponent
)

Parameters

objContext
objComponent

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RegisteredComponent.NotImplementedGateway Class
RegisteredComponent.NotImplementedGateway Members


Theme Class

[image]
Gizmox.WebGUI.Common
Theme Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : Theme Class

Object Model

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class Theme
Visual Basic (Usage) Copy Code
Dim instance As Theme
C#
[DefaultMemberAttribute("Item")]
public class Theme
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
public __gc class Theme
C++/CLI
[DefaultMemberAttribute("Item")]
public ref class Theme

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.Theme

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

Theme Members
Gizmox.WebGUI.Forms Namespace


Theme Class Members

[image]
Gizmox.WebGUI.Common
Theme Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : Theme Class

The following tables list the members exposed by Theme.

Public Constructors

 | Name | Description
Public Constructor | Theme Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Assembly |
static (Shared in Visual Basic) | Default |
Public Property | Flavor |
Public Property | Flavors |
Public Property | FullName |
Public Property | Item |
Public Property | Name |
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Create | Overloaded.
static (Shared in Visual Basic) | CreateFromFullName |
Public Method | Equals | Overridden.
Public Method | GetHashCode | Overridden.
Public Method | ToString | Overridden.
Top

See Also

Reference

Theme Class
Gizmox.WebGUI.Forms Namespace


Theme Constructor

[image]
Gizmox.WebGUI.Common
Theme Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Theme Class : Theme Constructor

Overload List

Overload | Description
Theme Constructor(String) |
Theme Constructor(String,String) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Theme Class
Theme Members


Theme Constructor(String)

[image]
Gizmox.WebGUI.Common
Theme Constructor(String)
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Theme Class > Theme Constructor : Theme Constructor(String)

strName

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal strName As String _
)
Visual Basic (Usage) Copy Code
Dim strName As String

Dim instance As Theme(strName)
C#
public Theme(
   string strName
)
Managed Extensions for C++
public: Theme(
   string* strName
)
C++/CLI
public:
Theme(
   String^ strName
)

Parameters

strName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Theme Class
Theme Members
Overload List


Theme Constructor(String,String)

[image]
Gizmox.WebGUI.Common
Theme Constructor(String,String)
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Theme Class > Theme Constructor : Theme Constructor(String,String)

strName
strFlavor

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal strName As String, _
   ByVal strFlavor As String _
)
Visual Basic (Usage) Copy Code
Dim strName As String
Dim strFlavor As String

Dim instance As Theme(strName, strFlavor)
C#
public Theme(
   string strName,
   string strFlavor
)
Managed Extensions for C++
public: Theme(
   string* strName,
   string* strFlavor
)
C++/CLI
public:
Theme(
   String^ strName,
   String^ strFlavor
)

Parameters

strName
strFlavor

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Theme Class
Theme Members
Overload List


Theme Class Methods

[image]
Gizmox.WebGUI.Common
Theme Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : Theme Class

For a list of all members of this type, see Theme members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Create | Overloaded.
static (Shared in Visual Basic) | CreateFromFullName |
Public Method | Equals | Overridden.
Public Method | GetHashCode | Overridden.
Public Method | ToString | Overridden.
Top

See Also

Reference

Theme Class
Gizmox.WebGUI.Forms Namespace


Create Method

[image]
Gizmox.WebGUI.Common
Create Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Theme Class : Create Method

Overload List

Overload | Description
Create(String) |
Create(String,String) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Theme Class
Theme Members


Create(String) Method

[image]
Gizmox.WebGUI.Common
Create(String) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Theme Class > Create Method : Create(String) Method

strName

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Create( _
   ByVal strName As String _
) As Theme
Visual Basic (Usage) Copy Code
Dim strName As String
Dim value As Theme

value = Theme.Create(strName)
C#
public static Theme Create(
   string strName
)
Managed Extensions for C++
public: static Theme* Create(
   string* strName
)
C++/CLI
public:
static Theme^ Create(
   String^ strName
)

Parameters

strName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Theme Class
Theme Members
Overload List


Create(String,String) Method

[image]
Gizmox.WebGUI.Common
Create(String,String) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Theme Class > Create Method : Create(String,String) Method

strName
strFlavor

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function Create( _
   ByVal strName As String, _
   ByVal strFlavor As String _
) As Theme
Visual Basic (Usage) Copy Code
Dim strName As String
Dim strFlavor As String
Dim value As Theme

value = Theme.Create(strName, strFlavor)
C#
public static Theme Create(
   string strName,
   string strFlavor
)
Managed Extensions for C++
public: static Theme* Create(
   string* strName,
   string* strFlavor
)
C++/CLI
public:
static Theme^ Create(
   String^ strName,
   String^ strFlavor
)

Parameters

strName
strFlavor

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Theme Class
Theme Members
Overload List


CreateFromFullName Method

[image]
Gizmox.WebGUI.Common
CreateFromFullName Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Theme Class : CreateFromFullName Method

strFullName

Syntax

Visual Basic (Declaration)
Public Shared Function CreateFromFullName( _
   ByVal strFullName As String _
) As Theme
Visual Basic (Usage) Copy Code
Dim strFullName As String
Dim value As Theme

value = Theme.CreateFromFullName(strFullName)
C#
public static Theme CreateFromFullName(
   string strFullName
)
Managed Extensions for C++
public: static Theme* CreateFromFullName(
   string* strFullName
)
C++/CLI
public:
static Theme^ CreateFromFullName(
   String^ strFullName
)

Parameters

strFullName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Theme Class
Theme Members


Equals Method

[image]
Gizmox.WebGUI.Common
Equals Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Theme Class : Equals Method

obj

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Theme
Dim obj As Object
Dim value As Boolean

value = instance.Equals(obj)
C#
public override bool Equals(
   object obj
)
Managed Extensions for C++
public: bool Equals(
   Object* obj
) override
C++/CLI
public:
bool Equals(
   Object^ obj
) override

Parameters

obj

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Theme Class
Theme Members


GetHashCode Method

[image]
Gizmox.WebGUI.Common
GetHashCode Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Theme Class : GetHashCode Method

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode() As Integer
Visual Basic (Usage) Copy Code
Dim instance As Theme
Dim value As Integer

value = instance.GetHashCode()
C#
public override int GetHashCode()
Managed Extensions for C++
public: int GetHashCode(); override
C++/CLI
public:
int GetHashCode(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Theme Class
Theme Members


ToString Method

[image]
Gizmox.WebGUI.Common
ToString Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Theme Class : ToString Method

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As Theme
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Theme Class
Theme Members


Theme Class Properties

[image]
Gizmox.WebGUI.Common
Theme Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : Theme Class

For a list of all members of this type, see Theme members.

Public Properties

 | Name | Description
Public Property | Assembly |
static (Shared in Visual Basic) | Default |
Public Property | Flavor |
Public Property | Flavors |
Public Property | FullName |
Public Property | Item |
Public Property | Name |
Top

See Also

Reference

Theme Class
Gizmox.WebGUI.Forms Namespace


Assembly Property

[image]
Gizmox.WebGUI.Common
Assembly Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Theme Class : Assembly Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Assembly As Assembly
Visual Basic (Usage) Copy Code
Dim instance As Theme
Dim value As Assembly

value = instance.Assembly
C#
public Assembly Assembly {get;}
Managed Extensions for C++
public: __property Assembly* get_Assembly();
C++/CLI
public:
property Assembly^ Assembly {
   Assembly^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Theme Class
Theme Members


Default Property

[image]
Gizmox.WebGUI.Common
Default Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Theme Class : Default Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Default As Theme
Visual Basic (Usage) Copy Code
Dim value As Theme

value = Theme.Default
C#
public static Theme Default {get;}
Managed Extensions for C++
public: __property static Theme* get_Default();
C++/CLI
public:
static property Theme^ Default {
   Theme^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Theme Class
Theme Members


Flavor Property

[image]
Gizmox.WebGUI.Common
Flavor Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Theme Class : Flavor Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Flavor As ThemeFlavor
Visual Basic (Usage) Copy Code
Dim instance As Theme
Dim value As ThemeFlavor

value = instance.Flavor
C#
public ThemeFlavor Flavor {get;}
Managed Extensions for C++
public: __property ThemeFlavor* get_Flavor();
C++/CLI
public:
property ThemeFlavor^ Flavor {
   ThemeFlavor^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Theme Class
Theme Members


Flavors Property

[image]
Gizmox.WebGUI.Common
Flavors Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Theme Class : Flavors Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Flavors As Theme.FlavorCollection
Visual Basic (Usage) Copy Code
Dim instance As Theme
Dim value As Theme.FlavorCollection

value = instance.Flavors
C#
public Theme.FlavorCollection Flavors {get;}
Managed Extensions for C++
public: __property Theme.FlavorCollection* get_Flavors();
C++/CLI
public:
property Theme::FlavorCollection^ Flavors {
   Theme::FlavorCollection^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Theme Class
Theme Members


FullName Property

[image]
Gizmox.WebGUI.Common
FullName Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Theme Class : FullName Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FullName As String
Visual Basic (Usage) Copy Code
Dim instance As Theme
Dim value As String

value = instance.FullName
C#
public string FullName {get;}
Managed Extensions for C++
public: __property string* get_FullName();
C++/CLI
public:
property String^ FullName {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Theme Class
Theme Members


Item Property

[image]
Gizmox.WebGUI.Common
Item Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Theme Class : Item Property

strAttributeName

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal strAttributeName As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As Theme
Dim strAttributeName As String
Dim value As String

value = instance.Item(strAttributeName)
C#
public string this[
   string strAttributeName
]; {get;}
Managed Extensions for C++
public: __property string* get_Item(
   string* strAttributeName
);
C++/CLI
public:
property String^ default [String^] {
   String^ get(String^strAttributeName);
}

Parameters

strAttributeName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Theme Class
Theme Members


Name Property

[image]
Gizmox.WebGUI.Common
Name Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Theme Class : Name Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As Theme
Dim value As String

value = instance.Name
C#
public string Name {get;}
Managed Extensions for C++
public: __property string* get_Name();
C++/CLI
public:
property String^ Name {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Theme Class
Theme Members


Theme.FlavorCollection Class

[image]
Gizmox.WebGUI.Common
Theme.FlavorCollection Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : Theme.FlavorCollection Class

Object Model

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class Theme.FlavorCollection
Visual Basic (Usage) Copy Code
Dim instance As Theme.FlavorCollection
C#
[DefaultMemberAttribute("Item")]
public class Theme.FlavorCollection
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
public __gc class Theme.FlavorCollection
C++/CLI
[DefaultMemberAttribute("Item")]
public ref class Theme.FlavorCollection

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.Theme.FlavorCollection

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

Theme.FlavorCollection Members
Gizmox.WebGUI.Forms Namespace


Theme.FlavorCollection Class Members

[image]
Gizmox.WebGUI.Common
Theme.FlavorCollection Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : Theme.FlavorCollection Class

The following tables list the members exposed by Theme.FlavorCollection.

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Default |
Public Property | IsSynchronized |
Public Property | Item |
Public Property | SyncRoot |
Top

Public Methods

 | Name | Description
Public Method | CopyTo |
Public Method | GetEnumerator |
Top

See Also

Reference

Theme.FlavorCollection Class
Gizmox.WebGUI.Forms Namespace


Theme.FlavorCollection Class Methods

[image]
Gizmox.WebGUI.Common
Theme.FlavorCollection Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : Theme.FlavorCollection Class

For a list of all members of this type, see Theme.FlavorCollection members.

Public Methods

 | Name | Description
Public Method | CopyTo |
Public Method | GetEnumerator |
Top

See Also

Reference

Theme.FlavorCollection Class
Gizmox.WebGUI.Forms Namespace


CopyTo Method

[image]
Gizmox.WebGUI.Common
CopyTo Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Theme.FlavorCollection Class : CopyTo Method

array
index

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array As Array, _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As Theme.FlavorCollection
Dim array As Array
Dim index As Integer

instance.CopyTo(array, index)
C#
public void CopyTo(
   Array array,
   int index
)
Managed Extensions for C++
public: void CopyTo(
   Array* array,
   int index
)
C++/CLI
public:
void CopyTo(
   Array^ array,
   int index
)

Parameters

array
index

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Theme.FlavorCollection Class
Theme.FlavorCollection Members


GetEnumerator Method

[image]
Gizmox.WebGUI.Common
GetEnumerator Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Theme.FlavorCollection Class : GetEnumerator Method

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As Theme.FlavorCollection
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Theme.FlavorCollection Class
Theme.FlavorCollection Members


Theme.FlavorCollection Class Properties

[image]
Gizmox.WebGUI.Common
Theme.FlavorCollection Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : Theme.FlavorCollection Class

For a list of all members of this type, see Theme.FlavorCollection members.

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Default |
Public Property | IsSynchronized |
Public Property | Item |
Public Property | SyncRoot |
Top

See Also

Reference

Theme.FlavorCollection Class
Gizmox.WebGUI.Forms Namespace


Count Property

[image]
Gizmox.WebGUI.Common
Count Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Theme.FlavorCollection Class : Count Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As Theme.FlavorCollection
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Theme.FlavorCollection Class
Theme.FlavorCollection Members


Default Property

[image]
Gizmox.WebGUI.Common
Default Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Theme.FlavorCollection Class : Default Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Default As ThemeFlavor
Visual Basic (Usage) Copy Code
Dim instance As Theme.FlavorCollection
Dim value As ThemeFlavor

value = instance.Default
C#
public ThemeFlavor Default {get;}
Managed Extensions for C++
public: __property ThemeFlavor* get_Default();
C++/CLI
public:
property ThemeFlavor^ Default {
   ThemeFlavor^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Theme.FlavorCollection Class
Theme.FlavorCollection Members


IsSynchronized Property

[image]
Gizmox.WebGUI.Common
IsSynchronized Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Theme.FlavorCollection Class : IsSynchronized Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsSynchronized As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Theme.FlavorCollection
Dim value As Boolean

value = instance.IsSynchronized
C#
public bool IsSynchronized {get;}
Managed Extensions for C++
public: __property bool get_IsSynchronized();
C++/CLI
public:
property bool IsSynchronized {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Theme.FlavorCollection Class
Theme.FlavorCollection Members


Item Property

[image]
Gizmox.WebGUI.Common
Item Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Theme.FlavorCollection Class : Item Property

strFlavorName

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal strFlavorName As String _
) As ThemeFlavor
Visual Basic (Usage) Copy Code
Dim instance As Theme.FlavorCollection
Dim strFlavorName As String
Dim value As ThemeFlavor

value = instance.Item(strFlavorName)
C#
public ThemeFlavor this[
   string strFlavorName
]; {get;}
Managed Extensions for C++
public: __property ThemeFlavor* get_Item(
   string* strFlavorName
);
C++/CLI
public:
property ThemeFlavor^ default [String^] {
   ThemeFlavor^ get(String^strFlavorName);
}

Parameters

strFlavorName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Theme.FlavorCollection Class
Theme.FlavorCollection Members


SyncRoot Property

[image]
Gizmox.WebGUI.Common
SyncRoot Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Theme.FlavorCollection Class : SyncRoot Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SyncRoot As Object
Visual Basic (Usage) Copy Code
Dim instance As Theme.FlavorCollection
Dim value As Object

value = instance.SyncRoot
C#
public object SyncRoot {get;}
Managed Extensions for C++
public: __property Object* get_SyncRoot();
C++/CLI
public:
property Object^ SyncRoot {
   Object^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Theme.FlavorCollection Class
Theme.FlavorCollection Members


Theme.ThemeCollection Class

[image]
Gizmox.WebGUI.Common
Theme.ThemeCollection Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : Theme.ThemeCollection Class

Object Model

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class Theme.ThemeCollection
Visual Basic (Usage) Copy Code
Dim instance As Theme.ThemeCollection
C#
[DefaultMemberAttribute("Item")]
public class Theme.ThemeCollection
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
public __gc class Theme.ThemeCollection
C++/CLI
[DefaultMemberAttribute("Item")]
public ref class Theme.ThemeCollection

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.Theme.ThemeCollection

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

Theme.ThemeCollection Members
Gizmox.WebGUI.Forms Namespace


Theme.ThemeCollection Class Members

[image]
Gizmox.WebGUI.Common
Theme.ThemeCollection Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : Theme.ThemeCollection Class

The following tables list the members exposed by Theme.ThemeCollection.

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Default |
Public Property | IsSynchronized |
Public Property | Item |
Public Property | SyncRoot |
Top

Public Methods

 | Name | Description
Public Method | CopyTo |
Public Method | GetEnumerator |
Top

See Also

Reference

Theme.ThemeCollection Class
Gizmox.WebGUI.Forms Namespace


Theme.ThemeCollection Class Methods

[image]
Gizmox.WebGUI.Common
Theme.ThemeCollection Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : Theme.ThemeCollection Class

For a list of all members of this type, see Theme.ThemeCollection members.

Public Methods

 | Name | Description
Public Method | CopyTo |
Public Method | GetEnumerator |
Top

See Also

Reference

Theme.ThemeCollection Class
Gizmox.WebGUI.Forms Namespace


CopyTo Method

[image]
Gizmox.WebGUI.Common
CopyTo Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Theme.ThemeCollection Class : CopyTo Method

array
index

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array As Array, _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As Theme.ThemeCollection
Dim array As Array
Dim index As Integer

instance.CopyTo(array, index)
C#
public void CopyTo(
   Array array,
   int index
)
Managed Extensions for C++
public: void CopyTo(
   Array* array,
   int index
)
C++/CLI
public:
void CopyTo(
   Array^ array,
   int index
)

Parameters

array
index

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Theme.ThemeCollection Class
Theme.ThemeCollection Members


GetEnumerator Method

[image]
Gizmox.WebGUI.Common
GetEnumerator Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Theme.ThemeCollection Class : GetEnumerator Method

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As Theme.ThemeCollection
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Theme.ThemeCollection Class
Theme.ThemeCollection Members


Theme.ThemeCollection Class Properties

[image]
Gizmox.WebGUI.Common
Theme.ThemeCollection Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : Theme.ThemeCollection Class

For a list of all members of this type, see Theme.ThemeCollection members.

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Default |
Public Property | IsSynchronized |
Public Property | Item |
Public Property | SyncRoot |
Top

See Also

Reference

Theme.ThemeCollection Class
Gizmox.WebGUI.Forms Namespace


Count Property

[image]
Gizmox.WebGUI.Common
Count Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Theme.ThemeCollection Class : Count Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As Theme.ThemeCollection
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Theme.ThemeCollection Class
Theme.ThemeCollection Members


Default Property

[image]
Gizmox.WebGUI.Common
Default Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Theme.ThemeCollection Class : Default Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Default As Theme
Visual Basic (Usage) Copy Code
Dim instance As Theme.ThemeCollection
Dim value As Theme

value = instance.Default
C#
public Theme Default {get;}
Managed Extensions for C++
public: __property Theme* get_Default();
C++/CLI
public:
property Theme^ Default {
   Theme^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Theme.ThemeCollection Class
Theme.ThemeCollection Members


IsSynchronized Property

[image]
Gizmox.WebGUI.Common
IsSynchronized Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Theme.ThemeCollection Class : IsSynchronized Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsSynchronized As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Theme.ThemeCollection
Dim value As Boolean

value = instance.IsSynchronized
C#
public bool IsSynchronized {get;}
Managed Extensions for C++
public: __property bool get_IsSynchronized();
C++/CLI
public:
property bool IsSynchronized {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Theme.ThemeCollection Class
Theme.ThemeCollection Members


Item Property

[image]
Gizmox.WebGUI.Common
Item Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Theme.ThemeCollection Class : Item Property

strThemeName

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal strThemeName As String _
) As Theme
Visual Basic (Usage) Copy Code
Dim instance As Theme.ThemeCollection
Dim strThemeName As String
Dim value As Theme

value = instance.Item(strThemeName)
C#
public Theme this[
   string strThemeName
]; {get;}
Managed Extensions for C++
public: __property Theme* get_Item(
   string* strThemeName
);
C++/CLI
public:
property Theme^ default [String^] {
   Theme^ get(String^strThemeName);
}

Parameters

strThemeName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Theme.ThemeCollection Class
Theme.ThemeCollection Members


SyncRoot Property

[image]
Gizmox.WebGUI.Common
SyncRoot Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > Theme.ThemeCollection Class : SyncRoot Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SyncRoot As Object
Visual Basic (Usage) Copy Code
Dim instance As Theme.ThemeCollection
Dim value As Object

value = instance.SyncRoot
C#
public object SyncRoot {get;}
Managed Extensions for C++
public: __property Object* get_SyncRoot();
C++/CLI
public:
property Object^ SyncRoot {
   Object^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Theme.ThemeCollection Class
Theme.ThemeCollection Members


ThemeFlavor Class

[image]
Gizmox.WebGUI.Common
ThemeFlavor Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ThemeFlavor Class

Syntax

Visual Basic (Declaration)
Public Class ThemeFlavor
Visual Basic (Usage) Copy Code
Dim instance As ThemeFlavor
C#
public class ThemeFlavor
Managed Extensions for C++
public __gc class ThemeFlavor
C++/CLI
public ref class ThemeFlavor

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ThemeFlavor

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

ThemeFlavor Members
Gizmox.WebGUI.Forms Namespace


ThemeFlavor Class Members

[image]
Gizmox.WebGUI.Common
ThemeFlavor Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : ThemeFlavor Class

The following tables list the members exposed by ThemeFlavor.

Public Properties

 | Name | Description
Public Property | FullName |
Public Property | Name |
Top

Public Methods

 | Name | Description
Public Method | GetVariable |
Top

See Also

Reference

ThemeFlavor Class
Gizmox.WebGUI.Forms Namespace


ThemeFlavor Class Methods

[image]
Gizmox.WebGUI.Common
ThemeFlavor Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ThemeFlavor Class

For a list of all members of this type, see ThemeFlavor members.

Public Methods

 | Name | Description
Public Method | GetVariable |
Top

See Also

Reference

ThemeFlavor Class
Gizmox.WebGUI.Forms Namespace


GetVariable Method

[image]
Gizmox.WebGUI.Common
GetVariable Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ThemeFlavor Class : GetVariable Method

strBrowser
strVariableName

Syntax

Visual Basic (Declaration)
Public Function GetVariable( _
   ByVal strBrowser As String, _
   ByVal strVariableName As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As ThemeFlavor
Dim strBrowser As String
Dim strVariableName As String
Dim value As String

value = instance.GetVariable(strBrowser, strVariableName)
C#
public string GetVariable(
   string strBrowser,
   string strVariableName
)
Managed Extensions for C++
public: string* GetVariable(
   string* strBrowser,
   string* strVariableName
)
C++/CLI
public:
String^ GetVariable(
   String^ strBrowser,
   String^ strVariableName
)

Parameters

strBrowser
strVariableName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ThemeFlavor Class
ThemeFlavor Members


ThemeFlavor Class Properties

[image]
Gizmox.WebGUI.Common
ThemeFlavor Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ThemeFlavor Class

For a list of all members of this type, see ThemeFlavor members.

Public Properties

 | Name | Description
Public Property | FullName |
Public Property | Name |
Top

See Also

Reference

ThemeFlavor Class
Gizmox.WebGUI.Forms Namespace


FullName Property

[image]
Gizmox.WebGUI.Common
FullName Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ThemeFlavor Class : FullName Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FullName As String
Visual Basic (Usage) Copy Code
Dim instance As ThemeFlavor
Dim value As String

value = instance.FullName
C#
public string FullName {get;}
Managed Extensions for C++
public: __property string* get_FullName();
C++/CLI
public:
property String^ FullName {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ThemeFlavor Class
ThemeFlavor Members


Name Property

[image]
Gizmox.WebGUI.Common
Name Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ThemeFlavor Class : Name Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As ThemeFlavor
Dim value As String

value = instance.Name
C#
public string Name {get;}
Managed Extensions for C++
public: __property string* get_Name();
C++/CLI
public:
property String^ Name {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ThemeFlavor Class
ThemeFlavor Members


ThemeFonts Class

[image]
Gizmox.WebGUI.Common
ThemeFonts Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ThemeFonts Class

Syntax

Visual Basic (Declaration)
Public Class ThemeFonts
Visual Basic (Usage) Copy Code
Dim instance As ThemeFonts
C#
public class ThemeFonts
Managed Extensions for C++
public __gc class ThemeFonts
C++/CLI
public ref class ThemeFonts

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ThemeFonts

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

ThemeFonts Members
Gizmox.WebGUI.Forms Namespace


ThemeFonts Class Members

[image]
Gizmox.WebGUI.Common
ThemeFonts Class Members
See Also Properties Send Feedback
Gizmox.WebGUI.Forms Namespace : ThemeFonts Class

The following tables list the members exposed by ThemeFonts.

Public Constructors

 | Name | Description
Public Constructor | ThemeFonts Constructor |
Top

Public Properties

 | Name | Description
static (Shared in Visual Basic) | CaptionFont |
static (Shared in Visual Basic) | DefaultFont |
static (Shared in Visual Basic) | DialogFont |
static (Shared in Visual Basic) | IconTitleFont |
static (Shared in Visual Basic) | MenuFont |
static (Shared in Visual Basic) | MessageBoxFont |
static (Shared in Visual Basic) | SmallCaptionFont |
static (Shared in Visual Basic) | StatusFont |
Top

See Also

Reference

ThemeFonts Class
Gizmox.WebGUI.Forms Namespace


ThemeFonts Constructor

[image]
Gizmox.WebGUI.Common
ThemeFonts Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ThemeFonts Class : ThemeFonts Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ThemeFonts()
C#
public ThemeFonts()
Managed Extensions for C++
public: ThemeFonts();
C++/CLI
public:
ThemeFonts();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ThemeFonts Class
ThemeFonts Members


ThemeFonts Class Properties

[image]
Gizmox.WebGUI.Common
ThemeFonts Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ThemeFonts Class

For a list of all members of this type, see ThemeFonts members.

Public Properties

 | Name | Description
static (Shared in Visual Basic) | CaptionFont |
static (Shared in Visual Basic) | DefaultFont |
static (Shared in Visual Basic) | DialogFont |
static (Shared in Visual Basic) | IconTitleFont |
static (Shared in Visual Basic) | MenuFont |
static (Shared in Visual Basic) | MessageBoxFont |
static (Shared in Visual Basic) | SmallCaptionFont |
static (Shared in Visual Basic) | StatusFont |
Top

See Also

Reference

ThemeFonts Class
Gizmox.WebGUI.Forms Namespace


CaptionFont Property

[image]
Gizmox.WebGUI.Common
CaptionFont Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ThemeFonts Class : CaptionFont Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property CaptionFont As Font
Visual Basic (Usage) Copy Code
Dim value As Font

value = ThemeFonts.CaptionFont
C#
public static Font CaptionFont {get;}
Managed Extensions for C++
public: __property static Font* get_CaptionFont();
C++/CLI
public:
static property Font^ CaptionFont {
   Font^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ThemeFonts Class
ThemeFonts Members


DefaultFont Property

[image]
Gizmox.WebGUI.Common
DefaultFont Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ThemeFonts Class : DefaultFont Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property DefaultFont As Font
Visual Basic (Usage) Copy Code
Dim value As Font

value = ThemeFonts.DefaultFont
C#
public static Font DefaultFont {get;}
Managed Extensions for C++
public: __property static Font* get_DefaultFont();
C++/CLI
public:
static property Font^ DefaultFont {
   Font^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ThemeFonts Class
ThemeFonts Members


DialogFont Property

[image]
Gizmox.WebGUI.Common
DialogFont Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ThemeFonts Class : DialogFont Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property DialogFont As Font
Visual Basic (Usage) Copy Code
Dim value As Font

value = ThemeFonts.DialogFont
C#
public static Font DialogFont {get;}
Managed Extensions for C++
public: __property static Font* get_DialogFont();
C++/CLI
public:
static property Font^ DialogFont {
   Font^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ThemeFonts Class
ThemeFonts Members


IconTitleFont Property

[image]
Gizmox.WebGUI.Common
IconTitleFont Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ThemeFonts Class : IconTitleFont Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property IconTitleFont As Font
Visual Basic (Usage) Copy Code
Dim value As Font

value = ThemeFonts.IconTitleFont
C#
public static Font IconTitleFont {get;}
Managed Extensions for C++
public: __property static Font* get_IconTitleFont();
C++/CLI
public:
static property Font^ IconTitleFont {
   Font^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ThemeFonts Class
ThemeFonts Members


MenuFont Property

[image]
Gizmox.WebGUI.Common
MenuFont Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ThemeFonts Class : MenuFont Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property MenuFont As Font
Visual Basic (Usage) Copy Code
Dim value As Font

value = ThemeFonts.MenuFont
C#
public static Font MenuFont {get;}
Managed Extensions for C++
public: __property static Font* get_MenuFont();
C++/CLI
public:
static property Font^ MenuFont {
   Font^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ThemeFonts Class
ThemeFonts Members


MessageBoxFont Property

[image]
Gizmox.WebGUI.Common
MessageBoxFont Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ThemeFonts Class : MessageBoxFont Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property MessageBoxFont As Font
Visual Basic (Usage) Copy Code
Dim value As Font

value = ThemeFonts.MessageBoxFont
C#
public static Font MessageBoxFont {get;}
Managed Extensions for C++
public: __property static Font* get_MessageBoxFont();
C++/CLI
public:
static property Font^ MessageBoxFont {
   Font^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ThemeFonts Class
ThemeFonts Members


SmallCaptionFont Property

[image]
Gizmox.WebGUI.Common
SmallCaptionFont Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ThemeFonts Class : SmallCaptionFont Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property SmallCaptionFont As Font
Visual Basic (Usage) Copy Code
Dim value As Font

value = ThemeFonts.SmallCaptionFont
C#
public static Font SmallCaptionFont {get;}
Managed Extensions for C++
public: __property static Font* get_SmallCaptionFont();
C++/CLI
public:
static property Font^ SmallCaptionFont {
   Font^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ThemeFonts Class
ThemeFonts Members


StatusFont Property

[image]
Gizmox.WebGUI.Common
StatusFont Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ThemeFonts Class : StatusFont Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property StatusFont As Font
Visual Basic (Usage) Copy Code
Dim value As Font

value = ThemeFonts.StatusFont
C#
public static Font StatusFont {get;}
Managed Extensions for C++
public: __property static Font* get_StatusFont();
C++/CLI
public:
static property Font^ StatusFont {
   Font^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ThemeFonts Class
ThemeFonts Members


ThreadBookmarkEventArgs Class

[image]
Gizmox.WebGUI.Common
ThreadBookmarkEventArgs Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ThreadBookmarkEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class ThreadBookmarkEventArgs
   Inherits EventArgs
Visual Basic (Usage) Copy Code
Dim instance As ThreadBookmarkEventArgs
C#
public class ThreadBookmarkEventArgs : EventArgs
Managed Extensions for C++
public __gc class ThreadBookmarkEventArgs : public EventArgs
C++/CLI
public ref class ThreadBookmarkEventArgs : public EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gizmox.WebGUI.Forms.ThreadBookmarkEventArgs

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

ThreadBookmarkEventArgs Members
Gizmox.WebGUI.Forms Namespace


ThreadBookmarkEventArgs Class Members

[image]
Gizmox.WebGUI.Common
ThreadBookmarkEventArgs Class Members
See Also Properties Send Feedback
Gizmox.WebGUI.Forms Namespace : ThreadBookmarkEventArgs Class

The following tables list the members exposed by ThreadBookmarkEventArgs.

Public Constructors

 | Name | Description
Public Constructor | ThreadBookmarkEventArgs Constructor |
Top

Public Properties

 | Name | Description
Public Property | Data |
Top

See Also

Reference

ThreadBookmarkEventArgs Class
Gizmox.WebGUI.Forms Namespace


ThreadBookmarkEventArgs Constructor

[image]
Gizmox.WebGUI.Common
ThreadBookmarkEventArgs Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ThreadBookmarkEventArgs Class : ThreadBookmarkEventArgs Constructor

objData

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal objData As Object _
)
Visual Basic (Usage) Copy Code
Dim objData As Object

Dim instance As ThreadBookmarkEventArgs(objData)
C#
public ThreadBookmarkEventArgs(
   object objData
)
Managed Extensions for C++
public: ThreadBookmarkEventArgs(
   Object* objData
)
C++/CLI
public:
ThreadBookmarkEventArgs(
   Object^ objData
)

Parameters

objData

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ThreadBookmarkEventArgs Class
ThreadBookmarkEventArgs Members


ThreadBookmarkEventArgs Class Properties

[image]
Gizmox.WebGUI.Common
ThreadBookmarkEventArgs Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ThreadBookmarkEventArgs Class

For a list of all members of this type, see ThreadBookmarkEventArgs members.

Public Properties

 | Name | Description
Public Property | Data |
Top

See Also

Reference

ThreadBookmarkEventArgs Class
Gizmox.WebGUI.Forms Namespace


Data Property

[image]
Gizmox.WebGUI.Common
Data Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ThreadBookmarkEventArgs Class : Data Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Data As Object
Visual Basic (Usage) Copy Code
Dim instance As ThreadBookmarkEventArgs
Dim value As Object

value = instance.Data
C#
public object Data {get;}
Managed Extensions for C++
public: __property Object* get_Data();
C++/CLI
public:
property Object^ Data {
   Object^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ThreadBookmarkEventArgs Class
ThreadBookmarkEventArgs Members


ThreadExceptionEventArgs Class

[image]
Gizmox.WebGUI.Common
ThreadExceptionEventArgs Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ThreadExceptionEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class ThreadExceptionEventArgs
   Inherits EventArgs
Visual Basic (Usage) Copy Code
Dim instance As ThreadExceptionEventArgs
C#
public class ThreadExceptionEventArgs : EventArgs
Managed Extensions for C++
public __gc class ThreadExceptionEventArgs : public EventArgs
C++/CLI
public ref class ThreadExceptionEventArgs : public EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gizmox.WebGUI.Forms.ThreadExceptionEventArgs

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

ThreadExceptionEventArgs Members
Gizmox.WebGUI.Forms Namespace


ThreadExceptionEventArgs Class Members

[image]
Gizmox.WebGUI.Common
ThreadExceptionEventArgs Class Members
See Also Properties Send Feedback
Gizmox.WebGUI.Forms Namespace : ThreadExceptionEventArgs Class

The following tables list the members exposed by ThreadExceptionEventArgs.

Public Constructors

 | Name | Description
Public Constructor | ThreadExceptionEventArgs Constructor |
Top

Public Properties

 | Name | Description
Public Property | Exception |
Top

See Also

Reference

ThreadExceptionEventArgs Class
Gizmox.WebGUI.Forms Namespace


ThreadExceptionEventArgs Constructor

[image]
Gizmox.WebGUI.Common
ThreadExceptionEventArgs Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ThreadExceptionEventArgs Class : ThreadExceptionEventArgs Constructor

objException

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal objException As Exception _
)
Visual Basic (Usage) Copy Code
Dim objException As Exception

Dim instance As ThreadExceptionEventArgs(objException)
C#
public ThreadExceptionEventArgs(
   Exception objException
)
Managed Extensions for C++
public: ThreadExceptionEventArgs(
   Exception* objException
)
C++/CLI
public:
ThreadExceptionEventArgs(
   Exception^ objException
)

Parameters

objException

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ThreadExceptionEventArgs Class
ThreadExceptionEventArgs Members


ThreadExceptionEventArgs Class Properties

[image]
Gizmox.WebGUI.Common
ThreadExceptionEventArgs Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ThreadExceptionEventArgs Class

For a list of all members of this type, see ThreadExceptionEventArgs members.

Public Properties

 | Name | Description
Public Property | Exception |
Top

See Also

Reference

ThreadExceptionEventArgs Class
Gizmox.WebGUI.Forms Namespace


Exception Property

[image]
Gizmox.WebGUI.Common
Exception Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ThreadExceptionEventArgs Class : Exception Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Exception As Exception
Visual Basic (Usage) Copy Code
Dim instance As ThreadExceptionEventArgs
Dim value As Exception

value = instance.Exception
C#
public Exception Exception {get;}
Managed Extensions for C++
public: __property Exception* get_Exception();
C++/CLI
public:
property Exception^ Exception {
   Exception^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ThreadExceptionEventArgs Class
ThreadExceptionEventArgs Members


ThreadMessage Class

[image]
Gizmox.WebGUI.Common
ThreadMessage Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ThreadMessage Class

Syntax

Visual Basic (Declaration)
<SerializableAttribute()>
Public Class ThreadMessage
Visual Basic (Usage) Copy Code
Dim instance As ThreadMessage
C#
[SerializableAttribute()]
public class ThreadMessage
Managed Extensions for C++
[SerializableAttribute()]
public __gc class ThreadMessage
C++/CLI
[SerializableAttribute()]
public ref class ThreadMessage

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ThreadMessage

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

ThreadMessage Members
Gizmox.WebGUI.Forms Namespace


ThreadMessage Class Members

[image]
Gizmox.WebGUI.Common
ThreadMessage Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : ThreadMessage Class

The following tables list the members exposed by ThreadMessage.

Public Constructors

 | Name | Description
Public Constructor | ThreadMessage Constructor |
Top

Public Properties

 | Name | Description
Public Property | Body |
Public Property | RecipientId |
Public Property | RecipientModule |
Public Property | RecipientType |
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | SendMessageToHost | Overloaded.
Top

See Also

Reference

ThreadMessage Class
Gizmox.WebGUI.Forms Namespace


ThreadMessage Constructor

[image]
Gizmox.WebGUI.Common
ThreadMessage Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ThreadMessage Class : ThreadMessage Constructor

strRecipientId
enmRecipientType
strRecipientModule
objMessageBody

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal strRecipientId As String, _
   ByVal enmRecipientType As ThreadMessageRecipientType, _
   ByVal strRecipientModule As String, _
   ByVal objMessageBody As Object _
)
Visual Basic (Usage) Copy Code
Dim strRecipientId As String
Dim enmRecipientType As ThreadMessageRecipientType
Dim strRecipientModule As String
Dim objMessageBody As Object

Dim instance As ThreadMessage(strRecipientId, enmRecipientType, strRecipientModule, objMessageBody)
C#
public ThreadMessage(
   string strRecipientId,
   ThreadMessageRecipientType enmRecipientType,
   string strRecipientModule,
   object objMessageBody
)
Managed Extensions for C++
public: ThreadMessage(
   string* strRecipientId,
   ThreadMessageRecipientType enmRecipientType,
   string* strRecipientModule,
   Object* objMessageBody
)
C++/CLI
public:
ThreadMessage(
   String^ strRecipientId,
   ThreadMessageRecipientType enmRecipientType,
   String^ strRecipientModule,
   Object^ objMessageBody
)

Parameters

strRecipientId
enmRecipientType
strRecipientModule
objMessageBody

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ThreadMessage Class
ThreadMessage Members


ThreadMessage Class Methods

[image]
Gizmox.WebGUI.Common
ThreadMessage Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ThreadMessage Class

For a list of all members of this type, see ThreadMessage members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | SendMessageToHost | Overloaded.
Top

See Also

Reference

ThreadMessage Class
Gizmox.WebGUI.Forms Namespace


SendMessageToHost Method

[image]
Gizmox.WebGUI.Common
SendMessageToHost Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ThreadMessage Class : SendMessageToHost Method

Overload List

Overload | Description
SendMessageToHost(Object) |
SendMessageToHost(String,Object) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ThreadMessage Class
ThreadMessage Members


SendMessageToHost(Object) Method

[image]
Gizmox.WebGUI.Common
SendMessageToHost(Object) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ThreadMessage Class > SendMessageToHost Method : SendMessageToHost(Object) Method

objMessageBody

Syntax

Visual Basic (Declaration)
Public Overloads Shared Sub SendMessageToHost( _
   ByVal objMessageBody As Object _
)
Visual Basic (Usage) Copy Code
Dim objMessageBody As Object

ThreadMessage.SendMessageToHost(objMessageBody)
C#
public static void SendMessageToHost(
   object objMessageBody
)
Managed Extensions for C++
public: static void SendMessageToHost(
   Object* objMessageBody
)
C++/CLI
public:
static void SendMessageToHost(
   Object^ objMessageBody
)

Parameters

objMessageBody

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ThreadMessage Class
ThreadMessage Members
Overload List


SendMessageToHost(String,Object) Method

[image]
Gizmox.WebGUI.Common
SendMessageToHost(String,Object) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ThreadMessage Class > SendMessageToHost Method : SendMessageToHost(String,Object) Method

strModule
objMessageBody

Syntax

Visual Basic (Declaration)
Public Overloads Shared Sub SendMessageToHost( _
   ByVal strModule As String, _
   ByVal objMessageBody As Object _
)
Visual Basic (Usage) Copy Code
Dim strModule As String
Dim objMessageBody As Object

ThreadMessage.SendMessageToHost(strModule, objMessageBody)
C#
public static void SendMessageToHost(
   string strModule,
   object objMessageBody
)
Managed Extensions for C++
public: static void SendMessageToHost(
   string* strModule,
   Object* objMessageBody
)
C++/CLI
public:
static void SendMessageToHost(
   String^ strModule,
   Object^ objMessageBody
)

Parameters

strModule
objMessageBody

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ThreadMessage Class
ThreadMessage Members
Overload List


ThreadMessage Class Properties

[image]
Gizmox.WebGUI.Common
ThreadMessage Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ThreadMessage Class

For a list of all members of this type, see ThreadMessage members.

Public Properties

 | Name | Description
Public Property | Body |
Public Property | RecipientId |
Public Property | RecipientModule |
Public Property | RecipientType |
Top

See Also

Reference

ThreadMessage Class
Gizmox.WebGUI.Forms Namespace


Body Property

[image]
Gizmox.WebGUI.Common
Body Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ThreadMessage Class : Body Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Body As Object
Visual Basic (Usage) Copy Code
Dim instance As ThreadMessage
Dim value As Object

value = instance.Body
C#
public object Body {get;}
Managed Extensions for C++
public: __property Object* get_Body();
C++/CLI
public:
property Object^ Body {
   Object^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ThreadMessage Class
ThreadMessage Members


RecipientId Property

[image]
Gizmox.WebGUI.Common
RecipientId Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ThreadMessage Class : RecipientId Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RecipientId As String
Visual Basic (Usage) Copy Code
Dim instance As ThreadMessage
Dim value As String

value = instance.RecipientId
C#
public string RecipientId {get;}
Managed Extensions for C++
public: __property string* get_RecipientId();
C++/CLI
public:
property String^ RecipientId {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ThreadMessage Class
ThreadMessage Members


RecipientModule Property

[image]
Gizmox.WebGUI.Common
RecipientModule Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ThreadMessage Class : RecipientModule Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RecipientModule As String
Visual Basic (Usage) Copy Code
Dim instance As ThreadMessage
Dim value As String

value = instance.RecipientModule
C#
public string RecipientModule {get;}
Managed Extensions for C++
public: __property string* get_RecipientModule();
C++/CLI
public:
property String^ RecipientModule {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ThreadMessage Class
ThreadMessage Members


RecipientType Property

[image]
Gizmox.WebGUI.Common
RecipientType Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ThreadMessage Class : RecipientType Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RecipientType As ThreadMessageRecipientType
Visual Basic (Usage) Copy Code
Dim instance As ThreadMessage
Dim value As ThreadMessageRecipientType

value = instance.RecipientType
C#
public ThreadMessageRecipientType RecipientType {get;}
Managed Extensions for C++
public: __property ThreadMessageRecipientType get_RecipientType();
C++/CLI
public:
property ThreadMessageRecipientType RecipientType {
   ThreadMessageRecipientType get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ThreadMessage Class
ThreadMessage Members


ThreadMessageEventArgs Class

[image]
Gizmox.WebGUI.Common
ThreadMessageEventArgs Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ThreadMessageEventArgs Class

Object Model

Syntax

Visual Basic (Declaration)
Public Class ThreadMessageEventArgs
   Inherits EventArgs
Visual Basic (Usage) Copy Code
Dim instance As ThreadMessageEventArgs
C#
public class ThreadMessageEventArgs : EventArgs
Managed Extensions for C++
public __gc class ThreadMessageEventArgs : public EventArgs
C++/CLI
public ref class ThreadMessageEventArgs : public EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gizmox.WebGUI.Forms.ThreadMessageEventArgs

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

ThreadMessageEventArgs Members
Gizmox.WebGUI.Forms Namespace


ThreadMessageEventArgs Class Members

[image]
Gizmox.WebGUI.Common
ThreadMessageEventArgs Class Members
See Also Properties Send Feedback
Gizmox.WebGUI.Forms Namespace : ThreadMessageEventArgs Class

The following tables list the members exposed by ThreadMessageEventArgs.

Public Constructors

 | Name | Description
Public Constructor | ThreadMessageEventArgs Constructor |
Top

Public Properties

 | Name | Description
Public Property | Message |
Top

See Also

Reference

ThreadMessageEventArgs Class
Gizmox.WebGUI.Forms Namespace


ThreadMessageEventArgs Constructor

[image]
Gizmox.WebGUI.Common
ThreadMessageEventArgs Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ThreadMessageEventArgs Class : ThreadMessageEventArgs Constructor

objThreadMessage

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal objThreadMessage As ThreadMessage _
)
Visual Basic (Usage) Copy Code
Dim objThreadMessage As ThreadMessage

Dim instance As ThreadMessageEventArgs(objThreadMessage)
C#
public ThreadMessageEventArgs(
   ThreadMessage objThreadMessage
)
Managed Extensions for C++
public: ThreadMessageEventArgs(
   ThreadMessage* objThreadMessage
)
C++/CLI
public:
ThreadMessageEventArgs(
   ThreadMessage^ objThreadMessage
)

Parameters

objThreadMessage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ThreadMessageEventArgs Class
ThreadMessageEventArgs Members


ThreadMessageEventArgs Class Properties

[image]
Gizmox.WebGUI.Common
ThreadMessageEventArgs Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ThreadMessageEventArgs Class

For a list of all members of this type, see ThreadMessageEventArgs members.

Public Properties

 | Name | Description
Public Property | Message |
Top

See Also

Reference

ThreadMessageEventArgs Class
Gizmox.WebGUI.Forms Namespace


Message Property

[image]
Gizmox.WebGUI.Common
Message Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ThreadMessageEventArgs Class : Message Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Message As ThreadMessage
Visual Basic (Usage) Copy Code
Dim instance As ThreadMessageEventArgs
Dim value As ThreadMessage

value = instance.Message
C#
public ThreadMessage Message {get;}
Managed Extensions for C++
public: __property ThreadMessage* get_Message();
C++/CLI
public:
property ThreadMessage^ Message {
   ThreadMessage^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ThreadMessageEventArgs Class
ThreadMessageEventArgs Members


VWGContext Class

[image]
Gizmox.WebGUI.Common
VWGContext Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : VWGContext Class

Object Model

Syntax

Visual Basic (Declaration)
Public Class VWGContext
Visual Basic (Usage) Copy Code
Dim instance As VWGContext
C#
public class VWGContext
Managed Extensions for C++
public __gc class VWGContext
C++/CLI
public ref class VWGContext

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.VWGContext

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

VWGContext Members
Gizmox.WebGUI.Forms Namespace


VWGContext Class Members

[image]
Gizmox.WebGUI.Common
VWGContext Class Members
See Also Properties Send Feedback
Gizmox.WebGUI.Forms Namespace : VWGContext Class

The following tables list the members exposed by VWGContext.

Public Constructors

 | Name | Description
Public Constructor | VWGContext Constructor |
Top

Public Properties

 | Name | Description
static (Shared in Visual Basic) | Current |
Top

See Also

Reference

VWGContext Class
Gizmox.WebGUI.Forms Namespace


VWGContext Constructor

[image]
Gizmox.WebGUI.Common
VWGContext Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > VWGContext Class : VWGContext Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As VWGContext()
C#
public VWGContext()
Managed Extensions for C++
public: VWGContext();
C++/CLI
public:
VWGContext();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

VWGContext Class
VWGContext Members


VWGContext Class Properties

[image]
Gizmox.WebGUI.Common
VWGContext Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : VWGContext Class

For a list of all members of this type, see VWGContext members.

Public Properties

 | Name | Description
static (Shared in Visual Basic) | Current |
Top

See Also

Reference

VWGContext Class
Gizmox.WebGUI.Forms Namespace


Current Property

[image]
Gizmox.WebGUI.Common
Current Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > VWGContext Class : Current Property

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Current As IContext
Visual Basic (Usage) Copy Code
Dim value As IContext

value = VWGContext.Current
C#
public static IContext Current {get;}
Managed Extensions for C++
public: __property static IContext* get_Current();
C++/CLI
public:
static property IContext^ Current {
   IContext^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

VWGContext Class
VWGContext Members


AttributeType Enumeration

[image]
Gizmox.WebGUI.Common
AttributeType Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : AttributeType Enumeration

Syntax

Visual Basic (Declaration)
Public Enum AttributeType
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As AttributeType
C#
public enum AttributeType : Enum
Managed Extensions for C++
__value public enum AttributeType : public Enum
C++/CLI
public enum class AttributeType : public Enum

Members

Member | Description
None |
Redraw |
Layout |
Visual |
Control |
ToolTip |
Drag |
Error |
Enabled |
Extended |
All |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.AttributeType

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


CheckState Enumeration

[image]
Gizmox.WebGUI.Common
CheckState Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : CheckState Enumeration

Syntax

Visual Basic (Declaration)
Public Enum CheckState
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As CheckState
C#
public enum CheckState : Enum
Managed Extensions for C++
__value public enum CheckState : public Enum
C++/CLI
public enum class CheckState : public Enum

Members

Member | Description
Checked |
Indeterminate |
Unchecked |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.CheckState

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


DialogResult Enumeration

[image]
Gizmox.WebGUI.Common
DialogResult Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DialogResult Enumeration

Syntax

Visual Basic (Declaration)
Public Enum DialogResult
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As DialogResult
C#
public enum DialogResult : Enum
Managed Extensions for C++
__value public enum DialogResult : public Enum
C++/CLI
public enum class DialogResult : public Enum

Members

Member | Description
Abort |
Cancel |
Ignore |
No |
None |
OK |
Retry |
Yes |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.DialogResult

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


EventTypes Enumeration

[image]
Gizmox.WebGUI.Common
EventTypes Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : EventTypes Enumeration

Syntax

Visual Basic (Declaration)
Public Enum EventTypes
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As EventTypes
C#
public enum EventTypes : Enum
Managed Extensions for C++
__value public enum EventTypes : public Enum
C++/CLI
public enum class EventTypes : public Enum

Members

Member | Description
None |
Click |
DoubleClick |
KeyDown |
ValueChange |
GotFocus |
LostFocus |
CheckedChange |
SizeChange |
EnterKeyDown |
LocationChange |
Expand |
Collapse |
SelectionChange |
ContentClick |
ContentDoubleClick |
RowHeaderMouseClick |
CellBeginEdit |
CellEndEdit |
DragDrop |
RowHeaderMouseDoubleClick |
AfterLabelEdit |
CellEnter |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.EventTypes

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


ExecutionMode Enumeration

[image]
Gizmox.WebGUI.Common
ExecutionMode Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ExecutionMode Enumeration

Syntax

Visual Basic (Declaration)
Public Enum ExecutionMode
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As ExecutionMode
C#
public enum ExecutionMode : Enum
Managed Extensions for C++
__value public enum ExecutionMode : public Enum
C++/CLI
public enum class ExecutionMode : public Enum

Members

Member | Description
Client |
Web |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.ExecutionMode

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


KeyFilter Enumeration

[image]
Gizmox.WebGUI.Common
KeyFilter Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : KeyFilter Enumeration

Syntax

Visual Basic (Declaration)
Public Enum KeyFilter
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As KeyFilter
C#
public enum KeyFilter : Enum
Managed Extensions for C++
__value public enum KeyFilter : public Enum
C++/CLI
public enum class KeyFilter : public Enum

Members

Member | Description
All |
Alt |
Control |
Delete |
Down |
End |
Escape |
F1 |
F2 |
F3 |
F4 |
F5 |
F6 |
F7 |
F8 |
F9 |
F10 |
F11 |
F12 |
Home |
Insert |
Left |
PageDown |
PageUp |
Right |
Shift |
Up |
Enter |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.KeyFilter

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


Keys Enumeration

[image]
Gizmox.WebGUI.Common
Keys Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : Keys Enumeration

Syntax

Visual Basic (Declaration)
Public Enum Keys
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As Keys
C#
public enum Keys : Enum
Managed Extensions for C++
__value public enum Keys : public Enum
C++/CLI
public enum class Keys : public Enum

Members

Member | Description
A |
Add |
Alt |
Apps |
Attn |
B |
Back |
BrowserBack |
BrowserFavorites |
BrowserForward |
BrowserHome |
BrowserRefresh |
BrowserSearch |
BrowserStop |
C |
Cancel |
Capital |
CapsLock |
Clear |
Control |
ControlKey |
Crsel |
D |
D0 |
D1 |
D2 |
D3 |
D4 |
D5 |
D6 |
D7 |
D8 |
D9 |
Decimal |
Delete |
Divide |
Down |
E |
End |
Enter |
EraseEof |
Escape |
Execute |
Exsel |
F |
F1 |
F10 |
F11 |
F12 |
F13 |
F14 |
F15 |
F16 |
F17 |
F18 |
F19 |
F2 |
F20 |
F21 |
F22 |
F23 |
F24 |
F3 |
F4 |
F5 |
F6 |
F7 |
F8 |
F9 |
FinalMode |
G |
H |
HanguelMode |
HangulMode |
HanjaMode |
Help |
Home |
I |
IMEAceept |
IMEConvert |
IMEModeChange |
IMENonconvert |
Insert |
J |
JunjaMode |
K |
KanaMode |
KanjiMode |
KeyCode |
L |
LaunchApplication1 |
LaunchApplication2 |
LaunchMail |
LButton |
LControlKey |
Left |
LineFeed |
LMenu |
LShiftKey |
LWin |
M |
MButton |
MediaNextTrack |
MediaPlayPause |
MediaPreviousTrack |
MediaStop |
Menu |
Modifiers |
Multiply |
N |
Next |
NoName |
None |
NumLock |
NumPad0 |
NumPad1 |
NumPad2 |
NumPad3 |
NumPad4 |
NumPad5 |
NumPad6 |
NumPad7 |
NumPad8 |
NumPad9 |
O |
Oem8 |
OemBackslash |
OemClear |
OemCloseBrackets |
Oemcomma |
OemMinus |
OemOpenBrackets |
OemPeriod |
OemPipe |
Oemplus |
OemQuestion |
OemQuotes |
OemSemicolon |
Oemtilde |
P |
Pa1 |
PageDown |
PageUp |
Pause |
Play |
Print |
PrintScreen |
Prior |
ProcessKey |
Q |
R |
RButton |
RControlKey |
Return |
Right |
RMenu |
RShiftKey |
RWin |
S |
Scroll |
Select |
SelectMedia |
Separator |
Shift |
ShiftKey |
Snapshot |
Space |
Subtract |
T |
Tab |
U |
Up |
V |
VolumeDown |
VolumeMute |
VolumeUp |
W |
X |
XButton1 |
XButton2 |
Y |
Z |
Zoom |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.Keys

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


LinkWindowStyle Enumeration

[image]
Gizmox.WebGUI.Common
LinkWindowStyle Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : LinkWindowStyle Enumeration

Syntax

Visual Basic (Declaration)
Public Enum LinkWindowStyle
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As LinkWindowStyle
C#
public enum LinkWindowStyle : Enum
Managed Extensions for C++
__value public enum LinkWindowStyle : public Enum
C++/CLI
public enum class LinkWindowStyle : public Enum

Members

Member | Description
Normal |
ModalWindow |
ModelessWindow |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.LinkWindowStyle

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


MouseButtons Enumeration

[image]
Gizmox.WebGUI.Common
MouseButtons Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : MouseButtons Enumeration

Syntax

Visual Basic (Declaration)
Public Enum MouseButtons
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As MouseButtons
C#
public enum MouseButtons : Enum
Managed Extensions for C++
__value public enum MouseButtons : public Enum
C++/CLI
public enum class MouseButtons : public Enum

Members

Member | Description
Left |
Middle |
None |
Right |
XButton1 |
XButton2 |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.MouseButtons

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


ThreadMessageRecipientType Enumeration

[image]
Gizmox.WebGUI.Common
ThreadMessageRecipientType Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ThreadMessageRecipientType Enumeration

Syntax

Visual Basic (Declaration)
Public Enum ThreadMessageRecipientType
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As ThreadMessageRecipientType
C#
public enum ThreadMessageRecipientType : Enum
Managed Extensions for C++
__value public enum ThreadMessageRecipientType : public Enum
C++/CLI
public enum class ThreadMessageRecipientType : public Enum

Members

Member | Description
Host |
Applicatoin |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.ThreadMessageRecipientType

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


UnhandledExceptionMode Enumeration

[image]
Gizmox.WebGUI.Common
UnhandledExceptionMode Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : UnhandledExceptionMode Enumeration

Syntax

Visual Basic (Declaration)
Public Enum UnhandledExceptionMode
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As UnhandledExceptionMode
C#
public enum UnhandledExceptionMode : Enum
Managed Extensions for C++
__value public enum UnhandledExceptionMode : public Enum
C++/CLI
public enum class UnhandledExceptionMode : public Enum

Members

Member | Description
Automatic |
ThrowException |
CatchException |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.UnhandledExceptionMode

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


IDataObject Interface

[image]
Gizmox.WebGUI.Common
IDataObject Interface
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : IDataObject Interface

Syntax

Visual Basic (Declaration)
<ComVisibleAttribute(True)>
Public Interface IDataObject
Visual Basic (Usage) Copy Code
Dim instance As IDataObject
C#
[ComVisibleAttribute(true)]
public interface IDataObject
Managed Extensions for C++
[ComVisibleAttribute(true)]
public __gc __interface IDataObject
C++/CLI
[ComVisibleAttribute(true)]
public interface class IDataObject

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

IDataObject Members
Gizmox.WebGUI.Forms Namespace


IDataObject Interface Members

[image]
Gizmox.WebGUI.Common
IDataObject Interface Members
See Also Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : IDataObject Interface

The following tables list the members exposed by IDataObject.

Public Methods

 | Name | Description
Method | GetData | Overloaded.
Method | GetDataPresent | Overloaded.
Method | GetFormats | Overloaded.
Method | SetData | Overloaded.
Top

See Also

Reference

IDataObject Interface
Gizmox.WebGUI.Forms Namespace


IDataObject Interface Methods

[image]
Gizmox.WebGUI.Common
IDataObject Interface Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : IDataObject Interface

For a list of all members of this type, see IDataObject members.

Public Methods

 | Name | Description
Method | GetData | Overloaded.
Method | GetDataPresent | Overloaded.
Method | GetFormats | Overloaded.
Method | SetData | Overloaded.
Top

See Also

Reference

IDataObject Interface
Gizmox.WebGUI.Forms Namespace


GetData Method

[image]
Gizmox.WebGUI.Common
GetData Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > IDataObject Interface : GetData Method

Overload List

Overload | Description
GetData(String) |
GetData(Type) |
GetData(String,Boolean) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IDataObject Interface
IDataObject Members


GetData(String) Method

[image]
Gizmox.WebGUI.Common
GetData(String) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > IDataObject Interface > GetData Method : GetData(String) Method

format

Syntax

Visual Basic (Declaration)
Overloads Function GetData( _
   ByVal format As String _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As IDataObject
Dim format As String
Dim value As Object

value = instance.GetData(format)
C#
object GetData(
   string format
)
Managed Extensions for C++
Object* GetData(
   string* format
)
C++/CLI
Object^ GetData(
   String^ format
)

Parameters

format

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IDataObject Interface
IDataObject Members
Overload List


GetData(Type) Method

[image]
Gizmox.WebGUI.Common
GetData(Type) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > IDataObject Interface > GetData Method : GetData(Type) Method

format

Syntax

Visual Basic (Declaration)
Overloads Function GetData( _
   ByVal format As Type _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As IDataObject
Dim format As Type
Dim value As Object

value = instance.GetData(format)
C#
object GetData(
   Type format
)
Managed Extensions for C++
Object* GetData(
   Type* format
)
C++/CLI
Object^ GetData(
   Type^ format
)

Parameters

format

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IDataObject Interface
IDataObject Members
Overload List


GetData(String,Boolean) Method

[image]
Gizmox.WebGUI.Common
GetData(String,Boolean) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > IDataObject Interface > GetData Method : GetData(String,Boolean) Method

format
autoConvert

Syntax

Visual Basic (Declaration)
Overloads Function GetData( _
   ByVal format As String, _
   ByVal autoConvert As Boolean _
) As Object
Visual Basic (Usage) Copy Code
Dim instance As IDataObject
Dim format As String
Dim autoConvert As Boolean
Dim value As Object

value = instance.GetData(format, autoConvert)
C#
object GetData(
   string format,
   bool autoConvert
)
Managed Extensions for C++
Object* GetData(
   string* format,
   bool autoConvert
)
C++/CLI
Object^ GetData(
   String^ format,
   bool autoConvert
)

Parameters

format
autoConvert

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IDataObject Interface
IDataObject Members
Overload List


GetDataPresent Method

[image]
Gizmox.WebGUI.Common
GetDataPresent Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > IDataObject Interface : GetDataPresent Method

Overload List

Overload | Description
GetDataPresent(String) |
GetDataPresent(Type) |
GetDataPresent(String,Boolean) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IDataObject Interface
IDataObject Members


GetDataPresent(String) Method

[image]
Gizmox.WebGUI.Common
GetDataPresent(String) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > IDataObject Interface > GetDataPresent Method : GetDataPresent(String) Method

format

Syntax

Visual Basic (Declaration)
Overloads Function GetDataPresent( _
   ByVal format As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As IDataObject
Dim format As String
Dim value As Boolean

value = instance.GetDataPresent(format)
C#
bool GetDataPresent(
   string format
)
Managed Extensions for C++
bool GetDataPresent(
   string* format
)
C++/CLI
bool GetDataPresent(
   String^ format
)

Parameters

format

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IDataObject Interface
IDataObject Members
Overload List


GetDataPresent(Type) Method

[image]
Gizmox.WebGUI.Common
GetDataPresent(Type) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > IDataObject Interface > GetDataPresent Method : GetDataPresent(Type) Method

format

Syntax

Visual Basic (Declaration)
Overloads Function GetDataPresent( _
   ByVal format As Type _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As IDataObject
Dim format As Type
Dim value As Boolean

value = instance.GetDataPresent(format)
C#
bool GetDataPresent(
   Type format
)
Managed Extensions for C++
bool GetDataPresent(
   Type* format
)
C++/CLI
bool GetDataPresent(
   Type^ format
)

Parameters

format

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IDataObject Interface
IDataObject Members
Overload List


GetDataPresent(String,Boolean) Method

[image]
Gizmox.WebGUI.Common
GetDataPresent(String,Boolean) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > IDataObject Interface > GetDataPresent Method : GetDataPresent(String,Boolean) Method

format
autoConvert

Syntax

Visual Basic (Declaration)
Overloads Function GetDataPresent( _
   ByVal format As String, _
   ByVal autoConvert As Boolean _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As IDataObject
Dim format As String
Dim autoConvert As Boolean
Dim value As Boolean

value = instance.GetDataPresent(format, autoConvert)
C#
bool GetDataPresent(
   string format,
   bool autoConvert
)
Managed Extensions for C++
bool GetDataPresent(
   string* format,
   bool autoConvert
)
C++/CLI
bool GetDataPresent(
   String^ format,
   bool autoConvert
)

Parameters

format
autoConvert

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IDataObject Interface
IDataObject Members
Overload List


GetFormats Method

[image]
Gizmox.WebGUI.Common
GetFormats Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > IDataObject Interface : GetFormats Method

Overload List

Overload | Description
GetFormats() |
GetFormats(Boolean) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IDataObject Interface
IDataObject Members


GetFormats() Method

[image]
Gizmox.WebGUI.Common
GetFormats() Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > IDataObject Interface > GetFormats Method : GetFormats() Method

Syntax

Visual Basic (Declaration)
Overloads Function GetFormats() As String()
Visual Basic (Usage) Copy Code
Dim instance As IDataObject
Dim value() As String

value = instance.GetFormats()
C#
string[] GetFormats()
Managed Extensions for C++
string*[]* GetFormats();
C++/CLI
array<String^>^ GetFormats();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IDataObject Interface
IDataObject Members
Overload List


GetFormats(Boolean) Method

[image]
Gizmox.WebGUI.Common
GetFormats(Boolean) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > IDataObject Interface > GetFormats Method : GetFormats(Boolean) Method

autoConvert

Syntax

Visual Basic (Declaration)
Overloads Function GetFormats( _
   ByVal autoConvert As Boolean _
) As String()
Visual Basic (Usage) Copy Code
Dim instance As IDataObject
Dim autoConvert As Boolean
Dim value() As String

value = instance.GetFormats(autoConvert)
C#
string[] GetFormats(
   bool autoConvert
)
Managed Extensions for C++
string*[]* GetFormats(
   bool autoConvert
)
C++/CLI
array<String^>^ GetFormats(
   bool autoConvert
)

Parameters

autoConvert

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IDataObject Interface
IDataObject Members
Overload List


SetData Method

[image]
Gizmox.WebGUI.Common
SetData Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > IDataObject Interface : SetData Method

Overload List

Overload | Description
SetData(Object) |
SetData(String,Object) |
SetData(Type,Object) |
SetData(String,Boolean,Object) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IDataObject Interface
IDataObject Members


SetData(Object) Method

[image]
Gizmox.WebGUI.Common
SetData(Object) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > IDataObject Interface > SetData Method : SetData(Object) Method

data

Syntax

Visual Basic (Declaration)
Overloads Sub SetData( _
   ByVal data As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As IDataObject
Dim data As Object

instance.SetData(data)
C#
void SetData(
   object data
)
Managed Extensions for C++
void SetData(
   Object* data
)
C++/CLI
void SetData(
   Object^ data
)

Parameters

data

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IDataObject Interface
IDataObject Members
Overload List


SetData(String,Object) Method

[image]
Gizmox.WebGUI.Common
SetData(String,Object) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > IDataObject Interface > SetData Method : SetData(String,Object) Method

format
data

Syntax

Visual Basic (Declaration)
Overloads Sub SetData( _
   ByVal format As String, _
   ByVal data As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As IDataObject
Dim format As String
Dim data As Object

instance.SetData(format, data)
C#
void SetData(
   string format,
   object data
)
Managed Extensions for C++
void SetData(
   string* format,
   Object* data
)
C++/CLI
void SetData(
   String^ format,
   Object^ data
)

Parameters

format
data

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IDataObject Interface
IDataObject Members
Overload List


SetData(Type,Object) Method

[image]
Gizmox.WebGUI.Common
SetData(Type,Object) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > IDataObject Interface > SetData Method : SetData(Type,Object) Method

format
data

Syntax

Visual Basic (Declaration)
Overloads Sub SetData( _
   ByVal format As Type, _
   ByVal data As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As IDataObject
Dim format As Type
Dim data As Object

instance.SetData(format, data)
C#
void SetData(
   Type format,
   object data
)
Managed Extensions for C++
void SetData(
   Type* format,
   Object* data
)
C++/CLI
void SetData(
   Type^ format,
   Object^ data
)

Parameters

format
data

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IDataObject Interface
IDataObject Members
Overload List


SetData(String,Boolean,Object) Method

[image]
Gizmox.WebGUI.Common
SetData(String,Boolean,Object) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > IDataObject Interface > SetData Method : SetData(String,Boolean,Object) Method

format
autoConvert
data

Syntax

Visual Basic (Declaration)
Overloads Sub SetData( _
   ByVal format As String, _
   ByVal autoConvert As Boolean, _
   ByVal data As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As IDataObject
Dim format As String
Dim autoConvert As Boolean
Dim data As Object

instance.SetData(format, autoConvert, data)
C#
void SetData(
   string format,
   bool autoConvert,
   object data
)
Managed Extensions for C++
void SetData(
   string* format,
   bool autoConvert,
   Object* data
)
C++/CLI
void SetData(
   String^ format,
   bool autoConvert,
   Object^ data
)

Parameters

format
autoConvert
data

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IDataObject Interface
IDataObject Members
Overload List


IFilteredCompoenent Interface

[image]
Gizmox.WebGUI.Common
IFilteredCompoenent Interface
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : IFilteredCompoenent Interface

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Interface IFilteredCompoenent
Visual Basic (Usage) Copy Code
Dim instance As IFilteredCompoenent
C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public interface IFilteredCompoenent
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public __gc __interface IFilteredCompoenent
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public interface class IFilteredCompoenent

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

IFilteredCompoenent Members
Gizmox.WebGUI.Forms Namespace


IFilteredCompoenent Interface Members

[image]
Gizmox.WebGUI.Common
IFilteredCompoenent Interface Members
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : IFilteredCompoenent Interface

The following tables list the members exposed by IFilteredCompoenent.

See Also

Reference

IFilteredCompoenent Interface
Gizmox.WebGUI.Forms Namespace


ThreadBookmarkEventHandler Delegate

[image]
Gizmox.WebGUI.Common
ThreadBookmarkEventHandler Delegate
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ThreadBookmarkEventHandler Delegate

sender
e

Syntax

Visual Basic (Declaration)
Public Delegate Sub ThreadBookmarkEventHandler( _
   ByVal sender As Object, _
   ByVal e As ThreadBookmarkEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New ThreadBookmarkEventHandler(AddressOf HandlerMethod)
C#
public delegate void ThreadBookmarkEventHandler(
   object sender,
   ThreadBookmarkEventArgs e
)
Managed Extensions for C++
public: __gc __delegate void ThreadBookmarkEventHandler(
   Object* sender,
   ThreadBookmarkEventArgs* e
)
C++/CLI
public delegate void ThreadBookmarkEventHandler(
   Object^ sender,
   ThreadBookmarkEventArgs^ e
)

Parameters

sender
e

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


ThreadExceptionEventHandler Delegate

[image]
Gizmox.WebGUI.Common
ThreadExceptionEventHandler Delegate
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ThreadExceptionEventHandler Delegate

sender
e

Syntax

Visual Basic (Declaration)
Public Delegate Sub ThreadExceptionEventHandler( _
   ByVal sender As Object, _
   ByVal e As ThreadExceptionEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New ThreadExceptionEventHandler(AddressOf HandlerMethod)
C#
public delegate void ThreadExceptionEventHandler(
   object sender,
   ThreadExceptionEventArgs e
)
Managed Extensions for C++
public: __gc __delegate void ThreadExceptionEventHandler(
   Object* sender,
   ThreadExceptionEventArgs* e
)
C++/CLI
public delegate void ThreadExceptionEventHandler(
   Object^ sender,
   ThreadExceptionEventArgs^ e
)

Parameters

sender
e

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


ThreadMessageEventHandler Delegate

[image]
Gizmox.WebGUI.Common
ThreadMessageEventHandler Delegate
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ThreadMessageEventHandler Delegate

sender
e

Syntax

Visual Basic (Declaration)
Public Delegate Sub ThreadMessageEventHandler( _
   ByVal sender As Object, _
   ByVal e As ThreadMessageEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New ThreadMessageEventHandler(AddressOf HandlerMethod)
C#
public delegate void ThreadMessageEventHandler(
   object sender,
   ThreadMessageEventArgs e
)
Managed Extensions for C++
public: __gc __delegate void ThreadMessageEventHandler(
   Object* sender,
   ThreadMessageEventArgs* e
)
C++/CLI
public delegate void ThreadMessageEventHandler(
   Object^ sender,
   ThreadMessageEventArgs^ e
)

Parameters

sender
e

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


Gizmox.WebGUI.Forms.Design Namespace (Gizmox.WebGUI.Common)

Gizmox.WebGUI.Common
Gizmox.WebGUI.Forms.Design Namespace (Gizmox.WebGUI.Common)
See Also Inheritance Hierarchy Send Feedback

Classes

 | Class | Description
Class | DesignTimeControllerAttribute |
Class | ToolboxItemCategoryAttribute |

See Also

Reference

Gizmox.WebGUI.Common Assembly


DesignTimeControllerAttribute Class

[image]
Gizmox.WebGUI.Common
DesignTimeControllerAttribute Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace : DesignTimeControllerAttribute Class

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AllowMultiple=False, Inherited=True)>
Public Class DesignTimeControllerAttribute
   Inherits Attribute
Visual Basic (Usage) Copy Code
Dim instance As DesignTimeControllerAttribute
C#
[AttributeUsageAttribute(AllowMultiple=false, Inherited=true)]
public class DesignTimeControllerAttribute : Attribute
Managed Extensions for C++
[AttributeUsageAttribute(AllowMultiple=false, Inherited=true)]
public __gc class DesignTimeControllerAttribute : public Attribute
C++/CLI
[AttributeUsageAttribute(AllowMultiple=false, Inherited=true)]
public ref class DesignTimeControllerAttribute : public Attribute

Inheritance Hierarchy

System.Object
System.Attribute
Gizmox.WebGUI.Forms.Design.DesignTimeControllerAttribute

Requirements

Namespace: Gizmox.WebGUI.Forms.Design

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

DesignTimeControllerAttribute Members
Gizmox.WebGUI.Forms.Design Namespace


DesignTimeControllerAttribute Class Members

[image]
Gizmox.WebGUI.Common
DesignTimeControllerAttribute Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms.Design Namespace : DesignTimeControllerAttribute Class

The following tables list the members exposed by DesignTimeControllerAttribute.

Public Constructors

 | Name | Description
Public Constructor | DesignTimeControllerAttribute Constructor |
Top

Public Properties

 | Name | Description
Public Property | Type |
Public Property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from System.Attribute)
Top

Public Methods

 | Name | Description
Public Method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from System.Attribute)
Public Method | GetHashCode | Returns the hash code for this instance. (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from System.Attribute)
Public Method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from System.Attribute)
Top

See Also

Reference

DesignTimeControllerAttribute Class
Gizmox.WebGUI.Forms.Design Namespace


DesignTimeControllerAttribute Constructor

[image]
Gizmox.WebGUI.Common
DesignTimeControllerAttribute Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > DesignTimeControllerAttribute Class : DesignTimeControllerAttribute Constructor

strTypeName

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal strTypeName As String _
)
Visual Basic (Usage) Copy Code
Dim strTypeName As String

Dim instance As DesignTimeControllerAttribute(strTypeName)
C#
public DesignTimeControllerAttribute(
   string strTypeName
)
Managed Extensions for C++
public: DesignTimeControllerAttribute(
   string* strTypeName
)
C++/CLI
public:
DesignTimeControllerAttribute(
   String^ strTypeName
)

Parameters

strTypeName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DesignTimeControllerAttribute Class
DesignTimeControllerAttribute Members


DesignTimeControllerAttribute Class Properties

[image]
Gizmox.WebGUI.Common
DesignTimeControllerAttribute Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace : DesignTimeControllerAttribute Class

For a list of all members of this type, see DesignTimeControllerAttribute members.

Public Properties

 | Name | Description
Public Property | Type |
Public Property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from System.Attribute)
Top

See Also

Reference

DesignTimeControllerAttribute Class
Gizmox.WebGUI.Forms.Design Namespace


Type Property

[image]
Gizmox.WebGUI.Common
Type Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > DesignTimeControllerAttribute Class : Type Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Type As Type
Visual Basic (Usage) Copy Code
Dim instance As DesignTimeControllerAttribute
Dim value As Type

value = instance.Type
C#
public Type Type {get;}
Managed Extensions for C++
public: __property Type* get_Type();
C++/CLI
public:
property Type^ Type {
   Type^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DesignTimeControllerAttribute Class
DesignTimeControllerAttribute Members


ToolboxItemCategoryAttribute Class

[image]
Gizmox.WebGUI.Common
ToolboxItemCategoryAttribute Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace : ToolboxItemCategoryAttribute Class

Syntax

Visual Basic (Declaration)
Public Class ToolboxItemCategoryAttribute
   Inherits Attribute
Visual Basic (Usage) Copy Code
Dim instance As ToolboxItemCategoryAttribute
C#
public class ToolboxItemCategoryAttribute : Attribute
Managed Extensions for C++
public __gc class ToolboxItemCategoryAttribute : public Attribute
C++/CLI
public ref class ToolboxItemCategoryAttribute : public Attribute

Inheritance Hierarchy

System.Object
System.Attribute
Gizmox.WebGUI.Forms.Design.ToolboxItemCategoryAttribute

Requirements

Namespace: Gizmox.WebGUI.Forms.Design

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

ToolboxItemCategoryAttribute Members
Gizmox.WebGUI.Forms.Design Namespace


ToolboxItemCategoryAttribute Class Members

[image]
Gizmox.WebGUI.Common
ToolboxItemCategoryAttribute Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms.Design Namespace : ToolboxItemCategoryAttribute Class

The following tables list the members exposed by ToolboxItemCategoryAttribute.

Public Constructors

 | Name | Description
Public Constructor | ToolboxItemCategoryAttribute Constructor |
Top

Public Properties

 | Name | Description
Public Property | Category |
Public Property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from System.Attribute)
Top

Public Methods

 | Name | Description
Public Method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from System.Attribute)
Public Method | GetHashCode | Returns the hash code for this instance. (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from System.Attribute)
Public Method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from System.Attribute)
Top

See Also

Reference

ToolboxItemCategoryAttribute Class
Gizmox.WebGUI.Forms.Design Namespace


ToolboxItemCategoryAttribute Constructor

[image]
Gizmox.WebGUI.Common
ToolboxItemCategoryAttribute Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > ToolboxItemCategoryAttribute Class : ToolboxItemCategoryAttribute Constructor

strCategory

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal strCategory As String _
)
Visual Basic (Usage) Copy Code
Dim strCategory As String

Dim instance As ToolboxItemCategoryAttribute(strCategory)
C#
public ToolboxItemCategoryAttribute(
   string strCategory
)
Managed Extensions for C++
public: ToolboxItemCategoryAttribute(
   string* strCategory
)
C++/CLI
public:
ToolboxItemCategoryAttribute(
   String^ strCategory
)

Parameters

strCategory

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ToolboxItemCategoryAttribute Class
ToolboxItemCategoryAttribute Members


ToolboxItemCategoryAttribute Class Properties

[image]
Gizmox.WebGUI.Common
ToolboxItemCategoryAttribute Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace : ToolboxItemCategoryAttribute Class

For a list of all members of this type, see ToolboxItemCategoryAttribute members.

Public Properties

 | Name | Description
Public Property | Category |
Public Property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from System.Attribute)
Top

See Also

Reference

ToolboxItemCategoryAttribute Class
Gizmox.WebGUI.Forms.Design Namespace


Category Property

[image]
Gizmox.WebGUI.Common
Category Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace > ToolboxItemCategoryAttribute Class : Category Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Category As String
Visual Basic (Usage) Copy Code
Dim instance As ToolboxItemCategoryAttribute
Dim value As String

value = instance.Category
C#
public string Category {get;}
Managed Extensions for C++
public: __property string* get_Category();
C++/CLI
public:
property String^ Category {
   String^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ToolboxItemCategoryAttribute Class
ToolboxItemCategoryAttribute Members


Gizmox.WebGUI.Forms.Interopability Namespace

Gizmox.WebGUI.Common
Gizmox.WebGUI.Forms.Interopability Namespace
See Also Inheritance Hierarchy Send Feedback

Classes

 | Class | Description
Class | InvokeMethodMessage |

See Also

Reference

Gizmox.WebGUI.Common Assembly


InvokeMethodMessage Class

[image]
Gizmox.WebGUI.Common
InvokeMethodMessage Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms.Interopability Namespace : InvokeMethodMessage Class

Syntax

Visual Basic (Declaration)
Public Class InvokeMethodMessage
Visual Basic (Usage) Copy Code
Dim instance As InvokeMethodMessage
C#
public class InvokeMethodMessage
Managed Extensions for C++
public __gc class InvokeMethodMessage
C++/CLI
public ref class InvokeMethodMessage

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.Interopability.InvokeMethodMessage

Requirements

Namespace: Gizmox.WebGUI.Forms.Interopability

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Common (in Gizmox.WebGUI.Common.dll)

See Also

Reference

InvokeMethodMessage Members
Gizmox.WebGUI.Forms.Interopability Namespace


InvokeMethodMessage Class Members

[image]
Gizmox.WebGUI.Common
InvokeMethodMessage Class Members
See Also Send Feedback
Gizmox.WebGUI.Forms.Interopability Namespace : InvokeMethodMessage Class

The following tables list the members exposed by InvokeMethodMessage.

Public Constructors

 | Name | Description
Public Constructor | InvokeMethodMessage Constructor |
Top

See Also

Reference

InvokeMethodMessage Class
Gizmox.WebGUI.Forms.Interopability Namespace


InvokeMethodMessage Constructor

[image]
Gizmox.WebGUI.Common
InvokeMethodMessage Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms.Interopability Namespace > InvokeMethodMessage Class : InvokeMethodMessage Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As InvokeMethodMessage()
C#
public InvokeMethodMessage()
Managed Extensions for C++
public: InvokeMethodMessage();
C++/CLI
public:
InvokeMethodMessage();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

InvokeMethodMessage Class
InvokeMethodMessage Members


Assembly Overview

Gizmox.WebGUI.Forms.Charts
Gizmox.WebGUI.Forms.Charts Assembly
See Also Send Feedback

Namespaces

Namespace | Description
Gizmox.WebGUI.Forms.Charts |


Gizmox.WebGUI.Forms.Charts Namespace

Gizmox.WebGUI.Forms.Charts
Gizmox.WebGUI.Forms.Charts Namespace
See Also Inheritance Hierarchy Send Feedback

Classes

 | Class | Description
Class | Axes |
Class | AxisX |
Class | AxisY |
Class | Chart | Summary description for Chart
Class | Data |
Class | DataPoint |
Class | DataSeries |
Class | Title |
Class | TitleBase |

Interfaces

 | Interface | Description
Interface | IChartData |

Enumerations

 | Enumeration | Description
Enumeration | AlignmentX |
Enumeration | AlignmentY |
Enumeration | AnimationTypes |
Enumeration | DisplayTypes |
Enumeration | ThemeTypes |

See Also

Reference

Gizmox.WebGUI.Forms.Charts Assembly


Axes Class

[image]
Gizmox.WebGUI.Forms.Charts
Axes Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace : Axes Class

Object Model

Syntax

Visual Basic (Declaration)
Public MustInherit Class Axes
   Inherits Control
   Implements IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Visual Basic (Usage) Copy Code
Dim instance As Axes
C#
public abstract class Axes : Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Managed Extensions for C++
public __gc abstract class Axes : public Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
C++/CLI
public ref class Axes abstract : public Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.Charts.Axes
Gizmox.WebGUI.Forms.Charts.AxisX
Gizmox.WebGUI.Forms.Charts.AxisY

Requirements

Namespace: Gizmox.WebGUI.Forms.Charts

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms.Charts (in Gizmox.WebGUI.Forms.Charts.dll)

See Also

Reference

Axes Members
Gizmox.WebGUI.Forms.Charts Namespace


Axes Class Members

[image]
Gizmox.WebGUI.Forms.Charts
Axes Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace : Axes Class

The following tables list the members exposed by Axes.

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackColor | Gets or sets the background color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BindingContext | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Container | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Context | Gets the context. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Form | Gets the owner form. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Height | Gets/Sets the height position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | IsRegistered | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Left | Gets/Sets the left position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Location | Gets or sets the control location. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Prefix | Gets or sets the prefix.
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Right | Gets/Sets the right position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Site | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Suffix | Gets or sets the suffix.
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Title | Gets or sets the title.
Public Property | Top | Gets/Sets the top position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Visible | Gets or sets the control visability. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Width | Gets/Sets the width position (Inherited from Gizmox.WebGUI.Forms.Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultBorderColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultBorderStyle | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultForeColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMargin | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultPadding | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DesignMode | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | Events | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | IsConnected | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Property | IsDelayedDrawing | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | Session | Gets the application object. (Inherited from Gizmox.WebGUI.Forms.Component)
Top

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Focus | Sets focus to this control (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | GetChartDataXML |
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | GetPreferredSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | ResetText | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SendToBack | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Show | Displays the control to the user. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ToString | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Update | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | Finalize | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCommandText | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetImage | Gets the image. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetPreferredSizeCore | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetService | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | InvokeMethod | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | IsDirty | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBindingContextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnControlAdded | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnControlRemoved | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | OnEnabledChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnGotFocus | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLostFocus | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentVisibleChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnResize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnTextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnUnregisterComponents | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnValidated | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnValidating | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ProcessGatewayRequest | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RegisterSelf | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | RenderAttributes | Renders the controls meta attributes (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderClientUpdateHandler | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderComponentEventAttributes | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetImage | Sets the image. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeText | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | UnRegisterBatch | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | UnRegisterSelf | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | UpdateParams | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Top

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Disposed | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Gizmox.WebGUI.Forms.Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Top

See Also

Reference

Axes Class
Gizmox.WebGUI.Forms.Charts Namespace


Axes Class Methods

[image]
Gizmox.WebGUI.Forms.Charts
Axes Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace : Axes Class

For a list of all members of this type, see Axes members.

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Focus | Sets focus to this control (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | GetChartDataXML |
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | GetPreferredSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | ResetText | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SendToBack | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Show | Displays the control to the user. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ToString | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Update | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | Finalize | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCommandText | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetImage | Gets the image. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetPreferredSizeCore | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetService | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | InvokeMethod | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | IsDirty | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBindingContextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnControlAdded | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnControlRemoved | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | OnEnabledChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnGotFocus | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLostFocus | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentVisibleChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnResize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnTextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnUnregisterComponents | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnValidated | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnValidating | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ProcessGatewayRequest | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RegisterSelf | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | RenderAttributes | Renders the controls meta attributes (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderClientUpdateHandler | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderComponentEventAttributes | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetImage | Sets the image. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeText | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | UnRegisterBatch | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | UnRegisterSelf | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | UpdateParams | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Top

See Also

Reference

Axes Class
Gizmox.WebGUI.Forms.Charts Namespace


GetChartDataXML Method

[image]
Gizmox.WebGUI.Forms.Charts
GetChartDataXML Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace > Axes Class : GetChartDataXML Method

objWriter

Syntax

Visual Basic (Declaration)
Public Function GetChartDataXML( _
   ByVal objWriter As XmlTextWriter _
) As XmlTextWriter
Visual Basic (Usage) Copy Code
Dim instance As Axes
Dim objWriter As XmlTextWriter
Dim value As XmlTextWriter

value = instance.GetChartDataXML(objWriter)
C#
public XmlTextWriter GetChartDataXML(
   XmlTextWriter objWriter
)
Managed Extensions for C++
public: XmlTextWriter* GetChartDataXML(
   XmlTextWriter* objWriter
)
C++/CLI
public:
XmlTextWriter^ GetChartDataXML(
   XmlTextWriter^ objWriter
)

Parameters

objWriter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Axes Class
Axes Members


Axes Class Properties

[image]
Gizmox.WebGUI.Forms.Charts
Axes Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace : Axes Class

For a list of all members of this type, see Axes members.

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackColor | Gets or sets the background color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BindingContext | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Container | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Context | Gets the context. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Form | Gets the owner form. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Height | Gets/Sets the height position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | IsRegistered | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Left | Gets/Sets the left position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Location | Gets or sets the control location. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Prefix | Gets or sets the prefix.
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Right | Gets/Sets the right position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Site | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Suffix | Gets or sets the suffix.
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Title | Gets or sets the title.
Public Property | Top | Gets/Sets the top position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Visible | Gets or sets the control visability. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Width | Gets/Sets the width position (Inherited from Gizmox.WebGUI.Forms.Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultBorderColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultBorderStyle | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultForeColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMargin | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultPadding | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DesignMode | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | Events | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | IsConnected | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Property | IsDelayedDrawing | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | Session | Gets the application object. (Inherited from Gizmox.WebGUI.Forms.Component)
Top

See Also

Reference

Axes Class
Gizmox.WebGUI.Forms.Charts Namespace


Prefix Property

[image]
Gizmox.WebGUI.Forms.Charts
Prefix Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace > Axes Class : Prefix Property

Gets or sets the prefix.

Syntax

Visual Basic (Declaration)
Public Property Prefix As String
Visual Basic (Usage) Copy Code
Dim instance As Axes
Dim value As String

instance.Prefix = value

value = instance.Prefix
C#
public string Prefix {get; set;}
Managed Extensions for C++
public: __property string* get_Prefix();
public: __property void set_Prefix(
   string* value
);
C++/CLI
public:
property String^ Prefix {
   String^ get();
   void set (String^value);
}

Return Value

The prefix.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Axes Class
Axes Members


Suffix Property

[image]
Gizmox.WebGUI.Forms.Charts
Suffix Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace > Axes Class : Suffix Property

Gets or sets the suffix.

Syntax

Visual Basic (Declaration)
Public Property Suffix As String
Visual Basic (Usage) Copy Code
Dim instance As Axes
Dim value As String

instance.Suffix = value

value = instance.Suffix
C#
public string Suffix {get; set;}
Managed Extensions for C++
public: __property string* get_Suffix();
public: __property void set_Suffix(
   string* value
);
C++/CLI
public:
property String^ Suffix {
   String^ get();
   void set (String^value);
}

Return Value

The suffix.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Axes Class
Axes Members


Title Property

[image]
Gizmox.WebGUI.Forms.Charts
Title Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace > Axes Class : Title Property

Gets or sets the title.

Syntax

Visual Basic (Declaration)
Public Property Title As String
Visual Basic (Usage) Copy Code
Dim instance As Axes
Dim value As String

instance.Title = value

value = instance.Title
C#
public string Title {get; set;}
Managed Extensions for C++
public: __property string* get_Title();
public: __property void set_Title(
   string* value
);
C++/CLI
public:
property String^ Title {
   String^ get();
   void set (String^value);
}

Return Value

The title.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Axes Class
Axes Members


AxisX Class

[image]
Gizmox.WebGUI.Forms.Charts
AxisX Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace : AxisX Class

Object Model

Syntax

Visual Basic (Declaration)
Public Class AxisX
   Inherits Axes
   Implements IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IChartData, IBindableComponent, IArrangedElement
Visual Basic (Usage) Copy Code
Dim instance As AxisX
C#
public class AxisX : Axes, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IChartData, IBindableComponent, IArrangedElement
Managed Extensions for C++
public __gc class AxisX : public Axes, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IChartData, IBindableComponent, IArrangedElement
C++/CLI
public ref class AxisX : public Axes, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IChartData, IBindableComponent, IArrangedElement

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.Charts.Axes
Gizmox.WebGUI.Forms.Charts.AxisX

Requirements

Namespace: Gizmox.WebGUI.Forms.Charts

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms.Charts (in Gizmox.WebGUI.Forms.Charts.dll)

See Also

Reference

AxisX Members
Gizmox.WebGUI.Forms.Charts Namespace


AxisX Class Members

[image]
Gizmox.WebGUI.Forms.Charts
AxisX Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace : AxisX Class

The following tables list the members exposed by AxisX.

Public Constructors

 | Name | Description
Public Constructor | AxisX Constructor |
Top

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackColor | Gets or sets the background color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BindingContext | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Container | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Context | Gets the context. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Form | Gets the owner form. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Height | Gets/Sets the height position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | IsRegistered | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Left | Gets/Sets the left position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Location | Gets or sets the control location. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Prefix | Gets or sets the prefix. (Inherited from Axes)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Right | Gets/Sets the right position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Site | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Suffix | Gets or sets the suffix. (Inherited from Axes)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Title | Gets or sets the title. (Inherited from Axes)
Public Property | Top | Gets/Sets the top position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Visible | Gets or sets the control visability. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Width | Gets/Sets the width position (Inherited from Gizmox.WebGUI.Forms.Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultBorderColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultBorderStyle | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultForeColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMargin | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultPadding | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DesignMode | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | Events | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | IsConnected | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Property | IsDelayedDrawing | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | Session | Gets the application object. (Inherited from Gizmox.WebGUI.Forms.Component)
Top

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Focus | Sets focus to this control (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | GetChartDataXML |
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | GetPreferredSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | ResetText | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SendToBack | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Show | Displays the control to the user. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ToString | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Update | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | Finalize | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCommandText | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetImage | Gets the image. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetPreferredSizeCore | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetService | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | InvokeMethod | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | IsDirty | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBindingContextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnControlAdded | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnControlRemoved | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | OnEnabledChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnGotFocus | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLostFocus | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentVisibleChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnResize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnTextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnUnregisterComponents | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnValidated | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnValidating | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ProcessGatewayRequest | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RegisterSelf | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | RenderAttributes | Renders the controls meta attributes (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderClientUpdateHandler | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderComponentEventAttributes | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetImage | Sets the image. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeText | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | UnRegisterBatch | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | UnRegisterSelf | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | UpdateParams | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Top

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Disposed | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Gizmox.WebGUI.Forms.Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Top

See Also

Reference

AxisX Class
Gizmox.WebGUI.Forms.Charts Namespace


AxisX Constructor

[image]
Gizmox.WebGUI.Forms.Charts
AxisX Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace > AxisX Class : AxisX Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As AxisX()
C#
public AxisX()
Managed Extensions for C++
public: AxisX();
C++/CLI
public:
AxisX();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AxisX Class
AxisX Members


AxisX Class Methods

[image]
Gizmox.WebGUI.Forms.Charts
AxisX Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace : AxisX Class

For a list of all members of this type, see AxisX members.

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Focus | Sets focus to this control (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | GetChartDataXML |
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | GetPreferredSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | ResetText | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SendToBack | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Show | Displays the control to the user. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ToString | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Update | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | Finalize | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCommandText | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetImage | Gets the image. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetPreferredSizeCore | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetService | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | InvokeMethod | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | IsDirty | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBindingContextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnControlAdded | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnControlRemoved | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | OnEnabledChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnGotFocus | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLostFocus | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentVisibleChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnResize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnTextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnUnregisterComponents | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnValidated | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnValidating | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ProcessGatewayRequest | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RegisterSelf | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | RenderAttributes | Renders the controls meta attributes (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderClientUpdateHandler | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderComponentEventAttributes | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetImage | Sets the image. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeText | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | UnRegisterBatch | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | UnRegisterSelf | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | UpdateParams | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Top

See Also

Reference

AxisX Class
Gizmox.WebGUI.Forms.Charts Namespace


GetChartDataXML Method

[image]
Gizmox.WebGUI.Forms.Charts
GetChartDataXML Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace > AxisX Class : GetChartDataXML Method

objWriter

Syntax

Visual Basic (Declaration)
Public Function GetChartDataXML( _
   ByVal objWriter As XmlTextWriter _
) As XmlTextWriter
Visual Basic (Usage) Copy Code
Dim instance As AxisX
Dim objWriter As XmlTextWriter
Dim value As XmlTextWriter

value = instance.GetChartDataXML(objWriter)
C#
public XmlTextWriter GetChartDataXML(
   XmlTextWriter objWriter
)
Managed Extensions for C++
public: XmlTextWriter* GetChartDataXML(
   XmlTextWriter* objWriter
)
C++/CLI
public:
XmlTextWriter^ GetChartDataXML(
   XmlTextWriter^ objWriter
)

Parameters

objWriter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AxisX Class
AxisX Members


AxisY Class

[image]
Gizmox.WebGUI.Forms.Charts
AxisY Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace : AxisY Class

Object Model

Syntax

Visual Basic (Declaration)
Public Class AxisY
   Inherits Axes
   Implements IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IChartData, IBindableComponent, IArrangedElement
Visual Basic (Usage) Copy Code
Dim instance As AxisY
C#
public class AxisY : Axes, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IChartData, IBindableComponent, IArrangedElement
Managed Extensions for C++
public __gc class AxisY : public Axes, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IChartData, IBindableComponent, IArrangedElement
C++/CLI
public ref class AxisY : public Axes, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IChartData, IBindableComponent, IArrangedElement

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.Charts.Axes
Gizmox.WebGUI.Forms.Charts.AxisY

Requirements

Namespace: Gizmox.WebGUI.Forms.Charts

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms.Charts (in Gizmox.WebGUI.Forms.Charts.dll)

See Also

Reference

AxisY Members
Gizmox.WebGUI.Forms.Charts Namespace


AxisY Class Members

[image]
Gizmox.WebGUI.Forms.Charts
AxisY Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace : AxisY Class

The following tables list the members exposed by AxisY.

Public Constructors

 | Name | Description
Public Constructor | AxisY Constructor |
Top

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackColor | Gets or sets the background color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BindingContext | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Container | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Context | Gets the context. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Form | Gets the owner form. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Height | Gets/Sets the height position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | IsRegistered | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Left | Gets/Sets the left position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Location | Gets or sets the control location. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Prefix | Gets or sets the prefix. (Inherited from Axes)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Right | Gets/Sets the right position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Site | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Suffix | Gets or sets the suffix. (Inherited from Axes)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Title | Gets or sets the title. (Inherited from Axes)
Public Property | Top | Gets/Sets the top position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Visible | Gets or sets the control visability. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Width | Gets/Sets the width position (Inherited from Gizmox.WebGUI.Forms.Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultBorderColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultBorderStyle | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultForeColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMargin | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultPadding | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DesignMode | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | Events | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | IsConnected | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Property | IsDelayedDrawing | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | Session | Gets the application object. (Inherited from Gizmox.WebGUI.Forms.Component)
Top

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Focus | Sets focus to this control (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | GetChartDataXML |
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | GetPreferredSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | ResetText | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SendToBack | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Show | Displays the control to the user. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ToString | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Update | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | Finalize | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCommandText | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetImage | Gets the image. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetPreferredSizeCore | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetService | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | InvokeMethod | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | IsDirty | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBindingContextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnControlAdded | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnControlRemoved | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | OnEnabledChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnGotFocus | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLostFocus | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentVisibleChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnResize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnTextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnUnregisterComponents | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnValidated | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnValidating | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ProcessGatewayRequest | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RegisterSelf | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | RenderAttributes | Renders the controls meta attributes (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderClientUpdateHandler | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderComponentEventAttributes | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetImage | Sets the image. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeText | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | UnRegisterBatch | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | UnRegisterSelf | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | UpdateParams | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Top

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Disposed | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Gizmox.WebGUI.Forms.Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Top

See Also

Reference

AxisY Class
Gizmox.WebGUI.Forms.Charts Namespace


AxisY Constructor

[image]
Gizmox.WebGUI.Forms.Charts
AxisY Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace > AxisY Class : AxisY Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As AxisY()
C#
public AxisY()
Managed Extensions for C++
public: AxisY();
C++/CLI
public:
AxisY();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AxisY Class
AxisY Members


AxisY Class Methods

[image]
Gizmox.WebGUI.Forms.Charts
AxisY Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace : AxisY Class

For a list of all members of this type, see AxisY members.

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Focus | Sets focus to this control (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | GetChartDataXML |
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | GetPreferredSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | ResetText | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SendToBack | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Show | Displays the control to the user. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ToString | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Update | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | Finalize | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCommandText | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetImage | Gets the image. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetPreferredSizeCore | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetService | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | InvokeMethod | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | IsDirty | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBindingContextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnControlAdded | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnControlRemoved | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | OnEnabledChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnGotFocus | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLostFocus | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentVisibleChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnResize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnTextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnUnregisterComponents | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnValidated | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnValidating | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ProcessGatewayRequest | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RegisterSelf | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | RenderAttributes | Renders the controls meta attributes (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderClientUpdateHandler | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderComponentEventAttributes | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetImage | Sets the image. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeText | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | UnRegisterBatch | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | UnRegisterSelf | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | UpdateParams | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Top

See Also

Reference

AxisY Class
Gizmox.WebGUI.Forms.Charts Namespace


GetChartDataXML Method

[image]
Gizmox.WebGUI.Forms.Charts
GetChartDataXML Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace > AxisY Class : GetChartDataXML Method

objWriter

Syntax

Visual Basic (Declaration)
Public Function GetChartDataXML( _
   ByVal objWriter As XmlTextWriter _
) As XmlTextWriter
Visual Basic (Usage) Copy Code
Dim instance As AxisY
Dim objWriter As XmlTextWriter
Dim value As XmlTextWriter

value = instance.GetChartDataXML(objWriter)
C#
public XmlTextWriter GetChartDataXML(
   XmlTextWriter objWriter
)
Managed Extensions for C++
public: XmlTextWriter* GetChartDataXML(
   XmlTextWriter* objWriter
)
C++/CLI
public:
XmlTextWriter^ GetChartDataXML(
   XmlTextWriter^ objWriter
)

Parameters

objWriter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AxisY Class
AxisY Members


Chart Class

[image]
Gizmox.WebGUI.Forms.Charts
Chart Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace : Chart Class

Summary description for Chart

Object Model

Syntax

Visual Basic (Declaration)
<ClientControllerAttribute()>
<ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<MetadataTagAttribute("CT")>
<SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.Charts.BindableChart,  Gizmox.WebGUI.Silverlight.Controls.Charts, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")>
<ToolboxBitmapAttribute()>
<DesignTimeControllerAttribute()>
Public Class Chart
   Inherits Control
   Implements IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IGatewayControl, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IRequiredRegistration, IChartData, IBindableComponent, IArrangedElement
Visual Basic (Usage) Copy Code
Dim instance As Chart
C#
[ClientControllerAttribute()]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[MetadataTagAttribute("CT")]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.Charts.BindableChart,  Gizmox.WebGUI.Silverlight.Controls.Charts, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[ToolboxBitmapAttribute()]
[DesignTimeControllerAttribute()]
public class Chart : Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IGatewayControl, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IRequiredRegistration, IChartData, IBindableComponent, IArrangedElement
Managed Extensions for C++
[ClientControllerAttribute()]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[MetadataTagAttribute("CT")]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.Charts.BindableChart,  Gizmox.WebGUI.Silverlight.Controls.Charts, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[ToolboxBitmapAttribute()]
[DesignTimeControllerAttribute()]
public __gc class Chart : public Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IGatewayControl, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IRequiredRegistration, IChartData, IBindableComponent, IArrangedElement
C++/CLI
[ClientControllerAttribute()]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[MetadataTagAttribute("CT")]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.Charts.BindableChart,  Gizmox.WebGUI.Silverlight.Controls.Charts, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[ToolboxBitmapAttribute()]
[DesignTimeControllerAttribute()]
public ref class Chart : public Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IGatewayControl, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IRequiredRegistration, IChartData, IBindableComponent, IArrangedElement

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.Charts.Chart

Requirements

Namespace: Gizmox.WebGUI.Forms.Charts

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms.Charts (in Gizmox.WebGUI.Forms.Charts.dll)

See Also

Reference

Chart Members
Gizmox.WebGUI.Forms.Charts Namespace


Chart Class Members

[image]
Gizmox.WebGUI.Forms.Charts
Chart Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace : Chart Class

The following tables list the members exposed by Chart.

Public Constructors

 | Name | Description
Public Constructor | Chart Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | AnimationEnabled | Gets or sets a value indicating whether [animation enabled].
Public Property | AnimationType | Gets or sets the type of the animation.
Public Property | AxisX | Gets or sets the axis X.
Public Property | AxisY | Gets or sets the axis Y.
Public Property | BackColor | Gets or sets the background color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BindingContext | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ColorSet | Gets or sets the color set.
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Container | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Context | Gets the context. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Data | Gets the data.
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Form | Gets the owner form. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Height | Gets/Sets the height position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | IsRegistered | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Left | Gets/Sets the left position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Location | Gets or sets the control location. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Right | Gets/Sets the right position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Site | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Theme | Gets or sets the theme.
Public Property | Title | Gets or sets the title.
Public Property | Top | Gets/Sets the top position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | View3D | Gets or sets a value indicating whether view3 D is on.
Public Property | Visible | Gets or sets the control visability. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Width | Gets/Sets the width position (Inherited from Gizmox.WebGUI.Forms.Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultBorderColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultBorderStyle | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultForeColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMargin | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultPadding | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DesignMode | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | Events | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | IsConnected | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Property | IsDelayedDrawing | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | Session | Gets the application object. (Inherited from Gizmox.WebGUI.Forms.Component)
Top

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Focus | Sets focus to this control (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | GetChartDataXML |
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | GetPreferredSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | ResetText | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SendToBack | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Show | Displays the control to the user. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ToString | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Update | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | Finalize | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCommandText | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetImage | Gets the image. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetPreferredSizeCore | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetService | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | InvokeMethod | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | IsDirty | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBindingContextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnControlAdded | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnControlRemoved | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | OnEnabledChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnGotFocus | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLostFocus | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentVisibleChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnResize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnTextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnUnregisterComponents | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnValidated | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnValidating | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ProcessGatewayRequest | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RegisterSelf | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | RenderAttributes | Overridden.
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderClientUpdateHandler | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderComponentEventAttributes | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetImage | Sets the image. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeText | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | UnRegisterBatch | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | UnRegisterSelf | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | UpdateParams | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Top

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Disposed | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Gizmox.WebGUI.Forms.Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Top

See Also

Reference

Chart Class
Gizmox.WebGUI.Forms.Charts Namespace


Chart Constructor

[image]
Gizmox.WebGUI.Forms.Charts
Chart Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace > Chart Class : Chart Constructor

Overload List

Overload | Description
Chart Constructor() |
Chart Constructor(AxisX,AxisY) |
Chart Constructor(Title) |
Chart Constructor(Title,AxisX,AxisY) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Chart Class
Chart Members


Chart Constructor()

[image]
Gizmox.WebGUI.Forms.Charts
Chart Constructor()
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace > Chart Class > Chart Constructor : Chart Constructor()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Chart()
C#
public Chart()
Managed Extensions for C++
public: Chart();
C++/CLI
public:
Chart();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Chart Class
Chart Members
Overload List


Chart Constructor(AxisX,AxisY)

[image]
Gizmox.WebGUI.Forms.Charts
Chart Constructor(AxisX,AxisY)
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace > Chart Class > Chart Constructor : Chart Constructor(AxisX,AxisY)

objAxisX
objAxisY

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal objAxisX As AxisX, _
   ByVal objAxisY As AxisY _
)
Visual Basic (Usage) Copy Code
Dim objAxisX As AxisX
Dim objAxisY As AxisY

Dim instance As Chart(objAxisX, objAxisY)
C#
public Chart(
   AxisX objAxisX,
   AxisY objAxisY
)
Managed Extensions for C++
public: Chart(
   AxisX* objAxisX,
   AxisY* objAxisY
)
C++/CLI
public:
Chart(
   AxisX^ objAxisX,
   AxisY^ objAxisY
)

Parameters

objAxisX
objAxisY

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Chart Class
Chart Members
Overload List


Chart Constructor(Title)

[image]
Gizmox.WebGUI.Forms.Charts
Chart Constructor(Title)
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace > Chart Class > Chart Constructor : Chart Constructor(Title)

objTitle

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal objTitle As Title _
)
Visual Basic (Usage) Copy Code
Dim objTitle As Title

Dim instance As Chart(objTitle)
C#
public Chart(
   Title objTitle
)
Managed Extensions for C++
public: Chart(
   Title* objTitle
)
C++/CLI
public:
Chart(
   Title^ objTitle
)

Parameters

objTitle

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Chart Class
Chart Members
Overload List


Chart Constructor(Title,AxisX,AxisY)

[image]
Gizmox.WebGUI.Forms.Charts
Chart Constructor(Title,AxisX,AxisY)
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace > Chart Class > Chart Constructor : Chart Constructor(Title,AxisX,AxisY)

objTitle
objAxisX
objAxisY

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal objTitle As Title, _
   ByVal objAxisX As AxisX, _
   ByVal objAxisY As AxisY _
)
Visual Basic (Usage) Copy Code
Dim objTitle As Title
Dim objAxisX As AxisX
Dim objAxisY As AxisY

Dim instance As Chart(objTitle, objAxisX, objAxisY)
C#
public Chart(
   Title objTitle,
   AxisX objAxisX,
   AxisY objAxisY
)
Managed Extensions for C++
public: Chart(
   Title* objTitle,
   AxisX* objAxisX,
   AxisY* objAxisY
)
C++/CLI
public:
Chart(
   Title^ objTitle,
   AxisX^ objAxisX,
   AxisY^ objAxisY
)

Parameters

objTitle
objAxisX
objAxisY

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Chart Class
Chart Members
Overload List


Chart Class Methods

[image]
Gizmox.WebGUI.Forms.Charts
Chart Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace : Chart Class

For a list of all members of this type, see Chart members.

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Focus | Sets focus to this control (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | GetChartDataXML |
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | GetPreferredSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | ResetText | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SendToBack | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Show | Displays the control to the user. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ToString | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Update | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | Finalize | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCommandText | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetImage | Gets the image. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetPreferredSizeCore | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetService | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | InvokeMethod | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | IsDirty | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBindingContextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnControlAdded | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnControlRemoved | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | OnEnabledChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnGotFocus | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLostFocus | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentVisibleChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnResize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnTextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnUnregisterComponents | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnValidated | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnValidating | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ProcessGatewayRequest | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RegisterSelf | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | RenderAttributes | Overridden.
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderClientUpdateHandler | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderComponentEventAttributes | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetImage | Sets the image. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeText | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | UnRegisterBatch | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | UnRegisterSelf | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | UpdateParams | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Top

See Also

Reference

Chart Class
Gizmox.WebGUI.Forms.Charts Namespace


GetChartDataXML Method

[image]
Gizmox.WebGUI.Forms.Charts
GetChartDataXML Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace > Chart Class : GetChartDataXML Method

objWriter

Syntax

Visual Basic (Declaration)
Public Function GetChartDataXML( _
   ByVal objWriter As XmlTextWriter _
) As XmlTextWriter
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim objWriter As XmlTextWriter
Dim value As XmlTextWriter

value = instance.GetChartDataXML(objWriter)
C#
public XmlTextWriter GetChartDataXML(
   XmlTextWriter objWriter
)
Managed Extensions for C++
public: XmlTextWriter* GetChartDataXML(
   XmlTextWriter* objWriter
)
C++/CLI
public:
XmlTextWriter^ GetChartDataXML(
   XmlTextWriter^ objWriter
)

Parameters

objWriter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Chart Class
Chart Members


RenderAttributes Method

[image]
Gizmox.WebGUI.Forms.Charts
RenderAttributes Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace > Chart Class : RenderAttributes Method

context
writer

Syntax

Visual Basic (Declaration)
Protected Overrides Sub RenderAttributes( _
   ByVal context As IContext, _
   ByVal writer As IAttributeWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim context As IContext
Dim writer As IAttributeWriter

instance.RenderAttributes(context, writer)
C#
protected override void RenderAttributes(
   IContext context,
   IAttributeWriter writer
)
Managed Extensions for C++
protected: void RenderAttributes(
   IContext* context,
   IAttributeWriter* writer
) override
C++/CLI
protected:
void RenderAttributes(
   IContext^ context,
   IAttributeWriter^ writer
) override

Parameters

context
writer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Chart Class
Chart Members


Chart Class Properties

[image]
Gizmox.WebGUI.Forms.Charts
Chart Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace : Chart Class

For a list of all members of this type, see Chart members.

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | AnimationEnabled | Gets or sets a value indicating whether [animation enabled].
Public Property | AnimationType | Gets or sets the type of the animation.
Public Property | AxisX | Gets or sets the axis X.
Public Property | AxisY | Gets or sets the axis Y.
Public Property | BackColor | Gets or sets the background color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BindingContext | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ColorSet | Gets or sets the color set.
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Container | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Context | Gets the context. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Data | Gets the data.
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Form | Gets the owner form. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Height | Gets/Sets the height position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | IsRegistered | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Left | Gets/Sets the left position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Location | Gets or sets the control location. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Right | Gets/Sets the right position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Site | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Theme | Gets or sets the theme.
Public Property | Title | Gets or sets the title.
Public Property | Top | Gets/Sets the top position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | View3D | Gets or sets a value indicating whether view3 D is on.
Public Property | Visible | Gets or sets the control visability. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Width | Gets/Sets the width position (Inherited from Gizmox.WebGUI.Forms.Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultBorderColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultBorderStyle | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultForeColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMargin | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultPadding | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DesignMode | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | Events | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | IsConnected | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Property | IsDelayedDrawing | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | Session | Gets the application object. (Inherited from Gizmox.WebGUI.Forms.Component)
Top

See Also

Reference

Chart Class
Gizmox.WebGUI.Forms.Charts Namespace


AnimationEnabled Property

[image]
Gizmox.WebGUI.Forms.Charts
AnimationEnabled Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace > Chart Class : AnimationEnabled Property

Gets or sets a value indicating whether [animation enabled].

Syntax

Visual Basic (Declaration)
Public Property AnimationEnabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim value As Boolean

instance.AnimationEnabled = value

value = instance.AnimationEnabled
C#
public bool AnimationEnabled {get; set;}
Managed Extensions for C++
public: __property bool get_AnimationEnabled();
public: __property void set_AnimationEnabled(
   bool value
);
C++/CLI
public:
property bool AnimationEnabled {
   bool get();
   void set (boolvalue);
}

Return Value

true if [animation enabled]; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Chart Class
Chart Members


AnimationType Property

[image]
Gizmox.WebGUI.Forms.Charts
AnimationType Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace > Chart Class : AnimationType Property

Gets or sets the type of the animation.

Syntax

Visual Basic (Declaration)
Public Property AnimationType As AnimationTypes
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim value As AnimationTypes

instance.AnimationType = value

value = instance.AnimationType
C#
public AnimationTypes AnimationType {get; set;}
Managed Extensions for C++
public: __property AnimationTypes get_AnimationType();
public: __property void set_AnimationType(
   AnimationTypes value
);
C++/CLI
public:
property AnimationTypes AnimationType {
   AnimationTypes get();
   void set (AnimationTypesvalue);
}

Return Value

The type of the animation.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Chart Class
Chart Members


AxisX Property

[image]
Gizmox.WebGUI.Forms.Charts
AxisX Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace > Chart Class : AxisX Property

Gets or sets the axis X.

Syntax

Visual Basic (Declaration)
Public Property AxisX As AxisX
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim value As AxisX

instance.AxisX = value

value = instance.AxisX
C#
public AxisX AxisX {get; set;}
Managed Extensions for C++
public: __property AxisX* get_AxisX();
public: __property void set_AxisX(
   AxisX* value
);
C++/CLI
public:
property AxisX^ AxisX {
   AxisX^ get();
   void set (AxisX^value);
}

Return Value

The axis X.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Chart Class
Chart Members


AxisY Property

[image]
Gizmox.WebGUI.Forms.Charts
AxisY Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace > Chart Class : AxisY Property

Gets or sets the axis Y.

Syntax

Visual Basic (Declaration)
Public Property AxisY As AxisY
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim value As AxisY

instance.AxisY = value

value = instance.AxisY
C#
public AxisY AxisY {get; set;}
Managed Extensions for C++
public: __property AxisY* get_AxisY();
public: __property void set_AxisY(
   AxisY* value
);
C++/CLI
public:
property AxisY^ AxisY {
   AxisY^ get();
   void set (AxisY^value);
}

Return Value

The axis Y.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Chart Class
Chart Members


ColorSet Property

[image]
Gizmox.WebGUI.Forms.Charts
ColorSet Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace > Chart Class : ColorSet Property

Gets or sets the color set.

Syntax

Visual Basic (Declaration)
Public Property ColorSet As String
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim value As String

instance.ColorSet = value

value = instance.ColorSet
C#
public string ColorSet {get; set;}
Managed Extensions for C++
public: __property string* get_ColorSet();
public: __property void set_ColorSet(
   string* value
);
C++/CLI
public:
property String^ ColorSet {
   String^ get();
   void set (String^value);
}

Return Value

The color set.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Chart Class
Chart Members


Data Property

[image]
Gizmox.WebGUI.Forms.Charts
Data Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace > Chart Class : Data Property

Gets the data.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Data As Data
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim value As Data

value = instance.Data
C#
public Data Data {get;}
Managed Extensions for C++
public: __property Data* get_Data();
C++/CLI
public:
property Data^ Data {
   Data^ get();
}

Return Value

The data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Chart Class
Chart Members


Theme Property

[image]
Gizmox.WebGUI.Forms.Charts
Theme Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace > Chart Class : Theme Property

Gets or sets the theme.

Syntax

Visual Basic (Declaration)
Public Property Theme As ThemeTypes
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim value As ThemeTypes

instance.Theme = value

value = instance.Theme
C#
public ThemeTypes Theme {get; set;}
Managed Extensions for C++
public: __property ThemeTypes get_Theme();
public: __property void set_Theme(
   ThemeTypes value
);
C++/CLI
public:
property ThemeTypes Theme {
   ThemeTypes get();
   void set (ThemeTypesvalue);
}

Return Value

The theme.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Chart Class
Chart Members


Title Property

[image]
Gizmox.WebGUI.Forms.Charts
Title Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace > Chart Class : Title Property

Gets or sets the title.

Syntax

Visual Basic (Declaration)
Public Property Title As Title
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim value As Title

instance.Title = value

value = instance.Title
C#
public Title Title {get; set;}
Managed Extensions for C++
public: __property Title* get_Title();
public: __property void set_Title(
   Title* value
);
C++/CLI
public:
property Title^ Title {
   Title^ get();
   void set (Title^value);
}

Return Value

The title.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Chart Class
Chart Members


View3D Property

[image]
Gizmox.WebGUI.Forms.Charts
View3D Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace > Chart Class : View3D Property

Gets or sets a value indicating whether view3 D is on.

Syntax

Visual Basic (Declaration)
Public Property View3D As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Chart
Dim value As Boolean

instance.View3D = value

value = instance.View3D
C#
public bool View3D {get; set;}
Managed Extensions for C++
public: __property bool get_View3D();
public: __property void set_View3D(
   bool value
);
C++/CLI
public:
property bool View3D {
   bool get();
   void set (boolvalue);
}

Return Value

true if [view3 D]; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Chart Class
Chart Members


Data Class

[image]
Gizmox.WebGUI.Forms.Charts
Data Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace : Data Class

Object Model

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class Data
   Implements IChartData
Visual Basic (Usage) Copy Code
Dim instance As Data
C#
[DefaultMemberAttribute("Item")]
public class Data : IChartData
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
public __gc class Data : public IChartData
C++/CLI
[DefaultMemberAttribute("Item")]
public ref class Data : public IChartData

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.Charts.Data

Requirements

Namespace: Gizmox.WebGUI.Forms.Charts

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms.Charts (in Gizmox.WebGUI.Forms.Charts.dll)

See Also

Reference

Data Members
Gizmox.WebGUI.Forms.Charts Namespace


Data Class Members

[image]
Gizmox.WebGUI.Forms.Charts
Data Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace : Data Class

The following tables list the members exposed by Data.

Public Properties

 | Name | Description
Public Property | Count |
Public Property | IsReadOnly |
Public Property | Item |
Top

Public Methods

 | Name | Description
Public Method | Add |
Public Method | Clear |
Public Method | Contains |
Public Method | CopyTo |
Public Method | GetChartDataXML | Gets the chart data XML.
Public Method | GetEnumerator |
Public Method | Remove |
Top

See Also

Reference

Data Class
Gizmox.WebGUI.Forms.Charts Namespace


Data Class Methods

[image]
Gizmox.WebGUI.Forms.Charts
Data Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace : Data Class

For a list of all members of this type, see Data members.

Public Methods

 | Name | Description
Public Method | Add |
Public Method | Clear |
Public Method | Contains |
Public Method | CopyTo |
Public Method | GetChartDataXML | Gets the chart data XML.
Public Method | GetEnumerator |
Public Method | Remove |
Top

See Also

Reference

Data Class
Gizmox.WebGUI.Forms.Charts Namespace


Add Method

[image]
Gizmox.WebGUI.Forms.Charts
Add Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace > Data Class : Add Method

item

Syntax

Visual Basic (Declaration)
Public Sub Add( _
   ByVal item As DataSeries _
)
Visual Basic (Usage) Copy Code
Dim instance As Data
Dim item As DataSeries

instance.Add(item)
C#
public void Add(
   DataSeries item
)
Managed Extensions for C++
public: void Add(
   DataSeries* item
)
C++/CLI
public:
void Add(
   DataSeries^ item
)

Parameters

item

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Data Class
Data Members


Clear Method

[image]
Gizmox.WebGUI.Forms.Charts
Clear Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace > Data Class : Clear Method

Syntax

Visual Basic (Declaration)
Public Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As Data

instance.Clear()
C#
public void Clear()
Managed Extensions for C++
public: void Clear();
C++/CLI
public:
void Clear();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Data Class
Data Members


Contains Method

[image]
Gizmox.WebGUI.Forms.Charts
Contains Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace > Data Class : Contains Method

item

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal item As DataSeries _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Data
Dim item As DataSeries
Dim value As Boolean

value = instance.Contains(item)
C#
public bool Contains(
   DataSeries item
)
Managed Extensions for C++
public: bool Contains(
   DataSeries* item
)
C++/CLI
public:
bool Contains(
   DataSeries^ item
)

Parameters

item

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Data Class
Data Members


CopyTo Method

[image]
Gizmox.WebGUI.Forms.Charts
CopyTo Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace > Data Class : CopyTo Method

array
arrayIndex

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array() As DataSeries, _
   ByVal arrayIndex As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As Data
Dim array() As DataSeries
Dim arrayIndex As Integer

instance.CopyTo(array, arrayIndex)
C#
public void CopyTo(
   DataSeries[] array,
   int arrayIndex
)
Managed Extensions for C++
public: void CopyTo(
   DataSeries*[]* array,
   int arrayIndex
)
C++/CLI
public:
void CopyTo(
   array<DataSeries^>^ array,
   int arrayIndex
)

Parameters

array
arrayIndex

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Data Class
Data Members


GetChartDataXML Method

[image]
Gizmox.WebGUI.Forms.Charts
GetChartDataXML Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace > Data Class : GetChartDataXML Method

objWriter
The obj writer.
Gets the chart data XML.

Syntax

Visual Basic (Declaration)
Public Function GetChartDataXML( _
   ByVal objWriter As XmlTextWriter _
) As XmlTextWriter
Visual Basic (Usage) Copy Code
Dim instance As Data
Dim objWriter As XmlTextWriter
Dim value As XmlTextWriter

value = instance.GetChartDataXML(objWriter)
C#
public XmlTextWriter GetChartDataXML(
   XmlTextWriter objWriter
)
Managed Extensions for C++
public: XmlTextWriter* GetChartDataXML(
   XmlTextWriter* objWriter
)
C++/CLI
public:
XmlTextWriter^ GetChartDataXML(
   XmlTextWriter^ objWriter
)

Parameters

objWriter
The obj writer.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Data Class
Data Members


GetEnumerator Method

[image]
Gizmox.WebGUI.Forms.Charts
GetEnumerator Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace > Data Class : GetEnumerator Method

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator(Of DataSeries)
Visual Basic (Usage) Copy Code
Dim instance As Data
Dim value As IEnumerator(Of DataSeries)

value = instance.GetEnumerator()
C#
public IEnumerator<DataSeries> GetEnumerator()
Managed Extensions for C++
public: IEnumerator<DataSeries*>* GetEnumerator();
C++/CLI
public:
IEnumerator<DataSeries^>^ GetEnumerator();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Data Class
Data Members


Remove Method

[image]
Gizmox.WebGUI.Forms.Charts
Remove Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace > Data Class : Remove Method

item

Syntax

Visual Basic (Declaration)
Public Function Remove( _
   ByVal item As DataSeries _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Data
Dim item As DataSeries
Dim value As Boolean

value = instance.Remove(item)
C#
public bool Remove(
   DataSeries item
)
Managed Extensions for C++
public: bool Remove(
   DataSeries* item
)
C++/CLI
public:
bool Remove(
   DataSeries^ item
)

Parameters

item

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Data Class
Data Members


Data Class Properties

[image]
Gizmox.WebGUI.Forms.Charts
Data Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace : Data Class

For a list of all members of this type, see Data members.

Public Properties

 | Name | Description
Public Property | Count |
Public Property | IsReadOnly |
Public Property | Item |
Top

See Also

Reference

Data Class
Gizmox.WebGUI.Forms.Charts Namespace


Count Property

[image]
Gizmox.WebGUI.Forms.Charts
Count Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace > Data Class : Count Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As Data
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Data Class
Data Members


IsReadOnly Property

[image]
Gizmox.WebGUI.Forms.Charts
IsReadOnly Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace > Data Class : IsReadOnly Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsReadOnly As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Data
Dim value As Boolean

value = instance.IsReadOnly
C#
public bool IsReadOnly {get;}
Managed Extensions for C++
public: __property bool get_IsReadOnly();
C++/CLI
public:
property bool IsReadOnly {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Data Class
Data Members


Item Property

[image]
Gizmox.WebGUI.Forms.Charts
Item Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace > Data Class : Item Property

index

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal index As Integer _
) As DataSeries
Visual Basic (Usage) Copy Code
Dim instance As Data
Dim index As Integer
Dim value As DataSeries

instance.Item(index) = value

value = instance.Item(index)
C#
public DataSeries this[
   int index
]; {get; set;}
Managed Extensions for C++
public: __property DataSeries* get_Item(
   int index
);
public: __property void set_Item(
   int index,
   DataSeries* value
);
C++/CLI
public:
property DataSeries^ default [int] {
   DataSeries^ get(intindex);
   void set (intindex, DataSeries^value);
}

Parameters

index

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Data Class
Data Members


DataPoint Class

[image]
Gizmox.WebGUI.Forms.Charts
DataPoint Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace : DataPoint Class

Syntax

Visual Basic (Declaration)
Public Class DataPoint
   Implements IChartData
Visual Basic (Usage) Copy Code
Dim instance As DataPoint
C#
public class DataPoint : IChartData
Managed Extensions for C++
public __gc class DataPoint : public IChartData
C++/CLI
public ref class DataPoint : public IChartData

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.Charts.DataPoint

Requirements

Namespace: Gizmox.WebGUI.Forms.Charts

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms.Charts (in Gizmox.WebGUI.Forms.Charts.dll)

See Also

Reference

DataPoint Members
Gizmox.WebGUI.Forms.Charts Namespace


DataPoint Class Members

[image]
Gizmox.WebGUI.Forms.Charts
DataPoint Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace : DataPoint Class

The following tables list the members exposed by DataPoint.

Public Constructors

 | Name | Description
Public Constructor | DataPoint Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | AxisLabel | Gets or sets the axis label.
Public Property | XValue | Gets or sets the X value.
Public Property | YValue | Gets or sets the Y value.
Public Property | ZValue | Gets or sets the Z value.
Top

Public Methods

 | Name | Description
Public Method | GetChartDataXML | Gets the chart data XML.
Top

See Also

Reference

DataPoint Class
Gizmox.WebGUI.Forms.Charts Namespace


DataPoint Constructor

[image]
Gizmox.WebGUI.Forms.Charts
DataPoint Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace > DataPoint Class : DataPoint Constructor

Overload List

Overload | Description
DataPoint Constructor() |
DataPoint Constructor(String,Double) |
DataPoint Constructor(String,Double,Double) |
DataPoint Constructor(String,Double,Double,Double) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataPoint Class
DataPoint Members


DataPoint Constructor()

[image]
Gizmox.WebGUI.Forms.Charts
DataPoint Constructor()
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace > DataPoint Class > DataPoint Constructor : DataPoint Constructor()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As DataPoint()
C#
public DataPoint()
Managed Extensions for C++
public: DataPoint();
C++/CLI
public:
DataPoint();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataPoint Class
DataPoint Members
Overload List


DataPoint Constructor(String,Double)

[image]
Gizmox.WebGUI.Forms.Charts
DataPoint Constructor(String,Double)
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace > DataPoint Class > DataPoint Constructor : DataPoint Constructor(String,Double)

strAxisLabel
dblYValue

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal strAxisLabel As String, _
   ByVal dblYValue As Double _
)
Visual Basic (Usage) Copy Code
Dim strAxisLabel As String
Dim dblYValue As Double

Dim instance As DataPoint(strAxisLabel, dblYValue)
C#
public DataPoint(
   string strAxisLabel,
   double dblYValue
)
Managed Extensions for C++
public: DataPoint(
   string* strAxisLabel,
   double dblYValue
)
C++/CLI
public:
DataPoint(
   String^ strAxisLabel,
   double dblYValue
)

Parameters

strAxisLabel
dblYValue

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataPoint Class
DataPoint Members
Overload List


DataPoint Constructor(String,Double,Double)

[image]
Gizmox.WebGUI.Forms.Charts
DataPoint Constructor(String,Double,Double)
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace > DataPoint Class > DataPoint Constructor : DataPoint Constructor(String,Double,Double)

strAxisLabel
dblYValue
dblXValue

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal strAxisLabel As String, _
   ByVal dblYValue As Double, _
   ByVal dblXValue As Double _
)
Visual Basic (Usage) Copy Code
Dim strAxisLabel As String
Dim dblYValue As Double
Dim dblXValue As Double

Dim instance As DataPoint(strAxisLabel, dblYValue, dblXValue)
C#
public DataPoint(
   string strAxisLabel,
   double dblYValue,
   double dblXValue
)
Managed Extensions for C++
public: DataPoint(
   string* strAxisLabel,
   double dblYValue,
   double dblXValue
)
C++/CLI
public:
DataPoint(
   String^ strAxisLabel,
   double dblYValue,
   double dblXValue
)

Parameters

strAxisLabel
dblYValue
dblXValue

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataPoint Class
DataPoint Members
Overload List


DataPoint Constructor(String,Double,Double,Double)

[image]
Gizmox.WebGUI.Forms.Charts
DataPoint Constructor(String,Double,Double,Double)
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace > DataPoint Class > DataPoint Constructor : DataPoint Constructor(String,Double,Double,Double)

strAxisLabel
dblYValue
dblXValue
dblZValue

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal strAxisLabel As String, _
   ByVal dblYValue As Double, _
   ByVal dblXValue As Double, _
   ByVal dblZValue As Double _
)
Visual Basic (Usage) Copy Code
Dim strAxisLabel As String
Dim dblYValue As Double
Dim dblXValue As Double
Dim dblZValue As Double

Dim instance As DataPoint(strAxisLabel, dblYValue, dblXValue, dblZValue)
C#
public DataPoint(
   string strAxisLabel,
   double dblYValue,
   double dblXValue,
   double dblZValue
)
Managed Extensions for C++
public: DataPoint(
   string* strAxisLabel,
   double dblYValue,
   double dblXValue,
   double dblZValue
)
C++/CLI
public:
DataPoint(
   String^ strAxisLabel,
   double dblYValue,
   double dblXValue,
   double dblZValue
)

Parameters

strAxisLabel
dblYValue
dblXValue
dblZValue

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataPoint Class
DataPoint Members
Overload List


DataPoint Class Methods

[image]
Gizmox.WebGUI.Forms.Charts
DataPoint Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace : DataPoint Class

For a list of all members of this type, see DataPoint members.

Public Methods

 | Name | Description
Public Method | GetChartDataXML | Gets the chart data XML.
Top

See Also

Reference

DataPoint Class
Gizmox.WebGUI.Forms.Charts Namespace


GetChartDataXML Method

[image]
Gizmox.WebGUI.Forms.Charts
GetChartDataXML Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace > DataPoint Class : GetChartDataXML Method

objWriter
The obj writer.
Gets the chart data XML.

Syntax

Visual Basic (Declaration)
Public Function GetChartDataXML( _
   ByVal objWriter As XmlTextWriter _
) As XmlTextWriter
Visual Basic (Usage) Copy Code
Dim instance As DataPoint
Dim objWriter As XmlTextWriter
Dim value As XmlTextWriter

value = instance.GetChartDataXML(objWriter)
C#
public XmlTextWriter GetChartDataXML(
   XmlTextWriter objWriter
)
Managed Extensions for C++
public: XmlTextWriter* GetChartDataXML(
   XmlTextWriter* objWriter
)
C++/CLI
public:
XmlTextWriter^ GetChartDataXML(
   XmlTextWriter^ objWriter
)

Parameters

objWriter
The obj writer.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataPoint Class
DataPoint Members


DataPoint Class Properties

[image]
Gizmox.WebGUI.Forms.Charts
DataPoint Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace : DataPoint Class

For a list of all members of this type, see DataPoint members.

Public Properties

 | Name | Description
Public Property | AxisLabel | Gets or sets the axis label.
Public Property | XValue | Gets or sets the X value.
Public Property | YValue | Gets or sets the Y value.
Public Property | ZValue | Gets or sets the Z value.
Top

See Also

Reference

DataPoint Class
Gizmox.WebGUI.Forms.Charts Namespace


AxisLabel Property

[image]
Gizmox.WebGUI.Forms.Charts
AxisLabel Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace > DataPoint Class : AxisLabel Property

Gets or sets the axis label.

Syntax

Visual Basic (Declaration)
Public Property AxisLabel As String
Visual Basic (Usage) Copy Code
Dim instance As DataPoint
Dim value As String

instance.AxisLabel = value

value = instance.AxisLabel
C#
public string AxisLabel {get; set;}
Managed Extensions for C++
public: __property string* get_AxisLabel();
public: __property void set_AxisLabel(
   string* value
);
C++/CLI
public:
property String^ AxisLabel {
   String^ get();
   void set (String^value);
}

Return Value

The axis label.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataPoint Class
DataPoint Members


XValue Property

[image]
Gizmox.WebGUI.Forms.Charts
XValue Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace > DataPoint Class : XValue Property

Gets or sets the X value.

Syntax

Visual Basic (Declaration)
Public Property XValue As Double
Visual Basic (Usage) Copy Code
Dim instance As DataPoint
Dim value As Double

instance.XValue = value

value = instance.XValue
C#
public double XValue {get; set;}
Managed Extensions for C++
public: __property double get_XValue();
public: __property void set_XValue(
   double value
);
C++/CLI
public:
property double XValue {
   double get();
   void set (doublevalue);
}

Return Value

The X value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataPoint Class
DataPoint Members


YValue Property

[image]
Gizmox.WebGUI.Forms.Charts
YValue Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace > DataPoint Class : YValue Property

Gets or sets the Y value.

Syntax

Visual Basic (Declaration)
Public Property YValue As Double
Visual Basic (Usage) Copy Code
Dim instance As DataPoint
Dim value As Double

instance.YValue = value

value = instance.YValue
C#
public double YValue {get; set;}
Managed Extensions for C++
public: __property double get_YValue();
public: __property void set_YValue(
   double value
);
C++/CLI
public:
property double YValue {
   double get();
   void set (doublevalue);
}

Return Value

The Y value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataPoint Class
DataPoint Members


ZValue Property

[image]
Gizmox.WebGUI.Forms.Charts
ZValue Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace > DataPoint Class : ZValue Property

Gets or sets the Z value.

Syntax

Visual Basic (Declaration)
Public Property ZValue As Double
Visual Basic (Usage) Copy Code
Dim instance As DataPoint
Dim value As Double

instance.ZValue = value

value = instance.ZValue
C#
public double ZValue {get; set;}
Managed Extensions for C++
public: __property double get_ZValue();
public: __property void set_ZValue(
   double value
);
C++/CLI
public:
property double ZValue {
   double get();
   void set (doublevalue);
}

Return Value

The Z value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataPoint Class
DataPoint Members


DataSeries Class

[image]
Gizmox.WebGUI.Forms.Charts
DataSeries Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace : DataSeries Class

Object Model

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class DataSeries
   Implements IChartData
Visual Basic (Usage) Copy Code
Dim instance As DataSeries
C#
[DefaultMemberAttribute("Item")]
public class DataSeries : IChartData
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
public __gc class DataSeries : public IChartData
C++/CLI
[DefaultMemberAttribute("Item")]
public ref class DataSeries : public IChartData

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.Charts.DataSeries

Requirements

Namespace: Gizmox.WebGUI.Forms.Charts

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms.Charts (in Gizmox.WebGUI.Forms.Charts.dll)

See Also

Reference

DataSeries Members
Gizmox.WebGUI.Forms.Charts Namespace


DataSeries Class Members

[image]
Gizmox.WebGUI.Forms.Charts
DataSeries Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace : DataSeries Class

The following tables list the members exposed by DataSeries.

Public Constructors

 | Name | Description
Public Constructor | DataSeries Constructor |
Top

Public Properties

 | Name | Description
Public Property | Count |
Public Property | IsReadOnly |
Public Property | Item |
Public Property | LabelEnabled | Gets or sets a value indicating whether the label is enabled.
Public Property | MarkerScale | Gets or sets the marker scale. Should be between 0-1.0
Public Property | Name | Gets or sets the name.
Public Property | Opacity | Gets or sets the opacity. Should be between 0-1.0
Public Property | RenderAs | Gets or sets the render as property(Data chart type).
Public Property | ToolTipText | Gets or sets the tool tip text.
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded.
Public Method | Clear |
Public Method | Contains |
Public Method | CopyTo |
Public Method | GetChartDataXML | Gets the chart data XML.
Public Method | GetEnumerator |
Public Method | Remove |
Top

See Also

Reference

DataSeries Class
Gizmox.WebGUI.Forms.Charts Namespace


DataSeries Constructor

[image]
Gizmox.WebGUI.Forms.Charts
DataSeries Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace > DataSeries Class : DataSeries Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As DataSeries()
C#
public DataSeries()
Managed Extensions for C++
public: DataSeries();
C++/CLI
public:
DataSeries();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataSeries Class
DataSeries Members


DataSeries Class Methods

[image]
Gizmox.WebGUI.Forms.Charts
DataSeries Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace : DataSeries Class

For a list of all members of this type, see DataSeries members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded.
Public Method | Clear |
Public Method | Contains |
Public Method | CopyTo |
Public Method | GetChartDataXML | Gets the chart data XML.
Public Method | GetEnumerator |
Public Method | Remove |
Top

See Also

Reference

DataSeries Class
Gizmox.WebGUI.Forms.Charts Namespace


Add Method

[image]
Gizmox.WebGUI.Forms.Charts
Add Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace > DataSeries Class : Add Method

Overload List

Overload | Description
Add(DataPoint) |
Add(String,Double) |
Add(String,Double,Double) |
Add(String,Double,Double,Double) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataSeries Class
DataSeries Members


Add(DataPoint) Method

[image]
Gizmox.WebGUI.Forms.Charts
Add(DataPoint) Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace > DataSeries Class > Add Method : Add(DataPoint) Method

item

Syntax

Visual Basic (Declaration)
Public Overloads Sub Add( _
   ByVal item As DataPoint _
)
Visual Basic (Usage) Copy Code
Dim instance As DataSeries
Dim item As DataPoint

instance.Add(item)
C#
public void Add(
   DataPoint item
)
Managed Extensions for C++
public: void Add(
   DataPoint* item
)
C++/CLI
public:
void Add(
   DataPoint^ item
)

Parameters

item

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataSeries Class
DataSeries Members
Overload List


Add(String,Double) Method

[image]
Gizmox.WebGUI.Forms.Charts
Add(String,Double) Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace > DataSeries Class > Add Method : Add(String,Double) Method

strAxisLabel
dblYValue

Syntax

Visual Basic (Declaration)
Public Overloads Sub Add( _
   ByVal strAxisLabel As String, _
   ByVal dblYValue As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As DataSeries
Dim strAxisLabel As String
Dim dblYValue As Double

instance.Add(strAxisLabel, dblYValue)
C#
public void Add(
   string strAxisLabel,
   double dblYValue
)
Managed Extensions for C++
public: void Add(
   string* strAxisLabel,
   double dblYValue
)
C++/CLI
public:
void Add(
   String^ strAxisLabel,
   double dblYValue
)

Parameters

strAxisLabel
dblYValue

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataSeries Class
DataSeries Members
Overload List


Add(String,Double,Double) Method

[image]
Gizmox.WebGUI.Forms.Charts
Add(String,Double,Double) Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace > DataSeries Class > Add Method : Add(String,Double,Double) Method

strAxisLabel
dblYValue
dblXValue

Syntax

Visual Basic (Declaration)
Public Overloads Sub Add( _
   ByVal strAxisLabel As String, _
   ByVal dblYValue As Double, _
   ByVal dblXValue As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As DataSeries
Dim strAxisLabel As String
Dim dblYValue As Double
Dim dblXValue As Double

instance.Add(strAxisLabel, dblYValue, dblXValue)
C#
public void Add(
   string strAxisLabel,
   double dblYValue,
   double dblXValue
)
Managed Extensions for C++
public: void Add(
   string* strAxisLabel,
   double dblYValue,
   double dblXValue
)
C++/CLI
public:
void Add(
   String^ strAxisLabel,
   double dblYValue,
   double dblXValue
)

Parameters

strAxisLabel
dblYValue
dblXValue

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataSeries Class
DataSeries Members
Overload List


Add(String,Double,Double,Double) Method

[image]
Gizmox.WebGUI.Forms.Charts
Add(String,Double,Double,Double) Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace > DataSeries Class > Add Method : Add(String,Double,Double,Double) Method

strAxisLabel
dblYValue
dblXValue
dblZValue

Syntax

Visual Basic (Declaration)
Public Overloads Sub Add( _
   ByVal strAxisLabel As String, _
   ByVal dblYValue As Double, _
   ByVal dblXValue As Double, _
   ByVal dblZValue As Double _
)
Visual Basic (Usage) Copy Code
Dim instance As DataSeries
Dim strAxisLabel As String
Dim dblYValue As Double
Dim dblXValue As Double
Dim dblZValue As Double

instance.Add(strAxisLabel, dblYValue, dblXValue, dblZValue)
C#
public void Add(
   string strAxisLabel,
   double dblYValue,
   double dblXValue,
   double dblZValue
)
Managed Extensions for C++
public: void Add(
   string* strAxisLabel,
   double dblYValue,
   double dblXValue,
   double dblZValue
)
C++/CLI
public:
void Add(
   String^ strAxisLabel,
   double dblYValue,
   double dblXValue,
   double dblZValue
)

Parameters

strAxisLabel
dblYValue
dblXValue
dblZValue

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataSeries Class
DataSeries Members
Overload List


Clear Method

[image]
Gizmox.WebGUI.Forms.Charts
Clear Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace > DataSeries Class : Clear Method

Syntax

Visual Basic (Declaration)
Public Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As DataSeries

instance.Clear()
C#
public void Clear()
Managed Extensions for C++
public: void Clear();
C++/CLI
public:
void Clear();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataSeries Class
DataSeries Members


Contains Method

[image]
Gizmox.WebGUI.Forms.Charts
Contains Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace > DataSeries Class : Contains Method

item

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal item As DataPoint _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataSeries
Dim item As DataPoint
Dim value As Boolean

value = instance.Contains(item)
C#
public bool Contains(
   DataPoint item
)
Managed Extensions for C++
public: bool Contains(
   DataPoint* item
)
C++/CLI
public:
bool Contains(
   DataPoint^ item
)

Parameters

item

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataSeries Class
DataSeries Members


CopyTo Method

[image]
Gizmox.WebGUI.Forms.Charts
CopyTo Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace > DataSeries Class : CopyTo Method

array
arrayIndex

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array() As DataPoint, _
   ByVal arrayIndex As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As DataSeries
Dim array() As DataPoint
Dim arrayIndex As Integer

instance.CopyTo(array, arrayIndex)
C#
public void CopyTo(
   DataPoint[] array,
   int arrayIndex
)
Managed Extensions for C++
public: void CopyTo(
   DataPoint*[]* array,
   int arrayIndex
)
C++/CLI
public:
void CopyTo(
   array<DataPoint^>^ array,
   int arrayIndex
)

Parameters

array
arrayIndex

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataSeries Class
DataSeries Members


GetChartDataXML Method

[image]
Gizmox.WebGUI.Forms.Charts
GetChartDataXML Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace > DataSeries Class : GetChartDataXML Method

objWriter
The obj writer.
Gets the chart data XML.

Syntax

Visual Basic (Declaration)
Public Function GetChartDataXML( _
   ByVal objWriter As XmlTextWriter _
) As XmlTextWriter
Visual Basic (Usage) Copy Code
Dim instance As DataSeries
Dim objWriter As XmlTextWriter
Dim value As XmlTextWriter

value = instance.GetChartDataXML(objWriter)
C#
public XmlTextWriter GetChartDataXML(
   XmlTextWriter objWriter
)
Managed Extensions for C++
public: XmlTextWriter* GetChartDataXML(
   XmlTextWriter* objWriter
)
C++/CLI
public:
XmlTextWriter^ GetChartDataXML(
   XmlTextWriter^ objWriter
)

Parameters

objWriter
The obj writer.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataSeries Class
DataSeries Members


GetEnumerator Method

[image]
Gizmox.WebGUI.Forms.Charts
GetEnumerator Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace > DataSeries Class : GetEnumerator Method

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator(Of DataPoint)
Visual Basic (Usage) Copy Code
Dim instance As DataSeries
Dim value As IEnumerator(Of DataPoint)

value = instance.GetEnumerator()
C#
public IEnumerator<DataPoint> GetEnumerator()
Managed Extensions for C++
public: IEnumerator<DataPoint*>* GetEnumerator();
C++/CLI
public:
IEnumerator<DataPoint^>^ GetEnumerator();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataSeries Class
DataSeries Members


Remove Method

[image]
Gizmox.WebGUI.Forms.Charts
Remove Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace > DataSeries Class : Remove Method

item

Syntax

Visual Basic (Declaration)
Public Function Remove( _
   ByVal item As DataPoint _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataSeries
Dim item As DataPoint
Dim value As Boolean

value = instance.Remove(item)
C#
public bool Remove(
   DataPoint item
)
Managed Extensions for C++
public: bool Remove(
   DataPoint* item
)
C++/CLI
public:
bool Remove(
   DataPoint^ item
)

Parameters

item

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataSeries Class
DataSeries Members


DataSeries Class Properties

[image]
Gizmox.WebGUI.Forms.Charts
DataSeries Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace : DataSeries Class

For a list of all members of this type, see DataSeries members.

Public Properties

 | Name | Description
Public Property | Count |
Public Property | IsReadOnly |
Public Property | Item |
Public Property | LabelEnabled | Gets or sets a value indicating whether the label is enabled.
Public Property | MarkerScale | Gets or sets the marker scale. Should be between 0-1.0
Public Property | Name | Gets or sets the name.
Public Property | Opacity | Gets or sets the opacity. Should be between 0-1.0
Public Property | RenderAs | Gets or sets the render as property(Data chart type).
Public Property | ToolTipText | Gets or sets the tool tip text.
Top

See Also

Reference

DataSeries Class
Gizmox.WebGUI.Forms.Charts Namespace


Count Property

[image]
Gizmox.WebGUI.Forms.Charts
Count Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace > DataSeries Class : Count Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As DataSeries
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataSeries Class
DataSeries Members


IsReadOnly Property

[image]
Gizmox.WebGUI.Forms.Charts
IsReadOnly Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace > DataSeries Class : IsReadOnly Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsReadOnly As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataSeries
Dim value As Boolean

value = instance.IsReadOnly
C#
public bool IsReadOnly {get;}
Managed Extensions for C++
public: __property bool get_IsReadOnly();
C++/CLI
public:
property bool IsReadOnly {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataSeries Class
DataSeries Members


Item Property

[image]
Gizmox.WebGUI.Forms.Charts
Item Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace > DataSeries Class : Item Property

index

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal index As Integer _
) As DataPoint
Visual Basic (Usage) Copy Code
Dim instance As DataSeries
Dim index As Integer
Dim value As DataPoint

instance.Item(index) = value

value = instance.Item(index)
C#
public DataPoint this[
   int index
]; {get; set;}
Managed Extensions for C++
public: __property DataPoint* get_Item(
   int index
);
public: __property void set_Item(
   int index,
   DataPoint* value
);
C++/CLI
public:
property DataPoint^ default [int] {
   DataPoint^ get(intindex);
   void set (intindex, DataPoint^value);
}

Parameters

index

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataSeries Class
DataSeries Members


LabelEnabled Property

[image]
Gizmox.WebGUI.Forms.Charts
LabelEnabled Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace > DataSeries Class : LabelEnabled Property

Gets or sets a value indicating whether the label is enabled.

Syntax

Visual Basic (Declaration)
Public Property LabelEnabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DataSeries
Dim value As Boolean

instance.LabelEnabled = value

value = instance.LabelEnabled
C#
public bool LabelEnabled {get; set;}
Managed Extensions for C++
public: __property bool get_LabelEnabled();
public: __property void set_LabelEnabled(
   bool value
);
C++/CLI
public:
property bool LabelEnabled {
   bool get();
   void set (boolvalue);
}

Return Value

true if [label enabled]; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataSeries Class
DataSeries Members


MarkerScale Property

[image]
Gizmox.WebGUI.Forms.Charts
MarkerScale Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace > DataSeries Class : MarkerScale Property

Gets or sets the marker scale. Should be between 0-1.0

Syntax

Visual Basic (Declaration)
Public Property MarkerScale As Double
Visual Basic (Usage) Copy Code
Dim instance As DataSeries
Dim value As Double

instance.MarkerScale = value

value = instance.MarkerScale
C#
public double MarkerScale {get; set;}
Managed Extensions for C++
public: __property double get_MarkerScale();
public: __property void set_MarkerScale(
   double value
);
C++/CLI
public:
property double MarkerScale {
   double get();
   void set (doublevalue);
}

Return Value

The marker scale.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataSeries Class
DataSeries Members


Name Property

[image]
Gizmox.WebGUI.Forms.Charts
Name Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace > DataSeries Class : Name Property

Gets or sets the name.

Syntax

Visual Basic (Declaration)
Public Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As DataSeries
Dim value As String

instance.Name = value

value = instance.Name
C#
public string Name {get; set;}
Managed Extensions for C++
public: __property string* get_Name();
public: __property void set_Name(
   string* value
);
C++/CLI
public:
property String^ Name {
   String^ get();
   void set (String^value);
}

Return Value

The name.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataSeries Class
DataSeries Members


Opacity Property

[image]
Gizmox.WebGUI.Forms.Charts
Opacity Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace > DataSeries Class : Opacity Property

Gets or sets the opacity. Should be between 0-1.0

Syntax

Visual Basic (Declaration)
Public Property Opacity As Double
Visual Basic (Usage) Copy Code
Dim instance As DataSeries
Dim value As Double

instance.Opacity = value

value = instance.Opacity
C#
public double Opacity {get; set;}
Managed Extensions for C++
public: __property double get_Opacity();
public: __property void set_Opacity(
   double value
);
C++/CLI
public:
property double Opacity {
   double get();
   void set (doublevalue);
}

Return Value

The opacity.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataSeries Class
DataSeries Members


RenderAs Property

[image]
Gizmox.WebGUI.Forms.Charts
RenderAs Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace > DataSeries Class : RenderAs Property

Gets or sets the render as property(Data chart type).

Syntax

Visual Basic (Declaration)
Public Property RenderAs As DisplayTypes
Visual Basic (Usage) Copy Code
Dim instance As DataSeries
Dim value As DisplayTypes

instance.RenderAs = value

value = instance.RenderAs
C#
public DisplayTypes RenderAs {get; set;}
Managed Extensions for C++
public: __property DisplayTypes get_RenderAs();
public: __property void set_RenderAs(
   DisplayTypes value
);
C++/CLI
public:
property DisplayTypes RenderAs {
   DisplayTypes get();
   void set (DisplayTypesvalue);
}

Return Value

The render as.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataSeries Class
DataSeries Members


ToolTipText Property

[image]
Gizmox.WebGUI.Forms.Charts
ToolTipText Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace > DataSeries Class : ToolTipText Property

Gets or sets the tool tip text.

Syntax

Visual Basic (Declaration)
Public Property ToolTipText As String
Visual Basic (Usage) Copy Code
Dim instance As DataSeries
Dim value As String

instance.ToolTipText = value

value = instance.ToolTipText
C#
public string ToolTipText {get; set;}
Managed Extensions for C++
public: __property string* get_ToolTipText();
public: __property void set_ToolTipText(
   string* value
);
C++/CLI
public:
property String^ ToolTipText {
   String^ get();
   void set (String^value);
}

Return Value

The tool tip text.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

DataSeries Class
DataSeries Members


Title Class

[image]
Gizmox.WebGUI.Forms.Charts
Title Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace : Title Class

Object Model

Syntax

Visual Basic (Declaration)
Public Class Title
   Inherits TitleBase
   Implements IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IChartData, IBindableComponent, IArrangedElement
Visual Basic (Usage) Copy Code
Dim instance As Title
C#
public class Title : TitleBase, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IChartData, IBindableComponent, IArrangedElement
Managed Extensions for C++
public __gc class Title : public TitleBase, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IChartData, IBindableComponent, IArrangedElement
C++/CLI
public ref class Title : public TitleBase, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IChartData, IBindableComponent, IArrangedElement

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.Charts.TitleBase
Gizmox.WebGUI.Forms.Charts.Title

Requirements

Namespace: Gizmox.WebGUI.Forms.Charts

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms.Charts (in Gizmox.WebGUI.Forms.Charts.dll)

See Also

Reference

Title Members
Gizmox.WebGUI.Forms.Charts Namespace


Title Class Members

[image]
Gizmox.WebGUI.Forms.Charts
Title Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace : Title Class

The following tables list the members exposed by Title.

Public Constructors

 | Name | Description
Public Constructor | Title Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | AlignmentX | Gets or sets the alignment X. (Inherited from TitleBase)
Public Property | AlignmentY | Gets or sets the alignment Y. (Inherited from TitleBase)
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackColor | Gets or sets the background color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BindingContext | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Container | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Context | Gets the context. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | FontSize | Gets or sets the size of the font. (Inherited from TitleBase)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Form | Gets the owner form. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Height | Gets/Sets the height position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | IsRegistered | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Left | Gets/Sets the left position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Location | Gets or sets the control location. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Right | Gets/Sets the right position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Site | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from TitleBase)
Public Property | Top | Gets/Sets the top position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Visible | Gets or sets the control visability. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Width | Gets/Sets the width position (Inherited from Gizmox.WebGUI.Forms.Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultBorderColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultBorderStyle | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultForeColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMargin | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultPadding | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DesignMode | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | Events | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | IsConnected | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Property | IsDelayedDrawing | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | Session | Gets the application object. (Inherited from Gizmox.WebGUI.Forms.Component)
Top

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Focus | Sets focus to this control (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | GetChartDataXML | Gets the chart data XML.
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | GetPreferredSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | ResetText | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SendToBack | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Show | Displays the control to the user. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ToString | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Update | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | Finalize | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCommandText | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetImage | Gets the image. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetPreferredSizeCore | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetService | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | InvokeMethod | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | IsDirty | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBindingContextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnControlAdded | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnControlRemoved | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | OnEnabledChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnGotFocus | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLostFocus | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentVisibleChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnResize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnTextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnUnregisterComponents | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnValidated | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnValidating | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ProcessGatewayRequest | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RegisterSelf | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | RenderAttributes | Renders the controls meta attributes (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderClientUpdateHandler | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderComponentEventAttributes | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetImage | Sets the image. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeText | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | UnRegisterBatch | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | UnRegisterSelf | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | UpdateParams | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Top

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Disposed | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Gizmox.WebGUI.Forms.Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Top

See Also

Reference

Title Class
Gizmox.WebGUI.Forms.Charts Namespace


Title Constructor

[image]
Gizmox.WebGUI.Forms.Charts
Title Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace > Title Class : Title Constructor

Overload List

Overload | Description
Title Constructor() |
Title Constructor(String) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Title Class
Title Members


Title Constructor()

[image]
Gizmox.WebGUI.Forms.Charts
Title Constructor()
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace > Title Class > Title Constructor : Title Constructor()

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As Title()
C#
public Title()
Managed Extensions for C++
public: Title();
C++/CLI
public:
Title();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Title Class
Title Members
Overload List


Title Constructor(String)

[image]
Gizmox.WebGUI.Forms.Charts
Title Constructor(String)
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace > Title Class > Title Constructor : Title Constructor(String)

strText

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal strText As String _
)
Visual Basic (Usage) Copy Code
Dim strText As String

Dim instance As Title(strText)
C#
public Title(
   string strText
)
Managed Extensions for C++
public: Title(
   string* strText
)
C++/CLI
public:
Title(
   String^ strText
)

Parameters

strText

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Title Class
Title Members
Overload List


Title Class Methods

[image]
Gizmox.WebGUI.Forms.Charts
Title Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace : Title Class

For a list of all members of this type, see Title members.

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Focus | Sets focus to this control (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | GetChartDataXML | Gets the chart data XML.
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | GetPreferredSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | ResetText | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SendToBack | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Show | Displays the control to the user. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ToString | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Update | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | Finalize | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCommandText | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetImage | Gets the image. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetPreferredSizeCore | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetService | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | InvokeMethod | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | IsDirty | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBindingContextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnControlAdded | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnControlRemoved | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | OnEnabledChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnGotFocus | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLostFocus | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentVisibleChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnResize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnTextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnUnregisterComponents | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnValidated | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnValidating | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ProcessGatewayRequest | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RegisterSelf | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | RenderAttributes | Renders the controls meta attributes (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderClientUpdateHandler | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderComponentEventAttributes | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetImage | Sets the image. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeText | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | UnRegisterBatch | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | UnRegisterSelf | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | UpdateParams | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Top

See Also

Reference

Title Class
Gizmox.WebGUI.Forms.Charts Namespace


GetChartDataXML Method

[image]
Gizmox.WebGUI.Forms.Charts
GetChartDataXML Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace > Title Class : GetChartDataXML Method

objWriter
The obj writer.
Gets the chart data XML.

Syntax

Visual Basic (Declaration)
Public Function GetChartDataXML( _
   ByVal objWriter As XmlTextWriter _
) As XmlTextWriter
Visual Basic (Usage) Copy Code
Dim instance As Title
Dim objWriter As XmlTextWriter
Dim value As XmlTextWriter

value = instance.GetChartDataXML(objWriter)
C#
public XmlTextWriter GetChartDataXML(
   XmlTextWriter objWriter
)
Managed Extensions for C++
public: XmlTextWriter* GetChartDataXML(
   XmlTextWriter* objWriter
)
C++/CLI
public:
XmlTextWriter^ GetChartDataXML(
   XmlTextWriter^ objWriter
)

Parameters

objWriter
The obj writer.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

Title Class
Title Members


TitleBase Class

[image]
Gizmox.WebGUI.Forms.Charts
TitleBase Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace : TitleBase Class

Object Model

Syntax

Visual Basic (Declaration)
Public MustInherit Class TitleBase
   Inherits Control
   Implements IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Visual Basic (Usage) Copy Code
Dim instance As TitleBase
C#
public abstract class TitleBase : Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Managed Extensions for C++
public __gc abstract class TitleBase : public Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
C++/CLI
public ref class TitleBase abstract : public Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.Charts.TitleBase
Gizmox.WebGUI.Forms.Charts.Title

Requirements

Namespace: Gizmox.WebGUI.Forms.Charts

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms.Charts (in Gizmox.WebGUI.Forms.Charts.dll)

See Also

Reference

TitleBase Members
Gizmox.WebGUI.Forms.Charts Namespace


TitleBase Class Members

[image]
Gizmox.WebGUI.Forms.Charts
TitleBase Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace : TitleBase Class

The following tables list the members exposed by TitleBase.

Public Properties

 | Name | Description
Public Property | AlignmentX | Gets or sets the alignment X.
Public Property | AlignmentY | Gets or sets the alignment Y.
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackColor | Gets or sets the background color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BindingContext | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Container | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Context | Gets the context. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | FontSize | Gets or sets the size of the font.
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Form | Gets the owner form. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Height | Gets/Sets the height position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | IsRegistered | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Left | Gets/Sets the left position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Location | Gets or sets the control location. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Right | Gets/Sets the right position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Site | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Text | Gets or sets the text associated with this control.
Public Property | Top | Gets/Sets the top position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Visible | Gets or sets the control visability. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Width | Gets/Sets the width position (Inherited from Gizmox.WebGUI.Forms.Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultBorderColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultBorderStyle | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultForeColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMargin | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultPadding | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DesignMode | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | Events | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | IsConnected | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Property | IsDelayedDrawing | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | Session | Gets the application object. (Inherited from Gizmox.WebGUI.Forms.Component)
Top

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Focus | Sets focus to this control (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | GetPreferredSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | ResetText | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SendToBack | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Show | Displays the control to the user. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ToString | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Update | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | Finalize | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCommandText | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetImage | Gets the image. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetPreferredSizeCore | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetService | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | InvokeMethod | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | IsDirty | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBindingContextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnControlAdded | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnControlRemoved | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | OnEnabledChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnGotFocus | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLostFocus | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentVisibleChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnResize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnTextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnUnregisterComponents | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnValidated | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnValidating | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ProcessGatewayRequest | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RegisterSelf | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | RenderAttributes | Renders the controls meta attributes (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderClientUpdateHandler | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderComponentEventAttributes | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetImage | Sets the image. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeText | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | UnRegisterBatch | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | UnRegisterSelf | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | UpdateParams | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Top

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Disposed | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Gizmox.WebGUI.Forms.Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Top

See Also

Reference

TitleBase Class
Gizmox.WebGUI.Forms.Charts Namespace


TitleBase Class Properties

[image]
Gizmox.WebGUI.Forms.Charts
TitleBase Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace : TitleBase Class

For a list of all members of this type, see TitleBase members.

Public Properties

 | Name | Description
Public Property | AlignmentX | Gets or sets the alignment X.
Public Property | AlignmentY | Gets or sets the alignment Y.
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackColor | Gets or sets the background color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BindingContext | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Container | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Context | Gets the context. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | FontSize | Gets or sets the size of the font.
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Form | Gets the owner form. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Height | Gets/Sets the height position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | IsRegistered | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Left | Gets/Sets the left position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Location | Gets or sets the control location. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Right | Gets/Sets the right position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Site | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Text | Gets or sets the text associated with this control.
Public Property | Top | Gets/Sets the top position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Visible | Gets or sets the control visability. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Width | Gets/Sets the width position (Inherited from Gizmox.WebGUI.Forms.Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultBorderColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultBorderStyle | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultForeColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMargin | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultPadding | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DesignMode | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | Events | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | IsConnected | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Property | IsDelayedDrawing | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | Session | Gets the application object. (Inherited from Gizmox.WebGUI.Forms.Component)
Top

See Also

Reference

TitleBase Class
Gizmox.WebGUI.Forms.Charts Namespace


AlignmentX Property

[image]
Gizmox.WebGUI.Forms.Charts
AlignmentX Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace > TitleBase Class : AlignmentX Property

Gets or sets the alignment X.

Syntax

Visual Basic (Declaration)
Public Property AlignmentX As AlignmentX
Visual Basic (Usage) Copy Code
Dim instance As TitleBase
Dim value As AlignmentX

instance.AlignmentX = value

value = instance.AlignmentX
C#
public AlignmentX AlignmentX {get; set;}
Managed Extensions for C++
public: __property AlignmentX get_AlignmentX();
public: __property void set_AlignmentX(
   AlignmentX value
);
C++/CLI
public:
property AlignmentX AlignmentX {
   AlignmentX get();
   void set (AlignmentXvalue);
}

Return Value

The alignment X.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TitleBase Class
TitleBase Members


AlignmentY Property

[image]
Gizmox.WebGUI.Forms.Charts
AlignmentY Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace > TitleBase Class : AlignmentY Property

Gets or sets the alignment Y.

Syntax

Visual Basic (Declaration)
Public Property AlignmentY As AlignmentY
Visual Basic (Usage) Copy Code
Dim instance As TitleBase
Dim value As AlignmentY

instance.AlignmentY = value

value = instance.AlignmentY
C#
public AlignmentY AlignmentY {get; set;}
Managed Extensions for C++
public: __property AlignmentY get_AlignmentY();
public: __property void set_AlignmentY(
   AlignmentY value
);
C++/CLI
public:
property AlignmentY AlignmentY {
   AlignmentY get();
   void set (AlignmentYvalue);
}

Return Value

The alignment Y.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TitleBase Class
TitleBase Members


FontSize Property

[image]
Gizmox.WebGUI.Forms.Charts
FontSize Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace > TitleBase Class : FontSize Property

Gets or sets the size of the font.

Syntax

Visual Basic (Declaration)
Public Property FontSize As Double
Visual Basic (Usage) Copy Code
Dim instance As TitleBase
Dim value As Double

instance.FontSize = value

value = instance.FontSize
C#
public double FontSize {get; set;}
Managed Extensions for C++
public: __property double get_FontSize();
public: __property void set_FontSize(
   double value
);
C++/CLI
public:
property double FontSize {
   double get();
   void set (doublevalue);
}

Return Value

The size of the font.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TitleBase Class
TitleBase Members


Text Property

[image]
Gizmox.WebGUI.Forms.Charts
Text Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace > TitleBase Class : Text Property

Gets or sets the text associated with this control.

Syntax

Visual Basic (Declaration)
Public Property Text As String
Visual Basic (Usage) Copy Code
Dim instance As TitleBase
Dim value As String

instance.Text = value

value = instance.Text
C#
public string Text {get; set;}
Managed Extensions for C++
public: __property string* get_Text();
public: __property void set_Text(
   string* value
);
C++/CLI
public:
property String^ Text {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

TitleBase Class
TitleBase Members


AlignmentX Enumeration

[image]
Gizmox.WebGUI.Forms.Charts
AlignmentX Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace : AlignmentX Enumeration

Syntax

Visual Basic (Declaration)
Public Enum AlignmentX
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As AlignmentX
C#
public enum AlignmentX : Enum
Managed Extensions for C++
__value public enum AlignmentX : public Enum
C++/CLI
public enum class AlignmentX : public Enum

Members

Member | Description
Left |
Center |
Right |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.Charts.AlignmentX

Requirements

Namespace: Gizmox.WebGUI.Forms.Charts

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms.Charts (in Gizmox.WebGUI.Forms.Charts.dll)

See Also

Reference

Gizmox.WebGUI.Forms.Charts Namespace


AlignmentY Enumeration

[image]
Gizmox.WebGUI.Forms.Charts
AlignmentY Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace : AlignmentY Enumeration

Syntax

Visual Basic (Declaration)
Public Enum AlignmentY
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As AlignmentY
C#
public enum AlignmentY : Enum
Managed Extensions for C++
__value public enum AlignmentY : public Enum
C++/CLI
public enum class AlignmentY : public Enum

Members

Member | Description
Top |
Center |
Bottom |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.Charts.AlignmentY

Requirements

Namespace: Gizmox.WebGUI.Forms.Charts

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms.Charts (in Gizmox.WebGUI.Forms.Charts.dll)

See Also

Reference

Gizmox.WebGUI.Forms.Charts Namespace


AnimationTypes Enumeration

[image]
Gizmox.WebGUI.Forms.Charts
AnimationTypes Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace : AnimationTypes Enumeration

Syntax

Visual Basic (Declaration)
Public Enum AnimationTypes
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As AnimationTypes
C#
public enum AnimationTypes : Enum
Managed Extensions for C++
__value public enum AnimationTypes : public Enum
C++/CLI
public enum class AnimationTypes : public Enum

Members

Member | Description
Type1 |
Type2 |
Type3 |
Type4 |
Type5 |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.Charts.AnimationTypes

Requirements

Namespace: Gizmox.WebGUI.Forms.Charts

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms.Charts (in Gizmox.WebGUI.Forms.Charts.dll)

See Also

Reference

Gizmox.WebGUI.Forms.Charts Namespace


DisplayTypes Enumeration

[image]
Gizmox.WebGUI.Forms.Charts
DisplayTypes Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace : DisplayTypes Enumeration

Syntax

Visual Basic (Declaration)
Public Enum DisplayTypes
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As DisplayTypes
C#
public enum DisplayTypes : Enum
Managed Extensions for C++
__value public enum DisplayTypes : public Enum
C++/CLI
public enum class DisplayTypes : public Enum

Members

Member | Description
Area |
Bar |
Bubble |
Column |
Doughnut |
Stackedcolumn |
Line |
Pie |
Point |
StackedBar |
StackedBar100 |
Stackedcolumn100 |
StackedArea |
StackedArea100 |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.Charts.DisplayTypes

Requirements

Namespace: Gizmox.WebGUI.Forms.Charts

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms.Charts (in Gizmox.WebGUI.Forms.Charts.dll)

See Also

Reference

Gizmox.WebGUI.Forms.Charts Namespace


ThemeTypes Enumeration

[image]
Gizmox.WebGUI.Forms.Charts
ThemeTypes Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace : ThemeTypes Enumeration

Syntax

Visual Basic (Declaration)
Public Enum ThemeTypes
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As ThemeTypes
C#
public enum ThemeTypes : Enum
Managed Extensions for C++
__value public enum ThemeTypes : public Enum
C++/CLI
public enum class ThemeTypes : public Enum

Members

Member | Description
Theme1 |
Theme2 |
Theme3 |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.Charts.ThemeTypes

Requirements

Namespace: Gizmox.WebGUI.Forms.Charts

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms.Charts (in Gizmox.WebGUI.Forms.Charts.dll)

See Also

Reference

Gizmox.WebGUI.Forms.Charts Namespace


IChartData Interface

[image]
Gizmox.WebGUI.Forms.Charts
IChartData Interface
Members See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace : IChartData Interface

Syntax

Visual Basic (Declaration)
Public Interface IChartData
Visual Basic (Usage) Copy Code
Dim instance As IChartData
C#
public interface IChartData
Managed Extensions for C++
public __gc __interface IChartData
C++/CLI
public interface class IChartData

Requirements

Namespace: Gizmox.WebGUI.Forms.Charts

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms.Charts (in Gizmox.WebGUI.Forms.Charts.dll)

See Also

Reference

IChartData Members
Gizmox.WebGUI.Forms.Charts Namespace


IChartData Interface Members

[image]
Gizmox.WebGUI.Forms.Charts
IChartData Interface Members
See Also Methods Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace : IChartData Interface

The following tables list the members exposed by IChartData.

Public Methods

 | Name | Description
Method | GetChartDataXML |
Top

See Also

Reference

IChartData Interface
Gizmox.WebGUI.Forms.Charts Namespace


IChartData Interface Methods

[image]
Gizmox.WebGUI.Forms.Charts
IChartData Interface Methods
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace : IChartData Interface

For a list of all members of this type, see IChartData members.

Public Methods

 | Name | Description
Method | GetChartDataXML |
Top

See Also

Reference

IChartData Interface
Gizmox.WebGUI.Forms.Charts Namespace


GetChartDataXML Method

[image]
Gizmox.WebGUI.Forms.Charts
GetChartDataXML Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace > IChartData Interface : GetChartDataXML Method

objWriter

Syntax

Visual Basic (Declaration)
Function GetChartDataXML( _
   ByVal objWriter As XmlTextWriter _
) As XmlTextWriter
Visual Basic (Usage) Copy Code
Dim instance As IChartData
Dim objWriter As XmlTextWriter
Dim value As XmlTextWriter

value = instance.GetChartDataXML(objWriter)
C#
XmlTextWriter GetChartDataXML(
   XmlTextWriter objWriter
)
Managed Extensions for C++
XmlTextWriter* GetChartDataXML(
   XmlTextWriter* objWriter
)
C++/CLI
XmlTextWriter^ GetChartDataXML(
   XmlTextWriter^ objWriter
)

Parameters

objWriter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IChartData Interface
IChartData Members


Assembly Overview

Gizmox.WebGUI.Forms.Extended
Gizmox.WebGUI.Forms.Extended Assembly
See Also Send Feedback

Namespaces

Namespace | Description
Gizmox.WebGUI.Forms |
Gizmox.WebGUI.Forms.Editors |


Gizmox.WebGUI.Forms Namespace (Gizmox.WebGUI.Forms.Extended)

Gizmox.WebGUI.Forms.Extended
Gizmox.WebGUI.Forms Namespace (Gizmox.WebGUI.Forms.Extended)
See Also Inheritance Hierarchy Send Feedback

Classes

 | Class | Description
Class | SurfacePanel | Summary description for SurfacePanel
Class | WatermarkTextBox | Summary description for WatermarkTextBox
Class | WorkspaceTab | Represents a single tab page in a WorkspaceTabs.
Class | WorkspaceTabs | Manages a related set of tab pages.
Class | WorkspaceTabsCollection | Tab pages collection class

See Also

Reference

Gizmox.WebGUI.Forms.Extended Assembly


SurfacePanel Class

[image]
Gizmox.WebGUI.Forms.Extended
SurfacePanel Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : SurfacePanel Class

Summary description for SurfacePanel

Object Model

Syntax

Visual Basic (Declaration)
<ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableSurfacePanel, Gizmox.WebGUI.Silverlight.Controls.Extended, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="Surface")>
<ToolboxBitmapAttribute()>
<WebCompilerResourcesAttribute(Assembly=, Namespace="Gizmox.WebGUI.Forms.Extended")>
Public Class SurfacePanel
   Inherits Panel
   Implements IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IRequiredRegistration, IBindableComponent, IArrangedElement
Visual Basic (Usage) Copy Code
Dim instance As SurfacePanel
C#
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableSurfacePanel, Gizmox.WebGUI.Silverlight.Controls.Extended, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="Surface")]
[ToolboxBitmapAttribute()]
[WebCompilerResourcesAttribute(Assembly=, Namespace="Gizmox.WebGUI.Forms.Extended")]
public class SurfacePanel : Panel, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IRequiredRegistration, IBindableComponent, IArrangedElement
Managed Extensions for C++
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableSurfacePanel, Gizmox.WebGUI.Silverlight.Controls.Extended, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="Surface")]
[ToolboxBitmapAttribute()]
[WebCompilerResourcesAttribute(Assembly=, Namespace="Gizmox.WebGUI.Forms.Extended")]
public __gc class SurfacePanel : public Panel, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IRequiredRegistration, IBindableComponent, IArrangedElement
C++/CLI
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableSurfacePanel, Gizmox.WebGUI.Silverlight.Controls.Extended, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="Surface")]
[ToolboxBitmapAttribute()]
[WebCompilerResourcesAttribute(Assembly=, Namespace="Gizmox.WebGUI.Forms.Extended")]
public ref class SurfacePanel : public Panel, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IRequiredRegistration, IBindableComponent, IArrangedElement

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.ScrollableControl
Gizmox.WebGUI.Forms.Panel
Gizmox.WebGUI.Forms.SurfacePanel

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms.Extended (in Gizmox.WebGUI.Forms.Extended.dll)

See Also

Reference

SurfacePanel Members
Gizmox.WebGUI.Forms Namespace


SurfacePanel Class Members

[image]
Gizmox.WebGUI.Forms.Extended
SurfacePanel Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : SurfacePanel Class

The following tables list the members exposed by SurfacePanel.

Public Constructors

 | Name | Description
Public Constructor | SurfacePanel Constructor |
Top

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl)
Public Property | AutoSize | (Inherited from Panel)
Public Property | AutoSizeMode | Indicates the automatic sizing behavior of the control. (Inherited from Panel)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Gets a value indicating whether this control can recive focus. (Inherited from Panel)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text. (Inherited from Panel)
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Protected Property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl)
Top

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Control)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from ScrollableControl)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Control)
Protected Method | RenderAttributes | (Inherited from Panel)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | (Inherited from Panel)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializePanelType | (Inherited from Panel)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

SurfacePanel Class
Gizmox.WebGUI.Forms Namespace


SurfacePanel Constructor

[image]
Gizmox.WebGUI.Forms.Extended
SurfacePanel Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > SurfacePanel Class : SurfacePanel Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As SurfacePanel()
C#
public SurfacePanel()
Managed Extensions for C++
public: SurfacePanel();
C++/CLI
public:
SurfacePanel();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SurfacePanel Class
SurfacePanel Members


WatermarkTextBox Class

[image]
Gizmox.WebGUI.Forms.Extended
WatermarkTextBox Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : WatermarkTextBox Class

Summary description for WatermarkTextBox

Object Model

Syntax

Visual Basic (Declaration)
<ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableWatermarkTextBox, Gizmox.WebGUI.Silverlight.Controls.Extended, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="Watermark")>
<WebCompilerResourcesAttribute(Assembly=, Namespace="Gizmox.WebGUI.Forms.Extended")>
Public Class WatermarkTextBox
   Inherits TextBox
   Implements IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IRequiredRegistration, IBindableComponent, IArrangedElement
Visual Basic (Usage) Copy Code
Dim instance As WatermarkTextBox
C#
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableWatermarkTextBox, Gizmox.WebGUI.Silverlight.Controls.Extended, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="Watermark")]
[WebCompilerResourcesAttribute(Assembly=, Namespace="Gizmox.WebGUI.Forms.Extended")]
public class WatermarkTextBox : TextBox, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IRequiredRegistration, IBindableComponent, IArrangedElement
Managed Extensions for C++
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableWatermarkTextBox, Gizmox.WebGUI.Silverlight.Controls.Extended, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="Watermark")]
[WebCompilerResourcesAttribute(Assembly=, Namespace="Gizmox.WebGUI.Forms.Extended")]
public __gc class WatermarkTextBox : public TextBox, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IRequiredRegistration, IBindableComponent, IArrangedElement
C++/CLI
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableWatermarkTextBox, Gizmox.WebGUI.Silverlight.Controls.Extended, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="Watermark")]
[WebCompilerResourcesAttribute(Assembly=, Namespace="Gizmox.WebGUI.Forms.Extended")]
public ref class WatermarkTextBox : public TextBox, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IRequiredRegistration, IBindableComponent, IArrangedElement

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.TextBoxBase
Gizmox.WebGUI.Forms.TextBox
Gizmox.WebGUI.Forms.WatermarkTextBox

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms.Extended (in Gizmox.WebGUI.Forms.Extended.dll)

See Also

Reference

WatermarkTextBox Members
Gizmox.WebGUI.Forms Namespace


WatermarkTextBox Class Members

[image]
Gizmox.WebGUI.Forms.Extended
WatermarkTextBox Class Members
See Also Fields Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : WatermarkTextBox Class

The following tables list the members exposed by WatermarkTextBox.

Public Constructors

 | Name | Description
Public Constructor | WatermarkTextBox Constructor |
Top

Protected Fields

 | Name | Description
Protected Field | menmScrollBars | Member which holds the scrollbars mode. (Inherited from TextBox)
Top

Public Properties

 | Name | Description
Public Property | AcceptsReturn | Gets or sets a value indicating whether pressing ENTER in a multiline TextBox control creates a new line of text in the control or activates the default button for the form. (Inherited from TextBox)
Public Property | AcceptsTab | (Inherited from TextBoxBase)
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | (Inherited from TextBox)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | CanUndo | Gets a value indicating whether the user can undo the previous operation in a text box control. (Inherited from TextBox)
Public Property | CharacterCasing | Indicates if all characters should be left alone or converted to uppercase or lowercase (Inherited from TextBox)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DragTargets | Gets a value indicating whether this instance is dragable. (Inherited from TextBox)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Lines | (Inherited from TextBoxBase)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MaxLength | (Inherited from TextBoxBase)
Public Property | Message |
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Multiline | Gets or sets a value indicating whether text box is multi line. (Inherited from TextBoxBase)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PasswordChar | Gets or sets the password charecter. (Inherited from TextBox)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | ReadOnly | Gets or sets a value indicating whether [read only]. (Inherited from TextBoxBase)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | ScrollBars | Gets or sets which scroll bars should appear in a multiline TextBox control. (Inherited from TextBox)
Public Property | SelectedText | Gets or sets a value indicating the currently selected text in the control. (Inherited from TextBoxBase)
Public Property | SelectionLength | Gets or sets the number of characters selected in the text box. (Inherited from TextBoxBase)
Public Property | SelectionStart | Gets or sets the starting point of text selected in the text box. (Inherited from TextBoxBase)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Control)
Public Property | TextAlign | Gets or sets how text is aligned in a TextBox control. (Inherited from TextBox)
Public Property | TextLength | Gets the length of text in the control. (Inherited from TextBoxBase)
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | Validator | Gets or sets the text box validator. (Inherited from TextBox)
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Public Property | WordWrap | (Inherited from TextBoxBase)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from TextBox)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from TextBox)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

Public Methods

 | Name | Description
Public Method | AppendText | Appends text to the current text of a text box. (Inherited from TextBoxBase)
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Clear | Clears all text from the text box control. (Inherited from TextBoxBase)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | Copy | Copies the current selection in the text box to the Clipboard. (Inherited from TextBoxBase)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Cut | Moves the current selection in the text box to the Clipboard. (Inherited from TextBoxBase)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | Paste | Replaces the current selection in the text box with the contents of the Clipboard. (Inherited from TextBoxBase)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | ScrollToCaret | Scrolls the contents of the control to the current caret position. (Inherited from TextBoxBase)
Public Method | Select | Overloaded. Selects a range of text in the text box. (Inherited from TextBoxBase)
Public Method | SelectAll | Selects all text in the text box. (Inherited from TextBoxBase)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | Undo | Undoes the last edit operation in the text box. (Inherited from TextBox)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from TextBox)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetClipboardContent | Get content to be added to the clip board (Inherited from TextBox)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from TextBox)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from Control)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | InvokeSelection | Implements the actual client side selection (Inherited from TextBox)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Control)
Protected Method | RenderAttributes | Overridden.
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | Render control params (Inherited from TextBoxBase)
Protected Method | RenderValue | (Inherited from TextBox)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetClipboardContent | Set the value from the clip board (Inherited from TextBox)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | EnterKeyDown | Occurs on enter key down only on single line. (Inherited from TextBox)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

WatermarkTextBox Class
Gizmox.WebGUI.Forms Namespace


WatermarkTextBox Constructor

[image]
Gizmox.WebGUI.Forms.Extended
WatermarkTextBox Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > WatermarkTextBox Class : WatermarkTextBox Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As WatermarkTextBox()
C#
public WatermarkTextBox()
Managed Extensions for C++
public: WatermarkTextBox();
C++/CLI
public:
WatermarkTextBox();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WatermarkTextBox Class
WatermarkTextBox Members


WatermarkTextBox Class Methods

[image]
Gizmox.WebGUI.Forms.Extended
WatermarkTextBox Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : WatermarkTextBox Class

For a list of all members of this type, see WatermarkTextBox members.

Public Methods

 | Name | Description
Public Method | AppendText | Appends text to the current text of a text box. (Inherited from TextBoxBase)
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Clear | Clears all text from the text box control. (Inherited from TextBoxBase)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | Copy | Copies the current selection in the text box to the Clipboard. (Inherited from TextBoxBase)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Cut | Moves the current selection in the text box to the Clipboard. (Inherited from TextBoxBase)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | Paste | Replaces the current selection in the text box with the contents of the Clipboard. (Inherited from TextBoxBase)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | ScrollToCaret | Scrolls the contents of the control to the current caret position. (Inherited from TextBoxBase)
Public Method | Select | Overloaded. Selects a range of text in the text box. (Inherited from TextBoxBase)
Public Method | SelectAll | Selects all text in the text box. (Inherited from TextBoxBase)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | Undo | Undoes the last edit operation in the text box. (Inherited from TextBox)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from TextBox)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetClipboardContent | Get content to be added to the clip board (Inherited from TextBox)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from TextBox)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from Control)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | InvokeSelection | Implements the actual client side selection (Inherited from TextBox)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Control)
Protected Method | RenderAttributes | Overridden.
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | Render control params (Inherited from TextBoxBase)
Protected Method | RenderValue | (Inherited from TextBox)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetClipboardContent | Set the value from the clip board (Inherited from TextBox)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

See Also

Reference

WatermarkTextBox Class
Gizmox.WebGUI.Forms Namespace


RenderAttributes Method

[image]
Gizmox.WebGUI.Forms.Extended
RenderAttributes Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > WatermarkTextBox Class : RenderAttributes Method

context
writer

Syntax

Visual Basic (Declaration)
Protected Overrides Sub RenderAttributes( _
   ByVal context As IContext, _
   ByVal writer As IAttributeWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WatermarkTextBox
Dim context As IContext
Dim writer As IAttributeWriter

instance.RenderAttributes(context, writer)
C#
protected override void RenderAttributes(
   IContext context,
   IAttributeWriter writer
)
Managed Extensions for C++
protected: void RenderAttributes(
   IContext* context,
   IAttributeWriter* writer
) override
C++/CLI
protected:
void RenderAttributes(
   IContext^ context,
   IAttributeWriter^ writer
) override

Parameters

context
writer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WatermarkTextBox Class
WatermarkTextBox Members


WatermarkTextBox Class Properties

[image]
Gizmox.WebGUI.Forms.Extended
WatermarkTextBox Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : WatermarkTextBox Class

For a list of all members of this type, see WatermarkTextBox members.

Public Properties

 | Name | Description
Public Property | AcceptsReturn | Gets or sets a value indicating whether pressing ENTER in a multiline TextBox control creates a new line of text in the control or activates the default button for the form. (Inherited from TextBox)
Public Property | AcceptsTab | (Inherited from TextBoxBase)
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | (Inherited from TextBox)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | CanUndo | Gets a value indicating whether the user can undo the previous operation in a text box control. (Inherited from TextBox)
Public Property | CharacterCasing | Indicates if all characters should be left alone or converted to uppercase or lowercase (Inherited from TextBox)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DragTargets | Gets a value indicating whether this instance is dragable. (Inherited from TextBox)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Lines | (Inherited from TextBoxBase)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MaxLength | (Inherited from TextBoxBase)
Public Property | Message |
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Multiline | Gets or sets a value indicating whether text box is multi line. (Inherited from TextBoxBase)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PasswordChar | Gets or sets the password charecter. (Inherited from TextBox)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | ReadOnly | Gets or sets a value indicating whether [read only]. (Inherited from TextBoxBase)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | ScrollBars | Gets or sets which scroll bars should appear in a multiline TextBox control. (Inherited from TextBox)
Public Property | SelectedText | Gets or sets a value indicating the currently selected text in the control. (Inherited from TextBoxBase)
Public Property | SelectionLength | Gets or sets the number of characters selected in the text box. (Inherited from TextBoxBase)
Public Property | SelectionStart | Gets or sets the starting point of text selected in the text box. (Inherited from TextBoxBase)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Control)
Public Property | TextAlign | Gets or sets how text is aligned in a TextBox control. (Inherited from TextBox)
Public Property | TextLength | Gets the length of text in the control. (Inherited from TextBoxBase)
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | Validator | Gets or sets the text box validator. (Inherited from TextBox)
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Public Property | WordWrap | (Inherited from TextBoxBase)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from TextBox)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from TextBox)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

See Also

Reference

WatermarkTextBox Class
Gizmox.WebGUI.Forms Namespace


Message Property

[image]
Gizmox.WebGUI.Forms.Extended
Message Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > WatermarkTextBox Class : Message Property

Syntax

Visual Basic (Declaration)
Public Property Message As String
Visual Basic (Usage) Copy Code
Dim instance As WatermarkTextBox
Dim value As String

instance.Message = value

value = instance.Message
C#
public string Message {get; set;}
Managed Extensions for C++
public: __property string* get_Message();
public: __property void set_Message(
   string* value
);
C++/CLI
public:
property String^ Message {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WatermarkTextBox Class
WatermarkTextBox Members


WorkspaceTab Class

[image]
Gizmox.WebGUI.Forms.Extended
WorkspaceTab Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : WorkspaceTab Class

Represents a single tab page in a WorkspaceTabs.

Object Model

Syntax

Visual Basic (Declaration)
<DesignTimeControllerAttribute()>
<DefaultPropertyAttribute("Text")>
<ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")>
<ClientControllerAttribute()>
<DesignTimeVisibleAttribute()>
Public Class WorkspaceTab
   Inherits TabPage
   Implements IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Visual Basic (Usage) Copy Code
Dim instance As WorkspaceTab
C#
[DesignTimeControllerAttribute()]
[DefaultPropertyAttribute("Text")]
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
[ClientControllerAttribute()]
[DesignTimeVisibleAttribute()]
public class WorkspaceTab : TabPage, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Managed Extensions for C++
[DesignTimeControllerAttribute()]
[DefaultPropertyAttribute("Text")]
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
[ClientControllerAttribute()]
[DesignTimeVisibleAttribute()]
public __gc class WorkspaceTab : public TabPage, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
C++/CLI
[DesignTimeControllerAttribute()]
[DefaultPropertyAttribute("Text")]
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
[ClientControllerAttribute()]
[DesignTimeVisibleAttribute()]
public ref class WorkspaceTab : public TabPage, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.ScrollableControl
Gizmox.WebGUI.Forms.Panel
Gizmox.WebGUI.Forms.TabPage
Gizmox.WebGUI.Forms.WorkspaceTab

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms.Extended (in Gizmox.WebGUI.Forms.Extended.dll)

See Also

Reference

WorkspaceTab Members
Gizmox.WebGUI.Forms Namespace


WorkspaceTab Class Members

[image]
Gizmox.WebGUI.Forms.Extended
WorkspaceTab Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : WorkspaceTab Class

The following tables list the members exposed by WorkspaceTab.

Public Constructors

 | Name | Description
Public Constructor | WorkspaceTab Constructor | Overloaded. Initializes a new instance of the WorkspaceTab class.
Top

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl)
Public Property | AutoSize | (Inherited from Panel)
Public Property | AutoSizeMode | Indicates the automatic sizing behavior of the control. (Inherited from Panel)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Gets a value indicating whether this control can recive focus. (Inherited from Panel)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | Image | Gets or sets the image. (Inherited from TabPage)
Public Property | ImageIndex | Gets or sets the index of the image that is displayed for the item. (Inherited from TabPage)
Public Property | ImageKey | Gets or sets the key for the image that is displayed for the item. (Inherited from TabPage)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Loaded | Gets a value indicating whether this TabPage is loaded. (Inherited from TabPage)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | PanelType | Gets or sets the panel type. (Inherited from TabPage)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | TabControl | Gets the TabControl control. (Inherited from TabPage)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text to display on the tab. (Inherited from TabPage)
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | Visible | Gets or sets the control visability. (Inherited from TabPage)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Protected Property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl)
Top

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | CompareTo | Compares the current instance with another object of the same type. (Inherited from TabPage)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | Returns a string containing the value of the TabPage.Text property. (Inherited from TabPage)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Control)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from ScrollableControl)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Control)
Protected Method | RenderAttributes | Render control attributes (Inherited from TabPage)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from TabPage)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | (Inherited from Panel)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeImage | Shows the serialize image. (Inherited from TabPage)
Protected Method | ShouldSerializePanelType | (Inherited from Panel)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

WorkspaceTab Class
Gizmox.WebGUI.Forms Namespace


WorkspaceTab Constructor

[image]
Gizmox.WebGUI.Forms.Extended
WorkspaceTab Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > WorkspaceTab Class : WorkspaceTab Constructor

Initializes a new instance of the WorkspaceTab class.

Overload List

Overload | Description
WorkspaceTab Constructor() | Initializes a new instance of the WorkspaceTab class.
WorkspaceTab Constructor(String) | Initializes a new instance of the WorkspaceTab class and specifies the text for the tab.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WorkspaceTab Class
WorkspaceTab Members


WorkspaceTab Constructor()

[image]
Gizmox.WebGUI.Forms.Extended
WorkspaceTab Constructor()
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > WorkspaceTab Class > WorkspaceTab Constructor : WorkspaceTab Constructor()

Initializes a new instance of the WorkspaceTab class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As WorkspaceTab()
C#
public WorkspaceTab()
Managed Extensions for C++
public: WorkspaceTab();
C++/CLI
public:
WorkspaceTab();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WorkspaceTab Class
WorkspaceTab Members
Overload List


WorkspaceTab Constructor(String)

[image]
Gizmox.WebGUI.Forms.Extended
WorkspaceTab Constructor(String)
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > WorkspaceTab Class > WorkspaceTab Constructor : WorkspaceTab Constructor(String)

strText
The text for the tab.
Initializes a new instance of the WorkspaceTab class and specifies the text for the tab.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal strText As String _
)
Visual Basic (Usage) Copy Code
Dim strText As String

Dim instance As WorkspaceTab(strText)
C#
public WorkspaceTab(
   string strText
)
Managed Extensions for C++
public: WorkspaceTab(
   string* strText
)
C++/CLI
public:
WorkspaceTab(
   String^ strText
)

Parameters

strText
The text for the tab.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WorkspaceTab Class
WorkspaceTab Members
Overload List


WorkspaceTabs Class

[image]
Gizmox.WebGUI.Forms.Extended
WorkspaceTabs Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : WorkspaceTabs Class

Manages a related set of tab pages.

Object Model

Syntax

Visual Basic (Declaration)
<DesignTimeControllerAttribute()>
<DefaultEventAttribute("SelectedIndexChanged")>
<ToolboxItemCategoryAttribute("Containers")>
<SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableTabControl, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")>
<ToolboxBitmapAttribute()>
<ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<ClientControllerAttribute()>
<DefaultPropertyAttribute("TabPages")>
<WebCompilerResourcesAttribute(Assembly=, Namespace="Gizmox.WebGUI.Forms.Extended")>
Public Class WorkspaceTabs
   Inherits TabControl
   Implements IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IRequiredRegistration, IBindableComponent, IArrangedElement
Visual Basic (Usage) Copy Code
Dim instance As WorkspaceTabs
C#
[DesignTimeControllerAttribute()]
[DefaultEventAttribute("SelectedIndexChanged")]
[ToolboxItemCategoryAttribute("Containers")]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableTabControl, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[ToolboxBitmapAttribute()]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ClientControllerAttribute()]
[DefaultPropertyAttribute("TabPages")]
[WebCompilerResourcesAttribute(Assembly=, Namespace="Gizmox.WebGUI.Forms.Extended")]
public class WorkspaceTabs : TabControl, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IRequiredRegistration, IBindableComponent, IArrangedElement
Managed Extensions for C++
[DesignTimeControllerAttribute()]
[DefaultEventAttribute("SelectedIndexChanged")]
[ToolboxItemCategoryAttribute("Containers")]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableTabControl, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[ToolboxBitmapAttribute()]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ClientControllerAttribute()]
[DefaultPropertyAttribute("TabPages")]
[WebCompilerResourcesAttribute(Assembly=, Namespace="Gizmox.WebGUI.Forms.Extended")]
public __gc class WorkspaceTabs : public TabControl, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IRequiredRegistration, IBindableComponent, IArrangedElement
C++/CLI
[DesignTimeControllerAttribute()]
[DefaultEventAttribute("SelectedIndexChanged")]
[ToolboxItemCategoryAttribute("Containers")]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableTabControl, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[ToolboxBitmapAttribute()]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ClientControllerAttribute()]
[DefaultPropertyAttribute("TabPages")]
[WebCompilerResourcesAttribute(Assembly=, Namespace="Gizmox.WebGUI.Forms.Extended")]
public ref class WorkspaceTabs : public TabControl, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IRequiredRegistration, IBindableComponent, IArrangedElement

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.TabControl
Gizmox.WebGUI.Forms.WorkspaceTabs

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms.Extended (in Gizmox.WebGUI.Forms.Extended.dll)

See Also

Reference

WorkspaceTabs Members
Gizmox.WebGUI.Forms Namespace


WorkspaceTabs Class Members

[image]
Gizmox.WebGUI.Forms.Extended
WorkspaceTabs Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : WorkspaceTabs Class

The following tables list the members exposed by WorkspaceTabs.

Public Constructors

 | Name | Description
Public Constructor | WorkspaceTabs Constructor | Initializes a new instance of the WorkspaceTabs class.
Top

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | Appearance | Gets or sets the visual appearance of the control's tabs. (Inherited from TabControl)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientBehavior | Gets or sets the client drawing mode behavior (Inherited from TabControl)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | ImageList | Gets or sets the image list. (Inherited from TabControl)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Multiline | Gets or sets a value indicating whether more than one row of tabs can be displayed. (Inherited from TabControl)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | SelectedIndex | Gets or sets the index of the currently selected tab page. (Inherited from TabControl)
Public Property | SelectedItem | Gets the selected item. (Inherited from TabControl)
Public Property | ShowCloseButton | Gets or Sets value indication if the close button (when Appearance==TabAppearance.Workspace) should be shown (Inherited from TabControl)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabPages | Gets the collection of tab pages in this tab control.
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Control)
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | Overridden. Gets or sets the client update handler.
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | This member overrides Control.CreateControlsInstance. (Inherited from TabControl)
Protected Method | CreateTabPageCollection | Overridden. Creates the tab page collection.
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from TabControl)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from TabControl)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from Control)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnSelectedIndexChanged | Raises the SelectedIndexChanged event. (Inherited from TabControl)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Control)
Protected Method | RenderAttributes | Renders the controls meta attributes (Inherited from TabControl)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Renders the controls. (Inherited from TabControl)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from TabControl)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | CloseClick | Occurs when the user clicks the tab control close button (Inherited from TabControl)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | SelectedIndexChanged | Occurs when the SelectedIndex property is changed. (Inherited from TabControl)
Public Event | SelectedIndexChanging | Occurs when the SelectedIndex property is about to change. (Inherited from TabControl)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

WorkspaceTabs Class
Gizmox.WebGUI.Forms Namespace


WorkspaceTabs Constructor

[image]
Gizmox.WebGUI.Forms.Extended
WorkspaceTabs Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > WorkspaceTabs Class : WorkspaceTabs Constructor

Initializes a new instance of the WorkspaceTabs class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As WorkspaceTabs()
C#
public WorkspaceTabs()
Managed Extensions for C++
public: WorkspaceTabs();
C++/CLI
public:
WorkspaceTabs();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WorkspaceTabs Class
WorkspaceTabs Members


WorkspaceTabs Class Methods

[image]
Gizmox.WebGUI.Forms.Extended
WorkspaceTabs Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : WorkspaceTabs Class

For a list of all members of this type, see WorkspaceTabs members.

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | This member overrides Control.CreateControlsInstance. (Inherited from TabControl)
Protected Method | CreateTabPageCollection | Overridden. Creates the tab page collection.
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from TabControl)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from TabControl)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from Control)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnSelectedIndexChanged | Raises the SelectedIndexChanged event. (Inherited from TabControl)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Control)
Protected Method | RenderAttributes | Renders the controls meta attributes (Inherited from TabControl)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Renders the controls. (Inherited from TabControl)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from TabControl)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

See Also

Reference

WorkspaceTabs Class
Gizmox.WebGUI.Forms Namespace


CreateTabPageCollection Method

[image]
Gizmox.WebGUI.Forms.Extended
CreateTabPageCollection Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > WorkspaceTabs Class : CreateTabPageCollection Method

Creates the tab page collection.

Syntax

Visual Basic (Declaration)
Protected Overrides Function CreateTabPageCollection() As TabPageCollection
Visual Basic (Usage) Copy Code
Dim instance As WorkspaceTabs
Dim value As TabPageCollection

value = instance.CreateTabPageCollection()
C#
protected override TabPageCollection CreateTabPageCollection()
Managed Extensions for C++
protected: TabPageCollection* CreateTabPageCollection(); override
C++/CLI
protected:
TabPageCollection^ CreateTabPageCollection(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WorkspaceTabs Class
WorkspaceTabs Members


WorkspaceTabs Class Properties

[image]
Gizmox.WebGUI.Forms.Extended
WorkspaceTabs Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : WorkspaceTabs Class

For a list of all members of this type, see WorkspaceTabs members.

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | Appearance | Gets or sets the visual appearance of the control's tabs. (Inherited from TabControl)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientBehavior | Gets or sets the client drawing mode behavior (Inherited from TabControl)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | ImageList | Gets or sets the image list. (Inherited from TabControl)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Multiline | Gets or sets a value indicating whether more than one row of tabs can be displayed. (Inherited from TabControl)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | SelectedIndex | Gets or sets the index of the currently selected tab page. (Inherited from TabControl)
Public Property | SelectedItem | Gets the selected item. (Inherited from TabControl)
Public Property | ShowCloseButton | Gets or Sets value indication if the close button (when Appearance==TabAppearance.Workspace) should be shown (Inherited from TabControl)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabPages | Gets the collection of tab pages in this tab control.
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Control)
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | Overridden. Gets or sets the client update handler.
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

See Also

Reference

WorkspaceTabs Class
Gizmox.WebGUI.Forms Namespace


ClientUpdateHandler Property

[image]
Gizmox.WebGUI.Forms.Extended
ClientUpdateHandler Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > WorkspaceTabs Class : ClientUpdateHandler Property

Gets or sets the client update handler.

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property ClientUpdateHandler As String
Visual Basic (Usage) Copy Code
Dim instance As WorkspaceTabs
Dim value As String

value = instance.ClientUpdateHandler
C#
protected override string ClientUpdateHandler {get;}
Managed Extensions for C++
protected: __property string* get_ClientUpdateHandler() override;
C++/CLI
protected:
property String^ ClientUpdateHandler {
   String^ get() override;
}

Return Value

The client update handler.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WorkspaceTabs Class
WorkspaceTabs Members


TabPages Property

[image]
Gizmox.WebGUI.Forms.Extended
TabPages Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > WorkspaceTabs Class : TabPages Property

Gets the collection of tab pages in this tab control.

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
<MergablePropertyAttribute(False)>
Public ReadOnly Property TabPages As WorkspaceTabsCollection
Visual Basic (Usage) Copy Code
Dim instance As WorkspaceTabs
Dim value As WorkspaceTabsCollection

value = instance.TabPages
C#
[DesignerSerializationVisibilityAttribute()]
[MergablePropertyAttribute(false)]
public WorkspaceTabsCollection TabPages {get;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
[MergablePropertyAttribute(false)]
public: __property WorkspaceTabsCollection* get_TabPages();
C++/CLI
[DesignerSerializationVisibilityAttribute()]
[MergablePropertyAttribute(false)]
public:
property WorkspaceTabsCollection^ TabPages {
   WorkspaceTabsCollection^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WorkspaceTabs Class
WorkspaceTabs Members


WorkspaceTabsCollection Class

[image]
Gizmox.WebGUI.Forms.Extended
WorkspaceTabsCollection Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : WorkspaceTabsCollection Class

Tab pages collection class

Object Model

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class WorkspaceTabsCollection
   Inherits TabPageCollection
Visual Basic (Usage) Copy Code
Dim instance As WorkspaceTabsCollection
C#
[DefaultMemberAttribute("Item")]
public class WorkspaceTabsCollection : TabPageCollection
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
public __gc class WorkspaceTabsCollection : public TabPageCollection
C++/CLI
[DefaultMemberAttribute("Item")]
public ref class WorkspaceTabsCollection : public TabPageCollection

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.TabPageCollection
Gizmox.WebGUI.Forms.WorkspaceTabsCollection

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms.Extended (in Gizmox.WebGUI.Forms.Extended.dll)

See Also

Reference

WorkspaceTabsCollection Members
Gizmox.WebGUI.Forms Namespace


WorkspaceTabsCollection Class Members

[image]
Gizmox.WebGUI.Forms.Extended
WorkspaceTabsCollection Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : WorkspaceTabsCollection Class

The following tables list the members exposed by WorkspaceTabsCollection.

Public Properties

 | Name | Description
Public Property | Count | Gets the number of tab pages in the collection. (Inherited from TabPageCollection)
Public Property | IsFixedSize | Gets a value indicating whether the TabPageCollection has a fixed size. (Inherited from TabPageCollection)
Public Property | IsReadOnly | Gets a value indicating whether the collection is read-only. (Inherited from TabPageCollection)
Public Property | IsSynchronized | Gets a value indicating whether access to the TabPageCollection is synchronized (thread safe). (Inherited from TabPageCollection)
Public Property | Item | Gets the TabPage with the specified int index.
Public Property | SyncRoot | Gets an object that can be used to synchronize access to the TabPageCollection. (Inherited from TabPageCollection)
Top

Public Methods

 | Name | Description
Public Method | Add | Overridden. Adds the specified tab page.
Public Method | Clear | Removes all the tab pages from the collection. (Inherited from TabPageCollection)
Public Method | Compare | Compares the index of two sequencial TabPages in the TabPageCollection. (Inherited from TabPageCollection)
Public Method | Contains | Determines whether the specified TabPage control is in the TabPageCollection. (Inherited from TabPageCollection)
Public Method | CopyTo | Copies the elements of the collection to the specified array, starting at the specified index. (Inherited from TabPageCollection)
Public Method | GetEnumerator | Returns an enumeration of all the tab pages in the collection. (Inherited from TabPageCollection)
Public Method | IndexOf | Returns the index of the specified tab page in the collection. (Inherited from TabPageCollection)
Public Method | Insert | Inserts an existing tab page into the collection at the specified index. (Inherited from TabPageCollection)
Public Method | Remove | Overridden. Removes the specified tab page.
Public Method | RemoveAt | Removes the tab page at the specified index from the collection. (Inherited from TabPageCollection)
Top

Protected Methods

 | Name | Description
Protected Method | AdvanceTabIndexFromIndex | Overloaded. Advances the TabIndex property by the value of 'advanceBy', begginning at the 'fromIndex' position. (Inherited from TabPageCollection)
Protected Method | GetSortedTabPageListFromCurrent | Returns a sorted TabPage list from current unsorted TabPageCollection. (Inherited from TabPageCollection)
Top

See Also

Reference

WorkspaceTabsCollection Class
Gizmox.WebGUI.Forms Namespace


WorkspaceTabsCollection Class Methods

[image]
Gizmox.WebGUI.Forms.Extended
WorkspaceTabsCollection Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : WorkspaceTabsCollection Class

For a list of all members of this type, see WorkspaceTabsCollection members.

Public Methods

 | Name | Description
Public Method | Add | Overridden. Adds the specified tab page.
Public Method | Clear | Removes all the tab pages from the collection. (Inherited from TabPageCollection)
Public Method | Compare | Compares the index of two sequencial TabPages in the TabPageCollection. (Inherited from TabPageCollection)
Public Method | Contains | Determines whether the specified TabPage control is in the TabPageCollection. (Inherited from TabPageCollection)
Public Method | CopyTo | Copies the elements of the collection to the specified array, starting at the specified index. (Inherited from TabPageCollection)
Public Method | GetEnumerator | Returns an enumeration of all the tab pages in the collection. (Inherited from TabPageCollection)
Public Method | IndexOf | Returns the index of the specified tab page in the collection. (Inherited from TabPageCollection)
Public Method | Insert | Inserts an existing tab page into the collection at the specified index. (Inherited from TabPageCollection)
Public Method | Remove | Overridden. Removes the specified tab page.
Public Method | RemoveAt | Removes the tab page at the specified index from the collection. (Inherited from TabPageCollection)
Top

Protected Methods

 | Name | Description
Protected Method | AdvanceTabIndexFromIndex | Overloaded. Advances the TabIndex property by the value of 'advanceBy', begginning at the 'fromIndex' position. (Inherited from TabPageCollection)
Protected Method | GetSortedTabPageListFromCurrent | Returns a sorted TabPage list from current unsorted TabPageCollection. (Inherited from TabPageCollection)
Top

See Also

Reference

WorkspaceTabsCollection Class
Gizmox.WebGUI.Forms Namespace


Add Method

[image]
Gizmox.WebGUI.Forms.Extended
Add Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > WorkspaceTabsCollection Class : Add Method

objTabPage
tab page.
Adds the specified tab page.

Syntax

Visual Basic (Declaration)
Public Overrides Function Add( _
   ByVal objTabPage As TabPage _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As WorkspaceTabsCollection
Dim objTabPage As TabPage
Dim value As Integer

value = instance.Add(objTabPage)
C#
public override int Add(
   TabPage objTabPage
)
Managed Extensions for C++
public: int Add(
   TabPage* objTabPage
) override
C++/CLI
public:
int Add(
   TabPage^ objTabPage
) override

Parameters

objTabPage
tab page.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WorkspaceTabsCollection Class
WorkspaceTabsCollection Members


Remove Method

[image]
Gizmox.WebGUI.Forms.Extended
Remove Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > WorkspaceTabsCollection Class : Remove Method

objTabPage
tab page.
Removes the specified tab page.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Remove( _
   ByVal objTabPage As TabPage _
)
Visual Basic (Usage) Copy Code
Dim instance As WorkspaceTabsCollection
Dim objTabPage As TabPage

instance.Remove(objTabPage)
C#
public override void Remove(
   TabPage objTabPage
)
Managed Extensions for C++
public: void Remove(
   TabPage* objTabPage
) override
C++/CLI
public:
void Remove(
   TabPage^ objTabPage
) override

Parameters

objTabPage
tab page.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WorkspaceTabsCollection Class
WorkspaceTabsCollection Members


WorkspaceTabsCollection Class Properties

[image]
Gizmox.WebGUI.Forms.Extended
WorkspaceTabsCollection Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : WorkspaceTabsCollection Class

For a list of all members of this type, see WorkspaceTabsCollection members.

Public Properties

 | Name | Description
Public Property | Count | Gets the number of tab pages in the collection. (Inherited from TabPageCollection)
Public Property | IsFixedSize | Gets a value indicating whether the TabPageCollection has a fixed size. (Inherited from TabPageCollection)
Public Property | IsReadOnly | Gets a value indicating whether the collection is read-only. (Inherited from TabPageCollection)
Public Property | IsSynchronized | Gets a value indicating whether access to the TabPageCollection is synchronized (thread safe). (Inherited from TabPageCollection)
Public Property | Item | Gets the TabPage with the specified int index.
Public Property | SyncRoot | Gets an object that can be used to synchronize access to the TabPageCollection. (Inherited from TabPageCollection)
Top

See Also

Reference

WorkspaceTabsCollection Class
Gizmox.WebGUI.Forms Namespace


Item Property

[image]
Gizmox.WebGUI.Forms.Extended
Item Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > WorkspaceTabsCollection Class : Item Property

intIndex
Gets the TabPage with the specified int index.

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal intIndex As Integer _
) As WorkspaceTab
Visual Basic (Usage) Copy Code
Dim instance As WorkspaceTabsCollection
Dim intIndex As Integer
Dim value As WorkspaceTab

value = instance.Item(intIndex)
C#
public WorkspaceTab this[
   int intIndex
]; {get;}
Managed Extensions for C++
public: __property WorkspaceTab* get_Item(
   int intIndex
);
C++/CLI
public:
property WorkspaceTab^ default [int] {
   WorkspaceTab^ get(intintIndex);
}

Parameters

intIndex

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

WorkspaceTabsCollection Class
WorkspaceTabsCollection Members


Gizmox.WebGUI.Forms.Editors Namespace

Gizmox.WebGUI.Forms.Extended
Gizmox.WebGUI.Forms.Editors Namespace
See Also Inheritance Hierarchy Send Feedback

Classes

 | Class | Description
Class | FCKEditor | Summary description for FCKEditor
Class | FCKeditorConfigurations |

Enumerations

 | Enumeration | Description
Enumeration | FCKeditorLanguageDirection |

See Also

Reference

Gizmox.WebGUI.Forms.Extended Assembly


FCKEditor Class

[image]
Gizmox.WebGUI.Forms.Extended
FCKEditor Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms.Editors Namespace : FCKEditor Class

Summary description for FCKEditor

Object Model

Syntax

Visual Basic (Declaration)
<ClientControllerAttribute()>
<ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<WebCompilerResourcesAttribute(Assembly=, Namespace="Gizmox.WebGUI.Forms.Extended.Editors")>
<DesignTimeControllerAttribute()>
<MetadataTagAttribute("FCKE")>
<ToolboxBitmapAttribute()>
<SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.Editors.BindableFCKEditor, Gizmox.WebGUI.Silverlight.Controls.Extended, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")>
Public Class FCKEditor
   Inherits Control
   Implements IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Visual Basic (Usage) Copy Code
Dim instance As FCKEditor
C#
[ClientControllerAttribute()]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[WebCompilerResourcesAttribute(Assembly=, Namespace="Gizmox.WebGUI.Forms.Extended.Editors")]
[DesignTimeControllerAttribute()]
[MetadataTagAttribute("FCKE")]
[ToolboxBitmapAttribute()]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.Editors.BindableFCKEditor, Gizmox.WebGUI.Silverlight.Controls.Extended, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
public class FCKEditor : Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Managed Extensions for C++
[ClientControllerAttribute()]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[WebCompilerResourcesAttribute(Assembly=, Namespace="Gizmox.WebGUI.Forms.Extended.Editors")]
[DesignTimeControllerAttribute()]
[MetadataTagAttribute("FCKE")]
[ToolboxBitmapAttribute()]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.Editors.BindableFCKEditor, Gizmox.WebGUI.Silverlight.Controls.Extended, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
public __gc class FCKEditor : public Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
C++/CLI
[ClientControllerAttribute()]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[WebCompilerResourcesAttribute(Assembly=, Namespace="Gizmox.WebGUI.Forms.Extended.Editors")]
[DesignTimeControllerAttribute()]
[MetadataTagAttribute("FCKE")]
[ToolboxBitmapAttribute()]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.Editors.BindableFCKEditor, Gizmox.WebGUI.Silverlight.Controls.Extended, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
public ref class FCKEditor : public Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.Editors.FCKEditor

Requirements

Namespace: Gizmox.WebGUI.Forms.Editors

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms.Extended (in Gizmox.WebGUI.Forms.Extended.dll)

See Also

Reference

FCKEditor Members
Gizmox.WebGUI.Forms.Editors Namespace


FCKEditor Class Members

[image]
Gizmox.WebGUI.Forms.Extended
FCKEditor Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms.Editors Namespace : FCKEditor Class

The following tables list the members exposed by FCKEditor.

Public Constructors

 | Name | Description
Public Constructor | FCKEditor Constructor | Initializes a new instance of the FCKEditor class.
Top

Public Properties

Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | AutoDetectLanguage
Public Property | BackColor | Gets or sets the background color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BaseHref
Public Property BasePath Sets or gets the virtual path to the editor's directory. It is relative to the current page.

The default value is "/FCKeditor/".

The base path can be also set in the Web.config file using the appSettings section. Just set the "FCKeditor:BasePath" for that. For example:

    <configuration>
        <appSettings>
            <add key="FCKeditor:BasePath" value="/scripts/FCKeditor/" />
        </appSettings>
    </configuration>
Public Property | BindingContext | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Config
Public Property | Container | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ContentLangDirection
Public Property | Context | Gets the context. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CustomConfigurationsPath
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Debug
Public Property | DefaultLanguage
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | EditorAreaCSS
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | EnableSourceXHTML
Public Property | EnableXHTML
Public Property | FillEmptyBlocks
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | FontColors
Public Property | FontFormats
Public Property | FontNames
Public Property | FontSizes
Public Property | ForcePasteAsPlainText
Public Property | ForceSimpleAmpersand
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Form | Gets the owner form. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | FormatIndentator
Public Property | FormatOutput
Public Property | FormatSource
Public Property | FullPage
Public Property | GeckoUseSPAN
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Height | Gets/Sets the height position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ImageBrowserURL
Public Property | InternalParent | Gets the parent of this component. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | IsRegistered | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Left | Gets/Sets the left position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | LinkBrowserURL
Public Property | Location | Gets or sets the control location. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | PluginsPath
Public Property PreferredSize Not Implemented Property.

Gets the size of a rectangular area into which the control can fit. (Inherited from Gizmox.WebGUI.Forms.Control)

Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Right | Gets/Sets the right position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Site | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | SkinPath
Public Property | StartupFocus
Public Property | StylesXmlPath
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | TabSpaces
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ToolbarCanCollapse
Public Property | ToolbarSet
Public Property | ToolbarStartExpanded
Public Property | Top | Gets/Sets the top position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | UseBROnCarriageReturn
Public Property | Value
Public Property | Visible | Gets or sets the control visability. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Width | Gets/Sets the width position (Inherited from Gizmox.WebGUI.Forms.Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultBorderColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultBorderStyle | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultForeColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMargin | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultPadding | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DesignMode | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | Events | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | IsConnected | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Property | IsDelayedDrawing | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | Session | Gets the application object. (Inherited from Gizmox.WebGUI.Forms.Component)
Top

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Dispose | Overloaded. Clean up any resources being used.
Public Method | Focus | Sets focus to this control (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | GetPreferredSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | ResetText | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SendToBack | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Show | Displays the control to the user. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ToString | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Update | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | Finalize | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | FireEvent | Overridden.
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCommandText | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCriticalEvents | Overridden.
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetImage | Gets the image. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetPreferredSizeCore | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetService | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | InvokeMethod | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | IsDirty | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBindingContextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnControlAdded | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnControlRemoved | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | OnEnabledChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnGotFocus | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLostFocus | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentVisibleChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnResize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnTextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnUnregisterComponents | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnValidated | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnValidating | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnValueChanged |
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ProcessGatewayRequest | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RegisterSelf | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | RenderAttributes | Overridden.
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderClientUpdateHandler | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderComponentEventAttributes | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetImage | Sets the image. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeText | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | UnRegisterBatch | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | UnRegisterSelf | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | UpdateParams | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Top

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Disposed | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Gizmox.WebGUI.Forms.Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ValueChange | Occurs when the Value property changes.
Public Event | ValueChangeQueued | Occurs when the Value property changes (Queued).
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Top

See Also

Reference

FCKEditor Class
Gizmox.WebGUI.Forms.Editors Namespace


FCKEditor Constructor

[image]
Gizmox.WebGUI.Forms.Extended
FCKEditor Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms.Editors Namespace > FCKEditor Class : FCKEditor Constructor

Initializes a new instance of the FCKEditor class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As FCKEditor()
C#
public FCKEditor()
Managed Extensions for C++
public: FCKEditor();
C++/CLI
public:
FCKEditor();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FCKEditor Class
FCKEditor Members


FCKEditor Class Methods

[image]
Gizmox.WebGUI.Forms.Extended
FCKEditor Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms.Editors Namespace : FCKEditor Class

For a list of all members of this type, see FCKEditor members.

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Dispose | Overloaded. Clean up any resources being used.
Public Method | Focus | Sets focus to this control (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | GetPreferredSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | ResetText | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SendToBack | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Show | Displays the control to the user. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ToString | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Update | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | Finalize | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | FireEvent | Overridden.
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCommandText | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCriticalEvents | Overridden.
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetImage | Gets the image. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetPreferredSizeCore | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetService | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | InvokeMethod | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | IsDirty | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBindingContextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnControlAdded | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnControlRemoved | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | OnEnabledChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnGotFocus | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLostFocus | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentVisibleChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnResize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnTextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnUnregisterComponents | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnValidated | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnValidating | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnValueChanged |
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ProcessGatewayRequest | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RegisterSelf | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | RenderAttributes | Overridden.
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderClientUpdateHandler | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderComponentEventAttributes | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetImage | Sets the image. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeText | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | UnRegisterBatch | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | UnRegisterSelf | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | UpdateParams | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Top

See Also

Reference

FCKEditor Class
Gizmox.WebGUI.Forms.Editors Namespace


Dispose Method

[image]
Gizmox.WebGUI.Forms.Extended
Dispose Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Editors Namespace > FCKEditor Class : Dispose Method

Clean up any resources being used.

Overload List

Overload | Description
Dispose(Boolean) | Clean up any resources being used.
Dispose() | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FCKEditor Class
FCKEditor Members


Dispose(Boolean) Method

[image]
Gizmox.WebGUI.Forms.Extended
Dispose(Boolean) Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Editors Namespace > FCKEditor Class > Dispose Method : Dispose(Boolean) Method

disposing
true if managed resources should be disposed; otherwise, false.
Clean up any resources being used.

Syntax

Visual Basic (Declaration)
Protected Overloads Overridable Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As FCKEditor
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected virtual void Dispose(
   bool disposing
)
Managed Extensions for C++
protected: virtual void Dispose(
   bool disposing
)
C++/CLI
protected:
virtual void Dispose(
   bool disposing
)

Parameters

disposing
true if managed resources should be disposed; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FCKEditor Class
FCKEditor Members
Overload List


FireEvent Method

[image]
Gizmox.WebGUI.Forms.Extended
FireEvent Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Editors Namespace > FCKEditor Class : FireEvent Method

objEvent

Syntax

Visual Basic (Declaration)
Protected Overrides Sub FireEvent( _
   ByVal objEvent As IEvent _
)
Visual Basic (Usage) Copy Code
Dim instance As FCKEditor
Dim objEvent As IEvent

instance.FireEvent(objEvent)
C#
protected override void FireEvent(
   IEvent objEvent
)
Managed Extensions for C++
protected: void FireEvent(
   IEvent* objEvent
) override
C++/CLI
protected:
void FireEvent(
   IEvent^ objEvent
) override

Parameters

objEvent

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FCKEditor Class
FCKEditor Members


GetCriticalEvents Method

[image]
Gizmox.WebGUI.Forms.Extended
GetCriticalEvents Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Editors Namespace > FCKEditor Class : GetCriticalEvents Method

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetCriticalEvents() As EventTypes
Visual Basic (Usage) Copy Code
Dim instance As FCKEditor
Dim value As EventTypes

value = instance.GetCriticalEvents()
C#
protected override EventTypes GetCriticalEvents()
Managed Extensions for C++
protected: EventTypes GetCriticalEvents(); override
C++/CLI
protected:
EventTypes GetCriticalEvents(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FCKEditor Class
FCKEditor Members


OnValueChanged Method

[image]
Gizmox.WebGUI.Forms.Extended
OnValueChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Editors Namespace > FCKEditor Class : OnValueChanged Method

e

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnValueChanged( _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As FCKEditor
Dim e As EventArgs

instance.OnValueChanged(e)
C#
protected virtual void OnValueChanged(
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnValueChanged(
   EventArgs* e
)
C++/CLI
protected:
virtual void OnValueChanged(
   EventArgs^ e
)

Parameters

e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FCKEditor Class
FCKEditor Members


RenderAttributes Method

[image]
Gizmox.WebGUI.Forms.Extended
RenderAttributes Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Editors Namespace > FCKEditor Class : RenderAttributes Method

context
writer

Syntax

Visual Basic (Declaration)
Protected Overrides Sub RenderAttributes( _
   ByVal context As IContext, _
   ByVal writer As IAttributeWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As FCKEditor
Dim context As IContext
Dim writer As IAttributeWriter

instance.RenderAttributes(context, writer)
C#
protected override void RenderAttributes(
   IContext context,
   IAttributeWriter writer
)
Managed Extensions for C++
protected: void RenderAttributes(
   IContext* context,
   IAttributeWriter* writer
) override
C++/CLI
protected:
void RenderAttributes(
   IContext^ context,
   IAttributeWriter^ writer
) override

Parameters

context
writer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FCKEditor Class
FCKEditor Members


FCKEditor Class Properties

[image]
Gizmox.WebGUI.Forms.Extended
FCKEditor Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms.Editors Namespace : FCKEditor Class

For a list of all members of this type, see FCKEditor members.

Public Properties

Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | AutoDetectLanguage
Public Property | BackColor | Gets or sets the background color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BaseHref
Public Property BasePath Sets or gets the virtual path to the editor's directory. It is relative to the current page.

The default value is "/FCKeditor/".

The base path can be also set in the Web.config file using the appSettings section. Just set the "FCKeditor:BasePath" for that. For example:

    <configuration>
        <appSettings>
            <add key="FCKeditor:BasePath" value="/scripts/FCKeditor/" />
        </appSettings>
    </configuration>
Public Property | BindingContext | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Config
Public Property | Container | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ContentLangDirection
Public Property | Context | Gets the context. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CustomConfigurationsPath
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Debug
Public Property | DefaultLanguage
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | EditorAreaCSS
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | EnableSourceXHTML
Public Property | EnableXHTML
Public Property | FillEmptyBlocks
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | FontColors
Public Property | FontFormats
Public Property | FontNames
Public Property | FontSizes
Public Property | ForcePasteAsPlainText
Public Property | ForceSimpleAmpersand
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Form | Gets the owner form. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | FormatIndentator
Public Property | FormatOutput
Public Property | FormatSource
Public Property | FullPage
Public Property | GeckoUseSPAN
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Height | Gets/Sets the height position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ImageBrowserURL
Public Property | InternalParent | Gets the parent of this component. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | IsRegistered | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Left | Gets/Sets the left position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | LinkBrowserURL
Public Property | Location | Gets or sets the control location. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | PluginsPath
Public Property PreferredSize Not Implemented Property.

Gets the size of a rectangular area into which the control can fit. (Inherited from Gizmox.WebGUI.Forms.Control)

Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Right | Gets/Sets the right position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Site | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | SkinPath
Public Property | StartupFocus
Public Property | StylesXmlPath
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | TabSpaces
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ToolbarCanCollapse
Public Property | ToolbarSet
Public Property | ToolbarStartExpanded
Public Property | Top | Gets/Sets the top position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | UseBROnCarriageReturn
Public Property | Value
Public Property | Visible | Gets or sets the control visability. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Width | Gets/Sets the width position (Inherited from Gizmox.WebGUI.Forms.Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultBorderColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultBorderStyle | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultForeColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMargin | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultPadding | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DesignMode | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | Events | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | IsConnected | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Property | IsDelayedDrawing | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | Session | Gets the application object. (Inherited from Gizmox.WebGUI.Forms.Component)
Top

See Also

Reference

FCKEditor Class
Gizmox.WebGUI.Forms.Editors Namespace


AutoDetectLanguage Property

[image]
Gizmox.WebGUI.Forms.Extended
AutoDetectLanguage Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Editors Namespace > FCKEditor Class : AutoDetectLanguage Property

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Configurations")>
Public WriteOnly Property AutoDetectLanguage As Boolean
Visual Basic (Usage) Copy Code
Dim instance As FCKEditor

instance.AutoDetectLanguage = value
C#
[CategoryAttribute("Configurations")]
public bool AutoDetectLanguage {set;}
Managed Extensions for C++
[CategoryAttribute("Configurations")]
public: __property void set_AutoDetectLanguage(
   bool value
);
C++/CLI
[CategoryAttribute("Configurations")]
public:
property bool AutoDetectLanguage {
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FCKEditor Class
FCKEditor Members


BaseHref Property

[image]
Gizmox.WebGUI.Forms.Extended
BaseHref Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Editors Namespace > FCKEditor Class : BaseHref Property

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Configurations")>
Public WriteOnly Property BaseHref As String
Visual Basic (Usage) Copy Code
Dim instance As FCKEditor

instance.BaseHref = value
C#
[CategoryAttribute("Configurations")]
public string BaseHref {set;}
Managed Extensions for C++
[CategoryAttribute("Configurations")]
public: __property void set_BaseHref(
   string* value
);
C++/CLI
[CategoryAttribute("Configurations")]
public:
property String^ BaseHref {
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FCKEditor Class
FCKEditor Members


BasePath Property

[image]
Gizmox.WebGUI.Forms.Extended
BasePath Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Editors Namespace > FCKEditor Class : BasePath Property

Sets or gets the virtual path to the editor's directory. It is relative to the current page.

The default value is "/FCKeditor/".

The base path can be also set in the Web.config file using the appSettings section. Just set the "FCKeditor:BasePath" for that. For example:

    <configuration>
        <appSettings>
            <add key="FCKeditor:BasePath" value="/scripts/FCKeditor/" />
        </appSettings>
    </configuration>

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property BasePath As String
Visual Basic (Usage) Copy Code
Dim instance As FCKEditor
Dim value As String

instance.BasePath = value

value = instance.BasePath
C#
[DefaultValueAttribute()]
public string BasePath {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property string* get_BasePath();
public: __property void set_BasePath(
   string* value
);
C++/CLI
[DefaultValueAttribute()]
public:
property String^ BasePath {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FCKEditor Class
FCKEditor Members


Config Property

[image]
Gizmox.WebGUI.Forms.Extended
Config Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Editors Namespace > FCKEditor Class : Config Property

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property Config As FCKeditorConfigurations
Visual Basic (Usage) Copy Code
Dim instance As FCKEditor
Dim value As FCKeditorConfigurations

value = instance.Config
C#
[BrowsableAttribute(false)]
public FCKeditorConfigurations Config {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property FCKeditorConfigurations* get_Config();
C++/CLI
[BrowsableAttribute(false)]
public:
property FCKeditorConfigurations^ Config {
   FCKeditorConfigurations^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FCKEditor Class
FCKEditor Members


ContentLangDirection Property

[image]
Gizmox.WebGUI.Forms.Extended
ContentLangDirection Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Editors Namespace > FCKEditor Class : ContentLangDirection Property

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Configurations")>
Public WriteOnly Property ContentLangDirection As FCKeditorLanguageDirection
Visual Basic (Usage) Copy Code
Dim instance As FCKEditor

instance.ContentLangDirection = value
C#
[CategoryAttribute("Configurations")]
public FCKeditorLanguageDirection ContentLangDirection {set;}
Managed Extensions for C++
[CategoryAttribute("Configurations")]
public: __property void set_ContentLangDirection(
   FCKeditorLanguageDirection value
);
C++/CLI
[CategoryAttribute("Configurations")]
public:
property FCKeditorLanguageDirection ContentLangDirection {
   void set (FCKeditorLanguageDirectionvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FCKEditor Class
FCKEditor Members


CustomConfigurationsPath Property

[image]
Gizmox.WebGUI.Forms.Extended
CustomConfigurationsPath Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Editors Namespace > FCKEditor Class : CustomConfigurationsPath Property

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Configurations")>
Public WriteOnly Property CustomConfigurationsPath As String
Visual Basic (Usage) Copy Code
Dim instance As FCKEditor

instance.CustomConfigurationsPath = value
C#
[CategoryAttribute("Configurations")]
public string CustomConfigurationsPath {set;}
Managed Extensions for C++
[CategoryAttribute("Configurations")]
public: __property void set_CustomConfigurationsPath(
   string* value
);
C++/CLI
[CategoryAttribute("Configurations")]
public:
property String^ CustomConfigurationsPath {
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FCKEditor Class
FCKEditor Members


Debug Property

[image]
Gizmox.WebGUI.Forms.Extended
Debug Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Editors Namespace > FCKEditor Class : Debug Property

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Configurations")>
Public WriteOnly Property Debug As Boolean
Visual Basic (Usage) Copy Code
Dim instance As FCKEditor

instance.Debug = value
C#
[CategoryAttribute("Configurations")]
public bool Debug {set;}
Managed Extensions for C++
[CategoryAttribute("Configurations")]
public: __property void set_Debug(
   bool value
);
C++/CLI
[CategoryAttribute("Configurations")]
public:
property bool Debug {
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FCKEditor Class
FCKEditor Members


DefaultLanguage Property

[image]
Gizmox.WebGUI.Forms.Extended
DefaultLanguage Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Editors Namespace > FCKEditor Class : DefaultLanguage Property

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Configurations")>
Public WriteOnly Property DefaultLanguage As String
Visual Basic (Usage) Copy Code
Dim instance As FCKEditor

instance.DefaultLanguage = value
C#
[CategoryAttribute("Configurations")]
public string DefaultLanguage {set;}
Managed Extensions for C++
[CategoryAttribute("Configurations")]
public: __property void set_DefaultLanguage(
   string* value
);
C++/CLI
[CategoryAttribute("Configurations")]
public:
property String^ DefaultLanguage {
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FCKEditor Class
FCKEditor Members


EditorAreaCSS Property

[image]
Gizmox.WebGUI.Forms.Extended
EditorAreaCSS Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Editors Namespace > FCKEditor Class : EditorAreaCSS Property

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Configurations")>
Public WriteOnly Property EditorAreaCSS As String
Visual Basic (Usage) Copy Code
Dim instance As FCKEditor

instance.EditorAreaCSS = value
C#
[CategoryAttribute("Configurations")]
public string EditorAreaCSS {set;}
Managed Extensions for C++
[CategoryAttribute("Configurations")]
public: __property void set_EditorAreaCSS(
   string* value
);
C++/CLI
[CategoryAttribute("Configurations")]
public:
property String^ EditorAreaCSS {
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FCKEditor Class
FCKEditor Members


EnableSourceXHTML Property

[image]
Gizmox.WebGUI.Forms.Extended
EnableSourceXHTML Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Editors Namespace > FCKEditor Class : EnableSourceXHTML Property

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Configurations")>
Public WriteOnly Property EnableSourceXHTML As Boolean
Visual Basic (Usage) Copy Code
Dim instance As FCKEditor

instance.EnableSourceXHTML = value
C#
[CategoryAttribute("Configurations")]
public bool EnableSourceXHTML {set;}
Managed Extensions for C++
[CategoryAttribute("Configurations")]
public: __property void set_EnableSourceXHTML(
   bool value
);
C++/CLI
[CategoryAttribute("Configurations")]
public:
property bool EnableSourceXHTML {
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FCKEditor Class
FCKEditor Members


EnableXHTML Property

[image]
Gizmox.WebGUI.Forms.Extended
EnableXHTML Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Editors Namespace > FCKEditor Class : EnableXHTML Property

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Configurations")>
Public WriteOnly Property EnableXHTML As Boolean
Visual Basic (Usage) Copy Code
Dim instance As FCKEditor

instance.EnableXHTML = value
C#
[CategoryAttribute("Configurations")]
public bool EnableXHTML {set;}
Managed Extensions for C++
[CategoryAttribute("Configurations")]
public: __property void set_EnableXHTML(
   bool value
);
C++/CLI
[CategoryAttribute("Configurations")]
public:
property bool EnableXHTML {
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FCKEditor Class
FCKEditor Members


FillEmptyBlocks Property

[image]
Gizmox.WebGUI.Forms.Extended
FillEmptyBlocks Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Editors Namespace > FCKEditor Class : FillEmptyBlocks Property

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Configurations")>
Public WriteOnly Property FillEmptyBlocks As Boolean
Visual Basic (Usage) Copy Code
Dim instance As FCKEditor

instance.FillEmptyBlocks = value
C#
[CategoryAttribute("Configurations")]
public bool FillEmptyBlocks {set;}
Managed Extensions for C++
[CategoryAttribute("Configurations")]
public: __property void set_FillEmptyBlocks(
   bool value
);
C++/CLI
[CategoryAttribute("Configurations")]
public:
property bool FillEmptyBlocks {
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FCKEditor Class
FCKEditor Members


FontColors Property

[image]
Gizmox.WebGUI.Forms.Extended
FontColors Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Editors Namespace > FCKEditor Class : FontColors Property

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Configurations")>
Public WriteOnly Property FontColors As String
Visual Basic (Usage) Copy Code
Dim instance As FCKEditor

instance.FontColors = value
C#
[CategoryAttribute("Configurations")]
public string FontColors {set;}
Managed Extensions for C++
[CategoryAttribute("Configurations")]
public: __property void set_FontColors(
   string* value
);
C++/CLI
[CategoryAttribute("Configurations")]
public:
property String^ FontColors {
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FCKEditor Class
FCKEditor Members


FontFormats Property

[image]
Gizmox.WebGUI.Forms.Extended
FontFormats Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Editors Namespace > FCKEditor Class : FontFormats Property

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Configurations")>
Public WriteOnly Property FontFormats As String
Visual Basic (Usage) Copy Code
Dim instance As FCKEditor

instance.FontFormats = value
C#
[CategoryAttribute("Configurations")]
public string FontFormats {set;}
Managed Extensions for C++
[CategoryAttribute("Configurations")]
public: __property void set_FontFormats(
   string* value
);
C++/CLI
[CategoryAttribute("Configurations")]
public:
property String^ FontFormats {
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FCKEditor Class
FCKEditor Members


FontNames Property

[image]
Gizmox.WebGUI.Forms.Extended
FontNames Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Editors Namespace > FCKEditor Class : FontNames Property

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Configurations")>
Public WriteOnly Property FontNames As String
Visual Basic (Usage) Copy Code
Dim instance As FCKEditor

instance.FontNames = value
C#
[CategoryAttribute("Configurations")]
public string FontNames {set;}
Managed Extensions for C++
[CategoryAttribute("Configurations")]
public: __property void set_FontNames(
   string* value
);
C++/CLI
[CategoryAttribute("Configurations")]
public:
property String^ FontNames {
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FCKEditor Class
FCKEditor Members


FontSizes Property

[image]
Gizmox.WebGUI.Forms.Extended
FontSizes Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Editors Namespace > FCKEditor Class : FontSizes Property

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Configurations")>
Public WriteOnly Property FontSizes As String
Visual Basic (Usage) Copy Code
Dim instance As FCKEditor

instance.FontSizes = value
C#
[CategoryAttribute("Configurations")]
public string FontSizes {set;}
Managed Extensions for C++
[CategoryAttribute("Configurations")]
public: __property void set_FontSizes(
   string* value
);
C++/CLI
[CategoryAttribute("Configurations")]
public:
property String^ FontSizes {
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FCKEditor Class
FCKEditor Members


ForcePasteAsPlainText Property

[image]
Gizmox.WebGUI.Forms.Extended
ForcePasteAsPlainText Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Editors Namespace > FCKEditor Class : ForcePasteAsPlainText Property

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Configurations")>
Public WriteOnly Property ForcePasteAsPlainText As Boolean
Visual Basic (Usage) Copy Code
Dim instance As FCKEditor

instance.ForcePasteAsPlainText = value
C#
[CategoryAttribute("Configurations")]
public bool ForcePasteAsPlainText {set;}
Managed Extensions for C++
[CategoryAttribute("Configurations")]
public: __property void set_ForcePasteAsPlainText(
   bool value
);
C++/CLI
[CategoryAttribute("Configurations")]
public:
property bool ForcePasteAsPlainText {
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FCKEditor Class
FCKEditor Members


ForceSimpleAmpersand Property

[image]
Gizmox.WebGUI.Forms.Extended
ForceSimpleAmpersand Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Editors Namespace > FCKEditor Class : ForceSimpleAmpersand Property

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Configurations")>
Public WriteOnly Property ForceSimpleAmpersand As Boolean
Visual Basic (Usage) Copy Code
Dim instance As FCKEditor

instance.ForceSimpleAmpersand = value
C#
[CategoryAttribute("Configurations")]
public bool ForceSimpleAmpersand {set;}
Managed Extensions for C++
[CategoryAttribute("Configurations")]
public: __property void set_ForceSimpleAmpersand(
   bool value
);
C++/CLI
[CategoryAttribute("Configurations")]
public:
property bool ForceSimpleAmpersand {
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FCKEditor Class
FCKEditor Members


FormatIndentator Property

[image]
Gizmox.WebGUI.Forms.Extended
FormatIndentator Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Editors Namespace > FCKEditor Class : FormatIndentator Property

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Configurations")>
Public WriteOnly Property FormatIndentator As String
Visual Basic (Usage) Copy Code
Dim instance As FCKEditor

instance.FormatIndentator = value
C#
[CategoryAttribute("Configurations")]
public string FormatIndentator {set;}
Managed Extensions for C++
[CategoryAttribute("Configurations")]
public: __property void set_FormatIndentator(
   string* value
);
C++/CLI
[CategoryAttribute("Configurations")]
public:
property String^ FormatIndentator {
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FCKEditor Class
FCKEditor Members


FormatOutput Property

[image]
Gizmox.WebGUI.Forms.Extended
FormatOutput Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Editors Namespace > FCKEditor Class : FormatOutput Property

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Configurations")>
Public WriteOnly Property FormatOutput As Boolean
Visual Basic (Usage) Copy Code
Dim instance As FCKEditor

instance.FormatOutput = value
C#
[CategoryAttribute("Configurations")]
public bool FormatOutput {set;}
Managed Extensions for C++
[CategoryAttribute("Configurations")]
public: __property void set_FormatOutput(
   bool value
);
C++/CLI
[CategoryAttribute("Configurations")]
public:
property bool FormatOutput {
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FCKEditor Class
FCKEditor Members


FormatSource Property

[image]
Gizmox.WebGUI.Forms.Extended
FormatSource Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Editors Namespace > FCKEditor Class : FormatSource Property

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Configurations")>
Public WriteOnly Property FormatSource As Boolean
Visual Basic (Usage) Copy Code
Dim instance As FCKEditor

instance.FormatSource = value
C#
[CategoryAttribute("Configurations")]
public bool FormatSource {set;}
Managed Extensions for C++
[CategoryAttribute("Configurations")]
public: __property void set_FormatSource(
   bool value
);
C++/CLI
[CategoryAttribute("Configurations")]
public:
property bool FormatSource {
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FCKEditor Class
FCKEditor Members


FullPage Property

[image]
Gizmox.WebGUI.Forms.Extended
FullPage Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Editors Namespace > FCKEditor Class : FullPage Property

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Configurations")>
Public WriteOnly Property FullPage As Boolean
Visual Basic (Usage) Copy Code
Dim instance As FCKEditor

instance.FullPage = value
C#
[CategoryAttribute("Configurations")]
public bool FullPage {set;}
Managed Extensions for C++
[CategoryAttribute("Configurations")]
public: __property void set_FullPage(
   bool value
);
C++/CLI
[CategoryAttribute("Configurations")]
public:
property bool FullPage {
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FCKEditor Class
FCKEditor Members


GeckoUseSPAN Property

[image]
Gizmox.WebGUI.Forms.Extended
GeckoUseSPAN Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Editors Namespace > FCKEditor Class : GeckoUseSPAN Property

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Configurations")>
Public WriteOnly Property GeckoUseSPAN As Boolean
Visual Basic (Usage) Copy Code
Dim instance As FCKEditor

instance.GeckoUseSPAN = value
C#
[CategoryAttribute("Configurations")]
public bool GeckoUseSPAN {set;}
Managed Extensions for C++
[CategoryAttribute("Configurations")]
public: __property void set_GeckoUseSPAN(
   bool value
);
C++/CLI
[CategoryAttribute("Configurations")]
public:
property bool GeckoUseSPAN {
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FCKEditor Class
FCKEditor Members


ImageBrowserURL Property

[image]
Gizmox.WebGUI.Forms.Extended
ImageBrowserURL Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Editors Namespace > FCKEditor Class : ImageBrowserURL Property

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Configurations")>
Public WriteOnly Property ImageBrowserURL As String
Visual Basic (Usage) Copy Code
Dim instance As FCKEditor

instance.ImageBrowserURL = value
C#
[CategoryAttribute("Configurations")]
public string ImageBrowserURL {set;}
Managed Extensions for C++
[CategoryAttribute("Configurations")]
public: __property void set_ImageBrowserURL(
   string* value
);
C++/CLI
[CategoryAttribute("Configurations")]
public:
property String^ ImageBrowserURL {
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FCKEditor Class
FCKEditor Members


LinkBrowserURL Property

[image]
Gizmox.WebGUI.Forms.Extended
LinkBrowserURL Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Editors Namespace > FCKEditor Class : LinkBrowserURL Property

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Configurations")>
Public WriteOnly Property LinkBrowserURL As String
Visual Basic (Usage) Copy Code
Dim instance As FCKEditor

instance.LinkBrowserURL = value
C#
[CategoryAttribute("Configurations")]
public string LinkBrowserURL {set;}
Managed Extensions for C++
[CategoryAttribute("Configurations")]
public: __property void set_LinkBrowserURL(
   string* value
);
C++/CLI
[CategoryAttribute("Configurations")]
public:
property String^ LinkBrowserURL {
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FCKEditor Class
FCKEditor Members


PluginsPath Property

[image]
Gizmox.WebGUI.Forms.Extended
PluginsPath Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Editors Namespace > FCKEditor Class : PluginsPath Property

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Configurations")>
Public WriteOnly Property PluginsPath As String
Visual Basic (Usage) Copy Code
Dim instance As FCKEditor

instance.PluginsPath = value
C#
[CategoryAttribute("Configurations")]
public string PluginsPath {set;}
Managed Extensions for C++
[CategoryAttribute("Configurations")]
public: __property void set_PluginsPath(
   string* value
);
C++/CLI
[CategoryAttribute("Configurations")]
public:
property String^ PluginsPath {
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FCKEditor Class
FCKEditor Members


SkinPath Property

[image]
Gizmox.WebGUI.Forms.Extended
SkinPath Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Editors Namespace > FCKEditor Class : SkinPath Property

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Configurations")>
Public WriteOnly Property SkinPath As String
Visual Basic (Usage) Copy Code
Dim instance As FCKEditor

instance.SkinPath = value
C#
[CategoryAttribute("Configurations")]
public string SkinPath {set;}
Managed Extensions for C++
[CategoryAttribute("Configurations")]
public: __property void set_SkinPath(
   string* value
);
C++/CLI
[CategoryAttribute("Configurations")]
public:
property String^ SkinPath {
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FCKEditor Class
FCKEditor Members


StartupFocus Property

[image]
Gizmox.WebGUI.Forms.Extended
StartupFocus Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Editors Namespace > FCKEditor Class : StartupFocus Property

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Configurations")>
Public WriteOnly Property StartupFocus As Boolean
Visual Basic (Usage) Copy Code
Dim instance As FCKEditor

instance.StartupFocus = value
C#
[CategoryAttribute("Configurations")]
public bool StartupFocus {set;}
Managed Extensions for C++
[CategoryAttribute("Configurations")]
public: __property void set_StartupFocus(
   bool value
);
C++/CLI
[CategoryAttribute("Configurations")]
public:
property bool StartupFocus {
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FCKEditor Class
FCKEditor Members


StylesXmlPath Property

[image]
Gizmox.WebGUI.Forms.Extended
StylesXmlPath Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Editors Namespace > FCKEditor Class : StylesXmlPath Property

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Configurations")>
Public WriteOnly Property StylesXmlPath As String
Visual Basic (Usage) Copy Code
Dim instance As FCKEditor

instance.StylesXmlPath = value
C#
[CategoryAttribute("Configurations")]
public string StylesXmlPath {set;}
Managed Extensions for C++
[CategoryAttribute("Configurations")]
public: __property void set_StylesXmlPath(
   string* value
);
C++/CLI
[CategoryAttribute("Configurations")]
public:
property String^ StylesXmlPath {
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FCKEditor Class
FCKEditor Members


TabSpaces Property

[image]
Gizmox.WebGUI.Forms.Extended
TabSpaces Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Editors Namespace > FCKEditor Class : TabSpaces Property

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Configurations")>
Public WriteOnly Property TabSpaces As Integer
Visual Basic (Usage) Copy Code
Dim instance As FCKEditor

instance.TabSpaces = value
C#
[CategoryAttribute("Configurations")]
public int TabSpaces {set;}
Managed Extensions for C++
[CategoryAttribute("Configurations")]
public: __property void set_TabSpaces(
   int value
);
C++/CLI
[CategoryAttribute("Configurations")]
public:
property int TabSpaces {
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FCKEditor Class
FCKEditor Members


ToolbarCanCollapse Property

[image]
Gizmox.WebGUI.Forms.Extended
ToolbarCanCollapse Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Editors Namespace > FCKEditor Class : ToolbarCanCollapse Property

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Configurations")>
Public WriteOnly Property ToolbarCanCollapse As Boolean
Visual Basic (Usage) Copy Code
Dim instance As FCKEditor

instance.ToolbarCanCollapse = value
C#
[CategoryAttribute("Configurations")]
public bool ToolbarCanCollapse {set;}
Managed Extensions for C++
[CategoryAttribute("Configurations")]
public: __property void set_ToolbarCanCollapse(
   bool value
);
C++/CLI
[CategoryAttribute("Configurations")]
public:
property bool ToolbarCanCollapse {
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FCKEditor Class
FCKEditor Members


ToolbarSet Property

[image]
Gizmox.WebGUI.Forms.Extended
ToolbarSet Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Editors Namespace > FCKEditor Class : ToolbarSet Property

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property ToolbarSet As String
Visual Basic (Usage) Copy Code
Dim instance As FCKEditor
Dim value As String

instance.ToolbarSet = value

value = instance.ToolbarSet
C#
[DefaultValueAttribute()]
public string ToolbarSet {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property string* get_ToolbarSet();
public: __property void set_ToolbarSet(
   string* value
);
C++/CLI
[DefaultValueAttribute()]
public:
property String^ ToolbarSet {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FCKEditor Class
FCKEditor Members


ToolbarStartExpanded Property

[image]
Gizmox.WebGUI.Forms.Extended
ToolbarStartExpanded Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Editors Namespace > FCKEditor Class : ToolbarStartExpanded Property

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Configurations")>
Public WriteOnly Property ToolbarStartExpanded As Boolean
Visual Basic (Usage) Copy Code
Dim instance As FCKEditor

instance.ToolbarStartExpanded = value
C#
[CategoryAttribute("Configurations")]
public bool ToolbarStartExpanded {set;}
Managed Extensions for C++
[CategoryAttribute("Configurations")]
public: __property void set_ToolbarStartExpanded(
   bool value
);
C++/CLI
[CategoryAttribute("Configurations")]
public:
property bool ToolbarStartExpanded {
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FCKEditor Class
FCKEditor Members


UseBROnCarriageReturn Property

[image]
Gizmox.WebGUI.Forms.Extended
UseBROnCarriageReturn Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Editors Namespace > FCKEditor Class : UseBROnCarriageReturn Property

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Configurations")>
Public WriteOnly Property UseBROnCarriageReturn As Boolean
Visual Basic (Usage) Copy Code
Dim instance As FCKEditor

instance.UseBROnCarriageReturn = value
C#
[CategoryAttribute("Configurations")]
public bool UseBROnCarriageReturn {set;}
Managed Extensions for C++
[CategoryAttribute("Configurations")]
public: __property void set_UseBROnCarriageReturn(
   bool value
);
C++/CLI
[CategoryAttribute("Configurations")]
public:
property bool UseBROnCarriageReturn {
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FCKEditor Class
FCKEditor Members


Value Property

[image]
Gizmox.WebGUI.Forms.Extended
Value Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Editors Namespace > FCKEditor Class : Value Property

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property Value As String
Visual Basic (Usage) Copy Code
Dim instance As FCKEditor
Dim value As String

instance.Value = value

value = instance.Value
C#
[DefaultValueAttribute()]
public string Value {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property string* get_Value();
public: __property void set_Value(
   string* value
);
C++/CLI
[DefaultValueAttribute()]
public:
property String^ Value {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FCKEditor Class
FCKEditor Members


FCKEditor Class Events

[image]
Gizmox.WebGUI.Forms.Extended
FCKEditor Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms.Editors Namespace : FCKEditor Class

For a list of all members of this type, see FCKEditor members.

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Disposed | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Gizmox.WebGUI.Forms.Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ValueChange | Occurs when the Value property changes.
Public Event | ValueChangeQueued | Occurs when the Value property changes (Queued).
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Top

See Also

Reference

FCKEditor Class
Gizmox.WebGUI.Forms.Editors Namespace


ValueChange Event

[image]
Gizmox.WebGUI.Forms.Extended
ValueChange Event
See Also Send Feedback
Gizmox.WebGUI.Forms.Editors Namespace > FCKEditor Class : ValueChange Event

Occurs when the Value property changes.

Syntax

Visual Basic (Declaration)
Public Event ValueChange() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As FCKEditor
Dim handler As EventHandler

AddHandler instance.ValueChange, handler
C#
public event EventHandler ValueChange()
Managed Extensions for C++
public: __event EventHandler* ValueChange
C++/CLI
public:
event EventHandler^ ValueChange

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FCKEditor Class
FCKEditor Members


ValueChangeQueued Event

[image]
Gizmox.WebGUI.Forms.Extended
ValueChangeQueued Event
See Also Send Feedback
Gizmox.WebGUI.Forms.Editors Namespace > FCKEditor Class : ValueChangeQueued Event

Occurs when the Value property changes (Queued).

Syntax

Visual Basic (Declaration)
Public Event ValueChangeQueued() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As FCKEditor
Dim handler As EventHandler

AddHandler instance.ValueChangeQueued, handler
C#
public event EventHandler ValueChangeQueued()
Managed Extensions for C++
public: __event EventHandler* ValueChangeQueued
C++/CLI
public:
event EventHandler^ ValueChangeQueued

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FCKEditor Class
FCKEditor Members


FCKeditorConfigurations Class

[image]
Gizmox.WebGUI.Forms.Extended
FCKeditorConfigurations Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms.Editors Namespace : FCKeditorConfigurations Class

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
<SerializableAttribute()>
Public Class FCKeditorConfigurations
Visual Basic (Usage) Copy Code
Dim instance As FCKeditorConfigurations
C#
[DefaultMemberAttribute("Item")]
[SerializableAttribute()]
public class FCKeditorConfigurations
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
[SerializableAttribute()]
public __gc class FCKeditorConfigurations
C++/CLI
[DefaultMemberAttribute("Item")]
[SerializableAttribute()]
public ref class FCKeditorConfigurations

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.Editors.FCKeditorConfigurations

Requirements

Namespace: Gizmox.WebGUI.Forms.Editors

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms.Extended (in Gizmox.WebGUI.Forms.Extended.dll)

See Also

Reference

FCKeditorConfigurations Members
Gizmox.WebGUI.Forms.Editors Namespace


FCKeditorConfigurations Class Members

[image]
Gizmox.WebGUI.Forms.Extended
FCKeditorConfigurations Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms.Editors Namespace : FCKeditorConfigurations Class

The following tables list the members exposed by FCKeditorConfigurations.

Protected Constructors

 | Name | Description
Protected Constructor | FCKeditorConfigurations Constructor |
Top

Public Properties

 | Name | Description
Public Property | Item |
Top

Public Methods

 | Name | Description
Public Method | GetObjectData |
Top

See Also

Reference

FCKeditorConfigurations Class
Gizmox.WebGUI.Forms.Editors Namespace


FCKeditorConfigurations Constructor

[image]
Gizmox.WebGUI.Forms.Extended
FCKeditorConfigurations Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms.Editors Namespace > FCKeditorConfigurations Class : FCKeditorConfigurations Constructor

info
context

Syntax

Visual Basic (Declaration)
Protected Function New( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim info As SerializationInfo
Dim context As StreamingContext

Dim instance As FCKeditorConfigurations(info, context)
C#
protected FCKeditorConfigurations(
   SerializationInfo info,
   StreamingContext context
)
Managed Extensions for C++
protected: FCKeditorConfigurations(
   SerializationInfo* info,
   StreamingContext context
)
C++/CLI
protected:
FCKeditorConfigurations(
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

info
context

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FCKeditorConfigurations Class
FCKeditorConfigurations Members


FCKeditorConfigurations Class Methods

[image]
Gizmox.WebGUI.Forms.Extended
FCKeditorConfigurations Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms.Editors Namespace : FCKeditorConfigurations Class

For a list of all members of this type, see FCKeditorConfigurations members.

Public Methods

 | Name | Description
Public Method | GetObjectData |
Top

See Also

Reference

FCKeditorConfigurations Class
Gizmox.WebGUI.Forms.Editors Namespace


GetObjectData Method

[image]
Gizmox.WebGUI.Forms.Extended
GetObjectData Method
See Also Send Feedback
Gizmox.WebGUI.Forms.Editors Namespace > FCKeditorConfigurations Class : GetObjectData Method

info
context

Syntax

Visual Basic (Declaration)
Public Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As FCKeditorConfigurations
Dim info As SerializationInfo
Dim context As StreamingContext

instance.GetObjectData(info, context)
C#
public void GetObjectData(
   SerializationInfo info,
   StreamingContext context
)
Managed Extensions for C++
public: void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
)
C++/CLI
public:
void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

info
context

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FCKeditorConfigurations Class
FCKeditorConfigurations Members


FCKeditorConfigurations Class Properties

[image]
Gizmox.WebGUI.Forms.Extended
FCKeditorConfigurations Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms.Editors Namespace : FCKeditorConfigurations Class

For a list of all members of this type, see FCKeditorConfigurations members.

Public Properties

 | Name | Description
Public Property | Item |
Top

See Also

Reference

FCKeditorConfigurations Class
Gizmox.WebGUI.Forms.Editors Namespace


Item Property

[image]
Gizmox.WebGUI.Forms.Extended
Item Property
See Also Send Feedback
Gizmox.WebGUI.Forms.Editors Namespace > FCKeditorConfigurations Class : Item Property

configurationName

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal configurationName As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As FCKeditorConfigurations
Dim configurationName As String
Dim value As String

instance.Item(configurationName) = value

value = instance.Item(configurationName)
C#
public string this[
   string configurationName
]; {get; set;}
Managed Extensions for C++
public: __property string* get_Item(
   string* configurationName
);
public: __property void set_Item(
   string* configurationName,
   string* value
);
C++/CLI
public:
property String^ default [String^] {
   String^ get(String^configurationName);
   void set (String^configurationName, String^value);
}

Parameters

configurationName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

FCKeditorConfigurations Class
FCKeditorConfigurations Members


FCKeditorLanguageDirection Enumeration

[image]
Gizmox.WebGUI.Forms.Extended
FCKeditorLanguageDirection Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms.Editors Namespace : FCKeditorLanguageDirection Enumeration

Syntax

Visual Basic (Declaration)
Public Enum FCKeditorLanguageDirection
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As FCKeditorLanguageDirection
C#
public enum FCKeditorLanguageDirection : Enum
Managed Extensions for C++
__value public enum FCKeditorLanguageDirection : public Enum
C++/CLI
public enum class FCKeditorLanguageDirection : public Enum

Members

Member | Description
LeftToRight |
RightToLeft |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.Editors.FCKeditorLanguageDirection

Requirements

Namespace: Gizmox.WebGUI.Forms.Editors

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms.Extended (in Gizmox.WebGUI.Forms.Extended.dll)

See Also

Reference

Gizmox.WebGUI.Forms.Editors Namespace


Assembly Overview

Gizmox.WebGUI.Forms.Office
Gizmox.WebGUI.Forms.Office Assembly
See Also Send Feedback

Namespaces

Namespace | Description
Gizmox.WebGUI.Forms |


Gizmox.WebGUI.Forms Namespace (Gizmox.WebGUI.Forms.Office)

Gizmox.WebGUI.Forms.Office
Gizmox.WebGUI.Forms Namespace (Gizmox.WebGUI.Forms.Office)
See Also Inheritance Hierarchy Send Feedback

Classes

 | Class | Description
Class | HeaderedPanel |
Class | NavigationTab | Summary description for NavigationTab.
Class | NavigationTabCollection | Tab pages collection class
Class | NavigationTabEventArgs |
Class | NavigationTabs | Summary description for NavigationTabs.
Class | RibbonBar | Summary description for RibonBar
Class | RibbonBarButtonItem |
Class | RibbonBarButtonItemArgs |
Class | RibbonBarButtonItemMenuClickArgs |
Class | RibbonBarCheckBoxItem |
Class | RibbonBarCheckBoxItemArgs |
Class | RibbonBarComboBoxItem |
Class | RibbonBarDropDownButtonItem |
Class | RibbonBarFlowItem |
Class | RibbonBarGroup |
Class | RibbonBarGroupArgs |
Class | RibbonBarGroupCollection |
Class | RibbonBarItem |
Class | RibbonBarItemCollection |
Class | RibbonBarItemContainer |
Class | RibbonBarPage |
Class | RibbonBarPageCollection |
Class | RibbonBarStackItem |
Class | RibbonBarTextBoxItem |
Class | RibbonBarTextBoxItemArgs |
Class | RibbonBarToolBarButtonItem |
Class | RibbonBarToolBarDropDownButtonItem |
Class | RibbonBarToolBarItem |
Class | RichTextEditor | Summary description for RichTextEditor
Class | ScheduleBox | Represents a WebGUI schedule box control.
Class | ScheduleBox.ScheduleBoxEventArgs |
Class | ScheduleBoxEvent | Represents a schedule event
Class | ScheduleBoxEventCollection | Represents a collection of events in a ScheduleBox.
Class | SearchTextBox | Summary description for SearchTextBox

Interfaces

 | Interface | Description
Interface | ISupportsRibbonBar | Indicates the the class can create ribbon bar items

Delegates

 | Delegate | Description
Delegate | NavigationTabEventHandler |
Delegate | ScheduleBox.ScheduleBoxEventHandler |

Enumerations

 | Enumeration | Description
Enumeration | ScheduleBoxHourFormat | ScheduleBox hour format
Enumeration | ScheduleBoxView | ScheduleBox views

See Also

Reference

Gizmox.WebGUI.Forms.Office Assembly


HeaderedPanel Class

[image]
Gizmox.WebGUI.Forms.Office
HeaderedPanel Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : HeaderedPanel Class

Object Model

Syntax

Visual Basic (Declaration)
<SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableHeaderedPanel,  Gizmox.WebGUI.Silverlight.Controls.Office, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="HeaderedPanel")>
<WebCompilerResourcesAttribute(Assembly=, Namespace="Gizmox.WebGUI.Forms.Office")>
Public Class HeaderedPanel
   Inherits Panel
   Implements IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IRequiredRegistration, IBindableComponent, IArrangedElement
Visual Basic (Usage) Copy Code
Dim instance As HeaderedPanel
C#
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableHeaderedPanel,  Gizmox.WebGUI.Silverlight.Controls.Office, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="HeaderedPanel")]
[WebCompilerResourcesAttribute(Assembly=, Namespace="Gizmox.WebGUI.Forms.Office")]
public class HeaderedPanel : Panel, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IRequiredRegistration, IBindableComponent, IArrangedElement
Managed Extensions for C++
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableHeaderedPanel,  Gizmox.WebGUI.Silverlight.Controls.Office, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="HeaderedPanel")]
[WebCompilerResourcesAttribute(Assembly=, Namespace="Gizmox.WebGUI.Forms.Office")]
public __gc class HeaderedPanel : public Panel, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IRequiredRegistration, IBindableComponent, IArrangedElement
C++/CLI
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableHeaderedPanel,  Gizmox.WebGUI.Silverlight.Controls.Office, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="HeaderedPanel")]
[WebCompilerResourcesAttribute(Assembly=, Namespace="Gizmox.WebGUI.Forms.Office")]
public ref class HeaderedPanel : public Panel, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IRequiredRegistration, IBindableComponent, IArrangedElement

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.ScrollableControl
Gizmox.WebGUI.Forms.Panel
Gizmox.WebGUI.Forms.HeaderedPanel

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms.Office (in Gizmox.WebGUI.Forms.Office.dll)

See Also

Reference

HeaderedPanel Members
Gizmox.WebGUI.Forms Namespace


HeaderedPanel Class Members

[image]
Gizmox.WebGUI.Forms.Office
HeaderedPanel Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : HeaderedPanel Class

The following tables list the members exposed by HeaderedPanel.

Public Constructors

 | Name | Description
Public Constructor | HeaderedPanel Constructor | Initializes a new instance of the HeaderedPanel class.
Top

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl)
Public Property | AutoSize | (Inherited from Panel)
Public Property | AutoSizeMode | Indicates the automatic sizing behavior of the control. (Inherited from Panel)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Gets a value indicating whether this control can recive focus. (Inherited from Panel)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Header | Gets or sets the header control.
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | Icon | Gets or sets the header icon.
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text. (Inherited from Panel)
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Protected Property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl)
Top

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Control)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from ScrollableControl)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | Overridden.
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Control)
Protected Method | RenderAttributes | Overridden. Renders the attributes.
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Overridden. Renders the controls sub tree
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | (Inherited from Panel)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializePanelType | (Inherited from Panel)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

HeaderedPanel Class
Gizmox.WebGUI.Forms Namespace


HeaderedPanel Constructor

[image]
Gizmox.WebGUI.Forms.Office
HeaderedPanel Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > HeaderedPanel Class : HeaderedPanel Constructor

Initializes a new instance of the HeaderedPanel class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As HeaderedPanel()
C#
public HeaderedPanel()
Managed Extensions for C++
public: HeaderedPanel();
C++/CLI
public:
HeaderedPanel();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HeaderedPanel Class
HeaderedPanel Members


HeaderedPanel Class Methods

[image]
Gizmox.WebGUI.Forms.Office
HeaderedPanel Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : HeaderedPanel Class

For a list of all members of this type, see HeaderedPanel members.

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Control)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from ScrollableControl)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | Overridden.
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Control)
Protected Method | RenderAttributes | Overridden. Renders the attributes.
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Overridden. Renders the controls sub tree
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | (Inherited from Panel)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializePanelType | (Inherited from Panel)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

See Also

Reference

HeaderedPanel Class
Gizmox.WebGUI.Forms Namespace


OnUnregisterComponents Method

[image]
Gizmox.WebGUI.Forms.Office
OnUnregisterComponents Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > HeaderedPanel Class : OnUnregisterComponents Method

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnUnregisterComponents()
Visual Basic (Usage) Copy Code
Dim instance As HeaderedPanel

instance.OnUnregisterComponents()
C#
protected override void OnUnregisterComponents()
Managed Extensions for C++
protected: void OnUnregisterComponents(); override
C++/CLI
protected:
void OnUnregisterComponents(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HeaderedPanel Class
HeaderedPanel Members


RenderAttributes Method

[image]
Gizmox.WebGUI.Forms.Office
RenderAttributes Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > HeaderedPanel Class : RenderAttributes Method

objContext
The context.
objWriter
The writer.
Renders the attributes.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub RenderAttributes( _
   ByVal objContext As IContext, _
   ByVal objWriter As IAttributeWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As HeaderedPanel
Dim objContext As IContext
Dim objWriter As IAttributeWriter

instance.RenderAttributes(objContext, objWriter)
C#
protected override void RenderAttributes(
   IContext objContext,
   IAttributeWriter objWriter
)
Managed Extensions for C++
protected: void RenderAttributes(
   IContext* objContext,
   IAttributeWriter* objWriter
) override
C++/CLI
protected:
void RenderAttributes(
   IContext^ objContext,
   IAttributeWriter^ objWriter
) override

Parameters

objContext
The context.
objWriter
The writer.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HeaderedPanel Class
HeaderedPanel Members


RenderControls Method

[image]
Gizmox.WebGUI.Forms.Office
RenderControls Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > HeaderedPanel Class : RenderControls Method

Renders the controls sub tree

Overload List

Overload | Description
RenderControls(IContext,IResponseWriter,Int64) |
RenderControls(IContext,IResponseWriter,Int64,Boolean) | Renders the controls sub tree (Inherited from Control)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HeaderedPanel Class
HeaderedPanel Members


RenderControls(IContext,IResponseWriter,Int64) Method

[image]
Gizmox.WebGUI.Forms.Office
RenderControls(IContext,IResponseWriter,Int64) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > HeaderedPanel Class > RenderControls Method : RenderControls(IContext,IResponseWriter,Int64) Method

objContext
objWriter
lngRequestID

Syntax

Visual Basic (Declaration)
Protected Overloads Overrides Sub RenderControls( _
   ByVal objContext As IContext, _
   ByVal objWriter As IResponseWriter, _
   ByVal lngRequestID As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As HeaderedPanel
Dim objContext As IContext
Dim objWriter As IResponseWriter
Dim lngRequestID As Long

instance.RenderControls(objContext, objWriter, lngRequestID)
C#
protected override void RenderControls(
   IContext objContext,
   IResponseWriter objWriter,
   long lngRequestID
)
Managed Extensions for C++
protected: void RenderControls(
   IContext* objContext,
   IResponseWriter* objWriter,
   long lngRequestID
) override
C++/CLI
protected:
void RenderControls(
   IContext^ objContext,
   IResponseWriter^ objWriter,
   long long lngRequestID
) override

Parameters

objContext
objWriter
lngRequestID

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HeaderedPanel Class
HeaderedPanel Members
Overload List


HeaderedPanel Class Properties

[image]
Gizmox.WebGUI.Forms.Office
HeaderedPanel Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : HeaderedPanel Class

For a list of all members of this type, see HeaderedPanel members.

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl)
Public Property | AutoSize | (Inherited from Panel)
Public Property | AutoSizeMode | Indicates the automatic sizing behavior of the control. (Inherited from Panel)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Gets a value indicating whether this control can recive focus. (Inherited from Panel)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Header | Gets or sets the header control.
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | Icon | Gets or sets the header icon.
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text. (Inherited from Panel)
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Protected Property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl)
Top

See Also

Reference

HeaderedPanel Class
Gizmox.WebGUI.Forms Namespace


Header Property

[image]
Gizmox.WebGUI.Forms.Office
Header Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > HeaderedPanel Class : Header Property

Gets or sets the header control.

Syntax

Visual Basic (Declaration)
Public Property Header As Control
Visual Basic (Usage) Copy Code
Dim instance As HeaderedPanel
Dim value As Control

instance.Header = value

value = instance.Header
C#
public Control Header {get; set;}
Managed Extensions for C++
public: __property Control* get_Header();
public: __property void set_Header(
   Control* value
);
C++/CLI
public:
property Control^ Header {
   Control^ get();
   void set (Control^value);
}

Return Value

The header control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HeaderedPanel Class
HeaderedPanel Members


Icon Property

[image]
Gizmox.WebGUI.Forms.Office
Icon Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > HeaderedPanel Class : Icon Property

Gets or sets the header icon.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property Icon As ResourceHandle
Visual Basic (Usage) Copy Code
Dim instance As HeaderedPanel
Dim value As ResourceHandle

instance.Icon = value

value = instance.Icon
C#
[DefaultValueAttribute()]
public ResourceHandle Icon {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property ResourceHandle* get_Icon();
public: __property void set_Icon(
   ResourceHandle* value
);
C++/CLI
[DefaultValueAttribute()]
public:
property ResourceHandle^ Icon {
   ResourceHandle^ get();
   void set (ResourceHandle^value);
}

Return Value

The header icon.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

HeaderedPanel Class
HeaderedPanel Members


NavigationTab Class

[image]
Gizmox.WebGUI.Forms.Office
NavigationTab Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : NavigationTab Class

Summary description for NavigationTab.

Object Model

Syntax

Visual Basic (Declaration)
<WebCompilerResourcesAttribute(Assembly=, Namespace="Gizmox.WebGUI.Forms")>
<ToolboxBitmapAttribute()>
<DesignTimeControllerAttribute()>
<ClientControllerAttribute()>
<ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")>
Public Class NavigationTab
   Inherits TabPage
   Implements IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Visual Basic (Usage) Copy Code
Dim instance As NavigationTab
C#
[WebCompilerResourcesAttribute(Assembly=, Namespace="Gizmox.WebGUI.Forms")]
[ToolboxBitmapAttribute()]
[DesignTimeControllerAttribute()]
[ClientControllerAttribute()]
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
public class NavigationTab : TabPage, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Managed Extensions for C++
[WebCompilerResourcesAttribute(Assembly=, Namespace="Gizmox.WebGUI.Forms")]
[ToolboxBitmapAttribute()]
[DesignTimeControllerAttribute()]
[ClientControllerAttribute()]
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
public __gc class NavigationTab : public TabPage, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
C++/CLI
[WebCompilerResourcesAttribute(Assembly=, Namespace="Gizmox.WebGUI.Forms")]
[ToolboxBitmapAttribute()]
[DesignTimeControllerAttribute()]
[ClientControllerAttribute()]
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
public ref class NavigationTab : public TabPage, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.ScrollableControl
Gizmox.WebGUI.Forms.Panel
Gizmox.WebGUI.Forms.TabPage
Gizmox.WebGUI.Forms.NavigationTab

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms.Office (in Gizmox.WebGUI.Forms.Office.dll)

See Also

Reference

NavigationTab Members
Gizmox.WebGUI.Forms Namespace


NavigationTab Class Members

[image]
Gizmox.WebGUI.Forms.Office
NavigationTab Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : NavigationTab Class

The following tables list the members exposed by NavigationTab.

Public Constructors

 | Name | Description
Public Constructor | NavigationTab Constructor | Overloaded. Creates a new NavigationTab instance.
Top

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl)
Public Property | AutoSize | (Inherited from Panel)
Public Property | AutoSizeMode | Indicates the automatic sizing behavior of the control. (Inherited from Panel)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Gets a value indicating whether this control can recive focus. (Inherited from Panel)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Extra | Gets or sets a value indicating whether this NavigationTab is extra.
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | Image | Gets or sets the image. (Inherited from TabPage)
Public Property | ImageIndex | Gets or sets the index of the image that is displayed for the item. (Inherited from TabPage)
Public Property | ImageKey | Gets or sets the key for the image that is displayed for the item. (Inherited from TabPage)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Label | Gets or sets the label.
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Loaded | Gets a value indicating whether this TabPage is loaded. (Inherited from TabPage)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | NavigationTabs | Gets the navigation tabs.
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | PanelType | Gets or sets the panel type. (Inherited from TabPage)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | TabControl | Gets the TabControl control. (Inherited from TabPage)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text to display on the tab. (Inherited from TabPage)
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | Visible | Gets or sets the control visability. (Inherited from TabPage)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Protected Property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl)
Top

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | CompareTo | Compares the current instance with another object of the same type. (Inherited from TabPage)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | Returns a string containing the value of the TabPage.Text property. (Inherited from TabPage)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Control)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from ScrollableControl)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Control)
Protected Method | RenderAttributes | Overridden. Renders the controls meta attributes
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from TabPage)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | (Inherited from Panel)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeImage | Shows the serialize image. (Inherited from TabPage)
Protected Method | ShouldSerializePanelType | (Inherited from Panel)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

NavigationTab Class
Gizmox.WebGUI.Forms Namespace


NavigationTab Constructor

[image]
Gizmox.WebGUI.Forms.Office
NavigationTab Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > NavigationTab Class : NavigationTab Constructor

Creates a new NavigationTab instance.

Overload List

Overload | Description
NavigationTab Constructor() | Creates a new NavigationTab instance.
NavigationTab Constructor(String) | Creates a new NavigationTab instance.
NavigationTab Constructor(String,String) |
NavigationTab Constructor(String,String,Boolean,Control) |
NavigationTab Constructor(String,String,Control) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

NavigationTab Class
NavigationTab Members


NavigationTab Constructor()

[image]
Gizmox.WebGUI.Forms.Office
NavigationTab Constructor()
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > NavigationTab Class > NavigationTab Constructor : NavigationTab Constructor()

Creates a new NavigationTab instance.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As NavigationTab()
C#
public NavigationTab()
Managed Extensions for C++
public: NavigationTab();
C++/CLI
public:
NavigationTab();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

NavigationTab Class
NavigationTab Members
Overload List


NavigationTab Constructor(String)

[image]
Gizmox.WebGUI.Forms.Office
NavigationTab Constructor(String)
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > NavigationTab Class > NavigationTab Constructor : NavigationTab Constructor(String)

strText
The tab page text.
Creates a new NavigationTab instance.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal strText As String _
)
Visual Basic (Usage) Copy Code
Dim strText As String

Dim instance As NavigationTab(strText)
C#
public NavigationTab(
   string strText
)
Managed Extensions for C++
public: NavigationTab(
   string* strText
)
C++/CLI
public:
NavigationTab(
   String^ strText
)

Parameters

strText
The tab page text.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

NavigationTab Class
NavigationTab Members
Overload List


NavigationTab Constructor(String,String)

[image]
Gizmox.WebGUI.Forms.Office
NavigationTab Constructor(String,String)
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > NavigationTab Class > NavigationTab Constructor : NavigationTab Constructor(String,String)

strIcon
strText

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal strIcon As String, _
   ByVal strText As String _
)
Visual Basic (Usage) Copy Code
Dim strIcon As String
Dim strText As String

Dim instance As NavigationTab(strIcon, strText)
C#
public NavigationTab(
   string strIcon,
   string strText
)
Managed Extensions for C++
public: NavigationTab(
   string* strIcon,
   string* strText
)
C++/CLI
public:
NavigationTab(
   String^ strIcon,
   String^ strText
)

Parameters

strIcon
strText

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

NavigationTab Class
NavigationTab Members
Overload List


NavigationTab Constructor(String,String,Boolean,Control)

[image]
Gizmox.WebGUI.Forms.Office
NavigationTab Constructor(String,String,Boolean,Control)
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > NavigationTab Class > NavigationTab Constructor : NavigationTab Constructor(String,String,Boolean,Control)

strIcon
strText
blnExtra
objControl

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal strIcon As String, _
   ByVal strText As String, _
   ByVal blnExtra As Boolean, _
   ByVal objControl As Control _
)
Visual Basic (Usage) Copy Code
Dim strIcon As String
Dim strText As String
Dim blnExtra As Boolean
Dim objControl As Control

Dim instance As NavigationTab(strIcon, strText, blnExtra, objControl)
C#
public NavigationTab(
   string strIcon,
   string strText,
   bool blnExtra,
   Control objControl
)
Managed Extensions for C++
public: NavigationTab(
   string* strIcon,
   string* strText,
   bool blnExtra,
   Control* objControl
)
C++/CLI
public:
NavigationTab(
   String^ strIcon,
   String^ strText,
   bool blnExtra,
   Control^ objControl
)

Parameters

strIcon
strText
blnExtra
objControl

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

NavigationTab Class
NavigationTab Members
Overload List


NavigationTab Constructor(String,String,Control)

[image]
Gizmox.WebGUI.Forms.Office
NavigationTab Constructor(String,String,Control)
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > NavigationTab Class > NavigationTab Constructor : NavigationTab Constructor(String,String,Control)

strIcon
strText
objControl

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal strIcon As String, _
   ByVal strText As String, _
   ByVal objControl As Control _
)
Visual Basic (Usage) Copy Code
Dim strIcon As String
Dim strText As String
Dim objControl As Control

Dim instance As NavigationTab(strIcon, strText, objControl)
C#
public NavigationTab(
   string strIcon,
   string strText,
   Control objControl
)
Managed Extensions for C++
public: NavigationTab(
   string* strIcon,
   string* strText,
   Control* objControl
)
C++/CLI
public:
NavigationTab(
   String^ strIcon,
   String^ strText,
   Control^ objControl
)

Parameters

strIcon
strText
objControl

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

NavigationTab Class
NavigationTab Members
Overload List


NavigationTab Class Methods

[image]
Gizmox.WebGUI.Forms.Office
NavigationTab Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : NavigationTab Class

For a list of all members of this type, see NavigationTab members.

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | CompareTo | Compares the current instance with another object of the same type. (Inherited from TabPage)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | Returns a string containing the value of the TabPage.Text property. (Inherited from TabPage)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Control)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from ScrollableControl)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Control)
Protected Method | RenderAttributes | Overridden. Renders the controls meta attributes
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from TabPage)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | (Inherited from Panel)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeImage | Shows the serialize image. (Inherited from TabPage)
Protected Method | ShouldSerializePanelType | (Inherited from Panel)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

See Also

Reference

NavigationTab Class
Gizmox.WebGUI.Forms Namespace


RenderAttributes Method

[image]
Gizmox.WebGUI.Forms.Office
RenderAttributes Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > NavigationTab Class : RenderAttributes Method

objContext
Request context.
objWriter
Renders the controls meta attributes

Syntax

Visual Basic (Declaration)
Protected Overrides Sub RenderAttributes( _
   ByVal objContext As IContext, _
   ByVal objWriter As IAttributeWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As NavigationTab
Dim objContext As IContext
Dim objWriter As IAttributeWriter

instance.RenderAttributes(objContext, objWriter)
C#
protected override void RenderAttributes(
   IContext objContext,
   IAttributeWriter objWriter
)
Managed Extensions for C++
protected: void RenderAttributes(
   IContext* objContext,
   IAttributeWriter* objWriter
) override
C++/CLI
protected:
void RenderAttributes(
   IContext^ objContext,
   IAttributeWriter^ objWriter
) override

Parameters

objContext
Request context.
objWriter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

NavigationTab Class
NavigationTab Members


NavigationTab Class Properties

[image]
Gizmox.WebGUI.Forms.Office
NavigationTab Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : NavigationTab Class

For a list of all members of this type, see NavigationTab members.

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl)
Public Property | AutoSize | (Inherited from Panel)
Public Property | AutoSizeMode | Indicates the automatic sizing behavior of the control. (Inherited from Panel)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Gets a value indicating whether this control can recive focus. (Inherited from Panel)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Extra | Gets or sets a value indicating whether this NavigationTab is extra.
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | Image | Gets or sets the image. (Inherited from TabPage)
Public Property | ImageIndex | Gets or sets the index of the image that is displayed for the item. (Inherited from TabPage)
Public Property | ImageKey | Gets or sets the key for the image that is displayed for the item. (Inherited from TabPage)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Label | Gets or sets the label.
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Loaded | Gets a value indicating whether this TabPage is loaded. (Inherited from TabPage)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | NavigationTabs | Gets the navigation tabs.
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | PanelType | Gets or sets the panel type. (Inherited from TabPage)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | TabControl | Gets the TabControl control. (Inherited from TabPage)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text to display on the tab. (Inherited from TabPage)
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | Visible | Gets or sets the control visability. (Inherited from TabPage)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Protected Property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl)
Top

See Also

Reference

NavigationTab Class
Gizmox.WebGUI.Forms Namespace


Extra Property

[image]
Gizmox.WebGUI.Forms.Office
Extra Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > NavigationTab Class : Extra Property

Gets or sets a value indicating whether this NavigationTab is extra.

Syntax

Visual Basic (Declaration)
Public Property Extra As Boolean
Visual Basic (Usage) Copy Code
Dim instance As NavigationTab
Dim value As Boolean

instance.Extra = value

value = instance.Extra
C#
public bool Extra {get; set;}
Managed Extensions for C++
public: __property bool get_Extra();
public: __property void set_Extra(
   bool value
);
C++/CLI
public:
property bool Extra {
   bool get();
   void set (boolvalue);
}

Return Value

true if extra; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

NavigationTab Class
NavigationTab Members


Label Property

[image]
Gizmox.WebGUI.Forms.Office
Label Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > NavigationTab Class : Label Property

Gets or sets the label.

Syntax

Visual Basic (Declaration)
Public Property Label As String
Visual Basic (Usage) Copy Code
Dim instance As NavigationTab
Dim value As String

instance.Label = value

value = instance.Label
C#
public string Label {get; set;}
Managed Extensions for C++
public: __property string* get_Label();
public: __property void set_Label(
   string* value
);
C++/CLI
public:
property String^ Label {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

NavigationTab Class
NavigationTab Members


NavigationTabs Property

[image]
Gizmox.WebGUI.Forms.Office
NavigationTabs Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > NavigationTab Class : NavigationTabs Property

Gets the navigation tabs.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property NavigationTabs As NavigationTabs
Visual Basic (Usage) Copy Code
Dim instance As NavigationTab
Dim value As NavigationTabs

value = instance.NavigationTabs
C#
public NavigationTabs NavigationTabs {get;}
Managed Extensions for C++
public: __property NavigationTabs* get_NavigationTabs();
C++/CLI
public:
property NavigationTabs^ NavigationTabs {
   NavigationTabs^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

NavigationTab Class
NavigationTab Members


NavigationTabCollection Class

[image]
Gizmox.WebGUI.Forms.Office
NavigationTabCollection Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : NavigationTabCollection Class

Tab pages collection class

Object Model

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class NavigationTabCollection
   Inherits TabPageCollection
Visual Basic (Usage) Copy Code
Dim instance As NavigationTabCollection
C#
[DefaultMemberAttribute("Item")]
public class NavigationTabCollection : TabPageCollection
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
public __gc class NavigationTabCollection : public TabPageCollection
C++/CLI
[DefaultMemberAttribute("Item")]
public ref class NavigationTabCollection : public TabPageCollection

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.TabPageCollection
Gizmox.WebGUI.Forms.NavigationTabCollection

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms.Office (in Gizmox.WebGUI.Forms.Office.dll)

See Also

Reference

NavigationTabCollection Members
Gizmox.WebGUI.Forms Namespace


NavigationTabCollection Class Members

[image]
Gizmox.WebGUI.Forms.Office
NavigationTabCollection Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : NavigationTabCollection Class

The following tables list the members exposed by NavigationTabCollection.

Public Properties

 | Name | Description
Public Property | Count | Gets the number of tab pages in the collection. (Inherited from TabPageCollection)
Public Property | IsFixedSize | Gets a value indicating whether the TabPageCollection has a fixed size. (Inherited from TabPageCollection)
Public Property | IsReadOnly | Gets a value indicating whether the collection is read-only. (Inherited from TabPageCollection)
Public Property | IsSynchronized | Gets a value indicating whether access to the TabPageCollection is synchronized (thread safe). (Inherited from TabPageCollection)
Public Property | Item | Gets the TabPage with the specified int index.
Public Property | SyncRoot | Gets an object that can be used to synchronize access to the TabPageCollection. (Inherited from TabPageCollection)
Top

Public Methods

 | Name | Description
Public Method | Add | Overridden. Adds the specified tab page.
Public Method | Clear | Removes all the tab pages from the collection. (Inherited from TabPageCollection)
Public Method | Compare | Compares the index of two sequencial TabPages in the TabPageCollection. (Inherited from TabPageCollection)
Public Method | Contains | Determines whether the specified TabPage control is in the TabPageCollection. (Inherited from TabPageCollection)
Public Method | CopyTo | Copies the elements of the collection to the specified array, starting at the specified index. (Inherited from TabPageCollection)
Public Method | GetEnumerator | Returns an enumeration of all the tab pages in the collection. (Inherited from TabPageCollection)
Public Method | IndexOf | Returns the index of the specified tab page in the collection. (Inherited from TabPageCollection)
Public Method | Insert | Inserts an existing tab page into the collection at the specified index. (Inherited from TabPageCollection)
Public Method | Remove | Overridden. Removes the specified tab page.
Public Method | RemoveAt | Removes the tab page at the specified index from the collection. (Inherited from TabPageCollection)
Top

Protected Methods

 | Name | Description
Protected Method | AdvanceTabIndexFromIndex | Overloaded. Advances the TabIndex property by the value of 'advanceBy', begginning at the 'fromIndex' position. (Inherited from TabPageCollection)
Protected Method | GetSortedTabPageListFromCurrent | Returns a sorted TabPage list from current unsorted TabPageCollection. (Inherited from TabPageCollection)
Top

See Also

Reference

NavigationTabCollection Class
Gizmox.WebGUI.Forms Namespace


NavigationTabCollection Class Methods

[image]
Gizmox.WebGUI.Forms.Office
NavigationTabCollection Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : NavigationTabCollection Class

For a list of all members of this type, see NavigationTabCollection members.

Public Methods

 | Name | Description
Public Method | Add | Overridden. Adds the specified tab page.
Public Method | Clear | Removes all the tab pages from the collection. (Inherited from TabPageCollection)
Public Method | Compare | Compares the index of two sequencial TabPages in the TabPageCollection. (Inherited from TabPageCollection)
Public Method | Contains | Determines whether the specified TabPage control is in the TabPageCollection. (Inherited from TabPageCollection)
Public Method | CopyTo | Copies the elements of the collection to the specified array, starting at the specified index. (Inherited from TabPageCollection)
Public Method | GetEnumerator | Returns an enumeration of all the tab pages in the collection. (Inherited from TabPageCollection)
Public Method | IndexOf | Returns the index of the specified tab page in the collection. (Inherited from TabPageCollection)
Public Method | Insert | Inserts an existing tab page into the collection at the specified index. (Inherited from TabPageCollection)
Public Method | Remove | Overridden. Removes the specified tab page.
Public Method | RemoveAt | Removes the tab page at the specified index from the collection. (Inherited from TabPageCollection)
Top

Protected Methods

 | Name | Description
Protected Method | AdvanceTabIndexFromIndex | Overloaded. Advances the TabIndex property by the value of 'advanceBy', begginning at the 'fromIndex' position. (Inherited from TabPageCollection)
Protected Method | GetSortedTabPageListFromCurrent | Returns a sorted TabPage list from current unsorted TabPageCollection. (Inherited from TabPageCollection)
Top

See Also

Reference

NavigationTabCollection Class
Gizmox.WebGUI.Forms Namespace


Add Method

[image]
Gizmox.WebGUI.Forms.Office
Add Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > NavigationTabCollection Class : Add Method

objTabPage
tab page.
Adds the specified tab page.

Syntax

Visual Basic (Declaration)
Public Overrides Function Add( _
   ByVal objTabPage As TabPage _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As NavigationTabCollection
Dim objTabPage As TabPage
Dim value As Integer

value = instance.Add(objTabPage)
C#
public override int Add(
   TabPage objTabPage
)
Managed Extensions for C++
public: int Add(
   TabPage* objTabPage
) override
C++/CLI
public:
int Add(
   TabPage^ objTabPage
) override

Parameters

objTabPage
tab page.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

NavigationTabCollection Class
NavigationTabCollection Members


Remove Method

[image]
Gizmox.WebGUI.Forms.Office
Remove Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > NavigationTabCollection Class : Remove Method

objTabPage
tab page.
Removes the specified tab page.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Remove( _
   ByVal objTabPage As TabPage _
)
Visual Basic (Usage) Copy Code
Dim instance As NavigationTabCollection
Dim objTabPage As TabPage

instance.Remove(objTabPage)
C#
public override void Remove(
   TabPage objTabPage
)
Managed Extensions for C++
public: void Remove(
   TabPage* objTabPage
) override
C++/CLI
public:
void Remove(
   TabPage^ objTabPage
) override

Parameters

objTabPage
tab page.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

NavigationTabCollection Class
NavigationTabCollection Members


NavigationTabCollection Class Properties

[image]
Gizmox.WebGUI.Forms.Office
NavigationTabCollection Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : NavigationTabCollection Class

For a list of all members of this type, see NavigationTabCollection members.

Public Properties

 | Name | Description
Public Property | Count | Gets the number of tab pages in the collection. (Inherited from TabPageCollection)
Public Property | IsFixedSize | Gets a value indicating whether the TabPageCollection has a fixed size. (Inherited from TabPageCollection)
Public Property | IsReadOnly | Gets a value indicating whether the collection is read-only. (Inherited from TabPageCollection)
Public Property | IsSynchronized | Gets a value indicating whether access to the TabPageCollection is synchronized (thread safe). (Inherited from TabPageCollection)
Public Property | Item | Gets the TabPage with the specified int index.
Public Property | SyncRoot | Gets an object that can be used to synchronize access to the TabPageCollection. (Inherited from TabPageCollection)
Top

See Also

Reference

NavigationTabCollection Class
Gizmox.WebGUI.Forms Namespace


Item Property

[image]
Gizmox.WebGUI.Forms.Office
Item Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > NavigationTabCollection Class : Item Property

intIndex
Gets the TabPage with the specified int index.

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal intIndex As Integer _
) As NavigationTab
Visual Basic (Usage) Copy Code
Dim instance As NavigationTabCollection
Dim intIndex As Integer
Dim value As NavigationTab

value = instance.Item(intIndex)
C#
public NavigationTab this[
   int intIndex
]; {get;}
Managed Extensions for C++
public: __property NavigationTab* get_Item(
   int intIndex
);
C++/CLI
public:
property NavigationTab^ default [int] {
   NavigationTab^ get(intintIndex);
}

Parameters

intIndex

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

NavigationTabCollection Class
NavigationTabCollection Members


NavigationTabEventArgs Class

[image]
Gizmox.WebGUI.Forms.Office
NavigationTabEventArgs Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : NavigationTabEventArgs Class

Object Model

Syntax

Visual Basic (Declaration)
Public Class NavigationTabEventArgs
   Inherits EventArgs
Visual Basic (Usage) Copy Code
Dim instance As NavigationTabEventArgs
C#
public class NavigationTabEventArgs : EventArgs
Managed Extensions for C++
public __gc class NavigationTabEventArgs : public EventArgs
C++/CLI
public ref class NavigationTabEventArgs : public EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gizmox.WebGUI.Forms.NavigationTabEventArgs

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms.Office (in Gizmox.WebGUI.Forms.Office.dll)

See Also

Reference

NavigationTabEventArgs Members
Gizmox.WebGUI.Forms Namespace


NavigationTabEventArgs Class Members

[image]
Gizmox.WebGUI.Forms.Office
NavigationTabEventArgs Class Members
See Also Fields Send Feedback
Gizmox.WebGUI.Forms Namespace : NavigationTabEventArgs Class

The following tables list the members exposed by NavigationTabEventArgs.

Public Constructors

 | Name | Description
Public Constructor | NavigationTabEventArgs Constructor | Creates a new TreeViewNodeEventArgs instance.
Top

Public Fields

 | Name | Description
Public Field | NavigationTab |
Top

See Also

Reference

NavigationTabEventArgs Class
Gizmox.WebGUI.Forms Namespace


NavigationTabEventArgs Constructor

[image]
Gizmox.WebGUI.Forms.Office
NavigationTabEventArgs Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > NavigationTabEventArgs Class : NavigationTabEventArgs Constructor

objNavigationTab
Navigation tab.
Creates a new TreeViewNodeEventArgs instance.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal objNavigationTab As NavigationTab _
)
Visual Basic (Usage) Copy Code
Dim objNavigationTab As NavigationTab

Dim instance As NavigationTabEventArgs(objNavigationTab)
C#
public NavigationTabEventArgs(
   NavigationTab objNavigationTab
)
Managed Extensions for C++
public: NavigationTabEventArgs(
   NavigationTab* objNavigationTab
)
C++/CLI
public:
NavigationTabEventArgs(
   NavigationTab^ objNavigationTab
)

Parameters

objNavigationTab
Navigation tab.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

NavigationTabEventArgs Class
NavigationTabEventArgs Members


NavigationTabEventArgs Class Fields

[image]
Gizmox.WebGUI.Forms.Office
NavigationTabEventArgs Class Fields
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : NavigationTabEventArgs Class

For a list of all members of this type, see NavigationTabEventArgs members.

Public Fields

 | Name | Description
Public Field | NavigationTab |
Top

See Also

Reference

NavigationTabEventArgs Class
Gizmox.WebGUI.Forms Namespace


NavigationTab Field

[image]
Gizmox.WebGUI.Forms.Office
NavigationTab Field
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > NavigationTabEventArgs Class : NavigationTab Field

Syntax

Visual Basic (Declaration)
Public ReadOnly NavigationTab As NavigationTab
Visual Basic (Usage) Copy Code
Dim instance As NavigationTabEventArgs
Dim value As NavigationTab

value = instance.NavigationTab
C#
public readonly NavigationTab NavigationTab
Managed Extensions for C++
public: readonly NavigationTab* NavigationTab
C++/CLI
public:
readonly NavigationTab^ NavigationTab

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

NavigationTabEventArgs Class
NavigationTabEventArgs Members


NavigationTabs Class

[image]
Gizmox.WebGUI.Forms.Office
NavigationTabs Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : NavigationTabs Class

Summary description for NavigationTabs.

Object Model

Syntax

Visual Basic (Declaration)
<ClientControllerAttribute()>
<DesignTimeControllerAttribute()>
<SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableNavigationTabControl, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="Navigation")>
<WebCompilerResourcesAttribute(Assembly=, Namespace="Gizmox.WebGUI.Forms.Office")>
Public Class NavigationTabs
   Inherits TabControl
   Implements IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IRequiredRegistration, IBindableComponent, IArrangedElement
Visual Basic (Usage) Copy Code
Dim instance As NavigationTabs
C#
[ClientControllerAttribute()]
[DesignTimeControllerAttribute()]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableNavigationTabControl, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="Navigation")]
[WebCompilerResourcesAttribute(Assembly=, Namespace="Gizmox.WebGUI.Forms.Office")]
public class NavigationTabs : TabControl, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IRequiredRegistration, IBindableComponent, IArrangedElement
Managed Extensions for C++
[ClientControllerAttribute()]
[DesignTimeControllerAttribute()]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableNavigationTabControl, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="Navigation")]
[WebCompilerResourcesAttribute(Assembly=, Namespace="Gizmox.WebGUI.Forms.Office")]
public __gc class NavigationTabs : public TabControl, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IRequiredRegistration, IBindableComponent, IArrangedElement
C++/CLI
[ClientControllerAttribute()]
[DesignTimeControllerAttribute()]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableNavigationTabControl, Gizmox.WebGUI.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="Navigation")]
[WebCompilerResourcesAttribute(Assembly=, Namespace="Gizmox.WebGUI.Forms.Office")]
public ref class NavigationTabs : public TabControl, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IRequiredRegistration, IBindableComponent, IArrangedElement

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.TabControl
Gizmox.WebGUI.Forms.NavigationTabs

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms.Office (in Gizmox.WebGUI.Forms.Office.dll)

See Also

Reference

NavigationTabs Members
Gizmox.WebGUI.Forms Namespace


NavigationTabs Class Members

[image]
Gizmox.WebGUI.Forms.Office
NavigationTabs Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : NavigationTabs Class

The following tables list the members exposed by NavigationTabs.

Public Constructors

 | Name | Description
Public Constructor | NavigationTabs Constructor |
Top

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | Appearance |
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientBehavior | Gets or sets the client drawing mode behavior (Inherited from TabControl)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | ImageList | Gets or sets the image list. (Inherited from TabControl)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsCollapsable | Gets or sets a value indicating whether this HeaderedPanel is collapsable.
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Multiline | Gets or sets a value indicating whether more than one row of tabs can be displayed. (Inherited from TabControl)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | SelectedIndex | Gets or sets the index of the currently selected tab page. (Inherited from TabControl)
Public Property | SelectedItem | Gets the selected item. (Inherited from TabControl)
Public Property | ShowCloseButton | Gets or Sets value indication if the close button (when Appearance==TabAppearance.Workspace) should be shown (Inherited from TabControl)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabPages | Gets the collection of tab pages in this tab control.
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Control)
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | Overridden. Gets the update handler.
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | This member overrides Control.CreateControlsInstance. (Inherited from TabControl)
Protected Method | CreateTabPageCollection | Overridden.
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from TabControl)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from TabControl)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from Control)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnSelectedIndexChanged | Raises the SelectedIndexChanged event. (Inherited from TabControl)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Control)
Protected Method | RenderAttributes | Renders the controls meta attributes (Inherited from TabControl)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Renders the controls. (Inherited from TabControl)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from TabControl)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | CloseClick | Occurs when the user clicks the tab control close button (Inherited from TabControl)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | SelectedIndexChanged | Occurs when the SelectedIndex property is changed. (Inherited from TabControl)
Public Event | SelectedIndexChanging | Occurs when the SelectedIndex property is about to change. (Inherited from TabControl)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

NavigationTabs Class
Gizmox.WebGUI.Forms Namespace


NavigationTabs Constructor

[image]
Gizmox.WebGUI.Forms.Office
NavigationTabs Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > NavigationTabs Class : NavigationTabs Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As NavigationTabs()
C#
public NavigationTabs()
Managed Extensions for C++
public: NavigationTabs();
C++/CLI
public:
NavigationTabs();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

NavigationTabs Class
NavigationTabs Members


NavigationTabs Class Methods

[image]
Gizmox.WebGUI.Forms.Office
NavigationTabs Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : NavigationTabs Class

For a list of all members of this type, see NavigationTabs members.

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | This member overrides Control.CreateControlsInstance. (Inherited from TabControl)
Protected Method | CreateTabPageCollection | Overridden.
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from TabControl)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from TabControl)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from Control)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnSelectedIndexChanged | Raises the SelectedIndexChanged event. (Inherited from TabControl)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Control)
Protected Method | RenderAttributes | Renders the controls meta attributes (Inherited from TabControl)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Renders the controls. (Inherited from TabControl)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from TabControl)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

See Also

Reference

NavigationTabs Class
Gizmox.WebGUI.Forms Namespace


CreateTabPageCollection Method

[image]
Gizmox.WebGUI.Forms.Office
CreateTabPageCollection Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > NavigationTabs Class : CreateTabPageCollection Method

Syntax

Visual Basic (Declaration)
Protected Overrides Function CreateTabPageCollection() As TabPageCollection
Visual Basic (Usage) Copy Code
Dim instance As NavigationTabs
Dim value As TabPageCollection

value = instance.CreateTabPageCollection()
C#
protected override TabPageCollection CreateTabPageCollection()
Managed Extensions for C++
protected: TabPageCollection* CreateTabPageCollection(); override
C++/CLI
protected:
TabPageCollection^ CreateTabPageCollection(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

NavigationTabs Class
NavigationTabs Members


NavigationTabs Class Properties

[image]
Gizmox.WebGUI.Forms.Office
NavigationTabs Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : NavigationTabs Class

For a list of all members of this type, see NavigationTabs members.

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | Appearance |
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientBehavior | Gets or sets the client drawing mode behavior (Inherited from TabControl)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | ImageList | Gets or sets the image list. (Inherited from TabControl)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsCollapsable | Gets or sets a value indicating whether this HeaderedPanel is collapsable.
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Multiline | Gets or sets a value indicating whether more than one row of tabs can be displayed. (Inherited from TabControl)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | SelectedIndex | Gets or sets the index of the currently selected tab page. (Inherited from TabControl)
Public Property | SelectedItem | Gets the selected item. (Inherited from TabControl)
Public Property | ShowCloseButton | Gets or Sets value indication if the close button (when Appearance==TabAppearance.Workspace) should be shown (Inherited from TabControl)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabPages | Gets the collection of tab pages in this tab control.
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Control)
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | Overridden. Gets the update handler.
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

See Also

Reference

NavigationTabs Class
Gizmox.WebGUI.Forms Namespace


Appearance Property

[image]
Gizmox.WebGUI.Forms.Office
Appearance Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > NavigationTabs Class : Appearance Property

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<LocalizableAttribute(True)>
<BrowsableAttribute(False)>
Public Property Appearance As TabAppearance
Visual Basic (Usage) Copy Code
Dim instance As NavigationTabs
Dim value As TabAppearance

instance.Appearance = value

value = instance.Appearance
C#
[DefaultValueAttribute()]
[LocalizableAttribute(true)]
[BrowsableAttribute(false)]
public TabAppearance Appearance {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[LocalizableAttribute(true)]
[BrowsableAttribute(false)]
public: __property TabAppearance get_Appearance();
public: __property void set_Appearance(
   TabAppearance value
);
C++/CLI
[DefaultValueAttribute()]
[LocalizableAttribute(true)]
[BrowsableAttribute(false)]
public:
property TabAppearance Appearance {
   TabAppearance get();
   void set (TabAppearancevalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

NavigationTabs Class
NavigationTabs Members


ClientUpdateHandler Property

[image]
Gizmox.WebGUI.Forms.Office
ClientUpdateHandler Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > NavigationTabs Class : ClientUpdateHandler Property

Gets the update handler.

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property ClientUpdateHandler As String
Visual Basic (Usage) Copy Code
Dim instance As NavigationTabs
Dim value As String

value = instance.ClientUpdateHandler
C#
protected override string ClientUpdateHandler {get;}
Managed Extensions for C++
protected: __property string* get_ClientUpdateHandler() override;
C++/CLI
protected:
property String^ ClientUpdateHandler {
   String^ get() override;
}

Return Value

The update handler.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

NavigationTabs Class
NavigationTabs Members


IsCollapsable Property

[image]
Gizmox.WebGUI.Forms.Office
IsCollapsable Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > NavigationTabs Class : IsCollapsable Property

Gets or sets a value indicating whether this HeaderedPanel is collapsable.

Syntax

Visual Basic (Declaration)
Public Property IsCollapsable As Boolean
Visual Basic (Usage) Copy Code
Dim instance As NavigationTabs
Dim value As Boolean

instance.IsCollapsable = value

value = instance.IsCollapsable
C#
public bool IsCollapsable {get; set;}
Managed Extensions for C++
public: __property bool get_IsCollapsable();
public: __property void set_IsCollapsable(
   bool value
);
C++/CLI
public:
property bool IsCollapsable {
   bool get();
   void set (boolvalue);
}

Return Value

true if collapsable; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

NavigationTabs Class
NavigationTabs Members


TabPages Property

[image]
Gizmox.WebGUI.Forms.Office
TabPages Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > NavigationTabs Class : TabPages Property

Gets the collection of tab pages in this tab control.

Syntax

Visual Basic (Declaration)
<MergablePropertyAttribute(False)>
<DesignerSerializationVisibilityAttribute()>
Public ReadOnly Property TabPages As NavigationTabCollection
Visual Basic (Usage) Copy Code
Dim instance As NavigationTabs
Dim value As NavigationTabCollection

value = instance.TabPages
C#
[MergablePropertyAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public NavigationTabCollection TabPages {get;}
Managed Extensions for C++
[MergablePropertyAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public: __property NavigationTabCollection* get_TabPages();
C++/CLI
[MergablePropertyAttribute(false)]
[DesignerSerializationVisibilityAttribute()]
public:
property NavigationTabCollection^ TabPages {
   NavigationTabCollection^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

NavigationTabs Class
NavigationTabs Members


RibbonBar Class

[image]
Gizmox.WebGUI.Forms.Office
RibbonBar Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBar Class

Summary description for RibonBar

Object Model

Syntax

Visual Basic (Declaration)
<WebCompilerResourcesAttribute(Assembly=, Namespace="Gizmox.WebGUI.Forms.Office")>
<ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<ToolboxBitmapAttribute()>
Public Class RibbonBar
   Inherits UserControl
   Implements IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IRequiredRegistration, IUserControl, IBindableComponent, IContainerControl, IArrangedElement
Visual Basic (Usage) Copy Code
Dim instance As RibbonBar
C#
[WebCompilerResourcesAttribute(Assembly=, Namespace="Gizmox.WebGUI.Forms.Office")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ToolboxBitmapAttribute()]
public class RibbonBar : UserControl, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IRequiredRegistration, IUserControl, IBindableComponent, IContainerControl, IArrangedElement
Managed Extensions for C++
[WebCompilerResourcesAttribute(Assembly=, Namespace="Gizmox.WebGUI.Forms.Office")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ToolboxBitmapAttribute()]
public __gc class RibbonBar : public UserControl, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IRequiredRegistration, IUserControl, IBindableComponent, IContainerControl, IArrangedElement
C++/CLI
[WebCompilerResourcesAttribute(Assembly=, Namespace="Gizmox.WebGUI.Forms.Office")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[ToolboxBitmapAttribute()]
public ref class RibbonBar : public UserControl, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IRequiredRegistration, IUserControl, IBindableComponent, IContainerControl, IArrangedElement

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.ScrollableControl
Gizmox.WebGUI.Forms.ContainerControl
Gizmox.WebGUI.Forms.UserControl
Gizmox.WebGUI.Forms.RibbonBar

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms.Office (in Gizmox.WebGUI.Forms.Office.dll)

See Also

Reference

RibbonBar Members
Gizmox.WebGUI.Forms Namespace


RibbonBar Class Members

[image]
Gizmox.WebGUI.Forms.Office
RibbonBar Class Members
See Also Fields Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBar Class

The following tables list the members exposed by RibbonBar.

Public Constructors

 | Name | Description
Public Constructor | RibbonBar Constructor | Initializes a new instance of the RibonBar class.
Top

Public Fields

 | Name | Description
Public Field | mblnIsLoaded | Gets a value indicating whether the instance of UserControl is loaded. (Inherited from UserControl)
Top

Public Properties

 | Name | Description
Public Property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl)
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl)
Public Property | AutoSize | (Inherited from UserControl)
Public Property | AutoSizeMode | Indicates the automatic sizing behavior of the control. (Inherited from UserControl)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from ContainerControl)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Components | (Inherited from ContainerControl)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from UserControl)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this control has controls. (Inherited from UserControl)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Pages | Gets the ribbon bar pages.
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | SelectedIndex | Gets or sets the index of the selected page.
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Control)
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Protected Property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl)
Top

Public Methods

 | Name | Description
Public Method | Add | (Inherited from ContainerControl)
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from ContainerControl)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | Remove | (Inherited from ContainerControl)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Control)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from ScrollableControl)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnAdvancedClicked | Called when advanced was clicked.
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnButtonClick | Called when a ribbon bar button has been clicked
Protected Method | OnButtonMenuClick | Called when button menu was clicked.
Protected Method | OnCheckedChanged |
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the CreateControl event. (Inherited from UserControl)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLoad | Raises the UserControl.Load event. (Inherited from UserControl)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnSelectedIndexChanged | Called when the selected page index has changed
Protected Method | OnTextChanged | Overloaded. Called when text changed.
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | Renders the specified obj context. (Inherited from UserControl)
Protected Method | RenderAttributes | Renders the scrollable attribute (Inherited from ScrollableControl)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | Overridden.
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | Overridden.
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

Public Events

 | Name | Description
Public Event | AdvancedClicked | Occurs when a ribbon bar groupbox has been clicked on the advanced
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | ButtonClick | Occurs when a ribbon bar button has been clicked
Public Event | CheckChanged | Occurs when a ribbon bar checkbox has been changed
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | SelectedIndexChanged | Occurs when the selected page index has changed
Public Event | TextChanged | Occurs when a ribbon bar textbox tect has been changed
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

RibbonBar Class
Gizmox.WebGUI.Forms Namespace


RibbonBar Constructor

[image]
Gizmox.WebGUI.Forms.Office
RibbonBar Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBar Class : RibbonBar Constructor

Initializes a new instance of the RibonBar class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RibbonBar()
C#
public RibbonBar()
Managed Extensions for C++
public: RibbonBar();
C++/CLI
public:
RibbonBar();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBar Class
RibbonBar Members


RibbonBar Class Methods

[image]
Gizmox.WebGUI.Forms.Office
RibbonBar Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBar Class

For a list of all members of this type, see RibbonBar members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from ContainerControl)
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from ContainerControl)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | Remove | (Inherited from ContainerControl)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Control)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from ScrollableControl)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnAdvancedClicked | Called when advanced was clicked.
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnButtonClick | Called when a ribbon bar button has been clicked
Protected Method | OnButtonMenuClick | Called when button menu was clicked.
Protected Method | OnCheckedChanged |
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the CreateControl event. (Inherited from UserControl)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLoad | Raises the UserControl.Load event. (Inherited from UserControl)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnSelectedIndexChanged | Called when the selected page index has changed
Protected Method | OnTextChanged | Overloaded. Called when text changed.
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | Renders the specified obj context. (Inherited from UserControl)
Protected Method | RenderAttributes | Renders the scrollable attribute (Inherited from ScrollableControl)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | Overridden.
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | Overridden.
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

See Also

Reference

RibbonBar Class
Gizmox.WebGUI.Forms Namespace


OnAdvancedClicked Method

[image]
Gizmox.WebGUI.Forms.Office
OnAdvancedClicked Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBar Class : OnAdvancedClicked Method

sender
The sender.
e
The e.
Called when advanced was clicked.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnAdvancedClicked( _
   ByVal sender As Object, _
   ByVal e As RibbonBarGroupArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RibbonBar
Dim sender As Object
Dim e As RibbonBarGroupArgs

instance.OnAdvancedClicked(sender, e)
C#
protected virtual void OnAdvancedClicked(
   object sender,
   RibbonBarGroupArgs e
)
Managed Extensions for C++
protected: virtual void OnAdvancedClicked(
   Object* sender,
   RibbonBarGroupArgs* e
)
C++/CLI
protected:
virtual void OnAdvancedClicked(
   Object^ sender,
   RibbonBarGroupArgs^ e
)

Parameters

sender
The sender.
e
The e.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBar Class
RibbonBar Members


OnButtonClick Method

[image]
Gizmox.WebGUI.Forms.Office
OnButtonClick Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBar Class : OnButtonClick Method

sender
The sender.
e
The e.
Called when a ribbon bar button has been clicked

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnButtonClick( _
   ByVal sender As Object, _
   ByVal e As RibbonBarButtonItemArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RibbonBar
Dim sender As Object
Dim e As RibbonBarButtonItemArgs

instance.OnButtonClick(sender, e)
C#
protected virtual void OnButtonClick(
   object sender,
   RibbonBarButtonItemArgs e
)
Managed Extensions for C++
protected: virtual void OnButtonClick(
   Object* sender,
   RibbonBarButtonItemArgs* e
)
C++/CLI
protected:
virtual void OnButtonClick(
   Object^ sender,
   RibbonBarButtonItemArgs^ e
)

Parameters

sender
The sender.
e
The e.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBar Class
RibbonBar Members


OnButtonMenuClick Method

[image]
Gizmox.WebGUI.Forms.Office
OnButtonMenuClick Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBar Class : OnButtonMenuClick Method

sender
The sender.
e
The e.
Called when button menu was clicked.

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnButtonMenuClick( _
   ByVal sender As Object, _
   ByVal e As RibbonBarButtonItemMenuClickArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RibbonBar
Dim sender As Object
Dim e As RibbonBarButtonItemMenuClickArgs

instance.OnButtonMenuClick(sender, e)
C#
protected virtual void OnButtonMenuClick(
   object sender,
   RibbonBarButtonItemMenuClickArgs e
)
Managed Extensions for C++
protected: virtual void OnButtonMenuClick(
   Object* sender,
   RibbonBarButtonItemMenuClickArgs* e
)
C++/CLI
protected:
virtual void OnButtonMenuClick(
   Object^ sender,
   RibbonBarButtonItemMenuClickArgs^ e
)

Parameters

sender
The sender.
e
The e.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBar Class
RibbonBar Members


OnCheckedChanged Method

[image]
Gizmox.WebGUI.Forms.Office
OnCheckedChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBar Class : OnCheckedChanged Method

sender
e

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnCheckedChanged( _
   ByVal sender As Object, _
   ByVal e As RibbonBarCheckBoxItemArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RibbonBar
Dim sender As Object
Dim e As RibbonBarCheckBoxItemArgs

instance.OnCheckedChanged(sender, e)
C#
protected virtual void OnCheckedChanged(
   object sender,
   RibbonBarCheckBoxItemArgs e
)
Managed Extensions for C++
protected: virtual void OnCheckedChanged(
   Object* sender,
   RibbonBarCheckBoxItemArgs* e
)
C++/CLI
protected:
virtual void OnCheckedChanged(
   Object^ sender,
   RibbonBarCheckBoxItemArgs^ e
)

Parameters

sender
e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBar Class
RibbonBar Members


OnSelectedIndexChanged Method

[image]
Gizmox.WebGUI.Forms.Office
OnSelectedIndexChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBar Class : OnSelectedIndexChanged Method

sender
e
Called when the selected page index has changed

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnSelectedIndexChanged( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RibbonBar
Dim sender As Object
Dim e As EventArgs

instance.OnSelectedIndexChanged(sender, e)
C#
protected virtual void OnSelectedIndexChanged(
   object sender,
   EventArgs e
)
Managed Extensions for C++
protected: virtual void OnSelectedIndexChanged(
   Object* sender,
   EventArgs* e
)
C++/CLI
protected:
virtual void OnSelectedIndexChanged(
   Object^ sender,
   EventArgs^ e
)

Parameters

sender
e

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBar Class
RibbonBar Members


OnTextChanged Method

[image]
Gizmox.WebGUI.Forms.Office
OnTextChanged Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBar Class : OnTextChanged Method

Called when text changed.

Overload List

Overload | Description
OnTextChanged(Object,RibbonBarTextBoxItemArgs) | Called when text changed.
OnTextChanged(EventArgs) | (Inherited from Control)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBar Class
RibbonBar Members


OnTextChanged(Object,RibbonBarTextBoxItemArgs) Method

[image]
Gizmox.WebGUI.Forms.Office
OnTextChanged(Object,RibbonBarTextBoxItemArgs) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBar Class > OnTextChanged Method : OnTextChanged(Object,RibbonBarTextBoxItemArgs) Method

sender
The sender.
e
The e.
Called when text changed.

Syntax

Visual Basic (Declaration)
Protected Overloads Overridable Sub OnTextChanged( _
   ByVal sender As Object, _
   ByVal e As RibbonBarTextBoxItemArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RibbonBar
Dim sender As Object
Dim e As RibbonBarTextBoxItemArgs

instance.OnTextChanged(sender, e)
C#
protected virtual void OnTextChanged(
   object sender,
   RibbonBarTextBoxItemArgs e
)
Managed Extensions for C++
protected: virtual void OnTextChanged(
   Object* sender,
   RibbonBarTextBoxItemArgs* e
)
C++/CLI
protected:
virtual void OnTextChanged(
   Object^ sender,
   RibbonBarTextBoxItemArgs^ e
)

Parameters

sender
The sender.
e
The e.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBar Class
RibbonBar Members
Overload List


ShouldSerializeClientSize Method

[image]
Gizmox.WebGUI.Forms.Office
ShouldSerializeClientSize Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBar Class : ShouldSerializeClientSize Method

Syntax

Visual Basic (Declaration)
Protected Overrides Function ShouldSerializeClientSize() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RibbonBar
Dim value As Boolean

value = instance.ShouldSerializeClientSize()
C#
protected override bool ShouldSerializeClientSize()
Managed Extensions for C++
protected: bool ShouldSerializeClientSize(); override
C++/CLI
protected:
bool ShouldSerializeClientSize(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBar Class
RibbonBar Members


ShouldSerializeSize Method

[image]
Gizmox.WebGUI.Forms.Office
ShouldSerializeSize Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBar Class : ShouldSerializeSize Method

Syntax

Visual Basic (Declaration)
Protected Overrides Function ShouldSerializeSize() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RibbonBar
Dim value As Boolean

value = instance.ShouldSerializeSize()
C#
protected override bool ShouldSerializeSize()
Managed Extensions for C++
protected: bool ShouldSerializeSize(); override
C++/CLI
protected:
bool ShouldSerializeSize(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBar Class
RibbonBar Members


RibbonBar Class Properties

[image]
Gizmox.WebGUI.Forms.Office
RibbonBar Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBar Class

For a list of all members of this type, see RibbonBar members.

Public Properties

 | Name | Description
Public Property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl)
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl)
Public Property | AutoSize | (Inherited from UserControl)
Public Property | AutoSizeMode | Indicates the automatic sizing behavior of the control. (Inherited from UserControl)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from ContainerControl)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Components | (Inherited from ContainerControl)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from UserControl)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this control has controls. (Inherited from UserControl)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Pages | Gets the ribbon bar pages.
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | SelectedIndex | Gets or sets the index of the selected page.
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Control)
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Protected Property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl)
Top

See Also

Reference

RibbonBar Class
Gizmox.WebGUI.Forms Namespace


Pages Property

[image]
Gizmox.WebGUI.Forms.Office
Pages Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBar Class : Pages Property

Gets the ribbon bar pages.

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(True)>
Public ReadOnly Property Pages As RibbonBarPageCollection
Visual Basic (Usage) Copy Code
Dim instance As RibbonBar
Dim value As RibbonBarPageCollection

value = instance.Pages
C#
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(true)]
public RibbonBarPageCollection Pages {get;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(true)]
public: __property RibbonBarPageCollection* get_Pages();
C++/CLI
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(true)]
public:
property RibbonBarPageCollection^ Pages {
   RibbonBarPageCollection^ get();
}

Return Value

The ribbon bar pages.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBar Class
RibbonBar Members


SelectedIndex Property

[image]
Gizmox.WebGUI.Forms.Office
SelectedIndex Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBar Class : SelectedIndex Property

Gets or sets the index of the selected page.

Syntax

Visual Basic (Declaration)
Public Property SelectedIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As RibbonBar
Dim value As Integer

instance.SelectedIndex = value

value = instance.SelectedIndex
C#
public int SelectedIndex {get; set;}
Managed Extensions for C++
public: __property int get_SelectedIndex();
public: __property void set_SelectedIndex(
   int value
);
C++/CLI
public:
property int SelectedIndex {
   int get();
   void set (intvalue);
}

Return Value

The index of the selected page.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBar Class
RibbonBar Members


RibbonBar Class Events

[image]
Gizmox.WebGUI.Forms.Office
RibbonBar Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBar Class

For a list of all members of this type, see RibbonBar members.

Public Events

 | Name | Description
Public Event | AdvancedClicked | Occurs when a ribbon bar groupbox has been clicked on the advanced
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | ButtonClick | Occurs when a ribbon bar button has been clicked
Public Event | CheckChanged | Occurs when a ribbon bar checkbox has been changed
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | SelectedIndexChanged | Occurs when the selected page index has changed
Public Event | TextChanged | Occurs when a ribbon bar textbox tect has been changed
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

RibbonBar Class
Gizmox.WebGUI.Forms Namespace


AdvancedClicked Event

[image]
Gizmox.WebGUI.Forms.Office
AdvancedClicked Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBar Class : AdvancedClicked Event

Occurs when a ribbon bar groupbox has been clicked on the advanced

Syntax

Visual Basic (Declaration)
Public Event AdvancedClicked() As EventHandler(Of RibbonBarGroupArgs)
Visual Basic (Usage) Copy Code
Dim instance As RibbonBar
Dim handler As EventHandler(Of RibbonBarGroupArgs)

AddHandler instance.AdvancedClicked, handler
C#
public event EventHandler<RibbonBarGroupArgs> AdvancedClicked()
Managed Extensions for C++
public: __event EventHandler<RibbonBarGroupArgs*>* AdvancedClicked
C++/CLI
public:
event EventHandler<RibbonBarGroupArgs^>^ AdvancedClicked

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBar Class
RibbonBar Members


ButtonClick Event

[image]
Gizmox.WebGUI.Forms.Office
ButtonClick Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBar Class : ButtonClick Event

Occurs when a ribbon bar button has been clicked

Syntax

Visual Basic (Declaration)
Public Event ButtonClick() As EventHandler(Of RibbonBarButtonItemArgs)
Visual Basic (Usage) Copy Code
Dim instance As RibbonBar
Dim handler As EventHandler(Of RibbonBarButtonItemArgs)

AddHandler instance.ButtonClick, handler
C#
public event EventHandler<RibbonBarButtonItemArgs> ButtonClick()
Managed Extensions for C++
public: __event EventHandler<RibbonBarButtonItemArgs*>* ButtonClick
C++/CLI
public:
event EventHandler<RibbonBarButtonItemArgs^>^ ButtonClick

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBar Class
RibbonBar Members


CheckChanged Event

[image]
Gizmox.WebGUI.Forms.Office
CheckChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBar Class : CheckChanged Event

Occurs when a ribbon bar checkbox has been changed

Syntax

Visual Basic (Declaration)
Public Event CheckChanged() As EventHandler(Of RibbonBarCheckBoxItemArgs)
Visual Basic (Usage) Copy Code
Dim instance As RibbonBar
Dim handler As EventHandler(Of RibbonBarCheckBoxItemArgs)

AddHandler instance.CheckChanged, handler
C#
public event EventHandler<RibbonBarCheckBoxItemArgs> CheckChanged()
Managed Extensions for C++
public: __event EventHandler<RibbonBarCheckBoxItemArgs*>* CheckChanged
C++/CLI
public:
event EventHandler<RibbonBarCheckBoxItemArgs^>^ CheckChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBar Class
RibbonBar Members


SelectedIndexChanged Event

[image]
Gizmox.WebGUI.Forms.Office
SelectedIndexChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBar Class : SelectedIndexChanged Event

Occurs when the selected page index has changed

Syntax

Visual Basic (Declaration)
Public Event SelectedIndexChanged() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As RibbonBar
Dim handler As EventHandler

AddHandler instance.SelectedIndexChanged, handler
C#
public event EventHandler SelectedIndexChanged()
Managed Extensions for C++
public: __event EventHandler* SelectedIndexChanged
C++/CLI
public:
event EventHandler^ SelectedIndexChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBar Class
RibbonBar Members


TextChanged Event

[image]
Gizmox.WebGUI.Forms.Office
TextChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBar Class : TextChanged Event

Occurs when a ribbon bar textbox tect has been changed

Syntax

Visual Basic (Declaration)
Public Event TextChanged() As EventHandler(Of RibbonBarTextBoxItemArgs)
Visual Basic (Usage) Copy Code
Dim instance As RibbonBar
Dim handler As EventHandler(Of RibbonBarTextBoxItemArgs)

AddHandler instance.TextChanged, handler
C#
public event EventHandler<RibbonBarTextBoxItemArgs> TextChanged()
Managed Extensions for C++
public: __event EventHandler<RibbonBarTextBoxItemArgs*>* TextChanged
C++/CLI
public:
event EventHandler<RibbonBarTextBoxItemArgs^>^ TextChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBar Class
RibbonBar Members


RibbonBarButtonItem Class

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarButtonItem Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarButtonItem Class

Object Model

Syntax

Visual Basic (Declaration)
Public Class RibbonBarButtonItem
   Inherits RibbonBarItem
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarButtonItem
C#
public class RibbonBarButtonItem : RibbonBarItem
Managed Extensions for C++
public __gc class RibbonBarButtonItem : public RibbonBarItem
C++/CLI
public ref class RibbonBarButtonItem : public RibbonBarItem

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RibbonBarItem
Gizmox.WebGUI.Forms.RibbonBarButtonItem
Gizmox.WebGUI.Forms.RibbonBarDropDownButtonItem
Gizmox.WebGUI.Forms.RibbonBarToolBarButtonItem

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms.Office (in Gizmox.WebGUI.Forms.Office.dll)

See Also

Reference

RibbonBarButtonItem Members
Gizmox.WebGUI.Forms Namespace


RibbonBarButtonItem Class Members

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarButtonItem Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarButtonItem Class

The following tables list the members exposed by RibbonBarButtonItem.

Public Constructors

 | Name | Description
Public Constructor | RibbonBarButtonItem Constructor | Initializes a new instance of the RibbonBarButtonItem class.
Top

Public Properties

 | Name | Description
Public Property | ClientAction | Gets or sets the client action.
Public Property | Container | (Inherited from ComponentBase)
Public Property | Control | Gets the control. (Inherited from RibbonBarItem)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from RibbonBarItem)
Public Property | Image |
Public Property | Site | (Inherited from ComponentBase)
Public Property | Tag | Gets/Sets user definied tag (Inherited from RibbonBarItem)
Public Property | Text | Gets or sets the text. (Inherited from RibbonBarItem)
Public Property | ToolTip | Gets or sets the control tooltip. (Inherited from RibbonBarItem)
Public Property | Visible | Gets or sets a value indicating whether this RibbonBarItem is visible. (Inherited from RibbonBarItem)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Top

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded. (Inherited from ComponentBase)
Public Method | ToString | (Inherited from ComponentBase)
Top

Protected Methods

 | Name | Description
Protected Method | CreateButton |
Protected Method | CreateControl | Overridden.
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | GetService | (Inherited from ComponentBase)
Top

Public Events

 | Name | Description
Public Event | Click | Occurs when a ribbon bar button has been clicked
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | MenuClick | Invokes when a menu item was clicked
Top

See Also

Reference

RibbonBarButtonItem Class
Gizmox.WebGUI.Forms Namespace


RibbonBarButtonItem Constructor

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarButtonItem Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBarButtonItem Class : RibbonBarButtonItem Constructor

Initializes a new instance of the RibbonBarButtonItem class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarButtonItem()
C#
public RibbonBarButtonItem()
Managed Extensions for C++
public: RibbonBarButtonItem();
C++/CLI
public:
RibbonBarButtonItem();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBarButtonItem Class
RibbonBarButtonItem Members


RibbonBarButtonItem Class Methods

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarButtonItem Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarButtonItem Class

For a list of all members of this type, see RibbonBarButtonItem members.

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded. (Inherited from ComponentBase)
Public Method | ToString | (Inherited from ComponentBase)
Top

Protected Methods

 | Name | Description
Protected Method | CreateButton |
Protected Method | CreateControl | Overridden.
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | GetService | (Inherited from ComponentBase)
Top

See Also

Reference

RibbonBarButtonItem Class
Gizmox.WebGUI.Forms Namespace


CreateButton Method

[image]
Gizmox.WebGUI.Forms.Office
CreateButton Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBarButtonItem Class : CreateButton Method

Syntax

Visual Basic (Declaration)
Protected Overridable Function CreateButton() As Button
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarButtonItem
Dim value As Button

value = instance.CreateButton()
C#
protected virtual Button CreateButton()
Managed Extensions for C++
protected: virtual Button* CreateButton();
C++/CLI
protected:
virtual Button^ CreateButton();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBarButtonItem Class
RibbonBarButtonItem Members


CreateControl Method

[image]
Gizmox.WebGUI.Forms.Office
CreateControl Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBarButtonItem Class : CreateControl Method

Syntax

Visual Basic (Declaration)
Protected Overrides Function CreateControl() As Control
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarButtonItem
Dim value As Control

value = instance.CreateControl()
C#
protected override Control CreateControl()
Managed Extensions for C++
protected: Control* CreateControl(); override
C++/CLI
protected:
Control^ CreateControl(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBarButtonItem Class
RibbonBarButtonItem Members


RibbonBarButtonItem Class Properties

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarButtonItem Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarButtonItem Class

For a list of all members of this type, see RibbonBarButtonItem members.

Public Properties

 | Name | Description
Public Property | ClientAction | Gets or sets the client action.
Public Property | Container | (Inherited from ComponentBase)
Public Property | Control | Gets the control. (Inherited from RibbonBarItem)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from RibbonBarItem)
Public Property | Image |
Public Property | Site | (Inherited from ComponentBase)
Public Property | Tag | Gets/Sets user definied tag (Inherited from RibbonBarItem)
Public Property | Text | Gets or sets the text. (Inherited from RibbonBarItem)
Public Property | ToolTip | Gets or sets the control tooltip. (Inherited from RibbonBarItem)
Public Property | Visible | Gets or sets a value indicating whether this RibbonBarItem is visible. (Inherited from RibbonBarItem)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Top

See Also

Reference

RibbonBarButtonItem Class
Gizmox.WebGUI.Forms Namespace


ClientAction Property

[image]
Gizmox.WebGUI.Forms.Office
ClientAction Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBarButtonItem Class : ClientAction Property

Gets or sets the client action.

Syntax

Visual Basic (Declaration)
Public Property ClientAction As RegisteredClientAction
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarButtonItem
Dim value As RegisteredClientAction

instance.ClientAction = value

value = instance.ClientAction
C#
public RegisteredClientAction ClientAction {get; set;}
Managed Extensions for C++
public: __property RegisteredClientAction* get_ClientAction();
public: __property void set_ClientAction(
   RegisteredClientAction* value
);
C++/CLI
public:
property RegisteredClientAction^ ClientAction {
   RegisteredClientAction^ get();
   void set (RegisteredClientAction^value);
}

Return Value

The client action.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBarButtonItem Class
RibbonBarButtonItem Members


Image Property

[image]
Gizmox.WebGUI.Forms.Office
Image Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBarButtonItem Class : Image Property

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Overridable Property Image As ResourceHandle
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarButtonItem
Dim value As ResourceHandle

instance.Image = value

value = instance.Image
C#
[DefaultValueAttribute()]
public virtual ResourceHandle Image {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property virtual ResourceHandle* get_Image();
public: __property virtual void set_Image(
   ResourceHandle* value
);
C++/CLI
[DefaultValueAttribute()]
public:
virtual property ResourceHandle^ Image {
   ResourceHandle^ get();
   void set (ResourceHandle^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBarButtonItem Class
RibbonBarButtonItem Members


RibbonBarButtonItem Class Events

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarButtonItem Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarButtonItem Class

For a list of all members of this type, see RibbonBarButtonItem members.

Public Events

 | Name | Description
Public Event | Click | Occurs when a ribbon bar button has been clicked
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | MenuClick | Invokes when a menu item was clicked
Top

See Also

Reference

RibbonBarButtonItem Class
Gizmox.WebGUI.Forms Namespace


Click Event

[image]
Gizmox.WebGUI.Forms.Office
Click Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBarButtonItem Class : Click Event

Occurs when a ribbon bar button has been clicked

Syntax

Visual Basic (Declaration)
Public Event Click() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarButtonItem
Dim handler As EventHandler

AddHandler instance.Click, handler
C#
public event EventHandler Click()
Managed Extensions for C++
public: __event EventHandler* Click
C++/CLI
public:
event EventHandler^ Click

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBarButtonItem Class
RibbonBarButtonItem Members


MenuClick Event

[image]
Gizmox.WebGUI.Forms.Office
MenuClick Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBarButtonItem Class : MenuClick Event

Invokes when a menu item was clicked

Syntax

Visual Basic (Declaration)
Public Event MenuClick() As MenuEventHandler
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarButtonItem
Dim handler As MenuEventHandler

AddHandler instance.MenuClick, handler
C#
public event MenuEventHandler MenuClick()
Managed Extensions for C++
public: __event MenuEventHandler* MenuClick
C++/CLI
public:
event MenuEventHandler^ MenuClick

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBarButtonItem Class
RibbonBarButtonItem Members


RibbonBarButtonItemArgs Class

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarButtonItemArgs Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarButtonItemArgs Class

Object Model

Syntax

Visual Basic (Declaration)
Public Class RibbonBarButtonItemArgs
   Inherits EventArgs
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarButtonItemArgs
C#
public class RibbonBarButtonItemArgs : EventArgs
Managed Extensions for C++
public __gc class RibbonBarButtonItemArgs : public EventArgs
C++/CLI
public ref class RibbonBarButtonItemArgs : public EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gizmox.WebGUI.Forms.RibbonBarButtonItemArgs

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms.Office (in Gizmox.WebGUI.Forms.Office.dll)

See Also

Reference

RibbonBarButtonItemArgs Members
Gizmox.WebGUI.Forms Namespace


RibbonBarButtonItemArgs Class Members

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarButtonItemArgs Class Members
See Also Properties Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarButtonItemArgs Class

The following tables list the members exposed by RibbonBarButtonItemArgs.

Public Constructors

 | Name | Description
Public Constructor | RibbonBarButtonItemArgs Constructor |
Top

Public Properties

 | Name | Description
Public Property | Button |
Top

See Also

Reference

RibbonBarButtonItemArgs Class
Gizmox.WebGUI.Forms Namespace


RibbonBarButtonItemArgs Constructor

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarButtonItemArgs Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBarButtonItemArgs Class : RibbonBarButtonItemArgs Constructor

objButton

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal objButton As RibbonBarButtonItem _
)
Visual Basic (Usage) Copy Code
Dim objButton As RibbonBarButtonItem

Dim instance As RibbonBarButtonItemArgs(objButton)
C#
public RibbonBarButtonItemArgs(
   RibbonBarButtonItem objButton
)
Managed Extensions for C++
public: RibbonBarButtonItemArgs(
   RibbonBarButtonItem* objButton
)
C++/CLI
public:
RibbonBarButtonItemArgs(
   RibbonBarButtonItem^ objButton
)

Parameters

objButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBarButtonItemArgs Class
RibbonBarButtonItemArgs Members


RibbonBarButtonItemArgs Class Properties

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarButtonItemArgs Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarButtonItemArgs Class

For a list of all members of this type, see RibbonBarButtonItemArgs members.

Public Properties

 | Name | Description
Public Property | Button |
Top

See Also

Reference

RibbonBarButtonItemArgs Class
Gizmox.WebGUI.Forms Namespace


Button Property

[image]
Gizmox.WebGUI.Forms.Office
Button Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBarButtonItemArgs Class : Button Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Button As RibbonBarButtonItem
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarButtonItemArgs
Dim value As RibbonBarButtonItem

value = instance.Button
C#
public RibbonBarButtonItem Button {get;}
Managed Extensions for C++
public: __property RibbonBarButtonItem* get_Button();
C++/CLI
public:
property RibbonBarButtonItem^ Button {
   RibbonBarButtonItem^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBarButtonItemArgs Class
RibbonBarButtonItemArgs Members


RibbonBarButtonItemMenuClickArgs Class

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarButtonItemMenuClickArgs Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarButtonItemMenuClickArgs Class

Object Model

Syntax

Visual Basic (Declaration)
Public Class RibbonBarButtonItemMenuClickArgs
   Inherits EventArgs
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarButtonItemMenuClickArgs
C#
public class RibbonBarButtonItemMenuClickArgs : EventArgs
Managed Extensions for C++
public __gc class RibbonBarButtonItemMenuClickArgs : public EventArgs
C++/CLI
public ref class RibbonBarButtonItemMenuClickArgs : public EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gizmox.WebGUI.Forms.RibbonBarButtonItemMenuClickArgs

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms.Office (in Gizmox.WebGUI.Forms.Office.dll)

See Also

Reference

RibbonBarButtonItemMenuClickArgs Members
Gizmox.WebGUI.Forms Namespace


RibbonBarButtonItemMenuClickArgs Class Members

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarButtonItemMenuClickArgs Class Members
See Also Properties Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarButtonItemMenuClickArgs Class

The following tables list the members exposed by RibbonBarButtonItemMenuClickArgs.

Public Constructors

 | Name | Description
Public Constructor | RibbonBarButtonItemMenuClickArgs Constructor |
Top

Public Properties

 | Name | Description
Public Property | Button |
Public Property | MenuItem |
Top

See Also

Reference

RibbonBarButtonItemMenuClickArgs Class
Gizmox.WebGUI.Forms Namespace


RibbonBarButtonItemMenuClickArgs Constructor

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarButtonItemMenuClickArgs Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBarButtonItemMenuClickArgs Class : RibbonBarButtonItemMenuClickArgs Constructor

objButton
objMenuItem

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal objButton As RibbonBarButtonItem, _
   ByVal objMenuItem As MenuItem _
)
Visual Basic (Usage) Copy Code
Dim objButton As RibbonBarButtonItem
Dim objMenuItem As MenuItem

Dim instance As RibbonBarButtonItemMenuClickArgs(objButton, objMenuItem)
C#
public RibbonBarButtonItemMenuClickArgs(
   RibbonBarButtonItem objButton,
   MenuItem objMenuItem
)
Managed Extensions for C++
public: RibbonBarButtonItemMenuClickArgs(
   RibbonBarButtonItem* objButton,
   MenuItem* objMenuItem
)
C++/CLI
public:
RibbonBarButtonItemMenuClickArgs(
   RibbonBarButtonItem^ objButton,
   MenuItem^ objMenuItem
)

Parameters

objButton
objMenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBarButtonItemMenuClickArgs Class
RibbonBarButtonItemMenuClickArgs Members


RibbonBarButtonItemMenuClickArgs Class Properties

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarButtonItemMenuClickArgs Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarButtonItemMenuClickArgs Class

For a list of all members of this type, see RibbonBarButtonItemMenuClickArgs members.

Public Properties

 | Name | Description
Public Property | Button |
Public Property | MenuItem |
Top

See Also

Reference

RibbonBarButtonItemMenuClickArgs Class
Gizmox.WebGUI.Forms Namespace


Button Property

[image]
Gizmox.WebGUI.Forms.Office
Button Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBarButtonItemMenuClickArgs Class : Button Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Button As RibbonBarButtonItem
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarButtonItemMenuClickArgs
Dim value As RibbonBarButtonItem

value = instance.Button
C#
public RibbonBarButtonItem Button {get;}
Managed Extensions for C++
public: __property RibbonBarButtonItem* get_Button();
C++/CLI
public:
property RibbonBarButtonItem^ Button {
   RibbonBarButtonItem^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBarButtonItemMenuClickArgs Class
RibbonBarButtonItemMenuClickArgs Members


MenuItem Property

[image]
Gizmox.WebGUI.Forms.Office
MenuItem Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBarButtonItemMenuClickArgs Class : MenuItem Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MenuItem As MenuItem
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarButtonItemMenuClickArgs
Dim value As MenuItem

value = instance.MenuItem
C#
public MenuItem MenuItem {get;}
Managed Extensions for C++
public: __property MenuItem* get_MenuItem();
C++/CLI
public:
property MenuItem^ MenuItem {
   MenuItem^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBarButtonItemMenuClickArgs Class
RibbonBarButtonItemMenuClickArgs Members


RibbonBarCheckBoxItem Class

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarCheckBoxItem Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarCheckBoxItem Class

Object Model

Syntax

Visual Basic (Declaration)
Public Class RibbonBarCheckBoxItem
   Inherits RibbonBarItem
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarCheckBoxItem
C#
public class RibbonBarCheckBoxItem : RibbonBarItem
Managed Extensions for C++
public __gc class RibbonBarCheckBoxItem : public RibbonBarItem
C++/CLI
public ref class RibbonBarCheckBoxItem : public RibbonBarItem

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RibbonBarItem
Gizmox.WebGUI.Forms.RibbonBarCheckBoxItem

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms.Office (in Gizmox.WebGUI.Forms.Office.dll)

See Also

Reference

RibbonBarCheckBoxItem Members
Gizmox.WebGUI.Forms Namespace


RibbonBarCheckBoxItem Class Members

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarCheckBoxItem Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarCheckBoxItem Class

The following tables list the members exposed by RibbonBarCheckBoxItem.

Public Constructors

 | Name | Description
Public Constructor | RibbonBarCheckBoxItem Constructor |
Top

Public Properties

 | Name | Description
Public Property | Container | (Inherited from ComponentBase)
Public Property | Control | Gets the control. (Inherited from RibbonBarItem)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from RibbonBarItem)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Tag | Gets/Sets user definied tag (Inherited from RibbonBarItem)
Public Property | Text | Gets or sets the text. (Inherited from RibbonBarItem)
Public Property | ToolTip | Gets or sets the control tooltip. (Inherited from RibbonBarItem)
Public Property | Visible | Gets or sets a value indicating whether this RibbonBarItem is visible. (Inherited from RibbonBarItem)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Top

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded. (Inherited from ComponentBase)
Public Method | ToString | (Inherited from ComponentBase)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControl | Overridden.
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | GetService | (Inherited from ComponentBase)
Top

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from ComponentBase)
Top

See Also

Reference

RibbonBarCheckBoxItem Class
Gizmox.WebGUI.Forms Namespace


RibbonBarCheckBoxItem Constructor

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarCheckBoxItem Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBarCheckBoxItem Class : RibbonBarCheckBoxItem Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarCheckBoxItem()
C#
public RibbonBarCheckBoxItem()
Managed Extensions for C++
public: RibbonBarCheckBoxItem();
C++/CLI
public:
RibbonBarCheckBoxItem();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBarCheckBoxItem Class
RibbonBarCheckBoxItem Members


RibbonBarCheckBoxItem Class Methods

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarCheckBoxItem Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarCheckBoxItem Class

For a list of all members of this type, see RibbonBarCheckBoxItem members.

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded. (Inherited from ComponentBase)
Public Method | ToString | (Inherited from ComponentBase)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControl | Overridden.
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | GetService | (Inherited from ComponentBase)
Top

See Also

Reference

RibbonBarCheckBoxItem Class
Gizmox.WebGUI.Forms Namespace


CreateControl Method

[image]
Gizmox.WebGUI.Forms.Office
CreateControl Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBarCheckBoxItem Class : CreateControl Method

Syntax

Visual Basic (Declaration)
Protected Overrides Function CreateControl() As Control
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarCheckBoxItem
Dim value As Control

value = instance.CreateControl()
C#
protected override Control CreateControl()
Managed Extensions for C++
protected: Control* CreateControl(); override
C++/CLI
protected:
Control^ CreateControl(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBarCheckBoxItem Class
RibbonBarCheckBoxItem Members


RibbonBarCheckBoxItemArgs Class

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarCheckBoxItemArgs Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarCheckBoxItemArgs Class

Object Model

Syntax

Visual Basic (Declaration)
Public Class RibbonBarCheckBoxItemArgs
   Inherits EventArgs
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarCheckBoxItemArgs
C#
public class RibbonBarCheckBoxItemArgs : EventArgs
Managed Extensions for C++
public __gc class RibbonBarCheckBoxItemArgs : public EventArgs
C++/CLI
public ref class RibbonBarCheckBoxItemArgs : public EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gizmox.WebGUI.Forms.RibbonBarCheckBoxItemArgs

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms.Office (in Gizmox.WebGUI.Forms.Office.dll)

See Also

Reference

RibbonBarCheckBoxItemArgs Members
Gizmox.WebGUI.Forms Namespace


RibbonBarCheckBoxItemArgs Class Members

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarCheckBoxItemArgs Class Members
See Also Properties Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarCheckBoxItemArgs Class

The following tables list the members exposed by RibbonBarCheckBoxItemArgs.

Public Constructors

 | Name | Description
Public Constructor | RibbonBarCheckBoxItemArgs Constructor |
Top

Public Properties

 | Name | Description
Public Property | CheckBox |
Top

See Also

Reference

RibbonBarCheckBoxItemArgs Class
Gizmox.WebGUI.Forms Namespace


RibbonBarCheckBoxItemArgs Constructor

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarCheckBoxItemArgs Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBarCheckBoxItemArgs Class : RibbonBarCheckBoxItemArgs Constructor

objCheckBox

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal objCheckBox As RibbonBarCheckBoxItem _
)
Visual Basic (Usage) Copy Code
Dim objCheckBox As RibbonBarCheckBoxItem

Dim instance As RibbonBarCheckBoxItemArgs(objCheckBox)
C#
public RibbonBarCheckBoxItemArgs(
   RibbonBarCheckBoxItem objCheckBox
)
Managed Extensions for C++
public: RibbonBarCheckBoxItemArgs(
   RibbonBarCheckBoxItem* objCheckBox
)
C++/CLI
public:
RibbonBarCheckBoxItemArgs(
   RibbonBarCheckBoxItem^ objCheckBox
)

Parameters

objCheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBarCheckBoxItemArgs Class
RibbonBarCheckBoxItemArgs Members


RibbonBarCheckBoxItemArgs Class Properties

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarCheckBoxItemArgs Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarCheckBoxItemArgs Class

For a list of all members of this type, see RibbonBarCheckBoxItemArgs members.

Public Properties

 | Name | Description
Public Property | CheckBox |
Top

See Also

Reference

RibbonBarCheckBoxItemArgs Class
Gizmox.WebGUI.Forms Namespace


CheckBox Property

[image]
Gizmox.WebGUI.Forms.Office
CheckBox Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBarCheckBoxItemArgs Class : CheckBox Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CheckBox As RibbonBarCheckBoxItem
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarCheckBoxItemArgs
Dim value As RibbonBarCheckBoxItem

value = instance.CheckBox
C#
public RibbonBarCheckBoxItem CheckBox {get;}
Managed Extensions for C++
public: __property RibbonBarCheckBoxItem* get_CheckBox();
C++/CLI
public:
property RibbonBarCheckBoxItem^ CheckBox {
   RibbonBarCheckBoxItem^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBarCheckBoxItemArgs Class
RibbonBarCheckBoxItemArgs Members


RibbonBarComboBoxItem Class

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarComboBoxItem Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarComboBoxItem Class

Object Model

Syntax

Visual Basic (Declaration)
Public Class RibbonBarComboBoxItem
   Inherits RibbonBarItem
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarComboBoxItem
C#
public class RibbonBarComboBoxItem : RibbonBarItem
Managed Extensions for C++
public __gc class RibbonBarComboBoxItem : public RibbonBarItem
C++/CLI
public ref class RibbonBarComboBoxItem : public RibbonBarItem

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RibbonBarItem
Gizmox.WebGUI.Forms.RibbonBarComboBoxItem

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms.Office (in Gizmox.WebGUI.Forms.Office.dll)

See Also

Reference

RibbonBarComboBoxItem Members
Gizmox.WebGUI.Forms Namespace


RibbonBarComboBoxItem Class Members

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarComboBoxItem Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarComboBoxItem Class

The following tables list the members exposed by RibbonBarComboBoxItem.

Public Constructors

 | Name | Description
Public Constructor | RibbonBarComboBoxItem Constructor |
Top

Public Properties

 | Name | Description
Public Property | Container | (Inherited from ComponentBase)
Public Property | Control | Gets the control. (Inherited from RibbonBarItem)
Public Property | DataSource |
Public Property | DisplayMember |
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from RibbonBarItem)
Public Property | Items | Gets an object representing the collection of the items contained in this ComboBox.
Public Property | Site | (Inherited from ComponentBase)
Public Property | Tag | Gets/Sets user definied tag (Inherited from RibbonBarItem)
Public Property | Text | Gets or sets the text. (Inherited from RibbonBarItem)
Public Property | ToolTip | Gets or sets the control tooltip. (Inherited from RibbonBarItem)
Public Property | ValueMember |
Public Property | Visible | Gets or sets a value indicating whether this RibbonBarItem is visible. (Inherited from RibbonBarItem)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ComboBox |
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Top

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded. (Inherited from ComponentBase)
Public Method | ToString | (Inherited from ComponentBase)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControl | Overridden.
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | GetService | (Inherited from ComponentBase)
Top

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | TextChanged |
Top

See Also

Reference

RibbonBarComboBoxItem Class
Gizmox.WebGUI.Forms Namespace


RibbonBarComboBoxItem Constructor

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarComboBoxItem Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBarComboBoxItem Class : RibbonBarComboBoxItem Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarComboBoxItem()
C#
public RibbonBarComboBoxItem()
Managed Extensions for C++
public: RibbonBarComboBoxItem();
C++/CLI
public:
RibbonBarComboBoxItem();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBarComboBoxItem Class
RibbonBarComboBoxItem Members


RibbonBarComboBoxItem Class Methods

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarComboBoxItem Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarComboBoxItem Class

For a list of all members of this type, see RibbonBarComboBoxItem members.

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded. (Inherited from ComponentBase)
Public Method | ToString | (Inherited from ComponentBase)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControl | Overridden.
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | GetService | (Inherited from ComponentBase)
Top

See Also

Reference

RibbonBarComboBoxItem Class
Gizmox.WebGUI.Forms Namespace


CreateControl Method

[image]
Gizmox.WebGUI.Forms.Office
CreateControl Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBarComboBoxItem Class : CreateControl Method

Syntax

Visual Basic (Declaration)
Protected Overrides Function CreateControl() As Control
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarComboBoxItem
Dim value As Control

value = instance.CreateControl()
C#
protected override Control CreateControl()
Managed Extensions for C++
protected: Control* CreateControl(); override
C++/CLI
protected:
Control^ CreateControl(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBarComboBoxItem Class
RibbonBarComboBoxItem Members


RibbonBarComboBoxItem Class Properties

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarComboBoxItem Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarComboBoxItem Class

For a list of all members of this type, see RibbonBarComboBoxItem members.

Public Properties

 | Name | Description
Public Property | Container | (Inherited from ComponentBase)
Public Property | Control | Gets the control. (Inherited from RibbonBarItem)
Public Property | DataSource |
Public Property | DisplayMember |
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from RibbonBarItem)
Public Property | Items | Gets an object representing the collection of the items contained in this ComboBox.
Public Property | Site | (Inherited from ComponentBase)
Public Property | Tag | Gets/Sets user definied tag (Inherited from RibbonBarItem)
Public Property | Text | Gets or sets the text. (Inherited from RibbonBarItem)
Public Property | ToolTip | Gets or sets the control tooltip. (Inherited from RibbonBarItem)
Public Property | ValueMember |
Public Property | Visible | Gets or sets a value indicating whether this RibbonBarItem is visible. (Inherited from RibbonBarItem)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ComboBox |
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Top

See Also

Reference

RibbonBarComboBoxItem Class
Gizmox.WebGUI.Forms Namespace


ComboBox Property

[image]
Gizmox.WebGUI.Forms.Office
ComboBox Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBarComboBoxItem Class : ComboBox Property

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property ComboBox As ComboBox
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarComboBoxItem
Dim value As ComboBox

value = instance.ComboBox
C#
protected ComboBox ComboBox {get;}
Managed Extensions for C++
protected: __property ComboBox* get_ComboBox();
C++/CLI
protected:
property ComboBox^ ComboBox {
   ComboBox^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBarComboBoxItem Class
RibbonBarComboBoxItem Members


DataSource Property

[image]
Gizmox.WebGUI.Forms.Office
DataSource Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBarComboBoxItem Class : DataSource Property

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property DataSource As Object
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarComboBoxItem
Dim value As Object

instance.DataSource = value

value = instance.DataSource
C#
[DefaultValueAttribute()]
public object DataSource {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property Object* get_DataSource();
public: __property void set_DataSource(
   Object* value
);
C++/CLI
[DefaultValueAttribute()]
public:
property Object^ DataSource {
   Object^ get();
   void set (Object^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBarComboBoxItem Class
RibbonBarComboBoxItem Members


DisplayMember Property

[image]
Gizmox.WebGUI.Forms.Office
DisplayMember Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBarComboBoxItem Class : DisplayMember Property

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property DisplayMember As String
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarComboBoxItem
Dim value As String

instance.DisplayMember = value

value = instance.DisplayMember
C#
[DefaultValueAttribute()]
public string DisplayMember {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property string* get_DisplayMember();
public: __property void set_DisplayMember(
   string* value
);
C++/CLI
[DefaultValueAttribute()]
public:
property String^ DisplayMember {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBarComboBoxItem Class
RibbonBarComboBoxItem Members


Items Property

[image]
Gizmox.WebGUI.Forms.Office
Items Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBarComboBoxItem Class : Items Property

Gets an object representing the collection of the items contained in this ComboBox.

Syntax

Visual Basic (Declaration)
<EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.ListControlStringCollectionEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")>
<DesignerSerializationVisibilityAttribute()>
Public ReadOnly Property Items As ComboBox.ObjectCollection
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarComboBoxItem
Dim value As ComboBox.ObjectCollection

value = instance.Items
C#
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.ListControlStringCollectionEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[DesignerSerializationVisibilityAttribute()]
public ComboBox.ObjectCollection Items {get;}
Managed Extensions for C++
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.ListControlStringCollectionEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[DesignerSerializationVisibilityAttribute()]
public: __property ComboBox.ObjectCollection* get_Items();
C++/CLI
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Design.ListControlStringCollectionEditor, Gizmox.WebGUI.Forms.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=dd2a1fd4d120c769")]
[DesignerSerializationVisibilityAttribute()]
public:
property ComboBox::ObjectCollection^ Items {
   ComboBox::ObjectCollection^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBarComboBoxItem Class
RibbonBarComboBoxItem Members


ValueMember Property

[image]
Gizmox.WebGUI.Forms.Office
ValueMember Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBarComboBoxItem Class : ValueMember Property

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property ValueMember As String
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarComboBoxItem
Dim value As String

instance.ValueMember = value

value = instance.ValueMember
C#
[DefaultValueAttribute()]
public string ValueMember {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property string* get_ValueMember();
public: __property void set_ValueMember(
   string* value
);
C++/CLI
[DefaultValueAttribute()]
public:
property String^ ValueMember {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBarComboBoxItem Class
RibbonBarComboBoxItem Members


RibbonBarComboBoxItem Class Events

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarComboBoxItem Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarComboBoxItem Class

For a list of all members of this type, see RibbonBarComboBoxItem members.

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | TextChanged |
Top

See Also

Reference

RibbonBarComboBoxItem Class
Gizmox.WebGUI.Forms Namespace


TextChanged Event

[image]
Gizmox.WebGUI.Forms.Office
TextChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBarComboBoxItem Class : TextChanged Event

Syntax

Visual Basic (Declaration)
Public Event TextChanged() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarComboBoxItem
Dim handler As EventHandler

AddHandler instance.TextChanged, handler
C#
public event EventHandler TextChanged()
Managed Extensions for C++
public: __event EventHandler* TextChanged
C++/CLI
public:
event EventHandler^ TextChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBarComboBoxItem Class
RibbonBarComboBoxItem Members


RibbonBarDropDownButtonItem Class

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarDropDownButtonItem Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarDropDownButtonItem Class

Object Model

Syntax

Visual Basic (Declaration)
Public Class RibbonBarDropDownButtonItem
   Inherits RibbonBarButtonItem
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarDropDownButtonItem
C#
public class RibbonBarDropDownButtonItem : RibbonBarButtonItem
Managed Extensions for C++
public __gc class RibbonBarDropDownButtonItem : public RibbonBarButtonItem
C++/CLI
public ref class RibbonBarDropDownButtonItem : public RibbonBarButtonItem

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RibbonBarItem
Gizmox.WebGUI.Forms.RibbonBarButtonItem
Gizmox.WebGUI.Forms.RibbonBarDropDownButtonItem
Gizmox.WebGUI.Forms.RibbonBarToolBarDropDownButtonItem

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms.Office (in Gizmox.WebGUI.Forms.Office.dll)

See Also

Reference

RibbonBarDropDownButtonItem Members
Gizmox.WebGUI.Forms Namespace


RibbonBarDropDownButtonItem Class Members

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarDropDownButtonItem Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarDropDownButtonItem Class

The following tables list the members exposed by RibbonBarDropDownButtonItem.

Public Constructors

 | Name | Description
Public Constructor | RibbonBarDropDownButtonItem Constructor |
Top

Public Properties

 | Name | Description
Public Property | ClientAction | Gets or sets the client action. (Inherited from RibbonBarButtonItem)
Public Property | Container | (Inherited from ComponentBase)
Public Property | Control | Gets the control. (Inherited from RibbonBarItem)
Public Property | DropDownMenu | Gets or sets the context menu code.
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from RibbonBarItem)
Public Property | Image | (Inherited from RibbonBarButtonItem)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Tag | Gets/Sets user definied tag (Inherited from RibbonBarItem)
Public Property | Text | Gets or sets the text. (Inherited from RibbonBarItem)
Public Property | ToolTip | Gets or sets the control tooltip. (Inherited from RibbonBarItem)
Public Property | Visible | Gets or sets a value indicating whether this RibbonBarItem is visible. (Inherited from RibbonBarItem)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Top

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded. (Inherited from ComponentBase)
Public Method | ToString | (Inherited from ComponentBase)
Top

Protected Methods

 | Name | Description
Protected Method | CreateButton | (Inherited from RibbonBarButtonItem)
Protected Method | CreateControl | Overridden.
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | OnButtonMenuClick |
Top

Public Events

 | Name | Description
Public Event | Click | Occurs when a ribbon bar button has been clicked (Inherited from RibbonBarButtonItem)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from RibbonBarButtonItem)
Top

See Also

Reference

RibbonBarDropDownButtonItem Class
Gizmox.WebGUI.Forms Namespace


RibbonBarDropDownButtonItem Constructor

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarDropDownButtonItem Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBarDropDownButtonItem Class : RibbonBarDropDownButtonItem Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarDropDownButtonItem()
C#
public RibbonBarDropDownButtonItem()
Managed Extensions for C++
public: RibbonBarDropDownButtonItem();
C++/CLI
public:
RibbonBarDropDownButtonItem();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBarDropDownButtonItem Class
RibbonBarDropDownButtonItem Members


RibbonBarDropDownButtonItem Class Methods

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarDropDownButtonItem Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarDropDownButtonItem Class

For a list of all members of this type, see RibbonBarDropDownButtonItem members.

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded. (Inherited from ComponentBase)
Public Method | ToString | (Inherited from ComponentBase)
Top

Protected Methods

 | Name | Description
Protected Method | CreateButton | (Inherited from RibbonBarButtonItem)
Protected Method | CreateControl | Overridden.
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | OnButtonMenuClick |
Top

See Also

Reference

RibbonBarDropDownButtonItem Class
Gizmox.WebGUI.Forms Namespace


CreateControl Method

[image]
Gizmox.WebGUI.Forms.Office
CreateControl Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBarDropDownButtonItem Class : CreateControl Method

Syntax

Visual Basic (Declaration)
Protected Overrides Function CreateControl() As Control
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarDropDownButtonItem
Dim value As Control

value = instance.CreateControl()
C#
protected override Control CreateControl()
Managed Extensions for C++
protected: Control* CreateControl(); override
C++/CLI
protected:
Control^ CreateControl(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBarDropDownButtonItem Class
RibbonBarDropDownButtonItem Members


OnButtonMenuClick Method

[image]
Gizmox.WebGUI.Forms.Office
OnButtonMenuClick Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBarDropDownButtonItem Class : OnButtonMenuClick Method

objSource
objArgs

Syntax

Visual Basic (Declaration)
Protected Sub OnButtonMenuClick( _
   ByVal objSource As Object, _
   ByVal objArgs As MenuItemEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarDropDownButtonItem
Dim objSource As Object
Dim objArgs As MenuItemEventArgs

instance.OnButtonMenuClick(objSource, objArgs)
C#
protected void OnButtonMenuClick(
   object objSource,
   MenuItemEventArgs objArgs
)
Managed Extensions for C++
protected: void OnButtonMenuClick(
   Object* objSource,
   MenuItemEventArgs* objArgs
)
C++/CLI
protected:
void OnButtonMenuClick(
   Object^ objSource,
   MenuItemEventArgs^ objArgs
)

Parameters

objSource
objArgs

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBarDropDownButtonItem Class
RibbonBarDropDownButtonItem Members


RibbonBarDropDownButtonItem Class Properties

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarDropDownButtonItem Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarDropDownButtonItem Class

For a list of all members of this type, see RibbonBarDropDownButtonItem members.

Public Properties

 | Name | Description
Public Property | ClientAction | Gets or sets the client action. (Inherited from RibbonBarButtonItem)
Public Property | Container | (Inherited from ComponentBase)
Public Property | Control | Gets the control. (Inherited from RibbonBarItem)
Public Property | DropDownMenu | Gets or sets the context menu code.
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from RibbonBarItem)
Public Property | Image | (Inherited from RibbonBarButtonItem)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Tag | Gets/Sets user definied tag (Inherited from RibbonBarItem)
Public Property | Text | Gets or sets the text. (Inherited from RibbonBarItem)
Public Property | ToolTip | Gets or sets the control tooltip. (Inherited from RibbonBarItem)
Public Property | Visible | Gets or sets a value indicating whether this RibbonBarItem is visible. (Inherited from RibbonBarItem)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Top

See Also

Reference

RibbonBarDropDownButtonItem Class
Gizmox.WebGUI.Forms Namespace


DropDownMenu Property

[image]
Gizmox.WebGUI.Forms.Office
DropDownMenu Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBarDropDownButtonItem Class : DropDownMenu Property

Gets or sets the context menu code.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<BrowsableAttribute(True)>
Public Overridable Property DropDownMenu As ContextMenu
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarDropDownButtonItem
Dim value As ContextMenu

instance.DropDownMenu = value

value = instance.DropDownMenu
C#
[DefaultValueAttribute()]
[BrowsableAttribute(true)]
public virtual ContextMenu DropDownMenu {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[BrowsableAttribute(true)]
public: __property virtual ContextMenu* get_DropDownMenu();
public: __property virtual void set_DropDownMenu(
   ContextMenu* value
);
C++/CLI
[DefaultValueAttribute()]
[BrowsableAttribute(true)]
public:
virtual property ContextMenu^ DropDownMenu {
   ContextMenu^ get();
   void set (ContextMenu^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBarDropDownButtonItem Class
RibbonBarDropDownButtonItem Members


RibbonBarFlowItem Class

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarFlowItem Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarFlowItem Class

Object Model

Syntax

Visual Basic (Declaration)
Public Class RibbonBarFlowItem
   Inherits RibbonBarItemContainer
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarFlowItem
C#
public class RibbonBarFlowItem : RibbonBarItemContainer
Managed Extensions for C++
public __gc class RibbonBarFlowItem : public RibbonBarItemContainer
C++/CLI
public ref class RibbonBarFlowItem : public RibbonBarItemContainer

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RibbonBarItem
Gizmox.WebGUI.Forms.RibbonBarItemContainer
Gizmox.WebGUI.Forms.RibbonBarFlowItem

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms.Office (in Gizmox.WebGUI.Forms.Office.dll)

See Also

Reference

RibbonBarFlowItem Members
Gizmox.WebGUI.Forms Namespace


RibbonBarFlowItem Class Members

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarFlowItem Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarFlowItem Class

The following tables list the members exposed by RibbonBarFlowItem.

Public Constructors

 | Name | Description
Public Constructor | RibbonBarFlowItem Constructor | Initializes a new instance of the RibonBarButtonStack class.
Top

Public Properties

 | Name | Description
Public Property | Container | (Inherited from ComponentBase)
Public Property | Control | Gets the control. (Inherited from RibbonBarItem)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from RibbonBarItem)
Public Property | Items | Overridden.
Public Property | Site | (Inherited from ComponentBase)
Public Property | Tag | Gets/Sets user definied tag (Inherited from RibbonBarItem)
Public Property | Text | Gets or sets the text. (Inherited from RibbonBarItem)
Public Property | ToolTip | Gets or sets the control tooltip. (Inherited from RibbonBarItem)
Public Property | Visible | Gets or sets a value indicating whether this RibbonBarItem is visible. (Inherited from RibbonBarItem)
Public Property | Width | Gets or sets the width.
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Top

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded. (Inherited from ComponentBase)
Public Method | ToString | (Inherited from ComponentBase)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControl | Overridden.
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetValidItemTypes | Overridden.
Top

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from ComponentBase)
Top

See Also

Reference

RibbonBarFlowItem Class
Gizmox.WebGUI.Forms Namespace


RibbonBarFlowItem Constructor

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarFlowItem Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBarFlowItem Class : RibbonBarFlowItem Constructor

Initializes a new instance of the RibonBarButtonStack class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarFlowItem()
C#
public RibbonBarFlowItem()
Managed Extensions for C++
public: RibbonBarFlowItem();
C++/CLI
public:
RibbonBarFlowItem();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBarFlowItem Class
RibbonBarFlowItem Members


RibbonBarFlowItem Class Methods

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarFlowItem Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarFlowItem Class

For a list of all members of this type, see RibbonBarFlowItem members.

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded. (Inherited from ComponentBase)
Public Method | ToString | (Inherited from ComponentBase)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControl | Overridden.
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetValidItemTypes | Overridden.
Top

See Also

Reference

RibbonBarFlowItem Class
Gizmox.WebGUI.Forms Namespace


CreateControl Method

[image]
Gizmox.WebGUI.Forms.Office
CreateControl Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBarFlowItem Class : CreateControl Method

Syntax

Visual Basic (Declaration)
Protected Overrides Function CreateControl() As Control
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarFlowItem
Dim value As Control

value = instance.CreateControl()
C#
protected override Control CreateControl()
Managed Extensions for C++
protected: Control* CreateControl(); override
C++/CLI
protected:
Control^ CreateControl(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBarFlowItem Class
RibbonBarFlowItem Members


GetValidItemTypes Method

[image]
Gizmox.WebGUI.Forms.Office
GetValidItemTypes Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBarFlowItem Class : GetValidItemTypes Method

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetValidItemTypes() As Type()
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarFlowItem
Dim value() As Type

value = instance.GetValidItemTypes()
C#
protected override Type[] GetValidItemTypes()
Managed Extensions for C++
protected: Type*[]* GetValidItemTypes(); override
C++/CLI
protected:
array<Type^>^ GetValidItemTypes(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBarFlowItem Class
RibbonBarFlowItem Members


RibbonBarFlowItem Class Properties

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarFlowItem Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarFlowItem Class

For a list of all members of this type, see RibbonBarFlowItem members.

Public Properties

 | Name | Description
Public Property | Container | (Inherited from ComponentBase)
Public Property | Control | Gets the control. (Inherited from RibbonBarItem)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from RibbonBarItem)
Public Property | Items | Overridden.
Public Property | Site | (Inherited from ComponentBase)
Public Property | Tag | Gets/Sets user definied tag (Inherited from RibbonBarItem)
Public Property | Text | Gets or sets the text. (Inherited from RibbonBarItem)
Public Property | ToolTip | Gets or sets the control tooltip. (Inherited from RibbonBarItem)
Public Property | Visible | Gets or sets a value indicating whether this RibbonBarItem is visible. (Inherited from RibbonBarItem)
Public Property | Width | Gets or sets the width.
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Top

See Also

Reference

RibbonBarFlowItem Class
Gizmox.WebGUI.Forms Namespace


Items Property

[image]
Gizmox.WebGUI.Forms.Office
Items Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBarFlowItem Class : Items Property

Syntax

Visual Basic (Declaration)
<EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Office.Design.RibonBarFlowItemCollectionEditor, Gizmox.WebGUI.Forms.Office.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=d50c2c7452ba77d9")>
Public Overrides ReadOnly Property Items As RibbonBarItemCollection
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarFlowItem
Dim value As RibbonBarItemCollection

value = instance.Items
C#
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Office.Design.RibonBarFlowItemCollectionEditor, Gizmox.WebGUI.Forms.Office.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=d50c2c7452ba77d9")]
public override RibbonBarItemCollection Items {get;}
Managed Extensions for C++
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Office.Design.RibonBarFlowItemCollectionEditor, Gizmox.WebGUI.Forms.Office.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=d50c2c7452ba77d9")]
public: __property RibbonBarItemCollection* get_Items() override;
C++/CLI
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Office.Design.RibonBarFlowItemCollectionEditor, Gizmox.WebGUI.Forms.Office.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=d50c2c7452ba77d9")]
public:
property RibbonBarItemCollection^ Items {
   RibbonBarItemCollection^ get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBarFlowItem Class
RibbonBarFlowItem Members


Width Property

[image]
Gizmox.WebGUI.Forms.Office
Width Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBarFlowItem Class : Width Property

Gets or sets the width.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property Width As Integer
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarFlowItem
Dim value As Integer

instance.Width = value

value = instance.Width
C#
[DefaultValueAttribute()]
public int Width {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property int get_Width();
public: __property void set_Width(
   int value
);
C++/CLI
[DefaultValueAttribute()]
public:
property int Width {
   int get();
   void set (intvalue);
}

Return Value

The width.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBarFlowItem Class
RibbonBarFlowItem Members


RibbonBarGroup Class

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarGroup Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarGroup Class

Object Model

Syntax

Visual Basic (Declaration)
<ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")>
Public Class RibbonBarGroup
   Inherits RibbonBarItemContainer
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarGroup
C#
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
public class RibbonBarGroup : RibbonBarItemContainer
Managed Extensions for C++
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
public __gc class RibbonBarGroup : public RibbonBarItemContainer
C++/CLI
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
public ref class RibbonBarGroup : public RibbonBarItemContainer

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RibbonBarItem
Gizmox.WebGUI.Forms.RibbonBarItemContainer
Gizmox.WebGUI.Forms.RibbonBarGroup

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms.Office (in Gizmox.WebGUI.Forms.Office.dll)

See Also

Reference

RibbonBarGroup Members
Gizmox.WebGUI.Forms Namespace


RibbonBarGroup Class Members

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarGroup Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarGroup Class

The following tables list the members exposed by RibbonBarGroup.

Public Constructors

 | Name | Description
Public Constructor | RibbonBarGroup Constructor | Initializes a new instance of the RibonBarGroup class.
Top

Public Properties

 | Name | Description
Public Property | Container | (Inherited from ComponentBase)
Public Property | Control | Gets the control. (Inherited from RibbonBarItem)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from RibbonBarItem)
Public Property | HasAdvanced | Gets or sets a value indicating whether this instance has advanced.
Public Property | Items | Overridden.
Public Property | Site | (Inherited from ComponentBase)
Public Property | Tag | Gets/Sets user definied tag (Inherited from RibbonBarItem)
Public Property | Text | Gets or sets the text. (Inherited from RibbonBarItem)
Public Property | ToolTip | Gets or sets the control tooltip. (Inherited from RibbonBarItem)
Public Property | Visible | Gets or sets a value indicating whether this RibbonBarItem is visible. (Inherited from RibbonBarItem)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Top

Public Methods

 | Name | Description
Public Method | Apply | Applies content to an existing group.
Public Method | Dispose | Overloaded. (Inherited from ComponentBase)
Public Method | ToString | Overridden.
Top

Protected Methods

 | Name | Description
Protected Method | CreateControl | Overridden.
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetValidItemTypes | Overridden.
Top

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from ComponentBase)
Top

See Also

Reference

RibbonBarGroup Class
Gizmox.WebGUI.Forms Namespace


RibbonBarGroup Constructor

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarGroup Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBarGroup Class : RibbonBarGroup Constructor

Initializes a new instance of the RibonBarGroup class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarGroup()
C#
public RibbonBarGroup()
Managed Extensions for C++
public: RibbonBarGroup();
C++/CLI
public:
RibbonBarGroup();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBarGroup Class
RibbonBarGroup Members


RibbonBarGroup Class Methods

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarGroup Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarGroup Class

For a list of all members of this type, see RibbonBarGroup members.

Public Methods

 | Name | Description
Public Method | Apply | Applies content to an existing group.
Public Method | Dispose | Overloaded. (Inherited from ComponentBase)
Public Method | ToString | Overridden.
Top

Protected Methods

 | Name | Description
Protected Method | CreateControl | Overridden.
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetValidItemTypes | Overridden.
Top

See Also

Reference

RibbonBarGroup Class
Gizmox.WebGUI.Forms Namespace


Apply Method

[image]
Gizmox.WebGUI.Forms.Office
Apply Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBarGroup Class : Apply Method

objGenerator
strGroupName
The name of the ribbon bar group to apply.
Applies content to an existing group.

Syntax

Visual Basic (Declaration)
Public Sub Apply( _
   ByVal objGenerator As ISupportsRibbonBar, _
   ByVal strGroupName As String _
)
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarGroup
Dim objGenerator As ISupportsRibbonBar
Dim strGroupName As String

instance.Apply(objGenerator, strGroupName)
C#
public void Apply(
   ISupportsRibbonBar objGenerator,
   string strGroupName
)
Managed Extensions for C++
public: void Apply(
   ISupportsRibbonBar* objGenerator,
   string* strGroupName
)
C++/CLI
public:
void Apply(
   ISupportsRibbonBar^ objGenerator,
   String^ strGroupName
)

Parameters

objGenerator
strGroupName
The name of the ribbon bar group to apply.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBarGroup Class
RibbonBarGroup Members


CreateControl Method

[image]
Gizmox.WebGUI.Forms.Office
CreateControl Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBarGroup Class : CreateControl Method

Syntax

Visual Basic (Declaration)
Protected Overrides Function CreateControl() As Control
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarGroup
Dim value As Control

value = instance.CreateControl()
C#
protected override Control CreateControl()
Managed Extensions for C++
protected: Control* CreateControl(); override
C++/CLI
protected:
Control^ CreateControl(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBarGroup Class
RibbonBarGroup Members


GetValidItemTypes Method

[image]
Gizmox.WebGUI.Forms.Office
GetValidItemTypes Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBarGroup Class : GetValidItemTypes Method

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetValidItemTypes() As Type()
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarGroup
Dim value() As Type

value = instance.GetValidItemTypes()
C#
protected override Type[] GetValidItemTypes()
Managed Extensions for C++
protected: Type*[]* GetValidItemTypes(); override
C++/CLI
protected:
array<Type^>^ GetValidItemTypes(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBarGroup Class
RibbonBarGroup Members


ToString Method

[image]
Gizmox.WebGUI.Forms.Office
ToString Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBarGroup Class : ToString Method

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarGroup
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBarGroup Class
RibbonBarGroup Members


RibbonBarGroup Class Properties

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarGroup Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarGroup Class

For a list of all members of this type, see RibbonBarGroup members.

Public Properties

 | Name | Description
Public Property | Container | (Inherited from ComponentBase)
Public Property | Control | Gets the control. (Inherited from RibbonBarItem)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from RibbonBarItem)
Public Property | HasAdvanced | Gets or sets a value indicating whether this instance has advanced.
Public Property | Items | Overridden.
Public Property | Site | (Inherited from ComponentBase)
Public Property | Tag | Gets/Sets user definied tag (Inherited from RibbonBarItem)
Public Property | Text | Gets or sets the text. (Inherited from RibbonBarItem)
Public Property | ToolTip | Gets or sets the control tooltip. (Inherited from RibbonBarItem)
Public Property | Visible | Gets or sets a value indicating whether this RibbonBarItem is visible. (Inherited from RibbonBarItem)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Top

See Also

Reference

RibbonBarGroup Class
Gizmox.WebGUI.Forms Namespace


HasAdvanced Property

[image]
Gizmox.WebGUI.Forms.Office
HasAdvanced Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBarGroup Class : HasAdvanced Property

Gets or sets a value indicating whether this instance has advanced.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property HasAdvanced As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarGroup
Dim value As Boolean

instance.HasAdvanced = value

value = instance.HasAdvanced
C#
[DefaultValueAttribute()]
public bool HasAdvanced {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property bool get_HasAdvanced();
public: __property void set_HasAdvanced(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
public:
property bool HasAdvanced {
   bool get();
   void set (boolvalue);
}

Return Value

true if this instance has advanced; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBarGroup Class
RibbonBarGroup Members


Items Property

[image]
Gizmox.WebGUI.Forms.Office
Items Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBarGroup Class : Items Property

Syntax

Visual Basic (Declaration)
<EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Office.Design.RibonBarGroupItemCollectionEditor, Gizmox.WebGUI.Forms.Office.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=e838c68aaf727726")>
Public Overrides ReadOnly Property Items As RibbonBarItemCollection
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarGroup
Dim value As RibbonBarItemCollection

value = instance.Items
C#
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Office.Design.RibonBarGroupItemCollectionEditor, Gizmox.WebGUI.Forms.Office.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=e838c68aaf727726")]
public override RibbonBarItemCollection Items {get;}
Managed Extensions for C++
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Office.Design.RibonBarGroupItemCollectionEditor, Gizmox.WebGUI.Forms.Office.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=e838c68aaf727726")]
public: __property RibbonBarItemCollection* get_Items() override;
C++/CLI
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Office.Design.RibonBarGroupItemCollectionEditor, Gizmox.WebGUI.Forms.Office.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=e838c68aaf727726")]
public:
property RibbonBarItemCollection^ Items {
   RibbonBarItemCollection^ get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBarGroup Class
RibbonBarGroup Members


RibbonBarGroupArgs Class

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarGroupArgs Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarGroupArgs Class

Object Model

Syntax

Visual Basic (Declaration)
Public Class RibbonBarGroupArgs
   Inherits EventArgs
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarGroupArgs
C#
public class RibbonBarGroupArgs : EventArgs
Managed Extensions for C++
public __gc class RibbonBarGroupArgs : public EventArgs
C++/CLI
public ref class RibbonBarGroupArgs : public EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gizmox.WebGUI.Forms.RibbonBarGroupArgs

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms.Office (in Gizmox.WebGUI.Forms.Office.dll)

See Also

Reference

RibbonBarGroupArgs Members
Gizmox.WebGUI.Forms Namespace


RibbonBarGroupArgs Class Members

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarGroupArgs Class Members
See Also Properties Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarGroupArgs Class

The following tables list the members exposed by RibbonBarGroupArgs.

Public Constructors

 | Name | Description
Public Constructor | RibbonBarGroupArgs Constructor |
Top

Public Properties

 | Name | Description
Public Property | Group |
Top

See Also

Reference

RibbonBarGroupArgs Class
Gizmox.WebGUI.Forms Namespace


RibbonBarGroupArgs Constructor

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarGroupArgs Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBarGroupArgs Class : RibbonBarGroupArgs Constructor

objGroup

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal objGroup As RibbonBarGroup _
)
Visual Basic (Usage) Copy Code
Dim objGroup As RibbonBarGroup

Dim instance As RibbonBarGroupArgs(objGroup)
C#
public RibbonBarGroupArgs(
   RibbonBarGroup objGroup
)
Managed Extensions for C++
public: RibbonBarGroupArgs(
   RibbonBarGroup* objGroup
)
C++/CLI
public:
RibbonBarGroupArgs(
   RibbonBarGroup^ objGroup
)

Parameters

objGroup

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBarGroupArgs Class
RibbonBarGroupArgs Members


RibbonBarGroupArgs Class Properties

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarGroupArgs Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarGroupArgs Class

For a list of all members of this type, see RibbonBarGroupArgs members.

Public Properties

 | Name | Description
Public Property | Group |
Top

See Also

Reference

RibbonBarGroupArgs Class
Gizmox.WebGUI.Forms Namespace


Group Property

[image]
Gizmox.WebGUI.Forms.Office
Group Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBarGroupArgs Class : Group Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Group As RibbonBarGroup
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarGroupArgs
Dim value As RibbonBarGroup

value = instance.Group
C#
public RibbonBarGroup Group {get;}
Managed Extensions for C++
public: __property RibbonBarGroup* get_Group();
C++/CLI
public:
property RibbonBarGroup^ Group {
   RibbonBarGroup^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBarGroupArgs Class
RibbonBarGroupArgs Members


RibbonBarGroupCollection Class

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarGroupCollection Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarGroupCollection Class

Object Model

Syntax

Visual Basic (Declaration)
Public Class RibbonBarGroupCollection
   Inherits Collection(Of RibbonBarGroup)
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarGroupCollection
C#
public class RibbonBarGroupCollection : Collection<RibbonBarGroup>
Managed Extensions for C++
public __gc class RibbonBarGroupCollection : public Collection<RibbonBarGroup>
C++/CLI
public ref class RibbonBarGroupCollection : public Collection<RibbonBarGroup>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<RibbonBarGroup>
Gizmox.WebGUI.Forms.RibbonBarGroupCollection

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms.Office (in Gizmox.WebGUI.Forms.Office.dll)

See Also

Reference

RibbonBarGroupCollection Members
Gizmox.WebGUI.Forms Namespace


RibbonBarGroupCollection Class Members

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarGroupCollection Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarGroupCollection Class

The following tables list the members exposed by RibbonBarGroupCollection.

Public Constructors

 | Name | Description
Public Constructor | RibbonBarGroupCollection Constructor | Initializes a new instance of the RibonBarGroupCollection class.
Top

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<RibbonBarGroup>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<RibbonBarGroup>)
Top

Protected Properties

 | Name | Description
Protected Property | Items | (Inherited from System.Collections.ObjectModel.Collection<RibbonBarGroup>)
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Adds a ribbon bar group generated by an external source.
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<RibbonBarGroup>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<RibbonBarGroup>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<RibbonBarGroup>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<RibbonBarGroup>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<RibbonBarGroup>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<RibbonBarGroup>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<RibbonBarGroup>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<RibbonBarGroup>)
Top

Protected Methods

 | Name | Description
Protected Method | ClearItems | Overridden. Removes all elements from the Generic Collection.
Protected Method | InsertItem | Overridden. Inserts an element into the Generic Collection at the specified index.
Protected Method | RemoveItem | Overridden. Removes the element at the specified index of the Generic Collection.
Protected Method | SetItem | Overridden.
Top

See Also

Reference

RibbonBarGroupCollection Class
Gizmox.WebGUI.Forms Namespace


RibbonBarGroupCollection Constructor

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarGroupCollection Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBarGroupCollection Class : RibbonBarGroupCollection Constructor

objRibonBarPage
The obj ribbon bar page.
Initializes a new instance of the RibonBarGroupCollection class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal objRibonBarPage As RibbonBarPage _
)
Visual Basic (Usage) Copy Code
Dim objRibonBarPage As RibbonBarPage

Dim instance As RibbonBarGroupCollection(objRibonBarPage)
C#
public RibbonBarGroupCollection(
   RibbonBarPage objRibonBarPage
)
Managed Extensions for C++
public: RibbonBarGroupCollection(
   RibbonBarPage* objRibonBarPage
)
C++/CLI
public:
RibbonBarGroupCollection(
   RibbonBarPage^ objRibonBarPage
)

Parameters

objRibonBarPage
The obj ribbon bar page.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBarGroupCollection Class
RibbonBarGroupCollection Members


RibbonBarGroupCollection Class Methods

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarGroupCollection Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarGroupCollection Class

For a list of all members of this type, see RibbonBarGroupCollection members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Adds a ribbon bar group generated by an external source.
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<RibbonBarGroup>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<RibbonBarGroup>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<RibbonBarGroup>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<RibbonBarGroup>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<RibbonBarGroup>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<RibbonBarGroup>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<RibbonBarGroup>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<RibbonBarGroup>)
Top

Protected Methods

 | Name | Description
Protected Method | ClearItems | Overridden. Removes all elements from the Generic Collection.
Protected Method | InsertItem | Overridden. Inserts an element into the Generic Collection at the specified index.
Protected Method | RemoveItem | Overridden. Removes the element at the specified index of the Generic Collection.
Protected Method | SetItem | Overridden.
Top

See Also

Reference

RibbonBarGroupCollection Class
Gizmox.WebGUI.Forms Namespace


Add Method

[image]
Gizmox.WebGUI.Forms.Office
Add Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBarGroupCollection Class : Add Method

Adds a ribbon bar group generated by an external source.

Overload List

Overload | Description
Add(ISupportsRibbonBar,String) | Adds a ribbon bar group generated by an external source.
Add(RibbonBarGroup) | (Inherited from System.Collections.ObjectModel.Collection<RibbonBarGroup>)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBarGroupCollection Class
RibbonBarGroupCollection Members


Add(ISupportsRibbonBar,String) Method

[image]
Gizmox.WebGUI.Forms.Office
Add(ISupportsRibbonBar,String) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBarGroupCollection Class > Add Method : Add(ISupportsRibbonBar,String) Method

objGenerator
The ribbon bar generator.
strGroupName
The ribbon bar group name to generate.
Adds a ribbon bar group generated by an external source.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Add( _
   ByVal objGenerator As ISupportsRibbonBar, _
   ByVal strGroupName As String _
)
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarGroupCollection
Dim objGenerator As ISupportsRibbonBar
Dim strGroupName As String

instance.Add(objGenerator, strGroupName)
C#
public void Add(
   ISupportsRibbonBar objGenerator,
   string strGroupName
)
Managed Extensions for C++
public: void Add(
   ISupportsRibbonBar* objGenerator,
   string* strGroupName
)
C++/CLI
public:
void Add(
   ISupportsRibbonBar^ objGenerator,
   String^ strGroupName
)

Parameters

objGenerator
The ribbon bar generator.
strGroupName
The ribbon bar group name to generate.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBarGroupCollection Class
RibbonBarGroupCollection Members
Overload List


ClearItems Method

[image]
Gizmox.WebGUI.Forms.Office
ClearItems Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBarGroupCollection Class : ClearItems Method

Removes all elements from the Generic Collection.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub ClearItems()
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarGroupCollection

instance.ClearItems()
C#
protected override void ClearItems()
Managed Extensions for C++
protected: void ClearItems(); override
C++/CLI
protected:
void ClearItems(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBarGroupCollection Class
RibbonBarGroupCollection Members


InsertItem Method

[image]
Gizmox.WebGUI.Forms.Office
InsertItem Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBarGroupCollection Class : InsertItem Method

index
The zero-based index at which item should be inserted.
item
The object to insert. The value can be null for reference types.
Inserts an element into the Generic Collection at the specified index.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub InsertItem( _
   ByVal index As Integer, _
   ByVal item As RibbonBarGroup _
)
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarGroupCollection
Dim index As Integer
Dim item As RibbonBarGroup

instance.InsertItem(index, item)
C#
protected override void InsertItem(
   int index,
   RibbonBarGroup item
)
Managed Extensions for C++
protected: void InsertItem(
   int index,
   RibbonBarGroup* item
) override
C++/CLI
protected:
void InsertItem(
   int index,
   RibbonBarGroup^ item
) override

Parameters

index
The zero-based index at which item should be inserted.
item
The object to insert. The value can be null for reference types.

Exceptions

Exception | Description
ArgumentOutOfRangeException | index is less than zero.-or-index is greater than Count.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBarGroupCollection Class
RibbonBarGroupCollection Members


RemoveItem Method

[image]
Gizmox.WebGUI.Forms.Office
RemoveItem Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBarGroupCollection Class : RemoveItem Method

index
The zero-based index of the element to remove.
Removes the element at the specified index of the Generic Collection.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub RemoveItem( _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarGroupCollection
Dim index As Integer

instance.RemoveItem(index)
C#
protected override void RemoveItem(
   int index
)
Managed Extensions for C++
protected: void RemoveItem(
   int index
) override
C++/CLI
protected:
void RemoveItem(
   int index
) override

Parameters

index
The zero-based index of the element to remove.

Exceptions

Exception | Description
ArgumentOutOfRangeException | index is less than zero.-or-index is equal to or greater than Count.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBarGroupCollection Class
RibbonBarGroupCollection Members


SetItem Method

[image]
Gizmox.WebGUI.Forms.Office
SetItem Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBarGroupCollection Class : SetItem Method

index
item

Syntax

Visual Basic (Declaration)
Protected Overrides Sub SetItem( _
   ByVal index As Integer, _
   ByVal item As RibbonBarGroup _
)
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarGroupCollection
Dim index As Integer
Dim item As RibbonBarGroup

instance.SetItem(index, item)
C#
protected override void SetItem(
   int index,
   RibbonBarGroup item
)
Managed Extensions for C++
protected: void SetItem(
   int index,
   RibbonBarGroup* item
) override
C++/CLI
protected:
void SetItem(
   int index,
   RibbonBarGroup^ item
) override

Parameters

index
item

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBarGroupCollection Class
RibbonBarGroupCollection Members


RibbonBarItem Class

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarItem Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarItem Class

Object Model

Syntax

Visual Basic (Declaration)
<ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")>
Public MustInherit Class RibbonBarItem
   Inherits ComponentBase
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarItem
C#
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
public abstract class RibbonBarItem : ComponentBase
Managed Extensions for C++
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
public __gc abstract class RibbonBarItem : public ComponentBase
C++/CLI
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
public ref class RibbonBarItem abstract : public ComponentBase

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RibbonBarItem
Gizmox.WebGUI.Forms.RibbonBarButtonItem
Gizmox.WebGUI.Forms.RibbonBarCheckBoxItem
Gizmox.WebGUI.Forms.RibbonBarComboBoxItem
Gizmox.WebGUI.Forms.RibbonBarItemContainer
Gizmox.WebGUI.Forms.RibbonBarTextBoxItem

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms.Office (in Gizmox.WebGUI.Forms.Office.dll)

See Also

Reference

RibbonBarItem Members
Gizmox.WebGUI.Forms Namespace


RibbonBarItem Class Members

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarItem Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarItem Class

The following tables list the members exposed by RibbonBarItem.

Public Properties

 | Name | Description
Public Property | Container | (Inherited from ComponentBase)
Public Property | Control | Gets the control.
Public Property | Enabled | Gets or sets the control enabled state.
Public Property | Site | (Inherited from ComponentBase)
Public Property | Tag | Gets/Sets user definied tag
Public Property | Text | Gets or sets the text.
Public Property | ToolTip | Gets or sets the control tooltip.
Public Property | Visible | Gets or sets a value indicating whether this RibbonBarItem is visible.
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Top

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded. (Inherited from ComponentBase)
Public Method | ToString | (Inherited from ComponentBase)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControl |
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | GetService | (Inherited from ComponentBase)
Top

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from ComponentBase)
Top

See Also

Reference

RibbonBarItem Class
Gizmox.WebGUI.Forms Namespace


RibbonBarItem Class Methods

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarItem Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarItem Class

For a list of all members of this type, see RibbonBarItem members.

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded. (Inherited from ComponentBase)
Public Method | ToString | (Inherited from ComponentBase)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControl |
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | GetService | (Inherited from ComponentBase)
Top

See Also

Reference

RibbonBarItem Class
Gizmox.WebGUI.Forms Namespace


CreateControl Method

[image]
Gizmox.WebGUI.Forms.Office
CreateControl Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBarItem Class : CreateControl Method

Syntax

Visual Basic (Declaration)
Protected Overridable Function CreateControl() As Control
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarItem
Dim value As Control

value = instance.CreateControl()
C#
protected virtual Control CreateControl()
Managed Extensions for C++
protected: virtual Control* CreateControl();
C++/CLI
protected:
virtual Control^ CreateControl();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBarItem Class
RibbonBarItem Members


RibbonBarItem Class Properties

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarItem Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarItem Class

For a list of all members of this type, see RibbonBarItem members.

Public Properties

 | Name | Description
Public Property | Container | (Inherited from ComponentBase)
Public Property | Control | Gets the control.
Public Property | Enabled | Gets or sets the control enabled state.
Public Property | Site | (Inherited from ComponentBase)
Public Property | Tag | Gets/Sets user definied tag
Public Property | Text | Gets or sets the text.
Public Property | ToolTip | Gets or sets the control tooltip.
Public Property | Visible | Gets or sets a value indicating whether this RibbonBarItem is visible.
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Top

See Also

Reference

RibbonBarItem Class
Gizmox.WebGUI.Forms Namespace


Control Property

[image]
Gizmox.WebGUI.Forms.Office
Control Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBarItem Class : Control Property

Gets the control.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public ReadOnly Property Control As Control
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarItem
Dim value As Control

value = instance.Control
C#
[BrowsableAttribute(false)]
public Control Control {get;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property Control* get_Control();
C++/CLI
[BrowsableAttribute(false)]
public:
property Control^ Control {
   Control^ get();
}

Return Value

The control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBarItem Class
RibbonBarItem Members


Enabled Property

[image]
Gizmox.WebGUI.Forms.Office
Enabled Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBarItem Class : Enabled Property

Gets or sets the control enabled state.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Overridable Property Enabled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarItem
Dim value As Boolean

instance.Enabled = value

value = instance.Enabled
C#
[DefaultValueAttribute()]
public virtual bool Enabled {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property virtual bool get_Enabled();
public: __property virtual void set_Enabled(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
public:
virtual property bool Enabled {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBarItem Class
RibbonBarItem Members


Tag Property

[image]
Gizmox.WebGUI.Forms.Office
Tag Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBarItem Class : Tag Property

Gets/Sets user definied tag

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<TypeConverterAttribute("System.ComponentModel.StringConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
Public Overridable Property Tag As Object
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarItem
Dim value As Object

instance.Tag = value

value = instance.Tag
C#
[DefaultValueAttribute()]
[TypeConverterAttribute("System.ComponentModel.StringConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public virtual object Tag {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[TypeConverterAttribute("System.ComponentModel.StringConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public: __property virtual Object* get_Tag();
public: __property virtual void set_Tag(
   Object* value
);
C++/CLI
[DefaultValueAttribute()]
[TypeConverterAttribute("System.ComponentModel.StringConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public:
virtual property Object^ Tag {
   Object^ get();
   void set (Object^value);
}

Return Value

The user definied tag.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBarItem Class
RibbonBarItem Members


Text Property

[image]
Gizmox.WebGUI.Forms.Office
Text Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBarItem Class : Text Property

Gets or sets the text.

Syntax

Visual Basic (Declaration)
<LocalizableAttribute(True)>
<DefaultValueAttribute()>
Public Overridable Property Text As String
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarItem
Dim value As String

instance.Text = value

value = instance.Text
C#
[LocalizableAttribute(true)]
[DefaultValueAttribute()]
public virtual string Text {get; set;}
Managed Extensions for C++
[LocalizableAttribute(true)]
[DefaultValueAttribute()]
public: __property virtual string* get_Text();
public: __property virtual void set_Text(
   string* value
);
C++/CLI
[LocalizableAttribute(true)]
[DefaultValueAttribute()]
public:
virtual property String^ Text {
   String^ get();
   void set (String^value);
}

Return Value

The text.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBarItem Class
RibbonBarItem Members


ToolTip Property

[image]
Gizmox.WebGUI.Forms.Office
ToolTip Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBarItem Class : ToolTip Property

Gets or sets the control tooltip.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<LocalizableAttribute(True)>
Public Overridable Property ToolTip As String
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarItem
Dim value As String

instance.ToolTip = value

value = instance.ToolTip
C#
[DefaultValueAttribute()]
[LocalizableAttribute(true)]
public virtual string ToolTip {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[LocalizableAttribute(true)]
public: __property virtual string* get_ToolTip();
public: __property virtual void set_ToolTip(
   string* value
);
C++/CLI
[DefaultValueAttribute()]
[LocalizableAttribute(true)]
public:
virtual property String^ ToolTip {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBarItem Class
RibbonBarItem Members


Visible Property

[image]
Gizmox.WebGUI.Forms.Office
Visible Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBarItem Class : Visible Property

Gets or sets a value indicating whether this RibbonBarItem is visible.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Overridable Property Visible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarItem
Dim value As Boolean

instance.Visible = value

value = instance.Visible
C#
[DefaultValueAttribute()]
public virtual bool Visible {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property virtual bool get_Visible();
public: __property virtual void set_Visible(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
public:
virtual property bool Visible {
   bool get();
   void set (boolvalue);
}

Return Value

true if visible; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBarItem Class
RibbonBarItem Members


RibbonBarItemCollection Class

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarItemCollection Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarItemCollection Class

Object Model

Syntax

Visual Basic (Declaration)
Public Class RibbonBarItemCollection
   Inherits Collection(Of RibbonBarItem)
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarItemCollection
C#
public class RibbonBarItemCollection : Collection<RibbonBarItem>
Managed Extensions for C++
public __gc class RibbonBarItemCollection : public Collection<RibbonBarItem>
C++/CLI
public ref class RibbonBarItemCollection : public Collection<RibbonBarItem>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<RibbonBarItem>
Gizmox.WebGUI.Forms.RibbonBarItemCollection

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms.Office (in Gizmox.WebGUI.Forms.Office.dll)

See Also

Reference

RibbonBarItemCollection Members
Gizmox.WebGUI.Forms Namespace


RibbonBarItemCollection Class Members

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarItemCollection Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarItemCollection Class

The following tables list the members exposed by RibbonBarItemCollection.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<RibbonBarItem>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<RibbonBarItem>)
Top

Protected Properties

 | Name | Description
Protected Property | Items | (Inherited from System.Collections.ObjectModel.Collection<RibbonBarItem>)
Top

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<RibbonBarItem>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<RibbonBarItem>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<RibbonBarItem>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<RibbonBarItem>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<RibbonBarItem>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<RibbonBarItem>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<RibbonBarItem>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<RibbonBarItem>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<RibbonBarItem>)
Top

Protected Methods

 | Name | Description
Protected Method | ClearItems | Overridden. Removes all elements from the Generic Collection.
Protected Method | InsertItem | Overridden. Inserts an element into the Generic Collection at the specified index.
Protected Method | RemoveItem | Overridden. Removes the element at the specified index of the Generic Collection.
Protected Method | SetItem | (Inherited from System.Collections.ObjectModel.Collection<RibbonBarItem>)
Top

See Also

Reference

RibbonBarItemCollection Class
Gizmox.WebGUI.Forms Namespace


RibbonBarItemCollection Class Methods

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarItemCollection Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarItemCollection Class

For a list of all members of this type, see RibbonBarItemCollection members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<RibbonBarItem>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<RibbonBarItem>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<RibbonBarItem>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<RibbonBarItem>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<RibbonBarItem>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<RibbonBarItem>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<RibbonBarItem>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<RibbonBarItem>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<RibbonBarItem>)
Top

Protected Methods

 | Name | Description
Protected Method | ClearItems | Overridden. Removes all elements from the Generic Collection.
Protected Method | InsertItem | Overridden. Inserts an element into the Generic Collection at the specified index.
Protected Method | RemoveItem | Overridden. Removes the element at the specified index of the Generic Collection.
Protected Method | SetItem | (Inherited from System.Collections.ObjectModel.Collection<RibbonBarItem>)
Top

See Also

Reference

RibbonBarItemCollection Class
Gizmox.WebGUI.Forms Namespace


ClearItems Method

[image]
Gizmox.WebGUI.Forms.Office
ClearItems Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBarItemCollection Class : ClearItems Method

Removes all elements from the Generic Collection.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub ClearItems()
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarItemCollection

instance.ClearItems()
C#
protected override void ClearItems()
Managed Extensions for C++
protected: void ClearItems(); override
C++/CLI
protected:
void ClearItems(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBarItemCollection Class
RibbonBarItemCollection Members


InsertItem Method

[image]
Gizmox.WebGUI.Forms.Office
InsertItem Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBarItemCollection Class : InsertItem Method

index
The zero-based index at which item should be inserted.
item
The object to insert. The value can be null for reference types.
Inserts an element into the Generic Collection at the specified index.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub InsertItem( _
   ByVal index As Integer, _
   ByVal item As RibbonBarItem _
)
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarItemCollection
Dim index As Integer
Dim item As RibbonBarItem

instance.InsertItem(index, item)
C#
protected override void InsertItem(
   int index,
   RibbonBarItem item
)
Managed Extensions for C++
protected: void InsertItem(
   int index,
   RibbonBarItem* item
) override
C++/CLI
protected:
void InsertItem(
   int index,
   RibbonBarItem^ item
) override

Parameters

index
The zero-based index at which item should be inserted.
item
The object to insert. The value can be null for reference types.

Exceptions

Exception | Description
ArgumentOutOfRangeException | index is less than zero.-or-index is greater than Count.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBarItemCollection Class
RibbonBarItemCollection Members


RemoveItem Method

[image]
Gizmox.WebGUI.Forms.Office
RemoveItem Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBarItemCollection Class : RemoveItem Method

index
The zero-based index of the element to remove.
Removes the element at the specified index of the Generic Collection.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub RemoveItem( _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarItemCollection
Dim index As Integer

instance.RemoveItem(index)
C#
protected override void RemoveItem(
   int index
)
Managed Extensions for C++
protected: void RemoveItem(
   int index
) override
C++/CLI
protected:
void RemoveItem(
   int index
) override

Parameters

index
The zero-based index of the element to remove.

Exceptions

Exception | Description
ArgumentOutOfRangeException | index is less than zero.-or-index is equal to or greater than Count.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBarItemCollection Class
RibbonBarItemCollection Members


RibbonBarItemContainer Class

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarItemContainer Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarItemContainer Class

Object Model

Syntax

Visual Basic (Declaration)
Public MustInherit Class RibbonBarItemContainer
   Inherits RibbonBarItem
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarItemContainer
C#
public abstract class RibbonBarItemContainer : RibbonBarItem
Managed Extensions for C++
public __gc abstract class RibbonBarItemContainer : public RibbonBarItem
C++/CLI
public ref class RibbonBarItemContainer abstract : public RibbonBarItem

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RibbonBarItem
Gizmox.WebGUI.Forms.RibbonBarItemContainer
Gizmox.WebGUI.Forms.RibbonBarFlowItem
Gizmox.WebGUI.Forms.RibbonBarGroup
Gizmox.WebGUI.Forms.RibbonBarStackItem
Gizmox.WebGUI.Forms.RibbonBarToolBarItem

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms.Office (in Gizmox.WebGUI.Forms.Office.dll)

See Also

Reference

RibbonBarItemContainer Members
Gizmox.WebGUI.Forms Namespace


RibbonBarItemContainer Class Members

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarItemContainer Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarItemContainer Class

The following tables list the members exposed by RibbonBarItemContainer.

Public Properties

 | Name | Description
Public Property | Container | (Inherited from ComponentBase)
Public Property | Control | Gets the control. (Inherited from RibbonBarItem)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from RibbonBarItem)
Public Property | Items |
Public Property | Site | (Inherited from ComponentBase)
Public Property | Tag | Gets/Sets user definied tag (Inherited from RibbonBarItem)
Public Property | Text | Gets or sets the text. (Inherited from RibbonBarItem)
Public Property | ToolTip | Gets or sets the control tooltip. (Inherited from RibbonBarItem)
Public Property | Visible | Gets or sets a value indicating whether this RibbonBarItem is visible. (Inherited from RibbonBarItem)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Top

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded. (Inherited from ComponentBase)
Public Method | ToString | (Inherited from ComponentBase)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControl | (Inherited from RibbonBarItem)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetValidItemTypes |
Top

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from ComponentBase)
Top

See Also

Reference

RibbonBarItemContainer Class
Gizmox.WebGUI.Forms Namespace


RibbonBarItemContainer Class Methods

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarItemContainer Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarItemContainer Class

For a list of all members of this type, see RibbonBarItemContainer members.

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded. (Inherited from ComponentBase)
Public Method | ToString | (Inherited from ComponentBase)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControl | (Inherited from RibbonBarItem)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetValidItemTypes |
Top

See Also

Reference

RibbonBarItemContainer Class
Gizmox.WebGUI.Forms Namespace


GetValidItemTypes Method

[image]
Gizmox.WebGUI.Forms.Office
GetValidItemTypes Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBarItemContainer Class : GetValidItemTypes Method

Syntax

Visual Basic (Declaration)
Protected MustOverride Function GetValidItemTypes() As Type()
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarItemContainer
Dim value() As Type

value = instance.GetValidItemTypes()
C#
protected abstract Type[] GetValidItemTypes()
Managed Extensions for C++
protected: abstract Type*[]* GetValidItemTypes();
C++/CLI
protected:
abstract array<Type^>^ GetValidItemTypes();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBarItemContainer Class
RibbonBarItemContainer Members


RibbonBarItemContainer Class Properties

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarItemContainer Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarItemContainer Class

For a list of all members of this type, see RibbonBarItemContainer members.

Public Properties

 | Name | Description
Public Property | Container | (Inherited from ComponentBase)
Public Property | Control | Gets the control. (Inherited from RibbonBarItem)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from RibbonBarItem)
Public Property | Items |
Public Property | Site | (Inherited from ComponentBase)
Public Property | Tag | Gets/Sets user definied tag (Inherited from RibbonBarItem)
Public Property | Text | Gets or sets the text. (Inherited from RibbonBarItem)
Public Property | ToolTip | Gets or sets the control tooltip. (Inherited from RibbonBarItem)
Public Property | Visible | Gets or sets a value indicating whether this RibbonBarItem is visible. (Inherited from RibbonBarItem)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Top

See Also

Reference

RibbonBarItemContainer Class
Gizmox.WebGUI.Forms Namespace


Items Property

[image]
Gizmox.WebGUI.Forms.Office
Items Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBarItemContainer Class : Items Property

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(True)>
Public Overridable ReadOnly Property Items As RibbonBarItemCollection
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarItemContainer
Dim value As RibbonBarItemCollection

value = instance.Items
C#
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(true)]
public virtual RibbonBarItemCollection Items {get;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(true)]
public: __property virtual RibbonBarItemCollection* get_Items();
C++/CLI
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(true)]
public:
virtual property RibbonBarItemCollection^ Items {
   RibbonBarItemCollection^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBarItemContainer Class
RibbonBarItemContainer Members


RibbonBarPage Class

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarPage Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarPage Class

Object Model

Syntax

Visual Basic (Declaration)
<ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")>
Public Class RibbonBarPage
   Inherits ComponentBase
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarPage
C#
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
public class RibbonBarPage : ComponentBase
Managed Extensions for C++
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
public __gc class RibbonBarPage : public ComponentBase
C++/CLI
[ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
public ref class RibbonBarPage : public ComponentBase

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RibbonBarPage

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms.Office (in Gizmox.WebGUI.Forms.Office.dll)

See Also

Reference

RibbonBarPage Members
Gizmox.WebGUI.Forms Namespace


RibbonBarPage Class Members

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarPage Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarPage Class

The following tables list the members exposed by RibbonBarPage.

Public Constructors

 | Name | Description
Public Constructor | RibbonBarPage Constructor | Overloaded. Initializes a new instance of the RibonBarPage class.
Top

Public Properties

 | Name | Description
Public Property | Container | (Inherited from ComponentBase)
Public Property | Groups | Gets the groups.
Public Property | Site | (Inherited from ComponentBase)
Public Property | Text | Gets or sets the text.
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Top

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded. (Inherited from ComponentBase)
Public Method | ToString | Overridden.
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | GetService | (Inherited from ComponentBase)
Top

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from ComponentBase)
Top

See Also

Reference

RibbonBarPage Class
Gizmox.WebGUI.Forms Namespace


RibbonBarPage Constructor

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarPage Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBarPage Class : RibbonBarPage Constructor

Initializes a new instance of the RibonBarPage class.

Overload List

Overload | Description
RibbonBarPage Constructor() | Initializes a new instance of the RibonBarPage class.
RibbonBarPage Constructor(String) | Initializes a new instance of the RibbonBarPage class.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBarPage Class
RibbonBarPage Members


RibbonBarPage Constructor()

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarPage Constructor()
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBarPage Class > RibbonBarPage Constructor : RibbonBarPage Constructor()

Initializes a new instance of the RibonBarPage class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarPage()
C#
public RibbonBarPage()
Managed Extensions for C++
public: RibbonBarPage();
C++/CLI
public:
RibbonBarPage();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBarPage Class
RibbonBarPage Members
Overload List


RibbonBarPage Constructor(String)

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarPage Constructor(String)
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBarPage Class > RibbonBarPage Constructor : RibbonBarPage Constructor(String)

strText
The page text.
Initializes a new instance of the RibbonBarPage class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal strText As String _
)
Visual Basic (Usage) Copy Code
Dim strText As String

Dim instance As RibbonBarPage(strText)
C#
public RibbonBarPage(
   string strText
)
Managed Extensions for C++
public: RibbonBarPage(
   string* strText
)
C++/CLI
public:
RibbonBarPage(
   String^ strText
)

Parameters

strText
The page text.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBarPage Class
RibbonBarPage Members
Overload List


RibbonBarPage Class Methods

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarPage Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarPage Class

For a list of all members of this type, see RibbonBarPage members.

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded. (Inherited from ComponentBase)
Public Method | ToString | Overridden.
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | GetService | (Inherited from ComponentBase)
Top

See Also

Reference

RibbonBarPage Class
Gizmox.WebGUI.Forms Namespace


ToString Method

[image]
Gizmox.WebGUI.Forms.Office
ToString Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBarPage Class : ToString Method

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarPage
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBarPage Class
RibbonBarPage Members


RibbonBarPage Class Properties

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarPage Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarPage Class

For a list of all members of this type, see RibbonBarPage members.

Public Properties

 | Name | Description
Public Property | Container | (Inherited from ComponentBase)
Public Property | Groups | Gets the groups.
Public Property | Site | (Inherited from ComponentBase)
Public Property | Text | Gets or sets the text.
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Top

See Also

Reference

RibbonBarPage Class
Gizmox.WebGUI.Forms Namespace


Groups Property

[image]
Gizmox.WebGUI.Forms.Office
Groups Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBarPage Class : Groups Property

Gets the groups.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(True)>
<DesignerSerializationVisibilityAttribute()>
Public ReadOnly Property Groups As RibbonBarGroupCollection
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarPage
Dim value As RibbonBarGroupCollection

value = instance.Groups
C#
[BrowsableAttribute(true)]
[DesignerSerializationVisibilityAttribute()]
public RibbonBarGroupCollection Groups {get;}
Managed Extensions for C++
[BrowsableAttribute(true)]
[DesignerSerializationVisibilityAttribute()]
public: __property RibbonBarGroupCollection* get_Groups();
C++/CLI
[BrowsableAttribute(true)]
[DesignerSerializationVisibilityAttribute()]
public:
property RibbonBarGroupCollection^ Groups {
   RibbonBarGroupCollection^ get();
}

Return Value

The groups.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBarPage Class
RibbonBarPage Members


Text Property

[image]
Gizmox.WebGUI.Forms.Office
Text Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBarPage Class : Text Property

Gets or sets the text.

Syntax

Visual Basic (Declaration)
<LocalizableAttribute(True)>
Public Property Text As String
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarPage
Dim value As String

instance.Text = value

value = instance.Text
C#
[LocalizableAttribute(true)]
public string Text {get; set;}
Managed Extensions for C++
[LocalizableAttribute(true)]
public: __property string* get_Text();
public: __property void set_Text(
   string* value
);
C++/CLI
[LocalizableAttribute(true)]
public:
property String^ Text {
   String^ get();
   void set (String^value);
}

Return Value

The text.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBarPage Class
RibbonBarPage Members


RibbonBarPageCollection Class

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarPageCollection Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarPageCollection Class

Object Model

Syntax

Visual Basic (Declaration)
Public Class RibbonBarPageCollection
   Inherits Collection(Of RibbonBarPage)
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarPageCollection
C#
public class RibbonBarPageCollection : Collection<RibbonBarPage>
Managed Extensions for C++
public __gc class RibbonBarPageCollection : public Collection<RibbonBarPage>
C++/CLI
public ref class RibbonBarPageCollection : public Collection<RibbonBarPage>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<RibbonBarPage>
Gizmox.WebGUI.Forms.RibbonBarPageCollection

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms.Office (in Gizmox.WebGUI.Forms.Office.dll)

See Also

Reference

RibbonBarPageCollection Members
Gizmox.WebGUI.Forms Namespace


RibbonBarPageCollection Class Members

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarPageCollection Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarPageCollection Class

The following tables list the members exposed by RibbonBarPageCollection.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<RibbonBarPage>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<RibbonBarPage>)
Top

Protected Properties

 | Name | Description
Protected Property | Items | (Inherited from System.Collections.ObjectModel.Collection<RibbonBarPage>)
Top

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<RibbonBarPage>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<RibbonBarPage>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<RibbonBarPage>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<RibbonBarPage>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<RibbonBarPage>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<RibbonBarPage>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<RibbonBarPage>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<RibbonBarPage>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<RibbonBarPage>)
Top

Protected Methods

 | Name | Description
Protected Method | ClearItems | Overridden. Removes all elements from the Generic Collection.
Protected Method | InsertItem | Overridden. Inserts an element into the Generic Collection at the specified index.
Protected Method | RemoveItem | Overridden. Removes the element at the specified index of the Generic Collection.
Protected Method | SetItem | (Inherited from System.Collections.ObjectModel.Collection<RibbonBarPage>)
Top

See Also

Reference

RibbonBarPageCollection Class
Gizmox.WebGUI.Forms Namespace


RibbonBarPageCollection Class Methods

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarPageCollection Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarPageCollection Class

For a list of all members of this type, see RibbonBarPageCollection members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<RibbonBarPage>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<RibbonBarPage>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<RibbonBarPage>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<RibbonBarPage>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<RibbonBarPage>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<RibbonBarPage>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<RibbonBarPage>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<RibbonBarPage>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<RibbonBarPage>)
Top

Protected Methods

 | Name | Description
Protected Method | ClearItems | Overridden. Removes all elements from the Generic Collection.
Protected Method | InsertItem | Overridden. Inserts an element into the Generic Collection at the specified index.
Protected Method | RemoveItem | Overridden. Removes the element at the specified index of the Generic Collection.
Protected Method | SetItem | (Inherited from System.Collections.ObjectModel.Collection<RibbonBarPage>)
Top

See Also

Reference

RibbonBarPageCollection Class
Gizmox.WebGUI.Forms Namespace


ClearItems Method

[image]
Gizmox.WebGUI.Forms.Office
ClearItems Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBarPageCollection Class : ClearItems Method

Removes all elements from the Generic Collection.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub ClearItems()
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarPageCollection

instance.ClearItems()
C#
protected override void ClearItems()
Managed Extensions for C++
protected: void ClearItems(); override
C++/CLI
protected:
void ClearItems(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBarPageCollection Class
RibbonBarPageCollection Members


InsertItem Method

[image]
Gizmox.WebGUI.Forms.Office
InsertItem Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBarPageCollection Class : InsertItem Method

index
The zero-based index at which item should be inserted.
item
The object to insert. The value can be null for reference types.
Inserts an element into the Generic Collection at the specified index.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub InsertItem( _
   ByVal index As Integer, _
   ByVal item As RibbonBarPage _
)
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarPageCollection
Dim index As Integer
Dim item As RibbonBarPage

instance.InsertItem(index, item)
C#
protected override void InsertItem(
   int index,
   RibbonBarPage item
)
Managed Extensions for C++
protected: void InsertItem(
   int index,
   RibbonBarPage* item
) override
C++/CLI
protected:
void InsertItem(
   int index,
   RibbonBarPage^ item
) override

Parameters

index
The zero-based index at which item should be inserted.
item
The object to insert. The value can be null for reference types.

Exceptions

Exception | Description
ArgumentOutOfRangeException | index is less than zero.-or-index is greater than Count.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBarPageCollection Class
RibbonBarPageCollection Members


RemoveItem Method

[image]
Gizmox.WebGUI.Forms.Office
RemoveItem Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBarPageCollection Class : RemoveItem Method

index
The zero-based index of the element to remove.
Removes the element at the specified index of the Generic Collection.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub RemoveItem( _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarPageCollection
Dim index As Integer

instance.RemoveItem(index)
C#
protected override void RemoveItem(
   int index
)
Managed Extensions for C++
protected: void RemoveItem(
   int index
) override
C++/CLI
protected:
void RemoveItem(
   int index
) override

Parameters

index
The zero-based index of the element to remove.

Exceptions

Exception | Description
ArgumentOutOfRangeException | index is less than zero.-or-index is equal to or greater than Count.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBarPageCollection Class
RibbonBarPageCollection Members


RibbonBarStackItem Class

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarStackItem Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarStackItem Class

Object Model

Syntax

Visual Basic (Declaration)
Public Class RibbonBarStackItem
   Inherits RibbonBarItemContainer
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarStackItem
C#
public class RibbonBarStackItem : RibbonBarItemContainer
Managed Extensions for C++
public __gc class RibbonBarStackItem : public RibbonBarItemContainer
C++/CLI
public ref class RibbonBarStackItem : public RibbonBarItemContainer

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RibbonBarItem
Gizmox.WebGUI.Forms.RibbonBarItemContainer
Gizmox.WebGUI.Forms.RibbonBarStackItem

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms.Office (in Gizmox.WebGUI.Forms.Office.dll)

See Also

Reference

RibbonBarStackItem Members
Gizmox.WebGUI.Forms Namespace


RibbonBarStackItem Class Members

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarStackItem Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarStackItem Class

The following tables list the members exposed by RibbonBarStackItem.

Public Constructors

 | Name | Description
Public Constructor | RibbonBarStackItem Constructor | Initializes a new instance of the RibonBarButtonStack class.
Top

Public Properties

 | Name | Description
Public Property | Container | (Inherited from ComponentBase)
Public Property | Control | Gets the control. (Inherited from RibbonBarItem)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from RibbonBarItem)
Public Property | Items | Overridden.
Public Property | Site | (Inherited from ComponentBase)
Public Property | Tag | Gets/Sets user definied tag (Inherited from RibbonBarItem)
Public Property | Text | Gets or sets the text. (Inherited from RibbonBarItem)
Public Property | ToolTip | Gets or sets the control tooltip. (Inherited from RibbonBarItem)
Public Property | Visible | Gets or sets a value indicating whether this RibbonBarItem is visible. (Inherited from RibbonBarItem)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Top

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded. (Inherited from ComponentBase)
Public Method | ToString | (Inherited from ComponentBase)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControl | Overridden.
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetValidItemTypes | Overridden.
Top

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from ComponentBase)
Top

See Also

Reference

RibbonBarStackItem Class
Gizmox.WebGUI.Forms Namespace


RibbonBarStackItem Constructor

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarStackItem Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBarStackItem Class : RibbonBarStackItem Constructor

Initializes a new instance of the RibonBarButtonStack class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarStackItem()
C#
public RibbonBarStackItem()
Managed Extensions for C++
public: RibbonBarStackItem();
C++/CLI
public:
RibbonBarStackItem();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBarStackItem Class
RibbonBarStackItem Members


RibbonBarStackItem Class Methods

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarStackItem Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarStackItem Class

For a list of all members of this type, see RibbonBarStackItem members.

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded. (Inherited from ComponentBase)
Public Method | ToString | (Inherited from ComponentBase)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControl | Overridden.
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetValidItemTypes | Overridden.
Top

See Also

Reference

RibbonBarStackItem Class
Gizmox.WebGUI.Forms Namespace


CreateControl Method

[image]
Gizmox.WebGUI.Forms.Office
CreateControl Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBarStackItem Class : CreateControl Method

Syntax

Visual Basic (Declaration)
Protected Overrides Function CreateControl() As Control
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarStackItem
Dim value As Control

value = instance.CreateControl()
C#
protected override Control CreateControl()
Managed Extensions for C++
protected: Control* CreateControl(); override
C++/CLI
protected:
Control^ CreateControl(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBarStackItem Class
RibbonBarStackItem Members


GetValidItemTypes Method

[image]
Gizmox.WebGUI.Forms.Office
GetValidItemTypes Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBarStackItem Class : GetValidItemTypes Method

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetValidItemTypes() As Type()
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarStackItem
Dim value() As Type

value = instance.GetValidItemTypes()
C#
protected override Type[] GetValidItemTypes()
Managed Extensions for C++
protected: Type*[]* GetValidItemTypes(); override
C++/CLI
protected:
array<Type^>^ GetValidItemTypes(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBarStackItem Class
RibbonBarStackItem Members


RibbonBarStackItem Class Properties

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarStackItem Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarStackItem Class

For a list of all members of this type, see RibbonBarStackItem members.

Public Properties

 | Name | Description
Public Property | Container | (Inherited from ComponentBase)
Public Property | Control | Gets the control. (Inherited from RibbonBarItem)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from RibbonBarItem)
Public Property | Items | Overridden.
Public Property | Site | (Inherited from ComponentBase)
Public Property | Tag | Gets/Sets user definied tag (Inherited from RibbonBarItem)
Public Property | Text | Gets or sets the text. (Inherited from RibbonBarItem)
Public Property | ToolTip | Gets or sets the control tooltip. (Inherited from RibbonBarItem)
Public Property | Visible | Gets or sets a value indicating whether this RibbonBarItem is visible. (Inherited from RibbonBarItem)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Top

See Also

Reference

RibbonBarStackItem Class
Gizmox.WebGUI.Forms Namespace


Items Property

[image]
Gizmox.WebGUI.Forms.Office
Items Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBarStackItem Class : Items Property

Syntax

Visual Basic (Declaration)
<EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Office.Design.RibonBarStackItemCollectionEditor, Gizmox.WebGUI.Forms.Office.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=d50c2c7452ba77d9")>
Public Overrides ReadOnly Property Items As RibbonBarItemCollection
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarStackItem
Dim value As RibbonBarItemCollection

value = instance.Items
C#
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Office.Design.RibonBarStackItemCollectionEditor, Gizmox.WebGUI.Forms.Office.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=d50c2c7452ba77d9")]
public override RibbonBarItemCollection Items {get;}
Managed Extensions for C++
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Office.Design.RibonBarStackItemCollectionEditor, Gizmox.WebGUI.Forms.Office.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=d50c2c7452ba77d9")]
public: __property RibbonBarItemCollection* get_Items() override;
C++/CLI
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Office.Design.RibonBarStackItemCollectionEditor, Gizmox.WebGUI.Forms.Office.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=d50c2c7452ba77d9")]
public:
property RibbonBarItemCollection^ Items {
   RibbonBarItemCollection^ get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBarStackItem Class
RibbonBarStackItem Members


RibbonBarTextBoxItem Class

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarTextBoxItem Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarTextBoxItem Class

Object Model

Syntax

Visual Basic (Declaration)
Public Class RibbonBarTextBoxItem
   Inherits RibbonBarItem
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarTextBoxItem
C#
public class RibbonBarTextBoxItem : RibbonBarItem
Managed Extensions for C++
public __gc class RibbonBarTextBoxItem : public RibbonBarItem
C++/CLI
public ref class RibbonBarTextBoxItem : public RibbonBarItem

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RibbonBarItem
Gizmox.WebGUI.Forms.RibbonBarTextBoxItem

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms.Office (in Gizmox.WebGUI.Forms.Office.dll)

See Also

Reference

RibbonBarTextBoxItem Members
Gizmox.WebGUI.Forms Namespace


RibbonBarTextBoxItem Class Members

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarTextBoxItem Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarTextBoxItem Class

The following tables list the members exposed by RibbonBarTextBoxItem.

Public Constructors

 | Name | Description
Public Constructor | RibbonBarTextBoxItem Constructor |
Top

Public Properties

 | Name | Description
Public Property | Container | (Inherited from ComponentBase)
Public Property | Control | Gets the control. (Inherited from RibbonBarItem)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from RibbonBarItem)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Tag | Gets/Sets user definied tag (Inherited from RibbonBarItem)
Public Property | Text | Gets or sets the text. (Inherited from RibbonBarItem)
Public Property | ToolTip | Gets or sets the control tooltip. (Inherited from RibbonBarItem)
Public Property | Visible | Gets or sets a value indicating whether this RibbonBarItem is visible. (Inherited from RibbonBarItem)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Top

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded. (Inherited from ComponentBase)
Public Method | ToString | (Inherited from ComponentBase)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControl | Overridden.
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | GetService | (Inherited from ComponentBase)
Top

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from ComponentBase)
Top

See Also

Reference

RibbonBarTextBoxItem Class
Gizmox.WebGUI.Forms Namespace


RibbonBarTextBoxItem Constructor

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarTextBoxItem Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBarTextBoxItem Class : RibbonBarTextBoxItem Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarTextBoxItem()
C#
public RibbonBarTextBoxItem()
Managed Extensions for C++
public: RibbonBarTextBoxItem();
C++/CLI
public:
RibbonBarTextBoxItem();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBarTextBoxItem Class
RibbonBarTextBoxItem Members


RibbonBarTextBoxItem Class Methods

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarTextBoxItem Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarTextBoxItem Class

For a list of all members of this type, see RibbonBarTextBoxItem members.

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded. (Inherited from ComponentBase)
Public Method | ToString | (Inherited from ComponentBase)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControl | Overridden.
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | GetService | (Inherited from ComponentBase)
Top

See Also

Reference

RibbonBarTextBoxItem Class
Gizmox.WebGUI.Forms Namespace


CreateControl Method

[image]
Gizmox.WebGUI.Forms.Office
CreateControl Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBarTextBoxItem Class : CreateControl Method

Syntax

Visual Basic (Declaration)
Protected Overrides Function CreateControl() As Control
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarTextBoxItem
Dim value As Control

value = instance.CreateControl()
C#
protected override Control CreateControl()
Managed Extensions for C++
protected: Control* CreateControl(); override
C++/CLI
protected:
Control^ CreateControl(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBarTextBoxItem Class
RibbonBarTextBoxItem Members


RibbonBarTextBoxItemArgs Class

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarTextBoxItemArgs Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarTextBoxItemArgs Class

Object Model

Syntax

Visual Basic (Declaration)
Public Class RibbonBarTextBoxItemArgs
   Inherits EventArgs
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarTextBoxItemArgs
C#
public class RibbonBarTextBoxItemArgs : EventArgs
Managed Extensions for C++
public __gc class RibbonBarTextBoxItemArgs : public EventArgs
C++/CLI
public ref class RibbonBarTextBoxItemArgs : public EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gizmox.WebGUI.Forms.RibbonBarTextBoxItemArgs

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms.Office (in Gizmox.WebGUI.Forms.Office.dll)

See Also

Reference

RibbonBarTextBoxItemArgs Members
Gizmox.WebGUI.Forms Namespace


RibbonBarTextBoxItemArgs Class Members

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarTextBoxItemArgs Class Members
See Also Properties Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarTextBoxItemArgs Class

The following tables list the members exposed by RibbonBarTextBoxItemArgs.

Public Constructors

 | Name | Description
Public Constructor | RibbonBarTextBoxItemArgs Constructor |
Top

Public Properties

 | Name | Description
Public Property | TextBox |
Top

See Also

Reference

RibbonBarTextBoxItemArgs Class
Gizmox.WebGUI.Forms Namespace


RibbonBarTextBoxItemArgs Constructor

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarTextBoxItemArgs Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBarTextBoxItemArgs Class : RibbonBarTextBoxItemArgs Constructor

objTextBox

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal objTextBox As RibbonBarTextBoxItem _
)
Visual Basic (Usage) Copy Code
Dim objTextBox As RibbonBarTextBoxItem

Dim instance As RibbonBarTextBoxItemArgs(objTextBox)
C#
public RibbonBarTextBoxItemArgs(
   RibbonBarTextBoxItem objTextBox
)
Managed Extensions for C++
public: RibbonBarTextBoxItemArgs(
   RibbonBarTextBoxItem* objTextBox
)
C++/CLI
public:
RibbonBarTextBoxItemArgs(
   RibbonBarTextBoxItem^ objTextBox
)

Parameters

objTextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBarTextBoxItemArgs Class
RibbonBarTextBoxItemArgs Members


RibbonBarTextBoxItemArgs Class Properties

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarTextBoxItemArgs Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarTextBoxItemArgs Class

For a list of all members of this type, see RibbonBarTextBoxItemArgs members.

Public Properties

 | Name | Description
Public Property | TextBox |
Top

See Also

Reference

RibbonBarTextBoxItemArgs Class
Gizmox.WebGUI.Forms Namespace


TextBox Property

[image]
Gizmox.WebGUI.Forms.Office
TextBox Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBarTextBoxItemArgs Class : TextBox Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TextBox As RibbonBarTextBoxItem
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarTextBoxItemArgs
Dim value As RibbonBarTextBoxItem

value = instance.TextBox
C#
public RibbonBarTextBoxItem TextBox {get;}
Managed Extensions for C++
public: __property RibbonBarTextBoxItem* get_TextBox();
C++/CLI
public:
property RibbonBarTextBoxItem^ TextBox {
   RibbonBarTextBoxItem^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBarTextBoxItemArgs Class
RibbonBarTextBoxItemArgs Members


RibbonBarToolBarButtonItem Class

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarToolBarButtonItem Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarToolBarButtonItem Class

Object Model

Syntax

Visual Basic (Declaration)
Public Class RibbonBarToolBarButtonItem
   Inherits RibbonBarButtonItem
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarToolBarButtonItem
C#
public class RibbonBarToolBarButtonItem : RibbonBarButtonItem
Managed Extensions for C++
public __gc class RibbonBarToolBarButtonItem : public RibbonBarButtonItem
C++/CLI
public ref class RibbonBarToolBarButtonItem : public RibbonBarButtonItem

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RibbonBarItem
Gizmox.WebGUI.Forms.RibbonBarButtonItem
Gizmox.WebGUI.Forms.RibbonBarToolBarButtonItem

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms.Office (in Gizmox.WebGUI.Forms.Office.dll)

See Also

Reference

RibbonBarToolBarButtonItem Members
Gizmox.WebGUI.Forms Namespace


RibbonBarToolBarButtonItem Class Members

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarToolBarButtonItem Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarToolBarButtonItem Class

The following tables list the members exposed by RibbonBarToolBarButtonItem.

Public Constructors

 | Name | Description
Public Constructor | RibbonBarToolBarButtonItem Constructor |
Top

Public Properties

 | Name | Description
Public Property | ClientAction | Gets or sets the client action. (Inherited from RibbonBarButtonItem)
Public Property | Container | (Inherited from ComponentBase)
Public Property | Control | Gets the control. (Inherited from RibbonBarItem)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from RibbonBarItem)
Public Property | Image | (Inherited from RibbonBarButtonItem)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Tag | Gets/Sets user definied tag (Inherited from RibbonBarItem)
Public Property | Text | Overridden. Gets or sets the text.
Public Property | ToolTip | Gets or sets the control tooltip. (Inherited from RibbonBarItem)
Public Property | Visible | Gets or sets a value indicating whether this RibbonBarItem is visible. (Inherited from RibbonBarItem)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Top

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded. (Inherited from ComponentBase)
Public Method | ToString | (Inherited from ComponentBase)
Top

Protected Methods

 | Name | Description
Protected Method | CreateButton | Overridden.
Protected Method | CreateControl | Overridden.
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | GetService | (Inherited from ComponentBase)
Top

Public Events

 | Name | Description
Public Event | Click | Occurs when a ribbon bar button has been clicked (Inherited from RibbonBarButtonItem)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from RibbonBarButtonItem)
Top

See Also

Reference

RibbonBarToolBarButtonItem Class
Gizmox.WebGUI.Forms Namespace


RibbonBarToolBarButtonItem Constructor

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarToolBarButtonItem Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBarToolBarButtonItem Class : RibbonBarToolBarButtonItem Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarToolBarButtonItem()
C#
public RibbonBarToolBarButtonItem()
Managed Extensions for C++
public: RibbonBarToolBarButtonItem();
C++/CLI
public:
RibbonBarToolBarButtonItem();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBarToolBarButtonItem Class
RibbonBarToolBarButtonItem Members


RibbonBarToolBarButtonItem Class Methods

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarToolBarButtonItem Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarToolBarButtonItem Class

For a list of all members of this type, see RibbonBarToolBarButtonItem members.

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded. (Inherited from ComponentBase)
Public Method | ToString | (Inherited from ComponentBase)
Top

Protected Methods

 | Name | Description
Protected Method | CreateButton | Overridden.
Protected Method | CreateControl | Overridden.
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | GetService | (Inherited from ComponentBase)
Top

See Also

Reference

RibbonBarToolBarButtonItem Class
Gizmox.WebGUI.Forms Namespace


CreateButton Method

[image]
Gizmox.WebGUI.Forms.Office
CreateButton Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBarToolBarButtonItem Class : CreateButton Method

Syntax

Visual Basic (Declaration)
Protected Overrides Function CreateButton() As Button
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarToolBarButtonItem
Dim value As Button

value = instance.CreateButton()
C#
protected override Button CreateButton()
Managed Extensions for C++
protected: Button* CreateButton(); override
C++/CLI
protected:
Button^ CreateButton(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBarToolBarButtonItem Class
RibbonBarToolBarButtonItem Members


CreateControl Method

[image]
Gizmox.WebGUI.Forms.Office
CreateControl Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBarToolBarButtonItem Class : CreateControl Method

Syntax

Visual Basic (Declaration)
Protected Overrides Function CreateControl() As Control
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarToolBarButtonItem
Dim value As Control

value = instance.CreateControl()
C#
protected override Control CreateControl()
Managed Extensions for C++
protected: Control* CreateControl(); override
C++/CLI
protected:
Control^ CreateControl(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBarToolBarButtonItem Class
RibbonBarToolBarButtonItem Members


RibbonBarToolBarButtonItem Class Properties

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarToolBarButtonItem Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarToolBarButtonItem Class

For a list of all members of this type, see RibbonBarToolBarButtonItem members.

Public Properties

 | Name | Description
Public Property | ClientAction | Gets or sets the client action. (Inherited from RibbonBarButtonItem)
Public Property | Container | (Inherited from ComponentBase)
Public Property | Control | Gets the control. (Inherited from RibbonBarItem)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from RibbonBarItem)
Public Property | Image | (Inherited from RibbonBarButtonItem)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Tag | Gets/Sets user definied tag (Inherited from RibbonBarItem)
Public Property | Text | Overridden. Gets or sets the text.
Public Property | ToolTip | Gets or sets the control tooltip. (Inherited from RibbonBarItem)
Public Property | Visible | Gets or sets a value indicating whether this RibbonBarItem is visible. (Inherited from RibbonBarItem)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Top

See Also

Reference

RibbonBarToolBarButtonItem Class
Gizmox.WebGUI.Forms Namespace


Text Property

[image]
Gizmox.WebGUI.Forms.Office
Text Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBarToolBarButtonItem Class : Text Property

Gets or sets the text.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public Overrides Property Text As String
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarToolBarButtonItem
Dim value As String

instance.Text = value

value = instance.Text
C#
[BrowsableAttribute(false)]
public override string Text {get; set;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property string* get_Text() override;
public: __property void set_Text(
   string* value
) override;
C++/CLI
[BrowsableAttribute(false)]
public:
property String^ Text {
   String^ get() override;
   void set (String^value) override;
}

Return Value

The text.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBarToolBarButtonItem Class
RibbonBarToolBarButtonItem Members


RibbonBarToolBarDropDownButtonItem Class

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarToolBarDropDownButtonItem Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarToolBarDropDownButtonItem Class

Object Model

Syntax

Visual Basic (Declaration)
Public Class RibbonBarToolBarDropDownButtonItem
   Inherits RibbonBarDropDownButtonItem
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarToolBarDropDownButtonItem
C#
public class RibbonBarToolBarDropDownButtonItem : RibbonBarDropDownButtonItem
Managed Extensions for C++
public __gc class RibbonBarToolBarDropDownButtonItem : public RibbonBarDropDownButtonItem
C++/CLI
public ref class RibbonBarToolBarDropDownButtonItem : public RibbonBarDropDownButtonItem

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RibbonBarItem
Gizmox.WebGUI.Forms.RibbonBarButtonItem
Gizmox.WebGUI.Forms.RibbonBarDropDownButtonItem
Gizmox.WebGUI.Forms.RibbonBarToolBarDropDownButtonItem

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms.Office (in Gizmox.WebGUI.Forms.Office.dll)

See Also

Reference

RibbonBarToolBarDropDownButtonItem Members
Gizmox.WebGUI.Forms Namespace


RibbonBarToolBarDropDownButtonItem Class Members

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarToolBarDropDownButtonItem Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarToolBarDropDownButtonItem Class

The following tables list the members exposed by RibbonBarToolBarDropDownButtonItem.

Public Constructors

 | Name | Description
Public Constructor | RibbonBarToolBarDropDownButtonItem Constructor |
Top

Public Properties

 | Name | Description
Public Property | ClientAction | Gets or sets the client action. (Inherited from RibbonBarButtonItem)
Public Property | Container | (Inherited from ComponentBase)
Public Property | Control | Gets the control. (Inherited from RibbonBarItem)
Public Property | DropDownMenu | Gets or sets the context menu code. (Inherited from RibbonBarDropDownButtonItem)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from RibbonBarItem)
Public Property | Image | (Inherited from RibbonBarButtonItem)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Tag | Gets/Sets user definied tag (Inherited from RibbonBarItem)
Public Property | Text | Overridden. Gets or sets the text.
Public Property | ToolTip | Gets or sets the control tooltip. (Inherited from RibbonBarItem)
Public Property | Visible | Gets or sets a value indicating whether this RibbonBarItem is visible. (Inherited from RibbonBarItem)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Top

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded. (Inherited from ComponentBase)
Public Method | ToString | (Inherited from ComponentBase)
Top

Protected Methods

 | Name | Description
Protected Method | CreateButton | Overridden.
Protected Method | CreateControl | Overridden.
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | OnButtonMenuClick | (Inherited from RibbonBarDropDownButtonItem)
Top

Public Events

 | Name | Description
Public Event | Click | Occurs when a ribbon bar button has been clicked (Inherited from RibbonBarButtonItem)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from RibbonBarButtonItem)
Top

See Also

Reference

RibbonBarToolBarDropDownButtonItem Class
Gizmox.WebGUI.Forms Namespace


RibbonBarToolBarDropDownButtonItem Constructor

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarToolBarDropDownButtonItem Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBarToolBarDropDownButtonItem Class : RibbonBarToolBarDropDownButtonItem Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarToolBarDropDownButtonItem()
C#
public RibbonBarToolBarDropDownButtonItem()
Managed Extensions for C++
public: RibbonBarToolBarDropDownButtonItem();
C++/CLI
public:
RibbonBarToolBarDropDownButtonItem();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBarToolBarDropDownButtonItem Class
RibbonBarToolBarDropDownButtonItem Members


RibbonBarToolBarDropDownButtonItem Class Methods

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarToolBarDropDownButtonItem Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarToolBarDropDownButtonItem Class

For a list of all members of this type, see RibbonBarToolBarDropDownButtonItem members.

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded. (Inherited from ComponentBase)
Public Method | ToString | (Inherited from ComponentBase)
Top

Protected Methods

 | Name | Description
Protected Method | CreateButton | Overridden.
Protected Method | CreateControl | Overridden.
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | OnButtonMenuClick | (Inherited from RibbonBarDropDownButtonItem)
Top

See Also

Reference

RibbonBarToolBarDropDownButtonItem Class
Gizmox.WebGUI.Forms Namespace


CreateButton Method

[image]
Gizmox.WebGUI.Forms.Office
CreateButton Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBarToolBarDropDownButtonItem Class : CreateButton Method

Syntax

Visual Basic (Declaration)
Protected Overrides Function CreateButton() As Button
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarToolBarDropDownButtonItem
Dim value As Button

value = instance.CreateButton()
C#
protected override Button CreateButton()
Managed Extensions for C++
protected: Button* CreateButton(); override
C++/CLI
protected:
Button^ CreateButton(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBarToolBarDropDownButtonItem Class
RibbonBarToolBarDropDownButtonItem Members


CreateControl Method

[image]
Gizmox.WebGUI.Forms.Office
CreateControl Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBarToolBarDropDownButtonItem Class : CreateControl Method

Syntax

Visual Basic (Declaration)
Protected Overrides Function CreateControl() As Control
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarToolBarDropDownButtonItem
Dim value As Control

value = instance.CreateControl()
C#
protected override Control CreateControl()
Managed Extensions for C++
protected: Control* CreateControl(); override
C++/CLI
protected:
Control^ CreateControl(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBarToolBarDropDownButtonItem Class
RibbonBarToolBarDropDownButtonItem Members


RibbonBarToolBarDropDownButtonItem Class Properties

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarToolBarDropDownButtonItem Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarToolBarDropDownButtonItem Class

For a list of all members of this type, see RibbonBarToolBarDropDownButtonItem members.

Public Properties

 | Name | Description
Public Property | ClientAction | Gets or sets the client action. (Inherited from RibbonBarButtonItem)
Public Property | Container | (Inherited from ComponentBase)
Public Property | Control | Gets the control. (Inherited from RibbonBarItem)
Public Property | DropDownMenu | Gets or sets the context menu code. (Inherited from RibbonBarDropDownButtonItem)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from RibbonBarItem)
Public Property | Image | (Inherited from RibbonBarButtonItem)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Tag | Gets/Sets user definied tag (Inherited from RibbonBarItem)
Public Property | Text | Overridden. Gets or sets the text.
Public Property | ToolTip | Gets or sets the control tooltip. (Inherited from RibbonBarItem)
Public Property | Visible | Gets or sets a value indicating whether this RibbonBarItem is visible. (Inherited from RibbonBarItem)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Top

See Also

Reference

RibbonBarToolBarDropDownButtonItem Class
Gizmox.WebGUI.Forms Namespace


Text Property

[image]
Gizmox.WebGUI.Forms.Office
Text Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBarToolBarDropDownButtonItem Class : Text Property

Gets or sets the text.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
Public Overrides Property Text As String
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarToolBarDropDownButtonItem
Dim value As String

instance.Text = value

value = instance.Text
C#
[BrowsableAttribute(false)]
public override string Text {get; set;}
Managed Extensions for C++
[BrowsableAttribute(false)]
public: __property string* get_Text() override;
public: __property void set_Text(
   string* value
) override;
C++/CLI
[BrowsableAttribute(false)]
public:
property String^ Text {
   String^ get() override;
   void set (String^value) override;
}

Return Value

The text.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBarToolBarDropDownButtonItem Class
RibbonBarToolBarDropDownButtonItem Members


RibbonBarToolBarItem Class

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarToolBarItem Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarToolBarItem Class

Object Model

Syntax

Visual Basic (Declaration)
Public Class RibbonBarToolBarItem
   Inherits RibbonBarItemContainer
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarToolBarItem
C#
public class RibbonBarToolBarItem : RibbonBarItemContainer
Managed Extensions for C++
public __gc class RibbonBarToolBarItem : public RibbonBarItemContainer
C++/CLI
public ref class RibbonBarToolBarItem : public RibbonBarItemContainer

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RibbonBarItem
Gizmox.WebGUI.Forms.RibbonBarItemContainer
Gizmox.WebGUI.Forms.RibbonBarToolBarItem

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms.Office (in Gizmox.WebGUI.Forms.Office.dll)

See Also

Reference

RibbonBarToolBarItem Members
Gizmox.WebGUI.Forms Namespace


RibbonBarToolBarItem Class Members

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarToolBarItem Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarToolBarItem Class

The following tables list the members exposed by RibbonBarToolBarItem.

Public Constructors

 | Name | Description
Public Constructor | RibbonBarToolBarItem Constructor | Initializes a new instance of the RibbonBarToolBarItem class.
Top

Public Properties

 | Name | Description
Public Property | Container | (Inherited from ComponentBase)
Public Property | Control | Gets the control. (Inherited from RibbonBarItem)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from RibbonBarItem)
Public Property | Items | Overridden.
Public Property | Site | (Inherited from ComponentBase)
Public Property | Tag | Gets/Sets user definied tag (Inherited from RibbonBarItem)
Public Property | Text | Gets or sets the text. (Inherited from RibbonBarItem)
Public Property | ToolTip | Gets or sets the control tooltip. (Inherited from RibbonBarItem)
Public Property | Visible | Gets or sets a value indicating whether this RibbonBarItem is visible. (Inherited from RibbonBarItem)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Top

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded. (Inherited from ComponentBase)
Public Method | ToString | (Inherited from ComponentBase)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControl | Overridden.
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetValidItemTypes | Overridden.
Top

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from ComponentBase)
Top

See Also

Reference

RibbonBarToolBarItem Class
Gizmox.WebGUI.Forms Namespace


RibbonBarToolBarItem Constructor

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarToolBarItem Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBarToolBarItem Class : RibbonBarToolBarItem Constructor

Initializes a new instance of the RibbonBarToolBarItem class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarToolBarItem()
C#
public RibbonBarToolBarItem()
Managed Extensions for C++
public: RibbonBarToolBarItem();
C++/CLI
public:
RibbonBarToolBarItem();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBarToolBarItem Class
RibbonBarToolBarItem Members


RibbonBarToolBarItem Class Methods

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarToolBarItem Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarToolBarItem Class

For a list of all members of this type, see RibbonBarToolBarItem members.

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded. (Inherited from ComponentBase)
Public Method | ToString | (Inherited from ComponentBase)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControl | Overridden.
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetValidItemTypes | Overridden.
Top

See Also

Reference

RibbonBarToolBarItem Class
Gizmox.WebGUI.Forms Namespace


CreateControl Method

[image]
Gizmox.WebGUI.Forms.Office
CreateControl Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBarToolBarItem Class : CreateControl Method

Syntax

Visual Basic (Declaration)
Protected Overrides Function CreateControl() As Control
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarToolBarItem
Dim value As Control

value = instance.CreateControl()
C#
protected override Control CreateControl()
Managed Extensions for C++
protected: Control* CreateControl(); override
C++/CLI
protected:
Control^ CreateControl(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBarToolBarItem Class
RibbonBarToolBarItem Members


GetValidItemTypes Method

[image]
Gizmox.WebGUI.Forms.Office
GetValidItemTypes Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBarToolBarItem Class : GetValidItemTypes Method

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetValidItemTypes() As Type()
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarToolBarItem
Dim value() As Type

value = instance.GetValidItemTypes()
C#
protected override Type[] GetValidItemTypes()
Managed Extensions for C++
protected: Type*[]* GetValidItemTypes(); override
C++/CLI
protected:
array<Type^>^ GetValidItemTypes(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBarToolBarItem Class
RibbonBarToolBarItem Members


RibbonBarToolBarItem Class Properties

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarToolBarItem Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarToolBarItem Class

For a list of all members of this type, see RibbonBarToolBarItem members.

Public Properties

 | Name | Description
Public Property | Container | (Inherited from ComponentBase)
Public Property | Control | Gets the control. (Inherited from RibbonBarItem)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from RibbonBarItem)
Public Property | Items | Overridden.
Public Property | Site | (Inherited from ComponentBase)
Public Property | Tag | Gets/Sets user definied tag (Inherited from RibbonBarItem)
Public Property | Text | Gets or sets the text. (Inherited from RibbonBarItem)
Public Property | ToolTip | Gets or sets the control tooltip. (Inherited from RibbonBarItem)
Public Property | Visible | Gets or sets a value indicating whether this RibbonBarItem is visible. (Inherited from RibbonBarItem)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Top

See Also

Reference

RibbonBarToolBarItem Class
Gizmox.WebGUI.Forms Namespace


Items Property

[image]
Gizmox.WebGUI.Forms.Office
Items Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RibbonBarToolBarItem Class : Items Property

Syntax

Visual Basic (Declaration)
<EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Office.Design.RibonBarToolBarItemCollectionEditor, Gizmox.WebGUI.Forms.Office.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=d50c2c7452ba77d9")>
Public Overrides ReadOnly Property Items As RibbonBarItemCollection
Visual Basic (Usage) Copy Code
Dim instance As RibbonBarToolBarItem
Dim value As RibbonBarItemCollection

value = instance.Items
C#
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Office.Design.RibonBarToolBarItemCollectionEditor, Gizmox.WebGUI.Forms.Office.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=d50c2c7452ba77d9")]
public override RibbonBarItemCollection Items {get;}
Managed Extensions for C++
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Office.Design.RibonBarToolBarItemCollectionEditor, Gizmox.WebGUI.Forms.Office.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=d50c2c7452ba77d9")]
public: __property RibbonBarItemCollection* get_Items() override;
C++/CLI
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Gizmox.WebGUI.Forms.Office.Design.RibonBarToolBarItemCollectionEditor, Gizmox.WebGUI.Forms.Office.Design, Version=3.0.5701.0, Culture=neutral, PublicKeyToken=d50c2c7452ba77d9")]
public:
property RibbonBarItemCollection^ Items {
   RibbonBarItemCollection^ get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RibbonBarToolBarItem Class
RibbonBarToolBarItem Members


RichTextEditor Class

[image]
Gizmox.WebGUI.Forms.Office
RichTextEditor Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RichTextEditor Class

Summary description for RichTextEditor

Object Model

Syntax

Visual Basic (Declaration)
<MetadataTagAttribute("RTE")>
<WebCompilerPagesAttribute(Assembly=,
   Namespace="Gizmox.WebGUI.Forms.Office",
   Resoruces=System.String[])>
<ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableRichTextEditor,  Gizmox.WebGUI.Silverlight.Controls.Office, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")>
<WebCompilerResourcesAttribute(Assembly=, Namespace="Gizmox.WebGUI.Forms.Office")>
Public Class RichTextEditor
   Inherits Control
   Implements IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IRequiredRegistration, IBindableComponent, ISupportsRibbonBar, IArrangedElement
Visual Basic (Usage) Copy Code
Dim instance As RichTextEditor
C#
[MetadataTagAttribute("RTE")]
[WebCompilerPagesAttribute(Assembly=,
   Namespace="Gizmox.WebGUI.Forms.Office",
   Resoruces=System.String[])]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableRichTextEditor,  Gizmox.WebGUI.Silverlight.Controls.Office, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[WebCompilerResourcesAttribute(Assembly=, Namespace="Gizmox.WebGUI.Forms.Office")]
public class RichTextEditor : Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IRequiredRegistration, IBindableComponent, ISupportsRibbonBar, IArrangedElement
Managed Extensions for C++
[MetadataTagAttribute("RTE")]
[WebCompilerPagesAttribute(Assembly=,
   Namespace="Gizmox.WebGUI.Forms.Office",
   Resoruces=System.String[])]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableRichTextEditor,  Gizmox.WebGUI.Silverlight.Controls.Office, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[WebCompilerResourcesAttribute(Assembly=, Namespace="Gizmox.WebGUI.Forms.Office")]
public __gc class RichTextEditor : public Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IRequiredRegistration, IBindableComponent, ISupportsRibbonBar, IArrangedElement
C++/CLI
[MetadataTagAttribute("RTE")]
[WebCompilerPagesAttribute(Assembly=,
   Namespace="Gizmox.WebGUI.Forms.Office",
   Resoruces=System.String[])]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableRichTextEditor,  Gizmox.WebGUI.Silverlight.Controls.Office, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[WebCompilerResourcesAttribute(Assembly=, Namespace="Gizmox.WebGUI.Forms.Office")]
public ref class RichTextEditor : public Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IRequiredRegistration, IBindableComponent, ISupportsRibbonBar, IArrangedElement

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.RichTextEditor

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms.Office (in Gizmox.WebGUI.Forms.Office.dll)

See Also

Reference

RichTextEditor Members
Gizmox.WebGUI.Forms Namespace


RichTextEditor Class Members

[image]
Gizmox.WebGUI.Forms.Office
RichTextEditor Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : RichTextEditor Class

The following tables list the members exposed by RichTextEditor.

Public Constructors

 | Name | Description
Public Constructor | RichTextEditor Constructor |
Top

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | ReadOnly | Gets or sets a value indicating whether [read only].
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Control)
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | Value | Gets or sets the HTML value of the control.
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Overridden. Fires an event.
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Overridden.
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from Control)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Control)
Protected Method | RenderAttributes | Overridden.
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | ValueChanged |
Public Event | ValueChangedQueued |
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

RichTextEditor Class
Gizmox.WebGUI.Forms Namespace


RichTextEditor Constructor

[image]
Gizmox.WebGUI.Forms.Office
RichTextEditor Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RichTextEditor Class : RichTextEditor Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As RichTextEditor()
C#
public RichTextEditor()
Managed Extensions for C++
public: RichTextEditor();
C++/CLI
public:
RichTextEditor();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RichTextEditor Class
RichTextEditor Members


RichTextEditor Class Methods

[image]
Gizmox.WebGUI.Forms.Office
RichTextEditor Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RichTextEditor Class

For a list of all members of this type, see RichTextEditor members.

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Overridden. Fires an event.
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Overridden.
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from Control)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Control)
Protected Method | RenderAttributes | Overridden.
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

See Also

Reference

RichTextEditor Class
Gizmox.WebGUI.Forms Namespace


FireEvent Method

[image]
Gizmox.WebGUI.Forms.Office
FireEvent Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RichTextEditor Class : FireEvent Method

objEvent
event.
Fires an event.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub FireEvent( _
   ByVal objEvent As IEvent _
)
Visual Basic (Usage) Copy Code
Dim instance As RichTextEditor
Dim objEvent As IEvent

instance.FireEvent(objEvent)
C#
protected override void FireEvent(
   IEvent objEvent
)
Managed Extensions for C++
protected: void FireEvent(
   IEvent* objEvent
) override
C++/CLI
protected:
void FireEvent(
   IEvent^ objEvent
) override

Parameters

objEvent
event.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RichTextEditor Class
RichTextEditor Members


GetCriticalEvents Method

[image]
Gizmox.WebGUI.Forms.Office
GetCriticalEvents Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RichTextEditor Class : GetCriticalEvents Method

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetCriticalEvents() As EventTypes
Visual Basic (Usage) Copy Code
Dim instance As RichTextEditor
Dim value As EventTypes

value = instance.GetCriticalEvents()
C#
protected override EventTypes GetCriticalEvents()
Managed Extensions for C++
protected: EventTypes GetCriticalEvents(); override
C++/CLI
protected:
EventTypes GetCriticalEvents(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RichTextEditor Class
RichTextEditor Members


RenderAttributes Method

[image]
Gizmox.WebGUI.Forms.Office
RenderAttributes Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RichTextEditor Class : RenderAttributes Method

context
writer

Syntax

Visual Basic (Declaration)
Protected Overrides Sub RenderAttributes( _
   ByVal context As IContext, _
   ByVal writer As IAttributeWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As RichTextEditor
Dim context As IContext
Dim writer As IAttributeWriter

instance.RenderAttributes(context, writer)
C#
protected override void RenderAttributes(
   IContext context,
   IAttributeWriter writer
)
Managed Extensions for C++
protected: void RenderAttributes(
   IContext* context,
   IAttributeWriter* writer
) override
C++/CLI
protected:
void RenderAttributes(
   IContext^ context,
   IAttributeWriter^ writer
) override

Parameters

context
writer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RichTextEditor Class
RichTextEditor Members


RichTextEditor Class Properties

[image]
Gizmox.WebGUI.Forms.Office
RichTextEditor Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RichTextEditor Class

For a list of all members of this type, see RichTextEditor members.

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | ReadOnly | Gets or sets a value indicating whether [read only].
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Control)
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | Value | Gets or sets the HTML value of the control.
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

See Also

Reference

RichTextEditor Class
Gizmox.WebGUI.Forms Namespace


ReadOnly Property

[image]
Gizmox.WebGUI.Forms.Office
ReadOnly Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RichTextEditor Class : ReadOnly Property

Gets or sets a value indicating whether [read only].

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property ReadOnly As Boolean
Visual Basic (Usage) Copy Code
Dim instance As RichTextEditor
Dim value As Boolean

instance.ReadOnly = value

value = instance.ReadOnly
C#
[DefaultValueAttribute()]
public bool ReadOnly {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property bool get_ReadOnly();
public: __property void set_ReadOnly(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
public:
property bool ReadOnly {
   bool get();
   void set (boolvalue);
}

Return Value

true if [read only]; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RichTextEditor Class
RichTextEditor Members


Value Property

[image]
Gizmox.WebGUI.Forms.Office
Value Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RichTextEditor Class : Value Property

Gets or sets the HTML value of the control.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property Value As String
Visual Basic (Usage) Copy Code
Dim instance As RichTextEditor
Dim value As String

instance.Value = value

value = instance.Value
C#
[DefaultValueAttribute()]
public string Value {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property string* get_Value();
public: __property void set_Value(
   string* value
);
C++/CLI
[DefaultValueAttribute()]
public:
property String^ Value {
   String^ get();
   void set (String^value);
}

Return Value

The value HTML value of the control.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RichTextEditor Class
RichTextEditor Members


RichTextEditor Class Events

[image]
Gizmox.WebGUI.Forms.Office
RichTextEditor Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RichTextEditor Class

For a list of all members of this type, see RichTextEditor members.

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | ValueChanged |
Public Event | ValueChangedQueued |
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

RichTextEditor Class
Gizmox.WebGUI.Forms Namespace


ValueChanged Event

[image]
Gizmox.WebGUI.Forms.Office
ValueChanged Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RichTextEditor Class : ValueChanged Event

Syntax

Visual Basic (Declaration)
Public Event ValueChanged() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As RichTextEditor
Dim handler As EventHandler

AddHandler instance.ValueChanged, handler
C#
public event EventHandler ValueChanged()
Managed Extensions for C++
public: __event EventHandler* ValueChanged
C++/CLI
public:
event EventHandler^ ValueChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RichTextEditor Class
RichTextEditor Members


ValueChangedQueued Event

[image]
Gizmox.WebGUI.Forms.Office
ValueChangedQueued Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > RichTextEditor Class : ValueChangedQueued Event

Syntax

Visual Basic (Declaration)
Public Event ValueChangedQueued() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As RichTextEditor
Dim handler As EventHandler

AddHandler instance.ValueChangedQueued, handler
C#
public event EventHandler ValueChangedQueued()
Managed Extensions for C++
public: __event EventHandler* ValueChangedQueued
C++/CLI
public:
event EventHandler^ ValueChangedQueued

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

RichTextEditor Class
RichTextEditor Members


ScheduleBox Class

[image]
Gizmox.WebGUI.Forms.Office
ScheduleBox Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ScheduleBox Class

Represents a WebGUI schedule box control.

Object Model

Syntax

Visual Basic (Declaration)
<WebCompilerResourcesAttribute(Assembly=, Namespace="Gizmox.WebGUI.Forms.Office")>
<MetadataTagAttribute("SCB")>
<ToolboxItemCategoryAttribute("Common Controls")>
<ToolboxBitmapAttribute()>
<ClientControllerAttribute()>
<SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableScheduleBox,  Gizmox.WebGUI.Silverlight.Controls.Office, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")>
<ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<DesignTimeControllerAttribute()>
Public Class ScheduleBox
   Inherits Control
   Implements IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IRequiredRegistration, IBindableComponent, IArrangedElement
Visual Basic (Usage) Copy Code
Dim instance As ScheduleBox
C#
[WebCompilerResourcesAttribute(Assembly=, Namespace="Gizmox.WebGUI.Forms.Office")]
[MetadataTagAttribute("SCB")]
[ToolboxItemCategoryAttribute("Common Controls")]
[ToolboxBitmapAttribute()]
[ClientControllerAttribute()]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableScheduleBox,  Gizmox.WebGUI.Silverlight.Controls.Office, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[DesignTimeControllerAttribute()]
public class ScheduleBox : Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IRequiredRegistration, IBindableComponent, IArrangedElement
Managed Extensions for C++
[WebCompilerResourcesAttribute(Assembly=, Namespace="Gizmox.WebGUI.Forms.Office")]
[MetadataTagAttribute("SCB")]
[ToolboxItemCategoryAttribute("Common Controls")]
[ToolboxBitmapAttribute()]
[ClientControllerAttribute()]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableScheduleBox,  Gizmox.WebGUI.Silverlight.Controls.Office, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[DesignTimeControllerAttribute()]
public __gc class ScheduleBox : public Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IRequiredRegistration, IBindableComponent, IArrangedElement
C++/CLI
[WebCompilerResourcesAttribute(Assembly=, Namespace="Gizmox.WebGUI.Forms.Office")]
[MetadataTagAttribute("SCB")]
[ToolboxItemCategoryAttribute("Common Controls")]
[ToolboxBitmapAttribute()]
[ClientControllerAttribute()]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableScheduleBox,  Gizmox.WebGUI.Silverlight.Controls.Office, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[DesignTimeControllerAttribute()]
public ref class ScheduleBox : public Control, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IRequiredRegistration, IBindableComponent, IArrangedElement

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.ScheduleBox

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms.Office (in Gizmox.WebGUI.Forms.Office.dll)

See Also

Reference

ScheduleBox Members
Gizmox.WebGUI.Forms Namespace


ScheduleBox Class Members

[image]
Gizmox.WebGUI.Forms.Office
ScheduleBox Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : ScheduleBox Class

The following tables list the members exposed by ScheduleBox.

Public Constructors

 | Name | Description
Public Constructor | ScheduleBox Constructor | Creates a new ScheduleBox instance.
Top

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | DisplayMonthHeader | Get or set if the month header will be displayed
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Events | Gets a collection of current registered events
Public Property | FirstDate | Set or get the first date to display in view
Public Property | FirstDayOfWeek | Gets or sets the first day of the week as displayed in the month calendar.
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | HourFormat | Get or set the current schedule box hour format
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Control)
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | View | Get or set the current schedule box view
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Public Property | WorkEndHour | Get or set the work end hour
Public Property | WorkStartHour | Get or set the work start hour
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | Overridden. Defined delayed drawing component
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | CreateEventsCollectionInstance | Returns a new events collection instance
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Overridden. Fires an event.
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from Control)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnEventDoubleClick |
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | Overridden. Renders the current control.
Protected Method | RenderAttributes | Renders the controls meta attributes (Inherited from Control)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | EventDoubleClick | Occurs when the user double clicks an event
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

ScheduleBox Class
Gizmox.WebGUI.Forms Namespace


ScheduleBox Constructor

[image]
Gizmox.WebGUI.Forms.Office
ScheduleBox Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ScheduleBox Class : ScheduleBox Constructor

Creates a new ScheduleBox instance.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ScheduleBox()
C#
public ScheduleBox()
Managed Extensions for C++
public: ScheduleBox();
C++/CLI
public:
ScheduleBox();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ScheduleBox Class
ScheduleBox Members


ScheduleBox Class Methods

[image]
Gizmox.WebGUI.Forms.Office
ScheduleBox Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ScheduleBox Class

For a list of all members of this type, see ScheduleBox members.

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | CreateEventsCollectionInstance | Returns a new events collection instance
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Overridden. Fires an event.
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from Control)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnEventDoubleClick |
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | Overridden. Renders the current control.
Protected Method | RenderAttributes | Renders the controls meta attributes (Inherited from Control)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

See Also

Reference

ScheduleBox Class
Gizmox.WebGUI.Forms Namespace


CreateEventsCollectionInstance Method

[image]
Gizmox.WebGUI.Forms.Office
CreateEventsCollectionInstance Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ScheduleBox Class : CreateEventsCollectionInstance Method

Returns a new events collection instance

Syntax

Visual Basic (Declaration)
Protected Overridable Function CreateEventsCollectionInstance() As ScheduleBoxEventCollection
Visual Basic (Usage) Copy Code
Dim instance As ScheduleBox
Dim value As ScheduleBoxEventCollection

value = instance.CreateEventsCollectionInstance()
C#
protected virtual ScheduleBoxEventCollection CreateEventsCollectionInstance()
Managed Extensions for C++
protected: virtual ScheduleBoxEventCollection* CreateEventsCollectionInstance();
C++/CLI
protected:
virtual ScheduleBoxEventCollection^ CreateEventsCollectionInstance();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ScheduleBox Class
ScheduleBox Members


FireEvent Method

[image]
Gizmox.WebGUI.Forms.Office
FireEvent Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ScheduleBox Class : FireEvent Method

objEvent
event.
Fires an event.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub FireEvent( _
   ByVal objEvent As IEvent _
)
Visual Basic (Usage) Copy Code
Dim instance As ScheduleBox
Dim objEvent As IEvent

instance.FireEvent(objEvent)
C#
protected override void FireEvent(
   IEvent objEvent
)
Managed Extensions for C++
protected: void FireEvent(
   IEvent* objEvent
) override
C++/CLI
protected:
void FireEvent(
   IEvent^ objEvent
) override

Parameters

objEvent
event.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ScheduleBox Class
ScheduleBox Members


OnEventDoubleClick Method

[image]
Gizmox.WebGUI.Forms.Office
OnEventDoubleClick Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ScheduleBox Class : OnEventDoubleClick Method

objScheduleBoxEventArgs

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnEventDoubleClick( _
   ByVal objScheduleBoxEventArgs As ScheduleBox.ScheduleBoxEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ScheduleBox
Dim objScheduleBoxEventArgs As ScheduleBox.ScheduleBoxEventArgs

instance.OnEventDoubleClick(objScheduleBoxEventArgs)
C#
protected virtual void OnEventDoubleClick(
   ScheduleBox.ScheduleBoxEventArgs objScheduleBoxEventArgs
)
Managed Extensions for C++
protected: virtual void OnEventDoubleClick(
   ScheduleBox.ScheduleBoxEventArgs* objScheduleBoxEventArgs
)
C++/CLI
protected:
virtual void OnEventDoubleClick(
   ScheduleBox::ScheduleBoxEventArgs^ objScheduleBoxEventArgs
)

Parameters

objScheduleBoxEventArgs

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ScheduleBox Class
ScheduleBox Members


Render Method

[image]
Gizmox.WebGUI.Forms.Office
Render Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ScheduleBox Class : Render Method

objContext
Request context.
objWriter
lngRequestID
Renders the current control.

Syntax

Visual Basic (Declaration)
Protected Overrides Sub Render( _
   ByVal objContext As IContext, _
   ByVal objWriter As IResponseWriter, _
   ByVal lngRequestID As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As ScheduleBox
Dim objContext As IContext
Dim objWriter As IResponseWriter
Dim lngRequestID As Long

instance.Render(objContext, objWriter, lngRequestID)
C#
protected override void Render(
   IContext objContext,
   IResponseWriter objWriter,
   long lngRequestID
)
Managed Extensions for C++
protected: void Render(
   IContext* objContext,
   IResponseWriter* objWriter,
   long lngRequestID
) override
C++/CLI
protected:
void Render(
   IContext^ objContext,
   IResponseWriter^ objWriter,
   long long lngRequestID
) override

Parameters

objContext
Request context.
objWriter
lngRequestID

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ScheduleBox Class
ScheduleBox Members


ScheduleBox Class Properties

[image]
Gizmox.WebGUI.Forms.Office
ScheduleBox Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ScheduleBox Class

For a list of all members of this type, see ScheduleBox members.

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | DisplayMonthHeader | Get or set if the month header will be displayed
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Events | Gets a collection of current registered events
Public Property | FirstDate | Set or get the first date to display in view
Public Property | FirstDayOfWeek | Gets or sets the first day of the week as displayed in the month calendar.
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | HourFormat | Get or set the current schedule box hour format
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Control)
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | View | Get or set the current schedule box view
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Public Property | WorkEndHour | Get or set the work end hour
Public Property | WorkStartHour | Get or set the work start hour
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | Overridden. Defined delayed drawing component
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

See Also

Reference

ScheduleBox Class
Gizmox.WebGUI.Forms Namespace


DisplayMonthHeader Property

[image]
Gizmox.WebGUI.Forms.Office
DisplayMonthHeader Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ScheduleBox Class : DisplayMonthHeader Property

Get or set if the month header will be displayed

Syntax

Visual Basic (Declaration)
Public Property DisplayMonthHeader As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ScheduleBox
Dim value As Boolean

instance.DisplayMonthHeader = value

value = instance.DisplayMonthHeader
C#
public bool DisplayMonthHeader {get; set;}
Managed Extensions for C++
public: __property bool get_DisplayMonthHeader();
public: __property void set_DisplayMonthHeader(
   bool value
);
C++/CLI
public:
property bool DisplayMonthHeader {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ScheduleBox Class
ScheduleBox Members


Events Property

[image]
Gizmox.WebGUI.Forms.Office
Events Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ScheduleBox Class : Events Property

Gets a collection of current registered events

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Events As ScheduleBoxEventCollection
Visual Basic (Usage) Copy Code
Dim instance As ScheduleBox
Dim value As ScheduleBoxEventCollection

value = instance.Events
C#
public ScheduleBoxEventCollection Events {get;}
Managed Extensions for C++
public: __property ScheduleBoxEventCollection* get_Events();
C++/CLI
public:
property ScheduleBoxEventCollection^ Events {
   ScheduleBoxEventCollection^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ScheduleBox Class
ScheduleBox Members


FirstDate Property

[image]
Gizmox.WebGUI.Forms.Office
FirstDate Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ScheduleBox Class : FirstDate Property

Set or get the first date to display in view

Syntax

Visual Basic (Declaration)
Public Property FirstDate As Date
Visual Basic (Usage) Copy Code
Dim instance As ScheduleBox
Dim value As Date

instance.FirstDate = value

value = instance.FirstDate
C#
public DateTime FirstDate {get; set;}
Managed Extensions for C++
public: __property DateTime get_FirstDate();
public: __property void set_FirstDate(
   DateTime value
);
C++/CLI
public:
property DateTime FirstDate {
   DateTime get();
   void set (DateTimevalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ScheduleBox Class
ScheduleBox Members


FirstDayOfWeek Property

[image]
Gizmox.WebGUI.Forms.Office
FirstDayOfWeek Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ScheduleBox Class : FirstDayOfWeek Property

Gets or sets the first day of the week as displayed in the month calendar.

Syntax

Visual Basic (Declaration)
Public Property FirstDayOfWeek As Day
Visual Basic (Usage) Copy Code
Dim instance As ScheduleBox
Dim value As Day

instance.FirstDayOfWeek = value

value = instance.FirstDayOfWeek
C#
public Day FirstDayOfWeek {get; set;}
Managed Extensions for C++
public: __property Day get_FirstDayOfWeek();
public: __property void set_FirstDayOfWeek(
   Day value
);
C++/CLI
public:
property Day FirstDayOfWeek {
   Day get();
   void set (Dayvalue);
}

Exceptions

Exception | Description
InvalidEnumArgumentException | The assigned value is not one of the Day enumeration members.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ScheduleBox Class
ScheduleBox Members


HourFormat Property

[image]
Gizmox.WebGUI.Forms.Office
HourFormat Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ScheduleBox Class : HourFormat Property

Get or set the current schedule box hour format

Syntax

Visual Basic (Declaration)
Public Property HourFormat As ScheduleBoxHourFormat
Visual Basic (Usage) Copy Code
Dim instance As ScheduleBox
Dim value As ScheduleBoxHourFormat

instance.HourFormat = value

value = instance.HourFormat
C#
public ScheduleBoxHourFormat HourFormat {get; set;}
Managed Extensions for C++
public: __property ScheduleBoxHourFormat get_HourFormat();
public: __property void set_HourFormat(
   ScheduleBoxHourFormat value
);
C++/CLI
public:
property ScheduleBoxHourFormat HourFormat {
   ScheduleBoxHourFormat get();
   void set (ScheduleBoxHourFormatvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ScheduleBox Class
ScheduleBox Members


IsDelayedDrawing Property

[image]
Gizmox.WebGUI.Forms.Office
IsDelayedDrawing Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ScheduleBox Class : IsDelayedDrawing Property

Defined delayed drawing component

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property IsDelayedDrawing As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ScheduleBox
Dim value As Boolean

value = instance.IsDelayedDrawing
C#
protected override bool IsDelayedDrawing {get;}
Managed Extensions for C++
protected: __property bool get_IsDelayedDrawing() override;
C++/CLI
protected:
property bool IsDelayedDrawing {
   bool get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ScheduleBox Class
ScheduleBox Members


View Property

[image]
Gizmox.WebGUI.Forms.Office
View Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ScheduleBox Class : View Property

Get or set the current schedule box view

Syntax

Visual Basic (Declaration)
Public Property View As ScheduleBoxView
Visual Basic (Usage) Copy Code
Dim instance As ScheduleBox
Dim value As ScheduleBoxView

instance.View = value

value = instance.View
C#
public ScheduleBoxView View {get; set;}
Managed Extensions for C++
public: __property ScheduleBoxView get_View();
public: __property void set_View(
   ScheduleBoxView value
);
C++/CLI
public:
property ScheduleBoxView View {
   ScheduleBoxView get();
   void set (ScheduleBoxViewvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ScheduleBox Class
ScheduleBox Members


WorkEndHour Property

[image]
Gizmox.WebGUI.Forms.Office
WorkEndHour Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ScheduleBox Class : WorkEndHour Property

Get or set the work end hour

Syntax

Visual Basic (Declaration)
Public Property WorkEndHour As Integer
Visual Basic (Usage) Copy Code
Dim instance As ScheduleBox
Dim value As Integer

instance.WorkEndHour = value

value = instance.WorkEndHour
C#
public int WorkEndHour {get; set;}
Managed Extensions for C++
public: __property int get_WorkEndHour();
public: __property void set_WorkEndHour(
   int value
);
C++/CLI
public:
property int WorkEndHour {
   int get();
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ScheduleBox Class
ScheduleBox Members


WorkStartHour Property

[image]
Gizmox.WebGUI.Forms.Office
WorkStartHour Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ScheduleBox Class : WorkStartHour Property

Get or set the work start hour

Syntax

Visual Basic (Declaration)
Public Property WorkStartHour As Integer
Visual Basic (Usage) Copy Code
Dim instance As ScheduleBox
Dim value As Integer

instance.WorkStartHour = value

value = instance.WorkStartHour
C#
public int WorkStartHour {get; set;}
Managed Extensions for C++
public: __property int get_WorkStartHour();
public: __property void set_WorkStartHour(
   int value
);
C++/CLI
public:
property int WorkStartHour {
   int get();
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ScheduleBox Class
ScheduleBox Members


ScheduleBox Class Events

[image]
Gizmox.WebGUI.Forms.Office
ScheduleBox Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ScheduleBox Class

For a list of all members of this type, see ScheduleBox members.

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | EventDoubleClick | Occurs when the user double clicks an event
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

ScheduleBox Class
Gizmox.WebGUI.Forms Namespace


EventDoubleClick Event

[image]
Gizmox.WebGUI.Forms.Office
EventDoubleClick Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ScheduleBox Class : EventDoubleClick Event

Occurs when the user double clicks an event

Syntax

Visual Basic (Declaration)
Public Event EventDoubleClick() As ScheduleBox.ScheduleBoxEventHandler
Visual Basic (Usage) Copy Code
Dim instance As ScheduleBox
Dim handler As ScheduleBox.ScheduleBoxEventHandler

AddHandler instance.EventDoubleClick, handler
C#
public event ScheduleBox.ScheduleBoxEventHandler EventDoubleClick()
Managed Extensions for C++
public: __event ScheduleBox.ScheduleBoxEventHandler* EventDoubleClick
C++/CLI
public:
event ScheduleBox::ScheduleBoxEventHandler^ EventDoubleClick

Event Data

The event handler receives an argument of type ScheduleBox.ScheduleBoxEventArgs containing data related to this event. The following ScheduleBox.ScheduleBoxEventArgs properties provide information specific to this event.

Property | Description
Event |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ScheduleBox Class
ScheduleBox Members


ScheduleBox.ScheduleBoxEventArgs Class

[image]
Gizmox.WebGUI.Forms.Office
ScheduleBox.ScheduleBoxEventArgs Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ScheduleBox.ScheduleBoxEventArgs Class

Object Model

Syntax

Visual Basic (Declaration)
Public Class ScheduleBox.ScheduleBoxEventArgs
   Inherits EventArgs
Visual Basic (Usage) Copy Code
Dim instance As ScheduleBox.ScheduleBoxEventArgs
C#
public class ScheduleBox.ScheduleBoxEventArgs : EventArgs
Managed Extensions for C++
public __gc class ScheduleBox.ScheduleBoxEventArgs : public EventArgs
C++/CLI
public ref class ScheduleBox.ScheduleBoxEventArgs : public EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Gizmox.WebGUI.Forms.ScheduleBox.ScheduleBoxEventArgs

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms.Office (in Gizmox.WebGUI.Forms.Office.dll)

See Also

Reference

ScheduleBox.ScheduleBoxEventArgs Members
Gizmox.WebGUI.Forms Namespace


ScheduleBox.ScheduleBoxEventArgs Class Members

[image]
Gizmox.WebGUI.Forms.Office
ScheduleBox.ScheduleBoxEventArgs Class Members
See Also Properties Send Feedback
Gizmox.WebGUI.Forms Namespace : ScheduleBox.ScheduleBoxEventArgs Class

The following tables list the members exposed by ScheduleBox.ScheduleBoxEventArgs.

Public Constructors

 | Name | Description
Public Constructor | ScheduleBox.ScheduleBoxEventArgs Constructor |
Top

Public Properties

 | Name | Description
Public Property | Event |
Top

See Also

Reference

ScheduleBox.ScheduleBoxEventArgs Class
Gizmox.WebGUI.Forms Namespace


ScheduleBox.ScheduleBoxEventArgs Constructor

[image]
Gizmox.WebGUI.Forms.Office
ScheduleBox.ScheduleBoxEventArgs Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ScheduleBox.ScheduleBoxEventArgs Class : ScheduleBox.ScheduleBoxEventArgs Constructor

objEvent

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal objEvent As ScheduleBoxEvent _
)
Visual Basic (Usage) Copy Code
Dim objEvent As ScheduleBoxEvent

Dim instance As ScheduleBox.ScheduleBoxEventArgs(objEvent)
C#
public ScheduleBox.ScheduleBoxEventArgs(
   ScheduleBoxEvent objEvent
)
Managed Extensions for C++
public: ScheduleBox.ScheduleBoxEventArgs(
   ScheduleBoxEvent* objEvent
)
C++/CLI
public:
ScheduleBox.ScheduleBoxEventArgs(
   ScheduleBoxEvent^ objEvent
)

Parameters

objEvent

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ScheduleBox.ScheduleBoxEventArgs Class
ScheduleBox.ScheduleBoxEventArgs Members


ScheduleBox.ScheduleBoxEventArgs Class Properties

[image]
Gizmox.WebGUI.Forms.Office
ScheduleBox.ScheduleBoxEventArgs Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ScheduleBox.ScheduleBoxEventArgs Class

For a list of all members of this type, see ScheduleBox.ScheduleBoxEventArgs members.

Public Properties

 | Name | Description
Public Property | Event |
Top

See Also

Reference

ScheduleBox.ScheduleBoxEventArgs Class
Gizmox.WebGUI.Forms Namespace


Event Property

[image]
Gizmox.WebGUI.Forms.Office
Event Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ScheduleBox.ScheduleBoxEventArgs Class : Event Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Event As ScheduleBoxEvent
Visual Basic (Usage) Copy Code
Dim instance As ScheduleBox.ScheduleBoxEventArgs
Dim value As ScheduleBoxEvent

value = instance.Event
C#
public ScheduleBoxEvent Event {get;}
Managed Extensions for C++
public: __property ScheduleBoxEvent* get_Event();
C++/CLI
public:
property ScheduleBoxEvent^ Event {
   ScheduleBoxEvent^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ScheduleBox.ScheduleBoxEventArgs Class
ScheduleBox.ScheduleBoxEventArgs Members


ScheduleBoxEvent Class

[image]
Gizmox.WebGUI.Forms.Office
ScheduleBoxEvent Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ScheduleBoxEvent Class

Represents a schedule event

Syntax

Visual Basic (Declaration)
Public Class ScheduleBoxEvent
Visual Basic (Usage) Copy Code
Dim instance As ScheduleBoxEvent
C#
public class ScheduleBoxEvent
Managed Extensions for C++
public __gc class ScheduleBoxEvent
C++/CLI
public ref class ScheduleBoxEvent

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ScheduleBoxEvent

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms.Office (in Gizmox.WebGUI.Forms.Office.dll)

See Also

Reference

ScheduleBoxEvent Members
Gizmox.WebGUI.Forms Namespace


ScheduleBoxEvent Class Members

[image]
Gizmox.WebGUI.Forms.Office
ScheduleBoxEvent Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : ScheduleBoxEvent Class

The following tables list the members exposed by ScheduleBoxEvent.

Public Constructors

 | Name | Description
Public Constructor | ScheduleBoxEvent Constructor | Default constructor
Top

Public Properties

 | Name | Description
Public Property | End | The ending time of the event
Public Property | Start | The starting time of the event
Public Property | Subject | The subject of the event
Public Property | Tag | Gets/Sets User definied tag
Top

Public Methods

 | Name | Description
Public Method | ToString | Overridden. Overrides the default to string
Top

See Also

Reference

ScheduleBoxEvent Class
Gizmox.WebGUI.Forms Namespace


ScheduleBoxEvent Constructor

[image]
Gizmox.WebGUI.Forms.Office
ScheduleBoxEvent Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ScheduleBoxEvent Class : ScheduleBoxEvent Constructor

Default constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ScheduleBoxEvent()
C#
public ScheduleBoxEvent()
Managed Extensions for C++
public: ScheduleBoxEvent();
C++/CLI
public:
ScheduleBoxEvent();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ScheduleBoxEvent Class
ScheduleBoxEvent Members


ScheduleBoxEvent Class Methods

[image]
Gizmox.WebGUI.Forms.Office
ScheduleBoxEvent Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ScheduleBoxEvent Class

For a list of all members of this type, see ScheduleBoxEvent members.

Public Methods

 | Name | Description
Public Method | ToString | Overridden. Overrides the default to string
Top

See Also

Reference

ScheduleBoxEvent Class
Gizmox.WebGUI.Forms Namespace


ToString Method

[image]
Gizmox.WebGUI.Forms.Office
ToString Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ScheduleBoxEvent Class : ToString Method

Overrides the default to string

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As String
Visual Basic (Usage) Copy Code
Dim instance As ScheduleBoxEvent
Dim value As String

value = instance.ToString()
C#
public override string ToString()
Managed Extensions for C++
public: string* ToString(); override
C++/CLI
public:
String^ ToString(); override

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ScheduleBoxEvent Class
ScheduleBoxEvent Members


ScheduleBoxEvent Class Properties

[image]
Gizmox.WebGUI.Forms.Office
ScheduleBoxEvent Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ScheduleBoxEvent Class

For a list of all members of this type, see ScheduleBoxEvent members.

Public Properties

 | Name | Description
Public Property | End | The ending time of the event
Public Property | Start | The starting time of the event
Public Property | Subject | The subject of the event
Public Property | Tag | Gets/Sets User definied tag
Top

See Also

Reference

ScheduleBoxEvent Class
Gizmox.WebGUI.Forms Namespace


End Property

[image]
Gizmox.WebGUI.Forms.Office
End Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ScheduleBoxEvent Class : End Property

The ending time of the event

Syntax

Visual Basic (Declaration)
Public Property End As Date
Visual Basic (Usage) Copy Code
Dim instance As ScheduleBoxEvent
Dim value As Date

instance.End = value

value = instance.End
C#
public DateTime End {get; set;}
Managed Extensions for C++
public: __property DateTime get_End();
public: __property void set_End(
   DateTime value
);
C++/CLI
public:
property DateTime End {
   DateTime get();
   void set (DateTimevalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ScheduleBoxEvent Class
ScheduleBoxEvent Members


Start Property

[image]
Gizmox.WebGUI.Forms.Office
Start Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ScheduleBoxEvent Class : Start Property

The starting time of the event

Syntax

Visual Basic (Declaration)
Public Property Start As Date
Visual Basic (Usage) Copy Code
Dim instance As ScheduleBoxEvent
Dim value As Date

instance.Start = value

value = instance.Start
C#
public DateTime Start {get; set;}
Managed Extensions for C++
public: __property DateTime get_Start();
public: __property void set_Start(
   DateTime value
);
C++/CLI
public:
property DateTime Start {
   DateTime get();
   void set (DateTimevalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ScheduleBoxEvent Class
ScheduleBoxEvent Members


Subject Property

[image]
Gizmox.WebGUI.Forms.Office
Subject Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ScheduleBoxEvent Class : Subject Property

The subject of the event

Syntax

Visual Basic (Declaration)
Public Property Subject As String
Visual Basic (Usage) Copy Code
Dim instance As ScheduleBoxEvent
Dim value As String

instance.Subject = value

value = instance.Subject
C#
public string Subject {get; set;}
Managed Extensions for C++
public: __property string* get_Subject();
public: __property void set_Subject(
   string* value
);
C++/CLI
public:
property String^ Subject {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ScheduleBoxEvent Class
ScheduleBoxEvent Members


Tag Property

[image]
Gizmox.WebGUI.Forms.Office
Tag Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ScheduleBoxEvent Class : Tag Property

Gets/Sets User definied tag

Syntax

Visual Basic (Declaration)
<BindableAttribute(True)>
<DefaultValueAttribute()>
<TypeConverterAttribute("System.ComponentModel.StringConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
Public Property Tag As Object
Visual Basic (Usage) Copy Code
Dim instance As ScheduleBoxEvent
Dim value As Object

instance.Tag = value

value = instance.Tag
C#
[BindableAttribute(true)]
[DefaultValueAttribute()]
[TypeConverterAttribute("System.ComponentModel.StringConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public object Tag {get; set;}
Managed Extensions for C++
[BindableAttribute(true)]
[DefaultValueAttribute()]
[TypeConverterAttribute("System.ComponentModel.StringConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public: __property Object* get_Tag();
public: __property void set_Tag(
   Object* value
);
C++/CLI
[BindableAttribute(true)]
[DefaultValueAttribute()]
[TypeConverterAttribute("System.ComponentModel.StringConverter, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public:
property Object^ Tag {
   Object^ get();
   void set (Object^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ScheduleBoxEvent Class
ScheduleBoxEvent Members


ScheduleBoxEventCollection Class

[image]
Gizmox.WebGUI.Forms.Office
ScheduleBoxEventCollection Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ScheduleBoxEventCollection Class

Represents a collection of events in a ScheduleBox.

Object Model

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class ScheduleBoxEventCollection
   Inherits BaseCollection
Visual Basic (Usage) Copy Code
Dim instance As ScheduleBoxEventCollection
C#
[DefaultMemberAttribute("Item")]
public class ScheduleBoxEventCollection : BaseCollection
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
public __gc class ScheduleBoxEventCollection : public BaseCollection
C++/CLI
[DefaultMemberAttribute("Item")]
public ref class ScheduleBoxEventCollection : public BaseCollection

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.BaseCollection
Gizmox.WebGUI.Forms.ScheduleBoxEventCollection

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms.Office (in Gizmox.WebGUI.Forms.Office.dll)

See Also

Reference

ScheduleBoxEventCollection Members
Gizmox.WebGUI.Forms Namespace


ScheduleBoxEventCollection Class Members

[image]
Gizmox.WebGUI.Forms.Office
ScheduleBoxEventCollection Class Members
See Also Properties Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : ScheduleBoxEventCollection Class

The following tables list the members exposed by ScheduleBoxEventCollection.

Public Properties

 | Name | Description
Public Property | Count | Gets the total number of elements in the collection. (Inherited from BaseCollection)
Public Property | IsFixedSize |
Public Property | IsReadOnly | Gets a value indicating whether the collection is read-only. (Inherited from BaseCollection)
Public Property | IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized. (Inherited from BaseCollection)
Public Property | Item | Set or get event at index
Public Property | SyncRoot | Gets an object that can be used to synchronize access to the BaseCollection. (Inherited from BaseCollection)
Top

Protected Properties

 | Name | Description
Protected Property | List | Overridden.
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Add a new event
Public Method | Clear | Clears all events
Public Method | Contains |
Public Method | CopyTo | Copies all the elements of the current one-dimensional Array to the specified one-dimensional Array starting at the specified destination Array index. (Inherited from BaseCollection)
Public Method | GetEnumerator | Gets the object that enables iterating through the members of the collection. (Inherited from BaseCollection)
Public Method | IndexOf |
Public Method | Insert |
Public Method | Remove | Removes an event
Public Method | RemoveAt |
Top

See Also

Reference

ScheduleBoxEventCollection Class
Gizmox.WebGUI.Forms Namespace


ScheduleBoxEventCollection Class Methods

[image]
Gizmox.WebGUI.Forms.Office
ScheduleBoxEventCollection Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ScheduleBoxEventCollection Class

For a list of all members of this type, see ScheduleBoxEventCollection members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Add a new event
Public Method | Clear | Clears all events
Public Method | Contains |
Public Method | CopyTo | Copies all the elements of the current one-dimensional Array to the specified one-dimensional Array starting at the specified destination Array index. (Inherited from BaseCollection)
Public Method | GetEnumerator | Gets the object that enables iterating through the members of the collection. (Inherited from BaseCollection)
Public Method | IndexOf |
Public Method | Insert |
Public Method | Remove | Removes an event
Public Method | RemoveAt |
Top

See Also

Reference

ScheduleBoxEventCollection Class
Gizmox.WebGUI.Forms Namespace


Add Method

[image]
Gizmox.WebGUI.Forms.Office
Add Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ScheduleBoxEventCollection Class : Add Method

Add a new event

Overload List

Overload | Description
Add(String,DateTime,DateTime) | Add a new event
Add(ScheduleBoxEvent) | Add a new event object

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ScheduleBoxEventCollection Class
ScheduleBoxEventCollection Members


Add(String,DateTime,DateTime) Method

[image]
Gizmox.WebGUI.Forms.Office
Add(String,DateTime,DateTime) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ScheduleBoxEventCollection Class > Add Method : Add(String,DateTime,DateTime) Method

strSubject
objStart
objEnd
Add a new event

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal strSubject As String, _
   ByVal objStart As Date, _
   ByVal objEnd As Date _
) As ScheduleBoxEvent
Visual Basic (Usage) Copy Code
Dim instance As ScheduleBoxEventCollection
Dim strSubject As String
Dim objStart As Date
Dim objEnd As Date
Dim value As ScheduleBoxEvent

value = instance.Add(strSubject, objStart, objEnd)
C#
public ScheduleBoxEvent Add(
   string strSubject,
   DateTime objStart,
   DateTime objEnd
)
Managed Extensions for C++
public: ScheduleBoxEvent* Add(
   string* strSubject,
   DateTime objStart,
   DateTime objEnd
)
C++/CLI
public:
ScheduleBoxEvent^ Add(
   String^ strSubject,
   DateTime objStart,
   DateTime objEnd
)

Parameters

strSubject
objStart
objEnd

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ScheduleBoxEventCollection Class
ScheduleBoxEventCollection Members
Overload List


Add(ScheduleBoxEvent) Method

[image]
Gizmox.WebGUI.Forms.Office
Add(ScheduleBoxEvent) Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ScheduleBoxEventCollection Class > Add Method : Add(ScheduleBoxEvent) Method

objEvent
Add a new event object

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal objEvent As ScheduleBoxEvent _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As ScheduleBoxEventCollection
Dim objEvent As ScheduleBoxEvent
Dim value As Integer

value = instance.Add(objEvent)
C#
public int Add(
   ScheduleBoxEvent objEvent
)
Managed Extensions for C++
public: int Add(
   ScheduleBoxEvent* objEvent
)
C++/CLI
public:
int Add(
   ScheduleBoxEvent^ objEvent
)

Parameters

objEvent

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ScheduleBoxEventCollection Class
ScheduleBoxEventCollection Members
Overload List


Clear Method

[image]
Gizmox.WebGUI.Forms.Office
Clear Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ScheduleBoxEventCollection Class : Clear Method

Clears all events

Syntax

Visual Basic (Declaration)
Public Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As ScheduleBoxEventCollection

instance.Clear()
C#
public void Clear()
Managed Extensions for C++
public: void Clear();
C++/CLI
public:
void Clear();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ScheduleBoxEventCollection Class
ScheduleBoxEventCollection Members


Contains Method

[image]
Gizmox.WebGUI.Forms.Office
Contains Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ScheduleBoxEventCollection Class : Contains Method

value

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal value As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ScheduleBoxEventCollection
Dim value As Object
Dim value As Boolean

value = instance.Contains(value)
C#
public bool Contains(
   object value
)
Managed Extensions for C++
public: bool Contains(
   Object* value
)
C++/CLI
public:
bool Contains(
   Object^ value
)

Parameters

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ScheduleBoxEventCollection Class
ScheduleBoxEventCollection Members


IndexOf Method

[image]
Gizmox.WebGUI.Forms.Office
IndexOf Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ScheduleBoxEventCollection Class : IndexOf Method

value

Syntax

Visual Basic (Declaration)
Public Function IndexOf( _
   ByVal value As Object _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As ScheduleBoxEventCollection
Dim value As Object
Dim value As Integer

value = instance.IndexOf(value)
C#
public int IndexOf(
   object value
)
Managed Extensions for C++
public: int IndexOf(
   Object* value
)
C++/CLI
public:
int IndexOf(
   Object^ value
)

Parameters

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ScheduleBoxEventCollection Class
ScheduleBoxEventCollection Members


Insert Method

[image]
Gizmox.WebGUI.Forms.Office
Insert Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ScheduleBoxEventCollection Class : Insert Method

index
value

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal value As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ScheduleBoxEventCollection
Dim index As Integer
Dim value As Object

instance.Insert(index, value)
C#
public void Insert(
   int index,
   object value
)
Managed Extensions for C++
public: void Insert(
   int index,
   Object* value
)
C++/CLI
public:
void Insert(
   int index,
   Object^ value
)

Parameters

index
value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ScheduleBoxEventCollection Class
ScheduleBoxEventCollection Members


Remove Method

[image]
Gizmox.WebGUI.Forms.Office
Remove Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ScheduleBoxEventCollection Class : Remove Method

objEvent
Removes an event

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal objEvent As ScheduleBoxEvent _
)
Visual Basic (Usage) Copy Code
Dim instance As ScheduleBoxEventCollection
Dim objEvent As ScheduleBoxEvent

instance.Remove(objEvent)
C#
public void Remove(
   ScheduleBoxEvent objEvent
)
Managed Extensions for C++
public: void Remove(
   ScheduleBoxEvent* objEvent
)
C++/CLI
public:
void Remove(
   ScheduleBoxEvent^ objEvent
)

Parameters

objEvent

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ScheduleBoxEventCollection Class
ScheduleBoxEventCollection Members


RemoveAt Method

[image]
Gizmox.WebGUI.Forms.Office
RemoveAt Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ScheduleBoxEventCollection Class : RemoveAt Method

index

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt( _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As ScheduleBoxEventCollection
Dim index As Integer

instance.RemoveAt(index)
C#
public void RemoveAt(
   int index
)
Managed Extensions for C++
public: void RemoveAt(
   int index
)
C++/CLI
public:
void RemoveAt(
   int index
)

Parameters

index

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ScheduleBoxEventCollection Class
ScheduleBoxEventCollection Members


ScheduleBoxEventCollection Class Properties

[image]
Gizmox.WebGUI.Forms.Office
ScheduleBoxEventCollection Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ScheduleBoxEventCollection Class

For a list of all members of this type, see ScheduleBoxEventCollection members.

Public Properties

 | Name | Description
Public Property | Count | Gets the total number of elements in the collection. (Inherited from BaseCollection)
Public Property | IsFixedSize |
Public Property | IsReadOnly | Gets a value indicating whether the collection is read-only. (Inherited from BaseCollection)
Public Property | IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized. (Inherited from BaseCollection)
Public Property | Item | Set or get event at index
Public Property | SyncRoot | Gets an object that can be used to synchronize access to the BaseCollection. (Inherited from BaseCollection)
Top

Protected Properties

 | Name | Description
Protected Property | List | Overridden.
Top

See Also

Reference

ScheduleBoxEventCollection Class
Gizmox.WebGUI.Forms Namespace


IsFixedSize Property

[image]
Gizmox.WebGUI.Forms.Office
IsFixedSize Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ScheduleBoxEventCollection Class : IsFixedSize Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsFixedSize As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ScheduleBoxEventCollection
Dim value As Boolean

value = instance.IsFixedSize
C#
public bool IsFixedSize {get;}
Managed Extensions for C++
public: __property bool get_IsFixedSize();
C++/CLI
public:
property bool IsFixedSize {
   bool get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ScheduleBoxEventCollection Class
ScheduleBoxEventCollection Members


Item Property

[image]
Gizmox.WebGUI.Forms.Office
Item Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ScheduleBoxEventCollection Class : Item Property

index
Set or get event at index

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal index As Integer _
) As ScheduleBoxEvent
Visual Basic (Usage) Copy Code
Dim instance As ScheduleBoxEventCollection
Dim index As Integer
Dim value As ScheduleBoxEvent

instance.Item(index) = value

value = instance.Item(index)
C#
public ScheduleBoxEvent this[
   int index
]; {get; set;}
Managed Extensions for C++
public: __property ScheduleBoxEvent* get_Item(
   int index
);
public: __property void set_Item(
   int index,
   ScheduleBoxEvent* value
);
C++/CLI
public:
property ScheduleBoxEvent^ default [int] {
   ScheduleBoxEvent^ get(intindex);
   void set (intindex, ScheduleBoxEvent^value);
}

Parameters

index

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ScheduleBoxEventCollection Class
ScheduleBoxEventCollection Members


List Property

[image]
Gizmox.WebGUI.Forms.Office
List Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ScheduleBoxEventCollection Class : List Property

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property List As ArrayList
Visual Basic (Usage) Copy Code
Dim instance As ScheduleBoxEventCollection
Dim value As ArrayList

value = instance.List
C#
protected override ArrayList List {get;}
Managed Extensions for C++
protected: __property ArrayList* get_List() override;
C++/CLI
protected:
property ArrayList^ List {
   ArrayList^ get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ScheduleBoxEventCollection Class
ScheduleBoxEventCollection Members


SearchTextBox Class

[image]
Gizmox.WebGUI.Forms.Office
SearchTextBox Class
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : SearchTextBox Class

Summary description for SearchTextBox

Object Model

Syntax

Visual Basic (Declaration)
<WebCompilerResourcesAttribute(Assembly=, Namespace="Gizmox.WebGUI.Forms.Office")>
<ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableSearchTextBox, Gizmox.WebGUI.Silverlight.Controls.Office, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="STB")>
Public Class SearchTextBox
   Inherits TextBox
   Implements IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IRequiredRegistration, IBindableComponent, IArrangedElement
Visual Basic (Usage) Copy Code
Dim instance As SearchTextBox
C#
[WebCompilerResourcesAttribute(Assembly=, Namespace="Gizmox.WebGUI.Forms.Office")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableSearchTextBox, Gizmox.WebGUI.Silverlight.Controls.Office, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="STB")]
public class SearchTextBox : TextBox, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IRequiredRegistration, IBindableComponent, IArrangedElement
Managed Extensions for C++
[WebCompilerResourcesAttribute(Assembly=, Namespace="Gizmox.WebGUI.Forms.Office")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableSearchTextBox, Gizmox.WebGUI.Silverlight.Controls.Office, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="STB")]
public __gc class SearchTextBox : public TextBox, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IRequiredRegistration, IBindableComponent, IArrangedElement
C++/CLI
[WebCompilerResourcesAttribute(Assembly=, Namespace="Gizmox.WebGUI.Forms.Office")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[SilverlightControlAttribute(Type="Gizmox.WebGUI.Silverlight.Controls.BindableSearchTextBox, Gizmox.WebGUI.Silverlight.Controls.Office, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", Style="STB")]
public ref class SearchTextBox : public TextBox, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IRequiredRegistration, IBindableComponent, IArrangedElement

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.TextBoxBase
Gizmox.WebGUI.Forms.TextBox
Gizmox.WebGUI.Forms.SearchTextBox

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms.Office (in Gizmox.WebGUI.Forms.Office.dll)

See Also

Reference

SearchTextBox Members
Gizmox.WebGUI.Forms Namespace


SearchTextBox Class Members

[image]
Gizmox.WebGUI.Forms.Office
SearchTextBox Class Members
See Also Fields Properties Methods Events Send Feedback
Gizmox.WebGUI.Forms Namespace : SearchTextBox Class

The following tables list the members exposed by SearchTextBox.

Public Constructors

 | Name | Description
Public Constructor | SearchTextBox Constructor |
Top

Protected Fields

 | Name | Description
Protected Field | menmScrollBars | Member which holds the scrollbars mode. (Inherited from TextBox)
Top

Public Properties

 | Name | Description
Public Property | AcceptsReturn | Gets or sets a value indicating whether pressing ENTER in a multiline TextBox control creates a new line of text in the control or activates the default button for the form. (Inherited from TextBox)
Public Property | AcceptsTab | (Inherited from TextBoxBase)
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | (Inherited from TextBox)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | CanUndo | Gets a value indicating whether the user can undo the previous operation in a text box control. (Inherited from TextBox)
Public Property | CharacterCasing | Indicates if all characters should be left alone or converted to uppercase or lowercase (Inherited from TextBox)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DragTargets | Gets a value indicating whether this instance is dragable. (Inherited from TextBox)
Public Property | DropDownMenu | Defines a dropdown menu to the button
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | IsSearchActive | Gets or sets a value indicating whether this instance is search active.
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Lines | (Inherited from TextBoxBase)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MaxLength | (Inherited from TextBoxBase)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Multiline | Gets or sets a value indicating whether text box is multi line. (Inherited from TextBoxBase)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PasswordChar | Gets or sets the password charecter. (Inherited from TextBox)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | ReadOnly | Gets or sets a value indicating whether [read only]. (Inherited from TextBoxBase)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | ScrollBars | Gets or sets which scroll bars should appear in a multiline TextBox control. (Inherited from TextBox)
Public Property | SelectedText | Gets or sets a value indicating the currently selected text in the control. (Inherited from TextBoxBase)
Public Property | SelectionLength | Gets or sets the number of characters selected in the text box. (Inherited from TextBoxBase)
Public Property | SelectionStart | Gets or sets the starting point of text selected in the text box. (Inherited from TextBoxBase)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Control)
Public Property | TextAlign | Gets or sets how text is aligned in a TextBox control. (Inherited from TextBox)
Public Property | TextLength | Gets the length of text in the control. (Inherited from TextBoxBase)
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | Validator | Gets or sets the text box validator. (Inherited from TextBox)
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | WatermarkText | Gets or sets the watermark text.
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Public Property | WordWrap | (Inherited from TextBoxBase)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from TextBox)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from TextBox)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

Public Methods

 | Name | Description
Public Method | AppendText | Appends text to the current text of a text box. (Inherited from TextBoxBase)
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Clear | Clears all text from the text box control. (Inherited from TextBoxBase)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | Copy | Copies the current selection in the text box to the Clipboard. (Inherited from TextBoxBase)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Cut | Moves the current selection in the text box to the Clipboard. (Inherited from TextBoxBase)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | Paste | Replaces the current selection in the text box with the contents of the Clipboard. (Inherited from TextBoxBase)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | ScrollToCaret | Scrolls the contents of the control to the current caret position. (Inherited from TextBoxBase)
Public Method | Select | Overloaded. Selects a range of text in the text box. (Inherited from TextBoxBase)
Public Method | SelectAll | Selects all text in the text box. (Inherited from TextBoxBase)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | Undo | Undoes the last edit operation in the text box. (Inherited from TextBox)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Overridden.
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetClipboardContent | Get content to be added to the clip board (Inherited from TextBox)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from TextBox)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from Control)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | InvokeSelection | Implements the actual client side selection (Inherited from TextBox)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Control)
Protected Method | RenderAttributes | Overridden.
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | Render control params (Inherited from TextBoxBase)
Protected Method | RenderValue | (Inherited from TextBox)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetClipboardContent | Set the value from the clip board (Inherited from TextBox)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Clear |
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | EnterKeyDown | Occurs on enter key down only on single line. (Inherited from TextBox)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | Search |
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

SearchTextBox Class
Gizmox.WebGUI.Forms Namespace


SearchTextBox Constructor

[image]
Gizmox.WebGUI.Forms.Office
SearchTextBox Constructor
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > SearchTextBox Class : SearchTextBox Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As SearchTextBox()
C#
public SearchTextBox()
Managed Extensions for C++
public: SearchTextBox();
C++/CLI
public:
SearchTextBox();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SearchTextBox Class
SearchTextBox Members


SearchTextBox Class Methods

[image]
Gizmox.WebGUI.Forms.Office
SearchTextBox Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : SearchTextBox Class

For a list of all members of this type, see SearchTextBox members.

Public Methods

 | Name | Description
Public Method | AppendText | Appends text to the current text of a text box. (Inherited from TextBoxBase)
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Clear | Clears all text from the text box control. (Inherited from TextBoxBase)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | Copy | Copies the current selection in the text box to the Clipboard. (Inherited from TextBoxBase)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Cut | Moves the current selection in the text box to the Clipboard. (Inherited from TextBoxBase)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | Paste | Replaces the current selection in the text box with the contents of the Clipboard. (Inherited from TextBoxBase)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | ScrollToCaret | Scrolls the contents of the control to the current caret position. (Inherited from TextBoxBase)
Public Method | Select | Overloaded. Selects a range of text in the text box. (Inherited from TextBoxBase)
Public Method | SelectAll | Selects all text in the text box. (Inherited from TextBoxBase)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | Undo | Undoes the last edit operation in the text box. (Inherited from TextBox)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Overridden.
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetClipboardContent | Get content to be added to the clip board (Inherited from TextBox)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from TextBox)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from Control)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | InvokeSelection | Implements the actual client side selection (Inherited from TextBox)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Control)
Protected Method | RenderAttributes | Overridden.
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | Render control params (Inherited from TextBoxBase)
Protected Method | RenderValue | (Inherited from TextBox)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetClipboardContent | Set the value from the clip board (Inherited from TextBox)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

See Also

Reference

SearchTextBox Class
Gizmox.WebGUI.Forms Namespace


FireEvent Method

[image]
Gizmox.WebGUI.Forms.Office
FireEvent Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > SearchTextBox Class : FireEvent Method

objEvent

Syntax

Visual Basic (Declaration)
Protected Overrides Sub FireEvent( _
   ByVal objEvent As IEvent _
)
Visual Basic (Usage) Copy Code
Dim instance As SearchTextBox
Dim objEvent As IEvent

instance.FireEvent(objEvent)
C#
protected override void FireEvent(
   IEvent objEvent
)
Managed Extensions for C++
protected: void FireEvent(
   IEvent* objEvent
) override
C++/CLI
protected:
void FireEvent(
   IEvent^ objEvent
) override

Parameters

objEvent

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SearchTextBox Class
SearchTextBox Members


RenderAttributes Method

[image]
Gizmox.WebGUI.Forms.Office
RenderAttributes Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > SearchTextBox Class : RenderAttributes Method

context
writer

Syntax

Visual Basic (Declaration)
Protected Overrides Sub RenderAttributes( _
   ByVal context As IContext, _
   ByVal writer As IAttributeWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As SearchTextBox
Dim context As IContext
Dim writer As IAttributeWriter

instance.RenderAttributes(context, writer)
C#
protected override void RenderAttributes(
   IContext context,
   IAttributeWriter writer
)
Managed Extensions for C++
protected: void RenderAttributes(
   IContext* context,
   IAttributeWriter* writer
) override
C++/CLI
protected:
void RenderAttributes(
   IContext^ context,
   IAttributeWriter^ writer
) override

Parameters

context
writer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SearchTextBox Class
SearchTextBox Members


SearchTextBox Class Properties

[image]
Gizmox.WebGUI.Forms.Office
SearchTextBox Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : SearchTextBox Class

For a list of all members of this type, see SearchTextBox members.

Public Properties

 | Name | Description
Public Property | AcceptsReturn | Gets or sets a value indicating whether pressing ENTER in a multiline TextBox control creates a new line of text in the control or activates the default button for the form. (Inherited from TextBox)
Public Property | AcceptsTab | (Inherited from TextBoxBase)
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | (Inherited from TextBox)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | CanUndo | Gets a value indicating whether the user can undo the previous operation in a text box control. (Inherited from TextBox)
Public Property | CharacterCasing | Indicates if all characters should be left alone or converted to uppercase or lowercase (Inherited from TextBox)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DragTargets | Gets a value indicating whether this instance is dragable. (Inherited from TextBox)
Public Property | DropDownMenu | Defines a dropdown menu to the button
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | IsSearchActive | Gets or sets a value indicating whether this instance is search active.
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Lines | (Inherited from TextBoxBase)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MaxLength | (Inherited from TextBoxBase)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Multiline | Gets or sets a value indicating whether text box is multi line. (Inherited from TextBoxBase)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PasswordChar | Gets or sets the password charecter. (Inherited from TextBox)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | ReadOnly | Gets or sets a value indicating whether [read only]. (Inherited from TextBoxBase)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | ScrollBars | Gets or sets which scroll bars should appear in a multiline TextBox control. (Inherited from TextBox)
Public Property | SelectedText | Gets or sets a value indicating the currently selected text in the control. (Inherited from TextBoxBase)
Public Property | SelectionLength | Gets or sets the number of characters selected in the text box. (Inherited from TextBoxBase)
Public Property | SelectionStart | Gets or sets the starting point of text selected in the text box. (Inherited from TextBoxBase)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Control)
Public Property | TextAlign | Gets or sets how text is aligned in a TextBox control. (Inherited from TextBox)
Public Property | TextLength | Gets the length of text in the control. (Inherited from TextBoxBase)
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | Validator | Gets or sets the text box validator. (Inherited from TextBox)
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | WatermarkText | Gets or sets the watermark text.
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Public Property | WordWrap | (Inherited from TextBoxBase)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from TextBox)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from TextBox)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

See Also

Reference

SearchTextBox Class
Gizmox.WebGUI.Forms Namespace


DropDownMenu Property

[image]
Gizmox.WebGUI.Forms.Office
DropDownMenu Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > SearchTextBox Class : DropDownMenu Property

Defines a dropdown menu to the button

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property DropDownMenu As Menu
Visual Basic (Usage) Copy Code
Dim instance As SearchTextBox
Dim value As Menu

instance.DropDownMenu = value

value = instance.DropDownMenu
C#
[DefaultValueAttribute()]
public Menu DropDownMenu {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property Menu* get_DropDownMenu();
public: __property void set_DropDownMenu(
   Menu* value
);
C++/CLI
[DefaultValueAttribute()]
public:
property Menu^ DropDownMenu {
   Menu^ get();
   void set (Menu^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SearchTextBox Class
SearchTextBox Members


IsSearchActive Property

[image]
Gizmox.WebGUI.Forms.Office
IsSearchActive Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > SearchTextBox Class : IsSearchActive Property

Gets or sets a value indicating whether this instance is search active.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property IsSearchActive As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SearchTextBox
Dim value As Boolean

instance.IsSearchActive = value

value = instance.IsSearchActive
C#
[DefaultValueAttribute()]
public bool IsSearchActive {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property bool get_IsSearchActive();
public: __property void set_IsSearchActive(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
public:
property bool IsSearchActive {
   bool get();
   void set (boolvalue);
}

Return Value

true if this instance is search active; otherwise, false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SearchTextBox Class
SearchTextBox Members


WatermarkText Property

[image]
Gizmox.WebGUI.Forms.Office
WatermarkText Property
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > SearchTextBox Class : WatermarkText Property

Gets or sets the watermark text.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Property WatermarkText As String
Visual Basic (Usage) Copy Code
Dim instance As SearchTextBox
Dim value As String

instance.WatermarkText = value

value = instance.WatermarkText
C#
[DefaultValueAttribute()]
public string WatermarkText {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property string* get_WatermarkText();
public: __property void set_WatermarkText(
   string* value
);
C++/CLI
[DefaultValueAttribute()]
public:
property String^ WatermarkText {
   String^ get();
   void set (String^value);
}

Return Value

The message.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SearchTextBox Class
SearchTextBox Members


SearchTextBox Class Events

[image]
Gizmox.WebGUI.Forms.Office
SearchTextBox Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : SearchTextBox Class

For a list of all members of this type, see SearchTextBox members.

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Clear |
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | EnterKeyDown | Occurs on enter key down only on single line. (Inherited from TextBox)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | Search |
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

SearchTextBox Class
Gizmox.WebGUI.Forms Namespace


Clear Event

[image]
Gizmox.WebGUI.Forms.Office
Clear Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > SearchTextBox Class : Clear Event

Syntax

Visual Basic (Declaration)
Public Event Clear() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As SearchTextBox
Dim handler As EventHandler

AddHandler instance.Clear, handler
C#
public event EventHandler Clear()
Managed Extensions for C++
public: __event EventHandler* Clear
C++/CLI
public:
event EventHandler^ Clear

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SearchTextBox Class
SearchTextBox Members


Search Event

[image]
Gizmox.WebGUI.Forms.Office
Search Event
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > SearchTextBox Class : Search Event

Syntax

Visual Basic (Declaration)
Public Event Search() As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As SearchTextBox
Dim handler As EventHandler

AddHandler instance.Search, handler
C#
public event EventHandler Search()
Managed Extensions for C++
public: __event EventHandler* Search
C++/CLI
public:
event EventHandler^ Search

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

SearchTextBox Class
SearchTextBox Members


ScheduleBoxHourFormat Enumeration

[image]
Gizmox.WebGUI.Forms.Office
ScheduleBoxHourFormat Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ScheduleBoxHourFormat Enumeration

ScheduleBox hour format

Syntax

Visual Basic (Declaration)
Public Enum ScheduleBoxHourFormat
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As ScheduleBoxHourFormat
C#
public enum ScheduleBoxHourFormat : Enum
Managed Extensions for C++
__value public enum ScheduleBoxHourFormat : public Enum
C++/CLI
public enum class ScheduleBoxHourFormat : public Enum

Members

Member | Description
Clock12H | Displays 12 hours format
Clock24H | Displays 24 hours format

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.ScheduleBoxHourFormat

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms.Office (in Gizmox.WebGUI.Forms.Office.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


ScheduleBoxView Enumeration

[image]
Gizmox.WebGUI.Forms.Office
ScheduleBoxView Enumeration
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ScheduleBoxView Enumeration

ScheduleBox views

Syntax

Visual Basic (Declaration)
Public Enum ScheduleBoxView
   Inherits Enum
Visual Basic (Usage) Copy Code
Dim instance As ScheduleBoxView
C#
public enum ScheduleBoxView : Enum
Managed Extensions for C++
__value public enum ScheduleBoxView : public Enum
C++/CLI
public enum class ScheduleBoxView : public Enum

Members

Member | Description
Week | Displays five days
FullWeek | Displays seven days
FullMonth | Displays monthly days
Day | Displays one days
Month | Displays a full month

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Gizmox.WebGUI.Forms.ScheduleBoxView

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms.Office (in Gizmox.WebGUI.Forms.Office.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


ISupportsRibbonBar Interface

[image]
Gizmox.WebGUI.Forms.Office
ISupportsRibbonBar Interface
Members See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ISupportsRibbonBar Interface

Indicates the the class can create ribbon bar items

Syntax

Visual Basic (Declaration)
Public Interface ISupportsRibbonBar
Visual Basic (Usage) Copy Code
Dim instance As ISupportsRibbonBar
C#
public interface ISupportsRibbonBar
Managed Extensions for C++
public __gc __interface ISupportsRibbonBar
C++/CLI
public interface class ISupportsRibbonBar

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms.Office (in Gizmox.WebGUI.Forms.Office.dll)

See Also

Reference

ISupportsRibbonBar Members
Gizmox.WebGUI.Forms Namespace


ISupportsRibbonBar Interface Members

[image]
Gizmox.WebGUI.Forms.Office
ISupportsRibbonBar Interface Members
See Also Methods Send Feedback
Gizmox.WebGUI.Forms Namespace : ISupportsRibbonBar Interface

The following tables list the members exposed by ISupportsRibbonBar.

Public Methods

 | Name | Description
Method | ApplyGroup | Applies content to an existing group.
Method | CreateGroup | Creates a ribbon bar group.
Top

See Also

Reference

ISupportsRibbonBar Interface
Gizmox.WebGUI.Forms Namespace


ISupportsRibbonBar Interface Methods

[image]
Gizmox.WebGUI.Forms.Office
ISupportsRibbonBar Interface Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ISupportsRibbonBar Interface

For a list of all members of this type, see ISupportsRibbonBar members.

Public Methods

 | Name | Description
Method | ApplyGroup | Applies content to an existing group.
Method | CreateGroup | Creates a ribbon bar group.
Top

See Also

Reference

ISupportsRibbonBar Interface
Gizmox.WebGUI.Forms Namespace


ApplyGroup Method

[image]
Gizmox.WebGUI.Forms.Office
ApplyGroup Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ISupportsRibbonBar Interface : ApplyGroup Method

objGroup
The group to apply group.
strGroupName
The name of the ribbon bar group to apply.
Applies content to an existing group.

Syntax

Visual Basic (Declaration)
Sub ApplyGroup( _
   ByVal objGroup As RibbonBarGroup, _
   ByVal strGroupName As String _
)
Visual Basic (Usage) Copy Code
Dim instance As ISupportsRibbonBar
Dim objGroup As RibbonBarGroup
Dim strGroupName As String

instance.ApplyGroup(objGroup, strGroupName)
C#
void ApplyGroup(
   RibbonBarGroup objGroup,
   string strGroupName
)
Managed Extensions for C++
void ApplyGroup(
   RibbonBarGroup* objGroup,
   string* strGroupName
)
C++/CLI
void ApplyGroup(
   RibbonBarGroup^ objGroup,
   String^ strGroupName
)

Parameters

objGroup
The group to apply group.
strGroupName
The name of the ribbon bar group to apply.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISupportsRibbonBar Interface
ISupportsRibbonBar Members


CreateGroup Method

[image]
Gizmox.WebGUI.Forms.Office
CreateGroup Method
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace > ISupportsRibbonBar Interface : CreateGroup Method

strGroupName
The name of the ribbon bar to create.
Creates a ribbon bar group.

Syntax

Visual Basic (Declaration)
Function CreateGroup( _
   ByVal strGroupName As String _
) As RibbonBarGroup
Visual Basic (Usage) Copy Code
Dim instance As ISupportsRibbonBar
Dim strGroupName As String
Dim value As RibbonBarGroup

value = instance.CreateGroup(strGroupName)
C#
RibbonBarGroup CreateGroup(
   string strGroupName
)
Managed Extensions for C++
RibbonBarGroup* CreateGroup(
   string* strGroupName
)
C++/CLI
RibbonBarGroup^ CreateGroup(
   String^ strGroupName
)

Parameters

strGroupName
The name of the ribbon bar to create.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISupportsRibbonBar Interface
ISupportsRibbonBar Members


NavigationTabEventHandler Delegate

[image]
Gizmox.WebGUI.Forms.Office
NavigationTabEventHandler Delegate
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : NavigationTabEventHandler Delegate

objSource
objArgs

Syntax

Visual Basic (Declaration)
Public Delegate Sub NavigationTabEventHandler( _
   ByVal objSource As Object, _
   ByVal objArgs As NavigationTabEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New NavigationTabEventHandler(AddressOf HandlerMethod)
C#
public delegate void NavigationTabEventHandler(
   object objSource,
   NavigationTabEventArgs objArgs
)
Managed Extensions for C++
public: __gc __delegate void NavigationTabEventHandler(
   Object* objSource,
   NavigationTabEventArgs* objArgs
)
C++/CLI
public delegate void NavigationTabEventHandler(
   Object^ objSource,
   NavigationTabEventArgs^ objArgs
)

Parameters

objSource
objArgs

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms.Office (in Gizmox.WebGUI.Forms.Office.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


ScheduleBox.ScheduleBoxEventHandler Delegate

[image]
Gizmox.WebGUI.Forms.Office
ScheduleBox.ScheduleBoxEventHandler Delegate
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ScheduleBox.ScheduleBoxEventHandler Delegate

sender
e

Syntax

Visual Basic (Declaration)
Public Delegate Sub ScheduleBox.ScheduleBoxEventHandler( _
   ByVal sender As Object, _
   ByVal e As ScheduleBox.ScheduleBoxEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New ScheduleBoxEventHandler(AddressOf HandlerMethod)
C#
public delegate void ScheduleBox.ScheduleBoxEventHandler(
   object sender,
   ScheduleBox.ScheduleBoxEventArgs e
)
Managed Extensions for C++
public: __gc __delegate void ScheduleBox.ScheduleBoxEventHandler(
   Object* sender,
   ScheduleBox.ScheduleBoxEventArgs* e
)
C++/CLI
public delegate void ScheduleBox.ScheduleBoxEventHandler(
   Object^ sender,
   ScheduleBox::ScheduleBoxEventArgs^ e
)

Parameters

sender
e

Requirements

Namespace: Gizmox.WebGUI.Forms

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Forms.Office (in Gizmox.WebGUI.Forms.Office.dll)

See Also

Reference

Gizmox.WebGUI.Forms Namespace


Assembly Overview

Gizmox.WebGUI.Reporting
Gizmox.WebGUI.Reporting Assembly
See Also Send Feedback

Namespaces

Namespace | Description
Gizmox.WebGUI.Reporting |


Gizmox.WebGUI.Reporting Namespace

Gizmox.WebGUI.Reporting
Gizmox.WebGUI.Reporting Namespace
See Also Inheritance Hierarchy Send Feedback

Classes

 | Class | Description
Class | ReportViewer |

See Also

Reference

Gizmox.WebGUI.Reporting Assembly


ReportViewer Class

[image]
Gizmox.WebGUI.Reporting
ReportViewer Class
Members See Also Send Feedback
Gizmox.WebGUI.Reporting Namespace : ReportViewer Class

Object Model

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("")>
<DesignTimeControllerAttribute()>
<ClientControllerAttribute()>
<ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
Public Class ReportViewer
   Inherits AspControlBoxBase
   Implements IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Visual Basic (Usage) Copy Code
Dim instance As ReportViewer
C#
[SRDescriptionAttribute("")]
[DesignTimeControllerAttribute()]
[ClientControllerAttribute()]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
public class ReportViewer : AspControlBoxBase, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
Managed Extensions for C++
[SRDescriptionAttribute("")]
[DesignTimeControllerAttribute()]
[ClientControllerAttribute()]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
public __gc class ReportViewer : public AspControlBoxBase, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement
C++/CLI
[SRDescriptionAttribute("")]
[DesignTimeControllerAttribute()]
[ClientControllerAttribute()]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
public ref class ReportViewer : public AspControlBoxBase, IAttributeExtender, IControl, IEventHandler, IGatewayComponent, IObservableItem, IObservableLayoutItem, IRegisteredComponent, IRenderableComponent, IBindableComponent, IArrangedElement

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.FrameControl
Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase
Gizmox.WebGUI.Reporting.ReportViewer

Requirements

Namespace: Gizmox.WebGUI.Reporting

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

Assembly: Gizmox.WebGUI.Reporting (in Gizmox.WebGUI.Reporting.dll)

See Also

Reference

ReportViewer Members
Gizmox.WebGUI.Reporting Namespace


ReportViewer Class Members

[image]
Gizmox.WebGUI.Reporting
ReportViewer Class Members
See Also Properties Methods Events Send Feedback
Gizmox.WebGUI.Reporting Namespace : ReportViewer Class

The following tables list the members exposed by ReportViewer.

Public Constructors

 | Name | Description
Public Constructor | ReportViewer Constructor |
Top

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | AsyncRendering |
Public Property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Public Property | BackColor | Overridden.
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the Gizmox.WebGUI.Forms.ImageLayout enumeration. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BindingContext | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Container | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Context | Gets the context. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ControlCode | Gets or sets the control code. (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Public Property | ControlID | Gets or sets the control ID, which indicates the id of the hosted control with in the control code. (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CurrentPage |
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Disposing | Gets a value indicating whether the base Gizmox.WebGUI.Forms.Control class is in the process of disposing. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | DocumentMapCollapsed |
Public Property | DocumentMapWidth |
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Form | Gets the owner form. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Height | Gets/Sets the height position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | HyperlinkTarget |
Public Property | InternalBorderColor |
Public Property | InternalBorderStyle |
Public Property | InternalBorderWidth |
Public Property | InternalParent | Gets the parent of this component. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | IsAspRequest | Gets a value indicating whether this is ASP request. (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | IsRegistered | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Left | Gets/Sets the left position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | LinkActiveColor |
Public Property | LinkActiveHoverColor |
Public Property | LinkDisabledColor |
Public Property | LocalReport |
Public Property | Location | Gets or sets the control location. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Gizmox.WebGUI.Forms.Control.GetPreferredSize can specify. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Gizmox.WebGUI.Forms.Control.GetPreferredSize can specify. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ProcessingMode |
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | PromptAreaCollapsed |
Public Property | Right | Gets/Sets the right position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ServerReport |
Public Property | ShowBackButton |
Public Property | ShowCredentialPrompts |
Public Property | ShowDocumentMapButton |
Public Property | ShowExportControls |
Public Property | ShowFindControls |
Public Property | ShowPageNavigationControls |
Public Property | ShowParameterPrompts |
Public Property | ShowPrintButton |
Public Property | ShowPromptAreaButton |
Public Property | ShowRefreshButton |
Public Property | ShowReportBody |
Public Property | ShowToolBar |
Public Property | ShowZoomControl |
Public Property | Site | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | SizeToReportContent |
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ToolBarItemBorderColor |
Public Property | ToolBarItemBorderStyle |
Public Property | ToolBarItemBorderWidth |
Public Property | ToolBarItemHoverBackColor |
Public Property | ToolBarItemPressedBorderColor |
Public Property | ToolBarItemPressedBorderStyle |
Public Property | ToolBarItemPressedBorderWidth |
Public Property | ToolBarItemPressedHoverBackColor |
Public Property | Top | Gets/Sets the top position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Visible | Gets or sets the control visability. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | WaitMessageFont |
Public Property | Width | Gets/Sets the width position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ZoomMode |
Public Property | ZoomPercent |
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultBorderColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultBorderStyle | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultForeColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMargin | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultPadding | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DesignMode | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | Events | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | HostedControl | Get the currently hosted control (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Protected Property | HostedControlType | Overridden.
Protected Property | HostedReportViewer |
Protected Property | IsConnected | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Property | IsDelayedDrawing | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | IsFixedSize | Gets a value indicating whether this instance is fixed size. (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | Session | Gets the application object. (Inherited from Gizmox.WebGUI.Forms.Component)
Top

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Focus | Sets focus to this control (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | GetPreferredSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | InvokeClientMethod | Invokes a client side method on the hosted control frame. (Inherited from Gizmox.WebGUI.Forms.FrameControl)
Public Method | JumpToBookmark |
Public Method | JumpToDocumentMapId |
Public Method | PerformBack |
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Reset | Overloaded. Resets the specified property.
Public Method | ResetText | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SendToBack | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Show | Displays the control to the user. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ToString | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Update | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | AddEventHandler | Add an event handler to one of the control's event infos. (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Protected Method | CreateControlsInstance | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | CreateHostPageBody | Creates the host page body control. (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Protected Method | CreateHostPageForm | Creates the host page form control. (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Protected Method | CreateHostPageHead | Creates the host page head control. (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Protected Method | Finalize | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetBoolProperty | Gets a hosted control boolean property value (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetColorProperty | Gets a hosted control color property value (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Protected Method | GetCommandText | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetEventInfo | Get an event information object. (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetImage | Gets the image. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetIntProperty | Gets a hosted control integer property value (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Protected Method | GetPreferredSizeCore | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetProperty | Gets a hosted control property value (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Protected Method | GetPropertyInfo | Get property info (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Protected Method | GetService | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | InvokeMethod | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | IsDirty | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Gizmox.WebGUI.Forms.Control.BackgroundImageLayoutChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBindingContextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnClick | Raises the Gizmox.WebGUI.Forms.Control.Click event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnControlAdded | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnControlRemoved | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnCreateControl | Raises the Gizmox.WebGUI.Forms.Control.CreateControl event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnCursorChanged | Raises the Gizmox.WebGUI.Forms.Control.CursorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnDoubleClick | Raises the Gizmox.WebGUI.Forms.Control.DoubleClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | OnEnabledChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnEnter | Raises the Gizmox.WebGUI.Forms.Control.Enter event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnFontChanged | Raises the Gizmox.WebGUI.Forms.DataGridView.FontChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnForeColorChanged | Raises the Gizmox.WebGUI.Forms.Control.ForeColorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnGotFocus | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHostedControlDataBinding | (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Protected Method | OnHostedControlDisposed | (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Protected Method | OnHostedControlInit | (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Protected Method | OnHostedControlLoad | (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Protected Method | OnHostedControlPreRender | (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Protected Method | OnHostedControlUnload | (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Protected Method | OnHostedPageDataBinding | (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Protected Method | OnHostedPageDisposed | (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Protected Method | OnHostedPageError | Called when hosted page throws error. (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Protected Method | OnHostedPageInit | (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Protected Method | OnHostedPageInitComplete | (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Protected Method | OnHostedPageLoad | Occurs when the hosting page is loaded. (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Protected Method | OnHostedPageLoadComplete | (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Protected Method | OnHostedPagePreInit | (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Protected Method | OnHostedPagePreLoad | (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Protected Method | OnHostedPagePreRender | (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Protected Method | OnHostedPagePreRenderComplete | (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Protected Method | OnKeyDown | Raises the Gizmox.WebGUI.Forms.Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyPress | Raises the Gizmox.WebGUI.Forms.Control.KeyPress event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyUp | Raises the Gizmox.WebGUI.Forms.Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLeave | Raises the Gizmox.WebGUI.Forms.Control.Leave event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLocationChanged | Raises the Gizmox.WebGUI.Forms.Control.LocationChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLostFocus | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseDown | Raises the Gizmox.WebGUI.Forms.Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseUp | Raises the Gizmox.WebGUI.Forms.Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentVisibleChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnResize | Raises the E:Resize event. (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Protected Method | OnTextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnUnregisterComponents | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnValidated | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnValidating | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnVisibleChanged | Raises the Gizmox.WebGUI.Forms.Control.VisibleChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ProcessGatewayRequest | Provides a way to handle gateway requests. (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Protected Method | RegisterBatch | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RegisterSelf | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RemoveEventHandler | Removes an event handler from one of the control's event infos. (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Protected Method | Render | An abstract control method rendering (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Protected Method | RenderAttributes | Render control attributes (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderClientUpdateHandler | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderComponentEventAttributes | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | RestoreState |
Protected Method | SetImage | Sets the image. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | SetProperty | Sets a hosted control property value (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeText | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | StoreState |
Protected Method | UnRegisterBatch | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | UnRegisterSelf | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | UpdateParams | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Top

Public Events

 | Name | Description
Public Event | Back |
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BookmarkNavigation |
Public Event | Click | Occurs on clicking the button. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | CursorChanged | Occurs when the value of the Gizmox.WebGUI.Forms.Control.Cursor property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Disposed | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Event | DocumentMapNavigation |
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Event | Drillthrough |
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | HostedControlDataBinding | (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Public Event | HostedControlDisposed | (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Public Event | HostedControlInit | (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Public Event | HostedControlLoad | (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Public Event | HostedControlPreRender | (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Public Event | HostedControlUnload | (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Public Event | HostedHostedPageDataBinding | (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Public Event | HostedPageDisposed | (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Public Event | HostedPageError | (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Public Event | HostedPageInitComplete | (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Public Event | HostedPageLoad | Occurs when the hosted control page loads (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Public Event | HostedPageLoadComplete | (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Public Event | HostedPagePageInit | (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Public Event | HostedPagePreInit | (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Public Event | HostedPagePreLoad | (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Public Event | HostedPagePreRender | (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Public Event | HostedPagePreRenderComplete | (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Gizmox.WebGUI.Forms.Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | PageNavigation |
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ReportError |
Public Event | ReportRefresh |
Public Event | Resize | Occurs when the control is resized. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Search |
Public Event | Sort |
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Toggle |
Public Event | VisibleChanged | Occurs when the Gizmox.WebGUI.Forms.Control.Visible property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Top

See Also

Reference

ReportViewer Class
Gizmox.WebGUI.Reporting Namespace


ReportViewer Constructor

[image]
Gizmox.WebGUI.Reporting
ReportViewer Constructor
See Also Send Feedback
Gizmox.WebGUI.Reporting Namespace > ReportViewer Class : ReportViewer Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As ReportViewer()
C#
public ReportViewer()
Managed Extensions for C++
public: ReportViewer();
C++/CLI
public:
ReportViewer();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ReportViewer Class
ReportViewer Members


ReportViewer Class Methods

[image]
Gizmox.WebGUI.Reporting
ReportViewer Class Methods
See Also Send Feedback
Gizmox.WebGUI.Reporting Namespace : ReportViewer Class

For a list of all members of this type, see ReportViewer members.

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Focus | Sets focus to this control (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | GetPreferredSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | InvokeClientMethod | Invokes a client side method on the hosted control frame. (Inherited from Gizmox.WebGUI.Forms.FrameControl)
Public Method | JumpToBookmark |
Public Method | JumpToDocumentMapId |
Public Method | PerformBack |
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Reset | Overloaded. Resets the specified property.
Public Method | ResetText | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SendToBack | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Show | Displays the control to the user. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ToString | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Update | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | AddEventHandler | Add an event handler to one of the control's event infos. (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Protected Method | CreateControlsInstance | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | CreateHostPageBody | Creates the host page body control. (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Protected Method | CreateHostPageForm | Creates the host page form control. (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Protected Method | CreateHostPageHead | Creates the host page head control. (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Protected Method | Finalize | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetBoolProperty | Gets a hosted control boolean property value (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetColorProperty | Gets a hosted control color property value (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Protected Method | GetCommandText | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetEventInfo | Get an event information object. (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetImage | Gets the image. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetIntProperty | Gets a hosted control integer property value (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Protected Method | GetPreferredSizeCore | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetProperty | Gets a hosted control property value (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Protected Method | GetPropertyInfo | Get property info (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Protected Method | GetService | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | InvokeMethod | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | IsDirty | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Gizmox.WebGUI.Forms.Control.BackgroundImageLayoutChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBindingContextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnClick | Raises the Gizmox.WebGUI.Forms.Control.Click event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnControlAdded | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnControlRemoved | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnCreateControl | Raises the Gizmox.WebGUI.Forms.Control.CreateControl event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnCursorChanged | Raises the Gizmox.WebGUI.Forms.Control.CursorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnDoubleClick | Raises the Gizmox.WebGUI.Forms.Control.DoubleClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | OnEnabledChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnEnter | Raises the Gizmox.WebGUI.Forms.Control.Enter event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnFontChanged | Raises the Gizmox.WebGUI.Forms.DataGridView.FontChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnForeColorChanged | Raises the Gizmox.WebGUI.Forms.Control.ForeColorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnGotFocus | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHostedControlDataBinding | (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Protected Method | OnHostedControlDisposed | (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Protected Method | OnHostedControlInit | (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Protected Method | OnHostedControlLoad | (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Protected Method | OnHostedControlPreRender | (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Protected Method | OnHostedControlUnload | (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Protected Method | OnHostedPageDataBinding | (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Protected Method | OnHostedPageDisposed | (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Protected Method | OnHostedPageError | Called when hosted page throws error. (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Protected Method | OnHostedPageInit | (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Protected Method | OnHostedPageInitComplete | (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Protected Method | OnHostedPageLoad | Occurs when the hosting page is loaded. (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Protected Method | OnHostedPageLoadComplete | (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Protected Method | OnHostedPagePreInit | (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Protected Method | OnHostedPagePreLoad | (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Protected Method | OnHostedPagePreRender | (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Protected Method | OnHostedPagePreRenderComplete | (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Protected Method | OnKeyDown | Raises the Gizmox.WebGUI.Forms.Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyPress | Raises the Gizmox.WebGUI.Forms.Control.KeyPress event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyUp | Raises the Gizmox.WebGUI.Forms.Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLeave | Raises the Gizmox.WebGUI.Forms.Control.Leave event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLocationChanged | Raises the Gizmox.WebGUI.Forms.Control.LocationChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLostFocus | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseDown | Raises the Gizmox.WebGUI.Forms.Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseUp | Raises the Gizmox.WebGUI.Forms.Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentVisibleChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnResize | Raises the E:Resize event. (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Protected Method | OnTextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnUnregisterComponents | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnValidated | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnValidating | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnVisibleChanged | Raises the Gizmox.WebGUI.Forms.Control.VisibleChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ProcessGatewayRequest | Provides a way to handle gateway requests. (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Protected Method | RegisterBatch | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RegisterSelf | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RemoveEventHandler | Removes an event handler from one of the control's event infos. (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Protected Method | Render | An abstract control method rendering (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Protected Method | RenderAttributes | Render control attributes (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderClientUpdateHandler | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderComponentEventAttributes | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | RestoreState |
Protected Method | SetImage | Sets the image. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | SetProperty | Sets a hosted control property value (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeText | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | StoreState |
Protected Method | UnRegisterBatch | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | UnRegisterSelf | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | UpdateParams | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Top

See Also

Reference

ReportViewer Class
Gizmox.WebGUI.Reporting Namespace


JumpToBookmark Method

[image]
Gizmox.WebGUI.Reporting
JumpToBookmark Method
See Also Send Feedback
Gizmox.WebGUI.Reporting Namespace > ReportViewer Class : JumpToBookmark Method

bookmarkId

Syntax

Visual Basic (Declaration)
Public Sub JumpToBookmark( _
   ByVal bookmarkId As String _
)
Visual Basic (Usage) Copy Code
Dim instance As ReportViewer
Dim bookmarkId As String

instance.JumpToBookmark(bookmarkId)
C#
public void JumpToBookmark(
   string bookmarkId
)
Managed Extensions for C++
public: void JumpToBookmark(
   string* bookmarkId
)
C++/CLI
public:
void JumpToBookmark(
   String^ bookmarkId
)

Parameters

bookmarkId

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ReportViewer Class
ReportViewer Members


JumpToDocumentMapId Method

[image]
Gizmox.WebGUI.Reporting
JumpToDocumentMapId Method
See Also Send Feedback
Gizmox.WebGUI.Reporting Namespace > ReportViewer Class : JumpToDocumentMapId Method

documentMapId

Syntax

Visual Basic (Declaration)
Public Sub JumpToDocumentMapId( _
   ByVal documentMapId As String _
)
Visual Basic (Usage) Copy Code
Dim instance As ReportViewer
Dim documentMapId As String

instance.JumpToDocumentMapId(documentMapId)
C#
public void JumpToDocumentMapId(
   string documentMapId
)
Managed Extensions for C++
public: void JumpToDocumentMapId(
   string* documentMapId
)
C++/CLI
public:
void JumpToDocumentMapId(
   String^ documentMapId
)

Parameters

documentMapId

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ReportViewer Class
ReportViewer Members


PerformBack Method

[image]
Gizmox.WebGUI.Reporting
PerformBack Method
See Also Send Feedback
Gizmox.WebGUI.Reporting Namespace > ReportViewer Class : PerformBack Method

Syntax

Visual Basic (Declaration)
Public Sub PerformBack()
Visual Basic (Usage) Copy Code
Dim instance As ReportViewer

instance.PerformBack()
C#
public void PerformBack()
Managed Extensions for C++
public: void PerformBack();
C++/CLI
public:
void PerformBack();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ReportViewer Class
ReportViewer Members


Reset Method

[image]
Gizmox.WebGUI.Reporting
Reset Method
See Also Send Feedback
Gizmox.WebGUI.Reporting Namespace > ReportViewer Class : Reset Method

Resets the specified property.

Overload List

Overload | Description
Reset() |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ReportViewer Class
ReportViewer Members


Reset() Method

[image]
Gizmox.WebGUI.Reporting
Reset() Method
See Also Send Feedback
Gizmox.WebGUI.Reporting Namespace > ReportViewer Class > Reset Method : Reset() Method

Syntax

Visual Basic (Declaration)
Public Overloads Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As ReportViewer

instance.Reset()
C#
public void Reset()
Managed Extensions for C++
public: void Reset();
C++/CLI
public:
void Reset();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ReportViewer Class
ReportViewer Members
Overload List


RestoreState Method

[image]
Gizmox.WebGUI.Reporting
RestoreState Method
See Also Send Feedback
Gizmox.WebGUI.Reporting Namespace > ReportViewer Class : RestoreState Method

Syntax

Visual Basic (Declaration)
Protected Overridable Sub RestoreState()
Visual Basic (Usage) Copy Code
Dim instance As ReportViewer

instance.RestoreState()
C#
protected virtual void RestoreState()
Managed Extensions for C++
protected: virtual void RestoreState();
C++/CLI
protected:
virtual void RestoreState();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ReportViewer Class
ReportViewer Members


StoreState Method

[image]
Gizmox.WebGUI.Reporting
StoreState Method
See Also Send Feedback
Gizmox.WebGUI.Reporting Namespace > ReportViewer Class : StoreState Method

Syntax

Visual Basic (Declaration)
Protected Overridable Sub StoreState()
Visual Basic (Usage) Copy Code
Dim instance As ReportViewer

instance.StoreState()
C#
protected virtual void StoreState()
Managed Extensions for C++
protected: virtual void StoreState();
C++/CLI
protected:
virtual void StoreState();

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ReportViewer Class
ReportViewer Members


ReportViewer Class Properties

[image]
Gizmox.WebGUI.Reporting
ReportViewer Class Properties
See Also Send Feedback
Gizmox.WebGUI.Reporting Namespace : ReportViewer Class

For a list of all members of this type, see ReportViewer members.

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | AsyncRendering |
Public Property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Public Property | BackColor | Overridden.
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the Gizmox.WebGUI.Forms.ImageLayout enumeration. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BindingContext | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Container | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Context | Gets the context. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ControlCode | Gets or sets the control code. (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Public Property | ControlID | Gets or sets the control ID, which indicates the id of the hosted control with in the control code. (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CurrentPage |
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Disposing | Gets a value indicating whether the base Gizmox.WebGUI.Forms.Control class is in the process of disposing. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | DocumentMapCollapsed |
Public Property | DocumentMapWidth |
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Form | Gets the owner form. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Height | Gets/Sets the height position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | HyperlinkTarget |
Public Property | InternalBorderColor |
Public Property | InternalBorderStyle |
Public Property | InternalBorderWidth |
Public Property | InternalParent | Gets the parent of this component. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | IsAspRequest | Gets a value indicating whether this is ASP request. (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | IsRegistered | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Left | Gets/Sets the left position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | LinkActiveColor |
Public Property | LinkActiveHoverColor |
Public Property | LinkDisabledColor |
Public Property | LocalReport |
Public Property | Location | Gets or sets the control location. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Gizmox.WebGUI.Forms.Control.GetPreferredSize can specify. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Gizmox.WebGUI.Forms.Control.GetPreferredSize can specify. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ProcessingMode |
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | PromptAreaCollapsed |
Public Property | Right | Gets/Sets the right position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ServerReport |
Public Property | ShowBackButton |
Public Property | ShowCredentialPrompts |
Public Property | ShowDocumentMapButton |
Public Property | ShowExportControls |
Public Property | ShowFindControls |
Public Property | ShowPageNavigationControls |
Public Property | ShowParameterPrompts |
Public Property | ShowPrintButton |
Public Property | ShowPromptAreaButton |
Public Property | ShowRefreshButton |
Public Property | ShowReportBody |
Public Property | ShowToolBar |
Public Property | ShowZoomControl |
Public Property | Site | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | SizeToReportContent |
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ToolBarItemBorderColor |
Public Property | ToolBarItemBorderStyle |
Public Property | ToolBarItemBorderWidth |
Public Property | ToolBarItemHoverBackColor |
Public Property | ToolBarItemPressedBorderColor |
Public Property | ToolBarItemPressedBorderStyle |
Public Property | ToolBarItemPressedBorderWidth |
Public Property | ToolBarItemPressedHoverBackColor |
Public Property | Top | Gets/Sets the top position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Visible | Gets or sets the control visability. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | WaitMessageFont |
Public Property | Width | Gets/Sets the width position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ZoomMode |
Public Property | ZoomPercent |
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultBorderColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultBorderStyle | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultForeColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMargin | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultPadding | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DesignMode | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | Events | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | HostedControl | Get the currently hosted control (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Protected Property | HostedControlType | Overridden.
Protected Property | HostedReportViewer |
Protected Property | IsConnected | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Property | IsDelayedDrawing | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | IsFixedSize | Gets a value indicating whether this instance is fixed size. (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | Session | Gets the application object. (Inherited from Gizmox.WebGUI.Forms.Component)
Top

See Also

Reference

ReportViewer Class
Gizmox.WebGUI.Reporting Namespace


AsyncRendering Property

[image]
Gizmox.WebGUI.Reporting
AsyncRendering Property
See Also Send Feedback
Gizmox.WebGUI.Reporting Namespace > ReportViewer Class : AsyncRendering Property

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<WebBrowsableAttribute()>
<SRDescriptionAttribute("")>
<CategoryAttribute()>
Public Property AsyncRendering As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ReportViewer
Dim value As Boolean

instance.AsyncRendering = value

value = instance.AsyncRendering
C#
[DefaultValueAttribute()]
[WebBrowsableAttribute()]
[SRDescriptionAttribute("")]
[CategoryAttribute()]
public bool AsyncRendering {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[WebBrowsableAttribute()]
[SRDescriptionAttribute("")]
[CategoryAttribute()]
public: __property bool get_AsyncRendering();
public: __property void set_AsyncRendering(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
[WebBrowsableAttribute()]
[SRDescriptionAttribute("")]
[CategoryAttribute()]
public:
property bool AsyncRendering {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ReportViewer Class
ReportViewer Members


BackColor Property

[image]
Gizmox.WebGUI.Reporting
BackColor Property
See Also Send Feedback
Gizmox.WebGUI.Reporting Namespace > ReportViewer Class : BackColor Property

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
Public Overrides Property BackColor As Color
Visual Basic (Usage) Copy Code
Dim instance As ReportViewer
Dim value As Color

instance.BackColor = value

value = instance.BackColor
C#
[DefaultValueAttribute()]
public override Color BackColor {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
public: __property Color get_BackColor() override;
public: __property void set_BackColor(
   Color value
) override;
C++/CLI
[DefaultValueAttribute()]
public:
property Color BackColor {
   Color get() override;
   void set (Colorvalue) override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ReportViewer Class
ReportViewer Members


CurrentPage Property

[image]
Gizmox.WebGUI.Reporting
CurrentPage Property
See Also Send Feedback
Gizmox.WebGUI.Reporting Namespace > ReportViewer Class : CurrentPage Property

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute()>
<BrowsableAttribute(False)>
Public Property CurrentPage As Integer
Visual Basic (Usage) Copy Code
Dim instance As ReportViewer
Dim value As Integer

instance.CurrentPage = value

value = instance.CurrentPage
C#
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public int CurrentPage {get; set;}
Managed Extensions for C++
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public: __property int get_CurrentPage();
public: __property void set_CurrentPage(
   int value
);
C++/CLI
[DesignerSerializationVisibilityAttribute()]
[BrowsableAttribute(false)]
public:
property int CurrentPage {
   int get();
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ReportViewer Class
ReportViewer Members


DocumentMapCollapsed Property

[image]
Gizmox.WebGUI.Reporting
DocumentMapCollapsed Property
See Also Send Feedback
Gizmox.WebGUI.Reporting Namespace > ReportViewer Class : DocumentMapCollapsed Property

Syntax

Visual Basic (Declaration)
<WebBrowsableAttribute()>
<DefaultValueAttribute()>
<SRDescriptionAttribute("")>
<CategoryAttribute("ToolBar")>
Public Property DocumentMapCollapsed As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ReportViewer
Dim value As Boolean

instance.DocumentMapCollapsed = value

value = instance.DocumentMapCollapsed
C#
[WebBrowsableAttribute()]
[DefaultValueAttribute()]
[SRDescriptionAttribute("")]
[CategoryAttribute("ToolBar")]
public bool DocumentMapCollapsed {get; set;}
Managed Extensions for C++
[WebBrowsableAttribute()]
[DefaultValueAttribute()]
[SRDescriptionAttribute("")]
[CategoryAttribute("ToolBar")]
public: __property bool get_DocumentMapCollapsed();
public: __property void set_DocumentMapCollapsed(
   bool value
);
C++/CLI
[WebBrowsableAttribute()]
[DefaultValueAttribute()]
[SRDescriptionAttribute("")]
[CategoryAttribute("ToolBar")]
public:
property bool DocumentMapCollapsed {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ReportViewer Class
ReportViewer Members


DocumentMapWidth Property

[image]
Gizmox.WebGUI.Reporting
DocumentMapWidth Property
See Also Send Feedback
Gizmox.WebGUI.Reporting Namespace > ReportViewer Class : DocumentMapWidth Property

Syntax

Visual Basic (Declaration)
<WebBrowsableAttribute()>
<SRDescriptionAttribute("")>
<DefaultValueAttribute()>
<CategoryAttribute("Appearance")>
Public Property DocumentMapWidth As Unit
Visual Basic (Usage) Copy Code
Dim instance As ReportViewer
Dim value As Unit

instance.DocumentMapWidth = value

value = instance.DocumentMapWidth
C#
[WebBrowsableAttribute()]
[SRDescriptionAttribute("")]
[DefaultValueAttribute()]
[CategoryAttribute("Appearance")]
public Unit DocumentMapWidth {get; set;}
Managed Extensions for C++
[WebBrowsableAttribute()]
[SRDescriptionAttribute("")]
[DefaultValueAttribute()]
[CategoryAttribute("Appearance")]
public: __property Unit get_DocumentMapWidth();
public: __property void set_DocumentMapWidth(
   Unit value
);
C++/CLI
[WebBrowsableAttribute()]
[SRDescriptionAttribute("")]
[DefaultValueAttribute()]
[CategoryAttribute("Appearance")]
public:
property Unit DocumentMapWidth {
   Unit get();
   void set (Unitvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ReportViewer Class
ReportViewer Members


HostedControlType Property

[image]
Gizmox.WebGUI.Reporting
HostedControlType Property
See Also Send Feedback
Gizmox.WebGUI.Reporting Namespace > ReportViewer Class : HostedControlType Property

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property HostedControlType As Type
Visual Basic (Usage) Copy Code
Dim instance As ReportViewer
Dim value As Type

value = instance.HostedControlType
C#
protected override Type HostedControlType {get;}
Managed Extensions for C++
protected: __property Type* get_HostedControlType() override;
C++/CLI
protected:
property Type^ HostedControlType {
   Type^ get() override;
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ReportViewer Class
ReportViewer Members


HostedReportViewer Property

[image]
Gizmox.WebGUI.Reporting
HostedReportViewer Property
See Also Send Feedback
Gizmox.WebGUI.Reporting Namespace > ReportViewer Class : HostedReportViewer Property

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property HostedReportViewer As ReportViewer
Visual Basic (Usage) Copy Code
Dim instance As ReportViewer
Dim value As ReportViewer

value = instance.HostedReportViewer
C#
protected ReportViewer HostedReportViewer {get;}
Managed Extensions for C++
protected: __property ReportViewer* get_HostedReportViewer();
C++/CLI
protected:
property ReportViewer^ HostedReportViewer {
   ReportViewer^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ReportViewer Class
ReportViewer Members


HyperlinkTarget Property

[image]
Gizmox.WebGUI.Reporting
HyperlinkTarget Property
See Also Send Feedback
Gizmox.WebGUI.Reporting Namespace > ReportViewer Class : HyperlinkTarget Property

Syntax

Visual Basic (Declaration)
<CategoryAttribute()>
<DefaultValueAttribute()>
<WebBrowsableAttribute()>
<SRDescriptionAttribute("")>
Public Property HyperlinkTarget As String
Visual Basic (Usage) Copy Code
Dim instance As ReportViewer
Dim value As String

instance.HyperlinkTarget = value

value = instance.HyperlinkTarget
C#
[CategoryAttribute()]
[DefaultValueAttribute()]
[WebBrowsableAttribute()]
[SRDescriptionAttribute("")]
public string HyperlinkTarget {get; set;}
Managed Extensions for C++
[CategoryAttribute()]
[DefaultValueAttribute()]
[WebBrowsableAttribute()]
[SRDescriptionAttribute("")]
public: __property string* get_HyperlinkTarget();
public: __property void set_HyperlinkTarget(
   string* value
);
C++/CLI
[CategoryAttribute()]
[DefaultValueAttribute()]
[WebBrowsableAttribute()]
[SRDescriptionAttribute("")]
public:
property String^ HyperlinkTarget {
   String^ get();
   void set (String^value);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ReportViewer Class
ReportViewer Members


InternalBorderColor Property

[image]
Gizmox.WebGUI.Reporting
InternalBorderColor Property
See Also Send Feedback
Gizmox.WebGUI.Reporting Namespace > ReportViewer Class : InternalBorderColor Property

Syntax

Visual Basic (Declaration)
<WebBrowsableAttribute()>
<DefaultValueAttribute()>
<CategoryAttribute("Appearance")>
<SRDescriptionAttribute("")>
Public Property InternalBorderColor As Color
Visual Basic (Usage) Copy Code
Dim instance As ReportViewer
Dim value As Color

instance.InternalBorderColor = value

value = instance.InternalBorderColor
C#
[WebBrowsableAttribute()]
[DefaultValueAttribute()]
[CategoryAttribute("Appearance")]
[SRDescriptionAttribute("")]
public Color InternalBorderColor {get; set;}
Managed Extensions for C++
[WebBrowsableAttribute()]
[DefaultValueAttribute()]
[CategoryAttribute("Appearance")]
[SRDescriptionAttribute("")]
public: __property Color get_InternalBorderColor();
public: __property void set_InternalBorderColor(
   Color value
);
C++/CLI
[WebBrowsableAttribute()]
[DefaultValueAttribute()]
[CategoryAttribute("Appearance")]
[SRDescriptionAttribute("")]
public:
property Color InternalBorderColor {
   Color get();
   void set (Colorvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ReportViewer Class
ReportViewer Members


InternalBorderStyle Property

[image]
Gizmox.WebGUI.Reporting
InternalBorderStyle Property
See Also Send Feedback
Gizmox.WebGUI.Reporting Namespace > ReportViewer Class : InternalBorderStyle Property

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("")>
<CategoryAttribute("Appearance")>
<WebBrowsableAttribute()>
<DefaultValueAttribute()>
Public Property InternalBorderStyle As BorderStyle
Visual Basic (Usage) Copy Code
Dim instance As ReportViewer
Dim value As BorderStyle

instance.InternalBorderStyle = value

value = instance.InternalBorderStyle
C#
[SRDescriptionAttribute("")]
[CategoryAttribute("Appearance")]
[WebBrowsableAttribute()]
[DefaultValueAttribute()]
public BorderStyle InternalBorderStyle {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("")]
[CategoryAttribute("Appearance")]
[WebBrowsableAttribute()]
[DefaultValueAttribute()]
public: __property BorderStyle get_InternalBorderStyle();
public: __property void set_InternalBorderStyle(
   BorderStyle value
);
C++/CLI
[SRDescriptionAttribute("")]
[CategoryAttribute("Appearance")]
[WebBrowsableAttribute()]
[DefaultValueAttribute()]
public:
property BorderStyle InternalBorderStyle {
   BorderStyle get();
   void set (BorderStylevalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ReportViewer Class
ReportViewer Members


InternalBorderWidth Property

[image]
Gizmox.WebGUI.Reporting
InternalBorderWidth Property
See Also Send Feedback
Gizmox.WebGUI.Reporting Namespace > ReportViewer Class : InternalBorderWidth Property

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Appearance")>
<SRDescriptionAttribute("")>
<DefaultValueAttribute()>
<WebBrowsableAttribute()>
Public Property InternalBorderWidth As Unit
Visual Basic (Usage) Copy Code
Dim instance As ReportViewer
Dim value As Unit

instance.InternalBorderWidth = value

value = instance.InternalBorderWidth
C#
[CategoryAttribute("Appearance")]
[SRDescriptionAttribute("")]
[DefaultValueAttribute()]
[WebBrowsableAttribute()]
public Unit InternalBorderWidth {get; set;}
Managed Extensions for C++
[CategoryAttribute("Appearance")]
[SRDescriptionAttribute("")]
[DefaultValueAttribute()]
[WebBrowsableAttribute()]
public: __property Unit get_InternalBorderWidth();
public: __property void set_InternalBorderWidth(
   Unit value
);
C++/CLI
[CategoryAttribute("Appearance")]
[SRDescriptionAttribute("")]
[DefaultValueAttribute()]
[WebBrowsableAttribute()]
public:
property Unit InternalBorderWidth {
   Unit get();
   void set (Unitvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ReportViewer Class
ReportViewer Members


LinkActiveColor Property

[image]
Gizmox.WebGUI.Reporting
LinkActiveColor Property
See Also Send Feedback
Gizmox.WebGUI.Reporting Namespace > ReportViewer Class : LinkActiveColor Property

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("")>
<CategoryAttribute("Appearance")>
<WebBrowsableAttribute()>
<DefaultValueAttribute()>
Public Property LinkActiveColor As Color
Visual Basic (Usage) Copy Code
Dim instance As ReportViewer
Dim value As Color

instance.LinkActiveColor = value

value = instance.LinkActiveColor
C#
[SRDescriptionAttribute("")]
[CategoryAttribute("Appearance")]
[WebBrowsableAttribute()]
[DefaultValueAttribute()]
public Color LinkActiveColor {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("")]
[CategoryAttribute("Appearance")]
[WebBrowsableAttribute()]
[DefaultValueAttribute()]
public: __property Color get_LinkActiveColor();
public: __property void set_LinkActiveColor(
   Color value
);
C++/CLI
[SRDescriptionAttribute("")]
[CategoryAttribute("Appearance")]
[WebBrowsableAttribute()]
[DefaultValueAttribute()]
public:
property Color LinkActiveColor {
   Color get();
   void set (Colorvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ReportViewer Class
ReportViewer Members


LinkActiveHoverColor Property

[image]
Gizmox.WebGUI.Reporting
LinkActiveHoverColor Property
See Also Send Feedback
Gizmox.WebGUI.Reporting Namespace > ReportViewer Class : LinkActiveHoverColor Property

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<CategoryAttribute("Appearance")>
<SRDescriptionAttribute("")>
<WebBrowsableAttribute()>
Public Property LinkActiveHoverColor As Color
Visual Basic (Usage) Copy Code
Dim instance As ReportViewer
Dim value As Color

instance.LinkActiveHoverColor = value

value = instance.LinkActiveHoverColor
C#
[DefaultValueAttribute()]
[CategoryAttribute("Appearance")]
[SRDescriptionAttribute("")]
[WebBrowsableAttribute()]
public Color LinkActiveHoverColor {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[CategoryAttribute("Appearance")]
[SRDescriptionAttribute("")]
[WebBrowsableAttribute()]
public: __property Color get_LinkActiveHoverColor();
public: __property void set_LinkActiveHoverColor(
   Color value
);
C++/CLI
[DefaultValueAttribute()]
[CategoryAttribute("Appearance")]
[SRDescriptionAttribute("")]
[WebBrowsableAttribute()]
public:
property Color LinkActiveHoverColor {
   Color get();
   void set (Colorvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ReportViewer Class
ReportViewer Members


LinkDisabledColor Property

[image]
Gizmox.WebGUI.Reporting
LinkDisabledColor Property
See Also Send Feedback
Gizmox.WebGUI.Reporting Namespace > ReportViewer Class : LinkDisabledColor Property

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<SRDescriptionAttribute("")>
<CategoryAttribute("Appearance")>
<WebBrowsableAttribute()>
Public Property LinkDisabledColor As Color
Visual Basic (Usage) Copy Code
Dim instance As ReportViewer
Dim value As Color

instance.LinkDisabledColor = value

value = instance.LinkDisabledColor
C#
[DefaultValueAttribute()]
[SRDescriptionAttribute("")]
[CategoryAttribute("Appearance")]
[WebBrowsableAttribute()]
public Color LinkDisabledColor {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[SRDescriptionAttribute("")]
[CategoryAttribute("Appearance")]
[WebBrowsableAttribute()]
public: __property Color get_LinkDisabledColor();
public: __property void set_LinkDisabledColor(
   Color value
);
C++/CLI
[DefaultValueAttribute()]
[SRDescriptionAttribute("")]
[CategoryAttribute("Appearance")]
[WebBrowsableAttribute()]
public:
property Color LinkDisabledColor {
   Color get();
   void set (Colorvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ReportViewer Class
ReportViewer Members


LocalReport Property

[image]
Gizmox.WebGUI.Reporting
LocalReport Property
See Also Send Feedback
Gizmox.WebGUI.Reporting Namespace > ReportViewer Class : LocalReport Property

Syntax

Visual Basic (Declaration)
<PersistenceModeAttribute()>
<BrowsableAttribute(False)>
<NotifyParentPropertyAttribute(True)>
<SRDescriptionAttribute("")>
<CategoryAttribute()>
Public ReadOnly Property LocalReport As LocalReport
Visual Basic (Usage) Copy Code
Dim instance As ReportViewer
Dim value As LocalReport

value = instance.LocalReport
C#
[PersistenceModeAttribute()]
[BrowsableAttribute(false)]
[NotifyParentPropertyAttribute(true)]
[SRDescriptionAttribute("")]
[CategoryAttribute()]
public LocalReport LocalReport {get;}
Managed Extensions for C++
[PersistenceModeAttribute()]
[BrowsableAttribute(false)]
[NotifyParentPropertyAttribute(true)]
[SRDescriptionAttribute("")]
[CategoryAttribute()]
public: __property LocalReport* get_LocalReport();
C++/CLI
[PersistenceModeAttribute()]
[BrowsableAttribute(false)]
[NotifyParentPropertyAttribute(true)]
[SRDescriptionAttribute("")]
[CategoryAttribute()]
public:
property LocalReport^ LocalReport {
   LocalReport^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ReportViewer Class
ReportViewer Members


ProcessingMode Property

[image]
Gizmox.WebGUI.Reporting
ProcessingMode Property
See Also Send Feedback
Gizmox.WebGUI.Reporting Namespace > ReportViewer Class : ProcessingMode Property

Syntax

Visual Basic (Declaration)
<WebBrowsableAttribute()>
<DesignerSerializationVisibilityAttribute()>
<CategoryAttribute()>
<DefaultValueAttribute()>
<SRDescriptionAttribute("")>
Public Property ProcessingMode As ProcessingMode
Visual Basic (Usage) Copy Code
Dim instance As ReportViewer
Dim value As ProcessingMode

instance.ProcessingMode = value

value = instance.ProcessingMode
C#
[WebBrowsableAttribute()]
[DesignerSerializationVisibilityAttribute()]
[CategoryAttribute()]
[DefaultValueAttribute()]
[SRDescriptionAttribute("")]
public ProcessingMode ProcessingMode {get; set;}
Managed Extensions for C++
[WebBrowsableAttribute()]
[DesignerSerializationVisibilityAttribute()]
[CategoryAttribute()]
[DefaultValueAttribute()]
[SRDescriptionAttribute("")]
public: __property ProcessingMode get_ProcessingMode();
public: __property void set_ProcessingMode(
   ProcessingMode value
);
C++/CLI
[WebBrowsableAttribute()]
[DesignerSerializationVisibilityAttribute()]
[CategoryAttribute()]
[DefaultValueAttribute()]
[SRDescriptionAttribute("")]
public:
property ProcessingMode ProcessingMode {
   ProcessingMode get();
   void set (ProcessingModevalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ReportViewer Class
ReportViewer Members


PromptAreaCollapsed Property

[image]
Gizmox.WebGUI.Reporting
PromptAreaCollapsed Property
See Also Send Feedback
Gizmox.WebGUI.Reporting Namespace > ReportViewer Class : PromptAreaCollapsed Property

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<SRDescriptionAttribute("")>
<WebBrowsableAttribute()>
<CategoryAttribute("Appearance")>
Public Property PromptAreaCollapsed As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ReportViewer
Dim value As Boolean

instance.PromptAreaCollapsed = value

value = instance.PromptAreaCollapsed
C#
[DefaultValueAttribute()]
[SRDescriptionAttribute("")]
[WebBrowsableAttribute()]
[CategoryAttribute("Appearance")]
public bool PromptAreaCollapsed {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[SRDescriptionAttribute("")]
[WebBrowsableAttribute()]
[CategoryAttribute("Appearance")]
public: __property bool get_PromptAreaCollapsed();
public: __property void set_PromptAreaCollapsed(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
[SRDescriptionAttribute("")]
[WebBrowsableAttribute()]
[CategoryAttribute("Appearance")]
public:
property bool PromptAreaCollapsed {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ReportViewer Class
ReportViewer Members


ServerReport Property

[image]
Gizmox.WebGUI.Reporting
ServerReport Property
See Also Send Feedback
Gizmox.WebGUI.Reporting Namespace > ReportViewer Class : ServerReport Property

Syntax

Visual Basic (Declaration)
<NotifyParentPropertyAttribute(True)>
<CategoryAttribute()>
<PersistenceModeAttribute()>
<BrowsableAttribute(False)>
<SRDescriptionAttribute("")>
Public ReadOnly Property ServerReport As ServerReport
Visual Basic (Usage) Copy Code
Dim instance As ReportViewer
Dim value As ServerReport

value = instance.ServerReport
C#
[NotifyParentPropertyAttribute(true)]
[CategoryAttribute()]
[PersistenceModeAttribute()]
[BrowsableAttribute(false)]
[SRDescriptionAttribute("")]
public ServerReport ServerReport {get;}
Managed Extensions for C++
[NotifyParentPropertyAttribute(true)]
[CategoryAttribute()]
[PersistenceModeAttribute()]
[BrowsableAttribute(false)]
[SRDescriptionAttribute("")]
public: __property ServerReport* get_ServerReport();
C++/CLI
[NotifyParentPropertyAttribute(true)]
[CategoryAttribute()]
[PersistenceModeAttribute()]
[BrowsableAttribute(false)]
[SRDescriptionAttribute("")]
public:
property ServerReport^ ServerReport {
   ServerReport^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ReportViewer Class
ReportViewer Members


ShowBackButton Property

[image]
Gizmox.WebGUI.Reporting
ShowBackButton Property
See Also Send Feedback
Gizmox.WebGUI.Reporting Namespace > ReportViewer Class : ShowBackButton Property

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<CategoryAttribute("ToolBar")>
<SRDescriptionAttribute("")>
<WebBrowsableAttribute()>
Public Property ShowBackButton As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ReportViewer
Dim value As Boolean

instance.ShowBackButton = value

value = instance.ShowBackButton
C#
[DefaultValueAttribute()]
[CategoryAttribute("ToolBar")]
[SRDescriptionAttribute("")]
[WebBrowsableAttribute()]
public bool ShowBackButton {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[CategoryAttribute("ToolBar")]
[SRDescriptionAttribute("")]
[WebBrowsableAttribute()]
public: __property bool get_ShowBackButton();
public: __property void set_ShowBackButton(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
[CategoryAttribute("ToolBar")]
[SRDescriptionAttribute("")]
[WebBrowsableAttribute()]
public:
property bool ShowBackButton {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ReportViewer Class
ReportViewer Members


ShowCredentialPrompts Property

[image]
Gizmox.WebGUI.Reporting
ShowCredentialPrompts Property
See Also Send Feedback
Gizmox.WebGUI.Reporting Namespace > ReportViewer Class : ShowCredentialPrompts Property

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("")>
<CategoryAttribute("Appearance")>
<DefaultValueAttribute()>
<WebBrowsableAttribute()>
Public Property ShowCredentialPrompts As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ReportViewer
Dim value As Boolean

instance.ShowCredentialPrompts = value

value = instance.ShowCredentialPrompts
C#
[SRDescriptionAttribute("")]
[CategoryAttribute("Appearance")]
[DefaultValueAttribute()]
[WebBrowsableAttribute()]
public bool ShowCredentialPrompts {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("")]
[CategoryAttribute("Appearance")]
[DefaultValueAttribute()]
[WebBrowsableAttribute()]
public: __property bool get_ShowCredentialPrompts();
public: __property void set_ShowCredentialPrompts(
   bool value
);
C++/CLI
[SRDescriptionAttribute("")]
[CategoryAttribute("Appearance")]
[DefaultValueAttribute()]
[WebBrowsableAttribute()]
public:
property bool ShowCredentialPrompts {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ReportViewer Class
ReportViewer Members


ShowDocumentMapButton Property

[image]
Gizmox.WebGUI.Reporting
ShowDocumentMapButton Property
See Also Send Feedback
Gizmox.WebGUI.Reporting Namespace > ReportViewer Class : ShowDocumentMapButton Property

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("")>
<DefaultValueAttribute()>
<WebBrowsableAttribute()>
<CategoryAttribute("ToolBar")>
Public Property ShowDocumentMapButton As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ReportViewer
Dim value As Boolean

instance.ShowDocumentMapButton = value

value = instance.ShowDocumentMapButton
C#
[SRDescriptionAttribute("")]
[DefaultValueAttribute()]
[WebBrowsableAttribute()]
[CategoryAttribute("ToolBar")]
public bool ShowDocumentMapButton {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("")]
[DefaultValueAttribute()]
[WebBrowsableAttribute()]
[CategoryAttribute("ToolBar")]
public: __property bool get_ShowDocumentMapButton();
public: __property void set_ShowDocumentMapButton(
   bool value
);
C++/CLI
[SRDescriptionAttribute("")]
[DefaultValueAttribute()]
[WebBrowsableAttribute()]
[CategoryAttribute("ToolBar")]
public:
property bool ShowDocumentMapButton {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ReportViewer Class
ReportViewer Members


ShowExportControls Property

[image]
Gizmox.WebGUI.Reporting
ShowExportControls Property
See Also Send Feedback
Gizmox.WebGUI.Reporting Namespace > ReportViewer Class : ShowExportControls Property

Syntax

Visual Basic (Declaration)
<WebBrowsableAttribute()>
<CategoryAttribute("ToolBar")>
<DefaultValueAttribute()>
<SRDescriptionAttribute("")>
Public Property ShowExportControls As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ReportViewer
Dim value As Boolean

instance.ShowExportControls = value

value = instance.ShowExportControls
C#
[WebBrowsableAttribute()]
[CategoryAttribute("ToolBar")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("")]
public bool ShowExportControls {get; set;}
Managed Extensions for C++
[WebBrowsableAttribute()]
[CategoryAttribute("ToolBar")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("")]
public: __property bool get_ShowExportControls();
public: __property void set_ShowExportControls(
   bool value
);
C++/CLI
[WebBrowsableAttribute()]
[CategoryAttribute("ToolBar")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("")]
public:
property bool ShowExportControls {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ReportViewer Class
ReportViewer Members


ShowFindControls Property

[image]
Gizmox.WebGUI.Reporting
ShowFindControls Property
See Also Send Feedback
Gizmox.WebGUI.Reporting Namespace > ReportViewer Class : ShowFindControls Property

Syntax

Visual Basic (Declaration)
<CategoryAttribute("ToolBar")>
<SRDescriptionAttribute("")>
<WebBrowsableAttribute()>
<DefaultValueAttribute()>
Public Property ShowFindControls As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ReportViewer
Dim value As Boolean

instance.ShowFindControls = value

value = instance.ShowFindControls
C#
[CategoryAttribute("ToolBar")]
[SRDescriptionAttribute("")]
[WebBrowsableAttribute()]
[DefaultValueAttribute()]
public bool ShowFindControls {get; set;}
Managed Extensions for C++
[CategoryAttribute("ToolBar")]
[SRDescriptionAttribute("")]
[WebBrowsableAttribute()]
[DefaultValueAttribute()]
public: __property bool get_ShowFindControls();
public: __property void set_ShowFindControls(
   bool value
);
C++/CLI
[CategoryAttribute("ToolBar")]
[SRDescriptionAttribute("")]
[WebBrowsableAttribute()]
[DefaultValueAttribute()]
public:
property bool ShowFindControls {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ReportViewer Class
ReportViewer Members


ShowPageNavigationControls Property

[image]
Gizmox.WebGUI.Reporting
ShowPageNavigationControls Property
See Also Send Feedback
Gizmox.WebGUI.Reporting Namespace > ReportViewer Class : ShowPageNavigationControls Property

Syntax

Visual Basic (Declaration)
<WebBrowsableAttribute()>
<DefaultValueAttribute()>
<SRDescriptionAttribute("")>
<CategoryAttribute("ToolBar")>
Public Property ShowPageNavigationControls As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ReportViewer
Dim value As Boolean

instance.ShowPageNavigationControls = value

value = instance.ShowPageNavigationControls
C#
[WebBrowsableAttribute()]
[DefaultValueAttribute()]
[SRDescriptionAttribute("")]
[CategoryAttribute("ToolBar")]
public bool ShowPageNavigationControls {get; set;}
Managed Extensions for C++
[WebBrowsableAttribute()]
[DefaultValueAttribute()]
[SRDescriptionAttribute("")]
[CategoryAttribute("ToolBar")]
public: __property bool get_ShowPageNavigationControls();
public: __property void set_ShowPageNavigationControls(
   bool value
);
C++/CLI
[WebBrowsableAttribute()]
[DefaultValueAttribute()]
[SRDescriptionAttribute("")]
[CategoryAttribute("ToolBar")]
public:
property bool ShowPageNavigationControls {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ReportViewer Class
ReportViewer Members


ShowParameterPrompts Property

[image]
Gizmox.WebGUI.Reporting
ShowParameterPrompts Property
See Also Send Feedback
Gizmox.WebGUI.Reporting Namespace > ReportViewer Class : ShowParameterPrompts Property

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<CategoryAttribute("Appearance")>
<WebBrowsableAttribute()>
<SRDescriptionAttribute("")>
Public Property ShowParameterPrompts As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ReportViewer
Dim value As Boolean

instance.ShowParameterPrompts = value

value = instance.ShowParameterPrompts
C#
[DefaultValueAttribute()]
[CategoryAttribute("Appearance")]
[WebBrowsableAttribute()]
[SRDescriptionAttribute("")]
public bool ShowParameterPrompts {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[CategoryAttribute("Appearance")]
[WebBrowsableAttribute()]
[SRDescriptionAttribute("")]
public: __property bool get_ShowParameterPrompts();
public: __property void set_ShowParameterPrompts(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
[CategoryAttribute("Appearance")]
[WebBrowsableAttribute()]
[SRDescriptionAttribute("")]
public:
property bool ShowParameterPrompts {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ReportViewer Class
ReportViewer Members


ShowPrintButton Property

[image]
Gizmox.WebGUI.Reporting
ShowPrintButton Property
See Also Send Feedback
Gizmox.WebGUI.Reporting Namespace > ReportViewer Class : ShowPrintButton Property

Syntax

Visual Basic (Declaration)
<WebBrowsableAttribute()>
<SRDescriptionAttribute("")>
<CategoryAttribute("ToolBar")>
<DefaultValueAttribute()>
Public Property ShowPrintButton As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ReportViewer
Dim value As Boolean

instance.ShowPrintButton = value

value = instance.ShowPrintButton
C#
[WebBrowsableAttribute()]
[SRDescriptionAttribute("")]
[CategoryAttribute("ToolBar")]
[DefaultValueAttribute()]
public bool ShowPrintButton {get; set;}
Managed Extensions for C++
[WebBrowsableAttribute()]
[SRDescriptionAttribute("")]
[CategoryAttribute("ToolBar")]
[DefaultValueAttribute()]
public: __property bool get_ShowPrintButton();
public: __property void set_ShowPrintButton(
   bool value
);
C++/CLI
[WebBrowsableAttribute()]
[SRDescriptionAttribute("")]
[CategoryAttribute("ToolBar")]
[DefaultValueAttribute()]
public:
property bool ShowPrintButton {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ReportViewer Class
ReportViewer Members


ShowPromptAreaButton Property

[image]
Gizmox.WebGUI.Reporting
ShowPromptAreaButton Property
See Also Send Feedback
Gizmox.WebGUI.Reporting Namespace > ReportViewer Class : ShowPromptAreaButton Property

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("")>
<CategoryAttribute("ToolBar")>
<WebBrowsableAttribute()>
<DefaultValueAttribute()>
Public Property ShowPromptAreaButton As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ReportViewer
Dim value As Boolean

instance.ShowPromptAreaButton = value

value = instance.ShowPromptAreaButton
C#
[SRDescriptionAttribute("")]
[CategoryAttribute("ToolBar")]
[WebBrowsableAttribute()]
[DefaultValueAttribute()]
public bool ShowPromptAreaButton {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("")]
[CategoryAttribute("ToolBar")]
[WebBrowsableAttribute()]
[DefaultValueAttribute()]
public: __property bool get_ShowPromptAreaButton();
public: __property void set_ShowPromptAreaButton(
   bool value
);
C++/CLI
[SRDescriptionAttribute("")]
[CategoryAttribute("ToolBar")]
[WebBrowsableAttribute()]
[DefaultValueAttribute()]
public:
property bool ShowPromptAreaButton {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ReportViewer Class
ReportViewer Members


ShowRefreshButton Property

[image]
Gizmox.WebGUI.Reporting
ShowRefreshButton Property
See Also Send Feedback
Gizmox.WebGUI.Reporting Namespace > ReportViewer Class : ShowRefreshButton Property

Syntax

Visual Basic (Declaration)
<CategoryAttribute("ToolBar")>
<WebBrowsableAttribute()>
<SRDescriptionAttribute("")>
<DefaultValueAttribute()>
Public Property ShowRefreshButton As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ReportViewer
Dim value As Boolean

instance.ShowRefreshButton = value

value = instance.ShowRefreshButton
C#
[CategoryAttribute("ToolBar")]
[WebBrowsableAttribute()]
[SRDescriptionAttribute("")]
[DefaultValueAttribute()]
public bool ShowRefreshButton {get; set;}
Managed Extensions for C++
[CategoryAttribute("ToolBar")]
[WebBrowsableAttribute()]
[SRDescriptionAttribute("")]
[DefaultValueAttribute()]
public: __property bool get_ShowRefreshButton();
public: __property void set_ShowRefreshButton(
   bool value
);
C++/CLI
[CategoryAttribute("ToolBar")]
[WebBrowsableAttribute()]
[SRDescriptionAttribute("")]
[DefaultValueAttribute()]
public:
property bool ShowRefreshButton {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ReportViewer Class
ReportViewer Members


ShowReportBody Property

[image]
Gizmox.WebGUI.Reporting
ShowReportBody Property
See Also Send Feedback
Gizmox.WebGUI.Reporting Namespace > ReportViewer Class : ShowReportBody Property

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<CategoryAttribute("Appearance")>
<SRDescriptionAttribute("")>
<WebBrowsableAttribute()>
Public Property ShowReportBody As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ReportViewer
Dim value As Boolean

instance.ShowReportBody = value

value = instance.ShowReportBody
C#
[DefaultValueAttribute()]
[CategoryAttribute("Appearance")]
[SRDescriptionAttribute("")]
[WebBrowsableAttribute()]
public bool ShowReportBody {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[CategoryAttribute("Appearance")]
[SRDescriptionAttribute("")]
[WebBrowsableAttribute()]
public: __property bool get_ShowReportBody();
public: __property void set_ShowReportBody(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
[CategoryAttribute("Appearance")]
[SRDescriptionAttribute("")]
[WebBrowsableAttribute()]
public:
property bool ShowReportBody {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ReportViewer Class
ReportViewer Members


ShowToolBar Property

[image]
Gizmox.WebGUI.Reporting
ShowToolBar Property
See Also Send Feedback
Gizmox.WebGUI.Reporting Namespace > ReportViewer Class : ShowToolBar Property

Syntax

Visual Basic (Declaration)
<WebBrowsableAttribute()>
<SRDescriptionAttribute("")>
<DefaultValueAttribute()>
<CategoryAttribute("Appearance")>
Public Property ShowToolBar As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ReportViewer
Dim value As Boolean

instance.ShowToolBar = value

value = instance.ShowToolBar
C#
[WebBrowsableAttribute()]
[SRDescriptionAttribute("")]
[DefaultValueAttribute()]
[CategoryAttribute("Appearance")]
public bool ShowToolBar {get; set;}
Managed Extensions for C++
[WebBrowsableAttribute()]
[SRDescriptionAttribute("")]
[DefaultValueAttribute()]
[CategoryAttribute("Appearance")]
public: __property bool get_ShowToolBar();
public: __property void set_ShowToolBar(
   bool value
);
C++/CLI
[WebBrowsableAttribute()]
[SRDescriptionAttribute("")]
[DefaultValueAttribute()]
[CategoryAttribute("Appearance")]
public:
property bool ShowToolBar {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ReportViewer Class
ReportViewer Members


ShowZoomControl Property

[image]
Gizmox.WebGUI.Reporting
ShowZoomControl Property
See Also Send Feedback
Gizmox.WebGUI.Reporting Namespace > ReportViewer Class : ShowZoomControl Property

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<SRDescriptionAttribute("")>
<WebBrowsableAttribute()>
<CategoryAttribute("ToolBar")>
Public Property ShowZoomControl As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ReportViewer
Dim value As Boolean

instance.ShowZoomControl = value

value = instance.ShowZoomControl
C#
[DefaultValueAttribute()]
[SRDescriptionAttribute("")]
[WebBrowsableAttribute()]
[CategoryAttribute("ToolBar")]
public bool ShowZoomControl {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[SRDescriptionAttribute("")]
[WebBrowsableAttribute()]
[CategoryAttribute("ToolBar")]
public: __property bool get_ShowZoomControl();
public: __property void set_ShowZoomControl(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
[SRDescriptionAttribute("")]
[WebBrowsableAttribute()]
[CategoryAttribute("ToolBar")]
public:
property bool ShowZoomControl {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ReportViewer Class
ReportViewer Members


SizeToReportContent Property

[image]
Gizmox.WebGUI.Reporting
SizeToReportContent Property
See Also Send Feedback
Gizmox.WebGUI.Reporting Namespace > ReportViewer Class : SizeToReportContent Property

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<SRDescriptionAttribute("")>
<CategoryAttribute("Appearance")>
<WebBrowsableAttribute()>
Public Property SizeToReportContent As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ReportViewer
Dim value As Boolean

instance.SizeToReportContent = value

value = instance.SizeToReportContent
C#
[DefaultValueAttribute()]
[SRDescriptionAttribute("")]
[CategoryAttribute("Appearance")]
[WebBrowsableAttribute()]
public bool SizeToReportContent {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[SRDescriptionAttribute("")]
[CategoryAttribute("Appearance")]
[WebBrowsableAttribute()]
public: __property bool get_SizeToReportContent();
public: __property void set_SizeToReportContent(
   bool value
);
C++/CLI
[DefaultValueAttribute()]
[SRDescriptionAttribute("")]
[CategoryAttribute("Appearance")]
[WebBrowsableAttribute()]
public:
property bool SizeToReportContent {
   bool get();
   void set (boolvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ReportViewer Class
ReportViewer Members


ToolBarItemBorderColor Property

[image]
Gizmox.WebGUI.Reporting
ToolBarItemBorderColor Property
See Also Send Feedback
Gizmox.WebGUI.Reporting Namespace > ReportViewer Class : ToolBarItemBorderColor Property

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<CategoryAttribute("Appearance")>
<WebBrowsableAttribute()>
<SRDescriptionAttribute("")>
Public Property ToolBarItemBorderColor As Color
Visual Basic (Usage) Copy Code
Dim instance As ReportViewer
Dim value As Color

instance.ToolBarItemBorderColor = value

value = instance.ToolBarItemBorderColor
C#
[DefaultValueAttribute()]
[CategoryAttribute("Appearance")]
[WebBrowsableAttribute()]
[SRDescriptionAttribute("")]
public Color ToolBarItemBorderColor {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[CategoryAttribute("Appearance")]
[WebBrowsableAttribute()]
[SRDescriptionAttribute("")]
public: __property Color get_ToolBarItemBorderColor();
public: __property void set_ToolBarItemBorderColor(
   Color value
);
C++/CLI
[DefaultValueAttribute()]
[CategoryAttribute("Appearance")]
[WebBrowsableAttribute()]
[SRDescriptionAttribute("")]
public:
property Color ToolBarItemBorderColor {
   Color get();
   void set (Colorvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ReportViewer Class
ReportViewer Members


ToolBarItemBorderStyle Property

[image]
Gizmox.WebGUI.Reporting
ToolBarItemBorderStyle Property
See Also Send Feedback
Gizmox.WebGUI.Reporting Namespace > ReportViewer Class : ToolBarItemBorderStyle Property

Syntax

Visual Basic (Declaration)
<WebBrowsableAttribute()>
<DefaultValueAttribute()>
<CategoryAttribute("Appearance")>
<SRDescriptionAttribute("")>
Public Property ToolBarItemBorderStyle As BorderStyle
Visual Basic (Usage) Copy Code
Dim instance As ReportViewer
Dim value As BorderStyle

instance.ToolBarItemBorderStyle = value

value = instance.ToolBarItemBorderStyle
C#
[WebBrowsableAttribute()]
[DefaultValueAttribute()]
[CategoryAttribute("Appearance")]
[SRDescriptionAttribute("")]
public BorderStyle ToolBarItemBorderStyle {get; set;}
Managed Extensions for C++
[WebBrowsableAttribute()]
[DefaultValueAttribute()]
[CategoryAttribute("Appearance")]
[SRDescriptionAttribute("")]
public: __property BorderStyle get_ToolBarItemBorderStyle();
public: __property void set_ToolBarItemBorderStyle(
   BorderStyle value
);
C++/CLI
[WebBrowsableAttribute()]
[DefaultValueAttribute()]
[CategoryAttribute("Appearance")]
[SRDescriptionAttribute("")]
public:
property BorderStyle ToolBarItemBorderStyle {
   BorderStyle get();
   void set (BorderStylevalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ReportViewer Class
ReportViewer Members


ToolBarItemBorderWidth Property

[image]
Gizmox.WebGUI.Reporting
ToolBarItemBorderWidth Property
See Also Send Feedback
Gizmox.WebGUI.Reporting Namespace > ReportViewer Class : ToolBarItemBorderWidth Property

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("")>
<CategoryAttribute("Appearance")>
<DefaultValueAttribute()>
<WebBrowsableAttribute()>
Public Property ToolBarItemBorderWidth As Unit
Visual Basic (Usage) Copy Code
Dim instance As ReportViewer
Dim value As Unit

instance.ToolBarItemBorderWidth = value

value = instance.ToolBarItemBorderWidth
C#
[SRDescriptionAttribute("")]
[CategoryAttribute("Appearance")]
[DefaultValueAttribute()]
[WebBrowsableAttribute()]
public Unit ToolBarItemBorderWidth {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("")]
[CategoryAttribute("Appearance")]
[DefaultValueAttribute()]
[WebBrowsableAttribute()]
public: __property Unit get_ToolBarItemBorderWidth();
public: __property void set_ToolBarItemBorderWidth(
   Unit value
);
C++/CLI
[SRDescriptionAttribute("")]
[CategoryAttribute("Appearance")]
[DefaultValueAttribute()]
[WebBrowsableAttribute()]
public:
property Unit ToolBarItemBorderWidth {
   Unit get();
   void set (Unitvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ReportViewer Class
ReportViewer Members


ToolBarItemHoverBackColor Property

[image]
Gizmox.WebGUI.Reporting
ToolBarItemHoverBackColor Property
See Also Send Feedback
Gizmox.WebGUI.Reporting Namespace > ReportViewer Class : ToolBarItemHoverBackColor Property

Syntax

Visual Basic (Declaration)
<WebBrowsableAttribute()>
<DefaultValueAttribute()>
<SRDescriptionAttribute("")>
<CategoryAttribute("Appearance")>
Public Property ToolBarItemHoverBackColor As Color
Visual Basic (Usage) Copy Code
Dim instance As ReportViewer
Dim value As Color

instance.ToolBarItemHoverBackColor = value

value = instance.ToolBarItemHoverBackColor
C#
[WebBrowsableAttribute()]
[DefaultValueAttribute()]
[SRDescriptionAttribute("")]
[CategoryAttribute("Appearance")]
public Color ToolBarItemHoverBackColor {get; set;}
Managed Extensions for C++
[WebBrowsableAttribute()]
[DefaultValueAttribute()]
[SRDescriptionAttribute("")]
[CategoryAttribute("Appearance")]
public: __property Color get_ToolBarItemHoverBackColor();
public: __property void set_ToolBarItemHoverBackColor(
   Color value
);
C++/CLI
[WebBrowsableAttribute()]
[DefaultValueAttribute()]
[SRDescriptionAttribute("")]
[CategoryAttribute("Appearance")]
public:
property Color ToolBarItemHoverBackColor {
   Color get();
   void set (Colorvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ReportViewer Class
ReportViewer Members


ToolBarItemPressedBorderColor Property

[image]
Gizmox.WebGUI.Reporting
ToolBarItemPressedBorderColor Property
See Also Send Feedback
Gizmox.WebGUI.Reporting Namespace > ReportViewer Class : ToolBarItemPressedBorderColor Property

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<CategoryAttribute("Appearance")>
<WebBrowsableAttribute()>
<SRDescriptionAttribute("")>
Public Property ToolBarItemPressedBorderColor As Color
Visual Basic (Usage) Copy Code
Dim instance As ReportViewer
Dim value As Color

instance.ToolBarItemPressedBorderColor = value

value = instance.ToolBarItemPressedBorderColor
C#
[DefaultValueAttribute()]
[CategoryAttribute("Appearance")]
[WebBrowsableAttribute()]
[SRDescriptionAttribute("")]
public Color ToolBarItemPressedBorderColor {get; set;}
Managed Extensions for C++
[DefaultValueAttribute()]
[CategoryAttribute("Appearance")]
[WebBrowsableAttribute()]
[SRDescriptionAttribute("")]
public: __property Color get_ToolBarItemPressedBorderColor();
public: __property void set_ToolBarItemPressedBorderColor(
   Color value
);
C++/CLI
[DefaultValueAttribute()]
[CategoryAttribute("Appearance")]
[WebBrowsableAttribute()]
[SRDescriptionAttribute("")]
public:
property Color ToolBarItemPressedBorderColor {
   Color get();
   void set (Colorvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ReportViewer Class
ReportViewer Members


ToolBarItemPressedBorderStyle Property

[image]
Gizmox.WebGUI.Reporting
ToolBarItemPressedBorderStyle Property
See Also Send Feedback
Gizmox.WebGUI.Reporting Namespace > ReportViewer Class : ToolBarItemPressedBorderStyle Property

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("")>
<WebBrowsableAttribute()>
<DefaultValueAttribute()>
<CategoryAttribute("Appearance")>
Public Property ToolBarItemPressedBorderStyle As BorderStyle
Visual Basic (Usage) Copy Code
Dim instance As ReportViewer
Dim value As BorderStyle

instance.ToolBarItemPressedBorderStyle = value

value = instance.ToolBarItemPressedBorderStyle
C#
[SRDescriptionAttribute("")]
[WebBrowsableAttribute()]
[DefaultValueAttribute()]
[CategoryAttribute("Appearance")]
public BorderStyle ToolBarItemPressedBorderStyle {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("")]
[WebBrowsableAttribute()]
[DefaultValueAttribute()]
[CategoryAttribute("Appearance")]
public: __property BorderStyle get_ToolBarItemPressedBorderStyle();
public: __property void set_ToolBarItemPressedBorderStyle(
   BorderStyle value
);
C++/CLI
[SRDescriptionAttribute("")]
[WebBrowsableAttribute()]
[DefaultValueAttribute()]
[CategoryAttribute("Appearance")]
public:
property BorderStyle ToolBarItemPressedBorderStyle {
   BorderStyle get();
   void set (BorderStylevalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ReportViewer Class
ReportViewer Members


ToolBarItemPressedBorderWidth Property

[image]
Gizmox.WebGUI.Reporting
ToolBarItemPressedBorderWidth Property
See Also Send Feedback
Gizmox.WebGUI.Reporting Namespace > ReportViewer Class : ToolBarItemPressedBorderWidth Property

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Appearance")>
<WebBrowsableAttribute()>
<DefaultValueAttribute()>
<SRDescriptionAttribute("")>
Public Property ToolBarItemPressedBorderWidth As Unit
Visual Basic (Usage) Copy Code
Dim instance As ReportViewer
Dim value As Unit

instance.ToolBarItemPressedBorderWidth = value

value = instance.ToolBarItemPressedBorderWidth
C#
[CategoryAttribute("Appearance")]
[WebBrowsableAttribute()]
[DefaultValueAttribute()]
[SRDescriptionAttribute("")]
public Unit ToolBarItemPressedBorderWidth {get; set;}
Managed Extensions for C++
[CategoryAttribute("Appearance")]
[WebBrowsableAttribute()]
[DefaultValueAttribute()]
[SRDescriptionAttribute("")]
public: __property Unit get_ToolBarItemPressedBorderWidth();
public: __property void set_ToolBarItemPressedBorderWidth(
   Unit value
);
C++/CLI
[CategoryAttribute("Appearance")]
[WebBrowsableAttribute()]
[DefaultValueAttribute()]
[SRDescriptionAttribute("")]
public:
property Unit ToolBarItemPressedBorderWidth {
   Unit get();
   void set (Unitvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ReportViewer Class
ReportViewer Members


ToolBarItemPressedHoverBackColor Property

[image]
Gizmox.WebGUI.Reporting
ToolBarItemPressedHoverBackColor Property
See Also Send Feedback
Gizmox.WebGUI.Reporting Namespace > ReportViewer Class : ToolBarItemPressedHoverBackColor Property

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Appearance")>
<DefaultValueAttribute()>
<SRDescriptionAttribute("")>
<WebBrowsableAttribute()>
Public Property ToolBarItemPressedHoverBackColor As Color
Visual Basic (Usage) Copy Code
Dim instance As ReportViewer
Dim value As Color

instance.ToolBarItemPressedHoverBackColor = value

value = instance.ToolBarItemPressedHoverBackColor
C#
[CategoryAttribute("Appearance")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("")]
[WebBrowsableAttribute()]
public Color ToolBarItemPressedHoverBackColor {get; set;}
Managed Extensions for C++
[CategoryAttribute("Appearance")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("")]
[WebBrowsableAttribute()]
public: __property Color get_ToolBarItemPressedHoverBackColor();
public: __property void set_ToolBarItemPressedHoverBackColor(
   Color value
);
C++/CLI
[CategoryAttribute("Appearance")]
[DefaultValueAttribute()]
[SRDescriptionAttribute("")]
[WebBrowsableAttribute()]
public:
property Color ToolBarItemPressedHoverBackColor {
   Color get();
   void set (Colorvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ReportViewer Class
ReportViewer Members


WaitMessageFont Property

[image]
Gizmox.WebGUI.Reporting
WaitMessageFont Property
See Also Send Feedback
Gizmox.WebGUI.Reporting Namespace > ReportViewer Class : WaitMessageFont Property

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Appearance")>
<SRDescriptionAttribute("")>
Public ReadOnly Property WaitMessageFont As FontInfo
Visual Basic (Usage) Copy Code
Dim instance As ReportViewer
Dim value As FontInfo

value = instance.WaitMessageFont
C#
[CategoryAttribute("Appearance")]
[SRDescriptionAttribute("")]
public FontInfo WaitMessageFont {get;}
Managed Extensions for C++
[CategoryAttribute("Appearance")]
[SRDescriptionAttribute("")]
public: __property FontInfo* get_WaitMessageFont();
C++/CLI
[CategoryAttribute("Appearance")]
[SRDescriptionAttribute("")]
public:
property FontInfo^ WaitMessageFont {
   FontInfo^ get();
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ReportViewer Class
ReportViewer Members


ZoomMode Property

[image]
Gizmox.WebGUI.Reporting
ZoomMode Property
See Also Send Feedback
Gizmox.WebGUI.Reporting Namespace > ReportViewer Class : ZoomMode Property

Syntax

Visual Basic (Declaration)
<WebBrowsableAttribute()>
<DefaultValueAttribute()>
<SRDescriptionAttribute("")>
<CategoryAttribute("Appearance")>
Public Property ZoomMode As ZoomMode
Visual Basic (Usage) Copy Code
Dim instance As ReportViewer
Dim value As ZoomMode

instance.ZoomMode = value

value = instance.ZoomMode
C#
[WebBrowsableAttribute()]
[DefaultValueAttribute()]
[SRDescriptionAttribute("")]
[CategoryAttribute("Appearance")]
public ZoomMode ZoomMode {get; set;}
Managed Extensions for C++
[WebBrowsableAttribute()]
[DefaultValueAttribute()]
[SRDescriptionAttribute("")]
[CategoryAttribute("Appearance")]
public: __property ZoomMode get_ZoomMode();
public: __property void set_ZoomMode(
   ZoomMode value
);
C++/CLI
[WebBrowsableAttribute()]
[DefaultValueAttribute()]
[SRDescriptionAttribute("")]
[CategoryAttribute("Appearance")]
public:
property ZoomMode ZoomMode {
   ZoomMode get();
   void set (ZoomModevalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ReportViewer Class
ReportViewer Members


ZoomPercent Property

[image]
Gizmox.WebGUI.Reporting
ZoomPercent Property
See Also Send Feedback
Gizmox.WebGUI.Reporting Namespace > ReportViewer Class : ZoomPercent Property

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("")>
<WebBrowsableAttribute()>
<CategoryAttribute("Appearance")>
<DefaultValueAttribute()>
Public Property ZoomPercent As Integer
Visual Basic (Usage) Copy Code
Dim instance As ReportViewer
Dim value As Integer

instance.ZoomPercent = value

value = instance.ZoomPercent
C#
[SRDescriptionAttribute("")]
[WebBrowsableAttribute()]
[CategoryAttribute("Appearance")]
[DefaultValueAttribute()]
public int ZoomPercent {get; set;}
Managed Extensions for C++
[SRDescriptionAttribute("")]
[WebBrowsableAttribute()]
[CategoryAttribute("Appearance")]
[DefaultValueAttribute()]
public: __property int get_ZoomPercent();
public: __property void set_ZoomPercent(
   int value
);
C++/CLI
[SRDescriptionAttribute("")]
[WebBrowsableAttribute()]
[CategoryAttribute("Appearance")]
[DefaultValueAttribute()]
public:
property int ZoomPercent {
   int get();
   void set (intvalue);
}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ReportViewer Class
ReportViewer Members


ReportViewer Class Events

[image]
Gizmox.WebGUI.Reporting
ReportViewer Class Events
See Also Send Feedback
Gizmox.WebGUI.Reporting Namespace : ReportViewer Class

For a list of all members of this type, see ReportViewer members.

Public Events

 | Name | Description
Public Event | Back |
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BookmarkNavigation |
Public Event | Click | Occurs on clicking the button. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | CursorChanged | Occurs when the value of the Gizmox.WebGUI.Forms.Control.Cursor property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Disposed | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Event | DocumentMapNavigation |
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Event | Drillthrough |
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | HostedControlDataBinding | (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Public Event | HostedControlDisposed | (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Public Event | HostedControlInit | (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Public Event | HostedControlLoad | (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Public Event | HostedControlPreRender | (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Public Event | HostedControlUnload | (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Public Event | HostedHostedPageDataBinding | (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Public Event | HostedPageDisposed | (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Public Event | HostedPageError | (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Public Event | HostedPageInitComplete | (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Public Event | HostedPageLoad | Occurs when the hosted control page loads (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Public Event | HostedPageLoadComplete | (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Public Event | HostedPagePageInit | (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Public Event | HostedPagePreInit | (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Public Event | HostedPagePreLoad | (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Public Event | HostedPagePreRender | (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Public Event | HostedPagePreRenderComplete | (Inherited from Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Gizmox.WebGUI.Forms.Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | PageNavigation |
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ReportError |
Public Event | ReportRefresh |
Public Event | Resize | Occurs when the control is resized. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Search |
Public Event | Sort |
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Toggle |
Public Event | VisibleChanged | Occurs when the Gizmox.WebGUI.Forms.Control.Visible property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Top

See Also

Reference

ReportViewer Class
Gizmox.WebGUI.Reporting Namespace


Back Event

[image]
Gizmox.WebGUI.Reporting
Back Event
See Also Send Feedback
Gizmox.WebGUI.Reporting Namespace > ReportViewer Class : Back Event

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("")>
Public Event Back() As BackEventHandler
Visual Basic (Usage) Copy Code
Dim instance As ReportViewer
Dim handler As BackEventHandler

AddHandler instance.Back, handler
C#
[SRDescriptionAttribute("")]
public event BackEventHandler Back()
Managed Extensions for C++
[SRDescriptionAttribute("")]
public: __event BackEventHandler* Back
C++/CLI
[SRDescriptionAttribute("")]
public:
event BackEventHandler^ Back

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ReportViewer Class
ReportViewer Members


BookmarkNavigation Event

[image]
Gizmox.WebGUI.Reporting
BookmarkNavigation Event
See Also Send Feedback
Gizmox.WebGUI.Reporting Namespace > ReportViewer Class : BookmarkNavigation Event

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("")>
Public Event BookmarkNavigation() As BookmarkNavigationEventHandler
Visual Basic (Usage) Copy Code
Dim instance As ReportViewer
Dim handler As BookmarkNavigationEventHandler

AddHandler instance.BookmarkNavigation, handler
C#
[SRDescriptionAttribute("")]
public event BookmarkNavigationEventHandler BookmarkNavigation()
Managed Extensions for C++
[SRDescriptionAttribute("")]
public: __event BookmarkNavigationEventHandler* BookmarkNavigation
C++/CLI
[SRDescriptionAttribute("")]
public:
event BookmarkNavigationEventHandler^ BookmarkNavigation

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ReportViewer Class
ReportViewer Members


DocumentMapNavigation Event

[image]
Gizmox.WebGUI.Reporting
DocumentMapNavigation Event
See Also Send Feedback
Gizmox.WebGUI.Reporting Namespace > ReportViewer Class : DocumentMapNavigation Event

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("")>
Public Event DocumentMapNavigation() As DocumentMapNavigationEventHandler
Visual Basic (Usage) Copy Code
Dim instance As ReportViewer
Dim handler As DocumentMapNavigationEventHandler

AddHandler instance.DocumentMapNavigation, handler
C#
[SRDescriptionAttribute("")]
public event DocumentMapNavigationEventHandler DocumentMapNavigation()
Managed Extensions for C++
[SRDescriptionAttribute("")]
public: __event DocumentMapNavigationEventHandler* DocumentMapNavigation
C++/CLI
[SRDescriptionAttribute("")]
public:
event DocumentMapNavigationEventHandler^ DocumentMapNavigation

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ReportViewer Class
ReportViewer Members


Drillthrough Event

[image]
Gizmox.WebGUI.Reporting
Drillthrough Event
See Also Send Feedback
Gizmox.WebGUI.Reporting Namespace > ReportViewer Class : Drillthrough Event

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("")>
Public Event Drillthrough() As DrillthroughEventHandler
Visual Basic (Usage) Copy Code
Dim instance As ReportViewer
Dim handler As DrillthroughEventHandler

AddHandler instance.Drillthrough, handler
C#
[SRDescriptionAttribute("")]
public event DrillthroughEventHandler Drillthrough()
Managed Extensions for C++
[SRDescriptionAttribute("")]
public: __event DrillthroughEventHandler* Drillthrough
C++/CLI
[SRDescriptionAttribute("")]
public:
event DrillthroughEventHandler^ Drillthrough

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ReportViewer Class
ReportViewer Members


PageNavigation Event

[image]
Gizmox.WebGUI.Reporting
PageNavigation Event
See Also Send Feedback
Gizmox.WebGUI.Reporting Namespace > ReportViewer Class : PageNavigation Event

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("")>
Public Event PageNavigation() As PageNavigationEventHandler
Visual Basic (Usage) Copy Code
Dim instance As ReportViewer
Dim handler As PageNavigationEventHandler

AddHandler instance.PageNavigation, handler
C#
[SRDescriptionAttribute("")]
public event PageNavigationEventHandler PageNavigation()
Managed Extensions for C++
[SRDescriptionAttribute("")]
public: __event PageNavigationEventHandler* PageNavigation
C++/CLI
[SRDescriptionAttribute("")]
public:
event PageNavigationEventHandler^ PageNavigation

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ReportViewer Class
ReportViewer Members


ReportError Event

[image]
Gizmox.WebGUI.Reporting
ReportError Event
See Also Send Feedback
Gizmox.WebGUI.Reporting Namespace > ReportViewer Class : ReportError Event

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("")>
Public Event ReportError() As ReportErrorEventHandler
Visual Basic (Usage) Copy Code
Dim instance As ReportViewer
Dim handler As ReportErrorEventHandler

AddHandler instance.ReportError, handler
C#
[SRDescriptionAttribute("")]
public event ReportErrorEventHandler ReportError()
Managed Extensions for C++
[SRDescriptionAttribute("")]
public: __event ReportErrorEventHandler* ReportError
C++/CLI
[SRDescriptionAttribute("")]
public:
event ReportErrorEventHandler^ ReportError

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ReportViewer Class
ReportViewer Members


ReportRefresh Event

[image]
Gizmox.WebGUI.Reporting
ReportRefresh Event
See Also Send Feedback
Gizmox.WebGUI.Reporting Namespace > ReportViewer Class : ReportRefresh Event

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("")>
Public Event ReportRefresh() As CancelEventHandler
Visual Basic (Usage) Copy Code
Dim instance As ReportViewer
Dim handler As CancelEventHandler

AddHandler instance.ReportRefresh, handler
C#
[SRDescriptionAttribute("")]
public event CancelEventHandler ReportRefresh()
Managed Extensions for C++
[SRDescriptionAttribute("")]
public: __event CancelEventHandler* ReportRefresh
C++/CLI
[SRDescriptionAttribute("")]
public:
event CancelEventHandler^ ReportRefresh

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ReportViewer Class
ReportViewer Members


Search Event

[image]
Gizmox.WebGUI.Reporting
Search Event
See Also Send Feedback
Gizmox.WebGUI.Reporting Namespace > ReportViewer Class : Search Event

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("")>
Public Event Search() As SearchEventHandler
Visual Basic (Usage) Copy Code
Dim instance As ReportViewer
Dim handler As SearchEventHandler

AddHandler instance.Search, handler
C#
[SRDescriptionAttribute("")]
public event SearchEventHandler Search()
Managed Extensions for C++
[SRDescriptionAttribute("")]
public: __event SearchEventHandler* Search
C++/CLI
[SRDescriptionAttribute("")]
public:
event SearchEventHandler^ Search

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ReportViewer Class
ReportViewer Members


Sort Event

[image]
Gizmox.WebGUI.Reporting
Sort Event
See Also Send Feedback
Gizmox.WebGUI.Reporting Namespace > ReportViewer Class : Sort Event

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("")>
Public Event Sort() As SortEventHandler
Visual Basic (Usage) Copy Code
Dim instance As ReportViewer
Dim handler As SortEventHandler

AddHandler instance.Sort, handler
C#
[SRDescriptionAttribute("")]
public event SortEventHandler Sort()
Managed Extensions for C++
[SRDescriptionAttribute("")]
public: __event SortEventHandler* Sort
C++/CLI
[SRDescriptionAttribute("")]
public:
event SortEventHandler^ Sort

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ReportViewer Class
ReportViewer Members


Toggle Event

[image]
Gizmox.WebGUI.Reporting
Toggle Event
See Also Send Feedback
Gizmox.WebGUI.Reporting Namespace > ReportViewer Class : Toggle Event

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("")>
Public Event Toggle() As CancelEventHandler
Visual Basic (Usage) Copy Code
Dim instance As ReportViewer
Dim handler As CancelEventHandler

AddHandler instance.Toggle, handler
C#
[SRDescriptionAttribute("")]
public event CancelEventHandler Toggle()
Managed Extensions for C++
[SRDescriptionAttribute("")]
public: __event CancelEventHandler* Toggle
C++/CLI
[SRDescriptionAttribute("")]
public:
event CancelEventHandler^ Toggle

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ReportViewer Class
ReportViewer Members


Empty Index Entry
Send Feedback

Glossary Item Box

Empty Index Entry

The index entry you selected has no target topics associated with it.

If you have chosen a parent entry, please select a child entry.


Topic Not Found
Send Feedback

Glossary Item Box

Topic Not Found

The link you just clicked was not able to connect to the target page.

Some possible reasons and remedies are as follows:

Reason | Remedy
Destination topic is not part of the area you specified in the Filtered by field. | Either select another filter or select (no filter).
The URL of the destination topic is incorrect or has changed. | Use the index or the search function instead.
Problems with the help installation. | Rerun Setup for the product this help is related to and select the 'Repair' option.

Additional help is available for filters, search, and the index.

Click Back to return to the page you were on.

The target parameters are:

Keyword:
Index Moniker:
URL:


Deploying On a Hosted Server

Visual WebGui Documentation
Deploying On a Hosted Server
Send Feedback

Glossary Item Box

Basically deploying a Visual WebGui application is similar to deploying an ASP.NET application. This is because a Visual WebGui application is actually an extension to ASP.NET application. When you create the deployment project you should check that the Gizmox.WebGUI.Forms, Gizmox.WebGUI.Common and Gizmox.WebGUI.Server are deployed as well. If you are using the Visual Studio publish feature you should check to verify that the Visual WebGui references are marked as copy local. Other then that creating a deployment project is similar to that of ASP.NET.

Registering the ".wgx" extension

Registering the “.wgx” extension is an easy task for hosting sites and does not have any security impacts. It is actually the same as allowing the aspx extension. Currently we know of two hosting sites that had already provided users with this extension which are Brinkster and SiteGround.

You can read more about registering the ".wgx" extension here.


Getting Started - Gizmox.WebGUI.Common

Gizmox.WebGUI.Common
Getting Started
Send Feedback


Introduction - Gizmox.WebGUI.Common

Gizmox.WebGUI.Common
Introduction
Send Feedback


Gizmox.WebGUI.Client.Design Namespace Inheritance Hierarchy

Gizmox.WebGUI.Common
Gizmox.WebGUI.Client.Design Namespace Inheritance Hierarchy
See Also Send Feedback

See Also

Reference

Gizmox.WebGUI.Common Assembly


Gizmox.WebGUI.Common.Configuration Namespace Inheritance Hierarchy

Gizmox.WebGUI.Common
Gizmox.WebGUI.Common.Configuration Namespace Inheritance Hierarchy
See Also Send Feedback

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Common.Configuration.Config

See Also

Reference

Gizmox.WebGUI.Common Assembly


LogonException Class Properties

[image]
Gizmox.WebGUI.Common
LogonException Class Properties
See Also Send Feedback
Gizmox.WebGUI.Common.Exceptions Namespace : LogonException Class

For a list of all members of this type, see LogonException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
Protected Property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from System.Exception)
Top

See Also

Reference

LogonException Class
Gizmox.WebGUI.Common.Exceptions Namespace


Gizmox.WebGUI.Common.Exceptions Namespace Inheritance Hierarchy

Gizmox.WebGUI.Common
Gizmox.WebGUI.Common.Exceptions Namespace Inheritance Hierarchy
See Also Send Feedback

Inheritance Hierarchy

System.Object
System.Exception
Gizmox.WebGUI.Common.Exceptions.LogonException

See Also

Reference

Gizmox.WebGUI.Common Assembly


ClientControllerAttribute Class Methods

[image]
Gizmox.WebGUI.Common
ClientControllerAttribute Class Methods
See Also Send Feedback
Gizmox.WebGUI.Common.Extensibility Namespace : ClientControllerAttribute Class

For a list of all members of this type, see ClientControllerAttribute members.

Public Methods

 | Name | Description
Public Method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from System.Attribute)
Public Method | GetHashCode | Returns the hash code for this instance. (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from System.Attribute)
Public Method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from System.Attribute)
Top

See Also

Reference

ClientControllerAttribute Class
Gizmox.WebGUI.Common.Extensibility Namespace


SilverlightControlAttribute Class Methods

[image]
Gizmox.WebGUI.Common
SilverlightControlAttribute Class Methods
See Also Send Feedback
Gizmox.WebGUI.Common.Extensibility Namespace : SilverlightControlAttribute Class

For a list of all members of this type, see SilverlightControlAttribute members.

Public Methods

 | Name | Description
Public Method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from System.Attribute)
Public Method | GetHashCode | Returns the hash code for this instance. (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from System.Attribute)
Public Method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from System.Attribute)
Top

See Also

Reference

SilverlightControlAttribute Class
Gizmox.WebGUI.Common.Extensibility Namespace


WebCompilerPagesAttribute Class Methods

[image]
Gizmox.WebGUI.Common
WebCompilerPagesAttribute Class Methods
See Also Send Feedback
Gizmox.WebGUI.Common.Extensibility Namespace : WebCompilerPagesAttribute Class

For a list of all members of this type, see WebCompilerPagesAttribute members.

Public Methods

 | Name | Description
Public Method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from System.Attribute)
Public Method | GetHashCode | Returns the hash code for this instance. (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from System.Attribute)
Public Method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from System.Attribute)
Top

See Also

Reference

WebCompilerPagesAttribute Class
Gizmox.WebGUI.Common.Extensibility Namespace


WebCompilerResourcesAttribute Class Methods

[image]
Gizmox.WebGUI.Common
WebCompilerResourcesAttribute Class Methods
See Also Send Feedback
Gizmox.WebGUI.Common.Extensibility Namespace : WebCompilerResourcesAttribute Class

For a list of all members of this type, see WebCompilerResourcesAttribute members.

Public Methods

 | Name | Description
Public Method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from System.Attribute)
Public Method | GetHashCode | Returns the hash code for this instance. (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from System.Attribute)
Public Method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from System.Attribute)
Top

See Also

Reference

WebCompilerResourcesAttribute Class
Gizmox.WebGUI.Common.Extensibility Namespace


WinCompilerControllerAttribute Class Methods

[image]
Gizmox.WebGUI.Common
WinCompilerControllerAttribute Class Methods
See Also Send Feedback
Gizmox.WebGUI.Common.Extensibility Namespace : WinCompilerControllerAttribute Class

For a list of all members of this type, see WinCompilerControllerAttribute members.

Public Methods

 | Name | Description
Public Method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from System.Attribute)
Public Method | GetHashCode | Returns the hash code for this instance. (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from System.Attribute)
Public Method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from System.Attribute)
Top

See Also

Reference

WinCompilerControllerAttribute Class
Gizmox.WebGUI.Common.Extensibility Namespace


Gizmox.WebGUI.Common.Extensibility Namespace Inheritance Hierarchy

Gizmox.WebGUI.Common
Gizmox.WebGUI.Common.Extensibility Namespace Inheritance Hierarchy
See Also Send Feedback

Inheritance Hierarchy

System.Object
System.Attribute
Gizmox.WebGUI.Common.Extensibility.ClientControllerAttribute
Gizmox.WebGUI.Common.Extensibility.SilverlightControlAttribute
Gizmox.WebGUI.Common.Extensibility.WebCompilerPagesAttribute
Gizmox.WebGUI.Common.Extensibility.WebCompilerResourcesAttribute
Gizmox.WebGUI.Common.Extensibility.WinCompilerControllerAttribute

See Also

Reference

Gizmox.WebGUI.Common Assembly


GZipGatewayReference Class Methods

[image]
Gizmox.WebGUI.Common
GZipGatewayReference Class Methods
See Also Send Feedback
Gizmox.WebGUI.Common.Gateways Namespace : GZipGatewayReference Class

For a list of all members of this type, see GZipGatewayReference members.

Public Methods

 | Name | Description
Public Method | ToString | (Inherited from GatewayReference)
Top

See Also

Reference

GZipGatewayReference Class
Gizmox.WebGUI.Common.Gateways Namespace


GZipGatewayReference Class Properties

[image]
Gizmox.WebGUI.Common
GZipGatewayReference Class Properties
See Also Send Feedback
Gizmox.WebGUI.Common.Gateways Namespace : GZipGatewayReference Class

For a list of all members of this type, see GZipGatewayReference members.

Public Properties

 | Name | Description
Public Property | Action | (Inherited from GatewayReference)
Public Property | Chachable | (Inherited from GatewayReference)
Public Property | Component | (Inherited from GatewayReference)
Public Property | Handler | (Inherited from GatewayReference)
Top

See Also

Reference

GZipGatewayReference Class
Gizmox.WebGUI.Common.Gateways Namespace


Gizmox.WebGUI.Common.Gateways Namespace Inheritance Hierarchy

Gizmox.WebGUI.Common
Gizmox.WebGUI.Common.Gateways Namespace Inheritance Hierarchy
See Also Send Feedback

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Common.Gateways.Gateway
Gizmox.WebGUI.Common.Gateways.GatewayHandler
Gizmox.WebGUI.Common.Gateways.GatewayWriter
Gizmox.WebGUI.Common.Gateways.GatewayFile
Gizmox.WebGUI.Common.Gateways.GatewayParameters
Gizmox.WebGUI.Common.Gateways.GatewayReference
Gizmox.WebGUI.Common.Gateways.GZipGatewayReference
Gizmox.WebGUI.Common.Gateways.StaticGateway
Gizmox.WebGUI.Common.Gateways.StaticGateway.StaticXmlViewerGateway

See Also

Reference

Gizmox.WebGUI.Common Assembly


Gizmox.WebGUI.Common.Interfaces Namespace Inheritance Hierarchy

Gizmox.WebGUI.Common
Gizmox.WebGUI.Common.Interfaces Namespace Inheritance Hierarchy
See Also Send Feedback

Inheritance Hierarchy

System.Object
System.EventArgs
Gizmox.WebGUI.Common.Interfaces.ObservableItemPropertyChangedArgs
Gizmox.WebGUI.Common.Interfaces.ObservableListEventArgs
Gizmox.WebGUI.Common.Interfaces.ObservableResumeLayoutArgs

See Also

Reference

Gizmox.WebGUI.Common Assembly


DataResourceHandle Class Properties

[image]
Gizmox.WebGUI.Common
DataResourceHandle Class Properties
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace : DataResourceHandle Class

For a list of all members of this type, see DataResourceHandle members.

Public Properties

 | Name | Description
Public Property | File | (Inherited from ResourceHandle)
Top

Protected Properties

 | Name | Description
Protected Property | Config | (Inherited from ResourceHandle)
Top

See Also

Reference

DataResourceHandle Class
Gizmox.WebGUI.Common.Resources Namespace


FileStreamHandle Class Fields

[image]
Gizmox.WebGUI.Common
FileStreamHandle Class Fields
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace : FileStreamHandle Class

For a list of all members of this type, see FileStreamHandle members.

Protected Fields

 | Name | Description
Protected Field | InternalStream | (Inherited from FileHandle)
Top

See Also

Reference

FileStreamHandle Class
Gizmox.WebGUI.Common.Resources Namespace


HttpPostedFileHandle Class Fields

[image]
Gizmox.WebGUI.Common
HttpPostedFileHandle Class Fields
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace : HttpPostedFileHandle Class

For a list of all members of this type, see HttpPostedFileHandle members.

Protected Fields

 | Name | Description
Protected Field | InternalStream | (Inherited from FileHandle)
Top

See Also

Reference

HttpPostedFileHandle Class
Gizmox.WebGUI.Common.Resources Namespace


IconResourceHandle Class Properties

[image]
Gizmox.WebGUI.Common
IconResourceHandle Class Properties
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace : IconResourceHandle Class

For a list of all members of this type, see IconResourceHandle members.

Public Properties

 | Name | Description
Public Property | File | (Inherited from ResourceHandle)
Top

Protected Properties

 | Name | Description
Protected Property | Config | (Inherited from ResourceHandle)
Top

See Also

Reference

IconResourceHandle Class
Gizmox.WebGUI.Common.Resources Namespace


ImageResourceHandle Class Properties

[image]
Gizmox.WebGUI.Common
ImageResourceHandle Class Properties
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace : ImageResourceHandle Class

For a list of all members of this type, see ImageResourceHandle members.

Public Properties

 | Name | Description
Public Property | File | (Inherited from ResourceHandle)
Top

Protected Properties

 | Name | Description
Protected Property | Config | (Inherited from ResourceHandle)
Top

See Also

Reference

ImageResourceHandle Class
Gizmox.WebGUI.Common.Resources Namespace


PhysicalFileHandle Class Fields

[image]
Gizmox.WebGUI.Common
PhysicalFileHandle Class Fields
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace : PhysicalFileHandle Class

For a list of all members of this type, see PhysicalFileHandle members.

Protected Fields

 | Name | Description
Protected Field | InternalStream | (Inherited from FileHandle)
Top

See Also

Reference

PhysicalFileHandle Class
Gizmox.WebGUI.Common.Resources Namespace


SkinResourceHandle Class Properties

[image]
Gizmox.WebGUI.Common
SkinResourceHandle Class Properties
See Also Send Feedback
Gizmox.WebGUI.Common.Resources Namespace : SkinResourceHandle Class

For a list of all members of this type, see SkinResourceHandle members.

Public Properties

 | Name | Description
Public Property | File | (Inherited from ResourceHandle)
Top

Protected Properties

 | Name | Description
Protected Property | Config | (Inherited from ResourceHandle)
Top

See Also

Reference

SkinResourceHandle Class
Gizmox.WebGUI.Common.Resources Namespace


Gizmox.WebGUI.Common.Resources Namespace Inheritance Hierarchy

Gizmox.WebGUI.Common
Gizmox.WebGUI.Common.Resources Namespace Inheritance Hierarchy
See Also Send Feedback

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Common.Resources.FileHandle
Gizmox.WebGUI.Common.Resources.FileStreamHandle
Gizmox.WebGUI.Common.Resources.HttpPostedFileHandle
Gizmox.WebGUI.Common.Resources.PhysicalFileHandle
Gizmox.WebGUI.Common.Resources.ResourceHandle
Gizmox.WebGUI.Common.Resources.AssemblyResourceHandle
Gizmox.WebGUI.Common.Resources.DataResourceHandle
Gizmox.WebGUI.Common.Resources.GatewayResourceHandle
Gizmox.WebGUI.Common.Resources.IconResourceHandle
Gizmox.WebGUI.Common.Resources.ImageResourceHandle
Gizmox.WebGUI.Common.Resources.SkinResourceHandle
Gizmox.WebGUI.Common.Resources.StaticGatewayResourceHandle
Gizmox.WebGUI.Common.Resources.DatabaseResourceHandle
Gizmox.WebGUI.Common.Resources.TypeResourceHandle
Gizmox.WebGUI.Common.Resources.UrlResourceHandle
Gizmox.WebGUI.Common.Resources.ResourceManager
System.Collections.Specialized.NameObjectCollectionBase
Gizmox.WebGUI.Common.Resources.FileHandleCollection
System.ComponentModel.TypeConverter
Gizmox.WebGUI.Common.Resources.ResourceHandleConverter

See Also

Reference

Gizmox.WebGUI.Common Assembly


WGTracingSwitch Class Methods

[image]
Gizmox.WebGUI.Common
WGTracingSwitch Class Methods
See Also Send Feedback
Gizmox.WebGUI.Common.Switches Namespace : WGTracingSwitch Class

For a list of all members of this type, see WGTracingSwitch members.

Protected Methods

 | Name | Description
Protected Method | GetSupportedAttributes | Gets the custom attributes supported by the switch. (Inherited from System.Diagnostics.Switch)
Protected Method | OnSwitchSettingChanged | Updates and corrects the level for this switch. (Inherited from System.Diagnostics.TraceSwitch)
Protected Method | OnValueChanged | Sets the SwitchSetting property to the integer equivalent of the Value property. (Inherited from System.Diagnostics.TraceSwitch)
Top

See Also

Reference

WGTracingSwitch Class
Gizmox.WebGUI.Common.Switches Namespace


WGTracingThresholdSwitch Class Methods

[image]
Gizmox.WebGUI.Common
WGTracingThresholdSwitch Class Methods
See Also Send Feedback
Gizmox.WebGUI.Common.Switches Namespace : WGTracingThresholdSwitch Class

For a list of all members of this type, see WGTracingThresholdSwitch members.

Protected Methods

 | Name | Description
Protected Method | GetSupportedAttributes | Gets the custom attributes supported by the switch. (Inherited from System.Diagnostics.Switch)
Protected Method | OnSwitchSettingChanged | Invoked when the SwitchSetting property is changed. (Inherited from System.Diagnostics.Switch)
Protected Method | OnValueChanged | Invoked when the Value property is changed. (Inherited from System.Diagnostics.Switch)
Top

See Also

Reference

WGTracingThresholdSwitch Class
Gizmox.WebGUI.Common.Switches Namespace


Gizmox.WebGUI.Common.Switches Namespace Inheritance Hierarchy

Gizmox.WebGUI.Common
Gizmox.WebGUI.Common.Switches Namespace Inheritance Hierarchy
See Also Send Feedback

Inheritance Hierarchy

System.Object
System.Diagnostics.Switch
Gizmox.WebGUI.Common.Switches.WGTracingThresholdSwitch
System.Diagnostics.TraceSwitch
Gizmox.WebGUI.Common.Switches.WGTracingSwitch

See Also

Reference

Gizmox.WebGUI.Common Assembly


EventTraceRecord Class Methods

[image]
Gizmox.WebGUI.Common
EventTraceRecord Class Methods
See Also Send Feedback
Gizmox.WebGUI.Common.Trace Namespace : EventTraceRecord Class

For a list of all members of this type, see EventTraceRecord members.

Protected Methods

 | Name | Description
Protected Method | GetMessage | (Inherited from TraceRecord)
Top

See Also

Reference

EventTraceRecord Class
Gizmox.WebGUI.Common.Trace Namespace


RenderTraceRecord Class Methods

[image]
Gizmox.WebGUI.Common
RenderTraceRecord Class Methods
See Also Send Feedback
Gizmox.WebGUI.Common.Trace Namespace : RenderTraceRecord Class

For a list of all members of this type, see RenderTraceRecord members.

Protected Methods

 | Name | Description
Protected Method | GetMessage | (Inherited from TraceRecord)
Top

See Also

Reference

RenderTraceRecord Class
Gizmox.WebGUI.Common.Trace Namespace


Gizmox.WebGUI.Common.Trace Namespace Inheritance Hierarchy

Gizmox.WebGUI.Common
Gizmox.WebGUI.Common.Trace Namespace Inheritance Hierarchy
See Also Send Feedback

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Common.Trace.TraceRecord
Gizmox.WebGUI.Common.Trace.EventTraceRecord
Gizmox.WebGUI.Common.Trace.RenderTraceRecord
Gizmox.WebGUI.Common.Trace.VerboseRecord

See Also

Reference

Gizmox.WebGUI.Common Assembly


Gizmox.WebGUI.Common Namespace Inheritance Hierarchy

Gizmox.WebGUI.Common
Gizmox.WebGUI.Common Namespace Inheritance Hierarchy
See Also Send Feedback

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Common.Global

See Also

Reference

Gizmox.WebGUI.Common Assembly


DesignTimeControllerAttribute Class Methods

[image]
Gizmox.WebGUI.Common
DesignTimeControllerAttribute Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace : DesignTimeControllerAttribute Class

For a list of all members of this type, see DesignTimeControllerAttribute members.

Public Methods

 | Name | Description
Public Method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from System.Attribute)
Public Method | GetHashCode | Returns the hash code for this instance. (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from System.Attribute)
Public Method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from System.Attribute)
Top

See Also

Reference

DesignTimeControllerAttribute Class
Gizmox.WebGUI.Forms.Design Namespace


ToolboxItemCategoryAttribute Class Methods

[image]
Gizmox.WebGUI.Common
ToolboxItemCategoryAttribute Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace : ToolboxItemCategoryAttribute Class

For a list of all members of this type, see ToolboxItemCategoryAttribute members.

Public Methods

 | Name | Description
Public Method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from System.Attribute)
Public Method | GetHashCode | Returns the hash code for this instance. (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from System.Attribute)
Public Method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from System.Attribute)
Top

See Also

Reference

ToolboxItemCategoryAttribute Class
Gizmox.WebGUI.Forms.Design Namespace


Gizmox.WebGUI.Forms.Design Namespace (Gizmox.WebGUI.Common) Inheritance Hierarchy

Gizmox.WebGUI.Common
Gizmox.WebGUI.Forms.Design Namespace (Gizmox.WebGUI.Common) Inheritance Hierarchy
See Also Send Feedback

Inheritance Hierarchy

System.Object
System.Attribute
Gizmox.WebGUI.Forms.Design.DesignTimeControllerAttribute
Gizmox.WebGUI.Forms.Design.ToolboxItemCategoryAttribute

See Also

Reference

Gizmox.WebGUI.Common Assembly


FormCollection Class Methods

[image]
Gizmox.WebGUI.Common
FormCollection Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : FormCollection Class

For a list of all members of this type, see FormCollection members.

Public Methods

 | Name | Description
Public Method | GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollectionBase instance. (Inherited from System.Collections.ReadOnlyCollectionBase)
Top

See Also

Reference

FormCollection Class
Gizmox.WebGUI.Forms Namespace


Gizmox.WebGUI.Forms.Interopability Namespace Inheritance Hierarchy

Gizmox.WebGUI.Common
Gizmox.WebGUI.Forms.Interopability Namespace Inheritance Hierarchy
See Also Send Feedback

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.Interopability.InvokeMethodMessage

See Also

Reference

Gizmox.WebGUI.Common Assembly


MetadataTagAttribute Class Methods

[image]
Gizmox.WebGUI.Common
MetadataTagAttribute Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : MetadataTagAttribute Class

For a list of all members of this type, see MetadataTagAttribute members.

Public Methods

 | Name | Description
Public Method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from System.Attribute)
Public Method | GetHashCode | Returns the hash code for this instance. (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from System.Attribute)
Public Method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from System.Attribute)
Top

See Also

Reference

MetadataTagAttribute Class
Gizmox.WebGUI.Forms Namespace


RegisteredComponent Class Events

[image]
Gizmox.WebGUI.Common
RegisteredComponent Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RegisteredComponent Class

For a list of all members of this type, see RegisteredComponent members.

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from ComponentBase)
Top

See Also

Reference

RegisteredComponent Class
Gizmox.WebGUI.Forms Namespace


Gizmox.WebGUI.Forms Namespace (Gizmox.WebGUI.Common) Inheritance Hierarchy

Gizmox.WebGUI.Common
Gizmox.WebGUI.Forms Namespace (Gizmox.WebGUI.Common) Inheritance Hierarchy
See Also Send Feedback

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.Application
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Metadata
Gizmox.WebGUI.Forms.MetadataControl
Gizmox.WebGUI.Forms.RegisteredClientAction
Gizmox.WebGUI.Forms.RegisteredComponent.NotImplementedGateway
Gizmox.WebGUI.Forms.Theme
Gizmox.WebGUI.Forms.Theme.FlavorCollection
Gizmox.WebGUI.Forms.Theme.ThemeCollection
Gizmox.WebGUI.Forms.ThemeFlavor
Gizmox.WebGUI.Forms.ThemeFonts
Gizmox.WebGUI.Forms.ThreadMessage
Gizmox.WebGUI.Forms.VWGContext
System.Attribute
Gizmox.WebGUI.Forms.MetadataTagAttribute
System.Collections.ReadOnlyCollectionBase
Gizmox.WebGUI.Forms.FormCollection
System.EventArgs
Gizmox.WebGUI.Forms.ThreadBookmarkEventArgs
Gizmox.WebGUI.Forms.ThreadExceptionEventArgs
Gizmox.WebGUI.Forms.ThreadMessageEventArgs

See Also

Reference

Gizmox.WebGUI.Common Assembly


Gizmox.WebGUI Namespace Inheritance Hierarchy

Gizmox.WebGUI.Common
Gizmox.WebGUI Namespace Inheritance Hierarchy
See Also Send Feedback

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.CommonSwitches
Gizmox.WebGUI.CommonUtils
Gizmox.WebGUI.WGAttributes
Gizmox.WebGUI.WGConst
Gizmox.WebGUI.WGLabels
Gizmox.WebGUI.WGTags

See Also

Reference

Gizmox.WebGUI.Common Assembly


Getting Started - Gizmox.WebGUI.Forms.Charts

Gizmox.WebGUI.Forms.Charts
Getting Started
Send Feedback


Introduction - Gizmox.WebGUI.Forms.Charts

Gizmox.WebGUI.Forms.Charts
Introduction
Send Feedback


Axes Class Events

[image]
Gizmox.WebGUI.Forms.Charts
Axes Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace : Axes Class

For a list of all members of this type, see Axes members.

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Disposed | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Gizmox.WebGUI.Forms.Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Top

See Also

Reference

Axes Class
Gizmox.WebGUI.Forms.Charts Namespace


AxisX Class Events

[image]
Gizmox.WebGUI.Forms.Charts
AxisX Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace : AxisX Class

For a list of all members of this type, see AxisX members.

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Disposed | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Gizmox.WebGUI.Forms.Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Top

See Also

Reference

AxisX Class
Gizmox.WebGUI.Forms.Charts Namespace


AxisX Class Properties

[image]
Gizmox.WebGUI.Forms.Charts
AxisX Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace : AxisX Class

For a list of all members of this type, see AxisX members.

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackColor | Gets or sets the background color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BindingContext | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Container | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Context | Gets the context. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Form | Gets the owner form. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Height | Gets/Sets the height position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | IsRegistered | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Left | Gets/Sets the left position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Location | Gets or sets the control location. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Prefix | Gets or sets the prefix. (Inherited from Axes)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Right | Gets/Sets the right position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Site | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Suffix | Gets or sets the suffix. (Inherited from Axes)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Title | Gets or sets the title. (Inherited from Axes)
Public Property | Top | Gets/Sets the top position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Visible | Gets or sets the control visability. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Width | Gets/Sets the width position (Inherited from Gizmox.WebGUI.Forms.Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultBorderColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultBorderStyle | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultForeColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMargin | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultPadding | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DesignMode | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | Events | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | IsConnected | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Property | IsDelayedDrawing | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | Session | Gets the application object. (Inherited from Gizmox.WebGUI.Forms.Component)
Top

See Also

Reference

AxisX Class
Gizmox.WebGUI.Forms.Charts Namespace


AxisY Class Events

[image]
Gizmox.WebGUI.Forms.Charts
AxisY Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace : AxisY Class

For a list of all members of this type, see AxisY members.

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Disposed | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Gizmox.WebGUI.Forms.Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Top

See Also

Reference

AxisY Class
Gizmox.WebGUI.Forms.Charts Namespace


AxisY Class Properties

[image]
Gizmox.WebGUI.Forms.Charts
AxisY Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace : AxisY Class

For a list of all members of this type, see AxisY members.

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackColor | Gets or sets the background color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BindingContext | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Container | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Context | Gets the context. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Form | Gets the owner form. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Height | Gets/Sets the height position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | IsRegistered | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Left | Gets/Sets the left position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Location | Gets or sets the control location. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Prefix | Gets or sets the prefix. (Inherited from Axes)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Right | Gets/Sets the right position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Site | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Suffix | Gets or sets the suffix. (Inherited from Axes)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Title | Gets or sets the title. (Inherited from Axes)
Public Property | Top | Gets/Sets the top position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Visible | Gets or sets the control visability. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Width | Gets/Sets the width position (Inherited from Gizmox.WebGUI.Forms.Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultBorderColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultBorderStyle | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultForeColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMargin | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultPadding | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DesignMode | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | Events | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | IsConnected | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Property | IsDelayedDrawing | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | Session | Gets the application object. (Inherited from Gizmox.WebGUI.Forms.Component)
Top

See Also

Reference

AxisY Class
Gizmox.WebGUI.Forms.Charts Namespace


Chart Class Events

[image]
Gizmox.WebGUI.Forms.Charts
Chart Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace : Chart Class

For a list of all members of this type, see Chart members.

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Disposed | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Gizmox.WebGUI.Forms.Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Top

See Also

Reference

Chart Class
Gizmox.WebGUI.Forms.Charts Namespace


Title Class Events

[image]
Gizmox.WebGUI.Forms.Charts
Title Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace : Title Class

For a list of all members of this type, see Title members.

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Disposed | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Gizmox.WebGUI.Forms.Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Top

See Also

Reference

Title Class
Gizmox.WebGUI.Forms.Charts Namespace


Title Class Properties

[image]
Gizmox.WebGUI.Forms.Charts
Title Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace : Title Class

For a list of all members of this type, see Title members.

Public Properties

 | Name | Description
Public Property | AlignmentX | Gets or sets the alignment X. (Inherited from TitleBase)
Public Property | AlignmentY | Gets or sets the alignment Y. (Inherited from TitleBase)
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackColor | Gets or sets the background color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BindingContext | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Container | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Context | Gets the context. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | FontSize | Gets or sets the size of the font. (Inherited from TitleBase)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Form | Gets the owner form. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Height | Gets/Sets the height position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | IsRegistered | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Left | Gets/Sets the left position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Location | Gets or sets the control location. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Right | Gets/Sets the right position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Site | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from TitleBase)
Public Property | Top | Gets/Sets the top position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Visible | Gets or sets the control visability. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Width | Gets/Sets the width position (Inherited from Gizmox.WebGUI.Forms.Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultBorderColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultBorderStyle | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultForeColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMargin | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultPadding | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DesignMode | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | Events | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | IsConnected | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Property | IsDelayedDrawing | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | Session | Gets the application object. (Inherited from Gizmox.WebGUI.Forms.Component)
Top

See Also

Reference

Title Class
Gizmox.WebGUI.Forms.Charts Namespace


TitleBase Class Events

[image]
Gizmox.WebGUI.Forms.Charts
TitleBase Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace : TitleBase Class

For a list of all members of this type, see TitleBase members.

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Disposed | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Gizmox.WebGUI.Forms.Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Top

See Also

Reference

TitleBase Class
Gizmox.WebGUI.Forms.Charts Namespace


TitleBase Class Methods

[image]
Gizmox.WebGUI.Forms.Charts
TitleBase Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms.Charts Namespace : TitleBase Class

For a list of all members of this type, see TitleBase members.

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Focus | Sets focus to this control (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | GetPreferredSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | ResetText | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SendToBack | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Show | Displays the control to the user. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ToString | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Update | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | Finalize | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCommandText | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetImage | Gets the image. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetPreferredSizeCore | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetService | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | InvokeMethod | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | IsDirty | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBindingContextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnControlAdded | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnControlRemoved | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | OnEnabledChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnGotFocus | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLostFocus | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentVisibleChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnResize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnTextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnUnregisterComponents | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnValidated | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnValidating | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ProcessGatewayRequest | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RegisterSelf | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | RenderAttributes | Renders the controls meta attributes (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderClientUpdateHandler | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderComponentEventAttributes | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetImage | Sets the image. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeText | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | UnRegisterBatch | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | UnRegisterSelf | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | UpdateParams | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Top

See Also

Reference

TitleBase Class
Gizmox.WebGUI.Forms.Charts Namespace


Gizmox.WebGUI.Forms.Charts Namespace Inheritance Hierarchy

Gizmox.WebGUI.Forms.Charts
Gizmox.WebGUI.Forms.Charts Namespace Inheritance Hierarchy
See Also Send Feedback

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.Charts.Data
Gizmox.WebGUI.Forms.Charts.DataPoint
Gizmox.WebGUI.Forms.Charts.DataSeries
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.Charts.Axes
Gizmox.WebGUI.Forms.Charts.AxisX
Gizmox.WebGUI.Forms.Charts.AxisY
Gizmox.WebGUI.Forms.Charts.Chart
Gizmox.WebGUI.Forms.Charts.TitleBase
Gizmox.WebGUI.Forms.Charts.Title

See Also

Reference

Gizmox.WebGUI.Forms.Charts Assembly


Getting Started - Gizmox.WebGUI.Forms.Extended

Gizmox.WebGUI.Forms.Extended
Getting Started
Send Feedback


Introduction - Gizmox.WebGUI.Forms.Extended

Gizmox.WebGUI.Forms.Extended
Introduction
Send Feedback


Gizmox.WebGUI.Forms.Editors Namespace Inheritance Hierarchy

Gizmox.WebGUI.Forms.Extended
Gizmox.WebGUI.Forms.Editors Namespace Inheritance Hierarchy
See Also Send Feedback

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.Editors.FCKEditor
Gizmox.WebGUI.Forms.Editors.FCKeditorConfigurations

See Also

Reference

Gizmox.WebGUI.Forms.Extended Assembly


SurfacePanel Class Events

[image]
Gizmox.WebGUI.Forms.Extended
SurfacePanel Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : SurfacePanel Class

For a list of all members of this type, see SurfacePanel members.

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

SurfacePanel Class
Gizmox.WebGUI.Forms Namespace


SurfacePanel Class Methods

[image]
Gizmox.WebGUI.Forms.Extended
SurfacePanel Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : SurfacePanel Class

For a list of all members of this type, see SurfacePanel members.

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Control)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from ScrollableControl)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Control)
Protected Method | RenderAttributes | (Inherited from Panel)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | (Inherited from Panel)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializePanelType | (Inherited from Panel)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

See Also

Reference

SurfacePanel Class
Gizmox.WebGUI.Forms Namespace


SurfacePanel Class Properties

[image]
Gizmox.WebGUI.Forms.Extended
SurfacePanel Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : SurfacePanel Class

For a list of all members of this type, see SurfacePanel members.

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl)
Public Property | AutoSize | (Inherited from Panel)
Public Property | AutoSizeMode | Indicates the automatic sizing behavior of the control. (Inherited from Panel)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Gets a value indicating whether this control can recive focus. (Inherited from Panel)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text. (Inherited from Panel)
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Protected Property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl)
Top

See Also

Reference

SurfacePanel Class
Gizmox.WebGUI.Forms Namespace


WatermarkTextBox Class Events

[image]
Gizmox.WebGUI.Forms.Extended
WatermarkTextBox Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : WatermarkTextBox Class

For a list of all members of this type, see WatermarkTextBox members.

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | EnterKeyDown | Occurs on enter key down only on single line. (Inherited from TextBox)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

WatermarkTextBox Class
Gizmox.WebGUI.Forms Namespace


WatermarkTextBox Class Fields

[image]
Gizmox.WebGUI.Forms.Extended
WatermarkTextBox Class Fields
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : WatermarkTextBox Class

For a list of all members of this type, see WatermarkTextBox members.

Protected Fields

 | Name | Description
Protected Field | menmScrollBars | Member which holds the scrollbars mode. (Inherited from TextBox)
Top

See Also

Reference

WatermarkTextBox Class
Gizmox.WebGUI.Forms Namespace


WorkspaceTab Class Events

[image]
Gizmox.WebGUI.Forms.Extended
WorkspaceTab Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : WorkspaceTab Class

For a list of all members of this type, see WorkspaceTab members.

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

WorkspaceTab Class
Gizmox.WebGUI.Forms Namespace


WorkspaceTab Class Methods

[image]
Gizmox.WebGUI.Forms.Extended
WorkspaceTab Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : WorkspaceTab Class

For a list of all members of this type, see WorkspaceTab members.

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | CompareTo | Compares the current instance with another object of the same type. (Inherited from TabPage)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | Returns a string containing the value of the TabPage.Text property. (Inherited from TabPage)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Control)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from ScrollableControl)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Control)
Protected Method | RenderAttributes | Render control attributes (Inherited from TabPage)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from TabPage)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | (Inherited from Panel)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeImage | Shows the serialize image. (Inherited from TabPage)
Protected Method | ShouldSerializePanelType | (Inherited from Panel)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

See Also

Reference

WorkspaceTab Class
Gizmox.WebGUI.Forms Namespace


WorkspaceTab Class Properties

[image]
Gizmox.WebGUI.Forms.Extended
WorkspaceTab Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : WorkspaceTab Class

For a list of all members of this type, see WorkspaceTab members.

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl)
Public Property | AutoSize | (Inherited from Panel)
Public Property | AutoSizeMode | Indicates the automatic sizing behavior of the control. (Inherited from Panel)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Gets a value indicating whether this control can recive focus. (Inherited from Panel)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | Image | Gets or sets the image. (Inherited from TabPage)
Public Property | ImageIndex | Gets or sets the index of the image that is displayed for the item. (Inherited from TabPage)
Public Property | ImageKey | Gets or sets the key for the image that is displayed for the item. (Inherited from TabPage)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Loaded | Gets a value indicating whether this TabPage is loaded. (Inherited from TabPage)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | PanelType | Gets or sets the panel type. (Inherited from TabPage)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | TabControl | Gets the TabControl control. (Inherited from TabPage)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text to display on the tab. (Inherited from TabPage)
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | Visible | Gets or sets the control visability. (Inherited from TabPage)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Protected Property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl)
Top

See Also

Reference

WorkspaceTab Class
Gizmox.WebGUI.Forms Namespace


WorkspaceTabs Class Events

[image]
Gizmox.WebGUI.Forms.Extended
WorkspaceTabs Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : WorkspaceTabs Class

For a list of all members of this type, see WorkspaceTabs members.

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | CloseClick | Occurs when the user clicks the tab control close button (Inherited from TabControl)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | SelectedIndexChanged | Occurs when the SelectedIndex property is changed. (Inherited from TabControl)
Public Event | SelectedIndexChanging | Occurs when the SelectedIndex property is about to change. (Inherited from TabControl)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

WorkspaceTabs Class
Gizmox.WebGUI.Forms Namespace


Gizmox.WebGUI.Forms Namespace (Gizmox.WebGUI.Forms.Extended) Inheritance Hierarchy

Gizmox.WebGUI.Forms.Extended
Gizmox.WebGUI.Forms Namespace (Gizmox.WebGUI.Forms.Extended) Inheritance Hierarchy
See Also Send Feedback

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.ScrollableControl
Gizmox.WebGUI.Forms.Panel
Gizmox.WebGUI.Forms.SurfacePanel
Gizmox.WebGUI.Forms.TabPage
Gizmox.WebGUI.Forms.WorkspaceTab
Gizmox.WebGUI.Forms.TabControl
Gizmox.WebGUI.Forms.WorkspaceTabs
Gizmox.WebGUI.Forms.TextBoxBase
Gizmox.WebGUI.Forms.TextBox
Gizmox.WebGUI.Forms.WatermarkTextBox
Gizmox.WebGUI.Forms.TabPageCollection
Gizmox.WebGUI.Forms.WorkspaceTabsCollection

See Also

Reference

Gizmox.WebGUI.Forms.Extended Assembly


Getting Started - Gizmox.WebGUI.Forms.Office

Gizmox.WebGUI.Forms.Office
Getting Started
Send Feedback


Introduction - Gizmox.WebGUI.Forms.Office

Gizmox.WebGUI.Forms.Office
Introduction
Send Feedback


HeaderedPanel Class Events

[image]
Gizmox.WebGUI.Forms.Office
HeaderedPanel Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : HeaderedPanel Class

For a list of all members of this type, see HeaderedPanel members.

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

HeaderedPanel Class
Gizmox.WebGUI.Forms Namespace


NavigationTab Class Events

[image]
Gizmox.WebGUI.Forms.Office
NavigationTab Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : NavigationTab Class

For a list of all members of this type, see NavigationTab members.

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

NavigationTab Class
Gizmox.WebGUI.Forms Namespace


NavigationTabs Class Events

[image]
Gizmox.WebGUI.Forms.Office
NavigationTabs Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : NavigationTabs Class

For a list of all members of this type, see NavigationTabs members.

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | CloseClick | Occurs when the user clicks the tab control close button (Inherited from TabControl)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | SelectedIndexChanged | Occurs when the SelectedIndex property is changed. (Inherited from TabControl)
Public Event | SelectedIndexChanging | Occurs when the SelectedIndex property is about to change. (Inherited from TabControl)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

NavigationTabs Class
Gizmox.WebGUI.Forms Namespace


RibbonBar Class Fields

[image]
Gizmox.WebGUI.Forms.Office
RibbonBar Class Fields
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBar Class

For a list of all members of this type, see RibbonBar members.

Public Fields

 | Name | Description
Public Field | mblnIsLoaded | Gets a value indicating whether the instance of UserControl is loaded. (Inherited from UserControl)
Top

See Also

Reference

RibbonBar Class
Gizmox.WebGUI.Forms Namespace


RibbonBarCheckBoxItem Class Events

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarCheckBoxItem Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarCheckBoxItem Class

For a list of all members of this type, see RibbonBarCheckBoxItem members.

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from ComponentBase)
Top

See Also

Reference

RibbonBarCheckBoxItem Class
Gizmox.WebGUI.Forms Namespace


RibbonBarCheckBoxItem Class Properties

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarCheckBoxItem Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarCheckBoxItem Class

For a list of all members of this type, see RibbonBarCheckBoxItem members.

Public Properties

 | Name | Description
Public Property | Container | (Inherited from ComponentBase)
Public Property | Control | Gets the control. (Inherited from RibbonBarItem)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from RibbonBarItem)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Tag | Gets/Sets user definied tag (Inherited from RibbonBarItem)
Public Property | Text | Gets or sets the text. (Inherited from RibbonBarItem)
Public Property | ToolTip | Gets or sets the control tooltip. (Inherited from RibbonBarItem)
Public Property | Visible | Gets or sets a value indicating whether this RibbonBarItem is visible. (Inherited from RibbonBarItem)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Top

See Also

Reference

RibbonBarCheckBoxItem Class
Gizmox.WebGUI.Forms Namespace


RibbonBarDropDownButtonItem Class Events

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarDropDownButtonItem Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarDropDownButtonItem Class

For a list of all members of this type, see RibbonBarDropDownButtonItem members.

Public Events

 | Name | Description
Public Event | Click | Occurs when a ribbon bar button has been clicked (Inherited from RibbonBarButtonItem)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from RibbonBarButtonItem)
Top

See Also

Reference

RibbonBarDropDownButtonItem Class
Gizmox.WebGUI.Forms Namespace


RibbonBarFlowItem Class Events

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarFlowItem Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarFlowItem Class

For a list of all members of this type, see RibbonBarFlowItem members.

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from ComponentBase)
Top

See Also

Reference

RibbonBarFlowItem Class
Gizmox.WebGUI.Forms Namespace


RibbonBarGroup Class Events

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarGroup Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarGroup Class

For a list of all members of this type, see RibbonBarGroup members.

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from ComponentBase)
Top

See Also

Reference

RibbonBarGroup Class
Gizmox.WebGUI.Forms Namespace


RibbonBarGroupCollection Class Properties

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarGroupCollection Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarGroupCollection Class

For a list of all members of this type, see RibbonBarGroupCollection members.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<RibbonBarGroup>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<RibbonBarGroup>)
Top

Protected Properties

 | Name | Description
Protected Property | Items | (Inherited from System.Collections.ObjectModel.Collection<RibbonBarGroup>)
Top

See Also

Reference

RibbonBarGroupCollection Class
Gizmox.WebGUI.Forms Namespace


RibbonBarItem Class Events

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarItem Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarItem Class

For a list of all members of this type, see RibbonBarItem members.

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from ComponentBase)
Top

See Also

Reference

RibbonBarItem Class
Gizmox.WebGUI.Forms Namespace


RibbonBarItemCollection Class Properties

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarItemCollection Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarItemCollection Class

For a list of all members of this type, see RibbonBarItemCollection members.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<RibbonBarItem>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<RibbonBarItem>)
Top

Protected Properties

 | Name | Description
Protected Property | Items | (Inherited from System.Collections.ObjectModel.Collection<RibbonBarItem>)
Top

See Also

Reference

RibbonBarItemCollection Class
Gizmox.WebGUI.Forms Namespace


RibbonBarItemContainer Class Events

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarItemContainer Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarItemContainer Class

For a list of all members of this type, see RibbonBarItemContainer members.

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from ComponentBase)
Top

See Also

Reference

RibbonBarItemContainer Class
Gizmox.WebGUI.Forms Namespace


RibbonBarPage Class Events

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarPage Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarPage Class

For a list of all members of this type, see RibbonBarPage members.

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from ComponentBase)
Top

See Also

Reference

RibbonBarPage Class
Gizmox.WebGUI.Forms Namespace


RibbonBarPageCollection Class Properties

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarPageCollection Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarPageCollection Class

For a list of all members of this type, see RibbonBarPageCollection members.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<RibbonBarPage>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<RibbonBarPage>)
Top

Protected Properties

 | Name | Description
Protected Property | Items | (Inherited from System.Collections.ObjectModel.Collection<RibbonBarPage>)
Top

See Also

Reference

RibbonBarPageCollection Class
Gizmox.WebGUI.Forms Namespace


RibbonBarStackItem Class Events

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarStackItem Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarStackItem Class

For a list of all members of this type, see RibbonBarStackItem members.

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from ComponentBase)
Top

See Also

Reference

RibbonBarStackItem Class
Gizmox.WebGUI.Forms Namespace


RibbonBarTextBoxItem Class Events

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarTextBoxItem Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarTextBoxItem Class

For a list of all members of this type, see RibbonBarTextBoxItem members.

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from ComponentBase)
Top

See Also

Reference

RibbonBarTextBoxItem Class
Gizmox.WebGUI.Forms Namespace


RibbonBarTextBoxItem Class Properties

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarTextBoxItem Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarTextBoxItem Class

For a list of all members of this type, see RibbonBarTextBoxItem members.

Public Properties

 | Name | Description
Public Property | Container | (Inherited from ComponentBase)
Public Property | Control | Gets the control. (Inherited from RibbonBarItem)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from RibbonBarItem)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Tag | Gets/Sets user definied tag (Inherited from RibbonBarItem)
Public Property | Text | Gets or sets the text. (Inherited from RibbonBarItem)
Public Property | ToolTip | Gets or sets the control tooltip. (Inherited from RibbonBarItem)
Public Property | Visible | Gets or sets a value indicating whether this RibbonBarItem is visible. (Inherited from RibbonBarItem)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Top

See Also

Reference

RibbonBarTextBoxItem Class
Gizmox.WebGUI.Forms Namespace


RibbonBarToolBarButtonItem Class Events

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarToolBarButtonItem Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarToolBarButtonItem Class

For a list of all members of this type, see RibbonBarToolBarButtonItem members.

Public Events

 | Name | Description
Public Event | Click | Occurs when a ribbon bar button has been clicked (Inherited from RibbonBarButtonItem)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from RibbonBarButtonItem)
Top

See Also

Reference

RibbonBarToolBarButtonItem Class
Gizmox.WebGUI.Forms Namespace


RibbonBarToolBarDropDownButtonItem Class Events

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarToolBarDropDownButtonItem Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarToolBarDropDownButtonItem Class

For a list of all members of this type, see RibbonBarToolBarDropDownButtonItem members.

Public Events

 | Name | Description
Public Event | Click | Occurs when a ribbon bar button has been clicked (Inherited from RibbonBarButtonItem)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from RibbonBarButtonItem)
Top

See Also

Reference

RibbonBarToolBarDropDownButtonItem Class
Gizmox.WebGUI.Forms Namespace


RibbonBarToolBarItem Class Events

[image]
Gizmox.WebGUI.Forms.Office
RibbonBarToolBarItem Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RibbonBarToolBarItem Class

For a list of all members of this type, see RibbonBarToolBarItem members.

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from ComponentBase)
Top

See Also

Reference

RibbonBarToolBarItem Class
Gizmox.WebGUI.Forms Namespace


SearchTextBox Class Fields

[image]
Gizmox.WebGUI.Forms.Office
SearchTextBox Class Fields
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : SearchTextBox Class

For a list of all members of this type, see SearchTextBox members.

Protected Fields

 | Name | Description
Protected Field | menmScrollBars | Member which holds the scrollbars mode. (Inherited from TextBox)
Top

See Also

Reference

SearchTextBox Class
Gizmox.WebGUI.Forms Namespace


Gizmox.WebGUI.Forms Namespace (Gizmox.WebGUI.Forms.Office) Inheritance Hierarchy

Gizmox.WebGUI.Forms.Office
Gizmox.WebGUI.Forms Namespace (Gizmox.WebGUI.Forms.Office) Inheritance Hierarchy
See Also Send Feedback

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.BaseCollection
Gizmox.WebGUI.Forms.ScheduleBoxEventCollection
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.RichTextEditor
Gizmox.WebGUI.Forms.ScheduleBox
Gizmox.WebGUI.Forms.ScrollableControl
Gizmox.WebGUI.Forms.ContainerControl
Gizmox.WebGUI.Forms.UserControl
Gizmox.WebGUI.Forms.RibbonBar
Gizmox.WebGUI.Forms.Panel
Gizmox.WebGUI.Forms.HeaderedPanel
Gizmox.WebGUI.Forms.TabPage
Gizmox.WebGUI.Forms.NavigationTab
Gizmox.WebGUI.Forms.TabControl
Gizmox.WebGUI.Forms.NavigationTabs
Gizmox.WebGUI.Forms.TextBoxBase
Gizmox.WebGUI.Forms.TextBox
Gizmox.WebGUI.Forms.SearchTextBox
Gizmox.WebGUI.Forms.RibbonBarItem
Gizmox.WebGUI.Forms.RibbonBarButtonItem
Gizmox.WebGUI.Forms.RibbonBarDropDownButtonItem
Gizmox.WebGUI.Forms.RibbonBarToolBarDropDownButtonItem
Gizmox.WebGUI.Forms.RibbonBarToolBarButtonItem
Gizmox.WebGUI.Forms.RibbonBarCheckBoxItem
Gizmox.WebGUI.Forms.RibbonBarComboBoxItem
Gizmox.WebGUI.Forms.RibbonBarItemContainer
Gizmox.WebGUI.Forms.RibbonBarFlowItem
Gizmox.WebGUI.Forms.RibbonBarGroup
Gizmox.WebGUI.Forms.RibbonBarStackItem
Gizmox.WebGUI.Forms.RibbonBarToolBarItem
Gizmox.WebGUI.Forms.RibbonBarTextBoxItem
Gizmox.WebGUI.Forms.RibbonBarPage
Gizmox.WebGUI.Forms.ScheduleBoxEvent
Gizmox.WebGUI.Forms.TabPageCollection
Gizmox.WebGUI.Forms.NavigationTabCollection
System.Collections.ObjectModel.Collection<RibbonBarGroup>
Gizmox.WebGUI.Forms.RibbonBarGroupCollection
System.Collections.ObjectModel.Collection<RibbonBarItem>
Gizmox.WebGUI.Forms.RibbonBarItemCollection
System.Collections.ObjectModel.Collection<RibbonBarPage>
Gizmox.WebGUI.Forms.RibbonBarPageCollection
System.EventArgs
Gizmox.WebGUI.Forms.NavigationTabEventArgs
Gizmox.WebGUI.Forms.RibbonBarButtonItemArgs
Gizmox.WebGUI.Forms.RibbonBarButtonItemMenuClickArgs
Gizmox.WebGUI.Forms.RibbonBarCheckBoxItemArgs
Gizmox.WebGUI.Forms.RibbonBarGroupArgs
Gizmox.WebGUI.Forms.RibbonBarTextBoxItemArgs
Gizmox.WebGUI.Forms.ScheduleBox.ScheduleBoxEventArgs

See Also

Reference

Gizmox.WebGUI.Forms.Office Assembly


Getting Started - Gizmox.WebGUI.Forms

Getting Started
Send Feedback


Introduction - Gizmox.WebGUI.Forms

Introduction
Send Feedback


LogonForm Class Events

[image]
Gizmox.WebGUI.Forms
LogonForm Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms.Authentication Namespace : LogonForm Class

For a list of all members of this type, see LogonForm members.

Public Events

 | Name | Description
Public Event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Closed | (Inherited from Gizmox.WebGUI.Forms.Form)
Public Event | Closing | The form closing event. This event is not raised on the main form. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Disposed | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Load | The form load event (Inherited from Gizmox.WebGUI.Forms.Form)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Gizmox.WebGUI.Forms.Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Top

See Also

Reference

LogonForm Class
Gizmox.WebGUI.Forms.Authentication Namespace


LogonForm Class Methods

[image]
Gizmox.WebGUI.Forms
LogonForm Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms.Authentication Namespace : LogonForm Class

For a list of all members of this type, see LogonForm members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from Gizmox.WebGUI.Forms.ContainerControl)
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Close | Closes this window. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Gizmox.WebGUI.Forms.ContainerControl)
Public Method | Focus | Sets focus to this control (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | GetPreferredSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Remove | (Inherited from Gizmox.WebGUI.Forms.ContainerControl)
Public Method | ResetText | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Public Method | Select | Overloaded. Activates the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SendToBack | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Show | (Inherited from Gizmox.WebGUI.Forms.Form)
Public Method | ShowDialog | Overloaded. Shows a the form as a dialog. The ShowDialog in Visual WebGui works differently than WinForms. Code lines after this call is executed immediately and won’t wait for the dialog to close. If you need to run code only after the dialog is closed or only if a specific result is returned register to the close event of the dialog. See documentation for code example. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Method | ShowPopup | Overloaded. Displays the form as a popup window. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ToString | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Update | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | Finalize | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCommandText | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetImage | Gets the image. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetPreferredSizeCore | (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Protected Method | GetService | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | InvokeMethod | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | IsDirty | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | OnActivated | Raises the Activated event. (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBindingContextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnClosed | (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnClosing | (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnControlAdded | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnControlRemoved | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnCreateControl | Occurs when control is created (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | OnEnabledChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnGotFocus | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLoad | Raises the Load event. (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnLocationChanged | (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnLostFocus | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentVisibleChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnResize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnTextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnUnregisterComponents | (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnValidated | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnValidating | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ProcessGatewayRequest | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RegisterSelf | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | Render | Render the form content (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | RenderAttributes | Renders the forms attribute (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderClientUpdateHandler | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderComponentEventAttributes | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderUpdatedAttributes | (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetImage | Sets the image. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeText | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | UnRegisterBatch | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | UnRegisterSelf | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | UpdateParams | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Top

See Also

Reference

LogonForm Class
Gizmox.WebGUI.Forms.Authentication Namespace


LogonForm Class Properties

[image]
Gizmox.WebGUI.Forms
LogonForm Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms.Authentication Namespace : LogonForm Class

For a list of all members of this type, see LogonForm members.

Public Properties

 | Name | Description
Public Property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | ActiveControl | Gets or sets the active control on the container control. (Inherited from Gizmox.WebGUI.Forms.ContainerControl)
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | AutoScaleBaseSize | Gets or sets the size of the auto scale base. Not implemented. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Public Property | BackColor | Gets or sets the background color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BeforeUnloadMessage | Gets or sets the before unload message. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | BindingContext | (Inherited from Gizmox.WebGUI.Forms.ContainerControl)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CancelButton | Gets or sets the button on the form that is clicked when the user presses the ESC key. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Components | (Inherited from Gizmox.WebGUI.Forms.ContainerControl)
Public Property | Container | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Context | Gets the context. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | DialogResult | Gets or sets the dialog result. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Public Property | DragMappings | Gets the form drag mappings. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Form | Gets the owner form. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | FormBorderStyle | Gets or sets the form border style. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | FormStyle | Gets or sets the form style. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | HasControls | Gets a value indicating whether this control has controls. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Header | Gets or sets the form header control. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Height | Gets/Sets the height position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Icon | Gets or sets the form icon (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | IsRegistered | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Left | Gets/Sets the left position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Location | Gets or sets the control location. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | MaximizeBox | Gets or sets a value indicating whether [maximize box]. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | MinimizeBox | Gets or sets a value indicating whether [minimize box]. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Modal | Gets or sets a value indicating whether this window is modal. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | OwnedForms | Gets the child forms. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Owner | Gets the parent window. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Padding | Gets or sets the control padding. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Right | Gets/Sets the right position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ShowInTaskbar | Gets or sets a value indicating whether [show in taskbar]. Not implemented by design (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Site | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | StartPosition | Gets or sets the form start position. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Top | Gets/Sets the top position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Visible | Get/Sets the form visibility (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Width | Gets/Sets the width position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | WindowState | Gets or sets the state of the window. (Inherited from Gizmox.WebGUI.Forms.Form)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultBorderColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultBorderStyle | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultForeColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMargin | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultPadding | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DesignMode | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | Events | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Protected Property | IsConnected | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Property | IsDelayedDrawing | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | IsWindowSized | Calculate size invluding borders (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | Session | Gets or sets the main form. (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Top

See Also

Reference

LogonForm Class
Gizmox.WebGUI.Forms.Authentication Namespace


LogonListenerForm Class Events

[image]
Gizmox.WebGUI.Forms
LogonListenerForm Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms.Authentication Namespace : LogonListenerForm Class

For a list of all members of this type, see LogonListenerForm members.

Public Events

 | Name | Description
Public Event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Closed | (Inherited from Gizmox.WebGUI.Forms.Form)
Public Event | Closing | The form closing event. This event is not raised on the main form. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Disposed | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Load | The form load event (Inherited from Gizmox.WebGUI.Forms.Form)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Gizmox.WebGUI.Forms.Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Top

See Also

Reference

LogonListenerForm Class
Gizmox.WebGUI.Forms.Authentication Namespace


LogonListenerForm Class Methods

[image]
Gizmox.WebGUI.Forms
LogonListenerForm Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms.Authentication Namespace : LogonListenerForm Class

For a list of all members of this type, see LogonListenerForm members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from Gizmox.WebGUI.Forms.ContainerControl)
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Close | Closes this window. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Gizmox.WebGUI.Forms.ContainerControl)
Public Method | Focus | Sets focus to this control (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | GetPreferredSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Remove | (Inherited from Gizmox.WebGUI.Forms.ContainerControl)
Public Method | ResetText | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Public Method | Select | Overloaded. Activates the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SendToBack | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Show | (Inherited from Gizmox.WebGUI.Forms.Form)
Public Method | ShowDialog | Overloaded. Shows a the form as a dialog. The ShowDialog in Visual WebGui works differently than WinForms. Code lines after this call is executed immediately and won’t wait for the dialog to close. If you need to run code only after the dialog is closed or only if a specific result is returned register to the close event of the dialog. See documentation for code example. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Method | ShowPopup | Overloaded. Displays the form as a popup window. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ToString | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Update | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | Finalize | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCommandText | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetImage | Gets the image. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetPreferredSizeCore | (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Protected Method | GetService | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | InvokeMethod | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | IsDirty | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | OnActivated | Raises the Activated event. (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBindingContextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnClosed | (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnClosing | (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnControlAdded | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnControlRemoved | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnCreateControl | Occurs when control is created (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | OnEnabledChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnGotFocus | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLoad | Raises the Load event. (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnLocationChanged | (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnLostFocus | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentVisibleChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnResize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnTextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnUnregisterComponents | (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnValidated | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnValidating | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ProcessGatewayRequest | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RegisterSelf | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | Render | Render the form content (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | RenderAttributes | Renders the forms attribute (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderClientUpdateHandler | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderComponentEventAttributes | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderUpdatedAttributes | (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetImage | Sets the image. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeText | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | UnRegisterBatch | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | UnRegisterSelf | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | UpdateParams | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Top

See Also

Reference

LogonListenerForm Class
Gizmox.WebGUI.Forms.Authentication Namespace


LogonListenerForm Class Properties

[image]
Gizmox.WebGUI.Forms
LogonListenerForm Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms.Authentication Namespace : LogonListenerForm Class

For a list of all members of this type, see LogonListenerForm members.

Public Properties

 | Name | Description
Public Property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | ActiveControl | Gets or sets the active control on the container control. (Inherited from Gizmox.WebGUI.Forms.ContainerControl)
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | AutoScaleBaseSize | Gets or sets the size of the auto scale base. Not implemented. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Public Property | BackColor | Gets or sets the background color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BeforeUnloadMessage | Gets or sets the before unload message. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | BindingContext | (Inherited from Gizmox.WebGUI.Forms.ContainerControl)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CancelButton | Gets or sets the button on the form that is clicked when the user presses the ESC key. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Components | (Inherited from Gizmox.WebGUI.Forms.ContainerControl)
Public Property | Container | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Context | Gets the context. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | DialogResult | Gets or sets the dialog result. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Public Property | DragMappings | Gets the form drag mappings. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Form | Gets the owner form. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | FormBorderStyle | Gets or sets the form border style. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | FormStyle | Gets or sets the form style. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | HasControls | Gets a value indicating whether this control has controls. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Header | Gets or sets the form header control. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Height | Gets/Sets the height position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Icon | Gets or sets the form icon (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | IsRegistered | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Left | Gets/Sets the left position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Location | Gets or sets the control location. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | MaximizeBox | Gets or sets a value indicating whether [maximize box]. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | MinimizeBox | Gets or sets a value indicating whether [minimize box]. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Modal | Gets or sets a value indicating whether this window is modal. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | OwnedForms | Gets the child forms. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Owner | Gets the parent window. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Padding | Gets or sets the control padding. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Right | Gets/Sets the right position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ShowInTaskbar | Gets or sets a value indicating whether [show in taskbar]. Not implemented by design (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Site | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | StartPosition | Gets or sets the form start position. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Top | Gets/Sets the top position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Visible | Get/Sets the form visibility (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Width | Gets/Sets the width position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | WindowState | Gets or sets the state of the window. (Inherited from Gizmox.WebGUI.Forms.Form)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultBorderColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultBorderStyle | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultForeColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMargin | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultPadding | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DesignMode | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | Events | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Protected Property | IsConnected | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Property | IsDelayedDrawing | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | IsWindowSized | Calculate size invluding borders (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | Session | Gets or sets the main form. (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Top

See Also

Reference

LogonListenerForm Class
Gizmox.WebGUI.Forms.Authentication Namespace


LogonOpenerForm Class Events

[image]
Gizmox.WebGUI.Forms
LogonOpenerForm Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms.Authentication Namespace : LogonOpenerForm Class

For a list of all members of this type, see LogonOpenerForm members.

Public Events

 | Name | Description
Public Event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Closed | (Inherited from Gizmox.WebGUI.Forms.Form)
Public Event | Closing | The form closing event. This event is not raised on the main form. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Disposed | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Load | The form load event (Inherited from Gizmox.WebGUI.Forms.Form)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Gizmox.WebGUI.Forms.Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Top

See Also

Reference

LogonOpenerForm Class
Gizmox.WebGUI.Forms.Authentication Namespace


LogonOpenerForm Class Methods

[image]
Gizmox.WebGUI.Forms
LogonOpenerForm Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms.Authentication Namespace : LogonOpenerForm Class

For a list of all members of this type, see LogonOpenerForm members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from Gizmox.WebGUI.Forms.ContainerControl)
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Close | Closes this window. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Gizmox.WebGUI.Forms.ContainerControl)
Public Method | Focus | Sets focus to this control (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | GetPreferredSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Remove | (Inherited from Gizmox.WebGUI.Forms.ContainerControl)
Public Method | ResetText | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Public Method | Select | Overloaded. Activates the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SendToBack | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Show | (Inherited from Gizmox.WebGUI.Forms.Form)
Public Method | ShowDialog | Overloaded. Shows a the form as a dialog. The ShowDialog in Visual WebGui works differently than WinForms. Code lines after this call is executed immediately and won’t wait for the dialog to close. If you need to run code only after the dialog is closed or only if a specific result is returned register to the close event of the dialog. See documentation for code example. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Method | ShowPopup | Overloaded. Displays the form as a popup window. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ToString | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Update | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | Finalize | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCommandText | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetImage | Gets the image. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetPreferredSizeCore | (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Protected Method | GetService | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | InvokeMethod | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | IsDirty | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | OnActivated | Raises the Activated event. (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBindingContextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnClosed | (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnClosing | (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnControlAdded | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnControlRemoved | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnCreateControl | Occurs when control is created (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | OnEnabledChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnGotFocus | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLoad | Raises the Load event. (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnLocationChanged | (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnLostFocus | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentVisibleChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnResize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnTextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnUnregisterComponents | (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnValidated | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnValidating | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ProcessGatewayRequest | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RegisterSelf | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | Render | Render the form content (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | RenderAttributes | Renders the forms attribute (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderClientUpdateHandler | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderComponentEventAttributes | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderUpdatedAttributes | (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetImage | Sets the image. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeText | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | UnRegisterBatch | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | UnRegisterSelf | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | UpdateParams | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Top

See Also

Reference

LogonOpenerForm Class
Gizmox.WebGUI.Forms.Authentication Namespace


LogonOpenerForm Class Properties

[image]
Gizmox.WebGUI.Forms
LogonOpenerForm Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms.Authentication Namespace : LogonOpenerForm Class

For a list of all members of this type, see LogonOpenerForm members.

Public Properties

 | Name | Description
Public Property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | ActiveControl | Gets or sets the active control on the container control. (Inherited from Gizmox.WebGUI.Forms.ContainerControl)
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | AutoScaleBaseSize | Gets or sets the size of the auto scale base. Not implemented. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Public Property | BackColor | Gets or sets the background color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BeforeUnloadMessage | Gets or sets the before unload message. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | BindingContext | (Inherited from Gizmox.WebGUI.Forms.ContainerControl)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CancelButton | Gets or sets the button on the form that is clicked when the user presses the ESC key. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Components | (Inherited from Gizmox.WebGUI.Forms.ContainerControl)
Public Property | Container | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Context | Gets the context. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | DialogResult | Gets or sets the dialog result. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Public Property | DragMappings | Gets the form drag mappings. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Form | Gets the owner form. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | FormBorderStyle | Gets or sets the form border style. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | FormStyle | Gets or sets the form style. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | HasControls | Gets a value indicating whether this control has controls. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Header | Gets or sets the form header control. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Height | Gets/Sets the height position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Icon | Gets or sets the form icon (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | IsRegistered | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Left | Gets/Sets the left position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Location | Gets or sets the control location. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | MaximizeBox | Gets or sets a value indicating whether [maximize box]. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | MinimizeBox | Gets or sets a value indicating whether [minimize box]. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Modal | Gets or sets a value indicating whether this window is modal. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | OwnedForms | Gets the child forms. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Owner | Gets the parent window. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Padding | Gets or sets the control padding. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Right | Gets/Sets the right position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ShowInTaskbar | Gets or sets a value indicating whether [show in taskbar]. Not implemented by design (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Site | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | StartPosition | Gets or sets the form start position. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Top | Gets/Sets the top position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Visible | Get/Sets the form visibility (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Width | Gets/Sets the width position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | WindowState | Gets or sets the state of the window. (Inherited from Gizmox.WebGUI.Forms.Form)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultBorderColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultBorderStyle | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultForeColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMargin | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultPadding | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DesignMode | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | Events | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Protected Property | IsConnected | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Property | IsDelayedDrawing | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | IsWindowSized | Calculate size invluding borders (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | Session | Gets or sets the main form. (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Top

See Also

Reference

LogonOpenerForm Class
Gizmox.WebGUI.Forms.Authentication Namespace


Gizmox.WebGUI.Forms.Authentication Namespace Inheritance Hierarchy

Gizmox.WebGUI.Forms.Authentication Namespace Inheritance Hierarchy
See Also Send Feedback

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.ScrollableControl
Gizmox.WebGUI.Forms.ContainerControl
Gizmox.WebGUI.Forms.Form
Gizmox.WebGUI.Forms.Authentication.LogonForm
Gizmox.WebGUI.Forms.Authentication.LogonListenerForm
Gizmox.WebGUI.Forms.Authentication.LogonOpenerForm

See Also

Reference

Gizmox.WebGUI.Forms Assembly


Button Class Events

[image]
Gizmox.WebGUI.Forms
Button Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : Button Class

For a list of all members of this type, see Button members.

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

Button Class
Gizmox.WebGUI.Forms Namespace


CheckedListBox.ObjectCollection Class Properties

[image]
Gizmox.WebGUI.Forms
CheckedListBox.ObjectCollection Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : CheckedListBox.ObjectCollection Class

For a list of all members of this type, see CheckedListBox.ObjectCollection members.

Public Properties

 | Name | Description
Public Property | Count | Gets the number of items in the collection. (Inherited from ListBox.ObjectCollection)
Public Property | IsFixedSize | Gets a value indicating whether the collection has a fixed size. (Inherited from ListBox.ObjectCollection)
Public Property | IsReadOnly | Gets a value indicating whether the collection is read-only. (Inherited from ListBox.ObjectCollection)
Public Property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe). (Inherited from ListBox.ObjectCollection)
Public Property | Item | Gets or sets the item at the specified index within the collection. (Inherited from ListBox.ObjectCollection)
Public Property | SyncRoot | Gets the sync root. (Inherited from ListBox.ObjectCollection)
Top

See Also

Reference

CheckedListBox.ObjectCollection Class
Gizmox.WebGUI.Forms Namespace


ColorComboBox.ObjectCollection Class Properties

[image]
Gizmox.WebGUI.Forms
ColorComboBox.ObjectCollection Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ColorComboBox.ObjectCollection Class

For a list of all members of this type, see ColorComboBox.ObjectCollection members.

Public Properties

 | Name | Description
Public Property | Count | Gets the number of items in the collection. (Inherited from ComboBox.ObjectCollection)
Public Property | IsFixedSize | For a description of this member, see IsFixedSize. (Inherited from ComboBox.ObjectCollection)
Public Property | IsReadOnly | Gets a value indicating whether this collection can be modified. (Inherited from ComboBox.ObjectCollection)
Public Property | IsSynchronized | For a description of this member, see IsSynchronized. (Inherited from ComboBox.ObjectCollection)
Public Property | Item | Gets the Object with the specified int index. (Inherited from ComboBox.ObjectCollection)
Public Property | SyncRoot | Gets the sync root. (Inherited from ComboBox.ObjectCollection)
Top

See Also

Reference

ColorComboBox.ObjectCollection Class
Gizmox.WebGUI.Forms Namespace


ColorComboBox Class Events

[image]
Gizmox.WebGUI.Forms
ColorComboBox Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ColorComboBox Class

For a list of all members of this type, see ColorComboBox members.

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | DataSourceChanged | Occurs when the ListControl.DataSource changes. (Inherited from ListControl)
Public Event | DisplayMemberChanged | Occurs when the ListControl.DisplayMember property changes. (Inherited from ListControl)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | Format | Occurs when the control is bound to a data value. (Inherited from ListControl)
Public Event | FormatInfoChanged | Occurs when the value of the ListControl.FormatInfo property changes. (Inherited from ListControl)
Public Event | FormatStringChanged | Occurs when value of the ListControl.FormatString property changes (Inherited from ListControl)
Public Event | FormattingEnabledChanged | Occurs when the value of the ListControl.FormattingEnabled property changes. (Inherited from ListControl)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | SelectedIndexChanged | Occurs when the ComboBox.SelectedIndex property has changed. (Inherited from ComboBox)
Public Event | SelectedIndexChangedQueued | Occurs when the SelectedIndex property has changed (Queued). (Inherited from ComboBox)
Public Event | SelectedValueChanged | Occurs when the ListControl.SelectedValue property changes. (Inherited from ListControl)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | ValueMemberChanged | Occurs when the ListControl.ValueMember property changes. (Inherited from ListControl)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

ColorComboBox Class
Gizmox.WebGUI.Forms Namespace


ColorDialog Class Events

[image]
Gizmox.WebGUI.Forms
ColorDialog Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ColorDialog Class

For a list of all members of this type, see ColorDialog members.

Public Events

 | Name | Description
Public Event | Closed | The form close event (Inherited from CommonDialog)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | HelpRequest | Occurs when the user clicks the Help button on a common dialog box. (Inherited from CommonDialog)
Top

See Also

Reference

ColorDialog Class
Gizmox.WebGUI.Forms Namespace


ColorListBox.ObjectCollection Class Properties

[image]
Gizmox.WebGUI.Forms
ColorListBox.ObjectCollection Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ColorListBox.ObjectCollection Class

For a list of all members of this type, see ColorListBox.ObjectCollection members.

Public Properties

 | Name | Description
Public Property | Count | Gets the number of items in the collection. (Inherited from ListBox.ObjectCollection)
Public Property | IsFixedSize | Gets a value indicating whether the collection has a fixed size. (Inherited from ListBox.ObjectCollection)
Public Property | IsReadOnly | Gets a value indicating whether the collection is read-only. (Inherited from ListBox.ObjectCollection)
Public Property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe). (Inherited from ListBox.ObjectCollection)
Public Property | Item | Gets or sets the item at the specified index within the collection. (Inherited from ListBox.ObjectCollection)
Public Property | SyncRoot | Gets the sync root. (Inherited from ListBox.ObjectCollection)
Top

See Also

Reference

ColorListBox.ObjectCollection Class
Gizmox.WebGUI.Forms Namespace


ColorListBox Class Events

[image]
Gizmox.WebGUI.Forms
ColorListBox Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ColorListBox Class

For a list of all members of this type, see ColorListBox members.

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | DataSourceChanged | Occurs when the ListControl.DataSource changes. (Inherited from ListControl)
Public Event | DisplayMemberChanged | Occurs when the ListControl.DisplayMember property changes. (Inherited from ListControl)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | Format | Occurs when the control is bound to a data value. (Inherited from ListControl)
Public Event | FormatInfoChanged | Occurs when the value of the ListControl.FormatInfo property changes. (Inherited from ListControl)
Public Event | FormatStringChanged | Occurs when value of the ListControl.FormatString property changes (Inherited from ListControl)
Public Event | FormattingEnabledChanged | Occurs when the value of the ListControl.FormattingEnabled property changes. (Inherited from ListControl)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | SelectedIndexChanged | Occurs when the SelectedIndex property has changed. (Inherited from ListBox)
Public Event | SelectedValueChanged | Occurs when the ListControl.SelectedValue property changes. (Inherited from ListControl)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | ValueMemberChanged | Occurs when the ListControl.ValueMember property changes. (Inherited from ListControl)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

ColorListBox Class
Gizmox.WebGUI.Forms Namespace


ColumnHeader Class Events

[image]
Gizmox.WebGUI.Forms
ColumnHeader Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ColumnHeader Class

For a list of all members of this type, see ColumnHeader members.

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Top

See Also

Reference

ColumnHeader Class
Gizmox.WebGUI.Forms Namespace


ColumnStyle Class Methods

[image]
Gizmox.WebGUI.Forms
ColumnStyle Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ColumnStyle Class

For a list of all members of this type, see ColumnStyle members.

Protected Methods

 | Name | Description
Protected Method | FireObservableItemPropertyChanged | Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from TableLayoutStyle)
Top

See Also

Reference

ColumnStyle Class
Gizmox.WebGUI.Forms Namespace


ContainerControl Class Events

[image]
Gizmox.WebGUI.Forms
ContainerControl Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ContainerControl Class

For a list of all members of this type, see ContainerControl members.

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

ContainerControl Class
Gizmox.WebGUI.Forms Namespace


ContextMenu Class Properties

[image]
Gizmox.WebGUI.Forms
ContextMenu Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ContextMenu Class

For a list of all members of this type, see ContextMenu members.

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContextMenu | Gets or sets the context menu code. (Inherited from Menu)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | MenuItems | (Inherited from Menu)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

See Also

Reference

ContextMenu Class
Gizmox.WebGUI.Forms Namespace


ControlBindingsCollection Class Events

[image]
Gizmox.WebGUI.Forms
ControlBindingsCollection Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ControlBindingsCollection Class

For a list of all members of this type, see ControlBindingsCollection members.

Public Events

 | Name | Description
Public Event | CollectionChanged | Occurs when the collection has changed. (Inherited from BindingsCollection)
Public Event | CollectionChanging | Occurs when the collection is about to change. (Inherited from BindingsCollection)
Top

See Also

Reference

ControlBindingsCollection Class
Gizmox.WebGUI.Forms Namespace


ControlCollection Class Properties

[image]
Gizmox.WebGUI.Forms
ControlCollection Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ControlCollection Class

For a list of all members of this type, see ControlCollection members.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from Control.ControlCollection)
Public Property | IsFixedSize | (Inherited from Control.ControlCollection)
Public Property | IsReadOnly | (Inherited from Control.ControlCollection)
Public Property | Item | Overloaded. Indicates a Control with the specified key in the collection. (Inherited from Control.ControlCollection)
Public Property | Owner | Gets the control that owns this Control.ControlCollection. (Inherited from Control.ControlCollection)
Top

See Also

Reference

ControlCollection Class
Gizmox.WebGUI.Forms Namespace


ItemChooser Class Fields

[image]
Gizmox.WebGUI.Forms
ItemChooser Class Fields
See Also Send Feedback
Gizmox.WebGUI.Forms.Controls Namespace : ItemChooser Class

For a list of all members of this type, see ItemChooser members.

Public Fields

 | Name | Description
Public Field | mblnIsLoaded | Gets a value indicating whether the instance of UserControl is loaded. (Inherited from Gizmox.WebGUI.Forms.UserControl)
Top

See Also

Reference

ItemChooser Class
Gizmox.WebGUI.Forms.Controls Namespace


Gizmox.WebGUI.Forms.Controls Namespace Inheritance Hierarchy

Gizmox.WebGUI.Forms.Controls Namespace Inheritance Hierarchy
See Also Send Feedback

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.ScrollableControl
Gizmox.WebGUI.Forms.ContainerControl
Gizmox.WebGUI.Forms.UserControl
Gizmox.WebGUI.Forms.Controls.ItemChooser

See Also

Reference

Gizmox.WebGUI.Forms Assembly


DataGridViewButtonColumn Class Events

[image]
Gizmox.WebGUI.Forms
DataGridViewButtonColumn Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewButtonColumn Class

For a list of all members of this type, see DataGridViewButtonColumn members.

Public Events

 | Name | Description
Public Event | Disposed | Occurs when the DataGridViewColumn is disposed. (Inherited from DataGridViewColumn)
Top

See Also

Reference

DataGridViewButtonColumn Class
Gizmox.WebGUI.Forms Namespace


DataGridViewCheckBoxColumn Class Events

[image]
Gizmox.WebGUI.Forms
DataGridViewCheckBoxColumn Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewCheckBoxColumn Class

For a list of all members of this type, see DataGridViewCheckBoxColumn members.

Public Events

 | Name | Description
Public Event | Disposed | Occurs when the DataGridViewColumn is disposed. (Inherited from DataGridViewColumn)
Top

See Also

Reference

DataGridViewCheckBoxColumn Class
Gizmox.WebGUI.Forms Namespace


DataGridViewComboBoxColumn Class Events

[image]
Gizmox.WebGUI.Forms
DataGridViewComboBoxColumn Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewComboBoxColumn Class

For a list of all members of this type, see DataGridViewComboBoxColumn members.

Public Events

 | Name | Description
Public Event | Disposed | Occurs when the DataGridViewColumn is disposed. (Inherited from DataGridViewColumn)
Top

See Also

Reference

DataGridViewComboBoxColumn Class
Gizmox.WebGUI.Forms Namespace


DataGridViewImageColumn Class Events

[image]
Gizmox.WebGUI.Forms
DataGridViewImageColumn Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewImageColumn Class

For a list of all members of this type, see DataGridViewImageColumn members.

Public Events

 | Name | Description
Public Event | Disposed | Occurs when the DataGridViewColumn is disposed. (Inherited from DataGridViewColumn)
Top

See Also

Reference

DataGridViewImageColumn Class
Gizmox.WebGUI.Forms Namespace


DataGridViewLinkColumn Class Events

[image]
Gizmox.WebGUI.Forms
DataGridViewLinkColumn Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewLinkColumn Class

For a list of all members of this type, see DataGridViewLinkColumn members.

Public Events

 | Name | Description
Public Event | Disposed | Occurs when the DataGridViewColumn is disposed. (Inherited from DataGridViewColumn)
Top

See Also

Reference

DataGridViewLinkColumn Class
Gizmox.WebGUI.Forms Namespace


DataGridViewRowHeaderCell Class Properties

[image]
Gizmox.WebGUI.Forms
DataGridViewRowHeaderCell Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewRowHeaderCell Class

For a list of all members of this type, see DataGridViewRowHeaderCell members.

Public Properties

 | Name | Description
Public Property | ColumnIndex | Gets the column index for this cell. (Inherited from DataGridViewCell)
Public Property | ContentBounds | (Inherited from DataGridViewCell)
Public Property | DataGridView | Gets the DataGridView control associated with this element. (Inherited from DataGridViewElement)
Public Property | DefaultNewRowValue | Gets the default value for a cell in the row for new records. (Inherited from DataGridViewCell)
Public Property | Displayed | (Inherited from DataGridViewHeaderCell)
Public Property | EditedFormattedValue | Gets the current, formatted value of the cell, regardless of whether the cell is in edit mode and the value has not been committed. (Inherited from DataGridViewCell)
Public Property | EditType | Gets the type of the cell's hosted editing control. (Inherited from DataGridViewCell)
Public Property | ErrorIconBounds | (Inherited from DataGridViewCell)
Public Property | ErrorText | Gets or sets the text describing an error condition associated with the cell. (Inherited from DataGridViewCell)
Public Property | FormattedValue | Gets the value of the cell as formatted for display. (Inherited from DataGridViewCell)
Public Property | FormattedValueType | Gets the type of the formatted value of the cell. (Inherited from DataGridViewHeaderCell)
Public Property | Frozen | Gets a value indicating whether the cell is frozen. (Inherited from DataGridViewHeaderCell)
Public Property | HasStyle | Gets a value indicating whether the DataGridViewCell.Style property has been set. (Inherited from DataGridViewCell)
Public Property | InheritedState | Gets the current state of the cell as inherited from the state of its row and column. (Inherited from DataGridViewCell)
Public Property | InheritedStyle | Gets the style currently applied to the cell. (Inherited from DataGridViewCell)
Public Property | IsInEditMode | Gets a value indicating whether this cell is currently being edited. (Inherited from DataGridViewCell)
Public Property | OwningColumn | Gets the column that contains this cell. (Inherited from DataGridViewCell)
Public Property | OwningRow | Gets the row that contains this cell. (Inherited from DataGridViewCell)
Public Property | PreferredSize | Gets the size, in pixels, of a rectangular area into which the cell can fit. (Inherited from DataGridViewCell)
Public Property | ReadOnly | Gets a value indicating whether the header cell is read-only. (Inherited from DataGridViewHeaderCell)
Public Property | Resizable | Gets a value indicating whether the cell is resizable. (Inherited from DataGridViewHeaderCell)
Public Property | RowIndex | Gets the index of the cell's parent row. (Inherited from DataGridViewCell)
Public Property | Selected | Gets or sets a value indicating whether the cell is selected. (Inherited from DataGridViewHeaderCell)
Public Property | Size | Gets the size of the cell. (Inherited from DataGridViewCell)
Public Property | State | Gets the user interface (UI) state of the element. (Inherited from DataGridViewElement)
Public Property | Style | Gets or sets the style for the cell. (Inherited from DataGridViewCell)
Public Property | Tag | Gets or sets the object that contains supplemental data about the cell. (Inherited from DataGridViewCell)
Public Property | ToolTipText | Gets or sets the ToolTip text associated with this cell. (Inherited from DataGridViewCell)
Public Property | Value | Gets or sets the value associated with this cell. (Inherited from DataGridViewCell)
Public Property | ValueType | Gets the type of the value stored in the cell. (Inherited from DataGridViewHeaderCell)
Public Property | Visible | Gets a value indicating whether or not the cell is visible. (Inherited from DataGridViewHeaderCell)
Top

Protected Properties

 | Name | Description
Protected Property | ButtonState | Gets the buttonlike visual state of the header cell. (Inherited from DataGridViewHeaderCell)
Protected Property | MemberID | (Inherited from DataGridViewCell)
Protected Property | TagName | (Inherited from DataGridViewElement)
Top

See Also

Reference

DataGridViewRowHeaderCell Class
Gizmox.WebGUI.Forms Namespace


DataGridViewTextBoxColumn Class Events

[image]
Gizmox.WebGUI.Forms
DataGridViewTextBoxColumn Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewTextBoxColumn Class

For a list of all members of this type, see DataGridViewTextBoxColumn members.

Public Events

 | Name | Description
Public Event | Disposed | Occurs when the DataGridViewColumn is disposed. (Inherited from DataGridViewColumn)
Top

See Also

Reference

DataGridViewTextBoxColumn Class
Gizmox.WebGUI.Forms Namespace


DataGridViewTextBoxEditingControl Class Events

[image]
Gizmox.WebGUI.Forms
DataGridViewTextBoxEditingControl Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewTextBoxEditingControl Class

For a list of all members of this type, see DataGridViewTextBoxEditingControl members.

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | EnterKeyDown | Occurs on enter key down only on single line. (Inherited from TextBox)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

DataGridViewTextBoxEditingControl Class
Gizmox.WebGUI.Forms Namespace


DataGridViewTextBoxEditingControl Class Fields

[image]
Gizmox.WebGUI.Forms
DataGridViewTextBoxEditingControl Class Fields
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewTextBoxEditingControl Class

For a list of all members of this type, see DataGridViewTextBoxEditingControl members.

Protected Fields

 | Name | Description
Protected Field | menmScrollBars | Member which holds the scrollbars mode. (Inherited from TextBox)
Top

See Also

Reference

DataGridViewTextBoxEditingControl Class
Gizmox.WebGUI.Forms Namespace


DataGridViewTopLeftHeaderCell Class Properties

[image]
Gizmox.WebGUI.Forms
DataGridViewTopLeftHeaderCell Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DataGridViewTopLeftHeaderCell Class

For a list of all members of this type, see DataGridViewTopLeftHeaderCell members.

Public Properties

 | Name | Description
Public Property | ColumnIndex | Gets the column index for this cell. (Inherited from DataGridViewCell)
Public Property | ContentBounds | (Inherited from DataGridViewCell)
Public Property | DataGridView | Gets the DataGridView control associated with this element. (Inherited from DataGridViewElement)
Public Property | DefaultNewRowValue | Gets the default value for a cell in the row for new records. (Inherited from DataGridViewCell)
Public Property | Displayed | (Inherited from DataGridViewHeaderCell)
Public Property | EditedFormattedValue | Gets the current, formatted value of the cell, regardless of whether the cell is in edit mode and the value has not been committed. (Inherited from DataGridViewCell)
Public Property | EditType | Gets the type of the cell's hosted editing control. (Inherited from DataGridViewCell)
Public Property | ErrorIconBounds | (Inherited from DataGridViewCell)
Public Property | ErrorText | Gets or sets the text describing an error condition associated with the cell. (Inherited from DataGridViewCell)
Public Property | FormattedValue | Gets the value of the cell as formatted for display. (Inherited from DataGridViewCell)
Public Property | FormattedValueType | Gets the type of the formatted value of the cell. (Inherited from DataGridViewHeaderCell)
Public Property | Frozen | Gets a value indicating whether the cell is frozen. (Inherited from DataGridViewHeaderCell)
Public Property | HasStyle | Gets a value indicating whether the DataGridViewCell.Style property has been set. (Inherited from DataGridViewCell)
Public Property | InheritedState | Gets the current state of the cell as inherited from the state of its row and column. (Inherited from DataGridViewCell)
Public Property | InheritedStyle | Gets the style currently applied to the cell. (Inherited from DataGridViewCell)
Public Property | IsInEditMode | Gets a value indicating whether this cell is currently being edited. (Inherited from DataGridViewCell)
Public Property | OwningColumn | Gets the column that contains this cell. (Inherited from DataGridViewCell)
Public Property | OwningRow | Gets the row that contains this cell. (Inherited from DataGridViewCell)
Public Property | PreferredSize | Gets the size, in pixels, of a rectangular area into which the cell can fit. (Inherited from DataGridViewCell)
Public Property | ReadOnly | Gets a value indicating whether the header cell is read-only. (Inherited from DataGridViewHeaderCell)
Public Property | Resizable | Gets a value indicating whether the cell is resizable. (Inherited from DataGridViewHeaderCell)
Public Property | RowIndex | Gets the index of the cell's parent row. (Inherited from DataGridViewCell)
Public Property | Selected | Gets or sets a value indicating whether the cell is selected. (Inherited from DataGridViewHeaderCell)
Public Property | Size | Gets the size of the cell. (Inherited from DataGridViewCell)
Public Property | SortGlyphDirection | Gets or sets a value indicating which sort glyph is displayed. (Inherited from DataGridViewColumnHeaderCell)
Public Property | State | Gets the user interface (UI) state of the element. (Inherited from DataGridViewElement)
Public Property | Style | Gets or sets the style for the cell. (Inherited from DataGridViewCell)
Public Property | Tag | Gets or sets the object that contains supplemental data about the cell. (Inherited from DataGridViewCell)
Public Property | ToolTipText | Gets or sets the ToolTip text associated with this cell. (Inherited from DataGridViewCell)
Public Property | Value | Gets or sets the value associated with this cell. (Inherited from DataGridViewCell)
Public Property | ValueType | Gets the type of the value stored in the cell. (Inherited from DataGridViewHeaderCell)
Public Property | Visible | Gets a value indicating whether or not the cell is visible. (Inherited from DataGridViewHeaderCell)
Top

Protected Properties

 | Name | Description
Protected Property | ButtonState | Gets the buttonlike visual state of the header cell. (Inherited from DataGridViewHeaderCell)
Protected Property | MemberID | (Inherited from DataGridViewCell)
Protected Property | TagName | (Inherited from DataGridViewElement)
Top

See Also

Reference

DataGridViewTopLeftHeaderCell Class
Gizmox.WebGUI.Forms Namespace


DateTimeEditor Class Properties

[image]
Gizmox.WebGUI.Forms
DateTimeEditor Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace : DateTimeEditor Class

For a list of all members of this type, see DateTimeEditor members.

Public Properties

 | Name | Description
Public Property | IsDropDownResizable | Gets a value indicating whether drop-down editors should be resizable by the user. (Inherited from WebUITypeEditor)
Public Property | IsTextEditable | Gets a value indicating whether this editor value should support text editing. (Inherited from WebUITypeEditor)
Top

See Also

Reference

DateTimeEditor Class
Gizmox.WebGUI.Forms.Design Namespace


FontEditor Class Properties

[image]
Gizmox.WebGUI.Forms
FontEditor Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms.Design Namespace : FontEditor Class

For a list of all members of this type, see FontEditor members.

Public Properties

 | Name | Description
Public Property | IsDropDownResizable | Gets a value indicating whether drop-down editors should be resizable by the user. (Inherited from WebUITypeEditor)
Public Property | IsTextEditable | Gets a value indicating whether this editor value should support text editing. (Inherited from WebUITypeEditor)
Top

See Also

Reference

FontEditor Class
Gizmox.WebGUI.Forms.Design Namespace


Gizmox.WebGUI.Forms.Design Namespace (Gizmox.WebGUI.Forms) Inheritance Hierarchy

Gizmox.WebGUI.Forms.Design Namespace (Gizmox.WebGUI.Forms) Inheritance Hierarchy
See Also Send Feedback

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.Design.PropertyTab
Gizmox.WebGUI.Forms.Design.EventsTab
Gizmox.WebGUI.Forms.Design.WebUITypeEditor
Gizmox.WebGUI.Forms.Design.AnchorEditor
Gizmox.WebGUI.Forms.Design.CollectionEditor
Gizmox.WebGUI.Forms.Design.ColorEditor
Gizmox.WebGUI.Forms.Design.DateTimeEditor
Gizmox.WebGUI.Forms.Design.DockEditor
Gizmox.WebGUI.Forms.Design.FontEditor
System.Attribute
Gizmox.WebGUI.Forms.Design.WebEditorAttribute

See Also

Reference

Gizmox.WebGUI.Forms Assembly


ListViewColumnOptions Class Events

[image]
Gizmox.WebGUI.Forms
ListViewColumnOptions Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms.Dialogs Namespace : ListViewColumnOptions Class

For a list of all members of this type, see ListViewColumnOptions members.

Public Events

 | Name | Description
Public Event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Closed | (Inherited from Gizmox.WebGUI.Forms.Form)
Public Event | Closing | The form closing event. This event is not raised on the main form. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Disposed | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Load | The form load event (Inherited from Gizmox.WebGUI.Forms.Form)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Gizmox.WebGUI.Forms.Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Top

See Also

Reference

ListViewColumnOptions Class
Gizmox.WebGUI.Forms.Dialogs Namespace


ListViewColumnOptions Class Methods

[image]
Gizmox.WebGUI.Forms
ListViewColumnOptions Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms.Dialogs Namespace : ListViewColumnOptions Class

For a list of all members of this type, see ListViewColumnOptions members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from Gizmox.WebGUI.Forms.ContainerControl)
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Close | Closes this window. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Gizmox.WebGUI.Forms.ContainerControl)
Public Method | Focus | Sets focus to this control (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | GetPreferredSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Remove | (Inherited from Gizmox.WebGUI.Forms.ContainerControl)
Public Method | ResetText | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Public Method | Select | Overloaded. Activates the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SendToBack | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Show | (Inherited from Gizmox.WebGUI.Forms.Form)
Public Method | ShowDialog | Overloaded. Shows a the form as a dialog. The ShowDialog in Visual WebGui works differently than WinForms. Code lines after this call is executed immediately and won’t wait for the dialog to close. If you need to run code only after the dialog is closed or only if a specific result is returned register to the close event of the dialog. See documentation for code example. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Method | ShowPopup | Overloaded. Displays the form as a popup window. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ToString | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Update | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | Finalize | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCommandText | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetImage | Gets the image. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetPreferredSizeCore | (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Protected Method | GetService | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | InvokeMethod | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | IsDirty | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | OnActivated | Raises the Activated event. (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBindingContextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnClosed | (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnClosing | (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnControlAdded | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnControlRemoved | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnCreateControl | Occurs when control is created (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | OnEnabledChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnGotFocus | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLoad | Raises the Load event. (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnLocationChanged | (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnLostFocus | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentVisibleChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnResize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnTextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnUnregisterComponents | (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnValidated | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnValidating | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ProcessGatewayRequest | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RegisterSelf | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | Render | Render the form content (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | RenderAttributes | Renders the forms attribute (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderClientUpdateHandler | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderComponentEventAttributes | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderUpdatedAttributes | (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetImage | Sets the image. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeText | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | UnRegisterBatch | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | UnRegisterSelf | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | UpdateParams | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Top

See Also

Reference

ListViewColumnOptions Class
Gizmox.WebGUI.Forms.Dialogs Namespace


ListViewColumnOptions Class Properties

[image]
Gizmox.WebGUI.Forms
ListViewColumnOptions Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms.Dialogs Namespace : ListViewColumnOptions Class

For a list of all members of this type, see ListViewColumnOptions members.

Public Properties

 | Name | Description
Public Property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | ActiveControl | Gets or sets the active control on the container control. (Inherited from Gizmox.WebGUI.Forms.ContainerControl)
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | AutoScaleBaseSize | Gets or sets the size of the auto scale base. Not implemented. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Public Property | BackColor | Gets or sets the background color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BeforeUnloadMessage | Gets or sets the before unload message. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | BindingContext | (Inherited from Gizmox.WebGUI.Forms.ContainerControl)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CancelButton | Gets or sets the button on the form that is clicked when the user presses the ESC key. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Components | (Inherited from Gizmox.WebGUI.Forms.ContainerControl)
Public Property | Container | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Context | Gets the context. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | DialogResult | Gets or sets the dialog result. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Public Property | DragMappings | Gets the form drag mappings. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Form | Gets the owner form. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | FormBorderStyle | Gets or sets the form border style. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | FormStyle | Gets or sets the form style. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | HasControls | Gets a value indicating whether this control has controls. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Header | Gets or sets the form header control. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Height | Gets/Sets the height position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Icon | Gets or sets the form icon (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | IsRegistered | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Left | Gets/Sets the left position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Location | Gets or sets the control location. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | MaximizeBox | Gets or sets a value indicating whether [maximize box]. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | MinimizeBox | Gets or sets a value indicating whether [minimize box]. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Modal | Gets or sets a value indicating whether this window is modal. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | OwnedForms | Gets the child forms. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Owner | Gets the parent window. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Padding | Gets or sets the control padding. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Right | Gets/Sets the right position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ShowInTaskbar | Gets or sets a value indicating whether [show in taskbar]. Not implemented by design (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Site | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | StartPosition | Gets or sets the form start position. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Top | Gets/Sets the top position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Visible | Get/Sets the form visibility (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Width | Gets/Sets the width position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | WindowState | Gets or sets the state of the window. (Inherited from Gizmox.WebGUI.Forms.Form)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultBorderColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultBorderStyle | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultForeColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMargin | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultPadding | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DesignMode | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | Events | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Protected Property | IsConnected | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Property | IsDelayedDrawing | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | IsWindowSized | Calculate size invluding borders (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | Session | Gets or sets the main form. (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Top

See Also

Reference

ListViewColumnOptions Class
Gizmox.WebGUI.Forms.Dialogs Namespace


ListViewGroupingOptions Class Events

[image]
Gizmox.WebGUI.Forms
ListViewGroupingOptions Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms.Dialogs Namespace : ListViewGroupingOptions Class

For a list of all members of this type, see ListViewGroupingOptions members.

Public Events

 | Name | Description
Public Event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Closed | (Inherited from Gizmox.WebGUI.Forms.Form)
Public Event | Closing | The form closing event. This event is not raised on the main form. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Disposed | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Load | The form load event (Inherited from Gizmox.WebGUI.Forms.Form)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Gizmox.WebGUI.Forms.Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Top

See Also

Reference

ListViewGroupingOptions Class
Gizmox.WebGUI.Forms.Dialogs Namespace


ListViewGroupingOptions Class Methods

[image]
Gizmox.WebGUI.Forms
ListViewGroupingOptions Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms.Dialogs Namespace : ListViewGroupingOptions Class

For a list of all members of this type, see ListViewGroupingOptions members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from Gizmox.WebGUI.Forms.ContainerControl)
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Close | Closes this window. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Gizmox.WebGUI.Forms.ContainerControl)
Public Method | Focus | Sets focus to this control (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | GetPreferredSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Remove | (Inherited from Gizmox.WebGUI.Forms.ContainerControl)
Public Method | ResetText | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Public Method | Select | Overloaded. Activates the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SendToBack | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Show | (Inherited from Gizmox.WebGUI.Forms.Form)
Public Method | ShowDialog | Overloaded. Shows a the form as a dialog. The ShowDialog in Visual WebGui works differently than WinForms. Code lines after this call is executed immediately and won’t wait for the dialog to close. If you need to run code only after the dialog is closed or only if a specific result is returned register to the close event of the dialog. See documentation for code example. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Method | ShowPopup | Overloaded. Displays the form as a popup window. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ToString | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Update | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | Finalize | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCommandText | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetImage | Gets the image. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetPreferredSizeCore | (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Protected Method | GetService | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | InvokeMethod | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | IsDirty | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | OnActivated | Raises the Activated event. (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBindingContextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnClosed | (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnClosing | (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnControlAdded | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnControlRemoved | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnCreateControl | Occurs when control is created (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | OnEnabledChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnGotFocus | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLoad | Raises the Load event. (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnLocationChanged | (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnLostFocus | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentVisibleChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnResize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnTextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnUnregisterComponents | (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnValidated | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnValidating | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ProcessGatewayRequest | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RegisterSelf | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | Render | Render the form content (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | RenderAttributes | Renders the forms attribute (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderClientUpdateHandler | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderComponentEventAttributes | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderUpdatedAttributes | (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetImage | Sets the image. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeText | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | UnRegisterBatch | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | UnRegisterSelf | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | UpdateParams | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Top

See Also

Reference

ListViewGroupingOptions Class
Gizmox.WebGUI.Forms.Dialogs Namespace


ListViewGroupingOptions Class Properties

[image]
Gizmox.WebGUI.Forms
ListViewGroupingOptions Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms.Dialogs Namespace : ListViewGroupingOptions Class

For a list of all members of this type, see ListViewGroupingOptions members.

Public Properties

 | Name | Description
Public Property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | ActiveControl | Gets or sets the active control on the container control. (Inherited from Gizmox.WebGUI.Forms.ContainerControl)
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | AutoScaleBaseSize | Gets or sets the size of the auto scale base. Not implemented. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Public Property | BackColor | Gets or sets the background color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BeforeUnloadMessage | Gets or sets the before unload message. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | BindingContext | (Inherited from Gizmox.WebGUI.Forms.ContainerControl)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CancelButton | Gets or sets the button on the form that is clicked when the user presses the ESC key. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Components | (Inherited from Gizmox.WebGUI.Forms.ContainerControl)
Public Property | Container | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Context | Gets the context. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | DialogResult | Gets or sets the dialog result. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Public Property | DragMappings | Gets the form drag mappings. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Form | Gets the owner form. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | FormBorderStyle | Gets or sets the form border style. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | FormStyle | Gets or sets the form style. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | HasControls | Gets a value indicating whether this control has controls. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Header | Gets or sets the form header control. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Height | Gets/Sets the height position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Icon | Gets or sets the form icon (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | IsRegistered | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Left | Gets/Sets the left position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Location | Gets or sets the control location. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | MaximizeBox | Gets or sets a value indicating whether [maximize box]. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | MinimizeBox | Gets or sets a value indicating whether [minimize box]. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Modal | Gets or sets a value indicating whether this window is modal. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | OwnedForms | Gets the child forms. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Owner | Gets the parent window. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Padding | Gets or sets the control padding. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Right | Gets/Sets the right position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ShowInTaskbar | Gets or sets a value indicating whether [show in taskbar]. Not implemented by design (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Site | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | StartPosition | Gets or sets the form start position. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Top | Gets/Sets the top position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Visible | Get/Sets the form visibility (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Width | Gets/Sets the width position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | WindowState | Gets or sets the state of the window. (Inherited from Gizmox.WebGUI.Forms.Form)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultBorderColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultBorderStyle | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultForeColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMargin | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultPadding | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DesignMode | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | Events | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Protected Property | IsConnected | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Property | IsDelayedDrawing | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | IsWindowSized | Calculate size invluding borders (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | Session | Gets or sets the main form. (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Top

See Also

Reference

ListViewGroupingOptions Class
Gizmox.WebGUI.Forms.Dialogs Namespace


ListViewSortingOptions Class Events

[image]
Gizmox.WebGUI.Forms
ListViewSortingOptions Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms.Dialogs Namespace : ListViewSortingOptions Class

For a list of all members of this type, see ListViewSortingOptions members.

Public Events

 | Name | Description
Public Event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Closed | (Inherited from Gizmox.WebGUI.Forms.Form)
Public Event | Closing | The form closing event. This event is not raised on the main form. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Disposed | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Load | The form load event (Inherited from Gizmox.WebGUI.Forms.Form)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Gizmox.WebGUI.Forms.Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Top

See Also

Reference

ListViewSortingOptions Class
Gizmox.WebGUI.Forms.Dialogs Namespace


ListViewSortingOptions Class Methods

[image]
Gizmox.WebGUI.Forms
ListViewSortingOptions Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms.Dialogs Namespace : ListViewSortingOptions Class

For a list of all members of this type, see ListViewSortingOptions members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from Gizmox.WebGUI.Forms.ContainerControl)
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Close | Closes this window. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Gizmox.WebGUI.Forms.ContainerControl)
Public Method | Focus | Sets focus to this control (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | GetPreferredSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Remove | (Inherited from Gizmox.WebGUI.Forms.ContainerControl)
Public Method | ResetText | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Public Method | Select | Overloaded. Activates the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SendToBack | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Show | (Inherited from Gizmox.WebGUI.Forms.Form)
Public Method | ShowDialog | Overloaded. Shows a the form as a dialog. The ShowDialog in Visual WebGui works differently than WinForms. Code lines after this call is executed immediately and won’t wait for the dialog to close. If you need to run code only after the dialog is closed or only if a specific result is returned register to the close event of the dialog. See documentation for code example. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Method | ShowPopup | Overloaded. Displays the form as a popup window. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ToString | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Update | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | Finalize | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCommandText | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetImage | Gets the image. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetPreferredSizeCore | (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Protected Method | GetService | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | InvokeMethod | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | IsDirty | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | OnActivated | Raises the Activated event. (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBindingContextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnClosed | (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnClosing | (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnControlAdded | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnControlRemoved | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnCreateControl | Occurs when control is created (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | OnEnabledChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnGotFocus | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLoad | Raises the Load event. (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnLocationChanged | (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnLostFocus | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentVisibleChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnResize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnTextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnUnregisterComponents | (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | OnValidated | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnValidating | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ProcessGatewayRequest | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RegisterSelf | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | Render | Render the form content (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | RenderAttributes | Renders the forms attribute (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderClientUpdateHandler | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderComponentEventAttributes | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderUpdatedAttributes | (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetImage | Sets the image. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeText | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | UnRegisterBatch | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | UnRegisterSelf | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | UpdateParams | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Top

See Also

Reference

ListViewSortingOptions Class
Gizmox.WebGUI.Forms.Dialogs Namespace


ListViewSortingOptions Class Properties

[image]
Gizmox.WebGUI.Forms
ListViewSortingOptions Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms.Dialogs Namespace : ListViewSortingOptions Class

For a list of all members of this type, see ListViewSortingOptions members.

Public Properties

 | Name | Description
Public Property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | ActiveControl | Gets or sets the active control on the container control. (Inherited from Gizmox.WebGUI.Forms.ContainerControl)
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | AutoScaleBaseSize | Gets or sets the size of the auto scale base. Not implemented. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Public Property | BackColor | Gets or sets the background color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BeforeUnloadMessage | Gets or sets the before unload message. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | BindingContext | (Inherited from Gizmox.WebGUI.Forms.ContainerControl)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CancelButton | Gets or sets the button on the form that is clicked when the user presses the ESC key. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Components | (Inherited from Gizmox.WebGUI.Forms.ContainerControl)
Public Property | Container | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Context | Gets the context. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | DialogResult | Gets or sets the dialog result. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Public Property | DragMappings | Gets the form drag mappings. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Form | Gets the owner form. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | FormBorderStyle | Gets or sets the form border style. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | FormStyle | Gets or sets the form style. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | HasControls | Gets a value indicating whether this control has controls. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Header | Gets or sets the form header control. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Height | Gets/Sets the height position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Icon | Gets or sets the form icon (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | IsRegistered | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Left | Gets/Sets the left position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Location | Gets or sets the control location. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | MaximizeBox | Gets or sets a value indicating whether [maximize box]. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | MinimizeBox | Gets or sets a value indicating whether [minimize box]. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Modal | Gets or sets a value indicating whether this window is modal. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | OwnedForms | Gets the child forms. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Owner | Gets the parent window. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Padding | Gets or sets the control padding. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Right | Gets/Sets the right position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ShowInTaskbar | Gets or sets a value indicating whether [show in taskbar]. Not implemented by design (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Site | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | StartPosition | Gets or sets the form start position. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Top | Gets/Sets the top position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Visible | Get/Sets the form visibility (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Width | Gets/Sets the width position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | WindowState | Gets or sets the state of the window. (Inherited from Gizmox.WebGUI.Forms.Form)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultBorderColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultBorderStyle | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultForeColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMargin | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultPadding | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DesignMode | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | Events | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Protected Property | IsConnected | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Property | IsDelayedDrawing | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | IsWindowSized | Calculate size invluding borders (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | Session | Gets or sets the main form. (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Top

See Also

Reference

ListViewSortingOptions Class
Gizmox.WebGUI.Forms.Dialogs Namespace


TraceViewer Class Events

[image]
Gizmox.WebGUI.Forms
TraceViewer Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms.Dialogs Namespace : TraceViewer Class

For a list of all members of this type, see TraceViewer members.

Public Events

 | Name | Description
Public Event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Closed | (Inherited from Gizmox.WebGUI.Forms.Form)
Public Event | Closing | The form closing event. This event is not raised on the main form. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Disposed | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Load | The form load event (Inherited from Gizmox.WebGUI.Forms.Form)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Gizmox.WebGUI.Forms.Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Top

See Also

Reference

TraceViewer Class
Gizmox.WebGUI.Forms.Dialogs Namespace


TraceViewer Class Properties

[image]
Gizmox.WebGUI.Forms
TraceViewer Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms.Dialogs Namespace : TraceViewer Class

For a list of all members of this type, see TraceViewer members.

Public Properties

 | Name | Description
Public Property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | ActiveControl | Gets or sets the active control on the container control. (Inherited from Gizmox.WebGUI.Forms.ContainerControl)
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | AutoScaleBaseSize | Gets or sets the size of the auto scale base. Not implemented. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Public Property | BackColor | Gets or sets the background color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BeforeUnloadMessage | Gets or sets the before unload message. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | BindingContext | (Inherited from Gizmox.WebGUI.Forms.ContainerControl)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CancelButton | Gets or sets the button on the form that is clicked when the user presses the ESC key. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Components | (Inherited from Gizmox.WebGUI.Forms.ContainerControl)
Public Property | Container | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Context | Gets the context. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | DialogResult | Gets or sets the dialog result. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Public Property | DragMappings | Gets the form drag mappings. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Form | Gets the owner form. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | FormBorderStyle | Gets or sets the form border style. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | FormStyle | Gets or sets the form style. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | HasControls | Gets a value indicating whether this control has controls. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Header | Gets or sets the form header control. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Height | Gets/Sets the height position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Icon | Gets or sets the form icon (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | IsRegistered | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Left | Gets/Sets the left position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Location | Gets or sets the control location. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | MaximizeBox | Gets or sets a value indicating whether [maximize box]. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | MinimizeBox | Gets or sets a value indicating whether [minimize box]. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Modal | Gets or sets a value indicating whether this window is modal. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | OwnedForms | Gets the child forms. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Owner | Gets the parent window. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Padding | Gets or sets the control padding. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Right | Gets/Sets the right position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | ShowInTaskbar | Gets or sets a value indicating whether [show in taskbar]. Not implemented by design (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Site | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | StartPosition | Gets or sets the form start position. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Gizmox.WebGUI.Forms.Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | Top | Gets/Sets the top position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Visible | Get/Sets the form visibility (Inherited from Gizmox.WebGUI.Forms.Form)
Public Property | Width | Gets/Sets the width position (Inherited from Gizmox.WebGUI.Forms.Control)
Public Property | WindowState | Gets or sets the state of the window. (Inherited from Gizmox.WebGUI.Forms.Form)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultBorderColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultBorderStyle | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultForeColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMargin | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultPadding | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DefaultSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | DesignMode | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | Events | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Protected Property | IsConnected | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Property | IsDelayedDrawing | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | IsWindowSized | Calculate size invluding borders (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Property | Session | Gets or sets the main form. (Inherited from Gizmox.WebGUI.Forms.Form)
Protected Property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from Gizmox.WebGUI.Forms.ScrollableControl)
Top

See Also

Reference

TraceViewer Class
Gizmox.WebGUI.Forms.Dialogs Namespace


Gizmox.WebGUI.Forms.Dialogs Namespace Inheritance Hierarchy

Gizmox.WebGUI.Forms.Dialogs Namespace Inheritance Hierarchy
See Also Send Feedback

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.ScrollableControl
Gizmox.WebGUI.Forms.ContainerControl
Gizmox.WebGUI.Forms.Form
Gizmox.WebGUI.Forms.Dialogs.ListViewColumnOptions
Gizmox.WebGUI.Forms.Dialogs.ListViewGroupingOptions
Gizmox.WebGUI.Forms.Dialogs.ListViewSortingOptions
Gizmox.WebGUI.Forms.Dialogs.TraceViewer

See Also

Reference

Gizmox.WebGUI.Forms Assembly


DragMappings Class Events

[image]
Gizmox.WebGUI.Forms
DragMappings Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DragMappings Class

For a list of all members of this type, see DragMappings members.

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Top

See Also

Reference

DragMappings Class
Gizmox.WebGUI.Forms Namespace


DragMappings Class Properties

[image]
Gizmox.WebGUI.Forms
DragMappings Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : DragMappings Class

For a list of all members of this type, see DragMappings members.

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContextMenu | Gets or sets the context menu code. (Inherited from Component)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

See Also

Reference

DragMappings Class
Gizmox.WebGUI.Forms Namespace


ErrorProvider Class Events

[image]
Gizmox.WebGUI.Forms
ErrorProvider Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ErrorProvider Class

For a list of all members of this type, see ErrorProvider members.

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from ComponentBase)
Top

See Also

Reference

ErrorProvider Class
Gizmox.WebGUI.Forms Namespace


SilverlightExtender Class Events

[image]
Gizmox.WebGUI.Forms
SilverlightExtender Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms.Extenders Namespace : SilverlightExtender Class

For a list of all members of this type, see SilverlightExtender members.

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Top

See Also

Reference

SilverlightExtender Class
Gizmox.WebGUI.Forms.Extenders Namespace


SilverlightExtender Class Properties

[image]
Gizmox.WebGUI.Forms
SilverlightExtender Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms.Extenders Namespace : SilverlightExtender Class

For a list of all members of this type, see SilverlightExtender members.

Public Properties

 | Name | Description
Public Property | Container | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | Site | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | DesignMode | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | Events | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Top

See Also

Reference

SilverlightExtender Class
Gizmox.WebGUI.Forms.Extenders Namespace


UniqueIdExtender Class Events

[image]
Gizmox.WebGUI.Forms
UniqueIdExtender Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms.Extenders Namespace : UniqueIdExtender Class

For a list of all members of this type, see UniqueIdExtender members.

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Top

See Also

Reference

UniqueIdExtender Class
Gizmox.WebGUI.Forms.Extenders Namespace


UniqueIdExtender Class Properties

[image]
Gizmox.WebGUI.Forms
UniqueIdExtender Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms.Extenders Namespace : UniqueIdExtender Class

For a list of all members of this type, see UniqueIdExtender members.

Public Properties

 | Name | Description
Public Property | Container | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Property | Site | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | DesignMode | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Property | Events | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Top

See Also

Reference

UniqueIdExtender Class
Gizmox.WebGUI.Forms.Extenders Namespace


Gizmox.WebGUI.Forms.Extenders Namespace Inheritance Hierarchy

Gizmox.WebGUI.Forms.Extenders Namespace Inheritance Hierarchy
See Also Send Feedback

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.Extenders.SilverlightExtender
Gizmox.WebGUI.Forms.Extenders.UniqueIdExtender

See Also

Reference

Gizmox.WebGUI.Forms Assembly


FlowLayoutPanel Class Events

[image]
Gizmox.WebGUI.Forms
FlowLayoutPanel Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : FlowLayoutPanel Class

For a list of all members of this type, see FlowLayoutPanel members.

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

FlowLayoutPanel Class
Gizmox.WebGUI.Forms Namespace


FolderBrowserDialog Class Events

[image]
Gizmox.WebGUI.Forms
FolderBrowserDialog Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : FolderBrowserDialog Class

For a list of all members of this type, see FolderBrowserDialog members.

Public Events

 | Name | Description
Public Event | Closed | The form close event (Inherited from CommonDialog)
Public Event | Disposed | (Inherited from ComponentBase)
Top

See Also

Reference

FolderBrowserDialog Class
Gizmox.WebGUI.Forms Namespace


FrameControl Class Events

[image]
Gizmox.WebGUI.Forms
FrameControl Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : FrameControl Class

For a list of all members of this type, see FrameControl members.

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

FrameControl Class
Gizmox.WebGUI.Forms Namespace


FrameControl Class Properties

[image]
Gizmox.WebGUI.Forms
FrameControl Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : FrameControl Class

For a list of all members of this type, see FrameControl members.

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Control)
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

See Also

Reference

FrameControl Class
Gizmox.WebGUI.Forms Namespace


GroupBox Class Events

[image]
Gizmox.WebGUI.Forms
GroupBox Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : GroupBox Class

For a list of all members of this type, see GroupBox members.

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

GroupBox Class
Gizmox.WebGUI.Forms Namespace


HelpProvider Class Events

[image]
Gizmox.WebGUI.Forms
HelpProvider Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : HelpProvider Class

For a list of all members of this type, see HelpProvider members.

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from ComponentBase)
Top

See Also

Reference

HelpProvider Class
Gizmox.WebGUI.Forms Namespace


AppletBox Class Events

[image]
Gizmox.WebGUI.Forms
AppletBox Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace : AppletBox Class

For a list of all members of this type, see AppletBox members.

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Disposed | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Gizmox.WebGUI.Forms.Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Top

See Also

Reference

AppletBox Class
Gizmox.WebGUI.Forms.Hosts Namespace


AppletBoxBase Class Events

[image]
Gizmox.WebGUI.Forms
AppletBoxBase Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace : AppletBoxBase Class

For a list of all members of this type, see AppletBoxBase members.

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Disposed | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Gizmox.WebGUI.Forms.Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Top

See Also

Reference

AppletBoxBase Class
Gizmox.WebGUI.Forms.Hosts Namespace


AspControlBoxBase.ResourceFile Class Properties

[image]
Gizmox.WebGUI.Forms
AspControlBoxBase.ResourceFile Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace : AspControlBoxBase.ResourceFile Class

For a list of all members of this type, see AspControlBoxBase.ResourceFile members.

Public Properties

 | Name | Description
Public Property | IsDirectory | Gets a value that indicates that this is a virtual resource that should be treated as a file. (Inherited from System.Web.Hosting.VirtualFile)
Public Property | Name | Gets the display name of the virtual resource. (Inherited from System.Web.Hosting.VirtualFileBase)
Public Property | VirtualPath | Gets the virtual file path. (Inherited from System.Web.Hosting.VirtualFileBase)
Top

See Also

Reference

AspControlBoxBase.ResourceFile Class
Gizmox.WebGUI.Forms.Hosts Namespace


AspControlBoxBase.ResourceProvider Class Properties

[image]
Gizmox.WebGUI.Forms
AspControlBoxBase.ResourceProvider Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace : AspControlBoxBase.ResourceProvider Class

For a list of all members of this type, see AspControlBoxBase.ResourceProvider members.

Protected Properties

 | Name | Description
Protected Property | Previous | Gets a reference to a previously registered VirtualPathProvider object in the compilation system. (Inherited from System.Web.Hosting.VirtualPathProvider)
Top

See Also

Reference

AspControlBoxBase.ResourceProvider Class
Gizmox.WebGUI.Forms.Hosts Namespace


AspPageBase Class Events

[image]
Gizmox.WebGUI.Forms
AspPageBase Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace : AspPageBase Class

For a list of all members of this type, see AspPageBase members.

Public Events

 | Name | Description
Public Event | AbortTransaction | Occurs when a user ends a transaction. (Inherited from System.Web.UI.TemplateControl)
Public Event | CommitTransaction | Occurs when a transaction completes. (Inherited from System.Web.UI.TemplateControl)
Public Event | DataBinding | Occurs when the server control binds to a data source. (Inherited from System.Web.UI.Control)
Public Event | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from System.Web.UI.Control)
Public Event | Error | Occurs when an unhandled exception is thrown. (Inherited from System.Web.UI.TemplateControl)
Public Event | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from System.Web.UI.Control)
Public Event | InitComplete | Occurs when page initialization is complete. (Inherited from System.Web.UI.Page)
Public Event | Load | Occurs when the server control is loaded into the Page object. (Inherited from System.Web.UI.Control)
Public Event | LoadComplete | Occurs at the end of the load stage of the page's life cycle. (Inherited from System.Web.UI.Page)
Public Event | PreInit | Occurs at the beginning of page initialization. (Inherited from System.Web.UI.Page)
Public Event | PreLoad | Occurs before the page Load event. (Inherited from System.Web.UI.Page)
Public Event | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from System.Web.UI.Control)
Public Event | PreRenderComplete | Occurs before the page content is rendered. (Inherited from System.Web.UI.Page)
Public Event | SaveStateComplete | Occurs after the page has completed saving all view state and control state information for the page and controls on the page. (Inherited from System.Web.UI.Page)
Public Event | Unload | Occurs when the server control is unloaded from memory. (Inherited from System.Web.UI.Control)
Top

See Also

Reference

AspPageBase Class
Gizmox.WebGUI.Forms.Hosts Namespace


AspPageBase Class Methods

[image]
Gizmox.WebGUI.Forms
AspPageBase Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace : AspPageBase Class

For a list of all members of this type, see AspPageBase members.

Public Methods

 | Name | Description
Public Method | AddOnPreRenderCompleteAsync | Overloaded. Registers beginning and ending event handler delegates that do not require state information for an asynchronous page. (Inherited from System.Web.UI.Page)
Public Method | ApplyStyleSheetSkin | Applies the style properties defined in the page style sheet to the control. (Inherited from System.Web.UI.Control)
Public Method | DataBind | Overloaded. Binds a data source to the invoked server control and all its child controls. (Inherited from System.Web.UI.Control)
Public Method | Dispose | Enables a server control to perform final clean up before it is released from memory. (Inherited from System.Web.UI.Control)
Public Method | ExecuteRegisteredAsyncTasks | Starts the execution of an asynchronous task. (Inherited from System.Web.UI.Page)
Public Method | FindControl | Overloaded. Searches the page naming container for a server control with the specified identifier. (Inherited from System.Web.UI.Page)
Public Method | Focus | Sets input focus to a control. (Inherited from System.Web.UI.Control)
Public Method | GetDataItem | Gets the data item at the top of the data-binding context stack. (Inherited from System.Web.UI.Page)
Public Method | GetPostBackClientEvent | Gets a reference that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from System.Web.UI.Page)
Public Method | GetPostBackClientHyperlink | Gets a reference, with javascript: appended to the beginning of it, that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from System.Web.UI.Page)
Public Method | GetPostBackEventReference | Overloaded. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object. (Inherited from System.Web.UI.Page)
Public Method | GetValidators | Returns a collection of control validators for a specified validation group. (Inherited from System.Web.UI.Page)
Public Method | HasControls | Determines if the server control contains any child controls. (Inherited from System.Web.UI.Control)
Public Method | IsClientScriptBlockRegistered | Determines whether the client script block with the specified key is registered with the page. (Inherited from System.Web.UI.Page)
Public Method | IsStartupScriptRegistered | Determines whether the client startup script is registered with the Page object. (Inherited from System.Web.UI.Page)
Public Method | LoadControl | Overloaded. Loads a Control object from a file based on a specified virtual path. (Inherited from System.Web.UI.TemplateControl)
Public Method | LoadTemplate | Obtains an instance of the ITemplate interface from an external file. (Inherited from System.Web.UI.TemplateControl)
Public Method | MapPath | Retrieves the physical path that a virtual path, either absolute or relative, or an application-relative path maps to. (Inherited from System.Web.UI.Page)
Public Method | ParseControl | Overloaded. Parses an input string into a Control object on the Web Forms page or user control. (Inherited from System.Web.UI.TemplateControl)
Public Method | RegisterArrayDeclaration | Declares a value that is declared as an ECMAScript array declaration when the page is rendered. (Inherited from System.Web.UI.Page)
Public Method | RegisterAsyncTask | Registers a new asynchronous task with the page. (Inherited from System.Web.UI.Page)
Public Method | RegisterClientScriptBlock | Emits client-side script blocks to the response. (Inherited from System.Web.UI.Page)
Public Method | RegisterHiddenField | Allows server controls to automatically register a hidden field on the form. The field will be sent to the Page object when the HtmlForm server control is rendered. (Inherited from System.Web.UI.Page)
Public Method | RegisterOnSubmitStatement | Allows a page to access the client OnSubmit event. The script should be a function call to client code registered elsewhere. (Inherited from System.Web.UI.Page)
Public Method | RegisterRequiresControlState | Registers a control as one whose control state must be persisted. (Inherited from System.Web.UI.Page)
Public Method | RegisterRequiresPostBack | Registers a control as one that requires postback handling when the page is posted back to the server. (Inherited from System.Web.UI.Page)
Public Method | RegisterRequiresRaiseEvent | Registers an ASP.NET server control as one requiring an event to be raised when the control is processed on the Page object. (Inherited from System.Web.UI.Page)
Public Method | RegisterRequiresViewStateEncryption | Registers a control with the page as one requiring view-state encryption. (Inherited from System.Web.UI.Page)
Public Method | RegisterStartupScript | Emits a client-side script block in the page response. (Inherited from System.Web.UI.Page)
Public Method | RegisterViewStateHandler | Causes page view state to be persisted, if called. (Inherited from System.Web.UI.Page)
Public Method | RenderControl | Overloaded. Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from System.Web.UI.Control)
Public Method | RequiresControlState | Determines whether the specified Control object is registered to participate in control state management. (Inherited from System.Web.UI.Page)
Public Method | ResolveClientUrl | Gets a URL that can be used by the browser. (Inherited from System.Web.UI.Control)
Public Method | ResolveUrl | Converts a URL into one that is usable on the requesting client. (Inherited from System.Web.UI.Control)
Public Method | SetFocus | Overloaded. Sets the browser focus to the specified control. (Inherited from System.Web.UI.Page)
Public Method | SetRenderMethodDelegate | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from System.Web.UI.Control)
Public Method | TestDeviceFilter | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from System.Web.UI.TemplateControl)
Public Method | UnregisterRequiresControlState | Stops persistence of control state for the specified control. (Inherited from System.Web.UI.Page)
Public Method | Validate | Overloaded. Instructs any validation controls included on the page to validate their assigned information. (Inherited from System.Web.UI.Page)
Public Method | VerifyRenderingInServerForm | Confirms that an HtmlForm control is rendered for the specified ASP.NET server control at run time. (Inherited from System.Web.UI.Page)
Top

Protected Methods

 | Name | Description
Protected Method | AddedControl | Called after a child control is added to the Controls collection of the Control object. (Inherited from System.Web.UI.Control)
Protected Method | AddParsedSubObject | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from System.Web.UI.Control)
Protected Method | BuildProfileTree | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from System.Web.UI.Control)
Protected Method | ClearChildControlState | Deletes the control-state information for the server control's child controls. (Inherited from System.Web.UI.Control)
Protected Method | ClearChildState | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from System.Web.UI.Control)
Protected Method | ClearChildViewState | Deletes the view-state information for all the server control's child controls. (Inherited from System.Web.UI.Control)
Protected Method | Construct | Performs design-time logic. (Inherited from System.Web.UI.TemplateControl)
Protected Method | CreateChildControls | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from System.Web.UI.Control)
Protected Method | CreateControlCollection | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from System.Web.UI.Control)
Protected Method | CreateHtmlTextWriter | Creates an HtmlTextWriter object to render the page's content. (Inherited from System.Web.UI.Page)
Protected Method | CreateResourceBasedLiteralControl | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl method is not intended for use from within your code. (Inherited from System.Web.UI.TemplateControl)
Protected Method | DataBindChildren | Binds a data source to the server control's child controls. (Inherited from System.Web.UI.Control)
Protected Method | DeterminePostBackMode | Returns a NameValueCollection of data posted back to the page using either a POST or a GET command. (Inherited from System.Web.UI.Page)
Protected Method | EnsureChildControls | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from System.Web.UI.Control)
Protected Method | EnsureID | Creates an identifier for controls that do not have an identifier assigned. (Inherited from System.Web.UI.Control)
Protected Method | Eval | Overloaded. Evaluates a data-binding expression. (Inherited from System.Web.UI.TemplateControl)
Protected Method | FrameworkInitialize | Initializes the control tree during page generation based on the declarative nature of the page. (Inherited from System.Web.UI.Page)
Protected Method | GetDesignModeState | Gets design-time data for a control. (Inherited from System.Web.UI.Control)
Protected Method | GetGlobalResourceObject | Overloaded. Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from System.Web.UI.TemplateControl)
Protected Method | GetLocalResourceObject | Overloaded. Gets a page-level resource object based on the specified ResourceKey property. (Inherited from System.Web.UI.TemplateControl)
Protected Method | HasEvents | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from System.Web.UI.Control)
Protected Method | InitializeCulture | Sets the Culture and UICulture for the current thread of the page. (Inherited from System.Web.UI.Page)
Protected Method | IsLiteralContent | Determines if the server control holds only literal content. (Inherited from System.Web.UI.Control)
Protected Method | LoadControlState | Restores control-state information from a previous page request that was saved by the SaveControlState method. (Inherited from System.Web.UI.Control)
Protected Method | LoadPageStateFromPersistenceMedium | Loads any saved view-state information to the Page object. (Inherited from System.Web.UI.Page)
Protected Method | LoadViewState | Restores view-state information from a previous page request that was saved by the SaveViewState method. (Inherited from System.Web.UI.Control)
Protected Method | MapPathSecure | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from System.Web.UI.Control)
Protected Method | OnAbortTransaction | Raises the AbortTransaction event. (Inherited from System.Web.UI.TemplateControl)
Protected Method | OnBubbleEvent | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from System.Web.UI.Control)
Protected Method | OnCommitTransaction | Raises the CommitTransaction event. (Inherited from System.Web.UI.TemplateControl)
Protected Method | OnDataBinding | Raises the DataBinding event. (Inherited from System.Web.UI.Control)
Protected Method | OnError | Raises the Error event. (Inherited from System.Web.UI.TemplateControl)
Protected Method | OnInit | Called when the page is initialized (Inherited from AspPipeLinePage)
Protected Method | OnInitComplete | Raises the InitComplete event after page initialization. (Inherited from AspPipeLinePage)
Protected Method | OnLoad | Raises the Load event. (Inherited from System.Web.UI.Control)
Protected Method | OnLoadComplete | Raises the LoadComplete event at the end of the page load stage. (Inherited from System.Web.UI.Page)
Protected Method | OnPreInit | Raises the PreInit event at the beginning of page initialization. (Inherited from System.Web.UI.Page)
Protected Method | OnPreLoad | Called before the page is loaded to get the pipeline events (Inherited from AspPipeLinePage)
Protected Method | OnPreRender | Generates an update command to the pipeline field (Inherited from AspPipeLinePage)
Protected Method | OnPreRenderComplete | Raises the PreRenderComplete event after the OnPreRenderComplete event and before the page is rendered. (Inherited from System.Web.UI.Page)
Protected Method | OnSaveStateComplete | Raises the SaveStateComplete event after the page state has been saved to the persistence medium. (Inherited from System.Web.UI.Page)
Protected Method | OnUnload | Raises the Unload event. (Inherited from System.Web.UI.Control)
Protected Method | OpenFile | Gets a Stream used to read a file. (Inherited from System.Web.UI.Control)
Protected Method | RaiseBubbleEvent | Assigns any sources of the event and its information to the control's parent. (Inherited from System.Web.UI.Control)
Protected Method | RaisePostBackEvent | Notifies the server control that caused the postback that it should handle an incoming postback event. (Inherited from System.Web.UI.Page)
Protected Method | RemovedControl | Called after a control is removed from the Controls collection of another control. (Inherited from System.Web.UI.Control)
Protected Method | Render | Initializes the HtmlTextWriter object and calls on the child controls of the Page to render. (Inherited from System.Web.UI.Page)
Protected Method | RenderChildren | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from System.Web.UI.Control)
Protected Method | ResolveAdapter | Gets the control adapter responsible for rendering the specified control. (Inherited from System.Web.UI.Control)
Protected Method | SaveControlState | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from System.Web.UI.Control)
Protected Method | SavePageStateToPersistenceMedium | Saves any view-state and control-state information for the page. (Inherited from System.Web.UI.Page)
Protected Method | SaveViewState | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from System.Web.UI.Control)
Protected Method | SetDesignModeState | Sets design-time data for a control. (Inherited from System.Web.UI.Control)
Protected Method | TrackViewState | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from System.Web.UI.Control)
Protected Method | XPath | Overloaded. Evaluates an XPath data-binding expression. (Inherited from System.Web.UI.TemplateControl)
Protected Method | XPathSelect | Overloaded. Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from System.Web.UI.TemplateControl)
Top

See Also

Reference

AspPageBase Class
Gizmox.WebGUI.Forms.Hosts Namespace


AspPageBox Class Events

[image]
Gizmox.WebGUI.Forms
AspPageBox Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace : AspPageBox Class

For a list of all members of this type, see AspPageBox members.

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Disposed | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Gizmox.WebGUI.Forms.Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Top

See Also

Reference

AspPageBox Class
Gizmox.WebGUI.Forms.Hosts Namespace


AspPipeLinePage.AspControlBoxStatePersister Class Properties

[image]
Gizmox.WebGUI.Forms
AspPipeLinePage.AspControlBoxStatePersister Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace : AspPipeLinePage.AspControlBoxStatePersister Class

For a list of all members of this type, see AspPipeLinePage.AspControlBoxStatePersister members.

Public Properties

 | Name | Description
Public Property | ControlState | Gets or sets an object that represents the data that controls contained by the current Page object use to persist across HTTP requests to the Web server. (Inherited from System.Web.UI.PageStatePersister)
Public Property | ViewState | Gets or sets an object that represents the data that controls contained by the current Page object use to persist across HTTP requests to the Web server. (Inherited from System.Web.UI.PageStatePersister)
Top

Protected Properties

 | Name | Description
Protected Property | Page | Gets or sets the Page object that the view state persistence mechanism is created for. (Inherited from System.Web.UI.PageStatePersister)
Protected Property | StateFormatter | Gets an IStateFormatter object that is used to serialize and deserialize the state information contained in the ViewState and ControlState properties during calls to the Save and Load methods. (Inherited from System.Web.UI.PageStatePersister)
Top

See Also

Reference

AspPipeLinePage.AspControlBoxStatePersister Class
Gizmox.WebGUI.Forms.Hosts Namespace


AspPipeLinePage Class Events

[image]
Gizmox.WebGUI.Forms
AspPipeLinePage Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace : AspPipeLinePage Class

For a list of all members of this type, see AspPipeLinePage members.

Public Events

 | Name | Description
Public Event | AbortTransaction | Occurs when a user ends a transaction. (Inherited from System.Web.UI.TemplateControl)
Public Event | CommitTransaction | Occurs when a transaction completes. (Inherited from System.Web.UI.TemplateControl)
Public Event | DataBinding | Occurs when the server control binds to a data source. (Inherited from System.Web.UI.Control)
Public Event | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from System.Web.UI.Control)
Public Event | Error | Occurs when an unhandled exception is thrown. (Inherited from System.Web.UI.TemplateControl)
Public Event | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from System.Web.UI.Control)
Public Event | InitComplete | Occurs when page initialization is complete. (Inherited from System.Web.UI.Page)
Public Event | Load | Occurs when the server control is loaded into the Page object. (Inherited from System.Web.UI.Control)
Public Event | LoadComplete | Occurs at the end of the load stage of the page's life cycle. (Inherited from System.Web.UI.Page)
Public Event | PreInit | Occurs at the beginning of page initialization. (Inherited from System.Web.UI.Page)
Public Event | PreLoad | Occurs before the page Load event. (Inherited from System.Web.UI.Page)
Public Event | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from System.Web.UI.Control)
Public Event | PreRenderComplete | Occurs before the page content is rendered. (Inherited from System.Web.UI.Page)
Public Event | SaveStateComplete | Occurs after the page has completed saving all view state and control state information for the page and controls on the page. (Inherited from System.Web.UI.Page)
Public Event | Unload | Occurs when the server control is unloaded from memory. (Inherited from System.Web.UI.Control)
Top

See Also

Reference

AspPipeLinePage Class
Gizmox.WebGUI.Forms.Hosts Namespace


FlashBox Class Events

[image]
Gizmox.WebGUI.Forms
FlashBox Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace : FlashBox Class

For a list of all members of this type, see FlashBox members.

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Disposed | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Gizmox.WebGUI.Forms.Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Top

See Also

Reference

FlashBox Class
Gizmox.WebGUI.Forms.Hosts Namespace


FlashBoxBase Class Events

[image]
Gizmox.WebGUI.Forms
FlashBoxBase Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace : FlashBoxBase Class

For a list of all members of this type, see FlashBoxBase members.

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Disposed | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Gizmox.WebGUI.Forms.Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Top

See Also

Reference

FlashBoxBase Class
Gizmox.WebGUI.Forms.Hosts Namespace


FlashBoxBase Class Methods

[image]
Gizmox.WebGUI.Forms
FlashBoxBase Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace : FlashBoxBase Class

For a list of all members of this type, see FlashBoxBase members.

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Focus | Sets focus to this control (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | GetGatewayHandler | (Inherited from ObjectBox)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | GetPreferredSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | ResetText | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | Select | Overloaded. Activates the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SendToBack | (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Show | Displays the control to the user. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Method | ToString | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Method | Update | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | Finalize | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCommandText | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetImage | Gets the image. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | GetPreferredSizeCore | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetService | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | InvokeMethod | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | IsDirty | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnBindingContextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnControlAdded | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnControlRemoved | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | OnEnabledChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnGotFocus | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnLostFocus | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnParentVisibleChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnResize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnTextChanged | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnUnregisterComponents | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnValidated | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnValidating | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ProcessGatewayRequest | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RegisterSelf | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | Render | Renders the current control. (Inherited from ObjectBox)
Protected Method | RenderAttributes | Renders the controls meta attributes (Inherited from ObjectBox)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderClientUpdateHandler | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderComponentEventAttributes | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | RenderUpdatedAttributes | An abstract param attribute rendering (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetImage | Sets the image. (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeSize | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | ShouldSerializeText | (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | UnRegisterBatch | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Gizmox.WebGUI.Forms.Component)
Protected Method | UnRegisterSelf | (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Gizmox.WebGUI.Forms.Control)
Protected Method | UpdateParams | Overloaded. (Inherited from Gizmox.WebGUI.Forms.RegisteredComponent)
Top

See Also

Reference

FlashBoxBase Class
Gizmox.WebGUI.Forms.Hosts Namespace


FormBox Class Events

[image]
Gizmox.WebGUI.Forms
FormBox Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace : FormBox Class

For a list of all members of this type, see FormBox members.

Public Events

 | Name | Description
Public Event | DataBinding | Occurs when the server control binds to a data source. (Inherited from System.Web.UI.Control)
Public Event | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from System.Web.UI.Control)
Public Event | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from System.Web.UI.Control)
Public Event | Load | Occurs when the server control is loaded into the Page object. (Inherited from System.Web.UI.Control)
Public Event | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from System.Web.UI.Control)
Public Event | Unload | Occurs when the server control is unloaded from memory. (Inherited from System.Web.UI.Control)
Top

See Also

Reference

FormBox Class
Gizmox.WebGUI.Forms.Hosts Namespace


ObjectBox Class Events

[image]
Gizmox.WebGUI.Forms
ObjectBox Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms.Hosts Namespace : ObjectBox Class

For a list of all members of this type, see ObjectBox members.

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Disposed | (Inherited from Gizmox.WebGUI.Forms.ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Gizmox.WebGUI.Forms.Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Gizmox.WebGUI.Forms.Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Gizmox.WebGUI.Forms.Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Gizmox.WebGUI.Forms.Control)
Top

See Also

Reference

ObjectBox Class
Gizmox.WebGUI.Forms.Hosts Namespace


Gizmox.WebGUI.Forms.Hosts Namespace Inheritance Hierarchy

Gizmox.WebGUI.Forms.Hosts Namespace Inheritance Hierarchy
See Also Send Feedback

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.FrameControl
Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase
Gizmox.WebGUI.Forms.Hosts.AspPageBox
Gizmox.WebGUI.Forms.Hosts.AppletBoxBase
Gizmox.WebGUI.Forms.Hosts.AppletBox
Gizmox.WebGUI.Forms.Hosts.ObjectBox
Gizmox.WebGUI.Forms.Hosts.FlashBoxBase
Gizmox.WebGUI.Forms.Hosts.FlashBox
System.EventArgs
Gizmox.WebGUI.Forms.Hosts.AspControlEventArgs
Gizmox.WebGUI.Forms.Hosts.AspPageEventArgs
System.MarshalByRefObject
System.Web.Hosting.VirtualFileBase
System.Web.Hosting.VirtualFile
Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase.ResourceFile
System.Web.Hosting.VirtualPathProvider
Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase.ResourceProvider
System.Web.UI.Control
Gizmox.WebGUI.Forms.Hosts.FormBox
System.Web.UI.TemplateControl
System.Web.UI.Page
Gizmox.WebGUI.Forms.Hosts.AspPipeLinePage
Gizmox.WebGUI.Forms.Hosts.AspPageBase
System.Web.UI.PageStatePersister
Gizmox.WebGUI.Forms.Hosts.AspPipeLinePage.AspControlBoxStatePersister

See Also

Reference

Gizmox.WebGUI.Forms Assembly


HtmlBox.HtmlGateway Class Properties

[image]
Gizmox.WebGUI.Forms
HtmlBox.HtmlGateway Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : HtmlBox.HtmlGateway Class

For a list of all members of this type, see HtmlBox.HtmlGateway members.

Protected Properties

 | Name | Description
Protected Property | ContentType | (Inherited from Gizmox.WebGUI.Common.Gateways.GatewayWriter)
Protected Property | GatewayComponent | (Inherited from Gizmox.WebGUI.Common.Gateways.GatewayWriter)
Top

See Also

Reference

HtmlBox.HtmlGateway Class
Gizmox.WebGUI.Forms Namespace


HtmlBox Class Events

[image]
Gizmox.WebGUI.Forms
HtmlBox Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : HtmlBox Class

For a list of all members of this type, see HtmlBox members.

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

HtmlBox Class
Gizmox.WebGUI.Forms Namespace


ImageList Class Events

[image]
Gizmox.WebGUI.Forms
ImageList Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ImageList Class

For a list of all members of this type, see ImageList members.

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from ComponentBase)
Top

See Also

Reference

ImageList Class
Gizmox.WebGUI.Forms Namespace


Label Class Events

[image]
Gizmox.WebGUI.Forms
Label Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : Label Class

For a list of all members of this type, see Label members.

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

Label Class
Gizmox.WebGUI.Forms Namespace


Gizmox.WebGUI.Forms.Layout Namespace Inheritance Hierarchy

Gizmox.WebGUI.Forms.Layout Namespace Inheritance Hierarchy
See Also Send Feedback

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.Layout.ArrangedElementCollection

See Also

Reference

Gizmox.WebGUI.Forms Assembly


ListViewItem Class Events

[image]
Gizmox.WebGUI.Forms
ListViewItem Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ListViewItem Class

For a list of all members of this type, see ListViewItem members.

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Top

See Also

Reference

ListViewItem Class
Gizmox.WebGUI.Forms Namespace


MainMenu Class Events

[image]
Gizmox.WebGUI.Forms
MainMenu Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : MainMenu Class

For a list of all members of this type, see MainMenu members.

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

MainMenu Class
Gizmox.WebGUI.Forms Namespace


MaskedTextBox Class Events

[image]
Gizmox.WebGUI.Forms
MaskedTextBox Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : MaskedTextBox Class

For a list of all members of this type, see MaskedTextBox members.

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | EnterKeyDown | Occurs on enter key down only on single line. (Inherited from TextBox)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

MaskedTextBox Class
Gizmox.WebGUI.Forms Namespace


MaskedTextBox Class Fields

[image]
Gizmox.WebGUI.Forms
MaskedTextBox Class Fields
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : MaskedTextBox Class

For a list of all members of this type, see MaskedTextBox members.

Protected Fields

 | Name | Description
Protected Field | menmScrollBars | Member which holds the scrollbars mode. (Inherited from TextBox)
Top

See Also

Reference

MaskedTextBox Class
Gizmox.WebGUI.Forms Namespace


MdiClient.ControlCollection Class Properties

[image]
Gizmox.WebGUI.Forms
MdiClient.ControlCollection Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : MdiClient.ControlCollection Class

For a list of all members of this type, see MdiClient.ControlCollection members.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from Control.ControlCollection)
Public Property | IsFixedSize | (Inherited from Control.ControlCollection)
Public Property | IsReadOnly | (Inherited from Control.ControlCollection)
Public Property | Item | Overloaded. Indicates a Control with the specified key in the collection. (Inherited from Control.ControlCollection)
Public Property | Owner | Gets the control that owns this Control.ControlCollection. (Inherited from Control.ControlCollection)
Top

See Also

Reference

MdiClient.ControlCollection Class
Gizmox.WebGUI.Forms Namespace


MdiClient Class Events

[image]
Gizmox.WebGUI.Forms
MdiClient Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : MdiClient Class

For a list of all members of this type, see MdiClient members.

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

MdiClient Class
Gizmox.WebGUI.Forms Namespace


Menu Class Events

[image]
Gizmox.WebGUI.Forms
Menu Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : Menu Class

For a list of all members of this type, see Menu members.

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Top

See Also

Reference

Menu Class
Gizmox.WebGUI.Forms Namespace


MenuCollection Class Events

[image]
Gizmox.WebGUI.Forms
MenuCollection Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : MenuCollection Class

For a list of all members of this type, see MenuCollection members.

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Top

See Also

Reference

MenuCollection Class
Gizmox.WebGUI.Forms Namespace


MenuCollection Class Properties

[image]
Gizmox.WebGUI.Forms
MenuCollection Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : MenuCollection Class

For a list of all members of this type, see MenuCollection members.

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContextMenu | Gets or sets the context menu code. (Inherited from Component)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

See Also

Reference

MenuCollection Class
Gizmox.WebGUI.Forms Namespace


MessageBoxWindow Class Events

[image]
Gizmox.WebGUI.Forms
MessageBoxWindow Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : MessageBoxWindow Class

For a list of all members of this type, see MessageBoxWindow members.

Public Events

 | Name | Description
Public Event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form)
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | Closed | (Inherited from Form)
Public Event | Closing | The form closing event. This event is not raised on the main form. (Inherited from Form)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | Load | The form load event (Inherited from Form)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

MessageBoxWindow Class
Gizmox.WebGUI.Forms Namespace


MessageBoxWindow Class Methods

[image]
Gizmox.WebGUI.Forms
MessageBoxWindow Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : MessageBoxWindow Class

For a list of all members of this type, see MessageBoxWindow members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from ContainerControl)
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Close | Closes this window. (Inherited from Form)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from ContainerControl)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | Remove | (Inherited from ContainerControl)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | (Inherited from Form)
Public Method | ShowDialog | Overloaded. Shows a the form as a dialog. The ShowDialog in Visual WebGui works differently than WinForms. Code lines after this call is executed immediately and won’t wait for the dialog to close. If you need to run code only after the dialog is closed or only if a specific result is returned register to the close event of the dialog. See documentation for code example. (Inherited from Form)
Public Method | ShowPopup | Overloaded. Displays the form as a popup window. (Inherited from Form)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Form)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from ScrollableControl)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnActivated | Raises the Activated event. (Inherited from Form)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnClosed | (Inherited from Form)
Protected Method | OnClosing | (Inherited from Form)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Occurs when control is created (Inherited from Form)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLoad | Raises the Load event. (Inherited from Form)
Protected Method | OnLocationChanged | (Inherited from Form)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Form)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | Render the form content (Inherited from Form)
Protected Method | RenderAttributes | Renders the forms attribute (Inherited from Form)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Form)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Form)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | (Inherited from Form)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

See Also

Reference

MessageBoxWindow Class
Gizmox.WebGUI.Forms Namespace


MessageBoxWindow Class Properties

[image]
Gizmox.WebGUI.Forms
MessageBoxWindow Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : MessageBoxWindow Class

For a list of all members of this type, see MessageBoxWindow members.

Public Properties

 | Name | Description
Public Property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form)
Public Property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl)
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | AutoScaleBaseSize | Gets or sets the size of the auto scale base. Not implemented. (Inherited from Form)
Public Property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BeforeUnloadMessage | Gets or sets the before unload message. (Inherited from Form)
Public Property | BindingContext | (Inherited from ContainerControl)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CancelButton | Gets or sets the button on the form that is clicked when the user presses the ESC key. (Inherited from Form)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Form)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Components | (Inherited from ContainerControl)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Form)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | DialogResult | Gets or sets the dialog result. (Inherited from Form)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl)
Public Property | DragMappings | Gets the form drag mappings. (Inherited from Form)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | FormBorderStyle | Gets or sets the form border style. (Inherited from Form)
Public Property | FormStyle | Gets or sets the form style. (Inherited from Form)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this control has controls. (Inherited from Form)
Public Property | Header | Gets or sets the form header control. (Inherited from Form)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | Icon | Gets or sets the form icon (Inherited from Form)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form. (Inherited from Form)
Public Property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms. (Inherited from Form)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximizeBox | Gets or sets a value indicating whether [maximize box]. (Inherited from Form)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form. (Inherited from Form)
Public Property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form)
Public Property | MinimizeBox | Gets or sets a value indicating whether [minimize box]. (Inherited from Form)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Modal | Gets or sets a value indicating whether this window is modal. (Inherited from Form)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | OwnedForms | Gets the child forms. (Inherited from Form)
Public Property | Owner | Gets the parent window. (Inherited from Form)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | ShowInTaskbar | Gets or sets a value indicating whether [show in taskbar]. Not implemented by design (Inherited from Form)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | StartPosition | Gets or sets the form start position. (Inherited from Form)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Control)
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form)
Public Property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. Not implemented by design. (Inherited from Form)
Public Property | Visible | Get/Sets the form visibility (Inherited from Form)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Public Property | WindowState | Gets or sets the state of the window. (Inherited from Form)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | IsWindowSized | Calculate size invluding borders (Inherited from Form)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets or sets the main form. (Inherited from Form)
Protected Property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl)
Top

See Also

Reference

MessageBoxWindow Class
Gizmox.WebGUI.Forms Namespace


OpenFileDialog Class Events

[image]
Gizmox.WebGUI.Forms
OpenFileDialog Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : OpenFileDialog Class

For a list of all members of this type, see OpenFileDialog members.

Public Events

 | Name | Description
Public Event | Closed | The form close event (Inherited from CommonDialog)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | FileOk | Occurs when the user clicks on the Open or Save button on a file dialog box. (Inherited from FileDialog)
Public Event | HelpRequest | Occurs when the user clicks the Help button on a common dialog box. (Inherited from CommonDialog)
Top

See Also

Reference

OpenFileDialog Class
Gizmox.WebGUI.Forms Namespace


Panel Class Events

[image]
Gizmox.WebGUI.Forms
Panel Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : Panel Class

For a list of all members of this type, see Panel members.

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

Panel Class
Gizmox.WebGUI.Forms Namespace


PictureBox Class Events

[image]
Gizmox.WebGUI.Forms
PictureBox Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : PictureBox Class

For a list of all members of this type, see PictureBox members.

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

PictureBox Class
Gizmox.WebGUI.Forms Namespace


ProgressBar Class Events

[image]
Gizmox.WebGUI.Forms
ProgressBar Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ProgressBar Class

For a list of all members of this type, see ProgressBar members.

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

ProgressBar Class
Gizmox.WebGUI.Forms Namespace


Gizmox.WebGUI.Forms.PropertyGridInternal Namespace Inheritance Hierarchy

Gizmox.WebGUI.Forms.PropertyGridInternal Namespace Inheritance Hierarchy
See Also Send Feedback

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.Design.PropertyTab
Gizmox.WebGUI.Forms.PropertyGridInternal.PropertiesTab

See Also

Reference

Gizmox.WebGUI.Forms Assembly


PropertyManager Class Events

[image]
Gizmox.WebGUI.Forms
PropertyManager Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : PropertyManager Class

For a list of all members of this type, see PropertyManager members.

Public Events

 | Name | Description
Public Event | BindingComplete | Occurs at the completion of a data-binding operation. (Inherited from BindingManagerBase)
Public Event | CurrentChanged | Occurs when the currently bound item changes. (Inherited from BindingManagerBase)
Public Event | CurrentItemChanged | Occurs when the state of the currently bound item changes. (Inherited from BindingManagerBase)
Public Event | DataError | Occurs when an Exception is silently handled by the BindingManagerBase. (Inherited from BindingManagerBase)
Public Event | PositionChanged | Occurs after the value of the Position property has changed. (Inherited from BindingManagerBase)
Top

See Also

Reference

PropertyManager Class
Gizmox.WebGUI.Forms Namespace


RelatedImageListAttribute Class Methods

[image]
Gizmox.WebGUI.Forms
RelatedImageListAttribute Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RelatedImageListAttribute Class

For a list of all members of this type, see RelatedImageListAttribute members.

Public Methods

 | Name | Description
Public Method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from System.Attribute)
Public Method | GetHashCode | Returns the hash code for this instance. (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from System.Attribute)
Public Method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from System.Attribute)
Top

See Also

Reference

RelatedImageListAttribute Class
Gizmox.WebGUI.Forms Namespace


RowStyle Class Methods

[image]
Gizmox.WebGUI.Forms
RowStyle Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : RowStyle Class

For a list of all members of this type, see RowStyle members.

Protected Methods

 | Name | Description
Protected Method | FireObservableItemPropertyChanged | Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from TableLayoutStyle)
Top

See Also

Reference

RowStyle Class
Gizmox.WebGUI.Forms Namespace


ScrollableControl Class Events

[image]
Gizmox.WebGUI.Forms
ScrollableControl Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ScrollableControl Class

For a list of all members of this type, see ScrollableControl members.

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

ScrollableControl Class
Gizmox.WebGUI.Forms Namespace


ShortcutsContainer Class Events

[image]
Gizmox.WebGUI.Forms
ShortcutsContainer Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ShortcutsContainer Class

For a list of all members of this type, see ShortcutsContainer members.

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Top

See Also

Reference

ShortcutsContainer Class
Gizmox.WebGUI.Forms Namespace


Splitter Class Properties

[image]
Gizmox.WebGUI.Forms
Splitter Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : Splitter Class

For a list of all members of this type, see Splitter members.

Public Properties

 | Name | Description
Public Property | AllowDrop | Gets or sets whether this control accepts dropping dragged content to it (Inherited from Component)
Public Property | Anchor | Gets or sets the anchoring style. (Inherited from Control)
Public Property | BackColor | Gets or sets the background color. (Inherited from Control)
Public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control)
Public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control)
Public Property | BindingContext | (Inherited from Control)
Public Property | BorderColor | Gets or sets the border color. (Inherited from Control)
Public Property | BorderStyle | Gets or sets the border style. (Inherited from Control)
Public Property | BorderWidth | Gets or sets the width of the border. (Inherited from Control)
Public Property | Bottom | Gets/Sets the bottom position (Inherited from Control)
Public Property | CanFocus | Gets a value indicating whether this instance can focus. (Inherited from Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control)
Public Property | ClientAction | Gets or sets the client action. (Inherited from Component)
Public Property | ClientSize | Gets or sets the client size of the form. (Inherited from Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control)
Public Property | Container | (Inherited from ComponentBase)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control)
Public Property | Context | Gets the context. (Inherited from Control)
Public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from Control)
Public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control)
Public Property | CustomStyle | Gets or sets the control custom style. (Inherited from Control)
Public Property | CustomTemplate | Gets or sets the custom template. (Inherited from Component)
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from Control)
Public Property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control)
Public Property | Dock | Gets/Sets the controls docking style (Inherited from Control)
Public Property | DragTargets | Defines the valid drag and drop targets when drag starts from this control. (Inherited from Component)
Public Property | Enabled | Gets or sets the control enabled state. (Inherited from Control)
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control)
Public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control)
Public Property | ForeColor | Gets or sets the fore color. (Inherited from Control)
Public Property | Form | Gets the owner form. (Inherited from Component)
Public Property | Handle | Gets the handle that the control is bound to. (Inherited from Control)
Public Property | HasChildren | Gets a value indicating whether this control has children. (Inherited from Control)
Public Property | HasControls | Gets a value indicating whether this instance has controls. (Inherited from Control)
Public Property | Height | Gets/Sets the height position (Inherited from Control)
Public Property | InternalParent | Gets the parent of this component. (Inherited from Component)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control)
Public Property | IsRegistered | (Inherited from RegisteredComponent)
Public Property | KeyFilter | Gets or sets the key down filter. (Inherited from Control)
Public Property | Left | Gets/Sets the left position (Inherited from Control)
Public Property | Location | Gets or sets the control location. (Inherited from Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that Control.GetPreferredSize can specify. (Inherited from Control)
Public Property | Name | Gets or sets the name associated with this control. (Inherited from Control)
Public Property | Padding | Gets or sets the control padding. (Inherited from Control)
Public Property | Parent | Gets or sets the parent container of this control. (Inherited from Control)
Public Property | PreferredSize | Not Implemented Property. Gets the size of a rectangular area into which the control can fit. (Inherited from Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control)
Public Property | Right | Gets/Sets the right position (Inherited from Control)
Public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control)
Public Property | Site | (Inherited from ComponentBase)
Public Property | Size | Gets or sets the size. (Inherited from Control)
Public Property | TabIndex | Gets or sets the tab index. (Inherited from Control)
Public Property | TabStop | Gets or sets a value indicating whether tab stop is enabled. (Inherited from Control)
Public Property | Tag | Gets/Sets User definied tag (Inherited from Component)
Public Property | Text | Gets or sets the text associated with this control. (Inherited from Control)
Public Property | Top | Gets/Sets the top position (Inherited from Control)
Public Property | Visible | Gets or sets the control visability. (Inherited from Control)
Public Property | Width | Gets/Sets the width position (Inherited from Control)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | ClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Property | DefaultBackColor | (Inherited from Control)
Protected Property | DefaultBorderColor | (Inherited from Control)
Protected Property | DefaultBorderStyle | (Inherited from Control)
Protected Property | DefaultForeColor | (Inherited from Control)
Protected Property | DefaultMargin | (Inherited from Control)
Protected Property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control)
Protected Property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control)
Protected Property | DefaultPadding | (Inherited from Control)
Protected Property | DefaultSize | (Inherited from Control)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Protected Property | HasPositioning | Gets or sets a value indicating whether this instance has positioning. (Inherited from Control)
Protected Property | IsConnected | (Inherited from Component)
Protected Property | IsDelayedDrawing | (Inherited from Control)
Protected Property | MetadataTag | Gets the control tag name. (Inherited from Control)
Protected Property | ReverseControls | Gets a value indicating whether to reverse control rendering. (Inherited from Control)
Protected Property | ScrollLeft | Gets or sets the ScrollLeft property. (Inherited from Control)
Protected Property | ScrollLeftInternal | Sets the scroll left internal. (Inherited from Control)
Protected Property | ScrollTop | Gets or sets the ScrollTop property. (Inherited from Control)
Protected Property | ScrollTopInternal | Sets the scroll top internal. (Inherited from Control)
Protected Property | Session | Gets the application object. (Inherited from Component)
Top

See Also

Reference

Splitter Class
Gizmox.WebGUI.Forms Namespace


SplitterPanel Class Events

[image]
Gizmox.WebGUI.Forms
SplitterPanel Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : SplitterPanel Class

For a list of all members of this type, see SplitterPanel members.

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Top

See Also

Reference

SplitterPanel Class
Gizmox.WebGUI.Forms Namespace


SplitterPanel Class Methods

[image]
Gizmox.WebGUI.Forms
SplitterPanel Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : SplitterPanel Class

For a list of all members of this type, see SplitterPanel members.

Public Methods

 | Name | Description
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control)
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control)
Public Method | Dispose | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources. (Inherited from Control)
Public Method | Focus | Sets focus to this control (Inherited from Control)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control)
Public Method | GetPreferredSize | (Inherited from Control)
Public Method | Hide | Conceals the control from the user. (Inherited from Control)
Public Method | Invalidate | Overloaded. Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control)
Public Method | Invoke | Overloaded. Invokes the specified method. (Inherited from Control)
Public Method | PerformLayout | WinForm complaint - No use. (Inherited from Control)
Public Method | RegisterClientAction | Overloaded. Registers the default client invocation. (Inherited from Component)
Public Method | RegisterClientActionWithId | Registers the default client invocation (Adds component id as the first parameter). (Inherited from Component)
Public Method | ResetText | (Inherited from Control)
Public Method | ResumeLayout | Overloaded. Resumes the layout. (Inherited from Control)
Public Method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl)
Public Method | Select | Overloaded. Activates the control. (Inherited from Control)
Public Method | SendToBack | (Inherited from Control)
Public Method | SetLoadingMessage | Sets the loading message. (Inherited from Component)
Public Method | Show | Displays the control to the user. (Inherited from Control)
Public Method | SuspendLayout | Suspends the layout. (Inherited from Control)
Public Method | ToString | (Inherited from ComponentBase)
Public Method | UnregisterClientAction | Unregisters the default client invocation. (Inherited from Component)
Public Method | Update | Overloaded. (Inherited from RegisteredComponent)
Top

Protected Methods

 | Name | Description
Protected Method | CreateControlsInstance | (Inherited from Control)
Protected Method | Finalize | (Inherited from ComponentBase)
Protected Method | FireEvent | Fires an event. (Inherited from Control)
Protected Method | FireObservableItemPropertyChanged | Overloaded. Fires the ObservableItemPropertyChanged event of the IObservableItem interface. (Inherited from Component)
Protected Method | GetAncestorByType | Gets the ancestor by type. (Inherited from Component)
Protected Method | GetCalculatedHeight | Gets the calculated height. (Inherited from Control)
Protected Method | GetCalculatedLeft | Gets the calculated left. (Inherited from Control)
Protected Method | GetCalculatedTop | Gets the calculated top. (Inherited from Control)
Protected Method | GetCalculatedWidth | Gets the calculated width. (Inherited from Control)
Protected Method | GetCommandText | (Inherited from Control)
Protected Method | GetCriticalEvents | Gets the critical events. (Inherited from Control)
Protected Method | GetEventValue | Gets the event integer attribute value. (Inherited from Component)
Protected Method | GetImage | Gets the image. (Inherited from Component)
Protected Method | GetPreferredSizeCore | (Inherited from ScrollableControl)
Protected Method | GetService | (Inherited from ComponentBase)
Protected Method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control)
Protected Method | GetTopLevel | Gets the top level. (Inherited from Control)
Protected Method | InvokeMethod | (Inherited from RegisteredComponent)
Protected Method | InvokeMethodWithId | (Inherited from RegisteredComponent)
Protected Method | IsDirty | (Inherited from RegisteredComponent)
Protected Method | IsDirtyAttributes | Overloaded. (Inherited from RegisteredComponent)
Protected Method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control)
Protected Method | OnBackgroundImageLayoutChanged | Raises the Control.BackgroundImageLayoutChanged event. (Inherited from Control)
Protected Method | OnBindingContextChanged | (Inherited from Control)
Protected Method | OnClick | Raises the Control.Click event. (Inherited from Control)
Protected Method | OnControlAdded | (Inherited from Control)
Protected Method | OnControlRemoved | (Inherited from Control)
Protected Method | OnCreateControl | Raises the Control.CreateControl event. (Inherited from Control)
Protected Method | OnCursorChanged | Raises the Control.CursorChanged event. (Inherited from Control)
Protected Method | OnDoubleClick | Raises the Control.DoubleClick event. (Inherited from Control)
Protected Method | OnDragDrop | Raises the DragDrop event. (Inherited from Component)
Protected Method | OnEnabledChanged | (Inherited from Control)
Protected Method | OnEnter | Raises the Control.Enter event. (Inherited from Control)
Protected Method | OnFontChanged | Raises the DataGridView.FontChanged event. (Inherited from Control)
Protected Method | OnForeColorChanged | Raises the Control.ForeColorChanged event. (Inherited from Control)
Protected Method | OnGotFocus | (Inherited from Control)
Protected Method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Control)
Protected Method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Control)
Protected Method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control)
Protected Method | OnKeyDown | Raises the Control.KeyDown event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnKeyPress | Raises the Control.KeyPress event. (Inherited from Control)
Protected Method | OnKeyUp | Raises the Control.KeyUp event. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Protected Method | OnLeave | Raises the Control.Leave event. (Inherited from Control)
Protected Method | OnLocationChanged | Raises the Control.LocationChanged event. (Inherited from Control)
Protected Method | OnLostFocus | (Inherited from Control)
Protected Method | OnMouseClick | Raises the MouseClick event. (Inherited from Control)
Protected Method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control)
Protected Method | OnMouseDown | Raises the Control.MouseDown event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnMouseUp | Raises the Control.MouseUp event. Implemented by design as Click (Use Click instead). (Inherited from Control)
Protected Method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control)
Protected Method | OnParentBindingContextChanged | (Inherited from Control)
Protected Method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control)
Protected Method | OnParentVisibleChanged | (Inherited from Control)
Protected Method | OnResize | (Inherited from Control)
Protected Method | OnTextChanged | (Inherited from Control)
Protected Method | OnTextChangedQueued | Raise TextChangedQueued event (Inherited from Control)
Protected Method | OnUnregisterComponents | (Inherited from Control)
Protected Method | OnValidated | (Inherited from Control)
Protected Method | OnValidating | (Inherited from Control)
Protected Method | OnVisibleChanged | Raises the Control.VisibleChanged event. (Inherited from Control)
Protected Method | ProcessGatewayRequest | (Inherited from RegisteredComponent)
Protected Method | RegisterBatch | (Inherited from RegisteredComponent)
Protected Method | RegisterComponent | (Inherited from RegisteredComponent)
Protected Method | RegisterContextMenu | (Inherited from Component)
Protected Method | RegisterSelf | (Inherited from RegisteredComponent)
Protected Method | Render | An abstract control method rendering (Inherited from Control)
Protected Method | RenderAttributes | (Inherited from Panel)
Protected Method | RenderClientInvocation | Renders the client invocation mapping if needed. (Inherited from Component)
Protected Method | RenderClientUpdateHandler | (Inherited from RegisteredComponent)
Protected Method | RenderComponentAttributes | Renders the controls meta attributes (Inherited from Component)
Protected Method | RenderComponentEventAttributes | (Inherited from RegisteredComponent)
Protected Method | RenderControl | Checks if the current control needs rendering and continues to process sub trree/ (Inherited from Control)
Protected Method | RenderControls | Overloaded. Renders the controls sub tree (Inherited from Control)
Protected Method | RenderDragAndDropAttributes | Renders the drag and drop attributes. (Inherited from Component)
Protected Method | RenderExtendedComponentAttributes | Renders the extended component attributes. (Inherited from Component)
Protected Method | RenderUpdatedAttributes | (Inherited from Panel)
Protected Method | ResetCreatedFlag | Resets the created flag. (Inherited from Control)
Protected Method | SetImage | Sets the image. (Inherited from Component)
Protected Method | SetStyle | Sets the specified style bit to the specified value. (Inherited from Control)
Protected Method | SetTopLevel | Sets the top level. (Inherited from Control)
Protected Method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control)
Protected Method | ShouldSerializeAllowDrop | (Inherited from Component)
Protected Method | ShouldSerializeBackColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderColor | (Inherited from Control)
Protected Method | ShouldSerializeBorderStyle | (Inherited from Control)
Protected Method | ShouldSerializeClientSize | (Inherited from Control)
Protected Method | ShouldSerializeCustomTemplate | (Inherited from Component)
Protected Method | ShouldSerializeDragTargets | (Inherited from Component)
Protected Method | ShouldSerializeForeColor | (Inherited from Control)
Protected Method | ShouldSerializePanelType | (Inherited from Panel)
Protected Method | ShouldSerializeSize | (Inherited from Control)
Protected Method | ShouldSerializeTabIndex | (Inherited from Control)
Protected Method | ShouldSerializeText | (Inherited from Control)
Protected Method | UnRegisterBatch | (Inherited from RegisteredComponent)
Protected Method | UnRegisterComponent | (Inherited from RegisteredComponent)
Protected Method | UnregisterContextMenu | (Inherited from Component)
Protected Method | UnRegisterSelf | (Inherited from RegisteredComponent)
Protected Method | UpdateDataBinding | Updates the received data binding. (Inherited from Control)
Protected Method | UpdateParams | Overloaded. (Inherited from RegisteredComponent)
Top

See Also

Reference

SplitterPanel Class
Gizmox.WebGUI.Forms Namespace


StatusBar Class Events

[image]
Gizmox.WebGUI.Forms
StatusBar Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : StatusBar Class

For a list of all members of this type, see StatusBar members.

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

StatusBar Class
Gizmox.WebGUI.Forms Namespace


StatusBarPanel Class Events

[image]
Gizmox.WebGUI.Forms
StatusBarPanel Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : StatusBarPanel Class

For a list of all members of this type, see StatusBarPanel members.

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Top

See Also

Reference

StatusBarPanel Class
Gizmox.WebGUI.Forms Namespace


TableLayoutCellPaintEventArgs Class Methods

[image]
Gizmox.WebGUI.Forms
TableLayoutCellPaintEventArgs Class Methods
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TableLayoutCellPaintEventArgs Class

For a list of all members of this type, see TableLayoutCellPaintEventArgs members.

Public Methods

 | Name | Description
Public Method | Dispose | Overloaded. (Inherited from PaintEventArgs)
Top

Protected Methods

 | Name | Description
Protected Method | Finalize | (Inherited from PaintEventArgs)
Top

See Also

Reference

TableLayoutCellPaintEventArgs Class
Gizmox.WebGUI.Forms Namespace


TabPage Class Events

[image]
Gizmox.WebGUI.Forms
TabPage Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TabPage Class

For a list of all members of this type, see TabPage members.

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

TabPage Class
Gizmox.WebGUI.Forms Namespace


TextBoxBase Class Events

[image]
Gizmox.WebGUI.Forms
TextBoxBase Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : TextBoxBase Class

For a list of all members of this type, see TextBoxBase members.

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

TextBoxBase Class
Gizmox.WebGUI.Forms Namespace


ToolTip Class Events

[image]
Gizmox.WebGUI.Forms
ToolTip Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ToolTip Class

For a list of all members of this type, see ToolTip members.

Public Events

 | Name | Description
Public Event | Disposed | (Inherited from ComponentBase)
Top

See Also

Reference

ToolTip Class
Gizmox.WebGUI.Forms Namespace


ToolTip Class Properties

[image]
Gizmox.WebGUI.Forms
ToolTip Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : ToolTip Class

For a list of all members of this type, see ToolTip members.

Public Properties

 | Name | Description
Public Property | Container | (Inherited from ComponentBase)
Public Property | Site | (Inherited from ComponentBase)
Top

Protected Properties

 | Name | Description
Protected Property | CanRaiseEvents | (Inherited from ComponentBase)
Protected Property | DesignMode | (Inherited from ComponentBase)
Protected Property | Events | (Inherited from ComponentBase)
Top

See Also

Reference

ToolTip Class
Gizmox.WebGUI.Forms Namespace


UpDownBase Class Events

[image]
Gizmox.WebGUI.Forms
UpDownBase Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : UpDownBase Class

For a list of all members of this type, see UpDownBase members.

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

UpDownBase Class
Gizmox.WebGUI.Forms Namespace


XamlBox.XamlGateway Class Properties

[image]
Gizmox.WebGUI.Forms
XamlBox.XamlGateway Class Properties
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : XamlBox.XamlGateway Class

For a list of all members of this type, see XamlBox.XamlGateway members.

Protected Properties

 | Name | Description
Protected Property | ContentType | (Inherited from Gizmox.WebGUI.Common.Gateways.GatewayWriter)
Protected Property | GatewayComponent | (Inherited from Gizmox.WebGUI.Common.Gateways.GatewayWriter)
Top

See Also

Reference

XamlBox.XamlGateway Class
Gizmox.WebGUI.Forms Namespace


XamlBox Class Events

[image]
Gizmox.WebGUI.Forms
XamlBox Class Events
See Also Send Feedback
Gizmox.WebGUI.Forms Namespace : XamlBox Class

For a list of all members of this type, see XamlBox members.

Public Events

 | Name | Description
Public Event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control)
Public Event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control)
Public Event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control)
Public Event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control)
Public Event | Click | Occurs on clicking the button. (Inherited from Control)
Public Event | ControlAdded | Occurs when a new control is added to the ControlCollection. (Inherited from Control)
Public Event | ControlRemoved | Occurs when a control is removed from the ControlCollection. (Inherited from Control)
Public Event | CursorChanged | Occurs when the value of the Control.Cursor property changes. (Inherited from Control)
Public Event | Disposed | (Inherited from ComponentBase)
Public Event | DoubleClick | Occurs when the control is double clicked. (Inherited from Control)
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Component)
Public Event | Enter | Occurs when the control is entered. Not implemented by design. (Inherited from Control)
Public Event | FontChanged | Occurs when the FontChanged property changes. (Inherited from Control)
Public Event | ForeColorChanged | Occurs when the ForeColorChanged property changes. (Inherited from Control)
Public Event | GotFocus | Occurs when the control recives focus. (Inherited from Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control)
Public Event | KeyDown | Occurs on key down. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | KeyPress | Occurs on key press. (Inherited from Control)
Public Event | KeyUp | Occurs on key up. Implemented by design as KeyPress (Use KeyPress instead). (Inherited from Control)
Public Event | Leave | Occurs when the input focus leaves the control. Not implemented by design. (Inherited from Control)
Public Event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from Control)
Public Event | MenuClick | Invokes when a menu item was clicked (Inherited from Component)
Public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. Implemented by design as Click (Use Click instead). (Inherited from Control)
Public Event | PaddingChanged | Occurs when the PaddingChanged property changes. (Inherited from Control)
Public Event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from Control)
Public Event | TextChanged | Occurs when the Text property value changes. (Inherited from Control)
Public Event | TextChangedQueued | Occurs when the Text property value changes (Queued). (Inherited from Control)
Public Event | VisibleChanged | Occurs when the Control.Visible property value changes. (Inherited from Control)
Top

See Also

Reference

XamlBox Class
Gizmox.WebGUI.Forms Namespace


Gizmox.WebGUI.Forms Namespace (Gizmox.WebGUI.Forms) Inheritance Hierarchy

Gizmox.WebGUI.Forms Namespace (Gizmox.WebGUI.Forms) Inheritance Hierarchy
See Also Send Feedback

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Common.Gateways.GatewayHandler
Gizmox.WebGUI.Common.Gateways.GatewayWriter
Gizmox.WebGUI.Forms.HtmlBox.HtmlGateway
Gizmox.WebGUI.Forms.XamlBox.XamlGateway
Gizmox.WebGUI.Forms.BaseCollection
Gizmox.WebGUI.Forms.BindingsCollection
Gizmox.WebGUI.Forms.ControlBindingsCollection
Gizmox.WebGUI.Forms.DataGridViewCellCollection
Gizmox.WebGUI.Forms.DataGridViewColumnCollection
Gizmox.WebGUI.Forms.DataGridViewSelectedCellCollection
Gizmox.WebGUI.Forms.DataGridViewSelectedColumnCollection
Gizmox.WebGUI.Forms.DataGridViewSelectedRowCollection
Gizmox.WebGUI.Forms.TreeNodeCollection
Gizmox.WebGUI.Forms.Binding
Gizmox.WebGUI.Forms.BindingContext
Gizmox.WebGUI.Forms.BindingManagerBase
Gizmox.WebGUI.Forms.CurrencyManager
Gizmox.WebGUI.Forms.PropertyManager
Gizmox.WebGUI.Forms.CheckedListBox.CheckedIndexCollection
Gizmox.WebGUI.Forms.CheckedListBox.CheckedItemCollection
Gizmox.WebGUI.Forms.Clipboard
Gizmox.WebGUI.Forms.ColumnHeaderGroupingData
Gizmox.WebGUI.Forms.ColumnHeaderSortingData
Gizmox.WebGUI.Forms.ComboBox.ObjectCollection
Gizmox.WebGUI.Forms.ColorComboBox.ObjectCollection
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.BindingSource
Gizmox.WebGUI.Forms.CommonDialog
Gizmox.WebGUI.Forms.ColorDialog
Gizmox.WebGUI.Forms.FileDialog
Gizmox.WebGUI.Forms.OpenFileDialog
Gizmox.WebGUI.Forms.FolderBrowserDialog
Gizmox.WebGUI.Forms.FontDialog
Gizmox.WebGUI.Forms.ErrorProvider
Gizmox.WebGUI.Forms.HelpProvider
Gizmox.WebGUI.Forms.ImageList
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.ColumnHeader
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.Button
Gizmox.WebGUI.Forms.CheckBox
Gizmox.WebGUI.Forms.DataGridView
Gizmox.WebGUI.Forms.DateTimePicker
Gizmox.WebGUI.Forms.FrameControl
Gizmox.WebGUI.Forms.HtmlBox
Gizmox.WebGUI.Forms.GroupBox
Gizmox.WebGUI.Forms.Label
Gizmox.WebGUI.Forms.LinkLabel
Gizmox.WebGUI.Forms.ListControl
Gizmox.WebGUI.Forms.ComboBox
Gizmox.WebGUI.Forms.ColorComboBox
Gizmox.WebGUI.Forms.ListBox
Gizmox.WebGUI.Forms.CheckedListBox
Gizmox.WebGUI.Forms.ColorListBox
Gizmox.WebGUI.Forms.ListView
Gizmox.WebGUI.Forms.MainMenu
Gizmox.WebGUI.Forms.MdiClient
Gizmox.WebGUI.Forms.MonthCalendar
Gizmox.WebGUI.Forms.PagingStrip
Gizmox.WebGUI.Forms.PictureBox
Gizmox.WebGUI.Forms.ProgressBar
Gizmox.WebGUI.Forms.RadioButton
Gizmox.WebGUI.Forms.ScrollableControl
Gizmox.WebGUI.Forms.ContainerControl
Gizmox.WebGUI.Forms.Form
Gizmox.WebGUI.Forms.MessageBoxWindow
Gizmox.WebGUI.Forms.PropertyGrid
Gizmox.WebGUI.Forms.SplitContainer
Gizmox.WebGUI.Forms.UpDownBase
Gizmox.WebGUI.Forms.DomainUpDown
Gizmox.WebGUI.Forms.NumericUpDown
Gizmox.WebGUI.Forms.UserControl
Gizmox.WebGUI.Forms.Panel
Gizmox.WebGUI.Forms.FlowLayoutPanel
Gizmox.WebGUI.Forms.SplitterPanel
Gizmox.WebGUI.Forms.TabPage
Gizmox.WebGUI.Forms.Splitter
Gizmox.WebGUI.Forms.StatusBar
Gizmox.WebGUI.Forms.TabControl
Gizmox.WebGUI.Forms.TableLayoutPanel
Gizmox.WebGUI.Forms.TextBoxBase
Gizmox.WebGUI.Forms.RichTextBox
Gizmox.WebGUI.Forms.TextBox
Gizmox.WebGUI.Forms.DataGridViewTextBoxEditingControl
Gizmox.WebGUI.Forms.MaskedTextBox
Gizmox.WebGUI.Forms.ToolBar
Gizmox.WebGUI.Forms.BindingNavigator
Gizmox.WebGUI.Forms.TrackBar
Gizmox.WebGUI.Forms.TreeView
Gizmox.WebGUI.Forms.XamlBox
Gizmox.WebGUI.Forms.DragMappings
Gizmox.WebGUI.Forms.ListViewItem
Gizmox.WebGUI.Forms.Menu
Gizmox.WebGUI.Forms.ContextMenu
Gizmox.WebGUI.Forms.MenuItem
Gizmox.WebGUI.Forms.MenuCollection
Gizmox.WebGUI.Forms.ShortcutsContainer
Gizmox.WebGUI.Forms.StatusBarPanel
Gizmox.WebGUI.Forms.ToolBarButton
Gizmox.WebGUI.Forms.TreeNode
Gizmox.WebGUI.Forms.Timer
Gizmox.WebGUI.Forms.ToolTip
Gizmox.WebGUI.Forms.Cursor
Gizmox.WebGUI.Forms.Cursors
Gizmox.WebGUI.Forms.DataFormats
Gizmox.WebGUI.Forms.DataFormats.Format
Gizmox.WebGUI.Forms.DataGridView.DisplayedBandsData
Gizmox.WebGUI.Forms.DataGridViewAdvancedBorderStyle
Gizmox.WebGUI.Forms.DataGridViewCellStyle
Gizmox.WebGUI.Forms.DataGridViewComboBoxCell.ObjectCollection
Gizmox.WebGUI.Forms.DataGridViewElement
Gizmox.WebGUI.Forms.DataGridViewBand
Gizmox.WebGUI.Forms.DataGridViewColumn
Gizmox.WebGUI.Forms.DataGridViewButtonColumn
Gizmox.WebGUI.Forms.DataGridViewCheckBoxColumn
Gizmox.WebGUI.Forms.DataGridViewComboBoxColumn
Gizmox.WebGUI.Forms.DataGridViewImageColumn
Gizmox.WebGUI.Forms.DataGridViewLinkColumn
Gizmox.WebGUI.Forms.DataGridViewTextBoxColumn
Gizmox.WebGUI.Forms.DataGridViewRow
Gizmox.WebGUI.Forms.DataGridViewCell
Gizmox.WebGUI.Forms.DataGridViewButtonCell
Gizmox.WebGUI.Forms.DataGridViewCheckBoxCell
Gizmox.WebGUI.Forms.DataGridViewComboBoxCell
Gizmox.WebGUI.Forms.DataGridViewHeaderCell
Gizmox.WebGUI.Forms.DataGridViewColumnHeaderCell
Gizmox.WebGUI.Forms.DataGridViewTopLeftHeaderCell
Gizmox.WebGUI.Forms.DataGridViewRowHeaderCell
Gizmox.WebGUI.Forms.DataGridViewImageCell
Gizmox.WebGUI.Forms.DataGridViewLinkCell
Gizmox.WebGUI.Forms.DataGridViewTextBoxCell
Gizmox.WebGUI.Forms.DataGridViewRowCollection
Gizmox.WebGUI.Forms.DataObject
Gizmox.WebGUI.Forms.DragMapping
Gizmox.WebGUI.Forms.FormReference
Gizmox.WebGUI.Forms.GridItem
Gizmox.WebGUI.Forms.GridItemCollection
Gizmox.WebGUI.Forms.Help
Gizmox.WebGUI.Forms.ImageList.ImageCollection
Gizmox.WebGUI.Forms.Layout.ArrangedElementCollection
Gizmox.WebGUI.Forms.Control.ControlCollection
Gizmox.WebGUI.Forms.ControlCollection
Gizmox.WebGUI.Forms.MdiClient.ControlCollection
Gizmox.WebGUI.Forms.TableLayoutControlCollection
Gizmox.WebGUI.Forms.LayoutEngine
Gizmox.WebGUI.Forms.LayoutSettings
Gizmox.WebGUI.Forms.TableLayoutSettings
Gizmox.WebGUI.Forms.Link
Gizmox.WebGUI.Forms.LinkLabel.Link
Gizmox.WebGUI.Forms.LinkParameters
Gizmox.WebGUI.Forms.LinkParameters.LinkArguments
Gizmox.WebGUI.Forms.ListBindingHelper
Gizmox.WebGUI.Forms.ListBox.ObjectCollection
Gizmox.WebGUI.Forms.CheckedListBox.ObjectCollection
Gizmox.WebGUI.Forms.ColorListBox.ObjectCollection
Gizmox.WebGUI.Forms.ListBox.SelectedObjectCollection
Gizmox.WebGUI.Forms.ListView.ColumnHeaderCollection
Gizmox.WebGUI.Forms.ListView.ListViewItemCollection
Gizmox.WebGUI.Forms.ListView.SelectedListViewItemCollection
Gizmox.WebGUI.Forms.ListViewItem.ListViewSubItem
Gizmox.WebGUI.Forms.ListViewItem.ListViewSubItemCollection
Gizmox.WebGUI.Forms.ListViewItemSorter
Gizmox.WebGUI.Forms.MenuItemCollection
Gizmox.WebGUI.Forms.MessageBox
Gizmox.WebGUI.Forms.ProfessionalColors
Gizmox.WebGUI.Forms.ProfessionalColorTable
Gizmox.WebGUI.Forms.PropertyGrid.PropertyTabCollection
Gizmox.WebGUI.Forms.PropertyStore
Gizmox.WebGUI.Forms.Screen
Gizmox.WebGUI.Forms.ScrollableControl.DockPaddingEdges
Gizmox.WebGUI.Forms.StatusBar.StatusBarPanelCollection
Gizmox.WebGUI.Forms.TableLayoutStyle
Gizmox.WebGUI.Forms.ColumnStyle
Gizmox.WebGUI.Forms.RowStyle
Gizmox.WebGUI.Forms.TableLayoutStyleCollection
Gizmox.WebGUI.Forms.TableLayoutColumnStyleCollection
Gizmox.WebGUI.Forms.TableLayoutRowStyleCollection
Gizmox.WebGUI.Forms.TabPageCollection
Gizmox.WebGUI.Forms.TabPageCollection.TabIndexComparer
Gizmox.WebGUI.Forms.TextBoxValidation
Gizmox.WebGUI.Forms.ToolBarItemCollection
Gizmox.WebGUI.Forms.WGSite
System.Attribute
Gizmox.WebGUI.Forms.DataGridViewColumnDesignTimeVisibleAttribute
Gizmox.WebGUI.Forms.RelatedImageListAttribute
System.Collections.ArrayList
Gizmox.WebGUI.Forms.DomainUpDown.DomainUpDownItemCollection
System.Collections.CollectionBase
Gizmox.WebGUI.Forms.ToolBarCollection
System.ComponentModel.TypeConverter
Gizmox.WebGUI.Forms.CursorConverter
Gizmox.WebGUI.Forms.DataGridViewCellStyleConverter
Gizmox.WebGUI.Forms.ListBindingConverter
Gizmox.WebGUI.Forms.ScrollableControl.DockPaddingEdgesConverter
Gizmox.WebGUI.Forms.TableLayoutSettingsTypeConverter
System.ComponentModel.ExpandableObjectConverter
Gizmox.WebGUI.Forms.ListViewItemConverter
System.EventArgs
Gizmox.WebGUI.Forms.BindingManagerDataErrorEventArgs
Gizmox.WebGUI.Forms.ColumnClickEventArgs
Gizmox.WebGUI.Forms.ControlEventArgs
Gizmox.WebGUI.Forms.ConvertEventArgs
Gizmox.WebGUI.Forms.DataGridViewCellFormattingEventArgs
Gizmox.WebGUI.Forms.DataGridViewCellParsingEventArgs
Gizmox.WebGUI.Forms.ListControlConvertEventArgs
Gizmox.WebGUI.Forms.DataGridViewAutoSizeColumnModeEventArgs
Gizmox.WebGUI.Forms.DataGridViewAutoSizeColumnsModeEventArgs
Gizmox.WebGUI.Forms.DataGridViewAutoSizeModeEventArgs
Gizmox.WebGUI.Forms.DataGridViewBindingCompleteEventArgs
Gizmox.WebGUI.Forms.DataGridViewCellEventArgs
Gizmox.WebGUI.Forms.DataGridViewCellErrorTextNeededEventArgs
Gizmox.WebGUI.Forms.DataGridViewCellToolTipTextNeededEventArgs
Gizmox.WebGUI.Forms.DataGridViewCellStateChangedEventArgs
Gizmox.WebGUI.Forms.DataGridViewCellStyleContentChangedEventArgs
Gizmox.WebGUI.Forms.DataGridViewCellValueEventArgs
Gizmox.WebGUI.Forms.DataGridViewColumnEventArgs
Gizmox.WebGUI.Forms.DataGridViewColumnStateChangedEventArgs
Gizmox.WebGUI.Forms.DataGridViewEditingControlShowingEventArgs
Gizmox.WebGUI.Forms.DataGridViewRowContextMenuStripNeededEventArgs
Gizmox.WebGUI.Forms.DataGridViewRowErrorTextNeededEventArgs
Gizmox.WebGUI.Forms.DataGridViewRowEventArgs
Gizmox.WebGUI.Forms.DataGridViewRowHeightInfoNeededEventArgs
Gizmox.WebGUI.Forms.DataGridViewRowsAddedEventArgs
Gizmox.WebGUI.Forms.DataGridViewRowsRemovedEventArgs
Gizmox.WebGUI.Forms.DataGridViewRowStateChangedEventArgs
Gizmox.WebGUI.Forms.DragEventArgs
Gizmox.WebGUI.Forms.DragDropEventArgs
Gizmox.WebGUI.Forms.HelpEventArgs
Gizmox.WebGUI.Forms.ItemChangedEventArgs
Gizmox.WebGUI.Forms.ItemCheckEventArgs
Gizmox.WebGUI.Forms.KeyEventArgs
Gizmox.WebGUI.Forms.KeyPressEventArgs
Gizmox.WebGUI.Forms.LayoutEventArgs
Gizmox.WebGUI.Forms.LinkLabelLinkClickedEventArgs
Gizmox.WebGUI.Forms.ListViewItemEventArgs
Gizmox.WebGUI.Forms.MenuItemEventArgs
Gizmox.WebGUI.Forms.MonthCalendarEventArgs
Gizmox.WebGUI.Forms.MouseEventArgs
Gizmox.WebGUI.Forms.DataGridViewCellMouseEventArgs
Gizmox.WebGUI.Forms.HandledMouseEventArgs
Gizmox.WebGUI.Forms.DataGridViewColumnDividerDoubleClickEventArgs
Gizmox.WebGUI.Forms.DataGridViewRowDividerDoubleClickEventArgs
Gizmox.WebGUI.Forms.TreeNodeMouseClickEventArgs
Gizmox.WebGUI.Forms.NodeLabelEditEventArgs
Gizmox.WebGUI.Forms.PaintEventArgs
Gizmox.WebGUI.Forms.TableLayoutCellPaintEventArgs
Gizmox.WebGUI.Forms.PropertyTabChangedEventArgs
Gizmox.WebGUI.Forms.PropertyValueChangedEventArgs
Gizmox.WebGUI.Forms.QuestionEventArgs
Gizmox.WebGUI.Forms.SelectedGridItemChangedEventArgs
Gizmox.WebGUI.Forms.SplitterEventArgs
Gizmox.WebGUI.Forms.TabPageEventArgs
Gizmox.WebGUI.Forms.TextBoxChangedEventArgs
Gizmox.WebGUI.Forms.ToolBarButtonClickEventArgs
Gizmox.WebGUI.Forms.ToolBarItemEventArgs
Gizmox.WebGUI.Forms.TreeViewEventArgs
System.ComponentModel.CancelEventArgs
Gizmox.WebGUI.Forms.BindingCompleteEventArgs
Gizmox.WebGUI.Forms.DataGridViewCellCancelEventArgs
Gizmox.WebGUI.Forms.DataGridViewDataErrorEventArgs
Gizmox.WebGUI.Forms.DataGridViewCellValidatingEventArgs
Gizmox.WebGUI.Forms.DataGridViewRowCancelEventArgs
Gizmox.WebGUI.Forms.SplitterCancelEventArgs
Gizmox.WebGUI.Forms.TabControlCancelEventArgs
Gizmox.WebGUI.Forms.TreeViewCancelEventArgs
System.ComponentModel.HandledEventArgs
Gizmox.WebGUI.Forms.DataGridViewRowHeightInfoPushedEventArgs
Gizmox.WebGUI.Forms.DataGridViewSortCompareEventArgs

See Also

Reference

Gizmox.WebGUI.Forms Assembly


Getting Started - Gizmox.WebGUI.Reporting

Gizmox.WebGUI.Reporting
Getting Started
Send Feedback


Introduction - Gizmox.WebGUI.Reporting

Gizmox.WebGUI.Reporting
Introduction
Send Feedback


Gizmox.WebGUI.Reporting Namespace Inheritance Hierarchy

Gizmox.WebGUI.Reporting
Gizmox.WebGUI.Reporting Namespace Inheritance Hierarchy
See Also Send Feedback

Inheritance Hierarchy

System.Object
Gizmox.WebGUI.Forms.ComponentBase
Gizmox.WebGUI.Forms.RegisteredComponent
Gizmox.WebGUI.Forms.Component
Gizmox.WebGUI.Forms.Control
Gizmox.WebGUI.Forms.FrameControl
Gizmox.WebGUI.Forms.Hosts.AspControlBoxBase
Gizmox.WebGUI.Reporting.ReportViewer

See Also

Reference

Gizmox.WebGUI.Reporting Assembly


Glossary

Visual WebGui Documentation
Glossary
Send Feedback

Glossary Item Box

A | B | C | D | E | F | G | H | I | J | K | L | M | N | O | P | Q | R | S | T | U | V | W | X | Y | Z


How To Create Your Own Visual Webgui Silverlight Theme

Visual WebGui Documentation
How To Create Your Own Visual Webgui Silverlight Theme
Send Feedback

Glossary Item Box

In this “How to” we are going to learn how to create your own Visual WebGui Silverlight theme using our default theme.

You should be familiar by now with What is Visual WebGui and What is Visual WebGui over Silverlight. It is recommended that you read “How to create a Visual WebGui Silverlight application”.

Visual WebGui (VWG) SDK supplies you with a default theme to your application. This theme holds the default display specification to all the VWG controls.
The VWG silverlight installation adds a new project type “Visual WebGUI Silverlight Theme”. This project allows you to take the default theme and design it according to your needs.

Lets open one of the previous application that we created in one of our previous “How to”. I’ve opened “How to embed HTML inside a Visual WebGui Silverlight application”.

Now, add a new project to our solution. Select a project type Visual WebGui Silverlight theme

Our new theme project should look like this. The Generic.xaml file holds the the XMAL styles of all the VWG Silverlight controls.

Let’s look at one of them. This is the Window Background Style. This style defines the style of a window in a Silverlight application.

XAML Copy Code

<!-- Default style for WindowBackgroundStyle -->

<Style x:Name="WindowBackgroundStyle" TargetType="Control">

<Setter Property="Template">

<Setter.Value>

<ControlTemplate TargetType="ContentControl">

<Grid>

<Rectangle>

<Rectangle.Fill>

<LinearGradientBrush StartPoint="0,0" EndPoint="0.2,1">

<GradientStop Color="#FFBFDBFF" Offset="0"/>

<GradientStop Color="#FF6591CD" Offset="0.8"/>

</LinearGradientBrush>

</Rectangle.Fill>

</Rectangle>

</Grid>

</ControlTemplate>

</Setter.Value>

</Setter>

</Style>

This How it looks like.

Now, let’s change the gradient color of the rectangle to a different color.

XAML Copy Code
<!-- Default style for WindowBackgroundStyle -->

<Style x:Name="WindowBackgroundStyle" TargetType="Control">

<Setter Property="Template">

<Setter.Value>

<ControlTemplate TargetType="ContentControl">

<Grid>

<Rectangle>

<Rectangle.Fill>

<LinearGradientBrush StartPoint="0,0" EndPoint="0.2,1">

<GradientStop Color="Yellow" Offset="0"/>

<GradientStop Color="Orange" Offset="0.8"/>

</LinearGradientBrush>

</Rectangle.Fill>

</Rectangle>

</Grid>

</ControlTemplate>

</Setter.Value>

</Setter>

</Style>

Next we will set the build order of our application. Right click on the solution and select properties. Open project dependencies and set HtmlBox to depend on MyTheme project.

Now, let’s build our application. After the build has completed open the project property page and go to the registration section. Lets add our theme

Set the our theme as the selected theme by checking the box next to it.

Let’s rerun the application it will look like this

This will be our default window theme in our application, You can reuse this theme project in any VWG application by just adding a reference to the Dll in the package manager and setting the theme to the default theme.

Next we will edit another style but use Expression blend this time.

So let’s open the Expression blend and create a new Silverlight2 project.

Add a user control to the project.

Add a button to the user control.

Right click on the button and select “Edit Control Parts(Templates)” –> “Edit a Copy”

Click ok to create the ButtonStyle resource.

Let’s get back to our VWG theme project and locate the “ButtonStyle” style and copy it.
Now, go back to the Expression blend and replace the button style with our style.

Click on the button and select “Edit control Parts(Template) “ –> “Edit Template” option.

Select the “MouseOver” event

Open the Timeline panel and set the time to 0.25 sec.

Now, we’ll rotate the button to the point that it is 90 degrees.

On the 0.5 sec rotate anther 90 degrees

And once again at 0.75 sec

Last time make it complete a 360 degrees turn.

Now, open the XAML and copy the button style back to the generic.xaml in our theme project.

On the “MouseOver” event of the “ButtonStyle” set the “RepeatBehavior” property to forever so our new affect will last forever as long as the mouse is over the button.

XAML Copy Code

<vsm:VisualState x:Name="MouseOver">

<Storyboard RepeatBehavior="forever">

Let’s add a button to the form.

And run the application.

To summarize:
We have seen how to use Visual WebGui Silverlight theme project to customizes and to design your application. We used Expression blend to edit the default xamel and created an animation to the button “MouseOver” event.


How To Embed Html Inside A Visual Webgui Silverlight Application

Visual WebGui Documentation
How To Embed Html Inside A Visual Webgui Silverlight Application
Send Feedback

Glossary Item Box

In this “How to” we are going to see how we embed an HTML page inside a Visual WebGui Silverlight Application.

You should be familiar by now with What is Visual WebGui and What is Visual WebGui over Silverlight. It is recommended that you read “How to create a Visual WebGui Silverlight application”.

The current Silverlight beta 2 version does not provide any methodology of combining HTML/DHTML elements and pages within Silverlight. There is always the option of floating an HTML above Silverlight or showing what’s “behind” Silverlight by specifying 0 opacity areas, however, dealing with multiple layers combining HTML/DHTML and Silverlight is a very difficult challenge .

Visual WebGui provides an internal capability of calculating the overlapping areas providing the best way currently possible with Silverlight 2 beta 2 of handling multiple HTML/DHTML and Silverlight layered application (using mixed surfaces, dialogs and popups) seamlessly.

To solve the problem we created a control called “HtmlBox”. To use this control we’ll first create a new VWG application.

First thing you need to do is to enable Visual WebGui this action allows you to use the VWG Visual Studio integration that will allow you to run your VWG application as a silverlight application. To do so right click on the project and select the "Enable Visual WebGui". You will be prompt to reload the project and save the WebConfig.

To allow this application to run as Silverlight application you have to open the property page of the project and in the Deployment section enable Silverlight. This action will add the necessary definition to the web config. You will have to add the the reference to the Silverlight Server assembly.

Next we’ll build the application to allow the VWG Silverlight packaging tool to build the application Silverlight packages.

Now we can run our Visual WebGui application but first let set the application entry point. Right click on form on and select "Set as start form" option.

Open Form1, add an “HtmlBox” control and dock the control to fill the form.

Now, we’ll add some HTML code to our application to display on our form. Let’s add a new Html page to the project with this Html:

HTML Copy Code

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

<html xmlns="http://www.w3.org/1999/xhtml" >

<head>

<title>Untitled Page</title>

</head>

<body>

<h2>Check list to this how to</h2>

<table style="width:100%;">

<tr>

<td>Check list</td>

<td>&nbsp;</td>

</tr>

<tr>

<td>Silverlight application</td>

<td>Yes</td>

</tr>

<tr>

<td>HtmlBox control</td>

<td>Yes</td>

</tr>

<tr>

<td>Dislpaly Html in silverlight</td>

<td>Yes</td>

</tr>

<tr>

<td>Set a url to the HtmlBox control</td>

<td>No</td>

</tr>

<tr>

<td>Display a html page from another site in a VWG Silverlight application</td>

<td>No</td>

</tr>

</table>

</body>

</html>

In the properties window set the “Copy to Output Directory” property to “Copy if newer” so it will be copied to the application bin folder.

Next on the “Onload” event of the form, read the html file to a StreamReader.
And afterward set the content of the file to the Html property in the “HtmlBox” control.

C# Copy Code

StreamReader stream = new StreamReader(Context.Server.MapPath("\\") + "\\HTMLPage1.htm");

htmlBox1.Html = stream.ReadToEnd();

stream.Close();

Now run the application this is the result you will see.

Next we display the HTML from another site and not the HMTL itself. For this I’ve created a web site on my computer.

Take the link to this page and set the URL property in the “HtmlBox” control to it

C# Copy Code
htmlBox1.Url = http://localhost:2889/HTMLPage1.htm;

Let’s run the application again.

This is the “HtmlBox” displaying an Html page using URL.

As you can see every issue in our check list for this “How to” is done.

To summarize:.
We’ve seen how to use Visual WebGui “HtmlBox” to display Html inside a Visual WebGui application
using two techniques:
1. Html code.
2. URL to an Html page.


How to use Visual WebGui sources

Visual WebGui Documentation
How to use Visual WebGui sources
Send Feedback

Glossary Item Box

In this tutorial we will learn how to use Visual WebGui source code instead of the pre-compiled DLLs to developed and to extend Visual WebGui applications and abilities.
Working with the source code instead of working with the pre-compiled DLLs enables you to change VWG code to fit your needs.

First lets see how do we get the source code. There are two ways to get VWG source code.
The first is to download the code from Visual WebGui's site here is the link for the latest version. You can download and install the required VWG by selecting the type of installation that fits you. Make sure that you select a download that has sources like "VWG SDK for .NET 2.0 w/ Sources".
The second way to get VWG source code is to download it from our SVN. you can read how to download the code form the SVN in this tutorial on how to submit VWG code patch.

Once you have the source code lets open the installation / SVN download folder and see the result (there might be a slight difference between the amount of projects that were downloaded between the installation and the SVN ).

Let's open "Core" solution and build the application and create the DLL's needed to create a VWG application. Once the build process is over (and succeeded) Open the bin folder of the Gizmox.WebGUI.Forms.References project. In the bin folder of this project you will find all the DLL's that you need to create a VWG application.

Lets create a new Visual WebGui application

If you haven't installed the VWG project templates take a look at this tutorial on how to create a Visual WebGui project from an ASP.Net project this should bring you to the same point.

In a usual VWG installation this templates works just like that and you can open the designer and start working. But because this is Source installation we need to add a few DLL's before we open the designer.

Right click on the project and select add reference and add this assembles "Gizmox.WebGUI.Client", "Gizmox.WebGUI.Common.Design", "Gizmox.WebGUI.Forms.Design".

Now you are ready to work with Visual WebGui sources. Every update that you will do in the core solution will be available in the VWG project that you created.
Make sure that you close your project solution before working on the core to avoid designer problems from updating the Designer DLLs.

After you make changes in the core solution and building it reopen your project solution and update the private version of the project to update cached resources like js files and images. You can do this by opening the property page of the project and change the private version number in the general tab.

Or by changing it manually in the web config file

XML Copy Code

    <PrivateVersion Value="121" />


Icon Pre loading

Visual WebGui Documentation
Icon Pre loading
Send Feedback

Glossary Item Box

Visual WebGui enables you to define pre loading mode to prevent icons issues mainly for IE innerHTML issue (http://support.microsoft.com/kb/319546).

IE has an issue with caching an image in innerHTML operation which is the cornet stone of any browser based AJAX environment. Activating the icons pre loading mode prevents IE from reloading the icons multiple times. In order to activate pre loading mode you should set the following switch (Icon Pre loading) in the Visual WebGui configuration section to true.

Icon pr loading


Installation process

Visual WebGui Documentation
Installation process
Send Feedback

Glossary Item Box

This installation process installs Visual WebGui (SDK/Studio).

The install process allows you to choose what part of the Visual WebGui installation will be installed.

Typical - When you select typical installation you will install the DHTML SDK and extensions but under the old Visual Studio behavior. This means that you will have templates just like you are used to and will continue to work as before.

Complete - The complete installation installs the new Visual Studio integration with the DHTML and the Silverlight SDK, the extensions + the Scalable server extension (This includes a service that will be installed on your computer.) and the new Visual WebGui documentation.

Custom - Using custom install section you can decide what extension will be installed or select not to install the documentation according to your needs.


Installing Visual WebGui without Visual Studio

Visual WebGui Documentation
Installing Visual WebGui without Visual Studio
Send Feedback

Glossary Item Box

If you want to use Visual WebGui on a computer that Visual Studio is not installed on you can install the Visual WebGui SDK and develop a Visual WebGui application using Visual Studio express or SharpDevelop.

You can do this by using the custom install option this will install the Visual WebGui DLL needed to develop a VWG application. You will have to manually add references to this DLLs.

A more detailed issue will be added in the near future and will show how to develop a full application without Visual Studio.


How to create a Silverlight Visual WebGui Application

Visual WebGui Documentation
How to create a Silverlight Visual WebGui Application
Send Feedback

Glossary Item Box

In this “How to” we are going to learn how to create a Visual WebGui Silverlight Application.

This topic assumes that you have some basic knowledge of Visual WebGui and what is Visual WebGui over Silverlight.

After installing Visual WebGui we will open Visual Studio and create a new Visual WebGui application.

First thing you need to do is to enable Visual WebGui this action allows you to use the VWG Visual Studio integration that will allow you to run your VWG application as a silverlight application. To do so right click on the project and select the "Enable Visual WebGui". You will be prompt to reload the project and save the WebConfig.

Enable Visual WebGui

To allow this application to run as Silverlight application you have to open the property page of the project and in the Deployment section enable Silverlight. This action will add the necessary definition to the web config. You will have to add the the reference to the Silverlight Server assembly.

Add referance to the Silverlight server Dll

We’ll open the Main form “Form1.cs” in designer mode.

Now we’ll add a few Visual WebGui controls to display the richness of a Visual WebGui Silverlight application.

First we’ll add a TextBox. As you can see Visual WebGui design time mimics .Net Windows forms design time abilities.

Lets add a few more controls to our application.

Next we’ll build the application to allow the VWG Silverlight packaging tool to build the application Silverlight packages. You can see the packager too in the deployment section by clicking the advanced button and edit the package structure of your application.

Now we can run our Visual WebGui application but first let set the application entry point. Right click on form on and select "Set as start form" option.

Set as start up form

Now we can run our application Visual WebGui Silverlight application in explorer.

And we can also view our application in FireFox

In this “How to” we’ve seen that Visual WebGui framework enables developers to create cross browser Silverlight applications while using visual studio .Net windows forms design time abilities.


How to create a Visual WebGui Silverlight custom control

Visual WebGui Documentation
How to create a Visual WebGui Silverlight custom control
Send Feedback

Glossary Item Box

In this "How to" Visual WebGui tutorial we are going to create WatermarkTextBox control for a Visual WebGui Silverlight application.

This topic assumes that you have some basic knowledge of Visual WebGui and Visual WebGui over Silverlight. Its also recommended that you read the "How to create a Visual WebGui Application".

The WatermarkTextBox is a plain TextBox control, with one added feature of showing a default text when no content was entered or when the content was deleted.

The first thing we'll need to do is open visual studio and create a new Visual WebGui Application.

Add new Visual Webgui application

First thing you need to do is to enable Visual WebGui this action allows you to use the VWG Visual Studio integration that will allow you to run your VWG application as a silverlight application. To do so right click on the project and select the "Enable Visual WebGui". You will be prompt to reload the project and save the WebConfig.

Enable Visual WebGui

To allow this application to run as Silverlight application you have to open the property page of the project and in the Deployment section enable Silverlight. This action will add the necessary definition to the web config. You will have to add the the reference to the Silverlight Server assembly.

Next we'll add a new Visual WebGui Silverlight control Library project to our solution named Watermark.Silverlight.Controls.

Add new Visual WebGui Silverlight control library

Add a new class BindableWatermarkTextBox

We'll make sure that our BindableWatermarkTextBox class inherits from Gizmox.WebGUI.Silverlight.Controls.BindableTextBox.

C# Copy Code

using Gizmox.WebGUI.Silverlight.Controls;

namespace Watermark.Controls

{

public class BindableWatermarkTextBox : BindableTextBox

}

Now we'll add a TextBlock. This TextBlock will show the default text until the user start's entering his own text.

We'll also add a boolean member named _IsFocused that represents the current control status.

C# Copy Code
private TextBlock mobjMask = null;

private bool _IsFocused = false;

Next we'll add a constructor to our class. In the constructor we'll sign-up to 3 events which are exposed by the default Winfroms-like TextBox and used by the BindableWatermarkTextBox .

1. GotFocus event
2. TextChanged event
3. LostFocus event

C# Copy Code

public BindableWatermarkTextBox()

{

this.TextChanged += new TextChangedEventHandler(OnTextChanged);

this.GotFocus += new RoutedEventHandler(OnGotFocus);

this.LostFocus += new RoutedEventHandler(OnLostFocus);

}

To our OnGotFocus and OnLostFocus methods we'll add code to change the _IsFocused boolean field.

C# Copy Code

private void OnLostFocus( object sender, RoutedEventArgs e)

{

_IsFocused = false;

}

private void OnGotFocus( object sender, RoutedEventArgs e)

{

_IsFocused = true;

}

Next we'll create a new method named UpdateMaskthat will update the TextBlock text according to the _IsFocued boolean field.

C# Copy Code

private void UpdateMask()

{

if (mobjMask != null)

{

// If the control is not focused and the text is empty set the

// default text to the TextBlock.

if (this.Text == string.Empty && !_IsFocused)

{

mobjMask.Visibility = Visibility.Visible;

mobjMask.Text = BindingManager.GetAttribute( this, "Message", "Write text here...");

}

// Else hide the TextBlock and show the textbox so the

// User could add his text.

else

{

mobjMask.Visibility = Visibility.Collapsed;

}

}

}

After creating the UpdateText method we'll invoke it in all 3 events handlers that we created.

C# Copy Code

private void OnLostFocus( object sender, RoutedEventArgs e)

{

_IsFocused = false;

UpdateMask();

}

private void OnGotFocus( object sender, RoutedEventArgs e)

{

_IsFocused = true;

UpdateMask();

}

private void OnTextChanged( object sender, TextChangedEventArgs e)

{

UpdateMask();

}

Now we'll add a new Method that will override OnApplyTemplate Method. This will allow us to show the TextBlock with the default text above the TextBox.

C# Copy Code

public override void OnApplyTemplate()

{

// Call the base TextBox OnApplyTemplate Method.

base.OnApplyTemplate();

// Get the TextBlock object

mobjMask = this.GetTemplateChild( "MaskElement") as TextBlock;

if (mobjMask != null)

{

// Set the TextBlock as the text area when visuble.

mobjMask.Opacity = 0.6;

mobjMask.Foreground = new SolidColorBrush( Colors.White);

// Update the TextBlock acording to the _IsFocued boolean field.

UpdateMask();

}

}

At this point we have a Silverlight Visual WebGui control that we can use in our application but to do so we will have to add an implementation to a WatermarkTextBox DHTML so we can use this control in design time.
Pay attention that we are not going to implement the DHTML control completely because we are not going to display the DHTML control at this tutorial, a different tutorial will cover "How to" create a DHTML WatermarkTextBox .

Now we'll add a Visual WebGui Library Control project named "Watermark.Controls".

Add a new Visual WebGui control Library

Next we'll add a Visual WebGui Custom Control named WatermarkTextBox. Right click on the project and select "Add\ New Item".

We'll make sure that our WatermarkTextBox class inherits from Gizmox.WebGUI.Forms.TextBox.

C# Copy Code

public partial class WatermarkTextBox : TextBox

{

public WatermarkTextBox()

{

InitializeComponent();

}

Next we'll add an attribute to the class SilverlightControl to allow the control to register in Manifest file.

C# Copy Code
[SilverlightControl( "Watermark.Controls.Silverlight.BindableWatermarkTextBox, Watermark.Controls.Silverlight, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", "Watermark")]

To add design-time support for this control we'll want the developer to input the WaterMark text.
In order to do that we'll expose a public property named Message that will be our default WaterMark text.

C# Copy Code

private string mstrMessage;

public string Message

{

get

{

return mstrMessage;

}

set

{

if (mstrMessage != value)

{

mstrMessage = value;

this.Update();

}

}

}

In the Constructor we'll set the CustomStyle to "Watermark". This property sets the style that the control by will be used to drawn by.

C# Copy Code

public WatermarkTextBox()

{

this.CustomStyle = "Watermark";

}

Now we'll add to the control an attribute that will hold the Message property this will allow us to access this value in runtime.

C# Copy Code

protected override void RenderAttributes( IContext context, IAttributeWriter writer)

{

base.RenderAttributes(context, writer);

writer.WriteAttributeString( "Message", this.Message);

}

Now we can start using the Watermark control in our application. We'll add a reference to the DHTML control.

We'll open our form in designer mode and add our Watermark control to it.

Next we will register our control. This will alow the VWG server access to the control resources. To do this open the project property page in the "Registration" section

After you abb the control it will appear in the registered control list like this.

Set the size of the control and add your default Watermark text in the Message property.

Now we can run our Visual WebGui application but first let set the application entry point. Right click on form on and select "Set as start form" option.

After We build the application lets see the Xap file that was created by the packager tool. This package holds the client side code that will be download to the client.

Now we'll run the application and here is our Watermark TextBox control.

In this "How to" we've seen how to create our own Visual WebGui Silverlight custom control by inheriting for a Visual WebGui control and adding it a feature. we've also seen how to use this control in a Visual WebGui Silverlight


How to create property binding in a Visual WebGui Silverlight control

Visual WebGui Documentation
How to create property binding in a Visual WebGui Silverlight control
Send Feedback

Glossary Item Box

In this "How to" we are going to learn how to create property binding in a Visual WebGui Silverlight Control.

This topic assumes that you have some basic knowledge of Visual WebGui and what is Visual WebGui over Silverlight. Its also recommended that you read the "How to create a Visual WebGui Custom Control".

The Visual WebGui Silverlight presentation layer is heavily based on WPF concepts which are combined with a powerful server binding mechanism. The server binding mechanism provides a generic mechanism to interact between the server and the client, using the highly optimized communication methods of Visual WebGui.

The binding mechanism provides multiple events and over-ridable methods that make custom development of controls and capabilities real simple. It basically frees you completely of the need to expose services, consume services or manipulate data on the client. It makes it possible to implement the empty client approach that Visual WebGui brings with it and to enjoy the multiple benefits it entails.

In this "How to" we'll create a Visual WebGui Silverlight control. This control will be a simple label that will show how to create binding to the Message property.

First thing we do is Create a new Visual WebGui application that will host our new label control.

First thing you need to do is to enable Visual WebGui this action allows you to use the VWG Visual Studio integration that will allow you to run your VWG application as a silverlight application. To do so right click on the project and select the "Enable Visual WebGui". You will be prompt to reload the project and save the WebConfig.

To allow this application to run as Silverlight application you have to open the property page of the project and in the Deployment section enable Silverlight. This action will add the necessary definition to the web config. You will have to add the the reference to the Silverlight Server assembly.

Next will add a Visual WebGui Control Library named BindingApp.Controls and create a new Custom control named MyLabel.

Our project should look like this at this point

Now will add a property named Message that will show our label message.

C# Copy Code

private string mstrMessage;

public string Message

{

get

{

return mstrMessage;

}

set

{

if (mstrMessage != value)

{

mstrMessage = value;

this.Update();

}

}

}

Next will add to the RenderAttributes method an attribute named Message so we could access the message in the XSLT.

C# Copy Code

protected override void RenderAttributes( IContext context, IAttributeWriter writer)

{

base.RenderAttributes(context, writer);

writer.WriteAttributeString( "Message", this.Message);

}

At this point will stop developing our DHTML control because this is not part of this "How to" and will focus on the Visual WebGui Silverlight control.

So we'll add a new Visual WebGui Silverlight Control Library project to our solution named BindingApp.Controls.Silverlight.

Add a new class named BindableMyLabel.cs.
Next will add the default style to our control in the generic.xaml file. Our control is a very simple one only a TextBox that will bind the message to.

XAML Copy Code

< Style TargetType ="local:BindableMyLabel">

< Setter Property ="Template">

< Setter.Value >

< ControlTemplate TargetType ="local:BindableMyLabel">

< TextBox Foreground ="Black"/>

</ ControlTemplate >

</ Setter.Value >

</ Setter >

</ Style >

In the DHTML control will set our control CustomStyle to BindableMyLabel in the contractor.

C# Copy Code

public MyLabel()

{

this.CustomStyle = "BindableMyLabel";

}

Now we'll make our control inherit from BindableContentControl so We'll have the abilities of a bindable control.

C# Copy Code

public class BindableMyLabel : BindableContentControl

Next will add a System.Windows. DependencyProperty and a static constructor to initialize it. The DependencyProperty in Silverlight allows us to bind a property without implementing event handling to the properties changes and allows us to bind the value to our template.

C# Copy Code

public static readonly DependencyProperty MessageProperty;

static BindableMyLabel()

{

MessageProperty = DependencyProperty.Register( "Message",

typeof( string), typeof( BindableMyLabel), null);

}

We'll add a string property that get's and set's the DependencyProperty

C# Copy Code

public string Message

{

get

{

return (string) this.GetValue(MessageProperty);

}

set

{

this.SetValue(MessageProperty, value);

}

}

Now will add a new class BindableMyLabelDelegate that inherits BindingDelegate. This will allow us to broaden the object state according to the properties that we added

C# Copy Code

public class BindableMyLabelDelegate : BindingDelegate

{

public string Message

{

get

{

return this.GetValue( "Message", "");

}

}

protected override void OnAttributeChange( string strAttribute)

{

base.OnAttributeChange(strAttribute);

if (strAttribute == "Message")

{

OnPropertyChanged( "Message");

}

}

}

Because our control inherits from BindableContentControl we'll override the ApplyBindings method and set our control to the binding delegate we create in the Binding Manager.

C# Copy Code

protected override void ApplyBindings()

{

base.ApplyBindings();

BindingManager.SetDelegate( this, typeof( BindableMyLabelDelegate));

this.SetBinding(MessageProperty, new Binding( "Delegate.Message"));

}

In the Generic.Xmal file will set the TextBox Text to the TempletBinding.

XAML Copy Code
< TextBox Text ="{ TemplateBinding Message }" Foreground ="Black"/>

Next register our control so the Visual WebGui server can access the resources. To do so will open the project Registration section property page

Last but not least will add to the DHTML control a reference to our Silverlight control template to allow the control to register in Manifest file.

C# Copy Code
[ SilverlightControl( "Gizmox.WebGUI.Silverlight.Controls.BindableMyLabel, BindingApp.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", "BindableMyLabel")]

Now we start using our new control. Lets go to our Visual WebGui application and open the main Form in design mode. From The ToolBox Drag a text box and a button to the form. Add our Control to the form. On the onClick event set the message property in our control to the text in the text box.

C# Copy Code

private void button1_Click( object sender, EventArgs e)

{

myLabel1.Message = textBox1.Text;

}

Next we’ll build the application to allow the VWG Silverlight packaging tool to build the application Silverlight packages.

To

Now we can run our Visual WebGui application but first let set the application entry point. Right click on form on and select "Set as start form" option.

And this is our control in action


How to raise event from the client to the server in a Visual WebGui Silverlight control

Visual WebGui Documentation
How to raise event from the client to the server in a Visual WebGui Silverlight control
Send Feedback

Glossary Item Box

In this "How to?" we are going to learn how to raise an event from our Visual WebGui Silverlight control client side and how to handle it in the server side implementation of this control.

This topic assumes that you have some basic knowledge of Visual WebGui and Visual WebGui over Silverlight. Its also recommended that you read the "How to create property binding in a Visual WebGui Silverlight control".

The Visual WebGui programming model is event based. When a control changes state, such as when the user clicks a button, it raises an event. This events can be created and immediately raised or they can be created and queued.

First will open our "BindableMyLabel" custom control that we've created in "How to create property binding in Visual WebGui Silverlight control" in Visual studio.

What we are going to do is to sign up in the constructor to the MouseLeftButtonDown event.

C# Copy Code
this.MouseLeftButtonDown += new MouseButtonEventHandler(BindableMyLabel_MouseLeftButtonDown);

Now will add the BindableMyLabel_MouseLeftButtonDown method

C# Copy Code

void BindableMyLabel_MouseLeftButtonDown( object sender, MouseButtonEventArgs e)

{

}

What we do next is add the code to handle this event

C# Copy Code

void BindableMyLabel_MouseLeftButtonDown( object sender, MouseButtonEventArgs e)

{

//Create a new Click event.

Event objEvent = BindingManager.CreateEvent( this, "MouseDown ");

//Add a property value to use in the server

objEvent.SetProperty( "test", "sss");

//Make sure that this event is critical which means that the

//event was registered and should be raised immediately.

//If the event was not registered the event will be queued and will

//be raised with the next critical event.

if (BindingManager.IsCriticalEvent( this, EventTypes.Click))

{

//Raise the event

BindingManager.RaiseEvents();

}

}

The BindingManager.CreateEvent method have a few overloading. One of them allows you to create the event as unique event so if the user repeats an action a few times but the event was not handheld yet the there wont be a list of events of the same type but just one with the last update of the control state.

Next we override the FireEvent method in the server side of the control and raise our event if the type is MouseDown

C# Copy Code

protected override void FireEvent( IEvent objEvent)

{

base.FireEvent(objEvent);

if (objEvent.Type == " MouseDown ")

{

LabelClick( this, EventArgs.Empty);

}

}

Now will add 2 label to the main form of our application

We'll sign up to the MouseDown event on one of the labels to show that only when we register the event is raised.|

Add a breakpoint to the fire event method to see this works and that we've reached the server from the client.

This event will be fired when the mouse is pressed on the background of the control so I've changed the control design to expose the background like this. When you press the mouse button make sure you press on the background

XAML Copy Code

< Grid Background ="Azure">

< TextBox Height ="20" Text ="{ TemplateBinding Message }"

Foreground ="Red"/>

</ Grid >

The result will look like this.

When you press on the background of the second label you can see that the event is not fired and we don't get to the server. But when the next critical event will be fired this event will reach the server as well.

What we've seen in this "How to" is that when we register to an event in the Silverlight control we don't reach the server but run on the client.
If we want to get to the server we need to raise an event using the BindingManager.RaiseEvents() method that will raise an event to the server and will be handled in the server side of the control (the DHTML class of the control).

We've also seen the event queuing mechanism of VWG that prevents form unnecessary trips to the server.


How to convert a Silverlight control to a Visual WebGui Silverlight control

Visual WebGui Documentation
How to convert a Silverlight control to a Visual WebGui Silverlight control
Send Feedback

Glossary Item Box

In this "How to" we are going to learn how to convert a Silverlight control to a Visual WebGui Control. This will allow you to take your hard earned controls that you created in Silverlight our Silverlight controls that you found while roaming the web and convert them with very little effort to a Visual WebGui

This topic assumes that you have some basic knowledge of Visual WebGui and what is Visual WebGui over Silverlight. Its also recommended that you read the "How to create a Visual WebGui Custom Control" And the "How to create property binding in a Visual WebGui Silverlight control".

The first thing we do is take a Silverlight control in this case I've created a simple Silverlight Media Player control.

This is the Media player control Generic.xaml

XAML Copy Code

< ResourceDictionary

xmlns ="http://schemas.microsoft.com/winfx/2006/xaml/presentation"

xmlns : x ="http://schemas.microsoft.com/winfx/2006/xaml"

xmlns : local ="clr-namespace:GZVideoPlayer.Controls;assembly=GZVideoPlayer.Controls">

< Style TargetType ="local:VideoPlayer">

< Setter Property ="Template">

< Setter.Value >

< ControlTemplate TargetType ="local:VideoPlayer">

< Grid Background ="White" Margin ="10,10,10,10" ShowGridLines ="True">

< Grid.RowDefinitions >

< RowDefinition Height ="*"></ RowDefinition >

< RowDefinition Height ="35"></ RowDefinition >

</ Grid.RowDefinitions >

< MediaElement Stretch ="Fill" x : Name ="MediaElement" Source ="{ TemplateBinding MediaSource }" Margin ="0,0,0,0" Grid.Row ="0"/>

< Grid Grid.Row ="1" Grid.Column ="1" Width ="500" Background ="#FFEFEFE8">

< Grid.ColumnDefinitions >

< ColumnDefinition Width ="55"></ ColumnDefinition >

< ColumnDefinition Width ="445"></ ColumnDefinition >

</ Grid.ColumnDefinitions >

< Button x : Name ="PlayButton" HorizontalAlignment ="Left" Margin ="5,1,0,0" VerticalAlignment ="Stretch" Width ="50" Height ="25" Grid.Column ="0" Grid.Row ="0" Content ="Play"/>

< Button x : Name ="StopButton" HorizontalAlignment ="Left" Margin ="0,1,0,0" VerticalAlignment ="Stretch" Width ="50" Height ="25" Grid.Column ="1" Grid.Row ="0" Content ="Stop"/>

</ Grid >

</ Grid >

</ ControlTemplate >

</ Setter.Value >

</ Setter >

</ Style >

</ ResourceDictionary >

And this is the Media Player control class VideoPlayer.cs

C# Copy Code

public class VideoPlayer : Control

{

public static DependencyProperty MediaSourceProperty;

private Button mobjPlayButton;

private Button mobjStopButton;

private MediaElement mobjMediaElement;

static VideoPlayer()

{

MediaSourceProperty = DependencyProperty.Register( "MediaSource", typeof( Uri), typeof( VideoPlayer), null);

}

public VideoPlayer()

{

this.DefaultStyleKey = typeof( VideoPlayer);

}

public override void OnApplyTemplate()

{

base.OnApplyTemplate();

mobjPlayButton = this.GetTemplateChild( "PlayButton") as Button;

mobjPlayButton.Click += new RoutedEventHandler(mobjPlayButton_Click);

mobjStopButton = this.GetTemplateChild( "StopButton") as Button;

mobjStopButton.Click += new RoutedEventHandler(mobjStopButton_Click);

mobjMediaElement = this.GetTemplateChild( "MediaElement") as MediaElement;

}

void mobjPlayButton_Click( object sender, RoutedEventArgs e)

{

mobjMediaElement.Play();

}

void mobjStopButton_Click( object sender, RoutedEventArgs e)

{

mobjMediaElement.Stop();

}

public Uri MediaSource

{

get

{

return (Uri) this.GetValue(MediaSourceProperty);

}

set

{

this.SetValue(MediaSourceProperty, value);

}

}

}

As you can see this my solution has one Silverlight application and one Silverlight class library that I used to create this Silverlight control.

Now we'll add a Visual WebGui Application that will host our Control.

First thing you need to do is to enable Visual WebGui this action allows you to use the VWG Visual Studio integration that will allow you to run your VWG application as a silverlight application. To do so right click on the project and select the "Enable Visual WebGui". You will be prompt to reload the project and save the WebConfig.

To allow this application to run as Silverlight application you have to open the property page of the project and in the Deployment section enable Silverlight. This action will add the necessary definition to the web config. You will have to add the the reference to the Silverlight Server assembly.

Next we'l add a new Visual WebGui Silverlight Control Library named VideoPlayer.Silverlight.Controls

Delete the empty generic.xml file from the project and select the generic.xaml and the generic.xaml files from the Silverlight project and drag them to the VideoPlayer.Controls project.

Change the VideoControl class to inherit from BindableControl and not from control.

Next will add VideoPlayerDelegate that is in charge of updating our control when attribute value is changed.

C# Copy Code

public class VideoPlayerDelegate : BindingDelegate

{

public Uri MediaSource

{

get

{

return Session.GetResourceUri( this.GetValue( "MediaSource", ""), false);

}

}

protected override void OnAttributeChange( string strAttribute)

{

base.OnAttributeChange(strAttribute);

if (strAttribute == "MediaSource")

{

OnPropertyChanged( "MediaSource");

}

}

}

We'll override the ApplyBindings method to set the VideoPlayerDelegate.

C# Copy Code

protected override void ApplyBindings()

{

base.ApplyBindings();

BindingManager.SetDelegate( this, typeof( VideoPlayerDelegate));

this.SetBinding(MediaSourceProperty, new Binding( "Delegate.MediaSource"));

}

Now we'll add a new Visual WebGui class library project to create the DHTML control.

And create a new Visual WebGui Control Named VideoPlayer.Cs

In the DHTML control add this attribute so our control will be added to the manifest with the right template.

C# Copy Code

[SilverlightControl( "VideoPlayer.Silverlight.Controls.VideoPlayer, VideoPlayer.Silverlight.Controls, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null")]

public partial class VideoPlayer : Control

Add a ResourceHandle property named MediaSource.

private ResourceHandle _MediaSource;

public ResourceHandle MediaSource

{

get

{

return _MediaSource;

}

set

{

if (_MediaSource != value)

{

_MediaSource = value;

this.Update();

}

}

}

And add the property as an attribute so will have access to in the client.

C# Copy Code

protected override void RenderAttributes( IContext context, IAttributeWriter writer)

{

base.RenderAttributes(context, writer);

if ( this.MediaSource != null)

{

writer.WriteAttributeString( "MediaSource", this.MediaSource.ToString());

}

}

Now will open the application main form and add the Video player control to our designer.

Add a folder named Resources and a sub folder named Data and in it place the video file you want to play.

Next we'll set on the form load the video Uri that we want to play.

C# Copy Code

private void Form1_Load( object sender, EventArgs e)

{

videoPlayer1.MediaSource = new UrlResourceHandle( "Resources/Data/lake.wmv");

}

Next register our control so the Visual WebGui server can access the resources. To do so will open the project Registration section property page

Next we’ll build the application to allow the VWG Silverlight packaging tool to build the application Silverlight packages.

To do Image show client bin and packages

Now we can run our Visual WebGui application but first let set the application entry point. Right click on form on and select "Set as start form" option.

And now we can watch our movie played in our Silverlight application

So in this "How to" we've seen how easy it is to take a Silverlight control and convert it in just a few steps to a Visual WebGui Control.


How to create a Visual WebGui Silverlight control with elements

Visual WebGui Documentation
How to create a Visual WebGui Silverlight control with elements
Send Feedback

Glossary Item Box

In this "How to" we are going to learn how to create a Visual WebGui Silverlight control with elements. for this we will broaden our Video player control to have a movie menu.

This topic assumes that you have some basic knowledge of Visual WebGui and Visual WebGui over Silverlight. Its also recommended that you read the "How to convert a Silverlight control to a Visual WebGui Silverlight control".

First will open our Video player Solution in Visual studio that we created in "How to convert a Silverlight control to a Visual WebGui Silverlight control".

We'll add a new class named Movie to our VideoPlayer.Controls project.

In the movie class we'll add 2 properties a ResourceHandle MediaSource and string Title.

C# Copy Code

private ResourceHandle _MediaSource;

public ResourceHandle MediaSource

{

get

{

return _MediaSource;

}

set

{

if (_MediaSource != value)

{

_MediaSource = value;

}

}

}

private string _Title;

public string Title

{

get { return _Title; }

set

{

if (_Title != value)

{

_Title = value;

}

}

}

Next we'll add a movie collection class named MovieCollection.

C# Copy Code

public class MovieCollection : Collection< Movie>

{

internal MovieCollection()

{

}

}

Now we'll add to the VideoPlayer.cs a Property of MovieCollection named Movies and initialize it in the constructor.

C# Copy Code

private MovieCollection _Movies;

public MovieCollection Movies

{

get

{

return _Movies;

}

}

public VideoPlayer()

{

InitializeComponent();

_Movies = new MovieCollection();

}

At this point we have in the server side of our control a collection of movie type objects that we need to add as elements to the XML file that will sent to browser. to do this will Override the RenderControls method.

C# Copy Code

protected override void RenderControls( IContext objContext, IResponseWriter objWriter, long lngRequestID)

{

foreach (Movie objMovie in this.Movies)

{

objWriter.WriteStartElement( "Movie");

objWriter.WriteAttributeString( "MediaSource", objMovie.MediaSource.ToString());

objWriter.WriteAttributeString( "Title", objMovie.Title);

objWriter.WriteEndElement();

}

}

In our Main form will change the OnLoad method and add in it 3 movies to our VideoPlayer control.

C# Copy Code

private void Form1_Load( object sender, EventArgs e)

{

Movie objMovie1 = new Movie();

objMovie1.Title = "Movie 1";

objMovie1.MediaSource = new MyResource( "Resources/Data/lake.wmv");

videoPlayer1.Movies.Add(objMovie1);

Movie objMovie2 = new Movie();

objMovie2.Title = "Movie 2";

objMovie2.MediaSource = new MyResource( "Resources/Data/Bear.wmv");

videoPlayer1.Movies.Add(objMovie2);

Movie objMovie3 = new Movie();

objMovie3.Title = "Movie 3";

objMovie3.MediaSource = new MyResource( "Resources/Data/Butterfly.wmv");

videoPlayer1.Movies.Add(objMovie3);

}

In the XML that is rendered the movie collection will look like this. Each movie was rendered as a movie element.

XAML Copy Code

< WC:VideoPlayer.Controls.VideoPlayer Id =" 3" TI =" 1" F =" 1" L =" 51" T =" 89"

H =" 332" W =" 434" A =" LT" >

< Movie MediaSource =" Resources/Data/lake.wmv" Title =" Movie 1" />

< Movie MediaSource =" Resources/Data/Bear.wmv" Title =" Movie 2" />

< Movie MediaSource =" Resources/Data/Butterfly.wmv" Title =" Movie 3" />

</ WC:VideoPlayer.Controls.VideoPlayer >

Now we'll switch to the client side of the control and add to the VideoPlayer.Silverlight.Controls project a new class named VideoPlayerList. The class should inherit from ListBox.

C# Copy Code
public class VideoPlayerList : ListBox

In the constructor we'll set the DisplayMemberPath property to "Title". This will set the Title property of our movie element as the visible text of the ListBoxItem.

C# Copy Code

public VideoPlayerList()

{

this.DisplayMemberPath = "Title";

}

Next we'll add a VideoPlayerListItemDelegate that inherits BindingDelegate. This will allow us to broaden the object state with the properties that we added MediaSource and Title.

C# Copy Code

public class VideoPlayerListItemDelegate : BindingDelegate

{

public VideoPlayerListItemDelegate( ElementState state)

: base(state)

{

}

public Uri MediaSource

{

get

{

return Session.GetResourceUri( this.GetValue( "MediaSource", ""), false);

}

}

public string Title

{

get

{

return this.GetValue( WGAttributes.Title, "");

}

}

protected override void OnAttributeChange( string strAttribute)

{

base.OnAttributeChange(strAttribute);

if (strAttribute == "MediaSource")

{

OnAttributeChange( "MediaSource");

}

else if (strAttribute == WGAttributes.Text)

{

OnAttributeChange( "Title");

}

}

}

We'll override the PrepareContainerForItemOverride method and set the DataContext of our element and set the ListBoxItemStyle as the elements template.

C# Copy Code

protected override void PrepareContainerForItemOverride(System.Windows. DependencyObject element, object item)

{

base.PrepareContainerForItemOverride(element, item);

((ListBoxItem)element).DataContext = new VideoPlayerListItemDelegate(( ElementState)item);

ThemeManager.ApplyTheme(( FrameworkElement)element, "ListBoxItemStyle");

}

In our generic XMAL will add a new row definition this row will be under the control buttons. In that row we'll add a VideoPlayerList element.

XAML Copy Code

< Grid.RowDefinitions >

< RowDefinition Height ="*"></ RowDefinition >

< RowDefinition Height ="35"></ RowDefinition >

< RowDefinition Height ="60"></ RowDefinition >

</ Grid.RowDefinitions >

< local : VideoPlayerList x : Name ="MovieList" Grid.Row ="2" Visibility ="Visible" Foreground ="Black" Background ="White" />

Next we'll add to our client side MoviePlayer control access to the VideoPlayerList element by adding a VideoPlayerList member. We'll attach it to the template element by adding to the OnApplyTemplate method.

C# Copy Code

private VideoPlayerList mobjMovieList;

public override void OnApplyTemplate()

{

base.OnApplyTemplate();

mobjMovieList = this.GetTemplateChild( "MovieList") as VideoPlayerList;

if (mobjMovieList != null)

{

mobjMovieList.SetBinding( ItemsControl.ItemsSourceProperty, new Binding( "Elements"));

mobjMovieList.SelectionChanged += new SelectionChangedEventHandler(mobjMovieList_SelectionChanged);

ThemeManager.ApplyTheme(mobjMovieList, "ListBoxStyle");

}

Now We'll add implementation to the Method that we registered to the on SelectionChange event of the MoviePlayerList control.

C# Copy Code

void mobjMovieList_SelectionChanged( object sender, SelectionChangedEventArgs e)

{

MediaSource = ((VideoPlayerList. VideoPlayerListItemDelegate)(( ElementState)mobjMovieList.SelectedItem).Delegate).MediaSource;

}

the result should look something like this.

What we've seen in this "Who to" is how to take a collection of objects and add it as elements to our data XML file. We've seen how to bind this elements to a control and how to display them in a Silverlight control.


Providing all the necessary assemblies

Visual WebGui Documentation
Providing all the necessary assemblies
Send Feedback

Glossary Item Box

A Visual WebGui application requires three runtime assemblies in order to run properly which are the

  • Gizmox.WebGUI.Common
  • Gizmox.WebGUI.Forms
  • Gizmox.WebGUI.Server

These three assemblies should be present in the project bin directory.

If Silverlight presentation layer is enabled a fourth runtime assembly is needed Gizmox.WebGUI.Server.Silverlight.


a
about
after
against
all
along
also
although
am
among
an
and
are
as
at
be
became
because
been
being
between
but
by
can
caution
come
could
details
did
do
does
doing
done
during
each
early
far
finally
for
found
from
had
has
have
he
her
here
his
how
however
I
if
in
include
including
information
into
is
it
its
late
later
made
many
may
me
med
might
more
most
near
no
non
none
nor
not
note
of
off
on
only
or
other
over
saw
see
seen
several
she
since
so
some
such
than
that
the
their
them
then
there
these
they
this
those
through
tip
to
too
under
until
up
us
use
very
warning
was
we
were
when
where
which
while
who
with
you